Micro Focus Studio Enterprise Edition 6.0

Welcome to Studio Enterprise Edition

  • Getting Started
  • Product Information

What's New

  • New Features in ServicePack 2 WrapPack 2

Featured Sections

  • Developing COBOL Applications
  • Tips and Tricks with the IDE
  • Managed COBOL Reference

Tutorials and Demonstrations

  • Tutorials on COBOL and PL/I in the Visual Studio IDE
  • Demonstrations of .NET COBOL

Online Resources

  • Micro Focus Infocenter
  • Micro Focus SupportLine
  • Micro Focus Product Updates
  • Micro Focus Knowledge Base
  • Micro Focus Community Forums
  • Micro Focus Training Store

Provide Feedback

  • Contacting Micro Focus
  • Email us feedback regarding this Help


Welcome

Studio Enterprise Edition enables you to develop COBOL applications within Microsoft Visual Studio. You use the integrated development environment (IDE) in Visual Studio to edit, compile and debug COBOL applications. The IDE provides all the functionality to manage projects and build applications.

You can develop COBOL applications that run as .NET managed code in the .NET environment. You can also develop and compile applications to native COBOL code, as .exe or .dll. You then deploy and further debug the application under Server Enterprise Edition.

You can develop applications that have been migrated from the mainframe and that use mainframe technologies like CICS, JCL, and IMS. These compile to native COBOL code, as .exe or .dll. You then deploy and further debug the application under Server Enterprise Edition.

.NET managed code and unmanaged native code can interoperate within the same application, enabling you to exploit existing COBOL in the .NET environment.

Server Enterprise Edition is a companion to Studio Enterprise Edition. Server Enterprise Edition provides the run-time environment for running COBOL applications. .NET applications also require the Microsoft .NET Framework to be installed and this is available from the Microsoft Web site.

For help getting started:

  1. To learn about COBOL development using Visual Studio, see the topics in the Visual Studio and COBOL section.
  2. For a list of the various features for editing, building and debugging COBOL provided by the IDE, see Tips and Tricks with the IDE.
  3. For information about the samples and tutorials supplied with this COBOL development system, see Tutorials on COBOL in the Visual Studio IDE, Demonstrations of .NET Managed Code and Samples Browser.
  4. For examples of programming in .NET COBOL and comparison with the C# and VB.NET languages, see COBOL, C#, and VB.NET Comparison.

If you are a mainframe programmer:

We recommend you start with the Getting Started. This will walk you through the major components of the product and will provide you with some basic tutorials on how to use the IDE to develop mainframe applications. The Getting Started includes the following items:

  1. Introduction, which gives an overview of the product and explains the mainframe capabilities.
  2. A basic tutorial, which uses a mainframe application to guide you through using the IDE to develop, build and debug both an online and batch application.
  3. Additional tutorials that show you, for example, how to create and use different mainframe projects that contain CICS, IMS, PL/I and JCL.
  4. A detailed description of the samples available with this product.
  5. An overview of how to move existing mainframe applications into the Visual Studio IDE.
  • New Features
  • Tutorials on COBOL and PL/I in the Visual Studio IDE
  • Demonstrations of .NET COBOL
  • Product Information
  • Licensing
  • Getting Started
  • Help on Help
Parent topic: Micro Focus Studio Enterprise Edition 6.0
Related information
Visual Studio and COBOL
Tips and Tricks with the IDE
Tutorials on COBOL in the Visual Studio IDE
Demonstrations of .NET Managed Code
Tutorial: Developing a Simple COBOL Application
Tutorial: JCL
Tutorial: CICS
Tutorial: IMS


New Features

  • New Features in ServicePack 2 WrapPack 2 - November 2012
  • New Features in ServicePack 2 WrapPack 1 - October 2011
  • New Features in ServicePack 2 - June 2011
  • New Features in ServicePack 1 WrapPack 1 - November 2010
  • New Features in ServicePack 1 - August 2010
  • New Features in 6.0 WrapPack 2 - April 2010
  • New Features in 6.0 WrapPack 1 - February 2010
  • New Features in 6.0 - July 2009
Parent topic: Welcome


New Features in ServicePack 2 WrapPack 2 - November 2012

Studio Enterprise Edition 6.0 ServicePack 2 WrapPack 2 provides the following new features and updates:

  • Enterprise Server
  • HCO for SQL Server (HCOSS)
  • IMS Support
  • OpenESQL
  • Open PL/I
  • strictvsam (Added in HotFix 11 - October 2013)
  • WebSphere Support
Parent topic: New Features


Enterprise Server

Enterprise Server now supports standard ECI calls to Mainframe Subsystem regions. The External Call Interface (ECI) allows non-CICS programs running outside the server to invoke CICS programs within a region opening up access to legacy business logic.

ECI client programs can run on the same machine as the enterprise server and, in this configuration, can communicate across shared memory or through the "Web Services and J2EE" listener. Programs running on different physical hardware submit ECI requests through the listener.

Parent topic: New Features in ServicePack 2 WrapPack 2 - November 2012


HCO for SQL Server (HCOSS)

HCO for SQL Server supports rowset cursors.

Parent topic: New Features in ServicePack 2 WrapPack 2 - November 2012


IMS Support

This release includes the following IMS Support enhancements:
IMS Database Forward Recovery
The IMS Database Forward Recovery feature consists of a set of backup and restore utilities that enable you to restore your IMS database complete with the most recent updates made just before a system or hardware failure.
Parent topic: New Features in ServicePack 2 WrapPack 2 - November 2012


OpenESQL

This release includes the following enhancements:

SQL Compiler Directive Options

OpenESQL has been enhanced to support the following new SQL compiler directive options:

DATE
Controls the reformatting of date values in output parameters and in input parameter character host variables when DETECTDATE is also specified.
TIME
Controls the reformatting of date values in output parameters and in input parameter character host variables when DETECTDATE is also used.
DATEDELIM
Specifies a single character as the delimiter between the year, month, and day components to override the default delimiter determined by the HCOSS DIALECT or DATE directive specification.
TIMEDELIM
Specifies a single character as the delimiter between the hour, minute, and second components to override the default delimiter determined by the HCOSS DIALECT or TIME directive specification.
TSTAMPSEP
Specifies a single character as the separator between the date and time parts of timestamp and date/time data.

SQL Server

We now support Microsoft SQL Server 2012.

Parent topic: New Features in ServicePack 2 WrapPack 2 - November 2012


Open PL/I

This release includes the following enhancements:

  • Support for WCHAR data types and associated built-in function enhancements. See Language Reference Manual for more information.
  • Support for Big-Endian CHAR VARYING on Intel chipsets
  • Support for PLICTF, PLIFILL, PLIMOVE, PLIOVER, VALIDDATE built-in functions
  • Support for the NOINIT and PARAMETER attributes of the DECLARE statement
  • Support for XN (hex) binary fixed-point and numeric literal constants, as well as for punctuating constants
  • New TINY and HUGE built-in functions
  • Support for character picture data types. See Language Reference Manual for more information.
  • Preprocessor for SQL Server (HCOSS)
  • A new PLITEST debugger attach facility
  • Macro preprocessor enhancements that include:
    • Support for multiple closure
    • Support for 100-byte variable names
    • Support for %SELECT,%DO WHILE,SYSVERSION, ||=
    • Support for the –incafter directive which allows you to add an include file without having to modify the customer source.
  • The DB2 LUW precompiler now allows you to specify an userid and a password
  • Integration with Visual Studio 2010
  • Early Adopter support for Oracle through the ODBC interface
Parent topic: New Features in ServicePack 2 WrapPack 2 - November 2012


strictvsam (Added in HotFix 11 - October 2013)

A new run-time tunable has been introduced to enable strict mainframe emulation when processing VSAM files.

When set to ON, file status 37 is returned for an existing VSAM file when opened for OUTPUT if the file has data or previously had data written to it, or if the file is of a different format to the file on disk. When set to OFF, file status 0 is returned and a new file is created when an existing VSAM file is opened for OUTPUT. This tunable is OFF by default.

Parent topic: New Features in ServicePack 2 WrapPack 2 - November 2012
Related information
strictvsam


WebSphere Support

Support has been added for IBM WebSphere 8 Application Server.

Parent topic: New Features in ServicePack 2 WrapPack 2 - November 2012


New Features in ServicePack 2 WrapPack 1 - October 2011

Studio Enterprise Edition 6.0 ServicePack 2 WrapPack 1 provides the following new features and updates:

  • Enhancements in Management Packs for System Center Operations Manager (SCOM)
  • HCO for SQL Server (HCOSS)
  • Open PL/I
  • Update to Visual COBOL 2010 Enterprise Option
Parent topic: New Features


Enhancements in Management Packs for System Center Operations Manager (SCOM)

The following management packs are included to integrate with Microsoft's System Center Operations Manager (SCOM):

  • MicroFocus.Server.Core.Library.mp 6.0.2.0
  • MicroFocus.Server.EnterpriseServer.ManagementPack.mp 6.0.7.0
  • MicroFocus.Server.EnterpriseServer.MTO.ManagementPack.mp 6.0.12.0

Enhancements include checking for failures when opening ports for a TCIPIPSERVICE.

Parent topic: New Features in ServicePack 2 WrapPack 1 - October 2011


HCO for SQL Server (HCOSS)

The following enhancements are available:
Assess Data Migration Tool
This new tool enables you to examine extracted DB2 schemas for the purpose of estimating the table sizes, and to identify the tables you want to migrate to your SQL Server database using HCOSS.
Forward Compatibility
SQL programs that were compiled and bound with Studio Enterprise Edition 6.0 Service Pack 1 Wrap Pack 1, published 30 November 2010, are now forward compatible with all later updates to Studio Enterprise Edition 6.0. That is, SQL programs can be run without being recompiled or re-bound. However, such programs cannot take advantage of improvements made to later versions of HCOSS until you recompile and rebind them. You can do this all at once, or incrementally as part of your regular program maintenance.
SQL programs that were compiled and bound using any of the following earlier versions of Studio Enterprise Edition must be recompiled and rebound before you deploy them to your production environment:
  • Studio Enterprise Edition 6.0
  • Studio Enterprise Edition 6.0 Wrap Pack 1
  • Studio Enterprise Edition 6.0 Wrap Pack 2
  • Studio Enterprise Edition 6.0 Service Pack 1
Log File Management
Several of the HCOSS tools now provide a Log File tab where you can view the contents of the log files generated, and delete the log files of your choice. You can also configure your HCOSS options to automatically delete log files older than a given number of days.
Parent topic: New Features in ServicePack 2 WrapPack 1 - October 2011


Open PL/I

This release provides improved support and integration of Open PL/I. Features include:

  • Improved debugging capabilities for applications under development and running in production which help increase the programmers' productivity during and after migration.
    • Support for the PLIDUMP() facility which generates a callstack and shows all static variables, local variables and API parameters that were in effect at the time of the call to PLIDUMP. Typically, you can use the facility for analysis of application failures while running in production.
    • Support for an enhanced PLITEST API which allows for dynamic attachment of the PL/I Debugger at a point the application programmer specifies. In addition, the PLITEST interface now has the capability of displaying the Codewatch Debugger UI on any platform capable of hosting an X-Windows Server.
  • Generation of ASA Control Characters when writing to PL/I files with the STREAM and PRINT attributes.

    When writing PL/I files that are defined to have the STREAM and PRINT attributes, appropriate control characters are now written to column 1 of the output dataset to represent a new page, skip(1), skip(2), skip(3), and skip(0) (known as overstrike). This helps ease the migration and integration of PL/I applications with existing printing subsystems.

  • Improved emulation of mainframe compiler and run-time system behaviors in the treatment of CONTROLLED storage.

    The Open PL/I applications now allow the passing of unallocated CONTROLLED storage data items from one procedure to another. These variables can then be checked for ALLOCATION() and allocated as appropriate. This facilitates the migration and helps reduce the coding changes to the existing application logic.

Parent topic: New Features in ServicePack 2 WrapPack 1 - October 2011


Update to Visual COBOL 2010 Enterprise Option

Visual COBOL 2010 Enterprise Option delivers functionality for developing and maintaining managed code CICS applications, and for running these applications. It also provides scale-out solution and architecture for the cloud.

Micro Focus Visual COBOL Enterprise Option consists of:

  • The Enterprise Server for .NET runtime environment that you use to run managed code CICS applications.
  • The Enterprise Server for .NET MMC snap-in that you use to configure and administer your managed code CICS environment.
  • A component that allows you to use Microsoft's Visual Studio 2010 to develop and maintain managed code CICS applications.

This release provides enhancements in the following areas:

User Interface

The following features are now available:

  • Dynamic debugging view in the MMC UI - you can enable or disable dynamic debugging for a running region and view all active debugging sessions.
  • An option to rename resources in the CICS resource file editor
  • Context-sensitive help in the MMC UI

When migrating applications, these improvements simplify the deployment and administration of scaled-out regions. Deploying files to a central database location helps minimize the risk of file version conflicts in scaled-out regions.

Improved Mainframe Compatibility

This ensures you need to make fewer changes to the code and so reduces the risk when migrating applications.

  • The following application programmer APIs are now supported or have been enhanced:
    • SEND TEXT has been enhanced
    • POP HANDLE
    • PUSH HANDLE
    • SEND PAGE
    • PURGE MESSAGE
    • GETMAIN has been enhanced
    • WRITE OPERATOR has been enhanced
  • The following system programmer APIs are now supported or have been enhanced:
    • INQUIRE TASK LIST has been enhanced
    • INQUIRE TASK
    • INQUIRE TERMINAL
    • INQUIRE SYSTEM

Support for Windows Azure

You can now deploy CICS systems as Windows Azure hosted services and exploit the benefits of the Windows Azure platform. The original code defining existing online business processes is reused so applications behave just as they did on the mainframe.

You use the MMC UI to administer the CICS systems from on-premise machines.

Parent topic: New Features in ServicePack 2 WrapPack 1 - October 2011


New Features in ServicePack 2 - June 2011

Studio Enterprise Edition 6.0 ServicePack 2 provides the following new features and updates:

  • Assembler Support
  • CICS Web Interface
  • Enterprise Server
  • Mainframe Access Client Capabilities
  • Open PL/I
  • Service Interfaces
  • HCO for SQL Server (HCOSS)
  • Update to Visual COBOL 2010 Enterprise Option
Parent topic: New Features


Assembler Support

Support for IBM® High Level Assembler (HLA) has been added to Studio Enterprise Edition and Studio Enterprise Edition Test Server.

Important: This capability is NOT supported in production. It is only supported within development and testing environments.

When migrating applications, COBOL or PL/I programs which call Assembler programs can be demonstrated running on Windows before the Assembler programs have to be converted. This can be instrumental in proof of value exercises that must be undertaken before any investment in the conversion of the Assembler is approved.

When rehosting testing workload to Windows, HLA enables comprehensive testing of mainframe applications that contain 370 Assembler on low-cost Windows environments rather than having to utilize expensive mainframe MIPS.

Features include:

  • The IBM High Level Assembler available from the product command line
  • Assembler linker capable of generating assembler data tables or executable code added
  • COBOL run-time loader modified to load and execute assembler executables
  • Assembler files can now be added to Visual Studio projects and be edited, assembled and linked using the Visual Studio 2008 IDE
  • Assembler programs can now be executed for testing purposes within the Studio Enterprise Edition and Studio Enterprise Edition Test Server environments.
Parent topic: New Features in ServicePack 2 - June 2011
Related information
Assembler Support


CICS Web Interface

This release provides support for CICS™ as an HTTP client consuming HTTP content from Web servers. This enables you to write CICS™ applications that can:

  • Use a common protocol for business-to-business communications
  • Control hardware (like printers) or software using the HTTP protocol
  • Access HTTP applications that provide items of information (like share prices) and retrieve this information for use in the application.
Parent topic: New Features in ServicePack 2 - June 2011


Enterprise Server

The following enhancements are available:

LDAP password management improvements
LDAP password management has been improved. When migrating applications this helps customers meet security audit compliance requirements. The following features are now available:
  • Recording last login time when a user is verified
  • Keeping a configurable password history and rejecting a password change if the Password matches one in the history
  • Lock out after a configurable number of consecutive failed logins
CICS Support
Improvements are available in the following areas:
CICS Web Interface (CWI)
Offers an additional CICS Web Interface (CWI) support to include DOCUMENT and EXTRACT TCPIP CICS APIs and to provide support for or CICS as an HTTP client.
Support is provided for the following APIs as well as for the associated resources and infrastructure:
  • CREATE DOCTEMPLATE
  • INQUIRE DOCTEMPLATE
  • DOCUMENT DELETE
  • DISCARD DOCTEMPLATE
  • DOCUMENT INSERT
  • DOCUMENT RETRIEVE
  • DOCUMENT SET
  • EXTRACT TCIPIP
During application migration, CICS applications using these specific CWI API can be migrated without change to the existing CWI logic.
Support for CICS as an HTTP client provides a common gateway for business to business communications whether this be controlling hardware or software applications or, posting and retrieving data through the HTTP protocol. This ensures that CICS applications that act as consumers of HTTP content from Web Servers can now be migrated.
Support for EXEC CICS INQUIRE REQID
Initial support for EXEC CICS INQUIRE REQID has been added. This API provides a mechanism for querying information about a queued request and returns the INTERVAL value - the time remaining until the request expires.
The feature also provides improved control over queued requests by providing a way for an application to access information about queued requests such as START TRANSID(...).
During migration, this feature enables applications which make heavy use of this API to be migrated without the need of finding alternative means to provide existing behavior.
When rehosting testing workload to Windows, the feature ensures that applications that use this API can be tested without change to source code or application behavior.
Two-Phase Commit
The CICS Inter-System Communications (ISC) support within Server Enterprise Edition has been improved to support 2-Phase Commit communications flows using various third-party UNIX APPC communications products. When migrating applications, this improves transactional data integrity between CICS applications on UNIX and CICS applications that continue to reside on z/OS.
  • Enterprise Server "Sys62" connections to a remote peer now support the standard communications flows required for 2-Phase Commit support.
  • Uses IBM Communications Server (on AIX, Red Hat and SuSE SLES - excluding IA64), HP SNAPlus2 (on HP/UX) and Metaswitch SNAP-IX (on Solaris) to enable Enterprise Server to take part as a peer in distributed Sync Level 2 Sync Point processing conversations.
JCL Support
Improved VSE and MVS JCL support within Studio and Server Enterprise Edition products.

When migrating applications, the new VSE features mean that a migration to a Server Enterprise Edition platform requires fewer changes to the original host JCL making it quicker and easier to migrate. SMS managed GDGs scratch processing now mimics latest mainframe release behavior avoiding unexpected results during the migration process which can be very difficult to track down.

When rehosting testing workload to Windows, the new VSE features ensure that host JCL can be executed with minimal change on Test Server and SMS managed GDGs scratch processing now emulates the latest mainframe release behavior when running in test.

The enhancements include:
  • Internal reader support for VSE JCL
  • Support for multiple logical files within a single in-stream dataset (VSE JCL)
  • User exit for POWER statements (VSE JCL)
  • Allow in-stream data to be included via SLI INCLUDE statements. (VSE JCL)
  • Improved JESYSMSG layout for VSE (previously it was very difficult to read)
  • GDG scratch processing at step end
IMS Support
Batch backout support has been added for IMS batch applications running in Enterprise Server. This provides the ability to recover database changes made by IMS batch applications (DLI and DB) to a point before a program was initiated or to a checkpoint.
This improvement ensures that when migrating applications:
  • Database changes made by a failed batch IMS applications when running in Enterprise Server can now be recovered.
  • Provides increased compatibility with IMS applications running on the mainframe and reduces effort and risk when migrating such applications.
Historical Statistical Facility (HSF)
This release provides a new Historical Statistics Facility (HSF) that enables you to gather statistical information about transaction execution within the Server Enterprise Edition environment.
When migrating applications, it enables system administrators to identify poorly performing transactions. It also provides statistics for quantifying the time taken for execution of a given transaction which can be utilized to fulfill common accounting and costing requirements off the mainframe.
Historical timing statistics are generated for Enterprise Server transactions. Statistics can be written to a .CSV file format and a limited number of records can also be held in memory for viewing through ESMAC. The statistics generated include information about:
  • The type of task (CICS, IMS. JCL, Web Service, CGI)
  • Task number and start time
  • Transaction ID/Program name and user who initiated it
  • Latency and response times
  • Files accessed, duration and number of occurrences
  • Time spent in SQL and CICS API
Batch backout support for IMS batch applications
This release includes a batch backout utility for IMS batch applications running in Enterprise Server which ensures an increased compatibility with mainframe IMS. The utility enables you to recover database changes made by IMS batch applications (DLI and DBB) to a point before a program was initiated or to a checkpoint.
Parent topic: New Features in ServicePack 2 - June 2011
Related information
Collecting Information about Transactions


Mainframe Access Client Capabilities

Mainframe Access (MFA) client capabilities have been added to Studio Enterprise Edition and Studio Enterprise Edition Test Server.

When migrating applications, this ensures source and data can be transferred from the mainframe and projects can be setup more efficiently within theStudio Enterprise Edition environment to make it easier to demonstrate rapid progress to key stake holders. Once projects are set up, the synchronization with mainframe artifacts can be automated to deliver significant gains in efficiency.

When rehosting testing workload to Windows, this provides:

  • Seamless but secure access to mainframe application source code and data simplifies set up and deployment of the Test Server platform.
  • Significantly increases the breadth of applications that can be tested within the Studio Enterprise Edition Test Server environment as jobs, programs and utilities that cannot be rehosted to Windows can be remotely accessed on the mainframe.
  • Allows source synchronization with mainframe source control systems. Test Server can then be configured to automatically compile changes as they are checked into source libraries. This provides early exposure to test teams performing smoke or regression testing.
  • Data can continue to reside on the mainframe. COBOL programs running under Test Server can directly access mainframe files. This not only allows multiple test levels against different subsets of data, it means that sensitive or archive data can remain in position.

Features Include:

  • Mainframe Drag & Drop to enable mainframe source and data artifacts to be dragged from mainframe and dropped into Studio EE projects
  • MFA Synchronisation and Control Monitor (aka "Syncmon") – synchronises selected source components between mainframe hosted source and a Windows development or test environment
  • Automatic Synchronise and Compile to automatically compile modules after source code synchronisation.
  • Remote Job (JCL) Step Execution to enable execution of jobs on mainframe that cannot be rehosted to Windows
  • Mainframe Call Generator – enables remote execution of mainframe programs that cannot be re-hosted to Windows.
  • SourceConnect – allows direct access to source hosted on mainframe.
  • DataConnect – allows COBOL file access to data files hosted on mainframe.
Parent topic: New Features in ServicePack 2 - June 2011


Open PL/I

This release provides enhancements in the following areas:

  • Integration with Microsoft's Visual Studio 2008

    This release includes enhanced integration of the Open PL/I Compiler, Debugger and Run Time System (RTS) into the Visual Studio 2008 IDE. When migrating applications, this improves the productivity for PL/I programmers post migration so they can deliver updates faster than previously possible on the mainframe.

    Enhancements include:

    • PL/I Project Types which allow for creation of .EXE(s), .DLL(s), and user application programs (.DLLs) targeted for the Server Enterprise Edition JCL, CICS, and IMS rehosting environment
    • Source Colorizing
    • User Customizable Templates
    • Compile, link and debug using the Open PL/I Debugger from the Visual Studio IDE
  • CICS-based Open PL/I applications

    This release includes an enhanced support for Open PL/I applications that utilize CICS within Enterprise Server. Ability to migrate mainframe CICS PL/I applications to lower cost Windows, UNIX or Linux platforms while keeping PL/I and EXEC CICS code intact to minimize application updates, simplify migration and mitigate risk.

    Features include:

    • A new PL/I CICS preprocessor
    • Enhanced source level debugging
    • PL/I RTS support for CICS applications
  • OpenESQL for PL/I

    Support for Microsoft SQL Server within Open PL/I included within Micro Focus Studio Enterprise Edition and Server Enterprise Edition is available as an early adopter release. This provides the option to select Microsoft SQL Server as the target database when migrating PL/I applications that utilize DB2.

    • The mature OpenESQL technologyMicro Focus has supported for many years for its COBOL customers, is now available for use with PL/I applications. This means PL/I SQL can now execute against popular relational databases like Microsoft SQL Server even though a SQL preprocessor for PL/I is not available from the database vendor.
    • This support is classified as "Preview". It has been successfully tested by Micro Focus development but this functionality has had limited exposure to different customer environments.
  • New language and run-time level support for PL/I Dynamic calls

    Support for PL/I Dynamic Calls (FETCH/RELEASE) has been added. This provides greater efficiency during migration and less risk as applications using dynamic calls can be rehosted without significant changes to application logic.

  • Open PL/I DB2 LUW Preprocessor

    The Open PL/I DB2 LUW Preprocessor now supports ROWID, BLOB and CLOB which widens the breadth of applications that can be rehosted. Without this support, applications using such features would not be considered as candidates for migration due to the significant reengineering that would be required.

  • Language compatibility with IBM's z/OS based PL/I Compiler

    The language compatibility with IBM's z/OS based PL/I Compiler has been improved. Applications that use these IBM mainframe PL/I language features no longer need code modification to function in the same manner using Open PL/I. This reduces risk while accelerating migration of such programs.

    Support for the following new language elements has been added:

    • Variable names up to 100 bytes (*)
    • Support for user written PLIDUMP routines (*)
    • Support for STDCALL linkage on Intel Platforms (*)
    • Support of named constants using the VALUE attribute (*)
    • Compound assignment operators +=, -=, /=, |=, ||=, *=, **= (*)
    • Support for optional parameters to the INDEX built-in function.

    Support for the following new BUILTIN functions has been added:

    • ADDRDATA (*)
    • CENTERLEFT/CENTRELEFT, CENTERRIGHT/CENTRERIGHT (*)
    • FILEOPEN, FILEDDINT, FILEDDWORD (*)
    • HEX
    • LEFT. LOWERCASE (*)
    • MAXLENGTH
    • PACKAGENAME, PROCEDURENAME (*)
    • RANDOM, REVERSE, RIGHT (*)
    • SEARCH, SEARCHR (*)
    • TALLY (*)
    • UPPERCASE (*)
    • Use of the DIM built in function to size static arrays.
    • STRING built in function enhanced to allow for CHAR VARYING structure elements.
Parent topic: New Features in ServicePack 2 - June 2011
Related information
PL/I Programming


Service Interfaces

This release provides the following improvements:

Workflow Capture
The Workflow Capture functionality from Net Express has been added to the Interface Mapping Toolset running under Visual Studio 2008. Service interface operations can be created based on a recording (capturing) of the CICS or the IMS application flow. This simplifies the creation of service interfaces for CICS or IMS applications that contain moderate to large number of screens when modernizing post migration.
You can display a graph showing the screens that were captured as well as the flow between the screens.
WPF clients for testing service interfaces
Users now have a choice of generating WPF, Windows Forms or ASPX .NET test clients for service interfaces during the modernization process.
Parent topic: New Features in ServicePack 2 - June 2011
Related information
Service Interfaces


HCO for SQL Server (HCOSS)

HCOSS makes it simple to migrate both COBOL code and data from mainframe DB2 to SQL Server. In addition to the host compatibility features, HCOSS also provides assessment capability to analyze your COBOL code, and identify every SQL statement that would require amendments with and without the use of HCOSS when updating applications to operate against SQL Server. The assessment tool clearly identifies problematic COBOL SQL code so customers can get early idea of what needs to change and potential costs

This release provides the following improvements:

  • Usability enhancements to Assessment Tool and various Data and Code Migration Tools
  • Support for dynamic SQL
  • Support for additional mainframe DB2 syntax including:
    • Cascading Deletes
    • Case expressions
    • Date/Time directive
    • DECLARED global temporary tables
    • DYNAMiCRULES BIND option
    • OLAP (Online Analytical Processing) specifications
    • Result Set Processing for Stored Procedures
    • XML functions
  • Trusted Connection XA switch module for DB2.LUW
  • Plan Name Support in JCL
  • Support for SQLClient, .NET Data provider for SQL Server 2008 to enable COBOL/CICS applications running as managed code under the .NET framework to take advantage of all the capabilities HCOSS provides
  • Enhanced connection editor experience for .NET platforms
Parent topic: New Features in ServicePack 2 - June 2011
Related information
HCO for SQL Server (HCOSS)


Update to Visual COBOL 2010 Enterprise Option

Visual COBOL 2010 Enterprise Option delivers functionality for developing and maintaining managed code CICS applications, and for running these applications. It also provides scale out solution and architecture for the cloud

Micro Focus Visual COBOL Enterprise Option consists of:

  • The Enterprise Server for .NET runtime environment that you use to run managed code CICS applications.
  • The Enterprise Server for .NET MMC snap-in that you use to configure and administer your managed code CICS environment.
  • A component that allows you to use Microsoft Visual Studio 2010 to develop and maintain managed code CICS applications.

This release provides improvements in the following areas:

User Interface
The following enhancements are available:
  • Copy/Paste support. Multiple nodes can now be selected.
  • Non-administrators are now able to run the MMC UI.
  • Ability to create, edit and delete resource definition files residing in the cross-region database.
  • Transaction programs and BMS maps can now be deployed to the cross-region and/or custom database from the MMC UI. Previously this could only be achieved by using the seedeploy command-line tool.
  • Regions can now be started and stopped on a remote machine. Previously regions could only be started and stopped on the same machine that the MMC UI, or seestart command-line tool, was running on.
  • Region startup and resource definition files can now be deployed to the cross-region database. These files can be edited in situ using the MMC UI's configuration file editors
  • Cmdlets are provided to allow CICS regions to be started, stopped and monitored with PowerShell scripts.
  • seeupgrade utility introduced to allow the upgrading of region startup and resource definition files to the current product release level.
When migrating applications, these improvements simplify the deployment and administration of scaled-out regions. Deploying files to a central database location helps minimize the risk of file version conflicts in scaled-out regions.
Security
CICS applications can now run under the identity of the signed-on Windows user. As the OS controls access to system resources, some application actions, such as direct (COBOL or system API) file access, will be restricted by the privileges of the signed-on user. Support for single-signon to regions scaled out across multiple machines. Two mechanisms are provided to support this functionality: protocol transition (PT) and credential passing (CP).
When migrating applications, you can use Windows security to control access to system resources to further improve the overall system security.
Improved mainframe compatibility
This ensures you need to make fewer changes to the code and so less risk when migrating applications.
  • The following system programmer APIs are now supported or have been enhanced:
    • INQUIRE PROGRAM (enhanced support)
    • INQUIRE TRANSACTION (new)
    • SET PROGRAM (enhanced support)
    • SET TRANSACTION (new)
  • Supplied transactions:
    • CINS (new) - has the same functional level as native Enterprise Server
    • CPMT has been updated to the same functional level as native Enterprise Server
  • The verbosity level of messages written to the system consoled can now be configured. This provides similar functionality to the CICS MSGLVL system initialisation parameter found on the mainframe.
  • PPT entries are now used to determine whether BMS maps are resident or non-resident. Previously all maps were considered to be resident.
Deployment
  • Application binaries can now be deployed to the cross-region database.
  • Resource definition files can now be deployed to the cross-region database.
System Center Operations Manager (SCOM) integration
A management pack is provided that allows CICS regions to be discovered, and their current state (such as "stopped" or "started"), active SEP pools and running transactions to be monitored.
When Migrating applications, you can use SCOM to monitor the health and state of .NET managed code CICS regions.

See the Visual COBOL 2010 Enterprise Option help for more.

Parent topic: New Features in ServicePack 2 - June 2011


New Features in ServicePack 1 WrapPack 1 - November 2010

Studio Enterprise Edition 6.0 ServicePack 1 WrapPack 1 provides the following new features and updates:

  • Assembler Support
  • CICS Web Interface
  • Host Compatibility Option (HCO) for Microsoft SQL Server
  • JBoss Support
  • LDAP-based Enterprise Server Security
  • OpenESQL
  • Open PL/I
Parent topic: New Features


Assembler Support

Studio Enterprise Edition now provides the IBM® High Level Assembler capability on 32-bit Windows machines. The feature enables you to generate Assembler data tables needed by the COBOL applications and execute critical Assembler subroutines in Studio Enterprise Edition which removes the need to rewrite them in COBOL.

Note: Assembler is available only for development and testing purposes and offers no production support.

The IBM® High Level Assembler is available from the COBOL command line and includes the following:

  • Assembler linker capable of generating Assembler data tables or executable code.
  • COBOL runtime loader modified to load and execute Assembler executable modules.
Parent topic: New Features in ServicePack 1 WrapPack 1 - November 2010


CICS Web Interface

The CICS Web Interface implementation has been enhanced by an extended CICS™ support which includes DOCUMENT and EXTRACT TCPIP CICS™ APIs. The support provided by the DOCUMENT API allows for the rapid development of Web-based CICS™ applications. The support provided by the EXTRACT TCPIP API allows TCP-aware applications to identify the IP address and host name of the client whose request is being processed.

Support as well as associated resources and infrastructure is provided for the following APIs:

  • INQUIRE DOCTEMPLATE
  • SET DOCTEMPLATE
  • DOCUMENT CREATE
  • DOCUMENT DELETE
  • DOCUMENT INSERT
  • DOCUMENT RETRIEVE
  • DOCUMENT SET
  • EXTRACT TCPIP CICS

The following APIs are not supported:

  • CREATE DOCTEMPLATE
  • DISCARD DOCTEMPLATE
Parent topic: New Features in ServicePack 1 WrapPack 1 - November 2010


Host Compatibility Option (HCO) for Microsoft SQL Server

HCOSS makes it simple to migrate both COBOL code and data from mainframe DB2 to SQL Server. In addition, HCOSS offers an assessment tool which tells you precisely where the problem areas of code migration are, and how HCOSS can fix these problems for you.

This release provides the following improvements:

  • Complete support for System.Data.SqlClient, the .NET Framework Data Provider for SQL Server 2008.
  • Usability enhancements to the Assessment Tool; various Data and Code Migration Tools.
  • Support for dynamic SQL.
  • Support for additional mainframe DB2 syntax which includes:
    • XMLCAST specification
    • Case expressions
    • Date/Time directive
    • OLAP (Online Analytical Processing) specifications
  • Assessment Tool clearly identifies problematic COBOL SQL code for migration effort.
  • HCOSS now caters for over 85% of the most commonly used mainframe DB2 SQL that would otherwise require code changes when migrating to SQL Server. In this way, HCOSS dramatically drives down costs and risks when migrating DB2 applications to Windows and SQL Server.
  • Earlier time to market to ensure cost savings can be realized when expected.
Parent topic: New Features in ServicePack 1 WrapPack 1 - November 2010


JBoss Support

Support for JBoss 5 has been added.

Parent topic: New Features in ServicePack 1 WrapPack 1 - November 2010


LDAP-based Enterprise Server Security

Several new features have been added for LDAP-based Enterprise Server security:

  • Options for recording the last user signon time.
  • Configurable password history and password change rejection if the password matches one in the history.
  • Automatic lockout after a configurable number of consecutive failed signons.
  • Minimum and maximum password lengths.

See the documentation for the MLDAP ESM Module for more information. Note that existing installations will need to update their LDAP schema to take advantage of these new features.

Parent topic: New Features in ServicePack 1 WrapPack 1 - November 2010


OpenESQL

Starting with this release of Studio Enterprise Edition, OpenESQL now requires that you set a default behavior for your OpenESQL applications.

When compiling from outside of the Visual Studio IDE (e.g., from a command prompt), if you have not set a default behavior, OpenESQL now issues the following error:

"Please run OpenESQL Configuration Utility to set default behavior"

This error persists until you have set a default behavior using the OpenESQL Configuration utility.

When compiling from the Visual Studio IDE, if you have not set a default behavior, OpenESQL now automatically invokes the UI implementation of the OpenESQL Configuration utility. You must set a default behavior via this utility before compilation can continue.

Parent topic: New Features in ServicePack 1 WrapPack 1 - November 2010
Related information
OpenESQL Config Utility


Open PL/I

The following improvements are available:

  • Support for Open PL/I applications that utilize CICS within Enterprise Server. This provides the ability to re-host mainframe PL/I applications to lower cost Windows, UNIX or Linux platforms while keeping PL/I code intact to minimize risk.

    Features include:

    • A new PL/I CICS precompiler.
    • Enhanced source level debugging.
    • PL/I RTS support for CICS applications.
  • The Open PL/I Compiler, Debugger and RTS are now integrated into Microsoft's Visual Studio 2008 IDE.

    Features include:

    • PL/I project types which enable you to create .exe, .dll, and user application programs (.dll's) targeted for the Enterprise Server JCL, CICS, and IMS migration platform.
    • Source colorizing.
    • User customizable templates.
    • Compile, link and debug (using the Open PL/I Debugger) from the Visual Studio IDE.
  • Improved language compatibility with IBM's z/OS based PL/I Compiler ensures faster migration of z/OS based applications to distributed platforms with reduced risk. Features include:

    Support for new language elements:

    • Variable names up to 100 bytes in length.
    • Support for user written PLIDUMP routines.
    • Support for STDCALL linkage on Intel platforms.
    • Support of named constants using the VALUE attribute.
    • Compound assignment operators: +=, -=, /=, |=, ||=, *=, **=.

    Support for new built-in functions:

    • ADDRDATA
    • CENTERLEFT/CENTRELEFT
    • CENTERRIGHT/CENTRERIGHT
    • FILEOPEN
    • FILEDDINT
    • FILEDDWORD
    • HEX
    • LEFT
    • LOWERCASE
    • MAXLENGTH
    • PACKAGENAME
    • PROCEDURENAME
    • RANDOM
    • REVERSE
    • RIGHT
    • SEARCH
    • SEARCHR
    • TALLY
    • UPPERCASE

    The INDEX built-in function is now supported with a third optional argument.

  • New format of compiler diagnostic messages.
Parent topic: New Features in ServicePack 1 WrapPack 1 - November 2010


New Features in ServicePack 1 - August 2010

Studio Enterprise Edition 6.0 ServicePack 1 provides the following new features and updates:

  • CICS Web Interface
  • Host Compatibility Option (HCO) for Microsoft SQL Server
  • Open PL/I
  • Service Interfaces
  • Enhancements in Management Packs for System Center Operations Manager (SCOM)
  • XDB
Parent topic: New Features


CICS Web Interface

The CICS Web Interface (CWI) is now provided. This is a collection of CICS services that enable a CICS region to act as an HTTP server. When CICS is an HTTP server, a Web client can send an HTTP request to CICS and receive a response. The response can be a static response created by CICS from an HTML file, or an application-generated response created dynamically by a user application program.

Parent topic: New Features in ServicePack 1 - August 2010


Host Compatibility Option (HCO) for Microsoft SQL Server

HCO provides the following improvements:

  • New assessment tool that clearly identifies problematic COBOL SQL code and helps you estimate the migration effort. The tool identifies the mainframe SQL that will work or will not work with SQL Server. In addition, the tool reports the mainframe DB/2 specific SQL that HCOSS supports against SQL Server.
  • New GUI Bind Tool that provides a simple, easy-to-use interface for binding SQL Server packages and plans.
Parent topic: New Features in ServicePack 1 - August 2010


Open PL/I

The following improvements to Open PL/I are available:

  • Support for IMS/DB and IMS/TM applications - Open PL/I now supports the PLITDLI and PLIHSSR interfaces. Customers who wish to migrate their PL/I Online or Batch applications that utilize IMS can now run them on Enterprise Server.
  • An early release of a New Open PL/I Debugger User Interface is available. It has been designed to streamline debugging tasks and has a host of usability improvements such as persistent break points, watch lists, etc. The new debugger user interface is written in Java and available in early adopter form in this release. It will eventually supplant the cwgui interface based on the deprecated Allegris Foundation Class libraries.
  • Improved compatibility with z/OS extensions to the PL/I Language - Ensures fewer changes are required when migrating an application to run under Enterprise Server. The following features are supported:
    • ADDRDATA built-in function
    • ADDRNAME built-in function
    • PROCEDURENAME built-in function
    • The VALUE clause of a variable declaration
    • Big Endian FIXED BIN data types when running on Little Endian Architectures
    • "Host Variables" declared outside of an EXEC SQL DECLARE section
    • "Host Structures" within our DB2 LUW precompiler
    • Variable names longer than 31 bytes
    • User-written PLIDUMP functionality
    • Up to 64 keys in internal sorts using character, packed, binary and float key types
    • Use of RECSIZE(N) in file declarations where N is a fixed binary number
    • += and +|| shorthand operators
    • DB2 LUW 8.1 - 9.5 Clients
    • Restricted expression evaluation in static initializers when using the built-ins SIZE(), LENGTH(), STORAGE() and PROCEDURENAME()
Note: You can access the Open PL/I features from the Net Express command prompt.
Parent topic: New Features in ServicePack 1 - August 2010
Related information
PL/I Programming


Service Interfaces

Integration of the Interface Mapping Toolset with the Visual Studio 2008 IDE is provided.

Features include:

  • Seamless integration with the Visual Studio IDE - Enables you to extend and modernize the COBOL applications developed in Visual Studio from within the same IDE.
  • An ability to create and maintain Service Interfaces for COBOL programs, CICS screen-based and COMMAREA programs and IMS screen programs using the Visual Studio 2008 IDE.
Note: Default mappings for COBOL program Service Interfaces created in Visual Studio will result in only input mappings being created. The behavior for default mappings created with the Interface Mapping Toolkit in Net Express has not changed.
Parent topic: New Features in ServicePack 1 - August 2010


Enhancements in Management Packs for System Center Operations Manager (SCOM)

The following management packs are included to integrate with Microsoft's System Center Operations Manager (SCOM):

  • MicroFocus.Server.Core.Library.mp 6.0.2.0
  • MicroFocus.Server.EnterpriseServer.ManagementPack.mp 6.0.6.0
  • MicroFocus.Server.EnterpriseServer.MTO.ManagementPack.mp 6.0.12.0
Monitoring enhancements include:
  • Time threshold for IMS transactions - IMS transactions can now be configured with a time threshold - locally in the transaction definition or at a system level in Transaction Manager configuration dialog. Whenever a transaction exceeds it threshold, a message is logged to the console. This indicates if a transaction is performing slower than expected and helps identify potential problems quickly.

    The following messages are monitored:

    • CASKC6005I (Transaction exceeded its threshold)
    • CASIP0026I (Transaction completed but exceeded its threshold)
  • IMS time threshold monitor - the SCOM management packs include a new monitor for detecting transactions that exceed their thresholds. This indicates if a transaction is performing slower than expected and helps identify potential problems quickly. An alert is raised in SCOM.
  • CICS, JES, and IMS instance names now reflect the region name.
  • The Transactions aggregate monitor changes from 'Internal' accessibility to 'Public'. This allows for the creation of additional child monitors using custom management packs.
Parent topic: New Features in ServicePack 1 - August 2010


XDB

Studio Enterprise Edition 6.0 ServicePack 1 now provides support for XDB in Visual Studio 2008. XDB is a development-only environment that provides mainframe DB/2 compatibility on Windows for both mainframe DB2 data and COBOL programs. XDB is the easiest way to move mainframe DB2 applications and their corresponding data from the mainframe to the Windows environment. It can serve as an initial step in the migration efforts that lead to deployment implementation for the DBMS vendor of choice.

Features include:

  • Tooling for moving data from Mainframe DB2 to Windows.
  • DB2v8 COBOL processing environment for mainframe DB2 application programs.
  • Initial DB2 9 COBOL processing environment for mainframe DB2 application programs.
  • DBMS tooling that facilitates the migration of your mainframe DB2 environment.
Parent topic: New Features in ServicePack 1 - August 2010


New Features in 6.0 WrapPack 2 - April 2010

Studio Enterprise Edition 6.0 WrapPack 2 provides the following new features:

  • Enhancements in Management Packs for System Center Operations Manager
  • GDG Limit Change
  • Host Compatibility Option (HCO) for Microsoft SQL Server
  • Modernization Workbench v3.1
  • Open PL/I
  • Spool File Format Change
  • Tutorials
Parent topic: New Features


Enhancements in Management Packs for System Center Operations Manager

The following management packs are included to integrate Server Enterprise Edition with Microsoft's System Center Operations Manager (SCOM):

  • MicroFocus.Server.Core.Library.mp 6.0.2.0
  • MicroFocus.Server.EnterpriseServer.ManagementPack.mp 6.0.5.0
  • MicroFocus.Server.EnterpriseServer.MTO.ManagementPack.mp 6.0.5.0

Monitoring enhancements include:

  • The "Transactions" monitor now targets CICS rather than MicroFocus.Server.EnterpriseServer, and includes the "Transaction ABENDs" monitor, which checks for System, Timeout, and User transaction abends.
  • You can now configure PCT entries with an expected maximum duration. When a transaction exceeds its threshold, a console message will be logged."

    The management packs include a new "Transaction Thresholds" monitor which detects transactions that have exceeded their time threshold.

  • "JES Time Threshold" is a new monitor and checks for a job exceeding its TIME threshold.
  • The "Resources" monitor now also checks for file access errors.

In addition, a new SCOM Task enables you to open a browser in the ESMAC SEP view for a selected server. The Launch MFDS task has been renamed to View Enterprise Server Administration Page.

Parent topic: New Features in 6.0 WrapPack 2 - April 2010


GDG Limit Change

Server Enterprise Edition 6.0 WrapPack 2, and subsequent software releases change the GDG-LIMIT value for Generation Datasets.

After you install the WrapPack or new software releases that include this change, the GDG-LIMIT value conversion is handled automatically. The GDG-LIMIT values are changed over time from the old pic 99 format to the new comp field, as individual catalog records are accessed and updated.

However, if you revert to a previous release, the new-format System Catalog is not readable by the old version of the product. If you revert to a previous release, you can revert the System Catalog so that the system can use it.

To revert the catalog to GDG_LIMIT 99:

  1. Backup your system catalog.
  2. Run the catalog scan utility mfcatrvt with no parameters.

    This identifies all GDGs where the LIMIT is greater than 99, or has been cycled more than 99 times.

  3. Run the catalog revert utility mfcatrvt with the command line parameter REVERT.

    This changes the comp value of the GDG-LIMIT field back to the original PIC 99 representation. Note that the process also converts values greater than 99 back to 99.

When this process completes, the System catalog is readable in older versions of Server Enterprise Edition.

Parent topic: New Features in 6.0 WrapPack 2 - April 2010


Host Compatibility Option (HCO) for Microsoft SQL Server

HCO has been updated to make it easier to migrate data from DB2 to SQL Server and provides middleware technology to minimize the changes required to COBOL application code when re-hosting the applications. HCO removes much of the risk related to migrating batch or online COBOL/DB2 applications to Windows and SQL Server. It ensures earlier time to market to ensure cost savings can be realized when expected.

The following improvements are available:

  • New GUI tools to help assess the migration effort from Mainframe DB/2 to SQL Server, and ease specific database function mappings.
  • Better error processing support so that SQL Server mimics mainframe DB/2 behavior.
  • New HCO for SQL Server Visual Studio templates to ease SQL Server compilation and execution.
  • New DATE and TIME directives to support standard mainframe DB2 date/time formats with SQL Server.
  • Additional support for BIND utility with JCL.
  • Provided additional support for Mainframe DB/2 scalar functions and label duration processing.
Parent topic: New Features in 6.0 WrapPack 2 - April 2010


Modernization Workbench v3.1

Modernization Workbench v3.1 includes the following improvements:

  • Single Platform for Managers - provides the only business-centric solution for measuring and managing the application portfolio. Its integrated Enterprise View module delivers browser-based dashboards that help prioritize development projects via metrics like application cost, complexity, value, and risk.
  • Single Platform for Assessments - provides the richest technical information about your applications. Powerful queries, visualizations, and specialized assessment tools, including for platform migrations, are available.
  • Expanded Language Coverage - provides deep and now even broader language coverage. This new release expands its coverage of Java, JEE, additional job schedulers, and more.
  • Mass Change Activities - dramatically accelerates the execution of projects that require numerous changes to application code - for instance, to adhere to regulatory requirements like ICD-10.
  • Major Relational Database Support - adds support for Microsoft SQL Server, ensuring that all three major relational databases are supported (adding to existing support for Oracle RDBMS and IBM DB2).
Parent topic: New Features in 6.0 WrapPack 2 - April 2010


Open PL/I

The Micro Focus Open PL/I Compiler, Debugger and Runtime are being introduced into the Studio Enterprise Edition and Server Enterprise Edition products to enable Micro Focus to offer a comprehensive, low-risk migration solution for mainframe Pl/I applications. Additional support and integration points will be provided with each incremental release of the Studio Enterprise Edition and Server Enterprise Edition products. If you would like to learn more details about what support will be available in the future and participate in the relevant Early Adopter program, please, send an email to eap@microfocus.com.

Features include:

  • Shared Filehandling between Micro Focus COBOL and Open PL/I - Open PL/I enables you to use the same filehandler as used by the Micro Focus COBOL products. It's primary advantage is that it provides support for Indexed files and the ability to execute PL/I programs under the control of Enterprise Server JCL.
  • DB2 UDB Precompiler - A DB2 UDB Precompiler is now available on all platforms for Open PL/I. This feature allows you to migrate applications which contain EXEC SQL logic.
  • Enhanced support for the PLISRTx routines to now support data types of ZD, PD, FI, BI, and FL.
  • Improved support for large PL/I programs.
Parent topic: New Features in 6.0 WrapPack 2 - April 2010


Spool File Format Change

Server Enterprise Edition 6.0 WrapPack 2, and subsequent software releases change the format of the spool record held in the MVS Spool file, mvsspl01.dat.

After you install the WrapPack or new software releases that include this change, the MVS Spool file conversion is handled automatically. The spool process:

  • Checks for the presence of an existing mvsspl01.dat file.
  • If found, automatically converts this file to a new-format mvsspl02.dat.
  • Renames the old mvsspl01.dat file to mvsspl01.R1.

The mvsspl02.dat spool file is used in all subsequent processing.

However, if you revert to a previous release, the new format MVS Spool file records are not readable by an old version of the product. If you revert to a previous release, you can revert the new-format spool file to the old format.

To revert the mvsspl02.dat to mvsspl01.dat:

  1. Backup the existing mvsspl02.dat file.
  2. Set the MFSYSCAT Environment variable to the location of the System Catalog.
  3. Run the MVS Spool convert utility MFSPLRVT.

    This utility reads the records in the new format MVS Spool file mvsspl02.dat, converts then to the old format, and writes them to mvsspl01.dat. When this process completes, mvsspl02.dat is renamed to mvsspl02.r2.

When this completes, the MVS Spool file is readable in older versions of Server Enterprise Edition.

Parent topic: New Features in 6.0 WrapPack 2 - April 2010


Tutorials

The following tutorials have been added:

  • IMS tutorial - A tutorial for Studio Enterprise Edition showing how you can create an IMS project in Visual Studio. You associate the project with Enterprise Server, deploy the IMS application to the server, and debug it in Visual Studio.
  • Open PL/I - A tutorial showing you how to compile, link and debug Open PL/I programs running under the control of JCL in Enterprise Server.
Parent topic: New Features in 6.0 WrapPack 2 - April 2010


New Features in 6.0 WrapPack 1 - February 2010

Studio Enterprise Edition 6.0 WrapPack 1 provides the following new features:

  • Native Code Application Settings
  • Compiling Single Files
  • Context Help for the COBOL Properties
  • Deployment License Reporting Improvements
  • Enterprise Server Integration within Visual Studio
  • Enhancements in Management Packs for System Center Operations Manager (SCOM)
  • Properties Enhancements
  • Resources
  • Solution Explorer Enhancements
Parent topic: New Features


Native Code Application Settings

The ability to set environment variables and enable COBOL switches for your native COBOL applications has been added.

Parent topic: New Features in 6.0 WrapPack 1 - February 2010


Compiling Single Files

A command to compile individual files (such as COBOL, IMS, BMS) in your COBOL projects has been added.

Parent topic: New Features in 6.0 WrapPack 1 - February 2010


Context Help for the COBOL Properties

This WrapPack provides context help on the project and file properties pages for COBOL projects.

Parent topic: New Features in 6.0 WrapPack 1 - February 2010


Deployment License Reporting Improvements

A new command has been added that details individual installed licenses.

Parent topic: New Features in 6.0 WrapPack 1 - February 2010


Enterprise Server Integration within Visual Studio

  • The context menus of your Micro Focus Servers in Server Explorer now provide commands for starting, stopping and restarting the regions.
  • You can now submit JCL files to JCL configured enterprise servers using drag and drop feature to move the JCL files from the destination location (your project in Solution Explorer, or from outside of Visual Studio - for example, from Windows Explorer) onto the JCL configured server in Server Explorer.
Parent topic: New Features in 6.0 WrapPack 1 - February 2010


Enhancements in Management Packs for System Center Operations Manager (SCOM)

The following management packs are included to integrate with Microsoft's System Center Operations Manager (SCOM):

  • MicroFocus.Server.Core.Library.mp 6.0.2.0
  • MicroFocus.Server.EnterpriseServer.ManagementPack.mp 6.0.4.0
  • MicroFocus.Server.EnterpriseServer.MTO.ManagementPack.mp 6.0.4.0
Monitoring enhancements include:
  1. The frequency of discovery is now every hour.
  2. The "Availability" monitor for XA resources has been enhanced to also detect message CASXO0023S (Severe error detected in XA interface, RM interface disabled) .
Parent topic: New Features in 6.0 WrapPack 1 - February 2010


Properties Enhancements

An option to set additional CICS directives for your COBOL projects and on individual files has been added.

Parent topic: New Features in 6.0 WrapPack 1 - February 2010


Resources

You can now embed resources and version info in your native COBOL applications by adding existing resource script files (.rc) to your projects and building them. It is possible to edit your resource scrip files in the Visual Studio code editor.

Parent topic: New Features in 6.0 WrapPack 1 - February 2010


Solution Explorer Enhancements

You can now use drag and drop feature to add, copy and move files and folders between your projects, or from outside Visual Studio - for example, from Windows Explorer.

Parent topic: New Features in 6.0 WrapPack 1 - February 2010


New Features in 6.0 - July 2009

Studio Enterprise Edition 6.0 provides the following new features:

  • Microsoft Visual Studio as the Core IDE
  • Enterprise Server Integration with Visual Studio
  • 64-bit Enterprise Server
  • CICS Capability Improvements on Windows
  • CICS ISC Using Biz Talk
  • CICS/VSAM to SQL Server Data Mapping
  • DB2 to Microsoft SQL Server Migration Tools
  • Mainframe Subsystem Support (MSS)
  • Tutorials
Parent topic: New Features


Microsoft Visual Studio as the Core IDE

In this release, Microsoft Visual Studio is now the core IDE for maintaining and developing applications that have been migrated from the mainframe and that still use CICS, JCL and IMS. You use the Microsoft Visual Studio and its integrated development environment (IDE) to develop, compile as native code, and debug your applications. You can then deploy and further debug the application under the Server Enterprise Edition run-time system.

The development features include:

  • Project templates for native COBOL applications, including Mainframe Subsystem applications, Console applications, and Windows applications
  • Editing native COBOL- with syntax colorization and background parsing
  • Debugging native COBOL - with the usual features such as stepping, breakpoints and watch windows
  • Mainframe application support - for editing, compiling and debugging CICS programs, JCL applications and IMS applications
  • Project properties for native COBOL
  • Scanning existing files when they are added to a project to scan for the dialect, EXEC CICS and EXEC SQL statements, and to set directives accordingly
Parent topic: New Features in 6.0 - July 2009


Enterprise Server Integration with Visual Studio

Support is provided for running applications under Enterprise Server. This includes:

  • Integrated Server Explorer — for browsing the available enterprise servers within Visual Studio IDE and interacting with them as needed
  • Deployment of mainframe and native code applications to an enterprise server
  • JCL submission to an enterprise server
  • Dynamic debugging of applications that are running under an enterprise server
  • Configuration of enterprise servers using the Administration Web interface
Parent topic: New Features in 6.0 - July 2009


64-bit Enterprise Server

Enterprise Server can be configured to either a 32- or 64-bit working mode and can therefore run 32- and 64-bit COBOL applications, including CICS, IMS, and JCL.

Parent topic: New Features in 6.0 - July 2009


CICS Capability Improvements on Windows

CICS API support has been enhanced to include support for channels and containers, removing limitations on parameter sizes between CICS programs.

Parent topic: New Features in 6.0 - July 2009


CICS ISC Using Biz Talk

We've integrated with Microsoft BizTalk Host Integration Server for CICS Intersystem Communications supporting interoperability between mainframe and distributed applications.

Parent topic: New Features in 6.0 - July 2009


CICS/VSAM to SQL Server Data Mapping

You can now extend an existing CICS application to use Micro Focus’s Database Connectors™ for Microsoft® SQL Server. This enables your application to store and access information in a Microsoft SQL Server relational database management system (RDBMS).

Parent topic: New Features in 6.0 - July 2009


DB2 to Microsoft SQL Server Migration Tools

We now have tools that help automate most of the tasks for migrating DB2 databases to Microsoft SQL databases, easing this process itself. These tools support the following parts of mainframe migrations:

  • Database schema objects from DB2 to SQL Server
  • Data between DB2 and SQL Server
  • Migration and deployment of mainframe COBOL applications that use Embedded SQL for DB2 to Windows and SQL Server

The tools:

  • Schema Extractor — processes DB2 schema to obtain metadata for creating Microsoft SQL Data Definition Language (DDL)
  • DDL Converter — takes metadata from the Schema Extractor to create DDL for Microsoft SQL
  • Data Transfer — transfers data from the host to the destination database, with optional host and destination data comparison
  • • Data Compare — review and verify the results of data transfers.
Parent topic: New Features in 6.0 - July 2009


Mainframe Subsystem Support (MSS)

Previous Micro Focus products referred to Mainframe Transaction Option (MTO) as a facility to enable CICS, IMS and JCL applications that have been migrated from the mainframe to be maintained, developed and deployed on Windows or UNIX platforms. This term has now been replaced by Mainframe Subsystem Support (MSS).

You might still see the term MTO referred to within some areas of the product - for example, supplied support files, pathnames and within the documentation. In these instances the terminology has remained the same.

Parent topic: New Features in 6.0 - July 2009


Tutorials

We've included a number of tutorials to walk you through the new capabilities:

  • Visual Studio IDE — A tutorial introducing you to the Visual Studio IDE and showing you how to create, build, and debug a native code console application using supplied COBOL source files.
  • CICS — A tutorial showing how you can create a CICS project in Visual Studio. You associate the project with Enterprise Server, deploy the CICS application to the server and debug it in Visual Studio.
  • JCL — A tutorial showing how you can create a JCL project in Visual Studio. You associate the project with Enterprise Server, deploy the JCL file to the server, and debug it in Visual Studio.
  • Debugging Web Services — A tutorial showing you how you can use Visual Studio to debug COBOL Web services deployed under Enterprise Server.
  • CICS/VSAM to SQL Server Data Mapping — A tutorial showing you how to extend an existing CICS application to use Micro Focus’s Database Connectors™ for Microsoft® SQL Server. This enables your application to store and access information in a Microsoft SQL Server relational database management system (RDBMS).
Parent topic: New Features in 6.0 - July 2009


Tutorials on COBOL and PL/I in the Visual Studio IDE

There are a number of tutorials that guide you through creating COBOL applications of various sorts using the Visual Studio IDE. Some of them use the demonstration programs supplied with this product. The source files of the demonstrations are installed in subfolders under %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration by default.

The following tutorials are available:

Mainframe Subsystem Tutorials

Tutorial | Shows you how to
Tutorial: Assembler | AACT is a sample CICS 3270 transaction that comprises several Assembler programs and a single BMS map, and uses the resource definitions in the file dfhdrdat. This tutorial walks you through the steps required to implement and test the AACT transaction.
Tutorial: CICS | Create a CICS project in Visual Studio. You associate the project with Enterprise Server, deploy the CICS application to the server and debug in Visual Studio.
Tutorial: Web-Enabled CICS Acting as a Web Server | Create a Web-enabled version of a CICS project in Visual Studio.
Tutorial: Web-Enabled CICS Acting as a Web Client | Create a CICS Web client project in Visual Studio.
Tutorial: Extending CICS Applications to Use Database Connector for Microsoft SQL Server | Extend an existing CICS application to use Micro Focus’s Database Connectors™ for Microsoft® SQL Server. This enables your application to store and access information in a Microsoft SQL Server relational database management system (RDBMS).
Tutorial: JCL | Create a JCL project in Visual Studio. You associate the project with Enterprise Server, deploy the JCL file to the server and debug in Visual Studio.
Tutorial: IMS | Create an IMS project in Visual Studio. You associate the project with Enterprise Server, deploy the IMS files to the server and debug in Visual Studio.
Tutorials: Service Interfaces Using the IMTK | Three tutorials that walk you through the process of defining service interfaces in Visual Studio using the Interface Mapping Toolkit feature, deploying them to enterprise server instances running on Enterprise Server, and generating and running clients to access them.
Tutorial: Compiling, Linking and Debugging a CICS-based Open PL/I Application | Compile, link and debug a CICS-based Open PL/I application using the Open PL/I CICS preprocessor.
Tutorial: Compiling, Linking and Debugging Open PL/I Programs Running Under ES/JCL | Compile, link and debug an Open PL/I application running under the control of JCL in Enterprise Server.
Tutorial: Developing an Open PL/I Application Using Visual Studio | Develop an Open PL/I application using the Visual Studio IDE.
Tutorial: Using Java CodeWatch | Use Java CodeWatch as an alternative to the standard debugger.

Tutorials on Native COBOL

Tutorial | Shows you how to
Tutorial: Developing a Simple COBOL Application | Create a native COBOL application, using existing supplied source COBOL code.
Tutorial: Debugging Web Services | Use Visual Studio to debug COBOL Web services deployed under Enterprise Server.

Tutorials on Managed COBOL

Tutorial | Shows you how to
Tutorial: Developing .NET Managed COBOL | Create a simple Windows application in .NET managed COBOL. You create a Windows form that says "Hello World".
Tutorial: Creating Windows Forms in COBOL | Create a Windows form that interacts with an existing COBOL program.
Tutorial: Creating Web Forms in COBOL | Create a Web page that interacts with an existing COBOL program.
Tutorial: Creating and Accessing WCF COBOL Services | Create a WCF Service in COBOL and access it from a client application
Parent topic: Welcome


Demonstrations of .NET COBOL

We provide a number of demonstration programs designed to help you to better understand some of the concepts involved when working with COBOL projects in Visual Studio.

The following demonstrations are supplied:

\Mainframe
\JCL and \CICS
Shows how to create and build Mainframe Subsystem Applications in Visual Studio. You create a MSS-enabled Enterprise Server and configure it for CICS, JCL or IMS support. Then you associate your project with Enterprise Server, deploy the application to the server and debug it in Visual Studio.
\COBOL for .NET
\Core.Net
Core.NET introduces some of the standard features of the .NET Framework you need to be aware of, and any new COBOL syntax in order to support these features.
All other subdirectories under \COBOL for .NET
Each of the demonstrations shows how to use the corresponding COBOL feature within the .NET framework.
\Forms
\CobolDoKu
Demonstrates Windows Forms using a .NET user control.
\BookDemoWebApplication
A Web Application project which contains a Web form. The form provides a .NET interface to an existing COBOL program. The BookClass project provides a proxy COBOL program that calls the existing COBOL Book program.
\BookWrapper
A managed wrapper (written in COBOL .NET), over the Legacy Book library. The WinBook program uses the BookWrapper library to read and write data from the bookfile.dat.
\LegacyBook
A native COBOL library which needs data records from a data (.dat) file.
\LoginFormApplication
This demonstration is a Visual Studio solution containing a login form created from the Login Form template. It contains classes that check whether the entered user name and password are correct.
\WebBook
Shows how to create a Web Forms page to provide a .NET interface to an existing COBOL program. The BookClass project provides a proxy COBOL program that calls the existing COBOL Book program.
\WebHello
Shows how to use Web Forms to say "Hello World".
\Winbook
Shows how to create a Windows form to provide a .NET interface to an existing COBOL program. The BookClass project provides a proxy COBOL program that calls the existing COBOL Book program.
\WinHello
Shows how to use Windows Forms to say "Hello World".
\SendHTTP
Demonstrates interaction with .NET classes for interacting with http requests and responses.
\InterfacingWithStdCOBOL
Demonstrates how to use compatible types to interface with standard COBOL, and in particular how to manipulate group items and occurs structures.
\MultiRunUnits
Demonstrates why and how procedural COBOL is compiled and invoked in a multiple user environment. The application is an ASP.NET Web Service and you invoke it through the ASP.NET Development Server.
\Multithreading
Introduces some key aspects of Multithreaded programming using COBOL syntax and the run-time threading APIs.
\ConnectedDemo
Fills a DataSet from a data source, modifies the DataSet and then synchronizes the changes in the DataSet with the data source. The modified contents of the DataSet are displayed in the Output Window. To execute this demonstration, you must first download and install the SQL Server Northwind database from the Microsoft Web site, http://www.microsoft.com. Once there, enter the following search criteria to locate the appropriate download page: northwind pubs database download
\CursorDemo
Demonstrates how to mix OpenESQL with direct calls to ADO.NET.
\DisconnectedDemo
Manipulates offline data in a DataSet. The results of the data manipulation are displayed in the Output Window.
\LobDemo
Demonstrates how ADO.NET can be used in mixed language projects to insert and select large objects (LOBs). LobDemo shows OpenESQL working with LOB columns in a SQL Server table.
\OrderStatusDemo
Demonstrates how ADO.NET can be used in mixed language projects, and uses COBOL and C#.
\ConnectedDemo
Fills a DataSet from a data source, modifies the DataSet and then synchronizes the changes in the DataSet with the data source. The modified contents of the DataSet are displayed in the Output Window. To execute this demonstration, you must first download and install the SQL Server Northwind database from the Microsoft Web site, http://www.microsoft.com. Once there, enter the following search criteria to locate the appropriate download page: northwind pubs database download
\CursorDemo
Demonstrates how to mix OpenESQL with direct calls to ADO.NET.
\DisconnectedDemo
Manipulates offline data in a DataSet. The results of the data manipulation are displayed in the Output Window.
\LobDemo
Demonstrates how ADO.NET can be used in mixed language projects to insert and select large objects (LOBs). LobDemo shows OpenESQL working with LOB columns in a SQL Server table.
\OrderStatusDemo
Demonstrates how ADO.NET can be used in mixed language projects, and uses COBOL and C#.
\Samples Browser
Shows a list of the samples installed with your COBOL development system. You can select a sample from the list and view its readme. Click one of the available links to open the sample in Visual Studio, open the directory that stores the sample's files or open its readme.
\WCF
Demonstrates the use of Windows Communication Foundation (WCF) services. To run this demonstration you need to have Microsoft’s Visual Web Developer 2010 installed.
\WPF
Demonstrates the use of Windows Presentation Foundation (WPF).
\CobolAddin
Demonstrates the use of COBOL to develop an add-in for the Visual Studio IDE.
\XMLWinForm
Demonstrates that COBOL can be used to read and write XML documents and demonstrates the use of the treeview and property grid Windows Forms objects.
\pinvoke
Demonstrates that COBOL can be used to read and write XML documents and shows the use of the treeview and property grid Windows Forms objects.
Parent topic: Welcome


Product Information

This Product Information covers information available at the time of writing. Up-to-date information is downloadable from the SupportLine Web site.

  • System Requirements for Studio Enterprise Edition
  • Installing Studio Enterprise Edition
  • Updates and Product Support
  • Micro Focus End User License Agreement
  • Third Party Software
  • Known Errors and Restrictions
  • Contacting Micro Focus
Parent topic: Welcome


System Requirements for Studio Enterprise Edition

  • Hardware Requirements
  • Operating Systems Supported
  • Software Requirements
Parent topic: Product Information


Hardware Requirements

Studio Enterprise Edition has the following requirements in addition to the requirements of Microsoft Visual Studio. See the Visual Studio documentation for details of the Microsoft requirements.

The disk space requirements are:

  • 58MB for the Sentinel RMS license server
  • 200MB for Micro Focus COBOL integration into Visual Studio
  • 516MB for a minimum installation of the Net Express IDE only
Note: This includes the space needed to cache information locally so that you can modify the installation without the original source media.
Parent topic: System Requirements for Studio Enterprise Edition


Operating Systems Supported

Note: You can produce 64-bit and 32-bit applications on 64-bit operating systems.

The following platforms are supported:

32-bit Windows Platforms
  • Windows Server 2003
  • Windows Server 2003 R2
  • Windows Server 2008
  • Windows Vista
  • Windows XP Professional SP3 or later
  • Windows 7
64-bit Windows Platforms
  • Windows Server 2003
  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows Vista
  • Windows XP Professional SP2 or later
  • Windows 7
Citrix and Terminal Server
  • Windows Server 2000
  • Windows Server 2003
  • Windows Server 2003 R2
  • Windows Server 2003 - 64-bit
  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows 7
Parent topic: System Requirements for Studio Enterprise Edition


Software Requirements

  • This release requires and will upgrade Studio Enterprise Edition ServicePack 2 or Service Pack 2 WrapPack 1.
Important: This release requires version 10000.2.990 or later of the Micro Focus licensing software. For local servers, you do not need to install it separately, as the setup file installs a new Studio Enterprise Edition client and a new licensing server on the same machine.

If you have a network server, you must update the license server before installing the product as the client is not able to communicate with license servers of versions older than 10000.2.660. On Windows, you can check the version of your license server by clicking Help > About in the Micro Focus Licensing System Administration tool.

You can download the new version of the license server software from the Micro Focus SupportLine Web site: http://supportline.microfocus.com/websync/SLM.aspx.

ou need to install the following software beforehand:

The following functionality, tools and features have additional requirements:

Visual Studio IDE

  • Microsoft Visual Studio 2008 Service Pack 1 or Microsoft Visual Studio Shell 2008. Microsoft Visual Studio Express Edition is not supported.
  • Microsoft Windows SDK is required if you are using Visual Studio Shell. See the Microsoft Download Center and search for Windows SDK.
  • Microsoft .NET Framework 3.5. This is included with the above versions of Visual Studio.

Enterprise Server

  • A Web browser, such as Microsoft Internet Explorer 6.0 or Netscape Navigator 6.1, is required for Enterprise Server Administration in Server Enterprise Edition.

    To use your Web browser offline, you need the dial-up networking feature of Windows installed. Otherwise you might have TCP/IP errors such as being unable find "localhost" or the numeric equivalent (127.0.0.1).

  • To use Enterprise Server Administration, scripting or JavaScript support must be enabled in your browser. This is on by default in Internet Explorer in most Windows operating systems, apart from Windows Server 2003. Also, active content must be allowed and not blocked. To enable both these in Internet Explorer:
    1. Click Tools > Internet Options.
    2. On the Security tab, click Custom Level. In the Scripting section, under Active Scripting, click Enable.
    3. On the Advanced tab, scroll down the list to the Security section, and ensure the item Allow active content to run in files on My Computer is checked.
  • Enterprise Server Help requires the Java Runtime Environment on some Windows systems to enable the Search facility to work.

Server Enterprise Edition for .NET

  • Microsoft .NET Framework 4.0
  • Microsoft SQL Server 2008 R2. (For beta or development installations, SQL Server Express 2008 R2 is sufficient.)

    You can download Microsoft's SQL Server from http://www.microsoft.com/sqlserver/en/us/get-sql-server/try-it.aspx.

  • A TN3270 terminal emulator. Micro Focus Rumba is supplied with this product.
Note: You also need to enable IIS and some additional Windows features. Read the Quick Start section in your Server Enterprise Edition for .NET help for further instructions on how to set up your operating environment.

Java Beans

  • Java 2 Platform Standard Edition (J2SE) 1.4 or later from Oracle or IBM. Oracle versions 1.4 and later are supported, but only IBM version 1.4 is supported. You can download the J2SE from www.oracle.com.

Java Compilation

  • The Java Development Kit (JDK) is required for compiling Java. The JDK is downloadable from www.oracle.com. After installing the JDK, you must put the tools.jar file for the JDK on your classpath, using a command similar to:
     set classpath=jdk-install-directory\lib\tools.jar

OpenESQL

  • Database access is supported using the OpenESQL preprocessor with applications compiled as .NET managed code to access relational databases using ODBC 3.0-compliant drivers. Refer to your driver vendor's documentation to determine whether your driver is suitable for use with OpenESQL.
  • OpenESQL has been tested against the following ADO.NET data providers:
    • Microsoft provider for SQL Server
    • Microsoft provider for Oracle
    • IBM DB2
    • Oracle Data Provider for .NET (ODP.NET)
    • OleDb
    • Managed ODBC .NET providers
  • Dynamic SQL using the SQL Descriptor Area (SQLDA) is not currently supported for OpenESQL applications compiled with the SQL(DBMAN=ODBC) directive.

Windows Forms

  • Microsoft Visual Studio is required for using the Service Interfaces feature to generate Windows Forms and ASP.NET Web site test clients.
  • Microsoft Internet Information Service (IIS) is also required for generating Windows Forms test clients.
Parent topic: System Requirements for Studio Enterprise Edition


Installing Studio Enterprise Edition

  • Installation Restrictions and Requirements
  • Downloading the Product
  • Installing
  • Installing Silently
    You can install Micro Focus products silently by using command line parameters to specify the installation directory, user information, and which features to install.
  • Microsoft Terminal Server
  • Installing from a Server
  • Windows Compatibility Mode
  • Repairing
  • Installing Mainframe Access Server
  • Uninstalling
Parent topic: Product Information


Installation Restrictions and Requirements

Before starting the installation you should consider the following:

  • Studio Enterprise Edition and Server Enterprise Edition cannot co-exist on the same machine.
  • If, when you install Studio Enterprise Edition for Visual Studio 2008, the machine does not have Microsoft Visual C++ 2008 Redistributable Runtime already installed, it is installed as required by Studio Enterprise Edition. The installation of Microsoft Visual C++ 2008 Redistributable Runtime adds a number of .dll files, without digital signatures, into the winsxs directory.
  • If you are installing this as an upgrade, make sure that none of the product files are in use when you start the installation.
  • You need to be logged in with a user-ID that has write access to the registry structure under HKEY_LOCAL_MACHINE, HKEY_CLASSES_ROOT, and HKEY_CURRENT_USER so the installation software can set the environment appropriately. You also need to be logged on with Administrator privileges.
  • Before installing this product , make sure that any existing Micro Focus Directory Server (MFDS) or CCITCP2 Windows service from an existing product is stopped and uninstalled. Do this as follows:
    1. Stop the service, using either the Windows Service Management Console GUI or from a command line prompt by typing: net stop mf_ccitcp2 Only one instance of the MFDS or CCITCP2 service can run on a Windows machine.
    2. Uninstall the MFDS or CCITCP2 service.

      For MFDS, from a command line prompt enter: mfds -u

      For CCITCP2: ccitcp2 -u

    To run an earlier version of MFDS as a service after you have installed a later version:

    1. Stop and uninstall the MFDS service, as described above.
    2. Reinstall the earlier version, as follows:
      1. Open a Net Express command prompt.
      2. Install the service. Enter the following command: mfds -i
      3. Start the service. Enter the following command: net start mf_ccitcp2
      Note: The two versions use different paths for environment and registry values, so the list of configured Enterprise Servers might be different depending on which version has been started, since, by default, different MFDS data repositories are used.

    MFDS 5.1 and later are able to import or use Enterprise Server configuration data generated by earlier versions of MFDS, but 5.0 or earlier versions of MFDS might not be able to read data generated by later versions.

    It is possible to run MFDS from a command prompt ("mfds") rather than as a service, but by default the "mfcobol" port is used (86) and this can only be used by one process at a time

Parent topic: Installing Studio Enterprise Edition
Related information
To install (or selected files)


Downloading the Product

  1. Use the download links in your Electronic Product Delivery email.

    For more information follow the links for the installation instructions and the End User License Agreement.

Parent topic: Installing Studio Enterprise Edition
Related information
Micro Focus End User License Agreement


Installing

Use the setup file on your machine and install the product as follows:

  1. Run the NXP32xxxxxxxx.msp file and follow the wizard instructions to complete the installation.
Note:
  • If you are installing onto a machine that has an existing Micro Focus product that uses an older Sentinel RMS License Manager, you might be prompted to remove it and install the Micro Focus License Manager. By doing this you maintain the existing Sentinel RMS license files while adding the Micro Focus License Manager. If you are unsure about existing licenses on your computer or removing the Sentinel RMS License Manager, consult your System Administrator. If you want to proceed, remove Sentinel RMS License Manager by using Windows Add or Remove Programs and rerun the installation file.
  • Trial licenses cannot be used with remote desktop services. If you want to use your product in this way, please contact Micro Focus SupportLine to obtain a relevant license.
  • We recommend that you install any updates for Visual Studio and the .NET Framework that are available at the Microsoft Download site.
  • If you install JDK you might be prompted to install the latest update. The latest update is not required for use with Studio Enterprise Edition but you can install it if you wish.
Parent topic: Installing Studio Enterprise Edition


Installing Silently

You can install Micro Focus products silently by using command line parameters to specify the installation directory, user information, and which features to install.

To install silently use the following commands:

start /wait install-file.msp /q [parameters]

where install-file for the following products is as follows:

Studio Enterprise Edition
NXP32xxxxxxxx.msp

Examples

  • To install the product in a non-default directory:
    start /wait install-file.exe /s /v"/qn INSTALLDIR=c:\DirectoryName"
  • To install feature B, which is a child of feature A, from install file InstallFile.exe:
    start /wait install-file.exe /s /v"/qn ADDLOCAL=B,A"
  • To install feature C from the install file install-file.exe:
    start /wait install-file.exe /s /v"/qn ADDLOCAL=C"
  • To install feature DOTNET, from install file install-file.exe:
    start /wait InstallFile.exe /s /v"/qn ADDLOCAL=DOTNET"
  • To install and specify the log file as c:\install-log.txtfor :
    start /wait install-file.exe /s /v"/qn /l*vx c:\install-log.txt"
  • To install with Serial Number and WO number:
    start /wait install-file.exe /s /v"/qn SERIALNUM=SerialNumber WONUMBER=WONumber"
  • To install the .msp for a WebSync and specify the log file:
    start /wait msiexec.exe /update install-file*.msp /qn /l*v wsinstall.txt
Parent topic: Installing Studio Enterprise Edition


Microsoft Terminal Server

You can use this program with Microsoft Terminal Server but note that a separate end-user license is required for each user who accesses it, even if the product is running on a single machine. See your End User License Agreement.

Microsoft Terminal Server is an environment for running multiple instances of a single user product. It is not a platform where a single-user product can be made to perform as a multi-user product.

  • To install onto a terminal server, log on to the physical terminal server with a user ID that has administrator privileges. Then use Control Panel > Programs (or Add/Remove Programs on older versions of Windows) and follow the instructions on the screen.
  • When you install the product on Microsoft Terminal Server or similar terminal software, do not execute more than one installation at the same time.
  • When you install Microsoft Terminal server, you must assign a unique port address to each user. Then the very first time that each user logs into Studio Enterprise Edition and starts the terminal server, he or she should:
    1. Select Options > Project > Port address for Web Server.
    2. Type in the assigned port address.

    This is necessary because the default port address for the Web server is 80. Once this has been allocated to the first user, when the next user attempts to start the Web server, the software recognizes that this port is in use and rejects the attempt. Consequently each user requires an individual port address.

Parent topic: Installing Studio Enterprise Edition
Related information
Micro Focus End User License Agreement


Installing from a Server

There are two methods for installing this product on users' machines using a server. You can:

  • Install onto the server. Then users run Setup to install from the server onto their own machines.
  • Copy the product onto the server and then use Setup under control of a third-party software distribution package, such as Microsoft's Systems Management Server (SMS), to install the product onto multiple users' machines.

    This method of installation and the associated file are not supported by Micro Focus. They are provided on an "as is" basis and have not been tested in any form. You can use them at your own discretion.

Both methods give you control of what options the user can install and mean you do not have to send the installation media to every user, as they install from the server instead.

Parent topic: Installing Studio Enterprise Edition


Windows Compatibility Mode

In Windows Vista and Windows Server 2008, if you have problems starting Enterprise Server instances using the Micro Focus Enterprise Server Administration HTML GUI, ensure that none of the Enterprise Server program files are configured to use a Windows compatibility mode. You can check for compatibility modes by examining the file properties for the program file using Windows Explorer.

  1. Open the Properties dialog for the file.
  2. Go to the Compatibility tab.
  3. Ensure that Run this program in compatibility mode for is not checked.
  4. ClickShow settings for all users and ensure that Run this program in compatibility mode for is not checked.
  5. Click OK on both dialogs to update the file properties.

Verify that product-install-folder\base\bin\mfds.exe is not set to run in a compatibility mode.

  • For 32-bit Enterprise Server, check base\bin\cas*.exe and base\bin\mfcs.exe
  • For 64-bit Enterprise Server, check base\bin\win64\cas*.exe and base\bin\win64\mfcs.exe.
Parent topic: Installing Studio Enterprise Edition


Repairing

If any product files, registry settings or shortcuts are accidentally removed at any point, you can perform a Repair on the installation to replace them.

To repair your installation on versions of Windows Vista or later:

  1. From the Control Panel, click Uninstall a program under Programs.
  2. Right-click your Micro Focus product and select Repair.

To repair your installation on older versions of Windows, such as Windows XP:

  1. Click Start Menu > Control Panel > Add/Remove Programs.
  2. Click your Micro Focus product in the list of installed programs.
  3. Click Click here for support information.
  4. Click Repair.
Parent topic: Installing Studio Enterprise Edition


Installing Mainframe Access Server

Introduction

The installation process for Mainframe Access Server uses a single FTP operation to transfer all of the mainframe software into a partitioned data set that you pre-allocate. When this transfer is complete, the remaining installation activities are all done on the mainframe. You customize and submit the pre-built FRESTORE job to restore the product data sets from the uploaded files and then continue with customization steps to create an operational Mainframe Access Server.

Requirements

  • IBM TCP/IP 4.0, or Interlink TCP/IP 3.1 or higher
  • two APPLIDs, two TCP/IP ports
  • APF security authorization support personnel availability
  • Access to a network share with acceptable space for source and data, as well as the ability to access the IP address and ports used to access MFA
  • The following installation-specific variable information:
    Variable | Description
    drive
    userid | TSO user-ID for FTP to your mainframe
    pswd | TSO password for the FTP user-ID
    your.mainframe.name | TCP/IP host name or IP address of your mainframe
    prodhlq | A NEW high level qualifier that will be assigned for all Host Connectivity data sets when the new Mainframe Access product is installed. These are NOT existing product data sets, but rather brand new files that you will be creating for this base version.
    Important: The installation of a new version creates new product run-time data sets before the upgrade is applied. Any existing Host Connectivity 3.01 libraries remain intact, and can be used for fallback. If you prefer to retain your former production library names and re-use your existing prodhlq then rename your old libraries beforehand.

    Make a note of the maintenance level of your current Mainframe Access Server. Messages MFM0001I and MFM0014I on the syslog and XDBOUT sysout data set show the maintenance level at startup. You may need to know what level you are upgrading from when you complete post-installation customizations for this upgrade.

Install Mainframe Access Server

In the instructions that follow, the information that you must provide is shown as one of the variable names from the table of information in the previous section. For example, if your high-level qualifier (prodhlq) value is MY.MFA, then substitute MY.MFA for prodhlq.

Follow these steps to load Mainframe Access Server:
  1. Download the installation file from the link in your Electronic Product Delivery email and extract its contents to a directory on the PC.
  2. On the mainframe, allocate a new partitioned data set named prodhlq.UPLOAD to receive the uploaded files. Use the following data set characteristics for this upload library:
    DSORG=PO                   <=== PDS (partitioned data set)
RECFM=FB                   <=== record format fixed and blocked
LRECL=80                   <=== 80 character record size
BLKSIZE=3120               <=== 3120 character block size
SPACE=(3120,(3500,500,50)) <=== allocate blocks (BLKS) size 3120
                                3500 primary blocks
                                500 secondary blocks
                                50 directory blocks
  3. On the PC, issue the following FTP commands. The actual text of the FTP prompts and responses that you see may differ slightly from those shown in this example.
    1. Start FTP:
      C:\>ftpyour.mainframe.name
Connected to your.mainframe.name.
220-FTPD1 IBM FTP CS/390 VxRy at YOUR.MAINFRAME.NAME, hh:mm:ss
220 Connection will close if idle for more than 5 minutes.
User (your.mainframe.name:(none)): userid
331 Send password please.
Password: pswd
230 userid is logged on. Working directory is "userid.".
    2. Change the working directory on the mainframe to be the upload library that you allocated:
      ftp> cd 'prodhlq.UPLOAD'
250 The working directory "hlq.UPLOAD" is a partitioned data set.
    3. Set file transfer type to binary:
      ftp> binary
200 Representation type is Image
    4. Set FTP prompting off to transfer all files without interruption:
      ftp> prompt
Interactive mode Off.
    5. Transfer all files from the extracted \Upload directory to members in the prodhlq.UPLOAD library:
      ftp> mputdrive:\upload\f*
200 Port request OK.
125 Storing data set prodhlq.UPLOAD(Fxxxxxxx)
250 Transfer completed successfully.
ftp: xxxx bytes sent in x.xx seconds (xxx.xx Kbytes/sec)
.
.
.
    6. When mput has transferred all files the ftp> prompt appears. End the FTP connection:
      ftp> quit
221 Quit command received. Goodbye.
    7. On the mainframe, verify that all files transferred successfully and that for each Fxxxxxxx file in the \Upload directory there is a corresponding member in the prodhlq.UPLOAD data set. There should be 10 members, F1 through to F9 and FRESTORE.
  4. On the mainframe, edit member FRESTORE in the upload library, prodhlq.UPLOAD. Follow the instructions in that member to customize the JCL and then submit that job to restore the product libraries from the uploaded files and populate your new product runtime libraries.
  5. Start Mainframe Access Server.

After installation

Since the program libraries can change between versions, it is necessary to either create new procedures, or back up the old procedures, and at least modify the DSNQUAL=prodhlq within your MFA sample started task procedures as provided by Micro Focus. The prodhlq.LOADLIB and prodhlq.SASC.LINKLIB must both be authorized.

Verify successful maintenance application by checking the Mainframe Access Server startup message:

MFM0001I: Mainframe Access V4.00 (BASE ) is active

The "(BASE )" indicates the product maintenance level. Also check for "V4.00" in the Mainframe Access Data Connect server startup message:

MFA303I MFA/DATACONNECT V4.00 - BASE COPYRIGHT (C) 1987-2012 MICRO FOCUS...

When you are satisfied with the new version installation you may delete the UPLOAD data set from your system.

New parameters and members in the CNTL samples data set

The following updated members are found in the CNTL data set.

MFA | sample MFA started task
MFAS | *new* sample MFAS started task for Data Connect
MFAAS | sample MFAAS application server started task
MFAVTAM | sample MFA VTAM definitions
PARMS | sample PARMS for MFA started task
PARMSAS | sample PARMSAS for MFAAS started task
SERVERS | sample SERVERS configuration for MFA
UPQUICK | configuration notes

If you are migrating from Host Connectivity 3.01 WebSync 10 or earlier, you may want to retain your existing CNTL members from your current version as an installation test. You can simply copy the existing MFA started task JCL and change the STEPLIB to reference the new product libraries. You will however be required to modify the MFAS started task JCL since the module names for Data Connect have been changed to allow co-residence within the same authorized library as MFA.

Review the Change Log in each of the new members. Read the documentation for any new parameters in the Readme and in the updated Mainframe Access Administrator's Guide. Add these new parameters and other changes to your working copies. If necessary, customize the new parameters for your installation.

Once you are satisfied with the operation of Mainframe Access, you can consolidate the configuration settings into the new high-level qualified CNTL members.

Parent topic: Installing Studio Enterprise Edition


Uninstalling

Windows

To uninstall the product, you cannot simply delete its files from your hard disk. To uninstall the product:

  1. Log in with the same user-ID as you used when you installed the product.
  2. Click Uninstall a program under Programs (or Add/Remove Programs on older versions of Windows) in Control Panel.
  3. On older versions of Windows such as Windows XP, ensure that Show Updates (at the top of the Add or Remove Programs dialog) is checked, so that any hot fixes or WrapPacks are listed.
  4. On versions of Windows Vista and later, click View installed updates in the left-hand pane.
  5. Select the product and click Remove or Uninstall, respectively.

When you uninstall, the only files deleted are those that the installation software installed. If the product directory has not been removed, delete any unwanted files and subdirectories within it using Windows Explorer.

Note: When you installed, three separate items were created on the Start menu: Micro Focus Open PL/I 8.1, Micro Focus Studio Enterprise Edition 6.0, and Micro Focus License Management System.

Some registry entries are not removed by the uninstallation process and you need to manually delete them. These registry entries are for event logging and are created at run time, as follows:

  • SYSTEM\CurrentControlSet\Services\Eventlog
  • Micro Focus Server[<SERVER_NAME>] with the following entries:
    • CategoryCount
    • CategoryMessageFile
    • EventMessageFile
    • TypesSupported

In addition, the following registry entries are not removed. These are created the first time that an Enterprise Server that has been enabled for performance monitoring starts up:

  • Micro Focus Server\Performance\Active Servers
  • Micro Focus Server\Performance\PerfIniFile
Parent topic: Installing Studio Enterprise Edition


Updates and Product Support

When you have installed, you need to apply the latest updates if there are any. These are located on the Micro Focus Web site.

Before you can access the Product Updates page, you need to register (first-time users only) and log in with Product Support. To register:

  1. Click Register on the Product Support page.
  2. Enter your details. You will need your product serial numbers, which you can find in the subject line and body of your Electronic Product Delivery Notice email that you received from Micro Focus.

To log in:

  1. Enter your User Name and Password on the Product Support page.

    We recommend you check Auto Login so you don't have to do this every time.

  2. Click Login.

The Product Updates page is now displayed, where you can find the latest update for your product and version number.

You can turn on notifications about product updates in Visual Studio. To do this click Tools > Options > Projects and Solutions > COBOL Project Settings. Check Notify me about updates when they become available.

You will then be notified on a weekly basis, when you run this COBOL development system, if an update is available. The notification will include a link to the Product Support page from where you can access the update, as described above.

Product Support is a web-based support and information service from Micro Focus. It provides all the latest information and software updates for this COBOL development system:

  • Technical support information
  • Latest product information
  • Documentation updates
  • New and updated demonstrations and templates
  • Hints and tips
  • Lots more - try it and see!
Parent topic: Product Information


Micro Focus End User License Agreement

IMPORTANT: LICENSOR IS PROVIDING THIS SOFTWARE FOR YOUR USE SUBJECT TO YOUR AGREEMENT TO BE BOUND BY THE TERMS AND CONDITIONS SET FORTH BELOW. IF YOU DO NOT AGREE TO THE TERMS OF THIS AGREEMENT BY CLICKING ON SETUP'S ACCEPT BUTTON, YOU WILL NOT BE ABLE TO USE THE SOFTWARE. BY CLICKING SETUP’S ACCEPT BUTTON YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, UNDERSTOOD IT, AND AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS.

WHEREAS, Licensor desires to grant to Licensee, and Licensee desires to accept from Licensor, a license to use Licensed Software (as defined herein) upon the terms and conditions hereinafter set forth; NOW, THEREFORE, Licensor and Licensee agree as follows:

For this End User License Agreement (“License Agreement”) the following terms shall have the meanings given below:

“Blades” means multiple server modules housed in a single chassis each with its own CPU, hard disk and memory.

“Core” means a single unit of processing within a computer chip, comprising an arithmetic logic unit, registers, instruction fetcher and data fetcher/storer. “CPU” (Central Processor Unit) means a data processing unit, normally identified with a single microchip mounted on a single circuit board and can comprise several Cores. A computer “box” can contain several CPUs. The “box” is sometimes referred to as a “server” or a “machine” (or possibly a “mainframe”).

“Licensor” means the Micro Focus named legal entity authorized to license the Licensed Software in the country in which Licensee acquires the Licensed Software.

“Licensed Software” means the object code version of the Licensor computer programs, their accompanying user documentation (“Documentation”) and other supplemental materials as provided to Licensee by Licensor, including but not limited to any software security keys, modifications or additions relating thereto. The Licensed Software shall also include any new releases, updates, revisions, modifications, additions, corrections and fixes of the Licensed Software that Licensee receives under Sections 6 and 7 below or under maintenance for which Licensee has separately contracted and paid. From commencement of this License Agreement, the “Licensed Software” shall also include, and this License Agreement shall apply to, any prior versions of the Licensed Software licensed by Licensee. This License Agreement does not grant Licensee the right to any new releases, updates, revisions, modifications, additions, corrections and fixes of the Licensed Software unless provided by Licensor under Section 6 below. Licensed Software products are available to operate on the Windows, Linux, Unix or other computer platforms and a separate license is required for a Licensed Software product for each computer platform.

“Product Order” means a document that has been (i) executed by Licensee, describing each Licensed Software license purchased and (ii) accepted by Licensor or its authorized distributors. Licensor will accept the Product Order by either confirming Licensor’s acceptance in writing or by delivering the Licensed Software Licensee, whichever occurs first. Each Product Order shall constitute a separate agreement and shall incorporate therein all of the terms and conditions of this License Agreement. In the event of any conflict between the terms of this License Agreement and the terms of any Product Order which have been expressly accepted by a duly authorized signatory of Licensor in writing, such terms of the Product Order shall govern. In no event shall any terms and conditions of Licensee contained in a purchase order or similar document issued by Licensee in connection with this License Agreement or a Product Order apply and any such document issued shall be only for the administrative purposes of identifying the Licensed Software ordered, the number of licenses, and the price to be paid and shall have no other legal effect.

“Disaster Recovery System” is defined as a computer system that is used (i) if a disaster arises and the original production system is unavailable, (ii) for the purposes of disaster recovery testing and/or (iii) for system diagnostics or maintenance of the Disaster Recovery System itself. A Disaster Recovery System does not include any system that is in the same computer cluster as the machine on which the development or production copy of the Licensed Software is installed.

“Virtual Machine” means a software implementation that executes programs like a physical machine where the software running inside the virtual machine is limited to the resources and abstractions provided by the virtual machine.

  1. GRANT OF LICENSE. For payment of the applicable non-refundable license fees identified on the Product Order, Licensor grants solely to Licensee, as an end user, a personal, perpetual, non-transferable, non-sublicensable and non exclusive license to use the Licensed Software subject to the terms and conditions set forth in this License Agreement. Licensee shall have the right to use the Licensed Software solely for its own internal use and benefit. For the avoidance of doubt, the license granted herein does not permit (i) third party contractors (including without limitation outsourcers) to access or use the Licensed Software for Licensee’s internal use and benefit without the prior written consent of Licensor and the payment of an additional license fee, (ii) the public to access or use the Licensed Software (including without limitation, via the internet) except as specifically provided in Annex 1 hereunder, and/or (iii) installation, use or access of the Licensed Software on, in, or from a Virtual Machine except as specifically provided in Annex 1 or Annex 2 hereunder. Where permitted by Licensor pursuant to sections 1(i) and (ii) hereof, Licensee shall be liable to Licensor in respect of any breach of this License Agreement resulting from any access or use by third party contractors and/or the public. Access and/or use of data, results and/or output obtained and/or generated, either directly or indirectly, through the use of any Licensed Software are deemed to be access and/or use of such Licensed Software and such data, results and/or output shall be subject to the licensing terms and restrictions applicable to such Licensed Software. Different license options are available from Licensor as set forth or referred to in Annex 1 (“License Option(s)”), although not all License Options are available for each specific Licensed Software product. The applicable License Option to be purchased by Licensee for the Licensed Software shall be identified in the Product Order. Additional License Options (as appropriate) are required to be purchased by Licensee for use of the Licensed Software on a Disaster Recovery System or for load-balancing, fail-over, training, or testing purposes. Licensed Software purchased for testing purposes will be subject to the Test License Option terms and restrictions set forth in Annex 1.E. Certain Licensed Software may also be subject to additional terms and conditions as set forth in the “Specific Software Terms” located in Annex 2. The Specific Software Terms will prevail in the event of any conflict.
  2. USER RESTRICTION. Licensee agrees not to:
    1. Copy and distribute the Licensed Software, in whole or in part, for internal use without paying Licensor the applicable additional fees, except (i) for making a reasonable number of archival back-up copies; or (ii) as expressly authorized by Licensor in writing; or (iii) for making a reasonable number of copies of the Documentation supplied to Licensee by Licensor in electronic form. Licensee shall reproduce and affix all copyright and other proprietary rights notices appearing in or on the Licensed Software, including the notices of all third party suppliers and all those included in any Third Party Software, as defined below in all such copies thereof.
    2. Copy and/or distribute the Licensed Software, in whole or in part, to third parties without first entering into a separate distribution license agreement with Licensor or permit use or access to all or part of the Licensed Software to any third party except as specifically provided in Annex 1 hereunder. For the avoidance of doubt, third party(ies) include without limitation contractors, outsourcers, Licensee’s customers and the public.
    3. Transfer, ship or use the Licensed Software outside the continent in which it was originally licensed to Licensee, except as otherwise specified in Annex 1 and/or Annex 2.
    4. Install, access or use the Licensed Software on an operating system other than the operating system for which the Licensed Software was originally licensed to Licensee, except as otherwise specified in Annex 1 and/or Annex 2.
    5. Assign, sell, rent, lease, lend, sublicense, outsource or otherwise transfer the Licensed Software to any third party, or authorize or appoint any third party to do so.
    6. Use the Licensed Software for timesharing, facilities management, outsourcing, hosting, service bureau use, other data processing services to third parties or like purposes.
    7. Modify the Licensed Software or provide any person with the means to do the same.
    8. Create derivative works, translate, disassemble, recompile or reverse engineer any Licensed Software or attempt to do so (except to the extent applicable law specifically permits such activity).
    9. Alter, destroy, or otherwise remove any proprietary notices or labels on or embedded within the Licensed Software or Documentation.
    10. Utilize for itself, or permit any third party to utilize, any software application program created, in whole or in part, utilizing any Licensed Software without a valid and properly granted Deployment Product License.
    11. Use the Licensed Software in a manner other than as specifically permitted in this License Agreement.
  3. AUDITS. Licensee agrees to (i) keep records of and provide the location, model and serial number of any and all machines on which the Licensed Software is installed or from which the Licensed Software is accessed, and the names of and how many users are accessing the Licensed Software, (ii) implement a reasonable mechanism or process to ensure that Licensee’s use of the Licensed Software does not exceed the number of licenses granted, (iii) take all necessary steps to destroy or erase all Licensed Software codes, programs and other proprietary information before disposing of any media containing the Licensed Software, and (iv) promptly provide written notice to Licensor if Licensee’s usage exceeds the license granted. Upon Licensor’s reasonable request, but not more frequently than annually without reasonable cause, Licensee shall furnish Licensor with a statement signed by a director and/or auditor, as required by Licensor, verifying the above and shall permit Licensor to audit the use of the Licensed Software at such times as may be mutually agreed upon. In the event Licensee’s usage exceeds the license granted, without prejudice to any other rights or remedies Licensor may have, including without limitation injunctive relief, Licensee agrees to pay Licensor the then current license and maintenance fees for the use of the additional licenses. Further, if such usage exceeds the license granted by more than five percent (5%), Licensee shall also reimburse Licensor for the reasonable cost of such audit in addition to other amounts due.
  4. DOCUMENTATION. One (1) electronic copy of Licensor’s standard Documentation, describing Licensor’s recommended use and application of the Licensed Software, will be furnished free of additional charge to Licensee by Licensor with the Licensed Software. Printed copies of any documentation may be available for purchase from Licensor or its authorized distributors.
  5. TERM OF LICENSE. This License Agreement and Licensee’s license for the Licensed Software is perpetual, unless a subscription/term license has been purchased by Licensee, and is subject to earlier termination as provided in this Section 5. Licensor may terminate this License Agreement and Licensee’s license to the Licensed Software immediately by giving Licensee written notice of termination in the event that either (i) Licensee breaches any term or condition of this License Agreement and Licensee has failed to remedy such breach within ten (10) days of the date of notice from Licensor to Licensee or (ii) Licensee is wound up, has a receiver appointed or enters into liquidation or bankruptcy or analogous process or processes in Licensee’s home country. Termination shall be without prejudice to any other rights or remedies Licensor may have. Licensee may at any time terminate this License Agreement voluntarily by giving written notice of termination to Licensor. In the event of any termination Licensee will have no right to keep or use the Licensed Software or any copy of the Licensed Software for any purpose and Licensee shall destroy and erase all copies of such Licensed Software in its possession or control, and forward written certification to Licensor that all such copies of Licensed Software have been destroyed or erased.
  6. MAINTENANCE. Where Licensee purchases maintenance services, Licensee’s initial maintenance term will begin upon delivery to Licensee of the Licensed Software and continue for one (1) year thereafter unless otherwise specified in the applicable annual maintenance agreement or in the Product Order, or earlier if the license is terminated. Where Licensee purchases maintenance for any Licensed Software product licensed hereunder, Licensee hereby agrees that it shall purchase such support services for all of Licensee’s licensed copies of such Licensed Software product on the relevant computer platform. Maintenance services provided by Licensor will be subject to Licensor’s then current applicable annual maintenance agreement unless otherwise agreed by the parties in writing.
  7. LIMITED WARRANTY. Licensor warrants for a period of ninety (90) days from delivery to Licensee (“Warranty Period”) (i) that the media on which the Licensed Software is supplied is free from defects in materials or workmanship under normal use and (ii) that the copy of the Licensed Software delivered to Licensee conforms in all material respects to the Documentation. As the sole and exclusive remedy for not meeting part (i) of the above warranty, Licensor’s sole obligation shall be to repair or replace free of charge any defective media on which the Licensed Software is delivered if the media is returned to Licensor by Licensee during the Warranty Period. As the sole and exclusive remedy for not meeting part (ii) of the above warranty, Licensor shall repair or replace the Licensed Software free of charge or if Licensor reasonably determines that such remedy is not economically or technically feasible, Licensee shall be entitled to a full refund of the license fee and any maintenance fee paid by Licensee with respect to that particular Licensed Software and Licensee’s license to use such Licensed Software will terminate. The warranty set forth in this Section 7 shall not apply if the defect in the Licensed Software is the result of: (a) the Licensed Software not being used in accordance with the Documentation, this License Agreement or with the platform(s) for which the Licensed Software has been designed and licensed by Licensor; or (b) the Licensed Software having been altered, modified or converted by Licensee or any third party except as may be specified in the Documentation; or (c) the malfunctioning of Licensee’s equipment; or (d) accident or abuse; or (e) service by any unauthorized person; or (f) other software used by Licensee which has not been provided by Licensor or for which the Licensed Software is not designed and licensed for operation; or (g) Third Party Software, as defined below; or (h) any other cause occurring after initial delivery of the media to Licensee unless caused directly by Licensor. The foregoing states the complete and entire remedies that Licensee has under this warranty. Licensor shall have no responsibility for any warranty claims made outside of the Warranty Period.
  8. DISCLAIMER OF WARRANTY. The Licensed Software cannot be tested in every possible operating environment, therefore Licensor does not warrant that the functions contained in the Licensed Software will meet Licensee’s requirements, that operation of the Licensed Software will be uninterrupted, or that the Licensed Software is error free. EXCEPT AS SET FORTH HEREIN AND TO THE EXTENT PERMITTED BY LAW, ALL OTHER WARRANTIES, EXPRESSED OR IMPLIED, STATUTORY OR OTHERWISE, INCLUDING, BUT NOT LIMITED TO, IMPLIED WARRANTIES OF MERCHANTABILITY, QUALITY AND FITNESS FOR A PARTICULAR PURPOSE ARE EXCLUDED ON THE PART OF LICENSOR AND ITS THIRD-PARTY SUPPLIERS. Licensee acknowledges that Licensee is responsible for the selection of the Licensed Software to achieve Licensee’s intended results and for the installation of, use of and results obtained from the Licensed Software.
  9. LIMITATION OF LIABILITY. ANY LIABILITY OF LICENSOR SHALL BE LIMITED IN THE AGGREGATE TO THE AMOUNTS PAID BY LICENSEE FOR THE LICENSED SOFTWARE. THIS LIMITATION APPLIES TO ALL CAUSES OF ACTION, INCLUDING WITHOUT LIMITATION BREACH OF CONTRACT, BREACH OF WARRANTY, NEGLIGENCE, STRICT LIABILITY, MISREPRESENTATION AND OTHER TORTS. THE LIMITATIONS OF LIABILITY DESCRIBED IN THIS SECTION 9 ALSO APPLY TO LICENSOR’S THIRD-PARTY SUPPLIERS. LICENSOR’S AND ITS THIRD-PARTY SUPPLIERS’ LIMITATIONS OF LIABILITY ARE NOT CUMULATIVE. Licensee’s remedies in this License Agreement are Licensee’s exclusive remedies.

    NEITHER LICENSOR NOR ANY OF ITS THIRD-PARTY SUPPLIERS SHALL BE LIABLE FOR ANY INJURY, LOSS OR DAMAGE, WHETHER INDIRECT, SPECIAL, INCIDENTAL OR CONSEQUENTIAL NOR FOR ANY LOST PROFITS, CONTRACTS, LOSS OF DATA OR PROGRAMS, OR THE COST OF RECOVERING SUCH DATA OR PROGRAMS, EVEN IF INFORMED OF THE POSSIBILITY OF SUCH DAMAGES IN ADVANCE.

    NEITHER THIS LICENSE AGREEMENT NOR ANYTHING IN THIS SECTION 9 SHALL PURPORT TO EXCLUDE OR RESTRICT THE LIABILITY OF LICENSOR OR ITS THIRD-PARTY SUPPLIERS TO ANY EXTENT NOT PERMITTED BY LAW.

  10. HIGH-RISK USES. The Licensed Software is not fault tolerant, nor designed, manufactured or intended for use in hazardous environments requiring fail-safe performance (including, without limitation, the operation of nuclear facilities, aircraft navigation or communication systems, air traffic control, direct life support machines, or weapons systems) in which failure of the Licensed Software could lead directly or indirectly to death, personal injury or severe physical or environmental damage. Licensor and its suppliers specifically disclaim any express or implied warranty of fitness for a particular purpose and shall have no liability for any use of the Licensed Software in any high-risk situations.
  11. OWNERSHIP. Licensor (or its affiliates) and where applicable Licensor’s third party suppliers have and will retain all ownership rights to the Licensed Software, together with any complete or partial copies thereof. Such ownership rights include without limitation all patent rights, copyrights, trademarks, trade secrets, service marks, related goodwill, and confidential and proprietary information relating thereto. This License Agreement does not convey any proprietary interest to Licensee with respect to the Licensed Software other than the license specified herein. Where the Licensed Software provided under this License Agreement contains or is derived from portions of materials provided by a third-party supplier under license to Licensor, Licensor has assumed responsibility for the selection of such materials and their use in producing the Licensed Software and any such third-party suppliers are intended beneficiaries of this License Agreement.
  12. NOTICE TO U.S. GOVERNMENT END USERS. The Licensed Software is provided to the United States Government with RESTRICTED RIGHTS and its supporting documentation is provided with LIMITED RIGHTS. Use, duplication, or disclosure by the United States Government is subject to the restrictions as set forth in FAR52.227-14 and DFAR252.227-7013 et seq. or the successor as appropriate. Manufacturer is Micro Focus (US), Inc., 9420 Key West Drive, Rockville, MD 20850 as or on behalf of Licensor.
  13. LICENSE FEES, PAYMENT, AND TERMS. Licensee agrees to pay the applicable end user license fees for the Licensed Software within thirty (30) days of the date of invoice or such earlier date as is specified in the Product Order. End user license fees are non-refundable except as provided in Section 7 above, or in the Specific Software Terms below, and shall be paid without deduction, including without limitation, of any withholding tax. End user license fees are exclusive of any applicable transportation charges, value added and other applicable taxes and duties and all such amounts shall be paid or reimbursed by Licensee. Late payments shall accrue interest at the rate of 1.5% per month compounded or, if lower, the maximum rate allowed by law.
  14. RELATED SERVICES. Licensee shall be responsible for obtaining and installing all proper hardware and support software (including operating systems) and for proper installation and implementation of and training concerning the Licensed Software. In the event that Licensee retains Licensor to perform any services with respect to the Licensed Software (for example: installation, implementation, maintenance, consulting and/or training services), Licensee and Licensor agree that such services shall be subject to Licensor’s then current standard terms, conditions and rates for such services unless otherwise agreed in writing by Licensor.
  15. THIRD PARTY SOFTWARE AND COMPONENTS. The Licensed Software may contain certain named third party software programs that Licensee shall license directly from the third party subject to such third party’s terms and conditions (for example Adobe Acrobat or Microsoft Internet Explorer) (“Third Party Software”). All Third Party Software is provided by the licensor of the Third Party Software and solely under such third party’s terms and conditions and not by Licensor. Therefore the obligations, duties and rights of Licensor and Licensee under this License Agreement do not apply to such Third Party Software. Additionally, Licensor has embedded certain run time or other elements provided by third party suppliers to Licensor (“Third Party Components”). Such Third Party Components may also be loaded on the Licensed Software media. Third Party Components are licensed to Licensee pursuant to this License Agreement. Licensee may only access Third Party Components of the Licensed Software in the course of using the Licensed Software. Licensee may not make or attempt any direct access to any such Third Party Components other than with the Licensed Software. The Third-Party Software is the property of its respective third party supplier to Licensor. Such third party suppliers own all copies of the Third-Party Software, however made. Licensee agrees not to contest the ownership of the Third Party Components nor use any trademark or service mark belonging to such third party suppliers. All limitations, restrictions and obligations applicable to the Licensed Software set forth in this License Agreement shall apply to Licensee’s use of the Third Party Components. Licensee agrees that such third party suppliers are intended third party beneficiaries of all terms and conditions of this License Agreement intended to protect intellectual property rights in the Licensed Software (including the Third Party Components) and limit certain uses thereof.
  16. PRIVACY. The Licensed Software may contain features which may allow Licensee to collect data from, control and/or monitor computers running the Licensed Software deployed by Licensee without notice to or knowledge by users of the Licensed Software. Licensee is solely responsible for, and assumes all liability with respect to, the collection of data with respect to its users of the Licensed Software including, without limitation, notifying such users and complying with all data collection, privacy and other regulations, laws, industry standards and rights of others applicable to any such activity. Licensee shall indemnify and hold Licensor harmless from and against any damages, claims, losses, settlements, attorneys' fees, legal fees and court costs and other expenses related to any such activities or any claims in connection therewith. To the extent permitted by law, by entering into this License Agreement, Licensee hereby expressly consents to (i) Licensor sending information to Licensee from time to time advertising the various products that Licensor provides, whether or not such products are provided under this License Agreement; (ii) the use of Licensee’s name in Licensor customer lists, promotional materials and/or press releases; and (iii) the collection and use by Licensor of information about the computer system on which the Licensed Software is installed (e.g. product version, serial number) for internal security and licensing purposes; Licensor does not use this information to identify individuals utilizing such software.
  17. MISCELLANEOUS. Licensor may assign this License Agreement to any member of Licensor’s group of companies or to a purchaser of the intellectual property rights in the Licensed Software, but otherwise neither this License Agreement nor any rights hereunder may be assigned (any change of control merger, sale or other transfer of all, or substantially all, of the assets of Licensee shall be included in the meaning of an assignment) nor duties delegated by either party, and any attempt to do so will be void. If Licensee acquires the Licensed Software in North America, the laws of the state of Maryland govern this License Agreement and it shall be subject to the exclusive jurisdiction of the courts of the State of Maryland. If Licensee acquires the Licensed Software in France, Germany or Japan, this License Agreement is governed by the laws of the country in which Licensee acquired the Licensed Software. In the rest of the world the laws of England govern this License Agreement. The aforesaid applicable law shall apply without regard to conflicts of laws provisions thereof, and without regard to the United Nations Convention on the International Sale of Goods. Other than for North American transactions, this License Agreement shall be subject to the exclusive jurisdiction of the courts of the country determining the applicable law as aforesaid. This License Agreement is in addition expressly made subject to any United States, United Kingdom or European Union laws, regulations and other restrictions regarding export or re-export of computer software and technology. Licensee agrees not to export or re-export any Licensed Software or derivative thereof in contradiction to any such applicable restriction. Except for the Product Order, this License Agreement is the complete and exclusive statement of agreement between the parties relating to the license for the Licensed Software and supersedes all proposals, communications, purchase orders, and prior agreements, verbal or written, including without limitation prior end user license agreements in relation to the Licensed Software between the parties and end user license agreements embedded in such Licensed Software. Upon Licensee’s properly authorized installation of any update and/or upgrade of any Licensed Software licensed hereunder, the license granted to such prior version and/or release shall terminate after a ninety (90) day transition period from such installation and only the license to such updated and/or upgraded Licensed Software shall continue. No employee, agent, or representative of Licensor has the authority to bind Licensor to any oral representation or warranty concerning the Licensed Software. No representation or statement not expressly contained in this License Agreement nor any supplement, modification, or amendment of this License Agreement will be binding on either party unless executed in writing by a duly authorized representative of each party to this License Agreement.

ANNEX 1

A. LICENSE OPTIONS FOR THE FOLLOWING SOFTWARE PRODUCTS:

All Micro Focus Application Development and Application Deployment products, including Net Express®, Net Express® with .NET, Net Express® for Eclipse, Server Express™, Server Express™ for Eclipse, Micro Focus Studio™ Enterprise Edition, Micro Focus Studio™ for COBOL Developers, Micro Focus Studio™ for ISVs, SOA Express, Micro Focus Server™ Enterprise Edition, Micro Focus Server ™ for COBOL, Micro Focus Server™ for .NET, Micro Focus Server ™ for SOA, Extend®, Relativity®, RM/COBOL®, Open PL/I, Open PL/I SQL, Open PL/I Run Time, ReUzeDeveloper, ReUze Server, XDBC, Database Connectors and Xcentrisity® including portions thereof, other products within the same product families and other Software Products where indicated by Licensor.

  1. Development License Options
    1. Named User License. Licensed Software provided under this License Option gives Licensee the right to install the Licensed Software on either (i) a single machine which may be accessed by the named end users for those licenses or (ii) on a single host machine or server (“Host Server”) which may be accessed by any of the named end users licensed. A Named User License means that only one named person can use each license and that named person has the right to unlimited access to the Licensed Software. A Named User License is not based on concurrent users, but instead on an actual named user basis. Licensor reserves the right at any time to require Licensee to provide a list of the named end users. Licensee may change a named end user provided that the change is made either permanently away from the named end user or temporarily to accommodate the use of the Licensed Software by a temporary worker while the named end user is absent, but in no event more than once every 30 days.
    2. Lines of Code License. Licensed Software provided under the Lines of Code license option requires, as a condition of use, that Licensee use a usage counter containing a credit for the number of lines of code that Licensee has purchased (“Usage Counter”). Licensee shall have sole responsibility for installing, configuring, and administering the Usage Counter. The Usage Counter will allow Licensee to create metering control files in order to track the number of lines of code which Licensee has purchased and which Licensee accesses. Licensee hereby acknowledges and agrees that unless Licensee can demonstrate to Licensor’s satisfaction that the Usage Counter was faulty on delivery to Licensee, Licensee is solely responsible for any lost, damaged, corrupted, destroyed, inaccurate or improperly used metering control files or metering transaction files, and in any such circumstance, may be required to pay an additional license fee on a line of code basis for lines of code which may have been already accessed and recorded using the Usage Counter. Each line of code which Licensee has accessed using the Licensed Software and which has been properly recorded using the Usage Counter may be re-accessed without the need to pay an additional license fee. However, if Licensee creates an additional line of code by updating a line of code source member which has already been accessed and metered by the Licensed Software, then Licensee will need to pay an additional license fee to access such additional line of code using the Licensed Software. Upon exhaustion of prepaid license fees, however, Licensee must purchase more lines of code in order to continue to use the Licensed Software on lines of code not yet accessed by the Licensed Software and properly recorded using the Usage Counter. Any prepaid license fees are non-cancellable and non-refundable.
  2. Deployment License Options
    1. User License for Authorized Users. Licensed Software provided under this License Option gives Licensee the right to install the Licensed Software on unlimited Host Servers for use by the total number of named individuals for whom Licensee has paid the applicable license fee. The Licensed Software may not be used or accessed by (a) individuals who are not named individuals; or (b) any other software or hardware device that does not require a named individual to use or access it. A named individual means an individual identified by Licensee by name who is authorized to use any device or other software program that may access the Licensed Software, either directly or indirectly through any other software program, regardless of how such access occurs or if such individual uses any hardware or software that reduces the apparent number of users who are using the Licensed Software, such as by using a terminal service. The Licensed Software may not be used or accessed by any other software or hardware device that does not require an individual to use or access it including, without limitation, batch processing (as defined in subsection (b)(ii) below). Licensor reserves the right at any time to require Licensee to provide a list of the named individual(s). Licensee may change a named individual provided that the change is made either permanently away from the named individual or temporarily to accommodate the use of the Licensed Software by a temporary worker while the named individual is absent, but in no event more than once every 30 days.
    2. Server License. There are two options for server-based licenses.
      1. Server License for Concurrent Users. Licensed Software provided under this License Option gives Licensee the right to install the Licensed Software on the designated Host Server specified in the Product Order for use by the maximum number of Concurrent Users for whom Licensee has paid the applicable license fee. Concurrent Users are individuals who are actively using any device or other software program that may access the Licensed Software either directly, or indirectly through any other software program, regardless of how such access occurs or if such user uses any hardware or software that reduces the apparent number of users who are using the Licensed Software, such as by using a terminal service. The Licensed Software may not be used or accessed by any other software or hardware device that does not require an individual to use or access it including, without limitation, batch processing (as defined in subsection (b)(ii) below). Licensee may change the designated Host Server to an equivalent Host Server for which Licensee has paid the applicable license fee. Licensee may only use the Licensed Software on or access the Licensed Software from one Host Server at any one time. Subject to the prior written consent of Licensor and to payment of additional license fees, Licensee may permit the public and/or Licensee’ customers to access and use the Licensed Software via the internet and/or Licensee’ terminals in connection with Licensee’ internal business purposes (for example to access internet banking from Licensee) but not for the public’ and/or Licensee’ customers’ own internal use.
      2. Server License for CPUs. Licensed Software provided under this License Option gives Licensee the right to install the Licensed Software on the designated Host Server specified in the Product Order and have the Licensed Software executed by up to the total number of Cores and other processing devices within such Host Server. The Host Server comprises the entire computer system (i.e. combined hardware) that will be running the Licensed Software (e.g. all CPUs, Cores, Blades and other processing devices running an operating system compatible with that which the Licensed Software is designed for and which are contained in, and/or can be accessed by, the same computer system, even if one or more of such CPUs, Cores, Blades or other processing devices are not accessing or running the Licensed Software). Each Core or other processing device on a multi-core or multi-processing device requires its own CPU license. For example a dual core single CPU Host Server will require a 2 CPU license (in the absence of any Blades or other processing devices). The Licensed Software is for use by an unlimited number of Licensee’s internal users, other software devices and hardware devices. A Server License for CPU is the only license authorized for use or access by Licensee for any batch processing. Batch processing is defined as the execution of one or more task, transaction or program by a computer system without the interaction of the end user with the Licensed Software while such tasks, transactions or programs are being executed by the system. Batch processing includes situations where a queue of jobs is processed as resources become available and is in contrast to transaction or interactive processing. Licensor reserves the right at any time to require Licensee to provide a specification of the Host Server. Licensee may change the designated Host Server provided that the total number of CPU and Core licenses required in the new Host Server does not exceed the total number of CPU and Core licenses designated in the Product Order. Licensee may only use or access the Licensed Software from one Host Server at any one time. Licensee is required to purchase a license for each Host Server that accesses or uses the Licensed Software either directly or indirectly through any other software program, regardless of how such access occurs, or if the Host Server, CPU or operator uses any hardware or software that reduces the apparent number of CPU, Cores, blades or other processing devices that are using the Licensed Software, such as by using a terminal service. Subject to the prior written consent of Licensor and to payment of additional license fees, Licensee may permit the public and/or Licensee’ customers to access and use the Licensed Software via the internet and/or Licensee’ terminals in connection with Licensee’ internal business purposes (for example to access internet banking from Licensee) but not for the public’ and/or Licensee’ customers’ own internal use.
  3. reUZE Mainframe Migration Licensing. Micro Focus reUZE software products may be licensed for installation and use solely with computer environments which meet the following criteria, provided Licensee complies with the restrictions set forth in this Subsection 3 in addition to those contained in the License Agreement. The licensing model in this Subsection 3 is only applicable to the reUZE software products and is not available for licensees who exceed one or more of the following limitations: (i) Mainframe Size Limitation: The Micro Focus reUZE software is expressly limited for use where Licensee’s entire mainframe estate (the “Licensee Mainframe System”) does not exceed a collective performance speed of 50 MIPS (million instructions per second). The Licensee Mainframe System shall include all mainframe systems owned, leased and/or operated (either by Licensee or a third party) by, or for the benefit of, Licensee (including but not limited to the system environment which the applicable application is being migrated from). The collective performance speed benchmark test shall be a collective measurement of the total possible performance of all such mainframe system(s). In the event that the Licensee Mainframe System exceeds a collective performance speed greater than 50 MIPS, Licensee shall not be permitted to utilize the reUZE software product and must contact Licensor for proper licensing of its computer system(s); (ii) CPU and Core Requirements: Notwithstanding Subsection 2(b)(ii) of this Annex 1A, a Deployment Product License option for a Server license for CPU shall be limited by the number of CPUs instead of the combination of Cores, Blades, CPUs and other processing devices; and (iii) Application Limitation: The reUZE software is expressly limited for use by Licensee solely with a specific application(s). Such application(s) shall be designated in writing in the Product Order.

B. LICENSE OPTIONS FOR THE FOLLOWING SOFTWARE PRODUCTS:

OnWeb™, RUMBA™, ViewNow™, Modernization Workbench™, Analyzer Express™, Analyzer Architect ™, Business Rule Manager ™, Enterprise View Express ™, Data Express™, Mainframe Express Enterprise Edition Data Express™, Modernisation Workbench Data Express®, OPTIMAL TRACE®, QACENTER®, QADIRECTOR®, QALOAD®, QARUN®, RECONCILE®, TESTPARTNER®, TRACKRECORD®, CARS®, TEST FACTORY™, DEVPARTNER® including portions thereof, other products within the same product families and other Software Products where indicated by Licensor.

  1. Workstation License Licensed Software provided under this License Option gives Licensee the right to install and use one copy of the Licensed Software on one stand-alone workstation. Licensee may not (i) install the Licensed Software on any networked workstation (e.g., a server) that allows more than one user to use a copy of the Licensed Software, or (ii) use the Licensed Software other than on one stand-alone workstation at a time. Licensee may transfer the Licensed Software to another stand-alone workstation and reactivate it for use on such other stand-alone workstation provided that the Licensed Software is removed and all copies of it are deleted from the stand-alone workstation from which it is transferred. Such transfers may not be undertaken more often than once every 30 days.
  2. Named User License Licensed Software provided under this License Option gives Licensee the right to install the Licensed Software on either (i) a single machine which may be accessed by the named end users for those licenses or (ii) on one or more host machines or servers which may be accessed by any of the named end users licensed. A Named User License means that only one named person can use each license and that named person has the right to unlimited access to the Licensed Software. A Named User License is not based on concurrent users, but instead on an actual named user basis. Licensor reserves the right at any time to require Licensee to provide a list of the named end users. Licensee may change a named end user provided that the change is made either permanently away from the named end user or temporarily to accommodate the use of the Licensed Software by a temporary worker while the named end user is absent, but in no event more than once every 30 days.
  3. Volume of Data Licensed Software provided under this option gives Licensee the right to utilize the Licensed Software with the volume of data (the number of terabytes) identified in the Product Order for each of the applicable modules or extensions licensed with the Licensed Software. Volume of data is measured as the original volume of Licensee’ production data to be processed utilizing the Licensed Software before any data reduction process by the Licensed Software or otherwise has been applied. The same data source (defined as a database table or a file) and data may be processed multiple times without counting it more than once towards the total volume of data processed by the Licensed Software, however any additional data and/or data sources (that is, new or increased amounts to the original data source) are counted cumulatively towards such total volume of data number.
  4. Concurrent User License Licensed Software provided under this License Option gives Licensee the right to install and use one copy of the Licensed Software on the designated Host Server (as defined above) specified in the Product Order for use by the maximum number of Concurrent Users (defined above) for whom Licensee has paid the applicable license fee. Licensee may connect any number of workstations to the Host Server; however, the total number of users who may access and use the Licensed Software at any given time is limited by the number of Concurrent Users expressly authorized by Licensor in the Product Order. The total number of Concurrent Users is one (1), unless Licensor expressly authorized Licensee to connect more than one Concurrent User.
  5. Concurrent Users with Load Sharing Configuration Licensed Software provided under this License Option gives Licensee the right to install and use one copy of the Licensed Software on each server supported by a single load sharing device. Licensee may connect any number of workstations to the load sharing device and its connected servers; however, the total number of users who may access and use the Licensed Software at any given time is limited by the number of Concurrent Users expressly authorized by Licensor in the Product Order. The total number of Concurrent Users is one (1), unless Licensor expressly authorized Licensee to connect more than one Concurrent User.
  6. Server Based Thin Client License Licensed Software provided under this License Option gives Licensee the right to install and use one copy of the server portion of the Licensed Software on one server. If installation of the server portion of the Licensed Software requires a thin client component to be installed, Licensee may install and use one copy of the thin client portion of the Licensed Software on one workstation per each thin client license that is specified in the Product Order and for which Licensee has paid the applicable license fee.
  7. Processor Capacity License Licensed Software provided under this License Option gives Licensee the right to install the Licensed Software on up to the total number of Cores and other processing devices within each CPU on the designated Host Server specified in the Product Order. Licensee may install an unlimited number of copies of the Licensed Software on single-user computers to allow communication with the designated single Host Server. Licensee may not reinstall or operate the Licensed Software on multiple host processors without Licensor’s prior written consent and payment of all applicable fees.

C. LICENSE OPTIONS FOR THE FOLLOWING SOFTWARE PRODUCTS:

CaliberRM™, TeamDefine™, Together®, StarTeam®, Tempo™, TeamDemand®, TeamFocus™, TeamAnalytics®, TeamInspector™, SilkCentral®, Test Manager™, SilkTest®, Silk4J™, SilkPerformer® including portions thereof, other products within the same product families and other Software Products where indicated by Licensor.

Regardless of the type of license, each copy of the Licensed Software contains (i) software that provides services on a computer called a server (“Server Software”) and (ii) software that allows a computer or workstation to access or utilize the services provided by the Server Software (“Client Software”). For any type of license acquired, Licensee may install one copy of the Server Software on a single computer (the computer running the Server Software shall be referred to as the “Server”). The number of Client Software copies that may be installed is determined by the type of license acquired as set forth below.

  1. Named User A Named User license means Licensee may allow only one (1) designated person in Licensee’s organization (“Named User”) to use the Licensed Software per Named User license purchased (each, a “Named User License”). The foregoing Named User Licenses shall be for access and use, only by the equivalent number of Named Users licenses purchased. For each Named User, Licensee may install the Client Software on up to five (5) computers provided that the Named User is the only individual permitted to use the Licensed Software.
  2. Concurrent User A Concurrent User License means Licensee may install the Client Software on a reasonable number of computers or machines, provided that the Licensed Software is used only by as many concurrent users at any given moment in time as Licensee has purchased concurrent licenses and provided further that Licensee’s use of the Licensed Software (both Client Software and Server Software) is only on computers or machines located in the Territory and accessed only by users physically located in the Territory. The foregoing license shall be for access and use, only by the equivalent number of concurrent users for whom Licensee has paid the applicable license fees. As used in this Section, use or in use means that the Licensed Software is "in use" on a computer or machine when it is loaded into random access memory (RAM) of that computer and “access” means the ability to use, copy or operate the Licensed Software . The Licensed Software may not be shared or used concurrently on computers or machines located outside of the Territory or in such a way to enable use or access by users located outside the Territory. ‘Territory’ means the geographical area in which the Licensed Software may be used. The use in the Territory shall be subject to applicable export restrictions. Territory may be any one, and only one, of the following three geographic areas: Americas Territory, EMEA Territory or AsiaPac Territory each as defined below. The Territory shall be based on the primary business location of the Licensor, unless otherwise specified in a Product Order. The geographic Territories are: (i) ‘Americas Territory’ including and limited to those geographical areas found within the boundaries of North and South America. (ii) ‘Europe, Middle East and Africa Territory’ or ‘EMEA Territory’ including and limited to those geographical areas found within the boundaries of Europe, Middle East and Africa, including all the countries which are part of the European Union, Switzerland, Norway, Jersey, Guernsey, Isle of Man, Iceland, Monaco, Andorra, Liechtenstein, San Marino, Albania, all the countries of the former Yugoslavia, Israel, Turkey, countries of the Arab Middle East, all the countries of the former Soviet Union, Africa, Madagascar, and the Islands of the South Indian Ocean. (iii) ‘Asia Pacific Territory’ or ‘AsiaPac Territory’ including and limited to those geographical areas found within the boundaries of Asia and Australia/Pacific including South Korea, Japan, China, Taiwan, Hong Kong, and Macau India, Maldives, Pakistan, Myanmar, Nepal, Bhutan, Bangladesh, Thailand, Laos, Cambodia, Vietnam, Singapore, Malaysia, Indonesia, East Timor, the Philippines, Brunei, Papua New Guinea, the Pacific Ocean Islands, Australia, and New Zealand.
  3. Virtual User (SilkPerformer only) A "Virtual User" represents a simulation of a particular individual user executing a transaction or sequence of operations. Virtual Users are further qualified by class, and may be licensed on either a Node-Locked or Concurrent User basis. If a Virtual User is licensed on a Node-Locked basis (as provided below) (“Node-Locked Virtual User License”), that Virtual User may be associated with a Multi-Machine Controller (“MMC”) component of the Licensed Software only on the particular system for which the Virtual User is licensed. If a Virtual User is licensed on a Concurrent User basis (as provided below) (“Concurrent Virtual User License”), then that Virtual User may be associated with any licensed instantiation of a MMC at any one time, but during the operation of that instantiation, may not be associated with any other instantiation of a MMC at the same time. By way of example; if 50 Virtual Users are licensed on a Concurrent User basis, Licensee may simultaneously associate all 50 with one MMC instantiation; or simultaneously may associate 20 with one MMC instantiation and 30 with a second MMC instantiation; but could not, for example, simultaneously associate 30 with each of the two MMC instantiations. A "Web Virtual User" is a Virtual User limited to performing actions in basic web-based applications making use of the common web protocols set forth in the accompanying release notes. A "Standard Virtual User" is a Virtual User that has all of the rights of a Web Virtual User, and that may additionally make use of certain client-server, database and other protocols as set forth in the accompanying release notes. A "Premium Virtual User" is a Virtual User that has all of the rights of a Standard Virtual User, and that may additionally make use of certain protocols for packaged third-party applications and complex enterprise technologies as set forth in the accompanying release notes. Node-Locked Virtual User Licenses and Concurrent Virtual User Licenses are available for the MMC or Service Analysis Module (“SAM”) component of the Licensed Software. A Node Locked Virtual User License means Licensee may use the Licensed Software in object code form on a production basis on one (1) computer and to permit the Licensed Software to be used and accessed at any one time by no more than the number of users indicated in the applicable Product Order (each a "Node Locked User"). If no number is indicated, the number shall be 1. A Concurrent Virtual User License means the same as the Concurrent User license option above.

Notes (i) Multiplexing software: The use of one or more external tools, including multiplexors or replicators, to reduce the number of users directly connected to the Licensed Software shall not exempt Licensee from acquiring licenses for all users. For example, use of multiplexing or connection pooling software or hardware to reduce the number of users directly connected to the Licensed Software, the number of Named Users or Concurrent Users within Licensee’s organization using the Licensed Software shall be measured as the number of distinct inputs to the multiplexing or connection pooling front end and Licensee shall purchase the equivalent number of Named User or Concurrent User Licenses. If Licensee uses replicator software, Licensee may not use the Licensed Software or share licenses in any way not explicitly provided for in this License Agreement. (ii) APIs: Any user of any third party application that calls any Licensed Software application programming interfaces (“Product APIs”) must have a valid license to connect to the Licensed Software. Licensee shall not, and shall not allow others, to reverse engineer, decompile, or disassemble the Product APIs. Commercial distribution of any products that include Product APIs requires a separate distribution license and such license is not granted by this License Agreement. (iii) TeamInspector: TeamInspector is licensed on a Named User basis only. (iv) Connectors: A license purchased for this Licensed Software allows use of such software in any quantity solely in conjunction with TeamAnalytics that is licensed and ordered separately.

D. LICENSE OPTIONS FOR THE FOLLOWING SOFTWARE PRODUCTS:

All Application Middleware products including AppServer™ and VisiBroker® including portions thereof, other products within the same product families and other Software Products where indicated by Licensor.

  1. Development License Options
    1. Named User: For each Named User License, Licensee may install and execute the Licensed Software on one (1) computer for use by one (1) person in Licensee’s organization solely to develop, compile (including byte code compile), and test, in source or object code form, Licensee’s own application programs and other works ("Works") designed to work with the Licensed Software. Unless Licensee has purchased a valid Deployment License as described below, Licensee may not deploy or use the Licensed Software on a production basis. The Licensed Software contains certain time-out features designed to prevent the Licensed Software from being deployed in a runtime environment for longer than a specified period without Deployment License keys. Deployment License keys will be provided to Licensee at such time as Licensee purchases the requisite Deployment Licenses. WORKS CREATED USING THE LICENSED SOFTWARE MAY REQUIRE THE LICENSED SOFTWARE IN ORDER TO RUN. WITHOUT THE REQUISITE DEPLOYMENT LICENSE KEYS, THE LICENSED SOFTWARE WILL BE DISABLED AND THOSE WORKS MAY NO LONGER RUN. LICENSEE SHOULD THEREFORE TAKE PRECAUTIONS TO AVOID ANY LOSS OF DATA THAT MIGHT RESULT.
  2. Deployment License Options
    1. Concurrent User: For each Concurrent User Deployment License, License may install the Licensed Software, in executable form only, on a server accessed and used by multiple users over a network, provided that the Licensed Software is used only by as many concurrent users at any given moment in time as Licensee has purchased concurrent licenses and provided further that use of the Licensed Software is only in the Territory and accessed only by users physically located in the Territory. The foregoing license shall be for access and use, only by the equivalent number of concurrent users for whom Licensee has paid the applicable license fees, solely to create, compile (including byte code compile), test and deploy, in source or object code form, Works. As used in this Section, use or in use means that the Licensed Software is "in use" on a computer or machine when it is loaded into random access memory (RAM) of that computer. The Licensed Software may not be shared or used concurrently on computers or machines located outside of the Territory or in such a way to enable use or access by users located outside the Territory.
    2. Server/CPU: For each Server/CPU Deployment License Licensee may install and execute the Licensed Software in object code form on a production basis on one (1) server hardware unit that is operating the platform designated in the applicable Product Order and that has no more than the number of CPUs designated in the applicable Product Order and to permit the Licensed Software as so installed to be accessed at any one time by an unlimited number of concurrent users. Licensee may not install or execute the Licensed Software on any type of device that has a greater number of CPUs and Licensee may not, under a given Server/CPU Deployment License, install or execute the Licensed Software on more than one (1) computer. Licensee may use and deploy the Licensed Software either as a Server or as a Client. Use of the Licensed Software as a "Server" means to manage and control the automated exchanges of information with one or more remote computers through various telecommunications channels. Use of the Licensed Software as a "Client" means to operate the Licensed Software on a computer to facilitate communications with the Server. The Client shall not act as or perform the functions of a Server. A Client may make only a maximum of 10 concurrent call backs. A Client shall not have POA (Portable Object Adapter) policies with the following values: LifespanPolicyValue.PERSISTENT; RequestProcessingPolicyValue.USE_SERVANT_MANAGER; RequestProcessingPolicyValue.USE_DEFAULT_SERVANT Subject to these restrictions and limitations and any additional restrictions or limitations that may appear in the applicable Product Order, Licensee may install the Client on an unlimited number of computers. Licensee receives no right to deploy Clients without the purchase of a Server/CPU Deployment License.
    3. Backup Server License Option for AppServer and VisiBroker Licensee may install the Licensed Software on a single backup server and use the Licensed Software in object code form solely for backup or disaster recovery purposes (“Backup Server License”). Licensee may not use the Licensed Software on a production basis except during periods when one or more copies of the Licensed Software for which Licensee has purchased a Deployment License are nonfunctional, and, in such event, only in accordance with the terms of the Deployment License.
    4. Standby Server License Option for AppServer and VisiBroker Licensee may install the Licensed Software on a single standby server and use the Licensed Software in object code form solely in a standby, non-production mode for use in the event the primary server fails (“Standby Server License”). Licensee may not use the Licensed Software on a production basis under a Standby Server License except during periods when one or more copies of the Licensed Software for which Licensee has purchased a Deployment License are nonfunctional, and, in such event, only in accordance with the terms of the Deployment License.

E. OTHER LICENSE OPTIONS

  1. System Partitioning /LPAR/IFL Licensed Software may be licensed for installation and use on computer systems which incorporate logical partitioning (LPAR), and/or Integrated Facility for Linux (“IFL”) provided such rights have been expressly granted to Licensee by Licensor in writing and Licensee complies with the restrictions set forth in this Section. The licensing models in this Section 1 are only applicable to Server type licenses and are not available for computer systems where system resources (e.g. Cores/CPUs) may be scaled down or varied (e.g. “Pay Per Use” or “Pay Per Forecast” models).
    1. Logical Partitioning (LPAR): The licensing requirements of computer systems (e.g. a Host Server) which incorporate hard and/or soft partitioning shall have their licensing requirements determined as follows:
      1. Hard Partitioning: Hard partitioning is established by using a hard physical partition to physically segment a single larger server so that the Host Server utilizing the Licensed Software is a separate and distinct smaller system (that is, each separate system acts as a physically independent, self-contained server with its own CPUs, operating system, separate boot area, memory, input/output subsystem and network resources). Examples of such hard partitioning include: Dynamic System Domains (DSD) -- enabled by Dynamic Reconfiguration (DR), Solaris 10 Containers (capped Containers only), LPAR (adds DLPAR with AIX 5.2), Micro-Partitions (capped partitions only), vPar, nPar, Integrity Virtual Machine (capped partitions only), Secure Resource Partitions (capped partitions only), and Static Hard Partitioning. For computer systems where hard partitioning has been employed to create the Host Server being utilized to operate the Licensed Software, such Host Server shall be licensed pursuant to the terms and conditions set forth in this Section 1 as if such Host Server where a separate and distinct computer system. For example, where the total computer system has 8 Cores/CPUs but only 4 Cores/CPUs have been hard portioned to use the Licensed Software, Licensee shall only be required to license such 4 Cores/CPUs on such hard partitioned system.
      2. Soft Partitioning: Soft partitioning is established by using the computer systems operating system resource manager to segment and limit the number of Cores/CPUs where the Licensed Software is running by creating areas where processor resources are allocated and limited within the same operating system. Examples of such soft partitioning include: Solaris 9 Resource Containers, AIX Workload Manager, HP Process Resource Manager, Affinity Management, Oracle VM, and VMware. For computer systems where soft partitioning has been employed to create the Host Server being utilized to operate the Licensed Software, such Host Server shall be licensed pursuant to the terms and conditions set forth in this Section 1 as if such Host Server where a separate and distinct computer system but the Cores/CPU required to be licensed shall be an “expected” Cores/CPU number calculated as the ratio of the number of Cores/CPUs soft partitioned as a percentage of the entire computer system’ Cores/CPUs, increased by ten percent (10%). For example, on an 8 Core/CPU computer system where soft partitioning has been utilized such that only 4 Cores/CPUs are allocated to use the Licensed Software, a Server License fee charge equal to 60% of the total computer system Cores/CPUs would be required (50%+10% = 60% of an 8 Core/CPU system license fee).
    2. Integrated Facility for Linux (“IFL”): An Integrated Facility for Linux or IFL Host Server is established by using a dedicated Host Server where the IFL Host Server is isolated from general use and is only capable of utilizing the Linux operating system and running Linux applications and cannot run other operating systems or applications. For IFL Host Server computer systems being utilized to operate the Licensed Software, such IFL Host Server shall be licensed pursuant to the terms and conditions set forth in this Section 1 as if such IFL Host Server were a separate and distinct computer system. For example, where the total computer system that has 8 Cores/CPUs but the IFL Host Server is a 4 Cores/CPUs IFL computer system and the IFL system is the only system using the Licensed Software, Licensee shall only be required to license such 4 Cores/CPUs on such IFL Host Server system.
    3. LPAR and IFL Host Server Verification: Licensee shall provide to Licensor, upon commencement of this License Agreement and at such other times as Licensor may reasonably request, confirmation that Licensee’s computer systems comply with the LPAR and/or IFL license requirements set forth in Subsections 1(a) and (b) above. Such confirmation shall be signed by a director or officer of Licensee and shall be accompanied by all information as Licensor reasonably requires to verify that Licensee is utilizing the Licensed Software in compliance with the terms and conditions of the License Agreement. The foregoing is in addition to Licensor’s rights under Section 3 of the License Agreement.
  2. Evaluation License Option Licensed Software provided under this License Option gives Licensee a term license to use the Licensed Software within Licensee’s organization during the evaluation term specified in writing by Licensor, solely for evaluation and testing purposes on a single computer system and not for development, commercial, or production purposes. Licensee may not reproduce or distribute the Licensed Software. Licensee’s results of benchmark or other performance tests run on or using the Licensed Software may not be disclosed to any third party without Licensor’s prior written consent. At any time during the evaluation term or upon completion thereof, Licensee may, upon written notification to Licensor and payment of the applicable license fee, replace the evaluation license with a license to use the Licensed Software pursuant to one of the other applicable options listed in Annex1. In the absence of such notification by Licensee, the evaluation license shall automatically terminate at the end of the evaluation term and Licensee shall return, or, if Licensor so directs, delete and destroy all such Licensed Software and provide Licensor with written confirmation of such deletion and destruction being completed. Licensor may, in its sole discretion, grant Licensee an extension to the evaluation term subject to receiving a written request and reasons for such request from Licensee prior to expiration of the evaluation term. Licensor will specify any such agreed extension in writing to Licensee. Licensed Software provided by Licensor free of license fee charge shall be deemed to be provided pursuant to this Evaluation License Option unless otherwise agreed in writing. In the absence of any contrary period specified in writing by Licensor, the evaluation term shall be deemed to be thirty (30) days. In relation to Licensed Software provided pursuant to this Evaluation License Option, this Section shall prevail over any contrary provisions set forth in this License Agreement.
  3. Test License Option Licensed Software provided under this License Option gives Licensee a limited license to use the Licensed Software solely for Licensee’ internal testing purposes on a single computer system. At no time may Licensee use the Licensed Software for development, commercial, or production purposes, nor may Licensee reproduce or distribute the Licensed Software or any software application programs created with it. The applicable license fee for this License Option will be determined by the access or use to be tested. For example, batch process testing will require the payment of the applicable license fee for a Licensor server license for CPU. Licensee’ results of benchmark or other performance tests run on or using the Licensed Software may not be disclosed to any third party without Licensor’s prior written consent. If Licensee uses the Test Licenses for any purpose other than for Licensee’ internal testing purposes, the Test License shall terminate automatically and without notice. Upon such termination, Licensee may convert the terminated Test License to a standard license type listed above by paying the applicable conversion fee. In relation to Licensed Software provided pursuant to this Test License Option, this Section shall prevail over any contrary provisions set forth in this License Agreement.

ANNEX 2 SPECIFIC SOFTWARE TERMS

The following terms and conditions apply to the applicable Licensed Software products named below and supersede any conflicting terms and conditions set forth elsewhere in this License Agreement:

ALL VERSIONS OF NET EXPRESS®, SERVER EXPRESS™, MICRO FOCUS STUDIO™, MICRO FOCUS SERVER™, EXTEND®, RELATIVITY®, RM/COBOL® , REUZE DEVELOPER, OPEN PL/I AND XCENTRISITY®. For this Licensed Software Licensee has the option to use the Licensed Software licenses purchased either (i) for internal development purposes, or (ii) to reproduce and distribute internally, as both options are described in Annex 1, any software application program created by Licensee using any such Licensed Software product, in whole or in part, as a part of Licensee’ own application software product (“Licensee Application Software”). Where the foregoing option (ii) is selected it is contingent upon Licensee (a) including Licensor’s copyright notice for the Licensed Software on the product label and as a part of the sign-on message for such Licensee Application Software product; and (b) indemnifying, holding harmless and defending Licensor and its third-party suppliers from and against any claims or lawsuits, including attorneys’ fees, legal fees and court costs that arise out of, or result from, the use or distribution of such Licensee Application Software. Licensee can only reproduce and distribute Licensee Application Software to third parties after entering into a separate distribution agreement with Licensor. Usage and distribution of the Licensed Software arises both by the explicit distribution of any Licensee Application Software and by the implicit distribution and usage of any such functionality when linked into a software application program. The grant of license for the Licensed Software does not permit Licensee to either use or reproduce and distribute any files supplied as part of the Licensed Software in order to create a compiler, interpreter or runtime support product. Licensor offers specific production licensing options for distribution to third parties which vary depending upon the license fees paid by Licensee and Licensee should contact its Licensor sales representative for more details.

MAINFRAME EXPRESS® ENTERPRISE EDITION.

  1. Where Mainframe Express Enterprise Edition (all versions and editions including earlier versions such as Mainframe Express) is the Licensed Software, Mainframe Express Enterprise Edition may only be used for development purposes. Licensee may not use Mainframe Express Enterprise Edition for production purposes nor utilize or access any of the Mainframe Access portions of the Licensed Software from any Licensed Software product licensed separately, unless the Licensor product, Mainframe Access, has also been separately licensed from Licensor, in which case, the Mainframe Access product included as part of Mainframe Express Enterprise Edition may be installed on the number of host (mainframe) machines needed to support the number of authorized end-users of Mainframe Express Enterprise Edition.
  2. Where Mainframe Express Enterprise Edition is the Licensed Software, the Licensed Software will contain Component Generator. In order to use the components created using Component Generator, Licensee must pay a license fee. Upon payment of such license fee, Licensor grants Licensee a personal, non-exclusive, non-transferable license to use the components according to the type of license granted. Licensor has and will retain all ownership rights to any application source code generated by a template, wizard or similar functionality, (“Generated Source Code”) supplied as part of the Component Generator including without limitation all patent rights, copyrights, trademarks, trade secrets, service marks, related goodwill, and confidential and proprietary information relating thereto. For the avoidance of doubt, Generated Source Code does not include Application Server Files. Licensee shall have and retain all ownership rights to Licensee’s implementation of the Generated Source Code, provided that nothing in this Section shall be construed as in any way granting Licensee any right to limit or prevent: (i) Licensor from licensing any of its existing or future Licensed Software or providing any of its existing or future services to third parties; or (ii) Licensor or any other users of the Component Generator from generating and using identical or similar implementations of Generated Source Code. Licensor grants Licensee a perpetual, transferable, non-exclusive, royalty-free right to reproduce and distribute the Generated Source Code in object code form together with any implementation Licensee make thereto as a part of Licensee’s application of the Licensed Software product created using the Component Generator and that such Licensee application of the Licensed Software product adds significant and primary functionality to the Generated Source Code.

ALL VERSIONS OF MICRO FOCUS STUDIO, REUZE DEVELOPER AND NET EXPRESS. For this Licensed Software

  1. Redistribution of Internet Shortcut Support DLL (URL.DLL) in Microsoft Win32 SDK. To obtain rights to distribute file "URL.DLL" supplied as part of the Microsoft Win32 SDK that may be included with the Licensed Software, Licensee must print out, sign and return the Microsoft Win32 SDK End User Licensee Software License Agreement (located at \license\win32sdk.txt in the Microsoft Win32 SDK) to Microsoft Corporation, Win32 SDK Program, Building 5-2, One Microsoft Way, Redmond, Washington 98052-6399. URL.DLL may be included as part of a future version of Windows or Windows NT. Upon notification by Microsoft of its inclusion of URL.DLL in Windows or Windows NT, Licensee shall upgrade its application so that it no longer contains URL.DLL, and within a reasonable period after such time, but no later than six (6) months, cease distribution of URL.DLL.
  2. Use of Microsoft Visual Studio Technology and Visual Studio .NET Premier Partner Edition, including VSIP-SDK (“VSN Software”). The VSN Software is provided by and governed under the VSN Software End User License Agreement (“VSN EULA”) enclosed with the Licensed Software. Licensee must agree to be bound by the VSN EULA before use of the VSN Software. Licensee shall not use or enable others to use the information/content of the VSIP-SDK to enable any development environment other than Visual Studio .NET to host packages that use the interfaces documented in the VSIP-SDK or use or enable others to develop or distribute extensions to or wrappers for the VSN Software, or the interfaces between the Licensed Software and the VSN Software.

ACADEMIC EDITIONS/USERS. Where Licensed Software is licensed under Licensor’s ACTION Program, in addition to the above terms and conditions:

  1. Licensee shall not use the Licensed Software for any purpose other than for education, training or academic research activities.
  2. Licensee shall not copy the Licensed Software, nor shall Licensee distribute, transfer or assign the Licensed Software without specific permission from Licensor.
  3. License management: If Licensee is the academic institution using the Licensed Software for teaching purposes, Licensee will manage all student licenses through a license server provided by Licensor in accordance with guidelines provided by Licensor. Licensee agrees to provide reports describing the number of licenses Licensee has issued in each period upon Licensor’s request.
  4. Where CALIBERRM™, TEAMDEFINE™, TOGETHER®, STARTEAM®, TEMPO™, TEAMDEMAND®, TEAMFOCUS™, TEAMANALYTICS®, TEAMINSPECTOR™, SILKCENTRAL®, TEST MANAGER™, SILKTEST®, SILK4J™, SILKPERFORMER® APPSERVER™ OR VISIBROKER is the Licensed Software, the Licensed Software may be used solely for Licensee’s personal use in providing or receiving instruction within the limited scope of guided computer programming and/or software training course(s) in which Licensee is a direct and personal participant, either as student or instructor (“Course(s)”). The Licensed Software may only be used with other participants of the Courses and then only for educational or training purposes. The Licensed Software may not be used for any commercial, business, governmental or institutional purpose of any kind, except to the extent Licensee is an instructor teaching a Course.

NET EXPRESS PERSONAL EDITION. Where Net Express Personal Edition is the Licensed Software, in addition to the above terms and conditions:

  1. Licensee shall not to use the Licensed Software for any purpose other than for personal educational and non-commercial activities. The Licensed Software may not be used for training or teaching purposes.
  2. Licensee shall not use the Licensed Software to compile source code for applications of more than two thousand, two hundred (2200) lines of procedural code (exclusive of lines containing comments and/or blanks) in any one (1) application or to deploy such application to any other machine.
  3. Licensee shall not copy the Licensed Software, nor shall Licensee distribute, transfer or assign the Licensed Software without specific permission from Licensor

ALL VERSIONS OF MICRO FOCUS STUDIO, NET EXPRESS, AND SERVER EXPRESS. This Licensed Software may include or generate limited licenses for Micro Focus Server, Application Server and/or Enterprise Server. If such licenses are included or generated, these limited licenses are provided solely for use by the Named User of the Licensed Software in order to unit test an application developed with any version of Micro Focus Studio, Net Express, or Server Express on the server used to develop the application and may not be used for system testing, production or deployment. Any use of this limited license outside of the development and unit testing of such applications is outside the scope of the license.

ALL VERSIONS OF MICRO FOCUS STUDIO, REVOLVE® ENTERPRISE EDITION, MAINFRAME EXPRESS, NET EXPRESS, AND MICRO FOCUS LICENSE SERVER. Licensee may use the Micro Focus License Server that accompanies the Licensed Software to generate request or access codes for Licensee’s use of the Licensed Software. Licensee may not use the Micro Focus License Server to generate multiple-user request of access codes for the Licensed Software unless Licensee has paid the appropriate license fees for each authorized user accessing the Licensed Software.

MICRO FOCUS STUDIO FOR COBOL DEVELOPERS AND MICRO FOCUS STUDIO ENTERPRISE EDITION. Where Micro Focus Studio is the Licensed Software, Licensee may utilize the Licensed Software on both the Windows platform and one UNIX platform, which will be designated on the Product Order. Use of the Licensed Software on a different UNIX platform than originally licensed or on more than one UNIX platform will require additional licenses and the payment of applicable license fees. Licensee may install the Licensed Software on more than one machine or Host Server, so long as the Licensed Software is only used by the same named user on each machine or Host Server.

MICRO FOCUS REVOLVE ENTERPRISE EDITION. Where Micro Focus Revolve Enterprise Edition is the Licensed Software, Licensee may only utilize the Licensed Software for its own internal benefit and may not use the Licensed Software to process third-party code or to generate reports to be delivered to a third-party for that third party’s benefit without first entering into a separate agreement with Licensor.

MICRO FOCUS DATA EXPRESS™. Where Micro Focus Data Express is the Licensed Software Licensee may utilize both the Data Subset Extraction and the Data Masking modules, however, Licensee may only use other modules that are expressly listed in the relevant Product Order and for which Licensee has paid the separate relevant license fee.

MICRO FOCUS ENTERPRISE VIEW™. Where Micro Focus Enterprise View is the Licensed Software, Licensee may only use those additional modules that are listed in the Product Order and for which Licensee has paid a separate license fee. Where a Micro Focus Enterprise View module has language-specific capability, any licensed languages shall be listed in the Product Order. Support for additional languages is subject to an additional license fee.

MICRO FOCUS ENTERPRISE VIEW - RAPID ASSESSMENT OPTION. Micro Focus Enterprise View – Rapid Assessment Option is provided to Licensee on a fixed term license basis only. The start and ending dates of the term will be set forth in the Product Order. Unless otherwise stated in the Product Order, Micro Focus Enterprise View – Rapid Assessment Option is licensed on a “Line of Code” basis.

MODERNIZATION WORKBENCH SOFTWARE DEVELOPMENT KIT. This Licensed Software may only be utilized for the purpose of creating applications designed to operate with Modernization Workbench. The SDK does not contain any redistributable code and Licensee is not permitted to distribute any part of the SDK. No support is provided for the SDK.

XCENTRISITY BUSINESS INFORMATION SERVER. This Licensed Software is licensed on a concurrent user basis for local area network usage (“LAN”) or wide area network usage (“WAN”). A LAN license may only be installed and used on one server, whereas a WAN license may be installed and used on any number of servers, both subject to the number of concurrent users licensed.

OPTIMAL TRACE, QACENTER, QADIRECTOR, QALOAD, QARUN, RECONCILE, TESTPARTNER, TRACKRECORD, CARS, TEST FACTORY, DEVPARTNER. This Licensed Software may include technology for monitoring authorized use, including the policy files and license keys required to use the Licensed Software (the “License Authorization Server” or “LAS”). The LAS may be installed on a single-specified computer system at the specific site for which Licensee has contracted (the “Designated System”). The LAS, or any part thereof, may not be transferred from the Designated System. Regardless of the installation of the LAS, Licensee must remain compliant with the terms in this License Agreement (including without limitation any license restrictions and number of users permitted pursuant to this License Agreement). The LAS cannot be used or installed on a Virtual Machine.

Licensee may not transfer, ship or use this Licensed Software outside the country in which it was originally licensed to Licensee. Only one copy of the Licensed Software may be installed on a single computer at any one time unless: (A)The Software is designed and intended by Licensor for use in a shared network client server environment, as set forth in the Documentation; or (B) Licensee has purchased a license for each individual user of the Licensed Software and/or for each computer that will have access to the Software. Except for Optimal Trace Enterprise Edition, in the event the Software is designed and intended by Licensor for use in a shared network client server environment, Licensee may only install the Software on a single server.

The following shall only apply if the Licensed Software is device driver development software, used by Licensee to develop application or device driver programs (“User Software”), as specified in the Documentation. The User Software may include run-time components (“RTCs”) that have been extracted by the Software from the library files of the Software, programs to remotely test the User Software, and compiled code examples. These RTCs, examples, and programs are specifically designated as redistributable in the Documentation. Licensee has a worldwide, non-exclusive, royalty-free, restricted license to: (A) modify, compile and distribute the driver code examples; (B) distribute the remote testing program for testing purposes only; (C) embed the RTCs and driver code examples in its User Software, in object code form only; and (D) reproduce and distribute the RTCs and driver code examples embedded in its User Software, in object code form only provided that with respect to each of (A) – (D) inclusive (i) Licensee distributes the RTCs and driver code examples only in conjunction with and as a part of its User Software; (ii) Licensee will be solely responsible to anyone receiving its User Software for any updates, technical and other support obligations, and any other liability which may arise from the distribution of its User Software; (iii) Licensee does not use Licensor’s or its licensors' names, logos, or trademarks to market or distribute its User Software; (iv) Licensee includes Licensor’s and its licensors' copyright and/or proprietary notices and legends within the executable images of its User Software and on Licensee's software media and documentation; and (v) Licensee agrees to indemnify, hold harmless and defend Licensor and its licensors from and against any claims or lawsuits, including attorneys’ fees, that arise or result from the use or distribution of its User Software.

OPTIMAL TRACE, QACENTER, QADIRECTOR, QALOAD, QARUN, QUALITY MANAGER, RECONCILE, TESTPARTNER, TRACKRECORD, TEST FACTORY, DEVPARTNER. This Licensed Software may be used in a Virtual Machine only where licensed for concurrent users. In addition this Licensed Software may be used on any operating system on which the Licensed Software is capable of operating and which is supported by Licensor.

QALOAD. This Licensed Software may be licensed on a Virtual User basis. A "Virtual User" represents a simulation of a particular individual user executing a transaction or sequence of operations. QALoad Virtual users are pooled for use by the total number of licensed QALoad Conductors and one or more licensed QALoad Conductors may use some or all licensed Virtual Users. Virtual Users may be used across all support protocols (Easyscripts).

SILKCENTRAL, TEST MANAGER, SILKTEST, SILK4J, SILKPERFORMER This Licensed Software may include technology for monitoring authorized use, including the policy files and license keys required to use the Licensed Software (the “License Authorization Server” or “LAS”). The LAS may be installed on a single-specified computer system at the specific site for which Licensee has contracted (the “Designated System”). The LAS, or any part thereof, may not be transferred from the Designated System. Regardless of the installation of the LAS, Licensee must remain compliant with the terms in this License Agreement (including without limitation any license restrictions and number of users permitted pursuant to this License Agreement). The LAS cannot be used or installed on a Virtual Machine.

SILK PERFORMER. This Licensed Software may be installed on a reasonable number of Licensee computer systems. Licensee may use the Multi-Machine Controller (also referred to as “Workbench”) (“MMC”) component and related load-test agents on an unlimited number of machines for an unlimited number of users, but solely in connection with the use of SilkPerformer in accordance with the number, type and class of Virtual User Licenses purchased. Premium Virtual User Licenses for SilkPerformer, when ordered in any quantity, include a single Named User limited license to use SilkTest (the “Additional Product”). The Additional Product may be used ONLY in conjunction with the Premium Virtual User Licenses of SilkPerformer and may not be used or transferred on a stand-alone basis. Incremental use of any Additional Product beyond the single Named User license, or stand-alone use, must be licensed and paid for separately.

TEAMANALYTICS 2008. This Licensed Software includes a single Named User limited license to use StarTeam (either StarTeam Enterprise 2006, StarTeam Enterprise Advantage 2006, StarTeam Enterprise 2008 or StarTeam Enterprise Advantage 2008), CaliberRM (either CaliberRM 2006 or CaliberRM 2008) and SilkCentral Test Manager (either SilkCentral Test Manager 2006 or SilkCentral Test Manager 2008) (the “Additional Products”). The Additional Products may be used only in conjunction with the TeamAnalytics 2008 product and may not be used or transferred on a stand-alone basis. Incremental use of any Additional Products beyond the single Named User license, or stand-alone use, must be licensed and paid for separately.

TEAMANALYTICS 2009. This Licensed Software includes a single Named User limited license to use StarTeam, CaliberRM and SilkCentral Test Manager (collectively, the “Additional Products”). The Additional Products may be used ONLY in conjunction with the TeamAnalytics 2009 and may not be used or transferred on a stand-alone basis. Incremental use of any Additional Products beyond the single Named User license, or stand-alone use, must be licensed and paid for separately.

TOGETHER. This Licensed Software may be used solely to create, compile (including byte code compile), test and deploy, in source or object code form, Licensee application programs and other works. This Licensed Software requires registration with Licensor prior to use. Licensee will be prompted to register at the time of installation or first use, at which time Licensee will be notified, or directed to online resources explaining, how registration information provided by Licensee may be used and Licensee will be afforded the opportunity to opt out of certain uses of such information. Licensee may use the License Manager component of the Licensed Software, in executable form only, on a server for use solely in connection with Licensee’s use of the Licensed Software.

TEAMDEFINE. This Licensed Software includes the capability for an unlimited number of users to review the simulation program integrated into the Licensed Software by Licensor or its suppliers. Such users may not otherwise use the Licensed Software. Where an evaluation license option is obtained for this Licensed Software pursuant to Annex 1.E.2 the evaluation period will continue for up to 365 days. During the first 30 days of the evaluation period Licensee will be able to access all functionality of this Licensed Software except “Project Export”. During the remaining evaluation period such functionality will continue except that Licensee will have read only access to “simulations”, “requirements”, “SDK”, “integrations”, “images” and “templates”. Licensee may purchase a full license for this Licensed Software at any time during the evaluation period.

SILKCENTRAL, TEST MANAGER, SILKTEST, SILK4J, SILKPERFORMER, TEAMDEFINE, CALIBER™, TOGETHER, STARTEAM, TEMPO, TEAMDEMAND, TEAMFOCUS, TEAMANALYTICS, TEAMINSPECTOR, APPSERVER, VISIBROKER. This Licensed Software may be used in a Virtual Machine only where a concurrent user license has been granted

APPSERVER, VISIBROKER. For this Licensed Software, regardless of the number of CPU's for which Licensee has purchased a Deployment License: (i) Licensee may not run more than one instance of the deployed Licensed Software on a single computer, and (ii) the Licensed Software may not be accessed at any one time by more than the number of Concurrent Users indicated in the applicable Product Order. In the event Licensee desire additional instances or additional Concurrent Users, Licensee must purchase a separate license applicable to a different computer.

APPLICATION MIDDLEWARE PRODUCTS. Licensee may not include this Licensed Software or any component thereof in any general-purpose software development tool, library, component, or any other product that is generally competitive with or a substitute for the Licensed Software or any other Licensor product offerings; nor may Licensee use the Licensed Software to create a product or operate a service that is generally competitive with the Licensed Software or any other Licensor product offerings, including any general-purpose software development tool. The foregoing restriction does not apply, however, to use of the Licensed Software to develop "plug-ins" (i.e., integrations created using the Licensed Software's open tools API) so long as such plug-ins are designed to provide supplementary functionality to the Licensed Software.

This Licensed Software is not redistributable. Licensee is not permitted to reproduce the Licensed Software for sublicensing, resale, lending, leasing, deployment or distribution to any party, including without limitation, distributing the Licensed Software as part of a VAR, OEM, distributor or reseller arrangement. If Licensee integrates the Licensed Software into a Work and intends to distribute or resell the resulting integrated Work, Licensee must contact Licensor to obtain the appropriate distribution license.

The portions of this Licensed Software identified as VISISECURE, VISITRANSACT, VISINOTIFY, VISITIME and VISITELCOLOG (collectively, the " VISISERVICES") are not redistributable. This License Agreement does not permit Licensee to execute, or otherwise use the VISISERVICES portion of the Licensed Software for any purpose unless Licensee has acquired a separate Development and/or Deployment License for VISISERVICES directly from Licensor before developing or deploying any Work that uses such portion of the Licensed Software. Licensee is not permitted to reproduce VISISERVICES for sublicensing, resale, lending, leasing, deployment or distribution to any party, including without limitation, distributing VISISERVICES as part of a VAR, OEM, distributor or reseller arrangement. If Licensee integrates VISISERVICES into a Work and intends to distribute or resell the resulting integrated Work, Licensee must contact Licensor to obtain the appropriate distribution license.

Notwithstanding the prohibition hereunder against decompiling this Licensed Software, Licensee may use that portion of the Licensed Software identified as "API Decompiler" for inspecting the public application programming interface (API) of the JAVA BEANS COMPONENT LIBRARY, DATAEXPRESS, DBSWING and OPENTOOLS API modules.

The following Java Technology Restrictions are applicable to the component of this Licensed Software identified as SonicMQ if it accompanies the Licensed Software: Licensee may not modify the Java Platform Interface ("JPI", identified as classes contained within the "java" package or any subpackages of the "java" package), by creating additional classes within the JPI or otherwise causing the addition to or modification of the classes in the JPI. In the event that Licensee otherwise create an additional class and associated API(s) which (i) extends the functionality of a Java platform, and (ii) is exposed to third party software developers for the purpose of developing additional software which invokes such additional API, Licensee must promptly publish broadly an accurate specification for such API for free use by all developers. Licensee may not create, or authorize its own licensees to create additional classes, interfaces, or subpackages that are in any way identified as "java", "javax", "sun" or similar convention as specified by sun in any class file naming convention.

This Licensed Software may include certain files, libraries and/or source code specifically designated as “redistributables" by Licensor in the accompanying printed or on-line documentation and that are necessary to use works created using the Product ("Redistributables"). From time to time, Licensor may designate other files as Redistributables. Subject to the terms and conditions of this License Agreement, Licensee may freely redistribute source code or compiled code that is entirely Licensee’s own and does not contain any Redistributables. Subject to the terms and conditions of this License Agreement, Licensor grants Licensee the personal, non-exclusive, non-transferable and limited license to: (a) make exact copies of the Redistributables and distribute those copies solely as components of Licensee’s Works and solely as required for permitting end users of the Works ('End users") to install and execute the Works; (b) install and execute Redistributables, without modification, solely for Licensee’s own internal use; and (c) sublicense to End Users the personal, non-exclusive, non-transferable right to install and execute Redistributables, without modification, solely as components of Works and solely for such End Users' own internal use, subject to End Users' compliance with the restrictions in this License Agreement. These rights granted may not be exercised by others, including co-developers, regardless of how Licensee’s Works are compiled, linked, or packaged. These rights apply only to Redistributables and to no other file, library, source code or other component or derivative work of the Licensed Software. They may be exercised only with respect to works created by Licensee using a duly licensed, properly registered copy of the Licensed Software.

ENDS

END USER LICENSE AGREEMENT SUPPLEMENT

The following terms and conditions shall supersede any conflicting terms and conditions set forth elsewhere in the End User License Agreement:

Where Licensor has expressly granted to Licensee the right to install and use the Licensed Software on a soft partition, the license fee shall be based on an "expected" Cores number calculated as the ratio of the number of Cores allocated to the soft partition to the total number of Cores on the Host Server, increased by a percentage to be determined by Licensor. To be effective, such grant must be set forth in the applicable Product Order or otherwise in writing separate from this License Agreement.

END USER LICENSE AGREEMENT SUPPLEMENT

The following terms and conditions shall supersede any conflicting terms and conditions set forth elsewhere in the End User License Agreement:

With respect to Micro Focus COBOLTM 2010 Runtime, COBOL Server, and all other application deployment products, Licensee may reproduce and distribute internally, in whole or in part, subject to the applicable license option as described in Annex 1 and the applicable Product Order, any software application program created by Licensee using the corresponding development product for the Licensed Software (if separately licensed to Licensee by Micro Focus) that contains any files from such development product and/or the Licensed Software ("Licensee Application Software"). Licensee shall (a) include Licensor's copyright notice for the Licensed Software on any product label and as a part of any sign-on message for such Licensee Application Software product; and (b) indemnify, hold harmless and defend Licensor and its third-party suppliers from and against any claims or lawsuits, including attorneys' fees, legal fees and court costs that arise out of, or result from, the use or distribution of such Licensee Application Software. Licensee can only reproduce and distribute Licensee Application Software to third parties after entering into a separate distribution agreement with Licensor. Usage and distribution of the Licensee Application Software arises both by the explicit distribution of any Licensee Application Software and by the implicit distribution and usage of any of the Licensee Application Software's functionality when linked into another software application program. The grant of license for the Licensed Software does not permit Licensee to either use or reproduce and distribute any files supplied as part of the Licensed Software in order to create a compiler, interpreter or runtime support product. Licensor offers specific production licensing options for distribution to third parties which vary depending upon the license fees paid by Licensee and Licensee should contact its Licensor sales representative for more details.

With respect to all application development products including Visual COBOL®:

  1. Licensee shall not use the Licensed Software, nor reproduce or distribute any files supplied as part of the Licensed Software, in order to create a compiler, interpreter, runtime support product or any other product that is generally competitive with or a substitute for the Licensed Software or any other Licensor product.
  2. This Licensed Software may include or generate limited licenses for Micro Focus COBOLTM 2010 Runtime, COBOL Server, or other deployment product. If such licenses are included or generated, these limited licenses are provided solely for use by the Named User of the Licensed Software in order to unit test an application developed with the Licensed Software on the same machine or server used to develop the application and may not be used for system testing, production or deployment, and (for Visual COBOL® products) may only be used if the Licensed Software is current on support and maintenance. Any use of this limited license outside of the development and unit testing of such applications is not permitted.

With respect to VISUAL COBOL® PERSONAL EDITION products:

  1. Licensee shall not use the Licensed Software for any purpose other than for personal educational and non-commercial activities. The Licensed Software may not be used for training or teaching purposes, and
  2. Licensee shall not use the Licensed Software to compile source code for applications of more than two thousand, two hundred (2200) lines of procedural code (exclusive of lines containing comments and/or blanks) in any one (1) application or to deploy such application to any other machine.

END USER LICENSE AGREEMENT SUPPLEMENT

The following terms and conditions shall supersede any conflicting terms and conditions set forth elsewhere in the End User License Agreement:

With respect to Enterprise Developer PERSONAL EDITION products:

  1. Licensee shall not use the Licensed Software, nor reproduce or distribute any files supplied as part of the Licensed Software, in order to create a compiler, interpreter, runtime support product or any other product that is generally competitive with or a substitute for the Licensed Software or any other Licensor product.
  2. The compiler functionality in the Licensed Software has been disabled. Licensee shall not use the Licensed Software for any purpose other than to input, edit and syntax check code for personal educational use. The Licensed Software may not be used for training or teaching purposes.
Micro Focus License Agreement 1 November 2009 All products LIC-GEN-17Supp1, 2.1, ED PE
Parent topic: Product Information
Related information
Downloading the Product
Microsoft Terminal Server


Third Party Software

These third party products may be required by the software in order to provide full functionality. In most cases you will need to obtain and install them individually.

  • Database Access Support with Native COBOL
  • Database Access Support with .NET Managed COBOL
  • Java 2 Enterprise Edition (J2EE) Support
  • Known Errors in J2EE Third Party Software
  • Team Foundation Server Support
    Extra information about and requirements for Team Foundation Server.
Parent topic: Product Information


Database Access Support with Native COBOL

Before you can use this product to deploy SQL applications developed for native COBOL with COBSQL, DB2 ECM or OpenESQL, ensure any third-party software prerequisites are installed and the environment is set properly.

Certification of RDBMS Precompilers
Certification of RDBMS precompilers with Micro Focus products is the responsibility of the RDBMS vendor, rather than Micro Focus. Certification information can be found within the relevant RDBMS documentation:
Oracle
If you have an Oracle MetaLink account (http://metalink.oracle.com), document # 43208.1 provides details of all language compilers certified by Oracle for use with their precompilers.
HCO for DB2 LUW
IBM document certification information for DB2/COBOL applications within the Information Center for DB2, in the topic Support for database application development in COBOL.
COBSQL
COBSQL supports the following database preprocessors:
  • Sybase Open Client Embedded SQL/COBOL Version 11.1 or later
  • Oracle Pro*COBOL Version 10gR1 or later
  • Informix Embedded SQL/COBOL Version 7.3 or later

COBSQL is supported in both 32-bit and 64-bit environments.

On x86 and x86-64 platforms, when compiling with COBSQL for use with Oracle, do not use the COBSQL directive option NOMAKESYN, since this directive results in COMP host variables, and on Intel platforms these are incompatible with the native byte order expected by Oracle.

DB2 ECM
DB2 ECM supports the following database preprocessors:
  • IBM DB2 LUW Version 9.1 or later
  • IBM DB2 Connect Version 9.1 or later

Applications compiled with the DB2 ECM are supported in 32-bit environments only.

Host Compatibility Option (HCO)
Host Compatibility Option requires that you have one of the following software products installed and configured:
  • IBM Database Connect
  • IBM DB2 LUW

If you are using DB2 LUW version 9.1 or later, you must also install the DB2 Application Development Client (formerly called DB2 SDK) or you will not be able to compile any DB2 programs.

HCO for SQL Server (HCOSS)
Microsoft SQL Server
SQL Server 2008, SQL Server 2008 R2, or SQL Server 2012, Developer or Enterprise Editions.
Database Migration
  • Microsoft OLE DB Provider for DB2, available in the SQL Server 2008 or 2012 Feature Pack
  • Mainframe DB2
    Note: We support only the mainframe DB2 versions that are currently under IBM support.
Application Migration
ODBC applications require either of the following combinations:
  • SQL Server 2008 and SQL Server Native Client 10.x
  • SQL Server 2012 and SQL Server Native Client 11.x
OpenESQL
  • OpenESQL supports the following database preprocessors:
    • Access to relational databases using ODBC 3.0-compliant drivers
    • Connectivity to Oracle's OCI interface
  • Refer to your driver vendor's documentation to determine whether your driver is suitable for use with OpenESQL
  • OpenESQL is supported in both 32-bit and 64-bit environments
Parent topic: Third Party Software
Related concepts
Database Access
Running HCO Tools
Introducing HCO
Related information
HCO for SQL Server (HCOSS)


Database Access Support with .NET Managed COBOL

Before you can use this product to deploy SQL applications developed for .NET managed COBOL with COBSQL, DB2 ECM or OpenESQL, ensure any third-party software prerequisites are installed and the environment is set properly.

HCO for SQL Server (HCOSS)
Microsoft SQL Server
SQL Server 2008, SQL Server 2008 R2, or SQL Server 2012, Developer or Enterprise Editions.
Database Migration
  • Microsoft OLE DB Provider for DB2, available in the SQL Server 2008 or 2012 Feature Pack
  • Mainframe DB2
    Note: We support only the mainframe DB2 versions that are currently under IBM support.
Application Migration
ADO.NET applications
ADO.NET applications require either of the following combinations:
  • SQL Server 2008 and SqlClient Data Provider in .NET Framework 3.5
  • SQL Server 2012 and SqlClient Data Provider in .NET Framework 3.5 or 4.0 (4.0 is preferred)
COBOL Stored Procedures
See the requirements specified in the SQL CLR Integration section below.
OpenESQL
  • Database access is supported using the OpenESQL preprocessor with applications compiled as .NET managed code to access relational databases using ODBC 3.0-compliant drivers. Refer to your driver vendor's documentation to determine whether your driver is suitable for use with OpenESQL.
  • OpenESQL has been tested against the following ADO.NET data providers:
    • Microsoft provider for SQL Server
    • Microsoft provider for Oracle
    • IBM DB2
    • Oracle Data Provider for .NET (ODP.NET)
    • OleDb
    • Managed ODBC .NET providers
  • Dynamic SQL using the SQL Descriptor Area (SQLDA) is not currently supported for OpenESQL applications compiled with the SQL(DBMAN=ODBC) directive.
Parent topic: Third Party Software
Related concepts
Database Access


Java 2 Enterprise Edition (J2EE) Support

J2EE 1.3 and 1.4 are supported for the deployment of EJBs generated using the Interface Mapping Toolkit, as follows:

  • J2EE 1.4 includes support for EJB 2.1 and Java Connector Architecture 1.5
  • Java EE 5 includes support for EJB 3.0 and Java Connector Architecture 1.5

The following J2EE application servers are supported using the following JDKs:

J2EE Application Servers | JDK (vendor) | J2EE | Java EE
JBoss 5 | 1.5 (Oracle) | 1.4 |
JBoss 4.2.3 | 1.5 (Oracle) | 1.4 |
BEA WebLogic 9.2 | 1.5 (Oracle) | 1.4 |
IBM WebSphere 6.0 | 1.4.2 (IBM) | 1.4 |
IBM WebSphere 6.1 | 1.5 (IBM) | 1.4 |
IBM WebSphere 6.1 with IBM EJB 3 Feature Pack | 1.5 (IBM) |  | 5
IBM WebSphere 7.0 | 1.5 (IBM) |  | 5
Parent topic: Third Party Software
Related information
IBM Support Web site
Resource Adapters Supplied by Micro Focus


Known Errors in J2EE Third Party Software

  • IBM WebSphere issues various warnings when running some applications. These are WebSphere problems. For example:
    07/12/10 11:35:55:843 JST] 00000056 PrivExAction W
J2CA0144W: Could not find
a mappingConfigAlias for the connection ...
07/12/10 11:35:55:908 JST] 00000056 PrivExAction W
J2CA0114W: Could not fing a container managed credential alias ...

    For details on these warnings, see the IBM Support Web site. [547718]

  • When using XA transactions with EJB 3.0 on Websphere 6.1 with the EJB 3 Feature Pack, if there are two resource managers and one of them is ES and the other is using JDBC, if the JDBC update fails, the Transaction Manager in Websphere does not receive the failure message and hence does not send a rollback to the other resource manager/s (Enterprise Server included). Instead, it sends a commit which is incorrect. This issue is being investigated.

    -557021

Parent topic: Third Party Software


Team Foundation Server Support

Restarting

When you install this COBOL development system on top of Team Build, you need to restart your machine after the installation. This sets the environment properly and enables Team Build to track changes. You do not need to restart if you install Team Build later.

Web Access

If you are using Team System Web Access you may find that merge and annotate commands are disabled for certain file types in your COBOL project (such as .cbl,.cpy ). To enable the commands, you need to add the extensions to MimeMap.xml in webaccess_install_dir\Web\App_Data. Edit the file with a text editor and add the extensions to the <Extensions> section with content type "text/plain". Finally, reset the application pool.

Multiple check out

You can enable multiple check out and merge for certain file types in your COBOL project. In order to do this, right-click your server in Team Explorer and choose Team Foundation Server Settings > Source Control File Types. Add the extensions of the files to the list and enable multiple check out and merge as required.

Parent topic: Third Party Software


Known Errors and Restrictions

The restrictions covered here are those that are not covered elsewhere in the documentation, or that are of a temporary nature and may be removed in a later product. Permanent limits are generally covered in the main help.

Where an entry arose from a problem report, the report's number is given, to enable Product Support to help you more quickly if you call. These numbers are called Reported Product Issue (RPI) numbers.

If you have installed a WrapPack containing updates and fixes to your installation, the fixes and any last-minute issues are documented in the WrapPack readme, which is downloadable with the WrapPack from the SupportLine Web site.

  • COBOL Programming
  • Compatibility
  • Data Access
  • Java EE App Server Support
  • Mainframe Programming and Management
  • .NET Code
  • Problem Determination and Diagnostic Tools
  • Visual Studio IDE
Parent topic: Product Information
Related information
Updates and Product Support


COBOL Programming

  • Arithmetic Calculation
  • Boolean Data Items
  • CBL2XML Utility
  • Enhanced ACCEPT/DISPLAY Syntax (Adis)
  • IDXFORMAT 8 File Size Limits
  • Managed COBOL: the REDEFINE clause of the PROPERTY keyword
  • Unsupported Features
  • XML Support and Syntax Extensions
Parent topic: Known Errors and Restrictions


Arithmetic Calculation

Exact equality of arithmetic results from managed and unmanaged code is not guaranteed. [573761]

Parent topic: COBOL Programming


Boolean Data Items

  • Argument-2 of the BOOLEAN-OF-INTEGER statement must be a numeric constant when the function is used in an expression with B-NOT, or as part of a boolean expression which is used as an argument in INTEGER-OF-BOOLEAN.
  • You can only query PIC 1(n) USAGE BIT items which are at the 01 level.
  • You cannot query boolean data items defined as PIC1(n) USAGE BIT that are subscripted. If you need to query them, move the value to a PIC 1 (n) USAGE DISPLAY data item.
  • The JUSTIFIED clause cannot be specified for boolean data items.
  • You cannot use reference modification on boolean data items.
  • If you use the ODOSLIDE directive, you cannot have boolean data items following a variable-length table in the same record; neither can you have data items following a variable-length table containing boolean data items.
  • You cannot use the BX literal format.
  • You cannot have boolean data items in text-data used in EXEC(UTE) CICS or EXEC(UTE) SQL statements.
  • You cannot use include boolean data items in conditional compilation statements.
  • You cannot use boolean data items in the Screen Section.
  • The Report Writer feature does not support boolean data items.
  • You cannot use variable length items with GROUP-USAGE BIT specified in boolean expressions.
  • You cannot set CHARSET"EBCDIC" for programs using boolean data items.
  • You cannot move data between national items and boolean items.
  • Boolean data items can contain up to 64 digit positions; groups of GROUP-USAGE BIT are also limited to 64 digit positions.
  • If you use the syntax VALUE IS {{literal}... FROM ({subscript-1}...) [TO ({subscript-2}...)]}, subscript-1 and subscript-2 cannot be boolean data items.
  • Using the SYNCHRONIZED clause has no effect on the alignment of any type of bit data item.
Parent topic: COBOL Programming


CBL2XML Utility

When converting from COBOL to COBOL with XML syntax using the cbl2xml command, level 88 conditions cause erroneous results.

Parent topic: COBOL Programming


Enhanced ACCEPT/DISPLAY Syntax (Adis)

Some DBCS fields are displayed with different content depending on whether or not the cursor is in the field.

This problem only occurs if the PROMPT option is on, and either of the two bytes that comprise a non-space DBCS character in the field matches (for value and position) either of the two bytes that comprise a DBCS space.

Parent topic: COBOL Programming


IDXFORMAT 8 File Size Limits

File size limits for IDXFORMAT 8 files are not enforced. Allowing your file to grow over the documented limit could result in an error related to the relevant restriction. If you think your file may exceed the documented limits, use FILEMAXSIZE=8 where applicable.

Parent topic: COBOL Programming


Managed COBOL: the REDEFINE clause of the PROPERTY keyword

The REDEFINE clause when used with the PROPERTY keyword does not give the desired results.

REDEFINE is currently giving the same behavior as the OVERRIDE clause.

Parent topic: COBOL Programming


Unsupported Features

Projects compiled to .int, .gnt and .lbr files

The preferred executable file formats with Studio Enterprise Edition are .dll and .exe. The .int and .gnt file formats are still supported by the Compiler and the debugger but cannot be created directly by the IDE.

Run-time Features

The run-time features of your COBOL development system not supported include:

  • Dialog System (Character and GUI)
  • GUI Class Library
  • HyHelp
  • Panels Version 2

Note that some of these features might compile correctly, but won't run.

Parent topic: COBOL Programming


XML Support and Syntax Extensions

On 64-bit Windows platforms, the current version of XML support reads/writes only local XML documents. Support for remote XML documents will be added in a future release.

Parent topic: COBOL Programming


Compatibility

  • Co-existing with Earlier Micro Focus Products
  • Installation
  • Setup Issues
Parent topic: Known Errors and Restrictions


Co-existing with Earlier Micro Focus Products

Run-time system error due to COBCONFIG
A run-time system error occurs if either the COBCONFIG or COBCONFIG_ environment variable is set when you run aStudio Enterprise Edition application or when you use Studio Enterprise Edition to edit or create projects and the configuration file it refers to contains entries that are not valid for Studio Enterprise Edition.

For example, this might happen if you have Net Express or Studio Enterprise Edition installed and either COBCONFIG or COBCONFIG_ is set for it.

To work around this issue, ensure that Studio Enterprise Edition is not running and then modify the configuration file by doing one of the following:

  • If the invalid tunable is not needed by another application, remove it from the run-time configuration file.
  • Add the following as the first line in the configuration file:
    set cobconfig_error_report=false
  • Unset COBCONFIG (or COBCONFIG_) or set it to another configuration file that does not contain the invalid tunable for the particular session you are running in.
Licensing error due to environment settings
The message "Micro Focus License Manager service is not running" can occur when you invoke a Net Express, Mainframe Express or Studio Enterprise Edition utility from Studio Enterprise Edition. This happens when the tool is invoked with Studio Enterprise Edition environment settings while it requires the Net Express or Studio Enterprise Edition ones.

This happens when you edit files such as .dat that have a file association with Net Express or Studio Enterprise Edition. This can also happen when invoking a utility within the Net Express or Studio Enterprise Edition products as an external tool from Studio Enterprise Edition.

You can workaround this problem in Studio Enterprise Edition as follows:

  1. Create a batch file that unsets COBREG_PARSED before the tool is invoked. The batch file contains:
    Set COBREG_PARSED=
Call [PathToUtility] %1

    Where PathToUtility is the path to the Net Express or Studio Enterprise Edition utility.

  2. In the Visual Studio IDE, add the batch file instead of the utility itself as an external tool.

    This ensures that the proper environment is established when running that tool.

Parent topic: Compatibility


Installation

  • A bug in Windows 7 x64 may cause the display of the Compatibility Assistant dialog during the installation of the product showing incorrectly that aslmpclocate.exe and init2aslm.exe are not compatible. The two utilities run properly and the install is successful. To avoid receiving this notification, run Windows update and install update KB978637 before installing this product.
  • If, when you start Visual Studio, you receive a message box about Micro Focus package load failures, check that the Packages folder is on the PATH. If it is not, click NO to disable loading the packages.

    If you accidently click YES, you need to re-enable loading the packages, as follows:

    1. Open a Visual Studio command prompt from the Start menu.
    2. Enter the command:
      devenv /ResetSkipPkgs

    When you reboot the machine, the problem is resolved, the PATH is set up correctly and the packages are found.

  • Installing this release as an upgrade to a previous version of the product might take longer in relative terms compared to a clean install.
Parent topic: Compatibility


Setup Issues

  • If you have any Studio Enterprise Edition 6.0 SP2 Hotfixes installed, they need to be removed before you install Studio EE 6.0 SP2 WS1. If the Hotfixes are not removed, the following error message is displayed during the install, and the install exits: "Error 2771. Upgrade of feature DOTNET has a missing component."

    The current Hotfixes that have been released are:

    • nxp326020110-48105-hotfix01-8121.msp
    • nxp326020110-48274-hotfix02-8264.msp
    • nxp326020110-50061-hotfix03-8329.msp
Parent topic: Compatibility


Data Access

  • COBSQL
  • DB2
  • File Handling
  • Records with Alternate Keys
  • OpenESQL
Parent topic: Known Errors and Restrictions


COBSQL

  • COBSQL cannot process directives within a $SET statement. Any of the COBOL directives that COBSQL processes should be placed either within the build/project settings, or in a directives file (for example, cobol.dir ).

  • If an Embedded SQL statement has a comment in columns 73 - 80 and is not terminated by a period, the Oracle precompiler (Pro*Cobol) considers the next COBOL line as part of the Embedded SQL statement and comments it out.

    To prevent this making COBSQL hang, use the COBSQL directive SQLDEBUG. Then, when COBSQL encounters such a line, it displays:

    CSQL-W-040: Pro*Cobol commented out the following line

    Note that the program logic is altered because Pro*Cobol has commented out a COBOL line. It is recommended, therefore, that you do not execute programs that produce this message. You should either remove the comment text or terminate the Embedded SQL statement with a period.

  • Using sequence numbers inside Sybase Embedded SQL statements causes COBSQL to lose its position in the source. This leads to the message "Premature end of expanded source" being displayed and means the code cannot be checked.
  • If an EXEC WHENEVER ... END-EXEC or an EXEC DECLARE ... END-EXEC statement is the last statement in a paragraph or section, you may get a compilation error on the name of the following paragraph. If this happens, place an extra COBOL sentence (terminated by a period) after the WHENEVER or DECLARE statement. For example:
    CONTINUE.
Parent topic: Data Access


DB2

DB2 LUW
Studio Enterprise Edition only supports versions of DB2 LUW that are currently supported by IBM.
Parent topic: Data Access


File Handling

  • Using Btrieve, a START operation cannot be performed with a part-key. The whole key must be used.
  • In Studio Enterprise Edition, if you attempt to open a data file located on a Novell Netware drive you may receive a file status 9/181 message, which indicates that you have used an invalid parameter.

    The defaults for new indexed files are IDXFORMAT(8) and FILEMAXSIZE = 8, which enables support for 64-bit file handling. Novell Netware drives only behave like 32-bit drives and can only handle files up to 4GB in size.

    To access files from a Novell Netware drive in Studio Enterprise Edition, you need to override these file handling formats by setting the following options in the file handler configuration file (EXTFH.CFG):

    [XFH-DEFAULT]
IDXFORMAT=4
FILEMAXSIZE=4
  • If you are accessing Vision files through the Vision file handler (as opposed to the default Micro Focus File Handler) and you are upgrading from Studio Enterprise Edition version 2.0 to version 2.1, you must first uninstall version 2.0, otherwise the Vision file handler may not function correctly.
Parent topic: Data Access


Records with Alternate Keys

  • A write of a record with an alternate key where the alternate key is the first value for that key may now return a 0/2 file status rather than a 0/0 status if a record with that alternate key value has been deleted by uncommitted transaction (possibly the same transaction as that performing the write).
Parent topic: Data Access


OpenESQL

Embedded SQL Statements
  • Any EXEC SQL statement that specifies a table or column name containing one or more special characters must have that table or column name enclosed in quotes to prevent a preprocessor error. A special character is an ASCII character with a value greater than 128 or a hexadecimal character with a value greater than x"80".
ODBC
  • When using Oracle's ODBC driver, array fetches and some scrolling fetches might produce inconsistent behavior if you change the array size between fetches. To overcome this, build your application with SQL(NORESULTARRAY). When this is set, OpenESQL performs single row fetches under the covers, bypassing this limitation.
Parent topic: Data Access


Java EE App Server Support

EJB Generation
EJBs generated for WebLogic 10.3.5 do not support local interfaces. This is because this version of WebLogic does not make business local interfaces available on the global JNDI tree.
Parent topic: Known Errors and Restrictions


Mainframe Programming and Management

  • Assembler Emulation
  • CICS Web Interface
  • CodeWatch
  • DOCUMENT APIs
  • Enterprise Server
  • General Open PL/I Issues
  • HCO for SQL Server (HCOSS)
  • Historical Statistics Facility (HSF)
  • IMS MFS Displays
  • IMS Printing
  • IMS Database Forward Recovery
  • Installing Mainframe Access Server
  • JCL Utilities
  • Mainframe Subsystem Support (MSS)
  • PL/I Syntax
  • Run-time Behavior
  • User ID and password constraints in Enterprise Server
Parent topic: Known Errors and Restrictions


Assembler Emulation

MFASM, the mainframe assembler emulator for IBM High Level Assembler programs, has the following restrictions and limitations:

  • E15 and E35 Assembler sort exits are not supported.
  • EXEC CICS statements in assembler modules are not supported.
  • The ASM2DLI interface for IMS is not supported.
  • There is no interactive debugger for Assembler. It is recommended to use CTF with your Assembler applications to produce CTF (consolidated trace file) output. Note: There is an Assembler generalized trace facility (GTF) available for recording all Assembler instructions executed during a test run. This facility is turned on by the presence of the environment variable GTFFILE= and has various options for the amount of detail wanted in the trace file. Also, note that in an Enterprise Server environment the server running the Assembler modules must be stopped before the trace file can be accessed as the server will open the file for exclusive access.
  • During assembly the MFASM.EXE program will produce a SYSLIST.WTO file containing the results of the assembly. This file is created by default and is purely for informational use. It can be deleted at any time if unwanted.
  • When adding Assembler files that contain CICS statements to a project in Visual Studio, the CICS statements are not automatically detected. Choosing the "Reset source directives" project menu command also does not detect the CICS statements. To enable the EXEC CICS options for the project, open the project properties, click the Assembler tab and check EXEC CICS under Preprocessors.
Parent topic: Mainframe Programming and Management


CICS Web Interface

Enterprise Server now supports CICS web-enabled application programs.

The CICS Web Interface APIs have the following limitations:

  • Only BASIC authentication is supported
  • HTTPS is not supported
  • Trailer HTTP headers are not supported
  • Conversion of codesets and codepages is not supported
  • You cannot connect to an HTTP server through a proxy
  • The Action(Expect) option of a WEB SEND request is ignored.
Parent topic: Mainframe Programming and Management


CodeWatch

  • The sample demo sessions in the back of the CodeWatch User's Guide may not match exactly with this version of CodeWatch.
  • CodeWatch is unable to evaluate an array in a based structure when the dimensions of the array are declared using the REFER option.
  • Problems may arise when evaluating expressions containing certain built-in functions, especially when given incorrect arguments (for example, wrong type or wrong number of).
  • EVALUATE of BASED and CONTROLLED arrays do not work when using CodeWatch with Open PL/I.
  • When using CodeWatch with Open PL/I, EVALUATE can not use the POSITION attribute.
  • On platforms where the WIDECHAR data type is supported, Codewatch allows evaluation of WIDECHAR variables only. Evaluation of WIDECHAR expressions is currently not supported.

    For WIDECHAR variable evaluation, half byte-pairs outside the ASCII range display as a '.' character. Use the EVALUATE command with the /h option to display hexadecimal values for each byte-pair. For example:

    dcl wc wchar (16) init('003900370038'Wx);

...

eval wc

WC = .9.7.8. . . . . . . . . . . . .  {widechar (16)}

eval /h wc

WC = 00 39 00 37 00 38 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 (hex)  {widechar (16)}
Parent topic: Mainframe Programming and Management


DOCUMENT APIs

Enterprise Server now supports the CREATE, INSERT, RETRIEVE, DELETE, and SET commands of the DOCUMENT API so that you can use documents and document templates in your application programs.

Because Enterprise Server is not started using JCL, you must use an environment variable to retrieve the PDS names of the templates' locations. You can have up to 20 PDS names, separated by a semi-colon. For example:

MYHTML=MYPDS.HTML.LEVEL1;MYPDS.HTML.LEVEL2; MYPDS.HTML.LEVEL3;... MYPDS.HTML.LEVEL20
DOCUMENT support has the following limitations:
  • DOCUMENT CREATE and DOCUMENT INSERT do not support HOSTCODEPAGE
  • DOCUMENT RETRIEVE does not support CHARACTERSET and CLNTCODEPAGE
  • You cannot create a document from, or insert into a document, a previously-retrieved document which contains tags embedded by CICS.
  • DOCUMENT CREATE and DOCUMENT INSERT do not support the #include command within a template.
  • RECFM V is not supported for PDS associated to a DOCTEMPLATE definition. You must use RECFM Line sequential or Fixed instead.
Parent topic: Mainframe Programming and Management


Enterprise Server

  • Enterprise Server does not support the use of Object-oriented COBOL in CICS or JCL programs.
Parent topic: Mainframe Programming and Management


General Open PL/I Issues

Open PL/I was designed to be, and still is, an ANSI standard PL/I compiler. Customers interested in migrating need to assume changes to existing PL/I applications may be required to remove any proprietary mainframe syntax and/or deal with differences in behavior in order to make programs portable. You should read the topic Open PL/I 8.1 for Windows before starting to use this feature.

Parent topic: Mainframe Programming and Management
Related information
PL/I Programming


HCO for SQL Server (HCOSS)

  • The first time the DSN Bind utility connects to the SQL Server database, either immediately after you create the database or immediately after you install an HCOSS upgrade, the SQL Server connection used must provide read, update, and create permissions to the SYSIBM and dbo schemas.

    At other times, during routine DSN use, the SQL Server connection need only have read and update permissions to SYSIBM, assuming that the SYSIBM owner has update permissions for the tables in the SYSIBM schema.

    Each time you execute DSN, it automatically evaluates the need for schema creation and maintenance, which is necessary immediately after the creation of the SQL Server database, and immediately after an HCOSS upgrade. In these cases, it executes the following SQL scripts that require create permissions:
    • InstallSYSIBM.sql to create the SYSIBM schema and install its appropriate tables
    • InstallBindProcs.sql to create appropriate stored procedures in the SYSIBM schema
    • InstallDigitsFunction.sql to create appropriate user-defined functions in the dbo schema

    You can prevent DSN from executing these SQL scripts by executing them manually immediately after creating your SQL Server database and immediately after performing an HCOSS upgrade. All three script files reside in your %ProgramData%\Micro Focus\NetExpress\6.0 directory.

Parent topic: Mainframe Programming and Management


Historical Statistics Facility (HSF)

You can create records for tasks that have been executed and completed under Enterprise Server using the Historical Statistics Facility (HSF).

HSF has the following known issues:

  1. HSF doesn't populate the Program field in ESMAC or Prog field in the .csv file for IMS records.
  2. The User field (containing the user id) is not populated when the user has the default user name - for example CICSUSER.
  3. If a job step abends, then the total response time shown in the job's END record will be greater than the response time from all steps added together.
  4. The File and TS fields are only populated for CICS transactions.
  5. All fields with time values are measured in hundredths of a second. A side effect of this is that cumulative times, such as the total time a transaction accesses a file or temporary storage queue, will display as zero if each access took less than a hundredth of a second but the total is greater than a hundredth of a second.
Parent topic: Mainframe Programming and Management


IMS MFS Displays

In some circumstances the TN3270 stream sent when an IMS message screen is requested does not display as expected. This can happen if you have private copies of the system MFS objects. These objects are distributed in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\files.

If you encounter this problem, delete any local copies of these objects. The system objects are:

  • 427FdFSDF1.DIF
  • 427FDFSDF1.DOF
  • 427FdFSDF2.DIF
  • 427FDFSDF2.DOF
  • 427FdFSIGN.DIF
  • 427FDFSIGN.DOF
  • 477FdFSDF1.DIF
  • 477FDFSDF1.DOF
  • 477FdFSDF2.DIF
  • 477FDFSDF2.DOF
  • 477FdFSIGN.DIF
  • 477FDFSIGN.DOF
  • DFSDSPO1.MOD
  • DFSIGNI.MID
  • DFSIGNP.MOD
  • DFSMI1.MID
  • DFSMI2.MID
  • DFSMO1.MOD
  • DFSMO2.MOD
  • DFSMO3.MOD
Parent topic: Mainframe Programming and Management


IMS Printing

IMS printing and Printer Spool API are not currently supported.

Parent topic: Mainframe Programming and Management


IMS Database Forward Recovery

Server Enterprise Edition does not create forward recovery log files when databases are updated offline by batch programs running DLI or DBB mode. In these cases, we recommend that you create a backup of each affected database immediately following the completion of each batch job.

Parent topic: Mainframe Programming and Management


Installing Mainframe Access Server

The MFA installation process references a missing card image PDS file that can cause the MFAAS task to fail the first time it runs.

You should define this file, by creating under TSO or by submitting JCL. For example:

 //DEFVCTL JOB (MFA),MSGCLASS=A,CLASS=A,MSGLEVEL=1
 //*
 //* Define Data Connect VSAM mapping control
 //*
 // EXEC PGM=IEFBR14
 // MFAVCTL DD DSN=<hlq>.MFAVCTL,
 // UNIT=3390,
 // VOL=SER=volser,
 // DCB=(RECFM=FB,LRECL=80,BLKSIZE=6160),
 // SPACE=(CYL,(1,1,25),RLSE),DISP=(,CATLG,DELETE)

You must assign an appropriate high-level qualifier and select the unit and volume names for where this file will reside. In addition, each site may assign storage class options which comply with their data centre's standards.

Parent topic: Mainframe Programming and Management


JCL Utilities

  • Calling MFFJUXIT after a parsing error B539260 results in corrupting the JCL file name in -U-pc-fname. The file name is missing some leading characters.
Parent topic: Mainframe Programming and Management


Mainframe Subsystem Support (MSS)

If you have clients using the ECI interface with the CICS Transaction Gateway to communicate with a CICS application running in MSS, a client program might receive an ECI_ERR_TRANSACTION_ABEND return code with an abend code of AZTY, indicating that several clients tried to communicate with the system at the same time but not all requests could be satisfied by MTO. The workaround for this issue is to set the environment variable TX_UNICLI_SESSIONS to the required number of sessions in the Configuration Information for the enterprise server as follows:

[ES-Environment]
TX_UNICLI_SESSIONS=<required-number-of-sessions>

The default is 4.

You should set Maximum requests in the Client Section of the CICS Transaction Gateway configuration to the same value.

If you do this you will also probably need to change the client program to ignore the ECI-ERROR_MAX_SESSIONS return code and retry the call. For example:

do
 {
   Rc = CICS_ExternalCall (&EciParms);
 } while (Rc == ECI_ERR_MAX_SESSIONS);

If you do not make this modification, the client program might still receive the ECI_ERR_TRANSACTION_ABEND return code.

Emulation is not available for the DSNTIAUL and DSNUTILB mainframe utilities

Parent topic: Mainframe Programming and Management


PL/I Syntax

  • In the AIX version of Open PL/I, the ABS function returns incorrect values for very small floating point operands.
  • The internal representations of floating point constants on the Sun versions of Open PL/I are sometimes different from those on the IBM RS6000.
  • The compiler does not diagnose a mismatch between actual parameters and the parameter list in the entry declaration when the dimension attribute is used in the parameter list.
  • DO j = 1 to 6 while(...), j = 1 to 6 while(...); fails because the second set of iterations starts at 0 instead of 1.
  • DO j = 1 repeat j+1 while(...), j = j repeat j-I while(...); fails because the second set of iterations begins at 1 instead of j.
  • The compiler is confused by the declaration of an ENTRY whose RETURNS type is specified by the TYPE attribute referring to a structure whose members are declared using the TYPE attribute.
  • No diagnostic is generated when you pass an array argument to a non-array parameter.
  • If the length operand for COPY of a bit-string is less than the length of the target to which the COPY is assigned, the trailing bits of the target are not always zeroed.
  • Assignment of a shorter bit-string to a longer target does not always obtain padding with zeros on the right as it should.
  • Static initialization of a pointer to the address of a static data item is not supported.
  • The TRUNC built-in causes an runtime error if its argument is a double precision floating point value whose integer value is greater than 2**31.
  • The PUT FILE statement adds an extra character in front of the data being written into a file.
Parent topic: Mainframe Programming and Management


Run-time Behavior

  • Studio Enterprise Edition does not support environment variables with names containing embedded spaces.
  • In mainframe emulation of DFSORT, the run-time system error COBRT252 Memory corruption detected (Fatal), might occur when performing a SORT FIELDS=COPY on a file with a record format of VB.
Parent topic: Mainframe Programming and Management


User ID and password constraints in Enterprise Server

Enterprise Server emulates the mainframe operating system on Microsoft Windows, UNIX and Linux operating system platforms. Mainframe user authentication constraints and technical limitations are therefore emulated through the Enterprise Server External Security Facility (ESF) Manager to ensure mainframe compatibility.

These constraints and technical limitations apply to many components of Enterprise Server including:
  • CICS
  • Job Entry Subsystem (JES)
  • Micro Focus Directory Server (MFDS)
  • IMS
User IDs and passwords are limited to a maximum of eight ASCII characters.

To avoid issues with user signon and similar functions, avoid attempting to create user IDs or passwords that do not meet these requirements.

Parent topic: Mainframe Programming and Management


.NET Code

  • ASP.NET
  • Compiler Directives
  • File Handler
  • Language Service and IntelliSense
  • OpenESQL
  • Projects
  • Remote Debugging
  • Security
  • Web Reference Generation
Parent topic: Known Errors and Restrictions


ASP.NET

  • Packages are not loaded when you try to run and debug an ASP.NET application or Web service.
  • Windows Forms and ASP .NET test clients for service interfaces require that Visual Studio 2008 Standard Edition or higher is installed.
  • It is not possible to run ASP.NET Web Sites or Web Services on a production machine (one that has Micro Focus Server Enterprise Edition installed) without an additional setup. This is because the production machine does not contain development tools such as the COBOL Compiler. To workaround this, you need to do the following steps:
    1. Precompile the site before you deploy it using the Publish Web Site command in Visual Studio.
    2. Edit the .asmx file of the Web service project or the .aspx file of the Web site and delete the Language="COBOL" statement.
    3. Edit the Web.config file with a text editor and delete the line which contains: <compiler language="COBOL"...
    4. Ensure that a .NET Server license is installed using Apptrack.

    -1080101

Parent topic: .NET Code


Compiler Directives

The following compiler directives are not currently supported in the .NET environment:

  • ACCEPTREFRESH
  • AMODE
  • CALL-RECOVERY
  • CANCELLBR
  • CICSECM
  • COPYLBR
  • DATA
  • DATA-CONTEXT
  • DB2
  • DEFAULTCALLS
  • HOST-NUMCOMPARE
  • HOST-NUMMOVE
  • HOSTARITHMETIC
  • NATIVE-FLOATING-POINT
  • NOPRESERVECASE
  • ODOOSVS
  • PC1
  • PROFILE
  • SIGN-FIXUP
  • STICKY-LINKAGE
  • STICKY-PERFORM
  • TESTCOVER
Parent topic: .NET Code


File Handler

The IDXNAMETYPE file-handler configuration option does not work correctly when used in a managed .NET application and the filename (including the specified path) of the file being opened includes one or more space characters. The file will not be opened and an error file-status or RTS error message will be generated.

Parent topic: .NET Code


Language Service and IntelliSense

  • The Language Service reads from assemblies referenced by your project to provide IntelliSense and error reporting while you are editing code. The Language Service is unable to reread an assembly that has changed. So if you have a project with references to other projects or assemblies which change, the Intellisense and error reporting can become inaccurate. Currently, the only way to refresh this information is to close down the IDE and restart it.
Parent topic: .NET Code


OpenESQL

  • Dynamic SQL using the SQL Descriptor Area (SQLDA) is not supported in .NET managed code.
Parent topic: .NET Code


Projects

  • There is a limit of about 300 COBOL source files that can be part of a single managed COBOL project. If the limit is exceeded, a "Memory Allocation Fail" message is received. The actual limit may vary depending on the size of each source file.
Parent topic: .NET Code


Remote Debugging

Remote debugging does not work for managed code if you set the project properties to start a remote application via a network drive (for example, remote debug machine = \\nwb-csdserv). This will trigger Code Access Security exceptions in the COBOL run time.

You can instead use Debug/Attach to process and select the machine name in the dialog box. This allows you to attach to an already running process on the remote machine. Obviously, the process needs to be running either in a loop or by manually adding a CBL_DEBUGBREAK in order to allow time to attach before the program terminates.

Parent topic: .NET Code


Security

Micro Focus COBOL applications deployed to environment such as ASP.NET/Network drives are currently required to have full trust.

Parent topic: .NET Code


Web Reference Generation

When adding a web reference to a project, you must ensure the web reference name does not contain a hyphen. The web reference name is used as part of the name of the classes being generated. If the name contains a hyphen, you will get a class name not compliant error at run time.

You can change the name in the Web reference name field in the Add Web Reference dialog.

Parent topic: .NET Code


Problem Determination and Diagnostic Tools

  • Debugging in Visual Studio
  • Debugging Start Point
  • Error Markers
  • Test Coverage
Parent topic: Known Errors and Restrictions


Debugging in Visual Studio

  • You might experience a slight delay when initiating a debug session for a COBOL project. This is caused by the out-of-date checking to determine whether the project requires a rebuild.
  • You cannot attach the debugger to a 64-bit native process.
  • The debugger ignores a COBOL watchpoint that is hit if there is no statement following the statement that modifies the data on which that watchpoint is set.
  • The debugger does not fully support native OO programs. For example, QuickWatch or entering data names in the Watch window displays an error.
  • If your application receives a raceOnRCWCleanup (managed code debugger assistant) while debugging, this could be because your WPF application is not performing any closed/shutdown handling. To resolve this, add the following method in the App.xaml.cbl source:
           method-id OnExit protected override.

       procedure division using by value e as type ExitEventArgs.
           invoke super::OnExit(e)
      *>   Insert any other closedown code before the stop run statement.

           stop run.

       end method.

    For more information see http://msdn.microsoft.com/en-us/library/ms743714.aspx#Application_Shutdown

  • A core dump file is not created for a stack overflow condition.
  • If your project includes more than one program and you hover data items in a program that is not the current program being debugged, you may get the wrong values in the debug tooltip or no debug tooltip at all. This is because the context is the current program being debugged. This is expected and is the default Visual Studio behavior.

    To point which program is the current context:

    1. Start debugging your project and step into the code.
    2. Click Debug > Call Stack to display the call stack.

      The program being debugged is indicated by a yellow arrow. This program is also the current context.

    3. Continue stepping the code till the call stack list is populated with the other programs in your application.
    4. Double-click the program you wish to query in the call stack list.

      This adds a green arrow in front of the program in the list to indicate it is the current context.

    5. In the editor, open the program or the copybook which contains a reference to the item you want to query.
    6. Hover a data item.

      The debug tooltip should display the correct value.

Parent topic: Problem Determination and Diagnostic Tools


Debugging Start Point

  • By default, the first file added to a Net Express project is selected for debugging whether or not it is a .cbl file. You can override the default file by selecting Debug > Settings and entering the name of the file in the Start Animating at field.
Parent topic: Problem Determination and Diagnostic Tools


Error Markers

The IDE does not set correctly the error markers in files that are not associated with the Micro Focus COBOL project types. Instead of setting the markers on the exact lines that cause a problem, the IDE sets all of them on the first line of the respective files. To work around this issue, you need to add the unknown file extensions or the file names as file associations for the COBOL project types. To do this, click Window > Preferences. In the left-hand pane, click General > Content. Expand Text > Micro Focus COBOL Project Types. Add the file extensions in the File association pane.

Parent topic: Problem Determination and Diagnostic Tools


Test Coverage

Programs in .exe or .dll format that have been compiled with the TESTCOVER directive set, and have been run under the TESTCOVER environment, might find that at the reporting stage the .idy or .cbl/.cpy files cannot be found when creating reports from the results file(s). To work around this, run the tcreport utility from the directory containing the .idy/.cbl/.cpy files. [530281]

Parent topic: Problem Determination and Diagnostic Tools


Visual Studio IDE

  • Examples and Demonstrations
  • Fonts and Colors Dialog Box
  • Licensing
  • Reference Paths
  • Service Interfaces
  • General Visual Studio IDE Issues
  • Visual Studio Shell
  • Visual Studio Team System
  • Windows Communication Foundation (WCF)
Parent topic: Known Errors and Restrictions


Examples and Demonstrations

  • Some examples and demonstrations do not work in Visual Studio Shell, due to the limited support in the Shell.
Parent topic: Visual Studio IDE


Fonts and Colors Dialog Box

The Fonts and Colors dialog box might not show COBOL entries. If this is the case, open a Visual Studio command prompt and execute devenv /setup .

Parent topic: Visual Studio IDE


Licensing

  • When you create a new project in Visual Studio with a timed license, a Licensing window appears explaining when the license is due to expire. If you press Exit, the license is considered invalid. You might get an error message saying this. You cannot continue working in Visual Studio.

    To avoid this problem, do not press Exit.

    To recover from this problem, if you pressed Exit, exit Visual Studio and restart it. If your license has expired, contact Micro Focus for a new licence.

Parent topic: Visual Studio IDE


Reference Paths

In the project properties, on the References page, the Reference Paths functionality does not behave as expected. You can click Reference Paths and enter a path to identify assemblies to be referenced. For example, you can enter c:\build to identify assemblies in that directory. However, the assemblies in that directory are not listed on the .NET tab of the Add References dialog box.

To add references to assemblies that are not listed in the .NET tab of the Add References dialog, go to the Browse tab of the Add References dialog and browse to the assemblies you require.[556890]

Parent topic: Visual Studio IDE


Service Interfaces

  • When importing service interfaces from Net Express projects into Visual Studio, any program source that the service interface relies upon must be at the root level of the target Visual Studio project - it cannot exist in subfolders within the Visual Studio project.
  • Please, leave the Build Action Setting for a Service Interface set to None (the default). Setting the Build Action for a Service interface from the default value of "None" to "Compile" will result in service interface properties not being displayed.
  • The names of the CICS or IMS Java service interfaces should not start with two characters in uppercase (for example, MYSERVICE or MYservice) as this can cause JSP client runtime errors and does not comply with the established CamelCase naming conventions.

    If you are using any names for CICS or IMS Java Service interfaces that start with two characters in upper case, you must rename them. To do this:

    1. First, rename the service interface to a temporary name – for example, rename MYservice to tempsvc.
    2. Rename the temporary name to a name that complies with the CamelCase naming conventions - rename tempsvc to MyService.
    3. Close Visual Studio project that contains the service interface and then reopen it.
Parent topic: Visual Studio IDE


General Visual Studio IDE Issues

  • In the Visual Studio IDE, re-positioning the windows, for example after docking and undocking windows, can cause the IDE to crash. To resolve this issue download and apply the following patch from Microsoft: http://code.msdn.microsoft.com/KB960075.
  • Do not use the Startup object in the Application properties page to set the main program. The startup object must be the first static method in a class specified using the ILMAIN directive.
  • If you use an explorer mouse with navigation buttons, these will not function when editing COBOL source files in the Visual Studio editor. You can use the navigation buttons on the standard toolbar instead.
  • The IDE may crash if you create a C++ project that uses a Project Wizard.
Parent topic: Visual Studio IDE


Visual Studio Shell

The following restrictions apply if you are using the Visual Studio shell:

  • WCF is not supported and so the WCF demonstration programs do not work. In addition, the project templates for WCF are not installed.
  • The Syndication Service Library project is not supported.
  • There is no integrated designer for icon and bitmap files
  • The option File > New > Project From Existing Code is not supported
  • The Windows SDK must be installed.
  • Examples and demonstration programs that use languages other than COBOL do not work, because Visual Studio Shell doesn't support any other languages. This applies to the following demonstrations:
    • CursorDemo
    • InterfacingWithStdCOBOL
    • LobDemo
    • OrderStatusDemo
Parent topic: Visual Studio IDE


Visual Studio Team System

If you are using Visual Studio Team System, note that Code Analysis and Code Metrics do not work for COBOL projects.

Parent topic: Visual Studio IDE


Windows Communication Foundation (WCF)

WCF is not supported in the Visual Studio Shell.

Parent topic: Visual Studio IDE


Contacting Micro Focus

Our Web site gives up-to-date details of contact numbers and addresses.

  • Further Information and Product Support
  • Information We Need
  • Creating Debug Files
Parent topic: Product Information


Further Information and Product Support

Additional technical information or advice is available from several sources.

The product support pages contain a considerable amount of additional information, such as:

  • The WebSync service, where you can download fixes and documentation updates.
  • The Knowledge Base, a large collection of product tips and workarounds.
  • Examples and Utilities, including demos and additional product documentation.

To connect, enter http://www.microfocus.com in your browser to go to the Micro Focus home page.

Note: Some information may be available only to customers who have maintenance agreements.

If you obtained this product directly from Micro Focus, contact us as described on the Micro Focus Web site, www.microfocus.com. If you obtained the product from another source, such as an authorized distributor, contact them for help first. If they are unable to help, contact us.

Parent topic: Contacting Micro Focus
Related information
Knowledge Base
Examples and Utilities
Community Forums
White Papers and Webcasts


Information We Need

However you contact us, please try to include the information below, if you have it. The more information you can give, the better Micro Focus SupportLine can help you. But if you don't know all the answers, or you think some are irrelevant to your problem, please give whatever information you have.

  • The name and version number of all products that you think might be causing a problem.
  • Your computer make and model.
  • Your operating system version number and details of any networking software you are using.
  • The amount of memory in your computer.
  • The relevant page reference or section in the documentation.
  • Your serial number. To find out these numbers, look in the subject line and body of your Electronic Product Delivery Notice email that you received from Micro Focus.

On Windows, if you are reporting a protection violation you might be asked to provide a dump ( .dmp) file. To produce a dump file you use the Unexpected Error dialog box that is displayed when a protection violation occurs. Unless requested by Micro Focus SupportLine, leave the dump setting as Normal (recommended), click Dump, then specify a location and name for the dump file. Once the dump file has been written you can email it to Micro Focus SupportLine.

Alternatively, you might be asked to provide a log file created by the Consolidated Tracing Facility (CTF) - a tracing infrastructure that enables you to quickly and easily produce diagnostic information detailing the operation of a number of Micro Focus software components.

Parent topic: Contacting Micro Focus


Licensing

  • Using the Micro Focus Licensing Administration Tool
  • Authorizing Your Product
  • Revoking Licenses
  • Licensing Error Messages
    Messages you might encounter when working with licensing.
Parent topic: Welcome
Parent topic: General Reference


Using the Micro Focus Licensing Administration Tool

  • Overview
  • To start the Micro Focus Licensing Administration tool
  • To view installed licenses
  • Trial Licenses
  • Usage Log
  • Using the Licensing Services
    Guidance on using the Sentinel RMS license server when developing COBOL projects.
Parent topic: Licensing


Overview

You manage your product licensing by using the Micro Focus Licensing Administration tool.

When you install your Micro Focus product, the Sentinel RMS license server is also installed to manage your license. Depending on how your site is administering licenses, you can also request licenses from a central license server.

Some licensing tasks require Internet connectivity from your computer. For example, when you authorize your product a connection is made with a Micro Focus server to verify the authorization code you have used and return a license code string. Similarly, the revoke license process uses a Micro Focus server to revoke the existing license and then provide a new authorization code. Where Internet connectivity is required, it is highlighted in the relevant task help.

Tip: You can prevent the license server being installed by creating an empty file called SKIP_SAFENET_INSTALL and saving it in the Sentinel installation folder ...\SafeNet Sentinel\Sentinel RMS License Manager\WINNT).

This stops licensing being interrupted while updates to the server are installing. When licensing needs to be updated, remove the file and install the server manually. You can also use this process on machines where you need to preserve the production environment.

To install License Manager manually:
  1. From the command line, run the product installer NXP32xxxxxxxx.exe with the /extractcab option. This creates a subdirectory called SupportFiles that contains all the product .msi files including those for License Manager.
  2. Run the installer appropriate for the bitism of your platform, either lmsetupx86.msi or lmsetupx64.msi.

Central License Server

If your site has multiple licenses and you want to use a central license server to manage them, install the Micro Focus License Manager that is supplied with your product. Individual workstations can then be configured to obtain a license from the license server machine.

License Management System Restrictions

The Sentinel RMS license management system supplied with your product does not acknowledge or manage Micro Focus product licenses you have previously installed and that use the Micro Focus License Management System.

CAUTION:
If you are using a timed license (for example, a 30 day trial license), do not change the machine’s date and time. If you do, the license will be invalidated and you will need to call Micro Focus SupportLine.

If you need to change the machine’s date and time, make sure that you have installed a full license that is not time limited.

Uninstalling a Product that uses Sentinel RMS

When you uninstall a Micro Focus product that uses Sentinel RMS, the license server is not uninstalled. You can choose to either revoke the license(s) that you have activated for that product or keep them.

Parent topic: Using the Micro Focus Licensing Administration Tool


To start the Micro Focus Licensing Administration tool

From the Windows Taskbar click Start > All Programs >Micro Focus License Manager > License Management System.

Parent topic: Using the Micro Focus Licensing Administration Tool
Related information
To authorize your product using a local license server
To authorize your product manually
To configure your workstation to use a central license server
To view installed licenses
To revoke licenses
To revoke licenses manually


To view installed licenses

  1. Start the Micro Focus Licensing Administration tool.
  2. Select the Licenses tab.
A list of installed licenses will be displayed and will show:
  • The name of the product licensed
  • The serial number of the license
  • The type of license
  • For limited licenses, the expiry date
  • Whether the license is hosted locally or a networked computer
Parent topic: Using the Micro Focus Licensing Administration Tool
Related information
To start the Micro Focus Licensing Administration tool
To authorize your product using a local license server
To authorize your product manually
To configure your workstation to use a central license server
To revoke licenses
To revoke licenses manually


Trial Licenses

Depending on your product you may have trial licenses installed. If this is the case and you have not yet authorized your full license a Trial Notice dialog box might be displayed when you run your product.

While you are using a trial license within the license period, the Trial Notice dialog box might display every time you run your product. To prevent this, enter your authorization code to obtain a full license.

Parent topic: Using the Micro Focus Licensing Administration Tool


Usage Log

The licensing system creates a usage log file that details all licensing activity. In addition to monitoring usage, the file is a useful licensing diagnostic tool.

Log files are called lservrc.log. When they reach 10MB in size they are archived to lservrc.log.xxx where xxx is an incremental number for the archive file.

The files are located in C:\Documents and Settings\All Users\Application Data\Micro Focus or C:\Programdata\Micro Focus depending on which version of Windows you are using. As these files contain important and useful information, and, to maintain disk space, it is recommended that you manage these files accordingly.

Parent topic: Using the Micro Focus Licensing Administration Tool


Using the Licensing Services

Developing COBOL projects requires that licenses are installed.

By default the Sentinel RMS license server is installed automatically in your Micro Focus product. It starts automatically and runs as a service.

  • To start the Sentinel RMS license server
    Steps to start the license server.
  • To stop the Sentinel RMS license server
    Steps to stop the license server.
  • To start the Micro Focus licensing service
Parent topic: Using the Micro Focus Licensing Administration Tool


To start the Sentinel RMS license server

Note: Normally you don't need to start the license server as it starts automatically and runs as a service.
  1. Open the Microsoft Management Console Services snap-in.
  2. Right-click on Sentinel RMS License Manager and choose Start.
Parent topic: Using the Licensing Services


To stop the Sentinel RMS license server

  1. Open the Microsoft Management Console Services snap-in.
  2. Right-click on Sentinel RMS License Manager and choose Stop.
Parent topic: Using the Licensing Services


To start the Micro Focus licensing service

The licensing service enables the Micro Focus licensing system to communicate with the Sentinel system. It starts automatically. If you need to restart it, do the following:

  1. Open Control Panel > Services.
  2. Start MF CES Daemon.
Parent topic: Using the Licensing Services


Authorizing Your Product

Depending on your system and requirements, you can either install Sentinel RMS license server on individual computers or on a single computer that will act as a central license server. A Sentinel RMS license server is installed automatically with your product, and you can choose any machine on which it is installed to act as the central server if required.

You need an appropriate type of authorization code in order to install your license or licenses. For example, if you have ordered 50 licenses then the authorization code installs either 1 license on each of 50 machines or 50 licenses on the central server. If you do not know which type of code you need, contact your system administrator.

  • To authorize your product using a local license server
  • To authorize your product manually
  • To configure your workstation to use a central license server
Parent topic: Licensing


To authorize your product using a local license server

The task steps below describe how to authorize your product if you are using the Sentinel RMS license server that is set up on your local machine. (The license server is automatically set up when you first install your product.)

Note: Internet connectivity is required to perform this task.
  1. Start the Micro Focus Licensing Administration tool.
  2. Click the Authorize tab.
  3. Enter your authorization code.
  4. Click Authorize.
Note: If authorization fails, the user interface will allow you to attempt manual authorization.
Parent topic: Authorizing Your Product
Related information
To start the Micro Focus Licensing Administration tool
To authorize your product manually
To configure your workstation to use a central license server
To view installed licenses
To revoke licenses
To revoke licenses manually


To authorize your product manually

Manual authorization is necessary if your machine does not have Internet connectivity or if normal (automatic) authorization has failed. where normal authorization has failed, the user interface for manual authorization is displayed automatically. You can start this interface manually by choosing the Manual Activation option from the Options menu.

  1. Start the Micro Focus Licensing Administration tool if it is not already enabled.
  2. From the Options menu, select Manual Authorization.

Take the following steps for both methods of Manual Authorization:

  1. Either click the http link on the Manual Authorization Interface or paste the http link into an Internet browser. If you don't have an Internet connection, make a note of the address and perform this step on a machine with Internet access. When you have obtained the license strings you can then copy them onto the license server.

    The link will take you to the Micro Focus license activation webpage.

  2. Enter your authorization code (a 16-character alphanumeric string)
  3. Enter your Machine ID. The Machine ID string is displayed on the Manual Authorization interface.
  4. Enter your e-mail address in the Email Address field.
  5. Click Generate.
  6. Copy the generated license string and paste it into License String on the Manual Authorization interface.

    Alternatively, wait until you have received an email message from Product Support containing your license string.

  7. Click Install Licenses.
Parent topic: Authorizing Your Product
Related information
To start the Micro Focus Licensing Administration tool
To authorize your product using a local license server
To configure your workstation to use a central license server
To view installed licenses
To revoke licenses
To revoke licenses manually


To configure your workstation to use a central license server

You can set up a central Sentinel RMS license server if your authorization code grants multiple licenses. A license server is installed automatically when you install your Micro Focus product, and you can use any license server installation as your central license server without additional configuration.

CAUTION:
If you change the name of your license server after you have installed licenses it will stop working.

The task steps below describe how to authorize your workstation product if you want to obtain a license from a central Sentinel RMS license server. Internet connectivity is required.

You need the IP address or server name for the central license server you want to access. You should be able to get this from your License System Administrator.

Important: We recommend that other options on Advanced Configuration are modified only under guidance from Micro Focus SupportLine.
  1. Start the Micro Focus Licensing Administration tool.
  2. Select Options > Advanced Configuration
  3. Click Change against the License Server row.
  4. Enter the IP address or server name of the central license server.
  5. Click Save.
  6. Click Close.
Parent topic: Authorizing Your Product
Related information
To start the Micro Focus Licensing Administration tool
To authorize your product using a local license server
To authorize your product manually
To view installed licenses
To revoke licenses
To revoke licenses manually


Revoking Licenses

  • To revoke licenses
  • To revoke licenses manually
    The manual revoke process should be followed when automatic revoke has failed.
  • To revoke licenses during product uninstall
  • To move your product license to a different computer
Parent topic: Licensing


To revoke licenses

Revoke licenses if you want, for example, to move your product to a different machine or if you no longer use your product and want to reallocate the license.

Note: Internet connectivity is required to perform this task.
  1. Start the Micro Focus Licensing Administration tool.
  2. Select the Revoke tab.
  3. Select the product license you want to revoke.
  4. Click Revoke

    After a check has been made to ensure no licensed products are running, the Revoke Product Licenses dialog box is displayed.

  5. Input or select the number of licenses you want to revoke.
  6. Click Revoke.

A new authorization code for each revoked license will be generated and saved to file on your computer. The file location and the new codes will be displayed on the screen.

Ensure that you keep the new authorization codes in a safe place. You will need them when you re-authorize your product.

Note: If there is a problem accessing the Micro Focus License Authorization Server and the revoke fails, the Revoke Product Licenses dialog box will enable options to allow manual revocation. At this point your licences are revoked and cannot be used. To obtain an authorization code you must send the License Revocation Tickets (LRTs) to Micro Focus, either by pasting them into the revoke web page or by sending the indicated file to your SupportLine representative.
Parent topic: Revoking Licenses
Related information
To start the Micro Focus Licensing Administration tool
To authorize your product using a local license server
To authorize your product manually
To configure your workstation to use a central license server
To view installed licenses
To revoke licenses manually


To revoke licenses manually

The manual revoke process should be followed when automatic revoke has failed.

If automatic revocation fails, the Revoke Product Licenses dialog box will display options for manual revocation. Either:

  1. Copy all of the character string displayed in the text box at the bottom of the Revoke Product Licenses dialog box.

    This string contains the Sentinel RMS License Revoke Tickets that are required to issue a new authorization code.

  2. Click the HTTP link.

    The link will take you to the Micro Focus license revocation web page.

  3. Paste the copied string into the text box and click Generate.

    The new Authorization code will be displayed.

Or

  1. Copy all of the character string displayed in the text box at the bottom of the Revoke Product Licenses dialog box and send in an email to your SupportLine representative.
Important: Ensure that you keep the new authorization codes in a safe place. You will need them when you re-authorize your product.
Parent topic: Revoking Licenses
Related information
To start the Micro Focus Licensing Administration tool
To authorize your product using a local license server
To authorize your product manually
To configure your workstation to use a central license server
To view installed licenses
To revoke licenses


To revoke licenses during product uninstall

When you uninstall a product, the Micro Focus License Manager software performs a check to see if any licenses for that product exist on your computer. If so, you will be prompted to revoke them. If you do revoke them, they will be removed and you will be given you a new authorization code. You use this new code to generate a license when you install the product on another machine.

If you are going to re-install your product on the same machine, you do not need to revoke the license. In this case, select Keep when you are prompted to revoke the license.

  1. Uninstall your product.

    A prompt will display to reallocate your licenses.

  2. Select Revoke if you want to revoke the licenses.

    The Micro Focus License System Administration tool is displayed at the Revoke tab.

  3. Select the product license you want to revoke.
  4. Click Revoke.

    After a check has been made to ensure no licensed products are running, the Revoke Product Licenses dialog box is displayed.

  5. Input or select the number of licenses you want to revoke.
  6. Click Revoke.

    A new authorization code for each revoked license will be generated and saved to file on your computer. The file location and the new codes will be displayed on the screen.

    Ensure that you keep the new authorization codes in a safe place. You will need them when you re-authorize your product(s) .

Note: If there is a problem accessing the Micro Focus License Authorization Server and the revoke fails, the Revoke Product Licenses dialog box will enable options to allow manual revocation. At this point your licences are revoked and cannot be used. To obtain an authorization code you must send the License Revocation Tickets (LRTs) to Micro Focus, either by pasting them into the revoke web page or by sending the indicated file to your SupportLine representative.
Parent topic: Revoking Licenses


To move your product license to a different computer

If you have been using a product that has had a license provided by the local license server, you can use the product on a different computer by performing these steps

  1. Start the Micro Focus Licensing Administration tool.
  2. Revoke the license, making note of the new authorization code that will be required when you re-authorize your product.
  3. Uninstall the product.
  4. Install the product on the new computer.
  5. Start the Micro Focus Licensing Administration tool.
  6. Authorize your product with the new authorization code.
Note: You can proceed with the product uninstall without taking steps to revoke the license first. In this case, you will be guided through the revoke process as part of the uninstall.
Parent topic: Revoking Licenses
Related tasks
To revoke licenses during product uninstall
Related information
To start the Micro Focus Licensing Administration tool
To authorize your product using a local license server
To configure your workstation to use a central license server


Licensing Error Messages

  • Initialization error - Initializing: Cannot communicate with licensing daemon
    Check the licensing service is running.
  • Error - Initalizing: Cannot find initialization file
    The initialization file <path to Micro Focus licensing bin directory> ces.ini is missing. Verify your installation with Micro Focus SupportLine.
  • Error - Unable to manage licenses in license manager that is not running on localhost
    You have a remote license server configured. You should install the licenses on that machine or configure your license server to be the local host.
  • Error [5]: Cannot talk to the license server on host "xxx.x.x.x". Server not running
    The /etc/hosts file might not contain an entry for hostname and IP address.
  • Error authorizing... Remote request error - The authorization code is invalid
    Check the authorization code you have entered against the code provided by Micro Focus.
  • Error [26] - Request Denied due to clock tamper detection
    The clock has been changed on a machine where a time-limited license is installed.
  • Error[18]: No license code is available for feature (component)
    The license string installed on the machine does not contain the necessary license string of the component being used.
  • Unable to authorize (cause)
    The authorization code cannot be verified. The specific cause is given in the brackets. Depending on the nature of the message, further detail and instruction will accompany the message.
Parent topic: Licensing


Initialization error - Initializing: Cannot communicate with licensing daemon

Check the licensing service is running.

The service is called MF CES Daemon. Check if it is running and start it using the Control Panel > Services dialog box.

Parent topic: Licensing Error Messages


Error - Initalizing: Cannot find initialization file

The initialization file <path to Micro Focus licensing bin directory> ces.ini is missing. Verify your installation with Micro Focus SupportLine.
Parent topic: Licensing Error Messages


Error - Unable to manage licenses in license manager that is not running on localhost

You have a remote license server configured. You should install the licenses on that machine or configure your license server to be the local host.
Parent topic: Licensing Error Messages


Error [5]: Cannot talk to the license server on host "xxx.x.x.x". Server not running

The /etc/hosts file might not contain an entry for hostname and IP address.
Ensure that these values are added to the /etc/hosts file. You can find the hostname by typing hosntame from a command prompt. To obtain the IP address, type /sbin/ipconfig from a command prompt.
Parent topic: Licensing Error Messages


Error authorizing... Remote request error - The authorization code is invalid

Check the authorization code you have entered against the code provided by Micro Focus.
Parent topic: Licensing Error Messages


Error [26] - Request Denied due to clock tamper detection

The clock has been changed on a machine where a time-limited license is installed.
Contact your Micro Focus SupportLine representative in order to resolve the matter. You will be asked to provide the locking code of the machine and in return will receive a clean certificate which you run on the machine in order to restore the license to its previous working state.
Parent topic: Licensing Error Messages


Error[18]: No license code is available for feature (component)

The license string installed on the machine does not contain the necessary license string of the component being used.
Contact your Micro Focus SupportLine representative in order to obtain the correct license string.
Parent topic: Licensing Error Messages


Unable to authorize (cause)

The authorization code cannot be verified. The specific cause is given in the brackets. Depending on the nature of the message, further detail and instruction will accompany the message.
Parent topic: Licensing Error Messages


Getting Started

This book shows you how to start using Studio Enterprise Edition to develop COBOL applications. The tutorials introduce the major features of Studio Enterprise Edition within Microsoft Visual Studio.

  • Features
    This chapter introduces you to the main features of Studio Enterprise Edition.
  • Mainframe Tutorials
    This section contains tutorials for developing on a mainframe, including how to develop CICS, IMS, JCL and Open PL/I applications.
  • Native COBOL Tutorials
    This section contains tutorials covering the production of native COBOL.
  • Managed COBOL Tutorials
    This section contains tutorials covering the production of managed COBOL.
  • Procedural COBOL Compared with Managed COBOL
    Procedural COBOL is regular COBOL without any of the new syntax that has been added for .NET and JVM. Managed COBOL is the collective term for .NET COBOL and JVM COBOL.
Parent topic: Welcome
Related concepts
Tutorials on COBOL and PL/I in the Visual Studio IDE


Features

  • Introduction
  • Develop and Build within Visual Studio
  • Build Using Server Express
  • Test on Server Enterprise Edition
  • Modernization and Integration
Parent topic: Getting Started


Introduction

Studio Enterprise Edition provides a tool suite that enables you to migrate business applications to lower cost environments. You can also use the product to maintain, improve and modernize the migrated application.

Studio Enterprise Edition supports many mainframe technologies, such as CICS, IMS, JCL, and DB2 on Linux, UNIX, and Windows. This means that the core online and batch application logic can be migrated and reused with minimal modification on any of these new environments.

The product also includes the development and testing tools you need to modernize the migrated applications, to exploit existing interfaces and extend them to a Service Oriented Architecture (SOA), through .NET, Web services or J2EE.

The Studio Enterprise Edition suite supports the entire development life cycle from analysis to test, while its companion product, Server Enterprise Edition, supports the deployment of the migrated application on the new production platform.

Parent topic: Features


Develop and Build within Visual Studio

You use Microsoft Visual Studio and its integrated development environment (IDE) to edit, compile and debug the COBOL applications. The IDE provides all the functionality to manage projects and debug applications.

You can develop applications that have been migrated from the mainframe and that use mainframe technologies like CICS, JCL, and IMS. These compile to native (Micro Focus) COBOL code, as .exe or .dll, and execute in conjunction with the run-time system.

You can also develop COBOL applications as .NET managed code. .NET managed COBOL programs compile to Microsoft Intermediate Language (MSIL), and they execute in conjunction with the Microsoft Common Language run-time system (CLR), just like programs in other .NET languages, such as C#.

Development support is provided for:

  • Projects — with templates supplied for mainframe applications, console applications, class libraries and more
  • Editing — with syntax colorization, background parsing and, for .NET managed code Intellisense
  • Debugging code — with the usual features such as stepping, breakpoints, watch windows and querying execution environments
  • Mainframe applications — for editing, compiling and debugging CICS programs, JCL applications and IMS applications
Parent topic: Features


Build Using Server Express

When the target deployment environment is Linux or UNIX, you develop the application under Windows. When the application is working you transfer the project artifacts to the Linux or UNIX server for re-compilation and building with Server Express.

Server Express includes a native code generator that produces optimized native code specific to the target Linux or UNIX platform. Also included is a complete set of character-based tools for debugging and managing diagnostics directly on Linux or UNIX.

Parent topic: Features


Test on Server Enterprise Edition

The Server Enterprise Edition run-time environment is included within the development product to enable you to perform extensive unit testing. It provides a local run-time environment for the migrated application that supports the execution of COBOL/CICS/IMS applications, JCL procedures and the COBOL programs or utilities they call.

You can use the monitoring and administration tools to start and stop instances of the Server Enterprise Edition environment and to administer the local configuration. These tools enable you to interact with a running Server Enterprise Edition environment in a similar way to a mainframe console. They also provide real-time reporting on the current status of any instance of Server Enterprise Edition for debugging and diagnostics purposes.

Parent topic: Features


Modernization and Integration

  • Terminal Emulator User Interfaces and Modernization
  • Integration with Other Systems
Parent topic: Features


Terminal Emulator User Interfaces and Modernization

Studio Enterprise Edition includes the Micro Focus RUMBA terminal emulator to enable connectivity from Windows desktops to virtually any host system. This includes connectivity to migrated 3270 based applications executing within Server Enterprise Edition.

If the target environment is Linux or UNIX, RUMBA also provides a VT100 connection to enable you to connect from Windows to the LINUX or UNIX environment without the need to install any other third party software on their Windows desktops.

Parent topic: Modernization and Integration


Integration with Other Systems

Studio Enterprise Edition and Server Enterprise Edition support CICS Inter-System Communication (ISC). This enables you to develop and test the appropriate interfaces to integrate CICS transactions running off the mainframe with other CICS transactions running on the mainframe.

Server Enterprise Edition includes technology that can be deployed on the mainframe to handle the conversion between TCP/IP protocol stacks on Linux, UNIX or Windows and the SNA/LU6.2 protocol stack on the mainframe.

Parent topic: Modernization and Integration


Mainframe Tutorials

  • Tutorial: Assembler
  • Tutorials: CICS
  • Tutorials: HCO for SQL Server (HCOSS)
  • Tutorial: IMS
  • Tutorial: JCL
    This tutorial takes you step by step through the process of configuring an Enterprise Server to run JCL applications, and then deploying and running a JCL application. This is intended both as an introduction to using JCL with the Studio Enterprise Edition and Server Enterprise Edition environments and as an Installation Verification Procedure (IVP) to confirm that JCL support is correctly installed.
  • Tutorials: Open PL/I
  • Tutorials: Service Interfaces Using the IMTK
    These tutorials walk you through the process of defining service interfaces in Visual Studio using the Interface Mapping Toolkit feature of Studio Enterprise Edition, deploying them to enterprise server instances running on Enterprise Server, and generating and running clients to access them.
Parent topic: Getting Started


Tutorial: Assembler

AACT is a sample CICS 3270 transaction that comprises several Assembler programs and a single BMS map, and uses the resource definitions in the file dfhdrdat. This tutorial walks you through the steps required to implement and test the AACT transaction.

Prerequisites

To complete this tutorial, you need the following software:
  • Studio Enterprise Edition
  • Micro Focus Rumba or another TN3270 emulator

Demonstration Application

The CICS application that you use in this tutorial is the AACT demonstration application, the standard example application that IBM supplies with CICS systems. The AACT application executables are supplied with Studio Enterprise Edition.

  1. Create a Visual Studio Project
  2. Import Files from the Demonstration Program
  3. Build the AACT Project
  4. Create an Enterprise Server
  5. Configure the Enterprise Server
  6. Start the AACT Enterprise Server
  7. Run the AACT Application
Parent topic: Mainframe Tutorials


Create a Visual Studio Project

You create a project that comprises all the parts of your application. In this case, the Assembler source and BMS files.

  1. From the Visual Studio IDE, click File > New > Project.
  2. Under Project types, expand COBOL Projects; then click Native.
  3. Under Templates, clickMainframe Subsystem Application.
  4. Complete the remaining fields as follows:
    Name | AACT
    Location | c:\tutorials
    Solution Name | AACT
  5. Uncheck Create directory for solution.
  6. Click OK.

    Visual Studio creates the project in the c:\tutorials\AACT directory, and opens the Solution Explorer showing the AACT solution and project.

Parent topic: Tutorial: Assembler
Next topic: Import Files from the Demonstration Program


Import Files from the Demonstration Program

In this step, you import the files from the AACT demonstration program into your project and copy the resource definition files to the project.

  1. In Visual Studio, right-click the AACT project in Solution Explorer and select Add > Existing Item.
  2. Browse to the AACT sample files, located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Visual Studio Integration\Tutorials\Mainframe\Assembler\AACT directory.
  3. On the Add Existing Item dialog box, click the drop-down list associated with the File Name field and select All Files (*.*).
  4. Select all of the following files, and then click Add to add them to the project:
    • acctrec.cpy
    • acctset.bms
    • acctset.cpy
    • acctset.mac
    • acctrec.mac
    • asmacct0.mlc
    • asmacct1.mlc
    • asmacct2.mlc
    • asmacct3.mlc
    • asmacct4.mlc
    • asmacctm.mlc

    As each file is added to the project, Studio Enterprise Edition automatically scans each one to determine the appropriate preprocessor to use when compiling, and set the appropriate directive. In this case, Studio Enterprise Edition automatically sets each to use CICS directive. You can watch the progress of this process in the Output window.

  5. At a command prompt or using Explorer, create a subdirectory under c:\tutorials\AACT named System.
  6. Copy the dfhdrdat and dfhdrdat.idx files from the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Visual Studio Integration\Tutorials\Mainframe\Assembler\AACT\System directory to the c:\tutorials\AACT\System subdirectory that you just created. These are the files that contain the resource definitions you need to create an enterprise server to run the AACT application.
Parent topic: Tutorial: Assembler
Previous topic: Create a Visual Studio Project
Next topic: Build the AACT Project


Build the AACT Project

You must compile the Assembler and BMS code into an application.

  1. From the Visual Studio Solution Explorer, right-click the AACT project name; then select Build.

    You can watch the progress of this process in the Output window.

  2. When the build is complete, save the project.
Parent topic: Tutorial: Assembler
Previous topic: Import Files from the Demonstration Program
Next topic: Create an Enterprise Server


Create an Enterprise Server

To successfully run your new AACT application, you must first create a new enterprise server instance configured for Mainframe Subsystem Support, and with Assembler enabled.

  1. Start Server Enterprise Edition Administration using one of the following methods:
    • From the Visual Studio Server Explorer: Right-click Micro Focus Servers and choose Administration from the context menu. This starts Server Enterprise Edition Administration in a Visual Studio window.
    • From the Start menu: Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Configuration > Enterprise Server Administration. This starts Server Enterprise Edition Administration in a browser outside of the IDE.
    • From your browser: Enter http://localhost:86 into the Address field.
  2. Click Add.
  3. In the Server Name field, type AACT.
  4. Choose 32-bit for the Working mode option; then click Next.
  5. In the Server Type group, click Micro Focus Enterprise Server with Mainframe Subsystem Support; then click Next.
  6. In the Startup Options group, check Show Local Console. This enables you to see the Server Enterprise Edition Console Daemon when you start up the enterprise server.
  7. In the Creation Options group, ensure that Set TN3270 listener is checked; then enter 9004 into the Using port field. This is the port number used when you connect to the enterprise server with your TN3270 emulator.
  8. You need to set these two environment variables:
    BASE=c:\tutorials\AACT | Provides your enterprise server with the path to your Visual Studio project files
    ES_MFASM_SUPPORT=Y | Enables Assembler for CICS regions
    To do this, type the following into the Configuration Information field:
    [ES-Environment]
BASE=c:\tutorials\AACT
ES_MFASM_SUPPORT=Y
  9. In the Description field, type a description of the new enterprise server, for example Assembler AACT Tutorial.
  10. Click Add.

    This displays the Server Enterprise Edition Administration Home page with your new AACT server in the list of the available enterprise servers.

Parent topic: Tutorial: Assembler
Previous topic: Build the AACT Project
Next topic: Configure the Enterprise Server


Configure the Enterprise Server

Now you need to configure your enterprise server instance to enable it to run AACT Assembler/CICS application.

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the AACT enterprise server.
  2. On the Server > Properties > MSS > CICS tab, type ASMSIT into the System Initialization Table field. The ASMSIT is provided for you and contains all of the resource information necessary to run the AACT application.
  3. In the Transaction Path, and File Path fields, specify the location of the AACT files and transaction programs:

    $BASE

  4. In the Map Path field, specify the location for BMS output files:

    $BASE\bin\x86\debug

  5. In the Resource Definition File Path field, specify the location of your dfhdrdat resource definition file:

    $BASE\System

  6. Click Apply.

    At this point you have enabled Assembler and CICS support for this enterprise server and specified the appropriate resources and locations of the relevant files.

Parent topic: Tutorial: Assembler
Previous topic: Create an Enterprise Server
Next topic: Start the AACT Enterprise Server


Start the AACT Enterprise Server

You must start your enterprise server before you can access your application. You can do this in several ways, but for this tutorial, you'll start your enterprise server from a command prompt so you can see each module loading on the Server Enterprise Edition Console Daemon.

  1. To open aNet Express command prompt,click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Compatibility Tools > Net Express Command Prompt (32-bit).
  2. Enter casstart /rAACT.
  3. Observe the output from the daemon. You should see the message MFASM support loaded successfully. This means that Assembler is enabled for your enterprise server.
  4. Return to the Server Enterprise Edition Home page. When the server has started successfully, you'll see the word "Started" in green text in the Status column for your AACT enterprise server.
Parent topic: Tutorial: Assembler
Previous topic: Configure the Enterprise Server
Next topic: Run the AACT Application


Run the AACT Application

Now that the application is built and you have an enterprise server running it, we can test it by connecting to it and interacting with it using a TN3270 emulator.

  1. Start your TN3270 emulator and connect to the machine running your AACT enterprise server using port 9004 as you configured in your enterprise server.
  2. Clear the screen of your TN3270 emulator.
    Note: If you are using Rumba, press Ctrl+Shift+Z to clear the screen.
  3. If this is your first time running the application, you must initialize the files. To do this, enter CFCR AACTFIL at the prompt on your TN3270 emulator screen; then clear the screen again. After doing this the first time, you do not need to do it when you run the application again.
  4. Enter AACT. The following shows the initial screen of our application:

    AACT Main Menu

    As you can see from this screen, this application lets you display, add , delete, print, or modify information in a database. To show how the application runs, you'll add a record and then retrieve it.

  5. Tab to the REQUEST TYPE field and type A.
  6. In the ACCOUNT field, type 11111.
  7. Press Enter.
  8. Complete the fields on the NEW RECORD screen as follows. Of the three ADDRESS fields, complete only the first two. Fields not represented here are not mandatory so please skip over them.
    SURNAME | Washington
    FIRST | George
    TITLE | Pres
    TELEPHONE | 8005551212
    ADDRESS | Mt. Vernon Estate
    Mt. Vernon, VA
    NO. CARDS ISSUED | 1
    DATE ISSUED | 07 04 76
    REASON | N
    CARD CODE | 1
    APPROVED BY | ME
  9. Press Enter.
  10. Tab to the REQUEST TYPE field.
  11. Type D to display a record.
  12. In the ACCOUNT field, type 11111.
  13. Press Enter. The following shows the record retrieved from the database:

    ACCT Record Display

  14. Clear the screen of your TN3270 emulator to return to the main menu, then clear the screen again to exit the application.
Parent topic: Tutorial: Assembler
Previous topic: Start the AACT Enterprise Server


Tutorials: CICS

  1. Tutorial: CICS
  2. Tutorial: Web-Enabled CICS Acting as a Web Server
  3. Tutorial: Web-Enabled CICS Acting as a Web Client
Parent topic: Mainframe Tutorials


Tutorial: CICS

  1. Introduction
    This tutorial walks you through the process of implementing and running the sample transaction ACCT.
  2. Create a project
  3. Specify Project Properties
  4. Import Files From the Demonstration Program
  5. Build the Solution
  6. Configure Enterprise Server/MSS
  7. Set Up and Run the ACCT Application
  8. Debug the CICS Application
Parent topic: Tutorials: CICS
Next topic: Tutorial: Web-Enabled CICS Acting as a Web Server
Related information
Configure Enterprise Server/MSS
Create a project
Set Up and Run the ACCT Application
Debug the CICS Application


Introduction

ACCT is a sample CICS 3270 transaction which comprises several COBOL programs and a single BMS map, and uses the resource definitions in the file dfhdrdat. This tutorial walks you through the steps required to implement and test the ACCT transaction.

Prerequisites

To complete this tutorial, you need the following software:

  • Studio Enterprise Edition
  • Micro Focus RUMBA or another TN3270 emulator.
Parent topic: Tutorial: CICS
Next topic: Create a project


Create a project

You create a project that comprises all the parts of your application, for example the COBOL source and BMS files. You build the demonstration application in the IDE, and deploy and run it on an Enterprise Server configured with the MSS.

  1. Create a working directory on your machine such as c:\tutorials.
  2. Start Visual Studio.
  3. Click File > New > Project.
  4. Under the COBOL templates, click Native and then Mainframe Subsystem Application.
  5. Specify a name for your project such as ACCT.
  6. Specify your working folder, c:\tutorials, in the Location field.
  7. Disable Create directory for solution.
  8. Click OK.

    This creates an ACCT folder in your working directory.

Parent topic: Tutorial: CICS
Previous topic: Introduction
Next topic: Specify Project Properties
Related information
Tutorial: CICS
Configure Enterprise Server/MSS
Set Up and Run the ACCT Application
Debug the CICS Application


Specify Project Properties

To specify properties for your project:

  1. In Solution Explorer, double-click the Properties folder.
  2. On the Copybook Paths tab, type .\cpy in the text box.
  3. On the BMS tab:
    1. Select Yes for the Create Copybook and Create Load Module options.
    2. In the Copybook Output Path text box, enter .\cpy.
    3. In the Load Module Output Path text box, enter .\loadlib.
  4. On the COBOL tab:
    1. Ensure Platform Target is set to Active (x86).
    2. Make sure Generate debugging information is checked.
    3. From the Source Format drop-down list, choose Fixed.
    4. Type .\loadlib in the Output path field.
    5. Set Character set to ASCII.
  5. On the Debug tab, choose CICS from the Choose Active Setting drop-down list.
  6. Click File > Save All.
Parent topic: Tutorial: CICS
Previous topic: Create a project
Next topic: Import Files From the Demonstration Program
Parent topic: Create Project and Configure Server
Previous topic: Create a Project
Next topic: Import Files from the Demonstration Program


Import Files From the Demonstration Program

To import the files from the CICS demonstration program into your project:

  1. Browse to the location of the ACCT sample in the install directory of the Samples %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Visual Studio Integration\Tutorials\Mainframe\CICS\ACCT directory.
  2. Copy the bms, cbl, and cpy subfolders from this folder and paste them into your project's directory, c:\tutorials\ACCT.
  3. Create the following new subfolders in the project directory, c:\tutorials\ACCT - system and data.
  4. In Visual Studio, right-click your project in Solution Explorer and select Add > Existing Item.
  5. Browse to the c:\tutorials\ACCT\cbl folder and then click Add.
  6. Select all .cbl files and then click Add.
  7. Browse to the c:\tutorials\ACCT\bms folder.
  8. Set the file type filter BMS Files (*.bms).
  9. Select the .bms file and then click Add.
    Note: The BMS map needs to be included in your project, so that you can compile it easily. There is no need to edit the BMS file for the purposes of this tutorial. However, if you did need to edit it, you would do this using the BMS Painter.
Parent topic: Tutorial: CICS
Previous topic: Specify Project Properties
Next topic: Build the Solution


Build the Solution

To build the solution:

  1. Right-click the solution in Solution Explorer.
  2. Choose Build.
Parent topic: Tutorial: CICS
Previous topic: Import Files From the Demonstration Program
Next topic: Configure Enterprise Server/MSS
Parent topic: Create Project and Configure Server
Previous topic: Import Files from the Demonstration Program
Next topic: Create an Enterprise Server


Configure Enterprise Server/MSS

Overview

In this tutorial, you create an enterprise server with the Mainframe Subsystem Support (MSS), configure it for the ACCT application, and run the application under Enterprise Server/MSS.

Create an Enterprise Server

Server Enterprise Edition comes with a pre-configured enterprise server named ESDEMO. However, it is not configured for Mainframe Subsystem Support (MSS). Therefore, you must create a new enterprise server instance configured for MSS for the CICS application.

  1. Open the Server Explorer window in the IDE.

    If it is hidden, click View > Server Explorer.

  2. In Server Explorer, right-click Micro Focus Servers and choose Administration from the context menu.

    This opens the home page of Enterprise Server Administration (also called MFDS) in the IDE.

    Alternatively, you can open the Enterprise Server Administration from the Start menu - click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Configuration > Enterprise Server Administration. This opens Enterprise Server Administration in a browser outside of the IDE.

  3. Click Add.
  4. In the Server Name field, type ACCT and click Next.
  5. Choose 32-bit for the Working mode option.
  6. Click Next.
  7. In the Server Type group, select Micro Focus Enterprise Server with Mainframe Subsystem Support.
  8. Click Next.
  9. In the Creation Options group, enter 5239 in the Using port field. This will be the port number to be used to customize the 3270 emulator.
  10. In the Description field, type a description of the new Enterprise Server, for example ACCT demo.
  11. Click Add.

    This displays the Enterprise Server Administration home page with your new ACCT server in the list of the available enterprise servers.

Configure the Enterprise Server

Now that you have created an enterprise server instance for our CICS application, you need to configure the Mainframe Subsystem Support that drives CICS applications. The ACCT application is already compiled, so configuration is minimal.

  1. On the Enterprise Server Administration home page, click the Edit button that corresponds to the ACCT enterprise server.
  2. Click the General tab.
  3. Type the following in the Configuration Information text box:
    [ES-Environment]
ESPROJ=c:\tutorials\ACCT

    You are going to reuse this environment variable to configure your enterprise server further.

  4. Click Apply.
  5. Click the MSS tab.
  6. Ensure that Mainframe Subsystem Support enabled is checked.
  7. Enter the following details in the fields on the CICS tab:
    System Initialization Table | DEMOSIT
    Transaction Path | $ESPROJ\loadlib
    File Path | $ESPROJ\data
    Map Path | $ESPROJ\loadlib
    Resource Definition File Path | $ESPROJ\system
  8. Click Apply.
  9. On the list at the left of the page, click Home to return to the Enterprise Server Administration Home page.

Create and Upgrade the CICS Resource Definition File

  1. Open the Net Express command prompt by choosing Start > Programs > Micro Focus Studio Enterprise Edition > Compatibility Tools > Net Express 32-bit Command Prompt.
  2. Create a CICS resource definition file using following command:
    caspcrd /c /dp=c:\tutorials\acct\system
  3. Upgrade the resource definition file by running the following command:
    caspcupg /dp=c:\tutorials\acct\system

Start the ACCT Enterprise Server

You need to start the enterprise server instance that you have created and configured.

  1. Ensure ESDEMO and any other servers that use the TN3270 port are not running. If any of them is running, stop it before starting the ACCT server.

    This is because they use the same port the ACCT server uses for one of their listeners.

  2. In Server Explorer, right-click ACCT in the list of servers and then click Start.
Parent topic: Tutorial: CICS
Previous topic: Build the Solution
Next topic: Set Up and Run the ACCT Application
Related information
Tutorial: CICS
Create a project
Set Up and Run the ACCT Application
Debug the CICS Application


Set Up and Run the ACCT Application

Having created and configured an enterprise server instance with Mainframe Subsystem Support for the ACCT application, you need to create a VSAM file for the ACCT transaction to execute properly.

Note: If you stopped your ACCT enterprise server, start it again.

Initialize VSAM Files

Before you can run ACCT, you need to initialize its VSAM file.

  1. Use a host name of localhost and port number 5239 to connect your TN3270 emulator to the enterprise server.
  2. Clear the CESN login screen as security is not enabled - in Micro Focus RUMBA you need to press CTRL+SHIFT+Z.
  3. Type CFCR ACCTFIL and press Enter to initialize the VSAM files for the application.

    You should receive a message indicating that the file was successfully created.

If the ACCTFIL VSAM was previously initialized, a message appears explaining that the ACCTFIL already exists. This might be the case, especially if you have previously run this tutorial.

Start the CICS Transaction

  1. Clear the screen of your TN3270 emulator.
  2. Enter ACCT. This shows the initial screen of our application.

Add Two Records

You will use the records you create here later on in the tutorial.

  1. Tab to the REQUEST TYPE field and type A.
  2. In the ACCOUNT field, type 11111.
  3. Press Enter.
  4. Complete the fields on the NEW RECORD screen as follows. Of the three ADDRESS fields, complete only the first two. Fields not represented here are not mandatory so please skip over them.
    SURNAME | Washington
    FIRST | George
    TITLE | Pres
    TELEPHONE | 7037802000
    ADDRESS | Mt. Vernon Estate
    Mt. Vernon, VA 22121
    NO. CARDS ISSUED | 1
    DATE ISSUED | 07 04 76
    REASON | N
    CARD CODE | 1
    APPROVED BY | JF
  5. Press Enter.
  6. Tab to the REQUEST TYPE field and type A.
  7. In the ACCOUNT field, type 11112 and press Enter.
  8. Repeat steps 4 and 5, substituting the following data:
    SURNAME | Jefferson
    FIRST | Thomas
    TITLE | Pres
    TELEPHONE | 4349849800
    ADDRESS | Monticello
    Charlottesville, VA 22902
    NO. CARDS ISSUED | 3
    DATE ISSUED | 07 04 76
    REASON | N
    CARD CODE | 1
    APPROVED BY | JF
  9. Press Enter to return to the Menu.

Display a Record

  1. Tab to the REQUEST TYPE field.
  2. Type D to display a record.
  3. In the ACCOUNT field, type 11111.
  4. Press Enter. This displays the record retrieved from the database.

    ACCT Record Display

  5. Clear the screen of your TN3270 emulator to exit the application.
Parent topic: Tutorial: CICS
Previous topic: Configure Enterprise Server/MSS
Next topic: Debug the CICS Application
Related information
Tutorial: CICS
Configure Enterprise Server/MSS
Create a project
Debug the CICS Application


Debug the CICS Application

You can start debugging your CICS application by using the Enterprise Server Dynamic Debugging facility, which enables you to debug a service on a local or remote enterprise server.

Note: When you have finished debugging, you must stop the debugger before you stop the enterprise server. This stops all the active transactions and ensures the enterprise server stops cleanly.

Configure the Enterprise Server for Dynamic Debugging

  1. In Server Explorer, right-click ACCT in the list of servers and then click Stop.
  2. Right-click Micro Focus Servers and then click Administration.
  3. On the Enterprise Server Administration home page, click Edit in the row for the ACCT server.
  4. Check Allow Dynamic Debugging and then click OK.
  5. Return to the Enterprise Server Administration home page.

Set Project Properties for Debugging

  1. Select your project in Solution Explorer and click Project > Properties
  2. Click the Debug tab.
  3. Ensure Choose Active Settings is set to CICS.
  4. Type ACCT in the Transaction text box.
  5. Click File > Save All.

Associate Your Project with the Target Enterprise Server

  1. In Visual Studio, right-click Micro Focus Servers in Server Explorer and choose Refresh.
  2. In Server Explorer, right-click ACCT in the list of servers and then click Start. If this is the first time you have started the server you might see a sign-on dialog box. Select Store Credentials to skip this step in the future, and click OK to continue.
  3. Right-click ACCT in Server Explorer and choose Associate with project > ACCT.

Debug the ACCT Application

  1. Click Debug > Start Debugging.

    To start debugging you need to run the application.

  2. Run the ACCT transaction from your 3270 emulator.
  3. Step through the application in the usual manner.
  4. To stop debugging, click Debug > Stop Debugging.
  5. To stop the server, right-click ACCT in Server Explorer and click Stop.
Parent topic: Tutorial: CICS
Previous topic: Set Up and Run the ACCT Application
Related information
Tutorial: CICS
Configure Enterprise Server/MSS
Create a project
Set Up and Run the ACCT Application


Tutorial: Web-Enabled CICS Acting as a Web Server

  1. Introduction
    This tutorial walks you through the process of implementing and running the Web-enabled version of the sample transaction ACCT.
  2. Create Project and Configure Server
    In this step, you create an enterprise server with the Mainframe Subsystem Support (MSS), configure it for the ACCTWEB application, and run the application under Enterprise Server/MSS.
  3. Set Up the ACCTWEB Application
    Having created, configured, and started an enterprise server with MSS for ACCT, and the Web-enabled version ACCTWEB, you need to create a VSAM file for the ACCTWEB application to execute properly.
  4. Run the ACCTWEB Application
    In this step, you run the CICS Web-enabled application.
  5. Debug the Application
    In this step, you debug your CICS Web-enabled application.
Parent topic: Tutorials: CICS
Previous topic: Tutorial: CICS
Next topic: Tutorial: Web-Enabled CICS Acting as a Web Client


Introduction

ACCT is a sample CICS transaction. With the added CICS Web support, part of this transaction has been web-enabled. The walkthrough will take you through the steps required to implement and test this web-enabled version of ACCT.

The ACCT transaction comprises several COBOL programs and a BMS map, and uses the resource definitions in the file dfhdrdat. In the Web-enabled version, all the components of the transaction are unchanged except for acct01.cbl. Note that acct01.cbl is still compatible with a non-web-enabled version of ACCT.

Note: The ACCTWEB demonstration only supports the SEARCH BY NAME function of ACCT. It is not possible to add or modify individual records.

Prerequisites

To complete this tutorial, you need the following software:
  • Studio Enterprise Edition
  • Micro Focus RUMBA or another TN3270 emulator.
Parent topic: Tutorial: Web-Enabled CICS Acting as a Web Server
Next topic: Create Project and Configure Server


Create Project and Configure Server

  1. Create a Project
  2. Specify Project Properties
  3. Import Files from the Demonstration Program
  4. Build the Solution
  5. Create an Enterprise Server
  6. Configure the Enterprise Server
  7. Create and Upgrade the CICS Resource Definition File
  8. Start the ACCTWEB Server
Parent topic: Tutorial: Web-Enabled CICS Acting as a Web Server
Previous topic: Introduction
Next topic: Set Up the ACCTWEB Application


Create a Project

To create a project to hold the demo application files:

  1. Create a working directory on your machine, for example c:\tutorials\.
  2. Start Visual Studio.
  3. Click File > New > Project > COBOL Projects > Native > Mainframe Subsystem Application.
  4. Specify a name for your project, for example acctweb.
  5. Specify your working folder as c:\tutorials\ in the Location text box.
  6. Clear the Create directory for solution check box.
  7. Click OK. This creates a folder acctweb in your working directory.
Parent topic: Create Project and Configure Server
Next topic: Specify Project Properties


Import Files from the Demonstration Program

To import the files from the CICS demonstration program into your project:

  1. Navigate to your project directory, c:\tutorials\ACCTWEB.
  2. Browse to the location of the ACCTWEB sample in the install directory of the Samples %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Tutorials\Mainframe\CICS\ACCTWEB directory.
  3. Copy the bms, cbl, cpy, and html subfolders and their content from this folder and paste them into your project's directory, c:\tutorials\ACCTWEB.
  4. Create the following new subfolders in the project directory, c:\tutorials\ACCTWEB - system and data.
  5. In Visual Studi0, right-click your project in Solution Explorer and select Add > Existing Item.
  6. Browse to the project directory, click the cbl folder and then click Add.

    This opens the contents of the cbl folder.

  7. Set the file type filter on the Add Existing Item dialog to All files (*.*).
  8. Select all .cbl files and then click Add.
  9. Add the bms folder and the bms file in the same manner.
    Note: The BMS map needs to be included in your project, so that you can compile it easily. There is no need to edit the BMS file for the purposes of this tutorial. However, if you did need to edit it, you would do this using the BMS Painter.
Parent topic: Create Project and Configure Server
Previous topic: Specify Project Properties
Next topic: Build the Solution


Create an Enterprise Server

You must create a new Enterprise Server instance, configured for MSS, for the ACCTWEB application.

To create the server:

  1. Open the Server Explorer window in the IDE.

    If it is hidden, click View > Server Explorer.

  2. In Server Explorer, right-click Micro Focus Servers and choose Administration from the context menu.

    This opens the home page of Enterprise Server Administration (also called MFDS) in the IDE.

    Alternatively, you can open the Enterprise Server Administration from the Start menu - click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Configuration > Enterprise Server Administration. This opens Enterprise Server Administration in a browser outside of the IDE.

  3. Click Add.
  4. In the Server Name field, type ACCTWEB.
  5. Choose 32-bit for the Working mode option.
  6. Click Next.
  7. In the Server Type group, select Micro Focus Enterprise Server with Mainframe Subsystem Support.
  8. Click Next.
  9. In the Creation Options group, enter 5239 in the Using port field. This will be the port number to be used to customize the 3270 emulator.
  10. In the Description field, type a description of the new Enterprise Server, for example ACCT WEB demo.
  11. Click Add.

    This displays the Enterprise Server Administration home page with your new ACCTWEB server in the list of the available enterprise servers.

Parent topic: Create Project and Configure Server
Previous topic: Build the Solution
Next topic: Configure the Enterprise Server


Configure the Enterprise Server

Now that you have created an enterprise server instance for the CICS application, you need to configure the Mainframe Subsystem Support that drives CICS applications.

  1. On the Enterprise Server Administration home page, click the Edit button that corresponds to the ACCTWEB enterprise server.
  2. On the General tab, add the following entry in the Configuration Information text box:
    [ES-Environment]
ESPROJ=c:\tutorials\acctweb
ES_DOCTEMPLATE_PATH=$ESPROJ\html

    This path is used in the template definition for the DOCUMENT created in this tutorial: ACCTMP1, defined in the group DFHWEB.

  3. Click Apply.
  4. Select the MSS tab.
  5. Choose Mainframe Subsystem Support enabled and enter the following values for the options:
    System Initialization Table | DEMOSIT
    Transaction Path | $ESPROJ\loadlib
    File Path | $ESPROJ\data
    Map Path | $ESPROJ\loadlib
    Resource Definition File Path | $ESPROJ\system
  6. Click Apply.
  7. On the menu at the left of the page, click Home to return to the Enterprise Server Administration Home page.
Parent topic: Create Project and Configure Server
Previous topic: Create an Enterprise Server
Next topic: Create and Upgrade the CICS Resource Definition File


Create and Upgrade the CICS Resource Definition File

  1. Open the Net Express command prompt by choosing Start > Programs > Micro Focus Studio Enterprise Edition > Compatibility Tools > Net Express 32-bit Command Prompt.
  2. Create a CICS resource definition file using following command:
    caspcrd /c /dp=c:\tutorials\acctweb\system
  3. For CICS Web support a new group has been added to the system. To ensure this group appears on the list of available groups to add to your resources, upgrade the resource definition file by running the following command:
    caspcupg /dp=c:\tutorials\acctweb\system
    This updates the CICS resource definition file and makes the DFHWEB group available.
Parent topic: Create Project and Configure Server
Previous topic: Configure the Enterprise Server
Next topic: Start the ACCTWEB Server


Start the ACCTWEB Server

You need to start the enterprise server instance that you have now created and configured.

  1. Make sure ESDEMO and any other server that us using the TN3270 is not running. If it is, stop it before starting the ACCTWEB server.

    This is because these two servers use the same port for one of their listeners.

  2. In Server Explorer, expand the Micro Focus Servers group.

    The view may need to be refreshed by right-clicking Micro Focus Servers and selecting Refresh.

  3. Right-click ACCTWEB and click Start.

    The server needs a few seconds to start running.

  4. When ACCTWEB has a status of Started, click Edit on the row for the server in the Enterprise Server Administration.
  5. Click Control and then ES monitor & Control.
  6. You need to add the new group DFHWEB to your system. In the Resources pane, select by Group from the drop-down list and click Startup.
  7. In the list of startup lists, select DEMOSTRT, and in box 14 enter DFHWEB. This is the name of the group you need to add for CICS Web support and contains the system resources as well as the one required by the ACCTWEB demo.
  8. Click Apply.
  9. Ensure that the resources are available to the system by either running CINS DFHWEB from your 3270 emulator or restarting your ACCTWEB enterprise server.
Parent topic: Create Project and Configure Server
Previous topic: Create and Upgrade the CICS Resource Definition File


Set Up the ACCTWEB Application

Having created, configured, and started an enterprise server with MSS for ACCT, and the Web-enabled version ACCTWEB, you need to create a VSAM file for the ACCTWEB application to execute properly.
Note: If you stopped your ACCTWEB enterprise server, start it again.
  1. Initialize the VSAM File
  2. Add Records to the VSAM File
  3. Add Records
Parent topic: Tutorial: Web-Enabled CICS Acting as a Web Server
Previous topic: Create Project and Configure Server
Next topic: Run the ACCTWEB Application


Initialize the VSAM File

Before you can run ACCTWEB you need to initialize its VSAM file.

  1. Connect your TN3270 emulator to your enterprise server using a host name of localhost and a port number of 5239.
  2. Clear the screen to clear the CESN login screen as security is not enabled.
  3. Enter CFCR ACCTFIL. You should receive a message indicating that the file was successfully created.
Note: If the ACCTFIL VSAM was previously initialized, a message appears explaining that ACCTFIL already exists. This might be the case, especially if you have previously run this tutorial.
Parent topic: Set Up the ACCTWEB Application
Next topic: Add Records to the VSAM File


Add Records to the VSAM File

You only need to run ACCT in a TN3270 session to add records to the ACCTFIL file as the ACCTWEB demo runs in a Web browser.

  1. Clear the screen of your TN3270 emulator.
  2. Enter ACCT. This shows the initial screen of our application.
Parent topic: Set Up the ACCTWEB Application
Previous topic: Initialize the VSAM File
Next topic: Add Records


Add Records

Create two records to use later in the tutorial.

  1. Tab to the REQUEST TYPE field and type A.
  2. In the ACCOUNT field, type 11111 .
  3. Press Enter.
  4. Complete the fields on the NEW RECORD screen as follows. Of the three ADDRESS fields, complete only the first two. Fields not represented in this topic are not mandatory and can be ignored.
    SURNAME | Washington
    FIRST | George
    TITLE | Pres
    TELEPHONE | 7037802000
    ADDRESS Mt. Vernon Estate

    Mt. Vernon, VA 22121

    NO. CARDS ISSUED | 1
    DATE ISSUED | 07 04 76
    REASON | N
    CARD CODE | 1
    APPROVED BY | JF
  5. Press Enter.
  6. Repeat steps 1 and 2, substituting 11112 in the ACCOUNT field.
  7. Repeat steps 3 through 5, substituting the following data:
    SURNAME | Washington
    FIRST | Martha
    TITLE | Mrs
    TELEPHONE | 7037802000
    ADDRESS Mt. Vernon Estate

    Mt. Vernon, VA 22121

    NO. CARDS ISSUED | 1
    DATE ISSUED | 07 04 77
    REASON | N
    CARD CODE | 1
    APPROVED BY | NF
  8. Press Enter to return to the menu.
Parent topic: Set Up the ACCTWEB Application
Previous topic: Add Records to the VSAM File


Run the ACCTWEB Application

  1. Open a browser and enter the following URL: http://localhost:9003/ACCTWEB. The name ACCTWEB (defined in the URIMAP) is case sensitive. This takes you to the ACCTWEB page.
  2. In the Surname field enter W and click Submit. You should see both Washington records you defined using the 3270 version of the ACCT application.
Parent topic: Tutorial: Web-Enabled CICS Acting as a Web Server
Previous topic: Set Up the ACCTWEB Application
Next topic: Debug the Application


Debug the Application

You can start debugging a CICS application by using the Enterprise Server Dynamic Debugging facility, which enables you to debug a service on a local or remote enterprise server.

Note: When you have finished debugging, you must stop the debugger before you stop the enterprise server. This stops all the active transactions and ensures the enterprise server stops cleanly.
  1. Configure Enterprise Server for Dynamic Debugging
  2. Associate the Project with the Target Enterprise Server
  3. Configure the Project Debugging Properties
  4. Debug ACCTWEB
Parent topic: Tutorial: Web-Enabled CICS Acting as a Web Server
Previous topic: Run the ACCTWEB Application


Configure Enterprise Server for Dynamic Debugging

  1. In Server Explorer, right-click Micro Focus Servers and choose Administration from the context menu.
  2. On the Enterprise Server Administration page, click Edit in the row for ACCTWEB.
  3. Check Allow Dynamic Debugging then OK.
  4. Stop the ACCTWEB enterprise server.
Parent topic: Debug the Application
Next topic: Associate the Project with the Target Enterprise Server


Associate the Project with the Target Enterprise Server

  1. In Server Explorer, right-click Micro Focus Servers and choose Refresh.
  2. Right-click ACCTWEB and choose Start from the context menu.
  3. Right-click ACCTWEB and choose Associate with project > your project.
Parent topic: Debug the Application
Previous topic: Configure Enterprise Server for Dynamic Debugging
Next topic: Configure the Project Debugging Properties


Configure the Project Debugging Properties

  1. In your Visual Studio project, select the Debug properties tab.
  2. Select CICS from the Choose Active Settings drop-down list.
  3. Enter ACCTWEB in the Link-level program text box.
Parent topic: Debug the Application
Previous topic: Associate the Project with the Target Enterprise Server
Next topic: Debug ACCTWEB


Debug ACCTWEB

  1. Click Debug > Start debugging.
  2. Run the ACCTWEB application.
  3. Step through the application in the usual manner.
  4. To stop debugging, click Debug > Stop debugging.
  5. To stop the server, right-click ACCTWEB in Server Explorer and click Stop.
Parent topic: Debug the Application
Previous topic: Configure the Project Debugging Properties


Tutorial: Web-Enabled CICS Acting as a Web Client

  1. Introduction
    This tutorial walks you through the process of building and running a version of the sample transaction ACCT that acts as a Web client.
  2. Configure Enterprise Server for a Web-Enabled Application
    In this step, you create an enterprise server with the Mainframe Subsystem Support (MSS), configure it for the ACCTCLNT application, and run the application under Enterprise Server/MSS.
  3. Set Up and Run the ACCTCLNT Application
  4. Debug the Application
    In this step, you debug your CICS Web-enabled application.
Parent topic: Tutorials: CICS
Previous topic: Tutorial: Web-Enabled CICS Acting as a Web Server


Introduction

This tutorial uses a modified and extended version of the ACCT demonstration application.

In this version, it uses the CICS Web client APIs to act as a Web client, and converses with a Web server to submit and retrieve account information.

For this reason a server program is also included that acts as the back end for the demonstration application.

Prerequisites

  • Studio Enterprise Edition
  • Micro Focus RUMBA or another TN3270 emulator.
Parent topic: Tutorial: Web-Enabled CICS Acting as a Web Client
Next topic: Configure Enterprise Server for a Web-Enabled Application


Configure Enterprise Server for a Web-Enabled Application

  1. Create a Project
  2. Specify Project Properties
  3. Import the Web Client Demo Program Files
  4. Build the Solution
  5. Create an Enterprise Server
  6. Configure the Enterprise Server
  7. Create and Upgrade the CICS Resource Definition File
  8. Start the ACCTCLNT Server
Parent topic: Tutorial: Web-Enabled CICS Acting as a Web Client
Previous topic: Introduction
Next topic: Set Up and Run the ACCTCLNT Application


Create a Project

To create a project to hold the demo application files:

  1. Create a working directory on your machine, for example c:\tutorials\.
  2. Start Visual Studio.
  3. Click File > New > Project.
  4. Under Installed Templates, expand COBOL and select Native. In the right-hand pane, select Mainframe Subsystem Application.
  5. Enter acctclnt as the name of the project.
  6. Enter c:\tutorials as the location of your project.
  7. Clear the Create directory for solution check box.
  8. Click OK. This creates a folder acctclnt in the directory specified in the Location text box.
Parent topic: Configure Enterprise Server for a Web-Enabled Application
Next topic: Specify Project Properties


Specify Project Properties

To specify properties for your project:

  1. In Solution Explorer, double-click the Properties folder.
  2. On the Copybook Paths tab, type .\cpy in the text box.
  3. On the BMS tab:
    1. Select Yes for the Create Copybook and Create Load Module options.
    2. In the Copybook Output Path text box, enter .\cpy.
    3. In the Load Module Output Path text box, enter .\loadlib.
  4. On the COBOL tab:
    1. Ensure Platform Target is set to x86.
    2. Set Character set to ASCII.
    3. From the Source Format drop-down list, choose Fixed.
    4. Make sure Generate debugging information is checked.
    5. Type .\loadlib in the Output path field.
  5. On the Debug tab, choose CICS from the Choose Active Setting drop-down list.
  6. Click File > Save All.
Parent topic: Configure Enterprise Server for a Web-Enabled Application
Previous topic: Create a Project
Next topic: Import the Web Client Demo Program Files


Import the Web Client Demo Program Files

You need to import the files from the CICS demonstration program into your project.

  1. Browse to the location of the ACCTCLNT sample in the install directory of the Samples %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Tutorials\Mainframe\CICS\ACCTCLNT directory.
  2. Copy the bms, cbl, and cpy subfolders from this folder and paste them into your project's directory, c:\tutorials\ACCTCLNT.
  3. Create the following new subfolders in the project directory, c:\tutorials\ACCTCLNT - system and data.
  4. In Visual Studio, right-click your project in Solution Explorer and select Add > Existing Item.
  5. Browse to the project directory, click the cbl folder and then click Add.

    This opens the contents of the cbl folder.

  6. Set the file type filter on the Add Existing Item dialog to All files (*.*).
  7. Select all .cbl files and then click Add.
  8. Add the bms folder and the bms file in the same manner.
    Note: The BMS map needs to be included in your project, so that you can compile it easily. There is no need to edit the BMS file for the purposes of this tutorial. However, if you did need to edit it, you would do this using the BMS Painter.
Parent topic: Configure Enterprise Server for a Web-Enabled Application
Previous topic: Specify Project Properties
Next topic: Build the Solution


Build the Solution

Note: The application's .idy files are created automatically and generated in the same place as the application's .dll files because the active configuration is "Debug".

To build the solution:

  1. Right-click acctclnt in Solution Explorer.
  2. Choose Build.
Parent topic: Configure Enterprise Server for a Web-Enabled Application
Previous topic: Import the Web Client Demo Program Files
Next topic: Create an Enterprise Server


Create an Enterprise Server

You must create a new Enterprise Server instance, configured for MSS, for the ACCTCLNT CICS application.

To create the server:

  1. Open the Server Explorer window in the IDE.

    If it is hidden, click View > Server Explorer.

  2. In Server Explorer, right-click Micro Focus Servers and choose Administration from the context menu.

    This opens the home page of Enterprise Server Administration (also called MFDS) in the IDE.

    Alternatively, you can open the Enterprise Server Administration from the Start menu - click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Configuration > Enterprise Server Administration. This opens Enterprise Server Administration in a browser outside of the IDE.

  3. Click Add.
  4. In the Server Name field, type ACCTCLNT and click Next.
  5. Choose 32-bit for the Working mode option.
  6. Click Next.
  7. In the Server Type group, select Micro Focus Enterprise Server with Mainframe Subsystem Support.
  8. Click Next.
  9. In the Creation Options group, enter 5239 in the Using port field. This will be the port number to be used to customize the 3270 emulator.
  10. In the Description field, type a description of the new Enterprise Server, for example CICS Web Client Tutorial.
  11. Click Add.

    This displays the Enterprise Server Administration home page with your new ACCTCLNT demo server in the list of the available enterprise servers.

Parent topic: Configure Enterprise Server for a Web-Enabled Application
Previous topic: Build the Solution
Next topic: Configure the Enterprise Server


Configure the Enterprise Server

Now that you have created an enterprise server instance for the CICS application, you need to configure the Mainframe Subsystem Support that drives CICS applications.

  1. On the Enterprise Server Administration home page, click the Edit button that corresponds to the ACCTCLNT enterprise server.
  2. Click the General tab.
  3. Type the following in the Configuration Information text box:
    [ES-Environment]
ESPROJ=c:\tutorials\ACCTCLNT

    You are going to reuse this environment variable to configure your enterprise server further.

  4. Click Apply.
  5. Click the MSS tab.
  6. Ensure that Mainframe Subsystem Support enabled is checked.
  7. Enter the following details in the fields on the CICS tab:
    System Initialization Table | DEMOSIT
    Transaction Path | $ESPROJ\loadlib
    File Path | $ESPROJ\data
    Map Path | $ESPROJ\loadlib
    Resource Definition File Path | $ESPROJ\system
  8. Click Apply.
  9. On the list at the left of the page, click Home to return to the Enterprise Server Administration Home page.
Parent topic: Configure Enterprise Server for a Web-Enabled Application
Previous topic: Create an Enterprise Server
Next topic: Create and Upgrade the CICS Resource Definition File


Create and Upgrade the CICS Resource Definition File

  1. Open the Net Express command prompt by choosing Start > Programs > Micro Focus Studio Enterprise Edition > Compatibility Tools > Net Express 32-bit Command Prompt.
  2. Create a CICS resource definition file using following command:
    caspcrd /c /dp=c:\tutorials\acctclnt\system
  3. For CICS Web support a new group has been added to the system. To ensure this group appears on the list of available groups to add to your resources, upgrade the resource definition file by running the following command:
    caspcupg /dp=c:\tutorials\acctclnt\system
    This updates the CICS resource definition file and makes the DFHWEB group available.
Parent topic: Configure Enterprise Server for a Web-Enabled Application
Previous topic: Configure the Enterprise Server
Next topic: Start the ACCTCLNT Server


Start the ACCTCLNT Server

To setup the necessary CICS resources, you need to start the enterprise server instance that you have created and configured.

  1. Make sure the ESDEMO server and any other server that uses the TN3270 port is not running. If it is, stop the server before starting the ACCTCLNT server.

    This is because these two servers use the same port for one of their listeners.

  2. In Server Explorer, right-click ACCTCLNT in the list of servers and then click Start.
  3. Click the Details button under Status that corresponds to the ACCTCLNT Enterprise Server.
  4. Select ES Monitor & Control.
  5. You need to add the new group DFHWEB to your system. In the Resources pane, select by Group from the drop-down list and choose Startup.
  6. Select DEMOSTRT by clicking the corresponding Details button, and enter DFHWEB in box 14. This is the group that contain the necessary CICS Web system resources.
  7. Click Apply.
  8. In box 15 enter DFHCWI. This group contains ACCTCLNT-specific resources.
  9. Click Apply.
  10. Ensure that the resources are available to the system by either running CINS DFHWEB and CINS DFHCWI from your 3270 emulator, or by restarting your ACCTCLNT enterprise server.
Parent topic: Configure Enterprise Server for a Web-Enabled Application
Previous topic: Create and Upgrade the CICS Resource Definition File


Set Up and Run the ACCTCLNT Application

Overview

Now that you have created, configured, and started an enterprise server with MSS for the CICS application, you need to run the application and become familiar with how it works.

Preparation

If you have stopped your ACCTCLNT enterprise server, start it again.

Initialize VSAM Files

Before you can run our application via the enterprise server you have created and started, you need to initialize its VSAM files.

  1. Connect to your enterprise server using your TN3270 emulator. Your host name is localhost, and the port number is 5239.
  2. Clear the CESN login screen as security is not enabled.
  3. Enter CFCR ACCTFIL. You should receive a message indicating that the file was successfully created.
Note: If the ACCTFIL VSAM was previously initialized, a message appears explaining that the ACCTFIL already exists. This might be the case, especially if you have previously run this tutorial.

Start the CICS Transaction

This application lets you add, display, modify or delete information in the VSAM file you have just created.

  1. Clear the screen of your TN3270 emulator.
  2. Enter ACCT. This shows the initial screen of our application.

Add Two Records

You will use the records you create here later on in the tutorial.

  1. Tab to the REQUEST TYPE field and type A.
  2. In the ACCOUNT field, type 11111.
  3. Press Enter.
  4. Complete the fields on the NEW RECORD screen as follows. Of the three ADDRESS fields, complete only the first two. Fields not represented here are not mandatory so please skip over them.
    SURNAME | Washington
    FIRST | George
    TITLE | Pres
    TELEPHONE | 7037802000
    ADDRESS | Mt. Vernon Estate
    Mt. Vernon, VA 22121
    NO. CARDS ISSUED | 1
    DATE ISSUED | 07 04 76
    REASON | N
    CARD CODE | 1
    APPROVED BY | JF
  5. Press Enter.
  6. Tab to the REQUEST TYPE field and type A.
  7. In the ACCOUNT field, type 11112 and press Enter.
  8. Repeat steps 4 and 5, substituting the following data:
    SURNAME | Jefferson
    FIRST | Thomas
    TITLE | Pres
    TELEPHONE | 4349849800
    ADDRESS | Monticello
    Charlottesville, VA 22902
    NO. CARDS ISSUED | 3
    DATE ISSUED | 07 04 76
    REASON | N
    CARD CODE | 1
    APPROVED BY | JF
  9. Press Enter to return to the Menu.

Display a Record

  1. Tab to the REQUEST TYPE field.
  2. Type D to display a record.
  3. In the ACCOUNT field, type 11111.
  4. Press Enter. This displays the record retrieved from the database.

    ACCT Record Display

  5. Clear the screen of your TN3270 emulator to exit the application.
Parent topic: Tutorial: Web-Enabled CICS Acting as a Web Client
Previous topic: Configure Enterprise Server for a Web-Enabled Application
Next topic: Debug the Application


Debug the Application

You can start debugging a CICS application by using the Enterprise Server Dynamic Debugging facility, which enables you to debug a service on a local or remote enterprise server.

Note: When you have finished debugging, you must stop the debugger before you stop the enterprise server. This stops all the active transactions and ensures the enterprise server stops cleanly.
  1. Configure Enterprise Server for Dynamic Debugging
  2. Associate the Project with the Target Enterprise Server
  3. Configure the Project Debugging Properties
  4. Debug ACCTCLNT
Parent topic: Tutorial: Web-Enabled CICS Acting as a Web Client
Previous topic: Set Up and Run the ACCTCLNT Application


Configure Enterprise Server for Dynamic Debugging

  1. In Server Explorer, right-click ACCTCLNT in the list of servers and then click Stop.
  2. Right-click Micro Focus Servers and then click Administration.
  3. On the Enterprise Server Administration home page, click Edit in the row for the ACCTCLNT server.
  4. Check Allow Dynamic Debugging and then click OK.
  5. Return to the Enterprise Server Administration home page.
Parent topic: Debug the Application
Next topic: Associate the Project with the Target Enterprise Server


Associate the Project with the Target Enterprise Server

  1. In Visual Studio, right-click Micro Focus Servers in Server Explorer and choose Refresh.
  2. In Server Explorer, right-click ACCTCLNT in the list of servers and then click Start.
  3. Right-click ACCTCLNT in Server Explorer and choose Associate with project > ACCTCLNT.
Parent topic: Debug the Application
Previous topic: Configure Enterprise Server for Dynamic Debugging
Next topic: Configure the Project Debugging Properties


Configure the Project Debugging Properties

  1. In Solution Explorer, double-click the Properties item and select the Debug tab.
  2. Select CICS from the Choose Active Settings drop-down list.
  3. Enter ACCTCLNT in the Link-level program text box to debug the Web client program specifically. Change this at a later stage in order to debug other programs. Leave all text boxes blank if you want to debug everything.
Parent topic: Debug the Application
Previous topic: Associate the Project with the Target Enterprise Server
Next topic: Debug ACCTCLNT


Debug ACCTCLNT

  1. Choose Debug > Start Debugging.

    To start debugging you need to run the application.

  2. Run the ACCT transaction from your 3270 emulator.
  3. Step through the application in the usual manner.
  4. To stop debugging, click Debug > Stop debugging.
  5. To stop the server, right-click ACCTCLNT in Server Explorer and click Stop.
Parent topic: Debug the Application
Previous topic: Configure the Project Debugging Properties


Tutorials: HCO for SQL Server (HCOSS)

The HCO for SQL Server tutorials provide you with an opportunity to use the HCOSS toolset to perform a DB2 database migration, and provide three different scenarios in which you migrate a DB2 application to a SQL Server application.

To complete any of the HCOSS tutorials, you must have Microsoft SQL Server 2008 Enterprise or Developer Edition, including the SQL Server Management Studio installed. In addition, these tutorials assume that you are not using Windows UAC.

Additional requirements that apply to specific tutorials appear in the Requirements section of each.

To complete the DB2 Database Migration and Application Migration tutorials, you must start with the following, completing each tutorial in the order listed:
  1. Tutorial: Create a SQL Server Database
  2. Tutorial: Create a SQL Server Database Connection
  3. Tutorial: DB2 Database Migration

Following the completion of these tutorials, you may do the Application Migration tutorials in any order.

  • Tutorial: Create a SQL Server Database
    This tutorial takes you through the process of using Microsoft SQL Server Management Studio to create a SQL Server database.
  • Tutorial: Create a SQL Server Database Connection
    This tutorial takes you through the process of creating a connection to your SQL Server database using the HCOSS Manage Connections tool.
  • Tutorial: DB2 Database Migration
    This tutorial takes you through each step in the process migrating a mainframe-based DB2 database to a Microsoft SQL Server database using HCO for SQL Server database migration tools.
  • Tutorial: Application Migration - Switching Package Sets
    This tutorial takes you through the process of migrating a DB2 application to a SQL Server application, using HCOSS to switch package sets and alternate fetching data using a single cursor name.
  • Tutorial: Application Migration - Converting Labeled Duration Calculations
    This tutorial takes you through the process of migrating a DB2 application to a SQL Server application, using HCOSS to convert labeled duration calculations and managing date formats.
  • Tutorial: Application Migration - Adding Function Emulation
    This tutorial takes you through the process of migrating a DB2 application to a SQL Server application, using HCOSS to add function emulation.
Parent topic: Mainframe Tutorials


Tutorial: Create a SQL Server Database

  1. Open SQL Server 2008 Management Studio.
  2. In the Object Explorer, right-click Databases, and select New Database.
  3. Name the database HCO_Test.
  4. Click OK.
  5. Close SQL Server 2008 Management Studio.

This completes the tutorial. Next, please complete Tutorial: Create a SQL Server Database Connection.

Parent topic: Tutorials: HCO for SQL Server (HCOSS)
Related information
Tutorial: Create a SQL Server Database Connection
Tutorial: DB2 Database Migration
Tutorial: Application Migration - Switching Package Sets
Tutorial: Application Migration - Converting Labeled Duration Calculations
Tutorial: Application Migration - Adding Function Emulation


Tutorial: Create a SQL Server Database Connection

Requirements

Before attempting this tutorial, you must complete Tutorial: Create a SQL Server Database.

Create the Connection

  1. Start Studio Enterprise Edition as an administrator from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Microsoft Visual Studio 2008.
  2. From the Visual Studio IDE, click Tools > Micro Focus COBOL Tools > HCO for SQL Server Tools.
  3. From the HCO for SQL Server interface, click Manage Connections.
  4. Select the User Connection Type.
  5. From the Connection List tab, click New SQL Server Connection. This takes you to the SQL Server Connection tab.
  6. In the Data Source Name field, type HCODemo.
  7. Click Integrated Windows Authentication to select it. This means that SQL Server uses your Windows logon credentials to access the database.
  8. In the SQL Server Instance field, type the name of your SQL Server instance. If you have a default instance, this could be . or (local). If you have a named instance, use the combined server name and instance name. For example: mysqlserver\myinstance.
  9. Click Confirm Server to confirm that HCOSS can locate your specified SQL Server Instance.
  10. Check Use a database other than the default database:.
  11. From the Database drop-down menu, select the HCO_Test destination database that you created in SQL Server 2008 Management Studio.
  12. Click Test. If the test fails, review your field entries, make corrections accordingly, and try again. When you have a successful connection, click OK.
  13. Click Save to save the connection. This takes you back to the Connection List tab where you should now see your SQL Server connection listed.

This completes the tutorial. Next, please complete Tutorial: DB2 Database Migration.

Parent topic: Tutorials: HCO for SQL Server (HCOSS)
Related information
Tutorial: Create a SQL Server Database
Tutorial: DB2 Database Migration
Tutorial: Application Migration - Switching Package Sets
Tutorial: Application Migration - Converting Labeled Duration Calculations
Tutorial: Application Migration - Adding Function Emulation


Tutorial: DB2 Database Migration

Requirements

Before attempting this tutorial, you must first complete the following tutorials to ensure you have an established SQL Server database named HCO_Test and a connection to that database:
  • Tutorial: Create a SQL Server Database
  • Tutorial: Create a SQL Server Database Connection
To complete this tutorial, you need access to and connection information for a mainframe-based DB2 database. This includes:
  • Computer address and port number
  • Initial catalog and Package collection name
  • User ID and password that grant you read access to the SYSIBM system database tables
  • DB2 schema named DSN8910, which is a standard schema provided with DB2 for z/OS v9

Phase 1: Start Studio Enterprise Edition and HCO for SQL Server

If Studio Enterprise Edition and HCOSS for SQL Server tools are already running, skip this phase.

  1. Start Studio Enterprise Edition as an administrator from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Microsoft Visual Studio 2008.
  2. From the Visual Studio IDE, click Tools > Micro Focus COBOL Tools > HCO for SQL Server Tools.

Phase 2: Create a DB2 Database Connection

You need to establish a connection to a DB2 database on your mainframe so that you can access its SYSIBM tables.
  1. Be sure you have installed the Microsoft OLEDB Provider for DB2.
  2. From the HCO for SQL Server interface, click Manage Connections. This takes you to the Connection List tab.
  3. Click New DB2 Connection. This takes you to the DB2 Connection tab.
  4. In the Data Source Name field, type mainframeDB2 to provide a name for the connection.
  5. Provide values for all remaining fields on this tab. Valid entries for all fields are required to ensure a valid connection. If you do not know the correct values required, contact your DB2 administrator.
  6. Click Test. If the test fails, review your field entries, make corrections accordingly, and try again. When you have a successful connection, click OK.
  7. Click Save to create the connection. This takes you back to the Connection List tab where you should now see your DB2 connection listed.

Phase 3: Extract a DB2 Schema

In this phase, you download the DSN8910 schema from your DB2 database in the form of an XML file that contains its information, and view that file in a text editor. The DSN8910 schema is a standard schema provided with DB2 for z/OS v9.

Extract the DSN8910 schema
  1. From the HCO for SQL Server interface, click Extract Schema. This takes you to the Schema Extract tab.
  2. From the Source Connection drop-down list, select the DB2 data source that you specfied when creating your connection with the Manage Connections tool.

    Depending on your DB2 database connection specifications, you might be prompted for a user ID and password. If so, enter the user ID and password you supplied when creating the DB2 connection.

    After completing the connection, HCOSS displays a list of available schema objects.

  3. In the Extract column, check the box that corresponds to the DSN8910 schema.
  4. In the Schema Extract Name field, type dsn8910.
  5. Click Local. This sets the Extract Schema tool to save the generated schema extract file to the directory specified by the Local HCOSS Directory HCOSS option.
  6. Click Extract. This initiates the extract schema process, writing the dsn8910.hcodbs XML file, and takes you to the Results tab. Here you can see the results of the extraction.
View the dsn8910.hcodbs File
  1. From the Visual Studio IDE, click Tools > Options > Micro Focus COBOL Tools > HCO for SQL Server.
  2. Note the path specification for the Local HCOSS Directory.
  3. Start a text editor and open the following file:

    %APPDATA%\Micro Focus\NetExpress\6.0\HCOSS\Schemas\dsn8910.hcodbs

    Where localDirectory is the path specification for the Local HCOSS Directory option.

  4. When you have finished looking at the file, close the text editor. Do not save any changes if prompted.

Phase 4: Create a Transfer List

In this phase, you create a list of objects from the DB2 schema you extracted. In a later phase, HCOSS uses this transfer list to identify the objects associated with this extraction and migration.

  1. From the HCO for SQL Server interface, click Define Lists.
  2. On the Transfer Lists tab, click New.
  3. In the Name field, type dsn8910.
  4. From the Schema Extract drop-down list, select dsn8910. This populates the Available Objects list.
  5. Click Add All to add all available schema objects to the Selected Objects list.
  6. Click Save.

Phase 5: Generate DDL and Verify

In this phase of the migration process, you generate DDL from the schema objects in your object transfer list. You use this DDL in the next phase to define the structure of your new SQL Server database, including tables, views, indexes, and foreign key relationships.

Generate DDL
  1. From the HCO for SQL Server interface, click Generate DDL. This takes you to the DDL Tasks tab.
  2. Click New to create a new DDL task.
  3. In the Name field, type dsn8910test.
  4. From the Transfer List drop-down list, select dsn8910.
  5. Click OK.
  6. From the Connection for Execute drop-down list, select HCODemo.
  7. To map the extracted schema to a SQL Server schema:
    1. Click Schema Mappings. This takes you to the Schema Mappings tab.
    2. In the SQL Server Schema Name field, type TEST.
  8. Click the DDL Tasks tab; then click Save.
  9. Click Execute to execute the task to generate the DDL.
Verify the SQL Server Database Structure
  1. Open the Server Explorer in Visual Studio and add a connection for your SQL Server server.
  2. Verify that the appropriate objects were created in the SQL Server database by expanding the entry for your HCO_Test database and its Tables sub-entry. You should see the objects created in the TEST schema. If you don't see the objects, click on the database name and then refresh.
Repeat the Process
  1. Map the extracted schema to a different SQL Server schema by repeating the procedure, using the following information:
    DDL task name | dsn8910prod
    Associated transfer list | dsn8910
    Connection for execute | HCODemo
    SQL Server schema name | PROD
  2. Save, execute, and verify.

Phase 6: Transfer Data and Verify

You now use the HCOSS Transfer Data tool to populate the schema objects in your SQL Server database with data from your DB2 database.

Transfer Data
  1. From the HCO for SQL Server interface, click Transfer Data. This takes you to the Transfer Data Tasks tab.
  2. Click New to create a new transfer data task.
  3. In the Name field, type dsn8910test.
  4. From the DDL Task drop-down list, select dsn8910test.
  5. Click OK.
  6. From the Source Connection drop-down list, select mainframeDB2, which is the name of your DB2 connection.
  7. From the Destination Connection drop-down list, select HCODemo, which is the name of your SQL Server connection.
  8. Click Save to save the task.
  9. Click Transfer to transfer the list. This takes you to the Results tab where you can view log messages as the transfer takes place.
Verify the Data Transfer
  • In the Visual Studio Server Explorer, view the table data for the HCO_Test database's TEST.DEPT table.
Repeat the Process
  1. Transfer data for a different DDL task by repeating the procedure, using the following information:
    Transfer Data task name | dsn8910prod
    Associated DDL task | dsn8910prod
    Source connection | mainframeDB2
    Destination connection | HCODemo
  2. Save, transfer, and verify.

Phase 7: Compare Data

In this final phase, you compare the data in the DB2 database to the data transferred into the SQL Server database using the HCOSS Compare Data tool.

Compare Data
  1. From the HCO for SQL Server interface, click Compare Data.
  2. Select an appropriate Source Connection and Destination Connection.
  3. Click New to create a new compare data task.
  4. In the Name field, type dsn8910test.
  5. From the DDL Task drop-down list, select dsn8910test.
  6. Click OK.
  7. Click Save to save the compare data task.
  8. Click Compare to compare the data. This takes you to the Results tab where you can view messages as the tool compares the data.
Repeat the Process
  1. Compare data for another DDL task by repeating the procedure, using the following information:
    Compare Data task name | dsn8910prod
    Associated DDL task | dsn8910prod
    Source connection | mainframeDB2
    Destination connection | HCODemo
  2. Save and compare.

This completes the tutorial. Next, please complete one or more Application Migration tutorials. These tutorials use the TEST and PROD schemas you created in this tutorial.

Parent topic: Tutorials: HCO for SQL Server (HCOSS)
Related information
Tutorial: Create a SQL Server Database
Tutorial: Create a SQL Server Database Connection
Tutorial: Application Migration - Switching Package Sets
Tutorial: Application Migration - Converting Labeled Duration Calculations
Tutorial: Application Migration - Adding Function Emulation


Tutorial: Application Migration - Switching Package Sets

This tutorial also demonstrates how, with HCOSS, you can bind the application using the HCOSS Manage Packages and Plans tool.

Requirements

Before attempting this tutorial, you must first complete the following tutorials to ensure you have an established SQL Server database named HCO_Test containing the required PROD and TEST schemas and a connection to the HCO_Test database:
  • Tutorial: Create a SQL Server Database
  • Tutorial: Create a Database Connection
  • Tutorial: DB2 Database Migration

Visual Studio Application

The Visual Studio solution we provide for this tutorial contains two HCOSS projects. The TwoPackageSet project is a native COBOL project. The MTwoPackageSet project is a managed COBOL project. However, the COBOL code is the same in both projects.

Phase 1: Start Studio Enterprise Edition and HCO for SQL Server

If Studio Enterprise Edition and HCOSS for SQL Server tools are already running, skip this phase.

  1. Start Studio Enterprise Edition as an administrator from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Microsoft Visual Studio 2008.
  2. From the Visual Studio IDE, click Tools > Micro Focus COBOL Tools > HCO for SQL Server Tools.

Phase 2: Analyze the Native Application

  1. From the Visual Studio IDE, open the solution named TwoPackageSet, which is located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\hcoss\TwoPackageSet directory.
  2. From the Solution Explorer, open the TwoPackageSet.cbl file to view its contents. Pay particular attention to the EXEC SQL statements.
  3. Close the code editor.
  4. Open the project properties for the TwoPackageSet project.
  5. Notice that the Output type on the Application tab is Console Application.
  6. Switch to the COBOL tab, and set the following:
    Configuration | Debug
    Platform target | Any CPU
  7. Switch to the SQL tab. Several OpenESQL compiler directives have been set for you. The following table offers a brief description of each:
    SQL(DBMAN=ODBC) | Uses an ODBC connection
    SQL(TARGETDB=MSSQLSERVER) | Target database is SQL Server
    SQL(DB=HCODemo) | SQL Server connection name is HCODemo
    SQL(DIALECT=MAINFRAME) | HCOSS database syntax conversion is enabled
    SQL(DBRMLIB) | EXEC-SQL commands are extracted and placed in database request module (DBRM)
    SQL(DETECTDATE) | Converts date/time strings
    SQL(INIT) | Initiates the database connection
    SQL(MARS) | Enables multiple active results sets
    SQL(QUALIFIER=TEST) | Schema qualifier is TEST
    SQL(NOCHECK) | No SQL compile-time checking performed
  8. Close the Properties window.

Phase 3: Build the Native Application

  1. From the Solution Explorer, rebuild the TwoPackageSet project, thereby generating a DBRM for the application.
  2. Verify that the project built successfully.

Phase 4: Bind the Native Application

Here, you bind the application to the DBRM generated when you built the application. You do this using the HCOSS Manage Packages and Plans tool to create two packages and a plan. Each package you create is in its own collection and has a unique qualifier, but both point to the same source member and library. You then bind both packages into one plan.

Start the Manage Packages and Plans Tool
  1. From the HCO for SQL Server interface, click Manage Packages and Plans.
  2. From the SQL Server Connection drop-down list, select HCODemo.
Create Two Packages
  1. Click New Package. Then specify the following:
    Property | Value
    Collection Name | TEST
    Library Name | <Default>
    Member Name | TWOPACKAGESET
    Default Qualifier | TEST
    Action | Replace
  2. Click Execute. This creates the package in the database.
  3. Change the Collection Name to PROD and the Default Qualifier to PROD.
  4. Click Execute. This creates a second package.
  5. Switch to the Bind Scripts tab. Notice the BIND script commands that were created as a result of creating each package.
Bind the Two Packages into a Plan
  1. Click New Plan.
  2. In the Plan Name field, type TWOPACKAGESET.
  3. On the Available Collections list, click PROD.
  4. On the Available Packages list, click TWOPACKAGESET.
  5. Click Add to add this package to the Selected Packages list.
  6. Repeat steps 3 through 5, substituting TEST instead of PROD, to add the TEST.TWOPACKAGESET package to the Selected Packages list.
  7. In the Action group, click Replace.
  8. Click Execute to add the BIND PLAN entry to the script and to also bind the plan.
Verify the Results
  1. In Visual Studio, switch to the Server Explorer and expand the tree view to show the contents of the HCO_Test.dbo > Stored Procedures entry. HCOSS created these stored procedures when you executed your packages and plan.
  2. Open one of the stored procedures that contains PKG as part of its name.

    In this, you see the SQL from your application code. You also see SQL Server function calls to UPPER. These were converted from DB2 function calls to UCASE. This is due to having set the SQL(DIALECT=MAINFRAME) directive when you compiled.

Phase 5: Run the Native Application

  1. From the Solution Explorer in Visual Studio, open the TwoPackageSet.cbl source file.
  2. Set a break point on the STOP RUN line.
  3. Run the application.

You should see from the output that alternating rows are coming from different database schemas. This demonstrates the use of a single cursor to switch package sets, pulling data from different schemas.

Phase 6: Analyze, Build, Bind, and Run the Managed Application

Analyze the Managed Application
  1. From the Solution Explorer, switch the starting project: Right-click the MTwoPackageSet project and select Set as StartUp Project.
  2. Open the project properties for the MTwoPackageSet project.
  3. Click the SQL tab. Notice the directive settings for the OpenESQL ESQL Preprocessor include SQL(DBMAN=ADO). This means that we're using the ADO.NET database connection rather than the ODBC database connection.
  4. Close the Properties window.
Build the Managed Application
  • From the Solution Explorer, right-click the MTwoPackageSet project and select Rebuild.
Bind the Managed Application
  1. From the HCO for SQL Server interface, go to the Bind Scripts tab of the Manage Packages and Plans tool.
  2. Click Execute All, to execute all of the BIND commands listed. Because the application was rebuilt as a managed application, HCOSS uses the same commands to create and bind the packages and plan to the managed version of the application.
Run the Managed Application
  1. From the Solution Explorer in Visual Studio, open the TwoPackageSet.cbl source file.
  2. Set a break point on the STOP RUN line.
  3. Run the application.

You should see the same data output that you saw when you ran the native application, indicating that the program is switching package sets between row fetches.

This completes the tutorial.

Parent topic: Tutorials: HCO for SQL Server (HCOSS)
Related information
Tutorial: Create a SQL Server Database
Tutorial: Create a SQL Server Database Connection
Tutorial: DB2 Database Migration


Tutorial: Application Migration - Converting Labeled Duration Calculations

SQL Server does not support labeled duration calculations directly. HCOSS handles the conversion to T-SQL to implement the DB2 syntax of an EXEC SQL statement using labeled durations.

This tutorial also demonstrates binding the application using a post-build event in Visual Studio.

Requirements

Before attempting this tutorial, you must first complete the following tutorials to ensure you have an established SQL Server database named HCO_Test, a connection to that database, and a migrated DB2 database including the PROD and TEST migrated schema tables.
  • Tutorial: Create a SQL Server Database
  • Tutorial: Create a Database Connection
  • Tutorial: DB2 Database Migration

Visual Studio Application

The Visual Studio solution we provide for this tutorial contains two HCOSS projects. The LBLDURATION project is a native COBOL project. The MLBLDURATION project is a managed COBOL project. However, the COBOL code is the same in both projects.

Phase 1: Start Studio Enterprise Edition and HCO for SQL Server

If Studio Enterprise Edition and HCOSS for SQL Server tools are already running, skip this phase.

  1. Start Studio Enterprise Edition as an administrator from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Microsoft Visual Studio 2008.
  2. From the Visual Studio IDE, click Tools > Micro Focus COBOL Tools > HCO for SQL Server Tools.

Phase 2: Analyze, Build, and Bind the Native Application

Analyze the Native Application
  1. From the Visual Studio IDE, open the solution named LBLDURATION, which is located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\hcoss\LBLDURATION directory.
  2. From the Solution Explorer, open the LBLDURATION.cbl file to view its contents. Pay particular attention to the following EXEC SQL statement:
               EXEC SQL
               DECLARE CSR69 CURSOR FOR SELECT
                A.PROJNO
               ,A.PROJNAME
               ,A.PRSTDATE
               ,A.PRENDATE
               ,(((DAYS(A.PRENDATE) - DAYS(A.PRSTDATE) ) / 7) + 1) * 40
               AS MANHOURS
               FROM PROJ A
               ORDER BY A.PROJNAME
           END-EXEC
    This contains your labeled duration calculation:
    ,(((DAYS(A.PRENDATE) - DAYS(A.PRSTDATE) ) / 7) + 1) * 40
    In this case, you are using the DAYS labeled duration in a calculation where you:
    • Start with the number of days between the start and end date for projects
    • Divide that number by 7 to get the number of weeks
    • Add 1 to account for truncation of a partial week
    • Multiply that result by 40 to get the number of hours needed to complete the project
  3. Close the code editor.
  4. Open the project properties for the LBLDURATION project.
  5. Notice that the Output type on the Application tab is Console Application.
  6. Switch to the COBOL tab, and set the following:
    Configuration | Debug
    Platform target | Any CPU
  7. Switch to the SQL tab. Several OpenESQL compiler directives have been set for you. The following table offers a brief description of each:
    SQL(DBMAN=ODBC) | Uses an ODBC connection
    SQL(TARGETDB=MSSQLSERVER) | Target database is SQL Server
    SQL(DB=HCODemo) | SQL Server connection name is HCODemo
    SQL(DIALECT=MAINFRAME) | HCOSS database syntax conversion is enabled
    SQL(DBRMLIB) | EXEC-SQL commands are extracted and placed in database request module (DBRM)
    SQL(DATE=USA) | Date output is in USA format
    SQL(INIT) | Initiates the database connection
    SQL(QUALIFIER=TEST) | Schema qualifier is TEST
    SQL(NOCHECK) | No SQL compile-time checking performed
Define a Post-Build Event
  1. In the Properties window, click the COBOL tab.
  2. Click Build Events.
  3. In the Post build event command line field, type the following command:
    DSN SYSTEM(HCODemo) @"$(ProjectDir)LBLDURATION.hcodsn"

    This command calls the DSN Bind utility, specifies the SQL database connection to use, and states the location and name of a bind script file. Visual Studio executes this event immediately after building the application, automatically binding the application at that time.

  4. Click OK.
View the Contents of the Bind Script File
  • From the Solution Explorer open and review the content of LBLDURATION.hcodsn. This bind script file contains one BIND PLAN command that binds the LBLDURATION member into a plan named LBLDURATION.
Build and Bind the Applcation
  1. From the Solution Explorer, rebuild the LBLDURATION project, thereby generating a DBRM for the application and automatically binding it to the DBRM using the post-build event.
  2. Verify that the project built successfully.
Verify the Results
  1. In Visual Studio, switch to the Server Explorer and expand the tree view to show the contents of the HCO_Test.dbo > Stored Procedures entry. HCOSS created these stored procedures when you executed your packages and plan.
  2. Open the stored procedure named PLN:LBLDURATION.LBLDURATIONconsistency-token$0, where consistency-token is the value of the generated consistency token.

    In this, you see the SQL from your application code. You also see that HCOSS has converted the original DB2 DAYS expression into T-SQL syntax that recreates the same functionality in SQL Server. This is due to having set the SQL(DIALECT=MAINFRAME) directive when you compiled.

Phase 3: Run the Native Application

  1. From the Solution Explorer in Visual Studio, open the LBLDURATION.cbl source file.
  2. Set a break point on the GO BACK line.
  3. Run the application.

You see from the output that your results show the hours required to complete each project. All output dates are in USA format.

Phase 4: Analyze, Build, Bind, and Run the Managed Application

Analyze the Managed Application
  1. From the Solution Explorer, switch the starting project: Right-click the MLBLDURATION project and select Set as StartUp Project.
  2. Open the project properties for the MLBLDURATION project.
  3. Click the SQL tab.

    Notice the directive settings for the OpenESQL ESQL Preprocessor include SQL(DBMAN=ADO). This means that we're using the ADO.NET database connection rather than the ODBC database connection.

    Also notice the SQL(DATE=EUR) directive, which specifies the European output format.

Define a Post-Build Event
  1. From the Properties window add a post-build event to execute the following command (same command you used for the native project):
    DSN SYSTEM(HCODEMO) @"$(ProjectDir)LBLDURATION.hcodsn"
  2. Close the Properties window.
Build and Bind the Managed Application
  • From the Solution Explorer, right-click the MLBLDURATION project and select Rebuild.
Run the Managed Application
  1. From the Solution Explorer in Visual Studio, open the LBLDURATION.cbl source file.
  2. Set a break point on the GO BACK line.
  3. Run the application.

This completes the tutorial.

Parent topic: Tutorials: HCO for SQL Server (HCOSS)
Related information
Tutorial: Create a SQL Server Database
Tutorial: Create a SQL Server Database Connection
Tutorial: DB2 Database Migration


Tutorial: Application Migration - Adding Function Emulation

This tutorial demonstrates adding function emulation by taking you through the process of:
  • Adding math functions to SQL Server that represent standard math functions in DB2.
  • Mapping the DB2 functions to the new SQL Server functions using the Customize SQL Name Mapping tool.

This tutorial also demonstrates binding the application using a post-build event in Visual Studio.

Requirements

Before attempting this tutorial, you must first complete the following tutorials to ensure you have an established SQL Server database named HCO_Test, a connection to that database, and a migrated DB2 database including the PROD and TEST migrated schema tables.
  • Tutorial: Create a SQL Server Database
  • Tutorial: Create a Database Connection
  • Tutorial: DB2 Database Migration

Visual Studio Application

The Visual Studio solution we provide for this tutorial contains two HCOSS projects. The FunctionEmulation project is a native COBOL project. The MFunctionEmulation project is a managed COBOL project. However, the COBOL code is the same in both projects.

Phase 1: Create User-Defined Functions

  1. Launch SQL Server Management Studio, and select the HCO_Test database.
  2. Navigate to and open the FunctionEmulation.sql file, located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\hcoss\FunctionEmulation directory.

    This file contains a script that creates some user defined math functions needed by the example code.

  3. Click Execute.
  4. From the Object Explorer expand and select HCO_Test > Programmability > Functions > Scalar-Valued Functions and Refresh this folder. You should now see the newly created functions.

Phase 2: Start Studio Enterprise Edition and HCO for SQL Server

If Studio Enterprise Edition and HCOSS for SQL Server tools are already running, skip this phase.

  1. Start Studio Enterprise Edition as an administrator from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Microsoft Visual Studio 2008.
  2. From the Visual Studio IDE, click Tools > Micro Focus COBOL Tools > HCO for SQL Server Tools.

Phase 3: Map the Functions for HCOSS

  1. From the HCO for SQL Server interface, click Customize SQL Name Mappings.
  2. Scroll to the bottom of the grid and double-click in the first empty cell to activate it for editing. Type the following information in the appropriate rows and columns, and check the corresponding Is Function box for each:
    DB2 Function/Special Register | SQL Server Equivalent
    atanh | dbo.atanh
    cosh | dbo.cosh
    sinh | dbo.sinh
    tanh | dbo.tanh
  3. Click Save to save the mappings.

Phase 4: Analyze, Build, and Bind the Native Application

Analyze the Native Application
  1. From the Visual Studio IDE, open the solution named FunctionEmulation, which is located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\hcoss\FunctionEmulation directory.
  2. From the Solution Explorer, open the FunctionEmulation.cbl file to view its contents. Pay particular attention to the EXEC SQL statement that references the user-defined functions.
  3. Close the code editor.
  4. Open the project properties for the FunctionEmulation project.
  5. Notice that the Output type on the Application tab is Console Application.
  6. Switch to the COBOL tab, and set the following:
    Configuration | Debug
    Platform target | Any CPU
  7. Switch to the SQL tab. Several OpenESQL compiler directives have been set for you. The following table offers a brief description of each:
    SQL(TARGETDB=MSSQLSERVER) | Target database is SQL Server
    SQL(DB=HCODemo) | SQL Server connection name is HCODemo
    SQL(DIALECT=MAINFRAME) | HCOSS database syntax conversion is enabled
    SQL(DBRMLIB) | EXEC-SQL commands are extracted and placed in database request module (DBRM)
    SQL(INIT) | Initiates the database connection
    SQL(NOCHECK) | No SQL compile-time checking performed
Define a Post-Build Event
  1. In the Properties window, click the COBOL tab.
  2. Click Build Events.
  3. In the Post build event command line field, type the following command:
    DSN SYSTEM(HCODemo) @"$(ProjectDir)FunctionEmulation.hcodsn"

    This command calls the DSN Bind utility, specifies the SQL database connection to use, and states the location and name of a bind script file. Visual Studio executes this event immediately after building the application, automatically binding the application at that time.

  4. Click OK.
View the Contents of the Bind Script File
  • From the Solution Explorer open and review the content of FunctionEmulation.hcodsn. This bind script file contains one BIND PLAN command that binds the FunctionEmulation member into a plan named FunctionEmulation.
Build and Bind the Applcation
  1. From the Solution Explorer, rebuild the FunctionEmulation project, thereby generating a DBRM for the application and automatically binding it to the DBRM using the post-build event.
  2. Verify that the project built successfully.
Verify the Results
  1. In Visual Studio, switch to the Server Explorer and expand the tree view to show the contents of the HCO_Test.dbo > Stored Procedures entry. HCOSS created these stored procedures when you executed your packages and plan.
  2. Open one of the stored procedures that contains PLN as part of its name.

    In this, you see your application code making the calls to the user-defined functions.

Phase 5: Run the Native Application

  1. From the Solution Explorer in Visual Studio, open the FunctionEmulation.cbl source file.
  2. Set a break point on the line containing if sqlcode = 0.
  3. Run the application.

You should see from the output that the results are calculations performed by your user-defined functions.

Phase 6: Analyze, Build, Bind, and Run the Managed Application

Analyze the Managed Application
  1. From the Solution Explorer, switch the starting project: Right-click the MFunctionEmulation project and select Set as StartUp Project.
  2. Open the project properties for the MFunctionEmulation project.
  3. Click the SQL tab.

    Notice the directive settings for the OpenESQL ESQL Preprocessor include SQL(DBMAN=ADO). This means that we're using the ADO.NET database connection rather than the ODBC database connection.

Define a Post-Build Event
  1. From the Properties window add a post-build event to execute the following command (same command you used for the native project):
    DSN SYSTEM(HCODEMO) @"$(ProjectDir)FunctionEmulation.hcodsn"
  2. Close the Properties window.
Build and Bind the Managed Application
  • From the Solution Explorer, right-click the MFunctionEmulation project and select Rebuild.
Run the Managed Application
  1. From the Solution Explorer in Visual Studio, open the FunctionEmulation.cbl source file.
  2. Set a break point on the line containing if sqlcode = 0.
  3. Run the application.

This completes the tutorial.

Parent topic: Tutorials: HCO for SQL Server (HCOSS)
Related information
Tutorial: Create a SQL Server Database
Tutorial: Create a SQL Server Database Connection
Tutorial: DB2 Database Migration


Tutorial: IMS

  1. Tutorial: IMS
  2. Creating and Building an IMS Application
  3. Configuring an Enterprise Server for IMS
  4. Running the IMS Application
  5. Debugging the IMS Application
Parent topic: Mainframe Tutorials


Tutorial: IMS

Overview

This tutorial takes you step by step through the process of creating IMS applications, configuring an enterprise server to run IMS applications, running the applications and debugging them.

Demonstration Application

This tutorial uses the MFDEMO demonstration, located by default in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Tutorials\Mainframe\IMS directory.

MFDEMO is a COBOL IMS TM transaction for creating and maintaining an IMS DB tabular Database. User defined tables are organized by table element within table name. The following components are used by this application:

IMS components:

  • DEMO03DD.DBD
  • DEMO03DD.DBU
  • DEMO001T.PSB
  • DEMO90.MFS
  • DEMO91.MFS
  • DEMO92.MFS
  • TRANCODE.TXT - IMS Stage 1 file

COBOL components:

  • DEMO001T.CBL
  • RGHTJUST.CBL

Prerequisites

To complete this tutorial, you need the following software:

  • Micro Focus RUMBA or another TN3270 emulator

Outline

In this tutorial you perform the steps typically required in implementing, maintaining and running IMS applications. In summary, you:

  1. Create and build a Mainframe Subsystem Application (MSS), a native COBOL project comprising all the parts of your application: the COBOL source and the IMS files.
  2. Configure an enterprise server for IMS support and associate it with your mainframe project.
  3. Execute the application using the Micro Focus RUMBA 3270 emulator.
  4. Debug the application.
Parent topic: Tutorial: IMS
Next topic: Creating and Building an IMS Application
Related information
Creating and Building an IMS Application
Configuring an Enterprise Server for IMS
Running the IMS Application
Debugging the IMS Application


Creating and Building an IMS Application

These are the steps to create a Visual Studio project comprising all the parts of your application, such as the COBOL source and the IMS files.

You build the demonstration application in Visual Studio, deploy and run it on an Enterprise Server configured for IMS support, and debug it dynamically.

Create a Project

To create a native COBOL project to hold the files from the demonstration program:

  1. Create a working folder on your machine such as c:\tutorials.
  2. Start Visual Studio.
  3. Click File > New > Project > COBOL Projects > Native > Mainframe Subsystem Application.
  4. Specify a name for your project such as ims.
  5. Specify a working folder in the Location field.

    This is the folder you defined in step 1 above.

  6. Uncheck Create directory for solution.
  7. Click OK.

    This creates an ims folder in your working foldercurrent workspace that holds your solution and project.

Import the Files from the Demonstration Program

To import the files from the demonstration program into your project:

  1. In Solution Explorer, right-click your project and select Add > New > Folder.
  2. Create the following subfolders in your project: cbl, dbd, mfs, psb, loadlib, and system.
  3. Right-click a subfolder of your project and select Add > Existing Item.
  4. Browse to the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Tutorials\Mainframe\IMS directory (default location).
  5. Set Objects of type filter to All Files (*.*).
  6. Select the files to add and click Add.
    Add the following demonstration files to the subfolders of your project as detailed in the table below:
    Folder name | File | Comments
    cbl DEMO001T.CBL

    RGHTJUST.CBL

    dbd | DEMO03DD.DBD
    loadlib TRANCODE.TXT

    DEMO03DD.DBU

            Contains the data files and will contain the executables required at runtime.
    mfs DEMO90.MFS

    DEMO91.MFS

    DEMO92.MFS

    psb | DEMO001T.PSB
    system | Will contain system files such as the cics resource definitions files, dfhdrdat.*.

    This creates copies of the files in the respective subfolders of your project.

Specify Project Properties

To specify properties for your project:

  1. In Solution Explorer, double-click the Properties folder.
  2. On the COBOL tab, set Configuration to Debug.
  3. Ensure Platform target is set to x86.
  4. Ensure COBOL dialect to Enterprise COBOL for z/OS.
  5. Set Source Format to Fixed.
  6. In the Additional Directives field, enter CHARSET(ASCII).
  7. Ensure Compile for debugging is checked.
  8. In the Output path field, specify the path to the loadlib subfolder of your project: .\loadlib.
  9. On the IMS tab, enter c:\tutorials\ims\loadlib in the Generated files, MFS Path and Database path fields.

    This redirects the output from generation of the IMS files into the loadlib subfolder.

  10. In DBD Build Settings section, check Generate Map for DBD.
  11. On the Debug tab, select IMS from the drop down list for Choose Active Settings.
  12. Click File > Save All to save the changes in the project properties.

Build the Solution

To build the solution:

  1. Right-click the solution in Solution Explorer.
  2. Click Build Solution.

    The build creates different executables and other system files in the following subfolders of the project:

    C:\tutorials\ims
    • IMSCONFG.DAT
    C:\tutorials\loadlib
    • IMSCONFG.idx
    • DBDGEN2.DAT
    • DBDGEN2F.DAT
    • PSBGEN3.DAT
    • DEMO001T.ACB
    • DEMO03DD.ACB
    • The MFS files generation creates some .mid, .mod, .dif and .dof files as well as imsconfg.dat and imsconfg.idx. These files contain system configuration data. You should move them only if you know how to configure your enterprise server.
    • Building the DBD and the PSB files produces respectively dbdgen2.dat, dbdgen2f.dat and psbgen3.dat.
  3. Copy the IMSCONFG.* and the DEMO0*.* files from the project directory to the loadlib subfolder.

Update the Resource Definition File

IMS support includes two transactions, /CIC and /IMS, that you use to switch enterprise servers to CICS or IMS mode respectively. In order for these new transactions to be available you need to update your resource definition file using the caspcupg command.

  1. Using Windows Explorer, copy the dfhdrdat and dfhdrdat.idx files from the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Base\FILES\SYS (default location) to the system subfolder in your project directory.

    It is a good practice to create copies of the product dfhdrdat and dfhdrdat.idx files for your project rather than using the files that are in the installation of this COBOL development system.

  2. Start a COBOL command prompt:

    Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Compatibility Tools > Net Express Command Prompt, 32-bit.

  3. Type the following at the command line:
    caspcupg /dp=C:\tutorials\ims\system

    The DP parameter specifies the path to the system subfolder in which you copied the resource definition files.

Load the IMS Database

To load the IMS database:

  1. From the COBOL command environment navigate to the loadlib subfolder of your project.
  2. Execute the following command:
    MFIMS IMSDBU LOAD DEMO03DD NOCLS

Set Up a List of IMS Transactions

To set up the list of IMS transactions for the IMS configured enterprise server:

  1. Execute the following from the COBOL command environment starting in loadlib:
    MFIMS STAGE1IMP TRANCODE.TXT
Parent topic: Tutorial: IMS
Previous topic: Tutorial: IMS
Next topic: Configuring an Enterprise Server for IMS
Related information
Tutorial: IMS
Configuring an Enterprise Server for IMS
Running the IMS Application
Debugging the IMS Application


Configuring an Enterprise Server for IMS

This section shows the steps to configure an enterprise server so that you can run the IMS TM application.

Open Enterprise Server Administration

  1. In Server Explorer, right-click on Micro Focus Servers.
  2. Select Administration from the context menu.

Create an MSS-enabled Enterprise Server

  1. On the Home page of Enterprise Server Administration, click Add at the bottom of the table of servers.
  2. On the first Add server page:
    1. Type IMSDEMO in Server Name.
    2. Make sure the Working Mode is set to 32-bit.
    3. Click Next.
  3. On the second Add server page:
    1. Click Micro Focus Enterprise Server with Mainframe Subsystem Support.
    2. Click Next.
  4. On the third Add server page:
    1. In the Creation Options group, make sure Create TN3270 listener is checked and specify a port number. Do not specify a port smaller than 1025. Use a greater number such as 5039 instead.
    2. In the Configuration Information field, enter the following two lines:
      [ES-Environment]
IMSPROJ=c:\tutorials\ims

      Setting the environment variable IMSPROJ enables you to specify the paths to any subfolder in your project as $IMSPROJ\subfolder.

    3. Type Server for IMS in Description.
    4. Click Add.

      The Home page is redisplayed, and a row for the IMSDEMO enterprise server is shown in the table of servers.

Enable IMS for Your Enterprise Server

To enable IMS support for the IMSDEMO enterprise server:

  1. Click Edit next to the IMSDEMO row in the table of servers.

    The Edit page that appears contains a hierarchy of tabs and you should see open the following tabs: Server, Properties, General.

  2. Check Show Local Console.
  3. Check Allow Dynamic Debugging.
  4. Click Apply.
  5. Click the MSS, IMS and General tabs.
  6. Ensure that Mainframe Subsystem Support enabled is checked.
  7. Check IMS enabled.

    This specifies that the IMSDEMO enterprise server can use the IMS support. Do not click Apply yet as there is more to do on this page.

Configure the Enterprise Server

For this demonstration you use the IMS Mainframe Subsystem Application that you created in Visual Studio. The build produced the required DBDGENs, IMSGENs, MFSGENs and PSBGENs as well as the .dll files in the loadlib subfolder of your project. You need to configure the IMSDEMO enterprise server to look for the .dll files and the IMS gen and database files in the loadlib subfolder of your project

To specify the locations of the required files:

  1. In the GEN file directory field, specify the subfolder in which all gen files have been created using the environment variable IMSPROJ: $IMSPROJ\loadlib.
  2. Click Apply.
  3. Click the Server, Properties, MSS, IMS, TM and General tabs.
  4. In the MFS path field, enter $IMSPROJ\loadlib.
  5. In the Application Path field, enter $IMSPROJ\loadlib.
  6. In the Transaction definition file directory field, enter $IMSPROJ\loadlib.
  7. Click Apply.
  8. Click the Server, Properties, MSS, IMS, and DB tabs.
  9. In the Database path field, enter $IMSPROJ\loadlib.
  10. Click Apply to save the changes.

Configure the MSS

To start IMS, an enterprise server needs to use the supplied CICS IMSSIT:

  1. Click the Server, Properties, MSS and CICS tabs.
  2. Specify IMSSIT in System Initialization Table.
  3. In the Resource Definition File Path field, enter the path to the Resource Definition File that you updated in the section Updating the Resource Definition File: $IMSPROJ\system.
  4. Leave the other fields blank.
  5. Click Apply to save the changes.

Define an Automatic Message Processing Region

You need at least one message processing region (MPR) to run an IMS application in an enterprise server.

To specify a message processing region for the IMSDEMO enterprise server:

  1. Click the Server, Properties, MSS, IMS, TM and MPR tabs.
  2. Click Add.
  3. In the Name field, enter: MPR01.
  4. In Transaction Class, enter: 001.
  5. In Description, enter: MPR for class 1.
  6. Click Add.
  7. Click Home at the upper left corner to return to the Home page of Enterprise Server Administration.

Associate Your Project with the IMS Configured Enterprise Server

To associate your project with the IMS configured server that you created, IMSDEMO:

  1. In Server Explorer, right-click IMSDEMO.
  2. Choose Associate with project > your project.

Start the Enterprise Server

  1. In Server Explorer, right-click IMSDEMO.
  2. Choose Start from the context menu.

You can verify that MSS and IMS are enabled by watching the start-up messages in the Enterprise Server Console Daemon window. Messages should also appear indicating that the message processing region has started:

Deploy to Enterprise Server

You do not need to deploy the application to Enterprise Server as you configured IMSDEMO to search for the required files in your Visual Studio project directory. Enterprise Server finds the application files that it needs to run using the region IMS configuration entry, MSS|IMS|TM Application path: $IMSPROJ\loadlib.

Parent topic: Tutorial: IMS
Previous topic: Creating and Building an IMS Application
Next topic: Running the IMS Application
Related information
Tutorial: IMS
Creating and Building an IMS Application
Running the IMS Application
Debugging the IMS Application


Running the IMS Application

To start the demonstration application:

  1. Start your TN3270 emulator.
  2. Specify the following connection information.

    Note that field names could vary depending on the 3270 emulator you are using.

    Field | Value
    Host name | The dnsname or TCP/IP @ of the computer the enterprise server is running on. This is localhost on your machine.
    Port | The port number you specified for the 3270 listener when creating the IMS-enabled enterprise server.
  3. Connect.
  4. On the IMS sign-on screen, specify a user ID and password, and then press Enter.

    If you have not configured Enterprise Server security, you can use the user SYSAD with password SYSAD.

  5. Clear the screen of your terminal emulator.

    In RUMBA, you do this by pressing CTRL+SHIFT+Z.

  6. Enter MFDEMO (with a trailing space).

    The following sections describe the demonstration program and how you navigate through its screens.

IMS demonstration Screen Entries

For the screens which follow, enter the characters which are shown in yellow.

Note: Each table you add must have a unique table ID.

The "Add Testdept Table" Screen in Transaction MFDEMO:

Press Enter when you have finished entering data on a screen.

On the screens that follow press Tab to move to the next field. Press Shift+Tab to move to the previous field.

The "Add Testdept Elements" Screen:

The "Change Testdept Table" Screen:

The "Change Testdept Elements" Screen:

The "Add Testers Table" Screen:

The "Add Testers Elements" Screen:

The "End Transaction" Screen:

The "MFDEMO - ENDED" Screen:

Parent topic: Tutorial: IMS
Previous topic: Configuring an Enterprise Server for IMS
Next topic: Debugging the IMS Application
Related information
Tutorial: IMS
Creating and Building an IMS Application
Configuring an Enterprise Server for IMS
Debugging the IMS Application


Debugging the IMS Application

Debugging requires that your project is associated with the IMSDEMO Enterprise Server and that the Enterprise Server is configured to enable dynamic debugging, which you performed in the previous steps.

Start Debugging

To start a debugging session:

  1. Click Debug > Start Debugging or press F5.

Run the IMS Application and Debug It

Run the IMS application again as follows:

  1. Clear the screen of your TN3270 emulator.
  2. Enter MFDEMO (with a trailing space).
  3. Press Enter.

    At this point, Visual Studio opens DEMO001T.CBL in a debug session and highlights the line of code that is part of the initialization.

  4. Continue debugging the application as required.

Stop Debugging

When you have finished debugging, end the debug session as follows:

  1. Click Debug > Stop Debugging.
Parent topic: Tutorial: IMS
Previous topic: Running the IMS Application
Related information
Tutorial: IMS
Creating and Building an IMS Application
Configuring an Enterprise Server for IMS
Running the IMS Application


Tutorial: JCL

  1. JCL Integration with CICS Overview
  2. Configure an Enterprise Server for JCL Support
  3. Create and Build a JCL Application
  4. Submit and run a JCL job
  5. View the spool queues
  6. View the Catalog
  7. Debug dynamically under Enterprise Server
  8. Debug remotely Under Enterprise Server
  9. More Information
Parent topic: Mainframe Tutorials


JCL Integration with CICS Overview

The Server Enterprise Edition execution environment is built on top of the Micro Focus Enterprise Server technology that provides the infrastructure not just for executing COBOL, CICS, IMS, DB2, VSAM and JCL, but also for deploying existing transactions as Web Services for easier re-use within new architectures like .NET, J2EE or SOA.

JCL applications written to run on a z/OS or VSE mainframe can be run with the Server Enterprise Edition environment. You maintain the applications in Visual Studio.

You can maintain your JCL files on the PC using any text editor.

  1. Demonstration application
  2. Outline
Parent topic: Tutorial: JCL
Next topic: Configure an Enterprise Server for JCL Support


Demonstration application

This tutorial uses the demonstration application JCL supplied with your COBOL development system. The JCL application performs four functions:

  1. Uses the IDCAMS mainframe utility to delete from the catalog the data set created earlier, if it is already there.
  2. Runs a COBOL program that writes a simple data set, which is added to the catalog.
  3. Uses the IEBGENER mainframe utility to create a temporary data set.
  4. Runs a COBOL program that reads through the data set created in step 3 and displays it.
Parent topic: JCL Integration with CICS Overview
Next topic: Outline


Outline

In this tutorial you perform the steps typically required in managing, maintaining and running JCL applications. In summary, you:

  1. Configure an Enterprise Server to run JCL applications.
  2. Create a native COBOL project comprising all the parts of your application, such as the COBOL source and the JCL batch files.
  3. Associate the project with your Enterprise Server.
  4. Build the COBOL project in your IDE.
  5. Submit the JCL file on your Enterprise Server.
  6. Run the application in your Enterprise Server.
  7. View the spool and the catalog.
  8. Debug dynamically.
  9. Debug remotely.
Parent topic: JCL Integration with CICS Overview
Previous topic: Demonstration application


Configure an Enterprise Server for JCL Support

To enable JCL support in an Enterprise Server, you need to do the following tasks:

  1. Create an MSS-enabled Enterprise Server
  2. Enable JES
  3. Configure the Program Paths
  4. Define Batch Initiators and Printers
  5. Start Your Enterprise Server
Parent topic: Tutorial: JCL
Previous topic: JCL Integration with CICS Overview
Next topic: Create and Build a JCL Application


Create an MSS-enabled Enterprise Server

To open the Enterprise Server Administration page in the IDE:

  1. Launch Visual Studio.
  2. Open Server Explorer.

    If it is hidden, display it by choosing View > (Other Windows >) > Server Explorer.

  3. Right-click Micro Focus Servers and choose Administration from the context menu.

To create an MSS-enabled Enterprise Server:

  1. On the Home page of Enterprise Server Administration, click Add at the bottom of the table of servers.
  2. On the first Add Server page:
    1. Type JCLDEMO in the Server Name field.
    2. Make sure 32-bit is selected in the Working Mode section.
    3. Click Next.
  3. On the second Add Server page:
    1. Click Micro Focus Enterprise Server with Mainframe Subsystem Support.
    2. Click Next.
  4. On the third Add Server page:
    1. Clear the check mark by Create TN3270 listener.
    2. It is useful to have the character-mode console daemon window showing when the JCLDEMO region is running, so select Show Local Console.
    3. Type Server for JCL in the Description field (near the bottom of the page).
    4. Click Add.

The Home page is redisplayed, and a row for the new Enterprise Server is visible in the table of servers.

Parent topic: Configure an Enterprise Server for JCL Support
Next topic: Enable JES


Enable JES

To enable the JES support within MSS:

  1. Click Edit next to the JCLDEMO row in the table of servers.

    The Edit page that appears contains a hierarchy of tabs.

  2. Make sure the Server and Properties tabs are selected, and click MSS and then JES.
  3. Check the Job Entry Subsystem enabled check box.

    Don't click Apply yet — there is more to do on this page.

Parent topic: Configure an Enterprise Server for JCL Support
Previous topic: Create an MSS-enabled Enterprise Server
Next topic: Configure the Program Paths


Configure the Program Paths

You need to specify the directories and other details needed for the Enterprise Server to find deployed programs. To do this:

  1. Enter values into the fields on the JES > General tab, as shown in the table below. The paths you enter here point to the directory of your project.
    Field Value to enter: Details
    JES Program Path | c:\tutorials\jcl\bin\x86\Debug | Path for the directory containing executable files to be run by your JCL jobs. This is the path to the build output folder of your project that contains the .dll files. For debugging, the .idy and .cbl files are used.
    System Catalog | c:\tutorials\jcl\catalog\catalog.dat | Path and name of the system catalog. This is a file that holds the details of data files, their attributes and locations.
    Default Allocated Dataset Location | c:\tutorials\jcl\catalog\datasets | The default path for the directory where new data sets are to be created, if you do not specify a directory.
    System Procedure Library | SYS1.PROCLIB | Set of cataloged PDS data set names that will be searched to resolve JCL procedure names.
  2. Click Apply.
  3. Click Home on the Enterprise Server Administration.
Parent topic: Configure an Enterprise Server for JCL Support
Previous topic: Enable JES
Next topic: Define Batch Initiators and Printers


Define Batch Initiators and Printers

JCL execution requires the following types of Service Execution Processes (SEPs):

  • Batch initiator (often abbreviated to simply "initiator") — for running JCL jobs
  • Batch printer SEP (often abbreviated to simply "printer") — for sending the output from a JCL job to a printer

You can define initiators and printers to start up automatically whenever the Enterprise Server is started, and you can also create ones that last only for the current session.

To define an initiator to start automatically:

  1. On the home page of Enterprise Server Administration, click Edit next to JCLDEMO.
  2. Make sure the Server and Properties tabs are selected, and click MSS > JES.
  3. Define a batch initiator as follows:
    1. Click Initiators > Add.
    2. Enter values in the fields as shown in the following table:
      Field | Value | Comment
      Name | INITB | Not case sensitive — gets folded to upper case
      Class | B | Not case sensitive — gets folded to upper case
      Description | Initiator for class B job
    3. Click Add.
  4. Click Home on the Enterprise Server Administration.
Parent topic: Configure an Enterprise Server for JCL Support
Previous topic: Configure the Program Paths
Next topic: Start Your Enterprise Server


Start Your Enterprise Server

You can now start JCLDEMO:

  1. In Server Explorer, right-click JCLDEMO under the Micro Focus Servers group.
  2. Choose Start from the context menu. If this is the first time you have started the server you might see a sign-on dialog box. Select Store Credentials to skip this step in the future, and click OK to continue.
Parent topic: Configure an Enterprise Server for JCL Support
Previous topic: Define Batch Initiators and Printers


Create and Build a JCL Application

These are the steps to create a Visual Studio project comprising all the parts of your application, such as the COBOL source and the JCL batch files. We build the demonstration application in Visual Studio, deploy and run it on an Enterprise Server configured to run JCL applications and debug it dynamically.

  1. Create a Project
  2. Import the files from the demonstration program
  3. Specify Project Properties
  4. Build the application
  5. Associate your project with the JCL Enterprise Server
  6. Deploy to Enterprise Server
Parent topic: Tutorial: JCL
Previous topic: Configure an Enterprise Server for JCL Support
Next topic: Submit and run a JCL job


Create a Project

To create a native COBOL project to hold the JCL demonstration program:

  1. Create a working folder on your machine such as c:\tutorials.
  2. Start Visual Studio.
  3. Click File > New > Project > COBOL Projects > Native > Mainframe Subsystem Application.
  4. Specify a name for your project such as jcl.
  5. Clear Create directory for solution.
  6. Specify your working folder in the Location field. This is the folder you defined in step 1 above.
  7. Click OK.

    This creates a jcl folder in your working folder that holds your solution and project.

  8. Create a catalog folder in your project folder — c:\tutorials\jcl\catalog. Your project folder needs to have this folder created beforehand in order to submit the JCL successfully.
  9. Right-click the solution in Solution Explorer and choose Open Folder in Windows Explorer.
  10. Using Windows Explorer, copy the demonstration files from %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Tutorials\Mainframe\JCL (default location) to your project folder, c:\tutorials\jcl.
Parent topic: Create and Build a JCL Application
Next topic: Import the files from the demonstration program


Import the files from the demonstration program

To import the files from the JCL demonstration program into your project:

  1. In Solution Explorer, right-click your project and select Add > Existing Item.
  2. Set Objects of type filter to All Files (*.*).
  3. Select the .jcl file and the two .cbl files in the project folder.
  4. Click Add.
Parent topic: Create and Build a JCL Application
Previous topic: Create a Project
Next topic: Specify Project Properties


Specify Project Properties

To specify the project properties:

  1. In Solution Explorer, double-click the Properties folder.
  2. On the Micro Focus COBOL > Project Settings > COBOL tab, make sure Source Format is set to Fixed.
  3. Make sure Enterprise COBOL for z/OS COBOL dialect is selected.
  4. In the Additional Directives field, enter CHARSET(ASCII).
  5. On the Debug tab, select JCL from the drop down list for Choose Active Setting.
  6. Click the JCL tab on this page — there is no need to specify any settings on it at this point.
  7. Press CTRL + S to save the changes in the project properties.
Parent topic: Create and Build a JCL Application
Previous topic: Import the files from the demonstration program
Next topic: Build the application


Build the application

Building creates the application's .dll and .idy files in the Debug subfolder of your project.

  1. Right-click the solution in Solution Explorer.
  2. Choose Build Solution from the context menu.
Parent topic: Create and Build a JCL Application
Previous topic: Specify Project Properties
Next topic: Associate your project with the JCL Enterprise Server


Associate your project with the JCL Enterprise Server

The IDE enables you to associate your project with the running JCLDEMO Enterprise Server. To associate your project with the JCL server that you created, JCLDEMO, you need to:

  1. Open Server Explorer.
  2. Start JCLDEMO by clicking Start in the Status column.If this is the first time you have started the server you might see a sign-on dialog box. Select Store Credentials to skip this step in the future, and click OK to continue.
  3. Right-click JCLDEMO and choose Associate with project > your project.
Parent topic: Create and Build a JCL Application
Previous topic: Build the application
Next topic: Deploy to Enterprise Server


Deploy to Enterprise Server

You do not need to deploy the application to your JCLDEMO enterprise server as you configured the search path of the server to be the Debug subfolder of your project. Enterprise Server automatically finds the application files that it needs to run.

Parent topic: Create and Build a JCL Application
Previous topic: Associate your project with the JCL Enterprise Server


Submit and run a JCL job

To submit the JCL application to the running JCL-configured Enterprise Server:

  1. In the IDE, right-click the .jcl file in Solution Explorer.
  2. Choose Submit JCL.

See the output messages in the Enterprise Server Console Daemon for the result of running the JCL job.

Alternatively, you can use drag and drop feature to submit the JCL application to the JCL configured server as follows:
  1. Select the .jcl file in Solution Explorer.
  2. Drag the file to Server Explorer and drop it on the JCLDEMO server.
Parent topic: Tutorial: JCL
Previous topic: Create and Build a JCL Application
Next topic: View the spool queues


View the spool queues

The Enterprise Server Monitor and Control (ESMAC) works in conjunction with Enterprise Server Administration and enables you to view and control Enterprise Servers, and the services, packages, and handlers that run on those servers. The spooler is another name for the job entry subsystem, JES. It maintains a number of spool queues, showing the status of jobs in the system.

The IDE enables direct access to the Spool and Catalog on the ESMAC pages.

To see the spool queues:

  1. In Server Explorer, right-click JCLDEMO under Micro Focus Servers.
  2. Select Show Spool from the context menu.

    The page that appears shows one of the spooler queues.

  3. Click Output.

    This displays the Output Queue. It contains the output from the job you have just run.

  4. Select the check box to the left of the JCLTEST entry, and click Display.

    This shows details of the job.

  5. You can view details of a particular step. For example, click Details on the line for the READ step.
  6. On that details page, click Display to view the output from the READ step.

    The output from this step consists of a small number of simple records.

  7. Right-click in the window and select Back to return to the ESMAC pages.
Parent topic: Tutorial: JCL
Previous topic: Submit and run a JCL job
Next topic: View the Catalog


View the Catalog

The catalog file holds the details of datasets required by the JCL jobs that run in an Enterprise Server. To view the catalog:

  1. In Server Explorer, right-click JCLDEMO and choose Show Catalog.

    The page that appears shows the catalog file, MFIJCL.OUTFILE.DATA, created by the example job. If this file isn't shown, select Cataloged Only.

  2. Select the check box beside the catalog file.
  3. Click Details to see the catalog entry.

    Note that Codeset for the file is ASCII.

  4. To view the file, click Display on the page showing the catalog entry.

    The file contents are displayed as a page in the browser.

Parent topic: Tutorial: JCL
Previous topic: View the spool queues
Next topic: Debug dynamically under Enterprise Server


Debug dynamically under Enterprise Server

The IDE enables you to debug a job running under Enterprise Server. It’s not possible to debug the JCL file but you can debug the programs that are invoked by the job that is EXEC PGM=PROG.

Before proceeding, stop any Enterprise Server region that may be running.

  1. Enable Enterprise Server Debugging
  2. Set a fixed port
  3. Start debugging
  4. View the List of Attached Debuggers
Parent topic: Tutorial: JCL
Previous topic: View the Catalog
Next topic: Debug remotely Under Enterprise Server


Enable Enterprise Server Debugging

Before you can debug within the IDE, you must enable the dynamic debugging feature within your Enterprise Server. This option is available on the General properties page within Enterprise Server Administration.

  1. Open Enterprise Server Adminstration.
  2. Click Edit next to the JCLDEMO row in the table of servers.

    The Edit page that appears contains a hierarchy of tabs.

  3. Make sure the Server and Properties tabs are selected, and click General.
  4. Check Allow Dynamic Debugging.
  5. Click OK.
Parent topic: Debug dynamically under Enterprise Server
Next topic: Set a fixed port


Set a fixed port

By default, Enterprise Server uses ephemeral ports for its communication listeners, to prevent clashes occurring with other network software on your machine when a listener starts. However, this can make debugging more complex, since Enterprise Server is likely to be assigned a different port each time it starts.

To force Enterprise Server to use a fixed port number for debugging purposes:

  1. Open Enterprise Server Administration.
  2. On the row for JCLDEMO on Enterprise Server Administration page, click Details for the Listeners in the Communications Processes column.
  3. Click Edit on the row for Web Services and J2EE.
  4. The existing setting should be *:*.
  5. The second * indicates use an ephemeral port number.
  6. Change the Endpoint Address to *:5055 in order to use a fixed port.
  7. Click OK.
  8. Click Home on the left to return to the Enterprise Server Administration page.
  9. Start the Enterprise Server.

    During the startup sequence, watch for a mention of dynamic debug enabled. If you missed it, check the log by opening Enterprise Server Administration, clicking Edit in the JCLDEMO row, and selecting Server > Control > ES Monitor and Control > Display.

  10. Now that you have a fixed port, reassociate the region with your project in Server Explorer.
Parent topic: Debug dynamically under Enterprise Server
Previous topic: Enable Enterprise Server Debugging
Next topic: Start debugging


Start debugging

Debugging requires no changes to your program code. It requires that your project is associated with the JCLDEMO Enterprise Server and that the Enterprise Server is configured to enable dynamic debugging, which you performed in the previous steps.

  1. Double-click the JCLRead.cbl and JCLCreate.cbl files in Solution Explorer to open them.
  2. Introduce breakpoints in both files: right-click on a line in the Procedure Division and click Breakpoint > Insert Breakpoint.
  3. Choose Debug > Start Debugging or press F5.

    The debugger enters a wait state.

  4. Submit the JCL file. The debugger stops in your JCLCreate program at the breakpoint.
  5. Step through a few lines and press F5 to continue.
    The debugger should stop again in the JCLRead program.
    Tip: If you want to view the list of attached debuggers, work through the next topic before performing the next step.
  6. Once you’ve completed your debug session, select Debug > Stop Debugging.

Notice the messages that have appeared in the Enterprise Server console window.

The debugger offers you a number of choices when specifying what you want to debug. You may choose a Job Name, a Job Number, a Step Name or the top-level program on the Debug tab of the project properties.

These choices enable you to perform remote debugging, to support multiple users debugging on the same region.

In this tutorial you’re running Enterprise Server locally and no one else is connecting to it, so you do not need to specify any options and the debugger debugs any debuggable program that it finds.

Parent topic: Debug dynamically under Enterprise Server
Previous topic: Set a fixed port
Next topic: View the List of Attached Debuggers


View the List of Attached Debuggers

You can view the list of debuggers waiting to attach to your region using ESMAC:

  1. Click Edit on the row for JCLDEMO in Enterprise Server Administration.
  2. Click the Control tab under Server.
  3. Click ES Monitor & Control.

    This opens the ESMAC page.

  4. Click the Dyn-Dbg button at the bottom left of the page.

You can also remove these debuggers from the list.

Parent topic: Debug dynamically under Enterprise Server
Previous topic: Start debugging


Debug remotely Under Enterprise Server

You can submit JCL to a region working on the remote machine, to enable it to access Enterprise Server. For this purpose the remote machine must have Enterprise Server with JCLDEMO configured and working.

Make sure the firewall is not working on the remote machine to be able to access Enterprise Server.

  1. In the IDE, right-click Micro Focus Servers in Server Explorer.
  2. Select MFDS Configuration.
  3. Type the name of a remote machine in the Host name field, or specify its IP address in the IP Address field.
  4. Click OK.
  5. Refresh the Micro Focus Servers group.
  6. Right-click JCLDEMO on the remote machine and choose Associate with project > your project.
  7. In Solution Explorer, right-click the .jcl file and choose Submit JCL.
  8. See if you can debug the JCLCREATE and JCLREAD applications running on the remote machine.
Parent topic: Tutorial: JCL
Previous topic: Debug dynamically under Enterprise Server
Next topic: More Information


More Information

For more information about using Studio Enterprise Edition, refer to the Help either in the product or on the Micro Focus Web site.

Parent topic: Tutorial: JCL
Previous topic: Debug remotely Under Enterprise Server


Tutorials: Open PL/I

  • Tutorial: Compiling, Linking and Debugging a CICS-based Open PL/I Application
  • Tutorial: Compiling, Linking and Debugging Open PL/I Programs Running Under ES/JCL
    This tutorial shows you how to compile, link and debug Open PL/I programs running under the control of JCL in Enterprise Server.
  • Tutorial: Developing an Open PL/I Application Using Visual Studio
  • Tutorial: Using Java CodeWatch
Parent topic: Mainframe Tutorials


Tutorial: Compiling, Linking and Debugging a CICS-based Open PL/I Application

This tutorial shows you how to compile, link and debug a CICS-based Open PL/I application using the Open PL/I CICS preprocessor.

  1. Overview
  2. Prerequisites
  3. Configure an Enterprise Server
  4. Compile and Link the Programs
  5. Start the Enterprise Server
  6. Debugging an Application
  7. Stop the Enterprise Server
Parent topic: Tutorials: Open PL/I


Overview

In this tutorial, you:

  1. Import an enterprise server.
  2. Compile and link a CICS-based Open PL/I application.
  3. Debug the application.
Parent topic: Tutorial: Compiling, Linking and Debugging a CICS-based Open PL/I Application
Next topic: Prerequisites


Prerequisites

To run this tutorial you need to have Studio Enterprise Edition 2.0 or later installed, as well as a TN3270 emulator such as Micro Focus Rumba.

Parent topic: Tutorial: Compiling, Linking and Debugging a CICS-based Open PL/I Application
Previous topic: Overview
Next topic: Configure an Enterprise Server


Configure an Enterprise Server

This tutorial uses a preconfigured enterprise server rather than a manually created enterprise server.

To import the preconfigured enterprise server:

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Configuration > Enterprise Server Administration. The Enterprise Server Administration utility appears in your default browser.
  2. On the Home page of the Enterprise Server Administration, under Actions at the left, click Import. The first Import server information screen appears.
  3. Enter the path where the predefined server data is stored. By default this is %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\OPEN-PLI\CICSDemo\staff_def.
  4. Click Next.
  5. Continue to click Next through the Import server information screens. On the final Import server information screen, click OK.

The selected server appears in the Enterprise Server Administration Home page server table. The server is named STAFF. Click Edit to the left of the row for the STAFF server to view the server settings.

In the General tab, the Configuration Information field shows the following:

[ES-Environment]
ES_PLI_SUPPORT=Y
MF_USE_JAVA_CW=Y
CICSDEMO=%ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\OPEN-PLI\CICSDEMO
CODEWATCH_SRCPATH=$CICSDEMO
CODEWATCH_STBPATH=$CICSDEMO\cicsrdef
ES_SSTM_CICS="$CICSDEMO\sstmcics.jcl"
MFPLI_CONFIG_DIR=$CICSDEMO
Note: For Studio Enterprise Edition, ensure the path for CICSDEMO is correct. If not, edit the path to match the install location of the CICS demo samples.
  • ES_PLI_SUPPORT=Y loads CICS Emulation subsystem support for PL/I user programs.
  • MF_USE_JAVA_CW=Y specifies use of Java CodeWatch for debugging.
  • CODEWATCH_SRCPATH is the location where the source files are stored.
  • CODEWATCH_STBPATH shows where the debugger looks for its symbol (.stb) files.

In the MSS tab, CICS is enabled and the following paths are set.

Path | Value
Transaction Path | $CICSDEMO\cicsrdef
File Path | $CICSDEMO\cicsrdef
Map Path | $CICSDEMO\cicsrdef\
Resource Definition File Path | $CICSDEMO\cicsrdef
Default directory | %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x
Note: These settings are only valid if you have installed Studio Enterprise Edition to the default directory. Do the following if you have installed to a different location or a drive other than the default.
  • Edit the paths to match the install location.
  • Click the General tab and create an entry in the Configuration Information field to set the PROGRAMFILES variable to the install location. For example, if installing to Program Files (x86) on a D: drive, type the line PROGRAMFILES=d:\program files (x86) in the Configuration Information field.

Click the Listeners tab and check the settings for the TN3270 listener. The port to which the terminal emulator connects is 5150.

Parent topic: Tutorial: Compiling, Linking and Debugging a CICS-based Open PL/I Application
Previous topic: Prerequisites
Next topic: Compile and Link the Programs


Compile and Link the Programs

To compile and link the programs:

  1. On the Start menu, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Compatibility Tools > Net Express Command Prompt (32-bit).
  2. Change to the directory where the demo files are. By default this is: %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\OPEN-PLI\CICSDemo.
  3. Run bld.bat.

This batch file will compile all programs. It contains a bunch of mfplx commands with various compiler options. Some of them are:

-bigendian
Specifies that all fixed binary items are implicitly declared with the BIGENDIAN data attribute, unless the NATIVE attribute is explicitly applied to a data item.
-c
Suppresses linking and produces a relocatable object file.
-cics
Invokes the CICS preprocessor.
-deb
Produces debugging information for CodeWatch, the debugger that you are going to use in this tutorial.

For more information on the compiler options used in bld.bat, see Compiler Options.

Parent topic: Tutorial: Compiling, Linking and Debugging a CICS-based Open PL/I Application
Previous topic: Configure an Enterprise Server
Next topic: Start the Enterprise Server
Related information
Compiler Options


Start the Enterprise Server

To start the enterprise server, run this command at aNet Express command prompt:

casstart -rSTAFF
Note: In Windows, if using the Enterprise Server Administration page to start your server, you are not prompted to debug your program unless you have modified your configuration such that your Micro Focus Directory Service runs as your logon ID and has the ability to interact with the Windows Desktop.
Parent topic: Tutorial: Compiling, Linking and Debugging a CICS-based Open PL/I Application
Previous topic: Compile and Link the Programs
Next topic: Debugging an Application


Debugging an Application

This part of the CICS tutorial shows how to use a debugger to walk through an employee directory PL/I sample application. It explains pertinent parts of the application and debugger functionality.

Before you start debugging, connect to the enterprise server using a TN3270 emulator such as Micro FocusRumba. Your host name is localhost, and the port number is 5150. This tutorial assumes that you are using Rumba for hosting.

Logging in and starting the application in CodeWatch Debugger

  1. Start Micro FocusRumba and create a new mainframe display.
  2. Choose Connection > Connect. The Signon to CICS screen appears in the mainframe display.
  3. Type a user ID and password. These would typically be SYSAD and SYSAD. Press the Tab key to move from the ID field to the Password field.
  4. Press Enter.
  5. Press Ctrl + Shift + Z to clear the screen if using Micro Focus Rumba. If using a different terminal emulator, follow instructions for that emulator to clear its screen.
  6. Type TTEA and press Enter to start the sample application. A message appears asking you if you want to debug the PL/I program STAFF02. To see data returned by the program while stepping through code, data must be supplied. At this point, since no data has been supplied to the program, Click No to return to the application.
  7. In the Name field type WILLIAMS and press Enter. A message appears asking if you want to debug the PL/I program STAFF02.
  8. Click Yes. The CodeWatch debugger window appears. The debugger displays the STAFF02 program and moves to the first line of the program code. If using Rumba to connect to the enterprise server, a Rumba terminal log window also appears.

Stepping through the CICS mapset in the STAFF02 Program

The code for the STAFF02 program receives data from the CICS mapset. This part of the tutorial steps through to where data gets received from the mapset.

  1. Choose View > Show Line Numbers to display line numbers in the CodeWatch debugger.
    Note: You need to have the line numbers displayed to follow the instructions in this tutorial.
  2. Press [image] or F10 several times until you step to the line that shows the following:
    244:       EXEC CICS RECEIVE MAPSET('OCMCS')

    This line indicates that the program receives data from the data from the CICS mapset.

  3. Press F10. The debugger steps to line 248. Move the cursor over the text RC. The tooltip displays RC=0{fixed binary(31)} which indicates the mapset is successfully retrieved.
  4. Press F10 to step to line 256 and move the cursor over the text NAMEDI. The tooltip displays WILLIAMS.
  5. Press F10 several times until you reach line 313. This line writes the processed input data (WILLIAMS) to CICS temporary storage.
  6. Press F10 to step to line 322. Move the cursor over the text RC on the line. The tooltip displays RC=0{fixed binary(31)}, which indicates that the program successfully writes the processed input data to a CICS temporary data queue.
  7. Press F10 to step to line 330. This line calls the program STAFF03.
  8. Press F10 to step into STAFF03. The CodeWatch debugger stops and a message appears asking you if you want to debug the PL/I program STAFF03.
  9. Click Yes. CodeWatch reappears and highlights the first line of STAFF03.

Stepping through the CICS mapset in the STAFF03 Program

  1. Choose View > Show Line Numbers to display line numbers in the CodeWatch debugger.
    Note: You need to have the line numbers displayed to follow the instructions in this tutorial.
  2. Press F10 several times to step to line 128, which shows the following.
    128:   CALL READ_QUEUE;
    This line reads a record from the temporary data queue.
  3. Press [image] or F11 to step into the procedure started on line 128. This steps to line 672, which starts a procedure to read the queue that contains in which the processed input data (WILLIAMS) is stored.
  4. While still stepped to line 672, move the cursor over the text DDP_STRUCA on line 677. Notice that LAST NAME doesn't contain WILLIAMS.
  5. Press F10 to step to line 681.
  6. Move the cursor over RC and check if the tooltip displays: RC=0{fixed binary(31)}.
  7. Move the cursor back over DDP_STRUCA on line 677. The record now contains WILLIAMS.
  8. Press F10 to continue stepping until you return from the procedure and are on line 144. This line calls the STAFF04 program, which reads the file to determine if WILLIAMS is present.
  9. Press [image] or F11 to step into STAFF04.
  10. Scroll to line 529 and double click to set a breakpoint, then press [image] to stop program execution at line 529 where you set the breakpoint.
  11. Press [image] or F11 to step into the READ RECORD procedure.
  12. If you continue stepping, you will see that as you keep reading records, none of them match on WILLIAMS.

You can repeat the steps above using a different last name. You can type for example CH in the last name field and you will see valid records being found in the PROCESS_DATA procedure.

You can also use the debugger's Go to line function to skip the code matching on the last name and thus make it "think" it found a matching record and cause it to be displayed. You can access the Go to line function from the context menu when you right-click the line you want.

Note: For more information on debugging with Java CodeWatch, see Tutorial: Using Java CodeWatch.
Parent topic: Tutorial: Compiling, Linking and Debugging a CICS-based Open PL/I Application
Previous topic: Start the Enterprise Server
Next topic: Stop the Enterprise Server
Related information
Tutorial: Using Java CodeWatch


Stop the Enterprise Server

When you finish debugging, you need to stop the enterprise server. To do it, at aNet Express command prompt, type the following:

casstop -rSTAFF
Parent topic: Tutorial: Compiling, Linking and Debugging a CICS-based Open PL/I Application
Previous topic: Debugging an Application


Tutorial: Compiling, Linking and Debugging Open PL/I Programs Running Under ES/JCL

  1. Overview
  2. Prerequisites
  3. Configure an Enterprise Server to Run Open PL/I Programs Under JCL
  4. Compile and Link Open PL/I Programs Under JCL
  5. Debug Open PL/I Programs Under JCL
Parent topic: Tutorials: Open PL/I


Overview

In this tutorial, you:
  1. Create and configure an enterprise server to run Open PL/I programs under JCL.
  2. Compile and link Open PL/I programs for execution under the control of JCL.
  3. Debug Open PL/I programs.
Parent topic: Tutorial: Compiling, Linking and Debugging Open PL/I Programs Running Under ES/JCL
Next topic: Prerequisites


Prerequisites

To run this tutorial, you need to:
  • Have Microsoft Visual Studio and Studio Enterprise Edition installed.
  • Copy to your root the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\examples\OPEN-PLI\ directory.
  • Create two empty directories called data and debug under C:\nxopdemo.
Parent topic: Tutorial: Compiling, Linking and Debugging Open PL/I Programs Running Under ES/JCL
Previous topic: Overview
Next topic: Configure an Enterprise Server to Run Open PL/I Programs Under JCL


Configure an Enterprise Server to Run Open PL/I Programs Under JCL

These are the steps to create and configure an enterprise server to execute Open PL/I programs under the control of JCL.

  1. Configure an MSS-enabled Enterprise Server
    This topic shows you how to configure an enterprise server with enabled Mainframe Subsystem Support (MSS).
  2. Enable JES
    This topic shows you how to configure the Job Entry Subsystem (JES) environment after you have created an enterprise server.
  3. Configure Program Paths
    This topic shows you how to configure the program paths.
  4. Add an Initiator
    This topic shows you how to add an initiator.
  5. Start the Enterprise Server
    This topic shows you the steps you need to follow to start the enterprise server.
Parent topic: Tutorial: Compiling, Linking and Debugging Open PL/I Programs Running Under ES/JCL
Previous topic: Prerequisites
Next topic: Compile and Link Open PL/I Programs Under JCL


Configure an MSS-enabled Enterprise Server

  1. On the Start menu, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Configuration > Enterprise Server Administration.
  2. On the Home page of Enterprise Server Administration, click Add at the bottom of the table of servers.
  3. On the first Add Server page, type PLIDEMO in the Server Name field.
  4. Make sure 32-bit is selected in the Working Mode section.
    Note: Open PL/I is currently a 32-bit product.
  5. Click Next.
  6. Select Micro Focus Enterprise Server with Mainframe Subsystem Support .
  7. Click Next.
  8. Under Creation Options, clear the Create TN3270 listener check box.
  9. Type the following in the Configuration Information field:
    [ES-Environment]
CODEWATCH_SRCPATH=c:\nxopdemo
CODEWATCH_STBPATH=c:\nxopdemo
ES_PL1_MFFH_JCL=Y
  10. Click Add.
  11. The Home page is redisplayed, and a row for the new enterprise server is visible in the table of servers.
Parent topic: Configure an Enterprise Server to Run Open PL/I Programs Under JCL
Next topic: Enable JES


Enable JES

  1. On the Enterprise Server Administration home page, click Edit next to the PLIDEMO row in the table of servers.

    The Edit page that appears contains a hierarchy of tabs.

  2. Make sure the Server and Properties tabs are selected, and click MSS and then JES
  3. Check the Job Entry Subsystem enabled check box.

    Don't click Apply yet - there is more to do on this page.

Parent topic: Configure an Enterprise Server to Run Open PL/I Programs Under JCL
Previous topic: Configure an MSS-enabled Enterprise Server
Next topic: Configure Program Paths


Configure Program Paths

You need to specify the directories and other details needed for the enterprise server to find deployed programs. To do this:
  1. Enter values into the fields on the JES > General tab, as shown in the table below. The paths you enter here point to the directory of your project.
    Field: Value to enter: Details:
    JES Program Path | c:\nxopdemo\debug | Path for the directory containing executable files to be run by your JCL jobs. This is the path to the Debug folder of your project that contains the Open PL/I .dll files.
    System Catalog | c:\nxopdemo\catalog.dat | Path and name of the system catalog. This is a file that holds the details of data files, their attributes and locations. If the catalogue does not exist, it will be created.
    Default Allocated Dataset Location | c:\nxopdemo\data | The default path for the directory where new data sets are to be created, if you do not specify a directory.
  2. Click Apply to save the changes.
Parent topic: Configure an Enterprise Server to Run Open PL/I Programs Under JCL
Previous topic: Enable JES
Next topic: Add an Initiator


Add an Initiator

Initiator (or batch initiator) is a Service Execution Process for running JCL jobs. You can define initiators to start up automatically whenever the enterprise server is started, and you can also create ones that last only for the current session. We will define one initiator to start automatically.

  1. Go to the Initiators tab.
  2. Click Add.
  3. Type INIT1 in the Name field.
  4. Type the job class in the Class field.

    It can be abcdefghijklmnopqrstuvwxyz or 0123456789. For the purposes of this tutorial, type abcdefghijklmnopqrstuvwxyz.

  5. Click Add.
  6. Click Home on the Enterprise Server Administration page.
Parent topic: Configure an Enterprise Server to Run Open PL/I Programs Under JCL
Previous topic: Configure Program Paths
Next topic: Start the Enterprise Server


Start the Enterprise Server

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Compatibility Tools > Net Express Command Prompt (32-bit).
  2. Change to c:\nxopdemo.
  3. Enter casstart -rPLIDEMO.

Don't close the command prompt, as you are going to need it later in this tutorial.

Note: If you use the Enterprise Server Administration page to start your server, you will not be prompted to debug your program, unless you have modified your configuration such that your Micro Focus Directory Service runs as your logon ID and has the ability to interact with the Windows Desktop.
Parent topic: Configure an Enterprise Server to Run Open PL/I Programs Under JCL
Previous topic: Add an Initiator


Compile and Link Open PL/I Programs Under JCL

These are the steps to compile and link Open PL/I programs for execution under the control of JCL.

  1. Go back to the command prompt used to start the enterprise server.
  2. Enter the following command:
    mfplx opdemo.pli -deb -defext -mvs -dll -out:c:\Public\Documents\Micro Focus\Enterprise Developer\Samples\OPEN-PLI\NXOPDEMO\debugopdemo.dllpdemo.dll
    This will compile and link opdemo.pli. Files copy to %PUBLIC%\Documents\Micro Focus\Enterprise Developer\Samples\OPEN-PLI\NXOPDEMO\debug.
  3. Build opdemo2.pli in the same way, replacing opdemo.pli with opdemo2.pli and opdemo.dll with opdemo2.dll in the command above.
    mfplx opdemo2.pli -deb -defext -mvs -dll -out:c:\nxopdemo\debug\opdemo2.dll
Parent topic: Tutorial: Compiling, Linking and Debugging Open PL/I Programs Running Under ES/JCL
Previous topic: Configure an Enterprise Server to Run Open PL/I Programs Under JCL
Next topic: Debug Open PL/I Programs Under JCL
Related information
Creating a DLL


Debug Open PL/I Programs Under JCL

After you have compiled and linked opdemo.pli and opdemo2.pli, you can start debugging.

  1. PLIDEBUG.DAT
  2. Start Debugging
  3. Debug Using CodeWatch
  4. Java CodeWatch
    As an alternative to the standard debugger, you can use the new Java debugger.
Parent topic: Tutorial: Compiling, Linking and Debugging Open PL/I Programs Running Under ES/JCL
Previous topic: Compile and Link Open PL/I Programs Under JCL
Related information
CodeWatch User's Guide


PLIDEBUG.DAT

The PLIDEBUG.DAT file contains settings defining whether the debugger should automatically attach when the program is executed or whether it should shut down when the program completes. It also contains an initial set of debugger commands that are executed when the debugger is attached.

PLIDEBUG.DAT is located in the installation directory. By default this is %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x.
Note: The file is not there when you install the product, it appears when you first try to execute a job.
To view the file and edit it:
  1. From the Visual Studio IDE, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Data Tools > Data File Tools.
  2. Browse to the installation directory of Open PL/I, select PLIDEBUG.DAT and click Open.
Find the lines of OPDEMO and OPDEMO2. They should look like this:
OPDEMO              Y Y shlib opdemo.dll; env opdemo; br %ENTRY; br %EXIT [det;q];c
OPDEMO2             Y Y shlib shlib opdemo2.dll; env opdemo2; br %ENTRY; br %EXIT [det;q];c
The Y in the first column indicates if the debugger will attach when the step starts. The Y in the second column shows if the debugger will shut down when the step ends.
Note: You still need to use the DETACH command.

The rest is a series of commands that will be issued to the debugger when it starts.

If the two lines are not there, you need to create them.

Note:
  • Make sure that the first Y is in the 21st column.
  • Always close down the editing session before you start debugging because otherwise the file will be locked and Enterprise Server won't access it.
Parent topic: Debug Open PL/I Programs Under JCL
Next topic: Start Debugging
Related information
CodeWatch User's Guide


Start Debugging

Note: Make sure you have closed the editing session of PLIDEBUG.DAT.
  1. Go back to the Net Express command prompt that you used earlier to start the enterprise server.
  2. Run cassub -rPLIDEMO -jopdemo.jcl.
  3. The Open PL/I debugger, CodeWatch, will pop up and you can start debugging.
Parent topic: Debug Open PL/I Programs Under JCL
Previous topic: PLIDEBUG.DAT
Next topic: Debug Using CodeWatch


Debug Using CodeWatch

CodeWatch provides debugging facilities, such as stepping, setting breakpoints or tracing. You can examine the source program, find specified text strings, move to specified line numbers, and examine included source files.

The CodeWatch graphical interface consists of a source window, output window, and edit-line used for command-line input, plus a set of buttons. You can enter commands either using the buttons or via the edit-line.

To see some of the CodeWatch debugging facilities:
  1. Click Continue or type C in the edit-line. It begins program execution.
  2. Click Step or type S in the edit-line. This executes the first statement.
  3. Type S 4 and this will execute the next 4 statements.
  4. Type P 10 in the edit-line. It will print the next 10 lines in the output window.
  5. Type BR 106 and this will set a breakpoint on line 106.
  6. Type C and the statements until the breakpoint will be executed.
  7. Type DETACH to detach from the process. CodeWatch will shut down and then pop up with opdemo2.dll ready for debugging.
  8. Type S 7 and this will execute the next 7 statements.
  9. Type EVALUATE SYSPRINT_BUFF to evaluate the SYSPRINT_BUFF variable.
  10. You can continue stepping or if you want to stop debugging, type DETACH.

See the CodeWatch User's Guide for more information on debugging with CodeWatch.

Note: To stop the enterprise server, type casstop -rPLIDEMO
Parent topic: Debug Open PL/I Programs Under JCL
Previous topic: Start Debugging
Next topic: Java CodeWatch


Java CodeWatch

This new user interface has been designed to streamline debugging tasks and has a host of usability improvements such as persistent break points, watch lists, etc. It is written in Java and to use it you need to have the latest Java Runtime Environment (JRE) or Java Development Kit (JDK) installed.

You also need to copy cw_java.jar from the Bin directory in the installation of your development system to the debug directory under C:\nxopdemo

Which debugger you use is controlled by an environment variable:

  • MF_USE_JAVA_CW=Y, if you want to use the Java debugger.
  • MF_USE_JAVA_CW=N, if you want to use the standard debugger.

To see some of the Java debugger's facilities:

  1. When the Java debugger runs, you will see the source code displayed on the left and some panels on the right.
  2. Scroll down in the source code panel until you can see the line beginning with SYSPRINT_BUFF = 'ABC...
  3. Double-click on this line to set a breakpoint at this instruction.
  4. Click [image] on the top left of the debugger to continue to this breakpoint.
  5. Click [image] to step over this line.
  6. Place the mouse cursor above the word SYSPRINT in the source code panel to see the contents of this variable.
  7. Right-click on the word SYSPRINT and click Add 'SYSPRINT' to watch panel to make it a permanent watch item.
  8. You can keep stepping at this point or press the [image] in the top right corner to close the debugger.
Parent topic: Debug Open PL/I Programs Under JCL
Previous topic: Debug Using CodeWatch


Tutorial: Developing an Open PL/I Application Using Visual Studio

This tutorial shows you how to develop an Open PL/I application using the Visual Studio IDE.

  1. Overview
  2. Prerequisites
  3. Start Visual Studio
  4. Create a Solution and a Project
  5. Create a New Template
  6. Open the Program
  7. Change the Fonts and Colors
  8. Change the Source Type
  9. Add a Program to the Project
  10. Build the Project
  11. Errors and Warnings
  12. Project and Source File Properties
  13. Run the Program
  14. Add Include Files
  15. Differences Between Build and Rebuild
Parent topic: Tutorials: Open PL/I


Overview

This tutorial introduces the Visual Studio IDE, and shows how to create and build a simple console application.

Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Next topic: Prerequisites


Prerequisites

To run this tutorial, you need to have Visual Studio 2008 and Studio Enterprise Edition 6.0 SP1 WS1 or later installed.

Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Overview
Next topic: Start Visual Studio


Start Visual Studio

To start Visual Studio:

  1. On the Start menu, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> Microsoft Visual Studio 2008.
  2. You might be prompted to set the environment, depending on the version installed. If you are prompted, choose General development environment.

The IDE is shown in the figure below, although the information displayed in the large pane will be different.

Visual Studio IDE

The large pane is where your solutions and projects will be opened. At the moment, this shows the Start Page, with up-to-date information on Visual Studio. When you start work, this pane is where your code is displayed.

The pane at the bottom is the Output window, where messages from the IDE and Compiler are displayed.

The right-hand pane is the Solution Explorer, which displays the structure of your solution and projects. At the bottom of the Solution Explorer pane are some tabs. Solution Explorer appears by default.

If any of these panes is hidden, you can show it from the View menu.

Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Prerequisites
Next topic: Create a Solution and a Project


Create a Solution and a Project

The first task is to create a solution and a project. A solution is a container holding one or more projects that work together to create an application. The solution has the extension .sln, and is a readable text file. Microsoft recommends you do not edit the file outside of Visual Studio.

A PL/I project has the extension .pliproj, and again this is a readable file, but Microsoft recommends that you do not edit it.

To create a project and solution:

  1. In Visual Studio, create a new project by clicking File > New > Project.
  2. In the Project Types pane, expand Open PL/I.
  3. Select the Console Application template.
  4. In the Name field, specify the name of the project.

    Notice that the Name and New Solution Name fields have the same name. Changing the name automatically changes the solution name but changing the solution name does not change the project name.

  5. In the Location field, browse to a directory where you want to put this tutorial.

    For example, if you create a folder on your c: drive called tutorials, change the location field to c:\tutorials. The solution will be stored in a subdirectory with the same name as the project name.

  6. Click OK.
This creates a solution and a project. The Solution Explorer shows the project. It contains:
  • program.pli which is a newly created skeleton program.
Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Start Visual Studio
Next topic: Create a New Template


Create a New Template

You can export this project to a template on which you can base future projects. To do this:

  1. On the menu bar click File > Export Template....
  2. Follow the wizard to export the template.
Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Create a Solution and a Project
Next topic: Open the Program


Open the Program

Double-click on program.pli to open the file.

Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Create a New Template
Next topic: Change the Fonts and Colors


Change the Fonts and Colors

To change the fonts and colors in which the program is displayed:

  1. Click Tools > Options.
  2. In the Options window, expand Environment and then select Fonts and Colors.
  3. The PL/I color items are the following:
    • PL/I Comment
    • PL/I End of line
    • PL/I Keyword
    • PL/I Margin
    • PL/I Number
    • PL/I String
    • PL/I Text
    • PL/I White space

    Select them in the Display items list and click OK to save your settings.

Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Open the Program
Next topic: Change the Source Type


Change the Source Type

To change the source type:

  1. Close program.pli.
  2. Select it in the project tree.
  3. In the Properties pane, change the source type from Normal to Punched Card.
  4. Open program.pli.
  5. Insert spaces at the left margin to recover the colorization.
    Note:
    1. If you add spaces into the end of the comment until the end comment marker */ is past column 72, this causes it to become invalid because the / is outside the margins and so the whole program is treated as a comment. Thus it is displayed in the comment color.
    2. Characters outside the margins are coloured with PL/I Margin.
    3. The -margins 2,72 option is automatically added to the compile line for this program.
Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Change the Fonts and Colors
Next topic: Add a Program to the Project


Add a Program to the Project

To add another program to the project:

  1. Right-click on the project.
  2. Select Add > New Item.
  3. Select Program from the Visual Studio installed templates.
  4. Change the name to sub.pli.
  5. In the program, change put skip list ('Hello world' ); to put skip list ('Hello world sub1' );.
Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Change the Source Type
Next topic: Build the Project


Build the Project

  1. Before you build the project, change the contents of program.pli to:
    /* Micro Focus Open PL/I Console Application */

 program: proc options (main);
   dcl sub entry;
   dcl a1 char(14);
   put skip list ('Hello world - main' );
   call sub();
   put skip;
   get list (a1);

 end program;
  2. On the menu bar click Tools > Options.
  3. Expand Projects.
  4. Select Build and Run.
  5. From the MSBuild project build output verbosity dropdown list, select Normal.
  6. Click OK.
  7. On the menu bar, click Build.
  8. Click Build Solution.
    Note: If while going through the tutorial, you have already built the project, then you need to click Rebuild Solution instead of Build Solution.

If you inspect the Output window, you will notice that program.pli has been compiled with the -margins 2,72 option but sub.pli has not and the build is clean.

Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Add a Program to the Project
Next topic: Errors and Warnings


Errors and Warnings

  1. Open sub.pli.
  2. Add a1 = fred; to the source code.
  3. Remove end sub;.
  4. Add Invalid command.
  5. Rebuild the solution.

Note that two errors and two warnings have been reported. You can go directly to the errors in the code by double-clicking the error messages.

Revert the changes by pressing Alt + Backspace twice and rebuild.

Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Build the Project
Next topic: Project and Source File Properties


Project and Source File Properties

To view the project properties:

  1. Right-click the project.
  2. Select Properties.

Note that most of the properties for the project are not duplicated for each program. For example, Defext is only specified for individual files.

Note also that there are Other options fields for both compiling and linking.

On the Link Options tab there is a field for Libraries. This is used for both external libraries such as ODBC, and for linking projects. If a second project creates a necessary .lib, put the name of that .lib here and if it is updated by the build process, this project will be re-linked.

Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Errors and Warnings
Next topic: Run the Program


Run the Program

To start without debugging, press Ctrl + F5. Note that program.pli has a get list to stop the program before returning to Visual Studio.

To start with debugging, press F5. You can choose which debugger to use if you go to Project Properties > Run Options > Debugger.

Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Project and Source File Properties
Next topic: Add Include Files


Add Include Files

To add new include files to the project:

  1. Right-click the project name.
  2. Select Add > New Item.
  3. From the Visual Studio installed templates, select Include File.
    Note: When an include file is added in this way, the build action is set to "Include File".

To add existing include files:

  1. Go to Project Properties > Compile.
  2. Put the directory where the include files are in the Include path field.
  3. Right-click the project name.
  4. Select Add > Existing Item.
  5. Select include file.
  6. Click Add.
Note: You need to add the include files to the project so that the build process will recognize when an include file has changed and will recompile the appropriate programs. It will also help with features such as find in files.
Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Run the Program
Next topic: Differences Between Build and Rebuild


Differences Between Build and Rebuild

To see the differences between build and rebuild, follow these steps:

  1. Add a new include file to the project as demonstrated earlier in the tutorial.
  2. Change the contents of the include file to:
    /* Micro Focus Open PL/I Include File */
  put skip list ('jim', MSG);
  3. Make sure Build Option in the include file's properties is set to Content.
  4. Change the contents of program.pli to:
    /* Micro Focus Open PL/I Console Application */
 %replace MSG by 'From inclue - main';
 program: proc options (main);
   dcl sub entry;
   dcl a1 char(14);
   put skip list ('Hello world - main' );
   %include 'include1.in';
   call sub();
   put skip;
   get list (a1);

 end program;
  5. Change the contents of sub.pli to:
    /* Micro Focus Open PL/I program */
 %replace MSG by 'From inclue - sub';

sub: proc;
   put skip list ('Hello world sub' );
   %include 'include1.in';
end sub;
  6. Go to Project Properties > Pre-processors.
  7. Change the value of Macro Pre-processor to Yes.
  8. On the menu bar, click Build > Rebuild Solution and inspect the Output window. This will compile both program.pli and sub.pli.
  9. On the menu bar, click Build > Build Solution. You will now get the following message in the output window:
    Target "CoreCompile" in project "PLIPROJ.pliproj"
       Skipping target "CoreCompile" because all output files are up-to-date with respect to the input files.

    If you change one of the source files and then click Build > Build Solution, only that program will be compiled.

    If you change the include file, both programs will be compiled, because it is included in both of them. Any program that does not use the include file, will not be re-compiled.

Parent topic: Tutorial: Developing an Open PL/I Application Using Visual Studio
Previous topic: Add Include Files


Tutorial: Using Java CodeWatch

This tutorial shows you how to use Java CodeWatch as an alternative to the standard debugger.

  1. Overview
  2. Prerequisites
  3. Sample Programs
  4. Start Java CodeWatch
  5. Using the Button Bar
  6. Stack Panel
  7. Data Variables Panel
  8. Set Breakpoints
  9. Environment Files
  10. Memory Window
Parent topic: Tutorials: Open PL/I


Overview

Java CodeWatch is an alternative to the standard debugger which has been designed to streamline debugging tasks and has a host of usability improvements such as persistent break points, watch lists, etc.

This tutorial introduces the Java debugger's user interface and standard debugging features.

Parent topic: Tutorial: Using Java CodeWatch
Next topic: Prerequisites


Prerequisites

To run this tutorial, you need to have the latest Java Runtime Environment (JRE) or Java Development Kit (JDK) installed (1.6.0_14 or later), as well as Studio Enterprise Edition 6.0 SP1 WS1 or later.

Parent topic: Tutorial: Using Java CodeWatch
Previous topic: Overview
Next topic: Sample Programs


Sample Programs

This tutorial uses two programs, cwj.pl1 and ext.pl1. You can find them in the cw_java folder located in the Examples directory in the installation of your development system. By default this is %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\OPEN-PLI.

To compile the programs:

  1. On the Start menu, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Compatibility Tools > Net Express Command Prompt, 32-bit.
  2. Change to the directory where you have put the two sample programs.
  3. Run this command:
    mfplx -deb cwj.pl1 ext.pl1
Parent topic: Tutorial: Using Java CodeWatch
Previous topic: Prerequisites
Next topic: Start Java CodeWatch


Start Java CodeWatch

After you have compiled cwj.pl1 and ext.pl1, you can start debugging.

To start the debugger, run the command below in the command prompt:

java -jar "%MFPLI_PRODUCT_DIR%bin\cw_java.jar" cwj

This opens the main screen of Java CodeWatch with the source of cwj.pl1 displayed:

Parent topic: Tutorial: Using Java CodeWatch
Previous topic: Sample Programs
Next topic: Using the Button Bar


Using the Button Bar

The button bar is situated at the top of the debugger window, right under the menu bar and consists of the following sections.

Standard Debug Buttons
The standard control buttons are on the left of the button bar. Each button has a tooltip that describes it and indicates which function key can be used as a substitute. The function of these buttons is also available off the actions menu.The buttons are:
  • - Continue (F5)
  • - Step over (F10)
  • - Step into (F11)
  • - Step out (Shift + F11)
Sources
To select the source that you want to be displayed, use the Src dropdown list on the button bar. In this case you can select ext.pl1 and then go back to cwj.pl1.
Environments
You can go to a specific CodeWatch environment by using the Env dropdown list. It only shows environments that have been discovered so far. You can also type an environment name directly into the box. If you type FEXT into this box, it will show you the source for ext.pl1 and the dropdown list will now include the environments from ext.pl1. To go back to the original source, select cwj from the Env dropdown list.
Searching Text
You can search in the current text. For example, enter cust in the search box and click [image] (Find next) three times. You can also click [image] (Find previous) to search up.
Parent topic: Tutorial: Using Java CodeWatch
Previous topic: Start Java CodeWatch
Next topic: Stack Panel


Stack Panel

If you press [image] until the cursor is on the first line that says do i = 1 to 20, you will notice that there is now information in the stack panel in the top left corner:

This panel will show you the current stack whenever the program is stopped. As with all panels, the columns can be re-sized. You can change the relative sizes of the panels by pulling the splitter bars between each panel.

You can turn on and off the visibility of the stack panel by using the Stack option under the View menu.

Parent topic: Tutorial: Using Java CodeWatch
Previous topic: Using the Button Bar
Next topic: Data Variables Panel


Data Variables Panel

The middle panel on the left is the data variables panel.

One way of displaying data is via tooltips. If you move the mouse over the blank areas of the source code, the following tooltip will appear:

If you hover over allocate, it will show:

Hovering over Newbury gives:

Hovering over c1->name gives:

Hovering over c1 gives:

Note that in this case it has evaluated just the left-hand portion of the item. This can also be useful with arrays where hovering over line shows the whole array whereas hovering over line(i) evaluates only that item.

If you hover over c1->cust, you will get:

If you right-click over c2->cust, you will be given two popup menu items:

Click the first one and the following infomation will be displayed in the data variables panel:

You can compress and expand this item by pressing the - or + button in the top left. If you add i to the data items panel, there will be no - or + buttons because it has no sub-items.

You can enter data items directly into the Expr column to display new data items. You can modify values by entering directly into the Value column.

You can delete items by right-clicking them and selecting Delete or by using Actions > Watches>Delete.

Parent topic: Tutorial: Using Java CodeWatch
Previous topic: Stack Panel
Next topic: Set Breakpoints


Set Breakpoints

To set a breakpoint, double click on the line you want. For example, if you double click to set breakpoint on line i = 27, you get:

The red dot shows that a breakpoint has been set there.

The following information is displayed in the breakpoint panel at the bottom on the left:

You can delete the breakpoint by double-clicking on the line again or by using the context menu. You can also disable a breakpoint using the context menu. Disabled breakpoints look like this:

Parent topic: Tutorial: Using Java CodeWatch
Previous topic: Data Variables Panel
Next topic: Environment Files


Environment Files

Variable names and breakpoints are saved in a file progname.cwenv. If you change either of these items, you will be asked if you want to save these settings when you exit the debugger. When the debugger is executed again for the same program, these variable names and breakpoints will be reinstated. There are also menu items to open and save environment files if you want multiple settings.

Parent topic: Tutorial: Using Java CodeWatch
Previous topic: Set Breakpoints
Next topic: Memory Window


Memory Window

The memory window shows the contents of memory as text or numbers.

To open this window, click View > Memory.

Parent topic: Tutorial: Using Java CodeWatch
Previous topic: Environment Files


Tutorials: Service Interfaces Using the IMTK

We provide these basic tutorials:
  • COBOL Program Tutorial - Start with a COBOL application, and using its entry points, define a service interface that you deploy to an enterprise server as a Java/EJB service. Generate a JSP client and access the service.
  • CICS Screen Tutorial - Start with a CICS COBOL application and, using its .bms maps, define a service interface that you deploy to an enterprise server as a Web Services service. Generate a Windows Forms and a console client and access the service with each.
  • IMS Screen Tutorial - Start with an IMS COBOL application and, using its .mfs maps, define a service interface that you deploy to an enterprise server as a Web Services service. Generate a Windows Forms and a console client and access the service with each.

Before starting any tutorial, you must first create a Visual Studio Solution to contain your service interface projects. Following that, you can do the three tutorials in any order, but within each you must complete each topic of instruction in sequence in its entirety to be successful. The bottom of each topic provides Next topic and Previous topic navigational links to help you proceed through the tutorials in their proper sequence.

If you are not familiar with the concept and implementation of a service interface, take some time to review the introductory information and other relevant topics for the Service Interfaces feature.

  1. Create a Visual Studio Solution
  2. COBOL Program Tutorial
  3. CICS Screen Tutorial
  4. IMS Screen Tutorial
Parent topic: Mainframe Tutorials


Create a Visual Studio Solution

A service interface is a component of a Visual Studio project. For these tutorials, you'll create one Visual Studio Solution to contain your service interfaces projects -- one for each tutorial.

  1. From the Visual Studio IDE, click File > New > Project.
  2. Under Project types, expand COBOL Projects; then click Native.
  3. Under Templates, clickMainframe Subsystem Application.
  4. Complete the remaining fields as follows:
    Name | SVITutorials
    Location | Any location.
    Solution Name | SVITutorials
  5. Check Create directory for solution.
  6. Click OK.

    Visual Studio opens the Solution Explorer for the SVITutorials solution, showing the SVITutorials project. Because each service interface created in a tutorial uses a different enterprise server, and enterprise servers are associated at the project level, each service interface must be in its own project. Therefore, we will not use the default SVITutorials project but instead will create a separate project within the SVITutorial Solution for each tutorial.

Parent topic: Tutorials: Service Interfaces Using the IMTK
Next topic: COBOL Program Tutorial


COBOL Program Tutorial

In this tutorial, we take you through the following tasks:
  • In Visual Studio, set up and run the COBOL demonstration application to become familiar with how it works
  • Create a Visual Studio project for the COBOL program service interface
  • Define a Java/EJB service interface to access the COBOL application
  • Deploy the service interface to the enterprise server as an EJB
  • Generate and deploy a JSP client to access the service
  • Deploy the resource adapter to JBoss
  • Run the JSP client, accessing the service

Complete this tutorial by following the instructions in the following topics in the order listed here:

  1. Prerequisite Software
  2. Demonstration Application
  3. Create a Visual Studio Project
  4. Create a Service Interface
  5. Define a Service Interface
  6. Deploy a Service Interface
  7. Generate and Deploy a JSP Client
  8. Deploy the Resource Adapter to JBoss
  9. Run the JSP Client
Parent topic: Tutorials: Service Interfaces Using the IMTK
Previous topic: Create a Visual Studio Solution
Next topic: CICS Screen Tutorial


Prerequisite Software

To successfully deploy and access a Java service, you must have both the Java Development Kit (JDK) and a J2EE application server installed. This tutorial provides instructions for using the JBoss application server. Therefore, to complete the tutorial successfully, you must install and configure the JDK and JBoss software as follows:

  • JDK version 1.5 or later - After installation, set your system path statement to include the path to your JDK installation's \bin directory. For example:

    set path=c:\program files\java\jdk1.5\bin;%path%

  • JBoss version 4.2.3
    • Edit the run.bat file, located in your JBoss installation's \bin directory, and set the JAVA_HOME environment variable to the directory containing your JDK. For example:
      • set JAVA_HOME=c:\program files\java\jdk1.5
    • Edit the jboss-service.xml file located in your JBoss installation's \server\default\conf folder as follows:
      • Set CallByValue to true
    • Edit the ear-deployer.xml file located in your JBoss installation's \server\default\deploy folder as follows:
      • Set Isolated to false
      • Set CallByValue to true
    • Edit the jboss-service.xml file located in your JBoss installation's \server\default\deploy\jboss-web.deployer\META-INF folder as follows:
      • Set Java2ClassLoadingCompliance to true
      • Set UseJBossWebLoader to false
Parent topic: COBOL Program Tutorial
Next topic: Demonstration Application


Demonstration Application

The demonstration application provided for this tutorial represents a legacy application, that is, one that has already been in production use for some time. Legacy applications are great candidates for improvement using the Service Interfaces feature because the service you create based on the application enables you to access the application using a new, more modern interface.

The Service Interfaces feature is designed to use COBOL programs that are subprograms in an application, that is, programs with a Linkage Section. The book.cbl program supplied with the demonstration COBOL legacy application is just such a program. It maintains an indexed file, which is a stock file such as might be in use at a book retailer.

To follow the tutorial you need to understand the outline logic of the book.cbl program and its parent program, booktest.cbl even though we do not directly use the parent program. Therefore, you might want to look at the COBOL source to get familiar with it. By default, it is in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Tutorials\Service Interfaces\BookDemo folder. You can display it in Visual Studio or any text editor.

book.cbl performs four actions:
  • Read record
  • Add record
  • Delete record
  • Get Next record
Using the following parameters or data:
  • The action required - a value supplied by the user
  • The data to be processed - contained in a specified data file
  • A data item to return to the program - retrieved from the data file
Parent topic: COBOL Program Tutorial
Previous topic: Prerequisite Software
Next topic: Create a Visual Studio Project


Create a Visual Studio Project

Because the service generated from this COBOL Program service interfaces tutorial runs on an enterprise server not associated with the other tutorials, it needs its own project (enterprise servers are associated with a project rather than any specific service interface). In the project, we must add the application files needed to define the service interface and then access the deployed service.

  1. From the SVITutorials Solution in the Solution Explorer, right-click the solution name; then click Add > New Project.
  2. In the Name field, type ProgramEJB.
    Note: Because you are creating the project from within the SVITutorials solution, the default settings for Project types, Templates, and Location are correct by default.
  3. Click OK. The ProgramEJB project now appears on the Solution Explorer.
  4. Right-click the ProgramEJB project, and click Add > Existing Item.
  5. Browse to the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Tutorials\Service Interfaces\BookDemo folder.
  6. From the Objects of type drop-down list, click All files (*.*); then select the following files:
    • book.cbl
    • book-rec.cpy
    • bookfile.dat
    • bookfile.idx
  7. Click Add.
Parent topic: COBOL Program Tutorial
Previous topic: Demonstration Application
Next topic: Create a Service Interface


Create a Service Interface

We are creating a Java type service interface (EJB) that uses the source program book.cbl.

  1. From the Solution Explorer, right-click the ProgramEJB project; then click Add > New Item.
  2. Under Categories:, expand Native and click Mainframe Subsystem.
  3. Under Templates:, click Service Interface.
  4. In the Name field, type ProgramEJB; then click Add.
  5. Select Java Interface as your type of interface and COBOL Program as your type of source; then click OK.

At this point, Visual Studio adds the ProgramEJB service interface to the Solution Explorer and invokes the Service Interfaces Editor. We are ready to define the details of the service interface.

Parent topic: COBOL Program Tutorial
Previous topic: Create a Visual Studio Project
Next topic: Define a Service Interface


Define a Service Interface

A service interface is defined as a series of operations. In each operation, you create service interface fields that correspond to your COBOL program's entry point fields. At runtime, data is sent between the service and the program via these fields.

In COBOL, you describe a data item's data type precisely, using its picture clause. Java uses its own set of data types. The Service Interfaces Editor enables you to create mappings between the COBOL types in your program and the types available in Java.

We'll use the Service Interfaces Editor to define streamlined access to our program by defining an operation for each of the program's four possible actions - Read record, Add record, Delete record, and Get next record. Each operation will require the client to send just the data needed by that particular operation.

  1. Add Operation
  2. Next Operation
  3. Read Operation
  4. Delete Operation
Parent topic: COBOL Program Tutorial
Previous topic: Create a Service Interface
Next topic: Deploy a Service Interface


Add Operation

The first logical operation to define for our service interface is one that enables us to add a record. The process entails identifying the COBOL program that contains the Add action, identifying the COBOL Entry point code for that program, determining which fields send and receive information, and defining our operation to interact with the program, specifying the Add action.

  1. Create the Add Operation
  2. Define an Interface Field
  3. Define a Group of Interface Fields
  4. Change a Type
  5. Define a COBOL Assignment
  6. The Completed Add Operation
Parent topic: Define a Service Interface
Next topic: Next Operation


Create the Add Operation

First, we create the operation, giving it a name and identifing the program and entry point with which we want to interact. In this case, we want to create an operation that enables us to add a record.

  1. Click Operation > New.
  2. In the Name field, type Add.

    The programs available in your Visual Studio project appear on the Select program list. From studying the COBOL code in the application, we know that the book.cbl program performs the add record action.

  3. Select book.

    The name of each entry point contained in the program appears farther down on the dialog box. This shows that Book.cbl contains only one entry point - book.

  4. From the Select entry point list, click book. The entry point code appears to its right.
  5. Click OK.

In the Service Interfaces Editor, you now see that the entry point fields have been placed into the COBOL Entry Point pane on the left.

Parent topic: Add Operation
Next topic: Define an Interface Field


Define an Interface Field

We see from the book.cbl source that lnk-file-status field returns the status of the last file input/output action. We will create an interface field to contain the value so the client can send it to the application.

  1. Drag lnk-file-status from the COBOL Entry Point pane to the Interface Fields pane.

    This creates an interface field called lnk_file_status. A mapping is automatically created between the new field and the entry point field it was created from. The purpose of this field is to relay information back to the user; therefore we need to change its direction from Input to Output.

  2. In the Direction column, double-click Input and use the drop-down list to change the direction of the lnk_file_status interface field to Output.
Parent topic: Add Operation
Previous topic: Create the Add Operation
Next topic: Define a Group of Interface Fields


Define a Group of Interface Fields

We see from the COBOL source that to add a record, the client must supply all the data needed to add the new record to the indexed file. The Book program receives the data in the group item lnk-b-details. For this operation, we need to define a set of interface fields to hold this data.

  1. Drag lnk-b-details from the COBOL Entry Point pane to the Interface Fields pane.

    The default direction, Input, is what we want because this group of fields will receive data and then pass it on to the data items in lnk-b-details.

    By default, the name of the new interface field group created is lnk_b_details. However, in this case we should change the default name. We need to use this same group of source fields to create similar groups of interface fields in other operations in this same service interface. The Service Interfaces Editor requires that interface field groups have unique names across operations in the same service interface. Therefore, because the default name for each of these would be identical in each operation, we must change the name in each operation to ensure that each is different from that used in other operations.

  2. In the Interface Fields pane, double-click lnk_b_details and change the name to addop_details; then click OK.
Parent topic: Add Operation
Previous topic: Define an Interface Field
Next topic: Change a Type


Change a Type

When defining a service interface, knowledge of the application and how it is used can enable you to make refinements to the new interface. For example, looking at the COBOL Entry Points pane, notice that the retail price field lnk-b-retail is defined as 9(2)V9(2). If you fully expand the tree for addop_details in the Interface Fields pane, you will see that lnk_b_retail has therefore defaulted to BigDecimal. Imagine that you know from your experience with the application that the retail prices are in fact always in whole numbers of dollars, and that lnk_b_retail can therefore be simply an int. We'll change the type of the lnk-b-retail interface field to reflect this.

  1. If not already expanded, fully expand the tree for addop_details in the Interface Fields pane.
  2. Double-click the BigDecimal type for the lnk_b_retail field.
  3. Select int from the dropdown list.
Parent topic: Add Operation
Previous topic: Define a Group of Interface Fields
Next topic: Define a COBOL Assignment


Define a COBOL Assignment

When the Book program executes, it uses the value in the lnk-function field to determine which action to perform. In cases like this where the value required to initialize an action is known, we create a COBOL Assignment field rather than an interface field, and assign it the value required by the program to ensure a specific action.

For the Add operation, we want the program to perform the add-record action. From looking at the source code, we know that when the value in the lnk-function field is 2, the program performs an add-record action.

  1. Drag the lnk-function field from the COBOL Entry Point pane to the COBOL Assignments pane.
  2. In the Value field, type 2; then click OK.
  3. Save the service interface.
Parent topic: Add Operation
Previous topic: Change a Type
Next topic: The Completed Add Operation


The Completed Add Operation

The Add Operation (EJB)

Let's look in a little more detail at what this means.

The correspondence between the COBOL Entry Point fields and interface fields is set up when you do the drag-and-drop. If you right-click an elementary interface field, such as lnk_file_status, and click Mapping, you see a dialog box showing the COBOL Entry point field associated with it. This correspondence is not affected by the names or order of interface fields. You can use the dialog box to alter the mapping if you want.

In the messages passed between the service and a client, the interface fields are identified by keywords. Their names in the Interface Fields pane are used as the keywords. Nevertheless, their order in the Interface Fields pane is the order in which they are seen by a client, so it is good practice to be aware of this order. You can re-order fields by dragging them.

Parent topic: Add Operation
Previous topic: Define a COBOL Assignment


Next Operation

In our indexed file, the primary key is the stock number. The program action that gets the next record takes a stock number as input, finds the record in the data file that has that stock number, and returns the next record found.

The program uses the the COBOL Entry Point field lnk-b-details as both an input and an output field, although on input lnk-b-stockno is the only part of lnk-b-details actually used. In our operation, we will use the same field to access the program action that gets the next record in the data file.

  1. Create and Define the Next Operation
  2. The Completed Next Operation
Parent topic: Define a Service Interface
Previous topic: Add Operation
Next topic: Read Operation


Create and Define the Next Operation

  1. Right-click the word Operation below the title bar, and click New on the popup menu.

    Using this popup menu is an alternative to the pulldown menu we used before.

  2. In the Name field, type Next.

    The Select program list shows that book is already selected for you. This is because each service interface can use only one program, and you specified the book program in the Add operation we defined earlier for this same service interface.

  3. From the Select entry point list, click book; then click OK.

    The Interface Fields and COBOL Assignments panes for the new operation are blank in anticipation of new definitions for this operation.

  4. Based on the instructions for the Add operation, define a COBOL Assignment for the lnk-function field and set its value to 4. This is the value that instructs the program to get the next record.
  5. Create an interface field named lnk_file_status from the COBOL Entry Point field link-file-status; then set its direction to Output.

    The program action that retrieves the next record gets the required record from the data file and returns it. So we need a set of output fields in which to return the fields of this record.

  6. Drag lnk-b-details from the COBOL Entry Point pane to the Interface Fields pane.

    The new interface field created is called lnk_b_details. As we did when defining the Add operation, we will change the field name to ensure that it is different from the name used for similar groupings in the other operations for this interface.

  7. Double-click the lnk_b_details field name in the Interface Fields pane and change the name to nextop_details; then click OK.
  8. Fully expand the tree for nextop_details, and change the type of lnk_b_retail from BigDecimal to int, just as we did for the Add operation.
  9. Change the direction of the nextop_details field to Output.

    In the application, the lnk_b_stockno field serves as an output field and is also the field in which the key identifying the required record is input. To handle this, we will now create an input interface field to accept the key.

  10. Drag lnk-b-stockno from the COBOL Entry Point pane to the Interface Fields pane and drop it onto the lnk_file_status interface field. This ensures that the new interface field is first on the list and thus the first field to supply its value to the program.
  11. Save the service interface.
Parent topic: Next Operation
Next topic: The Completed Next Operation


The Completed Next Operation

The Next Operation (EJB)
Parent topic: Next Operation
Previous topic: Create and Define the Next Operation


Read Operation

For the program action that reads a record, the caller supplies a book's stock reference number, title, or author in the appropriate field in the lnk-b-details group. The program looks it up in the indexed file and returns the data back to the lnk-b-details group. Therefore, the program uses the fields contained in the lnk-b-details group as both input and output. On input, the program expects the stock number, title, or author to be supplied; the other data items in lnk-b-details are ignored. On output, lnk-b-details is used to return the record indicated by the supplied stock number, title, or author.

  1. Create and Define the Read Operation
  2. Define a Reusable Field
  3. The Completed Read Operation
Parent topic: Define a Service Interface
Previous topic: Next Operation
Next topic: Delete Operation


Create and Define the Read Operation

  1. Create a new operation named Read that uses the book entry point.
  2. Create a COBOL Assignment for the lnk-function field and set its value to 1. This is the value that instructs the program to read a record.
  3. Create an interface field named lnk_file_status from the COBOL Entry Point field lnk-file-status; then set its direction to Output.

    The program functionality that reads a record gets the required record from the data file and returns it. Therefore, we need a set of output fields in which to return the fields of this record.

  4. Drag lnk-b-details from the COBOL Entry Point pane to the Interface Fields pane.
  5. Change the name of the lnk_b_details interface field to readop_details.
  6. Expand the tree for readop_details and change the type of lnk_b_retail from BigDecimal to int.
  7. Change the direction of readop_details to Output.
Parent topic: Read Operation
Next topic: Define a Reusable Field


Define a Reusable Field

We now need to define our input fields. In doing this, we will demonstrate another feature of the Service Interfaces Editor -- Reusable Fields. You create reusable fields from COBOL entry point fields for the purpose of using them across operations. In Java terms, a reusable field is a custom record according to the CustomRecord interface defined in the Common Client Interface (CCI) from Sun. For Java-based service interfaces, the Service Interfaces Editor assigns a custom data type to interface fields created from reusable fields based on the CCI. Here we will create a group of reusable fields that contains only the fields used by the service interface, eliminating those that are not.

  1. Drag lnk-b-details to the Reusable Fields pane.
  2. Fully expand the tree under lnk_b_details in the Reusable Fields pane.
  3. Ungroup lnk_b_text_details so that all the items are at the same level. To do this, right-click lnk_b_text_details; then click Ungroup.
  4. Delete each elementary field in the Reusable Fields pane except lnk_b_title, lnk_b_author and lnk_b_stockno. To delete a field, either click it and press Delete or right-click it and select Delete from the popup menu. If the tree view contracts, expand it to see what you have created.

    You have defined a group of reusable fields as shown here:
    The Reusable Mapping Created for your EJB

  5. Drag lnk_b_details from the Reusable Fields pane to the Interface Fields pane. Be sure not to drop it amongst the fields that are subordinate to readop_details.

    This creates an interface field of type lnk_b_details. By default, its name is also lnk_b_details.

  6. Because Java requires that group fields have unique names across operations, change its name to readop_input.
  7. Save the service interface.
Parent topic: Read Operation
Previous topic: Create and Define the Read Operation
Next topic: The Completed Read Operation
Related information
CustomRecord and Other Java Support


The Completed Read Operation

The Read Operation (EJB)
Parent topic: Read Operation
Previous topic: Define a Reusable Field


Delete Operation

Like the program action that reads a record, the action that deletes a record expects the stock number, title, or author to be supplied. The other data items in lnk-b-details are ignored. It deletes the record indicated by the supplied stock number, title, or author.

  1. Create and Define the Delete Operation
  2. The Completed Delete Operation
Parent topic: Define a Service Interface
Previous topic: Read Operation


Create and Define the Delete Operation

  1. Create a new operation named Delete that uses the book entry point.

    Reusable fields you created in a different operation remain visible for all operations.

  2. Create a COBOL Assignment for the lnk-function field and set its value to 3. This is the value that instructs the program to delete a record.
  3. Create an interface field named lnk_file_status from the COBOL Entry Point field link-file-status; then set the direction to Output. This is the only required output field.
  4. Drag lnk_b_details from the Reusable Fields pane to the Interface Fields pane and rename the new interface field delete_input.
  5. Save the service interface.

    This completes the Delete operation and the ProgramEJB service interface definition..

  6. Close the Service Interfaces Editor.
Parent topic: Delete Operation
Next topic: The Completed Delete Operation


The Completed Delete Operation

The Delete Operation (EJB)
Parent topic: Delete Operation
Previous topic: Create and Define the Delete Operation


Deploy a Service Interface

To successfully deploy a Java service interface, we must first ensure that we have an enterprise server to run the service, and that our deployment settings are in order. Then, we can run the deployment process to copy all of the appropriate service interface files to the deployment area, enabling the deployed service to run.

  1. Associate and start the ESDEMO Enterprise Server
  2. Build the ProgramEJB Project
  3. Set Deployment Properties
  4. Deploy the ProgramEJB Service Interface
  5. View Deployment Results
Parent topic: COBOL Program Tutorial
Previous topic: Define a Service Interface
Next topic: Generate and Deploy a JSP Client


Associate and start the ESDEMO Enterprise Server

Enterprise Server provides an enterprise server instance, ESDEMO, that will run our deployed service. We need to associate it with our ProgramEJB project, and then start it.

  1. In Visual Studio from the Server Explorer, expand Localhost under Micro Focus Servers to see a list of available enterprise servers.
  2. Right-click the ESDEMO enterprise server; then click Associate with project > ProgramEJB.
  3. To start the ESDEMO enterprise server, right-click it; then click Start. If this is the first time you have started the server you might see a sign-on dialog box. Select Store Credentials to skip this step in the future, and click OK to continue.

The Enterprise Server Console Daemon is then invoked, starting the enterprise server.

Parent topic: Deploy a Service Interface
Next topic: Build the ProgramEJB Project


Build the ProgramEJB Project

We need to generate a .dll executable file from our project to deploy with our service interface. This is necessary so that we can debug the service after generating a client.

  • From the Solution Explorer, right-click the ProgramEJB project; then click Build.
Parent topic: Deploy a Service Interface
Previous topic: Associate and start the ESDEMO Enterprise Server
Next topic: Set Deployment Properties


Set Deployment Properties

To ensure that the deployment process runs smoothly, we must set some options that tell the Service Interfaces feature what application server to use and where to find certain files.

  1. From the Solution Explorer, right-click the ProgramEJB service interface; then click Properties.
  2. Be sure that the Application server property is set to JBoss 4.2.3 (J2EE 1.4) (this is the default).
  3. Click the Application files to deploy field, and then click the browse button to add the following files:
    File | Location
    bookfile.dat | Your Visual Studio project's ProgramEJB folder
    bookfile.idx | Your Visual Studio project's ProgramEJB folder
    book.dll | Your Visual Studio project's ProgramEJB\bin\x86\debug folder

    These files are copied to the enterprise server when you deploy. The .dll is the executable file you need to debug the service. The .dat and .idx files are the data and index parts of the indexed file accessed by the service.

  4. Click the browse button on the Classpath field and add the following files, all of which are located in your JBoss installation's \server\default\lib folder:
    • jboss-j2ee.jar
    • jboss-jca.jar
    • servlet-api.jar

    These are your EJB connector classes.

  5. Accept the default values for all other fields.
Parent topic: Deploy a Service Interface
Previous topic: Build the ProgramEJB Project
Next topic: Deploy the ProgramEJB Service Interface


Deploy the ProgramEJB Service Interface

  • From the Solution Explorer, right-click the ProgramEJB service interface; then click Deploy.

The Output window shows the progression of the deployment process. If deployment was successful, you should see a message indicating success.

If ever deployment fails, you should find a message in the output window indicating why it failed. Also, the failure message contains the path to the deployment log file. You can type the address into a browser and view the log file from there.

Parent topic: Deploy a Service Interface
Previous topic: Set Deployment Properties
Next topic: View Deployment Results


View Deployment Results

Now that your service interface has been deployed as a service running on the ESDEMO enterprise server, we can look at the details of the deployed service Enterprise Server Administration page.

  1. From the Server Explorer, right-click Micro Focus Servers; then click Administration.

    The Enterprise Server Administration Home page appears in the main window of Visual Studio.

    In the row showing information for the ESDEMO enterprise server, you should see that the Objects column shows the number of services that this enterprise server runs. In this case, the number of running services should be at least 9. These are the five that come standard with the ESDEMO enterprise server, plus the one service we added containing four operations. You might see more if you have deployed other services to the ESDEMO enterprise server.

  2. Click the Details button for the ESDMO Services.

    In the row showing our new service, ProgramEJB, you'll notice that the Current Status column shows all four operations as Available. This means that the service is ready to be access by a client.

Parent topic: Deploy a Service Interface
Previous topic: Deploy the ProgramEJB Service Interface


Generate and Deploy a JSP Client

For an EJB to access a COBOL service running on an enterprise server, you must have the EJB and a JSP client running on an application server. We will now generate an EJB and a JSP client for the ProgramEJB service we deployed and configure our JBoss application server to run them.

  1. From the Solution Explorer, right-click the ProgramEJB service interface; then click Generate Clients.

    The Output window tells you when the client has generated successfully.

  2. Copy the ProgramEJB.ear file, located in your Visual Studio project's \ProgramEJB.deploy directory, to your JBoss installation's \server\default\deploy directory.
Parent topic: COBOL Program Tutorial
Previous topic: Deploy a Service Interface
Next topic: Deploy the Resource Adapter to JBoss


Deploy the Resource Adapter to JBoss

Before you can run your JSP client, you must first deploy the resource adapter to JBoss.

  • Copy the following resource adapter files from your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x directory to your JBoss installation's \server\default\deploy directory:
    • mfcobol-notx-ds.xml
    • mfcobol-notx.rar
Parent topic: COBOL Program Tutorial
Previous topic: Generate and Deploy a JSP Client
Next topic: Run the JSP Client


Run the JSP Client

Now we are ready to run our JSP client in JBoss. When you run the JSP client, it takes a request from the end user and passes it to the EJB you generated. The EJB in turn passes the request to the enterprise server, ESDEMO. The original COBOL program runs on the enterprise server and processes the request, returning the results back to the JSP.

  1. From a command prompt, change to your JBoss installation's \bin directory and enter Run.
  2. When the JBoss startup script has completed, start a Web browser, and enter the following address:

    http://localhost:8080/ProgramEJB/ProgramEJBMain.jsp.

  3. Click Read.
  4. In the read_readop_input_lnk_b_stockno field, type 1111; then click Go!.

    The service returns the record that corresponds to the 1111 stock number.

  5. Experiment with running the Add, Next, and Delete options, providing the input required.

This completes the COBOL Program tutorial.

Note: If you plan to continue with another Service Interfaces tutorial, stop the ESDEMO enterprise server before continuing.
Parent topic: COBOL Program Tutorial
Previous topic: Deploy the Resource Adapter to JBoss


CICS Screen Tutorial

In this tutorial, we take you through the following tasks:

  • Create and configure an enterprise server to run an existing CICS application under Enterprise Server Mainframe Subsystem Support (MSS)
  • Set up and run the ACCT demonstration application to become familiar with how it works
  • Create a Visual Studio project for the CICS Screen service interface
  • Define a Web Services service interface to the CICS application
  • Deploy the service interface to the enterprise server as a Web Services service
  • Generate clients to access the service
  • Run the Windows Forms and the console clients, accessing the service

Complete this tutorial by following the instructions in the following topics in the order listed here:

  1. Prerequisite Software
  2. Demonstration Application
  3. Create an Enterprise Server
  4. Configure and Start the Enterprise Server
  5. Set Up and Run the ACCT Application
  6. Create a Visual Studio Project
  7. Associate the CICSEXT Enterprise Server
  8. Create a Service Interface
  9. Define a Service Interface
  10. Deploy a Service Interface
  11. Generate Clients
  12. Register the Proxy Library
  13. Run the Windows Forms Client
  14. Build and Run the Console Client
Parent topic: Tutorials: Service Interfaces Using the IMTK
Previous topic: COBOL Program Tutorial
Next topic: IMS Screen Tutorial


Prerequisite Software

In addition to Studio Enterprise Edition, to complete this tutorial you also need to have a TN3270 emulator installed, for example, Micro Focus Rumba.

Parent topic: CICS Screen Tutorial
Next topic: Demonstration Application
Parent topic: IMS Screen Tutorial
Next topic: Demonstration Application


Demonstration Application

The CICS application that you use in this tutorial is the ACCT demonstration application, the standard example application that IBM supplies with CICS systems. The ACCT application executables are supplied with Studio Enterprise Edition.

To successfully define a service interface, you need to be familiar with the ACCT application. You will get the chance to do this as you complete the first series of tasks in this tutorial, which are next in the sequence.

Parent topic: CICS Screen Tutorial
Previous topic: Prerequisite Software
Next topic: Create an Enterprise Server


Create an Enterprise Server

Enterprise Server comes with a pre-configured enterprise server named ESDEMO. However, it is not configured for Mainframe Subsystem Support (MSS). Therefore, you must create a new enterprise server instance configured for MSS for the CICS application.

  1. Start Visual Studio.
  2. Open Server Explorer.

    If it is hidden, choose View > (Other Windows >) Server Explorer.

  3. Right-click Micro Focus Servers and choose Administration from the context menu.

    This opens the home page of Enterprise Server Administration.

    Alternatively, you can start Enterprise Server outside of the IDE in a browser. Enter the following URL in the address bar: http://localhost:86.

  4. On the Enterprise Server Administration home page, click Add.
  5. In the Server Name field, type CICSEXT.
  6. Make sure the Working mode is set to 32-bit.
  7. Click Next.
  8. In the Server Type group, click Micro Focus Enterprise Server with Mainframe Subsystem Support.
  9. Click Next.
  10. In the Startup Options group, set the Service Execution Processes to 3. Because the service interface is a screen-based CICS service, at least 3 SEPs are required for the service to run smoothly.
  11. In the Creation Options group, be sure that Create TN3270 listener is checked.
  12. In the using port field to the right of the checkbox, type 9004.
    Note: If port 9004 is already in use on your system, specify another free port instead.
  13. In the Description field, type a description of the new enterprise server, for example, CICS Screen Tutorial.
  14. Click Add.

This displays the Enterprise Server Administration Home page with your new CICSEXT server on the list of the available enterprise servers.

Parent topic: CICS Screen Tutorial
Previous topic: Demonstration Application
Next topic: Configure and Start the Enterprise Server


Configure and Start the Enterprise Server

Now that you have created an enterprise server for our CICS application, you need to configure the Mainframe Subsystem Support that drives CICS applications. The ACCT application is already compiled, so configuration is minimal. After configuration, we will start the CICSEXT enterprise server in preparation for running the ACCT application.

  1. On the Enterprise Server Administration Home page, click the Edit button that corresponds to the CICSEXT enterprise server.
  2. Click the MSS tab.
  3. In the System Initialization Table field, type IMTKCICS.
  4. Click Apply.
  5. On the list at the left of the page, click Home to return to the Enterprise Server Administration Home page.
  6. In the row that corresponds to the CICSEXT enterprise server, click the Details button that corresponds to 3 Listeners.

    The listeners represent the three types of services you can run using this enterprise server.

  7. Click the Edit button that corresponds to Web Services and J2EE.
  8. Change the contents of the Endpoint Address field to *:9003.
  9. Click OK.
  10. On the list at the left of the page, click Home to return to the Enterprise Server Administration Home page.
  11. In the row that corresponds to the CICSEXT enterprise server, click the Start button that appears in the column labeled Status. This displays a daemon and starts your CICS region.

    After the Enterprise Server Administration Home page refreshes itself a time or two, you should see the word Started above the Details and Stop buttons for the CICSEXT enterprise server.

    Note: If any other enterprise servers are started, stop them before proceeding.
Parent topic: CICS Screen Tutorial
Previous topic: Create an Enterprise Server
Next topic: Set Up and Run the ACCT Application


Set Up and Run the ACCT Application

Now that you have created, configured, and started an enterprise server with MSS for the CICS application, you need to run the application and become familiar with how it works. It is essential when defining a service interface that you are familiar with the application. Work through the instructions in the following topics, in order, to help you become familiar with the ACCT application:

  1. Initialize VSAM Files
  2. Start the ACCT Application
  3. Add Two Records
  4. Display a Record
Parent topic: CICS Screen Tutorial
Previous topic: Configure and Start the Enterprise Server
Next topic: Create a Visual Studio Project


Initialize VSAM Files

Before you can run our application via the enterprise server you have created and started, you need to initialize its VSAM files.

  1. Connect to your enterprise server using your TN3270 emulator. Your host name is localhost, and the port number is 9004.
  2. Clear the screen to get rid of the CESN login screen. You do not need to log in.
    Note: If you are using Rumba, press F3 to skip the signon screen.
  3. To initialize the VSAM files for our application, enter CFCR ACCTFIL. You should receive a message indicating that the file was successfully created.
Note: If the ACCTFIL VSAM was previously initialized, a message appears explaining that the ACCTFILE already exists. This might be the case, especially if you have previously run this tutorial.
Parent topic: Set Up and Run the ACCT Application
Next topic: Start the ACCT Application


Start the ACCT Application

  1. Clear the screen of your TN3270 emulator.
    Note: If you are using Rumba, press Ctrl+Shift+Z to clear the screen.
  2. Enter ACCT. The following shows the initial screen of our application:

As you can see from this screen, this application lets you display, add to, delete, print, or modify information in a database. In the next two topics, you add two records to the database and then display one of those records. This should give you a good understanding of how the application works.

Parent topic: Set Up and Run the ACCT Application
Previous topic: Initialize VSAM Files
Next topic: Add Two Records


Add Two Records

You will use the records you create here later on in the tutorial.

  1. Tab to the REQUEST TYPE field and type A.
  2. In the ACCOUNT field, type 11111.
  3. Press Enter.
  4. Complete the fields on the NEW RECORD screen as follows. Of the three ADDRESS fields, complete only the first two. Fields not represented here are not mandatory so please skip over them.
    SURNAME | Washington
    FIRST | George
    TITLE | Pres
    TELEPHONE | 8005551212
    ADDRESS | Mt. Vernon Estate
    Mt. Vernon, VA
    NO. CARDS ISSUED | 1
    DATE ISSUED | 07 04 76
    REASON | N
    CARD CODE | 1
    APPROVED BY | ME
  5. Press Enter.
  6. Repeat steps 1 through 5, substituting the following data:
    ACCOUNT | 33333
    SURNAME | Jefferson
    FIRST | Thomas
    TITLE | Pres
    TELEPHONE | 8005551212
    ADDRESS | Monticello
    Charlottesville, VA
    NO. CARDS ISSUED | 3
    DATE ISSUED | 07 04 76
    REASON | N
    CARD CODE | 1
    APPROVED BY | ME
  7. Press Enter to return to the Menu.
Parent topic: Set Up and Run the ACCT Application
Previous topic: Start the ACCT Application
Next topic: Display a Record


Display a Record

  1. Tab to the REQUEST TYPE field.
  2. Type D to display a record.
  3. In the ACCOUNT field, type 11111.
  4. Press Enter. The following shows the record retrieved from the database:

    ACCT Record Display

  5. Clear the screen of your TN3270 emulator to exit the application.
Parent topic: Set Up and Run the ACCT Application
Previous topic: Add Two Records


Create a Visual Studio Project

Because the service generated from this CICS Screen service interfaces tutorial runs on an enterprise server not associated with the other tutorials, it needs its own project (enterprise servers are associated with a project rather than any specific service interface). In the project, we must add the application files needed to define the service interface and then access the deployed service.

  1. From the SVITutorials Solution in the Solution Explorer, right-click the solution name; then click Add > New Project.
  2. In the Name field, type CICSScreenWS.
    Note: Because you are creating the project from with the SVITutorials solution, the default settings for Project types, Templates, and Location are correct.
  3. Click OK. The CICSScreenWS project now appears on the Solution Explorer.
  4. Right-click the CICSScreenWS project, and click Add > Existing Item.
  5. Browse to the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Tutorials\Service Interfaces\ACCTDEMO folder.
  6. From the Objects of type drop-down list, click BMS files (*.bms); then select the acctset.bms file.
  7. Click Add.
  8. To save this project, click File > Save CICSScreenWS.
Parent topic: CICS Screen Tutorial
Previous topic: Set Up and Run the ACCT Application
Next topic: Associate the CICSEXT Enterprise Server


Associate the CICSEXT Enterprise Server

We now need to associate the CICSEXT enterprise server we created with our CICSScreenWS project.

  1. In Visual Studio from the Server Explorer, expand Localhost under Micro Focus Servers to see a list of available enterprise servers.
  2. Right-click the CICSEXT enterprise server; then click Associate with project > CICSScreenWS.
    Note: If CICSEXT does not appear on the list of enterprise servers, click Refresh Refresh.
Parent topic: CICS Screen Tutorial
Previous topic: Create a Visual Studio Project
Next topic: Create a Service Interface


Create a Service Interface

We are creating a Web Services type service interface that uses CICS screens.

  1. From the Solution Explorer, right-click the CICSScreenWS project; then click Add > New Item.
  2. Under Categories:, expand Native and click Mainframe Subsystem.
  3. Under Templates:, click Service Interface.
  4. In the Name field, type CICSScreenWS; then click OK.
  5. Select Web Service as your type of interface and CICS Screen as your type of source; then click OK.

At this point, Visual Studio adds the CICSScreenWS service interface to the Solution Explorer and invokes the Service Interfaces Editor. We are ready to define the details of the service interface.

Parent topic: CICS Screen Tutorial
Previous topic: Associate the CICSEXT Enterprise Server
Next topic: Define a Service Interface


Define a Service Interface

Each service interface you create is comprised of a set of operations. For a CICS Screen service interface, each operation addresses a screen encountered by the program. We will define these four operations to enable users to retrieve and display account information from the database by providing the account number:

  • Start - to start up the ACCT application
  • Enter Account Number - to set the request type to display account information, and to expose the account number for input
  • Get Account Data - to retrieve and expose the data for the specified account number
  • On Error - to provide a message when an error is encountered
  1. Start Operation
  2. Enter Account Number Operation
  3. Get Account Data Operation
  4. On Error Operation
Parent topic: CICS Screen Tutorial
Previous topic: Create a Service Interface
Next topic: Deploy a Service Interface


Start Operation

The purpose of the Start operation is to connect to our application.

  1. From the Service Interfaces Editor, click Operation > New.
  2. In the Operation Name field, type Start.
  3. Leave the default values in the Active Screen and Previous Screen fields.
  4. In the Transaction ID field, type ACCT.
  5. Click OK.
  6. Save the service interface.

    This completes the Start operation.

Parent topic: Define a Service Interface
Next topic: Enter Account Number Operation


Enter Account Number Operation

The Enter Account Number operation exposes the account number of the record to be retrieved. It automatically sets the request type to display information.

  1. Click Operation > New.
  2. In the Operation Name field, type Enter Account Number.
  3. From the Active Screen drop-down list, click ACCTSET.ACCTMNU. This is the name of the main menu of the ACCT application.
  4. Leave the default value, ANY SCREEN, in the Previous Screen field.
  5. Leave the Transaction ID field blank. This operation does not start a transaction.
  6. Leave Create Default Mapping unchecked.
  7. Click OK. This returns you to the Service Interfaces Editor and shows the CICS Screen ACCTSET.ACCTMNU.

    We're now ready to map our interface fields and make some assignments for this operation. As we learned from running this application in its original form, we need to provide the application with a D (for display) in the REQUEST TYPE field and an account number in the ACCOUNT field in order to retrieve information about an account. We will start with specifying the input field for the account number.

  8. On the CICS Screen pane, locate the ACCTM field by hovering over the entry fields. ACCTM is located to the right of the ACCOUNT label. It is the field where users enter the account number.
  9. Click and drag the ACCTM field to the Interface Fields pane and drop it there.

    The name ACCTM is not particularly descriptive. Because this field is really the input field for the account number, we will rename it in the Service Interfaces Editor so that it is more recognizable. The name we use here will appear as the field label in our generated Windows Forms client.

  10. In the Interface Fields pane, double-click ACCTM.
  11. In the Name field, type AccountNumber. The other fields on this dialog box are accurate so no additional adjusting is necessary here.
  12. Click OK.

    Notice that the Mappings pane shows the interface field with its new name, AccountNumber, mapping to the COBOL field ACCTM.

    Now we will make some assignments that automatically set the value for the request to D for display, and set the attention identifier.

  13. On the CICS Screen pane, hover over the input field next to the REQUEST TYPE label. Note that the name of the input field is REQM.
  14. In the Assignments pane, right-click and select New Assignment from the popup menu.
  15. From the Assign to drop-down list, click REQM.
  16. In the Field 1/Operand 1 field, type D, which is the value that tells the application to display information.
  17. Click OK.
  18. In the Assignments pane, right-click and select New Assignment from the popup menu.
  19. From the Assign to drop-down list, click ATTENTION ID. This is the field that defines which AID key (for example, Enter, PF8, etc.) should be used.
  20. From the Field 1/Operand 1 drop-down list, click ENTER.
  21. Click OK.
  22. Save the service interface.

    This completes the Enter Account Number operation.

Parent topic: Define a Service Interface
Previous topic: Start Operation
Next topic: Get Account Data Operation


Get Account Data Operation

The Get Account Data operation retrieves the requested account information from the database and exposes it in the service interface.

  1. Click Operation > New.
  2. In the Operation Name field, type Get Account Data.
  3. From the Active Screen drop-down list, click ACCTSET.ACCTDTL. This is the name of the details screen of the ACCT application.
  4. In the Previous Screen field, leave the default value of ANY SCREEN because in this service interface, the ACCTSET.ACCTDTL screen is used only once.
  5. Leave the Transaction ID field blank. This operation does not start a transaction.
  6. Leave Create Default Mapping unchecked.
  7. Click OK. The CICS Screen pane now shows the ACCTSET.ACCTDTL screen.

    We want this operation to retrieve the data for a specified account. Therefore, we need to identify the fields on the ACCTSET.ACCTDTL screen that contain the information we want to include.

  8. Hover over the fields on the ACCTSET.ACCTDTL screen and identify the location of the following fields:
    • SNAMED - surname
    • FNAMED - first name
    • ADDR1D - first address field
    • ADDR2D - second address field
    • TELD - telephone number

    These five fields contain the data we want to retrieve from the database.

  9. Drag each of the fields listed in step 8 from the screen to the Interface Fields pane and drop them there.

    We want to rename each of the fields to something more meaningful. The default direction for each of these fields is Input. Because these fields function as output fields in our service, we must change their direction to Output.

  10. Double-click each entry on the Interface Fields list. Rename each as indicated in the following table, and click the Output radio button for each:
    Name | New Name
    SNAMED | LastName
    FNAMED | FirstName
    ADDR1D | Address1
    ADDR2D | Address2
    TELD | Phone
  11. Save the service interface.

    This completes the Get Account Data operation.

Parent topic: Define a Service Interface
Previous topic: Enter Account Number Operation
Next topic: On Error Operation


On Error Operation

Here we will add an operation that provides an error message if something goes wrong during the execution of our service. This is the last operation we need to add to our service interface; therefore, we will also close the Service Interfaces Editor in preparation for deployment.

  1. Click Operation > New.
  2. In the Operation Name field, type On Error.
  3. From the Active Screen drop-down list, click ACCTSET.ACCTMNU.
  4. From the Previous Screen drop-down list, click ACCTSET.ACCTMNU. This sets the operation to execute if the application sends a second consecutive ACCTSET.ACCTMNU screen, indicating an error.
  5. Leave the Transaction ID field blank. This operation does not start a transaction.
  6. Leave Create Default Mapping unchecked.
  7. Click OK. The CICS Screen pane now shows the ACCTSET.ACCTMNU screen.

    We want this operation to output a message indicating an error has occurred. Therefore, we need to identify the error message field on the ACCTSET.ACCTMNU screen.

  8. Hover over the fields on the ACCTSET.ACCTMNU screen and identify the location of the MSGM field, located at the bottom of the screen.
  9. Drag the MSGM field to the Interface Fields pane and drop it there.
  10. In the Interface Fields pane, double-click msgm and change its name to Msg and its direction to Output.
    Note:

    It seems logical to name this output field "Message." However, MESSAGE is a COBOL reserved word. We cannot name a field using a reserved word.

  11. Click OK.
  12. Save the service interface.

    This completes the On Error operation and the CICSScreenWS service interface definition.

  13. Close the Service Interfaces Editor.
Parent topic: Define a Service Interface
Previous topic: Get Account Data Operation


Deploy a Service Interface

To successfully deploy our Web services service interface, we must be sure that the CICSEXT enterprise server is started, and then run the deployment process to copy all of the appropriate service interface files to the deployment area, enabling the deployed service to run.

  1. On the Server Explorer, expand Micro Focus Servers > Localhost to show a list of available enterprise servers.
  2. Check to be sure that the CICSEXT enterprise server is started by right-clicking CICSEXT. If it is stopped, click Start.
  3. If any enterprise servers other than CICSEXT show as being started, right-click each; then click Stop to stop them.
  4. From the Solution Explorer, right-click the CICSScreenWS service interface; then click Deploy.

    The Output window shows the progression of the deployment process. If deployment was successful, you should see a message indicating success.

Note: If deployment ever fails, a message appears in the output window indicating why it failed. Also, the failure message contains the path to the deployment log file. You can type the address into a browser and view the log file from there.
Parent topic: CICS Screen Tutorial
Previous topic: Define a Service Interface
Next topic: Generate Clients


Generate Clients

We will now generate Web Services clients to access the CICSScreenWS service that we deployed to our CICSEXT enterprise server.
Note: Be sure you have met all of the prerequisites for generating Windows Forms clients as specified in the topic Prerequisites.

The generation process for Web Services automatically produces a console client; however, we must set an option to enable generation of a Windows Forms client.

  1. From Visual Studio, click Tools > Options.
  2. Expand Projects and Solutions > COBOL Project Settings; then click Service Interfaces.
  3. Check Windows Forms Application; then click OK.
  4. From the Solution Explorer, right-click the CICSScreenWS service interface; then click Generate Clients.
You can watch the generation process in the Output window. When it is complete, you'll see the message "Generation of Windows Forms Application completed." You should see that two projects have been added to the Solution Explorer:
  • CICSScreenWSConsoleApp - the console client.
  • CICSScreenWSWinApp - the Windows Forms client.

Each new project contains the necessary client files to successfully access the CICSScreenWS service now running on the CICSEXT enterprise server.

Parent topic: CICS Screen Tutorial
Previous topic: Deploy a Service Interface
Next topic: Register the Proxy Library
Related information
Prerequisites


Register the Proxy Library

Depending on your Windows operating system version, you might be required to register the Proxy Library after after generating a Windows Forms client for the first time. If you received a message indicating that registration is necessary, follow these steps:

  1. Start aNet Express command prompt.
  2. Change to your CICSScreenWSWinApp project's \bin\release directory.
  3. Enter regsvr32 CICSScreenWSProxyWrapper.dll.
  4. Click OK to clear the RegSvr32 message.
Note: The full path to and name of the proxy library .dll file appears in the Output window during client generation. For example:

Register proxy library CICSScreenWSProxyWrapper.dll in "c:\myProjects\SVITutorials\CICSScreenWSWinApp\Bin\Release".

Parent topic: CICS Screen Tutorial
Previous topic: Generate Clients
Next topic: Run the Windows Forms Client


Run the Windows Forms Client

  1. From the Solution Explorer, right-click CICSScreenWSWinApp; then click Debug > Start new instance.
  2. In the AccountNumber field, type 33333, then click Submit. The client returns account information for the 33333 account number.
  3. Click Exit.
Parent topic: CICS Screen Tutorial
Previous topic: Register the Proxy Library
Next topic: Build and Run the Console Client


Build and Run the Console Client

  1. From the Solution Explorer, right-click CICSScreenWSConsoleApp; then click Build.
  2. Again, right-click CICSScreenWSConsoleApp; then click Set as StartUp Project.
  3. From the main menu, click Debug > Start Debugging.
  4. Press Enter three times to progress to the AccountNumber field.
  5. Enter 12345. The client returns an error message and exits.
Parent topic: CICS Screen Tutorial
Previous topic: Run the Windows Forms Client


IMS Screen Tutorial

In this tutorial, we take you through the following tasks:

  • Prepare the IMS demonostration application files to run on an enterprise server.
  • Create and configure an enterprise server to run the IMS application under Enterprise Server Mainframe Subsystem Support (MSS)
  • In Visual Studio, set up and run the COBOL demonstration application to become familiar with how it works
  • Create a Visual Studio project for the IMS Screen service interface
  • Define a Web Services service interface to the IMS application
  • Deploy the service interface to the enterprise server as a Web Services service
  • Generate clients to access the service
  • Run the Windows form and the console client, accessing the service

Complete this tutorial by following the instructions in the following topics in the order listed here:

  1. Prerequisite Software
  2. Demonstration Application
  3. Prepare the IMS Application and Enterprise Server
  4. Create a Visual Studio Project
  5. Associate the IMSIVP Enterprise Server
  6. Create a Service Interface
  7. Define a Service Interface
  8. Deploy a Service Interface
  9. Generate Clients
  10. Register the Proxy Library
  11. Run the Windows Forms Client
  12. Build and Run the Console Client
Parent topic: Tutorials: Service Interfaces Using the IMTK
Previous topic: CICS Screen Tutorial


Demonstration Application

The IMS application that you use in this tutorial is the MFDEMO application. This application provides access to tables of data in an IMS database. You can add, modify, or query the information via MFS screens.

You will get the chance to become familiar with the MFDEMO application as you prepare it for an enterprise server and run the application on an enterprise server. These tasks are completed next.

Parent topic: IMS Screen Tutorial
Previous topic: Prerequisite Software
Next topic: Prepare the IMS Application and Enterprise Server


Prepare the IMS Application and Enterprise Server

All of the instructions you need to prepare the demonstration application to run on an enterprise server, create an enterprise server to run it, and to run the application to become familiar with it are in the following topics. Complete all of the tasks contained in these topics before continuing on to create a Visual Studio project for your IMS Screen service interface.

  • IVP Overview
  • Before Running the IVP
  • Running the IVP
Parent topic: IMS Screen Tutorial
Previous topic: Demonstration Application
Next topic: Create a Visual Studio Project


IVP Overview

The IVP is based around a demonstration program called Mfdemo, which is installed into %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Net Express IDE\MTO-IMS\IVP by default. Mfdemo is a system for capturing and maintaining table data. The tables are organized by table element within table name. The tables eliminate the program maintenance associated with traditional Data Division tables. The following source members are used by this application:

  • demo03dd.dbd
  • demo001t.psb
  • demo90.mfs
  • demo91.mfs
  • demo92.mfs
Parent topic: Prepare the IMS Application and Enterprise Server
Parent topic: IMS Installation Verification


Before Running the IVP

This section describes the steps you need to perform before you can run the IVP. These steps are split into three sections:

  • Preparing the IVP. This section shows how to compile and generate the various source files that make up the IVP and load the database.
  • Updating the Resource Definition File. This section shows how to update your resource definition file with transactions required to run IMS applications.
  • Configuring an Enterprise Server for the IVP. This section shows how to configure an enterprise server so that you can run the IMS IVP.
  1. Preparing the IVP
  2. Updating the Resource Definition File
  3. Configuring an Enterprise Server for the IVP
Parent topic: Prepare the IMS Application and Enterprise Server
Parent topic: IMS Installation Verification
Preparing the IVP
Updating the Resource Definition File
Configuring an Enterprise Server for the IVP


Preparing the IVP

Although the Mfdemo application is supplied with your application software, you need to perform a number of operations on the source files before you can run it. These operations are:

  • Copy the IVP files to a new folder
  • Compile the COBOL programs
  • Generate the MFSs
  • Generate the DBD
  • Generate the PSB
  • Load the database

These operations are defined in the following sections.

  • Copying the IVP Files to a New Folder
  • Compiling the COBOL Programs
  • Generating the MFSs
  • Generating the DBD
  • Generating the PSB
  • Loading the Database
Parent topic: Before Running the IVP
Next topic: Updating the Resource Definition File


Copying the IVP Files to a New Folder

  1. From an application command prompt, create a new folder to hold your version of the IVP files.
  2. Navigate to the folder containing the IVP files. This is %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Net Express IDE\MTO-IMS\IVP by default.
  3. Copy the contents of the IVP folder to the folder you created at step 1.
Parent topic: Preparing the IVP
Related information
Specifying the Location of Required Files


Compiling the COBOL Programs

To compile the COBOL programs that comprise the Mfdemo application:

  1. At aNet Express command prompt, navigate to the folder containing Mfdemo's source files, which by default is %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x \Net Express IDE\MTO-IMS\IVP .
  2. Enter the following commands:
    cobol demo001b dialect(vsc24) noflag anim noobj charset(ascii) outdd"sysout 121 r e";
cobol cdlidemo dialect(mf) osvs cicsecm noflag charset(ascii) anim noobj;
cobol execdemo dialect(mf) cicsecm execdli noflag charset(ascii) anim noobj;
cobol demo001t dialect(vsc24) noflag charset(ascii) anim noobj;
cobol rghtjust dialect(mf) charset(ascii) anim noobj;

This creates an intermediate code (.int) and dictionary (.idy) file for each COBOL program.

Parent topic: Preparing the IVP


Generating the MFSs

Mfdemo includes three MFS files (demo90.mfs, demo91.mfs and demo92.mfs) that you need to generate. To generate theses MFSs:

  1. Enter the following commands:
    mfims mfsgen demo90.mfs nocls
mfims mfsgen demo91.mfs nocls
mfims mfsgen demo92.mfs nocls
Note:

Because you are generating all of the MFSs in the current folder you could have used the Windows for command to simplify this operation:

for %i in (*.mfs) do mfims mfsgen %i nocls

In addition to the .mid, .mod, .dif and .dof files, generating the MFSs produces imsconfg.dat and imsconfg.idx. These files contain system configuration data and must not be edited, moved or deleted.

Parent topic: Preparing the IVP


Generating the DBD

Mfdemo includes one DBD file (demo03dd.dbd) that you need to generate. To generate the DBD:

  1. Enter the following command:
    mfims dbdgen demo03dd.dbd nocls echo(enderr,0,50)

Creating the DBD gens produces the following files:

  • dbdgen2.dat
  • dbdgen2f.dat
Note:

If dbdgen2.dat does not exist when you generate a DBD you see message DBDUT0U35U ("File not found DBDGEN2.DAT"). This message is for information only, and dbdgen2.dat is created.

These files contain DBD source information that has been extracted and formatted into a smaller structure optimized for faster access during execution. These files are indexed files and can contain information for one or more generated DBD members. Do not edit, move or delete these files.

Parent topic: Preparing the IVP


Generating the PSB

Once you have generated the DBD you need to generate the PSB. To generate Mfdemo's single PSB file (demo001t.psb):

  1. Enter the following command:
    mfims psbgen demo001t.psb nocls echo(enderr,0,50)

Generating the PSB produces the following file:

  • psbgen3.dat
Note:

If psbgen3.dat does not exist when you generate a PSB you see message DBDUT0U35U ("File not found PSBGEN3.DAT"). This message is for information only, and psbgen3.dat is created.

These files contain PSB source information that has been extracted and formatted into a smaller structure optimized for faster access during execution. These files are indexed files and can contain one or more generated PSB members. Do not edit, move or delete these files.

Parent topic: Preparing the IVP


Loading the Database

Next you need to load the databases that Mfdemo uses.

  1. Enter the following command:
    mfims imsdbu load demo03dd nocls
Parent topic: Preparing the IVP


Updating the Resource Definition File

IMS support includes two new transactions, /CIC and /IMS, that you use to switch enterprise servers to CICS and IMS modes respectively. In order for these new transactions to be available you need to update your resource definition file using the caspcupg command as follows:

caspcupg

See the section Adding IMS-specific Resource Definitions in the chapter Configuring MSS-enabled Enterprise Servers for IMS in your Mainframe Subsystem Support Configuration and Administration Guide for more information on the caspcupg command.

Parent topic: Before Running the IVP
Previous topic: Preparing the IVP
Next topic: Configuring an Enterprise Server for the IVP
Related information
Adding IMS-specific Resource Definitions


Configuring an Enterprise Server for the IVP

To enable IMS support in an enterprise server, you need to:

  1. Create an IMS-enabled enterprise server.
  2. Enable IMS for the enterprise server.
  3. Specify the location of files produced by gens.
  4. Specify the system initialization table (SIT) to use.
  5. Define a message processing region.

The sections below walk you through these tasks.

  • Creating an MSS-enabled Enterprise Server
  • Enabling IMS for an Enterprise Server
  • Specifying the Location of Required Files
  • Specifying the SIT
  • Defining an Automatic Message Processing Region
  • Starting the Enterprise Server
  • Enabling JCL for an Enterprise Server
Parent topic: Before Running the IVP
Previous topic: Updating the Resource Definition File


Creating an MSS-enabled Enterprise Server

To create an MSS-enabled enterprise server:

  1. On the Home page of Enterprise Server Administration, click Add at the bottom of the table of servers.
  2. On the first Add Server page:
    1. Type IMSIVP in Server Name.
    2. Under Working Mode, click 32-bit.
    3. Click Next.
  3. On the second Add Server page:
    1. Click Micro Focus Enterprise Server with Mainframe Subsystem Support enabled.
    2. Click Next.
  4. On the third Add Server page:
    1. In the Creation Options group, check Create TN3270 listener; then specify a port number in using port.
    2. Type Server for IMS IVP in Description.
    3. Click Add.
  5. The Home page is redisplayed, and a row for the IMSIVP enterprise server is shown in the table of servers.
Parent topic: Configuring an Enterprise Server for the IVP


Enabling IMS for an Enterprise Server

To enable IMS support for the IMSIVP enterprise server:

  1. Click Edit next to the IMSIVP row in the table of servers.
  2. The Edit page that appears contains a hierarchy of tabs. Click the Server, Properties, MSS, IMS and General tabs.
  3. Ensure that Mainframe Subsystem Support enabled is checked, then check IMS enabled.

    This specifies that the IMSIVP enterprise server can use the IMS support. Don't click Apply yet as there is more to do on this page.

Parent topic: Configuring an Enterprise Server for the IVP


Specifying the Location of Required Files

You need to specify the directory where the files produced by DBDGENs, IMSGENs, MFSGENs and PSBGENs are created, and where the application and database files are located.

  1. In both the GEN file directory and Configuration directory fields, specify the name of the folder you created to hold generated files, and that contains your version of the Mfdemo application files (see Copying the IVP Files to a New Folder).
  2. Click Apply.
  3. Click the Server, Properties, MSS, IMS, TM and General tabs.
  4. In the MFS path field, specify the name of the folder you created to hold generated files, and that contains your version of the Mfdemo application files.
  5. Enter the same information in the Application Path and the Transaction definition file directory fields.
  6. Click Apply to save the change.
  7. Click the Server, Properties, MSS, IMS, and DB tabs.
  8. In the Database path field, specify the name of the folder you created to hold generated files, and that contains your version of the Mfdemo application files.
  9. Click Apply to save the change.
Parent topic: Configuring an Enterprise Server for the IVP
Related information
Copying the IVP Files to a New Folder


Specifying the SIT

You have now created the IMSIVP enterprise server and enabled it to use IMS and JCL, but you now need to specify that it uses a CICS SIT. You need to specify a SIT even though Mfdemo does not contain any CICS for two reasons:

  • You need a message processing region to start automatically whenever the IMSIVP enterprise server starts, and to do this you need to create a resource group and specify that resource group in a SIT's startup list. See the section Defining an Automatic Message Processing Region for more information.
  • You need to use the /IMS transaction that you added to the resource definition file in the section Updating the Resource Definition File.

To specify that the IMSIVP enterprise server uses the supplied SIT IMSSIT:

  1. Click the Server, Properties, MSS and CICS tabs.
  2. Specify IMSSIT in System Initialization Table. Leave the other fields blank as Mfdemo doesn't use CICS.
  3. Click Apply to save your change.
Parent topic: Configuring an Enterprise Server for the IVP
Related information
Defining an Automatic Message Processing Region
Updating the Resource Definition File


Defining an Automatic Message Processing Region

To run an IMS application in an enterprise server you need at least one specialized service execution process (SEP) called a message processing region (MPR). To specify that a message processing region starts each time an enterprise server starts you need to in a resource group that is specified by the startup list in the SIT used by the enterprise server.

  1. Click the Server, Properties, MSS, IMS, TM, and MPRs tabs.
  2. Click Add.
  3. In the Name field, type IMSMPR.
  4. In the Transaction Class field, type 001.
  5. Click Add.
  6. Click Home to return to the Home page of Enterprise Server Administration.
Parent topic: Configuring an Enterprise Server for the IVP


Starting the Enterprise Server

  1. In the table of servers on the Home page of Enterprise Server Administration, click Start in IMSIVP's Current Status column.
  2. On the confirmation page, click OK.
  3. You can confirm that MSS and IMS are enabled by watching the startup messages in the Console Daemon window. Messages should also appear indicating that the message processing region has started.
Parent topic: Configuring an Enterprise Server for the IVP


Running the IVP

To start the demonstration application:

  1. Start a TN3270 emulator, for example RUMBA.
  2. Specify the following connection information. Note that field names could vary depending on the 3270 emulator you are using.
    Field | Value
    Host name | The name of the computer the enterprise server is running on. This is localhost if it is the current machine.
    Port | The number you specified for the field using port in the section Creating an MSS-enabled Enterprise Server.
  3. Connect.
  4. Specify a user id and password, then press Enter. If you have not configured Enterprise Server security you can use the user SYSAD with password SYSAD.
  5. Press Clear (3270 key).
  6. Enter MFDEMO (with a trailing space).

The following sections describe the demonstration program and how you navigate through its screens.

  1. Mfdemo Screen Entries
Parent topic: Prepare the IMS Application and Enterprise Server
Parent topic: IMS Installation Verification
Related information
Creating an MSS-enabled Enterprise Server


Mfdemo Screen Entries

For the screens which follow, enter the characters which are shown in green.

Note:

Each table you add must have a unique table ID.

Figure 1. The "Add Testdept Table" Screen in Transaction MFDEMO
The "Add Testdept Table" Screen in Transaction MFDEMO

Press Enter when you have finished entering data on a screen.

On the screens that follow press Tab to move to the next field. Press Shift+Tab to move to the previous field.

Figure 2. The "Add Testdept Elements" Screen
The "Add Testdept Elements" Screen
Figure 3. The "Change Testdept Table" Screen
The "Change Testdept Table" Screen
Figure 4. The "Change Testdept Elements" Screen
The "Change Testdept Elements" Screen
Figure 5. The "Add Testers Table" Screen
The "Add Testers Table" Screen
Figure 6. The "Add Testers Elements" Screen
The "Add Testers Elements" Screen
Figure 7. The "End Transaction" Screen
The "End Transaction" Screen
Figure 8. The "MFDEMO - ENDED" Screen
The "MFDEMO - ENDED" Screen
Parent topic: Running the IVP


Create a Visual Studio Project

Because the service generated from this IMS Screen service interfaces tutorial is the only service that runs on the IMSIVP enterprise server you created earlier, it needs its own Visual Studio project. In the project, we must add the MFS maps needed to define the service interface and then access the deployed service.

Note: Before continuing, be sure you have completed all of the tasks presented in the IMS Installation Verification topic and its subtopics.
  1. From the SVITutorials Solution in the Solution Explorer, right-click the solution name; then click Add > New Project.
  2. In the Name field, type IMSScreenWS.
    Note: Because you are creating the project from with the SVITutorials solution, the default settings for Project types, Templates, and Location are correct.
  3. Click OK. The IMSScreenWS project now appears on the Solution Explorer.
  4. Right-click the IMSScreenWS project, and click Add > Existing Item.
  5. Browse to the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Tutorials\Service Interfaces\MFDemo folder.
  6. From the Objects of type drop-down list, click IMS files (.psb, .dbd, .mfs); then select the following files:
    • demo90.mfs
    • demo91.mfs
    • demo92.mfs
  7. Click Add.
  8. To save this project, click File > Save IMSScreenWS.
Parent topic: IMS Screen Tutorial
Previous topic: Prepare the IMS Application and Enterprise Server
Next topic: Associate the IMSIVP Enterprise Server
Related information
IMS Installation Verification


Associate the IMSIVP Enterprise Server

We now need to associate the IMSIVP enterprise server we created with our IMSScreenWS project.

  1. In Visual Studio from the Server Explorer, expand Localhost under Micro Focus Servers to see a list of available enterprise servers.
  2. Right-click the IMSIVP enterprise server; then click Associate with project > IMSScreenWS.
    Note: If IMSIVP does not appear on the list of enterprise servers, click Refresh Refresh.
Parent topic: IMS Screen Tutorial
Previous topic: Create a Visual Studio Project
Next topic: Create a Service Interface


Create a Service Interface

We are creating a Web Services type service interface that uses IMS screens.

  1. From the Solution Explorer, right-click the IMSScreenWS project; then click Add > New Item.
  2. Under Categories:, expand Native and click Mainframe Subsystem.
  3. Under Templates:, click Service Interface.
  4. In the Name field, type IMSScreenWS; then click OK.
  5. Select Web Service as your type of interface and IMS Screen as your type of source; then click OK.

At this point, Visual Studio adds the IMSScreenWS service interface to the Solution Explorer and invokes the Service Interfaces Editor.

Parent topic: IMS Screen Tutorial
Previous topic: Associate the IMSIVP Enterprise Server
Next topic: Define a Service Interface


Define a Service Interface

Each service interface you create is comprised of a set of operations. For an IMS Screen service interface, each operation addresses a screen encountered by the program. We will define a service interface that enables users to query a table in the database by providing the table ID.

The MFDEMO application is not conversational, meaning it does not maintain state, we could successfully deploy, run, and access our service without providing a way to terminate the application from a terminal. However, if this IMS application were a conversational application, we would need to add this functionality. To show how this is done, we'll also define the service interface to behave as if it were accessing a conversational application.

To accommodate these requirements, we will create the following operations:

  • Start Operation
  • Query Data Operation
  • Show Data Operation
  • Exit Gracefully Operation
  • Get Out Operation
Parent topic: IMS Screen Tutorial
Previous topic: Create a Service Interface
Next topic: Deploy a Service Interface


Start Operation

The purpose of the Start operation is to connect to our application by pressing the Enter key.

  1. From the Service Interfaces Editor, click Operation > New.
  2. In the Operation Name field, type Start.
  3. Leave the default values in the Active Screen and Previous Screen fields.
  4. In the Transaction ID field, type MFDEMO; then click OK.
  5. In the Assignments pane, right-click and select New Assignment from the popup menu.
  6. From the Assign to drop-down list, click ATTENTION ID. This is the field that defines which AID key (for example, Enter, PF8, etc.) should be used.
  7. From the Field 1/Operand 1 drop-down list, click ENTER.
  8. Click OK.
  9. Save the service interface.

    This completes the Start operation.

Parent topic: Define a Service Interface


Query Data Operation

The purpose of the Query Data operation is to send a query instruction to the application and to provide a return path to the application's main menu.

  1. Create the Query Data Operation
  2. Create an Assignment
  3. Create an Interface Field
  4. Create an ATTENTION ID
Parent topic: Define a Service Interface


Create the Query Data Operation

  1. Click Operation > New.
  2. In the Operation Name field, type Query Data.
  3. From the Active Screen drop-down list, click DEMO91. This is the screen name for the main menu of the MFDEMO application.
  4. From the Previous Screen drop-down list, click <None>. DEMO91 is the first screen we want to access.
  5. Leave Create Default Mapping unchecked. We will create appropriate mappings ourselves.
  6. Click OK. This returns you to the Service Interfaces Editor and shows the IMS Screen DEMO91 in the IMS Screen pane.
Parent topic: Query Data Operation
Next topic: Create an Assignment


Create an Assignment

As we learned from running this application in its original form, to query the database we need to provide the application with a function code of I (for Inquire). We do this by assigning a value of I to the appropriate field.

  1. On the IMS Screen pane, hover over the entry field located to the right of the FUNCTION CODE label. A popup indicates that the name of this field is FLD0003. We need to know the name of this field so we can create an assignment for it.
  2. In the Assignments pane, right-click; then click New Assignment.
  3. From the Assign to drop-down list, click FLD0003.
  4. In the Field 1/Operand 1 field, type an upper-case I, then click OK. The Assignments pane now shows that FLD0003 is set to a value of I.
Parent topic: Query Data Operation
Previous topic: Create the Query Data Operation
Next topic: Create an Interface Field


Create an Interface Field

We also need to provide our users with a field into which they can type the table ID for the table they want to query. We'll do this by creating an interface field based on the original input field on the DEMO91 screen.

  1. On the IMS Screen pane, locate the input field to the right of the TABLE-ID label.
  2. Click and drag this field to the Interface Field pane and drop it there.

    The name of this field, FLD0004, is not particularly descriptive. Because this field is really the input field for the table ID, we will rename it in the Service Interfaces Editor so that it is more recognizable. The name we use here will appear as the field label in our generated Windows Forms client.

  3. In the Interface Fields pane, double-click FLD0004.
  4. In the Name field, type TableID.

    The original FLD0004 field is defined as an input/output field, so by default the Service Interfaces Editor has created its service interface equivalent as an input field, which is what we want here. No further adjustments are necessary.

  5. Click OK.

    Notice that the Mappings pane shows the interface field with its new name, TableID, mapping to the COBOL field FLD0004.

Parent topic: Query Data Operation
Previous topic: Create an Assignment
Next topic: Create an ATTENTION ID


Create an ATTENTION ID

To complete the operation, we need to submit the value of the interface field using an ATTENTION ID for the Enter key:

  1. In the Assignments pane, right-click and select New Assignment from the popup menu.
  2. From the Assign to drop-down list, click ATTENTION ID.
  3. From the Field 1/Operand 1 drop-down list, click ENTER.
  4. Click OK.
  5. Save the service interface.

    This completes the Query Data operation.

Parent topic: Query Data Operation
Previous topic: Create an Interface Field


Show Data Operation

The Show Data operation returns and displays the data requested by the Query Data operation. Because this operation requires several definitions, we have broken it down into the following steps:

  1. Create the Show Data Operation
  2. Group Map Fields
  3. Create Interface Fields
  4. Create Mapping Conditions
  5. Create Assignments
Parent topic: Define a Service Interface


Create the Show Data Operation

Again, the first step is to create the operation.

  1. Click Operation > New.
  2. In the Operation Name field, type Show Data.
  3. From the Active Screen drop-down list, click DEMO92. This is the name of the details screen of the application.
  4. From the Previous Screen drop-down list, click DEMO91 to establish that the path to the active screen is through the DEMO91 screen, or you can simply leave this field blank since DEMO91 is the only possible path to the active screen.
  5. Leave the Transaction ID field blank. The transaction for this operation is a continuation of the transaction started by the Query Data operation.
  6. Leave Create Default Mapping unchecked.
  7. Click OK. The IMS Screen pane now shows the DEMO92 screen.
Parent topic: Show Data Operation
Next topic: Group Map Fields


Group Map Fields

The MFDEMO application displays information returned from the database on the DEMO92 screen in a series of three columns across. If we group these fields using the Map Annotation Editor, we can then refer to the grouped fields as arrays when we define our service operation.

  1. In the Service Interfaces Editor, IMS Screen pane, hover the mouse over the left-most field that appears in the first row, just below the FUNC label. A popup tells us that the name of this field is FLD0014.
  2. Now hover your mouse over the right-most field that appears in the last row, just above the NEXT-ELEMENT label. The popup tell us that the name of this field is FLD0055.
  3. From the Solution Explorer, right-click DEMO92.mfs; then click Edit Annotations for Services > Map DEMO92. This starts the Map Annotations Editor.
  4. Scroll down the list of fields until you find FLD0014, then click this field to select it.
  5. Continue scrolling down until you find FLD0055. Hold the Shift key down and click FLD0055 to select it and all of the fields listed between it and FLD0014.
  6. Move your mouse to the area of the window that is selected, then right-click and select Group from the popup menu.
  7. In the Number of fields to appear in the new group field, type 3.
  8. In the Group name prefix field, type RETURN. This prefix along with a generated group identifier (for example, GRP1) becomes a parent to the fields in the group.
  9. Click OK.

    On the DEMO92 window, you now see that the parent for the grouped fields is RETURN-GRPn, and that this group occurs 14 times as is shown in the Occurs column. The three fields listed below the parent each bear the name of the first field in each column that appears across the screen, appended by Grp.

  10. Save your changes and exit the Map Annotations Editor.

    The rendering of the DEMO92 screen in the Service Interfaces Editor is automatically updated with these changes to the map.

Parent topic: Show Data Operation
Previous topic: Create the Show Data Operation
Next topic: Create Interface Fields


Create Interface Fields

We now need to define interface fields to accommodate the returned data. We have already identified and grouped the fields we need on the DEMO92 screen, which simplifies this process a great deal.

  1. From the IMS Screen pane, click and drag the following fields to the Interface Fields pane and drop them there:
    • FLD0015Grp - located under the ELEMENT KEY heading
    • FLD0016Grp - located under the ELEMENT VALUE/DESCRIPTION heading

    Fields that originate as input/output fields are by default created as input fields in their Interface Field equivalents. Therefore, each of these fields is now defined as an input field. However, in this case, we want them to be output fields. We also want to rename each of the fields to something more meaningful. The names we assign here appear as field labels in our generated client.

  2. From the Interface Fields pane, double-click FLD0015Grp.
  3. In the Name field, type ElementKey to rename the field.
  4. Click Output to change the direction of the field.
  5. Click OK.
  6. Repeat steps 2 through 5 for the FLD0016Grp field, renaming it to ElementValue.

Now let's turn our attention to the Mapping pane. The Service Interfaces Editor has automatically generated mappings for these two fields. Notice that the Interface Fields column shows the fields with an asterisk appended to the end of each field name. The asterisk tells us that these fields each represent an array and that all occurrences of the field are included.

The COBOL Field column shows the field from the originating IMS screen that corresponds to the interface field we've created. Field names in this column are qualified by the group parent name we assigned when we grouped the fields in the Screen Editor, and also have an asterisk in parentheses appended to them. Again, this asterisk tells us that all fields on the originating screen are included.

The Map column shows us the direction that data travels. Here, because we have defined our interface fields as output fields, data moves from the COBOL fields to the interface fields as is represented by the left-pointing arrow.

Parent topic: Show Data Operation
Previous topic: Group Map Fields
Next topic: Create Mapping Conditions


Create Mapping Conditions

We need to create a condition for each of our interface fields that prevents them from receiving null values from the application.

  1. From the Mapping pane, right-click ElementKey(*), then click Apply Condition on the popup menu.
  2. In the New Name field, type KeyNotNull, then click Create.
  3. From the Field drop-down list, click RETURN-GRP1.FLD0015Grp(14).
  4. In the Field field, replace the 14 with an asterisk to represent all occurrences.
  5. From the Operator drop-down list, click >=.
  6. In the Field or Literal value field, type " " (double-quote followed by a space and another double-quote); then click OK to close the Condition Editor, and OK again to close the Apply Condition dialog box.

    This condition mandates that only data that has a value greater than or equal to a space can be moved from RETURN-GRP1.FLD0015Grp(*) to ElementKey(*). We need to apply a similar condition to the other mapping.

  7. From the Mapping pane, right-click ElementValue(*), then click Apply Condition on the popup menu.

    Because the condition we're creating here is so similar to the condition we created for ElementKey, we can use the condition we created for ElementKey as a starting point.

  8. From the Existing Condition drop-down list, click KeyNotNull.
  9. In the New Name field, type ValueNotNull, then click Create.
  10. From the Field drop-down list, click RETURN-GRP1.FLD0016Grp(14).
  11. In the Field field, replace the 14 with an asterisk to represent all occurrences.

    The rest of the condition definition is the same as for KeyNotNull and is already populated in the appropriate fields.

  12. Click OK to close the Condition Editor; then click OK to return to the Service Interfaces Editor.

    The Condition column in the Mappings pane now shows the conditions you defined.

  13. Save the service interface without exiting the Service Interfaces Editor.
Parent topic: Show Data Operation
Previous topic: Create Interface Fields
Next topic: Create Assignments


Create Assignments

To enable this service interface to terminate the application as if from a terminal, we must add assignment to the Show Data operation that return the application to the DEMO91 screen -- the main menu for our application. We do this by assigning the string value X to FLD0056 and also adding an ATTENTION ID assignment for the Enter key as follows:

  1. In the Assignments pane, right-click and select New Assignment from the popup menu.
  2. From the Assign to drop-down list, click FLD0056.
  3. In the Field 1/Operand 1 field, type X, which is the value that tells the application to return to the main menu screen.
  4. Click OK.
  5. In the Assignments pane, right-click and select New Assignment from the popup menu.
  6. From the Assign to drop-down list, click ATTENTION ID.
  7. From the Field 1/Operand 1 drop-down list, click ENTER.
  8. Click OK.
  9. Save the service interface.

    This completes the Show Data operation.

Parent topic: Show Data Operation
Previous topic: Create Mapping Conditions


Exit Gracefully Operation

In this operation, we supply the application with a value of E (for exit) for the main menu's FUNCTION CODE field (FLD0003).

  1. Click Operation > New.
  2. In the Operation Name field, type Exit Gracefully.
  3. From the Active Screen drop-down list, click DEMO91. This is the name of the details screen of the application.
  4. From the Previous Screen drop-down list, click DEMO92 to establish that the path to the active screen is through the DEM092 screen.
  5. Leave the Transaction ID field blank.
  6. Leave Create Default Mapping unchecked.
  7. Click OK. The IMS Screen pane now shows the DEMO91 screen.
  8. In the Assignments pane, right-click and select New Assignment from the popup menu.
  9. From the Assign to drop-down list, click FLD0003.
  10. In the Field 1/Operand 1 field, type E, which is the value that tells the application to exit.
  11. Click OK.
  12. In the Assignments pane, right-click and select New Assignment from the popup menu.
  13. From the Assign to drop-down list, click ATTENTION ID.
  14. From the Field 1/Operand 1 drop-down list, click ENTER.
  15. Click OK.
  16. Save the service interface.

    This completes the Exit Gracefully operation.

Parent topic: Define a Service Interface


Get Out Operation

Finally, we need an operation that simply terminates the service interface if, for some reason, the application screen for any operation does not match it's specified Active Screen. This operation is provided as a failsafe only.

  1. Click Operation > New.
  2. In the Operation Name field, type Get Out.
  3. From the Active Screen drop-down list, click ANY SCREEN.
  4. From the Previous Screen drop-down list, click ANY SCREEN.
  5. Leave the Transaction ID field blank.
  6. Leave Create Default Mapping unchecked.
  7. Click OK.
  8. Save the service interface.

    This completes the Get Out operation and the IMSScreenWS service interface definition.

  9. Close the Service Interfaces Editor.
Parent topic: Define a Service Interface


Deploy a Service Interface

To successfully deploy our Web services service interface, we must be sure that the IMSIVP enterprise server is started, and then run the deployment process to copy all of the appropriate service interface files to the deployment area, enabling the deployed service to run.

  1. On the Server Explorer, expand Micro Focus Servers > Localhost to show a list of available enterprise servers.
  2. Right-click IMSIVP; then click Start.

    Startup information shows in the Output window.

  3. If any enterprise servers other than IMSIVP show as being started, right-click each; then click Stop to stop them.
  4. From the Solution Explorer, right-click the IMSScreenWS service interface; then click Deploy.

    The Output window shows the progression of the deployment process. If deployment was successful, you should see a message indicating success.

Note: If deployment ever fails, a message appears in the output window indicating why it failed. Also, the failure message contains the path to the deployment log file. You can type the address into a browser and view the log file from there.
Parent topic: IMS Screen Tutorial
Previous topic: Define a Service Interface
Next topic: Generate Clients


Generate Clients

We will now generate Web Services clients to access the IMSScreenWS service that is now deployed to Enterprise Server.
Note: Be sure you have met all of the prerequisites for generating Windows Forms clients as specified in the topic Prerequisites.

The generation process for Web Services automatically produces a console client; however, we must set an option to enable generation of a Windows Forms client.

  1. From Visual Studio, click Tools > Options.
  2. Expand Projects and Solutions > COBOL Project Settings; then click Service Interfaces.
  3. Check Windows Forms Application; then click OK.
  4. From the Solution Explorer, right-click the IMSScreenWS service interface; then click Generate Clients.
You can watch the generation process in the Output window. When it is complete, you'll see the message "Generation of Windows Forms Application completed." You should see that two projects have been added to the Solution Explorer:
  • CICSScreenWSConsoleApp - the console client.
  • CICSScreenWSWinApp - the Windows Forms client.

Each new project contains the necessary client files to successfully access the IMSScreenWS service now running on the IMSIVP enterprise server.

Parent topic: IMS Screen Tutorial
Previous topic: Deploy a Service Interface
Next topic: Register the Proxy Library
Related information
Prerequisites


Register the Proxy Library

Depending on your Windows operating system version, you might be required to register the Proxy Library after after generating a Windows Forms client for the first time. If you received a message indicating that registration is necessary, follow these steps:

  1. Start aNet Express command prompt.
  2. Change to your IMSScreenWSWinApp project's \bin\release directory.
  3. Enter regsvr32 IMSScreenWSProxyWrapper.dll.
  4. Click OK to clear the RegSvr32 message.
Note: The full path to and name of the proxy library .dll file appears in the Output window during client generation. For example:

Register proxy library IMSScreenWSProxyWrapper.dll in "c:\myProjects\SVITutorials\IMSScreenWSWinApp\Bin\Release".

Parent topic: IMS Screen Tutorial
Previous topic: Generate Clients
Next topic: Run the Windows Forms Client


Run the Windows Forms Client

  1. From the Solution Explorer, right-click IMSScreenWSWinApp; then click Set as Startup Project.
  2. From the Visual Studio IDE, click Debug > Start without debugging.
  3. In the TableID field, type TESTERS, then click Submit. The client returns the data contained in the TESTERS table of your database.
  4. Click Exit.
Parent topic: IMS Screen Tutorial
Previous topic: Register the Proxy Library
Next topic: Build and Run the Console Client


Build and Run the Console Client

  1. From the Solution Explorer, right-click IMSScreenWSConsoleApp; then click Build.
  2. Again, right-click IMSScreenWSConsoleApp; then click Set as Startup Project.
  3. From the Visual Studio IDE, click Debug > Start without debugging.
  4. Enter TESTDEPT. The client returns the data contained in the TESTDEPT table of your database.
  5. Click Exit.
Parent topic: IMS Screen Tutorial
Previous topic: Run the Windows Forms Client


Native COBOL Tutorials

  • Tutorial: Developing a Simple COBOL Application
    This tutorial introduces the Visual Studio IDE, and shows how to create, build and debug a simple console application using supplied COBOL programs that use ACCEPT/DISPLAY statements.
Parent topic: Getting Started


Tutorial: Developing a Simple COBOL Application

This tutorial introduces the Visual Studio IDE, and shows how to create, build and debug a simple console application using supplied COBOL programs that use ACCEPT/DISPLAY statements.
  1. Starting Visual Studio
  2. Creating a Solution and a Project
  3. Add Files to the Project
  4. Build and Run the Project
  5. Project Properties
  6. Debug the COBOL Project
Parent topic: Native COBOL Tutorials


Starting Visual Studio

To run this tutorial, you must have both Microsoft Visual Studio and Studio Enterprise Edition installed.

To start Visual Studio:

  1. On the Start menu, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> Microsoft Visual Studio xxxx.
  2. You might be prompted to set the environment, depending on the version installed. If you are prompted, choose General development environment. In this setup Visual Studio is customized for work with COBOL projects.

The IDE is shown in the figure below, although the information displayed in the large pane will be different.

Visual Studio IDE

The large pane is where your solutions and projects will be opened. At the moment, this shows the Start Page, with up-to-date information on Visual Studio. When you start work, this pane is where your code is displayed.

The pane at the bottom is the Output window, where messages from the IDE and Compiler are displayed.

The right-hand pane is the Solution Explorer, which displays the structure of your solution and projects. At the bottom of the Solution Explorer pane are some tabs. Solution Explorer appears by default.

If any of these panes is hidden, you can show it from the View menu.

Parent topic: Tutorial: Developing a Simple COBOL Application
Next topic: Creating a Solution and a Project


Creating a Solution and a Project

The first task is to create a solution and a project. A solution is a container holding one or more projects that work together to create an application. The solution has the extension .sln, and is a readable text file. Microsoft recommends you do not edit the file outside of Visual Studio.

A COBOL project has the extension .cblproj, and again this is a readable file, but Microsoft recommends that you do not edit it. Different types of project have different extensions, so for example a C# project has the extension .csproj.

In this section, you create a project and solution, as follows:

  1. In Visual Studio, create a new project by clicking File > New > Project.
  2. In the Project Types pane, expand COBOL Projects and click Native.
  3. Select the Console Application template.
  4. In the Name field, specify Locking as the name of the project.

    Notice that the Name and Solution Name fields have the same name. Changing either one of them automatically changes the other.

  5. In the Location field, browse to a directory where you want to put this tutorial.

    For example, if you create a folder on your c: drive called tutorials, change the location field to c:\tutorials. The solution will be stored in a subdirectory Locking, according to the project name.

  6. Click OK.

This creates a solution and a project. The Solution Explorer shows the Locking project. It contains:

  • Program1.cbl, which is a newly created skeleton program. You can ignore this, because the tutorial uses existing COBOL files.
  • Properties, which displays the project's properties when you double-click it.
Parent topic: Tutorial: Developing a Simple COBOL Application
Previous topic: Starting Visual Studio
Next topic: Add Files to the Project


Add Files to the Project

You can add existing files to the project, as follows:

  1. Right-click the project in the Solution Explorer.
  2. Click Add>Existing Item.
  3. Browse to the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Tutorials\Locking.
  4. Select all .cbl files.
  5. Click Add.

Alternatively, you can add folders and source files to your project in Solution Explorer using drag and drop. You can drag files and folders from other projects in Solution Explorer or from outside Visual Studio from Windows Explorer. You can use drag and drop with the following keys:

  • Hold Ctrl to create copies of the files and folders in your project directory
  • Hold Shift to move the files and folders to your project directory
  • Hold Ctrl+Shift to link to files or folders in a different location without copying them
Parent topic: Tutorial: Developing a Simple COBOL Application
Previous topic: Creating a Solution and a Project
Next topic: Build and Run the Project


Build and Run the Project

There are two default build configurations for each project type: Debug and Release. These configurations define how to build the project for the different situations.

To build the project and run it:

  1. Check the build configuration in use, by clicking Build > Configuration Manager.
  2. In Active solution configuration, choose Debug and click Close.

    Notice in the Standard toolbar at the top of the IDE, that Debug shows as the active configuration.

  3. Build the project, by clicking Build > Build Solution.

    The Build option builds only those files that have changed since they were last built, whereas the Rebuild option builds all the files in the project, regardless of whether they have changed since they were last built.

  4. Check that the project compiled successfully by looking in the Output view. To display this view, click View > Output.
  5. Run the application, by clicking Debug > Start Without Debugging or [image].

    A console window opens, showing this character-based application running.

  6. Go to the console by clicking it. Then type 5 and press Enter.

    "5" is the code that tells this application to finish and the console closes.

Parent topic: Tutorial: Developing a Simple COBOL Application
Previous topic: Add Files to the Project
Next topic: Project Properties


Project Properties

Project properties define characteristics of the project and enable you to control a project's behavior among other things. Different properties are set by default for different types of projects.

  1. To see a summary of the project properties, select the project or solution in the Solution Explorer. By default, the Properties window is displayed below the Solution Explorer.

    If the Properties window is not visible, you can show it by clicking View (> Other Windows) > Properties Window.

    A description of the selected property is displayed dynamically at the bottom of the Properties window. To turn this description on and off, right-click in the description.

  2. To display the full project properties, right-click the project in Solution Explorer and click Properties.
  3. Go to the COBOL page of the properties, to display the selected properties for building the project. Notice that:
    • Configuration is set to Active (Debug)
    • Managed code is set to No, because the current application is being built as native COBOL
    • Generate debugging information is checked
    • COBOL dialect is set to non-mainframe
    • Output path shows where the build files will be put
  4. Go to the Debug page and notice that Start project is checked, so that the application starts debugging in the current project.
  5. Browse the other properties pages to see what is available and what is set by default for a console application.
Parent topic: Tutorial: Developing a Simple COBOL Application
Previous topic: Build and Run the Project
Next topic: Debug the COBOL Project


Debug the COBOL Project

The IDE provides debugging facilities, such as stepping, examining data item values and setting breakpoints. To see some of these facilities:

  1. Click Debug > Step Into, or Step Into button.

    A console opens for running the built programs.

    The source code for locking.cbl opens in the COBOL editor. The first statement DISPLAY SPACE is highlighted in yellow, with a yellow arrow pointing to it. This is the statement to be executed next.

  2. Execute the first statement, by clicking Debug > Step Into, Step Into button or pressing F11.
  3. Step the next statement, DISPLAY LOCKING01-00, in the same way.

    This statement displays some information about the application in the console.

  4. Execute the whole of the next PERFORM statement. To do this, click Debug > Step Over, Step Over button or pressing F10.

    Step Over executes all the code for a PERFORM or CALL statement in a single step.

  5. Continue stepping into the code, until you reach the ACCEPT statement accept choice at 2445.
  6. Step into the ACCEPT statement.

    The console now appears and waits for your input.

  7. Type 5, as before, and press Enter.

    Notice that the statement "EVALUATE CHOICE" is now highlighted ready for execution and that the value of the choice variable is now "5". You can see this by hovering over the choice variable in the Evaluate statement, and also by looking in the Autos pane at the bottom.

    If the Autos pane is not visible, open it by clicking Debug > Windows > Autos.

  8. To add the choice variable to the Watch list, right-click it and click Add Watch.

    This opens a separate pane, the Watch pane, which shows the values of watched variables.

  9. Continue stepping to the end.

You can close Visual Studio now. You do not need to explicitly save anything, because the files are automatically saved when you build them.

Parent topic: Tutorial: Developing a Simple COBOL Application
Previous topic: Project Properties


Managed COBOL Tutorials

  • Tutorial: Developing .NET Managed COBOL
    This tutorial introduces the Visual Studio IDE.
  • Tutorial: Creating Windows Forms in COBOL
  • Tutorial: Developing Web Application Projects
  • Tutorial: Creating Web Forms in COBOL
  • Tutorial: Creating and Accessing WCF COBOL Services
    Shows how to create and access WCF services in COBOL.
Parent topic: Getting Started


Tutorial: Developing .NET Managed COBOL

Overview

This tutorial introduces the Visual Studio IDE, and shows how to create a solution for a Windows application with a Windows form that says "Hello World".

Starting Visual Studio

To run this tutorial, you must have both Microsoft Visual Studio and Studio Enterprise Edition installed.

To start Visual Studio:

  1. On the Start menu, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> Microsoft Visual Studio xxxx.
  2. You might be prompted to set the environment, depending on the version installed. If you are prompted, choose General development environment. In this setup Visual Studio is customized for work with COBOL projects.

The IDE is shown in the figure below, although the information displayed in the large pane will be different.

Visual Studio IDE

The large pane is where your solutions and projects will be opened. At the moment, this shows the Start Page, with up-to-date information on Visual Studio. When you start work, this is the pane where your code is displayed.

The pane at the bottom is the Output window, where messages from the IDE and Compiler are displayed.

The right-hand pane is the Solution Explorer, which displays the structure of your solution and projects. At the bottom of the Solution Explorer pane are some tabs. Solution Explorer appears by default.

If any of these panes is hidden, you can show it from the View menu.

Creating a Solution and a Project

The first task is to create a solution and a project. A solution is a container holding one or more projects that work together to create an application. The solution has the extension .sln and is a readable text file. Microsoft recommends that you do not edit the file outside of Visual Studio.

A COBOL project has the extension .cblproj and again is human readable but Microsoft recommends that you do not edit it. Different types of project have different extensions, so for example a C# project has the extension .csproj.

In this section, you create a project and solution, as follows:

  1. Start Visual Studio.
  2. Create a new project by clicking File > New > Project.
  3. In the Project Types pane, expand COBOL Projects and click Managed.
  4. In the Templates pane, select Windows Forms Application.

    The drop-down list above the Templates pane allows you to change the version of the target framework. Select the framework your clients are using to ensure your application includes classes and methods supported by it. You can leave the default .NET Framework for this demonstration.

  5. In the Name field at the bottom of the window, specify WinHello as the name of the project.

    Notice that the Name and Solution Name fields have the same name. Changing the name of the project automatically changes the name of the solution.

  6. In the Location field, browse to a directory where you want to put this tutorial.

    For example, if you create a folder on your c: drive called "Tutorials," change the location field to c:\tutorials. The solution will be stored in a subdirectory WinHello, according to the project name.

  7. Click OK.

This creates a solution, a project and an empty form, which is opened in the form designer. The Solution Explorer pane shows the WinHello project, which contains:

  • Properties, which contains the full project properties, including the resources for the form and references to some system packages, such as System.Windows.Forms, which support the system classes that the project uses.
  • Form1.cbl, which contains your code for the form. Under the expanded Form1.cbl is Form1.Designer.cbl, which is created by the form designer. Don't edit this code, because this defines the form, and if you change it you might not be able to open the Design window. Also, any changes you make might be overwritten by the form designer.
  • Main.cbl, which contains the trigger program that displays the main form.

Painting a Button and a Label

This section "paints" a button and a label on the page or form.

  1. Paint a button as follows:
    • Click Toolbox or View > Toolbox.
    • If the Button object isn't listed, click Common Controls in the Toolbox.
    • Point to the Button object and drag it onto the page or form.
  2. Change the text on the button to "Say Hello", by editing the button's Text property, as follows:
    • Click on the button.
    • In the Appearance section of the Properties pane, scroll to the Text property.
      Note: Right-click the button in the designer, and then click Properties to display the Properties pane if it is not visible.
    • Edit the text to Say Hello and press Enter.

      Notice that the Name property of the button (in the Design section of the Properties pane) is, and remains, "button1."

  3. Paint a label somewhere on the form by dragging the Label object in the same manner as you did the Button object.
  4. Clear the default text in the label, by deleting the text in the Text property field and pressing Enter.

    The label essentially disappears upon this action, but remains on the form, as you will see when you build and run the application. Notice that the name property of the label control is, and remains, Label1 (or label1).

Adding a Click Event Handler

Now, you add an event handler to display "Hello World" when the button is clicked.

  1. Create a click event handler for the button by double-clicking the button.

    This generates a method called button1_Click in the code.

    Look at the code for the button1_Click method. It is just a skeleton and does nothing. The procedure division is empty. We will look at the rest of the code when we have run the application.

  2. In the procedure division of the button1_Click method, insert the following line:
    move "Hello World!" to self::"label1"::"Text"
  3. or you could equally write:
    set self::"label1"::"Text" to "Hello World!"

    This moves the text "Hello World" into the Text property of the label you painted.

Building and Running the COBOL Application

There are two default build configurations for each project type: Debug and Release. These configurations define how to build the project for the different situations.

To build the project for debugging and to run it:

The Build menu offers the choice of building and rebuilding the solution, as well as building and rebuilding our project. The Build option builds only those files that have changed since they were last built. Whereas the Rebuild option builds all the files in the project, regardless of whether they have changed since they were last built.

To build and run the project:

  1. Check the build configuration in use, by clicking Build > Configuration Manager.
  2. In Active solution configuration, ensure Debug is selected and click Close.

    Notice in the Standard toolbar at the top of the IDE, that Debug shows as the active configuration.

  3. Click Build > Build WinHello.
  4. Check that the project compiled successfully by looking in the Output pane. To display this pane, click View > Output .
  5. Run the application, by clicking Debug > Start Without Debugging or Run button.
  6. When the page or form displays, click the Say Hello button.

    The label should now say "Hello World!"

  7. Click the X at the top right to close the page or form.

Project References

When you create a project, the full project properties contain the references to assemblies containing classes that are used by the project, such as the System assembly and, for our Windows application, System.Windows.Forms. You can see this on the References page of the full project properties.

If you write code that uses other classes in other assemblies, you add the assemblies as references as follows:

  1. Right-click the WinHello project in Solution Explorer.
  2. Click Add Reference, or double-click the Properties folder in Solution Explorer and on the References tab, click Add.
  3. On the .NET tab in the Add Reference dialog box, you can select .NET Framework assemblies or other .NET assemblies. Scroll to MicroFocus to see the available Micro Focus assemblies.
  4. On the COM tab, you can select the COM objects that you have registered on your machine.
  5. On the Projects tab, you can select other assemblies that your .NET code refers to. There are currently none available to the project in this tutorial.
  6. Click OK when you have completed your selections.

For more information, see the Visual Studio Help.

Project Properties

Project properties define characteristics of the project and enable you to control a project's behavior, among other things.

Brief project properties are by default dynamically displayed in the Properties pane, below the Solution Explorer. Here are some tips on viewing brief project properties:

  • To see brief project properties, select the project or solution in the Solution Explorer. The Properties pane is displayed below the Solution Explorer, by default.
  • If the Properties pane is not visible, you can show it by clicking View (> Other Windows) > Properties Window.
  • A description of the selected property is displayed dynamically at the bottom of the Properties pane. To turn this description on and off, right-click in the toolbar of the Properties pane.

Full project properties are available by selecting the project in Solution Explorer and clicking Project > ProjName Properties. The full properties that you can specify for your native or managed project can apply to all configurations or only to the selected configuration, such as Debug or Release.

Assemblies

Each project is built into a code assembly.

Assemblies are documented in the Visual Studio Help, which describes them as "a collection of one or more files that are versioned and deployed as a unit. An assembly is the primary building block of a .NET Framework application. All managed types and resources are contained within an assembly and are marked either as accessible only within the assembly or as accessible from code in other assemblies.

Assemblies also play a key role in security. The code access security system uses information about the assembly to determine the set of permissions that code in the assembly is granted". For the basic concepts on assemblies see the Visual Studio Help.

Assemblies are created automatically when you build projects. You need to create a strong-named assembly if you want to include it in the Global Assembly Cache (GAC), which makes it secure and shareable among all the applications on your machine.

Examining the Generated Code

The form designer creates broadly-speaking two partial classes for the page or form. One partial class contains the generated code for your application, and you can edit and add to this. The other partial class is in the file Form1.Designer.cbl. It contains code owned by the designer, and you must not edit it.

The partial class containing the generated code contains, among other things:

  • A declaration of the class as a partial class such as the following for a Windows form:
       class-id. Form1 as "Hello.Form1" is partial
             inherits type "System.Windows.Forms.Form".
  • The object Working Storage section. This allocates storage for the controls for the form, or more precisely, for object references for the controls.
  • The New method, which invokes the InitializeComponent method in the designer-owned partial class.
  • The button1_Click method, which you edited to say "Hello World."

Examining the Event Handlers in the Design View

When you double-click a control in the Design view, a click event handler is created and a method is inserted in the generated code. You created the Button1_Click event handler in this way.

You can rename the event handler and add and delete others.

Note: You must do this in the Design view and not in your application code. If you do it in the code, it might get overwritten when the code is regenerated from the design.

To change the name of the event handler:

  1. Display the Design view. One way to do this is to select the page or form in Solution Explorer, and then click View > Designer or View Design .
  2. Select the Say Hello button.
  3. In the Properties pane, display the events, by clicking Events.

    (The events are found in the Action section of this pane.) You can scroll through the events to see what is available.

  4. Change the name of the click event handler to readButton1_Click then press Enter.
  5. Display the Code view and notice that our method at the end has changed name to readButton1_Click, and that our procedure division is still intact.

Similarly, if you double-click a control by mistake (say on the label control), you generate an unwanted event handler. You cannot simply delete this event handler in the code view, because some event handler code is also in the design. Instead you need to delete the event handler in the design view. Do this in much the same way as you edited the name of the event handler, but instead delete the name.

Changing the Startup Form

This section adds another form and uses this as the startup form.

Notice that the form you created was called Form1. This form is opened when you run the application. If you rename the form, you also need to change the name of the form that starts the application. Similarly, if you delete this form, you need to specify another form as the startup form.

To demonstrate this, add another form and use this as the startup form, as follows:

  1. Create a second form similar to the first, as follows:
    1. Right-click the project in Solution Explorer.
    2. Click Add > New item.
    3. Choose Windows Form and specify a name for the form, such as "HelloAgain."
    4. In the Add New Item dialog, click Managed under Installed Templates.
    5. Click Add.
    6. Paint the form however you wish and add an event handler. You could paint a form similar to the Hello World one, but with slightly different text, such as "Hello again."
  2. Set the main form to the new form, by editing the lines that define and create the main form in the program main.cbl, as follows:
    1. Double-click Main.cbl in Solution Explorer.
    2. In the local-storage section, change from:
      01 mainForm type "WinHello.Form1".

      to:

      01 mainForm type "WinHello.HelloAgain".
    3. In the procedure division, change from:
      set mainForm to new "WinHello.Form1"()

      to:

      set mainForm to new "WinHello.HelloAgain"()
  3. Build and run the application.

Debugging the COBOL Project

The IDE provides debugging facilities, such as stepping, examining data item values and setting breakpoints. To see some of these facilities:

  1. On the toolbar, click Debug > Step Into , or Step Into button.

    If you are prompted to rebuild the project configurations, click Yes.

    The IDE enters debug mode. You can see a yellow arrow at the left of the Editor window pointing to the first line to be executed.

  2. Click Debug > Continue (or the green Continue arrow on the toolbar).

Close the IDE window now. You do not need to explicitly save anything, because the files are automatically saved when you build them.

Parent topic: Managed COBOL Tutorials


Tutorial: Creating Windows Forms in COBOL

Overview

This tutorial shows how to create a Windows form and how to make this interact with an existing COBOL program. The form is generated in managed COBOL. The form calls an intermediary program to map .NET data types onto COBOL data types. The intermediary program then calls the existing COBOL program to perform the business logic.

The solution has three programs:

  • Windows form. The Microsoft form designer enables you to create a Windows form in any .NET language, such as C# and COBOL. This tutorial shows how to generate these forms in .NET COBOL.
  • Existing COBOL program, the Book program. This program simulates a pre-existing COBOL program, which contains the business logic and which remains unchanged. This program is supplied and this tutorial adds it to the solution so that it is recompiled as managed code and exposed as a class that can be called by .NET managed code without needing any changes to the source.
  • Intermediary COBOL class, the BookWrapper program. This program acts as an interface between the client form and the pre-existing COBOL program. This intermediary class interfaces with the .NET client form using objects, and it interfaces with the existing COBOL using the standard COBOL PIC X data types. This intermediary class is supplied and this tutorial adds it to the solution.

Start Painting the Form

In this section, you create a Windows form and then you paint the form. You can also examine the code generated.

  1. Create a managed Windows Forms project and choose or specify:
    • COBOL Managed Projects and Windows Forms Application
    • WinFormBook as the project name
    • Tutorials as the project location
    • WinBook as the solution name and check Create a directory for the solution
  2. Paint four labels, three text boxes and one button on the form.
  3. Edit the properties of the controls, being careful to not double-click any of the controls. Double-clicking creates an event for the control, which we don't want to do till the next step. Edit the properties to the following values:
    Control | Name Property | Text Property
    Label | label1 | Stock Number
    TextBox | textBoxStockNo (the case is significant) | (blank)
    Label | label2 | Title
    TextBox | textBoxTitle (the case is significant) | (blank)
    Label | label3 | Price
    Label | label4 (the case is significant) | (blank)
    TextBox | textBoxPrice (the case is significant) | (blank)
    Button | button1 (the case is significant) | Read

    To display the properties right-click the label and then click Properties. You can then scroll to the relevant property and edit it.

  4. Create a click event for the Read button. Do this by double-clicking the button, which creates an event called button1_Click , and then displays the code that is generated for the form.
  5. Notice that the code for the button1_Click method doesn't do anything yet; the procedure division is empty. You can scroll through and review the rest of the generated code.
  6. You can build the form, by clicking Build > Build WinFormBook . You should have no errors.

For more information on the generated code, see the tutorial Tutorial: Developing .NET Managed COBOL.

Handle the Click Events

Now you need to add the code for the button click, which needs to call the legacy COBOL program and to populate the form with the information returned.

  1. In code view, find the button1_Click method. Update the code so that it reads as follows:
           method-id.  "button1_Click" final private.
       local-storage section.
       01 input-string string.
       01 my-exception type "System.Exception".
       procedure division using by value sender as object e as type "System.EventArgs".
           set input-string to textBoxStockNo::"Text"
           try
               set my-book to type "BookWrapper.Book"::"Read"(input-string)
               invoke self::"PopulateForm"(my-book)
           catch my-exception
               invoke self::"DisplayException"(my-exception)
           end-try
       end method "button1_Click".
  2. Notice the red squigglies underlining some words. These indicate a syntax error from automatic parsing happening in the background. Hover over an underlined word and read the popup that gives information on the error. Notice that the status bar tells you the number of background parsing errors.
  3. Hover over the words error-message and display the popup, which says that it cannot find the PopulateForm method. Add the following methods to your code, after the button1_Click method and before the end object statement.
           method-id.  "PopulateForm" final private.
       procedure division using my-book as type "BookWrapper.Book".
           if my-book <> null
               set textBoxStockNo::"Text"      to my-book::"StockNumber"
               set textBoxTitle::"Text"        to my-book::"Title"
               set textBoxPrice::"Text"        to type "System.Convert"::"ToString"(my-book::"RetailPrice")
           else
               set textBoxStockNo::"Text"      to "****"
               set textBoxTitle::"Text"        to "*************************************"
               set textBoxPrice::"Text"        to "****"
           end-if
       end method "PopulateForm".
           method-id. "DisplayException" private.
       procedure division using by value ex as type "System.Exception".
           set label4::"Text" to ex::"Message"
           set my-book to null
           invoke self::"PopulateForm"(my-book)
       end method "DisplayException".

The remaining errors are all associated with my-book. We will clear when we have added the legacy code.

Add the Legacy Code and the Wrapper Code

You now need to add the existing COBOL code that contains the business logic, so that the form can use it. This code is supplied in a LegacyBook project containing book.cbl.

In addition, you need some wrapper code to convert the data from .NET types to COBOL types. The Windows form uses .NET data types; these are System.String objects in our case. The book program uses COBOL types such as PIC X and PIC 99V99. The supplied program BookWrapper.cbl does this conversion, and you need to add this to the solution.

The supplied files are in the Examples subfolder, with all the Visual Studio and .NET examples, and in the Visual Studio Integration\Forms subfolder of your installation directory, which by default is %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x.

To add book.cbl and BookWrapper.cbl:

  1. Copy the supplied LegacyBook and BookWrapper folders from the Forms folder into your tutorials directory.
  2. Add the BookWrapper project to the solution, as follows:
    1. Right-click the solution in the Solution Explorer.
    2. Click Add > Existing project.
    3. Browse to the BookWrapper folder, which is in the tutorials folder.
    4. Select the project file BookWrapper.cblproj and click Open.
  3. Now add the LegacyBook project in the same way.
  4. Add a reference to the BookWrapper project in the WinFormBook project. To do this:
    1. Right-click the WinFormBook project in the Solution Explorer.
    2. Click Add Reference.
    3. Go to the Projects tab.
    4. Select BookWrapper and click OK.
  5. Confirm that when the two supplied projects are built, their built .dll files are stored in the bin directory for the project WinFormBook. For the BookWrapper project and then the LegacyBook project:
    1. In Solution Explorer, double-click the Properties folder for each project.
    2. Click the COBOL tab in the properties.
    3. Confirm that the Output Path is ..\bin\. You might need to adjust this relative path if your BookWrapper or LegacyBook directories are not siblings to the WinFormBook directory. Alternatively you can specify absolute paths.

Provide Access to the Legacy Code

You now need to add some code to the form to call the wrapper code and to clear the last of the red squigglies to do with my-book.

  1. Declare the data item my-book in object working storage, as follows:
           01 my-book   type "BookWrapper.Book".

  2. You should now have no parsing errors, now that BookWrapper is declared. If you do have errors, check the supplied demonstration in Forms\ WinBook to see where yours differs.

  3. Set up an environment variable to point to the bookfile.* data files, which are supplied in BookData. To do this:
    1. Right-click the project WinFormBook and click Add > New Item.
    2. Select Application Configuration File in the templates pane.
    3. Click Add.

      This adds an App.config file to the WinFormBook project.

    4. In Solution Explorer, right-click App.config and choose Edit.
    5. Enter the following details on the Environment tab of the Application Settings dialog:
      • Enter dd_bookfile in the Name field, which is the prefix dd_ followed by the name of the data file as declared in the program book.cbl.
      • In the Value field, enter the path and filename for bookfile.dat. For example, enter:
        • A hardcoded path such as %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\BookData\bookfile.dat.
        • A path using an environment variable such as %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Forms\BookData\bookfile.dat.
    6. Click Set.
    7. Click OK.

Run the Application

You can now run the application.

  1. Build the project. Set the form project as the starting project.

    To do this right-click the WinFormBook project in the Solution Explorer and click Set as StartUp Project.

  2. Click Debug > Start without Debugging.
  3. Experiment entering information and using the Read button.

    You can read data for stock numbers 1111 and 2222.

Examine the Sample Code

The sample code is available in the Examples\Visual Studio Integration folder, with all the Visual Studio and .NET examples, and in the Forms subfolder.

Client Windows Form

The client Windows form Form1.cbl is generated as COBOL. The user enters data into the form and receives the return data there. The client form does the following:

  1. Extracts the input data from text boxes on the form as System.Strings.
  2. Calls BookWrapper passing it the string objects.
  3. Populates the text boxes on the form with the System.Strings.

Book Wrapper Program

The BookWrapper.cbl program acts as an intermediary between the pre-existing COBOL program book.cbl and the Windows form. This enables you to leave the pre-existing COBOL unchanged.

The important point here is that you need to use compatible types when mixing languages. The Windows form stores the data as .NET types and yet the Book program expects data as COBOL types.

The purpose of the BookWrapper program is to map your COBOL PICTUREs to .NET System.Strings. The program receives data from the Windows form as System.Strings, and maps them onto standard COBOL data types before passing them to the pre-existing book program.

The object working storage declares the data items in a book record by using a copybook, as follows:

 object.
        data division.
        working-storage section.
        copy "book-rec-dotnet.cpy" replacing == (prefix) == by == book ==.
    ...

The copybook book-rec-dotnet.cpy declares the book-details record. It declares book-title and book-stockno as COBOL pictures and also as properties so that Getter/Setter methods can be used to access them. The copybook contains:

    01 (prefix)-details.
        03 (prefix)-text-details.
            05 (prefix)-title  pic x(50) property as "Title".
        ...
        03 (prefix)-stockno pic x(4) property as "StockNumber".

The following get property method gets a pointer to the book-details record:

       method-id. get property "BookDetails".
       procedure division returning bookDetailsAddress as pointer.
           set bookDetailsAddress to address of book-details
           goback.
       end method.

The Read method is implemented in the static section as follows:

       method-id. "Read".
       local-storage section.
       01 file-status pic xx.
       procedure division using by value stockno-in as string
                          returning      myBook     as Book.

           set myBook to new  Book()
           set myBook::"StockNumber" to stockno-in

           call "BookLegacy" using by value readRecord
                                   by value myBook::"BookDetails"
                                   by reference file-status

           invoke "RaiseExceptionIfError" using file-status
           goback.
       end method "Read".

Where:

  • procedure division using ...

    shows a .NET System.String, stockno-in, being passed in from client form. It also shows an instance of the Book class being returned. BookWrapper.cbl defines a new .NET type, Book, which can be used by programs written in any .NET language.

  • set myBook to new Book()

    creates a new instance of the BookWrapper class.

  • set mybook::"StockNumber"

    takes the data from the .NET System.String (stockno-in) and stores it as the StockNumber property of myBook. This property is declared in the copybook as a picture string, and so the data is stored as a standard COBOL data type in book-stockno. The COBOL Compiler implicitly converts the data from the .NET string into a COBOL usage display item (pic x).

  • call "BookLegacy" using ...

    calls the legacy program, book.cbl. It passes it the “BookDetails” property of myBook. If you look at the code in BookWrapper.cbl, you can see that what BookDetails does is pass a pointer to the BookRecord structure defined in book-rec-net.cpy. This structure matches the structure in the old book-rec.cpy, so what the legacy Book program sees is a book record being passed in by reference – which is what it expects. Book reads the stock number from this record, reads a record from the indexed file, and then puts the data in the other fields of the record.

  • invoke "RaiseExceptionIfError" using file-status

    checks the file status returned from reading the file, and raises a .NET exception if there was an error. Exceptions are the standard .NET mechanism for signaling error conditions.

Legacy Book Program

The book.cbl program is a long-standing demonstration program that has been shipped with Micro Focus products for several years. It is written in procedural COBOL. The program reads and writes to an indexed file containing book records.

In this solution, the Book program is recompiled to managed code without any changes. Recompiling the program exposes it as a class and exposes its main entry point as a static method.

The program's Linkage section defines data as standard COBOL types, such as PIC X, which non-COBOL client programs will not understand. These types need to be mapped to .NET compatible types before communication with the client program. This mapping is done by the intermediary program BookWrapper.cbl.

Parent topic: Managed COBOL Tutorials
Related concepts
Windows Forms
To deploy a CICS service interface to the .NET environment


Tutorial: Developing Web Application Projects

Overview

This tutorial shows how to create a Web application project and how to make it interact with an existing COBOL program. The project includes a page that is generated in managed COBOL. The page calls an intermediary program to map .NET data types onto COBOL data types. The intermediary program then calls the existing COBOL program to perform the business logic.

The Web application project has three programs:

  • A Web page. The Microsoft form designer enables you to create a Web page (also known as a Web form) in any .NET language, such as C# and COBOL. This tutorial shows how to generate these forms in .NET COBOL.
  • Existing COBOL program, the Book program. This program simulates a pre-existing COBOL program, which contains the business logic and which remains unchanged. This program is supplied and this tutorial adds it as a reference to the Web application project so that it is recompiled as managed code and exposed as a class that can be called by .NET managed code without needing any changes to the source.
  • Intermediary COBOL class, the BookWrapper program. This program acts as an interface between the client form and the pre-existing COBOL program. This intermediary class interfaces with the .NET client form using objects, and it interfaces with the existing COBOL using the standard COBOL PIC X data types. This intermediary class is supplied and this tutorial adds it as a reference to the Web application project.

Create a Web Application Project

The first task is to create a Web Application Project, which you do as follows:

  1. Start Visual Studio.
  2. Create a new Web Application Project by clicking File > New > Project.
  3. Ensure is selected in the dropdown list above the installed templates pane.
  4. Select ASP.NET Web Application.
  5. Specify a name such as BookDemoWebApplication.
  6. Specify a location to store the project on your file system such as c:\tutorials.
  7. Uncheck Create Directory for Solution.
  8. Click OK.

This creates the BookDemoWebApplication project, which is shown in the Solution Explorer. The project includes:

  • App_Data, which is an empty folder for holding application data
  • Default.aspx, which is the trigger program that displays the main form
  • Default.aspx.cbl, which contains your code for the form
  • Web.config, which is the application configuration file

Add the Legacy Code and the Wrapper Code

You now need to add the existing COBOL code that contains the business logic, so that the form can use it. This code is supplied in a LegacyBook project containing book.cbl.

In addition, you need some wrapper code to convert the data from .NET types to COBOL types. The project uses .NET data types; these are System.String objects in our case. The book program uses COBOL types such as PIC X and PIC 99V99. The supplied program BookWrapper.cbl does this conversion, and you need to add this to the solution.

The supplied files are in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration and in the Forms subfolder. On older versions of Windows the samples might be installed in a different folder, such as for Windows XP, C:\Documents and Settings\All Users\Documents\Micro Focus\<product name>\Samples.

To include dependant code in your Web application project, you need to add a reference to the code in your solution as follows:

  1. Right-click the solution in Solution Explorer.
  2. Click Add > Existing Project.
  3. Navigate to the Forms\BookWrapper subfolder in the Samples directory.
  4. Select the .cblproj file and click Open.
  5. Similarly, add the LegacyBook project from the Forms\LegacyBook subfolder in the Samples.
  6. Add the two projects as references to the BookDemoWebApplication project as follows:
    • Right-click BookDemoWebApplication in Solution Explorer.
    • Click Add > Add Reference.
    • Go to the Projects tab.
    • Select BookWrapper and click OK.
    • Add LegacyBook to the project references in the same way.

Provide Access to the Legacy Code

You now need to add some code to the form to call the wrapper code and to clear the last of the red squigglies to do with my-book.

  1. Open Default.aspx.cbl in the editor and declare the data item my-book in the working storage section, as follows:
           01 my-book   type BookWrapper.Book.
  2. Rebuild the entire solution.

    You should have no parsing errors, now that BookWrapper is declared. If you do have errors, check the supplied demonstration in the Forms\BookDemoWebApplication subfolder of the Samples to see where yours differs.

  3. In Solution Explorer, right-click the Web.config file in the BookDemoWebApplication project and click Open to open the file in the editor.
  4. In the Web.config file, add the following configuration sections after the opening tag line that starts with <configuration>:
    <!--The following code declares a section group for application configuration -->
  <configSections>
    <sectionGroup name="MicroFocus.COBOL.Application">
      <section name="Switches" type="System.Configuration.NameValueSectionHandler" />
      <section name="Environment" type="System.Configuration.NameValueSectionHandler" />
    </sectionGroup>
    <sectionGroup name="MicroFocus.COBOL.Runtime">
      <section name="Tunables" type="System.Configuration.NameValueSectionHandler" />
      <section name="Switches" type="System.Configuration.NameValueSectionHandler" />
    </sectionGroup>
  </configSections>
  5. Set up an environment variable to point to the bookfile.* data files, which are supplied in the Samples\BookData directory. To do this:

    In the Web.config file, add the following text immediately after the </configSections> line:

    <appSettings />
<MicroFocus.COBOL.Application>
      <Switches/>
      <Environment>
         <add key="dd_bookfile" value="MyPath\bookfile.dat"/>
      </Environment>
   </MicroFocus.COBOL.Application>

    Where MyPath is the full path to the data file bookfile.dat, which is in the BookData subfolder in the Samples directory.

Start Painting the Form

In this section, you paint the form. You can also examine the code generated. For basic help on painting a form, see the tutorial Tutorial: Developing .NET Managed COBOL.

  1. Display the empty form by right-clicking Default.aspx in the Solution Explorer and clicking View Designer.
  2. Paint a number of labels, text boxes and a button as detailed in the table below.

    To lay out the Web form, use spaces and new lines, in the same way as you do in a text editor or in HTML.

  3. Edit the properties of the controls, being careful to not double-click any of the controls. Double-clicking creates an event for the control, which we don't want to do till the next step. Edit the properties to the following values:
    Control | ID Property | Text Property
    Label | label1 | CATALOG SEARCH
    Label | catalogueNumberLabel | Catalog Number
    TextBox | textBoxStockNo (the case is significant) | (blank)
    Button | searchButton | Search
    Label errorLabel File Status

    Also, set the Visible property to False.

    TextBox errorField (blank)

    Also, set the Visible property to False.

    Label | label2 | RESULTS
    Label | titleLabel | Title
    TextBox | textBoxTitle (the case is significant) | (blank)
    Label | authorLabel | Author
    TextBox | textBoxAuthor | (blank)
    Label | typeLabel | Type
    TextBox | textBoxType | (blank)
    Label | priceLabel | Price
    TextBox | textBoxPrice (the case is significant) | (blank)
    Label | soldLabel | Sold
    TextBox | textBoxSold | (blank)
    Label | onHandLabel | On Hand
    TextBox | textBoxOnhand | (blank)
    Label | stockValueLabel | Stock Value
    TextBox | textBoxStockValue | (blank)

    To display the properties right-click the label and then click Properties. You can then scroll to the relevant property and edit it.

  4. Create a click event for the Search button. Do this by double-clicking the button, which creates an event called searchButton, and then displays the code that is generated for the form.
  5. Notice that the code for the searchButton method doesn't do anything yet; the procedure division is empty. You can scroll through and review the rest of the generated code.
  6. You can build the solution, by selecting it in Solution Explorer and choosing Build > Build Solution. You should have no errors.

Handle the Click Events

Now you need to add the code for the button click, which needs to call the legacy COBOL program and to populate the form with the information returned.

  1. In code view, find the searchButton_Click method. Update the code so that it reads as follows:
           method-id searchButton_Click protected.
       working-storage section.
       01 aBook type BookWrapper.Book.
       01 anException type System.Exception.

       local-storage section.

       procedure division using by value lnkSender as object by value lnkEvent as type EventArgs.
       try
           set aBook to type BookWrapper.Book::Read(textBoxStockNo::Text)
           invoke self::PopulateForm(aBook)
       catch anException
           invoke self::DisplayException(anException)
       end-try

       end method.
  2. Notice the red squigglies underlining some words. These indicate a syntax error from automatic parsing happening in the background. Hover over an underlined word and read the popup that gives information on the error. Notice that the status bar tells you the number of background parsing errors.
  3. Notice that the above code invokes the PopulateForm and the DisplayException method. Add the following methods to your code, after the searchButton method and before the end class statement.
           method-id  PopulateForm final private.
       procedure division using aBook as type BookWrapper.Book.

           if aBook <> null
               set errorLabel::Visible to false
               set errorField::Visible to false
               set textBoxStockNo::Text    to aBook::StockNumber
               set textBoxTitle::Text      to aBook::Title
               set textBoxAuthor::Text     to aBook::Author
               set textBoxType::Text       to aBook::Type
               set textBoxPrice::Text      to type System.Convert::ToString(aBook::RetailPrice)
               set textBoxOnhand::Text     to type System.Convert::ToString(aBook::NumberOnHand)
               set textBoxSold::Text       to type System.Convert::ToString(aBook::NumberSold)
               set textBoxStockValue::Text to type System.Convert::ToString(aBook::StockValue)
           else
               set textBoxStockNo::Text    to "****"
               set textBoxTitle::Text      to "*************************************"
               set textBoxAuthor::Text     to "*************************************"
               set textBoxType::Text       to "****"
               set textBoxPrice::Text      to "****"
               set textBoxOnhand::Text     to "****"
               set textBoxSold::Text       to "****"
           end-if

       end method.
           method-id DisplayException private.
       procedure division using by value lnkException as type System.Exception.
           set my-book to null
           set errorLabel::Visible to true
           set errorField::Visible to true
           set errorField::Text to lnkException::Message
           invoke self::PopulateForm(my-book)
       end method.

Run the Application

You can now run the application.

  1. Right-click BookDemoWebApplication in Solution Explorer.
  2. Select Rebuild.
  3. Click Debug > Start Without Debugging.

    This starts the Web application in a new browser instance.

  4. Experiment entering information and using the Search button.

    You can search for data for catalog numbers 1111 and 2222.

Examine the Sample Code

The sample code is available in the Samples folder, with all the Visual Studio and .NET examples, and in the Forms subfolder.

Legacy Book Program

The book.cbl program is a long-standing demonstration program that has been shipped with Micro Focus products for several years. It is written in procedural COBOL. The program reads and writes to an indexed file containing book records.

In this solution, the Book program is recompiled to managed code without any changes. Recompiling the program exposes it as a class and exposes its main entry point as a static method.

The program's Linkage section defines data as standard COBOL types, such as PIC X, which non-COBOL client programs will not understand. These types need to be mapped to .NET compatible types before communication with the client program. This mapping is done by the intermediary program BookWrapper.cbl.

Client Web Form

The client Web form Default.aspx.cbl is generated as COBOL. The user enters data into the form and receives the return data there. The client form does the following:

  1. Extracts the input data from text boxes on the form as System.Strings.
  2. Calls BookWrapper passing it the string objects.
  3. Populates the text boxes on the form with the System.Strings.

Book Wrapper Program

The BookWrapper.cbl program acts as an intermediary between the pre-existing COBOL program book.cbl and the Web form. This enables you to leave the pre-existing COBOL unchanged.

The important point here is that you need to use compatible types when mixing languages. The Web form stores the data as .NET types and yet the Book program expects data as COBOL types.

The purpose of the BookWrapper program is to map your COBOL PICTUREs to .NET System.Strings. The program receives data from the Web form as System.Strings, and maps them onto standard COBOL data types before passing them to the pre-existing book program.

The object working storage declares the data items in a book record by using a copybook, as follows:

 object.
        data division.
        working-storage section.
        copy "book-rec-dotnet.cpy" replacing == (prefix) == by == book ==.
    ...

The copybook book-rec-dotnet.cpy declares the book-details record. It declares book-title and book-stockno as COBOL pictures and also as properties so that Getter/Setter methods can be used to access them. The copybook contains:

    01 (prefix)-details.
        03 (prefix)-text-details.
            05 (prefix)-title  pic x(50) property as "Title".
        ...
        03 (prefix)-stockno pic x(4) property as "StockNumber".

The following get property method gets a pointer to the book-details record:

       method-id. get property "BookDetails".
       procedure division returning bookDetailsAddress as pointer.
           set bookDetailsAddress to address of book-details
           goback.
       end method.

The Read method is implemented in the static section as follows:

       method-id. "Read".
       local-storage section.
       01 file-status pic xx.
       procedure division using by value stockno-in as string
                          returning      myBook     as Book.

           set myBook to new  Book()
           set myBook::"StockNumber" to stockno-in

           call "BookLegacy" using by value readRecord
                                   by value myBook::"BookDetails"
                                   by reference file-status

           invoke "RaiseExceptionIfError" using file-status
           goback.
       end method "Read".

Where:

  • procedure division using ...

    shows a .NET System.String, stockno-in, being passed in from client form. It also shows an instance of the Book class being returned. BookWrapper.cbl defines a new .NET type, Book, which can be used by programs written in any .NET language.

  • set myBook to new Book()

    creates a new instance of the BookWrapper class.

  • set mybook::"StockNumber"

    takes the data from the .NET System.String (stockno-in) and stores it as the StockNumber property of myBook. This property is declared in the copybook as a picture string, and so the data is stored as a standard COBOL data type in book-stockno. The COBOL Compiler implicitly converts the data from the .NET string into a COBOL usage display item (pic x).

  • call "BookLegacy" using ...

    calls the legacy program, book.cbl. It passes it the “BookDetails” property of myBook. If you look at the code in BookWrapper.cbl, you can see that what BookDetails does is pass a pointer to the BookRecord structure defined in book-rec-net.cpy. This structure matches the structure in the old book-rec.cpy, so what the legacy Book program sees is a book record being passed in by reference – which is what it expects. Book reads the stock number from this record, reads a record from the indexed file, and then puts the data in the other fields of the record.

  • invoke "RaiseExceptionIfError" using file-status

    checks the file status returned from reading the file, and raises a .NET exception if there was an error. Exceptions are the standard .NET mechanism for signaling error conditions.

Parent topic: Managed COBOL Tutorials
Related concepts
Web Application Projects


Tutorial: Creating Web Forms in COBOL

Overview

This tutorial shows how to create a Web page and how to make this interact with an existing COBOL program. The page is generated in managed COBOL. The page calls an intermediary program to map .NET data types onto COBOL data types. The intermediary program then calls the existing COBOL program to perform the business logic.

The Web Site has three programs:

  • Web page. The Microsoft form designer enables you to create a Web page (also known as a Web form) in any .NET language, such as C# and COBOL. This tutorial shows how to generate these forms in .NET COBOL.
  • Existing COBOL program, the Book program. This program simulates a pre-existing COBOL program, which contains the business logic and which remains unchanged. This program is supplied and this tutorial adds it to the Web Site so that it is recompiled as managed code and exposed as a class that can be called by .NET managed code without needing any changes to the source.
  • Intermediary COBOL class, the BookWrapper program. This program acts as an interface between the client form and the pre-existing COBOL program. This intermediary class interfaces with the .NET client form using objects, and it interfaces with the existing COBOL using the standard COBOL PIC X data types. This intermediary class is supplied and this tutorial adds it to the Web Site.

Create a Web Site

The first task is to create a Web Site, which you do as follows:

  1. Start Visual Studio.
  2. Create a new Web Site by clicking File > New > Web Site.
  3. In the Language field, select COBOL.
  4. Select ASP.NET Web Site.
  5. In the Location field, select File System and browse to a directory where you want to put this tutorial, and specify the directory WebBook.
  6. Click OK.

This creates the WebBook Web Site, which is then displayed in the Solution Explorer. The Web Site contains:

  • App_Data, which is an empty folder for holding application data
  • Default.aspx, which is the trigger program that displays the main form
  • Default.aspx.cbl, which contains your code for the form
  • Web.config, which is the application configuration file

A Web Site appears in the solution explorer in a similar way to a project, but a Web Site is not a project. It is a directory, which enables you to publish the Web Site simply. For full details see the Visual Studio Help, such as the topic .NET Development\Web Applications. This tutorial shows some of the other differences, which include:

  • A Web Site does not have extensive project properties, but has Web configuration settings in the Web.config file. You use the Web.config file to specify the location of copybooks, copypath, which is added to the directives file or to the COBCPY environment variable.
  • To include dependant code in your Web Site, you add a reference to the code in the usual way, but the code appears in a Bin folder in your Web Site, rather than as a reference in your solution.
  • You can add Web pages of any language to the Web Site, because it is not a project and is therefore language independent.

Start Painting the Form

In this section, you paint the form. You can also examine the code generated. For basic help on painting a form, see the tutorial Tutorial: Developing .NET Managed COBOL.

  1. Display the empty form by right-clicking Default.aspx in the Solution Explorer and clicking View Designer.
  2. Paint four labels, three text boxes and one button on the form.

    To lay out the Web form, use spaces and new lines, in the same way as you do in a text editor or in HTML.

  3. Edit the properties of the controls, being careful to not double-click any of the controls. Double-clicking creates an event for the control, which we don't want to do till the next step. Edit the properties to the following values:
    Control | ID Property | Text Property
    Label | label1 | Stock Number
    TextBox | textBoxStockNo (the case is significant) | (blank)
    Label | label2 | Title
    TextBox | textBoxTitle (the case is significant) | (blank)
    Label | label3 | Price
    Label | label4 (the case is significant) | (blank)
    TextBox | textBoxPrice (the case is significant) | (blank)
    Button | button1 (the case is significant) | Search

    To display the properties right-click the label and then click Properties. You can then scroll to the relevant property and edit it.

  4. Create a click event for the Search button. Do this by double-clicking the button, which creates an event called button1_Click , and then displays the code that is generated for the form.
  5. Notice that the code for the button1_Click method doesn't do anything yet; the procedure division is empty. You can scroll through and review the rest of the generated code.
  6. You can build the form, by clicking Default.aspx in Solution Explorer and choosing Build > Build Page. You should have no errors.

Handle the Click Events

Now you need to add the code for the button click, which needs to call the legacy COBOL program and to populate the form with the information returned.

  1. In code view, find the button1_Click method. Update the code so that it reads as follows:
           method-id.  "button1_Click" protected.
       local-storage section.
       01 input-string string.
       01 my-exception type "System.Exception".
       procedure division using by value lnkSender as object lnkEvent as type "System.EventArgs".
           set input-string to textBoxStockNo::"Text"
           try
               set my-book to type "BookWrapper.Book"::"Read"(input-string)
               invoke self::"PopulateForm"(my-book)
           catch my-exception
               invoke self::"DisplayException"(my-exception)
           end-try
       end method "button1_Click".
  2. Notice the red squigglies underlining some words. These indicate a syntax error from automatic parsing happening in the background. Hover over an underlined word and read the popup that gives information on the error. Notice that the status bar tells you the number of background parsing errors.
  3. Notice that the above code invokes the PopulateForm and the DisplayException method. Add the following methods to your code, after the button1_Click method and before the end object statement.
           method-id.  "PopulateForm" final private.
       procedure division using my-book as type "BookWrapper.Book".
           if my-book<>null
               set textBoxStockNo::"Text"      to my-book::"StockNumber"
               set textBoxTitle::"Text"        to my-book::"Title"
               set textBoxPrice::"Text"        to type "System.Convert"::"ToString"(my-book::"RetailPrice")
           else
               set textBoxStockNo::"Text"      to "****"
               set textBoxTitle::"Text"        to "*************************************"
               set textBoxPrice::"Text"        to "****"
           end-if
       end method "PopulateForm".
           method-id. "DisplayException" private.
       procedure division using by value lnkException as type "System.Exception".
           set label4::"Text" to lnkException::"Message"
           set my-book to null
           invoke self::"PopulateForm"(my-book)
       end method "DisplayException".

Add the Legacy Code and the Wrapper Code

You now need to add the existing COBOL code that contains the business logic, so that the form can use it. This code is supplied in a LegacyBook project containing book.cbl.

In addition, you need some wrapper code to convert the data from .NET types to COBOL types. The Web page uses .NET data types; these are System.String objects in our case. The book program uses COBOL types such as PIC X and PIC 99V99. The supplied program BookWrapper.cbl does this conversion, and you need to add this to the solution.

  1. Create a bin directory for the WebBook Web Site. To do this, right-click the Web Site in the Solution Explorer and click Add ASP.NET Folder > Bin.
  2. Add the prebuilt files for the supplied LegacyBook and BookWrapper programs. To do this, right click Bin in the Solution Explorer, click Add Existing Item and browse to Visual Studio Integration\Forms\WebBook\bin folder within the examples folder, where the built files are supplied. Select the .dll files, and also the .pdb files in case you want to debug the application. The programs are now part of the Web Site.

Provide Access to the Legacy Code

You now need to add some code to the form to call the wrapper code and to clear the last of the red squigglies to do with my-book.

  1. Declare the data item my-book in object working storage, as follows:
           01 my-book   type "BookWrapper.Book".

  2. You should now have no parsing errors, now that BookWrapper is declared. If you do have errors, check the supplied demonstration in Forms\WebBook to see where yours differs.

  3. In the Web.config file, add the following configuration sections after the opening tag line that starts with <configuration>:
    <!--The following code declares a section group for application configuration -->
  <configSections>
  <sectionGroup name="MicroFocus.COBOL.Application">
    <section name="Switches" type="System.Configuration.NameValueSectionHandler" />
    <section name="Environment" type="System.Configuration.NameValueSectionHandler" />
  </sectionGroup>
  <!--The following code declares a section group for run-time configuration -->
  <sectionGroup name="MicroFocus.COBOL.Runtime">
    <section name="Tunables" type="System.Configuration.NameValueSectionHandler" />
    <section name="Switches" type="System.Configuration.NameValueSectionHandler" />
  </sectionGroup>
</configSections>
  4. Set up an environment variable to point to the bookfile.* data files, which are supplied in WinBook. To do this:

    In the Web.config file, add the following text immediately after the <App_settings/> line:

    <MicroFocus.COBOL.Application>
      <Switches/>
      <Environment>
         <add key="dd_bookfile" value="MyPath\bookfile.dat"/>
      </Environment>
   </MicroFocus.COBOL.Application>

    Where MyPath is the path to the data file bookfile.dat, which is in the bin subfolder of the WinBook sample. See the \Forms\WinBook\bin subfolder in the examples.

Run the Application

You can now run the application.

  1. Build the Web Site.
  2. Click Debug > Start without Debugging.
  3. Experiment entering information and using the Search button.

    You can search for data for stock numbers 1111 and 2222.

Examine the Sample Code

The sample code is available in the Examples\Visual Studio Integration folder, with all the Visual Studio and .NET examples, and in the Forms subfolder.

Legacy Book Program

The book.cbl program is a long-standing demonstration program that has been shipped with Micro Focus products for several years. It is written in procedural COBOL. The program reads and writes to an indexed file containing book records.

In this solution, the Book program is recompiled to managed code without any changes. Recompiling the program exposes it as a class and exposes its main entry point as a static method.

The program's Linkage section defines data as standard COBOL types, such as PIC X, which non-COBOL client programs will not understand. These types need to be mapped to .NET compatible types before communication with the client program. This mapping is done by the intermediary program BookWrapper.cbl.

Client Web Form

The client Web form Default.aspx.cbl is generated as COBOL. The user enters data into the form and receives the return data there. The client form does the following:

  1. Extracts the input data from text boxes on the form as System.Strings.
  2. Calls BookWrapper passing it the string objects.
  3. Populates the text boxes on the form with the System.Strings.

Book Wrapper Program

The BookWrapper.cbl program acts as an intermediary between the pre-existing COBOL program book.cbl and the Web form. This enables you to leave the pre-existing COBOL unchanged.

The important point here is that you need to use compatible types when mixing languages. The Web form stores the data as .NET types and yet the Book program expects data as COBOL types.

The purpose of the BookWrapper program is to map your COBOL PICTUREs to .NET System.Strings. The program receives data from the Web form as System.Strings, and maps them onto standard COBOL data types before passing them to the pre-existing book program.

The object working storage declares the data items in a book record by using a copybook, as follows:

 object.
        data division.
        working-storage section.
        copy "book-rec-dotnet.cpy" replacing == (prefix) == by == book ==.
    ...

The copybook book-rec-dotnet.cpy declares the book-details record. It declares book-title and book-stockno as COBOL pictures and also as properties so that Getter/Setter methods can be used to access them. The copybook contains:

    01 (prefix)-details.
        03 (prefix)-text-details.
            05 (prefix)-title  pic x(50) property as "Title".
        ...
        03 (prefix)-stockno pic x(4) property as "StockNumber".

The following get property method gets a pointer to the book-details record:

       method-id. get property "BookDetails".
       procedure division returning bookDetailsAddress as pointer.
           set bookDetailsAddress to address of book-details
           goback.
       end method.

The Read method is implemented in the static section as follows:

       method-id. "Read".
       local-storage section.
       01 file-status pic xx.
       procedure division using by value stockno-in as string
                          returning      myBook     as Book.

           set myBook to new  Book()
           set myBook::"StockNumber" to stockno-in

           call "BookLegacy" using by value readRecord
                                   by value myBook::"BookDetails"
                                   by reference file-status

           invoke "RaiseExceptionIfError" using file-status
           goback.
       end method "Read".

Where:

  • procedure division using ...

    shows a .NET System.String, stockno-in, being passed in from client form. It also shows an instance of the Book class being returned. BookWrapper.cbl defines a new .NET type, Book, which can be used by programs written in any .NET language.

  • set myBook to new Book()

    creates a new instance of the BookWrapper class.

  • set mybook::"StockNumber"

    takes the data from the .NET System.String (stockno-in) and stores it as the StockNumber property of myBook. This property is declared in the copybook as a picture string, and so the data is stored as a standard COBOL data type in book-stockno. The COBOL Compiler implicitly converts the data from the .NET string into a COBOL usage display item (pic x).

  • call "BookLegacy" using ...

    calls the legacy program, book.cbl. It passes it the “BookDetails” property of myBook. If you look at the code in BookWrapper.cbl, you can see that what BookDetails does is pass a pointer to the BookRecord structure defined in book-rec-net.cpy. This structure matches the structure in the old book-rec.cpy, so what the legacy Book program sees is a book record being passed in by reference – which is what it expects. Book reads the stock number from this record, reads a record from the indexed file, and then puts the data in the other fields of the record.

  • invoke "RaiseExceptionIfError" using file-status

    checks the file status returned from reading the file, and raises a .NET exception if there was an error. Exceptions are the standard .NET mechanism for signaling error conditions.

Parent topic: Managed COBOL Tutorials
Related concepts
Web Forms


Tutorial: Creating and Accessing WCF COBOL Services

Shows how to create and access WCF services in COBOL.

Overview and Demonstration Applications

The tutorial is based on the BookWrapper demonstrations supplied with this COBOL development system. The BookWrapper is an intermediary program which maps .NET data types onto COBOL data types. It then calls the existing COBOL program, book.cbl, to perform the business logic.

In this tutorial you expose the functionality of the BookWrapper program as a WCF service and use a console application as a client to communicate with it.

A more sophisticated version of the demonstration shown here is supplied in the Studio Enterprise Edition samples. To check the code, start Samples Browser and open the WCF Book Service and Client demonstration in the Windows Communication Foundation category.

Prerequisites

  • You need a complete version of Microsoft's Visual Studio as the Visual Studio Shell does not support WCF.

As a prerequisite step for this tutorial, you need to build the BookWrapper and LegacyBook projects that are part of the WinBook sample. To do this:

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition > Samples to start the Samples Browser.
  2. Click Windows Forms in the left pane and then Win Book.
  3. Click Open sample in Visual Studio.
  4. In Solution Explorer, right-click WinBook solution and choose Build Solution.

The build creates two binaries, BookWrapper.dll and LegacyBook.dll, in the bin subfolder of the WinBook solution.

Outline

In order to create and configure a WCF service and then use a client to access it, you need to:

  1. Create the WCF service.
  2. Define a service contract.
  3. Implement the service.
  4. Host and test the service.
  5. Create and configure a COBOL client application.
  6. Run the client and access the service.

Create a WCF Service Project

To start you need to create a solution to hold your WCF service and the client application:

  1. Click File > New > Project.
  2. Select WCF Service Library.
  3. Specify a name such as WCFBook.
  4. Specify a location for your project and click OK.

Add the BookWrapper and the LegacyBook Demonstrations to the Solution

You need to add the program that includes the functionality to expose as a service to your solution. To do this:

  1. In Solution Explorer, right-click your solution and select Add > Existing Project.
  2. Navigate to the Forms\BookWrapper subfolder in the Studio Enterprise Edition samples.
  3. Select BookWrapper.cblproj and click .
  4. In a similar way, add the LegacyBook demonstration which is installed in the Forms\LegacyBook subfolder in the samples to your solution.

Add the BookWrapper and the LegacyBook projects as references in the WCFBook Project

To enable your service to access the functionality in the BookWrapper and the LegacyBook projects, you must add them as project references to the WCFBook project:

  1. In Solution Explorer, right-click the References folder in your WCFBook project.
  2. Select Add Reference.

Define the WCF Service Contract and Create the Service

  1. Rename the COBOL files in the WCFBook project as follows:
    • Service1.cbl to BookService.cbl
    • IService1.cbl to IBook.cbl
  2. Paste the code below in the IBook.cbl file. This defines the service and data contracts.
    • The methods that are marked with the System.ServiceModel.OperationContract() attribute define the operations from the BookWrapper program that are exposed through the service endpoints.
    • The WCFBookWrapper.Book class that is marked with the DataContract attribute exposes the data from the BookWrapper program.
           interface-id WCFBook.IBook
                     attribute System.ServiceModel.ServiceContract().

       method-id GetData public
           attribute System.ServiceModel.OperationContract().
       procedure division using by value the-value as binary-long
                          returning return-value as string.
       end method.

       method-id GetDataUsingDataContract public
           attribute System.ServiceModel.OperationContract().
       procedure division using by value stockNumber as string
                          returning return-value as type WCFBookWrapper.Book.

       end method.

       method-id Read public attribute System.ServiceModel.OperationContract().
       procedure division using by value stockNumber as string returning theBook as type WCFBookWrapper.Book.
       end method.

       end interface.

       class-id WCFBookWrapper.Book attribute DataContract().

       working-storage section.
       01 BookTitle string property as "Title" attribute DataMember().
       01 BookType string property as "Type" attribute DataMember().
       01 BookAuthor string property as "Author" attribute DataMember().
       01 BookStockno string property as "StockNumber" attribute DataMember().
       01 BookRetail decimal property as "RetailPrice" attribute DataMember().
       01 BookOnhand binary-long property as "NumberOnHand" attribute DataMember().
       01 BookSold binary-long property as "NumberSold" attribute DataMember().
       01 StockValue float-short property as "StockValue" attribute DataMember().

       method-id New.
       working-storage section.
       01 newBook type WCFBookWrapper.Book.
       procedure division using by value stdbook as type BookWrapper.Book.
           set BookTitle to stdbook::Title
           set BookType to stdbook::Type
           set BookAuthor to stdbook::Author
           set BookStockno to stdbook::StockNumber
           set BookRetail to stdbook::RetailPrice
           set BookOnhand to stdbook::NumberOnHand
           set BookSold to stdbook::NumberSold
           set StockValue to stdbook::StockValue
           goback.
       end method.

       end class.
  3. Paste the code below into the BookService.cbl file. This is the actual WCF service.
           class-id WCFBook.Service1
                 implements type WCFBook.IBook.

       working-storage section.

       method-id GetData public.
       procedure division using by value the-value as binary-long
                          returning return-value as string.
           set return-value to string::Format("You entered {0}" the-value)
           goback.
       end method.

       method-id GetDataUsingDataContract public.
       working-storage section.
       01 book type BookWrapper.Book.
       01 bookException type BookWrapper.BookException.
       procedure division using by value stockNumber as string
                          returning theBook as type WCFBookWrapper.Book.

           try
               set book to type BookWrapper.Book::Read(stockNumber)
               set theBook to new WCFBookWrapper.Book(book)
           catch bookException
               raise new System.ServiceModel.FaultException(bookException::Message)
           end-try
           goback.
       end method.

       method-id Read public.
       working-storage section.
       01 book type BookWrapper.Book.
       01 bookException type BookWrapper.BookException.
       procedure division using by value stockNumber as string returning theBook
as type WCFBookWrapper.Book.
           try
               set book to type BookWrapper.Book::Read(stockNumber)
               set theBook to new WCFBookWrapper.Book(book)
           catch bookException
               raise new System.ServiceModel.FaultException(bookException::Message)
           end-try
           goback.
       end method.

       end class.

Provide Access to the Legacy Code

Additionally, you need to configure your WCF the service to call the BookWrapper code as follows:

  1. Right-click the App.config file in your WCF service project and select .
  2. Add the code below immediately after the opening <configuration> tag:
      <configSections>
    <!--The following code declares a section group for application configuration -->
    <sectionGroup name="MicroFocus.COBOL.Application">
      <section name="Switches" type="System.Configuration.NameValueSectionHandler" />
      <section name="Environment" type="System.Configuration.NameValueSectionHandler" />
    </sectionGroup>
    <!--The following code declares a section group for run-time configuration -->
    <sectionGroup name="MicroFocus.COBOL.Runtime">
      <section name="Tunables" type="System.Configuration.NameValueSectionHandler" />
      <section name="Switches" type="System.Configuration.NameValueSectionHandler" />
    </sectionGroup>
  </configSections>
  <MicroFocus.COBOL.Application>
    <Switches />
    <Environment>
      <add key="dd_bookfile" value="%Public%\Documents\Micro Focus\Product Name\Samples\BookData\bookfile.dat" />
    </Environment>
  </MicroFocus.COBOL.Application>
  3. Save and close the App.config file.
  4. Build the WCFBook project.

Configure the service endpoints

You need to configure the service endpoint details as follows:

  1. Right-click the App.config file in your WCF service project select Edit WCF Configuration.
  2. In the Microsoft Service Configuration Editor, expand WCFBook.Service1.
  3. Click Host.

    Note that the default base address of the service is localhost - Visual Studio hosts the service on your machine.

  4. Expand Endpoints and click on the first item in the group.

    This displays the general details of the endpoint - the address of the service, its binding and the service contract you want to expose - all known as the ABC of the endpoint. You need to configure the endpoint to use the IBook contract you defined earlier.

  5. On the General tab, click [image] on the row for Contract.
  6. Navigate to the \bin\Debug subfolder in the WCFBook project directory.
  7. Double-click the WCFBook.dll file.
  8. Select the WCFBook.IBook contract and click Open.
  9. Click the second item under Endpoints.

    This is the default endpoint that exposes metadata details about your service through the IMetaData Exchange contract.

  10. Click File > Save in the Configuration Editor and close the window.

Start and Test the Service

Visual Studio provides a built-in WCF Service Host application and a WCF Test Client application to help you test your service without your own client application. This is enabled by default on the WCF Options tab in the project properties.

  1. In Solution Explorer, right-click the WCFBook project and select Set as StartUp Project.
  2. Click Debug > Start Without Debugging.

    Visual Studio hosts your service in the WCF Service Host and loads it in the WCF Test Client application. The test client displays the endpoint for your service and the operations that are exposed.

  3. Double-click the GetDataUsingDataContract() operation.

    This displays the operation details and enables you to test the operation with various parameters.

  4. In the Request pane, change the value for stockNumber from null to 1111 and press Enter.
  5. Click Invoke.

    This displays the details about record 1111 in the BookWrapper application in the Response pane.

  6. Test the Read operation with other stock numbers. The valid numbers are 1111, 2222 and 3333.
  7. Close the WCF Test Client application.

Create a WCF Client Application

In the real world, you use various client applications to access services through their available endpoints. As part of this tutorial, you will create a simple managed console application that accesses the BookWrapper application through the WCF service contract and reads the records that it contains:

  1. In Solution Explorer, right-click the solution and select Add > New Project.
  2. Select the managed Console Application template.
  3. Specify a name such as WCFClient and click OK.

Add the WCF Service as a Service Reference to the Client

Visual Studio provides an easy way to use a WCF service in a client application. The Add Service Reference functionality adds the service to the client project and generates a proxy for the client to use.

  1. Start the WCF Service.
  2. Right-click the project for the client and choose Add Service Reference.
  3. Click Discover in the Add Service Reference dialog to locate the WCF service.
  4. In the Namespace field, rename the namespace for the service to WCFBook.
  5. Click OK.

Edit the Client Application

You need to program your WCF client so that it uses the exposed operations of the WCF service reference. In this tutorial, the client uses the Read operation to access the information in the BookWrapper application and displays the record for a specified stock number.

  1. Edit Program1.cbl in the project for the client application.
  2. Replace the code in the COBOL program with the following:
           program-id. Program1 as "WCFClient.Program1".

       data division.
       working-storage section.
       01 stock-no              string.
       01 bookClient            type WCFBook.BookClient.
       01 myBook                type WCFBook.Book.

       procedure division.

       invoke type System.Console::WriteLine("Enter a stock number and press Enter.")

       set stock-no to type System.Console::ReadLine()
       set bookClient to new WCFBook.BookClient
       set myBook to bookClient::Read(stock-no)

       invoke type System.Console::WriteLine(myBook::Title)
       invoke type System.Console::WriteLine(myBook::Type)
       invoke type System.Console::WriteLine(myBook::Author)
       invoke type System.Console::WriteLine(myBook::StockNumber)
       invoke type System.Console::WriteLine(myBook::RetailPrice)
       invoke type System.Console::WriteLine(myBook::NumberOnHand)
       invoke type System.Console::WriteLine(myBook::NumberSold)
       invoke type System.Console::WriteLine(myBook::StockValue)

       invoke type System.Console::WriteLine("Press Enter to exit.")
       invoke type System.Console::ReadLine()

                  goback.

       end program Program1.
  3. Click File > Save.

Configure the Client Endpoints

You need to configure the client so that it uses the WCF service endpoint and the service contract:

  1. Right-click the app.config file in the WCFClient project.
  2. Click Edit WCF Configuration.
  3. In the Configuration pane, expand Client and then Endpoints.
  4. Click WCHttpBinding_IBook.
  5. In the Client Endpoint pane and on the General tab, click [image] on the row for the Contract.
  6. Navigate to the \bin\Debug subfolder in the directory of the WCFService project.
  7. Double-click WCFBook.dll.
  8. Select the WCFBook.IBook contract and click Open.
  9. In the Microsoft Service Configuration Editor window, click File > Save.
  10. Close the configuration editor.

Use the Client to Access the Service

  1. Set the WCFClient project as the StartUp project for the entire solution.
  2. Click Debug > Start Debugging.

    This hosts the service in the WCF Service Host and starts the client.

  3. In the console, enter a valid stock number and press Enter.

    The record for that stock number is displayed.

Parent topic: Managed COBOL Tutorials
Related concepts
WCF and COBOL


Procedural COBOL Compared with Managed COBOL

Procedural COBOL is regular COBOL without any of the new syntax that has been added for .NET and JVM. This is the COBOL that will have been used to write Net Express, Server Express and Mainframe Express applications, and it is still actively supported today.

You can compile to native or (in most cases) managed code. The core COBOL syntax is supported in managed code. However, there are some features that are not supported (for example Panels V2, Dialog System and ACUCOBOL-GT). This means that you can take most existing COBOL applications and recompile to create managed applications.

Managed COBOL

Managed COBOL is the collective term for .NET COBOL and JVM COBOL.

Managed COBOL is COBOL with extensions to support the .NET and JVM frameworks. It offers OO syntax support and syntax to allow access to the available class libraries.

When you compile managed COBOL the compiler generates managed code: .il for the .NET framework.

Managed Code and Native Code

You can compile your COBOL program to managed code using the ilgen compiler directive. From within the IDE this happens automatically if you are using a managed COBOL project.

The compiler has now created an intermediate language (.il).

COBOL and all other .NET languages (for example C# and VB) compile to this format, which makes mixed language applications easy to write.

You can also create native code applications. In Visual Studio there are native COBOL project templates.

The compiler generates .exe/.dlls as the result of a native compilation.

The native COBOL application has to call the appropriate management services available for the operating system, whereas a managed application can take advantage of the management services provided by the run time such as exception handling, garbage collection, and thread management.

Run Time

The intermediate language (.il files) can be deployed to a Windows platform running Microsoft's Common Language Runtime (CLR) for execution.

All programs written for the .NET Framework are executed by the Microsoft's Common Language Runtime (CLR) which makes mixed language application programming seamless.

The CLR's just-in-time (JIT) compiler compiles the .il into code native to the operating system. The CLR provides additional services including memory management, exception handling, garbage collection and thread management.

Developing Native and Managed Applications

You use the IDE to develop, compile and debug both native and managed applications. You can write new COBOL code or you can recompile existing COBOL applications to managed or native code, potentially without any code changes.

You can deploy and further debug the application under the run-time system provided by Server Enterprise Edition.

.NET COBOL applications are deployed to Windows platforms running Microsoft's CLR.

Parent topic: Getting Started


Help on Help

The latest up-to-date Help is available on the Micro Focus Infocenter on the Web, at http://documentation.microfocus.com. Alternatively, you can display the Help locally from the Help menu in the IDE, or from the Start menu.

Help in the Infocenter

Tips on using the Infocenter Help:

  • You can specify the scope of Help to search, by creating your own search lists. To do this, click Search scope and follow the wizard instructions.
  • The Help topic being displayed can get out of step with the contents, such as when you choose the topic from a search or when you link to it from another topic. To show where the topic appears in the contents, click Show in Table of Contents on the toolbar.
  • You can navigate the Help using the following keystrokes:
    Alt+left arrow/Alt+right arrow | Go back/forward.
    Alt+C | Move to the Contents tab.
    Alt+K | Move to the topic content frame.
    Alt+R | Move to the Search Results tab.
    Alt+S | Move to the search entry field.
    Ctrl+Tab or Ctrl+F6 depending on your browser | Go to the next frame or toolbar.
    Left arrow/Right arrow | Collapse/Expand a tree node or move left/right between tabs depending on the keyboard focus.
    Shift+Ctrl+Tab or Shift+Ctrl+F6 depending on your browser | Move to the previous frame or toolbar.

COBOL Help within the IDE

Tips on getting Help on COBOL when using the IDE:

  • COBOL syntax, library routines and Compiler directives. In the COBOL editor, put the cursor anywhere within the reserved word, routine or directive, and then press F1.
  • Error messages. In the output pane, put the cursor on the error message number and press F1.
  • Tooltips. Hover over an item in the COBOL code or over a field or control, by leaving the mouse pointer on it for a moment. A brief description of it may be displayed, either beside it or at the bottom of the window.

Help in Microsoft Visual Studio

The Microsoft Help on using Visual Studio is comprehensive and detailed and includes many samples as well as extensive reference material and more. If you are new to Visual Studio, we recommend that you explore the Microsoft Help and follow the tours and introductory material there.

Tips on using Help in Visual Studio Help format:

  • The locally installed Help has not been updated since the first release of Studio Enterprise Edition 6.0.
  • You can choose to display only the Micro Focus Help, or to display it integrated with the Visual Studio Help, by choosing the appropriate option from the Start menu.
  • You can choose whether to search the local or the online Help. To do this, click Tools > Options > Help > Online and choose the option you require.
  • You can filter the Help to show just a subset in Contents and Index. For example, you can choose Micro Focus Studio Enterprise Edition from the Filtered by: drop-down list on the Contents tab. It is quick to change filters, whenever you need a different subset of the Help.
  • You can filter Help searches to search just the COBOLHelp. To do this, select COBOL from the Language drop-down list on the Search tab.
  • The Help topic being displayed can get out of step with the Contents, such as when you choose the topic from the Index or when you link to it from another topic. To show where the topic appears in the Contents, click Sync with Table of Contents [image] on the toolbar.
  • For full details of the Help system, see the Microsoft Help.

HTML Help in the Net Express IDE

The Help for Net Express is available from the Help menu in Net Express and also from the Start menu from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Compatibility Tools> Net Express Help. This Help has not been updated since the first release of Studio Enterprise Edition 6.0.

Tips on using HTML Help within the IDE:

  • If you look up information using the index, you don't necessarily know where the topic you find belongs in the hierarchy of information. For example, is the topic part of the deploying Help or is it to do with preparing an application for deployment? You can find out where an indexed topic belongs, by clicking the Contents tab.
  • The contents on the left usually points to the topic you are reading on the right. Sometimes, if you follow a series of links in the Help, the contents gets out of step and points to the wrong topic. To bring the contents back in step, click Locate at the top.
  • You can display or hide the contents and index, by clicking Show or Hide at the top.
  • In the contents, book-style information has book icons, whereas topic-based information has folder icons.
Parent topic: Welcome


Developing COBOL Applications

This COBOL system enables you to develop native and managed COBOL applications, including applications that have been migrated from the mainframe and that use mainframe technologies like CICS, JCL and IMS. You use the Microsoft Visual Studio Integrated Development Environment to develop, compile as either native (unmanaged) or managed code, and debug your applications. You can then deploy and further debug the application under the Micro Focus COBOL run-time system.

  • Using Visual Studio for COBOL Development
  • Creating COBOL Solutions and Projects
  • Building COBOL Applications
    To build an application, you need to compile its programs and link them to a run-time system. You use a build configuration to define how to do this.
  • Debugging Native COBOL Programs
  • Running Native COBOL Applications
  • Running Mainframe Applications on Enterprise Server
  • Test Coverage for Native COBOL
  • Deploying COBOL Applications
Parent topic: Micro Focus Studio Enterprise Edition 6.0


Using Visual Studio for COBOL Development

This COBOL Development system is integrated into Microsoft Visual Studio. You use the Microsoft Visual Studio Integrated Development Environment to develop, build and debug COBOL applications, as either native COBOL or .NET managed COBOL.

  • Introduction to COBOL Development in Visual Studio
  • Tips and Tricks with the IDE
  • Differences between Studio Enterprise Edition and Earlier Micro Focus Products
    COBOL applications developed and built using previous Micro Focus IDEs, such as Net Express or Server Express, can now be developed and built with Studio Enterprise Edition. However there are some differences in behavior and in terminology, which are described here.
Parent topic: Developing COBOL Applications


Introduction to COBOL Development in Visual Studio

Studio Enterprise Edition enables you to develop native COBOL applications as well as .NET managed code applications.

You use the Microsoft Visual Studio IDE to develop, build and debug your applications. You can then deploy and further debug the application under the run-time system provided by Server Enterprise Edition.

You use the Visual Studio integrated development environment (IDE) to develop, build and debug COBOL applications, whether they are built as native or managed COBOL. The IDE provides all the functionality to manage projects and debug applications. It includes:

  • Templates for creating COBOL projects such as Windows applications and console applications, and also your own COBOL project types
  • Colorization of the COBOL language when editing and debugging
  • Background parsing of COBOL
  • Information provided when hovering over COBOL variables
  • Debugging that is sensitive to COBOL and includes all the usual features such as stepping, watch windows and breakpoints
  • Querying 64-bit execution environments

For native COBOL, programs compile to .exe or .dll and they execute under the Server Enterprise Edition.

.NET COBOL compiles to Microsoft Intermediate Language (MSIL), and they execute in conjunction with the CLR, just like programs in other .NET languages, such as C#. Applications written in .NET COBOL need the Server Enterprise Edition as it enables them to run in the .NET environment.

Both new and existing COBOL can be compiled as .NET managed code. This enables you to:

  • Reuse existing COBOL business logic and data access across the .NET environment
  • Access .NET Framework classes and features from COBOL applications including Windows Forms and Web Forms
  • Create and extend composite applications consisting of COBOL, C#, VB.NET, C++ and ASP.NET
  • Reuse and extend Open ESQL applications

Both procedural and OO COBOL are supported within the .NET. OO COBOL classes can inherit classes written in other Microsoft .NET languages and vice versa.

The COBOL syntax includes a number of extensions to support .NET features. For example, the TRY ... CATCH syntax is now included to enable exception handling in COBOL.

There are some programming techniques, COBOL syntax and functionality that are applicable to unmanaged COBOL only and not to .NET managed COBOL.

Parent topic: Using Visual Studio for COBOL Development
Related concepts
Using OpenESQL with ADO.NET
OpenESQL Assistant
Managed Code Concepts
Managed COBOL Restrictions


Tips and Tricks with the IDE

  • Editing COBOL
  • Building COBOL
  • Debugging COBOL
  • IntelliSense and COBOL
  • Code Snippets
Parent topic: Using Visual Studio for COBOL Development


Editing COBOL

Here are some tips on editing COBOL code in the Visual Studio IDE:

Bookmark Window
Shows the bookmarks added to source code in your solution. Choose View > Bookmark Window to display the window.
Bookmarks
To add a bookmark, position the cursor on a line in the code and choose Edit > Bookmarks > Toggle Bookmark. View > Bookmark Window.
Background Syntax Checking
The COBOL code is checked in the background, as you type it. Any errors are underlined with wavy red lines. You can turn this setting off or on the Miscellaneous page in Tools > Options > Text Editor > COBOL. Generally, we recommend that you leave Background Syntax Checking turned on. You might consider turning it off only when editing exceptionally large files.
Class View Window
Shows an outline of the classes used in your solution and their members. To display the window choose View > Class View. This applies to managed projects only.
COBOL Reserved Words
To configure the case of the COBOL reserved words used in the code snippets for COBOL choose Tools > Options > Text Editor > COBOL > Miscellaneous and set the case in the Case Format for Reserved Words field.
Code Definition Window
If you position the cursor on an object in the source code, the Code Definition Window automatically displays the section of the code implementing the objects referenced on that line. To display the window choose View > Code Definition Window.
Code Snippets
Insert the code constructs for elements of the .NET COBOL language, for example for classes, methods, delegates. To insert a snippet choose Edit > IntelliSense > Insert Snippet, or right-click in the editor and select Insert Snippet, or type the shortcut for the particular snippet (for example, class-id, method-id) and press Tab. This inserts an outline of the syntax for you to fill in. Available in managed code only.
To configure the case in which the code snippets are displayed choose Tools > Options > Text Editor > COBOL > Miscellaneous and set the case in the Case Format for Identifiers field.
Comments
Start end-of-line comments in the code using *>. For fixed or variable source format of code, enter * in column 7 to comment out an entire line.
Errors Window
Shows the errors, warning and messages created when editing or compiling. Double-click on an item in the errors list to position the cursor on the line of code that causes the error. You can get help on the error by pointing to the relevant error number and pressing F1.
Go To Definition (F12)
Pointing to a variable in the editor and pressing F12 positions the cursor on the definition of that variable.
Performing Go To Definition on a copybook name opens the copybook in the editor.
IntelliSense
Displays lists of the namespaces, types, members and parameters that are available when you type an object name followed by a space, dot, double colon or an opening bracket. The IntelliSense information is updated as you type.
Navigation Bar
The navigation bar at the top of the COBOL editor displays lists of the objects and procedures used in the current program and enables you to position the cursor on any of them. This is available for managed code only.
Outlining
Enables you to hide portions of the code. Choose Edit > Outlining > Toggle Outlining Expansion.
References
Enable you to add references to .NET assemblies, COM objects, projects and files. To add a reference choose Project > projectProperties, open the References tab and click Add > Reference or Add > Web Reference. This applies to managed projects only.
Syntax Colorizing
Colorizes the members of the COBOL language, for example data items, statements, comments, level 78 words, in different colors. To configure the colors for the COBOL language, choose Tools > Options > Environment and click Fonts and Colors. The items related to COBOL are prefixed with "COBOL".
Syntax Help
In the editor, point to a COBOL reserved word and press F1 to display the syntax Help for that word.
XML Documentation Comments
Insert XML documentation comments immediately before all your classes and methods to provide a description of what they do. Start each line of the documentation comment with *>>. When you type code IntelliSense shows the classes and methods you can use, the definitions are displayed as tool-tips for your classes and methods.
Parent topic: Tips and Tricks with the IDE


Building COBOL

Here are some tips on handling projects and building COBOL applications in the Visual Studio IDE:

Add Files to the Project
Right-click the project in Solution Explorer. Choose Add > New Item to create a new file from the supported types in the project directory. To add an existing file, choose Add > Existing Item and browse to the location of the file to select it. This adds a link in the project to the file but does not copy it in the project directory.
Application Configuration File
Includes the environment variables and COBOL programmable switches used by your native COBOL application at run time. Right-click the project in Solution Explorer and choose Add > New Item > Application Configuration File. To edit the file, right-click it in Solution Explorer and choose Edit. This applies to native projects only.
Assembly / Output name
Choose Project > projectProperties and go to the Application tab. Specify the name of the target file to build and the name of the output assembly in the Assembly name/Output name field.
Build Configuration and Settings
The Visual Studio standard toolbar shows the active build configuration for your project, for example Debug or Release. You can specify settings for a particular configuration on the COBOL tab in your project properties. To create new build configurations or edit the existing ones, choose Build > Configuration Manager.
COBOL Settings
Use this to set the dialect, the source format and directives for the whole project. Choose Project > projectProperties and select the COBOL tab.
Compile Single File
In Solution Explorer, right-click the file you want to compile and click Compile. This works for native code only.
Compiler Directives

You can use directives to control the way the Compiler behaves: what output it produces, what code is compiled and how the compiled code behaves when it runs. To set directives, choose Project > projectProperties and select the COBOL tab. Click in the Additional Directives field and type the directives, separated with a space.

Copybook Paths
The locations in which the project searches for copybook files. To add copybook paths to the project, choose Project > projectProperties and select the Copybook paths tab.
Entry Point/Startup Object
Defines the method entry of the application. Choose Project > myProject Properties and select the Application tab. Specify an entry point for your project in the Entry point/Startup object field.
Errors Window
Shows the errors, warning and messages created during edit or compile. Double-click on an error to position the cursor on the line of code that causes the error. You can get Help on the error if you point to the error number in the list and press F1.
Link and Run-Time Environment Settings
Go to the COBOL tab in your project properties and click Link Settings. This is available only for native code.
Output window
Displays the status messages for the executed commands at build time. Display it from View > Output.
Stop a Build
Choose Build > Cancel.
Resource Definition Script File
Enables you to add non-executable binary data such as icons, version info, to your executable files. Create the resource script file (.rc) outside of Visual Studio and to add it to your project right-click the project in Solution Explorer and choose Add > Existing Item. This applies to native projects only.
Parent topic: Tips and Tricks with the IDE
Related information
COBOL Properties


Debugging COBOL

Here are some tips and tricks on debugging COBOL applications in the Visual Studio IDE:

Attach to a Running Process
See To attach to a running process and debug.
Autos Window
Displays the variables used in the current and in the previous statements and enables you to change their values or add watches to them. To display the window, click Debug > Windows > Autos.
Breakpoint-Setting
Double-click in the left margin of editor next the a line of code, or position the cursor on the line and press F9. You can also choose Debug > Toggle Breakpoint or choose Breakpoint > Insert Breakpoint from the editor context menu.
Note: Tracepoints are supported only when debugging managed code.
Breakpoints Window
Displays a list of all breakpoints and tracepoints set in the code. Double-click on a breakpoint in the window to position the cursor on the line for which it has been added.
DataTips
Provide information about the variables in the source code. To display the DataTip for a variable, you can hover it. This works only in break mode when the execution stops and with variables that are used at run time.
Just-In-Time Debugging

Enables just-in-time debugging for when an application causes an error. To enable Just-In-Time Debugging for native COBOL code, click Tools > Options > Debugging > Just-In-Time Debugging. Check Micro Focus Native Debugger. Works with native code only.

Remote Debugging
You can debug a process running on a remote system if the machines are connected using TCP/IP. See Remote Debugging.
Ensure that the local and remote systems are networked using TCP/IP. To connect to the remote machine and debug a program, choose Project > projectProperties and go to the Debug tab. Check Use remote machine and fill in the IP address of the remote machine.
Run To Cursor
Right-click a line of code in the editor and select Run To Cursor. This starts a debugging session and executes the code till the line on which you positioned the cursor.
Start Debugging
Choose Debug > Start Debugging or, alternatively, press F5 or F11. F5 starts debugging and runs the application until a breakpoint or an error occurs. F11 starts debugging and breaks on the first statement that can be debugged.
Stop Debugging
Choose Debug > Stop Debugging. You can also click [image] in the Debug toolbar.
Threads Window
Shows all threads that are running in the process. To display the window, choose Debug > Windows > Threads.
Tracepoint-Setting
Tracepoints are conditional breakpoints. When the debugger hits a tracepoint, it performs an action instead of or before stopping the execution. To set a tracepoint, click on the line of code where you need to set one and choose Debug > Toggle Tracepoint or from the context menu choose Breakpoint > Insert Tracepoint and specify the action to perform. Tracepoints are supported only when debugging managed code.
Variable Windows
Include windows, such as for example Autos, Locals, Quick Watch, Watch, for monitoring and editing values and expressions.
Parent topic: Tips and Tricks with the IDE
Related information
To attach to a native running process and debug
Remote Debugging of Native COBOL Applications
Using the Memory Window in Native COBOL
To enable just-in-time debugging for when the application fails for Native COBOL
Overview - Debugging Native COBOL Programs


IntelliSense and COBOL

Note: The following applies to .NET managed code only.

IntelliSense is a feature of Visual Studio that provides easy access to language elements. It is also available when coding COBOL programs. IntelliSense shows lists of methods, fields, properties, parameters, classes and so on that are available when you type an object name followed by a double colon, an opening bracket or a double quote. You can choose an item from the list to complete the code rather than typing it yourself. Users of procedural COBOL can also gain IntelliSense on their programs.

The following are examples of where IntelliSense pops up:

  • Type Listings - When you start declaring a type, such as 01 my-string type ", IntelliSense pops up a list of the namespaces and types available to your program, as soon as you type the ". These namespaces are obtained from each of the references you’ve added to your project. As you type a namespace, IntelliSense shows all the types within that namespace. For example, when you type:
    • 01 my-string type " - all the available namespaces are listed
    • 01 my-string type "System - all the types within the System namespace are listed
    • 01 my-string type "System.IO - all the types within the System.IO namespace are listed.
  • Member Listings - When you invoke an object, IntelliSense pops up a list of methods, fields, properties and events that are available for that object. This happens when you use inline style of invoke statements (with the double colons ::), such as:
    invoke my-string::
  • Parameter Listings - When you type either USING or an opening a bracket for the parameters of an inline invoke, IntelliSense pops up a list of the parameters available for the method you’re invoking. It also displays any overloaded methods which you can scroll through using the arrow keys.
Parent topic: Tips and Tricks with the IDE


Code Snippets

Intellisense code snippets are portions of code that you can quickly insert in your applications.

  • To insert a snippet in your code
  • Shortcuts for the COBOL Snippets
  • To create a custom COBOL snippet
Parent topic: Tips and Tricks with the IDE


To insert a snippet in your code

  1. Right-click in the Editor and select Insert Snippet.
  2. Press TAB to navigate through the replacement fields and fill in values as required.
Parent topic: Code Snippets


Shortcuts for the COBOL Snippets

Use the following shortcuts to insert the code snippets. Type the shortcut in the editor and then press the tab key to insert the snippet.

Shortcut | Snippet | Description
accept | Accept From Date or Accept From Time | Enables you to set a variable to the current date or time.
attribute | Attribute | Inserts a class that implements a custom attribute.
class-id | Class-Id | Inserts a class declaration.
create | Create | Creates or constructs an instance of a list or a dictionary.
DateString | .NET Date Format | Enables you to set a localized date format by specifying the desired locale.
declare | Declare as Type | Declares a local variable.
delegate-id | Delegate-Id | Inserts a delegate declaration.
delete | Delete Key | Deletes an element from a list or a dictionary.
enum-id | Enum-Id | Inserts an enum-id declaration.
evaluate | Evaluate True | Inserts an EVALUATE statement declaration.
if | If Then Else | Inserts an IF statement declaration.
implements | Implement Class/interface | Implements Class/Interface method stubs.
inspect | Inspect Replacing simple characters or Inspect Tallying before terminator | Inserts an INSPECT statement declaration for either replace or tally.
interface-id | Interface-Id | Inserts an interface-id declaration.
method-id | Method-Id(instance) | Inserts an instance method declaration.
static-method | Method-Id(static) | Inserts a static method declaration.
perform | Perform Varying, Perform Varying Thru or Perform Varying Dictionary | Inserts a PERFORM statement declaration.
program-id | Program-Id | Inserts a COBOL program declaration.
property | Get/Set Property | Inserts a getter and a setter properties.
read | Read Into Key | Reads an element in a list or reads an element in the dictionary at a given key.
reset | Reset | Delete all the elements from a list or a dictionary.
rewrite | Rewrite From Key | Overwrite an element in a list or a dictionary.
setnew | Set New | Inserts the code to set an instance object to a new class object.
try | Try Catch Finally | Inserts a TRY-CATCH-FINALLY statement declaration.
valuetype-id | ValueType-Id | Inserts a valuetype-id declaration.
write | Write From | Writes an element to a list or a dictionary.
Parent topic: Code Snippets


To create a custom COBOL snippet

  1. Create a code snippet file.

    See the Visual Studio Help for instructions.

  2. Edit the code of the snippet file in the editor to include the desired functionality.

    See the MSDN Code Snippet Schema Reference.

  3. Specify Cobol in the <Code Language=""> tag - <Code Language="Cobol">.
  4. Save the file as type Snippet Files (*.snippet).
  5. To update Intellisense with your snippet, use Visual Studio Code Snippet Manager to add the file you just created to the available COBOL snippets.

    See How to: Manage Code Snippets in the Visual Studio Help.

Parent topic: Code Snippets
Related information
MSDN Code Snippet Schema Reference


Differences between Studio Enterprise Edition and Earlier Micro Focus Products

COBOL applications developed and built using previous Micro Focus IDEs, such as Net Express or Server Express, can now be developed and built with Studio Enterprise Edition. However there are some differences in behavior and in terminology, which are described here.
  • Overview of the Differences
  • Tips: Visual Studio IDE Equivalents to IDE Features in
    Many IDE features have different names and locations in Studio Enterprise Edition.
Parent topic: Using Visual Studio for COBOL Development
Related information
Managed COBOL Restrictions
COBOL Syntax Restrictions in Managed COBOL
Native COBOL Compared with Managed COBOL


Overview of the Differences

This COBOL system is integrated with Microsoft Visual Studio. The techniques you use to develop and debug native COBOL applications are much the same as the techniques you use with Visual Studio to develop nonCOBOL applications.

The development environment is Visual Studio, which provides all the functionality to manage projects and debug applications. It includes:

  • Templates for native COBOL projects such as mainframe applications, Windows applications and console applications, and also the ability to add your own COBOL project type
  • COBOL language colorization when editing and debugging
  • Information provided when hovering over COBOL variables
  • COBOL sensitive debugging including watch windows and breakpoints

COBOL applications previously built in the Micro Focus IDEs can be built with Visual Studio. The main differences between the IDEs are as follows:

Solutions, projects and source file folders
A solution is a container holding one or more projects that work together to create an application. The solution and its projects are reflected in the file system as folders, with solution folder containing the project folders, and the project folders containing the main COBOL source files. The folder tree shown in Solution Explorer mirrors the folder tree on disk.

If your solution has files that are shared across multiple projects, such as copybooks, you can create a folder for the shared files in the solution. COBOL copybooks can be held in folders outside the solution or project folders. You specify the location of the copybooks in the project properties.

Copybook extensions and source file extensions
The default extensions for source files are cbl, cob, and cpy. You can define other copybook extensions, using the COPYEXT Compiler directive.

In addition, alternative file extensions need to be identified to the text editor, so that the files can be found when searching. To specify these, you first need to associate the extensions with COBOL (from Tools > Options > Text Editor > File Extensions), add them to the list of copybook extensions (in Tools > Options > Text Editor > COBOL > Miscellaneous > Copybook extensions), and then add them to your project (type copyext(ext1,ext2) in Additional Directives on the COBOL page in your project's properties).

Source code character values
We recommend that you replace any non-text characters representing hexadecimal values with a hexadecimal character string definition.

In Net Express and Mainframe Express, COBOL source files are written using the ANSI character set and can contain characters using the full range of hexadecimal values from 00 to FF. When a source file is written to disk characters with values below hex 20 are NULL protected, that is, a character pair is written to disk, NULL(hex 00) followed by the original character.

Executables created in Visual Studio
In Visual Studio, each project creates a single executable, either an .exe or a .dll, rather than .int or .gnt. To choose the type of executable, its location and other build settings, specify these in the project's properties.
Build configurations
Previously, you specified how to build a project in Build Settings and Project Settings. In Visual Studio, you specify this in a build configurations, such as the default Debug or Release configuration, or in a configuration that you create.
Running or debugging an application
Where a solution has multiple projects, you need to ensure that the application's executable can locate the dependent project executables (.dll) and their symbol (.idy) files. To do this, you have several options:
  • In the exe project, add references to the projects that create the dlls. Specify where the symbol files are located using Debug > Options and Settings.
  • Specify that your projects put their output executables in the same folder as the solution executable (such as a bin folder). Copy the symbol files to this folder when building the dll, by setting up a post build event in the project's properties. See Project > Properties > COBOL > Advanced > Build Events.
Navigating the source
In Net Express or Mainframe Express, when you have built a COBOL application, context information is often used for program navigation. Visual Studio does not provide the same capability but you can achieve the same result by using one or more of the following options:
  • Edit > Find and Replace > Find in Files. The results of the find are displayed in the Find Results tab. You can then double-click an item within the find results and the source file is then loaded into a text editor view at the identified location.
  • In the program editor, position the cursor on an object, right-click, and select Go To Definition or press F12. This shows the definition of the object in a popup window.
  • In the program editor, position the cursor on an object, right-click, and select Find All References or press Shift+F12. This lists all instances of the object in the Find Symbol Results window.
Build results in the Output view and the Error List
When you build an application, you can view the build results in the Output view and the Error List. You can double-click a build message to identify a source. You can also double-click an item in the Error List to load the source file into a text editor at the relevant location. Turn on these panes, using View > Output and View > Error List.
Parent topic: Differences between Studio Enterprise Edition and Earlier Micro Focus Products
Related information
Creating COBOL Solutions and Projects
COPYEXT
Text Editor Miscellaneous Options
General Debugging Options
Build Configuration
Managed COBOL Restrictions
COBOL Syntax Restrictions in Managed COBOL


Tips: Visual Studio IDE Equivalents to IDE Features in

The following table shows Net Express IDE features and their corresponding equivalents and locations in Visual Studio.

Functionality | In Mainframe Express | In Net Express | In Studio Enterprise Edition for Visual Studio
Project Control
Project filename | *.MVP | *.APP | *.cblproj
Add file to project | Right-click the project in Solution Explorer. Choose Add > New Item to create a new file from the supported types in the project directory. To add an existing file, choose Add > Existing Item and browse to the location of the file to select it. This adds a link in the project to the file and by default moves it to the project directory.
Copybook path | Via Workgrouping | Choose Project > projectProperties and select the Copybook paths tab.
Build settings for the project:
  • COBOL
  • CICS including BMS
  • IMS (DBD, PSB, MFS)
  • Assembler
  • Preprocessor
  • Additional Directive
ALT+F7 or click Project > Build Setting for Project and select the corresponding tabs. Click Project > project Properties, go to the COBOL tab and choose a configuration in the Configuration field. To create a new build configuration or to edit one, click Build > Configuration Manager.
Execution environment settings:
  • General
  • Assembler
  • COBOL
  • JCL
The execution environment is Server Enterprise Edition.
Debug settings:
  • DateWarp
  • Stored Procedures
Editing
Suggest Word/Content Assist | CTRL+G | CTRL+G | CTRL+Space
Locate | F12 (or context menu Locate) | F12 (or context menu Locate) | F12
COBOL Find | CTRL+Shift+F12 (or context menu COBOL Find) | CTRL+Shift+F12 (or context menu COBOL Find) | Shift+F12
Compress | Tool bar compress Tool Bar Compress (or context menu Compress) | Tool bar compress Tool Bar Compress (or context menu Compress)
Bookmark | CTRL+F2 | CTRL+F2 | CTRL+B, T
Compiling
Single file Compile CTRL+F7 (or click check mark Check Mark) CTRL+F7 (or click check mark Check Mark) In Solution Explorer, right-click the file you want to compile and click Compile.
Note: This applies to native code only.
Build | F7 (or click build Build) | F7 (or click build Build) | F6
Build All | ALT+B A | ALT+B A | Click Build > Build <project>.
Debugging
Start Debugging | Alt+D A | Alt+D A | Choose Debug > Start Debugging or press F5.
Stop Debugging | Shift+F5 | Shift+F5 | Choose Debug > Stop Debugging.
Restart Debugging | Ctrl+Shift+F5 | Ctrl+Shift+F5
Run | F5 | F5 | F5
Step | F11 (or click step Step) | F11 (or click step Step) | F11
Step All | Ctrl+F5 | Ctrl+F5
Run Thru
Run Return
Run to Cursor | Shift+F10 (or context menu) | Shift+F10 (or context menu) | Ctrl+F10
Skip to Cursor | CTRL+Shift+F10 | CTRL+Shift+F10 | context menu
Skip Statement | ALT+D, I or click Debug > Skip Statement .
Skip Return | ALT+D, K or click Debug > Skip Return
Examine ' data item' | Shift+F9 | Shift+F9 | Shift+F9
Breakpoint set | F9 | F9 | Double-click in the left margin of editor next to the a line of code, or right-click the line and choose Breakpoint > Insert Breakpoint, or press Shift+F9.
Conditional Breakpoint | Breakpoint > Condition
Break on Data Change | Via list view | Via list view | You can break on data change in native COBOL projects, by right-clicking and choosing Add COBOL Watchpoint.
Attach to Process | Click Debug > Attach to Process, or Ctrl+Alt+P
Just-In-Time Debugging Click Tools > Options > Debugging > Just-In-Time Debugging, and check Micro Focus Native Debugger.
Note: This applies to native code only.
Parent topic: Differences between Studio Enterprise Edition and Earlier Micro Focus Products


Interface Mapping Toolkit

  • Overview
  • Starting the Interface Mapping Toolkit
  • Command Line Interface
  • Service Interfaces
  • Mapping Wizard
  • Interface Mapper
  • Deploy Tool
  • Client Generation
Parent topic: Developing COBOL Applications


Overview

The Interface Mapping Toolkit enables you to take an existing COBOL application, and deploy it as a service - that is, a software component that can be kept loaded ready to be invoked by a separately written client application. The main thing you need to do is create a new interface that can be invoked through one of the established mechanisms used for such components. These mechanisms are Java interfaces and Web Services. You need to define how this new interface maps onto the parameters of your existing program.

You can also use the Interface Mapping Toolkit to extend CICS applications. For more information, see the chapter The Interface Mapping Toolkit in your Extending CICS Applications book.

In many cases, the program to be turned into a service has formed part of an application in production use for many years. Therefore we often refer to it as the legacy program. However, there is no reason why it should not be a new program especially written to be the basis of the new service.

The main elements in the Toolkit are:

  • Service Interfaces - A tree view showing services you have created.
  • Mapping Wizard - A wizard in which you define the basic properties of a new service - its name, the mechanism it uses, the name of the legacy COBOL program, and so on.
  • Interface Mapper - A graphical drag-and-drop editor where you define how data passed between a client and the service is to be mapped onto the data in the COBOL program.
  • Deploy Tool - A tool to copy a service you have created to where it will be run, and a dialog box for setting deployment options.
  • Client Generation - A tool to create a client, either COBOL client application to use a Web service you have created, or a JSP client to use an EJB you have created.
Parent topic: Interface Mapping Toolkit


Starting the Interface Mapping Toolkit

The Service Interfaces window is an Integrated Development Environment (IDE) for the Interface Mapping Toolkit. That is, you access all the tools in the Toolkit from this window. To open it, you use the cobimtk script, which resides in the $COBDIR/bin directory when Enterprise Server is installed. It takes no parameters.

To run cobimtk, you need $JAVA_HOME set - cobimtk uses $JAVA_HOME/bin/java. You must have J2SE installed. See the Third Party Software information in your Readme for the supported versions.

You also need DISPLAY to be set to point to a host capable of running X Windows.

For example, enter:

export DISPLAY=ip-address:0.0
cobimtk
Parent topic: Interface Mapping Toolkit


Command Line Interface

There is also a command line interface to the Interface Mapping Toolkit. It is called imtkmake, and it is documented fully in the topic imtkmake. We give a brief overview here.

It has the following functions:

-defmap | Create a default mapping
-generate | Generate the deployment package (.car file)
-query | List the enterprise servers available for deployment
-deploy | Deploy the package to an enterprise server
-showlog | Display the deployment log file
-genclient | Generate a COBOL client from the mapping
-genclientwsdl | Generate a COBOL client from a WSDL file
-help | Display information about the functions

These can be used together or in separate commands. For example, to create a Web service called myservice with default mapping, from the program program.cbl, use:

imtkmake -defmap src=program.cbl service=myservice
    type=webservice

Then, to generate the deployment package, use:

imtkmake -generate service=myservice type=webservice

Then, to deploy it to the enterprise server ESDEMO, use:

imtkmake -deploy carname=myservice.car server=ESDEMO,Deployer
Parent topic: Interface Mapping Toolkit
Related information
imtkmake
COBOL to Service Interface Data Type Matches


Service Interfaces

You store the files created by the Interface Mapping Toolkit, containing the definition of the new interface and the mapping, in a repository. In practice the terms "interface" and "mapping" are often used interchangeably.

The Service Interfaces shows the service interfaces (also called mappings) stored in a given service interface repository ( .mpr file). Such a set of service interfaces is called a service interface group.

A service interface group is not necessarily associated with a project. However, when you create a new service interface using the Mapping Wizard, if a project is open, the service interface is added to the service interface group in that project’s project folder. If the group does not exist, it is created.

The tree view shows whether a service is a Web service or Java interface. It also shows the operations in each service.

You can import and export service interfaces between machines and between different COBOL development systems, and between different platforms (such as Windows and UNIX, or different UNIX platforms).

Right-click the name of a service interface to get a menu giving access to functions for editing and deploying the service.

Parent topic: Interface Mapping Toolkit
Related information
To import a service interface
To export a service interface


Mapping Wizard

You use the Mapping Wizard to prepare a COBOL application for exposure as a Web service or Java interface, so it can be invoked as a service by client applications.

In the Wizard, you define the basic properties of the service, such as its name and whether it is a Web service or Java interface. At the end of the Wizard, the Interface Mapper opens so that you can define how data sent between a client and the service maps onto the parameters expected by the COBOL application.

The fields are described in popup help, accessible by clicking the Context Help Context help button buttons and then clicking the field. There are also a number of How-to topics.

The following notes give some more details on some aspects of this wizard.

  • New Service Interfaces Group - If no project or service interface group is open when you try to create a new Service Interface, you first need to create a service interface group to add the new service to.
  • Warning on Finish - If you create a service for a program that is already used in existing services, then when you click Finish on the wizard you get a warning that the program has been updated. This message refers to the fact that the program has been recompiled in the course of the Mapping Wizard. No implicit changes are made to the program source itself.
  • Files Created - Whether you are creating a Web service or Java interface, the Interface Mapping Toolkit creates two XML files, describing the COBOL program and the service respectively. These should not be confused with the WSDL file, which is the XML file created for a Web service by the Deploy tool. These two files are for internal use by the Interface Mapping Toolkit.
Parent topic: Interface Mapping Toolkit
Related information
To update a service mapping
To delete a service mapping
To import a service interface
To export a service interface
To validate a service mapping
To specify a user exit for a service
To enable user exits for an operation
To define the run-time environment for a service
To add an operation
To update operation properties
To delete an operation


Interface Mapper

A typical COBOL program performs several related functions. For example, a file maintenance program may be able to add a record, return a record, delete a record, and so on. When you expose your program as a service, you make these functions available to be invoked at any time by separately-written client applications. In the terminology of services, these functions are called operations.

The Interface Mapper is the heart of the Interface Mapping Toolkit. You use it to define which of the program's functions to expose as operations of the service. For each operation, you define the fields that will be in the messages sent between the service and a client. They are called interface fields.

Data sent and received in interface fields can be mapped either onto data items in the program's Linkage Section or onto data items that are the subject of ANSI ACCEPT, ACCEPT FROM COMMAND-LINE or ANSI DISPLAY statements or the program's RETURN-CODE special register. This chapter uses the term non-Linkage Section items for this second type. Normally a program uses either Linkage Section items or non-Linkage Section items to communicate with the caller, but you can map both types of fields in the same program.

When a service is invoked, the data received in the interface fields is moved to the mapped items in the COBOL program. When the service exits, the data from the mapped items is returned in the interface fields.

You can have the Interface Mapper generate a default mapping that simply reflects the formal structure of the COBOL program. However, a programmer with a good knowledge of the workings of the COBOL program may see ways of making the interface more efficient and user-friendly. You use the Interface Mapper to do this. You can start off with the default mapping and modify it, or you can start with the Interface Mapper empty and define the interface and mapping from scratch.

When you have finished creating a mapping, you should validate it. The validate option reports one error at a time, so you need to repeat the validation until no errors are reported.

  • Layout of the Interface Mapper
  • Operation Details
  • Linkage Section
  • Interface Fields
  • Reusable Fields
  • COBOL Assignments
Parent topic: Interface Mapping Toolkit


Layout of the Interface Mapper

The Interface Mapper displays one operation at a time. Its window is split into the following areas:

  • Operation details - The name of the operation, and other details that apply to the operation as a whole, are at the top near the title bar.
  • Linkage Section pane - The left-hand pane shows the Linkage Section of your COBOL program.
  • Interface Fields pane - The top right-hand pane is where you define the data fields to be sent to or from the service, for the operation currently displayed.
  • Reusable Fields pane - The middle right-hand pane is where you define complex data types.
  • COBOL Assignments pane - The bottom right-hand pane is where you define fixed values to be placed into specified Linkage Section items when the operation is invoked.
Parent topic: Interface Mapper


Operation Details

The Interface Mapper displays details of one operation at a time. The name of the operation currently displayed is at the top right, with a dropdown list for you to select a different operation.

At the top left is the name of the entry point at which the program will be entered when this operation is invoked.

To add a new operation, you use Operation > New. You specify a name for the new operation and select the entry point where the program is to be entered.

In the default mapping that the Interface Mapper can create for you, each entry point becomes one operation. A typical improvement you might make is if you know that a single entry point leads to an EVALUATE statement choosing between different functions. You could make each of these functions into a separate operation. Often in such a program, one parameter is a code tested by this EVALUATE to see which function is wanted - see the section COBOL Assignments for how to handle this.

Parent topic: Interface Mapper
Related information
COBOL Assignments


Linkage Section

The left-hand pane shows the Linkage Section of your COBOL program, in a tree view reflecting the COBOL data hierarchy.

The easiest way to create new entries in the right-hand panes is by dragging items from this pane. For details, see the sections for the appropriate right-hand pane.

You can also create a new interface field by right-clicking in this pane and using the popup menu.

Parent topic: Interface Mapper


Interface Fields

In the Interface Fields pane, you define interface fields for the operation currently displayed. This pane shows the interface fields for just the operation currently displayed. To see those for a different operation, use the dropdown list at the top right of the Interface Mapper to display that operation.

You can define new entries using the Field menu, or the popup menu in the Interface Fields pane, or the popup menu in the Linkage Section pane, or by dragging data items from the Linkage Section pane. Dragging is usually the most convenient method for Linkage Section items. If you need interface fields for the non-Linkage Section items, you use the the Field menu, or the popup menu in the Interface Fields pane.

If you define a field by dragging, it is mapped to the data item you dragged. You can create a set of interface fields by dragging a group item.

In the default mapping that the Interface Mapper can create for you, the interface fields for each operation are defined automatically from the Linkage Section items used by the operation's entry point. Each interface field is mapped onto the corresponding Linkage Section item.

  • Interface Field Properties
  • Mappings
Parent topic: Interface Mapper


Interface Field Properties

Most of an interface field's properties are shown in columns in the Interface Fields pane, and you can update a property by double-clicking it. Some properties can then be overtyped, while others can be selected from a dropdown menu. For some properties, you must use Field > Properties. The following properties are available:

  • Name - The interface field's name will be visible in the external definition of this service (for a Web service, the WSDL), and will be used as its identifying keyword in messages to or from the service. If you created this field by drag-and-drop, then by default this is the same as the name of the corresponding COBOL item. The names assigned by default are designed to be unique. You can change them to more meaningful names if you wish.
  • Direction - An interface field has a direction:
    • Input - it will be expected in the messages received by the service
    • Output - it will be included in the messages returned by the service
    • I/O - it is both input and output. Note that the Web Services mechanism does not have the concept of an I/O message.
    • Output Return - it is an output field and will be used as the return parameter

    When a service is invoked, data in the input fields is moved to the corresponding Linkage Section items in the COBOL program. When the service exits, data is moved from the Linkage Section items to the corresponding output fields.

    Fields within the same group cannot have different directions from one another. A group’s direction applies to all items within it.

    In the default mapping that the Interface Mapper can create for you, fields mapped to BY VALUE parameters are Input. Fields mapped to BY REFERENCE parameters are I/O in a Java interface, while in a Web service two fields are declared, one Input and one Output, for each parameter. A typical improvement you might make is if you know that a parameter passed as BY REFERENCE contains data on output but is ignored on input. You could make it Output rather than I/O.

  • Type - In COBOL, you describe a data item's data type precisely, using its picture-string. XML (used for sending data between a client and a Web service) and Java each define their own sets of data types. By default, the Interface Mapper maps the data type of each data item in your program onto the nearest type available in the mechanism you are using - XML or Java. The dropdown menu for this property includes all the primitive types provided by that mechanism, plus the complex types you have defined in the Reusable Fields pane.
  • Occurs - This property corresponds to the OCCURS clause in COBOL. If you created this entry by drag-and-drop, then by default it has the same number of occurrences as the COBOL item you dragged.
Parent topic: Interface Fields


Mappings

A mapping defines which COBOL data item the interface field is mapped to. It is shown on the field's Mappings dialog box (Field > Mappings) in a format similar to:

data-name -> interface-field-name

The arrow shows the direction of the mapping. This derives from the direction of the interface field, and you can change it only by changing the interface field's Direction property. For an input field, data is moved from the interface field to the data item when the service is invoked. For an output field or output return field, data is moved from the data item to the interface field when the service returns to the caller. For an I/O field, both these moves are done (represented by a double-headed arrow).

If you create an interface field by drag-and-drop, it is mapped by default to the COBOL item you dragged.

A field can have more than one mapping. For an input field, this means data received in the field is moved to all the data items the field is mapped to. For an output field it is meaningless (data from several COBOL items would be moved to the field, overwriting one another), unless the interface field has an Occurs property. In this case you can specify different values of the subscript in different mappings.

On the Mappings dialog box, a list box shows the mappings for the interface field. To add a mapping, you specify the name of the desired COBOL data item or one of the non-Linkage Section types in the COBOL Field field and click Add. The mapping is added to the list box.

The mappings for a non-Linkage Section item are ANSI ACCEPT and COMMAND-LINE for input fields, and ANSI DISPLAY and RETURN-CODE for output fields. These always appear at the bottom of the list box.

You cannot normally change the Field Name on this dialog box, since the purpose of the Mappings function is to specify the mappings for a particular interface field. However, if the interface field has the Occurs property, you can edit the Field Name so as to specify the subscript. Changing anything other than the subscript will result in an error message when you click Add to add a mapping.

By default, for an item with the Occurs property, each occurrence is mapped onto the corresponding occurrence of the COBOL data item. If the number in the Occurs column does not match the OCCURS clause of the Linkage Section item, a message warning you appears before the Mappings dialog box opens. You should then use the dialog box to specify mappings for the individual occurrences.

Note: If you are creating a Web service you should take care not to map an output interface field defined as a string to a COBOL alphanumeric data item that can contain a character value that is invalid for a SOAP string. Invalid character values are values less than x"20" except for x"09", x"10" and x"13". If you do create such a mapping, the client program might receive the message: "458 Illegal character in SOAP string".
Parent topic: Interface Fields


Reusable Fields

The Reusable Fields pane is primarily for convenience. If you want to create a group of interface fields, and use the same group in several operations, you cannot create it in the Interface Fields pane and copy it from operation to operation, because the Interface Fields pane shows only the fields for the operation currently displayed. So instead you create it in the Reusable Mappings pane, and copy it from there to the Interface Fields pane for each operation. The Reusable Fields pane does not change when you display a different operation.

You can define new entries using the Field menu, or the popup menu in the Reusable Fields pane, or by dragging data items from the Linkage Section pane. Dragging is usually the most convenient method.

What you are in fact doing is defining a complex data type. Technically, for a Web service it defines a complex data type in the WSDL file. For a Java interface, it creates a custom record according to the CustomRecord interface defined in the Common Client Interface (CCI) from Sun.

In these cases, what you see in the Interface Mapper is a complex type, displayed in a way similar to a COBOL data hierarchy. Every item in the Reusable Fields pane, whether it is a group item or an elementary item, is a complex type. When you drag such a type to the Interface Fields pane, you create an interface field which has as its type the name of the type you dragged. If you double-click the Type column in the Interface Fields pane, you see listed there all the types you have defined, as well as the native types for the mechanism - Java interfaces or Web Services - that you are using for the service.

The properties available for an entry in the Reusable Fields pane are the same as those for an interface field, except that, being a type declaration not an actual field, it has no direction. Most properties are shown in columns in the Reusable Fields pane. You can update a property by double-clicking the entry. Alternatively, click Field > Properties or right-click the entry and click Properties.

You update the mappings of an entry in the Reusable Fields pane in the same way as for an interface field, using Field > Mappings.

  • The Reusable Fields Pane with a Web Service
Parent topic: Interface Mapper


The Reusable Fields Pane with a Web Service

For a Web service there is an extra reason for using the Reusable Fields pane. When you drag a group item to the Interface Fields pane, this creates a hierarchy of interface fields similar to the COBOL hierarchy. The Interface Mapping Toolkit declares each group field as a complex type in the WSDL file. If you create the same group in several different operations, this complex type will be declared several times. But this is illegal in WSDL, where each complex type must have a unique name.

You could get around this by renaming each group field after creating it. But an easier and more convenient way is to drag the group item to the Reusable Fields pane instead, resulting in the complex type being declared just once. You can then create as many interface fields as you like using this type - by dragging it from the Reusable Fields pane to the Interface Fields pane - without the type being declared again.

Parent topic: Reusable Fields


COBOL Assignments

In the COBOL Assignments pane, you define values to be placed into specified Linkage Section items when the operation currently displayed is invoked.

This pane shows the COBOL Assignments for just the operation currently displayed. To see those for a different operation, use the dropdown list at the top right of the Interface Mapper to display that operation.

Use a COBOL assignment when several operations go to the same entry point and the program takes different paths depending on the value of a parameter. Instead of defining an interface field to map to that parameter, place the value here that makes the program take the required path.

You can define new entries using the Field menu, or the popup menu in the COBOL Assignments pane, or by dragging data items from the Linkage Section pane. Dragging is usually the most convenient method. A dialog box automatically opens where you can specify the value to be placed into the item at the start of the operation.

If you drag a group field, a dialog box opens for each elementary item in turn. You can click Cancel if you do not want to set values for all of them.

A COBOL Assignment entry has only one property, the value to be assigned. It is shown in a column in the COBOL Assignments pane, and you can update it by double-clicking the entry.

Parent topic: Interface Mapper


Deploy Tool

The Interface Mapping Toolkit includes a Deploy tool, which does several things for you. It:

  • Generates one of the following: a WSDL file containing the Web Service, or an EJB packaged in a Java archive file (.jar).

    must deploy to an enterprise server that has a deployment service and a deployment listener, such as ESDEMO. The Deploy tool creates a new directory under the deployment directory specified in the deployment service's and listener's configuration. It then copies the interface files, together with the application files, to the new directory.

  • Deploys the service interface to an enterprise server. The service interface comprises the mapping information you defined using the Interface Mapper and any COBOL and data files you specified.
  • Packages the service interface into a COBOL archive file (.car) file. This archive file then contains the mapping information you specified and might contain the COBOL sources, among other files. You can manually deploy this .car file to another enterprise server, without using the Deploy tool again.

For more information about deployment services and listeners, see the section Deployment Services and Listeners in the chapter Configuration in your Enterprise Server Configuration and Administration Guide.

You use the Deploy tool in two stages. First you specify the deployment settings and then you deploy your service. If you find you have to make updates to the source code or service mapping to make the service perform as expected, you can redeploy it.

Alternatively, you can deploy services from the command line, using the tools imtkmake or mfdepinst. See the reference Help topics imtkmake and mfdepinst.

After deploying the service interface to an enterprise server, you deploy further software depending on the type of interface you generated:

  • For a Web Service, there is nothing else to deploy.
  • For a J2SE Java bean, there is nothing else to deploy.
  • For an EJB, you need to deploy the EJB to a J2EE application server. You also need to deploy a resource adapter.

When a service interface is ready to be run in a production environment, administrators usually take responsibility for deployment, and they typically deploy using a manual mechanism. For more information about manual deployment and about the extra tasks required for EJB services, see the chapter Deploying Interfaces in your Enterprise Server Configuration and Adminstration Guide.

  • Data Files
  • Deployment Settings
Parent topic: Interface Mapping Toolkit
Related information
Deployment Services and Listeners
To deploy a service interface using the Deploy tool
mfdepinst
Deploying Interfaces
imtkmake
COBOL to Service Interface Data Type Matches
mfdepinst


Data Files

You need to make sure the legacy program can find its data files.

can deploy the data files with the program, by specifying them on the Application Files tab on the Settings dialog box. By default, the current directory for the execution of a service is set to the directory where the service starts executing, so the service will find the files you deployed with it.

If a data file is also maintained by another application, beware that this application and the service will be maintaining different copies of the file. This situation will arise if you continue to run the old legacy application in parallel with the new service. To avoid this problem, there are several alternatives to copying the files.

You can specify the filenames in the SELECT statements with an environment variable (for example, $MYDATADIR\myfile.dat), and then set the environment variable to point to the original copy of the file.

Setting the environment variable in the operating system works for a Web service or EJB too - the enterprise server inherits the setting from the operating system environment. You can also set it locally in the enterprise server where the service is deployed - the server definition is then portable and can be administered remotely. See your Enterprise Server Configuration and Administration Guide for details. You can also set it for your individual service, as described in Deployment Settings .

If the service is to be deployed to a specific server where the location is known, you can simply give an absolute path in the SELECT statement.

Parent topic: Deploy Tool
Related information
Deployment Settings
Configuration and Administration Guide


Deployment Settings

You configure the deployment settings in the Interface Mapping Toolkit. can configure a range of deployment settings, including:

  • In the Enterprise Server Name field, you can choose the deployment service to use. The Deploy tool uses that field to determine which enterprise server will own the new services and packages, and which listener they'll be associated with. The Deploy tool looks in MFDS for the deployment service that you chose. If there are any configuration settings specifying the server and listener, these are used. If there aren't any settings, the Deploy tool uses the enterprise server that owns the deployment service that you chose.
  • The Configure enterprise server run-time environment button enables you to configure the environment in which your service will run; you can set switches, tunables, environment variables and so on. These settings override, for this service only, the settings made in Enterprise Server Administration (the GUI for administering Enterprise Server) for the environment server in which your service runs.

    To enable these settings, check Enable enterprise server run-time environment. When this is not checked, the settings are ignored.

By default, the Deploy tool deploys to the enterprise server called ESDEMO. If your enterprise server is running on a different machine, you need to specify the remote machine name in the Micro Focus Common Client (MFCC) configuration file, which by default is mf-client.dat in the base\bin directory of your COBOL development system installation. You can create your own configuration file of any name or location, but you must identify it using the MFC_CONFIG environment variable. .

Parent topic: Deploy Tool


Client Generation

Clients can be generated for Web services. These clients are WS-I compliant. See the chapter COBOL Web Services with the Interface Mapping Toolkit .

Clients can also be generated for EJBs. See the chapter Mapping a Java Interface and Using Resource Adapters.

Parent topic: Interface Mapping Toolkit
Related information
COBOL Web Services with the Interface Mapping Toolkit
Mapping a Java Interface and Using Resource Adapters


Preparing Applications for Enterprise Server

The following topics explain the implications of exposing COBOL applications as services to be run under Enterprise Server:

  • The Application Container
  • Resource Management
  • Restrictions on the COBOL Application
Parent topic: Service Interfaces with the IMTK


The Application Container

A COBOL application that is deployed as an enterprise server service is always run inside one of the server's service execution processes. The part of the service execution process that runs the application is a tightly managed COBOL run-time environment, or application container. Enterprise Server maintains a consistent state for this container between application invocations to ensure consistent execution behavior.

When a client request arrives, the application program to be invoked is loaded, and then the container sets up its execution environment prior to its invocation. This information includes environment variables, tunables and switches that the application requires. If no run-time configuration information was specified for the service at deployment time, a default environment will be set up for the application.

Client requests can be short-running or long-running. Short-running client requests are requests where there is just one interaction between the client and the service; the client request arrives, the service runs, and a response is returned to the client. Requests from Web services clients are always short-running. Long-running client requests are either requests where the same client makes repeated requests of services and needs data to be preserved between invocations of the service, or where a client makes a request that is part of a transaction. So if the client is a stateful Java bean running in a J2EE server such as WebSphere, the service will run for as long as the bean runs.

  • Short-running Requests
  • Long-running Requests
Parent topic: Preparing Applications for Enterprise Server


Short-running Requests

If the application was invoked by a short-running request, when it terminates, whether normally or due to a run-time system error occurring, the application container returns itself to its initial state before a response is generated and sent back to the client.

Normally, having sent a response back to the client, the service execution process waits for the enterprise server to notify it to process another request. However, there are some circumstances where the service execution process is terminated following the execution of an application:

  • The integrity of the container has been compromised in some way (for example, a run-time system error, such as a 114 error, occurred or an executable file loaded by the application could not be unloaded; etc.).
  • You unchecked Reuse container after application termination on the Deployment Characteristics tab of the Enterprise Server Run-time Configuration dialog box before you deployed the service. You should uncheck this if the application is likely to leave the application container in a state that will compromise its ability to be safely reused, for example, if your application is mixed-language and the non-COBOL modules do not clean up resources before the application terminates.
  • You unchecked Reuse container after non-fatal run-time system error on the Deployment Characteristics tab of the Enterprise Server Run-time Configuration dialog box before you deployed the service, and the application has terminated due to a non-fatal run-time system error (for example. 173 error "Program not found"). You should uncheck this if you decide that any run-time error that occurs while running the application indicates a major failure that compromises the integrity of the container.

When such a circumstance occurs, the enterprise server will start a new service execution process to replace the one just terminated.

Parent topic: The Application Container


Long-running Requests

A long-running request starts when either a transaction begins, or when a request is made to invoke a stateful service. When in this mode, the connection between the client and the server is maintained until either the transaction ends, or the client indicates that stateful processing is no longer required. However, a transaction start request may occur when a long-running request is already in effect (for example, a request for a stateful request has been previously made), or when the first service request within a transaction is for a stateful service. In this situation, the end of transaction will not terminate the long-running request as the server is still running in stateful mode.

Once a long-running request has been initiated, the service execution process is only able to process requests made by this specific client. To maintain responsiveness to other clients, the enterprise server starts a new service execution process each time an existing service execution process starts processing a stateful request.

When stateful processing is in effect, the application container does not return to its initial state following successful execution of a service request. Instead it maintains the client state of the container across multiple service requests until it receives notification from the client indicating that stateful processing is no longer required. (For example, it does not cancel user programs; does not return environment variables, tunables, or switches back to their initial state; does not unload user libraries etc.) When it receives notification indicating that stateful processing is no longer required, the application container returns itself to its initial state.

Stateful mode is implicitly exited if a service request causes a run-time system error to occur.

Enterprise Server manages its service execution processes to maintain the configured number of processes. This may mean that the enterprise server terminates the service execution process when a stateful client request completes.

Parent topic: The Application Container


Resource Management

A COBOL application providing a service that uses external resources, such as databases and files, can manage its own resources or let the application container manage them. A service that manages its own resources is known as application-managed, while a service that does not manage its own resources is known as container-managed.

You specify whether an application you are deploying is to be application-managed or container-managed when setting properties for the service interface.

  • Application-managed Services
  • Container-managed Services
Parent topic: Preparing Applications for Enterprise Server


Application-managed Services

A service must manage its own resources if:

  • The application accesses files or databases (or both) in a transactional way, and contains transactional logic: that is, it includes COMMITs and ROLLBACKs
  • The application uses a resource manager that we do not support in the Enterprise Server environment.

A service in which the application accesses files in a non-transactional way (that is, it does not includes COMMITs and ROLLBACKs), should be application managed.

A transactional application-managed service must contain all the transactional logic it needs, that is, it must complete with all resources either committed or rolled back.

Application-managed services are executed in a similar way to applications in a conventional execution environment. One of the main differences is that the process is not terminated at the end of execution of the service.

Parent topic: Resource Management
Related information
Container-managed Services


Container-managed Services

If an application running as a service uses databases and files but does not contain any transactional logic, it can let the application container manage its resources.

The application container must know in advance what resource managers will be required. You define resource managers in Enterprise Server. You can only define resource managers that are XA-compliant.

The application container decides whether to commit or roll back resources using information that you provide on the Deployment Characteristics tab of the Enterprise Server Run-time Configuration dialog. To reach this, Enable enterprise server run-time environment, and click Configure enterprise server run-time environment. You can specify whether or not the application uses the value of its return code to indicate success or failure, and what the maximum success value is. If you specify that the application does not use the value of its return code to indicate success or failure, the application container considers all application invocations to be successful.

Parent topic: Resource Management
Related information
Application-managed Services
Resource Managers


Restrictions on the COBOL Application

There are certain restrictions on the COBOL application. These are mostly common sense, arising from the fact that the program is being used as a self-contained component being called by remote users.

Before deciding to expose a COBOL application as a service, you must determine whether the application is suitable. Examine all the functions you intend to expose, and make sure they conform to the requirements in this section. You may need to do some restructuring.

  • User Interaction for COBOL Program Services
  • Run-time Errors and Completion
  • Multithreading
  • Preserving State
  • File Handling
  • Releasing Resources
  • Object-oriented COBOL
Parent topic: Preparing Applications for Enterprise Server


User Interaction for COBOL Program Services

A COBOL program service can receive and return data in two ways:
  • Using input and output parameters defined as data items in the Linkage Section.
  • Using ACCEPT and DISPLAY statements or the RETURN-CODE special register. Two forms of the ACCEPT statement are supported: ANSI ACCEPT and ACCEPT FROM COMMAND-LINE.

When the application runs as a service in an enterprise server, any ANSI ACCEPT or ACCEPT FROM COMMAND-LINE statements that are not mapped to interface fields return spaces, and any ANSI DISPLAY statements or RETURN-CODE values that are not mapped to interface fields are ignored. Any screen or keyboard operation other than an ANSI ACCEPT, ACCEPT FROM COMMAND-LINE or ANSI DISPLAY will generate the run-time system error 197 and the application will be terminated.

A service can also issue ACCEPT FROM CONSOLE and DISPLAY UPON CONSOLE statements. When execution reaches a DISPLAY UPON CONSOLE statement, the display text is displayed in the enterprise server console log, and the service continues. When execution reaches an ACCEPT FROM CONSOLE statement, the service pauses and asks for input using pages in ESMAC.

Parent topic: Restrictions on the COBOL Application


Run-time Errors and Completion

A service must be well-behaved, that is, it must run to completion, return its results to the client, and exit so that control returns to the server.

Therefore, the COBOL application must handle all errors by returning an error indication in the output parameter, never by stopping. You should make sure that all error conditions are detected, through the use of the FILE STATUS clause, declarative procedures, etc., so that the program does not crash or otherwise abort.

Similarly, the COBOL application should not contain a STOP RUN statement. When encountered during service execution, the STOP RUN statement is effectively a quit statement, making the program exit at once.

Parent topic: Restrictions on the COBOL Application


Multithreading

Multi-threaded applications are not supported, since service execution processes in the enterprise server can only run applications that use the single-threaded run-time system.

Parent topic: Restrictions on the COBOL Application


Preserving State

If your service will be invoked by short-running client requests, the application will run in an enterprise server with no memory of previous invocations by the same client. If you need to preserve state or data from one call to the next, you need to program this for yourself, for example, by saving data in a work file.

Parent topic: Restrictions on the COBOL Application


File Handling

If the application uses the API of the Micro Focus File Handler for COBOL file operations, it must ensure that all files that it has opened using this interface are closed on its termination. Failure to do so will leave the files open for subsequent service requests and may lead to service execution failure.

Parent topic: Restrictions on the COBOL Application


Releasing Resources

The application must release any resources it uses that are not managed by the COBOL run-time system before it terminates. Failure to do so will potentially result in undefined execution behavior for subsequent services invoked by the container. If it is not possible to release such resources (for example, third-party modules are being used by the application that acquire resources), you must indicate this when you deploy the service. This ensures that the service execution process in the enterprise server will be terminated once the application has terminated.

Parent topic: Restrictions on the COBOL Application


Object-oriented COBOL

When deploying a COBOL service program that uses Object-oriented COBOL to an enterprise server, you must specify that any container used to run the service is not reused. You do this by unchecking Reuse container after application termination and Reuse container after non-fatal run-time system error on the Deployment Characteristics tab of the Enterprise Server Run-time Configuration dialog box when you deploy the service.

Parent topic: Restrictions on the COBOL Application


To start interface mapping and open a service interface

  1. Open the Interface Mapper perspective.
  2. Show the Service Interfaces view, if it isn't already visible.
  3. Show the Navigator view, if it isn't already visible.
  4. In the Navigator view, select and open the project that contains the COBOL whose interface you want to map.
  5. You can now right-click items in the Service Interfaces view to create and maintain services.
Parent topic: Developing COBOL Applications


To create a service interface

  1. Start the Interface Mapper.
  2. Click File > New > Service Interface and click OK.
  3. Follow the Mapping wizard.

    When you have finished, the Interface Mapping editor starts.

  4. In the Interface Mapping editor, define or edit your service interface. You can:
    • Create an operation for an entry point in the COBOL program. When the Interface Mapper create a default mapping, it creates one operation for each entry point. To create an operation, click Operation > New Operation and fill in the fields as required.
    • Map fields in your COBOL program to the service interface, by dragging fields from the Linkage Section pane on the left into the Interface Fields pane on the right.
    • Change the properties of the fields in the Interface Fields pane, by right-clicking a field and clicking Properties.
    • Reuse a group of interface fields in several operations. To do this, you drag the group item from the Interface Fields pane into the Reusable Fields pane.
    • Define values for Linkage Section items by specifying the values in the COBOL Assignments pane. Use this when several operations go to the same entry point and the program takes a different path depending on the value you define.

For full details on the Interface Mapper, see the chapter Interface Mapping Toolkit.

Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To update a service mapping
To delete a service mapping
To import a service interface
To export a service interface
To validate a service mapping
To add an operation
To update operation properties
To delete an operation


To define the run-time environment for a service

  1. Open the Service Interfaces view, if it isn't already open.
  2. In Service Interfaces, right-click the service interface whose run-time environment you want to define and click Settings
  3. Check Enable enterprise server run-time environment.
  4. Click Configure enterprise server run-time environment.
  5. Specify the run-time environment you require when the service runs in an enterprise server.

    Most of the options are similar to those for configuring the run-time environment for programs that don't use Enterprise Server, such as program switches and environment variables.

Related Topics

Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To specify a user exit for a service
To enable user exits for an operation
To define the run-time environment for a service
Overview - Run-time Configuration
Run-time Tunables


To delete a service mapping

  1. Open the Service Interfaces view, if it isn't already open.
  2. In Service Interfaces, right-click the service interface you want to delete and click Delete.
  3. Click Yes.
Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To update a service mapping
To delete a service mapping
To import a service interface
To export a service interface
To validate a service mapping
To add an operation
To update operation properties
To delete an operation


To export a service interface

  1. Open the service interface to export or the project containing it.
  2. Click File > Export Service Interfaces , and navigate to the directory to which you want the service mappings to be exported.
  3. Specify a filename for the export file. All the service mappings in the current project or group and their settings are saved in the specified file with the extension .sie.
    Note: Note:

    The .sie file is a standard .zip archive file containing the details of the service interface.

  4. Transfer the .sie file and any application programs and other files that need to be deployed to the target machine to the machine and platform to which you want to import the settings.
Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To update a service mapping
To delete a service mapping
To import a service interface
To export a service interface
To validate a service mapping
To add an operation
To update operation properties
To delete an operation


To import a service interface

  1. Open the service interface to import or the project containing it.
  2. Click File > Import Service Interfaces , and navigate to the directory containing the service interface you want to import.
  3. Double-click the .sie file containing the service interface that you want to import. The file is imported into the current project or service interface group. You will be able to see the imported interfaces in the service interfaces tree.
Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To update a service mapping
To delete a service mapping
To import a service interface
To export a service interface
To validate a service mapping
To add an operation
To update operation properties
To delete an operation


To specify a user exit for a service

  1. Open the Service Interfaces view, if it isn't already open.
  2. In Service Interfaces, right-click the service interface you want to specify a user exit for and click Settings .
  3. Click the Mapping Properties tab.
  4. Specify the name of your user exit program in Exit point handler program name.
  5. Click OK.
Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To specify a user exit for a service
To enable user exits for an operation
To define the run-time environment for a service


To update a service mapping

  1. Open the Service Interfaces view, if it isn't already open.
  2. In Service Interfaces, double-click the service interface you want to update. This starts the Interface Mapper.
  3. Make the desired changes to the operations in your service interface using the Interface Mapper.
  4. To save the updates, click File > Save.
Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To update a service mapping
To delete a service mapping
To import a service interface
To export a service interface
To validate a service mapping
To add an operation
To update operation properties
To delete an operation


To validate a service interface or workflow

  1. From the Solution Explorer, right-click the service interface or workflow you want to validate, and click Validate. Errors are reported in the Error List window.
  2. For service interfaces, continue as follows if an error is reported:
    1. Double-click the error to open the Service Interfaces Editor.
    2. Correct the error and close the Service Interfaces Editor.
    3. Repeat this process until the Error List window shows the message "The service mappings are valid."
Parent topic: Developing COBOL Applications
Parent topic: Manage Service Interface Projects
Related information
Workflow Capture Process


To create a COBOL program-based operation

  1. In the Service Interfaces Editor, right-click Operation, and click New.
  2. Define the new operation by specifying:
    • A name for the new operation
    • A program
    • An entry point, which you select from the list of entry points available in the program
    • Any user exits that you require
  3. If you want to automatically create interface fields for all of the fields associated with the entry point selected, check Create Default Mapping.
Parent topic: Developing COBOL Applications
Parent topic: Define Service Interfaces
Related information
Creating COBOL Program-based Operations
Operation Properties - COBOL Program/CICS Commarea-based Services - General tab
Operation Properties - User Exits tab
Operation Reorder


To delete an operation

  1. Open the Service Interfaces view, if it isn't already open.
  2. In Service Interfaces, double-click the service interface that contains the operation you want to delete. This starts the Interface Mapper.
  3. Select an operation from the Operation drop-down list.
  4. Right-click the Operation button and click Delete from the popup menu.
  5. Click Yes.
Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To update a service mapping
To delete a service mapping
To import a service interface
To export a service interface
To validate a service mapping
To add an operation
To update operation properties
To delete an operation


To enable user exits for an operation

  1. Open the Service Interfaces view, if it isn't already open.
  2. In the Service Interfaces window, double-click the service interface containing the operation you want to specify a user exit for.
  3. Click Operation > Properties.
  4. Click the User Exits tab user then check the check boxes for the exit points at which you want to provide extra processing in your user exit program.
  5. Click OK.
Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To specify a user exit for a service
To enable user exits for an operation
To define the run-time environment for a service


To update operation properties

  1. Open the Service Interfaces view, if it isn't already open.
  2. In Service Interfaces, double-click the service interface that contains the operation you want to update. This starts the Interface Mapper.
  3. Select an operation from the Operation drop-down list.
  4. Right-click the Operation button and click Properties from the popup menu.
  5. To change the name of the operation, type a new name into the Operation Name field.
  6. To change the entry point for the operation, select an alternate entry point from the Entry Point drop-down menu.
  7. To change the user exits for the operation, click the User Exits tab and change the check boxes as necessary.
  8. Click OK.
Tip: Use the context help available from the Quesicon button for information on individual fields and controls.
Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To update a service mapping
To delete a service mapping
To import a service interface
To export a service interface
To validate a service mapping
To add an operation
To update operation properties
To delete an operation


To generate a COBOL client from a Web service interface

  1. Open the Service Interfaces view, if it isn't already open.
  2. In Service Interfaces, right-click the service interface for which you want to generate a client.
  3. Click Generate Client.
  4. If a client for this service has been generated before, generation completes at once. Otherwise, select the project you want the client to be associated with. The default is for it to be associated with the currently open project, if any.
Tip: You can also generate a client from the WSDL file generated when you deployed the service.
Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To generate a COBOL client from a Web service interface
To generate a COBOL client from a WSDL file
To generate an EJB and a client
To generate an EJB without a client


To generate a COBOL client from a WSDL file

  1. Open the Service Interfaces view, if it isn't already open.
  2. In Service Interfaces, right-click the service interface for which you want to generate a client.
  3. Click Generate Client > Using WSDL.
  4. Select the WSDL file from which you want to generate the client and choose the project with which to associate the client..
Tip: You can also generate a client directly from a service mapping that you created using the Interface Mapper.
Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To generate a COBOL client from a Web service interface
To generate a COBOL client from a WSDL file
To generate an EJB and a client
To generate an EJB without a client


To generate an EJB and a client

  1. Consider making a copy of the COBOL archive file (.car) if one exists in the folder my-project\repos\my-service.deploy, because the .car file will be deleted when the client is generated. See the note below.
  2. In the Service Interfaces window, select the service interface for which you want to generate a client.
  3. Right-click the service interface for which you want to generate a client.
  4. Click Settings and specify the following:
    • On the General tab, choose EJB generation.
    • On the EJB Generation tab, choose the Application Server and its J2EE version. This ensures that the appropriate deployment descriptors are generated and packaged in the relevant archive files. If your application server is not listed, choose WebLogic 7.0, which will result in some deployment descriptors that you can ignore.
    • Also on the EJB Generation tab, specify the classpath of the J2EE SDK with which to compile the EJB.
    • Click OK.
  5. Generate Client.

    The archive files .ear .jar .war generated for the application, EJB and client are stored in the directory structure under my-project\repos\my-service.deploy.

  6. Consider making copies of the archive files (.ear .jar and .war), because they will be deleted if you subsequently use the Deploy tool to deploy the COBOL services to an enterprise server. See the note below.
Note:

The client generation process deletes all the files in the folder my-project\repos\my-service.deploy before it starts. It then creates the .ear .jar and .war files in that folder. Similarly the Deploy tool deletes all the files in that folder before it starts and then creates a .car file in that folder.

This means that before you generate a client, you need to make a copy of any .car file that you want to keep. You might want to keep the .car file so that you can copy it to another machine and deploy it from the command line there.

After you have generated the client, you need to make a copy the .ear .jar and .war files before using the Deploy tool. You can then deploy the .ear .jar and .war to your J2EE application server at any time.

Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To generate a COBOL client from a Web service interface
To generate a COBOL client from a WSDL file
To generate an EJB and a client
To generate an EJB without a client


To generate an EJB without a client

  1. Consider making copies of the archive files (.ear .jar and .war) if any exist in the folder my-project\repos\my-service.deploy, because they will be deleted when you use the Deploy tool to generate the EJB. See the note below.
  2. In the Service Interfaces window, right-click the service interface you want to generate an EJB for.
  3. Click Settings and specify the following:
    • On the General tab, choose EJB generation.
    • On the EJB Generation tab, choose the Application Server and its J2EE version. This ensures that the appropriate deployment descriptors are generated and packaged in the relevant archive files. If your application server is not listed, choose WebLogic 7.0, which will result in some deployment descriptors that you can ignore.
    • Also on the EJB Generation tab, specify the classpath of the J2EE SDK with which to compile the EJB.
    • Click OK.
  4. Deploy the COBOL service for the EJB to an enterprise server:
  5. Check the log in the output pane to confirm that the EJB is generated and compiled successfully. The EJB classes are stored in the directory structure under my-project\repos\my-service.deploy.
  6. Consider making a copy of the COBOL archive file (.car), if you intend to generate a client, because generating a client deletes the .car file. See the note below.
Note:

The Deploy tool deletes all the files in the folder my-project\repos\my-service.deploy before it starts. It then creates the .car file in that folder. Similarly the client generation process deletes all the files in that folder before it starts and then creates the .ear .jar and .war files in that folder.

This means that before you generate the EJB using the Deploy tool, you need to make a copy of any .ear .jar and .war files that you want to keep. You can then deploy the .ear .jar and .war to your J2EE application server at any time.

After you have generated the EJB, you need to make a copy the .car file before you generate a client. You might want to keep the .car file so that you can copy it to another machine and deploy it from the command line there.

Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To deploy a service interface using the Deploy tool
To generate a COBOL client from a Web service interface
To generate a COBOL client from a WSDL file
To generate an EJB and a client
To generate an EJB without a client


To generate a Java bean

  1. Consider making a copy of the COBOL archive file (.car) if one exists in the folder my-project\repos\my-service.deploy, because the .car file will be deleted when the Java bean is generated. See the note below.
  2. Open the Service Interfaces view, if it isn't already open.
  3. In Service Interfaces, right-click the service interface for which you want to generate a Java bean.
  4. Click Settings and accept or change the defaults as required.
  5. Deploy the COBOL service for the Java bean to an enterprise server:
  6. Check the log in the output pane to confirm that the Java bean is generated and compiled successfully. The Java classes are stored in the directory structure under my-project\repos\my-service.deploy.
  7. Consider making copies of the class files, because they will be deleted if you subsequently use the Deploy tool to deploy the COBOL services to an enterprise server. See the note below.
Note:

The Deploy tool deletes all the files in the folder my-project\repos\my-service.deploy before it starts. It then creates the Java bean class files in that folder.

This means that before you generate a Java bean, you need to make a copy of any .car file that you want to keep. You might want to keep the .car file so that you can copy it to another machine and deploy it from the command line there.

Parent topic: Developing COBOL Applications
Related tasks
To start interface mapping and open a service interface
Related information
To deploy a service interface using the Deploy tool
To generate a COBOL client from a Web service interface
To generate a COBOL client from a WSDL file
To generate an EJB and a client
To generate an EJB without a client


To deploy a service interface using the Deploy tool

  1. Start the enterprise server that you want to deploy to.
  2. If the enterprise server is running on a different machine, specify the machine in the Micro Focus Common Client (MFCC) configuration file, which by default is mf-client.dat in the base\bin directory of your COBOL development system installation. You can create your own configuration file of any name or location, but you must identify it using the MFC_CONFIG environment variable. .
  3. Open the Service Interfaces view, if it isn't already open.
  4. Right-click the service you want to deploy.
  5. Click Settings and specify the settings you want. In particular, click Change to display the Enterprise server dialog box to choose the deployment service to use. From that field, the enterprise server to deploy to is determined.
  6. Click Deploy and monitor the deployment in the Deployment Progress window that pops up. You can also confirm that the service has been successfully deployed by looking in the Enterprise Server Administration console.
  7. A COBOL archive file .car containing the service is generated in the folder myproject/repos/myservice.deploy.
Note:
  • To deploy a service interface that is mapped onto an EJB, you also need to deploy the EJB.
  • To deploy a service interface that is mapped onto a COM object, you also need to register the COM object in Windows.
  • When deploying a COBOL service program that uses object-oriented COBOL to an enterprise server, you must specify that any container used to run the service is not reused.
Parent topic: Developing COBOL Applications


To deploy to a remote enterprise server

  1. On the COBOL development system machine, open the file mf-client.dat in a text editor. By default this file is in the base\bin of your COBOL development system installation.
  2. Add the following line to the [directories] section of the file:
    mrpi://myESmachine

    where myESmachine is the name of the remote machine where your enterprise server runs.

    You can keep any existing lines that point to other machines running an enterprise server. You do not need to specify the port number. The default port number 86 is used.

  3. Save the file.
  4. Restart your COBOL development system if it is already running, so that the remote enterprise servers are available locally.
  5. Deploy the service interface using the Deploy tool.
Parent topic: Developing COBOL Applications


To redeploy a service interface

  1. Start the Enterprise Server Administration console.
  2. Delete the service from the enterprise server.
  3. Deploy the service either using the Deploy tool or manually.
  4. Confirm that the service has been successfully deployed by checking in Enterprise Server Administration.
Parent topic: Developing COBOL Applications
Related information
To access Enterprise Server Administration
To delete a service with operations
To deploy a service interface using the Deploy tool
To manually deploy a service interface
To view services for an enterprise server
Introduction to Enterprise Server Administration
Interface Mapping Toolkit
Deploying Interfaces
To install a COBOL archive file manually
To deploy to a remote enterprise server


To install a COBOL archive file manually

  1. You can generate a COBOL archive file (.car) using the Deploy tool or imtkmake command, if you don't already have one.
  2. In a text editor, open the file .mfdeploy on the machine where the enterprise server is running. This file is located in the deploy directory of your Enterprise Server or COBOL development system installation.
  3. Edit the MFES_SERVER line. By default this is set to ESDEMO. Change it to specify the name of the enterprise server you want to use, as follows:

    MFES_SERVER=myserver

  4. Make sure that the .mfdeploy file is in the parent directory of the .car file that you are installing. So, for example, if the .car file is in %COBDIR%\deploy\test , the .mfdeploy file must be in %COBDIR%\deploy .
  5. Install the COBOL archive file (.car) using the mfdepinst command. For example, to deploy the services in myservice.car, enter:
    mfdepinst myservice.car
Parent topic: Developing COBOL Applications
Related reference
imtkmake
Related information
To deploy a service interface using the Deploy tool
COBOL to Service Interface Data Type Matches
Deploying Interfaces
To manually deploy a service interface


Creating COBOL Solutions and Projects

Solutions are a Visual Studio concept. A solution is a container holding one or more projects that work together to create an application. Splitting your solution into a number of projects has several advantages:

  • Multiple users can work on a solution, as different users can work on different projects.
  • Breaking a solution down into a number of smaller projects makes them easier to handle and quicker to build.
  • The projects in a solution can be in different programming languages, so splitting your application into a number of projects enables you to take advantage of mixed language programming.
  • Solutions can contain projects, where some are compiled as managed code and some as native COBOL. You can use the various interoperability techniques to combine native COBOL with managed COBOL.

A solution has the extension .sln, and is a human readable text file, which you could edit, though we recommend that you use the Visual Studio IDE to do so.

A COBOL project has the extension .cblproj, and again is human readable. It is in msbuild format, which is explained in the Visual Studio Help. Different types of project have different extensions, so for example a C# project has the extension .csproj.

Templates for different types of COBOL projects are supplied. Each template creates the appropriate file structure to hold the project and defines the appropriate build settings. For example, the following COBOL project templates, among others, are supplied:

  • Mainframe Subsystem Application (native COBOL) - creates an empty solution and project. It offers project properties specific to the Mainframe applications such as BMS, CICS, IMS and JCL.
  • Windows Forms Application (managed code) - creates an empty Windows form and skeleton COBOL code behind the form. It adds the necessary .NET Framework classes, such as System.Windows.Forms to the project references. It creates default project properties.
  • Console Application (native COBOL) - adds the items needed to create a console application. Console applications are typically designed without a graphical user interface and are compiled into a stand-alone executable file. A console application is run from the command line with input and output information being exchanged between the command prompt and the running application.
  • Class Library (managed code) - creates reusable classes and components that can be shared with other projects. Typically, this is built into a .dll file.
  • Templates for Windows Presentation Foundation (WPF) and Windows Communication Foundation (WCF) (managed code).

See the Visual Studio Help for more information on solutions and projects.

  • Exploring Your COBOL Projects and Solutions
    You can use different windows on the IDE to explore and manage your solutions and projects.
  • Project and File Properties and Options
    You can set different project and file properties to control the way you build your COBOL projects.
  • Converting Net Express Projects to Visual Studio Projects
    The Net Express Project Import Wizard enables you to convert existing Net Express projects into Visual Studio solutions so you can use them with Studio Enterprise Edition.
  • Creating COBOL Projects from Existing Code
    The Create Projects from Existing Code wizard helps you choose and configure a Visual Studio project type to use, and imports your existing files.
  • Creating a New Project From Files in an Existing Project
    You can subdivide a COBOL project in your solution by selecting files in the project and using those to create a new project in the same solution. Splitting the code and moving parts of it into a different project could be useful if you need to move portions of the code to a dynamic library project.
Parent topic: Developing COBOL Applications


Exploring Your COBOL Projects and Solutions

You can use different windows on the IDE to explore and manage your solutions and projects.

Solution Explorer

Solution Explorer is the default window of Visual Studio for exploring and managing your solutions and projects. To open the window select View > Solution Explorer.

Solution Explorer displays the projects that form your solution, the files and folders in a project as they appear on the physical hard drive, and any assemblies, COM objects or files the project references. The context menus within Solution Explorer provide a variety of command that help you manage your projects.

Project Details Window

To open the window, select your project or solution in Solution Explorer and click Projects > Project Details Window.

The Project Details window shows a list of the files in a project or files in a solution along with various file details. In the window you can sort the files by a specific detail, double-click a file and open it in the editor, access the file properties from the context menu or reset the file directives.

The window includes the following columns:

Name
File name.
Type
Shows the file type such as CBL or CPY.
Error Count
Displays the number of compiler errors reported for a file.
Full Path
Displays the absolute file path on your hard drive.
Dialect
Shows the dialect of the COBOL files.
Directives
Informs the user if there are any directives set on the file that override the directives set for the project. Right-click a file in the window and select Properties to access the file properties. Alternatively, choose Reset Directives if you wish to apply the directives set in the global properties.
From the context menu for the file you can access the file properties or reset the directives on the file.

Parent topic: Creating COBOL Solutions and Projects


Project and File Properties and Options

You can set different project and file properties to control the way you build your COBOL projects.
  • Overview of COBOL Project Properties
    You can specify default properties that apply to the COBOL projects in all or selected build configurations, and to individual files in the projects. You can also configure the directives scan feature which automatically determines and sets Compiler directives on the COBOL source files in the IDE.
  • Options for Setting Directives when Scanning Files
    The IDE is configured to automatically perform a directives scan and set Compiler directives on any COBOL files you add to your projects. You can also start a directives scan manually using the Reset source directives context menu command in Solution Explorer. Each file is examined to determine the directives required and the directives are set on the file accordingly. However, if the directive is already set on the project, it is not set on the file.
  • Global Options
    The options you set in the IDE, in Tools > Options, apply to all COBOL projects.
  • Project Properties
    The COBOL project properties comprise some properties that apply to the project generally, regardless of the type of build, and some properties that apply to specific build configurations of the project, such as a debug build or release build.
  • To set COBOL project properties
    The properties set on project level apply to all files in the project.
  • To specify file properties
    Files inherit the properties set on project level. You can, however, specify individual file properties and they override the ones set on project level.
  • To choose options for setting directives when scanning files
    You can configure the directives scan feature in the IDE and specify what Compiler directives it can set.
  • To reset the directives on COBOL files
    This triggers a directives scann of the COBOL files in your project and sets Compiler directives on them as specified in Tools > Options > Projects > COBOL Project Settings.
Parent topic: Creating COBOL Solutions and Projects


Overview of COBOL Project Properties

You can specify default properties that apply to the COBOL projects in all or selected build configurations, and to individual files in the projects. You can also configure the directives scan feature which automatically determines and sets Compiler directives on the COBOL source files in the IDE.

After you have created a solution with one or more projects to hold your source code, you can set various project and file properties to control the way your applications build and execute.

For example, you can first set the project properties that apply to all files in the project in all or selected build configurations. Then you can modify the properties of the individual files in the projects if that’s necessary. If you change the file properties, they take precedence over the directives on project level.

In some cases, for certain project types and for multiple files, it might be useful to perform a directives scan – that is to trigger an automatic scan of all COBOL files in the project or solution to determine and set certain Compiler directives. By default, the IDE performs a directives scan of all COBOL files you add to your projects.

Project Properties

You can set project-level properties that can be specific to native and managed COBOL applications. You can set general properties that apply to all types of build as well as properties that apply to specific build configurations of the project, such as a debug or a release build.

Among the properties you can select are CICS, IMS, BMS, SQL and different debug options.

You can set different properties for the individual files included in your project. In this case the file properties override the ones set on project level.

Performing a Directives Scan and Setting Compiler Directives on Files

Restriction: It is possible to scan and determine the directives only for COBOL files that are part of native COBOL or Mainframe Subsystem Applications projects (native or managed). It is not possible to set Compiler directives on individual COBOL files for managed non-Mainframe Subsystem COBOL projects.
Performing a directives scan automatically
By default, the IDE is configured to automatically scan any new COBOL source files you add to the project. The scan assesses the code, determines what Compiler directives are required, and then automatically sets those directives on the files.

The IDE identifies and sets the COBOL dialect of the files or default CICS and SQL directives for the files that include EXEC CICS or EXEC SQL statements as specified in Tools > Options > Projects > COBOL Project Settings.

Triggering a directives scan manually
You can also trigger a directives scan of the COBOL files in your projects from Solution Explorer – right-click your project and select Reset source directives.

The directives identified through a directives scan are only set on individual COBOL files and override the directives set on project level. However, if the directive is already set on the project, it is not set on the file.

The options for a directives scan are project independent.

Viewing the results of a directives scan
Each time the IDE performs a directives scan, it displays the results in the Output window.

In cases when the scan sets or unsets a directive value, a description of the action, and the directive value set is shown. For example:

Scanning file C:\Users\Public\Documents\MyProject\ConfigReader.cbl
Setting SQL off
Setting Dialect MF
Scanning file C:\Users\Public\Documents\MyProject\Minesweeper.cbl
Setting SQL off
Setting Dialect MF
Scan complete.

After a directives scan completes and sets directives on the files, you can further modify the file properties.

File Properties

By default, the files that are included in your project inherit properties from the project level. You can modify the properties of individual files manually or trigger a directives scan to determine and set Compiler directives automatically. The file properties take precedence over the ones set on project level.

Depending on the file type, you can specify properties such as the COBOL dialect, CICS and SQL options, IMS specific options or any additional directives.

Parent topic: Project and File Properties and Options
Related information
Options for Setting Directives when Scanning Files
Project Properties
To specify file properties
To choose options for setting directives when scanning files
To reset the directives on COBOL files


Options for Setting Directives when Scanning Files

The IDE is configured to automatically perform a directives scan and set Compiler directives on any COBOL files you add to your projects. You can also start a directives scan manually using the Reset source directives context menu command in Solution Explorer. Each file is examined to determine the directives required and the directives are set on the file accordingly. However, if the directive is already set on the project, it is not set on the file.

For more on what a directives scan is see Overview of COBOL Project Properties.

Restriction: It is possible to scan and determine the directives only for COBOL files that are part of native COBOL or Mainframe Subsystem Applications projects (native or managed). It is not possible to set Compiler directives on individual COBOL files for managed non-Mainframe Subsystem COBOL projects.

You can configure the options that are set when performing a directives scan in Tools > Options > Projects and Solutions > COBOL Project Settings. The following directives are available:

  • DIALECT directive

    When a file is examined to determine the dialect, a list of possible dialects is produced. The possible dialects are then compared with:

    • The project dialect. If one of the possible dialects matches the project dialect, the DIALECT directive is not set on the file.
    • A list of dialects in priority order. The most likely dialect is chosen and the directive set on the file.
  • CICSECM or NOCICS directives

    Files that contain EXEC CICS statements might require the CICSECM directive with potentially additional options, such as "Abend at run time". If the directive required together with its options differs from the directive set on the project, the required directive is set on the file. For details of the options see COBOL Properties.

    You can also choose to set the NOCICS directive on files that don't contain CICSECM directives. The directives are then not applied at compile time, regardless of any CICS directives set on the project.

  • SQL directives

    Files that contain EXEC SQL statements require specific SQL directives.

    Note: You must choose the SQL directives that you want to set if they occur in the file. To do this you click the browse button and select the directives you want.

    If you do not select any directives, but only check the box, no directives are set.

    If any of the required directives are not set on the project, they are set on the file. If a required directive is already set on the project, it is not set on the file.

    You can also choose to unset SQL directives for this file. The directives are then not applied at compile time, regardless of any SQL directives set on the project.

Parent topic: Project and File Properties and Options
Related information
Overview of COBOL Project Properties
Project Properties
To specify file properties
To choose options for setting directives when scanning files
To reset the directives on COBOL files


Global Options

The options you set in the IDE, in Tools > Options, apply to all COBOL projects.
  • Text Editor General Options
    You set general options for the COBOL text editor in Tools > Options > Text Editor > COBOL, and on the General page.
  • Text Editor Tabs Options
    You specify options for the indents and for the Tab key in the COBOL text editor in the Tools > Options > Text Editor > COBOL, and on the Tabs page.
  • Text Editor Miscellaneous Options
    You can use the settings in Tools > Options > Text Editor > COBOL and on the Miscellaneous page to configure some additional features such as the formatting or some of the tooltips.
Parent topic: Project and File Properties and Options


Text Editor General Options

You set general options for the COBOL text editor in Tools > Options > Text Editor > COBOL, and on the General page.
Statement completion
Auto list members
Enables IntelliSense to automatically display a list of the available members of an object when writing code.
Hide advanced members
Hides the members that are marked internally as advanced.
Parameter information
Shows information about the parameters available for functions and procedures.
Settings
Enable virtual space
Enables writing in the editor after the end of a line of code.
Word wrap
Enables word wrap for lines of the code that are longer than the visible range.
Apply Cut or Copy command to blank lines when there is no selection
Enables you to copy or cut the blank lines in the code.
Display
Line numbers
Displays the line numbers in the editor.
Enable single-click URL navigation
Enables opening the URLs in the text with a single click of the mouse.
Navigation bar
Displays the navigation bar at the top of the COBOL editor which enables you to use the lists for objects and procedures.
Parent topic: Global Options


Text Editor Tabs Options

You specify options for the indents and for the Tab key in the COBOL text editor in the Tools > Options > Text Editor > COBOL, and on the Tabs page.
Indenting
None
Disables the automatic indenting of new lines of code.
Block
Indents a new line at the same tab position as the previous line.
Smart
Indents new lines of code according to the rules of the COBOL language.
Tab
Tab and indent size
Defines the number of spaces inserted when you press Tab or Enter. When programming in COBOL, the compiler expects the meaningful code to start from column eight. This is why it is convenient to have the tab character replaced by four spaces to reduce the risk of introducing compilation errors in the code.
Insert spaces
Replaces the tab character with the number of spaces specified in the Tab and indent size field.
Keep tabs
Inserts a tab character when you press Tab.
Parent topic: Global Options


Text Editor Miscellaneous Options

You can use the settings in Tools > Options > Text Editor > COBOL and on the Miscellaneous page to configure some additional features such as the formatting or some of the tooltips.
Formatting
Case format for identifiers
Specifies the case format of the identifiers in the built assembly.
Case format for reserved words
Specifies the case format of the COBOL reserved words in the built assembly.
Misc
Background syntax check timeout
Specifies the response time (in seconds) after which the background parse is aborted.
Copybook extensions
Specifies the file extensions that are recognized as copybook files. Separate the extensions by a comma.
Note: To ensure the file extensions will be recognized as COBOL copybooks, you also need to associate them with the COBOL language (from Tools > Options > Text Editor > File Extensions) and then add them to your project properties (type copyext(ext1,ext2) in Additional Directives on the COBOL page in your project's properties).
Customize editor for COBOL
Enables features that facilitate COBOL development, for example pressing Tab in the editor to position the cursor on the eighth column.
Debug tooltip style for subscripted OCCURS items
Specifies what information should be displayed by the debug tooltip.
Expandable tooltip
Choose this if you wish the tooltip to display the elements of arrays.
Value of expression
Choose this if you wish the tooltip to display the value of the current expression.
Note: You can switch between the two styles of the tooltip in the editor. To do this, press and hold Ctrl and hover over the data item to display the alternative tooltip.
Enable automatic outlining
Enables the outlining of the code.
Enable background syntax checking
Enables automatic syntax checking of the code as you type.
Parent topic: Global Options


Project Properties

The COBOL project properties comprise some properties that apply to the project generally, regardless of the type of build, and some properties that apply to specific build configurations of the project, such as a debug build or release build.

You access the properties of a projects from Project > <project> properties.

  • Application Properties for .NET Managed COBOL
    The Application property page for managed COBOL projects lets you specify properties such as the name of the target assembly file to build and output type, targeted version of the .NET framework or Startup object / Entry point .
  • Application Properties for Native COBOL
    The Application property page for native COBOL projects lets you specify properties such as the name of the file to build and entry point for the application.
  • Assembler Dependency Paths
    The paths you specify on this page take precedence over those specified in the SYSLIB environment variable in the MF370CTL.cfg configuration file.
  • Assembler Properties
    The properties you specify on the Assembler page in your project properties apply to the selected configuration.
  • BMS Properties
    The BMS page in the project properties lets you specify build settings for BMS compilations.
  • COBOL Properties
    The properties you specify on the COBOL page in your project properties apply to the selected configuration. If different from the project's properties, the properties set on file level take precedence over those set for the project.
  • Copybook Paths
    The Copybook Paths page in your project properties enables you to specify the paths to the directories in which this development system searches for copybook files.
  • Debug Properties
    The properties you specify on the Debug page of the project properties apply to the selected configuration.
  • IMS Properties
    The IMS pages in your project properties enable you to specify output folders for the generated files, or DBD, PSB or MFS build settings.
  • Link Settings
    You use Link Settings on the Build page in your project properties to link your native project to the run-time system and specify link parameters.
  • References
    The References page in the project properties lets you specify project references, import or update namespaces.
  • SQL Properties
    The SQL page in your project or file properties enables you to select an ESQL preprocessor and add SQL directives.
Parent topic: Project and File Properties and Options
Related reference
LIST
Related information
Overview of COBOL Project Properties
Options for Setting Directives when Scanning Files
To set COBOL project properties
To specify file properties
To choose options for setting directives when scanning files
To reset the directives on COBOL files


Application Properties for .NET Managed COBOL

The Application property page for managed COBOL projects lets you specify properties such as the name of the target assembly file to build and output type, targeted version of the .NET framework or Startup object / Entry point .
Assembly / Output name
The name of the target file to be built and the name of the output assembly. By default, this is the same as the project name. Equivalent to the ILASSEMBLY Compiler directive.
Default namespace
A design time only property that allows new classes to be automatically added to the default namespace.
Target framework
Previously, each version of Visual Studio targeted a specific .NET framework (.NET Framework version 2.0 was included with Visual Studio 2005, .NET Framework 3.0 was included with Windows Vista). Now, Visual Studio 2008 can target the .NET framework version that you specify. When you change the target framework, the IDE requires that you close the project and reload it.

When you migrate a project or solution that was created with an earlier version of Visual Studio, the target .NET framework version stays the same. For example, when you migrate a Visual Studio 2005 project to 2008, the .NET Framework version stays set to 2.0.

Output type
Defines the type of project to be built. This is one of console, library or windows. Console defines a console application (always an .exe), library defines a library project such as a collection of shareable classes (always a .dll), and windows defines a windows application. This is initialized depending on the type of new project the user creates. This is equivalent to ILGEN for a console application, ILGEN (SUB) for a library, and ILGEN(SUB) ILSUBSYSTEM(2) for a windows application.
Preserve case
Enable this options to prevent external symbols (such as Program-ID and names of called programs) being converted to upper case.
Compile to multiple assemblies
Check this if you want the build to create a separate assembly for each one of the COBOL source files that are part of your project.
If this option is not selected, the project compiles to a single assembly. In this case, the build takes into account only the project level directives, file level directives are ignored.
Note: This setting is available only for Visual COBOL 2010 Enterprise Option and Server Enterprise Edition for .NET .
Startup object / Entry point
Defines the method entry of the application, for .exe-based projects. If no entry name is specified for a Console or Windows application (.exe type), the first static method in the first program (in OO code) or the first procedure division (in procedural code) becomes the main entry point. The name needs to be the full method name as defined in the Program-ID (in order to include the namespace). Equivalent to the ILMAIN Compiler directive.

Assembly Information

Assembly Identity Attributes
Culture
The name of the culture this assembly supports. Equivalent to the ILCULTURE Compiler directive.
Version
The version of this assembly. Equivalent to the ILVERSION Compiler directive.
Assembly Information Attributes
Custom attributes in the assembly manifest for Company, Copyright, Product and Trademark. Equivalent to the ILCOMPANY, ILCOPYRIGHT, ILPRODUCT and ILTRADEMARK Compiler directives.
Assembly Manifest Attributes
Custom attributes in the assembly manifest for Description and Title. Equivalent to the ILDESCRIPTION and ILTITLE Compiler directives.
Assembly Strong Name Attributes
Delay Sign
Indicates whether you want to reserve space in the executable file for the strong name signature, but defer the actual signing until a later stage. Equivalent to the ILDELAYSIGN Compiler directive.
Key File
The name of a file that contains a key or key pair for strong naming the assembly. Equivalent to the ILKEYFILE Compiler directive.
Key Name
The name of container of a key or key pair that has been installed in the Crypto Service Provider (CSP). Equivalent to the ILKEYNAME Compiler directive.

Resources

The Resources section enables you to specify how the application resources will be managed. You can choose between "Icon and Manifest" or specifying a location for a resource file. The manifest can be used for User Account Control (UAC) configuration in Windows Vista or Windows Server 2008.

When you embed a custom manifest, an app.manifest file is added to the project. This file is placed in the Properties folder of the project.

Parent topic: Project Properties
Related information
Introduction to COBOL Development in Visual Studio


Application Properties for Native COBOL

The Application property page for native COBOL projects lets you specify properties such as the name of the file to build and entry point for the application.
Output name
Defines the name of the target file to be built. By default, this is the same as the project name.
Output type
Defines the type of project to be built. This is one of:
  • Console Application - defines a console application (always an .exe)
  • Link Library - defines a library project such as a collection of shareable classes (always a .dll)
  • Windows Application - defines a windows application
This is initialized depending on the type of new project you create.
Entry point
Defines the method entry of the application, for .exe-based projects. If no entry name is specified for a Console or Windows application (.exe type), the first static method in the first program (in OO code) or the first procedure division (in procedural code) becomes the main entry point. The name needs to be the full method name as defined in the Program-ID (in order to include the namespace).
Parent topic: Project Properties


Assembler Dependency Paths

The paths you specify on this page take precedence over those specified in the SYSLIB environment variable in the MF370CTL.cfg configuration file.
Folder
Add folders containing copybook or macro files to the list of Copybook/Macro Paths. The paths are added to the SYSLIB environment variable.
Note: The dependency paths you specify here take precedence over the paths specified in the SYSLIB environment variable in the m370ctl.cfg file, even if the mf370ctl.cfg file exists in the current project folder.
Copybook/Macro Paths
Shows the available dependency paths arranged in the order the IDE searches them. You can rearrange the list to change the order in which copybook\macro files are searched for copybooks or macro files.

By default, the IDE searches for copybooks and macro files in the following locations in priority order:

  1. If there are dependency paths set on this page, the search order is as follows:
    1. the project folder
    2. the paths in the Copybook/Macro Paths section in the order listed
    3. the include folder in your Studio Enterprise Edition installation
  2. If no dependency paths are set on this page, the SYSLIB dependency paths specified in the m370ctl.cfg configuration file are used instead.
Parent topic: Project Properties
Related concepts
Assembler Support
Assembler Emulation


Assembler Properties

The properties you specify on the Assembler page in your project properties apply to the selected configuration.

Assembler Tab

General
Create debug information
Check this to generate debug information at compile time.
Restriction: There is no interactive debugger for Assembler. It is recommended to use CTF with your Assembler applications to produce CTF (consolidated trace file) output. Note: There is an Assembler generalized trace facility (GTF) available for recording all Assembler instructions executed during a test run. This facility is turned on by the presence of the environment variable GTFFILE= and has various options for the amount of detail wanted in the trace file. Also, note that in an Enterprise Server environment the server running the Assembler modules must be stopped before the trace file can be accessed as the server will open the file for exclusive access.
Generate listing file
Check this to generate a listing file with optional cross-reference listing at compile time.
Create optimized code
Check this if you want the Assembler Compiler to make an extra pass of macro object code to resolve references to addresses. If the compilation of your program involves the execution of many macros, you can reduce the total compilation time by specifying this directive. This sets the OPT compiler directive.
Include cross reference listings
Check this to include cross reference listings when a listing file is created at compile time.
Mark module as reentrant
This has the same effect as marking code as serially reusable. Equivalent to setting the REENTRANT Compiler directive which controls reentrancy of a multithreading program. If you check this, many program areas are dynamically allocated, so that it is safe to have multiple copies of the program running.
Additional directives
Type here any additional directives that will be applied at compile time.
Preprocessor
Check EXEC CICS to specify whether the module includes EXEC CICS commands that need to be preprocessed. Note that if an Assembler copybook includes EXEC CICS commands you must perform some additional steps. The available EXEC CICS options are:
Insert standard prolog machine (DFHEIENT, DFHEIEND, DFHEISTG)
Check this to insert DFHEIENT, DFHEIEND, and DFHEISTG macros in the EXEC CICS code.
Insert standard epilog macro (DFHEIRET)
Check this to insert DFHEIRET macro in the EXEC CICS code.
Unsupported function handling
Specify how to unsupported CICS functions are handled in Assembler.
Unsupported option handling
Specify how to unsupported CICS options are handled in Assembler.
Link
Automatically link module
Check this when you link a single standalone Assembler module.
Auto-link options
  • Mark load module as serially reusable - Check this to prevent reloading of the module each time it is called.
  • Resolve external calls at link time - To link multiple Assembler modules where all the calls reference the external names of the called modules, you need to ensure that Automatically link module and Resolve external calls at link time are checked for the main module (the calling module) and unchecked for the called modules
  • Addressing mode or AMODE - indicates the memory requirements of an Assembler program. AMODE governs the type of addresses the program uses.

    There are two AMODE values:

    • AMODE(24) indicates 24-bit (three-byte) addressing - memory below the line.
    • AMODE(31) indicates 31-bit addressing - memory above and below the line.

    This product supports values of 24 and 31 for AMODE, since it emulates both types of addressing by mapping mainframe-style above and below the line addresses to real 32-bit PC memory addresses. An AMODE (24) program can only access memory below the line, while an AMODE(31) program can access memory both below and above the line.

  • Residency mode or an RMODE - indicates the memory requirements of an Assembler program. RMODE indicates where the program must be located when it is loaded for execution.

    There are two RMODE values:

    • RMODE(24) indicates that the program must be loaded into memory below the line.
    • RMODE(31) indicates that the program can be loaded either below or above the line.
  • Linker output - Specify what type of load module is to be produced, an executable code file or a data table.
Advanced
Use pre-assembled macros
Check this to use a valid pre-processed macro file (.mpc) that might be found in your project directory as input to the assembly phase, rather than running the macro pre-process phase. If a valid .mpc file is not found or one is found but it predates the corresponding macro source file, compile the macro from source and save it as an .mpc file for future use. This setting is equivalent to setting the MPC Compiler directive.
Create Assembler Analysis Tool (AAT) information
Check this to generate reports from the Assembler Analysis Tool (AAT) during the Assembler compilation. These reports are files that assist in the analysis of Assembler programs. Equivalent to setting the AAT directive.
&SYSPARM substitution value
For the Assembler programs in your project that need SYSPARM settings, type the value that you wish to be substituted for occurrences of &SYSPARM in user macros. Provide a value for $SYSPARM, which is a variable that can be used within an Assembler module to determine which parts of the code to assemble.
Build settings
A read-only field that shows all Assembler Compiler directives that are set for your project at the compile phase.

Linker Tab

General
Create debug information
Check this to create debug information when linking the code.
Restriction: There is no interactive debugger for Assembler. It is recommended to use CTF with your Assembler applications to produce CTF (consolidated trace file) output. Note: There is an Assembler generalized trace facility (GTF) available for recording all Assembler instructions executed during a test run. This facility is turned on by the presence of the environment variable GTFFILE= and has various options for the amount of detail wanted in the trace file. Also, note that in an Enterprise Server environment the server running the Assembler modules must be stopped before the trace file can be accessed as the server will open the file for exclusive access.
Mark load module as reentrant
Check this to mark that the load module to link is reentrant.
Mark load module as serially reusable
Check this to prevent reloading of the module each time it is called.
Resolve external calls at link time
Check this when you link multiple Assembler modules where all the calls reference the external names of the called modules. Uncheck this if you want to link modules dynamically at run-time.
Generate listing file
Check this to generate a listing file with optional cross-reference listing during the link phase.
Addressing mode
Also known as AMODE. Indicates the memory requirements of an Assembler program. AMODE governs the type of addresses the program uses.

There are two AMODE values:

  • AMODE(24) indicates 24-bit (three-byte) addressing - memory below the line.
  • AMODE(31) indicates 31-bit addressing - memory above and below the line.

This product supports values of 24 and 31 for AMODE, since it emulates both types of addressing by mapping mainframe-style above and below the line addresses to real 32-bit PC memory addresses. An AMODE (24) program can only access memory below the line, while an AMODE(31) program can access memory both below and above the line.

Additional directives
Type here any additional directives that apply during the link phase.
Advanced
Rename output to alias name
Use this command to create an alias for the executable file that you are building. The alias is created in the entry point mapping file, mfentmap.dat.
Residency mode
Also know as RMODE. Indicates the memory requirements of an Assembler program. RMODE indicates where the program must be located when it is loaded for execution.

There are two RMODE values:

  • RMODE(24) indicates that the program must be loaded into memory below the line.
  • RMODE(31) indicates that the program can be loaded either below or above the line.
Linker output
Specify what type of load module is to be produced, an executable code file or a data table.
Build settings
A read-only field that shows all directives that will be applied during the linking phase.
Parent topic: Project Properties
Related concepts
Assembler Support
Assembler Emulation


BMS Properties

The BMS page in the project properties lets you specify build settings for BMS compilations.
Note: These settings are available only for Visual COBOL 2010 Enterprise Option and Server Enterprise Edition for .NET .

Compile

Additional Directives
Specify any additional directives to pass to the BMS compiler. Use space to separate the directives.
Align Map
Specify whether to align the fields on a halfword boundary.
Create Copybook
Specify whether to generate the copybook for the mapset.
Create Load Module
Specify whether to generate the BMS mapset .mod file.
High level assembler features
Specify whether to use long labels for macros in the .bms files. Equivalent to the HLL option of the BMS compiler.
Hyphenate Field Name
Specify whether to enable hyphenated suffices for fields.
Levels
Specify the COBOL levels to use when the copybook is generated (copybook start level and increment).
Map as Prefix
Specify if you want the map name to be used as a prefix.
Prefix
Specify the SDF prefix to be used for SDF data items generated in the copybook.
Prefix Separator
Specify the character that should separate the prefix from the name of an individual field. This option is used only when either Map as Prefix is set to Yes or a Prefix is specified.
Redefine Input Maps
Specify if each field's attribute byte should redefine the flag byte in the input map.
SDF Map Size
Specify whether to generate map length in the copybook for SDF mapsets.

General

Copybook Output Path
Specify a path for the generated copybook files different than the default one.
Load Module Output Path
Specify a path for the generated .mod file different than the default one.
SDF
Specify whether to use SDF comments for parse and compile.

Parse

Keep Preprocessor File
Specify whether to keep the preprocessor file created by the Assembler preprocessor.
Use Assembler Preprocessor
Specify whether to execute the Assembler preprocessor before parsing the file.
Parent topic: Project Properties


COBOL Properties

The properties you specify on the COBOL page in your project properties apply to the selected configuration. If different from the project's properties, the properties set on file level take precedence over those set for the project.

General

Managed code
Specify whether the code is managed, native or verifiable.
Platform target
The target platform, such as x86, x64 or Any CPU. Any CPU is available for managed code projects only. Valid values are given in the drop-down list.

For .NET managed projects, this is equivalent to the ILTARGET Compiler directive.

Tip: Avoid building your managed projects for Any CPU if they include ActiveX references. Instead, set the particular target platform to either x86 or x64 to match the targeting of the ActiveX control.
Additional copybook paths
The paths to search for copybook files that apply only to the selected build configuration of the current project. This enables you, for example, to have different copybook paths for debug and release builds. Use semicolon as a delimiter when entering multiple copybook paths.

This option sets the COBCPY environment variable, which is appended with the COBCPY setting in the Registry.

You can specify general copybook paths that apply to the project regardless of the active build configuration on the Copybook Paths page of your project properties. The configuration-specific copybook paths take precedence over the project copybook paths.

Generate debugging information
Value of true or false, to determine whether or not to generate debugging information.
Build Events
The commands to be executed before or after the build and when to execute them. See the Visual Studio Help for details.
Generate 64-bit pointers
This setting is available for managed projects only. Compiles the project with 64-bit pointer support enabled. Equivalent to the P64 Compiler directive.
Source Format
The default source format for source files. This is one of Fixed, Variable, or Free. Equivalent to the SOURCEFORMAT Compiler directive, but can be overridden (and often is) by using a $set statement in the source code.

Native

The following properties are specific for the native COBOL projects:

COBOL dialect
Specify the COBOL dialect used by your code. This sets the DIALECT Compiler directive for the project accordingly.
EXEC CICS
Check this to specify CICS options for your project.

Click Options to set CICSECM options as follows:

Unsupported function handling
Choose the behavior if the source code contains an unsupported CICS function. This applies only to functions that are recognized (but unsupported) by the CICS preprocessor.
Compiler error
The default is that the CICS preprocessor treats unsupported CICS functions as Compiler errors.
Treat as comment
Any unsupported functions are treated as comments (that is, ignored).
Abend at runtime
Any unsupported functions result in an abend at run time.
Unsupported option handling
Choose the behavior if the source code contains an unsupported option. This applies only to options that are recognized (but unsupported) by the CICS preprocessor.
  • Compiler error - the default is that the CICS preprocessor treats unsupported CICS options as Compiler errors
  • Treat as comment - any unsupported options are treated as comments (that is, ignored by the preprocessor)
  • Abend at runtime - any unsupported options result in an abend at run time
  • Ignore at runtime - any unsupported options are ignored at run time
Additional CICSECM options
Specify additional CICS directives for your project as required. The syntax is as follows: CICSECM (option=setting). For example, CICSECM(EXCI=YES).
Link Settings
Specify different linking options such as the type of the Runtime Library and the thread model, or link to any subprograms needed by your application. See Link Settings for more.
EXEC DLI
Check this if your programs contain EXEC DLI statements.

Click Options to set EXEC DLI options as follows:

DIB Group name
Specify the name of the DL/I Interface Block (DIB) group placed in your application program by the preprocessor at 01 level, or accept the default value, DLZDIB.
DIBVER value
Specify the version of the DL/I Interface Block (DIB) group placed in your application program by the preprocessor at 01 level or accept the default value. This field is provided for compatibility with IMS/ESA.
Additional directives
Specify any additional IMS preprocessor directives.

Errors and Warnings

The Errors and Warnings fields enable you to choose what warnings and errors will be displayed when you build the specified configuration.

Warning level
Specifies the severity of errors or the warning messages that are displayed in the output console.
Stop after
Specifies the maximum number of errors or the warning messages that will be displayed during the build.
Treat warnings as errors
Stops the build when a warning is received.
Raise ECM error level to Severe (Level S)
Changes all ECM warnings and errors to Severe errors and fails the build.

Additional Directives

This field enables you to specify additional COBOL Compiler directives to pass to the Compiler.

Output

Output path
The directory to contain the built output files. Equivalent to the ILOUTPUT Compiler directive.
XML documentation file
Generates documentation in XML format that includes the comments you have made in the source code about the used methods and classes. Equivalent to the ILDOC Compiler directive.
Register for COM interop
Value of true or false, to determine whether or not to register the build output as a COM component, which allows non-.NET code to use the project as if it was a COM object.
Generate directives file
Generates a file containing the directives that are used to compile the project. The file is named project name.dir and is placed in the project directory.
Parent topic: Project Properties
Related reference
LIST


Copybook Paths

The Copybook Paths page in your project properties enables you to specify the paths to the directories in which this development system searches for copybook files.

This sets the COBCPY environment variable, which is appended with the COBCPY setting in the Registry.

Note: There are additional copybook paths that apply only for specific build configurations. You specify these on the COBOL page of the project properties. The configuration-specific copybook paths take precedence over the project copybook paths.
Parent topic: Project Properties
Related information
Order in which Copybooks Are Searched For


Debug Properties

The properties you specify on the Debug page of the project properties apply to the selected configuration.

Start Action

Start project
Specifies that the project is to be debugged by launching its output.
Note: This setting does not apply to managed class library projects, or to native projects that compile to multiple library files. For these project types, you must specify a different start action.
Start external program
The path to a file to be debugged.

This setting is typically used when your application is a library.

Start browser with URL
Starts debugging by opening a web page.

Start Options

Command line arguments
Program arguments to be passed.
Working directory
The directory from which the program is launched.
Use remote machine
The name of the machine on which the program to be debugged resides.

Managed Code

The following properties are specific for managed COBOL projects:

Enable SQL Server debugging
Enables the Microsoft SQL debugger.
Redirect standard output
Value of true or false, to determine whether or not standard output (such as System.Console.WriteLine) should be redirected to the debugger's output window. For Console projects, this is initially set to False, and for Windows projects it is initially set to true.
Note: This feature does not work for 64-bit applications and on 64-bit machines it is supported only by a x86 platform type.
Enable mixed mode debugging
Check this to enable debugging of C/C++ code alongside managed code.

Native Code

The following properties are specific for native COBOL projects:

Use multi-threaded run-time
Select this to specify that the project is to be debugged using the multi-threaded run-time system.
Wait for animatable attachment
Check this to debug dynamic link libraries. The debugger waits for the program to start in a separate process before attempting to attach to it.

Uncheck this if you are not debugging a dynamic link library, otherwise debugging is suspended while waiting for a separate process that doesn't exist.

CICS, JCL, IMS, Web Service and Core Dump Debug Properties

The following debug properties apply only to applications that run on an Enterprise Server. They appear on the Debug page of the Mainframe Subsystem Applications.

Click the tab for the type of service or application that you want to debug and enter its details.

Choose Active Settings
Specify whether you debug a CICS, a JCL, an IMS application, a Web service, or a coredump file.
Region
Note: These settings are available only for Mainframe Managed Subsystem Applications in Visual COBOL 2010 Enterprise Option and Server Enterprise Edition for .NET .
Specify details for connecting to a database server.
Database Server Instance
The name of the database server that hosts the application to debug.
Region Name
The name of the region that hosts the application to debug.
Properties on the CICS tab
User
The CICS user id used to start the application.
Terminal
The CICS terminal id used to start the application.
Transaction
The CICS transaction for the application.
Link-level program
The CICS invoked program at which to start debugging.
Properties on the JCL tab
Job name
The name of the job.
Job number
The number of the job in the held queue.
Step name
The step that you want to debug.
Top-level program
The program id of the program that you want to debug.
Properties on the IMS tab
User
The user id to be used when debugging this application.
Terminal
The logical terminal ID to be used when debugging this application. This is the eight-character name of the TN3270 connection within Enterprise Server that is either allocated dynamically or specified by the TN3270 client emulator.
Transaction
The transaction to be used when debugging this application.
Top-level program
The start program to be used when debugging this application.
Properties on the Web Service tab
Client IP Address
Leave this field empty to enable debugging from any IP address. Specify an IP address to allow debugging only from it.
Service
Specify the address of the web service to debug. Enter the address and any specific operation that is part of the web service in the following format - http://namespace/ServiceName#OperationName
Properties on the Core Dump tab
File Name
Specify the name and the path to the core dump file to use for debugging your application.
Parent topic: Project Properties
Related concepts
Wait for Debuggable Attachment and Native COBOL
Related information
Overview - Debugging Native COBOL Programs


IMS Properties

The IMS pages in your project properties enable you to specify output folders for the generated files, or DBD, PSB or MFS build settings.

You can specify the following properties:

Output Folders
Generated files
Use this field to specify the folder to contain the output from the generation of the DBD and the PSB files in your project.
MFS Output
Use this field to specify the folder to contain the output from the generation of the MFS files in your project.
IMS Databases
Use this field to specify the folder to use when looking for IMS databases for the current project.
DBD Build Settings
Message level
Choose the level of error message reporting when generating DBDs.

Levels are cumulative, that is, if you select Severe, you only see Severe errors, while if you select Error, you see messages at Severe and Error level, and if you select Warning, you see all messages.

Generate listing file
Check this to generate a listing file, filename.lst, containing the original DBD source statements with any warning or error messages included, for each filename.dbd file in your project.

By default, the files are saved in a Listing subfolder within the project directory. To specify a different location for the files, type LIST"path\*.lst" in the Additional Directives field for the DBD build settings.

Rebuilding the project updates all listing files. Cleaning the project deletes the listing files.

Generate Map for DBD
Check this to cause the DBDMAP utility to be run and generate a .MAP file in the directory of the .DBD source file.
Additional directives
Specify any DBDGEN directives to be used when genning DBD files in the current project. Separate directives with a space.
PSB Build Settings
Message level
Choose the level of error message reporting for PSBGEN.

Levels are cumulative, that is, if you select Severe, you only see Severe errors, while if you select Error, you see messages at Severe and Error level, and if you select Warning, you see all messages.

Generate listing file
Check this to generate a listing file, filename.lst, containing the original PSB source statements with any warning or error messages included, for each filename.psb file in your project.

By default, the files are saved in a Listing subfolder within the project directory. To specify a different location for the files, type LIST"path\*.lst" in the Additional Directives field for the PSB build settings.

Rebuilding the project updates all listing files. Cleaning the project deletes the listing files.

Validate PSB against DBDGENs
Check this to validate the genned PSB against the current DBDGEN library.

If Generate listing file is checked, the validation report will appear in the listing after the PSB source statements.

Additional directives
Specify any PSBGEN directives to be used when genning PSB files in the current project. Separate directives with a space.
MFS Build Settings
Message level
Choose the level of error message reporting for MFSGEN.

Levels are cumulative, that is, if you select Severe, you only see Severe errors, while if you select Error, you see messages at Severe and Error level, and if you select Warning, you see all messages.

Generate listing file
Check this to generate a listing file, filename.lst, containing the original MFS source statements with any warning or error messages included, for each filename.mfs file in your project.

By default, the files are saved in a Listing subfolder within the project directory. To specify a different location for the files, type LIST"path\*.lst" in the Additional Directives field for the MFS build settings.

Rebuilding the project updates all listing files. Cleaning the project deletes the listing files.

STACK handling
Choose a method of processing STACK and UNSTACK statements. The STACK and UNSTACK statements are often used to define different device types for one format. With Mainframe Subsystem Support, only one device type can be 'active' at a time, thus, the STACKs for the other device types are not needed and would slow the processing of the MFSGEN.
Parent topic: Project Properties
Related reference
LIST


Link Settings

You use Link Settings on the Build page in your project properties to link your native project to the run-time system and specify link parameters.

Runtime Library

Static
Click this to link the application to the static run-time system. The run-time system is linked into your executable file.

Click this if you are building a monolithic application either as a standalone executable or as a DLL that will be called by a non-COBOL program.

Shared
Click this to link the application to the shared run-time system. The run-time system is not linked into your executable files, but is loaded dynamically when your application is run.

Click this if you are building a modular application, or a DLL that will be called by a COBOL program.

Dynamic
Check this to bind the application to run-time system dynamically at run time. The application binds to any appropriate run-time system on the end-user's system when it is run. The COBOL run-time system files are automatically located on the end-user's system by looking them up in the Windows Registry.
If you don't select this, your application requires the run-time system supplied with this version of your COBOL development system to be available on the end-user's system. You need to install the run-time system files in the same directory as your application's executable file.
Bind to current RTS only
Select this to dynamically bind the application to a run-time system of the same version (or later) as your COBOL development system.

If you don't select this, the application binds to any suitable run-time system on the end-user's system.

Thread Model

Single-threaded
Click this if you want the application to be linked with the single-threaded run-time system.
Multi-threaded
Click this if you want the application to be linked with the multi-threaded run-time system.
Either
Click this if you have chosen dynamic binding for the shared run-time system and you do not care whether the application binds to the single or to the multi-threaded system.

Link Level

If you want to debug statically linked system executable files or dynamic link libraries, ensure that you have selected the Static option under Runtime Library.

Lite
Click this if you want your application to be statically linked with the lite run-time system.

The lite run-time system is a smaller version of the run-time system that includes sufficient support for many statically linked COBOL applications consisting of .obj files only. Do not use it if you need support for any of the following:

  • Micro Focus library (.lbr) files
  • Run-time system configuration using COBCONFIG
  • Shared memory allocation
  • DD_ name mapping
Base
Click this if you want your application to be statically linked with the base run-time system.

The base run-time system is the default run-time system for statically linked executable files. It provides all support needed for linking COBOL applications consisting of .obj files only. Do not use it if you need support for the following:

  • Micro Focus library (.lbr) files
Full
Click this if you want your application to be statically linked with the full run-time system.

The full run-time system is a slightly larger run-time system that provides full support for all COBOL applications, including support for Micro Focus library (.lbr) files.

Linker Parameters

Link with obj's
Type the names of any .obj files you want to link with this system executable file. Alternatively, you can add them to the Project tree view under the .exe file.
Link with libs
Type the names of any library (.lib) files you want to link with this system executable file. Alternatively, you can add them to the Project tree view under the .exe file.
Additional directives
Type any additional parameters you want to pass to the Cbllink utility. For a list of possible directives, see the command-line reference in the Reference Bookshelf in help, or look up Cbllink utility in the help index.
Entry point
Type the root name of the object file that contains the first module of code to be executed in your application. The root name is the filename without the .obj extension.
Output name
Specify a name for the output application file which can be different for the different configurations.
Keep temporary files
Select this if you don't want temporary files created when linking to be deleted. Temporary files include import libraries, definition (.def) files, and .lnk files.
Include system programs
Select this if you want any run-time system support modules needed by your application to be automatically linked with it. Run-time support modules provide support for the following:
  • User-defined classes in SPECIAL NAMES paragraphs
  • EXTERNAL files and data
  • Enhanced ACCEPT and DISPLAY syntax
  • Intrinsic functions
  • PC_PRINT library routines

If you don't select this, you need to link any support modules needed by adding them to your project.

If your application needs run-time support other than that listed above, you need to link in the appropriate modules by adding them to your project.

Generate map file
Select this to create a .map file when your application is rebuilt. The linker map file contains information such as a timestamp, a preferred loading address, a list of public entry points used in the linked object files, and a fixup (load offset) table.
Graphical application
Check this if your application uses a graphical user interface.
Verbose output
Select this if you want all notes and messages from the Linker to be displayed in the Output window. Messages that use the LNK prefix are from the Linker, and are explained in more detail in the Microsoft Win32 Software Development Kit.
Parent topic: Project Properties
Related information
Overview of Linking Native COBOL Applications and Run-time Systems


References

The References page in the project properties lets you specify project references, import or update namespaces.
Reference Paths
Specify the paths to the locations of the assemblies containing classes that are used by the project.
References
If you write code that uses other classes in other assemblies, you can add the assemblies as references in this window. This is equivalent to the ILREF compiler directive.
Imported namespaces
Enables you to add namespaces to the project. This is equivalent to the ILUSING compiler directive.
Update Namespace
Enables you to specify a different name for an imported namespace.

Alternatively, you can add project references from Solution Explorer. See Tutorial: Developing .NET Managed COBOL.

Parent topic: Project Properties
Related information
Tutorial: Developing .NET Managed COBOL


SQL Properties

The SQL page in your project or file properties enables you to select an ESQL preprocessor and add SQL directives.
ESQL Preprocessor
Select the preprocessor you want to handle your embedded SQL code.
Directives
Displays the directives that are set for your project.
Directive Details
Directive
Shows the selected directive.
Value
Enables you to change the value available for the selected directive.
Disabled
Check this check box to prefix the directive with NO (e.g. ACCESS becomes NOACCESS).
Note: This check box is only enabled when the NO- form of the directive is valid.
Description
Explains the function of the selected directive.
SQL Directives
Displays the directives that are set for your project for the selected ESQL preprocessor.
Parent topic: Project Properties


To set COBOL project properties

The properties set on project level apply to all files in the project.
  1. In Solution Explorer, click the project whose properties you want to set.
  2. Click Project > project_name properties.
  3. Click a tab in the left hand side of the editor to open a particular properties page.
  4. Set the properties as required.
  5. Click File > Save All to save your changes.
Parent topic: Project and File Properties and Options
Related information
To specify file properties
To choose options for setting directives when scanning files
To reset the directives on COBOL files
Project Properties


To specify file properties

Files inherit the properties set on project level. You can, however, specify individual file properties and they override the ones set on project level.
  1. In Solution Explorer, right-click one or more files whose properties you want to set.
  2. Click Properties.
  3. For files used in the COBOL projects such as .cbl , .jcl and .vse or .dbd, .mfs and .psb, set the options and directives you require.

    For example, for JCL files you can specify the JCL File Type in the Misc section of the file properties.

  4. Click OK or press Enter as required.
Parent topic: Project and File Properties and Options
Related information
To set COBOL project properties
To choose options for setting directives when scanning files
To reset the directives on COBOL files
Project Properties
Overview of COBOL Project Properties
Options for Setting Directives when Scanning Files


To choose options for setting directives when scanning files

You can configure the directives scan feature in the IDE and specify what Compiler directives it can set.
  1. Click Tools > Options.
  2. Expand Projects and Solutions.
  3. Click COBOL Project Settings.
  4. To determine the COBOL dialect of the files and set the DIALECT directive, check Set the DIALECT directive on files.

    The dialect directive is set only if it differs from the directive set for the project.

  5. Check Set CICSECM directive on files containing EXEC CICS, if required.

    The CICSECM() directive is set on files that contain an EXEC CICS statement.

  6. Check Set NOCICS directive on files that do not contain EXEC CICS, if required.

    When this directive is set on a file, it overrides any CICSECM directive set on the project.

  7. Check Set SQL directives on files containing EXEC SQL, if required.

    Click [image] and choose the SQL directives to set if they occur in the file.

    Note: You must select the directives you require, as well as check the box or no directives are set on the files.
  8. Check Unset SQL directives on files that do not contain EXEC SQL, if required.

    When SQL directives are unset on a file, they override any SQL setting on the project.

Tip:
  • The status bar identifies the file currently being scanned for directives
  • The output window shows the directives being set on each file
  • To interrupt and stop setting directives, click Project > Cancel file scanning
Parent topic: Project and File Properties and Options
Related information
To set COBOL project properties
To specify file properties
To reset the directives on COBOL files
Overview of COBOL Project Properties
Options for Setting Directives when Scanning Files
Project Properties


To reset the directives on COBOL files

This triggers a directives scann of the COBOL files in your project and sets Compiler directives on them as specified in Tools > Options > Projects > COBOL Project Settings.
  1. If necessary, check and ensure the options for setting directives are the ones you require. Click Tools > Options > Projects and Solutions > COBOL Project Settings.
  2. In Solution Explorer, right-click your project or the file whose directives you want to reset.
  3. Click Reset source directives.
    Each file is handled in turn, as follows:
    • The existing directives are removed
    • The file is scanned to determine the directives currently required
    • Directives are set on the files as specified in COBOL Project Settings.

      If the directive is already set on project level, it is not reset on file level.

  4. Check the Output window to see the results of the directives scanning.

    It shows which files were scanned and what directives have been set or unset on them.

Parent topic: Project and File Properties and Options
Related information
To set COBOL project properties
To specify file properties
To choose options for setting directives when scanning files
Overview of COBOL Project Properties
Options for Setting Directives when Scanning Files
Project Properties


Converting Net Express Projects to Visual Studio Projects

The wizard analyzes the Net Express project file, its configuration settings and the dependencies set, and creates one or more Visual Studio native projects based on this information, imports the existing source code into them, and sets the requisite project and file properties from the original Net Express project. It can optionally produce and display a detailed conversion report.

The wizard takes the following information from the Net Express project:
  • file dependencies and all output file types produced by the project
  • the type of application that is being built, such as a console application or a library
  • the build configurations such as Generic Debug Build and Generic Release Build
  • the paths for copybooks that aren't in known locations such as the solution folder tree, links from the solution, and the cpylib folder in the installation
  • the Compiler directives and build settings
  • how the application starts, such as any command line arguments
Note: If you have any questions or comments about the Net Express Project Import Wizard or upgrading to Studio Enterprise Edition in general, please use the Micro Focus Community pages (http://community.microfocus.com/Home) to get in touch with us and other Studio Enterprise Edition users.

The structure of a Net Express project is similar to that of a Visual Studio solution, where the solution represents a whole application. A solution can contain multiple projects, each one producing a single or multiple output files. The final application then can contain a mixture of .exe or .dll files files.

Visual Studio projects and project types
Depending on the output files they produced in the available configurations (for example, Generic Debug Build or Generic Release Build), Net Express projects convert to different Visual Studio project types as shown below:
Files created by the Net Express project | Visual Studio project type after the conversion
A single output file | A single Visual Studio project
A mixture of executable files - .exe and .dll files | Multiple Visual Studio projects in the same solution, each of which produces single or multiple executables - .exe or .dll files.
.int or .gnt files only | The import wizard prompts you to specify the type of Visual Studio project to create (INT/GNT being the default one, Console, Link Library, or Windows Forms) and the files it will include.
.lbr files only For each .lbr in the Net Express project, the wizard creates a corresponding INT/GNT project that compiles to a single .lbr file.
Note: The .lbr files produced by Studio Enterprise Edition can only contain COBOL source files and cannot include data files.

You can copy any data files that are part of the project to the output folder but they will exist as separate files and will not be packaged in the .lbr. To configure this, set Copy To Output Directory in the properties of the data file.

A combination of different output file types (.int, .gnt, .lbr, .exe or .dll) | One project for each .lbr, .exe or .dll file, and the wizard prompts you to specify a project type for the .int and .gnt files as detailed above.
Copybook paths
Copybook paths are determined by how the Visual Studio project is structured and by what dependency each file has. If a file depends on another file in a different folder, that folder is added to the copybook paths.
Directives
The directives set on project or file level are taken from the Net Express project.

For more on upgrading Net Express applications to Studio Enterprise Edition, see Upgrading to Studio Enterprise Edition.

  • To import Net Express projects into the Visual Studio IDE
  • Restrictions and Limitations to Converting Net Express Projects
    The Net Express Project Import Wizard enables you to convert existing Net Express projects into Visual Studio solutions so you can use them with Studio Enterprise Edition.
Parent topic: Creating COBOL Solutions and Projects


To import Net Express projects into the Visual Studio IDE

To use the Net Express Project Import Wizard:

  1. Ensure that your Net Express project and all relevant files are available and in the same location.
  2. Ensure any file extensions that are not traditionally associated with COBOL will be recognized as COBOL programs or copybooks.

    Read To associate file extensions with COBOL and To specify that a file extension is a copybook for details.

  3. Start the Net Express Project Import Wizard to convert the Net Express project file:
    1. In Windows Explorer, locate and double-click the Net Express .app file or, in Visual Studio, click File > Open > Project/Solution.
    2. In the Open Project dialog box, set the file type filter to Net Express Project Files (*.app) and browse to the location of the Net Express project.
    3. Select the Net Express .app file to convert and click Open.

      This starts the Visual Studio Conversion Wizard.

    4. Click Finish to skip the Visual Studio Conversion Wizard and start the Net Express Project Import Wizard.
  4. Select the Net Express project you want to convert and click Continue.

    During this first stage, the wizard analyzes the Net Express project and displays the information about the build configurations, copybook paths, the components to which the project compiles and the directives that are set on the source files. Based on these, the wizard will then create a solution with one or more projects be used in the Visual Studio project.

  5. On the Summary tab check Generate Conversion Report if you wish to create and review the details of the conversion.
  6. Click Finish to start the conversion.
  7. If your Net Express project compiled to .int or .gnt code, the wizard opens the Int/Gnt upgrade questions dialog box prompting you to set your preferences for a Visual Studio project in your solution that will contain the files that compiled to .int or .gnt. Specify your preferences and click Continue.

    The wizard creates a Visual Studio solution with one or more projects for the COBOL code and creates a conversion report file.

  8. Review the report to double check that the project has converted as you expected.
  9. Review the files in Solution Explorer. You should see:
    • One solution representing your Net Express project
    • One or more native COBOL projects within the solution, where each project builds output files of the same output file type
    • Any files that were in the original project, such as COBOL source files and copybooks
  10. Review the project properties, by right-clicking the project in Solution Explorer and clicking Properties. Notice the following properties:
    • Application - these properties show the type of application that is built, such as a console application or a library
    • Copybook Paths - the paths for copybooks that aren't in known locations, which are the solution folder tree, links from the solution, and the cpylib folder in the Studio Enterprise Edition installation
    • COBOL - the Directives and Build Settings specify the settings that were in the original Net Express project
    • Debug - these properties define how the application starts, such as any command line arguments
  11. You can also check the individual file properties, by right-clicking a COBOL source file in Solution Explorer and clicking Properties.
Parent topic: Converting Net Express Projects to Visual Studio Projects


Restrictions and Limitations to Converting Net Express Projects

  • If you import a Net Express project that uses functionality that is not supported in Studio Enterprise Edition, the wizard will still produce a Visual Studio solution. In such a case you might need to perform additional steps (such as editing source files, installing AddPacks, or reworking parts of the application) before you can successfully compile and run it.
Parent topic: Converting Net Express Projects to Visual Studio Projects


Creating COBOL Projects from Existing Code

The Create Projects from Existing Code wizard helps you choose and configure a Visual Studio project type to use, and imports your existing files.

It scans the files as it imports them to determine whether they are COBOL programs or copybooks, and sets directives for each imported file according to the determined file type, taking into account any relevant IDE options.

This is how you use the Create Projects from Existing Code wizard to create a Visual Studio project from existing COBOL sources:

  • To create a COBOL project from existing code
Parent topic: Creating COBOL Solutions and Projects


To create a COBOL project from existing code

These are the steps to use the Project from Existing Code wizard in Visual Studio to create and configure a project:

  1. Locate the existing COBOL files that you need to import in the Visual Studio IDE.
  2. In the IDE, click Tools > Options > Projects > COBOL Project Settings.
  3. Ensure the directives on the Options page are set as appropriate.

    The directives set on this page are set on imported files. For example, you can choose to set the dialect directive or various SQL directives. After the files are imported in the project, the IDE performs an additional directives scanning of them and sets the directives as necessary.

  4. Ensure any file extensions that are not traditionally associated with COBOL will be recognized as COBOL programs or copybooks.

    Read To associate file extensions with COBOL and To specify that a file extension is a copybook for details.

  5. Click File > New > Project from Existing Code to invoke the wizard.
  6. On the Welcome page, ensure Micro Focus COBOL is selected as the project type to create.
  7. Click Next.
  8. On the Specify Project Location, Project Type and Source Files page, specify a directory, a name and an output type for the Visual Studio project.

    You do not need to specify the cblproj extension in the name as the wizard adds it automatically.

  9. Specify the folders that contain the source files to import into your project:
    1. Click Add.
    2. Browse to the folder that contains the source files and select it.
    3. Click Select Folder.
    4. Check Add subfolders if you want to add files from all subfolders.
    5. Repeat and add other folders as needed.
  10. Ensure File types to add to the project lists all file extensions that you want to add to your project.
  11. Check Add copybooks to Solution Explorer if you want to show the copybook files as part of the project in Solution Explorer.
  12. Click Next.
  13. On the Specify New COBOL Project Properties page, specify whether to create a native or a managed project.
  14. For native projects, select the target platforms.
  15. Click Finish.

    Visual Studio starts importing the files which is an asynchronous process so the IDE will be unresponsive to any other events till the import is complete.

    During file import, the wizard:

    1. Creates a Visual Studio project in the specified directory.
    2. Scans the files in the source folders to determine which ones are COBOL programs and which are copybooks.
    3. Imports the files of the selected file types into your project:
      • If the source files are in the same folder, the wizard adds them to the project and re-creates the subfolder structure.
      • If the source files are stored in other folders, the wizard only links them to your project.
    4. Adds the paths to the source folders that contain copybook files to the COBCPY environment variable as paths relative to the project.

      To see what paths are set for the project, click Project > ProjectName Properties and check the Copybook Paths tab.

    5. Adds the copybooks to the project in Solution Explorer (if you specified this in the wizard).
    6. Sets the Compile build action on files which it identified as COBOL programs.

      Copybook files do not compile so no build action is set on them.

    7. Performs a directives scan of the imported files and sets additional directives as specified in Tools > Options > Projects > COBOL Project Settings.
    8. Displays a summary report about the files it imported, the directives and copybooks paths that it set in the Output window.
  16. Check the Output window for summary report of the actions the wizard performed. From the drop-down list next to Show output from choose:
    • Import Files Results - shows a list of the files that were imported and the copybooks paths that were added to the COBCPY environment variable.
    • General - shows results from the file scan and the directives that were set as specified in Tools > Options > Projects > COBOL Project Settings.
Parent topic: Creating COBOL Projects from Existing Code


Creating a New Project From Files in an Existing Project

You can subdivide a COBOL project in your solution by selecting files in the project and using those to create a new project in the same solution. Splitting the code and moving parts of it into a different project could be useful if you need to move portions of the code to a dynamic library project.

You use the COBOL Projects From Selection wizard available from Solution Explorer to subdivide your projects:

To invoke the wizard, in Solution Explorer select the files in your project that you wish to use to create a new project, right-click the selection and click Create Project. The wizard enables you to specify the type of project to create and whether to copy or move the selected files into it. Once you specify you preferences, the wizard creates the new project in the same solution and it has the same properties and references as the original project, and a build configuration which is the default one for the specified project type.

  • To create a new COBOL project from selected files in an existing project
    You can use the Create Project From Selection dialog to subdivide an existing COBOL project by selecting certain files in the project and moving or copying them to a new project in the same solution.
Parent topic: Creating COBOL Solutions and Projects


To create a new COBOL project from selected files in an existing project

You can use the Create Project From Selection dialog to subdivide an existing COBOL project by selecting certain files in the project and moving or copying them to a new project in the same solution.
  1. In Solution Explorer, select the COBOL files and copybooks to use in the new project.
  2. Right-click the selection and choose Create Project.

    This starts the Create Project from Selection dialog:

  3. Specify details for the new project as follows:
    Project Name, Output Type
    Specify a name and type for the new project to create in the directory of the original solution.
    Managed project
    Uncheck this if you want to create a native project.
    More Details
    Click this to verify what files will be used in the new project.
    Exclude selection from original project
    Ensure this is checked if you want to move the selected files from the original project to the new one. If you uncheck this, the selected files are copied to the new project.
  4. Click OK.

    This creates a new project in your solution with the same properties and references and with the default build configuration for the selected project type. If Exclude selection from original project was checked, the files you selected are now moved to the new project.

Parent topic: Creating a New Project From Files in an Existing Project


Building COBOL Applications

To build an application, you need to compile its programs and link them to a run-time system. You use a build configuration to define how to do this.

The Micro Focus Compiler goes through the following phases:

Building Native COBOL Applications

When building native COBOL applications the Compiler first checks the program for syntax errors. Then, it generates native machine code. Finally, the linker links the native machine code into an executable (either an .exe or a .dll).

  1. The check phase - the Compiler checks the program's syntax and creates files to use for testing and debugging. The check phase creates a dictionary file for use with the Debugger.
  2. The generate phase - during the generate phase, the Compiler creates native machine code from the intermediate code produced during the check phase, and produces either an industry-standard .obj file.

    You cannot execute the object code file. You must link it with the appropriate run-time system to create an executable file.

  3. The linking phase - during the link phase, the code is linked to the run-time system and creates an executable file - an .exe, .dll. You specify how to link your applications within the IDE and on the COBOL Link page in your project's properties.

Building Managed COBOL Applications

When building .NET Managed COBOL applications the Compiler compiles your code to Microsoft Intermediate Language (IL) source file which is stored in an assembly file - either an .exe or a dll.

  • Build Configuration
  • Compiling COBOL Applications
  • Linking Native COBOL Code
  • To build a COBOL project
  • To embed resources in a native COBOL application
  • To add a configuration file
  • To add a resource script file to your native COBOL project
  • To edit a resource-definition script file for a native COBOL project
  • To set an entry point for a native COBOL project
  • To set Compiler directives on a COBOL file
  • To compile individual files in your project
  • To link a native COBOL project to the run-time system
Parent topic: Developing COBOL Applications


Build Configuration

Before you build a project you need to configure how to build in a build configuration.

The following build configurations are available: Debug build and Release build. You can also create your own custom build configuration.

You use the Configuration Manager to choose the build configuration to use for your project / solution, create new build configurations or edit the existing ones.

The combination of configuration type and platform settings define the build configuration of your project / solution. For example you can create a Debug build configuration for x86 platforms, and a Debug build configuration for x64 platforms. Use Project Properties to view and change the platform type for which you want to build your application.

See the Visual Studio Help for more information on build configuration and build configurations and build platforms.

Parent topic: Building COBOL Applications
Related information
Project Properties


Compiling COBOL Applications

Before you can run a program, you have to compile the source code.

  • Compiling COBOL code
  • Compiled File Types
  • Setting Compiler Directives for COBOL
  • Temporary Files Used when Compiling Native COBOL
  • Techniques for Compiling Quickly
Parent topic: Building COBOL Applications
Related information
Command Line Reference
Setting Directives Outside the IDE
The cobol Command
cbllink


Compiling COBOL code

Before you can run a program, you have to compile the source code.

By default, the Compiler compiles your program without any intervention. You can configure the project to be built in a specific way, such as specifying types of target files to build, the target platform and so on.

You can configure the compilation using the following techniques:

  • Compiler directives. You can control the way programs are compiled by using Compiler directives.

    You use directives to control the way the Compiler behaves. Normally, you need only a few directives. Most of the time, you use the default values. Note that setting some directives affects the default setting of other directives. For example, setting one directive might automatically unset another directive, and some directive settings are mutually exclusive.

  • 32- and 64-bit compilation. You can produce 32- and 64-bit applications from the same source code by setting the Platform Target option in the IDE. You can also compile bit-specific output from the command line by using the cobol command from the 32-bit or 64-bit command prompt.
  • Linked resources. Linked resources enable you to link to sources that are outside the project, thereby saving you from copying the sources into the project, and enabling to share resources with others.
  • Copybook locations. You can specify the location of the copybooks that your program refers to, if you keep them in different directories from the program. You can do this in the IDE, and also through the COBCPY environment variable.
  • Temporary files used during compilation. Before compiling, you must ensure there is enough free space for the Compiler's temporary work files. You can specify the location where the Compiler puts its temporary files.
  • Techniques for compiling quickly. Large applications comprising many programs can take significant time to compile. You can use various techniques to increase the speed of compilation.

The Compiler records errors with severity levels ranging from information messages to fatal errors which stop the Compiler working.

When you compile as native code, the Compiler can produce executable code directly or object code. Object code is not executable, and has to be linked to the run-time system to create an executable file.

Compiling from the command line

Using the command line, you can compile without linking using the cobol command, or compile and link your program in one step using the cbllink utility.

You can either specify all the information required on the command line, or use the Compiler prompts.

Parent topic: Compiling COBOL Applications


Compiled File Types

Before your program can be run or debugged, it must be in a form that can be executed. The Compiler can produce the following types of files:

Executable code
You produce executable code by compiling and linking in one step.

An executable file has a filename extension of .exe.

To produce executable code, you need to modify the Output Type setting in the project properties.

Object code
You can compile to object code from the source code file. The object code file is not executable. It requires linking with the run-time system to produce an executable file.

By default, object code files have the extension .obj.

Object code files must be linked to create .exe or .dll files.

Dynamic Link Libraries
Dynamic Link Libraries are dynamically loaded at run time when required, that is, when referenced as a main entry point (for example, by run ) or by the COBOL CALL syntax. When all the entry points in a Dynamic Link Library have been canceled then the file is unloaded, releasing any memory used.

This behavior is different to linked shared libraries and system executables, which are always loaded at process start-up, whether they are used or not. Further, the code and memory used by shared libraries and system executables are only unloaded when the process terminates.

A Dynamic Link Library can contain more than one COBOL program and can also contain other language programs, such as C and C++. Dynamic Link Libraries can also be linked with third party object files or shared libraries. This behavior is similar to system executables and shared libraries.

A Dynamic Link Library has a filename extension of .dll.

Bundling intermediate or generated code files

You can bundle .int files and .gnt files in Micro Focus library files. The advantages of this are:

  • It can simplify the packaging of files for users, as it reduces the number of files to be shipped.
  • When your program calls a subprogram stored in a library file, the library file and all the programs loaded in it, is loaded into memory. This can make program execution faster.

A library file has the file extension .lbr.

For example, given the following programs in our application:
Figure 1. Programs in application
Programs in application

ProgC and ProgD could be compiled as generated code files, and then placed in a library file, mylib.lbr. When ProgA calls ProgC, mylib.lbr would be loaded into memory, also loading progc.gnt and progd.gnt. You would need to ship proga.gnt, progb.gnt, and mylib.lbr, as well as a trigger program.

To package the .int and .gnt files into an .lbr file, set the following properties:

  1. Navigate to your project's properties - click Project > MyProject Properties.
  2. Click the Application tab.

    The Output type for your project must be set to INT/GNT.

  3. Check Package as .lbr and save your changes.

    Next time you build your project, the project compiles to an .lbr.

Important: You cannot debug a project that compiles to .int or .gnt code if it is set to package the output files as an .lbr file. Before you can debug such projects you need to disable the setting Package as .lbr on the Application page in your project's properties.
Parent topic: Compiling COBOL Applications


Setting Compiler Directives for COBOL

You can use directives to control the way the Compiler behaves: what output it produces, what code is compiled and how the compiled code behaves when it runs. For normal operation you need only a few directives. Most of the time, you use the default values.

Important: Setting some directives affects the default setting of other directives. For example, setting one directive might automatically unset another directive, and some directive settings are mutually exclusive.

You can set Compiler directives within the IDE, either on the whole project or on an individual file. You set:

  • Project-wide directives in the build configuration for the project.
  • File-specific directives in the individual file's properties. The file-specific properties override the project-wide ones.

Separate compiler directives with a space. You can supply parameters either within brackets or speech marks: for example charset"ascii" dialect(MF), and if you need more than one parameter for a particular directive, separate the parameters with a comma: for example outdd(sysout 121 r e) or ACTUAL-PARAMS"MyInterface ClassA ClassB".

In addition, you can set Compiler directives in a number of other ways, such as on the command line, or in a directives file, or as part of a response to a prompt.

Important: For applications that use a RDBMS, you might need to set some additional directives in your build configuration.
  • To set project-wide build properties and compiler directives
  • Setting Compiler Directives from the Command Line
  • Setting Compiler Directives in a Response to a Prompt
  • Setting Compiler Directives in Source Code
  • Setting Compiler Directives in a Directives File
Parent topic: Compiling COBOL Applications
Related tasks
To set project-wide build properties and compiler directives
To compile individual files in your project
Related information
Compiling from the Command Line
Compiler Directives
Setting Directives Outside the IDE
To set project-wide build properties and compiler directives


To set project-wide build properties and compiler directives

  1. Click Project > MyProject Properties.
  2. Click the COBOL tab.
  3. In Additional directives, type the directives you want to use. Separate the directives with a space.
  4. Click File > Save.

The compiler directives are saved with the project, so that they are used on all files in the project the next time you rebuild.

These directives are overridden by any specified for individual source filesand for the build type.

Parent topic: Setting Compiler Directives for COBOL
Related information
Compiling from the Command Line
Compiler Directives
Setting Directives Outside the IDE


Setting Compiler Directives from the Command Line

When you compile from the command line using the cobol command, you include any directives as part of the command. This applies to command line fields in the IDE and any compilation started from a prompt.

Parent topic: Setting Compiler Directives for COBOL


Setting Compiler Directives in a Response to a Prompt

You can supply all or part of the command line as a response file, which is an ASCII text file containing options for the command. You give the name of the response file on the command line, preceded by an at character (@). This name is replaced in the command by the contents of the file. Within the response file, the end of a line is equivalent to a comma separating filenames or a space between directives beyond the last comma.

Parent topic: Setting Compiler Directives for COBOL


Setting Compiler Directives in Source Code

You can use $SET statements in source code to set directives when your program is affected by particular circumstances that none of the other programs in an application needs. For example:

$SET OSVS NOFORM CHECKDIV"OSVS"
Parent topic: Setting Compiler Directives for COBOL


Setting Compiler Directives in a Directives File

Place the directive that you want to override in the system-wide directives file, cobol.dir. Make sure that the file is in folder in a directory specified by the COBDIR environment variable. By default cobol.dir is in the $COBDIR\etc folder.

CAUTION:
This file affects all compilation done on the system and using it or editing it can result in unexpected effects.
Parent topic: Setting Compiler Directives for COBOL


Temporary Files Used when Compiling Native COBOL

Note: The following information applies to native code only.

The Compiler creates a number of temporary work files. The size of them depends on the content of your program and the directives used, in particular the number of data and procedure names. The Compiler puts the files in the directory indicated by the TMP environment variable. If this environment variable does not exist, the files are created in the current directory.

The Compiler normally deletes these temporary files before it terminates. However if the Compiler terminates abnormally, for example due to machine failure, it might leave these files on disk. You can delete them, unless the Compiler is running in another session.

Before compiling, you must ensure there is enough free space for these temporary files in the appropriate directory.

Parent topic: Compiling COBOL Applications


Techniques for Compiling Quickly

Note: The following information applies to native code only.

A large application can consists of many programs; compiling all of these might take some time. To speed up the compilation process, use the following Compiler directives:

  • NOALTER. If your code does not have any ALTER statements, you can disable the ALTER default directive and produce slightly more efficient code and produce it more quickly.
  • NOCOPYLIST. If you are using the LIST directive to create a listing file, you can disable the COPYLIST default directive and prevent the Compiler from expanding the copybooks and include files in the listing. Note that compilation is quicker still if you do not create a listing.
  • NOLIST. This is the default. Compiling is quicker if you accept this default and do not produce a listing file.
  • NOQUAL. If your code does not use qualified data names, you can disable the QUAL default directive to compile more quickly. An example qualified data name is:
    elementary-item-a  of  group-item-1
Parent topic: Compiling COBOL Applications
Related reference
COPYLIST
ALTER
LIST
QUAL


Linking Native COBOL Code

There are several ways to link to the run-time system. The way you link depends on the type of application.

To link native code, the following information is applicable:

  • Overview of Linking Native COBOL Applications and Run-time Systems
  • Static-linked Run-time System and When To Use It
  • Shared Run-time System for Running Native COBOL Applications
  • Dynamically Binding Run-time Systems to Your Native COBOL Applications
  • Order of Program Loading and Run-time System Usage for Native COBOL
  • Loading a Dynamic Link Library Built as Native COBOL Code
  • Application Performance with Dynamic Binding for Native COBOL
Parent topic: Building COBOL Applications


Overview of Linking Native COBOL Applications and Run-time Systems

Note: The following information applies to native code only.

When you link a program compiled as native code, you link it to any run-time support modules that it uses, and to the run-time system that it needs.

There are two COBOL run-time systems to choose from: the static-linked run-time system and the shared run-time system. There is a version of both these run-time systems for creating single-threaded and multi-threaded applications.

There are two ways to link to the shared run-time system: by importing the run-time system, or by binding to the run-time system dynamically.

The way you link depends on the type of application, as follows:

Application for personal use
such as a small application or utility. With this model, you create an application the run-time system and support files are built into in your application's executable file. This might be a standalone application comprising a single file.

To build this type of application, you link it statically as a standalone application.

Application for selling on to an end user
such as those written by Independent Software Vendors (ISVs). This type of application is likely to be the sole COBOL application that the user runs, and so it does not share the run-time system and support files with other applications. If there are other applications, they each use their own versions of the run-time files without disruption. With this model, you create an application that imports the run-time system and support files.

To build this type of application, you build a modular application, and link it with the run-time system. You do not enable dynamic binding so that the run-time files are imported into the application.

Application for corporate use
where multiple COBOL applications are running, and need to share the run-time system and support files both on disk and in memory. With this model, you create an application that is dynamically bound to the run-time system and support files.

To build this type of application, you build a modular application, and dynamically bind it to the run-time system. To do this, you link the top-level COBOL executable to the run-time system and enable dynamic binding.

Parent topic: Linking Native COBOL Code
Related information
Run-time System Configuration
To link a native COBOL project to the run-time system
cbllink


Static-linked Run-time System and When To Use It

The static-linked run-time system is designed for standalone applications.

When an .exe or .dll file runs, it uses whichever run-time system it is linked with: either the shared or the static-linked run-time system.

With the static-linked run-time system, the run-time system support required by your program is included in the final executable file along with your program modules. This means that the program runs without support from any other files, so you do not need to ship a separate copy of the run-time system with your application.

Programs linked with the static-linked run-time system are larger than if they were linked with the shared run-time system. Each separately linked subprogram contains its own run-time system support, so duplicate code is loaded when you run them.

You might also need to use the static run-time system with a static linked .dll file. For example, if the calling program was written in another language, such as Visual Basic, you might want to static link all of the COBOL programs in one .dll file, and provide the run-time system as part of the .dll file. To do this, you would need to use the static linked run-time system.

The static-linked run-time system is provided in these versions:

Lite Minimises the run-time support that is linked to your application. This option must not be used if a program in your application:
  • Uses CBL_ALLOC_MEM to allocate shared memory
  • Invokes an executable via CBL_EXEC_RUN_UNIT
Base | Includes the full run-time support. Use this version of the run-time system for a standalone application.
Full | As for Base, but also includes support for dynamic linking.
Debug | Enables an executable to be debugged within the IDE. This version of the run-time system can also produce a core dump and save it in a file if the application crashes with a run-time system error 114. The core-dump file can subsequently be analyzed using the debugger to determine the cause of the crash. For this reason, it is sometimes useful to deploy an application that has been linked with this version of the run-time system.
Parent topic: Linking Native COBOL Code


Shared Run-time System for Running Native COBOL Applications

Note: The following information applies to native code only.

The shared run-time system for running native COBOL code comprises multiple .dll files, each of which can be separately loaded when required, whenever a program linked with it runs. All separately linked subprograms call the same copy of the run-time system, avoiding duplicate code. In addition, programs running in separate sessions use the same run-time system, reducing memory usage.

When a program linked to the shared run-time system runs, external calls are made to the run-time system and the required part of the run-time system is loaded.

To run a program linked with the shared run-time system, you might need to provide some other files, such as a trigger program or some run-time support modules.

When an .exe or .dll file runs, it uses whichever run-time system it is linked with: either the shared or the static linked run-time system.

Parent topic: Linking Native COBOL Code


Dynamically Binding Run-time Systems to Your Native COBOL Applications

Note: The following information applies to native code only.

If you ship an application to a site where other applications are already installed, your application might conflict with the existing ones if your application uses a different version of the run-time system from the existing ones. For example, your application uses version 4 of the run-time system and the existing applications use version 3. Normally, you would need to ship the version 4 run-time system. You would also need to set the paths on your user's system so that each application used its own version of the run-time system: the version 4 application used the version 4 run-time system and the version 3 application used the version 3 run-time system.

Similarly, if you create a system that can be used by two applications, one multi-threaded and one single-threaded, you would normally have to create two dynamic link libraries, one linked to the multi-threaded run-time system, one to the single-threaded run-time system.

To solve these problems, you can dynamically bind a run-time system to your programs. Dynamic run-time system binding enables you to:

  • Create system executables that can use any installed run-time system, whatever its version or mode (that is, whether single-threading or multi-threading)
  • Create system executables that can recognize whether they are compatible with the versions and threading modes of available run-time systems
  • Create dynamic link libraries that can dynamically bind to any run-time system that exists within a process

Dynamic run-time system binding is enabled using a glue library, called cblrtsg.lib. When you choose to dynamically bind an application, your system executable is linked to the glue library rather than directly to a run-time system. If your executable is a .dll file, it can then run in a process that has loaded the single-threaded or multi-threaded run-time system. If your executable is an .exe file, it dynamically binds to either the required version of the run-time system, or the system default run-time system. As long as the system to which you are shipping your system executable file already has a run-time system installed, you need to ship only the executable file. How your system executable interacts with the installed run-time system depends on how you linked your program to the glue library.

You can create a dynamically bound executable in the Link page of the Build Settings, or by using the Cbllink utility.

Parent topic: Linking Native COBOL Code
Related information
Link Settings
To link a native COBOL project to the run-time system
cbllink


Order of Program Loading and Run-time System Usage for Native COBOL

Note: The following information applies to native code only.

In dynamically bound applications that are built as native COBOL code, the order in which programs are loaded affects which run-time systems are searched for and the use of the run-time system. For example:

  • The .exe file and the first .dll file determine which run-time system is loaded
  • The level of run-time system specified when you link ensures that the run-time system is compatible and provides the features required by the executable
  • Further .dll files bind to the existing run-time system within the process

.exe Files and First .dll Files

A "first" COBOL .dll file is the first loaded component of an application that needs a COBOL run-time system for execution. In the following description, the term ".exe file" also implies the term "first .dll file".

When the application runs, the .exe file locates and loads a compatible run-time system, depending on how the application was linked. If the application was:

  • Linked normally (that is, without using dynamic binding), the .exe file looks for a run-time system on the path specified by the PATH environment variable. If more than one run-time system is installed, this can cause a conflict.
  • Linked using dynamic binding, the .exe file dynamically binds to a run-time system by consulting the Windows registry for installed and compatible run-time systems. If a run-time system cannot be found, then the current setting of the PATH environment variable is used to load a default run-time system.

Compatible Run-time Systems

When you create a dynamically bound executable file you can specify what level of run-time system the executable file is allowed to work with. This enables you to specify that the executable can work with any newer version of the run-time system than the one you linked it with, or whether the executable is restricted to the current release of the run-time system only.

You can also specify that an executable file can work with only one or other of the single-threading run-time system or the multi-threading run-time system.

The level and threading mode of a run-time system is checked as follows:

  • The level of the run-time system is identified as a version number in the registry. For example, for version 6.0 of the COBOL development system, the run-time system level is 6.0.
  • The path used to load the run-time system is determined from the registry value:
    \HKEY_LOCAL_MACHINE\SOFTWARE
\Micro Focus\Studio Enterprise Edition\x.y\COBOL\Environment\PATH

    where:

    x.y
    is the installed version of the COBOL system.

    If the executable was restricted to the current release level when it was created, x.y must be greater than or equal to the development system version with which the executable was created.

  • If none of the above techniques works, the default setting of PATH is used to load the run-time system.

When a path to a run-time system has been found, the executable file determines whether it needs a specific threading mode of run-time system, as follows:

  • If you specified a threading mode of run-time system when you linked the executable, then the relevant run-time system is loaded
  • If you did not specify a threading mode of run-time system, then the registry item is used to determine which run-time system to load, as follows:
    \HKEY_LOCAL_MACHINE\SOFTWARE\Micro Focus\MyProduct\n.m\COBOL\Selector

    where:

    n.m
    is the current release of the COBOL development system.
  • If a threading mode of run-time system was not specified and the Selector registry item is not found, then, by default, a single-threaded run-time system (cblrtss.dll) is loaded.

In any case, when the run-time system has been loaded a version and type check is performed and any incompatibilities reported.

Further .dll Files

When a second or further .dll file is loaded into a same process, it must bind to the existing run-time system within the process. If you create an application that does not use dynamic binding, then you must make sure that all programs in an application are linked to the same run-time system, otherwise conflicts could occur that would result in the application failing.

If you use dynamic binding when you create the second or further .dll files in your application then you can specify that they will either bind to any loaded and compatible run-time system, or will fail cleanly with informative diagnostic messages.

Parent topic: Linking Native COBOL Code


Loading a Dynamic Link Library Built as Native COBOL Code

Note: The following information applies to native code only.

.dll files (which are built as native COBOL code) must be loaded into memory before they can be used. If you statically link a .dll file it is loaded automatically before your application is run. If you use dynamic linking, your program should load each .dll file as necessary before attempting to call entry points in it:

  • If the .dll file contains a single public entry point and you use the name of the .dll file in the CALL statement, the file is loaded automatically when called.

    For example, if a file mydll.dll contains a single public entry point, the file is loaded and the call executed by a CALL "mydll" statement.

  • If the .dll file contains several public entry points, use the SET procedure-pointer-name TO ENTRY program-name statement before you call the entry point. For example:
    set mypointer to entry "mybigdll"
call "My-third-entry-point"

You need to load a dynamic link library the first time you use it only, unless the .dll file is no longer in memory.

Canceling a Program and Unloading a .dll

A .dll file is automatically removed from memory when a COBOL program within it is canceled and this results in all COBOL programs in the .dll file being either in an uncalled or a canceled state.

For example, consider a .dll file called sub.dll which contains three COBOL programs: sub.cbl, sub1.cbl and sub2.cbl.

  1. Program sub.cbl is called from the main program.
  2. Program sub2.cbl is called.
  3. Program sub.cbl is then canceled.

    The .dll file is not removed from memory because sub2.cbl has not yet been canceled.

  4. Program sub2.cbl is canceled.

    The .dll file is removed, because all programs within it are now either canceled (sub.cbl and sub2.cbl) or not called (sub1.cbl).

The way you load OO .dll files depends on whether they contain a single class or several classes.

Parent topic: Linking Native COBOL Code


Application Performance with Dynamic Binding for Native COBOL

Note: The following information applies to native code only.

The call speed of a dynamically bound application in native code is roughly the same as an application directly linked to the shared run-time systems.

The first call to the run-time system by a dynamically bound application invokes the dynamic binder. The dynamic binder queries .dll files within the process, accesses the machine registry, and finally, if necessary loads the appropriate run-time system, determining the entry point address. Following this, first-time calls to other entry points also go through the dynamic binder, but they need to determine the entry point address only. Successive calls to previously called entry-points go directly to the bound entry-point.

Applications that use dynamic run-time system binding might be slightly larger than applications linked in the normal way. This is because a dynamically bound application requires the binding code and strings for each run-time system entry point referenced in the application.

Parent topic: Linking Native COBOL Code


To build a COBOL project

  1. Specify the build configuration.

    Use the Configuration Manager to choose the build configuration to use for your project or solution.

  2. Set properties for your projects such as, for example:
    • On the Application tab, specify the type of executable to build, such as a class library or an application
    • On the COBOL tab, specify how to build the project, such as Compiler directives
    • On the Copybook Paths tab, specify the copybook locations
    • On the Debug tab, choose the build configuration, such as Debug or Release
  3. From Solution Explorer, add an application configuration file to a native project and use it to set any required environment variables and COBOL switches.
  4. Build the project, by clicking Build > Build project name.
Parent topic: Building COBOL Applications
Related information
To embed resources in a native COBOL application
To set project properties
To set project-wide build properties and compiler directives
To compile individual files in your project
To link a native COBOL project to the run-time system
To add a configuration file
Project Properties


To embed resources in a native COBOL application

Note: The following information applies to native COBOL applications only.
  1. Create individual files for your cursors, icons, bitmaps, dialog boxes, and fonts.
  2. Create the resource-definition script file (.rc file) that describes the resources used by your application outside of Visual Studio.
  3. Add the resource-definition script file (.rc file) to your project.
  4. Build your project.

    During the build the resource script file compiles to a resource file (.res) which then is linked by the cbllink utility into the output application file (.dll or .exe).

    When you build a Mainframe Subsystem Applications, a separate .dll file is built for each COBOL program in your project. The resources are embedded in each individual .dll file.

Note that this release does not support the Visual Studio resource editor and you can edit the resource-definition files in the IDE only in code view. It is recommended to create and edit your resource-definition script files outside of Visual Studio.

Parent topic: Building COBOL Applications
Related information
To add a resource script file to your native COBOL project


To add a configuration file

  1. In Solution Explorer, right-click your project.
  2. Click Add > New Item .
  3. Select the relevant configuration file for your application.
  4. Specify a filename in the Name field.
  5. Click OK.
Parent topic: Building COBOL Applications
Related concepts
Application Configuration
To set run-time environment variables and switches for native COBOL applications
Related information
To embed resources in a native COBOL application
To set project properties
To set project-wide build properties and compiler directives
To compile individual files in your project
To link a native COBOL project to the run-time system
Project Properties


To add a resource script file to your native COBOL project

Note: The following information applies to native COBOL applications only.
  1. In Solution Explorer, right-click your project.
  2. Click Add > Existing Item.
  3. Set Object of type filter to Resources files (.rc).
  4. Browse to the location of the resource script file and select it.
  5. Click Add.
Parent topic: Building COBOL Applications
Related information
To embed resources in a native COBOL application


To edit a resource-definition script file for a native COBOL project

Note: The following information applies to native COBOL applications only.

This release does not support the Visual Studio resource editor and the resource-definition script (.rc) files that you use in your COBOL projects can be opened only in code view.

It is recommended to use other applications to edit resource-definition script files.

Parent topic: Building COBOL Applications


To set an entry point for a native COBOL project

Note: The following information applies to native COBOL applications only.
  1. Right-click a project in the Solution Explorer and click Properties.
  2. Click the Application tab on the left-hand side of the Properties window.
  3. Specify an entry point for your project in the Entry point field.
Note: You can specify an entry point for all native COBOL projects except for the Mainframe Subsystem applications (MSS). Mainframe projects do not have the Application tab in the project properties.
Parent topic: Building COBOL Applications
Related information
Application Properties for Native Projects


To set Compiler directives on a COBOL file

Note: The following applies to native COBOL only.
  1. To specify Compiler directives on an individual COBOL file in your project:
    1. In Solution Explorer, right-click the file on which you want to set the directives.
    2. Click Properties.
    3. Go to the COBOL page.
    4. In Additional Directives, type the directives to set. Separate each directive with a space.
    5. Click OK.

The next time you compile the file or the entire project, the directives are applied.

The directives set on individual files override those that are specified for the entire project.

Parent topic: Building COBOL Applications


To compile individual files in your project

Restriction:
  • You can only compile individual COBOL programs that are part of a native project, or a managed Mainframe Subsystem Application project that compiles to multiple output files.
  • It is not possible to compile copybook files.

To compile an individual COBOL, IMS, JCL, or BMS file in your project:

  1. In Solution Explorer, right-click the file you want to compile.
  2. Click Compile.

    This option is not available when a build is already in progress or when you are debugging the application.

Parent topic: Building COBOL Applications
Related information
COBOL Properties
Compiling from the Command Line
Compiler Directives
Setting Directives Outside the IDE


To link a native COBOL project to the run-time system

Note: The following information applies to native COBOL applications only.
  1. Right-click a project or a solution in the Solution Explorer and click Properties.
  2. Click the COBOL tab on the left-hand side of the Properties window.
  3. In the Native section, click Link Settings.
  4. In the Runtime Library section check static, shared or dynamic, as appropriate.
Parent topic: Building COBOL Applications


Debugging Native COBOL Programs

Note: The following information applies to native code only.
  • Overview - Debugging Native COBOL Programs
    Your COBOL development system provides a debugging environment, which is sensitive to COBOL and includes all the usual features such as stepping, watch windows and breakpoints.
  • Debugging Features in the IDE
  • Just-In-Time Debugging and Native COBOL
  • Debugging Using a Core Dump
    You can arrange for an error in your application to automatically produce a core dump.
  • Remote Debugging of Native COBOL Applications
  • Debugging mainframe applications and services on Enterprise Server
    Guidance on debugging services and applications on Enterprise Server.
  • To configure the symbol path for native COBOL applications
  • To set a COBOL watchpoint in native COBOL code
  • To attach to a native running process and debug
  • To debug a native COBOL project that compiles to multiple executables
Parent topic: Developing COBOL Applications


Overview - Debugging Native COBOL Programs

Your COBOL development system provides a debugging environment, which is sensitive to COBOL and includes all the usual features such as stepping, watch windows and breakpoints.
Note: The following information applies to native code only.

When you debug an application, the source code of each program is displayed in a separate window. Each line of the source is highlighted in turn as each statement is executed, showing the effect of each statement. You can execute the program at full speed and can interrupt execution to examine and change data items.

You control the way debugging works by setting options on the Debug page of the project's properties and in the option pages which you can access from Tools > Options > Debugging.

Parent topic: Debugging Native COBOL Programs
Related information
Debugging COBOL


Debugging Features in the IDE

  • Wait for Debuggable Attachment and Native COBOL
    When you use Wait for animatable attachment the debugger waits for the program to start in a separate process before attempting to attach to it.
  • Using the Memory Window in Native COBOL
    The Memory Windows enables you to view and monitor the contents of the memory.
Parent topic: Debugging Native COBOL Programs


Wait for Debuggable Attachment and Native COBOL

When you use Wait for animatable attachment the debugger waits for the program to start in a separate process before attempting to attach to it.
Note:
  • Works with native COBOL only.
  • You should not use this option if you are not debugging dynamic link libraries, otherwise debugging is suspended while waiting for a separate process that does not exist.

To enable the option:

  1. Click Project > MyProject Properties and click the Debug tab.
  2. Check Wait for animatable attachment.
Parent topic: Debugging Features in the IDE
Related reference
Debug Properties


Using the Memory Window in Native COBOL

Restriction: Works with native COBOL only.

To display the window, click Debug > Windows > Memory > Memory n in debug mode.

Use the Memory window to:

  • Search the memory by typing any of the following in the Address field:
    • A data item
    • The address of a data-item - address of varname
    • A pointer reference - for example, varnamepointer
    • A memory address such as H"nnnnnnnn"
    • An expression
  • Monitor the contents of the memory - any values that change during the execution of the program are displayed in red.
  • View the contents of the memory in hexadecimal or decimal view:
    1. Right-click in the window and select the format you prefer to show the values.
  • Change the values of the memory:
    1. Right-click a value in the window and select Edit Value.
Parent topic: Debugging Features in the IDE


Just-In-Time Debugging and Native COBOL

  • Overview - Just-In-Time Debugging and Native COBOL
    Just-In-Time debugging allows a debugger to be connected to a running application when an error occurs.
  • To enable just-in-time debugging for when the application fails for Native COBOL
  • Troubleshooting - Just-In-Time Debugging and Native COBOL
    Provides tips on resolving issues you can encounter while debugging using Just-In-Time.
Parent topic: Debugging Native COBOL Programs


Overview - Just-In-Time Debugging and Native COBOL

Just-In-Time debugging allows a debugger to be connected to a running application when an error occurs.
Note: The following information applies to native code only.

This is how you use the Micro Focus Native Debugger for Just-In-Time debugging when a runtime error occurs:

  1. Just-In-Time debugging must be enabled. See To enable just-in-time debugging for when the application fails .
  2. When a runtime error occurs, the Visual Studio Just-In-Time Debugger dialog is displayed with a list of the possible debuggers to use.
  3. Select a Visual Studio debugger.

    This can either be a new instance of Visual Studio or one that is already running.

  4. Check Manually choose the debugging engines.
  5. Click Yes to start debugging.
  6. In the Attach to Process dialog, ensure only Micro Focus Native Debugger is selected under Choose the types of code to debug.
  7. Click OK.

    The debugger attaches to the application that caused the error.

Note:
  • To debug the application, the debugger must find the symbols file (the .idy file). Depending on what application you debug the path to the symbols file may need to be manually defined.
  • If you have the source files and the .idy files, the source code is displayed at the line where the error occurred. If you do not have the required files, the name of the source file or the program where the error occurred is displayed.
  • For 64-bit applications, your COBOL development system must be running and waiting for a debuggable attachment.
Parent topic: Just-In-Time Debugging and Native COBOL
Related information
To enable just-in-time debugging for when the application fails for Native COBOL
Troubleshooting - Just-In-Time Debugging and Native COBOL


To enable just-in-time debugging for when the application fails for Native COBOL

Note: The following information applies to native code only.
  1. Click Tools > Options > Debugging > Just-In-Time.
  2. Check Micro Focus Native Debugger.
Note:
  • For 32-bit applications, when your application fails, the COBOL debugger is invoked if it is not already running.
  • For 64-bit applications, your COBOL development system must be running and waiting for a debuggable attachment.
  • If you have the source files and the .idy files, the source code is displayed at the line where the error occurred. If you do not have the required files, you are given the name of the source file or program where the error occurred.
Parent topic: Just-In-Time Debugging and Native COBOL
Related information
Overview - Just-In-Time Debugging and Native COBOL
Troubleshooting - Just-In-Time Debugging and Native COBOL


Troubleshooting - Just-In-Time Debugging and Native COBOL

Provides tips on resolving issues you can encounter while debugging using Just-In-Time.
Note: The following information applies to native code only.
"The program does not show in the debugger"
Problem:

You experience one of the following problems when you are debugging your program:

  • You step into a program, but the program runs without debugging.
  • You receive the following alert: "No Source Available. No symbols are loaded for any call stack frame."

    Cause: The reason for this may be that the symbols file (the .idy file) is not found.

    To confirm that this is the issue:

    1. In the Output window, select Show output from: Debug.

      This shows the program name, and if the .idy file was loaded.

    2. Click Debug > Windows > Modules.

      This opens the Modules window that shows all the programs that have been loaded and the relevant symbol status for them.

    3. If the status is "Cannot find or load the IDY file", right-click on the program in the Modules window and choose Symbol Load Information.

      This displays the directory paths that were used to search for the .idy file.

Parent topic: Just-In-Time Debugging and Native COBOL
Related information
To enable just-in-time debugging for when the application fails for Native COBOL
Overview - Just-In-Time Debugging and Native COBOL


Debugging Using a Core Dump

You can arrange for an error in your application to automatically produce a core dump.
Note: The following applies to native code only.
  • Debugging Using a Core Dump
    You can arrange for the state of an application to be saved to disk in a core dump file when the application crashes. You can then use the dump file to help debug problems, as it indicates where in the source code the error occurred, along with the values of variables, expressions, and the contents of memory as they were at the moment the error occurred.
  • core_on_error
    Specifies in what circumstances a core file is produced.
  • core_filename
    Specifies the name of the file that is generated when the core_on_error tunable is set to 3.
Parent topic: Debugging Native COBOL Programs


Debugging Using a Core Dump

You can arrange for the state of an application to be saved to disk in a core dump file when the application crashes. You can then use the dump file to help debug problems, as it indicates where in the source code the error occurred, along with the values of variables, expressions, and the contents of memory as they were at the moment the error occurred.
Important:
  • On Windows, the core dump files created by this product are Microsoft minidump files. If you have a mixed language application you can use the minidump file to debug the other languages involved.
  • The following applies to native code only.

You can produce a core dump even when you don't have the COBOL development system installed. This is valuable when you are debugging a released application on site, and you have only the Server Enterprise Edition environment installed.

You must have the source files and the .idy files to get the most detail from the core dump. If you do not have the required files, the IDE indicates that no source is available.

You can produce a core dump file in one of the following ways:

  1. Copy the file cblcored.exe from the Base\bin subfolder in the product installation directory to the same directory as your application's main executable file.
  2. At the command line, go to the directory containing cblcored.exe and type:
    cblcored
  3. From the Core Dump list, select one of the following:
    • Enabled with prompt if you want a message box displayed when a core dump is about to be created.
    • Enabled with no prompt if you do not want a message box displayed when a core dump is about to be created.
    • Disabled if you do not require a core dump.

    If you have selected one of the enabled options, the next time you run the application and an error occurs, the state of the application at the time of the error is saved in the file cblcore. This file is saved in the same folder as the application.

Alternatively, you can configure the system so that it produces a core dump for run-time errors. To do this:

  1. Create a run-time tunable configuration file and add to it the core_on_error tunable.

    The default name of the core dump file to be produced is cblcore. To specify a different file name, add the core_filename tunable to the run-time tunable configuration file.

  2. Run the application. When the application crashes, a core dump is produced.

To debug a core dump file:

  1. Create a native COBOL Link Library project.
  2. In the IDE, click Project > MyProject Properties and navigate to the Debug tab.
  3. Click Start external program and specify the name of the Micro Focus core dump file.
  4. To start debugging:
    • Right-click the project in Solution Explorer, and click Debug > Start new instance.
    • Or, right-click the project in Solution Explorer, and click Set as StartUp Project. Then, click Debug > Start Debugging.
  5. When you start debugging you can query the state of the program at the point at which the error occurred.
Note:
  • You cannot enable both Just-In-Time Debugging and Core Dump concurrently.
  • To debug a 64-bit core dump you must first create a 64-bit project configuration or select x64 as the Platform target on the COBOL tab in the Project Properties.
  • cblcored.exe is one of the Server Enterprise Edition files, which is provided for on-site debugging. You are authorised to redistribute this file to your customers providing you have the appropriate license.
  • To create a core dump for an application running under IIS, the application must be run in the same user account as that being used when enabling the core dump feature. For example, a core dump will not be produced for a CGI or ISAPI application running under the default anonymous logon account.
Parent topic: Debugging Using a Core Dump
Related reference
core_on_error
core_filename
Run-time Configuration Tunables - Overview
Format of a Configuration File for Native COBOL


core_on_error

Specifies in what circumstances a core file is produced.
Restriction: This tunable is supported for native COBOL only.

Syntax:

>>-----set core_on_error=---.-0-.-----------><
                            +-1-+
                            +-2-+
                            +-3-+
                            +-129-+
                            +-130-+
                            +-131-+

Parameters:

0 | The run-time system never produces a core file on any exception or run-time system error. This is the default behavior of the run-time system.
1 | The run-time system produces a core file when any exception is received that would normally produce a core file on the host system; for example, a run-time system error COBRT114, and so on.
2 | The run-time system produces a core file when any run-time system error occurs. After writing out the core file the process terminates immediately.
3 | The run-time system produces a snap shot core file when any run-time system error occurs. After writing out the core file the process continues as normal; for example, to display an RTS error message.
129 | Same as core_on_error=1, except no message box is displayed after the core file is created.
130 | Same as core_on_error=2, except no message box is displayed after the core file is created.
131 | Same as core_on_error=3, except no message box is displayed after the core file is created.

Properties:

Default: | 0
IDE equivalent: | None

Comments:

You can debug core files to determine the cause of the problem if you have the appropriate dictionary (.idy) files. When a core file is produced, using core_on_error=1 or core_on_error=2, the run-time system itself cannot clean up COBOL file buffers or free system resources. This could lead to data file corruption that might not have occurred if no core file was produced.

Parent topic: Debugging Using a Core Dump
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
debug_on_error
signal_regime


core_filename

Specifies the name of the file that is generated when the core_on_error tunable is set to 3.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set core_filename=---"filename"-----------><

Parameters:

filename The name of the file that will be produced when a core file is generated if you set the core_on_error tunable to the value 3. If filename contains a tunable string it is substituted as folows:
%%
Single %
%d
The date of when the program encountered the error, in the format yyyymmdd
%f
The basename of the program that encountered the error
%p
The process ID of the program that has encountered the error
%t
The time of when the program encountered the error, in the format hhmmss

Properties:

Default: | cblcore in the current working directory.
Setting: | None

Example:

The command

set core_filename="core.%p@%t_%d"

will produce a filename such as core.12345@165920_20080115.

Parent topic: Debugging Using a Core Dump
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


Remote Debugging of Native COBOL Applications

Note: The following applies to native code only.
  • Overview - Debugging Native COBOL Applications Remotely
    You can use Studio Enterprise Edition to debug programs that are running on a different computer from the one on which you are using to develop COBOL.
  • To set up remote debugging for native COBOL applications
    The local and remote systems must be networked using TCP/IP and the cobremotedaemon process must be started.
  • To debug a native COBOL program running remotely
  • Troubleshooting - Communications Issues when Debugging Native COBOL
Parent topic: Debugging Native COBOL Programs


Overview - Debugging Native COBOL Applications Remotely

Note: The following applies to native code only.

You can debug programs that are running on a different computer from the one on which you are using to develop COBOL.

The remote computer can be a Windows system or a UNIX system.

Either the COBOL development system or Server Enterprise Edition needs to be installed on the remote computer. Enterprise Server is not required.

To debug remotely, the two systems must be networked using TCP/IP and must be set up appropriately.

Parent topic: Remote Debugging of Native COBOL Applications


To set up remote debugging for native COBOL applications

Restriction: The following applies to native code only.
  1. Before you start your COBOL development system, ensure that the local and remote systems are networked using TCP/IP. See your Configuring CCI Guide.

    The two systems must be connected using the same CCITCP2 or MFDS process. A simple way to do this would be to set the CCITCP2 variable on the local machine where you run the IDE to point to the remote machine.

    This environment variable must be set so that the Visual Studio devenv process can picks it up.

    You can set the variable from at a command prompt:

    set CCITCP2=machine-with-CCI

    Where machine-with-CCI can be the machine name or its IP address.

    Then, you need to execute devenv to start the IDE from the same command prompt.

    Alternatively, you can set CCITCP2 globally for your machine, from Control Panel > System >Advanced System settings.

  2. On the remote machine, start a COBOL system command environment, and start a cobremotedaemon process.

    You can start multiple processes and thereby enable multiple users to debug remotely on this machine. To do this, you name each process individually, using a command like this:

    cobremotedaemon name="MyRemoteDaemon"
  3. To allow remote debugging, add the following inbound rules to the firewall on the remote machine:
    • Ensure that port 86 is opened for TCP and UDP protocols.
    • Allow access through the firewall for the following programs - cobremotedaemon, cobdebugengineproxy (and cobdebugengineproxy64 for 64-bit environments) which are in the <install-dir>/base/bin directory.
Parent topic: Remote Debugging of Native COBOL Applications


To debug a native COBOL program running remotely

Note: The following applies to native COBOL only.
  1. Set up remote debugging.
  2. Build your project for debugging.
  3. Specify the remote machine as follows:
    • Click Project > Properties.
    • Go to the Debug tab.
    • Check Use remote machine.
    • Fill in the IP address or name of the remote machine.
  4. Click Debug> Start Debugging .
    Note: To debug a program on a remote UNIX machine, you need to have an X Window implementation installed and running, so that the output of the remote program can be viewed on your local machine.
  5. When you stop debugging, the cobremotedaemon process continues to run. When you no longer need the process, stop it manually, using:
    cobremotedaemon stop daemon-name
Parent topic: Remote Debugging of Native COBOL Applications


Troubleshooting - Communications Issues when Debugging Native COBOL

Note: The following applies to native code only.
CCITC32-0025E Transport initialization failure CCI_Initclient could not find CCITCP2

The CCITCP2 process could not be found. This process normally runs as a windows service so it may have been stopped or uninstalled.

Use the Services tool to check that either 'Micro Focus CCITCP2 daemon' or 'Micro Focus Directory Server' is installed and started. If neither is installed use the Repair option of the Micro Focus Studio Enterprise Edition installation.

CCITC32-0006E An invalid server or machine name was presented to CCITCP

The remote machine name specified in the debug configuration could not be found or is invalid.

Check you have entered the name correctly.

Parent topic: Remote Debugging of Native COBOL Applications


Debugging mainframe applications and services on Enterprise Server

To debug applications and services you need to run them on an enterprise server which has the Dynamic Debugging option set. This option enables you to debug services from within your COBOL development environment, while the services are running on a local or remote enterprise server. This requires no changes to your program code.

When you debug a project with Dynamic Debugging enabled, you can specify the items to debug. For example, you can specify that you want to debug instances of a given transaction.

Before you can debug services, you need to prepare. You need to configure the enterprise server, deploy your service and make sure that both the enterprise server and your development environment are set up appropriately.

  • How Debugging on Enterprise Server Works
  • To prepare for debugging on enterprise server
  • To debug on enterprise server
  • Error Messages for Web Services
Parent topic: Debugging Native COBOL Programs


How Debugging on Enterprise Server Works

When you start a debug session for a project that uses an enterprise server configured for Dynamic Debugging, you can tell the server that you want to debug any service or application instance that matches criteria that you supply. For example, you can specify that you want to debug instances of a given web service that are started from a particular client machine.

Each time an application or service is started the enterprise server checks to see if it matches the criteria that you supplied. If it does, the enterprise server attaches it to your debug session. You can then step through the application in the normal way.

Your match criteria can be specific or general. However, we recommend that you are as specific as possible to avoid conflicts with other users. If more than one user specifies details that match a particular service or application instance, the most specific match (that is, the session that provided the most specific information) is attached to the instance.

For example:

  1. USERA specifies CICS transactions started from a particular Terminal ID
  2. USERB specifies CICS transactions started from the same Terminal ID, but also specifies the transaction ID
  3. When a matching CICS transaction is started, the enterprise server attaches USERB's debug session to the CICS transaction

When you specify the match criteria, you are warned if they are similar to those provided by another user. If you specify identical match criteria to those provided by another user, you receive an error message and the criteria are rejected.

Note: You can view the active dynamic debug sessions and the associated debug criteria on your enterprise server by using the Dyn-Dbg button in ESMAC. You can also use the screen to remove debug criteria that are no longer required.
Parent topic: Debugging mainframe applications and services on Enterprise Server


To prepare for debugging on enterprise server

  1. Open the Enterprise Server Administration Web page. To do this:
  2. Enable dynamic debugging for the enterprise server that you want to use for debugging. To do this:
    1. In the table of servers on the Home page of Enterprise Server Administration, find the row for the server that you want to configure, and click Edit in the left hand column.
    2. In the Server > Properties > General section, select Allow Dynamic Debugging.
    3. Click OK to confirm your changes.
    Important: You must restart the server for the changes to take effect.
  3. Configure the enterprise server to run your application or transaction, by enabling Mainframe Subsystem Support (MSS) and JCL support as required.
  4. Make sure that the symbol files (.idy) for the application are available. In Visual Studio, configure the locations that are searched for symbol files as follows:
    1. Click Tools > Options > Debugging > Symbols.
    2. Add a new folder by clicking the New Folder button.
    3. In the Symbol file locations list, enter the absolute path to the .idy files.
    If the symbol files for the application cannot be found, the application runs without debugging and no error message is shown. There is however a message shown in the output window.
  5. Associate the project with the enterprise server:
    1. Ensure that your project is open.
    2. In Server Explorer, expand Micro Focus Servers.
    3. Expand the subgroup of servers.
    4. Right-click the enterprise server region with which to associate your project.
    5. Select Associate with project > your project .
Parent topic: Debugging mainframe applications and services on Enterprise Server


To debug on enterprise server

  1. Prepare for debugging.
  2. Click Project > myprojectProperties and go to the Debug tab.
  3. Click the tab for the type of service or application that you want to debug and enter its details, as follows:
    • For a Web Service, enter the IP address of the client that will make the service request. You can also enter the fully qualified name of the service. This is formed by taking the name of the service and appending a pound or hash character (#) followed by the name of the operation that you want to debug. For example, if the service name for the web service that you deployed is http://tempuri.org/wmapserv, and the operation to be debugged is Read, the fully qualified service name is http://tempuri.org/wmapserv#Read.
    • For CICS, you can enter the CICS terminal ID, the CICS transaction for the application and so on. For non-facility tasks (those not running on a terminal or printer) specify '....' for the value of the terminal ID.
    • For JCL, you can enter job name, job number, top-level program and so on.
  4. Click Debug > Start Debugging .
  5. Start the service or application on your enterprise server. How you do this depends on what type of application it is. For example:
    • For a Web Service, you can run the client program and enter some input. You cannot run the client module from within your debug session. However, if the client program is part of a different project to the one that you are using for debugging, you can start another session, open the client project and run the client module.
    • For a CICS application, you can start a TN3270 terminal session and run your transaction.
  6. Step through the deployed programs in the usual manner. When debugging reaches the exit program statement and no line is highlighted, the service or application has exited. The debugger now waits for the next matching service or application to start.
  7. When you have finished debugging, click Debug > Stop Debugging .
Parent topic: Debugging mainframe applications and services on Enterprise Server


Error Messages for Web Services

You may find, when you are debugging a Web service, that the client returns error 0015. This is a time-out, and is caused by the service not returning to the client in the expected time, because you were debugging it. If you find this a problem, you can change the timeout interval by editing the Micro Focus Common Client (MFCC) configuration file, which by default is mf-client.dat, located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin. You can create your own configuration file of any name or location, but you must identify it using the MFC_CONFIG environment variable.

Open the file and insert:

[defaults]
timeout=nn

where nn is the desired timeout period in seconds (at run time the figure is rounded up to a multiple of 5).

Parent topic: Debugging mainframe applications and services on Enterprise Server


To configure the symbol path for native COBOL applications

Note: The following applies to native code only.
Note: If you are debugging from within a project, you do not need to set this option; the symbol path is set to the project output path by default.

To configure the directory paths that are used to search for the application .idy files when you attach to a native running process or use Just-in-Time debugging:

  1. Click Tools > Options > Debugging > Symbols.
  2. Use the Symbol file (.pdb) locations pane to add or remove paths to search for the symbols files (.idy files), as required.
Restriction: The Micro Focus Native COBOL debugger does not support the Symbol Cache and Load all symbols options.
Parent topic: Debugging Native COBOL Programs


To set a COBOL watchpoint in native COBOL code

Restriction: Works with native code only.

You can add COBOL watchpoints ( [image]) in the source code in one of the following ways:

  1. To add a watchpoint from the editor, right-click a data item and select Add COBOL Watchpoint.

    This opens the Watchpoints (Native COBOL) window and adds the data item to it.

  2. Add a watchpoint from the Watchpoints (Native COBOL) window:
    1. To display the window, click Debug > Windows > COBOL Watchpoints.
    2. Click New.
    3. Type a data item in the field and press Enter.

      Click [image], [image], [image] to enable, disable or delete watchpoints as necessary.

Parent topic: Debugging Native COBOL Programs


To attach to a native running process and debug

Note: The following applies to native code only.

To attach the Micro Focus Native Debugger to a 32-bit or 64-bit running process:

  1. Click Debug > Attach to Process.
  2. In the Attach To: field, click Select.
  3. Check Debug these code types.
  4. Select Micro Focus Native Debugger.
  5. Click OK.
  6. Select the process to debug from the list.
  7. Click Attach.

    The debugger is attached to the process, but will not break execution until the process hits a breakpoint, an error occurs, or you press the break button.

Parent topic: Debugging Native COBOL Programs


To debug a native COBOL project that compiles to multiple executables

Important: You cannot debug a project that compiles to .int or .gnt code if it is set to package the output files as an .lbr file. Before you can debug such projects you need to disable the setting Package as .lbr on the Application page in your project's properties.
  1. In Solution Explorer, select the project to debug.
  2. Click Debug > Start Debugging. If your project only includes one COBOL program, the IDE starts a debug session.

    If the project includes two or more COBOL programs, this starts Select the program to debug dialog showing all executable files that you can debug.

  3. Set the file type filter set to the desired file type.
  4. Select the executable you want to debug and click Open. This starts the Micro Focus debugger.
  5. Step through the program in the usual way.
Parent topic: Debugging Native COBOL Programs


Running Native COBOL Applications

Note: The following information applies to native code only.
  • Overview of Configuring Run-time Behavior for native COBOL applications
  • Application Configuration
  • To set run-time environment variables and switches for native COBOL applications
Parent topic: Developing COBOL Applications


Overview of Configuring Run-time Behavior for native COBOL applications

Note: This information applies to native code only.

You can ensure that your application is always run in a consistent environment by building a run-time configuration into the application. These settings configure the COBOL run-time environment each time your application is started so that it always behaves as you have specified, regardless of settings used by other COBOL applications.

You can configure the application behavior using:

  • Configuration file. You can create a configuration file for the project in the IDE. You can configure items such as memory allocation, the search order for called programs, how to handle ANSI displays and so on.
  • Run-time tunables. Certain run-time behavior can be configured only by using run-time tunables. These are stored in a configuration file that is read when the run-time system or a statically linked executable starts up.
  • COBOL switches. You can also configure the COBOL switches that are used when your application starts up. Their state can be read by your application while it is running, and thereby change your initial setting.
  • cobopt.cfg files. The settings in this file are equivalent to the run-time configuration settings in the IDE. You can import configurations from these cobopt.cfg files.
Parent topic: Running Native COBOL Applications


Application Configuration

You can specify how your native COBOL application should be run, by specifying the required settings in a configuration file. You can specify the following:

  • Environment variables - These set or modify the environment that is required for your native COBOL applications
  • COBOL switches - The COBOL programmable switches (numbered from 0 to 8) must be defined using a condition name in the special-names paragraph in your program. Then you set the switches on and off when your app is started. Their state can be read by your application at any time when it is running.

The configuration file is named Application.config.

You can add an application configuration file for all types of native projects except for Mainframe Subsystem Applications. This is because under Enterprise Server you configure the environment in a different way. You specify them either on the MFDS region configuration page or from the command line environment if you start Enterprise Server from the command line.

If you run your application outside of the Visual Studio IDE, you need to set the environment variable COBCONFIG.BLOCK to the location of the application configuration file in order for the switches and environment variables set for the application to be applied.

Parent topic: Running Native COBOL Applications
Related concepts
To set run-time environment variables and switches for native COBOL applications
To add a configuration file
Related reference
Setting Run-time Switches
0, 1, 2, 3, 4, 5, 6, 7 and 8 run-time switches


To set run-time environment variables and switches for native COBOL applications

Note: This information applies to native code only.
  1. In Solution Explorer, open the application configuration file for your project. By default, it has the file extension .config.

    If the file does not exist, create one.

  2. On the Environment tab, enter a variable name and its value in the Name and Value fields, and click Set.
  3. On the COBOL Switches tab, check the switches you require.
  4. Click OK.
Note: If you run your application outside of the Visual Studio IDE, you need to set the environment variable COBCONFIG.BLOCK to the location of the application configuration file in order for the switches and environment variables set for the application to be applied.
Parent topic: Running Native COBOL Applications
Related concepts
Application Configuration
To add a configuration file
Related information
Setting Run-time Switches
Run-time Switches


Running Mainframe Applications on Enterprise Server

  • Server Explorer
  • To view the available servers
  • To refresh the list of the available servers
  • To sign on to Enterprise Server
  • To connect to a remote enterprise server
  • To access Enterprise Server Administration
  • To start, stop, or restart an enterprise server region from the IDE
  • To associate an enterprise server region with a Mainframe Subsystem Application
  • To submit a JCL file
  • To show the spool and the catalog
Parent topic: Developing COBOL Applications


Server Explorer

Server Explorer is a feature that enables you to connect to servers, as well as view and access their resources. For example, you can connect to, view and access the following resources:

  • Data Connections
  • Servers
  • Event Logs
  • Services

In your COBOL development system, you can also view and access a Micro Focus server. You can:

  • Connect to a Micro Focus server and check which regions are running
  • Start and stop Micro Focus regions
  • Run and monitor Mainframe Subsystem applications
  • Access the enterprise server administration facilities

The related links contain information on the commands available via Server Explorer for maintaining the Micro Focus servers and mainframe applications:

  1. View the available Micro Focus regions on your local machine or connect to an enterprise server running on a remote machine
  2. Specify sign on details as required
  3. Open the Enterprise Server administration page to create and configure enterprise server regions.
  4. Associate Mainframe Subsystem applications with enterprise server regions.
  5. Start or stop enterprise server regions.
  6. Update the status of the enterprise server regions.
  7. Run the mainframe application.
  8. Use the Enterprise Server administration facilities to monitor the execution of your mainframe applications.

If Server Explorer is not displayed, click View > Server Explorer or View > Other Windows > Server Explorer.

Parent topic: Running Mainframe Applications on Enterprise Server
Related information
To view the available servers
To refresh the list of the available servers
To sign on to Enterprise Server
To connect to a remote enterprise server
To access Enterprise Server Administration
To start, stop, or restart an enterprise server region from the IDE
To associate an enterprise server region with a Mainframe Subsystem Application
To submit a JCL file
To show the spool and the catalog


To view the available servers

  1. In Server Explorer, right-click the Micro Focus Servers group.
  2. Choose Refresh from the context menu.
  3. Expand the Micro Focus Servers group by clicking Expand.
  4. Expand the group that contains an enterprise server for which you want to view defined regions.

The enterprise server regions created on your machine appear under the localhost group.

Parent topic: Running Mainframe Applications on Enterprise Server


To refresh the list of the available servers

  1. In Server Explorer, right-click the Micro Focus Servers group.
  2. Choose Refresh from the context menu.
  3. Expand the Micro Focus Servers group by clicking Expand.
Note: Server Explorer does not refresh the server list automatically. You must refresh is manually as described above.
Parent topic: Running Mainframe Applications on Enterprise Server


To sign on to Enterprise Server

  1. In Server Explorer, right-click the Micro Focus Servers group.
  2. Select User details from the context menu.
  3. Specify a User ID, Password and a Group as appropriate.
  4. Check Force all to upper case if required.
Parent topic: Running Mainframe Applications on Enterprise Server


To connect to a remote enterprise server

  1. In Server Explorer, right-click on Micro Focus Servers.
  2. Click MFDS Configuration.
  3. Specify the remote machine in one of the following ways:
    • Click Host name and enter the name of the host
    • Click IP Address and enter the IP address of the host
  4. Specify a port number.
    Note: By default, Server Explorer displays the group of available regions on your local machine accessible on port 86. Contact the remote machine Administrator to determine the port number of the remote machine.
  5. Click OK.
Parent topic: Running Mainframe Applications on Enterprise Server


To access Enterprise Server Administration

  1. In Server Explorer, right-click on Micro Focus Servers.
  2. Select Administration from the context menu.
Parent topic: Running Mainframe Applications on Enterprise Server


To start, stop, or restart an enterprise server region from the IDE

You can start and stop regions on your local machine only. These options are not available when you select a remote server.

  1. In Server Explorer, right-click your enterprise server under the Micro Focus Servers group.
  2. Choose the appropriate option from the context menu.

    A security dialog box might appear. If the server you are starting has no security set, click OK to continue. Otherwise, select Server is secured and enter the credentials. You can choose to store these connection settings to skip this step in the future when starting, stopping, or restarting the server, or submitting a JCL job.

    To clear saved the connection settings, right-click your enterprise server in Server Explorer and click Clear credentials.

    You can see the progress of the command in the console if you have enabled Show Local Console for your enterprise server.

Parent topic: Running Mainframe Applications on Enterprise Server


To associate an enterprise server region with a Mainframe Subsystem Application

You can associate a particular project with only one region at a time.

  1. Ensure that your project is open.
  2. In Server Explorer, expand Micro Focus Servers.
  3. Expand the subgroup of servers.
  4. Right-click the enterprise server region with which to associate your project.
  5. Select Associate with project > your project .
Parent topic: Running Mainframe Applications on Enterprise Server


To submit a JCL file

  1. Ensure that your JCL project is open and that your JCL configured enterprise server is running.
  2. Associate the enterprise server region with your project.
  3. Right-click the .jcl file in Solution Explorer.
  4. Click Submit JCL.

Alternatively, you can submit a JCL file using drag and drop feature as follows:

  1. Select the .jcl file in Solution Explorer or, click on it in Windows Explorer outside of Visual Studio.
  2. Drag the file to Server Explorer and drop it on the JCL configured region.

You can use drag and drop to submit JCL files that are not part of projects associated with the JCL configured server.

Parent topic: Running Mainframe Applications on Enterprise Server


To show the spool and the catalog

To view the spool and catalog, the region has to be started.

  1. In Server Explorer, refresh the Micro Focus Servers group.
  2. Expand Micro Focus Servers.
  3. Expand the group of regions.
  4. Right-click the enterprise server region.
  5. Click Show catalog or Show spool as appropriate.
Parent topic: Running Mainframe Applications on Enterprise Server


Test Coverage for Native COBOL

Note: The following applies to native COBOL only.
  • Overview - Test Coverage and Native COBOL
  • Test Coverage Configuration File for Native COBOL
  • Format of a Test Coverage Report for Native COBOL
  • Reporting on Tagged Lines for Native COBOL
  • Test Coverage Tag File for Native COBOL
  • Troubleshooting Test Coverage
  • Test Coverage Error Messages
  • How To...
Parent topic: Developing COBOL Applications


Overview - Test Coverage and Native COBOL

Restriction: Test coverage supports native COBOL only.

Development teams often need to show that they have performed testing which has covered all logical paths through a program. Using the test coverage utility, they can produce a report to illustrate the extent of test coverage, and can promote this report along with the source code at the various stages of the development lifecycle.

While a program is running in test coverage mode, code execution is logged for each program and sub-program that has been compiled with the TESTCOVER directive set. The results are stored in a binary results file, which has the filename extension .tcz. The information stored in the results file depends on how you configure test coverage.

Running a program in test coverage mode uses significantly more resources than running the same program without test coverage enabled. As a result, we recommend that you use test coverage only in development systems; we recommend that you do not use test coverage in production systems.

As the results file is a binary file, it has to be formatted to produce a text or HTML report file. You can create a report file from the command line, using the reporting utility TCReport . Reports can be formatted to produce a plain text (.txt) file or an HTML (.htm) file.

You can also tag statements in your source code and use test coverage to report on whether these statements have been executed. This is particularly useful if you want to see the coverage of new or changed lines in your source code.

  • Report Files Created for Native COBOL
  • Recompiling Programs
  • Restrictions when Using Test Coverage in Native COBOL
Parent topic: Test Coverage for Native COBOL
Related reference
TESTCOVER


Report Files Created for Native COBOL

Note: This applies to native COBOL only.
The following files are created:
  • An index file, called tcindex.htm or tcindex.txt
  • The .htm or .txt report files
You can view the generated .txt file in any editor, or open the .htm file in your browser. The index file is overwritten every time you produce reports.
Parent topic: Overview - Test Coverage and Native COBOL


Recompiling Programs

Note: This applies to native COBOL only.

If you recompile a program that has already been used to produce a .tcz results file, you need to be aware that the .idy file required for reporting the source lines executed will be overwritten and so will give a mismatch on the source lines in the original .tcz file. You will be given a warning when trying to produce a report if an .idy file cannot be found to match exactly a particular program.

Parent topic: Overview - Test Coverage and Native COBOL


Restrictions when Using Test Coverage in Native COBOL

Note: This applies to native COBOL only.
The following restrictions apply to test coverage:
  • Manually changing the execution point while debugging a program produces test coverage results that are unpredictable.
  • If you have a multi-threaded program (one that is compiled with the REENTRANT directive) and you compile it with the TESTCOVER directive and run it under test coverage, the test coverage results obtained will be unpredictable.
  • When the TESTCOVER directive is used with preprocessors, only the basic blocks of the original code are taken into account.

We recommend that you do not use test coverage in a production system because of the increased requirements on system resources when running in test coverage mode. However, you can compile TESTCOVER into your production system if needed.

Parent topic: Overview - Test Coverage and Native COBOL
Related reference
TESTCOVER
REENTRANT


Test Coverage Configuration File for Native COBOL

Note: This applies to native COBOL only.

An example test coverage configuration file, default.tcf, is supplied in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.xbase\source\testcover. You can edit this or use it as is.

The configuration is a text file that has the format:

[TESTCOVER]
; comment
RESULT filename.tcz [ACCUMULATE]
ECHOLOG [YES|NO]
LOGNAME [filename]
where the options are:
[TESTCOVER]
The configuration file must contain this tag. It identifies the file as a test coverage configuration file.
; comment
The semicolon (;) identifies a comment line. The semicolon must be positioned in the first column of the file. Comments can appear anywhere in the file. Optional.
RESULT filename.tcz [ACCUMULATE]
Specifies the results (.tcz) files to create. Your configuration file must contain a RESULT keyword.
ACCUMULATE
Optional. If specified, test coverage accumulates the results of succesive runs in a single results file filename.tcz.

If you omit ACCUMULATE, on each run test coverage overwrites filename.tcz, unless you use the variable version of filename.tcz (see below).

filename.tcz
The name of the file that is to hold test coverage results. If the file does not exist, a new file is created.

filename.tcz can include the following:

  • an absolute or relative pathname. If the pathname includes the name of a folder that does not exist, the folder is created, for example:
    RESULT tcresult.tcz

    creates the results file tcresult.tcz in the current folder, while

    RESULT ./results/tcresult.tcz

    creates the results file tcresult.tcz in the folder results, which will be created below the current folder.

  • a variable filename, by using the question mark (?) wildcard in the name.

    In this case, the filename should be specified in the form str????.tcz, where str can be any appropriate string. Test coverage then looks for files which match the wildcard string str????.tcz. It then takes the highest numeric value found in the wildcard character positions, increments that value, and uses this as the filename to which to write results.

    For example, if you specify the filename as x????.tcz, and the files x0001.tcz and x0002.tcz already exist, then test coverage automatically creates x0003.tcz.

    The number generated has as many digits as there are wild cards. For example x??.ccz generates x01.ccz, x02.ccz, and so on.

    Using a variable filename enables you to create separate results files for multiple runs of test coverage, without needing to change the configuration file for each run.

  • the token <pid>, which is replaced by the current process id, for example:
    RESULT myres_<pid>.tcz

    creates the results file myres_2749.tcz, assuming a process id of 2749.

ECHOLOG [YES|NO]
Specifies whether the test coverage summary should be echoed to the screen or not. Optional.

If you do not specify an option, or the keyword is omitted, the default is YES.

Use ECHOLOG NO if your application might have problems accessing the screen; for example, during debugging.

LOGNAME [filename]
At the end of each run, the test coverage summary is appended to filename. If filename is not specified, a default file is used, with the name projectdir\testcover\testcover.log, where projectdir is the folder in which your project is located. Optional.

The filename specified for the LOGNAME keyword can include the token <pid>. See the description of the RESULT keyword for more information on this token.

We recommend that a configuration file should contain at least the following:

[TESTCOVER]
ECHOLOG NO
RESULT filename.tcz ACCUMULATE
Note:
  • Only one RESULT, ECHOLOG and LOGNAME keyword are allowed. You can have more than one instance of each of the keywords if they are non-active; that is, preceded by the semicolon (;) comment character.

Examples of the RESULT keyword

RESULT .\results\tcresult.tcz ACCUMULATE

Test coverage accumulates all results in the tcresult.tcz, located in the folder results relative to the current folder.

RESULT c:\myres\tcresult.tcz

As the ACCUMLATE verb has been omitted, test coverage stores its results in the file tcresult.tcz, which will be overwritten on each run.

RESULT run????.tcz

Separate results files are used for each run. In this example, on the first run, test coverage would create the results file run0001.tcz. On the second run, test coverage would create the results file run0002.tcz. The number would increment for each additional run.

Configuration file example

[TESTCOVER]
RESULT run????.tcz
ECHO NO
LOGNAME testcover.log

This example shows a complete configuration file. Separate results files are used for each run. Results are not to be echoed to the screen. Summary results are to be appended to testcover.log.

Parent topic: Test Coverage for Native COBOL


Format of a Test Coverage Report for Native COBOL

Note: This applies to native COBOL only.

When you use TCReport to create reports, the following files are produced:

  • An index file (tcindex.htm), in HTML format, which links to your reports.
  • Your reports, in either HTML (.htm) or text (.txt) format.

The information contained in the .htm or .txt files is the same; the .htm format enables the report to contain links to sections within the report.

The picture below shows an example tcindex.htm index report.

Figure 1. Test Coverage Report
Test Coverage Report

The Contents section lists all of the programs in this report. If you had specified the COMBINE option, all the programs would be listed here, with the reports displayed further down the document. This report contains links to two report files: swap-elements.htm and vsort.htm. If you change the location of the report files, enter the new location in the Report Location field so that this report can locate them.

Below is the top of the report for vsort.htm. Report files saved as text contain exactly the same information, and differ only in containing links and formatting enabled by HTML. The explanation of the report contents given below also applies to text files.

Figure 2. Test Coverage Report
Test Coverage Report

The Contents section lists only one program - if we had specified that all the results were to be combined in this report, there could potentially be a large number of programs listed in the Contents section, and we would be able to click on a program name to jump straight to the section of the report that contained the results for that program.

On the row containing the name of the program, you can use the pull-down menu of Unexecuted Blocks and click GO to navigate directly to a specific unexecuted block in that program.

The rightmost column, block, shows the blocks of code in your program. Blocks can be thought of as a number of statements with no jumps: when you've executed one line, the next is executed. They are executed consecutively. Numbering starts from zero. The block starting on line 17 as shown above covers four lines of code, and then has a jump, which means the next block starts.

The other column on the right, count, shows how many times the block has been executed.

Below is the bottom of the report for vsort.htm.

Figure 3. Test Coverage Report
Test Coverage Report

The summary at the bottom shows the percentage of statements, blocks, sections and CALL statements which have been executed in your program.

The number of basic blocks shown tells you that there are five areas of code, thirteen statements and one section/ paragraph which have not been executed.

Parent topic: Test Coverage for Native COBOL


Reporting on Tagged Lines for Native COBOL

Note: This applies to native COBOL only.

It can be useful to report on the coverage of new or changed lines in your source code. You can do this by tagging the new or changed lines, and then creating a report that provides additional information specific to these tagged lines. You can choose to report on some or all of your tagged lines.

You first have to create tags in your source code. The tags can be any appropriate string (such as, for example, sdnw01, or chng02) entered in the left (columns 1 through 6) or right (columns 73 through 80) margin of your source code. Your tags can only be six characters long.

You then run your program in test coverage mode.

You can create the tag-specific information in the test coverage report using the command line TCReport utility.

Parent topic: Test Coverage for Native COBOL


Test Coverage Tag File for Native COBOL

Note: This applies to native COBOL only.

The test coverage tag file is used by TCReport to identify tags in your source code, enabling TCReport to provide information specific to the tagged lines.

The tag file is a text file that contains a list of the tags for which you want information, and a keyword specifying which margin of your source code your tags are in.

The format of the tag file is:

margin
tag1, [tag2, ...]
# comment
where the parameters are:
margin
The margin used by your tags. This can be set to either:
  • @LEFT, which specifies that your tags are in the left margin (columns 1 through 6)
  • @RIGHT, which specifies that your tags are in the right margin (columns 73 through 80).

You can specify one keyword or the other, but not both. By default, margin is set to @LEFT.

tag1, [tag2, ...]
A comma-separated list of tags. The list can contain up to 20 tags. You can also split the list over multiple lines. In this case you need not delimit the last item in the line with a comma. For example:
new1, new2, new7
chg1,chg5
upd4, upd5,up8
#
The # indicates a comment line. Comment text is optional.
Parent topic: Test Coverage for Native COBOL


Troubleshooting Test Coverage

Note: This applies to native COBOL only.
If you have any problems with test coverage, check the following issues and follow the suggestions.
TCReport Cannot find the .idy file
Set COBIDY to the location of the .idy file.
No results file has been produced
Ensure your environment variable is pointing to a valid .tcf file, and that your .tcf file contains a results line.

Ensure you have compiled your program with the TESTCOVER directive set.

Ensure you have exited from the program you are running. The results are only written when the program has exited. If you are debugging a program, you must stop the debugger if it is still active, even when a Stop Run has been encountered. If your program terminates abnormally, the results are not written.

"IDY file cannot be found" error is produced
Ensure you still have the .idy file and source for this compiled version of the program. If you have run another compilation, they will have been overwritten.

If you do have them, and they cannot be located, set COBIDY and COBCPY as necessary to the location of the .idy file.

No source lines are appearing
Ensure that your results file is in the location you were expecting. If you have not specified a directory before the name of the results file in the .tcf file and you are running from a command prompt, the results file will be placed in the directory from which the command line was run, which is not necessarily the same location as the programs. If you are running from the IDE, the results file will be placed in the project folder alongside the application file. You must, therefore, be careful to run your programs from the correct location, or to specify the required directory in the .tcf file.
Not all of the results are being shown, or mismatches are occurring
Ensure that the .cbl or .cpy and .idy files that were used at compile time are still available, and that TCReport can find them. You might need to set COBIDY to the location of the .idy file.
Mismatches are occurring
Ensure you have not recompiled your program, thus overwriting the .idy file so that a mismatch will be given on the source lines in the original .tcz file.

Ensure you do not have different compile versions of a program with the same name in different locations.

Parent topic: Test Coverage for Native COBOL
Related reference
TESTCOVER
Related information
Environment Variables


Test Coverage Error Messages

Note: This applies to native COBOL only.
TC001S No input results file specified
TCREPORT or TCSCAN executed but no results file is named in the parameters.
TC004S Too many program / timestamp combinations
TCREPORT has encountered too many programs with the same name but different timestamps to be able to generate different file name suffixes for all of them.
TC005S Unable to open program source file
TCREPORT was processing a results file and was unable to open the associated source.
TC006S Unable to open output report file
TCREPORT or TCSCAN was unable to open the named report file - it might be protected or locked for use by another process.
TC007S Unable to open output text file
TCREPORT was unable to open the named text file - it might be protected or locked for use by another process.
TC008S Unable to open output index file
TCREPORT was unable to open the named text file - it might be protected or locked for use by another process.
TC009S The version number on the results file is invalid
TESTCOVER writes a version number to the results file which is checked by TCREPORT to ensure compatibility. This error indicates that the results file was written by a version of TESTCOVER that is incompatible with the version of TCREPORT that is reading it.
TC010S Unable to open results file
TCREPORT was unable to open the named file - it might be protected or locked for use by another process.
TC012I NOHTML and NOTEXT specified - nothing to do
If neither NOHTML nor NOTEXT is specified in TCREPORT, no reports are produced.
TC014S Invalid option entered
One or more of the command line options entered in TCREPORT or TCSCAN was invalid. Re-enter the command.
TC018I Severe error encountered
This information message indicates that a severe error was encountered which prevented the program running to normal completion. It will be accompanied by a further message giving more specific details.
TC021S Timestamp mismatch
TESTCOVER timestamp check has detected a program has been canceled, and a different one of the same name reloaded.
TC022S Version number from calling program is invalid
When the user application program is run, it calls TESTCOVER to log statement execution, and passes a version number which TESTCOVER checks to ensure compatibility. This error indicates that the version numbers do not match. Ensure that the product is properly installed, and that all current FixPacks have been applied.
TC034E IDY/Results timestamp mismatch
TCREPORT was unable to find an IDY file with the correct timestamp. Recompile and rerun the program with the TESTCOVER option.
TC035E IDY/Results program not compiled with TESTCOVER
The TCREPORT user program was not compiled with the TESTCOVER option set. Recompile and rerun the program with the TESTCOVER option.
TC037E IDY/Result inconsistency
There is an inconsistency between the IDY and GNL files, in that each shows the program with a different number of code blocks. You need to recompile and re-run.
TC040E missing idy - file, no source available
TCREPORT cannot open the IDY file. It might have been deleted or locked by another process. Free the file or recreate it by recompiling the program and rerunning.
TC043S Unable to open Trace file
Internal error.
TC052S Unable to open the configuration file
The configuration file named in the TESTCOVER environment variable cannot be read. Correct the environment variable or create the configuration file.

System Errors

If you receive any of the following errors, try rerunning with more memory available. Otherwise, contact Micro Focus.

  • TC002S System error null link list pointer
  • TC003S System error - Unable to get current directory
  • TC011S System error Memory alloc failed
  • TC013S system error - Parsing failed
  • TC015S System error - File list allocation failed
  • TC016S System error - Summary list allocation fail
  • TC017S System error - Suffix list alloc fail
  • TC020S SYSTEM error - null caller program pointer
  • TC015S System error - File list allocation failed
  • TC016S System error - Summary list allocation fail
  • TC017S System error - Suffix list alloc fail
  • TC044S System error - CDI2 cannot find program
Parent topic: Test Coverage for Native COBOL


How To...

  • To create test coverage reports for native COBOL
  • To use test coverage from the command line for native COBOL
  • To use test coverage for native COBOL in a production system
  • To report on tagged lines for native COBOL
Parent topic: Test Coverage for Native COBOL


To create test coverage reports for native COBOL

Note: This applies to native COBOL only.
  1. Locate the .tcz file in the location specified in your .tcf file.
  2. From a command prompt, enter:
    tcreport filename [NO]options

    where:

    • filename is one or more .tcz files, separated by a comma, or @filelist.txt, which is a text file containing a list of all .tcz files to be reported on
    • options are shown below. Many of the options can be prepended with no, which means the option will not be acted upon. Options are all off by default, unless otherwise stated. They can be specified in any order. None is mutually exclusive.
      [no]blocknum | Displays the basic block number of each statement in the rightmost column. Blocks can be thought of as a number of contiguous statements with no jumps. They are executed consecutively. Lines within a block will have the same basic block number. There is a limit of 65535 basic blocks per program.
      [no]browse | Opens your browser with the report file in HTML format.
      [no]calls | Gives a summary of CALLed subroutines. Called subprograms are listed alphabetically. The CALL overhead in COBOL can be considerable, and this lets users identify the most commonly called routines.
      [no]combine | Produces a single text and/or HTML file, instead of individual ones on a per program basis.
      [no]datafreq | Computes the total execution count for each data item in the program. ie. it totals the execution counts for all statements in which a data item is referenced. This report also identifies misaligned 2-, 3- or 4-byte items.
      [no]echo | Echoes output to the console.
      [no]html | Creates the output in HTML format. If you do not specify an output format, HTML is on by default: use [no]html if you do not want an .htm output file.
      [no]leftcol | Displays the columns for counts and block numbers on the left of the report.
      reportloc(location) | Creates the report in the folder specified by location.
      rootname(rootname) | Creates reports with a name prepended with rootname.
      [no]source | Produces a listing of the program source, showing execution counts for every statement. This option is on by default. Both the .idy and .cbl source file need to be present for the execution counts to tally correctly.
      taglines(tagfile) | Specifies the tag file, which identifies tags in your source code for which you want the report to generate specific information.
      text | Creates the output in text format, with a .txt extension.
      [no]verbs Gives a summary of COBOL verbs used. Verbs are listed in descending order of execution. The columns used are:
      • occurs - which shows the number of occurrences of that verb in a program
      • coverage - which shows the number of this type of statement that were covered, and what percentage of these verbs it represents
      • executed - which is the total of all the execution counts for this type of statement, and the percentage of the program's total execution count this represents
  3. Open the resulting index file to view the tcindex.txt or .htm file.

If you want to simply list the programs in your .tcz file, without looking at the report file, from a command prompt enter:

#tcscan filename

where filename is the name of your .tcz file.

Parent topic: How To...


To use test coverage from the command line for native COBOL

Note: This applies to native COBOL only.
  1. Create a test coverage configuration file.
  2. Build your application with the TESTCOVER compiler directive set.
  3. Set the TESTCOVER environment variable.

    The value of the variable should be the path of the test coverage configuration file.

  4. Run your application.

    Depending on how you set the options in your configuration file, one or more results (.tcz) files are created.

  5. If you want test coverage to report on tagged lines, create a tag file.
  6. Use TCReport to produce reports from the results files. If you want to include information on tags, set the taglines option.
Parent topic: How To...
Related reference
TESTCOVER
Related information
Environment Variables


To use test coverage for native COBOL in a production system

Note:
  • This applies to native COBOL only.
  • We recommend that you do not use test coverage in a production system because of the increased requirements on system resources when running in test coverage mode.

To use test coverage in a production system, you need:

  • To ship the file testcover.dll which enables your users to run a program that has been compiled with the TESTCOVER directive. This file is in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.xbase\bin directory by default.
  • To supply the .idy and the .cbl or .cpy files for the production code. This enables your user to produce .tcz results files.
  • The TCReport executable file, tcreport.exe. You need this file in order to produce reports, as it is used to match the source lines in the code with the results.
  • To ship the appropriate test coverage configuration (.tcf) file.
  • To ensure your user sets up the TESTCOVER environment variable.
Parent topic: How To...


To report on tagged lines for native COBOL

Note: This applies to native COBOL only.

To be able to produce a report with information specific to tagged lines, you must first enter tags in your source code. You can produce the report using TCReport.

Before you can format and display a report, you must create a test coverage binary file (a .tcz file) by running test coverage.

  1. Enter the command:
    tcreport filename taglines(tagfile) [options]

    where filename is the .tcz file you are using to create the report, tagfile is the file that specifies the tags to be used, and options are other tcreport options.

    For example:

    tcreport myreport.tcz taglines(tagfile.txt)
Parent topic: How To...


Deploying COBOL Applications

  • Deploying Native COBOL Applications
  • Server Enterprise Edition
  • Deploying COBOL Applications to the .NET Environment
    This chapter explains how to deploy COBOL applications to the .NET environment.
Parent topic: Developing COBOL Applications


Deploying Native COBOL Applications

Note: The information in this section applies to native COBOL only.
  • Overview of Deploying Native COBOL Applications
  • Shipping Selected Files from Server Enterprise Edition
  • Writing Your Own Setup Program
  • To set up an application with a shared Server Enterprise Edition
  • To set up an application with its own Server Enterprise Edition
Parent topic: Deploying COBOL Applications
Parent topic: Deployment
Related concepts
Deploying Native Applications


Overview of Deploying Native COBOL Applications

Note: The following applies to native COBOL only.

Native applications developed using a COBOL development system require a COBOL run-time server to provide the necessary run-time system and support.

Server Enterprise Edition is your COBOL run-time server. It is supplied as part of Studio Enterprise Edition, which is your COBOL development system. Server Enterprise Edition is also supplied separately.

End users need to install COBOL run-time licenses before they can run applications that use the COBOL run-time system.

You need to:

  • Ship Server Enterprise Edition with your application, if it is a modular application. We recommend that you ship the whole of Server Enterprise Edition to avoid compatibility issues and other problems.
  • Ensure that the application you have developed has the proper Server Enterprise Edition licenses. Your end users need to install the licenses before they can run the application. This is done by using the Micro Focus Licensing Administration Tool. The license Authorization Code, required to license the application, is either supplied when you ship the COBOL run-time server with the application or by end-user request from Micro Focus.
Note: This product is available in two variants which you can install and use with the same license - Server Enterprise Edition which is the deployment environment for COBOL applications created with Studio Enterprise Edition for Visual Studio 2010 or Studio Enterprise Edition for Eclipse, and Server Enterprise Edition 2012 which targets applications created with Studio Enterprise Edition for Visual Studio 2012.

Studio Enterprise Edition for Visual Studio 2010 and Studio Enterprise Edition for Visual Studio 2012 each target a different version of the COBOL run-time system - Server Enterprise Edition and COBOL Server 2012, respectively.

Ensure that after you've edited the project in the preferred version of Visual Studio, you compile your source code in that version of Studio Enterprise Edition which targets the version of the COBOL run-time in which you want your applications to run.

For example, if you build your application using Studio Enterprise Edition for Visual Studio 2010 you cannot deploy the target files to COBOL Server 2012; you must use Server Enterprise Edition.

Parent topic: Deploying Native COBOL Applications
Related information
Deployment Licensing


Shipping Selected Files from Server Enterprise Edition

Note: The following applies to native COBOL only.
CAUTION:

We recommend that you ship the whole of Server Enterprise Edition with your application. However to provide backward compatibility, you can still select and ship specific files.

The Server Enterprise Edition files you need to ship with your application depend on how you linked the application, the type of executable it is, and the support functionality it uses. The files that you need to ship also depend on whether your application is single or multi-threaded.

You can package the files you need in whatever you choose, such as by creating .dll files from the supplied .obj files.

When you ship a modular application that is dynamically linked, you need to ship the following files:

  • The main program of your application
  • Any dynamically linked programs that are part of your application, including objects that have been linked into dynamic link libraries
  • The Microsoft Visual C++ run-time system
  • The file for the shared run-time system, one of the following:
    • cblrtss.dll for single-threaded applications
    • cblrtsm.dll for multi-threaded applications
  • Licensing files
  • The National Locale Support message files for the locales that you support:
    • mflangdf.lbr (default language)
    • mflang01.lbr (American English)
    • mflang05.lbr (English)
    • mflang20.lbr (Japanese)

In addition, you need to ship the following files depending on your application requirements:

  • The file adisctrl, if your application uses the enhanced ACCEPT/DISPLAY syntax, and you have configured it to use a non-default configuration
  • On-site Debugging Support Files to Ship
  • OO COBOL Files to Ship
  • Run-time System Files to Ship
Parent topic: Deploying Native COBOL Applications


On-site Debugging Support Files to Ship

CAUTION:

We recommend that you ship the whole of Server Enterprise Edition with your application. However to provide backward compatibility, you can still select and ship specific files.

The following files are available for you to distribute to assist with on-site debugging, but we do not recommend that you ship them with your applications as a matter of routine:

Debugger
  • animlist.dll
  • animpars.dll
  • animserv.exe
  • animsrvr.lbr
  • cbldbg.dll
  • cobcli.lbr
  • run.cfg
  • run.exe
  • runm.exe
  • runmw.exe
  • runs.exe
  • runsw.exe
  • runw.exe
  • shell.lbr
  • tools.lbr
  • visremot.dll
Debugging shipped single-threaded executable files
cblanms.dll
Debugging shipped multi-threaded executable files
cblanmm.dll
Debugging core dump of shipped executable files
cblcored.exe
Debugging remotely
cbldbg.dll
Test Coverage
testcover.dll
Parent topic: Shipping Selected Files from Server Enterprise Edition


OO COBOL Files to Ship

Note: The following applies to native COBOL only.
CAUTION:

We recommend that you ship the whole of Server Enterprise Edition with your application. However to provide backward compatibility, you can still select and ship specific files.

If your application uses OO programming, you need to ship the following files:

If your application requires: Single-threading files needed: Multi-threading files needed:

OO programming support

  • class.dll
  • classs.dll
  • mfos.dll
  • oopss.cfg
  • oopss.dll
  • class.dll
  • classm.dll
  • mfom.dll
  • oopsm.cfg
  • oopsm.dll

Java and COBOL mixed language support, depending on the JVM used by the application

  • javaclass.dll (OO Java domain class library)
  • mfcobol.jar (Java classes for accessing COBOL)
  • mfjavam.dll (OO java domain)
  • javaclass.dll (OO Java domain class library)
  • mfcobol.jar (Java classes for accessing COBOL)
  • mfjavam.dll (OO java domain)
Parent topic: Shipping Selected Files from Server Enterprise Edition


Run-time System Files to Ship

Note: The following applies to native COBOL only.
CAUTION:

We recommend that you ship the whole of Server Enterprise Edition with your application. However to provide backward compatibility, you can still select and ship specific files.

Many of the frequently required files are already packaged together into the utils.lbr file, which you can ship if it suits your application's needs.

If you require support for: | Single-threading files needed: | Multi-threading files needed:
CBL_EXEC_RUN_UNIT (graphical user interface applications) | cblxecws.exe | cblxecwm.exe
CBL_EXEC_RUN_UNIT (character user interface applications) | cblexecs.exe | cblexecm.exe
Character user interfaces (for true console applications only) | cblvios.dll | cblviom.dll
Character user interfaces (for applications that use the default COBOL text window) | cbldwins.dll | cbldwinm.dll
File handling, for enhanced ACCEPT/DISPLAY syntax (ADIS), and for OO persistence | mffh.dll | mffh.dll
Print support module | cblprnt.dll | cblprnt.dll

Other run-time support files that you might need to ship depending on the functionality that your application uses are as follows:

If your application uses: Files needed:
ActiveX controls:
  • Toolbar
  • Status bar
  • Tree view
  • Spin button
  • comctl32.dll (Microsoft module)
Btrieve
  • xfh2btr.gnt
  • _btrv.gnt
Command-line Sort
  • mfsort.exe

CCI:

  • APPC protocol
  • DDE protocol
  • IPX protocol
  • NetBios protocol
  • TCP/IP protocol
  • TCP2 registration

  • cciap32.dll
  • ccide32.dll
  • cciix32.dll
  • ccinb32.dll
  • cciinst.exe and ccitc32.dll
  • ccitcp2.exe
Client/server binding
  • mfcsmgr.int
  • mfserver.int
  • mfclient.int
FaultFinder facility
  • cbldbg.dll
  • cblffndm.exe (multi-threaded)
  • cblffnds.exe (single-threaded)
File handling
  • xfh2btr.gnt (access to btrieve files)
Fileshare
  • fhrdrpwd.lbr
  • fs.dll (server)
  • fs.exe (server trigger)
  • fsservice.exe (to run as an NT service)
  • fsclose.exe (server closedown support)
  • fsmgr.dll (manager API support)
Host Compatibility Option
  • mfhcolib.lbr (when using the DB2 ECM compiler)
  • mfsqlsmf.dll
Java interfaces support
  • mfcc.exe
  • mfccmui.jar
  • xerces.jar

Micro Focus run trigger program:

  • multithreaded trigger
  • multithreaded trigger (Windows)
  • single-threaded trigger
  • single-threaded trigger (Windows)

  • run.cfg
  • run.exe
  • runm.exe
  • runmw.exe
  • runs.exe
  • runsw.exe
  • runw.exe
  • shell.lbr
  • utils.lbr
  • tools.lbr
Microsoft Transaction Server
  • objectcontext.dll
ODBC
  • drivers obtained separately, and
  • odbcrw32.dll
Rebuild facility (command-line file recovery tool)
  • callrb.lbr
  • rebuild.exe
  • the language files mflangxx.lbr. These files need to be available, and the COBDIR environment variable needs to point to the directory containing them
SQL, ESQL and ODBC
  • csqlsupp.dll (Cobsql)
  • odbcrw32.dll or odbcrw64.dll (OpenESQL)
  • oesqlebc.dll (OpenESQL with EBCDIC data)
  • ODBC drivers obtained separately
  • mfsqlsmf.dll
Web Services support
  • gk-os.dll
  • gk-utility.dll
  • mclient.dll
  • mfclsoap.dll
  • mfidmap.dll
  • nxwscrun.dll
  • xerces-c_2_1_0.dll
Parent topic: Shipping Selected Files from Server Enterprise Edition


Writing Your Own Setup Program

Note: The following applies to native COBOL only.

You can write your own setup program for applications that run under a COBOL run-time system, such as Server Enterprise Edition. Setting up an application that runs under Enterprise Server requires that the application is deployed to Enterprise Server, but there are no other major considerations.

When you provide your own setup program for an application that uses a COBOL run-time system without Enterprise Server, first you need to decide how your end users will install your application. Will they install your application together with its own run-time system or will they install your application separately from the run-time system, so that the run-time system can be shared with other applications?

The main ways of packaging an application and Server Enterprise Editionwithout Enterprise Server are:

  • As a standalone application, statically linked to the run-time system. This requires your executable file, the Microsoft Visual C++ run-time system msvcrt.dll and the Server Enterprise Edition licensing files.

    You need to create an installation procedure that:

    1. Installs the Server Enterprise Edition licensing files in the same directory as your application.
    2. Sets up a license database if this is the first time an application using Server Enterprise Edition is being installed on this machine. Subsequent installations use the same license database, so that the database holds a pool of licenses for all the uses of Server Enterprise Edition on the machine.
    3. Installs and starts the license manager service.
  • As an application using a shared run-time system - This run-time system is used by multiple COBOL applications on an end user's machine. It is installed in its own directory, separate from any applications. There is only one run-time system installed on the machine.

    You use the supplied setup program to install a shared Server Enterprise Edition and to set up the relevant registry entries.

  • As an application using its own application-specific run-time system - This run-time system is installed with and is used by a sole COBOL application.

    We recommend installing the full Server Enterprise Edition without Enterprise Server. However for backward compatibility, you can still select the run-time files to install, some of which are mandatory, such as the licensing files.

    You create an installation procedure that installs your application and, in the same directory, installs Server Enterprise Edition (or the selected run-time files). Your installation procedure also needs to set up licensing.

Parent topic: Deploying Native COBOL Applications


To set up an application with a shared Server Enterprise Edition

Note: The following applies to native COBOL only.
  1. Install Server Enterprise Edition.
  2. Install your application executable files in a separate directory from Server Enterprise Edition.
  3. If your application is linked with dynamic binding to the run-time system, create a shortcut pointing to the application. We recommend a shortcut in preference to adding the Server Enterprise Edition directory to the user's path, so that you avoid interactions with other COBOL applications.

    If your application is not linked with dynamic binding, set the PATH on the end-users' machines to point to Server Enterprise Edition, using the following command:

    path = app-server-dir;%PATH%

    where r:\app-server-dir is the directory where Server Enterprise Edition is installed. If you specify a directory containing spaces, you must use quotes ("") to delimit the data values. For example:

    path = "r:\application directory";%PATH%
Parent topic: Deploying Native COBOL Applications


To set up an application with its own Server Enterprise Edition

Note: The following applies to native COBOL only.
  1. Install Server Enterprise Edition.
  2. Install your application executable files in the same directory as Server Enterprise Edition.
  3. Create a shortcut pointing to the application. We recommend a shortcut in preference to adding the application directory to the user's path, so that you avoid interactions with other COBOL applications.
Parent topic: Deploying Native COBOL Applications


Server Enterprise Edition

  • To install Server Enterprise Edition (or selected files)
  • Server Enterprise Edition Installation Options
    Describes the different ways in which you can install Server Enterprise Edition.
  • Server Enterprise Edition Deployment Toolkit
    Describes the component parts of the Server Enterprise Edition Deployment Toolkit.
Parent topic: Deploying COBOL Applications


To install Server Enterprise Edition (or selected files)

Note: The following applies to native COBOL only.

To install the full Server Enterprise Edition (recommended):

  1. Install Server Enterprise Edition either in same directory as your application or a separate directory, which is recommended if several applications will be sharing it. To install this, run the install file SRP32xxxxxxxx.exe.

    You can also install Server Enterprise Edition silently.

To install selected files (not recommended, but available for backward compatibility):

  1. Determine the files to ship.
  2. Extract the files in the Server Enterprise Edition install file , which is on your CD. To do this, run the executable file SRP32xxxxxxxx.exe.
  3. Copy the files that your application requires into same directory as your application, or if several applications will be sharing the files, copy them into a separate directory.
Parent topic: Server Enterprise Edition


Server Enterprise Edition Installation Options

To install the Server Enterprise Edition update you run SRP32xxxxxxxx.msp.

SRP32xxxxxxxx.msp can take a number of parameters, enabling you to specify a number of different types of installation:

  • Standard Installation
    • Format:
    • start /wait SRP32xxxxxxxx.msp
    • Summary:
    • An update of the existing installation of Server Enterprise Edition.
  • Non-interactive Installation
    • Format:
    • start /wait SRP32xxxxxxxx.msp /qb
    • Summary:
    • An update of the existing installation of Server Enterprise Edition. Displays a progress bar only.
  • Silent Installation
    • Format:
    • start /wait SRP32xxxxxxxx.msp /q
    • Summary:
    • An update of the existing installation of Server Enterprise Edition. Does not display any UI.
Note:
  • Log files that are created during installation are saved in the folder specified by the TEMP environment variable.
Parent topic: Server Enterprise Edition


Server Enterprise Edition Deployment Toolkit

  • Introduction to the Server Enterprise Edition Deployment Toolkit
  • Merge Modules
    Provides background information on merge modules and describes the Deployment Toolkit's support for them.
  • The Deployment Toolkit Web Installer
    Lists and describes the files that comprise the Deployment Toolkit web installer.
Parent topic: Server Enterprise Edition


Introduction to the Server Enterprise Edition Deployment Toolkit

The Server Enterprise Edition Deployment Toolkit gives you more flexibility when deciding how to deploy your COBOL-based applications that depend on Server Enterprise Edition.

When you install Server Enterprise Edition, the files making up the Deployment Toolkit are saved in the deployment_toolkit folder.

Parent topic: Server Enterprise Edition Deployment Toolkit


Merge Modules

Merge modules provide you with a standard method by which you can deliver shared Windows Installer components and setup logic to your applications. See MSDN for information on merge modules.

The Deployment Toolkit includes a merge module (.msm file) which you can merge into an application’s .msi file to make available all of the Server Enterprise Edition components. It also includes a merge module for the Microsoft Visual C++ Runtime, which is a prerequisite of Server Enterprise Edition.

Parent topic: Server Enterprise Edition Deployment Toolkit


The Deployment Toolkit Web Installer

The Deployment Toolkit includes a web installer client to enable you to deploy using a client/server installation. The deployment_toolkit folder contains the following files for the web installer client:

deployment_toolkit_client.exe | Client application that loads deployment_toolkit_client.xml, that is deployment_toolkit_client.exe /configfile deployment_toolkit_client.xml.
deployment_toolkit_client.xml | Specifies the location of deployment_toolkit_server.xml on an internal or external web server.
deployment_toolkit_server.xml | Specifies each component to be installed as part of the product. The example XML lists Microsoft .NET Framework 4.0, Microsoft Visual Studio Shell edition as prerequisites and two dummy entries for Productx86 and Productx64. See dotNetInstaller: setup bootstrapper for Windows for information on the XML format.
Parent topic: Server Enterprise Edition Deployment Toolkit


Deploying COBOL Applications to the .NET Environment

  • Overview of Deploying COBOL Applications to the .NET Environment
  • Deploying to the .NET Environment with or without a Setup Project
  • Deploying Web and ASP.NET Applications
Parent topic: Deploying COBOL Applications


Overview of Deploying COBOL Applications to the .NET Environment

Managed COBOL applications require Server Enterprise Edition to enable them to run. Server Enterprise Edition provides support for managed COBOL and also for native COBOL. The native COBOL support enables your application to interoperate with native COBOL.

Before you deploy your application, you must first install Server Enterprise Edition.

When you install Server Enterprise Edition, both the native and the managed support is installed. The installation process adds the managed code support files to the Global Assembly Cache (GAC), as well as installing the files into the Server Enterprise Edition directory.

You can deploy COBOL applications using a setup project, or you can copy the files manually. You can also deploy ASP.NET applications using the Publish Web Site tool in Visual Studio.

Parent topic: Deploying COBOL Applications to the .NET Environment


Deploying to the .NET Environment with or without a Setup Project

Note: The following applies to COBOL for .NET only.

There are broadly two ways of deploying COBOL Windows-based applications to the .NET environment. You can either use a traditional Setup using Windows Installer technology, or you can copy the files manually. In both cases you need the prerequisite software such as Server Enterprise Edition and the .NET Framework installed on the target machine. See Overview for more information.

With Windows Installer deployment, you package the application in a setup.exe file and distribute that file to users, who run it to install the application.

To create a setup project, you create a new project of the type Setup. This creates a setup.exe program and a Microsoft Installer file (.msi) that encapsulates the entire setup. See the Visual Studio Help.

Alternatively, you can deploy your COBOL application without a setup project. To do this, use the Xcopy command (which copies a directory structure) to copy your application files from the project output directory to the directory containing your installation.

Parent topic: Deploying COBOL Applications to the .NET Environment


Deploying Web and ASP.NET Applications

Note: The following applies to COBOL for .NET only.

Visual Studio provides tools for deploying applications to a Web server. These tools provide an advantage over simply copying files, in that they handle any issues with registration and configuration automatically. However, you can copy the files and register them manually.

Micro Focus COBOL applications deployed to environment such as ASP.NET/Network drives are currently required to have full trust. Applications that are executed without full trust will cause a SecurityException and terminate. Full trust can be configured by using web.config (for ASP.NET) or by using your machines .NET Framework Configuration utility.

Because of the inherent risks that come with running in Full trust mode Microsoft recommends that the ASP.NET applications are isolated. This means that every Web site using COBOL should uses its own application pool and its own application pool identity to cut down the security exposure of executing the application with full trust.

For more information, see the MSDN:

  • How To: Use Code Access Security in ASP.NET 2.0
  • Configuring Security Policy Using the Code Access Security Policy Tool (Caspol.exe)
  • ASP.NET 2.0 Hosting Deployment Guide
Parent topic: Deploying COBOL Applications to the .NET Environment
Related information
To deploy a CICS service interface to the .NET environment
To deploy a COBOL Web site to the .NET environment


Programming

  • COBOL Programming
  • Compatibility
  • Data Access
  • Mainframe Programming
  • Managed COBOL Programming
  • Problem Determination and Diagnostic Tools
  • Hints and Tips
Parent topic: Micro Focus Studio Enterprise Edition 6.0


COBOL Programming

  • Internationalization Support
  • Mixed Language Programming with Native COBOL
    This section covers parameters, return codes and call conventions for mixed language development with native COBOL.
  • Web Services and COBOL
  • XML Input/Output
  • Creating 64-bit Native COBOL Programs
    You can create a 64-bit native COBOL program from scratch, or convert an existing 32-bit native program.
  • Calling COBOL Programs
Parent topic: Programming


Internationalization Support

  • National Locale Support
  • Unicode Support
  • OEM and ANSI Character Sets
Parent topic: COBOL Programming


National Locale Support

Restriction: National Locale Support is not available for .NET managed code.

The National Locale Support (NLS) facility provides an automatic means of adapting your program to the character code set, collating sequence, and editing symbols associated with a particular country, without the need for your application to know what these are in advance. This facility is also useful in English-speaking countries for handling codepages, collating upper- and lower-case letters correctly and selecting the appropriate currency symbol.

If full-screen ACCEPTs are to be used, you must set the range of data keys to be accepted in the adisctrl database. Your COBOL development system attempts to provide the appropriate national language tables for the language, country and character set selected by the user.

The NLS facility provides you with the means to access the following features which are associated with particular countries and codepages:

  • Class condition tests (ALPHABETIC, ALPHABETIC-UPPER, ALPHABETIC-LOWER, NUMERIC and user-defined CLASS conditions), appropriate to codepages
  • Collating sequences, appropriate to codepages (for example, the correct handling of accented characters)
  • Linguistic collating sequences applied to sort or merge files

NLS can also be used to create message files for your applications. These message files can contain error messages, but can also contain any other messages that need to be displayed by your application.

If you want to sort index files according to the local collating sequence rather than the ASCII collating sequence, you must specify the IXNLSKEY directive.

  • Compiling Programs with NLS
  • Setting Up the National Locale Environment
  • Using the LANG Environment Variable
  • Running Your NLS Program
  • NLS Initialization
  • NLS Operations
  • Message Files
Parent topic: Internationalization Support
Related information
Unicode Support
OEM and ANSI Character Sets
Message Files


Compiling Programs with NLS

Restriction: National Locale Support is not available for .NET managed code.

To use the NLS facility in your program, you must compile it with the NLS Compiler directive set. By default, the NLS Compiler directive is not set.

If you do set the NLS directive then, before checking the syntax of a program, you must ensure that it does not contain any of the following syntax:

  • In the Object-Computer paragraph, the phrase:

    PROGRAM COLLATING SEQUENCE IS alphabet-name

  • In the Special-Names paragraph, the phrases:
    • alphabet-name IS
    • STANDARD-1
    • NATIVE
    • literal-1 THRU literal-2, and so on
    • CURRENCY SIGN IS literal
    • DECIMAL-POINT IS COMMA
  • In the Procedure Division, the phrase:

    COLLATING SEQUENCE IS alphabet-name in MERGE or SORT statements

If your program contains any of the above syntax, and you want to use the NLS facility, you must either remove the syntax from your program, or mark it as a comment line. If you set the NLS directive and attempt to compile a program which contains any of the above syntax, compilation fails with the error:

136 Illegal use of phrase for National Language operation

You can compile any program in a COBOL application with the NLS directive set, providing it does not contain any of the above syntax. Thus some programs within an application might use NLS facilities, while others might not.

For more information, read Mixing programs with and without NLS.

Parent topic: National Locale Support
Related information
Setting Up the National Locale Environment
Using the LANG Environment Variable
Running Your NLS Program
NLS Initialization
NLS Operations
Message Files


Setting Up the National Locale Environment

Restriction: National Locale Support is not available for .NET managed code.

Before you run a program with the facility, you must define your locale. A locale is the combination of language, territory and codepage. The locale used by the run-time system is initially set to the value of the regional settings for the operating system.

Parent topic: National Locale Support
Related information
Compiling Programs with NLS
Using the LANG Environment Variable
Running Your NLS Program
NLS Initialization
NLS Operations
Message Files


Using the LANG Environment Variable

Restriction: National Locale Support is not available for .NET managed code.

You define a locale using the LANG environment variable. LANG is set using the operating system command SET:

set LANG=language

Parameters

where the parameters are:

language The language environment in which you wish to run your program. This determines which message catalog is open so that if an error occurs, the error message is output in the selected language. language can take any of the following values:
  • 1 = American English
  • 2 = Canadian French
  • 3 = Danish
  • 4 = Dutch
  • 5 = English
  • 6 = Finnish
  • 7 = French
  • 8 = German
  • 9 = Italian
  • 10 = Norwegian
  • 11 = Portuguese
  • 12 = Spanish
  • 13 = Swedish
_ The delimiter for language and territory, if territory is specified.

The following example illustrates how to specify a language of French and use the operating system values for the territory and codepage:

set LANG=7
Parent topic: National Locale Support
Related information
Compiling Programs with NLS
Setting Up the National Locale Environment
Running Your NLS Program
NLS Initialization
NLS Operations
Message Files


Running Your NLS Program

Restriction: National Locale Support is not available for .NET managed code.

You run programs containing in the same way as you run programs without it. When the program runs:

  • The run-time system initializes the NLS. The initializes the NLS facility when it encounters the first program within the application which was compiled with the NLS directive set. The operating system's regional settings are used to determine which language environment to set up for this program. However, you can use the LANG environment variable to override the current settings.
  • The NLS facility performs various operations in accordance with the rules of the language specified in the LANG environment variable.
Parent topic: National Locale Support
Related information
Compiling Programs with NLS
Setting Up the National Locale Environment
Using the LANG Environment Variable
NLS Initialization
NLS Operations
Message Files


NLS Initialization

Restriction: National Locale Support is not available for .NET managed code.

The run-time system initializes the NLS facility only once during an application's run: when it encounters the first program within the application which was compiled with the NLS directive set. It uses the operating system's regional settings to determine which language environment to set up for this program; if the LANG environment variable is set, that is used instead.

The run-time system uses the same language environment for any subsequent programs within the application which are compiled to use NLS.

If an error occurs during this initialization process, for example the language specified in the LANG environment variable is not supported, the run-time system reports the error:

40  National Language initialization not set up correctly

and terminates its run.

You can also receive this error if the LANG environment variable was set up by a third party product in a format different from that used by this COBOL system. If this occurs, use the COBLANG environment variable instead of the LANG environment variable.

If the run-time system cannot find the NLS run-time support modules, it issues the message:

46  NLS support module not found

and terminates its run.

Parent topic: National Locale Support
Related information
Compiling Programs with NLS
Setting Up the National Locale Environment
Using the LANG Environment Variable
Running Your NLS Program
NLS Operations
Message Files


NLS Operations

Restriction: National Locale Support is not available for .NET managed code.

When you run a program which has been compiled with the NLS directive set, certain operations are carried out in accordance with the rules of the language specified in the LANG environment variable.

Other language-dependent features, such as the symbols used to denote the decimal points and the currency character, also appear in the format of the specified language. However, in languages that define the currency sign as trailing, this has no effect and the usual COBOL rules are observed.

Certain NLS definitions have characters other than the ASCII characters 0-9 defined as numerics. Such characters cannot be ACCEPTed into numeric picture strings, nor can they be used in numeric operations. Note that in all NLS operations in the COBOL environment, a numeric item must be formed only from the ASCII digits 0-9, with or without the ASCII operational signs "+" or "-". There is no means of automatically converting the NLS representation to the ASCII equivalent.

It is possible to enter European modifying characters into numeric ACCEPT fields. These are accepted as zero.

Note that the values assigned to figurative constants, for example LOW-VALUES, are not changed by using NLS features.

You can also use the Adis Flip Case Control key when using NLS characters. However, if you attempt to convert a European character to upper case using this key, the character will be replaced by spaces if it has no upper case equivalent.

  • String Comparisons
  • Class Condition Tests
  • SORT and MERGE Key Comparisons
  • Case Conversion
  • Collating Sequence Operations
  • Editing and De-editing Moves
  • Intrinsic Functions Numval and Numval-c
  • Using NLS Library Routines in Your Programs
  • Mixing Programs With and Without NLS
Parent topic: National Locale Support
Related information
Compiling Programs with NLS
Setting Up the National Locale Environment
Using the LANG Environment Variable
Running Your NLS Program
NLS Initialization
Message Files


String Comparisons

Restriction: National Locale Support is not available for .NET managed code.

For programs which have been compiled with the NLS directive set, the run-time system invokes the CBL_NLS_COMPARE routine when it needs to carry out string comparisons. This routine is also called for alphanumeric comparisons if the program uses the intrinsic functions Max, Min, Ord-max or Ord-min on alphanumeric operands.

During a MOVE operation of one alphanumeric item to another which is longer, padding with spaces occurs. Similar padding is also implied before the comparison of two such items. In both cases, an ASCII space is assumed.

Parent topic: NLS Operations
Related information
Class Condition Tests
SORT and MERGE Key Comparisons
Case Conversion
Collating Sequence Operations
Editing and De-editing Moves
Intrinsic Functions Numval and Numval-c
Using NLS Library Routines in Your Programs
Mixing Programs With and Without NLS


Class Condition Tests

Restriction: National Locale Support is not available for .NET managed code.

For programs which have been compiled with the NLS directive set, the run-time system invokes locale-specific tests when it needs to carry out class condition tests. These tests determine if a string of information is in ALPHABETIC, ALPHABETIC-UPPER, ALPHABETIC-LOWER or NUMERIC format. The numeric test always tests that all characters are in the range of ASCII 0-9.

Parent topic: NLS Operations
Related information
String Comparisons
SORT and MERGE Key Comparisons
Case Conversion
Collating Sequence Operations
Editing and De-editing Moves
Intrinsic Functions Numval and Numval-c
Using NLS Library Routines in Your Programs
Mixing Programs With and Without NLS


SORT and MERGE Key Comparisons

Restriction: National Locale Support is not available for .NET managed code.

If a program compiled with the NLS directive set performs a SORT or MERGE operation, it automatically uses NLS key comparisons. The run-time system invokes the CBL_NLS_COMPARE routine for all key comparisons used in SORT or MERGE operations.

Parent topic: NLS Operations
Related information
String Comparisons
Class Condition Tests
Case Conversion
Collating Sequence Operations
Editing and De-editing Moves
Intrinsic Functions Numval and Numval-c
Using NLS Library Routines in Your Programs
Mixing Programs With and Without NLS


Case Conversion

Restriction: National Locale Support is not available for .NET managed code.

If a program compiled with the NLS directive set performs a case conversion, either by using the intrinsic functions Upper-case and Lower-case or by calling the library routines CBL_TOUPPER and CBL_TOLOWER, the run-time system invokes a routine to fold national characters correctly.

Parent topic: NLS Operations
Related information
String Comparisons
Class Condition Tests
SORT and MERGE Key Comparisons
Collating Sequence Operations
Editing and De-editing Moves
Intrinsic Functions Numval and Numval-c
Using NLS Library Routines in Your Programs
Mixing Programs With and Without NLS


Collating Sequence Operations

Restriction: National Locale Support is not available for .NET managed code.

When a program compiled with the NLS directive set is initialized, a collating sequence appropriate to the locale is set up. If the program performs a collating sequence operation by using the intrinsic functions Char and Ord, then this special collating sequence is used.

Parent topic: NLS Operations
Related information
String Comparisons
Class Condition Tests
SORT and MERGE Key Comparisons
Case Conversion
Editing and De-editing Moves
Intrinsic Functions Numval and Numval-c
Using NLS Library Routines in Your Programs
Mixing Programs With and Without NLS


Editing and De-editing Moves

Restriction: National Locale Support is not available for .NET managed code.

If a program compiled with the NLS directive set performs an editing or de-editing move, then the decimal point and thousands separator appropriate to the locale are used. Also, the currency symbol used is the first character of the currency symbol of the locale territory.

Parent topic: NLS Operations
Related information
String Comparisons
Class Condition Tests
SORT and MERGE Key Comparisons
Case Conversion
Collating Sequence Operations
Intrinsic Functions Numval and Numval-c
Using NLS Library Routines in Your Programs
Mixing Programs With and Without NLS


Intrinsic Functions Numval and Numval-c

Restriction: National Locale Support is not available for .NET managed code.

If a program compiled with the NLS directive set attempts to convert a number or a monetary value in a display item to a numeric value by using the intrinsic functions Numval or Numval-c, then the run-time system uses the decimal point and thousands separator appropriate to the locale. Also, if no second argument is supplied for Numval-c, then the currency symbol used is the currency symbol of the locale territory.

Parent topic: NLS Operations
Related information
String Comparisons
Class Condition Tests
SORT and MERGE Key Comparisons
Case Conversion
Collating Sequence Operations
Editing and De-editing Moves
Using NLS Library Routines in Your Programs
Mixing Programs With and Without NLS


Using NLS Library Routines in Your Programs

Restriction: National Locale Support is not available for .NET managed code.

There are various library routines you can use in a program that uses NLS.

  • CBL_NLS_INFO
    Gets/sets national language information.
  • CBL_NLS_OPEN_MSG_FILE
    Open a National Locale Support (NLS) message file.
  • CBL_NLS_READ_MSG
    Reads a message from a National Locale Support (NLS) message file.
  • CBL_NLS_CLOSE_MSG_FILE
    Closes a National Locale Support (NLS) message file.
  • CBL_NLS_COMPARE
    Compares two strings.
Parent topic: NLS Operations
Related information
String Comparisons
Class Condition Tests
SORT and MERGE Key Comparisons
Case Conversion
Collating Sequence Operations
Editing and De-editing Moves
Intrinsic Functions Numval and Numval-c
Mixing Programs With and Without NLS


Mixing Programs With and Without NLS

Restriction: National Locale Support is not available for .NET managed code.

Programs in your application can be compiled with or without the NLS directive set. A program which is compiled without the NLS directive set can CALL programs which were compiled without this directive set and programs which were compiled with it set. The reverse is equally true; that is, a program compiled with the NLS directive set can CALL both programs compiled with this directive, and those compiled without it.

A program compiled with the NLS directive set has no particular language or locale associated with it. The locale it uses is the application locale, which is initialized along with the NLS facility when the first program that uses NLS in the application is called.

The library routines for NLS can be called from any program which has been compiled with the NLS directive set.

Programs in the application which were compiled without the NLS directive set can also call these routines, but only after the National Locale Support module has been loaded and initialized by calling a program which has been compiled with the NLS directive set.

You can pass parameters from a program with the NLS facility to a program without it. However, you must note that parameters that are dependent on the language environment in which they are created retain their format regardless of the language environment in which they are used. If you attempt to use a parameter that was created in a program with the NLS facility in a program without the NLS facility, the result might not be as you would expect. We recommend that you do not attempt to pass such parameters to programs other than those which have the same language environment.

Parent topic: NLS Operations
Related information
String Comparisons
Class Condition Tests
SORT and MERGE Key Comparisons
Case Conversion
Collating Sequence Operations
Editing and De-editing Moves
Intrinsic Functions Numval and Numval-c
Using NLS Library Routines in Your Programs


Message Files

Restriction: National Locale Support is not available for .NET managed code.

Message files use so that the COBOL always displays them using the appropriate codeset for the environment an application is running in. You write each message file as an ASCII file with the file extension .err, and then compile it into a language file (which has the file extension .lng). To make messages available in more than one language, you write one message file per language, and compile them into separate .lng files.

You can open, read and close message files with the NLS library routines.

  • Format of a Message File
  • Example Error Message File
Parent topic: National Locale Support
Related information
Compiling Programs with NLS
Setting Up the National Locale Environment
Using the LANG Environment Variable
Running Your NLS Program
NLS Initialization
NLS Operations


Format of a Message File

Restriction: National Locale Support is not available for .NET managed code.

When you write the message file, start it with the statements:

$quote x
$set 1

where x is the character you wish to use as a quote character.

Then, write each message in the format:

$ nnnnn  "your message here"

where the double-quote character (") is assumed to be the quote character set in the $quote statement above. You can change quote statements at any point in the message file; each change applies to all the messages which follow it up until the next $quote statement.

Parent topic: Message Files
Related information
Example Error Message File


Example Error Message File

Restriction: National Locale Support is not available for .NET managed code.

This example shows an error message file. You can include comments by starting a line with the dollar sign ($) followed by a space.

$quote "
$
$set 1
1    "Invalid key type"
2    "Failed to open file for dictionary"
3    "Using a key of different size"
4    "Record exceeds maximum allowed length"
5    "Error reading control record"
6    "Indexed file has wrong key structure"
7    "Key not found in file"
8    "Attempt to write a record which has been deleted"
 ...
$ *****************************************************************
$ Copyright (c) 1981,1995 Micro Focus Ltd
$
$ Last modified on 95/08/01
$
$ ****************************************************************
Parent topic: Message Files
Related information
Format of a Message File


Unicode Support

Unicode is the general name given to the collection of character encoding schemes that can be used to represent most national languages. The main encodings defined under Unicode are UTF-8, UTF-16 and UTF-32 (where UTF stands for Universal Transformation Format). The COBOL development system uses UTF-16 as its representation for national characters. This means that each national character takes up 2 bytes of memory, and there are 65536 possible character combinations available.

COBOL applications are increasingly moving towards the use of Unicode to manage application data from multiple national languages in a single application. The COBOL language support for Unicode is in compliance with the ISO2002 COBOL standard. National data can be stored in standard COBOL files or in an SQL database. In addition, the Unicode support can be used to pass national character strings directly between COBOL and Java. In DBCS environments, it can also be used side-by-side with the existing DBCS support, making it possible to incrementally transition existing DBCS applications over to Unicode as needed.

  • UTF-16 Byte Ordering
  • National Literals
  • National Hexadecimal Literals
  • National Data Items
Parent topic: Internationalization Support
Related information
National Locale Support
OEM and ANSI Character Sets
National Literals
UTF-16 Byte Ordering
National Data Items
National Hexadecimal Literals


UTF-16 Byte Ordering

A UTF-16 character can be stored in one of two byte orders. The computer’s default byte order is normally used. For example, on Intel-based machines, the least significant byte of the character pair is stored at the byte with the lowest memory address (lo-hi byte ordering). On most other machines the most significant byte is stored first (hi-lo byte ordering). When you have a COBOL program containing Unicode characters, and that program must be accessed by machines that use either byte-order, you must change the byte order on a lo-hi machine to force the data to be stored in hi-lo order. You achieve this using the UNICODE directive. This directive enables you to specify NATIVE (whatever the machine defaults to) or PORTABLE (always hi-lo) byte ordering. Use the following syntax:

unicode({native | portable})

For example, the character “A” is represented by (0x00, 0x41) in UTF-16. On an Intel machine this is stored as:

0x41 0x00

However, if you specify the UNICODE(PORTABLE) directive, it is stored as:

0x00 0x41
Parent topic: Unicode Support
Related information
Overview - Unicode Support
National Literals
National Data Items
National Hexadecimal Literals


National Literals

Specifiy a national literal using the following notation:

N"string"

If the NSYMBOL(DBCS) directive is enabled, then the literal is a DBCS literal. If the NSYMBOL(NATIONAL) directive is enabled, then the literal is a national literal. In this case, the string is converted to Unicode (UTF-16) at runtime according to the code page of the current locale.

See the section National Literals in the chapter Concepts of the COBOL Language in your Language Reference.

Parent topic: Unicode Support


National Hexadecimal Literals

National hexadecimal literals specify the Unicode (UTF-16) characters directly in hexadecimal, and enable the portability of code. Use the following format:

NX"string"

Each character in the string consists of two bytes and the most significant byte of the pair is specified first. For example, in UTF-16 the character "A" is represented by the byte pair (0x00, 0x41) and the character "B" is represented by (0x00, 0x42). The string "AB" could therefore be specified by the national hexadecimal literal:

NX"00410042"

See the section National Literals in the chapter Concepts of the COBOL Language in your Language Reference.

Parent topic: Unicode Support


National Data Items

Define COBOL data items that hold a Unicode string as USAGE NATIONAL. These must have a picture clause that consists of one or more N symbols. If the Usage clause is omitted then the usage is implied from the setting of the NSYMBOL directive. For example:

01 mystring	pic n(20) usage national
Parent topic: Unicode Support
Related information
Overview - Unicode Support
Overview - National Literals
UTF-16 Byte Ordering
National Hexadecimal Literals


OEM and ANSI Character Sets

  • Overview - OEM and ANSI Character Sets
  • Handling OEM and ANSI Data
  • Code Pages
  • How to
Parent topic: Internationalization Support
Related information
National Locale Support
Unicode Support


Overview - OEM and ANSI Character Sets

The DOS command prompt, DOS applications, and many Micro Focus products (including Net Express 1.0) use the OEM character set for editing and displaying text. Files created or displayed using these applications might show some characters differently from the way they appear in Net Express 2.0 and most other Windows applications, which use the ANSI character set. The characters affected are only those in the "extended set", including diacritical (accented) characters, line drawing characters and symbols.

For example, suppose you type an e with an acute accent (Y) in a COBOL source file in Net Express 2.0 or later. If you view the file in a DOS application using code page 850, this character displays as a Greek capital theta. This difference can also affect non-alphabetic characters such as the tilde (~) and British pound sign (£).

Net Express enables you to specify which character set is used by clicking a radio button on the Edit Options dialog box.

You should be aware of the following consequences of opening a source file that has not been saved in the currently selected character set (that is, an OEM file with Net Express set to ANSI, or an ANSI file with Net Express set to OEM):

  • Diacritical, line drawing and some symbol characters are not shown correctly
  • Find and Find in Files operations might not correctly match these characters
  • Data containing these characters does not appear correctly when you examine it using the Examine List, monitors, or data tooltips
  • Changes you make to the file are saved in the currently selected format, so the file will contain a mixture of character sets
  • In most cases the application runs normally, displaying the correct characters.

A COBOL source or data file has probably been saved in the OEM character set if it was created using:

  • Net Express 1.0 or another Micro Focus product
  • A DOS editor or tool
  • A UNIX editor or tool

A COBOL source or data file has probably been saved in ANSI format if it was created using:

  • Net Express 2.0 or later
  • A Windows editor or tool
Parent topic: OEM and ANSI Character Sets


Handling OEM and ANSI Data

In some situations, you might need to use existing data files that have been saved in OEM format with new GUI or Internet programs that read and write in ANSI format. There are several options you can choose between to handle the required conversion:

  • If you do not need to preserve your existing data in OEM format, you can convert it to ANSI using the supplied utility, Mfoemtoa.
  • If your application is a Dialog System application, you can use the OEM conversion dialog in your application
  • You can convert data to and from ANSI as needed using the call-by-name routines PC_WIN_CHAR_TO_OEM and PC_WIN_OEM_TO_CHAR
  • If your application is a Win32 API application, you can convert data to and from ANSI as needed using the Win32 API calls OemToCharBuff and CharToOemBuff.
Parent topic: OEM and ANSI Character Sets
Related information
Overview - OEM and ANSI Character Sets
Handling OEM and ANSI Data
Code Pages
To convert ANSI characters to OEM
To convert OEM characters to ANSI
To use the Mfoemtoa utility


Code Pages

The default OEM character set for DOS applications includes an extensive range of line drawing characters, but does not include a full set of diacritical (accented) characters as used in non-English languages. To cope with these characters, the OEM character set is split in two. The first half of the character set is constant, but the second half can be substituted with a number of alternative character sets called code pages. The exact character available at a particular character position depends on which code page is active at the time.

You can find out which code page is active by typing the DOS command chcp. You can change the active code page using the DOS commands mode or chcp.

For example:

mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)
mode con codepage select=850
chcp 850

The most commonly used code pages are:

  • 437 for English in the United States of America
  • 850 (commonly called Multilingual or Latin I) for most languages, including International English, that use the Latin alphabet
  • 852 (commonly called Latin II) for Slavic languages that use the Latin alphabet
Parent topic: OEM and ANSI Character Sets
Related information
Overview - OEM and ANSI Character Sets
Handling OEM and ANSI Data
Code Pages
To convert ANSI characters to OEM
To convert OEM characters to ANSI
To use the Mfoemtoa utility


How to

  • To convert ANSI characters to OEM
  • To convert OEM characters to ANSI
  • To convert OEM files to ANSI
Parent topic: OEM and ANSI Character Sets


To convert ANSI characters to OEM

  • Use the call-by-name routine PC_WIN_CHAR_TO_OEM in your program
  • Use the Win32 API call CharToOEM or CharToOEMBuff in your program (see the Microsoft Win32 SDK documentation for details of these calls).
Parent topic: How to
Related information
Overview - OEM and ANSI Character Sets


To convert OEM characters to ANSI

Use one of the following techniques, as appropriate:

  • Use the supplied Mfoemtoa utility to convert existing files
  • Use the OEM conversion dialog in a Dialog System application
  • Use the call-by-name routine PC_WIN_OEM_TO_CHAR in your program
  • Use the Win32 API call OEMToChar or OEMToCharBuff in your program (see the Win32 SDK documentation for details of these calls).
Parent topic: How to
Related information
Overview - OEM and ANSI Character Sets


To convert OEM files to ANSI

  1. Open aStudio Enterprise Edition prompt from the Start menu.
  2. Type the following and press Enter:
    mfoemtoa filename

    where filename is the name of the OEM source file or line sequential date file you want to convert.

The ANSI version of the file is created and saved with the same root name as the OEM file, but with the file extension .ans.

Note: Mfoemtoa works for line sequential files with records no longer than 255 characters. For larger data files, we recommend you use the PC_WIN_OEM_TO_CHAR function to convert the records.
Parent topic: How to


Mixed Language Programming with Native COBOL

This section covers parameters, return codes and call conventions for mixed language development with native COBOL.
Restriction: The following applies to native COBOL only.

Applications can contain programs written in both COBOL and other languages, such as C. COBOL programs call non-COBOL programs using the standard COBOL CALL ... USING statement.

Although you pass parameters to non-COBOL programs in broadly the same way as to COBOL programs, the interfaces to programs in different languages differ from each other and they need to correspond.

  • Ordering Parameters to Pass to Non-COBOL Programs
    The order in which the parameters are passed, since the calling program might not pass parameters in the order that the called program expects them.
  • Removing Parameters from the Stack
    Defining whether the called program removes the parameters from the stack before it returns to the calling program, or whether the calling program does it after receiving control back.
  • Storage Representation of Parameters
    The storage of parameters in mixed language applications, since different systems store data either with the most significant byte first or with it last.
  • Aligning Parameters on Word and Double Word Boundaries
    Aligning numeric parameters on word and double-word boundaries to match the alignment in the non-COBOL program.
  • Handling Return Codes in Mixed Language Applications
    COBOL can pass and receive return codes from other programs.
  • Call Conventions for Interfacing with Mixed Languages
    The conventions for passing parameters, and other details of the interface between the two programs.
  • Building a Mixed Language Application
    Compiling and linking a mixed language application, and preserving the COBOL run-time system when calling a non-COBOL program.
  • Interfacing with Assembler Subprograms
  • Interfacing with Windows API Routines
  • Interfacing with C Programs
  • Passing Data between C and COBOL
    Passing data using record layouts.
  • Error Messages when Calling Non-COBOL Programs
  • Signal Handling
    You can use signal handling in your application, especially if you are mixing COBOL and C in your application.
  • Examples of Mixed Language Programming
Parent topic: COBOL Programming
Parent topic: Interoperability
Related information
Ordering Parameters to Pass to Non-COBOL Programs
Storage Representation of Parameters
Call Conventions for Interfacing with Mixed Languages
Error Messages when Calling Non-COBOL Programs
Building a Mixed Language Application
Removing Parameters from the Stack
Aligning Parameters on Word and Double Word Boundaries
Handling Return Codes in Mixed Language Applications


Ordering Parameters to Pass to Non-COBOL Programs

The order in which the parameters are passed, since the calling program might not pass parameters in the order that the called program expects them.
Restriction: The following applies to native COBOL only.

You pass parameters to a non-COBOL program in much the same way as to a COBOL program, by specifying them in the USING phrase of the CALL statement. For example:

CALL call-convention "program-name" USING parameter-1, parameter-2

Just as when calling COBOL programs, the order of the parameters is important. However, some languages, such as Pascal, expect parameters in the opposite order from that expected by COBOL programs. You can use the call convention to define the order in which to pass the parameters.

COBOL programs pass parameters by pushing them onto the stack before calling the subprogram. The parameters can be pushed onto the stack either from right-to-left (reverse order) or from left-to-right (order specified). The first of these methods is the convention used by COBOL and by C. The second method is used by languages such as Pascal.

For example, on entry to a subprogram called with the statement:

CALL "sub-prog" USING  parameter-1
                       parameter-2
                        ...
                       parameter-n-1
                       parameter-n

the stack looks like one of the following illustrations. In both cases, parameters are pushed onto the stack from high memory to low memory. Stack Pointer is the register that points to the next vacant slot in the stack.

Figure 1. *
*
Parent topic: Mixed Language Programming with Native COBOL
Related information
Storage Representation of Parameters
Number of Parameters in a USING Phrase
Number of Files for Sorting or Merging
Call Conventions for Interfacing with Mixed Languages
Mixed Language Programming with Native COBOL
Removing Parameters from the Stack
Optimizing Parameter Handling
Passing Parameters to a Called Program
Building a Mixed Language Application
Aligning Parameters on Word and Double Word Boundaries
Handling Return Codes in Mixed Language Applications


Removing Parameters from the Stack

Defining whether the called program removes the parameters from the stack before it returns to the calling program, or whether the calling program does it after receiving control back.
Restriction: The following applies to native COBOL only.

Different languages remove parameters from the stack at different times. In some languages, the called program removes the parameters before terminating and returning to the calling program. While in other languages, the calling program removes the parameters immediately after it receives control back.

In COBOL or C, the calling program removes the parameters, while in Pascal the called program removes them.

Specify the appropriate calling convention to ensure that the parameters are removed once and once only.

Parent topic: Mixed Language Programming with Native COBOL
Related information
Optimizing Parameter Handling
Passing Parameters to a Called Program
Building a Mixed Language Application
Aligning Parameters on Word and Double Word Boundaries
Handling Return Codes in Mixed Language Applications
Ordering Parameters to Pass to Non-COBOL Programs
Storage Representation of Parameters
Number of Parameters in a USING Phrase
Number of Files for Sorting or Merging
Call Conventions for Interfacing with Mixed Languages
Mixed Language Programming with Native COBOL


Storage Representation of Parameters

The storage of parameters in mixed language applications, since different systems store data either with the most significant byte first or with it last.
Restriction: The following applies to native COBOL only.

The format in which parameters are stored can vary from one language to another. The following data types have implications for mixed-language programming:

USAGE | Storage Representation
COMP-X | Data is stored with the most significant byte first; that is, the most significant byte is at the lowest address. Although this is standard COBOL format, it is the reverse of the Intel standard of storing the most significant byte last.
COMP-5 | Defined as Intel reversed byte storage format, in which data is stored with the least significant byte first; that is, the least significant byte is at the lowest address. Using this data-type enables you to pass parameters directly from COBOL to non-COBOL programs without parameter conversion.
POINTER and PROCEDURE-POINTER | The entire format is a double-word reversed byte offset. Pointer variables are extremely useful for holding the address of a dynamically allocated memory area. COBOL programs can then access this memory using the SET ADDRESS statement.
Parent topic: Mixed Language Programming with Native COBOL
Related information
Ordering Parameters to Pass to Non-COBOL Programs
Number of Parameters in a USING Phrase
Number of Files for Sorting or Merging
Call Conventions for Interfacing with Mixed Languages
Mixed Language Programming with Native COBOL
Removing Parameters from the Stack
Optimizing Parameter Handling
Passing Parameters to a Called Program
Building a Mixed Language Application
Aligning Parameters on Word and Double Word Boundaries
Handling Return Codes in Mixed Language Applications


Aligning Parameters on Word and Double Word Boundaries

Aligning numeric parameters on word and double-word boundaries to match the alignment in the non-COBOL program.
Restriction: The following applies to native COBOL only.

COBOL places no restrictions on the alignment of the addresses of data items, whereas in languages such as C and assembler, it is normal for numeric items to be aligned on word or double-word boundaries.

Make sure that you correctly align any numeric parameters that are not level-01 data items in the COBOL program, or that are in a parameter block passed as a single item.

To align numeric items, you can:

  • Modify group items to include additional filler items.
  • Use the ALIGN Compiler directive with a parameter that is a multiple of four. This aligns all level-01 and level-77 data items on double word boundaries. The Compiler uses ALIGN"8" by default.
  • Use the SYNCHRONIZED clause in conjunction with the IBM COMP Compiler directive.
Parent topic: Mixed Language Programming with Native COBOL
Related information
Building a Mixed Language Application
Removing Parameters from the Stack
Handling Return Codes in Mixed Language Applications
Mixed Language Programming with Native COBOL
Ordering Parameters to Pass to Non-COBOL Programs
Storage Representation of Parameters
Call Conventions for Interfacing with Mixed Languages


Handling Return Codes in Mixed Language Applications

COBOL can pass and receive return codes from other programs.
Restriction: The following applies to native COBOL only.

Most languages are capable of passing a return code back to the calling program. COBOL can pass and receive them as follows:

  • To receive a return code from a non-COBOL program, use the RETURNING phrase in the CALL statement in the calling COBOL program.
  • To pass a return code back from a COBOL program, use the RETURNING phrase of the EXIT PROGRAM, GOBACK, or STOP RUN statement.

The RETURNING phrase enables you to define the format of the return code yourself and so cope with whatever size of return code you require.

Note that the operating system limits the return value to two bytes if you use the IF ERRORLEVEL syntax to check the return value.

The registers used to pass the return code from COBOL and Microsoft C are:

32-bit Intel Return Code Size | Register
One byte | AL
Two bytes | AX
Four bytes | EAX
X64 Return Code Size | Register
One, two, and four bytes | as for X86
Eight bytes | RAX
IA64 Return Code Size | Register
Any size | R8
Parent topic: Mixed Language Programming with Native COBOL
Related information
Building a Mixed Language Application
Removing Parameters from the Stack
Aligning Parameters on Word and Double Word Boundaries
Mixed Language Programming with Native COBOL
Ordering Parameters to Pass to Non-COBOL Programs
Storage Representation of Parameters
Call Conventions for Interfacing with Mixed Languages


Call Conventions for Interfacing with Mixed Languages

The conventions for passing parameters, and other details of the interface between the two programs.

These call conventions are relevant to .NET managed code when using Platform Invoke only to call unmanaged code.

COBOL programs can call and be called by programs written in other languages. However, some languages handle calls differently from COBOL. For example, some language pass parameters in the opposite order from that expected by COBOL programs. To enable COBOL and non-COBOL programs to call each other, you can adjust the calling mechanisms that the COBOL program uses or that it expects to be used.

To specify the calling mechanisms you require, you first construct the call convention number that produces the required mechanisms. The call convention number is a 16-bit number defined as follows:

Bit 0
0 | Process parameters from right-to-left
1 | Process parameters from left-to-right
Bit 1
0 | Parameters removed from stack by calling program
1 | Parameters removed from stack by called program
Bit 2
0 | RETURN-CODE is updated on exit
1 | RETURN-CODE is not updated on exit
Any RETURNING phrase is not affected by this bit
Bit 3
0 | Normal linking behavior
1 | Call is resolved at link time
Bits 4 and 5
Reserved (always 0).
Bit 6
0 | The call does not conform to the Windows stdcall calling convention
1 | The call conforms to the Windows stdcall calling convention
This has no effect on dynamic calls, but alters the call name on static-linked calls.
Bit 7
Reserved (always 0).
Bit 8
0 | The parameter-count of individual entry-points is checked
1 | The parameter-count of individual entry-points is not checked
Bit 9
0 | The case of the program or call name is disregarded
1 | The case of the program or call name is significant
This call convention is an instruction to the generator on how to treat the text of a quoted program name or call name when litlinking. If this bit is 0 the case of the program or call name might still be significant depending on the CASE generator directive.
Bit 10
0 | Normal calling behavior
1 | The first parameter is always the RETURNING item for the CALL
Bits 11-15
Reserved (always 0).

When you have constructed the call convention number, you convert it to a decimal number, and then assign this decimal number to a name, by defining it the Special Names paragraph. You then use the call convention name in the CALL statement.

For example, if you define the following call conventions:

 SPECIAL-NAMES.
     CALL-CONVENTION 0 IS Microsoft-c
     CALL-CONVENTION 3 IS Pascal.

you can then use one convention when calling a C program as follows:

    CALL Microsoft-c "routine-name" USING parameter-1,parameter-2

and use the other convention when receiving a call from a Pascal program, such as:

 PROCEDURE DIVISION Pascal USING parameter-1,parameter-2

If you do not specify a call convention, the standard COBOL convention (call-convention 0) is assumed, unless the DEFAULTCALLS Compiler directive is used.

Parent topic: Mixed Language Programming with Native COBOL
Related information
Ordering Parameters to Pass to Non-COBOL Programs
Storage Representation of Parameters
Number of Parameters in a USING Phrase
Number of Files for Sorting or Merging
Mixed Language Programming with Native COBOL
Interfacing with Assembler Subprograms
Example of Calling an Assembler Subprogram
Example of Calling a Win32 API Routine
Interfacing with Windows API Routines
Interfacing with C Programs
Removing Parameters from the Stack
Optimizing Parameter Handling
Passing Parameters to a Called Program
Building a Mixed Language Application
Aligning Parameters on Word and Double Word Boundaries
Handling Return Codes in Mixed Language Applications


Building a Mixed Language Application

Compiling and linking a mixed language application, and preserving the COBOL run-time system when calling a non-COBOL program.
Restriction: The following applies to native COBOL only.

You can create applications that have both COBOL and non-COBOL programs calling each other. To do this:

  1. Make sure any non-COBOL program that runs preserves the COBOL run-time system, as follows:
    • The called program must preserve the local COBOL run environment (that is, the registers) according to C calling conventions
    • The global COBOL run environment (that is, data areas allocated by the COBOL system, open file, buffers, environment variables, and so on) must not be destroyed or altered, except under the direct control of the COBOL system.
  2. Compile the non-COBOL programs to standard Intel native object code.
  3. Link the compiled programs either to the dynamic loader run-time support module or to your statically or dynamically linked COBOL application.
Parent topic: Mixed Language Programming with Native COBOL
Related information
Removing Parameters from the Stack
Aligning Parameters on Word and Double Word Boundaries
Handling Return Codes in Mixed Language Applications
Mixed Language Programming with Native COBOL
Ordering Parameters to Pass to Non-COBOL Programs
Storage Representation of Parameters
Call Conventions for Interfacing with Mixed Languages


Interfacing with Assembler Subprograms

Restriction: The following applies to native COBOL only.

We recommend that you write your assembler subprograms to comply with the standard COBOL calling convention (bits 0 and 1 set to 0, the default). The assembler subprogram can consist of multiple code and data segments.

Assembler subprograms must be statically or dynamically linked. If they are statically linked they must use the faster form of static linking. To do this, call the assembler subprogram using the COBOL statements:

SPECIAL-NAMES.
     CALL-CONVENTION 8 IS litlinked.
     .
     .
     .
     CALL litlinked "EXAMPLE" USING parameter1, parameter2

The registers used, assuming the standard call convention, are:

Register | Usage
ESP | holds the return address, followed by parameters which have been pushed in right to left order
EBP, EBX, ESI, EDI | must be preserved by the called program
EAX | holds the return-code for four byte data items
EDX:EAX register pair | holds the return-code for an eight byte structure

For an example, see Example of Calling an Assembler Subprogram.

Parent topic: Mixed Language Programming with Native COBOL
Related information
Example of Calling an Assembler Subprogram
Call Conventions for Interfacing with Mixed Languages
Example of Calling a Win32 API Routine
Interfacing with Windows API Routines


Interfacing with Windows API Routines

Restriction: The following applies to native COBOL only.

The Win32 API routines can be treated as subprograms that can be called directly from COBOL. The API routines should always be called with the correct call convention.

For an example, see Example of Calling a Win32 API Routine.

Parent topic: Mixed Language Programming with Native COBOL
Related information
Interfacing with Assembler Subprograms
Example of Calling an Assembler Subprogram
Call Conventions for Interfacing with Mixed Languages
Example of Calling a Win32 API Routine


Interfacing with C Programs

Restriction: The following applies to native COBOL only.

This COBOL system provides a number of library functions that enable you to mix C and COBOL programs. These functions are intended primarily for use in C programs.

The functions are prototyped in C header files, which are located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\include by default.

The functions use portable data types, which have the naming convention cobtype_t. Definitions of these data types can be found in the cobtypes.h header file located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\include by default.

A C function can call a COBOL entry point in the same way as it would call another C function. For example, the following demonstrates C code that calls a COBOL entry point, cobep, using two arguments:

cobep(arg1, arg2);

A C function can call, and cancel, COBOL programs and entry points using the cobcall(), cobcancel() and cobfunc() routines, as described in the sections below.

Before calling a COBOL program, you must call cobinit(). In a threaded environment where you don't know if you're the first thread or not, each thread should call cobinit().

Before exiting a thread that has called a COBOL program, but which was not created via COBOL multi-threading syntax or library routines, you must call cobthreadtidy().

Before exiting an application that has called a COBOL program you must call either cobtidy() or cobexit().

If the COBOL program and the C function that calls it are not contained in a callable DLL/shared object, nor linked together in a system executable file, then:

  • If the program on disk has a different name to the entry point being called, the program needs to be preloaded using cobgetfuncaddr()

All the C routines for calling COBOL are described in reference topics.

Parent topic: Mixed Language Programming with Native COBOL
Related reference
cobget
cobput
Related information
C Functions for Calling COBOL
Call Conventions for Interfacing with Mixed Languages
Passing Data between C and COBOL
Signal Handling Overview


Passing Data between C and COBOL

Passing data using record layouts.
Restriction: The following applies to native COBOL only.

A COBOL record layout is similar to a C structure containing arrays of characters. When the Compiler assigns a COBOL record layout, it does not take into account the alignment of binary or pointer data items, or byte ordering of binary (COMP-X) data items, required by any specific hardware platform; because of this, COBOL applications are extremely portable. However, this portability can cause problems in mixed-language applications. C structure layout is not as rigidly defined as COBOL record layout and varies quite widely from operating system to operating system. For example, the structure is six bytes long in COBOL, no matter what platform it is compiled on:

01  mystruct is typedef.
        05  mystruct-key-1     pic x occurs 2.
        05  mystruct-bin-1     pic x(4) comp-5.

However, with the C compilers provided on most operating systems, a straightforward representation of this record layout in C would give different results. For example, the following would result in a structure eight bytes long on most 32-bit operating systems, and 16 bytes long on most 64-bit operating systems, due to alignment padding:

struct mystruct
 {
         char		mystruct_key_1[2];
         long		mystruct_bin_1;
     };

A better solution, because it is portable, is to represent the COBOL record mystruct using the C structure, as follows:

struct mystruct
 {
         char		mystruct_key_1[2];
         char		mystruct_bin_1[4];
     };

To enable conversion of COBOL data records into the C data types for a mixed-language application, a C include file is supplied. This file, cbltypes.h and located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\include , contains many of the basic types used in COBOL applications and in our CBL_ library routine interfaces. These types directly correspond to those types contained in the copybook cbltypes.cpy, found in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source by default.

Revisiting the example above, the following COBOL record layout:

01  mystruct is typedef.
     05  mystruct-key-1  cblt_x1 occurs 2. *> aka. "PIC X"
     05  mystruct-bin-1  cblt_x4_comp5.    *> aka.
#                                       "PIC X(4) COMP-5"

can be correctly represented in C, using cbltypes.h, as:

#include "cbltypes.h"

    struct mystruct
 {
        cbl_x1_t          mystruct_key_1[2];
        cbl_x4_comp5_t    mystruct_bin_1;
    };

The type name conventions used in cbltypes.h are intended to naturally reflect the PICTURE strings of the corresponding COBOL type definition. The basic types provided in this include file are as follows:

cbl_x1_t  cobol character position - basis for all types

cbl_pointer_t   Equivalent to: USAGE POINTER
cbl_ppointer_t  Equivalent to: USAGE PROCEDURE-POINTER

cbl_sx1_comp5_t Equivalent to: PIC s9(n) COMP-5
                                         where n=1 or 2
cbl_sx2_comp5_t Equivalent to: PIC s9(n) COMP-5
                                         where n=3 or 4
cbl_sx4_comp5_t Equivalent to: PIC s9(n) COMP-5
                                         where n=7 through 9
cbl_sx8_comp5_t Equivalent to: PIC s9(18) COMP-5

cbl_x1_comp5_t  Equivalent to: PIC X(1) COMP-5
cbl_x2_comp5_t  Equivalent to: PIC X(2) COMP-5
cbl_x4_comp5_t  Equivalent to: PIC X(4) COMP-5
cbl_x8_comp5_t  Equivalent to: PIC X(8) COMP-5

cbl_x1_compx_t  Equivalent to: PIC X(1) COMP-X
cbl_x2_compx_t  Equivalent to: PIC X(2) COMP-X
cbl_x4_compx_t  Equivalent to: PIC X(4) COMP-X
cbl_x8_compx_t  Equivalent to: PIC X(8) COMP-X

Even though you can portably declare COBOL data in the C language, you still need to operate on that data in a C context. To enable you to do this, C library routines are provided. These routines enable many COBOL-based data types to be converted into a format suitable for use in the context of your C application component.

Parent topic: Mixed Language Programming with Native COBOL
Related reference
cobget
cobput
Related information
Interfacing with C Programs
Signal Handling Overview


Error Messages when Calling Non-COBOL Programs

Restriction: The following applies to native COBOL only.

When calling non-COBOL programs, the following Run-time system error messages might be returned:

114  Attempt to access item beyond bounds of memory
115  Unexpected signal

Where C and COBOL modules are linked, these error messages are usually due to an error in the C code which causes a hardware interrupt for such conditions as segmentation violation. If you do receive these RTS errors, carefully check the C source routines using the system debugger. Pay particular attention to the format and byte order of parameters passed between the COBOL and C modules.

Parent topic: Mixed Language Programming with Native COBOL
Related information
Mixed Language Programming with Native COBOL


Signal Handling

You can use signal handling in your application, especially if you are mixing COBOL and C in your application.
Restriction: The following applies to native COBOL only.
  • Signal Handling Overview
  • Posting Signal Handlers
  • Writing Signal Handlers
  • More than One Handler for the Same Signal
  • Converting Signal Handlers Written for the signal() Function
  • Third Party Software that Uses Signals
Parent topic: Mixed Language Programming with Native COBOL


Signal Handling Overview

Restriction: The following applies to native COBOL only.

The run-time system sets up default signal handlers for all signals whose operating system default action is to cause termination. These default handlers make sure that the COBOL system is properly cleaned up before terminating. Hence, any open files are closed (to prevent file corruption), the PC is reset to a sane state, user posted exit and error procedures are executed, and so on.

You can complement or override the signal handling used by the run-time system by using the following routines:

  • cobpostsighandler()
  • cobremovesighandler()

These routines allow multiple handlers for each signal and enable you to prioritize use of these handlers. You can use them from inside a C program only, not least because you need the C library include file <signal.h> for the signal values, which vary between platforms.

Use these routines instead of the operating system signal calls, (signal() and so on) which provide only the ability to post a single signal handler for each call and so often prevent multiple applications being able to work together reliably.

For example, if you use one of the C library signal calls to post a signal handler before invoking a COBOL program, your signal handler might be overridden. Whereas, if you use one of the C library signal calls after invoking a COBOL program, the default run-time system handler, additional COBOL functionality and user-posted signal handlers are all overridden, causing unexpected results.

Parent topic: Signal Handling
Related reference
signal_regime
cobremovesighandler
cobpostsighandler
cobget
cobput
cobpostsighandler
cobremovesighandler
Related information
Converting Signal Handlers Written for the signal() Function
Posting Signal Handlers
Writing Signal Handlers
More than One Handler for the Same Signal
Third Party Software that Uses Signals
Example of Posting a Signal Handler
Passing Data between C and COBOL
Interfacing with C Programs


Posting Signal Handlers

Restriction: The following applies to native COBOL only.

You use the cobpostsighandler() routine to post signal handlers.

The run-time system also uses the cobpostsighandler() routine to post all of its signal handling. Default handlers are posted for all signals whose operating system default action causes termination. The default handlers either make sure that the COBOL system has been cleaned up before terminating, or cause the signal to be ignored. These default handlers assume that the signals were generated by the operating system due to a serious error or that a signal has been unexpectedly raised. Hence, they usually produce a run-time system message, such as 114 or 115.

If the same handler is posted twice at the same priority, and neither of them is removed using the cobremovesighandler() routine, the handler is executed twice (assuming the handler, and all handlers executed in between, do not return a value of zero).

If you try to post the same signal handler for the same signal at the same priority twice and the first has not been removed using cobremovesighandler(), then cobpostsighandler() returns the handle for the old handler and does not post a new one.

If two different handlers are posted with the same priority, the last one posted is executed first.

Once you have posted a handler, you do not need to repost it. The handler is called each time that signal is received (assuming that the first receipt of the signal does not cause termination). If you want to execute your handler only once, you must remove it, using the cobremovesighandler() routine, in your signal handler.

While a signal handler is processing a signal, the signal is blocked. This prevents recursion if the same signal is received in rapid succession.

A signal handler must return normally. That is, you must not use any other function that terminates a signal handler function, such as longjmp() or coblongjmp(), and you must use the C syntax to return a value, as follows:

return(num);

If you do use another function to return, the signal remains blocked, preventing any further signals from being processed.

When the run-time system receives a signal it calls the handler posted with the highest priority for that signal. Your handler should take any appropriate action (such as setting a flag to be acted on later) and then return. If the handler returns a non-zero value, the run-time system calls the handler with the next highest priority for that signal. If the signal handler returns zero, the run-time system does nto call any further signal handlers.

The run-time system posts its default signal handlers with priority 127. So, to override them, or to process your signal handler before them, post your handler with priority 128. Use a priority of 126 (or less) if you want to make sure that your handler is processed after the default run-time system handler (if the default run-time system handler does not exit).

The run-time system provides various functionality using signal handlers. These handlers are posted with a priority in the range of 129 to 139.

Parent topic: Signal Handling
Related reference
cobremovesighandler
cobpostsighandler
Related information
Converting Signal Handlers Written for the signal() Function
Signal Handling Overview
Writing Signal Handlers
More than One Handler for the Same Signal
Third Party Software that Uses Signals
Example of Posting a Signal Handler


Writing Signal Handlers

Restriction: The following applies to native COBOL only.

A signal handler should do very little. A signal can be generated at any time so the routine that was being executed could be in an "unsafe" state (eg. in the middle of modifying global variables) and so trying to execute it in your signal handler could cause problems. The routine being executed could be a C library routine such as malloc().

There is a small subset of C library routines that are safe to call from signal handlers. Do not try to call any other C library routines, or any COBOL routines, from your signal handler. See your system documentation for more information on the safe C library routines.

Some signals are generated by the operating system when a serious error has occurred. Catching these signals can cause unexpected and potentially dangerous results. You should not catch any of the following signals:

  • SIGABRT
  • SIGBUS
  • SIGEMT
  • SIGFPE
  • SIGILL
  • SIGIOT
  • SIGSEGV
  • SIGSYS
  • SIGTRA

Preventing the run-time system from processing certain signals can break some run-time system functionality. If you catch any of these signals (with a priority of 140 or more), your signal handler must return a non-zero value so that the run-time system's handler is also executed. The signals concerned include:

  • SIGCHLD
  • SIGCONT
  • SIGPIPE
  • SIGTSTP
  • SIGTTIN
  • SIGTTOU
  • SIGUSR1
  • SIGUSR2
  • SIGVTALRM
  • SIGWINCH
Note: We reserve the right to change our default signal handlers or use extra signals in the future.

For an example, see Example of Posting a Signal Handler.

Parent topic: Signal Handling
Related reference
cobremovesighandler
cobpostsighandler
Related information
Converting Signal Handlers Written for the signal() Function
Signal Handling Overview
Posting Signal Handlers
More than One Handler for the Same Signal
Third Party Software that Uses Signals
Example of Posting a Signal Handler


More than One Handler for the Same Signal

Restriction: The following applies to native COBOL only.

The cobpostsighandler() routine enables two or more handlers to be posted for the same signal. When that signal is generated by the operating system (such as a SIGINT generated when the interrupt key is pressed), each handler can take appropriate action and then let other handlers be executed (by returning a non-zero value). Alternatively, they can decide to make the signal "ignored" by returning a value of zero to prevent other handlers from being executed. However, so that your handler can work with other handlers for the same signal, a handler of priority 140 (or more) should return non-zero to let other handlers have the opportunity to also be notified. A handler of priority 128 can return zero if you do not want the run-time system default action to be executed (which may cause termination).

When you raise a signal (such as by using CTRL+C to raise a SIGINT signal, or when raising a signal to a different run-unit or application), then it is probable that only your signal handler wants to be called and other posted signal handlers are not expecting the signal. Hence, in this case, you should set a global resource before raising the signal and then check that resource in your signal handler. If the resource is set (as expected), then the signal was raised by you, so you can take the appropriate action and return zero to prevent other handlers from being unexpectedly called. If the resource is unset, then someone else (or something else, such as the operating system) raised the signal and so you can take no action and should let other handlers execute by returning a non-zero value.

Examples of global resources are global variables (if in the same run unit), shared memory, pipes, files, and so on. Hence, in the above example, we could have set a global variable before raising the alarm() signal. We would then need to check the global variable in the signal handler, mysigcatch(). If it was set, we would carry out our action, reset the variable and return zero. However, if the global variable had not been set, then some other code is likely to have raised the signal. Hence, we would not want to carry out our action and would instead need to return a non-zero value immediately. This allows the appropriate action to be taken in some other handler.

Parent topic: Signal Handling
Related reference
cobremovesighandler
cobpostsighandler
Related information
Converting Signal Handlers Written for the signal() Function
Signal Handling Overview
Posting Signal Handlers
Writing Signal Handlers
Third Party Software that Uses Signals
Example of Posting a Signal Handler


Converting Signal Handlers Written for the signal() Function

Restriction: The following applies to native COBOL only.

If you have any signal handlers that are posted using a C library signal call, such as signal(), change them to use the cobpostsighandler() routine. This is so that your handler and any default run-time system handler, additional COBOL functionality and user-posted signal handlers can all co-exist without one overriding the other, causing unexpected results.

The cobpostsighandler() routine interface is very similar to the signal() interface. The two parameters you pass to signal() are also passed to the cobpostsighandler() routine, plus a priority.

The differences between signal() and the cobpostsighandler() routine are:

  • The return value from signal() is the previous signal handler that was posted for the signal. This is returned because signal() allows only one handler per signal. The cobpostsighandler() routine allows multiple handlers per signal.

    The return value from cobpostsighandler() is either a pointer or NULL. You use this pointer to remove your handler later using cobremovesighandler(). If the return value is NULL, the handler was not posted for the signal.

  • A signal handler function that you post using cobpostsighandler() needs to return an integer value, whereas a signal handler function that you install using signal() needs to return no value.
  • A signal handler posted using C library signal calls can be terminated by functions such as longjmp() and siglongjmp(), but a signal handler posted using the cobpostsighandler() routine cannot be terminated by these routines. If you try to do this, the signal is blocked, and further signals cannot be processed.
  • A signal handler function posted using signal() needs to repost itself, using another signal() call, if it wants to catch subsequent signals. This is because the operating system resets the signal to the operating system default handler before the signal handler function is called.

    By contrast, you do not need to repost a handler that you posted using cobpostsighandler() routine; it stays posted. If you want your handler to be executed only once, remove it using the cobremovesighandler() routine.

Parent topic: Signal Handling
Related reference
cobremovesighandler
cobpostsighandler
Related information
Signal Handling Overview
Posting Signal Handlers
Writing Signal Handlers
More than One Handler for the Same Signal
Converting Signal Handlers Written for the signal() Function
Third Party Software that Uses Signals
Example of Posting a Signal Handler


Third Party Software that Uses Signals

Restriction: The following applies to native COBOL only.

If you are using third party software that posts a signal handler using a C library signal routine, such as signal() or sigaction(), unexpected results may occur. For example, if the third party software posts its handler before COBOL has been invoked, then when COBOL is invoked the third party's handler might be overridden by a run-time system or COBOL handler. If the third party subsequently raises a signal, then a 115 error may occur.

To overcome this, you can use the run-time tunable signal_regime. This tunable prevents handlers from being posted for the specified signal if a signal handler is posted before the first COBOL invocation.

If handlers are prevented from being posted for a signal, due to this tunable, the cobpostsighandler() routine returns NULL. Hence, the default run-time system handlers and any additional COBOL functionality achieved using the signal is not available. It also means that you should check the value returned from any cobpostsighandler() routine calls for NULL.

We recommend that you use the signal_regime tunable only with third party software. You should always use the cobpostsighandler() routine in your own code.

Parent topic: Signal Handling
Related reference
signal_regime
cobremovesighandler
cobpostsighandler
cobpostsighandler
cobremovesighandler
Related information
Converting Signal Handlers Written for the signal() Function
Signal Handling Overview
Posting Signal Handlers
Writing Signal Handlers
More than One Handler for the Same Signal
Example of Posting a Signal Handler


Examples of Mixed Language Programming

Restriction: The following applies to native COBOL only.
  • Example of Calling C functions from COBOL
  • Example of Calling an Assembler Subprogram
  • Example of Calling a Win32 API Routine
  • Example of Posting a Signal Handler
Parent topic: Mixed Language Programming with Native COBOL


Example of Calling C functions from COBOL

Restriction: The following applies to native COBOL only.

The following example shows how C functions can be accessed from a COBOL program:

$set rtncode-size"4"
 working-storage section.
 01 str.
     03 str-text    pic x(10).
     03 filler      pic x  value x"00".
* Null terminate string for C function
 01 counter  pic 9(8) comp-5  value zero.

 procedure division.
 call-c section.
     call "cfunc" using str, counter
     if return-code not = zero
* RETURN-CODE set from return () in C

         display "ERROR"
     else
         display "OK"
     end-if
     stop run.
------------------------------------------------

cfunc  (st, c)
char  *st;
int   *c;
{
   ...
   return(0);
}
Parent topic: Examples of Mixed Language Programming


Example of Calling an Assembler Subprogram

Restriction: The following applies to native COBOL only.

An assembler subprogram that obeys the standard COBOL calling convention takes the following form:

The assembler subprogram can consist of multiple code and data segments. You should ensure that the initial code entry point is at the start of the first code segment defined or alternatively that you explicitly define the entry point label after the End directive.

Note:
  • It is essential that each code segment is defined as having a class name of CODE or have a class-name with the suffix CODE. Failure to do so means that the Linker fails to give the segment the access rights which permits it to be executed
  • When linking dynamically, the entry point to the subprogram should be defined in the .def file which you must supply when linking. For the example above the .def file should contain the following lines:
    LIBRARY libname
EXPORTS entry-point-name @1
;---------------------------------------------------------
; Example skeleton assembler subprogram
;---------------------------------------------------------
;---------------------------------------------------------
; Declare local data segment(s)
;---------------------------------------------------------

.386
.MODEL FLAT ;
_DATA   segment dword use32 public 'DATA'
        ...
    data used by subprogram
        ...
_DATA ends

;---------------------------------------------------------
; Declare local code segment(s)
;---------------------------------------------------------

_TEXT   segment dword use32 public 'CODE'

assume cs:flat, ds:flat, ss:flat, es:flat

;---------------------------------------------------------
; Declare public entry point
;---------------------------------------------------------

PUBLIC EXAMPLE

;---------------------------------------------------------
; Declare equates for accessing params(COBOL convention)
;---------------------------------------------------------

param1 equ  ebp+8
param2  equ  ebp+12

EXAMPLE proc  near
    push  ebp              ; preserve ebp
    mov   ebp,esp          ; address params on stack
    push  esi              ; preserve esi, edi
    push  edi

    ...
    program code
    ...

    mov  esi,[param1]      ; access parameter 1
    ...
    mov  esi,[param2]      ; access parameter 2
    ...
    mov  eax,{return-code} ; set up
                           ; return code
    ...

    pop  edi
    pop  esi               ; restored esi,edi
    pop  ebp               ; restored ebp
    ret

EXAMPLE endp

    _TEXT    ends
    end
Parent topic: Examples of Mixed Language Programming
Related information
Interfacing with Assembler Subprograms
Call Conventions for Interfacing with Mixed Languages
Example of Calling a Win32 API Routine
Interfacing with Windows API Routines


Example of Calling a Win32 API Routine

Restriction: The following applies to native COBOL only.

The following program makes use of an API routine to retrieve the current date and time.

 special-names.
     call-convention 74 is winapi.
 working-storage section.
 01 system-time.
     03 system-year     pic 9(4) comp-5.
     03 system-month    pic 9(4) comp-5.
     03 system-day-of-week  pic 9(4) comp-5.
     03 system-day    pic 9(4) comp-5.
     03 system-hour    pic 9(4) comp-5.
     03 system-minute   pic 9(4) comp-5.
     03 system-second   pic 9(4) comp-5.
     03 system-millisecond  pic 9(4) comp-5.

 procedure division.
     call "cob32api"
     $if NOILGEN defined
         call "cob32api"
     $end
     call winapi "GetSystemTime" using
                  by reference system-time
     display "Day of week is:  " system-day-of-week
     display "Day of month is:  " system-day
     stop run.
Parent topic: Examples of Mixed Language Programming
Related information
Interfacing with Assembler Subprograms
Example of Calling an Assembler Subprogram
Call Conventions for Interfacing with Mixed Languages
Interfacing with Windows API Routines


Example of Posting a Signal Handler

Restriction: The following applies to native COBOL only.

The following example illustrates posting a signal handler for the SIGABRT signal:

#include <stdio.h>
#include <signal.h>
#include "cobsignal.h"
#include "cobmain.h"

int
mysigcatch(int sig, cobsiginfo_t * mf_info)
{
     printf("In signal handler for sig %d\n", sig);
     return 0;  /* Do not process any further handlers. */
}

void
mysigexit(cobsigtype_t sighand)
{
    printf("Cancelling handler\n");
    cobremovesighandler(sighand);       /* Remove the handler. */
}

int
main(int argc, char *argv[])
{
    cobsigtype_t sighandle;

    cobinit();

    sighandle = cobpostsighandler(SIGABRT, 128, mysigcatch);
    if(sighandle)
    {
        /* Call a cobol program using cobfunc function. */
        cobfunc("cobolprog", argc, argv);

        raise(SIGABRT); /* Raise the signal. */
        mysigexit(sighandle);
    }

    cobexit(0); /* Cobexit - close down COBOL run-time environment. */
}
Parent topic: Examples of Mixed Language Programming
Related reference
cobremovesighandler
cobpostsighandler
cobpostsighandler
cobremovesighandler
Related information
Converting Signal Handlers Written for the signal() Function
Signal Handling Overview
Posting Signal Handlers
Writing Signal Handlers
More than One Handler for the Same Signal
Third Party Software that Uses Signals


Web Services and COBOL

  • Introduction to COBOL Web Services
    There are different ways that you can use your COBOL development system to expose a COBOL application as a Web service.
  • Tutorials - Web Services and COBOL
  • Generating a Client from a WSDL File
    Starting with any WSDL file, you can generate a COBOL client application using the Generate Client from WSDL feature, or the imtkmake command.
Parent topic: COBOL Programming


Introduction to COBOL Web Services

There are different ways that you can use your COBOL development system to expose a COBOL application as a Web service.
  • Overview
    Web Services is the name of a set of standards and mechanisms enabling software components to be invoked across the Web. The components themselves are called Web services.
  • COBOL Web Services
    There are several ways you can use your COBOL development system to expose COBOL programs as Web services.
  • WS-I Compliance
    The Web services that the Service Interfaces feature creates are WS-I Basic Profile 1.0 compliant.
Parent topic: Web Services and COBOL
Related information
Tutorials - Web Services and COBOL
Generating a Client from a WSDL File


Overview

An application using a Web service (a client application) can invoke it and pass data to and from it very easily, because all communication between them is in the form of XML files sent using a standard protocol such as HTTP. This means the client application has no need to know details of how the component is deployed, what language it is in, and so on.

In theory, exposing a component as a Web service means it can be invoked across the Web by anyone in the world. For example, a credit card company might provide a Web service to be called by retailers to validate card details. They are often used across companies' intranets, for use in internal applications and as a means of integrating disparate internal applications.

Web Services is built around three standards that define the format of the XML files needed to link clients to services:

  • WSDL - Web Services Description Language

    A file containing information in this format is made available to people wanting to write clients that call a Web service. It describes the interface that the service expects and what format the data will be in. This is, in effect, the contract for the Web service that must be obeyed by both parties. You can also generate a client application directly from a WSDL file.

  • SOAP - Simple Object Access Protocol

    SOAP is how the actual data that allows the web service client and service to communicate is formatted. A typical web service interaction will consist of a SOAP Request followed by a SOAP Response. These packets of data are sent across the network using the HTTP protocol.

  • UDDI - Universal Description, Discovery and Integration

    Lists, or registries, of services are published on the Web in this format. It may be advantageous to think of a UDDI repository as a type of telephone directory or ‘Yellow Pages’ of Web services.

For the latest specifications of WSDL, SOAP, HTTP and UDDI, see the World Wide Web consortium Web site.

Parent topic: Introduction to COBOL Web Services
Related information
World Wide Web consortium


COBOL Web Services

  • You can use the Interface Mapping Toolkit to map the call interface onto a Web Services interface, and to create a WSDL file. You deploy the Web service under Server Enterprise Edition.

    This approach is documented in the chapter COBOL Web Services with the Interface Mapping Toolkit. Also see the book Interface Mapping Tutorials.

  • You can use the Interface Mapping Toolkit to deploy the program as a COM object, and then use the Microsoft SOAP Toolkit to extract the call interface and create a WSDL file from it. You deploy the COM object under Server Enterprise Edition.

    This approach is documented in the chapter COBOL Web Services with the Microsoft SOAP Toolkit. You can download the SOAP Toolkit from the Microsoft Web site.

  • You can use toolkits based on Java. There is a variety of toolkits available (for example, the IBM Web Services Toolkit) that enable Java applications to call Web services, as well as exposing Java classes as Web services. By using the support included in Micro Focus COBOL for interoperability with Java, you can use these toolkits from COBOL.

    No documentation for this approach is provided here. For COBOL/Java interoperability, see the chapter Using Java and COBOL Together.

For a comparison of the advantages of the different methods, see the chapter Application Extension with Distributed Computing .

Parent topic: Introduction to COBOL Web Services
Related information
HTTP://WWW.MICROFOCUS.COM/DOCS/LINKS.ASP?MFE=MSFTDNLD


WS-I Compliance

The Web Services Interoperability Organization (WS-I) is an open industry organization chartered to promote Web services interoperability across platforms, operating systems, and programming languages. The WS-I Basic Profile is a document containing a set of assertions and rules which vendors and end-users should conform to in order to maximize the interoperability of their web services across various platforms.

Parent topic: Introduction to COBOL Web Services
Related information
HTTP://WWW.MICROFOCUS.COM/DOCS/LINKS.ASP?NX=WSI


Tutorials - Web Services and COBOL

  • Debugging Web Services
Parent topic: Web Services and COBOL
Related information
Introduction to COBOL Web Services
Generating a Client from a WSDL File


Debugging Web Services

  1. Tutorial: Debugging Web Services
  2. Configure an Enterprise Server for Web Services
  3. Deploy the Web Service under Enterprise Server
  4. Create a Visual Studio Project
  5. Debug the Web Service
Parent topic: Tutorials - Web Services and COBOL


Tutorial: Debugging Web Services

This tutorial shows how you can use Visual Studio to debug COBOL Web Services running on Enterprise Server.

The following outlines the steps to complete this tutorial:

  1. Create and configure an enterprise server for dynamic debugging.
  2. Configure the Net Express WebService demonstration application to use Enterprise Server.
  3. Use Net Express to deploy the supplied Web service to Enterprise Server.
  4. Generate a client with Net Express.
  5. Create a Visual Studio project for the COBOL source and associate it with Enterprise Server.
  6. Run the client in Net Express.
  7. Debug the Web service in Visual Studio.

Demonstration Applications and Prerequisites

This tutorial uses two demonstration applications supplied with your COBOL development system that use the same COBOL source, calculator.cbl. One of them is a Net Express project that includes the COBOL source application and a Web service created from it that you deploy to Enterprise Server via Net Express. The other demonstration application includes the COBOL source for the same Web service and you use it to debug the Web service in Visual Studio.

The COBOL source application, calculator.cbl, is a simple COBOL program that adds two numbers and outputs the result.

The demonstration applications are:

  1. The Net Express WebService demonstration is supplied in the subdirectory %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Net Express IDE\WebService in your installation folder. It includes the following files:
    • calculator.cbl - COBOL source file
    • calculator.xml - mapping for the Web service
    • calculatordemo.xml - the Web service to be deployed to Enterprise Server
    • webservice.mpr - service interface for the supplied Web service
    • webservice.app - project file for this Net Express demonstration application
  2. The Visual Studio demonstration, the Calculator demonstration, is in the subdirectory Examples\Visual Studio Integration\Calculator in your installation folder. It includes the calculator.cbl file, which is the COBOL source of the Web service supplied with the Net Express WebService demonstration.

For more info on how you can create Web Services from COBOL applications, read the chapters on Interface Mapping in the Micro Focus Net Express Help.

Parent topic: Debugging Web Services
Next topic: Configure an Enterprise Server for Web Services


Configure an Enterprise Server for Web Services

These are the steps to create an enterprise server on which you will deploy the Web service supplied with the demonstration application.

In this tutorial you:

  1. Create an Enterprise Server for Web Services.
  2. Configure the Enterprise Server.
  3. Start the Enterprise Server.

Create an Enterprise Server

To create an Enterprise Server on which you can deploy Web Services:

  1. Start Visual Studio.
  2. In Server Explorer, right-click Micro Focus Servers and choose Administration from the context menu.

    If Server Explorer is not visible, choose View > (Other Windows >) Server Explorer to open it.

  3. On the home page of Enterprise Server Administration, click Add.
  4. In the Server Name field, type WEBDEMO.
  5. Make sure Working mode is set to 32-bit.
  6. Click Next.
  7. In the Server Type group, make sure Micro Focus Enterprise Server is selected.
  8. Click Next.

    There is no need to change the settings on this page. Notice the description for your enterprise server in the Description field: "Communications server for Web Services".

  9. Click Add.

The home page of Enterprise Server Administration is displayed. It shows your new WEBDEMO server on the list of the available enterprise servers.

Configure the Enterprise Server

After you have created an enterprise server on which you can deploy Web Services, configure it to enable dynamic debugging as follows:

  1. On the home page of Enterprise Server Administration, click the Edit button that corresponds to WEBDEMO.
  2. Check Allow Dynamic Debugging.
  3. Click Apply.

Start the Enterprise Server

To run the application, you need to start the enterprise server instance that you just created as follows:

  1. In Server Explorer, right-click WEBDEMO under Micro Focus Servers.
  2. Choose Start from the context menu.

    This displays a daemon and starts the WEBDEMO enterprise server. When the home page of Enterprise Server Administration page is refreshed, you can see that the Status column in the row for WEBDEMO shows that the server is started.

  3. Minimize the daemon.
  4. In Server Explorer, right-click the Micro Focus Servers group.
  5. Choose Refresh from the context menu to update the server status.
  6. On the home page of Enterprise Server Administration, click Details that corresponds to Listeners for your WEBDEMO enterprise server.

    The listeners represent the three types of services we can run using this enterprise server.

  7. Under the Listeners tab, notice the address and the port for Web Services and J2EE. Write them down as you will need them later to deploy the Web service and to run the Calculator application.

    Note that each time you restart the enterprise server, the port changes.

  8. On the list that appears on the left-hand side of the page, click Home to return to the home page of Enterprise Server Administration.
Parent topic: Debugging Web Services
Previous topic: Tutorial: Debugging Web Services
Next topic: Deploy the Web Service under Enterprise Server


Deploy the Web Service under Enterprise Server

In this topic, you use Net Express to deploy the COBOL Web service supplied with the Net ExpressWebService demonstration to Enterprise Server and generate a client for it.

This is an outline of the steps you perform:

  1. Open the Net Express project supplied with the WebService demonstration.
  2. Configure the project to use your enterprise server, WEBDEMO.
  3. Open the supplied Web service and specify deployment settings for it.
  4. Deploy the Web service to Enterprise Server.
  5. Generate a client for the Web service.

Open the Supplied Net Express Project

To open the Net Express project supplied with the WebService demonstration:

  1. Navigate to the \Examples\Net Express IDE\WebService folder in the installation of your COBOL development system.
  2. Start webservice.app.
  3. Click Yes in the dialog that appears to start using the project directory.

The project opens displaying two windows - the Project window showing the COBOL source program, calculator.cbl, and the Service Interfaces window showing the Web service, CalculatorDemo, supplied with the demonstration.

Expand CalculatorDemo in tree view, to see that it consists of a single one operation, Add.

Configure the Project to Use Enterprise Server

To configure the project to use an enterprise server:

  1. Choose Project > Properties.
  2. Under Enterprise Server, select Project uses an enterprise server.
  3. Click the corresponding Browse button.
  4. In the Enterprise Servers window, click Refresh.
  5. Choose WEBDEMO from the drop-down list.
  6. Click OK twice.

Build the Project

To build the project:

  1. Click Build > Rebuild.

The application .dll and .idy files are created in the output Debug folder in your project directory.

Specify Settings for the Web Service

  1. In the Service Interfaces window, right-click CalculatorDemo.
  2. Click Settings.
  3. Click OK.
  4. On the Mapping Properties dialog, notice the name of your service, http://tempuri.org/CalculatorDemo.
  5. On the Deployment Server tab, click Change next to Enterprise server name.
  6. Select WEBDEMO.
  7. Click OK.
  8. Click Advanced.

    Notice the default namespace, http://tempuri.org/, which is used to define the service.

  9. In the Endpoint URL section, type the relevant address and port for Web Services of your WEBDEMO enterprise server using the following format: http://IPAddress:Port.
  10. Click OK.
  11. Click the Application Files tab.
  12. Click Legacy application needs deploying.
  13. Click Add files.
  14. Open the Debug folder in your project directory.
  15. Select the calculator.int and calculator.idy files.
  16. Click Add.
  17. Click OK twice.

Deploy the Web Service

Now that you have created and configured a project for the Web service, you can deploy it as follows:

  1. In the Service Interfaces window, right-click CalculatorDemo.
  2. Select Deploy.

    In the Deployment progress window, you can see when your Web service is deployed.

To see the Web service deployed to WEBDEMO:

  1. In Visual Studio, open Enterprise Server Administration.
  2. On the row corresponding to WEBDEMO, click Details in the Status column.
  3. Make sure Server > Control tabs are selected.
  4. Click ES Monitor & Control.
  5. Click Services in the left-hand bar.

    The Services page shows the Web service that you deployed, http://tempuri.org/CalculatorDemo#Add, where Add is the operation for this service.

Generate Client

To generate a client for the Web service:

  1. In Net Express, click calculator.int in the Project window.
  2. Choose Service > Generate Client > using WSDL.
  3. In the dialog that appears, click Browse next to the WSDL name field.
  4. Browse to the ..\webservice\REPOS\Calculator.deploy subfolder in your Net Express project directory.
  5. Select the .wsdl file.
  6. Click Open > Next > Use current Net Express project > Next > Finish.

    The client, CalculatorDemo-app.cbl, has been added to the Project window.

  7. Rebuild the project.
Parent topic: Debugging Web Services
Previous topic: Configure an Enterprise Server for Web Services
Next topic: Create a Visual Studio Project


Create a Visual Studio Project

You use Visual Studio to debug the source of the COBOL Web service deployed to Enterprise Server. That is why you need a Visual Studio project to hold the COBOL source of the service. You associate the project with the WEBDEMO enterprise server so when a client for the Web service starts, you can debug the service dynamically.

The following outlines the steps you perform in this topic:

  1. Create a Visual Studio project for the Calculator application, calculator.cbl, which is the source of the Web service you deployed to Enterprise Server.
  2. Specify properties for the project.
  3. Associate the project with your enterprise server, WEBDEMO.

Create a Visual Studio Project

To create a project to hold the COBOL source file from the demonstration program:

  1. Start Visual Studio.
  2. Click File > New > Project > COBOL Projects > Native > Mainframe Subsystem Application.
  3. Optionally, specify a name for your project such as Calculator.
  4. Optionally, specify a path to the project folder in Location.
  5. Click OK.
  6. Using Windows Explorer, copy calculator.cbl from from the subdirectory Examples\Visual Studio Integration\Tutorials\Calculator in your installation folder to your project directory.

Import the COBOL Source Program

To import the COBOL source program into your Visual Studio project:

  1. In Solution Explorer, right-click your project.
  2. Choose Add > Existing Item.
  3. Select calculator.cbl in your project directory.
  4. Click Add.

Specify Project Properties

To specify properties for the project:

  1. In Solution Explorer, double-click the Properties folder.
  2. On the COBOL tab, make sure that the “Non-mainframe” COBOL dialect is selected.
  3. On the Debug tab, select WebService in the Choose Active Setting.
  4. On the same tab, click the Web Services tab.
  5. Leave the Client IP Address field empty to allow debugging from any IP address.
  6. In the Service field, type the address of the Web service in the following format: http://tempuri.org/ServiceName#OperationName.

    In your case, you need to type the address of the service as it is displayed on the Services page of Enterprise Server Administration: http://tempuri.org/CalculatorDemo#Add.

  7. Click File > Save All to save the changes to the project properties.

Associate Your Project with Enterprise Server

You need to associate your Visual Studio project with the running WEBDEMO Enterprise Server to be able to debug the Web service deployed to it.

To associate the project:

  1. In Server Explorer, right-click Micro Focus Servers and choose Refresh.
  2. Right-click WEBDEMO and choose Associate with project > your project.

Build the Solution

To build the solution:

  1. Right-click the solution in Solution Explorer.
  2. Choose Build Solution from the context menu.

    Check the Output window to see if the solution built successfully.

Parent topic: Debugging Web Services
Previous topic: Deploy the Web Service under Enterprise Server
Next topic: Debug the Web Service


Debug the Web Service

In the previous steps you created and configured an enterprise server for dynamic debugging. You deployed to it the Web service supplied with the WebService demonstration and generated a client for it.

You created a Visual Studio project for the COBOL source program of the Web service.

Now if a client is invoked and the Web service is running you can debug the service by debugging its source in Visual Studio.

In this demonstration you:

  1. Insert a breakpoint in the COBOL source of the Web service.
  2. Rebuild the Visual Studio project.
  3. Start a debugging session in Visual Studio.
  4. Run the client in Net Express to start the service.
  5. You execute the service and debug it in Visual Studio.

Insert a Breakpoint in the COBOL Source

To introduce a breakpoint in the COBOL source of the Web service, the Calculator application:

  1. Open your Visual Studio project.
  2. In Solution Explorer, double-click the COBOL source, calculator.cbl.

    The application opens in the code editor.

  3. Insert a breakpoint on the ADD statement in the Procedure Division.

    To do this, double-click in the left margin of the ADD statement.

Rebuild the project

  1. Right-click the project in Solution Explorer.
  2. Select Rebuild from the context menu.

Start Debugging

To start a debugging session:

  1. Click Debug > Start Debugging.

Run the Client and Debug the Service

You run the client as follows:

  1. In the Net Express project window, right-click CalculatorDemo-app.int.
  2. Click Run.
  3. Click OK in the Start Animating dialog.
  4. In the Application output window, enter the address of the Web service and the port as stored under Listeners for WEBDEMO.

    The format should be as follows: http://IPAddress:Port.

  5. Press Enter twice to skip entering a username and a password.
  6. On the Add.a line, type an arbitrary number.
  7. Press Enter.
  8. On the Add.b line, type another number.
  9. Press Enter.

    At this point, the debugger hits the breakpoint in the COBOL source and Visual Studio opens and highlights the line of code that has a breakpoint.

Stop Debugging

When you have finished debugging, you need to end the debug session as follows:

  1. In Visual Studio, click Debug > Stop Debugging.
Parent topic: Debugging Web Services
Previous topic: Create a Visual Studio Project


Generating a Client from a WSDL File

You can generate a COBOL client console application starting from any WSDL file, whether generated using the Service Interfaces feature, or created using some other method. The files generated from a WSDL are:
  • wsdlFileName-app.cbl - main COBOL program
  • wsdlFileName-proxy.cbl - proxy COBOL program called by the main COBOL program
  • wsdlFileName-copy.cpy - copybook containing working storage definitions
  • wsdlFileName.cvt - an xml-formatted file containing data items and entry points
  • wsdlFileName.svi - a service interface file you can further define using the Service Interfaces feature

Generate From the Visual Studio IDE

The Generate Client from WSDL feature is available from the Visual Studio IDE.

Before generating your client, you can optionally change the default string length to use for unbounded strings and the default array size to use for unbounded arrays. Do this from the Visual Studio Options dialog box under Tools > Micro Focus COBOL Tools > Generate Client from WSDL. The preset defaults are:
Default string length: | 256
Default array size: | 256

Within Visual Studio, if you have a solution open at the time you generate the client, the generated client files are stored within the open solution. However, if you generate a client from Visual Studio without an active open solution, the generated files are written to the %USERPROFILE%\documents\Visual Studio nnnn\Projects\wsdlFileName\wsdlFileNameConsoleApp directory.

To generate a client from a WSDL file, click Tools > Micro Focus COBOL Tools > Generate Client from WSDL; then specify a WSDL filename.

Generate Using the imtkmake Command

Use of this command is fully documented in the topic imtkmake command.

Parent topic: Web Services and COBOL
Related information
Introduction to COBOL Web Services
Tutorials - Web Services and COBOL
imtkmake command


XML Input/Output

  • Using XML and COBOL Together
    Describes support for XML including an explanation of XML, XML schemas, and how XML fits in with COBOL.
  • XML Syntax Extensions
    This describes the XML syntax extensions provided to enable COBOL programs to input and output XML.
  • Generating COBOL Structures with XML Syntax
    Discusses the generation of COBOL data structures with XML syntax by means of the cbl2xml command-line utility.
Parent topic: COBOL Programming


Using XML and COBOL Together

  • COBOL and XML
  • XML Implementation
  • XML PARSE
  • XML in Brief
Parent topic: XML Input/Output
Related information
XML Syntax Extensions


COBOL and XML

Studio Enterprise Edition makes it easy to harness the power of XML data exchange with existing and new COBOL applications.

XML syntax extensions augment the COBOL syntax already supported. The extensions support a full range of syntax for manipulating XML documents, and are processed using the XML preprocessor.

You can use the cbl2xml command-line utility to:

  • Generate COBOL with XML syntax
  • Generate an XML schema based on existing COBOL records
  • Map COBOL records to a schema
  • Validate XML schemas and instance documents

Whether you do the process manually or with the aid of cbl2xml, the process of XML-enabling a COBOL application consists of:

  • Modifying the COBOL code using XML syntax extensions
  • Generating COBOL data records with XML syntax
  • Compiling the code, which invokes the XML preprocessor
  • Testing and deploying the application

You cannot create static-linked programs that handle XML data, as only the shared run-time system supports the XML interface.

Parent topic: Using XML and COBOL Together
Related information
XML Syntax Extensions
Generating COBOL Structures with XML Syntax
XML in Brief


XML Implementation

XML data encoding is record-based and the vast majority of possible encodings can be easily represented as COBOL data records. For example, this XML stream:

<?xml version="1.0"?>
<group elementNumber=1235 >
   <elementAlpha>Alpha value</elementAlpha>
</group>

Can be received directly by COBOL code using syntax extensions as follows:

01  xmls-group                    identified by "group".
    05  xmls-Number     pic 9(18) identified by
        "elementNumber" is attribute.
    05  xmls-Alpha      pic x(80) identified by
        "elementAlpha".

This is a simple example. However, we support a number of more complex syntax scenarios, including variable tag specifications, non-regular and nested occurrences, mixed data, and optional elements.

Once you are able to encode XML records in your application, you can originate or receive these records in your COBOL application. Do this using standard file input/output verbs including OPEN, READ, WRITE, and CLOSE. The run-time support automatically converts, encodes, and performs all of the necessary I/O. For example, the following code is all that is necessary to generate the XML stream depicted in the example above into the file out-xml:

     select xml-stream assign "out.xml"
           organization  is xml
           document-type is "group"
           file status is xml-bookdb-status.
     xd xml-stream.
     01  xmls-group                identified by "group".
         05  xmls-Number pic 9(18)
             identified by "elementNumber" is attribute.
         05  xmls-Alpha  pic x(80)
             identified by "elementAlpha".
     working-storage section.
     01  xml-bookdb-status         pic s9(9) comp.

     move 1235                     to xmls-Number
     move "Alpha value"            to xmls-Alpha
     open output xml-stream
     write xmls-group
     close xml-stream
     stop run.
Parent topic: Using XML and COBOL Together


XML PARSE

We fully support the IBM syntax for XML handling, known as XML PARSE.

The XML PARSE statement provides a mechanism for processing XML. The statement causes XML document data to be split into component fragments by the system's XML parser, and to be made available to a user-defined routine. Each fragment is labeled with a tag or "event" to indicate the nature of the fragment.

  • Special Registers
  • User Routine
Parent topic: Using XML and COBOL Together
Related reference
The XML PARSE Statement


Special Registers

Communication between the parser and the user routine is handled through four special registers:

  • XML-CODE to determine the status of the XML parsing.
  • XML-EVENT to receive the name of each XML event; for example, START-OF-DOCUMENT.
  • XML-TEXT to receive XML document fragments from an alphanumeric document.
  • XML-NTEXT to receive XML document fragments from a national document.
Parent topic: XML PARSE
Related information
Special Registers


User Routine

You need to include a user routine in your program. This routine typically contains an EVALUATE statement that handles the XML-EVENT values. The parser continually provides fragment information to the user routine until the entire document has been processed or until a fatal error is encountered. If malformed XML is encountered by the parser, an error code is placed into the special register XML-CODE, and control is transferred to an imperative statement. For non-fatal errors however, the user routine has the option of resetting XML-CODE to zero and and thus continuing execution. It also has the option of setting XML-CODE to -1 for a normal event. This causes the parser to terminate, but without generating an exception event.

Parent topic: XML PARSE


XML in Brief

XML (eXtensible Markup Language) is fast emerging as the language of choice for exchanging data over the World Wide Web. The language is governed by a set of rules set forth in an XML schema or a Document Type Definition (DTD). These rules dictate the structure of an XML document. The XML schema is a more modern, powerful and prevalent technology for dictating XML document structure than the older DTD technology. We provide comprehensive support for XML schemas that enable input from and output to XML documents from a COBOL application.

  • XML Schemas
  • XML Instance Documents
Parent topic: Using XML and COBOL Together
Related information
COBOL and XML
World Wide Web consortium


XML Schemas

An XML schema (usually an .xsd file) is made up in part of element definitions. These definitions dictate the structure and content of an XML instance document that references the schema. XML elements can have attributes associated with them. These attributes further describe the data contained in the element.

The following is an example of a simple XML schema:

Sample XML Schema

<schema xmlns="http://www.w3.org/2001/XMLSchema"
   elementFormDefault="qualified">
   <element name="employee">
      <complexType>
         <sequence>
            <element name="emp-name">
               <simpleType>
                  <restriction base="string">
                     <length value="12"/>
                  </restriction>
               </simpleType>
            </element>
            <element name="emp-number">
               <simpleType>
                  <restriction base="string">
                     <length value="8"/>
                  </restriction>
               </simpleType>
            </element>
         </sequence>
      </complexType>
   </element>
</schema>

This schema defines a parent element, employee, with two child elements, emp-name and emp-number. Each of the child elements contains two child elements of its own - restriction and length. In this implementation of XML support, the base and value attributes for those elements are translated into COBOL record PIC clauses.

Parent topic: XML in Brief


XML Instance Documents

XML instance documents (.xml files) are built using the elements declared in a schema, and also contain data. You use XML syntax extensions to read from and write to XML instance documents.

Parent topic: XML in Brief


XML Syntax Extensions

Your COBOL development system supports the creation of relationships between COBOL data structures and element definitions in XML schemas. You can create COBOL XML syntax extensions, which enable you to code references to XML structures right into your COBOL definitions. These XML structures are used to input and output information in an XML format.

  • Syntax for Handling XML in COBOL
  • Compiling XML-enabled COBOL
Parent topic: XML Input/Output
Related information
COBOL and XML
Using XML and COBOL Together
Generating COBOL Structures with XML Syntax
Generating a Copybook and Schema
Accessing an XML-enabled Record


Syntax for Handling XML in COBOL

Syntax is provided specially designed to XML-enable COBOL. The following paragraph and clause descriptions are specifically for reading and writing XML from COBOL.

Note: If you want to compile the examples in this section, be sure to place the line numbers starting in column 3.
  • SELECT Paragraph
  • XML Description Paragraph (XD)
  • IDENTIFIED BY and IS ATTRIBUTE Clauses
  • PROCESSING-INSTRUCTION Clause
  • COUNT IN Clause
  • NAMESPACE Clause
  • COBOL Verbs
Parent topic: XML Syntax Extensions


SELECT Paragraph

The SELECT paragraph has been extended to enable you to assign a file name to an XML stream using the ASSIGN clause. The ASSIGN clause determines the routing of the XML stream and declares the schema that the stream conforms to. The actual format of the stream is solely determined by the record definitions contained in the XML Descriptor (XD) paragraph in the File Section.

Parent topic: Syntax for Handling XML in COBOL
Related reference
XML Syntax - SELECT Clause


XML Description Paragraph (XD)

For every file with an organization of XML, a set of record definitions is required to define the format of the XML stream being manipulated. These record definitions are contained in the XD paragraph in the File Section of the source program.

The following are not supported in the XD paragraph:

  • TYPEDEF
  • IS EXTERNAL
  • IS THREAD-LOCAL
  • VALUE
  • ANY LENGTH
Parent topic: Syntax for Handling XML in COBOL
Related reference
XML Syntax - XD File Description


IDENTIFIED BY and IS ATTRIBUTE Clauses

Use this syntax when declaring a COBOL data record to map the record to an XML element (tag) or an XML attribute that is defined in an XML schema or document.

You match up an XML tag with a COBOL data record using IDENTIFIED BY, and match up attributes for the XML tags with the addition of IS ATTRIBUTE. For example:

If you had an XML document that contained the following:

<company_name type="accounting">Webber Lynch</company_name>

a matching COBOL record using the IDENTIFIED BY and IS ATTRIBUTE clauses would be as follows:

    05  company identified by "company_name".
        10  company-name-value   pic X(30).
        10  company-type    pic x(10)
            identified by "type" is attribute.

You can work with variable tag and attribute names in your XML-enabled program, as well as known tag names. Using this method, you specify tags and attributes by substituting a COBOL data-name for a tag or an attribute name. On an XML file opened for output, this allows you to write purely dynamic and arbitrarily complex XML documents. On a file opened for input this allows you to read such complex documents. For example, the following program reads any XML stream that has a single root tag, any number of single nested tags and any number of attributes per tag:

Using the IDENTIFIED BY and IS ATTRIBUTE clauses

0010 $set preprocess(prexml) o(foo.pp) warn endp
0030
0040 select doc           assign address of mybuf
0050                      organization is xml
0060                      document-type is external doc-type
0070                      file status is doc-status.
0080 xd doc.
0090 01  root-tag            identified by root-tag-name.
0100     10  root-tag-name   pic x(80).
0110     10  root-tag-val    pic x(80).
0120     10  root-tag-attr   identified by root-tag-attr-name
0130                         is attribute.
0140         15  root-tag-attr-name pic x(80).
0150         15  root-tag-attr-val  pic x(80).
0160
0170     10  sub-tag              identified by sub-tag-name.
0180         15  sub-tag-name pic x(80).
0190         15  sub-tag-val  pic x(80).
0200         15  sub-tag-attr identified by sub-tag-attr-name
0210                          is attribute.
0220             20  sub-tag-attr-val  pic x(80).
0230             20  sub-tag-attr-name pic x(80).
0240
0250 working-storage section.
0260 01  doc-type            pic x(80).
0270 01  doc-status          pic s9(9) comp.
0280 01  mybuf.
0290     10  pic x(300) value
0300     '<library location="here" '
0310     &    'xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" '
0320     &    'xsi:schemaLocation="library.xsd">'
0330     &  '<book published="yes" goodreading="ok">'
0340     &   'booktext'
0350     &  '</book>'
0360     &  'is a place'
0370     & '</library>'.
0380
0390 procedure division.
0400     open input doc
0410     read doc
0420     display "Document type is: " doc-type
0430     display "Tag name: " root-tag-name
0440     display "Tag value:" root-tag-val
0450     start doc key root-tag-attr
0460     *>
0470     *> Loop through all attributes dumping names
0480     *>
0490
0500     perform until exit
0510        read doc next key root-tag-attr
0520        if  doc-status not = 0
0530            exit perform
0540        end-if
0550        display "Attribute name : " root-tag-attr-name
0560        display "Attribute value: " root-tag-attr-val
0570     end-perform
0580
0590     *> Loop through all sub-tags
0600     start doc key sub-tag
0610     perform until exit
0620        read doc
0630          next key sub-tag *> index is 1 is default
0640        if  doc-status not = 0
0650            exit perform
0660        end-if
0670        display " Sub tag name: " sub-tag-name
0680        display " Sub tag value:" sub-tag-val
0690
0700        start doc key sub-tag-attr index is 1
0710        perform until exit
0720            read doc next key sub-tag-attr
0730            if  doc-status not = 0
0740                exit perform
0750            end-if
0760            display " Sub tag attribute name : "
0770              sub-tag-attr-name
0780            display " Sub tag attribute value: "
0790              sub-tag-attr-val
0800        end-perform
0810    end-perform
0820
0830    close doc
0840
0850    stop run.

Lines 0040 - 0070:

0040 select doc           assign address of mybuf
0050                      organization is xml
0060                      document-type is external doc-type
0070                      file status is doc-status.

Assigns a filename and the buffer mybuf as the source of the XML input, specifies the organization of the file (XML), provides a data-name that variably specifies the XML schema name, and provides a data-name for the file status.

Lines 0080 - 0230:

0080 xd doc.
0090 01  root-tag            identified by root-tag-name.
0100     10  root-tag-name   pic x(80).
0110     10  root-tag-val    pic x(80).
0120     10  root-tag-attr   identified by root-tag-attr-name
0130                         is attribute.
0140         15  root-tag-attr-name pic x(80).
0150         15  root-tag-attr-val  pic x(80).
0160
0170     10  sub-tag              identified by sub-tag-name.
0180         15  sub-tag-name pic x(80).
0190         15  sub-tag-val  pic x(80).
0200         15  sub-tag-attr identified by sub-tag-attr-name
0210                          is attribute.
0220             20  sub-tag-attr-val  pic x(80).
0230             20  sub-tag-attr-name pic x(80).

Sets up the record structure of the buffer area.

Lines 0280 - 0370:

0280 01  mybuf.
0290     10  pic x(300) value
0300     '<library location="here" '
0310     &         'xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" '
0320     &         'xsi:schemaLocation="library.xsd">'
0330     &    '<book published="yes" goodreading="ok">'
0340     &       'booktext'
0350     &    '</book>'
0360     &    'is a place'
0370     & '</library>'.

Codes the XML stream to be read into a static buffer. While this example has the XML stream coded directly into the program, you could also place the XML into the buffer (mybuf) using any standard input.

Lines 0400 - 0440:

0400     open input doc
0410     read doc
0420     display "Document type is: " doc-type
0430     display "Tag name: " root-tag-name
0440     display "Tag value:" root-tag-val

Opens the buffer area, reads in the XML record, and displays the document type, the name of the root tag, and the value of the root tag.

Line 0450:

0450     start doc key root-tag-attr

Sets the starting point in the buffer to the first attribute for the root tag.

Lines 0500 - 0570:

0500     perform until exit
0510        read doc next key root-tag-attr
0520        if  doc-status not = 0
0530            exit perform
0540        end-if
0550        display "Attribute name : " root-tag-attr-name
0560        display "Attribute value: " root-tag-attr-val
0570     end-perform

Loops through information in the root tag, reading each attribute for the root tag and displaying the attribute names and values.

Line 0600:

0600     start doc key sub-tag

Sets the starting point in the buffer to the first nested tag (non-root tag).

Lines 0610 - 0810:

0610     perform until exit
0620        read doc
0630          next key sub-tag *> index is 1 is default
0640        if  doc-status not = 0
0650            exit perform
0660        end-if
0670        display " Sub tag name: " sub-tag-name
0680        display " Sub tag value:" sub-tag-val
0690
0700        start doc key sub-tag-attr index is 1
0710        perform until exit
0720            read doc next key sub-tag-attr
0730            if  doc-status not = 0
0740                exit perform
0750            end-if
0760            display " Sub tag attribute name : "
0770              sub-tag-attr-name
0780            display " Sub tag attribute value: "
0790              sub-tag-attr-val
0800        end-perform
0810    end-perform

Loops through all non-root tags, displaying each XML tag name and value, and all its attribute names and values.

Parent topic: Syntax for Handling XML in COBOL
Related reference
XML Syntax - IDENTIFIED BY Clause
Related information
COUNT IN Clause


PROCESSING-INSTRUCTION Clause

The PROCESSING-INSTRUCTION clause is provided simply to allow XML processing instructions to be embedded directly within the data associated with a tag. For example, the following code:

    01  my-tag    identified by "my_tag".
        05  my-tag-data1    pic x(80).
        05  my-tag-pi       pic x(80)
            IS PROCESSING-INSTRUCTION.
        05  my-tag-data2    pic x(80).
    ...
        move 'data' to my-tag-data1 my-tag-data2
        move 'somepi' to my-tag-pi
        write my-tag

Would yield:

    <my_tag>data<?somepi?>data</my_tag>
Parent topic: Syntax for Handling XML in COBOL
Related reference
XML Syntax - PROCESSING-INSTRUCTION Clause


COUNT IN Clause

As shown in the section IDENTIFIED BY and IS ATTRIBUTE Clauses, it is possible to deal with unlimited multiple occurrences of known or unknown tag names through the use of various XML-extended verbs. In less complicated cases where the number of occurrences is known in advance, there are very simple syntax extensions that allow direct addressing.

You can deal with a known number of tag or attribute occurrences using the OCCURS and COUNT IN clauses. The number of acceptable occurrences of a tag or attribute is limited by the OCCURS clause. The COUNT IN clause enables you to determine the number of occurrences received or to specify the number to be sent.

The following example shows how to use the COUNT IN clause:

Using OCCURS and COUNT IN clauses

0010  $set preprocess(prexml) warn endp
0020  $set sourceformat(free) case
0030
0040  select library-file
0050        assign address of mybuf
0060        organization  is xml
0070        document-type is "library.xsd"
0080        file status is library-status.
0090
0100  data division.
0110
0120  xd library-file.
0130  01  library            identified by "library".
0140    05  book             identified by "book"
0150                           occurs 10 times
0160                           count in library-book-count.
0170        10  book-title  pic x(80) identified by "title".
0180        10  book-author pic x(80) identified by "author".
0190        10  book-toc              identified by "toc".
0200            15  book-toc-section  occurs 20 times
0210                              count in book-section-count
0220                              identified by "section"
0230                              pic x(20).
0240
0250  working-storage section.
0260  01  library-status  pic s999.
0270  01  mybuf.
0280      10  pic x(150) value
0290     '<library>'
0300     & '<book><title>book1</title>'
0310     &'       <toc><section>b1section1</section>'
0320     & '           <section>b1section2</section>'
0330     & '</toc></book>'.
0340      10 pic x(150) value
0350       '<book><title>book2</title>'
0360     & '      <toc><section>b2section1</section>'
0370     & '           <section>b2section2</section>'
0380     & '</toc></book>'
0390     & '</library>'.
0400
0410  open input library-file
0420  read library-file
0430  perform until library-book-count = 0
0440    display
0450     "Book title = '" book-title(library-book-count) "'"
0460    display "Number of Sects = "
0470     book-section-count(library-book-count)
0480     subtract 1 from library-book-count
0490  end-perform
0500  close library-file
0510  stop run.

Lines 0040 - 0080:

0040  select library-file
0050        assign address of mybuf
0060        organization  is xml
0070        document-type is "library.xsd"
0080        file status is library-status.

Assigns a filename and the buffer mybuf as the source of the XML input, specifies the organization of the file (XML) and provides a filename for the XML schema (library.xsd) and a data-name for the file status.

Lines 0120 - 0230:

0120  xd library-file.
0130  01  library            identified by "library".
0140    05  book             identified by "book"
0150                           occurs 10 times
0160                           count in library-book-count.
0170        10  book-title  pic x(80) identified by "title".
0180        10  book-author pic x(80) identified by "author".
0190        10  book-toc              identified by "toc".
0200            15  book-toc-section  occurs 20 times
0210                              count in book-section-count
0220                              identified by "section"
0230                              pic x(20).

Sets up the record structure of the buffer area. Notice the use of OCCURS and COUNT-IN. In this example, the book data-name is identified by the XML tag <book>, it occurs 10 times, and the occurrences are counted in the library-book-count field, which is defined implicitly. The book-toc-section data item is defined similarly, with book-section-count defined implicitly.

Lines 0270 - 0390:

0270  01  mybuf.
0280      10  pic x(150) value
0290     '<library>'
0300     & '<book><title>book1</title>'
0310     &'       <toc><section>b1section1</section>'
0320     & '           <section>b1section2</section>'
0330     & '</toc></book>'.
0340      10 pic x(150) value
0350       '<book><title>book2</title>'
0360     & '      <toc><section>b2section1</section>'
0370     & '           <section>b2section2</section>'
0380     & '</toc></book>'
0390     & '</library>'.

Codes the XML stream to be read in a static buffer. While this example has the XML stream coded directly into the program, you could also place the XML into the buffer (mybuf) using any standard input.

Lines 0430 - 0490:

0430  perform until library-book-count = 0
0440    display
0450     "Book title = '" book-title(library-book-count) "'"
0460    display "Number of Sects = "
0470     book-section-count(library-book-count)
0480     subtract 1 from library-book-count
0490  end-perform

Loops through all records, displaying all book titles and the number of sections contained in each. Notice that book-section-count uses library-book-count as an index.

The COUNT IN clause is also very useful to determine if the tag associated with an element definition was present in the XML stream. A very common use of this is determining which of a set of XD records is read during the execution of a READ statement. For example:

Using COUNT IN to determine which record has been read

0010  select book-or-author-file
0020        assign address of mybuf
0030        organization  is xml
0040        document-type is "bookdb.xsd"
0050        file status is xml-bookdb-status.
0060
0070  data division.
0080  xd book-or-author-file.
0090  01  book-rec        identified by "book"
0100                      count in book-count.
0110      05  price-val   pic 999.99 identified by "price"
0120                       is attribute
0130                       count in price-count.
0140      05  title-val   pic x(80) identified by "title".
0150
0160  01  author-rec      identified by "author"
0170                       count in author-count.
0180      05  author-val  pic x(80).
0190
0200  working-storage section.
0210  01  xml-bookdb-status  pic s999.
0220  01  mybuf  pic x(256) value
0230     '<book price="123.00"><title>A title</title></book>'.
0240
0250  procedure division.
0260     open input book-or-author-file
0270     read book-or-author-file
0280     evaluate true
0290     when book-count = 1
0300         if  price-count not = 0
0310             display "got <book price=" price-val ">
0320               <title>" title-val "</title></book>"
0330         else
0340             display "got <book><title>" title-val
0350               "</title></book>"
0360         end-if
0370     when author-count = 1
0380         display "got <author>" author-val "</author>"
0390     end-evaluate
0400     close book-or-author-file
0410     stop run.

Lines 0010 - 0050:

0010  select book-or-author-file
0020        assign address of mybuf
0030        organization  is xml
0040        document-type is "bookdb.xsd"
0050        file status is xml-bookdb-status.

Assigns a filename and the buffer mybuf as the source of the XML input, specifies the organization of the file (XML) and provides a filename for the XML schema (bookdb.xsd) and a data-name for the file status.

Lines 0080 - 0180:

0080  xd book-or-author-file.
0090  01  book-rec        identified by "book"
0100                      count in book-count.
0110      05  price-val   pic 999.99 identified by "price"
0120                       is attribute
0130                       count in price-count.
0140      05  title-val   pic x(80) identified by "title".
0150
0160  01  author-rec      identified by "author"
0170                       count in author-count.
0180      05  author-val  pic x(80).

Defines two 01 level items, one for a book record, and one for an author record. Later, the program uses the information defined by COUNT IN to determine which record is being read.

Lines 0220 - 0230:

0220  01  mybuf  pic x(256) value
0230     '<book price="123.00"><title>A title</title></book>'.

Codes the XML stream to be read in a static buffer. While this example has the XML stream coded directly into the program, you could also place the XML into the buffer (mybuf) using any standard input.

Lines 0260 - 0390:

0260     open input book-or-author-file
0270     read book-or-author-file
0280     evaluate true
0290     when book-count = 1
0300         if  price-count not = 0
0310             display "got <book price=" price-val ">
0320               <title>" title-val "</title></book>"
0330         else
0340             display "got <book><title>" title-val
0350               "</title></book>"
0360         end-if
0370     when author-count = 1
0380         display "got <author>" author-val "</author>"
0390     end-evaluate

The EVALUATE clause determines which record is being read based on the value of book-count or author-count.

Parent topic: Syntax for Handling XML in COBOL
Related reference
XML Syntax - COUNT IN Clause
Related information
IDENTIFIED BY and IS ATTRIBUTE Clauses


NAMESPACE Clause

XML documents often contain namespaces. The NAMESPACE clause enables you to set or identify those namespaces in your COBOL. Specify the NAMESPACE clause in a data description entry. The following example shows how to use the NAMESPACE clause:

Using NAMESPACE

0010  xd book-file.
0020  78  book-ns value "http://xml.microfocus.com/book.xsd".
0030  01  book                identified by "book"
0040                          namespace is book-ns.
0050      05  publisher pic x(80)
0060              identified by "name"
0070              namespace is
0080              "http://xml.microfocus.com/publisher.xsd".
0090
0100      05  author identified by "name"
0110                 namespace is
0120                 "http://xml.microfocus.com/author.xsd".
0130          10  author-first identified by "firstname"
0140                           pic x(80).
0150          10  author-last  identified by "lastname"
0160                           pic x(80).
0170      05  title            identified by "title"
0180                           pic x(80).

Line 0020:

0020  78  book-ns value "http://xml.microfocus.com/book.xsd".

Defines a namespace and its value.

Lines 0030 - 0040:

0030  01  book                identified by "book"
0040                          namespace is book-ns.

Defines a data record with a namespace equivalent to the value in book-ns.

Lines 0050 - 0080:

0050      05  publisher pic x(80)
0060              identified by "name"
0070              namespace is
0080              "http://xml.microfocus.com/publisher.xsd".

Sets a namespace to a fixed URI (Uniform Resource Identifier), which is a specific point of contact on the World Wide Web - in this case an XML schema file.

Lines 0100 - 0120:

0100      05  author identified by "name"
0110                 namespace is
0120                 "http://xml.microfocus.com/author.xsd".

Sets a namespace to a fixed URI.

Lines 0130 - 0160:

0130          10  author-first identified by "firstname"
0140                           pic x(80).
0150          10  author-last  identified by "lastname"
0160                           pic x(80).

Because these data items are in the author group, they take on the same namespace as author.

Lines 0170 - 0180:

0170      05  title            identified by "title"
0180                           pic x(80).

Title inherits the same namespace as book because it is in the book group but does not specify a namespace.

On input, both tags and namespaces must match those in the XML stream. On output, XML tags are qualified by the indicated namespace. The code in the example Using Namespace would yield an XML stream similar to:

<?xml version="1.0" encoding="utf-8" ?>
<book xmlns="http://xml.microfocus.com/book.xsd">
   <name xmlns="http://xml.microfocus.com/publisher.xsd">
      Just a publisher
   </name>
   <name xmlns="http://xml.microfocus.com/author.xsd">
      <firstname>AuthorFirstname</firstname>
      <lastname>AuthorFirstname</lastname>
   </name>
   <title>
      This is the title
   </title>
</book>

You can replace a specific NAMESPACE value with a data-name. This facilitates dynamic discovery of a namespace in XML. In this case, namespace matching is not performed on input. Instead, the namespace of the matching tag is populated into the data item specified by NAMESPACE. On output, the value of the namespace referenced by the data-name is used to qualify the output tag. The following record:

     xd generic-file.
     01  generic-tag identified by generic-tag-name
                     namespace is generic-tag-namespace.
         05  generic-tag-name           pic x(80).
         05  generic-tag-namespace      pic x(80).
         05  generic-tag-value          pic x(80).

and XML stream input:

   <name xmlns="http://xml.microfocus.com/publisher.xsd">
      Just a publisher
   </name>

yields the value of "name" for generic-tag-name, the value of "http://xml.microfocus.com/publisher.xsd" for generic-tag-namespace and the value of "Just a publisher" for generic-tag-value.

Parent topic: Syntax for Handling XML in COBOL
Related reference
XML Syntax - NAMESPACE clause


COBOL Verbs

The following familiar COBOL verbs have also been extended to handle XML:
  • START statement
  • OPEN statement
  • READ statement
  • WRITE statement
  • REWRITE statement
  • DELETE statement
  • CLOSE statement
Parent topic: Syntax for Handling XML in COBOL
Related reference
XML Syntax - CLOSE Statement
XML Syntax - DELETE Statement
XML Syntax - OPEN Statement
XML Syntax - READ Statement
XML Syntax - REWRITE Statement
XML Syntax - START Statement
XML Syntax - WRITE Statement


Compiling XML-enabled COBOL

To compile or build COBOL that has been XML-enabled using XML syntax extensions, the code must be preprocessed by the XML preprocessor in your COBOL development system. This is a necessary step that enables the Compiler to recognize the XML syntax you've coded into your program.

There are two ways you can compile or build XML-enabled COBOL.

  • Building XML-enabled COBOL from Studio Enterprise Edition
    This requires that you put additional code into your program that specifies use of the XML preprocessor.
  • Compiling XML-enabled COBOL from the Command Line
    This requires that you use command-line arguments that invoke the XML preprocessor before compiling the COBOL.
Parent topic: XML Syntax Extensions


Building XML-enabled COBOL from Studio Enterprise Edition

Before you build your XML-enabled COBOL, you must insert the following code on the first line of your program before the Identification Division:

$set {preprocess | p}(prexml) [{out | o} (outname)] [warn]
     [{preprocess | p} (ppname)] endp

where the parameters are:

{preprocess | p}
The pre-processor to be used.
{out | o} outname
The fully preprocessed output source file, outname. This output source file contains native COBOL processed from the XML syntax.
warn
Cause diagnostic warnings on parsing to be presented by PREXML.
ppname
The preprocessor name you want to use to read source files and process COPY statements. Preprocessors can be nested.

For example:

$set p(prexml) warn endp
Parent topic: Compiling XML-enabled COBOL


Compiling XML-enabled COBOL from the Command Line

If you have the $set statement coded into your program, then you compile from the command line just as you would a program that is not XML enabled. However, if you do not have the $set statement coded into your program, or you would like to override all of the parameters specified in your $set statement, specify a command line as follows:

cobol programname.cbl {preprocess | p}(prexml)
        [{out | o} (outname)]
        [warn]
        [{preprocess | p} (ppname)]
        endp

where programname is the file prefix of the COBOL program you are compiling, and the other parameters are the same as those used with the $set statement.

For example:

cobol foo.cbl p(prexml) warn o(foo.pp) endp
Parent topic: Compiling XML-enabled COBOL


Generating COBOL Structures with XML Syntax

  • CBL2XML Utility
  • Generating a Copybook and Schema
  • Generating XML-enhanced COBOL from an XML Schema
  • Mapping COBOL Data to XML Elements
  • Accessing an XML-enabled Record
  • Validate an XML Document
Parent topic: XML Input/Output
Related information
COBOL and XML
XML Syntax Extensions


CBL2XML Utility

You can use the cbl2xml utility to:

  • Generate COBOL records with XML syntax and a corresponding XML schema from an existing COBOL record
  • Generate COBOL records with XML syntax based on an existing XML schema
  • Validate XML schemas and instance documents

cbl2xml runs at a command prompt, reads a COBOL record, and generates several files. It is not case sensitive. Use the following command-line syntax:

cbl2xml filename
        [-c cpyBook]
        [-x schemaFile]
        [-m mapFile]
        [-p prefix]
        [-d directiveFile]
        [-v validationFile]
        [-noprompt]
        [-nocountin]

Where the parameters are:

filename The input file for cbl2xml.
  • When converting traditional COBOL data structures to COBOL with XML syntax, this is the filename of a COBOL file being read by cbl2xml. It can be a program with the file extension .cbl, or a copybook with the file extension .cpy.
  • When converting an XML schema to COBOL with XML syntax, this is the filename of an XML schema file being read by cbl2xml. Schema files usually have an .xsd file extension.
cpyBook | The filename of a COBOL copybook (.cpy file). cbl2xml generates this file to contain COBOL with XML syntax extensions. If you do not specify this parameter, cbl2xml names the generated file using the name of the COBOL or copybook with -cbl2xml appended to it. For example, if you specify a COBOL program file named account.cbl, the default filename for the copybook containing XML syntax extensions created by cbl2xml is account-cbl2xml.cpy.
schemaFile | The filename of a schema file to be created. If you do not specify this parameter, cbl2xml names the schema file the same as the COBOL file, but with an .xsd extension. For example, if you specify a COBOL program file named account.cbl, the default filename for the schema created by cbl2xml is account.xsd.
mapFile The filename of a map file to be created, or the name of an existing map file. The following rules apply:
  • If the map file you specify does not exist, cbl2xml creates a map file based on the information in the specified COBOL file.
  • If the map file you specify does exist, cbl2xml first asks if you want to overwrite it. If you anwer no, it applies the information in the map file to the generated COBOL file. If you answer yes, cbl2xml generates a new map file overwriting the previous contents of that file.

For more information on map files, see the section Mapping COBOL Data to XML Elements.

prefix Specify a prefix to prepend to generated data names. Use this parameter to create data records that are structured the same as the data records in your COBOL file, but that have different data names. This is useful when you want to keep the original data records intact and supply alternative data names for XML use.

The prefix takes the form of a character string. For example, if you specify -p xml-, cbl2xml prepends xml- to the beginning of each data name it generates.

directiveFile If you normally use a Compiler directive file to compile the COBOL program or copybook you are XML-enabling, specify that directive file each time you use cbl2xml.

For more information on directive files, see the topic Compiler Directives.

validationFile The filename of an XML schema or instance document you want to validate. The following rules apply:
  • If you specify a schema, cbl2xml validates that schema based on W3C XML conventions specified at http://www.w3.org/2001/XMLSchema, that is, it validates that the schema itself is a valid schema.
  • If you specify an XML instance document, cbl2xml validates that document against the XML schema specified in the document.
-noprompt Specify this argument when you want cbl2xml to overwrite existing files automatically.
CAUTION:
-noprompt overwrites all files generated by cbl2xml, including map files you have edited, and schema files supplied by third parties. Do not use this parameter unless you are sure you want to overwrite these.
-nocountin | Specify this argument to prevent the generation of COUNT IN clauses for generated COBOL data items. This option overrides any values specified in a CBL2XML mapping file.
Parent topic: Generating COBOL Structures with XML Syntax
Related reference
Compiler Directives
Related information
Mapping COBOL Data to XML Elements


Generating a Copybook and Schema

You can generate a copybook with XML syntax extensions and an XML schema from an existing copybook or COBOL program. You can use the generated copybook to XML-enable your COBOL program. You can use the generated schema to create an XML document that conforms to the schema and contains data, and use that document as input to your COBOL. Use the following command-line format for cbl2xml to generate the copybook and the schema:

cbl2xml filename
        [-c cobolFile]
        [-x schemaFile]
        [-d directiveFile]
        [-nocountin]

To enable your COBOL program to access XML information that conforms to the schema generated, cbl2xml generates a new record in a separate copybook. This new record contains the XML syntax extensions necessary for XML operation. The following example assumes that you have not specified the -c or -x parameters:

Generated copybook with XML syntax extensions

cbl2xml takes the following copybook record contained in the file record.cpy:

01 A-FILE-RECORD.
   05 A-FILE-ITEM PIC XX.

and generates the following XML-enhanced copybook, filename record-cbl2xml.cpy:

01 a-file-record identified by "a-file-record"
   count in a-file-record-count.
   02 a-file-item pic X(2) identified by "a-file-item"
      count in a-file-item-count.

For detailed information on XML syntax extensions, see the topic XML Syntax Extensions.

To XML-enable your program, you need to either rename record-cbl2xml.cpy to record.cpy, or replace the original record in record.cpy with the record in record-cbl2xml.cpy.

The process of XML-enabling an entire COBOL program is the same as that of XML-enabling a copybook. In this case, cbl2xml generates a schema and program that contain equivalent information for each record found in the program.

The schema produced by running cbl2xml on record.cpy, record.xsd, is as follows:

Generated XML schema from a COBOL file definition

<schema xmlns="http://www.w3.org/2001/XMLSchema"
   elementFormDefault="qualified">
   <element name="a-file-record">
      <complexType>
         <sequence>
            <element name="a-file-item">
               <simpleType>
                  <restriction base="string">
                     <length value="2"/>
                  </restriction>
               </simpleType>
            </element>
         </sequence>
      </complexType>
   </element>
</schema>

The following table explains the purpose of each schema tag in the context of the record it represents:

Schema Tag Description
<element name="a-file-record">
 This defines the group-level data name A-FILE-RECORD. It serves as the parent element to all elements that define data items contained in the group.
<complexType>
 This indicates that the group record has one or more subordinate data items.
<sequence>
 This indicates the beginning of the sequence of tags that defines the subordinate record.
<element name="a-file-item">
 This defines the data name of the subordinate data item A-FILE-ITEM. We know it is subordinate because this element tag is a child to a parent element tag.
<simpleType>
 This indicates that the data item has no subordinate data items.
<restriction base="string">
 This defines any restrictions on the data. In this case, the data must be a string, as indicated by the PIC XX clause in the COBOL data record.
<length value="2"/>
 This defines the length of the record, which in this case is 2, as defined by the PIC XX in the COBOL data record.
Parent topic: Generating COBOL Structures with XML Syntax
Related information
XML Syntax Extensions


Generating XML-enhanced COBOL from an XML Schema

The schema produced by cbl2xml using the format described in Generating a Copybook and Schema conforms to your existing COBOL record, and contains element names derived from your COBOL record. In practical application, a schema of this sort is limited because to exchange XML information with another party, you must use element names recognized by the other party. For example, many industries publish industry-standard schemas, which contain a specific set of elements used to exchange information throughout the industry. To generate COBOL records that contain XML syntax extensions that conform to a third-party schema, use the following cbl2xml format:

cbl2xml XMLschema
                 [-c cobolFile]
                 [-d directiveFile]
                 [-prompt | -noprompt]

In this example, we use a fictional industry-standard schema named widgets.xsd. This schema enables companies to exchange ordering information for the Widget product. The contents of widgets.xsd is as follows:

Industry-standard XML schema for "widgets"

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
 elementFormDefault="qualified">
    <xsd:element name="Availability" type="xsd:string"/>
    <xsd:element name="Base_Price" type="xsd:string"/>
    <xsd:element name="Base_Price_And_Unit">
        <xsd:complexType>
            <xsd:sequence>
                <xsd:element ref="Base_Price"/>
                <xsd:element ref="Unit"/>
            </xsd:sequence>
        </xsd:complexType>
    </xsd:element>
    <xsd:element name="Catalogue_Id" type="xsd:int"/>
    <xsd:element name="widgets">
        <xsd:complexType>
            <xsd:sequence>
                <xsd:element ref="Product_Id" minOccurs="0"/>
                <xsd:element ref="Company_Id"/>
                <xsd:element ref="Catalogue_Id"/>
                <xsd:element ref="SKU"/>
                <xsd:element ref="Product_Series" minOccurs="0"/>
                <xsd:element ref="Availability"/>
                <xsd:element ref="Sale"/>
                <xsd:element ref="Base_Price_And_Unit"/>
            </xsd:sequence>
        </xsd:complexType>
    </xsd:element>
    <xsd:element name="Company_Id" type="xsd:int"/>
    <xsd:element name="Product_Id" type="xsd:int"/>
    <xsd:element name="Product_Series" type="xsd:string"/>
    <xsd:element name="SKU" type="xsd:string"/>
    <xsd:element name="Sale" type="xsd:string"/>
    <xsd:element name="Unit" type="xsd:string"/>
</xsd:schema>

CBL2XML reads this schema and generates a copybook, widgets.cpy, as follows:

XML-enabled COBOL generated from widgets.cpy

       01 Widgets identified by "Widgets".
        02 Product-Id PIC X(80) identified by "Product_Id"
           count in Product-Id-count.
        02 Company-Id PIC X(80) identified by "Company_Id"
           count in Company-Id-count.
        02 Catalogue-Id PIC X(80) identified by "Catalogue_Id"
           count in Catalogue-Id-count.
        02 SKU PIC X(80) identified by "SKU" count in SKU-count.
        02 Product-Series PIC X(80)
            identified by "Product_Series"
            count in Product-Series-count.
        02 Availability PIC X(80) identified by "Availability"
           count in Availability-count.
        02 Sale PIC X(80) identified by "Sale"
           count in Sale-count.
        02 Base-Price-And-Unit
           identified by "Base_Price_And_Unit"
           count in Base-Price-And-Unit-count.
         03 Base-Price PIC X(80)
            identified by "Base_Price"
            count in Base-Price-count.
         03 Unit PIC X(80)

            identified by "Unit"
            count in Unit-count.

You can then include this copybook in a COBOL program you want to use to send and receive information about widgets.

Parent topic: Generating COBOL Structures with XML Syntax
Related information
Mapping COBOL Data to XML Elements


Mapping COBOL Data to XML Elements

The example shown in the topic Generating XML-enhanced COBOL from an XML Schema generates COBOL data records based on the element names found in the schema. However, you might have an existing COBOL record you want to use specifically to communicate with a third-party schema. To do this, you must create a direct relationship between a COBOL record and the elements of the schema by means of a map file.

Use this format to generate a map file that you can customize.

cbl2xml filename -m mapFile

The process of XML-enabling an application to exchange information with XML documents based on an existing COBOL record and an existing schema is as follows:

  1. Generate a map file using cbl2xml. To produce a new map file, specify a map filename that does not exist. When cbl2xml does not find an existing map file with the name you specify, it generates a new file.
  2. Edit the map file, changing the names of generated elements to element names that exist in the schema you want to use for data exchange.
  3. Rerun cbl2xml using the same format you used in step 1 of this process. However, this time specify the existing, edited map file. When cbl2xml does find a map file of the name you specified, it applies the mappings in the file to the COBOL record.

The remainder of this section explains the details of this process.

If the mapfile you specify does not exist, cbl2xml takes data structures from the COBOL file, translates them into XML, and writes that information into the map file.

For example:

COBOL record and XML schema communication

Product_info.cpy contains the following record:

       01  PRODUCT-INFO.
           05 PROD-ID     PIC 9(6).
           05 COMPANY-ID  PIC 9(4).
           05 CATALOG-NUM PIC 9(8).
           05 SKU-REF     PIC X(10).

The following is the element definition from widget.xsd with which you want to communicate:

    <xsd:element name="Widgets">
        <xsd:complexType>
            <xsd:sequence>
                <xsd:element ref="Product_Id" minOccurs="0"/>
                <xsd:element ref="Company_Id"/>
                <xsd:element ref="Catalogue_Id"/>
                <xsd:element ref="SKU"/>
                <xsd:element ref="Product_Series" minOccurs="0"/>
                <xsd:element ref="Availability"/>
                <xsd:element ref="Sale"/>
                <xsd:element ref="Base_Price_And_Unit"/>
            </xsd:sequence>
        </xsd:complexType>
    </xsd:element>

Cbl2xml generates the following map file from product_info.cpy:

Generated map file

<xml-cobol-mapping-file
   xmlns="http://xml.microfocus.com/schema/xml/v1.0/mfxmlmap.xsd"
   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
   xsi:schemaLocation=
    "http://xml.microfocus.com/schema/xml/v1.0/mfxmlmap.xsd
    mfxmlmap.xsd">
   <xml-cobol-mapping>
      <cobol-name>product-info</cobol-name>
      <cobol-count-in>true</cobol-count-in>
      <xml-name>product-info</xml-name>
      <xml-type>group</xml-type>
      <xml-attribute>false</xml-attribute>
      <xml-namespace></xml-namespace>
   </xml-cobol-mapping>
   <xml-cobol-mapping>
      <cobol-name>product-info.prod-id</cobol-name>
      <cobol-count-in>true</cobol-count-in>
      <xml-name>prod-id</xml-name>
      <xml-type>string</xml-type>
      <xml-attribute>false</xml-attribute>
      <xml-namespace></xml-namespace>
   </xml-cobol-mapping>
   <xml-cobol-mapping>
      <cobol-name>product-info.company-id</cobol-name>
      <cobol-count-in>true</cobol-count-in>
      <xml-name>company-id</xml-name>
      <xml-type>string</xml-type>
      <xml-attribute>false</xml-attribute>
      <xml-namespace></xml-namespace>
   </xml-cobol-mapping>
   <xml-cobol-mapping>
      <cobol-name>product-info.catalog-num</cobol-name>
      <cobol-count-in>true</cobol-count-in>
      <xml-name>catalog-num</xml-name>
      <xml-type>string</xml-type>
      <xml-attribute>false</xml-attribute>
      <xml-namespace></xml-namespace>
   </xml-cobol-mapping>
   <xml-cobol-mapping>
      <cobol-name>product-info.sku-ref</cobol-name>
      <cobol-count-in>true</cobol-count-in>
      <xml-name>sku-ref</xml-name>
      <xml-type>string</xml-type>
      <xml-attribute>false</xml-attribute>
      <xml-namespace></xml-namespace>
   </xml-cobol-mapping>
</xml-cobol-mapping-file>

The map file is an XML document. The tags generated by cbl2xml contain specific information about the COBOL record as follows:

Map file tag name | Meaning
<xml-cobol-mapping-file> | Indicates that this is a mapping file to be used to create XML structure in a COBOL program. It is the root element of the map file.
<xml-cobol-mapping> | Contains information for one COBOL data item. It is the parent element to <cobol-name>, <xml-name>, <xml-type>, <xml-attribute>, and <xml-namespace>.
<cobol-name> | Contains the name of a data item from a COBOL record, including the parent name of the data item. The parent name comes first, followed by the data item name, separated by a period (.). For example: a-file-record.a-file-item.
<cobol-count-in> | Specifies whether or not the COBOL XML COUNT IN clause is generated for the COBOL item in <cobol-name>. Acceptable values are “true” and “false”. The default value is “true.” This value is ignored when the –nocountin command-line option is used.
<xml-name> | Specifies an equivalent XML element name to be used to correspond to the record named in <cobol-name>.
<xml-type> | The XML simple type that the COBOL item is being mapped to. This parameter is applicable only when a COBOL data item has a PIC clause.
<xml-attribute> | Specifies whether or not the element specified in <xml-name> is to be treated as an attribute in the XML schema. Values are “true” or “false.”
<xml-namespace> | An optional element that specifies the XML namespace for the element specified in <xml-name>. A namespace specified at a group level is inherited automatically by child elements.

You can then create user-defined mappings by editing the map file and matching the XML element names found in the schema to the COBOL names found in your COBOL record. To do this, change the <xml-name>s in the map file to match the element names in the schema. In this example, you would edit the <xml-name>s in the map file shown in example Generated Map File as follows:

Change... | To...
<xml-name>product-info</xml-name> | <xml-name>Widgets</xml-name>
<xml-name>prod-id</xml-name> | <xml-name>Product_Id</xml-name>
<xml-name>company-id</xml-name> | <xml-name>Company_Id</xml-name>
<xml-name>catalog-num</xml-name> | <xml-name>Catalogue_Id</xml-name>
<xml-name>sku-ref</xml-name> | <xml-name>SKU</xml-name>

At this point, run cbl2xml again, specifying the edited map file, and cbl2xml produces a schema and a copybook. The schema will be similar to your existing schema, depending on how much of that existing schema you edited into your map file. You do not need to use this schema; it is created by default and is not critical. The copybook contains your original COBOL record with the appropriate XML syntax extensions appended to it, based on the information found in the map file. In this example, cbl2xml generates the following copybook:

        01 product-info identified by "Widgets"
           count in widgets-count.
         02 prod-id pic 9(6) identified by "Product_Id"
            count in Product_Id-count.
         02 company-id pic 9(4) identified by "Company_Id"
            count in Company_Id-count.
         02 catalog-num pic 9(8) identified by "Catalogue_Id"
            count in Catalogue_Id-count.
         02 sku-ref pic X(10) identified by "SKU"
            count in SKU-count.

Paste this new record into your COBOL program, replacing the original record. Your COBOL record is now XML-enabled to communicate with XML documents that conform to the widgets.xsd schema.

Parent topic: Generating COBOL Structures with XML Syntax
Related information
Generating XML-enhanced COBOL from an XML Schema
CBL2XML Utility


Accessing an XML-enabled Record

Once you have an XML-enabled record, you'll need to access it from the Procedure Division of your program. You can use existing COBOL verbs to do this and the XML-enhanced syntax for these verbs. See the topic XML Syntax Extensions for more information.

The following is a sample program with a Procedure Division that writes the contents of the widgets.xml file:

Sample COBOL program using XML

        $set p(prexml) endp
        select xml-stream assign "widgets.xml"
                          organization is xml
                          document-type is "widgets.xsd"
                          file status is file-status-spec.

        xd xml-stream.
           copy "widgets.cpy".

        data division.
        working-storage section.
        01 file-status-spec PIC S9(9).

        procedure division.
          open output xml-stream
          write widgets
          display file-status-spec
          close xml-stream
        stop run.
Parent topic: Generating COBOL Structures with XML Syntax
Related information
XML Syntax Extensions


Validate an XML Document

You can use cbl2xml to validate an XML schema (.xsd file) or instance document (.xml file) to determine if it is well formed. In the case of an instance document, cbl2xml checks the contents of the document against the schema referenced by the document. Use the following syntax:

cbl2xml -v filename

where filename is a schema file or an XML instance document file.

Parent topic: Generating COBOL Structures with XML Syntax


Creating 64-bit Native COBOL Programs

You can create a 64-bit native COBOL program from scratch, or convert an existing 32-bit native program.
Restriction: The following applies to native COBOL only.

For information about managed COBOL applications running on a 64-bit platform, see 64-Bit Applications in the .NET Environment.

  • Overview of Creating 64-bit Native COBOL Programs
  • Creating 64-bit Programs from 32-bit Native COBOL Programs
  • Compiling Native COBOL Programs for 64-Bit
  • Pointers and Compiling Native COBOL Programs for 64-Bit
  • Single Sourcing and Compiling Native COBOL Programs for 64-Bit
  • Library Routine Prototypes and Compiling Native COBOL Programs for 64-Bit
  • File and FCD Handling and 64-bit Native COBOL Programs
  • Single Sourcing and Dual FCD Support in 64-Bit Native COBOL Programs
Parent topic: COBOL Programming


Overview of Creating 64-bit Native COBOL Programs

Restriction: The following information applies to native COBOL only.

This COBOL system includes both 32-bit and a 64-bit versions of both the development and run time systems. This enables you to create new 64-bit native COBOL programs, or to convert existing 32-bit native programs.

64-bit COBOL programs are restricted to 32-bit sizes, but have 64-bit pointers. Therefore, COBOL elements such as Data Division sizes, offsets, Procedure Divisions, and so on, are restricted to 32-bits; however, these elements are addressed with 64-bit pointers.

The COBOL system works in 32-bit mode, but is configured in a 64-bit environment to enable it to work with 64-bit programs.

Restriction: You cannot port executable code between 32-bit and 64-bit development systems.
Parent topic: Creating 64-bit Native COBOL Programs
Related information
Creating 64-bit Programs from 32-bit Native COBOL Programs
Compiling Native COBOL Programs for 64-Bit
Pointers and Compiling Native COBOL Programs for 64-Bit
Single Sourcing and Compiling Native COBOL Programs for 64-Bit
Library Routine Prototypes and Compiling Native COBOL Programs for 64-Bit
File and FCD Handling and 64-bit Native COBOL Programs
Single Sourcing and Dual FCD Support in 64-Bit Native COBOL Programs


Creating 64-bit Programs from 32-bit Native COBOL Programs

Restriction: The following information applies to native COBOL only.

In general, you can take a 32-bit program, recompile it with the P64 Compiler directive set, and it should run without problem as a 64-bit application. There are, however, certain circumstances in which the conversion of your program won't be as simple as this:

If your program uses pointers
You need to ensure that pointers are not redefined or modified by reference. There should also be no assumptions in your record definitions about the sizes of pointers.
If your program uses a File Control Description (FCD) block that has been directly coded
The program will have to be modified to use the 64-bit FCD3 format if the 32-bit program was using the older FCD2 format. 64-bit programs need an FCD control block that has a different format to that used by older 32-bit applications.
Parent topic: Creating 64-bit Native COBOL Programs
Related information
Overview of Creating 64-bit Native COBOL Programs
Compiling Native COBOL Programs for 64-Bit
Pointers and Compiling Native COBOL Programs for 64-Bit
Single Sourcing and Compiling Native COBOL Programs for 64-Bit
Library Routine Prototypes and Compiling Native COBOL Programs for 64-Bit
File and FCD Handling and 64-bit Native COBOL Programs
Single Sourcing and Dual FCD Support in 64-Bit Native COBOL Programs


Compiling Native COBOL Programs for 64-Bit

Restriction: The following information applies to native COBOL only.

The Compiler directive P64 enables you to create a program that can be run on Server Enterprise Edition in 64-bit mode. If you do not use the P64 directive when you compile your program, the program can only be run on Server Enterprise Edition in 32-bit mode. Therefore, if you have developed an application on a 32-bit development system, you must recompile it with the P64 directive set, if you want to migrate it using Server Enterprise Edition in 64-bit mode.

The P64 directive is set by default if you check the 64-bit check box in the Build Settings dialog box.

Parent topic: Creating 64-bit Native COBOL Programs
Related information
Overview of Creating 64-bit Native COBOL Programs
Creating 64-bit Programs from 32-bit Native COBOL Programs
Pointers and Compiling Native COBOL Programs for 64-Bit
Single Sourcing and Compiling Native COBOL Programs for 64-Bit
Library Routine Prototypes and Compiling Native COBOL Programs for 64-Bit
File and FCD Handling and 64-bit Native COBOL Programs
Single Sourcing and Dual FCD Support in 64-Bit Native COBOL Programs


Pointers and Compiling Native COBOL Programs for 64-Bit

Restriction: The following information applies to native COBOL only.

If you compile a program using the P64 Compiler directive (referred to in the rest of this chapter as "64-bit programs") the data-type POINTER is a different size to that in programs compiled without the P64 directive (referred to in the rest of this section as "32-bit programs").

Parent topic: Creating 64-bit Native COBOL Programs
Related information
Overview of Creating 64-bit Native COBOL Programs
Creating 64-bit Programs from 32-bit Native COBOL Programs
Compiling Native COBOL Programs for 64-Bit
Single Sourcing and Compiling Native COBOL Programs for 64-Bit
Library Routine Prototypes and Compiling Native COBOL Programs for 64-Bit
File and FCD Handling and 64-bit Native COBOL Programs
Single Sourcing and Dual FCD Support in 64-Bit Native COBOL Programs


Single Sourcing and Compiling Native COBOL Programs for 64-Bit

Restriction: The following information applies to native COBOL only.

To aid migration and application development, the $IF statement has been extended to enable you to find out which Compiler directives have been set when your program is compiled. In particular, you can use $IF...SET to determine whether the P64 Compiler directive has been set. For details on the $IF ... SET statement, see your Language Reference.

Parent topic: Creating 64-bit Native COBOL Programs
Related information
Overview of Creating 64-bit Native COBOL Programs
Creating 64-bit Programs from 32-bit Native COBOL Programs
Compiling Native COBOL Programs for 64-Bit
Pointers and Compiling Native COBOL Programs for 64-Bit
Library Routine Prototypes and Compiling Native COBOL Programs for 64-Bit
File and FCD Handling and 64-bit Native COBOL Programs
Single Sourcing and Dual FCD Support in 64-Bit Native COBOL Programs
COBOL Language Reference


Library Routine Prototypes and Compiling Native COBOL Programs for 64-Bit

Restriction: The following information applies to native COBOL only.

Prototypes are provided for the COBOL library routines in this COBOL system. These help ensure that the library routines can run correctly in a 64-bit environment. Prototyping is an accepted way to ensure that the parameters provided to a library routine are correctly typed. See Using the Library Routine Type Definitions and Call Prototypes for information on how prototyping has been implemented for the library routines.

Parent topic: Creating 64-bit Native COBOL Programs
Related information
Overview of Creating 64-bit Native COBOL Programs
Creating 64-bit Programs from 32-bit Native COBOL Programs
Compiling Native COBOL Programs for 64-Bit
Pointers and Compiling Native COBOL Programs for 64-Bit
Single Sourcing and Compiling Native COBOL Programs for 64-Bit
File and FCD Handling and 64-bit Native COBOL Programs
Single Sourcing and Dual FCD Support in 64-Bit Native COBOL Programs
Using the Library Routine Type Definitions and Call Prototypes


File and FCD Handling and 64-bit Native COBOL Programs

Restriction: The following information applies to native COBOL only.

The File Control Description (FCD) is a data area which contains information about the file in use.

There are two different formats of the FCD that you can directly code in your application, FCD2 and FCD3 (FCD 1 is obsolete and should never be used in your applications).

These different FCD formats are supported on the following systems:
Platform | FCD 3 Format | FCD 2 Format
Net Express 5.0 64-bit | Y | N
Net Express 5.0 32-bit | Y | Y
Server Express 2.0 64-bit | Y | N
Server Express 2.0 32-bit | Y | Y
Server Express 1.1 32-bit | N | Y
Server Express 1.0 32-bit | N | Y
Net Express 3.0 and earlier versions | N | Y
OCDS | N | Y

FCD2 is not supported on 64-bit COBOL systems. This has the following effects on application conversion:

  • Applications that use FCD structures, either through explicit declaration and creation, or by using the syntax CALL program USING filename, have to be converted to handle FCD3 when compiled and run as a 64-bit application.
  • Applications that use the FCDREG directive need to be aware that various data-items including pointers and record sizes within the FCD have different sizes, and that reference modification of these fields results in different values on a 32-bit environment and a 64-bit one.
  • The copybook xfhfcd.cpy defines an FCD3 unless you specify the NOFCD3 directive. The FCD3 record is directly and unconditionally defined in the file xfhfcd3.cpy and the FCD2 record is directly and unconditionally defined in the file xfhfcd2.cpy.
Parent topic: Creating 64-bit Native COBOL Programs
Related information
Overview of Creating 64-bit Native COBOL Programs
Creating 64-bit Programs from 32-bit Native COBOL Programs
Compiling Native COBOL Programs for 64-Bit
Pointers and Compiling Native COBOL Programs for 64-Bit
Single Sourcing and Compiling Native COBOL Programs for 64-Bit
Library Routine Prototypes and Compiling Native COBOL Programs for 64-Bit
Single Sourcing and Dual FCD Support in 64-Bit Native COBOL Programs


Single Sourcing and Dual FCD Support in 64-Bit Native COBOL Programs

Restriction: The following information applies to native COBOL only.

All system components supplied with the 32-bit development system support FCD 2 and FCD 3. System components supplied with the 64-bit development system only support FCD 3; no system components can support FCD 2, due to the incompatibilities in pointer size. 32-bit and 64-bit system components are single sourced, meaning that the components work with FCD 3 on 64-bit systems if compiled with P64, or work with both FCD 2 and FCD 3 on 32-bit systems if compiled with NOP64. We recommend that you take this single-sourcing approach when developing your own applications.

Because the development system supports FCDs in both formats, your applications can use one of the following:

  • FCD 3 only. In this case, applications can be built on either a 32-bit or 64-bit development system, and shipped with either the 32-bit or 64-bit Server Enterprise Edition.
  • FCD 2 only. In this case, applications can be built only on the 32-bit development system, and shipped only with the 32-bit Server Enterprise Edition.

If you can solely use either FCD 3 or FCD 2 in your application, you need make no other provisions to handle the extended FCD structure.

However, some programs in your application might provide interfaces to other components in your application, and these interfaces might include FCD structures. In this case you might need to provide gradual transition to full FCD 3 support; at run time, therefore, your program will need to accept both FCD 2 and FCD 3 formats, and to distinguish them as necessary. For example, if there are few references to FCD fields within your code, the following source code model might be suitable:

 linkage section.
 01  fcd-user  pic x.
 01  fcd2.
  copy "xfhfcd2".
 01  fcd3.
  copy "xfhfcd3".
        procedure division using fcd-user.
     set address of fcd3  to address of fcd-user
     if  fcd-version of fcd3 = 0
         *> Dealing with FCD2..
$if P64 set
        display "Error: cannot accept FCD2 on 64 bit platform"
        exit program
$end
        set address of fcd2  to address of fcd-user
     end-if

Every time a field of the FCD is referenced you must add code that does something like the following:

    if  ( fcd-version of fcd3 not = 0
       and fcd--line-sequential of fcd3)
    or  ( not fcd-version of fcd3 = 0
       and fcd--line-sequential of fcd2 )
        *> Do line sequential manipulation
    end-if

If, however, the bulk of the code in your component directly references the FCD structure, you could internally use only the FCD 3 structure and, if necessary, establish mappings, to and from FCD 2 at entry and exit gateways to the component. For example:

 working-storage section.
 78  78-fcd3-map-to-fcd3         value 0.
 78  78-fcd3-map-from-fcd3       value 1.

 78  78-fcd3-map-error-none      value 0.
 78  78-fcd3-map-error-64bit     value -1.
 78  78-fcd3-map-error-func      value -2.
 78  78-fcd3-map-error-reladdr   value -3.
 01  fcd3-work.
     copy "xfhfcd3".
 linkage section.
 01  fcd-user            pic x.
 procedure division using fcd-user.
*> Entry Gate map FCD2 (if necessary) to FCD3
     call 'fcd3map' using fcd-user
                          fcd3-work
                          by value 78-fcd3-map-to-fcd3 size 1
     if  return-code not = 0
        display "Error: cannot convert FCD formats"
        exit program
     end-if

*> Operate on the FCD as FCD3 only
*> ....

*> Exit Gate map FCD3 (if necessary) to FCD2
     call 'fcd3map' using fcd-user
                          fcd3-work
                          by value 78-fcd3-map-from-fcd3 size 1
     exit program.
Parent topic: Creating 64-bit Native COBOL Programs
Related information
Overview of Creating 64-bit Native COBOL Programs
Creating 64-bit Programs from 32-bit Native COBOL Programs
Compiling Native COBOL Programs for 64-Bit
Pointers and Compiling Native COBOL Programs for 64-Bit
Single Sourcing and Compiling Native COBOL Programs for 64-Bit
Library Routine Prototypes and Compiling Native COBOL Programs for 64-Bit
File and FCD Handling and 64-bit Native COBOL Programs


Calling COBOL Programs

There are a variety of ways to call programs, each one being appropriate in a different situation.

  • Specifying the Program to Be Called
  • State of the Data when a Program is Called Again
  • Search Conventions Used for Calling Programs
  • Passing Parameters to a Called Program
  • Passing Return Codes Back to the Calling Program
  • Call Prototypes
Parent topic: COBOL Programming


Specifying the Program to Be Called

When you call one COBOL program from another, you specify the name of the program to call either in a data-name or as a literal. For example:

CALL progname USING ...
CALL "progname" USING ...

where progname (without quotation marks) is a data item that contains a valid program-name, and "progname" (with quotation marks) is a literal string and is the actual name of a valid program.

  • Naming a Program in its PROGRAM-ID Paragraph
  • Entry Point Mapping for COBOL Programs
  • .NET Entry Point Mapping
  • Calling programs from .NET COBOL projects
  • Calling Entry Points in Subprograms
  • Calling Programs According to How They Are Linked
Parent topic: Calling COBOL Programs
Related information
State of the Data when a Program is Called Again
Search Conventions Used for Calling Programs
Passing Parameters to a Called Program
Passing Return Codes Back to the Calling Program
Call Prototypes


Naming a Program in its PROGRAM-ID Paragraph

The CALL statement identifies the program to be called, by giving either the program's filename or the program's program-name. This program-name is defined in its PROGRAM-ID paragraph.

In general, make the program-name the same as the filename. In other words, in the program's PROGRAM-ID paragraph, specify the program's filename without its extension. This enables you to call the program using this common name, without knowing whether the name is the filename or the program name. This gives you the flexibility to change how the program is linked, and yet still call it successfully.

The CALL statement locates called programs differently depending on how they are linked:

  • A statically linked program can be located from its filename or its program name, because the program is loaded and its name and entry points are known. This means that the CALL statement can specify the program name or the filename of the called program.
  • A dynamically loadable program can be located only by its filename (with or without its extension), because the program name is not yet known as the program is not yet loaded into memory. This means that the CALL statement must quote the filename of the program to call.

    If you make the program name the same as the filename, you can quote that name in the CALL statement, and it will call the program whether it is statically and dynamically linked.

Parent topic: Specifying the Program to Be Called
Related information
Limits on Names, Literals and PICTURE Character Strings


Entry Point Mapping for COBOL Programs

The Entry Point Mapper enables you to specify entry points in COBOL programs so that the application can find them at run time. You need to do this for any entry points in programs that will not have been loaded prior to them being called.

To appreciate why and when to use this facility, you need to understand how calls to entry points are resolved by the run-time system:

  • When a program that is not statically linked makes a call to an entry point, the run-time system looks for the entry point to resolve it dynamically. In statically linked programs, the entry points are resolved during linking, and the Entry Point Mapper isn't needed.
  • When the program is loaded, the name of the program and all the entry points in the program are recorded in a table. When a call to an entry point is made, the run-time system searches the table for the entry point name. If it does not find the entry point name, it looks on disk for an executable file of the same name.
  • Consequently, if your program calls an entry point that is not the name of an executable file and is not an entry point in a previously loaded program, the run-time system cannot find the entry point and your program fails. This is when you need to use the Entry Point Mapper.

Entry points are often not found when you take code that has been downloaded from a mainframe to the PC for further development. Mainframe programs often have several entry points in a single program. On the mainframe, entry points are resolved by linking, so calls can be made to a program and the entry point located whether or not the program has been called. Using your COBOL development system, if the program containing the entry point has not already been called, the call to that entry point fails.

To ensure the entry points are found, you use the Entry Point Mapper. You create an entry name map file containing an entry point table and make it available to the run-time system.

Parent topic: Specifying the Program to Be Called


.NET Entry Point Mapping

The Entry Point Mapper is available for .NET managed COBOL. It supports the mfentmap.dat file and the ENTRYNAMEMAP and MFENTMAP environment variables to locate the file. In addition, the Entry Point Mapper can be configured through the application configuration file.

Parent topic: Specifying the Program to Be Called


Calling programs from .NET COBOL projects

Note: The following applies to .NET COBOL only.

If a program in your managed project is calling a program in another managed project you need to add a project or a file reference in the calling project to the project containing the program to be called. To do this:

  1. In Solution Explorer, select the calling project.
  2. Click Project > Project Properties.
  3. Click the References tab.
  4. Click Add.
  5. Choose Projects or Browse to add a project or a file reference.

Once this is done, you can use the classes and methods from the referenced project in the calling project.

For information on calling native code from a managed program see Interoperating with Unmanaged COBOL.

Parent topic: Specifying the Program to Be Called


Calling Entry Points in Subprograms

You can execute called programs from a specified entry point, rather than the start of the Procedure Division. You define entry points in programs that you call, using the ENTRY statement. You can then execute a called program starting at an entry point by specifying the entry point in the CALL statement.

When a program containing entry points is loaded into the run-time system, all the entry points in the program are identified to the run-time system and are available to be called by any program that is loaded later.

However, the run-time system cannot locate entry points in programs that are not already loaded. For example, when you execute a CALL statement like this:

CALL "abc" USING ...

the run-time system first looks for a program or entry point called abc in all of the programs that have already been loaded. If the run-time system does not find one, it then looks for a file on disk called abc.ext where .ext is an executable file format. If abc is the name of an entry point in an unloaded program, the run-time system cannot find it.

Therefore, before calling an entry point, either the entry point must be preloaded, or the program containing the entry point must be loaded.

You can preload entry points by creating a library file that contains any programs with entry points. When you call a library file, the run-time system does not load every program in the library file. Instead, the run-time system registers, for future reference, the existence of all programs and entry points contained in the called library file. Later when one of these programs is called, the run-time system notes that it is contained in the library file and loads it at that point.

Note: Entry points must have names that the system assembler and linker can accept; that is, they must contain only characters that are 0-9, A-Z, a-z, underscore, or hyphen.

Entry points are visible only when an assembly has been loaded. There are two solutions for this:

  • You can preload an assembly by calling the main program id.
  • For a managed application, you can add the assembly name to the interop/preload section of the application configuration file. The following example configuration file, for program a.exe, preloads the managed assembly b.dll:
    <?xml version="1.0" encoding="utf-8" ?>
<configuration>
 <configSections>
    <sectionGroup name="MicroFocus.COBOL.Application">
      <section name="Switches"
     type="System.Configuration.NameValueSectionHandler" />
      <section name="Environment"
     type="System.Configuration.NameValueSectionHandler" />
      <sectionGroup name="Interop">
        <section name="PreLoad"
     type="System.Configuration.NameValueSectionHandler" />
      </sectionGroup>
    </sectionGroup>
    <!--The following code declares a section group for
                            run-time configuration -->
    <sectionGroup name="MicroFocus.COBOL.Runtime">
     <section name="Tunables"
     type="System.Configuration.NameValueSectionHandler" />
     <section name="Switches"
     type="System.Configuration.NameValueSectionHandler" />
    </sectionGroup>
 </configSections>

 <MicroFocus.COBOL.Application>
    <Switches></Switches>
    <Environment></Environment>
    <Interop>
       <PreLoad>
         <add key="b.dll" value="managed" />
       </PreLoad>
    </Interop>
 </MicroFocus.COBOL.Application>
 <runtime>
     <assemblyBinding xmlns="urn:schemas-microsoft-om:asm.v1">
        <probing privatePath="bin"/>
     </assemblyBinding>
 </runtime>
</configuration>
Parent topic: Specifying the Program to Be Called


Calling Programs According to How They Are Linked

When you call one COBOL program from another, you specify the name of the program to call either in a data-name or as a literal. For example:

CALL program-name USING ...
CALL "program-name" USING ...

where program-name (without quotation marks) is a data item that contains a valid program-name, and "program-name" (with quotation marks) is a literal string and is the actual name of a valid program.

The called program can be statically or dynamically linked, where a statically linked program is an .exe file and a dynamically linked module is a .dll file.

Calling Statically or Dynamically Linked Programs

Use a CALL literal statement to call a statically or dynamically linked program directly. If the program is not already in memory, the dynamic loader tries to find a dynamically loadable version of the program. If the program cannot be found, an RTS error message is issued.

For statically linked programs, calls using literal strings are converted to subroutine calls which refer to external symbols. A routine is automatically created to define the symbol and to load the associated file if it is entered when the program runs.

Calling Dynamically Loadable Programs

Use either a CALL literal statement, or a CALL data-name statement, to call a dynamically loadable program, and make the dynamic loader run-time support module search for the called program.

If the file is not found, the run-time system tries to load a .dll file from PATH using the specified base-name.

Parent topic: Specifying the Program to Be Called


State of the Data when a Program is Called Again

When you call a program that has been called before and that has not been canceled, the data in the called program is in the same state as when it last exited. However, the data is reinitialized if:

  • The called program was canceled after it last ran
  • The called program has the INITIAL attribute in its PROGRAM-ID paragraph in the Identification Division.
Parent topic: Calling COBOL Programs
Related information
Specifying the Program to Be Called
Search Conventions Used for Calling Programs
Passing Parameters to a Called Program
Passing Return Codes Back to the Calling Program
Call Prototypes
L1 run-time switch


Search Conventions Used for Calling Programs

Restriction: This information is not applicable to .NET managed code.

When a program is called, the run-time system checks to see if the program has already been loaded or logically canceled. If the program is already available in memory, the run-time system passes control to it.

If the program is not available, the run-time system searches for it first in the current directory, then the directory containing the calling program, and then the directories set in the COBDIR environment variable.

The search sequence described here applies to executable files (programs). It does not apply to other file types, for example data files and COBOL source files. Also, you don't need to be concerned in this discussion if you have only one executable version of your program on disk.

The run-time system first looks in the current directory for the called program. If the called program is named explicitly, (its name and its extension are specified), the specific executable file is searched for. If the called program is named implicitly, (only its base name and not its extension is specified) the run-time system looks for executable files in the order:

  1. filename.dll filename.so
  2. filename

If the called program is not found in the current directory, the run-time system repeats the search in the calling program's directory, and then in each directory specified by COBDIR. If it reaches the last directory without finding an executable file, the run-time system issues a "program not found" error message.

This is the default behavior of the run-time system; you can change the search order using the Configure Application Environment dialog.

In the case of a library file, the run-time system opens it, and searches it for an executable name filename.ext where .ext is one of the other executable file types listed above (except .dll files).

Note: If the dollar sign ($) is the first character of a program name, and that program is dynamically linked, or dynamically loadable, the first element of the program name is checked for filename mapping. The first element of the program name consists of all the characters before the first backslash character (\). For example, if the source program contains the statement:
 CALL "$MYLIB\A"
the subprogram A is loaded from the path as defined by the MYLIB environment variable when the program is run.
Parent topic: Calling COBOL Programs
Related information
Specifying the Program to Be Called
State of the Data when a Program is Called Again
Passing Parameters to a Called Program
Passing Return Codes Back to the Calling Program
Call Prototypes


Passing Parameters to a Called Program

You pass parameters to a program by specifying them in the USING phrase of the CALL statement. For example:

CALL "program-name" USING parameter-1, ..., parameter-n

Similarly the called program specifies the parameters in the USING phrase of its Procedure Division header or its ENTRY statement. The parameters need not have the same names in the called and calling programs, but they must be in the same order. Each parameter must also be declared with the same data type and size in both the called and calling programs.

You can pass parameters in the following formats. You can pass the:

  • Address of a data item, using the USING BY REFERENCE or USING BY CONTENT phrase. Any changes that the called program makes to a parameter passed BY REFERENCE are reflected in the calling program, whereas any changes made to a parameter passed BY CONTENT are not reflected in the called program.

    For example, the following statement passes the address of parameter-1:

    CALL "program-name" USING BY CONTENT parameter-1
  • Value of a data item, using the USING BY VALUE phrase. Any changes made to the parameter in the called program are not reflected in the calling program.

    Each binary computational item (COMP, BINARY, COMP-4, COMP-5, and COMP-X) is passed as a COMP-5 data item. That is, it appears in machine-order as a data item and not as a pointer to that data item. The size of the COMP-5 item depends on whether the SIZE qualifier of the USING BY VALUE phrase is used. If it is, the size of the COMP-5 data item is either is four or eight bytes depending on the size of the original item. If the SIZE qualifier is not specified, the default size of 4 bytes is used.

    Floating point and decimal computational items (COMP-1, COMP-2, COMP-3 and PACKED DECIMAL) are copied intact to the stack without any conversion.

    For example, the following statement passes a two-byte value of 5:

    CALL "program-name" USING BY VALUE 5 SIZE 2.

The total size of all the parameters passed must not exceed 1020 bytes, where each BY REFERENCE and BY CONTENT parameter occupies 4 bytes.

Parent topic: Calling COBOL Programs
Related information
Specifying the Program to Be Called
State of the Data when a Program is Called Again
Search Conventions Used for Calling Programs
Passing Return Codes Back to the Calling Program
Call Prototypes


Passing Return Codes Back to the Calling Program

There are two methods for passing return codes back from the called program to the calling program. You can use the:

  • RETURN-CODE special register. The called program puts a value in the RETURN-CODE register before passing control back to the calling program with an EXIT PROGRAM or GOBACK statement. The RETURN-CODE register of the calling program is then automatically updated with the called program's return code and this register can be examined accordingly. The RETURN-CODE register is predefined as PIC S9(9) COMP; this can be changed using the RTNCODE-SIZE Compiler directive.
  • RETURNING or GIVING phrase. The preferred, and more flexible, way of handling return codes is to use the RETURNING or GIVING phrase of the CALL, EXIT PROGRAM, GOBACK, and STOP RUN statements. This phrase enables you to define the format of the return code yourself and so cope with whatever size of return code you require.

Note that, the operating system limits the return value to two bytes, if you use the IF ERRORLEVEL syntax to check the return value.

Parent topic: Calling COBOL Programs
Related information
Specifying the Program to Be Called
State of the Data when a Program is Called Again
Search Conventions Used for Calling Programs
Passing Parameters to a Called Program
Call Prototypes
Passing Return Codes Back to the Calling Program
Handling Return Codes in Mixed Language Applications
RTNCODE-SIZE
The PROCEDURE DIVISION Header
The CALL Statement
The ENTRY Statement
The EXIT Statement
The GOBACK Statement
The INVOKE Statement
The START Statement
The STOP Statement
The WAIT Statement
The ADD Statement
The DIVIDE Statement
The MERGE Statement
The MULTIPLY Statement
The SORT Statement
The SUBTRACT Statement
The USE Statement


Call Prototypes

  • About Call Prototypes
    Call prototypes are a relatively new feature of the COBOL language. Prototypes enable each CALL statement to be checked for correctness when the program is compiled.
  • The ANY Keyword
  • Relaxed Type-checking
  • Using Type Definitions
  • Using the Library Routine Type Definitions and Call Prototypes
Parent topic: Calling COBOL Programs
Related information
Specifying the Program to Be Called
State of the Data when a Program is Called Again
Search Conventions Used for Calling Programs
Passing Parameters to a Called Program
Passing Return Codes Back to the Calling Program


About Call Prototypes

Call prototypes are a relatively new feature of the COBOL language. Prototypes enable each CALL statement to be checked for correctness when the program is compiled.

Prototypes can help you write multi-program applications that function as you expect. For information on the CALL statement syntax see your Language Reference

When a COBOL program calls another program there is no validation of the type or the number of parameters provided in the CALL statement. If there is a mismatch between the parameter types provided on the CALL statement's USING clause and those of the called program's Linkage Section as referenced in the USING clause of the Procedure Division, then it is likely that either an application error or a run-time system error will occur.

For example, if you have the following program Mymain:

program-id. MYMAIN.
 working-storage section.
  01  .
     05 myhandle         pic x(4).
     05 othervalue       pic x(4) value "6x3b".
 procedure division.
     call 'MYROUTINE'   using myhandle
     display "Othervalue is " othervalue.

and the subprogram Myroutine:

program-id. MYROUTINE.
  linkage section.
  01  myhandle            usage pointer.
  procedure division using myhandle.
      set myhandle        to null
      exit program.

the program and its subprogram would work as you expected if compiled and run on a 32-bit system (where pointers are 4 bytes long), but would corrupt the value othervalue on a 64-bit system (where pointers are 8 bytes long).

You could be informed about this kind of problem when you compiled the programs, if the compiler had access to the data types expected by the called program Myroutine when it compiled the program Mymain. Call prototypes provide this information about called programs, and enable the compiler to check for semantic consistency between the parameters in both the calling program, and in the called subprogram.

A call prototype can be regarded as a cut-down version or model of the code of the called program. The prototype contains:

  • A full Linkage Section
  • A full PROCEDURE DIVISION header and/or ENTRY statements, and all associated USING parameters. These USING parameters should be defined in the Linkage Section.

No code is required in the Procedure Division.

A call prototype is identified by the use of the IS EXTERNAL clause in the Program-ID paragraph.

If you were to code the calling program above (Mymain) as follows:

  program-id. MYROUTINE is EXTERNAL.
  linkage section.
  01  myhandle            usage pointer.
  procedure division using myhandle.
  end program MYROUTINE.
  ******************************************************
  * Prototypes are usually defined in a copybook, but  *
  * here it is placed in-line                          *
  ******************************************************

  program-id. MYMAIN.
  working-storage section.
  01  .
      05 myhandle         pic x(4).
      05 othervalue       pic x(4) value "6x3b".
  procedure division.
      call 'MYROUTINE'   using myhandle
      display "Othervalue is " othervalue.
  end program MYMAIN.

when you compiled the program you would receive this warning message:

    14      call 'MYROUTINE'   using myhandle
*1059-E****************************************
**    Parameter is not consistent with that defined
      in prototype

Coding your programs in this way enables you to recognise programming errors without having to do run-time tests.

Ideally, all programs called from COBOL should be prototyped; however, this is not practical, as there is already a substantial body of COBOL code, and COBOL programmers are not used to type-checking programs. Even if the effort was expended to prototype all calls a program makes, it is likely that strict type-checking would cause a large number of Compiler errors on valid COBOL calls. For this reason, your COBOL system enables you to prototype called programs using a relaxed form of type-checking, and/or the keyword ANY with a USING statement.

For an extended example of using call prototypes, see the topic Call Prototypes in the section Examples in your Language Reference.

The COBOL system library routines are prototyped, enabling you to ensure that data items defined in your programs match those expected by the library routines. This is particularly useful if you are porting 32-bit applications to 64-bit systems, and want to ensure that data items are typed correctly.

Parent topic: Call Prototypes


The ANY Keyword

You can use the keyword ANY as a USING parameter. This enables any parameter to fill the corresponding parameter position on any CALL statement to the prototyped routine. For example, you can avoid producing the error shown in the example above by using this prototype:

program-id. MYROUTINE is EXTERNAL.
 procedure division using any.
 end program MYROUTINE.

For information on the ANY keyword, see the topic PROCEDURE DIVISION Header in the section Procedure Division in your Language Reference.

Parent topic: Call Prototypes
Related information
The PROCEDURE DIVISION Header
Call Prototypes
Relaxed Type-checking
Using Type Definitions
Using the Library Routine Type Definitions and Call Prototypes


Relaxed Type-checking

By default, the Compiler performs relaxed type-checking on BY VALUE binary data items. That is, even if binary data items have been defined with different sizes in the calling and called programs, the programs will compile with errors. If you specified a CALL statement that had a data item defined as PIC X(2) COMP in its USING list, that data item can correspond to a PIC X(n) COMP data item in a call prototype, where n on a 32-bit system can be from 1 through 4, and on a 64-bit system can be 1 through 8.

For example, the following program will compile successfully:

program-id. MYROUTINE is EXTERNAL.
 linkage section.
 01  callee-value             pic x(2) comp-5.
 procedure division using by value callee-value.
 end program MYROUTINE.

 program-id. MYMAIN.
 working-storage section.
 01  .
     05 caller-value          pic x(4) value 123.
 procedure division.
     call 'MYROUTINE' using by value caller-value
 end program MYMAIN.

In this example, if the actual value of caller-value was too big to fit a data item defined as PIC X(2) COMP-5, binary truncation would occur. Such truncations might cause problems with the logic of your program, so you might want to specify that type-checking is more strict so that you can identify such potential problems. You can do this by setting the Compiler directive PROTOTYPE"STRICT". If you were to set PROTOTYPE"STRICT" when you compiled the above program, the Compiler would produce a message warning you of the type mismatch.

Parent topic: Call Prototypes


Using Type Definitions

When you use call prototypes in your programs, an error occurs if there is a mismatch between data-types. To avoid this error, and to code the CALL statement and USING parameters correctly, the data description entry of the USING parameter in the call prototype must be duplicated in the program calling that prototype. If you were to do this manually, such duplication could lead to code maintenance problems, and perhaps lead to inconsistencies when you were creating programs.

To enable easy duplication of data description entries, you can create COBOL type definitions in the Linkage Section of the call prototype, which you can then reference in the calling and called programs. To create a COBOL type definition, you code a data description that includes the TYPEDEF clause. The name you give the data item then becomes a type definition. You can then code a data item with a USAGE clause that references the type definition. For example:

 01  callee-value-t           pic x(2) comp-5 is typedef.
 01  callee-value             usage callee-value-t.

In this example the type definition is callee-value-t.

Here is the complete call prototype and a program that calls a subroutine based on this prototype:

program-id. MYROUTINE is EXTERNAL.
 linkage section.
 01  callee-value-t           pic x(2) comp-5 is typedef.
 01  callee-value             usage callee-value-t.
 procedure division using callee-value.
 end program MYROUTINE.

 program-id. MYMAIN.
 working-storage section.
 01  .
     05 caller-value          usage callee-value-t.
 procedure division.
     call 'MYROUTINE' using caller-value
 end program MYMAIN.

You can use the TYPEDEF clause not only on elementary data descriptions, but also on group items and even on entire record structures. For example:

program-id. MYROUTINE is EXTERNAL.
 linkage section.
 01  callee-value-t is typedef.
     05  callee-value-item-1  pic x(2) comp-5.
     05  callee-value-item-2  pic x(4).
 01  callee-value             usage callee-value-t.

 procedure division using callee-value.
 end program MYROUTINE.

 program-id. MYMAIN.
 working-storage section.
 01  .
     05 caller-value          usage callee-value-t.
 procedure division.
     move 123      to callee-value-item-1 of caller-value
     move 'abcdef' to callee-value-item-2 of caller-value
     call 'MYROUTINE' using caller-value
 end program MYMAIN.

All data items defined as type definitions in a call prototype are available to any programs using that prototype.

For detailed information on the TYPEDEF clause, see the topic The TYPEDEF Clause in the section Data Division - File and Data Description in your Language Reference.

Parent topic: Call Prototypes


Using the Library Routine Type Definitions and Call Prototypes

Two copybooks are supplied with this system; one contains data items used by the library routines specified as type definitions, or TYPEDEFs, while the other contains call prototypes for the library routines. These can be used in your COBOL programs to enable the Compiler to validate all calls to these routines.

We provide the file cbltypes.cpy, which contains all types required by the system library routines. In order to avoid conflict with data-names contained within your program, all TYPEDEF names include the prefix CBLT-. Where the types are not elementary items, any subordinate elements have the prefix CBLTE-.

We also provide the file cblproto.cpy, which contains all prototypes of the system library routines. In some cases, these prototypes have parameters declared as ANY; this is usually when variable length data is required as input.

In the descriptions of the parameters for the library routines, references to the system-defined USAGE types have the prefix CBLT-, while subordinate items have the prefix CBLTE-. If you declare variables using the new USAGE types, you do not declare the subordinate items; you can, however, use the subordinate items anywhere that variable usage is allowed. If you declare more than one variable of the same type which contains subordinate items, then you must use qualification in order to tell the compiler which variable you intend to reference, as each group variable will have subordinate items of the same name.

In your programs, you need only specify the copybook cblproto.cpy; you must specify it before the Identification Division of your program. You do not need to specify the copybook cbltypes.cpy, as this is included in cblproto.cpy.

For an extended example of using call prototypes, see Call Prototypes.

If, for whatever reason, you decide not to use the new USAGE types defined in cbltypes.cpy, you must declare a group item and all the listed subordinate variables explicitly; in this case you can give the subordinate variables any name you want.

Some third party database preprocessors (such as Oracle Pro*COBOL) do not allow the use of nested programs, and so you cannot use the prototypes defined in cblproto.cpy if you are also using such a preprocessor; instead, you must explicitly set the data items used with the library routines.

Note:

The call prototypes apply only to call-by-name routines (those of the form CBL_name_name), not to the call-by-number routines (those of the form X"NN").

Below is an example of the use of these prototypes in a program. If the file mymain.cbl exists the program displays its size:

 copy "cblproto.cpy".

 program-id. MYMAIN.
 working-storage section.
 01  .
     05  file-details    cblt-fileexist-buf.
 procedure division.
     call 'CBL_CHECK_FILE_EXIST' using 'mymain.cbl '
                                       file-details
     if  return-code not = 0
       display 'File mymain.cbl does not exist (or error)'
     else
       display 'File mymain.cbl size is '
               cblte-fe-filesize of file-details
     end-if
 end program MYMAIN.
Parent topic: Call Prototypes
Related information
Library Routine Prototypes and Compiling Native COBOL Programs for 64-Bit
About Call Prototypes
Call Prototypes
The ANY Keyword
Relaxed Type-checking
Using Type Definitions
The CALL Statement
Data Description Entry Skeleton
The ANY LENGTH Clause
The OCCURS Clause
The PROCEDURE DIVISION Header
The ENTRY Statement
The EVALUATE Statement
The TYPEDEF Clause


Compatibility

  • Compatibility with DG Interactive COBOL
  • Compatibility with RM/COBOL
  • Java and COBOL
  • OO COBOL Class Library Reference
  • User Interface Programming
Parent topic: Programming


Compatibility with DG Interactive COBOL

  • Introduction
    Introduction to compatibility with DG Interactive COBOL.
  • Compatibility Directives
    This COBOL system provides compatibility with Data General Interactive COBOL rev 1.30 and 1.30 through the use of a Compiler directive.
  • Compatibility with DG Interactive COBOL
    Converting your DG Interactive COBOL application so that it is suitable for input to this COBOL system.
Parent topic: Compatibility


Introduction

Studio Enterprise Edition provides compatibility with the DG Interactive COBOL programming language.

This enables you to migrate programs from this environment.

You can:
  • Convert applications written in DG Interactive COBOL to the Micro Focus COBOL language, and enhance them using the advanced language and development features offered by Studio Enterprise Edition.
  • Retain the use of the selected COBOL on some machine environments while moving to Studio Enterprise Edition on others. You might want to maintain a common set of source programs which are suitable for all environments.
Note: Any error messages and numbers that are returned when you compile your program in Studio Enterprise Edition or when you execute the resulting code are different in the two environments. This should present no problems, but is something of which you should be aware.
Parent topic: Compatibility with DG Interactive COBOL


Compatibility Directives

This COBOL system provides compatibility with Data General Interactive COBOL rev 1.30 and 1.30 through the use of a Compiler directive.
  • DG
    Changes the behavior of certain features to be compatible with Data General Interactive COBOL rev 1.30.
Parent topic: Compatibility with DG Interactive COBOL
Related reference
Reserved Words Table
Data General Interactive COBOL V1.3 Syntax Support


DG

Changes the behavior of certain features to be compatible with Data General Interactive COBOL rev 1.30.

Syntax:

>>-.---.-.----.--DG------------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NODG (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

See your Language Reference for details of syntax support for Data General Interactive COBOL rev 1.30.

Parent topic: Compatibility Directives
Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List
Related concepts
The DG Directive
Related reference
Data General Interactive COBOL V1.3 Syntax Support


Compatibility with DG Interactive COBOL

Converting your DG Interactive COBOL application so that it is suitable for input to this COBOL system.
  • Overview
  • Compatibility with DG Interactive COBOL Source
  • Reformatting a DG COBOL Source File
Parent topic: Compatibility with DG Interactive COBOL


Overview

You need to take the steps listed below in order to convert your DG Interactive COBOL application so that it is suitable for input to this COBOL system:

  1. Reformat the DG Interactive COBOL source programs
  2. Submit your DG Interactive COBOL source programs to this COBOL system
  • DG Interactive COBOL Source Programs
  • Enhancing your Converted Application
Parent topic: Compatibility with DG Interactive COBOL


DG Interactive COBOL Source Programs

Your COBOL system includes certain language enhancements that enable you to submit programs written in DG Interactive COBOL directly to this COBOL system. Provided your DG Interactive COBOL source programs conform to the standard file format for your operating system, there should be no problems in submitting most of these programs to this COBOL system. You should ensure that the expansion of tab characters in literals is not significant to the operation of your program before it is processed by this COBOL system.

However, if your program is written in DG CRT format, you must reformat the source file before you submit it to your COBOL system.

You must set the DG directive when you submit your source code to this COBOL system if your source code contains DG Interactive COBOL features that are not supported in the standard Micro Focus COBOL language, or if user-defined words are reserved words in the Micro Focus COBOL language. Refer to the Language Reference help for a list of Micro Focus COBOL reserved words, and for a full definition of all the syntax supported in the standard Micro Focus COBOL language. See the chapter Data General Interactive COBOL V1.3 Syntax Support in your Language Reference for details of syntax support for Data General Interactive COBOL V1.3. This manual also contains a full list of the additional DG Interactive COBOL features enabled in the Micro Focus COBOL language when you set the DG system directive. See the chapter Compatibility Directives for details of the DG directive.

Parent topic: Overview
Related reference
Reserved Words Table
Data General Interactive COBOL V1.3 Syntax Support


Enhancing your Converted Application

Once you have successfully submitted your DG Interactive COBOL source programs to this COBOL system, you can enhance it to take advantage of any of the advanced features offered to you by this COBOL development system.

Parent topic: Overview


Compatibility with DG Interactive COBOL Source

All of the DG Interactive COBOL syntax as defined in revision 02, dated August 1984, of The Data General Interactive COBOL Programmer's Reference Manual is supported by your COBOL system, with the exception of:

UNDELETE RECORD

Support is not guaranteed for any of the syntax of the DG Interactive COBOL language that is not documented in the above revision of The Data General Interactive COBOL Programmer's Reference Manual.

If your DG Interactive COBOL programs perform any screen-handling operations you must run the Adiscf facility and select the DG screen-handling configuration option before you run them. See your Character User Interfaces book for full details of this utility.

  • The DG Directive
  • Reserved Words
  • DG International Character Set
  • DG File Status and other Exception Values
  • Calls
  • Linkage Section Access
  • Arithmetic of Group Level Items
  • Run-time Switches
  • Program Identification and Data-names
Parent topic: Compatibility with DG Interactive COBOL


The DG Directive

Your DG Interactive COBOL source programs can contain:

  • DG Interactive COBOL syntax which is not found in the standard Micro Focus COBOL language
  • DG Interactive COBOL syntax which is found in Micro Focus COBOL, but has a different interpretation at run time.

In either case you must specify the DG Compiler directive when you submit such source programs to this COBOL system.

The chapter Data General Interactive COBOL V1.3 Syntax Support in your Language Reference contains the DG syntax which is not found in the standard Micro Focus COBOL language

Features which are syntactically the same as Micro Focus COBOL features but have different behavior at run time, are described in the following sections of this chapter. Unless you set the DG directive at the time the object code is produced, this syntax behaves in the standard Micro Focus COBOL manner, as documented in the Language Reference. You do not need to amend DG Interactive COBOL source programs which contain these features, but if you try to submit them to this COBOL system without setting the DG directive they might not behave as you expect.

Parent topic: Compatibility with DG Interactive COBOL Source
Related reference
DG
Data General Interactive COBOL V1.3 Syntax Support


Reserved Words

The Language Reference lists all the words that are reserved in your version of the COBOL system. If you have included any of these words as user-defined words in your DG Interactive COBOL program, we advise that you use the REMOVE directive to disable the relevant reserved words in this COBOL system.

Parent topic: Compatibility with DG Interactive COBOL Source
Related reference
Reserved Words Table
REMOVE


DG International Character Set

The environment dependent feature of DG Interactive COBOL which allows you to use an extra 69 characters in addition to the 96 characters in the ASCII set, is not supported by this COBOL system.

Parent topic: Compatibility with DG Interactive COBOL Source


DG File Status and other Exception Values

DG Interactive COBOL file status and other exception values are not supported by this COBOL system, as they are environment dependent. If you wish to maintain a common source for programs used by both systems, you should maintain COPY-files of the file status values returned by each system.

Parent topic: Compatibility with DG Interactive COBOL Source


Calls

DG Interactive COBOL system calls are environment dependent, and are not supported by this COBOL system. Under this COBOL system you cannot pass a switch in a CALL statement; you should use Linkage Section items to communicate between programs.

Parent topic: Compatibility with DG Interactive COBOL Source


Linkage Section Access

DG Interactive COBOL allows a main program to access its Linkage Section but this facility is not supported by this COBOL system. We recommend that if a program is to be accessed as a main program, you transfer the Linkage Section entries into Working-Storage.

Parent topic: Compatibility with DG Interactive COBOL Source


Arithmetic of Group Level Items

DG Interactive COBOL allows arithmetic of group level items, but this is not supported by this COBOL system. We recommend that you redefine such fields into numeric items to overcome this problem.

Parent topic: Compatibility with DG Interactive COBOL Source


Run-time Switches

DG Interactive COBOL run-time switches A to Z, inclusive, are mapped onto switches 1 to 26, respectively, in this COBOL system.

Parent topic: Compatibility with DG Interactive COBOL Source


Program Identification and Data-names

The DG Interactive COBOL system allows the Program-ID and a data item in that program to have the same name. However, this COBOL system does not allow the use of the same name for the Program-ID and a data item in a program, requiring instead that each should be unique. We recommend that you either change the program-name in the Program-ID and in any programs that call this program, or change the name of the data item.

Parent topic: Compatibility with DG Interactive COBOL Source


Reformatting a DG COBOL Source File

Source programs written in DG Interactive COBOL CRT format cannot be accepted by this COBOL system unless you first amend the format, using a formatter or editor. This must alter the margins in these programs, and split any lines in them containing more than 72 characters, into lines of 72 characters or fewer.

  • Reformatting Rules
Parent topic: Compatibility with DG Interactive COBOL


Reformatting Rules

You should amend your source program according to the following rules:

  1. If the character in column 1 is an indicator (*/-), append six spaces to the beginning of a line.
  2. If the character in column 1 is any non-space character not mentioned in rule 1, append seven space characters to the beginning of the line.
  3. If area A (columns 1 to 4 inclusive) contains all spaces, append seven additional space characters to the beginning of the line. However, if the entire line contains spaces, it outputs a single 72 character line containing spaces.
  4. If a line is too long to fit onto a single 72 character line, break it onto subsequent lines, up to a maximum of three. Where possible, these breaks occur at a space character to preserve the program's readability.
  5. If a line is expanded beyond 132 characters, truncate the line to 132 characters. This prevents any pseudo-comment areas from being included in the program source.
Parent topic: Reformatting a DG COBOL Source File


Compatibility with RM/COBOL

Studio Enterprise Edition provides compatibility with the RM/COBOL programming language:

This enables you to migrate programs from this environment. You can:
  • Convert applications written in RM/COBOL to the Micro Focus COBOL language, and enhance them using the advanced language and development features offered by Studio Enterprise Edition.
  • Retain the use of the selected COBOL on some machine environments while moving to Studio Enterprise Edition on others. You might want to maintain a common set of source programs which are suitable for all environments.
Note: Any error messages and numbers that are returned when you compile your program in Studio Enterprise Edition or when you execute the resulting code are different in the two environments. This should present no problems, but is something of which you should be aware.
  • Converting RM/COBOL Applications
    This COBOL system supports certain extensions that enable you to submit source programs written in the RM/COBOL language.
  • RM/COBOL File Handling
    This COBOL system enables you to access the data files used in your RM/COBOL applications.
  • Compatibility with XML Extensions
    Compatibility issues when using XML Extensions in Studio Enterprise Edition when producing native code.
Parent topic: Compatibility


Converting RM/COBOL Applications

By default, this COBOL system already supports much of the RM/COBOL syntax and behavior. Additional RM/COBOL-specific syntax that has been added for compatibility is documented in the section RM/COBOL Syntax Support in your Language Reference.

You can also enable additional RM/COBOL behavior using certain Compiler directives. Using these directives when you submit your RM/COBOL source programs to this COBOL system ensures that most of the programs are accepted the first time they are submitted. There are still certain compatibility issues between the two COBOL systems, which are detailed, with any possible workarounds, in the RM/COBOL Conversion Issues section.

  • Compiler Directives for RM/COBOL Compatibility
    You can set a number of Compiler directives in your RM/COBOL source programs that enable a program to emulate RM/COBOL behavior.
  • Converting RM/COBOL Data Types
    Information on how to convert COMPUTATIONAL, COMPUTATIONAL-3, COMPUTATIONAL-6 and DISPLAY data from RM/COBOL format to the formats used by this system.
  • RM/COBOL Conversion Issues
    Information on issues you might encounter when running RM/COBOL source programs in this COBOL system.
Parent topic: Compatibility with RM/COBOL
Related reference
RM/COBOL Syntax Support


Compiler Directives for RM/COBOL Compatibility

You can set a number of Compiler directives in your RM/COBOL source programs that enable a program to emulate RM/COBOL behavior.

The main directive that sets the majority of RM/COBOL behavior is DIALECT(RM).

Setting the DIALECT(RM) directive automatically sets additional Compiler directives, such as RM, NOTRUNC, OLDINDEX, NOOPTIONAL-FILE, RETRYLOCK, ALIGN"2" and SEQUENTIAL"LINE". See the topic RM Dialect Settings for full details of the directives set.

The system will also behave as if you had specified the following syntax:

sign trailing separate

for signed numeric data items, and:

lock mode is automatic

Previously, compatibility was achieved by compiling with the RM Compiler directive. The newer DIALECT(RM) directive sets and extends the compatibility given by RM, and should be used for all new migrations from RM/COBOL, unless you normally set the ANSI switch when you submit your RM/COBOL source programs to the RM/COBOL system. If you do, set the RM"ANSI" directive when you compile your programs.

We also recommend that you set the NOMF directive when you submit your RM/COBOL source programs to this COBOL system. This ensures that only those words which are treated as reserved words under the ANSI '74 COBOL standard are regarded as reserved words by this COBOL system.

Setting the NORM directive disables the syntax enabled when the RM directive was set, and automatically resets the additional Compiler directives to NOSPZERO, TRUNC"ANSI", NOOLDINDEX, OPTIONAL-FILE, NORETRYLOCK, ALIGN"8" and SEQUENTIAL"RECORD". Additionally, the system behaves as if you had specified the syntax:

sign trailing included

for signed numeric data items, and:

lock mode is exclusive

for each file in the program which has no explicit locking syntax declared.

The final states of the additional directives set when you use the NORM directive are not necessarily the same as their initial default states.

Parent topic: Converting RM/COBOL Applications
Related reference
DIALECT
RM


Converting RM/COBOL Data Types

  • Types of Data
  • COMP/COMPUTATIONAL Data
  • COMP-3/COMPUTATIONAL-3 Data
  • COMP-6/COMPUTATIONAL-6 Data
  • DISPLAY Data
Parent topic: Converting RM/COBOL Applications


Types of Data

This COBOL system always allocates the same number of bytes to a data item as in the original program, but might redefine its contents when it is converted. Therefore, you must be aware that if these items are redefined, and the program logic expects to find a certain binary value in the redefinition, you might not receive the behavior you are expecting at run time. At run time, this COBOL system might treat the ON SIZE ERROR clause differently from the RM/COBOL system. See the chapter RM/COBOL Conversion Issues for further details.

The following sections define how this COBOL system treats COMPUTATIONAL, COMPUTATIONAL-1 and COMPUTATIONAL-6 types of data.

  • COMPUTATIONAL (COMP) Data Types
  • COMPUTATIONAL-1 (COMP-1) Data Types
  • PICTURE Character-strings
  • COMPUTATIONAL-6 (COMP-6) Data Types
Parent topic: Converting RM/COBOL Data Types


COMPUTATIONAL (COMP) Data Types

This COBOL system treats any COMP data items in your RM/COBOL source program as the standard Micro Focus COBOL DISPLAY format. The difference in the internal representation of such data in the two systems is that this COBOL system always sets the most significant four bits of each byte to the value 3, while the RM/COBOL system always sets such bits to the value 0.

For example, under the RM/COBOL system:

PIC 999 COMP VALUE 123

is held in three bytes as hexadecimal value 01 02 03

while under this COBOL system:

PIC 999 VALUE 123

is held in three bytes as hexadecimal value 31 32 33.

Parent topic: Types of Data
Related reference
COMPUTATIONAL-1 Data Items with a PICTURE other than S9(4)
Related information
COMPUTATIONAL-1 (COMP-1) Data Types
COMP/COMPUTATIONAL Data


COMPUTATIONAL-1 (COMP-1) Data Types

For each data item declared as USAGE COMP-1 in your RM/COBOL source program, regardless of its picture-string, this COBOL system allocates a 2-byte signed binary data item. This data item is capable of holding a hexadecimal value in the range -32768 to +32767. That is, this COBOL system treats each RM/COBOL USAGE COMP-1 data item as though it had a standard Micro Focus COBOL picture-string of S9(4) COMP. See your Language Reference for details on the standard Micro Focus COBOL language.

Parent topic: Types of Data
Related reference
COMPUTATIONAL-1 Data Items with a PICTURE other than S9(4)
Field Wrap-Around
Related information
COMPUTATIONAL (COMP) Data Types
COMP/COMPUTATIONAL Data


PICTURE Character-strings

The maximum length of a PICTURE character-string in a record description is 20 characters. However, you can overcome this limitation by splitting any PICTURE character-string which exceeds this limit into two, and defining a FILLER item with a PICTURE character-string which corresponds to the size of the second half of the original string.

Parent topic: Types of Data
Related reference
The PICTURE Clause


COMPUTATIONAL-6 (COMP-6) Data Types

This COBOL system treats any COMP-6 data items in your RM/COBOL source program as the standard Micro Focus COBOL COMP format. If, as a result of this, less data space is allocated to each item than would be under the RM/COBOL system, this COBOL system pads the space with a byte containing a zero, as shown in the following table:

RM COMP-6 PICTURE clause | Bytes allocated when converting to Micro Focus COBOL COMP PICTURE clause | Number of bytes containing leading zeros required to precede COMP PICTURE clause
9(1) | 1 | NONE
9(2) | 1 | NONE
9(3) | 2 | NONE
9(4) | 2 | NONE
9(5) | 3 | NONE
9(6) | 3 | NONE
9(7) | 4 | NONE
9(8) | 4 | NONE
9(9) | 5 | NONE
9(10) | 5 | NONE
9(11) | 5 | 1
9(12) | 5 | 1
9(13) | 6 | 1
9(14) | 6 | 1
9(15) | 7 | 1
9(16) | 7 | 1
9(17) | 8 | 1
9(18) | 8 | 1

The padding byte precedes the converted field, and is therefore included in any redefinition of group fields which contain the converted field. However, the padding byte would not be included if you redefined only the converted field. If you wish to ensure that the padding byte is included in the redefinition of the converted field, you must add a field at a higher level immediately before the converted field, and redefine this new field instead.

Parent topic: Types of Data
Related information
Redefinition of COMP or COMP6 Data Items
COMP-6/COMPUTATIONAL-6 Data


COMP/COMPUTATIONAL Data

The RM/COBOL system represents COMP (or COMPUTATIONAL) data in packed decimal format with one character per byte stored in each least significant four bits. The most significant half-byte always contains zero. If the picture string specifies a signed representation, an additional byte is added to the least significant end of the string: a negative value is represented by the hexadecimal value x"D", and a positive value is represented by the hexadecimal value x"B".

Consider the following examples:

Value | Picture Clause | RM Representation (Hexadecimal)
1234 | PIC 9(5) COMP | 00 01 02 03 04
1234 | PIC S9(5) COMP | 00 01 02 03 04 0B
-1234 | PIC S9(5) COMP | 00 01 02 03 04 0D

You should converts COMP data fields into DISPLAY format, with sign trailing separate. This is compatible with this COBOL system's treatment of RM/COBOL COMP fields in the source program when the RM directive is set. If the data item is signed, the sign byte has the most significant half-byte set to hexadecimal value 2.

After conversion, the examples above are represented as follows:

Value | Picture Clause | This COBOL's Representation (Hexadecimal)
1234 | PIC 9(5) DISPLAY | 30 31 32 33 34
1234 | PIC S9(5) DISPLAY | 30 31 32 33 34 2B
-1234 | PIC S9(5) DISPLAY | 30 31 32 33 34 2D
Parent topic: Converting RM/COBOL Data Types
Related reference
COMPUTATIONAL-1 Data Items with a PICTURE other than S9(4)
Related information
COMPUTATIONAL-1 (COMP-1) Data Types
COMPUTATIONAL (COMP) Data Types


COMP-3/COMPUTATIONAL-3 Data

The RM/COBOL system represents COMP-3 data in packed decimal format with the least significant half-byte holding the sign.

This sign half-byte contains the following values:

Field | RM Sign half-byte value (Hexadecimal)
Unsigned | F
Signed, Positive | B or F
Signed, Negative | D

Consider the following examples:

Value | Picture Clause | RM Representation (Hexadecimal)
1234 | PIC 9(5) COMP-3 | 00 23 4F
1234 | PIC S9(5) COMP-3 | 00 23 4F
-1234 | PIC S9(5) COMP-3 | 00 23 4D

The only requirement for conversion is that the sign half-byte has to be changed for signed positive fields to hexadecimal value C. The examples above are represented as follows:

Value | Picture Clause | This COBOL's Representation (Hexadecimal)
1234 | PIC 9(5) COMP-3 | 00 23 4F
1234 | PIC S9(5) COMP-3 | 00 23 4C
-1234 | PIC S9(5) COMP-3 | 00 23 4D
Parent topic: Converting RM/COBOL Data Types
Related information
COMPUTATIONAL-3 or PACKED-DECIMAL Format


COMP-6/COMPUTATIONAL-6 Data

The RM/COBOL system holds COMP-6 data in a similar format to COMP-3 data, except there is no sign half-byte. If a sign is indicated in the picture clause it is ignored and has no effect. The value held is always positive.

Consider the following examples:

Value | Picture Clause | RM Representation (Hexadecimal)
1234 | PIC 9(5) COMP-6 | 00 12 34
123456 | PIC S9(6) COMP-6 | 12 34 56

In order to maintain the size and capacity of the data items, this COBOL system treats COMP-6 data items as this COBOL's COMP format fields, and pads the field with binary zeros where necessary. The examples above are represented as follows:

Value | Picture Clause | This COBOL's Representation (Hexadecimal)
1234 | PIC 9(5) COMP-6 | 00 04 D2
123456 | PIC S9(6) COMP-6 | 01 E2 40

The 9(5) COMP field is extended by one byte containing binary zero in order to maintain the size of the original item. See the section COMPUTATIONAL-6 (COMP-6) Data Types in the chapter Compatibility with RM/COBOL for details.

Parent topic: Converting RM/COBOL Data Types
Related information
COMPUTATIONAL-6 (COMP-6) Data Types
Redefinition of COMP or COMP6 Data Items


DISPLAY Data

You should be aware of the following differences between the representation of numeric DISPLAY format data items, with sign INCLUDED, under the RM/COBOL system and this COBOL system:

  • This COBOL system does not encode a sign on the data if the data is positive, whereas the RM/COBOL system increments the value of the most significant half-byte by one to denote a positive value.
  • This COBOL system increments the value of the most significant half-byte by four to denote a negative value. The RM/COBOL system increments the value of the byte by twenty-five (that is, hexadecimal 19).

When the DIALECT"RM" directive is set, a DISPLAY format data item with no sign clause associated is treated by this system as though you had specified the SIGN TRAILING IS SEPARATE clause. However, when the RM"ANSI" directive is set, the same data item is treated as though you had specified the SIGN TRAILING IS INCLUDED clause. This is the default state for such data items in this COBOL system.

Consider the following examples:

Value | Picture Clause | RM Representation (Hexadecimal)
 |  | Leading | Trailing
123 | PIC 9(3) DISPLAY | 31 32 33 | 31 32 33
123 | PIC S9(3) DISPLAY | 41 32 33 | 31 32 43
-123 | PIC S9(3) DISPLAY | 4A 32 33 | 31 32 4C

These examples are represented as follows:

Value | Picture Clause | This COBOL's Representation (Hexadecimal)
 |  | Leading | Trailing
123 | PIC 9(3) DISPLAY | 31 32 33 | 31 32 33
123 | PIC S9(3) DISPLAY | 31 32 33 | 31 32 33
-123 | PIC S9(3) DISPLAY | 71 32 33 | 31 32 73
Parent topic: Converting RM/COBOL Data Types
Related reference
DIALECT


RM/COBOL Conversion Issues

The syntax of most RM/COBOL source programs when submitted to run on this COBOL system will be accepted and run successfully. However, sometimes this COBOL system might reject some of the syntax in your original RM/COBOL source program, or might cause your program to behave unexpectedly at run-time.

This section contains the known problems which you may encounter. Hints are also given on how you can either rectify the cause of such errors, or emulate the RM/COBOL type of behavior in this COBOL system.

  • Producing Executable Code
  • Running the Code
Parent topic: Converting RM/COBOL Applications


Producing Executable Code

The following section covers the known issues when submitting RM/COBOL source programs to this COBOL system. Where possible, work-arounds and resolutions are also provided.

  • Perform Statements
    PERFORM statements are not treated in the same way by both COBOL systems. This COBOL system uses a stack-based perform handling system, while the RM/COBOL system associates a return address with a specific procedure name.
  • ACCEPT FROM CENTURY-DATE and FROM CENTURY-DAY
    In Studio Enterprise Edition, to use the FROM CENTURY-DATE and FROM CENTURY-DAY phrases with the ACCEPT statement, set the RM Compiler directive.
  • Nested COPY statements with REPLACING phrase
    In Studio Enterprise Edition, you cannot specify text replacement as part of a nested COPY statement when text replacement is already active as part of a COPY statement.
  • Duplicate Paragraph-names
    Studio Enterprise Edition and RM/COBOL differ in the way that they reference paragraph-names when two or more duplicate paragraph names exist differs.
  • Empty Groups
    In Studio Enterprise Edition, if you have any empty groups specified in your source code, you must set the DIALECT"RM" Compiler directive.
  • Figurative Constants and the USING Phrase
    In Studio Enterprise Edition, to use figurative constants in the USING phrase of a CALL statement or as values of level 78 constants, set the DIALECT"RM" Compiler directive.
  • File Not Found Errors
    Studio Enterprise Edition and RM/COBOL differ in the environment variables that they use to locate program and data files.
  • Indexed File Error on Open
    Studio Enterprise Edition and RM/COBOL differ in how they handle record length fields and some data fields when you open an RM/COBOL indexed file.
  • Linkage Section in Main Program
    Studio Enterprise Edition and RM/COBOL differ in their ability to reference the Linkage Section items in the main program.
  • Library Routines
    To use the RM/COBOL standard library routines that are available in Studio Enterprise Edition, you must use the 1024 calling convention.
  • Nested OCCURS DEPENDING Clauses
    In Studio Enterprise Edition, if you are using nested OCCURS DEPENDING clauses, you must set the ODOSLIDE Compiler directive.
  • Numbering of Segments
    Studio Enterprise Edition and RM/COBOL differ in the number of segments that they permit you to specify.
  • Program Identification and Data Names
    In Studio Enterprise Edition, ensure that the Program-ID name does not share the same name as any data items in the program.
  • REMARKS Paragraph
    In Studio Enterprise Edition, if your program uses the REMARKS paragraph in the Identification Division, you must set the DIALECT"RM" Compiler directive.
  • Reserved Words
    In Studio Enterprise Edition, setting certain Compiler directives (such as RM and ANS85) activates certain reserved words that you cannot use as names for your data items.
  • SAME AS Clause Not Available When Defining Data Structures
    Studio Enterprise Edition and RM/COBOL differ in the way that they allow you to reuse existing data structures.
  • Source Code in Columns 73 to 80
    Studio Enterprise Edition ignores any of the code in your source programs which lies within columns 73-80 inclusive.
  • Undeclared Data Items in Clauses
    In Studio Enterprise Edition, if the data item used in a clause (for example, the File Status clause) is not declared, you receive an error.
  • User-names Longer than 127 Bytes are Truncated
    In RM/COBOL, you can specify user-names (data-names, procedure-names, program-names, etc) up to 240 characters long. In this COBOL system, user-names longer than 127 bytes in length are truncated and a warning message is produced.
Parent topic: RM/COBOL Conversion Issues


Perform Statements

PERFORM statements are not treated in the same way by both COBOL systems. This COBOL system uses a stack-based perform handling system, while the RM/COBOL system associates a return address with a specific procedure name.

As a result, under the RM/COBOL system, all end-points to PERFORM statements are always active until they are used. However, under this system, only the end-point of the last PERFORM statement is active at any one time.

You must set the PERFORM-TYPE directive with the RM parameter if this COBOL system is to emulate the behavior of RM/COBOL PERFORM statements.

Parent topic: Producing Executable Code
Related reference
The PERFORM Statement


ACCEPT FROM CENTURY-DATE and FROM CENTURY-DAY

In Studio Enterprise Edition, to use the FROM CENTURY-DATE and FROM CENTURY-DAY phrases with the ACCEPT statement, set the RM Compiler directive.

Alternatively, use the following equivalent phrases with the ACCEPT statement:

  • FROM DATE YYYYMMDD, which is the equivalent of FROM CENTURY-DATE.
  • FROM DAY YYYYDDD, which is the equivalent of FROM CENTURY-DAY.
procedure division.
ACCEPT data-name-1 FROM DATE YYYYMMDD.
ACCEPT data-name-2 FROM DAY YYYYDDD.
Parent topic: Producing Executable Code
Related reference
The ACCEPT Statement


Nested COPY statements with REPLACING phrase

In Studio Enterprise Edition, you cannot specify text replacement as part of a nested COPY statement when text replacement is already active as part of a COPY statement.

If you attempt to use COPY REPLACING in a file copied with a COPY REPLACING statement, an error code COBCH0062 COPY replacement not supported is displayed on compilation.

Parent topic: Producing Executable Code
Related reference
The COPY Statement
Related information
COBCH0062 Nested COPY replacement not supported


Duplicate Paragraph-names

In Studio Enterprise Edition, if you have duplicate paragraph-names, in different sections, and then call a paragraph-name from outside its section, an error is produced unless you have explicitly referenced the paragraph-name and its section. In RM/COBOL, by just calling the paragraph-name, it assumes you are calling the next declaration of the paragraph-name found.

To ensure that references to duplicate paragraph-names are correctly resolved, you must qualify a reference to a duplicate paragraph-name by adding the section-name in which it is declared.

Example

If your source code contains the following:

      ....
      perform para-2.
      ....
 sect-1 section.
      para-1.
      ....
      para-2.
      ....
 sect-2 section.
      para-2.
      ....

RM/COBOL will resolve the reference to para-2 in the PERFORM statement by using the declaration of para-2 in the sect-1 SECTION. In Studio Enterprise Edition, however, you must qualify the reference to the duplicate paragraph-name in your source code by using the PERFORM para-2 OF sect-1 statement.

Parent topic: Producing Executable Code
Related reference
The PERFORM Statement


Empty Groups

In Studio Enterprise Edition, if you have any empty groups specified in your source code, you must set the DIALECT"RM" Compiler directive.
Parent topic: Producing Executable Code
Related reference
DIALECT


Figurative Constants and the USING Phrase

In Studio Enterprise Edition, to use figurative constants in the USING phrase of a CALL statement or as values of level 78 constants, set the DIALECT"RM" Compiler directive.

Alternatively, the figurative constant can be replaced by the equivalent non-numeric literal, such as " " for SPACE or "0" for ZERO.

Parent topic: Producing Executable Code
Related reference
DIALECT


File Not Found Errors

Studio Enterprise Edition and RM/COBOL differ in the environment variables that they use to locate program and data files.

If your source code produces a file not found error, ensure the correct paths are set in the correct environment variables. In Studio Enterprise Edition, set COBPATH to locate program files and COBDATA to locate data files. The RUNPATH environment variable used in RM/COBOL, is not used in Studio Enterprise Edition.

Parent topic: Producing Executable Code
Related information
Environment Variables


Indexed File Error on Open

Studio Enterprise Edition and RM/COBOL differ in how they handle record length fields and some data fields when you open an RM/COBOL indexed file.

In Studio Enterprise Edition, when you try to open an RM/COBOL indexed file, you may receive either a run-time error COBRT161 Illegal intermediate code or a file status code 39 A conflict has been detected between the fixed file attributes and the attributes specified for that file in the program.

You must ensure that you read in the same size records that were created in RM/COBOL.

In Visual Studio, hover over the level 01 item of the file description to display the length of the record.

If the length of the file description does not match that which was processed in RM/COBOL, check the following:

  • In RM/COBOL, you can set the RECORD CONTAINS nn CHARACTERS clause to be a different length than the actual length specified in the record description. If this clause is greater than the actual description, you must pad the record description with filler bytes to match the RECORD CONTAINS clause.
  • If you have signed numeric display data in your file, Studio Enterprise Edition will treat the sign as a separate byte if you are using the RM directive without "ANSI" specified. If these fields are stored as sign internal, you must use RM"ANSI" or do not use the RM directive at all.
Parent topic: Producing Executable Code
Related information
COBRT161 Illegal intermediate code (Fatal)
RM/COBOL File Status Codes


Linkage Section in Main Program

In RM/COBOL, if the main program has a Linkage Section, it is initialized by the parameter passed on the command line. In Studio Enterprise Edition, you must use the command_line_linkage tunable to pass parameters from the command line to the Linkage Section.

Parent topic: Producing Executable Code
Related reference
Linkage Section
command_line_linkage


Library Routines

To use the RM/COBOL standard library routines that are available in Studio Enterprise Edition, you must use the 1024 calling convention.
  • C$Century
  • C$ConvertAnsiToOem
  • C$ConvertOemToAnsi
  • C$DARG (only partially supported)
  • C$Delay
  • C$GetEnv
  • C$GetNativeCharset
  • C$LogicalAnd
  • C$LogicalComplement
  • C$LogicalOr
  • C$LogicalShiftLeft
  • C$LogicalShiftRight
  • C$LogicalXor
  • C$NARG
  • C$SetEnv
  • C$RERR
  • DELETE
  • RENAME

For more information on each library routine, see RM/COBOL Library Routines in the product Help.

Parent topic: Producing Executable Code
Related concepts
RM/COBOL Library Routines


Nested OCCURS DEPENDING Clauses

In Studio Enterprise Edition, if you are using nested OCCURS DEPENDING clauses, you must set the ODOSLIDE Compiler directive.
Parent topic: Producing Executable Code
Related reference
The OCCURS Clause
ODOSLIDE


Numbering of Segments

In Studio Enterprise Edition, you can only specify segment numbers in the range 0 to 99 inclusive, which conforms to segment number limit specified in the ANS X3.23-1985 COBOL standard. In RM/COBOL, you can specify segment numbers greater than 99.

If your source code has segment numbers greater than 99, recode the program. Make sure that any new segment numbers you allocate do not clash with an already existing segment number. Segment numbers between 0 and 49 inclusive are used by Studio Enterprise Edition to indicate fixed portions of your object program, while segment numbers 50 to 99 inclusive indicate independent segments.

For details on the use of segmentation and segment numbers in your source programs, see COBOL Language Reference in the product Help.

Parent topic: Producing Executable Code


Program Identification and Data Names

In Studio Enterprise Edition, you cannot use the same name for the Program-ID and a data item in the program; each name should be unique. RM/COBOL permits the name of the Program-ID paragraph and a data item to share the same name.

Parent topic: Producing Executable Code
Related reference
The Program-ID Paragraph
Related information
Segmentation


REMARKS Paragraph

In Studio Enterprise Edition, if your program uses the REMARKS paragraph in the Identification Division, you must set the DIALECT"RM" Compiler directive.

Alternatively, mark the paragraph as comment lines.

Parent topic: Producing Executable Code
Related reference
DIALECT


Reserved Words

In Studio Enterprise Edition, setting certain Compiler directives (such as RM and ANS85) activates certain reserved words that you cannot use as names for your data items.

If you attempt to use a reserved word, you receive a COBCH0666 ("Reserved word used as data name or unknown data description qualifier") COBOL syntax error.

To continue to use the reserved word as a data name, you can:

  • Use the REMOVE Compiler directive, to unreserve that particular keyword.
  • Set the MFLEVEL Compiler directive to an appropriate level, to unreserve all keywords above that level.

    See Compiler Directives in the product Help.

Example

Your RM/COBOL source program may contain the following lines of code:

     ....
     03 sort   pic 99.
     ....
     move 1 to sort

If you submit this to Studio Enterprise Edition, you will receive an error because the SORT verb is reserved. However, if you specify the REMOVE"SORT" Compiler directive when you submit this source program, you will not receive the error.

Parent topic: Producing Executable Code
Related reference
REMOVE
Related information
COBCH0666 Reserved word used as data-name or unknown data description qualifier


SAME AS Clause Not Available When Defining Data Structures

Studio Enterprise Edition and RM/COBOL differ in the way that they allow you to reuse existing data structures.

In Studio Enterprise Edition, use the TYPEDEF clause to define your base data structure, and then use the USAGE clause to create data structures of the same type.

data division.
working-storage section.
01 atype is typedef.
   03 var1 pic x(10) value "brown".
   03 var2 pic x(10) value "blue".
   03 var3 pic x(10) value SPACE.
01 a1 usage atype.
procedure division.
display var2 of a1.

The result of the display statement is blue.

The SAME AS clause used in RM/COBOL is not supported in Studio Enterprise Edition.

Parent topic: Producing Executable Code
Related reference
The TYPEDEF Clause
The USAGE Clause


Source Code in Columns 73 to 80

Studio Enterprise Edition ignores any of the code in your source programs which lies within columns 73-80 inclusive.

Code in these columns could be the result of expanding TAB characters in your source program, instead of standard TAB stops. If your source program contains TAB stops, convert them to spaces.

Parent topic: Producing Executable Code


Undeclared Data Items in Clauses

In Studio Enterprise Edition, you receive a COBCH0250 STATUS field data-name missing or illegal error if a data item used in the File Status clause is not declared in the Working-Storage section. In RM/COBOL, you do not have to declare the data item in Working Storage.

Parent topic: Producing Executable Code
Related information
COBCH0250 STATUS field data-name missing or illegal
RM/COBOL File Status Codes


User-names Longer than 127 Bytes are Truncated

In RM/COBOL, you can specify user-names (data-names, procedure-names, program-names, etc) up to 240 characters long. In this COBOL system, user-names longer than 127 bytes in length are truncated and a warning message is produced.

Solution:

Results may be affected if the truncated user-name is used with XML Extensions, to export or import XML documents; therefore, we recommend that you keep user-names to 127 bytes or less.

Parent topic: Producing Executable Code
Parent topic: Compatibility with XML Extensions


Running the Code

Once you have successfully submitted your RM/COBOL source program to this COBOL system and produced executable code, you might encounter difficulties when you try to run this code under this system. Alternatively, the code might run but you might find that its behavior under this COBOL system is not exactly the same as under the RM/COBOL system. The following sections detail known areas of difficulty you might encounter, and offer hints on how you can avoid them.

  • Table Bound Checking
    If you try to run a program under this COBOL system which contains a subscript value greater than the size of the table to which it refers, the run-time system will produce an error indicating this. Under the RM/COBOL system, however, no such table bound checking is done.
  • ACCEPT Fields at the Edge of the Screen
    Studio Enterprise Edition and RM/COBOL differ in their alignment of numeric data items from an ACCEPT statement that would result in the data going beyond the right-hand edge of the screen.
  • COMPUTATIONAL-1 Data Items with a PICTURE other than S9(4)
    In Studio Enterprise Edition, a COMPUTATIONAL-1 data item is assumed to have a picture-string of S9(4). In some cases in RM/COBOL, this is not the case.
  • Display of Input Data in Concealed ACCEPT Fields
    Studio Enterprise Edition and RM/COBOL differ in the way that they treat data entered as part of an ACCEPT statement when the OFF and ECHO clauses are specified.
  • Embedded Control Sequences in DISPLAY Statements
    In Studio Enterprise Edition, you cannot embedded control sequences within data items that you want to be displayed.
  • End of File Notification
    After an unsuccessful READ on a sequential file, due to reaching the end of the file, Studio Enterprise Edition will indicate that there is still no next logical record if you attempt to read the file without closing and opening it again.
  • Environment Variables Used to Resolve File Names
    In Studio Enterprise Edition, you are unable to use environment variables to resolve a file name at run time if you are using RMFM, the RM/COBOL file handler.
  • Field Wrap-Around
    Studio Enterprise Edition and RM/COBOL differ when performing arithmetic operations on binary data items (that is, RM/COBOL COMPUTATIONAL-1 format items) which result in the value exceeding the capacity of the target data item and there is no ON SIZE ERROR clause specified.
  • File and Record Locking
    Certain versions of RM/COBOL contain some software errors in the way in which locks for files and records are handled. These errors do not occur in Studio Enterprise Edition.
  • Initialization of Working Storage
    Studio Enterprise Edition and RM/COBOL differ in the way that they initialize data items without values in Working Storage.
  • Numeric Fields Containing Illegal Characters When Using a DEPENDING ON Phrase of an OCCURS Clause
    In Studio Enterprise Edition, if you fail to initialize a numeric data item that is used in a DEPENDING ON phrase of an OCCURS clause appropriately, a COBRT163 Illegal character in numeric field error is displayed at run time.
  • ON SIZE ERROR Phrase
    Studio Enterprise Edition and RM/COBOL differ in their treatment of the ON SIZE ERROR condition.
  • Open EXTEND of Nonexistent File
    Studio Enterprise Edition when you have the RM Compiler directive set and RM/COBOL differ in the result of attempting to open a non-existent file for EXTEND.
  • Printer Output is Written to Disk
    By default, Studio Enterprise Edition writes all output intended for a printer to disk.
  • Redefinition of COMP or COMP6 Data Items
    Studio Enterprise Edition fully supports the size and capacity of RM/COBOL type COMPUTATIONAL and COMPUTATIONAL-6 data items when the RM Compiler directive is set. However, the internal representation of these data items in Studio Enterprise Edition and in RM/COBOL is not the same.
  • Screen Column Number Specification
    Studio Enterprise Edition and RM/COBOL differ in the number of screen columns you are able to specify.
  • Trailing Blanks in Line Sequential Files
    Studio Enterprise Edition and RM/COBOL differ in the way that they deal with trailing blanks from line sequential records before writing the record.
  • Undefined Results of MOVE and Arithmetic Operations
    Studio Enterprise Edition and RM/COBOL differ in the results of MOVE statements, arithmetic operations, and comparisons that involve numeric and alphanumeric data items.
  • Using the Correct Calling Convention
    The library routines provided for RM/COBOL compatibility use a different calling convention to the Studio Enterprise Edition library routines. Therefore, programs that contain both types of library routine must explicitly specify the appropriate calling convention for one type or the other.
Parent topic: RM/COBOL Conversion Issues


Table Bound Checking

If you try to run a program under this COBOL system which contains a subscript value greater than the size of the table to which it refers, the run-time system will produce an error indicating this. Under the RM/COBOL system, however, no such table bound checking is done.

Therefore, if you wish to disable table bound checking in this COBOL system, you must use the NOBOUND directive.

If you use the NOBOUND directive when running intermediate code, you will be able to access data beyond a table's bounds by using a subscript value greater than the table size. Use of the NOBOUND directive when you are producing intermediate code will also disable bound checking when running generated code. However, if you wish to access data beyond a table's bounds when running generated code, you must also use the directive NOBOUNDOPT.

Note: When you use the NOBOUNDOPT directive, performance will be impaired.

Parent topic: Running the Code
Related reference
BOUND
BOUNDOPT


ACCEPT Fields at the Edge of the Screen

If your program contains an ACCEPT statement for a numeric data item at a position on the screen where the definition of the numeric data item would cause the ACCEPT field to go beyond the right-hand edge of the screen, both COBOL systems will truncate the input value. In RM/COBOL, the input value will be aligned into the ACCEPT field as an alphanumeric field, whereas in Studio Enterprise Edition, the input value is aligned as a numeric field.

Change the definition of the relevant PICTURE clause from numeric to alphanumeric. Alternatively, change the PICTURE clause so that the field does not go beyond the edge of the screen.

Example

If your program contains the following statement:

ACCEPT data-item AT COLUMN NUMBER 75.

where data-item is a numeric data item defined as PIC 9(10), a value of 123456 entered into the ACCEPT field will be held under Studio Enterprise Edition as "0000123456". However, in RM/COBOL, the value in the ACCEPT field would be held as "1234560000". To allow Studio Enterprise Edition to emulate the RM/COBOL behavior, alter the definition of the data item in your program to PIC X(10) or PIC 9(6).

Parent topic: Running the Code
Related reference
The ACCEPT Statement


COMPUTATIONAL-1 Data Items with a PICTURE other than S9(4)

In Studio Enterprise Edition, a COMPUTATIONAL-1 data item is assumed to have a picture-string of S9(4). In RM/COBOL, when a COMP-1 item is used as the source of a MOVE statement to an alphanumeric item, the picture clause is preserved.

To produce the result you require, you must alter the definition of the target of the MOVE statement.

Example

The following source code causes TEST-RECORD to hold"99 " in RM/COBOL, but"0099" in Studio Enterprise Edition.

 01 test-record                pic x(4).
 01 comp-1-item                pic 99 comp-1.
 procedure division.
    ...

     move 99 to comp-1-item.
     move comp-1-item to test-record.

To overcome this problem, alter the definition of TEST-RECORD as shown below:

 01 test-record.
     03 test-numeric-field     pic 99.
     03 filler      pic xx.
 01 comp-1-item                pic 99 comp-1.
 procedure division.
     ...
    move 99 to comp-1-item.
    move comp-1-item to test-numeric-field.

This avoids moving the COMPUTATIONAL-1 data item directly to an alphanumeric field.

Parent topic: Running the Code
Related information
COMPUTATIONAL-1 (COMP-1) Data Types
COMPUTATIONAL (COMP) Data Types
COMP/COMPUTATIONAL Data
COMPUTATIONAL-1, COMPUTATIONAL-2,FLOAT-SHORT and FLOAT-LONG Formats


Display of Input Data in Concealed ACCEPT Fields

If you have specified OFF and ECHO clauses for the same ACCEPT statement in your program, RM/COBOL will conceal any data entered during input for that statement but on completion of input will display the data. Studio Enterprise Edition will not display the data for this ACCEPT statement once input has been completed.

If you want to display the data input for an ACCEPT statement with the OFF and ECHO clauses specified, you must add a DISPLAY statement after the ACCEPT statement.

Parent topic: Running the Code
Related reference
The ACCEPT Statement


Embedded Control Sequences in DISPLAY Statements

In Studio Enterprise Edition, you cannot embedded control sequences within data items that you want to be displayed.

Such characters are ignored at run time as they are hardware dependent.

Remove the control sequences from your source program and replace with the equivalent Micro Focus COBOL syntax; for example, use the syntax WITH UNDERLINE to replace <left-arrow>]4m.

Parent topic: Running the Code
Related information
COBOL Language Reference


End of File Notification

The first time you unsuccessfully try to READ a sequential file in either COBOL system because you have reached the end of the file, status key 1 in the FILE STATUS is set to 1 and status key 2 is set to 0. This indicates that there is no next logical record. If you try to READ the same file again, without it either having been previously closed and reopened, or it having been successfully started, Studio Enterprise Edition continues to indicate that there is no next logical record. However, if you try to READ the same file again under RM/COBOL, status key 1 is set to 9 and status key 2 is set to 6.

A solution to the different file statuses returned for the circumstances given above will depend on the way in which your source program is coded. We suggest that you include tests for the values 1 and 0 in status key 1 and 2 of the file status, respectively, at the same time as you test for the values 9 and 6 in these status keys.

Parent topic: Running the Code
Related reference
The READ Statement


Environment Variables Used to Resolve File Names

In Studio Enterprise Edition, you are unable to use environment variables to resolve a file name at run time if you are using RMFM, the RM/COBOL file handler.

To configure the RM/COBOL file handler, you must use the CALLFH(ACUFH) Compiler directive. When this is set, the value of an environment variable will not resolve any file names you have set.

Parent topic: Running the Code
Related reference
CALLFH


Field Wrap-Around

If, when using binary data items (that is, RM/COBOL COMPUTATIONAL-1 format items) an arithmetic operation gives a value which exceeds the capacity of the data item, and there is no ON SIZE ERROR clause, Studio Enterprise Edition wraps-around the value of the item. However, in RM/COBOL, the data item is set to the limit of its capacity.

You should specify an ON SIZE ERROR clause to highlight such problems.

Example

In RM/COBOL, the following lines of code result in the value +32767 being stored in the data item, CALC-ITEM. However, Studio Enterprise Edition sets CALC-ITEM to -32768:

01 calc-item         pic s9(4)  comp-1.

 procedure division.
      ....
     move 32767 to calc-item.
     add 1 to calc-item.
Parent topic: Running the Code
Related information
COMPUTATIONAL-1 (COMP-1) Data Types


File and Record Locking

Certain versions of RM/COBOL contain some software errors in the way in which locks for files and records are handled. These errors do not occur in Studio Enterprise Edition.

The errors fixed when upgrading to Studio Enterprise Edition are:

  • Indexed files do not detect or acquire locks if they are opened for output. This is regardless of whether you specify the WITH LOCK phrase
  • Relative and sequential files cannot be locked exclusively
  • Files which are opened for input can detect record locks, although the RM/COBOL documentation states that they cannot. When the RM directive is set in Studio Enterprise Edition, record locks can still be detected by files opened for input
  • The first record in a sequential file opened for input-output is locked whenever any other record in that file is locked
Parent topic: Running the Code
Related reference
The OPEN Statement


Initialization of Working Storage

Studio Enterprise Edition initializes all working storage items without VALUE clauses to SPACES .The RM/COBOL system initializes all working storage items to SPACES, unless you have placed numeric data items between data items with VALUE clauses.

If this feature causes you any problems, because your program relies on the initial value given to the system, add a VALUE clause with the appropriate value to your source program and resubmit it.

Example

The RM/COBOL system initializes the following group item to SPACES:

01 group-item.
     03 item-1     pic x.
     03 item-2     pic 99.
     03 item-3     pic x.

However, if item-1 and item-3 have value clauses associated with them, the RM/COBOL system initializes the second byte of item-2 to hexadecimal value 0 when item-2 is defined as USAGE COMP (signed or unsigned) or USAGE DISPLAY (unsigned only).

Parent topic: Running the Code
Related reference
The VALUE Clause


Numeric Fields Containing Illegal Characters When Using a DEPENDING ON Phrase of an OCCURS Clause

In Studio Enterprise Edition, if you fail to initialize a numeric data item that is used in a DEPENDING ON phrase of an OCCURS clause appropriately, a COBRT163 Illegal character in numeric field error is displayed at run time, because the data item is initialized to SPACES if no value is specified. In RM/COBOL, the data item is initialized to ZERO, and therefore, the error does not occur.

Parent topic: Running the Code
Related reference
The OCCURS Clause
Related information
COBRT163 Illegal character in numeric field (Fatal)


ON SIZE ERROR Phrase

In Studio Enterprise Edition, the ON SIZE ERROR condition exists when the value resulting from an arithmetic operation exceeds the capacity of the specified picture-string. In RM/COBOL, the ON SIZE ERROR condition exists when the value resulting from an arithmetic operation exceeds the capacity for the associated data item.

Ensure that the capacity of any data items in your source programs is specified by a picture-string; for example, COMPUTATIONAL-1 data items.

Parent topic: Running the Code
Related information
The ON SIZE ERROR Phrase and NOT ON SIZE ERROR Phrase


Open EXTEND of Nonexistent File

In Studio Enterprise Edition, because setting the RM Compiler directive sets the NOOPTIONAL-FILE Compiler directive, if you try to open a non-existent file for I-O or EXTEND the run-time system will give an error message. For I-O, RM/COBOL does the same. However, for EXTEND, RM/COBOL creates the file and opens it as if you had specified OUTPUT.

The following options are available:

  • Add the keyword OPTIONAL to the SELECT statement. This makes Studio Enterprise Edition create the file and open it for OUTPUT
  • Create the empty file before running your program
  • Specify the OPTIONAL-FILE Compiler directive. This makes Studio Enterprise Edition create the file and open it for OUTPUT. However, the behavior with files opened for I-O will now differ from RM/COBOL
Parent topic: Running the Code
Related reference
OPTIONAL-FILE


Printer Output is Written to Disk

By default, Studio Enterprise Edition writes all output intended for a printer to disk.
To send output to a physical printer, you must map the filename using the dd_LPT1 environment variable or, if your system supports the lp printer spooler, you should use:
dd_LPT1=">lp";export dd_LPT1
Parent topic: Running the Code
Related information
Filename Mapping


Redefinition of COMP or COMP6 Data Items

Studio Enterprise Edition fully supports the size and capacity of RM/COBOL type COMPUTATIONAL and COMPUTATIONAL-6 data items when the RM Compiler directive is set. However, the internal representation of these data items in Studio Enterprise Edition and in RM/COBOL is not the same. See the chapter Compatibility with RM/COBOL in the product Help.

If this causes you problems, redefine these data items to take advantage of their internal format. MOVE the data items concerned to other data items which are not defined as COMPUTATIONAL or COMPUTATIONAL-6. Moving these data items converts the data automatically, overcoming any problems you might have.

Example

The following source code is coded to take advantage of the internal representation of COMPUTATIONAL-6 data items in RM/COBOL, and to analyze a date field:

 01 birthdate-1          pic 9(6) comp-6.
 01 birthdate-2 redefines birthdate-1.
     03 month-2         pic 99 comp-6.
     03 day-2           pic 99 comp-6.
     03 year-2          pic 99 comp-6.
     ....

 procedure division.
 start-up section.
 para-1.
     ....

     move 082462 to birthdate-1.
     ....

     if year-2 = 62
         display "records not available for 1962."

Amend your source program to use the DISPLAY format instead of redefining COMPUTATIONAL-6 data items, before submitting it to Studio Enterprise Edition:

 01 birthdate-1          pic 9(6) comp-6.
 01 birthdate-2 redefines birthdate-1.
     03 month-2         pic 99 comp-6.
     03 day-2           pic 99 comp-6.
     03 year-2          pic 99 comp-6.

 01 birthdate-1a         pic 9(6).
 01 birthdate-2a redefines birthdate-1a.
     03 month-2a        pic 99.
     03 day-2a          pic 99.
     03 year-2a         pic 99.
     ....

 procedure division.
 start-up section.
 para-1.
     ....

     move 082462 to birthdate-1.
     move birthdate-1 to birthdate-1a.
     ....

     if year-2a = 62
         display "records not available for 1962."
Parent topic: Running the Code
Related information
COMPUTATIONAL-6 (COMP-6) Data Types
COMP-6/COMPUTATIONAL-6 Data


Screen Column Number Specification

Studio Enterprise Edition permits you to specify screen column numbers up to and including 999, but RM/COBOL permits you to specify column numbers greater than 999. If you try to run an RM/COBOL source program containing a column number greater than 999 in Studio Enterprise Edition, the column number is truncated so that only the last three digits are used. If truncation of the column number occurs for an item to be displayed on the screen, the position of that item on the screen in Studio Enterprise Edition will differ from its position in RM/COBOL.

Parent topic: Running the Code
Related information
COBOL Language Reference


Trailing Blanks in Line Sequential Files

Studio Enterprise Edition always removes trailing blanks from line sequential records before writing the record. RM/COBOL removes trailing blanks from such records only if the FD entry contains 01 level records of different sizes. This will not cause you any problems when you run your converted RM/COBOL programs in Studio Enterprise Edition. However, you may receive errors at run time if any REWRITE operations on line sequential files change the length of the records.

Change the file organization to sequential, or move an alternative padding character (for example, LOW-VALUES) to the end of the record before it is written. This ensures that full-length records are written.

You also need to ensure that the T run-time switch is not set, as this might also change the size of the record. See Run-time Switches in the product Help.

Parent topic: Running the Code
Related reference
T run-time switch


Undefined Results of MOVE and Arithmetic Operations

Studio Enterprise Edition and RM/COBOL differ in the results of MOVE statements, arithmetic operations, and comparisons that involve numeric and alphanumeric data items.

You can overcome most of these incompatibilities by redefining the data items involved, or by recoding the comparisons. If you submit a program in Studio Enterprise Edition containing an alphanumeric to numeric data item MOVE statement, a warning message will be displayed indicating this.

Example

If you submit a source program containing the following data items and procedural statements, the specified test will fail at run time:

 01 numeric-field        pic 9(5).
 procedure division.
     move "abc" to numeric-field.
     if numeric-field = "00abc"
         ....

When the RM Compiler directive is set, Studio Enterprise Edition partially emulates the behavior of RM/COBOL for alphanumeric to numeric MOVEs by treating the numeric item as an alphanumeric item which is right justified. However, the above example will still fail because RM/COBOL treats the literal ABC as numeric, and places 00ABC in the numeric item. To make the statement run successfully in Studio Enterprise Edition, amend the test in the source program to:

     if numeric-field = " abc"

and resubmit the source program.

Parent topic: Running the Code
Related reference
The MOVE Statement
Related information
Arithmetic Operators


Using the Correct Calling Convention

To run the RM/COBOL library routines provided in Studio Enterprise Edition, you set the DIALECT(RM) Compiler directive, which sets the required calling convention. To run the Studio Enterprise Edition library routines, you use the standard COBOL calling convention.

If you have RM/COBOL compatible library routines and Studio Enterprise Edition library routines in the same program, do one of the following:

  • Set the DIALECT(RM) Compiler directive to enable the RM/COBOL library routines, then explicitly use the standard COBOL calling convention for the Studio Enterprise Edition library routines.
  • Explicitly use the 1024 calling convention for calls to the RM/COBOL compatible library routines if DIALECT(RM) is not set.
Parent topic: Running the Code


RM/COBOL File Handling

This COBOL system enables you to utilize RMFM, the RM/COBOL file handler.

  • Configuring the Micro Focus File Handler to Call RM/COBOL Data Files
    To use an RM/COBOL data file in your source code, you can configure the Micro Focus File Handler to call the RM/COBOL file handler.
  • RM/COBOL File Status Codes
  • Enabling CTF to Trace RM/COBOL Data Files
    Enable the Micro Focus Consolidated Tracing Facility (CTF) to trace activity with your RM/COBOL data files.
Parent topic: Compatibility with RM/COBOL


Configuring the Micro Focus File Handler to Call RM/COBOL Data Files

To use an RM/COBOL data file in your source code, you can configure the Micro Focus File Handler to call the RM/COBOL file handler.

To configure Studio Enterprise Edition to use an RM/COBOL data file:

  • Set the CALLFH(ACUFH) Compiler directive.
    Note: Access to the RM/COBOL file handler is routed via Vision, the ACUCOBOL/GT native indexed sequential file system.
  • Set environment variable A_CONFIG to the path of a configuration file:
    set A_CONFIG=acurmfm.cfg		*> acurmfm.cfg is your configuration file.
  • In acurmfm.cfg, set the file handler:
    DEFAULT_FILESYSTEM RMFM

Comments:

The following list contains a number of supported RM/COBOL additional configurations that you can add to your configuration file:

  • RMFM_DEFINE_DEVICE

  • RMFM_EXTERNAL_ACCESS_METHOD

  • RMFM_EXTERNAL_ACCESS_METHOD_RMPLUSDB_CREATE_FILES

  • RMFM_EXTERNAL_ACCESS_METHOD_RMPLUSDB_OPTIONS

  • RMFM_EXTERNAL_ACCESS_METHOD_RMINFOX_CREATE_FILES

  • RMFM_EXTERNAL_ACCESS_METHOD_RMINFOX_OPTIONS

  • RMFM_EXTERNAL_ACCESS_METHOD_USRRMTACC_CREATE_FILES

  • RMFM_EXTERNAL_ACCESS_METHOD_USRRMTACC_OPTIONS

  • RMFM_EXTERNAL_ACCESS_METHOD_RMBTRV_CREATE_FILES

  • RMFM_EXTERNAL_ACCESS_METHOD_RMBTRV_OPTIONS

  • RMFM_EXTERNAL_ACCESS_METHOD_RMBTRV32_CREATE_FILES

  • RMFM_EXTERNAL_ACCESS_METHOD_RMBTRV32_OPTIONS

  • RMFM_EXTERNAL_ACCESS_METHOD_RMTCP32_CREATE_FILES

  • RMFM_EXTERNAL_ACCESS_METHOD_RMTCP32_OPTIONS

  • RMFM_PRINT_ATTR_AUTO_LINE_FEED

  • RMFM_PRINT_ATTR_COLUMNS

  • RMFM_PRINT_ATTR_FORM_FEED_AVAILABLE

  • RMFM_PRINT_ATTR_LINAGE_INITIAL_FORM_POSITION

  • RMFM_PRINT_ATTR_LINAGE_PAGES_PER_PHYSICAL_PAGE

  • RMFM_PRINT_ATTR_LINES

  • RMFM_PRINT_ATTR_TOP_OF_FORM_AT_CLOSE

  • RMFM_PRINT_ATTR_WRAP_COLUMN

  • RMFM_PRINT_ATTR_WRAP_MODE

  • RMFM_RUN_FILES_ATTR_ALLOW_EXTENDED_CHARS_IN_FILENAME

  • RMFM_RUN_FILES_ATTR_BLOCK_SIZE

  • RMFM_RUN_FILES_ATTR_BUFFER_POOL_SIZE

  • RMFM_RUN_FILES_ATTR_DEFAULT_USE_PROCEDURE

  • RMFM_RUN_FILES_ATTR_DISABLE_LOCAL_ACCESS_METHOD

  • RMFM_RUN_FILES_ATTR_ENABLE_OLD_DOS_FILENAME_HANDLING

  • RMFM_RUN_FILES_ATTR_EXPANDED_PATH_SEARCH

  • RMFM_RUN_FILES_ATTR_FATAL_RECORD_LOCK_TIMEOUT

  • RMFM_RUN_FILES_ATTR_FILE_LOCK_LIMIT

  • RMFM_RUN_FILES_ATTR_FILE_PROCESS_COUNT

  • RMFM_RUN_FILES_ATTR_FORCE_USER_MODE

  • RMFM_RUN_FILES_ATTR_KEEP_FLOPPY_OPEN

  • RMFM_RUN_FILES_ATTR_LARGE_FILE_LOCK_LIMIT

  • RMFM_RUN_FILES_ATTR_RESOLVE_LEADING_NAME

  • RMFM_RUN_FILES_ATTR_RESOLVE_SUBSEQUENT_NAMES

  • RMFM_RUN_FILES_ATTR_SKIP_INITIAL_CWD_SEARCH

  • RMFM_RUN_FILES_ATTR_USE_PROCEDURE_RECORD_LOCK_TIMEOUT

  • RMFM_RUN_INDEX_FILES_ALLOCATION_INCREMENT

  • RMFM_RUN_INDEX_FILES_BLOCK_SIZE

  • RMFM_RUN_INDEX_FILES_DATA_COMPRESSION

  • RMFM_RUN_INDEX_FILES_DEFAULT_FILE_VERSION_NUMBER

  • RMFM_RUN_INDEX_FILES_ENABLE_ATOMIC_IO

  • RMFM_RUN_INDEX_FILES_FORCE_CLOSED

  • RMFM_RUN_INDEX_FILES_FORCE_DATA

  • RMFM_RUN_INDEX_FILES_FORCE_DISK

  • RMFM_RUN_INDEX_FILES_FORCE_INDEX

  • RMFM_RUN_INDEX_FILES_KEY_COMPRESSION

  • RMFM_RUN_INDEX_FILES_MINIMUM_BLOCK_SIZE

  • RMFM_RUN_INDEX_FILES_PREVENT_WRITE_STARVATION

  • RMFM_RUN_INDEX_FILES_ROUND_TO_NICE_BLOCK_SIZE

  • RMFM_RUN_INDEX_FILES_USE_LARGE_FILE_LOCK_LIMIT

  • RMFM_RUN_REL_FILES_BLOCK_SIZE

  • RMFM_RUN_REL_FILES_USE_LARGE_FILE_LOCK_LIMIT

  • RMFM_RUN_SEQ_FILES_BLOCK_SIZE

  • RMFM_RUN_SEQ_FILES_DEFAULT_TYPE

  • RMFM_RUN_SEQ_FILES_DEVICE_SLEWING_RESERVE

  • RMFM_RUN_SEQ_FILES_TAB_STOPS

  • RMFM_RUN_SEQ_FILES_USE_LARGE_FILE_LOCK_LIMIT

Refer to the RM/COBOL User's Guide for full details of these configurations.

Parent topic: RM/COBOL File Handling


RM/COBOL File Status Codes

RM/COBOL file status codes are either ANSI'74 file status codes or can be mapped onto extended file status codes, as shown below.

Status Key 1 | Status Key 2 | Extended File Status Code | Description
9 | 0 | 9/143 | REWRITE/DELETE not after successful READ
 |  | 9/147 | Wrong open or access mode for READ/ START.
 |  | 9/148 | Wrong open or access mode for WRITE.
 |  | 9/149 | Wrong open or access mode for REWRITE/ DELETE.
 | 1 | 9/142 | File not open - cannot be closed.
 | 2 | 9/141 | File already open - cannot be opened.
 | 3 | 9/138 | File is closed with lock - cannot open.
 |  | 9/210 | File is closed with lock.
 | 4 | 9/013 | File not found.
 |  | 9/035 | Incorrect access permission.
 |  | 9/037 | File access denied.
 |  | 9/139 | Record length or key inconsistent.
9 | 4 | 9/188 | Filename too large.
 | 6 | 9/146 | No current record defined for sequential read.
 | 8 | 9/071 | Bad indexed file format.
 | 9 | 9/065 | File locked.
 |  | 9/068 | Record is locked.
Parent topic: RM/COBOL File Handling
Related concepts
C$RERR


Enabling CTF to Trace RM/COBOL Data Files

Enable the Micro Focus Consolidated Tracing Facility (CTF) to trace activity with your RM/COBOL data files.

To enable CTF:

  • Set the following environment variables:

    set MFTRACE_CONFIG=ctf.cfg
set MFTRACE_LOGS=pathname   *> if not set, logs are stored in the current folder.

  • In ctf.cfg, set the following:

    mftrace.dest                = textfile
mftrace.level.mf.rts        = info
mftrace.comp.mf.rts#eprintf = true
  • Set the following environment variable:
    set A_CONFIG=rmfm.cfg    *> rmfm is your RMFM configuration file

  • In rmfm.cfg, set the following:

    DEFAULT_FILESYSTEM RMFM
FILE_TRACE 3   *> values 0-9 set amount of activity traced.

When you run your program, a log-file is produced that includes the activity with the RM/COBOL data files.

For more information on CTF, see Introduction to the Consolidated Tracing Facility.

Parent topic: RM/COBOL File Handling
Related information
Introduction to the Consolidated Tracing Facility


Compatibility with XML Extensions

Note: This functionality is supported in native COBOL only.

XML Extensions has many capabilities. The major features support the ability to import and export XML documents to and from COBOL working storage. Specifically, XML Extensions allows data to be imported from an XML document by converting data elements (as necessary) and storing the results into a matching COBOL data structure. Similarly, data is exported from a COBOL data structure by converting the COBOL data elements (as necessary) and storing the results in an XML document.

For more information about XML Extensions, refer to the XML Extensions User's Guide, available from the RM/COBOL product documentation set, in the SupportLine section of the Micro Focus Web site.

For RM/COBOL users that utilize XML Extensions, here is a summary of compatibility issues that you need to be aware of when working in this COBOL system. Refer to this list and the RM/COBOL Conversion Issues list in the Compatibility with RM/COBOL section

Click a summary title for a fuller explanation and workaround, where possible.

  • Additional Parameter Required with XML Extensions Processing Statements
    In statements that use a Document Pointer parameter, you are also required to pass an additional Document Length parameter.
  • COBOL programs using BIS
    Programs in this COBOL system that are used with the Xcentrisity Business Information Server (BIS) must end with the GOBACK statement, not the STOP RUN statement. Also, messages for the BIS trace log must be generated by calling the B$Trace library program, not the DISPLAY statement.
  • Conflicts Between Model File-names and XML Data Files
    In this COBOL system, model file-names, as created by the compiler, are of the form program-name.xml. You should ensure your XML data files do not share the same name as this, to avoid any conflicts.
  • Displaying the Status of XML Extensions Statements
    In this COBOL system, use the XML-Status-Edited data item to display the status result of an XML Extensions statement execution.
  • Importing and Exporting Ambiguous Data-names
    When attempting to import or export an ambiguous model data-name, this COBOL system now displays a warning.
  • Invalid Characters in Condition Names
    In this COBOL system, if you use mark-up characters as values for condition names, this can produce invalid XML when exporting code using XML Extensions.
  • Restricted data items with XML Extensions
    In this COBOL system, you cannot use data items described in any section other than the File or Working Storage Sections, as model data names.
  • Unable to Use Data Items Declared in Nested Programs
    In this COBOL system, you cannot use data items declared in nested programs, as model data-names.
  • User-names Longer than 127 Bytes are Truncated
    In RM/COBOL, you can specify user-names (data-names, procedure-names, program-names, etc) up to 240 characters long. In this COBOL system, user-names longer than 127 bytes in length are truncated and a warning message is produced.
  • Using the Correct Calling Convention
    XML Extensions uses a different calling convention to the one used by the standard library routines implemented for RM/COBOL compatibility.
Parent topic: Compatibility with RM/COBOL


Additional Parameter Required with XML Extensions Processing Statements

In statements that use a Document Pointer parameter, you are also required to pass an additional Document Length parameter.

When using XML Extensions processing statements, each Document Pointer parameter must be immediately followed by a Document Length parameter. This applies to the following statements:

  • XML EXPORT TEXT
  • XML IMPORT TEXT
  • XML TEST WELLFORMED-TEXT
  • XML VALIDATE TEXT
  • XML GET TEXT
  • XML PUT TEXT
  • XML TRANSFORM TEXT
Note: XML FREE TEXT does not require that you use the Document Length parameter.

Solution:

Ensure that the Document Length parameter (MY-DOCUMENT-LENGTH) is specified immediately following the Document Pointer parameter (MY-DOCUMENT-POINTER) when calling an XML Extensions processing statement:

When the statement is outputting data, the statement will set MY-DOCUMENT-LENGTH:

XML EXPORT TEXT
    MY-DATA-ITEM
    MY-DOCUMENT-POINTER
    MY-DOCUMENT-LENGTH
    "MY-MODEL-FILE".
IF NOT XML-OK GO TO Z.

When the statement is inputting data, you must set MY-DOCUMENT-LENGTH before the statement is processed:

XML IMPORT TEXT
    MY-DATA-ITEM
    MY-DOCUMENT-POINTER
    MY-DOCUMENT-LENGTH			*> The size of the data item pointed to by MY-DOCUMENT-POINTER.
    "MY-MODEL-FILE".
IF NOT XML-OK GO TO Z.
Parent topic: Compatibility with XML Extensions


COBOL programs using BIS

Programs in this COBOL system that are used with the Xcentrisity Business Information Server (BIS) must end with the GOBACK statement, not the STOP RUN statement. Also, messages for the BIS trace log must be generated by calling the B$Trace library program, not the DISPLAY statement.

Programs that are used with the BIS must not use the STOP RUN statement, as this will terminate the MF run-time prematurely and the BIS will be unable to process any further web service requests.

In RM/COBOL, programs that are used with BIS capture the output of a DISPLAY statement and place it in the BIS trace log. In this COBOL system, to place messages in the BIS trace log, use the B$Trace library routine.

Solutions:

To ensure that programs used with the BIS do not prematurely terminate the MF run-time, use the GOBACK statement in those programs.

To place messages in the BIS trace log, call the B$Trace library program, using the same identifiers or literals, but not figurative constants, that you would use in a DISPLAY statement.
Note: Numeric data items can be of any data type and are converted to a numeric string by B$Trace.
call "B$Trace" using "Log message: " MyMessage " " MyStatus.
Parent topic: Compatibility with XML Extensions


Conflicts Between Model File-names and XML Data Files

In this COBOL system, model file-names, as created by the compiler, are of the form program-name.xml. You should ensure your XML data files do not share the same name as this, to avoid any conflicts.

In this COBOL system, if the ModelFileName#DataName parameter does not include a hash, it is always treated as a model data-name, and the model file-name is assumed to be program-name.xml for the program (or one of its callers) that executed an XML Extensions export or import statement. With this in mind, if you do not explicitly set a model file-name, you should ensure that your XML data files do not share the same name as your COBOL programs when performing import and export XML Extensions statements.

Solution:

To avoid conflicts between model file-names and XML data file-names, do one of the following:

  • Ensure you set the DocumentName parameter in your import and export statements to a name other than your COBOL program name.

  • If you want to keep your XML data file-names the same as the program-name, rename the model file-name after compilation and specify the new name in the value of the ModelFileDataName parameter before the hash, separating it from the ModelDataName.

When using the second technique, it is recommended that the compilation be done with a script that includes the renaming command, to avoid forgetting this step.

Notes:

In RM/COBOL, you can use the environment variable RM_MISSING_HASH to determine the meaning of the ModelFileDataName parameter when the hash is omitted. In this COBOL system, the environment variable is not supported.

Also, RM/COBOL v12 and later generally did not use model files because the model was embedded in the object program file; this COBOL system is more like RM/COBOL v11 and earlier, which always used model files. Thus, care must be taken to distribute model files with applications that use XML Extensions.

Parent topic: Compatibility with XML Extensions


Displaying the Status of XML Extensions Statements

In this COBOL system, use the XML-Status-Edited data item to display the status result of an XML Extensions statement execution.
In RM/COBOL, XML-Status, the data item used to display the status result of an XML Extensions statement execution, is defined as Display Usage. In this COBOL system, XML-Status is defined as:
03 XML-Status		PIC S9(4) COMP-5.
Therefore, an additional declaration is made in lixmldef.cpy, so that you can easily use the status result in your code:
03 XML-Status-Edited		PIC +9(4).
When an XML Extensions statement is executed, the value of XML-Status-Edited is not set, so you need move XML-Status to XML-Status-Edited before you can use the result.
Parent topic: Compatibility with XML Extensions


Importing and Exporting Ambiguous Data-names

In RM/COBOL, if you attempt to export an ambiguous data-item to a model file, an error is produced. If you attempt to import to an ambiguous data-item, the data is placed in the first occurrence of the named data-item.

In this COBOL system, if you attempt to export an ambiguous data-item to a model file, a warning message is produced and the first occurrence of the named data-item is exported. Similarly, If you attempt to import to an ambiguous data-item, a warning message is displayed and the data is placed in the first occurrence of the named data-item.

Example:

01 Group01.
    02 GroupA.
      03 NumItem	 PIC s9(5).
      03 StrItem	 PIC X(5).
        02 GroupB.
          03 NumItem  PIC s9(5).
          03 StrItem  PIC X(5).

--------------------------------
<StrItem> ABCDE </StrItem>   *> this produces a warning and updates StrItem in GroupA

<GroupB><StrItem> ABCDE </StrItem></GroupB>  *> this updates StrItem in GroupB
Parent topic: Compatibility with XML Extensions


Invalid Characters in Condition Names

In this COBOL system, if you use mark-up characters as values for condition names, this can produce invalid XML when exporting code using XML Extensions.

Mark-up characters, such as "<", ">" or "&" used in the values for condition names will produce invalid model files when using XML Extensions. The model files will cause parse errors when loaded by XML Extensions using the XML parser; XML Extensions will report the parse error and be unable to perform the requested export or import.

88 cond-name VALUE "<br/>".

Solution:

In this COBOL system, you must modify the COBOL source code, to eliminate mark-up characters in condition-name values.

Parent topic: Compatibility with XML Extensions


Restricted data items with XML Extensions

In this COBOL system, you cannot use data items described in any section other than the File or Working Storage Sections, as model data names.

To export data items from or import XML data into this COBOL system, use the XMLGEN Compiler directive to create a model file, for use with XML Extensions.

The model data names specified in the model file are determined by XMLGEN:
  • XMLGEN with no parameter specified produces model data names for data items/structures in the File Section only.
  • XMLGEN(ws) produces model data names for data items/structures in the Working Storage Section only.
Important: Data items/structures described in the Linkage Section, Communication Section, Local-Storage Section and Thread-Local-Storage Section cannot be used as model data names in a model file.

Solution:

Using a copybook containing your data items, compile a dummy program that copies the descriptions into the Working Storage section, and then use the XMLGEN(ws) Compiler directive to create a model file containing the required data items.

Notes:

The data items used at runtime when the model file is used can be in any section of the data division.

Parent topic: Compatibility with XML Extensions


Unable to Use Data Items Declared in Nested Programs

In this COBOL system, you cannot use data items declared in nested programs, as model data-names.

Solution:

Using a copybook containing your data items, compile a dummy program that copies the descriptions into the Working Storage section of your top-level program, and then use the XMLGEN(ws) Compiler directive to create a model file containing the required data items.

Parent topic: Compatibility with XML Extensions


Using the Correct Calling Convention

In this COBOL system, XML Extensions uses the standard COBOL calling convention. If your programs are also using the standard library routines, implemented for RM/COBOL compatibility, you need to be aware that these are called using the 1024 calling convention.

Solution:

If you set the DIALECT"RM" Compiler directive, the correct calling convention will be enabled for all entry points and CALL statements, for use of the standard library routines. If this is set, you must explicitly use the standard COBOL calling convention for your XML Extensions calls.

If you do not set the DIALECT"RM" Compiler directive, the correct calling convention will be enabled for all entry points and CALL statements, for use of XML Extensions. If this is not set, you must explicitly use the 1024 calling convention for the standard library routine calls.

Parent topic: Compatibility with XML Extensions


Java and COBOL

You can use COBOL and Java together, by coding the calls using the supplied support libraries.

Restriction: This applies to native code only.
  • Using Java and COBOL Together
    This chapter introduces the different ways that Java and COBOL applications can call each other.
  • Deploying a Java Service Interface and Using Resource Adapters
  • Calling Procedural COBOL from Java
    This chapter describes how you can access legacy procedural COBOL programs from Java using the support provided in the com.microfocus.cobol.RuntimeSystem class.
  • Calling Java from OO COBOL
    This chapter shows you how to code a COBOL program to call Java methods using the OO COBOL Java domain.
  • Calling OO COBOL from Java
    This chapter describes how you can access COBOL objects from Java programs. This is slightly different from the method for accessing procedural COBOL from Java programs.
  • Java Data Types
    This chapter describes how COBOL and Java data types are mapped on to each other.
Parent topic: Compatibility


Using Java and COBOL Together

This chapter introduces the different ways that Java and COBOL applications can call each other.
Restriction: This applies to native code only.
  • Overview
  • Setting Up the Environment for Java and COBOL
  • Compiling COBOL Programs that Call Java
  • Compiling COBOL Programs that Are Used from the CobolBean interface
  • Linking to the Multi-threaded Run-time System
Parent topic: Java and COBOL


Overview

Restriction: This applies to native code only.

You can use COBOL and Java together, by coding the calls using the supplied support libraries. You can also use the Interface Mapping Toolkit Java itself provides access to other technologies, such as Remote Method Invocation (RMI) and Java Naming and Directory Interface (JNDI) which enable you to distribute objects across different machines.

You can use COBOL and Java together by:

  • Mapping a Java interface onto procedural COBOL, using the Interface Mapping Toolkit, thereby exposing COBOL services without changing the COBOL code. The new interface then needs deploying, which involves deploying the generated EJB to J2EE and deploying the COBOL service to an enterprise server. At run time, the EJB running under J2EE calls the COBOL code, which runs under the control of an enterprise server.
  • Calling procedural COBOL from Java, using the support provided in the com.microfocus.cobol.RuntimeSystem class. This class is extended to provide the CobolBean class. This RuntimeSystem class support also enables you to call Java from procedural COBOL, through the Java Native Interface (JNI). This is ideal for use with Java 2 Standard Edition (J2SE).
  • Calling Java from OO COBOL, using the Java object domain for OO COBOL. This is ideal for use with Java 2 Standard Edition (J2SE).
  • Calling OO COBOL from Java, creating a Java wrapper class that provides a function for each method in the OO COBOL class. This is ideal for use with Java 2 Standard Edition (J2SE).

You use Server Enterprise Edition for running the other types of applications that use both COBOL and Java programs. Server Enterprise Edition with Enterprise Server is required to run legacy programs exposed using the Interface Mapping Toolkit.

The Java language defines its own data types, which are different to the ones used in COBOL. The COBOL run-time system automatically converts between COBOL and Java types whenever you call Java from COBOL or COBOL from Java. Where a COBOL data type cannot be translated directly (for example, edited fields), it is under some circumstances translated to a string.

Parent topic: Using Java and COBOL Together


Setting Up the Environment for Java and COBOL

Restriction: This applies to native code only.

You need a Java run-time system on any machine that is going to execute Java applications. If you are going to develop mixed Java and COBOL applications, you also need a Java development environment. You can use either the Java Software Development Kit (SDK) available from Oracle, or any Java IDE which is based on either the Oracle or Microsoft Java run-time environments. Alternatively you can have a Java Virtual Machine (JVM), which provides both a development environment and a run-time environment.

Your COBOL development system currently supports several Java run-time systems.

Before you start writing COBOL and Java programs which interact, you need to set up the following environment variables for the COBOL and Java run-time systems:

  • PATH

    If you are using the Java run-time system from Oracle, the jvm.dll file must be available. Do not move jvm.dll to a different location, because it has dependencies on other files shipped as part of the Java run-time system. The location of this file depends on which version of the JDK you are using. To ensure the file is available, add it to the system PATH. For example:

    set path=jdk-install-directory\bin\subdirectory;%path%

    Where subdirectory might be client, classic, hotspot or server.

    If you generate EJBs or Java beans using the Interface Mapping Toolkit, the Java Compiler must be available. To do this, put the bin directory of JDK on the PATH. For example:
    set path=jdk-install-directory\bin;%path%
  • CLASSPATH

    If you have Java programs that call COBOL, you need to provide access to the Java classes that interface to the COBOL run-time system. To do this, ensure that mfcobol.jar is specified by the CLASSPATH environment variable. For example:

    set classpath=install-directory\base\bin\mfcobol.jar;%classpath%;.;

    Alternatively, you can set the classpath when you run a Java program, using the -classpath switch. For example:

    java -classpath ".;install-directory\base\bin\mfcobol.jar;%classpath%" MyClass
    If you generate EJBs or Java beans using the Interface Mapping Toolkit, the tools.jar of the JDK must be on the CLASSPATH. For example:
    set classpath=jdk-install-directory\lib\tools.jar;%classpath%;.;
  • Shared library path

    The operating system's shared library path must include the directory containing libjava. This is often found in a subdirectory of Java's jre/lib directory, although the name of this directory is specific to each platform. On some platforms, you might need to specify more than one directory for this, for example, an additional directory containing the Java native threading support.

Parent topic: Using Java and COBOL Together
Related reference
Using the Java/COBOL Application Launcher from the Command Line


Compiling COBOL Programs that Call Java

Restriction: This applies to native code only.

Any COBOL program which is going to call Java must be compiled with the following directive:

ooctrl(+p-f)

This does two things:

  • Adds type information to invoke statements, which the COBOL run-time system needs to convert data correctly between the COBOL and Java domains
  • Prevents the compiler from folding method names it invokes to lower-case - Java method names are case-sensitive
Parent topic: Using Java and COBOL Together


Compiling COBOL Programs that Are Used from the CobolBean interface

Restriction: This applies to native code only.

Any COBOL program which is going to be called from Java using CobolBean.cobcall*() methods should be compiled with the DATA-CONTEXT Compiler directive. This enables the run-time system to create new application storage areas for each instance of a CobolBean that is created.

Parent topic: Using Java and COBOL Together


Linking to the Multi-threaded Run-time System

Restriction: This applies to native code only.

All COBOL programs for use with Java must be linked to the multi-threaded run-time system.

Parent topic: Using Java and COBOL Together


Deploying a Java Service Interface and Using Resource Adapters

You can expose procedural COBOL as EJBs or Java beans by using the Service Interfaces feature to map an interface onto your COBOL program.

The COBOL service inteface then needs to be deployed as a service to an enterprise server. The COBOL service comprises the mapping information and the original COBOL. You can deploy the service interface automatically by deploying from your Visual Studio project, or you can do it manually in one of the following ways:

  • You deploy the EJB to a Java 2 Enterprise Edition (J2EE) application server and also deploy a resource adapter to handle the connection between the J2EE application server and the enterprise server.
  • You run the Java bean in a Java 2 Standard Edition (J2SE) environment. The bean accesses the enterprise server directly, without a resource adapter. This avoids using a J2EE application server, but you lose the management and transaction support that it provides.
  • You ignore the EJB or Java bean generated and write your own Java, which uses an unmanaged connection to call the resource adapter and send the request to an enterprise server.

At run time, your client application makes Java requests and invokes the generated EJB or Java bean. The EJB uses the resource adapter to pass the requests to an enterprise server, which in turn runs the exposed COBOL. Tha Java bean pass the requests to the enterprise server directly.

The mapping information is used at run time to pass data to and from the exposed COBOL. The enterprise server returns the response to the EJB through the resource adapter or directly to the Java bean. The EJB or bean passes the response on to the client.

Note: Re the JNDI name for the resource adapter, the resource adapter's reference name (also called its coded name) is CCIMFCobol_v1.0, which is the name of the connection factory. The JNDI name that you specify is eisMFCobol_v1.0. You must use the names stated here.
  • EJB and Client Generation
  • Deployment Descriptors that Are Generated
  • Manifest Files
  • CustomRecord and Other Java Support
  • Calling the Generated EJB or Java Bean
  • Using Java Beans under J2SE
  • Overview of Using an Unmanaged Connection under J2SE
Parent topic: Java and COBOL


EJB and Client Generation

The EJB is generated automatically when you deploy your service interface and generate clients.

The generated EJB and optional client are packaged into archive files (.jar, .war and .ear), together with manifest files and deployment descriptors. These files are located in the directory structure under myservice\myservice.deploy . The following archive files are created:

  • myservice.jar, which contains the EJB classes and other files.
  • myservice.war, which contains the client JSP and other files.
  • myservice.ear, which contains the .jar file and the client .war file among others. This .ear file contains everything to deploy the EJB to the supported third party application servers, without further changes. For other application servers, you need to create deployment descriptors, and this is described later.

You can view the contents of these archive files using the jar command or through a zip utility such as Winzip.

  • Application Ear File
  • Client War File
  • EJB Jar File
Parent topic: Deploying a Java Service Interface and Using Resource Adapters
Parent topic: Generating Clients


Application Ear File

When you generate a client for an EJB, the EJB and the client are packaged together into an enterprise archive file myService.ear file together with the following files:

application.xml | Generic deployment descriptor, defining the .jar and the client .war files
myService.jar | EJB archive file
myService.war | Client archive file
manifest.mf | Manifest describing this .jar file
mfejlib.jar | Custom records
Parent topic: EJB and Client Generation


Client War File

When you generate a client for an EJB , it is packaged into a Web archive file myService.war file together with the following files:

*.jsp | JSP files. These pass data back and forth between the end user and the servlet.
myServiceJspBean.class | This file contains the getter and setter methods that are used to move information back and forth between the servlet and JSP.
myServiceServlet.class | This file is the servlet. It processes the incoming requests from the JSP, invokes an instance of the stateless EJB, and forwards the response back to the JSP.
myServiceSessionMonitor.class | This is a helper class, which stores the EJB instances for the stateful session bean.
manifest.mf | Manifest describing this .war file
mfejlib.jar | .. custom records
web.xml | Generic deployment descriptor, defining the client servlet and the EJB reference
*.xml, such as weblogic.xml | For some J2EE application servers (such as WebLogic), a deployment descriptor for deploying the .war file to that application server
Parent topic: EJB and Client Generation


EJB Jar File

When you generate an EJB, it is packaged into a Java archive file (myService.jar) together with the following files:
ejb-jar.xml | Generic deployment descriptor, defining the EJB
myServiceBean.class | Bean class for the EJB
myServiceHome.class | Home interface for the EJB
myService.class | Remote interface for the EJB
myRecord.class | custom record, if needed by the EJB
manifest.mf | Manifest describing this .jar file
*.xml, such as weblogic-ejb-jar.xml | For some J2EE application servers (such as WebLogic), a deployment descriptor for deploying the EJB to that application server

The source code for the EJB classes are generated in the directory com\mypackage\myService .

Parent topic: EJB and Client Generation


Deployment Descriptors that Are Generated

Deployment descriptors are xml files containing deployment information, such as the settings you specify in the Interface Mapping Toolkit. J2EE application servers require deployment descriptors for the archive files (.jar, .war and .ear) to be deployed. At run time, the J2EE application server reads the descriptors and acts accordingly. Deployment descriptors are not required for the generated Java beans.

When you generate an EJB or client, the following generic deployment descriptors are created and packaged into the relevant archive files:

  • application.xml, which defines and is packaged in the enterprise archive file (.ear)
  • ejb-jar.xml, which defines and is packaged in the EJB Java archive file (.jar) to be deployed.
  • web.xml, which defines and is packaged in the Web archive file (.war) to be deployed.

Some J2EE application servers require additional deployment descriptors in the archive files. These descriptors are generated automatically for the supported application servers.

If your application server requires additional deployment descriptors and these are not generated, you need to create them manually and add them to the archive files.

Parent topic: Deploying a Java Service Interface and Using Resource Adapters
To create deployment descriptors manually


Manifest Files

When you generate an EJB, a manifest file manifest.mf is included in each archive file that is generated. The manifest file specifies the information needed by the files in the archive. For example:

  • The manifest for myService.jar defines the classpath for mfejblib.jar, which provides the Micro Focus support for the CustomRecord and RuntimeProperties interfaces.
  • The manifest for myService.war defines the classpath for mfejblib.jar and for myService.jar.

Notice that the manifest file mandates that mfejblib.jar is in the root of the deployed archive file by specifying the classpath as follows:

Class-path: mfejblib.jar

You must ensure that the mfejblib.jar is in that location. Alternatively, if you require mfejblib.jar to be elsewhere, you can change the classpath accordingly.

Parent topic: Deploying a Java Service Interface and Using Resource Adapters


CustomRecord and Other Java Support

If your EJB or Java bean uses custom records you need to make sure that support for them is available. Custom records are created if you map COBOL group items onto Java data types. You map group items in the Interface Mapper whenever you set up Reusable Mappings for group items and you then make those group items into complex interface fields.

For Java beans, support for the CustomRecord and the RuntimeProperties interfaces is provided in mfj2se.jar, which is supplied in the ...\base\bin directory of your installation. This support must be available at run time, and you can ensure this by putting mfj2se.jar on the classpath. For example, you could run your application, with the command:.

java –classpath class-directory\mfj2se.jar myProgram.class

For EJBs, support for the CustomRecord and the RuntimeProperties interfaces is provided in mfejblib.jar. This support is automatically included in the application .ear file when you generate a client for the EJB. When the Deploy tool creates the EJB, it adds a manifest file manifest.mf to the .jar file, and in that manifest file it sets the classpath to mfejblib.jar.

If you create a client manually, you need to add the mfejblib.jar to your .ear file, manually. There are two versions of the file: one for J2EE 1.3 and one for J2EE 1.4, and these are available in the base\bin\j2ee13 and base\bin\j2ee14 directories. By default, the mfejblib.jar file belongs in the root of the .ear file, because the classpath to mfejblib.jar is set to the root in the manifest.mf file of the EJB's .jar file.

You can view this manifest file by extracting it from the EJB's archive file, myservice.jar, which is in myproject \Repos\.deploymyservice. Notice that the classpath is set as follows:

Class-path: mfejblib.jar

If you require mfejblib.jar to be elsewhere, you need to change the classpath in manifest.mf in the EJB's jar file accordingly.

Parent topic: Deploying a Java Service Interface and Using Resource Adapters


Calling the Generated EJB or Java Bean

You need to write some Java client software to call the generated EJB or Java bean and to pass it the parameters required for the COBOL service. This client software might be a JSP or a servlet or some other module.

The EJB or Java bean interface is defined in the Interface Mapping Toolkit. Typically, you find out the interface by importing the EJB or Java bean into a Java development tool and investigating the interface there. One point to note is with regard to output parameters. If the mapped interface passes multiple output parameters (rather than using a group item and its corresponding custom record), the output parameters are returned through a container object in the EJB or Java bean interface. You can see this in your Java development tool.

At run time, the Java client software calls the EJB or Java bean. The EJB passes the request to the resource adapter, which communicates with the enterprise server to execute the COBOL service. The Java bean communicates with the enterprise server directly.

Parent topic: Deploying a Java Service Interface and Using Resource Adapters


Using Java Beans under J2SE

You can bypass the J2EE application server and the resource adapter, by generating a Java bean that accesses the COBOL enterprise server directly. Although this avoids the overhead of administering a J2EE application server, you lose its advantages such as transaction support.

The Java bean generated is stateless. One class is generated for the bean and other classes are generated for any data classes representing the records that are mapped.

The Java bean runs in a J2SE environment with the libraries from the J2EE server. The Java bean accesses the COBOL enterprise server directly, in an out-of-process manner. The J2SE and enterprise server run in two separate processes and they communicate through sockets.

You need to write your client software to call the Java bean.

Support for the Java bean is supplied in mfj2se.jar, which is available in the base\bin directory.

To trace the behavior of the Java bean, use the –Dmfdebug=true switch. For example run the program myBean as follows:

java –Dmfdebug=true myBean
Parent topic: Deploying a Java Service Interface and Using Resource Adapters


Overview of Using an Unmanaged Connection under J2SE

  • Using an Unmanaged Connection under J2SE
    You can bypass the J2EE application server by writing your own code to call the resource adapter and send the request to an enterprise server.
  • Writing a Simple CCI Program
    The sample code in this section demonstrates Java code requesting a COBOL service.
Parent topic: Deploying a Java Service Interface and Using Resource Adapters


Using an Unmanaged Connection under J2SE

In this case, the connection is unmanaged. Your code runs in a J2SE environment with the libraries from the J2EE server. Although this avoids the overhead of administering a J2EE application server, you lose its advantages such as transaction support.

To deploy an unmanaged connection, all you need to do is to update your classpath to include the classes that provide support for the Micro Focus resource adapters. These classes are packaged in mfcobolpure.jar and mfconnector.jar. There are two versions of these files: one for J2EE 1.3 and one for J2EE 1.4, and these are available in the base\bin\j2ee13 and base\bin\j2ee14 directories.

The code you write needs to use CCI. The CCI defines an API for resource adapters connecting to Enterprise Information Servers (EISs), such as Enterprise Server. Micro Focus also supplies some extension classes specific to using the Micro Focus resource adapters.

In summary the code:

  1. Imports the Java and Micro Focus classes
  2. Gets a connection
  3. Gets an interaction
  4. Sets the InteractionSpecs for the interaction
  5. Executes the interaction
  6. Gets the results
  7. Closes the connection

The CCI classes and some of their methods include:

  • Managed ConnectionFactory - createConnectionFactory()
  • ConnectionFactory - get Connection(), getRecordFactory()
  • Connection -
          createInteraction(),
          getResultSetInfo(),
          close()
  • Interaction - getConnection(), execute(), getWarnings()
  • Record - getRecordName(), clone()
  • InteractionSpec - SYNC-SEND, SYNC_RECEIVE and so on

The Micro Focus extensions are supplied in the com.microfocus.cobol.connector.cci package and are documented in the J2EE 1.3 Connector Class Library Reference and J2EE 1.4 Connector Class Library Reference. The com.microfocus.cobol.connector.cci package provides classes such as:

  • CobolConnectionFactory - getConnection(), getRecordFactory()
  • CobolInteraction - execute(), getWarnings()
  • CobolInteractionSpec - getInteractionVerb(), setArgument()
  • CustomRecord -
          getRecordName(),
          clone(),
          hashCode()
  • IndexedRecord -
          lastIndexOf(),
          contains(),
          lastElement()
Parent topic: Overview of Using an Unmanaged Connection under J2SE


Writing a Simple CCI Program

The Java code uses CCI code to interact with a resource adapter which passes the request to the COBOL service. It demonstrates the use of a CCI custom record to represent a COBOL group item. In this sample, the Add service is mapped from the Calculate COBOL program through the entry point ADD using the reusable record Calculator.

  • Sample Program to Connect to a Resource Adapter
  • Sample Service
  • Sample Initialize Method
  • Sample Custom Record
  • Sample Calculator COBOL Program
Parent topic: Overview of Using an Unmanaged Connection under J2SE


Sample Program to Connect to a Resource Adapter

You need to map the COBOL program onto a Java interface using the Interface Mapper. You drag the Calculator parameter into the Reusable Mappings pane and then drag it up into the Interface Fields pane for the Add operation. You can do the same for the subtract, divide and multiply operations. You need to map the interface this way, in this example, because the sample unmanaged class is demonstrating the use of a CCI custom record.

The sample program uses classes from these Java packages:

javax.resource.cci | A collection of CCI interfaces defined in the J2EE Connector Architecture specification
com.microfocus.cobol.connector.spi | Classes specific to the Micro Focus resource adapters that implement the Service Provider Interface (SPI) interfaces
com.microfocus.cobol.connector.cci | Classes specific to the Micro Focus resource adapters that implement the CCI interfaces

To use the classes from these packages, we recommend that you import them into your code. For example, use statements such as:

import com.microfocus.cobol.connector.spi.*;
import com.microfocus.cobol.connector.cci.*;
import javax.resource.cci.*;
Parent topic: Writing a Simple CCI Program


Sample Service

Here is code for the sample service followed by an explanation of the significant lines of code.

1      try {
2       // Get a Connection Factory instance
3       mcf = new CobolNoTxManagedConnectionFactory();
4       // set the appropriate fields.
5       mcf.setServerHost("localhost");
6       mcf.setServerPort("9003");

7       // Get a connection Factory (without using JNDI)
8       cxf = (javax.resource.cci.ConnectionFactory)
               mcf.createConnectionFactory();

9       // Get a Cobol Connection Handle
10      connection = cxf.getConnection();
11      initialize(connection, cxf, true);

12      // Set up an interaction
13      interaction = connection.createInteraction();

14      // create a new interaction spec
15      CobolInteractionSpec iSpec =
             new CobolInteractionSpec();
16      iSpec.setFunctionName("myservice.add");

17      javax.resource.cci.RecordFactory rf =
             cxf.getRecordFactory();
18      Calculator calc = new Calculator();
19      calc.setArg1(new java.math.BigDecimal(10));
20      calc.setArg2(new java.math.BigDecimal(20));
21      iSpec.setArgument(0, com.microfocus.cobol.
             RuntimeProperties.BY_REFERENCE);

22      interaction.execute(iSpec, calc, calc);
23      System.out.println(
             "Input - Arg 1 was" + calc.getArg1());
24      System.out.println(
             "Input - Arg 2 was" + calc.getArg2());
25      System.out.println(
             "Result was" + calc.getResult());
26      System.out.println(
             "Memory was" + calc.getStorage());

28      interaction.close();
29      connection.close();
30      } catch( javax.resource.ResourceException re)
        {
31        re.printStackTrace();
32        Exception le = re.getLinkedException();
33      }

Lines 3-6:

mcf = new CobolNoTxManagedConnectionFactory();

Instantiate the above ConnectionFactory class. The class then configures the following attributes of the unmanaged connection between the Java code and the resource adapter:

  • mcf.setServerHost("localhost");

    This is the name of the machine where the resource adapter is located.

  • mcf.setServerPort("9003");

    This is the port where the enterprise server listens for resource adapter communication.

Line 8:

cxf = (javax.resource.cci.ConnectionFactory)
           mcf.createConnectionFactory();

Instantiate the javax.resource.cci.ConnectionFactory object, by using the CobolNoTxManagedConnectionFactory that you created in line 1.

Line 10:

connection = cxf.getConnection();

Instantiate the javax.resource.cci.Connection class. Invoke the getConnection method on your Connection Factory object to obtain an instance of Connection, configured as stated by the configuration of your CobolNoTxManagedConnectionFactory. This connection handle maps to a ManagedConnection at any time.

Line 11:

initialize(connection, cxf, true);

Initialize the connection. This is a necessary step. The true parameter denotes the state of the COBOL program on the enterprise server. If the program requires the same initial state each time, then set the boolean (parameter three) to true. Otherwise if you want to preserve the state between service calls then set the value to false.

Line 13:

interaction = connection.createInteraction();

Instantiate the javax.resource.cci.Interaction object, by invoking createInteraction() on your Connection object. The Connection object is responsible for the creation of the Interaction object, which will execute interactions with the enterprise server.

Line 15:

CobolInteractionSpec iSpec =
    new CobolInteractionSpec();

Instantiate and configure the specific object for the kind of interaction that is required. In this case, use the com.microfocus.cobol.connector.cci.CobolInteractionSpec class. This class builds the request and method of passing the parameters. The class is used to hold the function name and the direction (In, Out or I/O) of each of the arguments in an indexed record or the direction argument if it is a custom record.

Line 16:

iSpec.setFunctionName("myservice.add");

Set the name of the program to be run on the enterprise server, through the setFunctionName method.

Lines 18-21:

Calculator calc = new Calculator();
calc.setArg1(new java.math.BigDecimal(10));
calc.setArg2(new java.math.BigDecimal(20));
iSpec.setArgument(0,
      com.microfocus.cobol.
      RuntimeProperties.BY_REFERENCE);

Create a new object of custom record class. If only a custom record is being sent as an argument, the steps above are sufficient. The custom record is generated automatically when you generate the EJB. The source files generated for the custom record are available in myproject\repos\myService.deploy\packageName.

If more than one custom record or a mixture of custom records and basic Java types need to be passed as an argument, you need to use an indexed record. For example, if an integer and a custom record need to be passed as an argument, use the following code:

    javax.resource.cci.RecordFactory rf =
          cxf.getRecordFactory();
    javax.resource.cci.IndexedRecord iRec =
          rf.createIndexedRecord("IndexedIn");
    javax.resource.cci.IndexedRecord oRec =
          rf.createIndexedRecord("IndexedOut");
    iRec.add(new Integer(5));
    iRec.add(calc);
    iSpec.setArgument(0,
          com.microfocus.cobol.
          RuntimeProperties.BY_REFERENCE);

This sets the direction of the argument. The arguments are numbered from 0 and this is the first value passed to setArgument. The valid values for direction are:

    com.microfocus.cobol.RuntimeProperties.BY_REFERENCE
    com.microfocus.cobol.RuntimeProperties.BY_VALUE
    com.microfocus.cobol.RuntimeProperties.OUTPUT_ONLY

Line 22:

interaction.execute(iSpec, calc, calc);

Execute the Interaction. The execute() method invoked on the Interaction object causes the request to be flowed to the enterprise server.

Lines 28-29:

interaction.close();

Finally, close the Interaction and the Connection. The close() method on the Connection object is the final flow, and closes the underlying connection to the resource adapter. It must be executed after the close() method on the Interaction.

Parent topic: Writing a Simple CCI Program


Sample Initialize Method

The code for the initialize method is as follows:

private void initialize(
                 javax.resource.cci.Connection con,
                 javax.resource.cci.ConnectionFactory cf,
                 boolean isInitial) {
      try {
      javax.resource.cci.Interaction ix =
           con.createInteraction();
      com.microfocus.cobol.connector.cci.CobolInteractionSpec
           iSpec = new
           com.microfocus.cobol.connector.cci.CobolInteractionSpec();
      iSpec.setFunctionName("initialize");
      javax.resource.cci.RecordFactory rf =
           cf.getRecordFactory();
      javax.resource.cci.IndexedRecord irec =
           rf.createIndexedRecord("beanArgs");
      irec.add(new Boolean(isInitial));
      javax.resource.cci.Record orec =
           ix.execute(iSpec, irec);
      ix.close();
   } catch(javax.resource.ResourceException ex) {
      throw new javax.ejb.EJBException(
           "initialize threw ResourceException: ", ex);
   }
}
Parent topic: Writing a Simple CCI Program


Sample Custom Record

The above example uses the group record Calculator in the COBOL service, myservice.add. In the resource adapter CCI, this group record is expressed as a custom record. The following code is the custom record class, Calculator.java, corresponding to the group record:

/*******************************************************
This is a file generated by Micro Focus Net Express 4.0
This file represents the Custom Class for Calculator
*******************************************************/

public class Calculator extends
      com.microfocus.cobol.connector.cci.CustomRecord {

   private java.math.BigDecimal arg1 =
           java.math.BigDecimal.valueOf(0);
   private java.math.BigDecimal arg2 =
           java.math.BigDecimal.valueOf(0);
   private java.math.BigDecimal result =
           java.math.BigDecimal.valueOf(0);
   private java.math.BigDecimal storage =
           java.math.BigDecimal.valueOf(0);
   public Calculator() {
   }
   public java.math.BigDecimal getArg1() {
       return arg1;
   }
   public void setArg1(java.math.BigDecimal ___p) {
       arg1 = ___p ;
   }
   public java.math.BigDecimal getArg2() {
       return arg2;
   }
   public void setArg2(java.math.BigDecimal ___p) {
       arg2 = ___p ;
   }
   public java.math.BigDecimal getResult() {
       return result;
   }
   public void setResult(java.math.BigDecimal ___p) {
       result = ___p ;
   }
   public java.math.BigDecimal getStorage() {
       return storage;
   }
   public void setStorage(java.math.BigDecimal ___p) {
       storage = ___p ;
   }
   public Object[] getParameters() {
       Object[] objs = new Object[4];
       objs[0] = arg1;
       objs[1] = arg2;
       objs[2] = result;
       objs[3] = storage;
       return objs;
   }
   public void setParameters(Object[] objs) {
       arg1 = (java.math.BigDecimal)objs[0];
       arg2 = (java.math.BigDecimal)objs[1];
       result = (java.math.BigDecimal)objs[2];
       storage = (java.math.BigDecimal)objs[3];
   }
}
Parent topic: Writing a Simple CCI Program


Sample Calculator COBOL Program

The calculator COBOL program used in the sample service is:

$set intlevel(4)
 identification division.
 program-id. calculate.

 environment division.

 data division.
 working-storage section.
 01 calmemory      pic s9(9) comp-5 value 0.

 linkage section.
 01 calculator.
    05 arg1        pic s9(19)v9(19) comp-3.
    05 arg2        pic s9(19)v9(19) comp-3.
    05 result      pic s9(19)v9(19) comp-3.
    05 storage     pic s9(19)v9(19) comp-3.

 procedure division.
     exit program.

 entry "add" using calculator.
     move arg1 to result
     add  arg2 to result
     add  result to calmemory
     move calmemory to storage
     exit program.

 entry "subtract" using calculator.
     move arg1 to result
     subtract arg2 from result
     add  result to calmemory
     move calmemory to storage
     exit program.

 entry "multiply" using calculator.
     move arg1 to result
     multiply arg2 by result
     add  result to calmemory
     move calmemory to storage
     exit program.

 entry "divide" using calculator.
     move arg1 to result
     divide arg2 into result
     add  result to calmemory
     move calmemory to storage
     exit program.
Parent topic: Writing a Simple CCI Program


Calling Procedural COBOL from Java

This chapter describes how you can access legacy procedural COBOL programs from Java using the support provided in the com.microfocus.cobol.RuntimeSystem class.
Restriction: This applies to native code only.
  • Overview - Calling Procedural COBOL from Java
  • Coding Your Java Program
  • Multi-threading Considerations
  • Loading a COBOL Program or Library
  • Using the cobcall() Methods
  • Examples of Calling COBOL from Java
  • Changing Data Members in a Java Object
  • Using CobolBean for Instance Data
  • Canceling a COBOL Program
  • Handling Strings from a Java Program
  • Pointer Class
  • mfjstring
  • CobolNational Class
  • Using Custom Records to Pass Group Items
  • Using JNI with COBOL
  • Example of Throwing an Exception
Parent topic: Java and COBOL


Overview - Calling Procedural COBOL from Java

Restriction: This applies to native code only.

You can call procedural COBOL programs from Java or from EJBs written in any language, not necessarily COBOL. There are a number of ways of doing this, which are summarized in the chapter Using Java and COBOL Together chapter.

This chapter describes how to use the support provided in the com.microfocus.cobol.RuntimeSystem class and the CobolBean class, which is actually an extension to the RuntimeSystem class and uses RuntimeSystem.cobcall*() methods. Use this technique if you do not want to use OO COBOL and will not be using Enterprise Server.

Access to Java objects is available either through the Java Native Interface (JNI), or by use of the OO COBOL Java domain.

The Java support in the com.microfocus.cobol.RuntimeSystem class provides functions which enable you to load, call and cancel COBOL programs. It also enables you to pass parameters to a COBOL program using a Java array. The functions in com.microfocus.cobol.RuntimeSystem class unpack the array and pass the data to your COBOL program in a form it can use. The figure below shows a Java program calling a COBOL program and passing it two parameters.

Calling COBOL from Java

You need to have at least a basic knowledge of the Java language to be able to use this technology effectively. Oracle's Java Web site is a good starting place.

See the section Setting Up the Environment for Java and COBOL in the chapter Using Java and COBOL Together for instructions on how to set up the environments.

Parent topic: Calling Procedural COBOL from Java
Related information
Java Web site
Using Java and COBOL Together
Setting Up the Environment for Java and COBOL


Coding Your Java Program

Restriction: This applies to native code only.

A Java program calls a COBOL entry point by using the functions in RuntimeSystem.class, supplied in mfcobol.jar. This class contains a set of functions named cobcall_returntype(), where returntype is the data type returned by the COBOL program or entry point you want to call. For example, use cobcall_int() to call a COBOL program which returns an integer.

To make COBOL support available to your Java program, include the following statement at the start of your Java source file:

import com.microfocus.cobol.*;
Parent topic: Calling Procedural COBOL from Java


Multi-threading Considerations

Restriction: This applies to native code only.

Java run-time systems are multi-threaded, so any COBOL program you are going to use with Java must be linked with the COBOL multi-threaded run-time system whether or not the Java program calling it uses multi-threading. If your COBOL program is called from a multi-threaded Java program, you need to take care that COBOL data accessed from one thread is not corrupted by another thread.

There are several ways you can deal with this:

  • Compile your COBOL programs with the SERIAL directive.

    SERIAL causes the COBOL run-time system to serialize access to your COBOL code between different threads. Only one thread can access your program at a time. This is the safest option, although it has potentially the highest overhead for execution speed. It is suitable when the COBOL program is providing access to a shared resource (for example, a printer), or when the COBOL program called from Java is in turn calling other COBOL programs which have not been enabled for multi-threading.

  • Compile your COBOL programs with the REENTRANT(2) directive.

    REENTRANT(2) causes the COBOL run-time system to allocate separate user data and FD file areas to each different thread. This prevents any conflicts or data corruption within the program. But REENTRANT(2) can't guarantee thread safety if it calls other non-threaded programs, or accesses other shared resources - in these sorts of cases, SERIAL is a safer option. The REENTRANT(2) directive can provide better performance than SERIAL as one thread is not kept waiting for the next thread to finish.

  • Use thread-local storage in your COBOL programs instead of working storage.

    Thread-local storage is allocated per thread, so there is no possibility of one thread corrupting the data used by another thread. This is fairly efficient, but might not be always be an option with legacy code.

  • Multi-thread your COBOL program using COBOL multi-threading syntax or run-time system calls.

    This can be very efficient as you control which data is thread-local and which data is shared between threads. You could use this option with legacy COBOL code if you are ready to write COBOL driver programs to sit between the Java run-time environment and your legacy programs. Your driver program would be responsible for controlling access to the legacy programs, and would have to use semaphores or some similar mechanism to prevent two threads from accessing the same code at the same time.

    You need to be very careful when canceling a COBOL program in a threaded environment where the program is shared between threads. This applies whether you are using CANCEL or the com.microfocus.cobol.RuntimeSystem.cobcancel() method calls. If possible avoid canceling altogether.

Alternatively, consider using the CobolBean interface, which associates a COBOL programs working storage with a instance of a CobolBean class.

Parent topic: Calling Procedural COBOL from Java


Loading a COBOL Program or Library

Restriction: This applies to native code only.

If your COBOL programs are linked into a library file, or if you want to expose entry-points inside a COBOL program, you need to load the library file or programs before making any calls. You can do this using the runtime.cobload() method in runtime.class. For example, to load the programs inside mycbl:

{
  if (RuntimeSystem.cobload("mycbl") != 0)
     System.out.println("Could not load library\n") ;
  else
     System.out.println("Library loaded successfully\n") ;
}
Parent topic: Calling Procedural COBOL from Java


Using the cobcall() Methods

Restriction: This applies to native code only.

Once you have loaded the libraries or programs required by your Java application (see the previous section for details) you can make calls to COBOL using the cobcall_ methods. The cobcall_ methods are all static methods of RuntimeSystem.class, so you do not have to instantiate RuntimeSystem.class before starting. Each cobcall_ method takes two or three parameters (the third parameter is optional):

Style 1:

  • A string naming the COBOL program
  • A Java object array containing any parameters you want passed to the COBOL program, in the order they appear in the USING clause of the COBOL program's Procedure Division header. By default, parameters are passed by reference.
  • A Java integer array defining the USAGE clause for each parameter. You can select BY REFERENCE, BY VALUE or BY CONTENT, defined by static values of com.microfocus.cobol.RuntimeSystem

Style 2:

  • A string naming the COBOL program
  • A list of parameters encapsulated in a ParameterList()

Parameters are converted between Java and COBOL data types as described in the chapter Java Data Types. As explained in the section Coding Your Java Program there are different cobcall_ methods, each named according to the Java equivalent of the data type returned by the COBOL program or entry being called. For example, a COBOL program that returns a signed integer (such as a pic s9(9) comp-5) is returning the Java data type int. So you would call the COBOL program using the cobcall_int method. By default all parameters are passed by reference.

The copybook javatypes.cpy also provides a set of COBOL type definitions for Java data types. We advise you to use the data types defined in this file to declare COBOL data items that are going to be used for passing parameters between Java and COBOL. Using these data types helps keep your code portable between different COBOL platforms.

See the Java Run-time Class Library Reference, which is in help\mfcobol.docs.zip in your COBOL development system installation.

Parent topic: Calling Procedural COBOL from Java


Examples of Calling COBOL from Java

Restriction: This applies to native code only.

This section shows you two short examples of calling a COBOL program from Java. The first example shows the following features:

  • Passing data to a COBOL program by reference (the default)
  • Returning an integer by using cobcall_int()

This is a simple COBOL subroutine, named legacy.cbl:

working-storage section.
copy "javatypes.cpy".
01 wsResult       jint.

linkage section.
01 wsOperand1     jint. *> type defined in javatypes.cpy
01 wsOperand2     jint.
01 wsOperation    pic x.

procedure division using wsOperand1 wsOperand2 wsOperation.
    evaluate wsOperation
    when "a"
        add wsOperand1 to wsOperand2 giving wsResult
    when "s"
        subtract wsOperand1 from wsOperand2 giving wsResult
    end-evaluate
    exit program returning wsResult.

This is a Java program which calls the subroutine:

import com.microfocus.cobol.* ;
class SimpleCall
{
   public static void main(String argv[]) throws Exception
   {
       int i = RuntimeSystem.cobcall_int("legacy",
                        new ParameterList()
                                   .add((int)4
                          .add((int)7
                                   .add((byte)'a'));
       System.out.println(i) ;
   }
}

The second example shows you how to pass data to a COBOL program with the equivalent of different usage clauses. The cobcall() method used does not return a value, but it takes an object as the first parameter, and returns the same object type from the COBOL program. SimpleCall2 passes the first parameter by reference, the second by value, and the third by content.

import com.microfocus.cobol.* ;

class SimpleCall2
{
   public static void main(String argv[]) throws Exception
   {
      RuntimeSystem.cobcall(null, "usages",
                    new ParameterList()
                    .add((int)1, RuntimeSystem.BY_REFERENCE)
                    .add((int)2, RuntimeSystem.BY_VALUE)
                    .add((int)3, RuntimeSystem.BY_CONTENT));
   }
}
Parent topic: Calling Procedural COBOL from Java


Changing Data Members in a Java Object

Restriction: This applies to native code only.

The example in this section is similar to the example in the previous section, except that the result from the COBOL program is also used to change the value of one of the data members in the Java object.

thread-local-storage section.
copy "javatypes.cpy".

linkage section.
01 wsOperand1               jint.
01 wsOperand2               jint.
01 wsOperation              pic x.
01 wsResult                 jint.

procedure division using wsOperand1 wsOperand2 wsOperation
                         wsResult.
    evaluate wsOperation
    when "a"
        add wsOperand1 to wsOperand2
    when "s"
        subtract wsOperand1 from wsOperand2
    end-evaluate
    exit program returning wsResult

The Java class SimpleCall2 assumes that legacy2.cbl is built into a library file called legacy2.ext. However, if this subroutine were built into a different library file, you would need to use the RuntimeSystem.cobload() method to load the library file before making calls to the legacy program.

import com.microfocus.cobol.* ;
class SimpleCall2
{
   Integer simpleInteger1;
   Integer simpleInteger2;
   Integer simpleResult;
   public SimpleCall2(int a, int b)
   {
      simpleInteger1 = new Integer(a);
      simpleInteger2 = new Integer(b);
      simpleResult   = new Integer(0);
   }
   public String toString()
   {
      return new String(
            "simple1Integer1 = "+simpleInteger1+"\n" +
            "simple1Integer2 = "+simpleInteger2+"\n" +
            "simpleResult    = "+simpleResult);
   }
   public static void main(String argv[]) throws Exception
   {
      SimpleCall2 firstDemo = new SimpleCall2(4,7);
      Object theParams[] = { firstDemo.simpleInteger1,
                             firstDemo.simpleInteger2,
                             new Byte((byte) 'a'),
                             firstDemo.simpleResult }
      System.out.println("Before call\n"+firstDemo) ;
      int i = RuntimeSystem.cobcall_int("legacy2",theParams);
      System.out.println("After call\n"+firstDemo) ;
   }
}
Parent topic: Calling Procedural COBOL from Java


Using CobolBean for Instance Data

Restriction: This applies to native code only.

The com.microfocus.cobol.CobolBean class enables you to associate an instance of CobolBean to an instance of a COBOL program's storage section without having to recode the COBOL application to either be thread-safe or take the parameters from the Java application.

For example, the following COBOL program shares the same data when it is called using cobcall() by more than one Java class.

$set intlevel"4" data-context
 working-storage section.
 01 address-rec pic x(30).

 linkage section.
 01 lnk-address-rec pic x(30).

 procedure division.
    goback.
 entry "setAddressBook" using lnk-address-rec.
    move lnk-address-rec to address-rec
    exit program returning 0.
  entry "getAddressBook" using lnk-address-rec.
    move address-rec to lnk-address-rec
    exit program returning 0.

You can create a Java class that extends from com.microfocus.cobol.CobolBean, and this makes an instance (data-context) version of cobcall() available. You need to compile any COBOL programs called from CobolBean.cobcall() with the Compiler directive DATA-CONTEXT rather than using any threading directive such as RE-ENTRANT(1/2), SERIAL. The Compiler directive DATA-CONTEXT informs the COBOL run-time system to allocate a new COBOL Working-Storage Section whenever it is being used from CobolBean.cobcall().

In the following example, if the COBOL program shared data, bean1.getAddress() would be the same as bean2.getAddress(), causing problems. However because the Java program uses the cobcall() from CobolBean, the COBOL Working-Storage Section is associated with the bean.

import com.microfocus.cobol.*;
import com.microfocus.cobol.lang.*;

public class MyBean extends com.microfocus.cobol.CobolBean
{
   private StringBuffer address = new StringBuffer(30);

   public MyBean() throws Exception
   {
     super();
     super.cobload("addbook");
   }

   public String getAddress() throws Exception
   {
     Pointer addressPointer =
           new Pointer(this.address.toString(),30);
     super.cobcall("getAddressBook",
           new ParameterList().add(addressPointer));
     this.address.setLength(0);
     this.address.append(addressPointer.toString());
     return address.toString();
   }

   public void setAddress(String address) throws Exception
   {
     super.cobcall("setAddressBook",
           new ParameterList().add(new Pointer(address,30)));
   }

   public static void main(String[] args) throws Exception
   {
      MyBean bean1 =new MyBean();
      bean1.setAddress("Mr A");

      MyBean bean2 =new MyBean();
      bean2.setAddress("Mr B");

      System.out.println("bean1.getAddress="+
                            bean1.getAddress());
      System.out.println("bean2.getAddress="+
                            bean2.getAddress());
   }
}
Parent topic: Calling Procedural COBOL from Java


Canceling a COBOL Program

Restriction: This applies to native code only.

To prevent memory leaks you should cancel any COBOL programs you have loaded from Java before the owning Java object is subjected to garbage collection. Use the following call from the Finalize method of the Java object:

RuntimeSystem.cobcancel("program")

where program is the name of a COBOL program loaded using a RuntimeSystem.cobload() call. The following is an example of a Finalize method in a Java program:

private void Finalize()
      {
       try
          {
            RuntimeSystem.cobcancel("demoFinalizers");
            System.out.println("demoFinalizers - finalize'ed");
         }
       catch(Exception e)
         {
           System.out.println(
                "Error during finalize : "+e.getMessage());
             }
          }
CAUTION:
  • You should only cancel a program when you are sure you that no other program is using the program. This might be difficult in a server/threaded program.
  • This method is "Finalize" not "finalize" as we do not want the instance to be called during garbage collection as this may cause a memory block in the garbage collection process.
Parent topic: Calling Procedural COBOL from Java


Handling Strings from a Java Program

Restriction: This applies to native code only.

You pass strings to COBOL using either the String or StringBuffer class. You can use any the following mechanisms to do this:

  • Pointer class. This enables you to pass a Java string to a COBOL program without changing the COBOL source code. The Pointer class is in the com.microfocus.cobol.lang package.
  • mf-jstring. This enables you to convert a Java string to a user-defined type called mf-jstring, which is defined in javatypes.cpy. This user-defined type gives you full access to the information available from Java, this includes the data, the length of the string and the capacity of the string or string buffer.
  • CobolNational. This java class enables you to create UTF-16 strings that can be passed to a COBOL PIC N(...) USAGE NATIONAL field.
Parent topic: Calling Procedural COBOL from Java


Pointer Class

Restriction: This applies to native code only.

An intrinsic problem with passing Java strings to COBOL is that Java strings are variable length whereas COBOL strings are fixed length. For COBOL to modify a predefined fixed-length field, you need to wrap the instance in a new instance of the Pointer class. The Pointer class is in the com.microfocus.cobol.lang package.

For example, here is a COBOL program that defines a PIC X(20) data item:

showbytes.cbl:
       working-storage section.
       linkage section.
       01 lnk-string     pic x(20).
       procedure division using lnk-string.
          display "lnk-string = " lnk-string.
          move "Hello from COBOL - 1" to lnk-string.
          exit program returning 0.

The corresponding Java code would be:

showbytes.java:

import com.microfocus.cobol.RuntimeSystem;
import com.microfocus.cobol.lang.Pointer;
import com.microfocus.cobol.lang.ParameterList;

public class showbytes
{
  public static void main(String[] args) throws Exception
  {
   String myString = new String("Hello to COBOL");
   Pointer ptr2String = new Pointer(myString, 20);

   RuntimeSystem.cobcall("showbytes",
             new ParameterList().add(ptr2String));

   myString = ptr2String.toString();

   System.out.println(myString = ["+myString+"]");
  }
}
Parent topic: Calling Procedural COBOL from Java


mfjstring

Restriction: This applies to native code only.

A COBOL program cannot modify the contents of a String passed to it, but it can change a StringBuffer. To make handling strings easier, javatypes.cpy defines the type MF-JSTRING. This data type has the following structure:

01 mf-jstring is typedef.
    03 len                  jint.
    03 capacity             jint.
    03 ptr2string           pointer.

The len field defines the length of the string. The capacity field defines the size of the buffer - this field is always 0 for a String. The ptr2string field is a pointer to the start of the actual string. In the case of a StringBuffer, you can either modify the existing buffer, or allocate a new one and set ptr2string to the start of the new buffer.

The COBOL program below concatenates a String and StringBuffer from Java, and returns the result in the StringBuffer.

 program-id. StringAdd.
 thread-local-storage section.
 copy "javatypes.cpy".
 01 lsNewPtr                 pointer.
 01 lsSize         jint. *> type defined in javatypes.cpy
 01 i              jint.
 01 lsStatus       jint.
 01 lsBigBuffer              pic x(1024).
 linkage section.
 01 lnkJString               mf-jstring.
 01 lnkJStringBuffer         mf-jstring.
 01 lnkString                pic x(256).
 01 lnkStringbuffer          pic x(256).
 procedure division using lnkJString lnkJStringBuffer.
     set address of lnkStringBuffer to
                              ptr2string of lnkJStringBuffer
     set address of lnkString to ptr2string of lnkJString
*>   Check that lnkJStringBuffer is a Java StringBuffer
     if capacity of lnkJStringBuffer > 0
         add len of lnkJString to len of lnkJStringBuffer
                                   giving lsSize
*>   Check we don't overflow concatenation buffer
         if lsSize < 1024
             move len of lnkJString to i
             move lnkString(1:i) to lsBigBuffer
             add 1 to i
             move lnkStringBuffer to lsBigBuffer(i:lsSize)
             set ptr2string of lnkJStringBuffer
                                 to address of lsBigBuffer
             move lsSize to len of lnkJStringBuffer
         end-if
     end-if

The Java class StringsToCobol passes "fred" and "ginger" to StringAdd and then displays the result.

import mfcobol.*;
public class StringsToCobol {
  public static void main(String[] args) throws Exception
  {
      StringBuffer sb1 = new StringBuffer("ginger") ;
      Object theParams[] = {"fred" ,
                             sb1} ;
       RuntimeSystem.cobcall_int("stringadd", theParams) ;
       System.out.println(sb1) ;
  }
}
Parent topic: Calling Procedural COBOL from Java


CobolNational Class

Restriction: This applies to native code only.

The CobolNational Java class enables you to create UTF-16 strings that can be passed to a COBOL PIC N(...) usage is national field.

For example, the following COBOL program, hellonat, receives the string "Hello From Java" into a data item defined as PIC N(40) USAGE IS NATIONAL:

 $set unicode(portable)
  working-storage section.
  linkage section.
  01 lnk-natstring   pic n(40) usage is national.
  procedure division using lnk-natstring.
      display "Java said to COBOL [" lnk-natstring "]"
      move "Hello From Java" to lnk-natstring
      exit program returning 0.

The corresponding Java code passes the string "Hello From Java" to the COBOL program, hellonat:

CobolNational cobnat =
                 new CobolNational("Hello From Java", 40);
RuntimeSystem.cobcall("hellonat",
              new ParameterList().add(cobnat));
System.out.println(cobnat.toString());
Parent topic: Calling Procedural COBOL from Java


Using Custom Records to Pass Group Items

Restriction: This applies to native code only.

The CustomRecord interface in com.microfocus.cobol.lang enables you to pass group items to a legacy COBOL program, when using cobCall() and cobrcall().

The CustomRecord interface is:

package com.microfocus.cobol.lang;
public interface CustomRecord
{
  public Object[] getParameters();
  public void setParameters(Object[] parms);
}

The data item customerDetails can be defined as follows:

  01 customerDetails.
         03 customerName       pic x(30).
         03 customerAddress    pic x(30).
         03 customerRef        pic 9(6).

A Java implementation could be:

import com.microfocus.cobol.lang.*;
import java.text.*;

public class RecordData implements
             com.microfocus.cobol.lang.CustomRecord
{
    private String customerName;
    private StringBuffer customerAddress;
    private int customerRef;
    RecordData(String name, String address, int ref)
    {
      customerName = name;
      customerAddress = new StringBuffer(address);
      customerRef = ref;
    }
    public String getCustomerName()
    {
      return this.customerName;
    }
    public String getCustomerAddress()
    {
      return this.customerAddress.toString();
    }
    public int getCustomerRef()
    {
      return this.customerRef;
    }
    public Object[] getParameters()
    {
      String strCustomerRef =
                  Integer.toString(this.customerRef);
      while(strCustomerRef.length() <  6)
      {
         strCustomerRef = "0"+strCustomerRef;
      }
      customerAddress.setLength(30);
                  /* must ensure length is right! */
      customerAddress.ensureCapacity(30);
      return new ParameterList()
        .add(new Pointer(this.customerName,30))
        .add(this.customerAddress)
        .add(strCustomerRef.getBytes())
        .getArguments();
    }
    public void setParameters(Object[] parms)
    {
      Pointer ptr = (Pointer)parms[0];
      this.customerName = ptr.toString();
      this.customerAddress = (StringBuffer)parms[1];
      byte[] byteCustomerRef = (byte[])parms[2];
      this.customerRef =
              Integer.parseInt(new String(byteCustomerRef));
    }
    public String toString()
    {
      return "Customer Name : "+this.customerName+"\n"+
          "Customer Address : "+this.customerAddress+"\n"+
          "Customer Ref     : "+this.customerRef;
    }
}

The Java program could call the COBOL program as follows:

cobcall("RecordDemo",new ParameterList().add(
              new RecordData(myname, myaddress, myref)));
Parent topic: Calling Procedural COBOL from Java


Using JNI with COBOL

Restriction: This applies to native code only.

The Java Native Interface (JNI) enables non-Java programs to access Java objects and classes. One of the variants of the cobcall() method provided in the com.microfocus.cobol.RuntimeSystem class passes through a JNI pointer to the COBOL program being called. The JNI pointer is a pointer to a table of Java functions which enable non-Java code to access the Java run-time system.

For ease of use with COBOL, javatypes.cpy defines data type JNINativeInterface. JNINativeInterface is a group data item consisting of a set of procedure pointers to the JNI Java functions. One use of JNI with COBOL is to throw a Java exception from a COBOL program.

The other way to access Java from COBOL is to use the domain support.

Parent topic: Calling Procedural COBOL from Java


Example of Throwing an Exception

Restriction: This applies to native code only.

The following short COBOL program throws an exception using a JNI function.

 identification division.
 program-id.  "except".
 special-names.

**********************************************
* The call convention used for JNI calls needs
* to be defined here. For Win32 systems, it is
* 74 (which corresponds to the stdcall calling
* convention).
**********************************************
$if UNIX defined
     call-convention 0 is javaapi.
$else
     call-convention 74 is javaapi.
$end
 local-storage section.
 copy "javatypes.cpy".
 01 JavaException               pointer.
 01 ExceptionClass              pointer.
 linkage section.
 01 JEnv                        pointer.
 01 jobject                     pointer.
 01 lnk-JNINativeInterface      JNINativeInterface.
*  The first parameter (JEnv) is a pointer to the JNI
*  function table. It must be passed (by reference) as
*  the first parameter on all JNI function calls.
 procedure division
      using by reference JEnv.
* Map the pointer passed in JEnv to the
* JNINativeInterface structure so that we
* can call JNI functions.
     set address of lnk-JNINativeInterface to JEnv
* Get a reference to the exception class
      call javaapi FindClass
             using by reference JEnv
                   by reference
                   z"java/lang/IllegalArgumentException"
             returning ExceptionClass
      end-call
* Unable to find the exception class, so simply exit
     if ExceptionClass = NULL
             exit program
     end-if
* Throw the new exception
     call javaapi ThrowNew
             using by reference JEnv
                   by value ExceptionClass
                   by reference z"Thrown from COBOL code"
     end-call
     exit program
     .

This is the Java program which calls it:

import com.microfocus.cobol.*;
class testexcept
{
  public static void main(String argv[]) throws Exception
  {
    try
    {
       /* Last parameter is true for passing in JNIEnv... */
       RuntimeSystem.cobcall(null,"throwex",null,null,true);
    }
    catch(Exception e)
    {
       System.out.println(
                  "PASS - exception caught ("+ e + ")");
    }
  }
}
Parent topic: Calling Procedural COBOL from Java


Calling Java from OO COBOL

This chapter shows you how to code a COBOL program to call Java methods using the OO COBOL Java domain.
Restriction: This applies to native code only.
  • Overview of Calling Java from OO COBOL
  • Before You Start
  • Declaring Java Classes
  • Instantiating Java Objects
  • Calling Java Methods
  • Accessing Java Variables
  • Handling Java Exceptions
  • Accessing Native Java Objects
  • Finalizing Java Objects
Parent topic: Java and COBOL


Overview of Calling Java from OO COBOL

Restriction: This applies to native code only.

Micro Focus Java support enables you to send messages to Java objects from OO COBOL programs and classes.

Java is supported through a Java domain in OO COBOL. The Java domain enables you to declare Java classes inside a COBOL program. You can then send messages to the Java classes. The Java domain support works by creating a COBOL proxy object for each Java object, as shown in the figure below. The class itself that you declare is a proxy for the static methods of the Java class.

The Java Proxy

Your program needs to have a Repository paragraph, and needs to use the INVOKE verb each time you want to call a Java method, although it does not have to be written as an OO COBOL class.

The COBOL run-time system converts parameters sent with messages from COBOL data types to Java data types. If a method returns a parameter, it is converted from a Java data type to a COBOL data type.

Using the techniques described in this chapter, you can call any Java API, such as JDBC, Sockets and Swing.

You need to have at least a basic knowledge of the Java language to be able to use this technology effectively. The Java Web site is a good starting place.

You can also call COBOL programs from Java without using the OO COBOL Java domain.

Parent topic: Calling Java from OO COBOL
Related information
Java Web site
Calling Procedural COBOL from Java


Before You Start

Restriction: This applies to native code only.

Before you start, you need to set up your environment so that the COBOL and Java run-time systems can interact. See the section Setting Up the Environment for Java and COBOL in the chapter Using Java and COBOL Together.

Parent topic: Calling Java from OO COBOL
Parent topic: Calling OO COBOL from Java
Related information
Setting Up the Environment for Java and COBOL


Declaring Java Classes

Restriction: This applies to native code only.

Each Java class you want to use in a COBOL program must be declared in the Repository paragraph. You need to provide the full name of the package the Java class is in, prefixed by $java$. The prefix tells the COBOL run-time system to load the class from the Java domain.

Declare the Java class as follows:

repository.
     class COBOL-classname as "$java$class-name"
    .

where the names are:

COBOL-classname
The name by which the class is known to this COBOL program.
java
The name of the Java domain.
class-name
The name by which the class is known to the Java domain. This is usually determined by the name under which the class has been registered with the object model for that domain.

For example:

repository.
     class jRectangle as "$java$java.awt.Rectangle"
     .

This declares jRectangle as a COBOL proxy object for the Rectangle class in the java.awt package. The package must be available on your Java classpath or your program will fail at run time.

Parent topic: Calling Java from OO COBOL


Instantiating Java Objects

Restriction: This applies to native code only.

Each Java class has one or more constructor methods to instantiate objects. In Java, constructor methods have the same name as the class. To enable you to invoke these methods from COBOL, they are mapped to the "new" method name on the COBOL proxy object.

The different constructors on a Java class take different numbers and combinations of parameters to initialize the instance you are creating. For example, the Java Rectangle class can be instantiated in several different ways, including the two shown below in Java code:

 Rectangle r1 = new Rectangle ()
              //  rectangle (x,y) = 0,0, width=0, height=0
 Rectangle r2 = new Rectangle(4, 5, 10, 20)
             // rectangle (x,y) = (4,5), width=10, height=20

The equivalent COBOL code is shown below:

 working-storage section.
 01 r1                  object reference.
 01 r2                  object reference.
 ...

 procedure division.
 ...
     invoke jRectangle "new" returning r1
          *> rectangle (x,y) = 0,0, width=0, height=0
     invoke jRectangle "new" using 4, 5, 10, 20
                         returning r2
          *> rectangle (x,y) = (4,5), width=10, height=20

The COBOL run-time system uses the number and type of parameters to call the appropriate constructor on the Java class. You must be careful to provide parameters of the types expected by the Java class, as Java is a strongly typed language. The chapter Java Data Types explains how COBOL data types are mapped onto Java data types. The copybook javatypes.cpy also defines a set of data types for use in COBOL which correspond directly to Java data types; you are recommended to use these for transferring data between Java and COBOL.

Parent topic: Calling Java from OO COBOL


Calling Java Methods

Restriction: This applies to native code only.

You can call any of the methods on a Java object by sending it a message with the same name as the method. You can also call the static methods of a Java class - send the message to the classname declared in the Class-Control paragraph of your program. Method names in Java are case-sensitive, so the case of the message name in COBOL must match the case of the method in Java.

Java allows method overloading - where one method name has different implementations according to the number and type of parameters passed. COBOL handles this transparently for you, so that the correct Java method is always called.

For example, the Rectangle class has three different add() methods, which take different parameters. The Java code below shows three different ways you can call the add() method on a rectangle.

 Rectangle r1 = new Rectangle(0,0,0,0) ;
 Point pt = new Point(6,6) ;
 Rectangle r2 = new Rectangle(3,4,9,9) ;
 r1.add(4,5) ; // changes r1 to smallest rectangle
               //  containing r1 and point 4,5
 r1.add(pt) ;  // changes r1 to smallest rectangle
               //  containing r1 and Point pt.
 r1.add(r2) ;  // changes r1 to union of r1 & r2

The equivalent code in COBOL looks like this:

 repository.
     class jRectangle as"$java$java.awt.Rectangle"
     class jPoint as "$java$java.awt.Point"
     .
 working-storage section.
 01 r1                 object reference.
 01 r2                 object reference.
 01 pt                 object reference.

 procedure division.
     invoke jRectangle "new" returning r1
     invoke jPoint "new" using 4 5 returning pt
     invoke jRectangle "new" using 3 4 9 9 returning r2
     invoke r1 "add" using 4 5
     invoke r1 "add" using pt
     invoke r1 "add" using r2

Although r2 and pt are both data items of type object reference, the COBOL run-time system determines the type of Java object represented and calls the correct Java method.

Parent topic: Calling Java from OO COBOL


Accessing Java Variables

Restriction: This applies to native code only.

You can access the public members and static variables of a Java class by invoking "setname" and "getname" methods on the OO COBOL proxy. Variable names are case-sensitive in Java, so the case of name in your COBOL code must match the case declared in the Java code.

For example, the Java class below has public variables classVal and instVal:

public class x {
    static int classVal;
    int instVal;
};

This sample of COBOL code sets the static variable classVal, and then retrieves the member instVal.

$set ooctrl(-f+p)
repository.
     class x as "$Java$x"
     .

 working-storage section.
 copy "javatypes.cpy".
 01 anX                  object reference.
 01 anInt                jint.
 procedure division.
     invoke x "setclassVal" using by value 4
     invoke x "new" returning anX
     invoke anX "getinstVal" returning anInt
Parent topic: Calling Java from OO COBOL


Handling Java Exceptions

Restriction: This applies to native code only.

An exception thrown by Java is passed back to COBOL as an OO COBOL exception raised against the javaexpt class. The default exception behavior is for the COBOL run-time system to display a message warning of the exception, and then terminate. Alternatively, you can trap the exception by adding an exception handler to your COBOL program.

To trap Java exceptions:

  1. Declare the Exceptionmanager, JavaExceptionManager, and Callback or EntryCallback classes in the Class-Control paragraph. For example:
    repository.
    ...
    class JavaExceptionManager as "javaexpt"
    class ExceptionManager as "exptnmgr"
    class Callback as "callback"
    class EntryCallback as "entrycll"
    ...
    Tip: If you declare your own exception handling class method or entry-point, be aware that if it shares its name with one of the default Micro Focus exception handling methods shown above, you will not be able to invoke that default method.
  2. Write an exception handler (either a method in a class, or an entry-point) and create a Callback or EntryCallback to it. For example, a Callback looks like this:
    invoke Callback "new" using anObject z"methodName"
                  returning aHandler

    An EntryCallback looks like this:

    invoke EntryCallback "new" using  z"entryPointname"
                  returning aHandler
  3. Register your callback against the JavaExceptionManger class. For example:
    invoke ExceptionManager "register"
         using JavaExceptionManager aHandler

Now all Java exceptions thrown by classes you are calling through the OO COBOL Java domain get sent to your exception handler.

This is an example of a COBOL program which catches an exception thrown by a Java program:

$set ooctrl (+p-f)
 program-id. ExceptionCatcher.

 class-control.
     SimpleClass is class "$JAVA$SimpleClass"
     EntryCallback is class "entrycll"
     JavaExceptionManager is class "javaexpt"
     ExceptionManager is class "exptnmgr"
     .

 working-storage section.
 01 theInstance                  object reference.
 01 wsCallback                   object reference.
 local-storage section.
 01 filler pic x.   *> dummy storage to allow the local entry
                    *> point to be used for the callback
 linkage section.
 01 lnkException                 object reference.

 procedure division.
*>---Set up Exception handler
     invoke EntryCallback "new" using z"JException"
                            returning wsCallback
     invoke ExceptionManager "register"
                                  using javaexceptionmanager
                                        wsCallback
*>---Instantiate the class
     invoke SimpleClass "new" returning theInstance

     display "instantiated"
     invoke theInstance "TestException"
     display "excepted"
     stop run.

 entry "Jexception" using lnkException.
     invoke lnkException "display"
     .

The Local-Storage Section in the above program is simply to enable recursion - the COBOL run-time system treats the invocation of the EntryCallback as a recursive call. Without a Local-Storage Section, this will result in a run-time system error. This is the Java code for SimpleClass:

import java.lang.* ;

public class SimpleClass {

  public SimpleClass() {
  }

  public void TestException() throws Exception
  {
     Exception e = new Exception ("Test error" );
     throw e;
  }
}

See the Java Run-time Class Library Reference, which is in help\mfcobol.docs.zip in your COBOL development system installation.

Parent topic: Calling Java from OO COBOL


Accessing Native Java Objects

Restriction: This applies to native code only.

Using the OO COBOL Java domain means that you never access Java objects directly - you are always going through a proxy. You can obtain a pointer to the actual Java object using the "getJavaObject" method of the javasup class. You can use this in conjunction with the Java Native Interface (JNI) if you want access to Java functionality not provided by the OO COBOL Java domain.

To get a JNI pointer invoke "getEnv" on the javasup class. The JNI pointer is a pointer to a table of functions; data type JNINativeInterface in copybook javatypes.cpy provides a structure that makes the JNI function table easier to use, as shown in the example below:

 working-storage section.
 01 JEnv                        pointer.
 linkage section.
 01 lnk-JNINativeInterface      JNINativeInterface.

*>
 procedure division.
     invoke javasup "getEnv" returning jEnv
*>   Map the pointer passed in JEnv to the
*>   JNINativeInterface structure so that we
*>   can call JNI functions.
     set address of lnk-JNINativeInterface to JEnv
*>

You can now call JNI functions using the names provided by the JNINativeInterface type definition.

Parent topic: Calling Java from OO COBOL
Related information
Java Web Site


Finalizing Java Objects

Restriction: This applies to native code only.

The Java run-time system includes a garbage collector which automatically destroys unwanted objects. The garbage collector deletes any object which is not referenced by any other object. Once you have a proxy to a Java object in a COBOL program, the COBOL run-time system has a reference to the Java object which prevents the Java garbage collector from removing it.

When you have finished with a Java object, you must release the reference to it so that the garbage collector can delete the object - otherwise your application has a memory leak. To finalize the object:

invoke javaobject "finalize" returning javaobject

The returning parameter is important, as otherwise the COBOL run-time system passes the message on to the actual Java object instead of destroying the COBOL proxy. If the message is passed to the Java object, it invokes this function:

public void finalize()

This function is either inherited or implemented by all Java classes, and is called by the Java garbage collector before it destroys an object.

In the unlikely event that your Java class implements a finalize() method which returns a value, use the "delete" method to destroy the OO COBOL proxy instead:

invoke javaobject "delete" returning javaobject
Parent topic: Calling Java from OO COBOL


Calling OO COBOL from Java

This chapter describes how you can access COBOL objects from Java programs. This is slightly different from the method for accessing procedural COBOL from Java programs.
Restriction: This applies to native code only.
  • Overview - Calling OO COBOL from Java
  • Before You Start
  • Writing a Java Class in OO COBOL
  • Importing the COBOL Support
  • The Wrapper Class
  • Adding and Removing Methods
  • Throwing Exceptions from COBOL
  • Using BY REFERENCE Parameters
  • Working with Java Programs
  • Demonstration Programs
Parent topic: Java and COBOL


Overview - Calling OO COBOL from Java

Restriction: This applies to native code only.

You can write classes in OO COBOL which can be called from Java programs as though they were Java classes. You do this by providing a Java wrapper class, which provides a function for each method in the OO COBOL class.

The functions in the Java wrapper class put all the parameters for the method into a Java array, and then call one of the member functions of Java class com.microfocus.cobol.RuntimeSystem to invoke the method in the OO COBOL class and return the result. This is shown in the figure below:

Calling OO COBOL from Java

Parent topic: Calling OO COBOL from Java
Related information
Java Web Site


Writing a Java Class in OO COBOL

Restriction: This applies to native code only.

To write a class in OO COBOL which can be called from Java, you need to do the following:

  1. Set the following directive in your program:
    $set ooctrl(+p-f)
  2. Ensure that the OO COBOL class inherits from javabase.
  3. Create a Java wrapper class for the OO COBOL class. The wrapper class must have the same class name as the filename of the OO COBOL class.
  4. For each method that you create in your OO COBOL class, create a corresponding method in the Java wrapper class.
  5. Package the class inside a .dll file when deploying it on Windows platforms.
Parent topic: Calling OO COBOL from Java


Importing the COBOL Support

Restriction: This applies to native code only.

The support needed for the Java wrapper class to communicate with the OO COBOL class is in the com.microfocus.cobol package. The wrapper must include the following statement:

import com.microfocus.cobol.* ;

You must also ensure mfcobol.jar is on the Java classpath, or your Java programs will not compile or run.

Parent topic: Calling OO COBOL from Java


The Wrapper Class

Restriction: This applies to native code only.

The Java wrapper class must extend either microfocus.cobol.RuntimeObject or microfocus.cobol.RuntimeSystem. This affects the lifetime of the OO COBOL instances represented by instances of the Java wrapper class:

  • When the wrapper inherits from microfocus.cobol.RuntimeObject, if a wrapper object is destroyed by the Java garbage collector, the corresponding OO COBOL instance is finalized.

  • When the wrapper inherits from microfocus.cobol.RuntimeSystem, the OO COBOL instance is finalized whenever execution exits from a method, losing any instance data.

The wrapper class needs to be initialized with the library and filename of the COBOL class it is wrapping. You do this by including the following code inside the Java wrapper class:

static
{
  cobloadclass("libname","filename","fullJavaClassName");
}

where:

libname
s the name of the .dll file which contains the OO COBOL class. You can leave this parameter as null if the class is not packaged inside a .dll file .
filename
is the filename of the OO COBOL class.
FullJavaClassName
is the Java classname corresponding to the OO COBOL class.

There are three cobloadclass() methods, which provide slightly different ways of identifying the library, COBOL file and the Java wrapper class.

Parent topic: Calling OO COBOL from Java


Adding and Removing Methods

Restriction: This applies to native code only.

Every method you add to the COBOL class must have a corresponding function in the Java wrapper class.

The Java function must do the following:

  1. Declare the exceptions which can be thrown from an invoke of a COBOL method.

    By default, these are Exception (thrown if you raise an exception in COBOL) and CobolException (thrown by the COBOL run-time system). If your class is to be deployed either as an Enterprise JavaBean, or using Java Remote Method Invocation (RMI), you should also add RemoteException.

  2. Construct a Java array containing the parameters to be passed from Java to the COBOL method.

    Parameters are passed from Java to the COBOL run-time system in a Java array.

  3. Invoke one of the cobinvoke_ or cobinvokestatic_ methods provided by the class RuntimeSystem.java.

    There is a cobinvoke_ and cobinvokestatic_ method corresponding to each possible return type from a Java function (for example, cobinvoke_int returns an int). Use the cobinvoke_ methods for invoking OO COBOL instances. Use the cobinvokestatic_ methods for invoking OO COBOL classes.

    For the full list of cobinvoke_ functions, see the Java Run-time Class Library Reference, which is in help\mfcobol.docs.zip in your COBOL development system installation.

    You need to determine which Java data type maps to the return type from the COBOL method, and then choose the appropriate cobinvoke_ function. See the chapter Java Data Types for more information.

OO COBOL factory methods are mapped onto static functions in the Java wrapper.

The two code samples below show a COBOL instance method, and the corresponding function in the Java wrapper. This is the COBOL method.

 method-id. "myMethod".
 local-storage section.
*>---USER-CODE. Add any local storage items needed below.
 linkage Section.
 01 myParameter            pic x(4) comp-5.
 01 myReturnValue          pic x(4) comp-5.
 procedure division using by reference myParameter
                    returning myReturnValue.
*>---USER-CODE. Add method implementation below.
     exit method.
end method "myMethod".

This is the Java wrapper method.

public int myMethod (Integer myParameter) throws Exception,
                          CobolException, RemoteException
{
    // Parameters are passed to COBOL in an array
    Object[] params = {myParameter};
    return ((int) cobinvoke_int ("myMethod", params)); }

Although the name of a method is usually the same for the Java wrapper class and the COBOL class, it does not have to be. This enables you to implement method overloading in the Java wrapper.

Method overloading enables you to have several methods with the same name, but which take different types or numbers of parameters. Java supports method overloading, but COBOL does not. But you can add overloaded functions to the Java wrapper, and have them call differently named methods in the COBOL class.

For example, you could have these overloaded functions in your Java wrapper class:

public int add (int a, int b)
{...}
public int add (int a, int b, int c)
{...}

And map them to methods "add2" and "add3" in your COBOL class.

Parent topic: Calling OO COBOL from Java


Throwing Exceptions from COBOL

Restriction: This applies to native code only.

You can throw a Java exception from your COBOL code. The exception object can be any Java class.

The javasup class provides two methods for throwing exceptions, namely: throwException and throwNewException. You use these methods as follows:

invoke javasup "throwException" using aCOBOLProxy

invoke javasup "throwNewException" using javaclassdescription

where:

aCOBOLProxy
is a COBOL proxy to any Java object of type Throwable.
javaclass
is the name of the class of Java exception to throw.
description
is a text description of the exception.

For details of the javasup class and its methods, see the Java Run-time Class Library Reference, which is in help\mfcobol.docs.zip in your COBOL development system installation.

Parent topic: Calling OO COBOL from Java


Using BY REFERENCE Parameters

Restriction: This applies to native code only.

When parameters to a method are declared as BY REFERENCE, the default behavior is for any updates to those parameters to be reflected in the corresponding Java objects in the calling Java class on return from the OO COBOL method.

If you do not want the Java objects to be updated, you can set the following static variable:

static boolean mfcobol.runtimeProperties.updateByRefParams;

The default value for this variable is true. Set it to false if you do not want the Java objects to be updated.

Note: In an earlier version of this COBOL development system, the default behavior was for updates to BY REFERENCE parameters not to be reflected in the calling Java. If you have existing Java code that makes use of that behavior, you need to modify it to set mfcobol.runtimeProperties.updateByRefParams to false.

Your COBOL development system includes a demonstration program that illustrates the different ways of handling BY REFERENCE parameters.

Parent topic: Calling OO COBOL from Java


Working with Java Programs

Restriction: This applies to native code only.

When you develop mixed COBOL and Java programs, you need to be aware of the following:

  • The default Java build directives that your COBOL development system uses are -d %TARGETDIR -classpath "%CLASSPATH";%TARGETDIR %FILENAME. The "%CLASSPATH";%TARGETDIR section of the command appends the currently-specified target directory to the end of the current setting for the CLASSPATH environment variable, retaining any spaces specified in the current setting of CLASSPATH.
  • If you specify multiple classes in a .java program, only the resultant .class file with the same basename as the .java program is added to the project automatically. You must add any other .class files manually.
  • We recommend that you add the -g Java build directive in debug mode (to generate debugging information), but replace it with the -O directive in release mode (to create optimized code). You can set these directives by clicking on the Project menu. Then select the Compile tab for each .java file and add this directive to the list.
Parent topic: Calling OO COBOL from Java


Demonstration Programs

Restriction: This applies to native code only.

Your COBOL development system includes some demonstration programs that illustrate different aspects of calling OO COBOL from Java. These demonstration programs are in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration in your product installation. Each directory includes all relevant program files, as well as a readme.txt file to explain the programs in more detail.

The following table shows the directories containing the demonstration programs and gives a brief description of the purpose of the demonstration:

Directory | Illustrates
array | Receiving and accessing a Java array in OO COBOL. Creating a Java array in OO COBOL and passing it to Java.
record | Writing a simple COBOL Java object. Receiving structures in OO COBOL methods from Java objects that implement the DataType interface. Passing parameters BY REFERENCE.
simple | Writing a simple COBOL Java object. Calling both class and instance OO COBOL methods using Java.
sort | Writing a simple COBOL Java object. Calling OO COBOL methods using Java. Calling Java methods using OO COBOL. Dealing with Java objects as parameters and return values.
Parent topic: Calling OO COBOL from Java


Java Data Types

This chapter describes how COBOL and Java data types are mapped on to each other.
Restriction: This applies to native code only.
  • Overview
  • Java Data Type Conversion Rules
  • Java Typedefs
  • Using the Jarray Class
  • Adding Parameters Using ParameterList()
  • Using Structures
  • Creating Custom Records using com.microfocus.cobol.lang.CustomRecord Interface
Parent topic: Java and COBOL


Overview

Restriction: This applies to native code only.

The Java language defines its own data types, which are different to the ones used in COBOL. The COBOL run-time system automatically converts between COBOL and Java types whenever you call Java from COBOL or COBOL from Java, as shown below.

Mapping data between COBOL and Java

Numeric data types are converted in the same way whether the COBOL program is a procedural program, or OO COBOL. Objects and strings are converted differently, depending on whether you are using procedural COBOL or OO COBOL.

OO COBOL handles Java objects as COBOL object references, but procedural COBOL handles them as pointers.

Parent topic: Java Data Types


Java Data Type Conversion Rules

Restriction: This applies to native code only.

When you send COBOL data to Java, it is converted to an appropriate Java data type. Similarly, when a Java program sends Java data back to COBOL, it is converted to a COBOL data type. The table below defines the conversions which happen when data is passed between Java and COBOL. Some data types are handled differently depending on whether you are using procedural COBOL or the OO COBOL Java domain. The COBOL column in the table shows you the conversion rules for procedural COBOL, and the OO COBOL column shows you the rules for the OO COBOL Java domain.

Java Data Type | COBOL Data Type Used with .cobcall(...) | OO COBOL Data Type Used with .cobinvoke() | Description
byte | pic s99 comp-5 | pic s99 comp-5 pic s99 comp | Signed 1-byte integer
short | pic s9(4) comp-5 | pic s9(4) comp-5 pic s9(4) comp | Signed 2-byte integer
int | pic s9(9) comp-5 | pic s9(9) comp-5 pic s9(9) comp | Signed 4-byte integer
long | pic s9(18) comp-5 | pic s9(18) comp-5 pic s9(18) comp | Signed 8-byte integer
boolean | pic 99 comp-5 | pic 99 comp-5 | Zero value is false, non-zero is true
char (Unicode) | pic 9(4) comp-5 | pic s9(4) comp | All characters in Java are represented by 2-byte Unicode characters
float | comp-1BKDIDIJADTS003.html#FOOTNOTE1 | comp-1 BKDIDIJADTS003.html#FOOTNOTE1 | Floating-point number
double | comp-2 BKDIDIJADTS003.html#FOOTNOTE1 | comp-2 BKDIDIJADTS003.html#FOOTNOTE1 | Double-precision floating-point number
String | mf-jstring pointer | pic x(n) | The capacity is always zero. You should consider a string passed into a COBOL program as read-only, and not to be amended.
StringBufferBKDIDIJADTS003.html#FOOTNOTE4 | mf-jstring BKDIDIJADTS003.html#FOOTNOTE2 pointer BKDIDIJADTS003.html#FOOTNOTE3 | pic x(n) | The capacity is the total size of the buffer, and the size the length of the string currently held in the buffer.
objects | pointer | object reference | Any Java object. The pointer returned to procedural COBOL can be used with JNI calls (see the section Using JNI with COBOL in the chapter Calling Procedural COBOL from Java).
object[] | pointer | object reference to instance of class jarray | An array of Java objects. The pointer returned to procedural COBOL can be used with JNI calls (see the section Using JNI with COBOL in the chapter Calling Procedural COBOL from Java). jarray is an OO COBOL class for accessing the contents of Java arrays, and is described in the section Using the Jarray Class.
DataType | structure | structure | Complex data structure
Comp3 | comp-3 | comp-3 | COMP(UTATIONAL)-3 or Packed-Decimal
Pointer(StringBuffer) Pointer(String, int capacity) | pic x(99) | pic x(99) | Wraps a String, StringBuffer so it can safely be passed to COBOL with the right size allocated for the receiving COBOL to modify the Java object. StringBuffer capacity is used as the largest possible length that COBOL can edit.
java.sql.Date(long) CobolDate(date) | 0x jyear pic 9(4). 0x filler pic x. 0x jmonth pic 99. 0x filler pic x. 0x jday pic 99. | same as for cobcall | Standard SQL Date type as used by JDBC
java.sql.time(long) CobolTime(time) | 0x jhour pic 99. 0x filler pic x. 0x jminute pic 99. 0x filler pic x. 0x jseconds pic 99. | same as for cobcall | Standard SQL Time type as used by JDBC
CobolBigDecimal(java.math.BigDecimal) | pic s9(19)v9(19) comp-3 | same as for cobcall | The CobolBigDecimal wrapper class enables COBOL to update the value of a BigDecimal. The constructor for CobolBigDecimal() takes an initial value and the updated value can be obtained by using the .getValue() method.
CobolBigInteger(java.math.BigInteger) | pic S9(38) comp-3 | same as for cobcall | The CobolBigInteger wrapper class enables COBOL to update the value of a BigInteger. The constructor for CobolBigInteger() takes an initial value and the updated value can be obtained by using the .getValue() method.
CustomRecord | Structure | Structure | Complex data structure represented in Java as an array of objects.
CobolN ational | pic x(n) usage is national. | same as for cobcall | This java class enables you to create UTF-16 strings that you can pass to COBOL.

The conversion of COBOL data types that are not listed in the COBOL or OO COBOL columns of the above table is not supported. If you need to use a COBOL data item of a type not listed above, use an intermediate data item of a supported type and move your data to and from the intermediate data item as necessary.

Parent topic: Java Data Types
Related information
Using the Jarray Class
Calling Procedural COBOL from Java
Calling OO COBOL from Java
Calling Java from OO COBOL
1 The parameter can be passed only by reference. For floating point data types this restriction applies to UNIX platforms only. For long data types on 32-bit platforms the parameter can be passed by reference only, and on 64-bit platforms by reference or by value only.
2 Use mf-jstring for .cobcall(...). mf-jstring requires the receiving COBOL program to use ptr2string pointer to access the Java String or StringBuffer. Using mf-jstring gives you access to the size and capacity of the Java object.
3 Use pointer for .cobcall(...).
4 StringBuffer objects can be received by OO COBOL methods as pic x(n) data items but pic x(n) cannot be used to pass data to a Java method with a StringBuffer parameter.


Java Typedefs

Restriction: This applies to native code only.

For convenience, copybook javatypes.cpy defines a set of COBOL data types corresponding to Java data types - you can use these as a shorthand way of declaring data items for use with Java in your COBOL programs. You can find the copybook in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source directory.

These typedefs all start with the prefix "j" and are shown in the following table:

Typedef | COBOL Type
jbyte | pic s99 comp-5
jshort | pic s9(4) comp-5
jint | pic s9(9) comp-5
jlong | pic s9(18) comp-5
jboolean JNI-TRUE is true JNI-FALSE is false | pic 99 comp-5
jchar | pic 9(4) comp-5
jfloat | comp-1
jdouble | comp-2
jobject | pointer
jbigdecimal | pic s9(19)v9(19) comp-3 Programs that use this typedef must be compiled with the directive INTLEVEL 4
jbiginteger | pic s9(38) comp-3 Programs that use this typedef must be compiled with the directive INTLEVEL 4
mf-sql-date (in javatypes.cpy) | 0x jyear pic 9(4). 0x filler pic x. 0x jmonth pic 99. 0x filler pic x. 0x jday pic 99.
mf-sql-time (in javatypes.cpy) | 0x jhour pic 99. 0x filler pic x. 0x jminute pic 99. 0x filler pic x. 0x jseconds pic 99.
Parent topic: Java Data Types


Using the Jarray Class

Restriction: This applies to native code only.

The jarray class provides an OO COBOL wrapper for manipulating Java arrays. It is fully documented in the Java Run-time Class Library Reference, which is in help\mfcobol.docs.zip in your COBOL development system installation.

The following COBOL program gets an array from a Java object, finds its dimensions, and displays the contents of the array.

$set ooctrl(+p-f)
 Program-id. ReadArray.
 class-control.
     arraydemo is class "$Java$arraydemo"
     .

 thread-local-storage section.
 01 aJavaObj             object reference.

 01 theTotal        pic 9(9).
 01 CDims           pic x(4) comp-5.
 01 Dims.
   03 Dims-entry    pic x(4) comp-5 occurs 256.
 01 Bounds.
   03 Bounds-entry  pic x(4) comp-5 occurs 256.
 01 ind0            pic x(4) comp-5.
 01 ind1            pic x(4) comp-5.
 01 arrayElement    pic x(4) comp-5.
 01 wsTable         object reference.
 01 wsResult        pic x(4) comp-5.

 procedure division.
   invoke arraydemo "new" returning aJavaObj
   invoke aJavaObj "getArray" returning wsTable

*> find out the number of elements in the array
     invoke wsTable "getDimensions" returning CDims
     display "The array has " CDims " dimension(s)"

*> get the number of elements in each dimension
     display "dimensions are " with no advancing
     invoke wsTable "getBounds" using Bounds
     perform varying ind0 from 1 by 1 until ind0 > CDims
          display Bounds-entry(ind0) with no advancing
          if ind0 < CDims
             display " by " with no advancing
          end-if
     end-perform
     display " "

*> display each element in the array
     perform varying ind0 from 0 by 1
             until ind0 = Bounds-entry(1)
         move ind0 to Dims-entry(1)
         perform varying ind1 from 0 by 1
                   until ind1 = Bounds-entry(2)
             move ind1 to Dims-entry(2)
             invoke wsTable "getElement" using
                             by value CDims
                             by reference Dims
                             by reference arrayElement
             display "Element " ind0 ","
                   ind1 " is " arrayElement
*> modify the contents of the array
             add 50 to arrayElement
             invoke wsTable "putElement" using
                             by value CDims
                             by reference Dims
                             by reference arrayElement
         end-perform
     end-perform

This is an implementation of the Java arraydemo class used by ReadArray. This program creates a two-dimensional array.

import com.microfocus.cobol.*;
import java.io.*;

public class arraydemo extends RuntimeSystem
{
    int myArray[][];
    public arraydemo()
    {
        myArray = new int[5][2];
        int i,j;
        for (i = 0; i < 5; i++)
        {
            for (j = 0; j < 2; j++)
                myArray[i][j] = i * 100 + j;
        }
    }
    public int[][] getArray()
    {
        return myArray;
    }
}
Parent topic: Java Data Types


Adding Parameters Using ParameterList()

Restriction: This applies to native code only.

The ParameterList() class in com.microfocus.cobol.lang helps with coding parameters being passed between Java and COBOL.

The general mechanism for using ParameterList() is:

   RuntimeSystem.cobcall("myProgram",
    new ParameterList()
        .add(myOneInt,RuntimeSystem.BY_VALUE)
        .add(mySecondParameter,RuntimeSystem.BY_REFERENCE)
           .add(99)		// 99 by reference
           );

Where the parameters are:

myProgram
The program being called.
myOneInt
An integer parameter being passed by value.
mySecondParameter
A parameter being passed by reference.
99
A numeric value being passed by reference.
Parent topic: Java Data Types


Using Structures

Restriction: This applies to native code only.

COBOL programs and OO COBOL methods can use structures in their Linkage Sections and be passed data from a Java class, providing that the corresponding Java parameter is an object which implements the com.microfocus.cobol.lang.Datatype interface or com.microfocus.cobol.lang.CustomRecord, as described below:

package com.microfocus.cobol.lang;
public interface DataType
{
   void synchronizeData();
   byte[] getBytes();
}

and

package com.microfocus.cobol.lang;
public interface CustomRecord
{
   public Object[] getParameters();
   public void setParameters(Object[] parms);
}

Using com.microfocus.cobol.lang.Datatype/com.microfocus.cobol.lang.CustomRecord enables you to pass non-simple data into a COBOL program or method without needing to rearchitect the interface with numerous elementary data types.

An example of a class that implements the com.microfocus.cobol.lang.Datatype interface is com.microfocus.cobol.lang.Pointer, which is defined in mfcobol.jar. It has the following constructors:

/* Create a Pointer object from String initString*/
public Pointer(String initString);

/* Create a Pointer object from StringBuffer initString */
public Pointer(StringBuffer initString);

/* Create a pointer object containing 'capacity' bytes, */
/* space filling if initString has fewer characters     */
/* than 'capacity'                                      */
public Pointer(String initString, int capacity);
Parent topic: Java Data Types


Creating Custom Records using com.microfocus.cobol.lang.CustomRecord Interface

Restriction: This applies to native code only.

Custom records are useful for passing group items to existing COBOL programs. You use then in conjunction with the .cobcall mechanism.

The CustomRecord interface is:

package com.microfocus.cobol.lang;
public interface CustomRecord
{
        public Object[] getParameters();
        public void setParameters(Object[] parms);
}

The data item customerDetails can be defined as follows:

01 customerDetails.
                    03 customerName 				pic x(30).
                    03 customerAddress		pic x(30).
                    03 customerRef 					pic 9(6).

A Java implementation could be:

import com.microfocus.cobol.lang.*;
import java.text.*;
public class RecordData implements
       com.microfocus.cobol.lang.CustomRecord
{
    private String customerName;
    private StringBuffer customerAddress;
    private int customerRef;
    RecordData(String name, String address, int ref)
    {
        customerName = name;
        customerAddress = new StringBuffer(address);
        customerRef = ref;
    }
    public String getCustomerName()
    {
        return this.customerName;
    }
    public String getCustomerAddress()
    {
        return this.customerAddress.toString();
    }
    public int getCustomerRef()
    {
        return this.customerRef;
    }
    public Object[] getParameters()
    {
        String strCustomerRef =
                Integer.toString(this.customerRef);
        while(strCustomerRef.length() < 6)
        {
            strCustomerRef = "0"+strCustomerRef;
        }
        customerAddress.setLength(30);
            /* must ensure length is right! */
        customerAddress.ensureCapacity(30);
        return new ParameterList()
            .add(new Pointer(this.customerName,30))
            .add(this.customerAddress)
            .add(strCustomerRef.getBytes())
            .getArguments();
    }
    public void setParameters(Object[] parms)
    {
        Pointer ptr = (Pointer)parms[0];
        this.customerName = ptr.toString();
        this.customerAddress = (StringBuffer)parms[1];
        byte[] byteCustomerRef = (byte[])parms[2];
        this.customerRef =
            Integer.parseInt(new String(byteCustomerRef));
    }
    public String toString()
    {
        return "Customer Name :
        "+this.customerName+"\n"+ "Customer Address :
        "+this.customerAddress+"\n"+
        "Customer Ref : "+this.customerRef;
    }
}

and

package com.microfocus.cobol.lang;
public interface CustomRecord
{
   public Object[] getParameters();
   public void setParameters(Object[] parms);
}
Parent topic: Java Data Types


OO COBOL Class Library Reference

Help for the following OO COBOL class libraries is available:

  • Base class library
  • GUI class library
  • OLE class library
  • OLE Automation class library

The Help is available in the file nxrclr.chm, which is installed in the Help folder of your installation. The default location is %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Help.

To open the help, double-click nxrclr.chm in Windows Explorer.

Parent topic: Compatibility


User Interface Programming

  • Windows Forms
  • Web Application Projects
  • Web Forms
Parent topic: Compatibility


Windows Forms

  • To deploy a Windows application to the .NET environment
Parent topic: User Interface Programming


To deploy a Windows application to the .NET environment

We recommend that you use a Windows setup project to deploy a Windows application, as follows:

  1. Click File > New > Project.
  2. Expand Other Project Types and choose Setup and Deployment >Setup Project.
  3. Fill in the rest of the details as required.

    See the Visual Studio Help for details.

Alternatively, you can deploy your COBOL application without a setup project, as follows:

  1. Use the Xcopy command (which copies a directory structure) to copy your application files from the project output directory to the directory containing your Micro Focus Server installation.
Parent topic: Windows Forms


Web Application Projects

  • To deploy a Web Application to the .NET environment
Parent topic: User Interface Programming


To deploy a Web Application to the .NET environment

We recommend that you use Visual Studio to publish COBOL Web Applications, as follows:

  1. Select the Web Application project in Solution Explorer.
  2. Click Build > Publish WebApplication and specify publish details and credentials as needed. See the Visual Studio Help for details.
Parent topic: Web Application Projects


Web Forms

  • To deploy a COBOL Web site to the .NET environment
  • To deploy a CICS service interface to the .NET environment
Parent topic: User Interface Programming


To deploy a COBOL Web site to the .NET environment

We recommend that you use Visual Studio to publish COBOL Web sites, as follows:

  1. Click Build > Publish Web Site and specify the target location. See the Visual Studio Help for details.

Alternatively, you can deploy a COBOL Web site manually, as follows:

  1. Create a folder on the deployment machine to contain the Web site.
  2. Copy the files in the Web Site folder and its subfolders to the new location.

    If you cannot copy the files because of a "file is in use" error, you need to stop IIS and restart it. Then you should be able to copy the files.

  3. Execute the application from the new location.
Parent topic: Web Forms
Related information
Deploying Web and ASP.NET Applications


To deploy a CICS service interface to the .NET environment

  1. Create a folder on the deployment machine to contain the Web site.

    If you used the Service Interfaces feature generate a Web Forms client for a CICS service interface, the name of the folder must be the project name, and it must be located in \inetpub\wwwroot. For example, c:\inetpub\wwwroot\esbank where esbank is the project name.

  2. Copy the files in the Web Site folder and its subfolders to the new location.

    If you cannot copy the files because of a "file is in use" error, you need to stop IIS and restart it. Then you should be able to copy the files.

  3. Update the system path to point to IISpath\projectname\bin

    Where:

    • IISpath is the path to IIS on the deployment machine
    • projectname is the name of the project
  4. Register the file ProxyWrapper.dll, using commands such as:
    cd IISpath\projectname\bin
regsvr32.exe servicenameProxyWrapper.dll

    Where servicename is the name of the generated service.

  5. Execute the application from the new location.
Note: To redeploy, you need to repeat the above process, except that you do not need to update the system path again.
Parent topic: Web Forms
Related information
Deploying Web and ASP.NET Applications
Deploying COBOL Applications to the .NET Environment


Data Access

  • Database Access
  • Micro Focus Database Connectors Version 2.0 for Windows
  • File Handling
Parent topic: Programming


Database Access

We provide several programming options and features to accommodate database access in your COBOL applications.

  • Database Access Preprocessors
    Provides introductory information about each of the supported Database Access preprocessors.
  • Developing SQL Applications
    Information to assist you in developing SQL applications from scratch or maintaining SQL applications developed elsewhere.
  • Compiling SQL Applications
    Explains the process of compiling (building) and debugging SQL applications.
  • OpenESQL
    Explains the functionality available with the OpenESQL preprocessor and provides information for developing and deploying OpenESQL SQL applications.
  • DB2
    Explains the functionality associated with the DB2 External Compiler Module (ECM) preprocessor, and provides information for developing and deploying DB2 ECM SQL applications.
  • COBSQL
    Explains the functionality associated with the COBSQL preprocessor, and provides information for developing and deploying SQL applications for Oracle, Sybase, and Informix.
  • How to...
    How to use the database access utilities and editors available to help you develop and deploy your SQL applications.
  • Reference
    Reference information for embedded statements, compiler directives, and other coding standards associated with database access.
Parent topic: Data Access
Related concepts
Database Access Support with Native COBOL
Database Access Support with .NET Managed COBOL


Database Access Preprocessors

A database access preprocessor is essentially a conversion tool called by the COBOL compiler that processes embedded SQL, and can convert embedded SQL into code that is understood by your target database. Studio Enterprise Edition provides three database access preprocessors from which to choose, all designed to work closely with the Micro Focus COBOL Compiler.

OpenESQL Preprocessor

The OpenESQL preprocessor is the most flexible of the three available in Studio Enterprise Edition. Use it for basic SQL applications, applications designed to use multiple relational database systems, and for applications you might want to update to use a different relational database system in the future. In addition to processing embedded SQL statements, the OpenESQL preprocessor converts COBOL data types to their equivalent SQL data types.

OpenESQL provides these levels of database access:
  • ODBC for native applications
  • ADO.NET for managed .NET applications

DB2 External Compiler Module (ECM) Preprocessor

The DB2 ECM preprocessor converts embedded SQL statements into the appropriate calls to DB2 database services. Use this preprocessor for applications that access a DB2 relational database.

COBSQL Preprocessor

COBSQL is an integrated preprocessor designed to work with COBOL precompilers supplied by the Oracle, Sybase, and Informix relational database vendors. Use COBSQL if you are already using one of these precompilers with an earlier version of a Micro Focus COBOL product and want to migrate your application(s) to Studio Enterprise Edition. For any other type of embedded SQL application development, we recommend that you use OpenESQL.

This preprocessor replaces embedded SQL statements with the appropriate calls to database services, and adds code to bind COBOL host variables to the SQL variable names known to the database system.

When using the COBSQL precompiler with Studio Enterprise Edition, you can debug programs from the original source code rather than from the code produced by the precompiler.

Note: The COBSQL preprocessor is supported only for standard procedural COBOL programs. You cannot use COBSQL with Object Oriented COBOL syntax (OO programs) or with nested programs.
Parent topic: Database Access
Related concepts
OpenESQL
COBSQL
DB2


Developing SQL Applications

The following topics describe the programming features available for SQL applications in general. Specific information on programming for a particular preprocessor is contained in the topics covering the use of that preprocessor.

  • Embedded SQL
    Instructions on how to embed SQL statements into your programs.
  • Host Variables
    The purpose of host variables, how to declare them, and how to use them in your SQL applications.
  • Cursors
    The purpose of cursors, how to declare them, and how to use them in SQL applications.
  • Data Structures
    The purpose and use of the SQLCA and SQLDA data structures available for SQL applications.
  • Dynamic SQL
    An explanation of how dynamic SQL works, and a description of its purpose, advantages, and use.
Parent topic: Database Access


Embedded SQL

Each of the database access preprocessors works by taking the SQL statements that you have embedded in your COBOL program and converting them to the appropriate function calls to the database.

Keywords

In your COBOL program, each embedded SQL statement must be preceded by the introductory keywords:

EXEC SQL

and followed by the keyword:

END-EXEC

For example:

     EXEC SQL
         SELECT au_lname INTO :lastname FROM authors
          WHERE au_id = '124-59-3864'
     END-EXEC

The embedded SQL statement can be broken over as many lines as necessary following the normal COBOL rules for continuation, but between the EXEC SQL and END-EXEC keywords you can only code an embedded SQL statement; you cannot include any ordinary COBOL code.

The case of embedded SQL keywords in your programs is ignored. You can use all upper-case, all lower-case, or a combination of the two. For example, the following are all equivalent:

EXEC SQL CONNECT
exec sql connect
Exec Sql Connect

Cursor names, statement names, and connection names

The case of cursor names, statement names and connection names must match that used when the variable is declared. For example, if you declare a cursor as C1, you must always refer to it as C1 (and not as c1).

The settings for the particular database determine whether such things as connection names, table and column names, are case-sensitive.

SQL identifiers

Hyphens are not permitted in SQL identifiers such as table and column names.

SQL identifiers are typically restricted regarding which characters they support. Typically, unquoted identifiers can only contain A-Z, 0-9 and underscore. Some databases might also allow lower-case characters, and/or @ and # symbols. If your SQL identifiers contain any other characters, such as a grave accent, spaces, or DBCS characters, they must be delimited. Refer to your database vendor documentation for more information, including the character to use as the delimiter.

SQL statements

Most vendors provide SQL Reference documentation with their database software that includes full information about embedded SQL statements. Regardless of the database software, you should, for example, be able to perform the following typical operations using the statements shown:

Operation | SQL Statement(s)
Add data to a table | INSERT
Change data in a table | UPDATE
Retrieve a row of data from a table | SELECT
Create a named cursor | DECLARE CURSOR
Retrieve multiple rows of data using a cursor | OPEN, FETCH, CLOSE

A full syntax description is given for each of the supported embedded SQL statements, together with an example of its use, in the topics under Embedded SQL Statements.

Parent topic: Developing SQL Applications
Related reference
Embedded SQL Statements


Host Variables

Host variables are data items defined within a COBOL program. They are used to pass values to and receive values from a database. Host variables can be defined in the File Section, Working-Storage Section, Local-Storage Section or Linkage Section of your COBOL program and can be coded using any level number between 1 and 48.

A host variable can be input or output:
  • Input host variables - to specify data to be transferred from the COBOL program to the database
  • Output host variables - to hold data to be returned to the COBOL program from the database

To use host variables, you must declare them in your program and then reference them in your SQL statements.

A host variable can be defined as any of the following types:
  • Simple Host Variable - to store and retrieve a single string of data
  • Host Array - to store and retrieve multiple rows of data
  • Indicator Variable - a companion variable that store null value and data truncation information
  • Indicator Array - a companion array used to store null value and data truncation information for multiple rows

See the topics listed under Related concepts below for more information on features related to host variables.

Note: The OpenESQL Managed .NET Runtime supports .NET host variables in managed code. See the topic .NET Host Variables in Managed Code for more information.
  • Simple Host Variables
    Instructions for declaring and referencing simple host variables in your COBOL programs.
  • Host Arrays
    Instructions for declaring and referencing an array of host variables.
  • Indicator Variables
    A description of the types and uses of indicator variables in SQL applications.
  • Indicator Arrays
    A description of the types and uses of indicator arrays in SQL applications.
  • COBOL to SQL Data Type Mapping
    Describes how preprocessors map COBOL data types to SQL data types.
  • SQL TYPEs
    A description of SQL TYPE declarations and an example of using them with date, time, and timestamp fields.
Parent topic: Developing SQL Applications
Related concepts
.NET Host Variables in Managed Code


Simple Host Variables

Before you can use a host variable in an embedded SQL statement, you must declare it.

Declaring simple host variables

Generally, host variable declarations are coded as data items bracketed by the embedded SQL statements BEGIN DECLARE SECTION and END DECLARE SECTION. The following rules also apply:
  • You can use groups of data items as a single host variable. However, a group item cannot be used in a WHERE clause.
  • OpenESQL trims trailing spaces from character host variables. If the variable consists entirely of spaces, OpenESQL does not trim the first space character because some servers treat a zero length string as NULL.
  • For OpenESQL and DB2 ECM only, you can use COBOL data items as host variables even if they have not been declared using BEGIN DECLARE SECTION and END DECLARE SECTION.
  • Host variable names must conform to the COBOL rules for data items.
  • Host variables can be declared anywhere that it is legal to declare COBOL data items.
  • Underscores (_) are permitted in host variable names only when you compile using the ENTCOBOL dialect.

Referencing simple host variables

You reference host variables from embedded SQL statements. When you code a host variable name into an embedded SQL statement, it must be preceded by a colon (:) to enable the compiler to distinguish between the host variable and tables or columns with the same name.

Example

 EXEC SQL
     BEGIN DECLARE SECTION
 END-EXEC
 01 id             pic x(4).
 01 name           pic x(30).
 01 book-title     pic x(40).
 01 book-id        pic x(5).
 EXEC SQL
    END DECLARE SECTION
 END-EXEC
    . . .
     display "Type your identification number: "
     accept id.

* The following statement retrieves the name of the
* employee whose ID is the same as the contents of
* the host variable "id". The name is returned in
* the host variable "name".

     EXEC SQL
         SELECT emp_name INTO :name FROM employees
          WHERE emp_id=:id
     END-EXEC
     display "Hello " name.

* In the following statement, :book-id is an input
* host variable that contains the ID of the book to
* search for, while :book-title is an output host
* variable that returns the result of the search.

     EXEC SQL
        SELECT title INTO :book-title FROM titles
           WHERE title_id=:book-id
     END-EXEC
Parent topic: Host Variables


Host Arrays

An array is a collection of data items associated with a single variable name. You can define an array of host variables (called host arrays) and operate on them with a single SQL statement.

You can use host arrays as input variables in INSERT, UPDATE and DELETE statements and as output variables in the INTO clause of SELECT and FETCH statements. This means that you can use arrays with SELECT, FETCH, DELETE, INSERT and UPDATE statements to manipulate large volumes of data.

Some of the benefits to using host arrays include:
  • You can perform multiple CALL, EXECUTE, INSERT or UPDATE operations by executing only one SQL statement, which can significantly improve performance, especially when the application and the database are on different systems.
  • You can fetch data in batches, which can be useful when creating a scrolling list of information.

As with simple host variables, you must declare host arrays in your program and then reference them in your SQL statements.

Declaring host arrays

Host arrays are declared in much the same way as simple host variables using BEGIN DECLARE SECTION and END DECLARE SECTION. With host arrays, however, you must use the OCCURS clause to dimension the array.

Referencing host arrays

The following rules apply to coding host arrays into embedded SQL statements:
  • Just as with simple host variables, you must precede a host array name with a colon (;).
  • If the number of rows available is more than the number of rows defined in an array, a SELECT statement returns the number of rows defined in the array, and an SQLCODE message is issued to indicate that the additional rows could not be returned.
  • Use a SELECT statement only when you know the maximum number of rows to be selected. When the number of rows to be returned is unknown, use the FETCH statement.
  • If you use multiple host arrays in a single SQL statement, their dimensions must be the same.
  • OpenESQL does not support the mixing of host arrays and simple host variables within a single SQL statement. They must be all simple or all arrays.
  • For OpenESQL, you must define all host variables within a host array with the same number of occurrences. If one variable has 25 occurrences, all variables in that host array must have 25 occurrences.
  • If you are using COBSQL with a Sybase database, you can only use host arrays in SELECT and FETCH statements as output variables.
  • If you are using COBSQL with Oracle or Sybase, you can code a simple host variable in the WHERE clause of a SELECT statement that references a host array. This is the only scenario that allows the mixing of simple host variables and host arrays.
  • Optionally, use the FOR clause to limit the number of array elements processed to just those that you want. This is especially useful in UPDATE, INSERT and DELETE statements where you may not want to use the entire array. The following rules apply:
    • If the value of the FOR clause variable is less than or equal to zero, no rows are processed.
    • The number of array elements processed is determined by comparing the dimension of the host array with the FOR clause variable. The lesser value is used.
    • COBSQL supports the FOR clause with Oracle databases only.

Examples

The following example shows typical host array declarations and references.

 EXEC SQL
     BEGIN DECLARE SECTION
 END-EXEC
 01 AUTH-REC-TABLES
    05 Auth-id       OCCURS 25 TIMES PIC X(12).
    05 Auth-Lname    OCCURS 25 TIMES PIC X(40).
 EXEC SQL
    END DECLARE SECTION
 END-EXEC.
  . . .

     EXEC SQL
         CONNECT USERID 'user' IDENTIFIED BY 'pwd'
                 USING 'db_alias'
     END-EXEC
     EXEC SQL
         SELECT au-id, au-lname
          INTO :Auth-id, :Auth-Lname FROM authors
     END-EXEC
     display sqlerrd(3)

The following example demonstrates the use of the FOR clause, showing 10 rows (the value of :maxitems) modified by the UPDATE statement:

 EXEC SQL
     BEGIN DECLARE SECTION
 END-EXEC
 01 AUTH-REC-TABLES
    05 Auth-id       OCCURS 25 TIMES PIC X(12).
    05 Auth-Lname    OCCURS 25 TIMES PIC X(40).
 01 maxitems         PIC S9(4) COMP-5 VALUE 10.
 EXEC SQL
     END DECLARE SECTION
 END-EXEC.
   . . .
     EXEC SQL
         CONNECT USERID 'user' IDENTIFIED BY 'pwd'
                 USING 'db_alias'
     END-EXEC
     EXEC SQL
         FOR :maxitems
          UPDATE   authors
           SET   au_lname = :Auth_Lname
           WHERE au_id  = :Auth_id
     END-EXEC
     display sqlerrd(3)
Parent topic: Host Variables


Indicator Variables

Use indicator variables to:
  • Assign null values
  • Detect null values
  • Detect data truncation

Unlike COBOL, SQL supports variables that can contain null values. A null value means that no entry has been made and usually implies that the value is either unknown or undefined. A null value enables you to distinguish between a deliberate entry of zero (for numerical columns) or a blank (for character columns) and an unknown or inapplicable entry. For example, a null value in a price column does not mean that the item is being given away free, it means that the price is not known or has not been set.

Important: When a host variable is null, its indicator variable has the value -1; when a host variable is not null, the indicator variable has a value other than -1.

Indicator variables serve an additional purpose if truncation occurs when data is retrieved from a database into a host variable. If the host variable is not large enough to hold the data returned from the database, the warning flag sqlwarn1 in the SQLCA data structure is set and the indicator variable is set to the size of the data contained in the database.

Declaring indicator variables

Indicator variables are always defined as:

pic S9(4) comp-5.

Referencing indicator variables

Together, a host variable and its companion indicator variable specify a single SQL value. The following applies to coding a host variable with a companion indicator variable:
  • Both variables must be preceded by a colon (:).
  • Place an indicator variable immediately after its corresponding host variable.
  • Reference the host variable and indicator variable in a FETCH INTO or SELECT ...INTO statement with or without an INDICATOR clause as follows:
    :hostvar:indicvar

    or

    :hostvar INDICATOR :indicvar
  • You cannot use indicator variables in a search condition. To search for null values, use the is null construct instead.

Examples

This example demonstrates the declaration of an indiator variable that is used in a FETCH ...INTO statement.

 EXEC SQL
     BEGIN DECLARE SECTION
 END-EXEC
 01 host-var       pic x(4).
 01 indicator-var  pic S9(4) comp-5.
 EXEC SQL
    END DECLARE SECTION
 END-EXEC
    . . .

     EXEC SQL
         FETCH myCursor INTO :host-var:indicator-var
     END-EXEC

The following shows an embedded UPDATE statement that uses a saleprice host variable with a companion indicator variable, saleprice-null:

     EXEC SQL
        UPDATE closeoutsale
           SET temp_price = :saleprice:saleprice-null,
                listprice = :oldprice
     END-EXEC

In this example, if saleprice-null has a value of -1, when the UPDATE statement executes, the statement is read as:

     EXEC SQL
        UPDATE closeoutsale
           SET temp_price = null, listprice = :oldprice
     END-EXEC

This example demonstrates the use of the is null construct to do a search:

     if saleprice-null equal -1
         EXEC SQL
             DELETE FROM closeoutsale
                    WHERE temp_price is null
         END-EXEC
     else
         EXEC SQL
             DELETE FROM closeoutsale
                    WHERE temp_price = :saleprice
         END-EXEC
     end-if
Parent topic: Host Variables


Indicator Arrays

Just as an indicator variable is used as a companion to a host variable, use an indicator array as a companion to a host array to indicate the null status of each returned row or to store data truncation warning flags.

Note: COBSQL supports indicator arrays with Oracle databases only.

Example

In this example, an indicator array is set to -1 so that it can be used to insert null values into a column:
 01 ix                       PIC 99 COMP-5.
   . . .
 EXEC SQL
     BEGIN DECLARE SECTION
 END-EXEC
 01 sales-id       OCCURS 25 TIMES PIC X(12).
 01 sales-name     OCCURS 25 TIMES PIC X(40).
 01 sales-comm     OCCURS 25 TIMES PIC S9(9) COMP-5.
 01 ind-comm       OCCURS 25 TIMES PIC S9(4) COMP-5.
 EXEC SQL
     END DECLARE SECTION
 END-EXEC.
  . . .
     PERFORM VARYING iX FROM 1 BY 1 UNTIL ix > 25
         MOVE -1 TO ind-comm (ix)
     END-PERFORM.
      . . .
     EXEC SQL
         INSERT INTO SALES (ID, NAME, COMM)
           VALUES (:sales_id, :sales_name, :sales_comm:ind-comm)
     END-EXEC
Parent topic: Host Variables


COBOL to SQL Data Type Mapping

SQL has a standard set of data types, but the exact implementation of these varies between databases, and many databases do not implement the full set.

Within a program, COBOL host variable declarations can serve both as COBOL host variables and as SQL database variables. To make this possible, the preprocessor converts COBOL data types to their equivalent SQL data types. We sometimes refer to this conversion process as mapping COBOL data types to SQL data types. The preprocessor looks for specific COBOL picture clause formats that identify those that require mapping to SQL data types. For mapping to be successful, you must declare your COBOL host variables using these specific COBOL picture clauses.

We provide SQL data types for the OpenESQL and DB2 ECM preprocessors. For complete information on each SQL data type and its required COBOL host variable formats, see the SQL Data Types and SQL/COBOL Data Type Mappings Reference topics.

Note: For information on the appropriate host variable formats to use with the COBSQL preprocessor, see your DBMS documentation.
Parent topic: Host Variables
Related reference
SQL TYPEs
SQL Data Types
SQL/COBOL Data Type Mappings


SQL TYPEs

Manipulating SQL data that involves date, time, or binary data can be complicated using traditional COBOL host variables, and traditional techniques for handling variable-length character data can also be problematic. To make working with this data easier, we provide the SQL TYPE declaration to make it easier to specify host variables that more closely reflect the natural data types of relational data stores. This allows more applications to be built using static rather than dynamic SQL syntax, and also can help to optimize code execution.

You can code SQL TYPEs directly into your applications or, for OpenESQL applications, use the OpenESQL Assistant to automatically use SQL TYPEs by setting the Type COBOL Variable option for the OpenESQL Assistant to SQL TYPE.

Note: For a complete listing of available SQL TYPEs, see the SQL TYPEs reference topic.

Example: Defining date, time, and timestamp fields as SQL TYPEs

This example program shows date, time and timestamp escape sequences being used, and how to redefine them as SQL TYPEs. It applies to both OpenESQL and DB2 ECM:

 working-storage section.
 EXEC SQL INCLUDE SQLCA END-EXEC

 01  date-field1      pic x(29).
 01  date-field2      pic x(29).
 01  date-field3      pic x(29).

 procedure division.
     EXEC SQL
        CONNECT TO 'Net Express 4.0 Sample 1' USER 'admin'
     END-EXEC
* If the Table is there drop it.
     EXEC SQL
        DROP TABLE DT
     END-EXEC

* Create a table with columns for DATE, TIME, and DATE/TIME
* NOTE:  Access uses DATETIME column for all three.
*        Some databases will have dedicated column types.
* If you are creating DATE/TIME columns on another data
* source, refer to your database documentation to see how to
* define the columns.

     EXEC SQL
        CREATE TABLE DT ( id  INT,
                        myDate DATE NULL,
                        myTime TIME NULL,
                        myTimestamp TIMESTAMP NULL)
     END-EXEC

* INSERT into the table using the ODBC Escape sequences

     EXEC SQL
        INSERT into DT values (1 ,
            {d '1961-10-08'},  *> Set just the date part
            {t '12:21:54'  },  *> Set just the time part
            {ts '1966-01-24 08:21:56' } *> Set both parts
                              )
     END-EXEC

* Retrieve the values we just inserted

     EXEC SQL
        SELECT myDate
              ,myTime
              ,myTimestamp
         INTO  :date-field1
              ,:date-field2
              ,:date-field3
         FROM DT
         where id = 1
     END-EXEC

* Display the results.

     display 'where the date part has been set :'
             date-field1
     display 'where the time part has been set :'
             date-field2
     display 'NOTE, most data sources will set a default '
             'for the date part '
     display 'where both parts has been set :'
             date-field3

* Remove the table.

     EXEC SQL
        DROP TABLE DT
     END-EXEC

* Disconnect from the data source

     EXEC SQL
        DISCONNECT CURRENT
     END-EXEC

     stop run.

Alternatively you can use host variables defined with SQL TYPEs for date/time variables. Define the following host variables:

01  my-id          pic s9(08) COMP-5.
01  my-date        sql type is date.
01  my-time        sql type is time.
01  my-timestamp   sql type is timestamp.

and replace the INSERT statement with the following code:

*> INSERT into the table using SQL TYPE HOST VARS
    move 1                           to  MY-ID
    move "1961-10-08"                to  MY-DATE
    move "12:21:54"                  to  MY-TIME
    move "1966-01-24 08:21:56"       to  MY-TIMESTAMP

     EXEC SQL
        INSERT into DT value (
          :MY-ID
         ,:MY-DATE
         ,:MY-TIME
         ,:MY-TIMESTAMP  )
     END-EXEC
Parent topic: Host Variables
Related reference
SQL TYPEs


Cursors

When you write code in which the results set returned by a SELECT statement includes more than one row of data, you must declare and use a cursor. A cursor indicates the current position in a results set, in the same way that the cursor on a screen indicates the current position.

A cursor enables you to:

  • Fetch rows of data one at a time
  • Perform updates and deletions at a specified position within a results set.

The example below demonstrates the following sequence of events:

  1. The DECLARE CURSOR statement associates the SELECT statement with the cursor Cursor1.
  2. The OPEN statement opens the cursor, thereby executing the SELECT statement.
  3. The FETCH statement retrieves the data for the current row from the columns au_fname and au_lname and places the data in the host variables first_name and last_name.
  4. The program loops on the FETCH statement until no more data is available.
  5. The CLOSE statement closes the cursor.
 EXEC SQL DECLARE Cursor1 CURSOR FOR
     SELECT au_fname, au_lname FROM authors
 END-EXEC
  . . .
     EXEC SQL
         OPEN Cursor1
     END-EXEC
       . . .
     perform until sqlcode not = zero
         EXEC SQL
             FETCH Cursor1 INTO :first_name,:last_name
         END-EXEC
         display first_name, last_name
     end-perform
      . . .
     EXEC SQL
         CLOSE Cursor1
     END-EXEC
  • Declaring a Cursor
  • Opening a Cursor
  • Using a Cursor to Retrieve Data
  • Closing a Cursor
  • Positioned UPDATE and DELETE Statements
  • Using Cursors
Parent topic: Developing SQL Applications
Related concepts
Dynamic SQL Statements and Cursors
Related reference
FETCH
OPEN
QUERY ODBC
SELECT INTO
UPDATE (Positioned)


Declaring a Cursor

Before a cursor can be used, it must be declared. This is done using the DECLARE CURSOR statement in which you specify a name for the cursor and either a SELECT statement or the name of a prepared SQL statement.

Cursor names must conform to the rules for identifiers on the database that you are connecting to, for example, some databases do not allow hyphens in cursor names.

 EXEC SQL
     DECLARE Cur1 CURSOR FOR
      SELECT first_name FROM employee
       WHERE last_name = :last-name
 END-EXEC

This example specifies a SELECT statement using an input host variable (:last-name). When the cursor OPEN statement is executed, the values of the input host variable are read and the SELECT statement is executed.

 EXEC SQL
     DECLARE Cur2 CURSOR FOR stmt1
 END-EXEC
      . . .
     move "SELECT first_name FROM emp " &
          "WHERE last_name=?" to prep.
     EXEC SQL
        PREPARE stmt1 FROM :prep
     END-EXEC
      . . .
     EXEC SQL
        OPEN Cur2 USING :last-name
     END-EXEC

In this example, the DECLARE CURSOR statement references a prepared statement (stmt1). A prepared SELECT statement can contain question marks (?) which act as parameter markers to indicate that data is to be supplied when the cursor is opened. The cursor must be declared before the statement is prepared.

Within an Object Oriented (OO) program, you can declare a cursor anywhere that it is valid to declare a data item. Cursors are local to the object that they are opened in, that is, two instances of an object opening the "same" cursor each get their own cursor instance. You can open a cursor in one method, fetch it in a second and close it in a third but it must be declared in the Object-Storage Section if you want to do this.

COBSQL

A cursor can be declared in either the Data Division or the Procedure Division of your program. The DECLARE CURSOR statement does not generate any code but if a cursor is declared within the Procedure Division, COBSQL generates a debug breakpoint for the DECLARE CURSOR statement.

Note:
  • Object oriented COBOL syntax is not supported by COBSQL.
  • Some versions of the Informix precompiler can generate incorrect code if a cursor is declared within the Working-Storage Section. We therefore recommend that you only declare cursors in the Procedure Division when using INFORMIX.
Parent topic: Cursors


Opening a Cursor

Once a cursor has been declared, it must be opened before it can be used. This is done using the OPEN statement, for example:

     EXEC SQL
         OPEN Cur1
     END-EXEC

If the DECLARE CURSOR statement references a prepared statement that contains parameter markers, the corresponding OPEN statement must specify the host variables or the name of an SQLDA structure that will supply the values for the parameter markers, for example:

     EXEC SQL
         OPEN Cur2 USING :last-name
     END-EXEC

If an SQLDA data structure is used, the data type, length, and address fields must already contain valid data when the OPEN statement is executed.

COBSQL

  • When a cursor is opened, no locks are applied to the tables the data is being selected from.
  • An Oracle database allows a cursor to be re-opened before it is closed such that the SELECT statement is re-evaluated. If the program has been compiled in ANSI mode, however, re-opening the cursor before it has been closed generates an error. For more information on the MODE precompiler directive, refer to the Programmer's Guide to the ORACLE Precompilers.
Parent topic: Cursors


Using a Cursor to Retrieve Data

Once a cursor has been opened, it can be used to retrieve data from the database. This is done using the FETCH statement. The FETCH statement retrieves the next row from the results set produced by the OPEN statement and writes the data returned to the specified host variables (or to addresses specified in an SQLDA structure). For example:

     perform until sqlcode not = 0
         EXEC SQL
            FETCH Cur1 INTO :first_name
         END-EXEC
         display 'First name: ' fname
         display 'Last name : ' lname
         display spaces
     end-perform

When the cursor reaches the end of the results set, a value of 100 is returned in SQLCODE in the SQLCA data structure and SQLSTATE is set to "02000".

As data is fetched from a cursor, locks can be placed on the tables from which the data is being selected.

COBSQL

The ORACLE precompiler directive, MODE, affects the value put into SQLCODE when no data is found. For more information on the use of the MODE precompiler directive, refer to the Programmer's Guide to the ORACLE Precompilers.

Parent topic: Cursors


Closing a Cursor

When your application has finished using the cursor, it should be closed using the CLOSE statement. For example:

     EXEC SQL
         CLOSE Cur1
     END-EXEC

Normally, when a cursor is closed, all locks on data and tables are released. If the cursor is closed within a transaction, however, the locks may not be released.

COBSQL

  • The ORACLE precompiler directive, MODE, affects what happens to a cursor when either the commit or rollback command is used. For more information on the use of the precompiler directive MODE, refer to the Programmer's Guide to the ORACLE Precompilers.
  • When a cursor is closed, the ORACLE client may deallocate the memory and resources associated with the cursor. The following precompiler options control the deallocation of cursors: HOLD_CURSOR, MAXOPENCURSORS and RELEASE_CURSOR. For more information on the use of the precompiler directives, refer to the Programmer's Guide to the ORACLE Precompilers.
Parent topic: Cursors


Positioned UPDATE and DELETE Statements

Positioned UPDATE and DELETE statements are used in conjunction with cursors and include WHERE CURRENT OF clauses instead of search condition clauses. The WHERE CURRENT OF clause specifies the corresponding cursor.

     EXEC SQL
         UPDATE emp SET last_name = :last-name
          WHERE CURRENT OF Cur1
     END-EXEC

This will update last_name in the row that was last fetched from the database using cursor Cur1.

     EXEC SQL
         DELETE emp WHERE CURRENT OF Cur1
     END-EXEC

This example will delete the row that was last fetched from the database using cursor Cur1.

OpenESQL

With some ODBC drivers, cursors that will be used for positioned updates and deletes must include a FOR UPDATE clause. Note that positioned UPDATE and DELETE are part of the Extended ODBC Syntax and are not supported by all drivers.

COBSQL

With COBSQL, cursors that will be used for positioned updates and deletes must include a FOR UPDATE clause.

Parent topic: Cursors


Using Cursors

Cursors are very useful for handling large amounts of data but there are a number of issues which you should bear in mind when using cursors, namely: data concurrency, integrity and consistency.

To ensure the integrity of your data, a database server can implement different locking methods. Some types of data access do not acquire any locks, some acquire a shared lock and some an exclusive lock. A shared lock allows other processes to access the data but not update it. An exclusive lock does not allow any other process to access the data.

When using cursors there are three levels of isolation and these control the data that a cursor can read and lock:

  • Level zero

    Level zero can only be used by read-only cursors. At level zero, the cursor will not lock any rows but may be able to read data that has not yet been committed. Reading uncommitted data is dangerous (as a rollback operation will reset the data to its previous state) and is normally called a "dirty read". Not all databases will allow dirty reads.

  • Level one

    Level one can be used by read-only cursors or updateable cursors. With level one, shared locks are placed on the data unless the FOR UPDATE clause is used. If the FOR UPDATE clause is used, exclusive locks are placed on the data. When the cursor is closed, the locks are released. A standard cursor, that is a cursor without the FOR UPDATE clause, will normally be at isolation level one and use shared locks.

  • Level three

    Level three cursors are used with transactions. Instead of the locks being released when the cursor is closed, the locks are released when the transaction ends. With level three it is usual to place exclusive locks on the data.

It is worth pointing out that there can be problems with deadlocks or "deadly embraces" where two processes are competing for the same data. The classic example is where one process locks data A and then requests a lock on data B while a second process locks data B and then requests a lock on data A. Both processes have data that the other process requires. The database server should spot this case and send errors to one, or both, processes.

COBSQL

Oracle, Sybase and Informix allow an application to set the isolation level of the cursor and their documentation discusses the types of locks that are applied and how they work. Their documentation also discusses the physical level that the data is locked at. This can be a single row, a set of rows (that is, the page level), or the whole table. Care should be taken when using cursors that scan multiple tables, or tables that are used by most processes, as this will reduce the accessibility of the locked data.

Note:

COBSQL

Oracle, Sybase and Informix allow cursors to be defined with a number of different clauses, for example FOR READ ONLY, FOR UPDATE etc. These clauses effect the isolation level of the cursor and how it will act when involved in transaction processing. For more information on the effect of these difference clauses, refer to the SQL reference book supplied with your database.

Parent topic: Cursors


Data Structures

The SQL preprocessors supplied with this system use two data structures:

Data Structure | Description | Function
SQLCA | SQL Communications Area | Returns status and error information.
SQLDA | SQL Descriptor Area | Describes the variables used in dynamic SQL statements.
  • SQL Communications Area (SQLCA)
  • The SQL Descriptor Area (SQLDA)
Parent topic: Developing SQL Applications
Related reference
DESCRIBE
EXECUTE IMMEDIATE
FETCH
INCLUDE
OPEN
PREPARE
SELECT INTO


SQL Communications Area (SQLCA)

After each embedded SQL statement is executed, error and status information is returned in the SQL Communications Area (SQLCA).

Oracle, Sybase and Informix all have different versions of the SQLCA. The Oracle, Sybase and Informix SQLCA's all have a SQLCODE, SQLERRML, SQLERRMC and a SQLWARN. The sizes and the positions of these fields can differ between the precompilers.

For details of the layout of the SQLCA data structure, see the topic The SQLCA Data Structure.

OpenESQL

The SQLCA provided with Studio Enterprise Edition for use with OpenESQL contains two variables (SQLCODE and SQLSTATE) plus a number of warning flags which are used to indicate whether an error has occurred in the most recently executed SQL statement.

COBSQL

See your third-party vendor documentation for details on testing the success or failure of a given SQL statement.

  • Using the SQLCA
  • The SQLCODE Variable
  • The SQLSTATE Variable
  • The Warning Flags
  • The WHENEVER Statement
  • SQLERRM
  • SQLERRD
Parent topic: Data Structures
Related concepts
Error Codes
Related reference
The SQLCA Data Structure


Using the SQLCA

The SQLCA structure is supplied in the file sqlca.cpy, which by default is located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source. To include it in your program, use the following statement in the data division:

     EXEC SQL INCLUDE SQLCA END-EXEC

If you do not include this statement, the COBOL Compiler automatically allocates an area, but it is not addressable from within your program. However, if you declare either of the data items SQLCODE or SQLSTATE separately, the COBOL Compiler generates code to copy the corresponding fields in the SQLCA to the user-defined fields after each EXEC SQL statement.

If you declare the data item MFSQLMESSAGETEXT, it is updated with a description of the exception condition whenever SQLCODE is non-zero. MFSQLMESSAGETEXT must be declared as a character data item, PIC X(n), where n can be any legal value. This is particularly useful as ODBC error messages often exceed the 70-byte SQLCA message field.

Note: You do not need to declare SQLCA, SQLCODE, SQLSTATE or MFSQLMESSAGETEXT as host variables.
Parent topic: SQL Communications Area (SQLCA)


The SQLCODE Variable

Testing the value of SQLCODE is the most common way of determining the success or failure of an embedded SQL statement.

For details of SQLCODE values, see the topic SQLCODE Values.

DB2 LUW

For DB2, it is possible to get other positive values. This means that the SQL statement has executed but produced a warning.

COBSQL

For COBSQL, it is possible to get other positive values. This means that the SQL statement has executed but produced a warning.

  • For details about the range of positive values that SQLCODE can be set to, consult your Oracle, Sybase or Informix Error Messages manual. The above SQLCODES are produced by OpenESQL. The values for SQLCODE and the errors reported by Oracle, Sybase and Informix are all different. Please refer to Oracle, Sybase or Informix Error Messages manuals for more information on the errors returned.
  • The value +100 is the ANSI standard for 'data not found'. Oracle can return another value for 'data not found'. To get Oracle to return the value +100 for 'data not found', either of the Oracle precompiler directives MODE=ANSI or END_OF_FETCH=100 must be set. This will affect other aspects of the way the Oracle precompiler handles SQL statements. For more details on the Oracle precompiler MODE or END_OF_FETCH=+100 directives, refer to the Programmer's Guide to the ORACLE Precompilers.
  • Even when SQLCODE contains zero, a warning may have been generated. The values of the sqlwarn flags should be checked to determine the type of warning. For Oracle, Sybase and Informix, sqlwarn0 will always be set when the database server has sent a warning back to the application.
Parent topic: SQL Communications Area (SQLCA)
Related reference
SQLCODE Values


The SQLSTATE Variable

The SQLSTATE variable was introduced in the SQL-92 standard and is the recommended mechanism for future applications. It is divided into two components:

  • The first two characters are called the class code. Any class code that begins with the letters A through H or the digits 0 through 4 indicates a SQLSTATE value that is defined by the SQL standard or another standard.
  • The last three characters are called the subclass code.

A value of "00000" indicates that the previous embedded SQL statement executed successfully.

For specific details of the values returned in SQLSTATE when using Oracle, Sybase or Informix, refer to the relevant Database Error Messages manual.

DB2 LUW

DB2 returns SQL-92 compliant SQLSTATE values.

Parent topic: SQL Communications Area (SQLCA)
Related reference
SQLSTATE Values


The Warning Flags

Some statements may cause warnings to be generated. To determine the type of warning, your application should examine the contents of the SQLWARN flags.

  • W - The flag has generated a warning.
  • blank (space) - The flag has not generated a warning.

The value of a flag is set to "W" if that particular warning occured, otherwise the value will be a blank (space).

Each SQLWARN flag has a specific meaning. For more information on the meaning of the SQLWARN flags, see the topic The SQLCA Data Structure.

Parent topic: SQL Communications Area (SQLCA)
Related reference
The SQLCA Data Structure


The WHENEVER Statement

Explicitly checking the value of SQLCODE or SQLSTATE after each embedded SQL statement can involve writing a lot of code. As an alternative, check the status of the SQL statement by using a WHENEVER statement in your application.

The WHENEVER statement is not an executable statement. It is a directive to the Compiler to automatically generate code that handles errors after each executable embedded SQL statement.

The WHENEVER statement allows one of three default actions (CONTINUE, GOTO or PERFORM) to be registered for each of the following conditions:

Condition | Value of SQLCODE
NOT FOUND | 100
SQLWARNING | +1
SQLERROR | < 0 (negative)

A WHENEVER statement for a particular condition replaces all previous WHENEVER statements for that condition.

The scope of a WHENEVER statement is related to its physical position in the source program, not its logical position in the run sequence. For example, in the following code if the first SELECT statement does not return anything, paragraph A is performed, not paragraph C:

     EXEC SQL
         WHENEVER NOT FOUND PERFORM A
     END-EXEC.
     perform B.
     EXEC SQL
        SELECT col1 into :host-var1 FROM table1
         WHERE col2 = :host-var2
     END-EXEC.
 A.
     display "First item not found".
 B.
     EXEC SQL
         WHENEVER NOT FOUND PERFORM C.
     END-EXEC.
 C.
     display "Second item not found".

COBSQL

For Oracle, Sybase and Informix, setting SQLWARN0 to "W" triggers the SQLWARNING clause.

Oracle

When no data is returned from a SELECT or FETCH statement, the condition NOT FOUND is triggered, regardless of the setting of the Oracle precompiler directive MODE.

Informix

Informix allows you to perform a STOP or a CALL from within a WHENEVER statement. These are additions to the ANSI standard and are documented in the Informix ESQL/COBOL programmers manual.

Parent topic: SQL Communications Area (SQLCA)


SQLERRM

The SQLERRM data area is used to pass error messages to the application from the database server. The SQLERRM data area is split into two parts:

  • SQLERRML - holds the length of the error message
  • SQLERRMC - holds the error text.

Within an error routine, the following code can be used to display the SQL error message:

     if (SQLERRML > ZERO) and (SQLERRML < 80)
         display 'Error Message: ', SQLERRMC(1:SQLERRML)
     else
         display 'Error Message: ', SQLERRMC
     end-if.
Parent topic: SQL Communications Area (SQLCA)


SQLERRD

The SQLERRD data area is an array of six integer status values.

  • COBSQL
  • DB2 LUW
Parent topic: SQL Communications Area (SQLCA)


COBSQL

Oracle, Sybase and Informix may set one (or more) of the six values within the SQLERRD array. These indicate how many rows were affected by the SQL statement just executed. For example, SQLERRD(3) holds the total number of rows returned by a SELECT or a series of FETCH statements.

Parent topic: SQLERRD


DB2 LUW

The third element of SQLERRD in the SQLCA, SQLERRD(3), records the number of rows processed for INSERT, UPDATE, DELETE and SELECT INTO statements. For FETCH statements, it records the cumulative sum of rows processed.

SQLERRD(3)

For DB2, SQLERRD(3) contains the following:

  • If PREPARE is invoked and successful, an estimate of the number of rows that will be returned.
  • After INSERT, UPDATE and DELETE, the actual number of rows affected.
  • If compound SQL is invoked, a count of the number of successful substatements.
  • If CONNECT is invoked, either 1 if the database can be updated or 2 if the database is read-only.
  • If an error occurs when processing a host array, the last row that was processed successfully.

SQLERRD(4)

For DB2, SQLERRD(4) contains the following:

  • If PREPARE is invoked and successful, a relative cost estimate of the resources required to process the statement.
  • If compound SQL is invoked, a count of the number of successful substatements.
  • If CONNECT is invoked, 0 for a one-phase commit from a down-level client; 1 for a one-phase commit; 2 for a one-phase, read-only commit; 3 for a two-phase commit.

SQLERRD(5)

For DB2, SQLERRD(5) contains the following:

  • The total number of rows deleted, inserted, or updated as a result of both:
    • The enforcement of constraints after a successful delete operation.
    • The processing of triggered SQL statements from activated triggers.
  • If compound SQL is invoked, an accumulation of the number of such rows for all substatements. In some cases, when an error is encountered, this field contains a negative value that is an internal error pointer.
  • If CONNECT is invoked, an authentication type value of 0 for a server authentication; 1 for client authentication; 2 for authentication using DB2 Connect; 3 for DCE security services authentication; 255 for unspecified authentication.
Parent topic: SQLERRD


The SQL Descriptor Area (SQLDA)

The SQLDA is unique to each precompiler. The Oracle SQLDA is not compatible with that used by Sybase, OpenESQL or DB2 and vice versa.

When either the number of parameters to be passed, or their data types, are unknown at compilation time, you can use an SQL Descriptor Area (SQLDA) instead of host variables.

An SQLDA contains descriptive information about each input parameter or output column. It contains the column name, data type, length, and a pointer to the actual data buffer for each input or output parameter. An SQLDA is ordinarily used with parameter markers to specify input values for prepared SQL statements but you can also use an SQLDA with the DESCRIBE statement (or the INTO option of a PREPARE statement) to receive data from a prepared SELECT statement.

Although you cannot use an SQLDA with static SQL statements, you can use a SQLDA with a cursor FETCH statement.

  • COBSQL
  • OpenESQL
  • Using the SQLDA
Parent topic: Data Structures
Related reference
The SQLDA Data Structure


COBSQL

For Oracle, Sybase and Informix, the SQLDA is only required if your program uses dynamic SQL. It must be defined as a standard COBOL copybook. You cannot include the SQLDA in your program using the following syntax statement:

EXEC SQL
   INCLUDE SQLDA
END-EXEC
  • Oracle
  • Sybase
  • Informix
Parent topic: The SQL Descriptor Area (SQLDA)


Oracle

Oracle provides an extra copybook, ORACA, for use with dynamic SQL. This can be included in your program using the following syntax:

EXEC SQL
   INCLUDE ORACA
END-EXEC

You must set the Oracle precompiler option, ORACA=YES before you can use the ORACA copybook. For more information on setting Oracle precompiler options, refer to the Programmer's Guide to the Oracle Precompilers.

Oracle does not supply an SQLDA. For a clearer explanation of this and the ORACA copybook, refer to the Programmer's Guide to the Oracle Precompilers.

Parent topic: COBSQL


Sybase

Sybase does not supply an SQLDA copybook. The Sybase precompiler documentation describes the layout of the SQLDA and how to assign values to the various items within it. The documentation also describes how to get Sybase to convert between COBOL and Sybase data types.

Parent topic: COBSQL


Informix

Informix does not supply an SQLDA copybook. The Informix precompiler documentation describes the layout of the data items that need to be defined to be able to use Dynamic SQL with Informix.

Parent topic: COBSQL


OpenESQL

The SQLDA structure is supplied in the file sqlda.cpy, which by default is located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source directory. You can include it in your COBOL program by adding the following statement to your data division:

EXEC SQL
   INCLUDE SQLDA
END-EXEC
Parent topic: The SQL Descriptor Area (SQLDA)


Using the SQLDA

Before an SQLDA structure is used, your application must initialise the following fields:

SQLN This must be set to the maximum number of SQLVAR entries that the structure can hold.
SQLDABC

The maximum size of the SQLDA.

  • 32-bit - Calculated as sqln * 44 + 16.
  • 64-bit - Calculated as sqln * 56 + 16.
.
  • The PREPARE and DESCRIBE Statements
  • The FETCH Statement
  • The OPEN or EXECUTE Statements
  • The DESCRIBE Statement
Parent topic: The SQL Descriptor Area (SQLDA)


The PREPARE and DESCRIBE Statements

You can use the DESCRIBE statement (or the PREPARE statement with the INTO option) to enter the column name, data type, and other data into the appropriate fields of the SQLDA structure.

Before the statement is executed, the SQLN and SQLDABC fields should be initialised as described above.

After the statement has been executed, the SQLD field will contain the number of parameters in the prepared statement. A SQLVAR record is set up for each of the parameters with the SQLTYPE and SQLLEN fields completed.

If you do not know how big the value of SQLN should be, you can issue a DESCRIBE statement with SQLN set to 1 and SQLD set to 0. No column detail information is moved into the SQLDA structure, but the number of columns in the results set is inserted into SQLD.

Parent topic: Using the SQLDA


The FETCH Statement

Before performing a FETCH statement using an SQLDA structure, follow the procedure below:

  1. The application must initialize SQLN and SQLDABC as described above.
  2. The application must then insert, into the SQLDATA field, the address of each program variable that will receive the data from the corresponding column. (The SQLDATA field is part of SQLVAR).
  3. If indicator variables are used, SQLIND must also be set to the corresponding address of the indicator variable.

The data type field (SQLTYPE) and length (SQLLEN) are filled with information from a PREPARE INTO or a DESCRIBE statement. These values can be overwritten by the application prior to a FETCH statement.

Parent topic: Using the SQLDA


The OPEN or EXECUTE Statements

To use an SQLDA structure to specify input data to an OPEN or EXECUTE statement, your application must supply the data for the fields of the entire SQLDA structure, including the SQLN, SQLD, SQLDABC, and SQLTYPE, SQLLEN, and SQLDATA fields for each variable.

If the value of the SQLTYPE field is an odd number, the address of the indicator variable must also be supplied in SQLIND.

Parent topic: Using the SQLDA


The DESCRIBE Statement

After a PREPARE statement, you can execute a DESCRIBE statement to retrieve information about the data type, length and column name of each column returned by the specified prepared statement. This information is returned in the SQL Descriptor Area (SQLDA):

EXEC SQL
   DESCRIBE stmt1 INTO :sqlda
END-EXEC

If you want to execute a DESCRIBE statement immediately after a PREPARE statement, you can use the INTO option on the PREPARE statement to perform both steps at once:

EXEC SQL
   PREPARE stmt1 INTO :sqlda FROM :stmtbuf
END-EXEC
Parent topic: Using the SQLDA


Dynamic SQL

If everything is known about an SQL statement when the application is compiled, the statement is known as a static SQL statement.

In some cases, however, the full text of an SQL statement may not be known when an application is written. For example, you may need to allow the end-user of the application to enter an SQL statement. In this case, the statement needs to be constructed at run-time. This is called a dynamic SQL statement.

  • Dynamic SQL Statement Types
  • Preparing Dynamic SQL Statements
  • Executing Dynamic SQL Statements
  • Dynamic SQL Statements and Cursors
Parent topic: Developing SQL Applications
Related reference
DESCRIBE
EXECUTE
EXECUTE IMMEDIATE
OPEN
PREPARE
QUERY ODBC


Dynamic SQL Statement Types

There are four types of dynamic SQL statement:

Dynamic SQL Statement Type | Perform Queries? | Return Data?
Execute a statement once | No | No, can only return success or failure
Execute a statement more than once | No | No, can only return success or failure
Select a given list of data with a given set of selection criteria | Yes | Yes
Select any amount of data with any selection criteria | Yes | Yes

These types of dynamic SQL statement are described more fully below.

  • Execute a Statement Once
  • Execute a Statement More Than Once
  • Select a Given List of Data
  • Select any Amount of Data
Parent topic: Dynamic SQL


Execute a Statement Once

With this type of dynamic SQL statement, the statement is executed immediately. Each time the statement is executed, it is re-parsed.

Parent topic: Dynamic SQL Statement Types


Execute a Statement More Than Once

This type of dynamic SQL statement is either a statement that can be executed more than once or a statement that requires host variables. For the second type, the statement has to be prepared before it can be executed.

Parent topic: Dynamic SQL Statement Types


Select a Given List of Data

This type of dynamic SQL statement is a SELECT statement where the number and type of host variables is known. The normal sequence of SQL statements is:

  1. Prepare the statement
  2. Declare a cursor to hold the results
  3. Open the cursor
  4. Fetch the variables
  5. Close the cursor.
Parent topic: Dynamic SQL Statement Types


Select any Amount of Data

This type of dynamic SQL statement is the most difficult type to code. The type and/or number of variables is only resolved at run time. The normal sequence of SQL statements is:

  1. Prepare the statement
  2. Declare a cursor for the statement
  3. Describe the variables to be used
  4. Open the cursor using the variables just described
  5. Describe the variables to be fetched
  6. Fetch the variables using their descriptions
  7. Close the cursor.

If either the input host variables, or the output host variables are known (at compile time), then the OPEN or FETCH can name the host variables and they do not need to be described.

Parent topic: Dynamic SQL Statement Types


Preparing Dynamic SQL Statements

The PREPARE statement takes a character string containing a dynamic SQL statement and associates a name with the statement, for example:

     move "INSERT INTO publishers " &
               "VALUES (?,?,?,?)" to stmtbuf
     EXEC SQL
         PREPARE stmt1 FROM :stmtbuf
     END-EXEC

Dynamic SQL statements can contain parameter markers - question marks (?) that act as a place holder for a value. In the example above, the values to be substituted for the question marks must be supplied when the statement is executed.

Once you have prepared a statement, you can use it in one of two ways:

  • You can execute a prepared statement.
  • You can open a cursor that references a prepared statement.
  • Place Holders
  • Physical Location of PREPARE Statement
Parent topic: Dynamic SQL


Place Holders

Oracle does not use question marks as place holders. It uses the host variable notation. By convention, the place holders are named Vn, where n is a number to make the place holder unique within a statement. For readability the same place holder can be used more than once, but when the statement is executed (or opened if you are using a cursor), there must still be one host variable for each place holder. For example:

     string "update ordtab " delimited by size
            "set order_no = :v1, "
            "line_no = :v2, "
            "cust_code = :v3, "
            "part_no = :v4, "
            "part_name = :v5, "
            "order_val = :v6, "
            "pay_value = :v7 "
            "where order_no = :v1 and "
            "line_no = :v2 and "
            "cust_code = :v3 " delimited by size
      into Updt-Ord-Stmt-Arr
     end-string
     move 190 to Updt-Ord-Stmt-Len

     EXEC SQL PREPARE updt_ord FROM :Updt-Ord-Stmt END-EXEC

     EXEC SQL EXECUTE updt_ord USING
         :dcl-order-no, :dcl-line-no, :dcl-cust-code,
         :dcl-part-no,  :dcl-part-name:ind-part-name,
         :dcl-order-val,:dcl-pay-value,
         :dcl-order-no, :dcl-line-no, :dcl-cust-code
     END-EXEC

where Updt-Ord-Stmt has been defined as a host variable type of VARYING.

Parent topic: Preparing Dynamic SQL Statements


Physical Location of PREPARE Statement

When using the Oracle precompiler, the physical location of a PREPARE statement is important. A PREPARE statement must appear before an EXECUTE or a DECLARE statement.

Parent topic: Preparing Dynamic SQL Statements


Executing Dynamic SQL Statements

The EXECUTE statement runs a specified prepared SQL statement.

Note:

Only statements that do not return results can be executed in this way.

If the prepared statement contains parameter markers, the EXECUTE statement must include either the "using :hvar" option to supply parameter values using host variables or the "using descriptor :sqlda_struct" option identifying an SQLDA data structure already populated by the application. The number of parameter markers in the prepared statement must match the number of SQLDATA entries ("using descriptor :sqlda") or host variables ("using :hvar").

     move "INSERT INTO publishers " &
               "VALUES (?,?,?,?)" to stmtbuf
     EXEC SQL
         PREPARE stmt1 FROM :stmtbuf
     END-EXEC
      ...
     EXEC SQL
         EXECUTE stmt1 USING :pubid,:pubname,:city,:state
     END-EXEC.

In this example, the four parameter markers are replaced by the contents of the host variables supplied via the USING clause in the EXECUTE statement.

  • EXECUTE IMMEDIATE Statement
  • FREE Statement (COBSQL Informix)
Parent topic: Dynamic SQL


EXECUTE IMMEDIATE Statement

If the dynamic SQL statement does not contain any parameter markers, you can use EXECUTE IMMEDIATE instead of PREPARE followed by EXECUTE, for example:

     move "DELETE FROM emp " &
               "WHERE last_name = 'Smith'" to stmtbuf
     EXEC SQL
         EXECUTE IMMEDIATE :stmtbuf
     END-EXEC

When using EXECUTE IMMEDIATE, the statement is re-parsed each time it is executed. If a statement is likely to be used many times it is better to PREPARE the statement and then EXECUTE it when required.

Parent topic: Executing Dynamic SQL Statements


FREE Statement (COBSQL Informix)

The Informix precompiler provides a FREE statement that will release resources that are allocated to a prepared statement or to a cursor.

Once you have finished with a prepared statement, you would then use the FREE statement, for example:

     move "INSERT INTO publishers " " &
               "VALUES (?,?,?,?)" to stmtbuf
     EXEC SQL
         PREPARE stmt1 FROM :stmtbuf
     END-EXEC
      ...
     EXEC SQL
         EXECUTE stmt1 USING :pubid,:pubname,:city,:state
     END-EXEC.
      ...
     EXEC SQL
         FREE stmt1
     END-EXEC
Parent topic: Executing Dynamic SQL Statements


Dynamic SQL Statements and Cursors

If a dynamic SQL statement returns a result, you cannot use the EXECUTE statement. Instead, you must declare and use a cursor.

First, declare the cursor using the DECLARE CURSOR statement:

EXEC SQL
   DECLARE C1 CURSOR FOR dynamic_sql
END-EXEC

In the example above, dynamic_sql is the name of a dynamic SQL statement. You must use the PREPARE statement to prepare the dynamic SQL statement before the cursor can be opened, for example:

     move "SELECT char_col FROM mfesqltest " &
          "WHERE int_col = ?" to sql-text
     EXEC SQL
        PREPARE dynamic_sql FROM :sql-text
     END-EXEC

Now, when the OPEN statement is used to open the cursor, the prepared statement is executed:

EXEC SQL
   OPEN C1 USING :int-col
END-EXEC

If the prepared statement uses parameter markers, then the OPEN statement must supply values for those parameters by specifying either host variables or an SQLDA structure.

Once the cursor has been opened, the FETCH statement can be used to retrieve data, for example:

EXEC SQL
   FETCH C1 INTO :char-col
END-EXEC

For a full discussion of the FETCH statement, see the topic Cursors.

Finally, the cursor is closed using the CLOSE statement:

EXEC SQL
   CLOSE C1
END-EXEC

For a full discussion of the CLOSE statement, see the topic Cursors.

  • CALL Statements
Parent topic: Dynamic SQL
Related concepts
Cursors


CALL Statements

A CALL statement can be prepared and executed as dynamic SQL. This is supported only with the Open ESQL precompiler.

  • You can use parameter markers (?) in dynamic SQL wherever you use host variables in static SQL
  • Use of the IN, INPUT, OUT, OUTPUT, INOUT and CURSOR keyword following parameter markers is the same as their use after host variable parameters in static SQL.
  • The whole call statement must be enclosed in braces to conform to ODBC cannonical stored procedure syntax (the Open ESQL precompiler does this for you in static SQL). For example:
         move '{call myproc(?, ? out)}' to sql-text
     exec sql
         prepare mycall from :sql-text
     end-exec
     exec sql
         execute mycall using :parm1, :param2
     end-exec
  • If you use parameter arrays, you can limit the number of elements used with a FOR clause on the EXECUTE, for example:
         move 5 to param-count
     exec sql
         for :param-count
          execute mycall using :parm1, :param2
     end-exec
  • Example
Parent topic: Dynamic SQL Statements and Cursors


Example

The following is an example of a program that creates a stored procedure "mfexecsptest" using data source "SQLServer 2000" and then retrieves data from "publishers" table using a cursor "c1" with dynamic SQL.

$SET SQL
 WORKING-STORAGE SECTION.

 EXEC SQL INCLUDE SQLCA  END-EXEC

*> after an sql error this has the full message text
 01 MFSQLMESSAGETEXT  PIC X(250).
 01 IDX               PIC X(04)  COMP-5.

 EXEC SQL BEGIN DECLARE SECTION  END-EXEC
*> Put your host variables here if you need to port
*> to other COBOL compilers

 01  stateParam          pic xx.
 01  pubid               pic x(4).
 01  pubname             pic x(40).
 01  pubcity             pic x(20).

 01  sql-stat            pic x(256).

 EXEC SQL END DECLARE SECTION END-EXEC

 PROCEDURE DIVISION.

     EXEC SQL
         WHENEVER SQLERROR perform OpenESQL-Error
     END-EXEC

     EXEC SQL
         CONNECT TO 'SQLServer 2000' USER 'SA'
     END-EXEC

*> Put your program logic/SQL statements here

     EXEC SQL
         create procedure mfexecsptest
                 (@stateParam char(2) = 'NY' ) as

         select pub_id, pub_name, city from publishers
          where state = @stateParam
     END-EXEC

     exec sql
         declare c1 scroll cursor for dsql2 for read only
     end-exec

     move "{call mfexecsptest(?)}" to sql-stat
     exec sql prepare dsql2 from :sql-stat end-exec

     move "CA" to stateParam
     exec sql
         open c1 using :stateParam
     end-exec

     display "Testing cursor with stored procedure"
     perform until exit
         exec sql
             fetch c1 into :pubid, :pubname, :pubcity
         end-exec

         if sqlcode = 100
             exec sql close c1 end-exec
             exit perform
         else
             display pubid " " pubname " " pubcity
         end-if
     end-perform

      EXEC SQL close c1  END-EXEC

      EXEC SQL DISCONNECT CURRENT END-EXEC
      EXIT PROGRAM.
      STOP RUN.
*> Default sql error routine / modify to stop program if
*> needed
 OpenESQL-Error Section.

     display "SQL Error = " sqlstate " " sqlcode
     display MFSQLMESSAGETEXT
      *> stop run
     exit.
Parent topic: CALL Statements


Compiling SQL Applications

These topics apply to compiling SQL applications in general. Specific information on compiling for a particular preprocessor is contained in the topics covering the use of that preprocessor.

  • Specifying a Preprocessor
    Instructions that explain the various methods of specifying a preprocessor to use when compiling an SQL application.
  • Compiling Multiple Program Modules
    Provides information on how to best compile SQL applications that specify multiple program modules.
  • Creating Debug Files
    Explains the process of creating debug files to assist Micro Focus SupportLine representatives in resolving issues related to the compiling of an SQL application.
Parent topic: Database Access
Related concepts
OpenESQL
COBSQL
DB2


Specifying a Preprocessor

We provide several alternative methods for specifying a database access preprocessor for your programs and applications.

Project Properties

You can specify a preprocessor as part of your project properties.
OpenESQL
  1. On the SQL tab for your Project Properties, specify OpenESQL as the ESQL Preprocessor.
  2. To specify the type of database access you want, add the DBMAN directive and set its value to ODBC or ADO.
DB2
  1. On the SQL tab for your Project Properties, specify DB2 as the ESQL Preprocessor.
  2. To specify a value for the DB directive, type the name of your DB2 database into the Value field.
    Note: If you leave the value for DB blank, the compiler uses the database specified as the value of the DB2DBDFT environment variable.
COBSQL
On the COBOL tab for your Project Properties, type PREPROCESS(cobsql) into the Additional Directives field.

Command Line

If you compile your applications from the command line, specify your preprocessor as a command-line directive and set options as appropriate. Here we present the minimum with regard to options. For complete information on these compiler directives and their options, see the appropriate Reference topic listed at the end of this topic.

OpenESQL
Use the SQL compiler directive, followed by the DBMAN option to specify the type of database access:

SQL(DBMAN=dbaType)

Where dbaType is ODBC or ADO.

DB2
Use the DB2 compiler directive, followed by the DB option to specify the database name:

DB2(DB=dbName)

Where dbName is the name of your DB2 database.

Note: If you do not specify the DB option, the compiler uses the database specified as the value of the DB2DBDFT environment variable.
COBSQL
Use the PREPROCESS compiler directive:
PREPROCESS(cobsql)

Embedded in the Program

You can also specify a preprocessor on the program level by embedding a $SET statement into the program itself. Use this method only when the program requires a preprocessor different from other programs in an application.

OpenESQL
Use the SQL compiler directive, followed by the DBMAN option to specify the type of database access:
$SET SQL(DBMAN=dbaType)

Where dbaType is ODBC or ADO.

DB2
Use the DB2 compiler directive, followed by the DB option to specify the type of database access:
$SET DB2(DB=dbName)

Where dbName is the name of your DB2 database.

Note: If you do not specify the DB option, the compiler uses the database specified as the value of the DB2DBDFT environment variable.
COBSQL
Use the PREPROCESS compiler directive:
$SET PREPROCESS(cobsql)
Parent topic: Compiling SQL Applications


Compiling Multiple Program Modules

Multiple embedded SQL source files, compiled separately and linked to a single executable file, can share the same database connection at run time. This is also true for programs that are compiled into separate dynamic-link libraries (.dll files). If subsequent program modules (in the same process) do not process a CONNECT statement, they share the same database connection with the module that included the CONNECT statement.

OpenESQL
In a program that includes multiple, separately compiled modules, you should compile only one module with the INIT option of the SQL Compiler directive. All other modules in the program should share that first automatic connection or make explicit connections using the CONNECT statement.
OpenESQL - DB2
  • Statement names are local to a particular program module (compilation unit). This means that a statement cannot be prepared in one module and executed in another.
  • Within an application, cursor names should be unique.
COBSQL
With COBSQL, if the INIT directive is specified more than once, second and subsequent uses are ignored.
Parent topic: Compiling SQL Applications
Related reference
CONNECT
INIT


Creating Debug Files

If an error occurs when compiling a program that requires technical support, your support representative might ask you to provide additional debug files to help in determining the cause of the problem. You obtain these debug files by specifying extra Compiler directives. You might want to specifiy some of these directives to help in your own debugging efforts. The directives are:

OpenESQL
Directive | File created | Information within file
CHKECM(CTRACE) | ecmtrace.txt | Pseudo COBOL code that shows the code generated to replace the EXEC SQL statements. This file is equivalent to output from the OpenESQL ODBC precompiler.
CHKECM(TRACE) | ecmtrace.txt | Detailed information as to what information is passed between the ODBC ECM and the Compiler. If an error occurs that generates invalid syntax, this file will be needed to help isolate where the problem occurred.
SQL(CTRACE) | sqltrace.txt | Detailed list of information passed to OpenESQL Precompiler Services, and the results. This file is very useful if an error might involve a bug in the OpenESQL run time as well as the OpenESQL ECM.
ECMLIST | program-name.lst | The standard COBOL list file, with pseudo COBOL code that shows the code generated to replace the EXEC SQL statements. You must also compile the program with the CHKECM(CTRACE) and LIST directives.
DB2 ECM
Directive | File created | Information in the file
CHKECM(CTRACE) | ecmtrace.txt | This file contains pseudo COBOL code that shows the code generated to replace the EXEC SQL statements. This code is equivalent to output from the IBM DB2 COBOL precompiler.
CHKECM(TRACE) | ecmtrace.txt | This file contains detailed information as to what information is passed between the DB2 ECM and the Compiler. If an error occurs that generates invalid syntax, this file will be needed to help isolate where the problem occurred.
DB2(CTRACE) | sqltrace.txt | This file contains a detailed list of information passed to IBM Precompiler Services, and the results. This file is very useful if an error might involve a bug in the DB2 system software as well as the DB2 ECM.
ECMLIST | program-name.lst | This file is the standard COBOL list file, with pseudo COBOL code that shows the code generated to replace the EXEC SQL statements. You must also compile the program with the CHKECM(CTRACE) and LIST directives.
COBSQL
For more information, see the topic COBSQL.
Parent topic: Compiling SQL Applications
Related concepts
COBSQL


OpenESQL

The OpenESQL preprocessor provides comprehensive compatibility with most database providers. When developing applications for the OpenESQL preprocessor, you can take advantage of several features that enable you to simplify your code and optimize your application at run time.

  • OpenESQL Preprocessor Options
    A discussion of the two OpenESQL preprocessor options - ODBC for native code and ADO for .NET managed code.
  • Scope - OpenESQL SQL Compiler Directive Options
    Describes the scope of each SQL compiler directive option with regard to its use at compile and run time.
  • OpenESQL DBMAN Use Case Scenarios
    A set of use case scenarios that show the appropriate SQL compiler directive options to set for each.
  • OpenESQL Configuration Utility
    The purpose and use of the OpenESQL Configuration utility to specify the default behavior for the SQL(BEHAVIOR) compiler directive option.
  • Database Connections
    A discussion of the implicit and explicit database connection types, and how and under what circumstances to use each of them.
  • Setting OpenESQL Background Syntax Checking Options
    Explains how to set options that determine the level at which the OpenESQL preprocessor checks syntax in the background.
  • Programming for OpenESQL
    Programming techniques specific to SQL applications developed for the OpenESQL preprocessor.
  • ODBC
    Information specific to developing and maintaining native SQL applications that access ODBC data sources.
  • ADO.NET
    Information specific to developing and maintaining managed SQL applications that access ADO.NET data sources.
  • COBOL Program Migration Support
    The role of OpenESQL in aiding effective migration of mainframe applications.
  • Oracle OCI Support
    A description of Oracle OCI - an alternative for developers using ORACLE data sources.
Parent topic: Database Access
Related concepts
Database Access Preprocessors
Compiling SQL Applications
Related reference
DISCONNECT


OpenESQL Preprocessor Options

The OpenESQL preprocessor provides two preprocessor options - ODBC for native code and ADO for .NET managed code.

ODBC
Use OpenESQL with the ODBC option to compile your native applications. This option:
  • Is invoked using the SQL(DBMAN=ODBC) compiler directive
  • Uses any ODBC drivers and data providers
  • Connects to one or more ODBC data sources
  • Compiles applications to communicate with the OpenESQL Native Runtime
  • Enables maximum interoperability between different database systems
  • Provides comprehensive support for pessimistic (locking) concurrency control
  • Does not support disconnected or offline DataSets
ADO
Use OpenESQL with the ADO option to compile your .NET managed applications. This option:
  • Is invoked using the SQL(DBMAN=ADO) compiler directive
  • Uses ADO.NET data providers
  • Connects to one ADO.NET data source
  • Compiles applications to communicate with the OpenESQL Managed Runtime
  • Enables EXEC SQL statements to communicate with the ADO.NET data provider and data source name specified
  • Supports the use of EXEC ADO statements to create and manipulate ADO.NET objects
  • Maximizes scalability of data handling components in distributed systems
  • Is strongly biased in favour of optimistic (non-locking) concurrency control
  • Fully supports disconnected and offline DataSets
  • Supports dynamic SQL using PREPARE, EXECUTE and EXECUTE IMMEDIATE statements and cursors that use prepared statements, but only with host variable lists in the EXECUTE and OPEN statements
Parent topic: OpenESQL


Scope - OpenESQL SQL Compiler Directive Options

Each SQL compiler directive option is used either at compile time, runtime, or both. The behavior at run time is described as one of the following:
  • Source file - When a source file specifies the directive, the value set in the source file is used. If a source file does not specify the directive, then the process behavior is used.
  • Process - These directives affect connections. When the first-encountered EXEC SQL statement is executed, usually an EXEC SQL CONNECT statement, the runtime uses the directive settings for the source file containing the statement. These settings apply for the remainder of the process lifetime. The run-time behavior varies depending on the type of connection as follows:
    • ODBC with THREAD=ISOLATE - Each thread in the process uses its own set of global directive settings
    • ODBC with THREAD=SHARE - One set of global directive settings applies for the entire process
    • ADO.NET - .NET session, each session having its own set of global directive settings

For information on the scope of each SQL compiler directive option, see its corresponding Reference topic.

Parent topic: OpenESQL
Related concepts
XA Switch Modules


OpenESQL DBMAN Use Case Scenarios

The following OpenESQL use case scenarios show the appropriate SQL compiler directive options to set for each to ensure its ultimate success:

Type of Program | Scenario | SQL Compiler Directive Options
COBOL | Maximize performance and talk to an SQL Server data store via a .NET data provider | SQL(DBMAN=ADO, TARGETDB=MSSQLSERVER, BEHAVIOR=MAINFRAME)
COBOL | ANSI compliant, and talk to an SQL Server data store via an ODBC driver | SQL(DBMAN=ODBC, TARGETDB=MSSQLSERVER, BEHAVIOR=ANSI)
COBOL or PL/I | Maximize performance, not worry about mainframe compatibility, and talk to an Oracle data store via an ODBC driver | SQL(DBMAN=ODBC, TARGETDB=ORACLE, BEHAVIOR=MAINFRAME)
COBOL | Mimic Oracle Pro*COBOL functionality for SQL cursors, and talk to an Oracle data store via .NET data provider | SQL(DBMAN=ADO, TARGETDB=ORACLE, BEHAVIOR=ANSI)
Parent topic: OpenESQL


OpenESQL Configuration Utility

Use the OpenESQL Configuration utility to change the default behavior for the SQL(BEHAVIOR) directive option. OpenESQL uses this default only when SQL(BEHAVIOR) is not explicitly specified in one of the following places:

  • program source code
  • project settings
  • COBOL compiler directives file

When you specify the SQL(BEHAVIOR) directive in any of these places, the value you specify overrides the default set using the OpenESQL Configuration utility.

Note: The OpenESQL Configuration Utility does not enable you to set the BEHAVIOR directive to either JCL or CICS, both of which are valid settings. If you want to set the BEHAVIOR directive to either of these, be sure to set it in one of the above-referenced places before attempting to compile your application.

You can run this utility, using either its user-interface or command-line implementation (esqlconfig command), on each machine where you have installed Studio Enterprise Edition 6.0, Service Pack 1, Websync 1 or later, to change the default behavior before attempting to compile programs that do not specify the SQL(BEHAVIOR) directive in one or more of the above-referenced places. You need not run the utility again even after installing software upgrades; however, if you need to change the default behavior at any time, you can run the utility to do so as often as necessary.

Using the OpenESQL Configuration utility, you can set the default behavior to one of the following options:

  • Optimize for performance and mainframe compatibility
    This is the recommended setting for mainframe migrations and new development.
  • ANSI compliance
    This is the recommended setting for migrating applications that require ANSI compliance, and as a performance optimization for existing users of Micro Focus Net Express and earlier products.
  • No change in default behavior and no optimization
    This setting represents the default behavior in earlier releases of OpenESQL in Micro Focus products.
  • Issue a warning at compile time
    This is the recommended setting for users who would like to be notified when the SQL(BEHAVIOR) directive has not been set outside of the OpenESQL Configuration utility.
  • Issue an error at compile time
    This is the recommended setting for users who require that the SQL(BEHAVIOR) directive be set in program source, project settings, or a COBOL directives file.
Parent topic: OpenESQL
Related concepts
DBMAN Directive Settings
Programming for OpenESQL
COBOL Program Migration Support
Related reference
esqlconfig command
BEHAVIOR
Related information
To start the OpenESQL Configuration Utility
To set a default for SQL(BEHAVIOR)
COBOL Program Migration Support


Optimize for performance and mainframe compatibility

Sets the SQL(BEHAVIOR) directive to SQL(BEHAVIOR=MAINFRAME), meaning that data access is read only for everything except data access that is explicitly specified as read only or for update.

For database connections to Microsoft SQL Server, multiple active result sets (MARS) are enabled and read only cursors use SQL Server default result sets (otherwise known as firehose cursors).

For other databases, such as Oracle or DB2, read only cursors use block fetches of eight rows.

Updatable cursors for all databases use block fetches of eight rows. You can change the block fetch size.

Parent topic: OpenESQL Configuration Utility
Related reference
BEHAVIOR
Related information
To set a default for SQL(BEHAVIOR)


ANSI compliance

Sets the SQL(BEHAVIOR) directive to SQL(BEHAVIOR=ANSI), meaning that data access is updatable for everything except data access that is explicitly specified as read only or for update.

For database connections to Microsoft SQL Server, multiple active result sets (MARS) are enabled and read only cursors use SQL Server default result sets (otherwise known as firehose cursors).

For other databases, such as Oracle or DB2, read only cursors use block fetches of eight rows.

Updatable cursors for all databases use block fetches of eight rows. You can change the block fetch size. See the BEHAVIOR topic for more information.

Parent topic: OpenESQL Configuration Utility
Related reference
BEHAVIOR
Related information
To set a default for SQL(BEHAVIOR)


No change in default behavior and no optimization

Sets the SQL(BEHAVIOR) directive to SQL(BEHAVIOR=UNOPTIMIZED), meaning that data access is both scrollable and updatable for everything except data access that is explicitly specified as read only or for update.

With this option, OpenESQL does not perform block fetching, possibly degrading the performance of cursors that are not forward only, read only. Therefore we strongly recommend that you use this option only as an interim measure pending a change to one of the other default options such as Optimize for performance and mainframe compatibility or ANSI compliance.

Parent topic: OpenESQL Configuration Utility
Related reference
BEHAVIOR
Related information
To set a default for SQL(BEHAVIOR)


Issue a warning at compile time

Generates a compile-time warning when the SQL(BEHAVIOR) directive has not been set in your program source code, project settings, or in the COBOL compiler directives file. In addition to generating the warning, the default behavior is set to SQL(BEHAVIOR=UNOPTIMIZED).

OpenESQL generates the warning when the compiler encounters the first error free EXEC SQL statement in each OpenESQL-based program.

Parent topic: OpenESQL Configuration Utility
Related reference
BEHAVIOR
Related information
To set a default for SQL(BEHAVIOR)


Issue an error at compile time

Generates a compile-time error when the SQL(BEHAVIOR) directive has not been set in your program source code, project settings, or in the COBOL compiler directives file. In this case, all EXEC SQL statements are effectively ignored.

OpenESQL generates the error when the compiler encounters the first error free EXEC SQL statement in each OpenESQL-based program. Once the error is generated, OpenESQL ignores all subsequent EXEC SQL statements in that program.

Parent topic: OpenESQL Configuration Utility
Related reference
BEHAVIOR
Related information
To set a default for SQL(BEHAVIOR)


Database Connections

Each OpenESQL preprocessor option - ODBC and ADO - The OpenESQL preprocessor requires that you create a connection to the database using either an explicit or an implicit connection.
Important: You must have the appropriate drivers and/or data providers installed and data source names created before you can establish a connection. Each OpenESQL preprocessor type requires a different configuration.

Explicit Connections (recommended)

An explicit connection is one established within your program code using the CONNECT embedded SQL statement, and disconnected using the DISCONNECT embedded SQL statement. This enables you to make connections to multiple databases at runtime on an as needed basis.

Use explicit connections when your program accesses multiple data sources or databases.

See the CONNECT and DISCONNECT embedded SQL topics for details.

Note: For ODBC connections only, you can specify an explicit disconnect and rollback to execute automatically if the program terminates abnormally. See the INIT compiler directive option topic for more information.

Implicit Connections

An implicit connection is one defined by way of SQL compiler directive options at compile time. This method establishes a single connection to one database. Use this method only when your program accesses only one database.

Use a combination of the INIT, DB, and possibly PASS compiler directive options to create the connection.
  • INIT - to identify the data source name
  • DB - to identify the database
  • PASS - to provide a user ID and password if required

OpenESQL automatically disconnects from the data source when the program terminates.

Important: ADO.NET does not support the use of implicit connections.
Parent topic: OpenESQL
Related reference
CONNECT
DB
DISCONNECT
INIT
PASS


Setting OpenESQL Background Syntax Checking Options

Before compiling an OpenESQL application, you can set options that determine the level at which the OpenESQL preprocessor checks syntax in the background. To do this, click Tools > Options; then expand Micro Focus COBOL Tools and click OpenESQL Background Syntax Checking. You can set the following options:

  • Background Compile Setting > No syntax checking

    The precompiler does not connect to the DBMS and does not validate EXEC SQL statements; however, the precompiler does check host variables.

  • Background Compile Setting > Basic syntax checking

    The precompiler checks only ANSI and standard SQL syntax.

  • Background Compile Setting > Complete syntax checking

    This option sends all embedded SQL statements to the DBMS for validation, and requires a connection to the DBMS used by the program. Select this option for database providers that do not require SQL statement execution to perform validation.

See your Visual Studio documentation for information on setting properties.

Parent topic: OpenESQL


Programming for OpenESQL

These topics explain programming techniques that are specific to OpenESQL in general. For additional programming techniques specific to native applications, see the ODBC topic, and for managed applications, see the ADO.NET topic.

  • OpenESQL Assistant
  • Working With OpenESQL Cursors and Result Sets
  • Working With OpenESQL Stored Procedures and Result Sets
  • Unicode Support in OpenESQL
  • Keywords
Parent topic: OpenESQL
Related concepts
ODBC
ADO.NET
OpenESQL Configuration Utility


OpenESQL Assistant

The OpenESQL Assistant is an interactive tool that makes it easy for you to:

  • Prototype SQL SELECT, INSERT, UPDATE, and DELETE statements and test them against your database
  • Generate EXEC ADO statements
  • Insert your SQL queries into your COBOL code
  • Create and insert auxiliary code into your COBOL code
  • Tutorials: OpenESQL Assistant
    Use OpenESQL Assistant to generate SQL queries in a COBOL application.
  • Setting OpenESQL Assistant Options
  • Using OpenESQL Assistant
Parent topic: Programming for OpenESQL
Related concepts
Using OpenESQL with ADO.NET
Managed Code Concepts
Managed COBOL Restrictions
ADO.NET Data Providers and Data Source Names
Unicode Support in OpenESQL
Related tasks
To set OpenESQL Assistant options
To connect to a data source
To connect to a different data source
To disconnect from a data source
To start the ADO.NET Connection Editor
To add an XML data source
To close a query
To run a query
To create a TSQL stored procedure query
To create an SQL query
To embed an SQL query into a COBOL program
To specify search criteria (a WHERE clause)
To sort returned data (an ORDER BY clause)
To generate and embed auxiliary code
To view data source properties
Related reference
OpenESQL Assistant - Main Window
Select Type of Query to Create dialog box
Query tab
Results tab
Details tab
Search Criteria tab
Literal Value dialog box
Sort tab
Auxiliary Code tab
Data Source Properties dialog box


Tutorials: OpenESQL Assistant

In this set of tutorials, you create an application using OpenESQL Assistant to generate an SQL query, embed that query into a program, and generate a copybook for host variables. It also takes you through the process of compiling and running the resulting application.

Tutorial Requirements

To complete the OpenESQL Assistant tutorials, you must have the following software installed:

  • Studio Enterprise Edition
  • Microsoft SQL Server 2008, including the SQL Server Management Studio

Additional requirements that apply to specific tutorials appear in the Requirements section of each.

Order

You must complete this series of tutorials in the following order:

  • Tutorial: Create a SQL Server Database
    Create a SQL Server database using Microsoft SQL Server 2008 Management Studio.
  • Tutorial: Create and Configure a Visual Studio Project
    Create and configure a Visual Studio Managed COBOL solution and project in which to create an application.
  • Tutorial: Set OpenESQL Assistant Configuration Options
    Set configuration options for the OpenESQL Assistant.
  • Tutorial: Catalog a Connection
    Catalog a connection to the database you created in a previous tutorial.
  • Tutorial: Build and Test a Query
    Use the OpenESQL Assistant to build and test an SQL query.
  • Tutorial: Generate and Embed an SQL Program
    Use OpenESQL Assistant to generate a generic SQL program to run the query, and embed it into an existing COBOL program.
  • Tutorial: Provide Additional Code
    Add code to the generated SQL program to include a generated copybook and to send the returned data to the console in a readable format.
  • Tutorial: Build and Run the Application
    Add the generated copybook to the OESQLAssistantTutorial project, set a break point, and build and run the resulting application.
Parent topic: OpenESQL Assistant


Tutorial: Create a SQL Server Database

This tutorial takes you through the process of using Microsoft SQL Server 2008 Management Studio to create a SQL Server database and to create the schemas and tables required to complete the OpenESQL Assistant tutorials.

  1. Start the Microsoft SQL Server 2008 Management Studio.
  2. Connect to the server where you want to create your database.
    Note: The user ID and password you provide must log you on to SQL Server with dbadmin or sysadmin permissions that enable you to create a SQL Server database.
  3. Open and execute CreateAndLoadOESQLDemo.sql, located in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\sql\OpenESQL\SampleData directory.

    This SQL script creates a SQL Server database named OESQLDemo, and creates the schemas and tables required to complete the OpenESQL Assistant tutorials.

  4. Close SQL Server 2008 Management Studio.
Note: As an alternative, you can create the SQL Server database from the command line as follows:
  1. At a command prompt, change to the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\sql\OpenESQL\SampleData directory.
  2. Enter:

    sqlcmd -S . -E -i CreateAndLoadOESQLDemo.sql

This completes the tutorial. Next, please complete Tutorial: Create and Configure a Visual Studio Project.

Parent topic: Tutorials: OpenESQL Assistant


Tutorial: Create and Configure a Visual Studio Project

In this tutorial, you create a Visual Studio Managed COBOL project to use as you complete the remainder of these tutorials.

Requirements
Before attempting this tutorial, you must complete Tutorial: Create a SQL Server Database.
Phase 1: Launch Studio Enterprise Edition
  • Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Microsoft Visual Studio 2008.
Phase 2: Create a New Managed COBOL Project
In this set of tutorials, you create a Managed COBOL application to take advantage of the features available in the ADO.NET connection editor, and the OpenESQL Managed Runtime.
  1. From the Visual Studio IDE, click File > New > Project.
  2. Under Installed Templates, click COBOL > Managed.
  3. Click Console Application.
  4. In the Name field, type OESQLAssistantTutorial.
  5. In the Location field, specify a directory in which to store the project; then click OK.

    Visual Studio creates a new solution and a project named OESQLAssistantTutorial. The project contains one generic program, Program1.cbl, that we use in a later tutorial. If Visual Studio has automatically opened this file for editing, close it for now.

Phase 3: Set Project Properties
To compile this application such that it connects to the database via ADO.NET, we must set the project properties to include the DBMAN=ADO SQL compiler directive option. We must also set the BEHAVIOR compiler directive to provide optimal cursor behavior, including isolation level and lock concurrency settings.
  1. From the Solution Explorer, double-click Properties under your OESQLAssistantTutorial project.
  2. On the SQL tab, select OpenESQL from the ESQL Preprocessor drop-down list; then click Add.
  3. On the Available Directives list, click DBMAN; then click OK.
  4. From the Value drop-down, select ADO.
  5. Click Add.
  6. On the Available Directives list, click BEHAVIOR; then click OK.
  7. From the Value drop-down, select ANSI.
  8. Save your changes and close the Properties window.

This concludes this tutorial. Please continue with Tutorial: Set OpenESQL Assistant Configuration Options.

Parent topic: Tutorials: OpenESQL Assistant


Tutorial: Set OpenESQL Assistant Configuration Options

You can configure several features within OpenESQL Assistant, but for the purposes of this tutorial, we change just the value of the Type COBOL Variable setting. This setting determines the method used at runtime to resolve host variable definitions. By setting this option to Object, your compiled application communicates with the OpenESQL Managed Runtime, greatly improving performance.

Requirements
Before attempting this tutorial, you must complete the following tutorials in the order listed:
  • Tutorial: Create a SQL Server Database
  • Tutorial: Create and Configure a Visual Studio Project
Set the Type COBOL Variable Option
  1. From the Visual Studio IDE, click Tools > Options > Micro Focus COBOL Tools > OpenESQL Assistant.
  2. Change the value of Type COBOL Variable from Standard to Object; then click OK.

This completes the tutorial. Next, please complete Tutorial: Catalog a Connection.

Parent topic: Tutorials: OpenESQL Assistant


Tutorial: Catalog a Connection

Before you can connect to the SQL Server database you created earlier, you must catalog it using the ADO.NET Connection Editor.

Requirements
Before attempting this tutorial, you must complete the following tutorials in the order listed:
  • Tutorial: Create a SQL Server Database
  • Tutorial: Create and Configure a Visual Studio Project
  • Tutorial: Set OpenESQL Assistant Configuration Options
Phase 1: Start the OpenESQL Assistant
You can start the OpenESQL Assistant from the Start menu or from within Visual Studio. In this tutorial, we opt to start the OpenESQL Assistant from within Visual Studio.
  • From the Visual Studio IDE, click Tools > Micro Focus COBOL Tools > OpenESQL Assistant.
Phase 2: Start the ADO.NET Connection Editor
You can start the ADO.NET Connection Editor from the Start menu, or from within the OpenESQL Assistant. Here, we start it from within the OpenESQL Assistant.
  • From the OpenESQL Assistant, click ADO.NET Connection Editor Button ADO.NET Connection Editor.
Phase 3: Catalog the OESQLDemo Connection
In this phase, we catalog a 32-bit connection to our SQL Server database.
Important: If you are running on a 64-bit machine, you must catalog a 64-bit connection in addition to the 32-bit connection. Both connections have the same data source name. To do this, complete all of the steps in this phase, and then repeat the steps of this phase with the following change:
  • Before performing step 1, on the Connection tab, click 64 bit.
  1. On the Connection tab, click Add.
    Note: The 32-bit connection cataloged here does not require that we change any of the default settings on the Connection tab of the ADO.NET Connection Editor.
  2. In the grid on the Provider tab, click SqlClient Data Provider.
  3. In the Data Source Name field, type OESQLDemo, which is the name of your connection; then click Next, which takes you back to the Connection tab.
  4. With OESQLDemo selected on the Data Source Name list, modify the following fields on the Connection Settings grid, providing the appropriate values:
    Field | Value
    Initial Catalog | OESQLDemo
    Data Source | (local)
    Integrated Security | True
  5. Click Save to save your changes.
  6. Click Test Connection to ensure the connection works properly; then click OK to clear the message.
Phase 4: Close the ADO.NET Connection Editor
  • Click OK to close the ADO.NET Connection Editor.

    The OESQLDemo connection now appears on the list in the OpenESQL Assistant.

Phase 5: Refresh the Database Connection
For Visual Studio to recognize the connection you have cataloged, you must refresh it in the Server Explorer.
  1. From the Visual Studio IDE, open the Server Explorer.
  2. Right-click the connection listed for OESQLDemo, and select Refresh.

This completes the tutorial. Next, please complete Tutorial: Build and Test a Query.

Parent topic: Tutorials: OpenESQL Assistant


Tutorial: Build and Test a Query

We are now ready to build a query that we can embed into a COBOL program and run. In this scenario, we are interested in retrieving the first and last names of our employees and the salary for each. So we'll build the query to access the EMP table and return the data from three columns: FIRSTNME, LASTNAME, and SALARY.

Requirements
Before attempting this tutorial, you must complete the following tutorials in the order listed:
  • Tutorial: Create a SQL Server Database
  • Tutorial: Create and Configure a Visual Studio Project
  • Tutorial: Set OpenESQL Assistant Configuration Options
  • Tutorial: Catalog a Connection
Phase 1: Select a Table
  1. On the OpenESQL Assistant tree view, check the box adjacent to the OESQLDemo entry. This expands to show all available tables in the database.
  2. Check the box next to EMP.

    The Select Type of Query to Create dialog box enables you to choose the type of query you want to generate. In this case, we want to create a simple SELECT CURSOR statement. OpenESQL Assistant generates a default cursor name that we have the option to override. Here, we'll accept the default.

  3. Click SELECT (cursor), then click OK.

    The OpenESQL Assistant marks the table with check mark, generates the query, and places the generated code on the Query tab.

    The columns in your selected table appear on the tree view with an alias of "A" prepended to the column name. For SELECT queries only, OpenESQL Assistant assigns the alias of A to the first table you select for a query, B to the second table if you join another table to the query, C for the next, etc. By prepending the table alias to each column name, you can easily identify the table to which a column belongs even if the same column name appears in more than one table.

Phase 2: Select Columns
We want our SQL query to return the first and last names of our employees along with the pay rate for each employee.
  • Check the following column names:
    • A.FIRSTNME
    • A.LASTNAME
    • A.SALARY

    OpenESQL Assistant updates the Query tab with the appropriate code.

Phase 3: Test the Query
Our SQL query is complete at this point so we can test it.
  • Click Run Query Run Query.

    The OpenESQL Assistant shows the results of the query on the Results tab.

This completes the tutorial. Next, please complete Tutorial: Generate and Embed an SQL Program.

Parent topic: Tutorials: OpenESQL Assistant


Tutorial: Generate and Embed an SQL Program

Now that the SQL query has been generated, we can use OpenESQL Assistant to generate a generic COBOL program and embed the query right into it.

Requirements
Before attempting this tutorial, you must complete the following tutorials in the order listed:
  • Tutorial: Create a SQL Server Database
  • Tutorial: Create and Configure a Visual Studio Project
  • Tutorial: Set OpenESQL Assistant Configuration Options
  • Tutorial: Catalog a Connection
  • Tutorial: Build and Test a Query
Phase 1: Generate a Generic SQL Program
  1. Click the Auxiliary Code tab.
  2. From the drop-down list, click Generic SQL Program.

    OpenESQL Assistant generates a generic SQL program in the right-hand pane of the Auxiliary Code tab.

Phase 2: Open Program1.cbl
In this phase, we open the program that was automatically generated when we created the OESQLAssistantTutorial project, and delete its contents so we can replace them with the code generated by OpenESQL Assistant.
  1. In Solution Explorer, double-click Program1.cbl.

    This opens the source code editor with the cursor placed at the very beginning of the file.

  2. Select and delete all text in the file.
Phase 3: Embed the Generic SQL Program
We're now ready to embed our generic SQL program into the Program1.cbl file.
  1. Place your cursor at the beginning of the Program1.cbl file.
  2. From the OpenESQL Assistant Auxiliary Code tab, click Insert Query Into Current Program Insert Query Into Current Program.

    The generated code appears in Program1.cbl.

  3. Save Program1.cbl.
Phase 4: Embed the SQL Query
Next, we embed our SQL query into the generic program.
  1. In the program editor for Program1.cbl, place the cursor on the line just after the comment:
    *> Put your program logic/SQL statements here
  2. On the OpenESQL Assistant, click the Query tab; then click Insert Query Into Current Program Insert Query Into Current Program.

    OpenESQL Assistant inserts the query into the program.

This completes the tutorial. Next, please complete Tutorial: Provide Additional Code.

Parent topic: Tutorials: OpenESQL Assistant


Tutorial: Provide Additional Code

Our application will not compile and run unless we provide code that declares our table, provides a COBOL record to receive the data, and provides a COBOL record for indicator variables. We can use OpenESQL Assistant to generate a copybook that contains all of this code and an INCLUDE statement to call the copybook. We can also use OpenESQL Assistant to embed the INCLUDE statement into the program.

We want to send the output from the application to the console in a readable format. This requires additional code we enter into the program manually.

Requirements
Before attempting this tutorial, you must complete the following tutorials in the order listed:
  • Tutorial: Create a SQL Server Database
  • Tutorial: Create and Configure a Visual Studio Project
  • Tutorial: Set OpenESQL Assistant Configuration Options
  • Tutorial: Catalog a Connection
  • Tutorial: Build and Test a Query
Phase 1: Generate a Copybook
We can generate a copybook using the Host Variable Declarations feature on the Auxiliary Code tab of the OpenESQL Assistant.
  1. From the OpenESQL Assistant tree view, right-click the EMP table; then select Generate DCLGEN from the context menu.

    OpenESQL Assistant generates the copybook and brings up the Generate Host Variable Declarations dialog box, giving you the opportunity to name it. The default name of the copybook is tablename.cpy. In this case, the name of the generated copybook is emp.cpy.

  2. Save emp.cpy to the default folder, which is your current Visual Studio project folder.

    On the Auxiliary Code tab, you see that OpenESQL Assistant has also generated an INCLUDE statement to call the copybook from the program.

The following shows the code generated for the copybook:
       *> -------------------------------------------
       *> COBOL HOST VARIABLES FOR TABLE EMP
       *> -------------------------------------------
       01  EMP-EMPNO                          STRING.
       01  EMP-FIRSTNME                       STRING.
       01  EMP-MIDINIT                        STRING.
       01  EMP-LASTNAME                       STRING.
       01  EMP-WORKDEPT                       STRING.
       01  EMP-PHONENO                        STRING.
       01  EMP-HIREDATE                       type System.DateTime.
       01  EMP-JOB                            STRING.
       01  EMP-EDLEVEL                        BINARY-SHORT.
       01  EMP-SEX                            STRING.
       01  EMP-BIRTHDATE                      type System.DateTime.
       01  EMP-SALARY                         DECIMAL.
       01  EMP-BONUS                          DECIMAL.
       01  EMP-COMM                           DECIMAL.
       *> -------------------------------------------
       *> COBOL INDICATOR VARIABLES FOR TABLE EMP
       *> -------------------------------------------
       01  EMP-WORKDEPT-NULL                  BINARY-SHORT.
       01  EMP-PHONENO-NULL                   BINARY-SHORT.
       01  EMP-HIREDATE-NULL                  BINARY-SHORT.
       01  EMP-JOB-NULL                       BINARY-SHORT.
       01  EMP-EDLEVEL-NULL                   BINARY-SHORT.
       01  EMP-SEX-NULL                       BINARY-SHORT.
       01  EMP-BIRTHDATE-NULL                 BINARY-SHORT.
       01  EMP-SALARY-NULL                    BINARY-SHORT.
       01  EMP-BONUS-NULL                     BINARY-SHORT.
       01  EMP-COMM-NULL                      BINARY-SHORT.
Phase 2: Embed the INCLUDE statement
We need to embed the generated INCLUDE statement into our program.
  1. In the program editor for Program1.cbl, place the cursor on the line just after the EXEC SQL INCLUDE SQLCA statement.
  2. From the OpenESQL Assistant Auxiliary Code tab, click Insert Query Into Current Program Insert Query Into Current Program.

    OpenESQL Assistant inserts the generated INCLUDE statement into the program.

  3. Save Program1.cbl.
Phase 3: Add Code to Format Output
When we run our program, we want to be able to see the results of the query as easily as we see them when we run the query in the OpenESQL Assistant. To achieve this, we need to add some code to the program that formats SALARY data, and code that sends all data to the console in a readable format.
  1. With Program1.cbl showing in the source code editor, type the following working-storage record after the EXEC SQL INCLUDE EMP END-EXEC statement:
    01  EDIT-PAY     PIC Z,ZZ99.99.
  2. Scroll down to the following IF statement:
    IF SQLSTATE < "02000"
  3. Place your cursor on the next line down and insert the following MOVE statement:
    MOVE EMP-SALARY TO EDIT-PAY
  4. Replace the following DISPLAY statement:
    DISPLAY 'ROW FOUND'

    with

    DISPLAY 'NAME: ' EMP-LASTNAME ', ' EMP-FIRSTNME '   SALARY: ' EDIT-PAY UPON CONSOLE
  5. Save Program1.cbl.

This completes the tutorial. Next, please complete Tutorial: Build and Run the Application.

Parent topic: Tutorials: OpenESQL Assistant


Tutorial: Build and Run the Application

Requirements
Before attempting this tutorial, you must complete the following tutorials in the order listed:
  • Tutorial: Create a SQL Server Database
  • Tutorial: Create and Configure a Visual Studio Project
  • Tutorial: Set OpenESQL Assistant Configuration Options
  • Tutorial: Catalog a Connection
  • Tutorial: Build and Test a Query
  • Tutorial: Generate and Embed an SQL Program
  • Tutorial: Provide Additional Code
Phase 1: Add the Generated Copybook to the Project
While the OpenESQL Assistant generated and saved the copybook necessary to compile the application, it does not automatically add the file to the current project. The copybook must be part of the project to be included in the compiled application.
  1. From the Solution Explorer, right-click the OESQLAssistantTutorial project and select Add > Existing Item.
  2. Select EMP.cpy; then click Add.

    The EMP.cpy copybook is added to the project.

Phase 2: Add a Break Point
The program sends output to the console, and we want the application to pause at the point where we can see the output.
  1. If it isn't already in the program editor, double-click Program1.cbl from the Solution Explorer to call it up into the program editor.
  2. In ther program editor, scroll down to the following line of code:
    EXEC SQL DISCONNECT CURRENT END-EXEC
  3. Press F9 to toggle a break point.
  4. Save Program1.cbl.
Phase 3: Build the Application
  1. From the Solution Explorer, right-click the OESQLAssistantTutorial project and select Build.
Phase 4: Run the Application
  1. Press F5 to start debugging.
  2. If the console is not visible, minimize Visual Studio. You should see the console output.
  3. Press F5 again to complete the debugging process.

This completes the OpenESQL Assistant tutorials.

Parent topic: Tutorials: OpenESQL Assistant


Setting OpenESQL Assistant Options

Before creating SQL queries using OpenESQL Assistant, you can set options that determine the behavior of the OpenESQL Assistant and specify how it generates SQL. To do this, click Tools > Options; then expand Micro Focus COBOL Tools and click OpenESQL Assistant.

Parent topic: OpenESQL Assistant
Related tasks
To set OpenESQL Assistant options
To create a TSQL stored procedure query
To set OpenESQL Assistant options
To connect to a data source
To connect to a different data source
To disconnect from a data source
To start the ADO.NET Connection Editor
To add an XML data source
To close a query
To run a query
To create a TSQL stored procedure query
To create an SQL query
Related reference
SQL TYPEs
OpenESQL Assistant - Options
OpenESQL Assistant - Main Window
Select Type of Query to Create dialog box


Using OpenESQL Assistant

Use the OpenESQL Assistant to easily design and build SQL queries and embed those queries into your COBOL code. As you make specifications for a query, OpenESQL Assistant generates the necessary code for you. You can also test the queries you create to ensure they are producing the proper results before you embed them into your programs. And, you can use OpenESQL Assistant to generate and embed the auxiliary code necessary to support your queries in COBOL.

  • Starting the OpenESQL Assistant
  • Connecting to a Data Source
  • Building Queries
  • Testing Your SQL Queries
  • Embedding SQL into a Program
  • Auxiliary Code
  • Stored Procedures
Parent topic: OpenESQL Assistant


Starting the OpenESQL Assistant

You can configure the OpenESQL Assistant's dockable window to appear when you start Visual Studio or you can simply invoke it when you need it.

Depending on how OpenESQL is configured, you might be prompted to supply a user name and password.

Parent topic: Using OpenESQL Assistant
Related tasks
To start the OpenESQL Assistant


Connecting to a Data Source

Before you can use OpenESQL Assistant to generate SQL, you must first connect to the data source that contains the data you want to access. All data sources cataloged on your workstation are listed in the tree view of the OpenESQL Assistant. You can only connect to one data source at a time. After you have connected, all of the table names in the data source show on the tree view.

Important: You must connect to a 32-bit data source even if the generated application targets a 64-bit platform.

If you are running in ODBC mode and have checked the Automatically catalog data source on CONNECT option for OpenESQL Assistant, all ODBC data sources on your workstation are automatically cataloged as an ODBC ADO.NET data provider. See your Microsoft documentation for information on setting up ODBC data sources.

Note:
  • You can use the ADO.NET Connection Editor to catalog other data sources as ADO.NET data providers.
  • If you receive a connect error, OpenESQL Assistant prompts you for your User ID and Password if you don't want to save the information with connection settings.
Parent topic: Using OpenESQL Assistant
Related tasks
To connect to a data source
To connect to a different data source


Building Queries

The process of building a query using OpenESQL includes at least some and potentially all of the following steps:

  • Determine which table you want to query
  • Select the type of query to create
  • Select a column or columns to query
  • Specify search criteria to limit returned data
  • Dictate the order in which data is retrieved and displayed
  • Specify table joins

The following sections provide information about this process.

  • Selecting a Table and a Query Type
  • Selecting Columns
  • Specifying Aggregate Functions for Columns
  • Specifying Search Criteria
  • Specifying the Order in which Data is Retrieved
  • Creating a Table Join
  • Working with Queries
Parent topic: Using OpenESQL Assistant
Related tasks
To create a TSQL stored procedure query
To start the OpenESQL Assistant
To connect to a data source
To create an SQL query
To set OpenESQL Assistant options
To create a TSQL stored procedure query
To create an SQL query
To embed an SQL query into a COBOL program
To specify search criteria (a WHERE clause)
Related reference
Select Type of Query to Create dialog box
Query tab
Results tab
Details tab
Search Criteria tab
Literal Value dialog box


Selecting a Table and a Query Type

You can select one table at a time or you can select all of the tables in a data source. OpenESQL Assistant prompts you to select the type of query you would like to perform on the table or tables by presenting the Select Type of Query to Create dialog box. This dialog box contains a list of query types you can perform on your selection. Depending on the type of query you select, you can also change the default cursor name, specify that your query be generated as a Stored Procedure, and specify the stored procedure (SP) name.

Selected tables appear in the tree view with a check mark next to the table icon, Checked Table.

Once you have selected a query, the COBOL code for the query you have selected is automatically generated and displayed underneath the Query tab. At the same time, a list of all the columns in the table is displayed underneath the table name.

For SELECT queries, a table alias is generated automatically by the OpenESQL Assistant. For example:

SELECT FROM Customer A

The first table selected generates an alias of the letter A. If you select a second table, the OpenESQL Assistant generates an alias of B and so on.

Each column name is prefixed by its alias (for example, A.CustID, A.Company). This enables you to distinguish the columns in one table from those in another.

Some databases use special characters in the names of system tables. For example, Oracle can use system tables whose names contain a dollar sign ($). When the OpenESQL Assistant encounters a special character in the name of system table that would render the generated table name illegal, it automatically encloses the column and table names in quotes.

If the name generated from the column name (including any prefixes and suffixes) is longer than 31 characters or contains illegal characters would be illegal in COBOL, OpenESQL generates a host variable using the column number (for example, COL005) rather than the column name.

Parent topic: Building Queries
Related tasks
To create an SQL query
To generate an INSERT statement
To generate a DELETE statement
To generate a SELECT (cursor) statement
To generate a SELECT (singleton) statement
To generate an UPDATE statement


Selecting Columns

Once you have generated your initial query code, you can select one or more columns to process in your query. You can add columns to your query by checking the box that appears next to a column name in the tree view. Selected columns appear in the tree view with a check mark next to the column icon, Checked Column. Each column name is prefixed by its alias (for example, A.CustID, A.Company). This enables you to distinguish the columns in one table from those in another.

Note: If the name generated from the column name (including any prefixes and suffixes) is longer than 31 characters or contains characters that are illegal in COBOL, OpenESQL generates a host variable using the column number (for example, COL005) rather than the column name.
Parent topic: Building Queries
Related tasks
To add a column to a query
To add all columns in a table to a query


Specifying Aggregate Functions for Columns

You can specify an aggregate function for any column in a SELECT (cursor) or SELECT DISTINCT (cursor) query. An aggregate function retrieves certain information about the data returned from a column.

OpenESQL returns the following information for each group of returned data:

Aggregate Function | Value for each group of returned data
Sum | Sum of all values returned (numerical columns only)
Avg | Average of all values returned (numerical columns only)
Max | Maximum value returned
Min | Minimum value returned
Count | Number of records returned
Parent topic: Building Queries
Related tasks
To perform an aggregate function


Specifying Search Criteria

You can limit which rows are returned by a query by specifying search criteria on the OpenESQL Assistant Search Criteria tab. OpenESQL Assistant generates a WHERE clause based on the criteria you specify.

Parent topic: Building Queries
Related tasks
To specify search criteria (a WHERE clause)
To specify search criteria (a WHERE clause)
Related reference
Search Criteria tab


Specifying the Order in which Data is Retrieved

You can order the rows that are returned by a query by specifying which columns to sort using the OpenESQL Assistant Sort tab. OpenESQL Assistant generates an ORDER BY clause based on the order you specify.

Parent topic: Building Queries
Related tasks
To sort returned data (an ORDER BY clause)


Creating a Table Join

Where tables have at least one column in common, you can create a table join enabling you to retrieve information from more than one table at the same time. The OpenESQL Assistant creates a table join using the first matching column it finds. If OpenESQL does not find any matching columns, it cannot generate the join automatically. In this case, you can specify the join using the Search Criteria feature.

This feature is only available for SELECT queries.

Parent topic: Building Queries


Working with Queries

These topics present some features of OpenESQL Assistant that can help you enhance your ability to create queries.

  • Display Column Details
  • Disconnect from a Data Source
  • Close a Query
  • Remove a Table from a SELECT Query
  • Changing a SELECT (cursor) query to do an Array FETCH
Parent topic: Building Queries


Display Column Details

The Details tab in the OpenESQL Assistant shows detailed information on the columns in a table. The columns on the Details tab describe the columns in the selected table as follows:

  • Column Name

    The column name of each column in the table. Notice that each column name is prefixed by the table alias. For example, a table with the name CustID shows on in the Column Name column as A.CustID. A tick in the box to the left of Column Name indicates that the column is currently selected.

  • Type

    The data type of the column. These are the data types used by the data source to which you are connected. The data type of a column must match the COBOL picture clause of the host variable that is used to pass values for that column to and from the data source.

    OpenESQL Assistant can generate a copybook, tablename.cpy, in the current directory that declares all of the necessary host variables, matching them with COBOL picture clauses generated using column data types. See the topic Auxiliary Code for more details.

  • Precision

    The total number of digits in numerical columns or the length of the column for text columns.

  • Scale

    The number of digits to which the column is rounded, where relevant.

  • Host Variable

    The value of the generated host variable for the column. Generated host variable names take the form:

    :<table-name>-<column-name>
  • Indicator Variable

    The value of the generated indicator variable for the column. Generated indicator variable names take the form:

    :<table-name>-<column-name>-NULL
Parent topic: Working with Queries
Related concepts
Working With OpenESQL Cursors and Result Sets
Auxiliary Code
Related tasks
To display column details
Related reference
Details tab


Disconnect from a Data Source

When you disconnect from a data source, OpenESQL discards the current query. You must disconnect from one data source before you can connect to another.

Parent topic: Working with Queries
Related tasks
To disconnect from a data source


Close a Query

When you close a query, OpenESQL discards the generated code, enabling you to start a new query.

Parent topic: Working with Queries
Related tasks
To close a query


Remove a Table from a SELECT Query

Most queries you create using OpenESQL Assistant access one table only. If you remove that table from the query, OpenESQL closes the query and you lose the code you've generated for it. However, if you have created a SELECT query that contains one or more table joins, you can safely remove a table without closing the query. When you initiate the removal of a table from a SELECT query, you're prompted to confirm your decision. Upon confirmation, OpenESQL removes the generated code that pertains to the table from the query. It also removes any code pertaining to columns that belong to that table.

Parent topic: Working with Queries
Related tasks
To remove a table from a SELECT query


Changing a SELECT (cursor) query to do an Array FETCH

OpenESQL Assistant doesn't directly generate code for array fetches. However, you can modify the SELECT (cursor) code generated by OpenESQL Assistant to handle array fetches.

Parent topic: Working with Queries
Related tasks
To change a SELECT (cursor) query to do an array FETCH


Testing Your SQL Queries

You can use OpenESQL Assistant to test the queries you create before committing them to program code. To do this, you simply run a query from the OpenESQL Assistant. The results for all SELECT statements appear automatically on the Results tab. Other query types return the following information in a message box:

  • The name of the query executed
  • The number of rows returned
  • Whether or not the query ran successfully

Occasionally, the query you create will require additional specifications for it to execute correctly. If OpenESQL Assistant cannot execute the code, you are prompted to correct it.

Note: When you run a query in OpenESQL Assistant, any UPDATE, INSERT, and DELETE statements do execute against the database, potentially altering its contents.
Parent topic: Using OpenESQL Assistant
Related reference
Results tab


Embedding SQL into a Program

Once you are happy with the SQL query that you have created, you can insert it into your COBOL program.

Parent topic: Using OpenESQL Assistant
Related tasks
To generate and embed auxiliary code
To embed an SQL query into a COBOL program
To change a SELECT (cursor) query to do an array FETCH


Auxiliary Code

The SQL queries you generate with OpenESQL often require additional code outside of the query itself in order to execute properly from your COBOL programs. For example, under DB2 LUW you cannot successfully execute an SQL query that accesses a database until you have inserted a CONNECT statement to connect to the data source. Once you have embedded your query, you can use OpenESQL Assistant to generate and embed this auxiliary code.

  • Generating EXEC SQL Auxiliary Code
  • Embedding Auxiliary Code
  • Generating EXEC ADO Auxiliary Code
Parent topic: Using OpenESQL Assistant
Related concepts
Display Column Details
Related tasks
To generate and embed auxiliary code
To embed an SQL query into a COBOL program
To change a SELECT (cursor) query to do an array FETCH
To generate and embed auxiliary code
Related reference
Auxiliary Code tab


Generating EXEC SQL Auxiliary Code

OpenESQL Assistant can generate the following types of EXEC SQL auxiliary code:

  • CONNECT Statement

    Generates a CONNECT statement based on known information about your current data source connection.

  • Type 6 CONNECT statement

    Generates a type 6 CONNECT statement, allowing the application to connect to data sources that are not cataloged.

  • SQLCA Declaration

    Generates an INCLUDE statement to include an SQL Communications Area (SQLCA) in your program.

  • Host Variable Declarations

    For each table that you have selected, the OpenESQL Assistant generates a copybook that includes all of the host variable declarations you need. The OpenESQL Assistant can also generate the INCLUDE statement necessary to include the copybook in your program.

  • OpenESQL Assistant DISCONNECT Statement

    Generates a DISCONNECT statement to disconnect from the current data source.

  • COMMIT Statement

    Generates a COMMIT statement to commit changes to a data source issued from a previous SQL statement.

  • ROLLBACK Statement

    Generates a ROLLBACK statement to rollback changes to a data source issued by a previous SQL statement or statements.

  • Generic SQL Program

    Generates a skeleton SQL program that includes the INCLUDE SQLCA, CONNECT and DISCONNECT SQL statements and a default SQL error routine.

Parent topic: Auxiliary Code
Related tasks
To generate and embed auxiliary code
To embed an SQL query into a COBOL program
To change a SELECT (cursor) query to do an array FETCH


Embedding Auxiliary Code

You embed auxiliary code in the same manner as you embed your SQL queries.

Parent topic: Auxiliary Code
Related tasks
To generate and embed auxiliary code
To embed an SQL query into a COBOL program
To change a SELECT (cursor) query to do an array FETCH


Generating EXEC ADO Auxiliary Code

If you have enabled OpenESQL Assistant to generate EXEC ADO code by checking the Generate EXEC ADO option when you set options for OpenESQL, you can generate auxiliary code for both the EXEC ADO disconnected and connected models.

OpenESQL Assistant embeds the dataset name you specify in the Dataset name field on the Auxiliary Code tab into all generated statements that cite a dataset.

Note: You can mix EXEC ADO and EXEC SQL statements in the same program providing that you compile your COBOL program with the directive SQL(DBMAN=ADO).
  • Generated EXEC ADO Statements
  • Disconnected Model Statements
  • Connected Model Statements
  • EXEC ADO Wizards
Parent topic: Auxiliary Code


Generated EXEC ADO Statements

OpenESQL Assistant can generate the following types of EXEC ADO auxiliary code. For a description of each, see the section Using Embedded EXEC ADO Statements in the chapter Using OpenESQL with ADO.NET.

Connected or Disconnected Models

  • DECLARE DATASET
  • DECLARE DATATABLE
  • GET CHANGES
  • INITIALIZE DATASET
  • UNBIND DATASET

Disconnected Models

  • ACCEPT CHANGES
  • BIND DATASET
  • BIND DATATABLE
  • CLEAR
  • DECLARE DATATABLE
  • DECLARE UNTYPED DATASET
  • GET DATATABLE
  • INITIALIZE DATASET
  • INITIALIZE DATATABLE
  • LOAD DATASET
  • MERGE DATASET
  • REJECT CHANGES
  • SAVE DATASET
  • SAVE DATATABLE
  • UNBIND DATASET
  • UNBIND DATATABLE
  • USING DATASET
  • Generic SQL Program

    Generates a skeleton SQL program that includes the INCLUDE SQLCA statement and a default SQL error routine.

Connected Models

  • BIND CONNECTION
  • FILL DATASET
  • GET CONNECTION
  • PREPARE TO FILL
  • PREPARE TO UPDATE
  • REBIND CONNECTION
  • UNBIND DATASET
  • UPDATE DATASOURCE
  • UNBIND CONNECTION
  • TO DELETE USE
  • TO FILL USE
  • TO INSERT USE
  • TO REFRESH USE
  • TO UPDATE USE
  • Generic SQL Program

    Generates a skeleton SQL program that includes the INCLUDE SQLCA, CONNECT and DISCONNECT SQL statements and a default SQL error routine.

Parent topic: Generating EXEC ADO Auxiliary Code


Disconnected Model Statements

Disconnected model statements enable you to define, create and manipulate ADO.NET objects in COBOL. They are commonly used to:

  • Define DataTables and their relationships to each other within a DataSet
  • Insert, update and delete DataRows in a DataTable
  • Select DataRows from a DataTable
  • Clear DataTables in a DataSet
  • Commit or rollback pending changes in a DataSet
  • Load an existing XML DataSet file into a COBOL DataSet
  • Save a DataSet to a file in XML format.

The following disconnected model statements are available to you:

  • BIND DATATABLE – allows an ADO.NET DataTable to be shared with OpenESQL
  • BIND DATASET – allows an ADO.NET DataSet to be shared with OpenESQL
  • CLEAR - clears the data in specified DataTables of a DataSet
  • DECLARE DATATABLE – defines a DataTable
  • DECLARE DATASET – defines a DataSet
  • GET DATATABLE – copies a DataTable object into a host variable or creates a DataTable object within a host variable
  • INITIALIZE DATATABLE – creates a DataTable
  • INITIALIZE DATASET – creates a DataSet
  • INSERT – adds DataRows into a DataTable
  • DELETE (SEARCHED) – deletes DataRows from a DataTable
  • UPDATE (SEARCHED) – updates DataRows in a DataTable
  • SELECT INTO – retrieves DataRows from a DataTable
  • CLEAR – clears the DataTables in a DataSet
  • ACCEPT CHANGES – commits pending changes to a DataSet.

    Note that, this statement does not commit changes to a database. To commit changes to a database, you must use the connected model to synchronize the DataSet with the database and then use the EXEC SQL COMMIT statement.

  • REJECT CHANGES – rolls back pending changes made to a DataSet.

    Note that, this statement does not roll back changes made to a database. To roll back changes in a database, you must use the connected model to synchronize the DataSet with the database and then use the EXEC SQL ROLLBACK statement.

  • LOAD DATATABLE – loads a DataTable from an XML file
  • LOAD DATASET – loads a DataSet from an XML file
  • SAVE DATATABLE – saves a DataTable to an XML file
  • SAVE DATASET – saves a DataSet to an XML file
  • MERGE DATATABLE – merges two similar DataTables together
  • MERGE DATASET – merges two similar DataSets together
  • UNBIND DATATABLE – disassociates OpenESQL from a DataTable in another ADO.NET application
  • UNBIND DATASET – disassociates OpenESQL from a DataSet in another ADO.NET application
  • USING – defines a default DataSet for EXEC ADO processing
Parent topic: Generating EXEC ADO Auxiliary Code
Parent topic: Using Embedded EXEC ADO Statements


Connected Model Statements

Connected model statements enable you to interact with a data source. The FILL commands retrieve data from a data source and place it into the DataTables of a DataSet. The UPDATE commands ensure that any Data Manipulation Language (DML) changes (INSERT, UPDATE, and DELETE) are returned to the data source.

The following connected model statements are available to you:

  • PREPARE TO FILL – signals the DataSet to be filled
  • TO FILL USE – specifies the logic to retrieve data from table in data source to DataTable in DataSet
  • FILL – does the actual fill of the DataTables
  • PREPARE TO UPDATE – signals the DataSet whose DML changes are to be placed in a data source
  • TO DELETE USE – specifies the delete logic to be used in a data source
  • TO INSERT USE – specifies the insert logic to be used in a data source
  • TO REFRESH USE – specifies the refresh logic to be used in a data source
  • TO UPDATE USE – specified the update logic to be used in a data source
  • UPDATE – does the actual update to a data source
Parent topic: Generating EXEC ADO Auxiliary Code
Parent topic: Using Embedded EXEC ADO Statements


EXEC ADO Wizards

Certain EXEC ADO statements require a significant amount of user input to build them correctly. When you use the OpenESQL Assistant Auxiliary Code tab to generate one of these statements, you invoke a wizard that walks you through the various options for that statement.

The statements generated by these wizards are very similar to the EXEC ADO DELETE, INSERT, SELECT, and UPDATE statements except that you cannot execute them from the OpenESQL Assistant. Because the Wizards need table and column names to work correctly, you must create a query first.

OpenESQL Assistant provides the following wizards for use in generating auxiliary code:

  • TO DELETE USE Wizard

    Use this wizard to build a WHERE clause that limits what values to delete from a data source when the data source is updated. The wizard provides a page similar to the Search Criteria tab. It is not necessary for you to supply a Target type or Value because these are dependent upon the column selected.

    Embed the generated TO DELETE USE statement into your program after an EXEC ADO PREPARE TO UPDATE statement and before the EXEC ADO UPDATE DATASOURCE statement.

  • TO FILL USE Wizard

    Use this wizard to limit the number of rows and columns that are returned from the data source when the EXEC ADO FILL DATASET statement is executed. The wizard provides pages that enable you to:

    • Specify all columns or specific columns
    • Specify search criteria to use in building a WHERE clause
    Note: If you specify a literal value as part of your WHERE clause, surround it with either single or double quotes depending on which identifier your DBMS uses to enclose literals.

    For the generated statement to work properly you must have DECLARE DATATABLE and DECLARE DATASET statements coded into your program, and you must embed the TO FILL USE statement into your program after a PREPARE TO FILL statement.

    The ConnectedDemo application provided by Micro Focus shows detailed examples of using the TO FILL USE statement in an application. For more information, see the section Demonstration Projects in the chapter Using OpenESQL with ADO.NET.

  • TO INSERT USE Wizard

    Use this wizard limit what values to insert into a data source when the data source is updated. The wizard provides pages that enable you to:

    • Optionally generate a WITH REFRESH clause

      You should opt to generate this clause if you want data to be returned to your application after updating a data source with newly inserted rows.

    • Specify all columns or specific columns
    • Specify search criteria to use in building a WHERE clause
    • Specify the source data and column you want to return

      You can specify these only if you have opted to generate the WITH REFRESH clause. The pre-defined source value “@@IDENTITY” is provided to work with Microsoft SQL Server data providers.

    Embed this statement into your program after an EXEC ADO PREPARE TO UPDATE statement and before the EXEC ADO UPDATE DATASOURCE statement.

  • TO REFRESH USE WizardSpecify the source data and column you want to refresh

    Use this wizard to generate an EXEC ADO TO REFRESH statement to update values in your dataset after updating the data source. Generate this statement in lieu of placing the REFRESH clause in TO INSERT or TO UPDATE EXEC ADO statements. The wizard provides one page that enables you to specify the source data and column you want to return. The pre-defined source value “@@IDENTITY” is provided to work with Microsoft SQL Server data providers.

    Embed this statement into your program after an EXEC ADO PREPARE TO UPDATE statement and before the EXEC ADO UPDATE DATASOURCE statement.

  • TO UPDATE USE Wizard

    Use this wizard to limit what columns and values to update to a data source. The wizard provides pages that enable you to:

    • Optionally generate a WITH REFRESH clause

      You should opt to generate this clause if you want data to be returned to your application after updating a data source with new values.

    • Specify all columns or specific columns
    • Specify search criteria to use in building a WHERE clause

      It is not necessary for you to supply a Target type or Value when building your WHERE clause because these are dependent upon the column selected.

    • Specify the source data and column you want to return

      You can specify these only if you have opted to generate the WITH REFRESH clause. The pre-defined source value “@@IDENTITY” is provided to work with Microsoft SQL Server data providers.

    Embed this statement into your program after an EXEC ADO PREPARE TO UPDATE statement and before the EXEC ADO UPDATE DATASOURCE statement.

Parent topic: Generating EXEC ADO Auxiliary Code


Stored Procedures

This section provides information on generating stored procedures and testing them using OpenESQL Assistant.

Multiple types of SQL statements can exist within a stored procedure. OpenESQL Assistant is not designed to generate stored procedures with multiple types of SQL statements. You need tools, such as the ones provided by Microsoft, to do this.

The intention of OpenESQL Assistant is to allow you to quickly learn how to generate simple SQL stored procedures and the COBOL code required to invoke those stored procedures.

  • Generating an SQL Stored Procedure Query
  • Testing an SQL Stored Procedure Query
  • Embedding an SQL Stored Procedure into a Program
Parent topic: Using OpenESQL Assistant
Related tasks
To create a TSQL stored procedure query
To set OpenESQL Assistant options
To create a TSQL stored procedure query
To create an SQL query
Related reference
Select Type of Query to Create dialog box


Generating an SQL Stored Procedure Query

Microsoft provides tools to create, edit, and test SQL stored procedures. It is then the task of the programmer to generate the code to invoke these stored procedures from a COBOL client program. The OpenESQL Assistant makes this process easier.

When using Microsoft SQL Server data sources, you have the option to use OpenESQL Assistant to generate the query as a stored procedure. OpenESQL Assistant generates both the SQL statements to create the stored procedure and the client code to invoke it.

OpenESQL Assistant generates two SQL statements that drop the stored procedure and then create it. You typically place these SQL statements in a server program because they only need to be executed once.

OpenESQL Assistant also generates the code that goes into the client program and invokes the stored procedure. Depending on the type of query you select, OpenESQL Assistant might generate a DECLARE CURSOR statement that invokes the stored procedure or it might generate SQL CALL statements only.

Parent topic: Stored Procedures
Related tasks
To create a TSQL stored procedure query


Testing an SQL Stored Procedure Query

Once you have built the SQL stored procedure query, you can test it in much the same manner as you test other queries. However, because multiple SQL statements are created by OpenESQL Assistant for a stored procedure, you need to run the query multiple times. Each time you run the query, you execute the next SQL statement.

The first time you run the query, the DROP PROCEDURE statement is executed, and the following message appears:

Cannot drop the procedure 'spname,' because it does not exist...

This message is expected and will change if you execute the DROP PROCEDURE multiple times.

The second time you run the query, the CREATE PROCEDURE statement is executed. A message appears indicating that the statement executed successfully.

To execute a stored procedure CALL statement with search criteria that requires you to provide a literal value, you are prompted to provide that literal value.

When all SQL statements have been executed, OpenESQL shows the results on the Results tab.

You can repeat this process until you are satisfied with the results.

Parent topic: Stored Procedures


Embedding an SQL Stored Procedure into a Program

This procedure is also similar to that of embedding a standard SQL query into a program.

OpenESQL Assistant generates statements for both client and server programs. You can delete the statements which are not needed. If your program is the client program, the DROP and CREATE PROCEDURE statements are not necessary.

Note: If you test the query as outlined above, you do not need to run either the DROP or CREATE PROCEDURE statements in a program as the SQL stored procedure has already been created. If the stored procedure has not already been created, then you need to either add an SQL COMMIT statement or add directive SQL(AUTOCOMMIT) to the program that issues the CREATE PROCEDURE. Otherwise the stored procedure is not saved to the data source.
Parent topic: Stored Procedures
Related tasks
To embed an SQL query into a COBOL program


Working With OpenESQL Cursors and Result Sets

OpenESQL applications support multiple results sets when you define your DECLARE CURSOR statements to include multiple SELECT statements.

Note: You can also reference multiple result sets by executing a stored procedure. For more information on how this works, see Working With OpenESQL Stored Procedures and Result Sets.
To return multiple result sets for a particular cursor, its DECLARE CURSOR statement in your application must open the cursor and also contain a SELECT statement for each result set you want to return. For example:
      EXEC SQL
          DECLARE C1 CURSOR
          FOR
              SELECT CUSTID FROM COMPANY;
              SELECT CUSTNAME FROM COMPANY;
      END-EXEC
      EXEC SQL OPEN C1 END-EXEC

In this example, we return two result sets. After opening the C1 cursor, execute a FETCH statement to consume the first result set - that defined by the SELECT CUSTID FROM COMPANY statement.

When FETCH returns an SQLCODE of 100 (signifying the end of the current result set), issue the GET NEXT RESULT SET statement to fetch the result set for the next SELECT statement. For example:
      EXEC SQL
          GET NEXT RESULT SET FOR C1
      END-EXEC
Once the result set for SELECT CUSTNAME FROM COMPANY is consumed, GET NEXT RESULT SET returns an SQLCODE of 100, indicating that no additional result sets are available.
Note: If another result set is available, meaning your DECLARE CURSOR statement contains at least one additional SELECT statement that has not been processed, GET NEXT RESULT SET returns an SQLCODE of 0. To retrieve all available result sets, continue issuing the GET NEXT RESULT SET statement until it returns an SQLCODE of 100.
Parent topic: Programming for OpenESQL
Related concepts
Display Column Details
Related reference
DECLARE CURSOR
FETCH
GET NEXT RESULT SET


Working With OpenESQL Stored Procedures and Result Sets

An OpenESQL stored procedure can:

  • Accept input parameters
  • Return output parameters
  • Accept and return input/output parameters
  • Use positional or keyword parameters
  • Return one or more forward only read only result sets
  • Be called with parameter arrays
Note: The features provided by different database vendors vary considerably, and any given vendor might offer only a subset of the features listed above. For this reason, stored procedure calls are much less portable between data sources than other OpenESQL statements.

Calling a Stored Procedure that Returns No Result Sets

To call a stored procedure that returns no result sets, use the CALL embedded SQL statement, or the EXECSP embedded SQL statement if you want to ensure backward compatibility with the Micro Focus Embedded SQL Toolkit for Microsoft SQL Server. For complete details on using these statements, see the CALL and EXECSP topics.

Calling a Stored Procedure that Returns One or More Result Sets

If a stored procedure returns one or more result sets, you must first declare it using the DECLARE CURSOR statement. For example:

         EXEC SQL
                DECLARE cursorName CURSOR FOR storedProcedureCallStatement
         END-EXEC

You then call the stored procedure just as you would any other type of cursor using the OPEN statement to open the cursor, followed by the FETCH statement to fetch result set rows.

If your stored procedure is coded to return more than one result set, and your FETCH statement returns an SQLCODE of 100 (signifying the end of the current result set), you can issue the GET NEXT RESULT SET statement to fetch the next result set as follows:
          EXEC SQL
                 GET NEXT RESULT SET FOR cursorName
          END-EXEC

If your GET NEXT RESULT SET statement returns an SQLCODE of 0, another result set is available, and you can issue another GET NEXT RESULT SET to retrieve it. However, if GET NEXT RESULT SET returns an SQLCODE of 100, no additional result sets are available.

Using Array Parameters

ODBC parameters differ from Oracle array parameters. The effect of using a parameter array is the same as repeating the statement for each element of the array. On a stored procedure call, if one parameter is passed as an array, then all parameters must be arrays with the same number of elements. The stored procedure "sees" one call for each "row" of parameters. The number of rows passed can be limited to less than the full array size by preceding the call with the following phrase:
FOR :hvar

Where :hvar is an integer host variable containing a count of the number of rows to be passed.

Parent topic: Programming for OpenESQL
Related reference
CALL
EXECSP
DECLARE CURSOR
FETCH
GET NEXT RESULT SET


Unicode Support in OpenESQL

Some applications want to retrieve or store unicode data in Microsoft SQL Server data sources without it being converted to ANSI. Previous versions of OpenESQL did not have a way of accessing data without it being automatically converted. Now, however, OpenESQL and your COBOL development system can work directly with unicode data without having it converted to ANSI, by using a new type of host variable. Microsoft SQL Server supports three unicode column types:

  • NCHAR
  • NVARCHAR
  • NTEXT
Note: If an application uses Static SQL, it returns standard data types. If, however, an application uses Dynamic SQL, it returns the new data types listed above.

To access these columns without the data being automatically converted, define a host variable with a definition of:

PIC N(xx) USAGE NATIONAL

where xx is the size of the column. This format is currently supported for both fixed and variable length data. Variable length data can be terminated with nulls to signify end of data for column when inserting or updating data. When data is retrieved from the data source, it will be space filled to the end of the host variable.

For example, the following program will retrieve employee information from the Northwind sample database that comes with Microsoft SQL Server 2000 product:

$SET UNICODE(NATIVE)
$SET SQL
 WORKING-STORAGE SECTION.

 EXEC SQL INCLUDE SQLCA  END-EXEC

* after an sql error this has the full message text
 01 MFSQLMESSAGETEXT  PIC X(250).
 01 IDX         PIC X(04)  COMP-5.

 EXEC SQL BEGIN DECLARE SECTION  END-EXEC
* Put your host variables here if you need to port
* to other COBOL compilers
 EXEC SQL INCLUDE Employees END-EXEC

 EXEC SQL END DECLARE SECTION END-EXEC

 PROCEDURE DIVISION.

     EXEC SQL
         WHENEVER SQLERROR perform OpenESQL-Error
     END-EXEC

     EXEC SQL
         CONNECT TO 'LocalServer'
     END-EXEC

* Put your program logic/SQL statements here
     EXEC SQL
         DECLARE CSR135 CURSOR FOR SELECT
               A.FirstName
              ,A.LastName
              ,A.EmployeeID
              ,A.HireDate
             FROM Employees A
     END-EXEC
     EXEC SQL OPEN CSR135 END-EXEC
     PERFORM UNTIL SQLSTATE >= "02000"
         EXEC SQL
             FETCH CSR135 INTO
                :Employees-FirstName
               ,:Employees-LastName
               ,:Employees-EmployeeID
               ,:Employees-HireDate:Employees-HireDate-NULL
         END-EXEC

        *> Process data from FETCH
         IF SQLSTATE < "02000"

*      for array fetches, field sqlerrd(3) contains the
*      number of rows returned
*            PERFORM VARYING IDX FROM 1 BY 1
*                    UNTIL IDX > SQLERRD(3)

*     you will need to add code here to process the array

*            END-PERFORM
         END-IF
     END-PERFORM
     EXEC SQL CLOSE CSR135 END-EXEC

     EXEC SQL DISCONNECT CURRENT END-EXEC
     EXIT PROGRAM.
     STOP RUN.

* Default sql error routine - modify to stop program
* if needed
 OpenESQL-Error Section.
     display "SQL Error = " sqlstate " " sqlcode
     display MFSQLMESSAGETEXT
*    stop run
     exit.

This is the same code that would retrieve the data in ANSI except for the definitions in the INCLUDE copybook Employees which now looks like:

* -----------------------------------------------------------
* COBOL DECLARATION FOR TABLE Employees
* -----------------------------------------------------------
 01  DCLEmployees.
     03 Employees-EmployeeID       PIC S9(09)  COMP-5.
     03 Employees-LastName         PIC N(20) USAGE NATIONAL.
     03 Employees-FirstName        PIC N(10) USAGE NATIONAL.
     03 Employees-Title            PIC N(30) USAGE NATIONAL.
     03 Employees-TitleOfCourtesy  PIC N(25) USAGE NATIONAL.
     03 Employees-BirthDate        PIC X(23).
     03 Employees-HireDate         PIC X(23).
     03 Employees-Address          PIC N(60) USAGE NATIONAL.
     03 Employees-City             PIC N(15) USAGE NATIONAL.
     03 Employees-Region           PIC N(15) USAGE NATIONAL.
     03 Employees-PostalCode       PIC N(10) USAGE NATIONAL.
     03 Employees-Country          PIC N(15) USAGE NATIONAL.
     03 Employees-HomePhone        PIC N(24) USAGE NATIONAL.
     03 Employees-Extension        PIC N(4) USAGE NATIONAL.
     03 Employees-Photo            PIC X(64000).
     03 Employees-Notes          PIC N(32000) USAGE NATIONAL.
     03 Employees-ReportsTo        PIC S9(09)  COMP-5.
     03 Employees-PhotoPath        PIC N(255) USAGE NATIONAL.

OpenESQL Assistant has also been enhanced to support unicode data. See the chapter OpenESQL Assistant for details.

Parent topic: Programming for OpenESQL
Related concepts
OpenESQL Assistant


Keywords

A number of keywords are recognized by OpenESQL and should not therefore be used within your program for other purposes. A full list of reserved keywords is given in the Keywords reference topic.

Parent topic: Programming for OpenESQL
Related reference
Keywords


ODBC

Use OpenESQL with the ODBC option to compile your native applications. This option:
  • Is invoked using the SQL(DBMAN=ODBC) compiler directive
  • Uses any ODBC drivers and data providers
  • Connects to one or more ODBC data sources
  • Compiles applications to communicate with the OpenESQL Native Runtime
  • Enables maximum interoperability between different database systems
  • Provides comprehensive support for pessimistic (locking) concurrency control
  • Does not support disconnected or offline DataSets
  • Demonstration Applications
    A list of available demonstration applications provided to illustrate programming techniques and runtime behavior for native applications using ODBC, along with a description of each of these applications.
  • ODBC Drivers and Data Source Names
    Install ODBC drivers and create DSNs.
  • Using OpenESQL with ODBC
    Programming and compiling OpenESQL native SQL applications with ODBC.
  • Using OpenESQL with Web and Application Servers
    Using OpenESQL in environments controlled by Web and Application Servers, such as IIS, MTS, COM+, CICS and Tuxedo.
Parent topic: OpenESQL
Related concepts
Programming for OpenESQL
Related reference
DBMAN


Demonstration Applications

A number of ODBC demonstration applications are supplied in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Net Express IDE\ODBCESQL directory by default.

Before you can use any of the demonstration applications, you need to have installed at least one ODBC driver, and created DSNs to use with the demonstrations.

Some of the demonstration applications expect that a table called EMP exists on the database to which you are connecting.

The OpenESQL demonstration applications all produce a console log displaying their progress and, possibly, query results. They all terminate on receipt of an error, after displaying an error message.

The following applications are provided:

  • Behavior Demo

    Connects to a data source name LocalServer using the Microsoft SQL Server ODBC driver. To do this, see the Help topic To set up an ODBC data source name.

    The program creates and populates a table used by behavior.cbl and behavsub.cbl. After the table is created, we show how the BEHAVIOR directive makes the same ambiguous COBOL cursor declaration read only in behavior.cbl and updateable in behavsub.cbl.

    You can verify this by looking at the trace file OpenESQLTrace.processID.log, in the project directory. The log file is generated by the TRACELEVEL directive in behavior.cbl.

  • Catalog Demo

    Displays an SQL Data Sources dialog. Enter or select a name and click on OK. A Login dialog is displayed. Enter a login name of "admin", leave the password blank and click on OK. Performs three data dictionary queries and outputs the results.

  • Connect Demo

    Prompts for a data source, user name and password. Enter the data source name you created, a user name of "admin" and leave the password blank (just press return). Four tests which perform connects and disconnects using a variety of syntax options are run. The fifth test displays an SQL Data Sources dialog. Select the appropriate name from the Machine Data Source list and click on OK. A Login dialog is displayed. Enter a login name of "admin", leave the password blank and click on OK. The fifth test is run and the program terminates.

  • Select Demo

    Connects to the sample database and prompts for a customer code. Enter BLUEL (as the prompt suggests). Two fields from the customer record are displayed and the program prompts for another customer code. Just press the return key this time. The program prompts for a region. Enter CA (as the prompt suggests). The program displays a list of customers in that region and prompts for another region. This time, press the return key to terminate the program.

  • Static Demo and Dynamic Demo

    Both applications run the same sequence of tests, but using different SQL syntax options. They both start by prompting for a data source and user name. The test sequence is:

    1. connect
    2. drop test table
    3. create test table
    4. insert a row
    5. commit
    6. update the row
    7. read and verify
    8. rollback
    9. read and verify
    10. drop test table
    11. disconnect
    12. create test table

    Step two may output an error message - this is expected and the programs will continue. The final stage should produce an error message, and again this is not treated as a genuine error (though the absence of an ODBC error is treated as a test failure).

  • Whenever Demo

    Attempts to connect and displays an error message. Displays an SQL Data Sources dialog. Select the DSN name you created and click on OK. A Login dialog is displayed. Enter a login name of "admin", leave the password blank and click on OK. Tests error handling and outputs two error messages.

Parent topic: ODBC


ODBC Drivers and Data Source Names

To use ODBC with OpenESQL, you must have the following in place:
  • Install at least one ODBC driver of your choice.
    • When using the SQL Server driver installed automatically by most Windows operating systems, be sure that the driver corresponds to the release of SQL Server you are using.
    • When using HCOSS, you must use an ODBC driver for SQL Server 2008 or later.
  • Install and configure ODBC Driver Manager and the ODBC driver software. See your Driver Manager or Driver vendor documentation for details.
  • Create at least one data source name (DSN) that identifies a database to which you can connect. Do this using the ODBC Data Source Administrator, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > ODBC Connection Tools > ODBC Data Source Administrator.
Parent topic: ODBC


Using OpenESQL with ODBC

When using the ODBC option, follow the programming and compiling guidelines provided for OpenESQL in general. In addition, the following topics provide information specific to working with ODBC:

  • Managing Transactions
  • Positioned Update
  • XML Support
Parent topic: ODBC


Managing Transactions

With OpenESQL, you can use the COMMIT and ROLLBACK statements to exploit the transaction control facilities of ODBC. Although ODBC specifies transaction AUTOCOMMIT after each statement as the default mode of operation, OpenESQL turns this off for greater compatibility with other SQL systems. If you require this functionality, specify the TRANSACTION primitive directive of the BEHAVIOR SQL Compiler directive option.

Note: Not all ODBC drivers implement transaction processing and those that do not may make updates to the database permanent immediately. For more information see your database driver documentation.
Parent topic: Using OpenESQL with ODBC
Related reference
AUTOCOMMIT
BEHAVIOR
TRANSACTION
ROLLBACK
COMMIT


Positioned Update

ODBC supports positioned update, which updates the row most recently fetched by using a cursor. However, not all drivers provide support for positioned update.

Note: You cannot use host arrays with positioned update.

With some ODBC drivers, the select statement used by the cursor must contain a FOR UPDATE clause to enable positioned update. Most data sources require specific combinations of SCROLLOPTION and CONCURRENCY to be specified either by SET statements or in the DECLARE CURSOR statement. If this fails to work, the ODBC Cursor Library provides a restricted implementation of positioned update which can be enabled by compiling with the directive SQL(USECURLIB=YES) and using SCROLLOPTION STATIC and CONCURRENCY OPTCCVAL (or OPTIMISTIC). To avoid multiple rows being updated when using the ODBC Cursor Library, the cursor query should include the primary key column(s) for the table to be updated.

Example

$SET SQL(usecurlib=yes)
 WORKING-STORAGE SECTION.

 EXEC SQL INCLUDE SQLCA  END-EXEC

*> after an sql error this has the full message text
 01 MFSQLMESSAGETEXT  PIC X(250).
 01 IDX               PIC X(04)  COMP-5.

 EXEC SQL BEGIN DECLARE SECTION  END-EXEC
*> Put your host variables here if you need to port
*> to other COBOL compilers
 EXEC SQL INCLUDE Products END-EXEC

 EXEC SQL END DECLARE SECTION END-EXEC

 PROCEDURE DIVISION.

     EXEC SQL
         WHENEVER SQLERROR perform OpenESQL-Error
     END-EXEC

*> Demo for positioned updates using ACCESS datasource
     EXEC SQL
       CONNECT TO 'Inventory' USER 'admin'
     END-EXEC

*> Put your program logic/SQL statements here

     EXEC SQL
       DECLARE CSR679 CURSOR
         FOR SELECT
              A.ProductID
             ,A.ProductName
             ,A.UnitPrice
         FROM Products A
        WHERE ( A.ProductID <  3 )
     END-EXEC

     EXEC SQL SET SCROLLOPTION static  END-EXEC
     EXEC SQL SET CONCURRENCY optccval END-EXEC

     EXEC SQL OPEN CSR679 END-EXEC
     PERFORM UNTIL SQLSTATE >= "02000"
        EXEC SQL
        FETCH CSR679 INTO
            :ProductID
           ,:ProductName:ProductName-NULL
           ,:UnitPrice:UnitPrice-NULL
        END-EXEC
        *> Process data from FETCH
        IF SQLSTATE = "00000"
           *> increase price by 10%
            compute unitprice = unitprice * 1.10
            EXEC SQL
               UPDATE Products
                 SET UnitPrice = :UnitPrice:UnitPrice-NULL
               WHERE CURRENT OF CSR679
           END-EXEC
        END-IF
     END-PERFORM
     EXEC SQL CLOSE CSR679 END-EXEC

     EXEC SQL COMMIT END-EXEC

     EXEC SQL DISCONNECT CURRENT END-EXEC
     EXIT PROGRAM.
     STOP RUN.

*> Default sql error routine - modify to stop program if
*> needed
  OpenESQL-Error Section.

      display "SQL Error = " sqlstate " " sqlcode
      display MFSQLMESSAGETEXT
*> stop run
      exit.
Parent topic: Using OpenESQL with ODBC


XML Support

If you have an XML ODBC driver, you can set it up to access XML files just like any ODBC data source. You can then build SQL statements using the OpenESQL Assistant from the XML data source. Use the PERSIST embedded SQL statement to convert information to XML.

Parent topic: Using OpenESQL with ODBC
Related reference
PERSIST


Using OpenESQL with Web and Application Servers

This section describes what you must do to use OpenESQL in environments controlled by Web and Application Servers, such as IIS, MTS, COM+, CICS and Tuxedo.

All servers differ, but the principle described here is common to them all.

  • Thread Safety
  • Connection Management
  • Transactions
  • User Accounts, Schemas and Authentication
  • Transaction Wrapper Sample
Parent topic: ODBC


Thread Safety

OpenESQL is thread safe. Normally all threads in an application share SQL resources such as connections and cursors. When running with an application server, however, threads will be scheduled to handle requests from different users. Therefore, you must use the directive:

SQL(THREAD=ISOLATE)

to ensure that each thread's resources are isolated from each other.

Note: OpenESQL has an overhead of 72K for each thread created, and this memory is not released until the application terminates.
Parent topic: Using OpenESQL with Web and Application Servers


Connection Management

In most environments, the application server will manage a pool of connections, which means that actual connect and disconnect requests to the database will be rare. When an application runs, it will reuse an existing connection. In most cases, connection pooling will be managed by the ODBC Driver Manager and will be transparent to the application. In other cases, the application server itself will manage the connection pool, and the application must use a "set connection" statement before it does anything else.

Where the application uses OpenESQL connect and disconnect statements, and it is not clear that the application server itself enables ODBC connection pooling, it might be worth experimenting with the SQL(CONNECTIONPOOL=...) directive. However, you are unlikely to need to do this.

Parent topic: Using OpenESQL with Web and Application Servers


Transactions

In many cases, the application server provides transaction management. This is determined when your component is placed under the control of the application server.

If the application server is not providing transaction management, it must use OpenESQL COMMIT and ROLLBACK statements to manage transactions.

If, however, the application server is providing transaction management, the following applies:

  • If connection management is not provided by the application server (that is, your application uses CONNECT and DISCONNECT statements), you can use one of the following to handle transactions:
    • Set the TRANSACTION primitive directive of the BEHAVIOR SQL compiler directive option (recommended).
    • Set the AUTOCOMMIT SQL compiler directive option to enable your application to handle transactions using COMMIT and ROLLBACK statements.
    • Use the application server to provide API calls or return codes for you to signal success or failure.

If you are using MTS or COM+, the default transaction isolation level, when the application server is managing transactions, can be serialized. This might cause excessive locking, and reduce concurrency. Your application must be prepared to deal with its transaction being aborted when the application server attempts to resolve a deadlock. To ease these problems, you can use the following statement:

exec sql set transaction isolation read committed end-exec

to set a less stringent isolation level. In this case, the statement must be the first statement to be executed after the CONNECT statement. Note that when SQL(AUTOCOMMIT) is not used, a commit or rollback is required immediately prior to executing a SET TRANSACTION ISOLATION statement.

Parent topic: Using OpenESQL with Web and Application Servers


User Accounts, Schemas and Authentication

When running in an application server environment, the user account in which your application executes might be different from the account used for development. ODBC data sources set up as user data sources might, therefore, not be available. You will probably find it more convenient to set up data sources as system data sources on deployment systems. When a file-based data source is used, the database files must be accessible by the account used by the application server. When accessing the database, particularly if integrated security is used (that is, when the DBMS uses the same account number as the operating system), the default schema might be different from that used during development. This might well be what is intended, if different schema names are used for development and deployment. Alternatively, it might mean that tables are no longer visible to the application. It must either use explicit owner qualification, or execute a database-specific statement, which will select the correct schema to be the default.

Parent topic: Using OpenESQL with Web and Application Servers


Transaction Wrapper Sample

The following is an example of an transaction wrapper generated by the OCX Wizard modified to include the OpenESQL logic to handle the following scenarios using an MS SQL Server data source:

  • standalone transaction with no MTS/COM+ involved
  • component managed by MTS/COM+ but without MTS/COM+ handling transactions
  • component and transactions handled by MTS/COM+
$set ooctrl(+p) sql(thread=isolate autocommit)
*>-----------------------------------------------------------
*> Class description
*>-----------------------------------------------------------
 class-id. cblsqlwrapper
           inherits from olebase.
 object section.
 class-control.
     cblsqlwrapper is class "cblsqlwrapper"
*> OCWIZARD - start list of classes
     objectcontext is class "objectcontext"
     olebase is class "olebase"
     oleSafeArray is class "olesafea"
     oleVariant is class "olevar"
*> OCWIZARD - end list of classes
*>---USER-CODE. Add any additional class names below.
*>-----------------------------------------------------------
 working-storage section. *> Definition of global data
*>-----------------------------------------------------------

*>-----------------------------------------------------------
 class-object.   *> Definition of class data and methods
*>-----------------------------------------------------------
 object-storage section.

*> OCWIZARD - start standard class methods
*>-----------------------------------------------------------
*> Return details about the class.
*> If you have a type library, theClassId and theInterfaceId
*> here MUST match.
*> theProgId must match the registry entry for this class
*>   (a zero length string implies using the class file name)
*> theClassId must match the CLSID stored in the registry.
*> theVersion is currently ignored (default 1 used).
*>-----------------------------------------------------------
 method-id. queryClassInfo.
 linkage section.
 01 theProgId             pic x(256).
 01 theClassId            pic x(39).
 01 theInterfceId         pic x(39).
 01 theVersion            pic x(4) comp-5.
 01 theDescription        pic x(256).
 01 theThreadModel        pic x(20).
 procedure division using by reference theProgId
                          by reference theClassId
                          by reference theInterfceId
                          by reference theVersion
                          by reference theDescription
                          by reference theThreadModel.
     move z"{3EADD92C-06C5-46F2-A2E0-7EB0794C14DF}"
                                            to theClassId
     move z"{5BF3F966-9932-4835-BFF6-2582CA2592AD}"
                                            to theInterfceId
     move z"Description for class cblsqlwrapper"
                                            to theDescription
     move z"Apartment" to theThreadModel
     exit method.
 end method queryClassInfo.
 .

*>-----------------------------------------------------------
*> Return details about the type library - delete if unused.
*> theLocale is currently ignored (default 0 used).
*> theLibraryName is a null terminated string used for auto
*> registration, and supports the following values:
*>    <no string> - Library is embedded in this binary
*>    <number>    - As above, with this resource number
*>    <Path>      - Library is at this (full path)
*>                        location
*>-----------------------------------------------------------
 method-id. queryLibraryInfo.
 linkage section.
 01 theLibraryName        pic x(512).
 01 theMajorVersion       pic x(4) comp-5.
 01 theMinorVersion       pic x(4) comp-5.
 01 theLibraryId          pic x(39).
 01 theLocale             pic x(4) comp-5.
 procedure division using by reference theLibraryName
                          by reference theMajorVersion
                          by reference theMinorVersion
                          by reference theLibraryId
                          by reference theLocale.
     move 1 to theMajorVersion
     move 0 to theMinorVersion
     move z"{24207F46-7136-4285-A660-4594F5EE7B87}"
                                            to theLibraryId
     exit method.
 end method queryLibraryInfo.

*>-----------------------------------------------------------

*> OCWIZARD - end standard class methods

 end class-object.

*>-----------------------------------------------------------
 object.         *> Definition of instance data and methods
*>-----------------------------------------------------------
 object-storage section.

*> OCWIZARD - start standard instance methods
*> OCWIZARD - end standard instance methods

*>-----------------------------------------------------------
 method-id. "RetrieveString".
 working-storage section.

 01 mfsqlmessagetext pic x(400).
 01 ESQLAction       pic x(100).

 COPY DFHEIBLK.

 COPY SQLCA.
*>...your transaction program name
 01 transactionPgm           PIC X(7) VALUE 'mytran'.

 local-storage Section.
 01 theContext              object reference.
 01 transactionStatusFlag   pic 9.
   88 transactionPassed     value 1.
   88 transactionFailed     value 0.
*>---USER-CODE. Add any local storage items needed below.

 01 ReturnValue             pic x(4) comp-5.
   88 IsNotInTransaction    value 0.

 01 transactionControlFlag  pic 9.
   88 TxnControlledByMTS    value 0.
   88 TxnNotControlledByMTS value 1.

 linkage Section.

*>...Info passed to transaction
 01 transaction-Info.
    05 transaction-Info-RC   pic 9.
    05 transaction-Info-data pic x(100).

*>...Info returned from transaction via
 01 transaction-Info-Returned pic x(100).

 procedure division using by reference transaction-Info
                    returning transaction-Info-Returned.

*>...initialisation code
     perform A-Initialise
     perform B-ConnectToDB
     if TxnNotControlledByMTS
         perform C-SetAutoCommitOff
     end-if

*>...set isolation level to override SQLServer default,
*>...serialize
     perform D-ResetDefaultIsolationLevel

*>...set cursor type to overrde the OpenESQL default,
*>...dynamic+lock
     perform E-ResetDefaultCursorType

*>...call the transaction
     perform F-CallTransaction

*>...finalisation code - issue Commit/Rollback if not
*>...controlled by MTS/COM+
     if TxnNotControlledByMTS
         if transactionPassed
             perform X-Commit
         else
             perform X-Rollback
         end-if
     end-if

     perform Y-Disconnect

*>...Transaction Server - use setAbort if the method fails:
     if theContext not = null
         if transactionPassed
             invoke theContext "setComplete"
         else
             invoke theContext "setAbort"
         end-if
         invoke theContext "finalize" returning theContext
     end-if

     exit method
     .

 A-Initialise.
*>...Transaction Server - get the context we are running in
     invoke objectcontext "GetObjectContext"
            returning theContext

*>...check if this component is enlisted in an MTS transation
     if theContext = null
         set TxnNotControlledByMTS to true
     else
         invoke theContext "IsInTransaction"
                returning ReturnValue
         if IsNotInTransaction
             set TxnNotControlledByMTS to true
         else
            set TxnControlledByMTS    to true
          end-if
     end-if

*>...initialise program variables
     set transactionPassed to true

     INITIALIZE DFHEIBLK
     .

 B-ConnectToDB.
*>...connect to data source

     EXEC SQL
         CONNECT TO 'SQLServer 2000' USER 'SA'
     END-EXEC

     if sqlcode  zero
         move z"connection failed " to ESQLAction
         perform Z-ReportSQLErrorAndExit
     end-if
     .

 C-SetAutoCommitOff.
     EXEC SQL
         SET AUTOCOMMIT OFF
     END-EXEC
     if sqlcode  zero
         move z"Set Autocommit Off failed " to ESQLAction
         perform Z-ReportSQLErrorAndExit
     end-if

     perform X-Commit
    .

 D-ResetDefaultIsolationLevel.
*> the default isolation level for SQLServer is "Serialized",
*> so here we reset it to something more appropriate

     EXEC SQL
         SET TRANSACTION ISOLATION READ COMMITTED
     END-EXEC
     if sqlcode  zero
         move z"set transaction isoation failed "
                                            to ESQLAction
         perform Z-ReportSQLErrorAndExit
     end-if
     .

 E-ResetDefaultCursorType.
*> the default cursor type for OpenESQL is dynamic + lock
*> the most efficient is a "client" or "firehose" cursor -
*> this is a cursor declared as forward + read only - doing
*> this here will set it as a default from now on.  If
*> Forward causes a problem, change the concurrency to fast
*> forward (but note that it will then no longer be a client
*> cursor)

     EXEC SQL
         SET CONCURRENCY READ ONLY
     END-EXEC
     if sqlcode  zero
         move z"Set Concurrency Read Only" to ESQLAction
         perform Z-ReportSQLErrorAndExit
     end-if

     EXEC SQL
         SET SCROLLOPTION FORWARD
     END-EXEC
     if sqlcode  zero
         move z"Set Concurrancy Read Only" to ESQLAction
         perform Z-ReportSQLErrorAndExit
     end-if
     .

 F-CallTransaction.
*>...call the program to process the transaction
     move 0               to  transaction-Info-RC
     call tranactionPgm using dfheiblk transaction-Info

*>...check if processing was okay
     if transaction-Info-RC = 0
        set transactionPassed to true
     else
        set transactionFailed to true
     end-if
     .

 X-Commit.
     EXEC SQL
         COMMIT
     END-EXEC
     if sqlcode  zero
         move z"Commit failed " to ESQLAction
         perform Z-ReportSQLErrorAndExit
     end-if
     .

 X-Rollback.
     EXEC SQL
         ROLLBACK
     END-EXEC
     if sqlcode  zero
         move z"Rollback failed " to ESQLAction
         perform Z-ReportSQLErrorAndExit
     end-if
     .

 Y-Disconnect.
     EXEC SQL
         DISCONNECT CURRENT
     END-EXEC
     if sqlcode  zero
         move z"Disconnect failed " to ESQLAction
         perform Z-ReportSQLErrorAndExit
     end-if
     .

 Z-ReportSQLErrorAndExit.
     move spaces to transaction-Info-Returned
     string ESQLAction delimited by x"00"
            "SQLSTATE = "
            SQLSTATE
            "  "
            mfsqlmessagetext
            into transaction-Info-Returned
     end-string

     exit method
     .

 exit method.
 end method "RetrieveString".
*>-----------------------------------------------------------

 end object.
 end class cblsqlwrapper.
Parent topic: Using OpenESQL with Web and Application Servers


ADO.NET

Use OpenESQL with the ADO option to compile your managed applications. This option:
  • Is invoked using the SQL(DBMAN=ADO) compiler directive
  • Uses ADO.NET data providers
  • Connects to one ADO.NET data source
  • Compiles applications to communicate with the OpenESQL Managed Runtime
  • Enables EXEC SQL statements to communicate with the ADO.NET data provider and data source name specified
  • Supports the use of EXEC ADO statements to create and manipulate ADO.NET objects
  • Maximizes scalability of data handling components in distributed systems
  • Is strongly biased in favour of optimistic (non-locking) concurrency control
  • Fully supports disconnected and offline DataSets
  • Supports dynamic SQL using PREPARE, EXECUTE and EXECUTE IMMEDIATE statements and cursors that use prepared statements, but only with host variable lists in the EXECUTE and OPEN statements
  • Demonstration Applications
    A list of available demonstration applications provided to illustrate programming techniques and runtime behavior for managed applications using ADO.NET, along with a description of each of these applications.
  • ADO.NET Data Providers and Data Source Names
    Instructions for obtaining ADO.NET data providers and creating a data source name.
  • ADO.NET Connection Editor
    the ADO.NET Connection Editor enables you to catalog connections used used by the OpenESQL Managed Runtime.
  • Connection Information Migration Tool
    An overview of the use and purpose of the Connection Information Migration tool.
  • Using OpenESQL with ADO.NET
    Programming and compiling OpenESQL managed SQL applications with ADO.NET.
Parent topic: OpenESQL
Related concepts
Programming for OpenESQL
Related reference
DBMAN


Demonstration Applications

A number of ADO.NET demonstration applications are supplied in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Net Express IDE\ado.net.

Each sample application comes with a Readme file to explain how to use the application, and a makefile.

Before you can use any of the demonstration applications, you need to set up the data sources used by the demonstrations. You can do this with the ADO.NET Connection Editor.

The OpenESQL demonstration applications all produce a console log displaying their progress and, possibly, query results. They all terminate on receipt of an error, after displaying an error message.

  • Connected Demo

    Connected Demo uses the SQL Server Northwind database. You must set up a connection to the Northwind database to run the Connected Demo project.

    The ConnectedDemo.cbl program fills a DataSet from a data source, modifies the DataSet and then synchronizes the changes in the DataSet with the data source. The modified contents of the DataSet are displayed in the Output Window.

    Connected Demo demonstrates three methods for refreshing server generated primary keys in a DataSet after rows are added; a statement batch, a separate TO REFRESH statement and a stored procedure with output parameters. Connected Demo also shows you how to synchronize changes in the DataSet with the data source using either the main DataSet or a separate DataSet which contains only changed rows. You could use the latter method to minimize network traffic in a distributed application.

  • Cursor Demo

    You must set up a connection to the SQL Server Northwind database to run the Cursor Demo project. This project demonstrates how to intermix OpenESQL with direct calls to ADO.NET.

    The NoFetch.cbl program uses EXEC SQL to open a cursor and then EXEC ADO to fetch the results. The TestCursor.cbl program performs an EXEC SQL FETCH. The CursorDemo.cbl program populates a DataTable.

  • Disconnected Demo

    The DisconnectedDemo.cbl program manipulates offline data in a DataSet. The results of the data manipulation are displayed in the Output Window.

    Disconnected Demo demonstrates how to declare a DataSet from an XSD file generated by another project and how to load a DataSet from an XML file generated by another application.

  • Lob Demo

    This project shows how ADO.NET can be used in mixed language projects to insert and select large objects (LOBs). LobDemo shows OpenESQL working with LOB columns in a SQL Server table.

    LOB columns are columns that can be up to 2GB in size. In this demo, the LOB columns are image columns and the OpenESQL object reference host variable.

    The LobDemo.cbl program includes instructions for changing Lob Demo to use DB2 LUW and BLOB columns.

  • Order Status Demo

    The Order Status Demo project shows how ADO.NET can be used in mixed language projects. Order Status Demo uses COBOL and C#.

    The netorderstatus.cbl program generates an XSD file from a DataSet declaration. The XSD file is then imported into the C# form. This simplifies building the user interface by enabling data binding with a strongly typed DataSet generated from the XSD file.

    Order Status Demo also demonstrates the use of ADO.NET in legacy reuse not directly related to DBMS access. The data source used in this project is an existing COBOL subroutine.

    The techniques used in this demo are applicable to CICS ECI transactions.

Parent topic: ADO.NET
Related concepts
ADO.NET Connection Editor


ADO.NET Data Providers and Data Source Names

OpenESQL supports ADO.NET data providers. To obtain ADO.NET support, you must:

  1. Install ADO.NET data providers.
  2. Set up an ADO.NET Data Source Name (DSN) via the ADO.NET Connection Editor.
Parent topic: ADO.NET
Related concepts
ADO.NET Connection Editor
Using Embedded EXEC ADO Statements
OpenESQL Assistant


ADO.NET Connection Editor

The ADO.NET Connection Editor enables you to edit the repository that stores the connection information used by the OpenESQL managed run-time when a COBOL program connects to an ADO.NET data provider. The repository is a standard .NET Framework repository, machine.config. This enables mixed language applications to share connection strings

The OpenESQL run time supports any ADO.NET provider that supports the DbProviderFactory API.

Note:
  • We recommend that you use ADO.NET data providers when possible; however, if necessary you can use the OpenESQL Assistant to automatically catalog ODBC data providers.
  • When you run the ADO.NET Connection Editor under operating systems that have User Access Control enabled, such as Windows 7, you must run it as an administrator if you are adding, deleting, or updating connection settings to the system repository. However, when accessing User settings, you do not need this elevated authority.
  • Cataloging an ADO.NET Connection
  • Cataloging an ODBC Connection
  • Copying Connection Settings
  • Example Connection Settings
Parent topic: ADO.NET
Related concepts
ADO.NET Data Providers and Data Source Names
Demonstration Applications
Related tasks
To start the ADO.NET Connection Editor
To catalog an ADO.NET data provider
To test an ADO.NET connection
To uncatalog an ADO.NET data provider
To export connection settings from the ADO.NET Connection Editor
To import connections into the ADO.NET Connection Editor
To catalog an ODBC data provider
To set OpenESQL Assistant options
To start the OpenESQL Assistant


Cataloging an ADO.NET Connection

OpenESQL Assistant automatically catalogs any ODBC connection as an ODBC ADO.NET data provider if you have set your OpenESQL options to enable automatic cataloging. To use other ADO.NET data providers, you must catalog them manually using the ADO.NET Connection Editor. All cataloged data providers are listed on the Editor.

When you catalog a connection, the ADO.NET Connection Editor supplies default option settings for the type of connection you catalog. You should edit the values to reflect the correct settings for your data source. Micro Focus provides templates for certain ADO.NET data providers as examples of what type of connection settings are required and what their values should be. See the section Example Connection Settings for specific examples.

You also have the option of encrypting your connection settings in the repository. You might want to do this if your connection settings include sensitive information such as a user ID and password used to access your application.

Parent topic: ADO.NET Connection Editor
Related tasks
To catalog an ADO.NET data provider
To uncatalog an ADO.NET data provider


Cataloging an ODBC Connection

ODBC data providers cannot be added directly to the ADO.NET Connection Editor because generic ODBC data providers add no editable options. While we do support the importation of ODBC data providers, we recommend that you use an ADO.NET data provider whenever possible.

We provide two methods for catalog an ODBC connection:
  • Import the ODBC connection information by connecting to the ODBC data source in OpenESQL Assistant
  • Export the ODBC connection settings from a different machine, and then import them into the ADO.NET Connection Editor
Parent topic: ADO.NET Connection Editor
Related tasks
To catalog an ODBC data provider
To import connections into the ADO.NET Connection Editor
To export connection settings from the ADO.NET Connection Editor
To set OpenESQL Assistant options
To start the OpenESQL Assistant


Copying Connection Settings

You can copy your connection settings from one machine to another using the ADO Connection Editor's Export and Import functions. You do this by exporting the connection settings on one machine and importing them to another.

You can also import connection settings at a using the MFImportConn command. To do this, start a 32-bit or 64-bit version of the Net Express command prompt, as appropriate, and then enter:

MFImportConn path:\exportedXMLfile

Where:

path
is the full path to the XML file containing the exported connection settings
exportedXMLfile
is the filename of the XML file containing the exported connection settings
Parent topic: ADO.NET Connection Editor
Related reference
MFImportConn command


Example Connection Settings

The following topics provide examples of appropriate connection settings for a SqlClient and a DB2 ADO.NET data provider.

  • SqlClient Data Provider
  • DB2 ADO.NET
Parent topic: ADO.NET Connection Editor


SqlClient Data Provider

For a SqlClient data provider, you must provide the following connection information:

  • Data Source - The name of the SQL Server you want to use. If the server is local, you can usually specify localhost or (local).
  • Initial Catalog - The name of the database you want to access.
  • Integrated Security - Set this to True to use Windows security. It is set to False by default. When set to False, you must either provide values for the User ID and Password connection settings, or provide them in your program as part of the EXEC SQL CONNECT statement.
  • MultipleActiveResultSets - When using a SQL Server 2005 or later, set this to True to allow multiple active result sets.
Parent topic: Example Connection Settings


DB2 ADO.NET

For a DB2 ADO.NET data provider, you must provide the following connection information:

  • Database – The name of the database to access
  • Server – The name of the database server. If the server is remote, you might also need to specify the TCP port number used by DB2, typically 50000. For example, servername:50000.
  • User ID and Password - You can specify these as connection settings or code them into your program using the EXEC SQL CONNECT statement.
Parent topic: Example Connection Settings


Connection Information Migration Tool

The Micro Focus Connection Information Migration Tool is a tool for migrating connections cataloged in Visual Studio 2003 to Visual Studio 2008. The Connection Information Migration Tool lists all Visual Studio 2003 Connection Names it finds cataloged on your machine along with the Connection Names you have already cataloged for Visual Studio 2008.

Parent topic: ADO.NET
Related tasks
To migrate a connection


Using OpenESQL with ADO.NET

When using the ADO option, follow the programming and compiling guidelines provided for OpenESQL in general. In addition, the following topics provide information specific to working with ADO.NET:

  • Using Embedded EXEC ADO Statements
  • .NET Host Variables in Managed Code
  • Disconnected and Offline DataSets
  • Compiling Native Applications as Managed Code
  • Stored Procedures with ADO.NET
  • XML Support
Parent topic: ADO.NET


Using Embedded EXEC ADO Statements

To enhance ADO.NET support, a new family of EXEC ADO statements has been added to OpenESQL. These statements operate with DataSets rather than databases but their syntax is familiar to anyone with a knowledge of SQL and embedded SQL. Other EXEC ADO statements have been added which allow direct access to the underlying ADO.NET objects used by the OpenESQL Managed Runtime. With these statements it is possible for OpenESQL to share connections and transactions with other software components or for COBOL programmers to use low level properties and methods of objects that have been created by OpenESQL.

You embed EXEC ADO statements into a COBOL program in the same way as EXEC SQL statements. Embedded EXEC ADO statements enable you to:

  • Program ADO.NET calls without writing COBOL calls to the native ADO.NET API
  • Define, create and manipulate DataSets and associated objects in the ADO.NET disconnected model
  • Manipulate the underlying data source in the ADO.NET connected model, retrieving data as well as updating it
  • Declare and manipulate an ADO.NET DataRows cursor in the same way as a SQL cursor
  • Save and load ADO.NET DataSets (schema and data) to and from XML files
  • Share ADO.NET objects between COBOL programs and other .NET applications
  • Share calls and information between EXEC ADO and EXEC SQL statements in the same program
  • Disconnected Model Statements
  • Connected Model Statements
  • ADO.NET Cursor Statements
  • Sharing ADO.NET Objects Statements
Parent topic: Using OpenESQL with ADO.NET
Related concepts
ADO.NET Data Providers and Data Source Names
XML Support


ADO.NET Cursor Statements

ADO.NET cursor statements enable you to define, create and manipulate an ADO.NET DataRows cursor. These statements are similar to SQL cursor statements. However, instead of a selection criteria based on a table in a data source, an ADO.NET DataRows cursor is based on a DataTable in a DataSet.

The following ADO.NET cursor statements are available to you:

  • DECLARE DATAROWS – defines a DataRows cursor
  • OPEN – creates and opens a DataRows cursor
  • FETCH – fetches the DataRows from the DataRows cursor
  • DELETE (POSITIONED) – deletes the current DataRow from the DataRows cursor
  • UPDATE (POSITIONED) – updates the current DataRow in the DataRows cursor
  • CLOSE – closes a DataRows cursor
Parent topic: Using Embedded EXEC ADO Statements


Sharing ADO.NET Objects Statements

Sharing ADO.NET objects statements enable you to share ADO.NET objects (Connections, DataSets and DataReaders) between COBOL programs and other .NET applications. The GET statements retrieve objects OpenESQL has generated for EXEC SQL commands where dbman=ado. The BIND statements allow COBOL to access ADO.NET objects created by other .NET applications and the UNBIND statements disassociate COBOL from those objects.

The following sharing ADO.NET objects statements are available to you:

  • GET CHANGES - creates a DataSet that only contains changed information
  • GET CONNECTION – gets the current OpenESQL connection object
  • GET CURSOR – gets the DataReader or DataSet associated with an EXEC SQL cursor
  • GET RUNTIME – gets the OpenESQL MFADORTS run-time object
  • BIND CONNECTION – allows a named EXEC SQL connection to use an existing connection object
  • BIND – allows a named EXEC ADO DataSet to use an existing DataSet object
  • REBIND CONNECTION – informs a previously bound EXEC SQL connection object that a new transaction object is being used
  • UNBIND – releases an OpenESQL reference to a bound DataSet object
  • UNBIND CONNECTION – releases an OpenESQL reference to a bound connection object
Parent topic: Using Embedded EXEC ADO Statements


.NET Host Variables in Managed Code

For your managed applications, OpenESQL provides the option of using traditional host variable declarations, and an option to use .NET data types as your host variable declarations. Use of .NET data types is made possible by the OpenESQL Managed Runtime, specified by setting the DBMAN directive option to ADO.

When your managed application contains traditional host variable declarations using PIC clauses, this requires the OpenESQL Managed Runtime to read each PIC clause and convert it to the equivalent .NET type. However, by declaring your host variables using the .NET data types in place of the PIC clause, you get these advantages:
  • Improved performance - it is not necessary for the OpenESQL Managed Runtime to translate PIC clauses to .NET types, thereby greatly enhancing performance.
  • No size restrictions - .NET variables in managed applications are not restricted in size, whereas native COBOL applications have size restrictions on host variables, especially for applications that involve LOB data.
  • Improved application portability - the managed runtime simplifies the process of porting existing native EXEC SQL applications to .NET.
When coding your applications to use .NET host variables, keep in mind:
  • All .NET host variables must be defined at the 01 level or compiler errors result.
  • Syntax for common .NET data types can be defined with the short name. For example, System.String can be defined simply as:
    01 myName string.
  • Syntax for other .NET variables typically include a TYPE clause. For example:
    01 myDate type System.DateTime.
  • If a specific .NET type doesn't exist for an SQL data type provided by a vendor, you can use OBJECT as the host variable type. For example:
    01 myData object.
Note:
  • Only the OpenESQL preprocessor supports the use of .NET host variables. Currently, no DBMS vendors provide direct support for EXEC SQL syntax in .NET applications.
  • For complete information on declaring .NET host variables for the OpenESQL Managed Runtime, see the reference topics under SQL Data Types.
  • The OpenESQL Assistant provides an easy method of generating .NET host variables for a table via the DCLGEN option in the tool. See OpenESQL Assistant for more information on how to generate copybooks in this format.

Example: Defining .NET host variables

  *> -------------------------------------------
       *> COBOL HOST VARIABLES FOR TABLE EMP
       *> -------------------------------------------
       01  EMP-EMPNO                          STRING.
       01  EMP-FIRSTNME                       STRING.
       01  EMP-MIDINIT                        STRING.
       01  EMP-LASTNAME                       STRING.
       01  EMP-WORKDEPT                       STRING.
       01  EMP-PHONENO                        STRING.
       01  EMP-HIREDATE                       type System.DateTime.
       01  EMP-JOB                            STRING.
       01  EMP-EDLEVEL                        BINARY-SHORT.
       01  EMP-SEX                            STRING.
       01  EMP-BIRTHDATE                      type System.DateTime.
       01  EMP-SALARY                         DECIMAL.
       01  EMP-BONUS                          DECIMAL.
       01  EMP-COMM                           DECIMAL.

EXEC SQL
 SELECT
        A.FIRSTNME
       ,A.LASTNAME
       ,A.HIREDATE
       ,A.SALARY
       ,A.EMPNO
INTO
        :EMP-FIRSTNME
       ,:EMP-LASTNAME
       ,:EMP-HIREDATE:EMP-HIREDATE-NULL
       ,:EMP-SALARY:EMP-SALARY-NULL
       ,:EMP-EMPNO
   FROM HCOSQL.EMP A
  WHERE (A.EMPNO = :EMP-EMPNO)
END-EXEC
Parent topic: Using OpenESQL with ADO.NET
Related concepts
Host Variables
Related reference
SQL Data Types


Disconnected and Offline DataSets

ADO.NET fully supports the use of disconnected and offline DataSets.

A DataSet is like a miniature database, complete with tables, columns, keys and constraints, which can be filled from a database. When a DataSet is modified, both current and original values of data are kept in the DataSet. This allows the DataSet to be synchronized with the database from which it was filled after being passed between servers and components in a distributed system. Used in this way, a DataSet can be regarded as a lightweight replication tool. For example, data for a customer order is extracted from a database and processed remotely from the database server. Later, the database is synchronized with the changes made to the DataSet. Processing could take place on either a Web server or a laptop. Because the DataSet has no connection to the database while it is being processed, optimistic concurrency must be used when the database is updated.

DataSet contents can also be loaded from and saved to data sources other than relational databases. For example, XML files or software components, where the mechanism used to store data does not concern the application that processes the contents of the DataSet, can be used. DataSets also have excellent support for data binding to user interface controls in WinForms and WebForms. This means that DataSets are useful for communicating data in mixed language applications.

Parent topic: Using OpenESQL with ADO.NET


Compiling Native Applications as Managed Code

Many existing native applications can be compiled as managed applications simply by changing the compiler directive option from ODBC to ADO. For these applications, performance characteristics and storage requirements might differ.

For example, any cursor used for scrolling fetches or positioned updates has its result set read completely and buffered on the client system in a DataSet when it is opened. ADO.NET provides no native support for positioned updates and so OpenESQL converts them to searched updates using original column values and optimistic concurrency. For this to provide the same degree of integrity as ODBC, an application must use repeatable read transaction isolation and the result set must contain columns that will uniquely identify the row being updated.

It is also possible for a single application to include some programs compiled with each, but each of the programs included in the application must use one or the other, and each must specify a database connection that uses an appropriate DSN. You cannot share database connections and transactions between ODBC and ADO.NET.

Parent topic: Using OpenESQL with ADO.NET


Stored Procedures with ADO.NET

You can call stored procedures with ADO.NET. However, when calling stored procedures, be aware that the following features are not currently supported:
  • Named parameters
  • Oracle stored procedures returning a result set using Microsoft or Oracle managed providers (the ODBC provider can return Oracle result sets without problems)
  • Stored procedures called by dynamic SQL
Parent topic: Using OpenESQL with ADO.NET


XML Support

XML support is implemented in a different way for ADO.NET data providers. See the section Using Embedded EXEC ADO Statements for more information.

Parent topic: Using OpenESQL with ADO.NET
Related concepts
Using Embedded EXEC ADO Statements


COBOL Program Migration Support

You can use OpenESQL as an effective migration tool, particularly when you migrate from the mainframe. OpenESQL provides the BEHAVIOR directive to define the COBOL environment and make migration transparent, yet efficient:

  • BEHAVIOR can be set to any of the following:
    ANSI | Enables OpenESQL to work like the ANSI standard, and enhances the access speed
    MAINFRAME | Enables OpenESQL to work as it does on the mainframe, and enhances the access speed
    UNOPTIMIZED | Provides backward compatibility with earlier Micro Focus products
    CICS Sets all of the following:
    • Enables OpenESQL to work as it does on the mainframe
    • Enhances the access speed
    • Automatically sets the TRANSACTION primitive directive to GLOBAL
    JCL Sets all of the following:
    • Enables OpenESQL to work as it does on the mainframe
    • Enhances the access speed
    • Checks for the following statements that are not compatible with JCL applications:
      • CONNECT
      • DISCONNECT
      • SET CONNECT
    • Reports an error for each incompatible statement found
    primitivedirective | Optional directives that enable the fine-tuning of BEHAVIOR
  • With either the MAINFRAME or ANSI values, OpenESQL determines:
    • The optimal DBMS cursor for ambiguous COBOL cursors, i.e., cursors not defined as explicitly read only or updateable
    • The optimal DBMS cursor selection for both read-only and updateable COBOL cursors
    • The appropriate isolation level and lock concurrency settings

    You can set a default behavior of ANSI, MAINFRAME, or UNOPTIMIZED using the OpenESQL Configuration Utility. However, when the BEHAVIOR directive is specified in program code, project settings, or in a compiler directive file, the specified setting overrides the default setting.

  • Capability to override the BEHAVIOR characteristics cited above without changing the program's associated EXEC SQL statement.

For more information, see the BEHAVIOR topic and the demo application behavior listed in the topic Demonstration Applications.

Parent topic: OpenESQL
Related concepts
Demonstration Applications
OpenESQL Configuration Utility
Related reference
BEHAVIOR
Related information
To set a default for SQL(BEHAVIOR)
OpenESQL Configuration Utility


Oracle OCI Support

OpenESQL provides an alternative for developers using ORACLE data sources, in the form of the ORACLE OCI interface. To use this interface, you must compile your applications with the following directive:

sql(targetdb=ORACLEOCI)

When connecting to the Oracle server, use an Oracle Net8 service name in place of an ODBC data source name in the CONNECT statement. See your Oracle documentation on how to set up ORACLE Net8 services.

When you use Oracle OCI, be aware that the following OpenESQL functions are not supported:

  • BEGIN TRANSACTION statement
  • CALL statement
  • EXECSP statement
  • QUERY ODBC statement
  • SET AUTOCOMMIT statement
  • SET TRANSACTION ISOLATION statement
  • Scrolling cursors (including SET SCROLLOPTION and SET CONCURRENCY statements)
  • WITH PROMPT parameter on CONNECT statement (not available on UNIX)
  • SQL (CONNECTIONPOOL) directive
  • Switching connections using the SET CONNECTION statement
  • SQL statements that contain DBCS characters
Parent topic: OpenESQL


DB2

  • DB2 External Compiler Module
  • DB2 Stored Procedures
  • Host Compatibility Option (HCO)
Parent topic: Database Access
Related concepts
Database Access Preprocessors
Compiling SQL Applications


DB2 External Compiler Module

This collection of topics describe how you can access a DB2 database from a COBOL program that contains embedded SQL statements.

The DB2 External Compiler Module (ECM) is an integrated preprocessor provided with this system and designed to work closely with the Micro Focus COBOL Compiler. The DB2 ECM converts embedded SQL statements into the appropriate calls to DB2 database services.

  • Demonstration Applications
    A list of available demonstration applications provided to illustrate programming techniques and runtime behavior for native applications using the DB2 ECM, along with a description of each of these applications.
  • Compound SQL
  • User Defined Functions
  • Extensions to Embedded SQL Support
  • UDB-VERSION DB2 Directive Option
  • Compiling
  • Error Codes
  • Linking
  • Binding
Parent topic: DB2


Demonstration Applications

A number of DB2 ECM demonstration applications are supplied in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Net Express IDE\DB2ESQL directory.

Each sample application comes with a Readme file to explain how to use the application, and a makefile.

The following applications are provided:

  • Connect Demo

    Shows the syntax variants for connecting to and disconnecting from a DB2 database using Type 1 CONNECTs that IBM DB2 LUW supports.

  • Dynamic Demo

    A simple example of using dynamic SQL with IBM DB2 LUW, performing a variety of SQL operations. If this program was written as a STATIC SQL program, it would have to be broken apart into two programs, since static SQL requires that the table exists beforehand or it would cause a Compiler error.

  • Lob Demo

    Shows how LOB LOCATOR and VALUES functions to retrieve Lob data from DB2 LUW.

  • Select Demo

    A simple example of using both singleton SELECT and cursor-based FETCH statements with IBM DB2 LUW.

  • Whenever Demo

    Shows how to use EXEC SQL WHENEVER statements for error handling, and the DB2(MSGAREA) Compiler directive to specify a COBOL variable for retrieving error message text larger than the 70 bytes provided in SQLERRMC.

Parent topic: DB2 External Compiler Module


Compound SQL

Compound SQL is supported, including the extended form now available in DB2. Note that incomplete Compound SQL statements are detected by the DB2 ECM and cause an error to be produced. However, DB2 may not always recover from this condition and valid SQL statements later in the program source may generate additional errors.

Parent topic: DB2 External Compiler Module


User Defined Functions

A program containing a reference to a User Defined Function (UDF) causes a separate module to be invoked; it contains user-supplied code which returns an appropriate value or values. The UDF code itself does not contain any SQL.

Running a program containing embedded SQL statements causes DB2 to be invoked and this in turn may invoke the UDF module. The declaration of the UDF should specify the language this module is written in. DB2 currently allows this to be C only, although on some platforms it is possible to write the module in COBOL. The following section demonstrates by use of example how this may be achieved. More complete descriptions of User Defined Functions and parameter descriptions are provided in the DB2 documentation.

User Defined Functions written in COBOL are not currently supported on UNIX.

Note: In a client/server configuration, the UDF module is invoked on the server and these restrictions apply to the server only - any client can access UDFs if the server is suitable.

The entry points in the UDF should be defined using C calling conventions. The following sample code segments show the use and definition of a simple UDF to calculate an exponent:

Program 1 declares the function to DB2. This program must be compiled and executed before program 2 can be compiled.

exec sql
   create function mfexp(integer, integer)
      returns integer
      fenced
      external name 'db2v2fun!mfexp'
      not variant
      no sql
      parameter style db2sql
      language cobol
      no external action
end-exec

Note the LANGUAGE COBOL clause. This is provided by Micro Focus COBOL as an extension to the DB2 syntax. It is equivalent to LANGUAGE C and, regardless of which is used, the called module should conform to the C calling convention. The EXTERNAL NAME clause specifies, in this case, that the called module is called db2v2fun.dll and the entry point within this is mfexp.

Program 2 uses the UDF:

     move 2 to hv-integer
     move 3 to hv-integer-2
     exec sql
         values (mfexp(:hv-integer, :hv-integer-2))
          into :hv-integer-3
     end-exec

Program 3 is a pure COBOL program containing the UDF itself.

$set case
 special-names.
     call-convention 0 is cc.
 linkage section.
 01  a pic s9(9) comp-5.
 01  b pic s9(9) comp-5.
 01  c pic s9(9) comp-5.
 01  an pic s9(4) comp-5.
 01  bn pic s9(4) comp-5.
 01  cn pic s9(4) comp-5.
 01  udf-sqlstate pic x(6).
 01  udf-fname pic x(28).
 01  udf-fspecname pic x(19).
 01  udf-msgtext pic x(71).
 procedure division cc.
    goback
    .
 entry "mfexp" cc
     using a b c an bn cn
           udf-sqlstate
           udf-fname
           udf-fspecname
           udf-msgtext.
     if an not = 0 or bn not = 0
         move -1 to cn
     else
         compute c = a ** b
         move 0 to cn
     end-if
     goback
     .

This module should be compiled to create a dynamically loadable executable (dll) and placed somewhere where the operating system can locate it (on the PATH).

Note: Entry-point names are case sensitive on all systems. Care should be exercised in matching case names, and the CASE Compiler directive should be specified (as per the $SET statement in the example program above).
Parent topic: DB2 External Compiler Module


Extensions to Embedded SQL Support

This section discusses Micro Focus extensions to the embedded SQL support.

  • The INCLUDE Statement
  • The DECLARE TABLE Statement
  • Qualified Host Variables
  • Host Variable Groups and Indicator Arrays
  • The NOT Operator (¬)
  • The Concat Operator (|)
  • SQL Communications Area
  • Support for Object Oriented COBOL Syntax
  • Support for Nested COBOL programs
Parent topic: DB2 External Compiler Module


The INCLUDE Statement

Statements of the form:

exec sql
   include filename
end-exec

are permitted and are processed in exactly the same way as the statement:

copy filename

The included file can contain any COBOL statements that a copybook can, including further EXEC SQL statements.

Parent topic: Extensions to Embedded SQL Support


The DECLARE TABLE Statement

Statements of the form:

exec sql
   DECLARE table-name TABLE
   ...
end-exec

are permitted and are treated as comments.

Parent topic: Extensions to Embedded SQL Support


Qualified Host Variables

Host variables can be qualified using DB2 for MVS compatible syntax.

For example, suppose you have defined some host variables as follows:

01 block-1.
   03 hostvar pic s9(4) comp-5.
01 block-2.
   03 hostvar pic s9(4) comp-5.

You can qualify which instance of hostvar to use with syntax of the form:

exec sql
   fetch s2 into :block-1.hostvar
end-exec
Parent topic: Extensions to Embedded SQL Support


Host Variable Groups and Indicator Arrays

When host variables are declared in a group item, an SQL statement which needs to refer to each of these variables in turn can be abbreviated by referring instead to the group-name. If you need to associate indicator variables with these host variables, define a table of indicator variables with as many instances as there are host variables, and reference this table (the item with the OCCURS clause, not a group item containing it).

For example, suppose you have defined some host variables as follows:

01  host-structure.
   03 sumh           pic s9(9) comp-5.
   03 avgh           pic s9(9) comp-5.
   03 minh           pic s9(9) comp-5.
   03 maxh           pic s9(9) comp-5.
   03 varchar.
      49 varchar-l   pic s9(4) comp.
      49 varchar-d   pic x(1000).
 01  indicator-table.
     03 indic          pic s9(4) comp-5 occurs 4.
 01  redefines indicator-table.
     03 indic1         pic s9(4) comp-5.
     03 indic2         pic s9(4) comp-5.
     03 indic3         pic s9(4) comp-5.
     03 indic4         pic s9(4) comp-5.

In such an example, the procedural statement:

exec sql fetch s3 into
  :host-structure:indic
end-exec

is equivalent to:

exec sql fetch s3 into
  :sumh:indic1, :avgh:indic2, :minh:indic3,
  :maxh:indic4, :varchar
end-exec

The four declared indicator variables are allocated to the first four host variables. If five or more had been declared, all five host variables would have an associated indicator variable.

The table of indicator variables is redefined only to show the equivalent SQL statement (subscripting is not allowed in SQL statements). The redefinition can be omitted and the COBOL program can refer to the indicator variables using subscripting, if desired.

Parent topic: Extensions to Embedded SQL Support


The NOT Operator (¬)

DB2 allows the operators ¬=, ¬> and ¬<. These are mapped to <>, <= and >=. The character representation of the NOT operator varies from system to system, so you can define it using the NOT option of the DB2 Compiler directive.

Parent topic: Extensions to Embedded SQL Support


The Concat Operator (|)

In some countries the symbol used for the concat operator is not the ASCII character (|). The DB2 ECM enables you to specify a different ASCII character for the concat operator via the CONCAT option of the DB2 Compiler directive.

Parent topic: Extensions to Embedded SQL Support


SQL Communications Area

After any SQL statement has executed, important information is returned to the program in an area called the SQL Communications Area (SQLCA). The SQL Communications Area is usually included in your program using the statement:

exec sql include sqlca end-exec

If you do not include this statement, the DB2 ECM automatically allocates an area, but this area is not addressable in your program. However, if you declare either or both of SQLCODE and SQLSTATE, the DB2 ECM generates code to copy the corresponding fields in the SQLCA area to the user-defined fields after each EXEC SQL statement.

Tip: For ANSI compatibility, we recommend you define the entire SQLCA.

After any non-zero condition in SQLCODE, the DB2 ECM updates the contents of the MFSQLMESSAGETEXT data item with a description of the exception condition, provided it has been defined. If it is, it must be declared as a character data item (PIC X(n), where n can be any legal value; if the message does not fit into the data item it is truncated).

None of SQLCA, SQLCODE, SQLSTATE and MFSQLMESSAGETEXT is required to be declared as host variables.

Parent topic: Extensions to Embedded SQL Support


Support for Object Oriented COBOL Syntax

The DB2 ECM has been enhanced to work with Object Oriented COBOL syntax (OO programs). There are, however, a couple of restrictions that you should be aware of:

  • The INIT option of the DB2 Compiler directive is disabled if used within an OO program. Therefore, to obtain the functionality of the DB2(INIT=PROT) Compiler directive, include a non-OO module and compile it with this directive.
  • If you use an EXEC SQL WHENEVER statement within a METHOD, any additional METHODs coded in the same CLASS that have SQL statements in them need to have the section that is referenced in the preceding WHENEVER statement defined. Not doing this results in a compilation error indicating that the section has not been defined. You can get around this restriction by defining another EXEC SQL WHENEVER statement.
Parent topic: Extensions to Embedded SQL Support


Support for Nested COBOL programs

The DB2 ECM allows you to work with nested COBOL programs.

By default, DB2 interface code is generated for every nested COBOL program. To avoid generating DB2 interface code for each nested program, use the DB2 directive IGNORE-NESTED. To use the IGNORE-NESTED directive properly, there is one restriction that you should be aware of:

  • You must specify the PROGRAM-ID statement in the program for which you wish DB2 interface code to be generated. Otherwise, a compile error occurs.
Parent topic: Extensions to Embedded SQL Support


UDB-VERSION DB2 Directive Option

The DB2 ECM can use one of two sets of API calls, depending on the version of DB2 Database for Linux, UNIX and Windows (DB2 LUW) you are using. The set of calls used for DB2 LUW Version 7.1 and later make use of the new facilities that IBM introduced in Version 7. In this version, IBM changed the size of the program identifier string (PID) from 40 bytes to 162 bytes. The PID is stored in each application program when it is compiled. You need to use the new PID structure if you use a COLLECTION-ID greater than 8 characters.

The DB2 ECM automatically tries to use the newer set of calls if you connect to a DB2 LUW server at Version 7.1 or later when you compile your program. However, you might want to use the newer set of calls in other circumstances, for example, if you are not using Version 7.1 client software, or if you are connected to another DB2 server via DB2 Connect. To do this, use the DB2 Compiler directive UDB-VERSION, which allows you to indicate which DB2 LUW version you want to use. Valid values are V6, V7, V8, V9, V95, and V97. If you specify V7 or later, the ECM makes the new calls. For example:

DB2(UDB-VERSION=V7)

If the DB2 ECM fails to find the new API, it displays the following message:

* critical errror - DB2Initialize API not found
* Try using directive DB2(UDB-VERSION=V6)
* to compile program

followed by the message:

** DB00010 DB2 rejected an unspecified option. This error
** prevents SQL processing from continuing - further
** EXEC SQL statements will be ignored
Parent topic: DB2 External Compiler Module
Related reference
UDB-VERSION


Compiling

Compiling your SQL program with the COBOL Compiler is logically equivalent to two steps: precompiling to change SQL lines into host language statements, and then compiling the resulting source. These two steps actually occur in a single process, which is performed by the COBOL Compiler in conjunction with the DB2 ECM.

Before you try to compile any SQL program, please make sure the following have been done:

  • To avoid a compiler error with the DB2 directive, DB2 LUW Data Server Client must be installed.
  • DB2 has been started if checking against a local database or a remote database server via the DB2START or NET START DB2 command
  • If using DB2 LUW as a remote database server, that security services also must have been started
  • You have specified a valid database in the project settings under the SQL tab
Note: This is important since to compile a program, you must first connect to the database. If the connect fails, your program will not compile.

If you have done all of the above steps, and get a COBDB006 error ("Required DB software db2agapi could not be found."), check the PATH statement generated by Studio Enterprise Edition from aNet Express command prompt. The PATH gets modified by Studio Enterprise Edition, and the directory where DB2 is installed might appear in the path statement beyond the 255-byte limit. Modify your PATH statement to ensure that the ..\SQLLIB\BIN directory is closer to the beginning of the PATH statement so that the database DLLs required to compile the program can be loaded.

Before you can compile a SQL program, you must have been granted authorization. This is usually done by the DB2 Database Administrator. You must have one of the following:

  • sysadm or dbadm authority
  • BINDADD privilege if a package does not exist, and one of the following:
    • IMPLICIT_SCHEMA authority on database if the schema name of the package does not exist
    • CREATIN privilege on the schema if the schema name of the package exists
    • ALTERIN privilege on the schema if the package exists
    • BIND privilege on the package if it exists

The user also needs all table privileges required to compile any static SQL statement in the application. Note that privileges granted to groups are not used for authorization checking of static SQL statements. If a program fails to compile because of lack of authority on an SQL object, please contact your company's DB2 Database Administrator.

You use the DB2 Compiler directive to give the DB2 ECM information such as the fact that you are using SQL, and which database you are using.

If you are using the API calls introduced for DB2 LUW Version 7.1, the DB2 ECM calls an IBM module to validate them. If the DB2 ECM finds an error in the directive syntax, it displays a -104 SQLCODE error message:

Normally, programs containing embedded SQL are compiled in the same way as non-SQL programs, except that the DB2 Compiler directive is required. Special action is required only when creating an executable (binary) file when additional modules need to be linked in. Programs containing SQL code can be animated like any other program. You can examine host variables inside SQL statements as they are regular COBOL data items.

  • Setting DB2 Background Syntax Checking Options
    Explains how to set options that determine the level at which the DB2 ECM preprocessor checks syntax in the background.
  • Compiling Programs That Use a Remote DB2 Server
  • DB2 Compiler Directive
Parent topic: DB2 External Compiler Module
Related concepts
Invoking the DB2 ECM


Setting DB2 Background Syntax Checking Options

Before compiling a DB2 application, you can set options that determine the level at which the DB2 ECM preprocessor checks syntax in the background. To do this, click Tools > Options; then expand Micro Focus COBOL Tools and click DB2 Background Syntax Checking. You can set the following options:

  • Background Compile Setting > No syntax checking

    The precompiler does not connect to the DBMS and does not validate EXEC SQL statements; however, the precompiler does check host variables.

  • Background Compile Setting > Complete syntax checking

    This option sends all embedded SQL statements to the DBMS for validation, and requires a connection to the DBMS used by the program. Select this option for database providers that do not require SQL statement execution to perform validation.

See your Visual Studio documentation for information on setting properties.

Parent topic: Compiling


Compiling Programs That Use a Remote DB2 Server

To compile a program that uses a remote DB2 server, you must first connect to that remote server. The DB2 ECM first attempts to connect to the database using the default values for the client workstation you logged on with. If the logon fails, the DB2 ECM will invoke the Micro Focus SQL Logon dialog box, from which you can specify a logon ID and password for the database you are trying to compile your program against.

The Micro Focus SQL Dialog Box

There is an option to save your logon ID and password in memory so that you do not need to be prompted the next time you try to compile a program using the same database. This information is lost the next time you reboot your client machine or if you type the following command from aNet Express command prompt: MFDAEMON CLOSE.

  • Automated Compiles
Parent topic: Compiling


Automated Compiles

Having the graphical logon dialog appear might not be acceptable for automating compiles from a background process such as a command file. There is a way to supply the logon information by setting an environment variable and pointing the variable at a text file that contains the logon ID and password. To do this, set the environment variable SQLPASS.TXT to the name of the text file that contains the logon ID and password. For example:

SET SQLPASS.TXT=D:\BATCH.TXT

Then in the file batch.txt, specify the logon ID and password in the format id.password. For example:

MyId.Mypassword

If the security system used to validate your logon ID and password is case sensitive, you need to specify id.password in the correct case in this text file.

Note: Specifying the logon and password in a text file does raise security concerns, so care should be used when implementing this facility.
Parent topic: Compiling Programs That Use a Remote DB2 Server


DB2 Compiler Directive

You can specify the DB2 Compiler directive anywhere where you can specify any other Compiler directive. For example:

  • in a $SET statement:
    $set db2(init=prot bind collection=myschema)
  • using the Advanced Directives screen
Note: You cannot specify the DB2 directive more than once, so must only specify it in one of the possible places.

Compiler directives have a default value which is used if no other value is specified. This also applies to all existing DB2 directive options. Many of the options are passed straight to DB2 at compilation time and the Compiler default is used when no other value is specified. In these cases, however, the suitability of, and default values for these options is dependent on the DB2 configuration, notably whether it is connected to a DRDA server via DDCS. Because of this, the default Compiler setting of these options is "not set". This means that no value is passed to DB2 and the default value (if applicable) is determined by DB2 itself. Consult your IBM DB2 reference documentation for these values.

Note: This list assumes that you are using DB2 LUW V9.7 or later . Some directives are only valid when using DB2 Connect with DB2 LUW. If you are using a different version of DB2 LUW, consult your IBM DB2 reference documentation under PRECOMPILE or BIND to see if the DB2 directive option is supported locally (DB2) or only by DB2 Connect (DRDA). If you are in any doubt, you can specify the directive and attempt to compile the program. If it is not supported, an error message will be issued.
Parent topic: Compiling
Related reference
DB2 Compiler Directive Options


Error Codes

Error conditions are returned at compilation time as a number and explanation. Further details of these messages are given in the documentation supplied with your database system. Messages referencing host variables might be slightly modified if you are using an older version of DB2 LUW. Hyphens are shown as underscores (_), and there are up to three additional characters which can be ignored at the end of the name. These changes are side effects of modifications made by the DB2 ECM to the SQL code. For more information see the entry for the QUALFIX option in the section DB2 Compiler Directive Options

Error conditions at run time are indicated by non-zero values in SQLCODE. Explanatory text is placed in the MFSQLMESSAGETEXT data item if defined; see the section SQL Communications Area for further details about this data item.

For example:

801-S
** External Compiler Module message
** SQ0100 SQL1032N  No start database manager command was
**                  issued.
** SQLSTATE=57019
Parent topic: DB2 External Compiler Module
Related concepts
SQL Communications Area (SQLCA)
Related reference
QUALFIX
DB2 Compiler Directive Options


Linking

To link an application:

  1. Click Project > Properties for your current project.
  2. Click COBOL > Link Settings.
  3. In the Link with libs field, type db2api.lib; then click OK.
    Note: You must use the 32-bit version of db2api.lib even if you are running the 64-bit version of DB2 LUW software. In this case, include the full path to and filename of the 32-bit version of db2api.lib into the Link with libs field. The 32-bit version of db2api.lib is usually found in your \Program Files\IBM\SQLLIB\lib\Win32 directory.
Parent topic: DB2 External Compiler Module


Binding

If you use the NOACCESS option of the DB2 Compiler directive or intend to execute the application on a machine other than the one it was compiled on, bind the application to a particular database before execution. In this case, you should use the BIND option to create a bind file that can then be used to bind the program to the database using the DB2 BIND command. For details on doing this, see the documentation supplied with your SQL system.

You can direct the DB2 ECM to store bind files in a directory other than the current source directory by specifying the enviroment variable HCOBND, for example:

SET HCOBND=d:\production\binds

The directory you specify in the HCOBND environment variable is used to all bind files until you unset or reset the environment variable or unless you specify a specific bind file name using the DB2 BIND directive option, for example:

DB2(bind=d:\test\test1.bnd)

The DB2 BIND directive option overrides the HCOBND environment variable.

Parent topic: DB2 External Compiler Module


DB2 Stored Procedures

A stored procedure is a compiled program that can execute SQL statements.You need to use stored procedures if your application program operates in a client/server environment, and if either of the following two problems apply: The application accesses host variables for which you want to guarantee security and integrity. The application executes a series of SQL statements, creating many network send and receive operations, which significantly increase CPU and elapsed time costs.

Stored procedures are stored at a local or remote DB2 LUW Server. Local DB2 LUW Server applications or remote DRDA applications can use the SQL statement CALL to invoke a stored procedure.

Note:
  • If you are running your stored procedure on DB2 for OS/390, through the DB2 Connect product, see your IBM DB2 documentation for other steps necessary to run the stored procedure.
  • For complete information on writing stored procedures and setting options for DB2 Database for Linux, UNIX, and Windows (LUW), see IBM's documentation on Developing User-defined Routines (SQL and External) and also their SQL reference material.
  • Working with Stored Procedures
  • Writing and Preparing Stored Procedures
  • Writing and Preparing Applications to Use Stored Procedures
  • Defining Stored Procedures under DB2 LUW
  • Compiling Stored Procedures under DB2 LUW
Parent topic: DB2
Related reference
CALL


Working with Stored Procedures

To get a stored procedure up and running:

  1. Do one of the following:
    • Add your installation's executable (bin) directory to the PATH statement
    • Copy either the cblrtsm.dll run time (threaded run time) or the cblrtss.dll (non-threaded run time) run time file to the directory from which you execute the stored procedure. You need to do this for DB2 to be able to execute a COBOL stored procedure.
  2. Code and prepare a stored procedure. See the topic Writing and Preparing Stored Procedures for instructions.
  3. Code and prepare an application that calls the stored procedure. An SQL statement, CALL, in that application must use the same parameter list and linkage convention as the stored procedure that it invokes. See the section Writing and Preparing Applications to Use Stored Procedures for instructions.
  4. Define your stored procedure to the DB2 LUW Server by issuing a CREATE PROCEDURE command, which will place a row in the appropriate system table(s). See the section Defining Stored Procedures under DB2 LUW for additional details.
  5. Compile your stored procedure. See the section Compiling Stored Procedures under DB2 LUW for additional details.
  6. Debug and test your stored procedure. See the section Debugging Stored Procedures under DB2 LUW for additional details.
Parent topic: DB2 Stored Procedures
Related concepts
Writing and Preparing Stored Procedures
Writing and Preparing Applications to Use Stored Procedures


Writing and Preparing Stored Procedures

A stored procedure is an application program that runs in the DB2 LUW Server's address space. It can contain most statements that an application program normally contains. It can consist of more than one program. Your stored procedure can call other programs as well as nested stored procedures but there are restrictions.

The application program that invokes the stored procedure can be in any language that supports SQL statements. You can write a stored procedure using many languages such as C, JAVA, COBOL or now SQL Procedure Language which is consistent with the Persistent Stored Module definition of the ANSI SQL99 standard.

The store procedure can be written in one language, for example JAVA, with the client written in another language, for example COBOL. When the languages differ, DB2 transparently passes the values between the client and the stored procedure so each program gets the values in the expected format defined by the CREATE PROCEDURE statement.

  • Features of a Stored Procedure
  • Preparing Stored Procedures
  • How an Application Works With a Stored Procedure
Parent topic: DB2 Stored Procedures
Related concepts
Working with Stored Procedures
Writing and Preparing Applications to Use Stored Procedures


Features of a Stored Procedure

A stored procedure is similar to any other SQL application.

The following restrictions apply to stored procedures:

  • A C or COBOL stored procedure must be a dynamic link library (DLL) when built to run under Windows server.
  • To use SQL Procedure Language, you need to have a C compiler installed since the SQL statements generate a C program.
  • The following SQL statements are not allowed in a stored procedure:
    • CONNECT
    • DISCONNECT
    • SET CONNECTION
Parent topic: Writing and Preparing Stored Procedures


Preparing Stored Procedures

The following are tasks which must be completed before a stored procedure can be run on an DB2 LUW Server:

  1. Prepare the application according to your embedded SQL documentation for creating stored procedure.
  2. Define the stored procedure to the DB2 LUW Server. See Defining Stored Procedures under DB2 LUW.
  3. Place the stored procedure DLL or JAVA routine on the DB2 LUW Server machine in a location specified in the CREATE PROCEDURE. If not specified, the default location is the sqllib\function subdirectory where DB2 LUW is installed.
Parent topic: Writing and Preparing Stored Procedures


How an Application Works With a Stored Procedure

A typical stored procedure contains two or more SQL statements, and some manipulative or logical processing. In this example, your application, CALLSTPR, runs on a workstation client and calls a stored procedure, GETEMPSVR. The following process occurs:

  1. The workstation application establishes a connection to the DB2 LUW Server.
  2. The SQL statement CALL tells the DB2 LUW Server that the application is going to run the stored procedure, GETEMPSVR. The calling application provides the necessary parameters.
  3. The DB2 LUW Server searches the system tables for rows associated with stored procedure GETEMPSVR.
  4. The DB2 LUW Server passes information about the request to the stored procedure.
  5. The stored procedure executes SQL statements.
  6. The stored procedure assigns values to the output parameters and then exits.
  7. Control returns to the calling application, which receives the output parameters.

The application can call more stored procedures or it can execute more SQL statements. The application designer determines whether to COMMIT work in the stored procedure that runs on the server, or in the client as a single transaction.

Parent topic: Writing and Preparing Stored Procedures


Writing and Preparing Applications to Use Stored Procedures

To invoke a stored procedure and to pass a list of parameters to the procedure, use the SQL statement CALL. Your application program can call several stored procedures.

After connecting to its server, an application can mix calls to stored procedures with SQL statements sent to the server.

  • Executing the SQL Statement CALL
  • Parameter Conventions
  • Using Indicator Variables to Speed Processing
  • Declaring Data Types for Passed Parameters
  • Limitations
Parent topic: DB2 Stored Procedures
Related concepts
Working with Stored Procedures
Writing and Preparing Stored Procedures


Executing the SQL Statement CALL

Use the CALL statement to execute each series of SQL statements in your application.

Example 1

To call the stored procedure described in How an Application Works with a Stored Procedure, your application might use this statement:

EXEC SQL
 CALL GETEMPSVR (:V1, :V2)
END-EXEC

If you use host variables in the CALL statement, you must declare them before using them.

Example 2

The example above is based on the assumption that none of the input parameters can have null values. To allow null values, code a statement like this:

EXEC SQL
 CALL GETEMPSVR (:V1 :IV1, :V2 :IV2)
END-EXEC

where :IV1 and :IV2 are indicator variables for the parameters.

Example 3

To pass integer or character string constants or the null value to the stored procedure, code a statement like this:

EXEC SQL
 CALL GETEMPSVR (2, NULL)
END-EXEC

Example 4

To use a host variable for the name of the stored procedure, code a statement like this:

EXEC SQL
 CALL :PROCNAME (:V1, :V2)
END-EXEC

Example 5

Assume that the stored procedure name is GETEMPSVR. The host variable PROCNAME is a character variable of length 254 or less that contains the value GETEMPSVR. You should use this technique if you do not know in advance the name of the stored procedure, but you do know the parameter list convention.

To pass your parameters in a single structure, rather than as separate host variables, code a statement like this:

EXEC SQL
 CALL GETEMPSVR USING DESCRIPTOR :ADDVALS
END-EXEC

where ADDVALS is the name of an SQLDA.

Example 6

To use a host variable name for the stored procedure with an SQLDA, code a statement like this:

EXEC SQL
 CALL :PROCNAME USING DESCRIPTOR :ADDVALS
END-EXEC

This form gives you extra flexibility because you can use the same CALL statement to invoke different stored procedures with different parameter lists.

Your client program must assign a stored procedure name to the host variable PROCNAME and load the SQLDA ADDVALS with the parameter information before making the SQL CALL statement.

Each of the above CALL statement examples uses an SQLDA. If you do not explicitly provide an SQLDA, the precompiler generates the SQLDA based on the variables in the parameter list.

You can execute the CALL statement only from an application program. You cannot use the CALL statement dynamically.

Parent topic: Writing and Preparing Applications to Use Stored Procedures


Parameter Conventions

When an application executes the CALL statement, the DB2 LUW Server builds a parameter list for the stored procedure, using the parameters and values provided in the statement. The DB2 LUW Server obtains information about parameters from the system tables. See the section Defining Stored Procedures under DB2 LUW for more information. Parameters are defined as one of these types:

  • IN

    Input-only parameters, which provide values to the stored procedure.

  • OUT

    Output-only parameters, which return values from the stored procedure to the calling program.

  • INOUT

    Input/output parameters, which provide values to or return values from the stored procedure.

If a stored procedure fails to set one or more of the output-only parameters, the DB2 LUW Server simply returns the output parameters to the calling program, with the values established on entry to the stored procedure. COBOL supports three parameter list conventions. Other languages support other conventions. The parameter list convention is chosen based on the parameter style defined in the CREATE PROCEDURE statement.

Parameter Style | Description
SIMPLE | Use SIMPLE (or GENERAL) to prevent the calling program passing null values for input parameters (IN or INOUT) to the stored procedure. The stored procedure must declare a variable for each parameter passed in the CALL statement.
SIMPLE WITH NULLS Use SIMPLE WITH NULLS (or GENERAL WITH NULLS) to allow the calling program to supply a null value for any parameter passed to the stored procedure. The following rules apply:
  • An indicator variable must follow each parameter in the calling program's CALL statement, using one of the following two forms:
    • host variable :indicator variable

      or:

    • host variable INDICATOR :indicator variable
  • The stored procedure must declare a variable for each parameter passed in the CALL statement.
  • The stored procedure must declare a null indicator structure containing an indicator variable for each parameter passed in the CALL statement.
  • On entry, the stored procedure must examine all indicator variables associated with input parameters to determine which parameters contain null values.
  • On exit, the stored procedure must assign values to all indicator variables associated with output variables. An indicator variable for an output variable that returns a null value to the caller must be assigned a negative number. Otherwise, the indicator variable must be assigned the value zero (0).
DB2SQL In addition to the parameters on the CALL statement, the following arguments are passed to the stored procedure:
  • a NULL indicator for each input parameter on the CALL statement.
  • the SQLSTATE to be returned to DB2.
  • the qualified name of the stored procedure.
  • the specific name of the stored procedure.
  • the SQL diagnostic string to be returned to DB2.
Parent topic: Writing and Preparing Applications to Use Stored Procedures


Using Indicator Variables to Speed Processing

If any of your output parameters require a lot of storage, do not pass the entire storage areas to your stored procedure, but declare an indicator variable for every large output parameter in your SQL statement CALL. Indicator variables are used in the calling program to pass only a two-byte area to the stored procedure and to receive the entire area from the stored procedure.

Note: If you are using the SIMPLE WITH NULLS linkage convention, you must declare indicator variables for all of your parameters, so you do not need to declare another indicator variable for the large output parameters.

Assign a negative value to each indicator value associated with a large output variable. Then include the indicator variables in the CALL statement. This technique can be used whether the stored procedure linkage is SIMPLE or SIMPLE WITH NULLS.

For example, suppose that a stored procedure, STPROC2 defined with the SIMPLE linkage convention takes one integer input parameter and one character output parameter of length 5000. It is wasteful to pass the 5000 byte storage area to the stored procedure. Instead, a COBOL program containing these statements passes only two bytes to the stored procedure for the output variable and receives all 5000 bytes from the stored procedure:

INNUM  PIC S9(9) COMP
OUTCHAR PIC X(5000)
IND  PIC S9(4) COMP
.
.
.
MOVE -1                      TO IND
EXEC SQL CALL STPROC2(:INNUM, :OUTCHAR :IND)  END-EXEC
Parent topic: Writing and Preparing Applications to Use Stored Procedures


Declaring Data Types for Passed Parameters

A stored procedure must declare each parameter passed to it. In addition, the DATA TYPE declared in the declaration must be valid for the data source being used and must use a compatible host variable data type when calling the stored procedure. For more information on data types, see the chapter SQL Data Types earlier in this book.

For example:

CREATE PROCEDURE GETEMPSVR
 (IN  EMPNO CHAR(6),
  INOUT SQLCD    INT ,
  OUT FIRSTNME CHAR(12),
  OUT LASTNAME CHAR(12),
  OUT HIREDATE CHAR(10),
  OUT SALARY   DEC(9,2) )
  LANGUAGE COBOL
  EXTERNAL NAME 'GETEMPSVR!GETEMPSVR'
  PARAMETER STYLE DB2SQL;
Parent topic: Writing and Preparing Applications to Use Stored Procedures


Limitations

IBM has not implemented the same support for all SQL syntax related to stored procedures in every supported language. For example, you cannot create COBOL stored procedures that use result sets or the EXEC SQL syntax that supports that functionality with the workstation version of DB2 LUW.

There is no support for structure, array, or vector parameters using the DB2 native precompiler. However, there is much more flexibility when using the OpenESQL precompiler and a ODBC connection.

Parent topic: Writing and Preparing Applications to Use Stored Procedures


Defining Stored Procedures under DB2 LUW

A stored procedure is unusable until it is defined. Use the CREATE PROCEDURE command to do this. You can either use the DB2 command prompt or place the command in a program and compile and run it. If you use the DB2 command prompt, you first connect to the DB2 LUW Server where the stored procedure will be executed.

For example:

C:> db2 connect to sample

You can type in the command at the DB2 command prompt making sure you include continuation characters and command delimiters, or you can place the CREATE PROCEDURE in an ANSI text file. For example, if we placed the previous command in text file creproc.sql, the command that you would enter would be:

C:> db2 -td; -vf creproc.sql

where:

  • the "-td" option indicates the next character is the delimiter to end the command. In our example, it is a semicolon (;).
  • the "-vf" option indicates that the next token is the file to process that contains the SQL command script.

The create procedure statement must uniquely identify a stored procedure. If you want to change the stored procedure to either add or drop parameters or change functionality, you must use the DROP PROCEDURE command and then re-add it with the CREATE PROCEDURE command.

When DB2/2 was originally developed, DB2/2 did not support the CREATE PROCEDURE function, and it is possible to write COBOL stored procedures without doing a CREATE PROCEDURE. Examples of this method and the parmlist that is required are included in the DB2 LUW Application Development Client.

Parent topic: DB2 Stored Procedures


Compiling Stored Procedures under DB2 LUW

You can compile a COBOL stored procedure using DB2 LUW.

  1. Compile the program you want to use as a stored procedure with the DB2 directive, just like any DB2 LUW program. Do this by adding a $SET statement to your program.
    Note: If your program contains stored procedure CALL statements, you must specify the CALL_RESOLUTION DB2 directive to avoid an SQL0204 error.
  2. After the program has been added to the project, package it as a Dynamic Link Library (.dll).
  3. Click Project > Properties for your current project.
  4. Click COBOL > Link Settings.
  5. In the Link with libs field, type db2api.lib; then click OK.
  6. Right-click the .dll file; then click Rebuild object from the context menu.
  7. From the Rebuild object command, click Project > Deployment; then select the file and copy it to the sqllib\function directory.
Parent topic: DB2 Stored Procedures


Host Compatibility Option (HCO)

  • Introducing HCO
  • HCO Tools
  • Compiling and Run Time
Parent topic: DB2


Introducing HCO

Host Compatibility Option (HCO) is a set of tools that enable you to offload DB2 for z/OS development and testing to a PC Windows or UNIX platforms using IBM's DB2 LUW.

Host Compatibility Option does this by allowing EBCDIC-enabled programs to work with DB2 LUW. This means that you can use IMS Option and CICS Options with DB2 LUW while the data is still stored in ANSI format.

In addition, Host Compatibility Option can be used to re-host applications where the target run-time environment can change. Host Compatibility Option gives you the flexibility to use mainframe SQL syntax but replace character front ends with graphical interfaces.

For operating system and software requirements, see the System Requirements topic.

  • HCO Tools
  • Sample Programs
  • Product Specifications
  • Running HCO Tools
Parent topic: Host Compatibility Option (HCO)
Related concepts
Database Access Support with Native COBOL


HCO Tools

Included in Host Compatibility Option are tools to:

  • Create databases with EBCDIC collating sequences
  • Process SQL DDL statements so that DB2 table definitions stored on the mainframe can be downloaded to the PC and used to create tables without having to be modified
  • Generate copybooks for tables (DCLGEN)
  • Export data in a variety of formats
  • Import data in a variety of formats
Note:

You can use IBM's DB2 Control Center and/or the DB2 Setup tool to perform other HCO functions such as cataloging databases and servers, executing SQL, and generating aliases.

Parent topic: Introducing HCO


Sample Programs

We provide several scripts and COBOL programs that demonstrate the functionality of the Host Compatibility Option. The functionality represented includes:

  • Database creation
  • DDL processing
  • Import
  • Export
  • DCLGEN
  • Using Static SQL statements
  • Using Dynamic SQL statements

You can find the HCO demonstration applications in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Net Express IDE\hco directory. Review the hcodemo.txt file in that directory for more information.

Parent topic: Introducing HCO


Product Specifications

DB2 LUW is basically compatible with DB2 for z/OS, with some exceptions in DML syntax and functions supported and certain DDL statements that are hardware/operating system specific. Host Compatibility Option tries to address some of the main areas of incompatibility where possible by converting DB2 for z/OS SQL statements to supported DB2 LUW syntax.

Additional compatibility is possible when using DB2 for z/OS database servers via the DB2 Connect product.

For more information on the differences in syntax supported by the various versions of DB2, see IBM's SQL Reference for Cross-Platform Development.

  • HCO Functions
  • DDL DB2 for z/OS Syntax Supported
  • DB2 LUW Syntax DDL
  • Features Supported by DB2 LUW
  • Features Not Supported by DB2 LUW
Parent topic: Introducing HCO
Related concepts
DDL Processor
DDL Processing


HCO Functions

Host Compatibility Option provides the following functions:

  • Support of programs checked with CHARSET(EBCDIC)
  • Support of DB2 for z/OS syntax DDL statements in programs and via a batch utility
  • SQLCODE map function to translate SQLCODEs automatically from DB2 LUW value to a new, designated value
  • A utility to do DCLGENs to produce INCLUDE COBOL copybooks of tables
  • A DSNTIAR subroutine to translate SQLCODEs into expanded SQL error messages
  • Quotes can be used as literals within SQL statements
  • Dashes can be used within cursor definitions
  • Support of the syntax
    SET host-variable = SPECIAL REGISTER
  • Support of DECLARE TABLE statements
  • Support of host variables with data structures (COBOL level numbers 01 through 48)
  • Ability to use COMP data items for integer and small integer instead of the INTEL COMP-5 format
  • Removal of the need to identify all host variables in Working-Storage via BEGIN DECLARE SECTION and END DECLARE SECTION statements
  • Configurable CONCAT character ( | )
  • Support of the NOT OPERATOR (¬) within queries
  • Insertion of missing colon in fields when the SQL statement parameter must be a host variable
  • Support of NOFOR compile option which allows updateable cursors to be defined without using the FOR UPDATE clause
  • Support for alternate special register names, CURRENT_DATE, CURRENT_TIME, and CURRENT_TIMESTAMP
  • Support for the DECLARE hostVariableName FOR BIT DATA statement
Parent topic: Product Specifications


DDL DB2 for z/OS Syntax Supported

As stated previously, the Host Compatibility Option pre-processor and DDL processor are designed to handle DDL statements that use DB2 for z/OS syntax. Functions can be processed in one of the following ways:

  • With no changes
  • Changed to comments as their syntax is not supported under DB2 LUW
  • With only slight modifications to remove unsupported options

Sometimes it is better to perform the function manually.

  • Functions Processed Unchanged
  • Functions Changed to Comments
  • Functions That May Be Modified
Parent topic: Product Specifications


Functions Processed Unchanged

The following is a list of functions that are not modified or changed since they are supported by DB2 LUW V7.2 or later:

  • COMMENT
  • CREATE ALIAS
  • CREATE VIEW
  • CREATE SYNONYM
  • GRANT
  • REVOKE
  • DROP TABLE
  • DROP INDEX
  • DROP VIEW
  • DROP ALIAS
  • DROP SYNONYM
  • SET
Parent topic: DDL DB2 for z/OS Syntax Supported


Functions Changed to Comments

DB2 LUW does not use STOGROUP when creating databases and tables. Therefore, this syntax is changed to comments. Some syntax such as TABLESPACE is supported by DB2 LUW but the usage is machine specific depending on the type of DB2 server being used so this syntax is also removed. Other functions, such as DROP DATABASE can be done using other DDL Processor options.

The following is a list of functions that are changed to comments:

  • ALTER TABLESPACE
  • ALTER INDEX
  • ALTER STOGROUP
  • CREATE DATABASE
  • CREATE STOGROUP
  • CREATE TABLESPACE
  • DROP DATABASE
  • DROP STOGROUP
  • DROP TABLESPACE
  • EXPLAIN
Parent topic: DDL DB2 for z/OS Syntax Supported


Functions That May Be Modified

Host Compatibility Option auto-senses which SQL engine it is running with. In addition, certain options such as FIELDPROC are not supported under DB2 LUW. Consequently, all columns defined with this option must be modified. The following is a list of functions that are supported and modifications are made to statements as needed to run under DB2 LUW:

  • ALTER TABLE
  • CREATE TABLE
  • CREATE INDEX

For example, the ALTER TABLE statement has the following syntax and options:

ALTER TABLE table-name
    ADD column-name data-type FIELDPROC
    (program-name or constant)
    ADD column-name data-type NOT NULL WITH DEFAULT VALIDPROC
      program or NULL
    AUDIT NONE or CHANGES or ALL
    PRIMARY KEY ( column-name )
    FOREIGN KEY constraint-name ( column-name )
    REFERENCES table-name ON DELETE
    RESTRICT or CASCADE or SET NULL
    DROP PRIMARY KEY
    DROP FOREIGN KEY constraint-name

The options FIELDPROC, VALIDPROC and AUDIT are not supported by DB2 LUW and would be removed from the statement. The rest of the statement is supported unchanged.

Similarly, the CREATE INDEX statement has the following syntax and options:

CREATE unique INDEX index-name
ON table-name
    ( column-name ASC or DESC )
    USING VCAT catalog-name
    USING STOGROUP stogroup-name
    PRIQTY integer SECQTY integer
    ERASE no or yes
    FREEPAGE integer
    PCTFREE integer
    CLUSTER ( PART integer VALUES (constant )
    or using-block or free-block )
    SUBPAGES 1 or 2 or 4 or 8 or 16
    BUFFERPOOL BP0 or BP1 or BP2
    CLOSE yes or no
    DSETPASS password

The options USING VCAT, USING STOGROUP, FREEPAGE, PCTFREE, CLUSTER, SUBPAGES, BUFFERPOOL, CLOSE and DSETPASS are not supported under DB2 LUW and therefore will be removed from the command that is passed to DB2 LUW.

In the CREATE TABLE statement, the syntax and options are as follows:

CREATE TABLE table-name
     ( column-definition data-type FIELDPROC
    program-name or constants
    , column-definition data-type NOT NULL
    , column-definition data-type NOT NULL WITH DEFAULT
    , PRIMARY KEY (column-name)
    , FOREIGN KEY constraint-name ( column-name )
         REFERENCES table-name
         ON DELETE RESTRICT or CASCADE or SET NULL
    LIKE table-name or view-name )
    IN DATABASE database-name
    IN database-name.tablespace-name
    EDITPROC program-name
    VALIDPROC program-name
    AUDIT NONE or CHANGES or ALL

The options FIELDPROC, LIKE, IN DATABASE, EDITPROC and VALIDPROC are not supported by DB2 LUW.

Parent topic: DDL DB2 for z/OS Syntax Supported


DB2 LUW Syntax DDL

HCO can also process DDL statements in DB2 LUW syntax without modifying the statements.

Parent topic: Product Specifications
Related concepts
DDL Processor


Features Supported by DB2 LUW

DB2 LUW supports a number of DB2 for z/OS functions, scalars and special registers.

  • Column Functions and Scalars
  • Special Registers
Parent topic: Product Specifications


Column Functions and Scalars

DB2 LUW supports Date and Time arithmetic and the following Scalar and Column functions:

  • AVG
  • COUNT
  • MAX
  • MIN
  • SUM
  • CHAR
  • DATE
  • DAY
  • DAYS
  • DECIMAL
  • FLOAT
  • INTEGER
  • HOUR
  • LENGTH
  • MICROSECOND
  • MINUTE
  • SECOND
  • SUBSTR
  • TIME
  • TIMESTAMP
  • YEAR
  • CONCAT or the concatenation operator (||)
  • VALUE
  • DIGITS
  • HEX
Parent topic: Features Supported by DB2 LUW


Special Registers

DB2 LUW supports the following special registers:

  • USER
  • CURRENT DATE
  • CURRENT DEGREE
  • CURRENT EXPLAIN MODE
  • CURRENT EXPLAIN SNAPSHOT
  • CURRENT FUNCTION PATH
  • CURRENT NODE
  • CURRENT PATH
  • CURRENT QUERY OPTIMIZATION
  • CURRENT SERVER
  • CURRENT TIME
  • CURRENT TIMESTAMP
  • CURRENT TIMEZONE
  • CURRENT SQLID

See your DB2 LUW SQL Reference for details on any additional special registers that may be supported.

Parent topic: Features Supported by DB2 LUW


Features Not Supported by DB2 LUW

DB2 LUW is not completely DML-compatible with DB2 for z/OS.

  • Special Registers
  • Other Functions
Parent topic: Product Specifications


Special Registers

DB2 LUW does not support the following special register:

  • CURRENT LC_TYPE
  • CURRENT OPTIMIZATION HINT
  • CURRENT PRECISION
  • CURRENT PACKAGESET
  • CURRENT RULES

You can set the current packageset but IBM has not implemented this as a special register.

Parent topic: Features Not Supported by DB2 LUW


Other Functions

DB2 LUW does not support the following statements:

  • ALLOCATE CURSOR
  • ALTER FUNCTION
  • ALTER PROCEDURE
  • CREATE AUXILIARY TABLE
  • CREATE GLOBAL TEMPORARY TABLE
  • DECLARE
  • DESCRIBE CURSOR
  • DESCRIBE INPUT
  • DESCRIBE PROCEDURE
  • HOLD LOCATOR
  • LABEL ON
  • SET SPECIAL REGISTER where the register is not supported by DB2 LUW

Some SQL syntax especially dealing with stored procedures is supported by DB2 LUW via other languages such as C++ or JAVA but has not been implemented using COBOL.

Parent topic: Features Not Supported by DB2 LUW


Running HCO Tools

Host Compatibility Option is composed of a group of command-line tools that perform different functions that make developing DB2 and SQL applications easier. Before you start, be sure you have installed the prerequisite software. For more information, see the System Requirements topic.

  • What to Do First
  • Accessing a Database on the Mainframe
Parent topic: Introducing HCO
Related concepts
Database Access Support with Native COBOL


What to Do First

Before you can do any development, you need to have an SQL database. Depending on your organization's standards, this may be done for you by your database administrator, network administrator or you may have to do it yourself.

The IBM software that you have installed determines what you do next:

Software Installed on a PC | Which Tool to Use
DB2 LUW Personal Edition or DB2 Express-C | Use the Create Database tool to create a database.
DB2 LUW Workgroup or Enterprise Edition | Use the Create Database tool to create a database. If you have DB2 LUW server software installed, this function can be performed directly from a client PC.
Parent topic: Running HCO Tools


Accessing a Database on the Mainframe

The first time you use any of the Host Compatibility Option tools with a database, Host Compatibility Option automatically tries to bind itself to the database being connected to. If the database is on the mainframe, this automatic bind may fail if you do not have the authorities 'Create in collection NULLID' and 'BINDADD'. If an automatic bind fails, it is worth trying a manual bind, because the message returned from a manual bind clearly indicates why the bind failed.

You perform a manual bind using the DB2 command processor. At a 32-bit Net Express command prompt, enter the following commands:

db2 connect to servername
db2 bind mfhco80b.bnd collection NULLID

where servername is the name of the DB2 server for the database that you want to connect to.

If this bind fails, ask your database administrator to help resolve the problem, which is likely an authority issue.

Parent topic: Running HCO Tools


HCO Tools

  • Create Database
  • DDL Processor
  • DCLGEN
  • Exporting Data
  • Importing Data
Parent topic: Host Compatibility Option (HCO)


Create Database

Databases created on PCs or database servers store data in ANSI. To use these databases with EBCDIC enabled products such as IMS Option and CICS Option, you must have a database created with an alternate collating sequence.

Note: If you use any of the IBM tools to create the database, all data will be returned to your application in ANSI collating sequence. IBM does provide some examples of how to create databases with alternate collating sequences but the EBCDIC to ANSI translation that IBM uses may be different from the translation used in this COBOL development system. Therefore it is very important that you use the Create Database tool to create the database.
  • Command Line Interface
Parent topic: HCO Tools
Related concepts
Collating Sequence For Data


Command Line Interface

Syntax

mfhco create db=databasename [coll=collsequence] [log=logfilename] [drv=driveletter]

Syntax Rules

  1. At least one space must occur before each parameter in the command.
  2. There must be an equal sign (=) between parameters and their values.
  3. If you omit parameters that have a default value, Host Compatibility Option uses the default value.

Parameters

databasename | Specifies the name of the new database .
collsequence | Specifies the collating sequence to use. The default value is MFD, which is the EBCDIC collating sequence installed by Studio Enterprise Edition.
logfilename | The name of the logfile to capture output information. The default value is createdb.log.
driveletter | The drive letter to create local database on.

Example

The following command:
mfhco create db=test drv=e
creates a database named test on drive e using the default Studio Enterprise Edition EBCDIC collating sequence.
Parent topic: Create Database


DDL Processor

The DDL Processor processes SQL DDL statements using one of the following methods:
  • Transforming DB2 for z/OS syntax DDL statements to DB2 LUW format
  • Processing the DDL statements unchanged
  • Downloading Source DDL
  • Downloading Data to Load Tables
  • Using the DDL Processor to Load Data
  • Command Line Interface
Parent topic: HCO Tools
Related concepts
DB2 LUW Syntax DDL
Product Specifications


Downloading Source DDL

DDL source files on the mainframe should be downloaded and converted to standard ANSI text files. The maximum input length per record accepted by the DDL processor is 80 bytes.

Note:

If non-blank characters exist in columns 73 through 80, you must change maximum column to process to be 72 or they are treated as part of the DDL source statement. See the topic Command Line Interface for more details.

Parent topic: DDL Processor
Related concepts
Command Line Interface


Downloading Data to Load Tables

There are two tools in Host Compatibility Option to help you load test data exported from tables located on the mainframe:

  • The Export Data tool
  • The Import Data tool
Parent topic: DDL Processor
Related concepts
Importing Data
Exporting Data


Using the DDL Processor to Load Data

You can also use the DDL processor to load or update data into tables by placing one or more of the following DML statements in the same file as DDL statements:

  • INSERT
  • UPDATE
  • DELETE
  • COMMIT

This is a convenient way to load test data into tables.

Statements cannot contain any host variables and you cannot use quotes ( " ) around literals. You must use apostrophes ( ' ). You should also issue a COMMIT before you try to insert data into a table if it was created within the same unit of work. For example:

-- Create Available Product table
 CREATE TABLE MF.PRODUCT
  (PROD_ID  CHAR(04)    NOT NULL
  ,PROD_DESC  CHAR(40)    NOT NULL WITH DEFAULT
  ,VERSION  CHAR(6)    NOT NULL WITH DEFAULT
  ,PRIMARY KEY (PROD_ID) )
  IN DSB8G210.CISC0001
 ;
 COMMIT
 ;

 -- Sample data for Product table

 INSERT INTO MF.PRODUCT (PROD_ID ,PROD_DESC ,VERSION )
 VALUES ('SR02' ,'Host Compatibility Option ' ,'2.0.01' )
Parent topic: DDL Processor


Command Line Interface

Syntax

mfhco ddl db=databasename file=file [log=logfile]
    [max=colno] [mod=modify]

Syntax Rules

  1. At least one space must occur before each parameter in the command.
  2. There must be an equal sign (=) between parameters and their values.
  3. If you omit parameters that have a default value, Host Compatibility Option uses the default value.

Parameters

ddl | Specifies use of the DDL Processor. This parameter is positional.
databasename | Name of the database that you want to process DDL statements against.
file | The name of the file that contains DDL statements.
logfile | The name of log file to write processing details to. If this parameter is not specified, a logfile is created with a default logfile name using the project name. If you specify this parameter but specify no value for it (blank), this turns logging off.
colno | Column number to process DDL statements to. Must be a number less than or equal to 80.
modify | Set this parameter to "Y" if you want DDL statements converted to DB2 LUW format. Set this parameter to "N" if you want to process DDL statements unchanged. If you select this option, you must set the DDL delimiter value in the configuration file.

Example

mfhco ddl db=db2demo file=hcosetup.sql log=ddlproc.log
Parent topic: DDL Processor
Related concepts
Downloading Source DDL


DCLGEN

Host Compatibility Option provides a tool to generate DDL for existing SQL tables or copybooks for tables in COBOL, PL/I or C syntax.

  • Command Line Interface
  • DCLGEN Tool Examples
Parent topic: HCO Tools


Command Line Interface

Syntax

mfhco dclgen db=databasename lang=language tbl=schemaname.tablename
  file=copybookname [pre={USER | TBL | NO}] [user=username] [fld={COL | NUM}]

Syntax Rules

  1. At least one space must occur before each parameter in the command.
  2. There must be an equal sign (=) between parameters and their values.
  3. If you omit parameters that have a default value, Host Compatibility Option uses the default value.

Parameters

databasename | Database to connect to.
language | Language to generate. cbl is the default; can also specify c or pli.
schemaname | Schema name for the generated copybook.
tablename | Table name for the generated copybook.
filename | Name of the copybook file to generate.
TBL | Specifies that the prefix is the same as the table name. Default.
USER | Specifies that the prefix to use is the user's own ID.
NO | Specifies that there is no prefix.
username | User ID to use when the prefix is set to USER.
COL | Specifies the column name. Default.
NUM | Specifies the column number.

Example

mfhco dclgen db=db2demo lang=cbl tbl=demo.items file=item.cpy
Parent topic: DCLGEN


DCLGEN Tool Examples

Example 1

This example creates the file ITEMS.CPY from table DEMO.ITEMS in database DB2DEMO and prefixes all COBOL field names with the table name.

The DECLARE TABLE part of copybook file would look something like this:

************************************************************
*  MFHCODCL OPTIONS:
*  DATABASE : DB2DEMO
*  SCHEMA : DEMO
*  PREFIX : TABLE NAME
************************************************************
  EXEC SQL DECLARE DEMO.ITEMS TABLE
  ( ORD_NO    INTEGER   NOT NULL
  ,ITEM_NO    SMALLINT  NOT NULL
  ,PROD_ID    CHAR(4)
  ,QTY_ORDERED   SMALLINT  NOT NULL WITH DEFAULT
  ,QTY_SHIPPED   SMALLINT  NOT NULL WITH DEFAULT
  ,AMT_EACH    DECIMAL(7, 2) NOT NULL WITH DEFAULT
  ,DATE_ENTERED   TIMESTAMP  NOT NULL WITH DEFAULT
  ,DATE_SHIPPED   DATE
  ,ITEM_NOTES   VARCHAR(560)
  ) END-EXEC.

The COBOL DECLARATION part of copybook file would look something like this:

************************************************************
* COBOL DECLARATION FOR TABLE DEMO.ITEMS
************************************************************
 01 DCLITEMS.
  10 ITEMS-ORD-NO           PIC S9(09) COMP.
  10 ITEMS-ITEM-NO          PIC S9(04) COMP.
  10 ITEMS-PROD-ID          PIC X(4).
  10 ITEMS-QTY-ORDERED      PIC S9(04) COMP.
  10 ITEMS-QTY-SHIPPED      PIC S9(04) COMP.
  10 ITEMS-AMT-EACH         PIC S9(05)v9(02) COMP-3.
  10 ITEMS-DATE-ENTERED     PIC X(26).
  10 ITEMS-DATE-SHIPPED     PIC X(10).
  10 ITEMS-ITEM-NOTES.
   49 ITEMS-ITEM-NOTES-LEN  PIC S9(04) COMP.
   49 ITEMS-ITEM-NOTES-TEXT PIC X(560).
************************************************************
* COBOL INDICATOR VARIABLES FOR TABLE
************************************************************
 01 DCLITEMS-NULL.
  10 ITEMS-PROD-ID-NULL      PIC S9(04) COMP.
  10 ITEMS-DATE-SHIPPED-NULL PIC S9(04) COMP.
  10 ITEMS-ITEM-NOTES-NULL   PIC S9(04)COMP.
************************************************************
* THE NUMBER OF COLUMNS DESCRIBED BY THIS DECLARATION IS 9
************************************************************

Example 2

In this example, change the prefix to a user value of "HV" instead of using the table name as prefix and generate indicator values with a suffix of IND.

The COBOL DECLARATION part of copybook file would look something like this:

************************************************************
* COBOL DECLARATION FOR TABLE DEMO.ITEMS
************************************************************
 01 DCLITEMS.
  10 HV-ORD-NO           PIC S9(09) COMP.
  10 HV-ITEM-NO          PIC S9(04) COMP.
  10 HV-PROD-ID          PIC X(4).
  10 HV-QTY-ORDERED      PIC S9(04) COMP.
  10 HV-QTY-SHIPPED      PIC S9(04) COMP.
  10 HV-AMT-EACH         PIC S9(05)v9(02) COMP-3.
  10 HV-DATE-ENTERED     PIC X(26).
  10 HV-DATE-SHIPPED     PIC X(10).
  10 HV-ITEM-NOTES.
   49 HV-ITEM-NOTES-LEN  PIC S9(04) COMP.
   49 HV-ITEM-NOTES-TEXT PIC X(560).
************************************************************
* COBOL INDICATOR VARIABLES FOR TABLE
************************************************************
 01 DCLITEMS-IND.
  10 HV-PROD-ID-IND      PIC S9(04) COMP.
  10 HV-DATE-SHIPPED-IND PIC S9(04) COMP.
  10 HV-ITEM-NOTES-IND   PIC S9(04) COMP.
************************************************************
* THE NUMBER OF COLUMNS DESCRIBED BY THIS DECLARATION IS 9
************************************************************

Example 3

In this example, change the prefix to a user value of "FIELD" and generate numbered fields instead of column names. Use configuration default instead of specifying CBL for language.

The COBOL DECLARATION part of copybook file would look something like this:

************************************************************
* COBOL DECLARATION FOR TABLE DEMO.ITEMS
************************************************************
 01 DCLITEMS.
  10 FIELD-001       PIC S9(09) COMP.
  10 FIELD-002       PIC S9(04) COMP.
  10 FIELD-003       PIC X(4).
  10 FIELD-004       PIC S9(04) COMP.
  10 FIELD-005       PIC S9(04) COMP.
  10 FIELD-006       PIC S9(05)v9(02) COMP-3.
  10 FIELD-007       PIC X(26).
  10 FIELD-008       PIC X(10).
  10 FIELD-009.
   49 FIELD-009-LEN  PIC S9(04) COMP.
   49 FIELD-009-TEXT PIC X(560).
************************************************************
* COBOL INDICATOR VARIABLES FOR TABLE
************************************************************
 01 DCLITEMS-NULL.
  10 FIELD-003-NULL PIC S9(04) COMP.
  10 FIELD-008-NULL PIC S9(04) COMP.
  10 FIELD-009-NULL PIC S9(04) COMP.
************************************************************
* THE NUMBER OF COLUMNS DESCRIBED BY THIS DECLARATION IS 9
************************************************************

Example 4

In this example, create the file ITEMS.PLI from table DEMO.ITEMS in database DB2DEMO and prefix all field names with the table name. Language is PL/I.

The DECLARE TABLE part of copybook file would look something like this:

/*-------------------------------------------------------*/
/*  MFHCODCL OPTIONS:                                    */
/*   DATABASE : DB2DEMO                                  */
/*   SCHEMA : DEMO                                       */
/*   PREFIX : TABLE NAME                                 */
/*-------------------------------------------------------*/
 EXEC SQL DECLARE DEMO.ITEMS TABLE
 ( ORD_NO    INTEGER   NOT NULL,
  ITEM_NO    SMALLINT  NOT NULL,
  PROD_ID    CHAR(4),
  QTY_ORDERED   SMALLINT  NOT NULL WITH DEFAULT,
  QTY_SHIPPED   SMALLINT  NOT NULL WITH DEFAULT,
  AMT_EACH    DECIMAL(7, 2) NOT NULL WITH DEFAULT,
  DATE_ENTERED   TIMESTAMP  NOT NULL WITH DEFAULT,
  DATE_SHIPPED DATE,  ITEM_NOTES   VARCHAR(560)
 );

The PL/I DECLARATION part of copybook file would look something like this:

/*-------------------------------------------------------*/
/*  PL/I DECLARATION FOR TABLE DEMO.ITEMS                */
/*-------------------------------------------------------*/
DECLARE
1 DCLITEMS,
 5 ITEMS_ORD_NO     BIN FIXED(31),
 5 ITEMS_ITEM_NO    BIN FIXED(15),
 5 ITEMS_PROD_ID     CHAR(4),
 5 ITEMS_QTY_ORDERED    BIN FIXED(15),
 5 ITEMS_QTY_SHIPPED    BIN FIXED(15),
 5 ITEMS_AMT_EACH     DEC FIXED(5,2),
 5 ITEMS_DATE_ENTERED    CHAR(26),
 5 ITEMS_DATE_SHIPPED    CHAR(10),
 5 ITEMS_ITEM_NOTES    CHAR(560) VAR;
/*-------------------------------------------------------*/
/*  PL/I INDICATOR VARIABLES FOR TABLE                   */
/*-------------------------------------------------------*/
DECLARE 1 DCLITEMS_NULL,
 5 ITEMS_PROD_ID_NULL    BIN FIXED(15),
 5 ITEMS_DATE_SHIPPED_NULL   BIN FIXED(15),
 5 ITEMS_ITEM_NOTES_NULL   BIN FIXED(15);
/*-------------------------------------------------------*/
/*  THE NO. OF COLUMNS DESCRIBED BY THIS DECLARATION IS 9*/
/*-------------------------------------------------------*/

Example 5

This example creates the file ITEMS.C from table DEMO.ITEMS in database DB2DEMO and prefixes all field names with the table name. Language is C.

The copybook file would look something like this:

/*-------------------------------------------------------*/
/*  MFHCODCL OPTIONS:                                    */
/*   DATABASE : DB2DEMO                                  */
/*   SCHEMA : DEMO                                       */
/*   PREFIX : TABLE NAME                                 */
/*  C HOST VARIABLES FOR TABLE DEMO.ITEMS                */
/*-------------------------------------------------------*/
EXEC SQL BEGIN DECLARE SECTION;
struct dclitems
{
 long   items_ord_no;
 short   items_item_no;
 char   items_prod_id[4];
 short   items_qty_ordered;
 short   items_qty_shipped;
 double  items_amt_each;
 char   items_date_entered[26];
 char   items_date_shipped[10];
 struct {
    short len
    char data[560];
   }  items_item_notes;
/*-------------------------------------------------------*/
/*   C INDICATOR VARIABLES FOR TABLE                     */
/*-------------------------------------------------------*/
 short   items_prod_id_null;
 short   items_date_shipped_null;
 short   items_item_notes_null;
 };
EXEC SQL END DECLARE SECTION;
/*-------------------------------------------------------*/
/*  THE NO. OF COLUMNS DESCRIBED BY THIS DECLARATION IS 9*/
/*-------------------------------------------------------*/
Parent topic: DCLGEN


Exporting Data

Once you have created SQL tables, you need data to test your applications. You may also need to distribute data to other PCs or to send data back to the mainframe. IBM and other vendors provide products to do this. However, if you have not installed one of these products, moving data around can be a problem.

Host Compatibility Option supplies you with an Export Data tool that you can combine with DB2 Connect, IBM's DRDA gateway, giving you a relatively inexpensive way of moving data between mainframe databases and PCs .

  • Limitations
  • Command Line Interface
Parent topic: HCO Tools
Related concepts
Downloading Data to Load Tables


Limitations

The Export Data tool has the following limitations:

  • All columns and rows in a table are exported. There is no ability in this tool to limit the data or rows exported.
  • Export formats WSF (Lotus worksheet) and IXF (mainframe) are not supported
  • IXF and DEL files are exported using IBM's EXPORT application programming interface. Some options of the API are not supported. See IBM's DB2 LUW Command Reference for list of all available options.
  • DSNTIAUL is exported using a SELECT statement, so large tables may take a while to process
  • LOB data types are not supported in DSNTIAUL format
  • LOB data types are generated as part of file in IXF and DEL formats. See IBM's DB2 LUW Command Reference for other limitations.

If you need to restrict rows and/or columns exported, you can use the IBM command line processor, DB2 or the IBM Control Center to export data. See IBM's DB2 LUW Command Reference for more details on how to use the IBM Control Center.

Parent topic: Exporting Data


Command Line Interface

Syntax

mfhco export db=databasename tbl=table file=filename
    [fmt=format] [log=logfile] [chardel=chardelimiter] [coldel=coldelimiter]
       [date=dateformat] [plus=sign]

Syntax Rules

  1. At least one space must occur before each parameter in the command.
  2. There must be an equal sign (=) between parameters and their values.
  3. If you omit parameters that have a default value, Host Compatibility Option uses the default value.

Parameters

export | Parameter to invoke Export Data command line processor. Parameter is positional.
databasename | Name of the databae to connect to.
table | Name of table to be exported. Can include both schema and table name.
filename | Filename to export data to.
format | Format in which to export data. Valid values are IXF, DEL, and DSNTIAUL. You can use DSN for DSNTIAUL.
logfile | File to write processing messages to. If this parameter is not specified, a logfile is created with a default logfile name using the project name.
chardelimiter | Delimiter used to enclose character data when export format DEL specified. Default is double quotes (").
coldelimiter | Delimiter used to indicate the end of column data when export format DEL is specified. Default is comma (,).
dateformat | Format to export date fields in if exporting data in DSNTIAUL or DEL format. Default is format for your country. Valid values for DSNTIAUL are ISO, USA, EUR and JIS. ISO is the only valid option for DEL format.
sign | Generate positive numeric data with plus signs when exporting data in DEL format. Valid values are "Y" for yes to generate plus signs or "N" to not generate plus signs. Default is "Y".

Comments

You can also run the Export Data tool as a batch function.

Example

mfhco export db=db2demo fmt=ixf file=product.ixf tbl=demo.product log=export.log
Parent topic: Exporting Data


Importing Data

The Import Data tool is designed for programmers who need sample data for testing. This tool is not intended to be used to load large quantities of data. If you want to load large quantities of data, you should contact IBM or other third-party vendors who provide a number of products that can handle this better than Host Compatibility Option. You should take care in using this tool to ensure that the database does not become unusable. You should back up your data regularly to provide a means of recovering from loss of data.

  • Limitations
  • Command Line Interface
Parent topic: HCO Tools
Related concepts
Downloading Data to Load Tables


Limitations

The Import Data tool has the following limitations:

  • Data for all columns in a table must be in import file. There is no ability in this tool to limit the column data being inserted.
  • Import formats WSF (Lotus worksheet) and IXF (mainframe) are not supported.
  • IXF and DEL files are imported using IBM's IMPORT application programming interface. Some options of the API are not supported. See IBM's DB2 LUW Command Reference for list of all available options.
  • DSNTIAUL files are converted to ANSI delimited format and then use the DEL IMPORT API.
  • LOB data types are not supported in DSNTIAUL format.
  • LOB data types generated as part of file in IXF and DEL formats. See IBM's DB2 LUW Command Reference for other limitations.
Parent topic: Importing Data


Command Line Interface

Syntax

mfhco import db=databasename tbl=tablename file=filename [fmt=format]
    [log=logfile] [chardel=chardelimiter] [coldel=coldelimiter]
        [date=dateformat] [plus=sign]

Syntax Rules

  1. At least one space must occur before each parameter in the command.
  2. There must be an equal sign (=) between parameters and their values.
  3. If you omit parameters that have a default value, Host Compatibility Option uses the default value.

Parameters

import | Invokes the Import Data command-line processor. This parameter is positional.
databasename | Name of the database to import to.
tablename | Name of table to be imported. You can specify both the schema and the table name, separated with a period.
filename | Filename to import data to.
format | Format to import data. Valid values are IXF, DEL, and DSNTIAUL. You can use DSN for DSNTIAUL.
logfile | File to write processing messages to. If this parameter is not specified, a logfile is created with a default logfile name iusing the project name.
chardelimiter | Delimiter used to enclose character data when import format is DEL specified. Default is double quotes (").
coldelimiter | Delimiter used to indicate the end of column data when import format DEL is specified. Default is comma (,).
dateformat | Format to import date fields in if importing data in DSNTIAUL or DEL format. Default is the format for your country. Valid values for DSNTIAUL are ISO, USA, EUR, and JIS. ISO is only valid option for DEL format.
sign | Generate positive numeric data with plus signs when importing data in DEL format. Valid values are "Y" for yes to generate plus signs or "N" to not generate plus signs. Default is "Y".

Comments

The Import Data tool can also be run as a batch function.

Example

mfhco import db=db2demo fmt=dsn tbl=demo.product file=product.dsn chardel=' log=import.log
Parent topic: Importing Data


Compiling and Run Time

  • Compiling DB2 Programs with HCO
  • Run-time Services
Parent topic: Host Compatibility Option (HCO)


Compiling DB2 Programs with HCO

The DB2 External Compiler Module allows programs checked with CHARSET(EBCDIC) directive to access SQL tables using DB2 LUW. The DB2 ECM generates code to convert all character data (columns defined as CHAR or VARCHAR) from EBCDIC to ANSI before storing it in DB2 LUW tables and conversely converts it from ANSI to EBCDIC on all retrievals from DB2 LUW tables.

This means that other products such as Microsoft Excel can still be used to access data stored in the tables.

Note: If your application contains character columns defined as FOR BIT DATA, and the data stored in the columns is not ANSI, you must define the host variable with the DECLARE hostVariableName FOR BIT DATA statement. Otherwise, the results are unpredictable.
  • DDL Processing
  • Collating Sequence For Data
  • Invoking the DB2 ECM
  • Error Messages When Compiling Program
Parent topic: Compiling and Run Time


DDL Processing

The DB2 ECM has the ability to handle DB2 syntax DDL statements within programs. DDL statements are converted automatically to DB2 LUW syntax.

Parent topic: Compiling DB2 Programs with HCO
Related concepts
Product Specifications


Collating Sequence For Data

If you are merging data from multiple sources using EBCDIC, you need access to SQL tables that are stored in databases created with the correct collating sequence. To get the data to come out in the correct sort sequence or to be included correctly when specified in WHERE clauses, all tables that are used with this pre-processor must be created in a database that specifies the EBCDIC collating sequence. See the chapter Create Database for more details on creating databases with EBCDIC collating sequences.

Parent topic: Compiling DB2 Programs with HCO
Related concepts
Create Database


Invoking the DB2 ECM

When you compile your programs, the DB2 ECM must be invoked to add the additional code needed to do the ANSI to EBCDIC translations as well as translate the EXEC SQL statements into database API calls.

Parent topic: Compiling DB2 Programs with HCO
Related concepts
Compiling
Related reference
DB2 Compiler Directive Options


Error Messages When Compiling Program

There are two significant differences when using DB2 LUW versus mainframe DB2. The first is that you have to connect to the database before you can compile a program. With mainframe DB2 you can pre-compile a program without DB2 being active. The second major difference is that all columns and tables referenced in the program must be created in the database before a program can be compiled whereas with mainframe DB2 they don't have to be. In both cases, the mainframe DB2 pre-compiler uses the DECLARE TABLE information in an SQL INCLUDE copybook to determine valid syntax as opposed to DB2 LUW which uses DB2 system catalog information to validate statements. In either case, a SQL Error could result using DB2 DB2 LUW is basically compatible with DB2 for z/OS, with some exceptions in DML syntax and functions supported and certain DDL statements that are hardware/operating system specific. Host Compatibility Option tries to address some of the main areas of incompatibility where possible by converting DB2 for z/OS SQL statements to supported DB2 LUW syntax. .

In addition, if invalid SQL syntax is encountered while compiling your program, a SQL error is also generated for each statement in error. The text that is associated with the SQL error is displayed using the following format:

DB0100e SQLnnnnnn error-text

Where DB indicates error resulted from DB2 ECM (the error number is always 0100); e is the error severity, and SQLnnnnnn is the SQL error code (nnnnnn may vary between 2 and 6 characters).

Parent topic: Compiling DB2 Programs with HCO


Run-time Services

In addition to the tools described in earlier topics, Host Compatibility Option provides other tools that are only invoked when you run or debug your SQL program. Such run-time tools include the following:

  • MFHCOCDS - A routine to re-map SQLCODEs from one value to another
  • DSNTIAR and DSNTIAC- Routines to return text messages for a SQLCODE
  • MFHCOEBC - A routine that converts character data between ANSI and EBCDIC and, optionally, handles SISO characters for double byte character data in the mfhcolib.lbr file

All of these tools are stored in the file mfhcolib.lbr. You do not need to copy this file to any other location if you are running under this COBOL development system.

  • MFHCOCDS Tool
  • DSNTIAR and DSNTIAC Tools
  • MFHCOEBC
Parent topic: Compiling and Run Time


MFHCOCDS Tool

DB2 LUW generally returns the same SQLCODE as DB2 for common errors such as no more rows in table or duplicate index entry. MFHCOCDS is a mapping facility provided to support the translation of DB2 LUW SQLCODE's to their DB2 equivalent for special situations where the mappings are not the same. To enable this facility, create a line sequential text file named mfhcocds.sql in the same directory where your compiled application resides. In the mfhcocds.sql file, identify the DB2 LUW SQL code to be replaced and its equivalent DB2 SQL code to be returned to the application program. Use the following format:

DB2LUWcode DB2SQLcode

For example, if you want to change the SQLCODE -30080 (communication error) to -902 (system error), place the following line of text in the file:

-30080 -902
  • Dynamic Bind Utility
Parent topic: Run-time Services


Dynamic Bind Utility

The Dynamic Bind Utility enables you to bind dynamically programs that get -805 or -818 SQL errors.

A good example of how you can take advantage of this utility is if your organization has a number of common SQL routines that they share but they use these routines against multiple databases. Someone within the organization, usually the DBA, would have to bind these common modules against each database for them to be used. Another option would be to compile each of these routines against each database. If someone changed one of the common routines, the bind/compile process would have to be repeated for each database!

Host Compatibility Option offers a third option. When you compile an SQL routine, Host Compatibility Option passes additional information to the MFHCOCDS routine when an SQL error occurs. If a -805 or -818 error occurs, Host Compatibility Option tries to find the bind file associated with the routine in error and then bind the package against the database to which the program is currently connected. A message is then displayed reporting whether the bind was successful. The original SQL error is returned to your program so that you need to restart the program or, if you are animating the program, re-execute the SQL statement that originally failed.

To implement this feature, you need to:

  • Re-compile all common SQL routines with the DB2 directive BIND

The BIND directive creates a bind file for each common routine. When the -805 or -818 SQL error occurs, Host Compatibility Option looks for the bind file using the following search sequence:

  1. Current folder
  2. Folder specified by the HCOBND environment variable

To take advantage of the dynamic bind utility, set the HCO_AUTOREBIND environment variable as follows:

SET HCO_AUTOREBIND=ON

You can still use the HCO BIND tool to quickly re-bind all applications.

Parent topic: MFHCOCDS Tool


DSNTIAR and DSNTIAC Tools

The Host Compatibility Option DSNTIAR and DSNTIAC routine uses a similar parameter list to the one used by the IBM DSNTIAR and DSNTIAC routines on the mainframe. It is used to convert SQL return codes into more meaningful error messages.

The format for calling DSNTIAR is:

CALL 'DSNTIAR' USING sql-comm-area,
                     error-message,
                     error-rec-length

where:

Parameter | Description
sql-comm-area | SQL communications area. Usually set to SQLCA.
error-message | A group item in the Working-Storage Section where the error message is returned. The work area consists of two items, the first being a field defining the length of the error message to be returned. Fields have a value > 0 and < 1,000. The second item is the work area where the error message returns.
error-rec-length | The logical error line length. If the second item were defined as a table, this field would contain the length of each element within the table. Must have a length <= error message length.

The format for calling DSNTIAC is:

CALL 'DSNTIAC' USING sql-comm-area,
                     error-message,
                     error-rec-length

The parameters are same as with DSNTIAR.

  • DSNTIAR Tool Example
  • Return Codes
Parent topic: Run-time Services


DSNTIAR Tool Example

The following is an example of how to code a call to DSNTIAR:

01 ERR-MSG.
    05 ERR-MSG-LTH  PIC S9(04) COMP VALUE +280.
    05 ERR-MSG-TBL  PIC X(70) OCCURS 4 TIMES.
01 ERR-LINE-LTH   PIC S9(09) COMP VALUE +70.
 ...
CALL 'DSNTIAR' USING SQLCA, ERR-MSG, ERR-LINE-LTH
Parent topic: DSNTIAR and DSNTIAC Tools


Return Codes

The following is a list of codes returned after calling DSNTIAR or DSNTIAC.

Code | Description
0 | No error
8 | Logical error line length > error message length
12 | Error message length > 1,000
16 | Critical error - invalid parameter passed to routine or missing parameter
-1 | There is inadequate memory in the system for message formatting services to function. Requested message is not returned.
-2 | The SQLCA does not contain a non-zero SQLCODE
-3 | The SQLCA does not refer to a valid message
-4 | The logical error line length is less than zero
Parent topic: DSNTIAR and DSNTIAC Tools


MFHCOEBC

This routine converts each character column accessed by your program from ANSI to EBCDIC.

Host Compatibility Option automatically detects whether your environment supports DBCS data. If so, it examines all character strings for SISO characters.

Parent topic: Run-time Services


COBSQL

You can use COBSQL to access the SQL functions offered by the Oracle, Sybase or Informix Database Management System (DBMS) by embedding SQL statements within your COBOL program in the form:

EXEC SQL
   SQL statement
END-EXEC

and then using the Oracle, Sybase or Informix precompiler to process the embedded SQL before passing the program to the COBOL Compiler. The database precompiler replaces embedded SQL statements with the appropriate calls to database services. Other additions are made to the source code to bind COBOL host variables to the SQL variable names known to the database system.

The advantage of embedding SQL in this way is that you do not need to know the format of individual database routine calls. The disadvantage is that the source code that you see when you debug your program is that output by the precompiler and not the original embedded SQL. You can overcome this disadvantage by using COBSQL.

COBSQL provides an integrated interface between Micro Focus COBOL and the third-party standalone precompiler, enabling you to debug a program containing EXEC SQL statements and display your original source code rather than the code produced by the precompiler.

Note:
  • You should only use COBSQL if you are already using it with an earlier version of a Micro Focus COBOL product and want to migrate your application to this system. For any other type of embedded SQL development, we recommend that you use OpenESQL.
  • You cannot use COBSQL with programs that have been compiled with the Compiler directive SOURCEFORMAT"FREE". You must use OpenESQL if your programs are free format.
  • Using COBSQL
  • Using the CP Preprocessor to Expand Copybooks
  • National Locale Support (NLS)
  • Examples
  • Troubleshooting
Parent topic: Database Access
Related concepts
Database Access Preprocessors
Compiling SQL Applications
Creating Debug Files
Related reference
SOURCEFORMAT


Using COBSQL

To use COBSQL, specify the PREPROCESS(cobsql) Compiler directive when you compile your program. All directives following it are passed from the Compiler to COBSQL. You can specify Compiler directives by using $SET statements in your program or via the Additional Directives field, located on the COBOL tab of your project's Properties dialog box.

To terminate the directives to be passed to COBSQL, you must use the ENDP COBOL directive.

END-C and ENDP have the following effect:

  • Directives placed before END-C pass to COBSQL
  • Directives placed between END-C and ENDP pass via COBSQL to the precompiler
  • Directives placed after ENDP pass to the COBOL compiler. Therefore, without the ENDP directive, compiler directives continue to pass to COBSQL rather than to the COBOL compiler.
preprocess(cobsql) cobsqltype=database_product end-c
    comp5=yes endp;

where database_product is one of Oracle, Sybase or Informix. For example, for Oracle:

preprocess(cobsql) cobsqltype=oracle end-c comp5=yes endp;

Because the system sets extra default COBOL directives, the above line is required when putting directives into the Additional Directives field.

Examples

cobol testprog p(cobsql) cobsqldirectives END-C precompileroptions ENDP compilerdirectives;

cobol testprog p(cobsql) csqlt=ora makesyn end-c xref=yes mode=ansi endp list();

·

The COBSQL directives, terminated by end-c, are csqlt=ora and makesyn. The precompiler directives (in this case, Pro*COBOL), terminated by endp, are xref=yes and mode=ansi. The Compiler directive is list().

  • Specifying Directives
  • COBOL Directives
  • Building COBSQL Applications
Parent topic: COBSQL


Specifying Directives

You specify directives to COBSQL as if they were Compiler directives, but you must put them after the directive PREPROCESS(cobsql).

It is also possible to add the COBSQL directives to the directives file cobol.dir.

Note:
  • Each line in the cobol.dir file may contain one or more compiler directives
  • Don't split a compiler directive across multiple lines in the cobol.dir file
  • When the compiler encounters either P(cobsql) or PREPROCESS(cobsql) in the cobol.dir file, the compiler passes the rest of the line to the pre-processor until it reaches an ENDP
  • The compiler treats the PREPROCESS directive and all the options that follow, up to the ENDP, as a single compiler directive. Therefore, the PREPROCESS directive and all the options must all appear on a single line in the cobol.dir file.

Alternatively, you can put COBSQL and precompiler directives in a file, cobsql.dir. This file should reside either in the current directory or in a directory specified by the environment variable COBDIR. COBSQL searches the current directory and then along the COBDIR path for a cobsql.dir file. Once COBSQL finds a cobsql.dir file, it stops searching. So, if you have a cobsql.dir file in the current directory, the COBDIR path is not searched.

Note:
  • Each line in the file cobsql.dir can contain one or more COBSQL directives
  • Since COBOL does not read the file cobsql.dir, don't put COBOL compiler directives into the file
  • Don't split a COBSQL directive across multiple lines in the file cobsql.dir
  • When COBSQL encounters either END-C, END or END-COBSQL in the cobsql.dir file, the rest of the line passes to the database precompiler
  • The options to be passed to the database precompiler must all appear on a single line in the file cobsql.dir

COBSQL processes cobsql.dir first and then any directives specified via the Build Settings screen or command line.

A number of the directives can be reversed by placing NO in front of them, for example, DISPLAY can be reversed using NODISPLAY. By default, the NO version of a directive is set.

You can specify shortened versions of some of the directives. If applicable, the shortened version of a directive is shown in the lists below, immediately after the full length version.

Some directives can be passed to COBSQL by the COBOL Compiler (see the section COBOL Directives below), removing the need to specify common directives more than once. Directives that can be retrieved from the COBOL Compiler are processed before COBSQL directives.

For example, in the following:

cobol testprog p(cobsql) csqlt=ora makesyn end-c
      xref=yes mode=ansi endp list();
  • The COBSQL directives, terminated by end-c, are csqlt=ora and makesyn
  • The precompiler directives (in this case, Pro*COBOL), terminated by endp, are xref=yes and mode=ansi
  • The Compiler directive is list().
Parent topic: Using COBSQL


COBOL Directives

The following are COBOL directives that the Compiler also passes to COBSQL:

Directive | Description
[NO]BELL | Controls whether COBSQL sounds the bell when an error occurs.
[NO]BRIEF | Controls whether COBSQL shows SQL error text as well as the error number.
[NO]CONFIRM | Displays accepted/rejected COBSQL directives.
[NO]LIST | Saves the precompiler listing file (.lis).
[NO]WARNING | Determines the lowest severity of SQL errors to report.
Parent topic: Using COBSQL


Building COBSQL Applications

It is beyond the scope of this document to list the database support modules that are required when shipping on a COBSQL application. It is assumed that the end-user machine already has all the required support modules installed and that it is correctly configured to communicate with the database server.

When linking COBSQL applications, use the import library csqlsupp.lib. This resolves the calls inserted by COBSQL to the COBSQL init and stop run modules. The calls are actually handled by the module csqlsupp.dll which needs to be shipped with the application. This general support module is required for both Oracle and Sybase applications.

Specify the library csqlsupp.lib. To do this, go to your project's properties page, COBOL tab, and click Link Settings. Type csqlsupp.lib into the Link with libs field.

If you split the application into a main exe and a number of sub DLLs, then you only need to link csqlsupp.lib into the modules that you have compiled with the COBSQL directives CSTART or CSTOP.

If you compile all programs with CSTART or CSTOP, then you must link csqlsupp.lib into all the modules. Linking csqlsupp.lib to each module causes each module to be slightly larger than required. Only one version of csqlsupp.dll is loaded when the application runs.

If you compile the main program only with CSTART and CSTOP, then you need to link in the library csqlsupp.lib with the main program only. Any program that you compile with either the CSTART or the CSTOP COBSQL directive, you then need to link csqlsupp.lib with the module for that program.

Parent topic: Using COBSQL


Using the CP Preprocessor to Expand Copybooks

The complete set of methods used within COBOL to manipulate copybooks is not available with database precompilers and COBSQL itself cannot handle included copybooks. These problems can be overcome by using the Micro Focus Copybook Preprocessor (CP).

CP is a preprocessor that provides other preprocessors, such as COBSQL, with a mechanism for handling copybooks. CP follows the same rules as the COBOL Compiler for handling copybooks, so any copybook-related Compiler directives are automatically picked up and copybooks are searched for using the COBCPY environment variable. CP also expands the following statements:

EXEC SQL
   INCLUDE ...
END-EXEC

Oracle uses .pco and .cob extensions, Sybase uses .pco and .cbl extensions and Informix uses .eco, .cob and .mf2 extensions.

Oracle and Sybase:

For CP to resolve copybooks and include statements correctly, use the following COBOL Compiler directives for Sybase and Oracle:

copyext (pco,cbl,cpy,cob) osext(pco)

Informix:

For Informix, use:

copyext (eco,mf2,cbl,cpy,cob) osext(eco)

COBSQL can call CP to expand copybooks before the database precompiler is invoked. This means that all the copy-related commands are already resolved so that it appears to the database precompiler that a single source file is being used.

The other advantage of using CP is that it makes copybooks visible when debugging.

When CP sees an INCLUDE SQLCA statement, it does the following:

  • Searches for a file called sqlca.ext in the current directory, where ext is any copybook extension as set up by the OSEXT and COPYEXT Compiler directives. By default these are .cbl and .cpy.
  • Searches for sqlca.ext along the COBCPY path.
  • An example sqlca.cpy file is provided in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source directory. If the SQLCA file supplied by the database vendor is not located on the COBCPY path, this example of the SQLCA will be used.
Note: Using the file sqlca.cpy can result in errors when the program is run.

You can specify the CP preprocessor's SY directive to prevent CP expanding the SQLCA include file, for example:

preprocess(cobsql) preprocess(cp) sy endp

You should always use CP's SY directive when processing Sybase code because Sybase expects to expand the SQLCA itself.

As Oracle can produce code with either COMP or COMP-5 variables, it has two sets of copybooks. The standard sqlca.cob, oraca.cob and sqlda.cob all have COMP data items. The sqlca5.cob, oraca5.cob and sqlda5.cob files have COMP-5 data items. If you are using the comp5=yes Oracle directive, you must set the COBSQL directive MAKESYN to convert the COMP items in the SQLCA to COMP-5.

If CP produces errors when attempting to locate copybooks, check to make sure that the OSEXT and COPYEXT Compiler directives are set correctly. COPYEXT should be set first and should include as its first entry the extension used for source files (.pco or .eco, for example).

If these are set correctly, ensure that the copybook is either in the current directory or in a directory on the COBCPY path.

When using CP in conjunction with COBSQL, SQL errors inside included copybooks will be reported correctly. Without CP, the line counts will be wrong, and the error will either go unreported or will appear on the wrong line.

Parent topic: COBSQL
Related reference
CP Preprocessor


National Locale Support (NLS)

COBSQL error messages can be displayed in different languages depending on the setting of the LANG environment variable.

Most database clients include some NLS capability but their requirements for the setting of the LANG environment variable differ from those of this COBOL system. We recommend, therefore, that you use the alternative environment variable, COBLANG, which only affects this COBOL system, allowing the LANG environment variable to be used by the database client.

For COBLANG to work correctly, mflangnn.lbr, where nn is the setting of COBLANG, must be available in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory. For example, if COBLANG=05 (UK NLS messages), the file mflang05.lbr must be available.

The COBSQL error message file cobsql.lng has been translated into a number of different languages and can be found with the COBOL NLS message files. If there is not an error message cobsql.lng for the current setting of LANG, then the default error message file is used.

Note: COBSQL does not translate any error messages produced by the database precompilers.
Parent topic: COBSQL


Examples

The following examples show, for the Oracle and Sybase precompilers, command lines which can be entered at the Net Express command prompt to compile a program using COBSQL.

Oracle
cobol sample.pco anim nognt preprocess(cobsql)
   cstart cstop CSQLT=ORA end-c comp5=yes endp;
Sybase
cobol example1.pco confirm preprocess(cobsql)
   cstop csp cobsqltype=sybase preprocess(cp) sy endp;
Parent topic: COBSQL


Troubleshooting

Initially, you should check each of the items outlined below.

  • Basic network connectivity

    Forget SQL, and determine whether the client and server are communicating. For TCP/IP, check whether you can ping the server from the workstation and vice versa. If host names don't work, try raw IP addresses. For PC protocols, try mounting a network drive or sending messages.

  • SQL networking software

    Check that the SQL networking software is "talking" correctly to the network software. Many SQL vendors supply a ping utility which will show whether the SQL network is set up correctly.

  • Interactive SQL

    If the SQL network is okay, try some interactive SQL. Most vendors supply a simple utility that allows you to enter SQL from the keyboard and view the results. Most vendors also supply a sample database that is useful for this purpose.

  • Standalone Precompiler

    Verify that the standalone precompiler works. There may be an icon or a command line for the precompiler. Verify that it can produce COBOL code correctly. It is normal for some sample applications to be supplied with the precompiler.

  • Preprocessed application

    Check that a preprocessed application runs okay. Pass the expanded program through the COBOL Compiler and then try to run it.

  • COBSQL with minimal directives

    Try COBSQL with minimal directives. Set up a project. Place the SQLCA copybook into the directory with the sample program (prior to running the precompiler), and see if this works.

If you continue to have problems, please contact Micro Focus Support. To help Technical Support locate the cause of the problem:

  • Use the COBSQL directive SQLDEBUG
  • Send a zip file containing the following to Technical Support:
    • The original source
    • The expanded source (as produced by the database precompiler)
    • The trace file (which will have the extension .trc)
    • The database list file (which will normally have the extension .lis)
    • The command line debug file (which will have the extension .sdb)
    • The project file (which has the same name as the project but with the extension .app)
    • The COBSQL directive settings used
  • Common Problem Areas
  • Oracle Considerations
  • Sybase Considerations
  • Informix Considerations
Parent topic: COBSQL


Common Problem Areas

If you cannot locate the source of the problem, check each of the following:

  • Latest versions

    Ensure that you are using the latest version of all the products involved.

  • COMP/COMP-5 Conflicts

    Check the vendor's documentation and example applications.

  • Configuration

    Check that environment variables, PATH and configuration file settings are set up correctly.

  • Directives

    By default, COBSQL does not display the command line it passes to the database precompiler. Setting the SQLDEBUG directive enables the command line to be displayed (you will need to do this if the precompiler gives command line errors). Possible causes of command line errors are that the directives to be passed to the precompiler are incorrect or that the length of the precompiler command line has been exceeded.

  • Memory

    COBSQL may display the following error because the database precompiler has terminated unexpectedly:

    * CSQL-F-021: Precompiler did not complete -- Terminating

    This may be because the Operating System has run out of memory attempting to execute the database precompiler.

  • Missing output files

    COBSQL may display the following errors because it cannot find the precompiler's output file. This may be because the precompiler did not produce an output file. The normal reason for this is that the precompiler hit a fatal error which meant it could not create the output file.

    * CSQL-E-024: Encountered an I/O on file filename
* CSQL-E-023: File Status  3 / 5

    where filename is the name of the file produced by the database precompiler.

  • Premature end of expanded source

    If COBSQL reports the error "Premature end of expanded source" and the precompiler runs correctly, this indicates that COBSQL has not been able to match the original source lines with the lines produced by the database precompiler.

    Another possible reason for COBSQL reporting this error is that the program does not contain any SQL. Generally, if the database precompiler does not come across any SQL it will abort the creation of its output file part way through, causing this error to be displayed.

Parent topic: Troubleshooting


Oracle Considerations

If you are troubleshooting Oracle problems, consider the following:

  • The following Oracle precompiler options can have a marked effect on the behavior and the memory requirements of an Oracle application. We recommend that you take time to review your Oracle documentation before changing the setting of these directives.
    DBMS
HOLD_CURSOR
MAXOPENCURSORS
MODE
RELEASE_CURSOR
  • Within an Oracle program it is possible to use the ALTER SESSION command to change the OPTIMIZER_GOAL. This can have a profound effect on the performance of the application. Before using this syntax, we recommend that you consider what is the best optimisation for an application in the general case rather than for a particular SQL statement. If you need to change the performance of one particular statement, it is probably better to use HINTS. Consult your Oracle documentation for further information on ALTER SESSION, OPTIMIZER_GOAL and HINTS.
  • Oracle provides a method of reducing network access by using arrays within Embedded SQL statements. This enables the application to perform 'batch' SQL commands, in that more than one row can be acted upon in a single SQL statement. See the section Host Arrays in the chapter Host Variables for more details.

    The use of arrays enables an application, for example, to fetch ten rows at a time instead of one at a time. Oracle supply an example program (normally called sample3.pco) that uses an array to fetch multiple rows. Arrays are documented in the Pro*Cobol Supplement to the ORACLE Precompilers Guide.

  • Pro*Cobol treats BINARY host variables as though they had been defined with a picture clause of COMP. This means that BINARY items will also be converted to COMP-5 when the Pro*Cobol comp5=yes option is used.
  • Pro*Cobol always needs to be supplied with an include directive, unless the SQLCA copybook is in the current directory, because it needs to know the location of the SQLCA copybook. If this is not supplied, Pro*Cobol gives an error on filename.pco, where filename can be any string of eight characters.
  • When Pro*Cobol runs, it can generate useful information. When the COBSQL VERBOSE directive is used, COBSQL displays as much of this information as it can.

    To get the maximum information from Pro*Cobol, set the Pro*Cobol directive xref=yes. You can add this directive to the Pro*Cobol configuration file $ORACLE_HOME\PROxx\pcbcfg.cfg where:

    xx | is the Pro*Cobol version (for example, for Oracle 8.0 this is PRO80)
    $ORACLE_HOME | is the root directory for the Oracle installation on your machine
  • By using the COBSQL DISPLAY directive, the current Pro*Cobol directives can be seen on the screen. This will be followed by the statistical information created by Pro*COBOL.
  • If the COBOL LIST directive is used, COBSQL passes any information it has collected from the precompiler to the COBOL checker for inclusion at the the bottom of the COBOL listing.
  • Oracle 8 (and later) Directives for COBSQL
  • Migration and Development
  • Oracle 8 and Micro Focus COBOL
Parent topic: Troubleshooting


Oracle 8 (and later) Directives for COBSQL

To use COBSQL with Oracle 8 and later, you should use the following directives:

Directive | Description
CBL2ORA8 C28 | This puts calls into the Oracle 8 specific support modules ora8prot and ora8lib. Both of these modules are built into csqlsupp.dll.
COBSQLTYPE CSQLT | EXEC SQL preprocessor. Use the options ORACLE8 and ORA8 to use Pro*COBOL 8.x or later with COBSQL.
Parent topic: Oracle Considerations


Migration and Development

If you are migrating programs from Pro*COBOL 1.x to 8.x or later, you should be aware of the following:

  • Within the Data Division:
    • You should terminate all SQL statements with a period
    • Only ANSI comments are supported. Comments starting with *> in any column are not supported
  • Support for nested programs

    Define all inserted variables as GLOBAL including the data items inserted by COBSQL that support the EBCDIC to ASCII conversions.

  • Oracle 8 no longer requires a declare section as this can cause problems with the Oracle COMP to COMP-5 conversion.

    If the Oracle directive DECLARE_SECTION=NO is set (the default), Oracle converts all COMP, BINARY or COMP-4 data items to COMP-5.

    To limit the conversion of items to the declare section, set one of the following:

    • DECLARE_SECTION=YES or MODE=ANSI
    • The Pro*COBOL directive COMP5=NO and the COBSQL directive MAKESYN
  • Extra data types supported by Pro*COBOL 8.x or later are:
    • PACKED-DECIMAL

      These data items are treated in the same way as COMP-3 data items.

    • COMP-4
    • PIC 9(4) COMP / COMP-4 / BINARY / COMP-5
    • PIC 9(4) USAGE DISPLAY
    • PIC s9(4) USAGE DISPLAY SIGN TRAILING
    • PIC s9(4) USAGE DISPLAY SIGN TRAILING SEPARATE
    • PIC s9(4) USAGE DISPLAY SIGN LEADING
    • PIC s9(4) USAGE DISPLAY SIGN LEADING SEPARATE

      This type was previously supported as the Oracle DISPLAY datatype.

  • When working on x86 or x86-64 platforms, do not use the COBSQL directive NOMAKESYN, since this directive results in COMP host variables and on x86 and x86-64 platforms these items are incompatible with the native byte order expected by Oracle.
Parent topic: Oracle Considerations


Oracle 8 and Micro Focus COBOL

Pro*COBOL 8.x (or later) rejects some Micro Focus COBOL language extensions, data definitions and section headings:

  • All pointer data types
  • 88 level variables
  • Constants in a Value clause
  • Items defined as external-form
  • Local-Storage Section
  • Thread-Local-Storage Section

To overcome this you need to put these items into copybooks which are not opened by Pro*COBOL. However, this does not work if you use CP which expands copybooks before Pro*COBOL is invoked. This could cause a problem if you are using htmlpp which calls CP to expand copybooks. You must therefore invoke htmlpp before COBSQL.

For example, the following compile line works:

COBOL -k PROG P(HTMLPP) PREPROCESS(cobsql) CSQLT=ORACLE8

whereas this line does not:

COBOL -k PROG PREPROCESS(cobsql) CSQLT=ORACLE8 P(HTMLPP)

You must define at least one variable within the Working-Storage Section for Pro*COBOL to add its variables to the generated .cbl file.

Parent topic: Oracle Considerations


Sybase Considerations

Before using Sybase, you must make the following change to your system:

  • In the Sybase-supplied copybooks cobpub.cbl and sybhesql.cbl, change all COMP data items to COMP-5.

If you are troubleshooting Sybase problems, consider the following:

  • If CP is not used with COBSQL to locate copybooks, the copybook to be brought in by the Sybase precompiler needs to be fully qualified. The Sybase precompiler does not search for any extensions.
  • If the Sybase precompiler has problems locating the correct language to use to report messages on the client, check that the Sybase file, locales.dat is configured correctly.

    If the default setting for the client Operating System has been configured, but Sybase still reports national locale support errors, use the LANG environment variable to override the setting in the locales.dat file.

    For example if the Windows NT client was causing problems and the locales.dat file contained the following setting for Windows NT:

    [NT]
locale = default, us_english, iso_1
locale = enu, us_english, iso_1
locale = fra, french, iso_1
locale = deu, german, iso_1

    then the LANG setting for English would be:

    LANG=enu
  • It can be difficult to identify Sybase error messages. To help COBSQL identify them, you can modify the esql.loc file. Use a text editor to edit the esql.loc file to change the layout of the messages to the following:
    SYB-severity-number-text

    where the parameters are:

    SYB | A string which indicates to COBSQL that this is a modified Sybase error message.
    severity | Indicates the severity of the errror; some of the Sybase messages are only warnings rather than normal or fatal errors.
    number | A unique, four digit error number assigned to the Sybase error.
    text | The original Sybase error message.

    For example, a typical entry in the esql.loc file might be:

    9 = M_PRECLINE, "Warning(s) during check of query on line %1!."

    and this would be changed to read:

    9 = M_PRECLINE, "SYB-W-2009 Warning(s) during check of query on line %1!."

    It is recommended that you make a copy of esql.loc before altering it. Using the modified version, COBSQL can detect the full range of Sybase error messages.

    The location of esql.loc is dependent on the language and code page used. This is defined in the locales.dat file. If the definition of the default language for the AIX platform was as follows:

    [aix]
locale = C, us_english, iso_1
locale = En_US, us_english, iso_1
locale = en_US, us_english, iso_1
locale = default, us_english, iso_1

    The default langauge would be us_english, using the iso_1 code page, so the copy of esql.loc that is to be used is:

    /sybase-home/locales/messages/us_english/iso_1/esql.loc

    where sybase-home is the directory that the Sybase client is installed into.

    For more information on how Sybase uses and locates the different error message files, refer to your Sybase Client Reference Manual.

  • To use Sybping with different Sybase servers, each server should have a service defined. The Sybase product sqledit shows you how to enter the required information.
  • If the name of the server is not specified when connecting to Sybase, Sybase searches for an environment variable called DSQUERY. This can be set within the environment variable section of a project and enables different projects to connect to different Sybase servers.
  • When the Sybase precompiler runs, it can generate useful information. If the COBSQL directive VERBOSE is set, COBSQL displays as much of this information as it can.
  • By using the COBSQL DISPLAY directive, the statistical information created by the Sybase precompiler can be seen on the screen.
  • If the COBOL LIST directive is set, COBSQL passes any information it has collected from the precompiler to the COBOL checker for inclusion at the end of the COBOL listing.
  • The Sybase precompiler accepts programs that do not contain any SQL statements, and produces an output file. This means that all of the programs in a project can be compiled successfully. However, it also means that the Sybase precompiler inserts all the Working-Storage items and COBOL support code that it would insert for a program that contains Sybase SQL statements into a non-Sybase program. This makes the program larger, and may effect its performance.
  • The Sybase COBOL precompiler can be supplied separately to the Sybase System 11 Server. If this is the case, care must be taken when installing the Sybase COBOL precompiler as it is supplied with its own version of the Open Client support files and problems can arise if the two products have different versions of these files. In this situation, we strongly recommend that you contact Sybase support before proceeding with the installation of the Sybase System 11 COBOL precompiler.
  • You should take particular care if you are installing the Sybase client onto a machine that has the Server installed onto it (or vice versa). Installing the Sybase client only does not cause any problems.
Parent topic: Troubleshooting


Informix Considerations

  • Informix uses the .eco, .cob and .mf2 file extensions. For CP to resolve copybooks and include statements correctly, use the following COBOL Compiler directives:
    copyext(eco,mf2,cob,cpy,cbl) osext(eco)
  • Under UNIX, because COBSQL invokes the Informix precompiler, the INFORMIXCOB, INFORMIXCOBTYPE and INFORMIXCOBDIR environment variables all need to be setup before using COBSQL. For more information about these environment variables, refer to the Informix COBOL/ESQL Programmers Guide.
  • Informix only produces error messages in its list files. Normally the error message will contain the line the error occured on. If COBSQL cannot locate the line number from the error message, it will not report the error.
  • To run COBSQL correctly with Informix, the INFORMIXDIR environment variable should be set before using COBSQL.
Parent topic: Troubleshooting


How to...

  • OpenESQL Configuration Utility
  • OpenESQL Assistant
  • ADO.NET Connection Editor
  • To migrate a connection
Parent topic: Database Access


OpenESQL Configuration Utility

  • To start the OpenESQL Configuration Utility
  • To set a default for SQL(BEHAVIOR)
Parent topic: How to...


To start the OpenESQL Configuration Utility

  • Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Configuration > OpenESQL Configuration Utility.
Parent topic: OpenESQL Configuration Utility
Related reference
esqlconfig command
Related information
OpenESQL Configuration Utility


To set a default for SQL(BEHAVIOR)

  1. Start the OpenESQL Configuration utility.
  2. Select an option.
    Tip: Click Explain next to an option for further details on that option.
  3. Click Save.
Parent topic: OpenESQL Configuration Utility
Related reference
BEHAVIOR
Related information
OpenESQL Configuration Utility
Optimize for performance and mainframe compatibility
ANSI compliance
No change in default behavior and no optimization
Issue a warning at compile time
Issue an error at compile time
COBOL Program Migration Support


OpenESQL Assistant

  • To add a column to a query
  • To add all columns in a table to a query
  • To add an XML data source
  • To change a SELECT (cursor) query to do an array FETCH
  • To close a query
  • To close the OpenESQL Assistant
  • To connect to a data source
  • To connect to a different data source
  • To create a table join
  • To create an SQL query
  • To disconnect from a data source
  • To display column details
  • To embed an SQL query into a COBOL program
  • To generate a DCLGEN copybook
  • To generate a DELETE statement
  • To generate a SELECT (cursor) statement
  • To generate a SELECT (singleton) statement
  • To generate a SELECT DISTINCT (cursor) statement
  • To generate a SELECT DISTINCT (singleton) statement
  • To generate a DECLARE DATATABLE statement
  • To generate an INSERT statement
  • To generate an UPDATE statement
  • To generate and embed auxiliary code
  • To perform an aggregate function
  • To refresh the list of data sources
  • To remove a table from a SELECT query
  • To run a query
  • To set OpenESQL Assistant options
  • To sort returned data (an ORDER BY clause)
  • To specify search criteria (a WHERE clause)
  • To start the OpenESQL Assistant
  • To view data source properties
Parent topic: How to...


To add a column to a query

  1. In the OpenESQL Assistant, identify a column in the tree view that belongs to a table you have selected for your query.
  2. Check the box next to the column to add it to the query.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Selecting Columns
Related tasks
To add all columns in a table to a query
To create an SQL query


To add all columns in a table to a query

  1. In the OpenESQL Assistant, identify a table in the tree view that has been selected for the query and contains the columns you want to add to the query.
  2. Right-click the table name.
  3. Click Select All Columns.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Selecting Columns
Related tasks
To add a column to a query


To add an XML data source

  1. Start the OpenESQL Assistant.
  2. Right-click on the data source list.
  3. Click Add XML Data Source.
  4. Browse to the XML file you want to use as a data source and double-click to select it. This file must contain an embedded XML schema for the file as well as data.
Note:

This feature is available only when you set the following Visual Studio options for OpenESQL Assistant as follows:

  • Mode option set to ADO.NET
  • Generate option set to EXEC ADO - disconnected model
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Setting OpenESQL Assistant Options
OpenESQL Assistant
Setting OpenESQL Assistant Options
Related tasks
To start the OpenESQL Assistant
Related reference
OpenESQL Assistant - Options
OpenESQL Assistant - Main Window


To change a SELECT (cursor) query to do an array FETCH

  1. Check your OpenESQL Assistant configuration and be sure that the Use SQL TYPE check box is unchecked. This is necessary because the compiler does not support OCCURS clauses defined with SQL TYPE host variables.
  2. In the IDE, open the project that contains the program that contains the SELECT (cursor) query you want to modify.
  3. Open the appropriate program in the program editor.
  4. Locate the FETCH statement in the code generated for SELECT (cursor) statements.
  5. Remove the comments that appear before and between the PERFORM and END-PERFORM statements.
  6. Place your cursor between the PERFORM and END-PERFORM statements.
  7. In the OpenESQL Assistant, click the Auxiliary Code tab.
  8. Click Host Variables.
  9. In the Host Variable Array Size field, type the number that represents the maximum number of rows you want returned for each array FETCH.
  10. Click Insert Query into Current Program Insert Query into Current Program.
Note: If you decide to code the PERFORM without using code generated byOpenESQL Assistant, you should either define the index variable IDX or modify the code to use a variable that has been already defined to process the array loop.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Setting OpenESQL Assistant Options
Embedding SQL into a Program
Auxiliary Code
Embedding Auxiliary Code
Generating EXEC SQL Auxiliary Code
Changing a SELECT (cursor) query to do an Array FETCH
Related tasks
To generate and embed auxiliary code


To close a query

  1. In the OpenESQL Assistant, check the box next to the table name upon which you have built your query.
  2. Click Yes at the prompt.
Note:

If you have specified more than one table in your query, repeat the procedure for each table.

Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Close a Query
OpenESQL Assistant
Setting OpenESQL Assistant Options
Related tasks
To create an SQL query
Related reference
OpenESQL Assistant - Main Window


To close the OpenESQL Assistant

  • From the OpenESQL Assistant, click Close Close.
Parent topic: OpenESQL Assistant


To connect to a data source

  1. Start the OpenESQL Assistant.
  2. From the tree view, check the box next to a data source.
Note:

You might be prompted to supply one or more of the following:

  • A user ID
  • A password
  • A database name
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Building Queries
Connecting to a Data Source
OpenESQL Assistant
Setting OpenESQL Assistant Options
Related tasks
To start the OpenESQL Assistant
To connect to a different data source
To create a TSQL stored procedure query
Related reference
OpenESQL Assistant - Main Window


To connect to a different data source

  1. On the OpenESQL Assistant, click Create a new query Create a new query. The OpenESQL Assistant discards the current query.
  2. Check the box next to a data source on the tree view.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Connecting to a Data Source
OpenESQL Assistant
Setting OpenESQL Assistant Options
Related tasks
To connect to a data source
To view data source properties
Related reference
OpenESQL Assistant - Main Window
Related information
To connect to a data source
To view data source properties
The OpenESQL Assistant


To create a table join

  1. In the OpenESQL Assistant, create a SELECT query.
  2. In the tree view, identify a table that is not part of the current query and that you would like to join to the table that is part of the current query.
  3. Check the box next to the table name.
  4. Review the generated code.
  5. Do one of the following:
    • If the generated code is acceptable, click Yes. OpenESQL Assistant adds the generated code to the query, joining the table. You can now add columns from the joined table to the query.
    • If the generated code is not acceptable, click No. OpenESQL Assistant does not add the generated code to the query; however it does add the table to the query. You should add code for the join from the Search Criteria tab.
    • If OpenESQL Assistant cannot determine how to join the table to the query, it does not generate any code. Instead, either click Yes to add the table to the query or No to omit the table from the query. If you opt to add the table anyway you can specify the join from the Search Criteria tab.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Related tasks
To create an SQL query


To create an SQL query

  1. Start the OpenESQL Assistant.
  2. Connect to a data source.
  3. On the tree view, check the box next to a table name.
  4. On the Select Type of Query to Create dialog box, click a query type from the list.
  5. Click OK. The query code appears on the Query tab.
  6. Add tables, columns, search criteria, and auxiliary code to the query as necessary.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Building Queries
Selecting a Table and a Query Type
OpenESQL Assistant
Building Queries
Setting OpenESQL Assistant Options
Stored Procedures
Related tasks
To add a column to a query
To close a query
To create a table join
To start the OpenESQL Assistant
To remove a table from a SELECT query
Related reference
Select Type of Query to Create dialog box


To disconnect from a data source

  • On the OpenESQL Assistant, click Create a new query Create a new query, or uncheck the box next to the data source name.
Parent topic: OpenESQL Assistant
Related concepts
Disconnect from a Data Source
OpenESQL Assistant
Setting OpenESQL Assistant Options
Related reference
OpenESQL Assistant - Main Window


To display column details

  1. In the OpenESQL Assistant, create an SQL query.
  2. Click the Details tab.
Parent topic: OpenESQL Assistant
Related concepts
Display Column Details


To embed an SQL query into a COBOL program

  1. In the OpenESQL Assistant, create an SQL query.
  2. In the IDE, open the project that contains the program into which you want to embed the SQL.
  3. Open the appropriate program in the program editor.
  4. Place your cursor at the point in your program where you want the query to appear.
  5. On the OpenESQL Assistant, click Insert Query into Current Program Insert Query into Current Program.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Setting OpenESQL Assistant Options
Embedding SQL into a Program
Auxiliary Code
Embedding Auxiliary Code
Generating EXEC SQL Auxiliary Code
Embedding an SQL Stored Procedure into a Program
OpenESQL Assistant
Building Queries
Related tasks
To generate and embed auxiliary code
Related reference
Query tab


To generate a DCLGEN copybook

  1. Start the OpenESQL Assistant.
  2. Connect to a data source.
  3. Check the box next to a table name.
  4. Click Generate DCLGEN.
Note: This feature is available only when you set the following Visual Studio options for OpenESQL Assistant as follows:
  • Mode option set to ADO.NET
  • Generate option set to EXEC ADO - disconnected model
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Setting OpenESQL Assistant Options
Related reference
OpenESQL Assistant - Options


To generate a DELETE statement

  1. Start the OpenESQL Assistant.
  2. Connect to a data source.
  3. Check the box next to a table name.
  4. Click DELETE, then click OK.
  5. Further define the query using the Search Criteria feature. Optional.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Selecting a Table and a Query Type
Related tasks
To specify search criteria (a WHERE clause)


To generate a SELECT (cursor) statement

  1. Start the OpenESQL Assistant.
  2. Connect to a data source.
  3. Check the box next to a table name.
  4. Click SELECT (cursor), then click OK.
  5. Check the box next to each column you want to include in the SELECT statement.
  6. Further define the query using the Search Criteria and Sort features. Optional.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Selecting a Table and a Query Type
Related tasks
To specify search criteria (a WHERE clause)
To sort returned data (an ORDER BY clause)


To generate a SELECT (singleton) statement

  1. Start the OpenESQL Assistant.
  2. Connect to a data source.
  3. Check the box next to a table name.
  4. Click SELECT (singleton), then click OK.
  5. Check the box next to each column you want to include in the SELECT statement.
  6. Further define the query using the Search Criteria feature. Optional.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Selecting a Table and a Query Type
Related tasks
To specify search criteria (a WHERE clause)
To sort returned data (an ORDER BY clause)


To generate a SELECT DISTINCT (cursor) statement

  1. Start the OpenESQL Assistant.
  2. Connect to the data source.
  3. Check the box next to a table name.
  4. Click SELECT DISTINCT (cursor), then click OK.
  5. Check the box next to each column you want to include in the SELECT statement.
  6. Further define the query using the Search Criteria and Sort features. Optional.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Related tasks
To specify search criteria (a WHERE clause)
To sort returned data (an ORDER BY clause)


To generate a SELECT DISTINCT (singleton) statement

  1. Start the OpenESQL Assistant.
  2. Connect to a data source.
  3. Check the box next to a table name.
  4. Click SELECT DISTINCT (singleton), then click OK.
  5. Check the box next to each column you want to include in the SELECT statement.
  6. Further define the query using the Search Criteria feature. Optional.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Related tasks
To specify search criteria (a WHERE clause)
To sort returned data (an ORDER BY clause)


To generate a DECLARE DATATABLE statement

  1. Start the OpenESQL Assistant.
  2. Connect to a data source.
  3. Check the box next to a table name.
  4. Click Generate DataTable.
Note:

This feature is available only when you set the following Visual Studio options for OpenESQL Assistant as follows:

  • Mode option set to ADO.NET
  • Generate option set to EXEC ADO - disconnected model
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Setting OpenESQL Assistant Options
Related reference
OpenESQL Assistant - Options


To generate an INSERT statement

  1. Start the OpenESQL Assistant.
  2. Connect to a data source.
  3. Check the box next to a table name.
  4. Click INSERT, then click OK.
  5. Check the box next to each column you want to include in the INSERT statement.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Selecting a Table and a Query Type


To generate an UPDATE statement

  1. Start the OpenESQL Assistant.
  2. Connect to a data source.
  3. Check the box next to a table name.
  4. Click UPDATE, then click OK.
  5. Check the box next to each column you want to include in the UPDATE statement.
  6. Further define the query using the Search Criteria feature. Optional.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Selecting a Table and a Query Type
Related tasks
To specify search criteria (a WHERE clause)


To generate and embed auxiliary code

  1. Open the project that contains the program into which you want to embed the SQL.
  2. Open the appropriate program in the program editor.
  3. Place your cursor at the point in your program where you want the auxiliary code to appear.
  4. In the OpenESQL Assistant, click the Auxiliary Code tab.
  5. Click EXEC SQL, EXEC ADO connected, or EXEC ADO disconnected, depending on the type of code you want to generate.
  6. If you want to specify a data set name for EXEC ADO, type the data set name into the Dataset name field. Optional.
  7. Click Insert Query into Current Program Insert Query into Current Program.
Note: To enable OpenESQL Assistant to generate EXEC ADO code, be sure to check the Generate EXEC ADO option when you set options for OpenESQL.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Setting OpenESQL Assistant Options
Embedding SQL into a Program
Auxiliary Code
Embedding Auxiliary Code
Generating EXEC SQL Auxiliary Code
OpenESQL Assistant
Related tasks
To embed an SQL query into a COBOL program
To change a SELECT (cursor) query to do an array FETCH
Related reference
OpenESQL Assistant - Options
Auxiliary Code tab


To perform an aggregate function

  1. In the OpenESQL Assistant, create a SELECT (cursor) or a SELECT DISTINCT (cursor) query.
  2. On the tree view, right-click a column name.
  3. Click an aggregate function to perform on the column.
Note: For more information about aggregate functions, see the SQL documentation for your DBMS.
Parent topic: OpenESQL Assistant
Related concepts
Specifying Aggregate Functions for Columns


To refresh the list of data sources

  • In the OpenESQL Assistant, click Refresh list of available data sources Refresh list of available data sources.
Parent topic: OpenESQL Assistant


To remove a table from a SELECT query

  1. In the OpenESQL Assistant, uncheck the box next to a table name that has been specified in your query.
  2. Click Yes at the prompt.
Note: If you remove the only table specified in a query, this is equivalent to closing the query.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Remove a Table from a SELECT Query
Related tasks
To create an SQL query


To run a query

  1. In the OpenESQL Assistant, create an SQL query.
  2. Click Run the Query Insert Query into Current Program.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Setting OpenESQL Assistant Options
Related reference
OpenESQL Assistant - Main Window


To set OpenESQL Assistant options

  1. From Visual Studio, click Tools > Options; then expand Micro Focus COBOL Tools and click OpenESQL Assistant.
  2. Set the options according to your programming needs.
  3. Click OK.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Setting OpenESQL Assistant Options
Cataloging an ODBC Connection
ADO.NET Connection Editor
OpenESQL Assistant
Setting OpenESQL Assistant Options
Building Queries
Stored Procedures
Related tasks
To catalog an ODBC data provider
Related reference
OpenESQL Assistant - Options
OpenESQL Assistant - Main Window
Select Type of Query to Create dialog box


To sort returned data (an ORDER BY clause)

  1. In the OpenESQL Assistant, click the Sort tab.
  2. In the Columns in SELECT list, click a column you want to sort. This list box displays the column name of every column selected for the query.
  3. Do one of the following:
    • Click Asc to sort the column in ascending order.
    • Click Desc to sort the column in descending order.
  4. If you want to generate the query using a number to represent the column name, check Use integers for column names. The column names are still displayed in the Columns in ORDER BY field, but the integer value of the column is generated for the query.
  5. Insert the sort (ORDER BY clause) into your code by clicking the right-pointing arrow right-pointing arrow.
Note:
  • Code you place into the right-hand pane also appears automatically in the generated query.
  • To remove a sort, click the line of code you want to remove in the right-hand pane, then click the left-pointing arrow right-pointing arrow. This places the sort back into the appropriate fields on the left side of the tab, enabling you to edit it. Moving sorts from the right-hand to the left-hand pane also removes the associated COBOL code from the automatically generated query.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Specifying the Order in which Data is Retrieved
OpenESQL Assistant
Related tasks
To generate a SELECT (cursor) statement
To generate a SELECT (singleton) statement
To generate a SELECT DISTINCT (cursor) statement
To generate a SELECT DISTINCT (singleton) statement
Related reference
Sort tab


To specify search criteria (a WHERE clause)

  1. In the OpenESQL Assistant, click the Search Criteria tab.
  2. From the Column drop-down list, click a column name.
  3. From the Conditional Operator drop-down list, click a conditional operator.
  4. From the Target Type drop-down list, click a target type.
  5. Do one of the following:
    • If you have selected a target type of Special Register, type a value for your special register into the Target Value field.
    • If you have selected a target type of Column Name, click a column name from the Target Value drop-down list.
    • If you have selected a target type of Literal:
      1. Click Edit.
      2. Type the literal value you want to use.
      3. Click OK.
    • If you have selected a target type of Host Variable, the target value is set for you. Proceed to step 6.
  6. Insert the search criteria (WHERE clause) into your code by clicking the right-pointing arrow right-pointing arrow.
  7. To add a subsequent set of criteria, click either AND or OR and repeat this procedure. Optional.
Note:
  • Code you place into the right-hand pane also appears automatically in the generated query.
  • To remove search criteria, click the line of code you want to remove in the right-hand pane, then click the left-pointing arrow right-pointing arrow. This places the criteria back into the appropriate fields on the left side of the tab, enabling you to edit it. Moving search criteria from the right-hand to the left-hand pane also removes the associated COBOL code from the automatically generated query.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Specifying Search Criteria
OpenESQL Assistant
Specifying Search Criteria
Building Queries
Related tasks
To generate a DELETE statement
To generate a SELECT (cursor) statement
To generate a SELECT (singleton) statement
To generate a SELECT DISTINCT (cursor) statement
To generate a SELECT DISTINCT (singleton) statement
To generate an UPDATE statement
Related reference
Search Criteria tab
Literal Value dialog box


To start the OpenESQL Assistant

  1. Click Tools > Micro Focus COBOL Tools > OpenESQL Assistant.
  2. If prompted, type your user name and password and click OK.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Setting OpenESQL Assistant Options
Building Queries
Cataloging an ODBC Connection
ADO.NET Connection Editor
Starting the OpenESQL Assistant
Related tasks
To add an XML data source
To connect to a data source
To create a TSQL stored procedure query
To create an SQL query
To catalog an ODBC data provider


To view data source properties

  • In the OpenESQL Assistant, right-click a data source on the tree view, then click Data Source Properties from the popup menu.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
OpenESQL Assistant
Related tasks
To connect to a different data source
Related reference
Data Source Properties dialog box


ADO.NET Connection Editor

  • To start the ADO.NET Connection Editor
  • To catalog an ADO.NET data provider
  • To catalog an ODBC data provider
  • To uncatalog an ADO.NET data provider
  • To test an ADO.NET connection
  • To export connection settings from the ADO.NET Connection Editor
  • To import connections into the ADO.NET Connection Editor
Parent topic: How to...


To start the ADO.NET Connection Editor

  1. Do one of the following:
    • From your desktop, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > ADO.NET Connection Tools > ADO.NET Connection Editor.
      Note: On Windows 8 and Windows Server 2012, you use the Start screen to invoke programs.
    • From the OpenESQL Assistant, click ADO.NET Connection Editor Button ADO.NET Connection Editor.
Parent topic: ADO.NET Connection Editor
Related concepts
ADO.NET Connection Editor
OpenESQL Assistant
Setting OpenESQL Assistant Options
Related tasks
To catalog an ADO.NET data provider
To uncatalog an ADO.NET data provider
Related reference
OpenESQL Assistant - Main Window


To catalog an ADO.NET data provider

  1. Start the ADO.NET Connection Editor.
  2. On the Connection tab, select a Connection Type and Connection Availability for this connection; then click Add.
  3. On the Provider tab, click the ADO.NET data provider that you want to use, then type a data source name into the Data Source Name field. All data providers installed on your machine appear on this list.
  4. If you want the connection settings for your data source to be encrypted in the repository, check Encrypt connection settings. Optional.
  5. Click Next. This automatically saves your new connection information.
  6. Do one of the following:
    • If your ADO.NET data provider is an OleDb provider, the Microsoft Data Link Properties dialog box appears. Select an OLE DB provider from the Provider tab. Depending on the provider you select, you might need to also select a data source and set security on the Connection tab, then click OK. For more information, click the Help button on the dialog box.
      Note:

      If the Data Link Properties dialog box provides a Test button for your data provider, we recommend that you click it to test the connection. If the connection fails here it will also fail in ADO.

    • If your ADO.NET data provider is not an OleDb provider, proceed to step 7.
  7. On the Connection tab, ensure that each default value listed in the Value column is valid, editing incorrect values when necessary. If you make changes, click Save.
  8. Optionally test your connection.
  9. Click OK to exit the ADO.NET Connection Editor.
Parent topic: ADO.NET Connection Editor
Related concepts
ADO.NET Connection Editor
Cataloging an ADO.NET Connection
Related tasks
To start the ADO.NET Connection Editor
To test an ADO.NET connection
To uncatalog an ADO.NET data provider


To catalog an ODBC data provider

Preferred method:
  1. Configure an ODBC connection using ODBC administrator.
  2. Start Studio Enterprise Edition as an administrator.
  3. Set the OpenESQL Assistant Mode option to ODBC.
  4. Set the Automatically catalog data source option to True.
  5. Start the OpenESQL Assistant from within the Visual Studio IDE, or start it from the Start menu as an administrator.
  6. From the tree view, check the box next to the data source you want to catalog.

    This imports the connection details into the ADO.NET Connection Editor, and the connection remains available to the OpenESQL Assistant even when the Mode option is set to ADO.NET.

Alternative method:
  1. On a machine where the ADO.NET Connection Editor is installed and that has an ODBC connection already cataloged, start the ADO.NET Connection Editor as an administrator.
  2. Export the ODBC connection.
  3. On the machine where you want to add the ODBC connection, start the ADO.NET Connection Editor as an administrator.
  4. Import the exported ODBC connection information.
Parent topic: ADO.NET Connection Editor
Related concepts
Cataloging an ODBC Connection
ADO.NET Connection Editor
Related tasks
To import connections into the ADO.NET Connection Editor
To export connection settings from the ADO.NET Connection Editor
To set OpenESQL Assistant options
To start the OpenESQL Assistant


To uncatalog an ADO.NET data provider

  1. Start the ADO.NET Connection Editor.
  2. On the Connection tab, select a Connection Type and Connection Availability for the connection you want to uncatalog. This populates the Data Source Name list with connections that fit your selections.
  3. On the Data Source Name list, click connection you want to remove.
  4. Click Remove.
  5. Click OK.
  6. Click Yes at the prompt to save your changes and exit.
Parent topic: ADO.NET Connection Editor
Related concepts
ADO.NET Connection Editor
Cataloging an ADO.NET Connection
Related tasks
To catalog an ADO.NET data provider
To start the ADO.NET Connection Editor
To test an ADO.NET connection


To test an ADO.NET connection

  1. Start the ADO.NET Connection Editor.
  2. On the Connection tab, select a Connection Type and Connection Availability for the connection you want to test. This populates the Data Source Name list with connections that fit your selections.
  3. On the Data Source Name list, click the connection you want to test.
  4. If your application requires a user ID and password to connect to a data source, type these into the User ID and Password fields. Optional.
  5. Click Test Connection. A message box appears reporting the status of the connection attempt.
  6. Click OK to clear the prompt.
Note: If your application requires a user ID and password to connect to a data source, then for security reasons, do not save the user ID and password in the Connection Settings table. Information in those fields is used only to test the connection and is ignored when a CONNECT statement is executed. To provide your application with a user ID and password, pass the values as parameters in the CONNECT statement.
Parent topic: ADO.NET Connection Editor
Related concepts
ADO.NET Connection Editor
Related tasks
To catalog an ADO.NET data provider
To uncatalog an ADO.NET data provider


To export connection settings from the ADO.NET Connection Editor

  1. From the Export tab in the ADO.NET Connection Editor, click the connections you want to export, or check Select all connection names.
  2. In the Export to field, type the full path to and filename of an XML file you want to contain exported information, or click Browse Browse to select a directory.
    Note:
    • If you choose to type in the full path and filename, you can name the file anything you want.
    • If you choose to browse to select a directory, the Connection Editor uses the default filename MFconnectInfo.xml. You can overtype the filename with a different name of your choice.
  3. Click Export.
  4. Click OK to clear the prompt.
Parent topic: ADO.NET Connection Editor
Related concepts
ADO.NET Connection Editor
Cataloging an ODBC Connection
Related tasks
To import connections into the ADO.NET Connection Editor
To catalog an ODBC data provider
Related reference
MFImportConn command


To import connections into the ADO.NET Connection Editor

  1. From the Import tab in the ADO.NET Connection Editor, type the full path to and filename of the XML file that contains exported information, or click Browse Browse to select a file.
  2. Click Import.
  3. Click OK to clear the prompt.
Note: You can also import connection settings using the MFImportConn command.
Parent topic: ADO.NET Connection Editor
Related concepts
ADO.NET Connection Editor
Cataloging an ODBC Connection
Related tasks
To export connection settings from the ADO.NET Connection Editor
To catalog an ODBC data provider
Related reference
MFImportConn command


To migrate a connection

  1. Start the Connection Information Migration Tool from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > ADO.NET Connection Tools > ADO.NET Connection Editor > Connection Information Migration Tool.
  2. Select a connection name on the VS 2003 Connection Names list, by clicking it. You can select multiple connections, by holding Shift or Ctrl and then clicking.
  3. Click Migrate.
Parent topic: How to...
Related concepts
Connection Information Migration Tool


Reference

  • OpenESQL
  • DB2
  • COBSQL
  • SQL Data Types
  • SQL TYPEs
  • Data Structures
  • Keywords
Parent topic: Database Access


OpenESQL

  • Embedded SQL Statements
  • Embedded ADO Statements
  • SQL Compiler Directive Options
  • DBMAN Directive Settings
  • SQL/COBOL Data Type Mappings
  • OpenESQL Messages
  • MFImportConn command
    Enables you to import connection settings previously exported from the ADO.NET Connection Editor.
  • User Interface Reference
Parent topic: Reference


Embedded SQL Statements

With the exception of INSERT, DELETE(SEARCHED) and UPDATE(SEARCHED) which are included for your convenience, the embedded SQL statements described here work somewhat differently, or are in addition to, standard SQL statements.

  • ALLOCATE CURSOR
    Defines a cursor and associates it with a result set locator variable.
  • ASSOCIATE LOCATORS
    Gets the result set locator value for each result set returned by a SQL CLR stored procedure.
  • BEGIN DECLARE SECTION
    Signals the beginning of the DECLARE section.
  • BEGIN TRAN
    Provides compatibility with Embedded SQL implementations that do not conform to the ANSI SQL standard with respect to transaction management and, in particular, the Micro Focus Embedded SQL Toolkit for Microsoft SQL Server.
  • CALL
    Executes a stored procedure.
  • CLOSE
    Discards unprocessed rows and frees any locks held by the cursor.
  • COMMIT
    Makes any changes made by the current transaction on the current connection permanent in the database.
  • CONNECT
    Attaches to a specific database using the supplied user name and password.
  • DECLARE CURSOR
    Associates the cursor name with the specified SELECT statement and enables you to retrieve rows of data using the FETCH statement.
  • DECLARE DATABASE
    Declares the name of a database.
  • DELETE (Positioned)
    Deletes the row most recently fetched by using a cursor.
  • DELETE (Searched)
    Removes table rows that meet the search criteria.
  • DESCRIBE
    Provides information on prepared dynamic SQL statements.
  • DISCONNECT
    Closes the connection(s) to a database. In addition, all cursors opened for that connection are automatically closed.
  • END DECLARE SECTION
    Terminates a host variable declaration section begun by a BEGIN DECLARE SECTION statement.
  • EXECSP
    Executes a stored procedure.
  • EXECUTE
    Processes dynamic SQL statements.
  • EXECUTE IMMEDIATE
    Immediately executes the SQL statement.
  • FETCH
    Retrieves a row from the cursor's results set and writes the values of the columns in that row to the corresponding host variables (or to addresses specified in the SQLDA data structure).
  • GET HDBC
    Enables you to use ODBC calls that require you to supply the ODBC connection handle.
  • GET HENV
    Enables you to use ODBC calls that require you to supply the ODBC environment handle.
  • GET NEXT RESULT SET
    Makes the next result set available to an open cursor.
  • INCLUDE
    Includes the definition of the specified SQL data structure or source file in the COBOL program.
  • INSERT
    Adds new rows to a table.
  • OPEN
    Runs the SELECT statement specified in the corresponding DECLARE CURSOR statement to produce the results set that is accessed one row at a time by the FETCH statement.
  • PERSIST
    Saves information defined in a cursor SELECT statement as XML files.
  • PREPARE
    Processes dynamic SQL statements.
  • QUERY ODBC
    Delivers a results set in the same way as a SELECT statement, and must therefore be associated with a cursor via DECLARE and OPEN, or DECLARE, PREPARE and OPEN.
  • RESET CONNECTION
    Closes all open cursors, even if the application has not appropriately closed them.
  • ROLLBACK
    Backs out any changes made to the database by the current transaction on the current connection.
  • SELECT DISTINCT (using DECLARE CURSOR)
    Associates the cursor name with the SELECT DISTINCT statement and enables you to retrieve rows of data using the FETCH statement.
  • SELECT INTO
    Retrieves one row of results and assigns the values of the items in a specified SELECT list to the host variables specified in the INTO list.
  • SET AUTOCOMMIT
    Enables you to control ODBC AUTOCOMMIT mode at runtime.
  • SET CONCURRENCY
    Sets the concurrency option for cursors.
  • SET CONNECTION
    Sets the named connection as the current connection.
  • SET OPTION
    Enables you to set OpenESQL options.
  • SET SCROLLOPTION
    Enables you to set cursor scrolling options.
  • SET TRACELEVEL
    Enables you to dynamically set or change the reporting level of OpenESQL traces for native applications.
  • SET TRANSACTION ISOLATION
    Sets the transaction isolation level for the current connection to one of the isolation level modes specified by ODBC.
  • SYNCPOINT
    Closes all open cursors that were not opened using the WITH HOLD clause, even if the application has not appropriately closed them.
  • UPDATE (Positioned)
  • UPDATE (Searched)
    Updates a table or view based on specified search conditions.
  • WHENEVER
    Specifies the default action after running an Embedded SQL statement when a specific condition is met.
Parent topic: OpenESQL
Related concepts
Embedded SQL
Related reference
SQL


ALLOCATE CURSOR

Defines a cursor and associates it with a result set locator variable.

Syntax:

>>-EXEC SQL--ALLOCATE cursor_name FOR RESULT SET :rs_locator_variable->
>-----END-EXEC-----<>

Parameters:

cursor_name | A previously declared and opened cursor.
:rs_locator_variable | A result set locator host variable that has been declared in the application program.

Comments:

You can create SQL CLR stored procedures using our Studio Enterprise Edition for Visual Studio product.

Supported for client applications that call SQL CLR stored procedures that return result sets and are compiled with DBMAN=ODBC and DIALECT=MAINFRAME or DBMAN=ADO and DIALECT=MAINFRAME.

Example:

  working-storage section.
       exec sql include sqlca end-exec.
       01  mfsqlmessagetext    pic x(200).
       01  hv-country  pic n(15) national.
       01  CustomerID  pic n(5) national.
       01  Company     pic n(40) national.
       01  City        pic n(15) national.
       01  CustomerID2 pic n(5) national.
       01  Company2    pic n(40) national.
       01  City2       pic n(15) national.
       01  rsl         sql type result-set-locator varying.
       01  rs2         sql type result-set-locator varying.
       01  rs3         sql type result-set-locator varying.
       procedure division.
           exec sql connect to Northwind end-exec

           move N"UK" to hv-country

           *> Test DB2 result set locators
           *> This proc opens 3 cursors. closes 2 and re-opens on
           *> So should return 2 result sets
           exec sql call TestProc1(:hv-country) end-exec

           exec sql
               associate locators (:rsl, :rs2, :rs3)
               with procedure TestProc1
           end-exec

           exec sql
               allocate c1 cursor
               for result set :rsl
           end-exec
           if sqlcode not = 0
               display "Open 1st locator failed"
           end-if

           exec sql
               allocate c2 cursor
               for result set :rs2
           end-exec
           if sqlcode not = 0
               display "Open 2nd locator failed"
           end-if

           exec sql
               allocate c3 cursor
               for result set :rs3
           end-exec
           if sqlcode = 0
               display "FAIL: Open 3rd locator succeeded"
           end-if
Parent topic: Embedded SQL Statements


ASSOCIATE LOCATORS

Gets the result set locator value for each result set returned by a SQL CLR stored procedure.

Syntax:

              .-RESULT SET-.
>>-ASSOCIATE--+------------+--+-LOCATORS--+---------------------->
                              '-LOCATOR--'

      .-,-------------------.
      V                     |
>--(----rs-locator-variable-+--)-------------------------------->

>--WITH PROCEDURE--+-procedure-name-+--------------------------><
                   '-hvar-----------'

Parameter:

rs_locator_variable | A result set locator host variable that has been declared in the application program.
procedure-name | The name of a SQL CLR stored procedure.
hvar | A host variable that contains the name of a SQL CLR stored procedure.

Comments:

You can create SQL CLR stored procedures using our Studio Enterprise Edition for Visual Studio product.

Supported for client applications that call SQL CLR stored procedures that return result sets and are compiled with DBMAN=ODBC and DIALECT=MAINFRAME or DBMAN=ADO and DIALECT=MAINFRAME.

Example:

  working-storage section.
       exec sql include sqlca end-exec.
       01  mfsqlmessagetext    pic x(200).
       01  hv-country  pic n(15) national.
       01  CustomerID  pic n(5) national.
       01  Company     pic n(40) national.
       01  City        pic n(15) national.
       01  CustomerID2 pic n(5) national.
       01  Company2    pic n(40) national.
       01  City2       pic n(15) national.
       01  rsl         sql type result-set-locator varying.
       01  rs2         sql type result-set-locator varying.
       01  rs3         sql type result-set-locator varying.
       procedure division.
           exec sql connect to Northwind end-exec

           move N"UK" to hv-country

           *> Test DB2 result set locators
           *> This proc opens 3 cursors. closes 2 and re-opens on
           *> So should return 2 result sets
           exec sql call TestProc1(:hv-country) end-exec

           exec sql
               associate locators (:rsl, :rs2, :rs3)
               with procedure TestProc1
           end-exec

           exec sql
               allocate c1 cursor
               for result set :rsl
           end-exec
           if sqlcode not = 0
               display "Open 1st locator failed"
           end-if

           exec sql
               allocate c2 cursor
               for result set :rs2
           end-exec
           if sqlcode not = 0
               display "Open 2nd locator failed"
           end-if

           exec sql
               allocate c3 cursor
               for result set :rs3
           end-exec
           if sqlcode = 0
               display "FAIL: Open 3rd locator succeeded"
           end-if
Parent topic: Embedded SQL Statements


BEGIN DECLARE SECTION

Signals the beginning of the DECLARE section.

Syntax:

>>---EXEC SQL---BEGIN DECLARE SECTION---END-EXEC---><

Comments:

The BEGIN DECLARE SECTION statement can be included anywhere where COBOL permits variable declaration. Use END DECLARE SECTION to identify the end of a COBOL declaration section.

  • Declare sections cannot be nested.
  • Variables must be declared in COBOL, not in SQL.
  • To avoid conflict, variables inside a declaration section cannot be the same as any outside the declaration section or in any other declaration section, even in other compilation units.

If data structures are defined within a declaration section, only the bottom-level items (with PIC clauses) can be used as host variables. Two exceptions are arrays specified in FETCH statements and record structures specified in SELECT INTO statements.

Example:

 WORKING-STORAGE SECTION.
 EXEC SQL BEGIN DECLARE SECTION END-EXEC
 01 staff-id        pic x(4).
 01 last-name       pic x(30).
 EXEC SQL END DECLARE SECTION END-EXEC
Parent topic: Embedded SQL Statements
Related reference
END DECLARE SECTION
FETCH
SELECT INTO


BEGIN TRAN

Provides compatibility with Embedded SQL implementations that do not conform to the ANSI SQL standard with respect to transaction management and, in particular, the Micro Focus Embedded SQL Toolkit for Microsoft SQL Server.

Syntax, Format 1:

>>--EXEC SQL--BEGIN TRAN-.------------------.-END-EXEC---><
                         +-transaction_name-+

Syntax, Format 2:

>>-EXEC SQL-BEGIN TRANSACTION.----------------.-END-EXEC-><
                             +transaction_name+

Parameters:

transaction_name An optional identifier that is ignored.

Comments:

Use the BEGIN TRAN statement in AUTOCOMMIT mode to open a transaction. After you have opened the transaction in AUTOCOMMIT mode, you should execute a COMMIT or ROLLBACK statement to close the transaction and cause a return to AUTOCOMMIT mode.

If you are not opening a transaction in AUTOCOMMIT mode, then this statement has no effect.

Example:

 EXEC SQL BEGIN TRANSACTION END-EXEC
Parent topic: Embedded SQL Statements
Related reference
SET AUTOCOMMIT


CALL

Executes a stored procedure.

Syntax:

>>--EXEC SQL--.-----------------.--.----------------.->
              +-FOR :host_integer--+  +- :result_hvar -+

 >---CALL stored_procedure_name-.------------.-END-EXEC-><
                                | +-- , --+  |
                                | V       |  |
                                +(parameter)-+

Parameters:

host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
result_hvar | A host variable to receive the procedure result.
stored_procedure_name | The name of the stored procedure.
parameter A literal, a DECLARE CURSOR statement1, or a host variable parameter of the form:
[keyword=]:param_hvar [IN | INPUT |
INOUT | OUT | OUTPUT]

where:

keyword 2 | The formal parameter name for a keyword parameter. Keyword parameters can be useful as an aid to readability and where the server supports default parameter values and optional parameters.
param_hvar | A host variable.
IN | An input parameter.
INPUT | An input parameter (default).
INOUT | An input/output parameter.
OUT | An output parameter.
OUTPUT | An output parameter.

1 Specify DECLARE CURSOR only with Oracle 8 or later and for stored procedures that return a result set. The use of DECLARE CURSOR unbinds the corresponding parameter.

2 HCOSS does not support keyword parameters.

Comments:

Do not use the FOR clause if the CALL is part of a DECLARE CURSOR statement.

For maximum portability, observe the following as general rules:
  • Avoid literal parameters
  • Use host variable parameters
  • Avoid mixing positional parameters and keyword parameters
  • If your server supports a mixture of positional and keyword parameters, list keyword parameters after positional parameters

Examples:

Call a stored procedure using two positional host variables as input parameters:
   EXEC SQL
      CALL myProc(param1,param2)
   END-EXEC
Call a stored procedure using a keyword host variable as an input parameter:
   EXEC SQL
      CALL myProc (namedParam=:paramValue)
   END-EXEC
Call a stored procedure using a result host variable and a keyword host variable as an input parameter:
   EXEC SQL
      :myResult = CALL myFunction(namedParam=:paramValue)
   END-EXEC
Call a stored procedure using two positional host variables, one as an input parameter and one as an output parameter:
   EXEC SQL
      CALL getDept(:empName IN, :deptName OUT)
   END-EXEC
Call a stored procedure using a DECLARE CURSOR statement and a positional host variable as an input parameter (Oracle only):
   EXEC SQL
      DECLARE cities CURSOR FOR CALL locateStores(:userState)
   END-EXEC
Parent topic: Embedded SQL Statements
Related concepts
Working With OpenESQL Stored Procedures and Result Sets
Working With HCOSS SQL CLR Stored Procedures and Result Sets
Related reference
DECLARE CURSOR
EXECSP


CLOSE

Discards unprocessed rows and frees any locks held by the cursor.

Syntax:

>>---EXEC SQL---CLOSE---cursor_name---END-EXEC---><

Parameters:

cursor_name A previously declared and opened cursor.

Comments:

The cursor must be declared and opened before it can be closed. All open cursors are closed automatically at the end of the program.

Example:

*Declare the cursor...
     EXEC SQL
         DECLARE C1 CURSOR FOR
            SELECT staff_id, last_name
            FROM staff
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not declare cursor.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

     EXEC SQL
        OPEN C1
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not open cursor.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT CURRENT END-EXEC
        STOP RUN
     END-IF

     PERFORM UNTIL sqlcode NOT = ZERO
*SQLCODE will be zero as long as it has successfully fetched data
        EXEC SQL
           FETCH C1 INTO :staff-staff-id, :staff-last-name
        END-EXEC
        IF SQLCODE = ZERO
           DISPLAY "Staff ID: " staff-staff-id
           DISPLAY "Staff member's last name: " staff-last-name
        END-IF
     END-PERFORM

     EXEC SQL
        CLOSE C1
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not close cursor.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
     END-IF
Parent topic: Embedded SQL Statements
Related reference
DECLARE CURSOR
FETCH
OPEN
GET NEXT RESULT SET


COMMIT

Makes any changes made by the current transaction on the current connection permanent in the database.

Syntax:

>>---EXEC SQL---COMMIT----.--------------.--->
                          +-WORK---------+
                          +-TRAN---------+
                          +-TRANSACTION--+

 >---.-----------.---END-EXEC--><
     +--RELEASE--+

Parameters:

WORK | WORK, TRAN and TRANSACTION are optional and synonymous.
RELEASE | If RELEASE is specified and the transaction was successfully committed, the current connection is closed.

Example:

* Ensure that multiple records are not inserted for a
* member of staff whose staff_id is 99
     EXEC SQL
        DELETE FROM staff WHERE staff_id = 99
     END-EXEC

* Insert dummy values into table
     EXEC SQL
        INSERT INTO staff
        (staff_id
        ,last_name
        ,first_name
        ,age
        ,employment_date)
        VALUES
        (99
        ,'Lee'
        ,'Phil'
        ,19
        ,'1992-01-02')
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not insert dummy values.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

     EXEC SQL
        COMMIT
     END-EXEC

* Check it was committed OK
     IF SQLCODE = ZERO
        DISPLAY 'Error: Could not commit values.'
       DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT CURRENT END-EXEC
        STOP RUN
     END-IF

     DISPLAY 'Values committed.'

* Delete previously inserted data
     EXEC SQL
        DELETE FROM staff WHERE staff_id = 99
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not delete dummy values.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

* Check data deleted OK, commit and release the connection
     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not delete values.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

     EXEC SQL
        COMMIT WORK RELEASE
     END-EXEC

* Check data committed OK and release the connection.
    IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not commit and release.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT CURRENT END-EXEC
     END-IF

     DISPLAY 'Values committed and connection released.'
Parent topic: Embedded SQL Statements
Related concepts
Managing Transactions
Related reference
CONNECT
DISCONNECT
ROLLBACK
SET CONNECTION


CONNECT

Attaches to a specific database using the supplied user name and password.

Syntax, Format 1:

>>---EXEC SQL---CONNECT TO---.-------------.------------->
                             +-data_source-+

 >--.------------.------USER-.-------------------.-------->
    +-AS db_name-+           +-user-.-----------++
                                    +-.password-+

 >-.--------------------.-.-----------------------------.->
   +-WITH-.----.-PROMPT-+ +-RETURNING output_connection-+
          +-NO-+

 >------END-EXEC--------><

Syntax, Format 2:

>>---EXEC SQL---CONNECT user--.------------------------.->
                              +-IDENTIFIED BY password-+
                              +-------'/'password------+

 >---.--------------.--------.--------------------.------->
     +--AT db_name--+        +--USING data_source-+

 >---.----------------------.----------------------------->
     +--WITH-.----.-PROMPT--+
             +-NO-+

 >---.-----------------------------.---END-EXEC---><
     +-RETURNING output_connection-+

Syntax, Format 3:

>>----EXEC SQL---CONNECT WITH PROMPT-------------------->

 >---.------------------------------.---END-EXEC----><
     +-RETURNING output_connection -+

Syntax, Format 4:

>>----EXEC SQL---CONNECT RESET-.--------.--END-EXEC-----><
                               +--name--+

Syntax, Format 5:

>>----EXEC SQL--------CONNECT DSN input_connection------->

 >---.------------------------------.-------END-EXEC-----><
     +-RETURNING output_connection -+

Syntax, Format 6:

>>----EXEC SQL---CONNECT USING input_connection---------->

 >-----.-------------.---.---------------------.---------->
       +--AS db_name-+   +--WITH-.----.-PROMPT-+
                                 +-NO-+

 >-----.------------------------------.------END-EXEC----><
       +--RETURNING output_connection-+

Parameters:

data_ source

The name of the ODBC or ADO.NET data store. For ODBC data stores, this is the DSN created via the Microsoft ODBC Data Source Administrator. For ADO.NET data stores, this is a data source name created via the Micro Focus ADO.NET Connection Editor or the HCOSS Manage Connections tool.

If you omit data_source, the default ODBC data source is assumed. The data source can be specified as a literal or as a host variable.

db_name A name for the connection. Connection names can have as many as 30 characters, and can include alphanumeric characters and any symbols legal in filenames. The first character must be a letter. Do not use Embedded SQL keywords or CURRENT or DEFAULT or ALL for the connection name; they are invalid. If db_name is omitted, DEFAULT is assumed. db_name can be specified as a literal or a host variable.

When connecting to SQL Server, db_name is the database to which you are connecting.

user | A valid user-id at the specified data source.
password | A valid password for the specified user-id.
output_connection | A PIC X(n) text string defined by ODBC as the connection string used to connect to a particular data source. Subsequently, you can specify this string as the input_connection in a CONNECT USING statement.
input_connection | A PIC X(n) text string containing connection information used by ODBC to connect to the data source. The test string can be either a literal or a host variable.
RESET | Resets (disconnects) the specified connection.
name | You can specify name as CURRENT, DEFAULT or ALL.

Comments:

If you use only one connection, you do not need to supply a name for the connection. When you use more than one connection, you must specify a name for each connection. Connection names are global within a process. Named connections are shared by separately compiled programs that are linked into a single executable module.

After a successful CONNECT statement, all database transactions other than CONNECT RESET work through this most recently declared current connection. To use a different connection, use the SET CONNECTION statement.

To cause the ODBC run-time module to prompt at run-time for entry or confirmation of connection details, use CONNECT WITH PROMPT.

Use CONNECT DSN and CONNECT USING to simplify administration.

With CONNECT TO, CONNECT, CONNECT WITH PROMPT, CONNECT DSN and CONNECT USING, you can return connection information to the application.

Note:
  • The CONNECT WITH PROMPT syntax is not supported for applications compiled with SQL(DBMAN=ADO).
  • If the INIT option of the SQL Compiler directive is used, an implicit connection to the database will be made at run-time. In this case, it is not necessary to execute an explicit CONNECT statement.
  • A File DSN cannot contain a password.
  • If you are using the ADO.NET runtime and Format 6, you must add factory=invariantname to the input_connection specification. You can find the invariant name on the Add page of the ADO.NET Connection Editor.

Example, Format 1:

     MOVE 'servername' TO svr
     MOVE 'username.password' TO usr

     EXEC SQL
        CONNECT TO :svr USER :usr
     END-EXEC

Example, Format 2:

     EXEC SQL
        CONNECT 'username.password' USING 'servername'
     END-EXEC

Example, Format 3:

     EXEC SQL
        CONNECT WITH PROMPT
     END-EXEC

Example, Format 4:

     EXEC SQL
        CONNECT RESET
     END-EXEC

Example, Format 5:

    EXEC SQL
        CONNECT USING 'FileDSN=Oracle8;PWD=tiger'
     END-EXEC

The example above uses a File DSN.

Example, Format 6:

 01  connectString               PIC X(72) value
                   'DRIVER={Microsoft Excel Driver (*.xls)};'
                   &'DBQ=c:\demo\demo.xls;'
                   &'DRIVERID=22'
                   .

 procedure division.

     EXEC SQL
         CONNECT USING :connectString
     END-EXEC

The example above connects to an Excel spreadsheet without setting up a data source.

 01  connString    string.
 set connString    to  "Trusted_Connection=yes;Database=Northwind;server=localhost;factory=System.Data.SqlClient;"

 procedure division.

     EXEC SQL
         CONNECT USING :connString
     END-EXEC

The above example shows appropriate syntax for the ADO.NET runtime.

Parent topic: Embedded SQL Statements
Related concepts
Compiling Multiple Program Modules
Database Connections
Related reference
COMMIT
DISCONNECT
ROLLBACK
SET CONNECTION
DECLARE DATABASE
SET OPTION


DECLARE CURSOR

Associates the cursor name with the specified SELECT statement and enables you to retrieve rows of data using the FETCH statement.

Syntax:

>>--EXEC SQL---.------------.------DECLARE cursor_name------>
               +-AT db_name-+

 >--.-------------.-----.---------.------.--------------.--->
    +-SENSITIVE---+     +-FORWARD-+      +-LOCK---------+
    +-INSENSITIVE-+     +-KEYSET--+      +-LOCKCC-------+
                        +-DYNAMIC-+      +-OPTIMISTIC---+
                        +-STATIC--+      +-OPTCC--------+
                        +-SCROLL--+      +-OPTCCVAL-----+
                        +-DATASET-+      +-READ ONLY----+
                                         +-READONLY-----+
                                         +-FASTFORWARD--+
                                         +-FAST FORWARD-+

 >--CURSOR-------.----------------.---------FOR------------->
                 +----WITH HOLD---+

 >----.----select_stmt-----------------------.-------------->
      +----stored_procedure_call_statement---+
      +----prepared_stmt_name----------------+
      +----OPTIMIZE FOR n ROWS---------------+
 >--.-------------------------------.----------------------->
    +-FOR READ ONLY-----------------+
    +-FOR UPDATE-.----------------.-+
                 +-OF column_list-+
 >------END-EXEC--------><

Parameters:

db_name | The name of a database that has been declared using DECLARE DATABASE.
cursor_name | Cursor name used to identify the cursor in subsequent statements. Cursor names can contain any legal filename character and be up to 30 characters in length. The first character must be a letter.
select_stmt | Any valid SQL SELECT statement, or a QUERY ODBC statement or a CALL statement for a stored procedure that returns a result set.
prepared_stmt_name | The name of a prepared SQL SELECT statement or QUERY ODBC statement.
stored_procedure_call_stmt | A valid stored procedure call which returns a result set.
n | The number of rows per block fetched when the cursor is opened. The value of n must be less than 1000.
column_list | A list of column-names, separated by commas.

Comments:

Two separately compiled programs cannot share the same cursor. All statements that reference a particular cursor must be compiled together.

The DECLARE CURSOR statement must appear before the first reference to the cursor. The SELECT statement runs when the cursor is opened. The following rules apply to the SELECT statement:

  • It cannot contain an INTO clause or parameter markers.
  • It can contain input host variables previously identified in a declaration section.
  • With some ODBC drivers, the SELECT statement must include a FOR UPDATE clause if positioned updates or deletions are to be performed.

If OPTIMIZE FOR is specified, OpenESQL uses n to override the setting of the PREFETCH directive for the cursor. This allows prefetch optimization for individual cursors.

You can specify multiple SELECT statements in a DECLARE CURSOR statement, signifying the return of multiple result sets from a standard OpenESQL application program.The client application must use the GET NEXT RESULT SET statement to retrieve additional result sets.

The following applies to the behavior of certain DECLARE CURSOR options:
  • SCROLL selects a scroll option, other than FORWARD, that is supported by the driver.
  • DATASET enables a cursor that can be used with any BEHAVIOR setting. DATASET is required for applications that use the underlying .NET objects for interoperability with other .NET languages, and is available only for the OpenESQL Managed Runtime.
  • LOCKCC and LOCK are equivalent.
  • READ ONLY and READONLY are equivalent.
  • OPTIMISTIC selects an optimistic concurrency mode (OPTCC or OPTCCVAL) that is supported by the driver.
  • If a HOLD cursor is requested and the current connection closes cursors at the end of transactions, the OPEN statement will return an error (SQLCODE = -19520).
  • If the database is Microsoft SQL Server and the NOANSI92 ENTRY directive setting has been used (this is the default setting), then a Microsoft SQL Server specific ODBC call will be made at connect time to request that cursors are not closed at the end of transactions. This is compatible with the Micro Focus Embedded SQL Toolkit for Microsoft SQL Server. The setting for USECURLIB must not be YES.
  • FAST FORWARD and FASTFORWARD are equivalent. This is a performance optimization parameter that applies only to FORWARD, READ-ONLY cursors. You can obtain even greater performance gains by also compiling the program with the AUTOFETCH directive; this is the most efficient method of getting a results set into an application. The AUTOFETCH directive enables two optimizations that can significantly reduce network traffic. The most dramatic improvement is seen when processing cursors with relatively small result sets that can be cached in the memory of an application. FASTFORWARD cursors work only with Microsoft SQL Server 2000 or later servers.

Example:

EXEC SQL DECLARE C1 CURSOR FOR
   SELECT last_name, first_name FROM staff
END-EXEC

EXEC SQL DECLARE C2 CURSOR FOR
   QUERY ODBC COLUMNS TABLENAME 'staff'
END-EXEC
Parent topic: Embedded SQL Statements
Related concepts
Working With OpenESQL Stored Procedures and Result Sets
Working With OpenESQL Cursors and Result Sets
Working With HCOSS SQL CLR Stored Procedures and Result Sets
Related reference
CALL
CLOSE
SELECT DISTINCT (using DECLARE CURSOR)
FETCH
OPEN
PREPARE
QUERY ODBC
SET CONCURRENCY
SELECT INTO
SET SCROLLOPTION
DELETE (Positioned)
DELETE (Searched)
EXECSP
UPDATE (Positioned)


DECLARE DATABASE

Declares the name of a database.

Syntax:

>>---EXEC SQL---DECLARE db_name---DATABASE---END-EXEC---->

Parameters:

db_name A name associated with a database. It must be an identifier and not a host variable. It cannot contain quotation marks.

Comments:

You must DECLARE db_name before using a CONNECT ... AT db_name statement.

You cannot use DECLARE DATABASE with EXECUTE IMMEDIATE or with PREPARE and EXECUTE.

Parent topic: Embedded SQL Statements
Related reference
CONNECT
EXECUTE
EXECUTE IMMEDIATE
PREPARE
UPDATE (Positioned)


DELETE (Positioned)

Deletes the row most recently fetched by using a cursor.

Syntax:

>>---EXEC SQL---DELETE---FROM---table_name--------------->

 >----WHERE CURRENT OF---cursor_name---END-EXEC---><

Parameters:

table_name | The same table used in the SELECT FROM option (see DECLARE CURSOR).
cursor_name | A previously declared, opened, and fetched cursor.

Comments:

ODBC supports positioned delete, which deletes the row most recently fetched by using a cursor in the Extended Syntax (it was in the Core Syntax for ODBC 1.0 but was moved to the Extended Syntax for ODBC 2.0). Not all drivers provide support for positioned delete, although OpenESQL sets ODBC cursor names to be the same as COBOL cursor names to facilitate positioned update and delete.

With some ODBC drivers, the select statement used by the cursor must contain a 'FOR UPDATE' clause to enable positioned delete.

You cannot use host arrays with positioned delete.

The other form of DELETE used in standard SQL statements is known as a searched delete.

Most data sources require specific combinations of SCROLLOPTION and CONCURRENCY to be specified either by SET statements or in the DECLARE CURSOR statement.

The ODBC cursor libray provides a restricted implementation of positioned delete which can be enabled by compiling with SQL(USECURLIB=YES) and using SCROLLOPTION STATIC and CONCURRENCY OPTCCVAL (or OPTIMISTIC).

Example:

* Declare a cursor for update
     EXEC SQL DECLARE C1 CURSOR FOR
        SELECT staff_id, last_name FROM staff FOR UPDATE
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not declare cursor for update.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

* Open the cursor
     EXEC SQL
        OPEN C1
     END-EXEC
     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not open cursor for update.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

* Display staff member's details and give user the opportunity
* to delete particular members.
     PERFORM UNTIL SQLCODE NOT = ZERO
        EXEC SQL FETCH C1 INTO :staff-id,:last-name END-EXEC
        IF SQLCODE = ZERO
           DISPLAY 'Staff ID:     ' staff-id
           DISPLAY 'Last name:    ' last-name
           DISPLAY 'Delete <y/n>? ' WITH NO ADVANCING
           ACCEPT usr-input
           IF usr-input = 'y'
              EXEC SQL
                 DELETE FROM staff WHERE CURRENT OF C1
              END-EXEC
              IF SQLCODE NOT = ZERO
                 DISPLAY 'Error: Could not delete record.'
                 DISPLAY SQLERRMC
                 DISPLAY SQLERRML
              END-IF
           END-IF
        END-IF
     END-PERFORM
Parent topic: Embedded SQL Statements
Related reference
DECLARE CURSOR
FETCH
INSERT


DELETE (Searched)

Removes table rows that meet the search criteria.

Syntax:

>>--EXEC SQL--.-------------------.---DELETE--.------.--->
              +-FOR :host_integer-+           +-FROM-+

 >--.-table_name-.--.-------------------------.-END-EXEC-><
    +--view_name-+  +-WHERE search_conditions-+

Parameters:

host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
FROM | An optional keyword. It is required for ANSI SQL 92 conformance.
table_name | The target table for the delete operation.
view_name | The target view for the delete operation.
WHERE | A standard SQL WHERE clause identifying the row to be deleted.
search_conditions | Any valid expression that can follow the standard SQL WHERE clause.

Comments:

DELETE is a standard SQL statement. See the documentation supplied with your ODBC driver for the exact syntax.

You cannot mix simple host variables with host arrays in the WHERE clause. If one of the host variables is an array, they must all be arrays.

If you do not specify a WHERE clause, all of the rows in the named table are removed.

Example:

EXEC SQL
   DELETE FROM staff WHERE staff_id = 99
END-EXEC
Parent topic: Embedded SQL Statements
Related reference
DECLARE CURSOR
INSERT


DESCRIBE

Provides information on prepared dynamic SQL statements.

Syntax:

>>---EXEC SQL-----DESCRIBE---.----------------------.----->
                             +---SELECT LIST FOR----+
                             +---BIND VARIABLES FOR-+

 >--prepared_stmt_name---INTO---:sqlda_struct---END-EXEC--><

Parameters:

prepared_stmt_name | The name of a prepared SQL SELECT statement or QUERY ODBC statement.
: sqlda_struct | A host variable that specifies the output SQLDA data structure to be populated. The colon is optional to provide compatibility with other embedded SQL implementations.

Comments:

This statement populates the specified SQLDA data structure with the data type, length, and column name of each column returned by the specified prepared statement.

If neither SELECT LIST FOR or BIND VARIABLES FOR is specified, SELECT LIST is used by default. If BIND VARIABLES FOR is specified, information about input parameters is returned in the SQLDA rather than information about results columns.

The DESCRIBE statement inserts the number of columns into the sqld field of the SQLDA structure. If a non-select statement was prepared, sqld is set to 0. Before DESCRIBE is called, the following fields in the SQLDA data structure must be initialised by the application:

sqln The maximum number of sqlvar (column descriptor) entries that the structure can accomodate.
sqldabc The maximum size of the SQLDA:
  • 32-bit - Calculated as sqln * 44 + 16
  • 64-bit - Calculated as sqln * 56 + 16

If sqln is set to 0, no column descriptor entries are constructed, but sqld is set to the number of entries required. The DESCRIBE statement works in a similar way to a PREPARE statement with an INTO clause.

By default, the SQL types for date, time and timestamp are respectively DATE-RECORD, TIME-RECORD and TIMESTAMP-RECORD. When you use the BEHAVIOR=MAINFRAME option for the SQL Compiler directive, OpenESQL mimics the DB2 on the mainframe for these data types, providing character strings (i.e., PIC X(n)) instead of the standard, default record constructs.

Note:

Few drivers fully implement the ODBC calls necessary for DESCRIBE BIND VARIABLES.

Example:

     EXEC SQL INCLUDE SQLDA END-EXEC
     EXEC SQL BEGIN DECLARE SECTION END-EXEC
     01 statement   pic x(80).
     EXEC SQL END DECLARE SECTION END-EXEC

     EXEC SQL
         DECLARE C1 CURSOR FOR stmt1
     END-EXEC

     move "select * from dept" into statement

     move 20 to sqln
    $IF P64 SET
     compute sqldabc = 16 + 56 * sqln
    $ELSE
     compute sqldabc = 16 + 44 * sqln
    $END

     EXEC SQL
         PREPARE stmt1 FROM :statement
     END-EXEC
     EXEC SQL
         DESCRIBE stmt1 INTO :sqlda
     END-EXEC

* The data structure "sqlda" now contains a description
* of the dynamic SQL statement.
     EXEC SQL
         OPEN C1
     END-EXEC

* Complete the SQLDA, by adding buffer addresses and lengths

     EXEC SQL
         FETCH C1 USING DESCRIPTOR :sqlda
     END-EXEC
Parent topic: Embedded SQL Statements
Related concepts
Dynamic SQL
Data Structures
Related reference
PREPARE
FETCH
INCLUDE


DISCONNECT

Closes the connection(s) to a database. In addition, all cursors opened for that connection are automatically closed.

Syntax:

>>---EXEC SQL---DISCONNECT---.-name----.----END-EXEC----><
                             +-ALL-----+
                             +-CURRENT-+
                             +-DEFAULT-+

Parameters:

name | The connection name.
ALL | Disconnects all connections (including automatic connections made when the INIT option of the SQL Compiler directive is used).
CURRENT | Disconnects the current connection. The current connection is either the most recent connection established by a CONNECT statement or a subsequent connection set by a SET CONNECTION statement.
DEFAULT | Disconnects the default connection. This is the connection made by a CONNECT statement which did not specify a connection name.

Example:

EXEC SQL CONNECT TO "srv1" AS server1 USER "sa." END-EXEC
EXEC SQL CONNECT TO "srv2" AS server2 USER "sa." END-EXEC
...
EXEC SQL DISCONNECT server1 END-EXEC
EXEC SQL DISCONNECT server2 END-EXEC.
Parent topic: Embedded SQL Statements
Related concepts
Database Connections
OpenESQL
Related reference
COMMIT
CONNECT
ROLLBACK
SET CONNECTION


END DECLARE SECTION

Terminates a host variable declaration section begun by a BEGIN DECLARE SECTION statement.

Syntax:

>>---EXEC SQL---END DECLARE SECTION---------END-EXEC----><

Example:

 WORKING-STORAGE SECTION.

 EXEC SQL BEGIN DECLARE SECTION END-EXEC
 01 staff-id        pic x(4).
 01 last-name       pic x(30).
 EXEC SQL END DECLARE SECTION END-EXEC
Parent topic: Embedded SQL Statements
Related reference
BEGIN DECLARE SECTION


EXECSP

Executes a stored procedure.

Syntax:

>>--EXEC SQL-.----------------.-EXECSP-.---------------.->
             +-FOR :host_integer-+        +-:result_hvar -+

 >-- stored_procedure_name -----.------------.------------->
                                | +-- , --+  |
                                | V       |  |
                                +(parameter)-+

 >-.----------------.------------------------END-EXEC-----<>
   +-WITH RECOMPILE-+

Parameters:

:host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
:result_hvar | A host variable to receive the procedure result.
stored_procedure_name | The name of the stored procedure.
parameter A literal or a host variable parameter of the form:
[keyword=]:param_hvar [OUT | OUTPUT]

where:

keyword | is the formal parameter name for a keyword parameter.
:param_hvar | is a host variable.
OUT | specifies an output parameter.
OUTPUT | specifies an output parameter.
WITH RECOMPILE | Is ignored and has no effect. It is allowed for syntax compatibility only.

Comments:

The EXECSP statement is an alternative to the CALL statement and provides backwards compatibility with the Micro Focus Embedded SQL Toolkit for Microsoft SQL Server. Wherever possible, the CALL statement should be used in preference to EXECSP.

Do not use the FOR clause if the EXECSP is part of a DECLARE CURSOR statement.

Example:

EXEC SQL
   EXECSP myProc param1,param2
END-EXEC

EXEC SQL
   EXECSP :myResult = myFunction namedParam = :paramValue
END-EXEC

EXEC SQL
   EXECSP getDept :empName, :deptName OUT
END-EXEC

EXEC SQL
   DECLARE cities CURSOR FOR EXECSP locateStores :userState
END-EXEC
Parent topic: Embedded SQL Statements
Related concepts
Working With OpenESQL Stored Procedures and Result Sets
Related reference
CALL
DECLARE CURSOR


EXECUTE

Processes dynamic SQL statements.

Syntax:

>>-EXEC SQL-----.-------------------.------EXECUTE------>
                +--FOR :host_integer---+

 >-prepared_stmt_name-.--------------------------------.->
                      +-USING DESCRIPTOR :sqlda_struct-+
                      |       +- , -+                  |
                      |       V     |                  |
                      +-USING :hvar--------------------+

 >-----END-EXEC-----<>

Parameters:

:host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
prepared_stmt_name | A previously prepared SQL statement.
:sqlda_struct | A previously declared SQLDA data structure containing a description of the input values. The colon is optional to provide compatibility with other embedded SQL implementations.
:hvar | One or more input host variables.

Comments:

Do not use the FOR clause if the EXECUTE is part of a DECLARE CURSOR statement.

The EXECUTE statement runs the specified prepared SQL statement after substituting values for any parameter markers. (Prepared statements are created using the PREPARE statement.) Only statements that do not return results are permitted.

If the prepared statement contains parameter markers, the EXECUTE statement must include either the USING :hvar option with the same number of host variables or the USING DESCRIPTOR :sqlda_struct option identifying a SQLDA data structure already populated by the application.

The number of parameter markers in the prepared statement must match the number of sqldata entries (USING DESCRIPTOR :sqlda) or host variables (USING :hvar).

Example:

* Store statement to be dynamically executed...
     MOVE "INSERT INTO staff VALUES(?,?,?,?,?)" TO stmtbuf.

* Ensure attempt is not made to insert an existing record
     EXEC SQL
        DELETE FROM staff WHERE staff_id = 99
     END-EXEC

* Prepare the statement
     EXEC SQL
        PREPARE st FROM :stmtbuf
     END-EXEC.

     MOVE 99 TO staff-id
     MOVE 'Lee' TO last-name
     MOVE 'Phil' TO first-name
     MOVE 19 TO age
     MOVE '1997-01-01' TO employment-date

* Execute the statement with current values.
     EXEC SQL
        EXECUTE st USING :staff-id, :last-name
                        ,:first-name, :age, :employment-date
     END-EXEC
     IF SQLCODE = ZERO
        DISPLAY 'Statement executed.'
     ELSE
        DISPLAY 'Error: Could not execute statement.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

* Finally, remove the entry
     EXEC SQL
        DELETE FROM staff where staff_id = 99
     END-EXEC
     IF SQLCODE = ZERO
        DISPLAY 'Values deleted.'
     ELSE
        DISPLAY 'Error: Could not delete inserted values.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF
Parent topic: Embedded SQL Statements
Related concepts
Dynamic SQL
Related reference
DECLARE DATABASE
EXECUTE IMMEDIATE
PREPARE
INCLUDE
QUERY ODBC


EXECUTE IMMEDIATE

Immediately executes the SQL statement.

Syntax:

>>--EXEC SQL--.-------------------.--EXECUTE IMMEDIATE-->
              +--FOR :host_integer---+

 >----:stmt_hvar----END-EXEC-<>

Parameters:

:host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
:stmt_hvar | A character string host variable.

Comments:

Do not use the FOR clause if the EXECUTE IMMEDIATE is part of a DECLARE CURSOR statement.

The EXECUTE IMMEDIATE statement cannot contain input parameter markers or host variables. It cannot return results; any results returned from this statement are discarded. Additionally, the statement cannot contain SQL keywords that pertain exclusively to Embedded SQL.

If any rows are returned, SQLCODE is set to +1.

EXECUTE IMMEDIATE must be used for SET statements specific to the Microsoft SQL Server, that is, those that are intended to execute at that server.

Example:

     EXEC SQL
        DELETE FROM staff WHERE staff_id = 99
     END-EXEC

* Put the required SQL statement in prep.
     MOVE   "insert into staff (staff_id, last_name, first_name ,age,
-           "employment_date) VALUES (99, 'Lee', 'Phillip', 19, '1992-
-           "01-02')" TO prep

* Note EXECUTE IMMEDIATE does not require the statement to be
* prepared
     EXEC SQL
        EXECUTE IMMEDIATE :prep
     END-EXEC

* Check it worked...
     IF SQLCODE = ZERO
        DISPLAY 'Statement executed OK.'
     ELSE
        DISPLAY 'Error: Statement not executed.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

* Run through the same procedure again, this time deleting the
* values just inserted
     MOVE "delete from staff where staff_id = 99" TO prep
     EXEC SQL
        EXECUTE IMMEDIATE :prep
     END-EXEC

     IF SQLCODE = ZERO
        DISPLAY 'Statement executed OK.'
     ELSE
        DISPLAY 'Error: Statement not executed.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF
Parent topic: Embedded SQL Statements
Related concepts
Keywords
Dynamic SQL
Data Structures
Related reference
DECLARE DATABASE
EXECUTE
INCLUDE
PREPARE
QUERY ODBC


FETCH

Retrieves a row from the cursor's results set and writes the values of the columns in that row to the corresponding host variables (or to addresses specified in the SQLDA data structure).

Syntax:

>>--EXEC SQL--.-------------------.--------------->
              +-FOR :host_integer-+

 >--FETCH-------.-------------.------cursor_name-->
                +---PREVIOUS--+
                +---LAST------+
                +---PRIOR-----+
                +---FIRST-----+
                +---NEXT------+

 >--.-------------------------------------.------->
    +-USING DESCRIPTOR :sqlda_struct------+
    |       +--------------------------,-+|
    |       V                            ||
    +-INTO--.-:hvar----------------------.+
            +-:hvar:ivar-----------------+
            +-:hvar-.-----------.-:ivar--+
                    +-INDICATOR-+

 >--END EXEC--><

Parameters:

:host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
cursor_name | A previously declared and opened cursor.
:sqlda_struct | An SQLDA data structure previously populated by the DESCRIBE statement and containing output value addresses. This option is used only with a cursor declared by a prepared SELECT statement. (SELECT statements are prepared using the PREPARE statement.) The colon is optional to provide compatibility with other embedded SQL implementations.
:hvar | Identifies one or more host variables to receive the data.
:ivar Specifies either of the following:
  • One or more host variables, each separated by a comma
  • One or more host variable+indicator variable combinations, each combination separated by a comma

Comments:

By default, the FETCH statement retrieves the next row, but you can also specify the previous row or last row or prior row or first row. If there are no more rows to fetch SQLCODE is set to 100 and SQLSTATE is set to "02000".

An OPEN cursor_name statement must precede a FETCH statement, and the cursor must be open while FETCH runs. If you use PREVIOUS, LAST, PRIOR, FIRST or NEXT, you must also set the appropriate cursor options via the DECLARE CURSOR statement or the SET SCROLLOPTION and SET CONCURRENCY statements. Also, the data type of the host variable must be compatible with the data type of the corresponding database column.

If the number of columns is less than the number of host variables, the value of SQLWARN3 is set to W. If an error occurs, no further columns are processed. (Processed columns are not undone.)

Alternatively, the :hvar variable can specify a COBOL record that contains several fields, each corresponding to a column in the select list of the cursor declaration statement. To use this form, you must specify the DB2 option of the SQL Compiler directive. (Note that this will cause PREPARE INTO and DESCRIBE statements to be rejected by the COBOL compiler).

If ANSI92ENTRY is set, then attempting to fetch a null value will set SQLCODE to -19425 if there is no null indicator. If ANSI92ENTRY is not set, SQLCODE will be 0. In both cases, SQLSTATE will be 22002 and SQLWARN2 will be W.

If one of the host variables in the INTO clause is an array, they must all be arrays.

Comments:

After execution, SQLERRD(3) contains the number of elements processed. For FETCH it is the number of rows actually fetched.

Example:

* Declare a cursor for a given SQL statement.
     EXEC SQL DECLARE C1 CURSOR FOR
        SELECT last_name, first_name FROM staff
     END-EXEC

     EXEC SQL OPEN C1 END-EXEC

* Fetch the current values from the cursor into the host variables
* and if everything goes ok, display the values of the host
* variables
     PERFORM UNTIL SQLCODE NOT = ZERO
        EXEC SQL
           FETCH C1 INTO :lname,:fname
        END-EXEC
        IF SQLCODE NOT = ZERO AND SQLCODE NOT = 100
           DISPLAY 'Error: Could not perform fetch'
           DISPLAY SQLERRML
           DISPLAY SQLERRMC
           EXEC SQL DISCONNECT ALL END-EXEC
           STOP RUN
        END-IF
        DISPLAY 'First name: 'fname
        DISPLAY 'Last name : 'lname
        DISPLAY SPACES
     END-PERFORM
Parent topic: Embedded SQL Statements
Related concepts
Working With OpenESQL Stored Procedures and Result Sets
Working With OpenESQL Cursors and Result Sets
Cursors
Data Structures
Working With HCOSS SQL CLR Stored Procedures and Result Sets
Related reference
BEGIN DECLARE SECTION
CLOSE
DECLARE CURSOR
DELETE (Positioned)
DESCRIBE
OPEN
PREPARE
SELECT DISTINCT (using DECLARE CURSOR)
UPDATE (Positioned)


GET HDBC

Enables you to use ODBC calls that require you to supply the ODBC connection handle.

Syntax:

>>---EXEC SQL---GET HDBC---INTO---:hvar---END-EXEC---->

Parameters:

hvar A host variable to store the ODBC connection handle. Must be declared as PIC X(4) COMP-5.

Example:

EXEC SQL
    GET HENV INTO :HENV
END-EXEC
Parent topic: Embedded SQL Statements
Related reference
GET HENV


GET HENV

Enables you to use ODBC calls that require you to supply the ODBC environment handle.

Syntax:

>>---EXEC SQL---GET HENV---INTO---:hvar---END-EXEC---->

Parameters:

hvar A host variable to store the ODBC environment handle. Must be declared as PIC X(4) COMP-5.

Example:

EXEC SQL
    GET HENV INTO :HENV
END-EXEC
Parent topic: Embedded SQL Statements
Related reference
GET HDBC
GET HENV


GET NEXT RESULT SET

Makes the next result set available to an open cursor.

Syntax:

>>---EXEC SQL---GET NEXT RESULT SET FOR ---cursor_name---END-EXEC---><

Parameter:

cursor_name A previously declared and opened cursor.

Comments:

For client applications compiled without DIALECT=MAINFRAME, GET NEXT RESULT SET makes the next result set available when retrieving multiple result sets from a stored procedure or from a DECLARE CURSOR statement defined with multiple SELECT statements.

If additional result sets are not available, GET NEXT RESULT SET returns an SQLCODE of 100 and sets SQLSTATE to 02000.

Example:

           exec sql declare c cursor for
               call TestProc2(:hv-country)
           end-exec

           exec sql open c end-exec

           display " "
           display "First result set from proc"
           display " "

           perform until exit
               exec sql fetch c into
                   :CustomerID, :Company, :City
               end-exec
               if sqlcode = 100 or sqlcode < 0
                   exit perform
               end-if
               display CustomerID " " City
           end-perform

            *> Always get SQLCODE 100 at the end of a result set
            *> until you close the cursor or ask for another result set
            exec sql fetch c into
                :CustomerID, :Company, :City
            end-exec
            if sqlcode not  = 100
                display "FAIL: Fetch after SQLCODE 100 OK"
            end-if

            *> Ask for another result set, SQLCODE 100 if there isn't one
            exec sql get next result set for c end-exec

            display " "
            display "Second result set from proc"
            display " "

            perform until exit
               exec sql fetch c into
                   :CustomerID, :Company, :City
               end-exec
               if sqlcode = 100 or sqlcode < 0
                   exit perform
               end-if
               display CustomerID " " City
            end-perform
Parent topic: Embedded SQL Statements
Related concepts
Working With OpenESQL Stored Procedures and Result Sets
Working With OpenESQL Cursors and Result Sets
Working With HCOSS SQL CLR Stored Procedures and Result Sets
Related reference
CLOSE


INCLUDE

Includes the definition of the specified SQL data structure or source file in the COBOL program.

Syntax:

>>---EXEC SQL---INCLUDE-----.-SQLCA----.----END-EXEC----><
                            +-SQLDA----+
                            +-filename-+

Parameters:

SQLCA | Indicates that a SQLCA data structure is accessed.
SQLDA | Indicates that a SQLDA data structure is accessed.
filename | Indicates that a file should be included in the source at this point (this is equivalent to the COBOL COPY facility).

Comment:

This statement uses the corresponding .cpy file. Ensure that sqlca.cpy and sqlda.cpy are in the current directory or that the COBCPY environment variable specifies the directory that contains them.

Example:

EXEC SQL INCLUDE SQLCA END-EXEC
EXEC SQL INCLUDE SQLDA END-EXEC
EXEC SQL INCLUDE MYFILE END-EXEC
Parent topic: Embedded SQL Statements
Related concepts
Data Structures
Related reference
DESCRIBE
EXECUTE
EXECUTE IMMEDIATE
OPEN
PREPARE


INSERT

Adds new rows to a table.

Syntax:

>>--EXEC SQL--.-------------------.---------->
              +-FOR :host_integer-+

 >---.------------.--INSERT--.------.---.-table_name-.--->
     +-AT db_name-+          +-INTO-+   +-view_name--+

                                +-------- , ------+
                                V                 |
 >---.---------------.--VALUES (constant_expression)----->
     +-(column_list)-+

 >------END-EXEC---><

Parameters:

:host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
db_name | The name of a database that has been declared using DECLARE DATABASE.
table_name | The table into which rows are to be inserted.
view_name | The view into which rows are to be inserted.
INTO | An optional keyword. Required for ANSI SQL 92 conformance.
column_list | A list of one or more columns to which data is to be added. The columns can be in any order, but the incoming data must be in the same order as the columns. The column list is necessary only when some, but not all, columns in the table are to receive data. Enclose the items in the column list in parentheses. If no column list is given, all the columns in the receiving table (in CREATE TABLE order) are assumed. The column list determines the order in which values are entered.
VALUES | Introduces a list of constant expressions.
constant_expression | Constant or null values for the indicated columns. The values list must be enclosed in parentheses and must match the explicit or implicit columns list. Enclose non-numeric constants in single or quotation marks.

Comments:

The INSERT statement is passed directly to the ODBC driver. See the documentation supplied with your ODBC driver for the exact syntax.

If the host variables in the WHERE clause are arrays, the INSERT statement is executed once for each set of array elements.

Uuse UPDATE to modify column values in an existing row.

You can omit items in the column list and VALUES list providing that the omitted columns are defined to allow null values.

You can select rows from a table and insert them into the same table in a single statement.

After execution, SQLERRD(3) contains the number of elements processed. For INSERT it is the total number of rows inserted.

Example:

     DISPLAY "Enter new staff member's id:"
     ACCEPT staff-id

     DISPLAY "Enter new staff member's last name:"
     ACCEPT last-name

     DISPLAY "Enter new staff member's first name:"
     ACCEPT first-name

     DISPLAY "Enter new staff member's age:"
     ACCEPT age

     DISPLAY "Enter new staff member's employment date(yyyy/mm/dd):"
     ACCEPT employment-date

     EXEC SQL
        INSERT INTO staff
        (staff_id
       ,last_name
       ,first_name
      ,age
       ,employment_date)
        VALUES
        (:staff-id
       ,:last-name
       ,:first-name
       ,:age
       ,:employment-date)
     END-EXEC
Parent topic: Embedded SQL Statements
Related reference
DELETE (Positioned)
DELETE (Searched)
UPDATE (Positioned)
UPDATE (Searched)


OPEN

Runs the SELECT statement specified in the corresponding DECLARE CURSOR statement to produce the results set that is accessed one row at a time by the FETCH statement.

Syntax:

>>--EXEC SQL---OPEN---cursor_name------------------------>

 >----.--------------------------------.----END-EXEC-----><
      +-USING DESCRIPTOR :sqlda_struct-+
      |       +- , -+                  |
      |       V     |                  |
      +-USING :hvar--------------------+

Parameters:

cursor_name | A previously declared cursor.
:sqlda_struct | An SQLDA data structure previously constructed by the application. The SQLDA data structure contains the address, data type, and length of each input parameter. This option is used only with a cursor that references a prepared SQL statement in the DECLARE statement. The colon is optional to provide compatibility with other embedded SQL implementations.
:hvar | One or more input host variables corresponding to parameter markers in the SELECT statement. This option is used only with a cursor that references a prepared SQL statement in the DECLARE statement.

Comments:

If the cursor is declared with a static SELECT statement (that is, one that was not prepared), the SELECT statement can contain host variables but not parameter markers . The current values of the host variables are substituted when the OPEN statement runs. For a statically declared cursor, the OPEN statement cannot contain the USING :hvar or USING DESCRIPTOR :sqlda_struct option.

If the cursor is declared with a dynamic SELECT statement (that is, one that was prepared), the SELECT statement can contain parameter markers but not host variables. Parameter markers can appear wherever column values are allowed in the SELECT statement. If the SELECT statement has parameter markers, the OPEN statement must include either the USING :hvar option with the same number of host variables or the USING DESCRIPTOR :sqlda_struct option identifying an SQLDA data structure already populated by the application.

With the USING DESCRIPTOR :sqlda_struct option, values of the program variables are substituted for parameter markers in the SELECT statement. These program variables are addressed by corresponding SQLDATA entries in the SQLDA data structure.

The number of parameter markers in the SELECT statement must match the number of sqldata entries (USING DESCRIPTOR :sqlda_struct) or host variables (USING :hvar) in the OPEN statement.

Example:

*Declare the cursor...
     EXEC SQL
     DECLARE C1 CURSOR FOR
        SELECT staff_id, last_name
        FROM staff
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not declare cursor.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

     EXEC SQL
        OPEN C1
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not open cursor.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT CURRENT END-EXEC
        STOP RUN
     END-IF

     PERFORM UNTIL sqlcode NOT = ZERO
*SQLCODE will be zero as long as it has successfully fetched data
        EXEC SQL
           FETCH C1 INTO :staff-staff-id, :staff-last-name
        END-EXEC
        IF SQLCODE = ZERO
          DISPLAY "Staff ID: " staff-staff-id
           DISPLAY "Staff member's last name: " staff-last-name
        END-IF
     END-PERFORM

     EXEC SQL
        CLOSE C1
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not close cursor.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
     END-IF
Parent topic: Embedded SQL Statements
Related concepts
Cursors
Data Structures
Dynamic SQL
Related reference
CLOSE
DECLARE CURSOR
FETCH
INCLUDE
QUERY ODBC


PERSIST

Saves information defined in a cursor SELECT statement as XML files.

Syntax:

>>-EXEC SQL--PERSIST cursor_name TO xml_destination->
>-----END-EXEC-----<>

Parameters:

cursor_name | A previously declared and opened cursor.
xml_destination | An identifier, a host variable, or a literal enclosed in single or double quotes

Comments:

To use PERSIST, you must:
  • Have an XML ODBC driver installed
  • Embed the SET SCROLLOPTION statement and set it to STATIC

If you are using Data Direct Connect ODBC drivers, you must use version 3.70 or later.

Example:

 01  hv  pic x(50).
 procedure-division.

    *> set whenever clause to handle sql errors
    exec sql whenever sqlerror goto sql-error end-exec
    exec sql whenever sqlwarning perform sql-warning end-exec

    *> connect to data source
    exec sql connect to "data source"  end-exec

    *> declare static cursor with column info you want to save to xml file
    exec sql
      declare c static cursor for
        select * from emp
    end-exec

    *> open cursor
    exec sql open c end-exec

    *> save data to xml file using double quoted literal
    exec sql
      persist c to "c:\XML Files\xmltest1.xml"
    end-exec

    *> save data to xml file using single quoted literal
    exec sql
      persist c to 'c:\XML Files\xmltest2.xml'
    end-exec

    *> save data to xml file using a host variable
    move "c:\XML Files\xmltest3.xml" to hv
    exec sql
      persist c to :hv
    end-exec

    *> close the cursor
    exec sql close c end-exec

    *> disconnect from datasource
    exec sql disconnect current end-exec

    goback.
Parent topic: Embedded SQL Statements
Related reference
SET SCROLLOPTION
Related information
XML Support


PREPARE

Processes dynamic SQL statements.

Syntax:

>>--EXEC SQL---PREPARE---stmt_name---.-------------.----->
                                     +-INTO :sqlda-+

 >---FROM---:hvar---END-EXEC-----><

Parameters:

stmt_name | The prepared statement name. This can be used by a subsequent EXECUTE or OPEN statement, and/or a previous DECLARE CURSOR statement.
:sqlda | The output SQL descriptor area (SQLDA) data structure to be populated. The colon is optional to provide compatibility with other embedded SQL implementations.
:hvar | The host variable that contains the SQL statement.

Comments:

You can use a prepared statement in one of two ways:

  • You can open a cursor that references a prepared statement.
  • You can execute a prepared statement.

If the prepared statement is used by an EXECUTE statement, :hvar cannot contain a SQL statement that returns results.

Because singleton SELECT statements (SELECT INTO) are not allowed in dynamic SQL statements, they cannot be prepared.

When using PREPARE, the SQL statement in :hvar cannot contain host variables or comments, but it can contain parameter markers. Also, the SQL statement cannot contain SQL keywords that pertain exclusively to Embedded SQL.

The INTO :sqlda option merges the functionality of DESCRIBE and PREPARE so that this example code:

 EXEC SQL
     PREPARE stmt1 INTO :sqlda FROM :stmt-buf
 END-EXEC

is identical to:

 EXEC SQL
     PREPARE stmt1 FROM :stmt-buf
 END-EXEC
 EXEC SQL
     DESCRIBE stmt1 INTO :sqlda
 END-EXEC

For more details about using the PREPARE statement, see your Database Access Guide.

Example:

 PROGRAM-ID. progname.

 WORKING-STORAGE SECTION.
 EXEC SQL INCLUDE SQLCA END-EXEC
 EXEC SQL BEGIN DECLARE SECTION END-EXEC
 01 prep           PIC X(80).
 01 nme            PIC X(20).
 01 car            PIC X(20).
 01 n60            PIC x(5).
 EXEC SQL END DECLARE SECTION END-EXEC.

 PROCEDURE DIVISION.
     EXEC SQL CONNECT TO 'srv1' USER 'sa' END-EXEC
     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not connect to database.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRMC
        STOP RUN
     END-IF

* Ensure attempt is not made to recreate an existing table...
     EXEC SQL DROP TABLE mf_table END-EXEC

* Create a table...
     EXEC SQL CREATE TABLE mf_table
                 (owner          char(20)
                 ,car_col        char(20)
                 ,nought_to_60   char(5))
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not create table'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT CURRENT END-EXEC
        STOP RUN
     END-IF

* Insert an SQL statement into host variable prep...
     MOVE "insert into mf_table values(?,?,?)" TO prep

* Prepare the statement...
     EXEC SQL
        PREPARE prep_stat FROM :prep
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not prepare statement'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT CURRENT END-EXEC
        STOP RUN
     END-IF

     MOVE "Owner" TO nme
     MOVE "Lamborghini" TO car
     MOVE "4.9" TO n60

* Execute the prepared statement using the above host variables...
     EXEC SQL
        EXECUTE prep_stat USING :nme, :car, :n60
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not execute prepared statement.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT CURRENT END-EXEC
        STOP RUN
     END-IF

* Finally, drop the now unwanted table...
     EXEC SQL
        DROP TABLE mf_table
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not drop table.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT CURRENT END-EXEC
        STOP RUN
     END-IF

     DISPLAY 'All statements executed.'
     EXEC SQL DISCONNECT CURRENT END-EXEC
     STOP RUN.
Parent topic: Embedded SQL Statements
Related concepts
Data Structures
Dynamic SQL
Related reference
DECLARE CURSOR
DECLARE DATABASE
DESCRIBE
EXECUTE
FETCH
INCLUDE
EXECUTE IMMEDIATE
QUERY ODBC


QUERY ODBC

Delivers a results set in the same way as a SELECT statement, and must therefore be associated with a cursor via DECLARE and OPEN, or DECLARE, PREPARE and OPEN.

Syntax, Format 1:

>>--EXEC SQL---QUERY ODBC---.-COLUMN--.------------------>
                            +-COLUMNS-+

 >---.--------------------------.--.------------------.--->
     +-QUALIFIER qualifier_name-+  +-OWNER owner_name-+

 >--.----------------------.--.------------------------.-->
    +-TABLENAME table_name-+  +-COLUMNNAME column_name-+

 >---END-EXEC---<>

Syntax, Format 2:

>>--EXEC SQL---QUERY ODBC---.-DATATYPE--.---------------->
                            +-DATATYPES-+

 >---.-------------------------.---END-EXEC---><
     +-TYPE--.-datatype_name--.+
             +-BIGINT---------+
             +-BINARY---------+
             +-BIT------------+
             +-CHAR-----------+
             +-DATE-----------+
             +-DECIMAL--------+
             +-DOUBLE---------+
             +-FLOAT----------+
             +-INTEGER--------+
             +-LONG VARBINARY-+
             +-LONG VARCHAR---+
             +-NUMERIC--------+
             +-REAL-----------+
             +-SMALLINT-------+
             +-TIME-----------+
             +-TIMESTAMP------+
             +-TINYINT--------+
             +-VARBINARY------+
             +-VARCHAR--------+

Syntax, Format 3:

>>--EXEC SQL---QUERY ODBC---.-TABLE--.------------------>
                            +-TABLES-+
>---.--------------------------.--.------------------.--->
    +-QUALIFIER qualifier_name-+  +-OWNER owner_name-+

 >--.----------------------.--.------------------------.-->
    +-TABLENAME table_name-+  +-TYPE tabletype_name----+

 >--END-EXEC--<>

Parameters:

qualifier_name | A host variable, identifier or literal which specifies a qualifier to be used to select tables. Not all ODBC drivers support qualifiers, and those that do may use them in different ways. For example, if a data source supports multiple databases, a qualifier can be used to specify which database to use. Alternatively, for drivers providing access to file based data sources, a qualifier can be used to specify a particular directory to be searched.
owner_name | A host variable, identifier or literal which specifies a table owner to be used to select tables. Not all ODBC drivers support table ownership.
table_name | A host variable, identifier or literal which specifies tables to be included in the query.
datatype_name | A host variable, identifier or literal which specifies a data type to be queried.
tabletype_name | A host variable, identifier or literal which specifies a list of table types to be included in the query.

Comments:

Search patterns consist of the legal characters for SQL identifiers plus underscore (_) which matches any single character, percent (%) which matches any sequence of zero or more characters, or a driver defined escape character which can be used to allow underscore or percent in a pattern to represent themselves rather than a wildcard.

If a search pattern parameter is not supplied, a pattern of % is used, which will match all relevant dictionary entries.

For table queries the following special rules apply:

  • If qualifier-name is % and owner-name and table-name are empty strings, the results set consists of a list of valid qualifiers at the data source. All columns apart from TABLE_QUALIFIER in the results set (see below) will be null.
  • If owner-name is % and qualifier-name and table-name are empty strings, the results set consists of a list of valid owners at the data source. All columns apart from TABLE_OWNER in the results set (see below) will be null.
  • If tabletype-name is % and qualifier-name, owner-name and table-name are empty strings the results set consists of a list of valid table types at the data source. All columns apart from TABLE_TYPE in the results set (see below) will be null.
  • If tabletype-name is not specified, tables of all types will be returned in the results set. If it is specified it must consist of a comma separated list of table types, for example'TABLE,VIEW'.

Example:

     EXEC SQL
        DECLARE tcurs CURSOR FOR QUERY ODBC TABLES
     END-EXEC

     EXEC SQL DECLARE C1 CURSOR FOR
        QUERY ODBC TABLES OWNER :tab-owner TABLETYPE 'TABLE,VIEW'
     END-EXEC

     MOVE 'staff' to tab-name
     EXEC SQL DECLARE C2 CURSOR FOR
        QUERY ODBC COLUMNS TABLENAME :tab-name
     END-EXEC

     EXEC SQL DECLARE C3 CURSOR FOR
        QUERY ODBC DATATYPES
     END-EXEC
  • QUERY ODBC - Column Query
  • QUERY ODBC - Data Type Query
  • QUERY ODBC - Table Query
Parent topic: Embedded SQL Statements
Related concepts
Cursors
Dynamic SQL
Related reference
DECLARE CURSOR
EXECUTE
EXECUTE IMMEDIATE
PREPARE
OPEN


QUERY ODBC - Column Query

The results set for a column query is:

TABLE_QUALIFIER | VARCHAR(128) |
TABLE_OWNER | VARCHAR(128) |
TABLE_NAME | VARCHAR(128) NOT NULL |
COLUMN_NAME | VARCHAR(128) NOT NULL |
DATA_TYPE | SMALLINT NOT NULL | See odbcext.cpy and odbc.cpy for constants representing the ODBC data type codes.
TYPE_NAME | VARCHAR(128) NOT NULL | Driver dependent name for the column's data type.
PRECISION | INTEGER |
LENGTH | INTEGER | Amount of memory required for a column value in its native representation.
SCALE | SMALLINT |
RADIX | SMALLINT | For numeric columns either 10 or 2 depending on the data type; otherwise null
NULLABLE | SMALLINT NOT NULL |
REMARKS | VARCHAR(254) |
Parent topic: QUERY ODBC


QUERY ODBC - Data Type Query

The results set for a data type query is:

TYPE_NAME | VARCHAR(128) NOT NULL | Driver dependent name for the column's data type
DATA_TYPE | SMALLINT NOT NULL | See odbcext.cpy and odbc.cpy for constants representing the ODBC data type codes.
PRECISION | INTEGER | Maximum precision for columns of this type.
LITERAL_PREFIX | VARCHAR(128) | Character or characters required to prefix literal values for this type.
LITERAL_SUFFIX | VARCHAR(128) | Character or characters required to suffix literal values for this type.
CREATE_PARAMS | VARCHAR(128) | Parameters required when creating a column of this type, for example, 'precision,scale' for decimal types.
NULLABLE | SMALLINT NOT NULL |
CASE_SENSITIVE | SMALLINT NOT NULL | Specifies case sensitivity in comparisons for character data types.
SEARCHABLE | SMALLINT NOT NULL | SQL_UNSEARCHABLE, SQL_LIKE_ONLY or SQL_ALL_EXCEPT_LIKE (these are defined in odbc_cpy).
UNSIGNED_ATTRIBUTE | SMALLINT | Specifies if a numeric type is signed or unsigned.
MONEY | SMALLINT NOT NULL | Specifies if a numeric type is a money data type.
AUTO_INCREMENT | SMALLINT | Specifies if the data type is auto incrementing .
LOCAL_TYPE_NAME | VARCHAR(128) | Localized version of the data type name.
MINIMUM_SCALE | SMALLINT |
MAXIMUM_SCALE | SMALLINT |
Parent topic: QUERY ODBC


QUERY ODBC - Table Query

The results set for a table query is:

TABLE_QUALIFIER | VARCHAR(128) |
TABLE_OWNER | VARCHAR(128) |
TABLE_NAME | VARCHAR(128) |
TABLE_TYPE | VARCHAR(128) | One of TABLE, VIEW, SYSTEM TABLE, GLOBAL TEMPORARY, LOCAL TEMPORARY, ALIAS, SYNONYM or a data source specific type identifier
REMARKS | VARCHAR(254) |
Parent topic: QUERY ODBC


RESET CONNECTION

Closes all open cursors, even if the application has not appropriately closed them.

Syntax:

>>---EXEC SQL---RESET CONNECTION---END-EXEC---><

Comments:

Use RESET CONNECTION in the XA switch modules provided for Enterprise Server environments to ensure that all cursors have been closed before a new unit of work is started.

In Enterprise Server environments, RESET CONNECTION ensures that all database locks acquired are released if the application fails to close cursors explicitly.

Parent topic: Embedded SQL Statements


ROLLBACK

Backs out any changes made to the database by the current transaction on the current connection.

Syntax:

>>---EXEC SQL---ROLLBACK----.-WORK---------.------------->
                            +-TRAN---------+
                            +-TRANSACTION--+

 >---.-----------.---END-EXEC---><
     +--RELEASE--+

Comment:

If RELEASE is specified and the transaction was successfully rolled back, the current connection is closed.

Example:

EXEC SQL
   ROLLBACK
END-EXEC

EXEC SQL
    ROLLBACK WORK RELEASE
END-EXEC
Parent topic: Embedded SQL Statements
Related concepts
Managing Transactions
Related reference
COMMIT
CONNECT
DISCONNECT
SET CONNECTION


SELECT DISTINCT (using DECLARE CURSOR)

Associates the cursor name with the SELECT DISTINCT statement and enables you to retrieve rows of data using the FETCH statement.

Syntax:

>>---EXEC SQL--.------------.------DECLARE cursor_name---->
               +-AT db_name-+

 >---CURSOR FOR------SELECT DISTINCT------select_list------>

 >---FROM----table_list--.-----------------2--END-EXEC----><
                         +-select_options--+

Parameters:

db_name | The name of a database that has been declared using DECLARE DATABASE.
cursor_name | Cursor name used to identify the cursor in subsequent statements. Cursor names can contain any legal filename character and be up to 30 characters in length. The first character must be a letter.
select_list | The name of the columns to retrieve.
table_list | The name of the tables that contain the columns to be retrieved, as specified in select_list.
select_options | The options specified to limit the number of rows retrieved and/or order the rows retrieved.

Comments:

Two separately compiled programs cannot share the same cursor. All statements that reference a particular cursor must be compiled together.

The SELECT DISTINCT statement runs when the cursor is opened. The following rules apply to the SELECT DISTINCT statement:

  • The statement cannot contain an INTO clause or parameter markers.
  • The statement can contain input host variables previously identified in a declaration section.
  • With some ODBC drivers, the SELECT DISTINCT statement must include a FOR UPDATE clause if positioned updates or deletions are to be performed.
Note:

Use SELECT DISTINCT instead of SELECT INTO to remove duplicate rows in the row set.

Example:

 01 age-array        pic s9(09) comp-5 occurs 10 times.
 01 lname-array      pic x(32)   occurs 10 times.

    MOVE 5 TO staff-id
    EXEC SQL
       SELECT DISTINCT last_name
          INTO :lname-array
          FROM staff
          WHERE staff_id > :staff-id
    END-EXEC

    EXEC SQL
       SELECT DISTINCT age
          INTO :age-array
          FROM staff
          WHERE first_name > 'George'
    END-EXEC
Parent topic: Embedded SQL Statements
Related reference
DECLARE CURSOR
FETCH
SELECT INTO


SELECT INTO

Retrieves one row of results and assigns the values of the items in a specified SELECT list to the host variables specified in the INTO list.

Syntax:

>>---EXEC SQL--.-------------------.---.------------.---->
               +-FOR :host_integer-+   +-AT db_name-+

                                        +- ,-+
                                        V    |
 >----SELECT----.-------------.---INTO--:hvar------------->
                +-select_list-+

 >----select_options----END-EXEC---><

Parameters:

:host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
db_name | The name of a database that has been declared using DECLARE DATABASE.
select_list | The portion of the table to retrieve data from.
:hvar | One or more host variables to receive the select_list items.
select_options | One or more statements or other options that can be used with the SQL SELECT statement (for example, a FROM or WHERE clause).

Comments:

A singleton SELECT must contain a FROM clause.

If more columns are selected than the number of receiving host variables, the value of sqlwarn3 is set to 'W'. The data type and length of the host variable must be compatible with the value assigned to it. If data is truncated, the value of sqlwarn1 is set to 'W'.

If a SELECT INTO statement returns more than one row from the database, all rows except the first one will be discarded and sqlwarn4 will be set to "W". If you want to return more than the first row, you should use a cursor. Alternatively, you can specify array items in the INTO clause. The array will be populated up to either the maximum size of the array, the value of host_integer or the number of rows returned, whichever is the smallest.

If ANSI92ENTRY is set and a singleton SELECT retrieves more than 1 row, SQLCODE will be -811, SQLSTATE will be 21000 and SQLWARN4 will be W. If ANSI92ENTRY is not set, no error or warning conditions will be set.

Note:

If any one of the host variables in the INTO clause is an array, then they all must be arrays.

Example:

  ...
     MOVE 99 TO staff-id
     EXEC SQL
        SELECT last_name
           INTO :lname
           FROM staff
           WHERE staff_id=:staff-id
     END-EXEC
     EXEC SQL
        SELECT staff_id
           INTO :staff-id
           FROM staff
           WHERE first_name = 'Phil'
     END-EXEC
Parent topic: Embedded SQL Statements
Related concepts
Cursors
Data Structures
Related reference
BEGIN DECLARE SECTION
DECLARE CURSOR
SELECT DISTINCT (using DECLARE CURSOR)


SET AUTOCOMMIT

Enables you to control ODBC AUTOCOMMIT mode at runtime.

Syntax:

>>--EXEC SQL--SET AUTOCOMMIT---.-ON--.---END-EXEC--><
                               +-OFF-+

Parameters:

ON | Changes to AUTOCOMMIT mode, whereby each SQL statement is treated as a separate transaction and is committed immediately upon execution.
OFF | Switches off AUTOCOMMIT mode. If the ODBC driver you are using supports transactions, statements must be explicitly committed (or rolled back) as part of a transaction.

Comments:

The SET AUTOCOMMIT statement is useful for data sources which can only execute DDL statements, such as CREATE and DROP, in AUTOCOMMIT mode.

This statement overrides the AUTOCOMMIT SQL compiler directive.

Example:

EXEC SQL SET AUTOCOMMIT ON END-EXEC
Parent topic: Embedded SQL Statements
Related reference
BEGIN TRAN
AUTOCOMMIT


SET CONCURRENCY

Sets the concurrency option for cursors.

Syntax:

>>--EXEC SQL--SET CONCURRENCY--.-READONLY-.---END-EXEC--><
                               +-LOCKCC---+
                               +-OPTCC----+
                               +-OPTCCVAL-+

Parameters:

READONLY | Specifies read-only cursors. Data cannot be modified.
LOCKCC | Places an update intent lock on the data page that contains each row as it is fetched. If not inside an open transaction, the locks are released when the next fetch is performed. If inside an open transaction, the locks are released when the transaction is closed.
OPTCC | Optimistic concurrency control using timestamp or values. Changes to a row through the cursor succeed only if the row remains unchanged since the last fetch. Changes are detected by comparing timestamps or by comparing all non-text, non-image values if timestamps are not available.
OPTCCVAL | Optimistic concurrency control using values. Changes to a row through the cursor succeed only if the row remains unchanged since the last fetch. Changes are detected by comparing all non-text, non-image values.

Dependencies:

The BEHAVIOR compiler directive option must be set to UNOPTIMIZED.

Comments:

The SET CONCURRENCY statement is not supported by all ODBC drivers.

You should establish a connection before you use SET CONCURRENCY.

The default is LOCKCC unless:

  • The ESQLVERSION option of the SQL Compiler directive is set to 2.0, in which case the default is OPTCC.
  • LOCKCC is not supported by the ODBC driver, in which case SET CONCURRENCY is set to READONLY (all ODBC drivers should support this setting).

If you try to set an option which is not supported by the ODBC driver, you will get an error (-19512).

Note:
  • If you are using the Microsoft Access driver, the default for CONCURRENCY is set to READONLY. If you want to use an updateable cursor with Access, you must compile with SQL(USECURLIB=YES) and use SCROLLOPTION STATIC and CONCURRENCY OPTCCVAL (or OPTIMISTIC).
  • If the OPTCC or OPTCCVAL option is used, an UPDATE WHERE CURRENT OF statement can fail, with a value in SQLCODE of -532 (SQLSTATE = "01001"), if the row has been changed since the last FETCH statement. Your application needs to contain code to handle this situation.

Example:

EXEC SQL SET CONCURRENCY READONLY END-EXEC
Parent topic: Embedded SQL Statements
Related reference
DECLARE CURSOR
BEHAVIOR
UPDATE (Positioned)
SET OPTION


SET CONNECTION

Sets the named connection as the current connection.

Syntax:

>>--EXEC SQL--SET CONNECTION---.-name-----.---END-EXEC--><
                               +-DEFAULT--+

Parameters:

name | Specifies the name of a database connection. Must match the connection name specified in a previous CONNECT statement. The name can be either the connection's literal name or the name of a host variable containing character values.
DEFAULT | If you have established a connection using the CONNECT statement but omitting the connection name, you can refer to the connection established as DEFAULT.

Comment:

If you are using connections across compilation modules you must use named connections.

Example:

     EXEC SQL CONNECT TO "srv1" AS server1 USER "sa." END-EXEC
     EXEC SQL CONNECT TO "srv2" AS server2 USER "sa." END-EXEC

* server2 is the current connection
     EXEC SQL CREATE TABLE phil1
        (charbit    CHAR(5))
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not create table.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

     EXEC SQL INSERT INTO phil1 VALUES('hello') END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not insert data.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
      END-IF

* set the current connection to server1
     EXEC SQL SET CONNECTION server1 END-EXEC
     EXEC SQL
        SELECT first_name
           INTO :fname
           FROM staff
           WHERE staff_id = 10
     END-EXEC

     DISPLAY fname ' says ' WITH NO ADVANCING

* set the current connection back to server2
     EXEC SQL SET CONNECTION server2 END-EXEC
     EXEC SQL
        SELECT charbit
           INTO :fname
           WHERE charbit = 'hello'
           FROM phil1
     END-EXEC

     DISPLAY fname
     EXEC SQL DISCONNECT server1 END-EXEC
     EXEC SQL DISCONNECT server2 END-EXEC
     STOP RUN
Parent topic: Embedded SQL Statements
Related reference
COMMIT
CONNECT
DISCONNECT
ROLLBACK


SET OPTION

Enables you to set OpenESQL options.

Syntax:

>>---EXEC SQL---SET OPTION----.-QUERYTIME---.--->
                              +-LOGINTIME---+
                              +-APPLICATION-+
                              +-HOST--------+

 >---value---END-EXEC---><

Parameters:

value | A literal or the name of a host variable. The host variable must contain character values for APPLICATION or HOST and numeric values for LOGINTIME or QUERYTIME.
QUERYTIME | Sets the number of seconds that the program waits for a response to an OpenESQL statement. The default is 0, meaning forever. This option does not override existing network timeout settings.
LOGINTIME | Sets the number of seconds that the program waits for a response to a CONNECT TO statement. The default is 10 seconds. A value of 0 indicates an infinite timeout period.
APPLICATION | Sets the application name which is passed by OpenESQL to the data source when a CONNECT TO statement is executed.
HOST | Sets the host workstation name which is passed by OpenESQL when a CONNECT TO statement is executed.

Comment:

The SET OPTION statement is not supported by all ODBC drivers.

Example:

     EXEC SQL SET OPTION logintime 5 END-EXEC

     EXEC SQL CONNECT TO "srv2" USER "sa." END-EXEC

* If the CONNECT statement cannot log in to the server "srv2"
* within five seconds, it will time out and return to the program.

     EXEC SQL SET OPTION querytime 2 END-EXEC

     EXEC SQL SELECT name FROM sysobjects INTO :name END-EXEC

* If the SELECT statement does not respond within 2 seconds,
* the query will time out and return to the program.
Parent topic: Embedded SQL Statements
Related reference
CONNECT
SET CONCURRENCY
SET SCROLLOPTION


SET SCROLLOPTION

Enables you to set cursor scrolling options.

Syntax:

>>--EXEC SQL--SET SCROLLOPTION--.-KEYSET----.--END-EXEC-><
                                +-DYNAMIC------+
                                +-FORWARD------+
                                +-STATIC-------+
                                +-FASTFORWARD--+
                                +-FAST FORWARD-+

Parameters:

KEYSET | In a keyset cursor, the membership and order of rows in the cursor result set is determined when the cursor is opened. A row will not be fetched if it is deleted or if it is updated such that it no longer meets the WHERE clause criteria. A row appears in the cursor result set only if it is inserted through a cursor based on a single table. Any updates made by the cursor owner and committed changes made by other users to any of the rows in the results set are visible.
DYNAMIC | With a dynamic cursor, membership of rows in the cursor result set is determined at fetch time and it can change between each fetch. A row will disappear from the cursor result set if it is deleted or if it is updated such that it no longer meets the WHERE clause criteria. A row appears in the result set if it is inserted or updated such that it meets the WHERE clause criteria. Any updates made by the cursor owner and committed changes made by other users to any of the rows in the result set are visible.
FORWARD | Equivalent to DYNAMIC, but the application can only move forward through the result set.
STATIC | In a static cursor, the result set appears to be static. Changes to the membership, order or values of the result set after the cursor is opened are not usually detected.
FASTFORWARD and FAST FORWARD | FAST FORWARD and FASTFORWARD are equivalent. This is a performance optimization parameter that applies only to FORWARD, READ-ONLY cursors. You can obtain even greater performance gains by also compiling the program with the AUTOFETCH directive; this is the most efficient method of getting a results set into an application. The AUTOFETCH directive enables two optimizations that can significantly reduce network traffic. The most dramatic improvement is seen when processing cursors with relatively small result sets that can be cached in the memory of an application. FASTFORWARD cursors work only with Microsoft SQL Server 2000 or later servers.

Dependencies:

The BEHAVIOR compiler directive option must be set to UNOPTIMIZED.

Comments:

The SET SCROLLOPTION statement is not supported by all ODBC drivers.

You should establish a connection before you use SET SCROLLOPTION.

The default is DYNAMIC unless:

  • The ESQLVERSION option of the SQL Compiler directive is set to 2.0, in which case the default is KEYSET.
  • The ODBC driver does not support DYNAMIC, in which case SET SCROLLOPTION is set to FORWARD (all ODBC drivers should support this setting).
  • FAST FORWARD works only with Microsoft SQL Server data sources.

If you try to set an option which is not supported by the ODBC driver, you will get an error (-19512).

Example:

 PROGRAM-ID. progname.
 WORKING-STORAGE SECTION.
 EXEC SQL INCLUDE SQLCA END-EXEC
 01      buffer      PIC x(32).
 01      cnt         PIC 9 COMP-5.

 PROCEDURE DIVISION.
     EXEC SQL CONNECT TO 'srv1' USER 'sa' END-EXEC
     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not connect to database.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
     END-IF
* Any cursors declared hereafter can be updated dynamically
     EXEC SQL SET SCROLLOPTION DYNAMIC END-EXEC
     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not set scroll option.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

* Ensure multiple tables are not created ...
     EXEC SQL DROP TABLE phil1 END-EXEC

* Create a table...
     EXEC SQL
        CREATE TABLE phil1
             (ident      char(3)
             ,textbit    char(3))
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not create table.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

* Insert some values into it...
     EXEC SQL
        INSERT INTO phil1
            (ident
            ,textbit)
        VALUES
            ('AAA'
            ,'BBB')
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not insert values.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

     EXEC SQL
        INSERT INTO phil1
            (ident
           ,textbit)
         VALUES
           ('CCC'
            ,'DDD')
    END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not insert values.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

* Declare a cursor...
     EXEC SQL
        DECLARE C1 CURSOR FOR
           SELECT ident
           FROM phil1
           WHERE textbit = 'BBB'
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not declare cursor.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

* Open it...
     EXEC SQL
        OPEN C1
     END-EXEC
     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not open cursor.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

* Update one of the rows in the table such that it now meets the
* cursor requirements...
     EXEC SQL
        UPDATE phil1
        SET textbit = 'BBB'
        WHERE ident = 'CCC'
     END-EXEC

     IF SQLCODE NOT = ZERO
        DISPLAY 'Error: Could not update row.'
        DISPLAY SQLERRMC
        DISPLAY SQLERRML
        EXEC SQL DISCONNECT ALL END-EXEC
        STOP RUN
     END-IF

* Despite the row being updated to meet cursor requirement after
* the cursor was opened, SET SCROLLOPTION DYNAMIC should ensure
* that it is pointed to by the cursor. Check the displayed output
* to be sure...
    MOVE 0 TO cnt
    PERFORM UNTIL SQLCODE NOT = ZERO
       EXEC SQL
          FETCH C1 INTO :buffer
       END-EXEC
       IF SQLCODE = ZERO
          DISPLAY buffer
       END-IF
    END-PERFORM

    EXEC SQL
       CLOSE C1
    END-EXEC

    IF SQLCODE NOT = ZERO
       DISPLAY 'Error: Could not close cursor.'
       DISPLAY SQLERRMC
       DISPLAY SQLERRML
       EXEC SQL DISCONNECT ALL END-EXEC
       STOP RUN
    END-IF

    EXEC SQL DROP TABLE phil1 END-EXEC

    IF SQLCODE NOT = ZERO
       DISPLAY 'Error: Could not drop table.'
       DISPLAY SQLERRMC
       DISPLAY SQLERRML
       EXEC SQL DISCONNECT ALL END-EXEC
       STOP RUN
    END-IF

    EXEC SQL DISCONNECT CURRENT END-EXEC
    STOP RUN.
Parent topic: Embedded SQL Statements
Related reference
DECLARE CURSOR
BEHAVIOR
PERSIST
SET OPTION
AUTOFETCH
UPDATE (Positioned)


SET TRACELEVEL

Enables you to dynamically set or change the reporting level of OpenESQL traces for native applications.

Syntax:

>>--EXEC SQL--SET TRACELEVEL--.-0-------.---END-EXEC--><
                              +-1-------+
                              +-2-------+
                              +-3-------+
                              +-4-------+
                              +-OFF-----+
                              +-DEFAULT-+

Parameters:

0

Turns off the OpenESQL trace.

1

The following information is written to the trace file:

BEGIN | traces main SQL directives
END | indicates end of run
DIRECTIVES | traces per compilation unit directives the first time a compilation unit is enountered at run time
PREPARE | identifies the original source code when a statement is prepared
DISPOSE | provides summary information for overall statement usage when a statement is removed from the prepared statement cache at disconnect time
FLUSH | provides summary information for overall statement usage when a statement is flushed from the cache usually due to a cache overflow

2

The following information is written to the trace file in addition to the information written when you set the trace level to 1:

OPEN
EXECUTE | provides the number of rows selected, inserted, or updated
EXEC_IMMED EXECUTE | provides the number of rows selected, inserted, or updated
ODBCCLOSE | provides summary information for the current cursor use
STMT_CHANGED | reports new concurrency and scroll option settings when the ODBC driver uses different settings than those requested by OpenESQL

3

The following information is written to the trace file in addition to the information written when you set the trace level to 2:

ODBCFETCH | provides the number of rows fetched
COBOLFETCH | provides the number of rows returned to the COBOL application

4

The following information is written to the trace file in addition to the information written when you set the trace level to 3:

  • EXEC_SQL_BEGIN
  • EXEC_SQL_END

OFF

Turns off the OpenESQL trace.

DEFAULT

Resets the trace setting to the value set by the SQL TRACELEVEL directive. If the TRACELEVEL directive was not used to compile a program, this is equivalent to setting this option to OFF.

Example:

EXEC SQL SET TRACELEVEL DEFAULT END-EXEC
Parent topic: Embedded SQL Statements


SET TRANSACTION ISOLATION

Sets the transaction isolation level for the current connection to one of the isolation level modes specified by ODBC.

Syntax:

>>--EXEC SQL--SET TRANSACTION ISOLATION------------------->

 >-------.-READ UNCOMMITTED-.---------END-EXEC------------><
         +-READ COMMITTED---+
         +-REPEATABLE READ--+
         +-SERIALIZABLE-----+

Comments:

Transactions can affect each other in the following ways, depending on the setting of the transaction isolation level:

  • Dirty read - Transaction 1 updates a row. Transaction 2 reads the row before transaction 1 commits. Transaction 1 issues a rollback. Transaction 2's results are based on invalid data.
  • Nonrepeatable read - Transaction 1 reads a row. Transaction 2 updates or deletes the row and commits the change. If transaction 1 re-reads the row, it will retrieve different values, or may not be able to re-read the row.
  • Phantom - Transaction 1 reads a set of rows using a select with a where clause. Transaction 2 inserts a row that satisfies the where clause. If transaction 1 repeats the select, it will read a different set of rows.

These situations can be controlled by locking, which means that a transaction might have to wait until another transaction completes, which limits concurrency (sometimes called pessimistic concurrency), or by forcing a transaction to rollback if the situation occurs, which has less of an impact on concurrency but may force work to be repeated (this is sometimes called optimistic concurrency).

In READ UNCOMMITED mode, dirty reads, nonrepeatable reads and phantoms are all possible.

In READ COMMITED mode, dirty reads are not possible but nonrepeatable reads and phantoms are.

In REPEATABLE READ mode, dirty reads and nonrepeatable reads are not possible, but phantoms are.

In SERIALIZABLE mode dirty reads, nonrepeatable reads and phantoms are all impossible.

Note:

A driver might not support all the isolation levels defined by ODBC. If you set a mode that the driver does not support, SQLCODE and SQLSTATE are set accordingly.

Example:

EXEC SQL SET TRANSACTION ISOLATION READ UNCOMMITTED END-EXEC
Parent topic: Embedded SQL Statements


SYNCPOINT

Closes all open cursors that were not opened using the WITH HOLD clause, even if the application has not appropriately closed them.

Syntax:

>>---EXEC SQL---SYNCPOINT---END-EXEC---><

Comments:

Use SYNCPOINT in the XA switch modules provided for Enterprise Server environments to ensure that all cursors that were not opened using the WITH HOLD clause have been closed before a new unit of work is started.

In Enterprise Server environments, SYNCPOINT ensures that all database locks acquired are released if the application fails to close cursors explicitly.

Parent topic: Embedded SQL Statements


UPDATE (Positioned)

Syntax:

>>---EXEC SQL---.-----------------.--.------------.----->
                +--FOR :host_integer-+  +-AT db_name-+

                                  +------ ,--------+
                                  V                |
 >---UPDATE---table_name-----SET--column_expression----->

 >--WHERE CURRENT OF--cursor_name---END-EXEC---><

Parameters:

:host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
db_name | The name of a database that has been declared using DECLARE DATABASE.
table_name | The table to be updated.
column_expression | A value for a particular column name. This value can be an expression or a null value.
cursor_name | A previously declared, opened, and fetched cursor.

Comments:

Do not use the FOR clause if the UPDATE is part of a DECLARE CURSOR statement.

After execution, SQLERRD(3) contains the number of elements processed. For UPDATE it is the total number of rows updated.

ODBC supports positioned update, which updates the row most recently fetched by using a cursor, in the Extended Syntax (it was in the core Syntax for ODBC 1.0 but was moved to the Extended Syntax for ODBC 2.0). Not all drivers provide support for positioned update, although OpenESQL sets ODBC cursor names to be the same as COBOL cursor names to facilitate positioned update and delete.

With some ODBC drivers, the select statement used by the cursor must contain a FOR UPDATE clause to enable positioned update.

The other form of UPDATE used in standard SQL statements is known as a searched update.

You cannot use host arrays with positioned update.

Most data sources require specific combinations of SCROLLOPTION and CONCURRENCY to be specified either by SET statements or in the DECLARE CURSOR statement.

The ODBC cursor library provides a restricted implementation of positioned update which can be enabled by compiling with SQL(USECURLIB=YES) and using SCROLLOPTION STATIC and CONCURRENCY OPTCCVAL (or OPTIMISTIC).

Example:

     EXEC SQL CONNECT TO 'srv1' USER 'sa' END-EXEC

     EXEC SQL DECLARE C1 CURSOR FOR
        SELECT last_name, first_name
        FROM staff
        FOR UPDATE
     END-EXEC

     EXEC SQL
        OPEN C1
     END-EXEC

     PERFORM UNTIL SQLCODE NOT = ZERO

        EXEC SQL
            FETCH C1 INTO :fname,:lname
        END-EXEC

        IF SQLCODE = ZERO
           DISPLAY fname " " lname
           DISPLAY "Update?"
           ACCEPT reply
           IF reply = "y"
              DISPLAY "New last name?"
              ACCEPT lname
              EXEC SQL
                 UPDATE staff
                 SET last_name=:lname WHERE CURRENT OF c1
              END-EXEC
              DISPLAY "update sqlcode=" SQLCODE
            END-IF
        END-IF
     END-PERFORM

     EXEC SQL DISCONNECT ALL END-EXEC
     STOP RUN.
Parent topic: Embedded SQL Statements
Related concepts
Cursors
Related reference
INSERT
SET CONCURRENCY
DECLARE CURSOR
DECLARE DATABASE
FETCH
SET SCROLLOPTION
UPDATE (Searched)


UPDATE (Searched)

Updates a table or view based on specified search conditions.

Syntax:

>>--EXEC SQL--.-------------------.---------------------->
              +-FOR :host_integer-+

 >-----.-------------.------UPDATE------.-table_name-.---->
       +-AT db_name--+                  +-view_name--+

          +------ ,--------+
          V                |
 >---SET--column_expression--.-------------------------.-->
                             +-WHERE search_conditions-+

 >----END-EXEC---><

Parameters:

:host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
db_name | The name of a database that has been declared using DECLARE DATABASE.
table_name | The table to be updated.
view_name | The view to be updated.
column_expression | A value for a particular column name. This value can be an expression or a null value.
search_conditions | Any valid expression that can follow the standard SQL WHERE clause.

Comments:

UPDATE is a standard SQL statement which is passed directly to the ODBC driver. See the documentation supplied with your ODBC driver for the exact syntax.

If you do not specify a WHERE clause, all the rows in the named table are updated.

If one of the host variables used in the WHERE clause or SET clause is an array, they must all be arrays.

After execution, SQLERRD(3) contains the number of elements processed. For UPDATE it is the total number of rows updated.

Example:

     EXEC SQL
        UPDATE staff
        SET first_name = 'Jonathan'
        WHERE staff_id = 1
     END-EXEC

     MOVE 'Phil' TO NewName
     MOVE 1 TO targetID

     EXEC SQL
        UPDATE staff
        SET first_name = :NewName
        WHERE staff_id  = :targetID
     END-EXEC
Parent topic: Embedded SQL Statements
Related reference
INSERT
UPDATE (Positioned)


WHENEVER

Specifies the default action after running an Embedded SQL statement when a specific condition is met.

Syntax:

>>--EXEC SQL---WHENEVER---.-NOT FOUND--.----------------->
                          +-SQLERROR---+
                          +-SQLWARNING-+

 >--.-CONTINUE--------.----END-EXEC---><
    +-PERFORM label---+
    +-GOTO stmt_label-+

Parameters:

CONTINUE | Causes the next sequential statement in the source program to run.
PERFORM label | Identifies a paragraph or section of code to be performed when a certain error level is detected.
GOTO stmt_label | Identifies the place in the program that takes control when a certain error level is detected.

Comments:

The WHENEVER statement specifies the default action after running an Embedded SQL statement on each of the following conditions: NOT FOUND, SQLERROR, SQLWARNING.

Condition | sqlcode
No error | 0
NOT FOUND | 100
SQLWARNING | +1
SQLERROR | < 0 (negative)

The scope of a WHENEVER statement is related to the position of statements in the source program, not in the run sequence. The default is CONTINUE for all three conditions.

Example:

The following example shows the WHENEVER statement in use:

     EXEC SQL WHENEVER sqlerror PERFORM errormessage1 END-EXEC

     EXEC SQL
        DELETE FROM staff
        WHERE staff_id = 'hello'
     END-EXEC

     EXEC SQL
        DELETE FROM students
        WHERE student_id = 'hello'
     END-EXEC

     EXEC SQL WHENEVER sqlerror CONTINUE END-EXEC

     EXEC SQL
        INSERT INTO staff VALUES ('hello')
     END-EXEC

     DISPLAY 'Sql Code is: ' SQLCODE
     EXEC SQL WHENEVER sqlerror PERFORM errormessage2 END-EXEC

     EXEC SQL
        INSERT INTO staff VALUES ('hello again')
     END-EXEC

     STOP RUN.

 errormessage1 SECTION.
     display "SQL DELETE error: " sqlcode
     EXIT.

 errormessage2 SECTION.
     display "SQL INSERT error: " sqlcode
     EXIT.
Parent topic: Embedded SQL Statements
Related reference
The SQLCA Data Structure


Embedded ADO Statements

  • ACCEPT CHANGES
    Commits all pending changes made in the specified DataTables of the DataSet.
  • BIND
    Allows an ADO.NET DataSet or DataTable to be shared with OpenESQL.
  • BIND CONNECTION
    Enables the pair of ADO.NET connection and transaction objects to be shared with OpenESQL.
  • CLEAR
    Clears the data in the specified DataTables of a DataSet.
  • CLOSE
    Closes a previously declared and opened DataRows cursor.
  • DECLARE DATAROWS
    Declares an ADO.NET DataRows cursor (similar to an SQL cursor) based on criteria established against a particular DataTable.
  • DECLARE DATASET
    Defines a typed or an untyped DataSet.
  • DECLARE DATATABLE
    Defines an ADO.NET DataTable.
  • DELETE (POSITIONED)
    Deletes the row most recently fetched by a DataRows cursor.
  • DELETE (SEARCHED)
    Removes the DataRows that meet the row state and/or search criteria from the named DataTable.
  • FETCH
    Transfers all or a subset of a DataRows cursor into host variables or host arrays.
  • FILL
    Adds new DataRows to (or refreshes the existing DataRows of) the DataTables in a DataSet using data from the data source.
  • GET CHANGES
    Creates a new DataSet containing only DataRows that have been modified (deleted, added or changed).
  • GET CONNECTION
    Places the current OpenESQL connection and transaction objects into the supplied host variables such that the objects can then be shared with other ADO.NET programs.
  • GET CURSOR
    Places a DataReader or a DataSet ADO.NET object used by the OpenESQL EXEC SQL cursor into the supplied host variable such that the object can then be shared with other ADO.NET programs.
  • GET DATATABLE
    Copies a DataTable object into a host variable or creates a DataTable object within a host variable, enabling you to share the DataTable object with other .NET languages.
  • GET RUNTIME
    Places the current OpenESQL MFADORTS object into the supplied host variable.
  • INITIALIZE DATASET
    Creates an empty DataSet for a previously declared one and optionally stores a reference to that DataSet.
  • INITIALIZE DATATABLE
    Creates an empty DataTable for a previously declared one, and optionally stores a reference to that DataTable.
  • INSERT
    Adds new DataRows to a DataTable. It is similar to the EXEC SQL INSERT statement which adds new rows into a SQL table.
  • LOAD DATASET
    Loads a DataSet that has been stored as an XML file and provides addressability to the corresponding ADO.NET DataSet.
  • LOAD DATATABLE
    Loads a DataTable that has been stored as an XML file and provides addressability to the corresponding ADO.NET DataTable.
  • MERGE
    Merges new data into a target DataSet or DataTable.
  • OPEN
    Opens a previously declared DataRows cursor.
  • PREPARE TO FILL
    Begins the process of loading the DataTables in a DataSet from a data source.
  • PREPARE TO UPDATE
    Begins the process of updating a data source with changes made in the DataTables of a DataSet.
  • REBIND CONNECTION
    Informs OpenESQL that a shared connection transaction has been terminated and supplies a new transaction object for subsequent processing.
  • REJECT CHANGES
    Rolls back all pending changes made in the DataTables of a DataSet.
  • SAVE DATASET
    Saves the schema and data of a DataSet to an XML file.
  • SAVE DATATABLE
    Saves the data and optionally the schema of a DataTable to an XML file.
  • SELECT INTO
    Retrieves one or more DataRows from a DataTable into host variables or host arrays, enabling you to select information from a DataTable without declaring a DataRows cursor.
  • TO DELETE USE
    Specifies, for a specific DataTable, the SQL logic necessary to make deletes from a data source.
  • TO FILL USE
    Specifies, for a specific DataTable, the SQL logic necessary to load the columns of that DataTable with data from a data source.
  • TO INSERT USE
    Specifies, for a specific DataTable, the SQL logic necessary to make inserts into in a data source.
  • TO REFRESH USE
    Specifies, for a specific DataTable, the SQL logic necessary to refresh the rows of a DataTable, showing the changes made to the data source after the UPDATE DATASOURCE statement was executed.
  • TO UPDATE USE
    Specifies, for a specific DataTable, the SQL logic necessary to make updates to a data source.
  • UNBIND
    Disassociates OpenESQL from a DataSet or DataTable in another ADO.NET application.
  • UNBIND CONNECTION
    Disassociates OpenESQL from the original ADO.NET connection object.
  • UPDATE
    Updates a data source with changes made in the DataTables of a DataSet.
  • UPDATE (POSITIONED)
    Updates the DataRow most recently fetched by using a DataRows cursor.
  • UPDATE (SEARCHED)
    Updates a DataTable either by using a standard SQL WHERE clause or by replacement via a host variable array.
  • USING
    Specifies the current DataSet name to be used in subsequent processing.
Parent topic: OpenESQL


ACCEPT CHANGES

Commits all pending changes made in the specified DataTables of the DataSet.

Syntax:

>>--EXEC ADO-.--------------------.-ACCEPT CHANGES FOR--------->
             +-USING dataset_name-+

 >-------------.-ALL DATATABLES-.----END-EXEC------------------><
               | +------,-----+ |
               | V            | |
               +-datatable_name-+

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
datatable_name | The DataTables where the changes are accepted.

Comments:

The row state of the added and modified DataRows is modified to unchanged and deleted DataRows are removed.

No changes are made to the underlying data source. Only the DataTables in the DataSet accept changes. Use UPDATE DATASOURCE to change the underlying data source.

DataTables can be changed directly with INSERT, DELETE (SEARCHED) and UPDATE and via a DataRows cursor with DELETE (POSITIONED) and UPDATE.

Example:

     EXEC ADO
        ACCEPT CHANGES FOR ALL DATATABLES
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
DELETE (POSITIONED)
DELETE (SEARCHED)
INSERT
REJECT CHANGES
UPDATE (POSITIONED)
UPDATE (SEARCHED)


BIND

Allows an ADO.NET DataSet or DataTable to be shared with OpenESQL.

Syntax:

>>--EXEC ADO---.--------------------------.-BIND TO :dataset_hv-------->
               +-USING dataset_name-------+
               +-DATATABLE datatable_name-+

 >--.-------------------.---END-EXEC----><
    +-WITH SCHEMA CHECK-+

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
datatable_name | The name of the DataTable you want to share with OpenESQL.
dataset_hv | Host variable which identifies an ADO.NET DataSet object.
WITH SCHEMA CHECK | Runtime check that verifies that the current schema is the same as one declared at compile-time.

Comments:

Subsequent EXEC ADO statements in OpenESQL referencing dataset_name (or the current OpenESQL DataSet if dataset_name is not specified) use the current ADO.NET DataSet if it has been defined.

Examples:

     EXEC ADO
        USING changesDS BIND TO :changesDSobj
     END-EXEC

     EXEC ADO
        BIND DATATABLE TABLE1 TO :HV-CHGS
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
UNBIND
GET DATATABLE
GET CHANGES


BIND CONNECTION

Enables the pair of ADO.NET connection and transaction objects to be shared with OpenESQL.

Syntax:

>>--EXEC ADO--BIND CONNECTION--.-----------------.-TO :conn_obj_hv---->
                               +-connection_name-+
                               +- :conn_name_hv -+

 >------------------WITH +-TRANSACTION-+ :tran_obj_hv----------------->
                         +-TRAN       -+

 >--END-EXEC----><

Parameters:

connection_name | The connection name OpenESQL uses to refer to the ADO.NET connection object.
conn_name_hv | Host variable which contains the connection name OpenESQL uses to refer to the ADO.NET connection object.
conn_obj_hv | Host variable where the ADO.NET connection object is specified.
tran_obj_hv | Host variable where the ADO.NET transaction object is specified.

Comments:

The named OpenESQL connection can use the existing ADO.NET connection and transaction objects in further EXEC SQL and EXEC ADO processing.

Example:

     EXEC ADO
        BIND CONNECTION fred TO :con WITH TRANSACTION :tran
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
REBIND CONNECTION
UNBIND CONNECTION


CLEAR

Clears the data in the specified DataTables of a DataSet.

Syntax:

>>--EXEC ADO---.--------------------.—CLEAR------------>
               +-USING dataset_name-+

 >-------------+-ALL DATATABLES-+---------------------->
               | +- ,        -+ |
               | V            | |
               +-datatable_name-+

 >--END-EXEC----><

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
datatable_name | A list of the DataTables to be cleared.

Example:

     EXEC ADO
        CLEAR ALL DATATABLES
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
DECLARE DATASET
DECLARE DATATABLE
INITIALIZE DATASET


CLOSE

Closes a previously declared and opened DataRows cursor.

Syntax:

>>--EXEC ADO---CLOSE datarows_name-----END-EXEC-----><

Parameters:

datarows_name The name of a DataRows cursor.

Example:

     EXEC ADO
        CLOSE drOrder
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
DECLARE DATAROWS
DELETE (POSITIONED)
FETCH
OPEN
UPDATE (POSITIONED)


DECLARE DATAROWS

Declares an ADO.NET DataRows cursor (similar to an SQL cursor) based on criteria established against a particular DataTable.

Syntax:

>>--EXEC ADO---.--------------------.--DECLARE datarows_name DATAROWS->
               +-USING dataset_name-+

 >--.------------------------------------.—-FROM datatable_name------->
    |              +--- , ---+           |
    |              V         |           |
    +--FOR SELECT--column_name-----------+

 >--.-----------------------------------.—---------------------------->
    +-FOR-.-ADDED-------------.-DATAROWS+
          +-CURRENT-----------+
          +-DELETED-----------+
          +-MODIFIED CURRENT--+
          +-MODIFIED ORIGINAL-+
          +-ORIGINAL----------+
          +-UNCHANGED---------+

 >-.----------------------------------------------------.--—END-EXEC--><
   |                                                    |
   +-WHERE search_conditions--.----------------------.--+
   |                          +-ORDER BY sort_clause-+  |
   |                                                    |
   +-WHERE CHILDREN OF cursor_name (relation_name)------+
   +-WHERE PARENTS  OF cursor_name (relation_name}------+
   +-ORDER BY sort_clause-------------------------------+

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
datarows_name | The name of a DataRows cursor.
column_name | The names of the columns in the DataTable to specify in the DataRows cursor.
FOR row_state DATAROWS | Identifies the DataRows to use in a DataTable based on the row_state value.
datatable_name | The name of the DataTable on which the DataRows cursor is defined.
search_conditions | Any valid expression that can follow the standard SQL WHERE clause.
sort_clause | Any valid expression that can follow the standard SQL ORDER BY clause.
cursor_name | The name of a DataRows cursor to be associated with this DataRows cursor (as either a parent or a child.)
relation_name | The name of the constraint which specifies the parent-child relationship between this DataRows cursor and the cursor_name cursor referenced above. relation_name is defined in the DECLARE DATASET statement.

Comments:

The standard cursor manipulation statements (OPEN, FETCH, DELETE (POSITIONED), UPDATE (POSITIONED) and CLOSE) are also applicable to an ADO.NET DataRows cursor.

In addition to the standard WHERE clause, the DECLARE DATAROWS statement allows you to navigate parent-child relationships of related DataRows cursors with the WHERE CHILDREN and WHERE PARENTS clauses.

Example:

     EXEC ADO
        DECLARE drOrder DATAROWS
        FOR SELECT OrderID, OrderDate FROM Orders
        WHERE CHILDREN OF drCust(custord)
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
CLOSE
DELETE (POSITIONED)
FETCH
OPEN
UPDATE (POSITIONED)


DECLARE DATASET

Defines a typed or an untyped DataSet.

Syntax:

DECLARE <typed> DATASET
>>--EXEC ADO---DECLARE dataset_name DATASET----------------------->

 >--+-FROM dataset_xml_file_spec---------------------------------+
    +-LIKE src_dataset_name--------------------------------------+
    |                                                            |
    |       +---- , -----+                                       |
    |       V            |                                       |
    +-FOR---datatable_name---.--------------.----.-------------.-+
                             +-optrelations-+    +optschemasave+

 >--END-EXEC----><

where

optrelations:
 >-.------------------------------------------------------------------------.--><
   |                                                                        |
   | + ----------------- , ---------------------------------------------+   |
   | V                                                                  |   |
   +---.--------.-RELATION rel_name child_tbl (column_list)REFERENCES-> |   |
       +-NESTED-+                                                       |   |
              >--parent_tbl (column_list)-.------------------.----------+---+
                                          +optwithconstraints+

optschemasave:
 >----.--------------------------------------.--------------------><
      +-SAVE SCHEMA TO dataset_xml_file_spec-+

optwithconstraints:
>--.------------------------------------------------------------.-><
   +-WITH CONSTRAINTS-.-------------.-.----------.-.----------.-+
                      +-accrej_rule-+ +-del_rule-+ +-upd_rule-+

accrej_rule:
>---ON ACCEPT OR REJECT -.-CASCADE---.----------------------------><
                         +-NO ACTION-+

del_rule:
>---ON DELETE -.-CASCADE-----.------------------------------------><
               +-NO ACTION---+
               +-SET DEFAULT-+
               +-SET NULL----+

upd_rule:
>---ON UPDATE -.-CASCADE-----.------------------------------------><
               +-NO ACTION---+
               +-SET DEFAULT-+
               +-SET NULL----+

DECLARE <untyped> DATASET
>>--EXEC ADO---DECLARE dataset_name UNTYPED DATASET----END-EXEC---><

Parameters:

dataset_name | The DataSet to be declared.
dataset_xml_file_spec | The location of the DataSet XML file that specifies the characteristics for the declared DataSet.
src_dataset_name | The name of the DataSet that specifies the characteristics for the declared DataSet.
datatable_name | The declared DataTable to be included in this DataSet.
rel_name | The name of a relation.
child_tbl (column_list) | A specification of the table and columns which define the child key (foreign).
parent_tbl (column_list) | A specification of the table and columns which define the parent key.
SAVE SCHEMA TO | Saves the schema of the DataSet into an XSD file.

Comments:

When you declare a schema with a DataSet (typed), it is checked at compile time and optionally stored in an XSD file. If you do not declare a schema with the DataSet (untyped), then no compile time checking is done.

A DataSet consists of DataTables and the relationships between these tables.

All DataTables specified in a DECLARE DATASET statement must have a corresponding DECLARE DATATABLE. You can optionally specify parent key and child key relationships between these tables with the RELATION clause.

If WITH CONSTRAINTS is specified, then primary key and foreign key constraints will be created (if they do not already exist) in the parent and child DataTables, respectively. You can set rules to specify the effect of changes to a parent row on related child rows if WITH CONSTRAINTS is specified.

Example:

     EXEC ADO
        DECLARE ds DATASET
        FOR Customers, Orders, "Order Details"
        RELATION custord Orders(CustomerID) REFERENCES Customers(CustomerID),
        RELATION orditems "Order Details"(OrderID) REFERENCES Orders(OrderID)
     END-EXEC

     EXEC ADO
        DECLARE ds UNTYPED DATASET
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
CLEAR
DECLARE DATATABLE
INITIALIZE DATASET
GET CHANGES


DECLARE DATATABLE

Defines an ADO.NET DataTable.

Syntax:

>>--EXEC ADO---DECLARE datatable_name DATATABLE---------------------->

 >-------------( table_item_list )---------------------END-EXEC------><

where

table_item_list:

      +------------------   ,   ----------------------+
      V                                               |
 >-.--+-column_name data_type .----------------.------+--------------><
      |                       +-column_options-+      |
      |                                               |
      +-CONSTRAINT constraint_name constraint_def-----+

data_type:

 >-+-BOOLEAN---+---><
   +-SBYTE-----+
   +-INT16-----+
   +-INT32-----+
   +-INT64-----+
   +-DATETIME--+
   +-DECIMAL---+
   +-SINGLE----+
   +-DOUBLE----+
   +-STRING(N)-+
   +-OBJECT----+

column_options:

 >-.----------.---.-----------------.---.----------.---.--------.---->
   +-NULL-----+   +-DEFAULT literal-+   +-READONLY-+   +-UNIQUE-+
   +-NOT NULL-+   +-DEFAULT ident---+

 >-.---------------------------.--.---------------.------------------><
   +-AUTOINCREMENT FROM N BY N-+  +-CAPTION ident-+

constraint_def:

 >--+--PRIMARY KEY (column_list)--+--><
    +--UNIQUE (column_list)-------+

Parameters:

datatable_name | The DataTable to be declared.
column_name | The name of a column in the DataTable
data_type | The column data types available.
column_options | The column options available.
constraint_name | The name of a constraint for the DataTable.
constraint_def | The definition of the primary or unique key for the DataTable, as specified with columns.
column_list | A list of columns in the DataTable, separated by commas.

Comments:

A DECLARE DATATABLE statement is required for each DataTable specified in a DECLARE DATASET statement.

The DECLARE DATATABLE statement syntax is similar to the embedded EXEC SQL CREATE TABLE statement.

Example:

     EXEC ADO
        DECLARE Orders DATATABLE
        ( OrderID               INT32           AUTOINCREMENT FROM -1 BY -1
         ,CustomerID            STRING(5)
         ,EmployeeID            INT32
         ,OrderDate             DATETIME
         ,RequiredDate          DATETIME
         ,ShippedDate           DATETIME
         ,ShipVia               INT32
         ,Freight               DECIMAL
         ,ShipName              STRING(40)
         ,ShipAddress           STRING(60)
         ,ShipCity              STRING(15)
         ,ShipRegion            STRING(15)
         ,ShipPostalCode        STRING(10)
         ,ShipCountry           STRING(15)
         , CONSTRAINT pk_Orders primary key(OrderID))
     END-EXEC.
Parent topic: Embedded ADO Statements
Related reference
CLEAR
DECLARE DATASET
DELETE (SEARCHED)
INSERT
UPDATE (SEARCHED)


DELETE (POSITIONED)

Deletes the row most recently fetched by a DataRows cursor.

Syntax:

>>-EXEC ADO-.--------------------.-DELETE---FROM---datatable_name---->
            +-USING dataset_name-+

 >----WHERE CURRENT OF---datarows_name---END-EXEC---><

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
datatable_name | The same DataTable used in the SELECT FROM option (see DECLARE CURSOR).
datarows_name | A previously declared, opened, and fetched DataRows cursor.

Comments:

EXEC ADO supports positioned delete; however, you cannot use host arrays with positioned delete.

The other type of DELETE used in standard EXEC ADO statements is known as a searched delete.

Example:

* Declare the cursor
     EXEC ADO
        DECLARE c1 DATAROWS FROM oline
     END-EXEC

* Open the cursor
     EXEC ADO
        OPEN c1
     END-EXEC

* Modify the table using positioned updates and deletes
     PERFORM UNTIL EXIT
        * Delete row 1, 4, 7, ...
        EXEC ADO FETCH c1 INTO :oline END-EXEC
        IF SQLCODE NOT = 0
           EXIT PERFORM
        END-IF
        EXEC ADO DELETE FROM oline WHERE CURRENT OF c1 END-EXEC

        * Update row 2, 5, 8, ...
        EXEC ADO FETCH c1 INTO :oline END-EXEC
        IF SQLCODE NOT = 0
           EXIT PERFORM
        END-IF
        MOVE 99 TO qty
        EXEC ADO UPDATE oline SET qty = :qty WHERE CURRENT OF c1 END-EXEC

        * Leave alone row 3, 6, 9, ...
        EXEC ADO FETCH c1 INTO :oline END-EXEC
        IF SQLCODE NOT = 0
           EXIT PERFORM
        END-IF
     END-PERFORM
Parent topic: Embedded ADO Statements
Related reference
ACCEPT CHANGES
CLOSE
DECLARE DATAROWS
FETCH
OPEN
UPDATE (POSITIONED)
REJECT CHANGES


DELETE (SEARCHED)

Removes the DataRows that meet the row state and/or search criteria from the named DataTable.

Syntax:

>>--EXEC ADO--.-------------------.---DELETE---FROM------->
              +-USING dataset_name+

>--datatable_name--.------------------------------------.—>
                   +-FOR-.-ADDED-------------.-DATAROWS-+
                         +-CURRENT-----------+
                         +-DELETED-----------+
                         +-MODIFIED CURRENT--+
                         +-MODIFIED ORIGINAL-+
                         +-ORIGINAL----------+
                         +-UNCHANGED---------+

>----.-------------------------.----------------END-EXEC--><
     +-WHERE search_conditions-+

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
datatable_name | The target DataTable for the delete operation.
search_conditions | Any valid expression that can follow the standard SQL WHERE clause.

Comment:

If no criteria are specified, then all of the DataRows in the named DataTable are removed.

Example:

     EXEC ADO
        DELETE FROM Customers
        WHERE CustomerID = 'ZZZZ1'
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
ACCEPT CHANGES
DECLARE DATATABLE
REJECT CHANGES


FETCH

Transfers all or a subset of a DataRows cursor into host variables or host arrays.

Syntax:

>>--EXEC ADO--.-------------------.----------------->
              +-FOR :host_integer-+

 >-FETCH-------.----------.---.----------.—VALUES--->
               +---SAME---+   +-CURRENT--+
               +---LAST---+   +-DEFAULT--+
               +---PRIOR--+   +-ORIGINAL-+
               +---FIRST--+   +-PROPOSED-+
               +---NEXT---+

 >--.------.—-datarows_name--.---------------.------>
    +-FROM-+                 +-(column_list)-+

 >--.--------------------------------.---END-EXEC---><
    |      +--- , -----+             |
    |      V           |             |
    +-INTO :col_value_hv-------------+

Properties:

:host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
datarows_name | A previously declared and opened DataRows cursor
column_list | A list of one or more columns for which data is to be retrieved. The column list determines the order in which values are received. Items in the column list must be enclosed in parentheses. If no column list is given, all of the columns in the receiving table (in DECLARE DATATABLE order) are assumed. The column list is only necessary when some but not all of the columns in the DataRows cursors are to retrieve data.
:col_value_hv | Identifies one or more host variables to receive the data from the columns.

Comments:

This statement is similar to the embedded EXEC SQL FETCH statement.

After execution, SQLERRD(3) contains the number of elements processed. For FETCH it is the number of rows actually fetched.

Example:

* Declare a cursor for a given SQL statement.
     EXEC ADO
        DECLARE drCust DATAROWS FROM Customers
     END-EXEC

     EXEC ADO OPEN drCust END-EXEC

* Fetch the current values from the cursor into the host variables
* and if everything goes ok, display the values of the host
* variables
     PERFORM UNTIL EXIT
        EXEC ADO
           FETCH NEXT drCust (CustomerID, CompanyName)
           INTO :Customers-CustomerID, :Customers-CompanyName
        END-EXEC
        IF SQLCODE < 0 or SQLCODE = 100
           EXIT PERFORM
        END-IF
        DISPLAY "Customer ID  = " Customers-CustomerID " Company Name = " Customers-CompanyName
     END-PERFORM
Parent topic: Embedded ADO Statements
Related reference
CLOSE
DECLARE DATAROWS
DELETE (POSITIONED)
OPEN
UPDATE (POSITIONED)


FILL

Adds new DataRows to (or refreshes the existing DataRows of) the DataTables in a DataSet using data from the data source.

Syntax:

>>--EXEC ADO--FILL--DATASET--.--------------.-->
                             +-dataset_name-+
>--END-EXEC--><

Parameters:

dataset_name The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.

Comments:

This statement can only be executed after a PREPARE TO FILL and subsequent TO FILL statements. The TO FILL statements specify the SQL logic necessary to fill different DataTables from a data source.

If no TO FILL statements are used, OpenESQL attempts to supply default SQL. For a table with no parent tables the default SQL will select all rows in the table. For a table with a parent table, the default SQL selects the rows for which the parent rows have been selected. Tables are filled in the correct order to satisfy relationships between tables, for example, parent before children. The generation of default SQL searchs all relationships between tables, allowing a FILL statement for a parent table to be used to generate queries for children, grandchildren, great grandchildren and so on.

Example:

     EXEC ADO
        FILL DATASET
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
PREPARE TO FILL
TO FILL USE
INITIALIZE DATASET


GET CHANGES

Creates a new DataSet containing only DataRows that have been modified (deleted, added or changed).

Syntax:

>>-EXEC ADO-.--------------------.-GET CHANGES INTO— :dataset_hv---->
            +-USING dataset_name-+

 >--END-EXEC----><

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
dataset_hv | Host variable where the DataSet object is placed. This DataSet only contains changed data from the source DataSet.

Comment:

Because the resultant DataSet only contains change information, it can be used (rather than the entire DataSet) to minimize network traffic when updating a data source.

Example:

     EXEC ADO
        GET CHANGES INTO :changesDSobj
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
BIND
DECLARE DATASET


GET CONNECTION

Places the current OpenESQL connection and transaction objects into the supplied host variables such that the objects can then be shared with other ADO.NET programs.

Syntax:

>>--EXEC ADO---GET CONNECTION INTO :conn_obj_hv---------->

 >--------------+-TRANSACTION-+ INTO :tran_obj_hv-------->
                +-TRAN--------+

 >--END-EXEC----><

Parameters:

conn_obj_hv | Host variable where the current OpenESQL ADO.NET connection object is placed.
tran_obj_hv | Host variable where the current OpenESQL ADO.NET transaction object is placed.

Example:

     EXEC ADO
        GET CONNECTION INTO :con TRANSACTION INTO :tran
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
GET CURSOR
GET RUNTIME


GET CURSOR

Places a DataReader or a DataSet ADO.NET object used by the OpenESQL EXEC SQL cursor into the supplied host variable such that the object can then be shared with other ADO.NET programs.

Syntax:

>>--EXEC ADO---GET CURSOR cursor_name INTO :cursor_obj_hv-------->

 >---.------------------------------------------.---------------->
     +--RENAME DATATABLE AS new_datatable_name--+

 >--END-EXEC----><

Parameters:

cursor_name | Name of an EXEC SQL cursor.
cursor_obj_hv | Host variable where the OpenESQL ADO.NET object will be placed.
new_datatable_name | The new name of the underlying DataTable in the cursor.

Purpose:

If the ADO.NET object is a DataSet, then the DataTable containing the data for the cursor can optionally be renamed. The default name, if no renaming is undertaken, is "Table".

Example:

     EXEC ADO
        GET CURSOR CSR5 INTO :ws-dataset
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
GET CONNECTION
GET RUNTIME


GET DATATABLE

Copies a DataTable object into a host variable or creates a DataTable object within a host variable, enabling you to share the DataTable object with other .NET languages.

Syntax:

>>-EXEC ADO---GET DATATABLE datatable_name-+-INTO :datatable_hv---------+---END-EXEC---------><
                                           +-CHANGES INTO :datatable_hv-+

Parameters:

datatable_name | The ADO.NET DataTable object to be shared
INTO | Copy a DataTable object into a COBOL host variable
CHANGES INTO | Create a new DataTable object that contains only the DataRows that have been modified (deleted, added or changed).
datatable_hv | Host variable where the DataTable object is placed.

Comment:

When you create a DataTable object, the new object contains only changed information rather than the entire DataTable. This can minimize network traffic when updating a data source.

Example:

     EXEC ADO
        GET DATATABLE TABLE1 CHANGES INTO :HV-CHGS
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
BIND
UNBIND


GET RUNTIME

Places the current OpenESQL MFADORTS object into the supplied host variable.

Syntax:

>>--EXEC ADO---GET RUNTIME INTO :runtime_hv----END-EXEC---><

Parameters:

runtime_hv Host variable where the current OpenESQL MFADORTS object is placed.

Comment:

Investigating the OpenESQL MFADORTS object can provide valuable insight in debugging scenarios.

Example:

     EXEC ADO
        GET RUNTIME INTO :runtime
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
GET CONNECTION
GET CURSOR


INITIALIZE DATASET

Creates an empty DataSet for a previously declared one and optionally stores a reference to that DataSet.

Syntax:

>>--EXEC ADO--.-------------------.—INITIALIZE DATASET------>
              +-USING dataset_name+

 >---.-------------------------.-----------EXEC-END---------><
     +-RETURNING :dataset_hv---+

Parameters:

dataset_name | The DataSet to be created.
dataset_hv | Host variable where the DataSet object is placed.

Example:

     EXEC ADO
        INITIALIZE DATASET
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
CLEAR
DECLARE DATASET
FILL


INITIALIZE DATATABLE

Creates an empty DataTable for a previously declared one, and optionally stores a reference to that DataTable.

Syntax:

>>--EXEC ADO--INITIALIZE DATATABLE datatable_name----->

 >---.-------------------------.-----------END-EXEC---><
     +-RETURNING :datatable_hv-+

Parameters:

datatable_name | The DataTable to be created.
datatable_hv | Host variable where the DataTable object is placed.

Example:

     EXEC ADO
        INITIALIZE TABLE TABLE1
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
SAVE DATATABLE
LOAD DATATABLE


INSERT

Adds new DataRows to a DataTable. It is similar to the EXEC SQL INSERT statement which adds new rows into a SQL table.

Syntax:

>>--EXEC ADO--.--------------------.--.-----------------.---->
              +-USING dataset_name-+  +-FOR :host_integer-+

 >--INSERT INTO datatable_name--.---------------.------------>
                                |               |
                                |  +--- , ---+  |
                                |  V         |  |
                                +-(column_name)-+

            +---------- , ---------+
            V                      |
 >--VALUES (.----------------------.)---END-EXEC-------------><
            +-- :column_value_hv --+
            +-- column_value     --+

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
:host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.
datatable_name | The DataTable that will receive the new DataRows.
column_name | A column in the DataTable.
:column_value_hv | The corresponding column value for column_name.
column_value | The corresponding literal column value for column_name.

Comment:

After execution, SQLERRD(3) contains the number of elements processed. For INSERT it is the total number of rows inserted.

Example:

     EXEC ADO
        INSERT INTO Customers
        (CustomerID, CompanyName, ContactName)
        VALUES ('ZZZZ2', 'Java Jugglers', 'Mike Smith')
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
ACCEPT CHANGES
DECLARE DATATABLE
REJECT CHANGES


LOAD DATASET

Loads a DataSet that has been stored as an XML file and provides addressability to the corresponding ADO.NET DataSet.

Syntax:

>>--EXEC ADO---.--------------------.---LOAD DATASET FROM ----------->
               +-USING dataset_name-+

 >--xml_file_spec--.-------------------.--.----------------------.--->
                   +-WITH SCHEMA CHECK-+  +-RETURNING :ds_obj_hv-+

 >--END-EXEC----><

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
xml_file_spec | Location of the XML file that contains the DataSet’s schema and data.
WITH SCHEMA CHECK | Verifies that the DECLARE DATASET used at compile time matches the one stored in the XML file.
ds_obj_hv | Host variable where the DataSet object is placed.

Example:

     EXEC ADO
        LOAD DATASET FROM "c:\work\adotests\net_order_status.xml"
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
SAVE DATASET


LOAD DATATABLE

Loads a DataTable that has been stored as an XML file and provides addressability to the corresponding ADO.NET DataTable.

Syntax:

>>--EXEC ADO---LOAD DATATABLE datatable_name FROM ------------------->

 >--xml_file_spec--.-------------------.--.----------------------.--->
                   +-WITH SCHEMA CHECK-+  +-RETURNING :dt_obj_hv-+

 >--END-EXEC----><

Parameters:

datatable_name | The DataTable reference to be used.
xml_file_spec | Location of the XML file that contains the DataTable’s schema and data.
WITH SCHEMA CHECK | Verifies that the DECLARE DATATABLE used at compile time matches the one stored in the XML file.
dt_obj_hv | Host variable where the DataTable object is placed.

Example:

     EXEC ADO
        LOAD DATATABLE  TABLE1 FROM "C:\DATA\EMPLOYEE.XML"
        WITH SCHEMA CHECK RETURNING :DATATBL-OBJ
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
INITIALIZE DATATABLE
SAVE DATATABLE


MERGE

Merges new data into a target DataSet or DataTable.

Syntax, Format 1:

>>--EXEC ADO--.-------------------.-MERGE DATASET FROM ------->
              +-USING dataset_name+

 >---:src_dataset_hv --.--------------------.----------------->
                       +--PRESERVE CHANGES--+

 >---.--------------------------------------.-END-EXEC--------><
     |                                      |
     +-ON SCHEMA DIFFERENCE--+-ADD         -+
                             +-ADD WITH KEY-+
                             +-ERROR       -+
                             +-IGNORE      -+

Syntax, Format 2:

>>--EXEC ADO--.-------------------.-MERGE DATASET ------------>
              +-USING dataset_name+

 >---src_dataset_name -----.--------------------.------------->
                           +--PRESERVE CHANGES--+

 >---.--------------------------------------.-END-EXEC--------><
     |                                      |
     +-ON SCHEMA DIFFERENCE--+-ADD         -+
                             +-ADD WITH KEY-+
                             +-ERROR       -+
                             +-IGNORE      -+

Syntax, Format 3:

>>--EXEC ADO--.-------------------.-MERGE DATATABLE----------->
              +-USING dataset_name+

 >---dest_datatable FROM DATASET src_dataset_name------------->

 >-------------.------------------------------------.--------->
               +-FOR-.-ADDED-------------.-DATAROWS-+
                     +-CURRENT-----------+
                     +-DELETED-----------+
                     +-MODIFIED CURRENT--+
                     +-MODIFIED ORIGINAL-+
                     +-ORIGINAL----------+
                     +-UNCHANGED---------+

 >--.-------------------------.---.--------------------.------>
    +-WHERE search conditions-+   +--PRESERVE CHANGES--+

 >---.--------------------------------------.-END-EXEC--------><
     |                                      |
     +-ON SCHEMA DIFFERENCE--+-ADD         -+
                             +-ADD WITH KEY-+
                             +-ERROR       -+
                             +-IGNORE      -+

Syntax, Format 4:

>>--EXEC ADO---MERGE DATATABLE-------------------------------->

 >---dest_datatable FROM DATATABLE src_datatable_name--------->

 >---.------------------------------------.------------------->
     +-FOR-.-ADDED-------------.-DATAROWS-+
           +-CURRENT-----------+
           +-DELETED-----------+
           +-MODIFIED CURRENT--+
           +-MODIFIED ORIGINAL-+
           +-ORIGINAL----------+
           +-UNCHANGED---------+

 >---.-------------------------.---.--------------------.---->
     +-WHERE search conditions-+   +--PRESERVE CHANGES--+

 >---.--------------------------------------.-END-EXEC---><
     |                                      |
     +-ON SCHEMA DIFFERENCE--+-ADD         -+
                             +-ADD WITH KEY-+
                             +-ERROR       -+
                             +-IGNORE      -+

Parameters:

dataset_name | The target DataSet to be used. If you do not specify dataset_name, the current DataSet is used.
src_dataset_hv | The host variable that contains the source DataSet for the merge.
src_dataset_name | The source DataSet name that specifies which DataRows of a DataTable to use as the source for the merge.
dest_datatable | The destination into which DataTable data is to be merged.
src_datatable | The source that the DataTable data is to be copied from.
search_conditions | Any valid expression that can follow the standard SQL WHERE clause.
PRESERVE CHANGES | Prevents incoming values from the source overwriting the current values in the target (only Original).
ON SCHEMA DIFFERENCE | Specifies what happens if the DataSet or DataTable schemas of the source and target are different.

Comments:

The source of the new data is either a complete DataSet, a DataTable from another DataSet, or a set of DataRows from a DataTable in another DataSet.

In accordance with the .NET API standards, there is an option to preserve changes in the target DataSet or DataTable.

You can also specify what actions are taken if a schema difference is encountered.

Examples:

     EXEC ADO
        MERGE DATASET FROM :changesDSobj
     END-EXEC

     EXEC ADO
        MERGE DATATABLE TABLE2 FROM DATATABLE TABLE1 FOR ADDED ROWS
     END-EXEC
Parent topic: Embedded ADO Statements


OPEN

Opens a previously declared DataRows cursor.

Syntax:

>>--EXEC ADO---OPEN datarows_name-----END-EXEC----><

Parameters:

datarows_name The name of a DataRows cursor.

Comment:

OPEN is similar to the standard EXEC SQL OPEN statement.

Example:

* Declare the cursor...
     EXEC ADO
        DECLARE drCust DATAROWS FROM Customers
     END-EXEC

* Open the cursor...
     EXEC ADO
        OPEN drCust
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
CLOSE
DECLARE DATAROWS
DELETE (POSITIONED)
FETCH
UPDATE (POSITIONED)


PREPARE TO FILL

Begins the process of loading the DataTables in a DataSet from a data source.

Syntax:

                                                    +--   ,    --+
                                                    V            |
>>--EXEC ADO-.--------------------.-PREPARE TO FILL-datatable_name-->
             +-USING dataset_name-+
 >--END-EXEC---><

Parameters:

datatable_name | The DataTables that are prepared to be filled by the data source.
dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.

Comments:

After using PREPARE TO FILL to specify the DataTables that are to be loaded by the data source, use the TO FILL statement to specify how to retrieve the data from the data source. The FILL statement completes the process.

Example:

     EXEC ADO
        PREPARE TO FILL Customers, Orders, "Order Details"
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
FILL
TO FILL USE


PREPARE TO UPDATE

Begins the process of updating a data source with changes made in the DataTables of a DataSet.

Syntax:

                                                      +--    ,   --+
                                                      V            |
>>--EXEC ADO-.--------------------.-PREPARE TO UPDATE-datatable_name-->
             +-USING dataset_name-+
 >--END-EXEC---><

Parameters:

datatable_name | The DataTables whose changes are prepared to be placed in the data source.
dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.

Comments:

After specifying the DataTables whose changes will be loaded to the data source, TO INSERT, TO DELETE and TO UPDATE statements are used to specify for each DataTable how those changes are placed back in the data source. The UPDATE statement completes the process.

If no TO INSERT, TO DELETE or TO UPDATE statements are specified, OpenESQL will generate these statements based on the SQL construct used in the TO FILL statement.

Example:

     EXEC ADO
        PREPARE TO UPDATE Customers, Orders, "Order Details"
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
TO DELETE USE
TO INSERT USE
TO REFRESH USE
TO UPDATE USE
UPDATE


REBIND CONNECTION

Informs OpenESQL that a shared connection transaction has been terminated and supplies a new transaction object for subsequent processing.

Syntax:

>>--EXEC ADO---REBIND CONNECTION--.-----------------.----->
                                  +-connection_name-+
                                  +-:conn_name_hv---+

 >--WITH +-TRANSACTION-+  :tran_obj_hv---END-EXEC---------><
         +-TRAN       -+

Parameters:

connection_name | The connection name OpenESQL uses to refer to the ADO.NET connection object.
conn_name_hv | Host variable that contains the connection name OpenESQL uses for the ADO.NET connection object.
tran_obj_hv | Host variable that contains the new ADO.NET transaction object that OpenESQL is to use.

Comment:

If the transaction object is NULL, then the connection enters AUTOCOMMIT mode.

Example:

     EXEC ADO
        REBIND CONNECTION WITH TRANSACTION :tran
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
BIND CONNECTION
UNBIND CONNECTION


REJECT CHANGES

Rolls back all pending changes made in the DataTables of a DataSet.

Syntax:

>>--EXEC ADO---.--------------------.—REJECT CHANGES FOR-------->
               +-USING dataset_name-+

 >-------------.----------------.------------------------------->
               +-ALL DATATABLES-+
               | +---- ,  ----+ |
               | V            | |
               +-datatable_name-+

 >--END-EXEC----><

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
datatable_name | The DataTables where the changes are rejected.

Comments:

The row state and contents of the deleted and modified DataRows are returned to their original state and any added DataRows are removed.

Note:

No changes are made to the underlying data source. Only the DataTables in the DataSet reject changes.

Example:

     EXEC ADO
        REJECT CHANGES FOR ALL DATATABLES
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
ACCEPT CHANGES
DELETE (POSITIONED)
DELETE (SEARCHED)
INSERT
REJECT CHANGES
UPDATE (POSITIONED)
UPDATE (SEARCHED)


SAVE DATASET

Saves the schema and data of a DataSet to an XML file.

Syntax:

>>--EXEC ADO--.-------------------.—SAVE--DATASET------>
              +-USING dataset_name+

 >---TO----xml_file_spec--------------------EXEC-END---><

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
xml_file_spec | A file to contain the XML file that represents the DataSet.

Example:

     EXEC ADO
        SAVE DATASET TO "c:\work\adotests\net_order_status.xml"
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
LOAD DATASET


SAVE DATATABLE

Saves the data and optionally the schema of a DataTable to an XML file.

Syntax:

>>--EXEC ADO--SAVE DATATABLE datatable_name--.-------------.--->
                                             +-WITH SCHEMA-+

 >---TO----xml_file_spec---END-EXEC---><

Parameters:

datatable_name | The DataTable reference to be used.
xml_file_spec | A file to contain the XML file that represents the DataTable and schema.

Example:

     EXEC ADO
        SAVE DATATABLE TABLE1 WITH SCHEMA TO "C:\DATA\NEWEMPLOYEE.XML"
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
INITIALIZE DATATABLE
LOAD DATATABLE


SELECT INTO

Retrieves one or more DataRows from a DataTable into host variables or host arrays, enabling you to select information from a DataTable without declaring a DataRows cursor.

Syntax:

>>---EXEC ADO--.--------------------.—--SELECT---------------->
               +-USING dataset_name-+

                          +--  ,  --+         +---- , ----+
                          V         |         V           |
 >--.-----------------.---column_name---INTO--:col_value_hv--->
    +-CURRENT VALUES--+
    +-DEFAULT VALUES--+
    +-ORIGINAL VALUES-+
    +-PROPOSED VALUES-+

>--FROM datatable_name---------------------------------------->

>--.----------------------------------------------------.--—-->
   |                                                    |
   +-WHERE search_conditions--.----------------------.--+
   |                          +-ORDER BY sort_clause-+  |
   |                                                    |
   +-WHERE CHILDREN OF cursor_name (relation_name)------+
   +-WHERE PARENTS  OF cursor_name (relation_name}------+
   +-ORDER BY sort_clause-------------------------------+

>--END-EXEC---><

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
VALUES group | Determines which type of DataRows to use in the selection criteria.
column_name | The columns in the DataTable whose data values are retrieved.
col_value_hv | Host variable where the columns data values are stored.
datatable_name | The DataTable used in the selection criteria.
search_conditions | Any valid expression that can follow the standard SQL WHERE clause.
sort_clause | Any valid expression that can follow the standard SQL ORDER BY clause.
cursor_name | The name of the DataRows cursor to be associated with this DataRows cursor (as either a parent or a child.)
relation_name | The name of the constraint which specifies the parent-child relationship between this DataRows cursor and the cursor_name cursor referenced above. relation_name is defined in the DECLARE DATASET statement.

Comment:

This statement is similar to the embedded EXEC SQL SELECT INTO statement.

Example:

     MOVE 99 TO staff-id
     EXEC ADO
        SELECT last_name
        INTO :lname
        FROM staff
        WHERE staff_id=:staff-id
     END-EXEC

     EXEC ADO
        SELECT staff_id
        INTO :staff-id
        FROM staff
        WHERE first_name = 'Phil'
     END-EXEC
Parent topic: Embedded ADO Statements


TO DELETE USE

Specifies, for a specific DataTable, the SQL logic necessary to make deletes from a data source.

Syntax:

>>--EXEC ADO-.--------------------.-TO DELETE-.------.-datatable_name-->
             +-USING dataset_name-+           +-FROM-+

 >--------------USE--+-sql_searched_delete_statement-+----------------->
                     +-stored_procedure_statement----+

 >--END-EXEC---><

Parameters:

datatable_name | The name of a DataTable.
dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
sql_searched_delete_statement | A standard SQL DELETE (SEARCHED) statement that references a table in a data source.
stored_procedure_statement | Specifies which stored procedure to execute.

Comments:

The SQL logic must reference actual tables and columns in the data source.

The SQL logic can refer to column values for the row that has been deleted in the DataTable by using the column name enclosed in braces, optionally followed by the type of value (CURRENT, ORIGINAL, DEFAULT, or PROPOSED), separated by a period. For example, {OrderId} or {OrderID.Original}.

Example:

     EXEC ADO PREPARE TO UPDATE Orders, Customers, "Order Details" END-EXEC
        EXEC ADO TO DELETE FROM Customers USE
           DELETE FROM Customers WHERE CustomerID = {CustomerID}
        END-EXEC
     EXEC ADO UPDATE DATASOURCE END-EXEC
Parent topic: Embedded ADO Statements
Related reference
PREPARE TO UPDATE
TO INSERT USE
TO REFRESH USE
TO UPDATE USE
UPDATE


TO FILL USE

Specifies, for a specific DataTable, the SQL logic necessary to load the columns of that DataTable with data from a data source.

Syntax:

>>--EXEC ADO--.--------------------.--TO FILL  datatable_name-->
              +-USING dataset_name-+

 >---.-------------------------------------------------.------->
     |                                                 |
     |           +---------------  ,  --------------+  |
     |           V                                  |  |
     +- MAPPING--datatable_col_name AS table_col_name--+

 >--------------USE--+-sql_select_statement----------+--------->
                     +-stored_procedure_statement----+

 >--END-EXEC---><

Parameters:

datatable_name | The name of a DataTable.
dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
datatable_col_name | The name of a column in a DataTable.
table_col_name | The name of a column in a table in a data source.
sql_select_statement | A standard SQL SELECT statement that references a table in a data source.
stored_procedure_statement | Specifies the stored procedure to execute.

Comment:

The SQL logic must reference actual tables and columns in the data source.

Example:

     EXEC ADO
        TO FILL Customers USE
        SELECT CustomerID,CompanyName,ContactName,ContactTitle,Address
        ,City,Region,PostalCode,Country,Phone,Fax
        FROM Customers WHERE CustomerID LIKE :pattern
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
FILL
PREPARE TO FILL


TO INSERT USE

Specifies, for a specific DataTable, the SQL logic necessary to make inserts into in a data source.

Syntax:

>>--EXEC ADO--.--------------------.--TO INSERT INTO datatable_name-->
              +-USING dataset_name-+

 >--.----------------------------------------------------------.----->
    |                                                          |
    +--WITH REFRESH USING--+-RETURNED DATAROW                 -+
                           +-RETURNED DATAROW , OUT PARAMETERS-+
                           +-OUT PARAMETERS                   -+

 >--USE--+-sql_insert_statement--.-----------------------.----------->
         |                       +-sql_refresh_statement-+
         |                                               |
         +-stored_procedure_statement--------------------+

 >--END-EXEC---><

Parameters:

datatable_name | The name of a DataTable.
dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
WITH REFRESH USING | Specifies how to retrieve new values in the data source as a result of the execution of the TO INSERT statement.
sql_insert_statement | A standard SQL INSERT statement that references a table in data source.
sql_refresh_statement | The SQL SELECT statement that cites the columns in the DataTable that need to be refreshed.
stored_procedure_statement | Specifies the stored procedure to execute to perform the SQL INSERT statement.

Comments:

The SQL logic must reference actual tables and columns in the data source.

The SQL logic can refer to column values for the row that has been deleted in the DataTable by using the column name enclosed in braces, optionally followed by the type of value (CURRENT, ORIGINAL, DEFAULT, or PROPOSED), separated by a period. For example, {OrderId} or {OrderID.Original}.

Use the WITH REFRESH USING clause to specify how to update the DataSet with new values when the data source is updated. With RETURNED DATAROWS, you must supply sql_refresh_statement, which is an SQL SELECT for the columns which are to have new values. With OUT PARAMETERS, the stored procedure that performs the SQL INSERT will supply the update columns as output parameters.

Example:

     EXEC ADO
        TO INSERT INTO Orders
        WITH REFRESH USING RETURNED DATAROW USE
        INSERT INTO Orders (CustomerID, OrderDate)
        VALUES ({CustomerID}, {OrderDate});
        SELECT @@IDENTITY as OrderID
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
PREPARE TO UPDATE
TO DELETE USE
TO REFRESH USE
TO UPDATE USE
UPDATE


TO REFRESH USE

Specifies, for a specific DataTable, the SQL logic necessary to refresh the rows of a DataTable, showing the changes made to the data source after the UPDATE DATASOURCE statement was executed.

Syntax:

>>--EXEC ADO--.--------------------.TO REFRESH datatable_name-->
              +-USING dataset_name-+

>------+-AFTER UPDATE          -+------------------------------>
       +-AFTER INSERT          -+
       +-AFTER INSERT OR UPDATE-+

>---.-------------------------------------------------.-------->
     |                                                 |
     |           +---------------  ,  --------------+  |
     |           V                                  |  |
     +- MAPPING--datatable_col_name AS table_col_name--+

 >--------------USE--sql_refresh_statement--------------------->

 >--END-EXEC---><

Parameters:

datatable_name | The DataTable to be refreshed.
dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
AFTER | The action to the data source, when the UPDATE DATASOURCE statement is executed, that causes a refresh.
datatable_col_name | The name of a column in a DataTable.
table_col_name | The name of a column in an SQL table.
sql_refresh_statement | The SQL SELECT statement that retrieves the columns that need to be refreshed.

Comments:

The SQL logic must reference actual tables and columns in the data source that needs to be refreshed.

The SQL logic can refer to column values for the row that has been deleted in the DataTable by using the column name enclosed in braces, optionally followed by the type of value (CURRENT, ORIGINAL, DEFAULT, or PROPOSED), separated by a period. For example, {OrderId} or {OrderID.Original}.

Example:

     EXEC ADO
        TO REFRESH Orders USE
        SELECT @@IDENTITY as OrderID
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
PREPARE TO UPDATE
TO DELETE USE
TO INSERT USE
TO UPDATE USE
UPDATE


TO UPDATE USE

Specifies, for a specific DataTable, the SQL logic necessary to make updates to a data source.

Syntax:

>>--EXEC ADO--.---------------------.-TO UPDATE datatable_name-->
               +-USING dataset_name-+

>--.----------------------------------------------------------.->
   |                                                          |
   +--WITH REFRESH USING--+-RETURNED DATAROW                 -+
                          +-RETURNED DATAROW , OUT PARAMETERS-+
                          +-OUT PARAMETERS                   -+

>--USE--+-sql_update_statement--.-----------------------.------->
        |                       +-sql_refresh_statement-+
        |                                               |
        +-stored_procedure_statement--------------------+

 >--END-EXEC---><

Parameters:

datatable_name | The name of a DataTable.
dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
WITH REFRESH USING | Specifies how to retrieve new values in the data source as a result of the execution of the TO UPDATE statement.
sql_update_statement | A standard SQL UPDATE (SEARCHED) statement that references an actual table and its columns in a data source.
sql_refresh_statement | The SQL SELECT statement that cites columns in the DataTable that need to be refreshed.
stored_procedure_statement | Specifies the stored procedure to execute to perform the SQL UPDATE (SEARCHED) statement

Comments:

The SQL logic must reference actual tables and columns in the data source.

The SQL logic can refer to column values for the row that has been deleted in the DataTable by using the column name enclosed in braces, optionally followed by the type of value (CURRENT, ORIGINAL, DEFAULT, or PROPOSED), separated by a period. For example, {OrderId} or {OrderID.Original}.

Use the WITH REFRESH USING clause to specify how to update the DataSet with new values when the data source is updated. With RETURNED DATAROWS, you must supply sql_refresh_statement, which is an SQL SELECT for the columns which are to have new values. With OUT PARAMETERS, the stored procedure that performs the SQL INSERT will supply the update columns as output parameters.

Example:

     EXEC ADO PREPARE TO UPDATE Orders, Customers, "Order Details" END-EXEC
        EXEC ADO TO UPDATE Customers USE
              UPDATE Customers SET
                 ContactName = {ContactName},
                 City = {City}
              WHERE CustomerID = {CustomerID}
        END-EXEC
     EXEC ADO UPDATE DATASOURCE END-EXEC
Parent topic: Embedded ADO Statements
Related reference
PREPARE TO UPDATE
TO DELETE USE
TO INSERT USE
TO REFRESH USE
UPDATE


UNBIND

Disassociates OpenESQL from a DataSet or DataTable in another ADO.NET application.

Syntax, Format 1:

>>--EXEC ADO--.--------------------.--UNBIND---END-EXEC---><
              +-USING dataset_name-+

Syntax, Format 2:

>>--EXEC ADO --UNBIND DATATABLE datatable_name---END-EXEC---><

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
datatable_name | The name of the DataTable you want to share with OpenESQL.

Examples:

     EXEC ADO
        USING ds UNBIND
     END-EXEC

     EXEC ADO
        UNBIND DATATABLE TABLE1
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
BIND
GET DATATABLE


UNBIND CONNECTION

Disassociates OpenESQL from the original ADO.NET connection object.

Syntax:

>>--EXEC ADO--UNBIND CONNECTION--.-----------------.---->
                                 +-connection_name-+
                                 +-:conn_name_hv---+

 >----END-EXEC----><

Parameters:

connection_name | The connection name OpenESQL uses to refer to the ADO.NET connection object.
conn_name_hv | Host variable which contains the connection name OpenESQL uses to refer to the ADO.NET connection object.

Example:

     EXEC ADO
        UNBIND CONNECTION fred
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
BIND CONNECTION
REBIND CONNECTION


UPDATE

Updates a data source with changes made in the DataTables of a DataSet.

Syntax:

>>--EXEC ADO----—UPDATE DATASOURCE-----END-EXEC--><

Comment:

This statement can only be executed after a PREPARE TO UPDATE statement and subsequent TO INSERT, TO UPDATE and TO DELETE statements. The TO commands specify the SQL logic necessary to change tables in the actual data source. If no TO commands are created, OpenESQL attempts to supply default SQL. For a table with no parent tables the default SQL is to select all rows in the table. For a table with a parent table the default SQL is to select rows for which the parent rows have been selected.

Example:

     EXEC ADO
        UPDATE DATASOURCE
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
PREPARE TO UPDATE
TO DELETE USE
TO INSERT USE
TO REFRESH USE
TO UPDATE USE


UPDATE (POSITIONED)

Updates the DataRow most recently fetched by using a DataRows cursor.

Syntax:

>>-EXEC ADO-.--------------------.--UPDATE-datatable_name---->
            +-USING dataset_name-+

         +-----------  ,  -----------+
         V                           |
>--SET---column_name = -+- :hvar-----+----------------------->
                       -+- col_value-+

>--WHERE CURRENT OF--datarows_name---END-EXEC----------------><

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
datatable_name | The name of the DataTable to be updated.
column_name | The column to be updated.
hvar | Host variable that contains the column value.
col_value | The column value.
datarows_name | A previously declared, opened, and fetched DataRows cursor.

Comments:

EXEC ADO supports positioned update; however, not all ADO.NET data providers support positioned update.

With some ADO.NET data providers, the SELECT statement used by the cursor must contain a FOR UPDATE clause to enable positioned update.

The other form of UPDATE used in EXEC ADO statements is known as a searched update.

You cannot use host arrays with positioned update.

Most data sources require specific combinations of SCROLLOPTION and CONCURRENCY to be specified either by SET statements or in the DECLARE CURSOR statement.

Example:

* Declare the cursor
     EXEC ADO
        DECLARE c1 DATAROWS FROM oline
     END-EXEC

* Open the cursor
     EXEC ADO
        OPEN c1
     END-EXEC

* Modify the table using positioned updates and deletes
     PERFORM UNTIL EXIT
        * Delete row 1, 4, 7, ...
        EXEC ADO FETCH c1 INTO :oline END-EXEC
        IF SQLCODE NOT = 0
           EXIT PERFORM
        END-IF
        EXEC ADO DELETE FROM oline WHERE CURRENT OF c1 END-EXEC

        * Update row 2, 5, 8, ...
        EXEC ADO FETCH c1 INTO :oline END-EXEC
        IF SQLCODE NOT = 0
           EXIT PERFORM
        END-IF
        MOVE 99 TO qty
        EXEC ADO UPDATE oline SET qty = :qty WHERE CURRENT OF c1 END-EXEC

        * Leave alone row 3, 6, 9, ...
        EXEC ADO FETCH c1 INTO :oline END-EXEC
        IF SQLCODE NOT = 0
           EXIT PERFORM
        END-IF
     END-PERFORM
Parent topic: Embedded ADO Statements
Related reference
ACCEPT CHANGES
CLOSE
DECLARE DATAROWS
DELETE (POSITIONED)
FETCH
OPEN
REJECT CHANGES


UPDATE (SEARCHED)

Updates a DataTable either by using a standard SQL WHERE clause or by replacement via a host variable array.

Syntax, Format 1:

>>--EXEC ADO--.-------------------.---UPDATE—datatable_name--------->
              +-USING dataset_name+

         +-----------  ,  -----------+
         V                           |
>--SET---column_name = -+- :hvar-----+------------------------------>
                       -+- col_value-+

>-.------------------------------------.—.-------------------------.>
  +-FOR-.-ADDED-------------.-DATAROWS-+ +-WHERE search_conditions-+
        +-CURRENT-----------+
        +-DELETED-----------+
        +-MODIFIED CURRENT--+
        +-MODIFIED ORIGINAL-+
        +-ORIGINAL----------+
        +-UNCHANGED---------+

>--END-EXEC-><

Syntax, Format 2:

>>--EXEC ADO--.-------------------.---FOR :host_integer UPDATE—------->
              +-USING dataset_name+

                          +-----------  ,  -----------+
                          V                           |
>-- datatable_name  SET---column_name = -+- :hvar-----+----END-EXEC-><

Parameters:

dataset_name | The DataSet reference to be used. If you do not specify dataset_name, the current DataSet is used.
datatable_name | The name of the DataTable to be updated.
column_name | The name of a column in a DataTable.
:hvar | Host variable that contains the column value.
col_value | The column value.
FOR DATAROWS | The row state of the DataRows to be updated.
search_condition | Any valid expression that can follow the standard SQL WHERE clause.
:host_integer | A host variable that specifies the maximum number of host array elements processed. Must be declared as PIC S9(4) COMP-5 or PIC S9(9) COMP-5.

Comments:

This statement is similar to the embedded EXEC SQL UPDATE (SEARCHED) statement.

After execution, SQLERRD(3) contains the number of elements processed. For UPDATE it is the total number of rows updated.

Example:

     EXEC ADO
        UPDATE Customers
        SET
        ContactName = 'Alan Jones',
        ContactTitle = 'Managing Director',
        City = 'Norwich'
        WHERE CustomerID = 'ZZZZ2'
     END-EXEC
Parent topic: Embedded ADO Statements
Related reference
ACCEPT CHANGES
REJECT CHANGES
DECLARE DATATABLE


USING

Specifies the current DataSet name to be used in subsequent processing.

Syntax:

>>--EXEC ADO---USING dataset_name----END-EXEC----><

Parameters:

dataset_name The name of the DataSet that becomes the current DataSet for subsequent EXEC ADO processing.

Comment:

References to DataTables in EXEC ADO statements that have no USING clause use the current DataSet name.

Example:

     EXEC ADO
        USING ds
     END-EXEC
Parent topic: Embedded ADO Statements


SQL Compiler Directive Options

Note: SQL compiler directives for HCOSS are located under the SQL Compiler Directive Options - HCOSS topic in the HCO for SQL Server (HCOSS) section of this documentation.
  • ADOPICXISANSI
    Instructs OpenESQL to pass string and character variables as ANSI.
  • ALLOWNULLCHAR
    Allows programs to use PIC X(n) host variables, and to select/insert/update hexadecimal characters in CHAR columns without changing source to use SQL TYPE BINARY host variables.
  • ANSI92ENTRY
    If this is set, OpenESQL conforms to the SQL ANSI'92 entry level standard.
  • AUTOCOMMIT
    If this is set, each SQL statement is treated as a separate transaction and is committed immediately upon execution. If this is not set, and the ODBC driver you are using supports transactions, statements must be explicitly committed (or rolled back) as part of a transaction.
  • AUTOFETCH
    Sets the AUTOFETCH attribute on SELECT statements that are run on Microsoft SQL Server data sources. Compiling with this directive can help the performance of your application. This directive works only if the program is also compiled with directive SQL(TARGETDB=MSSQLSERVER). It also serves as a primitive directive for the BEHAVIOR directive option.
  • BEHAVIOR
    Instructs OpenESQL to properly match your COBOL cursors with the database you specify, thus maximizing database cursor performance. BEHAVIOR makes use of multiple primitive directives and associates a default value for each primitive directive depending on the DBMS you are using. You can also override the default setting of any primitive directive.
  • CHECK
    Sends each SQL statement to the database at compilation time.
  • CHECKDUPCURSOR
    Instructs OpenESQL to determine if the cursor has been opened twice, and if so takes action accordingly.
  • CHECKSINGLETON
    Instructs OpenESQL to check if singleton SELECTs return more than one row when executed. If this is the case, OpenESQL returns SQLCODE -811.
  • CONCAT
    Specifies the ASCII character code to use for the CONCAT symbol (|). Use this directive only if you need to change the default.
  • CONNECTIONPOOL
    Enables use of ODBC 3.0 connection pooling. When a connection is closed, the Driver Manager actually keeps it alive for a timeout period, and saves the overhead of re-establishing a connection from scratch if the application re-opens an identical connection. ODBC allows you to choose between having a pooling for an ODBC environment or for each driver. See your ODBC documentation for details.
  • CTRACE
    Causes debug information to be put into the file sqltrace.txt.
  • CURSORCASE
    If ESQLVERSION is 2.0, CURSORCASE is implied. NOCURSORCASE means that cursor names are not case sensitive. CURSORCASE means that they are case sensitive. Note that in previous versions of OpenESQL, cursor names have been case sensitive.
  • DATE
    Controls the reformatting of date values in output parameters and in input parameter character host variables when DETECTDATE is also specified.
  • DATEDELIM
    Specifies a single character as the delimiter between the year, month, and day components to override the default delimiter determined by the HCOSS DIALECT or DATE directive specification.
  • DB
    The name of the data source to connect to. This option works in conjunction with the INIT and/or CHECK options. The .int file generated is the same except for the TARGETDB number embedded in the file.
  • DBMAN
    Specifies the preprocessor to use. This directive is not required when compiling programs with OpenESQL.
  • DECDEL
    Eliminates the need for OpenESQL to call the routine GetLocaleInfo for any variable that would store decimal data. This routine is called every time the variable is accessed to return the decimal delimiter used. In most cases, this is a period or comma. The options for this directive are:
  • DETECTDATE
    Enables recognition of date, time and datetime values in character host variables.
  • ESQLVERSION
    Sets OpenESQL syntax level.
  • FIPSFLAG
    Enables FIPS flagging (NIST certification requirement only).
  • GEN-INIT-FLAG
    Generates the SQL-INIT-FLAG variable for DB2 for OS/390 compatibility. The flag is updated when the SQL environment is initialized. If you define this variable in your application, compile your application with this directive set to NOGEN-INIT-FLAG and the variable will not be generated by the precompiler.
  • HSFTRACE
    Generates calls around each SQL statement to the HSF trace routine if the application is running under Enterprise Server. In some cases, the application must be linked with mfsqlSMF.lib.
  • IGNORE-NESTED
    In nested programs, this is the program-id at which to start generating the database interface code. If the program file name matches the program-id, you can just specify IGNORE-NESTED.
  • INIT
    If this is set, the preprocessor automatically generates code to make the connection to the database. If you specify INIT, you must also specify DB and PASS. We highly recommend that you use EXEC SQL CONNECT statements in your application instead.
  • ISOLATION
    This directive specifies the isolation level that OpenESQL uses as a connection attribute. It also serves as a primitive directive for the BEHAVIOR directive option.
  • JIT
    Generate OpenESQL interface code only if an EXEC SQL statement is found in the procedure division.
  • MARS
    Enable multiple active results sets when connecting to an Microsoft SQL Server 2005 or later. To use this directive, you must also specify TARGETDB=MSSQLSERVER.
  • NIST
    Sets OpenESQL to conform to the NIST interpretation of the SQL ANSI 92 entry level standard.
  • NOT
    Specifies the character code to use for NOT symbol (¬). Use this only if you need to change the default setting.
  • ODBCTRACE
    ODBCTRACE=USER enables you to control ODBC tracing via the ODBC control panel from which you can specify the file that the trace goes into.
  • ODBCV3
    This directive causes an application to register itself as an ODBC Version 3 application. If ODBCV3 is not specified, the application registers itself as an ODBC Version 2 application. There can be a small performance benefit in registering as an ODBC 3 application. However, registering as an ODBC Version 3 application can result in error and warning conditions returning different values for SQLCODE and SQLSTATE. We recommend that you use this directive with care.
  • PARAMARRAY
    If PARAMARRAY is set, ODBC array binding is used, if it is supported by the ODBC driver, for all input parameters.
  • PASS
    The login to use to connect to the data source. This option works in conjunction with the INIT and/or CHECK options.
  • PRE
    PRE causes the preprocessor to generate code to load the OpenESQL runtime module (odbcrw32.dll) dynamically at runtime. This conflicts with the LITLINK compiler directive. So if you use LITLINK, specify NOPRE to stop the dynamic loading code being generated. In this case, you must add odbcrw32.lib to the list of LIBs to be linked in your build settings. Then the linker generates code into the executable which causes the operating system to load odbcrw32.dll implicitly when the executable is loaded.
  • PREFETCH
    An application can use this directive to request that OpenESQL use block fetches for cursors. This can provide performance benefits, similar to array fetching, without having to change program logic. The performance benefit depends on the value of n and on whether the ODBC driver in use is already configured to use prefetching.
  • QUALFIX
    Causes the OpenESQL preprocessor to append three characters to the name of the host variables when declaring them to SQL. This ensures problems caused by qualification (where two or more host variables have identical names when not qualified) are avoided but has the side-effect that SQL error messages sometimes display the names of host variables with the three additional characters appended to them.
  • RESULTARRAY
    If RESULTARRAY is set, ODBC array binding is used, if it is supported by the ODBC driver, for all output parameters.
  • STMTCACHE
    The number of prepared SQL statements OpenESQL can cache such that the statements never again require preparation during a program run, thus improving performance.
  • TARGETDB
    Set this directive if you want to optimize performance for a specific data source or have the application generate database calls using ORACLE OCI rather than ODBC calls.
  • TESTSQLSTATE
    Instructs OpenESQL to generate code that tests SQLSTATE rather than SQLCODE after an SQL statement is executed.
  • THREAD
    If THREAD is set to ISOLATE, all connections, cursors and so on are local to the thread that creates them. This is required for multi-threaded application server environments such as IIS/ISAPI. With THREAD=SHARE, if you have a hard-coded CONNECT statement and thread 1 executes it and then thread 2 executes it, thread 2 gets an error because the connection is already open. With THREAD=ISOLATE, each thread gets its own connection.
  • TIME
    Controls the reformatting of date values in output parameters and in input parameter character host variables when DETECTDATE is also used.
  • TIMEDELIM
    Specifies a single character as the delimiter between the hour, minute, and second components to override the default delimiter determined by the HCOSS DIALECT or TIME directive specification.
  • TRACELEVEL
    Produces a statistical analysis of application behavior by tracing certain operations in native applications. The report produced by this directive provides better readability and is inherently more useful than a traditional ODBC trace.
  • TSTAMPSEP
    Specifies a single character as the separator between the date and time parts of timestamp and date/time data.
  • USECURLIB
    Controls use of the ODBC's Cursor Library. The Cursor Library can provide support for scrolling cursors when the underlying driver doesn't, and can also allow "simulated" positioned updates. With USECURLIB=YES, the Cursor Library will always be used. With USERCURLIB=NO, it will never be used. With the default USERCURLIB=IFNEEDED, it will be used if the application tries to do something the driver manager thinks the driver doesn't support. To use a scrolling cursor with the Cursor Library, you must use a STATIC cursor. To do positioned updates using the Cursor Library, you must use OPTCCVAL concurrency.
Parent topic: OpenESQL
Related concepts
DBMAN Directive Settings
SQL Compiler Directive Options - HCOSS


ADOPICXISANSI

Instructs OpenESQL to pass string and character variables as ANSI.
Note: By default, the OpenESQL Managed .NET Runtime maps PIC X host variables to ANSI strings when data is sent to the server. The default behavior in earlier versions of the runtime mapped the variable to Unicode strings, occasionally causing performance problems on some servers. The current default corrects these problems in most cases; however, in rare cases where this change causes decreased performance, specify NOADOPICXISANSI to restore the original behavior.

Syntax:

ADOPICXISANSI
NOADOPICXISANSI

Properties:

Default: ADOPICXISANSI

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comment:

ADOPICXISANSI applies to managed ADO.NET runtime and safe runtime only.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


ALLOWNULLCHAR

Allows programs to use PIC X(n) host variables, and to select/insert/update hexadecimal characters in CHAR columns without changing source to use SQL TYPE BINARY host variables.

Syntax:

ALLOWNULLCHAR
NOALLOWNULLCHAR

Properties:

Default: NOALLOWNULLCHAR

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comment:

ALLOWNULLCHAR applies to native runtime only.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options
Fixed-length Binary Strings


ANSI92ENTRY

If this is set, OpenESQL conforms to the SQL ANSI'92 entry level standard.

Syntax:

[NO]ANSI92ENTRY

Properties:

Default: NOANSI92ENTRY

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related reference
DBMAN Directive Settings
Related information
Scope - OpenESQL SQL Compiler Directive Options


AUTOCOMMIT

If this is set, each SQL statement is treated as a separate transaction and is committed immediately upon execution. If this is not set, and the ODBC driver you are using supports transactions, statements must be explicitly committed (or rolled back) as part of a transaction.

Syntax:

[NO]AUTOCOMMIT

Properties:

Default: NOAUTOCOMMIT

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related concepts
Managing Transactions
Related reference
DBMAN Directive Settings
SET AUTOCOMMIT
Related information
Scope - OpenESQL SQL Compiler Directive Options


AUTOFETCH

Sets the AUTOFETCH attribute on SELECT statements that are run on Microsoft SQL Server data sources. Compiling with this directive can help the performance of your application. This directive works only if the program is also compiled with directive SQL(TARGETDB=MSSQLSERVER). It also serves as a primitive directive for the BEHAVIOR directive option.
Note:
  • BEHAVIOR=MAINFRAME for MS SQL Server enables AUTOFETCH
  • Errors on a cursor OPEN are deferred until the subsequent FETCH when AUTOFETCH is enabled

Syntax:

[NO]AUTOFETCH

Properties:

Default: NOAUTOFETCH

Scope:

Used at compile time: | No
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related reference
SET SCROLLOPTION
Related information
Scope - OpenESQL SQL Compiler Directive Options


BEHAVIOR

Instructs OpenESQL to properly match your COBOL cursors with the database you specify, thus maximizing database cursor performance. BEHAVIOR makes use of multiple primitive directives and associates a default value for each primitive directive depending on the DBMS you are using. You can also override the default setting of any primitive directive.

Syntax:

BEHAVIOR={ANSI | MAINFRAME | UNOPTIMIZED | CICS | JCL} [primitivedirective [value]]...

Parameters:

ANSI | Enables OpenESQL to work like the ANSI standard, and enhances the access speed
MAINFRAME | Enables OpenESQL to work as it does on the mainframe, and enhances the access speed
UNOPTIMIZED | Provides backward compatibility with earlier Micro Focus products
CICS Sets all of the following:
  • Enables OpenESQL to work as it does on the mainframe
  • Enhances the access speed
  • Automatically sets the TRANSACTION primitive directive to GLOBAL
JCL Sets all of the following:
  • Enables OpenESQL to work as it does on the mainframe
  • Enhances the access speed
  • Checks for the following statements that are not compatible with JCL applications:
    • CONNECT
    • DISCONNECT
    • SET CONNECT
  • Reports an error for each incompatible statement found
primitivedirective | Optional directives that enable the fine-tuning of BEHAVIOR

Scope:

Used at compile time: | No
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Default:

BEHAVIOR=UNOPTIMIZED

Comments:

  • You can change the default setting to either ANSI or MAINFRAME using the OpenESQL Configuration Utility. However, when the BEHAVIOR directive is specified in program code, project settings, or in a compiler directive file, the specified parameter overrides the default setting.
  • Setting this directive can also affect the SQL types returned when using Dynamic SQL. See the DESCRIBE Statement topic for more information.
  • OpenESQL sets default values for primitive directives depending on the value of BEHAVIOR and your target database. See the topic Primitive Directives for more information.
  • Primitive Directives
Parent topic: SQL Compiler Directive Options
Related concepts
COBOL Program Migration Support
Managing Transactions
HCO for SQL Server Precompiler Options
Related reference
PREFETCH
DBMAN Directive Settings
SET CONCURRENCY
SET SCROLLOPTION
Related information
To set a default for SQL(BEHAVIOR)
OpenESQL Configuration Utility
Optimize for performance and mainframe compatibility
ANSI compliance
No change in default behavior and no optimization
Issue a warning at compile time
Issue an error at compile time
COBOL Program Migration Support
Scope - OpenESQL SQL Compiler Directive Options


Primitive Directives

Primitive directives further qualify the behavior set by the BEHAVIOR directive.

For OpenESQL to use primitive directives, it must be able to determine your target database type. This is done one of two ways:
  • TARGETDB compiler directive option

    OpenESQL uses the database type you specify by setting the TARGETDB directive. When you set the TARGETDB directive, it enables you to override the default value of any primitive directive by specifying it as an argument to the BEHAVIOR directive.

  • SQL CONNECT TO statement

    If you do not set the TARGETDB SQL compiler directive option, OpenESQL determines the target database type based on the SQL CONNECT TO statement in your source code. In this case, OpenESQL uses the default settings for all primitive directives. You cannot override them.

Note: In addition to their role as OpenESQL SQL compiler directive options, AUTOFETCH and ISOLATION also serve as primitive directives to the BEHAVIOR compiler directive option.

Primitive Directive Defaults

Default values for primitive directives vary based on the value of the BEHAVIOR directive, and the database target. Defaults for the MS SQL Server database target are different than those for all other database targets. The following tables show default values for BEHAVIOR settings and database target combinations:

Primitive Directive Defaults for SQL Server Database Targets
Primitive Directive | BEHAVIOR=UNOPTIMIZED1 | BEHAVIOR=MAINFRAME (CICS or JCL) | BEHAVIOR=ANSI
AUTOFETCH | NOAUTOFETCH | AUTOFETCH | AUTOFETCH
DEF_CURSOR | UPD | RO | UPD
IC_FH_ISOLATION | N/A | UR | UR
ISOLATION | CR | CR | CR
PF_RO_CURSOR | 1 | 1 | 1
PF_UPD_CURSOR | 1 | 8 | 8
RO_CURSOR | DYNAMIC | IC_FH 2 | IC_FH 2
TRANSACTION | LOCAL | GLOBAL for CICS, otherwise LOCAL | LOCAL
UPD_CONCURRENCY | LOCK | LOCK | LOCK
UPD_CURSOR | DYNAMIC | DYNAMIC | DYNAMIC
1 Default setting in previous releases.

2 If both the server and the client support MARS, MARS is enabled using a FORWARD cursor.

Primitive Directive Defaults for Database Targets Other than SQL Server
Primitive Directive | BEHAVIOR=UNOPTIMIZED1 | BEHAVIOR=MAINFRAME (CICS or JCL) | BEHAVIOR=ANSI
AUTOFETCH | N/A | N/A | N/A
DEF_CURSOR | UPD | RO | UPD
IC_FH_ISOLATION | N/A | N/A | N/A
ISOLATION | CR | CR | CR
PF_RO_CURSOR | 1 | 8 | 8
PF_UPD_CURSOR | 1 | 8 | 8
RO_CURSOR | DYNAMIC | FORWARD | FORWARD
TRANSACTION | LOCAL | GLOBAL for CICS, otherwise LOCAL | LOCAL
UPD_CONCURRENCY | LOCK | LOCK | LOCK
UPD_CURSOR | DYNAMIC | KEYSET | KEYSET

If you set your target database type using the TARGETDB directive, you can override the default settings by specifying a primitive directive as an argument to the BEHAVIOR directive. The following topics explain the full use of each primitive directive:

  • DEF_CURSOR
    This cursor directive specifies the default cursor type for ambiguous COBOL cursors, either read only or updateable. Use this directive when the DECLARE CURSOR statement has neither the FOR READONLY nor the FOR UPDATE OF clause.
  • IC_FH_ISOLATION
    This directive sets the transaction isolation for independent firehose cursor connections, enabling simultaneous access to firehose cursors.
  • PF_RO_CURSOR
    This is a prefetch directive that enables you to retrieve more than one read only record at a time from the DBMS with one client request.
  • PF_UPD_CURSOR
    This is a prefetch directive that enables you to retrieve more than one updateable record at a time from the DBMS with one client request.
  • RO_CURSOR
    This directive determines what type of database cursor your COBOL read-only cursors use.
  • TRANSACTION
    This directive provides OpenESQL with specifications for managing run-time transactions and, in some cases, enabling compile-time checking.
  • UPD_CONCURRENCY
    This directive enables you to choose the level of concurrency for updateable COBOL cursors.
  • UPD_CURSOR
    This directive determines what type of database cursor updateable COBOL cursors use.
Parent topic: BEHAVIOR
Related reference
TARGETDB
AUTOFETCH
ISOLATION
Related information
Scope - OpenESQL SQL Compiler Directive Options


DEF_CURSOR

This cursor directive specifies the default cursor type for ambiguous COBOL cursors, either read only or updateable. Use this directive when the DECLARE CURSOR statement has neither the FOR READONLY nor the FOR UPDATE OF clause.

Syntax:

DEF_CURSOR={RO | UPD}

Parameters:

RO | Read Only
UPD | Updateable

Scope:

Used at compile time: | No
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comment:

While the default when BEHAVIOR=ANSI is DEF_CURSOR=UPD, if the original developer assumed RO, then use of UPD could adversely affect performance.

Parent topic: Primitive Directives
Related information
Scope - OpenESQL SQL Compiler Directive Options


IC_FH_ISOLATION

This directive sets the transaction isolation for independent firehose cursor connections, enabling simultaneous access to firehose cursors.

Syntax:

 IC_FH_ISOLATION={UR | CR | RR | SZ}

Parameters:

UR | Uncommitted Read
CR | Committed Read
RR | Repeatable Read
SZ | Serializable isolation in ODBC and ADO.NET

Scope:

Used at compile time: | No
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: Primitive Directives
Related information
Scope - OpenESQL SQL Compiler Directive Options


PF_RO_CURSOR

This is a prefetch directive that enables you to retrieve more than one read only record at a time from the DBMS with one client request.

Syntax:

PF_RO_CURSOR={numberofrows | buffersizeK | buffersizeB}

Parameters:

numberofrows | The number of rows to retrieve
buffersizeK | The size of the buffer you want to fill in kilobytes
buffersizeB | The size of the buffer you want to fill in bytes

Scope:

Used at compile time: | No
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comment:

Does not work with FORWARD or IC_FH selection in RO_CURSOR.

Parent topic: Primitive Directives
Related information
Scope - OpenESQL SQL Compiler Directive Options


PF_UPD_CURSOR

This is a prefetch directive that enables you to retrieve more than one updateable record at a time from the DBMS with one client request.

Syntax:

PF_UPD_CURSOR={numberofrows | buffersizeK | buffersizeB}

Parameters:

numberofrows | The number of rows to retrieve
buffersizeK | The size of the buffer you want to fill in kilobytes
buffersizeB | The size of the buffer you want to fill in bytes

Scope:

Used at compile time: | No
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comment:

Does not work with FORWARD selection in RO_CURSOR.

Parent topic: Primitive Directives
Related reference
DBMAN Directive Settings
Related information
Scope - OpenESQL SQL Compiler Directive Options


RO_CURSOR

This directive determines what type of database cursor your COBOL read-only cursors use.

Syntax:

RO_CURSOR={SCROLL | FORWARD | DYNAMIC | KEYSET | STATIC | FF | IC_FH}

Parameters:

FF | Fast Forward
IC_FH | Independent Connection Fire Hose

Scope:

Used at compile time: | No
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

  • SCROLL, FORWARD, DYNAMIC, and KEYSET are standard ODBC types.
  • FF and IC_FH are cursors specific to MS SQL Server.
  • Under MS SQL Server, prefetching does not work with FORWARD and IC_FH.
  • As its name indicates, an IC_FH cursor has its own independent connection to MS SQL Server. Because of this, these cursors are sensitive to the isolation level and locking protocol of previous data access in the application program.
  • When using a SQL Server connection that supports MARS, MARS is automatically enabled and IC_FH is converted to FORWARD.
Parent topic: Primitive Directives
Related information
Scope - OpenESQL SQL Compiler Directive Options


TRANSACTION

This directive provides OpenESQL with specifications for managing run-time transactions and, in some cases, enabling compile-time checking.

Syntax:

TRANSACTION={GLOBAL | LOCAL | MIXED}

Parameters:

GLOBAL Manages transactions using a distributed transaction manager such as CICS, Tuxedo, or COM+.
When BEHAVIOR=CICS, this parameter also:
  • Checks for the following statements that are not compatible with CICS applications:
    • BEGIN TRANSACTION
    • COMMIT
    • CONNECT
    • DISCONNECT
    • ROLLBACK
    • SET AUTOCOMMIT
    • SET CONNECT
    • SET TRANSACTION [ISOLATION]
  • Reports an error for each incompatible statement found.
LOCAL Manages transactions using the data source (default).
When BEHAVIOR=JCL, the default behavior includes:
  • Checks for the following statements that are not compatible with JCL applications:
    • CONNECT
    • DISCONNECT
    • SET CONNECT
  • Reports an error for each incompatible statement found.
MIXED Manages transactions using a distributed transaction manager, but does not perform compile-time checking. Use this option when you need to mix GLOBAL and LOCAL transaction behavior with different data sources.

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: Primitive Directives
Related concepts
Managing Transactions
Related information
Scope - OpenESQL SQL Compiler Directive Options


UPD_CONCURRENCY

This directive enables you to choose the level of concurrency for updateable COBOL cursors.

Syntax:

UPD_CONCURRENCY={LOCK | OPTIMISTIC | OPTCC | OPTCCVAL}

Scope:

Used at compile time: | No
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comment:

LOCK, OPTIMISTIC, OPTCC, and OPTCCVAL are standard ODBC types.

Parent topic: Primitive Directives
Related reference
DBMAN Directive Settings
Related information
Scope - OpenESQL SQL Compiler Directive Options


UPD_CURSOR

This directive determines what type of database cursor updateable COBOL cursors use.

Syntax:

UPD_CURSOR={SCROLL | FORWARD | DYNAMIC | KEYSET | STATIC}

Scope:

Used at compile time: | No
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

  • SCROLL, FORWARD, DYNAMIC, KEYSET, and STATIC are standard ODBC types.
  • Prefetching does not work with FORWARD.
Parent topic: Primitive Directives
Related information
Scope - OpenESQL SQL Compiler Directive Options


CHECK

Sends each SQL statement to the database at compilation time.

Syntax:

[NO]CHECK

Properties:

Default: NOCHECK

Dependencies:

CHECK requires that you also set the DB and PASS compiler directive options.

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

Depending on your driver and/or DBMS and in certain circumstances, CHECK does not flag invalid SQL statements.

Parent topic: SQL Compiler Directive Options
Related concepts
HCO for SQL Server Precompiler Options
Related information
Scope - OpenESQL SQL Compiler Directive Options
Building Applications


CHECKDUPCURSOR

Instructs OpenESQL to determine if the cursor has been opened twice, and if so takes action accordingly.

Syntax:

CHECKDUPCURSOR
NOCHECKDUPCURSOR

Properties:

Default: NOCHECKDUPCURSOR

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

If the cursor has been opened twice and the NOANSI92ENTRY directive has also been specified, CHECKDUPCURSOR returns SQLCODE -516 and sets SQLSTATE=24000.

If the cursor has been opened twice and NOANSI92ENTRY has not been specified, OpenESQL automatically closes the cursor and then re-opens it.

Parent topic: SQL Compiler Directive Options
Related concepts
HCO for SQL Server Precompiler Options
Related reference
DBMAN Directive Settings
Related information
Scope - OpenESQL SQL Compiler Directive Options


CHECKSINGLETON

Instructs OpenESQL to check if singleton SELECTs return more than one row when executed. If this is the case, OpenESQL returns SQLCODE -811.

Syntax:

CHECKSINGLETON
NOCHECKSINGLETON

Properties:

Default: NOCHECKSINGLETON

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

If CHECKSINGLETON is not specified, or NOCHECKSINGLETON is specified, and more than one row is returned, then OpenESQL returns SQLCODE -1.

CHECKSINGLETON is provided for DB2 compatibility.

Parent topic: SQL Compiler Directive Options
Related concepts
HCO for SQL Server Precompiler Options
Related reference
DBMAN Directive Settings
Related information
Scope - OpenESQL SQL Compiler Directive Options


CONCAT

Specifies the ASCII character code to use for the CONCAT symbol (|). Use this directive only if you need to change the default.

Syntax:

CONCAT=ascii-character-code

Properties:

Default: CONCAT=33.

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


CONNECTIONPOOL

Enables use of ODBC 3.0 connection pooling. When a connection is closed, the Driver Manager actually keeps it alive for a timeout period, and saves the overhead of re-establishing a connection from scratch if the application re-opens an identical connection. ODBC allows you to choose between having a pooling for an ODBC environment or for each driver. See your ODBC documentation for details.

This option is only useful for applications that frequently open and close connections. Note that some environments, such as Microsoft Transaction Server (MTS), control connection pooling themselves. This option will probably improve the performance of ISAPI applications that are not running under MTS.

Syntax:

CONNECTIONPOOL={DRIVER | ENVIRONMENT | NONE}

Properties:

Default: CONNECTIONPOOL=NONE.

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


CTRACE

Causes debug information to be put into the file sqltrace.txt.

Syntax:

[NO]CTRACE

Properties:

Default: NOCTRACE.

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


CURSORCASE

If ESQLVERSION is 2.0, CURSORCASE is implied. NOCURSORCASE means that cursor names are not case sensitive. CURSORCASE means that they are case sensitive. Note that in previous versions of OpenESQL, cursor names have been case sensitive.

Syntax:

[NO]CURSORCASE

Properties:

Default: NOCURSORCASE

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


DATE

Controls the reformatting of date values in output parameters and in input parameter character host variables when DETECTDATE is also specified.

Syntax

DATE={ODBC | ISO | USA | EUR | JIS}

Parameters:

ODBC
yyyy-mm-dd
ISO
yyyy-mm-dd
USA
mm/dd/yyyy
EUR
dd.mm.yyyy
JIS
yyyy-mm-dd

Properties:

Default: ODBC

Dependencies:

Requires that the DETECTDATE SQL directive also be set for input host parameters.

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

DATE changes the display format of output host variables as specified.

In addition, DATE scans input character host variables to identify those that match the DATE format. DATE then converts the contents of the host variables matching the DATE format to the date format of the DBMS.

You can use the DATEDELIM directive to override the default delimiter used in the output format to separate day, month, and year components.

Parent topic: SQL Compiler Directive Options
Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
HCO for SQL Server Precompiler Options
Building Applications
Related reference
DETECTDATE
Related information
Scope - OpenESQL SQL Compiler Directive Options
TIME
DATEDELIM
TSTAMPSEP


DATEDELIM

Specifies a single character as the delimiter between the year, month, and day components to override the default delimiter determined by the HCOSS DIALECT or DATE directive specification.

Syntax

DATEDELIM=character

Properties:

Default: None

Dependencies:

Requires that either the DATE or the DIALECT directive also be set.

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

The default delimiter overridden is the delimiter used in by output type parameter specified for the DATE directive, if set. For example, if DATE=USA, the default delimiter is a slash (/).

When using the HCOSS DIALECT directive without the DATE directive, the default delimiter overridden is a dash (-).

Parent topic: SQL Compiler Directive Options
Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Scope - HCOSS SQL Compiler Directive Options
Related reference
DATE
Related information
Scope - OpenESQL SQL Compiler Directive Options


DB

The name of the data source to connect to. This option works in conjunction with the INIT and/or CHECK options. The .int file generated is the same except for the TARGETDB number embedded in the file.

Syntax:

DB=databaseName
NODB

Properties:

Default: NODB

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related concepts
Database Connections
Related reference
INIT
CHECK
Related information
Scope - OpenESQL SQL Compiler Directive Options
Building Applications


DBMAN

Specifies the preprocessor to use. This directive is not required when compiling programs with OpenESQL.

Syntax:

DBMAN={ODBC | ADO}

Parameters:

ODBC | For native code
ADO | For .NET managed code

Properties:

Default: DBMAN=ODBC

Scope:

Used at compile time: | Yes
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

Applications compiled with SQL(DBMAN=ODBC) for .NET must be compiled with the ILTARGET directive specifying the appropriate platform. You cannot specify ILTARGET(AnyCPU) in this case.

Parent topic: SQL Compiler Directive Options
Related concepts
ODBC
ADO.NET
HCO for SQL Server Precompiler Options
Related reference
DBMAN Directive Settings
Related information
Scope - OpenESQL SQL Compiler Directive Options
Building Applications


DECDEL

Eliminates the need for OpenESQL to call the routine GetLocaleInfo for any variable that would store decimal data. This routine is called every time the variable is accessed to return the decimal delimiter used. In most cases, this is a period or comma. The options for this directive are:
DECDEL=PERIOD | Always use a period as a decimal delimiter
DECDEL=COMMA | Always use a comma as a decimal delimiter
DECDEL=LOCAL | Call GetLocaleInfo one time to get the decimal delimiter

Syntax:

DECDEL={PERIOD | COMMA | LOCAL}
NODECDEL

Properties:

Default: NODECDEL, which causes OpenESQL to call GetLocaleInfo every time a decimal variable is referenced.

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


DETECTDATE

Enables recognition of date, time and datetime values in character host variables.

Syntax:

[NO]DETECTDATE

Properties:

Default: NODETECTDATE

Scope:

Used at compile time: | Yes
Behavior at run time: | OpenESQL - Process HCOSS - Source file

See Scope - OpenESQL SQL Compiler Directive Options and Scope - HCOSS SQL Compiler Directive Options for more information.

Comments:

When using DETECTDATE with the HCOSS DATE or TIME directive, it converts values that match DB2 formats to SQL Server-compatible formats.

The following comments apply to DETECTDATE as a generic SQL compiler directive, that is, not in the context of HCO for SQL Server (HCOSS):
  • Use DETECTDATE if your server does not have a suitable native character string date representation (for example, Microsoft Access). It is also useful for generic applications.
  • DETECTDATE identifies the following escape sequences:
    • {dData} - date
    • {tData} - time
    • {tsData} - timestamp
  • Once identified, DETECTDATE binds the host variables as date, time, and timestamp columns as appropriate instead of binding them as character columns.
  • The use of DETECTDATE can cause problems if your database contains character columns not related to date or time data that can legitimately contain data that starts with {d, {t or {ts.
Parent topic: SQL Compiler Directive Options
Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Scope - HCOSS SQL Compiler Directive Options
Related reference
DATE
HCO for SQL Server Compiler Directive Options for PL/I
Related information
Scope - OpenESQL SQL Compiler Directive Options
Building Applications
TIME


ESQLVERSION

Sets OpenESQL syntax level.

Syntax:

Note: Micro Focus plans to deprecate ESQLVERSION in a future release.
ESQLVERSION={1.0 | 2.0 | 3.0}

Properties:

Default: ESQLVERSION=3.0

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related reference
DBMAN Directive Settings
Related information
Scope - OpenESQL SQL Compiler Directive Options


FIPSFLAG

Enables FIPS flagging (NIST certification requirement only).

Syntax:

[NO]FIPSFLAG

Properties:

Default: NOFIPSFLAG.

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


GEN-INIT-FLAG

Generates the SQL-INIT-FLAG variable for DB2 for OS/390 compatibility. The flag is updated when the SQL environment is initialized. If you define this variable in your application, compile your application with this directive set to NOGEN-INIT-FLAG and the variable will not be generated by the precompiler.

Syntax:

[NO]GEN-INIT-FLAG

Properties:

Default: NOGEN-INIT-FLAG

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


HSFTRACE

Generates calls around each SQL statement to the HSF trace routine if the application is running under Enterprise Server. In some cases, the application must be linked with mfsqlSMF.lib.

Syntax:

HSFTRACE
NOHSFTRACE

Properties:

Default: HSFTRACE

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

SMFTRACE is an alias for HSFTRACE.

Parent topic: SQL Compiler Directive Options
Parent topic: DB2 Compiler Directive Options
Parent topic: COBSQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


IGNORE-NESTED

In nested programs, this is the program-id at which to start generating the database interface code. If the program file name matches the program-id, you can just specify IGNORE-NESTED.

Syntax:

IGNORE-NESTED=program-id
NOIGNORENESTED

Properties:

Default: NOIGNORE-NESTED.

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


INIT

If this is set, the preprocessor automatically generates code to make the connection to the database. If you specify INIT, you must also specify DB and PASS. We highly recommend that you use EXEC SQL CONNECT statements in your application instead.

Syntax:

INIT[=PROT]
NOINIT

Parameters:

PROT In the event that the application terminates abnormally, correctly closes down the database connection and rolls back all changes since the last COMMIT, avoiding potential database corruption.

Properties:

Default: NOINIT

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related concepts
Compiling Multiple Program Modules
Database Connections
Related information
Scope - OpenESQL SQL Compiler Directive Options
Building Applications


ISOLATION

This directive specifies the isolation level that OpenESQL uses as a connection attribute. It also serves as a primitive directive for the BEHAVIOR directive option.

Syntax:

ISOLATION={UR | CR | RR | SZ}

Parameters:

UR | Uncommitted Read
CR | Committed Read
RR | Repeatable Read
SZ | Serializable isolation in ODBC and ADO.NET

Properties:

Default: CR

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


JIT

Generate OpenESQL interface code only if an EXEC SQL statement is found in the procedure division.

Syntax:

[NO]JIT

Properties:

Default: NOJIT

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


MARS

Enable multiple active results sets when connecting to an Microsoft SQL Server 2005 or later. To use this directive, you must also specify TARGETDB=MSSQLSERVER.

Syntax:

MARS

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related concepts
HCO for SQL Server Precompiler Options
Related information
Scope - OpenESQL SQL Compiler Directive Options
Building Applications


NIST

Sets OpenESQL to conform to the NIST interpretation of the SQL ANSI 92 entry level standard.

Syntax:

[NO]NIST

Properties:

Default: NONIST

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related reference
DBMAN Directive Settings
Related information
Scope - OpenESQL SQL Compiler Directive Options


NOT

Specifies the character code to use for NOT symbol (¬). Use this only if you need to change the default setting.

Syntax:

NOT=ascii-character-code

Properties:

Default: NOT=170.

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


ODBCTRACE

ODBCTRACE=USER enables you to control ODBC tracing via the ODBC control panel from which you can specify the file that the trace goes into.

ALWAYS lets you control ODBC tracing via a directive, which is more convenient from within the IDE. ALWAYS generates the trace into MFSQLTRACE.LOG in the current directory, regardless of the settings on the ODBC control panel.

Under normal development conditions, and depending on the project's build setting, this is the Debug or Release directory of the current project. NEVER means that the application will never be traced and overrides the control panel. As ODBC trace files can contain sensitive information, use NEVER in production applications in secure environments. For more information see the database driver documentation.

Syntax:

ODBCTRACE={ALWAYS | NEVER | USER}

Properties:

Default: ODBCTRACE=USER.

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


ODBCV3

This directive causes an application to register itself as an ODBC Version 3 application. If ODBCV3 is not specified, the application registers itself as an ODBC Version 2 application. There can be a small performance benefit in registering as an ODBC 3 application. However, registering as an ODBC Version 3 application can result in error and warning conditions returning different values for SQLCODE and SQLSTATE. We recommend that you use this directive with care.

Syntax:

[NO]ODBCV3

Properties:

Default: ODBCV3

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


PARAMARRAY

If PARAMARRAY is set, ODBC array binding is used, if it is supported by the ODBC driver, for all input parameters.

Syntax:

[NO]PARAMARRAY

Properties:

Default: PARAMARRAY.

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


PASS

The login to use to connect to the data source. This option works in conjunction with the INIT and/or CHECK options.

Syntax:

PASS={password | userid.password}
NOPASS

Properties:

Default: NOPASS

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related concepts
Database Connections
Related reference
INIT
CHECK
Related information
Scope - OpenESQL SQL Compiler Directive Options


PRE

PRE causes the preprocessor to generate code to load the OpenESQL runtime module (odbcrw32.dll) dynamically at runtime. This conflicts with the LITLINK compiler directive. So if you use LITLINK, specify NOPRE to stop the dynamic loading code being generated. In this case, you must add odbcrw32.lib to the list of LIBs to be linked in your build settings. Then the linker generates code into the executable which causes the operating system to load odbcrw32.dll implicitly when the executable is loaded.

Syntax:

Note:
[NO]PRE

Properties:

Default: PRE

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


PREFETCH

An application can use this directive to request that OpenESQL use block fetches for cursors. This can provide performance benefits, similar to array fetching, without having to change program logic. The performance benefit depends on the value of n and on whether the ODBC driver in use is already configured to use prefetching.

If n is less than 1000, it controls the number of rows to be fetched per batch and the same number of rows is fetched for all cursors. If n is greater than or equal to 1000, it sets the size of the prefetch buffer for each cursor. All cursors will have the same buffer size but the number of rows prefetched will depend on the overall size of the row returned by the query for each cursor.

When PREFETCH=n is used with Microsoft SQL Server, AUTOFETCH is also used for read only cursors. Cursors which are not read only are forced to be keyset cursors and can be used for positioned updates. PREFETCH=n is only supported with DB2, Oracle and Microsoft SQL Server.

Syntax:

PREFETCH=n

Properties:

Default: PREFETCH=8

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comment:

Much of the functionality provided by PREFETCH is now incorporated into the functionality of the BEHAVIOR SQL compiler directive option. As a result, PREFETCH is likely to be deprecated in a future release.

Parent topic: SQL Compiler Directive Options
Related reference
BEHAVIOR
Related information
Scope - OpenESQL SQL Compiler Directive Options


QUALFIX

Causes the OpenESQL preprocessor to append three characters to the name of the host variables when declaring them to SQL. This ensures problems caused by qualification (where two or more host variables have identical names when not qualified) are avoided but has the side-effect that SQL error messages sometimes display the names of host variables with the three additional characters appended to them.

Syntax:

[NO]QUALFIX

Properties:

Default: NOQUALFIX

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


RESULTARRAY

If RESULTARRAY is set, ODBC array binding is used, if it is supported by the ODBC driver, for all output parameters.

Syntax:

[NO]RESULTARRAY

Properties:

Default: RESULTARRAY.

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


STMTCACHE

The number of prepared SQL statements OpenESQL can cache such that the statements never again require preparation during a program run, thus improving performance.

Syntax:

STMTCACHE=n
NOSTMTCACHE

Parameter:

n Any number; however we recommend that you set this to a number between 20 and 300

Properties:

Default: NOSTMTCACHE

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

Exercise caution with this directive as STMTCACHE is a trade off between performance and memory use.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


TARGETDB

Set this directive if you want to optimize performance for a specific data source or have the application generate database calls using ORACLE OCI rather than ODBC calls.

Syntax:

TARGETDB={MSSQLSERVER | ORACLEOCI | ORACLE | INFORMIX |
          SYBASE | DB2 | ORACLE7}
NOTARGETDB

Properties:

Default: NOTARGETDB

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related reference
DBMAN Directive Settings
Related information
Scope - OpenESQL SQL Compiler Directive Options


TESTSQLSTATE

Instructs OpenESQL to generate code that tests SQLSTATE rather than SQLCODE after an SQL statement is executed.

Syntax:

TESTSQLSTATE
NOTESTSQLSTATE

Properties:

Default: NOTESTSQLSTATE

Scope:

Used at compile time: | Yes
Behavior at run time: | N/A

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Example:

           invoke wCLRRTS "adoastop" using
               by reference SQLCA
           move SQLCA(13:4) to MFSQLECM-SQLCODE-2(1:4)
           move SQLCA(101:1) to MFSQLECM-SQLWARN
           move SQLCA(132:2) to MFSQLECM-SQLSTATE-2
           perform MFSQLECM-UPD-SQLCA-2
           if MFSQLECM-SQLSTATE-2 not = "00" and MFSQLECM-SQLSTATE-2 not
      -        = "01" and MFSQLECM-SQLSTATE-2 not = "02"
               go to SQL-ERROR
           end-if
           if MFSQLECM-SQLCODE-2 > 0 and MFSQLECM-SQLCODE-2 not = 100
               move "W" to MFSQLECM-SQLWARN
           else
               if MFSQLECM-SQLCODE-2 not = 0
                   move " " to MFSQLECM-SQLWARN
               end-if
           end-if
           if MFSQLECM-SQLSTATE-2 = "01"
               go to SQL-ERROR
           end-if
Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


THREAD

If THREAD is set to ISOLATE, all connections, cursors and so on are local to the thread that creates them. This is required for multi-threaded application server environments such as IIS/ISAPI. With THREAD=SHARE, if you have a hard-coded CONNECT statement and thread 1 executes it and then thread 2 executes it, thread 2 gets an error because the connection is already open. With THREAD=ISOLATE, each thread gets its own connection.

Syntax:

THREAD={SHARE | ISOLATE}

Properties:

Default: THREAD=SHARE.

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


TIME

Controls the reformatting of date values in output parameters and in input parameter character host variables when DETECTDATE is also used.

Syntax:

TIME={ODBC | ISO | USA | EUR | JIS}

Parameters:

ODBC
hh:mm:ss
ISO
hh.mm.ss
USA
hh:mm {AM | PM}
EUR
hh.mm.ss
JIS
hh:mm:ss

Properties:

Default: ISO

Dependencies:

Requires that the DETECTDATE SQL directive also be set for input host parameters.

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

TIME changes the display format of output host variables as specified.

In addition, TIME scans input character host variables to identify those that match the TIME format. TIME then converts the contents of the host variables matching the TIME format to the time format of the DBMS.

The following apply to USA format:
  • Minutes can be omitted. For example, 1 PM is equivalent to 1:00 PM.
  • AM and PM are not case sensitive.
  • There must be a single blank before AM or PM.
  • The hour must not be greater than 12 and cannot be 0 except for the special case of 00:00 AM.

You can use the TIMEDELIM directive to override the default delimiter used in the output format to separate hours, minutes, and seconds components.

Parent topic: SQL Compiler Directive Options
Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Building Applications
Related reference
DETECTDATE
DATE
HCO for SQL Server Compiler Directive Options for PL/I
Related information
Scope - OpenESQL SQL Compiler Directive Options
TIMEDELIM
TSTAMPSEP


TIMEDELIM

Specifies a single character as the delimiter between the hour, minute, and second components to override the default delimiter determined by the HCOSS DIALECT or TIME directive specification.

Syntax

TIMEDELIM=character

Properties:

Default: None

Dependencies:

Requires that either the TIME or the DIALECT directive also be set.

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

The default delimiter overridden is the delimiter used in by output type parameter specified for the TIME directive, if set. For example, if TIME=JIS, the default delimiter is a colon (:).

When using the HCOSS DIALECT directive without the TIME directive, the default delimiter overridden is one of the following, depending on the parameter specified for the DIALECT directive:
DIALECT setting | Default delimiter
MAINFRAME | dot (.)
All other settings | dash (-)
Parent topic: SQL Compiler Directive Options
Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Scope - HCOSS SQL Compiler Directive Options
Related reference
DIALECT
Related information
Scope - OpenESQL SQL Compiler Directive Options
TIME


TRACELEVEL

Produces a statistical analysis of application behavior by tracing certain operations in native applications. The report produced by this directive provides better readability and is inherently more useful than a traditional ODBC trace.

The the statistical analysis information is written to a logfile named OpenESQLTrace.processID.log, which is created the first time you use TRACELEVEL. With each subsequent use of TRACELEVEL, tracing information is appended to the end of the file. A separator record is written at the end of each trace to help identify different traces.

When you compile with SQL(DBMAN=ADO TRACELEVEL), the statistical analysis is stored in a file named ADOTrace.processID.sessionID.log, where SessionID is in the context of our Multiple Run Unit support. This logfile is created the first time you use TRACELEVEL. With each subsequent use of TRACELEVEL, tracing information is appended to the end of the file. A separator record is written at the end of each trace to help identify different traces.

OpenESQL creates the logfiles under the directory where the application is located. If file/directory permissions prevent file creation in that location, OpenESQL creates the logfiles under the directory referenced in the %TEMP% environment variable.

For information on session IDs, see the topic Multiple User COBOL Applications in .NET.

All trace records contain the elapsed runtime, accurate to one microsecond.

Syntax:

TRACELEVEL={T | 1 | 2 | 3 | 4 | D}

Scope:

Used at compile time: | No
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

  • When TRACELEVEL=T, the following information is written to the trace file:
    • BEGIN - traces main SQL directives
    • END - indicates end of run
    • DIRECTIVES - traces per compilation unit directives the firs ttime acompilation unit is enountered at run time.
  • When TRACELEVEL=1, the following information is written to the trace file in addition to the information written when you speficy TRACELEVEL=T:
    • PREPARE - identifies the original source code when a statement is prepared.
    • DISPOSE - provides summary information for overall statement usage when a statement is removed from the prepared statement cache at disconnect time
    • FLUSH - provides summary information for overall statement usage when a statement is flushed from the cache usually due to a cache overflow
  • When TRACELEVEL=2, the following information is written to the trace file in addition to the information written when you specify TRACELEVEL=1:
    • OPEN
    • EXECUTE - provides the number of rows selected, inserted, or updated
    • EXEC_IMMED EXECUTE - provides the number of rows selected, inserted, or updated
    • ODBCCLOSE - provides summary information for the current cursor use
    • STMT_CHANGED - reports new concurrency and scroll option settings when the ODBC driver uses different settings than those requested by OpenESQL
  • When TRACELEVEL=3, the following information is written to the trace file in addition to the information written when you specify TRACELEVEL=2:
    • ODBCFETCH - provides the number of rows fetched
    • COBOLFETCH - provides the number of rows returned to the COBOL application
  • When TRACELEVEL= 4, the following information is written to the trace file in addition to the information written when you specify TRACELEVEL=3:
    • EXEC_SQL_BEGIN
    • EXEC_SQL_END
  • When TRACELEVEL=D, a reduced version of TRACELEVEL=4 is produced for debugging purposes. It contains only the following information:
    • BEGIN
    • END
    • EXEC_SQL_BEGIN
    • EXEC_SQL_END
    • DIRECTIVES
Parent topic: SQL Compiler Directive Options
Related concepts
Multiple User COBOL Applications in .NET
Related information
Scope - OpenESQL SQL Compiler Directive Options
Multiple User COBOL Applications in .NET


TSTAMPSEP

Specifies a single character as the separator between the date and time parts of timestamp and date/time data.

Syntax

TSTAMPSEP=character

Properties:

Default: None

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Comments:

When using TSTAMPSEP with the HCOSS DIALECT directive, the DIALECT directive setting determines the output format for timestamp and date/time data, and each data format uses a specific separator character. TSTAMPSEP overrides the separator character used by default in each data type.

See Date and Time Data Types for more information.

Parent topic: SQL Compiler Directive Options
Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Scope - HCOSS SQL Compiler Directive Options
Related reference
DATE
DIALECT
Related information
Scope - OpenESQL SQL Compiler Directive Options
Date and Time Data Types
TIME


USECURLIB

Controls use of the ODBC's Cursor Library. The Cursor Library can provide support for scrolling cursors when the underlying driver doesn't, and can also allow "simulated" positioned updates. With USECURLIB=YES, the Cursor Library will always be used. With USERCURLIB=NO, it will never be used. With the default USERCURLIB=IFNEEDED, it will be used if the application tries to do something the driver manager thinks the driver doesn't support. To use a scrolling cursor with the Cursor Library, you must use a STATIC cursor. To do positioned updates using the Cursor Library, you must use OPTCCVAL concurrency.
Note:

A "simulated" positioned update might hit more than one row. We recommend including the primary key in the select for this reason.

Syntax:

USECURLIB={NO | YES | IFNEEDED}
NOUSECURLIB

Properties:

Default: USECURLIB=IFNEEDED

Scope:

Used at compile time: | No
Behavior at run time: | Process

See Scope - OpenESQL SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options
Related information
Scope - OpenESQL SQL Compiler Directive Options


DBMAN Directive Settings

This table shows all of the SQL compiler directive options and the DBMAN preprocessor options with which they are valid.

Other Directives |  | DBMAN=ODBC | DBMAN=ADO
ADOPICXISANSI |  |  | X
ALLOWNULLCHAR |  | X | X
ANSI92ENTRY |  | X | X
AUTOCOMMIT |  | X | X
AUTOFETCH |  | X |
BEHAVIOR |  | X | X
 | DEF_CURSOR | X |
 | IC_FH_ISOLATION | X |
 | PF_RO_CURSOR | X |
 | PF_UPD_CURSOR | X | X (SQL Server only)
 | RO_CURSOR | X |
 | TRANSACTION | X |
 | UPD_CONCURRENCY | X | X
 | UPD_CURSOR | X |
CHECK |  | X | X
CHECKDUPCURSOR |  | X | X
CHECKSINGLETON |  | X | X
CONCAT |  | X |
CONNECTIONPOOL |  | X |
CTRACE |  | X | X
CURSORCASE |  | X |
DATE |  | X | X
DATEDELIM |  | X | X
DB |  | X | X
DECDEL |  | X |
DETECTDATE |  | X |
ESQLVERSION |  | X |
FIPSFLAG |  | X |
GEN-CC2 |  | X |
GEN-INIT-FLAG |  | X | X
GEN-CLASS-VAR |  | X | X
HSFTRACE |  | X |
IGNORE-NESTED |  | X | X
INIT |  | X | X
ISOLATION |  | X |
JIT |  | X | X
MARS |  | X | X
NIST |  | X | X
NOT |  | X | X
ODBCTRACE |  | X |
ODBCV3 |  | X | X
PARAMARRAY |  | X |
PASS |  | X | X
PRE |  | X |
PREFETCH |  | X |
QUALFIX |  | X | X
RESULTARRAY |  | X |
STMTCACHE |  | X | X
TARGETDB |  | X | X
TESTSQLSTATE |  | X |
TIME |  | X | X
TIMEDELIM |  | X | X
THREAD |  | X |
TRACELEVEL |  | X |
TSTAMPSEP |  | X | X
USECURLIB |  | X |
Parent topic: OpenESQL
Related concepts
OpenESQL Configuration Utility
Related reference
SQL Compiler Directive Options
ANSI92ENTRY
AUTOCOMMIT
BEHAVIOR
CHECKDUPCURSOR
CHECKSINGLETON
DBMAN
ESQLVERSION
NIST
PF_UPD_CURSOR
TARGETDB
UPD_CONCURRENCY


SQL/COBOL Data Type Mappings

The following table shows the mappings used by OpenESQL when converting between ODBC SQL and COBOL data types.

ODBC SQL Type | COBOL Picture | Notes
SQL_CHAR(n) | PIC X(n) |
SQL_NCHAR(n) | PIC X(n) or PIC N(n) |
SQL_VARCHAR(n) | PIC X(n) |
SQL_NVARCHAR(n) | PIC X(n) or PIC N(n) |
SQL_LONGVARCHAR | PIC X(max) or SQL TYPE LONG-VARCHAR(max) | max = 65000
SQL_NTEXT | PIC X(max) or PIC N(max) | max = 65000
SQL_DECIMAL(p,s) or SQL_NUMERIC(p,s) | PIC 9(p-s)V9(S) COMP-3 | p = precision (total number of digits). s = scale (number of digits after the decimal point). OpenESQL doesn’t support using unsigned packed decimal host variables.
SQL_SMALLINT | PIC S9(4) COMP-5 |
SQL_INTEGER | PIC S9(9) COMP-5 |
SQL_REAL | COMP-1 |
SQL_FLOAT | COMP-2 |
SQL_DOUBLE | COMP-2 |
SQL_BIT | PIC S9(4) COMP-5 |
SQL_TINYINT | PIC S9(4) COMP-5 |
SQL_BIGINT | PIC S9(18) COMP-3 |
SQL_BINARY(n) | PIC X(n) or SQL TYPE BINARY(n) |
SQL_VARBINARY(n) | PIC X(n) ) or SQL TYPE VARBINARY(n) |
SQL_LONVARBINARY | PIC X(max) or SQL TYPE LONG-VARBINARY(max) | max = 65000
SQL_DATE or SQL_TYPE_DATE | PIC X(10) ) or SQL TYPE DATE | yyyy-mm-dd
SQL_TIME or SQL_TYPE_TIME or SQL_SS_TIME2 | PIC X(8) or SQL TYPE TIME or SQL TYPE TIME-RECORD | hh:mm:ss
SQL_TIMESTAMP or SQL_TYPE_TIMESTAMP | PIC X(29) or SQL TYPE TIMESTAMP or SQL TYPE TIMESTAMP-RECORD | yyyy-mm-ddhh:mm:ss.ffffff
SQL_SS_TIMESTAMPOFFSET | PIC X(34) | yyyy-mm-ddhh:mm:ss.ffffff +/-hh:mm
Parent topic: OpenESQL
Related concepts
COBOL to SQL Data Type Mapping


OpenESQL Messages

  • SQLSTATE Values
  • SQLCODE Values
  • OpenESQL Preprocessor Error Messages
Parent topic: OpenESQL


SQLSTATE Values

OpenESQL statements return SQLSTATE values as defined by the X/Open and SQL Access Group SQL CAE specification (1992). SQLSTATE is a five character field that can be declared independently by an application, but which is also present in SQLCA, if declared. The table below lists SQLSTATE values that can be returned by OpenESQL statements.

The value returned in SQLSTATE consists of a two character class value followed by a three character subclass value. A class value of "01" indicates a warning and is accompanied by a SQLCODE of 1. Class values other than "01", except for the class "IM", indicate an error and are accompanied by a SQLCODE of -10000. The class "IM" is specific to warnings and errors that derive from the implementation of ODBC itself. The subclass value "000" in any class is for implementation defined conditions within the given class. The assignment of class and subclass values is defined by ANSI SQL-92.

Note:

Although successful execution of a function is normally indicated by a SQLCODE of 0, the SQLSTATE 00000 also indicates success.

SQLSTATE | Error
01000 | General warning
01002 | Disconnect error
01004 | Data truncated
01006 | Privilege not revoked
01S00 | Invalid connection string attribute
01S01 | Error in row
01S02 | Option value changed
01S03 | No rows updated or deleted
01S04 | More than one row updated or deleted
01S05 | Cancel treated as SQLFreeStmt with the SQL_CLOSE option
01S06 | Attempt to fetch before the result set returned the first rowset
07001 | Wrong number of parameters
07006 | Restricted data type attribute violation
07S01 | Invalid use of default parameter
08001 | Unable to connect to data source
08002 | Connection in use
08003 | Connection not open
08004 | Data source rejected establishment of connection
08007 | Connection failure during transaction
08S01 | Communication link failure
21S01 | Insert value list does not match column list
21S02 | Degree of derived table does not match column list
22001 | String data right truncation
22002 | Indicator variable required but not supplied
22003 | Numeric value out of range
22005 | Error in assignment
22008 | Datetime field overflow
22012 | Division by zero
22026 | String data, length mismatch
23000 | Integrity constraint violation
24000 | Invalid cursor state
25000 | Invalid transaction state
28000 | Invalid authorization specification
34000 | Invalid cursor name
37000 | Syntax error or access violation
3C000 | Duplicate cursor name
42000 | Syntax error or access violation
70100 | Operation aborted
IM001 | Driver does not support this function
IM002 | Data source name not found and no default driver specified
IM003 | Specified driver could not be loaded
IM004 | Driver's SQLAllocEnv failed
IM005 | Driver's SQLAllocConnect failed
IM006 | Driver's SQLSetConnect-Option failed
IM007 | No data source or driver specified; dialog prohibited
IM008 | Dialog failed
IM009 | Unable to load translation .dll file
IM010 | Data source name too long
IM011 | Driver name too long
IM012 | DRIVER keyword syntax error
IM013 | Trace file error
S0001 | Base table or view already exists
S0002 | Base table not found
S0011 | Index already exists
S0012 | Index not found
S0021 | Column already exists
S0022 | Column not found
S0023 | No default for column
S1000 | General error
S1001 | Memory allocation failure
S1002 | Invalid column number
S1003 | Program type out of range
S1004 | SQL data type out of range
S1008 | Operation canceled
S1009 | Invalid argument value
S1010 | Function sequence error
S1011 | Operation invalid at this time
S1012 | Invalid transaction operation code specified
S1015 | No cursor name available
S1090 | Invalid string or buffer length
S1091 | Descriptor type out of range
S1092 | Option type out of range
S1093 | Invalid parameter number
S1095 | Function type out of range
S1096 | Information type out of range
S1097 | Column type out of range
S1098 | Scope type out of range
S1099 | Nullable type out of range
S1100 | Uniqueness option type out of range
S1101 | Accuracy option type out of range
S1103 | Direction option out of range
S1105 | Invalid parameter type
S1106 | Fetch type out of range
S1107 | Row value out of range
S1108 | Concurrency option out of range
S1109 | Invalid cursor position
S1110 | Invalid driver completion
S1111 | Invalid bookmark value
S1C00 | Driver not capable
S1T00 | Timeout expired
Parent topic: OpenESQL Messages
Related concepts
The SQLSTATE Variable


SQLCODE Values

The possible values for SQLCODE are:

Value | Meaning
0 | The statement ran without error.
1 | The statement ran, but a warning was generated. The values of the SQLWARN flags should be checked to determine the type of error.
100 | Data matching the query was not found or the end of the results set has been reached. No rows were processed.
< 0 (negative) | The statement did not run due to an application, database, system, or network error.

OpenESQL

If you are using OpenESQL, the following error codes are defined for SQLCODE

SQLCODE | Message | Meaning
0 | Mismatch between number of parameter markers and host variables/user sqldas | Only used for special Embedded SQL statements, such as CONNECT.
1 | NULL value returned but no indicator variable supplied |
-1 | Autoconnect failure | SQL(INIT) was used, and automatic CONNECT failed. Programs which use SQL(INIT) need to check SQLCODE immediately on startup.
-10000 | <The first error message returned by the ODBC call SQLError after the OpenESQL run-time module detected an error> or | See your ODBC driver documentation, or other ODBC reference documents for details of ODBC error messages. SQLSTATE will contain a unique code for each ODBC error condition.
 | Unable to retrieve ODBC error | An ODBC error occurred, but no more details are available. This usually indicates a serious run-time condition, such as severe memory shortage.
-19085 | Invalid ODBC catalog query | This is caused by invalid parameters to a QUERY ODBC statement.
-19101 | Statement too long |
-19199 | ESQL Keyword(s) detected in PREPARE/EXECUTE IMMEDIATE statement |
-19313 | Too few host variables |
-19413 | Data overflow occurred during decimal data conversion |
-19501 | No cursor declared |
-19514 | Cursor is not prepared |
-19701 | NULL connection name or Connection name not found | These two errors (-19701 and -19702) occur when a program refers to a connection which does not exist. The most likely cause is attempting to execute an Embedded SQL statement before a CONNECT has executed successfully, or after all connections have been disconnected.
-19702 | Connection name not found or Attempt to close non-existent connection
-19703 | Could not make connection. |
-19707 | Duplicate connection name. |
-19822 | Improperly initialized User SQLDA |
-19957 | Statement text not found or empty |
-20000 | Unimplemented embedded SQL feature | The COBOL compiler may accept some Embedded SQL syntax which is not yet supported by the OpenESQL run-time module. If an attempt is made to execute such a statement, this condition will result.
Parent topic: OpenESQL Messages
Related concepts
The SQLCODE Variable


OpenESQL Preprocessor Error Messages

  • COBES0002 token is badly defined.
    An error exists in the definition of the SQLCA area, SQLCODE field, or SQLSTATE field.
  • COBES0003 Program contains more than one definition of token
    More than one definition exists of one or more of the following fields: SQLCA, SQLCODE, or SQLSTATE.
  • COBES0004 Nested or multi-source programs not allowed.
    You are trying to compile a program that is nested or multi-source. This is not supported.
  • COBES0005 An error occurred when processing the internal dictionary.
    A system error has occurred trying to read the internal dictionary that the preprocessor creates of all host variables used in the program.
  • COBES0006 No DB engine could be found.
    The required OpenESQL system software was not installed.
  • COBES0007 Source file name is invalid.
    A system error has occurred. The source file name passed to the preprocessor is not valid.
  • COBES0010 OESQL rejected an unspecified option.
    OESQL precompiler services returned a -4905 sql error on initialization.
  • COBES0022 The directive SQL(DBMAN=ODBC) is not supported under Personal Edition.
    You are using Studio Enterprise Edition Personal Edition. This Edition does not support ODBC.
  • COBES0023 The SQL(DBMAN) directive option is not supported with native applications.
    You have specified the SQL(DBMAN) compiler directive option to compile a native application. This is not supported.
  • COBES0100 SQL incompatible with MAINFRAME
    The preprocessor has encountered an embedded SQL statement that is not supported when the BEHAVIOR SQL compiler directive option is set to MAINFRAME.
  • COBES0101 Statement is too long.
    The SQL statement passed to the preprocessor is more than 65536 characters long. The preprocessor gets passed a compressed version of the SQL statement rather than the original source, which might have comments included as well as leading and trailing blanks.
  • COBES0102 Statement contains too many host variables.
    The SQL statement contains more than 8000 host and indicator variables.
  • COBES0103 token does not have a suitable definition to be used as a host variable.
    The host variable displayed in error message is not recognized with a data definition suitable for SQL data types.
  • COBES0104 Bad SQL data declaration.
    An unexpected SQL declaration was passed to the preprocessor.
  • COBES0105 Syntax error.
    The SQL statement includes invalid syntax or does not include required information.
  • COBES0106 Filename too long.
    A filename used in the program to specify a copybook or INCLUDE file is more than 260 characters long.
  • COBES0107 File token not found.
    The copybook specified in token was not found.
  • COBES0108 token is not unique and should be qualified.
    The host variable displayed in token is not unique.
  • COBES0109 token is not a data item.
    The host variable displayed in token was not defined or was defined incorrectly.
  • COBES0110 Statement contains more than one SQLDA.
    More than one SQLDA has been used in the SQL statement.
  • COBES0111 token is not a table of null indicator variables.
    The preprocessor expects that the token displayed is either a null indicator or a null indicator table.
  • COBES0112 token should not be defined with an OCCURS clause.
    A host variable is defined as part of an OCCURS clause.
  • COBES0113 token should not be a subordinate to an item defined with an OCCURS clause.
    A host variable is defined as part of an OCCURS clause or as part of a structure that includes an OCCURS clause.
  • COBES0114 Statement only allowed in the Procedure Division.
    An SQL statement such as EXEC SQL SELECT was coded in the Working-Storage Section.
  • COBES0115 Statement not allowed in the Procedure Division.
    A SQL statement such as EXEC SQL DECLARE TABLE was coded in the Procedure Division
  • COBES0116 An error occurred when processing the trace file.
    A file error occurred while trying to write information to the preprocessor trace file.
  • COBES0118 Mismatched DECLARE.
    More than one DECLARE statement was found within an EXEC SQL statement.
  • COBES0119 Host variable name is too long.
    The host variable name is too long. The maximum length of the host variable is 30 characters.
  • COBES0120 Internal error - dictionary handle is too big.
    The preprocessor creates an internal dictionary of all host variables used in a program. When building the dictionary, a system error occurred.
  • ES0121 Compiler directive SQL(token1=token2) is invalid or badly sequenced - all SQL statements ignored.
    The command line used to compile the application or program either contains an invalid value for a valid SQL compiler directive option (represented by token2), or the SQL compiler directive option appears in the wrong place.
  • COBES0123 Invalid ILTARGET - cannot use ILTARGET(ANYCPU) - must specify ILTARGET(X86) or ILTARGET(X64).
    You have specified the ILTARGET(ANYCPU) compiler directive to compile an ODBC application as .NET managed code.
  • COBES0201 BEHAVIOR directive not valid unless TARGETDB directive of DB2, ORACLE, or MSSQLSERVER set first.
    You have set the SQL(BEHAVIOR) compiler directive option, but neglected to also set the SQL(TARGETDB) directive to a value of DB2, ORACLE, or MSSQLSERVER. SQL(BEHAVIOR) is dependent on SQL(TARGETDB).
  • COBES0202 BEHAVIOR directive not set.
    You have neglected to set the SQL(BEHAVIOR) compiler directive option, which is required to compile OpenESQL applications.
  • COBES0203 PREFETCH and BEHAVIOR directives are mutually exclusive - cannot set both.
    You have set both the SQL(PREFETCH) and SQL(BEHAVIOR) compiler directive options to compile an application. These are mutually exclusive.
  • COBES0204 Cannot use PREFETCH directive with TARGETDB=ORACLEOCI directive.
    You have specified the SQL(PREFETCH) compiler directive option and also set the SQL(TARGETDB) compiler directive option to ORACLEOCI. We do not support this combination.
  • COBES0205 Cannot set directive PF_RO_CURSOR > 1 if RO_CURSOR directive is set to IC_FH.
    When compiling an application, you have set the PF_RO_CURSOR primitive directive to a value greater than 1 and also set the RO_CURSOR primitive directive to IC_FH. This combination is not supported.
  • COBES0206 Cannot set directive PF_RO_CURSOR > 1 if RO_CURSOR directive is set to FORWARD and TARGETDB is MSSQLSERVER.
    When compiling an application, you have set the PF_RO_CURSOR primitive directive to a value greater than 1, set the RO_CURSOR primitive directive to FORWARD, and set the TARGETDB SQL compiler directive option to MSSQLSERVER. This combination is not supported.
  • COBES0207 Cannot set directive PF_UPD_CURSOR > 1 if UPD_CURSOR directive is set to FORWARD.
    When compiling an application, you have set the PF_UPD_CURSOR primitive directive to a value greater than 1 and also set the UPD_CURSOR primitive directive to FORWARD. This combination is not supported.
  • COBES0208 Cannot set UPD_CURSOR directive to DYNAMIC if TARGETDB directive is set to ORACLE.
    When compiling an application, you have set the UPD_CURSOR primitive directive to DYNAMIC, and also set the TARGETDB SQL compiler directive option to ORACLE. This combination is not supported.
  • COBES0209 Cannot set UPD_CURSOR directive to STATIC if TARGETDB directive is set to MSSQLSERVER.
    When compiling an application, you have set the UPD_CURSOR primitive directive to STATIC, and also set the TARGETDB SQL compiler directive option to MSSQLSERVER. This combination is not supported.
  • COBES0211 DBRMLIB name is too long, max 44 characters.
    The value specified for the DBRMLIB HCOSS compiler directive option exceeds the maximum length of 44.
  • COBES0212 Simple name in DBRMLIB name is too long, max 8 characters.
    The value specified for the DBRMLIB HCOSS compiler directive option includes a simple name that exceeds the maximum length of eight.
  • COBES0213 Simple name in DBRMLIB name starts with invalid character.
    The value specified for the DBRMLIB HCOSS compiler directive option includes a simple name that begins with an illegal character.
  • COBES0214 Invalid character in DBRMLIB name.
    The value specified for the DBRMLIB HCOSS compiler directive option includes an illegal character.
  • COBES0215 MEMBER name is too long, max 8 characters.
    The value specified for the MEMBER HCOSS compiler directive option exceeds the maximum length of eight.
  • COBES0216 MEMBER name cannot begin with a numeric digit.
    The value specified for the MEMBER HCOSS compiler directive option begins with a numeric digit, which is not legal.
  • COBES0217 Invalid character in MEMBER name.
    The value specified for the MEMBER HCOSS compiler directive option contains an illegal character.
  • COBES0218 MEMBER directive not valid unless DBRMLIB directive set.
    You have set the MEMBER HCOSS compiler directive but neglected to also set the DBRMLIB HCOSS compiler directive. MEMBER is dependent on DBRMLIB.
  • COBES0219 VERSION directive not valid unless DBRMLIB directive set.
    When compiling an application, you have set the VERSION HCOSS directive without also explicitly setting the DBRMLIB HCOSS directive. The VERSION directive is dependent on the DBRMLIB directive.
  • COBES0220 VERSION is too long, max 64 characters.
    The value specified for the VERSION HCOSS compiler directive has exceeded its maximum allowable length of 64 characters.
  • COBES0221 Invalid character in VERSION.
    The value specified for the VERSION HCOSS compiler directive contains an invalid character.
  • COBES0222 Invalid Framework target - SQL applications must be built to target the 4.0 .NET Framework.
    When compiling an SQL application, you have specified the ILCLR compiler directive value as 2. SQL applications require that the SQL(ILCLR) compiler directive option be set to 4 to target .NET Framework version 4.0.
  • COBES0223 TARGETDB directive not set.
    When compiling an SQL application, you have either neglected to set the SQL(TARGETDB) compiler directive option, or you have set it after the BEHAVIOR, ACCESS, BIND, or MARS compiler directive options.
  • COBES0900 An internal error occurred.
    An unexpected error occurred in the preprocessor.
  • COBES0901 This error prevents SQL processing from continuing - further EXEC SQL statements will be ignored.
    A severe SQL error has occurred. Additional EXEC SQL statements will not be processed by the preprocessor.
  • COBES1000W Use of EXEC SQL INCLUDE SQLCA END-EXEC
    FIPS certification (reference X/OPEN CAE SQL 8.1.1) requires that this warning be generated.
  • COBES1002 Statement is not in area B.
    An EXEC SQL statement starts before column 12.
  • COBES1004 token directive is not supported and has been ignored.
    The compiler directive token is not supported when compiling SQL applications.
Parent topic: OpenESQL Messages


COBES0002 token is badly defined.

An error exists in the definition of the SQLCA area, SQLCODE field, or SQLSTATE field.

One of the following occurred:

  • The SQLCA area is defined with total length less than 136 characters.
  • The SQLCODE field is not defined as a S9(8) COMP-5 field.
  • The SQLSTATE field is not defined as a character field of length 5.
  • One of the previous fields is defined incorrectly.

Resolution:

Correct the definition or use the SQLCA copybook provided. If the problem persists, report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Creating Debug Files


COBES0003 Program contains more than one definition of token

More than one definition exists of one or more of the following fields: SQLCA, SQLCODE, or SQLSTATE.

Resolution:

Remove the duplicate definitions and recompile the program.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0004 Nested or multi-source programs not allowed.

You are trying to compile a program that is nested or multi-source. This is not supported.

Resolution:

Move the subroutines to a separate program.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0005 An error occurred when processing the internal dictionary.

A system error has occurred trying to read the internal dictionary that the preprocessor creates of all host variables used in the program.

Resolution:

Report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Creating Debug Files


COBES0006 No DB engine could be found.

The required OpenESQL system software was not installed.

Resolution:

Install the required OpenESQL software.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0007 Source file name is invalid.

A system error has occurred. The source file name passed to the preprocessor is not valid.

Resolution:

Report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Creating Debug Files


COBES0010 OESQL rejected an unspecified option.

OESQL precompiler services returned a -4905 sql error on initialization.

Resolution:

Check to make sure your ODBC drivers are installed properly and that all required system files are available via the PATH environment variable. If the problem persists, report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Creating Debug Files


COBES0022 The directive SQL(DBMAN=ODBC) is not supported under Personal Edition.

You are using Studio Enterprise Edition Personal Edition. This Edition does not support ODBC.

Resolution:

Either upgrade to Studio Enterprise Edition Team Edition, or remove the SQL(DBMAN=ODBC) directive; then recompile the application.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0023 The SQL(DBMAN) directive option is not supported with native applications.

You have specified the SQL(DBMAN) compiler directive option to compile a native application. This is not supported.

Resolution:

Recompile the application without the SQL(DBMAN) directive.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0100 SQL incompatible with MAINFRAME

The preprocessor has encountered an embedded SQL statement that is not supported when the BEHAVIOR SQL compiler directive option is set to MAINFRAME.

Resolution:

Correct the EXEC SQL statement; then recompile the program.

Parent topic: OpenESQL Preprocessor Error Messages
Related reference
BEHAVIOR


COBES0101 Statement is too long.

The SQL statement passed to the preprocessor is more than 65536 characters long. The preprocessor gets passed a compressed version of the SQL statement rather than the original source, which might have comments included as well as leading and trailing blanks.

Resolution:

Look at breaking the SQL statement into multiple SQL statements and then try recompiling the program.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0102 Statement contains too many host variables.

The SQL statement contains more than 8000 host and indicator variables.

Resolution:

Look at breaking the SQL statement into multiple SQL statements and then try recompiling the program.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0103 token does not have a suitable definition to be used as a host variable.

The host variable displayed in error message is not recognized with a data definition suitable for SQL data types.

Resolution:

Review the SQL Data Types documentation to determine valid data definitions for host variables.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
SQL Data Types


COBES0104 Bad SQL data declaration.

An unexpected SQL declaration was passed to the preprocessor.

Generally this error occurs only when the host variable is defined as:

 host-variable-name SQL TYPE IS ....

and the preprocessor has not been set up to handle that definition.

Resolution:

Report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Creating Debug Files


COBES0105 Syntax error.

The SQL statement includes invalid syntax or does not include required information.

For example, this error would be generated if you only coded:

EXEC SQL INCLUDE END-EXEC

and did not specify the name of the copybook file to INCLUDE.

Resolution:

Correct the SQL statement and recompile the program.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0106 Filename too long.

A filename used in the program to specify a copybook or INCLUDE file is more than 260 characters long.

Resolution:

Correct the filename and recompile the program

Parent topic: OpenESQL Preprocessor Error Messages


COBES0107 File token not found.

The copybook specified in token was not found.

Resolution:

The preprocessor looks first in the current directory, and then down the paths specified by environment variable COBCPY. Either correct the filename or set the environment variable COBCPY to include the full path to your copybook. You should also check your COPYEXT setting in case your copybook files have a file extension other than .cbl or .cpy.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0108 token is not unique and should be qualified.

The host variable displayed in token is not unique.

Resolution:

You must fully qualify a host variable in a SQL query if the variable name is not unique. For example if ORD-NO exists in both the ORDERS and ITEMS copybooks, you would need to specify the following if you wanted the host variable from the ORDERS copybook to be used in the query:

:ORDERS.ORD-NO
Parent topic: OpenESQL Preprocessor Error Messages


COBES0109 token is not a data item.

The host variable displayed in token was not defined or was defined incorrectly.

Resolution:

Verify that the host variable exists. If it does not, make the required changes to correct the error. Variables defined in COBOL copybooks are also valid for host variables, unlike mainframe DB2.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0110 Statement contains more than one SQLDA.

More than one SQLDA has been used in the SQL statement.

Resolution:

The preprocessor has a limit of only one SQLDA definition per program. If the problem persists, report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Creating Debug Files


COBES0111 token is not a table of null indicator variables.

The preprocessor expects that the token displayed is either a null indicator or a null indicator table.

Resolution:

Correct the SQL statement and recompile the program. If you are using a null indicator table, make sure you do not use the group name. For example if the following is a definition of a null indicator table:

 01 staff-null-tbl.
     03 staff-null-ind occurs 7 times pic s9(04) comp.

you would specify staff-null-ind rather than staff-null-tbl in your query.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0112 token should not be defined with an OCCURS clause.

A host variable is defined as part of an OCCURS clause.

Resolution:

The preprocessor does not allow host variables to be defined this way. Edit your program to remove the OCCURS clause and then recompile.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Host Variables


COBES0113 token should not be a subordinate to an item defined with an OCCURS clause.

A host variable is defined as part of an OCCURS clause or as part of a structure that includes an OCCURS clause.

Resolution:

The preprocessor does not allow host variables to be defined this way.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Host Variables


COBES0114 Statement only allowed in the Procedure Division.

An SQL statement such as EXEC SQL SELECT was coded in the Working-Storage Section.

Resolution:

This statement is not supported when coded in the Working-Storage Section. Move the statement to the Procedure Division and then recompile the program.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0115 Statement not allowed in the Procedure Division.

A SQL statement such as EXEC SQL DECLARE TABLE was coded in the Procedure Division

Resolution:

This statement is not supported when coded in the Procedure Division. Move it into Working-Storage Section and then recompile the program.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0116 An error occurred when processing the trace file.

A file error occurred while trying to write information to the preprocessor trace file.

Resolution:

Be sure you have WRITE permission on the drive and directory where the trace file is written, and be sure you have enough space left on the drive to save the file.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Creating Debug Files


COBES0118 Mismatched DECLARE.

More than one DECLARE statement was found within an EXEC SQL statement.

Resolution:

Correct the statement and then recompile the program.

Parent topic: OpenESQL Preprocessor Error Messages
Related reference
DECLARE CURSOR
DECLARE DATABASE


COBES0119 Host variable name is too long.

The host variable name is too long. The maximum length of the host variable is 30 characters.

Resolution:

Make sure the host variable is a valid COBOL name. It should be 30 characters or less in length.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Host Variables


COBES0120 Internal error - dictionary handle is too big.

The preprocessor creates an internal dictionary of all host variables used in a program. When building the dictionary, a system error occurred.

Resolution:

Report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

We also suggest that you be prepared to provide your SupportLine representative with enough information (e.g., program source, etc.) to recreate the error.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Creating Debug Files


ES0121 Compiler directive SQL(token1=token2) is invalid or badly sequenced - all SQL statements ignored.

The command line used to compile the application or program either contains an invalid value for a valid SQL compiler directive option (represented by token2), or the SQL compiler directive option appears in the wrong place.

For example, you must specify TARGETDB on the command line before specifying BEHAVIOR.

Resolution:

Correct the command line and recompile.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0123 Invalid ILTARGET - cannot use ILTARGET(ANYCPU) - must specify ILTARGET(X86) or ILTARGET(X64).

You have specified the ILTARGET(ANYCPU) compiler directive to compile an ODBC application as .NET managed code.

Resolution:

Recompile the application specifying either ILTARGET(X86) or ILTARGET(X64).

Parent topic: OpenESQL Preprocessor Error Messages
Related reference
ILTARGET


COBES0201 BEHAVIOR directive not valid unless TARGETDB directive of DB2, ORACLE, or MSSQLSERVER set first.

You have set the SQL(BEHAVIOR) compiler directive option, but neglected to also set the SQL(TARGETDB) directive to a value of DB2, ORACLE, or MSSQLSERVER. SQL(BEHAVIOR) is dependent on SQL(TARGETDB).

Resolution:

Set the SQL(TARGETDB) compiler directive option to DB2, ORACLE, or MSSQLSERVER in addition to specifying the SQL(BEHAVIOR) directive option; then recompile the application.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0202 BEHAVIOR directive not set.

You have neglected to set the SQL(BEHAVIOR) compiler directive option, which is required to compile OpenESQL applications.

Resolution:

Recompile the application using the SQL(BEHAVIOR) and SQL(TARGETDB) compiler directive options.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0203 PREFETCH and BEHAVIOR directives are mutually exclusive - cannot set both.

You have set both the SQL(PREFETCH) and SQL(BEHAVIOR) compiler directive options to compile an application. These are mutually exclusive.

Resolution:

Recompile your application specifying either the SQL(BEHAVIOR) or SQL(PREFETCH) compiler directive option, but not both.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0204 Cannot use PREFETCH directive with TARGETDB=ORACLEOCI directive.

You have specified the SQL(PREFETCH) compiler directive option and also set the SQL(TARGETDB) compiler directive option to ORACLEOCI. We do not support this combination.

Resolution:

Recompile your application either omitting the TARGETDB SQL compiler directive option, or set the TARGETDB SQL compiler directive option to DB2, ORACLE, or MSSQLSERVER.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0205 Cannot set directive PF_RO_CURSOR > 1 if RO_CURSOR directive is set to IC_FH.

When compiling an application, you have set the PF_RO_CURSOR primitive directive to a value greater than 1 and also set the RO_CURSOR primitive directive to IC_FH. This combination is not supported.

Resolution:

Recompile your application using a supported combination of primitive directives and values. See the topic Primitive Directives for more information.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0206 Cannot set directive PF_RO_CURSOR > 1 if RO_CURSOR directive is set to FORWARD and TARGETDB is MSSQLSERVER.

When compiling an application, you have set the PF_RO_CURSOR primitive directive to a value greater than 1, set the RO_CURSOR primitive directive to FORWARD, and set the TARGETDB SQL compiler directive option to MSSQLSERVER. This combination is not supported.

Resolution:

Recompile your application using a supported combination of primitive directives and values, and SQL(TARGETDB) compiler directive option value. See the topics Primitive Directives and TARGETDB for more information.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0207 Cannot set directive PF_UPD_CURSOR > 1 if UPD_CURSOR directive is set to FORWARD.

When compiling an application, you have set the PF_UPD_CURSOR primitive directive to a value greater than 1 and also set the UPD_CURSOR primitive directive to FORWARD. This combination is not supported.

Resolution:

Recompile your application using a supported combination of primitive directives and values. See the topic Primitive Directives for more information.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0208 Cannot set UPD_CURSOR directive to DYNAMIC if TARGETDB directive is set to ORACLE.

When compiling an application, you have set the UPD_CURSOR primitive directive to DYNAMIC, and also set the TARGETDB SQL compiler directive option to ORACLE. This combination is not supported.

Resolution:

Recompile your application, specifying a supported combination of primitive directives and SQL compiler directive options. See the topics Primitive Directives and TARGETDB for more information.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0209 Cannot set UPD_CURSOR directive to STATIC if TARGETDB directive is set to MSSQLSERVER.

When compiling an application, you have set the UPD_CURSOR primitive directive to STATIC, and also set the TARGETDB SQL compiler directive option to MSSQLSERVER. This combination is not supported.

Resolution:

Recompile your application, specifying a supported combination of primitive directives and SQL compiler directive options. See the topics Primitive Directives and TARGETDB for more information.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0211 DBRMLIB name is too long, max 44 characters.

The value specified for the DBRMLIB HCOSS compiler directive option exceeds the maximum length of 44.

Resolution:

Recompile the application, specifying a DBRMLIB value that conforms to the syntax specifications for Partitioned Dataset Names, including a length of 44 characters or fewer.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0212 Simple name in DBRMLIB name is too long, max 8 characters.

The value specified for the DBRMLIB HCOSS compiler directive option includes a simple name that exceeds the maximum length of eight.

Resolution:

Recompile the application, specifying a DBRMLIB value that conforms to the syntax specifications for Partitioned Dataset Names, including a length of eight characters or fewer for each simple name.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0213 Simple name in DBRMLIB name starts with invalid character.

The value specified for the DBRMLIB HCOSS compiler directive option includes a simple name that begins with an illegal character.

Resolution:

Recompile the application, specifying a DBRMLIB value that conforms to the syntax specifications for Partitioned Dataset Names, including an alphabetic character at the beginning of each simple name.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0214 Invalid character in DBRMLIB name.

The value specified for the DBRMLIB HCOSS compiler directive option includes an illegal character.

Resolution:

Recompile the application, specifying a DBRMLIB value that conforms to the syntax specifications for Partitioned Dataset Names.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0215 MEMBER name is too long, max 8 characters.

The value specified for the MEMBER HCOSS compiler directive option exceeds the maximum length of eight.

Resolution:

If you have not specified the MEMBER compiler directive option, then HCOSS uses the program name by default. In this case, reduce the length of your program name to eight characters or fewer, and recompile the program.

If you have specified the MEMBER compiler directive option, then recompile the program specifying a member name that conforms to the syntax for mainframe Partitioned Data Set names, including eight characters or fewer.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0216 MEMBER name cannot begin with a numeric digit.

The value specified for the MEMBER HCOSS compiler directive option begins with a numeric digit, which is not legal.

Resolution:

If you have not specified the MEMBER compiler directive option, then HCOSS uses the program name by default. In this case, change the name of your program name such that it starts with an alphabetic character, and recompile the program.

If you have specified the MEMBER compiler directive option, then recompile the program specifying a member name that begins with an alphabetic character.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0217 Invalid character in MEMBER name.

The value specified for the MEMBER HCOSS compiler directive option contains an illegal character.

Resolution:

If you have not specified the MEMBER compiler directive option, then HCOSS uses the program name by default. In this case, change the name of your program name such that it conforms to the syntax for mainframe Partitioned Data Set names, and recompile the program.

If you have specified the MEMBER compiler directive option, then recompile the program specifying a member name that conforms to the syntax for mainframe Partitioned Data Set names.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0218 MEMBER directive not valid unless DBRMLIB directive set.

You have set the MEMBER HCOSS compiler directive but neglected to also set the DBRMLIB HCOSS compiler directive. MEMBER is dependent on DBRMLIB.

Resolution:

Recompile the program, specifying both the MEMBER and the DBRMLIB HCOSS compiler directives.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0219 VERSION directive not valid unless DBRMLIB directive set.

When compiling an application, you have set the VERSION HCOSS directive without also explicitly setting the DBRMLIB HCOSS directive. The VERSION directive is dependent on the DBRMLIB directive.

Resolution:

Recompile the application, specifying both the VERSION and the DBRMLIB compiler directives.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0220 VERSION is too long, max 64 characters.

The value specified for the VERSION HCOSS compiler directive has exceeded its maximum allowable length of 64 characters.

Resolution:

Recompile the application, specifying a VERSION value of 64 or fewer letters, digits, or underscore characters (_).

Parent topic: OpenESQL Preprocessor Error Messages


COBES0221 Invalid character in VERSION.

The value specified for the VERSION HCOSS compiler directive contains an invalid character.

Resolution:

Recompile the application, specifying a VERSION value containing only letters, digits, or underscore characters (_)

Parent topic: OpenESQL Preprocessor Error Messages


COBES0222 Invalid Framework target - SQL applications must be built to target the 4.0 .NET Framework.

When compiling an SQL application, you have specified the ILCLR compiler directive value as 2. SQL applications require that the SQL(ILCLR) compiler directive option be set to 4 to target .NET Framework version 4.0.

Resolution:

Recompile the application, setting the ILCLR directive to 4.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0223 TARGETDB directive not set.

When compiling an SQL application, you have either neglected to set the SQL(TARGETDB) compiler directive option, or you have set it after the BEHAVIOR, ACCESS, BIND, or MARS compiler directive options.

Resolution:

Recompile the application, specifying the TARGETDB SQL compiler directive option before the BEHAVIOR, ACCESS, BIND, or MARS compiler directive options.

Parent topic: OpenESQL Preprocessor Error Messages


COBES0900 An internal error occurred.

An unexpected error occurred in the preprocessor.

Resolution:

Create a trace file using the CHKECM(TRACE) compiler directive, and contact SupportLine. See Creating Debug Files for additional details on how to create a trace file.

Parent topic: OpenESQL Preprocessor Error Messages
Related concepts
Creating Debug Files


COBES0901 This error prevents SQL processing from continuing - further EXEC SQL statements will be ignored.

A severe SQL error has occurred. Additional EXEC SQL statements will not be processed by the preprocessor.

Resolution:

Correct the severe error and then recompile the program.

Parent topic: OpenESQL Preprocessor Error Messages


COBES1000W Use of EXEC SQL INCLUDE SQLCA END-EXEC

FIPS certification (reference X/OPEN CAE SQL 8.1.1) requires that this warning be generated.

FIPS certification (reference X/OPEN CAE SQL 8.1.1) requires that a warning is generated if this syntax is supported:

   EXEC SQL
      INCLUDE SQLCA
   END-EXEC

Resolution:

No action is required.

Parent topic: OpenESQL Preprocessor Error Messages


COBES1002 Statement is not in area B.

An EXEC SQL statement starts before column 12.

Resolution:

Move the EXEC SQL statement so that it starts after column 12.

Parent topic: OpenESQL Preprocessor Error Messages


COBES1004 token directive is not supported and has been ignored.

The compiler directive token is not supported when compiling SQL applications.

Resolution:

Recompile the application, omitting the offending compiler directive.

Parent topic: OpenESQL Preprocessor Error Messages


MFImportConn command

Important: You must run this command from a 32-bit or a 64-bit Net Express command prompt, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x.

Syntax

MFImportConnpath:\exportedXMLfile {System | User} {32BIT | 64BIT}

Parameters

path | The full path to the XML file containing the exported connection settings
exportedXMLfile | The filename of the XML file containing the exported connection settings
System | Specify this to import the connection settings into the machine.config file for use by all users
User | Specify this to import the connection settings into the UserConnections32.config or UserConnections64.config file for use by the current user only
32BIT | Specify this for 32-bit connections
64BIT | Specify this for 64-bit connections
Parent topic: OpenESQL
Related concepts
Copying Connection Settings
Related tasks
To export connection settings from the ADO.NET Connection Editor
To import connections into the ADO.NET Connection Editor


User Interface Reference

  • OpenESQL Assistant
  • Manage Connections
  • Extract Schema
  • Assess Data Migration
  • Define Lists
  • Generate DDL
  • Transfer Data
  • Compare Data
  • Assess Application Migration
  • Manage Packages and Plans
  • Customize Type Mappings - Data Mappings tab
  • Customize SQL Name Mappings - SQL Name tab
  • Options
  • Bind Utility
  • The Declaration Generator Window
  • Link Utility
  • Migrate Utility
  • Options Utility
  • SQL Wizard
Parent topic: OpenESQL
Parent topic: Reference
Parent topic: Reference


OpenESQL Assistant

  • OpenESQL Assistant - Options
  • OpenESQL Assistant - Main Window
  • Select Type of Query to Create dialog box
  • Query tab
  • Results tab
  • Details tab
  • Search Criteria tab
  • Literal Value dialog box
  • Sort tab
  • Auxiliary Code tab
  • Data Source Properties dialog box
Parent topic: User Interface Reference


OpenESQL Assistant - Options

DCLGEN

Use level 49
By default, OpenESQL Assistant generates a host variable as a PIC X(n) field for VARCHAR columns. When data is mapped to the host variable, it is null terminated. However, you can set OpenESQL Assistant to generate the host variable with two level-49 variables; one for the length of the data mapped and one for the actual text data.
Type COBOL Variable
By default, OpenESQL Assistant generates COBOL host variables using COBOL definitions where appropriate. You can set this option to SQL TYPE to enable the SQL precompiler to better determine host variable usage, or set it to OBJECT to provide better performance for .NET applications.
Structure name
By default, OpenESQL Assistant generates the structure name for the copybook as DCLtablename. You can also generate the structure name using just the table name or you can supply your own structure name as long as it is a valid COBOL name. OpenESQL Assistant converts all underscores into hyphens. When you set this option to Other, specify your own structure in the User Defined Structure Name field.
User Defined Structure Name
Specify an 01-level COBOL structure name to use when generating the copybook. Required when Structure Name is set to Other.
Host Variable Prefix
By default, OpenESQL Assistant creates host variables using a combination of the column name and a prefix of the table name, converting all underscores to hyphens to create a valid COBOL name. You can also set OpenESQL Assistant to always generate host variables using only the column name (no prefix) or to use an alphabetic character prefix. Host variables generated with alphabetic character prefixes use "A" for the first table selected, "B" for the second table, etc.
Note: If a generated host variable name would result in a name that is either longer than 31 characters in length or that would contain invalid characters, OpenESQL Assistant generates the host variable name as the column number with a prefix of FLD regardless of the method specified.
Indicator Variables
By default, OpenESQL Assistant generates indicator variables at the end of a copybook. You can also set OpenESQL Assistant to generate indicator variables after each host variable instead. Your third option is to set OpenESQL Assistant so that no indicator variables are generated.

General

Mode
  • ADO.NET - builds the list of data sources using the information maintained by the Connection Editor (32-bit version). Default.
  • ODBC - builds the list of data sources maintained by the ODBC Data Source Administrator (32-bit version).

    Set this option before connecting to a data source. When in ADO.NET mode, you can also set the following:

    Note:

    If you are running Visual Studio 2008 under Windows Vista, Windows 7, or Windows Server 2008 and you use the ADO.NET Connection Editor from within OpenESQL Assistant to add, update, or delete connection information, you must run OpenESQL Assistant as an Administrator.

Start OpenESQL Assistant docked
By default, OpenESQL Assistant is not docked to Visual Studio. Set this option to True if you want OpenESQL Assistant to start docked to Visual Studio.
Prompt on disconnect
By default, OpenESQL Assistant does not prompt you when disconnecting from a data source. If you want to be prompted to save a query you have built before disconnecting, set this option to True. Otherwise, you could lose the query.
Automatically catalog data source
OpenESQL under .NET supports both EXEC SQL and EXEC ADO access to managed data sources. There currently exists no common repository for sharing connection information between ADO.NET data providers. However, we provide a common repository that all COBOL applications can use to save connection information. This also allows OpenESQL to be source code compatible when using EXEC SQL CONNECT statements. If you check this option, OpenESQL Assistant automatically transfers the ODBC connection information into the repository when you CONNECT to a data source.

OpenESQL Assistant also includes an ADO.NET Connection Editor which allows you to manually add connection information.

Once you have cataloged all your data sources in the repository you can uncheck this option.

List items in table name sequence
By default, OpenESQL Assistant lists items in the tree view in the sequence that they are returned from the system catalog. You can also set OpenESQL Assistant to list items in table name sequence instead. When you set OpenESQL Assistant to list items in table name sequence, owner names are not considered.
Generate code
By default, OpenESQL Assistant generates SQL queries and copybooks using a combination of upper and lower case. You can also set OpenESQL Assistant to generate in all uppercase or all lowercase.

Logon

User name
The user name used to connect to your data source. If you choose not to specify a user name, OpenESQL Assistant prompts you when connecting to a data source.
Password
The password associated with the user ID in the User name field. Depending on how you define your connection names, you might have the option of saving your login user name and password via the ADO.NET Connection Editor.

Query

Qualify table with owner name
By default, OpenESQL Assistant displays all tables in the tree view and builds all queries unqualified. However, if the data source has multiple tables with the same table name, you can set OpenESQL Assistant to show table names in the tree view with their owner names immediately following in parenthesis. Queries performed also return table names qualified with the owner name.
Quote table and column names
By default, OpenESQL Assistant does not enclose column and table names with the quote identifier associated with the data source unless the column or table name contains embedded blanks, a special character such as $, or DBCS characters. You can set OpenESQL Assistant to enclose all table and column names with the appropriate quote identifier by setting this option to True.
Use SQLSTATE
By default, OpenESQL Assistant generates SQL statements using SQLCODE checking. You change this to set OpenESQL Assistant to generate SQL statements using SQLSTATE checking instead.
Generate Interface Code
By default, OpenESQL Assistant generates SQL statements for use by any application. You can also set OpenESQL to generate SQL statements that can be used as a Web service.
Maximum Result Rows
By default, OpenESQL Assistant only returns the first 50 rows when you run a query. This is to prevent queries from returning huge numbers of rows, potentially crashing your machine or overloading your network. However, you can set the maximum number of rows returned to a number of your choice. Set this value to -1 if you want all rows returned. We recommend that you choose the number based on the amount of data you expect to be returned, or based on your testing needs.
Generate
Select one of three statement types:
  • EXEC SQL
  • EXEC ADO - disconnected model
  • EXEC ADO - connected model

By default, OpenESQL Assistant generates EXEC SQL statements. However, you can change it to build EXEC ADO statements if you have set Mode to ADO.NET and want to build EXEC ADO queries. You can then also generate EXEC ADO Disconnected or Connected statements as auxiliary code.

Restrict Tables

The following applies to Qualifier, Owner, and Table name when using ADO.NET mode:
  • Wildcard characters are not supported.
  • The qualifier, owner, and table name are case sensitive for some data providers and not for others. You might need to experiment when setting these restrictions.
Parent topic: OpenESQL Assistant
Related concepts
Setting OpenESQL Assistant Options
Related tasks
To set OpenESQL Assistant options
To add an XML data source
To generate a DCLGEN copybook
To generate a DECLARE DATATABLE statement
To generate and embed auxiliary code
To create a TSQL stored procedure query


OpenESQL Assistant - Main Window

Data Source List
A list of all catalogued data sources available for use with OpenESQL Assistant.
Create New Query Create New Query
Create a new SQL query for the data source.
Run Query Run Query
Run the query shown on the Query tab.
Insert query into program Insert query into program
Insert the query shown on the Query tab into the current program at the cursor location, or insert auxiliary code shown on the Auxiliary Code tab into the current program at the cursor location.
Refresh list of data sources Refresh list of data sources
Reload the list of data sources on the data source list, including updates to any data sources that have been added or deleted since the last time the list was loaded.
ADO.NET Connection Editor ADO.NET Connection Editor
Launch the ADO.NET Connection Editor
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Setting OpenESQL Assistant Options
Related tasks
To set OpenESQL Assistant options
To connect to a data source
To connect to a different data source
To disconnect from a data source
To start the ADO.NET Connection Editor
To add an XML data source
To close a query
To run a query


Select Type of Query to Create dialog box

Query Type List
A list of all query types available.
Cursor Name
The name of the cursor generated for the query. A default name is supplied; however, you can override this by typing in a name of your choice. Available when the Generate OpenESQL Assistant Option is set to EXEC SQL.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Building Queries
Setting OpenESQL Assistant Options
Stored Procedures
Related tasks
To set OpenESQL Assistant options
To create a TSQL stored procedure query
To create an SQL query


Query tab

Shows the query code generated by OpenESQL Assistant, based on the selections made.

Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Building Queries
Related tasks
To embed an SQL query into a COBOL program


Results tab

Column n
Shows the data returned for the column specified in the query.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Building Queries
Testing Your SQL Queries


Details tab

Shows column information for the selected table. A checked box next to a column name indicates that the column is included in the current query.

Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Building Queries
Display Column Details


Search Criteria tab

Column
A list of columns available for this query.
Conditional Operator
A list of operators available for building search criteria.
Target Type
A list of available target types for the search criteria, including Host Variable, Literal, Special Register, and Column Name.
Target Value
A list of values available for the Target Type selected.
Edit
Invokes the Literal Value dialog box, enabling you to supply a literal value required for the search criteria. The value supplied populates the Target Value field. Available when Target Type is set to Literal.
AND
Insert the AND operator into the search criteria.
OR
Insert the OR operator into the search criteria.
Insert Search String Insert Search String
Move the defined search string to the Generated Search Criteria.
Remove Search String Remove Search String
Remove the selected search string from the Generated Search Criteria.
Generated Search Criteria
List of search strings included in the search criteria.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Specifying Search Criteria
Building Queries
Related tasks
To specify search criteria (a WHERE clause)


Literal Value dialog box

Column Name
Shows the name of the column selected for the search string.
Column Type
Shows the data type of the column selected for the search string.
Precision
The maximum number of digits allowed in column data.
Scale
The maximum number of digits allowed to the right of a decimal point in column data.
Column Value
The literal value assigned to the column used in the search string.
Generated Delimiters
Delimiters automatically generated for the literal value specified in the Column Value field.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Building Queries
Related tasks
To specify search criteria (a WHERE clause)


Sort tab

Columns in SELECT
A list of columns available for inclusion in the SELECT statement.
Asc
Sort alphabetically by first letter of the column name in ascending order.
Desc
Sort alphabetically by first letter of the column name in descending order.
Insert Search String Insert Sort String
Move the defined sort string to the Columns in ORDER BY list.
Remove Search String Remove Sort String
Remove the selected sort string from the Columns in ORDER BY list.
Columns in ORDER BY
Sort strings inserted into your query.
Use integers for column names
Generate the integer value of the column instead of the column name.
Note: Column names are displayed on the Columns in ORDER BY list regardless of the setting for Use integers for column names.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Related tasks
To sort returned data (an ORDER BY clause)


Auxiliary Code tab

EXEC SQL
Generate an EXEC SQL statement based on the statement type selected in the Statement Type field.
EXEC ADO Disconnected
Generate an EXEC ADO statement based on the statement type selected in the Statement Type field. Available when the Mode OpenESQL Assistant Option is set to ADO.NET and the Generate option is set to either EXEC ADO - disconnected model or EXEC ADO - connected model.
EXEC ADO Connected
Generate an EXEC ADO statement based on the statement type selected in the Statement Type field. Available when the Mode OpenESQL Assistant Option is set to ADO.NET and the Generate option is set to either EXEC ADO - disconnected model or EXEC ADO - connected model.
Statement Type
Lists EXEC SQL or EXEC ADO statement types available for auxiliary code generation.
Host Variable Array Size
The number that represents the maximum number of rows you want returned for each array FETCH.
Dataset Name
Type a dataset name to specify the dataset in an EXEC ADO statement. Available for either EXEC ADO Disconnected or EXEC ADO Connected statements.
Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Auxiliary Code
Related tasks
To generate and embed auxiliary code


Data Source Properties dialog box

Lists and describes the properties of the selected data source.

Parent topic: OpenESQL Assistant
Related concepts
OpenESQL Assistant
Related tasks
To view data source properties


DB2

  • DB2 Compiler Directive Options
  • DB2 ECM Error Messages
Parent topic: Reference


DB2 Compiler Directive Options

  • ACCESS
    Specifies the name of the package to be created and stored in the database. If ACCESS is specified without a parameter, the package name defaults to the program name (without the .CBL extension).
  • ACTION
    Indicates whether the package can be added or replaced.
  • APREUSE
    Specifies whether or not to reuse static SQL access plans.
  • BIND
    Specifies the name of the bind file to be created. When BIND is specified without a parameter, the bind file defaults to the program name with the filename extension replaced by .BND, and is created in the current source directory.
  • BLOCK
    Specifies the record blocking mode to be used on package creation. For information about row blocking, see the IBM DB2 Administration Guide or the Application Programming Guide.
  • CALL_RESOLUTION
    Specifies how a CALL statement will be resolved.
  • CASE
    Specifies the case of the package name.
  • CCSIDG
    An integer specifying the coded character set identifier (CCSID) to be used for double byte characters in character column definitions (without a specific CCSID clause) in CREATE and ALTER TABLE SQL statements. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.
  • CCSIDM
    An integer specifying the coded character set identifier (CCSID) to be used for mixed byte characters in character column definitions (without a specific CCSID clause) in CREATE and ALTER TABLE SQL statements. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.
  • CCSIDS
    An integer specifying the coded character set identifier (CCSID) to be used for single byte characters in character column definitions (without a specific CCSID clause) in CREATE and ALTER TABLE SQL statements. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.
  • CHARSUB
    Designates the default character sub-type that is to be used for column definitions in CREATE and ALTER TABLE SQL statements. This DRDA precompile/bind option is not supported by DB2.
  • COLLECTION
    Specifies a 30-character collection identifier for the package. If this is not specified, the authorization identifier for the user processing the package is used.
  • COMMIT
    Specifies where implicit COMMIT statements should be generated.
  • CONCAT
    Specifies the ASCII character code to use for the CONCAT symbol (|).
  • CONCURRENTACCESSRESOLUTION
    Specifies the concurrent access resolution to use for statements in the package.
  • CONNECT
    Specifies that a CONNECT statement is to be processed as either a type 1 CONNECT or a type 2 CONNECT.
  • COPY
    Enables the use SQL host variables in COBOL copybooks.
  • CTRACE
    Creates a trace file for submission to Technical Support if requested. The filename of the file that is created is sqltrace.txt.
  • DB
    Specifies the name of the database that the program accesses. If DB is specified without a parameter, the database specified in the environment variable DB2DBDFT is used.
  • DBPROTOCOL
    Specifies what protocol to use when connecting to a remote site that is identified by a three-part name statement.
  • DEC
    Specifies the maximum precision to be used in decimal arithmetic operations. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.
  • DECDEL
    Designates whether a period (.) or a comma (,) will be used as the decimal point indicator in decimal and floating point literals. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.
  • DEFERRED_PREPARE
    Provides a performance enhancement when accessing DB2 common server databases or DRDA databases. This option combines the SQL PREPARE statement flow with the associated OPEN, DESCRIBE, or EXECUTE statement flow to minimize inter-process or network flow.
  • DEGREE
    Specifies whether or not the query is to be executed using I/O parallel processing.
  • DISCONNECT
  • DYNAMICRULES
    Specifies which authorization identifier to use when dynamic SQL in a package is executed.
  • ENCODING
    Specifies the encoding for all host variables in static statements in the plan or package.
  • EXPLAIN
    Stores information in the Explain tables about the access plans chosen for each SQL statement in the package. DRDA does not support the ALL value for this option.
  • EXPLSNAP
    Stores Explain Snapshot information in the Explain tables. This DB2 precompile/bind option is not supported by DRDA.
  • EXTENDEDINDICATOR
    Enables the recognition of extended indicator variable values during the execution of the associated plan or package.
  • FEDERATED
    Specifies whether a static SQL statement references a nickname or a federated view. SQL errors are returned if the package does not refer to a federated view or nickname and this option is specified, or if the package does refer to a federated view or nickname and the option is not specified.
  • FEDERATED_ASYNCHRONY
    Specifies the maximum number of asynchrony table queues (ATQs) that the federated server supports in the access plan for programs that use embedded SQL.
  • FOR
    Specifies whether or not the precompiler modifies the updatable cursor to add a FOR UPDATE clause.
  • FORMAT
    Specifies the date and time format when date/time fields are assigned to string representations in host variables. DEF is a date and time format associated with the country code of the database.
  • FUNCPATH
    Specifies the function path to be used in resolving user-defined distinct types and functions in static SQL. If this option is not specified, the default function path is:
  • GENERIC
    Provides a means of passing new bind options to a target DRDA database. Each option must be separated by one or more spaces and enclosed in double quotes. For example:
  • GEN-INIT-FLAG
    Generates the SQL-INIT-FLAG variable for DB2 for OS/390 compatibility. The flag is updated when the SQL environment is initialized. If you define this variable in your application, compile your application with this directive set to NOGEN-INIT-FLAG and the variable will not be generated by the precompiler.
  • GEN-SQLCA
    Generates an SQLCA set of program variables equivalent to coding an EXEC SQL INCLUDE SQLCA statement in an application program.
  • HOSTVAR
    Enables the precompiler to compile a program when host variables are defined on multiple lines. If host variables are defined on multiple lines, the precompiler generates a COBDB0100S error. If this error occurs, compile the program using DB2(HOSTVAR).
  • HSFTRACE
    Generates calls around each SQL statement to the HSF trace routine if the application is running under Enterprise Server. In some cases, the application must be linked with mfsqlSMF.lib.
  • IGNORE-NESTED
    In nested programs, specifies the program-id at which to start generating DB2 interface code. Any nested program encountered before the program-id is ignored and no DB2 interface code is generated. You must specify a program-id in the COBOL source code; otherwise, a compile error results. If you specify IGNORE-NESTED without a parameter, the program-id defaults to the program name with the filename extension replaced by .CBL.
  • IMMEDIATE
    A synonym for directive CALL_RESOLUTION=IMMEDIATE.
  • IMMEDWRITE
    Specifies whether or not to immediately write updates made to group buffer pool dependent pagesets or database partitions.
  • INIT
    Generates a CONNECT statement to initialize SQL. This option is disabled if it is used within an OO program.
  • INSERT
    Allows a program being precompiled or bound against a DB2 Enterprise Server Edition server to request that data inserts be buffered to increase performance.
  • ISOLATION
    Determines how far a program bound to this package can be isolated from the effect of other executing programs. For more information about isolation levels, see the IBM DB2 SQL Reference.
  • KEEPDYNAMIC
    Specifies whether or not to keep dynamic SQL statements after commit points.
  • LANGLEVEL
    For more information about this option, see the IBM DB2 Application Programming Guide.
  • LEVEL
    Defines the level of a module using the consistency token. The consistency token is any alphanumeric value up to 8 characters in length. The RDB package consistency token verifies that the requester's application and the relational database package are synchronized.
  • MSGAREA
    Specifies the name of an alphanumeric data item. If this item is present in the program source it will automatically contain a description of a DB2 error condition (when SQLCODE is non zero).
  • MULTI-NESTED
    Causes the precompiler to generate DB2 interface code in every routine in a source module including mutiple nested subroutines.
  • NOT
    Specifies the character code to use for NOT character (¬).
  • OPTPROFILE
    Specifies the name of an existing optimization profile to be used for all static statements in the package.
  • OPTHINT
    Specifies whether or not to use query optimization hints for static SQL.
  • OS400NAMING
    Specifies which naming option is to be used when accessing DB2 for System i® data.
  • OWNER
    Designates a 30-character authorization identifier for the package owner. The owner must have the privileges required to execute the SQL statements in the package. The default is the primary authorization ID of the precompile/bind process if this option has not been explicitly specified.
  • PASS
    Specifies the user ID and password to use when connecting to the database. If not specified, the values set for the DB2_USERNAME and DB2_PASSSWORD environment variables are used.
  • PRE
    Enables DB2 programs to be animated or executed by pre-loading DB2 API routine entry points. Specify NOPRE if creating an executable or shared object file; otherwise, you may have link problems.
  • QUALFIX
    Causes the DB2 ECM to append three characters to the name of the host variables when declaring them to DB2. This ensures problems caused by qualification (where two or more host variables have identical names when not qualified) are avoided but has the side-effect that DB2 error messages sometimes display the names of host variables with the three additional characters appended to them.
  • QUALIFIER
    Provides a 128-character implicit qualifier for unqualified table names, views, indexes, and aliases contained in the package. The default is the owner's authorization ID.
  • QUERYOPT
    Indicates the desired level of optimization for all static SQL statements contained in the package. The default value is 5. For the complete range of optimization levels available, see the SET CURRENT QUERY OPTIMIZATION statement in the SQL Reference. This DB2 precompile/bind option is not supported by DRDA.
  • RELEASE
    Indicates whether resources are released at each COMMIT point, or when the application terminates. This DRDA precompile/bind option is not supported by DB2.
  • REOPT
    Specifies whether or not to have DB2 optimize an access path using values for host variables, parameter markers, global variables, and special registers.
  • REPLVER
    Replaces a specific version of a package. The version identifier specifies which version of the package is to be replaced. Maximum length is 254 characters. REPLVER must follow immediately after ACTION=REPLACE or RETAIN if specified.
  • RETAIN
    Indicates whether EXECUTE authorities are to be preserved when a package is replaced. If ownership of the package changes, the new owner grants the BIND and EXECUTE authority to the previous package owner.
  • SORTSEQ
    Specifies which sort sequence table to use on the System i system.
  • SQLERROR
    Indicates whether to create a package or a bind file if an error is encountered.
  • SQLFLAG
    Identifies and reports on deviations from the SQL language syntax specified.
  • SQLRULES
    Specifies whether type 2 CONNECTs are to be processed according to the DB2 rules or the Standard (STD) rules based on ISO/ANS SQL92.
  • SQLWARN
    Indicates whether warnings will be returned from the compilation of dynamic SQL statements (via PREPARE or EXECUTE IMMEDIATE), or from describe processing (via PREPARE...INTO or DESCRIBE). This DB2 precompile/bind option is not supported by DRDA.
  • STATICREADONLY
    Determines whether or not static cursors are treated as READ ONLY.
  • STRDEL
    Designates whether an apostrophe (') or double quotation marks (") will be used as the string delimiter within SQL statements. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.
  • SYNCPOINT
    Specifies how commits or rollbacks are to be coordinated among multiple database connections.
  • SYNTAX
    A synonym for directive SQLERROR=CHECK.
  • TEXT
    The description of a package. Maximum length is 255 characters. The default value is blanks. This DRDA precompile/bind option is not supported by DB2.
  • TRANSFORM-GROUP
    Specifies the transform group name to be used for static SQL. This is a SQL identifier up to 18 characters in length.
  • UDB-VERSION
    Specifies the version of DB2 Database for Linux, UNIX, and Windows (LUW) you want to use.
  • VALIDATE
    Determines when the database manager checks for authorization errors and object not found errors. The package owner authorization ID is used for validity checking.
  • VERSION
    Defines the version identifier for a package. The version identifier is any alphanumeric value, $, #, @, _, -, or ., up to 254 characters in length.
Parent topic: DB2
Related concepts
DB2 Compiler Directive
Invoking the DB2 ECM
Error Codes


ACCESS

Specifies the name of the package to be created and stored in the database. If ACCESS is specified without a parameter, the package name defaults to the program name (without the .CBL extension).

Syntax:

ACCESS=package name
ACCESS
NOACCESS

Properties:

Default: | ACCESS
Synonym: | PACKAGE.
Parent topic: DB2 Compiler Directive Options


ACTION

Indicates whether the package can be added or replaced.

Syntax:

ACTION={ADD | REPLACE }
NOACTION

Parameters:

ADD | Indicates that the named package does not exist, and that a new package is to be created. If the package already exists, execution stops, and a diagnostic error message is returned.
REPLACE | Indicates that the old package is to be replaced by a new one with the same location, collection, and package name. If you specify REPLACE, and want to specify REPLVER or RETAIN or both, you must specify them (in either order) immediately after ACTION=REPLACE.

Properties:

Default: NOACTION
Parent topic: DB2 Compiler Directive Options


APREUSE

Specifies whether or not to reuse static SQL access plans.

When enabled, the compiler attempts to reuse the access plans for the statement in any existing packages during the bind and during future implicit and explicit rebinds.

Syntax:

APREUSE={NO | YES}

Parameters:

NO | The query compiler does not attempt to reuse access plans for the statements in the package.
YES | The compiler attempts to reuse the access plans for the statements in the package. If there is an existing package, the query compiler attempts to reuse the access plan for every statement that can be matched with a statement in the new bind file. For a statement to match, the statement text must be identical and the section number for the statement in the existing package must match the section number for the statement in the new package.

Properties:

Default: APREUSE=NO

Comment:

Applies to DB2 LUW only.

Parent topic: DB2 Compiler Directive Options


BIND

Specifies the name of the bind file to be created. When BIND is specified without a parameter, the bind file defaults to the program name with the filename extension replaced by .BND, and is created in the current source directory.

Bind files can be written to a specific directory other than the current source directory or a directory specified by the BIND directive. To do this, you set the HCOBND environment variable. For example:

HCOBND=d:\mydir\binds

The directory you specify in the HCOBND environment variable applies to all bind files created by Studio Enterprise Edition until you unset the environment variable or specify a specific build setting for a program using the DB2 bind directive. For example:

db2(bind=d:\mybinds\test.bnd)

would cause the HCOBND environment variable setting to be ignored.

Syntax:

BIND=bindfile
BIND
NOBIND

Properties:

Default: | NOBIND
Synonym: | BINDFILE.
Parent topic: DB2 Compiler Directive Options


BLOCK

Specifies the record blocking mode to be used on package creation. For information about row blocking, see the IBM DB2 Administration Guide or the Application Programming Guide.

Syntax:

BLOCK={UNAMBIG | ALL | NO}

Parameters:

ALL | Specifies blocking for read-only cursors or cursors not specified as FOR UPDATE OF. Ambiguous cursors are treated as read-only.
NO | Specifies no blocking of any cursors. Ambiguous cursors are treated as updateable.
UNAMBIG | Specifies blocking for read-only cursors or cursors not specified as FOR UPDATE OF. Ambiguous cursors are treated as updateable.

Properties:

Default: | BLOCK=UNAMBIG
Synonym: | BLOCKING.
Parent topic: DB2 Compiler Directive Options


CALL_RESOLUTION

Specifies how a CALL statement will be resolved.

Syntax:

CALL_RESOLUTION={IMMEDIATE | DEFERRED}
IMMEDIATE

Parameters:

IMMEDIATE | Specifies that the CALL statement will be excecuted as a normal SQL statement. If the name being called cannot be resolved, the precompiler reports error SQL0204.
DEFERRED | Specifies that the CALL statement will be executed as an invocation of the deprecated sqleproc() API.

Properties:

Default: IMMEDIATE

Comments:

You must be using DB2 LUW V8.1 or later for this directive to work.

You need to set CALL_RESOLUTION=DEFERRED if you place the name of the stored procedure in a host variable or if the precompiler fails to resolve the procedure on a CALL statement (in which case, the precompiler reports error SQL0204).

Parent topic: DB2 Compiler Directive Options


CASE

Specifies the case of the package name.
Note:

This option applies only to Linux and Unix DB2 Servers.

Syntax:

CASE={UPPER | LOWER | ASIS}

Parameters:

UPPER | Change the package name to use all upper-case characters
LOWER | Change the package name to use all lower-case characters
ASIS | Use the package name as it was entered
Parent topic: DB2 Compiler Directive Options


CCSIDG

An integer specifying the coded character set identifier (CCSID) to be used for double byte characters in character column definitions (without a specific CCSID clause) in CREATE and ALTER TABLE SQL statements. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.

Syntax:

CCSIDG=double-ccsid
NOCCSIDG

Properties:

Default: NOCCSIDG
Parent topic: DB2 Compiler Directive Options


CCSIDM

An integer specifying the coded character set identifier (CCSID) to be used for mixed byte characters in character column definitions (without a specific CCSID clause) in CREATE and ALTER TABLE SQL statements. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.

Syntax:

CCSIDM=mixed-ccsid
NOCCSIDM

Properties:

Default: NOCCSIDM
Parent topic: DB2 Compiler Directive Options


CCSIDS

An integer specifying the coded character set identifier (CCSID) to be used for single byte characters in character column definitions (without a specific CCSID clause) in CREATE and ALTER TABLE SQL statements. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.

Syntax:

CCSIDS=sbcs-ccsid
NOCCSIDS

Properties:

Default: NOCCSIDS
Parent topic: DB2 Compiler Directive Options


CHARSUB

Designates the default character sub-type that is to be used for column definitions in CREATE and ALTER TABLE SQL statements. This DRDA precompile/bind option is not supported by DB2.

Syntax:

CHARSUB={DEFAULT | BIT | SBCS | MIXED}
NOCHARSUB

Parameters:

BIT | Use the FOR BIT DATA SQL character sub-type in all new character columns for which an explicit sub-type is not specified.
DEFAULT | Use the target system defined default in all new character columns for which an explicit sub-type is not specified.
MIXED | Use the FOR MIXED DATA SQL character sub-type in all new character columns for which an explicit sub-type is not specified.
SBCS | Use the FOR SBCS DATA SQL character sub-type in all new character columns for which an explicit sub-type is not specified.

Properties:

Default: NOCHARSUB
Parent topic: DB2 Compiler Directive Options


COLLECTION

Specifies a 30-character collection identifier for the package. If this is not specified, the authorization identifier for the user processing the package is used.

Syntax:

COLLECTION=schema name
NOCOLLECTION

Properties:

Default: NOCOLLECTION
Parent topic: DB2 Compiler Directive Options


COMMIT

Specifies where implicit COMMIT statements should be generated.

Syntax:

COMMIT={1 | 2 | 3 | 4}

Parameters:

1 | No COMMIT statements implicitly generated
2 | COMMIT statements are implicitly generated on STOP RUN statements and at the end of the program
3 | COMMIT statements are implicitly generated on STOP RUN and EXIT PROGRAM statements and at the end of the program
4 | COMMIT statements are implicitly generated after every SQL statement

Properties:

Default: COMMIT=2
Parent topic: DB2 Compiler Directive Options


CONCAT

Specifies the ASCII character code to use for the CONCAT symbol (|).

Syntax:

CONCAT={ascii-character-code | 33}

Properties:

Default: CONCAT=33
Parent topic: DB2 Compiler Directive Options


CONCURRENTACCESSRESOLUTION

Specifies the concurrent access resolution to use for statements in the package.

Syntax:

CONCURRENTACCESSRESOLUTION={WAIT | USE-CURRENT}
NOCONCURRENTACCESSRESOLUTION

Parameters:

WAIT | Specifies Cursor Stability and higher scans to wait for the commit or rollback when encountering data in the process of being updated or deleted. Rows in the process of being inserted are not skipped. The settings for the registry variables DB2_EVALUNCOMMITTED, DB2_SKIPDELETED , and DB2_SKIPINSERTED do not apply.
USE CURRENT | Specifies that the database manager can use the currently committed version of the data for applicable scans when it is in the process of being updated or deleted. Rows in the process of being inserted can be skipped. This clause applies when the isolation level in effect is Cursor Stability or Read Stability (for Read Stability it skips uncommited inserts only) and is ignored otherwise. Applicable scans include read-only scans that can be part of a read-only statement as well as a non read-only statement. The settings for the registry variables DB2_EVALUNCOMMITTED, DB2_SKIPDELETED, and DB2_SKIPINSERTED do not apply to scans using currently committed. However, the settings for these registry variables still apply to scans that do not use currently committed.

Properties:

Default: NOCONCURRENTACCESSRESOLUTION
Parent topic: DB2 Compiler Directive Options


CONNECT

Specifies that a CONNECT statement is to be processed as either a type 1 CONNECT or a type 2 CONNECT.

Syntax:

CONNECT={1 | 2}
NOCONNECT

Properties:

Default: NOCONNECT
Parent topic: DB2 Compiler Directive Options


COPY

Enables the use SQL host variables in COBOL copybooks.

Syntax:

COPY
NOCOPY

Parameters:

Default: NOCOPY
Parent topic: DB2 Compiler Directive Options


CTRACE

Creates a trace file for submission to Technical Support if requested. The filename of the file that is created is sqltrace.txt.

Syntax:

CTRACE
NOCTRACE

Properties:

Default: NOCTRACE
Parent topic: DB2 Compiler Directive Options


DB

Specifies the name of the database that the program accesses. If DB is specified without a parameter, the database specified in the environment variable DB2DBDFT is used.

Syntax:

DB=database name
DB

Properties:

Default: DB
Parent topic: DB2 Compiler Directive Options


DBPROTOCOL

Specifies what protocol to use when connecting to a remote site that is identified by a three-part name statement.
Note:

Supported by DB2 for OS/390® only. For a list of supported option values, see your DB2 for OS/390 documentation.

Syntax:

DBPROTOCOL={DRDA | PRIVATE}

Parameters:

DRDA
PRIVATE
Parent topic: DB2 Compiler Directive Options


DEC

Specifies the maximum precision to be used in decimal arithmetic operations. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.

Use 15 to specify 15-digit precision is used in decimal arithmetic operations.

Use 31 to specify 31-digit precision is used in decimal arithmetic operations.

Syntax:

DEC={31 | 15}
NODEC

Properties:

Default: NODEC
Parent topic: DB2 Compiler Directive Options


DECDEL

Designates whether a period (.) or a comma (,) will be used as the decimal point indicator in decimal and floating point literals. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.

Syntax:

DECDEL={PERIOD | COMMA}
NODECDEL

Parameters:

COMMA | Use a comma (,) as the decimal point indicator.
PERIOD | Use a period (.) as the decimal point indicator.

Properties:

Default: NODECDEL
Parent topic: DB2 Compiler Directive Options


DEFERRED_PREPARE

Provides a performance enhancement when accessing DB2 common server databases or DRDA databases. This option combines the SQL PREPARE statement flow with the associated OPEN, DESCRIBE, or EXECUTE statement flow to minimize inter-process or network flow.

Syntax:

DEFERRED_PREPARE={NO | YES | ALL}
NODEFERRED_PREPARE

Parameters:

NO | The PREPARE statement will be executed at the time it is issued.
YES | Execution of the PREPARE statement will be deferred until the corresponding OPEN, DESCRIBE, or EXECUTE statement is issued. The PREPARE statement will not be deferred if it uses the INTO clause, which requires an SQLDA to be returned immediately. However, if the PREPARE INTO statement is issued for a cursor that does not use any parameter markers, the processing will be optimized by pre-OPENing the cursor when the PREPARE is executed.
ALL | Same as YES, except that a PREPARE INTO statement which contains parameter markers is deferred. If a PREPARE INTO statement does not contain parameter markers, pre-OPENing of the cursor will still be performed. If the PREPARE statement uses the INTO clause to return an SQLDA, the application must not reference the content of this SQLDA until the OPEN, DESCRIBE, or EXECUTE statement is issued and returned.

Properties:

Default: NODEFERRED_PREPARE
Parent topic: DB2 Compiler Directive Options


DEGREE

Specifies whether or not the query is to be executed using I/O parallel processing.

Syntax:

DEGREE={1 | degree-of-parallelism | ANY}
NODEGREE

Parameters:

1 | Prohibits parallel I/O operations
degree-of-I/O-parallelism | Specifies the degree of parallel I/O operations, a value between 2 and 32767 (inclusive)
ANY | Allows parallel I/O operations.

Properties:

Default: NODEGREE
Parent topic: DB2 Compiler Directive Options


DISCONNECT

Syntax:

DISCONNECT={EXPLICIT | CONDITIONAL | AUTOMATIC}
NODISCONNECT

Parameters:

AUTOMATIC | Specifies that all database connections are to be disconnected at commit.
CONDITIONAL | Specifies that the database connections that have been marked RELEASE or have no open WITH HOLD cursors are to be disconnected at commit.
EXPLICIT | Specifies that only database connections that have been explicitly marked for release by the RELEASE statement are to be disconnected at commit.

Properties:

Default: NODISCONNECT
Parent topic: DB2 Compiler Directive Options


DYNAMICRULES

Specifies which authorization identifier to use when dynamic SQL in a package is executed.

Syntax:

DYNAMICRULES={BIND | RUN | DEFINE | DEFINEBIND | DEFINERUN |
               INVOKE | INVOKEBIND | INVOKERUN}
NODYNAMICRULES

Parameters:

BIND | Indicates that the authorization identifier used for the execution of dynamic SQL is the package owner.
RUN | Indicates that the authorization identifier used for the execution of dynamic SQL is the authid of the person executing the package.
DEFINE | Indicates that the authorization identifier used for execution of dynamic SQL is the definer of the UDF or stored procedure. This option is not supported by DB2.
DEFINEBIND | If the package is used within a routine context, the authorization identifier of the routine definer is to be used for authorization checking and for implicit qualification of unqualified object references within dynamic SQL statements within the routine. If the package is used as a standalone application, dynamic SQL statements are processed as though the package were bound with DYNAMICRULES BIND.
DEFINERUN | If the package is used within a routine context, the authorization identifier of the routine definer is to be used for authorization checking and for implicit qualification of unqualified object references within dynamic SQL statements within the routine. If the package is used as a standalone application, dynamic SQL statements are processed as though the package were bound with DYNAMICRULES RUN.
INVOKE | Indicates that the authorization identifier used for the execution of dynamic SQL is the invoker of the UDF or stored procedure. This option is not supported by DB2.
INVOKEBIND | If the package is used within a routine context, the current statement authorization identifier in effect when the routine is invoked is to be used for authorization checking of dynamic SQL statements and for implicit qualification of unqualified object references within dynamic SQL statements within that routine. If the package is used as a standalone application, dynamic SQL statements are processed as though the package were bound with DYNAMICRULES BIND.
INVOKERUN | If the package is used within a routine context, the current statement authorization identifier in effect when the routine is invoked is to be used for authorization checking of dynamic SQL statements and for implicit qualification of unqualified object references within dynamic SQL statements within that routine. If the package is used as a standalone application, dynamic SQL statements are processed as though the package were bound with DYNAMICRULES RUN.

Properties:

Default: NODYNAMICRULES
Parent topic: DB2 Compiler Directive Options


ENCODING

Specifies the encoding for all host variables in static statements in the plan or package.
Note:

Supported by DB2 for OS/390® only. For a list of supported option values, see your DB2 for OS/390 documentation.

Syntax:

ENCODING={ASCII | EBCDIC | UNICODE | CCSID}
Parent topic: DB2 Compiler Directive Options


EXPLAIN

Stores information in the Explain tables about the access plans chosen for each SQL statement in the package. DRDA does not support the ALL value for this option.

Syntax:

EXPLAIN={NO | YES | ALL}
NOEXPLAIN

Parameters:

NO | Explain information will not be captured.
YES | Explain tables will be populated with information about the chosen access plan.
ALL | Explain information for each eligible static SQL statement will be placed in the Explain tables. In addition, Explain information will be gathered for eligible dynamic SQL statements at run time, even if the CURRENT EXPLAIN SNAPSHOT register is set to NO. For more information about special registers, see the IBM DB2 SQL Reference.

Properties:

Default: NOEXPLAIN
Parent topic: DB2 Compiler Directive Options


EXPLSNAP

Stores Explain Snapshot information in the Explain tables. This DB2 precompile/bind option is not supported by DRDA.

Syntax:

EXPLSNAP={NO | YES | ALL}
NOEXPLSNAP

Parameters:

NO | An Explain Snapshot will not be captured.
YES | An Explain Snapshot for each eligible static SQL statement will be placed in the Explain tables.
ALL | An Explain Snapshot for each eligible static SQL statement will be placed in the Explain tables. In addition, Explain Snapshot information will be gathered for eligible dynamic SQL statements at run time, even if the CURRENT EXPLAIN SNAPSHOT register is set to NO. For more information about special registers, see the IBM DB2 SQL Reference.

Properties:

Default: NOEXPLSNAP
Parent topic: DB2 Compiler Directive Options


EXTENDEDINDICATOR

Enables the recognition of extended indicator variable values during the execution of the associated plan or package.

Syntax:

EXTENDEDINDICATOR={NO | YES }

Parameters:

NO | Extended indicator variable values are recognized. Using any non-recognized indicator variable values, or using the default or unassigned indicator variable-based values in a non-supported location will cause DB2 database manager to generate an error message during execution of the bound statement.
YES | Extended indicator variable values are not recognized. Indicator variables are normal indicator variables; negative indicator variable values imply null, and positive or zero values imply non-null.

Properties:

Default: EXTENDEDINDICATOR=NO
Parent topic: DB2 Compiler Directive Options


FEDERATED

Specifies whether a static SQL statement references a nickname or a federated view. SQL errors are returned if the package does not refer to a federated view or nickname and this option is specified, or if the package does refer to a federated view or nickname and the option is not specified.

Syntax:

FEDERATED={NO | YES}

Parameters:

NO | The program will connect to a DB2 LUW. This is the default value.
YES | The program will access a DB2 federated system.

Properties:

Default: FEDERATED=NO
Parent topic: DB2 Compiler Directive Options


FEDERATED_ASYNCHRONY

Specifies the maximum number of asynchrony table queues (ATQs) that the federated server supports in the access plan for programs that use embedded SQL.

Syntax:

FEDERATED_ASYNCHRONY={ANY | atqsNo}
NOFEDERATED_ASYNCHONY

Parameters:

ANY | The optimizer determines the number of ATQs for the access plan. The optimizer assigns an ATQ to all eligible SHIP or remote pushdown operators in the plan. The value that is specified for DB2_MAX_ASYNC_REQUESTS_PER_QUERY server option limits the number of asynchronous requests.
atqsNo | The number of ATQs in the plan. You specify a number in the range 0 to 32767.

Properties:

Default: NOFEDERATED_ASYNCHONY

Comment:

Applies to DB2 LUW only.

Parent topic: DB2 Compiler Directive Options


FOR

Specifies whether or not the precompiler modifies the updatable cursor to add a FOR UPDATE clause.

Syntax:

[NO]FOR

Properties:

Default: FOR
Parent topic: DB2 Compiler Directive Options


FORMAT

Specifies the date and time format when date/time fields are assigned to string representations in host variables. DEF is a date and time format associated with the country code of the database.

Syntax:

FORMAT={DEF | USA | EUR | ISO | JIS | LOC}

Parameters:

EUR | is the IBM standard for European date and time format.
ISO | is the date and time format of the International Standards Organization.
JIS | is the date and time format of the Japanese Industrial Standard.
LOC | is the date and time format in local form associated with the country code of the database.
USA | is the IBM standard for U.S. date and time format.

Properties:

Default: | FORMAT=LOC
Synonym: | DATETIME.
Parent topic: DB2 Compiler Directive Options


FUNCPATH

Specifies the function path to be used in resolving user-defined distinct types and functions in static SQL. If this option is not specified, the default function path is:
"SYSIBM","SYS FUN",USER

where USER is the value of the USER special register. This DB2 precompile/bind option is not supported by DRDA.

Syntax:

FUNCPATH=schema-name
NOFUNCPATH

Parameters:

schema-name is a short SQL identifier, either ordinary or delimited, which identifies a schema that exists at the application server. No validation that the schema exists is made at precompile or at bind time. The same schema cannot appear more than once in the function path. The number of schemas that can be specified is limited by the length of the resulting function path, which cannot exceed 254 bytes. The schema SYSIBM does not need to be explicitly specified; it is implicitly assumed to be the first schema if it is not included in the function path. For more information, see the IBM DB2 SQL Reference.

Properties:

Default: NOFUNCPATH
Parent topic: DB2 Compiler Directive Options


GENERIC

Provides a means of passing new bind options to a target DRDA database. Each option must be separated by one or more spaces and enclosed in double quotes. For example:
DB2(GENERIC="keepdynamic
  yes")

Syntax:

GENERIC=string
Parent topic: DB2 Compiler Directive Options


GEN-INIT-FLAG

Generates the SQL-INIT-FLAG variable for DB2 for OS/390 compatibility. The flag is updated when the SQL environment is initialized. If you define this variable in your application, compile your application with this directive set to NOGEN-INIT-FLAG and the variable will not be generated by the precompiler.

Syntax:

GEN-INIT-FLAG
NOGEN-INIT-FLAG

Properties:

Default: GEN-INIT-FLAG
Parent topic: DB2 Compiler Directive Options


GEN-SQLCA

Generates an SQLCA set of program variables equivalent to coding an EXEC SQL INCLUDE SQLCA statement in an application program.

Syntax:

GEN-SQLCA
NOGEN-SQLCA

Properties:

Default: NOGEN-SQLCA
Parent topic: DB2 Compiler Directive Options


HOSTVAR

Enables the precompiler to compile a program when host variables are defined on multiple lines. If host variables are defined on multiple lines, the precompiler generates a COBDB0100S error. If this error occurs, compile the program using DB2(HOSTVAR).

Syntax:

HOSTVAR
NOHOSTVAR

Properties:

Default: NOHOSTVAR
Parent topic: DB2 Compiler Directive Options


IGNORE-NESTED

In nested programs, specifies the program-id at which to start generating DB2 interface code. Any nested program encountered before the program-id is ignored and no DB2 interface code is generated. You must specify a program-id in the COBOL source code; otherwise, a compile error results. If you specify IGNORE-NESTED without a parameter, the program-id defaults to the program name with the filename extension replaced by .CBL.

Syntax:

IGNORE-NESTED=program-id
IGNORE-NESTED
NOIGNORE-NESTED

Properties:

Default: NOIGNORE-NESTED
Parent topic: DB2 Compiler Directive Options


IMMEDIATE

A synonym for directive CALL_RESOLUTION=IMMEDIATE.

Syntax:

SYNTAX

Properties:

Synonym: CALL_RESOLUTION=IMMEDIATE
Parent topic: DB2 Compiler Directive Options


IMMEDWRITE

Specifies whether or not to immediately write updates made to group buffer pool dependent pagesets or database partitions.
Note:

Supported by DB2 for OS/390® only. For a list of supported option values, see your DB2 for OS/390 documentation.

Syntax:

IMMEDWRITE={NO | YES | PH1}
Parent topic: DB2 Compiler Directive Options


INIT

Generates a CONNECT statement to initialize SQL. This option is disabled if it is used within an OO program.

Syntax:

INIT={PROT | S | X }
NOINIT

Parameters:

PROT | In the event that the application terminates abnormally, correctly closes down the database connection and rolls back all changes since the last COMMIT, avoiding potential database corruption.
S | Database to be used in shared mode
X | Database to be used in exclusive mode

Properties:

Default: NOINIT

Comments:

  • Set INIT only once for each application. Do not set INIT for SQL programs called by other SQL programs. Instead, specify the INIT option for the first SQL program executed in a run unit. Compiling more than one module in an application with the INIT option could cause your program to terminate abnormally.
  • If you use DB2 LUW 7.2 with fixpack 8 or later, do not compile an application using both the INIT and the PASS directives. Instead, we recommend that you code a CONNECT statement directly into your programs. Because these versions of DB2 LUW generate an SQL error when host variables are passed with spaces or low values on a CONNECT, INIT does not generate the CONNECT statement with the blank host variables needed by the PASS directive for the user ID and password.
  • In some additional circumstances, you might find it best to code a CONNECT statement into your programs rather than using the DB2(INIT) directive. Consider the following:
    • In the past, IBM has occasionally changed the equivalent APIs used in the SQL CONNECT statement. Therefore, we cannot guarantee that the implicit code generated by the DB2(INIT) compiler directive will function with new releases of DB2 LUW.
    • Because the DB2(INIT) directive can generate and store user ID and password information, security is a consideration.
Parent topic: DB2 Compiler Directive Options
Related reference
PASS


INSERT

Allows a program being precompiled or bound against a DB2 Enterprise Server Edition server to request that data inserts be buffered to increase performance.

Syntax:

INSERT={DEF | BUF}
NOINSERT

Parameters:

BUF | Specifies that inserts from an application should be buffered.
DEF | Specifies that inserts from an application should not be buffered.

Properties:

Default: NOINSERT
Parent topic: DB2 Compiler Directive Options


ISOLATION

Determines how far a program bound to this package can be isolated from the effect of other executing programs. For more information about isolation levels, see the IBM DB2 SQL Reference.

Syntax:

ISOLATION={CS | RR | UR | RS | NC}

Parameters:

CS | specifies Cursor Stability as the isolation level.
NC | (No Commit) specifies that commitment control is not to be used. This isolation level is not supported by DB2.
RR | specifies Repeatable Read as the isolation level.
RS | specifies Read Stability as the isolation level. Read Stability ensures that the execution of SQL statements in the package is isolated from other application processes for rows read and changed by the application.
UR | specifies Uncommitted Read as the isolation level.

Properties:

Default: ISOLATION=CS
Parent topic: DB2 Compiler Directive Options


KEEPDYNAMIC

Specifies whether or not to keep dynamic SQL statements after commit points.
Note:

Supported by DB2 for OS/390® only. For a list of supported option values, see your DB2 for OS/390 documentation.

Syntax:

KEEPDYNAMIC={NO | YES}
Parent topic: DB2 Compiler Directive Options


LANGLEVEL

For more information about this option, see the IBM DB2 Application Programming Guide.

Syntax:

LANGLEVEL={SAA1 | NONE | MIA | SQL92E}

Parameters:

MIA | The FOR UPDATE clause is optional for positioned updates. C null-terminated strings are padded with blank characters, and always include the null-terminating character. This option is not supported by DB2 CONNECT or DDCS.
SAA1 | Requires the FOR UPDATE clause for all columns that are updated in a positioned update. C null-terminated strings are not padded with blank characters, and do not include a null-terminating character if truncation occurs.
NONE | Synonym for SAA1.
SQL92E | Similar to MIA. See the manual for the differences.

Properties:

Default: | LANGLEVEL=SAA1
Synonym: | STDLVL.
Parent topic: DB2 Compiler Directive Options


LEVEL

Defines the level of a module using the consistency token. The consistency token is any alphanumeric value up to 8 characters in length. The RDB package consistency token verifies that the requester's application and the relational database package are synchronized.
Note:

This option is not recommended for general use.

Syntax:

LEVEL=consistency-token
NOLEVEL

Properties:

Default: NOLEVEL
Parent topic: DB2 Compiler Directive Options


MSGAREA

Specifies the name of an alphanumeric data item. If this item is present in the program source it will automatically contain a description of a DB2 error condition (when SQLCODE is non zero).

Syntax:

MSGAREA={data-item-name | MFSQLMESSAGETEXT }
NOMSGAREA)

Properties:

Default: MSGAREA=MFSQLMESSAGETEXT
Parent topic: DB2 Compiler Directive Options


MULTI-NESTED

Causes the precompiler to generate DB2 interface code in every routine in a source module including mutiple nested subroutines.

Syntax:

MULTI-NESTED
NOMULTI-NESTED

Properties:

Default: NOMULTI-NESTED
Parent topic: DB2 Compiler Directive Options


NOT

Specifies the character code to use for NOT character (¬).

Syntax:

 NOT={ascii-character-code | 170}

Properties:

Default: NOT=170
Parent topic: DB2 Compiler Directive Options


OPTPROFILE

Specifies the name of an existing optimization profile to be used for all static statements in the package.
Note: This option is not supported by DRDA.

Syntax:

OPTPROFILE=profileName
NOOPTPROFILE

Parameters:

profileName The default value is an empty string. When specified, the name applies as the default for dynamic preparation of DML statements for which the CURRENT OPTIMIZATION PROFILE special register is null. If the specified name is unqualified, it is an SQL identifier, which is implicitly qualified by the QUALIFIER bind option.

Properties:

Default: NOOPTPROFILE

Comment:

Applies to DB2 LUW only.

Parent topic: DB2 Compiler Directive Options


OPTHINT

Specifies whether or not to use query optimization hints for static SQL.
Note:

Supported by DB2 for OS/390® only. For a list of supported option values, see your DB2 for OS/390 documentation.

Syntax:

OPTHINT=hintId
Parent topic: DB2 Compiler Directive Options


OS400NAMING

Specifies which naming option is to be used when accessing DB2 for System i® data.
Note:

Supported by DB2 for System i only. For a list of supported option values, see your DB2 for System i documentation.

Syntax:

OS44NAMING={SYSTEM | SQL}
Parent topic: DB2 Compiler Directive Options


OWNER

Designates a 30-character authorization identifier for the package owner. The owner must have the privileges required to execute the SQL statements in the package. The default is the primary authorization ID of the precompile/bind process if this option has not been explicitly specified.

Syntax:

OWNER=authorization-id
NOOWNER

Properties:

Default: | NOOWNER
Synonym: | SCHEMA.
Parent topic: DB2 Compiler Directive Options


PASS

Specifies the user ID and password to use when connecting to the database. If not specified, the values set for the DB2_USERNAME and DB2_PASSSWORD environment variables are used.

Syntax:

PASS={password | userid.password}
NOPASS

Properties:

Default: NOPASS

Comment:

For information about using PASS with INIT see the topic INIT.

Parent topic: DB2 Compiler Directive Options
Related reference
INIT


PRE

Enables DB2 programs to be animated or executed by pre-loading DB2 API routine entry points. Specify NOPRE if creating an executable or shared object file; otherwise, you may have link problems.

Syntax:

PRE
NOPRE

Properties:

Default: PRE
Parent topic: DB2 Compiler Directive Options


QUALFIX

Causes the DB2 ECM to append three characters to the name of the host variables when declaring them to DB2. This ensures problems caused by qualification (where two or more host variables have identical names when not qualified) are avoided but has the side-effect that DB2 error messages sometimes display the names of host variables with the three additional characters appended to them.

Syntax:

[NO]QUALFIX

Properties:

Default: NOQUALFIX
Parent topic: DB2 Compiler Directive Options
Related concepts
Error Codes


QUALIFIER

Provides a 128-character implicit qualifier for unqualified table names, views, indexes, and aliases contained in the package. The default is the owner's authorization ID.

Syntax:

QUALIFIER=qualifier-name
NOQUALIFIER

Properties:

Default: NOQUALIFIER
Parent topic: DB2 Compiler Directive Options


QUERYOPT

Indicates the desired level of optimization for all static SQL statements contained in the package. The default value is 5. For the complete range of optimization levels available, see the SET CURRENT QUERY OPTIMIZATION statement in the SQL Reference. This DB2 precompile/bind option is not supported by DRDA.

Syntax:

QUERYOPT= optimization-level
NOQUERYOPT

Properties:

Default: NOQUERYOPT
Parent topic: DB2 Compiler Directive Options


RELEASE

Indicates whether resources are released at each COMMIT point, or when the application terminates. This DRDA precompile/bind option is not supported by DB2.

Syntax:

RELEASE={COMMIT | DEALLOCATE}
NORELEASE

Parameters:

COMMIT | Release resources at each COMMIT point. Used for dynamic SQL statements.
DEALLOCATE | Release resources only when the application terminates.

Properties:

Default: NORELEASE
Parent topic: DB2 Compiler Directive Options


REOPT

Specifies whether or not to have DB2 optimize an access path using values for host variables, parameter markers, global variables, and special registers.

Syntax:

REOPT={NONE | ONCE | ALWAYS}

Parameters:

NONE | DB2 does not optimize the access path for SQL statements containing host variables, parameter markers, global variables, or special registers, and uses real values for these variables. Instead, DB2 uses the default estimates for the these variables, caching and using these defaults subsequently.
ONCE | When a query is first executed, DB2 optimizes the access path for SQL statements using the real values of the host variables, parameter markers, global variables, or special registers caching and using these real values subsequently.
ALWAYS | DB2 compiles and reoptimizes the access path for SQL statements using the values of the host variables, parameter markers, global variables, or special registers known at each execution time.

Properties:

Default: NONE
Parent topic: DB2 Compiler Directive Options


REPLVER

Replaces a specific version of a package. The version identifier specifies which version of the package is to be replaced. Maximum length is 254 characters. REPLVER must follow immediately after ACTION=REPLACE or RETAIN if specified.

Syntax:

REPLVER=version-id
NOREPLVER

Properties:

Default: NOREPLVER
Parent topic: DB2 Compiler Directive Options


RETAIN

Indicates whether EXECUTE authorities are to be preserved when a package is replaced. If ownership of the package changes, the new owner grants the BIND and EXECUTE authority to the previous package owner.

Syntax:

RETAIN={YES | NO}
NORETAIN

Parameters:

NO | does not preserve EXECUTE authorities when a package is replaced.
YES | preserves EXECUTE authorities when a package is replaced.

Properties:

Default: NORETAIN

Comments:

RETAIN must follow immediately after ACTION=REPLACE or REPLVER if specified.

Parent topic: DB2 Compiler Directive Options


SORTSEQ

Specifies which sort sequence table to use on the System i system.
Note:

Supported by DB2 for System i only. For a list of supported option values, see your DB2 for System i documentation.

Syntax:

SORTSEQ={JOBRUN | HEX}
Parent topic: DB2 Compiler Directive Options


SQLERROR

Indicates whether to create a package or a bind file if an error is encountered.

Syntax:

SQLERROR={NOPACKAGE | CHECK | CONTINUE}
NOSQLERROR

Parameters:

CHECK | Specifies that the target system performs all syntax and semantic checks on the SQL statements being bound. A package will not be created as part of this process. If, while creating a package, an existing package with the same name and version is encountered, the existing package is neither dropped nor replaced if action replace was specified.
CONTINUE | A package or a bind file is created even when SQL errors are encountered. This option is not supported by DB2.
NOPACKAGE | A package or a bind file is not created if an error is encountered.

Properties:

Default: | NOSQLERROR
Synonym: | ERROR.

Comments:

If syntax is used together with the package option, package is ignored.

Parent topic: DB2 Compiler Directive Options


SQLFLAG

Identifies and reports on deviations from the SQL language syntax specified.

A bind file or a package is created only if the BINDFILE or the PACKAGE option is specified in addition to the SQLFLAG option.

Local syntax checking is performed only if one of the following options is specified: BINDFILE, PACKAGE, SQLERROR CHECK, SYNTAX.

If SQLFLAG is not specified, the flagger function is not invoked, and the bind file or the package is not affected.

Syntax:

SQLFLAG={MVSDB2V23 | MVSDB2V31 | MVSDB2V41|SQL92E}-SYNTAX
NOSQLFLAG

Parameters:

MVSDB2V23-SYNTAX | The SQL statements will be checked against MVS DB2 Version 2.3 SQL language syntax. Any deviation from the syntax is reported in the precompiler listing.
MVSDB2V31-SYNTAX | The SQL statements will be checked against MVS DB2 Version 3.1 SQL language syntax. Any deviation from the syntax is reported in the precompiler listing.
MVSDB2V41-SYNTAX | The SQL statements will be checked against MVS DB2 Version 4.1 SQL language syntax. Any deviation from the syntax is reported in the precompiler listing.
SQL92E-SYNTAX | The SQL statements will be checked against ANSI or ISO SQL92 SQL language syntax. Any deviation from the syntax is reported in the compiler listing.

Properties:

Default: | NOSQLFLAG
Synonym: | FLAG.
Parent topic: DB2 Compiler Directive Options


SQLRULES

Specifies whether type 2 CONNECTs are to be processed according to the DB2 rules or the Standard (STD) rules based on ISO/ANS SQL92.

Syntax:

SQLRULES={DB2 | STD}
NOSQLRULES

Parameters:

DB2 | Allow the use of the SQL CONNECT statement to switch the current connection to another established (dormant) connection.
STD | Allow the use of the SQL CONNECT statement to establish a new connection only. The SQL SET CONNECTION statement must be used to switch to a dormant connection.

Properties:

Default: | NOSQLRULES
Synonym: | RULES.
Parent topic: DB2 Compiler Directive Options


SQLWARN

Indicates whether warnings will be returned from the compilation of dynamic SQL statements (via PREPARE or EXECUTE IMMEDIATE), or from describe processing (via PREPARE...INTO or DESCRIBE). This DB2 precompile/bind option is not supported by DRDA.

Syntax:

SQLWARN={YES | NO}
NOSQLWARN

Parameters:

NO | Warnings will not be returned from the SQL compiler.
YES | Warnings will be returned from the SQL compiler.

Properties:

Default: | NOSQLWARN
Synonym: | WARN.

Comments:

SQLCODE +238 is an exception. It is returned regardless of the sqlwarn option value.

Parent topic: DB2 Compiler Directive Options


STATICREADONLY

Determines whether or not static cursors are treated as READ ONLY.
Note:

This option is not supported by DRDA.

Syntax:

STATICREADONLY={NO | YES | INSENSITIVE}

Parameters:

NO | All static cursors take on the attributes generated based on the statement text and the setting of the LANGLEVEL option.
YES | Static cursors containing neither the FOR UPDATE nor the FOR READ ONLY clause are considered READ ONLY.
INSENSITIVE | Any static cursor that does not contain the FOR UPDATE clause is considered READ ONLY and INSENSITIVE.

Properties:

Default: NO
Parent topic: DB2 Compiler Directive Options


STRDEL

Designates whether an apostrophe (') or double quotation marks (") will be used as the string delimiter within SQL statements. This DRDA precompile/bind option is not supported by DB2. The DRDA server will use a system defined default value if this option is not specified.

Syntax:

STRDEL={APOSTROPHE | QUOTE}
NOSTRDEL

Parameters:

APOSTROPHE | Use an apostrophe (') as the string delimiter.
QUOTE | Use double quotation marks (") as the string delimiter.

Properties:

Default: NOSTRDEL
Parent topic: DB2 Compiler Directive Options


SYNCPOINT

Specifies how commits or rollbacks are to be coordinated among multiple database connections.

Syntax:

SYNCPOINT={ONEPHASE | TWOPHASE | NONE}
NOSYNCPOINT

Parameters:

NONE | Specifies that no Transaction Manager (TM) is to be used to perform a two-phase commit, and does not enforce single updater, multiple reader. A COMMIT is sent to each participating database. The application is responsible for recovery if any of the commits fail.
ONEPHASE | Specifies that no TM is to be used to perform a two-phase commit. A one-phase commit is to be used to commit the work done by each database in multiple database transactions.
TWOPHASE | Specifies that the TM is required to coordinate two-phase commits among those databases that support this protocol.

Properties:

Default: NOSYNCPOINT
Parent topic: DB2 Compiler Directive Options


SYNTAX

A synonym for directive SQLERROR=CHECK.

Syntax:

SYNTAX

Properties:

Synonym: SQLERROR=CHECK
Parent topic: DB2 Compiler Directive Options


TEXT

The description of a package. Maximum length is 255 characters. The default value is blanks. This DRDA precompile/bind option is not supported by DB2.

Syntax:

TEXT=label
NOTEXT

Properties:

Default: NOTEXT
Parent topic: DB2 Compiler Directive Options


TRANSFORM-GROUP

Specifies the transform group name to be used for static SQL. This is a SQL identifier up to 18 characters in length.

Syntax:

TRANSFORM-GROUP=identifier
NOTRANSFORM-GROUP

Properties:

Default: NOTRANSFORM-GROUP
Parent topic: DB2 Compiler Directive Options


UDB-VERSION

Specifies the version of DB2 Database for Linux, UNIX, and Windows (LUW) you want to use.

Syntax:

UDB-VERSION={V6 | V7 | V8 | V9 | V95 | V97}

Properties:

Default: DB2 LUW Server Version from connection
Parent topic: DB2 Compiler Directive Options
Related concepts
UDB-VERSION DB2 Directive Option
Related information
UDB-VERSION DB2 Directive Option


VALIDATE

Determines when the database manager checks for authorization errors and object not found errors. The package owner authorization ID is used for validity checking.

Syntax:

VALIDATE={RUN | BIND}
NOVALIDATE

Parameters:

BIND | Validation is performed at precompile/bind time. If all objects do not exist, or all authority is not held, error messages are produced. If sqlerror continue is specified, a package/bind file is produced despite the error message, but the statements in error are not executable.
RUN | Validation is attempted at bind time. If all objects exist, and all authority is held, no further checking is performed at execution time. If all objects do not exist, or all authority is not held at precompile/bind time, warning messages are produced, and the package is successfully bound, regardless of the sqlerror continue option setting. However, authority checking and existence checking for SQL statements that failed these checks during the precompile/bind process may be redone at execution time.

Properties:

Default: NOVALIDATE
Parent topic: DB2 Compiler Directive Options


VERSION

Defines the version identifier for a package. The version identifier is any alphanumeric value, $, #, @, _, -, or ., up to 254 characters in length.

Syntax:

VERSION=version-id
NOVERSION

Properties:

Default: NOVERSION
Parent topic: DB2 Compiler Directive Options


DB2 ECM Error Messages

  • COBDB0002 - COBDB0013
    Lists the DB2 ECM error messages from COBDB0002 through COBDB0013.
  • COBDB0100 - COBDB0115
    Lists the DB2 ECM error messages from COBDB0100 through COBDB0115.
  • COBDB0116 - COBDB0137
    Lists the DB2 ECM error messages from COBDB0116 through COBDB0137.
  • COBDB0900 - COBDB1004
    Lists the DB2 ECM error messages from COBDB0900 through COBDB1004.
Parent topic: DB2


COBDB0002 - COBDB0013

Lists the DB2 ECM error messages from COBDB0002 through COBDB0013.
  • COBDB0002 token is badly defined.
    The preprocessor has encountered a problem with one of the following: SQLCA copybook, SQLCODE field, SQLSTATE field, or MFSQLMESSAGETEXT field.
  • COBDB0003 Program contains more than one definition of field-name
    More than one definition exists for one or more of the following fields: SQLCA, SQLCODE, SQLSTATE or MFSQLMESSAGETEXT.
  • COBDB0004 Nested or multi-source programs not allowed.
    You are trying to compile a program that is nested or multi-source. This is not supported.
  • COBDB0005 An error occurred when processing the internal dictionary.
    A system error has occurred when the preprocessor attempted to create an internal dictionary of all host variables used in the program.
  • COBDB0006 Required DB software token could not be found.
    The required IBM DB2 system software was not installed.
  • COBDB0007 Source file name is invalid.
    A system error has occurred. The source file name passed to the preprocessor is not valid.
  • COBDB0008 MF DB2 Connect program missing or invalid.
    To compile your program, the preprocessor must connect to a DB2 database. The preprocessor uses the Micro Focus DB2 Connect program to do this. The program was not found, was damaged, or is an old version.
  • COBDB0009 MF DB2 Connect program reported error condition token.
    To compile your program, the preprocessor must connect to a DB2 database. The preprocessor uses the Micro Focus DB2 Connect program to do this. An unexpected SQL error was reported when attempting to connect.
  • COBDB0010 DB2 rejected an unspecified option.
    An SQLCODE of -4905 was reported when processing the DB2 compiler directive options specified.
  • COBDB0011 No database name was specified.
    Either you did not specify a database name in your project, or you have not set the DB2DBDFT environment variable to specify a database name.
  • COBDB0012 Functionality only supported in 32-bit mode
    The functionality built into your program or application is supported when running in 32-bit mode only.
  • COBDB0013 Invalid directive token. IBM supports only precompiled code running as native code.
    You have specified the ILGEN compiler directive to compile a native application, or you have specified DB2 compiler directive options to compile a managed code application. DB2 is supported for native applications only.
Parent topic: DB2 ECM Error Messages


COBDB0002 token is badly defined.

The preprocessor has encountered a problem with one of the following: SQLCA copybook, SQLCODE field, SQLSTATE field, or MFSQLMESSAGETEXT field.

The problem could be one of the following:

  • The SQLCA area was defined with total length less than 136 characters
  • The SQLCODE field was not defined as a S9(8) COMP field
  • The SQLSTATE field was not defined as a character field of length 5
  • The MFSQLMESSAGETEXT field was defined with a length greater than 65535 characters
  • One of the previous fields was defined incorrectly

Resolution:

Correct the definition or use the SQLCA copybook provided with Studio Enterprise Edition. If the problem persists, report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: COBDB0002 - COBDB0013
Related concepts
Creating Debug Files
SQL Communications Area (SQLCA)
The SQLCODE Variable
The SQLSTATE Variable


COBDB0003 Program contains more than one definition of field-name

More than one definition exists for one or more of the following fields: SQLCA, SQLCODE, SQLSTATE or MFSQLMESSAGETEXT.

Resolution:

Remove the duplicate definitions and recompile the program.

Parent topic: COBDB0002 - COBDB0013
Related concepts
SQL Communications Area (SQLCA)
The SQLCODE Variable
The SQLSTATE Variable


COBDB0004 Nested or multi-source programs not allowed.

You are trying to compile a program that is nested or multi-source. This is not supported.

Resolution:

Use Micro Focus Net Express if you want to develop applications using nested or multi-source programs.

Parent topic: COBDB0002 - COBDB0013


COBDB0005 An error occurred when processing the internal dictionary.

A system error has occurred when the preprocessor attempted to create an internal dictionary of all host variables used in the program.

Resolution:

Report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: COBDB0002 - COBDB0013
Related concepts
Creating Debug Files
Host Variables


COBDB0006 Required DB software token could not be found.

The required IBM DB2 system software was not installed.

Resolution:

Install one of the required DB2 system software products and then either create or catalog the DB2 database and tables against which to compile the program. If the token is db2agapi then either the DB2 software was not installed or the PATH statement might require modification to include the DB2 installation directory. If the token is db2aprep, be sure that the DB2 Application Development Client software is installed.

Parent topic: COBDB0002 - COBDB0013
Related concepts
Compiling


COBDB0007 Source file name is invalid.

A system error has occurred. The source file name passed to the preprocessor is not valid.

Resolution:

Report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: COBDB0002 - COBDB0013
Related concepts
Creating Debug Files


COBDB0008 MF DB2 Connect program missing or invalid.

To compile your program, the preprocessor must connect to a DB2 database. The preprocessor uses the Micro Focus DB2 Connect program to do this. The program was not found, was damaged, or is an old version.

Resolution:

If you have an old Micro Focus COBOL development system installed, uninstall it. In any case, reinstall Studio Enterprise Edition to ensure that the appropriate version of DB2 Connect is installed.

Parent topic: COBDB0002 - COBDB0013
Related concepts
Compiling Programs That Use a Remote DB2 Server


COBDB0009 MF DB2 Connect program reported error condition token.

To compile your program, the preprocessor must connect to a DB2 database. The preprocessor uses the Micro Focus DB2 Connect program to do this. An unexpected SQL error was reported when attempting to connect.

Resolution:

token is either an internal error or an SQLCODE return code. See the IBM DB2 Error Reference manual for additional information.

Parent topic: COBDB0002 - COBDB0013
Related concepts
The SQLCODE Variable
Compiling Programs That Use a Remote DB2 Server


COBDB0010 DB2 rejected an unspecified option.

An SQLCODE of -4905 was reported when processing the DB2 compiler directive options specified.

Resolution:

Verify that the compiler directive options specified are valid for the DB2 server that you are compiling the program against. Make any corrections necessary and then recompile the program.

Parent topic: COBDB0002 - COBDB0013
Related concepts
The SQLCODE Variable


COBDB0011 No database name was specified.

Either you did not specify a database name in your project, or you have not set the DB2DBDFT environment variable to specify a database name.

Resolution:

Do one of the following:
  • On the SQL tab in your Project Properties:
    • Set the ESQL Preprocessor to DB2/HCO
    • Set the DB directive, specifying the name of your DB2 database as its value
  • Set the DB2DBDFT environment variable value to the name of your DB2 database

Then, recompile the program.

Parent topic: COBDB0002 - COBDB0013
Related reference
Environment Variables: Alphabetical Order


COBDB0012 Functionality only supported in 32-bit mode

The functionality built into your program or application is supported when running in 32-bit mode only.

Resolution:

Run the program or application in 32-bit mode.

Parent topic: COBDB0002 - COBDB0013


COBDB0013 Invalid directive token. IBM supports only precompiled code running as native code.

You have specified the ILGEN compiler directive to compile a native application, or you have specified DB2 compiler directive options to compile a managed code application. DB2 is supported for native applications only.

Resolution:

Recompile using compiler directives appropriate to your application type.

Parent topic: COBDB0002 - COBDB0013
Related reference
ILGEN


COBDB0100 - COBDB0115

Lists the DB2 ECM error messages from COBDB0100 through COBDB0115.
  • COBDB0100 SQL error description
    The preprocessor encountered an SQL error while compiling your program. The SQL error is displayed following this error message.
  • COBDB0101 Statement is too long.
    The SQL statement passed to the preprocessor is longer than 65,536 characters. In this case, the preprocessor receives a compressed version of the SQL statement rather than the original source.
  • COBDB0102 Statement contains too many host variables.
    The SQL statement contains more than 8000 host and indicator variables.
  • COBDB0103 host-var definition does not match the column type associated with it.
    The host variable data definition does not match the column type associated with it in the SQL statement. For example, you would get this error if you use a host variable defined as PIC X(n) with a column defined as SMALLINT.
  • COBDB0104 Bad SQL data declaration.
    An unexpected SQL declaration was passed to the preprocessor.
  • COBDB0105 Syntax error.
    The SQL statement includes invalid syntax or does not include required information.
  • COBDB0106 Filename too long.
    A filename used in the program to specify a copybook or INCLUDE file is more than 260 characters long.
  • COBDB0107 File filename not found.
    The copybook specified in filename was not found.
  • COBDB0108 host-var is non-unique and should be qualified.
    The host variable host-var is not unique and requires that you qualify it.
  • COBDB0109 host-var is not a data item.
    The host variable host-var was not defined or was defined incorrectly.
  • COBDB0110 Statement contains more than one SQLDA.
    More than one SQLDA has been used in the SQL statement.
  • COBDB0111 token is not a table of null indicator variables.
    The preprocessor was expecting token to be either a null indicator or a null indicator table.
  • COBDB0112 host-var should not be defined with an OCCURS clause.
    A host variable is defined as part of an OCCURS clause. The preprocessor does support host variables defined this way.
  • COBDB0113 host-var should not be a subordinate to an item defined with an OCCURS clause.
    A host variable is defined as part of an OCCURS clause or as part of a structure that includes an OCCURS clause. The preprocessor does not support host variables defined this way.
  • COBDB0114 Statement only allowed in the Procedure Division.
    The SQL statement in question was not defined in the Procedure Division.
  • COBDB0115 Statement not allowed in the PROCEDURE DIVISION.
    An SQL statement such as EXEC SQL DECLARE TABLE was coded in the Procedure Division. The preprocessor does not support the SQL statement coded into the Procedure Division.
Parent topic: DB2 ECM Error Messages


COBDB0100 SQL error description

The preprocessor encountered an SQL error while compiling your program. The SQL error is displayed following this error message.

Resolution:

See your IBM SQL Error Message manual for information on the SQL error and how to resolve it.

Parent topic: COBDB0100 - COBDB0115


COBDB0101 Statement is too long.

The SQL statement passed to the preprocessor is longer than 65,536 characters. In this case, the preprocessor receives a compressed version of the SQL statement rather than the original source.

Resolution:

Reduce the statement length to less than 65,536 characters. If the SQL statement contains comments or leading and trailing blanks, consider removing these to shorten the statement length. You can also break the SQL statement into multiple statements. Recompile the program after reducing the statement length to less than 65,536 characters.

Parent topic: COBDB0100 - COBDB0115


COBDB0102 Statement contains too many host variables.

The SQL statement contains more than 8000 host and indicator variables.

Resolution:

Look at breaking the SQL statement into multiple SQL statements and then try recompiling the program.

Parent topic: COBDB0100 - COBDB0115
Related concepts
Host Variables


COBDB0103 host-var definition does not match the column type associated with it.

The host variable data definition does not match the column type associated with it in the SQL statement. For example, you would get this error if you use a host variable defined as PIC X(n) with a column defined as SMALLINT.

Resolution:

Verify that the host variable definition corresponds appropriately to the column definition and make any changes to correct the error. Alternatively use the Host Compatibility Option DCLGEN tool to generate a copybook of the host variable for the SQL table in question.

Parent topic: COBDB0100 - COBDB0115
Related concepts
Host Variables
Related reference
DCLGEN


COBDB0104 Bad SQL data declaration.

An unexpected SQL declaration was passed to the preprocessor.
Generally this error occurs only for host variables defined as:
host-variable-name SQL TYPE IS ....

and the preprocessor has not been set up to handle that definition.

Resolution:

Report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: COBDB0100 - COBDB0115
Related concepts
Creating Debug Files
Host Variables


COBDB0105 Syntax error.

The SQL statement includes invalid syntax or does not include required information.
For example, this error would be generated if you coded:
EXEC SQL INCLUDE END-EXEC

and did not specify the name of the copybook file to INCLUDE.

Resolution:

Correct the SQL statement and recompile the program.

Parent topic: COBDB0100 - COBDB0115


COBDB0106 Filename too long.

A filename used in the program to specify a copybook or INCLUDE file is more than 260 characters long.

Resolution:

Correct the filename and recompile the program

Parent topic: COBDB0100 - COBDB0115


COBDB0107 File filename not found.

The copybook specified in filename was not found.

Either the filename is incorrect, or the path containing the file has not been specified on either the SQLCPY or the COBCPY environment variables.

Resolution:

Do one of the following:
  • Correct the filename.
  • Add the path to the copybook to the COBCPY environment variable. You can do this from your project Properties on the COBOL tab, Advanced Options dialog box. Type the appropriate path into the Additional copybook paths field.
Note: The preprocessor looks first in the current directory, and then down the paths specified by the SQLCPY environment variable, and then the COBCPY environment variable.
Parent topic: COBDB0100 - COBDB0115


COBDB0108 host-var is non-unique and should be qualified.

The host variable host-var is not unique and requires that you qualify it.

Resolution:

Fully qualify a host variable in an SQL query. For example if the ORD-NO host variable exists in both the ORDERS and ITEMS copybooks, and you want the host variable from the ORDERS copybook to be used in the query, specify:
:ORDERS.ORD-NO
Parent topic: COBDB0100 - COBDB0115
Related concepts
Host Variables


COBDB0109 host-var is not a data item.

The host variable host-var was not defined or was defined incorrectly.

Resolution:

Verify that host-var exists. If not, make any changes to correct the error, or use the Host Compatibility Option DCLGEN tool to generate a copybook of the host variable for the SQL table in question.

Parent topic: COBDB0100 - COBDB0115
Related concepts
Host Variables
Related reference
DCLGEN


COBDB0110 Statement contains more than one SQLDA.

More than one SQLDA has been used in the SQL statement.

Resolution:

The preprocessor currently limits you to one SQLDA reference in an SQL statement. For example:
EXEC SQL PREPARE DYNSTMT INTO :SQLDA FROM :SQL-STMT END-EXEC

If this becomes an issue, contact SupportLine.

Parent topic: COBDB0100 - COBDB0115


COBDB0111 token is not a table of null indicator variables.

The preprocessor was expecting token to be either a null indicator or a null indicator table.

Resolution:

Correct the SQL statement and recompile the program. If you are using a null indicator table, make sure you do not use the group name. For example, if the following is a definition of a null indicator table:

01 staff-null-tbl.
03 staff-null-ind occurs 7 times pic s9(04) comp.

you should specify staff-null-ind rather than staff-null-tbl in your query.

Parent topic: COBDB0100 - COBDB0115


COBDB0112 host-var should not be defined with an OCCURS clause.

A host variable is defined as part of an OCCURS clause. The preprocessor does support host variables defined this way.

Resolution:

Modify the code such that the host variable is not defined as part of an OCCURS clause; then recompile the program.

Parent topic: COBDB0100 - COBDB0115
Related concepts
Host Variables


COBDB0113 host-var should not be a subordinate to an item defined with an OCCURS clause.

A host variable is defined as part of an OCCURS clause or as part of a structure that includes an OCCURS clause. The preprocessor does not support host variables defined this way.

Resolution:

Modify the code such that the host variable is not defined as part of an OCCURS clause or as part of a structure that includes an OCCURS clause; then recompile the program.

Parent topic: COBDB0100 - COBDB0115
Related concepts
Host Variables


COBDB0114 Statement only allowed in the Procedure Division.

The SQL statement in question was not defined in the Procedure Division.

Resolution:

Some SQL statements such as UPDATE, DELETE, INSERT, and SELECT..INTO can only be coded in the Procedure Division. Move the statement in question to the Procedure Division and then recompile the program.

Parent topic: COBDB0100 - COBDB0115


COBDB0115 Statement not allowed in the PROCEDURE DIVISION.

An SQL statement such as EXEC SQL DECLARE TABLE was coded in the Procedure Division. The preprocessor does not support the SQL statement coded into the Procedure Division.

Resolution:

Move the SQL statement into the Working-Storage Section and then recompile the program.

Parent topic: COBDB0100 - COBDB0115


COBDB0116 - COBDB0137

Lists the DB2 ECM error messages from COBDB0116 through COBDB0137.
  • COBDB0116 An error occurred when processing the trace file.
    A file error occurred when attempting to write information to the preprocessor trace file.
  • COBDB0117 Invalid format of compound SQL statement.
    The preprocessor could not process a compound SQL statement.
  • COBDB0118 Mismatched DECLARE.
    More than one DECLARE statement was found within an EXEC SQL statement.
  • COBDB0119 Host variable name is too long.
    The host variable name is too long.
  • COBDB0120 Internal error - dictionary handle is too big.
    The preprocessor creates an internal dictionary of all host variables used in a program. When building the dictionary, a system error occurred.
  • COBDB0121 Package name is too long.
    The package name specified is longer than 128 characters. If you did not specify an explicit package name via the ACCESS DB2 compiler directive option, the preprocessor defaults to using the filename of the program being compiled. If the program name is more than 128 characters, this error message is generated.
  • COBDB0122 Nested INCLUDEs not supported
    The DB2 ECM does not support EXEC SQL INCLUDE statements that expand an EXEC SQL INCLUDE statement.
  • COBDB0127 Parentheses are illegal in the INTO clause.
    A left parenthesis, (, was found in the INTO clause of an SQL statement. The preprocessor does not support parentheses in INTO clauses.
  • COBDB0131 SQLCA or SQLCODE not found.
    An SQLCA or SQLCODE was not found in the Working-Storage Section or Linkage Section.
  • COBDB0137 Indicator variable ind-var is not SMALLINT type.
    The indicator variable data definition does not match the data type associated with it in the SQL statement.
Parent topic: DB2 ECM Error Messages


COBDB0116 An error occurred when processing the trace file.

A file error occurred when attempting to write information to the preprocessor trace file.

Resolution:

Make sure you have write authority directory where the file is being written, and that you have sufficient disk space.

Parent topic: COBDB0116 - COBDB0137


COBDB0117 Invalid format of compound SQL statement.

The preprocessor could not process a compound SQL statement.

Resolution:

Modify the code to correct the invalid compound SQL statement. See the IBM SQL Reference for details.

Note: This condition is non-recoverable; subsequent valid SQL statements could generate spurious errors. Compound SQL statements contain multiple SQL statements that could each generate an error message after this error.
Parent topic: COBDB0116 - COBDB0137


COBDB0118 Mismatched DECLARE.

More than one DECLARE statement was found within an EXEC SQL statement.

Resolution:

Correct the statement and recompile the program.

Parent topic: COBDB0116 - COBDB0137


COBDB0119 Host variable name is too long.

The host variable name is too long.

If you are using a version of DB2 before DB2 LUW V5, the maximum length of the host variable is 30 characters. The preprocessor automatically adds 3 characters to a host variable name to make it unique unless you specify directive DB2(NOQUALFIX) to turn this feature off.

Resolution:

Specify the DB2(NOQUALFIX) compiler directive, and recompile the program. If you still get the error, make sure the host variable is a valid COBOL name of 30 characters or less in length.

Parent topic: COBDB0116 - COBDB0137
Related concepts
Host Variables
Related reference
QUALFIX


COBDB0120 Internal error - dictionary handle is too big.

The preprocessor creates an internal dictionary of all host variables used in a program. When building the dictionary, a system error occurred.

Resolution:

Report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

We also suggest that you be prepared to provide your SupportLine representative with enough information (e.g., program source, etc.) to recreate the error.

Parent topic: COBDB0116 - COBDB0137
Related concepts
Creating Debug Files
Host Variables


COBDB0121 Package name is too long.

The package name specified is longer than 128 characters. If you did not specify an explicit package name via the ACCESS DB2 compiler directive option, the preprocessor defaults to using the filename of the program being compiled. If the program name is more than 128 characters, this error message is generated.

Resolution:

Specify a package name using the DB2(ACCESS=packageName) compiler directive, where packageName is 128 characters or fewer.

Parent topic: COBDB0116 - COBDB0137
Related reference
ACCESS


COBDB0122 Nested INCLUDEs not supported

The DB2 ECM does not support EXEC SQL INCLUDE statements that expand an EXEC SQL INCLUDE statement.

Resolution:

Remove EXEC SQL INCLUDE statements that expand an EXEC SQL INCLUDE statement; then recompile the program.

Parent topic: COBDB0116 - COBDB0137


COBDB0127 Parentheses are illegal in the INTO clause.

A left parenthesis, (, was found in the INTO clause of an SQL statement. The preprocessor does not support parentheses in INTO clauses.

Resolution:

Correct the syntax and recompile your program. See the IBM SQL Reference for the correct syntax.

Parent topic: COBDB0116 - COBDB0137


COBDB0131 SQLCA or SQLCODE not found.

An SQLCA or SQLCODE was not found in the Working-Storage Section or Linkage Section.

Resolution:

Check to see if an SQLCA is included and declared correctly.

Parent topic: COBDB0116 - COBDB0137
Related concepts
SQL Communications Area (SQLCA)
The SQLCODE Variable


COBDB0137 Indicator variable ind-var is not SMALLINT type.

The indicator variable data definition does not match the data type associated with it in the SQL statement.

Resolution:

Correct the picture clause for the indicator variable identified in the error message and recompile the program. For example, define your indicator variable as PIC X(n) rather than PIC S9(04) COMP.

Parent topic: COBDB0116 - COBDB0137
Related concepts
Indicator Variables


COBDB0900 - COBDB1004

Lists the DB2 ECM error messages from COBDB0900 through COBDB1004.
  • COBDB0900 An internal error occurred.
    An unexpected error occurred in the preprocessor.
  • COBDB0901 SQL processing cannot continue.
    A severe SQL error has occurred. Any subsequent EXEC SQL statements are not processed by the preprocessor.
  • COBDB0902 An internal error occurred.
    An unexpected error occurred in the preprocessor. This applies to PL/I only.
  • COBDB1000 Use of EXEC SQL INCLUDE SQLCA END-EXEC.
    A warning that certifies the preprocessor as ANSI compliant.
  • COBDB1001 MF DB2 Connect program produced the warning token.
    While precompiling the program, the Micro Focus DB2 Connect software returned a warning token when attempting to connect to the DB2 server specified in the DB2(DB) directive.
  • COBDB1002 Statement is not in area B.
    An EXEC SQL statement starts before column 12.
  • COBDB1004 INVALID SQL STATEMENT - statement ignored.
    The program was compiled with the DB2(GEN-SQLCA) directive, but includes an EXEC SQL INCLUDE SQLCA statement.
Parent topic: DB2 ECM Error Messages


COBDB0900 An internal error occurred.

An unexpected error occurred in the preprocessor.

Resolution:

Create a trace file using the CHKECM(TRACE) compiler directive, and contact SupportLine. See Creating Debug Files for additional details on how to create a trace file.

Parent topic: COBDB0900 - COBDB1004
Related concepts
Creating Debug Files


COBDB0901 SQL processing cannot continue.

A severe SQL error has occurred. Any subsequent EXEC SQL statements are not processed by the preprocessor.

Resolution:

Report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: COBDB0900 - COBDB1004
Related concepts
Creating Debug Files


COBDB0902 An internal error occurred.

An unexpected error occurred in the preprocessor. This applies to PL/I only.

Resolution:

Report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: COBDB0900 - COBDB1004
Related concepts
Creating Debug Files


COBDB1000 Use of EXEC SQL INCLUDE SQLCA END-EXEC.

A warning that certifies the preprocessor as ANSI compliant.

Resolution:

On the COBOL tab in your Project Properties, set the Warning level to Severe errors only (Level S).

Parent topic: COBDB0900 - COBDB1004
Related concepts
SQL Communications Area (SQLCA)


COBDB1001 MF DB2 Connect program produced the warning token.

While precompiling the program, the Micro Focus DB2 Connect software returned a warning token when attempting to connect to the DB2 server specified in the DB2(DB) directive.

Resolution:

Verify that your DB2 software is installed correctly and that you can connect to the DB2 server specified. If the problem persists, report this error to SupportLine. We suggest that you have trace files available to help SupportLine to resolve this problem. See Creating Debug Files for details on how to create these trace files.

Parent topic: COBDB0900 - COBDB1004
Related concepts
Creating Debug Files
Compiling Programs That Use a Remote DB2 Server


COBDB1002 Statement is not in area B.

An EXEC SQL statement starts before column 12.

Resolution:

Move the EXEC SQL statement so that it starts after column 12.

Parent topic: COBDB0900 - COBDB1004


COBDB1004 INVALID SQL STATEMENT - statement ignored.

The program was compiled with the DB2(GEN-SQLCA) directive, but includes an EXEC SQL INCLUDE SQLCA statement.

Resolution:

Compile the program without the DB2(GEN-SQLCA) directive or remove the EXEC SQL INCLUDE SQLCA statement.

Parent topic: COBDB0900 - COBDB1004
Related concepts
SQL Communications Area (SQLCA)
Related reference
GEN-SQLCA


COBSQL

  • COBSQL Compiler Directive Options
  • COBSQL Messages
Parent topic: Reference


COBSQL Compiler Directive Options

  • COBSQLTYPE
    Specifies which precompiler to use.
  • CSTART
    Forces COBSQL to load the database support modules at execution time.
  • CSTOP
    Forces COBSQL to load the stop run module that performs a rollback if the application terminates abnormally
  • DEBUGFILE
    Creates a debug (.deb) file
  • DISPLAY
    Displays precompiler statistics. Should only be used when initially verifying that COBSQL is correctly calling the standalone precompiler.
  • END-COBSQL
    Signals the end of COBSQL directives; remaining directives, if any, are passed to the precompiler
  • HSFTRACE
    Generates calls around each SQL statement to the HSF trace routine if the application is running under Enterprise Server. In some cases, the application must be linked with mfsqlSMF.lib.
  • KEEPCBL
    Saves precompiled source file (.cbl)
  • MAKESYN
    Converts all COMP host variables to COMP-5 host variables. If neither MAKESYN nor NOMAKESYN is set (the default), all variables (not just host variables) defined as COMP or COMP-4 are converted to COMP-5.
  • SQLDEBUG
    Creates a number of files that we can use to debug COBSQL. These files include the output file from the precompiler (normally this has the extension .cbl), the listing file produced by the precompiler (this has the extension .lis), plus a COBSQL debug file which has the extension .sdb. SQLDEBUG will also turn on KEEPCBL and TRACE.
  • TRACE
  • VERBOSE
    Displays all precompiler messages and gives status updates as the program is processed. You should only use this when initially verifying that COBSQL is calling the standalone precompiler correctly.
Parent topic: COBSQL


COBSQLTYPE

Specifies which precompiler to use.

Syntax:

COBSQLTYPE={ORACLE | ORACLE8 | SYBASE | INFORMIX-NEW}

Properties:

Synonym: CSQLT
Parent topic: COBSQL Compiler Directive Options


CSTART

Forces COBSQL to load the database support modules at execution time.

Syntax:

[NO]CSTART

Properties:

Default: | NOCSTART
Synonym: | CST

Comments:

This directive is not available on UNIX.

Parent topic: COBSQL Compiler Directive Options


CSTOP

Forces COBSQL to load the stop run module that performs a rollback if the application terminates abnormally

Syntax:

[NO]CSTOP

Properties:

Default: | NOCSTOP
Synonym: | CSP

Comments:

This directive is not available on UNIX.

Parent topic: COBSQL Compiler Directive Options


DEBUGFILE

Creates a debug (.deb) file

Syntax:

[NO]DEBUGFILE

Properties:

Default: | NODEBUGFILE
Synonym: | DEB
Parent topic: COBSQL Compiler Directive Options


DISPLAY

Displays precompiler statistics. Should only be used when initially verifying that COBSQL is correctly calling the standalone precompiler.

Syntax:

[NO]DISPLAY

Properties:

Default: | NODISPLAY
Synonym: | DIS
Parent topic: COBSQL Compiler Directive Options


END-COBSQL

Signals the end of COBSQL directives; remaining directives, if any, are passed to the precompiler

Syntax:

END-COBSQL
END-C
END

Properties:

Default: | Not specified
Synonyms: | END-C, END
Parent topic: COBSQL Compiler Directive Options


KEEPCBL

Saves precompiled source file (.cbl)

Syntax:

KEEPCBL
Parent topic: COBSQL Compiler Directive Options


MAKESYN

Converts all COMP host variables to COMP-5 host variables. If neither MAKESYN nor NOMAKESYN is set (the default), all variables (not just host variables) defined as COMP or COMP-4 are converted to COMP-5.

Syntax:

[NO]MAKESYN

Properties:

Default: NOMAKESYN
Parent topic: COBSQL Compiler Directive Options


SQLDEBUG

Creates a number of files that we can use to debug COBSQL. These files include the output file from the precompiler (normally this has the extension .cbl), the listing file produced by the precompiler (this has the extension .lis), plus a COBSQL debug file which has the extension .sdb. SQLDEBUG will also turn on KEEPCBL and TRACE.

Syntax:

SQLDEBUG

Properties:

Default: | Not specified
Synonym: | SQLDEBUG
Parent topic: COBSQL Compiler Directive Options


TRACE

Syntax:

[NO]TRACE

Properties:

Default: | NOTRACE
Synonym: | Creates a trace file (.trc)
Parent topic: COBSQL Compiler Directive Options


VERBOSE

Displays all precompiler messages and gives status updates as the program is processed. You should only use this when initially verifying that COBSQL is calling the standalone precompiler correctly.

Syntax:

VERBOSE

Properties:

Default: Not specified
Parent topic: COBSQL Compiler Directive Options


COBSQL Messages

COBSQL displays four different types of message. These are as follows:

  • Banner Information

    As COBSQL starts, it displays three banner lines which include the COBSQL version number.

  • Precompiler Information

    The database precompilers produce information about the program that they are compiling. If the COBSQL "Verbose" or "Display" directives are used, then COBSQL will display this information.

  • Precompiler Errors

    All the database precompilers produce error messages. These messages range from those that are displayed for information only to those describing fatal errors. COBSQL attempts to identify the severity of the errors passed to it by the precompiler. It also extracts the precompiler error number and text and attempts to locate the source line on which the error occurred. The format of precompiler error messages is as follows:

    precompiler-error-no. severity precompiler-error-text

    The precompiler error message is passed to the COBOL Compiler after the source line that the error occurred on, allowing the COBOL Compiler to identify the source line that the error occurred on.

    If COBSQL cannot determine the severity of the error passed by the precompiler, it will assume that it is a normal error, rather than a fatal error.

  • COBSQL Errors

    COBSQL itself produces four types of message: information only, warning, error or fatal. Most are fatal. The format of COBSQL errors is as follows:

    * CSQL-severity-errorno.: error- text

  • CSQL-I-001 to CSQL-E-023
    Lists the COBSQL messages from CSQL-I-001 through CSQL-E-023.
  • CSQL-E-024 to CSQL-F-046
    Lists the COBSQL messages from CSQL-E-024 through CSQL-F-046.
Parent topic: COBSQL


CSQL-I-001 to CSQL-E-023

Lists the COBSQL messages from CSQL-I-001 through CSQL-E-023.
  • CSQL-I-001: COBSQL has finished returning to the Checker
    This message is for information only. COBSQL has successfully processed the source file and has passed all the necessary information back to the COBOL Compiler. The program can now be animated or executed.
  • CSQL-I-003: COBSQLTYPE is incorrect defaulting to Oracle
    This message is for information only. COBSQL defaults to using the Oracle precompiler if the COBSQLTYPE directive is not set, is set incorrectly, or is set to an obsolete value.
  • CSQL-I-004: Accepted COBSQL-directive
    COBSQL displays this message to confirm that a directive is valid.
  • CSQL-I-005: Passing precompiler-directive
    COBSQL has encountered directives after the END-COBSQL directive. These directives are for the database precompiler and COBSQL will pass them on. This message is only displayed if the CONFIRM directive is set.
  • CSQL-I-006: Rejected COBSQL-directive
    COBSQL has encountered an invalid directive. Either the directive is incorrect or the value supplied for the directive is incorrect.
  • CSQL-F-007: COBSQL/Checker incompatible -- Terminating
    When COBSQL has to interact with other COBOL Integrated Preprocessors (for example, CP or HTMLPP), it needs to make sure that the subordinate preprocessor(s) are using the same line buffer size as COBSQL. If they are not, this error message is generated.
  • CSQL-I-008: Invoking integrated-preprocessor Preprocessor
    This message is displayed when other Integrated Preprocessors are to be invoked. It is for information only.
  • CSQL-F-009: Irrecoverable error in integrated-preprocessor -- Terminating
    The Integrated Preprocessor that COBSQL invoked has returned a fatal error message. COBSQL passes this message to the COBOL Compiler and aborts.
  • CSQL-F-010: Irrecoverable error writing STK record
    In a stacked environment (for example when COBSQL invokes another Integrated Preprocessor such as CP), COBSQL stores information returned from the other Integrated Preprocessor in a side file that has an extension of STK. The file has the same basename as the input file.
  • CSQL-F-011: Environment unsupported by COBSQL/Informix
    COBSQL is being run with a version of COBOL for which, to the best of our knowledge, no Informix COBOL precompiler is available. This message is also displayed if the wrong Informix COBSQLTYPE is specified for the COBOL release that COBSQL is running with.
  • CSQL-F-012: INFORMIXDIR must be set for Informix Support
    To be able to use the Informix Precompiler, the environment variable INFORMIXDIR must be set. COBSQL uses the value of the INFORMIXDIR environment variable to locate the ESQL/COBOL precompiler.
  • CSQL-F-013: Unable to access: filename
    This error can occur when COBSQL tries to open the source code file, or tries to process a copy statement in the expanded code.
  • CSQL-F-015: DOS Exec error Return Code is return-code
    COBSQL has attempted to invoke the database precompiler and has been unsuccessful. There are a number of possible reasons for this.
  • CSQL-F-016: UNIX Exec error Return Code is Return-Code
    This message is displayed when running under UNIX. On UNIX this is not a fatal error. If a database precompiler came across errors in the source file, it is likely it would produce a non-zero return code. Because this might happen, COBSQL will continue after displaying this message.
  • CSQL-I-017: Creating filename
    COBSQL displays this message, for information only, when the expanded source file is to be kept.
  • CSQL-I-018: Invoking precompiler Precompiler/Translator
    COBSQL displays this message, for information only, to let the user know which database precompiler is about to be called.
  • CSQL-F-019: Irrecoverable error Opening STK file
    COBSQL has attempted to open the STK side file. This file is only used when COBSQL is stacked with other Integrated Precompilers.
  • CSQL-I-020: Processing output of precompiler Precompiler
    COBSQL displays this message once it has successfully called the database precompiler and is about to start processing the expanded code.
  • CSQL-F-021: Precompiler did not complete -- Terminating
    After calling the database precompiler COBSQL checks to make sure that it completed. It does this by trying to open the files that the precompiler should have produced. If it cannot open the files, it reports this error.
  • CSQL-F-022: Irrecoverable error Reopening ORG file
    As part of the processing performed after the database precompiler has completed, COBSQL reopens the original source code file. If COBSQL cannot open the file, it displays this error message.
  • CSQL-E-023: File Status file-status
    COBSQL displays this error message after a file operation has failed. This message is normally preceded by another COBSQL error message identifying the file in error.
Parent topic: COBSQL Messages


CSQL-I-001: COBSQL has finished returning to the Checker

This message is for information only. COBSQL has successfully processed the source file and has passed all the necessary information back to the COBOL Compiler. The program can now be animated or executed.

If any errors have been found, these will be highlighted in the source and the error text will be made available.

Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-I-003: COBSQLTYPE is incorrect defaulting to Oracle

This message is for information only. COBSQL defaults to using the Oracle precompiler if the COBSQLTYPE directive is not set, is set incorrectly, or is set to an obsolete value.

This message is displayed if the last COBSQLTYPE directive has an incorrect value.

COBSQL attempts to invoke the Oracle precompiler. This will cause further errors if the Oracle precompiler is not present.

Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-I-004: Accepted COBSQL-directive

COBSQL displays this message to confirm that a directive is valid.
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-I-005: Passing precompiler-directive

COBSQL has encountered directives after the END-COBSQL directive. These directives are for the database precompiler and COBSQL will pass them on. This message is only displayed if the CONFIRM directive is set.
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-I-006: Rejected COBSQL-directive

COBSQL has encountered an invalid directive. Either the directive is incorrect or the value supplied for the directive is incorrect.
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-F-007: COBSQL/Checker incompatible -- Terminating

When COBSQL has to interact with other COBOL Integrated Preprocessors (for example, CP or HTMLPP), it needs to make sure that the subordinate preprocessor(s) are using the same line buffer size as COBSQL. If they are not, this error message is generated.

Under normal execution, this message should not appear. If it does, it indicates that an old version of COBSQL is being used with a new Integrated Preprocessor, or vice versa.

Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-I-008: Invoking integrated-preprocessor Preprocessor

This message is displayed when other Integrated Preprocessors are to be invoked. It is for information only.
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-F-009: Irrecoverable error in integrated-preprocessor -- Terminating

The Integrated Preprocessor that COBSQL invoked has returned a fatal error message. COBSQL passes this message to the COBOL Compiler and aborts.

For more information about what might have caused the other Integrated Preprocessor to abort, refer to its documentation.

Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-F-010: Irrecoverable error writing STK record

In a stacked environment (for example when COBSQL invokes another Integrated Preprocessor such as CP), COBSQL stores information returned from the other Integrated Preprocessor in a side file that has an extension of STK. The file has the same basename as the input file.

This message is displayed if COBSQL receives a COBOL error while trying to write out a record to the STK side file. COBSQL also displays error message CSQL-E-023 (file I/O error) giving the COBOL I/O error message.

Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-F-011: Environment unsupported by COBSQL/Informix

COBSQL is being run with a version of COBOL for which, to the best of our knowledge, no Informix COBOL precompiler is available. This message is also displayed if the wrong Informix COBSQLTYPE is specified for the COBOL release that COBSQL is running with.
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-F-012: INFORMIXDIR must be set for Informix Support

To be able to use the Informix Precompiler, the environment variable INFORMIXDIR must be set. COBSQL uses the value of the INFORMIXDIR environment variable to locate the ESQL/COBOL precompiler.
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-F-013: Unable to access: filename

This error can occur when COBSQL tries to open the source code file, or tries to process a copy statement in the expanded code.

COBSQL attempts to open the source file before it invokes the database precompiler. If it cannot open the file, it will report this error.

This error may also be displayed if COBSQL cannot open a copybook that appears in the expanded source code. COBSQL needs to process copy statements that are inserted by the database precompiler. If COBSQL did not do this, the COBOL Compiler would treat the copy statement as though it appeared in the original source, and expand it.

Once COBSQL has displayed this error, it will also display error message CSQL-E-023 (file I/O error) giving the COBOL I/O error message.

Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-F-015: DOS Exec error Return Code is return-code

COBSQL has attempted to invoke the database precompiler and has been unsuccessful. There are a number of possible reasons for this.

You should check the following:

  • Has the database precompiler been installed?
  • Can the database precompiler be run on this machine/OS?
  • Is the database precompiler on the PATH?
  • Is there enough memory to execute the database precompiler?
  • Has COBSQLTYPE been set correctly?
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-F-016: UNIX Exec error Return Code is Return-Code

This message is displayed when running under UNIX. On UNIX this is not a fatal error. If a database precompiler came across errors in the source file, it is likely it would produce a non-zero return code. Because this might happen, COBSQL will continue after displaying this message.
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-I-017: Creating filename

COBSQL displays this message, for information only, when the expanded source file is to be kept.
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-I-018: Invoking precompiler Precompiler/Translator

COBSQL displays this message, for information only, to let the user know which database precompiler is about to be called.
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-F-019: Irrecoverable error Opening STK file

COBSQL has attempted to open the STK side file. This file is only used when COBSQL is stacked with other Integrated Precompilers.

COBSQL also displays error message CSQL-E-023 (file I/O error) giving the COBOL I/O error message.

Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-I-020: Processing output of precompiler Precompiler

COBSQL displays this message once it has successfully called the database precompiler and is about to start processing the expanded code.
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-F-021: Precompiler did not complete -- Terminating

After calling the database precompiler COBSQL checks to make sure that it completed. It does this by trying to open the files that the precompiler should have produced. If it cannot open the files, it reports this error.

If this message is displayed and the precompiler has created both a listing file and the expanded source code, then either COBSQL does not have read permissions on the files, or they have been created in the wrong directory. Ensure that the current directory is set correctly before running COBSQL.

Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-F-022: Irrecoverable error Reopening ORG file

As part of the processing performed after the database precompiler has completed, COBSQL reopens the original source code file. If COBSQL cannot open the file, it displays this error message.

COBSQL also displays error message CSQL-E-023 (file I/O error) giving the COBOL I/O error message.

Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-E-023: File Status file-status

COBSQL displays this error message after a file operation has failed. This message is normally preceded by another COBSQL error message identifying the file in error.
Parent topic: CSQL-I-001 to CSQL-E-023


CSQL-E-024 to CSQL-F-046

Lists the COBSQL messages from CSQL-E-024 through CSQL-F-046.
  • CSQL-E-024: Encountered an I/O on file filename
    This message is displayed when a write error occurs on either the trace or the debug file.
  • CSQL-F-025: Unable to Create virtual-heap
    To process the source file and the expanded code, COBSQL needs to create a number of virtual heaps. If there is a problem when COBSQL tries to create a heap, this message is displayed indicating which heap COBSQL had problems creating.
  • CSQL-F-026: Premature end of expanded source. Check for precompiler abort when run standalone. This error is unrecoverable. Hit any key to abort Source Lines could not be matched by COBSQL. COBSQL was processing: area-of-code Source lines around line in error are lines-of source-code
  • CSQL-I-027: Detected Working Section, now processing it
    This message is displayed, for information only, when COBSQL is running in VERBOSE mode. It indicates that COBSQL has encountered the Working Storage Section and is about to process it.
  • CSQL-I-028: Now processing through Procedure Division
    This message is displayed, for information only, when COBSQL is running in VERBOSE mode. It indicates that COBSQL has encountered the Procedure Division and is about to process it.
  • CSQL-I-029: Found an EXEC SQL Statement, processing it
    This message is displayed, for information only, when COBSQL is running in VERBOSE mode. It indicates that COBSQL has encountered an EXEC SQL statement within the procedure division of a program and is about to process it.
  • CSQL-E-036: Unable to open the precompiler file: filename
    As part of the processing performed after the database precompiler has completed, COBSQL opens the expanded source code file. If COBSQL cannot open the file, it displays this message.
  • CSQL-F-037: Wrong Version of COBOL used, please upgrade
    COBSQL is being run with an old version of COBOL and will not work correctly. Because of this, COBSQL terminates rather than trying to continue.
  • CSQL-I-038: The following directive is now Obsolete: COBSQL-directive
    COBSQL has encountered a directive that is now marked as obsolete.
  • CSQL-I-039: The ORG & the CBL files were out of synch
    COBSQL sometimes tries to re-position itself when working through the original source file (ORG) and the source produced by the database precompiler (CBL). It does this by scanning ahead in the CBL file to try to find a matching line. If it does, it displays this message.
  • CSQL-W-040: Pro*COBOL commented out the following line: source-line
    Pro*COBOL has commented out a line of code that was not a part of an EXEC SQL statement. This may alter the way that the program executes and care should be taken if the application is run.
  • CSQL-F-041: Cannot read the COBOL runtime switches
    COBSQL tries to determine how the current run-time is configured by examining the settings of the run-time switches. This error is displayed if COBSQL cannot read the current settings.
  • CSQL-F-042: Cannot set the COBOL runtime switches
    Some external code generators produce COBOL code which contains null characters. COBSQL reads the settings of the run-time switches and attempts to change the settings of the relevant switches in order to enable it to read code containing null characters.
  • CSQL-F-046: Command line is too large. Maximum length is 1140 characters
    Your command line length has exceeded the 1140-character limit.
  • CSQL-F-047: Cobsql cannot be used with the SOURCEFORMAT directive.
    You have specified the SOURCEFORMAT(FIXED) directive along with one or more other SOURCEFORMAT directives. COBSQL supports the SOURCEFORMAT(FIXED) directive only when no other SOURCEFORMAT directives are specified.
  • CSQL-F-048: Cobsql is not supported for use with managed code.
    You have attempted to compile a managed code application using COBSQL.
Parent topic: COBSQL Messages


CSQL-E-024: Encountered an I/O on file filename

This message is displayed when a write error occurs on either the trace or the debug file.

COBSQL also displays error message CSQL-E-023 (file I/O error) giving the COBOL I/O error message.

Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-F-025: Unable to Create virtual-heap

To process the source file and the expanded code, COBSQL needs to create a number of virtual heaps. If there is a problem when COBSQL tries to create a heap, this message is displayed indicating which heap COBSQL had problems creating.

The most likely cause of this problem is that not enough memory is available or that too many virtual heaps have already been created. The solution is to close down some COBOL applications to free up memory or virtual file slots.

Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-F-026: Premature end of expanded source. Check for precompiler abort when run standalone. This error is unrecoverable. Hit any key to abort Source Lines could not be matched by COBSQL. COBSQL was processing: area-of-code Source lines around line in error are lines-of source-code

  1. The precompiler could not complete the creation of the expanded source code.
  2. COBSQL found a mismatch between a line in the original source code and the expanded source code.

Of these two options, number two is the more likely.

The item area-of-code corresponds to the position within the original source code that COBSQL was processing. These areas include Working-Storage, Procedure Division and SQL statements.

The item lines-of source-code identifies the original source code lines that COBSQL was processing. These are displayed as they can indicate where the problem lies in the original source code.

Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-I-027: Detected Working Section, now processing it

This message is displayed, for information only, when COBSQL is running in VERBOSE mode. It indicates that COBSQL has encountered the Working Storage Section and is about to process it.
Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-I-028: Now processing through Procedure Division

This message is displayed, for information only, when COBSQL is running in VERBOSE mode. It indicates that COBSQL has encountered the Procedure Division and is about to process it.
Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-I-029: Found an EXEC SQL Statement, processing it

This message is displayed, for information only, when COBSQL is running in VERBOSE mode. It indicates that COBSQL has encountered an EXEC SQL statement within the procedure division of a program and is about to process it.
Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-E-036: Unable to open the precompiler file: filename

As part of the processing performed after the database precompiler has completed, COBSQL opens the expanded source code file. If COBSQL cannot open the file, it displays this message.

COBSQL also displays error message CSQL-E-023 (file I/O error) giving the COBOL I/O error message.

Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-F-037: Wrong Version of COBOL used, please upgrade

COBSQL is being run with an old version of COBOL and will not work correctly. Because of this, COBSQL terminates rather than trying to continue.
Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-I-038: The following directive is now Obsolete: COBSQL-directive

COBSQL has encountered a directive that is now marked as obsolete.
Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-I-039: The ORG & the CBL files were out of synch

COBSQL sometimes tries to re-position itself when working through the original source file (ORG) and the source produced by the database precompiler (CBL). It does this by scanning ahead in the CBL file to try to find a matching line. If it does, it displays this message.

The usual reason for a mismatch between the two source files is that the precompiler has produced code that COBSQL is not able to cope with. Until COBSQL is altered to cope with this, using the SQLDEBUG directive provides a temporary work-around.

The code produced when this message has been displayed may not function correctly because some of the original source may have been removed so that COBSQL can re-position itself.

Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-W-040: Pro*COBOL commented out the following line: source-line

Pro*COBOL has commented out a line of code that was not a part of an EXEC SQL statement. This may alter the way that the program executes and care should be taken if the application is run.
Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-F-041: Cannot read the COBOL runtime switches

COBSQL tries to determine how the current run-time is configured by examining the settings of the run-time switches. This error is displayed if COBSQL cannot read the current settings.

This error causes COBSQL to abort.

Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-F-042: Cannot set the COBOL runtime switches

Some external code generators produce COBOL code which contains null characters. COBSQL reads the settings of the run-time switches and attempts to change the settings of the relevant switches in order to enable it to read code containing null characters.

This message is displayed if COBSQL has successfully read the run-time switches but has failed in its attempt to set them.

Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-F-046: Command line is too large. Maximum length is 1140 characters

Your command line length has exceeded the 1140-character limit.

Resolution:

To reduce the number of characters on your command line, place parameters used by your DBMS precompiler into its appropriate configuration file rather than specifying the parameters on the command line. See the documentation for your DBMS for more information.

Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-F-047: Cobsql cannot be used with the SOURCEFORMAT directive.

You have specified the SOURCEFORMAT(FIXED) directive along with one or more other SOURCEFORMAT directives. COBSQL supports the SOURCEFORMAT(FIXED) directive only when no other SOURCEFORMAT directives are specified.

Resolution:

Remove the additional SOURCEFORMAT directive(s).

Parent topic: CSQL-E-024 to CSQL-F-046


CSQL-F-048: Cobsql is not supported for use with managed code.

You have attempted to compile a managed code application using COBSQL.

Resolution:

Recompile your application as native code.

Parent topic: CSQL-E-024 to CSQL-F-046


SQL Data Types

  • Integer Data Types
  • Character Data Types
  • Numeric Data Types
  • Binary Data Types
  • Date and Time Data Types
  • Locator Data Types
  • File Data Types
  • Miscellaneous Data Types
Parent topic: Reference
Related concepts
.NET Host Variables in Managed Code
COBOL to SQL Data Type Mapping
SQL Data Types


Integer Data Types

  • Tiny Integer
  • Small Integer
  • Integer
  • Big Integer
Parent topic: SQL Data Types


Tiny Integer

A tiny integer (TINYINT) is a 1-byte integer SQL data type.

Host Variable Formats

OpenESQL .NET Managed Runtime
01 tinyint1          PIC S9(2) COMP-5.
01 tinyint2          PIC S9(2) COMP.
01 tinyint3          PIC S9(2) BINARY.
01 tinyint4          PIC X     COMP-5.
01 tinyint5          PIC 9(2)  COMP-X.
01 tinyint6          binary-char.
Parent topic: Integer Data Types


Small Integer

A small integer (SMALLINT) is a 2-byte integer SQL data type.

Host Variable Formats

OpenESQL and DB2 ECM
01 shortint1      PIC S9(4)  COMP.
01 shortint2      PIC S9(4)  COMP-4.
01 shortint3      PIC X(2)   COMP-5.
01 shortint4      PIC S9(4)  COMP-5.
01 shortint5      PIC X(2)   COMP-X.
01 shortint6      PIC 9(4)   COMP-X.
01 shortint7      PIC S9(4)  BINARY.
OpenESQL .NET Managed Runtime
In addition to the definitions valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 shortint10     binary-short.
Parent topic: Integer Data Types


Integer

An integer (INT) is a 4-byte integer SQL data type.

Host Variable Formats

OpenESQL and DB2 ECM
All of the following definitions are valid for host variables to map directly onto the INT data type.
01 longint1      PIC S9(9)  COMP.
01 longint2      PIC X(4)   COMP-5.
01 longint3      PIC S9(9)  COMP-5.
01 longint4      PIC X(4)   COMP-X.
01 longint5      PIC 9(9)   COMP-X.
01 longint6      PIC S9(9)  BINARY.

For the most efficient access, we recommend that you declare integers as COMP-5.

OpenESQL .NET Managed Runtime
In addition to the definitions valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 longint9      binary-long.
Parent topic: Integer Data Types


Big Integer

A big integer (BIGINT) is an 8-byte integer SQL data type.

Host Variable Formats

OpenESQL and DB2 ECM
01 bigint1      PIC S9(18)  COMP-3.
01 bigint2      PIC S9(18)  COMP-5.
OpenESQL
01 bigint3      PIC X(8)    COMP-5.
01 bigint4      PIC X(8)    COMP-X.
In non-COBOL applications, a BIGINT data type can hold a value larger than PIC S9(18). If you define your host variable for a COBOL data time with a value larger than S9(18), your data might be truncated.
OpenESQL .NET Managed Runtime
In addition to the definitions valid OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 bigint5     binary-double.
Parent topic: Integer Data Types


Character Data Types

  • Fixed-length Character Strings
  • Variable-length Character Strings
  • Large Character Strings (CLOB)
  • Unicode Character Strings
  • Unicode Variable-length Character Strings
  • Unicode Large Character Strings (DBCLOB)
  • XML
Parent topic: SQL Data Types


Fixed-length Character Strings

Fixed-length character strings (CHAR) are SQL data types with a driver-defined maximum length. They are declared in COBOL as:
PIC X(n)
where n is an integer between 1 and the maximum length.

Host Variable Formats

OpenESQL and DB2 ECM
01 char-field1      PIC X(5).
01 char-field2      PIC X(254).

The largest supported fixed length character string is 254 bytes for the DB2 ECM. If you need a character string greater than 254 bytes in length, use a VARCHAR field.

OpenESQL
01 char-field3      SQL TYPE IS CHAR(200).

The char-field3 format uses the CHAR SQL TYPE.

OpenESQL .NET Managed Runtime
In addition to the definitions valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 char-net         string(200).
Parent topic: Character Data Types
Related reference
CHAR SQL Type


Variable-length Character Strings

Variable-length character strings (VARCHAR and LONGVARCHAR) are SQL data types with a variable maximum length.

Host Variable Formats

OpenESQL and DB2 ECM
01 varchar1.
   49 varchar1-len        PIC 9(4) COMP.
   49 varchar1-data       PIC X(200).
01 longvarchar1.
   49 longvarchar1-len    PIC 9(4) COMP.
   49 longvarchar1-data   PIC X(30000).
01 clob1                  SQL TYPE IS CLOB(32K).
  • The level number for group items containing only two elementary items must be 49. The first item is a 2-byte field declared with usage COMP or COMP-5 that represents the effective length of the character string. The length field must be COMP-5 for OpenESQL. The second item is a PIC X(n) data type, where n is an integer representing the length of the field that holds the data.
  • SQL statements must reference the group name.
  • If the data being copied to a SQL CHAR, VARCHAR or LONG VARCHAR data type is longer than the defined length, then the data is truncated and the SQLWARN1 flag in the SQLCA data structure is set. If the data is smaller than the defined length, a receiving CHAR data type might be padded with blanks.
  • The clob1 format uses the CLOB SQL TYPE.
OpenESQL
In addition to the definitions valid for both OpenESQL and DB2 ECM, the following definitions are also valid for OpenESQL:
01 varchar2  PIC X(20) VARYING.
01 varchar3  SQL TYPE IS CHAR-VARYING(200).
01 longvarchar1 SQL TYPE IS LONG-VARCHAR(50000).
01 varying1     PIC X(20) VARYING.
  • The varchar3 format uses the CHAR-VARYING SQL TYPE.
  • The longvarchar1 format uses the LONG-VARCHAR SQL TYPE.
OpenESQL .NET Managed Runtime
In addition to the definitions valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 varchar6           string.
Parent topic: Character Data Types
Related reference
CHAR-VARYING SQL Type
LONG-VARCHAR SQL Type
CLOB SQL Type
PIC X VARYING Data Type


Large Character Strings (CLOB)

Large character strings (CLOB) enable you to store large amounts of data in columns.

Host Variable Formats

OpenESQL
01 clob1     SQL TYPE IS CLOB(2M).
  • OpenESQL native support is limited to handling 65000 bytes.
  • The clob1 format uses the CLOB SQL TYPE.
OpenESQL .NET Managed Runtime
OpenESQL .NET Managed Runtime applications have no byte limit. In addition to the definitions valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 clob2     string.
Parent topic: Character Data Types
Related reference
CLOB SQL Type


Unicode Character Strings

Unicode character strings (UNI) are SQL data types similar to fixed-length character strings, but are encoded using UTF-16 characters instead of single- or mixed-byte characters.

Host Variable Formats

OpenESQL and DB2 ECM
03 uni-field1      PIC N(X) USAGE NATIONAL.
OpenESQL .NET Managed Runtime
In addition to the definition valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 uni-field2      string.
Parent topic: Character Data Types


Unicode Variable-length Character Strings

Unicode variable-length character strings (NVARCHAR) are SQL data types similar to variable-length character strings, but are encoded using UTF-16 characters instead of single- or mixed-byte characters.

Host Variable Formats

OpenESQL and DB2 ECM
01 nvarchar1.
   49 nvarchar1-len        PIC S9(4)  COMP-5.
   49 nvarchar1-data       PIC N(200) USAGE NATIONAL.

01 nvarchar2.
   49 nvarchar1-len        PIC S9(4)  COMP.
   49 nvarchar1-data       PIC N(200) USAGE NATIONAL.
OpenESQL .NET Managed Runtime
In addition to the definition valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 nvarchar3               string.
Parent topic: Character Data Types


Unicode Large Character Strings (DBCLOB)

Unicode large character strings (DBCLOB) enable you to store large amounts of Unicode data in columns.

Host Variable Formats

OpenESQL and DB2 ECM
01 dbclob2.
   49 dbclob2-len          PIC S9(9) COMP-5.
   49 dbclob2-data         PIC N(32000) USAGE NATIONAL.
OpenESQL
The following definition is also valid:
01 dbclob1     SQL TYPE IS DBCLOB(2M).
  • OpenESQL native support is limited to handling 65000 bytes.
  • The dbclob1 format uses the DBCLOB SQL TYPE.
OpenESQL .NET Managed Runtime
In addition to the definitions valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 dbclob3     string.

OpenESQL .NET Managed Runtime applications have no byte limit.

Parent topic: Character Data Types
Related reference
DBCLOB SQL Type


XML

Many DBMS providers support XML as a data type in both character and binary formats. See your DBMS documentation for further information as to what types of host variables the vendor suggests using.

Host Variable Format

OpenESQL and DB2 ECM
01 xmlclob1     SQL TYPE IS XML AS CLOB(2M).

The xmlclob1 format uses the XML SQL TYPE.

Parent topic: Character Data Types
Related reference
XML SQL Type


Numeric Data Types

  • Approximate Numeric Data Types
  • Exact Numeric Data Types
Parent topic: SQL Data Types


Approximate Numeric Data Types

Approximate numeric data types (FLOAT, DOUBLE, and REAL) are SQL data types that enable floating points.

Host Variable Formats

OpenESQL and DB2 ECM
01 real1       USAGE COMP-1.
01 float1      USAGE COMP-2.
  • The real1 format is for the 32-bit (single-precision) SQL floating-point data type, REAL.
  • The float1 format is for 64-bit (double-precision) SQL floating-point data types, FLOAT and DOUBLE.
OpenESQL .NET Managed Runtime
In addition to the definitions valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 real2       float-short.
01 float2      float-long.
Parent topic: Numeric Data Types


Exact Numeric Data Types

Exact numeric data types (DECIMAL and NUMERIC) can hold values up to a driver-specified precision and scale.

Host Variable Formats

OpenESQL and DB2 ECM
01 packed1      PIC S9(8)V9(10) USAGE COMP-3.
01 packed2      PIC S9(8)V9(10) USAGE PACKED-DECIMAL.
01 packed3      PIC S9(8)v9(10) USAGE DISPLAY.
Both OpenESQL and DB2 ECM support:
  • Unsigned and signed DISPLAY numerics
  • Leading and trailing signs
OpenESQL .NET Managed Runtime
In addition to the definitions valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 packed4      type system.decimal.
Parent topic: Numeric Data Types


Binary Data Types

  • Fixed-length Binary Strings
  • Variable-length Binary Strings
  • Large Binary Strings (BLOB)
Parent topic: SQL Data Types


Fixed-length Binary Strings

Fixed-length binary data types (RAW, BINARY, and CHAR(x) FOR BIT DATA) are SQL data types with a driver-defined maximum length.

Host Variable Formats

OpenESQL
03 bin-field1      PIC X(5).
03 bin-field2      SQL TYPE IS BINARY(200).
  • SQL BINARY, VARBINARY and IMAGE data are represented in COBOL as PIC X (n) fields.
  • OpenESQL does not perform data conversion.
  • When data is fetched from the database, if the host-variable field is smaller than the amount of data fetched, the data is truncated and the SQLWARN1 field in the SQLCA data structure is set to W. If the host-variable field is larger than the amount of data, the field is padded with null (x"00") bytes.
  • Any of the following enable you to insert data into BINARY, VARBINARY or LONG-VARBINARY columns:
    • Use dynamic SQL statements
    • Compile your application with the ALLOWNULLCHAR directive
    • Use SQL TYPE host variables
    • Use .NET Byte host variables
  • OpenESQL native support is limited to handling 65000 bytes.
  • If you use PIC X host variables, compile your application with the ALLOWNULLCHAR directive to prevent the truncation of transferred data to or from the host variable if a null (x"00") is encountered.
  • The bin-field2 format uses the BINARY SQL TYPE.
OpenESQL .NET Managed Runtime
In addition to the definitions valid for all databases and for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 bin-field3      type System.Byte[].
01 bin-field4      type System.Byte occurs 200 times.

OpenESQL .NET Managed Runtime applications have no byte limit.

DB2 ECM
03 bin-field1      PIC X(5).
  • Use CHAR FOR BIT DATA to represent BINARY.
  • Use VARCHAR(n) FOR BIT DATA to represent VARBINARY.
  • Use LONG VARCHAR FOR BIT DATA to represent LONG-VARBINARY.
  • The IBM ODBC driver returns the BINARY, VARBINARY and LONG VARBINARY data types instead of the IBM equivalent.
  • The IMAGE data type can be represented by BLOB.
  • DB2 uses LOBs (Character Large Object, Binary Large Object or Graphical Large Object) to define very large columns (2 Gigabytes maximum). You can use static SQL with these data types.
Parent topic: Binary Data Types
Related reference
BINARY SQL Type
ALLOWNULLCHAR


Variable-length Binary Strings

Variable-length binary data types (VARBINARY, LONG-VARBINARY, and LONG VARCHAR FOR BIT DATA) are SQL data types with a driver-defined maximum variable length.

Host Variable Formats

OpenESQL
01 varbin-field1      SQL TYPE IS VARBINARY(2000).
01 varbin-field2      SQL TYPE IS LONG-VARBINARY(20000).
01 varbin-field3.
   49 varbin-field3-len    PIC S9(4) COMP-5.
   49 varbin-field3-data   PIC X(2000).
  • SQL BINARY, VARBINARY and IMAGE data are represented in COBOL as PIC X (n) fields.
  • OpenESQL does not perform data conversion.
  • When data is fetched from the database, if the host-variable field is smaller than the amount of data fetched, the data is truncated and the SQLWARN1 field in the SQLCA data structure is set to W. If the host-variable field is larger than the amount of data, the field is padded with null (x"00") bytes.
  • Any of the following enable you to insert data into BINARY, VARBINARY or LONG-VARBINARY columns:
    • Use dynamic SQL statements
    • Compile your application with the ALLOWNULLCHAR directive
    • Use SQL TYPE host variables
    • Use .NET Byte host variables
  • OpenESQL native support is limited to handling 65000 bytes.
  • The varbin-field1 format uses the VARBINARY SQL TYPE.
  • The varbin-field2 format uses the LONG-VARBINARY SQL TYPE.
OpenESQL .NET Managed Runtime
In addition to the definitions valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 varbin-field4      type System.Byte[].

OpenESQL .NET Managed Runtime applications have no byte limit.

DB2 ECM
01 varbin-field3.
   49 varbin-field3-len    PIC S9(4) COMP-5.
   49 varbin-field3-data   PIC X(2000).
  • Use CHAR FOR BIT DATA to represent BINARY.
  • Use VARCHAR(n) FOR BIT DATA to represent VARBINARY.
  • Use LONG VARCHAR FOR BIT DATA to represent LONG-VARBINARY.
  • The IBM ODBC driver returns the BINARY, VARBINARY and LONG VARBINARY data types instead of the IBM equivalent.
  • The IMAGE data type can be represented by BLOB.
  • DB2 uses LOBs (Character Large Object, Binary Large Object or Graphical Large Object) to define very large columns (2 Gigabytes maximum). You can use static SQL with these data types.
Parent topic: Binary Data Types
Related reference
VARBINARY SQL Type
LONG-VARBINARY SQL Type


Large Binary Strings (BLOB)

Large binary string data types (BLOB) are SQL data types that enable you to store large amounts of data, from sources such as JPG files, in binary columns.

Host Variable Formats

OpenESQL
01 blob1     SQL TYPE IS BLOB(2M).
  • SQL BINARY, VARBINARY and IMAGE data are represented in COBOL as PIC X (n) fields.
  • OpenESQL does not perform data conversion.
  • When data is fetched from the database, if the host-variable field is smaller than the amount of data fetched, the data is truncated and the SQLWARN1 field in the SQLCA data structure is set to W. If the host-variable field is larger than the amount of data, the field is padded with null (x"00") bytes.
  • Any of the following enable you to insert data into BINARY, VARBINARY or LONG-VARBINARY columns:
    • Use dynamic SQL statements
    • Compile your application with the ALLOWNULLCHAR directive
    • Use SQL TYPE host variables
    • Use .NET Byte host variables
  • OpenESQL native support is limited to handling 65000 bytes.
OpenESQL .NET Managed Runtime
In addition to the definitions valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 blob2     type System.Byte[].

OpenESQL .NET Managed Runtime applications have no byte limit.

Parent topic: Binary Data Types
Related reference
BLOB SQL Type


Date and Time Data Types

COBOL does not support date and time data types directly. Therefore, date and time data columns are converted to COBOL character representations with the exception of OpenESQL .NET Managed Runtime applications that use JVM date and time data types.

  • DATE
  • DATETIMEOFFSET
  • TIME
  • TIMESTAMP
  • TIMESTAMPOFFSET
Parent topic: SQL Data Types
Related information
TSTAMPSEP


DATE

Data Format

If a COBOL output host variable is defined for an SQL DATE value, the date is specified in the format:
yyyy-mm-dd
For example:
1994-05-24

Host Variable Formats

OpenESQL and DB2 ECM
01 date1         PIC X(10).
OpenESQL
01 date2         SQL TYPE IS DATE.
01 date3         SQL TYPE IS DATE-RECORD.
  • When using the date1 format:
    • OpenESQL requires that you compile applications with the DETECTDATE SQL directive.
    • Move date specifications into the host variable in the form:
      {d 'yyyy-mm-dd'}
  • The date2 format uses the DATE SQL TYPE.
  • The date3 format uses the DATE-RECORD SQL TYPE.
OpenESQL .NET Managed Runtime
In addition to the definitions valid for all databases and those valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 date4         type System.DateTime.
Parent topic: Date and Time Data Types
Related reference
DATE SQL Type
DATE-RECORD SQL Type


DATETIMEOFFSET

Data Format

SQL Server 2008 introduced a new SQL date/time data type, DATETIMEOFFSET, which is supported by OpenESQL. The date and time are specified in the following format:
yyyy-mm-dd hh:mm:ss[.f[f[...]]]  {+ | -}hh:mm

Host Variable Formats

OpenESQL
01 datetimeoffset1     PIC X(34).
This data type can also use a DateTimeOffset record layout. For more information, see the topic The SQLDA Data Structure.
Parent topic: Date and Time Data Types
Related information
The SQLDA Data Structure


TIME

Data Format

If a COBOL output host variable is defined for an SQL TIME value, the time is specified in the following format:
hh:mm:ss
For example:
12:34:00

Host Variable Formats

OpenESQL and DB2 ECM
01 time1         PIC X(8).
OpenESQL
01 time2         SQL TYPE IS TIME.
01 time3         SQL TYPE IS TIME-RECORD.
  • When using the time1 format:
    • OpenESQL requires that you compile applications with the DETECTDATE SQL directive.
    • Move time specifications into the host variable in the form:
      {t 'hh:mm:ss'}
  • The time2 format uses the TIME SQL TYPE.
  • The time3 format uses the TIME-RECORD SQL TYPE.
OpenESQL .NET Managed Runtime
In addition to the definitions valid for all databases and those valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 time4         type System.TimeSpan.
Parent topic: Date and Time Data Types
Related reference
TIME SQL Type
TIME-RECORD SQL Type


TIMESTAMP

Data Format

If a COBOL output host variable is defined for an SQL timestamp value, the date and time are specified in the following format:
                    yyyy-mm-dd hh:mm:ss[.f[f[...]]]
where the number of fractional digits is driver-defined. For example:
1994-05-24 12:34:00.000

Host Variable Formats

OpenESQL and DB2 ECM
01 timestamp1         PIC X(29).
01 timestamp2         SQL TYPE IS TIMESTAMP.

The timestamp2 format uses the TIMESTAMP SQL TYPE.

OpenESQL
01 timestamp3         SQL TYPE IS TIMESTAMP-RECORD.
  • When using the timestamp1 format:
    • OpenESQL requires that you compile applications with the DETECTDATE SQL directive.
    • To move time specifications into the host variable:
      • To specify a time only, move the time into the host variable in the form:
        {t 'hh:mm:ss'}
      • To specify a time and a date, move them together into the host variable in the form:
        {ts 'yyyy-mm-dd
                                                    hh:mm:ss[.f[f[...]]]'
        For example:
        $set sql(dbman=odbc, detectdate)
 01 timestamp1 pic x(26).
  . . .
     move "{ts'1965-11-02 12:08:30'}" to timestamp1
     exec sql
         insert into emp (TransDate) values (:timestamp1)
     end-exec
  • When using the timestamp2 format, you can just move the date/time literal without the special characters. For example:
    01 timestamp2 SQL TYPE IS TIMESTAMP.
  . . .
     move "1965-11-02 08:12:56"  to timestamp2
     exec sql
         insert into emp (TransDate) values (:timestamp2)
     end-exec
  • The timestamp3 format uses the TIMESTAMP SQL TYPE.
OpenESQL .NET Managed Runtime
In addition to the definitions valid for all databases and those valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 timestamp4         type System.DateTime.
DB2 ECM

The TIMESTAMP data type has a maximum length of 26 characters.

Parent topic: Date and Time Data Types
Related reference
TIMESTAMP SQL Type
TIMESTAMP-RECORD SQL Type


TIMESTAMPOFFSET

Data Format

If a COBOL output host variable is defined for an SQL timestamp value with an offset, the date and time are specified in the following format:
                    yyyy-mm-dd hh:mm:ss[.f[f[...]]]  {+ | -}hh:mm
where the number of fractional digits is driver-defined. For example:
1994-05-24 12:34:00.000 +02:00

Host Variable Formats

OpenESQL and DB2 ECM
01 timestampoffset1   PIC X(36).
OpenESQL
01 timestampoffset2   SQL TYPE IS TIMESTAMP-OFFSET.
01 timestampoffset3   SQL TYPE IS TIMESTAMP-OFFSET-RECORD.
  • The timestampoffset2 format uses the TIMESTAMP-OFFSET SQL TYPE.
  • The timestampoffset3 format uses the TIMESTAMP-OFFSET-RECORD SQL TYPE.
OpenESQL .NET Managed Runtime
In addition to the definitions valid for all databases and those valid for OpenESQL, the following definition is also valid for the OpenESQL .NET Managed Runtime:
01 timestampoffset4   type System.DateTimeOffset.
Parent topic: Date and Time Data Types
Related reference
TIMESTAMP-OFFSET SQL Type
TIMESTAMP-OFFSET-RECORD SQL Type


Locator Data Types

  • BLOB-LOCATOR Data Type
  • CLOB-LOCATOR Data Type
  • DBCLOB-LOCATOR Data Type
  • RESULT-SET-LOCATOR Data Type
Parent topic: SQL Data Types


BLOB-LOCATOR Data Type

Host Variable Format

DB2 ECM
01 blob-locator-file1 SQL TYPE IS BLOB-LOCATOR.

The blob-locator-file1 format uses the BLOB-LOCATOR SQL TYPE.

Parent topic: Locator Data Types
Related reference
BLOB-LOCATOR SQL Type


CLOB-LOCATOR Data Type

Host Variable Format

DB2 ECM
01 clob-locator1 SQL TYPE IS CLOB-LOCATOR.

The clob-locator1 format uses the CLOB-LOCATOR SQL TYPE.

Parent topic: Locator Data Types
Related reference
CLOB-LOCATOR SQL Type


DBCLOB-LOCATOR Data Type

Host Variable Format

DB2 ECM
01 dbclob-locator-file1 SQL TYPE IS CLOB-LOCATOR.

The dbclob-locator-file1 format uses the DBCLOB-LOCATOR SQL TYPE.

Parent topic: Locator Data Types
Related reference
DBCLOB-LOCATOR SQL Type


RESULT-SET-LOCATOR Data Type

Host Variable Format

OpenESQL
01 result-set-locator1 SQL TYPE IS RESULT-SET-LOCATOR VARYING.
  • RESULT-SET-LOCATOR is only valid for OpenESQL applications compiled with HCOSS directives.
  • The result-set-locator1 format uses the RESULT-SET-LOCATOR SQL TYPE.
Parent topic: Locator Data Types
Related reference
RESULT-SET-LOCATOR SQL Type


File Data Types

  • BLOB-FILE Data Type
  • CLOB-FILE Data File
  • DBCLOB-FILE Data Type
Parent topic: SQL Data Types


BLOB-FILE Data Type

Host Variable Format

DB2 ECM
01 blob-file1      SQL TYPE IS BLOB-FILE.

The blob-file1 format uses the BLOB-FILE SQL TYPE.

Parent topic: File Data Types
Related reference
BLOB-FILE SQL Type


CLOB-FILE Data File

Host Variable Format

DB2 ECM
01 clob-file1 SQL TYPE IS CLOB-FILE.

The clob-file1 format uses the CLOB-FILE SQL TYPE.

Parent topic: File Data Types
Related reference
CLOB-FILE SQL Type


DBCLOB-FILE Data Type

Host Variable Format

DB2 ECM
01 dbclob-file1 SQL TYPE IS DBCLOB-FILE.

The dbclob-file1 format uses the DBCLOB-FILE SQL TYPE.

Parent topic: File Data Types
Related reference
DBCLOB-FILE SQL Type


Miscellaneous Data Types

  • PIC X VARYING Data Type
  • ROWID Data Type
Parent topic: SQL Data Types


PIC X VARYING Data Type

Note: OpenESQL only

Syntax

PIC X(n) VARYING

Where n is an integer representing the length of the field that holds the data.

Example

01 ename  PIC X(15) VARYING.

generates

01  ename.
     05  ename-len  PIC S9(4) COMP.
     05  ename-ARR  PIC X(15).
Parent topic: Miscellaneous Data Types
Related information
Variable-length Character Strings


ROWID Data Type

Host Variable Format

DB2 ECM
01 rowid1 SQL TYPE IS ROWID.
  • ROWID can be used with DB2 ECM but only for DB2 for z/OS servers.
  • The rowid1 format uses the ROWID SQL TYPE.
Parent topic: Miscellaneous Data Types
Related reference
ROWID SQL Type


SQL TYPEs

  • BINARY SQL Type
  • BLOB SQL Type
  • BLOB-FILE SQL Type
  • BLOB-LOCATOR SQL Type
  • CHAR SQL Type
  • CHAR-VARYING SQL Type
  • CLOB SQL Type
  • CLOB-FILE SQL Type
  • CLOB-LOCATOR SQL Type
  • DATE SQL Type
  • DATE-RECORD SQL Type
  • DBCLOB SQL Type
  • DBCLOB-FILE SQL Type
  • DBCLOB-LOCATOR SQL Type
  • LONG-VARBINARY SQL Type
  • LONG-VARCHAR SQL Type
  • RESULT-SET-LOCATOR SQL Type
  • ROWID SQL Type
  • TIME SQL Type
  • TIME-RECORD SQL Type
  • TIMESTAMP SQL Type
  • TIMESTAMP-RECORD SQL Type
  • TIMESTAMP-OFFSET SQL Type
  • TIMESTAMP-OFFSET-RECORD SQL Type
  • VARBINARY SQL Type
  • XML SQL Type
Parent topic: Reference
Related concepts
Setting OpenESQL Assistant Options
COBOL to SQL Data Type Mapping
SQL TYPEs


BINARY SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] BINARY(n)

Example

01 hv-name SQL TYPE IS BINARY(200).

generates

01 hv-name PIC X(200).
Parent topic: SQL TYPEs
Related information
Fixed-length Binary Strings


BLOB SQL Type

Note: OpenESQL and DB2 ECM only

Syntax

SQL [TYPE] [IS] BLOB(lob-length)

Where lob-length is a value between 1 and 1073741823 expressed either as a number or a number followed by K (kilobytes), M (megabytes), or G (gigabytes).

Note: Although this SQL TYPE has a theoretical size limitation of 2G, for all practical purposes, the actual limitation is approximately 450M, which is the data size actually allocated to the application program.

Example

01 hv-name SQL TYPE IS BLOB(2M).

generates

01 hv-name.
  03 hv-name-len    PIC S9(9) COMP-5.
  03 hv-name-val    PIC X(2097152).
Parent topic: SQL TYPEs
Related information
Large Binary Strings (BLOB)


BLOB-FILE SQL Type

Note: DB2 ECM only

Syntax

SQL [TYPE] [IS] BLOB-FILE

Example

01 hv-name SQL TYPE IS BLOB-FILE.

generates

01  hv-name.
  49 hv-name-name-length PIC S9(9) COMP-5.
  49 hv-name-data-length PIC S9(9) COMP-5.
  49 hv-name-file-option PIC S9(9) COMP-5.
  49 hv-name-name PIC X(255).
Parent topic: SQL TYPEs
Related information
BLOB-FILE Data Type


BLOB-LOCATOR SQL Type

Note: DB2 ECM only

Syntax

SQL [TYPE] [IS] BLOB-LOCATOR

Example

01 hv-name SQL TYPE IS BLOB-LOCATOR.

generates

01 hv-name PIC S9(9) COMP-5.
Parent topic: SQL TYPEs
Related information
BLOB-LOCATOR Data Type


CHAR SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] CHAR(n)

Example

01 hv-name SQL TYPE IS CHAR(200).

generates

01 hv-name PIC X(200).
Parent topic: SQL TYPEs
Related information
Fixed-length Character Strings


CHAR-VARYING SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] CHAR-VARYING(n)
  • CHAR-VARYING data is passed to OpenESQL as SQL_VARCHAR.
  • Data sent to the data source eliminates trailing spaces except for the first space if the value is all spaces.
  • Values fetched from the data source are padded with spaces.

Example

01 hv-name SQL TYPE IS CHAR-VARYING(200).

generates

01 hv-name PIC X(200).
Parent topic: SQL TYPEs
Related information
Variable-length Character Strings


CLOB SQL Type

Note: OpenESQL and DB2 ECM only

Syntax

SQL [TYPE] [IS] CLOB(lob-length)

Where lob-length is a value between 1 and 1073741823 expressed either as a number or a number followed by K (kilobytes), M (megabytes), or G (gigabytes).

Note: Although this SQL TYPE has a theoretical size limitation of 2G, for all practical purposes, the actual limitation is approximately 450M, which is the data size actually allocated to the application program.

Example

01 hv-name SQL TYPE IS CLOB(2M).

generates

01 hv-name.
  03 hv-name-len    PIC S9(9) COMP-5.
  03 hv-name-val    PIC X(2097152).
Parent topic: SQL TYPEs
Related information
Variable-length Character Strings
Large Character Strings (CLOB)


CLOB-FILE SQL Type

Note: DB2 ECM only

Syntax

SQL [TYPE] [IS] CLOB-FILE

Example

01 hv-name SQL TYPE IS CLOB-FILE.

generates

01  hv-name.
  49 hv-name-name-length PIC S9(9) COMP-5.
  49 hv-name-data-length PIC S9(9) COMP-5.
  49 hv-name-file-option PIC S9(9) COMP-5.
  49 hv-name-name PIC X(255).
Parent topic: SQL TYPEs
Related information
CLOB-FILE Data File


CLOB-LOCATOR SQL Type

Note: DB2 ECM only

Syntax

SQL [TYPE] [IS] CLOB-LOCATOR

Example

01 hv-name SQL TYPE IS CLOB-LOCATOR.

generates

01 hv-name PIC S9(9) COMP-5.
Parent topic: SQL TYPEs
Related information
CLOB-LOCATOR Data Type


DATE SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] DATE

Use DATE to generate a single working-storage record to contain all date information.

Example

01 hv-name SQL TYPE IS DATE.

generates

01 hv-name PIC X(10).
Parent topic: SQL TYPEs
Related information
DATE


DATE-RECORD SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] DATE-RECORD
Use DATE-RECORD to generate a group-level record for the date containing individual records for each element of the date as follows:
  • Year
  • Month
  • Day

Example

01 hv-name SQL TYPE IS DATE.

generates

01 hv-name PIC X(10).
Parent topic: SQL TYPEs
Related information
DATE


DBCLOB SQL Type

Note: OpenESQL and DB2 ECM only

Syntax

SQL [TYPE] [IS] DBCLOB(lob-length)

Where lob-length is a value between 1 and 1073741823 expressed either as a number or a number followed by K (kilobytes), M (megabytes), or G (gigabytes).

Note: Although this SQL TYPE has a theoretical size limitation of 2G, for all practical purposes, the actual limitation is approximately 450M, which is the data size actually allocated to the application program.

Example

01 hv-name SQL TYPE IS DBCLOB(2M).

generates

01 hv-name.
  03 hv-name-len    PIC S9(9) COMP-5.
  03 hv-name-val    PIC X(2097152).
Parent topic: SQL TYPEs
Related information
Unicode Large Character Strings (DBCLOB)


DBCLOB-FILE SQL Type

Note: DB2 ECM only

Syntax

SQL [TYPE] [IS] DBCLOB-FILE

Example

01 hv-name SQL TYPE IS DBCLOB-FILE.

generates

01  hv-name.
  49 hv-name-name-length PIC S9(9) COMP-5.
  49 hv-name-data-length PIC S9(9) COMP-5.
  49 hv-name-file-option PIC S9(9) COMP-5.
  49 hv-name-name PIC X(255).
Parent topic: SQL TYPEs
Related information
DBCLOB-FILE Data Type


DBCLOB-LOCATOR SQL Type

Note: DB2 ECM only

Syntax

SQL [TYPE] [IS] DBCLOB-LOCATOR

Example

01 hv-name SQL TYPE IS DBCLOB-LOCATOR.

generates

01 hv-name PIC S9(9) COMP-5.
Parent topic: SQL TYPEs
Related information
DBCLOB-LOCATOR Data Type


LONG-VARBINARY SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] LONG-VARBINARY(n)

Example

01 hv-name SQL TYPE IS LONG-VARBINARY(2000).

generates

01 hv-name.
  03 hv-name-len    PIC S9(9) COMP-5.
  03 hv-name-val    PIC X(2000).
Parent topic: SQL TYPEs
Related information
Variable-length Binary Strings


LONG-VARCHAR SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] LONG-VARCHAR(n)

Example

01 hv-name SQL TYPE IS LONG-VARCHAR(65000).

generates

01 hv-name.
  03 hv-name-len    PIC S9(9) COMP-5.
  03 hv-name-val    PIC X(65000).
Parent topic: SQL TYPEs
Related information
Variable-length Character Strings


RESULT-SET-LOCATOR SQL Type

Note: Valid only for OpenESQL applications compiled with HCOSS compiler directives

Syntax

SQL [TYPE] [IS] RESULT-SET-LOCATOR VARYING

Example

01 hv-name SQL TYPE IS RESULT-SET-LOCATOR VARYING.

generates

01 hv-name PIC S9(9) COMP-5.
Parent topic: SQL TYPEs
Related information
RESULT-SET-LOCATOR Data Type


ROWID SQL Type

Note: Valid for DB2 ECM but only for DB2 for z/OS servers

Syntax

SQL [TYPE] [IS] ROWID

Example

01 hv-name SQL TYPE IS ROWID.

generates

01 hv-name.
  03 hv-name-len    PIC S9(4) COMP.
  03 hv-name-data   PIC X(40).
Parent topic: SQL TYPEs
Related information
ROWID Data Type


TIME SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] TIME

Use TIME to generate a single working-storage record to contain all time information.

Example

01 hv-name SQL TYPE IS TIME.

generates

01 hv-name PIC X(8).
Parent topic: SQL TYPEs
Related information
TIME


TIME-RECORD SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] TIME-RECORD

Use TIME-RECORD to generate a group-level record for the time containing individual records for each element as follows:

  • Hour
  • Minutes
  • Seconds

To insert data, you must pass valid data in the generated field names.

Example

01 hv-name SQL TYPE IS TIME-RECORD.

generates

01 hv-name.
  03 hv-name-hour  PIC 9(4) COMP-5.
  03 hv-name-min   PIC 9(4) COMP-5.
  03 hv-name-sec   PIC 9(4) COMP-5.
Parent topic: SQL TYPEs
Related information
TIME


TIMESTAMP SQL Type

Note: OpenESQL and DB2 ECM only

Syntax

SQL [TYPE] [IS] TIMESTAMP
Use TIMESTAMP to generate a single working-storage record to contain all timestamp information.
  • Data must be organized in fixed date/time formats.
  • Fractional seconds are supported up to nine digits. However, this value can vary depending on your target DBMS and your ODBC driver. For example, DB2 ECM limits fractional seconds to six digits. Microsoft SQL Server limits fractional seconds to three digits. See your DBMS or ODBC driver documentation for more information.
  • Fractional data is passed left justified, and must contain the number of digits defined in your record. For example, to pass a fractional value of 678 to a record that defines fractional data as nine digits, move the value 678000000.
  • Fractional data is right justified when returned from a SELECT or FETCH statement.
  • Because of the way SQL Server stores date/time values, it might round the last fractional digit of a fractional value up or down depending on the digit. For example:
    If you pass... | SQL Server returns...
    01/01/98 23:59.59.999 | 1998-01-02 00:00:00.000
    01/01/98 23:59.59.995 | 1998-01-01 23:59:59.997
    01/01/98 23:59.59.996 | 1998-01-01 23:59:59.997
    01/01/98 23:59.59.997 | 1998-01-01 23:59:59.997
    01/01/98 23:59.59.998 | 1998-01-01 23:59:59.997
    01/01/98 23:59.59.992 | 1998-01-01 23:59:59.993
    01/01/98 23:59.59.993 | 1998-01-01 23:59:59.993
    01/01/98 23:59.59.994 | 1998-01-01 23:59:59.993
    01/01/98 23:59.59.990 | 1998-01-01 23:59:59.990
    01/01/98 23:59.59.991 | 1998-01-01 23:59:59.990

Example

01 hv-name SQL TYPE IS TIMESTAMP.

generates

01 hv-name PIC X(29).
Parent topic: SQL TYPEs
Related information
TIMESTAMP


TIMESTAMP-RECORD SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] TIMESTAMP-RECORD

Use TIMESTAMP-RECORD to generate a group-level record for the timestamp containing individual records for each element of the timestamp as follows:

  • Year
  • Month
  • Day
  • Hour
  • Minute
  • Second
  • Fractional second

To insert data, you must pass valid data in the generated field names.

  • Data must be organized in fixed date/time formats.
  • Fractional seconds are supported up to nine digits. However, this value can vary depending on your target DBMS and your ODBC driver. For example, DB2 ECM limits fractional seconds to six digits. Microsoft SQL Server limits fractional seconds to three digits. See your DBMS or ODBC driver documentation for more information.
  • Fractional data is passed left justified, and must contain the number of digits defined in your record. For example, to pass a fractional value of 678 to a record that defines fractional data as nine digits, move the value 678000000.
  • Fractional data is right justified when returned from a SELECT or FETCH statement.
  • Because of the way SQL Server stores date/time values, it might round the last fractional digit of a fractional value up or down depending on the digit. For example:
    If you pass... | SQL Server returns...
    01/01/98 23:59.59.999 | 1998-01-02 00:00:00.000
    01/01/98 23:59.59.995 | 1998-01-01 23:59:59.997
    01/01/98 23:59.59.996 | 1998-01-01 23:59:59.997
    01/01/98 23:59.59.997 | 1998-01-01 23:59:59.997
    01/01/98 23:59.59.998 | 1998-01-01 23:59:59.997
    01/01/98 23:59.59.992 | 1998-01-01 23:59:59.993
    01/01/98 23:59.59.993 | 1998-01-01 23:59:59.993
    01/01/98 23:59.59.994 | 1998-01-01 23:59:59.993
    01/01/98 23:59.59.990 | 1998-01-01 23:59:59.990
    01/01/98 23:59.59.991 | 1998-01-01 23:59:59.990

Example

01 hv-name SQL TYPE IS TIMESTAMP-RECORD.

generates

01 hv-name.
  03 hv-name-year  PIC S9(4) COMP-5.
  03 hv-name-month PIC 9(4) COMP-5.
  03 hv-name-day   PIC 9(4) COMP-5.
  03 hv-name-hour  PIC 9(4) COMP-5.
  03 hv-name-min   PIC 9(4) COMP-5.
  03 hv-name-sec   PIC 9(4) COMP-5.
  03 hv-name-frac  PIC 9(9) COMP-5.
Parent topic: SQL TYPEs
Related information
TIMESTAMP


TIMESTAMP-OFFSET SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] TIMESTAMP-OFFSET

Use TIMESTAMP-OFFSET to generate a single working-storage record to contain all timestamp information.

Example

01 hv-name SQL TYPE IS TIMESTAMP-OFFSET.

generates

01 hv-name PIC X(36).
Parent topic: SQL TYPEs
Related information
TIMESTAMPOFFSET


TIMESTAMP-OFFSET-RECORD SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] TIMESTAMP-OFFSET-RECORD
Use TIMESTAMP-OFFSET-RECORD to generate a group-level record for the timestamp containing individual records for each element of the timestamp as follows:
  • Year
  • Month
  • Day
  • Hour
  • Minute
  • Second
  • Fractional second
  • Offset hours
  • Offset minutes

To insert data, you must pass valid data in the generated field names.

Example

01 hv-name SQL TYPE IS TIMESTAMP-OFFSET-RECORD.

generates

01 hv-name.
  03 hv-name-year  PIC S9(4) COMP-5.
  03 hv-name-month PIC 9(4) COMP-5.
  03 hv-name-day   PIC 9(4) COMP-5.
  03 hv-name-hour  PIC 9(4) COMP-5.
  03 hv-name-min   PIC 9(4) COMP-5.
  03 hv-name-sec   PIC 9(4) COMP-5.
  03 hv-name-frac  PIC 9(9) COMP-5.
  03 hv-name-tz-hour PIC S9(4) COMP-5.
  03 hv-name-tz-min  PIC S9(4) COMP-5.
Parent topic: SQL TYPEs
Related information
TIMESTAMPOFFSET


VARBINARY SQL Type

Note: OpenESQL only

Syntax

SQL [TYPE] [IS] VARBINARY(n)

Example

01 hv-name SQL TYPE IS VARBINARY(2000).

generates

01 hv-name.
  03 hv-name-len    PIC S9(4) COMP-5.
  03 hv-name-val    PIC X(2000).
Parent topic: SQL TYPEs
Related information
Variable-length Binary Strings


XML SQL Type

Note: OpenESQL and DB2 ECM only

Syntax

SQL [TYPE] [IS] XML AS CLOB(lob-length)

Where lob-length is a value between 1 and 2147483647 expressed either as a number or a number followed by K (kilobytes), M (megabytes), or G (gigabytes).

Note: Although this SQL TYPE has a theoretical size limitation of 2G, for all practical purposes, the actual limitation is approximately 450M, which is the data size actually allocated to the application program.

Example

01 hv-name SQL TYPE IS XML AS CLOB(2M).

generates

01 hv-name.
  03 hv-name-len    PIC S9(9) COMP-5.
  03 hv-name-val    PIC X(2097152).
Parent topic: SQL TYPEs
Related information
XML


Data Structures

  • The SQLCA Data Structure
  • The SQLDA Data Structure
Parent topic: Reference


The SQLCA Data Structure

The SQLCA data structure for OpenESQL and the DB2 ECM is shown below:

 01 SQLCA.
     05  SQLCAID         PIC X(8)         VALUE "SQLCA   ".
     05  SQLCABC         PIC S9(9) COMP-5 VALUE 136.
     05  SQLCODE         PIC S9(9) COMP-5 VALUE 0.
     05  SQLERRM.
         49  SQLERRML    PIC S9(4) COMP-5.
         49  SQLERRMC    PIC X(70).
     05  SQLERRP         PIC X(8).
     05  SQLERRD         PIC S9(9) COMP-5 OCCURS 6 VALUE 0.
     05  SQLWARN.
         10  SQLWARN0    PIC X.
         10  SQLWARN1    PIC X.
         10  SQLWARN2    PIC X.
         10  SQLWARN3    PIC X.
         10  SQLWARN4    PIC X.
         10  SQLWARN5    PIC X.
         10  SQLWARN6    PIC X.
         10  SQLWARN7    PIC X.
     05  SQLEXT.
         10  SQLWARN8    PIC X.
         10  SQLWARN9    PIC X.
         10  SQLWARN10   PIC X.
         10  SQLWARNA    PIC X REDEFINES SQLWARN10.
     05  SQLSTATE    PIC X(5).

Oracle, Sybase and Informix all have different versions of the SQLCA. The Oracle, Sybase and Informix SQLCAs all have a SQLCODE, SQLERRML, SQLERRMC and a SQLWARN. The sizes and the positions of these fields can differ among the precompilers

The table below describes the contents of the SQLCA data structure:

Field | Contents
SQLCAID | The text string "SQLCA".
SQLCABC | The length of the SQLCA data structure.
SQLCODE | The status code for the last-run SQL statement:
SQLERRML | The length of the error message in SQLERRMC (0–70).
SQLERRMC | Error message text. Error messages longer than 70 bytes are truncated.
SQLERRP | Reserved (diagnostic information).
SQLERRD | An array of six integer status codes (those not listed below are reserved):
 | SQLERRD(1) | SQL server error number.
 | SQLERRD(2) | SQL server severity.
 | SQLERRD(3) | The number of rows affected.
SQLWARN | Eight warning flags, each containing a blank or "W" (those not listed below are reserved): A warning flag will be set if SQLCODE contains a value of +1:
 | SQLWARN0 | A summary of all warning fields. Blank means there are no warnings.
 | SQLWARN1 | "W" indicates that data was truncated on output to a character host variable.
 | SQLWARN2 | "W" indicates that a null value exists, but no indicator variable was provided.
 | SQLWARN3 | "W" indicates that the number of columns is less than the number of host variables or that the number of host variables provided does not match the number of parameter markers in the statement. The lower of the two numbers has been used.
 | SQLWARN4 | "W" indicates a singleton select that returns more than one row (only the first row is returned).
FILLER | Reserved.
SQLSTATE | Status indicator for the last-run SQL statement.
Parent topic: Data Structures
Related concepts
SQL Communications Area (SQLCA)
The Warning Flags
Related reference
WHENEVER


The SQLDA Data Structure

The SQLDA data structure is shown below:

    01 SQLDA sync.
          05 SQLDAID               PIC X(8)  VALUE "SQLDA  ".
          05 SQLDABC               PIC S9(9) COMP-5 value 0.
          05 SQLN                  PIC S9(4) COMP-5 value 0.
          05 SQLD                  PIC S9(4) COMP-5 value 0.
          05 SQLVAR OCCURS 0 TO 1489 TIMES DEPENDING ON SQLD.
             10 SQLTYPE            PIC S9(4) COMP-5.
             10 SQLLEN             PIC S9(4) COMP-5.
      $IF P64 SET
             *> For 64-bit environments, ensure that SQLDATA is
             *> aligned on an 8-byte boundary.
             10 FILLER             PIC S9(9) COMP-5.
      $END
             10 SQLDATA            USAGE POINTER.
             10 SQLIND             USAGE POINTER.
             10 SQLNAME.
                15 SQLNAMEL        PIC S9(4) COMP-5.
                15 SQLNAMEC        PIC X(30).

The following table describes the contents of the SQLDA data structure.

Field | Contains
SQLDAID | The text string "SQLDA".
SQLDABC
  • 32-bit - The length of the SQLDA data structure (SQLN * 44 + 16)
  • 64-bit - The length of the SQLDA data structure (SQLN * 56 + 16)
SQLN | Total number of SQLVAR entries allocated, equal to the number of input parameters or output columns.
SQLD | Number of SQLVAR entries used.
SQLVAR | SQLVAR is a group item, the number of occurrences of which depends on the value of SQLD.
SQLTYPE | A number representing the data type of the column or host variable and indicating whether null values are allowed (see the table below for valid values).
SQLLEN | Length of a value from a column. If the data is decimal (including money), SQLLEN is split into two parts: the first byte contains the precision; the second byte contains the scale.
FILLER | For 64-bit environments, this is necessary to ensure that SQLDATA and SQLIND reside on 8-byte boundaries in memory, which is required for execution within a 64-bit environment.
SQLDATA | For FETCH, OPEN, and EXECUTE, the address of the host variable (must be inserted by the application). For DESCRIBE and PREPARE, SQLDATA is not used.
SQLIND | For FETCH, OPEN, and EXECUTE, the address of an associated indicator variable, if one exists. If the column does not permit a null value, the field is undefined. If the column permits a null value, SQLIND is set to -1 if the data value is null or to 0 if the data value is not null. For DESCRIBE and PREPARE, SQLIND is not used.
SQLNAME | A group item containing the name and length of the column (not used for FETCH, OPEN or EXECUTE.
SQLNAMEL | Length of the name column
SQLNAMEC | Name of the column. For a derived column, this field contains the ASCII numeric literal value that represents the derived column's original position within the select list

SQL TYPE Values

       78  ESQL-DATE-CHAR                  VALUE 384.
       78  ESQL-DATE-CHAR-NULL             VALUE 385.
       78  ESQL-DATE-REC                   VALUE 386.
       78  ESQL-DATE-REC-NULL              VALUE 387.
       78  ESQL-TIME-CHAR                  VALUE 388.
       78  ESQL-TIME-CHAR-NULL             VALUE 389.
       78  ESQL-TIME-REC                   VALUE 390.
       78  ESQL-TIME-REC-NULL              VALUE 391.
       78  ESQL-TIMESTAMP-CHAR             VALUE 392.
       78  ESQL-TIMESTAMP-CHAR-NULL        VALUE 393.
       78  ESQL-TIMESTAMP-REC              VALUE 394.
       78  ESQL-TIMESTAMP-REC-NULL         VALUE 395.
       78  ESQL_TIMESTAMP_OFFSET_CHAR      VALUE 396.
       78  ESQL_TIMESTAMP_OFFSET_CHAR_NULL VALUE 397.
       78  ESQL_TIMESTAMP_OFFSET_REC       VALUE 398.
       78  ESQL_TIMESTAMP_OFFSET_REC_NULL  VALUE 399.

       78  ESQL-LONGVARBINARY              VALUE 404.
       78  ESQL-LONGVARBINARY-NULL         VALUE 405.
       78  ESQL-LONGVARCHAR                VALUE 408.
       78  ESQL-LONGVARCHAR-NULL           VALUE 409.
       78  ESQL-BINARY                     VALUE 444.
       78  ESQL-BINARY-NULL                VALUE 445.
       78  ESQL-VARBINARY                  VALUE 446.
       78  ESQL-VARBINARY-NULL             VALUE 447.
       78  ESQL-VARCHAR                    VALUE 448.
       78  ESQL-VARCHAR-NULL               VALUE 449.

       78  ESQL-CHARVARYING                VALUE 450.  *> added esq03n31
       78  ESQL-CHARVARYING-NULL           VALUE 451.  *> added esq03n31

       78  ESQL-CHAR                       VALUE 452.
       78  ESQL-CHAR-NULL                  VALUE 453.

       78  ESQL-CHAR-FIXED                 VALUE 454.  *> added esq03n31
       78  ESQL-CHAR-FIXED-NULL            VALUE 455.  *> added esq03n31

       78  ESQL-VARGRAPH                   VALUE 464.
       78  ESQL-VARGRAPH-NULL              VALUE 465.
       78  ESQL-GRAPHIC                    VALUE 468.
       78  ESQL-GRAPHIC-NULL               VALUE 469.
       78  ESQL-LONGRAPH                   VALUE 472.
       78  ESQL-LONGRAPH-NULL              VALUE 473.

       78  ESQL-DOUBLE                     VALUE 480.
       78  ESQL-DOUBLE-NULL                VALUE 481.
       78  ESQL-REAL                       VALUE 482.
       78  ESQL-REAL-NULL                  VALUE 483.
       78  ESQL-DECIMAL                    VALUE 484.
       78  ESQL-DECIMAL-NULL               VALUE 485.
       78  ESQL-BIGINT                     VALUE 492.
       78  ESQL-BIGINT-NULL                VALUE 493.
       78  ESQL-INTEGER                    VALUE 496.
       78  ESQL-INTEGER-NULL               VALUE 497.
       78  ESQL-SMALLINT                   VALUE 500.
       78  ESQL-SMALLINT-NULL              VALUE 501.
       78  ESQL-TINYINT                    VALUE 502.
       78  ESQL-TINYINT-NULL               VALUE 503.

       78  ESQL-UDISP-UNSIGN               VALUE 510.
       78  ESQL-UDISP-UNSIGN-NULL          VALUE 511.
       78  ESQL-UDISP-SIGN-LEAD-SEP        VALUE 512.
       78  ESQL-UDISP-SIGN-LEAD-SEP-NULL   VALUE 513.
       78  ESQL-UDISP-SIGN-TRAIL-SEP       VALUE 514.
       78  ESQL-UDISP-SIGN-TRAIL-SEP-NULL  VALUE 515.
       78  ESQL-UDISP-SIGN-LEAD-INC        VALUE 516.
       78  ESQL-UDISP-SIGN-LEAD-INC-NULL   VALUE 517.
       78  ESQL-UDISP-SIGN-TRAIL-INC       VALUE 518.
       78  ESQL-UDISP-SIGN-TRAIL-INC-NULL  VALUE 519.

       78  ESQL-WCHAR                      VALUE 1080.
       78  ESQL-WCHAR_NULL                 VALUE 1081.
       78  ESQL-WVARCHAR                   VALUE 1090.
       78  ESQL-WVARCHAR_NULL              VALUE 1091.
       78  ESQL-WLONGVARCHAR               VALUE 1100.
       78  ESQL-WLONGVARCHAR_NULL          VALUE 1101.

       78  ESQL_UTINYINT                   VALUE 1200.
       78  ESQL_UTINYINT_NULL              VALUE 1201.
       78  ESQL_USMALLINT                  VALUE 1202.
       78  ESQL_USMALLINT_NULL             VALUE 1203.
       78  ESQL_UINTEGER                   VALUE 1204.
       78  ESQL_UINTEGER_NULL              VALUE 1205.
       78  ESQL_UBIGINT                    VALUE 1206.
       78  ESQL_UBIGINT_NULL               VALUE 1207.

       78  ESQL-PICX-VARYING               VALUE 1208.
       78  ESQL-PICX-VARYING-NULL          VALUE 1209.
Parent topic: Data Structures
Related concepts
The SQL Descriptor Area (SQLDA)


Keywords

The following words are recognized by OpenESQL. Not all are currently used. Some are reserved for future enhancements, or for compatibility with other Embedded SQL implementations. Absence of a word from this list does not imply that ODBC drivers which use the word are not supported.

  • ALL
  • APPLICATION
  • ANSI
  • AS
  • AT
  • AUTOCOMMIT
  • BEGIN
  • BIND
  • BROWSE
  • BY
  • CALL
  • CLOSE
  • COMMIT
  • COMMITED
  • CONCURRENCY
  • CONNECT
  • CONNECTION
  • CONTINUE
  • CUR_BROWSE
  • CUR_STANDARD
  • CURRENT
  • CURSOR
  • CURSORTYPE
  • DATABASE
  • DATE
  • DBLIBVER
  • DECLARE
  • DEFAULT
  • DELETE
  • DESCRIBE
  • DESCRIPTOR
  • DISCONNECT
  • DO
  • DSN
  • DYNAMIC
  • END
  • EXEC
  • EXECSP
  • EXECUTE
  • ESQL_VERSION
  • FETCH
  • FETCHBUFFER
  • FIRST
  • FOR
  • FORWARD
  • FOUND
  • FROM
  • GET
  • GO
  • GOTO
  • HDBC
  • HENV
  • HOLD
  • HOST
  • IDENTIFIED
  • IMMEDIATE
  • IN
  • INCLUDE
  • INDICATOR
  • INOUT
  • INPUT
  • INSENSITIVE
  • INTO
  • ISARRAY
  • ISOLATION
  • KEYSET
  • LAST
  • LIST
  • LOCK
  • LOCKCC
  • LOGINTIME
  • MIXED
  • NEXT
  • NO
  • NOT
  • OF
  • OFF
  • ON
  • ONLY
  • OPEN
  • OPTCC
  • OPTCCVAL
  • OPTIMISTIC
  • OPTION
  • OUT
  • OUTPUT
  • PERFORM
  • PREPARE
  • PREVIOUS
  • PRIOR
  • PROMPT
  • QUERY
  • QUERYTIME
  • READ
  • READONLY
  • RECOMPILE
  • RELEASE
  • REPEATABLE
  • RESET
  • RETURNING
  • ROLLBACK
  • SAVE
  • SCROLL
  • SCROLLOPTION
  • SECTION
  • SELECT
  • SENSITIVE
  • SERIALIZABLE
  • SET
  • SQLCA
  • SQLERROR
  • SQLDA
  • SQLSERVER95
  • SQLWARNING
  • STANDARD
  • STATEMENT
  • STATIC
  • TIME
  • TIMESTAMP
  • TO
  • TRAN
  • TRANSACTION
  • UPDATE
  • USER
  • USING
  • UNCOMMITED
  • VARIABLES
  • WHENEVER
  • WITH
  • WORK

The following words are reserved for use in ODBC function calls by the ODBC specification.

  • ABSOLUTE
  • ACTION
  • ADA
  • ADD
  • ALL
  • ALLOCATE
  • ALTER
  • AND
  • ANY
  • ARE
  • AS
  • ASC
  • ASSERTION
  • AT
  • AUTHORIZATION
  • AVG
  • BEGIN
  • BETWEEN
  • BIT
  • BIT_LENGTH
  • BOTH
  • BY
  • CASCADE
  • CASCADED
  • CASE
  • CAST
  • CATALOG
  • CHAR
  • CHAR_LENGTH
  • CHARACTER
  • CHARACTER_LENGTH
  • CHECK
  • CLOSE
  • COALESCE
  • COBOL
  • COLLATE
  • COLLATION
  • COLUMN
  • COMMIT
  • CONNECT
  • CONNECTION
  • CONSTRAINT
  • CONSTRAINTS
  • CONTINUE
  • CONVERT
  • CORRESPONDING
  • COUNT
  • CREATE
  • CROSS
  • CURRENT
  • CURRENT_DATE
  • CURRENT_TIME
  • CURRENT_TIMESTAMP
  • CURRENT_USER
  • CURSOR
  • DATE
  • DAY
  • DEALLOCATE
  • DEC
  • DECIMAL
  • DECLARE
  • DEFAULT
  • DEFERRABLE
  • DEFERRED
  • DELETE
  • DESC
  • DESCRIBE
  • DESCRIPTOR
  • DIAGNOSTICS
  • DISCONNECT
  • DISTINCT
  • DOMAIN
  • DOUBLE
  • DROP
  • ELSE
  • END
  • END-EXEC
  • ESCAPE
  • EXCEPT
  • EXCEPTION
  • EXEC
  • EXECUTE
  • EXISTS
  • EXTERNAL
  • EXTRACT
  • FALSE
  • FETCH
  • FIRST
  • FLOAT
  • FOR
  • FOREIGN
  • FORTRAN
  • FOUND
  • FROM
  • FULL
  • GET
  • GLOBAL
  • GO
  • GOTO
  • GRANT
  • GROUP
  • HAVING
  • HOUR
  • IDENTITY
  • IMMEDIATE
  • IN
  • INCLUDE
  • INDEX
  • INDICATOR
  • INITIALLY
  • INNER
  • INPUT
  • INSENSITIVE
  • INSERT
  • INT
  • INTEGER
  • INTERSECT
  • INTERVAL
  • INTO
  • IS
  • ISOLATION
  • JOIN
  • KEY
  • LANGUAGE
  • LAST
  • LEADING
  • LEFT
  • LEVEL
  • LIKE
  • LOCAL
  • LOWER
  • MATCH
  • MAX
  • MIN
  • MINUTE
  • MODULE
  • MONTH
  • MUMPS
  • NAMES
  • NATIONAL
  • NATURAL
  • NCHAR
  • NEXT
  • NO
  • NONE
  • NOT
  • NULL
  • NULLIF
  • NUMERIC
  • OCTET_LENGTH
  • OF
  • ON
  • ONLY
  • OPEN
  • OPTION
  • OR
  • ORDER
  • OUTER
  • OUTPUT
  • OVERLAPS
  • PAD
  • PARTIAL
  • PASCAL
  • PLI
  • POSITION
  • PRECISION
  • PREPARE
  • PRESERVE
  • PRIMARY
  • PRIOR
  • PRIVILEGES
  • PROCEDURE
  • PUBLIC
  • READ
  • REAL
  • REFERENCES
  • RELATIVE
  • RESTRICT
  • REVOKE
  • RIGHT
  • ROLLBACK
  • ROWS
  • SCHEMA
  • SCROLL
  • SECOND
  • SECTION
  • SELECT
  • SEQUENCE
  • SESSION
  • SESSION_USER
  • SET
  • SIZE
  • SMALLINT
  • SOME
  • SPACE
  • SQL
  • SQLCA
  • SQLCODE
  • SQLERROR
  • SQLSTATE
  • SQLWARNING
  • SUBSTRING
  • SUM
  • SYSTEM_USER
  • TABLE
  • TEMPORARY
  • THEN
  • TIME
  • TIMESTAMP
  • TIMEZONE_HOUR
  • TIMEZONE_MINUTE
  • TO
  • TRAILING
  • TRANSACTION
  • TRANSLATE
  • TRANSLATION
  • TRIM
  • TRUE
  • UNION
  • UNIQUE
  • UNKNOWN
  • UPDATE
  • UPPER
  • USAGE
  • USER
  • USING
  • VALUE
  • VALUES
  • VARCHAR
  • VARYING
  • VIEW
  • WHEN
  • WHENEVER
  • WHERE
  • WITH
  • WORK
  • WRITE
  • YEAR
  • ZONE
Parent topic: Reference
Related concepts
Keywords
Related reference
EXECUTE IMMEDIATE


Micro Focus Database Connectors Version 2.0 for Windows

  • Database Connectors User's Guide
  • Database Connectors Tasks
  • Database Connectors Reference
  • Copyright and Legal Information
  • Notations and Conventions
Parent topic: Data Access


Database Connectors User's Guide

This book describes how to use Database Connectors interfaces to access relational database management systems from COBOL.

  • Database Connectors Overview
    This chapter provides an overview of Micro Focus Database Connectors and how you can use its interfaces to bridge the worlds of COBOL and Structured Query Language (SQL).
  • Getting Started
  • XFDs
  • Using XFD Directives
    This chapter explains what XFD directives are and how you can use them in your COBOL File Descriptors (FDs) to control how your database tables are built.
  • Invalid Data
    This chapter lists which COBOL data items are considered invalid and explains what happens to them when they are stored in the database. It also explains which database items are considered invalid and explains how these are translated to COBOL.
  • Working with COBOL
  • New and Existing Databases
    This chapter tells you how to handle your data in both existing and new databases.
  • Run Time Configuration
    Database Connectors™ uses an ACUFH configuration file to determine how the run time system should behave when interacting with data. This chapter describes the ACUFH configuration variable options that you can use to configure the run time system for your relational database environment.
  • Performance and Troubleshooting
  • Questions and Answers
  • Database Connectors for Microsoft SQL Server
  • Tutorial: Extending CICS Applications to Use Database Connector for Microsoft SQL Server
    This tutorial tells you how to extend an existing CICS application to use Micro Focus’s Database Connectors™ for Microsoft® SQL Server.
Parent topic: Micro Focus Database Connectors Version 2.0 for Windows


Database Connectors Overview

  • Introduction
  • RDBMS Support
  • Accessing Data
  • Database Concepts
  • How Database Connectors Works
Parent topic: Database Connectors User's Guide


Introduction

This guide describes how to use Database Connectors interfaces to access information stored in supported relational database management systems. It explains how to describe data in your COBOL programs and how to handle differences in the field names and data types that are passed between COBOL and the database engine.

Note: Unless otherwise indicated, the references to Windows in this Guide refer to the following versions of Windows operating systems:
  • Windows XP
  • Windows Vista
  • Windows 7
  • Windows 2003
  • Windows 2007
  • Windows 2008 R2
  • Windows 8
  • Windows 2012
When necessary to make a distinction among the individual versions of those operating systems, specific version numbers may be used.
Parent topic: Database Connectors Overview


RDBMS Support

Database Connectors supports the following RDBMS(s):
Database Connectors supports the following RDBMS(s):
  • Microsoft SQL Server
RDBMS Support includes the following:
RDBMS | Tested with RDBMS version | Probable compatibility, based on vendor information (Client/Server may be used for connecting to other versions)
Microsoft SQL Server | 2000, and 2005 | Versions greater than 6.5

Database Connectors use standard COBOL I/O statements to access databases. Database Connectors handles the translation between standard COBOL and the language used by the RDBMS.

Special instructions and status messages apply to each individual RDBMS. These are included in the appendices of this Guide. Each RDBMS has an appendix dedicated to its own specific information.

Parent topic: Database Connectors Overview


Accessing Data

COBOL systems includes a standard file system. The COBOL system files can optionally be replaced by (or used in conjunction with) database management systems such as Oracle, Microsoft SQL Server, and DB2. This is possible through the Micro Focus file handler, which can accommodate a wide variety of protocols.

  • Interface Routines
  • Extended File Descriptors (XFDs)
Parent topic: Database Connectors Overview


Interface Routines

All file systems communicate with the ACUFH File Handler via interface routines. The interfaces to various RDBMSs are available from Micro Focus as add-on modules. You can add any combination of traditional indexed file interfaces and RDBMS interfaces that meet particular needs. The run time system communicates with relational databases via the special family of add-on interfaces called Database Connectors.

Parent topic: Accessing Data


Extended File Descriptors (XFDs)

Database Connectors uses XFDs created by the compiler. These files map COBOL records into database fields and map the database fields back into records.

The following sections describe Database Connectors and explain how it interfaces to database systems by referencing XFDs. For detailed information about XFDs, see the section XFD Files in the chapter XFDs.

Parent topic: Accessing Data
Related information
XFD Files


Database Concepts

Relational databases differ from indexed file systems in several significant ways. These are the logical associations between database concepts and COBOL indexed file concepts:

Indexed File Concept | Database Concept
Directory | Database
File | Table
Record | Row
Field | Column

Or, put another way:

  • Database operations are performed on columns. Indexed file operations are performed on records
  • A COBOL indexed file is logically represented in database table format. Within a table, each column represents one COBOL field; each row represents one COBOL record
  • Database table columns are strictly associated with a particular data type, such as date, integer, or character. In COBOL, data can have multiple type definitions

For example, for Oracle, a COBOL record that looks like this:

01  terms-record.
    03  terms-code        pic 999.
    03  terms-rate        pic s9v999.
    03  terms-days        pic 9(2).
    03  terms-descript    pic x(15).

would be represented in the database as a table with a format similar to this:

Name | Null | Type
TERMS_CODE | NOT NULL | NUMBER (3)
TERMS_RATE | – | NUMBER (4, 3)
TERMS_DAYS | – | NUMBER (2)
TERMS_DESCRIPT | – | CHAR (15)
Parent topic: Database Connectors Overview


How Database Connectors Works

Database Connectors implements a direct, transparent interface between COBOL and RDBMSs.

Previously, accessing a relational database from a COBOL program involved writing SQL code and embedding that code in your program. You had to know SQL, and you had to write SQL statements appropriate for the specific database you wanted to access. Because your queries were tailored to suit one database management system, you had to re-code your COBOL application if you wanted to access a different RDBMS, or an indexed file system, or even to migrate a file from one system to another.

As an alternative, some interface products now translate COBOL I/O statements into direct reads and writes on the database files, without going through the driver, or engine, supplied by the database manufacturer. This means that the COBOL programmer must provide for enforcement of database rules that the engine already knows about and is designed to handle. Bypassing the database engine also means that new constraints or changes in the database structure require reprogramming of the COBOL application.

Database Connectors implements a more suitable approach by dynamically generating industry standard SQL from COBOL I/O statements. As the run time system is executing your COBOL application, Database Connectors is running behind the scenes to match up the requirements and rules of both COBOL and the RDBMS to accomplish the task set by your application. This means that Database Connectors uses the full power designed into the database engine. The engine enforces database rules and constraints; any violations are returned to the COBOL program as I/O error conditions.

  • What Is a Transparent Interface?
  • XFDs and Mapping
  • Summary
Parent topic: Database Connectors Overview


What Is a Transparent Interface?

Database Connectors provide a transparent, efficient interface between your program and the relational database. The interface is categorized as transparent because the communication between your COBOL program and the database is smooth, with no special query coding on your part and no interruptions in the execution of your program. You need not change your COBOL code if you later want to access a different database or to access an alternate indexed file system.

The information exchange operations between the database and the COBOL program are invisible to the end user. For example, if your program specifies a READ, a database query is automatically generated by the interface. Then the data that is read from the database is translated into a COBOL record. This exchange occurs in fractions of a second, and the application proceeds without interruption.

Parent topic: How Database Connectors Works


XFDs and Mapping

Because relational databases handle I/O at the column (field) level, and COBOL handles I/O at the record level, some mapping is necessary to associate records with their fields. One function of Database Connectors is to map COBOL records into database fields, and to map the database fields back into records. Database Connectors does this by consulting XFDs generated by the Compiler. The detailed structure of XFDs is discussed in the section XFD Files in the chapter XFDs.

Database Connectors builds its own database queries dynamically whenever an input or output request is received. You just compile your program, and Database Connectors does the rest.

Parent topic: How Database Connectors Works
Related information
To prepare and execute your program
XFD Files


Summary

Database Connectors ensures that all database changes are immediately available to your COBOL program. It also ensures that all data updates to your COBOL program are immediately reflected in the database.

After your XFDs are generated, you can switch to a different RDBMS simply by setting DEFAULT_HOST to point to the new RDBMS. No recompiling is necessary.

Because Database Connectors accesses the database through its native engine, the full relational integrity of the database is maintained. The COBOL program need not be concerned about such things as enforcing relationships between keys and foreign keys on tables or constraints on field relationships and contents.

If you have specified that a file is to reside on a RDBMS by setting either DEFAULT_HOST or filename_HOST, an OPEN OUTPUT filename statement in your COBOL program generates a CREATE TABLE filename function on the specified host database. Appropriate permissions are granted based on login and password and on set access parameters. (For details, see the Contents pane to find the appendix specific to your RDBMS.) For large tables, your systems database administrator can create the table and indexes for you. Databases offer many methods for creating tables that may improve performance for large tables, such as spreading the table across multiple hard drives or storing the data and the indexes on different drives.

Note: Database Connectors uses a specific naming convention for indexes it creates. Indexes created with Database Connectors use the i<TABLENAME>_<key value> convention. If you are using indexes created outside of the Database Connectors application, you must ensure that the index names match the Database Connectors naming convention.

Changes to the way a database functions should be carefully considered and tested before being fully implemented. If a database violation occurs, the engine detects it, and Database Connectors returns an I/O error condition to the COBOL program. The program can, if desired, call a standard COBOL library routine for an extended error description.

It is possible that there are library routines that do not work with or do not make sense to use with some of the Database Connectors interfaces. To find out if that is the case with your Database Connectors interface, look in the Common Questions and Answers section of the appendix specific to your interface.

Parent topic: How Database Connectors Works
Related information
DEFAULT_HOST configuration variable
filename_HOST configuration variable


Getting Started

This chapter points you in the right direction for installing and setting up the Database Connectors interface for your particular relational database system (RDBMS). Once Database Connectors is installed and ready, you should return to this chapter to find the information you need for preparing and compiling a COBOL program and running the demo program.

  • Licensing
  • The Demonstration Program
Parent topic: Database Connectors User's Guide


Licensing

Database Connectors is licensed through Sentinel RMS. For information and instructions on licensing Database Connectors, search for Development Licensing in your product help.

Parent topic: Getting Started


The Demonstration Program

As soon as your installation and setup are complete, you may run the demonstration program (demo.cbl) included on your distribution medium. This program illustrates many of the Database Connectors product capabilities, including how to

  • Map RDBMS data types to traditional COBOL data types
  • Compile a COBOL program in preparation for interfacing with an RDBMS
  • Modify records within the RDBMS database

The demo program simulates what might be used in a distributor’s shipping department. You'll be creating the orderfile table, which contains information about the orders placed by the distributor's customers. The orderfile table has the following columns of information (the database data type and COBOL data type are shown for each).

Note: The data type may be slightly different depending on your RDBMS.
Column Name | Data Type | COBOL PIC
ORDER_NUM | CHAR(4) | pic x(4)
ORDER_DATE | DATE | pic 9(6)
CUSTOMER_NUM | CHAR(3) | pic x(3)
SHIP_INSTRUCT | CHAR(40) | pic x(40)
BACKLOG | CHAR(1) | pic x
PO_NUM | CHAR(10) | pic x(10)
SHIP_DATE | DATE | pic 9(6)
SHIP_WEIGHT | NUMBER(8,2) | pic 9(6)v99
SHIP_CHARGE | NUMBER(6,2) | pic 9(4)v99
PAID_DATE | DATE | pic 9(6)

Here is the COBOL file descriptor (FD) that matches the orderfile table. Note that the FD entries must match the names of the RDBMS fields and must match their data types:

fd  orders.
01  order-record.
    03  order-num              pic x(4).
    03  order-fields.
        05  order-date         pic 9(6).
        05  customer-num       pic x(3).
        05  ship-instruct      pic x(40).
        05  backlog            pic x.
        05  po-num             pic x(10).
        05  ship-date          pic 9(6).
        05  ship-weight        pic 9(6)v99.
        05  ship-charge        pic 9(4)v99.
        05  paid-date          pic 9(6).

First compile the demo program, demo.cbl, using standard compile commands with the CALLFH (ACUFH) directive. The demo.cbl program contains compiler directives at the top of the program to generate an eXtended File Descriptors (XFD) file called orderfile.xfd (for information about XFDs, see the chapter XFDs.) You may also specify these directives on your compile command line. The run time system uses this XFD to map RDBMS data types to COBOL data types.

Database Connectors create new tables in the target database when your COBOL application issues an OPEN OUTPUT command. If you turn on file tracing for a COBOL program that performs this operation on a target file, you can see the series of SQL statements generated by the run time system to create the database table, indexes, and access permissions. This can be useful should you wish to have a set of stand-alone SQL scripts to generate test databases or base set of tables for an end user install for your COBOL files to work with.

Parent topic: Getting Started
Related information
To start the demo program
XFDs


XFDs

Extended File Descriptors (XFDs) map COBOL records to database fields. These are called XFDs because they're based on standard COBOL File Descriptors (FDs). An XFD file is created as an XML file. The XFD contains a description of a COBOL indexed, sequential, or relative file based on its fields. XFDs are used to interface to database management systems.

  • XFD Files
Parent topic: Database Connectors User's Guide


XFD Files

To create an XFD, use the CREATEXFD directive. When you specify the CREATEXFD directive with no parameters, an .xfd file is created for each indexed data file specified in the compiled program. XFDs are generated in XML format in the latest XFD version available (Version 6). XFDs are stored in your source code directory by default.

Specify all to generate XFDs for all indexed, relative, and sequential files, and specify an XFD path if you want to store your XFDs in a directory other than your source code directory.

Once you compile with the CREATEXFD directive, each COBOL file has a corresponding .xfd file. The directive creates .xfd files without changing anything in the object code.

Creating XFD files at compile time offers two significant advantages:

  • Any changes made to the file definitions are automatically included in the XFDs when the program is recompiled
  • The effects of all compile-time options, COPY REPLACING, and source-code control lines are reflected correctly in the XFDs
  • How XFDs are Formed
  • Defaults Used in XFD Files
  • Summary of XFD Fields
  • Identical Field Names
  • Long Field Names
  • Naming the XFD File
  • Forming the Final XFD Name
  • Mapping Other Files to an XFD
Parent topic: XFDs
Related information
CREATEXFD directive


How XFDs are Formed

XFDs enable the interface to create a table (or access an existing one) in the database for each indexed file. Each column in the table contains the values for one field. The column names are essentially the field names.

The table that is built is based on the largest record in the COBOL file and contains the fields from that record plus any key fields (key fields are those that are named in KEY IS phrases of SELECT verbs in the FILE CONTROL section). This ensures that data from all COBOL records fit within the table and simplifies the storage and retrieval process. If you were to examine the database columns, only the fields from the largest record, and the key fields, would appear. For additional information, see the section Defaults Used in XFD Files.

Note: If the field named in the KEY IS phrase is a group item, it does not become a column in the database table. Instead, each of the elementary items subordinate to the named group item become a column. You can force a group item to be a column by using the USE GROUP XFD directive.

With multiple record formats (level 01), not all COBOL fields are represented in the database by name, but all fields are storable and retrievable. The XFD maps fields from all records of a file to the corresponding locations in the master (largest) record of the file, and thus to the database table. Since Database Connectors has access to the XFD, it knows where the data from a given COBOL record fits in the database tables. This activity is invisible to the COBOL application.

For example, if your program has one file with the three records shown below, the underlined fields are included in the database table by default (this example assumes that ar-codes-key is named in a KEY IS phrase). Some fields do not appear in the table, but the XFD maps them to the master field names. Database Connectors thus eliminates redundancies for optimum performance.

01  ar-codes-record.
    03  ar-codes-key.
        05  ar-code-type      pic x.
        05  ar-code-num       pic 999.
01  ship-code-record.
    03  filler                pic x(4).
    03  ship-weight           pic s999v9.
    03  ship-instruct         pic x(15).
01  terms-code-record.
    03  filler                pic x(4).
    03  terms-rate-1          pic s9v999.
    03  terms-days-1          pic 9(3).
    03  terms-rate-2          pic s9v999.
    03  terms-descript        pic x(15).

The following diagram shows how Database Connectors creates database columns for some of the fields in the COBOL record, while the XFD maps other fields to those columns; this means that all of the fields are accessible to the COBOL program.

Making Field Accessible to COBOL Programs

See the section Defaults Used in XFD Files for a description of rules that Database Connectors follows as it builds the database table and an explanation of how you can override those rules when necessary.

Parent topic: XFD Files
Related information
USE GROUP XFD directive
Defaults Used in XFD Files
KEY IS Phrase


Defaults Used in XFD Files

Several elements of COBOL require special handling when XFDs are built. These include multiple record definitions REDEFINES, FILLER, and OCCUR. This section describes how the compiler handles each of these situations.

Note that in many instances you can override the default behavior described below by placing special comment lines in the FDs of your COBOL code. These comments are called XFD directives, and are described in the chapter Using XFD Directives. For example, the WHEN XFD directive lets you use multiple definitions for a single set of data by specifying when each definition should be used.

Databases generally do not support the notion of multiple definitions for the same column. As the following paragraphs explain, whenever a COBOL program gives more than one definition for the same data, the compiler chooses which definition to use in the XFD and disregards the rest.

  • KEY IS Phrase
  • REDEFINES Clause
Parent topic: XFD Files
Related information
WHEN XFD directive
Using XFD Directives


KEY IS Phrase

Fields named in KEY IS phrases of SELECT statements are included as column names. Other fields that occupy the same areas as the key fields (by either explicit or implicit redefinition) are not included by name, but are mapped to the key field column names by the XFD.

Remember, if the field named in the KEY IS phrase is a group item, it does not become a column in the database table unless a USE GROUP XFD directive is used (see the section How XFDs are Formed). Instead, the subordinate fields of the group item are used.

Parent topic: Defaults Used in XFD Files
Related information
How XFDs are Formed
USE GROUP XFD directive


REDEFINES Clause

Fields contained in a redefining item occupy the same positions as the fields being redefined. The compiler needs to select only one of the field definitions to use. The default rule that it follows is to use the fields in the item being redefined as column names; the XFD maps fields that appear subordinate to a REDEFINES clause to column names.

Multiple Record Definitions

This same rule extends to multiple record definitions. In COBOL, multiple record definitions are essentially redefinitions of the entire record area. This leads to the same complication that is encountered with REDEFINES: multiple definitions for the same data. So the compiler needs to select one definition to use.

Multiple Record Definitions

Because the multiple record types can be different sizes, the compiler needs to use the largest one, so that it can cover all of the fields adequately. Thus, the compiler's rule is to use the fields in the largest record defined for the file. If more than one record is of the largest size, the compiler uses the first one.

Group Items

Note that group items are, by default, never included in an XFD for the same reason that REDEFINES are excluded: they result in multiple names for the same data items. You can, however, choose to combine grouped fields into one data item by specifying the USE GROUP XFD directive.

FILLER Data Items

In a COBOL FD, FILLER data items are essentially place holders. FILLER items are not uniquely named and thus cannot be uniquely referenced. For this reason, they are not placed into the XFD. The XFD maintains the correct mapping of the other fields, and no COBOL record positional information is lost.

Sometimes you need to include a FILLER data item, such as when it occurs as part of a key. In such a case, you could include it under a USE GROUP XFD directive or give it a name of its own with the NAME XFD directive.

OCCURS Definition

An OCCURS clause always requires special handling, because the run time system must assign a unique name to each database column. The run time system accomplishes this by appending sequential index numbers to the item named in the OCCURS clause.

For example, if the following were part of a file's description:

03  employee-table occurs 20 times.
    05  employee-number            pic 9(3)

these column names would be created in the database table:

employee_number_1
employee_number_2
.
.
.
employee_number_10
employee_number_11
.
.
.
employee_number_20

Note that the hyphens in the COBOL code are translated to underscores in database field names, and the index number is preceded by an underscore.

Parent topic: Defaults Used in XFD Files
Related information
USE GROUP XFD directive
NAME XFD directive


Summary of XFD Fields

Fields defined with an OCCURS clause are assigned unique sequential names. Fields without names are disregarded. When multiple fields occupy the same area, the compiler chooses only one of them unless you have a WHEN XFD directive to distinguish them. To choose, the compiler:

  • Preserves fields mentioned in KEY IS phrases
  • Discards group items unless USE GROUP is specified
  • Discards REDEFINES
  • Uses the largest record if there are multiple record definitions
Parent topic: XFD Files
Related information
WHEN XFD directive


Identical Field Names

In COBOL, you distinguish fields with identical names by qualification. For example, there are two fields named RATE in the following code, but they can be qualified by their group items. Thus, you would reference RATE OF TERMS-CODE and RATE OF AR-CODE in your program:

01  record-area.
    03  terms-code.
        05  rate                   pic s9v999.
        05  days                   pic 9(3).
        05  descript               pic x(15).
    03  ar-code.
        05  rate                   pic s9v999.
        05  days                   pic 9(3).
        05  descript               pic x(15).

Database systems consider duplicate names an error. Thus, if more than one field in a particular file has the same name, the XFD is not generated for that file.

The solution to this situation is to add a NAME XFD directive that associates an alternate name with one or both of the conflicting fields.

Parent topic: XFD Files
Related information
NAME XFD directive


Long Field Names

To meet the SQL requirements of some relational database management systems (RDBMSs), the Database Connectors run time truncates long field names to the maximum allowed by the RDBMS. (In the case of the OCCURS clause described above, the truncation is to the original name, not the appended index numbers. However, the final name, including the index number, is limited to the RDBMS maximum.) It's a good idea to make sure that your field names are unique (and meaningful) within the first 18 characters.

The database you are connecting to may allow longer names, and if so, more characters are used. Names longer than 30 characters generate a warning. Instead of allowing default truncation, use the NAME XFD directive to give a shorter alias to a field with a long name. Note that within the COBOL application you can continue to use the original name. The NAME XFD directive affects only the XFD connection to the RDBMS table.

Parent topic: XFD Files
Related information
NAME XFD directive


Naming the XFD File

The compiler needs to give a name to each XFD file that is built. It attempts to build the name from your COBOL code, although there are some instances where the name in the code is nonspecific, and you must provide a name.

Each XFD name is built from a starting name that is derived (if possible) from the SELECT statement in your COBOL code. The following table explains how that occurs.

ASSIGN name is a variable | If the SELECT for the XFD file has a variable ASSIGN name (ASSIGN TO filename), you must specify a starting name for the .xfd file via a FILE XFD directive in your code. This process is described in the chapter Using XFD Directives
ASSIGN name is a constant | If the SELECT for the XFD file has a constant ASSIGN name (such as ASSIGN TO COMPFILE), that name is used as the starting name for the .xfd file name
ASSIGN name is generic | If the ASSIGN phrase refers to a generic device (such as ASSIGN TO DISK), the compiler uses the SELECT name as the starting name for the XFD
Parent topic: XFD Files
Related information
FILE XFD directive
Using XFD Directives


Forming the Final XFD Name

From the starting name, the final name is formed as follows:

  • The compiler removes any extensions from the starting name
  • It constructs a universal base name by stripping out directory information that fits any of the formats used by the operating systems that run the compiler
  • It reduces the base name to eight characters and converts it to lower case
  • It appends the letters .xfd to the base name

Examples of XFD names

COBOL code File name
ASSIGN TO "usr/ar/customer.dat"
 customer.xfd
SELECT TESTFILE, ASSIGN TO DISK
 testfile.xfd
ASSIGN TO FILENAME
 (you specify)
Parent topic: XFD Files


Mapping Other Files to an XFD

At run time, it is possible to use a single XFD for files that have different names. For example, suppose a site has customer files that have identical structures but different names (such as CUST0001, CUST0002, and CUST0003). It's not necessary to have a separate XFD for each file, as long as their record definitions are the same.

The individual files can all be mapped to the same XFD via an ACUFH configuration file variable called XFD_MAP. The following paragraphs describe how this works.

Suppose your COBOL application has a SELECT with a variable ASSIGN name, such as customer-file. This variable assumes different values (such as CUST0001 and CUST0002) during program execution.

Before compiling the application, you would use the FILE XFD directive to provide a base name for the XFD. Suppose you provide CUST as the base. The compiler would then generate an XFD named cust.xfd. (The compiler always converts XFD names to lower case.)

To ensure that all customer files, each having a unique name, use this same XFD, enter the following in your ACUFH configuration file:

XFD_MAP   CUST* = CUST

The asterisk ("*") in the example is a wildcard that matches any number of characters. Note that the extension .xfd should not be included in the map. This statement would cause the XFD cust.xfd to be used for all files whose names begin with CUST.

The XFD_MAP variable has this syntax:

XFD_MAP   [pattern = base-xfd-name]  ...

where pattern consists of any valid filename characters and may include "*" or "?". These two characters have special meanings in the pattern:

* | matches any number of characters
? | matches a single occurrence of any character

For example:

CUST???? | matches CUST0001 and CUSTOMER; does not match CUST001 or CUST00001
CUST* | matches all of the above
CUST*1 | matches CUST001 and CUST0001 and CUST00001; does not match CUSTOMER
*OMER | matches CUSTOMER; does not match CUST001 or CUST0001

The XFD_MAP variable is read during the open file stage of any Connector interfaces linked into the run time system.

XFD values can be replaced or added to the end of existing XFD map values by setting the XFD_MAP_RESETS ACUFH configuration file variable. This variable determines whether setting XFD_MAP adds to or replaces the existing value. When this variable is set to 0 (off, false, no), setting XFD_MAP adds new value patterns to the end of the existing value. When XFD_MAP_RESETS is set to 1 (on, true, yes), setting XFD_MAP replaces the existing value with a new value. The default value is 1 (on, true, yes).

This variable may be useful if you need to include multiple XFD_MAP lines in an ACUFH configuration file and want to avoid setting and resetting the variable. When multiple lines exist, all patterns are used in the order they are listed.

Parent topic: XFD Files
Related information
XFD_MAP configuration variable
FILE XFD directive
XFD_MAP_RESETS configuration variable


Using XFD Directives

  • Introduction
  • XFD Directive Syntax
  • Supported XFD Directives
Parent topic: Database Connectors User's Guide


Introduction

EXtended File Descriptors (XFDs) are based on your COBOL File Descriptors (FDs). Each XFD describes all of the fields for one file.

XFD directives are optional comments that you can use in your FDs to control how things look on the database side. Many applications use only the CREATEXFD directive. XFD directives are most commonly used when a site intends to do a lot of work with the relational database management system (RDBMS) outside of the COBOL application, and wants to control how the database table is built.

XFD directives are special comments placed into an FD in your COBOL source code. They guide the building of the XFDs, which in turn guide the building of the database table.

Each XFD directive includes the letters XFD. These three letters indicate to the compiler that the comment is to be used in XFD generation.

XFD directives provide extended control over how the database table is built. Among other things, they let you:

  • Specify a column name to be used in the database table, in place of a COBOL field name.
  • Map elementary items of a group item together into a single column.
  • Cause numeric COBOL data to be treated as a text string in the database.
  • Cause the fields from a specific record in a file to appear in the database table (rather than just the fields from the largest record).
  • Assign a column the DATE type, providing the built-in functionality that dates have in the RDBMS.
  • Give a name to the XFD file itself.

XFD directives are always placed within a COBOL FD. They do not affect Procedure Division I/O statements, and they do not change your COBOL fields in any way. Rather, they guide the building of the XFDs, giving you control over the way COBOL data maps to database fields.

You can build XFDs directly from your source code with only the CREATEXFD directive if the default mapping rules described in the chapters XFDs and New and Existing Databases are sufficient for your situation. If you would like to override the default mapping behavior or map a field to a different name, you must add additional XFD directives to your COBOL code.

Parent topic: Using XFD Directives
Related information
XFDs
New and Existing Databases


XFD Directive Syntax

Place each XFD directive syntax on a line by itself, immediately before the COBOL line to which it pertains.

Introduce each XFD directive with a $ in the Indicator Area (column 7 in standard ANSI source format), followed immediately by the letters XFD, and then the XFD directive itself. There should be no space between the $ and the XFD. Spaces are permitted elsewhere on the line as separators. For example, the NAME XFD directive looks like this:

$XFD  NAME = EMP-NUMBER

Note that XFD directives are case-insensitive and that hyphens and underscores are considered equivalent. Thus, for example,

$XFD VAR_LENGTH
$XFD VAR-LENGTH
$xfd var_length
$xfd var-length

are all recognized as equivalent.

Two or more XFD directives that pertain to the same line of COBOL code may be combined on one comment line. The XFD directives should be separated by a space or a comma. For example, to specify both USE GROUP and NUMERIC at the same time, you would add this line:

$XFD  USE GROUP, NUMERIC
  • Line Continuation for Complex XFDs
    Syntax for XFD directives that exceed one line.
Parent topic: Using XFD Directives


Line Continuation for Complex XFDs

$XFD directives may be continued onto multiple lines by specifying a single character backslash (\) as the last non-blank character on a line. For example:

$XFD WHEN (var1 = "abc" and var2 = "def"    \
$XFD       and (var3 = "ghi" or var4 = "jkl"))  \
$XFD       or var5 != "xyz"

Line Continuation Rules

  • $XFD directives are continued via a backslash as the last non-blank character on the line.
  • Continued lines begin with $XFD just like the first directive line (with the dollar sign in the indicator column).
  • The final continuation line omits the trailing backslash.
  • "The overall combined directive is a concatenation of all of the continuation lines.
  • The next character after the blank that follows $XFD is the next character of the directive. That character logically replaces the backslash on the previous line.
  • There is no limit on the number of continuation lines other than the limit on total program source lines, and the overall size of the continued directive is limited only by available memory. But it is highly unlikely that one XFD directive would ever need to exceed a few dozen lines or a few thousand characters.
  • In standard ANSI source format the contents of columns 73-80 are ignored, the continuation backslash must appear in Area B (columns 12-72).
  • Backslashes within data (literals) do not cause a problem because they are inside quoted strings (and cannot be the last non-blank character on the line).
  • In-line comments ("*>") are not allowed on continued XFD directive lines.
  • A new error message is generated for a syntax error within continued XFD directive lines and the erroneous continuation lines scanned up to that point are ignored. Possible syntax errors include placing a source line other than a comment line within an intended sequence of continued XFD directive lines, or omitting the final continuation line (the line that begins with $XFD and does not end with a trailing backslash). Other errors are possible when the directive itself is scanned and processed.
Parent topic: XFD Directive Syntax


Supported XFD Directives

The following XFD directives are supported. For complete definitions of these directives, look in the Reference > XFD Directives section of the Database Connectors Help.

XFD Directive | Brief Description
ALPHA | Allows you to treat a data item as alphanumeric text in the database, when it is declared as numeric in the COBOL program
BINARY | Specifies that the data in the field could be alphanumeric data of any classification
COBOL-TRIGGER | Tells Database Connectors that a COBOL trigger is to be executed
COMMENT | Allows you to include comments in an XFD file
DATE | Stores a field in the database as a date
FILE | Supplies a starting name from which the XFD file name is formed
NAME | Assigns a database field name to the field defined on the next line
NUMERIC | Allows you to treat a data item as an unsigned integer when it is declared as alphanumeric
SECONDARY_TABLE | Indicates that the next data item may be placed into a subordinate table
USE GROUP | Allows you to enter a group item into the database as a single field
VAR_LENGTH | Requests that the data item that immediately follows the XFD directive be assigned a type that implies variable length
WHEN | Lets you include multiple record definitions or REDEFINES in a database table
XSL | Allows you to include a stylesheet reference in the XML header
Parent topic: Using XFD Directives


Invalid Data

  • Illegal COBOL Data
  • Invalid Database Data
Parent topic: Database Connectors User's Guide


Illegal COBOL Data

COBOL data (except key data) that is illegal by database standards is stored in the database as null unless you specifically override this default. (Use the ACUFH configuration file variable 4GL_ILLEGAL_DATA to override.)

The following COBOL data usages are considered illegal by the database:

 | Illegal Values
USAGE DISPLAY numbers | LOW-VALUES , HIGH-VALUES, and SPACES
COMP-2 numbers | HIGH-VALUES and SPACES
COMP-3 numbers | HIGH-VALUES

All other numeric types fit one of the preceding cases (depending on their internal storage format)

DATE fields | The value "zero" and any other illegal conditions as defined by the date's USAGE type (see above)
text fields | LOW-VALUES

BINARY numbers are always legal, and all values are legal in BINARY text fields.

  • Invalid Key Data
  • Invalid Data Other Than Keys
Parent topic: Invalid Data
Related information
4GL_ILLEGAL_DATA configuration variable


Invalid Key Data

Any field that is part of a key is never stored as null. (A null key does not have a well-defined position in relation to other keys.) If a key field has an illegal value, the field is stored in the database as described here:

Illegal LOW-VALUES | minimum possible value (0 or -99999...) minimum possible date value (01/01/01)
Illegal HIGH-VALUES | maximum possible value (99999...) maximum possible date value (database dependent)
Illegal SPACES | zero (or 01/01/01 for a date field)
Parent topic: Illegal COBOL Data


Invalid Data Other Than Keys

You have the option to convert illegal data, other than keys, into legal values by setting the configuration variable 4GL_ILLEGAL_DATA to Converted. When this is set, the Database Connectors interface converts data the same way it does for keys.

4GL_ILLEGAL_DATA can also be set to Null to indicate that illegal COBOL data other than keys should be converted to null. This is the default behavior.

Parent topic: Illegal COBOL Data


Invalid Database Data

WhenDatabase Connectors receives a null field from the database, it translates it to COBOL as follows:

Numbers (including dates): | zero
Text (including binary): | spaces

For additional information about the handling of invalid dates, see the DATE XFD directive.

Parent topic: Invalid Data
Related information
4GL_ILLEGAL_DATA configuration variable
DATE XFD directive


Working with COBOL

After the environment has been set up for the Database Connectors interface, you are ready to use the system. This chapter describes how to prepare your COBOL program and compile it for use with Database Connectors.

  • Preparing and Compiling a Program Example
  • Creating a COBOL Application
Parent topic: Database Connectors User's Guide


Preparing and Compiling a Program Example

The following example and its modifications are included as samples in the installation directory. It shows how to set up a COBOL program to use Database Connectors.

Note: If you are not familiar with XFD directives, you may want to read the chapter Using XFD Directives before continuing with this section.

The purchase orders file from a COBOL program at an imaginary company are stored in the database. This file contains the records that handle all of the information from the company's purchase orders.

Within the purchase orders file are two record types:

  • The purchase order header record (there is one of these for each purchase order form)
  • The purchase order detail record (there is one detail record for each line item in a purchase order)

The file is keyed off the purchase order number. This example builds and examines the database table three times, to illustrate three different approaches to using the COBOL file descriptor:

  • First, only the largest record is included in the database table.
  • Second, the WHEN XFD directive is added, and the program recompiled. This causes all record formats to be included in the database.
  • Finally, several fields are grouped together and renamed for convenience.
IDENTIFICATION DIVISION.
program-id.  purchase.
ENVIRONMENT DIVISION.
input-output section.
file-control.

select p-o-file
assign to disk "purch1"
organization is indexed
access mode is dynamic
record key is p-o-number
file status is p-o-status.

DATA DIVISION.
file section.
fd p-o-file.
01 p-o-record.
   03 p-o-division-number                pic 9(3).
   03 p-o-record-type                    pic x.
      88 header-record                   value "h".
      88 detail-record                   value "d".
   03 p-o-number                         pic 9(10).
   03 p-o-number-detail redefines
         p-o-number.
      05 picking-ticket-number           pic 9(6).
      05 shipping-region                 pic 9(2).
      05 p-o-customer-type               pic 9(2).
      05 p-o-customer-breakdown redefines
            p-o-customer-type.
         07 customer-category            pic x.
         88 p-o-customer-retail          value "r".
         88 p-o-customer-whlsale         value "w".
         07 customer-pay-format          pic x.
            88 is-net-30                 value "3".
            88 is-net-10                 value "1".
   03 p-o-date.
      05 p-o-yy                          pic 9(2).
      05 p-o-mm                          pic 9(2).
      05 p-o-dd                          pic 9(2).

01 p-o-detail-record.
   03 p-o-dept-number                    pic 9(3).
   03 p-o-record-type                    pic x.
   03 detail-p-o-number                  pic 9(10).
   03 p-o-shipping-info.
      05 p-o-quantity-to-ship            pic s9(4) comp.
      05 p-o-total-quantity              pic s9(4) comp.
   03 p-o-notes.
      05 notes-line occurs 3 times       pic x(40).
working-storage section.
01 p-o-status                            pic x(2).
PROCEDURE DIVISION.
level-1 section.
main-logic.

open output p-o-file.
close p-o-file.
stop run.
  • Compiling with just the CREATEXFD directive
  • Compiling with the WHEN XFD Directive
  • Using Additional XFD Directives
Parent topic: Working with COBOL
Related information
Using XFD Directives


Compiling with just the CREATEXFD directive

You can compile the preceding program with just the CREATEXFD directive to generate the XFD. The compiled program builds the database table shown at the end of this section.

The database table builds as follows.
  • First, any fields listed in the KEY IS clause of the SELECT are included (p-o-number in this example).
  • The compiler then takes the largest record (p-o-detail-record) and lists the fields that make up that record.
The rest of this section shows the specific fields that are placed into the table.

All data from the COBOL program is stored in and retrieved from the database, even though not all fields are explicitly named in the database table. For a description of how this works, see the chapter XFDs.

The underlined fields are the only ones entered into the table:

fd p-o-file.
 01  p-o-record.
     03  p-o-division-number                   pic 9(3).
     03  p-o-record-type                       pic x.
         88  header-record                     value "h".
         88  detail-record                     value "d".
     03  p-o-number                            pic 9(10).
     03  p-o-number-detail redefines p-o-number.
         05  picking-ticket-number             pic 9(6).
         05  shipping-region                   pic 9(2).
         05  p-o-customer-type                 pic 9(2).
         05  p-o-customer-breakdown redefines
               p-o-customer-type.
             07  customer-category             pic x.
                 88  p-o-customer-retail       value "r".
                 88  p-o-customer-whlsale      value "w".
             07  customer-pay-format           pic x.
                 88 is-net-30                  value "3".
                 88 is-net-10                  value "1".
     03  p-o-date.
         05  p-o-yy                            pic 9(2).
         05  p-o-mm                            pic 9(2).
         05  p-o-dd                            pic 9(2).

 01  p-o-detail-record.
     03  p-o-dept-number                       pic 9(3).
     03  p-o-record-type                       pic x.
     03  detail-p-o-number                     pic 9(10).
     03  p-o-shipping-info.
         05  p-o-quantity-to-ship              pic s9(4) comp.
         05  p-o-total-quantity                pic s9(4) comp.
     03  p-o-notes.
         05  notes-line occurs 3 times         pic x(40).

As the table is built:

  • Any hyphens in the COBOL field names are converted to underscores
  • Field names longer than 18 characters generate a warning if the first 18 characters are not unique. Some databases limit you to 18 total characters. Use the least number of characters for optimal portability and end-user efficiency. You can use the NAME XFD directive for this to avoid changing your procedure division code.
  • Fields in OCCURS clauses get special handling, because the run time system must assign a unique name to each data item. Sequential index numbers are appended to the item named in the OCCURS. Limits vary between databases. See to the documentation for your RDBMS. In some instances, the name may be truncated by the Connector if necessary before the index is added.
Note: detail-p-o-number is not part of the table because the key overlays this area.

The following table is built in the database:

Column Name | Type
p_o_number | number(10)*
p_o_dept_number | number(3)*
p_o_record_type | char(1)
p_o_quantity_to_ship | number(4)*
p_o_total_quantity | number(4)*
notes_line_1 | char(40)
notes_line_2 | char(40)
notes_line_3 | char(40)

* The actual database data type may vary.

See the Limits and Ranges section for your specific RDBMS for a list of supported data types and their COBOL equivalents.

Parent topic: Preparing and Compiling a Program Example
Related information
XFDs
NAME XFD directive


Compiling with the WHEN XFD Directive

Suppose you want both record formats to be placed into the table. This might be the case if you intend to do any work within your RDBMS. Add the WHEN XFD directive in front of each record, as shown below. The underlined fields are entered into the table:

fd p-o-file.
$xfd when p-o-record-type = "h"
 01  p-o-record.
     03  p-o-division-number                       pic 9(3).
     03  p-o-record-type                           pic x.
         88  header-record                         value "h".
         88  detail-record                         value "d".
     03  p-o-number                                pic 9(10).
     03  p-o-number-detail redefines p-o-number.
         05  picking-ticket-number                 pic 9(6).
         05  shipping-region                       pic 9(2).
         05  p-o-customer-type                     pic 9(2).
         05  p-o-customer-breakdown redefines
               p-o-customer-type.
             07  customer-category                 pic x.
                 88  p-o-customer-retail           value "r".
                 88  p-o-customer-whlsale          value "w".
             07  customer-pay-format               pic x.
                 88  is-net-30                     value "3".
                 88  is-net-10                     value "1".
     03  p-o-date.
         05  p-o-yy                                pic 9(2).
         05  p-o-mm                                pic 9(2).
         05  p-o-dd                                pic 9(2).
$xfd when p-o-record-type = "d"
 01  p-o-detail-record.
     03  p-o-dept-number                           pic 9(3).
     03  p-o-record-type                           pic x.
     03  detail-p-o-number                         pic 9(10).
     03  p-o-shipping-info.
         05  p-o-quantity-to-ship                  pic s9(4) comp.
         05  p-o-total-quantity                    pic s9(4) comp.
     03  p-o-notes.
         05  notes-line occurs 3 times             pic x(40).
Note: p-o-record-type is entered into the table only once. The detail-p-o-number field is not part of the table, because the key overlays this area.

The following table is built in the database:

Column Name | Type
p_o_division_number | number(3)*
p_o_record_type | char(1)
p_o_number | number(10)*
p_o_yy | number(2)*
p_o_mm | number(2)*
p_o_dd | number(2)*
p_o_dept_number | number(3)*
p_o_quantity_to_ship | number(4)*
p_o_total_quantity | number(4)
notes_line_1 | char(40)
notes_line_2 | char(40)
notes_line_3 | char(40)

* The actual database data type may vary.

Note: When p_o_record_type is h, p_o_dept_number, p_o_quantity_to_ship, p_o_total_quantity, and notes_lines_1, 2, and 3 become NULL. When p_o_record_type is d, p_o_division_number, p_o_yy, p_o_mm and p_o_dd become NULL.
Parent topic: Preparing and Compiling a Program Example
Related information
WHEN XFD directive


Using Additional XFD Directives

In this final approach, streamline the code to introduce the following changes:

  • Apply the USE GROUP XFD directive to the notes to group them, which improves execution speed and clarity. Accessing each note line individually from the database side is not required.
  • Rename the notes field for convenience.
  • Apply the USE GROUP and DATE XFD directives to the date, to give it all the properties of a date on the database side.
fd p-o-file.
$xfd when p-o-record-type = "h"
 01  p-o-record.
     03  p-o-division-number                      pic 9(3).
     03  p-o-record-type                          pic x.
         88  header-record                        value "h".
         88  detail-record                        value "d".
     03  p-o-number                               pic 9(10).
     03  p-o-number-detail redefines p-o-number.
         05  picking-ticket-number                pic 9(6).
         05  shipping-region                      pic 9(2).
         05  p-o-customer-type                    pic 9(2).
         05  p-o-customer-breakdown redefines
               p-o-customer-type.
             07  customer-category                pic x.
                 88  p-o-customer-retail          value "r".
                 88  p-o-customer-whlsale         value "w".
             07  customer-pay-format              pic x.
                 88  is-net-30                    value "3".
                 88  is-net-10                    value "1".
$xfd use group, date
     03  p-o-date.
         05  p-o-yy                               pic 9(2).
         05  p-o-mm                               pic 9(2).
         05  p-o-dd                               pic 9(2).
$xfd when p-o-record-type = "d"
 01  p-o-detail-record.
     03  p-o-dept-number                          pic 9(3).
     03  p-o-record-type                          pic x.
     03  detail-p-o-number                        pic 9(10).
     03  p-o-shipping-info.
         05  p-o-quantity-to-ship                 pic s9(4) comp.
         05  p-o-total-quantity                   pic s9(4) comp.
$xfd use group, name = notes
     03  p-o-notes.
         05  notes-line occurs 3 times            pic x(40).
Note: p-o-record-type is entered only once into the table. The detail-p-o-number field is not part of the table, because the key overlays this area.

The following table is built in the database:

Column Name | Type
p_o_division_number | number(3)
p_o_record_type | char(1)
p_o_number | number(10)
p_o_date | date
p_o_dept_number | number(3)
p_o_quantity_to_sh | number(4)
p_o_total_quantity | number(4)
notes | char(120)
Parent topic: Preparing and Compiling a Program Example
Related information
USE GROUP XFD directive
DATE XFD directive


Creating a COBOL Application

Database Connectors simplifies the process of working with relational databases. It lets you use the traditional COBOL OPEN OUTPUT verb to create a new database table.

You can use a sample COBOL program that comes with Database Connectors to create a new database table in which to store your COBOL information. To do this, perform the following:

  • Create a new Visual Studio Solution and add the COBOL sample program.
  • Add COBOL directives to allow your application to work with Database Connectors.
  • Set up configuration variables and files to direct the operations of Database Connectors.
  • Run the sample program to create a new database table.
  • Check the resulting database table for columns and indexes.
  • Turning on Tracing
Parent topic: Working with COBOL
Related information
To create a Visual Studio Solution
To set the run time environment variables


Turning on Tracing

You can set variables that allow tracing and help to resolve issues encountered in the initial Database Connectors configuration. You should turn tracing off after successful configuration of Database Connectors, because it can significantly impact performance.

Set a new variable:

Variable | Value
MFTRACE_CONFIG | c:\DataConnectors\Test\config.ctf

In addition, you should create a configuration file for the tracing configuration. The following is a potential example of such a file c:\DataConnectors\Test\config.ctf :

mftrace.emitter.textfile#Format = $(TIME) $(THREAD) $(COMPONENT) $(EVENT) $(LEVEL) :$(DATA)

mftrace.level.mf.rts               = debug
mftrace.level                      = info
mftrace.comp.mf.rts#pgm            = true
mftrace.comp.mf.rts#pgmload        = true
mftrace.comp.mf.rts#syspgm         = true
mftrace.comp.mf.rts#eprintf        = 1
mftrace.emitter.TEXTFILE#location	 = C:\DataConnectors\Test\logs

You also need to create the directory C:\DataConnectors\Test\logs to receive your log files.

Note: The above directory location is just a sample. Your directory may be different. For more information about tracing, see the help for the Consolidated Tracing Facility (CTF) in the Micro Focus Studio Enterprise Edition documentation.

The important line in the CTF configuration file is the mftrace.comp.mf.rts#eprintf line, which is what causes the Database Connectors modules to emit trace information.

Parent topic: Creating a COBOL Application
Parent topic: Creating the Database Table


New and Existing Databases

  • Databases
  • Default Behavior
  • Accessing Existing Database Files
Parent topic: Database Connectors User's Guide


Databases

You may encounter one of two situations as you begin to use Database Connectors. In situation one, the database files don't exist yet. In situation two, the database files already exist, and you want to access that existing data from a COBOL application. There may or may not already be existing COBOL programs that access the database.

Each situation has potential questions.
  • How do I declare COBOL data so that it matches the database data?
  • Are there any special fields in the database that must be accessed in a special way?
  • How do I create COBOL record names, field names, index names, and data types that best conform to the compiler, Database Connectors, and the database engine?
These questions are addressed in the next few sections.
Parent topic: New and Existing Databases


Default Behavior

The following are automatically handled by Database Connectors:

  • Conversion of uppercase field names to lowercase (or vice versa) when necessary.
  • Data conversions needed to match the internal storage formats used by the database.
  • Creation of database files, if needed, when you execute an OPEN OUTPUT verb. If this is your situation, matching COBOL fields to database fields should not be an issue. Fields match perfectly, because the database fields are based on your COBOL code. As an alternative, you can use your database query tool to create a database.
  • Sequencing of data returned from a database: you may encounter unexpected sequencing. If your COBOL definition does not include alternate keys with duplicates, the data is returned in key order. If your COBOL definition does include alternate keys with duplicates, Database Connectors cannot control the sequence in which the data is returned. The database query optimizer decides how to order the returned records. For a set of records with the same key value, the records may not be in historical order
Parent topic: New and Existing Databases
Related information
A_MSSQL_ADD_IDENTITY configuration variable


Accessing Existing Database Files

If accessing existing data in a relational database, you need to know how to declare your data to match the database fields.

If your COBOL code isn't written yet, you should follow the guidelines given in the appendix of this manual for your specific RDBMS.

If your COBOL code already exists, you can make necessary adjustments by adding XFD directives to your code. XFD directives are comments that guide the creation of the eXtended File Descriptors (XFDs). The XFDs in turn help map the COBOL fields to their equivalent database fields. XFD directives are described in the chapter Using XFD Directives, and XFDs are described in the chapter XFDs.

  • How Do I Match Existing Text Fields?
  • How Do I Match Existing Numeric Fields?
  • Field Names
  • Index Names
Parent topic: New and Existing Databases
Related information
Using XFD Directives
XFDs


How Do I Match Existing Text Fields?

To access character data, you simply declare the field as PICTURE X, with as many X's as appropriate.

Parent topic: Accessing Existing Database Files


How Do I Match Existing Numeric Fields?

Numeric fields are more database-specific than text fields. Most relational database systems accommodate INTEGER, DECIMAL, and DATE types. For information on the handling of other numeric types, see the appendix containing information specific to your RDBMS.

Parent topic: Accessing Existing Database Files


Field Names

If your COBOL application already exists, and if it must access a relational database that already exists, you may have to work around differences in the names of the fields, as well as naming conventions imposed by the RDBMS. For example, your program might use the name EMPLOYEE-NO, while the database uses the name EMP-NUMBER for the same item of information.

  • Resolving Name Conflicts
Parent topic: Accessing Existing Database Files


Resolving Name Conflicts

If naming differences exist, you need not rename your COBOL fields and you need not change the database. This is because the CREATEXFD directive builds XFDs that map your COBOL fields to the correct database fields. The mapping is automatic if the names are the same. If the COBOL name differs from the database name, you enable the compiler to make the correct mapping by adding a NAME XFD directive to your COBOL code.

You can also use XFD directives to produce other effects when data is mapped from COBOL to the database. XFD directives are described in detail in the chapter Using XFD Directives.

Parent topic: Field Names
Related information
Using XFD Directives
Name XFD Directive


Index Names

Database Connectors uses a specific naming convention for indexes it creates. Indexes created with Database Connectors use the i<TABLENAME>_<key value> convention. If you are using indexes created outside of the Database Connectors application, you need to make sure the index names match the Database Connectors naming convention.

Performance is affected by the number of indexes you may have. If you use tables with multiple indexes, keep in mind that when a record is written or updated, locks are put onto all of the indexes, and they are all basically rewritten during the course of the write/update. This is a costly process. There may be multiple columns per index, and multiple indexes per table. Each rewrite implies a certain amount of wait time. Tables with a large number of indexes can be slow on writes/updates and possibly other operations in the database query optimizer become confused.

For more information about indexes and performance issues, see the chapter Performance and Troubleshooting.

Parent topic: Accessing Existing Database Files
Related information
Performance and Troubleshooting


Run Time Configuration

  • ACUFH Configuration Variables
  • Enabling Dynamic Redirection to a Custom File Handler
Parent topic: Database Connectors User's Guide


ACUFH Configuration Variables

Before running Database Connectors, you must set the A_CONFIG environment variable to the name of the ACUFH configuration file. You may want to make and use a personalized copy of the ACUFH configuration file to avoid impacting other users. You could use the A_CONFIG environment variable to identify a personal ACUFH configuration file. For example:

SET A_CONFIG=directory name\file name

defines a configuration file with the name of your choice in the directory of your choice.

There are several variables that can be set in your ACUFH configuration file that affect the Database Connectors processing. Those listed below are applicable to any relational database management system (RDBMS) with which Database Connectors communicates. Some ACUFH configuration variables are database-specific; those variables are discussed in the individual database sections found in the appendices of this guide.

The following ACUFH configuration variables, briefly described here, apply to any RDBMS. For detailed descriptions, look in the Reference > Configuration Variables section of the Database Connectors Help.

Variable | Description
4GL_2000_CUTOFF | Determines which two-digit years are considered to be in the twentieth century and which are considered to be in the twenty-first century
4GL_8_DIGIT_CUTOFF | Determines whether to use 4GL_2000_CUTOFF for dates that don't use a format string and that are eight digits
4GL_COLUMN_CASE | Tells Database Connectors to leave the case of the field names found in the eXtended File Descriptor (XFD) unchanged
4GL_COMMIT_COUNT | Indicates the conditions under which you want to issue an automatic COMMIT-WORK operation
4GL_CONVERT_DATE_ZERO | Allows Database Connectors to locate and return those records written using the date 01/01/01
4GL_DB_MAP | Enables you to set one map at a time by using FILE-PREFIX as a list of directories, each of which maps to a different database
4GL_EXTRA_DB_COLS_OK | Allows the database table to have more columns than the COBOL program's corresponding file descriptor
4GL_FULL_DATA_TEST | Allows you to specify whether an entire field is tested for illegal data or if only the first field is tested
4GL_IGNORED_SUFFIX_LIST | Lists the case-independent suffixes to ignore when opening Microsoft SQL Server tables or DB2 tables
4GL_ILLEGAL_DATA | Determines how COBOL data considered illegal by the database is converted before it is stored in the database
4GL_JULIAN_BASE_DATE | Sets the base date to be used for Julian date calculations
4GL_USEDIR_LEVEL | Provides a method of mapping filenames (with directory information) to table names
4GL_WHERE_CONSTRAINT | Allows you to override any value given in the external variable A4GL-WHERE-CONSTRAINT
DEFAULT_HOST | Designates the file system to be used for newly created files that are not individually assigned
filename_HOST | Assigns an individual data file to a file system
FILE_TRACE | Allows you to start file tracing without opening the debugger
XFD_DIRECTORY | Tells the run time system the name of the directory that contains the XFD files built by the compiler
XFD_MAP | Tells the run time system to associate certain filenames with a particular XFD
XFD_MAP_RESETS | Determines whether setting XFD_MAP adds to or replaces the existing value
XFD_PREFIX | Defines a specific series of directories to search for XFD files
Parent topic: Run Time Configuration


Enabling Dynamic Redirection to a Custom File Handler

To enable the dynamic redirection of the file handler, you need to set the following environment variables:

Variable | Value
DYNREDIR | DYNCONFIG:EXPAND
FHREDIR | <fhredir_config>

fhredir_config contains the redirection information, for example:

/f<VSAM_dir>\*   /r ACUFH!ACUFH

where <VSAM_dir>\* means that any COBOL file that has an XFD in the directory specified by VSAM_dir is redirected to the database.

You can replace the VSAM_dir\* with the full path, including the filename, for example:

/f<VSAM_dir>\DBFILE /r ACUFH!ACUFH

DYNREDIR=DYNCONFIG:EXPAND causes all filenames to be fully expanded into their pathnames. For example, if you have an entry:

/f<VSAM_dir>\*   /r ACUFH!ACUFH

and a COBOL file called DBFILE, it expands to:

<VSAM_dir>\DBFILE

If you are using VSAM and database files in the same COBOL program, you cannot have the VSAM files in the same directory as the XFD files if you are using wildcards like <VSAM_dir>\*. This is because the wildcard tells the run time to redirect all COBOL files in the specified directory to the database. For example, if your VSAM file is VFILE and your XFD file is DBFILE.xfd and they are in a directory specified by <VSAM_dir>, you cannot use:

/f <VSAM_dir>\*   /r ACUFH!ACUFH

This is because the DYNREDIR logic tries to redirect any file in that directory to the database. because VFILE is a VSAM file, you have to either specify the full path for the XFD as follows:

/f <VSAM_dir>\DBFILE    /r ACUFH!ACUFH

or put the XFD in a different directory and specify the directory with the wildcard, for example:

/f <XFD_dir>\*   /r ACUFH!ACUFH

where XFD_dir is a directory where your XFD files reside and is different from the directory where your VSAM files reside. If you have a separate directory for your XFDs like this, modify your COBOL program ASSIGN statement to specify the XFD_dir, for example:

ASSIGN TO DISK "<XFD_dir>\DBFILE"

In addition, modify your ACUFH configuration file and set XFD_DIRECTORY to XFD_dir so that the file handler can find your XFD files, for example:

XFD_DIRECTORY <XFD_dir>

Search for file handler redirection in the product online help for more information.

Parent topic: Run Time Configuration


Performance and Troubleshooting

This chapter provides guidelines for improving system performance. Also included is an alphabetical listing of the error messages that can occur during the compilation of your program.

  • Performance Issues
  • Troubleshooting
Parent topic: Database Connectors User's Guide


Performance Issues

Adding a relational database management system (RDBMS) brings significant complexity to any computer system. A few key guidelines may help to improve the performance of the system and prevent problems as the database grows.

  • Guidelines
  • The WHERE Constraint
Parent topic: Performance and Troubleshooting


Guidelines

The following sections describe some areas for you to consider as you prepare your database and your COBOL program.

Guideline 1 — Database Administrator

A site with a database management system needs a database administrator (DBA).

The administrator is critical in any large database installation. The DBA checks performance statistics and memory usage, performs general maintenance and backup for the database, initiates traces, executes database utilities, sets buffer sizes, determines how often buffers are flushing, and, in general, understands how database settings and events affect overall performance.

The DBA also performs periodic tuning of the database, including:

  • Using monitoring tools
  • Allocating table spaces
  • Examining output of the query optimizer to ensure that the most efficient paths are being used
  • Updating table statistics
  • Creating indexes

If a site experiences a performance problem, this usually means there is a bottleneck somewhere in the system. The DBA can help to isolate the bottleneck. Once the bottleneck is identified, the site can determine whether to apply more resources or correct the situation that is stressing the existing resources.

Guideline 2 — Understand COBOL Operations and Database Operation

Some COBOL operations are particularly stressful to a database. The more the application uses these operations, the more likely performance of the RDBMS suffers.

The more you understand about your RDBMS and how it operates, the more you can help your COBOL applications to work efficiently with it.

File Input and Output

Consider these standard COBOL I/O operations:

  • READ
  • REWRITE
  • WRITE
  • DELETE
  • OPEN

Each has an associated cost in terms of database performance. Each asks the database to do something that takes time. So if there are I/O operations that are optional in your COBOL application, you may want to remove them.

For example, developers sometimes OPEN and CLOSE files unnecessarily, using the OPEN–CLOSE pairing as a way to demarcate each new procedure:

OPEN file-A
procedural code
CLOSE file-A

But it's important to know that file OPENs are expensive in terms of performance. If you can eliminate non-essential OPENs from portions of your application, you may improve performance.

READ operations can also affect performance. All COBOL I/O is based on key indexes. Examining the output of your query optimizer allows you to determine if the most efficient execution path is being used for READs. The execution path for a given query can change as your data changes and as the size of the tables changes. It is also affected by database initialization parameters and any statistical information that you may have gathered on your tables. It might be helpful to know that, typically, the index path is the most efficient for Database Connectors applications.

Transactions

Large transactions are also very expensive. The main problem here is that the database holds locks on indexes and rows throughout an entire transaction. Thus, the database is creating additional overhead for an extended period of time if the transaction is lengthy. In addition, complex information tracking must take place to ensure that transactions can be successfully rolled back.

Often application designers decide to err on the side of safety when applying transaction management to a mature application. Which operations should be included in a single transaction? The safe approach is to group everything that is related into one transaction. But this scheme is expensive — and even more so when a database is involved. The lengthier the transaction, the longer the locks are held and system resources are tied up. The extensive data verification in COBOL programs only prolongs this.

If performance is an issue, give some thought to dividing each transaction into smaller and more efficient subgroups.

Tables with Multiple Indexes

If using tables with multiple indexes, keep in mind that when a record is written or updated, locks are put onto all of the indexes and they are all basically rewritten during the course of the write/update. This is a costly process. There may be multiple columns per index, and multiple indexes per table. Each rewrite implies a certain amount of wait time. Tables with a large number of indexes can be slow on writes/updates, possibly leading other operations in the database query optimizer to become confused.

There are two things you can do in this circumstance:

  • Restructure your data. The benefits of data restructuring may be significant. For example, if you have any situations in which two indexes start out with the same column or set of columns, you may be able to improve performance appreciably by changing your data definition.

    Suppose two indexes both start with MONTH, DAY, YEAR. These identical first three columns can cause the RDBMS's query optimizer to choose the wrong index, in which case you generate a significant amount of unnecessary and unproductive overhead. Restructuring one of the indexes can make a difference.

  • Use the file system for some of your data. If you cannot restructure your data but are finding certain operations to be too expensive, you might want to consider moving some data into the indexed file system.
Guiding the Data Searches
You can guide the data searches that result from database queries, and thus improve performance, by making use of an external variable called A4GL_WHERE_CONSTRAINT. This process is explained in the section The WHERE Constraint.

Guideline 3 — Program and Database Interaction

A database can interact with your COBOL program in surprising ways. When you introduce a database to a mature COBOL application, your application may experience errors you have not seen before. Being aware of this possibility helps you to prepare your response.

For example, your existing application without the database may rarely exceed the limit on the number of data files that can be open simultaneously. But when you add a database, you increase the likelihood of this significantly. This is because the query processing may often require temporary tables. Also, the ORDER BY clause (used in SQL statements to sequence retrieved data) opens temporary work files. So you may find that these files cause you to reach the limit sooner. (Note that proper tuning of the query optimizer can reduce the number of temporary files required.)

When upgrading to a new version of the RDBMS, new software components may interact with your applications differently than their predecessors did. It's important to rerun your pre-installation simulations (see Guideline 4 — Plan for Growth) to determine whether your system resources are still adequate. Investigate any differences in the two simulations. You may have to make adjustments to compensate for the differences in the RDBMS versions.

Upgrading or switching to a new database may also mean that you need to modify your makefile to coordinate with the settings of the new database. You can edit your makefile manually, or use one of the editing tools distributed with Database Connectors. For more information, see the appendix specific to the Connector interface you are using.

If you notice a change in performance with a new release of your RDBMS, keep in mind that certain database settings can have a significant effect on speed. Fine-tuning your settings can make a difference.

Several other options to help you improve performance are listed below:

  • Try one of the many third-party monitoring tools available
  • Break up data onto several connected hard drives to free up space and resources
  • Limit the number of indexes you have assigned with each database table

Guideline 4 — Plan for Growth

Planning ahead for growth is essential. You need to be able to predict the system resources that your application requires reaching a full load, both in terms of users and database size.

Before you choose and install hardware, it is best to run a simulation. Your hardware vendor or RDBMS vendor can help you to simulate a large number of users on a given platform with a given RDBMS.

Setting up and running a simulation that includes your own application lets you anticipate when moving into any installation, and can help to mitigate costly consequences.

A potentially costly mistake is to test in your office with a small database and a small number of users. Databases respond differently to small amounts of data and a small number of users than they do to large amounts of data and a large number of users. Functionally, the database works differently as the load increases. You might think of this adjustment as switching into a different gear. Significant changes in the load on your database can lead to large increases in overhead. The behaviors and loads encountered as the database expands cannot be determined from a linear projection based on the smaller scenario.

Parent topic: Performance Issues
Related information
The WHERE Constraint


The WHERE Constraint

The Database Connectors WHERE constraint is an external variable that gives the developer some control over the data searches that result from database queries. It can help to improve performance in some situations. This section describes purpose of the WHERE constraint and shows how it is implemented.

COBOL data processing is based on keyed READ operations following a positioning operation. Records are read until the key value being processed changes. Because traditional COBOL data processing is based on a B+ tree file system, the overhead for such operations is relatively minor.

RDBMS data processing introduces a new level of complexity to data processing. The database's query optimizer receives the SQL query for the COBOL operation being performed and then builds a working set of data that satisfies that query. Because the database optimizer has many different possible execution methods, this can result in poor performance if the optimizer chooses a query execution path that is less than optimal.

Performance degradation may also result from the fact that queries generated by COBOL operations result in unbounded index queries. Unbounded queries are generated because COBOL positioning operations (Start Not Less Than and Start Not Greater Than) provide only one of the bounding conditions for the working set, instead of both an upper and lower boundary.

As an example, consider the case in which an application needs to process all items in a warehouse on aisle 17, shelf 8, and bin 2. If each of these items is a field in a key, the COBOL program might generate the following query for a READ operation:

Note: The following example applies to the Database Connectors for Oracle product. The SQL generated differs based on the interface.

SELECT * FROM warehouse_items WHERE
   aisle = 17 and
   shelf = 8 and
   bin = 2
ORDER BY aisle ASC, shelf ASC, bin ASC;

This query achieves the desired result but has one problem. For the COBOL program to end its processing, it must read a record that has a new value for bin. The COBOL application has no way of specifying an upper boundary for the read operation, so when all rows of data from bin 2 have been read, the Connector attempts to read the next record by generating the following query:

SELECT * FROM warehouse_items WHERE
   aisle = 17 and
   shelf = 8 and
   bin > 2
ORDER BY aisle ASC, shelf ASC, bin ASC;

This query causes the database query optimizer to gather all records pertaining to items on the remainder of shelf 8 to build its working set. This is excessive from the COBOL application's point of view, because the COBOL program needs only the first record of the working set to determine that it has finished processing.

This problem can be even more serious if the application is processing the last bin on a shelf. Because there are no more bins on that shelf, the query would drop down a level and generate the following:

SELECT * FROM warehouse_items WHERE
   aisle = 17 and
   shelf > 8
ORDER BY aisle ASC, shelf ASC, bin ASC;

This would select all items on the remainder of that aisle of the warehouse, which could be a very large working set if each aisle had 130 shelves.

The database query optimizer normally does not build the entire working set if it has been properly tuned, but instead performs INDEXED READS to process the query. This means that the query optimizer traverses an index tree to retrieve the records, much as COBOL index files do, as opposed to using combinations of indexes and sort and merge operations.

It can be helpful to influence precisely which information is to be returned. If the precise scope of the record processing performed by the read operations is known at compile time (or before the query is executed), information retrieval can be more finely tuned.

Database Connectors provides a method by which the COBOL programmer can provide additional information to the database query optimizer by providing more specific selection information to the Connector. This selection information is added to the WHERE clause of the SQL queries generated by the Connector. This can be particularly useful in providing upper boundaries to queries being generated, with the result that the working set is smaller.

Upper boundaries can be provided on the key segments for a select, or any other selection criteria needed to constrain the working set to just the desired subset of rows. This additional information is added to generated queries with the AND condition. It is not possible for the application developer to specify a larger working set than would otherwise have resulted. The developer may only constrain the working set to a smaller subset.

Parent topic: Performance Issues
Related information
To use the WHERE constraint from COBOL


Troubleshooting

The remainder of this chapter lists the possible error messages that can occur during compilation. You can find recommended recovery procedures for each situation by following the link of the error message.

Note: You may experience slower performance simply because the Database Connectors application is limited because of the rules of COBOL. Many third-party tools available to help monitor performance levels.
  • Setting External Variables
  • Compiler Errors
  • Compiler Warnings
  • Run-Time System Errors
Parent topic: Performance and Troubleshooting


Setting External Variables

When using , file status variables and declarations may not be able to provide enough information to determine the cause of the error and the recommended resolution.

Setting external variables can provide additional information in troubleshooting situations. For example, if the database returns an error that does not map to one of the standard COBOL errors (record locked, duplicate key, etc.), the external variables F-ERRNO, F-INT-ERRNO, F-INT2-ERRNO and F-ERRMSG contain additional information. Typically, F-ERRNO is E_INTERNAL (which has a value of 15). F-INT-ERRNO and F-INT2-ERRNO are the error values returned by the database, and F-ERRMSG points to a text message returned by the database.

Add the following EXTERNAL declarations to working-storage:

01  F-INT-ERRNO   BINARY-LONG  SIGNED 	EXTERNAL.
01  F-INT2-ERRNO  BINARY-LONG  SIGNED	 EXTERNAL.
01  F-ERRMSG      POINTER             	EXTERNAL.
77  F-ERRNO       BINARY-SHORT SIGNED 	EXTERNAL.
Note: Not all errors return textual messages.
Parent topic: Troubleshooting


Compiler Errors

The errors listed below could occur when you compile with the CREATEXFD directive. In some cases, the XFD cannot be built until you remove the error condition. (XFD errors do not, however, prevent the object code from being generated.) For information about XFDs, see the chapter XFDs.

For detailed information about a particular error message, go to Reference > Error Messages in your Database Connectors documentation.

Bad picture for DATE: keyname
Data missing from key segment keyname
Directive word too long: keyname
GROUP expected after USE
Missing '=' in XFD directive
Missing field name after WHEN
xxx: unknown XFD directive
Value should be a name: xxx
Value should be numeric: xxx
Value should be a literal: xxx
Variable file name requires FILE directive
WHEN variable xxx not found in record
Parent topic: Troubleshooting
Related information
CREATEXFD directive
XFDs


Compiler Warnings

The compiler may also generate the following warning messages. For detailed information about a particular error message, go to Reference > Error Messages in your Database Connectors documentation.

xxx not unique in first 30 characters
Field xxx causes duplicate database data
Parent topic: Troubleshooting


Run-Time System Errors

You can determine the meanings of your database error codes by referring to the database documentation.

You can see run-time system errors by using the FILE_TRACE ACUFH configuration variable with the Consolidated Tracing Facility (CTF).

Unless noted otherwise, this method applies to all RDBMSs supported by the Database Connectors family of interfaces. For a listing of run-time system errors, refer to the Troubleshooting section of the appendix that pertains to your product.

  • Using the FILE_TRACE ACUFH Configuration Variable
  • Retrieving Messages Using the CTF
Parent topic: Troubleshooting
Related information
FILE_TRACE configuration variable


Using the FILE_TRACE ACUFH Configuration Variable

At run time, if you specify a CTF trace file and set the FILE_TRACE ACUFH configuration variable, the run time system puts the extended error code and some text associated with the error into the error file.

The text of the error would then have this format in the file:

*** File system error value = 3 ***
*** Dictionary (.xfd) file not found***
File error 9S,03 on filename
Dictionary (.xfd) file not found

Occasionally you may receive an error message that means syntax error. You can examine the CTF trace file and determine the cause of the problem if you receive this error code.

Parent topic: Run-Time System Errors
Related information
To examine the CTF trace file


Retrieving Messages Using the CTF

Use the CTF to trace diagnostic information in ACUFH.

Parent topic: Run-Time System Errors
Related information
To enable tracing for ACUFH


Questions and Answers

Here are some answers to common questions that can apply to any relational database management system (RDBMS) data source supported by the Database Connectors family of interfaces.

I can't seem to get ACUFH configuration file to create the files in my database. They keep coming up as indexed files.
Check to see that the DEFAULT_HOST variable is set in the ACUFH configuration file or the environment. Setting DEFAULT_HOST in the environment overrides the setting in the ACUFH configuration file.
Can I use both an RDBMS and the Micro Focus EXTFH file system at the same time?
Yes, you can. In the ACUFH configuration file, set DEFAULT_HOST to the file system you want the run time system to use automatically. Then, for select files, assign them to an alternate file system with the variable filename_HOST. For example, to put CUSTFILE into a specified RDBMS and everything else into EXTFH, you would add:
DEFAULT_HOST   EXTFH
CUSTFILE_HOST  name_of_file_system

where name_of_file_system is one of the following: Oracle , MSSQL, or DB2.

How can I find out what an error message is?
If you run your application with the FILE_TRACE ACUFH configuration file variable, you receive extended error numbers that include those returned by your RDBMS application.
Note: For Oracle, if you are using the OERR command-line utility, the error code must include five digits. If your error code does not already include five digits, you must add leading zeros to complete this requirement. For example, if your error code is code number 150, the syntax for this option is OERR ORA 00150.

If you have sent the errors to an output file with the FILE_TRACE ACUFH configuration variable, the run time system also attempts to include text that explains the errors. See the example in the section Runtime System Errors in the chapter Performance and Troubleshooting.

Do my eXtended File Descriptor (XFD) files have to be in the same directory as my object files?
No. You can instruct the compiler to put the XFD files in an alternate directory with the CREATEXFD directive. Then at run time, make sure you have the ACUFH configuration file variable XFD_PREFIX set to include that same directory.
Why aren't my KEYs being retrieved in the correct order?
If your KEY field is numeric or alphanumeric, you may have illegal data in the field. For example, if you've used LOW-VALUES or HIGH-VALUES to mark control records, those values are considered invalid and can cause the records containing them to be retrieved in an unexpected sequence.

To enable special values such as these to be processed, use the BINARY XFD directive in front of the key field. This allows data of any classification to be processed. Either designate an individual field as binary, or specify USE GROUP, BINARY in front of a group of fields.

The method of storing variables declared as binary is database-specific. For example, for Oracle databases, variables declared as binary are stored as raw fields. Refer to your database documentation for information specific to your data source or RDBMS.

Is it possible to use the same XFD file for data files with different names, if they all have the same structure? This would be useful when I create several customer files that use the same record definitions.
At run time, it is possible to use a single XFD for files that have different names. For example, suppose a site has customer files that have identical structures but different names (such as CUST0001, CUST0002, and CUST0003). It's not necessary to have a separate XFD for each file, as long as their record definitions are the same. The individual files can all be mapped to the same XFD via the configuration variable XFD_MAP. Here's how it works.

Suppose your COBOL application has a SELECT with a variable ASSIGN name, such as customer-file. This variable assumes different values (such as CUST0001 and CUST0002) during program execution.

Before compiling the application, you would use the FILE XFD directive to provide a base name for the XFD. Suppose you provide CUST as the base. The Compiler would then generate an XFD named cust.xfd. (The Compiler always converts XFD names to lower case.)

To ensure that all customer files, each having a unique name, use this same XFD, enter the following in your configuration file:

XFD_MAP  CUST* = CUST

The asterisk (*) in the example is a wildcard that matches any number of characters. The extension .xfd should not be included in the map. This statement would cause the XFD cust.xfd to be used for all files whose names begin with CUST.

The XFD_MAP variable has this syntax:

XFD_MAP   [pattern = base-xfd-name]  ...
where pattern consists of any valid filename characters and may include "*" or "?". These two characters have special meanings in the pattern:
* matches any number of characters
? matches a single occurrence of any character
For example:
CUST???? matches CUST0001 and CUSTOMER;

does not match CUST001 or CUST00001

CUST* matches all of the above
CUST*1 matches CUST001 and CUST0001 and CUST00001;

does not match CUSTOMER

*OMER matches CUSTOMER;

does not match CUST001 or CUST0001

The XFD_MAP variable is read during the open file stage with the run time system.
I'm unsuccessful in trying to create a table in MSSQL Server, and when I check the trace log, I find the following "File Error:9k":
ssinit_connection sss
Trying to open a connection to server MyBadServer
report_status called from 1176
[1] 08001 17 – [DBNETLIB]SQL Server does not exist or access denied.
[2] 01000 53 – [DBNETLIB]ConnectionOpen (Connect()).sssssss
where MyBadServer is the value set in my configuration file for A-MSSQL-DEFAULT-CONNECTION.
You might be using the wrong server name in the A-MSSQL-DEFAULT-CONNECTION variable. One way you can verify the server name is by following the steps below. This method is useful if you don't have the client tools for SQL Server installed.
  1. Create a new ODBC Datasource for SQL Server.
  2. When prompted for the server name, select your local server from the drop-down list of available servers.
  3. Connect to this server using ODBC Administrator.
This gives the server name you need to use in the A-MSSQL-DEFAULT-CONNECTION variable.
Parent topic: Database Connectors User's Guide


Database Connectors for Microsoft SQL Server

This section provides information specific to Database Connectors for Microsoft SQL Server.

  • Microsoft SQL Server Concepts Overview
  • Installation and Setup
  • Filename Translation
  • ACUFH Configuration File Variables
  • Using the Database Table
  • Table Locking
  • Stored Procedures
  • Limits and Ranges
  • Run-Time System Errors
  • Common Questions and Answers
Parent topic: Database Connectors User's Guide


Microsoft SQL Server Concepts Overview

This quick overview of some basic design concepts underlying the Microsoft SQL Server (MSSQL) Database Management System (RDBMS) helps to interface your COBOL program to it.

Servers

An MSSQL server is one copy of the database engine executing on a computer. A server has a name, and when a program wants to access the database controlled by a server, the program asks for a connection to that server by name. Multiple servers can be executing on a single machine, controlling different databases. The default name that MSSQL gives to a server is localhost. (The naming of servers is discussed under the configuration variable A_MSSQL_DEFAULT_CONNECTION.)

Table Ownership

Table names in MSSQL have the form database.owner.table_name. Within MSSQL, if you are the owner of a given table, you can refer to it as just table_name. If you are not the owner, you must refer to it with the owner of the table as a prefix. Different owners can thus have tables of the same name. However, this is not true when you use the Database Connectors for MSSQL interface.

The Database Connectors interface works a little differently: it automatically determines the owner name used to reference a table. It is therefore essential that there not be multiple tables with the same name in a single database, even though the tables have different owners. If there are such multiple tables, the interface does not necessarily find the correct one, and no diagnostic is issued.

Table names include dots (.) as separators. Because of this, you must make sure there are no extensions on COBOL file names that could be converted to table names. For example, for a COBOL file named IDX1.DTA, the Connector attempts to open a table DTA with owner IDX1. You can avoid this problem either by renaming your COBOL file in your source program or by using a configuration file variable to map the file name to an allowable file name, such as:

IDX1.DTA  IDX1

In the above example, IDX1.DTA is the name in the ASSIGN clause of the file's SELECT statement.

If you map your file name to a new name, drop the extension to form the new name. The compiler uses the base file name — without the extension — to create the eXtended File Descriptor (XFD) file name IDX1.XFD. (XFDs are explained in detail in the chapter XFDs.) The run time system needs to locate this file. But if you've mapped the file name to something completely different (such as MYFILE), the run time looks for an XFD file named MYFILE.XFD. So you would have to remember to change the name of IDX1.XFD to MYFILE.XFD in the XFD directory. Dropping the extension when you map the name prevents having to perform this extra step.

see the configuration variable 4GL_IGNORED_SUFFIX_LIST for an alternate method of removing file extensions.

Security

Security is implemented in the MSSQL RDBMS. A user is required to log in to the RDBMS before any file processing can occur. Database Connectors provides both a default and a user-configurable method for implementing this.

Generally, it is best for someone with database administrator (DBA) privileges to create and drop the tables, allowing others only the permissions to add, change, or delete information contained in them.

See the Microsoft SQL Server documentation for more details on DBA privileges.

Parent topic: Database Connectors for Microsoft SQL Server
Related information
A_MSSQL_DEFAULT_CONNECTION configuration variable
4GL_IGNORED_SUFFIX_LIST configuration variable


Installation and Setup

You must perform several steps before you begin using Database Connectors on a new system. The following topics provide this information:

  • Installing on a Client Machine
  • Setting Up a User Account
  • Setting Up the User Environment
  • Designating the Host File System

The MSSQL RDBMS, version 6.5 or later, must be installed and configured prior to the installation of Database Connectors for MSSQL.

Microsoft SQL Server's Query Analyzer, an interactive query tool, is also necessary for installing th stored procedures.

Micro Focus does not provide these products.

Note: The default sort order for MSSQL is case-independent. Make sure that this is what you really want when you install the server. The Connector uses the sort order as installed and cannot change its behavior to do case-dependent ordering if that is not what the server uses.

First you must install the files from the Micro Focus installation media onto the client machine. Then follow the instructions below for the server machine. Final setup steps on the client machine complete the installation.

Be sure to use the 64-bit libraries with a 64-bit run time system and 64-bit Database Connectors for MSSQL, and the 32-bit libraries with a 32-bit run time system and 32-bit Database Connectors for MSSQL.

  • Installing on a Client Machine
  • Setting Up a User Account
  • Setting Up the User Environment
  • Designating the Host File System
Parent topic: Database Connectors for Microsoft SQL Server
Related information
Installing on a Client Machine
Setting Up a User Account
Setting Up the User Environment
Designating the Host File System


Installing on a Client Machine

The Database Connectors interface for MSSQL is an add-on module. The installation includes a .DLL file that is detected at run time. It is not necessary for 32-bit users to relink the run time system.

The Database Connectors interface can be executed on a machine that is running any 32-bit Windows platform from Microsoft.

Note that the client machine may be the same machine as the server.

Installation instructions for each of these configurations are given in the links below. The instructions describe the steps you must follow on both the client machine and the server machine.

Once the installation is complete, please return to this appendix for setting up Database Connectors for MSSQL.

Parent topic: Installation and Setup
Related information
To install the Acu4GL product on a Windows NT server


Setting Up a User Account

Database Connectors must be able to connect to a user account. You may set up either one general account for all users or an account for each individual user. To set up an account, you must have DBA privileges.

See the Microsoft SQL Server Management Studio documentation for more information on setting up user accounts.

Parent topic: Installation and Setup


Setting Up the User Environment

The user's account should have been set up correctly to access the MSSQL RDBMS system. See your Microsoft SQL Server documentation for more details.

In addition to setting the variables required for MSSQL, you must do the following:

  • Ensure that your execution path contains the name of the directory in which you placed your run time system
  • Set the A_MSSQL_LOGIN and A_MSSQL_PASSWD variables, either in your environment or in the ACUFH configuration file. Alternately, set the configuration variable A_MSSQL_NT_AUTHENTICATION to TRUE. For security reasons, it is best to set the password variable from your COBOL program by asking the user to enter a password and then executing:
    SET ENVIRONMENT "A_MSSQL_PASSWD" TO user-entry
  • You may want to make and use a personalized copy of the ACUFH configuration file to avoid impacting other users.
Parent topic: Installation and Setup


Designating the Host File System

If you are opening an existing file, all file systems linked into the run time system are searched for the named file. If, however, you are creating a new file, you must tell the run time system which file system to use. You accomplish this with one of the following ACUFH configuration file variables:

DEFAULT_HOST filesystem

or

filename_HOST filesystem

DEFAULT_HOST Variable

Use the DEFAULT_HOST variable to designate the file system to be used for newly created files that are not individually assigned. For example:

DEFAULT_HOST MSSQL

means that all new files are MSSQL tables unless otherwise specified by the second ACUFH configuration file variable, filename_HOST.

filename_HOST Variable

Use the filename_HOST variable to assign an individual data file to a file system. Any file so assigned uses the designated file system and not the one specified by DEFAULT_HOST. The syntax is:

filename_HOST filesystem

where filename is the file name, without any extension, named in the ASSIGN TO clause of your SELECT statement. For example:

myfile_HOST MSSQL

means that myfile is under the MSSQL file system.

You can use these ACUFH configuration file variables in combination to assign your new files in a default with exceptions manner; for example, this set of entries:

DEFAULT_HOST DB2
afile_HOST MSSQL
bfile_HOST MSSQL

means that all new files except afile and bfile are assigned to DB2, and those two files are assigned to MSSQL.

You can also change the values of these variables during program execution by including in your code:

SET ENVIRONMENT "filename_HOST" TO filesystem

or

SET ENVIRONMENT "DEFAULT_HOST" TO filesystem

This enables you to change file systems during the execution of your program. This is not the typical way to specify a file system; normally it is designated in the ACUFH configuration file and is not changed in the COBOL program.

Note: The Database Connectors interface to MSSQL allows you to create an MSSQL table with an OPEN OUTPUT statement, just as you can create indexed files. The MSSQL equivalent of an indexed file is a table, not a database. You must create a database for your MSSQL tables before you run the COBOL program that creates the tables, just as you must create a directory for your files before you run a COBOL program that creates indexed files.

See the section To Install the Database Connectors on a Windows Server for instructions to complete the installation. Once install is complete, you can prepare and compile your COBOL program.

Parent topic: Installation and Setup
Related information
filename_HOST configuration variable
DEFAULT_HOST configuration variable
Preparing and Compiling Your COBOL Program
The Demonstration Program


Filename Translation

As you prepare to work with Database Connectors for MSSQL, you may find it helpful to understand the rules around filename interpretation and to understand how the names of tables and XFD files are formed and work together.

When the compiler generates XFD files, it uses lowercase letters to name the XFD file. In addition, the compiler changes hyphens to underscores when naming the XFD file.

Through ACUFH configuration file variables, the run time system translates the file name in the COBOL program into the filename that is passed to the open() function in the run time system. The open() function determines which file system to pass the request to, but does not change the name of the file.

However, the Connector needs the name of the file to find the appropriate XFD file. To do this, Database Connectors changes the name of the file to lowercase letters and changes hyphens to underscores. Note, however, that this is performed only on a local copy of the file. Once the XFD file is found, the filename reverts to the name that was originally passed to the open() function. Characters that are illegal in identifiers, such as a hyphen ("-"), are trapped by Database Connectors neither find the file nor create a new one.

Parent topic: Database Connectors for Microsoft SQL Server


ACUFH Configuration File Variables

Before running Database Connectors, you must set the A_CONFIG environment variable to the name of the ACUFH configuration file. You may want to make and use a personalized copy of the ACUFH configuration file to avoid impacting other users. You could use the A_CONFIG environment variable to identify a personal ACUFH configuration file. For example:

SET A_CONFIG=directory name\file name

defines a configuration file with the name of your choice in the directory of your choice.

This section lists the ACUFH configuration file variables that are specific to MSSQL. ACUFH configuration file variables that are generally applicable to any RDBMS with which Database Connectors communicates are discussed in the section ACUFH configuration file in the chapter Runtime Configuration. For detailed descriptions of these variables, see the Reference > Configuration Variables section of your Database Connectors documentation. A minimal required set of configuration variables is:

  • A_MSSQL_DEFAULT_CONNECTION
  • A_MSSQL_LOCK_DB
  • A_MSSQL_DATABASE

and either:

  • A_MSSQL_LOGIN
  • A_MSSQL_PASSWD

or:

  • A_MSSQL_NT_AUTHENTICATION

For information on dynamic redirection to a custom file handler, see the section Enabling Dynamic Redirection to a Custom File Handler.

Variable | Description
A_MSSQL_ADD_IDENTITY | Adds an extra column to any table created by the Connector
A_MSSQL_ADD_TIMESTAMP | Ensures that modifications made to a row are not overwriting someone else's changes
A_MSSQL_APPROLE_NAME | Allows the Connector to use approles
A_MSSQL_APPROLE_PASSWD | Allows the Connector to use approles
A_MSSQL_CURSOR_OPTION_1, A_MSSQL_CURSOR_OPTION_2, A_MSSQL_CURSOR_OPTION_3 | Allow you to fine-tune the declaration of cursors in the Connector
A_MSSQL_DATABASE | Specifies the name of the particular database to be accessed
A_MSSQL_DEADLOCK_LOOPS | Can be used to instruct the Connector to re-execute an INSERT statement
A_MSSQL_DEFAULT_CONNECTION | Specifies the name of the server to which the run time system connects
A_MSSQL_DEFAULT_OWNER | Specifies the name of the user of a table
A_MSSQL_FAST_ACCESS | Files opened while this variable is set to a nonzero value are optimized for forward sequential access
A_MSSQL_LOCK_DB | Specifies the name of the database that holds the lock table
A_MSSQL_LOGIN | Indicates the user name under which you want to connect to the database system
A_MSSQL_MAX_CHARACTERS | Indicates the maximum number of bytes the Connector allows in a table row
A_MSSQL_MAX_COLUMNS | Indicates the maximum number of columns the Connector allows in a table
A_MSSQL_NATIVE_LOCK_TIMEOUT | One of two locking methods available with the Connector
A_MSSQL_NO_COUNT_CHECK | Causes the interface not to check that a record was updated
A_MSSQL_NO_DBID | Causes the interface to use a Database ID of "0", instead of the actual ID of the database
A_MSSQL_NO_RECORD_LOCKS | Causes all READS to be treated as READ NO LOCK
A_MSSQL_NO_TABLE_LOCKS | Causes the interface to not use the AcuOpenTables1 table, which causes all table locking to be disabled
A_MSSQL_NO_23_ON_START | Causes START not to detect whether records actually exist
A_MSSQL_NT_AUTHENTICATION | Indicates whether MSSQL authenticates users based on their Windows login
A_MSSQL_PACKETSIZE | Sets the size of network packets
A_MSSQL_PASSWD | Set to the password assigned to the database account associated with the user name specified by A_MSSQL_LOGIN
A_MSSQL_ROWCOUNT | Determines how many rows are returned by a SELECT statement sent to the server
A_MSSQL_SELECT_KEY_ONLY | Directs the interface to select key columns only when searching for records
A_MSSQL_SKIP_ALTERNATE_KEYS | Determines whether alternate keys are used to form indexes during table creation
A_MSSQL_TRANSLATE_TO_ANSI | Causes the Connector to call the same translation function used by the Windows run time system to translate characters going to the server into the OEM character set, and to translate characters coming from the server to ANSI
A_MSSQL_UNLOCK_ON_EXECUTE | Causes all invocations of I$IO using the EXECUTE opcode to unlock all records
A_MSSQL_USE_DROPDOWN_QUERIES | Causes selects sent to the database to be of the drop-down variety, instead of a single large query
Parent topic: Database Connectors for Microsoft SQL Server
Related information
Enabling Dynamic Redirection to a Custom File Handler
ACUFH Configuration Variables


Using the Database Table

The database table is built and accessed automatically when the COBOL application is executed. To the end user, the interaction between the COBOL and the MSSQL database is invisible; queries are generated and data is exchanged in fractions of a second, and the application proceeds without interruption.

You can also access the database information directly from MSSQL, at your option.

To create a sample COBOL application, see the section Creating a COBOL Application.

Parent topic: Database Connectors for Microsoft SQL Server
Related information
Creating a COBOL Application


Table Locking

By default, MSSQL doesn't support the type of record and table locking that COBOL expects. For this reason, the Connector implements its own locking method. This is accomplished with the addition of two tables to a database. You choose the database to hold these tables during installation of Database Connectors.

Before using the locking tables, you must execute the included ms_inst.sql script. (See the installation instructions you used from this manual for the exact procedure. You can find them in the Contents.) If you don't perform this step, the first time you try to execute a COBOL program that opens an MSSQL table, error 11, Lock Table Incorrect, occurs.

AcuLocks1 Table

The first locking table is called AcuLocks1; it holds the record locks. The columns in this table are the

  • DBID
  • Table ID
  • Process ID of the process holding the lock
  • Primary key of the record that is locked

There is a unique index on the DBID, the Table ID, and the Key Value, so that inserts into this table are automatically rejected if another user holds a lock on the row in question. This also gives the DBA the information needed to determine who has locks set, and whether the user in question still has a connection to the server.

AcuOpenTables1 Table

The second locking table is called AcuOpenTables1; it holds information about open tables.

The columns in this table are

  • The DBID
  • The Table ID
  • The process ID (PID) of the process that has the table open
  • The Open Mode (Input, Output, I/O or Extend)
  • Whether Multiple records can be locked
  • Whether the file can be open for I/O by any other users
  • Whether the file can be open at all by any other users
  • Whether Mass Update was specified in the open

There are no indices on this table, but there is a trigger, which reject opens that are not allowed based on other users' open modes.

By using these lock tables, Database Connectors is able to support all the types of locking ordinarily supported. No special configuration variables are required.

This method of locking is all that is needed if no applications other than COBOL programs are going to be using Database Connectors for MSSQL. But if your site has other applications that access the MSSQL databases, you must use a method of locking that is inherent to Microsoft SQL Server.

Another method of locking that Microsoft SQL Server supports internally is the result of time stamping and the use of BROWSE MODE (see the discussion of BROWSE MODE in the Microsoft SQL Server Commands Reference Manual). If a table has a timestamp column, the Connector uses browse mode. This allows the server to detect whether another application has modified a record while locked by the server.

Parent topic: Database Connectors for Microsoft SQL Server


Stored Procedures

A stored procedure is a collection of SQL statements residing on the server, stored as text in a table in the database. Stored procedures provide an efficient environment for Database Connectors because, once they are executed on the server, they don't need to be parsed and optimized each time they are executed. (However, if the server goes down, the stored procedure is parsed and optimized when the procedure is called after the database restarts.)

If you run a set of stored procedures for the database where data is manipulated (your production database), this database must be the setting for A_MSSQL_LOCK_DB. If you run the stored procedures against both the lock database and the production database, the lock database can be the setting for A_MSSQL_LOCK_DB. Note that if you run one version of stored procedures against the lock database and another version against the production database, the stored procedures in the lock database override those in the production database. Therefore, we recommend that you always update your stored procedures with each new installation of Database Connectors for MSSQL, so that these procedures are consistent when you run them against the tables in your database.

Note: If you are upgrading from an earlier version of Database Connectors, be sure to install the new stored procedures. Stored procedures are always upgraded to be compatible with older versions of the product, so installing new stored procedures over old ones does not affect your ability to run with an older version of the interface software.
  • Developer- or Site-supplied Stored Procedures
  • Built-in Stored Procedures
Parent topic: Database Connectors for Microsoft SQL Server


Developer- or Site-supplied Stored Procedures

This section provides information on stored procedures you may want to create. It also supplies some example code.

Database Connectors checks for these stored procedures when opening a file and uses them in certain circumstances.

These stored procedures are

  • tablename_insert (where tablename is the name of the table being accessed)

    The INSERT stored procedures takes as arguments all columns in order listed in the XFD. It expects no columns to be returned.

  • tablename_delete

    The DELETE stored procedure takes as arguments the primary key fields in the order they are listed in the XFD. It expects no columns to be returned.

  • tablename_read

    The READ stored procedure takes as arguments the primary key fields in the order they are listed in the XFD (in the key section). It expects the columns to be returned in order of condition. So all condition 0 columns are retrieved first, then condition 1 columns, etc. For each condition, the columns are expected in order given in the XFD

  • tablename_update

    The UPDATE stored procedures takes as arguments all columns in order listed in the XFD. It expects no columns to be returned.

  • tablename_startnnn (where nnn is the key number to start on)

    The STARTnnn stored procedure takes as arguments a mode string (EQ, LE, GT, GE, LT), and then all columns of key nnn in order listed in the XFD. It must execute "raiserror 22006 'Record not found'" if no rows match the search criteria.

Note: Database Connectors does not create these stored procedures or check their accuracy. It is possible to create stored procedures in such a way as to make Database Connectors for MSSQL completely inoperable. Database Connectors uses these stored procedures for performance reasons only.
Parent topic: Stored Procedures
Related information
tablename_insert stored procedure
tablename_delete
tablename_read stored procedure
tablename_update stored procedure
tablename_startnnn stored procedure


Built-in Stored Procedures

Several stored procedures come with Database Connectors for MSSQL. One, sp_AcuInit, provides a means for customized initialization. sp_AcuInit is not installed; you must create it to use it for connection-time set-up. The others return information based on the AcuOpenTables1 and AcuLocks1 tables.

Note: Names of several stored procedures end in _1, indicating the first version of the stored procedure. Whenever a stored procedure is updated, the extension is updated by one. This is why you can install new stored procedures without overwriting older ones. Be sure to install all stored procedures when you install Database Connectors for MSSQL.
sp_AcuInit | A procedure you can set up to do customized initialization
sp_AcuRemoveUnusedLocks_1 | Determines who is logged in and removes Process IDs that are no longer active on the system
sp_AcuTableReport_1 | Shows who is using the tables in the database at the time this procedure is run
sp_AcuUserCount_1 | Use this to track table and database activity to ensure that your database is running as efficiently as possible
sp_AcuZeroUserCount_1 | Removes all locks on a table and closes it
Parent topic: Stored Procedures


Limits and Ranges

The following limits exist for the MSSQL file system:
Maximum number of columns per key: | 16
Maximum number of columns: | 1024
Maximum number of bytes in a single row when using Database Connectors for MSSQL: | 8060

To achieve the same sort or retrieval sequence under MSSQL as under the file system, key fields that contain signed numeric data must be preceded by a BINARY XFD directive.

Database Connectors supports the data types shown below; when it's creating tables, the following conversion rules are used, in the sequence shown:

COBOL SQL Server
DATE XFD directive
DATETIME
BINARY XFD directive
VARBINARY(n) (if SIZE < 255)
IMAGE (if SIZE >255)
VAR_LENGTH XFD directive
VARCHAR(n) (if SIZE < 255)
Usage FLOAT
REAL (if SIZE = 4)
Usage DOUBLE
FLOAT (if SIZE = 8)

Any other numeric usage:

PIC 9(n)V9(m)
SMALLINT (if m = 0 and n < 5)
INT (if m = 0 and n < 10)
DECIMAL(n + m, m)(otherwise)

Any other usage:

PIC X(n)
CHAR(n) (if n < 255)
TEXT (if n > 255)
Parent topic: Database Connectors for Microsoft SQL Server


Run-Time System Errors

This section lists the Database Connector for MSSQL error messages that could occur during execution of your program. For information on compile-time errors and several methods for retrieving run time system errors, see the chapter Performance and Troubleshooting.

Run time system errors have this format:

9/xxx

The 9 indicates a file system error and is reported as the first digit of the 2-byte FILE STATUS variable. The xxx is a binary value between 1 and 255 that provides more information. If xxx is 83, you can retrieve additional information with C$RERR. That additional information can come from either the database or the run time. Run-time codes returned with C$RERR include:

Code | Message
1 | Error reading the XFD file
2 | Corrupt XFD/dictionary file
3 | Error opening the XFD file
4 | Too many key fields (16 max)
5 | (no message associated with this error)
11 | Stored procedures not found
12 | A column of a key is of data type TEXT or IMAGE, which is illegal
13 | Internal error
14 | DB library function returned an unexpected error
16 | Trying to rename a table across databases
17 | Cache error
18 | Primary Key error
19 | Table Size Error
20 | (no message associated with this error)
21 | (no message associated with this error)

For a detailed description of a particular message, go to Reference > Error Messages in your Database Connectors documentation.

Parent topic: Database Connectors for Microsoft SQL Server


Common Questions and Answers

This section contains some questions and answers specific to Database Connectors for MSSQL.

When I try to open a file for output, I get the error 9/83, with a secondary error of 2714. There is already an object named "*" in the database. Why?
One of your record's data items probably has the same name as an MSSQL reserved word. Locate the column by comparing a file trace of the CREATE TABLE to MSSQL's list of reserved words. Apply the NAME XFD directive to the field in the file descriptor (FD) that is associated with the invalid column, then recompile the program to create a new XFD file.
Can I open tables in different databases?
Yes. Use a file name like:
database.owner.tablename

Note that, because Database Connectors for MSSQL automatically determines an owner, you can also specify a file name like database..tablename. The two dots are mandatory in this case.

Can I use multiple servers (on the same machine or on different machines) on my network?
Yes. Each server has a unique name.
I'm getting an error 9/83, with a secondary error of 11, Micro Focus lock table missing. I know that I added the lock table during installation.
This is probably a permissions problem. All users must have READ, WRITE, UPDATE, and DELETE access to AcuLocks1 (and therefore to the database that contains it). Be sure to check your permissions.
I keep receiving an error message saying that my login is invalid. But I'm sure I'm using the correct username and password.
All usernames, passwords, and database names are case-sensitive. Be sure that you are typing the names exactly as they are set up.
Are there any library routines that do not work with or would not make sense to use with Database Connectors for MSSQL?
Two library routines that either don't work with or do not make sense to use with Database Connectors for MSSQL: C$COPY and C$RECOVER.
Parent topic: Database Connectors for Microsoft SQL Server


Tutorial: Extending CICS Applications to Use Database Connector for Microsoft SQL Server

  • Introduction to the Data Conversion Tutorial
  • Gathering Information About Your COBOL Data File
  • Creating the COBOL Application
  • Creating the Database Table
  • Migrating Your Data
  • Troubleshooting
Parent topic: Database Connectors User's Guide


Introduction to the Data Conversion Tutorial

This section provides a brief introduction to the process of extending an existing CICS application to use Micro Focus’s Database Connectors™ for Microsoft® SQL Server. This allow your application to store and access information in a Microsoft SQL Server relational database management system (RDBMS).

This Getting Started tutorial is intended to provide a quick introduction to the most common tasks you encounter while migrating your data. You should do the sections in the order in which they are presented in this tutorial; each section uses information or files from the previous section(s).

  • Overview
  • Demonstration Application
  • Preparation
Parent topic: Tutorial: Extending CICS Applications to Use Database Connector for Microsoft SQL Server


Overview

The data conversion tutorial presents an example of one way to convert your data from an existing CICS application running under Studio Enterprise Edition. For the purposes of this tutorial, you should already have your data files residing in the Micro Focus file system with the ASCII character set.

This tutorial shows how to:

  • Gather information from your existing application describing the COBOL record layout
  • Gather information on the key structure of the file
  • Create a simple COBOL application with a SELECT and FILE DESCRIPTOR for the file
  • Compile the COBOL application to generate an eXtended File Descriptor (XFD) that map your data from the record-oriented COBOL application to a relational database’s column-oriented format
  • Use your newly created COBOL application to generate an empty database table in Microsoft SQL server
  • Verify the table format
  • Enhance the sample application to load the data from your Micro Focus data file into the newly created Microsoft SQL Server table
Parent topic: Introduction to the Data Conversion Tutorial


Demonstration Application

The CICS application that is used in this tutorial is the ACCT demonstration application, the standard example application that IBM supplies with CICS systems. The ACCT application files are supplied with Studio Enterprise Edition. This application is also used for the CICS tutorial (find the location of this tutorial in the next section, Preparation.

Parent topic: Introduction to the Data Conversion Tutorial
Related information
Preparation


Preparation

To complete this tutorial, have the following software installed:

  • Studio Enterprise Edition
  • Server Enterprise Edition
  • Mainframe Subsystem Support (MSS), an option within Server Enterprise Edition

You should also have completed the tutorial Tutorial: Web-Enabled CICS Acting as a Web Server This Database Connectors tutorial uses the VSAM file, ACCTFIL created while completing that tutorial.

Finally, you should be familiar with the Database Connectors User's Guide. This tutorial refers to sections of this manual.

Parent topic: Introduction to the Data Conversion Tutorial
Related concepts
Tutorial: Web-Enabled CICS Acting as a Web Server


Gathering Information About Your COBOL Data File

This section walks you through the process of gathering information about your data file.

  • Overview
  • Determining the File Descriptor
  • Determining the Key Layout
Parent topic: Tutorial: Extending CICS Applications to Use Database Connector for Microsoft SQL Server


Overview

To prepare for building a table in the relational database, you need to build a COBOL description for a VSAM file that matches the data used in your application. To accomplish this, you need to locate the following information:

  • COBOL file descriptor (FD) for the internal layout of the data within the file
  • Description of the unique primary key used for accessing the data file
  • Descriptions of any alternate indexes that may be required for the file
Parent topic: Gathering Information About Your COBOL Data File


Determining the File Descriptor

To determine the FD for your data, examine a COBOL application that accessed the data through CICS.

The files for the demonstration are in the subdirectory Examples\Visual Studio Integration\Mainframe\CICS in your installation folder. If you completed the CICS tutorial in an alternate directory, use that directory.

Open the demonstration project in:

  1. Click File > Open > Project/Solution, browse to your solution name (such as cics.sln), and select it.

    The solution explorer window shows the COBOL files, mapsets, and copy files used for this project.

  2. Open the COBOL source file acct01.cbl.
  3. Locate a CICS operation that reads in a data record.

    For example, you can do a quick find for the phrase EXEC CICS READNEXT. In this example, you see the statement:

    EXEC CICS READNEXT DATASET('ACCTIX') INTO(ACCTREC)
               LENGTH(ACCT-LNG) RIDFLD(BRKEY) END-EXEC.
  4. Go to the definition of ACCTREC by placing your cursor on its name and either right-clicking it and clicking Go To Definition or by pressing your <f12> function key.

    The structure of this record is defined in the copybook ACCTREC. If you want to examine this structure, open the file by placing your cursor on its name and right-clicking it and then clicking Open “ACCTREC”.

Parent topic: Gathering Information About Your COBOL Data File


Determining the Key Layout

If you ran the previously mentioned tutorial, you have a COBOL VSAM file called ACCTFIL. If you do not know the location in which this file was created, you can determine it with the following:

  1. Start Enterprise Server Administration.
  2. In the row for CICSDEMO, which is the enterprise server to use, click Details.
  3. Click the Properties tab.
  4. Click the MSS tab.

    The field File Path: contains the directory in which your file was created.

To determine the key structure, you can use the rebuild command:

  1. Change directory to the location pointed to by File Path.
  2. Use the rebuild command to determine the details of the file format. For example:
    rebuild /n acctfil
Micro Focus  V6 File Management Utility
Version 5.101.0057 Copyright ©) 1984-2009 Micro Focus (IP) Limited.

        File                             :   acctfil
        Organization                     :   Indexed
        Format                           :   IDX-8
        Recording Mode                   :   Variable
        Compression                      :   N
        Maximum Record Length            :               383
        Minimum Record Length            :                63
        Index Node Size                  :              1024
        Number of data records           :                 2
        Data  Created With Extfh Version :             14720
        Last  Updated With Extfh Version :             14720

        Key Description (where 'Start' is measured from offset 1):
          Key       Start     Length     Dupl     Key Comp   Sparse Char
            0           1          5        N
            1           6         12        Y
/n acctfil

You can also locate this same information from within Enterprise Server Administration:

  1. Start Enterprise Server Administration.
  2. In the row for CICSDEMO, which is the enterprise server to use, click Details.
  3. Click ES Monitor & Control….

    This shows summary information for the application that the server is running and its transactions.

  4. In Resources, which is about halfway down on the left, expand the drop-down list and click by Group and then Groups.

    Notice that the first group is DFH$ACCT for the ACCT demonstration program. If you click the Details button for this group, you can display information about the demo’s resources, and you can click Details again to see further details on each item.

  5. Click Details beside ACCTFIL FCT ACCT CICS primer base cluster.

    This provides information on the main file, such as:

    • Minimum record size = 63
    • Maximum record size = 383
    • Primary key offset = 1
    • Primary key length = 5
  6. Click your Back button, and then click Details beside ACCTIX FCT ACCT CICS alternate index.

    This provides information on the alternate index, such as:

    • Alternate key offset = 6
    • Alternate key length = 12
    • Allow Duplicate Keys
Parent topic: Gathering Information About Your COBOL Data File


Creating the COBOL Application

In this section, you use the information gathered in the previous section to write a simple COBOL application that describes the data file. You then compile the COBOL application to generate an eXtended File Descriptor (XFD) to map your data from the record-oriented COBOL application to a relational database’s column-oriented format.

  • Preparation
  • Code Sample
  • Creating XFD Files
Parent topic: Tutorial: Extending CICS Applications to Use Database Connector for Microsoft SQL Server


Preparation

Be sure you have installed and configured all of the prerequisite software.
  1. In Studio Enterprise Edition, click File > New > Project > COBOL Projects > Native > Console Applications.
  2. Create a new project called db_acct in a directory of your choice.
  3. In the solution explorer window, right-click in the db_acct project name.
  4. Click Add > Existing Item.
  5. Browse to the Studio Enterprise Edition subdirectory Examples\Visual Studio Integration\Mainframe\CICS and add the copy book acctrec.cpy.
  6. In the solution explorer window, right-click in the db_acct project name.
  7. Click Add > New Item > Native > COBOL Program to create a new COBOL program.
  8. Name the COBOL program dbacct.cbl.
  9. Add this program to your project.
Parent topic: Creating the COBOL Application


Code Sample

To begin the process, you write a small application to open and close the file. This allows you to check to see if our COBOL description of the file is correct.

From the previous section, you know that the record layout of the file is located in the copy book ACCTREC. You also know that you have two keys on the file. There is a primary key that is located at offset 1 and has a length of 5 bytes. There is also an alternate key located at offset 6 that is 12 bytes in length and allows duplicates. You fill in the initial COBOL structure using this information.

To get the key information, scan down the record description and locate COBOL fields at the correct offset.

  1. Enter the following to the newly created dbacct.cbl program:
    IDENTIFICATION DIVISION.
       PROGRAM-ID. DBACCT.

       ENVIRONMENT DIVISION.

       INPUT-OUTPUT SECTION.
       FILE-CONTROL.

       SELECT ACCT-IN
               ASSIGN TO DISK "ACCTFIL"
               ORGANIZATION IS INDEXED
               ACCESS MODE IS DYNAMIC
               RECORD KEY IS
                  ACCTDO OF ACCT-IN-REC
               ALTERNATE RECORD KEY IS
                  SNAMEDO OF ACCT-IN-REC WITH DUPLICATES
               FILE STATUS IS ACCT-FILE-STATUS.

       DATA DIVISION.
       FILE SECTION.

       FD ACCT-IN.
       01 ACCT-IN-REC.
       COPY "acctrec.cpy".

       WORKING-STORAGE SECTION.
       01 ACCT-FILE-STATUS.
          05 ACCT-STATUS-KEY-1                   PIC X(1).
          05 ACCT-STATUS-KEY-2                   PIC X(1).
          05 ACCT-STATUS-KEY-2-BINARY REDEFINES ACCT-STATUS-KEY-2
                                                 PIC 9(2) COMP-X.
       01 USER-RETURN                            PIC X(10).

       PROCEDURE DIVISION.
       DECLARATIVES.
       FILE-ERR-HANDLING SECTION.
          USE AFTER STANDARD ERROR PROCEDURE ON ACCT-IN.
       FILE-ERR.
          DISPLAY "File Error: ", ACCT-FILE-STATUS.
          DISPLAY "Press <return> to exit".
          ACCEPT USER-RETURN.
          STOP RUN.
       END DECLARATIVES.

       LEVEL-1 SECTION.
       MAIN-LOGIC.
            PERFORM OPEN-IN-FILE.
            STOP RUN.

       OPEN-IN-FILE.
            OPEN INPUT ACCT-IN.
            CLOSE ACCT-IN.
  2. After you have entered the program above, save the file and then build the project.

You can now run the project in the Debugger. However, when your application attempts to open the file, the following error message appears:

File Error: 35
Press <return> to exit

You have not told the program where the file is located. To do this in Studio Enterprise Edition, follow the steps below:

  1. Close your solution and exit Studio Enterprise Edition.
  2. Open a Visual Studio command prompt and set a variable:
    Variable | Value
    DD_ACCTFIL | <location of file>\ACCTFIL
  3. Start Studio Enterprise Edition from the command prompt using the devenv command.

This time when you run the file, the following error message appears.

File Error: 39
Press <return> to exit

This error indicates that there is a mismatch between the file description in our COBOL program and the actual file on disk. Reviewing the information from the previous section, you see that the first alternate key for the file should be only 12 bytes long. The field you selected for the alternate record key from the copy book, however, is 18 bytes long. You need to break this field up:

  1. Make a copy of acctrec.cpy called acctrec2.cpy and modify it as follows:
    02  ACCTDO               PIC X(5).
           02  SNAMEDO.
               05  SNAMEDO1         PIC X(12).
               05  SNAMEDO2         PIC X(6).
           02  FNAMEDO              PIC X(12).
  2. Once you have modified the new file and saved it, add it to your project.
  3. Change the copy statement in the COBOL application to copy in the new file acctrec2.cpy.
  4. Change the select statement to read:
    ALTERNATE RECORD KEY IS
SNAMEDO1 OF ACCT-IN-REC WITH DUPLICATES
  5. Change the FD statement to read:
    FD ACCT-IN
    RECORD IS VARYING FROM 63 TO 383.
01 ACCT-IN-REC.
COPY “acctrec2.cpy”.
  6. Rebuild your project and run the application.

You should now have a COBOL application that successfully opens the file for processing.

Parent topic: Creating the COBOL Application


Creating XFD Files

Relational databases work with data in a column-oriented format, while COBOL works with data in a record-oriented format. To move your data between these two domains, you need some form of mapping. To accomplish this, compile the COBOL application to generate an eXtended File Descriptor (XFD). This XFD maps data from the record-oriented COBOL application to a relational database’s column-oriented format. For detailed information on XFDs, see the chapter XFDs.

To instruct the compiler to generate XFD files:

  • At the top of your COBOL file, add the following directive:
    $SET CREATEXFD
 IDENTIFICATION DIVISION.
 PROGRAM-ID. DBACCT.

  • If you want the XFD files to be placed in a different directory from the current one, use the following format:

    $SET CREATEXFD(XFD-DIRECTORY=c:\myproject\xfd)
  • You can also set this directive using the project’s properties:
    1. Double-click Properties.
    2. Click on the COBOL tab.
    3. In the Additional Directives entry field, type CREATEXFD and save the changes.

The next section expands the COBOL application to create a database table in Microsoft SQL Server using the XFD file generated by the compiler.

Parent topic: Creating the COBOL Application
Related information
XFDs


Creating the Database Table

In this section, you use the COBOL application from the previous section to create a new Microsoft SQL Server table in which to store your COBOL information.

In this section, you will:

  • Modify the COBOL application to add a new file description
  • Add COBOL directives to allow your application to work with Database Connectors
  • Set up configuration variables and files to direct the operations of Database Connectors
  • Run the sample program to create a new database table
  • Check the resulting Microsoft SQL Server table for columns and indexes
  • Modify field names for improved readability
  • Code Sample
  • Setting Up the Configuration File
  • Setting the Runtime Environment Variable
  • Enabling Dynamic Redirection to a Custom File Handler
  • Turning on Tracing
  • Running the Sample Program
  • Checking the Resulting Microsoft SQL Server Table
  • Modifying Field Names for Improved Readability
Parent topic: Tutorial: Extending CICS Applications to Use Database Connector for Microsoft SQL Server


Code Sample

Database Connectors is designed to simplify the process of working with relational databases as much as possible for the COBOL application developer. With this in mind, you can use the traditional COBOL OPEN OUTPUT verb to create a new database table. Modify the application from the previous example to have a new file description matching the existing file format, but intended to be your new table in the database.

$SET CREATEXFD
      IDENTIFICATION DIVISION.
      PROGRAM-ID. DBACCT.

      ENVIRONMENT DIVISION.

      INPUT-OUTPUT SECTION.
      FILE-CONTROL.

      SELECT ACCT-IN
              ASSIGN TO DISK "ACCTFIL"
              ORGANIZATION IS INDEXED
              ACCESS MODE IS DYNAMIC
              RECORD KEY IS
                 ACCTDO OF ACCT-IN-REC
              ALTERNATE RECORD KEY IS
                 SNAMEDO1 OF ACCT-IN-REC WITH DUPLICATES
              FILE STATUS IS ACCT-FILE-STATUS.

      SELECT ACCT-OUT
              ASSIGN TO DISK "DBACCTFIL"
              ORGANIZATION IS INDEXED
              ACCESS MODE IS DYNAMIC
              RECORD KEY IS
                 ACCTDO OF ACCT-OUT-REC
              ALTERNATE RECORD KEY IS
                 SNAMEDO1 OF ACCT-OUT-REC WITH DUPLICATES
              FILE STATUS IS ACCT-FILE-STATUS.

      DATA DIVISION.
      FILE SECTION.

      FD ACCT-IN
         RECORD IS VARYING FROM 63 to 383.
      01 ACCT-IN-REC.
      COPY "acctrec2.cpy".

      FD ACCT-OUT
         RECORD IS VARYING FROM 63 to 383.
      01 ACCT-OUT-REC.
      COPY "acctrec2.cpy".

      WORKING-STORAGE SECTION.
      01 ACCT-FILE-STATUS.
         05 ACCT-STATUS-KEY-1                   PIC X(1).
         05 ACCT-STATUS-KEY-2                   PIC X(1).
         05 ACCT-STATUS-KEY-2-BINARY REDEFINES ACCT-STATUS-KEY-2
                                                 PIC 9(2) COMP-X.
      01 USER-RETURN                            PIC X(10).

      PROCEDURE DIVISION.
      DECLARATIVES.
      FILE-ERR-HANDLING SECTION.
         USE AFTER STANDARD ERROR PROCEDURE ON ACCT-IN, ACCT-OUT.
      FILE-ERR.
         DISPLAY "File Error: ", ACCT-FILE-STATUS.
         DISPLAY "Press <return> to exit".
         ACCEPT USER-RETURN.
         STOP RUN.
      END DECLARATIVES.

      LEVEL-1 SECTION.
      MAIN-LOGIC.
     *     PERFORM OPEN-IN-FILE.
           PERFORM CREATE-OUT-FILE.
           STOP RUN.

      OPEN-IN-FILE.
           OPEN INPUT ACCT-IN.
           CLOSE ACCT-IN.

      CREATE-OUT-FILE.
           OPEN OUTPUT ACCT-OUT.
           CLOSE ACCT-OUT.

In the code sample above, you have:

  • Added a new SELECT and FD for your output file
  • Modified the declaratives to handle the new file
  • Added new code to perform an OPEN OUTPUT on the file
Parent topic: Creating the Database Table


Setting Up the Configuration File

Set up a configuration file that instructs Database Connectors on how to operate. In this example, use a project directory of C:\DataConnectors\Test and a configuration file of mssql.cfg.

  1. Create a new textfile called mssql.cfg in your project directory.
  2. Add the following entries to the file:
    ##################################################
# mssql.cfg
#
# Configuration file for settings to be used in
# conjunction with Database Connectors for MSSQL
#
##################################################

##################################################
# The following is a list of individual assignments
# of files to a filesystem other than the default
##################################################

DBACCTFIL-HOST mssql
XFD-DIRECTORY c:\DataConnectors\Test

##################################################
# Connection information to be used when connecting
# to the target database in Microsoft SQL Server
##################################################

A-MSSQL-DEFAULT-CONNECTION MYSERVER
A-MSSQL-DATABASE testdb
A-MSSQL-LOCK-DB testlock
A-MSSQL-LOGIN testuser
A-MSSQL-PASSWD testpasswd

######################################
# File tracing
######################################

FILE_TRACE 9
FILE_TRACE_FLUSH TRUE
FILE_TRACE_TIMESTAMP TRUE

##################################################
# End of mssql.cfg
#
##################################################

The following table shows the options that you can set in the configuration file:

Variable | Value | Description
DEFAULT-HOST | mssql | Default File System
A-MSSQL-DEFAULT-CONNECTION | <servername> | Name of the MSSQL server
A-MSSQL-DATABASE | <testdb> | Name of the specific database to be accessed
A-MSSQL-LOCK-DB | <testlock> | Name of the database that holds the lock table
A-MSSQL-LOGIN | <testuser> | Name under which you want to connect to the database system
A-MSSQL-PASSWD | <testpasswd> | Password assigned to the user account
XFD-DIRECTORY | c:\DataConnectors\Test | Directory containing your XFD files if different from current directory
FILE-TRACE | <any number greater than “0”> | Level of file tracing to perform
Parent topic: Creating the Database Table


Setting the Runtime Environment Variable

After you have saved this configuration file, Studio Enterprise Edition must know where to find it, so set an environment variable:

  1. Close your solution and exit Studio Enterprise Edition.
  2. Open a Visual Studio command prompt and set the variable:
    Variable | Value
    A_CONFIG | c:\DataConnectors\Test\mssql.cfg
Parent topic: Creating the Database Table


Enabling Dynamic Redirection to a Custom File Handler

To enable the dynamic redirection of the file handler, set the following environment variables:

Variable | Value
DYNREDIR | DYNCONFIG:EXPAND
FHREDIR | <fhredir_config>

If you are using Enterprise Server, you also need to set the following environment variable:

Variable | Value
TXFILEP | <VSAM_dir>

If you are using Enterprise Server with only a database, TXFILEP needs to point to the directory where Micro Focus VSAM files would normally be found, and the XFD files need to go into the same directory specified by TXFILEP.

fhredir_config contains the redirection information, for example:

/f$TXFILEP\*     /r ACUFH!ACUFH
/f<VSAM_dir>\*   /r ACUFH!ACUFH

where $TXFILEP\* is needed only if you are using Enterprise Server, and <VSAM_dir>\* means that any COBOL file that has an XFD in the directory specified by VSAM_dir is redirected to the database.

If you are not using Enterprise Server, $TXFILEP is not needed.

You can replace the <VSAM_dir>\* with the full path, including the filename, for example:

/f<VSAM_dir>\ACCTFIL /r ACUFH!ACUFH

The DYNREDIR=DYNCONFIG:EXPAND fully expands all filenames into their pathnames. For example, if you have an entry:

/f<VSAM_dir>\*   /r ACUFH!ACUFH

and a COBOL file called ACCTFIL, it expands to:

<VSAM_dir>\ACCTFIL

If you are not using Enterprise Server, and you are using VSAM and database files in the same COBOL program, you cannot have the VSAM files in the same directory as the XFD files if you are using wildcards like <VSAM_dir>\*. This is because the wildcard tells the run time to redirect all COBOL files in the specified directory to the database. For example, if your VSAM file is ACCTFIL and your XFD file is DBACCTFIL.xfd and they are in a directory specified by <VSAM_dir>, you cannot use:

/f <VSAM_dir>\*   /r ACUFH!ACUFH

This is because the DYNREDIR logic redirects any file in that directory to the database, but you don't want to do this for ACCTFIL because it is a VSAM file. You have to either specify the full path for the XFD like this:

/f <VSAM_dir>\DBACCTFIL    /r ACUFH!ACUFH

or put the XFD in a different directory and specify the directory with the wildcard, for example:

/f <XFD_dir>\*   /r ACUFH!ACUFH

where XFD_dir is a directory where your XFD files reside and is different from the directory where your VSAM files reside. If you have a separate directory for your XFDs like this, you need to modify your COBOL program ASSIGN statement to specify the XFD_dir, for example:

ASSIGN TO DISK "<XFD_dir>\DBACCTFIL"

In addition, you need to modify your ACUFH configuration file and set XFD_DIRECTORY to XFD_dir so that the file handler can find your XFD files, for example:

XFD_DIRECTORY <XFD_dir>
Parent topic: Creating the Database Table


Running the Sample Program

When you have completed the above steps for creating your configuration file and preparing your environment, you are ready to create the new database table. Start Studio Enterprise Edition from the Visual Studio command prompt using the devenv command.

Run your application in Studio Enterprise Edition and step through the code. Upon successful creation, a new table is created in Studio Enterprise Edition.

Errors You May Encounter

When you come to the line OPEN OUTPUT ACCT-OUT, you may receive the error message File Error:9k. Check the log files that were created in the directory pointed to by mftrace.emitter.TEXTFILE#location = C:\DataConnectors\Test\logs, for the following:

init_connection
Trying to open a connection to server MyBadServer
report_status called from 1176
[1] 08001 17 – [DBNETLIB]SQL Server does not exist or access denied.
[2] 01000 53 – [DBNETLIB]ConnectionOpen (Connect()).

where MyBadServer is the value set in your configuration file for A-MSSQL-DEFAULT-CONNECTION.

Parent topic: Creating the Database Table


Checking the Resulting Microsoft SQL Server Table

Once the COBOL application has finished, you should review the resulting database table to ensure that it has the desired format and column names.

  1. To review the structure of the table, open Microsoft’s SQL Server Management Studio.
  2. Connect to the data source used in your configuration file. The entries map as follows:
    Server Management Studio | Database Connectors
    Server name | A-MSSQL-DEFAULT-CONNECTION
    Login | A-MSSQL-LOGIN
    Password | A-MSSQL-PASSWD
  3. Once you are connected, perform the following steps:
    1. Expand the Databases folder.
    2. Expand the folder referred to in the A-MSSQL-DATABASE setting from your configuration file.
    3. Expand the Tables folder.
    4. Locate and expand the folder containing the name DBACCTFIL.

This folder contains a list of subfolders that describe the columns that comprise the table, as well as the indexes on the table. (Note that there is also a folder titled Keys. Don't confuse this with the Indexes, which is where the equivalent of the COBOL keys are created.)

Indexes names take the form I<tablename><key>.

Review the objects in the Columns folder for readability and to ensure that the COBOL fields you wanted to be included were indeed created. You can affect field names with the use of the NAME directive placed in your COBOL FD. You can modify the table structure with the USE GROUP, WHEN, and other directives placed within your COBOL FD. Please refer to your Micro Focus Database Connectors Reference Help for further details on these directives.

Parent topic: Creating the Database Table


Modifying Field Names for Improved Readability

Once you have examined the resulting database table, there may be changes you want to make to improve readability. One of the most common modifications is to change the name of one of the resulting columns in the database table to make it easier to work with from SQL. Database Connectors provides a simple method for handling this situation.

You can embed COBOL directives into you program that modify how the table is created. One of the more convenient directives is the NAME directive, which instructs Database Connectors to name the resulting database column by another name. This directive does not in any way modify how the COBOL program operates. It is strictly a comment from the perspective of your application. For further information about the NAME directive, see the Help in your Database Connectors User's Guide Reference section.

  • Code Sample
Parent topic: Creating the Database Table


Code Sample

For your example here, you may want to modify the database table such that instead of the COBOL fields ACCTDO, SNAMEDO1, and FNAMEDO, the database table has the more readable names of ACCOUNT_NUMBER, SURNAME, and FIRST_NAME. To do this, place directives into the COBOL program as follows:

$XFD name=account_number
           02  ACCTDO               PIC X(5).
           02  SNAMEDO.
      $XFD name=surname
               05  SNAMEDO1         PIC X(12).
               05  SNAMEDO2         PIC X(6).
      $XFD name=first_name
           02  FNAMEDO              PIC X(12).
           02  MIDO                 PIC X.
           02  TTLDO                PIC X(4).
           02  TELDO                PIC X(10).
           02  ADDR1DO              PIC X(24).

Saving your file and rebuilding your project generates a new XFD file. When your application performs an OPEN OUTPUT, a new table with the new names is generated. From the perspective of your existing COBOL code, there has been no change. You won’t need to make any changes to your procedure division logic.

Parent topic: Modifying Field Names for Improved Readability


Migrating Your Data

In the previous section, you saw how by setting up a sequence of configuration variables, you were able to use a standard COBOL program to create a new database table in Microsoft SQL Server. In this section, you use the COBOL application from the previous section to move the data from the previously existing Micro Focus VSAM file into the newly created database table. You use a configuration variable to determine which file system is to host the file.

  • Code Sample
Parent topic: Tutorial: Extending CICS Applications to Use Database Connector for Microsoft SQL Server


Code Sample

This exercise adds a new paragraph to the COBOL application that reads all records from the source file and writes them into the newly created database table.

  1. Modify the procedure division of your COBOL application as follows:
    PROCEDURE DIVISION.
       DECLARATIVES.
       FILE-ERR-HANDLING SECTION.
          USE AFTER STANDARD ERROR PROCEDURE ON ACCT-IN, ACCT-OUT.
       FILE-ERR.
          DISPLAY "File Error: ", ACCT-FILE-STATUS.
          DISPLAY "Press <return> to exit".
          ACCEPT USER-RETURN.
          STOP RUN.
       END DECLARATIVES.

       LEVEL-1 SECTION.
       MAIN-LOGIC.
      *     PERFORM OPEN-IN-FILE.
      *     PERFORM CREATE-OUT-FILE.
            PERFORM COPY-FILE.
            STOP RUN.

       OPEN-IN-FILE.
            OPEN INPUT ACCT-IN.
            CLOSE ACCT-IN.

       CREATE-OUT-FILE.
            OPEN OUTPUT ACCT-OUT.
            CLOSE ACCT-OUT.

       COPY-FILE.
           OPEN INPUT ACCT-IN.
           OPEN OUTPUT ACCT-OUT.
           READ ACCT-IN NEXT RECORD AT END CONTINUE.
           PERFORM UNTIL ACCT-FILE-STATUS = "10"
               MOVE CORRESPONDING ACCT-IN-REC TO ACCT-OUT-REC
               WRITE ACCT-OUT-REC
               READ ACCT-IN NEXT RECORD AT END CONTINUE
           END-PERFORM.
           CLOSE ACCT-IN.
           CLOSE ACCT-OUT.
           DISPLAY "Conversion Complete.".
  2. Open your configuration file mssql.cfg and verify that it contains the following entry:

##################################################
# The following is a list of individual assignments
# of files to a filesystem other than the default
##################################################

DBACCTFIL-HOST mssql
  3. Rebuild and run your application.

If the run was successful, all of your records should now be stored in the database table. You can use a tool such as Microsoft SQL Server Management Studio to verify your data. For example, you can do a quick check with the SQL command:

select  acctdo, snamedo1, snamedo2 from dbo.DBACCTFIL

which returns all of the account numbers and surnames from your newly created table. Another quick spot check you can use is the SQL command:

SELECT COUNT (*) FROM dbo.DBACCTFIL

This returns the total number of rows in your table. You can compare this result to the number of records returned by the rebuild /n acctfil command.

Parent topic: Migrating Your Data


Troubleshooting

In this section are some of the possible problems you may encounter while modifying your applications to work with a relational database.

Question

Where is the Micro Focus VSAM file ACCTFIL?

This file should have been created when you ran the CICS tutorial. (For information on this tutorial, see the section Preparation.

Question

Why did I get file error 35 on OPEN INPUT ACCT-IN?

  • Verify that the file was created, as in the previous question.
  • To determine the location of the data file, refer to the section Determining the Key Layout.
  • Verify that the environment is set up correctly. See the discussion of this in the section Code Sample.

Question

Why did I get file error 39 on OPEN INPUT ACCT-IN?

The actual key definition of ACCTFIL does not directly match up to existing fields in the copy book acctrec.cpy. You need to modify the record description. See the discussion of this in the section Code Sample.

Question

Why did I get file error 9k or 9,107 on OPEN OUTPUT ACCT-OUT?

A Database Connectors-specific error has occurred. You need to rerun your application using an emitter to determine the exact nature of the error. See the section Turning on Tracing for details on how to turn on tracing and configure an emitter for use with Database Connectors.

Once you have a trace file, search for the error 9k to determine the source of the issue. There is a block of information providing details on the error, for example:

MF.RTS 51 1 : "  f_errno: 19"
MF.RTS 51 1 : "  f_int_errno: 3"
MF.RTS 51 1 : "  f_int2_errno: 2"
MF.RTS 51 1 : "  f_errmsg: Unable to open XFD file for 'DBACCTFIL',
                 error = 2"
MF.RTS 51 1 : "  9k or 9,107"

This error indicates the run time system was unable to locate the data dictionary (XFD) for the file. To resolve this, ensure that you compiled with the $SET CREATEXFD directive (see the section Creating XFD Files. If your XFD files are not in the current directory, you need to set the XFD-DIRECTORY variable in your Database Connectors configuration file to the directory in which your XFD files are stored (see the section Setting Up the Configuration File.

MF.RTS 51 1 : "  f_errno: 19"
MF.RTS 51 1 : "  f_int_errno: 18456"
MF.RTS 51 1 : "  f_int2_errno: 0"
MF.RTS 51 1 : "  f_errmsg: Login failed for user 'testuser'."
MF.RTS 51 1 : "  9k or 9,107"

This error indicates that Database Connectors was unable to log into the Microsoft SQL Server database. To resolve this, ensure that you have provided the correct configuration information for access to your MSSQL database (see the section Setting Up the Configuration File. The variables in question are:

  • A-MSSQL_DEFAULT-CONNECTION
  • A-MSSQL-DATABASE
  • A-MSSQL-LOGIN
  • A-MSSQL-PASSWD

Question

Why is the file DBACCTFIL is being created as a Micro Focus VSAM file, and not an MSSQL table?

Verify the following:

  • You are running on Version 6.0
  • You have created an environment variable, A_CONFIG, pointing to your Database Connectors configuration file (see the section Setting the Environment Variable.
  • Your configuration file contains the following entry:
    DBACCTFIL-HOST mssql

For a more complete discussion of troubleshooting your application using Micro Focus Database Connectors, refer to the chapter Performance and Troubleshooting of your Database Connectors User’s Guide.

Question

Why do I receive an error 9k when I try to create a table in Microsoft SQL Server?

You might be using the wrong server name in the A-MSSQL-DEFAULT-CONNECTION variable. One way you can verify the server name is by following the steps below. This method is useful if you don't have the client tools for SQL Server installed.

  1. Create a new ODBC Datasource for SQL Server.
  2. When prompted for the server name, select your local server from the drop-down list of available servers.
  3. Connect to this server using ODBC Administrator.

    This provides you with the name of the server you need to use in the A-MSSQL-DEFAULT-CONNECTION variable.

Parent topic: Tutorial: Extending CICS Applications to Use Database Connector for Microsoft SQL Server
Related information
Preparation
Determining the Key Layout
Code Sample
Turning on Tracing
Creating XFD Files
Setting Up the Configuration File
Setting the Environment Variable


Database Connectors Tasks

  • To check the database table
  • To create an empty table and grant access privileges to other users
  • To create an error map
  • To create a Visual Studio Solution
  • To enable tracing for ACUFH
  • To examine the CTF trace file
  • To install Database Connectors on a Windows server
  • To prepare your program and execute it using Database Connectors
  • To set the run time environment variables
  • To set the system parameters
  • To set up the user environment
  • To start the demo program
  • To use the WHERE constraint from COBOL
Parent topic: Micro Focus Database Connectors Version 2.0 for Windows


To check the database table

Once the COBOL application has finished, you should review the resulting database table to ensure that it has the desired format and column names. For this exercise, we are using Microsoft SQL Server.
  1. To review the structure of the table, bring up Microsoft’s SQL Server Management Studio.
  2. Connect to the data source you used in your configuration file. The entries map as follows:
    Server Management Studio | Database Connectors
    Server name | A-MSSQL-DEFAULT-CONNECTION
    Login | A-MSSQL-LOGIN
    Password | A-MSSQL-PASSWD
  3. Once you are connected, perform the following steps:
    1. Expand the Databases folder.
    2. Expand the folder referred to in the A-MSSQL-DATABASE setting from your configuration file.
    3. Expand the Tables folder.
    4. Locate and expand the folder containing the name purch1.

      This folder contains a list of subfolders that describe the table columns and indexes. Note that the folder titled Keys, which should not be confused with the Indexes folder, which is where the equivalent of the COBOL keys are created.

      Index names take the form I<tablename><key>.

    Review the objects in the “Columns” folder for readability and to ensure that the COBOL fields you wanted to be included were indeed created. You can affect field names by placing the NAME directive in your COBOL FD. You can modify the table structure with the USE GROUP, WHEN, and other directives placed within your COBOL FD.

Parent topic: Database Connectors Tasks


To create an empty table and grant access privileges to other users

  1. Run your database query tool.

    The program pauses to accept a SQL command.

  2. Enter the following (italics indicate variable names, non-italics are SQL reserved words):
    CREATE TABLE newtab (col1 CHAR(30), col2 CHAR(11))
    The program pauses to accept a SQL command.
  3. Now enter the following command:
    GRANT ALL PRIVILEGES ON newtab TO PUBLIC

    The program pause to accept a SQL command.

  4. Now enter:
    CREATE UNIQUE INDEX newtab_index ON newtab (col1)
  5. Next, press Enter again to exit the program.
Note:

When naming columns and tables, make sure to use underscores ("_"), not hyphens ("-"), or a syntax error occurs.

The above entries create a new table and grant access permission to everyone. Enter the following command to delete the table.

DROP TABLE newtab
Parent topic: Database Connectors Tasks


To create an error map

Although you can check your data source documentation for error code information, the easiest way to determine which error codes need to be mapped to more appropriate COBOL codes is through trial and error. As users use Database Connectors DB2, they may report receiving error messages that don't make sense based on their situation. Research these errors and try to determine a more appropriate COBOL error response.

When you create your error map file, use the following guidelines:

  • Begin comment lines with "#". Blank lines are also considered comments
  • Break the rest of the file into sections, with each section header comprising all the information enclosed in brackets from the data source error function.

    The following example leads to the entry in the sample DB2 error file:

      OdbcOneInfo: State: 23505, Native Error: -803
  '[IBM][CLI Driver][DB2/NT]SQL0803N One or more values in the INSERT statement, UPDATE statement, or foreign key update caused by a DELETE statement are not valid because they would produce duplicate rows for a table with a primary key, unique constraint, or unique index.  SQLSTATE=23505'
  Setting f_errno = 19
Leaving, error
***File system error value = -803 ***
>>>file status = 9S,-803
  • Include two fields in each line in the section: the internal error number, and a mapping string.

    Using the same example, you would include this line in the error_map file:

    -803 E_DUPLICATE

    The valid values for the second field are as follows:

    E_SYS_ERR
E_PARAM_ERR
E_TOO_MANY_FILES
E_MODE_CLASH
E_REC_LOCKED
E_BROKEN
E_DUPLICATE
E_NOT_FOUND
E_UNDEF_RECORD
E_DISK_FULL
E_FILE_LOCKED
E_REC_CHANGED
E_MISMATCH
E_NO_MEMORY
E_MISSING_FILE
E_PERMISSION
E_NO_SUPPORT
E_NO_LOCKS

The file DB2.err contains some initial file error mappings.

Parent topic: Database Connectors Tasks


To create a Visual Studio Solution

In this topic, you create a Visual Studio solution for your COBOL application. You then use the compiler to compile the COBOL application to generate an “eXtended File Descriptor” (XFD). The XFD is used to map your data from the record-oriented COBOL application to a relational database’s column-oriented format.

  1. In Visual Studio, click File > New > Project > COBOL Projects > Native > Console Applications.

    The new project generates a template program called program1.cbl that is not needed. You may want to delete it.

  2. Create a new project called dbsample in a directory of your choice.
  3. In Solution Explorer, double-click in Properties and ensure that the following options are set in the Application, COBOL, and Debug tabs:
    Application Tab Output type: Console Application
    COBOL Tab Native

    COBOL dialect: Non-mainframe

    Link settings

    • Run-time Library
      • [x] Shared
    • Thread Model
      • [x] Multi-threaded
    • Linker Parameters
      • Link with objs: "C:\Program Files\Micro Focus\Studio Enterprise Edition 6.0\Base\Lib\FHRSUB.OBJ"
      • [x] Include system programs

        If you don't check this, you don't need to link with fhrsub.ob

    Debug Tab Start Options
    • Working directory: <location of xfd file> (for example, c:\myproject\xfd).
  4. In Solution Explorer, right-click in the dbsample project name.
  5. Click Add > Existing Item.
  6. Browse to the following subdirectory in the samples, Examples\Database Connectors, and add the sample program order1.cbl.
  7. Open the order1.cbl program.

    Notice that to instruct the compiler to generate the XFD file, you use at the beginning of the COBOL program the following directive:

    $SET CREATEXFD

    If you want the XFD files to be placed in a different directory from the current one, you can use the following format:

    $SET CREATEXFD(XFD-DIRECTORY=c:\myproject\xfd)

    This directive can also be set using the project’s properties. To do this, double-click on the project’s Properties, click on the COBOL tab, and in the Additional Directives entry field type CREATEXFD. Save the changes.

  8. Build your project.

    The compiler creates the purch1.xfd file in your current XFD directory.

Parent topic: Database Connectors Tasks


To enable tracing for ACUFH

  1. Set the following environment variables:
    MFTRACE_CONFIG
MFTRACE_LOGS

    For example:

    MFTRACE_CONFIG=config.ctf
MFTRACE_LOGS=.

    The config.ctf file contains the Consolidated Tracing Facility (CTF) configuration information.

  2. Specify the run time system as a component with "eprintf" as the property.

Example:

mftrace.comp.mf.rts#eprintf
mftrace.level=info
Parent topic: Database Connectors Tasks


To examine the CTF trace file

  1. Set the FILE_TRACE ACUFH configuration variable to a number from 1 to 9.
  2. Run your program again.
  3. Proceed until you encounter the error condition, and then exit.

    Your CTF trace file contains the error information described in the section Retrieving Messages Using the FILE_TRACE ACUFH Configuration Variable in the chapter Performance and Troubleshooting, and also contains the SQL queries that the Database Connectors™ interface constructed. Examining these queries can help to determine the cause of the syntax error. Please contact Micro Focus Customer Care if you need help.

Parent topic: Database Connectors Tasks
Related information
Retrieving Messages Using the FILE_TRACE ACUFH Configuration Variable


To install Database Connectors on a Windows server

  1. Install MSSQL.

    You must install and configure Microsoft SQL Server, version 6.5 or later, on the Windows server machine before you install Database Connectors for MSSQL on the client machine. Follow the instructions from your RDBMS vendor.

  2. Copy the Batch File.

    MS_INST.CMD is a batch file from Micro Focus that creates the MS_INST.SQL file, which is the collection of stored procedures necessary for executing Database Connectors. Copy MS_INST.CMD to your server machine into a directory of your choice.

  3. Execute the Batch File.

    To execute the batch file, enter

    MS_INST LockDatabase

    where LockDatabase is the database you want to use for the internal lock tables. This database is created if it does not already exist.

    Users must have write access to this database.

    The next step creates MS_INST.SQL, the collection of stored procedures necessary for executing Database Connectors for MSSQL.

  4. Install the Micro Focus Stored Procedures.

    To install the stored procedures in your Microsoft SQL database, execute the generated MS_INST.SQL file with the SQL Query Analyzer or the SQL Server Management Studio if you are using Microsoft SQL Server 2005.

    By default, the stored procedures are installed into the master database. However, you may choose another database in which to store them.

This completes the setup on the Windows server machine.

Note: If you are upgrading from an earlier version of Database Connectors, be sure to install the new stored procedures. Stored procedures are always upgraded in such a way that they are compatible with older versions of the product, so installing new stored procedures over old ones does not affect your ability to run with an older version of the interface software. Your new version of Database Connectors for MSSQL may not run properly without the corresponding stored procedures.

It can be difficult to maintain multiple copies of stored procedures; therefore, we recommend that you continue to create the stored procedures in the master database. If your installation does not permit this, you do have the flexibility to create the stored procedures elsewhere. However, to facilitate maintenance of the stored procedures, we recommend that you create as few databases as possible.

Parent topic: Database Connectors Tasks


To prepare your program and execute it using Database Connectors

  1. Use the following directive:

    CREATEXFD (parameter,...)

    By default, if no parameters are specified to the CREATEXFD directive, XFDs are created for indexed files. XFDs are portable across operating systems.

    Parameters:
    • VERSION=n

      Creates XFDs as version n

    • XFD-DIRECTORY=pathname

      Creates XFDs in the directory specified by pathname

    • FILE-TYPE=ALL

      Creates XFDs for indexed, relative, and sequential files

    For information about XFDs, see the chapter XFDs.
  2. Compile.

    You compile your COBOL application with your COBOL development system's Compiler.

  3. Set the files host.

    In an ACUFH configuration file, you may specify which RDBMS file system you are using by setting the DEFAULT_HOST variable (sets a default for all files), or the filename_HOST variable (sets a file system for individual files), or both. For example, you might say EMPFILE_HOST ORACLE. This would direct EMPFILE input and output functions to the Oracle RDBMS via Database Connectors™, and direct I/O for all other indexed files to the EXTFH file handler. These are run time settings that allow you to change hosts without recompiling, and enable you to tailor your application for the specific needs of a particular end-user site.

    Note:

    The filename_HOST variable also enables you to do load balancing and migration of your application. You can move indexed files into the database in an incremental fashion, allowing you to test scaling and performance of the new configuration.

  4. Set database-specific variables.

    At this point, you set variables in the ACUFH configuration file that apply to the specific database system you are using. See the appendix specific to your RDBMS for details.

  5. Pass I/O requests to the interface.

    You use the run time system to execute your application. Whenever the run time system encounters an input or output instruction (such as READ or WRITE) on a file that is directed to an RDBMS, it passes the request to Database Connectors.

  6. Automatically build SQL statements.

    Database Connectors automatically builds SQL instructions that your database management system can understand. As it builds these SQL instructions, it looks at the XFD, which maps the COBOL record and its fields to the table rows and its columns.

  7. Access a database.

    The database management system uses its own XFD as a pointer into its own data files, performs the requested I/O operation, and passes the results back to Database Connectors.

  8. Form COBOL records.

    Database Connectors translates the data fields into COBOL records or status codes, which are then passed back to the run time system via the ACUFH file handler.

    All of this communication is automatic, and all database queries and translations are performed behind the scenes, so that the end user experiences no interruption in program execution.

Parent topic: Database Connectors Tasks
Related information
CREATEXFD XFD directive
DEFAULT_HOST configuration variable
filename_HOST configuration variable
XFDs


To set the run time environment variables

After you have built a project, you need to set the environment variables to point to your ACUFH configuration file and to enable the dynamic redirection of the file handler. This example, uses a project directory of C:\DataConnectors\Test and a configuration file of mssql.cfg, meaning that you use Microsoft SQL Server for this exercise. To do this, follow the steps below:
  1. Close your Solution and exit Visual Studio.
  2. Open a Visual Studio command prompt and set the following variables:
    Variable | Value
    A_CONFIG | c:\DataConnectors\Test\mssql.cfg
    DYNREDIR | DYNCONFIG:EXPAND
    FHREDIR | c:\DataConnectors\Test\fhredir.cfg
Parent topic: Database Connectors Tasks


To set the system parameters

Set the Oracle system parameter OPEN_CURSORS to indicate the total number of cursors you want to have. Look in Oracle's init.ora and initSID.ora, or any other database initialization files used at your site, and add or modify the line:

open_cursors = nnn

The number of cursors can be equal to the number of keys times the number of segments per key for each file. For example, if you have 5 files, each of which has 3 keys, and each key has 3 segments, you should set OPEN_CURSORS to a minimum of "45".

Note: Setting OPEN_CURSORS should be performed only by your system administrator or database administrator, because it affects all applications using the database.
Parent topic: Database Connectors Tasks


To set up the user environment

  1. Ensure that your execution path contains the name of the directory in which you placed the run time executable that includes Database Connectors for DB2.
  2. Set the A_DB2_LOGIN and A_DB2_PASSWD variables, either in your environment or in the ACUFH configuration file.

    Also, consider whether or not setting the USER_PATH variable would be useful in your setup situation. For security reasons, it is best to set the password variable from your COBOL program by asking the user to enter a password and then executing:

    SET ENVIRONMENT "A_DB2_PASSWD" TO user-entry
  3. You may want to make and use a personalized copy of the ACUFH configuration file to avoid impacting other users. You could use the A_CONFIG environment variable to identify a personal ACUFH configuration file.
  4. Define any other ACUFH configuration file variables you require for your unique environment.

    Possible variables define error map file location, locking method, commit count, commit timing, and BINARY/CHAR type conversion.

Parent topic: Database Connectors Tasks
Related information
A_DB2_LOGIN configuration variable
A_DB2_PASSWD configuration variable
ACUFH Configuration File Variables
Run-time Configuration


To start the demo program

Be sure the RDBMS data source is available and that all the non-Database Connectors™ environment variables required for your data source are set. To run the demo program, notify your COBOL development run time system that are interfacing to an RDBMS driver. You accomplish this by adding the following line to your ACUFH configuration file. (For information about the ACUFH configuration file, see the chapter Run-time Configuration.)

DEFAULT_HOST RDBMS_NAME

If you're running demo.cbl from the same directory in which you placed the XFD, you are ready to run. If the XFD (orderfile.xfd, created when you compiled the demo program) is in another directory, add the following line to the ACUFH configuration file:

XFD_PREFIX dir-containing-dictionary

Set any environment variables required for your specific RDBMS. For information on this, see the section Designating the Host Data Source or Designating the Host File System in the appendix specific to your particular RDBMS.

Run the demo program as usual.

The following screen appears:

The demo program lets you add, view, or change any of the rows (records) in the orders table. You can also view the source code for the demo program. When executed, the program creates an empty orderfile table in your target database. You may then add records to the newly created table.

The available menu options are:

First | View the first record in the file
Prev | View the previous record in the sequence
Next | View the next record in the sequence
Last | View the last record in the file
Delete | Remove the order that is being displayed from the database
Search | Enter the order number of the order to be viewed
Add | Resets the record to its initial state and increments the order number, putting you into edit mode with the new data
Edit | Allows you to add a record or modify the currently displayed record in the file
Help | Displays a short description of the demo program
Quit | Quit the demo program
Parent topic: Database Connectors Tasks
Related information
Run-time Configuration


To use the WHERE constraint from COBOL

The following steps are required for using the WHERE constraint.

  1. Declare an External Variable

    To make use of WHERE constraints from COBOL, the application must declare an external variable for communication with the Database Connectors interface. This variable is declared as follows:

    77  a4gl-where-constraint  pic x(300) external
  2. Modify Your COBOL Procedures

    Your COBOL application should move the information that you want added to the WHERE clause to the new external variable before a COBOL positioning operation such as START or READ is performed. The additional constraint is then applied to any SQL read query performed on that file until a new positioning operation is performed.

    The additional query information is also stored in the Connector's cursor cache, so that if the same read conditions occur in later processing, the existing closed cursor can be reused with new bind variables instead of being regenerated.

    Be sure to fill the external variable before a positioning operation (START or READ). The WHERE constraint affects only READ NEXT operations preceded by a positioning operation. The WHERE constraint does not affect a READ NEXT that was not preceded by a positioning operation (such as a READ NEXT without a START immediately after opening a file).

Example

In your COBOL program you include this statement:

Move "ftest_key > 3 and ftest_key < 6" to
   A4GL_WHERE_CONSTRAINT.
Inspect A4GL_WHERE_CONSTRAINT replacing trailing spaces by
   low-values.
START FTEST-FILE KEY NOT LESS FTEST-KEY.

These results occur:

CURSOR 0:
SELECT *,ROWID FROM ftest WHERE (ftest_key1_seg1 = ? AND
ftest_key1_seg2 >= ?) AND (ftest_key > 3 and ftest_key < 6)
ORDER BY ftest_key1_seg1 ASC, ftest_key1_seg2 ASC;
CURSOR 1:
SELECT *,ROWID FROM ftest WHERE (ftest_key1_seg1 > ?) AND
(ftest_key > 3 and ftest_key < 6) ORDER BY ftest_key1_seg1 ASC,
ftest_key1_seg2 ASC;

Limitations

  • WHERE constraints added by the COBOL program may not be portable between databases.
  • The application may specify conditions of such complexity that they confuse the database query optimizer, resulting in poor performance. Be sure to examine the results of the optimizer trace facilities to ensure optimal performance.
  • Verify the COBOL application is not sending information that results in a syntax error that is not detected until run time.
  • The WHERE constraint should reference only columns in the primary table.
  • If users have different configurations at different sites, so that some files can be vision files at one site, but Acu4GL tables at another site, then the WHERE-CONSTRAINT can be difficult to use. This happens because after the WHERE-CONSTRAINT is used, it is marked empty so it won't be used again. However, if a file is a vision file, the WHERE-CONSTRAINT is not used, and might be used for the next file. For example: At site 1, files AA and AB are both SQL Server tables. At site 2, file AA is a vision file, and AB is a SQL Server table. If the COBOL program sets a WHERE-CONSTRAINT that would work with file AA, then at site 2, that WHERE-CONSTRAINT will instead be used for file AB, which will fail.
Parent topic: Database Connectors Tasks


Database Connectors Reference

  • Configuration Variables
    Use the following variables to configure Database Connectors.
  • Error Messages
  • Stored Procedures
    The following stored procedures are available for use with Database Connectors.
  • XFD Directives
    The following are XFD directives for Database Connectors.
  • Compiler Directives Affecting XFD Creation
    The following are compiler directives that directly affect XFD creation.
Parent topic: Micro Focus Database Connectors Version 2.0 for Windows


Configuration Variables

  • A_MSSQL_CURSOR_OPTION_1,2,3 configuration variables
  • A_MSSQL_LIMIT_DROPDOWN
  • A_MSSQL_NO_CACHED_READ
  • A_MSSQL_NO_RECORD_LOCKS configuration variable
  • A_MSSQL_SEPARATE_LOCK_CONN
  • A_MSSQL_UNLOCK_ON_EXECUTE configuration variable
  • A_MSSQL_USE_DROPDOWN_QUERIES configuration variable
  • DEFAULT_HOST configuration variable
  • FILE_TRACE configuration variable
  • filename_HOST configuration variable
  • XFD_DIRECTORY configuration variable
  • XFD_MAP configuration variable
  • XFD_MAP_RESETS configuration variable
  • XFD_PREFIX configuration variable
Parent topic: Database Connectors Reference


4GL_2000_CUTOFF configuration variable

This variable implements "date windowing" for Database Connectors. It determines the two-digit years considered to be in the twentieth century and the two-digit years considered to be in the twenty-first century.

This variable accepts a two-digit value. Two-digit years that are smaller than this value are considered part of the twenty-first century ("2000" is added to these dates).

Two-digit years that are equal to or larger than this value are considered to be in the twentieth century ("1900" is added to them).

The default value for 4GL_2000_CUTOFF is 20.

Related information
4GL_8_DIGIT_CUTOFF configuration variable


4GL_8_DIGIT_CUTOFF configuration variable

This variable determines whether to use the 4GL_2000_CUTOFF variable for dates that do not use a format string and that are 8 digits. Setting this variable to 1 causes Database Connectors to apply the 4GL_2000_CUTOFF logic for 8-character-long dates. The default value is 0 (off, false, no). This variable can also take values of 1 (on, true, yes).

Related information
4GL_2000_CUTOFF configuration variable


4GL_COLUMN_CASE configuration variable

This configuration variable causes Database Connectors to leave the case of the field names found in the XFD unchanged. Normally, all field names are converted to lower case by the Connector (except for Oracle, which converts all values to upper case), and all hyphens are converted to underscores.

Valid values are:

UNCHANGED | All field names are used unchanged when the database table is created. Be aware that hyphens are not converted to underscores in this situation. Most databases do not accept hyphens in column names, so the XFD must be modified by hand to replace hyphens with underscores
LOWER (default) | Field names are converted to lower case and hyphens are converted to underscores


4GL_COMMIT_COUNT configuration variable

The 4GL_COMMIT_COUNT variable sets the conditions used to issue an automatic COMMIT-WORK operation. Valid values are:

0 (Default) | The run time system tracks the number of logical locks that are currently in effect. When the number of logical locks reaches zero, the run time system assumes that a transaction is complete and issues a COMMIT statement
n | When set to a nonzero value, the run time system tracks the number of WRITE, REWRITE, and DELETE operations, until the value of 4GL_COMMIT_COUNT is reached, at which time the run time system issues a COMMIT statement. The READ, START, and READ NEXT operations do not count toward this total, because the run time system is tracking data-altering operations rather than logical record locks. The disadvantage of this method is that when a COMMIT is issued, any record locks held by the run time system are released
-1 | No commit is issued by Database Connectors

When 4GL_COMMIT_COUNT is set to -1, the following alternate methods to perform a commit or rollback are available:

  • Call your database query tool with COMMIT WORK or ROLLBACK WORK
  • Use the COBOL verbs COMMIT and ROLLBACK, available in the Compiler

4GL_COMMIT_COUNT is set to -1 automatically when you use the transaction management facilities available in the compiler. A COMMIT WORK is, however, issued on exit from the run time system (for example, on execution of a STOP RUN).

Examples

4GL_COMMIT_COUNT 0

A commit is issued when no locks are held, either because all files that had locked records are closed, or because a COBOL COMMIT verb has been issued. This is the default value.

Note that some data sources lose the current row when a COMMIT or ROLLBACK is executed. For these data sources, setting 4GL_COMMIT_COUNT to 0 can slow performance.

4GL_COMMIT_COUNT n

A commit is issued after n operations. WRITE, REWRITE, and DELETE count towards n; READ, START, and READ NEXT do not.

4GL_COMMIT_COUNT  -1

No commit is issued by Database Connectors. When 4GL_COMMIT_COUNT is set to -1, the only way to perform a commit or rollback is to use the COBOL verbs COMMIT and ROLLBACK.

4GL_COMMIT_COUNT is set to -1 internally when you use the transaction management facilities available in your COBOL development system.

A COMMIT is issued on exit from the run time system (for example, on execution of a STOP RUN).

Note:
  • 4GL_COMMIT_COUNT can be set in the ACUFH configuration file only
  • 4GL_COMMIT_COUNT is available only in the Database Connectors for DB2 interface


4GL_CONVERT_DATE_ZERO configuration variable

If your data uses dates as part of database keys, some database dates cannot be written as NULL or illegal values. To write data that includes NULL or illegal values, the Connector converts the NULL or illegal date values used in keys to a value of 01/01/01 when writing data to some databases. Unfortunately, the code would not make a similar conversion when reading the same record, and those records written with 01/01/01 were not found. This could easily result in writing a record that cannot be read or deleted. When 4GL_CONVERT_DATE_ZERO is set to the default setting CONVERTED, the Connector locates and returns those records written using the date 01/01/01. This functionality can be disabled by setting the variable to UNCHANGED.


4GL_DB_MAP configuration variable

This configuration variable lets you set one map at a time, by using FILE-PREFIX as a list of directories, each of which maps to a different database. Note that in this case "database" refers to "collection of tables" rather than distinguishing between, say, DB2 and Microsoft SQL Server.

The syntax of the value of 4GL_DB_MAP is:

directory = database

where directory is matched against the file specification, and database is used when a directory matches. For example, if you have two databases, data01 and data02, and have COBOL programs written that reference data files in /home/dataA and /home/dataB, you can set 4GL_DB_MAP as follows:

4GL-DB-MAP /home/dataA = data01
4GL-DB-MAP /home/dataB = data02

When the run time attempts to open a file with a directory specification of /home/dataA, the Connector uses the table in database data01.

By setting this variable to blank, all maps are reset to nothing, so no mapping is performed.

Currently, this feature is available with the Database Connector™ for Microsoft SQL Server interface. Any special instructions are included in the section describing support.

The 4GL_USEDIR_LEVEL variable determines how many levels of directory information to use as part of a table name. 4GL_DB_MAP interacts with 4GL_USEDIR_LEVEL, in the following way:

  • 4GL_DB_MAP is tested first, to determine which database to search for the table
  • Then 4GL_USEDIR_LEVEL is used to change the final name of the table
Related information
4GL_USEDIR_LEVEL configuration variable


4GL_EXTRA_DB_COLS_OK configuration variable

4GL_EXTRA_DB_COLS_OK allows the database table to have more columns than the COBOL program's corresponding file descriptor.

If the 4GL_EXTRA_DB_COLS_OK variable is set to True (on, yes), its default value, the number of columns in the database table do not have to match up with the number of fields in the COBOL program that is accessing the table. The database table can have more columns than the COBOL program references; however, the COBOL program may not have more fields than the database table.

Ensure that these extra columns are set correctly when new rows are added to the table. This is database-dependent. For example, under some databases, the columns should either have a default value or should allow NULL. Ensuring that the column value is set is important because the SQL generated by the Database Connectors interface does not reference the extra columns when inserting rows. This ACUFH configuration file can also take values of False (off, no).

Note: Only Database Connectors for Microsoft SQL Server supports this variable.


4GL_FULL_DATA_TEST configuration variable

The ACUFH configuration file variable 4GL_FULL_DATA_TEST lets you specify whether an entire field is tested for illegal data or if only the first byte is tested. The default value is False (0, off, no), meaning that only the first byte of data is tested. However, if set to True (1, on, yes), the entire field is tested for illegal data.


4GL_IGNORED_SUFFIX_LIST configuration variable

This variable is a space-delimited list of case-independent suffixes to ignore when opening Microsoft SQL Server tables or DB2 tables.

The standard syntax for MSSQL tables is

server.database.owner.table

with a dot (".") as the separator. This syntax causes the filename idx1.dat to be interpreted as "the table dat owned by the user idx1." By setting this variable (which must be set in the ACUFH configuration file, and cannot be set via SET ENVIRONMENT), the Connector ignores the listed suffixes.

There can be up to 10 ignored suffixes (more than that are not kept internally, and are ignored.) The default value for this variable is dat.

Example

4GL_IGNORED_SUFFIX_LIST dat idx txt


4GL_ILLEGAL_DATA configuration variable

4GL_ILLEGAL_DATA determines how COBOL data considered illegal by the database is converted before being stored in the database.

The default value is NULL. This causes all illegal data (except key fields) to be converted to null before it is stored.

The value CONVERTED causes the following conversions to occur:

Illegal LOW-VALUES | Minimum possible value (0 or 99999...) Minimum possible date value (01/01/01)
Illegal HIGH-VALUES | Maximum possible value (99999...) Maximum possible date value (database dependent)
Illegal SPACES | Zero (or 01/01/01 for a date field)

Illegal data in key fields is always converted, regardless of the value of this variable.


4GL_JULIAN_BASE_DATE configuration variable

This variable sets the base date to be used for Julian date calculations. It is used in conjunction with the DATE XFD directive.

To define your own base date for Julian dates, set this variable to a date having the format YYYYMMDD.

The default value is set internally at 01/01/4713 BC. (Dates other than the default must be greater than 01/02/4713 BC.)

For example, suppose your COBOL program uses dates in the form of the number of days since 12/31/1899. If you want to store these dates in a database accessed by Database Connectors, you can set your DATE XFD directives to be $XFD DATE=JJJJJJ (make sure that the number of characters matches your date field). Then you should set the configuration variable 4GL_JULIAN_BASE_DATE to 18991231.

If you are using the run time intrinsic functions that work with Julian dates, set 4GL_JULIAN_BASE_DATE to December 31, 1600 using the Gregorian calendar.

Related information
DATE directive


4GL_USEDIR_LEVEL configuration variable

This variable provides a method of mapping filenames (with directory information) to table names. 4GL_USEDIR_LEVEL lets you use files of the same name, which would normally go into separate directories, as separate names in a single database. This variable determines how many levels of directory information to use as part of the table name.

  • If set to the default value of 0, all directory information is removed from the filename before it is used as a table name
  • When set to negative values, nothing is done differently
  • When set to a positive value, the number determines how much directory information to keep

For example, given the file /home/data1/gl/master.dat, the following values result in the given table name:

4GL-USEDIR-LEVEL | Final resolved name
0 | master.dat
1 | glmaster.dat
2 | data1glmaster.dat
3 or larger | homedata1glmaster.dat

This variable has an upper limit of 127 characters and is currently available with the Database Connectors for Microsoft SQL Server interface. Any special instructions are included in the section describing support.

The 4GL_DB_MAP configuration variable enables you to set one map at a time. 4GL_USEDIR_LEVEL interacts with 4GL_DB_MAP as follows.

  • 4GL_DB_MAP is tested first, to determine which database to search for the table
  • Then 4GL_USEDIR_LEVEL is used to change the final name of the table
Related information
4GL_DB_MAP configuration variable


4GL_WHERE_CONSTRAINT configuration variable

4GL_WHERE_CONSTRAINT lets you override any value given in the external variable A4GL-WHERE-CONSTRAINT. This ACUFH configuration file variable can have a value with any length (limited only by machine memory). If a value is set in 4GL_WHERE_CONSTRAINT, any value in the external variable is ignored. For information on the external variable, see the section The WHERE Constraint in the chapter Performance and Troubleshooting.

Related information
The WHERE Constraint


A_MSSQL_ADD_IDENTITY configuration variable

When set to the default of On (true, yes), A_MSSQL_ADD_IDENTITY adds an extra column to any table created by Database Connectors for MSSQL. The extra column includes the identity property and is included on all indexes that are not unique. Otherwise, when A_MSSQL_ADD_IDENTITY is set to False (false, no), no extra column is added.

Note: The COBOL FD should not include the identity column.

Example

A_MSSQL_ADD_IDENTITY TRUE

On keys that allow duplicates, this variable has been found to vastly improve performance. Note that the default value is True for a file that allows duplicates and is False for a file with no duplicate keys.


A_MSSQL_ADD_TIMESTAMP configuration variable

Using a timestamp column is the only way to absolutely ensure that modifications made to a row are not overwriting someone else's changes. When it's reading a table that is open for I/O,Database Connectors for MssQL uses BROWSE MODE if a timestamp column exists. When Database Connectors is creating a table, if the value of A_MSSQL_ADD_TIMESTAMP is TRUE, a timestamp column is included in the table. (Note that your COBOL FD should not include the timestamp column.) While the default value is Off (false, no), this variable can also take values of On (true, yes).

Note: Microsoft discourages the use of BROWSE MODE on Select statements because of performance reasons. Therefore, unless it is absolutely necessary, do not set this variable to On.

Example

A_MSSQL_ADD_TIMESTAMP  1
Note: If you do not use this option, be prepared for REWRITE statements to fail with an error stating that someone else has modified the row. Because of the AcuLocks1 tables, this can happen only from non-COBOL applications. For information about AcuLocks1 tables, see the section Table Locking.
Related information
Table Locking


A_MSSQL_APPROLE_NAME configuration variable

This variable, in conjunction with A_MSSQL_APPROLE_PASSWD, allows Database Connectors to use approles. Before connecting to a database, set A_MSSQL_APPROLE_NAME to the name of a role. Note that you must also set A_MSSQL_APPROLE_PASSWD to a password for that role. By using these two variables, you set the run time to use this approle.

For more information on approles, please see the Microsoft SQL Server documentation.

Related information
A_MSSQL_APPROLE_PASSWD configuration variable


A_MSSQL_APPROLE_PASSWD configuration variable

This variable, in conjunction with A_MSSQL_APPROLE_NAME, enables use of approles. Before connecting to a database, set A_MSSQL_APPROLE_NAME to the name of a role. Then set A_MSSQL_APPROLE_PASSWD to a password for that role. By using these two variables, you set the run time to use this approle.

For more information on approles, please see the Microsoft SQL Server documentation.

Related information
A_MSSQL_APPROLE_NAME configuration variable


A_MSSQL_CURSOR_OPTION_1,2,3 configuration variables

A_MSSQL_CURSOR_OPTION_1
A_MSSQL_CURSOR_OPTION_2
A_MSSQL_CURSOR_OPTION_3

These ACUFH configuration file variables allow you to fine-tune the declaration of cursors. In general, cursors are declared with the following syntax:

DECLARE cursor_name option_1 CURSOR option_2 FOR
  <select....> option_3

In other words, different phrases can go in each of the option_X places. Also, different versions of Microsoft SQL Server allow different options in each of those places. Because of this, Database Connectors allows customization of the cursor declaration via these three variables. The values of these variables are placed verbatim into the declare phrase when building a cursor. Note that any errors in the values of these variables may cause Database Connectors to be inoperable. Be sure to read the Microsoft SQL Server documentation to determine what phrases are allowed in each case.

The default values are as follows (the limit is 65 characters for each option):

OPTION_1: | "SCROLL"
OPTION_2: | blank
OPTION_3: | "For read only"
Note: This variable was added because of an issue in SQL Server 6.5 and SQL Server 7.0 that would return incorrect results if this phrase was not used.
Parent topic: Configuration Variables


A_MSSQL_DATABASE configuration variable

A_MSSQL_DATABASE specifies the name of the particular database to be accessed. You cannot open any database files until you have set this variable.

Example

A_MSSQL_DATABASE stores

indicates the "stores" database is to be accessed.


A_MSSQL_DEADLOCK_LOOPS configuration variable

Use A_MSSQL_DEADLOCK_LOOPS if user typically open a number of tables at the same time. This configuration variable can be used to instruct Database Connectors to re-execute an INSERT statement that could not execute because a row in the AcuOpen1Tables table was locked, or to return an error if the user chooses not to run the query again.

Valid values are:

0 (the default) | Returns an error 1205 indicating that a table is locked
A positive numeric value. | Re-executes by the number specified by the query that caused the deadlock. Note that it can be as long as 10 seconds until SQL Server detects the deadlock, and the application appears to stop responding while the repeated attempts to re-execute the query are in progress.
-1 or MESSAGE Displays a message box containing the text of the SQL Server error message and the option to rerun the query.
SQL Server has returned an error
(text of message from SQL Server)
Do you want to retry the operation?

If the user answers Yes, the interface reruns the query; if the user answers No, the interface returns an error.

Setting A_MSSQL_DEADLOCK_LOOPS to -1 or MESSAGE is the preferred action; the time it takes to inform users of the problem allows other connections to finish opening the tables, giving the AcuOpenTables1 table time to remove the deadlock. For information about AcuOpenTables1 table, see the section Table Locking.

Related information
Table Locking


A_MSSQL_DEFAULT_CONNECTION configuration variable

A_MSSQL_DEFAULT_CONNECTION specifies the name of the server to which the run time system connects. If A_MSSQL_DEFAULT_CONNECTION is set, the server is named localhost. To reference tables in another server, open the file servername.database.owner.table.

Example

Suppose you have two servers, one named TOM and one named HARRY. If most of the tables you want to access are on the server HARRY, you should set:

A_MSSQL_DEFAULT_CONNECTION  HARRY

For those occasions when you want to access the TOM server, you could open the file this way:

TOM.stores.johndoe.purch1


A_MSSQL_DEFAULT_OWNER configuration variable

In Microsoft SQL Server, tables are named database.user.tablename. The value of A_MSSQL_DEFAULT_OWNER specifies the name of the user. If this variable is set, it must match the owner of a table. Tables are referenced as owner.table, where owner is the value of A_MSSQL_DEFAULT_OWNER. If this variable is set to a value for which owner.table does not exist, the interface fails to access the table.

Note that newly created tables are owned by the users who create them, not the owner named in A_MSSQL_DEFAULT_OWNER. The default value of this variable is blank, causing the interface to call an internal stored procedure to determine the actual owner of the table. Note also that we discourage multiple tables with the same tablename in a single database.


A_MSSQL_FAST_ACCESS configuration variable

A_MSSQL_FAST_ACCESS is set from your COBOL program. Files opened while this variable is set to a nonzero value are optimized for forward sequential access.

This option improves the READ NEXT performance in some cases. For example, benchmark testing yielded the following results for the READ AND SKIP operation:

No FAST_ACCESS: | 72.76 seconds
FAST_ACCESS, ROWCOUNT 0: | 148.88 seconds
FAST_ACCESS, ROWCOUNT 10: | 8.09 seconds

(10 is the perfect value for ROWCOUNT in this benchmark, because the program does a START, 10 READ NEXT operations, and then does it again.)

For certain reporting programs, this option can dramatically improve performance. However, please note the following restrictions:

  • Files must be open INPUT or open IO with MASS-UPDATE. FAST_ACCESS boosts performance only when no locking is required. In files that allow locking, a record must be reread after being locked; this prevents an uninterrupted forward sequential traversal.
  • Files opened with FAST_ACCESS use a dedicated connection for reading from the file. Since connections are memory-intensive (both on the client, and on the server), the number of files opened with FAST_ACCESS should be kept to a minimum. In the event that opening a connection fails, the file open continues, but FAST_ACCESS mode is disabled, with the following message appearing in the trace file:
    FAST_ACCESS mode not available.

    Also, a new connection technically uses a new concurrent Microsoft SQL Server license from Microsoft.

  • Files opened with FAST_ACCESS do not participate in transactions and may even cause the run time system to stop responding if transactions are used, especially if the FAST_ACCESS file is updated within the transaction. If you use transactions, do not use FAST_ACCESS. If you use transactions, use FAST_ACCESS only for files open INPUT.
  • Files opened with FAST_ACCESS cannot be read backwards. In other words, READ PREVIOUS does not work with FAST_ACCESS files. If you try to READ PREVIOUS on a file opened with FAST_ACCESS, an error 9/83 with a secondary code of 20 occurs.
  • The ANSI standard states that READ NEXT after a READ returns the next record. Some applications depend on this, and some applications just want to read dynamically from a file, and don't use the positioning facility. Because of this ambiguity, files that are opened with FAST_ACCESS cannot be READ dynamically. If you try to READ on a file opened with FAST_ACCESS, an error 9/83 with a secondary code of 20 occurs.

There are no restrictions on WRITE, REWRITE, and DELETE. However, these operations use the cursor-based connection, not the dedicated connection. For this reason, transactions may stop responding.

While the default value is 0 (off, false, no), this variable can also take values of On (true, yes).


A_MSSQL_LIMIT_DROPDOWN

This configuration option is closely related to A_MSSQL_USE_DROPDOWN_QUERIES.

When a sequence of START and READ NEXT/PREVIOUS operations are performed by an application, Database Connectors/MSSQL generates a sequence of queries to return the set of records matching the application's request. To improve performance, the interface generates a sequence of "drop down" queries based upon the key of reference's key segments going from the most specific subset using the most number of segments to the most general using the least number of segments. This functionality is turned on by setting the configuration variable A_MSSQL_USE_DROPDOWN_QUERIES to TRUE.

For example if a key is described by:

    03 MY-ALTKEY.
       05 MY-ALTKEY-SEG1        PIC X(2).
       05 MY-ALTKEY-SEG2        PIC X(2).
       05 MY-ALTKEY-SEG3        PIC X(2).

Then a START followed by a sequence of READ NEXT operations might generate the selection criteria of:

WHERE MY-ALTKEY-SEG1 = :w0 AND MY-ALTKEY-SEG2 = :w1 AND
MY-ALTKEY-SEG3 >= :w3
WHERE MY-ALTKEY-SEG1 = :w0 AND MY-ALTKEY-SEG2 > :w1
WHERE MY-ALTKEY-SEG1 > :w0

This can improve performance because the target for each query is kept to a minimal size. If a set of records is not required, the database does not need to spend the time building the working set. When a "DROP DOWN" does occur however, the subsequent working set can require a large amount of time to process because of the potential magnitude of records. Normally there is not a way for a COBOL application to instruct the interface to stop processing when it has finished with the records based on a given key segment.

To address this, use A_MSSQL_LIMIT_DROPDOWN configuration variable.

This variable allows an application to direct the interface not to perform "drop down" query generation and instead return "end of file" when the records matching the current query have been exhausted.

This variable may be set to one of the following options:

OFF | This is the current default. The interface performs "drop down" queries.
PARTIAL | If the record positioning was performed by a START with a SIZE clause such that the initial positioning was performed using fewer than the total number of columns in the key, the process stops after all records matching the START columns have been exhausted.
FULL | If the record positioning was performed by a START without a SIZE clause, the process stops after all records matching the START columns have been exhausted.
ALL | Regardless of what form of START was used for the initial positioning, the process stops after all records matching the START columns have been exhausted.

This variable is performed at the time of each start, so the application may change its value.

Parent topic: Configuration Variables
Related information
A MSSQL USE DROPDOWN QUERIES configuration variable


A_MSSQL_LOCK_DB configuration variable

A_MSSQL_LOCK_DB specifies the name of the database that holds the lock table. For information about AcuLocks1 tables, see the section Table Locking.

Related information
Table Locking


A_MSSQL_LOGIN configuration variable

A_MSSQL_LOGIN indicates the user name under which you want to connect to the database system.

Example

To connect to the database with the user name MYNAME, specify A_MSSQL_LOGIN MYNAME in the ACUFH configuration file.

See the A_MSSQL_NT_AUTHENTICATION configuration variable for an alternate method to log onto the server. See the section Setting Up a User Account in the chapter ACUFH configuration file for Microsoft SQL Server for more information.

Related information
A_MSSQL_PASSWD configuration variable
A MSSQL NT AUTHENTICATION configuration variable
Setting Up a User Account


A_MSSQL_MAX_CHARACTERS configuration variable

A_MSSQL_MAX_CHARACTERS indicates the maximum number of bytes the Database Connectors allows in a table row.

Microsoft SQL Server places a limit on the number of bytes per table row. Database Connectors adheres to this limit, but sometimes it cannot accurately count how many bytes a particular row contains (because of overhead bytes that Microsoft SQL Server adds). This variable enables the developer to set Database Connectors upper bound.

You might want to try reducing this value if a table cannot be created. By reducing the upper bound, you may be able to prevent this problem.

If Microsoft SQL Server increases the maximum number of bytes allowed in a row (in a future release of the product), you can increase the value of this variable to take advantage of the new limit.

The A_MSSQL_MAX_CHARACTERS variable has a default value of 8060.


A_MSSQL_MAX_COLUMNS configuration variable

A_MSSQL_MAX_COLUMNS indicates the maximum number of columns Database Connectors allows in a table. The default value is 1024.

Microsoft SQL Server places a limit on the number of columns per table. Database Connectors adheres to this limit, but sometimes it cannot accurately count how many columns a table contains (because a column has been added to a table without Database Connectors knowledge). This variable enables the developer to set Database Connectors upper bound. You might want to try reducing the upper bound if you discover that a table cannot be created. By reducing the upper bound, you allow for uncountable columns and thus may be able to prevent this problem.

If Microsoft SQL Server increases the maximum number of columns allowed per table (in a future release of the product), you could increase the value of this variable to take advantage of the new limit. Consult your Microsoft SQL Server documentation to decide the new maximum number of columns allowed per table.


A_MSSQL_NATIVE_LOCK_TIMEOUT configuration variable

This is one of two locking methods available with Database Connectors for MSSQL. The methods are accessed via the A_MSSQL_NATIVE_LOCK_TIMEOUT configuration variable. If A_MSSQL_NATIVE_LOCK_TIMEOUT is set to a positive value, native locking is used. Otherwise, the AcuLocks1 table is used to hold locks.

This locking method enables you to use Microsoft SQL Server native locks if you explicitly code transactions in your COBOL program. You can access this method by setting A_MSSQL_NATIVE_LOCK_TIMEOUT to a positive value. This value is the number of seconds that a connection waits for a timeout to occur. When such a timeout occurs, Database Connectors assumes that the timeout is caused by a locked record, and returns error 99 (record locked). If you set this variable but do not explicitly code transactions in your COBOL program, record locking does not occur. Note that Database Connectors waits the number of seconds specified, and your application may appear to stop responding if the timeout is too long. On the other hand, if the timeout is too short, you may get record locked errors when the network is slow.

Microsoft SQL Server uses a page-locking mechanism, and so this method of locking records may cause your application to return spurious record locked errors caused by a record being locked on the same page as the record you are trying to access. Microsoft SQL Server 7.0 uses row-level locking, but because of the timing issue, using this option is not recommended.

Note: Even with this variable set, the interface still needs the AcuOpenTables1 table. For information about AcuOpenTables1, see the section Table Locking.
Related information
Table Locking


A_MSSQL_NO_23_ON_START configuration variable

When A_MSSQL_NO_23_ON_START is set to TRUE, START does not detect whether records matching the search criteria actually exist. Because it does not detect the existence of records, it is possible, when using this variable, to do a START without error, and for the next READ NEXT to return END_OF_FILE, contrary to the ANSI standard. The default value is FALSE.

Example

A_MSSQL_NO_23_ON_START TRUE


A_MSSQL_NO_CACHED_READ

By default, the Database Connectors for MSSQL run time applies the same READ logic on a previously-read record as is used for the Vision indexed file system. Instead of sending another request to MSSQL to read the same record, the run time gets the record from cache. This behavior is referred to as Cached Read and can improve performance.

A_MSSQL_NO_CACHED_READ controls this behavior. By default cached read is enabled. It can be disabled by setting A_MSSQL_NO_CACHED_READ to true or 1.

If the last operation was a successful READ with LOCK and the next operation is a READ with LOCK on the same key with the same key value then the cached record returneds without accessing the database. A trace file entry is made that says cached read.

Parent topic: Configuration Variables


A_MSSQL_NO_COUNT_CHECK configuration variable

When performing a REWRITE, the interface checks to see that a record was actually updated. If not, it returns an error 23. Setting this variable to ON disables that check. This improve REWRITE performance, at the risk of missing an error. While the default value is Off (false, no), this variable can also take the value of On (true, yes).


A_MSSQL_NO_DBID configuration variable

The interface stores the Database ID in the AcuLocks1 and AcuOpenTables1 tables, to distinguish different tables in different databases. Sometimes this causes problems. Setting this variable to On causes the interface to use a Database ID of 0, instead of the actual ID of the database. While the default value is Off (false, no), this variable can also take the value of On (true, yes).

For information about AcuLocks1 and AcuOpenTables1, see the section Table Locking.

Related information
Table Locking


A_MSSQL_NO_RECORD_LOCKS configuration variable

Setting this variable ON causes all READS to be treated as READ NO LOCK, which can improve performance (but has the obvious consequences). While the default value is Off (false, no), this variable can also take the value of On (true, yes).

Parent topic: Configuration Variables


A_MSSQL_NO_TABLE_LOCKS configuration variable

Setting this variable to On means the interface does not use the AcuOpenTables1 table, which causes all table locking to be disabled. This can improve performance on OPEN and CLOSE statements. While the default value is Off (false, no), this variable can also take the value of On (true, yes).

For information about AcuOpenTables1, see the section Table Locking.

Related information
Table Locking


A_MSSQL_NT_AUTHENTICATION configuration variable

The A_MSSQL_NT_AUTHENTICATION configuration variable indicates whether Microsoft SQL Server authenticates users based on their Windows login.

If this variable is set to True (on, yes), Database Connectors for MSSQL interface attempts to log users on using the Microsoft SQL Server Windows NT authentication mode. (See your SQL Server documentation for information about this authentication mode.) When A_MSSQL_NT_AUTHENTICATION is enabled, the A_MSSQL_LOGIN and A_MSSQL_PASSWD configuration variables are no longer needed or used. (They are still available if you are not using Windows NT authentication mode.) If you have not set up Microsoft SQL Server itself to allow this type of authentication, setting this variable to TRUE causes all login attempts to fail. See your Microsoft SQL Server documentation for information on how to set up this type of authentication.

The default is False (off, no), indicating that Database Connectors does not use Windows NT authentication mode when logging users on and continues to use login and password authentication.

Related information
A_MSSQL_LOGIN configuration variable
A_MSSQL_PASSWD configuration variable


A_MSSQL_PACKETSIZE configuration variable

The A_MSSQL_PACKETSIZE configuration variable sets the size of network packets. Setting this variable can affect performance, since fewer and larger network calls can improve performance.

This variable must be set in the ACUFH configuration file and has no effect if set in a COBOL program via SET CONFIGURATION or SET ENVIRONMENT. The value of this variable is the largest size that the transport layer uses for network packets (although the underlying library may reduce the size specified; this is out of the control of the interface.) The largest value that can be specified is 32767. The default depends on which version of the client libraries are linked into the run time system, although 512 is the most common default.

Use this variable to tune your database performance. To set the packet size to 8192 use:

A_MSSQL_PACKETSIZE   8192

Setting this variable to 0 or to a negative value causes Database Connectors to use the default value.


A_MSSQL_PASSWD configuration variable

The variable A_MSSQL_PASSWD should be set to the password assigned to the database account associated with the user name specified by A_MSSQL_LOGIN.

Examples

If the account with the user name in A_MSSQL_LOGIN has the associated password CW021535, specify:

A_MSSQL_PASSWD  CW021535

in the ACUFH configuration file.

For better security, you can accept a password from the user during program execution; set the A_MSSQL_PASSWD variable based on the response:

ACCEPT RESPONSE NO-ECHO.
SET ENVIRONMENT "A_MSSQL_PASSWD" TO RESPONSE.
Note: If the user has been set up without a password, this variable need not be set.
Related information
A_MSSQL_LOGIN configuration variable


A_MSSQL_ROWCOUNT configuration variable

This variable has an effect only if you are reading on a key that does not allow duplicates, or if you have added an Identity column to the table. A_MSSQL_ROWCOUNT determines how many rows are returned by a SELECT statement sent to the server.

This variable can be used to speed up the Connector. For example, if only reading one record at a time, and reading from a unique key, you can set A_MSSQL_ROWCOUNT to 1, thus speeding up the processing.

If you know you are going to be reading records ten rows at a time, set A_MSSQL_ROWCOUNT to 10. If you don't have any information about how many rows are going to be requested, set this variable to 0, which is the default.

Note: Setting this variable to a non-optional value can actually degrade performance, since the interface may be forced to issue more SELECT statements once the rowcount has been determined. Use caution when setting this variable.
Related information
A_MSSQL_ADD_IDENTITY configuration variable


A_MSSQL_SELECT_KEY_ONLY configuration variable

This variable directs the interface to select key columns only when searching for records. Its use can improve READ performance on large tables with many rows.

When set to True (on, yes), the default value, A_MSSQL_SELECT_KEY_ONLY causes the interface to select only key columns when searching for records, and then select the entire row of the single record that must be returned to the COBOL program. This improves performance on large tables with many rows.

Setting A_MSSQL_SELECT_KEY_ONLY to False (off, no) does not affect how the select is created for files open I/O (since the record must be locked and then the rest of the data fetched), but causes the interface to select all the columns of the table for files open INPUT.


A_MSSQL_SEPARATE_LOCK_CONN

When set to TRUE, this variable causes the Database Connectors for MSSQL interface to open two connections to any server it connects to. One of those connections performs all the normal COBOL data work (write, rewrite, read next, etc). Any transactions started affect this first connection.

The second connection does all the internal work needed by the interface to do its normal work, such as updating the lock tables, testing for locks, etc. This connection always remains outside of any transactions, allowing the interface to always handle the internals correctly.

The reason for the configuration variable is that a separate connection to SQL Server requires a separate license from Microsoft.

If you are not experiencing transaction difficulties with table or record locks, then keep this variable set to the default value of FALSE. On the other hand, if you are experiencing frequent deadlocks during record locking or opening of tables, you may be able to solve those by setting this variable to TRUE.

Parent topic: Configuration Variables


A_MSSQL_SKIP_ALTERNATE_KEYS configuration variable

A_MSSQL_SKIP_ALTERNATE_KEYS determines whether alternate keys are used to form indexes during table creation. The default value of this variable is 0, which allows alternate keys. This configuration variable can also take values of 1 (on, true, yes).

If you set this variable to a nonzero value (such as 1), alternate keys are not used to form indexes, which speeds up processing if many writes or rewrites are being performed. (Note that a value of 1 may slow processing if the application is reading sequentially using an alternate key.)


A_MSSQL_TRANSLATE_TO_ANSI configuration variable

Setting this variable to True (on, yes) causes Database Connectors to call the same translation function used by the Windows run time to translate characters going to the server into the OEM character set, and to translate characters coming from the server to ANSI.

The default is False (off, no), which indicates that Database Connectors does not call the translation function, but passes the data as is to the library.


A_MSSQL_UNLOCK_ON_EXECUTE configuration variable

Setting this variable to True (on, yes) causes all invocations of I$IO using the EXECUTE opcode to unlock all records. Normally, records are unlocked when a transaction finishes. But if users perform their own transaction management, the interface never knows to unlock records, because it does not check the text sent to the database to see if it is associated with a transaction. The default value is Off (false, no).

Parent topic: Configuration Variables


A_MSSQL_USE_DROPDOWN_QUERIES configuration variable

Setting A_MSSQL_USE_DROPDOWN_QUERIES to TRUE causes selects sent to the database to be of the drop-down variety, instead of a single large query.

For example, if you have a file with three fields in the primary key, (keyseg1, keyseg2, keyseg3), and your COBOL program does a START, the following query is sent to the database:

select (columns) from (table) where
((keyseg1 = value1 and keyseg2 = value2 and
keyseg3 > value3) or (keyseg1 = value1 and
keyseg2 > value2) or (keyseg1 > value1))
order by keyseg1, keyseg2, keyseg3

If you use drop-down queries, the following collection of queries is sent instead:

select (columns) from (table) where (keyseg1
= value1 and keyseg2 = value2 and keyseg3 >
value3) order by keyseg1, keyseg2, keyseg3

followed by:

select (columns) from (table) where (keyseg1
= value1 and keyseg2 > value2) order by
keyseg1, keyseg2, keyseg3

and:

select (columns) from (table) where (keyseg1
> value1) order by keyseg1, keyseg2, keyseg3

There are advantages and disadvantages to each method. If you use the A4GL_WHERE_CONSTRAINT variable, you should probably set A_MSSQL_USE_DROPDOWN_QUERIES to FALSE, because the WHERE constraint limits the result set sufficiently that the larger query is more efficient. For additional information, see the section The WHERE Constraint in the chapter Performance and Troubleshooting.

If you usually START files and read to the end, you should set A_MSSQL_USE_DROPDOWN_QUERIES to FALSE, because a fewer number of queries need to be sent to the database. On the other hand, if you START files and stop reading after some condition, but have not used the WHERE constraint, you may get more efficient access by setting this variable to TRUE and using the drop-down style of query. In either case, run some tests to see which value makes the most sense for your application.

This variable is accessed only during a positioning operation, so you can set it at different times for different tables.

The default value is FALSE.

Example

A_MSSQL_USE_DROPDOWN_QUERIES TRUE
Parent topic: Configuration Variables
Related information
The WHERE Constraint


DEFAULT_HOST configuration variable

If you are opening an existing file, most file systems linked into the run time system are searched for the named file. If, however, you are creating a new file, you must tell the run time system which file system to use. You accomplish this with the following ACUFH configuration file variable:

DEFAULT_HOST filesystem

This variable designates the file system used for newly created files that are not individually assigned. If this variable is not given a value, the EXTFH file system is used.

Examples

DEFAULT_HOST DB2

means that all new files are be DB2 files unless individually assigned to another file system.

DEFAULT_HOST ORACLE

means that all new files are be Oracle files unless individually assigned to another file system.

Parent topic: Configuration Variables


FILE_TRACE configuration variable

This variable allows you to start file tracing without opening the debugger. Set this variable to a non-zero value to save information about all file OPENs, READs, and WRITES in the error file. The default is 0.

Parent topic: Configuration Variables


filename_HOST configuration variable

The filename_HOST variable can be used to assign a newly-created file to a file system. This ACUFH configuration file variable is used to assign an individual data file to a file system. Any file so assigned uses the designated file system, and not the one specified by DEFAULT_HOST.

Substitute the base name of the file for filename. The name you substitute should not include any directory names and should not include a file extension.

Example

For example, if the file CUSTFILE were the only file you wanted to assign to the DB2 file system, and all other files were to be Oracle files, you could specify:

DEFAULT_HOST  DB2
CUSTFILE_HOST  ORACLE

in the ACUFH configuration file.

The DEFAULT_HOST variable specifies the file system to be used for all files not specified by filename_HOST.

You can use DEFAULT_HOST and filename_HOST in combination to assign your new files in a default with exceptions manner. For example, the following directives:

DEFAULT_HOST DB2
afile_HOST ORACLE
bfile_HOST ORACLE

mean that all new files except afile and bfile is be assigned to DB2, and those two files are assigned to Oracle.

Now suppose myfile1a and myfile1b both reside in mydb1, and myfile2a and myfile2b both reside in mydb2. With the following XFD directives:

DEFAULT_HOST DB2
a-oracle-database mydb1
myfile1a-HOST oracle
myfile1b-HOST oracle
myfile2a mydb2.dbo.myfile2a
myfile2b mydb2.dbo.myfile2b
mydb2-HOST oracle

the run time system uses the Oracle interface for myfile1a, myfile1b, myfile2a, and myfile2b and finds all the tables in the correct database. When the COBOL program opens myfile2a, the run time system translates that name to mydb2.dbo. myfile2a looks at the basename to determine the file system to use (mydb2). It then looks for mydb2-HOST to determine which file system to send the file requests to.

Parent topic: Configuration Variables
Related information
DEFAULT_HOST configuration variable


XFD_DIRECTORY configuration variable

XFD_DIRECTORY tells the run time system the name of the directory that contains the XFD files built by the compiler. The default value is the current directory.

Example

To tell the run time system that the XFDs are stored in the directory /usr/inventory/dictionaries, enter the following:

xfd–directory   /usr/inventory/dictionaries
Note: This variable is ignored if you have specified a search path for XFD files using the XFD_PREFIX configuration variable. XFD_PREFIX extends the functionality of XFD_DIRECTORY.

For information about the directive that tells the compiler where to put the XFDs, see the CREATEXFD directive. Unless you have moved the XFD files, you should use the same value in XFD_PREFIX (or for XFD_DIRECTORY) that you used with the CREATEXFD directive.

Parent topic: Configuration Variables
Related information
XFD_PREFIX configuration variable
CREATEXFD directive


XFD_MAP configuration variable

XFD_MAP tells the run time system to associate certain filenames with a particular XFD. This enables you to use one XFD for many different files. You can use XFD_MAP to add or replace the existing value, depending on the setting of the XFD_MAPS_RESETS configuration variable.

The XFD_MAP variable has this syntax:

XFD_MAP   [pattern = base-xfd-name]  ...

where pattern consists of any valid filename characters and may include "*" or "?". These two characters have special meanings in the pattern:

* | matches any number of characters
? | matches a single occurrence of any character

For example:

CUST???? | matches CUST0001 and CUSTOMER; does not match CUST001 or CUST00001
CUST* | matches all of the above
CUST*1 | matches CUST001 and CUST0001 and CUST00001; does not match CUSTOMER
*OMER | matches CUSTOMER; does not match CUST001 or CUST0001

Note that XFD_MAP cannot be read from the ACCEPT FROM ENVIRONMENT statement.

Parent topic: Configuration Variables
Related information
XFD_MAP_RESETS configuration variable


XFD_MAP_RESETS configuration variable

This ACUFH configuration file variable determines whether setting the XFD_MAP adds to or replaces the existing value.

Valid values are:

Value | Effect when setting the ACUFH configuration file variable
"0" (off, false, no) | Adds new value patterns to the end of the existing value
"1" (on, true, yes) the default | Replaces the existing value with a new value

This variable may be useful if you need to include multiple XFD_MAP lines in an ACUFH configuration file and want to avoid setting and resetting the variable. When multiple lines exist, all patterns are used in the order they are listed.

Parent topic: Configuration Variables
Related information
XFD_MAP configuration variable


XFD_PREFIX configuration variable

When this ACUFH configuration file variable is assigned a value, it is used to locate the XFD file, and the variable XFD_DIRECTORY is ignored. XFD_PREFIX enables you to define a specific series of directories to search for XFD files, rather than indicating only one. The run time system searches each directory in the order specified until an XFD file matching the name of the desired file is found and then assumes that is the correct file.

Therefore, when using the XFD_PREFIX variable, be aware that the run time system:

  • Searches each named directory and not its subdirectories
  • Stops searching once a matching file name is found, even if other files of the same name are located in a different directory later in the series
  • Does not validate that the file specifications (such as key or record size parameters) of the XFD file match those in the COBOL program. Be sure the correct file you want to use is in the path specified

You can specify a directory path that contains embedded spaces if you surround the path with quotation marks. You separate entries using a semi-colon (;). For example:

XFD_PREFIX C:\"Sales Data";C:\Customers

You can specify up to 4096 characters for this variable.

Note: The default for XFD_PREFIX is empty. If this variable is set to any other value, the XFD_DIRECTORY (in which you specify only one directory) is ignored.
Parent topic: Configuration Variables
Related information
XFD_DIRECTORY configuration variable


Error Messages

All non-standard file status errors returned by Database Connectors are of the form 9/83, with a secondary error that can be determined by examining the external variable f-int-errno, or by calling C$RERR. The secondary errors that can be returned include the following.

  • Run Time - File Status Errors
  • Compiler Errors
Parent topic: Database Connectors Reference


Run Time - File Status Errors

  • 01 Read error on dictionary file
  • 02 Corrupt dictionary file
  • 04 Open error
  • 04 Too many fields in the key
  • 05 (no message associated with this error)
  • 05 Too many fields in the key (more than 16 for Oracle)
  • 11 Net Express stored procedures not found
  • 12 A column of a key is of data type TEXT or IMAGE, which is illegal
  • 12 DB2 library function returned an unexpected error
  • 13 Illegal size or type of data for variable xxx
  • 13 Internal error
  • 14 More than one table with the same name
  • 16 Trying to rename a table across databases
  • 17 Cache error
  • 18 Primary Key error
  • 09/19 Table Size Error
  • 20 (no message associated with this error)
  • 21 (no message associated with this error)
  • 1001 Invalid Cursor
  • 22007 Invalid Character value for Cast Specification
Parent topic: Error Messages


01 Read error on dictionary file

An error occurred while reading the XFD file; this probably means the XFD is corrupt.

Resolution:

Recompile with the CREATEXFD directive to re-create the XFD.

Parent topic: Run Time - File Status Errors
Related information
CREATEXFD directive


02 Corrupt dictionary file

The XFD file for one of your COBOL files is corrupt and cannot be read.

Resolution:

Recompile with the CREATEXFD directive to re-create the XFD.

Parent topic: Run Time - File Status Errors
Related information
CREATEXFD directive


04 Open error

There was an error attempting to open the XFD file.

Resolution:

Recompile with the CREATEXFD directive to re-create the XFD.

Parent topic: Run Time - File Status Errors
Related information
CREATEXFD directive


04 Too many fields in the key

There are more than 16 fields in a key.

Resolution:

Check your key definitions and restructure the key that is illegal, then recompile with the CREATEXFD directive.

Parent topic: Run Time - File Status Errors
Related information
CREATEXFD directive


05 (no message associated with this error)

A date given to the Database Connectors interface is invalid and cannot be converted.

Parent topic: Run Time - File Status Errors


05 Too many fields in the key (more than 16 for Oracle)

There are more than 16 fields in a key.

Resolution:

Check your key definitions and restructure the key that is illegal, then recompile with the CREATEXFD directive.

Parent topic: Run Time - File Status Errors
Related information
CREATEXFD directive


11 Net Express stored procedures not found

The installation of Database Connector for Microsoft SQL Server creates a number of stored procedures and tables. At least one of these was not found.

Parent topic: Run Time - File Status Errors


12 A column of a key is of data type TEXT or IMAGE, which is illegal

Columns that are part of an index may not be of type TEXT or type IMAGE.

Resolution:

Check your key definition.

Parent topic: Run Time - File Status Errors


12 DB2 library function returned an unexpected error

One of the DB2 library functions returned an error that was not expected.

Parent topic: Run Time - File Status Errors


13 Illegal size or type of data for variable xxx

An elementary data item in your FD was larger than 255 bytes, or there is no DB2 type that matches the current data type.

Parent topic: Run Time - File Status Errors


13 Internal error

Multiple records were found with the same index (this is a Microsoft SQL Server error).

Parent topic: Run Time - File Status Errors


14 More than one table with the same name

When tables were listed, more than one table was found with the same name.

Resolution:

Consider whether or not setting the USER_PATH ACUFH configuration variable resolves the issue. This variable enables tables with identical names, but with different ownership (located in a different schema) to be found and accessed.

Parent topic: Run Time - File Status Errors


16 Trying to rename a table across databases

RENAME works only within the same database.

Parent topic: Run Time - File Status Errors


17 Cache error

(Internal error) The internal process cache has been corrupted.

Resolution:

Contact Micro Focus Product Support.

Parent topic: Run Time - File Status Errors


18 Primary Key error

An error occurred when creating the primary key for a secondary table.

Parent topic: Run Time - File Status Errors


09/19 Table Size Error

The table is larger than Microsoft SQL Server accepts, either in the number of columns or in the number of bytes in the row.

Resolution:

Use the SECONDARY_TABLE XFD directive to get around this.

Parent topic: Run Time - File Status Errors
Related information
SECONDARY_TABLE directive


20 (no message associated with this error)

This error tells you that you are trying to do something with a FAST_ACCESS table that is not allowed.

Resolution:

The description of the ACUFH configuration variable in the section A_MSSQL_FAST_ACCESS details the restrictions for tables opened this way.

Parent topic: Run Time - File Status Errors
Related information
A_MSSQL_FAST_ACCESS configuration variable


21 (no message associated with this error)

There was a problem accessing one or more files, and processing of this request cannot continue. The tertiary error is an error code returned from the COBOL file system.

Parent topic: Run Time - File Status Errors


1001 Invalid Cursor

The prepare portion is aged out of cache.

Resolution:

Re-enter the code while invalidating the prepare portion.

Parent topic: Run Time - File Status Errors


22007 Invalid Character value for Cast Specification

The error sub-code 22007 indicates that an attempt was made to write non-numeric data into a numeric field (database column).
Parent topic: Run Time - File Status Errors


Compiler Errors

  • Bad picture for DATE: keyname
    The PICTURE must be six or eight bytes in length, either alphanumeric or numeric with no sign.
  • Data missing from key segment keyname
    This error occurs when some part of the named key cannot be placed in the XFD; the XFD cannot be generated in this situation.
  • Directive word too long: keyname
    With one exception, the words contained in an XFD directive, including field names, cannot exceed 30 characters. The value of a WHEN XFD directive may consist of up to 50 characters.
  • Field xxx causes duplicate database data
  • GROUP expected after USE
    The USE GROUP XFD directive must include both words.
  • Missing '=' in XFD directive
    The NAME XFD directive requires an equal ("=") sign. The WHEN XFD directive requires a comparison operator.
  • Missing field name after WHEN
    A valid field name, or the word "OTHER", must be specified with the WHEN XFD directive.
  • Net Express lock table missing
    The installation of Database Connector™ for Microsoft SQL Server creates a number of stored procedures and tables. At least one of these was not found.
  • Value should be a literal: xxx
    This error occurs when the item to the right of an "=" should be a literal, and it isn't. The xxx in the message is the value found. A literal is either a quoted string or a numeric integer.
  • Value should be a name: xxx
    This error occurs when the item to the right of an "=" should be a name, and it isn't. For example, it would be an error to use a quoted string with the NAME XFD directive: $XFD NAME=some text. The xxx in the message is the value found.
  • Value should be numeric: xxx
    This error occurs when the item to the right of an "=" should be numeric and it isn't. The xxx in the message is the value found.
  • Variable file name requires FILE directive
    This message occurs when the Compiler cannot assign a name to the .xfd file, because the ASSIGN phrase for the file names a variable file name.
  • WHEN variable xxx not found in record
    This happens if you have a WHEN XFD directive that mentions a variable that doesn't exist in the record.
  • xxx not unique in first 30 characters
  • xxx: unknown XFD directive
    The Compiler did not recognize the XFD directive you used. The xxx is the XFD directive found.
Parent topic: Error Messages


Bad picture for DATE: keyname

Parent topic: Compiler Errors


Data missing from key segment keyname

This usually occurs because of filler. For example:

01  my-record.
    03  my-key.
        05  filler            pic xx.
        05  field-1           pic xx.

If my-key is declared as a record key, this error occurs because the area of the key described by filler is not included in the XFD.

Resolution:

To correct this error, ensure that every character that is part of the key is included in some field that is part of the XFD. Use an XFD to give a field name to each filler, to ensure that fillers are included:

 01  my-record.
     03  my-key.
$xfd name=myfiller
         05   filler            pic xx.
         05   field-1           pic xx.
Parent topic: Compiler Errors


Directive word too long: keyname

Parent topic: Compiler Errors
Related information
WHEN directive


Field xxx causes duplicate database data

The warning informs you of a special database situation that is not advisable. The XFD builds and the interface operates correctly.

This warning means that your record definition should be restructured. Your current definition is set up in such a way that:

  1. You have overlapping key fields, and
  2. Both keys must be represented in the database as separate items.

Database Connectors handles this situation by keeping the overlapping keys updated simultaneously, so that they always have the same value. However, the warning alerts you that you have the same data represented twice in the database. This is dangerous, because someone at the site might access the database via SQL and accidentally change only one of the keys.

Here's an example of the problem and a description of how to correct it (the example assumes that both key-1and key-2 have been declared as keys):

01  order–record.
    03  key–1.
        05  field–a                  pic x(5).
        05  field–b                  pic 9(5).
        05  key–2
            redefines field–b        pic x(3).

This example generates the warning message.

Because key-2 is a key, it must also be represented in the database. It doesn't correspond exactly to any other data field, so it must be entered as a separate column in the database.

In the COBOL view of the file, key-1and key-2 overlap. But the requirements of database storage force the same data (known to COBOL as field-b) to be physically represented twice in the database. Any updates to the data from any COBOL program correctly updates both columns. Updates from outside of this COBOL program carry no such guarantee.

Resolution

In this example, you can correct the situation by breaking field-b into two columns, so that key-2 corresponds exactly to another data field:

01  order–record.
    03  key–1.
        05  field–a                        pic x(5).
        05  field–b.
            07  field-b1                   pic x(3).
            07  field-b2                   pic 9(2).
        05  key–2
            redefines field–b              pic x(3).
Parent topic: Compiler Errors
Related information
CREATEXFD directive


GROUP expected after USE

Parent topic: Compiler Errors
Related information
USE GROUP directive


Missing '=' in XFD directive

Parent topic: Compiler Errors
Related information
NAME directive
WHEN directive


Missing field name after WHEN

Parent topic: Compiler Errors
Related information
WHEN directive


Net Express lock table missing

Parent topic: Compiler Errors


Value should be a literal: xxx

Parent topic: Compiler Errors


Value should be a name: xxx

Parent topic: Compiler Errors


Value should be numeric: xxx

Parent topic: Compiler Errors


Variable file name requires FILE directive

Resolution:

In this case, you must use a FILE XDF directive to name the .xfd file.

Parent topic: Compiler Errors
Related information
FILE directive


WHEN variable xxx not found in record

Parent topic: Compiler Errors
Related information
WHEN directive


xxx not unique in first 30 characters

This message occurs if a field name is not unique within the first 30 characters. The xxx is the name found.

Resolution:

You can either change the field name or apply the NAME XFD directive.

Parent topic: Compiler Errors
Related information
NAME XFD directive


xxx: unknown XFD directive

Resolution:

Check for a typographical error.

Parent topic: Compiler Errors


Stored Procedures

  • sp_AcuInit stored procedure
  • sp_AcuRemoveUnusedLocks_1 stored procedure
  • sp_AcuTableReport_1 stored procedure
  • sp_AcuUserCount_1 stored procedure
  • sp_AcuZeroUserCount_1 stored procedure
  • tablename_delete stored procedure
  • tablename_insert stored procedure
  • tablename_read stored procedure
  • tablename_startnnn stored procedure
  • tablename_update stored procedure
Parent topic: Database Connectors Reference


sp_AcuInit stored procedure

If the stored procedure sp_AcuInit exists, it is executed when the connection is made to the server. This is a procedure you can set up to do customized initialization. This stored procedure does not take any parameters and does not return any results. This optional stored procedure is executed for all connections by Database Connectors interface to the database, not just for the primary connection.

As an example of customized initialization, you can use this stored procedure to remove stale locks by calling sp_AcuRemoveUnusedLocks_1 (which is installed when all the other stored procedures are installed), or to limit access to the database by certain users during certain hours.

If sp_AcuInit returns an error, the connection is denied and the error is reported to the COBOL program. The method for returning an error is to execute the Transact-SQL statement "raiserror". See your Microsoft SQL Server documentation for information about Transact-SQL and stored procedures.

If the sp_AcuInit procedure exists, it executes whenever Database Connectors makes a new database connection, including FAST_ACCESS connections. Therefore, any customization that you've indicated via sp_AcuInit applies to all connections a transaction makes to the database, not just the primary connection.

Note: The sp_AcuInit procedure executes at connection time. It can exist in any database, but should reside either in the current database or a database in which stored procedures are searched by default (such as master).
Parent topic: Stored Procedures
Related information
sp_AcuRemoveUnusedLocks_1 stored procedure


sp_AcuRemoveUnusedLocks_1 stored procedure

Use this stored procedure to determine who is logged in and to remove Process IDs that are no longer active on the system. You can call this from sp_AcuInit each time a user connects to the database to ensure that the lock table contains only active locks. This stored procedure must reside in the same database as the AcuOpenTables1 and AcuLocks1 tables; it is placed there automatically when these tables are created during installation.

Parent topic: Stored Procedures
Related information
sp_AcuInit_1 stored procedure
Table Locking


sp_AcuTableReport_1 stored procedure

Use this stored procedure to learn who is using the tables in the database at the time this procedure is run. Run this procedure before running the sp_AcuZeroUserCount stored procedure, so that you can contact users to inform them that the database will be closing. This stored procedure must reside in the same database as the AcuOpenTables1 and AcuLocks1 tables; it is placed there automatically when these tables are created during installation.

Parent topic: Stored Procedures
Related information
sp_AcuZeroUserCount_1 stored procedure
Table Locking


sp_AcuUserCount_1 stored procedure

You can run sp_AcuUserCount from the query analyzer to learn how many users have a particular table open. You can use this to track table and database activity to ensure that your database is running as efficiently as possible. This stored procedure must reside in the same database as the AcuOpenTables1 and AcuLocks1 tables; it is placed there automatically when these tables are created during installation.

Parent topic: Stored Procedures
Related information
Table Locking


sp_AcuZeroUserCount_1 stored procedure

Use sp_AcuZeroUserCount to remove all locks on a table and close it. Be sure to run this stored procedure on all tables in the database if shutting down the database for any reason. This stored procedure must reside in the same database as the AcuOpenTables1 and AcuLocks1 tables; it is placed there automatically when these tables are created during installation.

Parent topic: Stored Procedures
Related information
Table Locking


tablename_delete stored procedure

tablename_delete is used to DELETE a record from an XFD file. The parameters passed to the stored procedure are the values of the primary key, in the order they are listed in the XFD.

Based on the Sample XFD, you might want to create the following stored procedure for deleting records from a file:

create procedure ftestdat_delete
@ft2_key char(4)
as
delete from ftestdat where ftest2_key = @ft2_key

grant execute on ftestdat_delete to public
Parent topic: Stored Procedures
Related information
tablename_insert stored procedure
Developer- or Site-supplied Stored Procedures
tablename_startnnn stored procedure
tablename_update stored procedure
tablename_read stored procedure


tablename_insert stored procedure

tablename_insert is used to WRITE a record to the file. The parameters passed to the stored procedure are the values of all the columns in the row, in the order of the columns in the database. The timestamp column and identity column (if present in the table) are not passed to the stored procedure.

Given the Sample XFD, you might want to create the following stored procedure for writing records to a file:

create procedure ftestdat_insert
@ft2_key char(4),
@ft2_key1_seg1 char(2),
@ft2_key1_seg2 char(2),
@ft2_altkey2 char(4),
@ft2_number char(9),
@ft2_info char(10)
as
insert into ftestdat (ftest2_key, ftest2_key1_seg1,
ftest2_key1_seg2, ftest2_altkey2, ftest2_number,
ftest2_info) values (@ft2_key, @ft2_key1_seg1,
@ft2_key1_seg2, @ft2_altkey2, @ft2_number, @ft2_info)
grant execute on ftestdat_insert to public
Parent topic: Stored Procedures
Related information
Developer- or Site-supplied Stored Procedures
tablename_startnnn stored procedure
tablename_update stored procedure
tablename_read stored procedure
tablename_delete stored procedure


tablename_read stored procedure

tablename_read is used to read a random record (READ only, not READ NEXT or READ PREVIOUS). The parameters passed to the stored procedure are the values of the primary key, in the order they are listed in the XFD. The expected rowset is the columns in the first table (if secondary tables are used), or the columns of the table (if secondary tables are not necessary).

This stored procedure is very similar to tablename_start.

Parent topic: Stored Procedures
Related information
Developer- or Site-supplied Stored Procedures
tablename_insert stored procedure
tablename_startnnn stored procedure
tablename_update stored procedure
tablename_delete stored procedure


tablename_startnnn stored procedure

tablename_startnnn is used to START a file. The nnn value is the key number to start on, and is 0 filled. For example, the start procedure for the primary key for table mytab is "mytab_start000".

Note: If A_MSSQL_NO_23_ON_START is set to Yes, the start stored procedure is disabled.

Because there can be up to 119 alternate keys, the Connector does not search for a start procedure unless, or until, it is used. The parameters passed to the stored procedure are a 2-char mode [it is a varchar(2) field], with one of the following values: ">", ">=", "=", "<=", or "<". The rest of the parameters are the columns of the key used to start. Because the ANSI specification for START includes information about the size of the key being used (and in particular allows partial keys), the start procedure is used only if an entire key is given to the start verb. This procedure is also special in that it does not return data, but needs to raise an error condition if the start fails. The way to raise the error condition from within the stored procedure is to include code similar to the following:

raiserror 22006 "Record not found"

The code "22006" is very important. It is the code searched for in setting the error condition from within Database Connectors. If you use a different number, your starts may succeed when they should actually fail.

For example, based on the Sample XFD, you might want to create the following stored procedure to start a file:

create procedure ftestdat_start001
@mode varchar(2),
@ft2_key1_seg1 char(2),
@ft2_key1_seg2 char(2)
as

if exists (select 1 from ftestdat where

(ftest2_key1_seg1 = @ft2_key1_seg1 and
((@mode = ">=" and ftest2_key1_seg2 >=@ft2_key1_seg2) or
(@mode = ">" and ftest2_key1_seg2 > @ft2_key1_seg2) or
(@mode = "=" and ftest2_key1_seg2 = @ft2_key1_seg2) or
(@mode = "<" and ftest2_key1_seg2 < @ft2_key1_seg2) or
(@mode = "<=" and ftest2_key1_seg2 <= @ft2_key1_seg2))))
return
if exists (select 1 from ftestdat where
(((@mode = ">=" or @mode = ">") and
ftest2_key1_seg1 > @ft2_key1_seg1) or
((@mode = "<=" or @mode = "<") and
ftest2_key1_seg1 < @ft2_key1_seg1)))
return
raiserror 22006 "Record not found"

grant execute on ftestdat_start001 to public
Parent topic: Stored Procedures
Related information
A_MSSQL_NO_23_ON_START configuration variable
Developer- or Site-supplied Stored Procedures
tablename_insert stored procedure
tablename_update stored procedure
tablename_read stored procedure
tablename_delete stored procedure


tablename_update stored procedure

tablename_update is used to REWRITE a record from the file. The parameters passed to the stored procedure are the values of all the columns in the row, in the order of the columns in the database. The timestamp column and identity column (if present in the table) are not passed to the stored procedure.

For example, based on the Sample XFD, you might want to create the following stored procedure for rewriting a record:

create procedure ftestdat_update
@ft2_key char(4),
@ft2_key1_seg1 char(2),
@ft2_key1_seg2 char(2),
@ft2_altkey2 char(4),
@ft2_number char(9),
@ft2_info char(10)
as
update ftestdat set
ftest2_key = @ft2_key,
ftest2_key1_seg1 = @ft2_key1_seg1,
ftest2_key1_seg2 = @ft2_key1_seg2,
ftest2_altkey2 = @ft2_altkey2,
ftest2_number = @ft2_number,
ftest2_info = @ft2_info
where ftest2_key = @ft2_key

grant execute on ftestdat_update to public
Parent topic: Stored Procedures
Related information
Sample XFD
Developer- or Site-supplied Stored Procedures
tablename_insert stored procedure
tablename_startnnn stored procedure
tablename_read stored procedure
tablename_delete stored procedure


XFD Directives

  • ALPHA XFD directive
  • BINARY XFD directive
  • COBOL-TRIGGER XFD directive
  • COMMENT XFD directive
  • DATE XFD directive
  • FILE XFD directive
  • NAME XFD directive
  • NULL XFD Directive
  • NUMERIC XFD directive
  • SECONDARY_TABLE XFD directive
  • USE GROUP XFD directive
  • VAR_LENGTH XFD directive
  • WHEN XFD directive
  • XSL XFD directive
Parent topic: Database Connectors Reference


ALPHA XFD directive

The ALPHA XFD directive allows you to treat a data item as alphanumeric text in the database, when it is declared as numeric in the COBOL program.

Syntax

$XFD ALPHA

This is especially useful when you have numeric keys in which you occasionally store non-numeric data, such as LOW-VALUES or special codes. In this situation, treating the field as alphanumeric allows you to move any kind of data to it.

Example

Suppose you have specified KEY IS code-key. Then assume the following record definition:

01  code-record.
    03  code-key.
        05  code-num      pic 9(5).

In the database, group items are disregarded, so CODE-NUM is the actual key field. Suppose you needed to move a non-numeric value to the key:

MOVE "C0531" TO CODE-KEY.
WRITE CODE-RECORD.

In this case the results are not well-defined because a non-numeric value has been moved into a numeric field. The database might very well reject the record.

One way to solve this problem is to use the ALPHA XFD directive. This causes the corresponding database field to accept alphanumeric data:

 01  code-record.
     03  code-key.
$XFD ALPHA
         05  code-num      pic 9(5).

As an alternative, you could specify the USE GROUP XFD directive on the line before code-key. The USE GROUP XFD directive implies that the field is alphanumeric.

Parent topic: XFD Directives
Related information
USE GROUP directive


BINARY XFD directive

The BINARY XFD directive is used to specify that the data in the field could be alphanumeric data of any classification. Absolutely any data is allowed.

The BINARY XFD directive cannot be used in combination with the VAR_LENGTH XFD directive.

The method of storing fields declared as binary is database-specific. For example, Oracle uses the data type raw for the field.

Syntax

$XFD BINARY

Example

You might use this XFD directive when you need to store a key that contains LOW-VALUES; COBOL allows a numeric field to contain LOW or HIGH values, but these are invalid for a numeric field in the RDBMS:

 01  code-record.
     03  code-key.
         05  code-indic          pic x.
$XFD BINARY
         05  code-num            pic 9(5).
         05  code-suffix         pic x(3).
             .
             .
             .
 move low-values to code-num.
Parent topic: XFD Directives
Related information
VAR_LENGTH directive


COBOL-TRIGGER XFD directive

This XFD directive indicates that a COBOL trigger is to be executed.

Note: This XFD directive must come immediately before the file descriptor of the file for which the trigger is defined. It uses the standard XFD directive syntax.

Syntax

XFD COBOL-TRIGGER=program-name

The following three parameters are passed to the COBOL program:

01  OPCODE.
  88  READ-BEFORE       VALUE "r".
  88  READ-AFTER        VALUE "R".
  88  WRITE-BEFORE      VALUE "w".
  88  WRITE-AFTER       VALUE "W".
  88  REWRITE-BEFORE    VALUE "u".
  88  REWRITE-AFTER     VALUE "U".
  88  DELETE-BEFORE     VALUE "d".
  88  DELETE-AFTER      VALUE "D".

01  FILE-RECORD         PIC X(MAX-RECORD-SIZE).

01  ERROR-CODE          PIC 99.

In cases in which the record size is known, the actual record is passed [READ-AFTER (all), WRITE-BEFORE, WRITE-AFTER, REWRITE-BEFORE, REWRITE-AFTER].

In cases in which the record size is not known, the maximum record size is passed [READ-BEFORE (all), DELETE-BEFORE, DELETE-AFTER].

The contents of this field are identical to the record area given to the file operation. The BEFORE images have the value before the file operation, and the AFTER images have the value after the file operation.

Use the ERROR-CODE parameter to signal that an error occurred:

  • If you set this parameter in a BEFORE trigger, the file operation does not execute
  • If you set this parameter in an AFTER trigger, the run time system treats the file operation as an error, though in fact the file operation did execute. This means that, for sequential access (next or previous), the file position has changed and a subsequent next or previous act as if the prior file operation succeeded

Also, if you set an error in the REWRITE-AFTER or DELETE-AFTER, the record does not return to its prior state — the record is modified or deleted in the database. We suggest that you use transactions if this behavior is not acceptable.

Please note that if the COBOL program cannot be called (for any reason), it is treated as having succeeded.

Parent topic: XFD Directives


COMMENT XFD directive

The COMMENT XFD directive lets you include comments in an XFD file. Because the information is embedded in a comment, it doesn't interfere with processing by the interfaces. Each comment entered with this XFD directive appears in the XFD file with the symbol "#" in column one.

Syntax

$XFD COMMENT text
Parent topic: XFD Directives


DATE XFD directive

The DATE XFD directive is used to store a field in the database as a date. Because there's no COBOL syntax that identifies a field as a date, you may want to add this XFD directive to differentiate dates from other numbers, so that they enjoy the properties associated with dates in the RDBMS. To view special options for two-digit dates, see the description of the ACUFH configuration file variable 4GL_2000_CUTOFF.

Syntax

$XFD DATE=date-format-string

This XFD directive implies the NUMERIC XFD directive.

If no date-format-string is specified, six-digit (or six-character) fields are retrieved as YYMMDD from the database. Eight-digit fields are retrieved as YYYYMMDD.

The date-format-string is a description of the desired date format, composed of characters from the following list:

M | Month (01–12)
Y | Year (two or four digits)
D | Day of month (01–31)
J | Julian day (00000000–99999999)
E | Day of year (001–366)
H | Hour (00–23)
N | Minute
S | Second
T | Hundredths of a second

Any other characters cause the date format string to be invalid and result in a corrupt XFD error or a compile-time warning.

Each character in a date format string can be considered a place holder that represents the type of information stored at that location. The characters also determine how many digits are used for each type of data.

For example, although you would typically represent the month with two digits, if you specify "MMM" as part of your date format, the resulting date uses three digits for the month, left-zero-filling the value. If the month is given as "M", the resulting date uses a single digit and truncates on the left.

Julian Dates

Because the definition of Julian day varies, the DATE XFD directive offers a great deal of flexibility for representing Julian dates. Many source books define the Julian day as the day of the year, with January 1st being 001, January 2nd being 002, and so forth. If you want to use this definition for Julian day, simply use "EEE" (day of year) in your date formats.

Other reference books define the Julian day as the number of days since some specific base date in the past. This definition is represented in the DATE XFD directive with the letter "J" (for example, a six-digit date field would be preceded with the XFD directive $XFD DATE=JJJJJJ). The default base date for this form of Julian date is 12/31/4714 BC.

You may define your own base date for Julian date calculations by setting the ACUFH configuration file variable 4GL_JULIAN_BASE_DATE.

Handling Invalid Dates

Dates in the following range are considered valid:

01/01/0001 to 12/31/9999

If the interface considers a date valid and passes it to an RDBMS that considers it invalid, the results depend on the particular RDBMS. Some systems return an error code. Some store the date as NULL and do not return an error. Some store the date in an unpredictable fashion and do not return an error. We recommend that you determine the error handling procedures of the RDBMS in use.

If a COBOL program attempts to write a record containing a date that the Database Connectors knows is invalid, the Database Connectors inserts NULLs into the date field and writes the record.

If a COBOL program attempts to read into a record from a table with a NULL date field, zeroes are inserted into that field in the COBOL record.

For date fields having two-digit years, by default years 0 through 19 are inserted as 2000 through 2019, and years 20 through 99 are inserted as 1920 through 1999. You can change this behavior by changing the value of the variable 4GL_2000_CUTOFF.

Note:

If a field is used as part of a key, the field cannot be a NULL value. For information about converting date values using the 4GL_CONVERT_DATE_ZERO variable, see the topic 4GL_CONVERT_DATE_ZERO.

Using Group Items

You may place the DATE XFD directive in front of a group item, as long as you also use the USE GROUP XFD directive.

Examples

Example 1

 $xfd date
      03  date-hired    pic 9(8).
      03  pay-scale     pic x(3).

The column "date-hired" has eight digits is type DATE in the database, with a format of YYYYMMDD.

Example 2

$XFD DATE, USE GROUP
      03  date-hired.
          05  yyyy      pic 9(4).
          05  mm        pic 9(2).
          05  dd        pic 9(2).

This also produces a column named "date-hired" with eight digits and type DATE in the database, format YYYYMMDD.

Example 3

 $XFD DATE=EEEYYYY
      03  date-sold      pic 9(7).
      03  sales-rep      pic x(30).

This produces a column named "date-sold" with seven digits and type DATE in the database. The date contains the day of the year (for example, February 1st would be 032), followed by the four-digit year, such as 1999).

Parent topic: XFD Directives
Related information
4GL_2000_CUTOFF configuration variable
4GL_JULIAN_BASE_DATE configuration variable
4GL_CONVERT_DATE_ZERO configuration variable
NUMERIC directive
USE GROUP directive


FILE XFD directive

The FILE XFD directive supplies a starting name from which the XFD file name is formed. This XFD directive is required only when the file name in the COBOL code is nonspecific. For example, use this XFD directive when the SELECT for the file has a variable ASSIGN name (ASSIGN TO variable_name). In this case, the Connector cannot form a file name automatically, and you must provide a name. The starting name serves as the basis for the XFD name.

Syntax

$XFD FILE=name

This XFD directive must appear on the line immediately preceding the file's FD.

Example

Suppose your SELECT statement has a variable ASSIGN name such as the one shown here:

select my-file
assign to my-variable.

Then you would need to add the FILE XFD directive as shown here:

select my-file
 assign to my-variable.
    .
    .
    .
$xfd  file=payroll
 fd my-file
Parent topic: XFD Directives
Related information
XFD_MAP configuration variable


NAME XFD directive

The NAME XFD directive assigns a database field name to the field defined on the next line.

Syntax

$XFD NAME=fieldname

This XFD directive has several uses, as shown in the following examples.

Example 1 — Non-unique field names

Within a database file, all field names must be unique. (Multiple database tables may include the same field name, but duplicates may not exist within a single table.) Unique field names are not required in COBOL, because names can be qualified by group items.

For example, the following is acceptable in COBOL:

01  employee-record.
    03  date-hired.
        05  yy      pic 99.
        05  mm      pic 99.
        05  dd      pic 99.
    03  date-last-paid.
        05  yy      pic 99.
        05  mm      pic 99.
        05  dd      pic 99.

You need not change the field names in your COBOL program to access a database. Instead, you use the NAME XFD directive to provide unique database names for the fields. For example:

  01  employee-record.
      03  date-hired.
          05  yy      pic 99.
          05  mm      pic 99.
          05  dd      pic 99.
      03      date-last-paid.
 $xfd  name=year-paid
          05  yy      pic 99.
 $xfd  name=month-paid
          05  mm      pic 99.
 $xfd  name=day-paid
          05  dd      pic 99.

The dates portion of the resulting database table is as follows.

yy | mm | dd | year_paid | month_paid | day_paid
88 | 02 | 15 | 94 | 04 | 30

Example 2 — Names not unique within first 18 characters or longer than 18 characters

Some SQL-based databases require that names be unique within 18 characters, and some require that names be no longer than 18 characters. For those systems, the run time system truncates longer COBOL names after the first 18 characters.

For names that are identical within the first 18 characters, or are not meaningful if shortened to the first 18 characters, use the NAME XFD directive to assign them different database field names.

Suppose you had:

01  acme-employee-record.
    03  acme-employee-record-date-hired          pic x(6).
    03  acme-employee-record-date-last-paid      pic x(6).

You could add two NAME XFD directives to differentiate the two item names by making them meaningful within 18 characters:

  01  acme-employee-record.
 $xfd name=date-hired
      03  acme-employee-record-date-hired        pic x(6).
 $xfd name=date-last-paid
      03  acme-employee-record-date-last-paid    pic x(6).

Note that your COBOL names have not changed. The new names are used only for the database fields.

Each time you compile your program to create XFDs, any field names longer than 18 characters is checked for uniqueness within the first 18. If any field names are identical for the first 18 characters, a compiler warning message appears. A warning of this type does not prevent the program from compiling, and the XFD is generated.

Example 3 — Assigning shorter names

You may want to use the NAME XFD directive to assign shorter names than those used in your COBOL programs. This makes the formation of interactive SQL queries easier and quicker. For example:

 $XFD  NAME=EMPNO
      03  employee-number        pic x(8).

This XFD directive causes the XFD to map EMPLOYEE-NUMBER to EMPNO in the database.

Example 4 — Matching field names and COBOL FDs

If your database already exists, and a field name in the database does not match the name used in your COBOL FD, you can use a NAME XFD directive to associate the two names. For example:

 $xfd name=employee-no
      03  employee-number        pic x(8).

This XFD directive causes the XFD to map EMPLOYEE-NUMBER in the COBOL program to EMPLOYEE-NO in the database.

Example 5 — Renaming fields that begin with a numeric character

If your COBOL program uses field names that begin with a numeric character, use the NAME XFD directive to assign a different name for use with your database. SQL typically generates a syntax error when it encounters a column name that begins with a numeric character. For example:

    03  12-months-sales      pic 9(5)V99.

could be renamed this way:

 $xfd  name=twelve-months-sales
      03  12-months-sales    pic 9(5)V99.
Parent topic: XFD Directives
Related information
CREATEXFD XFD directive


NULL XFD Directive

The NULL XFD directive handles NULL values in numeric tables by comparing non-key field values when performing read and write actions on the database to determine and perform appropriate actions.

Syntax

$XFD NULL=literal
where literal is any literal value, or one of the following special literals to indicate that the field is comprised entirely of a specific type of value:
  • LOW-VALUES
  • HIGH-VALUES
  • SPACES
  • ZEROES

Specify the NULL XFD directive on individual numeric fields within the COBOL FD.

During a write to the database, this directive compares the value of the COBOL numeric field against its own set literal value. If the values are equal, it writes a NULL value to the database.

During a read of the database, if a NULL value is returned, this directive places its own set literal value into the COBOL numeric field before returning to the COBOL program.

Note: Fields allowing NULL values are not allowed as part of a record key. If the compiler encounters a record key containing NULL values, it returns a syntax error.
Parent topic: XFD Directives


NUMERIC XFD directive

The NUMERIC XFD directive allows you to treat a data item as an unsigned integer when it is declared as alphanumeric. You might use this when the data stored in the item is always numeric.

Syntax

$XFD NUMERIC

Example

$xfd numeric
 01  student-code      pic x(7).
Parent topic: XFD Directives


SECONDARY_TABLE XFD directive

Some Database Connectors interfaces (including MSSQL Server) permit subordinate tables. When this is the case, you can use the SECONDARY_TABLE XFD directive to indicate that the next data item may be placed into a subordinate table if more than one table is necessary to accommodate the data.

Up to 26 subordinate tables can be created from a single record description. Each table name is based on the original table name, with a letter from A to Z appended. For example, if the original table were named "my-table", subsequent subordinate tables would be given these names:

  • my-tableA
  • my-tableB
  • my-tableC
  • my-tableD

When the run time system accesses the XFD, it makes an initial pass through the data, taking all eligible data items for which the SECONDARY_TABLE XFD directive is not specified.

SECONDARY_TABLE is ignored for certain data items. These include:

  • Any field that is part of a key
  • Any field that is an indicator for a WHEN XFD directive

If the table size is not exceeded in the first pass, then, in a second pass, the run time system appends to the original table all items marked SECONDARY_TABLE that can be accommodated.

When the first table reaches a limit (either in total number of columns or total number of characters), that table is created, and a new table is begun. Items that did not fit into the previous table are placed into a subordinate table, in the order in which they are encountered.

The process repeats until all items have been accommodated.

It is permissible to place the SECONDARY_TABLE XFD directive just before a level 01 record definition. In this case, it applies to all fields underneath the level 01.

Syntax

$XFD SECONDARY_TABLE

Example

 $xfd secondary_table
  01  description      pic x(80).
Parent topic: XFD Directives
Related information
WHEN XFD directive


USE GROUP XFD directive

The USE GROUP XFD directive allows you to enter a group item into the database as a single field, instead of using the elements contained in the group. This is necessary if the item is stored in an existing database as a group, rather than as individual fields.

Combining fields of data into meaningful groups for database storage also improves I/O efficiency.

Syntax

$XFD USE GROUP

By default, the USE GROUP XFD directive implies that the consolidated field is alphanumeric. If you want a numeric field, simply add the word NUMERIC at the end of the XFD directive.

Example 1 – Combining DATE and USE GROUP XFD directives

For example, the XFD directive in the following code combines the functions of the USE GROUP and DATE XFD directives, and indicates that the date should be entered into the database as a single date-formatted data item instead of three distinct fields:

  $XFD  USE GROUP, DATE
       03  date-entered.
           05  yy      pic 99.
           05  mm      pic 99.
           05  dd      pic 99.

Either a comma or a space (or both) may separate the word "DATE" from the words "USE GROUP".

Example 2 – Forming larger units

Other fields with which you might use this XFD directive include multi-part account numbers or department numbers, or keys that are referenced as a unit but not by their individual pieces. Here's an example of an item that might be grouped:

 $xfd  use group
  01  gl-acct-no.
      03  main-acct     pic 9(4).
      03  sub-acct      pic 9(3).
      03  dept-no       pic 9(3).

If you are using an existing database in which certain fields are grouped, they must also be grouped in your COBOL file descriptor.

If the database does not yet exist, keep in mind that combining fields into groups can improve execution speed. Whether to group fields or not also depends on whether they are always stored and used together. Someone who really knows how the data is being used might help to identify groups of fields that can be combined to speed processing.

Parent topic: XFD Directives
Related information
DATE XFD directive
NUMERIC XFD directive


VAR_LENGTH XFD directive

By default, the Compiler generates fixed-length fields in the XFD. The VAR_LENGTH XFD directive requests that the data item that immediately follows the XFD directive be assigned a type that implies variable length, if possible. This can save considerable space in your database.

The VAR_LENGTH XFD directive cannot be used in combination with the BINARY XFD directive.

The precise variable type that is assigned to the data item depends on which RDBMS is in use. Possible variable types that might be assigned are VARCHAR and VARBINARY.

Syntax

$XFD VAR_LENGTH

Example

For example, the XFD directive in the following code indicates that the employee-name field should be entered into a DB2 database as a VARCHAR data item.

 $XFD  VAR_LENGTH
      03  employee-notes      pic x(300).
Parent topic: XFD Directives
Related information
BINARY XFD directive


WHEN XFD directive

The WHEN XFD directive is used when you want to include multiple record definitions or REDEFINES in a database table. It's typically used when you want to force certain columns to be built that wouldn't be built by default (because you want to use them from the RDBMS side). For more information, see the section "REDEFINES" in the chapter XFDs.

Recall that the key fields and the fields from the largest record are automatically included as explicit columns in the database table. All fields are stored and retrieved from the database, whether they appear as explicit columns or not. So you don't need to use WHEN unless you want to ensure that some additional fields are explicitly listed by name in the table. (For details about how fields are included in the database table, see the section "How XFDs Are Formed" in the chapter XFDs.)

WHEN declares that the field (or subordinate fields, if it is a group item) that immediately follow the XFD directive must appear as a column (or columns) in the database table. It also states one condition under which the columns are to be used. The WHEN XFD directive guarantees that the fields are explicitly included in the table, as long as they aren't FILLER and don't occupy the same area as key fields.

The WHEN XFD directive results in a table that unites all fields subordinate to the WHEN XFD directive. This table might include more columns and could affect performance and storage requirements.

Syntax

$XFD WHEN field = value     (equals)
$XFD WHEN field <= value    (is less than or equals)
$XFD WHEN field < value     (is less than)
$XFD WHEN field >= value    (is greater than or equals)
$XFD WHEN field > value     (is greater than)
$XFD WHEN field != value    (is not equal to)
$XFD WHEN field = OTHER

The value may be an explicit data value (in quotes). The word "OTHER" can be used only with "=". It means use the following field(s) only if the WHEN condition(s) listed at the level of this field are not met.

Note: WHEN values must be on individual lines as single values in the code. WHEN values cannot be combined.

For example:

     03 ar-code-type                  pic x.
$xfd when ar-code-type = "s"
     03 ship-code-record              pic x(4).
$xfd when ar-code-type = "b"
     03 backorder-code-record redefines ship-code-record.
$xfd when ar-code-type = other
     03 obsolete-code-record redefines ship-code-record.

OTHER may be used before one record definition, and may be used once at each level within each record definition.

Note: A WHEN XFD directive with condition OTHER must be used if there is a possibility that the data in the field does not meet any of the explicit conditions specified in the other WHEN XFD directives. If this is not done, results are undefined.

Example 1

01  ar-codes-record.
    03  ar-codes-key.
        05  ar-code-type                  pic x.
        05  ar-code-num                   pic 999.
01  ship-code-record.
    03  filler                            pic x(4).
    03  ship-instruct                     pic x(15).
01  terms-code-record.
    03  filler                            pic x(4).
    03  terms-rate-1                      pic s9v999.
    03  terms-days-1                      pic 9(3).
    03  terms-rate-2                      pic s9v999.
    03  terms-descript                    pic x(15).

If you add the WHEN XFD directive as shown below, it causes the fields from the SHIP-CODE-RECORD to be included in the database table, and determines when specific database columns are used. The underlined fields then appear as columns in the database table:

01  ar-codes-record.
     03  ar-codes-key.
         05  ar-code-type                  pic x.
         05  ar-code-num                   pic 999.
$xfd  when ar-code-type = "s"
 01  ship-code-record.
     03  filler                            pic x(4).
     03  ship-instruct                     pic x(15).
$xfd  when ar-code-type = "t"
 01  terms-code-record.
     03  filler                            pic x(4).
     03  terms-rate-1                      pic s9v999.
     03  terms-days-1                      pic 9(3).
     03  terms-rate-2                      pic s9v999.
     03  terms-descript                    pic x(15).

FILLER data items don't have unique names and are thus not used to form columns in the database table. You could use the NAME XFD directive to give them a name if you really need to see them in the database table.

Note: In this example, the FILLER data items implicitly redefine key fields. Thus, they would be disregarded even if you provided a name for them.

Example 2

In the following code, in which no WHEN XFD directives are used, the underlined fields are explicitly named in the database table. (Key fields have the suffix key in their names in this example.)

Note that REDEFINES records simply re-map the same data area and are not explicitly included in the database table by default:

01  archive-record.
    03  filler                         pic x(33).
    03  archive-code                   pic 9(6).
    03  archive-location               pic 9(2).
    03  filler                         pic x(10).
01  master-record.
    03  animal-id-key.
        05  patient-id                 pic 9(6).
        05  species-code-type          pic 9(5).
        05  species-name               pic x(6).
    03  service-code-key.
        05  service-code-type          pic 9(6).
        05  service-name               pic x(10).
    03  billing-code.
        05  billing-code-type          pic 9(4).
        05  plan-name                  pic x(8).
    03  office-info.
        05  date-in-office             pic 9(8).
        05  served-by-name             pic x(10).
    03  remote-info redefines office-info.
        05  van-id                     pic 9(4).
        05  proc-code                  pic 9(8).
        05  vet-name                   pic x(6).

If you add the WHEN XFD directives shown below, you add several columns to the database table. The fields which then appear in the table are underlined:

$xfd when animal-id-key = "00000000000000000"
 01  archive-record.
     03  filler                          pic x(33).
     03  archive-code                    pic 9(6).
     03  archive-location                pic 9(2).
     03  filler                          pic x(10).
$xfd  when animal-id-key =  other
 01  master-record.
$xfd  use group
     03  animal-id-key.
         05  patient-id                  pic 9(6).
         05  species-code-type           pic 9(5).
         05  species-name                pic x(6).
     03  service-code-key.
         05  service-code-type           pic 9(6).
         05  service-name                pic x(10).
     03  billing-code.
         05  billing-code-type           pic 9(4).
         05  plan-name                   pic x(8).
$xfd when billing-code-type = "1440"
     03  office-info.
         05  date-in-office              pic 9(8).
         05  served-by-name              pic x(10).
$xfd when billing-code-type = other
     03  remote-info redefines office-info.
         05  van-id                      pic 9(4).
         05  proc-code                   pic 9(8).
         05  vet-name                    pic x(6).

Example 3

If your application has a REDEFINES whose field names are more meaningful than the fields they redefine, you might consider switching the order of your code, rather than using a WHEN XFD directive. Use the less significant field names in the REDEFINES.

For example, you might change this:

03  code-info.
        05  filler                  pic 9(8).
        05 code-1                  pic x(10).
    03  patient-info redefines code-info.
        05  patient-id              pic 9(4).
        05  service-code            pic 9(8).
        05  server-name             pic x(6).

to this:

 03  patient-info.
        05  patient-id              pic 9(4).
        05  service-code            pic 9(8).
        05  server-name             pic x(6).
    03  code-info redefines patient-info.
        05  filler                  pic 9(8).
        05  code-1                  pic x(10).

The fields that would appear in the database table by default are underlined above. This shows how the column names might become more meaningful when the order is reversed. Your application operates the same either way.

Note: When a WHEN XFD directive condition is met, COBOL record definitions or REDEFINES records that are subordinate to other WHEN XFD directives are not used. Database columns in rows that correspond to those records are set to the special database value NULL. This means that there is no value provided for those columns. NULL is not equivalent to zero, and it has special properties in the RDBMS. For example, you can select all rows for which a given column is NULL.

Example 4

This COBOL code:

01  col-type                         pic x.
 $xfd  when col-type = "a"
      03  def1                         pic x(2).
 $xfd  when col-type = "b"
      03  def2 redefines def1          pic 9(2).

results in this database table:

col_type | def1 | def2
a | Xx | <Null>
b | <Null> | 10
  • WHEN Complex Expressions
    Syntax and rules for using complex expressions with WHEN directives.
Parent topic: XFD Directives
Related information
How XFDs are Formed
NAME XFD directive
REDEFINES Clause


WHEN Complex Expressions

The XFD WHEN directive supports complex expressions such as those containing multiple AND and OR operations and parentheses to group sub-expressions for proper order of evaluation. For example:

$XFD WHEN (var1 = "abc" or var1 = "def") and \
$XFD      (var2 > "000" or var3 > "000") and \
$XFD       var4 != "xyzzy"

Here is a more complete example:

       fd idx1-file.
       01 idx1-record1.
          03 filler pic x(46).

       01 idx1-record2.
          03 idx1-key.
             05 idx1-num1  pic 9(3).
             05 idx1-num2  pic 9(3).
             05 idx1-num3  pic 9(3).
          03 filler pic x(37).

      $xfd when ((idx1-num1 = "000" or idx1-num1 = "009") and  \
      $xfd       (idx1-num2 = "000" or idx1-num2 = "009"))     \
      $xfd   tablename=one
       01 idx1-record3.
          03 filler pic x(6).
          03 rec3-name1  pic x(20).
      $xfd when idx1-num3 = "333" or idx1-num3 = "444", tablename=two
          03 rec3-name2  pic x(20).

      $xfd when idx1-num1 = "001" AND idx1-num2 = "001"
       01 idx1-record4.
          03 filler pic x(6).
          03 rec4-name1  pic x(30).
          03 rec4-name2  pic x(10).

      $xfd when idx1-num1 > "001" OR idx1-num2 > "001"
       01 idx1-record5.
          03 filler pic x(6).
          03 rec5-text  pic x(40).

WHEN Expression Rules

  1. The AND operation takes precedence over the OR operation. If sc1, sc2, and sc3 are simple conditions (as defined above) then the expression sc1 or sc2 and sc3 is interpreted as sc1 or (sc2 and sc3) meaning that the AND of sc2 and sc3 is performed first and the result of that operation is OR'ed with sc1. If you want the OR operation performed first then you must specify (sc1 or sc2) and sc3 using parentheses.
  2. Since expressions are likely to use parentheses it is strongly recommended that the "$XFD" syntax be used rather than the "*(( XFD" with trailing "))" syntax.
  3. Mismatched parentheses cause an error to be reported.
  4. The maximum number of simple conditions in one expression is 50. An error is reported if the maximum is exceeded.
  5. Only one WHEN expression directive is allowed on consecutive lines. For example, the following three lines cause a syntax error to be reported:
    $XFD WHEN var1 = "abc" or var2 = "def"
$XFD WHEN var3 = "xyz"
01  record-type-2.

    If what you meant was:

    $XFD WHEN (var1 = "abc" or var2 = "def") \
$XFD   and var3 = "xyz"
01  record-type-2.

    then you must code it that way (note the use of parentheses and the backslash XFD directive line continuation character).

    "The optional condition tablename at the end of a WHEN directive applies to all simple conditions within the expression and to the overall combined expression. For example:

    $XFD WHEN (var1 = "abc" or var1 = "def") and \
$XFD      (var2 = "123" or var2 = "456") \
$XFD      tablename = table-2
01  record-type-2.

    The condition tablename table-2 is applied to all four simple conditions and propagated to the two OR conditions and to the final AND condition of the expression.

Parent topic: WHEN XFD directive


XSL XFD directive

The XSL XFD directive allows you to include a stylesheet reference in the XML header.

Syntax

$XFD XSL=stylesheet

where stylesheet is an alphanumeric literal indicating the appropriate stylesheet. The Compiler includes the following line in all generated XML-style XFD files:

<?xml-stylesheet type="text/xsl" href="stylesheet"?>

For example:

$XFD XSL="myxsl.xsl"

generates this line:

<?xml-stylesheet type="text/xsl" href="myxsl.xsl"?>
Parent topic: XFD Directives


Compiler Directives Affecting XFD Creation

  • CREATEXFD XFD directive
Parent topic: Database Connectors Reference


CREATEXFD XFD directive

Use the CREATEXFD directive to tell the compiler to generate XFDs for the COBOL files contained in your program.

This directive has the following format:

Syntax

$SET CREATEXFD ( version=n, xfd-directory=pathname, file-type=all )

All of the arguments are optional, and can be given in any order.

version=n | Causes XFD files of type n to be used. Currently, "6" is the only valid value here. Any other value causes XFD files of the latest version to be created
xfd-directory=pathname | Causes the XFD files to be created in the directory named by pathname. Pathname must be a valid directory, either absolute or relative, and must be writable to the user
file-type=all | Causes XFD files for all file types to be created. Without this argument, the Compiler creates XFD files for only indexed files. If anything other than "all" is specified, the Compiler creates XFD files only for indexed files
Parent topic: Compiler Directives Affecting XFD Creation


Copyright and Legal Information

  • Copyright and Trademarks
  • Secure Communications (SSL) Legal Information
  • Cyrus SASL License
  • NET SNMP Copyright
  • OpenLDAP Public License
Parent topic: Micro Focus Database Connectors Version 2.0 for Windows
Parent topic: Micro Focus Studio Enterprise Edition 6.0


Copyright and Trademarks

Copyright © 1984-2012 Micro Focus. All rights reserved. The software and information contained herein are proprietary to, and comprise valuable trade secrets of, Micro Focus, which intends to preserve as trade secrets such software and information. This software is an unpublished copyright of Micro Focus and may not be used, copied, transmitted, or stored in any manner. This software and information or any other copies thereof may not be provided or otherwise made available to any other person.

Micro Focus has made every effort to ensure that this book is correct and accurate, but reserves the right to make changes without notice at its sole discretion at any time. The software described in this document is supplied under a license and may be used or copied only in accordance with the terms of such license, and in particular any warranty of fitness of Micro Focus software products for any particular purpose is expressly excluded and in no event will Micro Focus be liable for any consequential loss.

MICRO FOCUS, the Micro Focus logo, and Micro Focus product names are trademarks or registered trademarks of Micro Focus IP Development Limited or its subsidiaries or affiliated companies in the United States, United Kingdom, and other countries. All other marks are the property of their respective owners.

IBM®, z/OS®, CICS® and RACF® are registered trademarks, and IMS™ is a trademark, of International Business Machines Corporation.

License management is based on SentinelRMS © 1989-2006 SafeNet, Inc. All rights reserved. Sentinel is a registered trademark of SafeNet, Inc.

All other trademarks are the property of their respective owners.

Reference to third party companies, products and web sites is for information purposes only and constitutes neither an endorsement nor a recommendation. Micro Focus provides this information only as a convenience to users. Micro Focus makes no representation whatsoever regarding the content of any other web site or the use of any such third party products. Micro Focus shall not be liable in respect of your use or access to such third party products/web sites.

No part of this publication, with the exception of the software product user documentation contained on a CD-ROM, may be copied, photocopied, reproduced, transmitted, transcribed, or reduced to any electronic medium or machine-readable form without prior written consent of Micro Focus. Contact your Micro Focus representative if you require access to the modified Apache Software Foundation source files.

Licensees may duplicate the software product user documentation contained on a CD-ROM, but only to the extent necessary to support the users authorized access to the software under the license agreement. Any reproduction of the documentation, regardless of whether the documentation is reproduced in whole or in part, must be accompanied by this copyright statement in its entirety, without modification.

U.S. GOVERNMENT RESTRICTED RIGHTS. It is acknowledged that the Software and the Documentation were developed at private expense, that no part is in the public domain, and that the Software and Documentation are Commercial Computer Software provided with RESTRICTED RIGHTS under Federal Acquisition Regulations and agency supplements to them. Use, duplication or disclosure by the U.S. Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of The Rights in Technical Data and Computer Software clause at DFAR 252.227-7013 et. seq. or subparagraphs (c)(1) and (2) of the Commercial Computer Software Restricted Rights at FAR 52.227-19, as applicable. Contractor is Micro Focus, One Irvington Center, 700 King Farm Boulevard, Suite 400, Rockville, Maryland 20850. Rights are reserved under copyright laws of the United States with respect to unpublished portions of the Software.

Parent topic: Copyright and Legal Information


Secure Communications (SSL) Legal Information

OpenSSL Acknowledgment

The SSL support provided by the Micro Focus Security Pack is based on OpenSSL.

The OpenSSL project is a collaborative effort to develop a robust, commercial-grade, full-featured, and Open Source toolkit implementing the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) protocols as well as a full-strength general purpose cryptography library. The project is managed by a worldwide community of volunteers that use the Internet to communicate, plan, and develop the OpenSSL toolkit and its related documentation.

For further information, see the OpenSSL home page at http://www.openssl.org .

Usage and Export

The ability to send messages in an encrypted form is regarded in some parts of the world as being of military value, and therefore is subject in some countries to legal restrictions and export controls.

Important:

Therefore it may be illegal to use or export SSL or PKIs in or to some countries. You must check the legal position in your country.

Restrictions on Algorithms and Key Lengths

Some encryption or hashing algorithms available in OpenSSL are under patent. Micro Focus has, to the best of its knowledge, not included these in the SSL support included with this COBOL system.

The use of some key lengths may be legally restricted in some countries, because longer key lengths give stronger protection, and therefore may be considered of military value.

Important:

We recommend you take the advice of your own legal department, especially regarding conditions in your country, and especially if you will be shipping products of your own incorporating these features.

Parent topic: Copyright and Legal Information
Parent topic: Securing Communications


Cyrus SASL License

/* CMU libsasl
 * Tim Martin
 * Rob Earhart
 * Rob Siemborski
 */
/*
 * Copyright (c) 1998-2003 Carnegie Mellon University.  All rights reserved.
 *
 * Redistribution and use in source and binary forms, with or without
 * modification, are permitted provided that the following conditions
 * are met:
 *
 * 1. Redistributions of source code must retain the above copyright
 *    notice, this list of conditions and the following disclaimer.
 *
 * 2. Redistributions in binary form must reproduce the above copyright
 *    notice, this list of conditions and the following disclaimer in
 *    the documentation and/or other materials provided with the
 *    distribution.
 *
 * 3. The name "Carnegie Mellon University" must not be used to
 *    endorse or promote products derived from this software without
 *    prior written permission. For permission or any other legal
 *    details, please contact
 *      Office of Technology Transfer
 *      Carnegie Mellon University
 *      5000 Forbes Avenue
 *      Pittsburgh, PA  15213-3890
 *      (412) 268-4387, fax: (412) 268-7395
 *      tech-transfer@andrew.cmu.edu
 *
 * 4. Redistributions of any form whatsoever must retain the following
 *    acknowledgment:
 *    "This product includes software developed by Computing Services
 *     at Carnegie Mellon University (http://www.cmu.edu/computing/)."
 *
 * CARNEGIE MELLON UNIVERSITY DISCLAIMS ALL WARRANTIES WITH REGARD TO
 * THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY
 * AND FITNESS, IN NO EVENT SHALL CARNEGIE MELLON UNIVERSITY BE LIABLE
 * FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
 * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN
 * AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING
 * OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
 */
Parent topic: Copyright and Legal Information


NET SNMP Copyright

---- Part 1: CMU/UCD copyright notice: (BSD like) -----

       Copyright 1989, 1991, 1992 by Carnegie Mellon University

          Derivative Work - 1996, 1998-2000
Copyright 1996, 1998-2000 The Regents of the University of California

             All Rights Reserved

Permission to use, copy, modify and distribute this software and its
documentation for any purpose and without fee is hereby granted,
provided that the above copyright notice appears in all copies and
that both that copyright notice and this permission notice appear in
supporting documentation, and that the name of CMU and The Regents of
the University of California not be used in advertising or publicity
pertaining to distribution of the software without specific written
permission.

CMU AND THE REGENTS OF THE UNIVERSITY OF CALIFORNIA DISCLAIM ALL
WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ALL IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS.  IN NO EVENT SHALL CMU OR
THE REGENTS OF THE UNIVERSITY OF CALIFORNIA BE LIABLE FOR ANY SPECIAL,
INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING
FROM THE LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF
CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

---- Part 2: Networks Associates Technology, Inc copyright notice (BSD) -----

Copyright (c) 2001-2003, Networks Associates Technology, Inc
All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

*  Redistributions of source code must retain the above copyright notice,
   this list of conditions and the following disclaimer.

*  Redistributions in binary form must reproduce the above copyright
   notice, this list of conditions and the following disclaimer in the
   documentation and/or other materials provided with the distribution.

*  Neither the name of the Networks Associates Technology, Inc nor the
   names of its contributors may be used to endorse or promote
   products derived from this software without specific prior written
   permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS
IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 3: Cambridge Broadband Ltd. copyright notice (BSD) -----

Portions of this code are copyright (c) 2001-2003, Cambridge Broadband Ltd.
All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

*  Redistributions of source code must retain the above copyright notice,
   this list of conditions and the following disclaimer.

*  Redistributions in binary form must reproduce the above copyright
   notice, this list of conditions and the following disclaimer in the
   documentation and/or other materials provided with the distribution.

*  The name of Cambridge Broadband Ltd. may not be used to endorse or
   promote products derived from this software without specific prior
   written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER ``AS IS'' AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT HOLDER BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 4: Sun Microsystems, Inc. copyright notice (BSD) -----

Copyright © 2003 Sun Microsystems, Inc., 4150 Network Circle, Santa Clara,
California 95054, U.S.A. All rights reserved.

Use is subject to license terms below.

This distribution may include materials developed by third parties.

Sun, Sun Microsystems, the Sun logo and Solaris are trademarks or registered
trademarks of Sun Microsystems, Inc. in the U.S. and other countries.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

*  Redistributions of source code must retain the above copyright notice,
    this list of conditions and the following disclaimer.

*  Redistributions in binary form must reproduce the above copyright
    notice, this list of conditions and the following disclaimer in the
    documentation and/or other materials provided with the distribution.

*  Neither the name of the Sun Microsystems, Inc. nor the
    names of its contributors may be used to endorse or promote
    products derived from this software without specific prior written
    permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS
IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 5: Sparta, Inc copyright notice (BSD) -----

Copyright (c) 2003-2005, Sparta, Inc
All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

*  Redistributions of source code must retain the above copyright notice,
   this list of conditions and the following disclaimer.

*  Redistributions in binary form must reproduce the above copyright
   notice, this list of conditions and the following disclaimer in the
   documentation and/or other materials provided with the distribution.

*  Neither the name of Sparta, Inc nor the names of its contributors may
   be used to endorse or promote products derived from this software
   without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS
IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 6: Cisco/BUPTNIC copyright notice (BSD) -----

Copyright (c) 2004, Cisco, Inc and Information Network
Center of Beijing University of Posts and Telecommunications.
All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

*  Redistributions of source code must retain the above copyright notice,
   this list of conditions and the following disclaimer.

*  Redistributions in binary form must reproduce the above copyright
   notice, this list of conditions and the following disclaimer in the
   documentation and/or other materials provided with the distribution.

*  Neither the name of Cisco, Inc, Beijing University of Posts and
   Telecommunications, nor the names of their contributors may
   be used to endorse or promote products derived from this software
   without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS
IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

---- Part 7: Fabasoft R&D Software GmbH & Co KG copyright notice (BSD) -----

Copyright (c) Fabasoft R&D Software GmbH & Co KG, 2003
oss@fabasoft.com
Author: Bernhard Penz bernhard.penz@fabasoft.com

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:

*  Redistributions of source code must retain the above copyright notice,
   this list of conditions and the following disclaimer.

*  Redistributions in binary form must reproduce the above copyright
   notice, this list of conditions and the following disclaimer in the
   documentation and/or other materials provided with the distribution.

*  The name of Fabasoft R&amp;D Software GmbH & Co KG or any of its subsidiaries,
   brand or product names may not be used to endorse or promote products
   derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDER ``AS IS'' AND ANY
EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT HOLDER BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE
OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Parent topic: Copyright and Legal Information


OpenLDAP Public License

The OpenLDAP Public License
  Version 2.8, 17 August 2003

Redistribution and use of this software and associated documentation
("Software"), with or without modification, are permitted provided
that the following conditions are met:

1. Redistributions in source form must retain copyright statements
   and notices,

2. Redistributions in binary form must reproduce applicable copyright
   statements and notices, this list of conditions, and the following
   disclaimer in the documentation and/or other materials provided
   with the distribution, and

3. Redistributions must contain a verbatim copy of this document.

The OpenLDAP Foundation may revise this license from time to time.
Each revision is distinguished by a version number.  You may use
this Software under terms of this license revision or under the
terms of any subsequent revision of the license.

THIS SOFTWARE IS PROVIDED BY THE OPENLDAP FOUNDATION AND ITS
CONTRIBUTORS ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY
AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO EVENT
SHALL THE OPENLDAP FOUNDATION, ITS CONTRIBUTORS, OR THE AUTHOR(S)
OR OWNER(S) OF THE SOFTWARE BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

The names of the authors and copyright holders must not be used in
advertising or otherwise to promote the sale, use or other dealing
in this Software without specific, written prior permission.  Title
to copyright in this Software shall at all times remain with copyright
holders.

OpenLDAP is a registered trademark of the OpenLDAP Foundation.

Copyright 1999-2003 The OpenLDAP Foundation, Redwood City,
California, USA.  All Rights Reserved.  Permission to copy and
distribute verbatim copies of this document is granted.
Parent topic: Copyright and Legal Information


Notations and Conventions

COBOL Conventions
  • PIC X is used rather than PIC 99 with the COMP-X and COMP-5 data types. Unlike PIC 99, PIC X shows the length of the data item and so demonstrates more clearly the use of COMP-X, which is to define a binary item of the specified number of bytes.
Command Line Format
  • Words printed in italics are generic terms representing names to be devised by you.
  • Words printed in nonitalic characters are the actual words you must enter. You must type them in upper or lower case as shown.
  • Material enclosed in square brackets [ ] is optional.
  • When material is enclosed in braces { }, you must choose from the options within them. If there is only one option in the braces, the braces indicate repetition.
  • The ellipsis (. . .) follows { } or [ ] and means you can repeat the material in the { } or [ ]. The number of repetitions allowed is unlimited unless otherwise stated. If the ellipsis is used with [ ] the material can be omitted altogether.
  • If a command line does not fit across the page, it is continued on the next line; the continuation line is indented.
  • Command line options can be specified as /option or -option.
Keyboard Keys
  • Key names and menu choices are emboldened within the text.
  • Enter refers to the carriage return or Enter key. Where commands to be typed are shown, the Enter key is not explicitly shown; it is treated as implicit that Enter must be pressed at the end of the line.
  • The keys described in this book are not available in all environments. When there is a reference to use of a key such as a status or function key, this refers to the logical press and release of this key, rather than physical keystroke. If your environment does not support the key given, please refer to your accompanying Read Me for the equivalent key.
Numbers
  • Hexadecimal numbers are enclosed in quotation marks and preceded by a lower-case "x" or "h"; for example, x"9D", h"03FF". The "x" is used when the hexadecimal number represents a character string; the "h" when it represents a numerical value.
Path Specifications
  • All path specifications are based on installation to the default installation directory. If you have installed Studio Enterprise Edition to a non-default installation directory, adjust the path specifications accordingly.
  • All path specifications show default paths for installation on the Windows 7 operating system. If you have installed on an alternative operating system, adjust the path specifications accordingly.
  • All path specifications show the physical directory name. This might be different than the paths shown by default in the Windows Explorer address field. For example, a folder listed as Computer > (OS)C: > Users > Public > Public Documents, or something similar, in the Explorer address field usually describes a physical location of c:\users\public\documents. To see the physical location, click the address field in Explorer. You also see the physical path at a command prompt.
  • Some path specifications use an environment variable to represent dynamic drive and directory names. For example, if your %PUBLIC% environment variable is set to c:\users\public, then substitute c:\users\public in place of a %PUBLIC% specification in the documented path.
  • Some path specifications use the %ProgramFiles(x86)% environment variable to represent the drive and directory containing your program files for both 32-bit and 64-bit machines. If you are running on a 32-bit machine, resolve this to the value of the %ProgramFiles% environment variable.
User Interface
  • Menu choices, and UI control and field names are emboldened within the text.
  • In some environments, you might notice that what appears on your screen differs in minor ways (for example, version numbers) from that illustrated in this Help. This does not affect the operation of your software.
Parent topic: Micro Focus Database Connectors Version 2.0 for Windows
Parent topic: Micro Focus Studio Enterprise Edition 6.0


File Handling

  • File Handling Examples
  • File Handling Guide
  • Working with Data Files
  • File Systems
  • Fileshare Guide
Parent topic: Data Access


File Handling Examples

  • Btrieve
  • Example of Data and Key Compression
  • External Files
  • File Handler
  • File Names
  • File Status
  • Indexed Files
  • Locking Files and Records
  • MFSORT
  • Rebuild
  • Example Relative File Definition
  • Sequential Files
Parent topic: File Handling
Related information
File Handling Guide
Working with Data Files
File Systems
Fileshare Guide


Btrieve

  • Example Xfh2btr Configuration File
  • Example Btrieve Trace Output
  • Example Btrieve Trace Option Settings
  • Example of Btrieve Record Lengths
Parent topic: File Handling Examples
Related information
Example of Data and Key Compression
External Files
File Handler
File Names
File Status
Indexed Files
Locking Files and Records
MFSORT
Rebuild
Example Relative File Definition
Sequential Files


Example Xfh2btr Configuration File

[X2B-DEFAULTS]
output:accelerated
i-o-shareable:accelerated
i-o-exclusive:accelerated
btrpage:2048
btrmaxrec:2000
[test1.dat]
output:exclusive
i-o-shareable:normal
btrpage:4096

The above is an example Xfh2btr configuration file which specifies the following:

  • The default open mode for files opened OUTPUT is accelerated.
  • The default open mode for files opened I/O which are shareable is accelerated.
  • The default open mode for files opened I/O which are exclusive is accelerated.
  • The default page size to use when creating files is 2048 bytes.
  • The default maximum record length is 2000 bytes.
  • For the file test1.dat, OPEN OUTPUT operations open the file exclusively.
  • For the file test1.dat, OPEN I/O operations which are shareable use the normal open mode.
  • For the file test1.dat, the page size to use when creating the file is 4096 bytes.
Parent topic: Btrieve
Related information
Example Btrieve Trace Output
Example Btrieve Trace Option Settings
Example of Btrieve Record Lengths


Example Btrieve Trace Output

Below is an example of the output produced when the trace option is used:

                                             Line
Input FA01 ifile1.tmp                          1
Output Btrieve Error=+0000 COBOL Error=0/0     2
Input FAF3 ifile1.tmp                          3
Output Btrieve Error=+0000 COBOL Error=0/0     4
Input FAF3 ifile1.tmp                          5
Output Btrieve Error=+0000 COBOL Error=0/0     6
Input FADC All Files                           7
Output Btrieve Error=+0000 COBOL Error=0/0     8
Input FA80 ifile1.tmp                          9
Output Btrieve Error=+0000 COBOL Error=0/0    10
Input FA02 ifile1.tmp                         11
Output Btrieve Error=+0000 COBOL Error=0/0    12
Input FAF5 ifile1.tmp                         13
Output Btrieve Error=+0000 COBOL Error=0/0    14
Input FAF5 ifile1.tmp                         15
Output Btrieve Error=+0000 COBOL Error=0/0    16
Input FAF5 ifile1.tmp                         17
Output Btrieve Error=+0009 COBOL Error=1/0    18
Input FA80 ifile1.tmp                         19
Output Btrieve Error=+0000 COBOL Error=0/0    20
Input FA01 test.dat                           21
Output Btrieve Error=+0029 COBOL Error=9/078  22
Input FA00 ifile1.tmp                         23
Output Btrieve Error=+0000 COBOL Error=0/0    24
Input FAF3 ifile1.tmp                         25
Output Btrieve Error=+0000 COBOL Error=4/8    26
Input FA80 ifile1.tmp                         27
Output Btrieve Error=+0000 COBOL Error=0/0    28

Line 1 shows an example input line: the operation code and the name of the file on which the operation is being performed.

Line 2 shows an example output line: the Btrieve error status and the error being returned to the COBOL application.

Line 7 shows an example of an operation (in this case, COMMIT) being performed on all open files.

Line 22 shows the error status 29 being returned from the Btrieve run-time system and that this is returned to the COBOL application as a 9/078 status. For details of the Btrieve error status 29, see the relevant Btrieve documentation.

Line 26 shows an error that is generated within the Xfh2btr module. An attempt is being made to write to a file which is opened for INPUT.

Parent topic: Btrieve
Related information
Example Xfh2btr Configuration File
Example Btrieve Trace Option Settings
Example of Btrieve Record Lengths


Example Btrieve Trace Option Settings

The following entries in the Xfh2btr configuration file:

[X2B-DEFAULTS]
trace-file:x2btrace.dat
trace:

specify that tracing is on for every file and that the trace information is written to the file x2btrace.dat.

The following entries in the Xfh2btr configuration file:

[X2B-DEFAULTS]
trace-file:
[test1.dat]
trace:

specify that tracing is on for the file test1.dat and that the trace information is written to the file xfh2btr.lst (the default trace filename).

Parent topic: Btrieve
Related information
Example Xfh2btr Configuration File
Example Btrieve Trace Output
Example of Btrieve Record Lengths


Example of Btrieve Record Lengths

The following examples use a page size of 1024 bytes:

  • A fixed length record index file with a record length of 1018 bytes creates a fixed length record Btrieve file with a fixed record length of 1018 bytes.

    All the keys must be in the first 1018 bytes of the record.

  • A fixed length record index file with a record length of 1019 bytes creates a variable length record Btrieve file with a fixed record length of 1014 bytes.

    All the keys must be in the first 1014 bytes of the record.

  • A fixed length record index file with a record length of 1010 bytes and one key which allows duplicates creates a fixed length record Btrieve file with a fixed record length of 1010 bytes.

    All of the keys must be in the first 1010 bytes of the record.

  • A fixed length record index file with a record length of 1011 bytes and one key which allows duplicates creates a variable length record Btrieve file with a fixed record length of 1006 bytes.

    All of the keys must be in the first 1006 bytes of the record.

  • A fixed length record relative file with a record length of 1014 bytes creates a fixed length record Btrieve file with a fixed record length of 1018 bytes.

    The additional four bytes is due to the auto-increment key that is added automatically to the front of each record.

    If you are using the opcode 06 action-code for the Callable File Handler call interface, the record length returned is 1014 bytes.

  • A fixed length relative file with a record length of 1015 bytes creates a variable length Btrieve file with a fixed record length of 1014 bytes. This is because you are limited to a maximum of 1014 bytes.

    This length includes the additional four bytes automatically added to the front of each record, due to the auto-increment key.

    If you are using the opcode 06 action-code for the Callable File Handler call interface, the record length returned is 1010 bytes.

  • A variable length record index file with a minimum record length of 1014 bytes creates a variable length record Btrieve file with a fixed record length of 1014 bytes.

    All of the keys must be in the first 1014 bytes of the record.

  • A variable length record index file with a minimum record length of 1015 bytes creates a variable length record Btrieve file with a fixed record length of 1014 bytes.

    All of the keys must be in the first 1014 bytes of the record.

  • A variable length record index file with a minimum record length of 1006 bytes and one key which allows duplicates creates a variable length record Btrieve file with a fixed record length of 1006 bytes.

    All of the keys must be in the first 1006 bytes of the record.

  • A variable length record index file with a minimum record length of 1007 bytes and one key which allows duplicates creates a variable length record Btrieve file with a fixed record length of 1006 bytes.

    All of the keys must be in the first 1006 bytes of the record.

  • A variable length record relative file with a minimum record length of 1010 bytes creates a variable length record Btrieve file with a fixed record length of 1014 bytes.

    The additional four bytes is due to the auto-increment key that is added automatically to the front of each record.

    If you are using the opcode 06 action-code for the Callable File Handler call interface, the record length returned is 1010 bytes.

  • A variable length record relative file with a minimum record length of 1011 bytes creates a variable length record Btrieve file with a fixed record length of 1014 bytes.

    The additional four bytes is due to the auto-increment key that is added automatically to the front of each record.

    If you are using the opcode 06 action-code for the Callable File Handler call interface, the record length returned is 1010 bytes.

Parent topic: Btrieve
Related information
Example Xfh2btr Configuration File
Example Btrieve Trace Output
Example Btrieve Trace Option Settings


Example of Data and Key Compression

In the following program, data compression is specified for transfile but not for masterfile. For key compression, suppression of trailing spaces and of leading characters that are the same as in the previous key is specified for keys t-rec-key and m-rec-key.

Suppression of repetition of duplicate keys is also turned on for m-alt-key-1 and m-alt-key-2. This is ignored for m-alt-key-1 which does not allow duplicates.

$set callfh"extfh"
$set datacompress"1"
$set keycompress"6"
     select transfile
         assign to "user.dat"
         organization is indexed
         record key is t-rec-key.
$set nokeycompress
$set nodatacompress

     select masterfile
         assign to "stock.dat"
         organization is indexed
$set keycompress"6"
         record key is m-rec-key
$set keycompress"7"
         alternate key is m-alt-key-1 with duplicates
         alternate key is m-alt-key-2.
$set nokeycompress
Parent topic: File Handling Examples
Related information
Btrieve
External Files
File Handler
File Names
File Status
Indexed Files
Locking Files and Records
MFSORT
Rebuild
Example Relative File Definition
Sequential Files


External Files

  • Example External Files
Parent topic: File Handling Examples
Related information
Btrieve
Example of Data and Key Compression
File Handler
File Names
File Status
Indexed Files
Locking Files and Records
MFSORT
Rebuild
Example Relative File Definition
Sequential Files


Example External Files

  1$set ans85 mf noosvs
  2*****************************************************
  3*
  4*    (C) 1997-2002 Micro Focus International Ltd.
  5*
  6*      EXTFILE.CBL
  7*
  8* This program demonstrates how to use EXTERNAL files
  9* It calls WRITEFIL to write some records to a data
 10* file and READFILE to read the same records back
 11* (without opening or closing the file between calls
 12* READFILE displays the output.
 13*
 14****************************************************
 15 identification division.
 16 program-id. extfile.
 17 environment division.
 18 input-output section.
 19 file-control.
 20 select finfile assign to "isamfil.dat"
 21  organization is indexed
 22  record key is fd-tran-date
 23  access mode is dynamic.
 24
 25 file section.
 26 fd finfile
 27  is external
 28   record contains 50 characters.
 29 01 fd-finfile-record.
 30   05 fd-tran-date   pic x(4).
 31   05 fd-with-or-dep   pic x(2).
 32   05 fd-amount    pic 9(5)v99.
 33
 34 procedure division.
 35 main-line.
 36   perform open-file
 37   perform write-to-the-file
 38   perform start-file
 39   perform read-the-file
 40   perform close-file
 41   stop run.
 42
 43 open-file.
 44   open i-o finfile.
 45
 46 start-file.
 47   move 1111 to fd-tran-date
 48   start finfile key = fd-tran-date.
 49
 50 write-to-the-file.
 51   call "writefil".
 52
 53 read-the-file.
 54   call "readfile".
 55
 56 close-file.
 57   close finfile.
 58 end program extfile.
 59*****************************************************
 60 identification division.
 61 program-id. readfile.
 62 environment division.
 63 input-output section.
 64 file-control.
 65 select finfile assign to "isamfil.dat"
 66   organization is indexed
 67   record key is fd-tran-date
 68   access mode is dynamic.
 69
 70 file section.
 71 fd finfile
 72   is external
 73   record contains 50 characters.
 74 01 fd-finfile-record.
 75   05 fd-tran-date   pic x(4).
 76   05 fd-with-or-dep  pic x(2).
 77   05 fd-amount    pic 9(5)v99.
 78
 79 working-storage section.
 80 01 ws-end-of-file   pic 9   value 0.
 81 01 ws-subtotal    pic s9(5)v99 value 0.
 82 01 ws-total     pic -(4)9.99.
 83
 84 procedure division.
 85 main-line.
 86   perform read-the-file.
 87   perform until ws-end-of-file = 1
 88   perform calculate-totals
 89   perform read-the-file
 90   end-perform.
 91   perform display-output.
 92   exit program.
 93   stop run.
 94
 95 read-the-file.
 96   read finfile next record at end
 97    move 1 to ws-end-of-file.
 98
 99 calculate-totals.
100   evaluate fd-with-or-dep
101    when "WI"
102     subtract fd-amount from ws-subtotal
103    when "DE"
104     add fd-amount to ws-subtotal
105   end-evaluate.
106
107 display-output.
108   move ws-subtotal to ws-total
109   display "account balance = ", ws-total.
110
111 end program readfile.
112****************************************************
113 identification division.
114 program-id. writefil.
115 environment division.
116 input-output section.
117 file-control.
118 select finfile assign to "isamfil.dat"
119   organization is indexed
120   record key is fd-tran-date
121   access mode is dynamic.
122
123 file section.
124 fd finfile
125  is external
126  record contains 50 characters.
127 01 fd-finfile-record.
128   05 fd-tran-date   pic x(4).
129   05 fd-with-or-dep   pic x(2).
130   05 fd-amount    pic 9(5)v99.
131
132 procedure division.
133 main-line.
134   perform write-records
135   exit program
136   stop run.
137
138 write-records.
139
140* write a WIthdrawal record
141   move 1111 to fd-tran-date.
142   move 'WI' to fd-with-or-dep.
143   move 23.55 to fd-amount.
144   write fd-finfile-record.
145
146* write a DEposit record
147   move 2222 to fd-tran-date.
148   move 'DE' to fd-with-or-dep.
149   move 123.55 to fd-amount.
150   write fd-finfile-record.
151
152 end program writefil.
Parent topic: External Files


File Handler

  • Example Configuration File
  • Example of Creating a New Index File
  • Example of Accessing the FCD
  • Example of Setting Up the Record Area
  • Example of Setting up the Filename Area
Parent topic: File Handling Examples
Related information
Btrieve
Example of Data and Key Compression
External Files
File Names
File Status
Indexed Files
Locking Files and Records
MFSORT
Rebuild
Example Relative File Definition
Sequential Files


Example Configuration File

The following is an example of the contents of a file handler configuration file, extfh.cfg:

[XFH-DEFAULT]
trace=on
IdxDatBuf=0
IndexCount=22000
KeyCheck=off
NodeSize=512
TraceFileName=p:\data\trace.xfh

[test.dat]
IdxDatBuf=1024
trace=off

[test1.dat]
KeyCheck=on
Parent topic: File Handler
Related information
Example of Creating a New Index File
Example of Accessing the FCD
Example of Setting Up the Record Area
Example of Setting up the Filename Area


Example of Creating a New Index File

 78 close-file   value x"fa80"
 78 open-new-index  value x"0007".
 78 get-next-rec  value x"0008".
 78 add-key-value  value x"0009".
  ...

     move open-new-index to fh-opcode
     perform extfh-op
     move get-next-rec to fh-opcode
     perform extfh-op
     perform until fcd-status (1:1) not = "0"
         perform varying fcd-key-id from 0 by 1
                 until fcd-key-id = key-count
                    or fcd-status (1:1) not = "0"
             move add-key-value to fh-opcode
             perform extfh-op
         end-perform
         move get-next-rec to fh-opcode
         perform extfh-op
     end-perform
     move close-file to fh-opcode
     perform extfh-op
       ...

 extfh-op.
     call "EXTFH" using fh-opcode, fcd
     if fcd-status of fcd (1:1) = "1"
         move 1 to return-code
     end-if.
Parent topic: File Handler
Related information
Example Configuration File
Example of Accessing the FCD
Example of Setting Up the Record Area
Example of Setting up the Filename Area


Example of Accessing the FCD

The following program turns on key compression in a file by setting the appropriate bits in the file's Key Definition Block.

$set fcdreg
 select masterfile
     assign to ...
     organization is indexed
     record key is rec-key
     alternate key is m-alt-key-1 with duplicates
     alternate key is m-alt-key-2
     alternate key is m-alt-key-3 with duplicates.

 select indexfile
     assign to ...
     organization is indexed
     record key is rec-key
     alternate key is t-alt-key-1 with duplicates.
 ...
 working-storage section.
 ...
 linkage section.
 01 key-def-block.
     03 filler     pic x(6).
     03 key-count    pic 9(4) comp-x.
     03 filler     pic x(6).
     03 key-def occurs 1 to 4 times depending on key-count.
         05 filler    pic x(5).
         05 key-compression pic 9(2) comp-x.
         05 filler    pic x(10).
   ...
 procedure division.
     set address of key-def-block to address of fh--keydef of masterfile
     move 6 to key-compression (1)
     move 7 to key-compression (2)
     move 6 to key-compression (3)
     move 7 to key-compression (4)
     open I-O masterfile
     ...
     set address of key-def-block to address of fh--keydef of indexfile
     move 4 to key-compression (1)
     move 1 to key-compression (2)
     open input indexfile
Parent topic: File Handler
Related information
Example Configuration File
Example of Creating a New Index File
Example of Setting Up the Record Area
Example of Setting up the Filename Area


Example of Setting Up the Record Area

The following example shows how the FCD is set up to point to the record area:

 01 RECORD-AREA   PIC X(85).
...
     SET FCD-RECORD-ADDRESS TO ADDRESS OF RECORD-AREA
   ...
Parent topic: File Handler
Related information
Example Configuration File
Example of Creating a New Index File
Example of Accessing the FCD
Example of Setting up the Filename Area


Example of Setting up the Filename Area

The following example shows how the FCD is set up to point to the filename area:

 01 FILENAME-AREA PIC X(65) VALUE "master.dat".
...
     SET FCD-FILENAME-ADDRESS TO ADDRESS OF FILENAME-AREA
   ...
Parent topic: File Handler
Related information
Example Configuration File
Example of Creating a New Index File
Example of Accessing the FCD
Example of Setting Up the Record Area


File Names

  • Examples of static filename assignment
  • Example of dynamic filename assignment
  • Example of external filename assignment
  • Examples of device name assignment
  • Example of Forced Filename Mapping
  • Example of Connecting a File to Standard Output
  • Example of Connecting a File to Standard Input
  • Example of Setting up a Two-way Pipe
  • Example of using the External File Mapper
  • Example of Specifying a Fileshare Client User ID and Password
  • Example Fileshare Client Configuration File
  • Example Fileshare Client
Parent topic: File Handling Examples
Related information
Btrieve
Example of Data and Key Compression
External Files
File Handler
File Status
Indexed Files
Locking Files and Records
MFSORT
Rebuild
Example Relative File Definition
Sequential Files


Examples of static filename assignment

 select stockfile
     assign to "b:warehs.buy".

In this example, opening stockfile will cause the warehs.buy file on the b: drive to be opened.

 select printfile
     assign to "prn:".

In this example, writing to printfile will cause data to be output to prn:, the first parallel printer.

 select input-file
     assign to "data\prog".

In this example, opening input-file will cause the file prog in the data directory (relative to the current directory) to be opened.

Parent topic: File Names
Related information
Example of dynamic filename assignment
Example of external filename assignment
Examples of device name assignment
Example of Forced Filename Mapping
Example of Connecting a File to Standard Output
Example of Connecting a File to Standard Input
Example of Setting up a Two-way Pipe
Example of using the External File Mapper
Example of Specifying a Fileshare Client User ID and Password
Example Fileshare Client Configuration File
Example Fileshare Client


Example of dynamic filename assignment

 select fd-in-name
     assign to dynamic ws-in-file.
  ...
 select fd-out-name
     assign to dynamic ws-out-file.
  ...
 working-storage section.
 01 ws-in-file  pic x(30) value "input.dat".
 01 ws-out-file pic x(40).
  ...
 procedure division.
     accept ws-out-file.
     open input fd-in-name fd-out-name
  ...

In this example, the file input.dat in the current directory and the file specified by the current value of ws-out-file, are opened.

Parent topic: File Names
Related information
Examples of static filename assignment
Example of external filename assignment
Examples of device name assignment
Example of Forced Filename Mapping
Example of Connecting a File to Standard Output
Example of Connecting a File to Standard Input
Example of Setting up a Two-way Pipe
Example of using the External File Mapper
Example of Specifying a Fileshare Client User ID and Password
Example Fileshare Client Configuration File
Example Fileshare Client


Example of external filename assignment

 select fd-name
     assign to external envvar.

In this example, envvar must be an environment variable. Before executing the program, you must issue a SET command to relate envvar to the physical filename you want to use:

set envvar=c:\test.dat

At run-time, the filename fd-name is assigned to the file test.dat in the root directory on the c: drive.

Parent topic: File Names
Related information
Examples of static filename assignment
Example of dynamic filename assignment
Examples of device name assignment
Example of Forced Filename Mapping
Example of Connecting a File to Standard Output
Example of Connecting a File to Standard Input
Example of Setting up a Two-way Pipe
Example of using the External File Mapper
Example of Specifying a Fileshare Client User ID and Password
Example Fileshare Client Configuration File
Example Fileshare Client


Examples of device name assignment

 select fd-name
     assign to "con".

In this example, read/write operations on fd-name cause data to be read from/written to the console screen.

 select fd-name
     assign to dynamic ws-filename.
   ...
     move "lpt1:" to ws-filename.

In this example, write operations on fd-name cause data to be output to lpt1:, the first parallel printer.

Parent topic: File Names
Related information
Examples of static filename assignment
Example of dynamic filename assignment
Example of external filename assignment
Example of Forced Filename Mapping
Example of Connecting a File to Standard Output
Example of Connecting a File to Standard Input
Example of Setting up a Two-way Pipe
Example of using the External File Mapper
Example of Specifying a Fileshare Client User ID and Password
Example Fileshare Client Configuration File
Example Fileshare Client


Example of Forced Filename Mapping

 select fd-name
     assign to "$file1"

This causes the system to search for the environment variable . If this is not found, the system searches for the environment variable . If this is not found, the system attempts to open the file $file1.

Parent topic: File Names
Related information
Examples of static filename assignment
Example of dynamic filename assignment
Example of external filename assignment
Examples of device name assignment
Example of Connecting a File to Standard Output
Example of Connecting a File to Standard Input
Example of Setting up a Two-way Pipe
Example of using the External File Mapper
Example of Specifying a Fileshare Client User ID and Password
Example Fileshare Client Configuration File
Example Fileshare Client


Example of Connecting a File to Standard Output

 select input-file
     assign to "fname"
     organization is line sequential.
  ...
 fd input-file
    record contains 80 characters.
 01 input-file-record pic x(80).
 ...
 procedure division.
     open input input-file.
     read input-file record.
  ...
     close input-file.
     stop run.

If, before running the above program, the following command is issued:

set dd_fname="<cmd /c dir c:\help"

then each READ operation on input-file returns the next line of output from the dir command.

Parent topic: File Names
Related information
Examples of static filename assignment
Example of dynamic filename assignment
Example of external filename assignment
Examples of device name assignment
Example of Forced Filename Mapping
Example of Connecting a File to Standard Input
Example of Setting up a Two-way Pipe
Example of using the External File Mapper
Example of Specifying a Fileshare Client User ID and Password
Example Fileshare Client Configuration File
Example Fileshare Client


Example of Connecting a File to Standard Input

 select output-file
     assign to external evar
     organization is line sequential.
  ...
 fd output-file
    record contains 80 characters.
 01 output-file-record pic x(80).
  ...
 procedure division.
     open output output-file.
     write output-file-record from "c:\dir\file".
   ...
     close output-file.
     stop run.

If, before running the above code, the following command is issued:

set evar=">cmd /c print"

then each WRITE operation on output-file is passed as input to the print command.

Parent topic: File Names
Related information
Examples of static filename assignment
Example of dynamic filename assignment
Example of external filename assignment
Examples of device name assignment
Example of Forced Filename Mapping
Example of Connecting a File to Standard Output
Example of Setting up a Two-way Pipe
Example of using the External File Mapper
Example of Specifying a Fileshare Client User ID and Password
Example Fileshare Client Configuration File
Example Fileshare Client


Example of Setting up a Two-way Pipe

 select i-o-file
     assign to "| cmd /c sort"
     organization is line sequential.
 fd i-o-file.
 01 i-o-file-record pic x(20).
 procedure division.
     open i-o i-o-file
     write i-o-file-record from "Hello world"
     write i-o-file-record from all "A"
     write i-o-file-record from all "Z"
     write i-o-file-record from x"1a"
     perform until exit
         read i-o-file
          at end
             exit perform
         end-read
         display i-o-file-record
     end-perform
     close i-o-file

In this example, the program launches the sort process and passes it three lines of text, followed by an end-of-file marker. It then reads all three lines back from the standard output of the sort process.

Parent topic: File Names
Related information
Examples of static filename assignment
Example of dynamic filename assignment
Example of external filename assignment
Examples of device name assignment
Example of Forced Filename Mapping
Example of Connecting a File to Standard Output
Example of Connecting a File to Standard Input
Example of using the External File Mapper
Example of Specifying a Fileshare Client User ID and Password
Example Fileshare Client Configuration File
Example Fileshare Client


Example of using the External File Mapper

Suppose your program includes:

 select fd-name
     assign to external bigdata.

Create a text file called mfextmap.dat that contains the following line:

bigdata c:\big\bigdata.dat

At run-time:

  1. Ensure that mfextmap.dat is in the current directory, in a directory pointed to by the COBDIR environment variable or in a directory pointed to by the MFEXTMAP environment variable.
  2. Ensure that you have enabled the External File Mapper (Mfextmap) by adding the following line:
    set environment_mapper=TRUE

    to a configuration file pointed to by the COBCONFIG_ environment variable.

Then, when you run your program, the assigned filename bigdata is mapped to the physical file c:\big\bigdata.dat.

Parent topic: File Names
Related information
Examples of static filename assignment
Example of dynamic filename assignment
Example of external filename assignment
Examples of device name assignment
Example of Forced Filename Mapping
Example of Connecting a File to Standard Output
Example of Connecting a File to Standard Input
Example of Setting up a Two-way Pipe
Example of Specifying a Fileshare Client User ID and Password
Example Fileshare Client Configuration File
Example Fileshare Client


Example of Specifying a Fileshare Client User ID and Password

This example shows how to code your program to supply a user-ID and password to a Fileshare Server:

 working-storage section.
 01 function-code pic x comp-x.
 01 user-name  pic x(20).
 01 user-password pic x(20).
  ...
 procedure division.
      ...
     move 1 to function-code
     move "UserID" to user-name
     move "Password" to user-password
     call "fhrdrpwd" using function-code, user-name, user-password
     end-call
      ...
     open output testfile
Parent topic: File Names
Related information
Examples of static filename assignment
Example of dynamic filename assignment
Example of external filename assignment
Examples of device name assignment
Example of Forced Filename Mapping
Example of Connecting a File to Standard Output
Example of Connecting a File to Standard Input
Example of Setting up a Two-way Pipe
Example of using the External File Mapper
Example Fileshare Client Configuration File
Example Fileshare Client


Example Fileshare Client Configuration File

/s server1
/s server2
/f \orders\* /s server3
/f \accounts\payroll.dat
/f \transport\delivery\*

This example configuration file specifies that server1 and server2 are the default Fileshare Servers. This means that these Fileshare Servers will be searched, in this order, for any file which is not specified as either a local file or as located on a specific Fileshare Server. It also specifies that any files with a filename beginning orders\ are located on server3, that the file accounts\payroll.dat is a local file and that any file with a filename beginning transport\delivery\ is a local file.

Parent topic: File Names
Related information
Examples of static filename assignment
Example of dynamic filename assignment
Example of external filename assignment
Examples of device name assignment
Example of Forced Filename Mapping
Example of Connecting a File to Standard Output
Example of Connecting a File to Standard Input
Example of Setting up a Two-way Pipe
Example of using the External File Mapper
Example of Specifying a Fileshare Client User ID and Password
Example Fileshare Client


Example Fileshare Client

An example Fileshare Client is provided in the fileshar.project in the demo folder of your COBOL development system.

Note: You cannot run this example Fileshare Client unless TCP/IP support is installed and configured on your machine and you have a working TCP/IP connection to a remote machine on which you have installed and correctly configured a Fileshare Server. A Fileshare Client uses the Common Communications Interface CCI_ccitcp2 is running on. To do this, you must run the CCI installation utility.

The CCI installation utility will prompt you for a host name. If you do not know the TCP/IP host name of the system that the CCITCP2 daemon is running on, contact your system/network administrator.

To run the example Fileshare Client:

  1. Open fileshar.app in the demo directory.
  2. Run the application by clicking on Run on the Debug menu. (The first time that you run this application you will be prompted to rebuild the project. Rebuild the project by answering Yes to the prompt and then select Run from the Debug menu again.)
  3. The Fileshare Client prompts you:

    Do you want to use Fileshare (y/n):

    Enter y. (If you enter n, the Fileshare Client still runs but uses a local file rather than connecting to a Fileshare Server.)

  4. The first time you run this application, the Fileshare Client prompts you:

    Enter the name of your fileshare server:

    Enter the name of the Fileshare Server to which you want to connect.

    A Fileshare Client configuration file, fhredir.cfg, is created in the current directory containing the name of the Fileshare Server that you specified.

    When you subsequently run this application you are prompted:

    A fileshare client configuration file fhredir.cfg already exists in the current working directory. Overwrite (y/n).

    If you want to use the Fileshare Server specified in the existing configuration file, enter n. The following message is displayed:

    The existing fileshare client configuration file will be used

    If you want to specify a different Fileshare Server, enter y. You are prompted to enter the name of the Fileshare Server that you want to connect to:

    Enter the name of your fileshare server:

  5. Once you have specified a Fileshare Server, the Fileshare Client prompts you:

    Enter the name of the file you want to write to:

    Enter the name of the file that you want to write to.

  6. At this stage you are prompted:

    Do you want to continue ? (y/n)

    If you enter n, you are prompted:

    Press <return> to quit

    Press Enter to terminate the Fileshare Client.

    If you enter y, the file will be created on the Fileshare Server and 10 records will be written to it before you are prompted:

    Enter: <1> COMMIT

    <2> ROLLBACK

    Enter 1 to write the records to the file or 2 to delete them. Another 10 records will be written and you will be prompted again to commit or rollback.

  7. Finally, a list of the records written to the file is displayed and you are prompted:

    Press <return> to quit

    Press Enter to terminate the Fileshare Client.

Parent topic: File Names
Related information
Examples of static filename assignment
Example of dynamic filename assignment
Example of external filename assignment
Examples of device name assignment
Example of Forced Filename Mapping
Example of Connecting a File to Standard Output
Example of Connecting a File to Standard Input
Example of Setting up a Two-way Pipe
Example of using the External File Mapper
Example of Specifying a Fileshare Client User ID and Password
Example Fileshare Client Configuration File


File Status

  • Example of Displaying File Status Codes
  • Example of Checking File Status Codes
  • Example of Extended File Status Codes
Parent topic: File Handling Examples
Related information
Btrieve
Example of Data and Key Compression
External Files
File Handler
File Names
Indexed Files
Locking Files and Records
MFSORT
Rebuild
Example Relative File Definition
Sequential Files


Example of Displaying File Status Codes

The example code that follows illustrates one method of retrieving the values of the second byte of the file status for display purposes. Note how truncation has been avoided by redefining the two status bytes as one numeric data item (length two bytes) capable of storing up to four decimal digits.

 select fd-name
     assign "user.dat"
     status is fd-name-stat.
  ...
 data division.
 file section.
 fd fd-name.
 01 fd-rec    pic x(80)
  ...
 working-storage section.
 01 fd-name-stat.
     03 sk1     pic x.
     03 sk2     pic x.
     03 stat-bin redefines sk2 pic 9(2) comp-x.
 01 disply-stat.
     03 sk1-displ   pic x.
     03 filler    pic x(3).
     03 sk2-displpic  pic zz9.
  ...
 procedure division.
 start-test.
     open input fd-name
     move sk1 to sk1-displ
     if sk1 not= 9
         move sk2 to sk2-displpic
     else
         move stat-bin to sk2-displpic
     end-if
     display disply-stat
     close fd-name
     stop run.
Parent topic: File Status
Related information
Example of Checking File Status Codes
Example of Extended File Status Codes


Example of Checking File Status Codes

The example code that follows illustrates how file status checking is performed: first the first byte (status key 1) is interrogated; then, if more information is required, the second byte (status key 2) is interrogated.

 select recseq
     assign to "recseq.dat"
     file status is ws-file-status
     organization is record sequential.
  ...
 file section.
 fd recseq
    record contains 80 characters.
 01 recseq-fd-record  pic x(80).
  ...
 working-storage section.
 01 ws-file-status.
     05 status-key-1  pic x.
     05 status-key-2  pic x.
     05 binary-status redefines status-key-2 pic 99 comp-x.
  ...
 procedure division.
  ...
 perform check-status.
  ...
 check-status.
     evaluate status-key-1
      when "0" next sentence
      when "1" display "end of file reached"
         perform check-eof-status
      when "2" display "invalid key"
         perform check-inv-key-status
      when "3" display "permanent error"
         perform check-perm-err-status
      when "4" display "logic error"
      when "9" display "run-time-system error"
         perform check-mf-error-message
     end-evaluate.
  ...
 check-eof-status.
     if status-key-2 = "0"
         display "no next logical record"
     end-if.
  ...
 check-inv-key-status.
      evaluate status-key-2
       when "2" display "attempt to write dup key"
       when "3" display "no record found"
      end-evaluate.
  ...
 check-perm-err-status.
      if status-key-2 = "5"
 display "file not found"
      end-if.
  ...
 check-mf-error-message.
      evaluate binary-status
       when 002 display "file not open"
       when 007 display "disk space exhausted"
       when 013 display "file not found"
       when 024 display "disk error    "
       when 065 display "file locked      "
       when 068 display "record locked    "
       when 039 display "record inconsistent"
       when 146 display "no current record  "
       when 180 display "file malformed     "
       when 208 display "network error      "
       when 213 display "too many locks     "
       when other display "not error status "
           display binary-status
     end-evaluate.
Parent topic: File Status
Related information
Example of Displaying File Status Codes
Example of Extended File Status Codes


Example of Extended File Status Codes

The example code that follows illustrates how to redefine a standard file status so that it can be used as an extended file status. Assume for this example that the input file does not exist - when the OPEN INPUT statement is executed, a file status of 9/013 ("file not found") is returned.

 select in-file
     assign to "user.dat".
     file status is file-status.
  ...
 working-storage section.
 01 file-status.
     05 status-key-1     pic x.
     05 status-key-2     pic x.
     05 status-key-2-binary redefines status-key-2 pic 99 comp-x.
  ...
 procedure division.
     open input in-file
     if file-status not = "00"
     if status-key-1 = "9"
     if status-key-2-binary = 13
         display "File not found"
  ...

If you want to display the extended file status code, you need to move the second byte of the file status data item to a display field large enough to hold the maximum value 255:

 select in-file
     assign to "user.dat"
     file status is file-status.
  ...
 working-storage section.
 01 ans74-file-status.
     05 status-key-1    pic x.
     05 status-key-2    pic x.
     05 status-key-2-binary redefines status-key-2 pic 99 comp-x.
 01 display-ext-status
     05 filler          pic xx value "9/"
     05 display-key 2   pic 999
  ...
 procedure division.
     open input in-file
     if file-status not = "00"
         display "Error. File status =" with no advancing
         if status-key-1 = "9"
             move status-key-2-binary to display-key-2
             display display-ext-status
         else
             display file-status
         end-if
  ...
Parent topic: File Status
Related information
Example of Displaying File Status Codes
Example of Checking File Status Codes


Indexed Files

  • Example of Indexed File Definition
  • Example of Primary Key Definition
  • Example of Alternate Key Definition
  • Example of Duplicate Key Definition
  • Example of Sparse Key Definition
  • Example of Indexed File Access Definition
  • Example of Creating Fixed-length Records
  • Example of Creating Variable Length Records
Parent topic: File Handling Examples
Related information
Btrieve
Example of Data and Key Compression
External Files
File Handler
File Names
File Status
Locking Files and Records
MFSORT
Rebuild
Example Relative File Definition
Sequential Files


Example of Indexed File Definition

To define an indexed file:

 file-control.
     select fd-name
         assign to "user.dat"
         organization is indexed
         record key is fd-name-key
    ...
 fd fd-name.
 01 fd-name-record.
     03 fd-name-key  pic X(5).
Parent topic: Indexed Files
Related information
Example of Primary Key Definition
Example of Alternate Key Definition
Example of Duplicate Key Definition
Example of Sparse Key Definition
Example of Indexed File Access Definition
Example of Creating Fixed-length Records
Example of Creating Variable Length Records


Example of Primary Key Definition

To define a primary key:

 file control.
     select fd-name
         assign to "user.dat"
         organization is indexed
         record key is fd-name-key.
    ...
 fd fd-name.
 01 fd-name-record.
     03 fd-name-key  pic X(5).
Parent topic: Indexed Files
Related information
Example of Indexed File Definition
Example of Alternate Key Definition
Example of Duplicate Key Definition
Example of Sparse Key Definition
Example of Indexed File Access Definition
Example of Creating Fixed-length Records
Example of Creating Variable Length Records


Example of Alternate Key Definition

To define an alternate key:

 file control.
     select fd-name
         assign to "user.dat"
         organization is indexed
         record key is fd-name-key
         alternate record key is fd-name-alt-key.
    ...
 fd fd-name.
 01 fd-name-record.
     03 fd-name-key     pic X(5).
     03 fd-name-alt-key pic X(4).
Parent topic: Indexed Files
Related information
Example of Indexed File Definition
Example of Primary Key Definition
Example of Duplicate Key Definition
Example of Sparse Key Definition
Example of Indexed File Access Definition
Example of Creating Fixed-length Records
Example of Creating Variable Length Records


Example of Duplicate Key Definition

To define a duplicate key:

 file control.
     select fd-name
         assign to "user.dat"
         organization is indexed
         record key is fd-name-key
         alternate record key is fd-name-alt-key
          with duplicates.
    ...
 fd fd-name.
 01 fd-name-record.
     03 fd-name-key     pic X(5).
     03 fd-name-alt-key pic X(4).
Parent topic: Indexed Files
Related information
Example of Indexed File Definition
Example of Primary Key Definition
Example of Alternate Key Definition
Example of Sparse Key Definition
Example of Indexed File Access Definition
Example of Creating Fixed-length Records
Example of Creating Variable Length Records


Example of Sparse Key Definition

To define a sparse key:

 file control.
     select fd_name
         assign to "user.dat"
         organization is indexed
         record key is fd-name-key
         alternate record key is fd-name-alt-key
          with duplicates
          suppress when all "A".
     ...
 fd fd-name.
 01 fd-name-record.
     03 fd-name-key  pic X(3).

In this example, if a record is written for which the value of the alternate key is all A's, the actual key value is not stored in the index file.

Parent topic: Indexed Files
Related information
Example of Indexed File Definition
Example of Primary Key Definition
Example of Alternate Key Definition
Example of Duplicate Key Definition
Example of Indexed File Access Definition
Example of Creating Fixed-length Records
Example of Creating Variable Length Records


Example of Indexed File Access Definition

 file control.
     select fd-name
         assign to "user.dat"
         organization is indexed
         access mode is dynamic
         record key is fd-name-key.
Parent topic: Indexed Files
Related information
Example of Indexed File Definition
Example of Primary Key Definition
Example of Alternate Key Definition
Example of Duplicate Key Definition
Example of Sparse Key Definition
Example of Creating Fixed-length Records
Example of Creating Variable Length Records


Example of Creating Fixed-length Records

 file control.
     select fd-name
         assign to "user.dat"
         organization is indexed
         access mode is dynamic
         record key is fd-name-key.
    ...
 file section.
 fd fd-name
    record contains 80 characters.
 01 fd-name-record.
     05 fd-name-key    pic x(5).
     05 fd-name-data   pic x(75).

In this example an indexed file with fixed-length 80-byte records, keyed on the first five bytes of each record, is defined.

Parent topic: Indexed Files
Related information
Example of Indexed File Definition
Example of Primary Key Definition
Example of Alternate Key Definition
Example of Duplicate Key Definition
Example of Sparse Key Definition
Example of Indexed File Access Definition
Example of Creating Variable Length Records


Example of Creating Variable Length Records

 file control.
     select fd-name
         assign to "user.dat"
         organization is indexed
         access mode is dynamic
         record key is fd-name-key.
    ...
 file section.
 fd fd-name.
    record is varying in size
     from 5 to 80 characters depending on ws-record-count.
 01 fd-name-record.
     05 fd-name-key    pic x(5).
     05 fd-name-data   pic x(75).
 ...
 working-storage section.
 01 ws-record-count    pic 99 comp-x.

In this example an indexed file with variable-length records, varying in length from 5 to 80 bytes, is defined. Note that any key(s) must lie within the fixed part of the record.

Parent topic: Indexed Files
Related information
Example of Indexed File Definition
Example of Primary Key Definition
Example of Alternate Key Definition
Example of Duplicate Key Definition
Example of Sparse Key Definition
Example of Indexed File Access Definition
Example of Creating Fixed-length Records


Locking Files and Records

  • Example of Locking a File
  • Examples of Manual Record Locking
  • Examples of Automatic Record Locking
  • Examples of Single Record Locking
  • Examples of Multiple Record Locking
  • Example File and Record Locking Application
Parent topic: File Handling Examples
Related information
Btrieve
Example of Data and Key Compression
External Files
File Handler
File Names
File Status
Indexed Files
MFSORT
Rebuild
Example Relative File Definition
Sequential Files


Example of Locking a File

To lock a file:

 select fd-name
     assign to "muser.dat"
     lock mode is exclusive.
Parent topic: Locking Files and Records
Related information
Examples of Manual Record Locking
Examples of Automatic Record Locking
Examples of Single Record Locking
Examples of Multiple Record Locking
Example File and Record Locking Application


Examples of Manual Record Locking

To manually lock a single record:

 select fd-name
     assign to "muser.dat"
     lock mode is manual.
  ...
     read fd-name with lock

To manually lock multiple records:

 select fd-name
     assign to "muser.dat"
     lock mode is manual with lock on multiple records.
  ...
     read fd-name with kept lock
Parent topic: Locking Files and Records
Related information
Example of Locking a File
Examples of Automatic Record Locking
Examples of Single Record Locking
Examples of Multiple Record Locking
Example File and Record Locking Application


Examples of Automatic Record Locking

To specify automatic single record locking:

 select fd-name
     assign to "muser.dat"
     lock mode is automatic.
  ...
     read fd-name

To specify automatic multiple record locking:

 select fd-name
     assign to "muser.dat"
     lock mode is automatic with lock on multiple records.
  ...
     read fd-name
Parent topic: Locking Files and Records
Related information
Example of Locking a File
Examples of Manual Record Locking
Examples of Single Record Locking
Examples of Multiple Record Locking
Example File and Record Locking Application


Examples of Single Record Locking

To lock a single record, using manual record locking:

 select fd-name
     assign to "muser.dat"
     lock mode is manual.
  ...
     read fd-name with lock

To lock a single record, using automatic record locking:

 select fd-name
     assign to "muser.dat"
     lock mode is automatic.
  ...
     read fd-name
Parent topic: Locking Files and Records
Related information
Example of Locking a File
Examples of Manual Record Locking
Examples of Automatic Record Locking
Examples of Multiple Record Locking
Example File and Record Locking Application


Examples of Multiple Record Locking

To lock multiple records, using manual record locking:

 select fd-name
     assign to "muser.dat"
     lock mode is manual with lock on multiple records.
  ...
     read fd-name with kept lock

To lock multiple records, using automatic record locking:

 select fd-name
     assign to "muser.dat"
     lock mode is automatic with lock on multiple records.
  ...
     read fd-name
Parent topic: Locking Files and Records
Related information
Example of Locking a File
Examples of Manual Record Locking
Examples of Automatic Record Locking
Examples of Single Record Locking
Example File and Record Locking Application


Example File and Record Locking Application

An example file and record locking application is provided in the Examples\Net Express IDE\LOCKING folder in the installation of your COBOL development system.

To run the example application:

  1. Open the locking application.
  2. Run the application by clicking Run on the Debug menu.
  3. Choose option 4 (OUTPUT).
  4. Enter some example data in each of the following fields:
    • Stock code
    • Stock description
    • Stock held
    • Cost per unit
  5. Enter 1 to write the record to the file.

    Repeat steps 4 and 5 until you have entered a number of records.

  6. Enter 2 to exit.
  7. You are prompted:

    Do you wish to restart (Y/N)

    Enter n to redisplay the main screen.

  8. When you are ready to exit the application, enter 5 from the main screen.
Parent topic: Locking Files and Records
Related information
Example of Locking a File
Examples of Manual Record Locking
Examples of Automatic Record Locking
Examples of Single Record Locking
Examples of Multiple Record Locking


MFSORT

  • Example Mfsort Command Line
  • Example Mfsort Fields Instruction
  • Example Mfsort Key Instruction
  • Example Mfsort Instruction File
Parent topic: File Handling Examples
Related information
Btrieve
Example of Data and Key Compression
External Files
File Handler
File Names
File Status
Indexed Files
Locking Files and Records
Rebuild
Example Relative File Definition
Sequential Files


Example Mfsort Command Line

The following example shows the Mfsort command to sort four files:

mfsort use file1 record (v,4,8) use file2 use file3 use file4 give file5 sort fields (1, 1, s5, a, 2, 1, c5, d)
Parent topic: MFSORT
Related information
Example Mfsort Fields Instruction
Example Mfsort Key Instruction
Example Mfsort Instruction File


Example Mfsort Fields Instruction

The following example sorts the file on a 6-byte alphanumeric field which starts at the second byte of the record, in ascending order, with a secondary ordering on a 4-byte (PIC 9(8))COMP field starting at the tenth byte of the record, in descending order.

mfsort sort fields (2, 6, ch, a, 10, 4, bi, d)
Parent topic: MFSORT
Related information
Example Mfsort Command Line
Example Mfsort Key Instruction
Example Mfsort Instruction File


Example Mfsort Key Instruction

The following example defines three keys:

key (4,5,p,10,5,c,20,2,ad,40,2,a,46,10,c)

The first key, the primary key, is split with its first component starting at character position 4 with a length of 5 bytes and its second component starting at character position 10 with a length of 5 bytes.

The second key (alternate key) enables duplicates, starts at character position 20 and is 2 bytes in length.

The third key is a split alternate key, with the first component starting at character position 40 with a length of 2 bytes and the second component starting at character position 46 and with a length of 10 bytes.

Parent topic: MFSORT
Related information
Example Mfsort Command Line
Example Mfsort Fields Instruction
Example Mfsort Instruction File


Example Mfsort Instruction File

The following is an example Mfsort instruction file, called sample.srt:

use file1 record (v,4,8)
use file2
use file3
use file4
give file5
merge fields (1,1,S5,a,2,1,c5,d)

Note that ORG is not needed here as SQ is the default, and that file2 through file5 and the merge workfile use the RECORD format specified for file1.

This instruction file would be used as follows:

mfsort take sample.srt
Parent topic: MFSORT
Related information
Example Mfsort Command Line
Example Mfsort Fields Instruction
Example Mfsort Key Instruction


Rebuild

  • Example of Reorganizing an Indexed File
  • Example of recovering a corrupt indexed file
  • Example of using Rebuild to convert a file
  • Example of validating the structure of an indexed file
  • Example of a Rebuild options file
  • Example of calling Rebuild from a COBOL program
Parent topic: File Handling Examples
Related information
Btrieve
Example of Data and Key Compression
External Files
File Handler
File Names
File Status
Indexed Files
Locking Files and Records
MFSORT
Example Relative File Definition
Sequential Files


Example of Reorganizing an Indexed File

Example 1

rebuild infile.dat,outfile.dat

To reorganize the file, Rebuild reads the data file (infile.dat) using the index file (infile.idx) and then creates the output file (outfile.dat). The deleted records in infile.dat are not written to the output file.

Example 2

rebuild infile.dat,outfile.dat /i

In addition to reorganizing the file, Rebuild displays processing information when the reorganization is complete.

Example 3

rebuild infile.dat,outfile.dat /s:lii /t:lii

Reorganizes a LEVEL II V2.5 COBOL format file and retains the LII structure on the output file. It is possible to combine /s and /t with other formats in a similar manner.

Example 4

set data=\tmp.dat
rebuild data /i

Rebuild reorganizes and displays information about the file \tmp.dat.

Example 5

rebuild infile001.dat,outfile.dat/x:3

In addition to reorganizing the file, Rebuild writes the data in the order of the third alternate key.

Note: You cannot use the same filename for the input file and the output file.
Parent topic: Rebuild
Related information
Example of recovering a corrupt indexed file
Example of using Rebuild to convert a file
Example of validating the structure of an indexed file
Example of a Rebuild options file
Example of calling Rebuild from a COBOL program


Example of recovering a corrupt indexed file

Example 1

rebuild infile.dat

To get the key information, Rebuild reads the .idx file. Rebuild then reads the data file infile.dat to create a new index file.

If the index file is not present, you must use /k to supply information about the key structure.

Example 2

rebuild infile.dat, outfile.dat /d /e

Rebuild reads the input file to get the key information, and creates a new indexed file, by working through the data in physical order, skipping over duplicate records.

If the index file is not present, you must use /k to supply information about the key structure.

Example 3

rebuild infile.dat/k:1+20/i

To rebuild the indexed file, Rebuild reads the key definition information supplied by the /k option. In this case, there is a single key, starting at character position 1 and 20 characters in length.

Rebuild ignores any index files that already exist.

The key definition information that you supply using the /k option does not need to correspond to the key definition used when the file was created.

The /i option ensures that processing information is displayed when the rebuild is complete.

Parent topic: Rebuild
Related information
Example of Reorganizing an Indexed File
Example of using Rebuild to convert a file
Example of validating the structure of an indexed file
Example of a Rebuild options file
Example of calling Rebuild from a COBOL program


Example of using Rebuild to convert a file

rebuild infile.dat,outfile.dat /s:c-isam /c:d1 /t:mf

In this example, Rebuild converts a C-ISAM file into the format used by this system and compresses the data part of the file.

Parent topic: Rebuild
Related information
Example of Reorganizing an Indexed File
Example of recovering a corrupt indexed file
Example of validating the structure of an indexed file
Example of a Rebuild options file
Example of calling Rebuild from a COBOL program


Example of validating the structure of an indexed file

rebuild test.dat /f

In this example Rebuild performs a full integrity check on the file, displaying full information.

Parent topic: Rebuild
Related information
Example of Reorganizing an Indexed File
Example of recovering a corrupt indexed file
Example of using Rebuild to convert a file
Example of a Rebuild options file
Example of calling Rebuild from a COBOL program


Example of a Rebuild options file

rebuild infile.dat, outfile.dat @conv.par

In this example, conv.par is an ASCII text file containing the following Rebuild options:

/k:1+20,25+5:40+12:60+3,85+10d
Parent topic: Rebuild
Related information
Example of Reorganizing an Indexed File
Example of recovering a corrupt indexed file
Example of using Rebuild to convert a file
Example of validating the structure of an indexed file
Example of calling Rebuild from a COBOL program


Example of calling Rebuild from a COBOL program

This example shows Rebuild being called from within a COBOL program.

 01 parameters pic x(600).
 01 status  pic xx comp-x.
  ...
     move "infile.dat,outfile.dat /s:lii /c:d1" to parameters
     call "CALLRB" using parameters,status
     end-call
Parent topic: Rebuild
Related information
Example of Reorganizing an Indexed File
Example of recovering a corrupt indexed file
Example of using Rebuild to convert a file
Example of validating the structure of an indexed file
Example of a Rebuild options file


Example Relative File Definition

To define a relative file with a record length of 80 characters:

 file-control.
     select relfil
         assign to "relfil.dat"
         organization is relative
         access mode is random
         relative key is relfil-key.
 file section.
 fd relfil
    record contains 80 characters.
 01 recseq-fd-record  pic x(80).
   ...
 working-storage section.
 01 relfil-key        pic 9(8) comp-x.

The record key is relfil-key. When you are randomly accessing this file, there is no KEY IS field on the READ statement, the number in relfil-key determines which record is read. For sequential access, a simple READ NEXT statement gets the next record.

Parent topic: File Handling Examples
Related information
Btrieve
Example of Data and Key Compression
External Files
File Handler
File Names
File Status
Indexed Files
Locking Files and Records
MFSORT
Rebuild
Sequential Files


Sequential Files

  • Example Record Sequential File Definition - Fixed-length Records
  • Example Record Sequential File Definition - Variable Length Records
  • Example Line Sequential File Definition
  • Example Printer Sequential File Definition
Parent topic: File Handling Examples
Related information
Btrieve
Example of Data and Key Compression
External Files
File Handler
File Names
File Status
Indexed Files
Locking Files and Records
MFSORT
Rebuild
Example Relative File Definition


Example Record Sequential File Definition - Fixed-length Records

To define a record sequential file with fixed-length records:

 file-control.
     select recseq
         assign to "recseq.dat"
         organization is record sequential.
...
 file section.
 fd recseq
    record contains 80 characters.
 01 recseq-fd-record   pic x(80).

You could simply use ORGANIZATION IS SEQUENTIAL, as record sequential is the default for sequential files, as long as the SEQUENTIAL Compiler directive is not set.

Parent topic: Sequential Files
Related information
Example Record Sequential File Definition - Variable Length Records
Example Line Sequential File Definition
Example Printer Sequential File Definition


Example Record Sequential File Definition - Variable Length Records

To define a record sequential file with variable length records:

 file control.
     select recseqv
         assign to "recseqv.dat"
         organization is record sequential.
      ...
 file section.
 fd recseqv
    record varying from 3 to 80 characters depending on ws-record-length.
 01 recseqv-fd-record  pic x(80).
   ...
 working-storage section.
 01 ws-record-length   pic 99.

You could simply use ORGANIZATION IS SEQUENTIAL, as record sequential is the default for sequential files, as long as the SEQUENTIAL Compiler directive is not set.

Parent topic: Sequential Files
Related information
Example Record Sequential File Definition - Fixed-length Records
Example Line Sequential File Definition
Example Printer Sequential File Definition


Example Line Sequential File Definition

To define a line sequential file with a record length of 80 characters:

 file-control.
     select lineseq
         assign to "line.dat"
         organization is line sequential.
         ...

 file section.
 fd lineseq
    record contains 80 characters.
 01 lineseq-fd-record  pic x(80).
Parent topic: Sequential Files
Related information
Example Record Sequential File Definition - Fixed-length Records
Example Record Sequential File Definition - Variable Length Records
Example Printer Sequential File Definition


Example Printer Sequential File Definition

To define a printer sequential file:

 file control.
     select prseq
         assign to printer "prseq.dat"
   ...
Parent topic: Sequential Files
Related information
Example Record Sequential File Definition - Fixed-length Records
Example Record Sequential File Definition - Variable Length Records
Example Line Sequential File Definition


File Handling Guide

  • Introduction
    Studio Enterprise Edition provides a file handler containing built-in file handling capabilities for all types of file organization.
  • File Organizations
    This chapter describes the file organizations supported by your COBOL system.
  • Filenames
    This chapter covers information about file names and their usage, and includes details of the search sequence employed by the run-time system to find dynamically or externally assigned files.
  • File Status
    File status codes are used by this COBOL system to indicate the success, or otherwise, of any file operation carried out by your program.
  • Sharing Files
    This chapter explains how to prevent more than one user from changing the same data at the same time in a multi-user environment through the use of file and record locks.
  • File Handler Configuration
    Certain aspects of the File Handler's behavior can be configured. You can alter these aspects by entering values in the File Handler configuration file, by setting run-time switches, or by setting environment variables.
  • File Handler and Sort APIs
    This chapter shows you how to make explicit calls to the File Handler and the Sort Module from your program.
  • MFSORT and MFJSORT Utilities
    Studio Enterprise Edition provides MFSORT, a command line sort and merge utility, and MFJSORT, an emulator for DFSORT and SYNCSORT.
  • Btrieve
    Btrieve is the file handling system from Pervasive Software Inc. For full details on Btrieve, consult the Btrieve manuals supplied by Pervasive Software.The Xfh2btr call conversion module which enables you to use the Micro Focus File Handler API to process Btrieve files is supplied with this COBOL development system. Notes: The Btrieve run-time system is not supplied with this COBOL development system. It is assumed that you already have a copy of the Btrieve run-time system or a Btrieve Developer's Kit. You are not allowed to distribute the Btrieve run-time system to any third party unless you have entered into a License Agreement with Pervasive Software. Contact Pervasive Software for more information.
  • Data and Key Compression
    Records and keys in files created using the File Handler can be compressed so they take up less physical disk space. You can enable data compression by using the File Handler to call compression routines from your program.
  • Tracing File Operations
    Use the tracing file operations, which are provided to help in investigations into problems with file handling.
Parent topic: File Handling
Related information
File Handling Examples
Working with Data Files
File Systems
Fileshare Guide


Introduction

  • Overview
    COBOL offers file handling capabilities for files of sequential, relative and indexed organization, using simple COBOL syntax. In addition, Micro Focus COBOL offers additional file handling features.
  • Micro Focus File Handler
    The Micro Focus File Handler, by default, performs all COBOL I/O operations on all the standard COBOL file organizations: sequential, relative and indexed files.
Parent topic: File Handling Guide
Related information
File Organizations
Filenames
File Status
Sharing Files
File Handler Configuration
File Handler and Sort APIs
MFSORT and MFJSORT Utilities
Btrieve
Data and Key Compression
Tracing File Operations


Overview

COBOL offers file handling capabilities for files of sequential, relative and indexed organization, using simple COBOL syntax. In addition, Micro Focus COBOL offers additional file handling features.

File Handling Feature | Use to...
Line sequential file organization | Access ASCII text files from your COBOL program
A set of COBOL system library routines | Manipulate files and directories
A set of COBOL system library routines | Handle files at the byte level
Fileshare | Access groups of files on network servers
A conversion module | Read from and write to Btrieve files
Parent topic: Introduction
Related information
Micro Focus File Handler


Micro Focus File Handler

The Micro Focus File Handler, by default, performs all COBOL I/O operations on all the standard COBOL file organizations: sequential, relative and indexed files.

In addition, you can use the File Handler's Applications Programming Interface (API) to call the file handler directly from your COBOL program, or you can create a custom file handler of your own.

Parent topic: Introduction
Related information
Overview


File Organizations

  • Overview
  • Sequential Files
  • Relative Files
  • Indexed Files
  • Fixed-length and Variable-length Records
  • File Headers
Parent topic: File Handling Guide
Related information
Introduction
Filenames
File Status
Sharing Files
File Handler Configuration
File Handler and Sort APIs
MFSORT and MFJSORT Utilities
Btrieve
Data and Key Compression
Tracing File Operations


Overview

A file is a collection of data that is, typically, stored on disk. As a logical entity, a file enables you to divide your data into meaningful groups. For example, you can use one file to hold all of a company's product information and another file to hold all personnel information. As a physical entity, a file should be considered in terms of its file organization, which refers to the way in which data is stored physically in a file. This determines the way that you access the data subsequently.

This COBOL system supports three file organizations: sequential, relative and indexed. Depending upon the file organization, you have up to three ways of accessing the data:

File Organization | Sequential Access | Random Access | Dynamic Access
Sequential | Yes | No | No
Relative | Yes | Yes | Yes
Indexed | Yes | Yes | Yes
Parent topic: File Organizations
Related information
Sequential Files
Relative Files
Indexed Files
Fixed-length and Variable-length Records
File Headers


Sequential Files

A sequential file is one in which the individual records can only be accessed sequentially, that is, in the same order as they were originally written to the file. New records are always added to the end of the file.

Several types of sequential file are supported by this COBOL system.

  • Record Sequential Files
  • Line Sequential Files
  • Printer Sequential Files
Parent topic: File Organizations
Related information
Overview
Relative Files
Indexed Files
Fixed-length and Variable-length Records
File Headers


Record Sequential Files

Record sequential files are nearly always referred to simply as sequential files because when you create a file and specify the organization as sequential, a record sequential file is created by default.

To define a file as record sequential, specify ORGANIZATION IS RECORD SEQUENTIAL in the SELECT clause for the file in your COBOL program, for example:

 select recseq assign to "recseq.dat"
     organization is record sequential.

Because record sequential is the default for sequential files, you don't need to specify ORGANIZATION IS RECORD SEQUENTIAL. As long as you do not set the SEQUENTIAL Compiler directive, you can simply use ORGANIZATION IS SEQUENTIAL.

Parent topic: Sequential Files
Related information
Line Sequential Files
Printer Sequential Files


Line Sequential Files

The primary use of line sequential files (which are also known as "text files" or "ASCII files") is for display-only data. Most PC editors, for example Notepad, produce line sequential files.

In a line sequential file, each record in the file is separated from the next by a record delimiter. The record delimiter, which comprises the carriage return (x"0D") and the line feed (x"0A") characters, is inserted after the last non-space character in each record. A WRITE statement removes trailing spaces from the data record and appends the record delimiter. A READ statement removes the record delimiter and, if necessary, pads the data record (with trailing spaces) to the record size defined by the program reading the data.

If the record size in a line sequential file is greater than the record length, the data fills the record length and on the next READ it returns more data from that record. i.e. it uses the record length and the record delimiter.

To define a file as line sequential, specify ORGANIZATION IS LINE SEQUENTIAL in the SELECT clause for the file in your COBOL program, for example:

 select lineseq assign to "lineseq.dat"
     organization is line sequential.
Parent topic: Sequential Files
Related information
Record Sequential Files
Printer Sequential Files


Printer Sequential Files

Printer sequential files are files which are destined for a printer, either directly or by spooling to a disk file. They consist of a sequence of print records with zero or more vertical positioning characters (such as line-feed) between records. A print record consists of zero or more printable characters and is terminated by a carriage return (x"0D").

With a printer sequential file, the OPEN statement causes a x"0D" to be written to the file to ensure that the printer is located at the first character position before printing the first print record. The WRITE statement causes trailing spaces to be removed from the print record before it is written to the printer with a terminating carriage return (x"0D"). The BEFORE or AFTER clause can be specified in the WRITE statement to cause one or more line-feed characters (x"0A"), a form-feed character (x"0C") or a vertical tab character (x"0B") to be sent to the printer before or after writing the print record.

Printer sequential files should not be opened for INPUT or I/O.

You can define a file as printer sequential by specifying ASSIGN TO LINE ADVANCING FILE or ASSIGN TO PRINTER in the SELECT clause, for example:

 select printseq
     assign to line advancing file "printseq.dat".
Parent topic: Sequential Files
Related information
Record Sequential Files
Line Sequential Files


Relative Files

A relative file is a file in which each record is identified by its ordinal position in the file (record 1, record 2 and so on). This means that records can be accessed randomly as well as sequentially:

  • For sequential access, simply execute a READ or WRITE statement to access the next record in the file.
  • For random access, define a data item as the relative key. Then specify in the data item the ordinal number of the record that you need to READ or WRITE.

Because records can be accessed randomly, access to relative files is fast.

Although you can declare variable length records for a relative file, this can be wasteful of disk space because the system assumes the maximum record length for all WRITE statements to the file and pads the unused character positions. This is done so that the COBOL file handling routines can quickly calculate the physical location of any record, given the record's record number in the file.

As relative files always contain fixed length records, no space is saved by specifying data compression. In fact, if data compression is specified for a relative file, it is ignored by the File Handler.

Each record in a relative file is followed by a two-byte record marker which indicates the current status of the record. The status of a record can be:

x"0D0A" - record present

x"0D00" - record deleted or never written

When you delete a record from a relative file, the record's contents are not removed immediately. The record's record marker is updated to show that it has been deleted, but the contents of the deleted record remain physically in the file until a new record is written. If you need to remove the data from the file for security reasons, follow the procedure below:

  1. Use REWRITE to overwrite the record, for example with space characters.
  2. Delete the record.

To define a relative file, specify ORGANIZATION IS RELATIVE in the SELECT clause for the file in your COBOL program.

To access records randomly, you must also:

  • Specify ACCESS MODE IS RANDOM or ACCESS MODE IS DYNAMIC in the SELECT clause for the file
  • Define a relative key in the Working-Storage Section of your program

For example:

 select relfil assign to "relfil.dat"
     organization is relative
     access mode is random
     relative key is relfil-key.
 ...
 working-storage section.
 01 relfil-key   pic 9(8) comp-x.

The example code above defines a relative file. The access mode is random and so a relative key relfil-key is defined. For random access, you must always supply a record number in the relative key, before trying to read a record from the file.

If you specify ACCESS MODE IS DYNAMIC, you can access the file both sequentially and randomly.

Parent topic: File Organizations
Related information
Overview
Sequential Files
Indexed Files
Fixed-length and Variable-length Records
File Headers


Indexed Files

An indexed file is a file in which each record includes a primary key. To distinguish one record from another, the value of the primary key must be unique for each record. Records can then be accessed randomly by specifying the value of the record's primary key. Indexed file records can also be accessed sequentially.

As well as a primary key, indexed files can contain one or more additional keys known as alternate keys. The value of a record's alternate key(s) does not have to be unique.

To define a file as indexed, specify ORGANIZATION IS INDEXED in the SELECT clause for the file in your COBOL program. You must also specify a primary key using the RECORD KEY clause:

 select idxfile assign to "idx.dat"
    organization is indexed
    record key is idxfile-record-key.

Most types of indexed file actually comprise two separate files: the data file (containing the record data) and the index file (containing the index structure). Where this is the case, the name that you specify in your COBOL program is given to the data file and the name of the associated index file is produced by adding an .idx extension to the data file name. You should avoid using the .idx extension in other contexts.

The index is built up as an inverted tree structure that grows as records are added.

With indexed files, the number of disk accesses required to locate a randomly selected record depends primarily on the number of records in the file and the length of the record key. File I/O is faster when reading the file sequentially.

We strongly recommend that you take regular backups of files of all types. However, with indexed files there are events such as media corruption that can result in only one of the two files becoming unusable. If you do lose an index file, use the Rebuild utility to recover the index from the data file and so reduce the time lost due to a failure. For more information, see the topic Rebuild.

  • Primary Keys
  • Alternate Keys
  • Duplicate Keys
  • Sparse Keys
  • Indexed File Access
Parent topic: File Organizations
Related information
Overview
Sequential Files
Relative Files
Fixed-length and Variable-length Records
File Headers
Rebuild


Primary Keys

To define the primary key of an indexed file use the RECORD KEY IS clause in the SELECT clause:

 select idxfile assign to "idx.dat"
     organization is indexed
     record key is idxfile-record-key.
Parent topic: Indexed Files
Related information
Alternate Keys
Duplicate Keys
Sparse Keys
Indexed File Access


Alternate Keys

As well as the primary key, each record can have any number of additional keys, known as alternate keys. To define an alternate key use the ALTERNATE RECORD KEY IS clause in the SELECT clause:

 select idxfile assign to "idx.dat"
     organization is indexed
     record key is idxfile-record-key
     alternate record key is idxfile-alt-key.
Parent topic: Indexed Files
Related information
Primary Keys
Duplicate Keys
Sparse Keys
Indexed File Access


Duplicate Keys

You can define keys which allow duplicate values. However, do not allow duplicates on primary keys as the value of a record's primary key must be unique.

When you use duplicate keys, be aware that there is a limit on the number of times you can specify the same value for an individual key. Each time you specify the same value for a duplicate key, an increment of one is added to the key's occurrence number. The maximum number of duplicate values permitted for an individual key varies according to the type of indexed file. For a full list of indexed file types and their characteristics, see the topic Types of Indexed Files.

The duplicate occurrence value is a unique identifier, which is added to the key, which has duplicates in order to make it unique. When a new key is added, where keys of the same value exist, then the occurrence value of the last added key is incremented by one and used for the newly added key. If keys are deleted, no change is made to the keys, which are not deleted and so if the highest occurrence of the series of duplicates is not deleted, then the highest value does not change. If the highest occurrence is deleted, then the highest occurrence value reduces to the next lower still existing occurrence value.

Your COBOL system uses the occurrence number to ensure that duplicate key records are read in the order in which they were created. Because of this, you cannot reuse an occurrence number whose record you have deleted. Therefore, you can reach the maximum number of duplicate values, even if some of those keys have already been deleted.

Some types of indexed file contain a duplicate occurrence record in the data file. Where an indexed file contains a duplicate occurrence record, each record in the data file is followed by a system record. This system record holds, for each duplicate key in that record, the occurrence number of the key. This number is just a counter of the number of times that key value has been used during the history of the file. The presence of the duplicate occurrence record makes REWRITE and DELETE operations on a record with many duplicates much faster but causes the data records of such files to be larger than those of a standard file.

To enable duplicate values to be specified for alternate keys, use WITH DUPLICATES in the ALTERNATE RECORD KEY clause in the SELECT clause:

 file-control.
     select idxfile assign to "idx.dat"
         organization is indexed
         record key is idxfile-record-key
         alternate record key is idxfile-alt-key
                                 with duplicates.
Parent topic: Indexed Files
Related information
Primary Keys
Alternate Keys
Sparse Keys
Indexed File Access
Types of Indexed File


Sparse Keys

A sparse key is a key for which no index entry is stored for a given value of that key. For example, if a key is defined as sparse when it contains all spaces, index entries for the key are not included when the part of the record it occupies contains only space characters.

Only alternate keys can be sparse.

Using this feature results in smaller index files. The larger your key(s) and the more records you have for which the alternate key has the given value, the larger your saving of disk space.

To enable sparse keys, use SUPPRESS WHEN ALL in the ALTERNATE RECORD KEY clause in the SELECT clause:

 file-control.
     select idxfile assign to "idx.dat"
         organization is indexed
         record key is idxfile-record-key
         alternate record key is idxfile-alt-key
                                 with duplicates
                                 suppress when all "A".

In this example, if a record is written for which the value of the alternate key is all As, the actual key value is not stored in the index file.

Parent topic: Indexed Files
Related information
Primary Keys
Alternate Keys
Duplicate Keys
Indexed File Access


Indexed File Access

You can use both the primary and alternate keys to read records from an indexed file, either directly (random access) or in key sequence (sequential access). The access mode can be:

  • SEQUENTIAL

    Access records in order of ascending or descending record key value (default)

  • RANDOM

    Access records according to the value of the record key

  • DYNAMIC

    Use the appropriate forms of I/O statement to switch between sequential and random access

The method of accessing an indexed file is defined using the ACCESS MODE IS clause in the SELECT clause, for example:

 file-control.
     select idxfile assign to "idx.dat"
         organization is indexed
         access mode is dynamic
         record key is idxfile-record-key
         alternate record key is idxfile-alt-key.
Parent topic: Indexed Files
Related information
Primary Keys
Alternate Keys
Duplicate Keys
Sparse Keys


Fixed-length and Variable-length Records

A file can contain:

  • Fixed-length records - all the records are exactly the same length
  • Variable-length records - the length of each record varies

Using variable-length records might enable you to save disk space. When you use fixed-length records, you need to make the record length equal to the length of the longest record. If your application generates many short records with occasional long ones, using fixed-length records wastes a lot of disk space, so variable-length records would be a better choice.

The type of record is determined as follows:

To use: | Specify the clause:
Variable-length records | RECORDING MODE IS V
Fixed-length records | RECORDING MODE IS F

Otherwise:

To use: | Specify the clause:
variable length records | RECORD IS VARYING
fixed length records | RECORD CONTAINS n CHARACTERS

Otherwise:

To use: | Specify the Compiler directive:
variable length records | RECMODE"V"
fixed length records | RECMODE"F"

Otherwise, to use variable length records, specify the RECMODE"OSVS" Compiler directive plus one of the following:

  • RECORD CONTAINS n TO m CHARACTERS
  • More than one record area of different lengths
Parent topic: File Organizations
Related information
Overview
Sequential Files
Relative Files
Indexed Files
File Headers


File Headers

A file header is a block of 128 bytes at the start of the file. Files with the following file organizations contain file headers:

  • Indexed files
  • Record sequential files with variable length records
  • Relative files with variable length records

In addition, each record in these files is preceded by a two- or four-byte record header.

Parent topic: File Organizations
Related information
Overview
Sequential Files
Relative Files
Indexed Files
Fixed-length and Variable-length Records


Filenames

  • Filename Conventions
  • Assigning Filenames
  • Filename Mapping
  • Assigning Device Names
  • Setting Up Pipes
  • External File Mapper (Mfextmap)
Parent topic: File Handling Guide
Related information
Introduction
File Organizations
File Status
Sharing Files
File Handler Configuration
File Handler and Sort APIs
MFSORT and MFJSORT Utilities
Btrieve
Data and Key Compression
Tracing File Operations


Filename Conventions

This COBOL system, and applications created with it, use the standard filename conventions of the operating system on which it runs.

This COBOL system also supports the New Technology File System (NTFS) file naming conventions. This means that each file or directory can consist of up to 254 characters and contain both space characters, other special characters and any number of periods (.). This COBOL system regards any text following the final period as an extension (or a trailing period as a space extension) and may remove it when creating its own names.

If you are thinking of using the new file naming conventions, you should be aware of the following:

  • Avoid using the following characters when you are creating Internet applications: % # ( ) @.
  • The Micro Focus COBOL products available on UNIX contain components that do not handle long filenames and filenames and folder names containing spaces. Avoid using long names and names containing spaces for files that will be published to UNIX.
  • The Oracle 1.8 version of Pro*Cobol does not support filenames that contain spaces.
Parent topic: Filenames
Related information
Assigning Filenames
Filename Mapping
Assigning Device Names
Setting Up Pipes
External File Mapper (Mfextmap)


Assigning Filenames

The ASSIGN clause in the SELECT clause is used to specify either a physical filename or a logical name which can be mapped to a physical name at run time.

There are three types of filename assignment:

  • STATIC

    The filename is specified as a literal in the ASSIGN clause

  • DYNAMIC

    The filename is specified as a data-item in the ASSIGN clause, and so can be changed by the program at run time

  • EXTERNAL

    The filename is specified as EXTERNAL in the ASSIGN clause and is resolved at run time

Run-time mapping of filenames is available for all three types of filename assignment.

  • Static Filename Assignment
  • Dynamic Filename Assignment
  • External Filename Assignment
Parent topic: Filenames
Related information
Filename Conventions
Filename Mapping
Assigning Device Names
Setting Up Pipes
External File Mapper (Mfextmap)


Static Filename Assignment

With static filename assignment, the filename is specified in the SELECT clause as a literal:

 select filename
     assign to literal.

If the filename of the physical file that you are creating contains spaces, the filename is automatically surrounded by quotes for you.

In the following example, opening stockfile causes the file warehs.buy in the current directory on the b: drive to be opened:

 select stockfile
     assign to "b:warehs.buy".

In this example, a WRITE statement causes data to be output to prn:, the first parallel printer:

 select printfile
     assign to "prn:".

In this example, opening input-file opens the file prog in the directory data (relative to the current directory):

 select input-file
     assign to "data\prog".
Parent topic: Assigning Filenames
Related information
Dynamic Filename Assignment
External Filename Assignment


Dynamic Filename Assignment

With dynamic filename assignment, the filename is specified in the SELECT clause as a COBOL data item:

 select filename
     assign to dynamic data-item
where the parameters are:
filename | The filename of the file that is to be assigned.
data-item | The name of a COBOL data item. If the data item is not explicitly declared in your program, the Compiler creates one for you, with a picture of PIC X(255). Before the OPEN statement for the file is executed, the program must give a value to the data item.

If the filename of the physical file that you are creating contains spaces, you should surround the filename with quotes - see Example 2 below.

Example 1

In the following example, the file input.dat is created in the current directory:

   ...
 select fd-in-name
     assign to dynamic ws-in-file.
       ...
 working-storage section.
 01 ws-in-file     pic x(30).
       ...
     move "input.dat" to ws-in-file.
       ...
     open output fd-in-name.

Example 2

The following example shows how to use quotes to create the file spacey filename.dat, where the filename contains spaces:

 select f1
      assign to dynamic f1-name.
...
working-storage section.
01 f1     pic x(30).
...
move """spacey  filename.dat""" to f1-name
....
open output f1.
Note: If you use the ASSIGN"DYNAMIC" Compiler directive, you can omit the word DYNAMIC from the ASSIGN clause.
Parent topic: Assigning Filenames
Related information
Static Filename Assignment
External Filename Assignment


External Filename Assignment

With external filename assignment, the filename is specified in the SELECT clause as follows:

 select filename
     assign to external external-file-reference

where the parameters are:

filename | The filename of the file that is to be assigned.
external-file-reference | A COBOL word that identifies the specified file to the external environment for possible further mapping. If external-file-reference contains one or more hyphens, all characters up to and including the last hyphen are ignored.

For further details on run-time system filename mapping, see the section Filename Mapping.

Parent topic: Assigning Filenames
Related information
Static Filename Assignment
Dynamic Filename Assignment
Filename Mapping


Filename Mapping

This COBOL system provides several ways of mapping the filename supplied by the program via the ASSIGN clause onto a different name, for greater flexibility at run time. These rely on the use of environment variables.

In this topic, the term "environment variable" should be read as including the Micro Focus extended environment variables which are enabled via use of the External File Mapper (see the section External File Mapper (Mfextmap) later in this chapter).

Before you run the program, you should give any environment variables you are using an appropriate value using the operating system SET command, for example:

set dir=d2

When presented with a filename (which may be a literal, the contents of a data item, or, in the case of the ASSIGN TO EXTERNAL syntax, an external reference), the File Handler follows this procedure:

  1. Isolates the first element of the filename, that is, all the text before the first slash character (\), all the text if the name does not include such a character or nothing if the filename starts with a slash character.
  2. If the first element begins with two dollar characters ($$), indicating that the file is located on a Fileshare server, switches the search process to that Fileshare server, and continues the filename mapping process with the next element.
  3. Removes the leading dollar character ($) if it is present, prefixes the characters "dd_" to this first element and searches for an environment variable with this name.
  4. If it does not find this environment variable and either the ASSIGN EXTERNAL syntax was used or the element began with a dollar character, looks for an environment variable with the same name as the element (minus the leading dollar character if present).
  5. If the search is unsuccessful, leaves the element unchanged, except in the case where the element begins with a dollar character and the whole filename contains at least one slash character. In this case, the whole of the first element, together with the first slash, is removed from the name.

This procedure is then repeated for the next element in the filename, and continues until all the elements in the name have been processed. The result is then considered to be the filename of the physical file.

Consider the following examples:

Filename in ASSIGN Clause | Environment Variables Searched For | Contents of Environment Variable | Filename of Physical File
dir\file1 | dd_dir | d2 | d2\file1
$dir\file1 | dd_dir;dir | d2\d4 | d2\d4\file1
dir1\dir2\file1 | dd_dir1 | d4 | d4\dir2\file1
$dir1\$dir2\file1 | First iteration: dd_dir1;dir1 Second iteration: dd_dir2;dir2 | dd_dir1 or dir1: d2\d4 dd_dir2 or dir2: d3 | d2\d4\d3\file1
file1 | dd_file1 | d2 | d2

  • Multiple Paths
Parent topic: Filenames
Related reference
Printer Output is Written to Disk
Related information
Filename Conventions
Assigning Filenames
Assigning Device Names
Setting Up Pipes
External File Mapper (Mfextmap)
External Filename Assignment


Multiple Paths

An environment variable used for filename mapping can specify multiple pathnames. This causes the system to search for subsequent files if a "file not found" condition is returned for the first path specified by the environment variable.

Consider the following example contents of an environment variable named dd_dir.

dd_dir=\a\b;\c\d;
This causes the system to search \c\d for the assigned file if a "file not found" condition is returned on \a\b.
Note:
  • If an existing file is being opened, using OPEN INPUT, OPEN I-O, OPEN EXTEND or the CBL_OPEN_FILE byte stream routine, the environment variable is expanded to the first path on which the file is found.
  • If a new file is being created, using OPEN OUTPUT, OPEN I-O, OPEN EXTEND, or the CBL_CREATE_FILE byte stream routine, the environment variable is expanded to the first path named. For files which are opened with OPEN OUTPUT, you can override this behavior by setting the SEARCHONCREATE File Handler configuration option to ON.
  • The length of each path in a path list in an environment variable must be less than or equal to the permitted maximum number of characters for a path.
Parent topic: Filename Mapping


Assigning Device Names

You can write a COBOL program to send a report directly to the printer or to transfer data across a communications port. To do this, you need to assign a device-name to your COBOL filename.

You can specify the following device-names using static, dynamic or external filename assignment:

Device-name | Description
CON | Console keyboard or screen
PRN | First parallel printer
LPT1 | First parallel printer
LPT2 | Second parallel printer
LPT3 | Third parallel printer
COM1 | First asynchronous communications port
COM2 | Second asynchronous communications port

When specifying any of these device-names, a trailing colon(:) is optional.

In the following example, read or write operations on fd-name cause data to be read from or written to the console screen:

select fd-name
   assign to "con".

In the next example, write operations on fd-name cause data to be output to lpt1:, the first parallel printer:

select fd-name
   assign to dynamic ws-filename.
   ...
   move "lpt1:" to ws-filename.
Parent topic: Filenames
Related information
Filename Conventions
Assigning Filenames
Filename Mapping
Setting Up Pipes
External File Mapper (Mfextmap)


Setting Up Pipes

You can use COBOL file syntax to launch another process (such as the dir command) and either write data to the standard input of that other process or read data coming from the standard output of the other process. The COBOL file organization must be either LINE SEQUENTIAL or RECORD SEQUENTIAL.

  • Output Pipes
  • Input Pipes
  • Two-way Pipes
Parent topic: Filenames
Related information
Filename Conventions
Assigning Filenames
Filename Mapping
Assigning Device Names
External File Mapper (Mfextmap)


Output Pipes

To launch a process and write data to its standard input, the filename must consist of the > sign followed by the name of the command. The file should be opened for output.

For example:

 select output-file
     assign to ">cmd /c sort"
     organization is line sequential.
 fd output-file.
 01 output-file-record pic x(10).
 procedure division.
     open output output-file
     write output-file-record from "Charles"
     write output-file-record from "Bill"
     write output-file-record from "Alan"
     close output-file.
Parent topic: Setting Up Pipes
Related information
Input Pipes
Two-way Pipes


Input Pipes

To launch a process and read data from its standard output, the filename must consist of the < sign followed by the name of the command. The file should be opened for input.

For example:

 select input-file
     assign to "<cmd /c dir"
     organization is line sequential.
  ...
     open input input-file
     read input-file

In this example the program launches the dir process and reads in the first line that it writes to its standard output.

Parent topic: Setting Up Pipes
Related information
Output Pipes
Two-way Pipes


Two-way Pipes

Two-way pipes combine the functions of input and output pipes. To use a two-way pipe, the filename must consist of the pipe symbol (|) followed by the name of the command. The file should be opened for input-output i-o.

For example:

 select i-o-file
     assign to "| cmd /c sort"
     organization is line sequential.
 fd i-o-file.
 01 i-o-file-record pic x(20).
 procedure division.
     open i-o i-o-file
     write i-o-file-record from "Hello world"
     write i-o-file-record from all "A"
     write i-o-file-record from all "Z"
     write i-o-file-record from x"1a"
     perform until exit
         read i-o-file
          at end
             exit perform
         end-read
         display i-o-file-record
     end-perform
     close i-o-file

In this example, the program launches the sort process and passes it three lines of text, followed by an end-of-file marker. The program then reads all three lines back from the standard output of the sort process.

Parent topic: Setting Up Pipes
Related information
Output Pipes
Input Pipes


External File Mapper (Mfextmap)

You can assign filenames externally using the External File Mapper (Mfextmap). This provides a flexible method of mapping the assigned filename used in your COBOL program to a physical filename, by enabling filename mapping to be resolved in a text file (the mapper file). Filename mappings can be altered subsequently, simply by editing the file.

select filename
   assign to external assigned-name

where the parameters are:

filename | The logical (internal) filename used by your program.
assigned-name | An entry in the mapper file.

Using the External File Mapper, rather than resolving filename assignments via operating system environment variables, reduces the amount of memory required for environment space.

  • Mapper File Structure
  • Mapper File Location
  • Activating the External File Mapper
  • Disabling The External File Mapper
Parent topic: Filenames
Related information
Filename Conventions
Assigning Filenames
Filename Mapping
Assigning Device Names
Setting Up Pipes


Mapper File Structure

Before you can use the External File Mapper, you must create an ordinary text file (use a text editor such as Notepad to do this) and call that text file mfextmap.dat.

Each line in this file contains a filename assignment and takes the following form:

assigned-name physical-name

where the parameters are:

assigned-name | The assigned filename used in your program.
physical-name | The actual name of the physical file, including the pathname.

In this file:

  • Only one assignment is allowed per line
  • At least one space must separate the assigned and physical filenames
  • There can be any number of spaces preceding the assigned filename and following the physical filename
  • Filenames that include embedded spaces must be enclosed in double-quotes: for example, myfile "my file name"
  • Where you need to specify a file handler option for a filename that includes embedded spaces, it must be included within the double-quotes enclosing the name: for example, myfile "my file name(printer)"

You can alter the contents of the mapper file during the execution of your program. The mapping information in the current version of the mapper file is always used.

Parent topic: External File Mapper (Mfextmap)
Related information
Mapper File Location
Activating the External File Mapper
Disabling The External File Mapper


Mapper File Location

If you create a mapper file, it must be called mfextmap.dat and it must be located in one of the following places:

  • In the current directory (the directory in which your program is running)
  • In a directory on the COBOL system path (pointed to by the environment variable COBDIR)
  • In a directory on the path pointed to by the environment variable MFEXTMAP

Both MFEXTMAP and COBDIR can have multiple paths defined.

If MFEXTMAP is set but the mapper file does not exist in the directory or directories to which it points, the system tries to resolve the filename by searching for an environment variable with the same name as the assigned filename used in the program.

If MFEXTMAP is not set, the system searches for the mapper file in the current directory and then along the COBDIR path. If the mapper file is not found, the system tries to resolve the filename by searching for an environment variable with the same name as the assigned filename used in the program.

Parent topic: External File Mapper (Mfextmap)
Related information
Mapper File Structure
Activating the External File Mapper
Disabling The External File Mapper


Activating the External File Mapper

To use the External File Mapper, you must:

  • Link your program with the shared run-time system
  • Create a valid mapper file

Then, to activate the External File Mapper you must set the run-time system tunable environment_mapper to TRUE. You do this by adding the following line:

set environment_mapper=TRUE

to a configuration file pointed to by the COBCONFIG_ environment variable.

For more information on run-time tunables, see the topic Run-time Tunables.

Parent topic: External File Mapper (Mfextmap)
Related reference
Run-time Tunables
Related information
Mapper File Structure
Mapper File Location
Disabling The External File Mapper


Disabling The External File Mapper

By disabling the External File Mapper you will increase the speed of your system as no disk accesses are required to search for the current version of the mapper file.

To disable the External File Mapper set the run-time system tunable environment_mapper to FALSE.

Parent topic: External File Mapper (Mfextmap)
Related information
Mapper File Structure
Mapper File Location
Activating the External File Mapper


File Status

A full list of file status codes is given in the topic File Status Codes.

  • What is File Status?
  • Defining a File Status Data Item
  • File Status Conventions
  • Extended File Status Codes
Parent topic: File Handling Guide
Related reference
File Status Codes
Related information
Introduction
File Organizations
Filenames
Sharing Files
File Handler Configuration
File Handler and Sort APIs
MFSORT and MFJSORT Utilities
Btrieve
Data and Key Compression
Tracing File Operations


What is File Status?

File status is a two-byte code that indicates how a file operation completed; either successfully, or with some form of error. If an error occurs, file status indicates the cause of the error.

If you have a file status data item defined for a file, after every input/output operation on the file (OPEN, CLOSE, READ, WRITE, REWRITE, START and DELETE) the run-time system updates it to indicate how the operation completed.

Defining a file status data item is optional. If a file status data item is not declared and a serious file error occurs, the COBOL run-time system displays an error message and aborts your program.

You should check the file status data item after each input/output operation, to see if the operation completed successfully. For example, when your program is writing to disk, there might not be enough disk space to complete the WRITE operation. If you have not defined a file status data item and you run out of disk space, the run-time system displays an error number and aborts the program. If you have a file status data item defined (for the file you are writing), it is updated and the program continues to run. The program can then check the file status data item, determine from it that the disk is full and take the appropriate action.

Parent topic: File Status
Related information
Defining a File Status Data Item
File Status Conventions
Extended File Status Codes


Defining a File Status Data Item

Each file in a program can have a file status data item associated with it by specifying FILE STATUS IS in the SELECT clause for the file and defining the file status data item in the Working-Storage Section:

 select in-file
     assign to "user.dat"
     file status is ws-file-status.
      ...
 working-storage section.
     01 ws-file-status        pic xx.

A separate data item can be used for each file or a single data item can be used for multiple files.

File status is a two-byte code. For all file status conventions, except extended file status codes, the data item is defined as two alphanumeric characters (PIC XX). For extended file status codes, the second byte contains a binary number.

The first byte of the file status data item is known as status key 1 and indicates one of the following conditions upon completion of an I/O operation:

Value | Condition
0 | Successful operation
1 | AT END
2 | Invalid key
3 | Permanent error
4 | Logic error (improper sequence of I/O operations)
9 | COBOL run-time system error message

If the first byte of the file status data item is other than 9, the second byte (known as status key 2) is an alphanumeric character.

If the first byte of the file status data item is 9, the second byte is a binary field containing a run-time system error code.

The example code that follows illustrates how file status checking is performed: first the first byte (status key 1) is interrogated; then, if more information is required, the second byte (status key 2) is interrogated.

     select recseq
         assign to "recseq.dat"
         file status is ws-file-status
         organization is record sequential.
 ...
 file section.
 fd recseq
     record contains 80 characters.
 01 recseq-fd-record    pic x(80).
 ...
 working-storage section.
 01 ws-file-status.
     05 status-key-1     pic x.
     05 status-key-2     pic x.
     05 binary-status redefines status-key-2  pic 99 comp-x.
 ...
 procedure division.
     ...
     perform check-status.
     ...
 check-status.
     evaluate status-key-1
      when "0"
         next sentence
      when "1"
         display "end of file reached"
         perform check-eof-status
      when "2"
         display "invalid key"
         perform check-inv-key-status
      when "3"
         display "permanent error"
         perform check-perm-err-status
      when "4"
         display "logic error"
      when "9"
         display "run-time-system error"
         perform check-mf-error-message
     end-evaluate.
     ...
 check-eof-status.
     if status-key-2 = "0"
         display "no next logical record"
     end-if.
     ...
 check-inv-key-status.
     evaluate status-key-2
        when "2" display "attempt to write dup key"
        when "3" display "no record found"
     end-evaluate.
     ...
 check-perm-err-status.
     if status-key-2 = "5"
         display "file not found"
     end-if.
     ...
 check-mf-error-message.
     evaluate binary-status
      when 002 display "file not open       "
      when 007 display "disk space exhausted"
      when 013 display "file not found      "
      when 024 display "disk error          "
      when 065 display "file locked         "
      when 068 display "record locked       "
      when 039 display "record inconsistent "
      when 146 display "no current record   "
      when 180 display "file malformed      "
      when 208 display "network error       "
      when 213 display "too many locks      "
      when other
         display "not error status "
         display binary-status
     end-evaluate.
Parent topic: File Status
Related information
What is File Status?
File Status Conventions
Extended File Status Codes


File Status Conventions

This COBOL system supports a number of file status conventions. Each convention has a separate set of codes defined, although there is some overlap between conventions.

The conventions supported are:

  • ANSI'85 File Status
  • ANSI'74 File Status
  • RM/COBOL
  • IBM Mainframe COBOL
  • Microsoft COBOL V2 File Status
  • ANSI'85 File Status
  • ANSI'74 File Status
  • File Status Conversions
Parent topic: File Status
Related information
What is File Status?
Defining a File Status Data Item
Extended File Status Codes


ANSI'85 File Status

If you are using the standard system loaded for ANSI'85 operation, ANSI'85 file status codes are produced by default.

Parent topic: File Status Conventions
Related information
ANSI'74 File Status
File Status Conversions


ANSI'74 File Status

If you compile your program with the Compiler directive NOANS85, ANSI'74 file status codes are produced.

If you need to use ANSI'85 syntax, but have ANSI'74 file status codes then replace the NOANS85 directive with ANS85"SYNTAX".

Parent topic: File Status Conventions
Related information
ANSI'85 File Status
File Status Conversions


File Status Conversions

For emulation purposes, you can arrange to return file status codes other than ANSI'85 and ANSI'74. To do so:

  1. Use the CONVERTSTATUS File Handler configuration option to specify the name of a program that is called to map returned status values. The program name depends upon the type of compiler:
    Compiler | CONVERTSTATUS=
    RM/COBOL | rmstat
    IBM Mainframe COBOL | hoststat
    Microsoft COBOL V2 | msstat

    You can add the CONVERTSTATUS parameter to the File Handler configuration file extfh.cfg. For more information, see the topic File Handler Configuration.

  2. If creating a linked application, link an object into the application. The object that you link depends upon the compiler:
    Compiler | Object
    RM/COBOL | rmstat.obj
    IBM Mainframe COBOL | hoststat.obj
    Microsoft COBOL V2 | msstat.obj
  3. When compiling, use the following compiler directives:
    • NOANS85
    • COBFSTATCONV
Note: A list of Microsoft COBOL V2 file status codes is given in the topic Microsoft COBOL V2 File Status Codes.
Parent topic: File Status Conventions
Related information
ANSI'85 File Status
ANSI'74 File Status
Microsoft COBOL V2 File Status Codes
File Handler Configuration


Extended File Status Codes

The ANSI'74 and ANSI'85 file status conventions are augmented with extended file status codes. Extended file status codes have the character "9" as the first byte of the file status. The second byte is a binary (COMP-X) number, which is equivalent to a run-time system error number.

Extended file status codes are written as 9/nnn where nnn is the binary number in the second byte.

For example, if you are writing a file to disk and the disk runs out of space, the ANSI'74 file status would be a "30", which translates into the error message:

Permanent error - no other information is available

This error message is very general; a "permanent error" could mean that the disk has failed, or that the disk drive door is open. So, rather than return a generic file status, this COBOL system returns an extended file status of 9/007, that is, the character "9", in the first byte, and the binary value 7 in the second, meaning "disk full".

When using ANSI'74 or ANSI'85 file status codes, the run-time system returns extended file status codes if the extended file status code is more specific.

The example code that follows illustrates how to redefine a standard file status so that it can be used as an extended file status. Assume for this example that the input file does not exist - when the OPEN INPUT statement is executed, a file status of 9/013 ("File not found") is returned.

     select in-file
         assign to "user.dat".
         file status is file-status.
        ...
 working-storage section.
 01 file-status.
     05 status-key-1             pic x.
     05 status-key-2             pic x.
     05 status-key-2-binary redefines status-key-2
                                 pic 99 comp-x.
     ...
 procedure division.
     open input in-file
     if file-status not = "00"
         if status-key-1 = "9"
             if status-key-2-binary = 13
                 display "File not found"
        ...

To display the extended file status code, move the second byte of the file status data item to a display field large enough to hold the maximum value 255:

     select in-file
         assign to "user.dat"
         file status is file-status.
 ...
 working-storage section.
 01 ans74-file-status.
     05 status-key-1              pic x.
     05 status-key-2              pic x.
     05 status-key-2-binary redefines status-key-2
                                  pic 99 comp-x.
 01 display-ext-status
     05 filler                    pic xx value "9/"
     05 display-key 2             pic 999
     ...
 procedure division.
     open input in-file
     if file-status not = "00"
         display "Error. File status =" with no advancing
         if status-key-1 = "9"
             move status-key-2-binary to display-key-2
             display display-ext-status
         else
             display file-status
         end-if
     end-if
Parent topic: File Status
Related reference
Extended File Status Codes
Related information
What is File Status?
Defining a File Status Data Item
File Status Conventions


Sharing Files

  • Sharing mode
  • Record Locking
  • File Status Codes
Parent topic: File Handling Guide
Related information
Introduction
File Organizations
Filenames
File Status
File Handler Configuration
File Handler and Sort APIs
MFSORT and MFJSORT Utilities
Btrieve
Data and Key Compression
Tracing File Operations


Sharing mode

The sharing mode indicates whether a file is to participate in file sharing and record locking.

Three sharing modes are available:

Sharing Mode | Description
SHARING WITH NO OTHER | Do not allow sharing with any other user of this file
SHARING WITH READ ONLY | Allow sharing with other users who have the file opened for input
SHARING WITH ALL OTHER | Allow sharing with all other users

For a full table showing the results when an OPEN is attempted in the various sharing modes, see the table Opening available shared files that are currently open by another file connector in the topic The OPEN Statement.

To specify one of these sharing modes, use the SHARING phrase either on an OPEN statement or as part of the SELECT clause. The SHARING phrase in the OPEN statement overrides that in the SELECT clause.

If you do not include the SHARING phrase in either the SELECT clause or the OPEN statement, the sharing mode is determined when the first of the following conditions is satisfied:

If You Specify ... | Sharing Mode
The WITH LOCK phrase on the OPEN statement | SHARING WITH NO OTHER
The LOCK MODE IS EXCLUSIVE phrase in the SELECT clause | SHARING WITH NO OTHER
Either the LOCK MODE IS MANUAL phrase or the LOCK MODE IS AUTOMATIC phrase in the SELECT clause | SHARING WITH ALL OTHER
The open mode as OUTPUT, I-O or EXTEND | SHARING WITH NO OTHER
The open mode as INPUT and the configuration option OPENINPUTSHARED set to OFF | SHARING WITH READ ONLY
The open mode as INPUT and the configuration option OPENINPUTSHARED set to ON | SHARING WITH ALL OTHER
Parent topic: Sharing Files
Related information
Record Locking
File Status Codes
The OPEN Statement


Record Locking

If file sharing is in effect, you can set locks on individual records. In this way, you can prevent other users from accessing the locked records whilst enabling these users to access other unlocked records.

Note: You cannot lock records in either a line sequential file or a file that you have opened for input.
  • Manual and Automatic Record Locking
  • Single and Multiple Record Locking
  • Handling Record Locks
  • Releasing Record Locks
Parent topic: Sharing Files
Related information
Sharing mode
File Status Codes


Manual and Automatic Record Locking

To lock a record, use either manual or automatic record locking.

  • Manual Record Locking
  • Automatic Record Locking
Parent topic: Record Locking
Related information
Single and Multiple Record Locking
Handling Record Locks
Releasing Record Locks


Manual Record Locking

If you are using manual record locking, use the READ statement to acquire a record lock.

To specify manual locking, use:

  1. The LOCK MODE IS MANUAL clause in the SELECT clause for the file
  2. The WITH LOCK clause on the READ statement

For example:

 select fd-name
     assign to "muser.dat"
     lock mode is manual
   ...
     read fd-name with lock
Parent topic: Manual and Automatic Record Locking
Related information
Automatic Record Locking


Automatic Record Locking

If you are using automatic record locking, the READ statement acquires a record lock automatically. To avoid locking a record, use the WITH NO LOCK clause in the READ statement.

Note: When the RM Compiler directive is set, automatic record locking is enabled by default.

To specify automatic locking, use the LOCK MODE IS AUTOMATIC clause in the SELECT clause for the file:

 select fd-name
     assign to "muser.dat"
     lock mode is automatic
   ...
     read fd-name
Parent topic: Manual and Automatic Record Locking
Related information
Manual Record Locking


Single and Multiple Record Locking

You can lock either a single record or multiple records.

  • Single Record Locking
  • Multiple Record Locking
Parent topic: Record Locking
Related information
Manual and Automatic Record Locking
Handling Record Locks
Releasing Record Locks


Single Record Locking

If you are using single record locking, you can hold one record lock only at any one time. Each new i-o operation on the file releases any previous lock.

To specify single record locking, do not use the WITH LOCK ON MULTIPLE RECORDS clause after either the LOCK MODE IS MANUAL clause or the LOCK MODE IS AUTOMATIC clause.

Parent topic: Single and Multiple Record Locking
Related information
Multiple Record Locking


Multiple Record Locking

Multiple record locking permits many record locks to be held at once.

To specify multiple record locking, follow either the LOCK MODE IS MANUAL clause or the LOCK MODE IS AUTOMATIC clause with the WITH LOCK ON MULTIPLE RECORDS clause. For example:

 select fd-name
     assign to "muser.dat"
     lock mode is automatic with lock on multiple records
   ...
Note:
  • If you do not use the WITH LOCK ON MULTIPLE RECORDS clause, single record locking takes effect
  • If you specify multiple record locking for a file and you use the WRITELOCK Compiler directive when you compile your program, the program also acquires a record lock whenever it accesses the file with a WRITE or REWRITE statement
Parent topic: Single and Multiple Record Locking
Related information
Single Record Locking


Handling Record Locks

By default, when a read operation encounters a locked record, the operation returns a locked record status.

The operation will update the record area to show the contents of the record unless you set the environment variable ES_RLS_FILE_SUPPORT=Y, and set the /t parameter in the Fileshare Server configuration file to zero.

After this operation, the current record pointer remains associated with the locked record, so that a following READ NEXT operation continues to try and access the same record.

The following configuration options affect this behavior:
Configuration Option | Description
IGNORELOCK | When set to ON, specifies that record locks are to be ignored when reading files open for input
RETRYLOCK | When set to ON, specifies that operations that try to read locked records should be retried until the operation is successful. Can also be set to an integer, which specifies the maximum number of retries before the operation is aborted.
LOCKTYPE | When set to 1, record locks are placed on the record itself, which means that a read operation that meets a locked record cannot return the data record. In this case the contents of the record area following the read are undefined.
SKIPLOCK | When set to ON specifies that, following a read encountering a locked record, a READ NEXT operation returns the following record
Note: To bypass the locked record, you can also use the START…KEY IS GREATER THAN.. statement.
Parent topic: Record Locking
Related information
Manual and Automatic Record Locking
Single and Multiple Record Locking
Releasing Record Locks


Releasing Record Locks

When the program that acquired the lock does one of the following, the action releases all record locks:

  • Closes the file
  • Executes a COMMIT statement
  • Executes a ROLLBACK statement
  • Executes an UNLOCK statement on the file
  • Deletes the locked record

Additionally, when the program that acquired the lock accesses any other record in the file with any file operation, except START, this action releases single record locks.

Parent topic: Record Locking
Related information
Manual and Automatic Record Locking
Single and Multiple Record Locking
Handling Record Locks


File Status Codes

If your program runs in a multi-user environment, you should always check for the following file status codes:

File Status Code | Description
9/065 | This status code is returned by an OPEN statement and indicates that the file is locked.
9/068 | This status code is returned by a READ, DELETE or REWRITE statement and indicates that the record is locked.
9/213 | This status code indicates that the maximum number of permitted locks has been reached. The maximum number of permitted locks depends on your network and/or operating system.
Parent topic: Sharing Files
Related information
Sharing mode
Record Locking


File Handler Configuration

  • Configuration File
  • Configurable Behavior
Parent topic: File Handling Guide
Related information
Introduction
File Organizations
Filenames
File Status
Sharing Files
File Handler and Sort APIs
MFSORT and MFJSORT Utilities
Btrieve
Data and Key Compression
Tracing File Operations


Configuration File

The default filename for the File Handler configuration file is extfh.cfg but you can use a different filename by setting the EXTFH environment variable. For example:

set EXTFH=c:\mydir\test.cfg
sets the filename to c:\mydir\test.cfg.
Parent topic: File Handler Configuration
Related reference
Format of the Configuration File
Related information
Configurable Behavior
Configuration File Options


Configurable Behavior

Those aspects of the File Handler's behavior which can be configured via the File Handler configuration file and require some further explanation than is given in the online help file, are detailed below.

  • Large Indexed Files
  • File Striping
  • Performance
Parent topic: File Handler Configuration
Related information
Configuration File


Large Indexed Files

By default, the File Handler can handle files that are up to a maximum of 32 Terabytes in size. However many operating systems have a limit on file size: in order to create large files on these systems, a striping option is provided. Striping splits a large logical file into as many physical files as are required (up to a limit of 256).

Parent topic: Configurable Behavior
Related information
File Striping
Performance


File Striping

The file striping option enables you to create logical files that are up to 512 Gigabytes in size. These logical files can comprise up to 256 physical files.

As these large logical files comprise multiple physical files, you cannot enable file striping on a global basis as this could lead to the operating system running out of file handles. You need to decide, therefore, the files on which you are going to use striping.

You can enable striping for a particular file by setting the STRIPING=ON option for that file in the File Handler configuration file.

  • Headers in Striped Files
  • Options
  • Examples
Parent topic: Configurable Behavior
Related information
Large Indexed Files
Performance


Headers in Striped Files

In a striped file, the header of an individual stripe is 128 bytes long. The header contains an ASCII string of the form:

Stripe number nnn of file: filename

where nnn is a three-digit number containing the stripe number, and filename is the name of the associated file.

The string is padded with spaces up to the end of the 128 byte header.

Parent topic: File Striping
Related information
Options
Examples


Options

Striping options are not case sensitive.

Note:
  • If a striped file is in use, the required striping options must be present in the File Handler configuration file each time the file is opened
  • If file striping is enabled for a file and one of the stripes is deleted (or becomes unusable for any other reason, such as disk failure), the entire file becomes unusable
  • MAXSTRIPEDIGITS
    Specifies the number of digits to be appended to the name of the base file when naming the stripes. For example, if STRIPETYPENAME is 0, 2 would give test01.dat and 5 would give test00001.dat or tes0001.dat depending on the filename limitations of the operating system. The default value of n is 2. The minimum value is 1 and the maximum value is 5.
  • MAXSTRIPEFILES
    Specifies the number of stripe files, not including the base file. By default, 17 files are created, the base file and 16 stripes. The minimum value of n is 1 and the maximum value is 255.
  • MAXSTRIPESIZE
    Specifies the maximum size in bytes of an individual stripe. The default for n is 1 Gigabyte (1073741824 bytes). The minimum value is 65536 bytes. The maximum value is currently 2 Gigabytes (2147483648 bytes).
  • STRIPE-X
    Specifies the path and size for a stripe file where x is the stripe number, path is the location at which this stripe can be found and n is the size of the stripe. If n is omitted, the size is the same as that of the previous stripe.
  • STRIPENAMETYPE
    This option specifies the file naming convention used to name the stripes. The default setting is 0.
  • STRIPING
    Specifies whether a file is a striped file. The default setting is OFF.
Parent topic: File Striping
Related information
Headers in Striped Files
Examples


MAXSTRIPEDIGITS

Syntax:

MAXSTRIPEDIGITS=n
Parent topic: Options
Related reference
MAXSTRIPEFILES
MAXSTRIPESIZE
STRIPE-X
STRIPENAMETYPE
STRIPING


MAXSTRIPEFILES

Syntax:

MAXSTRIPEFILES=n
Parent topic: Options
Related reference
MAXSTRIPEDIGITS
MAXSTRIPESIZE
STRIPE-X
STRIPENAMETYPE
STRIPING


MAXSTRIPESIZE

Syntax:

MAXSTRIPESIZE=n
Parent topic: Options
Related reference
MAXSTRIPEDIGITS
MAXSTRIPEFILES
STRIPE-X
STRIPENAMETYPE
STRIPING


STRIPE-X

Once set, the new path and size apply to all stripes until changed by another STRIPE-X option. The number following Stripe- is the stripe number, with 0 indicating the base file. For stripes other than the base file, the number must not start with a 0 character.

Syntax:

STRIPE-X=path[,n]
Parent topic: Options
Related reference
MAXSTRIPEDIGITS
MAXSTRIPEFILES
MAXSTRIPESIZE
STRIPENAMETYPE
STRIPING


STRIPENAMETYPE

Syntax:

STRIPENAMETYPE=[0/1]

Comments:

If StripeNameType is set to 0, the stripe files use the same filename as the base file, but with a stripe number appended to the basename, before the file extension. For example, if the file test.dat has 3 stripes, the base file and its stripes are called:

File | Description
test.dat | base file
test01.dat | stripe number 1
test02.dat | stripe number 2
test03.dat | stripe number 3

If the basename is too long to accommodate the stripe file number, characters are removed from the right of the basename. For example, if the file testfile.dat has 3 stripes, the file and its stripes are called:

File | Description
testfile.dat | base file
testfi01.dat | stripe number 1
testfi02.dat | stripe number 2
testfi03.dat | stripe number 3

If StripeNameType is set to 1, the stripe files use the same filename as the base file but with a stripe number appended to the filename, after the file extension. Note that the base file becomes stripe 0 and is renamed. For example, if the file test.dat has 3 stripes, the base file and its stripes are called:

File | Description
test.dat.00 | base file
test.dat.01 | stripe number 1
test.dat.02 | stripe number 2
test.dat.03 | stripe number 3
Parent topic: Options
Related reference
MAXSTRIPEDIGITS
MAXSTRIPEFILES
MAXSTRIPESIZE
STRIPE-X
STRIPING


STRIPING

Syntax:

STRIPING=[ON/OFF]
Parent topic: Options
Related reference
MAXSTRIPEDIGITS
MAXSTRIPEFILES
MAXSTRIPESIZE
STRIPE-X
STRIPENAMETYPE


Examples

Below are several examples of how to specify file striping.

Example 1

The file test.dat has 2 stripes, each of the same size:

[test.dat]
Striping=on
Stripe-1=dir2
Stripe-2=dir3

This causes test.dat to be in the current directory, test01.dat to be in dir2 and test02.dat to be in dir3.

Example 2

The file test.dat has 5 stripes:

[test.dat]
Striping=on
Stripe-0=dir1
Stripe-4=dir2

This causes test.dat to be in dir1, test01.dat to be in dir1,test02.dat to be in dir1, test03.dat to be in dir1, test04.dat to be in dir2 and test05.dat to be in dir2.

Example 3

The file test.dat has 3 stripes:

[test.dat]
Striping=on
Stripe-0=dir1,100000000
Stripe-1=dir2,200000000

This causes test.dat to be in dir1 with a file size of 100000000 bytes and test01.dat to be in dir2 with a file size of 200000000 bytes.

Parent topic: File Striping
Related information
Headers in Striped Files
Options


Performance

You can take various steps to improve the performance of the File Handler. These all involve the use of various configuration options. Details are as follows:

  • You can increase the number of indexed file nodes that are cached, as opposed to being held on disk. You specify the number of nodes with the INDEXCOUNT configuration option. We recommend a setting of 32, but you can choose a larger number up to 64, for further improvement at the expense of memory usage
  • You can stop the File Handler from obtaining a semaphore when it executes an I/O operation that does not modify the file and the file is shared. In this context a semaphore is a lock applied to a reserved location in the file, which inhibits access to the file by more than one user. This extra call impairs performance. To stop the File Handler from obtaining a semaphore, set the READSEMA configuration option to OFF.
  • You can adjust the use of record locks. By default the File Handler:
    • Returns a locked-record file status when it finds a locked record, but also returns the data in the record area
    • Tests for the presence of a file lock when it executes a read operation that does not request a lock.

    Testing for the presence of a lock is expensive in terms of performance. You can eliminate this step by the use of either of the following configuration options:

    • LOCKTYPE. Set this to 1 to prevent access to locked records.
    • IGNORELOCK. Set this to ON to stop the File Handler testing for locks when it performs a READ operation that is not itself trying to obtain a lock.

    If you set LOCKTYPE to 1, the setting of IGNORELOCK is irrelevant

  • You can force the File Handler to load an entire file into memory when it opens the file, and to execute all file operations in memory, only writing it back to disk when it is closed. You force this behavior by setting LOADONTOHEAP to ON. This setting is available only for non-shared files. You should use this setting with care and only on small files.
Parent topic: Configurable Behavior
Related information
Large Indexed Files
File Striping


File Handler and Sort APIs

  • Calling the File Handler
  • Sort Module
Parent topic: File Handling Guide
Related information
Introduction
File Organizations
Filenames
File Status
Sharing Files
File Handler Configuration
MFSORT and MFJSORT Utilities
Btrieve
Data and Key Compression
Tracing File Operations


Calling the File Handler

You can call the File Handler to perform common actions such as opening a file and reading a record in an efficient and consistent way.

  • Overview
  • Data Structures
  • Accessing the FCD
  • Operation Codes
  • Relative Byte Addressing
  • Creating Your Own File Handler
  • Dynamic Redirection to a Custom File Handler
  • Creating a New Index File
  • Sort Module
  • Compression Routines
Parent topic: File Handler and Sort APIs
Related information
Sort Module


Overview

You can make explicit calls to the Callable File Handler from your program using the following syntax:

call "EXTFH" using opcode fcd

where the parameters are:

Parameter | Description
"EXTFH" | The module name of the File Handler interface.
opcode | A File Handler operation code. See the section Operation Codes.
fcd | The data area, known as the FCD (File Control Description) which is used by the File Handler to hold details of the file being accessed. See the section Data Structures.

Before the first call, you must follow these steps:

  1. Allocate data areas for the File Control Description (FCD), the record area, the filename area and the key definition block (if the file is indexed)
  2. Initialize all the data areas to binary zeros to ensure that the File Handler does not receive invalid values
  3. Set the pointers in the FCD to point to the:
    • Record area
    • Filename area
    • Key definition block (indexed files only)

You must then follow these steps for each File Handler operation:

  1. Fill in the appropriate fields in the FCD for the selected operation code
  2. Call the File Handler
  3. Determine the success of the file I/O operation by checking the file status
  4. Process the FCD fields and/or any data in the record area
Parent topic: Calling the File Handler
Related information
Data Structures
Accessing the FCD
Operation Codes
Relative Byte Addressing
Creating Your Own File Handler
Dynamic Redirection to a Custom File Handler
Creating a New Index File
Sort Module
Compression Routines


Data Structures

The File Handler uses four data structures during file I/O operations:

Data Structure | Description
File Control Description (FCD) | A 100-byte data area containing information about the file in use.
Record area | A data area into which records are read and from which records are written.
Filename area | A data area which contains the name of the file in use, as recognized by the operating system.
Key definition block | Used by the File Handler to hold index key information during operations on indexed files.
  • File Control Description (FCD)
  • Record Area
  • Filename Area
  • Key Definition Block
Parent topic: Calling the File Handler
Related information
Overview
Accessing the FCD
Operation Codes
Relative Byte Addressing
Creating Your Own File Handler
Dynamic Redirection to a Custom File Handler
Creating a New Index File
Sort Module
Compression Routines


File Control Description (FCD)

The File Control Description (FCD) is a data area which contains information about the file in use. There are two versions of the FCD, and which one is used depends on whether your COBOL development environment is running in 32-bit or 64-bit, as shown in the following table:

COBOL Development System | FCD Used
Visual COBOL | FCD3
Mainframe Express | FCD2
32-bit Studio Enterprise Edition | FCD3
64-bit Studio Enterprise Edition | FCD3
.NET Support within Studio Enterprise Edition | FCD3
32-bit Server Express | FCD2 or FCD3
64-bit Server Express | FCD3

Both FCD2 and FCD3 format can be used in 32-bit compilations. The copybook XFHFCD.CPY defines an FCD3 record unless the program is compiled with the Compiler directive NOFCD3. If the program is compiled with the NOFCD3 directive XFHFCD.CPY defines an FCD2 record. The FCD3 record is directly and unconditionally defined in the file xfhfcd3.cpy and the FCD2 record is directly and unconditionally defined in the file xfhfcd2.cpy.

To use the File Handler your program must set up an FCD, complete the appropriate fields (these vary according to the operation code) and then call the File Handler. The File Handler returns information to your program by writing it to the appropriate fields in the FCD.

All unused or reserved areas of the FCD must be set to binary zeros.

The FCD used on the call to open a file must be the one used on all subsequent accesses to that file. You can perform multiple open operations on a file but you must use a different FCD for each open.

The FCD includes pointers (that is, USAGE POINTER data items) that point to the record area, filename area and key definition block.

Parent topic: Data Structures
Related information
Record Area
Filename Area
Key Definition Block


Record Area

The record area is a data area into which records are read, and from which records are written.

The size of the record area must be four bytes larger than the largest record in the file.

The following example shows how the FCD is set up to point to the record area:

 01 RECORD-AREA      PIC X(85).
   ...
     SET FCD-RECORD-ADDRESS TO ADDRESS OF RECORD-AREA
       ...
Parent topic: Data Structures
Related information
File Control Description (FCD)
Filename Area
Key Definition Block


Filename Area

The filename area is a data area which contains the name of the file in use, as recognized by the operating system.

It can contain drive and/or path information as well as the actual name of the file. The name must be terminated by a space.

This filename area must be filled before the first operation on the file.

The following example shows how the FCD is set up to point to the filename area:

 01 FILENAME-AREA    PIC X(65) VALUE "master.dat".
   ...
     MOVE 65 TO FCD-NAME-LENGTH
     SET FCD-FILENAME-ADDRESS TO ADDRESS OF FILENAME-AREA
       ...
Parent topic: Data Structures
Related information
File Control Description (FCD)
Record Area
Key Definition Block


Key Definition Block

The key definition block is used to pass index key information to the File Handler when opening an indexed file. It consists of three data areas.

  • Global Information Area
  • Key Definition Area
  • Component Definition Area
Parent topic: Data Structures
Related information
File Control Description (FCD)
Record Area
Filename Area


Global Information Area

The size of the key definition area and the number of keys that are in the file are held in the global information area.

Parent topic: Key Definition Block
Related reference
Global Information Area
Related information
Key Definition Area
Component Definition Area


Key Definition Area

The key definition area describes the keys used in the indexed file.

The key definition area follows the global information area and contains one key definition for each key in the file.

You must define all keys before their components.

The order in which keys are defined is important as the ordinal position of the key is used to identify it. For example, if you have an indexed file with a prime key and two alternate keys, the Key Definition area contains three key definitions: the prime key is key 0, the first alternate is key 1, and the second alternate is key 2.

Parent topic: Key Definition Block
Related reference
Key Definition Area
Related information
Global Information Area
Component Definition Area


Component Definition Area

The component definition area follows the key definition area.

It contains a definition for each key component. Each key consists of one component, unless defined as a split key, when each component of the key requires its own component definition.

The component definitions define the position and length of the key component.

For numeric keys, you can use the component definition Area to specify the numeric type. You can then use the IXNUMKEY Compiler directive to specify that keys are ordered according to numeric type (the default situation is that keys are ordered according to their alphanumeric value).

Parent topic: Key Definition Block
Related reference
Component Definition Area
Related information
Global Information Area
Key Definition Area


Accessing the FCD

When file I/O operations are performed by your program, using ordinary COBOL syntax, a File Control Description (FCD) is created automatically for each file. You can access this automatically created FCD by compiling your program with the FCDREG Compiler directive. This enables you to read or change the FCD or to use it to make explicit calls to the File Handler.

To access the FCD, you must set up an FCD definition in the Linkage Section of your program. An example FCD definition is supplied in the copybook XFHFCD.CPY. This definition can be mapped onto the FCD you need to read or alter using the following SET statement in your program:

     set address of fcd to address of fh--fcd of file

where the parameters are:

Parameter | Description
fcd | The name of the FCD definition in the Linkage Section of your program
fh--fcd | The FCD used by this COBOL system to access the file (note the double hyphen)
file | The FD name of the file

Following this SET operation, you can access the file's FCD by accessing the data items in the FCD which you set up in your Linkage Section.

Similarly, you can access the key definition block as follows:

     set address of kdb to address of fh--keydef of file

where the parameters are:

Parameter | Description
kdb | The name of the key definition block in the Linkage Section of your program
fh--keydef | The key definition used by this COBOL system to access the file (note the double hyphen)
file | The FD name of the file
Parent topic: Calling the File Handler
Related information
Overview
Data Structures
Operation Codes
Relative Byte Addressing
Creating Your Own File Handler
Dynamic Redirection to a Custom File Handler
Creating a New Index File
Sort Module
Compression Routines


Operation Codes

Each file operation which can be performed by the File Handler is identified by a two-byte operation code.

There are two types of operation code:

Type of Operation Code | Description
Standard operation codes | The codes contain x"FA" in the most significant byte. The least significant byte indicates the specific operation.
Special operation codes | The codes contain x"00" in the most significant byte. The least significant byte indicates the specific operation.

Full lists of standard and special operation codes and links to detailed information are provided in the topics Standard Operation Codes - Overview and Special Operation Codes - Overview.

Parent topic: Calling the File Handler
Related reference
Standard Operation Codes - Overview
Special Operation Codes - Overview
Related information
Overview
Data Structures
Accessing the FCD
Relative Byte Addressing
Creating Your Own File Handler
Dynamic Redirection to a Custom File Handler
Creating a New Index File
Sort Module
Compression Routines


Relative Byte Addressing

The relative byte address of a record is placed in fcd-reladdr-offset in the FCD (or fcd-reladdr-big if bit 4 of fcd-config-flags is set) by all File Handler operations that involve specific records. To use the relative byte address of a record, simply save the contents of this field after a READ operation.

Using the relative byte address is a fast method of accessing records, but has limitations of which you should be aware:

  • A relative byte address operation does not affect the current record pointer. Therefore, a READ (sequential) after a relative byte address operation returns the record after the last one accessed using normal access methods. It does not return the record after the one you accessed using the relative byte address. It is possible, however, to update the current record pointer to point to the record you accessed using relative byte addressing by setting bit 5 of fcd-config-flags in the FCD before calling the File Handler to perform the relative byte address operation.
  • Relative byte address operations update the index when a record is rewritten or deleted.
  • If a record has been deleted since the relative byte address for it was obtained, a read or write using its relative byte address usually fails. However, it is possible for it to have been replaced by a different record and for this to go undetected.

Record locking is supported with relative byte address operations.

Once you have obtained the relative byte address of a record, you can use it to perform a number of operations.

  • Read a Record
  • Rewrite a Record
  • Delete a Record
Parent topic: Calling the File Handler
Related information
Overview
Data Structures
Accessing the FCD
Operation Codes
Creating Your Own File Handler
Dynamic Redirection to a Custom File Handler
Creating a New Index File
Sort Module
Compression Routines


Read a Record

You can read a specific record from a file in two ways using the relative byte address:

  • Put the address in fcd-reladdr-offset or fcd-reladdr-big in the FCD and set bit 6 of fcd-config-flags in the FCD. If you want to update the current record pointer, set bit 5 of fcd-config-flags.
  • Perform a READ (random) WITH NO LOCK, READ (random) WITH LOCK, READ (random) WITH KEPT LOCK or READ (random) operation on the file

The READ (direct) operations work in the same way, but do not require the bits in the FCD to be set. The READ (direct) operations always return the record at the address given in the relative byte address field of the FCD and update the current record pointer.

Both of the above methods provide a way of switching the current key-of-reference to a different key. For example, if READ (sequential) operations are performed via the prime key, you can start reading via the first alternate key from the current record using the following steps:

  1. Read the next record in the file (the address of this record is in the FCD relative byte address field)
  2. Put the new key-of-reference in fcd-key-id in the FCD
  3. Perform a READ (direct) operation to return the record at this address. The key-of-reference is changed to the new one
  4. Read the next record in the file. This is the next record in the new key-of-reference index
Parent topic: Relative Byte Addressing
Related information
Rewrite a Record
Delete a Record


Rewrite a Record

You can rewrite a record to a specific address by putting that address in fcd-reladdr-offset or fcd-reladdr-big in the FCD and setting bit 6 of fcd-config-flags in the FCD.

If you need to update the current record pointer, set bit 5 of fcd-config-flags in the FCD.

You then perform a REWRITE operation.

Parent topic: Relative Byte Addressing
Related information
Read a Record
Delete a Record


Delete a Record

You can delete a record at a specific address by putting that address in fcd-reladdr-offset or fcd-reladdr-big in the FCD and setting bit 6 of fcd-config-flags in the FCD.

You then perform a DELETE operation.

Parent topic: Relative Byte Addressing
Related information
Read a Record
Rewrite a Record


Creating Your Own File Handler

You can create your own, customised, file handler and use this in place of the File Handler supplied with your COBOL system.

To force programs to use your file handler for processing COBOL I/O syntax, use the CALLFH Compiler directive. For example, if you have a file handler called USERFH, compile your programs with the directive:

CALLFH"USERFH"

This causes all COBOL I/O operations to be compiled into calls to USERFH.

Alternatively, you can create a custom file handler that is dynamically loaded and invoked at run time by the Micro Focus File Handler. This removes the need to recompile the COBOL program performing the file I/O. For more information, see the section Dynamic Redirection to a Custom File Handler.

Important:
  • You must specify the NOCANCEL directive to stop your handler being canceled at STOP RUN before all the user programs have been canceled.
  • If you use CBL_EXIT_PROC, you must set the priority to 200, so that when the application calling your file handler terminates, your file handler shuts down properly.
Parent topic: Calling the File Handler
Related reference
CANCEL
Related information
Overview
Data Structures
Accessing the FCD
Operation Codes
Relative Byte Addressing
Dynamic Redirection to a Custom File Handler
Creating a New Index File
Sort Module
Compression Routines


Dynamic Redirection to a Custom File Handler

The run-time system can load and invoke a custom file handler module without requiring the recompilation of the COBOL program performing the file I/O for which the custom file handler is to be used.

This can be enabled by either creating a list of file handlers to be called in turn or by using a configuration file that maps files to File Handlers.

  • Redirection Using Configurable DYNREDIR
  • Specifying a List of Custom File Handlers
  • Specifying Configurable Custom File Handlers
  • Writing a Custom File Handler
  • Restrictions
Parent topic: Calling the File Handler
Related reference
CANCEL
Related information
Overview
Data Structures
Accessing the FCD
Operation Codes
Relative Byte Addressing
Creating Your Own File Handler
Creating a New Index File
Sort Module
Compression Routines
Enabling Dynamic Redirection to a Custom File Handler


Redirection Using Configurable DYNREDIR

When configured in this way, files are mapped to file handlers using the fhredir.cfgfile. If custom file handlers are not present, an XFHLOG entry will be emitted and the Micro Focus File Handler will be invoked instead. Up to three different custom file handlers can be used at any given time.

Parent topic: Dynamic Redirection to a Custom File Handler
Related information
Specifying a List of Custom File Handlers
Specifying Configurable Custom File Handlers
Writing a Custom File Handler
Restrictions


Specifying a List of Custom File Handlers

To specify your a list of custom file handlers, you use the DYNREDIR environment variable, as shown below:

set DYNREDIR=mod1!ep1[:mod2!ep2[:mod3!ep3]]

where:

modn | is the module containing a custom file handler
epn | is the name of a custom file handler's entry point
Note: Parsing of the DYNREDIR environment variable stops if modn or epn is longer than 30 characters. If this happens, the custom file handler with the name that is longer than 30 characters and any custom file handlers defined after it are ignored.

For example, setting DYNREDIR as shown below specifies three separate file handlers:

set module1!userfh1:userfh2:module3!userfh3
export DYNREDIR

The file handlers specified are:

  • userfh1 in the module1.dll file
  • userfh2
  • userfh3 in the module3.dll file

If a module is configured for a given file handler, that module is loaded during Micro FocusFile Handler initialization.

Parent topic: Dynamic Redirection to a Custom File Handler
Related concepts
Redirection Using Configurable DYNREDIR
Related information
Specifying Configurable Custom File Handlers
Writing a Custom File Handler
Restrictions


Specifying Configurable Custom File Handlers

To specify your configurable custom file handlers, you use the DYNREDIR environment variable, as shown below:

set DYNREDIR=DYNCONFIG[:EXPAND]

where:

DYNCONFIG | enables configurable DYNREDIR
EXPAND | enables relative filename expansion of paths

When configurable DYNREDIR is enabled, the file/custom file handler mapping is taken from your fhredir.cfg file, which is pointed to by the environment variable FHREDIR. Entries for directories/files that use a custom file handler should be added to the file.

See the topic Configuration in the Fileshare Guide for details on mapping files to custom file handlers.

On Windows, if you compile your program and link in system programs, you also need to link in fhrsub.obj; otherwise no custom file handlers will be called.

If you want to change configuration settings for custom DYNREDIR without stopping and restarting your system, your application can make a call to CBL_CFGREAD_DYNFH. For more information, see the library routine topic CBL_CFGREAD_DYNFH.

Note:
  • Restrictions for Client configuration apply to custom file handlers.
  • Filename mappings occur prior to the call to the custom file handlers.
  • Calls to FS_LOCATE_FILE will be routed to the custom file handler.
Parent topic: Dynamic Redirection to a Custom File Handler
Related concepts
Redirection Using Configurable DYNREDIR
Related information
Specifying a List of Custom File Handlers
Writing a Custom File Handler
Restrictions


Writing a Custom File Handler

When writing a custom file handler you must ensure that it:

  • conforms to the standard Micro Focus Call Handler interface. See the section Calling the File Handler for more information.

    Additionally, once a custom file handler has determined whether or not it will perform the I/O operations for a file, it must set the RETURN-CODE to 1 (to indicate that it will perform the file's I/O operations) or to 0 (to indicate that it will not).

    If a custom file handler sets RETURN-CODE to 0, the next specified custom file handler is tried. If no other custom file handler has been specified, the file's I/O operations are processed by the File Handler.

  • is compiled with CALLFH(EXTFH), CALLFH(MFFH) or CALLFH(FHREDIR). See The CALLFH Directive for more information.
  • does not call the Micro Focus File Handler (in order to avoid problems with recursion).
Parent topic: Dynamic Redirection to a Custom File Handler
Related concepts
Redirection Using Configurable DYNREDIR
Related reference
CALLFH
Related information
Specifying a List of Custom File Handlers
Specifying Configurable Custom File Handlers
Restrictions


Restrictions

You should note the following restrictions in behavior when using your own file handler:

  • Filenames passed to the custom file handler in the FCD are as specified by the caller; that is, they are not mapped.
  • The module name and entry point name for a custom file handler can each be up to 30 characters long.
  • Custom file handlers are not supported in the .NET environment.
  • The behavior of other file handling functionality (such as XFHTRACE and Rebuild) is undefined when using custom file handlers.
  • For configurable DYNREDIR, the format of the fhredir entries are the same as for the Fileshare server and have the same limitations.
  • Configurable DYNREDIR and non-configurable DYNREDIR cannot be used at the same time.
Parent topic: Dynamic Redirection to a Custom File Handler
Related concepts
Redirection Using Configurable DYNREDIR
Related information
Specifying a List of Custom File Handlers
Specifying Configurable Custom File Handlers
Writing a Custom File Handler


Creating a New Index File

You can use special operation codes to recreate an index file from the data file part of an existing indexed file as follows:

  1. Create the new index file using CREATE INDEX FILE (special operation code x"07")
  2. Read each record from the data file using GET NEXT RECORD (special operation code x"08")
  3. For each key value in the record, add the key value to the index file using ADD KEY VALUE (special operation code x"09")

The following example shows you how to create a new index file from an existing data file:

 78 close-file                  value x"fa80"
 78 open-new-index              value x"0007".
 78 get-next-rec                value x"0008".
 78 add-key-value               value x"0009".
   ...
     move open-new-index to fh-opcode
     perform extfh-op
     move get-next-rec to fh-opcode
     perform extfh-op
     perform until fcd-status (1:1) not = "0"
         perform varying fcd-key-id from 0 by 1
                   until fcd-key-id = key-count
                      or fcd-status (1:1) not = "0"
             move add-key-value to fh-opcode
             perform extfh-op
         end-perform
         move get-next-rec to fh-opcode
         perform extfh-op
     end-perform
     move close-file to fh-opcode
     perform extfh-op
     ...
 extfh-op.
     call "EXTFH" using fh-opcode, fcd
     if fcd-status of fcd (1:1) = "1"
         move 1 to return-code
     end-if.
Parent topic: Calling the File Handler
Related information
Overview
Data Structures
Accessing the FCD
Operation Codes
Relative Byte Addressing
Creating Your Own File Handler
Dynamic Redirection to a Custom File Handler
Sort Module
Compression Routines


Sort Module

The Sort Module is a standalone sort module that enables you to sort and merge data files. It is invoked implicitly when your COBOL program uses the SORT or MERGE statements.

When you perform a SORT operation on a data file, any records with duplicate keys are returned in their original order, regardless of whether or not the DUPLICATES IN ORDER phrase was specified on the SORT statement.

To call the Callable Sort Module explicitly to sort or merge your files, include the following call statement in your program:

call "EXTSM" using function-code, sort-fcd

where the parameters are:

Parameter | Description
function-code | A two-byte code indicating the type of operation to be performed. For more information see the topic Sort Module Function Codes.
sort-fcd | The name of the Sort File Control Description (FCD) as specified in the Data Division of your program. The FCD contains pointers to the record area, filename, collating sequence, key definition block and file definition block for the file. You need to specify, in the Data Division of your program, a Sort FCD for each file involved in the SORT operation. For more information see the topic Sort File Control Description.
Parent topic: Calling the File Handler
Parent topic: File Handler and Sort APIs
Related reference
Sort Module Function Codes
Sort File Control Description
Related information
Overview
Data Structures
Accessing the FCD
Operation Codes
Relative Byte Addressing
Creating Your Own File Handler
Dynamic Redirection to a Custom File Handler
Creating a New Index File
Compression Routines
Calling the File Handler


Compression Routines

You can call the compression routines that the File Handler uses to compress data and keys in your own applications. For full details see the section Compression Routines in the chapter Data and Key Compression.

Parent topic: Calling the File Handler
Related information
Overview
Data Structures
Accessing the FCD
Operation Codes
Relative Byte Addressing
Creating Your Own File Handler
Dynamic Redirection to a Custom File Handler
Creating a New Index File
Sort Module
Compression Routines


MFSORT and MFJSORT Utilities

  • Introduction
  • DFSORT and ICETOOL Emulation
  • SYNCSORT Emulation
  • Invoking Mfsort
  • Creating a Statistics Report
  • Example Commands
  • Error Messages
Parent topic: File Handling Guide
Related information
Introduction
File Organizations
Filenames
File Status
Sharing Files
File Handler Configuration
File Handler and Sort APIs
Btrieve
Data and Key Compression
Tracing File Operations


Introduction

This COBOL system provides the following methods of sorting and merging files:

Sorting Method | Description
The run-time system COBOL sort module | The default module that executes a SORT statement in your COBOL program. It can also be called directly using the CALL statement.
MFSORT utility | A utility that you can invoke from the command line, which enables you to sort and merge data files.
MFJSORT utility | An emulator of IBM’s DFSORT and ICETOOL utilities and SYNCSORT, which supports many of their major functions .
Note: MFJSORT and MFSORT are updated with new features on a regular basis but they do not offer a complete emulation of third-party sort utilities. If there are particular features that you need to use, please contact SupportLine to establish if they are available in MFJSORT or MFSORT.
Parent topic: MFSORT and MFJSORT Utilities
Related information
DFSORT and ICETOOL Emulation
SYNCSORT Emulation
Invoking Mfsort
Creating a Statistics Report
Example Commands
Error Messages


DFSORT and ICETOOL Emulation

Note: MFJSORT and MFSORT are updated with new features on a regular basis but they do not offer a complete emulation of third-party sort utilities. If there are particular features that you need to use, please contact SupportLine to establish if they are available in MFJSORT or MFSORT.

Every reasonable effort has been made to ensure the accuracy of information relating to the emulation of IBM's DFSORT and ICETOOL at the time of publication; however, we cannot guarantee complete accuracy as these tools continue to be developed.

The MFSORT and MFJSORT utilities support the following emulation:

  • DFSORT EXEC PARM Options Emulation
  • DFSORT Program Control Emulation
  • ICETOOL Emulation
Parent topic: MFSORT and MFJSORT Utilities
Related reference
MFJSENGINE
Related information
Introduction
SYNCSORT Emulation
Invoking Mfsort
Creating a Statistics Report
Example Commands
Error Messages


DFSORT EXEC PARM Options Emulation

The MFSORT and MFJSORT utilities emulate the following PARM parameters of the EXEC statement:

  • PARM
Parent topic: DFSORT and ICETOOL Emulation


PARM

The following PARM parameters of the EXEC statement are supported.

>--,PARM=--.-CENTWIN=.-s-.---.--------<<
           |         +-f-+   |
           |                 |
           +-SIZE-.-n------+-+
           |      +-nK-----+ |
           |      +-nM-----+ |
           |      +-MAX----+ |
           |      +-MAX-m--+ |
           |      +-MAX-mK-+ |
           |      +-MAX-mM-+ |
           |                 |
           +-SKIPREC=z-------+
           |                 |
           +-STOPAFT=n-------+
           |                 |
           +-VLSHRT----------+
           |                 |
           +-Y2PAST=.-s-.----+
                    +-f-+
Note: VLSHRT is ON by default.

In this COBOL system, the following parameter fields are only parsed and ignored:

Parameter | Fields
ABEND | NOABEND |
ARESALL | (n | nK | nM)
AVGRLEN | n
BSAM |
CINV | NOCINV |
COBEXIT | (COB1 | COB2)
DSPSIZE | (MAX | n)
DYNALLOC | [ =( d | n | d, n | OFF)]
EFS | (name | NONE)
EQUALS | NOEQUALS |
E15 | =COB
E35 | =COB
FILSZ | (x | Ex | Ux)
HIRPMAX | (OPTIMAL | N | p%)
LIST | NOLIST |
LISTX | NOLISTX |
LOCALE | (name | CURRENT | NONE)
MSGDDN | ddname
MSGPRT | (ALL | CRITICAL | NONE)
ODMAXBF | (n | nK | nM)
OUTREL | NOOUTREL |
OVFLO | (RC0 | RC4 | RC16)
PAD | (RC0 | RC4 | RC16)
RC16 | (ABE)
RESALL | (n | nK | nM)
RESERVE | (n | nK | nM)
RESET | NORESET |
SDB | (LARGE | YES | INPUT | NO)
SOLRF | NOSOLRF |
SPANINC | (RC0 | RC4 | RC16)
SZERO | NOSZERO |
TRUNC | (RC0 | RC4 | RC16)
VERIFY | NOVERIFY |
VLLONG | NOVLLONG |
VLSCMP | NOVLSCMP |
NOVLSHRT |
VSAMEMT | NOVSAMEMT |
VSAMIO | NOVSAMIO |
WRKREL | NOWRKREL |
WRKSEC | NOWRKSEC |
ZDPRINT | NZDPRINT |

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.
Parent topic: DFSORT EXEC PARM Options Emulation


DFSORT Program Control Emulation

The MFSORT and MFJSORT utilities emulate the following program control statements:

  • ALTSEQ
  • DEBUG
  • END
  • INCLUDE
  • INREC
  • MERGE
  • MODS
  • OMIT
  • OPTION
  • OUTFIL
  • OUTREC
  • RECORD
  • SORT
  • SUM
Parent topic: DFSORT and ICETOOL Emulation


ALTSEQ

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

                  +--,---+
                  V      |
>--ALTSEQ--CODE=-(.-fftt-.)------<<
Parent topic: DFSORT Program Control Emulation


DEBUG

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

          +------,-------+
          V              |
>--DEBUG--.--.---------.-.-----<<
             +-ABEND---+
             +-NOABEND-+
             +-ABSTP---+

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.
Parent topic: DFSORT Program Control Emulation


END

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

>--END--<<
Parent topic: DFSORT Program Control Emulation


INCLUDE

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

>--INCLUDE--COND=-(logical-expression)-.----------.----------<<
                                       +-FORMAT=f-+

The following options for the logical-expression field are supported:

>--relational-condition1--.----------------------------------------.---<<
                          | +-------------------.---------------+  |
                          | V                                   |  |
                          +-.-,-.-AND-.--,relational-condition2-.--.
                                +-OR--+

The following options for the relational-expression field are supported:

>--.-(p1,m1.---------.,binary-operator,-.-p2,m2,format-.)----------------.-->
   |       +-,format-+                  +-constant-----+                 |
   |                                                                     |
   +-(p1,m1,.-----.-.-EQ-.-,-.-constant-.-)------------------------------+
   |        +-SS,-+ +-NE-+   +-NUM------+                                |
   |                                                                     |
   +-(p1,m1,format,-.-EQ-.-,-NUM)----------------------------------------|
   |                +-NE-+                                               |
   |                                                                     |
   +-(p1,m1,-.----.-,-bit-operator,-mask)--------------------------------|
   |         +-BI-+                                                      |
   |                                                                     |
   +-(p1,m1,-.-------------.-,-binary-operator,-.-p2,m2,-.------------.)-+
             +-date-format-+                    |        +date-format-+
                                                +-constant------------+

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.

Limitations:

The maximum field length when comparing two fields that have the same format and the same length:

Format | MFJSORT | DFSORT and SYNCSORT
All | 256 | 256
CH (only when EBCDIC) | 128 | n/a

The maximum field length when comparing two fields that have the same format and differing lengths.

Format | MFJSORT | DFSORT and SYNCSORT
CH | 128 | 256
TS, CST | 19 | 256
ZD, OT, CTO, OL, CLO, LS, CSL | 18 | 256
FS, CSF | 18 | 32
PD | 10 | 255
PD0 | 8 | 8
BI, FI | 8 | 256
Parent topic: DFSORT Program Control Emulation


INREC

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

                      +--------,-------+
                      V                |
>---INREC--.-FIELDS=-(.-item-statement-.)----.---<<
           |                                 |
           |          +--------,----------+  |
           |          V                   |  |
           +-OVERLAY=(.-overlay-statement-.)-+

The following options for the item-statement field are supported:

                     +-------------,-----------------------------------------+
                     V                                                       |
>--item-statement=--(.--.----.-.-s-----------------------------------------.-.-)--<<
                        +-c:-+ |                                           |
                               +-p-----------------------------------------+
                               |                                           |
                               +-p,m.----.---------------------------------+
                               |    +-,a-+                                 |
                               |                                           |
                               +-p,m,format.-,edit-.-----------------------+
                               |           +-,to---+                       |
                               |                                           |
                               +-p,HEX-------------------------------------+
                               |                                           |
                               +-p,m,HEX-----------------------------------+
                               |                                           |
                               +-p,m,TRAN=LTOU-----------------------------+
                               |                                           |
                               +-p,m,TRAN=UTOL-----------------------------+
                               |                                           |
                               +-p,m,TRAN=ALTSEQ---------------------------+
                               |                                           |
                               +-p,m,Y2x(c)--------------------------------+
                               |                                           |
                               +-p,m,Y2xP----------------------------------+
                               |                                           |
                               +-p,m,CHANGE=(v,(find-set)+,[NOMATCH=(set)]-+
                               |                                           |
                               +-seqnum------------------------------------+
Note: For options p,m,Y2x(c), the (c) is only parsed and ignored in this COBOL system

The following options for the overlay-statement field are supported:

                +-------------,-----------------------------------------+
                V                                                       |
>--OVERLAY--=--(.--.----.-.-s-----------------------------------------.-.-)--<<
                   +-c:-+ |                                           |
                          +-p,m---------------------------------------+
                          |                                           |
                          +-p,m.----.---------------------------------+
                          |    +-,a-+                                 |
                          |                                           |
                          +-p,m,format.-,edit-.-----------------------+
                          |           +-,to---+                       |
                          |                                           |
                          +-p,m,HEX-----------------------------------+
                          |                                           |
                          +-p,m,TRAN=LTOU-----------------------------+
                          |                                           |
                          +-p,m,TRAN=UTOL-----------------------------+
                          |                                           |
                          +-p,m,TRAN=ALTSEQ---------------------------+
                          |                                           |
                          +-p,m,Y2x(c)--------------------------------+
                          |                                           |
                          +-p,m,Y2xP----------------------------------+
                          |                                           |
                          +-p,m,CHANGE=(v,(find-set)+,[NOMATCH=(set)]-+
                          |                                           |
                          +-seqnum------------------------------------+
Note: For options p,m,Y2x(c), the (c) is only parsed and ignored in this COBOL system

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.

The following field values are supported, where applicable:

Field | Values
a (alignment) | D (doubleword aligned), F (fullword aligned), H (halfword aligned).
s (separation) | ADD, DATE, &DATE, DATE=(abcd), &DATE=(abcd), DATE1, &DATE1, DATE1P, &DATE1P, DATE2, &DATE2, DATE2P &DATE2P, DATE3, &DATE3, DATE3P, &DATE3P, DATEn, &DATEn, DATEn+r, &DATEn+r, DATEn-r, &DATEn-r, DATEn(c), &DATEn(c), DATEn(c)+r, &DATEn(c)+r, DATEn(c)-r, &DATEn(c)-r, DATEnP, DATEnP+r, &DATEnP+r, DATEnP-r, &DATEnP-r, DATENS, &DATENS, DATENS=(abc), &DATENS=(abc), DIVIDE, LITERALS, MULTIPLY, SEPERATOR CHARS, SEQNUM, SUBTRACT.
Parent topic: DFSORT Program Control Emulation


MERGE

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

>--MERGE--FIELDS=-(logical-expression)--FORMAT=f-----<<
Note: The maximum size of a merge field is 256 characters.

In this COBOL system, the following parameter fields for this control statement are only parsed and ignored:

Parameter | Fields
FIELDS | (FILSZ=x | size=y]

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.

The following options for the logical-expression field are supported:

>--relational-condition1--.----------------------------------------.---<<
                          | +-------------------.---------------+  |
                          | V                                   |  |
                          +-.-,-.-AND-.--,relational-condition2-.--.
                                +-OR--+

The following options for the relational-expression field are supported:

>--.-(p1,m1.---------.,binary-operator,-.-p2,m2,format-.)----------------.-->
   |       +-,format-+                  +-constant-----+                 |
   |                                                                     |
   +-(p1,m1,.-----.-.-EQ-.-,-.-constant-.-)------------------------------+
   |        +-SS,-+ +-NE-+   +-NUM------+                                |
   |                                                                     |
   +-(p1,m1,format,-.-EQ-.-,-NUM)----------------------------------------|
   |                +-NE-+                                               |
   |                                                                     |
   +-(p1,m1,-.----.-,-bit-operator,-mask)--------------------------------|
   |         +-BI-+                                                      |
   |                                                                     |
   +-(p1,m1,-.-------------.-,-binary-operator,-.-p2,m2,-.------------.)-+
             +-date-format-+                    |        +date-format-+
                                                +-constant------------+

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.
Parent topic: DFSORT Program Control Emulation


MODS

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

         +----------------,-------------------+
         V                                    |
>--MODS--.-.-E15-.=-(-n,m.----------------.-)-.-+-.-------------.----<<
           +-E35-+       +-,-.---.-.----.-+       +-HILEVEL=YES-+
           +-E61-+           +-s-+ +-,e-+

In this COBOL system, the following parameter fields for this control statement are only parsed and ignored:

Parameter | Fields
MODS | (E18=n, m, [s] [e])+[HILEVEL=YES] (E39=n, m, [s] [e])+[HILEVEL=YES]

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.
Parent topic: DFSORT Program Control Emulation


OMIT

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

>--OMIT--COND=--(logical-expression)-.----------.----------<<
                                     +-FORMAT=f-+

The following options for the logical-expression field are supported:

>--relational-condition1--.----------------------------------------.---<<
                          | +-------------------.---------------+  |
                          | V                                   |  |
                          +-.-,-.-AND-.--,relational-condition2-.--.
                                +-OR--+

The following options for the relational-expression field are supported:

>--.-(p1,m1.---------.,binary-operator,-.-p2,m2,format-.)----------------.-->
   |       +-,format-+                  +-constant-----+                 |
   |                                                                     |
   +-(p1,m1,.-----.-.-EQ-.-,-.-constant-.-)------------------------------+
   |        +-SS,-+ +-NE-+   +-NUM------+                                |
   |                                                                     |
   +-(p1,m1,format,-.-EQ-.-,-NUM)----------------------------------------|
   |                +-NE-+                                               |
   |                                                                     |
   +-(p1,m1,-.----.-,-bit-operator,-mask)--------------------------------|
   |         +-BI-+                                                      |
   |                                                                     |
   +-(p1,m1,-.-------------.-,-binary-operator,-.-p2,m2,-.------------.)-+
             +-date-format-+                    |        +date-format-+
                                                +-constant------------+

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.

Limitations:

The maximum field length when comparing two fields that have the same format and the same length:

Format | MFJSORT | DFSORT and SYNCSORT
All | 256 | 256
CH (only when EBCDIC) | 128 | n/a

The maximum field length when comparing two fields that have the same format and differing lengths.

Format | MFJSORT | DFSORT and SYNCSORT
CH | 128 | 256
TS, CST | 19 | 256
ZD, OT, CTO, OL, CLO, LS, CSL | 18 | 256
FS, CSF | 18 | 32
PD | 10 | 255
PD0 | 8 | 8
BI, FI | 8 | 256
Parent topic: DFSORT Program Control Emulation


OPTION

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

           +---------,-------------+
           V                       |
>--OPTION--.--.-CENTWIN---------.--.----------<<
              |                 |
              +-COPY------------+
              |                 |
              +-EFS=.-name-.----+
              |     +-NONE-+    |
              |                 |
              +-.-EQUALS---.----+
              | +-NOEQUALS-+    |
              |                 |
              +-OVFLO=.-RC0--.--+
              |       +-RC4--+  |
              |       +-RC16-+  |
                 |                 |
              +--SKIPREC=z------+
              |                 |
              +--STOPAFT=n------+
              |                 |
              +--Y2PAST=.-s-.---+
              |         +-f-+   |
              |                 |
              +-.-ZDPRINT--.----+
              | +-NZDPRINT-+    |
              |                 |
              +-VLSHRT----------+
Note: VLSHRT is ON by default.

In this COBOL system, the following parameter fields for this control statement are only parsed and ignored:

Parameter | Fields
ARESALL | (n | nK | nM)
ARESINV | (n | nK | nM)
AVGRLEN | n
CHALT |
NOCHALT |
CHECK |
NOCHECK |
CINV |
NOCINV |
CKPT |
COBEXIT | (COB1 | COB2)
DSA | n
DSPSIZE | MAX
DYNALLOC | [=(d | n | d,n | OFF)]
EXITCK | (STRONG | WEAK)
FILSZ | (x | Ex | Ux)
SIZE | (y | Ey | Uy)
HIRPMAX | (OPTIMAL | n | P%)
LIST |
NOLIST |
LISTX |
NOLISTX |
LOCALE | (name | CURRENT | NONE)
MAINSIZE | (n | nK | nM | MAX)
MOSIZE | (MAX | n | p%)
MSGDDN | ddname
MSGPRT | (ALL | NONE | CRITICAL)
PRINT |
NOBLKSET |
NOOUTREL |
NOOUTSEC |
NULLOUT | (RC0 | RC4 | RC16)
ODMAXBF | (n | nK | nM)
PAD | (RC0 | RC4 | RC16)
RESALL | (n | nK | nM)
RESET |
NORESET |
RESINV | (n | nK | nM)
SDB | (LARGE | YES | INPUT | NO)
SMF | (SHORT | FULL | NO)
SOLRF |
NOSOLRF |
SORTDD | cccc
SORTIN | ddname
SORTOUT | ddname
SPANINC | (RC0 | RC4 | RC16)
SZERO |
NOSZERO |
TRUNC | (RC0 | RC4 | RC16)
USEWKDD |
VERIFY |
NOVERIFY |
VLLONG |
NOVLLONG |
VLSCMP |
NOVLSCMP |
NOVLSHRT |
VSAMEMT |
NVSAMEMT |
VSAMIO |
NOVSAMIO |
WRKREL |
NOWRKREL |
WRKSEC |
NOWRKSEC |

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.
Parent topic: DFSORT Program Control Emulation


OUTFIL

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

           +----------------------------,-----------------------------------+
           |                                                                |
           |             +---,----+                                         |
           V             V        |                                         |
>--OUTFIL--.--.--FNAMES=-.-ddname-.---------------------------------------.-.----------<<
              |                                                           |
              |         +---,-----+                                       |
              |         V         |                                       |
              +--FILES=-.-.-d---.-.---------------------------------------+
              |           +-dd--+                                         |
              |           +-OUT-+                                         |
              |                                                           |
              +--STARTREC=-n----------------------------------------------+
              |                                                           |
              +-ENDREC=-n-------------------------------------------------+
              |                                                           |
              |           +------,---------+                              |
              |           V                |                              |
              +--OUTREC=-(.-item-statement-.)-.----------.-.------------.-+
              |                               +-,VTOF----+ +-VFILL=byte-+ |
              |                               +-,CONVERT-+                |
              |            +-------,--------+                             |
              |            V                |                             |
              +--OVERLAY=-(.-item-statement-.)----------------------------+
              |                                                           |
              |                                                           |
              |                                                           |
              +-.-INCLUDE=-.-(-logical-expression-)-.---.-----------------+
              | |          +-ALL--------------------+   |                 |
              | |          +-NONE-------------------+   |                 |
              | |                                       |                 |
              | |                                       |                 |
              + +-OMIT=-.-(logical-expression-)-.-------+                 |
              |         +-ALL-------------------+                         |
              |         +-NONE------------------+                         |
              |                                                           |
              +--SAVE-----------------------------------------------------+
              |                                                           |
              +--FTOV-----------------------------------------------------+
              |                                                           |
              +--VLTRIM=byte----------------------------------------------+
              |                                                           |
              +--SPLIT----------------------------------------------------+
              |                                                           |
              +--LINES=n--------------------------------------------------+
              |                                                           |
              |           +--------,--------+                             |
              |           V                 |                             |
              +--HEADERn=-.-(-header-item-)-.-----------------------------+
              |                                                           |
              |            +-------,----------+                           |
              |            V                  |                           |
              +--TRAILERn=-.-(-trailer-item-)-.---------------------------+
              |                                                           |
              |            +-------,----------+                           |
              |            V                  |                           |
              +--SECTIONS=-.-(-section-item-)-.---------------------------|
              |                                                           |
              +--NODETAIL-------------------------------------------------|
              |                                                           |
              +--REMOVECC-------------------------------------------------|
              |                                                           |
              +--CONVERT--------------------------------------------------+
Note: The maximum number of OUTFILs is 2048.

The following options for the item-statement field are supported:

                     +-------------,-----------------------------------------+
                     V                                                       |
>--item-statement=--(.--.----.-.-s-----------------------------------------.-.-)--<<
                        +-c:-+ |                                           |
                               +-p-----------------------------------------+
                               |                                           |
                               +-p,m.----.---------------------------------+
                               |    +-,a-+                                 |
                               |                                           |
                               +-p,m,format.-,edit-.-----------------------+
                               |           +-,to---+                       |
                               |                                           |
                               +-p,HEX-------------------------------------+
                               |                                           |
                               +-p,m,HEX-----------------------------------+
                               |                                           |
                               +-p,m,TRAN=LTOU-----------------------------+
                               |                                           |
                               +-p,m,TRAN=UTOL-----------------------------+
                               |                                           |
                               +-p,m,TRAN=ALTSEQ---------------------------+
                               |                                           |
                               +-p,m,Y2x(c)--------------------------------+
                               |                                           |
                               +-p,m,Y2xP----------------------------------+
                               |                                           |
                               +-p,m,CHANGE=(v,(find-set)+,[NOMATCH=(set)]-+
                               |                                           |
                               +-seqnum------------------------------------+
Note: For options p,m,Y2x(c), the (c) is only parsed and ignored in this COBOL system

The following field values are supported, where applicable:

Field | Values
a (alignment) | D (doubleword aligned), F (fullword aligned), H (halfword aligned).
s (separation) | ADD, DATE, &DATE, DATE=(abcd), &DATE=(abcd), DATE1, &DATE1, DATE1P, &DATE1P, DATE2, &DATE2, DATE2P &DATE2P, DATE3, &DATE3, DATE3P, &DATE3P, DATEn, &DATEn, DATEn+r, &DATEn+r, DATEn-r, &DATEn-r, DATEn(c), &DATEn(c), DATEn(c)+r, &DATEn(c)+r, DATEn(c)-r, &DATEn(c)-r, DATEnP, DATEnP+r, &DATEnP+r, DATEnP-r, &DATEnP-r, DATENS, &DATENS, DATENS=(abc), &DATENS=(abc), DIVIDE, LITERALS, MULTIPLY, SEPERATOR CHARS, SEQNUM, SUBTRACT.

The following options for the logical-expression field are supported:

>--relational-condition1--.----------------------------------------.---<<
                          | +-------------------.---------------+  |
                          | V                                   |  |
                          +-.-,-.-AND-.--,relational-condition2-.--.
                                +-OR--+

The following options for the relational-expression field are supported:

>--.-(p1,m1.---------.,binary-operator,-.-p2,m2,format-.)----------------.-->
   |       +-,format-+                  +-constant-----+                 |
   |                                                                     |
   +-(p1,m1,.-----.-.-EQ-.-,-.-constant-.-)------------------------------+
   |        +-SS,-+ +-NE-+   +-NUM------+                                |
   |                                                                     |
   +-(p1,m1,format,-.-EQ-.-,-NUM)----------------------------------------|
   |                +-NE-+                                               |
   |                                                                     |
   +-(p1,m1,-.----.-,-bit-operator,-mask)--------------------------------|
   |         +-BI-+                                                      |
   |                                                                     |
   +-(p1,m1,-.-------------.-,-binary-operator,-.-p2,m2,-.------------.)-+
             +-date-format-+                    |        +date-format-+
                                                +-constant------------+

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.

The following options for the header item are supported:

              +-------------,--------------------+
              V                                  |
>--HEADERn=--(.--.----.-.-r------------------.-)-.--<<
                 +-c:-+ +-.-DATE----------.--+
                        | +-&DATE---------+  |
                        | +-DATE=(abcd)---+  |
                        | +-&DATE=(abcd)--+  |
                        | +-DATENS=(abc)--+  |
                        | +-&DATENS=(abc)-+  |
                        |                    |
                        +-.-TIME--.----------+
                        | +-&TIME-+          |
                        |                    |
                        +-.-PAGE--.----------+
                          +-&PAGE-+

The following options for a trailer item are supported:

               +-------------,----------------------------------+
               V                                                |
>--TRAILERn=--(.--.----.-.-r--------------------------------.-)-.--<<
                  +-c:-+ +-.-DATE----------.----------------+
                         | +-&DATE---------+                |
                         | +-DATE=(abcd)---+                |
                         | +-&DATE=(abcd)--+                |
                         | +-DATENS=(abc)--+                |
                         | +-&DATENS=(abc)-+                |
                         |                                  |
                         +-.-TIME--.------------------------+
                         | +-&TIME-+                        |
                         |                                  |
                         +-.-PAGE--.------------------------+
                         | +-&PAGE-+                        |
                         |                                  |
                         +-.-COUNT-------.------------------|
                         | +-COUNT=edit--+                  |
                         |                                  |
                         +-.-SUBCOUNT-----------.-----------|
                         | +-SUBCOUNT15---------+           |
                         | +-SUBCOUNT=(.-edit-.)+           |
                         |             +-to---+             |
                         |                                  |
                         +-.-TOTAL-.=-(p,m,f)---------------+
                         | +-TOT---+                        |
                         |                                  |
                         +-MIN=(p,m,f)----------------------+
                         |                                  |
                         +-MAX=(p,m,f)----------------------+
                         |                                  |
                         +-AVG=(p,m,f)----------------------+
                         |                                  |
                         +--.-SUB------.=-(p,m,f.-------.)--+
                         |  +-SUBTOT---+        +-,edit-+   |
                         |  +-SUBTOTAL-+        +-,to---+   |
                         |                                  |
                         +--SUBMIN=-(p,m,f.-------.)--------+
                         |                +-,edit-+         |
                         |                +-,to---+         |
                         |                                  |
                         +--SUBMAX=-(p,m,f.-------.)--------+
                         |                +-,edit-+         |
                         |                +-,to---+         |
                         |                                  |
                         +--SUBAVG=-(p,m,f.-------.)--------+
                         |                +-,edit-+         |
                         |                +-,to---+         |
                         +----------------------------------+
Note: See the Limitations section for the COUNT and SUBCOUNT values, and the TOTAL fields.

The following options for a sections item are supported:

              +------------------------------,--------------------------+
              |     +------------------------,------------------------+ |
              V     V                                                 | |
>--SECTIONS=-(.-p,m-.--.--------------------------------------------.-.-.)----<<
                       +-SKIP=.-P--.--------------------------------+
                       |      +-L--+                                |
                       |      +-nL-+                                |
                       |          +-----,-------+                   |
                       |          V             |                   |
                       +-HEADER3=(.-header-item-.)--.------------.--+
                       |                            +-,-PAGEHEAD-+  |
                       |           +-----,-------+                  |
                       |           V             |                  |
                       +-TRAILER3=(.-header-item-.)-----------------+

Limitations:

  • The maximum length of COUNT and SUBCOUNT values is 9 digits.
  • The maximum length of the TOTAL fields:
    TOTAL field formats | MFJSORT | DFSORT
    Length (m) | Digits (d) | Length (m) | Digits (d)
    ZD | 1-15 | *Maximum 18. | 1-15 | 15
    ZD | 16-31 | 16-31 | 31
    PD | 1-8 | 1-8 | 15
    PD | 9-16 | 9-16 | 31
    BI | 1-4 | 1-4 | 10
    BI | 5-8 | 5-8 | 20
    FI | 1-4 | 1-4 | 10
    FI | 5-8 | 5-8 | 20
    FL | 4 or 8 | 4 or 8 | 20
    CSF, FS | 1-15 | 1-15 | 15
    CSF, FS | 16-32 | 16-32 | 31

    * MFJSORT will display the total to the same amount of digits as specified in the length.

Parent topic: DFSORT Program Control Emulation


OUTREC

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

                      +--------,-------+
                      V                |
>--OUTREC--.-FIELDS=-(.-item-statement-.)----.---<<
           |                                 |
           |          +--------,----------+  |
           |          V                   |  |
           +-OVERLAY=(.-overlay-statement-.)-+

The following options for the item-statement field are supported:

                     +-------------,-----------------------------------------+
                     V                                                       |
>--item-statement=--(.--.----.-.-s-----------------------------------------.-.-)--<<
                        +-c:-+ |                                           |
                               +-p-----------------------------------------+
                               |                                           |
                               +-p,m.----.---------------------------------+
                               |    +-,a-+                                 |
                               |                                           |
                               +-p,m,format.-,edit-.-----------------------+
                               |           +-,to---+                       |
                               |                                           |
                               +-p,HEX-------------------------------------+
                               |                                           |
                               +-p,m,HEX-----------------------------------+
                               |                                           |
                               +-p,m,TRAN=LTOU-----------------------------+
                               |                                           |
                               +-p,m,TRAN=UTOL-----------------------------+
                               |                                           |
                               +-p,m,TRAN=ALTSEQ---------------------------+
                               |                                           |
                               +-p,m,Y2x(c)--------------------------------+
                               |                                           |
                               +-p,m,Y2xP----------------------------------+
                               |                                           |
                               +-p,m,CHANGE=(v,(find-set)+,[NOMATCH=(set)]-+
                               |                                           |
                               +-seqnum------------------------------------+
Note: For options p,m,Y2x(c), the (c) is only parsed and ignored in this COBOL system

The following options for the overlay-statement field are supported:

                +-------------,-----------------------------------------+
                V                                                       |
>--OVERLAY--=--(.--.----.-.-s-----------------------------------------.-.-)--<<
                   +-c:-+ |                                           |
                          +-p,m---------------------------------------+
                          |                                           |
                          +-p,m.----.---------------------------------+
                          |    +-,a-+                                 |
                          |                                           |
                          +-p,m,format.-,edit-.-----------------------+
                          |           +-,to---+                       |
                          |                                           |
                          +-p,m,HEX-----------------------------------+
                          |                                           |
                          +-p,m,TRAN=LTOU-----------------------------+
                          |                                           |
                          +-p,m,TRAN=UTOL-----------------------------+
                          |                                           |
                          +-p,m,TRAN=ALTSEQ---------------------------+
                          |                                           |
                          +-p,m,Y2x(c)--------------------------------+
                          |                                           |
                          +-p,m,Y2xP----------------------------------+
                          |                                           |
                          +-p,m,CHANGE=(v,(find-set)+,[NOMATCH=(set)]-+
                          |                                           |
                          +-seqnum------------------------------------+
Note: For options p,m,Y2x(c), the (c) is only parsed and ignored in this COBOL system

The following field values are supported, where applicable:

Field | Values
a (alignment) | D (doubleword aligned), F (fullword aligned), H (halfword aligned).
s (separation) | ADD, DATE, &DATE, DATE=(abcd), &DATE=(abcd), DATE1, &DATE1, DATE1P, &DATE1P, DATE2, &DATE2, DATE2P &DATE2P, DATE3, &DATE3, DATE3P, &DATE3P, DATEn, &DATEn, DATEn+r, &DATEn+r, DATEn-r, &DATEn-r, DATEn(c), &DATEn(c), DATEn(c)+r, &DATEn(c)+r, DATEn(c)-r, &DATEn(c)-r, DATEnP, DATEnP+r, &DATEnP+r, DATEnP-r, &DATEnP-r, DATENS, &DATENS, DATENS=(abc), &DATENS=(abc), DIVIDE, LITERALS, MULTIPLY, SEPERATOR CHARS, SEQNUM, SUBTRACT.
Parent topic: DFSORT Program Control Emulation


RECORD

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

>--RECORD--.-TYPE=-.-F-.--------------------.----<<
           |       +-V-+                    |
           +-.--------.--LENGTH=(L1,...,L3)-+
           | +-TYPE=F-+                     |
           +-.--------.--LENGTH=(L1,...,L7)-+
             +-TYPE=V-+
Parent topic: DFSORT Program Control Emulation


SORT

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

                    +---,---+                   +---------,------------+
                    V       |                   V                      |
>--SORT--FIELDS=-.-(.-p,m,f-.)----------------.-.--.-.-EQUALS---.---.--.----<<
                 |                            |    + +-NOEQUALS-+   |
                 |  +--,--------+             |    |                |
                 |  V           |             |    +-SKIPREC=z------+
                 +-(.-p,m,.---.-.)-,-FORMAT=f-+    +-STOPAFT=n------+
                 |        +-f-+               |    +-Y2PAST=-.-s-.--+
                 +-COPY-----------------------+    |         +-f-+  |
                                                   +-CENTWIN=-.-s-.-+
                                                              +-f-+
Note: The maximum size of a sort field is 256 characters.

In this COBOL system, the following parameter fields for this control statement are only parsed and ignored:

Parameter | Fields
FIELDS | CKPT DYNALLOC [=(d | n | d, n | OFF)] FILSZ = (x | Ex | Ux) SIZE = (y | Ey | Uy)

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.
Parent topic: DFSORT Program Control Emulation


SUM

The following parameters of this DFSORT control statement are supported in MFSORT and MFJSORT:

                   +---,---+
                   V       |
>--SUM--FIELDS=-.-(.-p,m,f-.)----------------.----<<
                |                            |
                |  +--,--------+             |
                |  V           |             |
                +-(.-p,m,.---.-.)-,-FORMAT=f-+
                |        +-f-+               |
                +-NONE-----------------------+
Restriction: The maximum number of SUM fields is 100 and the maximum SUM field length is 18.

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.
Parent topic: DFSORT Program Control Emulation


ICETOOL Emulation

The MFSORT and MFJSORT utilities support the following ICETOOL operators.

Note: Not each operator is fully supported. There is no support for parameters which are not listed.
  • COPY
  • COUNT
  • DISPLAY
  • OCCUR
  • RANGE
  • SELECT
  • SORT
  • STATS
  • UNIQUE
Parent topic: DFSORT and ICETOOL Emulation


COPY

The following parameters of this ICETOOL operator are supported in MFSORT and MFJSORT:

                              +---,---+
                              V       |
>--COPY--FROM(indd)-.-.--TO-(-.-outdd-.-)-----------.-.----<<
                    | +-USING(xxxx)-----------------+ |
                    | |                             | |
                    | |      +----,--+              | |
                    | |      V       |              | |
                    | +-TO-(-.-outdd-.-)-USING(xxx)-+ |
                    |                                 |
                    +-.-------------.-----------------+
                    | +-VSAMTYPE(x)-+                 |
                    |                                 |
                    +-.--------.----------------------+
                      +-SERIAL-+

Limits and Restrictions:

Parameter | Restriction
outdd | Maximum outdd count is 10
LOCALE(name), LOCALE(CURRENT), and LOCALE(NONE) | These parameters are parsed but ignored.
Parent topic: ICETOOL Emulation


COUNT

The following parameters of this ICETOOL operator are supported in MFSORT and MFJSORT:

>-COUNT--FROM(indd)-.--.-------------.--.------<<
                    |  +-USING(xxxx)-+  |
                    |                   |
                    +-.-------------.---+
                    | +-VSAMTYPE(x)-+   |
                    |                   |
                    +-.------.----------+
                    | +-RC4--+          |
                    | +-RC12-+          |
                    |                   |
                    +-.-------------.---+
                      +-EMPTY-------+
                      +-NOTEMPTY----+
                      +-HIGHER(x)---+
                      +-LOWER(y)----+
                      +-EQUAL(v)----+
                      +-NOTEQUAL(w)-+

Limits and Restrictions:

Parameter | Restriction
LOCALE(name), LOCALE(CURRENT), and LOCALE(NONE) | These parameters are parsed but ignored.
Parent topic: ICETOOL Emulation


DISPLAY

The following parameters of this ICETOOL operator are supported in MFSORT and MFJSORT:

                          +-----------,--------------+
                          V                          |
>--DISPLAY--FROM(indd)--.-.-.--ON(p,m,f)-----------.-.-.----<<
                        |   +--ON(p,m,f,formatting-+   |
                        |   +--ON(p,m,HEX)---------+   |
                        |   +--ON(VLEN)------------+   |
                        |   +--ON(NUM)-------------+   |
                        |                              |
                        +-LIST(listdd)-----------------+
                        |                              |
                        | +------,--------------+      |
                        | V                     |      |
                        +-.-.-----------------.-.------+
                        |   +-TITLE('string')-+        |
                        |                              |
                        +-.------.---------------------+
                        | +-PAGE-+                     |
                        |                              |
                        +-.------------.---------------+
                        | +-DATE-------+               |
                        | +-DATE(abcd)-+               |
                        |                              |
                        +-.-----------.----------------+
                        | +-TIME------+                |
                        | +-TIME(abc)-+                |
                        |                              |
                        +-.-------.--------------------+
                        | +-BLANK-+                    |
                        | +-PLUS--+                    |
                        |                              |
                        | +----------,-----------+     |
                        | V                      |     |
                        +-.-.------------------.-.-----+
                        |   +-HEADER('string')-+       |
                        |   +-HEADER(NONE)-----+       |
                        |   +-NOHEADER---------+       |
                        |                              |
                        +-.----------.-----------------+
                        | +-LINES(n)-+                 |
                        |                              |
                        +-.-----------------.----------+
                        | +-TOTAL('string')-+          |
                        |                              |
                        +-.-------------------.--------+
                        | +-MINIMUM('string')-+        |
                        |                              |
                        +-.-------------------.--------+
                        | +-MAXIMUM('string')-+        |
                        |                              |
                        +-.-------------------.--------+
                        | +-AVERAGE('string')-+        |
                        |                              |
                        +-.----------.-----------------+
                        | +-LIMIT(n)-+                 |
                        |                              |
                        +-.-------------.--------------+
                        | +-VSAMTYPE(x)-+              |
                        |                              |
                        +-.----------.-----------------+
                        | +-WIDTH(n)-+                 |
                        |                              |
                        +-.--------------.-------------+
                        | +-BREAK(p.m.f)-+             |
                        |                              |
                        +-.-----------------.----------+
                        | +-BTITLE('string')+          |
                        |                              |
                        +-.-----------------.----------+
                        | +-BTOTAL('string')+          |
                        |                              |
                        +-.-------.--------------------+
                          +-UZERO-+

Limits and Restrictions:

Parameter | Restriction
ON | Maximum ON count of 20
HEADER('string') | Maximum string size of 50
LINES(n) | Range of n = 9-1000
WIDTH(n) | Range of n = 121-2048
TITLE('string') | Maximum TITLE('string') count is 3
Parent topic: ICETOOL Emulation


OCCUR

The following parameters of this ICETOOL operator are supported in MFSORT and MFJSORT:

                             +-----------,--------------+
                             V                          |
>--.-OCCUR--.--FROM(indd)--.-.-.-ON(p,m,f)------------.-.-.-----<<
   +-OCCURS-+              |   +-ON(p,m,f,formatting)-+   |
                           |   +-ON(p,m,HEX)----------+   |
                           |   +-ON(VLEN)-------------+   |
                           |   +-ON(VALCNT)-----------+   |
                           |                              |
                           +---LIST(listdd)---------------+
                           |                              |
                           | +-------,-------------+      |
                           | V                     |      |
                           +-.-.-----------------.-.------+
                           |   +-TITLE('string')-+        |
                           |                              |
                           +-.------.---------------------+
                           | +-PAGE-+                     |
                           |                              |
                           +-.------------.---------------+
                           | +-DATE-------+               |
                           | +-DATE(abcd)-+               |
                           |                              |
                           +-.-----------.----------------+
                           | +-TIME------+                |
                           | +-TIME(abc)-+                |
                           |                              |
                           +-.-------.--------------------+
                           | +-BLANK-+                    |
                           | +-PLUS--+                    |
                           |                              |
                           | +----------,-----------+     |
                           | V                      |     |
                           +-.-.------------------.-.-----+
                           |   +-HEADER('string')-+       |
                           |   +-HEADER(NONE)-----+       |
                           |   +-NOHEADER---------+       |
                           |                              |
                           +-.----------.-----------------+
                           | +-LINES(n)-+                 |
                           |                              |
                           +-.-------------.--------------+
                           | +-VSAMTYPE(x)-+              |
                           |                              |
                           +-.----------.-----------------+
                           | +-WIDTH(n)-+                 |
                           |                              |
                           +-.-------.--------------------+
                           | +-UZERO-+                    |
                           |                              |
                           +-.-----------.----------------+
                             +-ALLDUPS---+
                             +-NODUPS----+
                             +-HIGHER(x)-+
                             +-LOWER(y)--+
                             +-EQUAL(v)--+

Limits and Restrictions

Parameter | Restriction
ON | Maximum ON count of 20
HEADER('string') | Maximum string size of 50
LINES(n) | Range of n = 9-1000
WIDTH(n) | Range of n = 121-2048
TITLE('string') | Maximum TITLE('string') count is 3

The ALLDUPS/NODUPS/HIGHER(x)/LOWER(y)/EQUAL(v) parameter must be the last parameter specified.

Parent topic: ICETOOL Emulation


RANGE

The following parameters of this ICETOOL operator are supported in MFSORT and MFJSORT:

>--RANGE--FROM(indd)--.-.--ON(p,m,f)--.--------.----<<
                      | +--ON(VLEN)---+        |
                      |                        |
                      +-.-HIGHER(x)----------.-+
                      | +-LOWER(y)-----------+ |
                      | +-HIGHER(x)-LOWER(y)-+ |
                      | +-EQUAL(v)-----------+ |
                      | +-NOTEQUAL(w)--------+ |
                      |                        |
                      +-.---------------.------+
                        +--VSAMTYPE(x)--+

Limits and Restrictions:

Parameter | Restriction
ON | Only one ON is allowed
Parent topic: ICETOOL Emulation


SELECT

The following parameters of this ICETOOL operator are supported in MFSORT and MFJSORT:

>--SELECT--FROM(indd)--.-.--TO(outdd)-----------------.-.---------<<
                       | +--DISCARD(savedd)-----------+ |
                       | +--TO(outdd)-DISCARD(savedd)-+ |
                       |                                |
                       |   +---,-------+                |
                       |   V           |                |
                       +-.-.-ON(p,m,f)-.-.--------------+
                       | +-ON(VLEN)------+              |
                       |                                |
                       +-.-ALLDUPS---.------------------+
                       | +-NODUPS----+                  |
                       | +-HIGHER(x)-+                  |
                       | +-LOWER(y)--+                  |
                       | +-EQUAL(v)--+                  |
                       | +--FIRST----+                  |
                       | +--LAST-----+                  |
                       |                                |
                       +-.-------------.----------------+
                       | +-VSAMTYPE(x)-+                |
                       |                                |
                       +-.---------.--------------------+
                         +--UZERO--+

Limits and Restrictions:

Parameter | Restriction
ON | Maximum ON count of 20
ON and ALLDUPS|NODUPS|HIGHER|LOWER|EQUAL|FIRST|LAST | Mandatory keywords
Parent topic: ICETOOL Emulation


SORT

The following parameters of this ICETOOL operator are supported in MFSORT and MFJSORT:

>--SORT--FROM(indd)--USING(xxxx)--.-.------------------.-.-----<<
                                  | |                  | |
                                  | |      +--,----+   | |
                                  | |      V       |   | |
                                  | +--TO(-.-outdd-.-)-+ |
                                  |                      |
                                  +-VSAMTYPE(x)----------+
                                  |                      |
                                  +-.--------.-----------+
                                    +-SERIAL-+

Limits and Restrictions:

Parameter | Restriction
outdd | Maximum outdd count is 10
LOCALE(name), LOCALE(CURRENT), and LOCALE(NONE) | These parameters are parsed but ignored.
Parent topic: ICETOOL Emulation


STATS

The following parameters of this ICETOOL operator are supported in MFSORT and MFJSORT:

                          +----,------+
                          V           |
>--STATS--FROM(indd)--.-.-.-ON(p,m,f)-.-.-.-----<<
                      | +-ON(VLEN)------+ |
                      |                   |
                      +-.-------------.---+
                        +-VSAMTYPE(x)-+
Parent topic: ICETOOL Emulation


UNIQUE

The following parameters of this ICETOOL operator are supported in MFSORT and MFJSORT:

                           +----,------+
                           V           |
>--UNIQUE--FROM(indd)--.-.-.-ON(p,m,f)-.-.-.-----<<
                       | +-ON(VLEN)------+ |
                       |                   |
                       +-.-------------.---+
                       | +-VSAMTYPE(x)-+   |
                       |                   |
                       +-.-------.---------+
                         +-UZERO-+
Parent topic: ICETOOL Emulation


SYNCSORT Emulation

Note: MFJSORT and MFSORT are updated with new features on a regular basis but they do not offer a complete emulation of third-party sort utilities. If there are particular features that you need to use, please contact SupportLine to establish if they are available in MFJSORT or MFSORT.
Every reasonable effort has been made to ensure the accuracy of information relating to the emulation of SYNCSORT at the time of publication; however, we cannot guarantee complete accuracy as this tool continues to be developed.

The MFSORT and MFJSORT utilities support the following emulation:

  • SYNCSORT EXEC PARM Options Emulation
  • SYNCSORT Program Control Emulation
Parent topic: MFSORT and MFJSORT Utilities
Related reference
MFJSENGINE
Related information
Introduction
DFSORT and ICETOOL Emulation
Invoking Mfsort
Creating a Statistics Report
Example Commands
Error Messages


SYNCSORT EXEC PARM Options Emulation

The MFSORT and MFJSORT utilities emulate the following PARM parameters of the EXEC statement:

  • PARM
Parent topic: SYNCSORT Emulation


PARM

The following PARM parameters of the EXEC statement are supported.

>--,PARM=--.-CENTWIN=.-s-.---.--------<<
           |         +-f-+   |
           |                 |
           +-SIZE-.-n------+-+
           |      +-nK-----+ |
           |      +-nM-----+ |
           |      +-MAX----+ |
           |      +-MAX-m--+ |
           |      +-MAX-mK-+ |
           |      +-MAX-mM-+ |
           |                 |
           +-SKIPREC=z-------+
           |                 |
           +-STOPAFT=n-------+
           |                 |
           +-VLSHRT----------+
           |                 |
           +-Y2PAST=.-s-.----+
                    +-f-+
Note: VLSHRT is ON by default.

In this COBOL system, the following parameter fields are only parsed and ignored:

Parameter | Fields
ABEND | NOABEND |
ARESALL | (n | nK | nM)
AVGRLEN | n
BSAM |
CINV | NOCINV |
COBEXIT | (COB1 | COB2)
DSPSIZE | (MAX | n)
DYNALLOC | [ =( d | n | d, n | OFF)]
EFS | (name | NONE)
ELAP |
EQUALS | NOEQUALS |
E15 | =COB
E35 | =COB
FILSZ | (x | Ex | Ux)
HIRPMAX | (OPTIMAL | N)
LIST | NOLIST |
LISTX | NOLISTX |
LOCALE | (name | CURRENT | NONE)
MSGDDN | ddname
MSGPRT | (ALL | CRITICAL | NONE)
ODMAXBF | (n | nK | nM)
OUTREL | NOOUTREL |
OVFLO | (RC0 | RC4 | RC16)
PAD | (RC0 | RC4 | RC16)
RC16 | (ABE)
RESALL | (n | nK | nM)
RESERVE | (n | nK | nM)
RESET | NORESET |
SDB | (LARGE | YES | INPUT | NO)
SOLRF | NOSOLRF |
SPANINC | (RC0 | RC4 | RC16)
SZERO | NOSZERO |
TRUNC | (RC0 | RC4 | RC16)
VERIFY | NOVERIFY |
VLLONG | NOVLLONG |
VLSCMP | NOVLSCMP |
NOVLSHRT |
VSAMEMT | NOVSAMEMT |
VSAMIO | NOVSAMIO |
VSCORE | value
VSCORET | value
WRKREL | NOWRKREL |
WRKSEC | NOWRKSEC |
ZDPRINT | NZDPRINT |

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.
Parent topic: SYNCSORT EXEC PARM Options Emulation


SYNCSORT Program Control Emulation

The MFSORT and MFJSORT utilities emulate the following program control statements:

  • ALTSEQ
  • DEBUG
  • END
  • INCLUDE
  • INREC
  • MERGE
  • MODS
  • OMIT
  • OPTION
  • OUTFIL
  • OUTREC
  • RECORD
  • SORT
  • SUM
Parent topic: SYNCSORT Emulation


ALTSEQ

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
                  +--,---+
                  V      |
>--ALTSEQ--CODE=-(.-fftt-.)------<<
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


DEBUG

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
          +------,-------+
          V              |
>--DEBUG--.--.---------.-.-----<<
             +-ABEND---+
             +-NOABEND-+
             +-ABSTP---+

In this COBOL system, the following parameter fields for this control statement are only parsed and ignored:

Parameter | Fields
DEBUG | BSAM CFW NOCFW CTRx=n EFSDPAFT=(n)+ EFSDPBFR=(n)+ EQUCOUNT ESTAE NOESTAE NOASSIST

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


END

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
>--END--<<
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


INCLUDE

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
>--INCLUDE--COND=-(logical-expression)-.----------.----------<<
                                       +-FORMAT=f-+

The following options for the logical-expression field are supported:

>--relational-condition1--.----------------------------------------.---<<
                          | +-------------------.---------------+  |
                          | V                                   |  |
                          +-.-,-.-AND-.--,relational-condition2-.--.
                                +-OR--+

The following options for the relational-expression field are supported:

>--.-(p1,m1.---------.,binary-operator,-.-p2,m2,format-.)----------------.-->
   |       +-,format-+                  +-constant-----+                 |
   |                                                                     |
   +-(p1,m1,.-----.-.-EQ-.-,-.-constant-.-)------------------------------+
   |        +-SS,-+ +-NE-+   +-NUM------+                                |
   |                                                                     |
   +-(p1,m1,format,-.-EQ-.-,-NUM)----------------------------------------|
   |                +-NE-+                                               |
   |                                                                     |
   +-(p1,m1,-.----.-,-bit-operator,-mask)--------------------------------|
   |         +-BI-+                                                      |
   |                                                                     |
   +-(p1,m1,-.-------------.-,-binary-operator,-.-p2,m2,-.------------.)-+
             +-date-format-+                    |        +date-format-+
                                                +-constant------------+

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.

Limitations:

The maximum field length when comparing two fields that have the same format and the same length:

Format | MFJSORT | DFSORT and SYNCSORT
All | 256 | 256
CH (only when EBCDIC) | 128 | n/a

The maximum field length when comparing two fields that have the same format and differing lengths.

Format | MFJSORT | DFSORT and SYNCSORT
CH | 128 | 256
TS, CST | 19 | 256
ZD, OT, CTO, OL, CLO, LS, CSL | 18 | 256
FS, CSF | 18 | 32
PD | 10 | 255
PD0 | 8 | 8
BI, FI | 8 | 256
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


INREC

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
                      +--------,-------+
                      V                |
>---INREC--.-FIELDS=-(.-item-statement-.)----.---<<
           |                                 |
           |          +--------,----------+  |
           |          V                   |  |
           +-OVERLAY=(.-overlay-statement-.)-+

The following options for the item-statement field are supported:

                     +-------------,-----------------------------------------+
                     V                                                       |
>--item-statement=--(.--.----.-.-s-----------------------------------------.-.-)--<<
                        +-c:-+ |                                           |
                               +-p-----------------------------------------+
                               |                                           |
                               +-p,m.----.---------------------------------+
                               |    +-,a-+                                 |
                               |                                           |
                               +-p,m,format.-,edit-.-----------------------+
                               |           +-,to---+                       |
                               |                                           |
                               +-p,HEX-------------------------------------+
                               |                                           |
                               +-p,m,HEX-----------------------------------+
                               |                                           |
                               +-p,m,TRAN=LTOU-----------------------------+
                               |                                           |
                               +-p,m,TRAN=UTOL-----------------------------+
                               |                                           |
                               +-p,m,TRAN=ALTSEQ---------------------------+
                               |                                           |
                               +-p,m,Y2x(c)--------------------------------+
                               |                                           |
                               +-p,m,Y2xP----------------------------------+
                               |                                           |
                               +-p,m,CHANGE=(v,(find-set)+,[NOMATCH=(set)]-+
                               |                                           |
                               +-seqnum------------------------------------+
Note: For options p,m,Y2x(c), the (c) is only parsed and ignored in this COBOL system

The following options for the overlay-statement field are supported:

                +-------------,-----------------------------------------+
                V                                                       |
>--OVERLAY--=--(.--.----.-.-s-----------------------------------------.-.-)--<<
                   +-c:-+ |                                           |
                          +-p,m---------------------------------------+
                          |                                           |
                          +-p,m.----.---------------------------------+
                          |    +-,a-+                                 |
                          |                                           |
                          +-p,m,format.-,edit-.-----------------------+
                          |           +-,to---+                       |
                          |                                           |
                          +-p,m,HEX-----------------------------------+
                          |                                           |
                          +-p,m,TRAN=LTOU-----------------------------+
                          |                                           |
                          +-p,m,TRAN=UTOL-----------------------------+
                          |                                           |
                          +-p,m,TRAN=ALTSEQ---------------------------+
                          |                                           |
                          +-p,m,Y2x(c)--------------------------------+
                          |                                           |
                          +-p,m,Y2xP----------------------------------+
                          |                                           |
                          +-p,m,CHANGE=(v,(find-set)+,[NOMATCH=(set)]-+
                          |                                           |
                          +-seqnum------------------------------------+
Note: For options p,m,Y2x(c), the (c) is only parsed and ignored in this COBOL system

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.

The following field values are supported, where applicable:

Field | Values
a (alignment) | D (doubleword aligned), F (fullword aligned), H (halfword aligned).
s (separation) | ADD, DATE, &DATE, DATE=(abcd), &DATE=(abcd), DATE1, &DATE1, DATE1P, &DATE1P, DATE2, &DATE2, DATE2P &DATE2P, DATE3, &DATE3, DATE3P, &DATE3P, DATEn, &DATEn, DATEn+r, &DATEn+r, DATEn-r, &DATEn-r, DATEn(c), &DATEn(c), DATEn(c)+r, &DATEn(c)+r, DATEn(c)-r, &DATEn(c)-r, DATEnP, DATEnP+r, &DATEnP+r, DATEnP-r, &DATEnP-r, DATENS, &DATENS, DATENS=(abc), &DATENS=(abc), DIVIDE, LITERALS, MULTIPLY, SEPERATOR CHARS, SEQNUM, SUBTRACT.
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


MERGE

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
>--MERGE--FIELDS=-(logical-expression)--FORMAT=f-----<<
Note: The maximum size of a merge field is 256 characters.

In this COBOL system, the following parameter fields for this control statement are only parsed and ignored:

Parameter | Fields
FIELDS | (FILSZ=x | size=y]

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.

The following options for the logical-expression field are supported:

>--relational-condition1--.----------------------------------------.---<<
                          | +-------------------.---------------+  |
                          | V                                   |  |
                          +-.-,-.-AND-.--,relational-condition2-.--.
                                +-OR--+

The following options for the relational-expression field are supported:

>--.-(p1,m1.---------.,binary-operator,-.-p2,m2,format-.)----------------.-->
   |       +-,format-+                  +-constant-----+                 |
   |                                                                     |
   +-(p1,m1,.-----.-.-EQ-.-,-.-constant-.-)------------------------------+
   |        +-SS,-+ +-NE-+   +-NUM------+                                |
   |                                                                     |
   +-(p1,m1,format,-.-EQ-.-,-NUM)----------------------------------------|
   |                +-NE-+                                               |
   |                                                                     |
   +-(p1,m1,-.----.-,-bit-operator,-mask)--------------------------------|
   |         +-BI-+                                                      |
   |                                                                     |
   +-(p1,m1,-.-------------.-,-binary-operator,-.-p2,m2,-.------------.)-+
             +-date-format-+                    |        +date-format-+
                                                +-constant------------+

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


MODS

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
         +----------------,-------------------+
         V                                    |
>--MODS--.-.-E15-.=-(-n,m.----------------.-)-.-+-.-------------.----<<
           +-E18-+       +-,-.---.-.----.-+       +-HILEVEL=YES-+
           +-E35-+           +-s-+ +-,e-+

In this COBOL system, the following parameter fields for this control statement are only parsed and ignored:

Parameter | Fields
MODS | (E18=n, m, [s] [e])+[HILEVEL=YES] (E39=n, m, [s] [e])+[HILEVEL=YES]

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


OMIT

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
>--OMIT--COND=--(logical-expression)-.----------.----------<<
                                     +-FORMAT=f-+

The following options for the logical-expression field are supported:

>--relational-condition1--.----------------------------------------.---<<
                          | +-------------------.---------------+  |
                          | V                                   |  |
                          +-.-,-.-AND-.--,relational-condition2-.--.
                                +-OR--+

The following options for the relational-expression field are supported:

>--.-(p1,m1.---------.,binary-operator,-.-p2,m2,format-.)----------------.-->
   |       +-,format-+                  +-constant-----+                 |
   |                                                                     |
   +-(p1,m1,.-----.-.-EQ-.-,-.-constant-.-)------------------------------+
   |        +-SS,-+ +-NE-+   +-NUM------+                                |
   |                                                                     |
   +-(p1,m1,format,-.-EQ-.-,-NUM)----------------------------------------|
   |                +-NE-+                                               |
   |                                                                     |
   +-(p1,m1,-.----.-,-bit-operator,-mask)--------------------------------|
   |         +-BI-+                                                      |
   |                                                                     |
   +-(p1,m1,-.-------------.-,-binary-operator,-.-p2,m2,-.------------.)-+
             +-date-format-+                    |        +date-format-+
                                                +-constant------------+

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.

Limitations:

The maximum field length when comparing two fields that have the same format and the same length:

Format | MFJSORT | DFSORT and SYNCSORT
All | 256 | 256
CH (only when EBCDIC) | 128 | n/a

The maximum field length when comparing two fields that have the same format and differing lengths.

Format | MFJSORT | DFSORT and SYNCSORT
CH | 128 | 256
TS, CST | 19 | 256
ZD, OT, CTO, OL, CLO, LS, CSL | 18 | 256
FS, CSF | 18 | 32
PD | 10 | 255
PD0 | 8 | 8
BI, FI | 8 | 256
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


OPTION

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
           +---------,-------------+
           V                       |
>--OPTION--.--.-CENTWIN---------.--.----------<<
              |                 |
              +-COPY------------+
              |                 |
              +-EFS=.-name-.----+
              |     +-NONE-+    |
              |                 |
              +-.-EQUALS---.----+
              | +-NOEQUALS-+    |
              |                 |
              +-OVFLO=.-RC0--.--+
              |       +-RC4--+  |
              |       +-RC16-+  |
                 |                 |
              +--SKIPREC=z------+
              |                 |
              +--STOPAFT=n------+
              |                 |
              +--Y2PAST=.-s-.---+
              |         +-f-+   |
              |                 |
              +-.-ZDPRINT--.----+
              | +-NZDPRINT-+    |
              |                 |
              +-VLSHRT----------+
Note: VLSHRT is ON by default.

In this COBOL system, the following parameter fields for this control statement are only parsed and ignored:

Parameter | Fields
ARESALL | (n | nK | nM)
ARESINV | (n | nK | nM)
AVGRLEN | n
CHALT |
NOCHALT |
CHECK |
NOCHECK |
CINV |
NOCINV |
CKPT |
COBEXIT | (COB1 | COB2)
DSA | n
DSPSIZE | MAX
DYNALLOC | [=(d | n | d,n | OFF)]
EXITCK | (STRONG | WEAK)
FILSZ | (x | Ex | Ux)
SIZE | (y | Ey | Uy)
HIRPMAX | (OPTIMAL | n | P%)
LIST |
NOLIST |
LISTX |
NOLISTX |
LOCALE | (name | CURRENT | NONE)
MAINSIZE | (n | nK | nM | MAX)
MOSIZE | (MAX | n | p%)
MSGDDN | ddname
MSGPRT | (ALL | NONE | CRITICAL)
PRINT |
NOBLKSET |
NOOUTREL |
NOOUTSEC |
NULLOUT | (RC0 | RC4 | RC16)
ODMAXBF | (n | nK | nM)
PAD | (RC0 | RC4 | RC16)
RESALL | (n | nK | nM)
RESET |
NORESET |
RESINV | (n | nK | nM)
SDB | (LARGE | YES | INPUT | NO)
SMF | (SHORT | FULL | NO)
SOLRF |
NOSOLRF |
SORTDD | cccc
SORTIN | ddname
SORTOUT | ddname
SPANINC | (RC0 | RC4 | RC16)
SZERO |
NOSZERO |
TRUNC | (RC0 | RC4 | RC16)
USEWKDD |
VERIFY |
NOVERIFY |
VLLONG |
NOVLLONG |
VLSCMP |
NOVLSCMP |
NOVLSHRT |
VSAMEMT |
NVSAMEMT |
VSAMIO |
NOVSAMIO |
WRKREL |
NOWRKREL |
WRKSEC |
NOWRKSEC |

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


OUTFIL

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
           +----------------------------,-----------------------------------+
           |                                                                |
           |             +---,----+                                         |
           V             V        |                                         |
>--OUTFIL--.--.--FNAMES=-.-ddname-.---------------------------------------.-.----------<<
              |                                                           |
              |         +---,-----+                                       |
              |         V         |                                       |
              +--FILES=-.-.-d---.-.---------------------------------------+
              |           +-dd--+                                         |
              |           +-OUT-+                                         |
              |                                                           |
              +--STARTREC=-n----------------------------------------------+
              |                                                           |
              +-ENDREC=-n-------------------------------------------------+
              |                                                           |
              |           +------,---------+                              |
              |           V                |                              |
              +--OUTREC=-(.-item-statement-.)-.----------.-.------------.-+
              |                               +-,VTOF----+ +-VFILL=byte-+ |
              |                               +-,CONVERT-+                |
              |            +-------,--------+                             |
              |            V                |                             |
              +--OVERLAY=-(.-item-statement-.)----------------------------+
              |                                                           |
              |                                                           |
              |                                                           |
              +-.-INCLUDE=-.-(-logical-expression-)-.---.-----------------+
              | |          +-ALL--------------------+   |                 |
              | |          +-NONE-------------------+   |                 |
              | |                                       |                 |
              | |                                       |                 |
              + +-OMIT=-.-(logical-expression-)-.-------+                 |
              |         +-ALL-------------------+                         |
              |         +-NONE------------------+                         |
              |                                                           |
              +--SAVE-----------------------------------------------------+
              |                                                           |
              +--FTOV-----------------------------------------------------+
              |                                                           |
              +--VLTRIM=byte----------------------------------------------+
              |                                                           |
              +--SPLIT----------------------------------------------------+
              |                                                           |
              +--LINES=n--------------------------------------------------+
              |                                                           |
              |           +--------,--------+                             |
              |           V                 |                             |
              +--HEADERn=-.-(-header-item-)-.-----------------------------+
              |                                                           |
              |            +-------,----------+                           |
              |            V                  |                           |
              +--TRAILERn=-.-(-trailer-item-)-.---------------------------+
              |                                                           |
              |            +-------,----------+                           |
              |            V                  |                           |
              +--SECTIONS=-.-(-section-item-)-.---------------------------|
              |                                                           |
              +--NODETAIL-------------------------------------------------|
              |                                                           |
              +--REMOVECC-------------------------------------------------|
              |                                                           |
              +--CONVERT--------------------------------------------------+
Note: The maximum number of OUTFILs is 2048.

The following options for the item-statement field are supported:

                     +-------------,-----------------------------------------+
                     V                                                       |
>--item-statement=--(.--.----.-.-s-----------------------------------------.-.-)--<<
                        +-c:-+ |                                           |
                               +-p-----------------------------------------+
                               |                                           |
                               +-p,m.----.---------------------------------+
                               |    +-,a-+                                 |
                               |                                           |
                               +-p,m,format.-,edit-.-----------------------+
                               |           +-,to---+                       |
                               |                                           |
                               +-p,HEX-------------------------------------+
                               |                                           |
                               +-p,m,HEX-----------------------------------+
                               |                                           |
                               +-p,m,TRAN=LTOU-----------------------------+
                               |                                           |
                               +-p,m,TRAN=UTOL-----------------------------+
                               |                                           |
                               +-p,m,TRAN=ALTSEQ---------------------------+
                               |                                           |
                               +-p,m,Y2x(c)--------------------------------+
                               |                                           |
                               +-p,m,Y2xP----------------------------------+
                               |                                           |
                               +-p,m,CHANGE=(v,(find-set)+,[NOMATCH=(set)]-+
                               |                                           |
                               +-seqnum------------------------------------+
Note: For options p,m,Y2x(c), the (c) is only parsed and ignored in this COBOL system

The following field values are supported, where applicable:

Field | Values
a (alignment) | D (doubleword aligned), F (fullword aligned), H (halfword aligned).
s (separation) | ADD, DATE, &DATE, DATE=(abcd), &DATE=(abcd), DATE1, &DATE1, DATE1P, &DATE1P, DATE2, &DATE2, DATE2P &DATE2P, DATE3, &DATE3, DATE3P, &DATE3P, DATEn, &DATEn, DATEn+r, &DATEn+r, DATEn-r, &DATEn-r, DATEn(c), &DATEn(c), DATEn(c)+r, &DATEn(c)+r, DATEn(c)-r, &DATEn(c)-r, DATEnP, DATEnP+r, &DATEnP+r, DATEnP-r, &DATEnP-r, DATENS, &DATENS, DATENS=(abc), &DATENS=(abc), DIVIDE, LITERALS, MULTIPLY, SEPERATOR CHARS, SEQNUM, SUBTRACT.

The following options for the logical-expression field are supported:

>--relational-condition1--.----------------------------------------.---<<
                          | +-------------------.---------------+  |
                          | V                                   |  |
                          +-.-,-.-AND-.--,relational-condition2-.--.
                                +-OR--+

The following options for the relational-expression field are supported:

>--.-(p1,m1.---------.,binary-operator,-.-p2,m2,format-.)----------------.-->
   |       +-,format-+                  +-constant-----+                 |
   |                                                                     |
   +-(p1,m1,.-----.-.-EQ-.-,-.-constant-.-)------------------------------+
   |        +-SS,-+ +-NE-+   +-NUM------+                                |
   |                                                                     |
   +-(p1,m1,format,-.-EQ-.-,-NUM)----------------------------------------|
   |                +-NE-+                                               |
   |                                                                     |
   +-(p1,m1,-.----.-,-bit-operator,-mask)--------------------------------|
   |         +-BI-+                                                      |
   |                                                                     |
   +-(p1,m1,-.-------------.-,-binary-operator,-.-p2,m2,-.------------.)-+
             +-date-format-+                    |        +date-format-+
                                                +-constant------------+

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.

Limitations:

  • The maximum length of COUNT and SUBCOUNT values is 9 digits.
  • The maximum length of the TOTAL fields:
    TOTAL field formats | MFJSORT | SYNCSORT
    Length (m) | Digits (d) | Length (m) | Digits (d)
    ZD | 1-15 | *Maximum 18. | 1-15 | 15
    ZD | 16-31 | 16-31 | 31
    PD | 1-8 | 1-8 | 15
    PD | 9-16 | 9-16 | 31
    BI | 1-4 | 1-4 | 10
    BI | 5-8 | 5-8 | 20
    FI | 1-4 | 1-4 | 10
    FI | 5-8 | 5-8 | 20
    FL | 4 or 8 | 4 or 8 | 20
    CSF, FS | 1-15 | 1-15 | 15
    CSF, FS | 16-32 | 16-32 | 31

    * MFJSORT will display the total to the same amount of digits as specified in the length.

Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


OUTREC

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
                      +--------,-------+
                      V                |
>--OUTREC--.-FIELDS=-(.-item-statement-.)----.---<<
           |                                 |
           |          +--------,----------+  |
           |          V                   |  |
           +-OVERLAY=(.-overlay-statement-.)-+

The following options for the item-statement field are supported:

                     +-------------,-----------------------------------------+
                     V                                                       |
>--item-statement=--(.--.----.-.-s-----------------------------------------.-.-)--.---------.--<<
                        +-c:-+ |                                           |      +-convert-+
                               +-p-----------------------------------------+
                               |                                           |
                               +-p,m.----.---------------------------------+
                               |    +-,a-+                                 |
                               |                                           |
                               +-p,m,format.-,edit-.-----------------------+
                               |           +-,to---+                       |
                               |                                           |
                               +-p,HEX-------------------------------------+
                               |                                           |
                               +-p,m,HEX-----------------------------------+
                               |                                           |
                               +-p,m,TRAN=LTOU-----------------------------+
                               |                                           |
                               +-p,m,TRAN=UTOL-----------------------------+
                               |                                           |
                               +-p,m,TRAN=ALTSEQ---------------------------+
                               |                                           |
                               +-p,m,Y2x(c)--------------------------------+
                               |                                           |
                               +-p,m,Y2xP----------------------------------+
                               |                                           |
                               +-p,m,CHANGE=(v,(find-set)+,[NOMATCH=(set)]-+
                               |                                           |
                               +-seqnum------------------------------------+
Note: For options p,m,Y2x(c), the (c) is only parsed and ignored in this COBOL system

The following options for the overlay-statement field are supported:

                +-------------,-----------------------------------------+
                V                                                       |
>--OVERLAY--=--(.--.----.-.-s-----------------------------------------.-.-)--<<
                   +-c:-+ |                                           |
                          +-p,m---------------------------------------+
                          |                                           |
                          +-p,m.----.---------------------------------+
                          |    +-,a-+                                 |
                          |                                           |
                          +-p,m,format.-,edit-.-----------------------+
                          |           +-,to---+                       |
                          |                                           |
                          +-p,m,HEX-----------------------------------+
                          |                                           |
                          +-p,m,TRAN=LTOU-----------------------------+
                          |                                           |
                          +-p,m,TRAN=UTOL-----------------------------+
                          |                                           |
                          +-p,m,TRAN=ALTSEQ---------------------------+
                          |                                           |
                          +-p,m,Y2x(c)--------------------------------+
                          |                                           |
                          +-p,m,Y2xP----------------------------------+
                          |                                           |
                          +-p,m,CHANGE=(v,(find-set)+,[NOMATCH=(set)]-+
                          |                                           |
                          +-seqnum------------------------------------+
Note: For options p,m,Y2x(c), the (c) is only parsed and ignored in this COBOL system

The following field values are supported, where applicable:

Field | Values
a (alignment) | D (doubleword aligned), F (fullword aligned), H (halfword aligned).
s (separation) | ADD, DATE, &DATE, DATE=(abcd), &DATE=(abcd), DATE1, &DATE1, DATE1P, &DATE1P, DATE2, &DATE2, DATE2P &DATE2P, DATE3, &DATE3, DATE3P, &DATE3P, DATEn, &DATEn, DATEn+r, &DATEn+r, DATEn-r, &DATEn-r, DATEn(c), &DATEn(c), DATEn(c)+r, &DATEn(c)+r, DATEn(c)-r, &DATEn(c)-r, DATEnP, DATEnP+r, &DATEnP+r, DATEnP-r, &DATEnP-r, DATENS, &DATENS, DATENS=(abc), &DATENS=(abc), DIVIDE, LITERALS, MULTIPLY, SEPERATOR CHARS, SEQNUM, SUBTRACT.
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


RECORD

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
>--RECORD--.-TYPE=-.-F-.--------------------.----<<
           |       +-V-+                    |
           +-.--------.--LENGTH=(L1,...,L3)-+
           | +-TYPE=F-+                     |
           +-.--------.--LENGTH=(L1,...,L7)-+
             +-TYPE=V-+
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


SORT

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
                    +---,---+                   +---------,------------+
                    V       |                   V                      |
>--SORT--FIELDS=-.-(.-p,m,f-.)----------------.-.--.-.-EQUALS---.---.--.----<<
                 |                            |    + +-NOEQUALS-+   |
                 |  +--,--------+             |    |                |
                 |  V           |             |    +-SKIPREC=z------+
                 +-(.-p,m,.---.-.)-,-FORMAT=f-+    +-STOPAFT=n------+
                 |        +-f-+               |    +-Y2PAST=-.-s-.--+
                 +-COPY-----------------------+    |         +-f-+  |
                                                   +-CENTWIN=-.-s-.-+
                                                              +-f-+
Note: The maximum size of a sort field is 256 characters.

In this COBOL system, the following parameter fields for this control statement are only parsed and ignored:

Parameter | Fields
FIELDS | CKPT DYNALLOC [=(d | n | d, n | OFF)] FILSZ = (x | Ex | Ux) SIZE = (y | Ey | Uy)

Use the following table as a guide to help you understand the options that are ignored:

Symbol | Meaning
(...) | Options within these brackets are required.
[...] | Options with these brackets are optional.
+ | This symbol follows a set of required or optional brackets to indicate that more than one option can be specified, delimited by a comma.
| | This symbol delimits options enclosed in required or optional brackets, to indicate a choice from these options.

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


SUM

The following parameters of this SYNCSORT control statement are supported in MFSORT and MFJSORT. To enable this support, set the MFJSENGINE environment variable.

Note: SYNCSORT emulation allows you to omit the equals sign (=) between a keyword and its bracketed parameters; for example, OUTREC(05:5,10).
                   +---,---+
                   V       |
>--SUM--FIELDS=-.-(.-p,m,f-.)----------------.----<<
                |                            |
                |  +--,--------+             |
                |  V           |             |
                +-(.-p,m,.---.-.)-,-FORMAT=f-+
                |        +-f-+               |
                +-NONE-----------------------+
Restriction: The maximum number of SUM fields is 100 and the maximum SUM field length is 18.

If required, use the SORTXSUM DD statement to write records that were deleted during a SUM process to a dataset. This occurs at the time of the SUM processing, and so will not undergo OUTREC, E35 or OUTFIL processing, which all occur after SUM processing.

The following field formats are supported, where applicable:

Field | Supported formats
Binary-operator | EQ, GE, GT, LE, LT, NE.
Bit-operator | ALL, BM, BNM, BNO, BNZ, BO, BZ, NONE, NOTALL, NOTNONE, NOTSOME, SOME.
Date-format | Y2B, Y2C, Y2D, Y2P, Y2S, Y2T, Y2U, Y2V, Y2W, Y2X, Y2Y, Y2Z, Y2TP, Y2UP, Y2VP, Y2WP, Y2XP, Y2YP.
Format | AQ, BI, CH, CLO, CSF, CSL, CST, CTO, FI, FL, FS, LS, OL, OT, PD, PD0, SB, SS, TS, ZD.
Parent topic: SYNCSORT Program Control Emulation
Related reference
MFJSENGINE


Invoking Mfsort

You can invoke mfsort from the command line in one of the following ways:

mfsort instructions
mfsort take filename

where the parameters are:

Parameter | Description
instructions | Mfsort instructions. When specifying instructions on the command line, the maximum length of the mfsort command is 1024 characters. Characters after this limit are ignored, and if this truncation causes an invalid or incomplete command, an error is produced.
filename | A text file containing mfsort instructions. See the section Instructions. Use this method if you need to specify a lot of instructions. This file must be a line sequential file, and the first 256 characters are processed as the command line. Characters that exceed this limit are processed separately if they form a valid command; however, this may result in undesired sort results. If this truncation causes an invalid or incomplete command, an error is produced.
  • Instructions
Parent topic: MFSORT and MFJSORT Utilities
Related information
Introduction
DFSORT and ICETOOL Emulation
SYNCSORT Emulation
Creating a Statistics Report
Example Commands
Error Messages
Instructions


Instructions

The following is a list of valid mfsort instructions:

Instruction | Meaning
* | The rest of the line is treated as a comment. This is useful if you are supplying instructions via a text file as you can add comments to the file which explain the purpose of each instruction.
CHAR-EBCDIC | EBCDIC data. CHAR-EBCDIC must precede all SORT, MERGE, USE or GIVE instructions.
SIGN-EBCDIC | Numeric DISPLAY items with included signs are interpreted according to the EBCDIC convention. SIGN-EBCDIC is not required when CHAR-EBCDIC is specified; it is required for data that is otherwise ASCII, such as when the program which created the data was compiled with the SIGN"EBCDIC" Compiler directive. SIGN-EBCDIC must precede all SORT, MERGE, USE or GIVE instructions.
SORT-EBCDIC | Record-sequential ASCII files are sorted in EBCDIC order. Important: SORT-EBCDIC cannot sort files that have keys containing non-printable characters.
SORT/MERGE | These instructions specify either a sort or a merge option and must be followed by a FIELDS instruction specifying the field(s) to be used. The FIELDS instruction may optionally be followed by a RECORD instruction specifying the record size and format of the workfile. SORT and MERGE are mutually exclusive.
FIELDS (instructions) | The fields on which the file is to be sorted or merged. See the section Fields Instruction.
RECORD definition | Record size and format. A RECORD instruction can be used to specify these details for the workfile, input file(s) and output file(s). See the section RECORD Instruction.
USE input-file | Each USE instruction specifies an input file. You must specify all USE instructions before any GIVE instructions. See the section Defining Input and Output Files.
GIVE output-file | Each GIVE instruction specifies an output file. See the section Defining Input and Output Files.
INCLUDE/OMIT | Specifies conditions in which records will be included or omitted from the sort process. For details, see the IBM documentation to be found at . INCLUDE and OMIT are mutually exclusive.
INREC | Reformats records before the SORT/MERGE process.
OUTREC | Reformats records following the SORT/MERGE process.
MODS | Specifies external procedures (user exits) that are executed, each time a record is released to or returned from the SORT/MERGE process. This implementation supports the E15 and E35 user exits.
SUM | Specifies that records with the same key value are returned as a single record. Optionally, a field may be specified to accumulate totals for all records with equal keys. The SUM operation can be done for the following control field types:
OUTFIL | This is used to specify complex editing and reporting to one or more output files. Each output file should be specified using a GIVE command. Otherwise, OUTFIL works as described in the IBM documentation to be found at .
OPTION | This can be used to specify various options. One of these options is COPY which results in records being copied, rather than sorted, to the output file.
  • FIELDS Instruction
  • Defining Input and Output Files
Parent topic: Invoking Mfsort
Related information
Invoking Mfsort
Fields Instruction
RECORD Instruction
Defining Input and Output Files


FIELDS Instruction

A SORT or MERGE instruction must be followed by a FIELDS instruction which specifies the fields on which the input file is to be sorted or merged.

A fields instruction takes the following form:

fields({start,length,type,order},...)

where the parameters are:

Parameter | Description
start | The starting position of the field in the record, counting in bytes from 1
length | The length of the field (bytes)
type | The type of data in the field. See the section Field Types .
order | The ordering of output, which can be either of: A - ascending D - descending

You can specify up to 100 fields by repeating the parameter set (start, length, type and order). Use commas to separate the parameters and the parameter sets.

  • Field Types
Parent topic: Instructions


Field Types

The following is a list of some of the available field types:

Field Type | Definition
AQ | Character with alternate collating sequence.
BI | COMP
C5 | COMP-5
C6 | COMP-6
CH | PIC X DISPLAY
CX | COMP-X
FL | Floating point, signed.
FS/CSF | Signed numeric, with optional leading floating sign.
LI/OL/CLO | PIC S9 LEADING INCLUDED
LS/CSL | PIC S9 LEADING SEPARATE
NU | PIC 9 DISPLAY
PD | PIC S9 COMP-3
PD0 | Packed decimal with first semi-byte and sign semi-byte ignored.
SB/FI | PIC S9 COMP
S5 | S9 COMP-5
SS | Substring. Used in conditions only.
TS/CST | PIC S9 TRAILING SEPARATE
TI/ZD/OT/CTO | PIC S9 TRAILING INCLUDED
Y2B | Two-digit, one-byte binary year data.
Y2C/Y2Z | Two-digit, two-byte year data, with optional trailing included sign. PIC 99 or PIC S99.
Y2D | Two-digit, one-byte packed decimal year data. PIC 99 COMP-6.
Y2P | Two-digit, two-byte packed decimal year data. PIC 99 COMP-3.
Y2S | Two-digit, two-byte character year data with special indicators. Binary zeros, blanks and binary ones are treated as special cases.
Y2T | Full date format, yyx...
Y2U | Full date format, yyx..., COMP-3.
Y2V | Full date format, yyx..., COMP-3. Ignores first semi-byte.
Y2W | Full date format, x...yy.
Y2X | Full date format, x...yy, COMP-3.
Y2Y | Full date format, x...yy, COMP-3. Ignores first semi-byte.

You can find other field types defined in the IBM documentation at SORT Control Statement.

Suppose that golf.dat is a relative file defined in a COBOL program as follows:

 file-control.
     select members-file
         assign to "d:\netexpress\base\workarea\golf.dat"
         organization is relative
         access mode is random
         relative key is relative-key.
 data division.
 file section.
 fd members-file
     record contains 28 characters.
 01 members-record.
     03 members-number pic 9(6).
     03 members-lname pic x(10).
     03 members-fname pic x(10).
     03 members-handicap pic 9(2).

You can then use the following mfsort command to sort the file golf.dat on the field containing the membership number in ascending order:

mfsort sort fields(1,6,nu,a)
   use golf.dat record f,28 org rl
   give members.dat

The sorted version of the file is written to the file members.dat.

Parent topic: FIELDS Instruction


Defining Input and Output Files

You need to give instructions to define both the input and output files:

File Instructions
Input
USE input-file [record definition]
   [org organization] [key structure]
Output
GIVE output-file [record definition]
   [org organization] [key structure]

Notes:

  • For input files that are either variable length or indexed files, you do not need to specify RECORD, ORG or KEYcommands as the file characteristics can be deduced from the file itself.
  • If you omit any of the above instructions, the last specified values are used. Therefore, you need only specify values for the first file if the input and output files are all of the same type and format.
  • If the first file is variable length or indexed, you do not need to specify any of the values.
  • You can use embedded library names and environment variables when you specify input and output files, in the same way as you can when you specify them in ASSIGN clauses; for more information see the sections Library Names in Paths and Filename Mapping in the chapter Filenames.
  • You can redirect the output file generated by MFSORT to another filename as follows:
    • If you do not use the SYSOUT environment variable, it is written to a file named SYSOUT.
    • If you do specify the SYSOUT environment variable, you specify the filename to be written to.
  • RECORD Instruction
  • ORG Instruction
  • KEY Instruction
Parent topic: Instructions


RECORD Instruction

You use the RECORD instruction to specify the format and length of records in the:

  • Sort work file
  • Input and output files when the instruction follows the associated USE or GIVE instruction

The RECORD instruction takes the following form:

RECORD format,rec-len,max-len

where the parameters are:

Parameter | Description
format | The record format, one of: F - fixed-length records of length rec-len V - variable-length records with a minimum length of rec-len and a maximum length of max-len
rec-len | If format is set to F, the record length If format is set to V, the minimum record length
max-len | If format is set to V, the maximum record length

If you do not specify a RECORD instruction for the sort workfile, the format defaults to fixed record format, with the record size equal to the largest record specified in the USE or GIVE instructions.

You do not need to specify a RECORD instruction for input files that are either variable length or indexed files as the file characteristics can be deduced from the file itself.

You must use a RECORD instruction if the record size is greater than 256.

If you do not specify a max-len for a line sequential input file, mfsort assumes 256. If you exceed this, the output file will have the input records split into several records.

Parent topic: Defining Input and Output Files


ORG Instruction

The ORG instruction specifies the file organization, and can be one of:

ORG Instruction | File Organization
IX | indexed
RL | relative
SQ | sequential (default value)
LS | line sequential

You do not need to specify an ORG instruction for input files that are either variable length or indexed files as the file characteristics can be deduced from the file itself.

Parent topic: Defining Input and Output Files


KEY Instruction

The KEY instruction specifies the key structure for an indexed file. It is used when an output file is indexed and its key structure is not the same as that of the indexed input file.

The format of the KEY instruction is:

KEY ({start,length,ixkey},...)

where the parameters are:

start
The starting position of the key in a record, counting in bytes from 1
length
The number of bytes in the key
ixkey
One of:
P
Primary key (this must always be defined first)
A
Alternate key
AD
Alternate key with duplicates
C
Component of the last-specified primary or alternate key

You can repeat the KEY instruction as often as required to describe the entire key structure. Use commas to separate the parameters and parameter sets (start, length, ixkey).

You must define the keys in order of importance with the primary key first, followed by all its components if it is split, then the first alternate key and all of its components and so on.

The following example defines three keys:

KEY (4,5,p,10,5,c,20,2,ad,40,2,a,46,10,c)

where:

4,5,p,10,5,c | represents the first primary key which is split. Its first component starts at character position 4 with a length of 5 bytes and its second component starts at character position 10 with a length of 5 bytes.
20,2,ad | represents the second (alternate) key which can have duplicates and starts at character position 20 with a length of 2 bytes
40,2,a,46,10,c | represents the third key. This is a split alternate key, with the first component starting at character position 40 with a length of 2 bytes and the second component starting at character position 46 with a length of 10 bytes.
Parent topic: Defining Input and Output Files


Creating a Statistics Report

There are two ways in which you can produce a statistics report:

  • If you are not running under mainframe emulation, you can create a statistical report by using the MFJSTATS environment variable.
    Note: Setting the environment variable MFJSTATS to ON creates a report containing statistics for the SORT that is displayed to SYSOUT. If a report file already exists for a previous SORT, the new statistics are appended to the end of the previous one. The syntax is MFJSTATS=ON.
  • If you are running under mainframe emulation, see the section Sort/Merge Operations (MFJSORT) in the chapter Utility Programs of your Mainframe Subsystem Support Developer's Guide for more information.
Parent topic: MFSORT and MFJSORT Utilities
Related information
Introduction
DFSORT and ICETOOL Emulation
SYNCSORT Emulation
Invoking Mfsort
Example Commands
Error Messages


Example Commands

This section gives some examples of mfsort commands and jobstreams.

You may find it helpful to refer to the Examples of DFSORT Job Streams section of your DFSORT Application Programming Guide.

  • Sorting Using More Than One File
  • Single File Sort Using INCLUDE and a Sub-string Comparison
  • Single File Sort Using Environment Variables
  • Transforming Records Using OUTREC
  • Sort Using OUTFIL for Complex Reporting
Parent topic: MFSORT and MFJSORT Utilities
Related information
Introduction
DFSORT and ICETOOL Emulation
SYNCSORT Emulation
Invoking Mfsort
Creating a Statistics Report
Error Messages


Sorting Using More Than One File

Imagine four indexed files (north.dat, south.dat, east.dat and west.dat) which contain for the north, south, east and west of the country the scores achieved by members of a national organisation in a national competition. The COBOL syntax used to define north.dat is shown below:

 file-control.
     select idxfile assign to "north.dat"
         organization is indexed
         record key is member-id.
 data division.
 file section.
 fd idxfile
     record contains 39 characters.
 01 idxfile-record.
     03 member-id  pic 9(6).
     03 surname    pic x(15).
     03 first-name pic x(15).
     03 score      pic 9(3).

Each of the other files has been created in the same way and the results of the competition have been entered in the files. The following examples use these files.

  • Character Sort in Ascending Order
  • Numeric Sort in Descending Order
  • Omitting Records
Parent topic: Example Commands


Character Sort in Ascending Order

The following mfsort commands takes all of the records from each of the four files, sorts them on the member's surname in ascending order and outputs the result to the relative file members.dat:

mfsort sort fields(7,15,ch,a)
   use north.dat
   use south.dat
   use east.dat
   use west.dat
   give members.dat org rl
Parent topic: Sorting Using More Than One File


Numeric Sort in Descending Order

The following mfsort command takes each of the four files, sorts them on the member's score (highest score first) and outputs the result to the relative file scores.dat:

mfsort sort fields(37,3,nu,d)
   use north.dat
   use south.dat
   use east.dat
   use west.dat
   give scores.dat org rl
Parent topic: Sorting Using More Than One File


Omitting Records

The following mfsort command takes each of the four files, sorts them on the membership number (which is the primary key) and outputs the result to the indexed file national.dat. All records for which the score field is less than 20 are omitted:

mfsort sort fields(1,6,nu,a)
   use north.dat
   use south.dat
   use east.dat
   use west.dat
   give national.dat
   omit cond (37,3,nu,lt,20)
Parent topic: Sorting Using More Than One File


Single File Sort Using INCLUDE and a Sub-string Comparison

The following mfsort command takes a line sequential file, sortin.dat and sorts its records on a character field starting at position 11 with a length of 4 bytes. The results are output to the file sortout.dat which will include only records for which the sub-string, starting at position 15 of length 3 bytes, is equal to any three consecutive characters in the string 'J69,L92,J82'.

mfsort sort fields=(11,4,ch,a)
   use sortin.dat org ls record (f 80)
   give sortout.dat
   include cond=(15,3,ss,eq,c'J69,L92,J82')
Parent topic: Example Commands


Single File Sort Using Environment Variables

The following mfsort command takes a text file, unsorted.txt and a file a.1, sorts its records in ascending order, and outputs the result to the file sorted.txt.

set $infile=unsorted.txt
set $outfile=sorted.txt

mfsort take a.1

where unsorted. txt contains:

BBBBBBBBBBBBBBBBBBBB
CCCCCCCCCCCCCCCCCCCC
AAAAAAAAAAAAAAAAAAAA

and a.1 contains:

use $infile org LS
sort
give $outfile
Parent topic: Example Commands


Transforming Records Using OUTREC

The following mfsort command transforms records containing a field of format cyymmdd to the format yyymmdd.

Sort C'cyymmdd'
     SORT FIELDS=(1,7,BI,A)        * sort C'cyymmdd'
     use mfs110a.in org ls record (f 40)
    * Transform C'cyymmdd' to C'yyyymmdd'
     OUTFIL OUTREC=(1,1,CHANGE=(2, * change C'c' as follows:
                      C'0',C'19',  *   C'0' to C'19'
                      C'1',C'20',  *   C'1' to C'20'
                      C'2',C'21'), *   C'2' to C'21'
                      NOMATCH=(C'99')
                    2,6)           * copy C'yymmdd'

     give sortout.dat
Parent topic: Example Commands


Sort Using OUTFIL for Complex Reporting

The following is an example of how to use the OUTFIL command to produce a complex report, in this case a Profit and Loss report for one of four divisions. The input file, mfs121a.dat is sorted on the first two fields and only records from the western region are output. The SECTIONS instruction produces a page throw when the field starting in position 3, length 10 bytes changes. The following shows:

  • The input data
  • The mfsort command
  • The resultant output
  • Input Data
  • Mfsort Command
  • Output
Parent topic: Example Commands


Input Data

  Chips        San Martin     0088902203 West
  Chips        Oakland        0023412432 West
  Chips        San Jose       0123213335 West
  Ice Cream    Marin          0054234123 West
  Chips        Gilroy         0055484342 West
  Ice Cream    Napa           0085734283 West
  Pretzels     San Jose       0123488534 West
  Ice Cream    San Francisco  0092231245 West
  Chips        San Francisco  000324343q West
  Chips        San Jose       0123213335 South
  Ice Cream    San Martin     0100346730 West
  Pretzels     Marin          0534332344 West
  Chips        Gilroy         0055484342 South
  Chips        Morgan Hill    0098732232 West
  Pretzels     Morgan Hill    0084384340 West
  Ice Cream    San Jose       000002345u West
  Pretzels     Napa           0531234856 West
  Chips        Oakland        0023412432 South
  Pretzels     San Martin     000023438r West
  Chips        Los Angeles    000223401t West
  Ice Cream    Marin          0054234123 South
  Pretzels     San Francisco  0541230005 West
  Ice Cream    Napa           0085734283 South
  Pretzels     San Jose       0123488534 South
  Ice Cream    San Francisco  0092231245 South
  Chips        San Francisco  000324343q South
  Ice Cream    San Martin     0100346730 South
  Pretzels     Marin          0534332344 South
  Chips        Morgan Hill    0098732232 South
  Pretzels     Morgan Hill    0084384340 South
  Ice Cream    San Jose       000002345u South
  Pretzels     Napa           0531234856 South
  Pretzels     San Martin     000023438r South
  Chips        Los Angeles    0002234014 South
  Pretzels     San Francisco  0541230005 South
Parent topic: Sort Using OUTFIL for Complex Reporting
Related information
Mfsort Command
Output


Mfsort Command

SORT FIELDS=(3,10,A,16,13,A),FORMAT=CH

  use mfs121a.dat  org ls record (f 80)
  OUTFIL
   INCLUDE=(42,6,CH,EQ,C'West'),
   HEADER1=(5/,18:'    Western Region',3/,
               18:'Profit and Loss Report',3/,
               18:'     for  ',&DATE,3/,
               18:'      Page',&PAGE),
   OUTREC=(6:16,13,24:31,10,ZD,M5,LENGTH=20,75:X),
   SECTIONS=(3,10,SKIP=P,
    HEADER3=(2:'Division:  ',3,10,5X,'Page:',&PAGE,2/,
             6:'Branch Office',24:'       Profit/(Loss)',/,
             6:'-------------',24:'--------------------'),
    TRAILER3=(6:'=============',24:'====================',/,
             6:'Total',24:TOTAL=(31,10,ZD,M5,LENGTH=20),/,
             6:'Lowest',24:MIN=(31,10,ZD,M5,LENGTH=20),/,
             6:'Highest',24:MAX=(31,10,ZD,M5,LENGTH=20),/,
             6:'Average',24:AVG=(31,10,ZD,M5,LENGTH=20),/,
             3/,2:'Average for all Branch Offices so far:',
                X,SUBAVG=(31,10,ZD,M5))),
    TRAILER1=(8:'Page ',&PAGE,5X,'Date:  ',&DATE,5/,
            8:'Total Number of Branch Offices Reporting:  ',
              COUNT,2/,
            8:'Summary of Profit/(Loss) for all',
              ' Western Division Branch Offices',2/,
            12:'Total:',
                22:TOTAL=(31,10,ZD,M5,LENGTH=20),/,
            12:'Lowest:',
                22:MIN=(31,10,ZD,M5,LENGTH=20),/,
            12:'Highest:',
                22:MAX=(31,10,ZD,M5,LENGTH=20),/,
            12:'Average:',
                22:AVG=(31,10,ZD,M5,LENGTH=20))
      give outfil1.dat
Parent topic: Sort Using OUTFIL for Complex Reporting
Related information
Input Data
Output


Output

                     Western Region

                 Profit and Loss Report

                      for  11/05/95

                       Page     1
************************************************************
  Division:  Chips          Page:     2

     Branch Office            Profit/(Loss)
     -------------     --------------------
     Gilroy                     554,843.42
     Los Angeles                (22,340.14)
     Morgan Hill                987,322.32
     Oakland                    234,124.32
     San Francisco              (32,434.31)
     San Jose                 1,232,133.35
     San Martin                 889,022.03
     =============     ====================
     Total                    3,842,670.99
     Lowest                     (32,434.31)
     Highest                  1,232,133.35
     Average                    548,952.99

 Average for all Branch Offices so far:     548,952.99
************************************************************
  Division:  Ice Cream      Page:     3

     Branch Office            Profit/(Loss)
     -------------     --------------------
     Marin                      542,341.23
     Napa                       857,342.83
     San Francisco              922,312.45
     San Jose                      (234.55)
     San Martin               1,003,467.30
     =============     ====================
     Total                    3,325,229.26
     Lowest                        (234.55)
     Highest                  1,003,467.30
     Average                    665,045.85

 Average for all Branch Offices so far:     597,325.02
************************************************************
  Division:  Pretzels       Page:     4

     Branch Office            Profit/(Loss)
     -------------     --------------------
     Marin                    5,343,323.44
     Morgan Hill                843,843.40
     Napa                     5,312,348.56
     San Francisco            5,412,300.05
     San Jose                 1,234,885.34
     San Martin                  (2,343.82)
     =============     ====================
     Total                   18,144,356.97
     Lowest                      (2,343.82)
     Highest                  5,412,300.05
     Average                  3,024,059.49

 Average for all Branch Offices so far:   1,406,236.51
************************************************************
        Page      5     Date:  11/05/95

       Total Number of Branch Offices Reporting:        18

       Summary of Profit/(Loss) for all Western Division
          Branch Offices

           Total:          25,312,257.22
           Lowest:            (32,434.31)
           Highest:         5,412,300.05
           Average:         1,406,236.51
Parent topic: Sort Using OUTFIL for Complex Reporting
Related information
Input Data
Mfsort Command


Workfile

During a sort or merge operation, mfsort uses a temporary workfile. This workfile is paged to disk in the current directory or, if it is set, in the directory specified by the TMP or TEMP environment variable. If not set, the current working directory is used.

Mfsort copies all the records from each of the input files to the temporary workfile, truncated or padded as appropriate. The workfile is then sorted or merged according to its key description. After being sorted or merged in the workfile, the records are copied to each of the output files and truncated or padded as appropriate.

During this operation:

  • If you do not need any of the records to be truncated, you must ensure that the record length of the workfile is sufficient for the longest record to be sorted
  • If your input files are of variable length and the sort workfile is not, all concept of variable-length is lost
  • If your input file is fixed length and the workfile is variable length, the record length of the record in the workfile is either the fixed length of the input file or the maximum record length of the workfile, whichever is the smaller


Error Messages

A full list of mfsort error messages is given in the topic Mfsort Error Messages.

Parent topic: MFSORT and MFJSORT Utilities
Related reference
Mfsort Error Messages
Related information
Introduction
DFSORT and ICETOOL Emulation
SYNCSORT Emulation
Invoking Mfsort
Creating a Statistics Report
Example Commands


Btrieve

  • Xfh2btr Call Conversion Module
  • Calling Xfh2btr
  • Btrieve Environment Variables
  • Xfh2btr Configuration File
  • Xfh2btr Differences
  • Calling Btrieve in Non-ANSI Mode
  • Btrieve Error Messages
Parent topic: File Handling Guide
Related information
Introduction
File Organizations
Filenames
File Status
Sharing Files
File Handler Configuration
File Handler and Sort APIs
MFSORT and MFJSORT Utilities
Data and Key Compression
Tracing File Operations


Xfh2btr Call Conversion Module

The Xfh2btr call conversion module enables you to use the Micro Focus File Handler API to access Btrieve files from this COBOL system.

Btrieve does not normally conform to ANSI standards but, by default, the Xfh2btr call conversion module makes the necessary calls to the Btrieve run-time system to force it to emulate ANSI behavior. You can, however, choose to operate in non-ANSI mode.

Xfh2btr is compatible with versions of Btrieve 6.1x and above.

It is supplied as part of this COBOL system and also as a linkable module, xfh2btr.obj, which can be linked with any application that needs to perform I/O on Btrieve files.

When the call conversion module needs to call the Btrieve run-time system to perform I/O, it calls the module _BTRV. The function of this module is to format the call and pass it to the Btrieve Microkernel Interface (wbtrv32.dll for Windows). Note that you can call the module _BTRV directly from your COBOL program using the same parameters as those used in Btrieve API calls (see your Btrieve Programmer's Reference Manual).

When linking any application to a standalone executable file, you need to link in _btrv.obj. Alternatively, if you have the Btrieve Developer's Kit, you can link the modules supplied by Pervasive Software in place of _btrv.obj. These are cobrbtrv.obj and cobpbtrv.obj. For more details of these modules, see the documentation supplied with the Btrieve Developer's Kit.

Parent topic: Btrieve
Related information
Calling Xfh2btr
Btrieve Environment Variables
Xfh2btr Configuration File
Xfh2btr Differences
Calling Btrieve in Non-ANSI Mode
Btrieve Error Messages


Calling Xfh2btr

There are three ways of calling the Xfh2btr call conversion module:

  • Use the CALLFH Compiler directive
  • Use the FILETYPE Compiler directive
  • Use external filename assignment

Note that some file operations and formats are not supported by Btrieve; for example, WRITE AFTER and line sequential files. In these cases, if you try and direct file I/O to the converter, you will get an error returned to your program.

  • CALLFH Compiler Directive
  • FILETYPE Compiler Directive
Parent topic: Btrieve
Related information
Xfh2btr Call Conversion Module
Btrieve Environment Variables
Xfh2btr Configuration File
Xfh2btr Differences
Calling Btrieve in Non-ANSI Mode
Btrieve Error Messages


CALLFH Compiler Directive

The CALLFH Compiler directive specifies the file handler used by your program to perform all COBOL I/O operations. By default, if no file handler is specified, the Micro Focus File Handler is used.

If you use the CALLFH Compiler directive to specify the Xfh2btr call conversion module, your program passes all I/O to the Xfh2btr call conversion module so that COBOL I/O operations are converted to Btrieve I/O operations.

You can include CALLFH at the top of your source program as an initial $SET statement as follows:

$set callfh"xfh2btr"
Parent topic: Calling Xfh2btr
Related information
FILETYPE Compiler Directive


FILETYPE Compiler Directive

The FILETYPE Compiler directive specifies the format of files created by your program.

You can put the FILETYPE Compiler directive at the top of your program as an initial $SET statement as follows:

$set filetype"n"

where n, in this case, can be either 5 or 6.

FILETYPE"5" is used when it is important for file operations to conform to ANSI standards. Btrieve does not normally conform to ANSI standards and this mode of operation requires a number of calls to the Btrieve run-time system to force it to emulate ANSI behavior.

FILETYPE"6" is used when speed is important. In this mode of operation, each Micro Focus File Handler operation is mapped to the nearest Btrieve run-time call. No attempt is made to conform to ANSI standards.

You can mix different types of file in your program by putting the FILETYPE Compiler directive around individual SELECT statements, for example:

$set filetype"0"
select testfile-1 assign to "test-1.dat"
   organization indexed
   record key prime-key
   access sequential.
$set filetype"5"
select testfile-2 assign to "test-2.dat"
   organization relative
   access sequential.

In the above example, all I/O on test-1.dat is handled by the Micro Focus File Handler while all I/O on test-2.dat is handled by the Xfh2btr call conversion module.

Note: Note:

To specify the format to use when creating an indexed file, you can include the IDXFORMAT parameter under that file's settings in your File Handler configuration file. Set IDXFORMAT to either 5 or 6 to indicate Btrieve with or without ANSI conformance respectively. For more information, see the chapter File Handler Configuration.

Parent topic: Calling Xfh2btr
Related information
CALLFH Compiler Directive
File Handler Configuration


Btrieve Environment Variables

There are two environment variables that you can set to change the way in which the Xfh2btr call conversion module operates: BTRPAGE and BTRMAXREC.

  • BTRPAGE Environment Variable
  • BTRMAXREC Environment Variable
Parent topic: Btrieve
Related information
Xfh2btr Call Conversion Module
Calling Xfh2btr
Xfh2btr Configuration File
Xfh2btr Differences
Calling Btrieve in Non-ANSI Mode
Btrieve Error Messages


BTRPAGE Environment Variable

The BTRPAGE environment variable specifies the page size that is used when Btrieve files are created. You can set it using the following command:

set BTRPAGE=nnn

where nnn is a byte value in the range 512 to 4096 inclusive, in multiples of 512 bytes. The value must be greater than the record size.

If you do not set BTRPAGE, or you specify a wrong value, the page size defaults to 1024 bytes.

Note: Notes:

  • The page size affects the number of keys you can define in the file and where the keys can occur in the record
  • The Btrieve Record Manager must be loaded with the correct page size
  • You can specify the value of BTRPAGE on a per-file basis using the xfh2btr configuration file
Parent topic: Btrieve Environment Variables
Related information
BTRMAXREC Environment Variable


BTRMAXREC Environment Variable

The BTRMAXREC environment variable specifies the maximum record size.

You can set BTRMAXREC using the following command:

set BTRMAXREC=nnnn

where nnnn is a byte value specifying the maximum record length.

You should set BTRMAXREC to the record size of the largest record to be accessed.

If you do not set BTRMAXREC, the default value of 32 Kilobytes is used.

You can specify the value of BTRMAXREC on a per-file basis using the xfh2btr configuration file.

Parent topic: Btrieve Environment Variables
Related information
BTRPAGE Environment Variable


Xfh2btr Configuration File

Note: Note:

If you need to use the Xfh2btr configuration file you must link your program with mfini.obj.

The Xfh2btr configuration file enables you to specify the page size, maximum record length and Btrieve open mode for all files or for an individual file.

You can specify the name of the configuration file via the XFH2BTR environment variable. If this environment variable is not set, the default configuration filename of xfh2btr.cfg is used. The configuration file is searched for first in the current directory and then along the path specified by the COBDIR environment variable.

The tag [X2B-DEFAULTS] is used to specify default values for page size, maximum record length and Btrieve open mode while a tag containing a filename (for example [test.dat]) is used to specify values for a particular file.

  • Page size
  • Maximum record length
  • Btrieve open mode

Attribute names can be separated from attribute values by a space or a colon (:) character.

Note: Note:

If a configuration file exists, the settings of the Btrieve environment variables BTRPAGE and BTRMAXREC are ignored.

You can also turn on the Xfh2btr trace option and specify the name of the trace file via the Xfh2btr configuration file.

  • Page Size
  • Maximum Record Size
  • Btrieve File Open Mode
  • Example Xfh2btr Configuration File
  • Trace Option
Parent topic: Btrieve
Related information
Xfh2btr Call Conversion Module
Calling Xfh2btr
Btrieve Environment Variables
Xfh2btr Differences
Calling Btrieve in Non-ANSI Mode
Btrieve Error Messages


Page Size

You can specify the page size to use when creating a Btrieve file by setting an attribute in the Xfh2btr configuration file as follows:

BTRPAGE:nnn

where nnn is a byte value in the range 512 to 4096 inclusive, in multiples of 512 bytes.

If you do not set BTRPAGE, or you specify a wrong value, the page size defaults to 1024 bytes.

Parent topic: Xfh2btr Configuration File
Related information
Maximum Record Size
Btrieve File Open Mode
Example Xfh2btr Configuration File
Trace Option


Maximum Record Size

You can specify the maximum record size for a Btrieve file by setting an attribute in the Xfh2btr configuration file as follows:

BTRMAXREC:nnnn

where nnnn is a byte value. You should set BTRMAXREC to the record size of the largest record to be accessed. If you do not set BTRMAXREC, the default value of 32 Kilobytes is used.

Parent topic: Xfh2btr Configuration File
Related information
Page Size
Btrieve File Open Mode
Example Xfh2btr Configuration File
Trace Option


Btrieve File Open Mode

You can use the Xfh2btr configuration file to specify the Btrieve open mode used to open a file:

INPUT-EXCLUSIVE:open-mode
INPUT-SHAREABLE:open-mode
OUTPUT:open-mode
EXTEND-EXCLUSIVE:open-mode
EXTEND-SHAREABLE:open-mode
I-O-EXCLUSIVE:open-mode
I-O-SHAREABLE:open-mode

The possible values of open-mode are: normal, accelerated, read-only, verify, exclusive. For further details on these open modes, consult your Btrieve documentation.

Parent topic: Xfh2btr Configuration File
Related information
Page Size
Maximum Record Size
Example Xfh2btr Configuration File
Trace Option


Example Xfh2btr Configuration File

[X2B-DEFAULTS]
output:accelerated
i-o-shareable:accelerated
i-o-exclusive:accelerated
btrpage:2048
btrmaxrec:2000
[test1.dat]
output:exclusive
i-o-shareable:normal
btrpage:4096

The above is an example Xfh2btr configuration file which specifies the following:

  1. The default open mode for files opened OUTPUT is accelerated
  2. The default open mode for files opened I/O which are shareable is accelerated
  3. The default open mode for files opened I/O which are exclusive is accelerated
  4. The default page size to use when creating files is 2048 bytes
  5. The default maximum record length is 2000 bytes
  6. For the file test1.dat, OPEN OUTPUT operations open the file exclusively
  7. For the file test1.dat, OPEN I/O operations which are shareable use the normal open mode
  8. For the file test1.dat, the page size to use when creating the file is 4096 bytes
Parent topic: Xfh2btr Configuration File
Related information
Page Size
Maximum Record Size
Btrieve File Open Mode
Trace Option


Trace Option

If the Xfh2btr trace option is set, every operation performed by the Xfh2btr call conversion module and every error code returned by the Btrieve Record Manager are either displayed on the screen or recorded in a trace file.

If an error is returned by the Btrieve Record Manager, the Xfh2btr call conversion module maps the Btrieve error to a COBOL file status code which it returns to your program. The COBOL file status code to which a Btrieve error has been mapped is also displayed in the trace file.

If a Btrieve error is not shown on the trace but a COBOL file status is returned, the error has been generated in the Xfh2btr call conversion module. For example, trying to write to a file opened for input would generate such an error.

There are two attributes that effect the trace option: TRACE-FILE and TRACE.

TRACE-FILE:filename

This specifies that the trace information is to be directed to the specified file and not to the screen. If no filename is specified, the default filename, xfh2btr.lst, is used. The trace-file attribute can only be specified under the [X2B-DEFAULTS] tag. If a number of client applications are writing trace information to the same trace file, the order in which the information appears in the file is undetermined.

Note: Note:

Specifying a trace filename does not turn on the TRACE facility.

TRACE

The TRACE attribute switches tracing on. It can be specified under the [X2B-DEFAULTS] tag (in which case operations on all files are traced) or under a filename tag (in which case only operations on that file are traced).

  • Example Trace Option Settings
  • Example Trace Output
Parent topic: Xfh2btr Configuration File
Related information
Page Size
Maximum Record Size
Btrieve File Open Mode
Example Xfh2btr Configuration File


Example Trace Option Settings

The following entries in the Xfh2btr configuration file:

[X2B-DEFAULTS]
trace-file:x2btrace.dat
trace:

specify that tracing is on for every file and that the trace information is written to the file x2btrace.dat.

The following entries in the Xfh2btr configuration file:

[X2B-DEFAULTS]
trace-file:
[test1.dat]
trace:

specify that tracing is on for the file test1.dat and that the trace information is written to the file xfh2btr.lst (the default trace filename).

Parent topic: Trace Option
Related information
Example Trace Output


Example Trace Output

Below is an example of the output produced when the trace option is used:

                                                Line
Input FA01 ifile1.tmp                            1
Output Btrieve Error=+0000 COBOL Error=0/0       2
Input FAF3 ifile1.tmp                            3
Output Btrieve Error=+0000 COBOL Error=0/0       4
Input FAF3 ifile1.tmp                            5
Output Btrieve Error=+0000 COBOL Error=0/0       6
Input FADC All Files                             7
Output Btrieve Error=+0000 COBOL Error=0/0       8
Input FA80 ifile1.tmp                            9
Output Btrieve Error=+0000 COBOL Error=0/0      10
Input FA02 ifile1.tmp                           11
Output Btrieve Error=+0000 COBOL Error=0/0      12
Input FAF5 ifile1.tmp                           13
Output Btrieve Error=+0000 COBOL Error=0/0      14
Input FAF5 ifile1.tmp                           15
Output Btrieve Error=+0000 COBOL Error=0/0      16
Input FAF5 ifile1.tmp                           17
Output Btrieve Error=+0009 COBOL Error=1/0      18
Input FA80 ifile1.tmp                           19
Output Btrieve Error=+0000 COBOL Error=0/0      20
Input FA01 test.dat                             21
Output Btrieve Error=+0029 COBOL Error=9/078    22
Input FA00 ifile1.tmp                           23
Output Btrieve Error=+0000 COBOL Error=0/0      24
Input FAF3 ifile1.tmp                           25
Output Btrieve Error=+0000 COBOL Error=4/8      26
Input FA80 ifile1.tmp                           27
Output Btrieve Error=+0000 COBOL Error=0/0      28

Line 1 shows an example input line: the operation code and the name of the file on which the operation is being performed.

Line 2 shows an example output line: the Btrieve error status and the error being returned to the COBOL application.

Line 7 shows an example of an operation (in this case, COMMIT) being performed on all open files.

Line 22 shows the error status 29 being returned from the Btrieve run-time system and that this is returned to the COBOL application as a 9/078 status. For details of the Btrieve error status 29, see the relevant Btrieve documentation.

Line 26 shows an error that is generated in the Xfh2btr module. An attempt is being made to write to a file which is opened for INPUT.

Parent topic: Trace Option
Related information
Example Trace Option Settings


Xfh2btr Differences

The majority of COBOL file operations performed by the Micro Focus File Handler operate in exactly the same way when performed by Xfh2btr on Btrieve files. However, due to underlying differences between the two systems, there are instances where behavior differs. These include:

  • Keys
  • Locked record detection
  • OPEN OUTPUT operation
  • Record lengths
  • Current Record Pointer (CRP)
  • Transaction processing
  • WRITELOCK
Note: Note:

You should especially note the positioning of the current record pointer (CRP) when performing sequential read operations after having written, rewritten or deleted records in a file.

  • Keys
  • Locked Record Detection
  • OPEN OUTPUT Operation
  • Record Lengths
  • Current Record Pointer (CRP)
  • Transaction Processing
  • WRITELOCK Compiler Directive
Parent topic: Btrieve
Related information
Xfh2btr Call Conversion Module
Calling Xfh2btr
Btrieve Environment Variables
Xfh2btr Configuration File
Calling Btrieve in Non-ANSI Mode
Btrieve Error Messages


Keys

With keys, the differences are:

  • Using Btrieve v5.x or earlier, the total number of key components per file (a normal key has one component, a split key has more than one) cannot exceed 24. So, you can have one key of 24 components, 24 keys of one component or any combination of these.
  • Using Btrieve v6.x or later, the maximum number of key components depends on the page size of the file. The page size of a file can be specified via the Btrieve environment variable, BTRPAGE or via the Xfh2btr configuration file. For files with a page size of 4096 bytes, the maximum number of key components is 119. See your Btrieve documentation for more details.
  • The Xfh2btr module does not verify the number of key components in the file; if your version of Btrieve does not support the required number of key components then any error returned from the Btrieve run-time system is reported to your application program
  • The total length of any key in a Btrieve file cannot exceed 255 bytes
  • All keys in a Btrieve file must be completely contained in the fixed part of a variable length file
  • Using Btrieve, you cannot perform a START operation with a part-key; you must use the whole key
Parent topic: Xfh2btr Differences
Related information
Locked Record Detection
OPEN OUTPUT Operation
Record Lengths
Current Record Pointer (CRP)
Transaction Processing
WRITELOCK Compiler Directive


Locked Record Detection

When this COBOL system reads a record that is locked by another user, the record data is returned to the program together with a COBOL file status of 9/068 ("Record locked").

With Btrieve, if a record is locked, the data is not returned and so reading a locked record requires multiple calls to the Btrieve run-time system, making default record reading slower.

You can improve the speed of read operations by:

  • Opening the file with an exclusive lock

    When you do this, calls to the Btrieve run-time system to detect record locks are not required because the file is locked exclusively and so individual records do not need to be checked

  • Using the NODETECTLOCK Compiler directive

    If this directive is set no calls are made to the Btrieve run-time system to see if the record is locked by another user

  • Accessing the file from a transaction

    When you access a Btrieve file from a transaction, a temporary exclusive lock is obtained on the file and so calls to the Btrieve run-time system to detect record locks are not required

Parent topic: Xfh2btr Differences
Related information
Keys
OPEN OUTPUT Operation
Record Lengths
Current Record Pointer (CRP)
Transaction Processing
WRITELOCK Compiler Directive


OPEN OUTPUT Operation

The COBOL OPEN OUTPUT operation creates a file and opens it with an exclusive lock. This is performed in a single operating system call. With Btrieve, this operation requires two calls to the Btrieve run-time system, the first to create the file and the second to open the file with an exclusive lock. Because a small time lapse exists between these two calls, it is possible for a second user to access the file between the time that the file is created and the time that it is opened. If this happens, the second user finds the file empty and an attempt to read the file results in an "at end" error. The user performing the OPEN OUTPUT receives a "file locked" error because the exclusive OPEN call fails.

Parent topic: Xfh2btr Differences
Related information
Keys
Locked Record Detection
Record Lengths
Current Record Pointer (CRP)
Transaction Processing
WRITELOCK Compiler Directive


Record Lengths

In a Btrieve file, variable length records consist of two parts: a fixed length part and a variable length part. Fixed length records consist of only the fixed length part.

For variable length records, the fixed length part of the record is usually determined by the minimum record length defined in your COBOL program. However, depending on the number of keys which allow duplicates and the page size used, Btrieve may impose restrictions on the maximum length of the fixed part of the record. The formula for determining the maximum length of the fixed part of a record is given below:

p - 6 - ( 8 * k ) [- 4 for variable length records] [- 4 for relative files]

where the parameters are:

p | The page size of the file.
k | The number of keys that allow duplicates.
Note: Notes:

  • If you try to create a Btrieve file with fixed length records and specify a record length that is greater than the maximum size allowed for the fixed part of the Btrieve record, the file is created as a variable length Btrieve file with the fixed part set to the maximum size allowed
  • If you try and create a Btrieve file with variable length records and specify a minimum record length that is greater than the maximum size allowed for the fixed part, the file is created with the fixed part set to the maximum size allowed
  • Btrieve requires that all the keys are defined in the fixed part of a Btrieve record
  • Relative files are created as Btrieve keyed files with a four-byte auto-increment key at the front of each record. This processing of the key is transparent to the user program. However, the physical Btrieve file has a fixed record length four bytes larger than that calculated using the above formula.
  • Example of Btrieve Record Lengths
Parent topic: Xfh2btr Differences
Related information
Keys
Locked Record Detection
OPEN OUTPUT Operation
Current Record Pointer (CRP)
Transaction Processing
WRITELOCK Compiler Directive


Example of Btrieve Record Lengths

The following examples use a page size of 1024 bytes:

  • A fixed length record index file with a record length of 1018 bytes creates a fixed length record Btrieve file with a fixed record length of 1018 bytes

    All the keys must be in the first 1018 bytes of the record

  • A fixed length record index file with a record length of 1019 bytes creates a variable length record Btrieve file with a fixed record length of 1014 bytes

    All the keys must be in the first 1014 bytes of the record

  • A fixed length record index file with a record length of 1010 bytes and one key which allows duplicates creates a fixed length record Btrieve file with a fixed record length of 1010 bytes

    All of the keys must be in the first 1010 bytes of the record

  • A fixed length record index file with a record length of 1011 bytes and one key which allows duplicates creates a variable length record Btrieve file with a fixed record length of 1006 bytes

    All of the keys must be in the first 1006 bytes of the record

  • A fixed length record relative file with a record length of 1014 bytes creates a fixed length record Btrieve file with a fixed record length of 1018 bytes

    The additional four bytes is due to the auto-increment key that is added automatically to the front of each record. If you are using the opcode 06 action-code for the Micro Focus File Handler call interface, the record length returned is 1014 bytes.

  • A fixed length relative file with a record length of 1015 bytes creates a variable length Btrieve file with a fixed record length of 1014 bytes. This is because you are limited to a maximum of 1014 bytes.

    This length includes the additional four bytes automatically added to the front of each record, due to the auto-increment key. If you are using the opcode 06 action-code for the Micro Focus File Handler call interface, the record length returned is 1010 bytes.

  • A variable length record index file with a minimum record length of 1014 bytes creates a variable length record Btrieve file with a fixed record length of 1014 bytes

    All of the keys must be in the first 1014 bytes of the record

  • A variable length record index file with a minimum record length of 1015 bytes creates a variable length record Btrieve file with a fixed record length of 1014 bytes

    All of the keys must be in the first 1014 bytes of the record

  • A variable length record index file with a minimum record length of 1006 bytes and one key which allows duplicates creates a variable length record Btrieve file with a fixed record length of 1006 bytes

    All of the keys must be in the first 1006 bytes of the record

  • A variable length record index file with a minimum record length of 1007 bytes and one key which allows duplicates creates a variable length record Btrieve file with a fixed record length of 1006 bytes

    All of the keys must be in the first 1006 bytes of the record

  • A variable length record relative file with a minimum record length of 1010 bytes creates a variable length record Btrieve file with a fixed record length of 1014 bytes

    The additional four bytes is due to the auto-increment key that is added automatically to the front of each record. If you are using the opcode 06 action-code for the Micro Focus File Handler call interface, the record length returned is 1010 bytes.

  • A variable length record relative file with a minimum record length of 1011 bytes creates a variable length record Btrieve file with a fixed record length of 1014 bytes

    The additional four bytes is due to the auto-increment key that is added automatically to the front of each record. If you are using the opcode 06 action-code for the Micro Focus File Handler call interface, the record length returned is 1010 bytes.

Parent topic: Record Lengths


Current Record Pointer (CRP)

With this COBOL system, the Current Record Pointer (CRP) is only affected when START, READ (sequential or random) and OPEN operations are performed on the file.

With the Btrieve run-time system, however, the CRP is affected by WRITE, REWRITE and DELETE operations. This means that, following these operations, the CRP in a Btrieve file has to be restored to its original position so that sequential READ statements are not affected.

In a shared environment, the re-positioning of the CRP can fail if the record to be re-positioned on has been deleted by another user. If this happens, any attempt to perform a sequential READ returns an error.

In the following sections, re-positioning of the CRP is performed after the operation has completed and not at the time of the next sequential READ statement. This reduces the possibility of the record being deleted and increases the possibility of successfully re-positioning the CRP.

Note: Note:

The non-ANSI conforming mode of operation does not try to re-position the CRP and can, therefore, be significantly faster.

  • Sequential READ Operations After WRITE Operations
  • Sequential READ Operations After DELETE Operations
  • Sequential READ Operations After REWRITE Operations
Parent topic: Xfh2btr Differences
Related information
Keys
Locked Record Detection
OPEN OUTPUT Operation
Record Lengths
Transaction Processing
WRITELOCK Compiler Directive


Sequential READ Operations After WRITE Operations

For shared files opened I/O that are not in transactions where the ANSI conforming mode of operation is being used, the file is actually opened twice. The first open of the file is used to read records from the file. The second open of the file is used to write records to the file. Therefore, it is not possible for the reading position to be affected by normal WRITE operations. However, if you use the WRITELOCK directive, the inserted record has to be read back with a lock and this changes the CRP in the file.

Re-positioning the Btrieve file position indicator after a WRITE operation can only fail if WRITELOCK directives are used and the file is shareable. If the re-positioning after the WRITE operation fails, an error is returned when the sequential READ is attempted.

Parent topic: Current Record Pointer (CRP)
Related information
Sequential READ Operations After DELETE Operations
Sequential READ Operations After REWRITE Operations


Sequential READ Operations After DELETE Operations

For files opened I/O with random or dynamic access, the Btrieve file position indicator has to be moved to the position of the record to be deleted. After performing the DELETE operation, the file position indicator is restored to its original position, although this could fail if the record to re-position on has been deleted.

This problem does not occur for files with sequential access because the file position indicator is already on the record to be deleted and so re-positioning is not necessary.

Note: Note:

It is not possible to perform a sequence of sequential READ and DELETE statements when the key of reference is on a key which allows duplicates. This is because it is not possible to re-position the CRP after the DELETE operation.

Parent topic: Current Record Pointer (CRP)
Related information
Sequential READ Operations After WRITE Operations
Sequential READ Operations After REWRITE Operations


Sequential READ Operations After REWRITE Operations

For files opened I/O with random or dynamic access, the Btrieve file position indicator is moved to the position of the record to be changed. After performing the REWRITE operation, the file position indicator is restored to its original position, although this could fail if the record to re-position on has been deleted.

This problem does not occur for files with sequential access because the file position indicator is already on the record to be rewritten and so re-positioning is not necessary.

Parent topic: Current Record Pointer (CRP)
Related information
Sequential READ Operations After WRITE Operations
Sequential READ Operations After DELETE Operations


Transaction Processing

In this COBOL system, transaction processing is only available if you are using Fileshare but Btrieve users do not require Fileshare to implement transaction processing.

When you update records in a file in a transaction with Fileshare, the individual records in the file are locked to prevent another user from reading the record. This is because there is the possibility of a ROLLBACK operation being performed when a record has been removed from the file. However, when you access a Btrieve file via Xfh2btr from a transaction, the whole file is given a temporary exclusive file lock which prevents other users from accessing the file at the same time. In Btrieve v6.x and later, concurrent transactions are used, so files can be shared in a transaction.

A Btrieve transaction starts whenever a REWRITE, WRITE or DELETE operation is performed for a file that has no transaction in progress and has been opened with ROLLBACK. At this point, Btrieve obtains an exclusive lock on the file and this file lock remains until the transaction finishes, except when concurrent transactions are in use (Btrieve v6.x and later).

Note: Notes:
  • For Btrieve v6.x or above, concurrent Btrieve transactions are used. Btrieve then performs locking at the page level. (See the Btrieve documentation for details.)
  • A transaction finishes when a COMMIT or ROLLBACK operation is performed. The transaction restarts when I/O is performed again on a file which is opened with ROLLBACK.

The CLOSE operation does not re-start transactions because Btrieve CLOSE operations can only be performed when transactions are not active.

File-locked errors are returned by Xfh2btr at the time files are opened, as this is the only time that this COBOL system returns a file-locked error. Btrieve can return a file-locked error on accessing a file in a transaction, although this is converted to a record-locked error by Xfh2btr which is a status that could legitimately be returned by this COBOL system when accessing files in transactions.

Parent topic: Xfh2btr Differences
Related information
Keys
Locked Record Detection
OPEN OUTPUT Operation
Record Lengths
Current Record Pointer (CRP)
WRITELOCK Compiler Directive


WRITELOCK Compiler Directive

With this COBOL system you can use the WRITELOCK Compiler directive to write a record to a file and obtain a lock on the record written. Locks are also obtained on records that are re-written to the file.

With Btrieve the record is first written or re-written to the file and then read back to obtain a lock on the record. This requires a number of calls to the Btrieve run-time system with small time lapses between the calls. It is possible, therefore, for a second user to access the record and obtain a lock on the written record before it can be read back with a lock by the first user.

Parent topic: Xfh2btr Differences
Related information
Keys
Locked Record Detection
OPEN OUTPUT Operation
Record Lengths
Current Record Pointer (CRP)
Transaction Processing


Calling Btrieve in Non-ANSI Mode

Btrieve does not normally conform to ANSI standards but, by default, the Xfh2btr call conversion module makes the necessary calls to the Btrieve run-time system to force it to emulate ANSI behavior. You can, however, choose to operate in non-ANSI mode by setting the FILETYPE Compiler directive to FILETYPE"6".

In this mode of operation, each Micro Focus File Handler operation is mapped to the nearest Btrieve run-time call and no attempt is made to conform to ANSI standards:

  • Any run-time system switches you set in this COBOL system are ignored by the Xfh2btr call conversion module
  • The operation proceeds as if you had specified the NODETECTLOCK Compiler directive
  • No attempt is made to re-position the current record pointer (CRP) after deleting, re-writing or writing records in the file
  • Each COBOL I/O call is mapped to its nearest corresponding Btrieve run-time system call as follows:
    COBOL I/O Call | Btrieve Run-time System Call
    OPEN | Open
    CLOSE | Close
    WRITE | Insert
    READ | Get
    START | Get
    DELETE | Get/Delete
    REWRITE | Get/Delete
    UNLOCK | Unlock
    ROLLBACK | Abort transaction
    COMMIT | End transaction
Parent topic: Btrieve
Related information
Xfh2btr Call Conversion Module
Calling Xfh2btr
Btrieve Environment Variables
Xfh2btr Configuration File
Xfh2btr Differences
Btrieve Error Messages


Btrieve Error Messages

For a full list of Btrieve error messages, see the online help. (Click Help Topics on the Help menu. Then, on the Index tab, double-click Btrieve, errors.)

If an error is returned by the Btrieve Record Manager, the Xfh2btr call conversion module maps the Btrieve error to a COBOL file status code which it returns to your program. Again, these mappings are shown in the online help. (Click Help Topics on the Help menu. Then, on the Index tab, double-click Btrieve, status codes.)

Parent topic: Btrieve
Related information
Xfh2btr Call Conversion Module
Calling Xfh2btr
Btrieve Environment Variables
Xfh2btr Configuration File
Xfh2btr Differences
Calling Btrieve in Non-ANSI Mode


Data and Key Compression

  • Data Compression
  • Key Compression
  • Example of Using Data and Key Compression
  • Compression Routines
Parent topic: File Handling Guide
Related information
Introduction
File Organizations
Filenames
File Status
Sharing Files
File Handler Configuration
File Handler and Sort APIs
MFSORT and MFJSORT Utilities
Btrieve
Tracing File Operations


Data Compression

Data compression enables you to compress the data in a sequential or indexed file. There are two compression mechanisms provided with this COBOL system, run-length encoding (type 1), and extended run-length encoding (type 3).

When a file is defined with run-length encoding, any string of repeating characters is stored as a single character with a repetition count.

You enable data compression using the DATACOMPRESS Compiler directive.

Specifying data compression for a fixed structure sequential file changes it into a variable structure sequential file.

The compression used by a file is determined by the last processed DATACOMPRESS directive when the SELECT statement for the file is processed. Consequently, the compression type can be set for an individual file by using a line of the form:

$SET DATACOMPRESS

immediately before its SELECT statement. You must not forget to turn it off with a $SET NODATACOMPRESS before any other files are processed.

For details on the DATACOMPRESS Compiler directive, see the topic DATACOMPRESS.

Note:

We recommend that you do not use the REWRITE statement on compressed sequential files. This is because a REWRITE operation will only succeed if the length of the compressed new record is the same as the length of the compressed old record.

Parent topic: Data and Key Compression
Related reference
Line Sequential File Structure
Printer Sequential File Structure
Fixed Format Record Sequential File
Fixed Format Relative File
Standard File Header
Standard Record Header
Variable Format Record Sequential File
Variable Format Relative Structure
Index Files - Overview
Types of Indexed File
DATACOMPRESS
Related information
Key Compression
Example of Using Data and Key Compression
Compression Routines


Key Compression

Key compression is a technique that can be applied to the keys of an indexed file. There are four types of compression available:

  • Compression of trailing nulls
  • Compression of trailing spaces
  • Compression of identical leading characters
  • Compression of duplicate alternate key values.

You can specify key compression using the KEYCOMPRESS option in the File Handler configuration file. Use the following integers to indicate which type of compression you want:

1 | Duplicate key compression.
2 | Leading character compression.
4 | Trailing space compression.
8 | Trailing null compression.

You can add these numbers together to specify a combination of compression types (with the exception of trailing nulls and trailing spaces which are mutually exclusive).

Alternatively, you can use the KEYCOMPRESS Compiler directive when compiling the program.

The key compression used by a file is determined by the last processed KEYCOMPRESS directive when the SELECT statement for the file is processed so you can set key compression for an individual file by using a line of the form:

$SET KEYCOMPRESS"8"

immediately before its SELECT statement in your program. You can turn it off again by specifying $SET NOKEYCOMPRESS before any other files are processed.

  • Compression of Trailing Nulls
  • Compression of Trailing Spaces
  • Compression of Leading Characters
  • Compression of Duplicate Keys
Parent topic: Data and Key Compression
Related reference
KEYCOMPRESS
Related information
Data Compression
Example of Using Data and Key Compression
Compression Routines


Compression of Trailing Nulls

When a key is defined with compression of trailing nulls, trailing nulls in a key value are not stored in the file.

For example, assume you have a primary or alternate key that is 30 characters long, and that you write a record in which only the first 10 characters of the key are used, the rest being nulls. Without compression, all 30 characters of the key are stored requiring 30 bytes. With compression of trailing nulls, only 11 bytes are required (10 bytes for the 10 characters of the key and 1 byte which is used to maintain a count of the trailing nulls).

Parent topic: Key Compression
Related information
Compression of Trailing Spaces
Compression of Leading Characters
Compression of Duplicate Keys


Compression of Trailing Spaces

When a key is defined with compression of trailing spaces, trailing spaces in a key value are not stored in the file. However, information is stored so that the key can be correctly located.

For example, assume you have a prime or alternate key that is 30 characters long, and that you write a record in which only the first 10 characters of the key are used, the rest being spaces. Without compression, all 30 characters of the key are stored. With compression of trailing spaces, the key only occupies 11 bytes in the index file (10 bytes for the characters of the key and 1 byte as a count of the trailing spaces).

Parent topic: Key Compression
Related information
Compression of Trailing Nulls
Compression of Leading Characters
Compression of Duplicate Keys


Compression of Leading Characters

When a key is defined with compression of leading characters, all leading characters that match leading characters in the preceding key are not stored in the index file. However, information is stored to enable the key to be correctly reconstructed.

For example, assume that records are written with the following key values in a key defined with compression of leading characters:

AXYZBBB BBCDEFG BBCXYZA BBCXYEF BEFGHIJ CABCDEF

The keys actually stored in the index file are:

AXYZBBB BBCDEFG XYZA    EF      EFGHIJ  CABCDEF
Parent topic: Key Compression
Related information
Compression of Trailing Nulls
Compression of Trailing Spaces
Compression of Duplicate Keys


Compression of Duplicate Keys

When an alternate key is defined with compression of duplicates, only the first duplicate key is contained in the file. The rest are not stored, but information is stored to enable correct recreation of the keys.

For example, suppose you write a record with an alternate key value "ABC". If you have enabled compression of duplicate keys, and you write another record with the same key value, the file handler does not physically store the duplicate key value in the index file. However, the record is still available along the alternate key path.

Parent topic: Key Compression
Related information
Compression of Trailing Nulls
Compression of Trailing Spaces
Compression of Leading Characters


Example of Using Data and Key Compression

In the following program, data compression is specified for transfile but not for masterfile. For key compression, suppression of trailing spaces and of leading characters that are the same as in the previous key is specified for keys t-rec-key and m-rec-key. Suppression of repetition of duplicate keys is also turned on for m-alt-key-1 and m-alt-key-2.

$set callfh"extfh"
$set datacompress"1"
$set keycompress"6"
     select transfile
         assign to ...
         key is t-rec-key.
$set nokeycompress
$set nodatacompress
     select masterfile
         assign to ...
         organization is indexed
$set keycompress"6"
         record key is m-rec-key
$set keycompress"7"
         alternate key is m-alt-key-1 with duplicates
         alternate key is m-alt-key-2.
$set nokeycompress
Parent topic: Data and Key Compression
Related information
Data Compression
Key Compression
Compression Routines


Compression Routines

The routines that the File Handler uses to compress data are stand-alone modules. This means that you can use them in your own applications, or alternatively make the File Handler use your own data compression routine.

There can be up to 127 Micro Focus compression routines, and up to 127 user-supplied compression routines.

  • Micro Focus Compression Routines
  • Calling a Micro Focus Compression Routine
  • User-supplied Compression Routines
Parent topic: Data and Key Compression
Related information
Data Compression
Key Compression
Example of Using Data and Key Compression


Micro Focus Compression Routines

Micro Focus routines are stored in modules called CBLDCnnn, where nnn is within the range 001 to 127. To use Micro Focus compression routines, set fcd-data-compress in the FCD to a value between 001 and 127.

Routine CBLDC001 and CBLDC101

The compression routine CBLDC001 uses a form of run-length encoding. This is a method of compression that detects strings (runs) of the same character and reduces them to an identifier, a count and one occurrence of the character.

Note: The routine is not effective for use with files that contain significant occurrences of double-byte characters, including double-byte spaces, as these are not compressed.

The routine put special emphasis on runs of spaces, binary zeros and character zeros (that can be reduced to a single character) and printable characters (that are reduced to two characters consisting of a count followed by the repeated character).

The compression routine CBLDC101 behaves in exactly the same way as CBLDC001.

The difference between CBLDC001 and CBLDC101 is that CBLDC101 can handle strings of up to 256 kilobytes (KB) in length, whereas CBLDC001 can only handle strings of up to 65535 bytes.

In the compressed file, bytes have the following meanings (hexadecimal values shown):

20-7F | (most printable characters) normal ASCII meaning.
80-9F | 1-32 spaces respectively.
A0-BF | 1-32 binary zeros respectively.
C0-DF | 1-32 character zeros respectively.
E0-FF | 1-32 occurrences of the character following.
00-1F | 1-32 occurrences of the character following, and that it should be interpreted literally, not as a compression code. This is used when characters in the range 00-1F, 80-9F, A0-BF, C0-DF or E0-FF occur in the original data. (Thus, one such character is expanded to two bytes; otherwise, no penalty is incurred by the compression.)

Routine CBLDC003 and CBLDC103

Like CBLDC001, the CBLDC003 routine uses run-length encoding, but detects strings (runs) of single- or double-byte characters. This routine is therefore suitable for DBCS characters, but can also be used in place of CBLDC001.

The CBLDC103 routine behaves in the same way as routine CBLDC003.

The difference between CBLDC003 and CBLDC103 is that CBLDC103 can handle strings of up to 256 kilobytes (KB) in length, whereas CBLDC003 can only handle strings of up to 65535 bytes.

The format of the compression is two header bytes followed by one or more characters. The bits in the header bytes indicate:

bit 15 | Unset - single character.
bit 14 | Set - compressed sequence. Unset - uncompressed sequence.
bit 0-13 | Compressed character(s) or count of uncompressed characters.

The length of the character string depends on the header bits:

bit 14 and 15 set | Two repeating characters.
Only bit 14 is set | One repeating character.
Otherwise | Between 1 and 63 uncompressed characters.
Parent topic: Compression Routines
Related information
Calling a Micro Focus Compression Routine
User-supplied Compression Routines


Calling a Micro Focus Compression Routine

For data file compression the File Handler calls the compression routine that you specify in the DATACOMPRESS Compiler directive.

To call a Micro Focus data compression routine use the syntax:

COBOL:

call "CBLDCnnn" using input-buffer,
                      input-buffer-size,
                      output-buffer,
                      output-buffer-size,
                      compression-type

C:

cbldcnnn(input_buffer, &input_buffer_size,
         output_buffer, &output_buffer_size,
         &compression-type);

where the parameters for routines CBLDC001 and CBLDC003 are:

nnn | A data compression routine in the range 001 to 127.
input_buffer | A PIC X(size) data item. On entry to the routine it must contain the data to compress or decompress; maximum size is 65535.
input_buffer_size | A two-byte (int in C, PIC XX COMP-5 in COBOL) data item. On entry it must contain the length of data in the input buffer.
output_buffer | A PIC X(size) data item. On exit it contains the resulting data.
output_buffer_size | A two-byte (int in C, PIC XX COMP-5 in COBOL) data item. On entry it must contain the size of the output buffer available; on exit it contains the length of the data in the buffer.
compression-type | A one-byte (char in C, PIC X COMP-X in COBOL) data item. On entry this must specify if the input data is to be compressed or decompressed: 0 - compress 1 - decompress.

and for routines CBLDC101 and CBLDC103 are:

nnn | A data compression routine in the range 001 to 127.
input_buffer | A PIC X(size) data item. On entry to the routine it must contain the data to compress or decompress; maximum size is 256 megabytes.
input_buffer_size | A four-byte (int in C, PIC XXXX COMP-5 in COBOL) data item. On entry it must contain the length of data in the input buffer.
output_buffer | A PIC X(size) data item. On exit it contains the resulting data.
output_buffer_size | A four-byte (int in C, PIC XXXX COMP-5 in COBOL) data item. On entry it must contain the size of the output buffer available; on exit it contains the length of the data in the buffer.
compression-type | A one-byte (char in C, PIC X COMP-X in COBOL) data item. On entry this must specify if the input data is to be compressed or decompressed: 0 - compress 1 - decompress.

The RETURN-CODE special register indicates whether the operation succeeded or not. Compression or decompression fails only if the output buffer is too small to accept the results. 0 indicates success and 1 indicates failure.

Parent topic: Compression Routines
Related information
Micro Focus Compression Routines
User-supplied Compression Routines


User-supplied Compression Routines

User-supplied compression routines must be stored in modules called USRDCnnn, where nnn is within the range 128 to 255.

To call a user-supplied routine, use the same syntax as for calling a Micro Focus routine, but use the filename USRDCnnn instead of CBLDCnnn where nnn must be a value in the range 128 through 255.

To make your compression routine available to your system, you must create a callable shared object that can be called when needed.

You can map calls to data compression routines in programs from previous UNIX COBOL systems to the new calls using the cob option:

-m CBL_DATA_COMPRESS_nnn=CBLDCnnn
Note:
  • Your compression routines must not make any calls to the File Handler, as this would result in a loop. If you need file access, use byte-stream file I/O.
  • Once you have enabled data compression for a file, you must always subsequently specify the same type of compression for that file. If you do not, you receive a run-time system error when you open the file.
  • Data compression has no effect on files other than those in indexed or record sequential format and is ignored at compile time for files that do not support it.
  • If you want to read a fixed-length sequential file that has had its data compressed, you must specify that the file is compressed in your program. You do this by specifying the DATACOMPRESS Compiler directive.
Parent topic: Compression Routines
Related information
Micro Focus Compression Routines
Calling a Micro Focus Compression Routine


Tracing File Operations

  • Introduction
  • Configuring Tracing and Logging
  • Dynamic Tracing
  • Trace Player
Parent topic: File Handling Guide
Related information
Introduction
File Organizations
Filenames
File Status
Sharing Files
File Handler Configuration
File Handler and Sort APIs
MFSORT and MFJSORT Utilities
Btrieve
Data and Key Compression


Introduction

The File Handler includes tracing file operations that enable you to:

  • Set tracing on or off using file handler configuration parameters
  • Set a further level of tracing known as logging, again using file handler configuration parameters
  • Dynamically turn tracing on or off from your COBOL program, using library routines
  • Replay a sequence of file handling operations, using Trace Player
Parent topic: Tracing File Operations
Related information
Configuring Tracing and Logging
Dynamic Tracing
Trace Player


Configuring Tracing and Logging

You use the File Handler configuration parameters TRACE, TRACEFILEEXTEND, TRACEFILENAME, LOG and LOGFILENAME to control tracing and logging activities:

  • Set TRACE=ON to turn tracing on
  • Set TRACEFILEEXTEND=ON to indicate that you want trace information to be written to the end of the current trace file, if the trace file already exists
  • Set TRACEFILENAME=filename if you want the trace file to have a name other than the default, which is xfhtrace.xfh
  • Set LOG=ON to indicate that you want any unusual file-related situations, such as corrupted files, or automatic file recovery, to be recorded in a log file for later examination
  • Set LOGFILENAME=filename if you want the log file to have a name other than the default, which is xfhlog

You can set TRACE and LOG either globally or for individual files, but you can only set TRACEFILEEXTEND, TRACEFILENAME and LOGFILENAME globally.

Here is an example configuration file:

[XFH-DEFAULT]
TRACE=OFF
TRACEFILENAME=c:\trace\mftracefile.xfh
TRACEFILEEXTEND=ON
LOG=ON
LOGFILENAME=c:\temp\mflogfile.log

[datafile1.dat]
TRACE=ON

[datafile2.dat]
LOG=OFF

In this example file tracing is set off globally and set on for the data file named datafile1.dat; new trace records are appended to the trace file, c:\trace\mftracefile.xfh, if it already exists. Logging is set on globally and set off for the data file named datafile2.dat.

Note: If the trace file might exceed a size of 4GB, ensure you specify the configuration options FILEMAXSIZE=8 and IDXFORMAT=8 (these are the default values).
Parent topic: Tracing File Operations
Related information
Introduction
Dynamic Tracing
Trace Player


Dynamic Tracing

You can turn tracing on and off from within a COBOL program either by setting the appropriate flags in the FCD or by using library routines. You might want to do this to focus on file handling problems in a subset of an application's operations. When you set FCD flags you do it for a particular file. When you use the library routines, the trace settings affect all the file operations executed by the program from that point on.

When you do dynamic tracing, you use two flags together. This is because file operations such as READs and WRITEs can be traced only if the OPEN operation was traced. If you execute a program with tracing turned off, open a file, then switch dynamic tracing on, the tracing mechanism won't be able to trace any subsequent operations. The best way to proceed is to switch dynamic tracing on for OPENs and CLOSEs at the beginning of the program, then switch tracing for all operations on and off as required. However, the tracing of OPEN and CLOSE operations on its own can also be useful.

  • Using the FCD to Control Tracing
  • Using Library Routines to Control Tracing
Parent topic: Tracing File Operations
Related information
Introduction
Configuring Tracing and Logging
Trace Player


Using the FCD to Control Tracing

To use the FCD flags you must have access to the FCD; see the topic Accessing the FCD in the section File Handler and Sort APIs.

File tracing is controlled by two flag bit settings within the FCD:

  • Bit 1 of fcd-flags-1 controls whether all file operations are traced.
  • Bit 3 of fcd-fs-flags controls whether OPEN and CLOSE operations only are traced.

Change these bit settings as required to control tracing for individual files.

Parent topic: Dynamic Tracing
Related concepts
Accessing the FCD
Related information
Using Library Routines to Control Tracing


Using Library Routines to Control Tracing

The library routines provide a means of obtaining the same tracing behavior as setting the FCD flags without the need to have the FCD available. All changes to tracing behavior made using the library routines affect all files subsequently accessed.

To control tracing, issue calls to the MFFH_MODIFY_TRACE library routine. You can:

  • Set the main tracing flag on and off
  • Set the OPEN/CLOSE tracing flag on and off
  • Disable a modification that you set earlier

To disable all the modifications that you have set, issue a call to the library routine MFFH_MODIFY_DISABLE.

For further information see the topics MFFH_MODIFY_TRACE and MFFH_MODIFY_DISABLE.

Parent topic: Dynamic Tracing
Related information
Using the FCD to Control Tracing


Trace Player

You can use the Trace Player to read and optionally replay the tracing information created when you have file operation tracing configured on. Tracing information is stored for one or more processes, with each process identified as a separate session. An operation trace consists of the I/O number (a number starting from 1 giving the position of the operation in the sequence of operations), the session ID, the opcode, file status resulting from the call and the name of the file. Additional information can optionally be displayed.

There are various ways to use the Trace Player:

  • View all the operations that were traced.
  • Replay all the operations across all sessions in I/O number order. All the files must be available in their original states.
  • Replay all the operations in one session in I/O number order.
  • Run a script to replay each session in session order. All the files must be available in their original states. The absolute order of operations across sessions might not be the same as when they were originally recorded.
  • Run the Trace Player from the Command Line
  • Examples
Parent topic: Tracing File Operations
Related information
Introduction
Configuring Tracing and Logging
Dynamic Tracing


Run the Trace Player from the Command Line

The format of the command line is:

cobfhrepro2/cobfhrepro3 [options]

Use cobfhrepro2 when you are using the FCD2 data structure and cobfhrepro3 when you are using FCD3.

The options specified on the command line define the operation to be carried out by the Trace Player. The following options are available:

num | Replays all the operations in one session, where num is the session ID. If num = 0, all the operations in all the sessions are replayed.
/a | Displays arguments; use in conjunction with /d
/d | Displays the trace information for each operation in I/O number order
/eop-num | Ends the replay at the I/O number op-num
/f | Displays the files needed for a replay
/nfilename | Trace a specific file
/pop-num | Pauses the replay at the I/O number op-num; press Enter to continue
/t | Displays only operations that fail and final status

If you run the Trace Player with no options, it creates the script that plays back each session in session order and informs you of the script's name. You must do this before every invocation of the script.

Parent topic: Trace Player
Related information
Examples


Examples

Here are some examples of typical output.

Example /d output

 I/O     Sess  Op  Opcode   Act   Exp   Filename                       O
Number    Id  Code Desc     Stat  Stat                                 K
-------- ---- ---- -------- ----- ----- ------------------------------ -
00000001 0001 FA02 Open      \    0\0   .\CATALOG.DAT
00000002 0001 FAF6 Read Ran  \    0\0   .\CATALOG.DAT
00000003 0001 FA02 Open      \    0\0   .\CATALOG.DAT

Example /d /a output

 I/O     Sess  Op  Opcode   Act   Exp   Filename                       O
Number    Id  Code Desc     Stat  Stat                                 K
-------- ---- ---- -------- ----- ----- ------------------------------ -
00000001 0001 FA02 Open      \    0\0   .\CATALOG.DAT
  fcd-version. 00   organisation 02   access-mode. 88   open.mode... 80
  opt2........ 20   shr2........ 08   shr......... 84   opt......... 20
  osp......... 80   file-format. 08   flags1...... 03   misc........ 10

RBA =000000000000  Rec Len = 010476
Session-id = 000000000000  FS-file-id =  000000000000

00000002 0001 FAF6 Read Ran  \    0\0   .\CATALOG.DAT
  fcd-version. 00   organisation 02   access-mode. 88   open.mode... 02
  opt2........ 20   shr2........ 08   shr......... 84   opt......... 20
  osp......... 80   file-format. 08   flags1...... 03   misc........ 10

RBA =000000000000  Rec Len = 010476
Session-id = 000000000000  FS-file-id =  000000000000

00000003 0001 FA02 Open      \    0\0   D:\Catalogs\TempOLFiles\Catalo
  fcd-version. 00   organisation 02   access-mode. 88   open.mode... 80
  opt2........ 20   shr2........ 08   shr......... 84   opt......... 20
  osp......... 80   file-format. 08   flags1...... 03   misc........ 10

RBA =000000000000  Rec Len = 010476
Session-id = 000000000000  FS-file-id =  000000000000

Example replay output

 I/O     Sess  Op  Opcode   Act   Exp   Filename                       O
Number    Id  Code Desc     Stat  Stat                                 K
-------- ---- ---- -------- ----- ----- ------------------------------ -
00000001 0001 FA02 Open     0\0   0\0   .\CATALOG.DAT -
00000002 0001 FAF6 Read Ran 0\0   0\0   .\CATALOG.DAT -
00000003 0001 FA02 Open     0\0   0\0   .\CATALOG.DAT -

Act Stat is the actual status returned when the Trace Player is run. Exp Stat is the status returned when the trace was recorded. In theory these two should be the same but in practice, they can be different. Act Stat is blank when you do a display because there is no actual status.

Parent topic: Trace Player
Related information
Run the Trace Player from the Command Line


Working with Data Files

  • Rebuild
    Rebuild is a file management utility invoked from the command line. It enables you to perform a number of actions on indexed data files, such as repairing or reorganizing them.
  • File Conversion Utilities
    This chapter describes utilities provided to help you move files between the mainframe and the PC.
  • Configurable Codesets
    Use the Codecomp utility to create your own customized mapping tables for EBCDIC/ANSI character set translation.
Parent topic: File Handling
Related information
File Handling Examples
File Handling Guide
File Systems
Fileshare Guide


Rebuild

  • Overview
  • Command Line
  • Rebuild Options
  • Reorganizing Indexed Files
  • Rebuilding a Corrupt Indexed File
  • Converting a File
  • Validating an Indexed File
  • Rebuild through Fileshare
  • Callable Rebuild
  • Rebuild Examples
Parent topic: Working with Data Files
Related information
File Conversion Utilities
Configurable Codesets


Overview

Rebuild is a file management utility invoked from the command prompt which enables you to:

  • Reorganize an indexed file
  • Rebuild a corrupt indexed file
  • Convert files from one organization to another
  • Validate an indexed file

The operation performed on a file by Rebuild depends on the options specified on the Rebuild command line.

Note:
  • If you are using Fileshare to access files, you should use only the Rebuild options that are supported for use through Fileshare. Otherwise, you will obtain undefined results.
  • When working with striped IDXFORMAT "8" files, you should ensure that:
    • All stripes are present
    • Rebuild picks up the File Handler configuration file extfh.cfg file.
    Failure to do this can lead to unpredictable results.
  • You should always take a backup copy of a file before you reorganize, rebuild or convert it. This is simply as a precaution against an incorrectly specified command line which could lead to file corruption. For indexed files, you should save both the index and data parts of the file.
  • Key offsets start at 1.
  • All temporary files are created in the system temporary file directory, unless you set TMP or TEMP to point to the directory where you would like to keep temporary files.
Parent topic: Rebuild
Related information
Command Line
Rebuild Options
Reorganizing Indexed Files
Rebuilding a Corrupt Indexed File
Converting a File
Validating an Indexed File
Rebuild through Fileshare
Callable Rebuild
Rebuild Examples


Command Line

The format of the Rebuild command line is:

rebuild in-file [,out-file] [options]

Both in-file and out-file must include the filename extension. The filename of out-file must not be the same as in-file. You can use environment variables in place of in-file or out-file to implement filename mapping.

The options specified on the command line define the operation to be carried out by Rebuild.

  • Option Files
  • Redirection of Information
Parent topic: Rebuild
Related information
Overview
Rebuild Options
Reorganizing Indexed Files
Rebuilding a Corrupt Indexed File
Converting a File
Validating an Indexed File
Rebuild through Fileshare
Callable Rebuild
Rebuild Examples


Option Files

On the Rebuild command line, an at character (@) followed by a filename indicates that the named file contains Rebuild command line options.

If you use a file to supply Rebuild command line options, the file must be an ASCII text file.

Within the Rebuild options file:

  • Options should be separated by spaces.
  • Line ends are treated as spaces.
  • Any text between an asterisk (*) and the line end is treated as a comment.

In the following example:

rebuild infile.dat, outfile.dat @conv.par

conv.par is an ASCII text file containing Rebuild options.

Parent topic: Command Line
Related information
Redirection of Information


Redirection of Information

All information displayed by the Rebuild utility can be redirected to a text file using standard operating system redirection:

> | Creates a new file.
>> | Extends an existing file

For example:

rebuild oldms001.dat,ms001.dat -k:1+20<N> -i >> rebuild.prt

redirects the output from Rebuild to the existing file rebuild.prt.

Note: When you are redirecting output, do not use the -v option.
Parent topic: Command Line
Related information
Option Files


Rebuild Options

The processing performed by Rebuild is defined by the option(s) specified on the command line.

On UNIX systems, Rebuild options must be preceded by a hyphen (-) character rather than a slash (/) character.

The following options are available:

-c | Specifies file compression
-d | Reconstructs an index from the data area of an indexed file
-e | Reports illegal duplicate keys and continues processing
-f | Validates indexed files
-i | Displays information about the files being processed
-k | Defines the key structure for an indexed file
-m | Reserved for future use
-n | Displays information about a file (no other processing is performed)
-o | Specifies the organization of the input and output files
-p | Rebuilds IDXFORMAT "8" file in place
-q | Reserved for future use
-r | Defines the record structure of the input and output files
-s | Specifies the format of the input file
-t | Specifies the format of the output file
-u | Attempts to recover a file for which the last update operation was not completed
-v | Displays a record count which is incremented as the file is processed
-y | Forces Rebuild to ignore file size discrepancies
-x | Specifies the order in which data is written when reorganizing an indexed file
-z | Instructs Rebuild to use a Fileshare server for file access
--q | Suppresses display of the Rebuild banner
--v | Displays the version number of Rebuild

Options can be placed in any order on the command line, except that options beginning with a double hyphen (--) must be placed before options beginning with a single hyphen (-). Options are free-format; spaces are required between options.

A colon (:) is required before parameters of the -f or -v options. For other options, a colon before parameters is optional. Do not insert spaces between the parameters of options.

Parent topic: Rebuild
Related information
Overview
Command Line
Reorganizing Indexed Files
Rebuilding a Corrupt Indexed File
Converting a File
Validating an Indexed File
Rebuild through Fileshare
Callable Rebuild
Rebuild Examples


Reorganizing Indexed Files

The format of the command line for reorganizing a file is:

rebuild in-file,out-file
[-c] [-d] [-i] [-k] [-n] [-p] [-s] [-v] [-x]

As indexed files are updated by adding, deleting and altering records, the index and data structures become disjointed, making processing less efficient. In addition, space left by deleted records is not always reused, making the file bigger than it needs to be.

After a large number of changes have been made, it is worth reorganizing an indexed file to rebuild the data and indices in an ordered sequential fashion and to reclaim any free space. This will ensure optimum performance and data integrity.

There are other reasons why you may want to reorganize a file. For example, if a file is processed sequentially, the access time to process the file increases over time, as the records start to become out of sequence due to updates. In this situation, you can reduce access time by reorganizing the file.

A third reason is to rebuild a duplicate key chain. A duplicate key has a duplicate occurrence value appended to it to make it unique. When a new duplicate key is added, the occurrence value of the last added key is incremented by one and used for the newly added key. If keys are deleted, no change is made to the occurrence values of the remaining keys. Therefore, you can reach the maximum number of duplicate values, even if some of those keys have already been deleted. In these circumstances it is a good idea to reorganize the file. For more information on duplicate keys, see the topic Duplicate Keysin the section File Organizations.

For example:

rebuild infile.dat,outfile.dat

causes Rebuild to read the data file (infile.dat) using the index file (infile.idx) and then create the output file (outfile.dat). The deleted records in infile.dat are not written to the output file.

Note: You cannot use the same filename for the input file and the output file.
Parent topic: Rebuild
Related information
Overview
Command Line
Rebuild Options
Rebuilding a Corrupt Indexed File
Converting a File
Validating an Indexed File
Rebuild through Fileshare
Callable Rebuild
Rebuild Examples


Rebuilding a Corrupt Indexed File

The format of the command line for rebuilding an index is:

rebuild in-file[,out-file]
[-c] [-d] [-e] [-i] [-k] [-n] [-p] [-s] [-v]

The out-file parameter is optional, but recommended, because if you do not specify it, and the Rebuild operation fails, you will lose your original file.

There are a number of reasons why an indexed file becomes corrupt, for example:

  • A close operation on an indexed file fails.
  • A power surge occurs while the indexed file is open.
  • The machine is rebooted or powered off while an indexed file is open.

When a COBOL program attempts to open a corrupt indexed file, the run-time system detects that the file is corrupt and returns an extended file status code.

Rebuild can recover corrupt indexed files for you:

  • If the data portion of the file is intact and only the index portion is corrupt, then Rebuild can generate a new index (.idx) file from the data file with no loss of data.
  • If the data portion of the file is corrupt then Rebuild can rebuild a complete new indexed file, both data and index portions, but there will be loss of data as Rebuild discards any corrupt data records that it encounters.
Note: When you use Rebuild to generate a new index file from an existing data file, the file can grow in size. One reason is that information held in the original index about free space in the data file is lost, which means that the free space cannot be reused. Another reason is that if you specify the -d option, index records are created individually as with normal I/O operations, leading to index nodes that are only partially filled. To overcome this problem, you should reorganize the file after you have rebuilt the index.

In the following example Rebuild reads the .idx file to get the key information, and creates a new index file, by reading the data file, infile.dat:

rebuild infile.dat

In the following example Rebuild reads the input file to get the key information, and creates a new indexed file, by working through the data in physical order, skipping over duplicate records:

rebuild infile.dat, outfile.dat -d -e

If the index file is not present, you must supply information about the key structure using the -k option.

Parent topic: Rebuild
Related information
Overview
Command Line
Rebuild Options
Reorganizing Indexed Files
Converting a File
Validating an Indexed File
Rebuild through Fileshare
Callable Rebuild
Rebuild Examples


Converting a File

The format of the command line for converting a file is:

rebuild in-file,out-file [-c] [-i]
    [-k] [-o] [-r] [-s] [-t] [-v]

Rebuild enables you to convert files from one file organization and format to another.

In the following example Rebuild converts a C-ISAM file into the format used by this system and compresses the data part of the file:

rebuild infile.dat,outfile.dat -s:c-isam -c:d1 -t:mf
Parent topic: Rebuild
Related information
Overview
Command Line
Rebuild Options
Reorganizing Indexed Files
Rebuilding a Corrupt Indexed File
Validating an Indexed File
Rebuild through Fileshare
Callable Rebuild
Rebuild Examples


Validating an Indexed File

The format of the command line for validating an indexed file is:

rebuild in-file -f

Rebuild can perform a number of validation checks and you can request all of them, or just a subset of them. Of course, the more checks you request, the longer the validation process takes.

In the following example Rebuild performs a full integrity check on the file:

rebuild test.dat -f
Parent topic: Rebuild
Related information
Overview
Command Line
Rebuild Options
Reorganizing Indexed Files
Rebuilding a Corrupt Indexed File
Converting a File
Rebuild through Fileshare
Callable Rebuild
Rebuild Examples


Rebuild through Fileshare

You can use Rebuild on files that reside on Fileshare servers, but only with a limited range of Rebuild options. The format of the command line for using Rebuild through Fileshare is:

rebuild in-file[,out-file] -z:server-name {/l|/n}

where:

server-name The name of a Fileshare server. All occurrences of server-name must refer to the same Fileshare server.

You can also specify a Fileshare server without using the -z Rebuild option. The format of the command line for this is:

rebuild $$server-name\in-file [$$server-name\out-file] {/l|/n}

On UNIX systems, replace the server-name prefix $$ with \$\$.

Parent topic: Rebuild
Related information
Overview
Command Line
Rebuild Options
Reorganizing Indexed Files
Rebuilding a Corrupt Indexed File
Converting a File
Validating an Indexed File
Callable Rebuild
Rebuild Examples


Callable Rebuild

You can call Rebuild from your COBOL program as follows:

call "callrb" using commands status

where the parameters are:

commands | A PIC X(600) item containing the Rebuild command line. This item must be 600 bytes in length because Rebuild scans the command line backwards from offset 599.
status | A PIC XX COMP X item containing the returned file status. This item shows the result of the call to Rebuild.

When called from within a program, Rebuild does not display any of its usual messages.

If an error occurs or the rebuild is unsuccessful, RETURN-CODE contains a non-zero value and status contains the returned file status. You should always check RETURN-CODE and status after a call to Rebuild.

The possible values of RETURN-CODE are shown below.

Value | Description
0 | Rebuild executed successfully
1 | An error occurred on the input file such as file not found or invalid file format - check status parameter
2 | An error occurred on the output file - check status parameter
3 | Error in sort
4 | File is corrupt
5 | Attempt to do a /k:a:exists
6 | Attempt to do a /k:r:onprime
7 | Attempt to do a /k:r:dontexist
8 | Too many duplicates on out
9 | The parameter list contained an error such as an invalid option or an invalid combination of options

If an error occurs, execute Rebuild from the command line on the same file with a set of identical options. The screen output should give a more precise indication as to the cause of the error.

Note: If you are using the -f option (validate an indexed file), then any non-zero RETURN-CODE indicates that the file is corrupt. Again, execute Rebuild from the command line on the same file with a set of identical options to obtain more precise information.

The following example shows Rebuild being called from within a COBOL program.

 01 parameters   pic x(600).
 01 status       pic xx comp-x.
   ...
     move "infile.dat,outfile.dat -s:lii -c:d1" to parameters
     call "callrb" using parameters,status
     end-call
Parent topic: Rebuild
Related information
Overview
Command Line
Rebuild Options
Reorganizing Indexed Files
Rebuilding a Corrupt Indexed File
Converting a File
Validating an Indexed File
Rebuild through Fileshare
Rebuild Examples


Rebuild Examples

The section provides examples of using Rebuild.

rebuild infile.dat,outfile.dat -i

Reorganizes the file. The data is written in the order of the prime record key, and processing information displayed when the reorganization is complete.

rebuild infile.dat,outfile.dat -x:3

Reorganizes the file. The data is written in the order of the third alternate key.

rebuild infile.dat

Rebuilds the indexed file (assuming that the index (.idx) file is still present, and the key information held therein is not corrupt).

rebuild infile.dat -k:1+20 -i

Rebuilds the indexed file. The index (.idx) file does not need to exist, and is ignored if it does. It will be completely recreated using the key definition specified (which need not correspond to the key definition used when the file was created). Processing information will be displayed when the rebuild is complete.

With C-ISAM and Level 2 files that do not have index files, use the -r and -s options to specify the record information and file format.

rebuild infile.dat,outfile.dat -s:c-isam -c:d1 -t:mf

Converts a C-ISAM format index file into the format used by this system and compresses the data part of the file.

rebuild infile.dat,outfile.dat --o:rel,ind -k:1+2:3+10d
-c:i7 -r:f10

Generates an index, with key compression, for a fixed-length relative file.

rebuild infile.dat,outfile.dat -s:lii -t:lii

Reorganizes a LEVEL II V2.5 COBOL format file and retains the LII structure on the output file. It is possible to combine -s and -t with other formats in a similar manner.

set data=/tmp.dat rebuild data -i

Reorganizes and displays information about the file /tmp.dat.

Parent topic: Rebuild
Related information
Overview
Command Line
Rebuild Options
Reorganizing Indexed Files
Rebuilding a Corrupt Indexed File
Converting a File
Validating an Indexed File
Rebuild through Fileshare
Callable Rebuild


File Conversion Utilities

File Conversion Utility | Use to...
DFCONV | Convert downloaded data files to the required format on the PC
VRECGEN | Modify mainframe files into the format required for download from the mainframe to the PC
VRECGEN2 | Modify files uploaded from the PC into the format required on the mainframe
  • DFCONV Batch File Conversion
  • VRECGEN
  • VRECGEN2
Parent topic: Working with Data Files
Related information
Rebuild
Configurable Codesets


DFCONV Batch File Conversion

The DFCONV utility, also known as the Data File Converter, converts data files. The utility provides a batch and called program interface to enable conversion of file formats, organizations and data formats and reorganization of indexed files using data file conversion profiles.

Use the Data File Converter to:

  • Convert data files downloaded to a PC from a mainframe
  • Convert PC data files to VRECGEN2 format files for sending to the mainframe
  • Convert report files from mainframe to PC formats and vice versa
  • Convert files between EBCDIC and ANSI or ASCII data formats
  • Convert floating-point formats
  • Reorganize file structures
  • Convert multiple record types
  • Convert Micro Focus format files to Btrieve format files and vice versa
  • Act as a batch interface
  • Act as a called program interface
Note:
  • To convert between character sets on records with non-text data items; that is, COMPUTATIONAL data and numeric data, you must have previously created a record layout file. For more information on how to create a record layout file, see the topic To create a record layout file.
  • A GUI version of the Data File Converter is also available as part of the Micro Focus Data Tools. To access these, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> Data Tools > Data File Tools .
  • Operation
  • Using the Data File Converter
  • Data File Converter Error Messages
Parent topic: File Conversion Utilities
Related information
VRECGEN
VRECGEN2


Operation

The following sections describe the two Data File Converter operations:

  • The command line batch interface
  • The call batch interface
  • Command Line Batch Interface
  • The DFCONV call batch interface
Parent topic: DFCONV Batch File Conversion


Command Line Batch Interface

The command line is:

run dfconv profile-fname [input-fname] [output-fname] [-d]
where the parameters are:
profile-fname
The name of the profile file that contains the details of the task you need to perform.
input-fname
The name of the input file (optional).
output-fname
The name of the output file (optional).
-d
Stops the display of the data file convert console messages (optional).

The input and output file-names are optional as they can be extracted from the profile file. If you specify file-names on the command line as well as in the profile file, those on the command line take precedence.

After conversion, the operating system error level (ERRORLEVEL) is set to non-zero if an error occurred during conversion. If you are running the conversion from a batch file, you can interrogate this to determine what action to take after the conversion.

Parent topic: Operation
Related information
The DFCONV call batch interface
Defining File Conversion with a Profile File


The DFCONV call batch interface

Calling the Data File Converter from a COBOL program

If a profile for a conversion exists, you can invoke the Data File Converter to do the conversion using the following interface:

call dfconv using dfconv-params

where:

 01 dfconv-params   PIC X(195).
dfconv-params contains the following parameters. These must be separated by spaces in the call, and file names that include spaces should be put in straight quotation marks.
profile-filename
The name of the profile file containing the details of the data file conversion.
-d
Optional. Stops information about the call being displayed in the console.
input-filename
The name of the input file. Optional, but must have a value if you want to specify output-filename.
output-filename
Optional. The name of the output file. You must also specify a value for input-filename.

If you specify file names in the parameter fields as well as in the profile file, those in the parameter fields take precedence.

On return from the Data File Converter, RETURN-CODE is set to non-zero if an error occurred, and the error number is returned in the first two characters of dfconv-params.

Calling the Data File Converter from a non-COBOL program

The Data File Converter can be called from a non-COBOL program using an entry point DFCONVC, provided within the Data File Converter .dll. The dfconv-params parameters are space terminated as for the COBOL call but the parameter list is NULL terminated.

Parent topic: Operation
Related information
Command Line Batch Interface


Using the Data File Converter

The following sections describe how to use the Data File Converter to convert data files and rebuild file indexes.

  • File Format and Data Conversion
  • EBCDIC to ANSI Conversion
  • Mainframe to PC Print Conversion
  • Indexed File Reorganization
  • Defining File Conversion with a Profile File
  • File Rebuild
Parent topic: DFCONV Batch File Conversion


File Format and Data Conversion

Converting files from one format to another enables data to be restructured from one format to another. For example, you can convert from sequential organization to indexed organization. You can also add extra secondary indices as the needs of an application change. When using the Data File Converter, you do not need to recreate data already produced or write special conversion programs.

Although many file transfer packages convert files from one format to another, they are restricted to converting the whole file to the other data format. Typical COBOL data files and database records have complex record structures with a mix of text and binary data that must be translated accordingly. The GUI version of the Data File Converter provides an easy method for data conversion using record layout descriptions. For more information on how to create a record layout file, For more information on how to create a record layout file, see the topic To create a record layout file.

The Data File Converter can also convert internal floating-point formats between IEEE format and S/370 format.

Parent topic: Using the Data File Converter
Related information
EBCDIC to ANSI Conversion
Mainframe to PC Print Conversion
Indexed File Reorganization
Defining File Conversion with a Profile File
File Rebuild


EBCDIC to ANSI Conversion

A mainframe file should be transferred to the PC in binary format. If, initially, this file is a variable-length indexed file, use the mainframe program VRECGEN to perform an initial reformat of the file on the mainframe. The Data File Converter can then process the downloaded file.

Parent topic: Using the Data File Converter
Related information
File Format and Data Conversion
Mainframe to PC Print Conversion
Indexed File Reorganization
Defining File Conversion with a Profile File
File Rebuild


Mainframe to PC Print Conversion

A mainframe report format file is either a file downloaded to the PC from the mainframe or a file created by an application, downloaded to the PC and run on the PC.

A mainframe report format contains carriage-control characters which are converted by the Data File Converter to PC printable formats. When defining the mainframe report files, the record length includes the carriage-control character and the records must be fixed length. In PC Print files, the record length is solely the data length.

You can print the PC print format files on any standard ANSI printer capable of printing 132 characters per line. As some ANSI printers print only 80 characters per line, you might have to print your files in compressed mode to achieve this.

If you specify the input file as a mainframe report format file, but it was created on the PC using a downloaded mainframe application, you may receive error message 139 ("Input file not "real" mainframe report format"). This can occur if the printer output has been created in PC format rather than the mainframe report format. Check directives used to control the compilation and execution of the program.

The Data File Converter provides specific support for conversion between Mainframe Report files and PC Print files. Conversion to or from these formats to other formats is not supported.

Parent topic: Using the Data File Converter
Related information
File Format and Data Conversion
EBCDIC to ANSI Conversion
Indexed File Reorganization
Defining File Conversion with a Profile File
File Rebuild


Indexed File Reorganization

As indexed files are updated by adding, deleting and altering records, the index and data structures become disjointed, making processing less efficient. In addition, space left by deleted records is not always reused, making the file bigger than it needs to be. After a large number of changes have been made, it is worth reorganizing an indexed file. By ensuring that the input and output file settings are identical, the data and indices can be rebuilt in an ordered sequential manner, reclaiming any free space, and so providing optimum file performance and integrity.

Parent topic: Using the Data File Converter
Related information
File Format and Data Conversion
EBCDIC to ANSI Conversion
Mainframe to PC Print Conversion
Defining File Conversion with a Profile File
File Rebuild


Defining File Conversion with a Profile File

This section describes the entries required in the profile file to convert a file, or to restructure a file from one organization to another. For example, you might need to do one of the following:

  • Add extra secondary indices to an indexed file
  • Convert a sequential or relative file to an indexed file
  • Convert an indexed file to a relative file
  • Convert a blocked variable length file to a sequential file

Example profile files

The first record in the file identifies the format of the profile file. The profiles used by DFCONV are the same format as used with earlier Workbench.

Example 1:
DFS Profile File Version  V09.B01.07

Batch-Process: Convert-file
                   ***************************************************
                   *           (Twin)                  (Single)      *
                   * Options:  Convert-File            Rebuild-index *
                   *           Rebuild-index-and-data  None          *
                   ***************************************************
Strt-file:              drive:\path\filename.STR
Edit-Mode:     Quick
                   * Options:  Quick/Full                            *
--------------------------------------------------------------------------------
Input-File     drive:\path\inputfile.dat
   Format:         Micro-Focus
                       * Options:  Micro-Focus         IDXFORMAT(4)  *
                       *           Btrieve             C-ISAM        *
                       *           LEVEL-II            ESDS          *
   Organization:   VRECGEN
                       * Options:  Sequential  Line-Sequential       *
                       *           Indexed     Mainframe-Report-ANSI *
                       *           Relative    Mainframe-Report-mach *
                       *           VRECGEN     PC-Print              *
   Record-Format:  Variable
                       * Options:  Fixed/Variable                    *
   Character-Set:  EBCDIC
                       * Options:  ASCII/EBCDIC                      *
   Floating-Point: 370
                       * Options:  IEEE/370                          *
   Compression:    Off
                       * Options:  On/Off                            *
   Min-Rec-Length: 352
   Max-Rec-Length: 633
--------------------------------------------------------------------------------

Output-File    drive:\path\outputfile.dat
   Format:         Micro-Focus
   Organization:   Indexed
                       * Options:  Sequential  Line-Sequential       *
                       *           Indexed     Mainframe-Report-ANSI *
                       *           Relative    PC-Print              *
                       *           VRECGEN2                          *
   Record-Format:  Variable
   Character-Set:  EBCDIC
   Floating-Point: 370
   Compression:    Off
   Min-Rec-Length: 352
   Max-Rec-Length: 633
                       * Key to settings                             *
                       *       d=      allow duplicates              *
                       *       s=      sparse character set          *
                       *       Compression                           *
                       *           cd= on duplicates                 *
                       *           cl= on leading spaces             *
                       *           ct= on trailing spaces            *
   Prime-key :   1:1, 2:6

   Alt-Key  1:   8:1
                 d,cl
   Alt-Key  2:   9:1
                 d,cd,ct
   Alt-Key  3:   10:5
Example 2:
DataTools Profile Version  V09.B02.05

Batch-Process: Convert-file
                   ***************************************************
                   *           <Twin>                  <Single>      *
                   * Options:  Convert-File            Rebuild-index *
                   *           Rebuild-index-and-data  None          *
                   ***************************************************
Strt-file:     No-structure
Edit-Mode:     Full
                   * Options:  Quick/Full                            *
--------------------------------------------------------------------------------
Input-File     LP2293.QA.DAT
   Format:         Micro-Focus
                       * Options:  Micro-Focus         IDXFORMAT(4)  *
                       *           Btrieve             C-ISAM        *
                       *           LEVEL-II            ESDS          *
   Organization:   Blocked-VRec
                       * Options:  Sequential  Line-Sequential       *
                       *           Indexed     Mainframe-Report-ANSI *
                       *           Relative    Mainframe-Report-mach *
                       *           VRECGEN     PC-Print              *
                       *           Blocked-VRec                      *
   Record-Format:  Variable
                       * Options:  Fixed/Variable                    *
   Character-Set:  EBCDIC
                       * Options:  ASCII/EBCDIC                      *
   Floating-Point: IEEE
                       * Options:  IEEE/370                          *
   Compression:    Off
                       * Options:  On/Off                            *
   Min-Rec-Length: 500
   Max-Rec-Length: 500
--------------------------------------------------------------------------------

Output-File    LP2293-seq.dat
   Format:         Micro-Focus
   Organization:   Sequential
   Record-Format:  Variable
   Character-Set:  EBCDIC
   Floating-Point: IEEE
   Compression:    Off
   Min-Rec-Length: 500
   Max-Rec-Length: 500
  • Specifying the Conversion Operation
  • Specifying the Input File Parameters
  • Specifying the Output File
  • General Conversion Information
Parent topic: Using the Data File Converter
Related information
File Format and Data Conversion
EBCDIC to ANSI Conversion
Mainframe to PC Print Conversion
Indexed File Reorganization
File Rebuild
Command Line Batch Interface


Specifying the Conversion Operation

The operation to be performed is chosen as a parameter to the Batch-Process option.

Batch-Process
The operation to be performed on the defined files. Value must be Convert-file, Rebuild-index, or Rebuild-index-and-data.
An Input-File is defined for all operations and an Output-File is defined for Convert-file and Rebuild-index-and-data. The Rebuild-index operation recreates the file index for the input data file so an Output-File description is not required.
Strt-file location\filename.str
The file containing the Record Layout descriptions for the input file.

If the data file is being converted between EBCDIC and ANSI and the records contain non-text data items, a record layout description is required to define the data items requiring conversion and those to be left unconverted (for example, binary values). The record layouts are created with the Record Layout Editor and stored in files with an .str file extension. For more information on how to create a record layout file, see the topic To create a record layout file.

Edit-Mode
The edit mode if this profile is read by the Data File Editor. Value must be either Quick or Full.

This parameter is not used by DFCONV.

Parent topic: Defining File Conversion with a Profile File
Related information
Specifying the Input File Parameters
Specifying the Output File
General Conversion Information


Specifying the Input File Parameters

First of all, choose an input file:
Input-File
The input file name for the defined operation.
Then, use parameters to describe the input file:
Format
The file format for the input file. Valid values are:
  • Micro Focus
  • ESDS
  • Btrieve
  • IDXFORMAT(4)
  • C-ISAM
  • LEVEL-II
  • IDXFORMAT(8)

The default format is Micro Focus and this would normally be used for files downloaded from the host and recreated on the PC. If the chosen file is an emulation of the mainframe VSAM entry-sequenced data set, choose ESDS to provide the emulation of VSAM ESDS on the PC.

Organization
The file organization for the input file. Valid values are:
  • Line sequential
  • Sequential
  • Indexed sequential
  • Relative
  • VRECGEN
  • ANSI Mainframe Report (The mainframe report with ANSI carriage control characters)
  • Machine Mainframe Report (The mainframe report with machine code carriage control characters)
  • PC Print.
  • Blocked-VRec
Record-Format
The record format for the input file. Valid values are:
  • Fixed
  • Variable

Variable length Mainframe Report files are not supported.

Character-Set
The character encoding used in the input file. Valid values are:
  • ASCII
  • EBCDIC
Note: The Windows environment uses the EBCIDIC and ANSI character encodings, and the UNIX/LINUX environments use the EBCIDIC and ASCII character encodings. The character encodings used in the ANSI and ASCII code pages are different.
Floating-Point
The type of floating-point format that is used in the input file.
  • IEEE
  • 370
Compression
An indication that data compression is used for the input file. Valid values are:
  • On
  • Off

This should only be set to On if the file was created with data compression.

Min-Rec-Length
The minimum record length for the input file.

If the file is fixed length this should be set to the same value as the maximum record length.

Max-Rec-Length
The maximum record length for the input file.
If the file being created is indexed, the keys are defined using the following records.
Prime-key
The start position of the key is either the column number or offset depending on the version of the profile being used. A colon is used to separate the position and length fields.
  • DFS Profile Files use a start position (column) starting at 1 with the prime key being in the format position:length (for example, 1:12).
  • DataTools Profiles use an offset starting at 0 with the prime key being in the format offset:length (for example, 1:12).
A second record in the profile file sets the key flags required for the indexed file being created. The flags are separated by a comma (for example: d,cd).
Flag | Description
d | allow duplicate record keys
s | sparse character - not supported
cd | compress duplicate record keys
cl | compress leading spaces on record keys
ct | compress trailing spaces on record keys
Parent topic: Defining File Conversion with a Profile File
Related information
Specifying the Conversion Operation
Specifying the Output File
General Conversion Information


Specifying the Output File

You need to specify the output file's name. If the Data File Converter does pick up a default organization and record format for the output file, you can change these values. Otherwise, if the Data File Converter does not offer any output file details, you need to supply this information.

You can select one of the following file formats:

File Format | Purpose
C-ISAM | Emulates files from old systems
ESDS | Emulates VSAM ES files
IDXFORMAT(4) | When converting an input file that has many duplicate keys
IDXFORMAT(8) | For very large files
Level-II | Emulates files from old systems
Micro Focus | In all other cases

Available file organizations from which you can select are:

  • Indexed sequential
  • Line sequential
  • Relative
  • Sequential
  • VRECGEN2
Note: If you request a conversion of a sequential file to an indexed file with unique keys and some of the records contain duplicate key values, Data File Converter ignores these records and does not convert them. At the end of the conversion, Data File Converter informs you of the number of records rejected.
Parent topic: Defining File Conversion with a Profile File
Related information
Specifying the Conversion Operation
Specifying the Input File Parameters
General Conversion Information


General Conversion Information

You should be aware of the following points when defining the input and output files:

  • If the chosen file type is indexed, variable-length sequential or variable-length relative:

    The record length information is extracted from the file header and replaces the record length information defined for the input file in the profile file

  • If the file type is Mainframe Report format:

    You should set the input record lengths and the output record lengths so that the record length of the mainframe Print Format file is one character longer to hold the carriage control characters

  • If a program calling DFCONV is compiled with CHARSET"EBCDIC":

    The Data File Converter cannot interpret the profiles sent to it; the File Converter applies only to DOS and ANSI based programs. To ensure correct processing, use an ANSI-based program to call the Data File Converter.

  • If the output file contains non-text data:

    The output file type you specify should not be line sequential. Extra bytes (X'00') are inserted into the ANSI line sequential record whenever a byte contains a value of X'1B' or less, this may result in unnecessarily large files. The extra bytes are include to provide NULL protection to data held in the line sequential file, these bytes would otherwise be interpreted as control characters used in this type of file.

Parent topic: Defining File Conversion with a Profile File
Related information
Specifying the Conversion Operation
Specifying the Input File Parameters
Specifying the Output File


File Rebuild

The interface to Rebuild from the Data File Converter supports the rebuilding of corrupt indices.

DFS Profile File Version  V08.U04.01

Batch-Process: Rebuild-index
                   ***************************************************
                   *           (Twin)                  (Single)      *
                   * Options:  Convert-File            Rebuild-index *
                   *           Rebuild-index-and-data  None          *
                   ***************************************************
Strt-file:     No-structure
Edit-Mode:     Quick
                   * Options:  Quick/Full                            *
--------------------------------------------------------------------------------
Input-File     e:\test\testidx.dat
   Format:         Micro-Focus
                       * Options:  Micro-Focus         IDXFORMAT(4)  *
                       *           Btrieve             C-ISAM        *
                       *           LEVEL-II            ESDS          *
   Organization:   Indexed
                       * Options:  Sequential  Line-Sequential       *
                       *           Indexed     Mainframe-Report-ANSI *
                       *           Relative    Mainframe-Report-mach *
                       *           VRECGEN     PC-Print              *
   Record-Format:  Variable
                       * Options:  Fixed/Variable                    *
   Character-Set:  ASCII
                       * Options:  ASCII/EBCDIC                      *
   Floating-Point: IEEE
                       * Options:  IEEE/370                          *
   Compression:    Off
                       * Options:  On/Off                            *
   Min-Rec-Length: 352
   Max-Rec-Length: 633
                       * Key to settings                             *
                       *       d=      allow duplicates              *
                       *       s=      sparse character set          *
                       *       Compression                           *
                       *           cd= on duplicates                 *
                       *           cl= on leading spaces             *
                       *           ct= on trailing spaces            *
   Prime-key :   1:1, 2:6

   Alt-Key  1:   8:1
                 d
   Alt-Key  2:   9:1
                 d

The Rebuild function can be used for rebuilding index sequential files only. To rebuild other file formats, use the file conversion function with identical settings for the input and output files.

Note: If you are using a profile file, as described above, any offsets you define in the Prime-key field start at 1. However, if you use the GUI version of the Data File Converter, key offsets start at zero from the Key Information dialog box. To find out more about the Data File Converter, see the chapter Converting Data Files.
  • Recovery of Corrupt Indexed Files
  • General Rebuild Information
Parent topic: Using the Data File Converter
Related information
File Format and Data Conversion
EBCDIC to ANSI Conversion
Mainframe to PC Print Conversion
Indexed File Reorganization
Defining File Conversion with a Profile File
Converting Data Files


Recovery of Corrupt Indexed Files

Indexed files that have a corrupt index can be recovered using this option. Indices can become corrupt if, for example, a power loss occurs when a program has opened and changed an index file, but has not yet closed the file. A flag, indicating that this has occurred, is detected in the file and reported by subsequent accesses to that file. No further operations can be done on the file until its integrity has been recovered.

Rebuild rebuilds just the index, which is all that is required for the recovery. If the index is already in existence, Rebuild tries to recover the index using the information in that file.

Parent topic: File Rebuild
Related information
General Rebuild Information


General Rebuild Information

You should be aware of the following points when using Rebuild:

  • You should make a backup copy of the file being rebuilt or reorganized before using Rebuild. Rebuild takes every precaution to prevent the original files from being corrupted, but this can happen if the parameters are wrongly specified. Additionally, the original index is overwritten, so it would be wise to preserve it in case of any subsequent problems.
  • The facility to rebuild the index of an indexed file does not retain the information held in the original about free space in the data file. Consequently, this free space cannot be reused, and your file might grow bigger than necessary. To overcome this problem, reorganize the file after you have rebuilt the index, thus removing all of the free space. (Free space consists of the spaces in the data file occupied by deleted records. Information about these areas is normally retained, and the areas reused for new records as appropriate.)
  • When the rebuild process is complete, the data file is changed by adding a blank free space pointer record to the end of the file. Every time you rebuild the index a new record is added. Consequently, several rebuilds, without intervening reorganizations, cause the data file to grow. Again, this problem can be relieved by reorganizing the file, causing all the free space pointer records to be removed, and a single new blank one added.
Parent topic: File Rebuild
Related information
Recovery of Corrupt Indexed Files


Data File Converter Error Messages

To see details on the error messages, click General Reference > Error Messages > Data File Converter Messages.

Parent topic: DFCONV Batch File Conversion
Related information
Data File Converter Error Messages


VRECGEN

VRECGEN is a mainframe utility. Use VRECGEN to create a copy of a variable-length mainframe file. That copy embeds record length information in the data records for download from the mainframe to the PC. Micro Focus provides the source code for the VRECGEN utility (vrecgen.cbl). However, you may need to modify the source code before use, to specify options not catered for by the supplied version vrecgen.cbl.

The file created by VRECGEN has a two-byte record length field preceding each of the variable length data records. The record length field contains a value which is the two-byte record length field plus the length of the variable length data record. This is necessary because most file transfer software (for example, IBM SEND/RECEIVE) works with logical records and strips off the "Record Descriptor Word" which contains the length for each record. Without this information, it is impossible to separate the records to rebuild the data set on the PC.

The file created by VRECGEN is in a special download format. You should use the standard Transfer utility to transfer this file to the PC in binary format. The file can then be processed through the Data File Converter.

Note:

The source code to VRECGEN (vrecgen.cbl) is provided by Micro Focus primarily as a model, rather than as a final utility that meets the needs of all sites without modification. You should edit your version of vrecgen.cbl so that it contains the specific values that meet your application or site requirements. A typical reason for editing vrecgen.cbl is to increase the maximum record length to be more than 32,000 bytes.

  • Installing VRECGEN
  • Running VRECGEN
Parent topic: File Conversion Utilities
Related information
DFCONV Batch File Conversion
VRECGEN2


Installing VRECGEN

If you plan to download variable-length test files, you must first upload and compile the VRECGEN program in your mainframe environment. This program is provided as a sample COBOL program for converting mainframe variable-length format files.

Note: Each site should review the provided source code and determine maximum and minimum lengths for its variable-length files. These values (plus 4 for the MVS "Record Descriptor Word") should be used in the OCCURS DEPENDING ON clause of the record descriptions in the sample FDs.

To install VRECGEN:

  1. The source code file for VRECGEN is copied onto the PC as part of the installation procedure; the file name is vrecgen.cbl and it copies to the base\source directory in the installation of your COBOL development system
  2. After you install your COBOL development system, upload the file vrecgen.cbl to the mainframe, specifying conversion from ANSI to EBCDIC. Verify that the file is in fixed file, 80-byte card image format.
  3. Compile VRECGEN on your mainframe using your COBOL Compiler. When compiling this program, specify the following options. Some are compiler options, some run-time system options, and some are link-edit options. Use only those applicable to your specific environment and compiler:
    • NOSSRANGE or NOSUBRNGCK (no subscript range checking)
    • DATA(24)
    • NOOPT
    • AMODE=24,RMODE=24
Note: If you use VS COBOL II, Release 3 or above, and receive a file status of 39, recompile VRECGEN using the CMPR2 compile option.
Parent topic: VRECGEN
Related information
Running VRECGEN


Running VRECGEN

You need to supply the appropriate JCL information before running the VRECGEN on the mainframe. Enter the following JCL skeleton pointing to the correct STEPLIB, input data set and output data set:

//MYJOB   JOB (ACCOUNTING INFORMATION)
//STP1    EXEC PGM=VRECGEN
//STEPLIB DD DSN=STEPLIB,DISP=SHR
//SYSOUT  DD SYSOUT=*
//INPDD   DD DSN=INPUT.OS.DATA.SET,DISP=SHR
//OUTDD   DD DSN=OUTPUT.OS.DATA.SET,
//        DISP=(NEW,CATLG,DELETE),
//        DCB=(RECFM=VB,LRECL=LLL,BLKSIZE=BBB),
//        SPACE=(TRK,(X,Y),RLSE),
//        UNIT=SYSDA
Note:
  • When you fill in the LLL (LRECL) and BBB (BLKSIZE) values for the output file, refer to the values specified in the FD for OUTDD in your version of VRECGEN. The default LRECL and BLKSIZE from the program is 32700, but must be changed so that the JCL, FD in VRECGEN, and file-label on the input file are consistent.
  • The resulting output files are in the special download format, ready to be transferred to the PC using the standard transfer facility. Be sure, when you do the download, to specify a binary transfer and to not use the carriage control characters, CR (carriage return) and LF (line feed).
Parent topic: VRECGEN
Related information
Installing VRECGEN


VRECGEN2

VRECGEN2 is a mainframe utility that converts files in Micro Focus variable-length record format to mainframe format. Thus it enables you to upload these files and use them on the mainframe.

  • Installing VRECGEN2
  • Running VRECGEN2
Parent topic: File Conversion Utilities
Related information
DFCONV Batch File Conversion
VRECGEN


Installing VRECGEN2

If you plan to convert files in Micro Focus variable-length record format to mainframe format, you must first upload and compile the VRECGEN2 program in your mainframe environment:

  1. The source code file for VRECGEN2 is copied onto the PC as part of the installation procedure. The file name is vrecgen2.cbl and it is copied to the base\source directory in the installation of your COBOL development system
  2. After you install your COBOL development system, upload the file vrecgen2.cbl to the mainframe, in the same way as for VRECGEN, using CRLF and ANSI as parameters
Parent topic: VRECGEN2
Related information
Running VRECGEN2


Running VRECGEN2

The following steps show you how to upload a variable length data file whose records are between 100 and 400 bytes long:

  1. Convert your variable-length PC file to VRECGEN2 input format using the Data File Converter. Specify the minimum and maximum record lengths as 100 and 400 respectively. Note that because the Data File Converter prepends two bytes containing the record length, the actual minimum and maximum lengths are 102 and 402 respectively. If the file is in ANSI format, you should also convert it to EBCDIC format at the same time.
  2. On the mainframe, allocate a data file to receive the file from the PC. Use the following parameters:
    • FORMAT = VB
    • RECLEN = 406
    • BLKLEN = 410
  3. Upload the file. Don't set CRLF insertion. If you converted to EBCDIC at step 1, don't specify ANSI.
  4. Change the source of vrecgen2.cbl on your mainframe so that the FD for the output file matches the format of the required mainframe data file
  5. Compile and link vrecgen2.cbl
  6. Run VRECGEN2. The JCL is the same as for VRECGEN, except for the following changes:
    • The program-name should be VRECGEN2
    • The output file definition should be consistent with the output FD in VRECGEN2
    • Specify:
      • RECFM=FB
      • LRECL=404
      • BLKSIZE=408

A valid variable length file should result as the output. The following shows the format of a VRECGEN2 format file, using a record length of 100 bytes as an example:

Bytes | Contents
1-4 | Record Descriptor Word.
5-6 | Record length.
7-106 | Record data. The record is padded with null bytes if it is shorter than the maximum record size.
Note: The VRECGEN and VRECGEN2 file formats are incompatible in that VRECGEN format is used to download files from the mainframe and VRECGEN2 format is used to upload Micro Focus format files to the mainframe.
Parent topic: VRECGEN2
Related information
Installing VRECGEN2


Configurable Codesets

  • The Codecomp Utility
  • The Codeset Mapping File Format
  • Supported Country Codes
Parent topic: Working with Data Files
Related information
Rebuild
File Conversion Utilities


The Codecomp Utility

The Codecomp utility enables you to create customized mapping tables for EBCDIC/ANSI character set translation.

Codecomp can be used either with or without the /p option in the following way:

  1. With the /p option, specifying one filename with extension .e2a and one with extension .a2e. Codecomp creates these files, which contain the mapping tables used for the current country setting. You can then edit these files to produce your own customized tables.
  2. Without the /p option, specifying the two files produced in step1. A copybook called codeset.cpy, used for building a customized codeset module from mapping files, is produced.

Syntax

>>--codecomp--.----.--filename--.-----------.--><
              +-/p-+            +-filename2-+

where

/p | Specifies that the mapping table(s) in use for the current country setting are to be written to the specified file(s)
filename | The name of a mapping file. The file must have the extension .e2a for an EBCDIC to ANSI mapping table, or .a2e for an ANSI to EBCDIC mapping table. This file is an output file when the /p option is used, and an input file when it is not.
filename2 | The name of a mapping file. The file must have the extension .e2a for an EBCDIC to ANSI mapping table, or .a2e for an ANSI to EBCDIC mapping table. This file is an output file when the /p option is used, and an input file when it is not.

If you specify only a single filename when using the /p option, only the mapping file that you have specified (EBCDIC to ANSI or ANSI to EBCDIC) is produced.

If you specify only a single filename without using the /p option, Codecomp attempts to produce the corresponding mapping table by inverting the one in the file you provide. This can only succeed if the second column in the table contains all values from 0 through 255, as otherwise it would not be possible to produce round-trip conversions.

Parent topic: Configurable Codesets


The Codeset Mapping File Format

The mapping file format consists of an identifying string followed by two columns of hexadecimal numbers, as follows:

$ <identifying-string>
;
;
00 corresponding-value
01 ....
02 ....
.. ....
0A ....
.. ....
FF ....

<identifying-string> is mandatory. It must be the first non-comment line in the file, and is denoted by the dollar sign ($) as the first non-space character on the line.

The file must contain one mapping per line, with white space separating the columns. The entries do not have to be in an ordered sequence and blank lines are allowed.

The rest of the line following a semicolon (;) anywhere on a line is treated as a comment.

Failure to specify a complete mapping (that is all values from 00 to FF are mapped to a value) causes an error with no creation of CODESET.CPY.

The currency-sign, decimal-point, and comma characters must be mapped to three separate characters to enable numeric de-editing to function correctly. A warning message is displayed if these characters are not mapped to three separate characters, although creation of CODESET.CPY continues.

The mapping tables must use the following relationships only:

  • one unique source character to one unique target character
  • many source characters to one target character

In the second case you must supply both mapping tables, as it is not possible to create the second table automatically by inverting the first.

Parent topic: Configurable Codesets


Supported Country Codes

Studio Enterprise Edition has built-in support for the following character sets. The numbering convention used for single-byte character sets is that defined by the CCIT/ITU country code.

Support is provided for the following character set conversions, except where indicated:

  • EBCDIC to ANSI
  • ANSI to EBCDIC
MFCODESET | Character set
AUTOMATIC | Determined from the Windows country setting
AUTO | Determined from the Windows country setting
DEFAULT | US English
0031 | Dutch
0033 | French
0034 | Spanish
0039 | Italian
0043 | German (Austrian)
0044 | UK English
0045 | Danish
0046 | Swedish
0047 | Norwegian
0049 | German
0081 | Japanese Katakana Extended
0082 | Korean
0086 | Simplified Chinese
0351 | Portuguese
0358 | Finnish
0437 | US English
0500 | International (Latin 1)
0886 | Traditional Chinese
0939 | Japanese Latin Extended
9122 | Japanese Katakana

On Windows platforms. to use the Euro symbol (€), prefix the country code for EURO codesets with "E".

Parent topic: Configurable Codesets


To customize character set conversion

Note:

When creating a customized character set conversion, the resulting program will not be thread safe. This will cause problems in the Communications Process (MFCS) resulting in memory corruption.

To prevent this, insert a local-storage section declaration immediately after the working-storage section in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source\csnnnn.cbl file, where nnnn is the 4-digit country code.

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Compatibility Tools > Net Express Command Prompt.
  2. Create a new folder to hold temporary files and make it the current folder. For example:
    md mylang
 cd mylang
  3. At the command prompt, enter:
    set mfcodeset=nnnn

    where nnnn is the supported 4-digit country code whose character set conversion tables are most similar to the customized versions you want to create.

  4. Enter:
    codecomp /p mapfile.a2e mapfile.e2a

    The files mapfile.a2e and mapfile.e2a are created in the current folder.

  5. Edit the conversion tables in the mapfiles to suit your requirements. Mapfile.a2e contains the ANSI to EBCDIC conversion table; mapfile.e2a contains the corresponding EBCDIC to ANSI conversion table.
  6. Enter:
    codecomp mapfile.a2e mapfile.e2a

    A file codeset.cpy is created in the current folder.

  7. Enter:
    copy
          %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source\csnnnn.cbl csnnnn.cbl

    where %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x is your installation directory and nnnn is a number between 2000 through 9999 (excluding 9122) that you use to refer to your customized codeset module.

  8. Enter:
    copy csnnnn.gnt
          %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source\

    where %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x is your installation directory and nnnn is the customized codeset number.

Parent topic: Configurable Codesets


To change the current character set for command-line utilities

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Compatibility Tools > Net Express Command Prompt.
  2. At the command prompt, enter:
    set MFCODESET=nnnn

    where nnnn is either a supported 4-digit country code or the codeset number of a customized conversion module.

  3. Start the command-line utility from the same command-line session.
Parent topic: Configurable Codesets


File Systems

File systems on different operating systems can use different size addressing. Most current file systems use 32-bit or 64-bit addressing. The operating systems/file systems using these two sizes are listed in the links below.

The File Handler is configured to work with either 32-bit or 64-bit addressing by setting the FILEMAXSIZE configuration option. It is vital that all applications sharing a file use a File Handler that is configured in the same way, otherwise data corruption can occur.

You can configure the File Handler to use 32-bit addressing in a file system that uses 64-bit addressing. In this case, all files will be safely limited in size (to 32-bit addressing) by the File Handler.

  • 32-bit file systems
  • 64-bit file systems
  • File systems and FILEMAXSIZE
Parent topic: File Handling
Related information
File Handling Examples
File Handling Guide
Working with Data Files
Fileshare Guide


32-bit file systems

  • Windows Millennium
  • Windows 2000 (FAT)
  • Windows XP (FAT)
  • UNIX without large file system enabled
Parent topic: File Systems
Related information
64-bit file systems
File systems and FILEMAXSIZE


64-bit file systems

  • Windows NT (NTFS)
  • Windows 2000 (NTFS)
  • Windows XP (NTFS)
  • UNIX large file system
  • Linux
Parent topic: File Systems
Related information
32-bit file systems
File systems and FILEMAXSIZE


File systems and FILEMAXSIZE

The underlying file system affects the value to which this File Handler configuration option should be set.

CAUTION:
  • Do not set FILEMAXSIZE to 8 under any of the following circumstances:
    • You are running applications on an operating system which does not support a 64-bit file system.
    • You are running applications that access FAT file systems, since such file systems do not support file addressibility greater than 32-bit file addressing.
    • If any accessing program needs to access a shared file in a 32-bit file system.
    • You are sharing files with applications using earlier versions of the Micro Focus COBOL product that only supported 32-bit file access.
  • All applications accessing a file must run with the File Handler configured with the same value for FILEMAXSIZE.
  • Only 32-bit (4GB) support is provided for Novell systems.

In these situations you must set FILEMAXSIZE to 4.

Parent topic: File Systems
Related information
32-bit file systems
64-bit file systems


Fileshare Guide

Fileshare is a client/server system designed to provide more efficient processing of data files that are accessed concurrently, across a network, by a large number of users.

In addition, Fileshare offers features that are not available with the base COBOL file handler including transaction processing and rollforward recovery logging.

  • Introduction
    This chapter gives a brief overview of the facilities provided by Fileshare and also describes how Fileshare works.
  • Standard Operation
    This chapter describes what you need to do at the Fileshare Client and Fileshare Server machines to enable a standard COBOL program to use Fileshare. Once you have read this chapter, you should be able to configure any COBOL program to use Fileshare.
  • Configuring CCI Communications for Fileshare
  • Database Integrity
    This chapter describes all of those Fileshare features which enable you to safeguard the integrity of your database:
  • Security
    Fileshare provides security features which enable you to restrict access to a Fileshare Server.
  • Advanced Operation
    This chapter describes the advanced features that are available with Fileshare.
  • Fileshare on UNIX
    This chapter describes Fileshare on UNIX.
  • Error Handling
    Fileshare error messages are listed in the chapter Fileshare Server Messages .
  • Fileshare Server Messages
    There are three levels of messages that can be produced by the Fileshare Server.
Parent topic: File Handling
Related information
File Handling Examples
File Handling Guide
Working with Data Files
File Systems


Introduction

  • Overview
  • How Fileshare Works
Parent topic: Fileshare Guide
Related information
Standard Operation
Configuring CCI Communications for Fileshare
Database Integrity
Security
Advanced Operation
Fileshare on UNIX
Error Handling
Fileshare Server Messages


Overview

Fileshare is best suited to applications that share data files, concurrently, between many users, across a network. It supports all of the functionality provided by the base COBOL file handling system and provides several additional features:

  • Reduced network traffic
  • Transaction processing
  • Rollforward recovery logging
  • Logon and file open security checks

The ability of any one application to take advantage of these features depends on:

  • The way the application processes the shared data files
  • The type of data files the application shares
  • The operating system on which the Fileshare Server is running
  • The communications protocol being used between the Fileshare Client and the Fileshare Server

You do not need to make any program source code changes to use the basic Fileshare system. Source code changes are only needed to take advantage of some of the advanced features provided by Fileshare.

Parent topic: Introduction
Related information
How Fileshare Works


How Fileshare Works

Using the base COBOL file handling system, a typical COBOL I/O request to a shared data file causes the file handler to make several accesses to that data file across the network. See Figure 1.

Figure 1. Conventional Network
Conventional Network

With Fileshare, a program that needs to access a data file has its request processed by the File Handling Redirector (FHRedir) module. The FHRedir module sends the request over the network to a Fileshare Server that performs the low-level I/O operations and then passes the result of the I/O operation, including the file status, back to FHRedir. FHRedir returns the result to the program. See Figure 2.

Figure 2. Fileshare Network
Fileshare Network

A Fileshare System is made up of:

Fileshare Clients | A Fileshare Client comprises a user program, making data file I/O requests, via the FHRedir module. FHRedir redirects the I/O requests to a Fileshare Server.
Fileshare Servers | A Fileshare Server runs on the same machine as the data files that you want to access. The Fileshare Server accepts requests across the network from the Fileshare Client, processes them by calling a local copy of the Micro Focus File Handler and then returns the result to the Fileshare Client.
Note:
  • The Fileshare Server and the Fileshare Client can be running on the same physical machine. For example, with a multi-tasking operating system such as Windows, the Fileshare Client can run in one session and the Fileshare Server can run in another session. Using this method, you can develop Fileshare applications on a single PC without actually sending data across a network. You should be aware, however, that performance improvements will not be observed, as no network is being used.
  • You can also run the Fileshare Server in the same session as the Fileshare Client using the single user mode of operation. This enables you to take advantage of advanced Fileshare features, such as transaction processing, without the need for a network or multiple sessions. For more information on the single user mode of operation, see the section Single User Mode in the chapter Advanced Operations.

Since a single Fileshare Server processes all the requests from several Fileshare Clients, it can use a single copy of the Micro Focus File Handler, regardless of how many users are accessing the Fileshare Server. This has several advantages:

  • The Fileshare Server can open the data files exclusively making full use of both its own cache and the operating system's cache
  • The Fileshare Server does not need to obtain semaphores on the data file. Normally semaphores are needed to control concurrent access to shared data files.
  • The Fileshare Server can process record locks internally without the need to make calls to the operating system
Parent topic: Introduction
Related information
Overview
Single User Mode


Standard Operation

  • Fileshare Client
  • Fileshare Server
Parent topic: Fileshare Guide
Related information
Introduction
Configuring CCI Communications for Fileshare
Database Integrity
Security
Advanced Operation
Fileshare on UNIX
Error Handling
Fileshare Server Messages


Fileshare Client

To enable your COBOL program to use Fileshare at the Fileshare Client machine, you need to do two things:

  • Force your program to pass file I/O requests to the File Handling Redirector module (FHR), thus creating a Fileshare Client
  • Configure your Fileshare Client, specifying the name of the Fileshare Server to connect to, and the communications protocol to use when connecting.

You might also need to configure CCI for the communications protocol you have chosen. For more details, please refer to:

  • Your online book Configuring CCI
  • Specifying the Fileshare Server
  • Specifying the Communications Protocol
  • Configuring Your Fileshare Client
  • Using the File Handling Redirector Module
  • FHREDIR Return Codes
Parent topic: Standard Operation
Related information
Fileshare Server


Specifying the Fileshare Server

Each Fileshare Server on the network is identified by a unique name, assigned when the Fileshare Server is started. The Fileshare Client uses this name to specify which Fileshare Server to use.

There are two ways to specify the Fileshare Server name:

  • As part of the filename in your program.

    This requires changes to your code.

  • In a Fileshare Client configuration file.

    This does not require changes to your code.

These methods are listed in the next two topics.

  • As a Filename
  • In a Configuration File
Parent topic: Fileshare Client
Related information
Specifying the Communications Protocol
Configuring Your Fileshare Client
Using the File Handling Redirector Module
FHREDIR Return Codes


As a Filename

Specifying the server as a filename in your program overrides any configuration file settings.

Windows:

select account-file assign to	"$$server1\c:\accounts\main.dat"

This SELECT statement tells the File Handling Redirector module to direct requests for this data file to the Fileshare Server named server1. The data file is main.dat in the directory accounts on drive c: on the Fileshare Server machine. The File Handling Redirector module passes the characters appearing after the text string $$server1\ to the Fileshare Server as the name of the file.

UNIX:

select account-file assign to	"$$server1//accounts/main.dat"

This SELECT statement tells the File Handling Redirector module to direct requests for this data file to the Fileshare Server named server1. The data file is main.dat in the directory accounts on the Fileshare Server machine. The File Handling Redirector module passes the characters appearing after the text string $$server1/ to the Fileshare Server as the name of the file.

Parent topic: Specifying the Fileshare Server
Related information
In a Configuration File


In a Configuration File

To specify a default Fileshare Server, use the /s option in the Fileshare Client configuration file. For example:

Windows:

/s server2

UNIX:

-s server2

tells the Fileshare Client to use the default Fileshare Server named server2. The File Handling Redirector module redirects all file I/O to this server unless you:

  • Specifically define a file as a local file. See the section Client Configuration in the chapter Configuration for further information.
  • Specify that a file is on a different Fileshare Server, using the Fileshare Client configuration file. See the section Client Configuration in the chapter Configuration for further information
  • Specify a different Fileshare Server as part of the filename in your program (see above)
Note:

  • The Fileshare Client configuration file can contain a maximum of 16 unique Fileshare Server names
  • Filenames appearing in the configuration file are case-sensitive unless defined by the /r option (DYNCONFIG), in which case they are not case sensitive when run in Windows
  • The filename in the configuration file must appear exactly as it will appear to the File Handling Redirector module on the first OPEN request passed by your program
Parent topic: Specifying the Fileshare Server
Related information
As a Filename
Client Configuration


Specifying the Communications Protocol

Fileshare over CCI supports several communications protocols. The protocol you use depends on the operating system the Fileshare Client and Fileshare Server(s) are running on and the type of network you are using. You specify the Fileshare CCI communications protocols in the client's cci.ini file.

The default protocol is TCP/IP (CCITCP).

If you require a communications protocol other than the default, you must specify it in the Fileshare Client configuration file.

To specify an alternative default CCI protocol, use the /cm option. For example:

  • To make the Novell IPX protocol (CCIIPX) the default:
    /cm cciipx
  • To specify that a particular CCI protocol is used when communicating with a specific Fileshare Server, use the /cm and /s options together:
    /cm cciipx /s server1
    This tells the Fileshare Client to use the CCIIPX for communicating with the Fileshare Server named server1.
  • To make the Fileshare Client use the TCP/IP protocol (CCITCP) as the default and CCIIPX for communicating with server1:
    /cm ccitcp
/cm cciipx /s server1
Note: The cci.ini file that ships with Enterprise Sever contains detailed comments that explain the various cci.ini options that you can use to alter the basic CCISMEM configuration. Most of these are rarely required.
Parent topic: Fileshare Client
Parent topic: Configuring CCI Communications for Fileshare
Related information
Specifying the Fileshare Server
Configuring Your Fileshare Client
Using the File Handling Redirector Module
FHREDIR Return Codes
About Fileshare Communications
Using CCITCP
About CCISMEM
Using CCISMEM
Using UNIX named pipes: ccinampu
Logging Fileshare Messsages: CCI Trace
Using Multiple Protocols with Test Programs
Configuring the CCI Timeout


Configuring Your Fileshare Client

The Fileshare Client configuration file is an ordinary text file that you can create using any text editor. By default, it is called fhredir.cfg. The Fileshare Client searches for this file in the current working directory of your application and then along the path specified by the COBDIR environment variable, if one has been set up. Alternatively, you can specify the location of the Fileshare Client configuration file using the FHREDIR environment variable, for example:

Windows:

set FHREDIR=c:\client.cfg

This example tells the Fileshare Client to use the configuration file client.cfg in the root directory on drive c:.

UNIX:

set FHREDIR=/client.cfg
export FHREDIR

This example tells the Fileshare Client to use the configuration file client.cfg in the root directory.

Configuring the Fileshare Client enables you to specify how you want to treat your data files, that is, as either:

  • Local data files, located on the machine where the Fileshare Client is running. To access local data files, the Fileshare Client uses a local copy of the Micro Focus file handler. This is the default.
  • Remote data files, located on the machine where the Fileshare Server is running. To access remote files, I/O operations are redirected to the appropriate Fileshare Server by the File Handling Redirector module.

In order to redirect I/O operations successfully, the File Handling Redirector module needs to know:

  • Which Fileshare Server to communicate with
  • Which communications protocol to use when contacting the server
  • Fileshare Client Configuration Options
  • Example Client Configuration File
Parent topic: Fileshare Client
Related information
Specifying the Fileshare Server
Specifying the Communications Protocol
Using the File Handling Redirector Module
FHREDIR Return Codes


Fileshare Client Configuration Options

This section describes all of the available Fileshare Client configuration options. These options can appear as many times as necessary within a Fileshare Client configuration file, and in any order, but only one option can be specified per line.

Note:
  • The Fileshare Client configuration file can contain a maximum of 16 unique Fileshare Server names
  • Filenames appearing in the configuration file are case-sensitive unless defined by the /r option (DYNCONFIG), in which case they are not case sensitive when run in Windows
  • The filename in the configuration file must appear exactly as it will appear to FHRedir on the first OPEN request passed by your program
  • The Fileshare Server name is folded to uppercase. Note that it may be necessary to use the name in uppercase in some configuration files to ensure name matching works as expected.
  • UNIX:
    • In this section, options are shown starting with a forward slash (/). This is how you specify the options on Windows. On UNIX, use the hyphen (-) character instead of the forward slash.
    • Filenames are shown using the Windows file-naming convention. On UNIX, use the UNIX filenaming conventions.
Client Configuration Option Specifying
/bl
 Open a file exclusively to enable blocking, to improve performance.
/cm CCI-Protocol
 The default communications protocol for this Fileshare Client. Valid values for CCI-Protocol are listed in the table below.
/cm CCI-Protocol
/s ServerName
 The communications protocol to use when contacting the Fileshare Server, ServerName. Valid values for CCI-Protocol are listed in the table below.
/ct CCI-Timeout server-name
 The communications timeout period, specified in 1/10th seconds. The default is 1200 (120 seconds). See the section CCI Timeout in the chapter Communications for more information.
/cr CCI-Timeout
 The connection retry timeout period, specified in 1/10th seconds. The default is 0. This timeout is only for the initial connection and only applies if the CCI module returns and is out of memory or resources. The client will reattempt to connect at varying intervals up to the timeout period. However, the default is that the connection is only tried once.
/f Filename
/r Custom-File-Handler
 The data file Filename is a local file and should be actioned by the custom file handler. Repeat this option for eveyr data file you want assigned to a specific custome file handler that is not the default File Handler. Valid values for Filename and Custom-File-Handler are listed in the table below.

This option only applies if the environment variable DYNREDIR is set to DYNCONFIG.

/f Filename
/s ServerName
 The data file Filename is a remote file on the Fileshare Server named server-name. Repeat this option for every data file you want assigned to a specific Fileshare Server that is not the default Fileshare Server. Valid values for Filename and ServerName are listed in the table below.
/f Filename
 Filename is a local data file held on the PC where the Fileshare Client resides. Valid values for Filename are listed in the table below.
/s ServerName
 The ServerName as a default Fileshare Server

Accesses to data files not directed to a particular Fileshare Server or not defined as local data files are directed to the default Fileshare Servers. The order in which the default Fileshare Servers are defined in the Fileshare Client configuration file is the order in which the Fileshare Client contacts each Fileshare Server in an attempt to locate the file.

If the data file is not found on any Fileshare Server, the request for that data file is directed to the first default Fileshare Server listed in the configuration file.

Valid values for options in the Fileshare Client configuration file are:

Option | Valid Values
CCI-Protocol

Windows:

  • TCP IP: /ccitcp
  • CCISMEM: /ccism

UNIX:

  • TCP IP: -ccitcp: ccitcp
  • UNIX named pipes: -ccinampu
ServerName | Any character string up to 16 characters long depending on the CCI protocol you are using. The Fileshare Client configuration file can contain a maximum of 16 unique Fileshare Server names.
Filename Any valid filename that is supported by the operating system. Filenames cannot contain embedded space characters. You can use terminating wildcard characters in Filename to designate groups of files. For example, use
/f \accounts\*

to specify all files starting with the string "\accounts\".

Parent topic: Configuring Your Fileshare Client
Related information
Example Client Configuration File


Example Client Configuration File

This example shows a typical Fileshare Client configuration file.

/s server1
/s server2
/cm cciipx
/f \orders\* /s server3
/cm ccitcp /s server3
/f \accounts\payroll.dat
/f \transport\delivery\*
/f \returns\* /r module1!userfh1

where:

Line 1:
/s server1

Specifies that server1 is one of the default Fileshare Servers.

This Fileshare Server is searched for any file that is not defined as being on a particular Fileshare Server (see Line 4) or as local (see Lines 6 and 7). If you specify more than one default Fileshare Server (see Line 2), the Fileshare Servers are searched in the order that you have defined them in the configuration file. In this example, server1 is searched before server2.
Line 2:
/s server2

Specifies that server2 is also a default Fileshare Server. If you access a file that you have not defined to be on a particular Fileshare Server (see Line 4) or as local (see Lines 6 and 7), this Fileshare Server is searched after the Fileshare Server server1.

Line 3:
/cm cciipx

Specifies that the default communications protocol is CCIIPX. When the Fileshare Client tries to contact a Fileshare Server that does not have a specific CCI protocol defined (see Lines 1 and 2), this is the one used.

Line 4:
/f \orders\* /s server3

Specifies that FHRedir should direct all accesses to files with a name beginning with the string \orders\ to the Fileshare Server named server3.

Line 5:
/cm ccitcp /s server3

Specifies that the communications protocol to use when communicating with the Fileshare Server, server3 is ccitcp. This overrides any default CCI protocol specified in the Fileshare Client configuration file (see Line 3).

Line 6:
/f \accounts\payroll.dat

Specifies that the file \accounts\payroll.dat is a local file on the Fileshare Client machine. The Fileshare Client accesses this file using a local copy of the Callable File Handler.

Line 7:
/f \transport\delivery\*

Specifies that any files with a filename beginning with the string \transport\delivery\ are local files.
Line 8:
/f \returns\* /r module1!userfh1

Specifies that the customer file handler userfh1 in module1 should be used for all accesses to files with a name beginning with the string "\returns\".

Note that module1 specifies the library containing a custom file handler and that usedrfh1 is the name of the custom file's entry point.

This option only applies if the environment variable DYNREDIR is set to DYNCONFIG.
Parent topic: Configuring Your Fileshare Client
Related information
Fileshare Client Configuration Options


Using the File Handling Redirector Module

There are three ways of forcing your program to pass file I/O requests to the File Handling Redirector module:

  • If your program uses COBOL I/O syntax, you must compile it with the CALLFH"FHREDIR" Compiler directive so that the File Handling Redirector module processes any I/O requests that your program makes.
  • If your program uses the Micro Focus file handler API, you need to change the program so that it calls "FHREDIR" and not "EXTFH". (The call interface to the File Handling Redirector module is exactly the same as the call interface to the Callable File Handler (ExtFH).)

    For example:

    call "FHREDIR" using operation-code, fcd
  • Set the File Handler configuration option FHREDIR=ON.
    Note:

    Take care with this option. If it is in effect when Fileshare itself is running, Fileshare will attempt to redirect file I/O requests to itself, and this will cause a timeout failure.

When you have performed any of these actions, you have created a Fileshare Client but your program works in exactly the same way as it did before because the File Handling Redirector module simply forwards I/O requests to a local copy of the Micro Focus File Handler.

Parent topic: Fileshare Client
Related information
Specifying the Fileshare Server
Specifying the Communications Protocol
Configuring Your Fileshare Client
FHREDIR Return Codes


FHREDIR Return Codes

Each call to FHREDIR returns a status code in fcd-file-status in the FCD. Most codes returned are the usual file handling codes. The following codes specific to Fileshare might also be returned:

Code | Meaning
-128 | Fileshare Security is enabled and the user name specified by the caller is not found in the password file on the server.
-127 | The named file is not currently open by the fileshare server. This does not mean that the file does not exist on the disk.
-126 | Fileshare Security is enabled and the password given is incorrect.
-125 | The requested data is larger than the buffer provided to contain it. Increase the size of your buffer.
Parent topic: Fileshare Client
Related information
Specifying the Fileshare Server
Specifying the Communications Protocol
Configuring Your Fileshare Client
Using the File Handling Redirector Module


Fileshare Server

Before a Fileshare Server is invoked, you need to configure the Fileshare Server to specify:

  • The Fileshare Server name to use on the network
  • The communications protocols that it can use
  • Configuring the Fileshare Server
  • Starting the Fileshare Server
  • Stopping the Fileshare Server
Parent topic: Standard Operation
Related information
Fileshare Client


Configuring the Fileshare Server

You can specify these Fileshare Server configuration options in one of two ways:

  • On the command line (separated by spaces)
  • In a Fileshare Server configuration file (a text file which you can create using any text editor).

    The Fileshare Server identifies the configuration file to use by checking the FS environment variable:

    • If set, the Fileshare Server uses the configuration file specified by this variable
    • If not set, the Fileshare Server uses the default configuration file fs.cfg either in the current working directory of the Fileshare Server or on the path specified by the COBDIR environment variable
  • Specifying a Fileshare Server Name
  • Specifying the Communications Protocol
  • Fileshare Server Configuration Options
Parent topic: Fileshare Server
Related information
Starting the Fileshare Server
Stopping the Fileshare Server


Specifying a Fileshare Server Name

Each Fileshare Server is identified on the network by a unique name. This name is specified using the /s option, for example, the command line:

Windows:

fs /s server1

UNIX:

fs -s server1

registers the name of the Fileshare Server as server1.

Note:

The Fileshare Server cannot be initialized unless it registers a name on the network. The server-name can be up to 16 characters in length, depending on the CCI protocol you are using.

Parent topic: Configuring the Fileshare Server
Related information
Specifying the Communications Protocol
Fileshare Server Configuration Options


Specifying the Communications Protocol

By default the Fileshare Server uses CCITCP to communicate with Fileshare Clients using the TCP/IP protocol. You need to specify any other protocol you want Fileshare to use by specifying the /cm option, for example:

Windows:

/cm cciipx

This entry in the Fileshare Server configuration file enables the Fileshare Server to communicate with Fileshare Clients using the Novell IPX (CCIIPX) protocol.

UNIX:

-cm ccitcp
-cm ccinampu

These entries in the Fileshare Server configuration file enable the Fileshare Server to communicate with Fileshare Clients using TCP/IP (CCITCP) and the Named Pipes for UNIX (CCINAMPU) protocol.

Parent topic: Configuring the Fileshare Server
Related information
Specifying a Fileshare Server Name
Fileshare Server Configuration Options


Fileshare Server Configuration Options

This section describes all of the available Fileshare Server configuration options. The /s option that defines the server-name is compulsory. All other options are optional or have default values that are specified below.

Note:
  • UNIX: In this section, options are shown starting with a forward slash (/). This is how you specify the options on Windows. On UNIX, use the hyphen (-) character instead of the forward slash.
  • UNIX: Filenames are shown using the Windows naming convention. On UNIX, use the UNIX file-naming conventions.
Server Configuration Options Specifying
/s server-name
 The name that the Fileshare Server registers on the network. This must be a character string up to 16 characters in length, depending on the CCI protocol that you are using. The name specified must be unique. If a Fileshare Server with the same name is already registered on the network, an error is returned.
/d database-reference-file
 The name of the database reference file that the Fileshare Server is to use. The database reference file is used to determine which additional Fileshare features you want to use.
/t timeout-period
 Setting the record lock timeout period after which the Fileshare Server releases all record locks held by a Fileshare Client and rolls back any outstanding transactions. The timeout period is specified in seconds. The default value is 60 seconds. Specifying a value of zero disables the timeout and record locks are only released under the control of your application program. Valid values are 0 thru 99999. The timeout only occurs if one Fileshare Client requests a record currently locked by another Fileshare Client.

Setting a value of zero in conjunction with setting the environment variable ES_RLS_FILE_SUPPORT=Y ensures that no information is returned to the record area following a READ operation on a locked record.

/m record-size
 The maximum record size that can be processed by the Fileshare Server. Setting a value lower than the default value reduces the amount of memory that the Fileshare Server needs to run. The record size is specified in kilobytes. Valid values are 16 thru 64. If you specify a value less than 16, the Fileshare Server uses a buffer size of 16K. If you specify a value greater than 64, the Fileshare Server uses a buffer size of 64K.
/cm cci-protocol
 The CCI protocols that the Fileshare Server can use. Repeat this option for every communications protocol that you want to use to contact this Fileshare Server. Valid values for cci-protocol are:

Windows: ccinetb ccitcp cciipx UNIX: ccitcp ccinampu

/pf password-file
 The name of the password file that the Fileshare Server uses.
/tr f
 Activating the Fileshare Server trace option on start-up. Trace messages are written to the screen and to a file called fsscreen.lst in the Fileshare Server's current directory. This option seriously impacts the Fileshare Server's performance, so you should only use it for problem investigation.
/sc
 Use this to get the best performance. Switching Fileshare into synchronous communications mode. This means that when there is nothing for Fileshare to process, it goes into a wait state until interrupted by a message from the communications layer. You need to use a password file, and provide a password for fsview so that you can shut down Fileshare remotely. You can shut it down from the screen, but you might need to wait up to two minutes before it responds to the screen action.
/ev event-emit
Indicates the types of error messages that are written to fsscreen.lst in order to cause events if you have Fileshare tracing enabled.
event-emit is any combination of IEWS, where
  • I = information
  • E = error
  • W = warning
  • S = severe
-b
 You must specify this if the Fileshare Server is to run as a background process. You can use it only on the command line.
/pt time
 Writes to fsscreen.lst details of processes that take longer than the time specified to complete. Time can be specified in 10ths of a second.
  • Example Server Configuration File
Parent topic: Configuring the Fileshare Server
Related information
Specifying a Fileshare Server Name
Specifying the Communications Protocol
Database Reference File Maintenance
Automatic Record Lock Timeout
Security
Monitoring Fileshare
Fileshare on UNIX


Example Server Configuration File

This example shows a typical Fileshare Server configuration file.

/s mainsrv
/cm cciipx
/d dbase1.ref
/t 120
/pf \pass\passwd.fil

where:

Line 1:
/s mainsrv

Specifies that the Fileshare Server is to register its name on the network as mainsrv. Fileshare Clients must specify this name when they want to contact this Fileshare Server.

Line 2:
/cm cciipx

Specifies that cciipx is one of the communications protocols that a Fileshare Client can use to contact this Fileshare Server.

Line 3:
/d dbase1.ref

Specifies that the database reference file the Fileshare Server is to use is named dbase1.ref.

Line 4:
/t 120

Specifies that the automatic record lock timeout period is 120 seconds.

Line 5:
/pf \pass\passwd.fil

Specifies that the Fileshare Password Security feature is enabled and that the password file is \pass\passwd.fil containing valid user-IDs and passwords.

Parent topic: Fileshare Server Configuration Options


Starting the Fileshare Server

You must start the Fileshare Server running before Fileshare Clients can connect to it.

To start the Fileshare Server use the following command line:

fs
Parent topic: Fileshare Server
Related information
Configuring the Fileshare Server
Stopping the Fileshare Server


Stopping the Fileshare Server

Once started, a Fileshare Server runs as an active process until you explicitly stop it. You must stop the Fileshare Server when you no longer need it. To do this, press the Escape key. Fileshare displays:

FS097-I Are you sure that you wish to close down the Fileshare Server?

Enter Y to confirm that you want Fileshare to terminate. Any other entry causes the Fileshare Server to continue running.

If any data files are still open, the following warning is displayed:

FS111-I Warning - files are still open
        Continue to close down the Fileshare Server (Y/N) ?

Enter Y to confirm that you want Fileshare to terminate. Fileshare automatically closes all data files and rolls back any outstanding transactions. Any other entry causes the Fileshare Server to continue running. This warning indicates one of the following:

  • Fileshare Clients are still active, with open data files
  • A user program terminated abnormally without closing the data files it had open

If you are using the CCITCP protocol and the Fileshare Server terminates abnormally, you can restart the Fileshare Server using the same server-name. However, Fileshare displays the warning message:

FS153-I The Fileshare Server name has been reregistered on the network.
Parent topic: Fileshare Server
Related information
Configuring the Fileshare Server
Starting the Fileshare Server


Configuring CCI Communications for Fileshare

This section describe how to configure the communications between Fileshare Client(s) and Fileshare Server(s). Fileshare clients and servers communicate using the Common Communications Interface (CCI).

  • About Fileshare Communications
  • Specifying the Communications Protocol
  • Using CCITCP
  • About CCISMEM
  • Using CCISMEM
  • Using UNIX named pipes: ccinampu
  • Logging Fileshare Messsages: CCI Trace
  • Using Multiple Protocols with Test Programs
  • Configuring the CCI Timeout
Parent topic: Fileshare Guide
Related information
Introduction
Standard Operation
Database Integrity
Security
Advanced Operation
Fileshare on UNIX
Error Handling
Fileshare Server Messages


About Fileshare Communications

A Fileshare Server communicates with a Fileshare Client using the Common Communications Interface (CCI). A Fileshare Server can use several communication protocols concurrently, enabling it to communicate with a number of Fileshare Clients that do not all use the same protocol.

When you invoke a Fileshare Server, you need to specify the communications protocols it supports, using the /cm option in the Fileshare configuration file. Valid values for /cm are:

Windows platform:

  • TCP IP

    Setting: /ccitcp

  • CCISMEM

    Setting: /ccism

UNIX platform:

  • TCP IP

    Setting: -ccitcp

  • UNIX named pipes (FIFO pipes)

    -ccinampu

When running the Fileshare Server and Fileshare Client on the same UNIX machine, use the Named Pipes protocol for UNIX (CCINAMPU) as this provides significantly better performance than CCITCP.

Parent topic: Configuring CCI Communications for Fileshare
Related information
Specifying the Communications Protocol
Using CCITCP
About CCISMEM
Using CCISMEM
Using UNIX named pipes: ccinampu
Logging Fileshare Messsages: CCI Trace
Using Multiple Protocols with Test Programs
Configuring the CCI Timeout


Using CCITCP

Fileshare defaults to the TCP/IP (CCITCP) protocol. When using CCITCP, you can use either CCITCP Direct or the following process:

  • Both the Fileshare Client and the Fileshare Server must have access to a registration process. Depending upon the product that has been installed there are two versions of the registration server called ccitcp2 or mfds the Micro Focus Directory Server.
  • The registration process helps the Fileshare Client to locate the Fileshare Server.
  • The registration process can be running on any machine that the Fileshare Client and Fileshare Server can contact. It does not have to be running on the same machine as either Fileshare Server or Fileshare Client.
  • You must set the environment variable CCITCP2 to the host name of the machine where the ccitcp2 process is running.

    If you do not set the environment variable, CCITCP assumes that ccitcp2 is running on the local machine. The Fileshare Client and the Fileshare Server must register with the same ccitcp2 process in order to communicate with each other.

    For example, consider the situation where the Fileshare Server and the Fileshare Client are running on different machines and the ccitcp2 process is running on the same machine as the Fileshare Server. The environment variable CCITCP2 does not have to be set on the machine running the Fileshare Server. However, it must be set (on the machine running the Fileshare Client) to the TCP/IP host name of the machine where the Fileshare Server (and the ccitcp2 process) is running.

  • By default both ccitcp2 and mfds will start on TCP (mfds only) and UDP port 86. Both registration processes may be started on different ports. If this has been done then you must set the environment variable CCITCP2_PORT to the decimal number of the port that is being used for the registration process.

    For example, consider the situation where mfds has been started with CCITCP2_PORT set to 2023, or using the -p 2023 option. You must set CCITCP2_PORT to 2023 on both the Fileshare Client and the Fileshare Server.

Many configuration options exist for CCITCP, details of these can be found in the comments within the CCI.INI configuration file.

Parent topic: Configuring CCI Communications for Fileshare
Related information
About Fileshare Communications
Specifying the Communications Protocol
About CCISMEM
Using CCISMEM
Using UNIX named pipes: ccinampu
Logging Fileshare Messsages: CCI Trace
Using Multiple Protocols with Test Programs
Configuring the CCI Timeout
Configuring CCI


About CCISMEM

CCISMEM () uses a Named Shared Memory communications method to transfer date between two processes on the same Windows system. Both the client and the server application must reside on the same Windows system.

These shared memory transfers are typically about as fast as its possible to transfer data buffers between processes. Individual data transfers that fit within the shared memory segment are typically several context switches faster than using TCP/IP in loopback mode to move the same data. As buffer sizes grow the difference becomes less noticeable, but is still present. By default, shared memory segments are 8K in size, but this is easily configurable using the cci.ini configuration file options.

To also use clients are located on other systems, you must configure Fileshare Server to use CCITCP as well as CCISM. To do this, in cci.in set the following configuration options:

-cm ccitcp -cm ccism

Using two protocols within a single Fileshare Server prevents Fileshare Server being used in synchronous mode. This is the only functionality that is lost with this configuration.

From a client perspective, the default CCITCP functionality doesn't require much FHREDIR.CFG configuration. When using CCISMEM you will need to use the following client options:

/CM ccism

Note: when using CCISMEM the /MA parameter should not normally be used as it has a different meaning in the context of Named Shared Memory. The /MA option is equivalent to using the mem_files_location option in CCI.INI.

Parent topic: Configuring CCI Communications for Fileshare
Related information
About Fileshare Communications
Specifying the Communications Protocol
Using CCITCP
Using CCISMEM
Using UNIX named pipes: ccinampu
Logging Fileshare Messsages: CCI Trace
Using Multiple Protocols with Test Programs
Configuring the CCI Timeout


Using CCISMEM

Fileshare defaults to using the TCP/IP (CCITCP) protocol. If you are running both the Fileshare Server and the Fileshare Client on the same Windows system you can use an alternative connection method that utilises shared memory.

Shared Memory transfers are usually faster than using TCP/IP between two processes.

To configure Fileshare Server to use CCISMEM you must use the following option:

fs -cm ccism

Provided that you do not intend to run Fileshare server in synchronous mode you can combined multiple communications methods as follows:

fs -cm ccism –cm ccitcp

To configure Fileshare Client to use CCISMEM you must use the following line in FHREDIR.CFG:

/CM ccism

Note: When using CCISMEM the /MA parameter in FHREDIR.CFG has no effect.

Many configuration options exist for CCISMEM, details of these can be found in the comments within the CCI.INI configuration file.

Parent topic: Configuring CCI Communications for Fileshare
Related information
About Fileshare Communications
Specifying the Communications Protocol
Using CCITCP
About CCISMEM
Using UNIX named pipes: ccinampu
Logging Fileshare Messsages: CCI Trace
Using Multiple Protocols with Test Programs
Configuring the CCI Timeout


Using UNIX named pipes: ccinampu

Using UNIX named pipes (FIFO pipes)

Parent topic: Configuring CCI Communications for Fileshare
Related information
About Fileshare Communications
Specifying the Communications Protocol
Using CCITCP
About CCISMEM
Using CCISMEM
Logging Fileshare Messsages: CCI Trace
Using Multiple Protocols with Test Programs
Configuring the CCI Timeout


Logging Fileshare Messsages: CCI Trace

CCI Trace enables all the messages sent by CCI to be logged to a file. This can help in tracking down and debugging problems related to communications. To activate CCI Trace, add the following to the Fileshare Server configuration file:

/tr cci

To prevent unauthorized access to the CCI Trace information, you are prompted for the supervisor password when you invoke a Fileshare Server with CCI Trace enabled. If the password is accepted, CCI Trace is enabled and a second prompt asks if CCI Trace should be activated immediately or not.

Note:
  • The supervisor password is that specified for the user-ID FSVIEW in the password file, so you must specify the appropriate password file when you start the Fileshare Server.
  • CCI Trace can be toggled on and off using the F3 key.
  • The CCI trace options are specified via the CCITRACE environment variable.
Parent topic: Configuring CCI Communications for Fileshare
Related information
About Fileshare Communications
Specifying the Communications Protocol
Using CCITCP
About CCISMEM
Using CCISMEM
Using UNIX named pipes: ccinampu
Using Multiple Protocols with Test Programs
Configuring the CCI Timeout


Using Multiple Protocols with Test Programs

Switching between CCITCP protocol and CCISMEM protocol can affect test program timings.

Access to the driver levels usually results in the context switching out of the sending process quite soon after the send attempt has begun. Typically the peer process uses the CPU before the context switches back to the original process.

As a result, with CCITCP, more processing time is required at the driver level than with CCISMEM which has no driver application to call. When CCITCP moves to the drivers to execute the extra data moves, the context is switched out the parent process. On the other hand, using CCISMEM with the same send operation, no context switch occurs. The CCI caller manages when to switch to its peers.

When the configuration is set to async mode (the default) File Share polls CCI to determine if data is present to read. As a result, much more time in CPU processing is spent at the user level, waiting for the next buffer to process. The application and File Share do not context switch to the conversation peer until the end of a full time-slice. That is, the CPU cannot process the next chunk of data and to respond to the original sender until the end of a full time-slice.

This can often cause quite dramatic effects on heavily loaded single CPU systems, or dual/quad core systems, when using test application created with polling loops that have scrolling screen displays.

Highlighting windows and de-selecting them alters the time spent in clients and servers because it changes their system priorities and hence the amount of time that is spent polling around not yielding to let partner processes do their work.

In these cases the fastest route is always to not high-light either client or server, then they both get the same amount of CPU with the smallest time slice. Its a case of the processes running with too much CPU not too little.

The fastest design is of course to not loop at all, then you'll be in the right place to receive the in-bound data when it arrives, and to respond quickly without wasting any CPU cycles in redundant polling.

File share can be configured to avoid the polling loop.

Parent topic: Configuring CCI Communications for Fileshare
Related information
About Fileshare Communications
Specifying the Communications Protocol
Using CCITCP
About CCISMEM
Using CCISMEM
Using UNIX named pipes: ccinampu
Logging Fileshare Messsages: CCI Trace
Configuring the CCI Timeout


Configuring the CCI Timeout

By default, CCI waits 120 seconds for a network request to complete before it times it out and returns an error. If a network request has not completed in a period much shorter than this, it can usually be assumed that it is unnecessary to wait any longer. For example, if a Fileshare Server with the correct server-name is not active when a Fileshare Client attempts its first open, the application appears to hang for 120 seconds before a 9/124 status is returned because the server cannot be contacted. See the section Communications Errors in the chapter Error Handling for more details.

You can configure the Fileshare Client to use a shorter timeout period by using the /ct option in the client configuration file, fhredir.cfg. The timeout period is specified in 1/10th seconds.

For example:

/ct 300

This instructs the Fileshare Client to specify that CCI waits for 30 seconds for network requests to complete. After this time it returns a 9/124 status to the application program.

Parent topic: Configuring CCI Communications for Fileshare
Related information
About Fileshare Communications
Specifying the Communications Protocol
Using CCITCP
About CCISMEM
Using CCISMEM
Using UNIX named pipes: ccinampu
Logging Fileshare Messsages: CCI Trace
Using Multiple Protocols with Test Programs


Database Integrity

  • Transaction processing
  • Rollforward recovery
  • Database sequence numbering
  • Automatic database backup
  • Database reference file maintenance
  • Transaction Processing
  • Rollforward Recovery Logging
  • Rollforward Recovery Utility
  • Database Sequence Numbering
  • Automatic Database Backup and Rollforward Recovery
  • Database Reference File Maintenance
Parent topic: Fileshare Guide
Related information
Introduction
Standard Operation
Configuring CCI Communications for Fileshare
Security
Advanced Operation
Fileshare on UNIX
Error Handling
Fileshare Server Messages


Transaction Processing

Transaction processing enables you to group a set of data file updates together into one logical unit of work, known as a transaction. The changes you make as part of a transaction can be:

  • Permanently reflected in the data files by committing the work
  • Removed from the data files by rolling back the work. When a transaction is rolled back, the Fileshare Server returns the data files to the state they were in before the transaction started.

A transaction can include multiple updates to multiple data files on multiple Fileshare Servers.

A transaction starts when your program performs the first update operation (WRITE, REWRITE or DELETE) on a file which has the WITH ROLLBACK clause defined in its SELECT statement after:

  • The file is opened
  • A COMMIT or ROLLBACK statement is executed

A transaction terminates when:

  • A COMMIT verb is executed
  • A ROLLBACK verb is executed
  • The transaction is timed out. See the section Automatic Record Lock Timeout for further information.
Notes:

  • The COMMIT and ROLLBACK verbs release all the record locks held by a program on every data file. This does not depend on whether or not you specified the WITH ROLLBACK clause for a particular file.
  • The time taken to process a COMMIT or ROLLBACK operation is directly proportional to the number of updates performed in that transaction.
  • If you try to CLOSE a file that is participating in an active transaction, a 9/100 error status is returned and the file remains open. A COMMIT or ROLLBACK needs to be issued before the CLOSE can be executed.
  • When you use the WITH ROLLBACK clause, multiple record locking is implicitly defined on the file.

Before using transaction processing you are strongly advised to do the following to ensure the highest level of integrity for your data:

  • Include any file on which transaction processing is to be performed in the database reference file of the Fileshare Server that services the I/O requests for that file. See the section Database Reference File Maintenance for further information.
  • Specify a rollforward recovery log file in the database reference file. See the section Rollforward Recovery Logging for further information.

Record locks are implicitly obtained on every record that is updated in a transaction. If a transaction is temporarily suspended, for example, if your program requests input and the user is not responding, record locks can remain in the file for a considerable length of time. If another Fileshare Client tries to access the locked records, and a specified length of time has passed, the Fileshare Server aborts (rolls back) the transaction. When this happens, the transaction is said to be timed out by the Fileshare Server. See the section Automatic Record Lock Timeout for further information.

Note:

By keeping the number of updates performed in a transaction to a minimum, the number of record locks obtained is also kept to a minimum. This reduces the number of record locking conflicts between Fileshare Clients sharing the data, and increases the speed of any subsequent COMMIT or ROLLBACK operations.

  • Automatic Record Lock Timeout
  • Transaction Processing - Fileshare Client
  • Transaction Processing - Fileshare Server
Parent topic: Database Integrity
Related information
Rollforward Recovery Logging
Rollforward Recovery Utility
Database Sequence Numbering
Automatic Database Backup and Rollforward Recovery
Database Reference File Maintenance
Automatic Record Lock Timeout
Database Reference File Maintenance
Rollforward Recovery Logging


Automatic Record Lock Timeout

In a multi-user environment where files are being shared, programs use record locks to control concurrent access to individual records. In addition, Fileshare automatically obtains a record lock on any record that it updates within a transaction. The larger the number of record locks being held, however, the less concurrent access to data is possible. It is beneficial, therefore, for any one program to keep the number of record locks that it holds at any one time to a minimum.

If a Fileshare Client obtains a lock on a record (either explicitly or because it updated the record within a transaction) and a second Fileshare Client tries to read the locked record, the Fileshare Server checks to see how long it is since the Fileshare Client holding the record lock last contacted the Fileshare Server. If this period is:

  • Greater than the timeout period, the Fileshare Server:
    • Automatically rolls back any pending transaction being carried out by the first Fileshare Client
    • Releases all the record locks held by the first Fileshare Client
    • Returns error 9/068 "record locked" to the Client trying to read the record. Retrying the operation succeeds in gaining access to the record because the lock has now been released.
  • Less than the timeout period, the Fileshare Server returns error 9/068 "record locked" to the Fileshare Client trying to read the record

The default timeout period is 60 seconds. You can change this value using the /t option in the Fileshare Server configuration file. Specifying a value of zero disables the automatic record lock timeout such that record locks are only released under application program control.

A program that is timed out receives error 9/125 on its next I/O operation. You should treat this as a warning message and repeat the operation on which the error was returned. The Fileshare Server rolls back any active transaction and releases all the record locks held by the program that timed out.

Parent topic: Transaction Processing
Related information
Transaction Processing - Fileshare Client
Transaction Processing - Fileshare Server


Transaction Processing - Fileshare Client

For each data file on which you want transaction processing active, use the WITH ROLLBACK clause when you define the data file using the SELECT statement in your COBOL program.

For example:

select test-file assign to "test.dat"
   organization indexed
   record key prime-key
   lock mode manual with rollback
   ...

This sample code specifies that transaction processing is active on the file test.dat.

In your program, use the COMMIT verb to make the updates in a transaction permanent. Use the ROLLBACK verb to remove the updates in a transaction from the data files.

The COMMIT and ROLLBACK verbs work on all data files involved in a transaction. This means that you cannot check the status of the COMMIT or ROLLBACK operation using the file status of any one data file. Instead, you must call the File Handling Redirector module to check the status of the COMMIT or ROLLBACK. The entry point to call in the the File Handling Redirector module module is fs_status. The format of the call is:

call "fs_status" returning t-status
end-call

where t-status is defined as:

01 t-status  pic x(2) comp-x.

A non-zero value returned in t-status indicates that the COMMIT or ROLLBACK operation failed.

For example:

1   SELECT test-file ASSIGN TO "test.dat"
2      LOCK MODE MANUAL WITH ROLLBACK
3   ...
4   OPEN I-O test-file
5   ...
6   move 1 to prime-key
7   WRITE test-file-record
8   ...
9   COMMIT
10   call "fs_status"
11      returning t-status
12   end-call
13   if t-status < > 0
14      display "Warning - Commit operation failed"
15   end-if
16   move 2 to prime-key
17   WRITE test-file-record
18   ...
19   ROLLBACK
20   call "fs_status"
21      returning t-status
22   end-call
23   if t-status < > 0
24      display "Warning - Rollback operation failed"
25   end-if
26   WRITE test-file-record
27   ...

where:

Lines 1 - 2:
SELECT test-file ASSIGN TO "test.dat"
   LOCK MODE MANUAL WITH ROLLBACK

Specifies transaction processing for this data file.
Line 7:
WRITE test-file-record

Starts a new transaction.
Line 9:
COMMIT

Makes the updates to test-file permanent and terminates the transaction.
Lines 10 - 15:
call "fs_status"
   returning t-status
end-call
if t-status < > 0
   display "Warning - Commit operation failed"
end-if

Checks the status of the COMMIT operation.
Line 17:
WRITE test-file-record

Starts a new transaction.
Line 19:
ROLLBACK

Removes the updates made to test-file and terminates the transaction.
Lines 20 - 25:
call "fs_status"
   returning t-status
end-call
if t-status < > 0
   display "Warning - Rollback operation failed"
end-if

Checks the status of the ROLLBACK operation.
Line 26:
WRITE test-file-record

Starts a new transaction.

You do not need to change the configuration of the Fileshare Client to enable transaction processing.

Parent topic: Transaction Processing
Related information
Automatic Record Lock Timeout
Transaction Processing - Fileshare Server


Transaction Processing - Fileshare Server

You do not need to change the configuration of the Fileshare Server to enable transaction processing. However, if you recover a data file using the Rollforward Recovery Utility, any outstanding transactions at the end of the recovery process are implicitly rolled back. See the section Rollforward Recovery Utility for further information.

Parent topic: Transaction Processing
Related information
Automatic Record Lock Timeout
Transaction Processing - Fileshare Client
Rollforward Recovery Utility


Rollforward Recovery Logging

A system failure can result in loss of data in either of the following circumstances:

  • The Fileshare Server's cache or operating system's cache is not written to disk
  • The system failed while updating a file. In this case, the integrity of the files cannot be guaranteed

Rollforward recovery logging is the method used by Fileshare to store all the updates made to your data files in one or more log files. If your system fails, resulting in loss of data, the Rollforward Recovery Utility together with the log file(s) can be used to re-apply the updates to a back-up copy of the original data files. When the recovery is complete, the files contain the data they contained at the time of the system failure (with any outstanding transactions rolled back).

You do not need to make any changes to the Fileshare Client in order to use rollforward recovery logging.

  • Rollforward Recovery Logging - Fileshare Server
Parent topic: Database Integrity
Related information
Transaction Processing
Rollforward Recovery Utility
Database Sequence Numbering
Automatic Database Backup and Rollforward Recovery
Database Reference File Maintenance


Rollforward Recovery Logging - Fileshare Server

To log updates to one or more files you need to create a database reference file containing the name of the file(s) for which updates are to be logged, and the name of the log file. See the section Database Reference File Maintenance below for details on creating database reference files.

You do not need to include an extension when you specify the log file name as this is generated automatically by the Fileshare Server. If you do specify an extension, the following message is displayed:

FS180-W The log filename specified has an extension. The name of the
log file has been changed to "filename".

During the logging process the Fileshare Server creates one or more recovery log files. The first recovery log file is called a starter log file, and subsequent log files are called continuation log files. The Fileshare Server creates a continuation log file whenever the current log file is backed up.

The current recovery log file always has an extension beginning with the character "L". A recovery log file that has been backed up has an extension beginning with the character "B". Following either of these letters is a two digit number indicating the recovery log file number, starting at 01. These automatically generated extensions indicate the order in which the log files were written, and hence the order in which they should be applied if a rollforward recovery is performed. For example, suppose you specify a log file called recover. When the Fileshare Server starts up it creates a log file called recover.L01 and logs updates in this file. If the recovery log file is backed up, the Fileshare Server renames the current log file recover.B01 and creates a new one called recover.L02. If the Fileshare Server is shut down, there would be two recovery log files: recover.B01 is called the starter log file and recover.L02 is a continuation log file. There is only ever one starter log file, but there can be any number of continuation log files.

When performing a recovery operation, the Rollforward Recovery Utility processes the starter log file first and then the continuation log files in the order in which they were created.

Updates to data files with entries in the database reference file are logged unless you explicitly turn logging off:

  • To add a data file entry to the database reference file, use the /f option of the Database Reference File Maintenance Utility
  • To turn logging off for a particular data file, use the "/o l" (omit logging) option when you add the filename entry to the database reference file

Because of the caching used by some operating systems, not all of the information written to the log file is physically written to disk. The Fileshare Server periodically calls the operating system to force the log file updates to be written. By default, the log file is flushed after every 100 records are written to the log file. You can configure this interval using the /lc (log count) option when you add the log file name to the database reference file. If you specify a log count of zero, the Fileshare Server does not make any calls to the operating system to flush the updates to disk. Instead, the operating system controls the flushing of the log file to disk.

The log file updates are also flushed to disk after every COMMIT operation.

If a transaction was pending at the time of a system failure, the Rollforward Recovery Utility implicitly rolls back the transaction when the files are recovered.

Rollforward recovery logging can severely affect performance. You can use the "/o l" option in the database reference file to switch logging off for those files for which this feature is not essential. Alternatively, you can omit entries for these files from the database reference file altogether.

The recommended method of using recovery logging is:

  1. Each time you want to take a backup of your data files (preferably every day), shut down the Fileshare Server. The Rollforward Recovery Log file(s) contains information about every update made to your database files since the Fileshare Server was started.
  2. Now take a backup of your data files. Once you have backed up your data files, the log file(s) is obsolete (because you only need to log the updates since your last backup) and can be deleted.
  3. Restart the Fileshare Server. It creates a new log file, and any further updates to the files in the database are logged in this new file. In the event of data loss due to a system failure, you can restore your latest database backup and re-apply the updates recorded in the log file(s) using the Rollforward Recovery Utility.
Note:

You can have the Fileshare Server automatically perform this sequence of operations for you by specifying a backup directory in the database reference file. See the section Automatic Database Backup and Rollforward Recovery.

If you have a large number of updates being logged, the log file can grow very large. If the disk where the log file resides were to become full, the ability to write records to the log file could be lost. This would result in an incomplete log file forcing the Fileshare Server to close down. A warning is displayed when the amount of free disk space for the log file drops below a certain percentage of the total disk. You can configure this percentage using the /p database reference file option. When you see this warning, close down the Fileshare Server and take a new backup of your data files. This enables you to discard the log file and continue with a new one when the Fileshare Server is restarted.

If you ignore the warning message and the log file continues to grow larger, the Fileshare Server suspends operation when the free disk space available for the log file drops below 200,000 bytes. It displays error message FS030 and waits for the old log file to be backed-up remotely or removed manually before continuing with a new log file.

Parent topic: Rollforward Recovery Logging
Related information
Database Reference File Maintenance
Automatic Database Backup and Rollforward Recovery


Rollforward Recovery Utility

The Rollforward Recovery Utility enables you to recover updates to data files after a system failure.

Note:

The Rollforward Recovery Utility can only be used to recover a database if the updates were logged to a recovery log file. See the section Rollforward Recovery Logging for further details.

Before attempting the rollforward recovery process:

  • All of the recovery log files created while the Fileshare Server was active should be in the recovery log file directory (or the log file backup directory if one is specified in the database reference file)
  • The original data files (the back-up versions taken before the Fileshare Server was started) should be restored to their correct directories

Use the /r (recover) option to invoke the Rollforward Recovery Utility. You must specify a database reference file when invoking the Rollforward Recovery Utility, for example:

fs /r dbase.ref [options]

Here dbase.ref is the name of the database reference file used by the Rollforward Recovery Utility. This must be the same as the database reference file used by the Fileshare Server while it was running. The Rollforward Recovery Utility reads the database reference file to determine the location and name of the rollforward recovery log file(s) and the name(s) of the data file(s) to recover.

Note:

You can select the data files you want to restore by erasing other entries from the database reference file using the Database Reference File Maintenance Utility (/e option) before invoking the Rollforward Recovery Utility.

You can use the Rollforward Recovery Utility to specify the following options:

  • /dt date-time

    Specifies that the Rollforward Recovery Utility restores the updates made to the data files up to the time specified. The format of date-time is YYMMDDHHMMSS (year, month, day, hour, minutes, seconds) specified numerically. When you do not specify this option, the Rollforward Recovery Utility applies all of the updates that are stored in the rollforward recovery log file.

    For example:

    fs /r dbase.ref /dt 931231235959

    invokes the Rollforward Recovery Utility using the database reference file dbase.ref. Only those updates that were made up to the end of 31 December 1993 are restored.

  • /v

    Causes the Rollforward Recovery Utility to display additional information about which recovery log files it is searching for and in which directories.

Updates can be recorded in multiple log files (see the section Rollforward Recovery Logging for further details). The Rollforward Recovery Utility scans the log file directory for the starter log file. If none is found, the directory is scanned for a backed-up starter log file. If a starter log file still cannot be found the same procedure is repeated with the searches being performed in the backup directory if one is specified in the database reference file. If the Rollforward Recovery Utility is able to locate the starter log file then the recovery procedure commences; if not an error is displayed and the recovery does not start.

Once the starter log file has been processed, the Rollforward Recovery Utility searches for a continuation log file. If no backup of the recovery log file was performed, there is no continuation log file and the recovery process terminates. The Rollforward Recovery Utility searches for the continuation log file in the log file directory and then in the log file backup directory. The recovery process continues using the continuation log file(s) until all of the updates have been recovered and applied to the data files.

If transactions were in progress when the server terminated, then these transactions will be recorded but not committed. In addition, if the server was forced to terminate, then all open files will record a close, even if they were in mid transaction. A rollforward recovery will not be able to commit these transactions and a subsequent normal close would be illegal. When this situation occurs, the user will be informed with the message:

FS290-W Uncommitted transaction recorded - cannot complete transaction.

followed by the name of the file that cannot complete the transaction.

Parent topic: Database Integrity
Related information
Transaction Processing
Rollforward Recovery Logging
Database Sequence Numbering
Automatic Database Backup and Rollforward Recovery
Database Reference File Maintenance
Rollforward Recovery Logging


Database Sequence Numbering

Database sequence numbering provides a method of linking groups of data files so that they and their corresponding log file can be kept in step.

A sequence number, contained in the log file, is automatically stored in the header of each data file for which you have specified sequence numbering. Fileshare increments these sequence numbers every time you invoke the Fileshare Server. In order for the Rollforward Recovery Utility to work, all data files must have sequence numbers that match the log file. If the sequence numbers in the data files do not match, the Fileshare Server fails to start after displaying this message:

FS038-S A matching sequence number not found in <filename>

The possible causes for this error are:

  • A data file has been replaced by a file that does not contain the same sequence number as all the other data files listed in the database reference file. To recover, you need to install the correct file(s) on the system.
  • A power failure prevented proper shutdown of the Fileshare Server when it was last running. To recover the database files, use rollforward recovery. See the section Rollforward Recovery Utility for further information.

All data files listed in the database reference file have sequence number checking active by default. You can turn off sequence number checking using the database reference file option "/o s" (omit sequence numbering). If sequence number checking is not used on a file, your system administrator must make sure that the correct version of the file is installed in the Fileshare System.

Sequence numbering is only available on data files with a variable length record file header. The following file organizations do not contain headers and so sequence number checking is not possible:

  • Line sequential files
  • Non-data-compressed fixed length record sequential files
  • C-ISAM files
  • Non-data-compressed fixed length record relative files

If you have fixed length record data files that you want to use sequence numbering on, create them as variable length record data files. You can do this by changing the file definition in your COBOL program before creating the file.

Example

Data file definition specifying fixed length records:

 FD account-file.
 01 account-file-record.
    03 account-file-prime pic x(4).

Equivalent data file definition specifying variable length records:

 FD account-file recording mode is variable.
 01 account-file-record.
    03 account-file-prime pic x(4).

You do not have to change the configuration of the Fileshare Client or your program to make use of database sequence numbers.

  • Database Sequence Numbers - Fileshare Server
Parent topic: Database Integrity
Related information
Transaction Processing
Rollforward Recovery Logging
Rollforward Recovery Utility
Automatic Database Backup and Rollforward Recovery
Database Reference File Maintenance
Rollforward Recovery Utility


Database Sequence Numbers - Fileshare Server

For data files that you entered in the database reference file, sequence number checking is on by default. If you do not need sequence number checking for a particular data file, you can disable the feature by using the /o s (omit sequence numbers) option for that data file's entry in the database reference file.

Example

Windows:

fs /d dbase.ref /l \logdir\log.dat
fs /d dbase.ref /f test1.dat
fs /d dbase.ref /f test2.dat /o l
fs /d dbase.ref /f test3.dat /o s

UNIX:

fs -d dbase.ref -l /logdir/log.dat
fs -d dbase.ref -f test1.dat
fs -d dbase.ref -f test2.dat -o l
fs -d dbase.ref -f test3.dat -o s

This example specifies:

  • The database reference file is named dbase.ref
  • The log file is named log.dat in the logdir directory
  • Updates to the data file test1.dat are logged in the log file. By default, sequence number checking is on for any data file in the database reference file, and hence for this file
  • Updates to the data file test2.dat are not logged in the log file. The "/o l" option specifies that logging is omitted. However, sequence number checking is still active for this file.
  • Updates to the data file test3.dat are logged in the log file. However, sequence number checking is not activated for this data file. The "/o s" option specifies that sequence number checking is not used on this data file.
Parent topic: Database Sequence Numbering


Automatic Database Backup and Rollforward Recovery

The recommended method of using Fileshare's update logging for rollforward recovery is:

  1. Periodically to shut down the Fileshare Server
  2. Take a backup of all your database files
  3. Re-start the Fileshare Server with a fresh recovery log file

See the section Rollforward Recovery Logging for further details.

You can get Fileshare to do this for you automatically by specifying a backup directory-name in the database reference file using the /backup option. For example, the command:

Windows:

fs /d dbase.ref /backup	c:\backdir

UNIX:

fs /d dbase.ref /backup	/backdir

adds an entry to the database reference file called dbase.ref which specifies the backup directory as c:\backdir on Windows or /backdir on UNIX. A full path can be specified for the backup directory, otherwise paths which are not fully qualified are taken to be relative to the current directory of the Fileshare Server.

Setting a backup directory in this way causes the Fileshare Server to copy all the data files specified in the database reference file to the directory c:\backdir or /backdir on startup. The Fileshare Server also deletes any recovery log file(s) that it finds since this data is obsolete once the database files have been backed up.

While the Fileshare Server is active, all updates to files which have logging switched on for them are recorded in the log file as normal. The next time the Fileshare Server is restarted, it backs up the database files again and discards any log file(s). However, if it detects that the previous Fileshare Server session did not shut down successfully and a valid terminating record had not been written to the log file (for example, as a result of a system crash), then Fileshare automatically triggers the Rollforward Recovery Utility. This automatically restores the previous backup of the database files and recovers all updates to them as recorded in the log file(s). If the recovery completes succesfully, the Fileshare Server starts up as normal.

It is still possible to run the Rollforward Recovery Utility manually before starting up the Fileshare Server when a backup directory is specified in the database reference file. The Rollforward Recovery Utility automatically restores the previous backup before initiating the recovery.

Note:

The purpose of the automatic database backup facility is to help database administrators follow the recommended steps for rollforward recovery, thus ensuring that the latest Fileshare log file contains only the updates made since the last database backup. If database files are added or replaced manually, Fileshare may not detect this and could backup or restore the incorrect version of a file, compromising the integrity of your data. We recommend, therefore, that you do not attempt to replace any of the database files manually and only ever use Fileshare operations such as closing down the server to back up the entire database.

If you have enabled automatic database backup by specifying a backup directory, you cannot use the "/o l" option to switch logging off for any of the data files declared in the database reference file. By having logging active for every file specified in the database reference file, Fileshare can guarantee that it can recover updates to them all when it copies backed-up versions from the backup directory. If there are some files for which you do not require automatic backup, omit them from the database reference file.

If you need to back up your Fileshare files, for example as part of a system-wide backup overnight, you can use a Fileshare Manager API function to request Fileshare to shut down, back up all the database files and then restart with a fresh log file. Having done this, we recommend that you then make a permanent hard copy of the Fileshare backup directory. See the section Fileshare Manager in the chapter Advanced Operation for more information.

Example

Windows:

fs /d dbase.ref /l logfile
fs /d dbase.ref /backup c:\backdir
fs /d dbase.ref /f c:\accounts\customer.dat
fs /d dbase.ref /f c:\finance\history.dat

UNIX:

fs /d dbase.ref /l logfile
fs /d dbase.ref /backup /backdir
fs /d dbase.ref /f /accounts/customer.txt
fs /d dbase.ref /f /finance/history.txt

These commands perform the following:

  • Create a database reference file called dbase.ref
  • Specify the recovery log file as logfile so that the first log file that the Fileshare Server creates is called logfile.L01
  • Specify that any updates to the files c:\accounts\customer.dat and c:\finance\history.dat on Windows, or /accounts/customer.txt and /finance/history.txt on UNIX, are logged
  • Specify c:\backdir on Windows or /backdir on UNIX as the backup directory

On startup, the Fileshare Server automatically backs up these data files in the directory c:\backdir or /backdir. If the log file is backed-up while the Fileshare Server is active, backup files are also placed in this directory. If the Rollforward Recovery Utility is invoked, the backup files in c:\backdir or /backdir are restored to their original directories and any updates recorded in the log file(s) are re-applied.

Parent topic: Database Integrity
Related information
Transaction Processing
Rollforward Recovery Logging
Rollforward Recovery Utility
Database Sequence Numbering
Database Reference File Maintenance
Rollforward Recovery Logging
Fileshare Manager


Database Reference File Maintenance

The database reference file contains information that the Fileshare Server uses to determine which Fileshare features you want to use on which files. This section explains how to create and update a database reference file in order to make use of the features described earlier in this chapter.

Note:
  • You should only create or change a database reference file using the Database Reference File Maintenance Utility. This is because the file contains information that is stored in a special format.
  • UNIX: In this section, options are shown starting with a forward slash (/). This is how you specify the options on Windows. On UNIX, use the hyphen (-) character instead of the forward slash.
  • UNIX: Filenames are shown using the Windows naming convention. On UNIX, use the UNIX filenaming conventions.

The Database Reference File Maintenance Utility is invoked using the /d (database) option, for example:

fs /d dbase.ref [options]

where the parameters are:

dbase.ref | Name of the database reference file. If the database reference file does not exist, it is created.
options | These specify the operation to be carried out on the database reference file. Each initiation of the Database Reference File Maintenance Utility adds a record to or removes a record from the database reference file specified.

You can add several types of record to the database reference file.

  • Recovery Log File Records
  • Filename Record
  • File String Record
  • Backup Folder Record
Parent topic: Database Integrity
Related information
Transaction Processing
Rollforward Recovery Logging
Rollforward Recovery Utility
Database Sequence Numbering
Automatic Database Backup and Rollforward Recovery


Recovery Log File Records

You specify the name of the recovery log file using the /l option, for example:

fs /d dbase.ref /l logfilename

You can only have one recovery log file record in a database reference file.

You can specify the following for a recovery log file record:

  • The point at which the Fileshare Server displays a warning when the drive containing the log file is becoming full (use the /p option)
  • How often the log file is flushed to disk (use the /lc option)
  • Deletion of the record (use the /e option)
  • Disk Space Warning (/p)
  • Flushing the Log File (/lc)
  • Erasing a Log File Record (/e)
  • Example
Parent topic: Database Reference File Maintenance
Related information
Filename Record
File String Record
Backup Folder Record


Disk Space Warning (/p)

You can specify the point at which the Fileshare Server displays a warning when the drive containing the log file is becoming full using the /p option:

fs /d dbase.ref /l logfilename /p nnn

where nnn specifies the percentage disk space remaining, below which the Fileshare Server displays a warning message. The default value is 5, that is, the Fileshare Server displays the warning message when the drive containing the log file contains less than 5% free space.

Parent topic: Recovery Log File Records
Related information
Flushing the Log File (/lc)
Erasing a Log File Record (/e)
Example


Flushing the Log File (/lc)

You can specify how often the log file is flushed to disk using the /lc option:

fs /d dbase.ref /l logfilename /lc nnn

where nnn specifies the number of records that are written to the log file before the Fileshare Server calls the operating system to flush the log file buffers to disk. The default value is 100, that is, the Fileshare Server flushes the log file to disk after each set of 100 records are written to it. In addition, the Fileshare Server automatically flushes the log file after every successful COMMIT operation.

The Fileshare Server is unable to flush a log file if the log file is not on the machine where the Fileshare Server is running or if the operating system does not allow Fileshare to force the log file to be flushed. In this situation, the "/lc 1" option forces the Fileshare Server to specify writethrough when opening the log file. The log file is then written to disk if the operating system supports writethrough on files.

Parent topic: Recovery Log File Records
Related information
Disk Space Warning (/p)
Erasing a Log File Record (/e)
Example


Erasing a Log File Record (/e)

You can erase a recovery log file record using the /e option:

fs /d dbase.ref /l logfilename /e

This is the only way to remove a record once you have created the database reference file.

Parent topic: Recovery Log File Records
Related information
Disk Space Warning (/p)
Flushing the Log File (/lc)
Example


Example

fs /d dbase.ref /l \log\log.dat /p 10 /lc 200

Specifies the log file as log.dat in the directory log. Any data files that are specified in this database reference file have all updates recorded in this log file, unless logging is explicitly disabled for a data file. The /p option specifies that the Fileshare Server displays a warning message when less than 10 percent of the disk space remains free on the drive where the log file resides. The /lc option specifies that the Fileshare Server flushes the log file to disk after every 200 records are written to it.

Parent topic: Recovery Log File Records
Related information
Disk Space Warning (/p)
Flushing the Log File (/lc)
Erasing a Log File Record (/e)


Filename Record

You specify a filename record using the /f option, for example:

fs /d dbase.ref /f filename

specifies a data file that you want to include in the database reference file.

Any file that you specify in the database reference file has logging and, for those file organizations that support it, database sequence numbering, enabled by default.

You can specify the following for a filename record:

  • An alternative filename (use the /af option)
  • A virtual file handler (use the /ap option)
  • Data and key compression (use the /k option)
  • That logging is disabled for this file (use the "/o l" option)
  • That database sequence numbering is disabled for this file (use the "/o s" option)
  • That transaction processing is disabled for this file (use the "/o t" option)
  • Deletion of the record
  • Alternative Filename (/af)
  • Virtual File Handler (/ap)
  • Data and Key Compression (/k)
  • Disable Logging (/o l)
  • Disable Database Sequence Numbering (/o s)
  • Disable Transaction Processing (/o t)
  • Erasing a Filename Record
  • Examples
Parent topic: Database Reference File Maintenance
Related information
Recovery Log File Records
File String Record
Backup Folder Record


Alternative Filename (/af)

You can specify an alternative filename for a filename record using the /af option:

fs /d dbase.ref /f filename /af alternate-filename

such that whenever the Fileshare Server is asked to access the data file filename, it accesses alternate-filename instead.

Parent topic: Filename Record
Related information
Virtual File Handler (/ap)
Data and Key Compression (/k)
Disable Logging (/o l)
Disable Database Sequence Numbering (/o s)
Disable Transaction Processing (/o t)
Erasing a Filename Record
Examples


Virtual File Handler (/ap)

You can specify a virtual file handler for a filename record using the /ap option:

fs /d dbase.ref /f filename /ap program-name

where program-name specifies the virtual file handler that the Fileshare Server calls to process all I/O requests on the data file. See the section Virtual File Handler in the chapter, Advanced Operation.

The filename definition in the /f entry (corresponding to an /ap entry) can include a trailing wildcard to specify that groups of files are to have their requests passed to the specified virtual file handler.

Parent topic: Filename Record
Related information
Alternative Filename (/af)
Data and Key Compression (/k)
Disable Logging (/o l)
Disable Database Sequence Numbering (/o s)
Disable Transaction Processing (/o t)
Erasing a Filename Record
Examples


Data and Key Compression (/k)

You can specify data and key compression for a filename record using the /k option, for example:

fs -d dbase.ref /f filename /k DnnnIx

where nnn specifies the data compression routine number and x specifies the key compression number. Valid values for nnn and x are the same as those that can be specified for the Compiler directives DATACOMPRESS and KEYCOMPRESS.

Parent topic: Filename Record
Related information
Alternative Filename (/af)
Virtual File Handler (/ap)
Disable Logging (/o l)
Disable Database Sequence Numbering (/o s)
Disable Transaction Processing (/o t)
Erasing a Filename Record
Examples


Disable Logging (/o l)

You can disable logging for a file using the "/o l" option:

fs /d dbase.ref /f filename /o l

disables logging for filename.

Note:

You cannot disable logging for a file if you have enabled automatic database backup by specifying a backup directory record.

Parent topic: Filename Record
Related information
Alternative Filename (/af)
Virtual File Handler (/ap)
Data and Key Compression (/k)
Disable Database Sequence Numbering (/o s)
Disable Transaction Processing (/o t)
Erasing a Filename Record
Examples


Disable Database Sequence Numbering (/o s)

You can disable database sequence numbering for a file using the "/o s" option:

fs /d dbase.ref /f filename /o s
disables database sequence numbering for filename.
Note:

You should be aware that even with database sequence checking turned off, Fileshare will still update the sequence number in the header of the data file and thus also the timestamp. This is to ensure that if sequencing is turned back on, the sequence numbers will be in sync with other files.

Parent topic: Filename Record
Related information
Alternative Filename (/af)
Virtual File Handler (/ap)
Data and Key Compression (/k)
Disable Logging (/o l)
Disable Transaction Processing (/o t)
Erasing a Filename Record
Examples


Disable Transaction Processing (/o t)

You can disable transaction processing for a file using the "/o t" option:

fs /d dbase.ref /f filename /o t

disables transaction processing for filename. The WITH ROLLBACK clause in a SELECT statement for this data file is ignored. This option in the database reference file overrides any transaction processing specified in your program.

Parent topic: Filename Record
Related information
Alternative Filename (/af)
Virtual File Handler (/ap)
Data and Key Compression (/k)
Disable Logging (/o l)
Disable Database Sequence Numbering (/o s)
Erasing a Filename Record
Examples


Erasing a Filename Record

You can erase a filename record using the /e option, for example:

fs /d dbase.ref /f filename /e

erases the record from the database reference file. This is the only way to remove a record once the database reference file has been created.

Parent topic: Filename Record
Related information
Alternative Filename (/af)
Virtual File Handler (/ap)
Data and Key Compression (/k)
Disable Logging (/o l)
Disable Database Sequence Numbering (/o s)
Disable Transaction Processing (/o t)
Examples


Examples

fs /d dbase.ref /f \accounts\nomlgr.dat /k d001i7

specifies that the data file nomlgr.dat in the directory accounts has data compression and key compression activated if it is created by the Fileshare Server. The d001 option specifies the data compression routine you want to use is the same as if you compiled your program with the DATACOMPRESS"1" Compiler directive. The i7 option specifies the key compression to use is the same as if you compiled your program with the KEYCOMPRESS"7" Compiler directive. This overrides any data or key compression specified in the program.

fs /d dbase.ref /f \accounts\salesday.dat /o tl

specifies that any transaction processing specified in your program for the data file salesday.dat in the directory accounts is ignored. Also, logging is disabled for this file.

fs /d dbase.ref /f \ref\clients.dat /af \oldref\oldclnts.dat /o s

specifies that all I/O requests for the data file clients.dat in the directory ref are redirected to the data file oldclnts.dat in the directory oldref. In addition, database sequence numbering is disabled for this file.

fs /d dbase.ref /f \accounts\saleslgr.dat

enables logging and database sequence numbering for the data file saleslgr.dat in the directory accounts. By default, logging and database sequence numbering are enabled for every data file listed in the database reference file.

fs /d dbase.ref /f \orders\week10.dat

enables logging and database sequence numbering for the data file week10.dat in the directory orders. By default, logging and database sequence numbering are enabled for every data file listed in the database reference file.

Parent topic: Filename Record
Related information
Alternative Filename (/af)
Virtual File Handler (/ap)
Data and Key Compression (/k)
Disable Logging (/o l)
Disable Database Sequence Numbering (/o s)
Disable Transaction Processing (/o t)
Erasing a Filename Record


File String Record

You specify a file string record using the /fs option, for example:

fs /d dbase.ref /fs string1 /af string2

specifies that for any data file with a filename starting with string1, string1 is replaced by the character string string2.

  • Erasing a File String Record
  • Example
Parent topic: Database Reference File Maintenance
Related information
Recovery Log File Records
Filename Record
Backup Folder Record


Erasing a File String Record

You can erase a file string record using the /e option:

fs /d dbase.ref /fs string /e

erases the record from the database reference file. This is the only way to remove a record once the database reference file has been created.

Parent topic: File String Record
Related information
Example


Example

fs /d dbase.ref /fs c:\accounts\ /af c:\lastyear\accounts\

specifies that the character string c:\accounts\ at the front of any filename is replaced by the character string c:\lastyear\accounts\. Note that the string specified by the /fs option is not expanded relative to the Fileshare Server's current directory.

Parent topic: File String Record
Related information
Erasing a File String Record


Backup Folder Record

You specify an automatic backup directory using the /backup option, for example:

fs /d dbase.ref /backup c:\backup

specifies that on startup the Fileshare Server automatically copies all of the files named in the database reference file into the directory c:\backup.

Parent topic: Database Reference File Maintenance
Related information
Recovery Log File Records
Filename Record
File String Record


Security

You can also restrict access to specific data files under the control of a Fileshare Server. These restrictions are implemented via:
  • The Fileshare Password System
  • The Logon Validation module
  • The File Access Validation module
  • Password System
  • Logon Validation Module
    To validate a request to log on from a Fileshare Client, the Fileshare Server calls the module FSSecLog (the Fileshare Security at Logon Validation module) to validate the user-ID and password. You can replace FSSecLog with your own module in order to use your own criteria for validating the log on request. Your new module must comply with the FSSecLog interface described below.
  • File Access Validation Module
    To validate an open request from a Fileshare Client, the Fileshare Server calls the Fileshare Security at Open Validation module (FSSecOpn).
  • Password File Maintenance
  • User-ID Groups
  • Supervisor Mode
Parent topic: Fileshare Guide
Related information
Introduction
Standard Operation
Configuring CCI Communications for Fileshare
Database Integrity
Advanced Operation
Fileshare on UNIX
Error Handling
Fileshare Server Messages


Password System

If you invoke the Fileshare Server with the Password System enabled, all Fileshare Clients must supply a valid user-ID and password before they can connect to the Fileshare Server. By default, the Fileshare Password System is not enabled when you invoke the Fileshare Server.

If you want to use the Fileshare Password System you must code your program to pass a user-ID and password to the File Handling Redirector module and you must create a password file on the Fileshare Server machine which contains the user-ID and password that your program will use.

Then, to enable the Fileshare Password System, you must use the /pf option to specify the name of the password file to the Fileshare Server.

With the Fileshare Password System enabled, the sequence of steps that your program and Fileshare follow is (see the figure below):

  1. Your program registers its user-ID and password with the Fileshare Client by calling the File Handling Redirector password module (FHRdrPwd)
  2. Your program performs the first I/O operation
  3. The File Handling Redirector module obtains the user-ID and password registered in step 1 by calling the File Handling Redirector password module (FHRdrPwd)
  4. File Handling Redirector module passes the user-ID and password to the Fileshare Server
    Figure 1. Fileshare Password System
    Fileshare Password System
  5. The Fileshare Server validates the user-ID and password using the password file.
  6. If the Fileshare Server allows the logon, a connection is established between the Fileshare Client and the Fileshare Server. If the Fileshare Server does not allow logon, it returns a file status of 9/037 ("access denied") to the Fileshare Client.

Each of these steps is explained in more detail in the topics that follow.

  • Fileshare Client
  • Fileshare Server
  • Writing Your Own FHRdrPwd Module
Parent topic: Security
Related information
Logon Validation Module
File Access Validation Module
Password File Maintenance
User-ID Groups
Supervisor Mode


Fileshare Client

When Fileshare security is active, your program must supply a user-ID and a password before the first I/O operation is performed.

Even if you have not activated security, your program can still supply the Fileshare Client with a user-ID and password. This enables your program to run unchanged on Fileshare whether or not security is activated.

To register a user-ID and password, your program must call the module FHRdrPwd as follows:

call "fhrdrpwd" using function-code,
                      user-ID,
                      user-password
end-call

where the parameters are:

01 function-code       pic x comp-x.
01 user-ID             pic x(20).
01 user-password       pic x(20).

The function code to register a user-ID and password is 1.

The following example shows how to register a user-ID and password:

working-storage section.
01 function-code    pic x comp-x.
01 user-name        pic x(20).
01 user-password    pic x(20).
...
procedure division.
...
    move 1 to function-code
    move "UserID" to user-name
    move "Password" to user-password
    call "fhrdrpwd" using function-code,
                        user-name,
                        user-password
    end-call
    ...
    open output testfile
    ...

You can substitute the FHRdrPwd module supplied with the Fileshare System with your own. This enables you to retrieve the user-ID and password from somewhere other than the application program. See the section Writing Your Own FHRdrPwd Module for further details.

Parent topic: Password System
Related information
Fileshare Server
Writing Your Own FHRdrPwd Module
Writing Your Own FHRdrPwd Module


Fileshare Server

By default, the Fileshare Password System is not active when you invoke the Fileshare Server. If you want password security activated, use the /pf (Password File) option in the Fileshare Server configuration file, for example:

Windows:

/pf password.fil /s server1

UNIX:

-pf password.fil -s server1

specifies that for the Fileshare Server, server1, Fileshare Password Security is enabled and the password file is password.fil. The Fileshare Server uses this file to determine whether a Fileshare Client is allowed to connect to this Fileshare Server.

The Password File Maintenance Utility is used to create the password file and add user-ID and password entries. See the section Password File Maintenance for further information on this utility.

Parent topic: Password System
Related information
Fileshare Client
Writing Your Own FHRdrPwd Module
Password File Maintenance


Writing Your Own FHRdrPwd Module

To register a user-ID and password, your program must call the File Handling Redirector password module supplying a user-ID and password. If you do not want to hard-code this call into your program, you can replace the supplied File Handling Redirector password module with one that obtains the user-ID and password using a different method (for example, via a screen prompt). Your new module must still conform to the File Handling Redirector password module interface, that is:

Function Code | Action
= 1: | Register the supplied user-ID and password
= 0: | Return the user-ID and password. The File Handling Redirector module uses this call to obtain the user-ID and password when it is about to connect to the Fileshare Server.

Once you have written your own File Handling Redirector password module:

  • Windows: Create an object module from it, then create fhrdrpwd.dll. Copy the new fhrdrpwd.dll to your COBOL system directory, replacing the one that already exists.
  • UNIX: Compile it to a .gnt file, then copy the new fhrdrpwd.gnt to your COBOL system directory, replacing the one that already exists.

You can create an object module and link it into any application executable as required.

Parent topic: Password System
Related information
Fileshare Client
Fileshare Server


Logon Validation Module

Introduction

If you have not activated the Fileshare Password System, the Fileshare Server validates requests to log on by calling the Fileshare Security Logon validation module (FSSecLog).

The FSSecLog module supplied with Fileshare allows any Fileshare Client to log on to a Fileshare Server. If you need to restrict the Fileshare Clients that can log on to a Fileshare Server, you must provide your own, alternative, FSSecLog module for the Fileshare Server to call.

For example, your own module can enable integration with the native operating system security, if this is needed.

The sequence of steps that your program and Fileshare follow is (see Figure 5-2):

  1. Your program registers a user-ID and password by calling the File Handling Redirector password module (FHRdrPwd)
  2. Your program performs the first I/O operation
  3. The File Handling Redirector module obtains the user-ID and password registered in step 1 by calling its password module (FHRdrPwd)
  4. The File Handling Redirector module passes the user-ID and password to the Fileshare Server
  5. The Fileshare Server calls the FSSecLog module passing the user-ID and password
  6. If the FSSecLog module allows logging on, a connection is established between the Fileshare Client and the Fileshare Server. If the FSSecLog module does not allow logging on, a status 9/037 "access denied" is returned to the Fileshare Client.

Logon Validation Module

Syntax:

call "fsseclog" using user-ID
                      password
                      return-status

Parameters:

user-ID | pic x(20).
password | pic x(20).
return-status | pic x comp-x.

On Entry:

user-ID | The Fileshare Client's user-ID
password | The Fileshare Client's password

On Exit:

user-ID | Unchanged
password | Unchanged
return-status | Set to 0 if the Fileshare Client is allowed to log onto the Fileshare Server. Any other status indicates the Fileshare Client is not allowed to log on and an error is returned to the Fileshare Client.

Comments:

Windows:

You can create your own fsseclog module and link it into the Fileshare Server. See the section Linking the Fileshare Server on Windows in the chapter Advanced Operation for further details.

UNIX:

You can create your own fsseclog module in generated code format and replace the one supplied in your COBOL system directory.

Parent topic: Security
Related information
Password System
File Access Validation Module
Password File Maintenance
User-ID Groups
Supervisor Mode


File Access Validation Module

Whenever a Fileshare Server receives an open request on a file from a Fileshare Client, the Fileshare Server calls the Fileshare Security at Open validation module (FSSecOpn).

The Fileshare Security at Open Validation module supplied with Fileshare allows any Fileshare Client to access a data file. If you need to restrict access to specific files, you must provide your own, alternative, Fileshare Security at Open Validation module for the Fileshare Server to call.

If the Fileshare Security at Open Validation module allows the file access, the operation is allowed to complete. If the module does not allow the file access, a file status of 9/037 "access denied" is returned to the Fileshare Client and the operation is not allowed to complete.

Note: This file access security check is entirely independent of the Fileshare Password System and the User Supplied Logon Validation Module.

The sequence of steps that your program and Fileshare follow are:

  1. Your program registers its user-ID and password with the File Handling Redirector password module. This information is used when the Fileshare Client first logs onto the Fileshare Server.
  2. When your program subsequently performs an I/O operation on a file that it does not have open (such as an Open or Delete file operation), the Fileshare Server calls the Fileshare Security at Open Validation module (FSSecOpn)

You can replace the supplied Fileshare Security at Open Validation module with one of your own in order to use your own criteria for validating the open request. Your new module must comply with the Fileshare Security at Open Validation module's interface described below

Syntax:

call "fssecopn" using filename
                      filename-length
                      operation-code
                      user-ID
                      return-status

Parameters:

filename | pic x(n).
filename-length | pic x(2) comp-x.
operation-code | pic x(2) comp-x.
user-ID | pic x(20).
return-status | pic x comp-x.

On Entry:

filename | The name of the data file that the Fileshare Client wants to open
filename-length | The length of filename
operation-code | The operation code specifying the I/O operation. These codes are those used by the Callable File Handler. See your online help for details on the Callable File Handler.
user-ID | The user-ID of the Fileshare Client making the open request

On Exit:

return-status Set to 0 if the open request is allowed. Any other status indicates that the Fileshare Client is not allowed to open the data file and an error status is returned.

Comments:

Windows:

You can create your own fssecopn module and link it into the Fileshare Server. See the section Linking the Fileshare Server on Windows in the chapter Advanced Operation for further details.

UNIX:

You can create your own fssecopn module in generated code format and replace the one supplied in your COBOL system directory.

Parent topic: Security
Related information
Password System
Logon Validation Module
Password File Maintenance
User-ID Groups
Supervisor Mode


Password File Maintenance

The password file contains details of user-IDs and passwords that the Fileshare Server uses when Fileshare Password Security is enabled. Because the information in the password file is encrypted for security reasons, you can only add records to and remove records from the password file using the Password File Maintenance Utility.

UNIX:
Note:
  • In this section, options are shown starting with a forward slash (/). This is how you specify the options on Windows. On UNIX, use the hyphen (-) character instead of the forward slash.
  • Filenames are shown using the Windows naming convention. On UNIX, use the UNIX filenaming conventions.

Use the /pf (password file) option to add or remove entries in the password file, for example:

fs /pf pass.dat [options]

This invokes password file maintenance and appends the specified options to the password file pass.dat. If this file does not exist, it is created.

The following options are available:

  • /u user-ID
    /pw password

    These add the specified user-ID and password to the password file. Both user-ID and password are case-sensitive and can be up to 20 characters in length.

  • [/e]

    This erases the record from the password file and is the only way to remove a record once the password file has been created.

Example

fs /pf pass.dat /u pkel /pw fishwife

This example invokes password file maintenance, creates or updates a password file called pass.dat and adds a user-ID of pkel and password of fishwife.

Parent topic: Security
Related information
Password System
Logon Validation Module
File Access Validation Module
User-ID Groups
Supervisor Mode


User-ID Groups

You can group user-IDs by using the # character. If the # character is present in a user-ID, Fileshare registers the full passed user-ID but only performs logon validation on the portion of the user-ID prior to the # character.

When adding entries to the password file, you should create them as exclusive up to the # character. See the section Password File Maintenance for further information.

If you use view a user with a utility such as FSVIEW, the user information returned will show the full user-ID supplied by the client. Note that any reference to a user must be made using the full user-ID.

Example

fs /pf pass.dat /u pkel#1 /pw fishwife

This example invokes password file maintenance, creates or updates a password file called pass.dat and adds a user-ID of pkel#1 and password of fishwife.

Parent topic: Security
Related information
Password System
Logon Validation Module
File Access Validation Module
Password File Maintenance
Supervisor Mode
Password File Maintenance


Supervisor Mode

In order to use the password-restricted functions of Fileshare Manager, a supervisor password must be defined (see the section Fileshare Manager in the chapter Advanced Operation).

To define a supervisor password, an entry must be made in the password file using the reserved user-ID, FSVIEW. Note that the user-ID FSVIEW must be entered in upper case.

If you are already using Fileshare Password Security, simply add the FSVIEW entry to your existing file.

If you are not using Fileshare Password Security, you can create a password file that contains a single entry, the FSVIEW user-ID. This defines a supervisor password without enabling Fileshare Password Security.

Example

The following example defines a supervisor password of "abracadabra" in the password file password.fil. If the file does not exist, it is created.

fs /pf password.fil /u FSVIEW /pw abracadabra

Once you have defined a supervisor password, you must specify the password file, either in the Fileshare Server configuration file, or on the command line when the Fileshare Server is started.

Note:

If FSVIEW is the only entry in the password file, the Fileshare Server displays a message indicating that Fileshare Password Security is disabled, even though a password file has been specified.

Parent topic: Security
Related information
Password System
Logon Validation Module
File Access Validation Module
Password File Maintenance
User-ID Groups
Fileshare Manager


Advanced Operation

  • Single User Mode
  • Filename Mapping
  • Data and Key Compression
  • Virtual File Handler Interface
  • Monitoring Fileshare
  • FSVIEW
  • Fileshare Manager
  • Fileshare Manager Configuration
  • Linking Fileshare Manager Applications
  • Byte-stream I/O Calls
  • Running Fileshare as a Windows Service
  • Fileshare Server Configuration
  • Linking the Fileshare Server on Windows
  • Performance Considerations
  • Large File Support with Fileshare
Parent topic: Fileshare Guide
Related information
Introduction
Standard Operation
Configuring CCI Communications for Fileshare
Database Integrity
Security
Fileshare on UNIX
Error Handling
Fileshare Server Messages


Single User Mode

You can configure Fileshare to run in single user mode. All network communication is bypassed and the Fileshare Client makes direct calls to the Fileshare Server module. The Fileshare Server does not run as a separate process in this mode of operation.

This is useful when:

  • You want to develop Fileshare applications without using a network or multiple sessions
  • A single-user application makes use of one of Fileshare's advanced features, such as transaction processing

To run Fileshare in single user mode, set the FSCOMMS environment variable to $local, for example:

Windows:

set FSCOMMS=$local /s servername

UNIX:

set FSCOMMS="\$local" /s servername
export FSCOMMS

Even when you are running in single user mode, you must still inform the Fileshare Client which Fileshare Server to use, either by specifying the Fileshare Server name as part of the filename in your program or by using a Fileshare Client configuration file.

The Fileshare Server is configured in the normal way using a Fileshare Server configuration file. At the minimum, you must define a Fileshare Server name in this file.

Note:

The Fileshare Server does not have control over the screen when it is running in single user mode. It directs all screen output to the file fsscreen.lst in the current Fileshare Client directory. If your program fails, check this file for messages.

The FSSERVER environment variable must be unset.

Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare


Filename Mapping

Filename mapping enables I/O requests made against one data file to be mapped to a different data file when your program is executed. For example, you can use filename mapping to enable applications that use DOS file naming conventions to access data files under the control of a Fileshare Server running on an operating system that uses different file naming conventions, such as UNIX or NetWare.

You do not need to change the configuration of the Fileshare Client to use filename mapping.

  • Fileshare Server
Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare


Fileshare Server

To enable filename mapping, use the /af (alternate filename) option with the /f option in the database reference file.

The /fs (filename string) option used in conjunction with the /af option enables you to substitute characters at the start of a filename. This is particularly useful for mapping pathnames.

For example:

fs /d dbase.ref /f old.dat /af new.dat
fs /d dbase.ref /fs c: /af e:

adds entries to the database reference file dbase.ref which specify that:

  • All requests to the data file old.dat are redirected to the data file new.dat
  • All accesses to data files starting with c: are directed to drive e:

If the Fileshare Server finds an entry specifying an alternate filename, any character string substitution specified by a /fs option is applied to the new filename.

After processing any string substitution specified by an /fs option, the Fileshare Server does not search the database reference file for any matching /f option using the new filename.

Fileshare processes all filenames as relative to the Fileshare Server's current directory if you have not given a fully qualified filename after the /f option or a fully qualified filename is not passed from the Fileshare Client.

All filenames and paths are forced to upper case by Fileshare Servers not running on the UNIX operating system and are expanded to include the full path to ensure matching. Filenames specified with the /af option are not modified.

Example 1:

fs /d dbase.ref /f file1.dat /af c:\data\file2.dat

This example adds entries to the database reference file dbase.ref that specify that file accesses to the file file1.dat are mapped to the alternate filename file2.dat.

Example 2:

fs /d dbase.ref /f file1.dat /af c:\data\file2.dat
fs /d dbase.ref /fs c: /af e:

This example adds entries to the database reference file dbase.ref that specify that all requests made to the data file file1.dat are redirected to the alternate filename and, in addition, the alternate filename is changed, using string substitution, to be on drive e:.

Parent topic: Filename Mapping


Data and Key Compression

You can configure the Fileshare Server so that data files are created using data or key compression.

You do not need to change the Fileshare Client configuration in order to use data or key compression on a data file.

  • Data and Key Compression - Fileshare Server
Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare


Data and Key Compression - Fileshare Server

To enable data or key compression for a data file, use the /k option in the database reference file. In conjunction with the /k option, use the d option to specify data compression and the i option to specify key compression.

Values that you specify after the d and i options are the same values that you would specify using the Compiler directives DATACOMPRESS and KEYCOMPRESS.

Data and key compression specifications in the database reference file are effective only if the Fileshare Server creates the data files. They do not affect existing data files. For existing files, the data and key compression information is retrieved from the data file header. Any settings in your program or the database reference file are ignored.

Example:

fs /d dbase.ref /f file1.dat /k d001
fs /d dbase.ref /f file2.dat /k d001i7

This example tells the Fileshare Server to create the file file1.dat with data compression and the file file2.dat with both data and key compression.

Parent topic: Data and Key Compression


Virtual File Handler Interface

The Fileshare Server can pass I/O requests to a program specified by you, rather than by the Micro Focus File Handler, as long as the program that you specify conforms to the call interface used by the File Handler.
Note: If you are handling files using DXFORMATs 17 and 21, transaction processing capabilities are not supported.

You do not need to change the configuration of the Fileshare Client to use the Virtual File Handler Interface.

  • Fileshare Server
Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare


Fileshare Server

To specify a virtual file handler, use the /ap (application program) option with the /f option in the database reference file to specify the program to which I/O requests for a particular data file are passed by the Fileshare Server.

Example:

fs /d dbase.ref /f user1.dat /ap myprog

This adds entries to the database reference file, dbase.ref which specify that the Fileshare Server should pass all I/O requests for the data file user1.dat to the program myprog.

Windows:

On Windows, your program should be in .obj file format and needs to be linked into the main Fileshare module, fs.dll. See Linking the Fileshare Server on Windows for further details.

UNIX:

On UNIX, your program should be compiled to intermediate or generated code, or to a callable shared object, and must be callable from the Fileshare process.

You also need to use the fcd3 copybook instead of the standard fcd layout.

Parent topic: Virtual File Handler Interface


Monitoring Fileshare

When the Fileshare Server is active, you can toggle the trace option on and off using the F2 key. If the trace option is on, the Fileshare Server displays the file access requests on the console as they happen. Each line of trace provides:

  • Input:
    • The user-ID assigned, in the order that the Fileshare Clients logged onto the Fileshare Server
    • The operation code, indicating the I/O operation requested (see the online help on the Micro Focus File Handler for further information about operation codes)
    • The name of the file being accessed
  • Output:
    • The status returned to the Fileshare Client, indicating the result of the operation
Note:

The trace option can degrade performance. You should only use it as a diagnostic aid in problem investigation.

You can activate the trace option when the Fileshare Server is started using the "/tr f" option. This causes the trace to be written to the file fsscreen.lst, as well as being displayed on the screen. Note, however, that this severely impacts the Fileshare Server performance if tracing is switched on. If, however, tracing is switched off, only information messages are written to the screen and to the file. This is a useful method of keeping a permanent record of Fileshare messages on disk.

If you are using Fileshare in single user mode (see the section Single User Mode), the trace display, together with all other output normally displayed on the Fileshare Server console screen, is written to the file fsscreen.lst in the Fileshare Server's current directory .

Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare
Single User Mode


FSVIEW

FSVIEW is a data tool which enables you to view data and statistics produced by Fileshare and manage Fileshare servers remotely.

You can use FSVIEW to perform the following tasks:

  • Close files
  • Display a list of the FSVIEW commands
  • Get information about the currently accessed Fileshare server
  • Log users off Fileshare
  • Monitor logged-on users
  • Monitor open files
  • Rename the Fileshare log file
  • Remotely shut down a Fileshare server
  • Set a server password
  • Toggle traces on and off
  • View communications information
  • View database information
  • FSVIEW Command Line
  • FSVIEW API
Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare


FSVIEW Command Line

All of the features of FSVIEW are available to you as a command line utility.

The commands you specify on the command line define the operation to be carried out by FSVIEW. Information is returned as a scrolling screen output.

  • Redirection of Information
  • Command Files
Parent topic: FSVIEW
Related information
FSVIEW API


Redirection of Information

All information displayed by the FSVIEW command line utility can be redirected to a text file using standard operating system redirection:

> | Creates a new file
>> | Extends an existing file

For example:

@fred.ctl >> fsview.txt

redirects the output from fred.ctl to the existing file fsview.txt.

Parent topic: FSVIEW Command Line
Related information
Command Files


Command Files

On the FSVIEW command line, an at character (@) followed by a filename indicates that the named file contains FSVIEW commands.

If you use a file to supply FSVIEW commands, the file must be an ASCII text file.

Within the FSVIEW command file:

  • Commands should be separated by spaces.
  • Line ends are treated as spaces but a new command must start on a new line.
  • Any text between an exclamation mark (!) and the line end is treated as a comment.

The following example shows an FSVIEW command file that identifies a file and lists the users currently accessing it:

    ! Demo of fsview command file
    ! Identify file and list its users

    option upcase
    option no-echo
    admin logon FSVIEW MFTEST
    server set NWB-GLEN
    server get
    users get
    files get
    file get-users F:\testing\fsvtests\fresh\testfile1.dat
    user-file close 7 F:\testing\fsvtests\fresh\testfile1.dat
    users get
    files get

    exit

    ! All done

Note that if your command file does not use the FSVIEW exit command, you will remain in FSVIEW after the file has been executed.

Parent topic: FSVIEW Command Line
Related information
Redirection of Information


FSVIEW API

All of the functionality of FSVIEW is available as an API. We provide two copybooks for use with the FSVIEW API:

  • fsviewop.cpy

    Defines the FSVIEW API call names and their parameters.

  • fsdatab.cpy

    Defines the passed data block for use when tables are passed.

Note that the FSVIEW API includes the Fileshare Manager (fsmgr) API. See the section Fileshare Manager for more information on Fileshare Manager.

  • Call Interface
  • Callbacks
Parent topic: FSVIEW
Related information
FSVIEW Command Line
Fileshare Manager


Call Interface

The FSVIEW API is called fsviewc. All usage of the FSVIEW API must begin with a call to FSV-C (fsviewc) and end with a call to FSVIEW-C-TERM (fsviewc_term). See the topic FSVIEW API for more information on FSVIEW API functions.

The following example shows access to a Fileshare server which does not have Fileshare security enabled. The name of the server, the time the server was started and the current server usage level are returned:

*** initialize fsview
     call FSV-C

*** connect to a server called serverx
     move spaces to l-user-name
     move spaces to l-server-password
     move “serverx” to l-server-name
     call FSV-C-change-server using l-server-name
                                    l-user-name
                                    l-server-password

*** get basic server information
     call FSV-C-get-server-info using fsvw-data-block
     if return-code = h”3030”
         display "Current Server Status"
         display "Server Name - " fsvw-server-name
         display "Started     - " fsvw-server-startup
         display "Utilization - " fsvw-server-usage
     end-if

*** terminate fsview
     call FSVIEW-C-TERM
Note: This example uses the two provided copybooks.
Parent topic: FSVIEW API
Related information
Callbacks


Callbacks

Some FSVIEW calls do not directly return information to the calling program but make repeated calls back to a user-defined call. This is because fsviewc only processes items in blocks of ten.

For example, FSV-C-get-files-users uses the FSV-C-add-to-user-list callback to return a list of logged-on users for a specific file. Because fsviewc processes blocks of ten, repeated calls must be made in order to handle enough blocks of ten to code the total number of logged-on users being returned.

The following example shows an FSV-C-add-to-user-list callback. The entry point in this program allows fsviewc to execute the main body of the program. Without the entry point, the program would just set the number of users to 1 and exit:

 working-storage section.
*------------------------
 copy "fsviewop.cpy".

 01  work-vars.
     03  i                           pic xx comp-x.
     03  j                           pic xx comp-x.

 linkage section.

 copy 'fsdatab.cpy'.
 01  number-of-entries           pic xx comp-x.

 procedure division.
*-------------------

     move 1 to user-list-ptr
     exit program
     .

 list-users section.

 entry FSV-C-add-to-user-list using number-of-entries
                                    fsvw-data-block.

     if hide-changeable
         perform user-test-masking
     end-if

     perform varying i from 1 by 1
             until i > 10
                or user-list-ptr > number-of-entries
         if FSVW-INSERT-LIST-BOX-ITEM (i) not = spaces
             if hide-changeable
                 move all "X"
                   to FSVW-INSERT-LIST-BOX-ITEM (i)(s:l)
                 perform user-line-test-masking
             end-if
             display FSVW-INSERT-LIST-BOX-ITEM (i)(1:78)
         else
             if i = 1
                 display "No users found"
             end-if
             move 11 to i
         end-if
         add 1 to user-list-ptr
     end-perform
     .

     move zero to return-code
     exit program
     .
Parent topic: FSVIEW API
Related information
Call Interface


Fileshare Manager

You can use the Fileshare Manager (fsmgr) to automate some of Fileshare's supervisor mode functions by writing a COBOL program to call it. The Fileshare Manager can be called to instruct a Fileshare server to:

  • Perform an automatic backup of its recovery log file
  • Close all of its currently open data files. Any client application accessing these files is returned a file status, indicating that the file is no longer open. This is particularly useful in the event of a system crash or power failure, either of which could cause a Fileshare client program to terminate without disconnecting properly from Fileshare. If this happens, and data files are left open on the Fileshare server, it can prevent automatic disk backups from running and possibly prevent other clients from accessing the files.
  • Log off any clients currently connected to it, close any open files and roll back any incomplete transactions belonging to these clients.Any subsequent access attempts by these client applications result in an error status (9/125).
  • Close down completely. Any open files are closed and any incomplete transactions rolled back
  • Close down completely and then re-start. If a backup directory has been specified in the database reference file, Fileshare copies all the files named in the database reference file to the backup directory, deletes the recovery log file(s) and re-starts with a new recovery log file.
Note: Any Fileshare Clients connected to the Fileshare Server when this instruction is issued will be logged off and any files which they had open will be closed.

The Fileshare Manager program (fsmgr) is called from a COBOL program as follows:

Syntax:

call "fsmgr" using parameter-block

Parameters:

parameter-block
A group item defined as:
function-code
pic xx comp-x.
error-status
pic xx comp-x.
fileshare-name
pic x(16).
supervisor-passwd
pic x(20).
reserved
pic x(24).

On Entry:

function-code
The Fileshare Manager program function required:
1 | Backup recovery log file
2 | Close all open data files
3 | Log off all connected clients
4 | Shut down Fileshare
5 | Shut down and re-start Fileshare
fileshare-name
The name of the Fileshare server (this is the name that was used when Fileshare was started)
supervisor-passwd
The supervisor password. See the section Supervisor Mode in the chapter Security for more information
reserved
Reserved for future use. Must contain binary zeros.

On Exit:

error-status
Reflects the success, or failure, of the call. Possible values of error-status are shown below.
Value | Meaning
0 | Function completed successfully
1 Communications error. A Fileshare server of the name specified in fileshare-name could not be contacted on the network using the specified communications protocol. This error is also returned if a network failure occurs during the execution of the function but after the initial connection was made.

Check that fileshare-name is specified correctly and that the Fileshare Handling Redirection module (FHRedir) is configured to use the correct communications protocol.

2 File error during initial connection.

To connect to Fileshare, the Fileshare Manager opens a file called fsmgr.ctl. This file should not already exist and the Fileshare Manager does not actually create it. If it does exist, this status is returned if there is a subsequent error in closing the file.

3 Invalid password specified in supervisor-password.

Ensure that Fileshare is running with a password file and that the contents of supervisor-password match the supervisor password entry in the password file. Note that Fileshare passwords are case sensitive.

See Supervisor Mode in the chapter Security for more information.

4 | Invalid value specified in function-code - must be within the range one to five
5 No Fileshare log file.

You have attempted to backup the log file on a Fileshare server that is running without a recovery log file.

6 Function 2 or 3 could not complete.

While attempting to log off all Fileshare's clients (function 3), it is possible for other clients to log on before the logging off operation completes. For example, the Fileshare Manager has to send a "logoff client n" request four times if there are four clients logged on. If, however, a new client logs on before all four original clients have been logged off, the Fileshare Manager retries the "logoff client n" request in order to log off the new client. It retries 10 times and if new clients are still logging on, it returns error 6. A similar situation can occur during processing of a function 2 (close all data files) if new files are continuously being opened at the same time.

10 | Other error
Parent topic: Advanced Operation
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare
Supervisor Mode


Fileshare Manager Configuration

Fileshare Manager, like other Fileshare Client applications, accesses a Fileshare server via the Fileshare Handling Redirection module (FHRedir) and so needs to be configured to use the correct communications protocol. See the section Client Configuration in the chapter Configuration for more information.

Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare
Client Configuration


Linking Fileshare Manager Applications

On Windows, if your program calls the Fileshare Manager, you need to link in the Fileshare manager object file (fsmgr.obj when you create an executable file.

Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare


Byte-stream I/O Calls

Fileshare supports some of the byte-stream I/O routines that are available with this COBOL system. Most of the routines use the same parameters and have the same effect as the corresponding COBOL system call, but access remote files via Fileshare. The only change needed to your program is to call the routine starting with FS_ instead of CBL_. The only routine that does not have exactly the same call interface as its corresponding CBL_ routine is FS_LOCATE_FILE.

Fileshare supports the following byte-stream I/O routines:

  • FS_CHECK_FILE_EXIST
  • FS_CLOSE_FILE
  • FS_CREATE_FILE
  • FS_COPY_FILE
  • FS_DELETE_FILE
  • FS_JOIN_FILENAME (see below)
  • FS_LOCATE_FILE (see below)
  • FS_OPEN_FILE
  • FS_READ_FILE
  • FS_RENAME_FILE
  • FS_SPLIT_FILENAME (see below)
  • FS_WRITE_FILE

You can use these routines to access files on remote Fileshare servers, as well as local files. Configure the Fileshare Client in the normal manner to define which files are local and which are remote.

Note:

  • The FS_COPY_FILE routine only works on the Fileshare server and cannot be used to copy the file locally or to another Fileshare server. Currently you would have to code your own FS_OPEN_FILE and FS_READ_FILE/CBL_WRITE_FILE loop to copy the contents of the file locally.
  • Do not use byte-stream I/O and COBOL I/O on the same file
  • If you want to share files between multiple Fileshare Clients you must access the files using normal COBOL I/O verbs
  • FS_LOCATE_FILE
  • FS_SPLIT_FILENAME and FS_JOIN_FILENAME
Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare


FS_LOCATE_FILE

The functionality provided by FS_LOCATE_FILE is the same as CBL_LOCATE_FILE except:

  • You cannot use FS_LOCATE_FILE to search for files in libraries on remote Fileshare Servers
  • You can use CBL_LOCATE_FILE to search for files along each path specified in an environment variable. You can then use the returned actual-file-spec as the filename when opening the file.

    If you have specified a $$server-name prefix in user-file-spec, actual-file-spec must contain the same $$server-name prefix for an OPEN using actual-file-spec to be re-directed automatically. By default, Fileshare only returns the filename in actual-file-spec to your program. To return the $$server-name in actual-file-spec, set the most significant bit of user-mode before making the call to FS_LOCATE_FILE.

  • When a remote file is found, using an environment variable containing many paths, FS_LOCATE_FILE returns actual-file-spec including the full path where the file is located

When a call to FS_LOCATE_FILE is directed to a custom file handler by configurable DYNREDIR, the customer file handler is called with op-code FAF8 plus fcd(3:1) and uses the value 5 to specifiy it as an FS_LOCATE_FILE call.

On Entry Fields

On entry, the following fields are set:

fcd-name-ptr | Pointer to the user file
fcd-open-mode | User mode
fcd-optional | Path flag
fcd-name-length | Length of filename

On entry, the length of the fcd-name-length field is the same as the length of the filename pointed to by the field fcd-name-ptr.

On exit, you need to set the following fields:

fcd-record-ptr | Pointer to the actual file spec
fcd-access-mode | Exist flag
fcd-file-status | File status
Parent topic: Byte-stream I/O Calls
Related information
FS_SPLIT_FILENAME and FS_JOIN_FILENAME


FS_SPLIT_FILENAME and FS_JOIN_FILENAME

The functionality provided by FS_SPLIT_FILENAME and FS_JOIN_FILENAME is the same as that provided by the corresponding CBL_routines. In addition, using FS_SPLIT_FILENAME and FS_JOIN_FILENAME you can process filenames that specify Fileshare Server names using the $$server-name prefix at the front of the filename. When processing such filenames, the $$server-name prefix characters are included as part of the pathname parameter.

If you have included the callable sort, and receive error 173 after switching to release build, you need to include fhrsub.obj in your project.

Parent topic: Byte-stream I/O Calls
Related information
FS_LOCATE_FILE


Running Fileshare as a Windows Service

You can use the Fileshare Server so that it runs as a Windows service, using the following commands:

fsservice -i [service-name [configuration-options] ]
fsservice -u [service-name]
fsservice -v [service-name]

Where:

-i
Install the service.
-v
Display the status of the service.
-u
Uninstall the service.
service-name
A unique name for the service. The service is called "Micro Focus Fileshare Service:name", where :name is included only if a name is specified. service-name is optional unless you specify configuration-options, in which case it is mandatory.
configuration-options
Options used to start the Fileshare service. See Fileshare Server Configuration .

To start the Fileshare service as a background process and to stop it:

  1. Make sure the License Manager service is started.
  2. Click Control Panel > Services.
  3. Select Micro Focus Fileshare Service[: service-name] from the list of displayed services.
  4. Click Start or Stop as appropriate.

    You can also choose to start the service automatically whenever Windows starts.

Notes:
  • When you stop the service from the Services window, as above, Fileshare closes down as normal. Any connected Fileshare clients are logged off and their data files closed (with any incomplete transactions rolled back).
  • When you shut down Windows, Fileshare is similarly shut down.
  • If you choose it to start the service automatically and you have logging switched on for any data files, we recommend that you specify a Fileshare backup directory in your database reference file.

For example, the following command installs a service called "Micro Focus Fileshare Service: My Service", which will execute in the c:\mydir directory and use a Fileshare server name of myserver:

fsservice -i "My Service" /wd c:\mydir /s myserver
Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare


Fileshare Server Configuration

Windows:

When the Fileshare Server service starts, it is configured according to the Fileshare Server configuration file. By default, the service takes its configuration from %windir%\system32\fs.cfg, where %windir% is for example c:\winnt\system32. You can edit this file or create your own here or elsewhere.

The /cf option enables you to specify a configuration file containing the configuration options. For example, the following command installs a service called "Micro Focus Fileshare Service: My Service", which takes its configuration from the file c:\mydir\myfs.cfg:

    fsservice -i "My Service" c:\mydir\myfs.cfg

To use a different working directory, specify this using the /wd option as the first entry in your configuration file. On start-up, Fileshare changes to your specified working directory and accesses any files that are not fully qualified as being relative to this working directory. For example, the following command installs a service called "Micro Focus Fileshare Service: My Service", which will execute in the c:\mydir directory:

    fsservice -i "My Service" /wd c:\mydir /cf c:\mydir\myfs.cfg

Because Fileshare runs as a background process, any messages it generates are written to the file fsscreen.lst in the current working directory. Check the contents of this file to diagnose any problems.

Example:

The following is an example of a Fileshare Server configuration file:

    /wd d:\fsdir
    /s server1
    /d dbase.ref

where:

  • /wd d:\fsdir specifies the directory fsdir on the drive d: as the Fileshare Server's current directory. Any data files without fully qualified pathnames are searched for relative to this directory.
  • /s server1 specifies that the Fileshare Server is to register its name on the network as server1
  • /d dbase.ref specifies that Fileshare is to use the database reference file dbase.ref. Because this name is not fully qualified it is searched for in Fileshare's current directory, that is, d:\fsdir.

For details on the configuration options, see the section Server Configuration in the chapter Configuration.

Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Linking the Fileshare Server on Windows
Performance Considerations
Large File Support with Fileshare


Linking the Fileshare Server on Windows

Windows:

If you want to use the Virtual File Handler Interface or your own security modules on Windows, you need to recreate the file fs.dll. You can do this by entering a command line similar to the following:

cbllink.exe -o.\build\bin\fs.dll -d -RE -Mfscmd fscmd.obj fsserver.obj
    fhxscomp.obj fsseclog.obj fsinstpw.obj fsinst.obj fsrcvr.obj
    fspthnam.obj fssecopn.obj fsossec.obj tlogrest.obj
    _codeset.obj mfini.obj c2banner.obj xfhlabel.obj fsdll.res

Alter this command line to suit your own purposes by adding object modules or substituting security modules as necessary.

Alternatively, if you are running Fileshare as a Windows service, you will need to relink the fsservice.exe module using a command similar to the following:

cbllink -Rm -s -Mfssrvice -ofsservice.exe fscmd.obj  fsserver.obj
    fssrvice.obj  CblNTService_Handler.obj  CblNTService_SetStatus.obj
    CblNTService_ServiceRoutine.obj servserv.obj  fhxscomp.obj fsseclog.obj
    fsinstpw.obj fsinst.obj  fsrcvr.obj fspthnam.obj fssecopn.obj
    fsossec.obj tlogrest.obj _codeset.obj mfini.obj c2banner.obj xfhlabel.obj
    fssexe.res

Then uninstall the old version of fsservice and install this new version.

Note:

The .obj files required by the above commands are not supplied with Mainframe Express. If you are using Mainframe Express and need to recreate fs.dll or relink fsservice.exe please contact Micro Focus Product Support who can supply you with additional software containing the required files.

Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Performance Considerations
Large File Support with Fileshare


Performance Considerations

Although Fileshare reduces the number of requests made across the network for COBOL I/O, some types of data file access benefit more than others. The following areas affect Fileshare's ability to improve the speed of accessing remote data:

  • File organization

    A single request to an indexed data file can involve many accesses to the physical data file itself such as reading the header and updating the integrity marker. Complex key structures also increase the number of accesses needed to update the index structure in the file. Using the normal COBOL file handling system, each of these accesses generates a request that is sent across the network. Using Fileshare, only one request is sent across the network. The simpler data file organizations (relative and sequential files) involve a smaller processing overhead.

    Any speed improvements using Fileshare are therefore more apparent when processing indexed data files.

  • I/O request

    The number of accesses to a data file needed to process a WRITE, DELETE or REWRITE operation is generally larger than the number needed to process a READ or START operation. Using the normal COBOL file handling system, each of these accesses generates a request that is sent across the network. Using Fileshare, only one request is sent across the network.

    Any speed improvements using Fileshare are therefore more apparent when performing WRITE, DELETE or REWRITE operations.

  • Concurrent use of data files

    If your program opens a data file exclusively, the normal COBOL file handling system uses caching. This means that it does not have to check to see if the file has been updated on every I/O operation. The number of requests sent across the network, therefore, is significantly less if the data file is opened exclusively.

    Fileshare provides a greater improvement in performance, therefore, when a large number of users require concurrent access to data files than when files are opened exclusively. This is because access and caching are controlled by the Fileshare Server and so the additional requests needed when accessing a shared data file via the normal COBOL file handling system are not needed.

Any speed improvements are therefore very specific to individual applications and become more pronounced as more Fileshare Clients concurrently access the same data files.

We recommend you always use the synchronous mode of operation for best performance with Fileshare. Async-mode should be considered as being for development purposes only, and production installations should always use synchronous operation.

UNIX:

On UNIX, when running the Fileshare Server and Fileshare Client on the same machine, we recommend that you use the CCINAMPU CCI protocol as it performs better in this situation than the CCITCP protocol.

  • Fileshare Performance on UNIX
Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Large File Support with Fileshare


Fileshare Performance on UNIX

UNIX:

Fileshare improves performance when remote COBOL applications are concurrently accessing shared data files across a network but it cannot improve peformance when the COBOL data resides on the same machine as the application. In this configuration, there is actually a performance overhead when using Fileshare instead of the standard Callable File Handler.

Although UNIX machines can be used as remote data servers, it is not uncommon for the application itself to run on the machine where the data resides. For example, multiple users may log in, across a network, to a machine where they run applications which share the same data. In such a configuration, you encounter the performance overhead of using Fileshare, making performance slower than when using the standard Callable File Handler.

Parent topic: Performance Considerations


Large File Support with Fileshare

Fileshare, by default, supports files that can be up to 32 Terabytes in size.

An alternative technology, file striping, was introduced in previous releases as an interim solution to overcome limitations on the maximum allowed file size some operating systems permit. It enables you to specify that a single data file is to be stored in multiple physical files (or stripes) on disk.

Because of the complications involved with configuring striping together with Fileshare (these issues are discussed below), we recommend that you keep your large files non-striped and instead, configure the file handler to use its standard large file support.

To configure large file support under Fileshare, you should consider the following:

  • Location of the extfh.cfg file

    The extfh.cfg file must be located in the same directory as the Fileshare Server or, if the EXTFH environment variable has been set to point to the extfh.cfg file, it must have been set in the Fileshare Server session.

  • Switching on large file support

    Makes sure the value of FILEMAXSIZE specified in the extfh.cfg file is 8. This is the default value.

The following information explains how to configure striped files under Fileshare control if your operating system does not support large files:

  • Expanded filenames in the extfh.cfg file

    You must use the fully qualified name of the base file in the extfh.cfg configuration file. This name includes the pathnames that you can see if you press F2 at the Fileshare Server to switch tracing on.

    UNIX:

    For example, on UNIX:

    [/u/username/file.dat]
Striping=on
    Note:

    You need only do this for files accessed through Fileshare. To enable the file handler to find the setting in extfh.cfg the filename tag must match exactly that specified by the I/O request, which in the case of Fileshare includes a fully qualified path.

  • Backslash character

    The backslash character is treated as an escape character within the extfh.cfg file.

    Windows:

    On Windows platforms you must therefore specify two backslash characters for each backslash character in the pathname, for example:

    [d:\\fsrvr\\file.dat]
Striping=on
  • Alternate filenames

    You can specify file striping on an alternate filename (specified in the database reference file using filename mapping). In this case, the expanded filename is not required. For example, if the database reference file contains the following line:

    /f file1.dat /af file2.dat

    you can specify the following in the extfh.cfg file:

    [file2.dat]
Striping=on
  • StripeNameType

    StripeNameType=1 (the default is StripeNameType=0) only works with Fileshare if the base filename does not have an extension. If you specify StripeNameType=1 for a filename that has an extension, the file is created but it is not striped.

  • Back up and recovery

    The use of striping complicates the process of logging for rollforward recovery because the administrator has to ensure that the correct versions of the files are in the latest backup, and that they are correctly restored in the event of needing to run the Fileshare Recovery Utility. This process is much more complex if file stripes also have to be maintained.

    The Automatic Database Backup and Recovery facility does not work correctly on striped files because it uses low-level I/O routines for backups and restores which are unaware of the stripe configuration.

  • Not using Fileshare

    The filenames passed to the File Handler must match exactly so that the File Handler can locate the filename tags in the extfh.cfg file.

    Generally, only Fileshare passes fully qualified names. Therefore, if you have set up an extfh.cfg file for use under Fileshare with expanded pathnames and then want to access the files outside of Fileshare, you need to change the filename tags in extfh.cfg to match exactly the filenames passed by the application.

Parent topic: Advanced Operation
Related reference
Fileshare Manager
Related information
Single User Mode
Filename Mapping
Data and Key Compression
Virtual File Handler Interface
Monitoring Fileshare
FSVIEW
Fileshare Manager Configuration
Linking Fileshare Manager Applications
Byte-stream I/O Calls
Running Fileshare as a Windows Service
Fileshare Server Configuration
Linking the Fileshare Server on Windows
Performance Considerations


Fileshare on UNIX

  • Running Fileshare as a Background Process
  • The NFILES Setting
Parent topic: Fileshare Guide
Related information
Introduction
Standard Operation
Configuring CCI Communications for Fileshare
Database Integrity
Security
Advanced Operation
Error Handling
Fileshare Server Messages


Running Fileshare as a Background Process

The Fileshare Server uses the Enhanced Accept/Display syntax (Adis module) for its screen displays and keyboard handling. Consequently, the Fileshare Server uses much more processor time if you start it as a background UNIX process. To avoid this overhead, you should configure the Fileshare Server using the -b option. This disables all Fileshare displays and keyboard reading.

Since Fileshare does not read the keyboard in background mode, you cannot close it down in the normal manner using the Esc key sequence.

CAUTION:

Do not kill the Fileshare process because this results in the corruption of any data files which are open.

Instead, write a program which calls Fileshare Manager. Alternatively, you can run the supplied utility fsclose as follows:

cobrun fsclose

The fsclose utility calls Fileshare Manager itself and prompts you for the name of the Fileshare Server you want to close down and the CCI protocol.

Because you can only shut down the Fileshare Server remotely, the Fileshare Server must have been configured to use a password file. See the section Password File Maintenance in the chapter Security for details.

The Fileshare Server does not start in background mode unless you start it with a password file.

In background mode, any messages the Fileshare Server would normally display on the screen are written to the file fsscreen.lst in the Fileshare Server's current directory.

An example configuration file follows.

-s server-1
-pf password.fil
-cm ccitcp

This configuration file specifies:

  • Fileshare Server name is server-1
  • Password file is password.fil
  • Communications protocol to use is CCITCP
  • -b option invokes running in background mode

On UNIX, you can now start the Fileshare Server in background mode by entering:

fs -b > server-1.log 2>&1 &

On some UNIX systems, output can be sent to the terminal after it has been disconnected. When this happens the entire session terminates. Consequently, you need to redirect the output from the command.

Parent topic: Fileshare on UNIX
Related information
The NFILES Setting
Password File Maintenance


The NFILES Setting

On UNIX systems, the NFILES setting defines how many separate file descriptors can be used in the File Handler config file. This can be set for individual accounts and for the system as a whole. You must ensure that the number of separate file descriptors is set sufficiently high for Fileshare which uses them as follows:

  • One file descriptor is used for every file opened on disk. So, two file descriptors are used for each indexed file opened. Note that two users sharing the same file only require the file to be opened once on disk.
  • CCITCP uses one file descriptor for every connected Fileshare client
  • CCITCP uses one file descriptor for every outstanding Fileshare request (normally this is a maximum of two)

For the user account that the Fileshare session uses, NFILES must be set to accommodate the maximum number of open files and the maximum number of Fileshare clients. In addition, the system setting of NFILES may need to be increased.

Parent topic: Fileshare on UNIX
Related information
Running Fileshare as a Background Process


Error Handling

This chapter details:
  • Fileshare-specific causes of run-time status codes returned by the COBOL system
  • Communications errors generated by CCI
  • Transaction processing errors
  • COBOL Run-time Errors
  • Communications Errors
  • Transaction Processing Errors
Parent topic: Fileshare Guide
Related information
Introduction
Standard Operation
Configuring CCI Communications for Fileshare
Database Integrity
Security
Advanced Operation
Fileshare on UNIX
Fileshare Server Messages
Fileshare Server Messages


COBOL Run-time Errors

Status Code | Meaning
9/037 Access is denied. In addition to the normal situations where this error occurs, Fileshare generates this error when:
  • An invalid user-ID and/or password is passed to a Fileshare Server and Fileshare Password Security is active
  • A Fileshare Client attempts to access a particular data file and access is denied

See the chapter Security for more information.
9/100 | A CLOSE operation is tried on a data file that is participating in an active transaction. See the section Transaction Processing in the chapter Database Integrity for more information.
9/124 | A communications error occurred between the Fileshare Client and the Fileshare Server. You can call fs_status to determine the cause of the error. For details of this call see the section Communications Errors.
9/125 Caused by one of these conditions:
  • A transaction or record lock timed out. (See the section Automatic Record Lock Timeout in the chapter Database Integrity.)
  • The Fileshare Client has been forced to log off from the Fileshare Server
  • If you are using the Micro Focus File Handler interface, an invalid Fileshare session ID was passed on the call to the File Handling Redirector module. Check that the six bytes of the FCD from offset 79 have not been changed.
  • A previous access to this open file returned a 9/124 status, so further operations cannot be made
9/126 | The record size used on the I/O operation is too large to be handled by the Fileshare Server. See the description of the /m option in the section Server Configuration in the chapter Configuration.
9/173 | When using the virtual file interface, the program-name specified in the database reference file is not found. See the section Virtual File Handler Interface in the chapter Advanced Operation.
Parent topic: Error Handling
Related information
Communications Errors
Transaction Processing Errors
Security
Transaction Processing
Communications Errors
Automatic Record Lock Timeout
Server Configuration
Virtual File Handler Interface


Communications Errors

Error status 9/124 on an I/O operation indicates that a communications error has occurred between the Fileshare Client and the Fileshare Server.

The most common time for error 9/124 to occur is on the very first I/O request that your program makes. It is then that the Fileshare Client tries to contact the Fileshare Server. If the Fileshare Client is unable to do this, it returns error 9/124. If you receive this error, examine the configuration of Fileshare and check that:

  • The Fileshare Server is started and operational
  • You have specified the correct Fileshare Server name. The name that you specify must exactly match the name specified when the Fileshare Server was started.
  • The Fileshare Client and Fileshare Server are configured to use the same CCI communications protocol
  • You have a working network connection between the Fileshare Client and the Fileshare Server and the correct network driver and software is loaded

Once you have made a successful connection and the Fileshare Server is servicing the request from the Fileshare Client, the request is visible if trace is active at the Fileshare Server. See the section Monitoring Fileshare in the chapter Advanced Operation for more information. Any further communications errors are returned to the program using the error code 9/124. This is a fatal error and the Fileshare Client drops the connection to the Server. To determine the cause of the error, call the entry point fs_status in the the File Handling Redirector module. The format of the call is:

call "fs_status" returning cci-status

where the parameter is defined as:

01 cci-status   pic x(2) comp-x.

On return, cci-status contains the CCI error code returned to the File Handling Redirector module from the CCI module. For details of CCI error codes, please refer to your book, Configuring CCI.

You can make an additional call after error 9/124 to obtain an extended error message. This message is in the form of a text string that indicates a CCI-specific error as well as some additional information. The format of the call is:

call "fs_commserr" using by reference buffer
                         by value maxlen
                         by reference actual-len

where the parameters are defined as:

01 buffer       pic x(n).
01 maxlen       pic x(4) comp-5 value length of buffer.
01 actual-len   pic x(4) comp-5.

On return, buffer contains the extended error message and actual-len contains the length of this message. The additional information in the returned message includes:

  • The date and time that the last error 9/124 was returned
  • Last return code from the CCI module (a 4-digit number)
  • Message code (for the File Handling Redirector module's internal use, a 2-digit number)
  • The CCI error message text

In addition, the File Handling Redirector module automatically logs communications errors in a local file called fhneterr.log. Each entry in the log file has the same format as the buffer returned from the fs_commserr call.

If you do not have a call to fs_commserr in your application, you can check this file for more detailed information following a 9/124 error.

This log file is not deleted by the Fileshare Client. You can, however, delete it if its contents are of no interest.

Parent topic: Error Handling
Related information
COBOL Run-time Errors
Transaction Processing Errors
Monitoring Fileshare
Configuring CCI


Transaction Processing Errors

The COMMIT and ROLLBACK operations work across many data files. You cannot check the file status of any one data file to see if the COMMIT or ROLLBACK operation was successful. Instead, call the entry point fs_status to determine the status of the COMMIT or ROLLBACK operation.

The format of the call is:

call "fs_status" returning t-status

where the parameter is defined as:

01 t-status   pic x(2) comp-x.

A non-zero status indicates that the COMMIT or ROLLBACK operation failed. Fileshare cannot provide definitive information on transaction processing errors because of the complexity of multiple file transactions across networks.

Parent topic: Error Handling
Related information
COBOL Run-time Errors
Communications Errors


Fileshare Server Messages

These are of varying levels of severity:

  • Severe

    Severe level messages indicate that a problem has occurred that has prevented the Fileshare Server carrying out the requested operation. The cause of the error should be rectified and then the operation tried again.

  • Warning

    Warning level messages indicate that a situation was encountered that the Fileshare Server was not expecting, but was able to continue.

  • Informational

    Informational level messages provide information about the operations that the Fileshare Server is performing.

The format of each message is as follows:

FSnnn-x text

where:

Parameter | Description
FS | Fileshare Server message
nnn | Message number
x | Indicates the severity of the message ("S", "W" or "I")
text | Text of the message

For more information on the messages, see the links below.

  • Messages from FS001-S to FS050-W
  • Messages from FS051-W to FS099-W
  • Messages from FS101-I to FS149-I
  • Messages from FS151-I to FS200-W
  • Messages from FS201-S to FS252-S
Parent topic: Fileshare Guide
Related information
Introduction
Standard Operation
Configuring CCI Communications for Fileshare
Database Integrity
Security
Advanced Operation
Fileshare on UNIX
Error Handling


Messages from FS001-S to FS050-W

  • FS001-S The parameter "text " is not recognized as a valid parameter.
    This error status is displayed when the Fileshare Server parses the specified parameters and finds one which it does not recognize.
  • FS004-S The parameter "text " specifies a time-out value that is invalid.
    The /t parameter has been specified in a configuration file, but the characters following do not conform to a valid specification of a time-out value.
  • FS005-S The parameter "text " is too long or invalid.
    The parameter indicated could not be processed correctly. This can be for one of the following reasons:
  • FS006-S The parameter "text " has already been specified.
    A duplicate parameter has been specified and duplicates are not permitted for this parameter.
  • FS007-S Invalid parameter combination.
    Fileshare has processed the specified parameters and is unable to process the information given.
  • FS008-S Communications Initialization Failure.
    An error has occurred when the Fileshare Server initialized CCI or the Fileshare Server was unable to perform the CCI call because the required operating system and/or Micro Focus communication support modules are not available. This error can also indicate a problem with the network setup on the machine (for example, the required drivers have not been loaded).
  • FS009-S The required communications module cannot be found.
    The Fileshare Server tried to load the CCI module required for the protocol specified, but was unable to do so. This implies that the CCI module (or required support modules) cannot be found or they cannot be loaded.
  • FS011-W Communications send failure.
    The Fileshare Server encountered a communications error when it tried to return the result of an I-O operation to a Fileshare Client. This can imply that there is a problem with the network or that the Fileshare Client process terminated abnormally.
  • FS012-W Communications disconnect failure.
    The Fileshare Server tried to drop the connection with the Fileshare Client, but the communications system returned an error. The Fileshare Server tries to disconnect from Fileshare Clients when:
  • FS013-W Communications receive error.
    An unexpected error occurred while receiving information from the communications system. This error implies a problem with the network software or hardware because a message has been received but could not be processed correctly.
  • FS014-W Communications data length not as expected.
    The information sent from the Fileshare Client to the Fileshare Server includes a check on the amount of information that is being sent. This error occurs when the amount of data received by the Fileshare Server is not the same as the amount sent by the Fileshare Client.
  • FS015-W Request from unknown user - request rejected.
    The information received by the Fileshare Server is not recognized as being from a Fileshare Client that is currently logged onto this Fileshare Server.
  • FS016-S The parameter "text " is invalid.
    The parameter has been recognized as a valid parameter, but the option specified for that parameter is not valid. For example, the /o (omit) parameter has been specified, but the option is not t (transaction processing), l (rollforward recovery logging) or s (sequence number checking).
  • FS017-S Unable to open the file : filename.
    The Fileshare Server is unable to create the file specified.
  • FS018-S Log file corrupt - unrecognizable record in file.
    Each record written to the recovery log file has a marker informing the Rollforward Recovery Utility of the type of data contained in the record.
  • FS019-S Log file corrupt - can't read header.
    Each record written to the recovery log file has a marker indicating the type of data contained in the record. This error indicates that the required header record at the beginning of the log file was not found. This implies that the log file has become corrupt, which can happen, for example, if the system crashed while records were being written to the recovery log file.
  • FS020-S The log file does not match the database sequence numbers - recovery aborted.
    Each index file (not C-ISAM) and all variable length record files have (by default) a sequence number stored in the header of the file. A corresponding sequence number is stored in the log file. Checks are made between the sequence numbers in the file headers and the log file to help ensure that the recovery process proceeds successfully.
  • FS021-S There is no log filename specified in the database reference file.
    You have tried to erase a log file entry from the database reference file but there is no log filename specified in the database reference file. The operation therefore cannot be completed successfully.
  • FS022-S The log filename given cannot be found in the database reference file.
    You have failed to erase a log file entry from the database reference file because the log filename specified is not the same as the log filename in the database reference file.
  • FS024-S Failed to open log file : filename.
    The Fileshare Server encountered an error while trying to open or create the rollforward recovery log file. Common causes of this error are:
  • FS025-S Write failure to the log file, Fileshare Server is closing down.
    The Fileshare Server encountered an error while writing a record to the recovery log file. Because the integrity of the log file cannot be guaranteed, the Fileshare Server shuts down so that the updates performed up to the point of failure are not lost.
  • FS026-W Failed to close the log file.
    The Fileshare Server encountered an error while closing the current log file.
  • FS027-S A second log file parameter has been found.
    While processing the database reference file, a second log file parameter was found. There should only ever be one log file specified in the database reference file and this error indicates that the database reference file is corrupt or has been changed without using the Database Reference File Maintenance Utility.
  • FS028-W The log file shows the last session was not shut down successfully.
    When the Fileshare Server shuts down successfully, the last record written to the recovery log file is a special record that marks the end of the recovery log file. This message indicates that the Fileshare Server could not find the special, last record when it opened the log file, suggesting that the log file was not closed in a controlled manner, probably due to a system crash. The log file could have been opened either to append to or read from in order to perform a rollforward recovery.
  • FS029-S The log filename is already specified in the database reference file.
    You have tried to add the name of the recovery log file to the database reference file. However a log filename already exists in the database reference file. A database reference file can only contain one log filename.
  • FS030-S Insufficient disk space to continue logging to log file.
    The amount of space remaining on the disk where the log file is being written has less than 200K bytes of free space remaining. This is not adequate to ensure that the recovery log file can continue to be successfully written.
  • FS031-I Record lock time-out failure on user : user.
    A record lock time-out has occurred on the user indicated. This is due to the user holding a lock on a record for a period of time longer than the record lock time-out period, when another user is trying to access that locked record.
  • FS034-S A filename or log file parameter must be specified.
    The Database Reference File Maintenance Utility has been invoked using the /d option, however a valid parameter for the utility has not been given
  • FS035-S A database reference file must be specified.
    The Database Reference File Maintenance Utility has been invoked, however the name of the database reference file to use has not been specified using the /d parameter. For example, the parameter /f (filename), /l (log filename), /fs (file string) or /backup (backup directory) has been used to invoke the Database Reference File Maintenance Utility but a /d option has not been specified to supply the name of the database reference file.
  • FS037-I The file filename does not have a file header record. Sequence checking is switched off for this file.
    The Fileshare Server has determined that the file indicated does not have a Micro Focus format file header. It is not possible to have sequence numbering on files that do not contain file headers. However, the configuration of the database reference file specifies that sequence number checking should be applied to this file.
  • FS038-S A matching sequence number not found in filename.
    This error message is displayed when the sequence number in the header of the named file does not match the sequence number in the rollforward recovery log file. See the section Database Sequence Numbering in the chapter Database Integrity for full details of database sequence numbering works.
  • FS039-S Improperly closed file - filename.
    The Fileshare Server has found that the file indicated has been marked as corrupt because it was not closed correctly. This implies that the file was not closed in a controlled manner and that the Fileshare Server last accessing the file terminated abnormally.
  • FS040-S Unable to read the file header record in the file filename.
    The Fileshare Server was able to open the file specified, but was not able to read the file header. The file header consists of the first 128 bytes of the file.
  • FS041-S Unable to update the sequence number in the file filename.
    The Fileshare Server was unable to update the sequence number in the header of the file specified. The sequence number in the header of this file cannot be relied on and hence messages relating to incorrect sequence numbers can be ignored. However, careful checks should be made to ensure that the correct version of the file are in place when starting the Fileshare Server or performing a rollforward recovery.
  • FS042-S Unable to open the database reference file: filename.
    The Fileshare Server was unable to open the database reference file indicated
  • FS043-S The database reference file contains an invalid entry.
    The Fileshare Server has found data in the database reference file which is not as expected. This implies that the database reference file has been changed without using the Database Reference File Maintenance Utility or that the database reference file is corrupt in some way.
  • FS044-S Error reading the database reference file.
    An error was encountered when reading the database reference file. The file was successfully opened by the Fileshare Server. This message implies that the file is corrupt or that a disk I/O error occurred. Alternatively, if the database reference file is on a remote drive, a network error could have occurred.
  • FS045-W Duplicate filename specified in the database reference file.
    A duplicate filename was found when the Fileshare Server processed the database reference file. This message implies that the database reference file has been modified, but not using the Database Reference File Maintenance Utility. A given filename should appear only once in the database reference file.
  • FS050-W A log file is not specified in the database reference file.
    The Fileshare Server processed the database reference file but could not find a rollforward recovery log filename. The database reference file should have a recovery log file specified in order that recovery logging can be performed.
Parent topic: Fileshare Server Messages
Related information
Messages from FS051-W to FS099-W
Messages from FS101-I to FS149-I
Messages from FS151-I to FS200-W
Messages from FS201-S to FS252-S


FS001-S The parameter "text " is not recognized as a valid parameter.

The operation did not complete.

Resolution:

Change the indicated parameter and retry the operation.

The valid parameters are given in the sections:

  • Server Configuration in the chapter Configuration
  • Database Reference File Maintenance and Rollforward Recovery Utility in the chapter Database Integrity
  • Password File Maintenance in the chapter Security
Parent topic: Messages from FS001-S to FS050-W
Related information
Server Configuration
Database Reference File Maintenance
Rollforward Recovery Utility
Password File Maintenance


FS004-S The parameter "text " specifies a time-out value that is invalid.

The time-out value is specified in seconds and must be in the range 0 through 99999.

See the section Automatic Record Lock Timeout in the chapter Database Integrity for more information.

Resolution:

Retry the operation using a time-out value in the correct range.

Parent topic: Messages from FS001-S to FS050-W
Related information
Automatic Record Lock Timeout


FS005-S The parameter "text " is too long or invalid.

  • The parameter specified is too long. For example a password has been specified which is more than 20 characters in length.
  • The parameter expects a value, but none has been given. For example, the /t parameter has been specified but no time-out value has been given.

Resolution:

Retry the operation using a correct value for the parameter indicated.

Parent topic: Messages from FS001-S to FS050-W


FS006-S The parameter "text " has already been specified.

Resolution:

Retry the operation ensuring that only one occurrence of the parameter exists.

Parent topic: Messages from FS001-S to FS050-W


FS007-S Invalid parameter combination.

This can be for the following reasons:

  • Not enough parameters have been specified in order for the operation to be processed. For example, you have tried to start the Fileshare Server without giving a server name.
  • The parameters specified do not indicate a valid operation that can be carried out. For example, the combination /s and /r is invalid as the first implies that the Fileshare Server is to start with the server name indicated, whereas the second parameter indicates that a Rollforward Recovery is to be performed.

Resolution:

Ensure that the parameters specified are correct and retry the operation.

Parent topic: Messages from FS001-S to FS050-W


FS008-S Communications Initialization Failure.

Resolution:

Ensure that the required CCI module(s) required for the protocol you are using is/are available. Use the CCI demo program supplied with the product to ensure that the CCI module required can be loaded and initialized.

Ensure that the network software on the machine is installed, configured and operational.

Parent topic: Messages from FS001-S to FS050-W


FS009-S The required communications module cannot be found.

Resolution:

Ensure that the CCI (and required network modules) are installed correctly on the machine.

Try out the CCI demo program supplied with the product with the same CCI protocols before trying the start the Fileshare Server again.

Parent topic: Messages from FS001-S to FS050-W


FS011-W Communications send failure.

See the message FS148-I for more information.

Resolution:

No user action is possible. However, if the error persists, this could indicate that there is a possible problem with the network or that the network has a high volume of traffic.

Parent topic: Messages from FS001-S to FS050-W
Related information
FS148-I


FS012-W Communications disconnect failure.

  • It receives a request from an unknown Fileshare Client
  • The CCI protocol indicated that the Fileshare Client application terminated abnormally

Resolution:

If the error persists, there could be a problem with the network that is being used. Also, ensure that users are closing down Fileshare Client applications correctly and not turning the workstation machines off or using utilities to terminate the Fileshare applications abnormally (for example kill on UNIX).

Parent topic: Messages from FS001-S to FS050-W


FS013-W Communications receive error.

See the message FS148-I for more information about the cause of the error.

Resolution:

No direct action by the user is possible. However, if the error persists, there could be a problem with the network that is being used or there could be a high volume of network traffic.

Parent topic: Messages from FS001-S to FS050-W
Related information
FS148-I


FS014-W Communications data length not as expected.

This error should not occur in normal circumstances. If found, it implies that there is a problem with the communications system or that the requester service has not been started when using the NETBIOS protocol.

The Fileshare Server has ignored the data sent from the Fileshare Client.

See also the messages FS151-I and FS082-S for additional information.

Resolution:

If using the NETBIOS protocol, ensure that it is installed correctly, configured and operational.

It is highly likely that the Fileshare Client appears to have stopped because the Fileshare Server has not sent back any reply. Depending on the CCI protocol being used, a time-out occurs in approximately two minutes and a 9/124 status is returned to the application program.

Parent topic: Messages from FS001-S to FS050-W
Related information
FS151-I
FS082-S


FS015-W Request from unknown user - request rejected.

The Fileshare Server has ignored the information that it has received and has returned a 9/125 error status to the Fileshare Client that sent the request.

With some CCI protocols, the session associated with this request is disconnected. See the message FS238-I for additional information.

Resolution:

No action is required.

Parent topic: Messages from FS001-S to FS050-W
Related information
FS238-I


FS016-S The parameter "text " is invalid.

Resolution:

Change the parameter specified to a valid option.

Parent topic: Messages from FS001-S to FS050-W


FS017-S Unable to open the file : filename.

The file may be open already or marked as read-only.

Resolution:

Ensure that the path and filename are valid and that the Fileshare Server has read and write access to the directory.

Parent topic: Messages from FS001-S to FS050-W


FS018-S Log file corrupt - unrecognizable record in file.

This error indicates that the marker in the record header is not recognized which implies that the log file has become corrupted in some way.

This error can occur if the last record of the recovery log file was not written successfully because of a system crash. The Recovery Utility will have processed all of the records up to the point of failure.

Resolution:

Ensure that the correct log file is available to the Fileshare Rollforward Recovery Utility.

Parent topic: Messages from FS001-S to FS050-W


FS019-S Log file corrupt - can't read header.

Resolution:

Ensure that the correct log file is available to the Fileshare Rollforward Recovery Utility. If the correct log file is in place, then the file is corrupt and cannot be used in a rollforward recovery process.

Parent topic: Messages from FS001-S to FS050-W


FS020-S The log file does not match the database sequence numbers - recovery aborted.

This error indicates one of the following:

  • The sequence number in the file headers is greater than that in the log file. This indicates that updates have been applied to the files, without the updates being logged in the log file. Because the log file does not contain all of the updates, it is not possible to perform a rollforward recovery. This also indicates that the rollforward recovery is trying to use the wrong versions of the files.
  • The first sequence number in the recovery log file is larger than the sequence number in the file headers. This indicates that updates have been written to the log file but they have not been applied to the data files. It is not possible to apply the updates from the recovery log file because the versions of the data files and the recovery log file do not match.

Resolution:

Ensure that the correct versions of the data and rollforward recovery log file are being used.

See the section Database Sequence Numbering in the chapter Database Integrity for more information.

Parent topic: Messages from FS001-S to FS050-W
Related information
Database Sequence Numbering


FS021-S There is no log filename specified in the database reference file.

Resolution:

No action is required.

Parent topic: Messages from FS001-S to FS050-W


FS022-S The log filename given cannot be found in the database reference file.

Resolution:

Specify the correct name of the log file when trying to erase the entry from the database reference file.

Parent topic: Messages from FS001-S to FS050-W


FS024-S Failed to open log file : filename.

  • The Fileshare Server does not have read/write access to the log file and/or the directory where the log file resides.
  • The filename specified for the log file is invalid. The filename may not be a valid filename for the operating system on which the Fileshare Server resides or the path specified in the log filename specifies a drive/directory that does not exist.
  • The log file is in use by another process, preventing the Fileshare Server from obtaining exclusive access to the log file.
  • The operating system or the COBOL run-time system is unable to allocate a file handle to the log file.
Parent topic: Messages from FS001-S to FS050-W


FS025-S Write failure to the log file, Fileshare Server is closing down.

The cause of the failure should be investigated. Possible causes include the disk is full, a disk error or, if logging to a remote drive, a network error occurred.

Resolution:

We advise you to have the recovery log file local to where the Fileshare Server is running so that the chances of network errors occurring while writing to the log file are reduced. Also, the Fileshare Server cannot force the operating system to flush records to disk if the log file is not on the local machine.

Parent topic: Messages from FS001-S to FS050-W


FS026-W Failed to close the log file.

Possible causes are that the disk is full or, if logging to a remote drive, a network error occurred.

We advise you to have the recovery log file local to where the Fileshare Server is running so that the chances of network errors occurring while writing to the log file are reduced.

The cause of the failure should be investigated.

Resolution:

It should be possible to use this recovery log file in a rollforward recovery operation as the Fileshare Server has written all of the required information to the file.

Parent topic: Messages from FS001-S to FS050-W


FS027-S A second log file parameter has been found.

Resolution:

Ensure that the correct database reference file is used and that only one recovery log filename is specified in the database reference file.

Only use the Database Reference File Maintenance Utility to change the contents of the database reference file. In this situation however, it may be possible to remove the duplicate entry using a normal text editor. Alternatively the current database reference file can be discarded and a new one created using the Database Reference File Maintenance Utility.

Parent topic: Messages from FS001-S to FS050-W


FS028-W The log file shows the last session was not shut down successfully.

If the Fileshare Server is starting up, the log file is backed up and a new log file created. If you have specified a backup directory in the database reference file, the Rollforward Recovery Utility is invoked automatically.

If a rollforward recovery is being performed, recovery proceeds up to the last full record in the recovery log file (any incomplete transactions are rolled back).

Resolution:

No action is required

Parent topic: Messages from FS001-S to FS050-W


FS029-S The log filename is already specified in the database reference file.

Resolution:

Remove the current log filename from the database reference file using the Database Reference File Maintenance Utility and then add the name of the new log file using the same utility.

Parent topic: Messages from FS001-S to FS050-W


FS030-S Insufficient disk space to continue logging to log file.

The Fileshare Server will close the current recovery log file and wait for it to be backed up before continuing.

Resolution:

Manually back up the current log file and then delete the file. This releases disk space and enables the Fileshare Server to continue logging with a new logfile.

Parent topic: Messages from FS001-S to FS050-W


FS031-I Record lock time-out failure on user : user.

This record lock time-out has caused any transactions that this user has outstanding to be automatically rolled back and all record locks held by this user have been released. See the section Automatic Record Lock Timeout in the chapter Database Integrity for more information.

You can specify the record lock time-out period using the /t option when you configure the Fileshare Server.

On the next I/O operation, a status of 9/125 will be returned to the Fileshare Client application that held the lock.

Resolution:

No action is required, however the time-out period can be changed or disabled if required.

Parent topic: Messages from FS001-S to FS050-W
Related information
Automatic Record Lock Timeout


FS034-S A filename or log file parameter must be specified.

Resolution:

Ensure that when invoking the Database Reference File Maintenance Utility, the option /f (filename), /l (log filename), /fs (file string) or /backup (log file backup directory) is used to specify which action should be taken

Parent topic: Messages from FS001-S to FS050-W


FS035-S A database reference file must be specified.

Resolution:

Include the /d option when invoking the Database Reference File Maintenance Utility to provide the name of the database reference file to use

Parent topic: Messages from FS001-S to FS050-W


FS037-I The file filename does not have a file header record. Sequence checking is switched off for this file.

The Fileshare Server will not apply sequence number checking to this file.

Resolution:

The programs accessing the files should be changed so that they define the files as variable length record files.

It is not possible to have sequence number checking on line sequential files.

If sequence number checking is required, the file must contain a file header. Fixed length indexed, sequential and relative files should be converted to variable length record format.

Alternatively, if sequence number checking is not required for this file, this message can be avoided by explicitly turning sequence number checking off using the /o s option in this file's entry in the database reference file. See the section Database Reference File Maintenance in the chapter Database Integrity for more details.

Parent topic: Messages from FS001-S to FS050-W
Related information
Database Reference File Maintenance


FS038-S A matching sequence number not found in filename.

The named file is listed in the database reference file and sequence number checking is active for the file. This message indicates that an incorrect version of the file is being used. The Fileshare Server does not start until this problem is rectified.

Resolution:

Ensure that the correct version of the file is available to the Fileshare Server and that if sequence numbering is used, all updates performed to the file are done via the Fileshare system. See the section Database Sequence Numbering in the chapter Database Integrity for more information.

Parent topic: Messages from FS001-S to FS050-W
Related information
Database Sequence Numbering


FS039-S Improperly closed file - filename.

Resolution:

The file is corrupt and a backup should be put in place and recovery performed using the Rollforward Recovery Utility. See the section Rollforward Recovery Utility in the chapter Database Integrity for details. If you have specified a backup directory in the database reference file, the recovery will be performed automatically.

If updates to the file have not been logged then the file should be rebuilt using the REBUILD utility.

Parent topic: Messages from FS001-S to FS050-W
Related information
Rollforward Recovery Utility


FS040-S Unable to read the file header record in the file filename.

Resolution:

If sequence number checking is not required for this file then this feature should be omitted for this file using the /o s option in the database reference file.

All files that can have sequence number checking are at least 128 bytes in length as this is the size of a file header (which is required for sequence number checking to be performed).

Parent topic: Messages from FS001-S to FS050-W


FS041-S Unable to update the sequence number in the file filename.

Resolution:

This error is very rare and implies a disk I/O error (or a network error if the file is not on the local Fileshare Server machine).

Parent topic: Messages from FS001-S to FS050-W


FS042-S Unable to open the database reference file: filename.

Resolution:

Ensure that the path and filename are correct and that the Fileshare Server has full read and write access to the file specified.

Also ensure that the Fileshare Server can gain exclusive access to the database reference file and that another process does not have the file open.

Parent topic: Messages from FS001-S to FS050-W


FS043-S The database reference file contains an invalid entry.

Resolution:

Ensure that only the Database Reference File Maintenance Utility is used to change the contents of the database reference file.

Alternatively, discard the current database reference file and re-create the contents of the file using the Database Reference File Maintenance Utility.

Parent topic: Messages from FS001-S to FS050-W


FS044-S Error reading the database reference file.

Resolution:

Try the operation again. If the problem persists, the database reference file is probably corrupt - the current file should be discarded and a new database reference file created using the Database Reference File Maintenance Utility

Parent topic: Messages from FS001-S to FS050-W


FS045-W Duplicate filename specified in the database reference file.

Resolution:

Recreate the database reference file ensuring that each filename appears in the file only once.

Parent topic: Messages from FS001-S to FS050-W


FS050-W A log file is not specified in the database reference file.

Resolution:

If rollforward recovery logging is required, add an entry to the database reference file specifying a rollforward recovery log filename. See the section Database Reference File Maintenance in the chapter Database Integrity for more details.

Parent topic: Messages from FS001-S to FS050-W
Related information
Database Reference File Maintenance


Messages from FS051-W to FS099-W

  • FS051-W Failure to allocate a larger buffer, the I-O request failed.
    When using compression on the communication buffers, this message indicates that there was not enough memory available to the Fileshare Server to enable it to decompress the buffer. The I/O request has failed and the Fileshare Client was returned a 9/105 (out of memory) error.
  • FS052-S Failure to allocate required memory. The Fileshare Server is closing down.
    You see this message when the Fileshare Server is initializing and cannot allocate enough memory for the required internal tables
  • FS055-S The parameter "text " specifies a configuration file that does not exist.
    The Fileshare Server is unable to locate or open the configuration file indicated
  • FS056-S The parameter "text " specifies a data compression value that is not within the range 0-255.
    You have tried to add an entry to the database reference file. This entry specifies a value for the data compression outside of the permitted limits. The data compression option must specify a value within the range 0 through 255. To use the routine CBLDC001 as the compression method on records in the file, specify a compression value of 1.
  • FS057-S The parameter "text " specifies a key compression value that is not within the range 0-7.
    You have tried to add an entry to the database reference file which specifies a value for the key compression outside of the permitted limits.
  • FS058-S Failure to allocate memory for the decompression of the log file.
    The Rollforward Recovery Utility has been invoked but is unable to allocate the required memory so that it can process the recovery log file. This error is displayed during the initialization of the recovery process and indicates a shortage of available memory.
  • FS059-S Failure to allocate the memory required for processing the database reference file.
    When reading in a database reference file (either when the Fileshare Server or the Rollforward Recovery Utility is starting) this message indicates that the Fileshare Server was not able to allocate the required memory to be able to process all of the information in the database reference file
  • FS062-S Failure creating the password file filename.
    The Fileshare Server was unable to create the password file indicated
  • FS063-S Failure opening the password file filename.
    The Fileshare Server was unable to open the password file indicated
  • FS064-S Failure reading the password file filename.
    The Fileshare Server encountered an error reading the information from the password file. This implies that an I/O error occurred, the password file has become corrupted in some way or that a network error occurred if the password file is located on a remote machine.
  • FS065-S The password file is not of a recognized format.
    The first record in the password file is a special record which indicates to the Fileshare Server that the file is a password file. This record also contains information regarding the version of the password file being used.
  • FS066-S The specified user name already exists in the password file.
    You see this message when using the Password File Maintenance Utility and you have tried to add a user name to the password file when the user name already exists in the password file
  • FS068-I The password file is now empty and has been deleted.
    You see this message when you have used /e (erase) option with the Password File Maintenance Utility to remove the last entry from the password file. As the password file is now empty, it has been deleted. If a new password file is required it is created automatically when you add an entry using the Password File Maintenance Utility.
  • FS069-S The specified entry could not be found in the password file.
    This message indicates that you have used /e (erase) option with the Password File Maintenance Utility to remove an entry, but the entry specified does not exist in the password file.
  • FS070-S Failure writing to the password file.
    The Password Maintenance Utility encountered an error when it tried to write information to the password file. This implies that an I/O error occurred (possibly a full disk) or a network error was encountered (if the password file is on a remote machine). The integrity of the password file cannot be guaranteed.
  • FS071-W Unable to load the module FHXSCOMP to decompress the data area.
    This message indicates that the Fileshare Server has received a compressed communications buffer. However, it is unable to load the decompression module FHXSCOMP in order to perform the necessary decompression. There may not be enough memory to load the module or the module may not be found.
  • FS072-S The parameter "text " contains a wild card which is not allowed with this parameter.
    A parameter containing a wild card symbol was specified when invoking the Database Reference File Maintenance Utility but the parameter does not support wild cards.
  • FS073-S Failure to allocate memory to process the password file.
    When reading in a password file (when either the Fileshare Server or the Password File Maintenance Utility is starting), this message indicates that the Fileshare Server was not able to allocate the required memory to be able to process all of the information in the password file.
  • FS074-S The Fileshare Server (NLM) failed to log on to NetWare with the login id specified.
    NLM: This message is only applicable to the Fileshare NLM.
  • FS075-W Unable to load the module FSSECLOG - LOGON has been denied.
    This message indicates that the Fileshare Server failed to call the module FSSECLOG because:
  • FS076-W Unable to load the module FSSECOPN - OPEN has been denied.
    This message indicates that the Fileshare Server failed to call the module FSSECLOG because:
  • FS077-S A Fileshare Server of the same name has already been defined - the Fileshare Server is closing down.
    When the Fileshare Server starts up, it registers its name on the network so that Fileshare Clients can connect to it. This message indicates that the Fileshare Server is trying to register with a name that is already in use by another Fileshare Server on the network.
  • FS078-S No password file has been specified for the use of background mode.
  • FS079-S A supervisor password entry must exist for the use of background mode.
  • FS080-S No password file has been specified for the use of the synchronous communications mode.
    You have tried to start the Fileshare Server using synchronous communications (as opposed to asynchronous communications which is the default). To enable the use of synchronous communications, you must specify a password file which contains a supervisor-ID of FSVIEW. This enables the Fileshare Server to be closed down remotely using FSVIEW or FSMgr. This is necessary because in this communications mode, the Fileshare Server only checks for keyboard input very occasionally.
  • FS081-S A supervisor password must be specified in the password file for the synchronous communications mode.
    You have tried to start the Fileshare Server using synchronous communications (as opposed to asynchronous communications which is the default). To enable the use of synchronous communications, you must specify a password file which contains a user-ID of FSVIEW. This enables the Fileshare Server to be closed down remotely using FSVIEW or FSMGR. This is necessary because in this communications mode, the Fileshare Server only checks for keyboard input very occasionally.
  • FS082-S The Netbios communications protocol is not responding. Ensure the requester software is loaded and functional.
    You have tried to start the Fileshare Server using the Netbios protocol (CCINETB) but the required network software is not loaded or is not operational. The Fileshare Server is trying to use the NETBIOS software but is receiving invalid data.
  • FS083-S Incompatible CCIIPX.NLM version.
    The Fileshare NLM Server has detected that the version of cciipx.nlm being used is not a compatible version. You are probably trying to use an old version of the CCIIPX NLM with this version of the Fileshare NLM.
  • FS084-I Fileshare Server is starting.
    This message indicates that the Fileshare Server is in the process of initializing. The configuration, database reference and password files (if specified) are being processed and the communications software is being loaded and initialized.
  • FS085-I Fileshare Server is active.
    This message indicates that the Fileshare Server has completed its initialization processing and is now ready to accept incoming requests from Fileshare Clients. At this stage all of the configuration, database reference and password files have been processed and the communications software has been successfully initialized and is operational.
  • FS086-I Fileshare Server is closing down.
    This message indicates that the Fileshare Server has started the process of closing down and will shortly terminate. This can be invoked by the following:
  • FS087-I Fileshare Server has closed down.
    This message indicates that the Fileshare Server has completed all of its termination processing. All communications have stopped, all files closed, all transactions rolled back and any rollforward recovery log file shut. The Fileshare Server can now be restarted when necessary.
  • FS089-I Database Reference File Maintenance Utility.
    The Database Reference File Maintenance Utility has been invoked using the parameters specified on the command line or in the Fileshare Server configuration file. The Database Reference File Maintenance Utility will try to process the remaining parameters specified as options to this utility.
  • FS090-I Database Reference File installation completed successfully.
    The Database Reference File Maintenance Utility has been invoked successfully and the required change made to the database reference file has been made.
  • FS091-I Rollforward Recovery Utility
    The Rollforward Recovery Utility has been invoked using the parameters specified on the command line or in the Fileshare Server configuration file.
  • FS092-I Rollforward Recovery has completed.
    The recovery process is now complete: the files contain the updates recorded in the log file when the Fileshare Server was in use.
  • FS094-I Password File Maintenance Utility.
    The Password File Maintenance Utility has been invoked using the parameters specified on the command line or in the Fileshare Server configuration file.
  • FS096-I Password File installation has completed.
    The Password File Maintenance Utility has successfully updated the password file using the options specified when the Password File Maintenance Utility was invoked.
  • FS097-I Are you sure that you wish to close down the Fileshare Server ? (Y/N)
    You have used the Esc key sequence to close down the Fileshare Server. This message is an additional prompt to avoid closing down the Fileshare Server in error.
  • FS099-W File I/O status was not as expected. Returned status: status Expected status: status Action code: text File: filename.
    This error occurs when a file is being recovered using the Rollforward Recovery Utility. When the log file is written during the normal operation of the Fileshare Server, a record is made in the log file of the status of each I/O operation performed. At the time of recovery, the status returned during the recovery process is compared with that stored in the recovery log file.
Parent topic: Fileshare Server Messages
Related information
Messages from FS001-S to FS050-W
Messages from FS101-I to FS149-I
Messages from FS151-I to FS200-W
Messages from FS201-S to FS252-S


FS051-W Failure to allocate a larger buffer, the I-O request failed.

Resolution:

Free some memory on the machine where the Fileshare Server is running so that it is able to increase the size of its decompression buffers.

Alternatively, reconfigure the Fileshare System so that compression on the communications buffers is not used.

Parent topic: Messages from FS051-W to FS099-W


FS052-S Failure to allocate required memory. The Fileshare Server is closing down.

Resolution:

Free some memory on the machine where the Fileshare Server is running so that more memory is available to the Fileshare Server.

Parent topic: Messages from FS051-W to FS099-W


FS055-S The parameter "text " specifies a configuration file that does not exist.

Resolution:

Ensure that the path and filename are correct and that the Fileshare Server has read access to the file. Also ensure that no other process currently has the file open as the Fileshare Server requires exclusive access to the configuration file.

Parent topic: Messages from FS051-W to FS099-W


FS056-S The parameter "text " specifies a data compression value that is not within the range 0-255.

The specification of compression of records only takes effect when the file is created. Specifying data compression on a file that already exists and contains uncompressed records has no effect.

Resolution:

Specify a data compression value of 0 through 255

See the section Database Reference File Maintenance in the chapter Database Integrity for more information on the /k parameter and valid options.

Parent topic: Messages from FS051-W to FS099-W
Related information
Database Reference File Maintenance


FS057-S The parameter "text " specifies a key compression value that is not within the range 0-7.

The key compression option must specify a value within the range 0 through 7.

Specifying key compression only has an effect at the time that the file is created. Specifying key compression on a file that already exists, but does not have key compression, has no effect.

Resolution:

Specify a key compression value of 0 through 7.

See the section Database Reference File Maintenance in the chapter Database Integrity for more information on the /k parameter and valid options.

Parent topic: Messages from FS051-W to FS099-W
Related information
Database Reference File Maintenance


FS058-S Failure to allocate memory for the decompression of the log file.

Resolution:

Increase the amount of available memory by reducing the number of processes and/or applications running on the same machine where you are running the Rollforward Recovery. Then try to run the Rollforward Recovery Utility again.

Parent topic: Messages from FS051-W to FS099-W


FS059-S Failure to allocate the memory required for processing the database reference file.

Resolution:

Try to make more memory available to the Fileshare Server by reducing the number of processes or applications that are running on the same machine. If this is not possible, reduce the amount of information that is contained in the database reference file.

Parent topic: Messages from FS051-W to FS099-W


FS062-S Failure creating the password file filename.

Resolution:

Ensure that the path and filename are valid and that the specified file is not already open by another process. The Fileshare Server requires read and write permission to the password file and tries to create the file with exclusive access.

Parent topic: Messages from FS051-W to FS099-W


FS063-S Failure opening the password file filename.

Resolution:

Ensure that the path and filename are valid and that the specified file is not already open by another process. The Fileshare Server requires read and write permission to the password file and tries to open the file with exclusive access.

Parent topic: Messages from FS051-W to FS099-W


FS064-S Failure reading the password file filename.

Resolution:

Retry the operation. If the message persists, the password file may be corrupt and should be discarded. A new password file should then be created using the Password File Maintenance Utility.

Parent topic: Messages from FS051-W to FS099-W


FS065-S The password file is not of a recognized format.

This message indicates that the Fileshare Server has not recognized this record in the file as being that identifying a password file. Alternatively the password file has become corrupt.

Resolution:

Check that the path and filename of the password file specified are correct.

If they are correct then the current password file should be discarded and a new one created using the Password File Maintenance Utility.

Parent topic: Messages from FS051-W to FS099-W


FS066-S The specified user name already exists in the password file.

Resolution:

To update a user entry that already exists in the password file, first erase the entry and then add the new entry to the file. See the section Password File Maintenance in the chapter Security for more details.

Parent topic: Messages from FS051-W to FS099-W
Related information
Password File Maintenance


FS068-I The password file is now empty and has been deleted.

Resolution:

No action is required.

Parent topic: Messages from FS051-W to FS099-W


FS069-S The specified entry could not be found in the password file.

Resolution:

Ensure that the user name and password are correct (that is, exactly those which were specified for the entry to be erased when the entry was first added to the password file). If the user-ID or password are no longer known, you must create a new password file using the Password File Maintenance Utility.

Parent topic: Messages from FS051-W to FS099-W


FS070-S Failure writing to the password file.

Resolution:

Restore the password file from a backup and try to add the new entry again. If no backup is available, discard the current password file and create a new one using the Password File Maintenance Utility.

Ensure that there is enough disk space available on the drive where the password file resides.

Parent topic: Messages from FS051-W to FS099-W


FS071-W Unable to load the module FHXSCOMP to decompress the data area.

Alternatively there may be an insufficient number of file handles available to enable the operating system or run-time system to load the module.

The request received from the Fileshare Client has been discarded.

Resolution:

Ensure that the system module FHXSCOMP is available on your system. Also ensure that there is enough memory available for the module to be loaded and file handles are available to enable the run-time or operating system to load the file.

Parent topic: Messages from FS051-W to FS099-W


FS072-S The parameter "text " contains a wild card which is not allowed with this parameter.

Wild cards are only permitted on database entries defining an alternate program.

See the /ap option in the section Database Reference File Maintenance in the chapter Database Integrity for more details.

Resolution:

Do not specify a wild card symbol for this parameter.

A full path or filename should be given.

Parent topic: Messages from FS051-W to FS099-W
Related information
Database Reference File Maintenance


FS073-S Failure to allocate memory to process the password file.

Resolution:

Try to make more memory available to the Fileshare Server by reducing the number of processes or applications that are running on the same machine. Alternatively, reduce the amount of information that is contained in the password file.

Parent topic: Messages from FS051-W to FS099-W


FS074-S The Fileshare Server (NLM) failed to log on to NetWare with the login id specified.

You see this message when using the /nu option to force the Fileshare Server to log onto NetWare with the specified user-ID. However, the Fileshare NLM Server encountered an error when trying to connect with the user-ID specified. This implies that there is no user account with the user-ID set up on the NetWare server or that you entered an incorrect password when prompted to do so.

Resolution:

Check that the user-ID is correct and that a user account for that ID is defined on the NetWare operating system. Also check that the correct password for this user-ID was entered when prompted.

Parent topic: Messages from FS051-W to FS099-W


FS075-W Unable to load the module FSSECLOG - LOGON has been denied.

  • FSSECLOG is not available
  • There is insufficient memory available to load FSSECLOG
  • There may be an insufficient number of file handles available to enable the operating system or run-timesystem to load FSSECLOG

FSSECLOG is required to validate logon requests to the Fileshare Server by Fileshare Clients. Because one possible cause of this error is that the FSSECLOG module has been removed on purpose, the Fileshare Server does not permit the logon to proceed in this situation.

The Fileshare Client application program has received a 9/037 error status.

Resolution:

Ensure that the module FSSECLOG is available to the Fileshare Server (this can be the FSSECLOG module supplied with the Fileshare system or a user-written one). If the module is available, try making more memory available by reducing the number of other processes or applications running on the machine and ensure that there are enough free file handles available to enable the module to be loaded.

See the chapter Security for more information about the FSSECLOG module.

Parent topic: Messages from FS051-W to FS099-W
Related information
Security


FS076-W Unable to load the module FSSECOPN - OPEN has been denied.

  • FSSECOPN is not available
  • There is insufficient memory available to load FSSECOPN
  • There may be an insufficient number of file handles available to enable the operating system or run-timesystem to load FSSECOPN

FSSECOPN is required to validate open requests to the Fileshare Server by Fileshare Clients. Because one possible cause of this error is that the FSSECOPN module has been removed on purpose, the Fileshare Server does not permit the open to proceed in this situation.

The Fileshare Client application program has received a 9/037 error status.

Resolution:

Ensure that the module FSSECOPN is available to the Fileshare Server (this can be the FSSECOPN module supplied with the Fileshare system or a user-written one). If the module is available, try making more memory available by reducing the number of other processes or applications running on the machine and ensure that there are enough free file handles available to enable the module to be loaded.

See the chapter Security for more information about the FSSECOPN module.

Parent topic: Messages from FS051-W to FS099-W
Related information
Security


FS077-S A Fileshare Server of the same name has already been defined - the Fileshare Server is closing down.

Alternatively, this message can indicate that a Fileshare Server that was using this name terminated abnormally and did not de-register its name from the network.

Resolution:

Ensure that the Fileshare Server name is unique for this server. This is the name that the Fileshare Server is configured to register on the network. If a Fileshare Server that was using this name terminated abnormally, it may be necessary to re-initialize the network software on the machine where that Fileshare Server was running to ensure that its name is no longer registered (what action is required in this situation depends on the communications protocol that is being used).

Parent topic: Messages from FS051-W to FS099-W


FS078-S No password file has been specified for the use of background mode.

UNIX:

This message is applicable to Fileshare Servers on UNIX only.

It is possible to configure the Fileshare Server to run as a daemon process on UNIX so that information is neither accepted from the keyboard nor displayed on the screen. When configuring the Fileshare Server to run in this mode, a password file must be used which should contain a FSVIEW (supervisor) user-ID and password. This enables the Fileshare Server to be closed down remotely using FSView, FSMgr or FSCLOSE.

This message indicates that you have tried to run the Fileshare Server in background mode but you have not specified a password file.

Resolution:

Create a password file using the Password File Maintenance Utility containing a user-ID of FSVIEW and a password. Then specify this password file (using the -pf option) in the Fileshare Server configuration file.

See the section Password File Maintenance in the chapter Security for more information.

Parent topic: Messages from FS051-W to FS099-W
Related information
Password File Maintenance


FS079-S A supervisor password entry must exist for the use of background mode.

UNIX:

This message is applicable to Fileshare Servers on UNIX only.

It is possible to configure the Fileshare Server to run as a daemon process in the background on UNIX where no information is accepted from the keyboard nor displayed on the screen. When configuring the Fileshare Server to run in this mode, a password file must be used which should contain an FSVIEW (supervisor) user-ID and password. This enables the Fileshare Server to be closed down remotely using FSMgr, FSView or FSCLOSE.

This message indicates that you have tried to run the Fileshare Server in background mode but the password file that you specified does not contain an FSVIEW (supervisor) user-ID or password.

Resolution:

Add a user-ID of FSVIEW and password to the password file specified using the Password File Maintenance Utility.

See the section Password File Maintenance in the chapter Security for more information.

Parent topic: Messages from FS051-W to FS099-W
Related information
Password File Maintenance


FS080-S No password file has been specified for the use of the synchronous communications mode.

Resolution:

When starting the Fileshare Server, use the /pf option in the Fileshare Server configuration file to specify the name of a password file containing a user-ID of FSVIEW. See the sections Password System and Password File Maintenance in the chapter Security for more information.

Parent topic: Messages from FS051-W to FS099-W
Related information
Password System
Password File Maintenance


FS081-S A supervisor password must be specified in the password file for the synchronous communications mode.

This message indicates that a password file has been specified, however, there is no (supervisor) user-ID of FSVIEW in the password file.

Resolution:

Add a user-ID of FSVIEW and a password to the password file using the Password File Maintenance Utility and try the operation again. See the section Password File Maintenance in the chapter Security for more information.

Parent topic: Messages from FS051-W to FS099-W
Related information
Password File Maintenance


FS082-S The Netbios communications protocol is not responding. Ensure the requester software is loaded and functional.

Resolution:

Ensure that the NETBIOS software has been loaded, is functioning and is configured correctly on the machine where you are trying to start the Fileshare Server. Try to start the Fileshare Server again. Alternatively, use another communications protocol.

See the message FS014 for further information.

Parent topic: Messages from FS051-W to FS099-W
Related information
FS014


FS083-S Incompatible CCIIPX.NLM version.

Resolution:

Ensure that the version of cciipx.nlm supplied with the Fileshare Server NLM is the one on the system and that this version is loaded in preference to any earlier version (meaning that this version is on the search path before any older version of the CCIIPX NLM)

Parent topic: Messages from FS051-W to FS099-W


FS084-I Fileshare Server is starting.

Resolution:

No action is required.

Parent topic: Messages from FS051-W to FS099-W


FS085-I Fileshare Server is active.

Fileshare Client applications can now be started and communicate with this Fileshare Server.

Resolution:

No action is required.

Parent topic: Messages from FS051-W to FS099-W


FS086-I Fileshare Server is closing down.

  • The Fileshare Server encountered an error when starting up, for example an error was found in a configuration, database reference or password file. Alternatively the communications support could not be started.
  • The user has requested to shut down the Fileshare Server (either by the Esc key sequence or a remote request from FSView or FSMgr)
  • The Fileshare Server has encountered an unrecoverable error during its operation. For example, the remaining disk space where the rollforward recovery log file resides is below the acceptable limits for logging to continue.
  • The Fileshare Server process was terminated by an event external to the Fileshare Server(for example a kill command on UNIX)

The Fileshare Server is closing all outstanding connections with Fileshare Clients, rolling back any outstanding transactions, closing all open files and shutting down the communication support.

Depending on the communications protocol that is in use, the Fileshare Client applications may appear to suspend if they are still trying to send requests to this Fileshare Server.

Resolution:

No action is required

Parent topic: Messages from FS051-W to FS099-W


FS087-I Fileshare Server has closed down.

Resolution:

No action is required.

Parent topic: Messages from FS051-W to FS099-W


FS089-I Database Reference File Maintenance Utility.

If the Database Reference File Maintenance Utility should not have been invoked, check the command line to ensure that neither the /d option nor any other valid Database Reference File Maintenance option has been specified. See the section Database Reference File Maintenance in the chapter Database Integrity for more details.

Resolution:

No action is required.

Parent topic: Messages from FS051-W to FS099-W
Related information
Database Reference File Maintenance


FS090-I Database Reference File installation completed successfully.

The database reference file specified now contains the change required.

Resolution:

No action is required.

Parent topic: Messages from FS051-W to FS099-W


FS091-I Rollforward Recovery Utility

If the Rollforward Recovery Utility should not have been invoked, check the command line to ensure that neither the /r option nor any other valid Rollforward Recovery Utility option has been specified. See the section Rollforward Recovery Utility in the chapter Database Integrity for more details.

Resolution:

No action is required.

Parent topic: Messages from FS051-W to FS099-W
Related information
Rollforward Recovery Utility


FS092-I Rollforward Recovery has completed.

If the updates have been applied successfully, you should back up the recovered files and use a new log file when you restart the Fileshare Server. This ensures that the new recovery log file is in step with the current data files.

Resolution:

No action is required.

Parent topic: Messages from FS051-W to FS099-W


FS094-I Password File Maintenance Utility.

If the Password File Maintenance Utility should not have been invoked, check the command line to ensure that the /pf option has been used correctly and that no other option specific to the Password File Maintenance Utility has been used. See the section Password File Maintenance in the chapter Security for more details.

Resolution:

No action is required.

Parent topic: Messages from FS051-W to FS099-W
Related information
Password File Maintenance


FS096-I Password File installation has completed.

Resolution:

No action is required.

Parent topic: Messages from FS051-W to FS099-W


FS097-I Are you sure that you wish to close down the Fileshare Server ? (Y/N)

The Fileshare Server does not accept input from Fileshare Clients whilst waiting for the response to this prompt. Consequently, you should respond quickly to this prompt.

Resolution:

Responding Y to this prompt causes the Fileshare Server to start its termination processing. If there are any files open or users logged onto this Fileshare Server, an additional prompt and confirmation are displayed. When the Fileshare Server shuts down, it rolls back all outstanding transactions, closes all open files, logs off all users and closes down the communication support modules.

If you give any reponse other than Y, the Fileshare Server continues operating as normal.

Parent topic: Messages from FS051-W to FS099-W


FS099-W File I/O status was not as expected. Returned status: status Expected status: status Action code: text File: filename.

This message indicates that the status returned during the recovery process was not the same as that when the operation was performed during the normal Fileshare Server processing when the log file was written.

The Returned status is the status that the Rollforward Recovery Utility encountered when trying to apply the updates from the recovery log file to the data files.

The Expected Status is the status that was returned when this operation was originally performed by the Fileshare Server (and when the log file was being written).

The Action code is the operation code that is being performed.

The name of the file is included in the message.

This error indicates one of the following:

  • The files to which the recovery log file is being applied are not the ones that were in use at the time that the Fileshare Server was started and the log file was created
  • The recovery log file or the files being rolled forward are corrupt
  • A situation has arisen which did not occur when the rollforward recovery file was created during normal Fileshare Server operation

Resolution:

Note the expected and returned error codes and take appropriate action. Also ensure that the correct version of the data files are in place and try to re-run the rollforward recovery.

Parent topic: Messages from FS051-W to FS099-W


Messages from FS101-I to FS149-I

  • FS101-I text -- parameter has been accepted.
    The indicated parameter (and value if required) has been accepted by the Fileshare Server
  • FS103-I The log filename has been added to the database reference file.
    The Database Reference File Maintenance Utility has been invoked to add a recovery log filename to the database reference file and the operation has completed successfully. The database reference file now contains the name of the recovery log file specified.
  • FS104-I The log file cannot be found, creating a new recovery log file.
    The Fileshare Server on starting up has processed the database reference file and determined the name of the rollforward recovery log file to use. The recovery log file does not exist and so the Fileshare Server has created a new one.
  • FS105-W The disk free space for the log file is below acceptable limits.
    The Fileshare Server has detected that the amount of disk space remaining on the drive where the recovery log file is being written is below a certain level.
  • FS106-I filename - added to database reference file.
    This message indicates that the Database Reference File Maintenance Utility has successfully added the filename indicated to the database reference file.
  • FS107-I filename - removed from the database reference file.
    This message indicates that the Database Reference File Maintenance Utility has successfully removed the filename indicated from the database reference file.
  • FS108-I Processing the files specified in the database reference file.
    This message indicates that the Fileshare Server has opened the database reference file and is now scanning through it, processing each filename listed. The type of processing that it performs depends on the utility being used:
  • FS109-W The file filename does not exist.
    You see this message when the filenames listed in the database reference file are being processed and indicates that the file indicated cannot be located physically on disk.
  • FS110-I filename - OK.
    The Fileshare system has successfully processed the entry indicated in the database reference file and the file has been physically located on disk.
  • FS111-W Files are still open. Continue to close down the Fileshare Server (Y/N) ?
    You have selected to close down the Fileshare Server using the Esc key sequence. This message indicates that Fileshare Clients are still connected to this Fileshare Server with files open, or at least one Fileshare Client application program has terminated abnormally leaving one or more files open. You are asked to confirm that you do want to shut down the Fileshare Server even though there are files open.
  • FS114-W Waiting for the old log file to be removed.
    The drive where the rollforward recovery log file is being written has become full and the Fileshare Server is no longer able to continue writing to the rollforward recovery log file. The Fileshare Server is waiting for the old log file to be backed up and then deleted so that it can continue writing to the directory where the log file resides.
  • FS118-I The database sequence number matches the sequence number in the log file, no recovery is needed.
    For files formats with file headers (all index files and variable length record relative and sequential files), the Fileshare Server stores a sequence number in the header. This sequence number is also placed in the recovery log file. The sequence numbers can be checked by the Fileshare Server in certain situations to ensure that the correct files are in use.
  • FS122-I Communications too busy on CCI SEND - retrying.
    The Fileshare Server tried to send a reply back to the Fileshare Client performing an I/O request. CCI returned a Too Busy error (error 10) to the Fileshare Server.
  • FS123-I Communications too busy on CCI RECEIVE - retrying.
    The Fileshare Server tried to receive information from the network but CCI returned a Too Busy error (error 10) to the Fileshare Server
  • FS124-I Checking the validity of the log file, please wait.
    You see this message when the Rollforward Recovery Utility has been invoked and it has not found a valid record as the last record in the recovery log file. The Rollforward Recovery Utility scans through the log file to find the last sequence number that was in use to validate the integrity of the recovery log file.
  • FS125-I Recovery possible to last valid recovery log file record.
    You see this message when the Rollforward Recovery Utility has been invoked. This message indicates that the recovery log file has been validated up to the point of the last complete record in the recovery log file. It is therefore possible to apply the updates stored in the recovery log file up to this point.
  • FS126-I Performing recovery, please wait.
    The Rollforward Recovery Utility has been invoked and has initialized successfully, processed the database reference file, checked the sequence numbers in the file listed in the database reference file and validated the recovery log file.
  • FS127-S Invalid name mapping command.
    You see this message when the Fileshare Server or Rollforward Recovery Utility is processing the command line or entries in the database reference file. An /fs (file string replacement) option has been specified without a corresponding /af option specifying the new string value. The /fs option must be used in conjunction with the /af option.
  • FS128-W Fileshare Server closedown invoked by Stop Run processing.
    This message indicates that the Fileshare Server has entered its termination routine not under the control of an administrator (that is, the Esc key sequence or FSView or FSMgr are not being used to shut down the Fileshare Server).
  • FS129-I The Fileshare Server is still active.
    The response to the prompt as to whether the Fileshare Server should be closed down (see messages FS097 and FS111) indicated that the Fileshare Server should not be shut down.
  • FS130-I Reading database reference file, please wait.
    The Fileshare Server, Database File Maintenance Utility or the Rollforward Recovery Utility is reading the information stored in the database reference file. The utility will try to open the database reference file and process the information held in it.
  • FS131-W Invalid communications mode - parameter ignored.
    You see this message when the Fileshare Server is processing a /cm (communications) option. The value specified for this parameter is not valid and the parameter has been ignored. See the chapters Communications and Configuration for details of valid communications modes.
  • FS132-I The Fileshare Server is running with the following communication protocol(s):
    This message gives a list of the communication protocols that the Fileshare Server is using, after it has performed all of its initialization processing.
  • FS133-I Processing the password file, please wait.
    You see this message displayed by the Fileshare Server when it is starting or by the Password File Maintenance Utility when the password file is being updated.
  • FS134-I The password file cannot be found - creating a new password file.
    The Password File Maintenance Utility displays this message when it cannot locate the password file specified with the /pf option.
  • FS135-I Fileshare Server security is active.
    Fileshare Server security is active and all Fileshare Client applications that try to access this Fileshare Server should supply a valid user-ID and password that are in the password file. If you do not provide a valid user-ID or password, access will be denied and a 9/037 error returned to the application.
  • FS136-I Fileshare Server security is not active.
    A password file has been specified, however the only user-ID specified in the file is the FSVIEW (supervisor) id. Because this is the only ID, Fileshare Server security is not active and Fileshare Client applications that try to access the Fileshare Server do not have to supply a valid user-ID or password.
  • FS138-W The log file has been backed up and a new one has been created.
    You see this message when the Fileshare Server is starting up and a recovery log file already exists. The Fileshare Server has determined that it is unable to append to the recovery log file because the last record in the log file indicates that it was not shut in a controlled manner.
  • FS139-I A matching date and time entry has been found in the log file.
    The Rollforward Recovery Utility displays this message when the /dt option has been used to recover updates to a certain point in time. The Rollforward Recovery Utility has performed the recovery using the recovery log file and has applied the updates up to the date and time specified. This message implies that there were additional records stored in the recovery log file which were not processed as they were written after the time specified.
  • FS140-I No matching date and time entry has been found in the log file.
    You see this message displayed by the Rollforward Recovery Utility when the /dt option has been used to recover updates to a certain point in time. The Rollforward Recovery Utility has performed the recovery using the recovery log file and reached the end of the log file before a record could be found that was written at the date and time specified. This implies that the date and time specified when performing the recovery is later than the date and time that the last record was written to the recovery log file. All the updates stored in the recovery log file have been applied to the data files.
  • FS142-W The Operating System does not permit the log file to be flushed to disk.
    You see this message when the Fileshare Server is using a recovery log file to store updates made to files. At certain points during its operation the Fileshare Server makes a call to the operating system to force it to flush the contents of the recovery log file to disk. This ensures that any data that has been written to the recovery log file is physically stored on disk and can be read in again after a system failure. The Fileshare Server performs this flush operation after every COMMIT operation is performed and at regular intervals (the default being after every 100 records have been written to the recovery log file, which can be changed using a /lc entry in the database reference file).
  • FS143-W The Operating System does not allow free disk space information to be obtained.
    When writing a recovery log file, it is important that there is enough disk space available. Consequently, the Fileshare Server makes periodic checks to see whether sufficient disk space remains.
  • FS144-W More than one communications protocol has been specified - synchronous communications mode not active.
    You have tried to start the Fileshare Server using the synchronous communications mode (as opposed to the asynchronous communications mode which is the default) using the /sc option.
  • FS145-W Fileshare Client disconnected, cannot contact user: text.
    The CCI has returned an error to the Fileshare Server indicating that a Fileshare Client has been disconnected. This message indicates that there may be a problem with the network or that the Fileshare Client application program is no longer functioning.
  • FS146-W Unexpected action code, action-code - discarded.
    You see this message when performing a rollforward recovery. The Rollforward Recovery Utility has read a record from the recovery log file which contains information not relating to any file currently being recovered. The information in the record cannot be processed and the Rollforward Recovery Utility has moved onto the next record in the recovery log file.
  • FS147-I A duplicate network message was received and discarded.
    This message only occurs when you are using the CCIIPX protocol and indicates that you are using an old version of the CCIIPX modules. The buffer sent between the Fileshare Client and Fileshare Server for each I/O request contains additional information which enables the Fileshare Server to check on the validity of the request. This message indicates that the Fileshare Server has received (in error) a duplicate of the previous buffer received from the communications system. This duplicate buffer has been discarded as it is not a valid I/O request.
  • FS148-I CCI return-code (function func) = code.
    You see this message when the Fileshare Server receives an unexpected error status from a CCI module. It is normally displayed in conjunction with a Fileshare Server message indicating the circumstances in which the error occurred.
  • FS149-I CCI SEND not complete, status will be checked later.
    A request sent back to a client application from the Fileshare Server has not completed within the expected time period. This message indicates that the Fileshare Server will continue processing requests from other client applications normally and will check the status of this request at a later time.
Parent topic: Fileshare Server Messages
Related information
Messages from FS001-S to FS050-W
Messages from FS051-W to FS099-W
Messages from FS151-I to FS200-W
Messages from FS201-S to FS252-S


FS101-I text -- parameter has been accepted.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS103-I The log filename has been added to the database reference file.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS104-I The log file cannot be found, creating a new recovery log file.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS105-W The disk free space for the log file is below acceptable limits.

The amount of disk space remaining is calculated as a percentage of the total size of the disk where the log file is being written. The default is for this warning to be displayed when less than 5 percent of the total disk space remains free. This percentage can be changed using the /p option when entering the log filename into the database reference file using the Database Reference File Maintenance Utility.

Note:

If disk space is not cleared, the drive where the recovery log file is located will become so full as to make rollforward recovery logging impossible.

Resolution:

Clear disk space on the drive where the recovery log file is being written so that the Fileshare Server can continue logging the updates being performed.

Alternatively, if the amount of free disk space is becoming very low, the Fileshare Server should be shut down and the recovery log file backed up and deleted before starting the Fileshare Server again.

Parent topic: Messages from FS101-I to FS149-I


FS106-I filename - added to database reference file.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS107-I filename - removed from the database reference file.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS108-I Processing the files specified in the database reference file.

  • The Database Reference File Maintenance Utility searches through the list of files to check the integrity of each one and also determine the current sequence numbers that are in use (if any)
  • The Fileshare Server scans the names in the database reference file in order to determine the processing to be done on each file
  • The Rollforward Recovery Utility searches through the list of files to check the integrity of each file and the sequence number in the header of each one

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS109-W The file filename does not exist.

Resolution:

If the file should exist, ensure that the filename and the path specified are correct and that the Fileshare Server is able to open the file with read-write access. Also ensure that the file is not open by another process as the Fileshare system requires exclusive access to the file.

If the file should not exist (for example, it is expected that it will be created by an application program), then this warning can be ignored.

Parent topic: Messages from FS101-I to FS149-I


FS110-I filename - OK.

Resolution:

No action is required as this message is informational.

Parent topic: Messages from FS101-I to FS149-I


FS111-W Files are still open. Continue to close down the Fileshare Server (Y/N) ?

Resolution:

At the prompt enter Y or N depending on whether the Fileshare Server is to be closed down or not.

Parent topic: Messages from FS101-I to FS149-I


FS114-W Waiting for the old log file to be removed.

Resolution:

The current log file should be backed up. The log file should then be moved so that the Fileshare Server can continue writing to the directory. If a rollforward recovery is necessary, the log files should be provided in the order that they were created to the Rollforward Recovery Utility. The Rollforward Recovery Utility will prompt for the continuation log files as they are required, if they cannot be located automatically.

Parent topic: Messages from FS101-I to FS149-I


FS118-I The database sequence number matches the sequence number in the log file, no recovery is needed.

You see this message when the Rollforward Recovery Utility has been invoked to perform a rollforward recovery. The Rollforward Recovery Utility has read the sequence numbers from the header of the files and also the last one that was written to the recovery log file. The sequence number in the headers and in the log file are the same indicating that the last updates written to the recovery log file have been applied to the files. It is therefore not necessary to perform a rollforward recovery as there are no updates in the recovery log file that have not already been applied to the files.

It is not necessary to perform the rollforward recovery.

See the sections Rollforward Recovery Logging and Rollforward Recovery Utility in the chapter Database Integrity for more details.

Resolution:

No action is required

Parent topic: Messages from FS101-I to FS149-I
Related information
Rollforward Recovery Logging
Rollforward Recovery Utility


FS122-I Communications too busy on CCI SEND - retrying.

The Fileshare Server will retry the operation until the CCI protocol has been able to complete the operation.

This message could indicate that the network or network software is reaching a limit or is very busy.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS123-I Communications too busy on CCI RECEIVE - retrying.

The Fileshare Server will retry the request until valid data is returned from CCI

This message could indicate that the network or network software is reaching a limit or is very busy

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS124-I Checking the validity of the log file, please wait.

The fact that the log file does not contain a valid last record indicates that the recovery log file was not closed in a controlled manner and that the Fileshare Server which was writing to the recovery log file terminated abnormally.

See the sections Rollforward Recovery Logging and Rollforward Recovery Utility in the chapter Database Integrity for more information.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I
Related information
Rollforward Recovery Logging
Rollforward Recovery Utility


FS125-I Recovery possible to last valid recovery log file record.

The Rollforward Recovery Utility will apply the updates up to the point of the last valid record stored in the recovery log file.

See the sections Rollforward Recovery Logging and Rollforward Recovery Utility in the chapter Database Integrity for more information.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I
Related information
Rollforward Recovery Logging
Rollforward Recovery Utility


FS126-I Performing recovery, please wait.

The Rollforward Recovery Utility will now start the recovery process. The time required to perform the recovery depends on the number of updates that are logged in the recovery log file.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS127-S Invalid name mapping command.

See the section Filename Mapping in the chapter Advanced Operation and the section Database Reference File Maintenance in the chapter Database Integrity for more information on the /fs option.

Resolution:

If the option has been specified on the command line, include the /af option to specify the name of the replacement string value and retry the operation.

If the option is specified in a database reference file, this error indicates that the database reference file has become corrupt or has been changed without using the Database Reference File Maintenance Utility.

In this situation, it may be possible to remove the invalid entry using a normal text editor. If this is unsuccessful, discard the current database reference file and create a new one using the Database Reference File Maintenance Utility.

Parent topic: Messages from FS101-I to FS149-I
Related information
Filename Mapping
Database Reference File Maintenance


FS128-W Fileshare Server closedown invoked by Stop Run processing.

This message should not be displayed under normal circumstances. Possible causes for this error are:

  • Closing the Fileshare Session on Windows or a kill command on UNIX. Such methods of closing the Fileshare Server should not be used as it can lead to files being corrupted and the recovery log file not being written to disk correctly.
  • The Fileshare Server has encountered an internal processing error which has caused the closedown code in the run-time system to be invoked. In this situation you should contact our technical support department to try and ascertain the cause of this error.

The Fileshare Server terminates by closing all files, rolling back any outstanding transactions, clearing all communication links with Fileshare Clients and closing the recovery log file (if in use).

Resolution:

You should try to ascertain why the Fileshare Server closed in this manner.

Parent topic: Messages from FS101-I to FS149-I


FS129-I The Fileshare Server is still active.

This message indicates that the Fileshare Server is continuing to function as normal.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I
Related information
FS097
FS111


FS130-I Reading database reference file, please wait.

The amount of time required to process the database reference file depends on the amount of information contained in the file.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS131-W Invalid communications mode - parameter ignored.

Resolution:

Ensure that the value specified for the communications parameter is valid.

If you do not wish to specify a communications protocol you should not use the /cm option. The Fileshare Server uses the default communications protocol for the operating system on which it is running.

Parent topic: Messages from FS101-I to FS149-I
Related information
Communications


FS132-I The Fileshare Server is running with the following communication protocol(s):

The Fileshare Client application programs can use any of the protocols listed to contact this Fileshare Server.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS133-I Processing the password file, please wait.

The password file has been successfully located and opened and is now being processed.

The time required for this operation depends on the amount of information that is stored in the password file.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS134-I The password file cannot be found - creating a new password file.

The Password File Maintenance Utility will therefore try to create a new password file of the name specified.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS135-I Fileshare Server security is active.

See the chapter Security for more details about the Fileshare Server security features and how to use them.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I
Related information
Security


FS136-I Fileshare Server security is not active.

Logons are validated by the Fileshare Server by calling the FSSECLOG module.

See the chapter Security for more details about the Fileshare Server security features and how to use them.

See the section Password File Maintenance in the chapter Security for more information about supervisor passwords.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I
Related information
Security
Password File Maintenance


FS138-W The log file has been backed up and a new one has been created.

This implies that the Fileshare Server which was previously writing to this log file terminated abnormally.

Because the Fileshare Server is unable to append to the existing log file, it has been renamed and a new recovery log file has been created. This new recovery log file will be used.

Note:

This message implies that the correct sequence of regularly backing up data files and deleting recovery log files is not being performed as the Fileshare Server is being started when a recovery log file already exists.

See the section Rollforward Recovery Logging in the chapter Database Integrity for more details.

Resolution:

No action is required

Parent topic: Messages from FS101-I to FS149-I
Related information
Rollforward Recovery Logging


FS139-I A matching date and time entry has been found in the log file.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS140-I No matching date and time entry has been found in the log file.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I


FS142-W The Operating System does not permit the log file to be flushed to disk.

This message indicates that an error was returned from the operating system when it tried to flush the recovery log file to disk. This implies that the operating system does not enable application programs to force I/O buffers to be flushed to disk. Consequently, the Fileshare Server is unable to force the operating system to write the contents of the recovery log file to disk and in the event of a system failure, it is possible that not all of the contents of the recovery log file will be available when the recovery process is performed.

Resolution:

See the section Database Reference File Maintenance in the chapter Database Integrity and Rollforward Recovery for more details.

Parent topic: Messages from FS101-I to FS149-I
Related information
Database Reference File Maintenance


FS143-W The Operating System does not allow free disk space information to be obtained.

This message indicates that the call to the operating system to determine how much disk space is available has returned an error. This implies that the operating system does not enable applications to determine how much disk space is available.

Resolution:

It is the system administrator's responsibility to ensure that sufficient disk space is available, as the Fileshare Server is unable to determine the amount of free space available on the drive. If the Fileshare Server is unable to write a recovery log file because there is insufficient disk space, the Fileshare Server automatically closes down.

Parent topic: Messages from FS101-I to FS149-I


FS144-W More than one communications protocol has been specified - synchronous communications mode not active.

With this mode of communication it is only possible to start the Fileshare Server with one communications protocol.

This message indicates that the Fileshare Server is configured to use more than one communications protocol and so the synchronous communications option has been ignored.

The Fileshare Server has started, but it is not using the synchronous communications mode.

Resolution:

If the synchronous communications mode is required, make sure that the Fileshare Server is configured to use only one communications protocol.

Parent topic: Messages from FS101-I to FS149-I


FS145-W Fileshare Client disconnected, cannot contact user: text.

You see the user number and user name, if one was supplied at the time that this user logged onto the Fileshare Server.

The Fileshare Server has closed all files that this user had open and rolled back any outstanding transactions pending for this user.

The Fileshare Client application, if still active, will be returned a 9/124 error on its next I/O operation.

Resolution:

Check that the Fileshare Client application is still running. Also check for any adverse network conditions that could have forced the connection to have been dropped.

Parent topic: Messages from FS101-I to FS149-I


FS146-W Unexpected action code, action-code - discarded.

This message can indicate that the recovery log file has become corrupted in some way or that the recovery file contains invalid information.

Resolution:

As the rollforward recovery log file contains an invalid record, it is possible that not all of the record updates have been recovered from the file. After the recovery has completed the data in the files should be checked. If the problem recurs contact our technical support department.

Parent topic: Messages from FS101-I to FS149-I


FS147-I A duplicate network message was received and discarded.

Resolution:

Ensure that the latest CCIIPX modules are installed on the Fileshare Client and Fileshare Server machines.

Parent topic: Messages from FS101-I to FS149-I


FS148-I CCI return-code (function func) = code.

The message consists of a function code which indicates which CCI verb was being used at the time of the error and the return-code received from the CCI module.

The Fileshare Server calls CCI to determine details of the error that has occurred. This information is also displayed on the screen.

Resolution:

No action is required. However, the above information should indicate the cause of an error or unexpected occurrence during the Fileshare Server operation. This information should be used with any additional information contained in other messages to determine the cause of any errors.

When contacting our technical support department the above information is important and must be included with any problem report.

Parent topic: Messages from FS101-I to FS149-I


FS149-I CCI SEND not complete, status will be checked later.

Message FS228 is displayed when it is determined that the request eventually either completed or failed.

If you see this message frequently, it may be due to large record sizes taking longer to process than expected on slower network connections.

Resolution:

No action is required.

Parent topic: Messages from FS101-I to FS149-I
Related information
FS228


Messages from FS151-I to FS200-W

  • FS151-I CCI message size received = text. Indicated send message size = text
    You see this message in conjunction with message FS014.
  • FS153-I The Fileshare Server name has been reregistered on the network.
    The Fileshare Server tried to register its name on the network so that Fileshare Clients can contact it. An error status was returned indicating that the Fileshare Server name was already registered on the network by a Fileshare Server which terminated abnormally. As this name is not being used by an active Fileshare Server, the name has been reregistered on the network by the Fileshare Server being started.
  • FS154-I Please enter the FSVIEW supervisor password to enable the use of CCI Trace.
    The Fileshare Server is being started and is configured to use the CCI Trace option. This option can only be used by a supervisor because it can cause a large amount of disk space to be used for storing the CCI Trace file. When starting the Fileshare Server a password file should be specified that contains a user-ID of FSVIEW.
  • FS155-I Password accepted - CCI Trace is enabled. Do you want CCI Trace active immediately? (Y/N)
    You see this message displayed after the supervisor has entered the supervisor password to enable the use of CCI Trace. The Fileshare Server has confirmed that the password entered is correct and it is now possible to use CCI Trace.
  • FS156-W Incorrect password - CCI Trace is disabled.
    You see this message after the FSVIEW supervisor has entered the supervisor password to enable the use of CCI Trace.
  • FS158-I CCI Trace activated.
    This message indicates that the Fileshare Server has enabled the CCI Trace option and all requests made to CCI are being logged in the CCI Trace file.
  • FS159-I CCI Trace switched off.
    This message indicates that the Fileshare Server has turned off the CCI Trace option and all requests made to CCI are no longer being logged in the CCI Trace file. You see this message when the CCI Trace is either:
  • FS160-I Fileshare trace activated.
    You see this message displayed by the Fileshare Server when the trace option has been activated using the F2 key. All requests received by the Fileshare Server will be shown, with the operation code being requested, the name of the user performing the request and some additional information depending on the operation being performed. The result of the operation (including the file status) that is returned to the Fileshare Client is also shown.
  • FS161-I Fileshare trace switched off.
    You see this message displayed by the Fileshare Server when the trace option has been toggled off using the F2 key. The Fileshare Server no longer displays requests received or information about the data being returned to the Fileshare Clients. The Fileshare Server also is no longer writing to the trace file fsscreen.lst if the trace file option was specified when the Fileshare Server was started.
  • FS163-I Input useropcode [filename-1] [ filename-2].
    You see this message when the Fileshare Server trace option is activated and a request has been received by the Fileshare Server. The information displayed is as follows:
  • FS170-I Input- Logon.
    You see this message when the Fileshare Server trace option is activated and a logon request has been received by the Fileshare Server. The Fileshare Server will process the logon request and the result of the request will also be displayed. A logon request is always the first operation performed by a new Fileshare Client connecting to this Fileshare Server.
  • FS171-I Input- Logoff user.
    You see this message when the Fileshare Server trace option is activated and a log off request has been received by the Fileshare Server. If the Fileshare Client supplied a user name when it logged onto this Fileshare Server, the user name is displayed here if Fileshare Security is active. If no user name was supplied, then the user number is displayed.
  • FS172-I Input- Find File userfilename.
    You see this message when the trace option is activated and a Find File request has been received by the Fileshare Server from a Fileshare Client when a program tries to open a file. The Fileshare Server that should process the file has not been explicitly defined and more than one default Fileshare Server is configured.
  • FS173-I Output- userstatus.
    You see this message when the Fileshare Server trace option is activated and a request has been processed by the Fileshare Server and the result sent back to the Fileshare Client
  • FS176-W There is no backup directory specified in the database reference file.
    You tried to erase a backup directory entry from the database reference file but the database reference file does not contain a backup directory entry
  • FS177-S The backup directory specified cannot be found in the database reference file.
    You tried unsuccessfully to erase a backup directory-name from the database reference file. This is because the backup directory-name specified is not the same as the backup directory-name in the database reference file.
  • FS178-I The backup directory has been added to the database reference file.
    The Database Reference File Maintenance Utility has been invoked to add a backup directory-name to the database reference file and the operation has completed successfully. The database reference file now contains the name of the backup directory specified.
  • FS179-S A backup directory is already specified in the database reference file.
    You tried to add the name of the backup directory to the database reference file. However such an entry already exists in the database reference file which can only contain one recovery log file backup directory-name.
  • FS180-W The log filename specified has an extension. The name of the log file has been changed to "filename".
    The Database Reference File Maintenance Utility has been invoked to add the name of the recovery log file to the database reference file. The name of the log file specified contained an extension and this has been removed. The extension is removed to enable the Fileshare Server to automatically backup the recovery log file when necessary. The name of the log file added to the database reference file is shown.
  • FS182-W Output- Access Denied
    You see this message when the Fileshare Server trace option is activated and a logon request was received by the Fileshare Server from the Fileshare Client. This logon request has been denied, either because:
  • FS188-W Fileshare Server database reference file installation completed with errors.
    The Database Reference File Maintenance Utility has been used to update the contents of the database reference file. However, an error was found when parsing the command line passed to the utility or when processing the information stored in the database reference file.
  • FS189-W The backup directory does not exist.
    The Database Reference File Maintenance Utility has been invoked to add the name of a backup directory to the database reference file.
  • FS190-W The backup directory specifies the name of an existing file.
    The Database Reference File Maintenance Utility has been invoked to add the name of a backup directory to the database reference file.
  • FS191-W An error occurred accessing the backup directory.
    The Database Reference File Maintenance Utility has been invoked to add the name of a backup directory to the database reference file.
  • FS192-S More than one log file exists in the log file directory.
    You see this message when the Fileshare Server is starting up. The Fileshare Server has searched the directory where the recovery log file is to be written and has determined that more than one recovery log file exists in the directory. The Fileshare Server is unable to determine which of these recovery log files is a valid one and hence which one it can append data to.
  • FS193-S Unable to open the log file.
    The Fileshare Server has determined that a recovery log file exists in the directory where the recovery log file is specified but an error was returned when the Fileshare Server tried to open it.
  • FS194-I The log file "filename-1" has been backed up successfully to "filename-2".
    This message indicates that the Fileshare Server has successfully backed up the recovery log file. The backup operation was performed either as a request from FSVIEW or FSMGR or because the current recovery log file cannot be appended to and has been automatically backed up when the Fileshare Server has started. filename-1 is the name of the log file that has been backed up. filename-2 is the name of the file that the log file has been backed up to.
  • FS195-I The Fileshare Server is using the log file "filename".
    The Fileshare Server has successfully opened (and created if necessary) the recovery log file indicated and is writing recovery records to this log file.
  • FS196-W Unable to create the log file "filename".
    The Fileshare Server tried to create the recovery log file indicated, but was unable to do so.
  • FS197-S Unable to create the log file "filename".
    The Fileshare Server tried to create the recovery log file indicated, but was unable to do so.
  • FS198-W The attempt to backup the log file failed because the backup file "filename" already exists.
    The Fileshare Server was unable to backup the recovery log file to the directory and name specified because a file of that name already exists.
  • FS199-S The attempt to backup the log file failed because the backup file "filename" already exists.
    The Fileshare Server was unable to backup the recovery log file to the directory and name specified because a file of that name already exists.
  • FS200-W The attempt to backup the log file to "filename" failed.
    The Fileshare Server tried to copy the recovery log file to the directory and name specified but encountered an error when doing so. Possible causes are that the directory is full or that a disk I/O error occurred during the copying process.
Parent topic: Fileshare Server Messages
Related information
Messages from FS001-S to FS050-W
Messages from FS051-W to FS099-W
Messages from FS101-I to FS149-I
Messages from FS201-S to FS252-S


FS151-I CCI message size received = text. Indicated send message size = text

The information sent from the Fileshare Client to the Fileshare Server includes a check on the amount of information that is being sent. This error states that the amount of data received by the Fileshare Server is not the same as the amount sent by the Fileshare Client.

This message shows the amount of data that has been received by the Fileshare Server and also the amount of data that was sent by the Fileshare Client.

The Fileshare Server has ignored the data sent from the Fileshare Client.

Resolution:

If using the NETBIOS protocol, ensure that it is installed correctly, configured and operational.

It is highly likely that the Fileshare Client appears to have stopped because the Fileshare Server has not sent any reply back. Depending on the CCI protocol being used, a time-out occurs in approximately two minutes and a 9/124 status is returned to the application program.

Parent topic: Messages from FS151-I to FS200-W
Related information
FS014-W


FS153-I The Fileshare Server name has been reregistered on the network.

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W


FS154-I Please enter the FSVIEW supervisor password to enable the use of CCI Trace.

See the section Password File Maintenance in the chapter Security for more information.

See also the messages FS155 and FS156.

Resolution:

At this prompt enter the supervisor password that corresponds to the entry in the password file for the user-ID of FSVIEW

Parent topic: Messages from FS151-I to FS200-W
Related information
Password File Maintenance
FS155
FS156


FS155-I Password accepted - CCI Trace is enabled. Do you want CCI Trace active immediately? (Y/N)

This prompt is to determine if the Fileshare Server is to trace communication requests immediately and include all of the CCI initialization requests made by the Fileshare Server.

Resolution:

Responding Y enables the Fileshare Server to start using CCI Trace immediately and causes all CCI initialization requests to be traced to the CCI Trace file. The CCI Trace remains operational until toggled off using the F3 key.

Entering any other response apart from Y does not enable CCI trace immediately. However, CCI trace can be toggled on at a later time using the F3 key.

See also the messages FS154 and FS156.

Parent topic: Messages from FS151-I to FS200-W
Related information
FS154
FS156


FS156-W Incorrect password - CCI Trace is disabled.

The Fileshare Server has determined that the password entered is incorrect and has consequently disabled the use of the CCI Trace feature.

Resolution:

If CCI Trace is required then the Fileshare Server should be brought down using the Esc key sequence. Ensure that when starting the Fileshare Server the /pf option is used to specify a password file that contains a password for the user-ID FSVIEW. When prompted to enter the supervisor password the password for the FSVIEW user-ID should be entered.

If CCI Trace is not required then no action is required as the Fileshare Server has started and the CCI Trace feature is not enabled. However, to prevent this message in future, the Fileshare Server should be reconfigured not to use CCI Trace.

Parent topic: Messages from FS151-I to FS200-W


FS158-I CCI Trace activated.

You see this message when either CCI Trace is made active on start-up, or is toggled on using the F3 key while the Fileshare Server is operational.

Note:

The CCI Trace file can become very large. If no disk space remains to enable the CCI Trace file to be written, no errors are reported and the tracing of CCI requests is suspended.

Resolution:

No action is required

Parent topic: Messages from FS151-I to FS200-W


FS159-I CCI Trace switched off.

  • Not made active immediately on the Fileshare Server starting up (see the message FS155)

    or

  • Toggled off using the F3 key while the Fileshare Server is operational

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W
Related information
FS155


FS160-I Fileshare trace activated.

If the trace to a file option was specified when the Fileshare Server was started then the information displayed on the screen is also written to a file called fsscreen.lst.

The trace option can be toggled off using the F2 key.

See also message FS161.

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W
Related information
FS161


FS161-I Fileshare trace switched off.

The trace option can be toggled on using the F2 key.

See also message FS160.

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W
Related information
FS160


FS163-I Input useropcode [filename-1] [ filename-2].

user | If the Fileshare Client supplied a user name when it logged onto this Fileshare Server then the user name is displayed here if Fileshare Security is active. If no user name was supplied, the user number is displayed. The user number is generated when the Fileshare Client logs onto this Fileshare Server. The first Fileshare Client has user-ID 1, the second user-ID 2, etc.
opcode | This is an indication of the type of action requested by the Fileshare Client. Most normal operations appear as an action-code. If a byte stream operation is being performed, the name of the operation is displayed. For COMMIT operations, an indication is given if the COMMIT is part of a prepare, confirm or abort stage of the transaction processing (if the transaction spans more than one Fileshare Server).
filename-1 | If the operation being performed is specific to a file then the name of the file is displayed here
filename-2 | If the operation being performed is specific to a file and requests to the file are being mapped to a different file using the alternate filename mapping option, the actual name of the file being processed is displayed here

The information displayed will also be written to a file called fsscreen.lst if the trace file option was specified when the Fileshare Server was started.

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W


FS170-I Input- Logon.

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W


FS171-I Input- Logoff user.

The user number is generated when the Fileshare Client logs onto this Fileshare Server. The first Fileshare Client has user-ID 1, the second user-ID 2.

A logoff request is the last operation performed by a Fileshare Client when the Fileshare Client application program terminates.

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W


FS172-I Input- Find File userfilename.

The Fileshare Client is in the process of polling each default Fileshare Server to determine if that Fileshare Server should process requests for this file.

The information displayed is as follows:

user | If the Fileshare Client supplied a user name when it logged onto this Fileshare Server, the user name is displayed here if Fileshare Server security is active. If no user name was supplied, then the user number is displayed. The user number is generated when the Fileshare Client logs on to this Fileshare Server. The first Fileshare Client has user-ID 1, the second user-ID 2.
filename | The name of the file that the Fileshare Client is trying to open

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W


FS173-I Output- userstatus.

The information displayed is as follows:

user | If the Fileshare Client supplied a user name when it logged onto this Fileshare Server then the user name is displayed here. If no user name was supplied, the user number is displayed. The user number is generated when the Fileshare Client logs onto this Fileshare Server. The first Fileshare Client has user-ID 1, the second user-ID 2.
status | The error status generated from the result of the requested operation. For normal file I/O operations this is the same format as standard file I/O statuses. Note that this status may not be the status that is returned to the application program. The Fileshare Client uses the status displayed here to do any status conversion necessary (for example, to an RM COBOL status) before returning the status to the application program.

For byte-stream I/O calls and other functions, the code returned to the Fileshare Client is displayed.

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W


FS176-W There is no backup directory specified in the database reference file.

Resolution:

No action is necessary (as the erase operation is not required because there is no backup directory name specified in the database reference file).

Parent topic: Messages from FS151-I to FS200-W


FS177-S The backup directory specified cannot be found in the database reference file.

Resolution:

Specify the correct backup directory-name when trying to erase the entry from the database reference file. If the name specified in the database reference file is not known then the current database reference file should be discarded and a new one created using the Database Reference File Maintenance Utility.

Parent topic: Messages from FS151-I to FS200-W


FS178-I The backup directory has been added to the database reference file.

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W


FS179-S A backup directory is already specified in the database reference file.

Resolution:

Remove the current backup directory-name from the database reference file using the Database Reference File Maintenance Utility (/e erase option) and then add the name of the new backup directory using the same utility.

Parent topic: Messages from FS151-I to FS200-W


FS180-W The log filename specified has an extension. The name of the log file has been changed to "filename".

Resolution:

No action is required (as the Fileshare Server has removed the extension and added the altered name to the database reference file). To avoid this message in the future, do not use a filename with an extension when adding a recovery log filename to the database reference file.

Parent topic: Messages from FS151-I to FS200-W


FS182-W Output- Access Denied

  • Password security is active and an incorrect password or user-ID was supplied.

    or

  • Password security is not active and the logon validation by the module FSSECLOG failed.

Resolution:

If the password file security option is:

  • Active, ensure that the application program has supplied a valid user-ID and password to the Fileshare Client. Also ensure that the user-ID and password are in the password file that was specified when the Fileshare Server was started.
  • Inactive, the logon has been denied by the FSSECLOG module. This module supplied with the Fileshare Server enables any Fileshare Client to log on to the Fileshare Server. This therefore suggests that the logon has been denied by a user-supplied FSSECLOG module and the appropriate action should be taken.

See the chapter Security for more information.

Parent topic: Messages from FS151-I to FS200-W
Related information
Security


FS188-W Fileshare Server database reference file installation completed with errors.

The database reference file has been left unaltered as the operation was unsuccessful.

Resolution:

Ensure that the command line specified for the Database Reference File Maintenance Utility is correct. Other messages displayed by the Database Reference File Maintenance Utility indicate which error has occurred.

For information on valid parameters, see the section Database Reference File Maintenance in the chapter Database Integrity .

Parent topic: Messages from FS151-I to FS200-W
Related information
Database Reference File Maintenance


FS189-W The backup directory does not exist.

This message indicates that the directory specified does not exist.

The backup directory-name has been added to the database reference file.

Resolution:

Check that the directory-name and path specified are correct. If they are not correct, the entry should be removed from the database reference file (using the /e (erase) option and the Database Reference File Maintenance Utility) and the correct entry added to the database reference file using the same utility.

If the path and directory-name are correct, ensure that the directory is created or made available to the Fileshare Server before starting the Fileshare Server, so that the automatic backup can take place. If the directory does not exist, the Fileshare Server fails when trying to back up the recovery log file or the data files automatically when required to do so.

Parent topic: Messages from FS151-I to FS200-W


FS190-W The backup directory specifies the name of an existing file.

This message indicates that the directory specified is the name of a file and not the name of a directory.

The backup directory-name has been added to the database reference file.

Resolution:

Check that the directory-name and path specified are correct. If they are not correct, the entry should be removed from the database reference file (using the /e (erase) option and the Database Reference File Maintenance Utility) and the correct entry added to the database reference file using the same utility.

If the path and directory-name are correct then before starting the Fileshare Server, ensure that a directory of the name specified is created or made available to the Fileshare Server so that the automatic backup can take place. The file of this name should be removed.

If the directory does not exist, the Fileshare Server fails when trying to back up the data files or the recovery log file automatically when required to do so.

Parent topic: Messages from FS151-I to FS200-W


FS191-W An error occurred accessing the backup directory.

This message indicates that the Database Reference File Maintenance Utility received an unexpected error when verifying that the directory exists.

See also messages FS189-W and FS190-W.

The backup directory-name has been added to the database reference file.

Resolution:

If the path and directory-name are correct, ensure that a directory of the name specified is created or made available to the Fileshare Server before starting the Fileshare Server, so that the automatic backup can take place.

If the directory does not exist or cannot be accessed, the Fileshare Server fails when trying to back up the data files or the recovery log file automatically when required to do so.

Parent topic: Messages from FS151-I to FS200-W
Related information
FS189-W
FS190-W


FS192-S More than one log file exists in the log file directory.

Recovery log files have an extension which start with L. This message indicates that the correct procedures for backing up data files and deleting recovery log files are not being followed.

The Fileshare Server will not start up until this problem is resolved.

Resolution:

Ensure that the correct recovery log file is in the directory where the log file is to be written. Alternatively ensure that the directory does not contain any recovery log file so that the Fileshare Server creates a new one when it starts up.

Make sure that the correct procedures for using rollforward recovery logging are used. See the sections Rollforward Recovery Logging and Rollforward Recovery Utility in the chapter Database Integrity.

Parent topic: Messages from FS151-I to FS200-W
Related information
Rollforward Recovery Logging
Rollforward Recovery Utility


FS193-S Unable to open the log file.

This error indicates that the Fileshare Server does not have the correct permissions to access the file or that the recovery log file is in use by another process. The Fileshare Server requires read and write access to the recovery log file and will try to open the file with exclusive access.

This message can occur:

  • When the Fileshare Server is starting up, in which case the Fileshare Server will not start and the problem should be corrected before the Fileshare Server is started again
  • When the Fileshare Server is in the process of backing up the recovery log file. The backup of the log file failed and the Fileshare Server has tried to use the original recovery log file. However, the opening of the recovery log file failed. In this situation, the logging of updates is suspended.

Resolution:

Ensure that the Fileshare Server has read and write access permissions to the recovery log file and that the file is not in use by another process.

Parent topic: Messages from FS151-I to FS200-W


FS194-I The log file "filename-1" has been backed up successfully to "filename-2".

If a recovery log file backup directory has been specified, then the backed-up recovery log file is in the backup directory.

If the log file was backed up when the Fileshare Server started, this indicates that the old recovery log file was not closed in a controlled manner. Not all of the updates in the old log file can be applied to the data files if a rollforward recovery becomes necessary. You are advised to close down the Fileshare Server and perform a rollforward recovery with the old recovery log file to restore the data files to a consistent state. The recovery log file should then be discarded and a new one will be created when the Fileshare Server is restarted.

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W


FS195-I The Fileshare Server is using the log file "filename".

Resolution:

No action is required.

Parent topic: Messages from FS151-I to FS200-W


FS196-W Unable to create the log file "filename".

The Fileshare Server was unable to create the new recovery log file after backing up the one that was in use. As the Fileshare Server is already operational, it does not close down. The Fileshare Server tries to re-open the old recovery log file and tries to continue writing recovery records to it. This message indicates that overall, the backing up of the recovery log file failed. The Fileshare Server is still operational.

Resolution:

Ensure that the log filename contains a valid directory and filename. The Fileshare Server requires read-write access to the log file and permissions to create the file if necessary. Ensure that, if the file of this name already exists, it is not being used by another process.

Parent topic: Messages from FS151-I to FS200-W


FS197-S Unable to create the log file "filename".

The Fileshare Server was unable to create the recovery log file when it was starting up and so will not start. The problem should be rectified before trying to start the Fileshare Server again.

Resolution:

Ensure that the log filename contains a valid directory and filename. The Fileshare Server requires read-write access to the log file and permissions to create the file if necessary. Ensure that, if the file of this name already exists, it is not being used by another process.

Parent topic: Messages from FS151-I to FS200-W


FS198-W The attempt to backup the log file failed because the backup file "filename" already exists.

The Fileshare Server was unable to backup the log file that is currently in use. As the Fileshare Server is already operational, it cannot close down. The Fileshare Server tries to re-open the old recovery log file and tries to continue writing recovery records to it. This message indicates that overall, the backing up of the recovery log file failed. The Fileshare Server is still operational.

Resolution:

Remove the filename indicated so that the recovery log file can be automatically backed up.

This message can indicate that the correct sequence of backing up data files and removing recovery log files is not being followed.

See the section Rollforward Recovery Logging in the chapter Database Integrity for more details.

Parent topic: Messages from FS151-I to FS200-W
Related information
Rollforward Recovery Logging


FS199-S The attempt to backup the log file failed because the backup file "filename" already exists.

The Fileshare Server was unable to back up the log file to which it cannot append. The Fileshare Server is unable to append to the current recovery log file and is also unable to back it up and will therefore not start. The problem should be rectified before trying to start the Fileshare Server again.

Resolution:

Remove the filename indicated so that the recovery log file can be automatically backed up.

This message can indicate that you are not following the correct sequence of backing up data files and removing recovery log files.

See the section Rollforward Recovery Logging in the chapter Database Integrity for more details.

Parent topic: Messages from FS151-I to FS200-W
Related information
Rollforward Recovery Logging


FS200-W The attempt to backup the log file to "filename" failed.

The Fileshare Server was unable to back up the log file that is currently in use. As the Fileshare Server is already operational, it cannot close down. The Fileshare Server will try to re-open the old recovery log file and continue to write recovery records to that. This message indicates that overall, the backing up of the recovery log file failed. The Fileshare Server is still operational.

Resolution:

Ensure that the filename and directory of the backup file are correct. Also ensure that there is enough disk space in the backup directory for the recovery log file to be copied.

If you are trying to start the Fileshare Server, this message can indicate that you are not following the correct sequence of backing up data files and removing recovery log files. See the section Rollforward Recovery Logging in the chapter Database Integrity for more details.

Parent topic: Messages from FS151-I to FS200-W
Related information
Rollforward Recovery Logging


Messages from FS201-S to FS252-S

  • FS201-S The attempt to backup the log file to "filename" failed.
    The Fileshare Server failed to copy the recovery log file to the directory and name specified. Possible causes are that the directory is full or that a disk I/O error occurred during the copying process.
  • FS202-I The Fileshare Server will continue logging to the log file "filename".
    The Fileshare Server failed to backup the recovery log file as part of an FSView or FSMgr operation and is trying to continue logging to the old recovery log file specified.
  • FS203-I The Fileshare Server is appending to the log file "filename".
    The Fileshare Server has found a valid recovery log file to which it is able to append data.
  • FS204-W The Fileshare Server is unable to log to the log file "filename". Rollforward recovery logging is disabled.
    The Fileshare Server has failed to back up the recovery log file as part of an FSView or FSMgr operation. Consequently, the Fileshare Server does not have a valid recovery log file into which it can write records.
  • FS205-W Unable to remove the old recovery log file "filename".
    The Fileshare Server has successfully backed-up the recovery log file as part of an FSView or FSMgr operation. However, deleting the old recovery log file returned an unexpected error. The Fileshare Server tries to create the new recovery log file.
  • FS206-S There is more than one starter log file. The Recovery Utility is unable to determine which one to use.
    You see this message when the Rollforward Recovery Utility has determined that there is more than one starter recovery log file. When the Fileshare Server starts, it creates a starter recovery log file and a new log file.
  • FS207-I There is no starter log file in the log file directory.
    The Rollforward Recovery Utility has been invoked and has scanned all of the recovery log files in the current directory. It has not found a starter log file, so the recovery cannot start using a log file in the recovery log file directory.
  • FS208-S There is no starter log file in the backup directory.
    The Rollforward Recovery Utility has been invoked and has scanned all of the recovery log files in the backup directory. No starter log file was found and so the recovery cannot commence.
  • FS209-I A starter log file has been located in the backup directory.
    The Rollforward Recovery Utility has not found a starter log file in the recovery log file folder, but one was located in the backup folder. The Rollforward Recovery Utility can start the rollforward recovery.
  • FS210-S There is more than one starter log file in the backup directory.
    The Rollforward Recovery Utility has scanned through all of the recovery log files that are in the backup directory and has determined that there is more than one starter recovery log file.
  • FS211-S An error occurred checking the header on the log file "filename".
    The Rollforward Recovery Utility found the log file indicated but was unable to open it. This message can also indicate that the file was opened successfully but the Rollforward Recovery Utility could not read the first record in the file.
  • FS212-I The Rollforward Recovery Utility is processing the log file "filename".
    The Rollforward Recovery Utility has successfully opened the starter or continuation recovery log file indicated and is processing the update information contained in it
  • FS213-W Unable to locate the continuation log file "filename" in the log file directory.
    The Rollforward Recovery Utility has processed the first recovery log file.
  • FS214-I Searching for a backed up log file in the log file directory.
    The Rollforward Recovery Utility cannot find the required recovery log file in the current log file directory. It is now searching for a backed-up copy of the required recovery log file in the log file directory.
  • FS215-I Searching for a backed up log file in the backup directory.
    The Rollforward Recovery Utility cannot find the required recovery log file in the current log file directory. It is now searching for a backed-up copy of the required recovery log file in the backup directory
  • FS216-I No backed up starter log file can be found in the log file directory.
    The Rollforward Recovery Utility has searched unsuccessfully for a backed-up starter recovery log file in the log file current directory
  • FS217-I No backed up starter log file can be found in the backup directory.
    The Rollforward Recovery Utility has searched unsuccessfully for a backed-up starter recovery log file in the backup directory
  • FS218-I No backed up continuation log file can be found in the log file directory.
    The Rollforward Recovery Utility has searched unsuccessfully for a backed-up continuation recovery log file in the current log file directory
  • FS219-I No backed up continuation log file can be found in the backup directory.
    The Rollforward Recovery Utility has searched unsuccessfully for a backed-up continuation recovery log file in the backup folder
  • FS220-I A backed up starter log file has been found in the log file directory.
    The Rollforward Recovery Utility has found a backed-up starter log file in the current log file recovery directory.
  • FS221-I A backed up starter log file has been found in the backup directory.
    The Rollforward Recovery Utility has found a backed-up starter log file in the backup directory.
  • FS222-I A backed up continuation log file has been found in the log file directory.
    The Rollforward Recovery Utility has found a backed-up continuation log file in the current recovery log file directory.
  • FS223-I A backed up continuation log file has been found in the backup directory.
    The Rollforward Recovery Utility has found a backed-up continuation log file in the backup directory.
  • FS224-S The log file directory contains more than one backed up starter log file.
    The current log file directory contains more than one backed-up starter log file and so the Rollforward Recovery Utility is unable to determine which one is the correct one to use.
  • FS225-S The backup directory contains more than one backed up starter log file.
    The Rollforward Recovery Utility has searched the backup directory for a backed-up starter log file. The backup directory contains more than one backed-up starter log file and so cannot determine which one is the correct one to use.
  • FS227-W Failure to set Fileshare Server's access rights.
    You only see this message displayed by the Fileshare NLM.
  • FS228-I CCI SEND status checked.
    A request sent back from the Fileshare Server to a client application, which previously had not completed within the expected time period, has now either failed or completed successfully.
  • FS229-I Unrecognized CCI session ID - could not disconnect user.
    The Fileshare Server tried to disconnect a Fileshare Client. However, the CCI session ID is invalid which means that the Fileshare Server cannot find details of this Fileshare Client.
  • FS230-I User : user-IDuser-name
    You see this message when the Fileshare Server has received an error from a CCI module following a communications request. The error message indicates a problem has occurred in contacting a specific Fileshare Client.
  • FS231-S The parameter "nnn" is not numeric.
    You see this message when the Fileshare Server is parsing the information supplied on the command line or in the Fileshare Server configuration file. The option specified requires a value which is numeric, however the value specified is not numeric and so that parameter cannot be processed.
  • FS232-I Date : date.
    This information is written to a Fileshare Server trace file (if one is in use) when the Fileshare Server starts up. It is also written to the Fileshare Server trace file when the date of the previous message written to the trace file is different to the current date and a new message is being written to the trace file.
  • FS233-W Unable to set the maximum amount of dynamic memory to the limit specified.
    This message is only displayed by the Fileshare NLM.
  • FS234-W The parameter "text " specifies a memory limit below the minimum of 6 Mbytes allowed.
    This message is only displayed by the Fileshare NLM.
  • FS235-W Failure to allocate memory for incomplete CCI SEND processing.
    The Fileshare Server has tried to allocate some memory in order to process CCI requests to multiple Fileshare Client sessions simultaneously, but there is insufficient free memory available. Consequently, the Fileshare Server may not be able to process communications requests correctly.
  • FS236-I The log file name has been removed from the database reference file.
    This message indicates that the Database Reference File Maintenance Utility has successfully removed the log file name from the database reference file
  • FS237-S The next log file to use filename already exists, unable to back up current log file.
    The Fileshare Server was unable to create the recovery log file because a file of the same name already exists
  • FS237-W The next log file to use filename already exists, unable to back up current log file.
    The Fileshare Server has tried to back up the current log file but was unable to create a new recovery log file because a file of that name already exists. The Fileshare Server will try to re-open the old log file and continue to write records to it.
  • FS238-I Terminating communications with this user.
    You see this message, together with FS015-W, when the network connection with an unknown Fileshare Client terminates
  • FS239-I Output - user Record locked. Retry operation.
    You see this message when tracing is enabled and an I/O operation returns a status of record locked. The user application making the request is compiled with the RETRYLOCK directive which specifies that the request is automatically retried when a status of record locked is returned. The Fileshare Server sends this message to the Fileshare Client requesting that it retries the operation.
  • FS240-I Output - user File locked. Retry operation.
    You see this message when tracing is enabled and an I/O operation returns a status of file locked. The user application making the request has the Callable File Handler RETRYOPEN option set which specifies that the open request is automatically retried when a status of file locked is returned. The Fileshare Server sends this message to the Fileshare Client requesting that it retries the operation.
  • FS241-I Output - user Insufficient log file disk space. Retry operation.
    You see this message when tracing is enabled and the amount of free disk space available to the Fileshare Server to log updates in the log file is below 200 Kbytes. See the messages FS030-S and FS114-W for further information.
  • FS243-S Failure backing up the file filename1 to filename2.
    During an automatic backup of the data files, an error has occurred while copying the file specified by filename1 to the destination specified by filename2
  • FS244-S Failure restoring the backed up file filename1 to filename2.
    An error has occurred while copying the file specified by filename1 to the destination specified by filename2 during an automatic restoration of the data files before running the Recovery Utility
  • FS245-S Failure deleting the log file filename.
    A failure occurred when Fileshare tried to delete the redundant log file, filename.
  • FS246-I Backing up database files to directory backup directory. Please wait.
    The data files listed in the database reference file are being copied to the directory specified by the /backup option
  • FS247-I Restoring database files from directory backup directory. Please wait.
    The data files listed in the database reference file are being copied from the directory specified by the /backup option to their correct locations in preparation for a Fileshare Recovery
  • FS248-I Commencing automatic Fileshare Recovery.
    This message indicates that the Fileshare Recovery Utility has been automatically invoked because the Fileshare Server has detected that the previous server session did not close down successfully
  • FS249-I Restarting Fileshare Server.
    This message indicates that the automatic Fileshare Recovery has completed successfully and that the Fileshare Server is restarting
  • FS250-I Deleting all unwanted log files.
    This message indicates that Fileshare is deleting redundant log files before re-starting the Fileshare Server when a new log file is created
  • FS251-S Logging must be activated for all files when specifying a backup directory.
    You have specified that update logging is to be switched off for one of the files named in the database reference file but have also specified a backup directory-name. You cannot do this because Fileshare automatically backs up (and restores where necessary) all the files listed in the database reference file, in order to keep them synchronized with the log file, when a backup directory is specified. If logging is not active for all files, Fileshare cannot guarantee that it can restore and recover the correct versions of these files.
  • FS252-S Failure deleting the file filename.
    An error occurred while deleting the file filename during an automatic backup or restoration of the data files
Parent topic: Fileshare Server Messages
Related information
Messages from FS001-S to FS050-W
Messages from FS051-W to FS099-W
Messages from FS101-I to FS149-I
Messages from FS151-I to FS200-W


FS201-S The attempt to backup the log file to "filename" failed.

The Fileshare Server is unable to append to the current recovery log file and is also unable to back it up and so will not start. You should rectify the problem before trying to re-start the Fileshare Server.

Resolution:

Ensure that the filename and directory of the backup file are correct. Also ensure that there is enough disk space in the backup directory for the recovery log file to be copied.

If you are trying to start the Fileshare Server, this message can indicate that you are not following the correct sequence of backing up data files and removing recovery log files. See the section Rollforward Recovery Logging in the chapter Database Integrity for more details.

Parent topic: Messages from FS201-S to FS252-S
Related information
Rollforward Recovery Logging


FS202-I The Fileshare Server will continue logging to the log file "filename".

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS203-I The Fileshare Server is appending to the log file "filename".

This message indicates that you are not following the recommended sequence of backing up data and removing recovery log files. A recovery log file already existed when the Fileshare Server started.

See the section Rollforward Recovery Logging in the chapter Database Integrity for more details.

Resolution:

No action is required

Parent topic: Messages from FS201-S to FS252-S
Related information
Rollforward Recovery Logging


FS204-W The Fileshare Server is unable to log to the log file "filename". Rollforward recovery logging is disabled.

Rollforward recovery logging has been suspended.

Resolution:

Terminate the Fileshare Client applications and shut down the Fileshare Server. Then back up the data files, remove the recovery log file and restart the Fileshare Server to create a new recovery log file.

Parent topic: Messages from FS201-S to FS252-S


FS205-W Unable to remove the old recovery log file "filename".

Resolution:

Ensure that the Fileshare Server has the correct permissions to enable it to delete the old recovery log file. Remove the old recovery log file manually if the backup operation has succeeded. This releases more disk space for recovery logging to take place.

Parent topic: Messages from FS201-S to FS252-S


FS206-S There is more than one starter log file. The Recovery Utility is unable to determine which one to use.

Thus, if the Fileshare Server:

  • Starts and there is no recovery log file available, it creates one
  • Automatically backs up the recovery log file, it backs up the starter recovery log file and creates a continuation recovery log file
  • Performs another back up, it backs up the continuation recovery log file and creates another continuation recovery log file

A rollforward recovery can only proceed when there is only one starter recovery log file to use.

Resolution:

Ensure that the correct recovery log files are in place and then try to re-run the rollforward recovery process.

This message indicates that you are not following the correct sequence of backing up data files and removing recovery log files. See the section Rollforward Recovery Logging in the chapter Database Integrity for more details.

Parent topic: Messages from FS201-S to FS252-S
Related information
Rollforward Recovery Logging


FS207-I There is no starter log file in the log file directory.

The Fileshare Server now searches for a starter recovery log file that has been backed up to the recovery log file backup directory.

Resolution:

If no starter recovery log file is found in the recovery log file backup directory, it is not possible for the rollforward recovery to be performed. Place the correct starter recovery log file in the recovery log file directory and try to re-run the rollforward recovery.

Parent topic: Messages from FS201-S to FS252-S


FS208-S There is no starter log file in the backup directory.

Resolution:

Place the correct starter recovery log file in the recovery log file directory and invoke the Rollforward Recovery Utility again to perform rollforward recovery.

Parent topic: Messages from FS201-S to FS252-S


FS209-I A starter log file has been located in the backup directory.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS210-S There is more than one starter log file in the backup directory.

A rollforward recovery can only start when there is only one starter recovery log file to use.

See the section Rollforward Recovery Logging in the chapter Database Integrity for more information.

Resolution:

Ensure that the correct recovery log files are in place and then re-try the rollforward recovery process.

This message indicates that you are not following the recommended sequence of backing up data files and removing recovery log files.

Parent topic: Messages from FS201-S to FS252-S
Related information
Rollforward Recovery Logging


FS211-S An error occurred checking the header on the log file "filename".

Resolution:

Ensure that the Rollforward Recovery Utility has read and write access to the file indicated. Also ensure that the utility is able to open the file exclusively and that it is not currently in use by another process.

Parent topic: Messages from FS201-S to FS252-S


FS212-I The Rollforward Recovery Utility is processing the log file "filename".

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS213-W Unable to locate the continuation log file "filename" in the log file directory.

The marker at the end of the recovery log file indicates that there is an additional recovery log file to be processed. This message indicates that the Rollforward Recovery Utility cannot find the next recovery log file in the same directory as the previous recovery log file.

The Rollforward Recovery Utility tries to find the next recovery log file in the backup directory if one has been specified.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS214-I Searching for a backed up log file in the log file directory.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS215-I Searching for a backed up log file in the backup directory.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS216-I No backed up starter log file can be found in the log file directory.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS217-I No backed up starter log file can be found in the backup directory.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS218-I No backed up continuation log file can be found in the log file directory.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS219-I No backed up continuation log file can be found in the backup directory.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS220-I A backed up starter log file has been found in the log file directory.

The Rollforward Recovery Utility will open and try to process the recovery log file that it has located.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS221-I A backed up starter log file has been found in the backup directory.

The Rollforward Recovery Utility will open and try to process the recovery log file which it has located

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS222-I A backed up continuation log file has been found in the log file directory.

The Rollforward Recovery Utility will open and try to process the recovery log file which it has located.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS223-I A backed up continuation log file has been found in the backup directory.

The Rollforward Recovery Utility will open and try to process the recovery log file which it has located.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS224-S The log file directory contains more than one backed up starter log file.

It is not possible to start the rollforward recovery process.

This message indicates that you have not followed the recommended sequence of backing up data files and removing unneeded recovery log files. See the section Rollforward Recovery Logging in the chapter Database Integrity for more information.

Resolution:

Ensure that only the correct backed-up starter recovery log file is in the log file directory. Then re-start the rollforward recovery process.

Parent topic: Messages from FS201-S to FS252-S
Related information
Rollforward Recovery Logging


FS225-S The backup directory contains more than one backed up starter log file.

It is not possible to start the rollforward recovery process.

This message indicates that you are not following the correct sequence of backing up data files and removing unneeded recovery log file. See the section Rollforward Recovery Logging in the chapter Database Integrity for more information.

Resolution:

Ensure that only the correct backed-up starter recovery log file is in the backup directory. Then re-start the rollforward recovery process.

Parent topic: Messages from FS201-S to FS252-S
Related information
Rollforward Recovery Logging


FS227-W Failure to set Fileshare Server's access rights.

The Fileshare NLM encountered an error when trying to set the Fileshare Server's access rights on the NetWare operating system.

This operation is performed after an I/O operation has been carried out for a Fileshare Client. Because this operation has failed, the Fileshare Server has assumed the access rights of that Fileshare Client.

This message indicates that the Fileshare Server's connection to the NetWare operating system is no longer valid. The Fileshare Server will try to connect with supervisor access rights to the NetWare operating system.

Resolution:

If this error persists you should contact our technical support department.

Parent topic: Messages from FS201-S to FS252-S


FS228-I CCI SEND status checked.

See also the message FS149.

A second message following this one indicates the outcome of the request in question. If this suggests frequent communications errors, there may be errors on the network or client applications may be terminating abnormally. The request completed normally if no message follows.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S
Related information
FS149


FS229-I Unrecognized CCI session ID - could not disconnect user.

A possible cause of this error is that CCI indicated that a Fileshare Client application program terminated abnormally, but the Fileshare Server is unable to locate details about the Fileshare Client which has terminated.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS230-I User : user-IDuser-name

This message provides information regarding the user-ID and the user-name (if available) of the Fileshare Client that the Fileshare Server tried to contact.

Resolution:

No action is required.

Use details contained in other messages displayed by the Fileshare Server to determine the cause of the error.

Parent topic: Messages from FS201-S to FS252-S


FS231-S The parameter "nnn" is not numeric.

Resolution:

Correct the Fileshare Server command line option or the Fileshare Server configuration file entry so that the value for the parameter indicated is numeric. Then try to re-start the Fileshare Server with the new command line or configuration file.

Parent topic: Messages from FS201-S to FS252-S


FS232-I Date : date.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS233-W Unable to set the maximum amount of dynamic memory to the limit specified.

This message indicates that the Fileshare NLM is configured to use a maximum amount of dynamically-allocated memory (using the /mm option).

The Fileshare Server was unable to set the limit of the amount of dynamically-allocated memory and therefore tries to allocate memory as required, with no upper limit.

Resolution:

The message indicates an internal Fileshare NLM failure. Please contact our technical support department.

Parent topic: Messages from FS201-S to FS252-S


FS234-W The parameter "text " specifies a memory limit below the minimum of 6 Mbytes allowed.

This message indicates that the Fileshare NLM is configured to use a maximum amount of dynamically-allocated memory (using the /mm option).

However, the amount of memory that it is configured to use is below the minimum of 6 Mbytes in which the Fileshare NLM can successfully operate. The Fileshare NLM has set the amount of dynamically-allocated memory it can use up to six megabytes.

Resolution:

Specify a different value for the /mm option so that the amount of dynamically-allocated memory that it can use is at least six megabytes

Parent topic: Messages from FS201-S to FS252-S


FS235-W Failure to allocate memory for incomplete CCI SEND processing.

Making more memory available to the Fileshare Server session after this message has been displayed will not rectify the problem with this particular request, although it might enable the Fileshare Server to allocate memory if it needs to in the future. However, the Fileshare Server process is near the limit of memory available to it which could adversely affect its operation.

See also the message FS149.

Resolution:

Make more memory available by closing other active applications on the machine where the Fileshare Server is running in order to avoid Fileshare Server memory problems in general.

Parent topic: Messages from FS201-S to FS252-S
Related information
FS149


FS236-I The log file name has been removed from the database reference file.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS237-S The next log file to use filename already exists, unable to back up current log file.

Resolution:

The Fileshare Server has not started. Ensure that no file already exists with the same name as that which the Fileshare Server is trying to use for the next recovery log file. Then re-start the Fileshare Server.

Parent topic: Messages from FS201-S to FS252-S


FS237-W The next log file to use filename already exists, unable to back up current log file.

Resolution:

The Fileshare Server continues to run but the back up of the recovery log file has failed. Ensure that no file already exists with the same name as that which the Fileshare Server is trying to use for the next recovery log file.

Parent topic: Messages from FS201-S to FS252-S


FS238-I Terminating communications with this user.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S
Related information
FS015-W


FS239-I Output - user Record locked. Retry operation.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS240-I Output - user File locked. Retry operation.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS241-I Output - user Insufficient log file disk space. Retry operation.

Resolution:

Because the Fileshare Server can no longer guarantee that it can store updates in the log file, it has suspended operations and is waiting for the log file to be removed in order to create more disk space. While operations are suspended any requests from Fileshare Clients are rejected. Refer to messages FS030-S and FS114-W

Parent topic: Messages from FS201-S to FS252-S
Related information
FS030-S
FS114-W


FS243-S Failure backing up the file filename1 to filename2.

Resolution:

Ensure that no other process is currently accessing either filename1 or filename2 and that the Fileshare Server has sufficient access permissions to carry out this operation.

Parent topic: Messages from FS201-S to FS252-S


FS244-S Failure restoring the backed up file filename1 to filename2.

Resolution:

Ensure that no other process is currently accessing either filename1 or filename2 and that the Fileshare Server has sufficient access permissions to carry out this operation. Then re-start the Recovery Utility. If this was invoked automatically during the Fileshare Server start-up, you also need to re-start the server manually once the recovery has completed successfully.

Parent topic: Messages from FS201-S to FS252-S


FS245-S Failure deleting the log file filename.

Resolution:

Ensure that no other process is accessing the file and that the Fileshare Server has sufficient permissions to delete the log file. Fileshare cannot start up and log updates to the correct log file until the redundant log file is deleted. Once the problem is rectified you need to restart the Fileshare Server.

Parent topic: Messages from FS201-S to FS252-S


FS246-I Backing up database files to directory backup directory. Please wait.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS247-I Restoring database files from directory backup directory. Please wait.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS248-I Commencing automatic Fileshare Recovery.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS249-I Restarting Fileshare Server.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS250-I Deleting all unwanted log files.

Resolution:

No action is required.

Parent topic: Messages from FS201-S to FS252-S


FS251-S Logging must be activated for all files when specifying a backup directory.

Resolution:

If you are adding the name of a data file to the database reference file, you must add it without specifying the /o l option.

If you are adding a backup directory-name using the /backup option, you should first remove any database reference file entries for files which have logging switched off

Parent topic: Messages from FS201-S to FS252-S


FS252-S Failure deleting the file filename.

Resolution:

Ensure that no other process is accessing the file and that the Fileshare Server has sufficient permissions to delete it. You will then need to re-start the Fileshare Server or the Fileshare Recovery Utility (depending on which you were trying when the error occured).

Parent topic: Messages from FS201-S to FS252-S


Mainframe Programming

  • Mainframe Subsystem Support Developer Introduction
    Contains Mainframe Subsystem Support information for developers.
  • Assembler Support
  • CICS Support
    This chapter describes the technical aspects of developing CICS applications.
  • IMS Support
  • JCL Support
    This chapter describes the support for JCL provided within Studio Enterprise Edition.
  • Mainframe Emulation
  • HCO for SQL Server (HCOSS)
  • PL/I Programming
  • Service Interfaces Using the IMTK
    Building service interfaces using the Interface Mapping Toolkit.
  • SQL Option for DB2
  • Communications and Client/Server Binding
Parent topic: Programming


Mainframe Subsystem Support Developer Introduction

This book explains how to use MSS to develop CICS , IMS and JCL applications that run under Server Enterprise Edition.
  • What is Mainframe Subsystem Support?
  • About CICS applications
  • About IMS applications
  • About JCL applications
  • Configuring Enterprise Server to Run the Application
  • CICS Intersystem Communication
  • Terminal Emulation
Parent topic: Mainframe Programming


What is Mainframe Subsystem Support?

Mainframe Subsystem Support (MSS) enables you to maintain and run CICS, IMS and JCL applications. These applications have been migrated from the mainframe and now run under Server Enterprise Edition on Windows or UNIX.

You use Studio Enterprise Edition for maintaining your CICS, IMS and JCL applications. If you are working with CICS, you can edit and compile BMS maps, and also compile the CICS programs, using the Micro Focus CICS preprocessor, which translates the CICS commands into native code. If you are working with IMS, you can edit and generate your DBDs, MFSs and PSBs, and compile your IMS programs. If you are working with JCL, you can edit and create JCL, and build projects containing the programs that the JCL references. When the application is ready to run, you then deploy it to Server Enterprise Edition.

You use Server Enterprise Edition for running your CICS, IMS and JCL applications, for testing and for production use. Server Enterprise Edition also provides facilities for monitoring and controlling your applications and for other tasks such as maintaining CICS resource definitions and viewing the system catalog and spool queues.

  • Migrating the Application
Parent topic: Mainframe Subsystem Support Developer Introduction


Migrating the Application

System integrators are typically responsible for migrating the CICS, IMS and JCL applications from the mainframe. They download the applications to the Windows or UNIX environment, and leave you with a working application, running under Enterprise Server.

In some cases the system integrators might use Micro Focus Mainframe Express to migrate your CICS or IMS applications. They replace one mainframe-only language or technology at a time, and make sure that the application works correctly before continuing. For example, if your application includes Assembler and PL/I modules, they might replace the Assembler modules with COBOL modules. They would then recompile and test the application thoroughly before moving on to replace the PL/I modules.

When the system integrators have got the application up and running under Enterprise Server, they hand over to you to maintain and develop the applications in Studio Enterprise Edition, and to run the applications under Enterprise Server.

This book assumes that your application has been migrated from the mainframe, and that it runs successfully under Enterprise Server.

Parent topic: What is Mainframe Subsystem Support?


About CICS applications

When the CICS application has been migrated from the mainframe to the PC, you maintain and develop the application as follows:

  1. Create a project comprising all the parts of the application, such as the COBOL source and BMS mapsets. This also involves specifying the appropriate project and build properties.
  2. Edit BMS mapsets used by your client program, as required.
    Note: If you have our Net Express product installed, you can do this using its BMS Screen Painter.

    If your client program uses a graphical or Web interface, use the IBM External Call Interface (ECI) to communicate with the CICS application.

  3. Compile the CICS COBOL programs and BMS mapsets.
  4. Configure an enterprise server to run the CICS application. This involves, among other things, adding a listener for CICS requests and setting up search paths to locate your application files, the CICS resource definitions and so on.
  5. Run the application in Enterprise Server and check that it is working correctly. Use the facilities for monitoring CICS applications within Enterprise Server, as necessary.
  6. Debug the application in your COBOL development system IDE.
  7. To publish the application to UNIX:
    1. Copy the source files to your UNIX machine.
    2. Compile the programs using the Cob utility.
    3. Test and debug the application using our Server Express product.
  • Micro Focus BMS Screen Painter
  • IBM External Call Interface (ECI)
  • CICS Application Programming Interface (API)
  • File and Database Support
  • CICS ECM Preprocessor
Parent topic: Mainframe Subsystem Support Developer Introduction
Related information
Developing CICS Applications


Micro Focus BMS Screen Painter

If your application uses Basic Mapping Support (BMS) mapsets, which provide the user interface, you might need to update these. The Micro Focus BMS Screen Painter enables you to do this.

The painter provides a screen painting facility that enables fields, labels, and attributes to be defined and positioned as they would be for a 3270 display device. It provides fast BMS screen definition and manipulation with powerful features like block moves and copies through simple use of a keyboard or mouse. It supports most standard BMS macro operands plus long data names and allows the construction of repeated groups of fields in a manner similar to the IBM Screen Definition Facility (SDF II).

BMS macro output is fully portable to mainframe CICS. Mapset painting and generation are supported for 3270 models 2 through 5.

  • Starting the BMS Painter Utility
  • Overview of the BMS Painter
    The BMS Painter is a powerful, flexible tool for designing maps and generating the BMS macros necessary for creating displayable mapset objects. The painter can also generate the corresponding copybooks needed for using these maps from your program, and compile them into executable modules.
  • Starting the BMS Painter Utility
  • Configuring the Painter
    You can configure the BMS screen painter using the BMS Screen Painter Options dialog box.
  • Build Settings for the BMS Screen Painter
    You specify BMS build settings for the BMS screen painter in the properties of the BMS file within Studio Enterprise Edition.
  • Working with Maps
  • Defining Field, Map and Mapset Properties
    You define the properties of fields, maps and mapsets using the Field Properties, Map Properties and Mapset Properties dialog boxes.
  • Working with Previously Created Maps
    You can open and work on a mapset that has been downloaded to your PC from the mainframe but as yet does not belong to a project.
  • Generating Output from the Painter
  • mfbmscl Command Line Tool
    Compiles BMS mapsets from the command line.
  • BMS Screen Painter Technical Details
  • BMS Directives
    There are a number of Compiler directives that are applicable to BMS files, and depending on the directive, can be set one of two ways.
  • BMS Painter Keyboard Shortcuts
    There are several keyboard shortcuts that you can use to navigate around the map view of the BMS Painter window.
  • BMS Painter Compile Messages
  • BMS Painter Generate Messages
Parent topic: About CICS applications
Parent topic: Mainframe Reference


Starting the BMS Painter Utility

  1. Start Net Express - Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Compatibility Tools > Net Express.
  2. Click File > Open and set Files of Type to Basic Mapping Support (BMS) File (*.bms).
  3. Navigate to the location of the .bms file to edit, select the file, and click Open. This opens the file in the BMS Painter within Net Express.
    Note: Alternatively, you can configure the IDE to always open .bms files with Net Express:
    1. Open your Mainframe Subsystem Project with Visual Studio.
    2. In Solution Explorer, right-click the .bms file in your project.
    3. Click Open With.
    4. Click Add.
    5. Click the browse button on the row for Program name, navigate to the install location of the Net Express program, <StEE-install-dir>\Base\Bin, select MFNETX.EXE, click Open, and then click OK twice.
  4. Use the Micro Focus BMS Painter to edit your maps and mapsets.
Parent topic: Micro Focus BMS Screen Painter


IBM External Call Interface (ECI)

The client program for your CICS application need not use BMS. You can have a graphical/ Web user interface that is written in Java or runs under Microsoft .NET or uses Dialog System. In this case you use the IBM External Call Interface (ECI) to communicate with the CICS application.

You use ECI calls in your client program to communicate with the CICS application running under Enterprise Server. The ECI calls from your client program are passed through the IBM CICS Transaction Gateway to Enterprise Server.

Enterprise Server supports standard ECI calls to Mainframe Sub-System regions. ECI allows non-CICS programs running outside the server to invoke COMMAREA-based CICS programs within a region, opening up access to legacy business logic.

ECI client programs can be running on the same machine as the enterprise server or on different physical hardware. In either case the requests are submitted to the target region through the communication layer via the “Web Services and J2EE” listener.

Client-side support

The ECI entry points such as CICSEXTERNALCALL are exposed by the casbnccl module which is supplied as a dynamic load library on Windows and a callable shared object on UNIX and Linux platforms.

Client programs should call this module either by coding a CALL statement or by using an INITCALL(casbnccl) compilation directive.

Configuration

ECI support is enabled by default in an MSS type region - no further configuration of the server is required.

The region to which the request is directed is identified through the ECI-SERVER variable in the ECI parameter block and takes a null or space padded value which must match a server defined in the target MFDS repository. The location of this can be specified either by editing the mf-client.dat file found in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin by default, or by setting the environment variable ES_ECI_CCITCP2 to the value <host>:<mfds-port>, for example ES_ECI_CCITCP2=localhost:86. You can also override and bypass the lookup by setting the environment variable ES_ECI_SOCKET to the value <host>:<Web-Services-listener-port>.

Parent topic: About CICS applications


CICS Application Programming Interface (API)

A large subset of the command-level API of IBM CICS is supported and provides the expected behavior for programs written using this syntax. Most syntax that is not functionally supported is recognized so that programs using these commands and operands will compile without change. Much of the CICS system programming interface is also supported; some CICS APIs in MSS return fixed, default values, rather than values that the mainframe might return.

Parent topic: About CICS applications


File and Database Support

Data access is supported for data in emulated VSAM files, IMS databases, and relational database systems.

VSAM file emulation is supported for ESDS and RRDS files and KSDS data sets, which can also be shared with non-CICS (batch) applications. Fileshare provides data integrity for VSAM emulation for application data files, temporary storage and transient data queues. Alternate indexes are supported for application data files. Emulated VSAM files use standard Micro Focus file formats.

Support is provided to the XA-compliant SQL databases from Oracle and IBM DB2/UDB.

Parent topic: About CICS applications


CICS ECM Preprocessor

The CICS command syntax is recognized by the CICS External Compiler Module (ECM) preprocessor, which runs as part of the program compilation step. The preprocessor scans the program source for EXEC CICS commands and replaces them with native statements for the language in which the program is written.

We provide two methods of invoking the CICS ECM:
  • On the COBOL tab in your Visual Studio project properties, check EXEC CICS (preferred method).
  • Set the CICSECM compiler directive when compiling on the command line, or in your program.
Parent topic: About CICS applications


About IMS applications

When the IMS application has been migrated from the mainframe to the PC, you maintain and develop the application as follows:

  1. Create a project comprising all the parts of the application, such as the COBOL source DBD, MFS and PSB files. This also involves specifying the appropriate project and build properties.
  2. Compile the IMS COBOL programs and generate the DBD, MFS and PSB files.
  3. Configure an enterprise server to run the IMS application. This involves, among other things, setting up search paths to locate your application files, and specifying the message processing regions in which your application will run.
  4. Run the application in Enterprise Server and check that it is working correctly. Use the facilities for monitoring IMS applications within Enterprise Server, as necessary.
  5. Debug the application in your COBOL development system IDE.
  6. To publish the application to UNIX:
    1. Copy the source files to your UNIX machine.
    2. Compile the programs using the Cob utility. See the Server Express Help.
    3. Test and debug the application using Server Express.
Parent topic: Mainframe Subsystem Support Developer Introduction
Related information
IMS Installation Verification
Developing IMS Applications


About JCL applications

When the JCL application has been migrated from the mainframe to the PC, you maintain and develop the application as follows:

  1. Create a project comprising all the parts of the application, such as the COBOL source JCL files. This also involves specifying the appropriate project and build properties.
  2. Compile the COBOL programs.
  3. Configure an enterprise server to run the JCL application. This involves, among other things, setting up search paths to locate your application files, the system catalog and so on.
  4. Run the application in Enterprise Server and check that it is working correctly. Use the facilities for monitoring JCL applications within Enterprise Server, as necessary.
  5. Debug the application using Studio Enterprise Edition.
  6. To publish the application to UNIX:
    1. Copy the source files to your UNIX machine.
    2. Compile the programs using the Cob utility.
    3. Test and debug the application using our Server Express product.

File and database support is the same as for CICS applications.

Parent topic: Mainframe Subsystem Support Developer Introduction
Related information
JCL Support


Configuring Enterprise Server to Run the Application

When the CICS, IMS or JCL application has been compiled, you run it under Enterprise Server. If you have CICS, IMS or JCL applications already running under an enterprise server, you might be able to use that enterprise server. Alternatively, if you want to run the application on your own machine under your own enterprise server, you need to configure an enterprise server for running CICS, IMS or JCL applications.

The Enterprise Server Administration console and Enterprise Server Monitoring and Control (ESMAC), provide facilities to do this. Among other tasks, you need to:

  • Update the resource definitions for the application, as necessary. The resources include system initialization tables (SITs), startup lists, transactions, programs and so on (CICS and JCL only).
  • Set up search paths to locate the programs, data files and other resources that your application uses.
  • Adjust the data conversion templates as necessary (CICS only).
  • Add an enterprise server listener to listen for CICS requests (CICS only).
  • CICS, IMS and JCL Resources
  • Data Conversion
Parent topic: Mainframe Subsystem Support Developer Introduction
Related information
Administering CICS-enabled Enterprise Servers
Administering JCL-enabled Enterprise Servers
Administering IMS-enabled Enterprise Servers


CICS, IMS and JCL Resources

The resources that your CICS application uses need to be defined, so that you have a CICS environment in which you can run and debug your applications. The resource definitions are set up as part of the migration of your application from the mainframe. They are stored in a Resource Definition file called dfhdrdat.

IMS and JCL applications also use CICS-style resource definitions, defined in the dfhdrdat file.

The resource definitions include:

  • A system initialization table (SIT)

    The SIT defines the initialization parameters to use when the enterprise server that runs your application is started. You might need to change some of these parameters for your project.

    A SIT is required for CICS, IMS and JCL applications.

  • A startup list

    The startup list contains the list of the groups of resources to be used. Enterprise Server loads all the groups in the startup list. The base startup list dfhlist contains recommended system groups that you should include in all your user-defined startup lists.

    A startup list is required for CICS, IMS and JCL applications.

  • Resource groups

    Resource groups are sets of resource definitions that define the programs and files that are used by the enterprise server running your application. If you create any resource groups you need to add them to the startup list, or you can add them at execution time in Enterprise Server with the CINS supplied transaction.

    Resource groups for CICS include:

    • Program Control Table (PCT) - this defines the transactions that your application uses
    • File Control Table (FCT) - this defines information about the files that your application uses, such as the file type (KSDS, ESDS, RRDS) and minimum and maximum record length
    • Processing Program Table (PPT) - this defines the programs that are invoked by transactions or other programs.

    The only resource group you need for JCL is a JES resource group. This contains definitions of special service execution processes which start when the enterprise server is started, and which run JCL jobs and handle the sending of job output to a printer.

    IMS applications also need to use the JES resource group, as it contains definitions of the message processing regions (MPRs) which start when the enterprise server is started.
Parent topic: Configuring Enterprise Server to Run the Application


Data Conversion

CICS applications on the mainframe run with an EBCDIC character set. PCs use an ANSI character set, while on UNIX the character set in use is ASCII. When CICS applications are migrated from the mainframe, the majority of them are converted to use ANSI or ASCII, and they run under Enterprise Server using ANSI or ASCII. However, there are some cases where an application needs to continue to use EBCDIC on the server, while the client program uses ANSI or ASCII. In these cases, you need to set up data conversion macros to ensure the data is converted.

For details see the section Data Conversion in the chapter Legacy Extension with MSS in your MSS Configuration and Administration Guide.

Parent topic: Configuring Enterprise Server to Run the Application


CICS Intersystem Communication

CICS applications can operate over networks in client/server, cooperative, and distributed processing modes.

The supported CICS intersystem communication facilities include:

  • Transaction routing
  • Function shipping
  • Distributed program linking (DPL)
  • Distributed transaction processing (DTP)
  • IBM CICS Transaction Gateway® (CTG). Enterprise Server provides a CTG listener and can process CTG requests, where the requests conform to the IBM External Call Interface (ECI). The client program contains ECI calls, which send requests through the CTG to Enterprise Server.
  • IBM Universal Client®. This is effectively the same as the CTG.

For more information about using these facilities, see the chapter Legacy Extension with MSS in your Mainframe Subsystem Support Configuration and Administration Guide.

Parent topic: Mainframe Subsystem Support Developer Introduction


Terminal Emulation

The user interface to CICS and IMS applications from the PC is often through 3270 terminal emulators. The 3270 terminal emulators enable the CICS and IMS applications to display input and output screens on the PC using 3270 data streams and to receive input from the PC. It is intended for programs that use BMS or build 3270 data streams. Emulation is provided for 3270 models 2 through 5.

We recommend that you use a Telnet 3270 (TN3270) client such as Micro Focus RUMBA. The keyboard mapping and support for character level attributes is a property of the third-party TN3270 client you choose.

When you start a 3270 terminal emulator, it is separate from the enterprise server that runs the CICS or IMS application. Terminals do not need to be predefined. This means terminal emulation characteristics can be specified at terminal startup.

Server Enterprise Edition needs to have a listener for requests from 3270 terminal emulators. You add this as part of configuring the enterprise server that will run your CICS or IMS application.

Parent topic: Mainframe Subsystem Support Developer Introduction


Assembler Support

Studio Enterprise Edition Assembler support allows you to import assembler programs into your project, and to use the trace and debug functionality to debug these programs.

Note: The current version of the product is aimed at the early adopter. Our Assembler support does not allow you to include assembler program components in your run-time applications. Once you have an assembler component working, you need to re-write it in COBOL in order to include it in a deployed application.
  • Assembler Support Overview
  • Configuring Assembler Project File Locations
  • Compiling and Linking Assembler Modules
  • Configuring Runtime Memory Requirements
  • Configuring a Program's Memory Requirements
  • File Handling
  • Using the Generalized Trace Facility
Parent topic: Mainframe Programming


Assembler Support Overview

Assembler support enables you to include Assembler modules in your projects. As with COBOL programs, you can edit and compile the Assembler source code on your PC. You can also create new Assembler modules.

Assembler support enables you to:

  • Compile and link your Assembler source code including copybooks and macros provided with Studio Enterprise Edition, or ones you have written yourself.
  • Trace and debug your Assembler modules.
Note: Assembler support does not allow you to include assembler program components in your run-time applications. Once you have an assembler component working, you need to re-write it in COBOL in order to include it in a deployed application.
  • About Developing Assembler Applications
  • About Creating Editing and Navigating Source Code
  • About the MF370CTL.CFG configuration file
Parent topic: Assembler Support


About Developing Assembler Applications

Assembler programs usually have file extensions of .MLC or .ASM and can be included into any Studio Enterprise Edition project.

Assembler modules with EXEC CICS statements in them are usually identified with the file extension .CAP. When these modules are added to your project you can assemble and link them into either data tables with the extension .MOD, or as executable modules with the extension .390.

Note:
  • Only assembler modules are linked to form executable modules.
  • Cobol modules cannot be linked with 390 assembler modules. Even though assembler modules have the .OBJ file extension these modules are not compatible with any Microsoft linker, and can only be linked with the Micro Focus assembler linker.

    As a result while assembler modules can be linked to make assembler to assembler calls static or dynamic, all Assembler to COBOL or COBOL to assembler calls must be dynamic.

Parent topic: Assembler Support Overview


About Creating Editing and Navigating Source Code

You create and edit the source code for the Assembler modules in your project in the same way as the source code for your COBOL modules.

Some of the IDE's facilities for navigating source code are available for Assembler source code; these are:

  • Find and replace text
  • Find in files
Note: For source code downloaded from a mainframe, you might want to consider removing the sequence numbers in positions 73 through 80 of each record. The source files for Assembler support are line-sequential, variable-length files. If you omit the sequence numbers, you can also omit the trailing blanks at the end of each instruction. This can result in a significant saving of disk space on a PC.

The presence of these sequence numbers does not cause errors at Assembly time.

Parent topic: Assembler Support Overview


About the MF370CTL.CFG configuration file

The MF370CTL.CFG file holds environment variable configurations for:

  • Project file locations
  • Default memory size
  • Run Time Virtual Memory settings
  • Fileshare pathnames
  • Controlling the Generalized Trace Facility (GTF)
  • Configuring the default SQA memory size

By default, this configuration file is located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin installation directory, but you can create a copy in your working directory. When you compile or run applications, the vaues set in the project's working directory version override the values set in the copy in the default directory.

Note: You can use create a copy of the configuration file in your working directory that contains project-specific settings to override the default values.
Parent topic: Assembler Support Overview
Related concepts
Setting Addressing Mode and Residency Mode
Configuring a Program's Memory Requirements
Introduction to File Handling
Turning GTF on and Specifying Options
Configuring the Default SQA Memory Size


Configuring Assembler Project File Locations

You can use sub-directories to hold the Assembler modules and input and output file types. For these files, all assembler input and output locations are controlled by setting specific environment variables.

To set sub-directory locations, you can use the MF370CTL.CFG configuration file, or you can configure environment variables from the user interface or the command prompt, or you can use a combination of both.

Note: Environment variables set from the user interface or from the command prompt override any environment variables set in the MF370CTL.CFG file.

For example, you can use the command line or a command file to temporarily override the project file locations set using ta configuration file.

  • Using the Configuration File to Set Locations
  • Using a Command File to Configure Locations
  • Component Location Environment Variables
Parent topic: Assembler Support
Related concepts
Component Location Environment Variables
Using a Command File to Configure Locations
Example: Using a Command File to Set Locations


Using the Configuration File to Set Locations

You can use the MF370CTL.CFG configuration file to set the varable=value pairs that the assembler uses. You can use a MF370CTL.CFG file to maintain a project's variables in one place.

By default, this configuration file is located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory.

It can be helpful to copy the assembler configuration and control file, MF370CTL.CFG, into your working directory and edit the environment variables in the file to customize where input and output files should be located in your project.

Note: Environment variables set from the user interface or in the environment override any environment variables set in the MF370CTL.CFG file.
  • Example: Using MF370CTL.CFG to Set Locations
Parent topic: Configuring Assembler Project File Locations


Example: Using MF370CTL.CFG to Set Locations

The following example illustrates how to use a MF370CTL.CFG file to configure project file locations.

Consider the following project directory structure:
  • Project directory: c:\bugs\envtest
  • Source code directory: c:\bugs\envtest\source
  • Listing file directory: c:\bugs\envtest\listing
  • Object and executable file directory: c:\bugs\envtest\debug

Setting the following environment variables configures this structure:

  • SYSLIN=.\DEBUG
  • SYSLIST=.\LISTING
  • SYSLMOD=.\DEBUG

If run from the current directory command line the command:

RUN MF370CHK SOURCE\BR14 NOANIM LIST;

results in BR14.OBJ and BR14.390 placed in \debug, while the listing file BR14.PRN is placed in \listing.

To use a MF370CTL.CFG file to make these settings, you would configure the file as follows:

*------------------------------------------------------------
* The following environment variables take a single directory:
* SYSIN - Macro input .MLC files
SYSIN=.
*
* SYSLIST  - Assemble and Link listing files .MAT .PRN .LST
SYSLIST=.\listing
* SYSWORK  - Assemble, Link and Animator/370 work files .BAL .IDF/.IDX
SYSWORK=.
* SYSPUNCH - Assemble output .PCH files for PUNCH statements
SYSPUNCH=.
* SYSMPC   - Assemble input precompiled macros .MPC
SYSMPC=.
* SYSLIN   - Link input .LIN files and Assemble output .OBJ files
SYSLIN=.\debug
* SYSLMOD  - Link output load-member .390 files
SYSLMOD=.\debug
Parent topic: Using the Configuration File to Set Locations


Using a Command File to Configure Locations

You can configure project locations using a command file to set the necessary environment variables:

For example, you could create a command file to hold temporary locations. Before a compile, you could then run this command file to override the locations set in the configuration file.

  • Example: Using a Command File to Set Locations
Parent topic: Configuring Assembler Project File Locations
Related concepts
Component Location Environment Variables
Configuring Assembler Project File Locations
Example: Using a Command File to Set Locations


Example: Using a Command File to Set Locations

The following command file configures the following project file locations:

  • The assembler reads all assembler source code files from the \mlclib directory.
  • The assembler looks for all macro and copyfiles from directory \maclib and \copylib
  • Linker input files, .LIN, are taken from \linlib
  • Output files such as .BAL files are written to \worklib
  • Object files are written to \loadlib
  • Listings are written to \listing
rem *--------------------------------------------------------------------------
rem * Tell the assembler where to find all input files:
rem *
rem * MLC's from SYSIN
rem * MAC's and CPY's from SYSLIB
rem * LIN files from SYSLIN
rem * OBJ files are both input (by the linker) and output (by the assembler)
rem *     so OBJ file locations are set by SYSLIN
rem *
set SYSIN=.\mlclib
set SYSLIB=.\maclib;.\copylib
set SYSLIN=.\linlib
rem *--------------------------------------------------------------------------
rem * Tell the assembler where to write all output files.
rem *
rem * BAL/IDF/IDX files are output to SYSWORK if specified
rem * LISTING files go to SYSLIST
rem * 390 files go to SYSLMOD
rem *
set SYSWORK=.\WORKLIB
set SYSLIST=.\LISTING
set SYSLMOD=.\loadlib
rem *
rem *  Now try an assembly and a link
rem *  Note the use of the BAL assembler option to get the
rem *  assembler to produce a TEST.BAL file.  The .BAL file
rem *  should go into the SYSWORK= directory
rem *
run mm370asm test.mlc bal noanim
run mf370lnk test noanim
rem *
Parent topic: Using a Command File to Configure Locations
Related concepts
Component Location Environment Variables
Configuring Assembler Project File Locations
Using a Command File to Configure Locations


Component Location Environment Variables

Set the following environment variables to a directory path or paths to define locations. For variables that can hold multiple paths, use a semi colon (;) to separate each entry.

OBJ370
The paths for Link input .OBJ files. SYSLIN must also be set.

You can specify multiple paths, each separated by a semi colon.

STEPLIB
The paths for Loader input load-members .390 files (must contain SYSLMOD) .

You can specify multiple paths, each separated by a semi colon.

SYSIN
The path for macro input .MLC files.

You can specify a single path only.

SYSLIST
The path for Assemble and Link listing files: .MAT, .PRN, and .LST.

You can specify a single path only.

SYSWORK
The path for Assemble, Link and Animator/370 work files .BAL .IDF/.IDX.

You can specify a single path only.

SYSPUNCH
The path for Assemble output .PCH files for PUNCH statements.

You can specify a single path only.

SYSMPC
The path for Assemble input precompiled macros: .MPC.

You can specify a single path only.

SYSLIB
The paths for Assemble input macro and copy files .MAC .CPY.

You can specify multiple paths, each separated by a semi colon.

SYSLIN
The path for Link input .LIN files and Assemble output .OBJ files.

You can specify a single path only.

SYSLMOD
The path for Link output load-member .390 files.

You can specify a single path only.

Parent topic: Configuring Assembler Project File Locations
Related concepts
Configuring Assembler Project File Locations
Using a Command File to Configure Locations
Example: Using a Command File to Set Locations


Compiling and Linking Assembler Modules

This chapter provides detailed information about compiling and linking Assembler modules.

Important: Only assembler modules can be linked together. Unlike on the mainframe, COBOL and Assembler modules cannot be linked together.
  • About Compiling and Linking Assembler Modules
  • Setting Compiler Directives
  • Compiling Assembler Copybooks and Macros Containing EXEC CICS Statements
  • Linking Modules
  • Entry Point Mapping
Parent topic: Assembler Support


About Compiling and Linking Assembler Modules

In Studio Enterprise Edition, compiling and linking is a one-stage process that takes place when you click Build or Rebuild on the Build menu. You control the process by specifying build settings for Assembler. You can do this either for the whole project or for the individual source file.

If you are compiling a single Assembler module that does not use CICS, and you want to debug the module, you should not need to change any of the default build settings.

If your project contains an Assembler executable that is created by linking several Assembler object modules into one single executable, then you may need to alter the build settings for linking.

If any of the Assembler modules in your project use 24-bit addressing rather than the default 31-bit addressing, you may need to alter project settings and build settings that affect the type of memory and addressing used at execution time. It is critical that any COBOL parameter passed to an AMODE(24) Assembler module resides below the 16 megabyte addressing line so it can be accessed by the Assembler module. This is typically done by compiling the COBOL module with the AMODE(24) or DATA(24) compiler options.

Parent topic: Compiling and Linking Assembler Modules


Setting Compiler Directives

You can use directives to control the way the Assembler Compiler behaves. For normal operation you need no more than a few directives. Most of the time, you use the default values.

Note: Setting some directives affects the default setting of other directives. For example, setting one directive might automatically unset another directive, and some directive settings are mutually exclusive.

You can set directives in the IDE simply by making selections on the Assembler page of your project properties. These appear in Build Settings at the bottom of the page.

You can also enter directives not already set by typing them into Additional Directives. As you type into Additional Directives, the directives you add appear in Build Settings.

Directives set at project level automatically apply to all Assembler programs within the project, unless you override them at program level.

The build settings are distributed over two Assembler tabs on the Assembler properties page: Assemble and Linker. You can set directives to:

  • Create debug information. The compiler stores the debug information in files filename.idf and filename.idx, where filename is the name of your program.
  • Create optimized code. An optimized code compilation fully resolves references to addresses in macro code. If the compilation of your program involves the execution of many macros, you can reduce the total compilation time by specifying this directive.
  • Mark the code as serially reusable. This prevents reloading of the module each time it is called.
  • Generate a listing file with optional cross-reference listing.
  • Link the module automatically; see the topic Linking Modules for more information.
  • Mark the code as re-entrant. This has the same effect as marking code as serially reusable.
  • Resolve external calls at link time; see the section Linking Modules for more information.
  • Set addressing mode and residency mode.
  • Specify what type of load module is to be produced, an executable code file or a data table.
  • Specify whether the module includes EXEC CICS commands, which require preprocessing. If an Assembler copybook includes EXEC CICS commands you must perform some additional steps, as described in the topic Compiling Assembler Copybooks and Macros Containing EXEC CICS Statements.
  • Use macros that have been partly pre-compiled, rather than recompiling them from the source file. If a macro source file has changed since the date of pre-compilation, it is recompiled anyway. If you have changed a copybook that is included in a macro file, you should always recompile the macro file from the source file.
  • Create Assembler Analysis Tool files. These are files that assist in the analysis of Assembler programs.
  • Provide a value for $SYSPARM, which is a variable that can be used within an Assembler module to determine which parts of the code to assemble.
Note: You can also set compiler and linker directives at the command line, and you can set directives for individual programs on the Property Pages dialog box for each.
Parent topic: Compiling and Linking Assembler Modules


Compiling Assembler Copybooks and Macros Containing EXEC CICS Statements

Compiling an Assembler copyboook or macro that contains EXEC CICS statements results in error ASMCM0060S ("Undefined operation code") if the file extension .MLC is used instead of .CAP.

This is because with these extensions, the EXEC CICS statements are not pre-processed before the copybook or macro is compiled, and the Assembler Compiler tries to interpret the EXEC statement as a macro. This results in the ASMCM0060S error mentioned above.

If Assembler modules with EXEC CICS in them are given the file extension .CAP, then the assembler runs the Assembler CICS preprocessor on them before assembling, and no errors result.

You can also set Studio Enterprise Edition to run the Assembler CICS preprocessor on an assembler file with the .MLC extension. To do this, perform the following additional steps:

  1. Right-click on the program name and then click Properties for the module on the popup menu.
  2. Specify the following build settings on the Preprocessor page; then click OK:
    1. Ensure EXEC CICS is checked.
    2. Click Options.
    3. Check or uncheck Insert standard prolog macros (DFHEIENT, DFHEIEND & DFHEISTG) and Insert standard epilog macro (DFHEIRET) as needed for your Assembler module. For example, if your module has already coded an EXEC CICS compatible prolog then there is no need for the Assembler CICS preprocessor to insert one.
    4. Click Close.
  3. Compile the module.

    This creates loadlib\<program name>.bal (the preprocessor output with macros expanded) and loadlib\<program name>.pac (the preprocessor output without macros expanded).

  4. Copy loadlib\program name.pac to copylib\program name.cpy as appropriate.

You can now compile without errors.

Note: We recommend you create a separate Studio Enterprise Edition project to handle Assembler copyboooks and macros that contain EXEC CICS statements as this enables you to keep your other projects separate from those that require special processing.
Parent topic: Compiling and Linking Assembler Modules


Linking Modules

When you build a project containing one or more Assembler modules, the Assembler Compiler first creates an object code file (.obj) for each module. Next, you can either have the Assembler compiler automatically link the object code file into an executable load module (.390) or you can run a separate linker process that combines several object modules into a single linked load module. The link process uses its own link file (.lin) containing link commands. The Assembler automatically searches for external references in CALL commands in the object code files and includes additional object code files as necessary to resolve the external references.

Linking modules when you build the project is known as static linking. You can also link modules dynamically at execution time, when external references in LINK or LOAD commands are resolved.

  • Program Structures and Static Linking
  • Dynamic Linking
  • Mixing Static and Dynamic Linking
  • Assembler Modules that call COBOL Modules
  • Link File INCLUDE Commands
  • Other Link File Commands
Parent topic: Compiling and Linking Assembler Modules


Program Structures and Static Linking

You can statically link one or more Assembler modules in several types of executable program structure, using build settings and an optional link file. Your executable program can consist of :

  • A single Assembler module which is either executed stand-alone or is dynamically called from another Assembler program or a COBOL program.
  • Several Assembler modules, one of which is the main module that calls the other modules. The main module calls the called modules using their external names (that is, there is only one entry point in each called program).
  • Several Assembler modules, one of which is the main module that calls the other modules. The main module calls the other modules using entry points other than the modules' external names.
  • Single Assembler Module
  • Multiple Assembler Modules with Calls Using External Names
  • Multiple Assembler Modules with Calls Using Entry Points
Parent topic: Linking Modules


Single Assembler Module

To link a single stand-alone Assembler module, you simply need to ensure that Automatically link module is checked. You can find this check box on the Link page of the Property Pages for the module.

Parent topic: Program Structures and Static Linking


Multiple Assembler Modules with Calls Using External Names

To link multiple Assembler modules where all the calls reference the external names of the called modules, you need to ensure that Automatically link module and Resolve external calls at link time are checked for the main module (the calling module) and unchecked for the called modules.

Note: When linking modules for the first time you may want to uncheck Resolve external calls to prevent the linker from automatically generating stub modules for them. Then you can see any missing assembler or COBOL reference that are required for this module.

You can find both these check boxes on the Link page of the Property Pages for the module or the Assembler tab on your project properties Assembler page.

Since all the calls reference the modules' external names, the Assembler Compiler finds and locates all the called modules in your Assembler source libraries, and builds the main and called modules into one .390 file. Once this .390 load module is brought into memory by the COBOL run-time loader, all public entry points in the .390 module are callable by any other COBOL or Assembler module.

Parent topic: Program Structures and Static Linking


Multiple Assembler Modules with Calls Using Entry Points

To link multiple Assembler modules where the calls reference entry points in the called programs rather than their external names, you need to:

  1. Ensure that Automatically link module is unchecked for all the modules in the project. You can find this check box on the Link page of the Property Pages for the module.
  2. Ensure that Resolve external calls at link time is checked on the Assembler tab on your project properties Assembler page.
  3. Create a link file (.lin) that lists all the object files to be included with the main module in the executable file. This link file must have the same name as the main module. For example if the main module has the name mymain.mlc, the link file must have the name mymain.lin.

If you compile individual modules, you must select the .lin file for compilation too. If you build or rebuild the whole project, the .lin file is compiled with the other source files but will always be linked after any assembly to ensure that only the latest .OBJ files are linked. In either case, the Assembler Linker looks in the .lin file to find which object files need to be included in the executable .390 or .MOD file.

Parent topic: Program Structures and Static Linking


Dynamic Linking

If you want to link modules dynamically at run-time, you have two choices:

  • You can code your calling module to check whether the called module is already available. This way you retain the option to link modules statically sometimes. Each calling module that calls another module first tests the external reference address, and then if it is zero, issues a LOAD for the module, saving the address in the external reference field, then a BALR to go to the called module. With this method you must also specify the Linker directive NCAL when you build the executable program; to do this, uncheck Resolve external calls at link time on the Assembler tab on your project properties Assembler page. With NCAL set, the linker issues warnings that external references were not resolved and stores zero in each field holding the address of an external reference.
  • You can code your calling module to link dynamically always. You simply issue a LOAD for the module you want to link to, then a BALR to branch to it. With this method it makes no difference whether you specify the NCAL Linker directive or not.

We recommend that you also mark each module in this environment as reentrant and serially reusable, so that modules are not deleted and reloaded for each call. To mark a module as reentrant, check Mark module as reentrant on the Assembler tab on your project properties Assembler page. To mark a module as serially reusable, check Mark load module as serially reusable on the Assembler tab on your project properties Assembler page.

If you want to use static linking on a module that is normally dynamically linked, and its END statement names a default entry point for the module, you may need to provide an ENTRY command in the linker input file, .LIN, to override the default entry point. This is because the Linker, emulating the mainframe binder tool, sets the entry point for the entire executable program to the entry point named on the END statement of the final included module.

Parent topic: Linking Modules


Mixing Static and Dynamic Linking

If you want to link some modules statically and others dynamically, you need to:

  • Specify the Linker directive CALL when you build the executable program; to do this, check Resolve external calls at link time on the Assembler tab on your project properties Assembler page. With CALL set, the linker attempts to resolve all external references.
  • • Ensure that for each module that you want to call dynamically, you include an INCLUDE command in the link file with the operand TYPE=COBOL or TYPE=ASM. When the Linker processes the INCLUDE command, it does not actually include the module, but instead generates and includes a small Assembler module to dynamically call that entry point. When the CALL is executed at run time, the Assembler module asks the cobol run time to load the module and transfer control to it.

If there are any entry points defined in the statically linked modules that match entry points in the dynamically linked modules, you must also use the Linker directive NOEXPORT, to prevent the linker from making any of the entries in the executable program available to calling programs after it is loaded into memory. By default any ENTRY or CSECT or START symbol in all Assembler modules are normally loaded into the cobol run time system’s entry point table so NOEXPORT will prevent this behaviour. Also use an ALIAS link file commands for the statically linked modules, including the main executable program. This technique gives you precise control over the type of linking you use for each module.

Parent topic: Linking Modules


Assembler Modules that call COBOL Modules

You must use dynamic linking if your Assembler module calls a COBOL module. By definition, all calls from assembler to cobol and vice versa are dynamic because Assembler .OBJ files and COBOL .OBJ files cannot be linked together. There are two methods of dynamically linking to COBOL modules:

  • You can issue a CALL macro call in your Assembler program. With this method you also need to put an INCLUDE command in a link file for the assembler module giving the name of the cobol module that you want to link to. When the Linker processes the INCLUDE command, it does not actually include the COBOL module, but instead generates and includes a small Assembler module. When the CALL is executed at run time, the Assembler module loads and links to the COBOL module entry point specified.
  • You can issue a LOAD macro call in your Assembler program. Again, the LOAD macro does not load the COBOL module directly, but instead creates and loads an Assembler module the address of which is returned by the LOAD. You then issue a BALR instruction specifying this address. The small Assembler stub module then performs a dynamic CALL to the COBOL module desired.
    Note: Note that if you use this option you must use standard Assembler to COBOL linking which means the high bit in the last parameter address being passed is set so that the COBOL program being called can determine the correct number of parameters being passed.

    Whenever a COBOL program calls an Assembler module this linkage is also automatically done and the assembler module will be entered with register 1 pointing at the list of addresses, one address per parameter passed, and the last parameter will have its high bit set to indicate the end of the parameter list.

Parent topic: Linking Modules


Link File INCLUDE Commands

You need an INCLUDE command in your link file for each module that you want to be linked with the main module to produce one .390 file.

Here is an example of a link file. Assume that assemA is the main Assembler module that calls assemB, assemC and cobolD (with two parameters). The link file assemA.lin contains the following three records:

INCLUDE SYSLIB(assemB)

INCLUDE SYSLIB(assemC)

INCLUDE SYSLIB(cobolD),TYPE=CBL,PARMS=2

The TYPE parameter specifies the language of the called module and is optional; it defaults to ASM (for Assembler) if the main module is Assembler. The PARMS parameter specifies the number of parameters to be passed to the called program; you only need to specify it if TYPE=CBL (for COBOL) . There are options that allow you to call a COBOL IMS program and to call a program with a variable number of parameters.

Parent topic: Linking Modules


Other Link File Commands

Link files can also contain the following commands:

  • NAME. Use this command to specify a name for the executable file other than the name of the source. For example, the name of the source file might be myprog.mlc, but you may want the executable to have the name program1.390
  • ENTRY. Use this command if the executable file you are building may be called by another program, and you want all such calls to enter the program at a particular entry point, rather than the beginning of the program.
  • ALIAS. Use this command to create an alias for the executable file that you are building. The alias is created in the entry point mapping file mfentmap.dat.
  • CHANGE. Use this command to change the names of external symbols in the object module named in the next INCLUDE command
Parent topic: Linking Modules


Entry Point Mapping

If one module calls another using the LOAD statement and the call is to an entry point within the module rather than to the external name of the module, you need to specify the relationship between the entry point and the module. You can do this by either:

  • Specifying the AUTOALIAS Linker directive; this directs the Linker to generate automatic entries in the mfentmap.dat file for all entry points.
  • Editing the entry point mapping file mfentmap.dat.
Parent topic: Compiling and Linking Assembler Modules


Configuring Runtime Memory Requirements

The topics in this section describe how to configure memory requirements.

  • About Memory Requirements
  • Setting Addressing Mode and Residency Mode
  • Configuring the Default SQA Memory Size
  • Reserving Memory for Execution
  • Run Time Memory Environment Variables
  • About Memory Requirements
  • Setting Addressing Mode and Residency Mode
  • Configuring the Default SQA Memory Size
  • Reserving Memory for Execution
  • Run Time Memory Environment Variables
Parent topic: Assembler Support
Parent topic: Assembler Support


About Memory Requirements

On the mainframe, an area of memory can be located either below the line or above the line. The term 'the line' means the point at which the address of an area of memory requires four bytes to hold it. Three-byte addresses can point to memory up to 16Mb. Any area of memory starting at a higher point than this requires a four-byte address. Four-byte addresses are actually 31-bit addresses, since bit 0 is used for other purposes. A 31-bit address can point to memory up to 2Gb.

The memory requirements of an Assembler program are indicated by its AMODE (or addressing mode) and RMODE (or residency mode). AMODE governs the type of addresses the program uses, while RMODE indicates where the program must be located when it is loaded for execution.

There are two AMODE values:

  • AMODE(24) indicates 24-bit (three-byte) addressing - memory below the line
  • AMODE(31) indicates 31-bit addressing - memory above and below the line.

You can set AMODE to 24 or 31 for Assembler, since we emulate both types of addressing by mapping mainframe-style above and below the line addresses to real 32-bit PC memory addresses. An AMODE (24) program can only access memory below the line, while an AMODE(31) program can access memory both below and above the line.

There are two RMODE values:

  • RMODE(24) indicates that the program must be loaded into memory below the line.
  • RMODE(31) indicates that the program can be loaded either below or above the line.
Parent topic: Configuring Runtime Memory Requirements
Parent topic: Configuring Runtime Memory Requirements
Related concepts
Program Only Uses Memory Above the Line
Program Only Uses Memory Below the Line


Setting Addressing Mode and Residency Mode

The memory requirements of an Assembler program are indicated by its AMODE and RMODE:

  • AMODE (or addressing mode) governs the type of addresses the program uses.
  • RMODE (or residency mode) indicates where the program must be located when it is loaded for execution.

There are two AMODE values:

There is an additional cobol compiler directive, DATA(24) that ensures that the working-storage section of the cobol module is assigned addresses below the 16 megabyte line irrespective of any AMODE setting.

Parent topic: Configuring Runtime Memory Requirements
Parent topic: Configuring Runtime Memory Requirements
Related concepts
About the MF370CTL.CFG configuration file
Configuring a Program's Memory Requirements
Introduction to File Handling
Turning GTF on and Specifying Options
Configuring the Default SQA Memory Size


Configuring the Default SQA Memory Size

You can use the MF370CTL.CFG file set the default SQA memory. You can also set the default memory above and below the line through the user interface.

Note: The settings in the user interface override any settings in the MF370CTL.CFG file.
For example, the following entry sets the SQA memory size to 3 Mb:
VM370=3000   ; set SQA size to 3Meg
Parent topic: Configuring Runtime Memory Requirements
Parent topic: Configuring Runtime Memory Requirements
Related concepts
About the MF370CTL.CFG configuration file
Setting Addressing Mode and Residency Mode
Configuring a Program's Memory Requirements
Introduction to File Handling
Turning GTF on and Specifying Options


Reserving Memory for Execution

When the Assembler run-time system is initialized, it allocates an area of memory called the system queue area to the executable program. You can specify how much of this memory is below the line and how much is above the line.

The main executable program and any other executables that it loads are loaded into memory below or above the line depending on the program's RMODE settings. When a program issues requests for extra memory using the macros GETMAIN or STORAGE OBTAIN, it can specify whether the memory needs to come from the below-the-line allocation or the above-the-line allocation, depending on its addressing needs.

In general the assembler run time allocates memory addresses bottom up from absolute address 0, while the COBOL run time allocates memory addresses top down, either from the 2 gigabyte line down, or the 16 megabyte line down.

  • Setting the Run Time Virtual Memory Environment
  • Example: Runtime Virtual Memory Configuration
  • Setting the Run Time Virtual Memory Environment
  • Example: Runtime Virtual Memory Configuration
Parent topic: Configuring Runtime Memory Requirements
Parent topic: Configuring Runtime Memory Requirements


Setting the Run Time Virtual Memory Environment

Run time virtual memory is controlled by environment variables set in the MF370CTL.CFG file

This file is located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory.

These control the amount of virtual memory which the 370 assembler emulator uses when the first assembler module is called:

Parent topic: Reserving Memory for Execution
Parent topic: Reserving Memory for Execution


Example: Runtime Virtual Memory Configuration

The following is a typical MF370CTL.CFG virtual memory configuration file located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory:
*--------------------------------------------------------------------------
* RUN TIME VARIABLES
MFPM=ON                   ; mainframe pointer manager is on by default
SVC370=MFI                ; set engine to MFI-mode
MEMSIZE=00000000,7FFFFFFF ; set valid address range
VM370=3000                ; set SQA size to 3Meg
AMODE370=31               ; run in 31-bit mode
Parent topic: Reserving Memory for Execution
Parent topic: Reserving Memory for Execution


Run Time Memory Environment Variables

The following environment variables control the run time virtual memory

MFMP
This must be set to ON for assembler to execute.
Example:

MFMP=ON

SVC370
This switch is related to backward compatibility. It must always be set to MFI.
Example:

SVC370=MFI

MEMSIZE=<LOW>,<HIGH>
Maximum 370 linear address that assembler modules can address. A value of 0,7FFFFFFF addresses the bottom 2 gigabytes of 370 virtual memory
Example:

MEMSIZE=0,7FFFFFFF

VM370
Amount of memory, starting at absolute address 0, to be allocated for the use of 370 assembler modules to be loaded into. Default is 3 meg below the 16 meg address line.
Example:

VM370=3000

AMODE370
Tells the assembler emulator which addressing mode to initially start in when the first assembler module is called.
Example:

AMODE370=31

Parent topic: Configuring Runtime Memory Requirements
Parent topic: Configuring Runtime Memory Requirements


Configuring a Program's Memory Requirements

Configuring access to the type of memory you require involves several steps. You must:

  1. Specify how much memory the program needs below the line and above the line, using the Max. memory below 16Mb line and Max. memory above 16Mb line fields. You can find these settings in the MF370CTL.CFG (assembler control and configuration file) which is located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory. The default values are:
    * RUN TIME VARIABLES
MFPM=ON                   ; mainframe pointer manager is on by
                          ;  default
SVC370=MFI                ; set engine to MFI-mode
MEMSIZE=00000000,7FFFFFFF ; set valid address range

* THE FOLLOWING RUN TIME VARIABLES ARE OVERRIDDEN BY
* THE SETTINGS IN
* THE IDE PROJECT, PROJECT OPTIONS PULLDOWN.
VM370=3000                ; set SQA size to 3Meg
AMODE370=31               ; run in 31-bit mode
    The most likely value you will need to change will be the VM370= value, which allocates the default size of assembler memory to allocate when the first assembler module is called in a COBOL run unit.
  2. Specify the addressing mode for each Assembler program that does not need a separate link file to control the production of an executable code file, including any programs that the main program calls, using the Addressing mode field, set on the Link page of the Property Pages for the program.
  3. Ensure that all your GETMAIN or STORAGE OBTAIN macro calls indicate which type of memory is required.

The following sections cover most possibilities.

  • Program Only Uses Memory Below the Line
  • Program Only Uses Memory Above the Line
  • Program Uses Memory Below and Above the Line
  • Setting Residency Mode
  • Using Subpools
Parent topic: Assembler Support
Related concepts
About the MF370CTL.CFG configuration file
Setting Addressing Mode and Residency Mode
Introduction to File Handling
Turning GTF on and Specifying Options
Configuring the Default SQA Memory Size


Program Only Uses Memory Below the Line

If your program only needs to address memory below the line, you should:

  1. Set Max. memory below 16Mb line to the maximum amount of memory below the line that your program requires. The default is 3Mb and the maximum is 16Mb.
  2. Set Addressing mode to AMODE(24) for the main program and for each program that the main program loads.
  3. Omit the LOC parameter from all GETMAIN or STORAGE OBTAIN macros issued by your program.
Parent topic: Configuring a Program's Memory Requirements
Related concepts
About Memory Requirements


Program Only Uses Memory Above the Line

If your program needs to address memory above the line, you should:

  1. Set Max. memory above 16Mb line to the maximum amount of memory above the line that your program requires. The default is 3Mb and the maximum is 2Gb.
  2. Set Addressing mode to AMODE(31) for the main program and for each program that the main program loads.
  3. Set LOC=ANY in all GETMAIN and STORAGE OBTAIN macros issued by your program.
Parent topic: Configuring a Program's Memory Requirements
Related concepts
About Memory Requirements


Program Uses Memory Below and Above the Line

If your program needs to address both types of memory, that is, you have a mix of some modules that use memory below the line and others that use memory above the line, you should:

  1. Set Max. memory below 16Mb line to the maximum amount of memory below the line that your program requires. The default is 3Mb and the maximum is 16Mb.
  2. Set Max. memory above 16Mb line to the maximum amount of memory above the line that your program requires. The default is 3Mb and the maximum is 2Gb.
  3. Set Addressing mode to AMODE (24) for each program to be loaded that uses memory below the line.
  4. Set Addressing mode to AMODE (31) for each program to be loaded that uses memory above the line.
  5. To allocate memory below the line, omit the LOC parameter from all GETMAIN and STORAGE OBTAIN macros that the module issues.
  6. To allocate memory above the line, set LOC=ANY in all GETMAIN and STORAGE OBTAIN macros that the module issues.
  7. Use the Assembler instructions BASSM or BSM to transfer control between programs that use different addressing modes.
Note:
  • If a program that uses 31-bit addressing needs to manipulate 24-bit addresses, you must include code to clear the unused byte of the address before any instruction that sets a register to a new address. These instructions include LA, BAL, BALR, EDMK and TRT.
  • You can only set LOC=ANY on the RU and RC formats of the GETMAIN macro. The R format of GETMAIN is restricted to memory below the line.
Parent topic: Configuring a Program's Memory Requirements


Setting Residency Mode

You specify the residency mode of a program and of any programs that the main program calls using the Residency mode field. Residency mode appears in two places:

Specify the residency mode for each Assembler program that does not need a separate link file to control the production of an executable code file, including any programs that the main program calls, using the Residency mode field, set on the Link page of the Property Pages for the program.

The valid combinations of AMODE and RMODE are:

  • AMODE(24) and RMODE(24)
  • AMODE(31) and RMODE(31)
  • AMODE(31) and RMODE(24): use this combination where the Assembler program contains 24-bit address constants but needs to be executed in 31-bit addressing mode so that it can handle 31-bit addresses passed as parameters by calling COBOL programs.
Note: If you set AMODE to 31 and RMODE to 31, but the Assembler module contains 24-bit addresses, the Linker overrides your RMODE setting and loads the module below the line, and displays a warning message.
Parent topic: Configuring a Program's Memory Requirements


Using Subpools

You can use subpools to help manage your memory requirements in just the same way as you do on the mainframe. A subpool is a logical grouping of memory allocations that can be de-allocated with a single FREEMAIN or STORAGE RELEASE macro statement. Subpools are available for memory both above and below the line.

You create a subpool simply by including the SP parameter in a GETMAIN or STORAGE OBTAIN macro statement. Valid subpool numbers are 0 through to 127, 131 and 132. If you omit the SP parameter from your GETMAIN and STORAGE OBTAIN macro statements, all memory is allocated in subpool 0, unless you specify the NONCAN Linker directive, in which case all memory is allocated in subpool 132.

Parent topic: Configuring a Program's Memory Requirements


File Handling

This section describes the file handling facilities supplied with Assembler support.

  • Introduction to File Handling
  • Using QSAM for File Handling
  • Using BSAM for File Handling
  • Using VSAM for File Handling
Parent topic: Assembler Support


Introduction to File Handling

Assembler support provides file handling facilities for a subset of data set organizations. The following table shows the data set organizations and access methods that you can use in your Assembler programs:

Data Set Organization | Record Formats | Access Methods
PS (member of GDG) | Fixed, variable, line sequential | QSAM, BSAM
PS | Fixed, variable, line sequential | QSAM, BSAM
PSU | Fixed, variable, line sequential | QSAM, BSAM
ES (Entry sequence) | Fixed, variable | VSAM
KS (Key sequence) | Fixed, variable | VSAM
RR (Relative record) | Fixed, variable | VSAM

Assembler support includes performing all file handling by calling the COBOL file handler; this ensures 100% compatibility. Your Assembler programs can access any file created by a COBOL program, as long as its data set organization is one of those shown in the table. Equally, COBOL programs can access files created by Assembler programs.

In your Assembler program you define your files and perform input/ouput operations on them using the same macros that you use on the mainframe. We ignore some control block parameters and applies others differently, but in general the level of compatibility between control blocks on the PC and control blocks on the mainframe is very high. The input/output request macros expand differently from the mainframe. All fields in request macros that accept register notation in a mainframe environment also accept register notation in our Assembler support.

If you are working with mainframe-style files you should map PC filenames to mainframe-style names using the catalog.

You can access data files held on Fileshare servers. We recommend that you specify full Fileshare pathnames in the catalog for any files that you want to access through Fileshare. Alternatively you can specify Fileshare pathnames in your Assembler file handling macros; if you want to use this method, you need to use the Fileshare File Handler, FHREDIR, rather than the standard COBOL File Handler. To do this, set the following parameter in the Assembler support configuration file, mf370ctl.cfg, located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory:

MF370EFH=FHREDIR

Parent topic: File Handling
Related concepts
About the MF370CTL.CFG configuration file
Setting Addressing Mode and Residency Mode
Configuring a Program's Memory Requirements
Turning GTF on and Specifying Options
Configuring the Default SQA Memory Size


Using QSAM for File Handling

Our Assembler support includes QSAM-style processing of files with the data set organizations PS and PSU. You define your file with the DCB macro and process it with the OPEN, CLOSE, GET and PUT request macros. QSAM file handling is identified in the DCB by the MACRF options of G, P, or G,P for GET, PUT or GET/PUT. The two-byte COBOL ANSI 85 file status code is available after every file operation at byte 6 in the data control block (DCB).

Your files can have fixed, variable or Micro Focus line sequential record formats. The length of the last record read or written is always available in the LRECL field of the DCB.

In the case of variable-length records, each record is prefixed by a four-byte mainframe-compatible record descriptor word (RDW)

To use Micro Focus line sequential file organization, specify RECFM=T in the DCB. All records are variable length and, whether read or written, must end with ANSI carriage-return and line-feed characters (x"0D0A").

Some of the sample programs provided with our Assembler support illustrate the use of QSAM-style file handling. All of these files are located by default in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Mainframe\Assembler\Classic\QSAM directory:

Program | Summary
pgasm04.mlc | Uses the input/ouput macro statements to copy a line sequential file. The input file is mf370get.dat; the new output file is mf370put.dat. The program displays the records on the screen as it copies them.
qsamex4.mlc | Reads an ANSI text file (line sequential format ) and writes the records to an EBCDIC PS file of 80-character fixed length records. This sample program is very useful for converting ASCII text files into 80-byte EBCDIC card-images to be read by other Assembler programs.
Parent topic: File Handling


Using BSAM for File Handling

Our Assembler support includes BSAM-style processing of files with the data set organizations PS and PSU. You define your file with the DCB macro and process it with the OPEN, CLOSE, READ and WRITE request macros. BSAM file handling is identified in the DCB by the MACRF options of R, W, or R,W for READ, WRITE or READ/WRITE. The two-byte COBOL ANSI 85 file status code is available after every file operation at byte 6 in the data control block (DCB).

The BSAM READ and WRITE operations act on a block of records at a time; your Assembler program is responsible for any processing required to deblock and block individual records. However, PC operating systems do not currently support blocked record files; all PC files must consist of individual logical records. There are two solutions to this incompatibility between the mainframe and PC. In both cases you need to convert the file to an unblocked format on the mainframe, using either a specially-written program or a third-party utility. The two solutions are as follows:

  • If the file is to be accessed only by an Assembler program, your conversion program should write out each block as a record. Then when the Assembler program on the PC issues a READ, although the COBOL file handler returns a single record, the Assembler program can continue to treat it as a block.
  • If the file is to be accessed by both an Assembler program and a COBOL program, your conversion program should write out each record individually. Then on the PC your COBOL program can access the file one record at a time, while the Assembler program can access it one block at a time, with each block holding one record. You can only use this approach if your Assembler program is able to handle blocks containing variable numbers of records.

Your blocked files can have fixed, variable or Micro Focus line sequential record formats. Fixed length records are held in fixed length blocks, while variable length records are held in variable length blocks. Line sequential records are held in variable length blocks, one record per block.

In the case of variable-length blocks, each block is prefixed by a four-byte mainframe-compatible block descriptor word. Each record is normally prefixed by its own record descriptor word, but processing this is the responsibility of your Assembler program.

To use Micro Focus line sequential file organization, specify RECFM=T in the DCB. The single record in each block must end with ANSI carriage-return and line-feed characters (x"0D0A").

Parent topic: File Handling


Using VSAM for File Handling

Our Assembler support includes VSAM-style processing of files with the data set organizations ES, KS and RR, providing sequential, indexed and random access. You define your file with the ACB, EXLST and RPL control block macros and process it with the OPEN, CLOSE, GET, PUT, POINT and ERASE request macros. You can also manipulate the ACB, EXLST and RPL control blocks at execution time using the SHOWCB, MODCB, TESTCB and GENCB macros. The two-byte COBOL ANSI 85 file status code is available after every file operation at byte 6 in the access method control block (ACB).

Your files can have fixed or variable record formats. The length of the last record read or written is always available in the RECLEN field of the request parameter list.

You can use one alternate index to access a VSAM KS files. You specify alternate index access with the AIX option of the MACRF parameter of the ACB macro.

We do not support the following mainframe VSAM options: reverse sequential processing, relative byte addressing, control interval access, asynchronous input/output and multiple file positions.

Some of the sample programs provided with our Assembler support illustrate the use of VSAM-style file handling. All of these files are located by default in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Mainframe\Assembler\Classic\VSAM directory:

Program | Summary
vsamex1.mlc | Reads a variable-length KS file sequentially by key and displays each record on the screen.
vsamex3.mlc | Reads a variable-length KS file directly by key, adding new records and optionally updating retrieved records.
vsamex5.mlc | Reads a fixed-length RR file, erases any existing records then performs a sequence of tests to demonstrate that records can be written and read sequentially and at random.
vsamex19.mlc | Reads a variable-length KS file using an alternate index. The alternate key values are verified after each read and a success or fail message is written to the screen depending on the sequence of records returned.
Parent topic: File Handling


Using the Generalized Trace Facility

The chapter describes how you use the Generalized Trace Facility to obtain an execution trace of an Assembler program.

  • Generalized Trace Facility Introduction
  • Turning GTF on and Specifying Options
  • The Trace File
  • Types of Trace
  • Program Interruption Information
Parent topic: Assembler Support


Generalized Trace Facility Introduction

The Assembler Generalized Trace Facility (GTF) is a debugging tool designed to help speed up the process of isolating the location and cause of a problem in an Assembler program. You use the GTF tool to create a trace file showing the operations performed by the program. You do not have to compile the program for debugging. You can request different levels of detail. For example, you might run a trace requesting program level information and then run a further trace on a specific section by specifying the level of detail and the start and end points for the trace.

Parent topic: Using the Generalized Trace Facility


Turning GTF on and Specifying Options

To turn on the Generalized Trace Facility, set the environment variable GTFFILE to the absolute path and file name of the trace file. You set this environment variable in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin\MF370ctl.cfg configuration file.

You can specify the following GTF options after the GTFFILE environment variable:

GTFIMIN
The instruction count at which to start the trace (default 00000000)
GTFIMAX
The instruction count at which to end the trace (default FFFFFFFF)
GTFAMIN
The instruction address at which to start the trace (default 00000000)
GTFAMAX
The instruction address at which to end the trace (default FFFFFFFF)
GTFOPT
The level of detail. You can set this environment variable to one or more of the following three-character codes separated by commas to indicate the level of detail you want: INS Trace each instruction

BAL Trace each BALR, BASR, and BASSM instruction

SVC Trace each SVC instruction

PGM Trace each LOAD, DELETE, and LINK

FOC Trace each file OPEN and CLOSE operation

FIO Trace each file input and output operation, as well as each OPEN and CLOSE

MEM Trace GETMAIN, FREEMAIN, and STORAGE

ALL All of the above trace options

REG Trace the 16 general-purpose registers at each trace event

The default value is BAL, PGM, FOC

The size of a trace file depends on the options that you specify. It can be very large. For this reason we recommend that you always begin by running a trace with the default options to find out the optimum starting point for a detailed trace. When you run a detailed trace, using options such as FIO, INS or ALL, specify the start and end points using the GTFIMIN and GTFIMAX or the GTFAMIN and GTFAMAX options.

You can also specify the REG option with any other option if you want the contents of the 16 general-purpose registers at each trace point. This increases the size of the trace file by a factor of 3 and makes it a little more difficult to read, so only use this option if you really need it. The contents of the registers are shown as they were just before the trace operation; hence the REG option is most useful with the following options:

  • INS, because this traces every instruction
  • MEM and PGM, because with these options the trace is performed at the end of the instructions affected such as LOAD and GETMAIN

Regardless of the trace options you have specified, whenever a program interruption occurs, the trace file contains extra lines for the instruction causing the interruption. These lines show the program status word (PSW), which contains the interruption code in the low-order byte of the first word, and the registers.

Parent topic: Using the Generalized Trace Facility
Related concepts
About the MF370CTL.CFG configuration file
Setting Addressing Mode and Residency Mode
Configuring a Program's Memory Requirements
Introduction to File Handling
Configuring the Default SQA Memory Size


The Trace File

You can view or print the GTF trace file using any ASCII-compatible editor or word processor. The file begins with the GTF options used to generate the file and the date and time the trace started. The last line of the file shows the date and time the trace ended. If this line is not present, the trace is probably incomplete because it was not closed properly. This can happen if you are running an interactive debugging session using the Assembler debugger with the Generalized Trace Facility turned on, and an unrecoverable error occurs. To ensure that the GTF trace file is complete, you must allow the debugging session to end without being forced: press S(tep) or G(o) to record the program exception on the trace file and then stop the debugging session.

In between the information at the beginning of the file and the last line are individual trace records. Each of these includes the following items of information:

  • Instruction count. This is a hexadecimal counter showing the total number of instructions executed up to the trace point. This count is very useful when you want to work out where to start a detailed trace at a point deep into a complex application where the same code may be executed many times before the point of failure. You use the option GTFIMIN to set the starting instruction count for a trace.
  • Instruction address. This is the linear address of the next instruction at the current trace point. This address provides an alternative way of specifying where you want a detailed trace to start. You use the option GTFAMIN to set the starting instruction address for a trace.
  • Instruction operation. This field indicates the machine instruction or run-time operation being performed at the trace point. Additional information may follow depending on the type of trace line: INS The hexadecimal machine instruction, which can be 2, 4, or 6 bytes in length
PGM
The program name and entry for LOAD, DELETE, or LINK
FOC and FIO
The DCB, ACB, or DTF control block address
MEM
Length and address of memory allocated or deallocated
Parent topic: Using the Generalized Trace Facility


Types of Trace

This section describes various types of trace you can obtain.

  • Default Trace
  • Detailed Trace
  • File Input/Output Trace
  • Memory Allocation Trace
Parent topic: Using the Generalized Trace Facility


Default Trace

Use the default trace option GTFOPT=PGM,BAL,FOC, which traces LOAD, DELETE, LINK, BALR, BASR, OPEN, and CLOSE operations, to get an overview of what an application is doing and to identify possible starting and ending points for more detailed traces if required.

Here is the trace file for a default trace of an IMS COBOL and Assembler application:

GTF option GTFFILE =D:\MFUSER\CONFIG\GTF.LOG
GTF option GTFOPT  =BAL,FOC,PGM
GTF option GTFIMIN =00000000
GTF option GTFIMAX =FFFFFFFF
GTF option GTFAMIN =00000000
GTF option GTFAMAX =FFFFFFFF
GTF trace file DATE=000114 TIME=08495898
INS-CTR  INS-ADDR INS-OP
00000043 81000188 BALR     05EF
00000044 81005998 BALR     05F0
00000047 810059A2 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
00000051 810001E6 LOAD     NAME=LDDECTBL ENTRY=810059D8
000006DA 8100033A BALR     05EF
00000704 81005998 BALR     05F0
00000707 810059A2 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
00000762 81000E10 LOAD     NAME=CG#CTL   ENTRY=80012CF0
00000988 810059B0 BALR     05F0
0000098B 810059BA LINK     NAME=ASMTDLI  ENTRY=(COBOL)
00001051 8100033A BALR     05EF
0000107B 81005998 BALR     05F0
0000107E 810059A2 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
000012F7 810059B0 BALR     05F0
000012FA 810059BA LINK     NAME=ASMTDLI  ENTRY=(COBOL)
00001360 8100033A BALR     05EF
0000139C 81005998 BALR     05F0
0000139F 810059A2 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
00001618 810059B0 BALR     05F0
0000161B 810059BA LINK     NAME=ASMTDLI  ENTRY=(COBOL)
00001CDC 8100033A BALR     05EF
00001D06 81005998 BALR     05F0
00001D09 810059A2 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
00001F82 810059B0 BALR     05F0
00001F85 810059BA LINK     NAME=ASMTDLI  ENTRY=(COBOL)
00001F92 810003EA DELETE   NAME=LDDECTBL ENTRY=00000000
00001FED 81007628 BALR     05EF
00001FEE 8100CE38 BALR     05F0
00001FF1 8100CE42 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
00001FFB 81007686 LOAD     NAME=LDDECTBL ENTRY=80011228
00002684 810077DA BALR     05EF
000026AE 8100CE38 BALR     05F0
000026B1 8100CE42 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000270C 810082B0 LOAD     NAME=CG#CTL   ENTRY=8100CE78
00002932 8100CE50 BALR     05F0
00002935 8100CE5A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
00002FFB 810077DA BALR     05EF
.........................................
.........................................
0000B04A 81022160 BALR     05F0
0000B04D 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000B0AA 8101CAEA BALR     05EF
0000B0EF 81022148 BALR     05F0
0000B0F2 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000B114 81022160 BALR     05F0
0000B117 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000B174 8101CAEA BALR     05EF
0000B1B0 81022148 BALR     05F0
0000B1B3 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000B4A4 81022160 BALR     05F0
0000B4A7 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000B501 8101CAEA BALR     05EF
0000B519 81022160 BALR     05F0
0000B51C 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000BBE2 8101CAEA BALR     05EF
0000BC0C 81022148 BALR     05F0
0000BC0F 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000BE8D 81022160 BALR     05F0
0000BE90 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000BEED 8101CAEA BALR     05EF
0000BF32 81022148 BALR     05F0
0000BF35 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000BF51 81022160 BALR     05F0
0000BF54 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000BFB1 8101CAEA BALR     05EF
0000BFED 81022148 BALR     05F0
0000BFF0 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000C2E1 81022160 BALR     05F0
0000C2E4 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000C33E 8101CAEA BALR     05EF
0000C356 81022160 BALR     05F0
0000C359 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000C3BF 8101CAEA BALR     05EF
0000C3FB 81022148 BALR     05F0
0000C3FE 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000C67C 81022160 BALR     05F0
0000C67F 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000CD40 8101CAEA BALR     05EF
0000CD6A 81022148 BALR     05F0
0000CD6D 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000CFEB 81022160 BALR     05F0
0000CFEE 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000CFFB 8101CB9A DELETE   NAME=LDDECTBL ENTRY=00000000
GTF trace file DATE=000114 TIME=08514748
Parent topic: Types of Trace


Detailed Trace

Use the GTFOPT=ALL option to obtain a detailed trace.

Here is a detailed trace of the last section of code starting with BALR at instruction count CFEB in the default trace example in section Default Trace. Options GTFOPT=ALL and GTFIMIN=0000CFEB were used to obtain this trace:

GTF option GTFFILE =D:\MFUSER\CONFIG\GTF.LOG
GTF option GTFOPT  =ALL
GTF option GTFIMIN =0000CFEB
GTF option GTFIMAX =FFFFFFFF
GTF option GTFAMIN =00000000
GTF option GTFAMAX =FFFFFFFF
GTF trace file DATE=000114 TIME=09370586
INS-CTR  INS-ADDR INS-OP
0000CFEB 81022160 BALR     05F0
0000CFEC 81022162 ICM      BF08F00D
0000CFED 81022166 LA       41F0F00E
0000CFEE 8102216A SVC      0A27
0000CFEE 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000CFEF 8102216C BCR      07FE
0000CFF0 8101DBFA L        58D0D004
0000CFF1 8101DBFE L        58E0D00C
0000CFF2 8101DC02 BCR      07FE
0000CFF3 8101CAEC L        58E0B092
0000CFF4 8101CAF0 BCR      07FE
0000CFF5 8101C864 BAS      4DE0B3B4
0000CFF6 8101CB7A ST       50E0B092
0000CFF7 8101CB7E CLC      D501300AB484
0000CFF8 8101CB84 BC       4770B40C
0000CFF9 8101CB88 L        5860B446
0000CFFA 8101CB8C BAL      4500B3D2
0000CFFB 8101CB98 SVC      0A09
0000CFFB 8101CB9A DELETE   NAME=LDDECTBL ENTRY=00000000
0000CFFC 8101CB9A LTR      12FF
0000CFFD 8101CB9C BC       4770B412
0000CFFE 8101CBA0 L        5810B4B6
0000CFFF 8101CBA4 L        5890B4BE
0000D000 8101CBA8 L        5860B442
0000D001 8101CBAC LR       1809
0000D002 8101CBAE LH       48F0B3EE
0000D003 8101CBB2 BC       47000003
0000D004 8101CBB6 SVC      0A78
0000D004 8101CBB8 FREEMAIN  LOC=  00010EC8 LEN=  00000359
0000D005 8101CBB8 LTR      12FF
0000D006 8101CBBA BC       4770B412
0000D007 8101CBBE L        5810B4D6
0000D008 8101CBC2 LH       48F0B4D2
0000D009 8101CBC6 LA       4120B49A
0000D00A 8101CBCA LH       4830B482
0000D00B 8101CBCE SR       1B55
0000D00C 8101CBD0 MVCL     0E24
0000D00D 8101CBD2 L        58E0B092
0000D00E 8101CBD6 BCR      07FE
0000D00F 8101C868 L        58D0B04E
0000D010 8101C86C ST       50FD0010
0000D011 8101C870 LM       98ECD00C
0000D012 8101C874 BCR      07FE
0000D013 80000860 SVC      0A00
GTF trace file DATE=000114 TIME=09375776
Parent topic: Types of Trace


File Input/Output Trace

Use the option GTFOPT=FIO to trace all file input and output operations including OPEN, CLOSE, GET, PUT, POINT, READ, WRITE etc. Alternatively, use the option GTFOPT=FOC, which traces file open and close operations only, to identify the location within an application where an OPEN or CLOSE is failing.

Here is the GTF trace file for a file input/output trace of the Assembler demo program pgasm04.mlc:

GTF option GTFFILE =D:\MFUSER\CONFIG\GTF.LOG
GTF option GTFOPT  =FIO
GTF option GTFIMIN =00000000
GTF option GTFIMAX =FFFFFFFF
GTF option GTFAMIN =00000000
GTF option GTFAMAX =FFFFFFFF
GTF trace file DATE=000114 TIME=09504509
INS-CTR  INS-ADDR INS-OP
0000002B 80017572 OPENL    CB=000172C0
00000070 80017572 OPENL    CB=00017320
000000A1 80017AD0 GET      CB=000172C0
000000C6 80017AD0 PUT      CB=00017320
000000F3 80017AD0 GET      CB=000172C0
00000118 80017AD0 PUT      CB=00017320
00000145 80017AD0 GET      CB=000172C0
0000016A 80017AD0 PUT      CB=00017320
00000197 80017AD0 GET      CB=000172C0
000001BC 80017AD0 PUT      CB=00017320
000001E9 80017AD0 GET      CB=000172C0
0000020E 80017AD0 PUT      CB=00017320
0000023B 80017AD0 GET      CB=000172C0
00000260 80017AD0 PUT      CB=00017320
0000028D 80017AD0 GET      CB=000172C0
000002B2 80017AD0 PUT      CB=00017320
000002DF 80017AD0 GET      CB=000172C0
00000304 80017AD0 PUT      CB=00017320
00000331 80017AD0 GET      CB=000172C0
00000356 80017AD0 PUT      CB=00017320
00000383 80017AD0 GET      CB=000172C0
000003A8 80017AD0 PUT      CB=00017320
000003D5 80017AD0 GET      CB=000172C0
000003FA 80017AD0 PUT      CB=00017320
00000427 80017AD0 GET      CB=000172C0
0000044C 80017AD0 PUT      CB=00017320
00000479 80017AD0 GET      CB=000172C0
0000049E 80017AD0 PUT      CB=00017320
000004CB 80017AD0 GET      CB=000172C0
000004F0 80017AD0 PUT      CB=00017320
0000051D 80017AD0 GET      CB=000172C0
00000542 80017AD0 PUT      CB=00017320
0000056F 80017AD0 GET      CB=000172C0
000005A2 80017E8A CLOSEL   CB=000172C0
000005DE 80017E8A CLOSEL   CB=00017320
GTF trace file DATE=000114 TIME=09504618
Parent topic: Types of Trace


Memory Allocation Trace

Use the option GTFOPT=MEM to focus on the allocation and deallocation of memory in an Assembler application. The information shown includes the address and length of memory allocated above and below the 16 megabyte line.

Here is the GTF trace file for a memory allocation trace of the Assembler demo program testvml.mlc:

GTF option GTFFILE =D:\MFUSER\CONFIG\GTF.LOG
GTF option GTFOPT  =INS,MEM
GTF option GTFIMIN =00000000
GTF option GTFIMAX =FFFFFFFF
GTF option GTFAMIN =00000000
GTF option GTFAMAX =FFFFFFFF
GTF trace file DATE=000114 TIME=10044120
INS-CTR  INS-ADDR INS-OP
00000001 81007E78 BALR     05C0
00000002 81007E7A LR       18BE
00000003 81007E7C BAL      4510C03A
00000004 81007EB4 SVC      0A23
00000005 81007EB6 PACK     F232C158C173
00000006 81007EBC PACK     F232C15CC176
00000007 81007EC2 PACK     F272C166C179
00000008 81007EC8 CVB      4F20C166
00000009 81007ECC MH       4C20C17E
0000000A 81007ED0 MH       4C20C17E
0000000B 81007ED4 CP       F930C158C181
0000000C 81007EDA BC       4780C0CA
0000000D 81007EDE BAL      4510C08C
0000000E 81007F06 SVC      0A23
0000000F 81007F08 LR       1802
00000010 81007F0A ICM      BF08C097
00000011 81007F0E BC       47000000
00000012 81007F12 SR       1B11
00000013 81007F14 BCTR     0610
00000014 81007F16 SVC      0A0A
00000014 81007F18 GETMAIN   LOC=  00010010 LEN=  00100000
00000015 81007F18 BAL      4510C0BE
00000016 81007F38 SVC      0A23
00000017 81007F3A SP       FB30C158C180
00000018 81007F40 BC       4720C08E
00000019 81007F08 LR       1802
0000001A 81007F0A ICM      BF08C097
0000001B 81007F0E BC       47000000
0000001C 81007F12 SR       1B11
0000001D 81007F14 BCTR     0610
0000001E 81007F16 SVC      0A0A
0000001E 81007F18 GETMAIN   LOC=  00110020 LEN=  00100000
0000001F 81007F18 BAL      4510C0BE
00000020 81007F38 SVC      0A23
00000021 81007F3A SP       FB30C158C180
00000022 81007F40 BC       4720C08E
00000023 81007F44 CP       F930C15CC181
00000024 81007F4A BC       4780C136
00000025 81007F4E BAL      4510C0FC
00000026 81007F76 SVC      0A23
00000027 81007F78 LR       1802
00000028 81007F7A LH       48F0C106
00000029 81007F7E BC       47000022
0000002A 81007F82 SVC      0A78
0000002A 81007F84 GETMAIN   LOC=  01008010 LEN=  00100000
0000002B 81007F84 BAL      4510C12A
0000002C 81007FA4 SVC      0A23
0000002D 81007FA6 SP       FB30C15CC180
0000002E 81007FAC BC       4720C0FE
0000002F 81007F78 LR       1802
00000030 81007F7A LH       48F0C106
00000031 81007F7E BC       47000022
00000032 81007F82 SVC      0A78
00000032 81007F84 GETMAIN   LOC=  01108020 LEN=  00100000
00000033 81007F84 BAL      4510C12A
00000034 81007FA4 SVC      0A23
00000035 81007FA6 SP       FB30C15CC180
00000036 81007FAC BC       4720C0FE
00000037 81007FB0 BAL      4510C154
00000038 81007FCE SVC      0A23
00000039 81007FD0 BCR      07FB
0000003A 80000860 SVC      0A00
GTF trace file DATE=000114 TIME=10044864
Program Interruption Information
Here is the trace file for a program that attempts to add 1 to a packed decimal field containing spaces. The PSW contains interrupt code 7 corresponding to the MVS abend 0C7 that would occur on the mainframe.

GTF option GTFFILE =GTF.LOG
GTF option GTFOPT  =ALL
GTF option GTFIMIN =00000000
GTF option GTFIMAX =FFFFFFFF
GTF option GTFAMIN =00000000
GTF option GTFAMAX =FFFFFFFF
GTF trace file DATE=000114 TIME=10565281
INS-CTR  INS-ADDR INS-OP
00000001 81007FE8 BALR     05C0
00000002 81007FEA LA       41100002
00000003 81007FEE AP       FA10C00CC00E
 R0-R7 00000000 00000002 00000000 00000000 00000000 00000000 00000000 00000000
 R9-RF 00000000 00000000 00000000 00000000 81007FEA 00002870 00000860 01007FE8
00000003 81007FF4 PGMCHK   PSW=0000000781007FF4
GTF trace file DATE=000114 TIME=10565286
Parent topic: Types of Trace


Program Interruption Information

Here is the trace file for a program that attempts to add 1 to a packed decimal field containing spaces. The PSW contains interrupt code 7 corresponding to the MVS abend 0C7 that would occur on the mainframe.

GTF option GTFFILE =GTF.LOG
GTF option GTFOPT  =ALL
GTF option GTFIMIN =00000000
GTF option GTFIMAX =FFFFFFFF
GTF option GTFAMIN =00000000
GTF option GTFAMAX =FFFFFFFF
GTF trace file DATE=000114 TIME=10565281
INS-CTR  INS-ADDR INS-OP
00000001 81007FE8 BALR     05C0
00000002 81007FEA LA       41100002
00000003 81007FEE AP       FA10C00CC00E
 R0-R7 00000000 00000002 00000000 00000000 00000000 00000000 00000000 00000000
 R9-RF 00000000 00000000 00000000 00000000 81007FEA 00002870 00000860 01007FE8
00000003 81007FF4 PGMCHK   PSW=0000000781007FF4
GTF trace file DATE=000114 TIME=10565286
Parent topic: Using the Generalized Trace Facility


CICS Support

  • Mainframe-style Pointers
  • Forcing a Program to be Reloaded
  • Accessing Large VSAM Files
  • Abends in Transaction Programs
  • Using the SET Option of the BMS-related SEND Functions
  • Developing Exit Programs
    This chapter explains how to write exit programs for use with MSS.
Parent topic: Mainframe Programming


Mainframe-style Pointers

This COBOL system enables the contents of pointer items to be stored in a format that is compatible with that used on an IBM mainframe. You can redefine both USAGE POINTER and CICS BLL cell data items as USAGE PIC S9(9) COMP and can perform full arithmetic on such items. You control the use of mainframe-style pointers with the AMODE compiler directive; there is a choice between 24-bit pointers, 31-bit pointers or NO AMODE, depending on the dialect in use; programs compiled with NO AMODE use PC-style pointers and are known as non-AMODE compiled programs.

  • AMODE and Non-AMODE Compiled Programs
Parent topic: CICS Support
Related reference
AMODE Compiler Directive


AMODE and Non-AMODE Compiled Programs

You can run transactions that use both AMODE and non-AMODE compiled programs within the same region. However, within each discrete transaction all programs must be either AMODE-compiled or non-AMODE compiled. You should be especially aware of this when using supplied system transactions such as the mirror transaction (CVMI or CPMI) for inbound system communications or facilities such as the autoinstall exits, as these are non-AMODE compiled and could cause problems if you try to execute them with AMODE-compiled programs.

If you are using distributed program linking, you can get round this problem by setting a value for communications area override. We recommend that you set communications area override at the individual program level in the PPT definition. To do this, set a value in Commarea on the CICS PPT page of ESMAC. If you are not sure what value to set it to, set it to the maximum, 32,767 bytes.

Parent topic: Mainframe-style Pointers


Forcing a Program to be Reloaded

By default, when a transaction program is canceled, it remains in memory. This behavior improves performance because the program does not need to be reloaded if it is called a subsequent time. However, it also means that you can't load a updated version of the program without closing down the enterprise server and starting it up again. If you are actively working on one or more programs that run in your enterprise server, and you want to ensure that the latest version is loaded every time, you can force programs to be reloaded each time they are called by checking Force program PHASEIN under the SIT properties . Alternatively, you can force an individual program to be reloaded by using the Phasein function of the transaction CPMT.

Parent topic: CICS Support


Accessing Large VSAM Files

You might find that VSAM files larger than 1 GB (gigabyte) cannot be accessed. This is because the default record locking mechanism uses the top two bits of the file address for locking and compression bits, thus reducing the address space for the maximum offset from 4 GB to 1 GB for a shared idxformat 3 or 4 file. If you encounter this problem, you should change the record locking mechanism for the file. To do this:

  1. If the large VSAM files are set to OPEN, (which means that the files are opened when the CICS region is started) verify that Integrated Fileshare Support on the SIT is enabled.
  2. Create a file handler configuration file that sets LOCKTYPE to 2 for the files causing the problem. With this setting, the file handling mechanism creates a separate file for storing record locks, with the same basename as the file and a .lck extension.
  3. Set the EXTFH environment variable to point to the file. The default file name is extfh.cfg.

The file handler configuration file lists defaults for all files under the tag [XFH-DEFAULT], and settings for individual files under a tag consisting of the filename. For example, the following configuration file sets BASENAME=ON (which means that you do not need to supply pathnames for files) and sets the lock type to 2 for the file myfile:

[XFH-DEFAULT]
BASENAME=ON
[MYFILE]
LOCKTYPE=2
Parent topic: CICS Support


Abends in Transaction Programs

Unhandled transaction program abends are reported through the TXKC0001E system message. Generally these abends are caused by a standard CICS error condition. The abend codes (and descriptions) in these cases are the same as the abend codes issued for those conditions in the mainframe environment.

In addition to these errors, the emulator can encounter conditions that do not match a standard CICS error condition but where the transaction cannot proceed successfully and so must be abended. These abend codes are:

  • ASSA
  • EXIF
  • FUNC
  • IRST
  • LANG
  • MATP
  • MBLL
  • MCOM
  • MUSR
  • RECU
Parent topic: CICS Support
Related information
IBM CICS/ESA Messages and Codes


ASSA

Your development system issues the ASSA abend code if it encounters either of the following:

  • an invalid resource name
  • a lack of storage

when it is dynamically creating a resource entry (for example, a PPT entry).

Use the diagnostic tools and log files to determine the cause of the error.

Parent topic: Abends in Transaction Programs


EXIF

Your development system issues the EXIF abend code if your program calls the CICS API with parameters that do not conform to the specifications. The most likely cause is that the transaction program was compiled from a translated source file that has been modified incorrectly.

Parent topic: Abends in Transaction Programs


FUNC

The FUNC abend code is issued when an unsupported CICS API function is requested. It is caused by the execution of an EXEC CICS command that was identified by the preprocessor as unsupported and the /CICSECM(FUNCTION=ABEND) preprocessor directive (abend at execution) was specified.

Parent topic: Abends in Transaction Programs


IRST

The IRST abend code is issued when the program control functions for saving and restoring Working Storage have encountered an illogical condition; generally a system error.

Parent topic: Abends in Transaction Programs


LANG

The LANG abend code is issued when different dialects of COBOL are mixed in a run unit, for example, a program written in VS COBOL II calls a program written in OS/VS COBOL.

Parent topic: Abends in Transaction Programs


MATP

The MATP abend code is issued when there is insufficient memory for the API Emulation server to allocate the control block needed for the target program of a LINK, XCTL, or VS COBOL II CALL.

Parent topic: Abends in Transaction Programs


MBLL

The MBLL abend code is issued when there is insufficient memory for the API Emulation server to allocate the BLL Cell List area for an OS/VS COBOL transaction program.

Parent topic: Abends in Transaction Programs


MCOM

The MCOM abend code is issued when there is insufficient memory for the API Emulation server to allocate a COMMAREA to be passed to a user transaction program invoked through XCTL.

Parent topic: Abends in Transaction Programs


MUSR

The MUSR abend code is issued when there is insufficient memory for the API Emulation server to allocate the file or terminal buffer for data to be returned to the user transaction program.

Parent topic: Abends in Transaction Programs


RECU

The RECU abend code is issued when an attempt is made to CALL (using DFHEIBLK) a user transaction program that is already active in the current CICS LINK level.

Parent topic: Abends in Transaction Programs


Using the SET Option of the BMS-related SEND Functions

To be able to support the SET option of the BMS-related SEND functions, your development system returns a fake TIOA address in the low-order three bytes of each entry in the Page List. To make use of a fake TIOA address, you need to convert it to a real (usable) TIOA address using DFHMFSET.

You need to modify every program that uses the SET option of the following BMS functions:

  • SEND CONTROL
  • SEND MAP
  • SEND PAGE
  • SEND TEXT

You also need to modify every program that uses the addresses in the resulting Page List.

  • Converting a Fake TIOA Address to a Real TIOA Address
  • Restrictions on Using DFHMFSET
  • Examples
Parent topic: CICS Support


Converting a Fake TIOA Address to a Real TIOA Address

Enter the following on the command line:

call "DFHMFSET" using page-list-entry
                      address-field

where:

  • page-list-entry is a four byte area, containing the value of one entry from the Page List (returned in the area addressed by the address returned for the SET option on a BMS SEND command). It might be the actual entry or some other area. Its value must be one of the current valid values in the list. The end of the list is marked by a mainframe NULL pointer data item (x'FF000000').
  • address-field is a four byte area.
    • For OS/VS COBOL it should be defined and used as a BLL Cell value, that is S9(8) COMP.
    • For VS COBOL II it should be defined and used as a POINTER data item.
Note: The end of the list is always signalled by an entry with high-values in the high-order byte and low-values in the low-order three bytes. On the mainframe, this corresponds to the defined value used for NULL pointer data items, but not to a NULL pointer value in the Micro Focus COBOL environment. The test for the end of the list should always be done by explicitly testing for high-values in the high-order byte of an entry.
Parent topic: Using the SET Option of the BMS-related SEND Functions


Restrictions on Using DFHMFSET

The following restrictions on using DFHMFSET apply:

  • The DFHMFSET entry point should only be called in programs preprocessed by the CICS preprocessor.
  • The conversion of any fake TIOA addresses in the Page List must be done before the Page List is reused. Subsequent BMS SEND commands specifying the SET option will only reuse the Page List if the first "logical message" has been completed (by SEND PAGE, PURGE MESSAGE, or SYNCPOINT).
  • In OS/VS COBOL only, a SERVICE RELOAD must be done for the associated 01-level if the actual BLL cell is used as the second parameter on the call to DFHMFSET. This is necessary to let the compiler know that it must re-establish the base address for that 01-level using the (possibly) changed value in the BLL cell.
  • The Page List returned cannot exceed 127 entries (plus one for the "end-of-list" entry).
Parent topic: Using the SET Option of the BMS-related SEND Functions


Examples

The OS/VS COBOL and VS COBOL II examples each provide the same function. They show a simple case of the use of the DFHMFSET entry point with the Page List that is returned for the SET option on BMS SEND commands.

They each do a SEND MAP command using the SET option that returns the address of a Page List containing the address of the datastream in the first entry. Note that the second entry of the Page List contains the end-of-list marker. The examples convert the Page List entry to a "real" TIOA address for the built datastream, establish the addressability for the datastream, and actually send it to the terminal using a SEND TEXT MAPPED command.

Note that the PIC X(9999) for PAGE-DSC-AREA and the value of 5 in the OCCURS clause for PAGE-LIST-ENTRY are not in themselves significant; they are just the values used in this example.

  • OS/VS COBOL Example
  • VS COBOL II Example
Parent topic: Using the SET Option of the BMS-related SEND Functions


OS/VS COBOL Example

WORKING-STORAGE SECTION.
        .
        .
     05  PAGE-LIST-ADDRESS       PIC S9(8)   COMP.
     05  PAGE-DATA-ADDRESS       PIC S9(8)   COMP.
        .
        .
 LINKAGE SECTION.
        .
        .
 01  BLL-CELL-LIST.
     05  FILLER                  PIC S9(8)   COMP.
     05  PAGE-LIST-BLL-CELL      PIC S9(8)   COMP.
     05  PAGE-DATA-BLL-CELL      PIC S9(8)   COMP.
*
 01  PAGE-LIST.
     05  PAGE-LIST-ENTRY              OCCURS 5 TIMES.
         10  PAGE-TERMINAL-TYPE  PIC X.
         10  PAGE-DSC-ADDRESS    PIC XXX.
 01  PAGE-DATA-AREA.
     05  PAGE-TIOA-PREFIX.
         10  FILLER              PIC X(8).
         10  PAGE-LENGTH         PIC 9(4)    COMP.
         10  FILLER              PIC X(2).
     05  PAGE-DSC-AREA           PIC X(9999).
        .
        .
 PROCEDURE DIVISION.
        .
     EXEC CICS SEND    MAP    ('MAPNAME')
                       MAPSET ('MSETNAM')
                       SET    (PAGE-LIST-BLL)
     END-EXEC.
        .
        .
     CALL 'DFHMFSET' USING PAGE-LIST-ENTRY (1)
                           PAGE-DATA-ADDRESS.
     MOVE PAGE-DATA-ADDRESS TO PAGE-DATA-BLL-CELL.
        .
        .
     EXEC CICS SEND TEXT MAPPED
                       FROM    (PAGE-DSC-AREA)
                       LENGTH  (PAGE-LENGTH)
     END-EXEC.
        .
Parent topic: Examples


VS COBOL II Example

        .
        .
 WORKING-STORAGE SECTION.
        .
        .
     05  PAGE-LIST-ADDR          POINTER.
     05  PAGE-DATA-POINTER       POINTER.
        .
        .
 LINKAGE SECTION.
        .
        .
 01  PAGE-LIST.
     05  PAGE-LIST-ENTRY              OCCURS 5 TIMES.
         10  PAGE-TERMINAL-TYPE  PIC X.
         10  PAGE-DSC-ADDRESS    PIC XXX.
 01  PAGE-DATA-AREA.
     05  PAGE-TIOA-PREFIX.
         10  FILLER              PIC X(8).
         10  PAGE-LENGTH         PIC 9(4)    COMP.
         10  FILLER              PIC X(2).
     05  PAGE-DSC-AREA           PIC X(9999).
        .
        .
 PROCEDURE DIVISION.
        .
        .
     EXEC CICS SEND    MAP     ('MAPNAME')
                       MAPSET  ('MSETNAM')
                       SET     (PAGE-LIST-ADDR)
     END-EXEC.
        .
        .
     CALL 'DFHMFSET' USING PAGE-LIST-ENTRY (1)
                           PAGE-DATA-POINTER.
     SET ADDRESS OF PAGE-DATA-AREA TO PAGE-DATA-POINTER.
        .
        .
     EXEC CICS SEND TEXT MAPPED
                       FROM    (PAGE-DSC-AREA)
                       LENGTH  (PAGE-LENGTH)
     END-EXEC.
        .
Parent topic: Examples


Developing Exit Programs

  • Introduction to Developing Exit Points
  • Global and Task-related Exit Programs
  • Security Exit Programs
Parent topic: CICS Support


Introduction to Developing Exit Points

A user exit is a point in MSS itself at which control can be transferred to a user-written program and at which MSS can resume control after it has finished. The following types of user exit program are supported:

  • Global exit programs. A global user exit is a point in the code that is unrelated to any particular CICS task; for example before control is transferred to an application program. The following types of global user exits are supported:
    • XZCATT
    • XZCIN
    • XZCOUT
    • XEIIN
    • XEIOUT
    • XWBOPEN
    • XWBSNDO
    • XWBAUTH
  • Task-related exit programs. A task-related user exit is a point in the code that handles task-related functions such as rollbacks and commits.
  • Security exit programs. A security exit program is an exit program written to emulate the behavior of the QUERY SECURITY CICS command.

You must write separate global and task-related user exits. You must write all user exit programs in non-mainframe COBOL. They must not use EXEC CICS commands, and they must use native addressing for pointers.

Parent topic: Developing Exit Programs
Related concepts
CICS Web Interface Support
Related information
Global and Task-related Exit Programs


Global and Task-related Exit Programs

You must enable each user exit that an application program needs before it is called, and you can disable it when the application program has finished with it, though you do not have to; user exits are always disabled by default when CICS starts up. You use the CICS command ENABLE PROGRAM to enable a user exit program, and the CICS command DISABLE PROGRAM to disable a user exit program. If you try to enable an invalid exit an EIBRCODE of X'804000' is returned. If you try to enable an exit that is valid but not implemented, an EIBRCODE of X'804010' is returned. The EXTRACT EXIT command is also provided; you use this to gain access to the work area of a user exit program. For details of the level of support provided for these commands see the topic System Programmers Commands.

You must define each user exit program as a program (in the PLT) and the definition must be available on the running system.

For information about global user exits and task-related user exits see the IBM manual CICS/ESA 3.3 Customization Guide. This manual contains a list of valid user exit points.

You need to include the following two copybooks in your user exit program, whether it is for a global user exit or a task-related user exit:

  • dfhcbuxi.cpy:
          78 78-uxi-TRUE                          value  1.
        78 78-uxi-XZCATT                        value  2.
        78 78-uxi-XZCIN                         value  3.
        78 78-uxi-XZCOUT                        value  4.
        78 78-uxi-XEIIN                         value  5.
        78 78-uxi-XEIOUT                        value  6.
        78 78-uxi-XWBOPEN                       value  7.
        78 78-uxi-XWBSNDO                       value  8.
        78 78-uxi-XWBAUTH                       value  9.

      ***--------------------------------------------------------------*
      ***  Base parameters                                             *
      ***--------------------------------------------------------------*
        01 uxi-user-exit-interface.
           02 uxi-operational-flags-ptr         pointer.
           02 uxi-scheduling-flags-ptr          pointer.
           02 uxi-global-area-ptr               pointer.
           02 uxi-global-area-length            pic x(4) comp-5.
           02 uxi-local-area-ptr                pointer.
           02 uxi-local-area-length             pic x(4) comp-5.
           02 uxi-dfheiblk-ptr                  pointer.
           02 uxi-unit-of-recovery-ptr          pointer.
      ***--------------------------------------------------------------*
      ***  Exit specific parameters                                    *
      ***--------------------------------------------------------------*
           02 uxi-exit-specific-ptrs.         *> XZCATT In/Out XEin/out
            03 uxi-resource-ptr      pointer. *> TCTTE  TCTTE  Arg list
            03 uxi-resource-data-ptr pointer. *> TIOA   TIOA   user-id
            03 uxi-res-data-len-ptr  pointer. *>  *      *
            03 uxi-aux-1-ptr         pointer. *> APPC          program
            03 uxi-aux-1-length-ptr  pointer. *>  *
            03 uxi-aux-2-ptr         pointer. *> Tran          Sys EIB
            03 uxi-aux-2-length-ptr  pointer. *>
            03 uxi-aux-3-ptr         pointer. *> TEUA   TEUA
            03 uxi-aux-3-length-ptr  pointer. *>  *      *
            03 uxi-aux-4-ptr         pointer. *> ComA   ComA
            03 uxi-aux-4-length-ptr  pointer. *>  *      *
            03                       pointer. *>
      ***--------------------------------------------------------------*
      ***  System parameters                                           *
      ***--------------------------------------------------------------*
           02 uxi-PCA-ptr                       pointer.
           02 uxi-CSA-ptr                       pointer.
           02 uxi-DCA-ptr                       pointer.
           02 uxi-local-trace-table-ptr         pointer.
  • dfhcbuxc.cpy:
            01 lk-uxc-operation.
           03 lk-uxc-exit-id                   pic x comp-x.
              88 lk-uxc-TRUE-88                value 78-uxi-TRUE.
              88 lk-uxc-XZCATT-88              value 78-uxi-XZCATT.
              88 lk-uxc-XZCIN-88               value 78-uxi-XZCIN.
              88 lk-uxc-XZCOUT-88              value 78-uxi-XZCOUT.
              88 lk-uxc-XEIIN-88               value 78-uxi-XEIIN.
              88 lk-uxc-XEIOUT-88              value 78-uxi-XEIOUT..
              88 lk-uxc-XWBOPEN-88             value 78-uxi- XWBOPEN.
              88 lk-uxc-XWBSNDO-88             value 78-uxi- XWBSNDO.
              88 lk-uxc-XWBAUTH-88             value 78-uxi- XWBAUTH.

           03 lk-uxc-schedule                  pic x.
              88 lk-uxc-generic-88             value x'80'.
              88 lk-uxc-TRUE-on-start-88       value x'80'.
              88 lk-uxc-TRUE-on-sync-88        value x'40'.
              88 lk-uxc-TRUE-on-prep-88        value x'20'.
              88 lk-uxc-TRUE-on-tr-wrap-88     value x'01'.
           03 lk-uxc-modifier                  pic x    comp-x.
              88 lk-uxc-user-syncpoint-88      value 0.
              88 lk-uxc-task-syncpoint-88      value 1.
              88 lk-uxc-task-start-88          value 2.
              88 lk-uxc-initialization-88      value 254.
              88 lk-uxc-shutdown-88            value 255.
           03 lk-uxc-action                    pic x    comp-x.
              88 lk-uxc-syncpoint-commit-88    value 0.
              88 lk-uxc-syncpoint-rollback-88  value 1.
              88 lk-uxc-syncpoint-prepare-88   value 2.
           03 lk-uxc-return-code               pic x(4) comp-5.

        01 lk-uxc-schedule-parm.
           03 lk-uxc-schedule-byte             pic x.
           78 78-lk-uxc-TRUE-on-start          value x'80'.
           78 78-lk-uxc-TRUE-on-sync           value x'40'.
           78 78-lk-uxc-TRUE-on-prep           value x'20'.
           78 78-lk-uxc-TRUE-on-tr-wrap        value x'01'.
Note:
  • The user exit parameters are passed to your exit program in structure uxi-user-exit-interface, defined in the copybook dfhcbuxi.cpy. Two fields in this structure, uxi-operational-flags-ptr and uxi-scheduling-flags-ptr, point respectively to two further structures, lk-uxc-operation and lk-uxz-schedule-param, in the other copybook, dfhcbuxc.cpy.
  • A CICS application can call a task-related user exit directly, for example, to obtain the address of the task area. Normally, the CICS application would call a task-related user exit program with the DFHRMCAL macro. As this macro is not supported, the application must call the user exit program directly, and must include the copy books dfhcbuxi.cpy and dfhcbuxc.cpy. If a user exit program can be called by an application program, you need to use a mechanism by which the exit program can decide whether it was called by an application program or by MSS. The sample exit program included below shows one approach: the application sets an unused bit in lk-uxc-schedule, which the user exit program tests for.

Here is a skeleton example of a task-related user exit program:

       id division.
       program-id. samptrue.
       environment division.
       configuration section.
       input-output section.
       data division.
       file section.
       working-storage section.
       01 work-scl.
           02 ws-allocate-local.
              03 ws-allocate-local-ptr-x.
                 04 ws-allocate-local-ptr       pointer.
              03 ws-allocate-local-size         pic x(4) comp-5.
              03 ws-allocate-local-return       pic x(4) comp-5.
                 88 ws-allocate-local-ok-88        value 0.
                 88 ws-allocate-local-no-space-88  value 1.
                 88 ws-deallocate-local-invalid-88 value 2.
                 88 ws-deallocate-inv-length-88    value 157.
           02 ws-allocate-local-type            pic x.
           02                                   pic x.
           02 ws-mfpm-register-flag             pic x(2).
              88 ws-mfpm-assign-24-88              value x'0000'.
              88 ws-mfpm-absolute-24-88            value x'0200'.
              88 ws-mfpm-assign-31-88              value x'0001'.
              88 ws-mfpm-absolute-31-88            value x'0201'.
           02 ws-mfpm-allocate-size             pic x(4) comp-x.
           02 ws-mfpm-allocate-ptr-x.
              03 ws-mfpm-allocate-ptr           pointer value null.
       linkage section .
       copy 'dfhcbuxi.cpy'.
       copy 'dfhcbuxc.cpy'.
       01 lk-global-area.
           03 lk-ga-byte pic x occurs 0 to 4096
               depending on uxi-global-area-length.
       01 lk-local-area.
           03 lk-la-byte pic x occurs 0 to 4096
               depending on uxi-local-area-length.
       procedure division using
                           uxi-user-exit-interface.
       module-entry-point.
           move 0                      to return-code
           set address of lk-uxc-operation
               to uxi-operational-flags-ptr
           set address of lk-uxc-schedule-parm
               to uxi-scheduling-flags-ptr
           move 0                      to lk-uxc-return-code
           *> -- Are we being called by an application?
           *> -- (User application sets unused value in lk-uxc-schedule.)
           if lk-uxc-schedule = x'02'
               perform called-by-application
               goback
           end-if
           *> -- Register syncpoint interest
           move 78-lk-uxc-TRUE-on-sync to lk-uxc-schedule-byte
           *> -- Register start of task interest
           call "CBL_OR" using
               78-lk-uxc-TRUE-on-start
               lk-uxc-schedule-byte
               by value 1
           end-call
           *> -- Register any other interest here by OR'ing bits
           *> -- in lk-uxc-schedule-byte as above.
           if lk-uxc-exit-id not = 0 *> -- handle only TRUEs
               goback
           end-if
           evaluate true
           when lk-uxc-initialization-88
           when lk-uxc-shutdown-88
               goback
           when lk-uxc-task-start-88
               perform save-TA-address
           when lk-uxc-task-syncpoint-88
               perform end-task-process
           when lk-uxc-user-syncpoint-88
               set address of lk-global-area
                   to uxi-global-area-ptr
               set address of lk-local-area
                   to uxi-local-area-ptr
               evaluate true
               when lk-uxc-syncpoint-prepare-88
                   *> -- We haven't registered an interest for this
                   continue
               when lk-uxc-syncpoint-commit-88
                   perform commit-process
               when lk-uxc-syncpoint-rollback-88
                   perform rollback-process
               end-evaluate
           end-evaluate
           goback
           .
       called-by-application section.
           *> -- Add any code here that you wish to execute when
           *> -- called by an application program.
           *> -- This sample passes back the address of the local
           *> -- task area.
           set uxi-local-area-ptr      to ws-mfpm-allocate-ptr
           exit
           .
       save-TA-address section.
           *> -- Convert local task area address and save in W/S.
           exit
           .
       end-task-process section.
           *> -- Insert code here that you wish to perform at
           *> -- end of task.
           exit
           .
       commit-process section.
           *> -- Insert code here that you wish to perform at
           *> -- user syncpoint.
           exit
           .
       rollback-process section.
           *> -- Insert code here that you wish to perform at
           *> -- user backout.
           exit
           .
Parent topic: Developing Exit Programs
Related concepts
CICS Web Interface Support
Related information
Introduction to Developing Exit Points
CICS/ESA 3.3 Customization Guide


Security Exit Programs

MSS emulates the behavior of the QUERY SECURITY CICS command by calling a user exit program. On the mainframe the QUERY SECURITY command interrogates an external security manager (ESM) such as IBM's RACF and returns information to the application about the level of access that a particular end-user is allowed to have to a particular resource. The user exit program must return the same information.

A default user exit program is supplied, and as supplied, this program returns NOT for all types of access. In other words, if your CICS application issues the QUERY SECURITY command, the result is always that access is denied. If you want any other behavior, you must alter the supplied exit program.

  • Interface
  • Error Conditions
Parent topic: Developing Exit Programs


Interface

The user exit program must be called dfhuesm. We provide a sample program and a copy book that defines the parameters passed between MSS and the exit program. We also provide a generated code file (.gnt) for both 32- and 64-bit platforms. These files are located in:

File | Location
dfhuesm.cbl | %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source and \base\source\win64
dfhcbesm.cpy | %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source and \base\source\win64
dfhuesm.gnt | %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin

When the QUERY SECURITY command is issued, the input parameters are set using the information supplied by your application. The parameters are as follows:

Field | Value
esm-version-no | Indicates the version of the parameter blocks. Micro Focus will increment this value if it issues an updated interface.
esm-user-id | The ID for the current user. If the user has not signed on, this field contains binary zeroes.
esm-opid | The operator ID associated with the user as defined in the sign-on table. If the user has not signed on, this field contains binary zeroes.
esm-opclass | The operator class associated with the user. This field contains character zeroes, unless the user has not signed on, in which case it contains binary zeroes.
esm-arg-01-flag | Unused.
esm-arg-02-flag | A value of 1 indicates that the application has used the RESTYPE keyword; the field esm-restype contains a valid resource type.
esm-arg-03-flag | A value of 1 indicates that the application has used the RESID keyword. This is mandatory, so this field is always set to 1. See the field esm-resid.
esm-arg-04-flag | A value of 1 indicates that the application has used the RESIDLENGTH keyword. See the field esm-residlength.
esm-arg-05-flag | A value of 1 indicates that the application has used the READ keyword. See the field esm-read.
esm-arg-06-flag | A value of 1 indicates that the application has used the UPDATE keyword. See the field esm-update.
esm-arg-07-flag | A value of 1 indicates that the application has used the RESCLASS keyword; the field esm-resclass contains a resource class.
esm-arg-08-flag | A value of 1 indicates that the application has used the ALTER keyword. See the field esm-alter.
esm-arg-09-flag | A value of 1 indicates that the application has used the CONTROL keyword. See the field esm-control.
esm-arg-10-flag | A value of 1 indicates that the application has used the LOGMESSAGE or the LOG keyword. See the field esm-logmessage.
esm-arg-11-flag | Unused.
esm-arg-12-flag | Unused.
esm-arg-13-flag | Unused.
esm-arg-14-flag | Unused.
esm-arg-15-flag | Unused.
esm-arg-16-flag | Unused.
esm-restype If specified, this field contains one of the following values:
  • DB2ENTRY
  • FILE
  • JOURNALNAME
  • JOURNALNUM
  • PROGRAM
  • PSB
  • SPCOMMAND
  • TDQUEUE
  • TRANSACTION
  • TRANSATTACH
  • TSQUEUE
esm-resclass | If specified, this field contains the name of a resource class.
esm-residlength | If specified, this field contains the number of significant characters in the field esm-resid.
esm-resid | This field contains the ID of a resource, the user's access to which the application needs to query. It may either be a CICS resource ID of up to 12 characters or a user-defined resource ID of up to 240 characters.
esm-logmessage | If specified, this field notifies the user exit program as to whether security violations are to be logged or not. On the mainframe, this field is used to tell CICS to log security violations. It is provided for compatibility with the mainframe; however, security violations are not logged.

The user exit program sets the output parameters, which are as follows:

Field | Value
esm-eibresp | This field contains either zero to indicate that the QUERY SECURITY call is valid, or a non-zero value to indicate otherwise. This value is returned to the application program in the EIBRESP field. It is the responsibility of the user exit program to ensure that a correct value is placed here. It should be necessary to return only the NOTFND or QIDERR condition, but you are not restricted in doing so.
esm-eibresp2 | If your exit program returns a non-zero value in the field esm-eibresp, it must return a non-zero value in this field. The only values that your exit program needs to return are 1, 3, 5 or 8 for the NOTFND condition, or 1 for the QIDERR condition. This value is returned to the application in the EIBRESP2 field.
esm-eibrcode | If your exit returns a non-zero value in the field esm-eibresp, then it must place a hexadecimal value in this field. This value is returned to the application program in the EIBRCODE field.
esm-alter | If the application has requested the ALTER status for the named resource (field esm-arg-08-flag set), then the exit program must return a CVDA value of either ALTERABLE or NOTALTERABLE in this field.
esm-control | If the application has requested the CONTROL status for the named resource (field esm-arg-09-flag set), then the exit program must return a CVDA value of either CTRLABLE or NOTCTRLABLE in this field.
esm-read | If the application has requested the READ status for the named resource (field esm-arg-05-flag set), then the exit program must return a CVDA value of either READABLE or NOTREADABLE in this field.
esm-update | If the application has requested the UPDATE status for the named resource (field esm-arg-06-flag set), then the exit program must return a CVDA value of either UPDATABLE or NOTUPDATABLE in this field.
Note: All character fields in the input parameter block are encoded in ANSI, even though they may have originated from an EBCDIC program. If you need the data in EBCDIC, then you will have to convert the data.
Parent topic: Security Exit Programs
Related information
National Locale Support
Internationalization Support


Error Conditions

When a QUERY SECURITY command is encountered the command is validated and may return one of a number of error conditions. If the command passes validation, the input fields are set up and control is passed to the user exit program. The user exit program may then itself perform some validation and reject the requests.

The following table shows the error conditions that can be returned:

Error Condition (EIBRESP field) | Further information (EIBRESP2 field)
INVREQ | 7 | LOGMESSAGE does not contain either LOG or NOLOG
 | 9 | RESID is invalid or filled with blanks
 | 10 | The external security manager (ESM) is inactive or not present. This means that the user exit program is missing.
LENGERR | 6 | The RESIDLENGTH value is not valid, that is, it is not in the range 1 through 246
NOTFND | 2 | The RESTYPE value is not valid

The following table shows the error conditions that you are most likely to need to check for in your exit program.

Error Condition (EIBRESP field) | Further information (EIBRESP2 field)
NOTFND | 1 | The RESID value is not valid
 | 3 | The RESID value for RESTYPE (SPCOMMAND) not valid.
 | 5 | The RESCLASS is not defined to the external security manager (ESM).
 | 8 | The resource is not protected. This is only returned when QUERY SECURITY is used with the RESCLASS option (and never occurs with RESTYPE).
QIDERR | 1 | An indirect queue name associated with the given RESID is not found

If any of these error codes are returned to an application program that does not provide error handling, the application abends.

Parent topic: Security Exit Programs


IMS Support

  • Developing IMS Applications
    This chapter describes the basic operations you need to perform when developing IMS applications.
  • IMSDBU Utility
    Information about the IMSDBU utility, which is an IMS database management tool.
Parent topic: Mainframe Programming


Developing IMS Applications

  • Sample Files
  • Generating DBDs
  • Generating PSBs
  • Generating MFSs
  • Loading Databases
  • Converting Segments from EBCDIC to ANSI
  • Exit Routines
    Describes the use of input message segment and field exits and data capture exits in the context of an IMS application.
  • Running an IMS Transaction
  • Performing a Cold Start
  • IMS flags
  • How to...
Parent topic: IMS Support


Sample Files

These sample files are located by default in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Net Express IDE\MTO-IMS\IVP directory.

Sample File | Filename | Description
Mainframe IMS/ESA DB extract | IMSDBUV.CBL | Can be used on your mainframe to extract an IMS/ESA database into a variable length sequential file for downloading and subsequent loading by the IMSDBU utility. IMSDBUV creates a formatted file specifically for use by IMSDBU on the PC. It can optionally compress the segment data to reduce disk space and transfer time.
Mainframe IMS DB extract JCL | IMSDBUV.JCL | Sample JCL for use with the IMSDBUV.
Mainframe IMS DB extract compression | IMSDBUC.CBL | Compression program for IMSDBUV.
IMSDBU Load and Unload exits | DBUPARMS.CPY | IMSDBU provides two exits during Load, Add and Unload processing. One allows for selecting and changing segments. The other provides for compression/decompression of the input and output sequential files.
Dynamic DB attach interface
  • DDBA.CBL
  • DDBA.TXT
The Dynamic DB Attach interface is a flexible way to 'connect' to IMS Option for issuing database calls. DDBA.TXT describes the detailed specifications for this API. DDBA.CBL is a sample program to demonstrate its use. An MFIMSCOB.DLL is provided with the IMS Option installation to allow other language programs to call the dynamic attach interface. See the MFIMSCOB.TXT file for details.
Gen file access
  • IMS86GIO.TXT
  • CALLGIO.CBL
CALLGIO demonstrates using the IMS86GIO call interface to retrieve and update the Trancode, Printer, DBD, PSB and MFS Gen, DB Catalog and System Configuration. The IMS86GIO.TXT file provides a complete description of the parameters and use of these APIs.
User entry point management | IMS86ENT.CBL | Option initialization and termination and invocation of IMS applications.
Utility call interface
  • IMS86GIO.TXT
  • CALLUTIL.CBL
  • CALLGIO2.CBL
CALLUTIL demonstrates the use of the callable interface for the utilities. CALLGIO2 combines IMS86GIO with other features to reorganize the Gen files from a command line and other sample uses.
IMSDBU call interface | DBUDEMO.CBL | Demonstrates the use of the direct call interface to IMSDBU for advanced DB administration.
MFSGEN preprocessor exit | MFSPREPR.CBL | Allows programmed modification of MFS source input to the MFSGEN utility.
COBOL DB sparse routine | SPARSRTN.CBL | A COBOL example for implementing Database Secondary Index sparse routines in COBOL.
Field exit routine | DFSME000.cbl | A COBOL implementation of the DFSME000 Assembler MFS field edit exit routine provided with the IMS/ESA product.
Segment exit routine | DFSME127.cbl | A COBOL implementation of the DFSME127 Assembler MFS segment edit exit routine provided with the IMS/ESA product.
Parent topic: Developing IMS Applications


Generating DBDs

To generate DBDs you must first have added them to your project.

Note:

When you build a project, the non-COBOL files are built in the order in which they were added to the project. To ensure that a project's DBD files are genned before its PSB files you must add the DBD files to the project before the PSB files.

Generating a DBD updates the following files:

  • dbdname.acb
  • dbdgen2.dat
  • dbdgen2f.dat

These files contain DBD source information that has been extracted and formatted into a smaller structure optimized for faster access during execution. The .dat files files are indexed files and can contain one or more generated DBD members.

When you generate the first DBD you will see message DBDUT0U35U informing you that dbdgen2.dat does not exist. Enter C to specify that you want to create dbdgen2.dat (and dbdgen2f.dat) and message DBDUT0U35U will not be displayed on subsequent DBD generations.

The dbdgen*.* and dbdname.acb files are created in the current directory. You need to ensure that you specify the location of these files to the enterprise server that you will be using. See the section Specifying the Location of Genned Files in the chapter Configuring IMS-enabled Enterprise Servers for more information.

Parent topic: Developing IMS Applications
Related information
Specifying the Location of Genned Files


Generating PSBs

Once you have generated the DBDs you need to generate the PSBs. To generate PSBs you must first have added them to your project.

Note: When you build a project, the non-COBOL files are built in the order in which they were added to the project. To ensure that a project's DBD files are genned before its PSB files you must add the DBD files to the project before the PSB files.

Generating a PSB updates the following files:

  • psbname.acb
  • psbgen3.dat

These files contain PSB source information that has been extracted and formatted into a smaller structure optimized for faster access during execution. psbgen3.dat is an indexed file and can contain one or more generated PSB members.

When you generate the first PSB you will see message DBDUT0U35U informing you that psbgen3.dat does not exist. Enter C to specify that you want to create psbgen3.dat and message DBDUT0U35U will not be displayed on subsequent PSB generations.

The psbgen3.dat and psbname.acb files are created in the current directory. You need to ensure that you specify the location of these files to the enterprise server that you will be using.

Parent topic: Developing IMS Applications


Generating MFSs

To generate MFSs you must first have added them to your project.

When you compile an IMS format, the system will generate .mid, .mod, .dif and .dof files, which are analogous to those created on a mainframe. However, in this system, the .dif and .dof file names do not generate hexadecimal file names. Instead, character-based names are generated. In addition, an extended file of suffix mfsx is generated – this is used by the IDE for controlling build dependencies.

  • mfsname.mfsx

The environment variable ES_MFSLIB is used to tell MFSGEN where to store the generated files. These files contain MFS source information that has been extracted and formatted into a smaller structure optimized for faster access during execution.

The .mid and .mod files are created in the current directory. You need to ensure that you specify the location of these files to the enterprise server that you will be using.

When you generate the first MFS you will see message DBDUT0U35U informing you that mfspef.dat does not exist. Enter C to specify that you want to create mfspef.dat (and the other files from the above list) and message DBDUT0U35U will not be displayed on subsequent MFS generations.

Parent topic: Developing IMS Applications


Loading Databases

To load a database you can either use the database management utility (as described in the section IMSDBU Utility) or perform the following steps:

  1. Navigate to the folder containing the .dat files.
  2. Enter the following command for each .dat file:
    mfims imsdbu load datfilename
Note: If you have more than one database to load you can use the Windows for command to simplify this operation, for example:
for %i in (*.dat) do mfims imsdbu load %i
datfilename is case sensitive.

By default, this loads the database from a file with the same basename as datfilename but with the extension .DBU. You can change this behavior using the DSN and LAYOUT options.

Parent topic: Developing IMS Applications
Related information
IMSDBU Utility


Converting Segments from EBCDIC to ANSI

Mainframe Subsystem Support includes a segment exit routine called IMSDBUEA that you can use to convert segments from EBCDIC to ANSI. You can use it in three ways:

  • when unloading, causing the output to be written in ANSI.
  • when loading, causing the file to be converted before it is loaded.
  • when adding segments, causing the segments to be converted before they are added.

IMSDBUEA uses a segment layout (.slf) file to determine which fields of each segment need to be converted, so you must create an .slf file using the IMS database editor before you can use IMSDBUEA. The .slf file must be in the directory specified by the ES_IMSDAT environment variable, or if the ES_IMSDAT environment variable is not set the .slf file must be in the current directory.

How you use IMSDBUEA depends on whether you are using the database management utility or the command line:

  • If you are using the database management utility specify IMSDBUEA in the SEGEXIT field when adding segments or loading or unloading a database.
  • If you are using the command line, add the following parameter:segexit=imsdbuea
It is not possible for IMSDBUEA to call one of your segment exit routines. However, if you need to perform some additional processing before converting from EBCDIC to ANSI you can write your own segment exit routine that performs the required processing, and then calls IMSDBUEA. To call this exit, which is actually an entry point, directly from your program, load its parent program, MFIMSDBU, first and use DBUPARMS.CPY. For example:
       PROCEDURE DIVISION.
      *=========================================================*

***** Load the MFIMSDBU module first.

     set ws-ptr to entry "MFIMSDBU"
     if ws-ptr = null
         display "Cannot Load MFIMSDBU DLL"
         display "Need to Die gracefully."
         stop run
      end-if

           MOVE 02                     TO SEGEXIT-VERSION
           MOVE 00                     TO SEGEXIT-FUNC
           MOVE 'P155'                 TO SEGEXIT-DBD
           MOVE 'P155SEG'              TO SEGEXIT-SEGM
           MOVE 10                     TO SEGEXIT-SEGM-LTH
           MOVE 10                     TO SEGEXIT-SEGM-MAX-LTH
           MOVE P155SEG                TO SEGEXIT-DATA

           CALL 'IMSDBUEA' USING SEGEXIT-PARMS
                                 SEGEXIT-DATA.

mftech     MOVE 02                     TO SEGEXIT-VERSION
mftech     MOVE 01                     TO SEGEXIT-FUNC
mftech     MOVE 'P155'                 TO SEGEXIT-DBD
mftech     MOVE 'P155SEG'              TO SEGEXIT-SEGM
mftech     MOVE 10                     TO SEGEXIT-SEGM-LTH
mftech     MOVE 10                     TO SEGEXIT-SEGM-MAX-LTH
mftech     MOVE P155SEG                TO SEGEXIT-DATA
mftech
mftech     CALL 'IMSDBUEA' USING SEGEXIT-PARMS
mftech                           SEGEXIT-DATA.
Note:
  • You cannot create another segment exit called IMSDBUEA.
  • IMSDBUEA performs the conversion using the COBOL program _CODESET. By default, _CODESET uses the EBCDIC and ANSI codepages in use on your PC. If you need to convert using different codepages you must use the codecomp utility to create customized mapping tables. For more information see The Codecomp Utility and the section Converting between EBCDIC and ASCII in the File Handling topic Converting Data Files.
Parent topic: Developing IMS Applications


Exit Routines

Describes the use of input message segment and field exits and data capture exits in the context of an IMS application.
Note: Exit routines load and execute in the application address space, effectively becoming part of the application. For example, if 10 active applications, each executing in MPRs, or with JES initiators, etc. and each calling the same exit routine, results in 10 active copies of the same exit routine. These exit routines do not share memory with each other, and execute fully isolated from each other.
  • Input Message Segment and Field Exits
    Describes the use of IMS MFS input message segment exits and input message field exits.
  • Data Capture Exits
    Describes the use of IMS data capture exits.
Parent topic: Developing IMS Applications


Input Message Segment and Field Exits

Studio Enterprise Edition supports the use of MFS input message field and segment exits in COBOL.

  • Coding Requirements
  • Run-time Requirements
  • Run-time Behavior
  • Examples
  • Troubleshooting
Parent topic: Exit Routines
Related reference
IMS-Specific Environment Variables
Related information
Control


Coding Requirements

To include MFS input message segment and field exits in IMS applications, follow these coding standards:
  • Write all input message segment and field exits in COBOL. This is different from IMS/ESA, where segment and field exits are written in Assembler.
  • Use the IMS/ESA naming convention as follows:
    DFSMEnnn
    Where nnn is the exit number expressed as a three-digit decimal number from 000 through 127. For example, for field exit number zero, use the name DFSME000.
  • Segment and field exits receive ASCII data. If the exit program is written for EBCDIC, it must also convert the IMS data it receives in ASCII from ASCII into EBCDIC, and convert the data from EBCDIC back to ASCII before exiting.
  • Be sure that segments are not modified such that they are rendered invalid. Invalid segments can cause runtime errors.
  • Do not use an exit to invoke IMS callable services, including storage services and control block services.
Note: If an MFS source references an exit that does not exist, the program behaves as if there were no exit coded in the MFS. Exception conditions returned by the exit are written to the server console log.
Parent topic: Input Message Segment and Field Exits


Run-time Requirements

The following are run-time requirements for IMS segment and field exits:

  • Compile all segment and field exits.
  • Place the compiled code in the directory specified by the ES_IMS_EXITPATH environment variable or, alternatively, in the directory specified by the COBPATH environment variable. Enterprise Server searches for segment and field exits in that order and uses the first matching exit found.
Parent topic: Input Message Segment and Field Exits


Run-time Behavior

The following describes the run-time behavior for IMS segment and field exits.

  • As the enterprise server is started, the names of the exits found are written to the server console log. For example, the following represents a typical server console log entry:
    120131 13172725 4684 IMSTEST CASTM5044I IMS TM exit programs loaded:
DFSME000.dll, DFSME127.dll 13:17:27
  • For input message field exits, the parameter list format passed to the exit has the same format as that passed by IMS/ESA.
  • For input message segment exits, the parameter list format passed to the exit has the same format as that passed by IMS/ESA with the exception of an extra field, DFSME-R1-RETURN, at the end of the control block. DFSME-R1-RETURN contains a user-defined error message number when the segment exit issues a return code of 12, canceling the message.
  • We do not support segment exit return code 16. A segment that returns a value of 16 does not send a message to the input device.
Parent topic: Input Message Segment and Field Exits


Examples

The sample segment and field exits provided are supported only for MFS source that uses the option 1 and 2 formats. All sample files are located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Net Express IDE\MTO-IMS\IVP by default.

Field Exit Routine
We provide a sample program, DFSME000.cbl, containing a field exit routine. It is a COBOL implementation of the DFSME000 Assembler MFS field edit exit routine provided with the IMS/ESA product. This program contains comments further describing the use of input message field exits. The following is an excerpt from the Linkage Section of DFSME000.cbl, showing the parameter list format:
       01  FIELDEXIT-PARMS.
           05  FLDFLAG             PIC  X(01).
           05  FILLER              PIC  X(01).
           05  FLDELTH             PIC  X(01) COMP-X.
           05  FLDVECT             PIC  X(01) COMP-X.
           05  FLDLTH              PIC  X(04) COMP-X.
           05  FLDADDR             USAGE POINTER.
Segment Exit Routine
We provide a sample program, DFSME127.cbl containing a segment exit routine. It is a COBOL implementation of the DFSME127 Assembler MFS segment edit exit routine provided with the IMS/ESA product. The following is an excerpt from the Linkage Section of DFSME127.cbl, showing the parameter list format:
       01  DFSME-PARM.
           05  DFSME-FLAG              PIC X(01).
           05  FILLER                  PIC X(01).
           05  FILLER                  PIC X(01).
           05  DFSME-VECTOR            PIC X(01)   COMP-X.
           05  DFSME-LTH               PIC X(04)   COMP-X.
           05  DFSME-ADDR              POINTER.
           05  DFSME-FLDEXIT-RC        PIC X(04)   COMP-X.
           05  DFSME-NEXT-MODNAME      PIC X(08).
           *>  NEXT FIELD IS IN COBOL PARM BLOCK ONLY
           05  DFSME-R1-RETURN         PIC X(04)   COMP-X.
Parent topic: Input Message Segment and Field Exits


Troubleshooting

Segment and field exits can generate trace entries that are useful for troubleshooting.

Enabling Trace
You enable the generation of segment and field exit trace entries from Server Enterprise Edition Administration as follows:
  1. From the Server Enterprise Edition Administration Home page, start the enterprise server that runs your application.
  2. Click Edit for the started enterprise server.
  3. Click Server > Control > ES Monitor & Control.
  4. Click Control.
  5. Under Trace Points > Server, check exits.
Viewing Trace Entries
MSS writes trace information for Trace diagnostics A and B datasets to the files casauxta.rec and casauxtb.rec respectively. By default, both are located in the System directory, %USERPROFILE%\Documents\Micro Focus\Net Express x.x\WORKAREA \es-name (where es-name is the name of the enterprise server). However, you can view trace entries in real time, including C/x trace information, by clicking Display.
Trace IDs
Trace entries are generated in entry and exit pairs using six-digit hexadecimal IDs as follows:
  • Digits one and two are 39. These indicate that the entry is for MFS.
  • Digits three and four are unique to the emitting source module.
  • Digit five is a 0 (zero).
  • Digit six indicates the type of trace entry, as follows:
    3 | entry
    4 | exit
    9 | error
The following lists MFS trace IDs along with their significance and the variable content of each.
x'390103', Segment exit entry, exit number, vector
x'390204', Segment exit exit, return code, segment number
x'390303', Field exit entry, exit number, vector
x'390404', Field exit exit, return code, max return code
x'390509', Segment exit missing, exit number, intended vector
x'390609', Field exit missing, exit number, intended vector
Example
In this example, the first field exit is for exit number 100 and vector 100. However, Server Enterprise Edition has failed to load the module. In this case, the error is simply recorded and processing continues. The second trace entry reveals that exit 5 was given control for vector 5. The third trace entry records the return code and the running maximum return code for the field exits at the return of exit 5. Processing continues on to the next to the last trace entry where segment exit 126 is called with vector 14. The return from the segment exit is 0 (zero) and the current segment is 1.
Note: In trace output, the trace ID includes a prepended "39 " indicating that the entry is from casmfs.dll, and digit five is shown as 8 instead of 0 (zero).
                                  Seq  Task-Nbr  ProcessID +---ID--+ hhmmsshh
mfsFldExitER(  100 )v(   100 )    654      6652      12312 39 390689 22105958
mfsFldExit(      5 )v(     5 )    655      6652      12312 39 390383 22105958
mfsFldExitRC(    0 )max(   0 )    656      6652      12312 39 390484 22105958
mfsFldExit(      5 )v(     1 )    657      6652      12312 39 390383 22105958
mfsFldExitRC(    8 )max(   0 )    658      6652      12312 39 390484 22105958
mfsFldExit(      5 )v(     1 )    659      6652      12312 39 390383 22105958
mfsFldExitRC(    0 )max(   8 )    660      6652      12312 39 390484 22105958
mfsFldExit(      5 )v(     1 )    661      6652      12312 39 390383 22105958
mfsFldExitRC(    0 )max(   8 )    662      6652      12312 39 390484 22105958
mfsSegExit(    126 )v(    14 )    663      6652      12312 39 390183 22105958
mfsSegExitRC(    0 )seg(   1 )    664      6652      12312 39 390284 22105958
Parent topic: Input Message Segment and Field Exits


Data Capture Exits

Studio Enterprise Edition supports the use of IMS data capture exits in COBOL according to the IBM mainframe IMS documentation, except as noted in this documentation; however the functionality of the IBM Data Propagator product is not provided. See the IBM Web site for access to IBM documentation.

Data capture exits enable updates to segments in a DL/I database to be passed to a data capture exit program. Mainframe IMS provides these exits to propagate data to DB2, commonly using the IBM Data Propagator product. Data Propagator takes the data capture exits and uses them to propagate data to DB2. You can also write your own data capture exits to perform propagation or other functions.

  • Enabling
  • Coding Requirements
  • Run-time Behavior
Parent topic: Exit Routines


Enabling

Data capture is enabled by default. Therefore, if the database has exits defined, we execute them.

We do not require that you compile or assemble all of the exits defined in your DBDs. Simply download the exits required by your application. If the runtime cannot locate a specific exit program, it writes a message to the console log and continues as if the exit were not defined in the DBD.

Data Capture exits that are defined must be present. If your DBD source contains one or more data capture exits that are not needed to support a migrated application, remove them from the source or use the NODCX DBDGEN command to prevent Server Enterprise Edition from loading them.

Parent topic: Data Capture Exits


Coding Requirements

Use the following as guidelines when coding data capture exits:
  • We support data capture exits written in COBOL.
  • We support a maximum of nine exit routines for any one DBD segment, with no limit on the total number of data capture exits defined for all segments in a DBD.
  • One IMS application region supports a maximum of 256 active exit routines. This means that you can define any number of exits in the DBDs referenced by PSBs; however, updates to segments cannot cause more than 256 exits to be called. An exit becomes active as its corresponding database segment is updated and calls the exit.
  • We support all fields in the XPCB and XSDB parameter blocks, with appropriate actions for all XPCB return codes.
  • Databases that use logical relationships are supported. In these, segment deletes can cascade across a maximum of 32 nested hierarchical relationships and up to a maximum of 99 segment levels.
  • Data capture exit programs can make DL/I calls to any PCB defined in the currently active PSB.
  • Data capture exits support the following operands:
    EXIT
    • Supported for both DBD and SEGM statements
    • The following options are supported:
      • KEY
      • DATA
      • PATH
      • CASCADE, including the following sub-options:
        • KEY
        • DATA
        Note: We do not support the CASCADE PATH sub-option.
    • The LOG option is not supported, meaning that we do not write data capture log records to disk and therefore are not available for asynchronous processing
    VERSION
    Supported for the DBD statement. The XPCB parameter block points to the value of the VERSION operand. The maximum length of the VERSION value is 128 bytes (after any substitution). If no VERSION operand is specified, a default 13-byte date-time stamp is generated. The &SYSDATE and &SYSTIME substitutable variables are also supported.
Parent topic: Data Capture Exits


Run-time Behavior

The following describes the run-time behavior expected for data capture exits:
  • Data capture exits are called from all IMS application region types, including BMP and DL/I regions as well as CICS and the IMS Dynamic Database Attach (DDBA) region type.
  • We follow standard rules for the calling sequence of exits. This includes calling the exit multiple times, if necessary for path calls, in a top-down order. Exits are called in a bottom-up sequence for cascaded deletes.
  • Unlike mainframe IMS, we do not perform before- and after-image segment compare during replace operations. Replace calls always cause the segment to be updated, even if the data was not changed, meaning that we always call data capture exits for a replace call whether or not the data was modified.
  • If you compile the data capture exit program for debugging, it is shown by the respective debugger when the exit is called.
  • XPCB return codes of 8 or greater are recorded in the Server Enterprise Edition console log.
Parent topic: Data Capture Exits


Running an IMS Transaction

Before you run your IMS transaction in an enterprise server you must first run the /IMS transaction to set up the enterprise server to run in IMS mode. Once you have done this, you run an IMS transaction in the same way as you would run it on the mainframe. If you run it from a 3270 terminal or emulator, you enter transaction IDs at the terminal. Note that on a PC the keys assigned to act as the CICS keys depend on your TN3270 emulator. For example, in many cases the Escape key is used as the 3270 Clear key, and the right-hand Ctrl key is used as the 3270 Enter key.

To run an IMS transaction from a 3270 session:

  1. Enter /IMS to switch the enterprise server to IMS mode.
  2. Enter the name of your transaction. If the name of the transaction is shorter than eight characters, add a trailing space to the end of it.
Note:
  • To switch from IMS mode back to CICS mode, use the /CIC transaction.
  • The /CIC and /IMS transactions is defined in the DFHSIGN group. To add these transactions to your resource definition file you must run the caspcupg command, as described in the section Adding IMS-specific Resource Definitions in the chapter Configuring IMS-enabled Enterprise Servers for IMS in your Mainframe Subsystem Support Configuration and Administration Guide.
Parent topic: Developing IMS Applications
Related information
Adding IMS-specific Resource Definitions


Performing a Cold Start

If your message processing regions for an enterprise server become unresponsive for some reason you need to perform a cold start. Performing a cold start involves deleting the IMS message queue for an enterprise server, so any outstanding messages are lost and need to be resubmitted after the cold start.

To perform a cold start you delete the file %USERPROFILE%\Documents\Micro Focus\Net Express x.x\WORKAREA \ES_name\imsmesgq.dat, where ES_name is the name of the enterprise server whose message processing regions are unresponsive.

Parent topic: Developing IMS Applications


IMS flags

A list of the IMS flags used in the IMS tracing.

Flag | Description
api | Check this to indicate that MSS is to trace IMS DL/I API entry points.
cli | Check this to indicate that MSS is to trace IMS MPR, JES and SEP processing.
data | (Not used)
DB-thread | Check this to indicate that MSS is to trace lock management for IMS DB.
dbc | Check this to indicate that MSS is to trace IMS DB control processing.
ES-DB | Check this to indicate that MSS is to trace ES IMS DB processing.
ES-stg | Check this to indicate that MSS is to trace ES IMS memory management.
TM-thread | Check this to indicate that MSS is to trace lock management for IMS TM.
i/o | Check this to indicate that MSS is to trace IMS physical/virtual file I/O.
stg | Check this to indicate that MSS is to trace IMS dynamic memory allocation/freeing.
TM-buffer | Check this to indicate that MSS is to trace the buffer for IMS TM lock management.
sys | Check this to indicate that MSS is to trace miscellaneous IMS processing.
TM-ctl | Check this to indicate that MSS is to trace IMS TM control processing.
Parent topic: Developing IMS Applications


How to...

  • To generate a DBD, MFS or PSB source
  • To edit a DAT, MFS or PSB source
  • To edit a DBD source
  • To view the properties of a DBD, MFS or PSB source
Parent topic: Developing IMS Applications


To generate a DBD, MFS or PSB source

  • Right-click a project in Solution Explorer and click Build.
Parent topic: How to...


To edit a DAT, MFS or PSB source

  • Right-click a .dat, .mfs or .psb file in Solution Explorer and click Open.
Parent topic: How to...


To edit a DBD source

  1. Right-click a .dbd file in Solution Explorer.
  2. Click Edit IMS Database.

    This starts the IMS DB Editor.

Parent topic: How to...


To view the properties of a DBD, MFS or PSB source

  • Right-click a .dbd, .mfs or .psb file in Solution Explorer and click Properties.
Parent topic: How to...


IMSDBU Utility

The IMSDBU utility is a database management tool that offers a wide range of operational control. You can use it to initialize, load, unload and reorganize databases. You can tailor its operation to control file naming conventions, progress reporting, statistics, audit reports, and more.

IMSDBU runs as a standalone utility; a PSB is not required to use it. It operates on physical databases defined using DBDGEN. Because it runs outside of the Application Region, it can provide streamlined operation.

You can access the features of IMSDBU in the following ways:

  • An interactive interface similar to a 3270 terminal.
  • Using JCL submission by executing the database utility program MFDBUJCL.
  • Executing mfims imsdbu at the command line.
  • Using the MFIMSDBU application program interface (API).
Note: When running the IMSDBU utility from JCL, use INPUT/OUTPUT DD statements to access database unload files.
  • MFIMSDBU API
    Describes the MFIMSDBU application programming interface, used to access the functionality of the IMSDBU utility.
  • IMSDBU Main Features
  • Using IMSDBU with Fileshare Databases
  • Fast Path MSDBs
  • Migrating from DBUTIL
  • IMSDBU Automation
  • IMSDBU Functions Overview
Parent topic: IMS Support
Related concepts
Database command interfaces
High Performance
IMS/ESA Extract
Load and Unload Exits
Reports, Statistics and Logs
Simplified Logical Loading
Using IMSDBU with Fileshare Databases
IMSDBU Automation
The Reorganize Function
Related reference
mfims imsdbu Command


MFIMSDBU API

MFIMSDBU API is invoked by calling the MFIMSDBU module. Details of this API are documented in the sample file DBUPARMS.CPY. The sample program DBUDEMO.CBL demonstrates this interface. Both files are located in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Net Express IDE\MTO-IMS\IVP directory.

Parent topic: IMSDBU Utility


IMSDBU Main Features

  • High Performance
  • IMS/ESA Extract
  • Load and Unload Exits
  • Reports, Statistics and Logs
  • Simplified Logical Loading
  • Specialized and Generic Load Inputs
Parent topic: IMSDBU Utility


High Performance

IMSDBU can load and unload a database in a fraction of the time taken by an application program issuing DL/I calls. This is because IMSDBU communicates directly to the physical access layer in the hierarchical database engine. This layer is common between the MFIMS DL/I language interface and IMSDBU to ensure consistent formatting of databases and segments.

Parent topic: IMSDBU Main Features
Related concepts
IMSDBU Utility


IMS/ESA Extract

A sample program is included for unloading databases from your IMS/ESA system. This program executes as a BMP or stand-alone DLI program using an application PSB. It is provided in COBOL source in a file called IMSDBUV.CBL. Instructions for execution are located in the program comments. A file named IMSDBUV.JCL contains sample JCL for running this program.

Parent topic: IMSDBU Main Features
Related concepts
IMSDBU Utility


Load and Unload Exits

The segment exit allows a user-written program to control segment selection and modify segment data during load and unload processing. The exit program is called for each database segment. It can delete the segment, modify the segment data or pass it through unchanged. If a segment is deleted, all of its children segments are automatically deleted. The segment exit is enabled using the SEGEXIT directive.

The compression exit is used for the input file to the Load and the output file for Unload. It allows for segment compression and/or encryption of the input or output files. It is not used for the data stored in the MFIMS database. A standard routine named CBLDCIMS is provided to decompress input and compress output files. A user-written program can perform different segment encoding. This exit is enabled using the COMPRESS directive.

The IMSDBUV sample program for unloading IMS/ESA databases can create compressed files for input to the IMSDBU Load and decompressed using the CBLDCIMS routine.

Details of these exits are documented in the sample file DBUPARMS.CPY.

Parent topic: IMSDBU Main Features
Related concepts
IMSDBU Utility
The Load Function
The Unload Function
Related reference
COMPRESS
SEGEXIT


Reports, Statistics and Logs

Progress Reporting

IMSDBU reports the progress it makes while processing a database function. When performing a database load or a logical pointer update, it shows a 'percent complete' and an estimate of the time remaining. For database unloads, a percentage cannot be calculated so IMSDBU displays the segment number in process. The frequency of progress reporting is controlled by the PROGRESS directive.

Detailed Reporting and Statistics

A detailed report showing the results of a database function is available. This report is produced as an ASCII text file. It can reflect the most recent function or can maintain a historical record. This reporting is controlled by the LIST and LISTOPEN directives. Items included in this report are:

  • A starting message indicating the date/time, database name and the function performed.
  • 'Options in effect' which lists the directives used.
  • Information, warning and error messages issued during execution.
  • Database statistics with the Load and Unload functions. These include segment counts, maximum per root, and average per root listed by segment type.
  • The ending message produced by the function. This states the success or failure of the function and the ending return code value. This message also appears in the historical activity log.

Historical Activity Log

A historical activity log can be kept for all IMSDBU activity. An entry is written to the log when a function completes. This entry consists of the date and time, database name and the ending message for a function. The most recent entries are written to the end of the file. This log is produced as an ASCII text file and is controlled by the LOG directive.

Parent topic: IMSDBU Main Features
Related concepts
IMSDBU Utility
IMSDBU Automation
Adjusting for Missing Segments
Reorganize Processing Details
Reorganize Failure Recovery
Related reference
PROGRESS
LISTOPEN
LIST
LOG


Simplified Logical Loading

IMSDBU loads all physical databases in the same way - with the Load function. For databases containing logical children, a pointer update function connects the logical children to their parents and resolves paired segments after loading.

Logical database loading is further simplified by the use of the Makelist function. Makelist generates all of the required steps to load a complete set of logically related databases. You provide one DBD name and Makelist follows its relationships to create the set. From this, it generates a file for input to the Runlist function to execute the steps.

Parent topic: IMSDBU Main Features
Related concepts
IMSDBU Utility
The Load Function
The Makelist Function
The Runlist Function


Specialized and Generic Load Inputs

IMSDBU provides a special-purpose input file layout for loading databases. This file layout is created by the IMSDBU Unload function or by the IMSDBUV program. IMSDBUV is provided as COBOL source code and is installed in the source directory. You can transfer this program to your mainframe, compile, and run it to extract IMS/ESA segment data.

This special-purpose layout provides for simpler loading of the database. The physical characteristics of the file and data are stored in header and trailer records in the file. This includes items such as the placement of the segment name, segment data, and compression options. Loading a database with this format is as easy as naming the input file and using the LAYOUT(D) directive. For reference, the IMSDBU layout file is a variable length file to reduce storage requirements and file transfer times.

IMSDBU also supports a special purpose IBM layout. This is specified using the LAYOUT(I) directive and supports input files created using IMS/ESA DB Unload Utilities such as DFSURGU0. This layout sets the directive values SEGM(7), DATA(36), RECFM(V) and NOCOMPRESS. This layout honors delete byte settings in the input file and directs IMSDBU to skip over segments marked as deleted.

IMSDBU supports sequential input files using the LAYOUT(S) directive. This enables you to load an IMS database from an input file produced from COBOL program or downloaded from the mainframe using Drag and Drop as a sequential file.

IMSDBU supports generic layouts for the input load files using the LAYOUT(G) directive. The generic layout must contain the segment name and segment data in the same position of each record. It can be a fixed or variable length segment. A SEGM directive indicates the position of the segment name in the record area. A DATA directive indicates the starting position of the segment data. The segments in the file must be in hierarchical order, but do not have to be in key sequence.

Parent topic: IMSDBU Main Features
Related concepts
The Add Function's Inputs and Outputs
The Load Function's Inputs and Outputs
The Unload Function's Inputs and Outputs
Related reference
LAYOUT
RECFM
SEGM
COMPRESS
DATA


Using IMSDBU with Fileshare Databases

Fileshare databases are supported for all of the IMSDBU functions, although you should avoid using Fileshare databases with IMSDBU when possible. Considerable performance gains can be achieved by accessing a database as an exclusive-use database. Exclusive-use databases can be on a local hard drive or accessed from a network redirected drive. Even when accessed through network redirection, exclusive-use databases will be much faster than Fileshare databases. However, using exclusive-use databases might not be a practical option in some environments. For example:

  • When you cannot use network redirection to access the machine containing the databases.
  • If your installation does not allow access to a database outside of Fileshare for security, integrity, or other reasons.

IMSDBU requires the MFIMS Supervisor to be installed for Fileshare databases. Performing a LOAD, UNLOAD, REORGANIZE, PTRUPDATE, or USEQ function to a Fileshare database without the Supervisor installed results in an error message.

IMSDBU functions require an exclusive database lock. No users can access a database while an IMSDBU function is running against it. If IMSDBU is unable to acquire an exclusive database lock, the function terminates and an error message is issued. The User ID of the lock holder is displayed in the message. The User ID is configured in the IMSGEN TM/MFS System Configuration.

For the Load and PtrUpdate functions, an automatic commit is issued periodically. The frequency of the commit is configured using the DB System Configuration. The configuration setting is the Maximum Updates Before Warning Pop-up. IMSDBU will issue a commit whenever the number of segments updated exceeds this value. No pop-up warning is issued.

IMSDBU may become locked out of a database during Load or PtrUpdate processing. This can occur when the exclusive database lock is temporarily released while IMSDBU performs its periodic commit. If a user is in 'lock retry' when IMSDBU begins commit processing, the user may be able to acquire the lock while it is temporarily released. If this happens, IMSDBU will timeout and report the failure.

Parent topic: IMSDBU Utility
Related concepts
IMSDBU Utility
The Load Function
The PtrUpdate Function


Fast Path MSDBs

MSDB databases are supported in a very similar way to full-function and DEDB databases. The MSDB support builds from this to add MSDB-specific features such as the FLD Verify and Change call.

MSDB databases are stored on disk and must be initialized using the Zeroload function. The Reorganize function can be used with MSDBs without any special consideration and is used for the same purposes as for other databases.

MSDBs are loaded using the Load function. The format of the input file to load MSDBs may be different than for other databases. This depends on which of the four types of MSDBs you are loading.

A non-terminal related MSDB without LTERM keys has the same input formats for Load as full-function and DEDB databases. This kind of MSDB is the easiest to manage since its segment is defined like other segments with a sequence field value provided by the application.

The other types of MSDBs use a different format. This is required to support the LTERM name which is used directly or indirectly as a key for the segments. The SEGM directive for the Load indicates the position of the LTERM name instead of the location of the segment name. Since MSDBs only have one segment, the segment name is not required for loading. The three types of MSDBs affected by this difference are:

  • Non-terminal related with LTERM keys
  • Terminal related fixed
  • Terminal related dynamic

The Unload function uses the SEGM directive the same as Load. For these three types, the SEGM directive indicates the location of the LTERM name for a generic Unload format.

You cannot use the IMSDBUV program to unload one of these kinds of MSDBs. You will need to create a program to format the type of input file required by the Load function.

Parent topic: IMSDBU Utility
Related concepts
The Load Function
The Unload Function
The Zeroload Function
The Reorganize Function


Migrating from DBUTIL

DBUTIL was the primary IMS database management tool in earlier Micro Focus products. This topic details the differences between DBUTIL and IMSDBU to assist you in migrating to IMSDBU.

DBUTIL's LOAD, UNLO, USEQ, MLOD and ZERO functions will continue to be supported, but will not be changed or enhanced.

  • No PSB required

    DBUTIL runs as a BMP program and requires a PSB. It loads and unloads databases by issuing DL/I calls to a specific PCB. IMSDBU does not issue DL/I calls for its functions and does not require a PSB.

  • Implicit Zeroload

    IMSDBU automatically performs a Zeroload of a database when processing a Load function. All existing database data is overlaid when performing a Load. IMSDBU does not allow adding to existing database data.

    The DBUTIL Load function issues ISRT calls. It can be used to add segments to existing database data. However, care must be taken if any segments in the input file duplicate segments already in the database.

  • Duplicate inserts - 'II'

    IMSDBU cannot add duplicate segment keys when loading a database. The Load function terminates if the input file contains duplicate segment keys for uniquely keyed segments. Termination occurs at the point the duplicate key is detected. Any calls made to this database will result in an AI status code until a successful load is performed.

    DBUTIL ignores II status codes for the insert calls it issues. Position is established on that key value and processing continues with the next segment record. This was required by DBUTIL for loading logical relationships. IMSDBU is a much simpler utility for loading logical databases and does not have to rely on the DL/I II status code position rules.

  • Remote IMS and User Exit Databases

    IMSDBU can only operate on 'native' MFIMS database types. That is, it can only read and update single-user exclusive use databases or shared update Fileshare databases. It can read shared read-only databases for a database unload.

    DBUTIL can load or unload User Exit Databases. DBUTIL can unload a Remote IMS database but cannot be used to load one.

  • Fileshare databases

    IMSDBU requires the MFIMS Supervisor to be installed on the Fileshare Server. This is required for the Load, Unload, Reorganize, Ptrupdate, and Useq functions. IMSDBU functions require an exclusive database lock. No users can access a database while an IMSDBU function is being performed against it.

    The Supervisor is not required by DBUTIL for Fileshare databases. DBUTIL does not require an exclusive lock of the database. This is not necessarily an advantage. Without an exclusive lock, another user may be able to update a database which is in the process of being loaded or reorganized. Also, without an exclusive database lock, more overhead is required to make database record level lock requests.

  • Logical database loading

    Loading databases containing logical children is very different between DBUTIL and IMSDBU. IMSDBU does not operate on databases defined as ACCESS=LOGICAL in the DBD. IMSDBU only operates on the physical databases which are referenced by a logical database. When downloading data from mainframe databases, always download the data from the physical databases and not the logical DBD.

  • Loading MSDBs - DBUTIL MLOD

    The DBUTIL MLOD function is used to load Fast Path MSDB databases. IMSDBU does not require a special load function - its Load function will load MSDB databases. There is a difference between these functions in the format of the input data files.

    For non-terminal related MSDB without LTERM keys, the DBUTIL MLOD input file is either a fixed or variable length record file with segment data starting in position 1. IMSDBU allows any format input file but requires the segment name in addition to the segment data. In IMSDBU, the input file for this kind of MSDB is the same as for other databases.

    For all other MSDB types, the IMSDBU Load supports the input files used by the DBUTIL MLOD.

Parent topic: IMSDBU Utility
Related concepts
The Load Function
The Unload Function
The PtrUpdate Function
The Reorganize Function
The Useq Function


IMSDBU Automation

This topic describes methods for automating database management functions. You can run IMSDBU functions using IMSDBU Runlist command files or operating system command prompt. Using these batch interfaces can simplify the execution of repetitive functions. LAN servers and other products provide timed-operation or command scheduling functions. Combining these functions with IMSDBU command execution can provide unattended operation.

Some example uses are:

  • Transferring files and loading databases overnight
  • Performing scheduled database reorganizations and/or backups
  • Refreshing test databases over a weekend

The command line interface executes IMSDBU functions from an operating system command file (or command prompt). Each IMSDBU command line runs one IMSDBU function. The system return code is set to the function's ending return code. A return code of 8 or above indicates that the function failed.

IMSDBU also supports its own Runlist command files. These are similar to operating system command files but allow you to process a series of commands as a group. One operating system command starts execution of the Runlist file which contains a list of functions.

The Runlist file may be easier to use when a function depends on a previous function completing successfully. When a function in a Runlist file fails, the remaining functions are canceled. With an operating system command file, ERRORLEVEL or return code checking must be used to bypass the remaining steps.

If you need to ensure a function runs, regardless of the outcome of a previous step, use operating system command files. A combination of operating system commands and Runlist files provides a great deal of flexiblility for performing IMSDBU functions.

Example

This example demonstrates loading several databases using an operating system command file and two Runlist files. It uses four databases: A, B, C, and D. Databases A and B are logically related to each other, as are databases C and D.

A Runlist file is used to load databases A and B. The Runlist file will produce one detail list file for all of its steps. The LISTOPEN(NEW) directive on the first step creates a new listing file. The LISTOPEN(MOD) directive on the subsequent steps appends to this listing. If the Load of either database fails, there is no reason to continue the process. Both of the databases must load successfully before PtrUpdate can run. All four steps must complete successfully before the databases can be used by an application.

Runlist file LOADAB.RUN

LOAD A DSN(A.LOD) LIST(LOADAB.LST) LISTOPEN(NEW)
LOAD B DSN(B.LOD) LIST(LOADAB.LST) LISTOPEN(MOD)
PTRU A LIST(LOADAB.LST) LISTOPEN(MOD)
PTRU B LIST(LOADAB.LST) LISTOPEN(MOD)

A similar process (and Runlist file) is used to load databases C and D.

Runlist file LOADCD.RUN

LOAD C DSN(C.LOD) LIST(LOADCD.LST) LISTOPEN(NEW)
LOAD D DSN(D.LOD) LIST(LOADCD.LST) LISTOPEN(MOD)
PTRU C LIST(LOADCD.LST) LISTOPEN(MOD)
PTRU D LIST(LOADCD.LST) LISTOPEN(MOD)

An operating system command file is used to execute these two Runlist files. The following command file executes the Runlist files. The ECHO directive causes display of ending messages and error messages with a return code of 4 or greater. The ECHO stoplvl of 50 indicates that no prompting should occur for any IMSDBU messages.

LOADABCD.BAT

xx IMSDBU RUN LOADAB.RUN echo(errend,4,50) nocls
xx IMSDBU RUN LOADCD.RUN echo(errend,4,50) nocls

In this example, a failure during the load of database A would cancel the load of database B but not affect the loading of databases C and D. This operating system command file could be run unattended - the activity log and the detail list files contain the results of the execution.

Parent topic: IMSDBU Utility
Related concepts
IMSDBU Utility
The Runlist Function
The PtrUpdate Function
Reports, Statistics and Logs
Related reference
LISTOPEN
ECHO


IMSDBU Functions Overview

IMSDBU provides the following functions:

  • The Add Function
    Adds segments to a database.
  • The Delete Function
    Deletes the work file.
  • The Load Function
    Initializes and loads an input file.
  • The Makelist Function
    Generates a logical database load.
  • The PtrUpdate Function
    Updates the logical child pointers.
  • The Reorganize Function
    Reorganizes a database.
  • The Runlist Function
    Executes a command file.
  • The Unload Function
    Unloads a database.
  • The Useq Function
    Unloads DEDB sequential dependents.
  • The Zeroload Function
    Initializes a database.
Parent topic: IMSDBU Utility


The Add Function

The Add function adds segments to a database from an input data file. The database is not re-initialized. The Add function does not perform a Zeroload of the database. This is intended for adding additional data to a database or refreshing some of the segments in the database.

The Add function is not intended for initial loading of a database, part of a database reorganization, or for reloading a database after changing the DBD definition.

When running IMSBDU from the command line, the function-id to use for the Add function is ADD.

  • The Add Function's Inputs and Outputs
  • Adding Segments to Logically Related Databases
Parent topic: IMSDBU Functions Overview
Related concepts
The Load Function
The Zeroload Function
The Runlist Function's Inputs and Outputs
Related reference
Add Directives


The Add Function's Inputs and Outputs

Input

There is a variety of input file formats supported for the Add function. See Specialized and Generic Load Inputs for complete details of the different formats.

The database for the segment Add function must be an existing primary physical database. It must be either Zeroloaded or previously loaded with data. An Add should not be run, for any other kinds of databases. An error message will result if you attempt an Add function to one of the following databases:

  • The primary index for a HIDAM database. A primary index database is not required. The .IDX component of an MFIMS database is the equivalent of this index and is modified automatically when adding segments to the primary database.
  • Secondary index databases. These are modified automatically when adding segments to the primary database they index.
  • Databases defined as ACCESS=LOGICAL. The physical databases contain the required pointers to support logical relationships.
  • GSAM databases. The Add function does not support GSAM databases.
  • A database which has not been Zeroloaded or previously loaded with data.

Exclusive use databases and shared update Fileshare databases may be used with the Add function. IMSDBU does not support adding segments to Remote IMS or User Exit databases. The DBUTIL utility can be used for adding segments to User Exit databases. You must develop your own program if you need to add segments to a Remote IMS database from the workstation.

Shared read-only databases must be processed as an exclusive use or shared update Fileshare database and copied to the shared directory.

Output

The database data files are modified by this function. Any secondary index databases are also modified. If the database contains logical children definitions, the PtrUpdate function must be run before the database can be accessed by an application program.

Parent topic: The Add Function
Related concepts
The PtrUpdate Function
Specialized and Generic Load Inputs


Adding Segments to Logically Related Databases

Adding segments to a database which contains logical relationships requires that the PtrUpdate function also be run against it. This resolves the links between logical children segments and their logical parents. When adding segments to several logically related databases, we recommend that the Add function first be performed against each of the databases, then the PtrUpdate function run against each of them.

The Makelist function can assist in identifying the databases included in the set of logically related databases.

Parent topic: The Add Function
Related concepts
The PtrUpdate Function
The Makelist Function


The Delete Function

This function is available only in a Runlist command file. It is used by the Reorganize function to delete the file containing the unloaded segment data. There is no logging or reporting of this function. The syntax for this command is:

DELETE DSN(file-spec)

Specify the name of the data set you want to delete. file-spec can specify a drive and/or directory for the file.

When running IMSBDU from the command line, the function-id to use for the Delete function is DEL.

Parent topic: IMSDBU Functions Overview
Related concepts
The Makelist Function
The Runlist Function
Reorganize Processing Details
Related reference
Delete Directives


The Load Function

The Load function initializes a database and loads it from an input data file. It can be used for initial loading of a database, as part of a database reorganization, or for reloading a database after changing the DBD definition.

Note:

The Load function automatically performs a Zeroload. Zeroloading an existing database will re-initialize the database and cause any data to be lost.

When running IMSBDU from the command line, the function-id to use for the Load function is LOAD.

  • The Load Function's Inputs and Outputs
  • Loading Logically Related Databases
Parent topic: IMSDBU Functions Overview
Related concepts
Simplified Logical Loading
Load and Unload Exits
Using IMSDBU with Fileshare Databases
Fast Path MSDBs
Migrating from DBUTIL
The Add Function
The Zeroload Function
Building the Logical List for Makelist
The PtrUpdate Function's Inputs and Outputs
The Reorganize Function
Reorganize Processing Details
The Reorganize Function's Inputs and Outputs
The Runlist Function's Inputs and Outputs
The Unload Function's Inputs and Outputs
Related reference
Load Directives


The Load Function's Inputs and Outputs

Input

There are a variety of input file formats supported for loading databases.

The database to be loaded must be a primary physical DBD or GSAM DBD which has been defined using DBDGEN. An automatic Zeroload is performed for physical databases. GSAM databases do not require the Zeroload step. A Load is not required, and should not be run, for any other kinds of databases. An error message will result if you attempt to Load one of the following databases:

  • The primary index for a HIDAM database. A primary index database is not required. The .IDX component of an MFIMS database is the equivalent of this index and is created automatically when loading the primary database.
  • Secondary index databases. These are created automatically when loading the primary database they index. A secondary index DBD which defines non-unique keys must be Genned prior to performing a Load for the primary database. When loading a database which contains segment data, any 'user data' in the index will be lost.
  • Databases defined as ACCESS=LOGICAL. The physical databases contain the required pointers to support logical relationships.

Exclusive use databases and shared update Fileshare databases can be loaded. IMSDBU does not support loading of Remote IMS or User Exit databases. The DBUTIL utility can be used for loading User Exit databases. You must develop your own program if you need to load a Remote IMS database from the workstation.

Shared read-only databases must be loaded as an exclusive use or shared update Fileshare database and copied to the shared directory.

Output

The database data files are created and loaded by this function. Any secondary index databases are also created and loaded. If the database contains logical children definitions, the PtrUpdate function must be run before the database can be accessed by an application program.

Parent topic: The Load Function
Related concepts
The PtrUpdate Function
Specialized and Generic Load Inputs
The Reorganize Function's Inputs and Outputs
The Unload Function's Inputs and Outputs


Loading Logically Related Databases

Loading logically related databases requires multiple steps that must be performed in a fixed sequence. In most cases, this involves multiple databases. The Makelist function can assist in creating the steps required to load a set of logically related databases.

The Load function performs a physical load of the segment data. The Load function does not process logical relationships. Logical children are connected to their logical parents by the PtrUpdate function. PtrUpdate also connects or establishes paired logical child relationships. A database which contains logical children segments cannot be accessed by an application until the PtrUpdate completes.

Parent topic: The Load Function
Related concepts
The Makelist Function


The Makelist Function

Loading logically related databases involves multiple steps that must be performed in a fixed sequence. The Makelist function simplifies the process of creating these steps. Makelist generates a Runlist command file containing the steps required to load a set of logically related databases. You perform Runlist to execute the steps in the generated command file.

When running IMSBDU from the command line, the function-id to use for the Makelist function is MAKE.

  • Building the Logical List for Makelist
  • The Makelist Function's Inputs and Outputs
Parent topic: IMSDBU Functions Overview
Related concepts
Simplified Logical Loading
Adding Segments to Logically Related Databases
The Delete Function
Loading Logically Related Databases
The Runlist Function
The Runlist Function's Inputs and Outputs
Related reference
Makelist Directives


Building the Logical List for Makelist

Makelist begins by creating a list of logically related databases. The DBDGEN definitions are used to determine the relationships. Once the set is determined, it creates the required load and logical pointer update steps to load the databases.

Makelist builds the list by starting with a single DBD name. The databases referenced by logical children in the input DBD are added to the list. These newly-added DBDs are scanned and databases referenced by their logical children are also added to the list. This continues until all of the relationships are located. Makelist requires that all of the physical DBDs have been genned. If a DBD referenced by a logical child is not found, an error message is issued and Makelist terminates. The error message includes the required DBD name. You should gen the DBD and re-run Makelist.

Databases referenced by logical children also need to be genned and at least zeroloaded. That is, if you need access to a database with a logical child, you must also gen the logical parent database and at least zeroload it.

However, if you need a database which contains only a logical parent for a unidirectional relationship, the database containing the logical child is not required. Thus, you may get different results from Makelist depending on the DBD name you start with.

You should review the output of Makelist for databases which define unidirectional logical relationships. You could also run Makelist multiple times with different initial DBD names and merge the output Runlist files. Database load steps can also be added by editing the Runlist command file manually. This is an ASCII text file and can be edited in any text editor. For any required logical child database which was not located, add a Load step at the top of the file and a PtrUpdate step at the bottom. All PtrUpdate steps should follow the Load steps.

Uni-directional Examples

Consider three logically related databases - 'A', 'B', and 'C'. Database A contains a logical child segment which defines a uni-directional logical relationship to database B. Database B contains the logical parent for database A's logical child. A second uni-directional logical relationship is defined between databases B and C. Database B contains a logical child segment which points to the logical parent in database C.

In other words, database A points to database B and database B points to database C. A is related to B and B is related to C by uni-directional relationships.

Example 1

If database A is used as the starting DBD name, databases B and C are both included. Database C contains no logical child segments and does not require a pointer update step. The sequence of the load steps is:

LOAD A DSN(...
LOAD B DSN(...
LOAD C DSN(...
PTRUPDATE A ...
PTRUPDATE B ...

Example 2

If database B is used as the starting DBD name, only database C is included. Database C contains no logical child segments and does not require a pointer update step. The sequence of the load steps is:

LOAD B DSN(...
LOAD C DSN(...
PTRUPDATE B ...

If your application requires the use of database A, a Load and PtrUpdate step must be added manually. MFIMS does not require database A if you only access databases B and C. The Load step for A must be placed prior to the first PtrUpdate step. The PtrUpdate step can be placed anywhere after the last Load step.

Example 3

If database C is used as the starting DBD name, databases A and B are not included. The load step is simply:

LOAD C DSN(...

If your application requires the use of database A and B, the Load and PtrUpdate step must be added manually. You do not need databases A or B if you only need access to database C. The steps to load all three databases is shown in Example 1.

Parent topic: The Makelist Function
Related concepts
The Runlist Function
The PtrUpdate Function
The Load Function
Reorganize Processing Details


The Makelist Function's Inputs and Outputs

Input

The input is the starting physical DBD name defined using DBDGEN. From this DBD, logical relationships are followed to create the set of logically related databases. The DBDGEN files are the input to Makelist.

Output

The output is a Runlist command file. Its name and location are controlled by the MAKELISTDSN directive. It is an ASCII text file. Any text editor can be used to modify this file for changing directives or file names.

Parent topic: The Makelist Function
Related reference
MAKELISTDSN


The PtrUpdate Function

PtrUpdate validates and establishes the pointers which maintain logical relationships. It connects logical children to their logical parents and matches paired logical children to each other. If logical child segments are loaded to a database, a PtrUpdate is required before making any calls to the database. A PtrUpdate is run after loading the physical databases containing the logical children and their logical parents.

When running IMSBDU from the command line, the function-id to use for the PtrUpdate function is PTRU.

  • Adjusting for Missing Segments
  • The PtrUpdate Function's Inputs and Outputs
Parent topic: IMSDBU Functions Overview
Related concepts
Using IMSDBU with Fileshare Databases
Migrating from DBUTIL
IMSDBU Automation
The Add Function's Inputs and Outputs
Adding Segments to Logically Related Databases
The Load Function's Inputs and Outputs
Building the Logical List for Makelist
The Reorganize Function
Reorganize Processing Details
The Reorganize Function's Inputs and Outputs
The Runlist Function's Inputs and Outputs
Related reference
PtrUpdate Directives


Adjusting for Missing Segments

The PtrUpdate function creates the pointers which establish logical relationships. Logical pointers are created between a logical child and its logical parent and between paired logical children. If two of these logically related segments cannot be connected, an adjustment is made. The adjustments ensure that all of the logical pointers in a database refer to valid segments.

The two adjustments which may be performed are:

  • A logical child segment is deleted when its logical parent segment does not exist. When this occurs, the logical child segment data and the logical parent concatenated key are included in the detail report listing.
  • If a paired segment to a logical child does not exist, it is created. The paired logical child is created in the same way it would be created for an application ISRT call.

The number of segments deleted and created because of these adjustments is included in the detail report listing. The number of logical child segments updated with a valid logical parent pointer is also included in this report. These counts are listed by segment name.

Parent topic: The PtrUpdate Function
Related concepts
Reports, Statistics and Logs


The PtrUpdate Function's Inputs and Outputs

Input

The input is the DBD name of a physical DBD which defines logical children segments. The IMSDBU Load function must have been performed for this DBD name and for any databases containing logical parents for the logical children. A database which defines logical children does not require PtrUpdate if no logical child segments were loaded to the database.

An error message is issued if you attempt to run PtrUpdate for:

  • A DBD which does not define any logical children
  • A DBD name which was not input to the IMSDBU Load function

A PtrUpdate can be run for exclusive use databases and shared update Fileshare databases. IMSDBU does not support PtrUpdate or Load for Remote IMS or User Exit databases. Shared read-only databases must be established as an exclusive use or shared update Fileshare database and copied to the shared directory.

Output

Updated database data files for the input DBD name and any database referenced by logical child occurrences in this database. Once PtrUpdate completes, the databases can be accessed from application programs using any of the supported physical and logical access paths.

Parent topic: The PtrUpdate Function
Related concepts
The Load Function


The Reorganize Function

The Reorganize function provides a simple mechanism for reorganizing a database or set of logically related databases. This automates the creation and running of separate Unload and Load functions. PtrUpdate steps are run automatically for any database containing logical children.

When running IMSBDU from the command line, the function-id to use for the Reorganize function is REOR.

  • Reorganize Processing Details
  • The Reorganize Function's Inputs and Outputs
  • Reorganize Failure Recovery
Parent topic: IMSDBU Functions Overview
Related concepts
IMSDBU Utility
Fast Path MSDBs
Migrating from DBUTIL
The PtrUpdate Function
The Load Function
The Unload Function
Related reference
Reorganize Directives


Reorganize Processing Details

When a segment is deleted, the space it occupied is reused by the next segment inserted which is not larger than the deleted segment. However, if new segments are not inserted which 'fit' this deleted space, the space is not reclaimed until you reorganize the database. Also, as a database is updated, the internal pointers can become fragmented which reduces performance. A reorganization will restore the performance to that of a newly loaded database.

The Reorganize function combines the functions of the Load, Unload, PtrUpdate, and Delete functions to perform the reorganization. It creates the required steps using an advanced feature of the Makelist function. This Makelist feature is only available when using the callable API interface to IMSDBU. The interactive and command line interfaces for Makelist only support creating steps for loading databases. The callable interface adds the ability to create the steps for reorganizing databases.

The reorganization for a database with no logical children is simply to unload the database to a sequential file and load it using the sequential file.

Reorganizing a database containing logical children results in reorganizing it and all of its related databases. The steps to reorganize these databases are:

  1. Identify all of the related databases
  2. Unload each of the databases to a sequential file
  3. Load each of the databases from the sequential unload
  4. Run PtrUpdate for each database with logical children definitions
  5. Delete the sequential files created in step 2

Identifying the related databases is done by Makelist. The process Makelist uses to create this list is the same for Reorganize as it is for Load.

The sequential unload files are not deleted until all of the Load and PtrUpdate processing is complete. Although this requires more disk space than deleting them after the Load, it provides for restarting if a subsequent Load or PtrUpdate step fails. If you need to conserve disk space, you can change the DBUREORG.RUN file to re-sequence the Delete commands and use Runlist to run the commands. You could also create your own Runlist command file or run the required functions in an operating system command file.

When the detailed report filename *.LST is used, a separate list file is created for each database involved in the reorganization. For a combined listing, specify the directives LIST(file-spec) and LISTOPEN(MOD).

Parent topic: The Reorganize Function
Related concepts
The PtrUpdate Function
The Load Function
The Unload Function
The Delete Function
Reports, Statistics and Logs
Building the Logical List for Makelist
Reorganize Failure Recovery


The Reorganize Function's Inputs and Outputs

Input

The database name input to the Reorganize function must be a primary physical database which has been defined using DBDGEN. This DBD name must be a type of database which is supported by the Load function. See the The Load Function's Inputs and Outputs topic for the database qualifications.

Database Data Files

The database data files are read and updated by Reorganize using the Unload, Load, and PtrUpdate functions.

Secondary index databases do not have to be available when starting reorganization. They will be re-created during the Load step.

The Unload function does not require the logical parent databases when unloading its logical child database. However, Reorganize uses Makelist to create Unload steps for each related database. All of the databases which are logically related must be available prior to starting Reorganize.

Output

Database unload work files containing the segment data are created during this process. These files are named using the DBD name with an 'ORG' extension. They are created in the project listing directory. For reference, they are an Unload file created with the directives LAYOUT(D) and COMPRESSION(CBLDC001). They are deleted upon successful completion of the Reorganize.

A Runlist command file is created with the name DBUREORG.RUN. It contains the steps to perform the reorganization. It is always placed in the current directory and is not deleted upon successful completion. You can use this file as a model for creating your own reorganization scripts. Be sure to copy it to a new name as the next Reorganize function will re-create it. You may need this file to recover from an incomplete reorganization.

Parent topic: The Reorganize Function
Related concepts
The Load Function's Inputs and Outputs
Reorganize Failure Recovery
The PtrUpdate Function
The Load Function
The Unload Function


Reorganize Failure Recovery

The easiest way to recover from a failed Reorganize function is to restore the original database data files from a backup copy. In the event that a backup copy is not available, recovery can be performed using the files produced by the reorganization. Failures can occur for several possible reasons. One example is running out of disk space.

In the event of a failure, an error message is issued and the process is terminated. The sequential file unloads are kept. These files may be required to complete the reorganization.

The first thing step is to determine the cause of the failure and correct it. The error message issued from the reorganization is written to the detail report listing. This message should provide enough information to determine the cause of the failure. In some cases, the IMSMTO.LOG will provide additional information about the failure.

The IMSDBU activity log will indicate all of the steps which were successful and the step which failed. If the failing step was an Unload, database recovery is not necessary. Just restart the Reorganize function after correcting the cause of the failure.

Compare the functions listed in the log to the reorganization command file DBUREORG.RUN to identify which step in the command file failed. Use a text editor to modify the command file and remove or comment out all of the steps which completed successfully. A step is commented out by placing an asterisk (*) in column 1. Use Runlist with the modified command file to complete the reorganization.

Parent topic: The Reorganize Function
Related concepts
Reorganize Processing Details
The Reorganize Function's Inputs and Outputs
The Runlist Function
Reports, Statistics and Logs


The Runlist Function

The Runlist function executes IMSDBU functions listed in a Runlist command file. This file can be created manually with a text editor or generated by Makelist.

The functions listed in the Runlist command file are processed in series. The highest error level set by an individual step is returned as the ending return code by Runlist. If a step fails with a return code of 8 or higher, all remaining steps are canceled. The ending return code is set to the return code of the failed step.

When running IMSBDU from the command line, the function-id to use for the Runlist function is RUN.

  • The Runlist Function's Inputs and Outputs
  • Restarting a Failed Runlist Operation
Parent topic: IMSDBU Functions Overview
Related concepts
Simplified Logical Loading
IMSDBU Automation
The Delete Function
The Makelist Function
Building the Logical List for Makelist
Reorganize Failure Recovery
Related reference
Runlist Directives


The Runlist Function's Inputs and Outputs

Input

The name of the command file containing IMSDBU functions. This is an ASCII text file with each function specified on a separate line. The format of this record is:

function dbdname [directives]

An individual command may not span multiple lines. An asterisk (*) in column 1 indicates a comment line.

All of the IMSDBU functions can be listed in a Runlist file except for Reorganize and Runlist functions. Reorganize uses Runlist to perform the reorganization and Runlist executions cannot be nested.

Output

The output is the results of the functions which were successfully executed and the IMSDBU listing and log report files.

Parent topic: The Runlist Function
Related concepts
The PtrUpdate Function
The Load Function
The Unload Function
The Useq Function
The Add Function
The Zeroload Function
The Makelist Function


Restarting a Failed Runlist Operation

In the event of a failure, an error message is issued and the Runlist is terminated. The remaining steps in the Runlist command file are not executed. You must determine the cause of the failure and correct it. The error message issued from Runlist is also written to the detail report file. This message should provide enough information to determine the cause of the failure. In some cases, the IMSMTO.LOG file will provide additional information.

The activity log indicates all of the Runlist steps which were successful and the step which failed. Use this to identify the step to restart from. Compare the functions listed in the log to the original Runlist file and identify which step failed.

Use a text editor to modify the Runlist file and remove or comment out all the steps which completed successfully. A step is commented out by placing an asterisk (*) in column 1 of that line.

Rerun Runlist with the modified Runlist command file.

Parent topic: The Runlist Function


The Unload Function

The Unload function writes database segment data to a sequential output file. It can be used as part of a database reorganization, for unloading a database prior to changing the DBD definition, or to create a flat file of database segment data for other purposes.

When running IMSBDU from the command line, the function-id to use for the Unload function is UNLO.

  • The Unload Function's Inputs and Outputs
Parent topic: IMSDBU Functions Overview
Related concepts
Load and Unload Exits
Fast Path MSDBs
Migrating from DBUTIL
The Reorganize Function
Reorganize Processing Details
The Reorganize Function's Inputs and Outputs
The Runlist Function's Inputs and Outputs
The Unload Function's Inputs and Outputs
Related reference
Unload Directives


The Unload Function's Inputs and Outputs

Input

The database to be unloaded must be a primary physical DBD or GSAM DBD which has been defined using DBDGEN. The data files for secondary index databases are not required by Unload. When unloading databases containing logical children, the database files for the logical parents is not required. An error message will result if you attempt to unload one of the following databases:

  • The primary index for a HIDAM database.
  • Secondary index databases. If you need to extract 'user data' from a secondary index, you can use the DBUTIL utility or develop your own program.
  • Databases defined as ACCESS=LOGICAL. IMSDBU manages logical relationships using the physical databases. If you need to unload data using a logical DBD, you can use the DBUTIL utility or develop your own program.

Remote IMS and User Exit program Database Catalog types cannot be unloaded by IMSDBU. Unload is supported for single-user exclusive use databases, shared read-only databases, and shared update Fileshare databases. The DBUTIL utility can unload User Exit and Remote IMS databases.

Output

There is a variety of output file formats supported for unloading databases. See the Specialized and Generic Load Inputs topic for complete details of the different formats. Any of the formats supported by the Load function can be created using Unload.

Parent topic: The Unload Function
Related concepts
Specialized and Generic Load Inputs
The Load Function's Inputs and Outputs
The Load Function
The Unload Function


The Useq Function

The Useq function unloads all sequential dependent segments (SDEPs) from a Fast Path DEDB. The unload file contains the segment data and the date and time the segment was inserted into the database. This file can be sorted for chronological processing.

When running IMSBDU from the command line, the function-id to use for the Useq function is USEQ.

  • The Useq Function's Inputs and Outputs
Parent topic: IMSDBU Functions Overview
Related concepts
Migrating from DBUTIL
The Runlist Function's Inputs and Outputs
Related reference
Useq Directives


The Useq Function's Inputs and Outputs

Input

The DEDB database data files are input to this function. The DEDB must have an SDEP segment definition. An error message is issued if a Useq function is attempted for any other kind of database.

The SDEP unload cannot be performed for the Remote IMS or User Exit Program Database Catalog types. IMSDBU supports the Useq function for single-user exclusive use databases, shared read-only databases, and shared update Fileshare databases.

Output

The data file containing the SDEP segments. This is a fixed length record sequential file. The LRECL is automatically set to the length of the SDEP segment plus 16 bytes. The LRECL used is written to the detail report file.

The first 8 bytes of the record is a date/time stamp followed by the 8-character SDEP segment name followed by the segment data. The date/time stamp is a 3-byte unsigned packed decimal Julian date field and a 5-byte unsigned packed decimal time field.

The Convert DataTool can convert this file from this format to some other format.

Parent topic: The Useq Function


The Zeroload Function

The Zeroload function creates the database data files and primes them for use. The database data files contain the segment data and pointers for the database. A database must be Zeroloaded before an application can issue calls against it. An automatic Zeroload is performed by the IMSDBU Load function prior to loading the data. A Zeroload can also be performed by the stand-alone Zeroload utility or DBUTIL.

Note:

Zeroloading an existing database reinitializes the database and causes any data to be lost.

When running IMSBDU from the command line, the function-id to use for the Zeroload function is ZERO.

  • The Zeroload Function's Inputs and Outputs
  • Zeroload Database Names
Parent topic: IMSDBU Functions Overview
Related concepts
Fast Path MSDBs
The Add Function
The Load Function
The Runlist Function's Inputs and Outputs
Related reference
Zeroload Directives


The Zeroload Function's Inputs and Outputs

Input

The input to a Zeroload function is the name of a primary physical DBD which has been defined using DBDGEN. A Zeroload is not required, and should not be run, for any other kinds of databases.

Exclusive use databases and shared update (Fileshare) databases can be Zeroloaded. Shared read-only, Remote IMS, and User Exit databases cannot be Zeroloaded. An attempt to run a Zeroload for an incorrect Database Catalog type will result in an error.

An error message is issued if you attempt to Zeroload the following databases:

  • The primary index for a HIDAM database. A primary index database is not required. The .IDX component of an MFIMS database is the equivalent of a primary index.
  • Secondary index databases. These are created automatically when Zeroloading the primary database they index. A secondary index DBD which defines non-unique keys must be genned before Zeroloading the primary database.
  • Databases defined as ACCESS=LOGICAL. The physical databases contain the required pointers to support logical relationships.
  • GSAM databases. See the GSAM topic for complete details for GSAM databases.

Output

The output from a Zeroload function is the set of data files for the primary database and any secondary indexes defined. Any database calls or IMSDBU special functions can be made against a Zeroloaded database. A PCB with processing option 'L' is not required to load an initial segment to a database.

Parent topic: The Zeroload Function


Zeroload Database Names

After performing a Zeroload, the output dbdname.DAT and .IDX files are the initialized data files for the database segment data and segment pointers. Exclusive use database data files reside in the location indicated by the exclusive use setting in the IMS project settings. If not set, they will reside in the project DATA directory. For Fileshare databases, the shared update IMS project setting names the Fileshare Server and optionally, a drive and/or directory.

The names for secondary index data files are the XDFLD's LCHILD name suffixed with both .DAT and .IDX. These files contain the secondary index key and pointer to the primary physical database. They reside in the same directory as the primary database files.

The database files may be copied, moved, renamed, or deleted using any standard operating system command or utility for manipulating files. These actions must be performed on both the .DAT and .IDX file components. The same actions should be applied to the .DAT and .IDX components for any secondary indexes. If a physical database is logically related to other databases, all of the files for the set of related databases must be acted on.

Example

DBD NAME=TEST01DD,
    ACCESS=(HIDAM,VSAM)
SEGM NAME=TESTHDRS,PARENT=0,
     BYTES=120
FIELD NAME=(SEQFIELD,SEQ,U),
      BYTES=1,START=4
FIELD NAME=REQ,
      BYTES=20,START=5
LCHILD NAME=(TESTHDRI,TEST01PD),PTR=INDX
LCHILD NAME=(TESTHDRX,TEST012D),PTR=INDX
XDFLD NAME=XSEQ,SRCH=REQ

The name input to Zeroload is TEST01DD. An attempt to Zeroload the primary index TEST01PD or the secondary index TEST012D will result in an error message.

The resulting database files for the primary database are TEST01DD.DAT and TEST01DD.IDX.

There is no 'special' data file for the primary index of a HIDAM database. The index is automatically included within these data files.

The resulting database files for the secondary index TEST012D are TEST012D.DAT and TEST012D.IDX.

If you copy this database to another directory, copy all four of these files. For deleting, backup, or other operations, perform the same action for each of these four files.

Parent topic: The Zeroload Function


JCL Support

  • Enterprise Server Integration with the IDE
    This chapter describes how to use the JCL support from the IDE.
  • JCL development
  • Files and Data Sets
    This section provides introductory information on how MSS uses the following types of file: Project files, System catalog files, User catalog files, Catalog files, Data set files, and Spool files
  • Advanced Data Set Information
    This section expands on the information presented in the topic Files and Data Sets in your User's Guide.
  • Utility Programs
    MSS has a number of utility programs. Many of these emulate the functions of commonly-used mainframe batch utilities. You can invoke these utilities in a JCL jobstream or REXX exec.
  • MVS Emulation
    This chapter describes how MSS emulates various facilities provided under MVS, OS/390 and z/OS on the mainframe.
  • Micro Focus Batch Scheduler Integration
  • Using JCL User Exits
    The JCL component provides a facility called the JCL user exit, which enables you to monitor and control various events that occur during execution of a job or TSO session.
  • Using JCL Subsystem Exits
  • REXX Support
    This chapter describes how REXX is supported in MSS.
  • Integration with CICS Support
    Using JCL facilities with CICS Support.
  • JCL API
Parent topic: Mainframe Programming


Enterprise Server Integration with the IDE

  • Introduction
  • Using the Project-based Facilities
  • Remote Job Execution
Parent topic: JCL Support


Introduction

When you are developing JCL applications for running on Enterprise Server, you can use the following Enterprise Server facilities from the IDE:

  • You can can start and stop an enterprise server associated with a project, submit jobs and view the results.
  • You can submit jobs to remote enterprise servers.

Also at any time, whatever type of development you are doing, you can access the Enterprise Server Administration Web interface, from your COBOL development environment.

Parent topic: Enterprise Server Integration with the IDE


Using the Project-based Facilities

If you are working on a JCL application, and you want to run it in a JCL-enabled enterprise server, you need to stop and start the enterprise server. You can do this from outside the IDE, with ES Admin running in its own browser window, or from within the IDE. Stopping and starting with in the IDE is likely to be more convenient, since you don't need to switch between windows.

To stop and start within the IDE, you need to associate the current project with an enterprise server. You must use an enterprise server that:

  • Is defined on your machine
  • Is enabled for MSS and JES
  • Has two system services:
    • One with a service class of "MF ES".
    • One with a service class of "MF JES"
  • All new servers that you create as MSS servers automatically have these services. If you want to use an existing server, you need to enable it for MSS (if not already enabled), then add the services.

Once you have associated the project with an enterprise server, you can:

  • Start the server associated with the project
  • Stop the server associated with the project
  • View the catalog
  • View the spool queues
  • Submit a job to the server associated with the project; make sure you have built the project first
  • Debug a job

Be careful not to mix different ways of starting and stopping servers; if you start a server from the IDE, you must stop it from the IDE.

Parent topic: Enterprise Server Integration with the IDE
Related information
To enable MTO for an enterprise server
To add a service for JCL
To add a service for integration with the Micro Focus Development Tools


Remote Job Execution

You can submit a JCL job to a remote enterprise server, that is, a server running on another machine in your local network. The JCL must be held locally, on your machine.

The IDE uses the MFCC (Micro Focus Common Client) infrastructure to determine which enterprise servers to interact with. It's controlled by a configuration file which by default is mf-client.dat, located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin. You can create your own configuration file of any name or location, but you must identify it using the MFC_CONFIG environment variable.

Before you can submit jobs to a remote enterprise server, you need to add an entry to this file that specifies the remote machine's URL and the port number for the Directory Server. Once you have done this, all the enterprise servers on the remote machine that have a service with the service class "MJ ES" become available in the dropdown list of enterprise servers in the Enterprise Server group on the Project Properties page. You can now associate the project with the remote server, and submit JCL to the remote machine by right-clicking the JCL file in the project view and clicking Submit.

You see the progress of the job in the Application Output window. After the job has finished, you can view the catalog and the spool queues in the normal way.

Note: The Start Server and Stop Server options on the Tools > Enterprise Server menu do not work with the remote server, although they are enabled. You must start and stop the remote server using ES Admin.
Parent topic: Enterprise Server Integration with the IDE


JCL development

  • Introduction
    MSS enables you to build an MVS mainframe application on Studio Enterprise Edition, deploy it to Enterprise Server on Windows or UNIX, and run it in Enterprise Server. You can maintain JCL files either in Studio Enterprise Edition or Enterprise Server.
  • Printer Exit Modules
  • ACCEPT and DISPLAY Handling
  • ASCII/EBCDIC
  • Enabling JOBLIB DD and STEPLIB DD Processing
  • Output Limitation Support
Parent topic: JCL Support


Introduction

An important part of an MVS application is the JCL jobstream that controls its execution. MSS provides facilities to support the use of batch JCL jobstreams on the PC or UNIX workstation. Within Studio Enterprise Edition, you can:
  • Create new jobstreams
  • Scan the jobstreams for syntax errors and dependencies
  • Submit the jobstreams for running in an enterprise server and view the spool output files
A major objective of the JCL support is to keep the operations in MSS as similar as possible to those done on the mainframe. Thus in MSS, you can:
  • Use mainframe data set names in the jobstream, even though the data is held in a file on the PC or UNIX workstation
  • Process jobstreams as if they were being run on the mainframe

  • View and process the SYSOUT listing and any other printed output produced by the jobstream

  • Use the functions of the many mainframe batch utilities
Before you start to use the JCL support in MSS, you need to understand more about the following topics:
  • JCL jobstreams
  • Data sets
  • Application programs
  • JCL Jobstreams
  • Data Sets
  • Application Programs
Parent topic: JCL development


JCL Jobstreams

You can run the same JCL jobstreams in MSS as you can on the mainframe. MSS checks the JCL statements for errors as far as possible. Several parameters, especially on DD statements, have no meaning in MSS running on Windows or UNIX and are ignored. This section describes the differences that apply when using JCL jobstreams in the MSS environment instead of the MVS mainframe environment.

MSS supports both MVS JCL and VSE JCL. The following sections describe the levels of support for MVS JCL and VSE JCL.

  • MVS JCL Support
  • VSE JCL Support
  • Special Characters in JCL Program-names
  • Character Sets
Parent topic: Introduction


MVS JCL Support

The following sections outline the features and statements in MVS JCL that are supported.

  • MVS JCL Features
  • MVS JCL Statements
Parent topic: JCL Jobstreams


MVS JCL Features

The following MVS JCL features are supported:

  • Instream procedures
  • Cataloged procedures
  • Symbolic parameters
  • EXEC statement overrides
  • JOBLIB and STEPLIB DD statements
  • DD statement overrides
  • Conditional execution (specified by IF, THEN, ELSE, and ENDIF statements)
  • Job restart after execution failure
  • Concatenated data sets
  • Instream data sets (preceded by a DD * or DD DATA statement)
  • Partitioned data sets
  • Generation data groups
  • Temporary data sets
  • Comments (indicated by //*)
  • Normal mainframe nesting limits (that is, 15 levels of nested procedures and 15 levels of nested INCLUDE statements)

The following MVS JCL features are not supported:

  • Multiple jobs in one jobstream
  • Program control statements (enclosed by CNTL and ENDCNTL statements)
  • Other special DD statements that are not relevant to the PC or that are implemented differently by MSS. These statements have the following DD names:
    • JOBCAT
    • STEPCAT
    • SYSABEND
    • SYSMDUMP
    • SYSUDUMP
    • SYSCHK
    • SYSCKEOV

More information about the MVS JCL statements supported by MSS is given later in this section.

MSS supports the running of MVS JCL jobstreams either directly or via the TSO SUBMIT command and the Micro Focus extension ASUBMIT. You can run these TSO commands with the IKJEFT01 utility.

Files containing MVS JCL jobstreams and cataloged procedures can be created on the PC or UNIX machine. Cataloged procedures should be stored as members of partitioned data sets, known as procedure libraries. The procedure libraries are defined to MSS in two different ways:

  • The libraries defined in the JCLLIB statement, for a single job
  • The libraries defined to MSS, for all jobs.

MSS searches these libraries in the order specified above.

When the job is submitted to an enterprise server for running , the effect depends on the setting of the TYPRUN parameter to the JOB statement as shown below:

TYPRUN=SCAN | The syntax is scanned
TYPRUN=COPY | The job stream is copied to a SYSOUT data set
TYPRUN=HOLD | Holding of the job until explicitly released for execution
No TYPRUN | The job is executed immediately, assuming resources are available
Parent topic: MVS JCL Support


MVS JCL Statements

For a full description of MVS JCL statements, please refer to your IBM OS/390 MVS JCL Reference manual.

The following MVS JCL statements are supported:
Statement | Description
DD | Defines the allocation and disposition of a data set
EXEC | Defines a job step, including the program or cataloged procedure to be run

IF

THEN

ELSE

ENDIF

Specifies conditional execution of MVS JCL statements
INCLUDE | Specifies where pre-defined MVS JCL statements are to be included in the jobstream
JCLLIB | Specifies procedure libraries and their search order
JOB | Defines a job. MSS supports only one job per jobstream
JOBLIB | Specifies private libraries to be searched for programs identified in EXEC statements
PROC | Defines the start of an instream MVS JCL procedure
PEND | Defines the end of an instream MVS JCL procedure
SET | Defines the values to be assigned to symbolic parameters
STEPLIB | Specifies private libraries to be searched for programs identified in EXEC statements
OUTPUT Specifies the processing options that the job entry subsystem is to use for printing a SYSOUT data set. MSS supports only the following parameters:
  • BURST
  • CHARS
  • COPIES
  • DEST
  • FLASH
  • FORMS
  • UCS

The following MVS JCL statements are not supported. They are checked only for correct syntax.

Statement | Description
COMMAND | Issues commands to MVS and JES2
CNTL | Defines the start of a set of program control statements
ENDCNTL | Defines the end of a set of program control statements
XMIT | Transmits records from JES3
Parent topic: MVS JCL Support
Related information
IBM OS/390 MVS JCL Reference


VSE JCL Support

The following sections outline the support for VSE JCL.

  • Restrictions
  • VSE JCL and POWER Statements
  • POWER Statements
  • VSE JCL Configuration Files
Parent topic: JCL Jobstreams


Restrictions

The following list describes some general restrictions that apply to the support for VSE JCL. For information on the support for individual statements, see the sections VSE JCL and POWER Statements and POWER Statements.

  • There is no TAPE support.
  • There is no VSE development environment (such as ICCF, DITTO or LIBR).
  • JCL statements can only be executed as part of a submitted file; that is, you cannot enter VSE JCL statements dynamically at the operator console.
  • There is no support for VSE BACKGROUND / FOREGRAND / STATIC / DYNAMIC partitions.
  • All JCL commands except continuations must start with //.
  • COBOL executables are generated in the usual Micro Focus way. There is no support for Compile/Link or Compile/Go via JCL.
  • DDs cannot persist across a Job Boundary, except for Standard labels.
  • Output listings, such as joblog, do not have a VSE look and feel.
Parent topic: VSE JCL Support
Related information
VSE JCL and POWER Statements
POWER Statements


VSE JCL and POWER Statements

The following table shows the level of support available for VSE JCL and POWER statements. For each statement, the "Support Level" column indicates whether that statement is fully processed or only parsed to check for correct syntax. Any VSE JCL and POWER statement not listed in this table is not supported.

Statement | Parameters | Support Level
// ASSGN | SYSxxx | Parse
 | ",Device" | Parse
 | "[,TEMP|PERM]]" | Parse
 | "[,VOL-volser]" | Parse
// ASSGN | SYSxxx | Process
 | ",Device" | Process
 | "[,TEMP|PERM]]" | Process
// ASSGN | SYSxxx | Parse
 | ",Device" | Parse
 | "[,mode|ALT]" | Parse
 | "[,TEMP|PERM]]" | Parse
 | "[,VOL-volser]" | Parse
// DATE | mm/dd/yy or dd/mm/yy depending on system settings | Parse
//DLBL | filename | Process
 | ",’fileid’" | Process
 | "[,date]" | Parse
 | "[,code]" | Parse
 | "[,DSF]" | Parse
 | "[,BLKSIZE=n]" | Process
 | "[,CISIZE=n]" | Parse
//DLBL | filename | Process
 | ",’fileid’" | Process
 | "[,exp-date]" | Parse
 | "[,VSAM]" | Process
 | "[,DSF]" | Parse
 | "[,BUFSP=n]" | Parse
 | "[,BUFND=n]" | Parse
 | [BUFNI=n] | Parse
 | "[,CAT=catname]" | Parse
 | "[,DISP=(disp,disp,disp)]" | Process
 | "[,RECORDS=primary,secondary]" | Parse
 | "[,CISIZE=n]" | Parse
// EXEC | PROC=procname | Process
 | "[,parms]" | Process
// EXEC | [PGM=]progname | Process
 | "[,REAL]" | Parse
 | "[,SIZE=size]" | Parse
 | "[,GO]" | Parse
 | "[,PARM=’value’]" | Process
// EXTENT | [logical-unit] | Parse
 | ",[volser]" | Parse
 | ",[type]" | Parse
 | ",[seqnumber]" | Parse
 | ",[location]" | Parse
 | ",[quantity]" | Parse
 | ",[split-cylinder-track]" | Parse
// GOTO | [label | $EOJ] | Process
// IF | { $RC | $MRC | parameter-name } | Process (except for parameter-name, which is parsed only)
 | operator | Process
 | value | Process
 | [OR|AND] | Process
 | { $RC | $MRC | parameter-name } | Process
 | operator | Process
 | value | Process
 | THEN | Process
// JOB | jobname | Process
 | [accounting info] | Process
// LIBDEF | type | Process
 | "[,SEARCH=(lib1,slib1,…lib15,slib15)]" | Process
 | "[,CATALOG=lib.slib]" | Process
 | "[,TEMP|PERM]" | Parse
// LIBDEF | type | Parse
 | "[,SEARCH=(lib1,slib1,…lib15,slib15)]" | Parse
 | "[,CATALOG=lib.slib]" | Parse
 | "[,TEMP|PERM]" | Parse
// LIBDROP | type | Process
 | "[,definition-type]" | Process
 | "[,TEMP|PERM]" | Parse
// LIBDROP | type | Parse
 | "[,definition-type]" | Parse
 | "[,TEMP|PERM]" | Parse
// LIBLIST | type | Process
 | "[,partition]" | Parse
 | "[,SYSxxxx]" | Parse
// LISTIO | type | Process
 | "[,partition]" | Parse
 | "[,outdev]" | Parse
// LIBSERV | Send requests to tape library server | Parse
// LOG and // NOLOG |  | Parse
// MTC | operation | Parse
 | "[,device]" | Parse
// ON | {$RC operator n | $CANCEL |$ABEND } | Process
 | [{OR|AND} condition] | Process
 | {$RC operator n | $CANCEL |$ABEND } | Process
 | [GOTO label | CONTINUE] | Process
// OPTION | parm | Parse
 | "[,parm2,…….]" | Parse
// PAUSE | Comment data | Parse
// PROC | [parm=value] | Process
// PWR | PRELEASE [operands] !] | Process
 | PHOLD[operands | Parse
// RESET | type | Process
// SETPARM | Parm=value | Process
 | "[,parm=value,………]" | Process
// SETPFIX |  | Parse
// STDOPT | "Option[,option2…]" | Parse
// TLBL | filename | Process
 | ",’fileid’" | Process
 | "[,date]" | Parse
 | "[,volser]" | Parse
 | "[,volseq]" | Parse
 | "[,fileseq]" | Parse
 | "[,generation]" | Parse
 | "[,version]" | Parse
// UPSI | nnnnnnnn | Process
// ZONE | EAST/hh/mm or WEST/hh/mm | Parse
/. label |  | Process
/* |  | Process
./ |  | Process
* |  | Process
/+ |  | Process
Parent topic: VSE JCL Support


POWER Statements

The following table shows the level of support available for POWER statements. For each statement, the "Support Level" column indicates whether that statement is fully processed or only parsed to check for correct syntax. Any POWER statement not listed in this table is not supported.

Statement | Parameters | Support Level
* $$ JOB | JNM=jobname | Process
 | [,DISP=disp] | Parse
 | [,PRI-pri] | Parse
 | [,CLASS=class] | Parse
 | [,NTFY=ntfy-option] | Parse
 | [,USER='user info'} | Parse
 | FROM=user_id | Parse
 | LOG=x | Parse
 | BRTNC=xxx | Parse
 | DUETIME=options | Parse
 | [,BLDG=x] | Parse
 | [,DEPT=x] | Parse
 | [,ROOM=x] | Parse
 | [,EOJMSG=YES] | Parse
 | [,PWD=x] | Parse
 | [,PROGR=x] | Parse
 | SYSID=(node_id,user_id) | Parse
 | NETACCT=account_no | Parse
 | XDEST=(node_id,user_id) | Parse
 | LDEST=(node_id,user_id) | Parse
 | PDEST=(node_id,user_id) | Parse
 | SEC=(user_id,password) | Parse
* $$ LST | [,DISP=disp] | Process
 | [,PRI-pri] | Process
 | [,CLASS=class] | Process
 | [,UNIT=addr] | Process
 | [,LST=SYSxxx] | Process
 | [,FNO=xxx] | Process
 | [,FCB=xxxxxx] | Process
 | [,JSSEP=x] | Process
 | [,RBS=nnnn] | Process
 | RBM=(norbm1,norbm2) | Process
 | RBC=norbc | Process
 | BRTNC=xxx | Process
 | PURGE=nnn | Process
 | DEST=(node_id,user_id,subsystem) | Process
 | PRMODE=value | Process
 | REMOTE=remote_id | Process
 | CMPACT=name | Process
 | SYSID=n | Process
 | DIST=distcode | Process
 | TADDR=(tapeaddr,mode) | Process
 | USER=user_info | Process
 | PWD=password | Process
 | BURST=x | Process
 | CHARS=tablename | Process
 | COPYG=(groupvalue) | Process
 | DLFT=x | Process
 | FLASH=(overlayname,count) | Process
 | MODIFY=(copymodname,tablename) | Process
 | [,PAGEDEF=xxx] | Process
 | [,FORMDEF=xxxx] | Process
* $$ PUN |  | Process
 | JNM=jobname | Process
 | CLASS=class | Process
 | DISP=disposition | D | T | Process
 | PRI=priority | Process
 | PUN=punchaddr | Process
 | COPY=n | Process
 | FNO=formno | Process
 | RBS=norbs | Process
 | RBM=(norbm1,norbm2) | Process
 | RBC=norbc | Process
 | JSEP=(n,option) | Process
 | BRTNC=YES | NO | Process
 | PURGE=NO | nnnn | Process
 | DEST=(node_id,user_id,subsystem) | Process
 | PRMODE==x | Process
 | SYSID=n | Process
 | DIST=distcode | Process
 | USER=userinfo | Process
 | PWD=password | Process
* $$ SLI |  |
 | MEM-membername | Parse
 | ,[.type] | Parse
 | ,S=lib1.sublib,lib2.sublib2] | Parse
 | Sublib. | Parse
 | bookname | Parse
* $$ SLI |  |
 | ICCF=membername, | Process
 | LIB=(libnumber,password) | Process
* $$ DATA | name | Parse
* $$ CTL | CLASS=class | Parse
* $$ EOJ |  | Process
Parent topic: VSE JCL Support


VSE JCL Configuration Files

At system start-up, VSE can set a number of values that are available to any job run on the system until shut down. MSS emulates this behavior with the use of a configuraiton file. You can use the configuration file to specify information about the following:

  • Devices. These can be designated as Printers, Punches, Tapes, Readers or Disks.
  • Logical Units. SYSxxx (where xxx is a 3 digit number) or one of the standard logical devices SYSIPT, SYSLST etc.
  • Standard labels. Commonly-used file names and the associated data sets can be set so that no DLBL statement for this filename/data set name is necessary in the JCL decks; the file is automatically allocated.

MSS reads the configuration file at the start of each job, so if you run a job then modify the configuration file, running the job again will pick up the modified configuration file.

  • Structure of a VSE JCL Configuration File
  • Specifying the Location of the VSE JCL Configuration File
  • Example VSE JCL Configuration File
Parent topic: VSE JCL Support


Structure of a VSE JCL Configuration File

A VSE JCL configuration file is a text file that contains a number of name-value pair entries, with each entry on a separate line. Blank lines or lines beginning with an asterisk (*) are treated as comment lines.

The format of the name-value pair entries are shown below.

For devices:

device_id      id
device_type    type

where:

id | is a three-digit code specifying the device address
type | is one of PRINTER, READER, PUNCH, DISK or TAPE.

For logical units:

assgn_lu        lu
assgn_device    device

where:

lu | is the logical unit to use.
device | is the device to assign to the logical unit lu.

For standard labels:

dlbl_dd         dd
dlbl_dsn        dsn

where:

dd | is the label to use.
dsn | is the data set name to assign to the label dd.
Note: There is an addtional name-value pair entry for defining partitions, but specifying it has no effect.
Parent topic: VSE JCL Configuration Files


Specifying the Location of the VSE JCL Configuration File

To make a VSE JCL configuration file available to MSS you specify its location using the VSE_STARTUP_CFG environment variable. For example, if you create the configuration file in c:\setup\vseconfg.cfg , you would set VSE_STARTUP_CFG as follows:

SET VSE_STARTUP_CFG=c:\setup\vseconfg.cfg
Parent topic: VSE JCL Configuration Files


Example VSE JCL Configuration File

* ========================================================================
* =     VSE SYSTEM START-UP
* ========================================================================
* ========================================================================
* =     devices
* ========================================================================
device_id        02A
device_type      PRINTER
*
device_id        02B
device_type      PRINTER
*
device_id        02C
device_type      PRINTER
*
device_id        02D
device_type      PRINTER
*
device_id        02E
device_type      PUNCH
*
device_id        02F
device_type      READER
*
device_id        02G
device_type      INTRDR
*
device_id        42E
device_type      PRINTER
*
device_id        43E
device_type      PRINTER
*
device_id        44E
device_type      PRINTER
*
device_id        45E
device_type      PRINTER
*
device_id        46E
device_type      PRINTER
*
device_id        020
device_type      DISK
*
* ========================================================================
* =     permanent assignments
* ========================================================================
*
assgn_lu         SYSIPT
assgn_device     02F
*
assgn_lu         SYSRDR
assgn_device     02G
*
assgn_lu         SYSLST
assgn_device     02A
*
assgn_lu         SYS001          SYSxxx logical unit
assgn_device     02B             cuu    device (device1 to device6)
*
assgn_lu         SYS002
assgn_lu_2       SYS001
*
assgn_lu         SYS002
assgn_lu_2       SYSLST
*
assgn_lu         SYSPCH
assgn_device     02E
* ========================================================================
* =     standard labels
* ========================================================================
 dlbl_dd         CMAST
 dlbl_dsn        CUSTOMER.MASTER.FILE
* ========================================================================
* =     Default In-stream input file.
* =       MVS PROGS these programs expect SYSIN and SYSPRINT
* =       by default. Max allowed = 100. IDCAMS, SORT and IPCPBTCH
* =       are assumed.
*
 USE_SYSIN       IEBGENER
 USE_SYSIN       MFJMATCH
* ========================================================================
*       POWER JOB DISP and LST DISP statements.
*         * $$ JOB DISP (hold or execute, delete or retain)
*         and
*         * $$ LST DISP (print or hold, delete or retain or spool to tape)
*         are normally parsed and ignored. If these options are set to 'Y'
*         then
*           the JOB DISP will override the JOB CLASS
*           the LST DISP will override the LST CLASS
*         so that the DISP processing can be emulated to some extent
*         via appropriate use of the CLASSES
*
 JOB_DISP        N
 LST_DISP        N
* ========================================================================
*      Controlling which DLBL and TLBL assignments are displayed.
*        By default all the current DLBL assignments will display in the
*        log for every step. Those which were not explicitly assigned
*        in the JCL for the current step will be preceded by ## and can be
*        suppressed by including the following line
  SHOW_##_ASSIGNS N
* ========================================================================
*      Controlling which messages are displayed on the log.
*        The following parameters will set values for the
*        MVS MSGLEVEL statement and message parameters respectively.
*        These control which JCL statements and messages appear in the log
 MESSAGE_LEVEL1  0                      valid values are 0,1,2
 MESSAGE_LEVEL2  0                      valid values are 0,1
* ========================================================================
*      Validation
*        If the config file fails validation the following message will
*        appear on the console:
*     JCLCM0198I JOB01208 ???????? VSE CONFIG FILE - FAIL CODE RC hh:mm:ss
* ========================================================================
* Values for the reason code (RC) are as follows:
*	01	Mismatched field name and value.
*	02	Too many devices specified - limit is 255
*	03	Device ID error
*	04	Device Type error
*	05	Too many assigns - limit is 300
*	06	Invalid ASSGN_LU_1
*	07	Invalid ASSGN_LU_2
*	08	Invalid ASSGN_DEVICE
*	09	Invalid DLBL or TLBL
*	10      not used
*	11	Invalid DLBL or TLBL
*	12 	System error
*	13      DLBL or TLBL label error
*	14	SHOW_##_ASSGNS error
*	15	MESSAGE_LEVEL1 error
*	16	MESSAGE_LEVEL2 error
*	17      Record with no valid keyword found
*	18, 19, 20 ,21	Unspecified Parse error
*	22	Config file OPEN failed - check VSE_STARTUP_CFG is correct
*	23	Config file READ failed
* ========================================================================
Parent topic: VSE JCL Configuration Files


Special Characters in JCL Program-names

MSS validates JCL program-names using IBM's list of valid characters. Valid characters in this list are @ # and $, although in some codepages the conversion of these characters causes incompatibilities with the name validation. If you experience problems using any of these special characters in the name of a JCL program, you should report these to Micro Focus.

Parent topic: JCL Jobstreams


Character Sets

You can run JCL applications on Enterprise Server either in EBCDIC or ASCII.

Parent topic: JCL Jobstreams
Related information
Character Sets


Data Sets

Support is provided for most mainframe data set organizations and record formats, as described in the topic Advanced Data Set Information .

Support is also provided for temporary data sets and in-stream data sets included in the jobstream.

Parent topic: Introduction
Related information
Advanced Data Set Information


Application Programs

MSS emulates the interface between application programs and MVS in order to allocate data sets and pass parameters. These facilities are described below.

  • Allocating Data Sets
  • Passing Parameters
Parent topic: Introduction


Allocating Data Sets

MVS provides a direct connection between the filename used in the program and the corresponding data set name used in the JCL. For example, for SYSUT1 in a COBOL program:

SELECT INFILE ASSIGN TO UT-S-SYSUT1

connects to

//SYSUT1 DD DSN=DSNAME1,DISP=OLD

and allocates to the program the PC file representing the data set named DSNAME1.

And, for SYSUT2:

SELECT OUTFILE ASSIGN TO UT-S-SYSUT2

connects to

//SYSUT2 DD DSN=DSNAME2,DISP=(NEW,CATLG),...

and allocates to the program a PC file representing the data set named DSNAME2. The file is created and cataloged automatically when the jobstream is run.

Parent topic: Application Programs


Passing Parameters

Parameters specified in the JCL PARM parameter are passed to the program using the same rules as the mainframe. Options specified in the parameters string are separated from any application parameters by a slash (/) character. For example:

PARMS(application-parameters/run-time-options)

The linkage area used when passing parameters is:

01 PARM.
     03 PARM-LENGTH    PIC 9(4)   COMP.
     03 PARM-DATA      PIC X OCCURS 100.
Parent topic: Application Programs
Related information
Passing Parameters


Printer Exit Modules

Enterprise Server JCL support provides the capability to view and browse job and report output using a browser based SDSF-like spool viewer. It does not include any other output or document management software per se, but instead allows you to utilize printer exit modules to integrate its batch printing capabilities with other third-party or external print subsystems.

A printer exit module (often abbreviated as simply printer exit) is a program that you can associate with a batch printer Server Execution Process (SEP). Instead of the SEP writing the output directly to a printer, it passes the output to the specified printer exit module. The printer exit module can then process the output before printing it. You might, for example, write an exit to present figures using graphical elements such as pie charts.

You can specify a unique printer exit module for each batch printer SEP, which means that you can set up specialized output processing for each output class if you wish. Printer exit modules have full access to related OUTPUT statement information contained in the JCL including destination, copies, routing, and form definition.

  • Writing a Printer Exit
Parent topic: JCL development


Writing a Printer Exit

An example of a printer exit module, sampprnx.cbl, is provided in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Net Express IDE\SAMPPRNX directory by default. This example simply takes each line and calls the COBOL run-time system's print routines to print it.

Printer exits need not be written in COBOL, but they must handle parameters as illustrated in sampprnx. These parameters are defined and documented in the cascbprn.cpy copybook. COBOL printer exits must be compiled with the non-mainframe dialect, which implies CHARSET(ASCII). They must be also built as an .int, a .gnt, or a .dll.

The linkage section of sampprnx, and the cascbprn.cpy are shown below.

linkage section.
 copy 'cascbprn.cpy' replacing ==(ws)== by ==lk==.
 01 lk-catalog-rec.
  copy 'mvscatlg.cpy' replacing ==(TAG)== by ==lk==.
 01 LK-OUTPUT.
  copy mvsdout  replacing ==()== by ==LK-OUTPUT==.
 01 LK-SPOOL.
  copy 'spool.cpy' replacing ==(tag)== by ==lk==.

       01  (ws)-prn-exit-interface.
           *>  What is the format of the structure used to call the
           *>  printer exit.  Will change with major revisions to this
           *>  Data Structure.
           03  (ws)-prn-version                     pic x(4) comp-5.
               88  (ws)-prn-current-version-88      value 1.
           *>  The printer exit is driven once as the batch printer SEP
           *>  starts, once for every print job, and once when the batch
           *>  printer is shut down.
           03  (ws)-prn-command                     pic x    comp-5.
               88  (ws)-prn-exit-init-88            value 0.
               88  (ws)-prn-exit-print-88           value 1.
               88  (ws)-prn-exit-term-88            value 2.
           *>  For the requested print job.  (ws)-prn-exit-print-88
           *>  what is the character set of the data being printed.
           03  (ws)-prn-char                        pic x.
               88  (ws)-prn-char-ascii-88           value 'A'.
               88  (ws)-prn-char-ebcdic-88          value 'E'.
               88  (ws)-prn-char-unknown-88         value '?'.
           *>  This is the file status returned by driving the procedure
           *>  pointers:
           *>              (ws)-prn-sysout-open-pptr
           *>              (ws)-prn-sysout-read-next-pptr
           *>              (ws)-prn-sysout-close-pptr
           *>
           03  (ws)-prn-sysout-status               pic x(2).
               88  (ws)-prn-sysout-status-ok-88     value '00'.
               88  (ws)-prn-sysout-status-eof-88    value '10'.
      ***--------------------------------------------------------------*
           *>  Procedure pointer to drive the open of the sysout dataset
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-sysout-open-pptr            procedure-pointer.
           *>  Procedure pointer to a read of the sysout dataset
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-sysout-read-next-pptr       procedure-pointer.
           *>  Procedure pointer to drive the close of the sysout dataset
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-sysout-close-pptr           procedure-pointer.
           *>  Procedure pointer to allow a message to be driven to the
           *>  console.  (all functions)
           03  (ws)-prn-message-pptr                procedure-pointer.
           *>  Procedure pointer to retrieve the next OUTPUT statement.
           *>  Returns a null (ws)-prn-output-record-ptr if none are
           *>  available.
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-output-read-next-pptr       procedure-pointer.
           03                                       procedure-pointer.
           03                                       procedure-pointer.
      ***--------------------------------------------------------------*
           *>  A pointer to the data structure contained in Spool.cpy
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-spool-record-ptr            pointer.
           *>  A pointer to the data structure contained in mvscatlg.cpy
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-catalog-record-ptr          pointer.
           *>  The printer handle for the printer assigned to the this SEP
           03  (ws)-prn-printer-handle              pic x(4) comp-5.
           *>  The LRECL of the dataset being printed.
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-lrecl                       pic x(4) comp-5.
           *>  The Maximum LRECL of the dataset being printed.
           *>  Same as ws-prn-lrecl.
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-lrecl-max                   pic x(4) comp-5.
           *>  The Minimum LRECL of the dataset being printed.
           *>  (Variable Length SYSOUT Datasets.
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-lrecl-min                   pic x(4) comp-5.
           03                                       pic x(4).
           *>  The length of the buffer used to return data when driving
           *>     (ws)-prn-sysout-read-next-pptr
           *>  (How much data was returned)
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-buffer-len                  pic x(4) comp-5.
           03  (ws)-prn-buffer.
               05  (ws)-prn-buffer-byte occurs 384 times pic x comp-x.
           *>  The "MVS" Name of the document being printed.
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-document.
               05  (ws)-prn-document-len            pic x(2) comp-5.
               05  (ws)-prn-document-title          pic x(128).
           *>  The name of the batch printer driving this print job.
           03  (ws)-prn-printer.
               05  (ws)-prn-printer-name-len        pic x(2) comp-5.
               05  (ws)-prn-printer-name            pic x(128).
           *>  The "physical" filename for the file being printed.
           *>  (eg.  Where does it reside on the disk pack)
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-sysout-file-name            pic x(260).
           *>  A pointer to an OUTPUT Statement associated with this
           *>  SYSOUT Dataset.  Points to the data structure contained
           *>  in IDADOUTP.CPY
           *>    (ws)-prn-exit-print-88 only
           03  (ws)-prn-output-record-ptr           pointer.
  • Accessing OUTPUT Statement Information
  • How the Exit is Called
  • Using the Exit
Parent topic: Printer Exit Modules


Accessing OUTPUT Statement Information

The exit can access the OUTPUT statement associated with the dataset through a pointer, (ws)-prn-output-record-ptr, defined in the cascbprn.cpy copybook. This points to a structure defined in the IDADOUTP.cpy copybook. For an illustration of this, please refer to the process-output-statements section of sampprnx.

Parent topic: Writing a Printer Exit


How the Exit is Called

A printer SEP that has been configured to use the printer exit module will call it as follows:

  • When the batch printer SEP is started. The printer exit module can do any initial processing that might be needed.
  • Repeatedly for each spool output file that would have been directed to the printer. Information about the spool output file is passed to the printer exit module instead. The exit module can copy the file, read and manipulate each line, print it, or do anything else that would be appropriate - for instance drive an external printing system.
  • When the batch printer SEP is terminated. The printer exit module can do any final processing that might be needed.
Parent topic: Writing a Printer Exit


Using the Exit

You can associate a printer exit module with a batch printer SEP defined as a permanent feature of an Enterprise Server, or with a batch printer SEP created during a session, or both. A printer exit module can also be associated with more than one batch printer SEP.

To create a printer SEP with an exit as a permanent feature, you use the Server Enterprise Edition Administration JES Printer Tab:

  1. In the table of servers on the Home page of Server Enterprise Edition Administration, click Edit to the left of the row for the relevant server.
  2. Navigate to Server > Properties > MSS > JES > Printers .
  3. Click Add and specify the details for the printer, giving the name of the printer exit in the Exit Module field.
  4. Click Add.

The executable file of the printer exit module must be on either the MSS Transaction Path, the JES Program Path or the COBPATH. Alternatively, if the exit is a Windows dll, it must be in a directory specified in the PATH environment variable.

Parent topic: Writing a Printer Exit


ACCEPT and DISPLAY Handling

You can run jobs on an enterprise server that include ACCEPT FROM CONSOLE and DISPLAY UPON CONSOLE statements. When execution reaches a DISPLAY statement, the display text is displayed in the console log and the job log. When execution reaches an ACCEPT FROM CONSOLE statement, the job pauses and asks for input using pages in ESMAC.

Parent topic: JCL development
Related information
Interacting with JCL Jobs


ASCII/EBCDIC

By default, Enterprise Server uses the ASCII character set. If you wish to use EBCDIC, you can override this default for an individual enterprise server.

To select ASCII or EBCDIC for an enterprise server, you use the environment variable MF_CHARSET. You specify it via ES Admin. On the Edit page for the enterprise server, on the General tab, you make the following entry in the [ES-Environment] section of the Configuration Information field:

MF_CHARSET=E

or:

MF_CHARSET=A

You can enter these as:

MF_CHARSET=EBCDIC

or:

MF_CHARSET=ASCII

for clarity if you wish. However, only the first character (E or A) is significant.

Your programs should be compiled with the CHARSET compiler directive that matches the character set of the enterprise server. The system will handle user program data appropriately for programs invoked as a result of an EXEC PGM= JCL statement, the RUN subcommand of the DSN command, or the TSO CALL command.

You should not mix ASCII and EBCDIC programs. If you do so, you are responsible for any conversion required. The compiler directive is:

CHARSET(EBCDIC)

or:

CHARSET(ASCII)

The character set attribute of all datasets is set to the current system character set. Based on their file’s character set, LSEQ datasets and SYSIN in-stream datasets are automatically converted to suit the program.

Parent topic: JCL development


Enabling JOBLIB DD and STEPLIB DD Processing

These statements specify directories that will be searched for the programs named in EXEC statements.

To enable JOBLIB/STEPLIB processing do the following:

  1. Create a dynamic PDS that represents each of the PC or UNIX subdirectories where your .gnt and .int files will reside. We recommend that you segregate .gnt and .int files into different subdirectories.
  2. Execute your JCL using JOBLIB and/or STEPLIB statements that reference the subdirectories you created in STEP1. The search order will be STEPLIB, JOBLIB, then the path specified in the JES Program Path field on the JCL > General tab in Enterprise Server.

If the partitioned data set referenced in a particular STEPLIB or JOBLIB statement exists as a catalog entry, the DD is allocated. Where there are multiple partitioned data sets referenced in a STEPLIB or JOBLIB concatenation, only those data sets that exist are mapped as part of the JOBLIB or STEPLIB concatenation.

Any job that has a STEPLIB and/or JOBLIB statement continues to run unmodified.

Parent topic: JCL development


Output Limitation Support

In line with mainframe practice, you can limit the amount of output sent to SYSOUT datasets. You can apply limits to the whole job by giving a value in the JCL job card. You can set global limits for the number of lines output using environment variables.

Limits to LINES, PAGES, CARDS, and BYTES

The LINES, PAGES, CARDS, and BYTES keyword parameters on the JCL job card are supported. PAGES, CARDS and BYTES are translated to a number of lines using the following values:

  • 60 LINES for every PAGE
  • 25 LINES for every CARD
  • 132 BYTES for every LINE

For example, an entry of PAGES=(100,CANCEL) on the job card equates to an output limit of 6000 lines before the job is cancelled.

Specifying limits with the OUTLIM parameter

Any SYSOUT DD statement can contain an OUTLIM parameter that specifies the maximum number of lines output to that dataset. When the limit has been reached the system will:
  • call the user exit, if it exists
  • process the global setting, if it exists
  • cancel the job

The OUTLIM value is ignored for SYSABEND, SYSMDUMP and SYSUDUMP datasets.

The user may implement an OUTLIM user exit to call if the output limit is reached. This can tell the system whether to continue or abend the job. The user exit program must be called MFJUSOXT, a sample of which is included in the source\enterpriseserver\exits folder of your product.

Specifying global limits with environment variables

Global limits are set by environment variables, either in the environment in which the enterprise server region was started or by entering the values in the enterprise server region's configuration settings. These values apply to all jobs that run in that region.

The format of the variable value is similar to that which would be entered in the JCL job card accounting information: it should contain the limit value and, optionally, the action to perform when that limit is reached. The actions you can specify are CANCEL, DUMP or WARNING. CANCEL and DUMP cause the job to abend at that point, WARNING issues a message but processing continues. If you give no action for LINES, PAGES, CARDS, and BYTES the system issues a warning and continues processing. If you give no action for OUTLIM the job is cancelled.

Environment Variable Value Range Example
ES_JES_LINES 0-99999999
ES_JES_LINES=(100,CANCEL)
Limit the number of lines output to 100000. When this limit is reached cancel the job.
ES_JES_PAGES 0-99999999
ES_JES_PAGES=10
Each page is assumed to hold 60 lines, therefore when 600 lines (60×10) have been processed issue a warning and carry on.
ES_JES_CARDS 0-99999999
ES_JES_CARDS=(30,WARNING)
Each card is assumed to hold 25 lines, therefore at 750 lines (25×30) issue a warning message and carry on.
ES_JES_BYTES 0-999999
ES_JES_BYTES=(100,DUMP)
Value for bytes is in thousands, each line is assumed to hold 132 bytes, therefore at 100000/132 lines the job will be cancelled.
ES_JES_OUTLIM 1-16777215
ES_JES_OUTLIM=5000
The job will be cancelled if any of the SYSOUT datasets reaches 5000 lines.
Parent topic: JCL development


Files and Data Sets

  • Catalog Files
    MSS uses a catalog file to hold information about the data sets needed for the JCL jobs that run in an enterprise server. You specify the name and location of the catalog file when you configure an enterprise server for JCL. If the file does not exist, MSS creates it when the first job starts executing.
  • Data Set Files
  • Spool Files
Parent topic: JCL Support


Catalog Files

The location and name of the catalog file is shown in the System Catalog field on the Server > Properties > MSS > JES page in ES Admin. You can change this field to use a different catalog file.

To maintain a connection with the mainframe environment, you can continue to use MVS data set names in JCL statements and TSO commands. However, these names have no meaning in a non-mainframe environment, so MSS also requires the name of the local file that represents the data set. Both names are included in the catalog entry.

Tip: Although you can share a catalog between servers if access to it is controlled by Fileshare, we recommend you do not do so.
Parent topic: Files and Data Sets


Data Set Files

This section contains basic information about using MSS with data sets. For further information on this subject, see the chapter Advanced Data Set Information.

All data sets that are referenced in JCL statements or TSO commands must have an entry in the catalog so that MSS can locate the local file that represents the data set. These data sets include:

  • Cataloged procedures referenced by EXEC statements
  • JCL procedures referenced by INCLUDE statements or TSO SUBMIT commands
  • Input and output data sets referenced in DD statements supported by MSS. See the section JCL Features in the chapter JCL Support for more information.
  • Input and output data sets referenced in TSO ALLOCATE, FREE and DELETE commands
  • REXX execs referenced by TSO EXEC commands
  • Partitioned data sets (libraries) that contain any of the above data sets

Entries in the catalog can be for cataloged or uncataloged data sets. On the mainframe data sets can be fully specified in JCL statements, such that a catalog entry is not needed in order for the operating system to locate them. In MSS, even uncataloged data sets must have entries in the catalog, because the information in the JCL relates to mainframe locations such as volume and serial number, which have no meaning in the Windows or UNIX environment. You can choose whether or not catalog entries for uncataloged data sets are visible when you view the catalog.

Data sets that are not referenced in JCL statements or TSO commands do not need entries in the catalog. For example, if you write a program that accesses a data file that exists only, that program should specify an actual physical filename in its SELECT clause in the Environment Division.

There are three methods of including an entry in the catalog:

  • New on the Catalog page in ESMAC

    Click New on the Catalog page in ESMAC. You need to specify both the MVS name and the local physical filename.

  • Through the allocation of a new data set (DISP=NEW or DISP=MOD for a new file) by means of a DD statement in a jobstream or an ALLOCATE command in REXX exec. MSS assigns the physical filename.
  • Dynamically, by MSS, if a data set is used which does not already have an entry. MSS assigns the physical filename.

When MSS assigns the physical filename, it uses the default data file path set on the Properties > JES page of ES Admin, followed by the mainframe name with the extension .dat, For example, if the default path for data files is c:\catalog\datasets then a file with an MVS name of MFE2004.S1217.S160553.J01013.D00006.SYSOUT, will be stored locally as C:\CATALOG\DATASETS\MFE2004.S1217.S160553.J01013.D00006.SYSOUT.DAT

Note: Default behavior is to allow new datasets to be cataloged without specifying a SPACE parameter. If you prefer that JCL missing the SPACE parameter fails in the same way it does on the mainframe, set the MF_NEWSPACE=Y environment variable.
  • Using Fileshare to Access Data Files
  • Partitioned Data Sets (PDSs)
Parent topic: Files and Data Sets
Related information
Advanced Data Set Information
JCL Features
Partitioned Data Sets (PDSs)


Using Fileshare to Access Data Files

You can share files on networks and multi-user systems using Fileshare. As you can connect up to sixteen Fileshare servers to your COBOL system, you can split your data across several machines.

There are three ways of configuring the use of Fileshare:

  • Specify explicit Fileshare server locations in the catalog
  • Specify explicit Fileshare server locations in SELECT clauses, for files that are not cataloged
  • Provide a Fileshare client configuration file that defines which files are located on Fileshare servers

You can use these methods in combination.

  • Specifying Fileshare Locations in the Catalog
  • Specifying Fileshare Locations in SELECT Clauses
  • Specifying Fileshare Locations in the Fileshare Client Configuration File
Parent topic: Data Set Files


Specifying Fileshare Locations in the Catalog

To specify that a file is located on a Fileshare server, give the full pathname of the file prefixed by $$servername in Physical File when you create a new catalog entry using New on the ESMAC Catalog page. Use the conventions appropriate to the server. For example, the file data01.dat on a UNIX server would require a pathname similar to:

$$unixserver/usr/accounts/data01.dat

while the same file located on a mainframe would require a pathname similar to:

$$MAINFRAME\FILES.ACCOUNTS.DATA01

Parent topic: Using Fileshare to Access Data Files


Specifying Fileshare Locations in SELECT Clauses

If you write programs that access files that are not cataloged, because they are not mainframe-style files, and you want to store these files on Fileshare servers, you can include the fileshare server name in the SELECT clause in the I-O-Section of the Environment Division, for example:

select datafile assign to "$$unixserver/usr/accounts/data01.dat".
Parent topic: Using Fileshare to Access Data Files


Specifying Fileshare Locations in the Fileshare Client Configuration File

The Fileshare client configuration file is called fhredir.cfg. If there is an fhredir.cfg file present, MSS consults it whenever it needs a file that has no explicit Fileshare server location specified in its catalog entry or SELECT clause. It does not consult it if an explicit Fileshare server location is specified.

If you want to specify a Fileshare location in the fhredir.cfg file for a cataloged file you must make sure you specify an explicit filename in Physical File that matches an entry in the fhredir.cfg file, rather than letting MSS allocate a name. Fileshare is case sensitive so filenames in the catalog and the fhredir.cfg file must use the same case.

You can either let the location of the fhredir.cfg file default to the current folder, or specify the location in the environment variable FHREDIR.

You must set the FHREDIR environment variable before you start the enterprise server.

For more information about setting FHREDIR and the use of Fileshare within Server Enterprise Edition see the section Fileshare in the chapter Configuration in your Configuration and Administration Guide

You can use entries in the fhredir.cfg file in a variety of ways. For example, you can

  • Simply name one or more Fileshare servers, and MSS will search those servers in the order they appear in the configuration file.
  • Specify full pathnames for every file located on a Fileshare server
  • Use wild cards in pathnames, for example, to indicate that all the files in a certain directory are held on a Fileshare server
  • Specify that certain files are actually located locally

For full details of all the options and examples see the chapters Standard Operation and Configuration in your Fileshare Guide.

Parent topic: Using Fileshare to Access Data Files
Related information
Fileshare
Standard Operation


Partitioned Data Sets (PDSs)

In an MVS mainframe environment, a file can be defined as an individual data set or as part of a partitioned data set (PDS). MSS supports both of these methods.

In a partitioned data set (organization = PO), the individual data sets are known as members (organization = PDSM). You define a partitioned data set and its members to MSS like any other data set.

  • Procedure Libraries
  • Dynamic PDSs
Parent topic: Data Set Files


Procedure Libraries

Procedure libraries are partitioned data sets that contain procedures that can be specified in JCL jobstreams. MSS searches for the JCL procedures executed via an EXEC statement in the following order:

  1. In-stream procedures.
  2. Libraries specified on a JCLLIB statement in the JCL.

    You must allocate these libraries to the catalog.

  3. The libraries that you specified when you enabled JCL Support, on the Server > Properties > JES page of ES Admin.
Parent topic: Partitioned Data Sets (PDSs)


Dynamic PDSs

In MSS, each member of a PDS is implemented as a separate physical PC file. By default, you have to create a separate catalog entry for each such member, giving the filename of the physical file. This is not practicable if a PDS has a great many members. You can avoid it by using a dynamic PDS.

To define a dynamic PDS you create just one catalog entry. On its Catalog Entry page in ESMAC, you set the DS Org field to PO and then put a check mark by Dynamic PDS. This enables the Physical Filename and PDS Exts fields. The value you enter in the Physical File field is assumed to be the name of an existing directory. The members of the PDS are implemented as individual physical files within this directory.

The Physical Filename field must end with a backslash ("\") on Windows or a forward slash ("/") on UNIX. As in any catalog entry, it must specify the full path. You can use the string "<CATALOGFOLDER>" to represent the directory where the catalog is stored.
Restriction: No other formats for the Physical Filename (for example paths containing an environment variable) are supported.

In the PDS Exts field you specify one or more filename extensions, separated by spaces. When a PDS member is created, the physical file is given a name consisting of the member's name as the basename, and the first entry in this field as the filename extension.

On UNIX, all member names used in a dynamic PDS must be upper case. Any file that uses a lower case member name will not be found.

Example

If you define a Catalog Entry with

Field | Value
DS Name | SOURCE.PDS
Physical File | <CATALOGFOLDER>\PAYROLL\
DS Org | PO
Dynamic PDS | checked
PDS Exts | CBL CPY

where the catalog folder is C:\CATALOG, and you then run the following JCL:

/FILE1	   DD DSN=SOURCE.PDS(PAYUPD),DISP=OLD
/FILE2	   DD DSN=SOURCE.PDS(PAYREP),DISP=OLD

(note DISP= OLD because SOURCE.PDS already exists), then this JCL creates physical files PAYUPD.CBL and PAYREP.CBL in directory C:\CATALOG\PAYROLL. It creates catalog entries for these individual PDS members (DSOrg = PDSM) automatically.

When a PDS member is being sought, the directory is searched for a file with the member's name plus each of the specified extensions in turn, and the first match is used. For example, if the directory contains PAYUPD.CBL, PAYUPD.CPY and PAYREP.CPY, then an attempt to access SOURCE.PDS(PAYUDP) will find PAYUPD.CBL. Because the search terminates once a match has been found, PAYUPD.CPY will never be found. An attempt to access SOURCE.PDS(PAYREP) will find PAYREP.CPY.

  • Creating a Dynamic PDS with JCL
Parent topic: Partitioned Data Sets (PDSs)


Creating a Dynamic PDS with JCL

You can create dynamic PDSs with JCL, by using the extension syntax illustrated in the following examples.

You must set the following variables in your JCL depending on whether the file is for data or source.
Variable | Value for a data PDS | Value for a source PDS
LRECL | Any number greater than zero | 0
RECFM | Either FB, V, VB, or F | LSEQ

Using a PDS for data files

//DD1      DD DSN='TEST.DYN1',DISP=(NEW,CATLG),
//            DCB=(RECFM=FB,LRECL=123,DSORG=PO)
//*MFE: %PCDSN=C:\DPDS\*.DAT

This will create TEST.DYN1 as a dynamic PDS whose members are files in the directory C:\DPDS with the extension .DAT.

Using a PDS for source files

//DD1      DD DSN='LORINCE.CTLLIB.PDS',DISP=(NEW,CATLG),
//            UNIT=SYSDA,SPACE=(CYL,(3,1,1)),
//            DCB=(RECFM=LSEQ,LRECL=0,DSORG=PO)
//*MFE: %PCDSN=C:\DCCPDS\*.TXT

This will create LORINCE.CTLLIB.PDS as a dynamic PDS that can be used for control cards or source for SORT, IDCAMS, REXX, JCL, and PROCs.

Deleting a Dynamic PDS

When you delete a dynamic PDS, this does not automatically delete the underlying PC files. To delete the underlying PC files, set the MF_DEL_DYNPDS environment variable to Y.

Parent topic: Dynamic PDSs


Spool Files

MSS emulates the spooler functions of the mainframe's job entry system. You can select emulation of VSE, JES2 or JES3.

MSS creates a spool file for each of the following:

  • Each job that is run. The spool file lists the jobstream and shows the results of each job step.
  • Each output data set that is directed to SYSOUT. The spool file shows the contents of the data set.

In MSS, a JCL jobstream can have only one job but the job can contain multiple job steps. You use an EXEC statement to specify the program to be executed by a job step. You can do this either directly:

EXEC PGM=program-name

or indirectly, using a cataloged procedure:

EXEC PROC=procedure-name ---------> EXEC PGM=program-name.

Although the Catalog page does not include spool files, they are assigned data set names.

If the data set name is not specified, the MVS name has the form:

MFEyyyy.Smmdd.Shhmmss.Jjjjjj.Dnnnnn.ddname

If the data set is temporary, the MVS name has the form:

MFEyyyy.Smmdd.Shhmmss.Jjjjjj.ANDAND.tempname

where:

  • yyyy is the year
  • mmdd is the month and day
  • hhmmss is the time
  • jjjjj is the job number
  • nnnnn is a number assigned by MSS. It indicates the order in which the data set was created by the job (00000 for the JOBLOG(JCL) file that shows the results of scanning or running a jobstream).
  • ddname is the DD name (for SYSOUT files only)
  • tempname is the temporary name, specified as &&tempname in the DD statement.
Parent topic: Files and Data Sets


Advanced Data Set Information

It covers the following subjects:
  • Data set organizations
  • Record formats
  • Logical record length
  • Mapping to local file formats
  • Dynamic PDS member lists
  • Support for mfextmap.dat and PROXMVS files
  • Support for Generation Data Groups
  • Data Set Organizations
  • Record Formats
  • Logical Record Length
  • Mapping to Physical File Formats
  • Support for Generation Data Groups
Parent topic: JCL Support
Related information
Files and Data Sets


Data Set Organizations

The data set organizations supported by MSS are shown in the following table.

Abbreviation | Organization | Comment
GDG | Generation data group |
IS | Indexed sequential |
ISU | Indexed sequential, unmoveable |
PDSM | Partitioned data set member | Micro Focus organization
PO | Partitioned |
POU | Partitioned, unmoveable |
PS | Physical sequential |
PSU | Physical sequential, unmoveable |
VSAM | Virtual storage access method |
Note: Although the direct access (DA) organization is not supported explicitly, you can emulate it by using the VSAM organization and relative record (RR) record format.
Parent topic: Advanced Data Set Information


Record Formats

The following table shows the record formats for all the data set organizations except VSAM.

Abbreviation | Format | Control Characters | Record Delimiters | Comment
F | Fixed | None | None |
FA | Fixed | ANSI | None |
FB | Fixed blocked | None | None | Same as F format
FBA | Fixed blocked | ANSI | None | Same as FA format
FBM | Fixed blocked | Machine | None | Same as FM format
FBS | Fixed blocked spanned | None | None | Same as F format
FM | Fixed | Machine | None |
FS | Fixed spanned | None | None | Same as F format
LSEQ | Line sequential | None | Carriage return/line feed |
U | Undefined |  |  | Results unpredictable on Windows or UNIX
V | Variable | None | Micro Focus type |
VA | Variable | ANSI | Micro Focus type |
VB | Variable blocked | None | Micro Focus type | Same as V format
VBA | Variable blocked | ANSI | Micro Focus type | Same as VA format
VBM | Variable blocked | Machine | Micro Focus type | Same as VM format
VBS | Variable blocked spanned | None | Micro Focus type | Same as V format
VM | Variable | Machine | Micro Focus type |
VS | Variable spanned | None | Micro Focus type | Same as V format
Note: Blocked and spanned record formats are accepted by MSS but have no meaning in a PC or UNIX environment.

The following table shows the record formats for VSAM files.

Abbreviation | Format | Control Characters | Comment
ES | Entry sequence | None |
KS | Key sequence | None |
LS | Linear sequence | None | Not supported
RR | Relative record | None |

Notes:

  • A cataloged VSAM file has two extra properties, LRECL Avg (average record length) and LRECL Max (maximum record length). If these two properties have the same value, MSS assumes that the file has fixed length records and does not use record delimiters to separate the records on Windows or UNIX.. If they have different values, MSS assumes that the record has variable length records and uses the Micro Focus type delimiters to separate records on Windows or UNIX.
  • If you have a program compiled to use EBCDIC, but that program reads a file with a RECFM of LSEQ and a character set of ASCII, the file's data is automatically converted to EBCDIC as part of the read. This automatic conversion is useful when reading files that do not contain hexadecimal data, such as control cards.
  • You allocate VSAM data sets to the MSS catalog using New on the ESMAC catalog page, or by submitting a batch job to define the file using IDCAMS.
  • If your application uses record-level locking on shared VSAM files, you might find that files larger than 1 GB (gigabyte) cannot be accessed. This is because the default record locking mechanism in MSS uses the top two bits of the file address for locking and compression bits, thus reducing the address space for the maximum offset from 4 GB to 1 GB for a shared idxformat 3 or 4 file. If you encounter this problem, set the LOCKTYPE Compiler directive to 2 when you compile the program affected. With this setting, the file handling mechanism creates a separate file for storing record locks, with the same basename as the file and a .lck extension.
Parent topic: Advanced Data Set Information


Logical Record Length

MSS works with logical record lengths as defined in the following table:

Record Format | Logical Record Length
Fixed | Actual record length
Variable | Actual record length + 4
LSEQ | Maximum record length

Note: If you have a program compiled to use EBCDIC, but that program reads a file with a RECFM of LSEQ, LRECL of 0 and a character set of ASCII, MSS automatically converts the file's data to EBCDIC as part of the read. This automatic conversion is useful when reading files such as control cards, that do not contain hexadecimal data.

Parent topic: Advanced Data Set Information


Mapping to Physical File Formats

MSS writes data sets to physical files on the PC and UNIX using the following organization and record format mapping:

Mainframe |  | Physical File
Data Set Organization | Record Format | File Organization | Record Format | Comment
DA, DAU, PS, PSU | Any fixed (Fnn) or variable (Vnn) format | Sequential | Micro Focus |
DA, DAU, PS, PSU | LSEQ | Line sequential | Micro Focus | Always uses ANSI character set. Can only be edited with a text editor
GDG |  |  |  | Catalog entry only
IS, ISU | Any fixed (Fnn) or variable (Vnn) format | Indexed sequential | Micro Focus |
PDSM | Any fixed (Fnn) or variable (Vnn) format | Sequential | Micro Focus |
PDSM | LSEQ | Line sequential | Micro Focus |
PO, POU |  |  |  | Catalog entry only
VSAM | ES | Sequential | ESDS |
VSAM | ES | Indexed sequential | ESDS | Alternate index defined
VSAM | KS | Indexed sequential | Micro Focus |
VSAM | LS | Not supported |  |
VSAM | RR | Relative | Micro Focus |
Parent topic: Advanced Data Set Information


Support for Generation Data Groups

A generation data group (GDG) consists of two parts: a GDG model and a series of physical sequential (PS) data sets, called biases (also known as generation data sets) that are associated with the GDG.

  • Creating Generation Data Groups
  • Generation Data Group Restrictions
Parent topic: Advanced Data Set Information


Creating Generation Data Groups

There are two main ways to set up a GDG:

  • By clicking Add on the ESMAC Catalog page. To define the model, specify the data set organization DSORG as "GDG". To define a bias, specify the DSORG as "PS" and provide the fully-qualified data set name. For example, if the model has the data set name MAG.TEST, the first bias might be named MAG.TEST.G0001V00, the second MAG.TEST.G0002V00, and so on (gaps in the numbering sequence are allowed).
  • By running an MFJAMS job that defines the GDG model and biases.

The following example illustrates a job that can be used to create a generation data group. STEP00 creates the GDG model and STEP01 creates five new GDG biases.

//MFIDMFGD JOB 'MFIDMFGD',CLASS=A,MSGCLASS=A,NOTIFY=MFIDF
//STEP00 EXEC PGM=IDCAMS
//SYSOUT DD SYSOUT=*
//SYSPRINT DD SYSOUT=*
//AMSDUMP DD SYSOUT=*
//SYSIN DD *
DELETE MFIDMF.TEST.GDG
DEFINE GENERATIONDATAGROUP(NAME(MFIDMF.TEST.GDG)
       EMPTY NOSCRATCH LIMIT(96))/*
//STEP01 EXEC PGM=IEFBR14
//SYSUXX DD DSN=MFIDMF.TEST.GDG(+1),DISP=(NEW,CATLG),SPACE=(TRK,(5,2))
//SYSUXY DD DSN=MFIDMF.TEST.GDG(+2),DISP=(NEW,CATLG),SPACE=(TRK,(5,2))
//SYSUXZ DD DSN=MFIDMF.TEST.GDG(+3),DISP=(NEW,CATLG),SPACE=(TRK,(5,2))
//SYSUXA DD DSN=MFIDMF.TEST.GDG(+4),DISP=(NEW,CATLG),SPACE=(TRK,(5,2))
//SYSUXB DD DSN=MFIDMF.TEST.GDG(+5),DISP=(NEW,CATLG),SPACE=(TRK,(5,2))

Five biases named MFIDMF.TEST.GDG.G0001V00, MFIDMF.TEST.GDG.G0002V00, MFIDMF.TEST.GDG.G0003V00, MFIDMF.TEST.GDG.G0004V00 and MFIDMF.TEST.GDG.G0005V00 are created by STEP01.

A bias can be processed by its relative number, its actual reference or as a part of the entire generation data group. For example, each of the following statements could be executed after running the previous job.

//SYSUT1 DD DSN=MFIDMF.TEST.GDG,DISP=SHR

This would cause the entire generation data group MFIDMF.TEST.GDG, consisting of a set of concatenated data sets MFIDMF.TEST.GDG.G0001V00 through MFIDMF.TEST.GDG.G0005V00, to be referenced.

//SYSUT1 DD DSN=MFIDMF.TEST.GDG(0),DISP=SHR

The relative number 0 would cause the data set named MFIDMF.TEST.GDG.G0005V00 to be referenced.

//SYSUT1 DD DSN=MFIDMF.TEST.GDG(-1),DISP=SHR

The relative number -1 would cause the data set named MFIDMF.TEST.GDG.G0004V00 to be referenced.

//SYSUT1 DD DSN=MFIDMF.TEST.GDG(+1),DISP=SHR

The relative number +1 would cause a new data set named MFIDMF.TEST.GDG.G0006V00 to be referenced.

//SYSUT1 DD DSN=MFIDMF.TEST.GDG.G0003V00,DISP=SHR

The actual reference G0003V00 would cause the data set named MFIDMF.TEST.GDG.G0003V00 to be referenced.

The increment of numbers occurs per job, so if you had two consecutive steps that referenced +1, then each step would be using the same data set.

Parent topic: Support for Generation Data Groups


Generation Data Group Restrictions

This section describes restrictions when using GDGs in MSS:

  • The maximum number of host GDG biases that you can reference is 255.
  • MSS does not support versioning of the GDG biases, so the only biases that versioning works for are those with a data set name ending with V00. For example, if the GDG model name is MFIDMF.TEST.GDG then the GDG biases must have the form MFIDMF.TEST.GDG.G0001V00 ... MFIDMF.TEST.G9999V00, with gaps in the numbering sequence. If you attempt to use a bias that ends, for example, in V01, it will not be found when GDG names are resolved during program execution.
  • A GDG model and all of its generation data sets (GDSs) must reside on the same platform. It is not possible to have a mixture of GDSs where some reside on the mainframe and others locally.
  • If you are using relative bias numbers to reference GDSs in your JCL, for example MFIDMF.TEST.GDG(-4) or MFIDMF.TEST.GDG(+1), the following restrictions apply:
    • If the GDSs are located on a Mainframe Access server, you cannot reference any numbers greater than zero. The only permitted numbers are 0 through -n, where n is the maximum number of GDSs supported by the GDG model.
    • If the GDSs are located on a PC or network, all processing is supported with only the limitations that are already documented in this section.
Parent topic: Support for Generation Data Groups


Utility Programs

There are two types of utility program:

  • Mainframe emulation utilities
  • Micro Focus utilities

This chapter also describes how, if required, you can write your own utility program; see the section Writing Your Own Utility Programs for details.

  • Emulations of Mainframe Utilities
  • Micro Focus Utilities
    This section describes the Micro Focus utility, MFJMATCH.
  • Writing Your Own Utility Programs
Parent topic: JCL Support
Related information
Mainframe emulation utilities
Micro Focus utilities
Writing Your Own Utility Programs


Emulations of Mainframe Utilities

This section describes the mainframe emulation utilities. You can invoke these utilities in a JCL jobstream or REXX exec by using the same program names, data sets and commands as on the mainframe. The mainframe utilities emulated by MSS are:

  • DFSORT and SORT, to perform sort/merge operations
  • DSNTEP2, to execute any SQL statement that can be executed dynamically
  • IDCAMS, to manage VSAM data sets
  • IEBCOMPR, to compare two sequential or partitioned data sets
  • IEBCOPY, to copy or merge partitioned data sets
  • IEBGENER, to copy sequential data sets
  • ICEGENER, like IEBGENER but with VSAM capabilities
  • IEBUPDTE, to create or modify sequential or partitioned data sets
  • IEFBR14, to provide a dummy program facility by simply returning to the caller
  • IKJEFT01, to submit TSO commands in batch mode (also IKJEFT1A and IKJEFT1B)
  • IRXJCL, to run a REXX exec in MVS batch mode
  • IEBDG, to create test data

These names are defined as aliases for the equivalent MSS utility.

This section describes the special considerations that apply when you use these utilities in a MSS environment. It does not include information on behavior that is the same in mainframe and MSS environments. For full information on the mainframe utilities referred to in this section, see the relevant IBM documentation.

Note:

If you wish to debug programs invoked by IKJEFT01, you must specify its equivalent MSS utility, IDAEFT01, as the program to debug.

  • Sort/Merge Operations (MFJSORT)
  • Executing Dynamic SQL statements (MFDSNTEP)
  • Unloading XDB Database Table Rows (MFDB2UNL)
  • Loading XDB Database Table Rows (MFDB2LOA)
  • VSAM Access Method Services (MFJAMS)
    MFJAMS emulates the main functions of the IDCAMS mainframe utility.
  • Comparing Data Sets (MFJMATCH - IEBCOMPR)
  • Copying and Merging Partitioned Data Sets (MFJCOPY)
    MFJCOPY emulates the operation of the IEBCOPY mainframe utility for copying and merging partitioned data sets.
  • Copying Sequential Data Sets (MFJGENER and ICEGENER)
  • Creating or Modifying Data Sets (MFJUPDTE)
    MFJUPDTE emulates the IEBUPDTE mainframe utility for creating or modifying sequential or partitioned data sets.
  • Dummy Program (MFJBR14)
    MFJBR14 emulates the IEFBR14 mainframe utility. It provides a dummy program facility by simply returning to the caller.
  • Executing TSO Commands in Batch Mode (IDAEFT01)
  • Running REXX Execs in MVS Batch Mode (MFIRXJCL)
    MFIRXJCL emulates the IRXJCL mainframe utility program.
  • TSO Support in Server Enterprise Edition
    Describes use of TSO commands in Server Enterprise Edition using the ISAEDT01 utility.
  • Generating Test Data (MFJDG)
    MFJDG emulates the IEBDG mainframe utility for creating test data.
Parent topic: Utility Programs


Sort/Merge Operations (MFJSORT)

Note: MFJSORT and MFSORT are updated with new features on a regular basis but they do not offer a complete emulation of third-party sort utilities. If there are particular features that you need to use, please contact SupportLine to establish if they are available in MFJSORT or MFSORT.

MFJSORT provides the following sort/merge operations for sequential data sets:

  • Sorting data sets by ascending or descending keys
  • Merging data sets by ascending or descending keys
  • Copying data sets
  • Selecting the records to be processed
  • Rearranging the fields in the records
  • Correctly processing two-digit year fields
  • Transforming two-digit year fields to four-digit fields
  • Summing numeric fields in records with duplicate keys
  • Creating multiple output data sets
  • Using an alternate collating sequence
  • Executing E15 and E35 exit programs.
  • JCL Statements
    This section describes the JCL statements used with the MFJSORT utility.
Parent topic: Emulations of Mainframe Utilities


JCL Statements

  • EXEC Statement
  • DD Statements
  • Program Control Statements
  • Exits
    MFJSORT, like its mainframe counterpart, invokes user exit programs for the E15 read exit and the E35 write exit.
  • SYNCSORT Emulation
Parent topic: Sort/Merge Operations (MFJSORT)


EXEC Statement

In the EXEC statement you need to specify the program named MFJSORT or its alias DFSORT or SORT. For example:

//STEPEXEC PGM=DFSORT,......
Parent topic: JCL Statements


DD Statements

The following DD statements are required for all uses of MFJSORT:

SYSIN
For the data set that contains the program control statements. It can be an in-stream data set.
SYSPRINT
For the output listing data set. It must have an LRECL value of at least 132.
SORTIN
For the input data sets. You can concatenate up to 16 data sets for SORTIN. It is not required if you use SORTIN nn
SORTOUT
For the output data set. It is not required if you use SORTOF nn.

The following DD statements are optional:

SORTINnn
For multiple input data sets. nn begins with 01 and increases by 1 up to a maximum of 16. SORTIN nn and SORTIN are mutually exclusive.
SORTOF nn
For multiple output data sets. nn begins with 01 and increases by 1 up to a maximum of 16. SORTOF nn is used by the OUTFIL statement.
Parent topic: JCL Statements


Program Control Statements

The program control statements supported by MFJSORT are listed below. The rules for coding the statements are identical to the mainframe utility.

Note:

MFJSORT emulates all major functions of IBM's DFSORT product.

Program Control Statements

ALTSEQ
Specifies an alternate collating sequence for AQ control fields.
END
Indicates the end of the program control statements. If omitted, MFJSORT reads to end of file.
INCLUDE
Includes records from the input data set based on comparison testing of one or more fields in the input record. Supports substring comparison and bit logic (bit operator and bit comparison) tests. You can specify up to 16 conditional expressions.
INREC
Rearranges input records before sorting or merging. Note that INREC may change the location of the control fields used by SORT, MERGE, OUTFIL, OUTREC and SUM statements.
MERGE
Defines a merge operation. You can include a COPY request in the MERGE statement. You can select portions of the input data sets for merging. You can define up to 32 control fields, but the total length of the control fields must not exceed 1,024 bytes. You can request ascending or descending sequences for the following control field types:
AQ
Alternate collating sequence.
BI
Binary.
CH
Character.
CLO
Signed numeric with leading overpunched sign.
CTO
Signed numeric with trailing overpunched sign.
CSF
Signed numeric with optional leading floating sign.
CSL
Signed numeric with leading separate sign.
CST
Signed numeric with trailing separate sign.
FI
Fixed integer.
FL
Floating point. Only 4-byte and 8-byte forms are supported. (COMP-1 and COMP-2).
FS
Signed numeric with optional leading floating sign.
LS
Signed numeric with leading separate sign.
OL
Signed numeric with leading overpunched sign.
OT
Signed numeric with trailing overpunched sign.
PD
Packed decimal.
PD0
Packed decimal, with sign and first digit ignored.
TS
Signed numeric with trailing separate sign.
Y2B
Two-digit, one-byte binary year data.
Y2C
Two-digit, two-byte character or zoned decimal year data.
Y2D
Two-digit, one-byte decimal year data.
Y2P
Two-digit, two-byte packed decimal year data.
Y2S
Two-digit, two-byte character or zoned decimal year data, with special indicators.
Y2Z
Two-digit, two-byte character or zoned decimal year data.
ZD
Zoned decimal.
MODS
Specifies the names of the E15 and E35 exit programs. Other exits are not supported.
OMIT
Excludes records from the input data set based on comparison testing of one or more fields in the input record. Supports substring comparison and bit logic (bit operator and bit comparison) tests. You can specify up to 16 conditional expressions.
OUTFIL
Writes multiple output files. OUTFIL allows for extensions.
  • Use the INCLUDE, OMIT and SAVE operands to select the records to be included in each output data set. The INCLUDE and OMIT operands provide all of the capabilities of the INCLUDE and OMIT statements, while SAVE can be used to select the records that are not selected for any other subset.
  • The OUTREC operand provides editing and control of the way numeric fields are presented with respect to length, leading or suppressed zeros, symbols, and so on. Twenty six pre-defined editing masks (M0 to M25) are available, and user-defined masks can be created using, for example, the EDIT, SIGNS and LENGTH options. Use the CHANGE option to select a character or hexadecimal string for output from a lookup table, based on a character, hexadecimal or bit string as input.
  • Use the STARTRECand ENDREC operands to select a range of records to be included in each output data set.
  • Use the SPLIT operand to distribute the records evenly among the output data sets.
  • Use the operands LINES, HEADER1, TRAILER1, HEADER2, TRAILER2, SECTIONS and NODETAIL, together with OUTREC, to create complex reports including, for example, totals, maximums, minimums and averages for numeric input fields.
OUTREC
Rearranges output records after sorting or merging. It can also insert literal variables into the output record. Supports reformatting of records as well as the creation of formatted reports.
RECORD
Specifies record length information. Only the first value of this statement, which specifies the maximum record length, is used; all other values are ignored. The logical record length of the input data set overrides any value specified by the RECORD statement.
SORT
Defines a sort operation. You can include a COPY request in the SORT statement. You can define up to 32 control fields, but the total length of the control fields must not exceed 1,024 bytes. You can request ascending or descending sequences for the same control field types as described for the MERGE statement.
SUM
Produces only one output record for records with duplicate sort fields. Optionally, numeric fields in the duplicate records can be summed in the output record. The sum operation can be done for the following control field types:
AQ
Alternate collating sequence.
BI
Binary.
FI
Fixed integer.
FL
Floating point. Only 4-byte and 8-byte forms are supported. (COMP-1 and COMP-2).
FS
Signed numeric with optional leading floating sign.
PD
Packed decimal.
ZD
Zoned decimal.

OVFLO Parameter

The OVFLO parameter gives you control over the the action (continue or terminate), type of message (informational or error), and return code (0 or 16) that can be set during summary overflow. For example:
OPTION OVFLO=-----RC0-----
                      -----RC16-----
  • RC0 - When summary fields overflow: issues overflow message, sets the return code to 0, and continues processing. RC0 is the default value for the OVFLO parameter.
  • RC16 - When summary fields overflow: issues overflow message, terminates processing, and gives a return code of 16.
Parent topic: JCL Statements


Exits

The exit programs should be written in COBOL and compiled by the Micro Focus syntax checker. They can be executed normally or debugged like any other COBOL program. Please refer to the mainframe documentation for instructions on writing and testing exit programs.

Linkage Area

MFJSORT provides a standard linkage area to the E15 and E35 exit program. It is compatible with the mainframe utility and should be defined as follows:
COBOL Statements Value
RECORD-FLAGS PIC 9(8) COMP.
 0 indicates the first record passed. 4 indicates subsequent records passed. 8 indicates the last record passed.
ENTRY-BUFFER PIC X(n).
 Contents of the input record. Do not change this area.
EXIT-BUFFER PIC X(n).
 Contents of the new or altered record provided by the exit.
UNUSED-ENTRY PIC 9(8) COMP.
 Not used
UNUSED-ENTRY PIC 9(8) COMP.
 Not used
ENTRY-RECORD-LENGTH PIC 9(8) COMP.
 Length of the input record.
EXIT-RECORD-LENGTH PIC 9(8) COMP.
 Length of the new or altered record provided by the exit.
UNUSED-ENTRY PIC 9(8) COMP.
 Not used
EXIT-AREA-LENGTH PIC 9(4) COMP.
 Length of the exit area scratchpad. Do not change this field.
EXIT-AREA PIC X(n).
 Exit area scratchpad used by the exit to maintain variables between calls to the exit program.

Return Codes

MFJSORT recognizes the same return codes from exit programs as the mainframe utility, as listed in the following table:
Return Code | Meaning
0 | No action required.
4 | Delete the current record. For E15, the record is not sorted. For E35, the record is not written to the output data set.
8 | Do not call this exit again; exit processing is no longer required.
12 | Insert the current record. For E15, the record is inserted for sorting. For E35, the record is written to the output data set.
16 | Terminate MFJSORT. The job step is terminated with the condition code set to 16.
20 | Alter the current record. For E15, the altered record is passed to the sort. For E35, the altered record is written to the output data set.
Parent topic: JCL Statements


SYNCSORT Emulation

MSS also provides limited emulation of SYNCSORT behavior. The behavior for SYNCSORT emulation is essentially the same as for DFSORT emulation, with the following exceptions:

  • SYNCSORT allows bracketed parameters to immediately follow a keyword without an equals sign (=) to separate them.
  • When using SYNCSORT, the OUTREC statement can optionally take the CONVERT option after the FIELDS option.

To specify that you want to use SYNCSORT, set the environment variable MFJSENGINE=SYNCSORT in Configuration Information on the Server > Properties > General page for the enterprise server you are using

Parent topic: JCL Statements


Executing Dynamic SQL statements (MFDSNTEP)

MFDSNTEP emulates the functions of the DSNTEP2 utility for executing dynamic SQL statements.

Note: You can only use this utility with XDB databases.
  • JCL Statements
Parent topic: Emulations of Mainframe Utilities


JCL Statements

This section describes the JCL statements used with the MFDSNTEP utility

In the EXEC statement you need to specify the program name MFDSNTEP or its alias DSNTEP2. For example:

//STEPEXEC DSNTEP2, ...
  • DD Statements
Parent topic: Executing Dynamic SQL statements (MFDSNTEP)


DD Statements

The DD statements required by MFDSNTEP are the same as for DSNTEP2; see the relevant IBM documentation for details.

Parent topic: JCL Statements


Unloading XDB Database Table Rows (MFDB2UNL)

MFDB2UNL emulates the functions of the DSNTIAUL utility for unloading rows from XDB tables.

This utility unloads some or all rows from up to 100 XDB tables. You can unload data of any XDB built-in data type or distinct type. You can unload up to 32KB of data from a LOB column. MFDB2UNL unloads the rows in a form that is compatible with the LOAD utility and generates utility control statements for LOAD. You can also execute any SQL non-SELECT statement that can be executed dynamically.

Note: You can only use this utility with XDB databases.
  • JCL Statements
Parent topic: Emulations of Mainframe Utilities


JCL Statements

This section describes the JCL statements used with the MFDB2UNL utility

In the EXEC statement you need to specify the program name MFDB2UNL or its alias DSNTIAUL. For example:

//STEPEXEC DSNTIAUL, ...
  • DD Statements
Parent topic: Unloading XDB Database Table Rows (MFDB2UNL)


DD Statements

The DD statements required by MFDB2UNL are the same as for DSNTIAUL; see the relevant IBM documentation for details.

Parent topic: JCL Statements


Loading XDB Database Table Rows (MFDB2LOA)

MFDB2LOA emulates the functions of the DSNUTILB utility for loading rows into XDB tables.

Note: You can only use this utility with XDB databases.
  • JCL Statements
    This section describes the JCL statements used with the MFDB2LOA utility.
Parent topic: Emulations of Mainframe Utilities


JCL Statements

In the EXEC statement you need to specify the program name MFDB2LOA or its alias DSNUTILB. For example:

//STEPEXEC DSNUTILB, ...

The PARM parameters are the same as for DSNUTILB; however, MFDB2LOA provides the following additional parameter:

FBD
Checks for x'00' in columns defined as CHAR, VARCHAR, or LONGVARCHAR; if found, the table column definition is changed to enable FOR BIT DATA.

For example:

//UTILSAMP EXEC PGM=DSNUTILB,REGION=1024K,
//             PARM='DB5B,MFIMAG,,FBD'
  • DD Statements
    The DD statements required by MFDB2LOA are the same as for DSNUTILB.
Parent topic: Loading XDB Database Table Rows (MFDB2LOA)


DD Statements

See the relevant IBM documentation for details.

Parent topic: JCL Statements


VSAM Access Method Services (MFJAMS)

It provides the following management services for VSAM key-sequenced data sets (KSDS), entry-sequenced data sets (ESDS) and relative-record data sets (RRDS).

  • ALTER, to change the attributes of a VSAM data set
  • DEFINE ALTERNATEINDEX, to define alternate indices for a VSAM data set
  • DEFINE CLUSTER, to define a new VSAM data set
  • DEFINE PATH, to support path data sets
  • DELETE, to delete data sets
  • LISTCAT, to list catalog entries
  • PRINT, to print a data set
  • REPRO, to copy a data set
  • SET, to change the condition code
  • VERIFY, to verify a VSAM data set

You can use some of these services for sequential data sets, partitioned data sets and generation data groups. All abbreviations of these commands and their parameters that are valid on the mainframe are supported by MFJAMS.

You can execute MFJAMS via a JCL jobstream or REXX exec.

For more information on VSAM access method services, see the IBM manual DFSMS/MVS Access Method Services for VSAM, SC26-4905.

  • Working with Empty Data Sets
  • File Structure
  • JCL Statements
    This section describes the JCL statements used with the MFJAMS utility.
  • Commands
    This section describes the MFJAMS commands.
Parent topic: Emulations of Mainframe Utilities


Working with Empty Data Sets

In previous versions of this software an empty VSAM data set, for example a data set that had just been defined, did not show as being empty. As a result, some of the IDCAMS commands that MFJAMS emulates, for example REPRO and PRINT, processed zero records and generated a condition code of 0.

This behavior differs from the corresponding mainframe IDCAMS utility for newly-defined VSAM data sets which generates I/O errors with a condition code of 12.

The behavior of MFJAMS is now consistent with that of IDCAMS.

Note:

Empty VSAM data sets created by previous versions of this software still generate a condition code of 0 in such cases. To ensure that these data sets are handled in a manner that is consistent with IDCAMS behavior you must delete and then redefine them.

Parent topic: VSAM Access Method Services (MFJAMS)


File Structure

Unlike the mainframe, a VSAM KSDS or ESDS data set is usually represented under Windows or UNIX by two files - a data file, which contains the actual data records for the VSAM data set, and an index file, which contains the primary and alternate key data. These files usually have filename extensions of .dat and .idx respectively. The exception is where IDXFORMAT8 files are in use; these have just a .dat file.

Although the two-file structure affects the way that IDCAMS commands are processed, it does not change the final outcome of the commands. The results of executing commands in a non-mainframe environment is the same as on the mainframe. MFJAMS ignores those parts of a command that have no relevance in a non-mainframe environment. For example, because the VSAM file structure under Windows or UNIX does not provide CI or CA sizes to manipulate, these command parameters are ignored.

Parent topic: VSAM Access Method Services (MFJAMS)


JCL Statements

  • EXEC Statement
  • DD Statements
Parent topic: VSAM Access Method Services (MFJAMS)


EXEC Statement

In the EXEC statement you need to specify the program name MFJAMS or its alias IDCAMS. For example:

//STEPEXEC PGM=IDCAMS,.......
Parent topic: JCL Statements


DD Statements

The following DD statements are required for all uses of MFJAMS:

SYSIN
For the data set that contains the input commands. It can be an in-stream data set
SYSPRINT
For the output listing data set. It must have an LRECL value of at least 121.

The following DD statements are used by some commands:

  • For the data sets that are used for input to the PRINT, REPRO and VERIFY commands. The DD statement can have any valid dd-name, such as INFILE.
  • For the data sets that are used for output from the PRINT and REPRO commands. The DD statement can have any valid dd-name, such as OUTFILE.
Parent topic: JCL Statements


Commands

  • ALTER
    The ALTER command changes the attributes of an MVS data set.
  • DEFINE ALTERNATEINDEX
    The DEFINE ALTERNATEINDEX command creates an alternate index for an existing VSAM data set. It also automatically reindexes the data set to maintain consistency between the data and index files on the PC. The alternate index is contained within the same file as the primary index.
  • DEFINE CLUSTER
    The DEFINE CLUSTER command creates a new VSAM data set. It creates the data and index files on the local machine and catalogs the data set name.
  • DEFINE PATH
    The DEFINE PATH command causes MFJAMS to create a dummy path data set so that any DD statement that refers to the data set will not fail. The data set is not needed for any other purpose because MFJAMS implements this function in a different way to the mainframe.
  • DELETE
    The DELETE command deletes up to 99 data sets. It can be used for both VSAM and non-VSAM data sets. It deletes the local files associated with the data set and removes the entry from the catalog.
  • LISTCAT
    The LISTCAT command lists the data set names contained in the catalog.
  • PRINT
    The PRINT command prints the contents of both VSAM and non-VSAM data sets. It prints a complete data set or part of a data set in character format, hexadecimal format or both formats.
  • REPRO
    The REPRO command copies the contents of one data set to another. The data sets can have either VSAM or sequential organization.
  • SET
    The SET command alters a condition code set by previous MFJAMS commands in this job step.
  • VERIFY
    The VERIFY command attempts to open a VSAM data set in order to verify that it can be read and that the index is usable. The data set is assumed to be readable if it can be opened without error or if it is locked to another process.
Parent topic: VSAM Access Method Services (MFJAMS)


ALTER

Parameters:

MFJAMS uses the parameters described in the following table. All other parameters are ignored.

data-set-name
Name of the data set to be renamed. This parameter is required.
NEWNAME(data-set-name)
The new name for the data set. This parameter is required.

Comments:

You cannot use * as a qualifier to rename a number of data sets with one command. For example, ABC.*.FILE is not permitted.

Parent topic: Commands


DEFINE ALTERNATEINDEX

Parameters:

MFJAMS uses the parameters described in the following table. All other parameters are ignored.

NAME(data-set-name)
Name of the data set. This parameter is required.
KEYS(length offset)
Length and offset, relative to 0, of the alternate key field. The offset must be within the first 4,096 bytes of the record. Length plus offset must not exceed the maximum length of the record. The default is KEYS(64 0).
UNIQUEKEY
Each alternate key value in the records is unique.
NONUNIQUEKEY
The alternate key values may contain duplicates.
RELATE(data-set-name)
Name of a cataloged VSAM data set to which the alternate index is to be related.

Comments:

  • UNIQUEKEY and NONUNIQUEKEY are mutually exclusive. NONUNIQUEKEY is the default.
  • Because MFJAMS automatically reindexes the data set, the BLDINDEX parameter is assumed even if it is not specified.
  • You can create up to seven alternate indices in one invocation of MFJAMS. Enter separate commands for each index. MFJAMS performs a single reindexing operation for all the alternate indices.
  • MFJAMS does not support the Micro Focus split-key and key-compression features. MSS cannot open a VSAM data set that uses either of these features.
Parent topic: Commands


DEFINE CLUSTER

Parameters:

MFJAMS uses the parameters described in the following table. All other parameters are ignored.

NAME(data-set-name)
Name of the VSAM data set. This parameter is required.
INDEXED
That a KSDS data set is being defined.
NONINDEXED
That an ESDS data set is being defined.
NUMBERED
That an RRDS data set is being defined.
KEYS(lengthoffset)
Length and offset, relative to 0, of the primary key field for a KSDS data set. The offset must be within the first 4096 bytes of the record. length plus offset must not exceed the maximum length of the record. The default is KEYS(64 0).
RECORDSIZE(averagemaximum)
Average and maximum lengths of the records, expressed in decimal format. If the lengths are the same, a fixed-length format is assumed. If the lengths are different, a variable-length format is assumed. The default is RECORDSIZE(4089 4089).
MODEL(data-set-name)
Name of a cataloged VSAM data set that has the same KEYS and RECORDSIZE parameters as this new data set. It is an alternative to specifying the parameters explicitly.

Comments:

  • INDEXED, NONINDEXED and NUMBERED are mutually exclusive. INDEXED is the default.
  • MFJAMS does not allow duplicate entries of the primary key.
  • KEYS and RECORDSIZE override the values obtained from MODEL.
  • MFJAMS does not support the Micro Focus split-key and key-compression features. MSS cannot open a VSAM data set that uses either of these features.

Example:

Here is a typical job to define a cluster:

//DEFCLUS  JOB  CLASS=A
//IDCSTEP  EXEC PGM=IDCAMS
//SYSPRINT DD   SYSOUT=*
//SYSIN    DD   *
DEFINE CLUSTER(NAME(TEST.KSDS.DUMMY) KEYS(5,0) -
       RECORDSIZE(80,80))

Note the use of the continuation character (-) in the DEFINE CLUSTER statement.

Parent topic: Commands


DEFINE PATH

Parameters:

MFJAMS uses the parameters described in the following LIST. All other parameters are ignored.

NAME(data-set-name)
Name of the path data set. This parameter is required.
Parent topic: Commands


DELETE

Parameters:

MFJAMS uses the parameters described in the following list. All other parameters are ignored.

data-set-names
Names of the data sets to be deleted. This parameter is required. You can specify a list of names separated by blanks and enclosed in parentheses. You can also specify generic names by using '*' as a qualifier. For example, a generic data set name of ABC.*.FILE means all data sets with ABC as the first qualifier, any value as the second qualifier, and FILE as the third and last qualifier.
FORCE
All GDG data sets will be deleted in addition to the GDG catalog entry.
NOFORCE
The GDG catalog entry will not be deleted if any GDG data sets exist.

Comments:

FORCE and NOFORCE are mutually exclusive. NOFORCE is the default.

Parent topic: Commands


LISTCAT

Parameters:

MFJAMS uses the parameters described in the following table. All other parameters are ignored.

ENTRIES(data-set-names)
Names of the data sets to be listed. You can specify a list of names separated by blanks. You can also specify generic names by using '*' as a qualifier. For example, a generic data set name of ABC.*.FILE means all data sets with ABC as the first qualifier, any value as the second qualifier and FILE as the third and last qualifier.
LEVEL(level)
Prefix qualifier of the data sets to be listed. For example, a level of ABC means all data sets with ABC as the first, high-level, qualifier.

Comments:

ENTRIES and LEVEL are mutually exclusive; you can specify only one of them. LEVEL(*) is the default if neither is specified.

Parent topic: Commands


PRINT

Parameters:

MFJAMS uses the parameters described in the following table. All other parameters are ignored.

INFILE(ddname)
Name of the DD statement, contained in the JCL for this job step, that provides the name of the data set that is to be printed.
INDATASET(data-set-name)
Name of the data set that is to be printed.
OUTFILE(ddname)
Name of the DD statement for the printed output. The data set must have an LRECL value of at least 121. If you omit OUTFILE, the SYSPRINTDD statement is assumed.
FROMKEY(key)
For a VSAM KSDS data set only, the key of the first record to print. Printing starts at the record with the same primary key, or the record with the nearest higher key if an exact match does not occur. Alternate indices are not used.
TOKEY(key)
For a VSAM KSDS data set only, the key of the last record to print. Printing ends at the record with the same primary key, the record with the nearest higher key if an exact match does not occur, or end of file. Alternate indices are not used.
SKIP(number)
The number of records to skip before printing starts.
COUNT(number)
The number of records to print.
CHARACTER
Records are to be printed in character format. MFJAMS converts EBCDIC data sets to ANSI. Unprintable characters are printed as periods.
HEX
Records are to be printed in hexadecimal format. MFJAMS prints each byte in the record as a two-byte hexadecimal value.
DUMP
Records are to be printed as a storage dump, in both hexadecimal and character format. MFJAMS converts EBCDIC data sets to ANSI. Unprintable characters are printed as periods.

Comments:

  • INFILE and INDATASET are mutually exclusive. You must specify one of them.
  • FROMKEY and SKIP are mutually exclusive. If you specify neither, printing starts at the first physical record.
  • TOKEY and COUNT are mutually exclusive. If you specify neither, printing ends at end of file.
  • CHARACTER, HEX and DUMP are mutually exclusive. DUMP is the default.
  • MFJAMS converts key values to EBCDIC if necessary.
  • MFJAMS pads partial keys with spaces.
Parent topic: Commands


REPRO

Thus the REPRO command can:

  • Load a sequential data set to a VSAM data set.
  • Load a VSAM data set to a VSAM data set, optionally replacing records that have the same primary key values as the input records.
  • Copy a VSAM data set to a sequential data set.
  • Copy a sequential data set to a sequential data set.

Parameters:

MFJAMS uses the parameters described in the following table. All other parameters are ignored.

INFILE(ddname)
Name of the DD statement, contained in the JCL for this job step, that provides the name of the data set that is to be used for input.
INDATASET(data-set-name)
Name of the data set that is to be used for input.
OUTFILE(ddname)
Name of the DD statement, contained in the JCL for this job step, that provides the name of the data set that is to be used for output.
OUTDATASET(data-set-name)
Name of the data set that is to be used for output.
FROMKEY(key)
For a VSAM KSDS only, the key of the first record to copy. Copying starts at the record with the same primary key, or the record with the nearest higher key if an exact match does not occur. Alternate indices are not used.
TOKEY(key)
For a VSAM KSDS only, the key of the last record to copy. Copying ends at the record with the same primary key, the record with the nearest higher key if an exact match does not occur, or end of file. Alternate indices are not used.
SKIP(number)
The number of records to skip before copying starts.
COUNT(number)
The number of records to copy.
REPLACE
For VSAM files only, the record in the input data set replaces any record in the output data set that has the same primary key.
NOREPLACE
For VSAM files only, the record in the input data set does not replace any record in the output data set that has the same primary key.

Comments:

  • INFILE and INDATASET are mutually exclusive. You must specify one of them.
  • OUTFILE and OUTDATASET are mutually exclusive. You must specify one of them.
  • REPLACE and NOREPLACE are mutually exclusive. NOREPLACE is the default.
  • MFJAMS automatically adds alternate key entries to the output data set if they have been previously defined.
  • IDCAMSREPRO pads (with blanks) LSEQ input records to the minimum record length (for primary and alternate keys) for VSAM data sets.
Parent topic: Commands


SET

Parameters:

MFJAMS uses only the MAXCC and LASTCC parameters, as described below. All other parameters are ignored.

MAXCC=number
Value that is to be set for the maximum condition code that was produced by all previous MFJAMS commands.
LASTCC=number
Value that is to be set for the last condition code that was produced by a MFJAMS command.

Comments:

In both cases, the highest valid value is 16. If you specify a higher value, MFJAMS sets the condition code to 16.

Parent topic: Commands


VERIFY

If the index is found to be unusable, the VERIFY command rebuilds the index by creating a new index file for the primary key and all alternate keys. The data portion of the data set is not changed.

Parameters:

MFJAMS uses the parameters described in the following list. All other parameters are ignored.

FILE(ddname)
Name of the DD statement, contained in the JCL for this job step, that provides the name of the data set that is to be verified.
DATASET(data-set-name)
Name of the data set.

Comments:

FILE and DATASET are mutually exclusive. You must specify one of them.

Parent topic: Commands


Comparing Data Sets (MFJMATCH - IEBCOMPR)

To compare two sequential or partitioned data sets you can use the MFJMATCH utility. MFJMATCH works in two modes, depending on the EXEC statement you use to invoke it:

EXEC Statement | Description
PGM=IEBCOMPR | MFJMATCH emulates the IEBCOMPR mainframe utility.
PGM=MFJMATCH | MFJMATCH performs a data set comparison but does not emulate the IEBCOMPR mainframe utility.

This section describes how to use MFJMATCH to emulate the IEBCOMPR mainframe utility. For information on using the non-IEBCOMPR version of MFJMATCH, see the section Comparing Data Sets (MFJMATCH).

  • JCL Statements
    This section describes the JCL statements used with the MFJMATCH utility.
  • Control Statements
Parent topic: Emulations of Mainframe Utilities
Related information
Comparing Data Sets (MFJMATCH)


JCL Statements

  • EXEC Statement
  • DD Statements
Parent topic: Comparing Data Sets (MFJMATCH - IEBCOMPR)


EXEC Statement

In the EXEC statement you need to specify MFJMATCH's alias, IEBCOMPR. For example:

//STEPEXEC PGM=IEBCOMPR, ...
Note: Specifying MFJMATCH instead of IEBCOMPR in the EXEC statement causes MFJMATCH to behave as described in the section Comparing Data Sets (MFJMATCH).
Parent topic: JCL Statements
Related information
Comparing Data Sets (MFJMATCH)


DD Statements

The following DD statements are required for all uses of MFJMATCH:

SYSPRINT
For the sequential data set used for listing control statements and messages.
SYSUT1
For an input sequential or partitioned data set to be compared.
SYSUT2
For the input sequential or partitioned data set to be compared with SYSUT1.

The following DD statement is optional:

SYSIN
For the control data set.
Parent topic: JCL Statements


Control Statements

The following control statements are parsed but not processed:

  • EXITS
  • LABELS
Parent topic: Comparing Data Sets (MFJMATCH - IEBCOMPR)


Copying and Merging Partitioned Data Sets (MFJCOPY)

  • JCL Statements
    This section describes the JCL statements used with the MFJCOPY utility.
  • Control Statements
Parent topic: Emulations of Mainframe Utilities


JCL Statements

  • EXEC Statement
    In the EXEC statement you need to specify the program name MFJCOPY or its alias IEBCOPY.
  • DD Statements
Parent topic: Copying and Merging Partitioned Data Sets (MFJCOPY)


EXEC Statement

For example:

//STEPEXEC PGM=IEBCOPY, ...
Parent topic: JCL Statements


DD Statements

The following DD statements are required for all uses of MFJCOPY:

SYSPRINT
For the sequential data set used for listing control statements and messages.
SYSUT1 or anyname1
For the input partitioned data set.
SYSUT2 or anyname2
For the output partitioned data set.

The following DD statement is optional:

SYSIN
For the control data set.

The following DD statements, which are used by the mainframe utility, are ignored by MFJCOPY:

SYSUT3
For a spill data set when there is no further space in virtual memory for the input data set.
SYSUT4
For a spill data set when there is no space in virtual memory for the output data set.
Parent topic: JCL Statements


Control Statements

The following control statements are parsed but not processed:

  • ALTERMOD
  • COMPRESS
  • COPYGRP
  • COPYMOD

Additional differences between behavior on the mainframe and in MSS are as follows:

  • MSS does not differentiate between PDS and PDSE organizations, so operations specific to PDSEs are not processed.
  • On the mainframe, specifying the same data set for INDD and OUTDD results in the data set being compressed. On MSS, such compression is not available, so no processing takes place.
  • On the mainframe, you can unload a PDS to an unload data set (by specifying a PDS as the INDD and a sequential data set as the OUTDD with no SYSIN) and reload a member from an unload data set into a PDS (by specifying a sequential data set as the INDD and a PDS as the OUTDD). Neither of these operations are supported in MSS.
  • Operations on load modules are not processed in MSS.
Parent topic: Copying and Merging Partitioned Data Sets (MFJCOPY)


Copying Sequential Data Sets (MFJGENER and ICEGENER)

MFJGENER emulates the basic copy operations of the IEBGENER mainframe utility for sequential data sets (that is, PS or PSU data sets, or members of PO or POU data sets.)

Note: ICEGENER behaves like IEBGENER but it also accommodates VSAM files.
  • JCL Statements
    This section describes the JCL statements used with the MFJGENER utility.
  • Control Statements
Parent topic: Emulations of Mainframe Utilities


JCL Statements

  • EXEC Statement
  • DD Statements
Parent topic: Copying Sequential Data Sets (MFJGENER and ICEGENER)


EXEC Statement

In the EXEC statement you need to specify the program name MFJGENER or its alias IEBGENER. For example:

//STEPEXEC PGM=IEBGENER,......
Parent topic: JCL Statements


DD Statements

The following DD statements are required:

SYSIN
For the command input data set.
SYSUT1
For the input data sets. You can concatenate up to 16 data sets for SYSUT1.
SYSUT2
For the output data set.
SYSPRINT
For the output listing data set.
Parent topic: JCL Statements


Control Statements

The following list describes how MFJGENER processes control statements differently to IEBGENER:

  • The EXITS and LABELS statements are parsed but not processed.
  • For the GENERATE statement, the DBCS operand is parsed but not processed.
  • For the MEMBER statement, any specified aliases are parsed but not processed.
  • For the RECORD statement:
    • operands relating to double-byte characters sets (such as IDENTG and the conversion types CG and CV) are parsed but not processed.
    • conversion type HE is not supported.
    • the LABELS operand is parsed but not processed.
Parent topic: Copying Sequential Data Sets (MFJGENER and ICEGENER)


Creating or Modifying Data Sets (MFJUPDTE)

  • JCL Statements
    This section describes the JCL statements used with the MFJUPDTE utility.
  • Control Statements
Parent topic: Emulations of Mainframe Utilities


JCL Statements

  • EXEC Statement
  • DD Statements
Parent topic: Creating or Modifying Data Sets (MFJUPDTE)


EXEC Statement

In the EXEC statement, you need to specify the program name MFJUPDTE or its alias IEBUPDTE. For example:

//STEPEXEC PGM=IEBUPDTE, ...
Parent topic: JCL Statements


DD Statements

The following DD statements are required:

SYSUT1
For the input data set.
SYSUT2
For the output data set.
SYSIN
For the control data set.
SYSPRINT
For the output listing data set.
Parent topic: JCL Statements


Control Statements

The following control statements are parsed but not processed:

  • ALIAS
  • LABEL

The following sub-operands for the function statement (ADD, CHANGE, REPL or REPRO) are parsed but not processed:

  • INHDR
  • INTLR
  • LEVEL
  • OUTDR
  • OUTTLR
  • SOURCE
  • SSI
  • TOTAL
Parent topic: Creating or Modifying Data Sets (MFJUPDTE)


Dummy Program (MFJBR14)

MFJBR14 can be used, for example, in a job step to delete data sets at the appropriate time. You can also use it to replace a program that does not have a version on the local machine, so that you can still test data set allocation and disposition for the job step.

  • JCL Statements
    This section describes the JCL statements used with the MFJBR14 utility.
Parent topic: Emulations of Mainframe Utilities


JCL Statements

  • EXEC Statement
    In the EXEC statement you need to specify the program name MFJBR14 or its alias IEFBR14.
Parent topic: Dummy Program (MFJBR14)


EXEC Statement

For example:

//STEPEXEC PGM=IEFBR14,......
Parent topic: JCL Statements


Executing TSO Commands in Batch Mode (IDAEFT01)

IDAEFT01 emulates the IKJEFT01 (and IKJEFT1A and IKJEFT1B) mainframe utility program. It starts a TSO session in batch, and the TSO session executes the TSO commands contained in the data set defined by the SYSTSINDD statement.

IDAEFT01 is typically used to run DB2/TSO applications in batch mode. Input for such applications is, at a minimum:

DSN SYSTEM(system)
RUN PROGRAM(name) PARM(parm-string)
 ....
END
SYSTEM(system)
Specifies the name of the DB2 system.
PROGRAM(name)
Specifies the name of the program to be executed. IDAEFT01 can execute any application program that is compiled within your COBOL development system, provided you have set the necessary directives.
PARM(parm-string)
Specifies the parameter string that is to be passed to the program through the standard linkage area.

If you are running a DB2 application, you need to define an XA Resource for the database manager. You can do this in either ES Admin or ESMAC:

  • JCL Statements
    This section describes the JCL statements used with the IDAEFT01 utility.
Parent topic: Emulations of Mainframe Utilities
Related information
To create a resource table
To add an XA resource to an enterprise server


JCL Statements

  • EXEC Statement
  • DD Statements
Parent topic: Executing TSO Commands in Batch Mode (IDAEFT01)


EXEC Statement

In the EXEC statement you need to specify the program name IDAEFT01 or its alias IKJEFT01. For example:

//STEPEXEC PGM=IKJEFT01,PARM='initial-command',.......
Parent topic: JCL Statements


DD Statements

The following DD statements are required:

SYSTSIN
This can be an in-stream data set, or sequential data set or PDS member with an 80 character record length.
SYSTSPRT
For the data set that contains output from IKFJEFT01.
SYSEXEC or SYSPROC
For the PDS containing any Rexx execs to be run under TSO.

You must also include any DD statements for sequential and VSAM data sets that are accessed by the application program.

Parent topic: JCL Statements


Running REXX Execs in MVS Batch Mode (MFIRXJCL)

It starts an MVS session in batch mode and runs the REXX exec specified in the PARM parameter. For more information about the REXX support in MSS see the chapter REXX Support.

  • JCL Statements
    This section describes the JCL statements used with the MFIRXJCL utility.
Parent topic: Emulations of Mainframe Utilities
Related information
REXX Support


JCL Statements

  • EXEC Statement
  • DD Statements
Parent topic: Running REXX Execs in MVS Batch Mode (MFIRXJCL)


EXEC Statement

In the EXEC statement you need to specify the program name MFIRXJCL, or its alias IRXJCL, and the name of the REXX exec as the first word in the PARM parameter. For example:

//STEPEXEC PGM=IRXJCL,PARM='REXXEXEC'
Parent topic: JCL Statements


DD Statements

The following DD statements may be required:

SYSTSIN
For the data set that contains input to the REXX exec. It can be an instream data set.
SYSTSPRT
For the data set that contains output from the exec.
SYSEXEC
SYSPROC
If the exec is a member of a PDS.

You must also include any DD statements for data sets that are accessed by the exec.

Parent topic: JCL Statements


TSO Support in Server Enterprise Edition

Server Enterprise Edition supports the use of TSO commands and REXX execs.

TSO commands can be run in a TSO batch (or background) session, using the IDAEFT01 (IKJEFF01) utility. TSO interactive processing is not supported in Server Enterprise Edition.

Server Enterprise Edition does not support CLIST processing.

  • TSO Commands and Micro Focus Extensions
    You can enter TSO commands and Micro Focus extensions individually within a REXX exec.
Parent topic: Emulations of Mainframe Utilities
Parent topic: Reference for MSS Deployment


TSO Commands and Micro Focus Extensions

The TSO commands and Micro Focus extensions supported by Server Enterprise Edition are listed below. Please refer to the IBM TSO documentation for any additional information about TSO commands.

  • ALLOCATE
    Allocates an MVS data set to the current user and defines the data set's DD name.
  • ATTRIB
    Allows DCB parameters to be dynamically defined and named for use in subsequent ALLOCATE commands.
  • CALL
    Invokes a program.
  • DELETE
    Deletes an MVS data set and its related PC file.
  • DSN
    Invokes the DSN command processor used to run DB2 programs.
  • EXEC
    Executes a TSO command, CLIST or REXX exec.
  • FREE
    Frees allocation of a data set.
  • LISTALC
    Displays the list of currently allocated DD names.
  • LISTCAT
    Lists the entries in the catalog with the high-level data set qualifier equal to the user ID defined to Server Enterprise Edition.
  • LOGOFF
    Terminates the current TSO session.
  • PROFILE
    Allows you to specify different PREFIX and PROMPT settings.
  • RELATE
    A Micro Focus extension that relates an MVS data set name in the catalog to a PC file name.
  • REXX
    Executes a file containing a set of JCL statements.
  • SUBMIT
    Executes a file containing a set of JCL statements.
  • TIME
    Displays the current time and date and the CPU seconds used.
Parent topic: TSO Support in Server Enterprise Edition


ALLOCATE

Allocates an MVS data set to the current user and defines the data set's DD name.

The following example allocates the existing data set TESTDATA.SORTED.DATA, with the DD name SYSUT1.

ALLOCATE FILE(SYSUT1) DATASET(TESTDATA.SORTED.DATA) OLD

Operands Support

The following operands are supported for ALLOCATE:

BLKSIZE | DUMMY | SHR
BLOCK | FILE | SPACE
CYLINDERS | LIKE | SYSOUT
DATACLAS | LRECL | TRACKS
DATASET | MOD | TRTCH
DDNAME | NEW | USING
DIR | OLD | WRITER
DSNAME | RECFM |
DSORG | REUSE |

The following are parsed and ignored:

ACCODE | DEN | NOBURST
ALTFILE | DEST | OPTCD
ATTRLIST | EROPT | OUTPUT
BFALN | EXPDT | PARALLEL
BFTEK | FCB | POSITION
BUFL | FLASH | RELEASE
BUFNO | FORMS | RETPD
BUFOFF | INPUT | ROUND
BURST | KEEP | UCS
CATALOG | KEYLEN | UNCATALOG
CHARS | LABEL | UNIT
COPIES | LIMCT | VOLUME
DELETE | NCP | VSEQ
Parent topic: TSO Commands and Micro Focus Extensions


ATTRIB

Allows DCB parameters to be dynamically defined and named for use in subsequent ALLOCATE commands.

The following example sets up an attribute called DATA1 that can be used in conjunction with an ALLOCATE command to provide DCB information for a DD name.

ATTRIB DATA1 BLKSIZE(32720) LRECL(80) DSORG(PS) RECFM(FB)

Operands Support

The following operands are supported for ATTRIB:

BLKSIZE | LRECL | TRTCH
DSORG | RECFM |

These operands produce identical output for SQL and VSAM datasets.

The following are parsed and ignored:

BFALN | BUFOFF | KEYLEN
BFTEK | DEN | NCP
BUFL | ERROPT | OPTCD
BUFNO | EXPDT | RETPD
Parent topic: TSO Commands and Micro Focus Extensions


CALL

Invokes a program.

The following example invokes program PROG1.

CALL PROG1

Operands Support

The following operands are supported for CALL:

ASIS | NOENVB | PASSENVB
CAPS | PARM | PROGRAM
Parent topic: TSO Commands and Micro Focus Extensions


DELETE

Deletes an MVS data set and its related PC file.

The following example deletes the data set TESTDATA.UNSORTED.DATA.

DELETE 'TESTDATA.UNSORTED.DATA'

Operands Support

The following operands are supported for DELETE:

DATASET | DSNAME
DDNAME | FILE

The following are parsed and ignored:

ALIAS | NONVSAM | PRG
CATALOG | NOPURGE | PURGE
CLUSTER | NOSCRATCH | SCRATCH
ERASE | NPRG | SPACE
GDG | NSCR | SPC
GENERATIONDATAGROUP | NVSAM | UCAT
NERASE | PAGESPACE | USERCATALOG
NOERASE | PGSPC |
Parent topic: TSO Commands and Micro Focus Extensions


DSN

Invokes the DSN command processor used to run DB2 programs.
In Server Enterprise Edition, the subcommands ABEND, BIND, DCLGEN, FREE, REBIND, SPUFI, SYSTEM, RETRY, TEST and PLAN are passed to the database sub system which may or may not support them.

The following example invokes the DSN subcommand processor to execute the RUN subcommand, which invokes the program PROG1 with the parameter string "HELLO". The END subcommand terminates the DSN subcommand processor.

DSN
RUN PROGRAM(PROG1) PLAN(PLANX) PARMS('HELLO')
END

Refer to the IBM DB2 for z/OS documentation for any additional information about the DSN command.

Operands Support

The following operands are supported for DSN:

RUN SYSTEM

The following are parsed and ignored:

RETRY TEST

The following are passed to the database sub system which may or may not support them:

ABEND | DCLGEN | FREE
BIND | END | REBIND
DATA | ENDDATA | SPUFI
Parent topic: TSO Commands and Micro Focus Extensions


EXEC

Executes a TSO command, CLIST or REXX exec.

The following example executes the member ABCD from the partitioned data set MYPDS.CLIST.

EXEC 'MYPDS.CLIST(ABCD)'
Parent topic: TSO Commands and Micro Focus Extensions


FREE

Frees allocation of a data set.
The following example frees the allocation for the data set with DD name SYSUT1.
FREE FILE(SYSUT1)

Operands Support

The following operands are supported for FREE:

ALL | DDNAME | DSNAME
DATASET | DELETE | FILE
Parent topic: TSO Commands and Micro Focus Extensions


LISTALC

Displays the list of currently allocated DD names.

Operands Support

The following operands are supported for LISTALC:

HISTORY | STATUS
MEMBERS | SYSNAMES

Specifying MEMBERS for a PDS also lists the PDS member names.

Parent topic: TSO Commands and Micro Focus Extensions


LISTCAT

Lists the entries in the catalog with the high-level data set qualifier equal to the user ID defined to Server Enterprise Edition.

Operands Support

If you invoke this command with the Micro Focus extension /F, it displays additional information.

The following operands are supported for LISTCAT:

ALL | /F | LVL
ENTRIES | LEVEL |

The following are parsed and ignored:

DATA | OFILE | USERCATALOG
INDEX | OUTFILE |
NONVSAM | SPACE |
Parent topic: TSO Commands and Micro Focus Extensions


LOGOFF

Terminates the current TSO session.
Once LOGOFF executes, remaining commands in the input stream are ignored.
Parent topic: TSO Commands and Micro Focus Extensions


PROFILE

Allows you to specify different PREFIX and PROMPT settings.

The following example adds a data set prefix of TVDF to any data set name not enclosed in quotes, and turns off prompting for REXX execs during the active TSO session.

PROFILE PREFIX(TVDF) NOPROMPT
Parent topic: TSO Commands and Micro Focus Extensions


RELATE

RELATE can be used in conjunction with an ALLOCATE command to set up tests in a TSO session.

The following example relates the MVS data set TESTDATA.SORTED.DATA to the PC file C:\MYFILE.DAT.

RELATE TESTDATA.SORTED.DATA C:\MYFILE.DAT

Operands Support

The following operands are supported for RELATE:

dataset name pc file name
Parent topic: TSO Commands and Micro Focus Extensions


REXX

Executes a file containing a set of JCL statements.

The following example executes the REXX statements contained in the PDS member IOCBL02.

REXX 'TEST.SYSEXEC(SBCS4315)'

Operands Support

The following operands are supported for REXX:

rexx name
Parent topic: TSO Commands and Micro Focus Extensions


SUBMIT

Executes a file containing a set of JCL statements.

The following example executes the JCL statements contained in IOCBL02.

SUBMIT 'TVDF.WORK.CNTL(IOCBL02)'

Operands Support

The following operands are supported for SUBMIT:

dataset name
Enter an example to illustrate your reference here (optional).
Parent topic: TSO Commands and Micro Focus Extensions


TIME

Displays the current time and date and the CPU seconds used.
The CPU seconds returned using the TIME command represent cumulative CPU time from LOGON. Current time and date are local.
Parent topic: TSO Commands and Micro Focus Extensions


Generating Test Data (MFJDG)

  • JCL Statements
    This section describes the JCL statements used with the MFJDG utility.
  • Control Statements
Parent topic: Emulations of Mainframe Utilities


JCL Statements

  • EXEC Statement
  • DD Statements
Parent topic: Generating Test Data (MFJDG)


EXEC Statement

In the EXEC statement, you need to specify the program-name MFJDG or IEBDG. For example:

//STEPEXEC PGM=IEBDG, ...

Any PARM on the exec statement is ignored.

Parent topic: JCL Statements


DD Statements

The following DD statements are required:

anyname1
For the optional input data set.
anyname2
For the output data set.
SYSIN
For the control data set.
SYSPRINT
For the output listing data set.
Parent topic: JCL Statements


Control Statements

The following sub-operands are parsed but not processed:

  • For the FD statement:
    • ACTION
    • CHARACTER
    • CYCLE
    • FORMAT
    • FROMLOCK
    • INDEX
    • RANGE
    • SIGN
  • For the CREATE statement:
    • EXIT
Parent topic: Generating Test Data (MFJDG)


Micro Focus Utilities

  • Comparing Data Sets (MFJMATCH)
    The MFJMATCH utility compares two MVS data sets. It accepts any record format, record length or data set organization supported by your COBOL development system.
Parent topic: Utility Programs


Comparing Data Sets (MFJMATCH)

If the data sets match, MFJMATCH ends with a return code of 0. If the two data sets do not match, when the MFJMATCH utility finds the first mismatch it writes the two records that differ to a third data set (with asterisks under the columns that differ), then ends with a return code of 12. Records following the first mismatch are not compared.

Note: You can also use the MFJMATCH utility to emulate the IEBCOMPR mainframe utility. For information on doing this, see the section Comparing Data Sets (MFJMATCH - IEBCOMPR).

If the data sets being compared are EBCDIC, the MFJMATCH utility also writes the hexadecimal representation.

  • JCL Statements
    This section describes the JCL statements used with the MFJMATCH utility.
Parent topic: Micro Focus Utilities
Related information
Comparing Data Sets (MFJMATCH - IEBCOMPR)


JCL Statements

  • EXEC Statement
  • DD Statements
  • Program Control Statements
    The program control statements define search criteria that limit matching to a particular range of records and to portions of the record. This topic lists the program control statements supported by MFJMATCH.
Parent topic: Comparing Data Sets (MFJMATCH)


EXEC Statement

In the EXEC statement you need to specify the program name MFJMATCH. For example:

//STEPEXEC PGM=MFJMATCH
Parent topic: JCL Statements


DD Statements

The following DD statements are required:

SYSUT1
For the first of the datasets to be compared.
SYSUT2
For the second of the datasets to be compared.
SYSIN
For the data set that contains the program control statements. It can be an in-stream data set.
SYSUT3
For the file to which results are written. It should also have the same DCB parameters as SYSUT1.
Parent topic: JCL Statements


Program Control Statements

KEY = ( start , length )
Defines a key field for use by FROMKEY and TOKEY program control statements. This statement can only occur once. The parameters are:
start
The position in the record at which the key starts.
length
The length of the key.

For VSAM keyed files, the KEY defaults to the actual key, although, as the files are processed sequentially, any field can be defined as the key for the purpose of specifying a range for record matching.

INCLUDE

Compare records only in the ranges defined by FROMKEYTOKEY or FROMRECCOUNT.

SKIP and INCLUDE are mutually exclusive.

IGNORE

Ignore records only in the ranges defined by FROMKEYTOKEY or FROMRECCOUNT.

SKIP and INCLUDE are mutually exclusive.

FROMKEY = ' value1 ' TOKEY = ' value1 '

Defines a range of records. value1 specifies the first record in the range, while value2 specifies the last record in the range. Hexadecimal values can be specified as x ' hhhhhh ' , where hhhhhh is a hexadecimal number.

FROMREC = recnum COUNT = count

Defines a range of record numbers, from record number x for the next y records.

FD = start , length

Defines a field to be ignored when comparing records. Used with INCLUDE only.

Example of Program Control Statements

In the following example:
  • The key field is defined as being the first ten bytes of the record
  • Records in the ranges AAAAAAAAAA to BBBBBBBBBB and WWWWWWWWW to ZZZZZZZZZZ are compared
  • Positions 11 to 15 and 21 to 25 are ignored in the second range
//SYSIN DD *
 KEY=(1,10)
 INCLUDE FROMKEY='AAAAAAAAAA' TOKEY='BBBBBBBBBB'
 INCLUDE FROMKEY='WWWWWWWWWW' TOKEY='YYYYYYYYYY'
 FD=(11,5)
 FD=(21,5)
Parent topic: JCL Statements


Writing Your Own Utility Programs

You might need to write your own utility programs or obtain them from other software vendors. MSS passes a standard MVS parameter area to these programs when they are invoked by TSO commands or JCL statements.

For a COBOL program, the parameter area has the following definition:

01 PARM.
      03 PARM-LENGTH         PIC 9(4)COMP.
      03 PARM-DATA.
         05 PARM-DATA-ARRAY  PIC X OCCURS 100.

PARM-DATA contains the data specified in the parameter field of the TSO command or JCL statement. MSS converts it to the default data representation defined for your system - ANSI or EBCDIC. The utility program should inspect the parameter data, determine its data representation and convert it, if necessary, to the representation used by the program.

Important: The utility program must be compiled within your COBOL development system to ensure that all interactions with the system are handled correctly.

For a PL/I program, the parameter area can be declared as CHAR(100) VARYING, or a structure equivalent to the COBOL definition.

Parent topic: Utility Programs


MVS Emulation

  • MVS Control Blocks
  • MVS External Writer
  • DB2 Call Attach Facility
Parent topic: JCL Support


MVS Control Blocks

MSS emulates those MVS control blocks that are accessible to applications running in problem program state. The information stored in these control blocks is limited to that which has value and meaning to applications running in problem program state.

Control blocks are accessed in MSS in the same way as they are on a mainframe, by referencing the appropriate field in the Communication Vector Table (CVT). The address of the CVT is stored at absolute address 16 in memory, as it is on the mainframe.

  • Low-memory Address Emulation in Assembler and COBOL
  • Control Blocks Supported
  • Accessing MVS Control Blocks from COBOL Programs
Parent topic: MVS Emulation


Low-memory Address Emulation in Assembler and COBOL

On the mainframe the prefixed save area (PSA) is mapped at absolute location 0. Many application programs access its contents. We provide software that allows your COBOL programs to access it as if they were running on the mainframe.

Parent topic: MVS Control Blocks


Control Blocks Supported

The table below lists the MVS control blocks that are emulated by MSS and specifies any differences between the non-mainframe versions and the mainframe versions.

Name | Description | Differences from mainframe
IHAACEE | Accessor Control Element | ACEEVRSN is set to 2
IHAASCB | Address Space Control Block
IHAASVT | Address Space Vector Table
IHAASXB | Address Space Extension Block
CVT Communication Vector Table CVTTOD is set to X'20', indicating that the Time Of Day clock is operational.

CVTMVSE - the X'80' bit in CVTDCB is always on, indicating that you are running under MVS/XA or later.

CVT4MPS - the X'04' bit in CVTDCB is on (indicating that you are running on System/360 Model 65 MP) only if the MVS control blocks are above the 16MB line (that is, all three-byte addresses are stored as four-byte addresses in the same location).

CVTDATE is set with the century number (that is, it uses "0cyyddds" format, where "c" is century number - 0 for 20th, 1 for 21st, etc.)

CVT | CVT Prefix | The CVT prefix is set to all binary zeros.
IHACDE | Contents Directory Entry | One "null" CDE is allocated. So it appears to be using a program for which the load module has not been loaded.
IDADDSA | Dynamic Storage Area (FSA - First Save Area) | This is an 88-byte save area pointed to by TCBFSA. It is used as the TCB First Save Area.
IEFJFCBN | Job File Control Block
IEZJSCB | Job Step Control Block
IHAPSA | Prefixed Save Area | The X'01' bit in byte 7 (the first byte being byte 0) is on only if the MVS control blocks are above the 16MB line (that is, all three-byte addresses are stored as four-byte addresses in the same location).
IEESMCA | SMF Control Area | SMCASID is set to 'MSTR'.
IDADTCA Task Communication Area

The PRV address is always zero.

The storage overflow routine does not provide overflow segments; it merely abends with the abend code S80A. You must ensure that the ISA setting is adequate for your application.

IDADTCA | TCA Prefix
IKJTCB | Task Control Block | The TCB protect key is set to key 8.
IEFTIOT1 | Task I/O Table | A maximum of 256 TIOT entries (representing the first 256 DDs in the job step) are supported.
Parent topic: MVS Control Blocks


Accessing MVS Control Blocks from COBOL Programs

MSS enables you to access MVS control blocks from a COBOL program. The following sample program shows how you can access the job, step, and program names for the currently running program.

Note: To run this program and its parent, you must compile them with the AMODE"31" (and by default DATA"31") compiler directive.
 IDENTIFICATION DIVISION.
 PROGRAM-ID. JOBINFO.

 DATA DIVISION.
 WORKING-STORAGE SECTION.
 01 JOB-NAME             PIC X(8).
 01 PROGRAM-NAME         PIC X(8).
 01 STEP-NAME            PIC X(8).

 LINKAGE SECTION.
 01 PSA.
    05 FILLER     PIC X(540).
    05 PSATOLD    POINTER.

 01 TCB.
    05 FILLER     PIC X(12).
    05 TCBTIO     POINTER.
    05 FILLER     PIC X(164).
    05 TCBJSCBB   POINTER.

 01 TIOT.
    05 TIOCNJOB   PIC X(8).
    05 TIOCSTPN   PIC X(8).

 01 JSCB.
    05 FILLER     PIC X(360).
    05 JSCBPGMN   PIC X(8).

 PROCEDURE DIVISION.
*    Address PSA
     SET ADDRESS OF PSA TO NULL

*    Address TCB
     SET ADDRESS OF TCB TO PSATOLD

*    Address TIOT
     SET ADDRESS OF TIOT TO TCBTIO

     MOVE TIOCNJOB TO JOB-NAME
     MOVE TIOCSTPN TO STEP-NAME

*    Address JSCB
     SET ADDRESS OF JSCB TO TCBJSCBB

     MOVE JSCBPGMN TO PROGRAM-NAME
     DISPLAY 'JOB NAME     = ' JOB-NAME
     DISPLAY 'STEP NAME    = ' STEP-NAME
     DISPLAY 'PROGRAM NAME = ' PROGRAM-NAME
     GOBACK
     .
Parent topic: MVS Control Blocks


MVS External Writer

Under MVS you can run a program that dynamically outputs a JCL job stream in the form of a SYSOUT data set, and you can specify that an external writer is to process the job stream. You can use the IBM-supplied external writer, INTRDR, or you can supply your own.

You can request an external writer in any of the following ways:

  • In JCL. The name of the external writer is a parameter in the DD statement for the SYSOUT data set
  • In a TSO ALLOCATE command
  • By issuing the DYNALLOC (SVC 99) service

MSS emulates the IBM-supplied external writer, INTRDR. It does not support user-supplied external writers.

The MSS emulation of INTRDR differs in the following ways from IBM's INTRDR:

  • IBM's INTRDR allows a program to submit a job without closing the data set, by writing records that contain control statements such as /*EOF, /*DEL, /*PURGE, and /*SCAN. Each of these statements effectively indicates that all data up to the statement is one or more complete jobs and that the action indicated by the statement should be carried out, for example, /*EOF causes the job to be submitted and is therefore equivalent to closing the data set. However, with the MSS emulation of INTRDR, the program must write an entire jobstream to the SYSOUT data set and then close the data set; the job is then submitted for execution. The program may then reopen the SYSOUT data set, write another complete jobstream and then close the data set for job submission.
  • IBM's INTRDR supports multiple jobs in one jobstream, regardless of whether the submission is triggered by a control statement or by the closing of the data set. The MSS emulation of INTRDR does not support multiple jobs in one submission, since MSS itself cannot handle such jobs. Each submission must contain only one job.
  • With IBM's INTRDR, the class of the submitted job defaults to the class of the SYSOUT data set. With the MSS emulation of INTRDR, the class of the submitted job is the same as it would be if the job were submitted without a class being specified.
  • You cannot request an external writer by issung the DYNALLOC (SVC 99) service
Parent topic: MVS Emulation


DB2 Call Attach Facility

You use the DB2 Call Attach Facility (CAF) to access DB2 subsystems and the data they manage. You do this by calling DSNALI with the appropriate series of functions. The MSS emulation of this facility behaves exactly as on the mainframe, with the following exceptions:

  • CONNECT function.
    • The subsystem parameter (parameter number 2) must be present but is otherwise ignored.
    • The termination Event Control Block (ECB) parameter (parameter number 3) must be present but is otherwise ignored. This ECB is never posted.
    • The starting ECB parameter (parameter number 4) must be present but is otherwise ignored. This ECB is never posted.
    • The Release Information Block (RIB) pointer (parameter 5) must be present and is set to point to a constant value which contains items such as an eye-catcher "RIB" and the DB2 subsystem release number of 710 (for DB2 V7.1.0).
  • OPEN function.
    • The subsystem parameter (parameter number 2) must be present but is otherwise ignored.
  • TRANSLATE function.
    • No translation is performed. In the SQLCA, SQLCODE is always set to -924, and SQLSTATE is always set to 58006.
Parent topic: MVS Emulation


Micro Focus Batch Scheduler Integration

This section explains how to use the Micro Focus Batch Scheduler Integration solution to allow feedback between Enterprise Server and a scheduler that controls JCL job execution.

  • Introduction
  • MFBSI Architecture
  • Supported Platforms
  • Prerequisites
  • Components
  • Configuring the Server
  • The MFBSI Configuration File
  • MFBSIJCL Submit Process
  • Job Restart
  • Sending Alerts to the Scheduler
  • JCL Parameter Substitution
  • User Exit Before Submission to Enterprise Server/JCL
  • Additional Notes
Parent topic: JCL Support


Introduction

To submit and start a JCL job to Server Enterprise Edition, you execute the CASSUB command with the appropriate parameters. However, by design CASSUB only provides notification on the proper submission of the job to Server Enterprise Edition if the JCL job syntax contains no errors. CASSUB can also end with a return code and output only to standard output (STDOUT).

If no initiator is available in Server Enterprise Edition, the job is never executed. If an initiator is available, the job may fail with a JCL error such as data set not found, or with a User, SYS, or RTS error in a program step execution.

Whether the job ends successfully of not, when using a scheduler to submit and control Server Enterprise Edition/JCL job execution, there is no mechanism to provide communication or feedback between the job execution and Server Enterprise Edition. You can submit and monitor JCL jobs activity using Server Enterprise Edition, but this requires manual intervention.

The Micro Focus Batch Scheduler Integration (MFBSI) provides this functionality, allowing for submission, execution and communication between JCL job execution and Server Enterprise Edition.

Parent topic: Micro Focus Batch Scheduler Integration


MFBSI Architecture

For MFBSI, the scheduler launches a COBOL program named MFBSIJCL, which executes CASSUB/CASOUT commands. MFBSIJCL then communicates with Server Enterprise Edition/JCL using the Event Manager user exit MFBSIEMX.

MFBSIJCL waits for Server Enterprise Edition/JCL job execution to end. It then returns the JCL Job return code or a specific return code to the scheduler.

Communication between MFBSIJCL and MFBSIEMX is done through a semaphore file named JOBnnnnn.Sem, where nnnnn is the job number assigned by Server Enterprise Edition/MSS JCL. These files are located in a folder shared by all MFBSIJCL instances and by MFBSIEMX. The environment variable MFBSI_DIR specifies this folder. If multiple Server Enterprise Edition/MSS JCL server are used, each one requires its own MFBSI_DIR settings.

MFBSIEMX creates a zero byte file when Server Enterprise Edition/JCL starts the job execution and adds a record containing the JCL return information when the job ends.

MFBSIJCL waits for the job start which creates JOBnnnnn.Sem, then for the job end in Server Enterprise Edition/MSS, which updates JOBnnnnn.Sem. When ended, MFBSIJCL stops execution with the return code read from JOBnnnnn.Sem. See the topic on how MFBSIJCL handles return codes for more information.

Using this technique, MFBSIJCL and Server Enterprise Edition can run on different machines and operating systems. Only a file share between machines is required. For example, the scheduler agent can run under Windows, launch MFBSIJCL with the appropriate parameters to submit the job to a machine running UNIX. The MFBSIJCL process run under Windows can monitor any directory residing on the UNIX machine using a network share utility such as SAMBA.

MFBSIJCL includes a timeout mechanism to prevent an instance from running infinitely without feedback. An alert can be sent to the scheduler if a either a startup or run timeout is detected. The alert calls an appropriate action in ESMAC SEE Web Administrator.

  • If the job is stopped, MFBSIJCL receives notification and sends that information to the scheduler.
  • If Server Enterprise Edition/MSS JCL is not properly stopped, or nothing abends, MFBSIJCL terminates with the appropriate return code, which is usually 225, 228 or 229.

MFBSIJCL uses the user exit MFBSIALR to send an alert to the scheduler. You must customize MFBSIJCL for a specific scheduler interaction. A skeleton program for MFBSIALR is available in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source (Windows), or .

Parent topic: Micro Focus Batch Scheduler Integration


Supported Platforms

MFBSI can be used on the these platforms:

  • Windows XP, Windows 7, Windows Server 2003/2008 or later (32-bit or 64-bit).
  • All UNIX and Linux platforms supported by Studio Enterprise Edition / MSS (32-bit or 64-bit).

As long as a shared folder can be defined, the scheduler can submit MFBSIJCL on one platform for execution of a JCL to another platform.

Parent topic: Micro Focus Batch Scheduler Integration


Prerequisites

Prerequisite software for the Micro Focus Batch Scheduler Integration is:

  • Micro Focus Server Enterprise Edition 5.0 or higher
  • An Enterprise Server must be available on the machine where the scheduler starts jobs.
Parent topic: Micro Focus Batch Scheduler Integration


Components

MFBSI consists of the following components:

  • The user exit program for Server Enterprise Edition/MSS Event Manager process (MFBSIEMX).
  • The trigger program launched by the scheduler to submit jobs to Server Enterprise Edition/MSS JCL (MFBSIJCL).
  • A sample user-exit program for MFBSIJCL, used to send time-out alerts to the scheduler (MFBSIALR).
  • Two modules (MFBSIPRM and MFBSICTM) used to substitute parameters found in the original JCL member. See the topic on JCL Parameters Substitution for more information.
  • A sample user exit sample programthat can provide additional modifications to the JCL file before submission (MFBSIUE1).
  • A sample user exit program that can be invoked just before MFBSIJCL termination (MFBSIUE2).
  • A recommended configuration file for MFBSIJCL (mfbsi.cfg).

MFBSI is a cross-platform and cross-system solution. Components are packaged as .exe or .dll modules (32-bit or 64-bit, depending on your Server Enterprise Edition configuration) for Windows, and .so for UNIX/Linux. For Windows, use appropriate modules located under \bin or \bin64.

  • MFBSIJCL
  • MFBSIEMX
Parent topic: Micro Focus Batch Scheduler Integration


MFBSIJCL

MFBSIJCL and called subroutines must be available on the system where the scheduler launches its jobs. The Micro Focus COBOL run-time system modules must also be accessible and configured on this system.

In Windows, start MFBSIJCL with the command MFBSIJCL commandLineParameters . In UNIX/Linux, start it with the command mfbsijcl commandLineParameters.

Tip: Command names in UNIX/Linux are case sensitive.
Parent topic: Components


MFBSIEMX

This module is packaged as a .dll file. The module is loaded and initialized at region startup.

Parent topic: Components


Configuring the Server

The MFBSIEMX module must be defined as an Event Manager user exit and the variable MFBSI_DIR must be specified similar to that shown the Configuration Information field.

For the line ES_EMP_EXIT_1=mfbsiemx shown in the Configuration Information field:

  • 1 can be a number from 1 to 9, based on the number of Event Manager user exits for the region. Set it to 1 if MFBSIEMX is the only Event Manager user exit for the region.
  • mfbsiemx is lower case by default for UNIX/Linux.

For the line BASE=/home/pringo/mfcobol/mfbsi shown in the Configuration Information field, the path must also include your server name. For, example, if the server name is ES-JCL, the Windows path is C:\MicroFocus\Netxproj\ES_JCL\MFBSI\ES-JCL. Long names with spaces are supported for the folder specified by MFBSI_DIR. In UNIX/Linux, the path is /home/Pringo/mfcobol/mfbsi/ES-JCL.

After making these settings in the region configuration, restart the server and check the console log for the message CASAM3001I to verify successful initialization of MFBSIEMX. Log entries are similar to:

060629 11445418    5790 ES-JCL    CASSI1501I Event Manager initialization started 11:44:54
060629 11445419    5790 ES-JCL    CASAM3001I Event Manager exit enabled (mfbsiemx) 11:44:54
060629 11445419    5790 ES-JCL    CASSI1503I Event Manager initialization complete 11:44:54

Server initialization creates a file named ES_server_name.Started in the MFBSI_DIR location. When the server shuts down, a file named ES_server_name.Shutdown replaces this file (where ES_server_name is the name of the server being used.

Additional configuration settings are required to restart submitted jobs. See the Job Restart section of the help for more information.

Parent topic: Micro Focus Batch Scheduler Integration


The MFBSI Configuration File

To simplify scheduler configuration, you can store most MFBSIJCL command line parameters for a given Server Enterprise Edition/MSS region to a configuration file. Storing parameters in a configuration file also means that potentially the only parameter needed to execute MFBSIJCL on a command line is the JCL member name.

Some special parameters are also only available from the configuration file and cannot be directly used in the command line.

By default, the configuration file resides in the location specified by the MFBSI_DIR environment variable. The configuration file name is mfbsi.cfg. You can change the default location and configuration file name as needed with the CFG command line parameter, or set a value for the MFBSI_CFG environment variable.

If a parameter is defined both in a configuration file and on the command line, the command line definition takes precedence.

A model of the configuration file, named mfbsi.cfg_model, is in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x folder (Windows), or the folder (UNIX, Linux).

That folder also contains a simple JCL rc08.jcl that invokes IDCAMS. You can use this JCL with MFBSI.

Parent topic: Micro Focus Batch Scheduler Integration


MFBSIJCL Submit Process

The scheduler always executes MFBSIJCL, either directly or by executing a script. This submits a JCL job to Server Enterprise Edition/JCL but does not directly invoke the CASSUB command. MFBSIJCL ends execution when the job terminates, either normally or abnormally.

If Server Enterprise Edition shuts down while submitted jobs are waiting for execution, other MFBSIJCL instances may still be running and waiting. After startup timeout, alerts may be sent to the scheduler. When Server Enterprise Edition restarts, jobs should be processed.

The environment variable MFBSI_DIR must be defined before MFBSIJCL starts. MFBSI_DIR specifies the folder where the temporary files JOBnnnnn.Sem and JobId.Log are stored. This folder must be accessible from where MFBSIJCL executes, either directly or from a share, or from the system running Server Enterprise Edition.

When MFBSIJCL executes, it takes execution parameters first from the command, and then from the configuration file mfbsi.cfg. The configuration file mfbsi.cfg is located in the folder specified by the MFBSI_DIR environment variable. mfbsi.cfg can specify parameters common to all jobs.

Note: Some execution parameters are only valid in mfbsi.cfg and not allowed on the command line.
  • MFBSIJCL Command Line Parameters
  • MFBSIJCL Return Codes
Parent topic: Micro Focus Batch Scheduler Integration


MFBSIJCL Command Line Parameters

MFBSIJCL uses two sets of command line parameters. The parameter sets are optionally delimited by END [space-END-space].

One parameter set corresponds exactly to the parameters used by the CASSUB and CASOUT commands. See online help for details on these commands. With MFBSI, the parameters -j and -x let you use OS environment variables in the path specification. See the description of the mfbsi.cfg parameter JCL-Submit for details.

The other parameter set is specific to MFBSI as shown.

Parameter | Description
SJOBID Specifies the MFBSIJCL output destination. Required when SJOBID is not defined in mfbsi.cfg or when not using a configuration file.
  • SJOBID=[JobId]. The internal Job ID assigned by the scheduler. This creates a log file containing the CASSUB or CASOUT outputs and includes the JCL execution return code. The log file is named by the Job ID (jobID.log).
  • SJOBID=JCL. The output log file name is set to the submitted JCL member name.
  • SJOBID=JOBNO. The output log file name is set to the job number assigned by the Server Enterprise Edition/MSS JCL.
  • SJOBID=STDOUT. No log file is created. The MFBSIJCL output is directly written to the console (STDOUT).

Specifying the JESYSMSG parameter includes the Server Enterprise Edition SysMsg log in the log file or STDOUT output.

STARTUPTIMEOUT=nnnn The timeout period in seconds between the job submission and the Server Enterprise Edition job start. Optional.

A value of 0 specifies an infinite wait. The default value is 300 (seconds).

You can use the MFBSIALR module to send an alert to the scheduler when the startup timeout period is reached.

RUNTIMEOUT=nnnn The timeout period in seconds between the Server Enterprise Edition job start and job end. Optional.

A value of 0 specifies an infinite wait. The default value is 900 (seconds).

You can use the MFBSIALR module to send an alert to the scheduler when the run timeout period is reached.

JCLExit=moduleName Specifies a user exit module to call before job submission to Server Enterprise Edition/JCL. Optional.

This user exit lets you modify the parts of the JCL such as parameters substitution, and return the full name of a new JCL file to be submitted. if needed, use JCLExitID to pass an identification string to the user exit.

TerminateExit=moduleName | Specifies a module to call just before terminating the MFBSIJCL process. Optional.
JESYSMSG | Extracts the Sysmsg log produced by Server Enterprise Edition for the job and includes it in the specified output destination, which is either a log file or STDOUT. Optional.
PARMS … [ENDPARMS] Used to define substitution pairs (parameterName=parameterValue). Optional.

See the topic on parameters substitution for details.

AUTOEDIT If PARMS … END-PARMS is not specified, this invokes the symbolic parameter substitution module to translate systems parameters. Optional.

See the topic on parameters substitution for details.

CFG=[path/][filename][.ext] Specifies a file to use as an alternate mfbsi.cfg parameters file. Optional.

The folder specified by $MFBSI_DIR is used if no path is specified. The extension .cfg is used if no extension is specified.

CASAPIParameter=ON|OFF|YES|NO Uses the CASSUB/CASOUT API call interfaces to submit the job, monitor the JCL region, and retrieve the JESYSMSG output. Optional.

By default, MFBSIJCL uses CASSUB/CASOUT external commands to submit the job, monitor the JCL region and retrieve the JESYSMSG output. Set this parameter to ON or YES for improved performance and tighter security.

Note: Do not use special configuration settings for the COBOL file handler (EXTFH) in the environment where MFBSIJCL is running. For example, do not use STRIPSPACE=OFF. If needed, you can specify special EXTFH parameters at the region level.
Parent topic: MFBSIJCL Submit Process


MFBSIJCL Return Codes

This table shows return codes from MFBSIJCL.

Return Code | Description
200 | CASSUB parameters missing
201 | More than 10 parameters after END
202 | Unknown parameter following END
203 | Scheduler JOBid is missing
204 | MFBSI_DIR environment variable not set
205 | MFBSI_DIR defines an invalid dir/folder
206 | More than 15 parameters for command line
207 | Pre-submit user-exit program aborts execution
208 | JCL error detected
209 | Job submission failed (See JOBid.Log for details)
210 | Job concluded signal event not returned
211 | Job ended, no numeric RC returned
212 | Command line parameters missing
213 | Configuration parameter file unknown
214 | Unable to configure JCL to submit parameter
215 | TYPRUN=SCAN: scan successful
216 | TYPRUN=SCAN: scan failed
217 | Pre-submit user-exit program missing or not found
218 | Terminate user-exit program missing or not found
220 | Restart for Job failed
221 | Unable to call module "MFBSIPRM"
222 | Error during skeletal parameter(s) substitution
223 | MFBSI.cfg error: "SkelProcessType" unknown
225 | Server EE region shut downed when Job was waiting for execution
226 | SYS/USR-ABEND-RC=nnn in MFBSI.cfg not numeric or greater than 199
227 | JESYSMSG-RC=Y(es) requires parameter JESYSMSG
228 | Server crashed/killed when job was in execution
229 | Job state unknown or inconsistent. Check Job status via SEE Web admin
230 | Max number of parameters to substitute reached
231 | Parameter file used for variable substitution not found
232 | mfbsijcl execution cancelled by a SIGTERM/Break signal
233 | Submitted job cancelled before starting execution
234 | MFBSI Control-M Post-Processing Handler Error
235 | Invalid specific mfbsi.cfg file name specified
236 | Specific mfbsi.cfg file name not found
240 | Security error (such as not authorized or invalid password)
Parent topic: MFBSIJCL Submit Process


Job Restart

Server Enterprise Edition allows job restarts at the step or procStep level.

You must add environment variables to the Server Enterprise Edition configuration information to allow the restart request for submitted jobs.

ES_JES_RESTART=Y and MF_UCC11=Y must be defined environment variables.

Refer to the following online documentation for more information regarding restarting jobs.

  • Micro Focus Server
  • Mainframe Support (CICS, IMS and JCL applications)
  • Mainframe Transaction Option Configuration and Administration Guide
  • JCL Support
  • Configuring an MSS-enabled Server Enterprise Edition for JCL
  • The Restarting Jobs topic.
  • Job Restart Usage
Parent topic: Micro Focus Batch Scheduler Integration


Job Restart Usage

To use MFBSIJCL to restart a failed job at a given step, replace the JCL parameter. The JCL parameter is similar to this line:

[-j][y:\MFServerEE\...\JCL\] MYJCL [.jcl]

Replace this line with:

[-j][JOB]nnnnn:STEP[:PROCSTEP]

where:

  • [JOB]nnnnn is the number referring to the job that you would like to restart. The string JOB may be omitted.
  • STEP is the step name for the restart.
  • PROCSTEP is the Proc Step name (optional).
Note: Parameters in square brackets in the example are optional.

MFBSIJCL restarts if [ -j][JOB]nnnnn:STEP[:PROCSTEP] is found in the JCL parameters as identified by -j or -J, or found in the assumed JCL member name.

For example, these commands are considered valid for a job restart:

MFBSIJCL ... -jJOB12345:step4 ...

MFBSIJCL ... /j12345:step4 ...

MFBSIJCL ... JOB12345:step4 ...

MFBSIJCL ... 12345:step4:PROC12 ...

MFBSIJCL ... 1234:step4 ...

Tip: MFBSIJCL normalizes the job as JOBnnnnn, that is the string JOB followed by 5 digits. StepName/ProcStepName is converted to upper-case.

Return code 220 from MFBSIJCL indicates a failed restart. If the stepName or the procStepName are invalid, it takes more than one minute for MFBSIJCL to end with return code 220. Check MFBSI job.log and the Server Enterprise Edition console for more information.

A parameter defined for MFBSIUE1 and MFBSIUE2 user exits identifies the execution mode:

  • Normal: normal job submit
  • Restart: restart of a job

When an exit is invoked at job restart, the ESue1-JCLfile or ESue2-JCLfile variable in the interface contains JOBnnnnn:StepName[procStepName].

For a job restart request, if the parameter SJOBID=JCL is used, it changes to SJOBID=JOBNO. The log file name is saved as JOBnnnnn.log. The job log from the restart execution in the folder specified by the $MFBSI_DIR variable overwrites the job log file of the initial submit.

Parent topic: Job Restart


Sending Alerts to the Scheduler

If a submitted job does not start execution after the time specified by StartupTimeout (with a minimum of one minute), or if a job is still running after the time specified by RunTimeout (with a minimum of one minute), the user exit MFBSIALR is called. This allows a notification to be sent to the scheduler requesting action by the Studio Enterprise Edition/MSS interface.

If after a first alert, the job is still in the same status after the specified time increment, subsequent alerts are sent at the specified time increment to invoke MFBSIALR.

MFBSIALR adds a new record in the file $MFBSI_DIR\Alert.txt displaying all the interface data.

The mfbsialr.cpy interface copybook file is located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source A sample COBOL program, mfbsialr.cbl, is located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source. Change this sample COBOL user exit program as needed for your environment, such as using the API provided by your scheduler.

  • MFBSIALR interface
Parent topic: Micro Focus Batch Scheduler Integration


MFBSIALR interface

This example shows the MFBSIALR interface.

*    -- copybook "MFBSIALR" --
01  ES-Alert-Exit-Interface.
**>
                    05  ESalrt-OS                   pic x(1).
            88 ESalrt-Windows             value '0'.
            88 ESalrt-UNIX                value '1'.
        05  ESalrt-Scheduler-Job-ID     pic x(16).
        05  ESalrt-AlertType.
         10  ESalrt-AlertType-Code   pic x(2).
                         88  Wait-on-Start         value '01'.
             88  Wait-on-EndOfRun      value '02'.
             88  No-Conclude-Signal    value '03'.
         10  ESalrt-AlertType-Txt    pic x(30).
     05  ESalrt-ES-Server            pic x(8).
     05  ESalrt-ES-Job               pic x(8).
     05  ESalrt-Date                 pic x(10).
     05  ESalrt-Time                 pic x(8).
Parent topic: Sending Alerts to the Scheduler


JCL Parameter Substitution

The JCL member submitted to MFBSIJCL may contain parameters that are substituted before submission to Server Enterprise Edition/MSS.

The ParameterName/ParameterValue pair capability is provided in the MFBSIJCL command line, but can also be specified in a parameter file or as operating system environment variables. MFBSIJCL may also automatically handle system parameters like DATE, DAY, or WEEK. For example, for the JCL member MYJCL.jcl:

//MFIDPS01  JOB 'MFIDPS',CLASS=A,MSGCLASS=A
//STEP1    EXEC PGM=IEFBR14
//SYSOUT   DD SYSOUT=*
//SYSPRINT DD SYSOUT=*
//DD1      DD DSN=%%HLQ.TEST.DSN,DISP=(MOD,DELETE)
//SYSIN    DD *
DATE    : %%DATE
/*
//
Note: In this example, %%HLQ is a user defined parameter and %%DATE is a system parameter (current date).

When submitted by MFBSIJCL using the command line parameters:

mfbsijcl MYJCL PARMS HLQ=MFIDPS [END-PARMS]

results in this JCL submitted to Server Enterprise Edition/MSS

//MFIDPS01  JOB 'MFIDPS',CLASS=A,MSGCLASS=A
//STEP1    EXEC PGM=IEFBR14
//SYSOUT   DD SYSOUT=*
//SYSPRINT DD SYSOUT=*
//DD1      DD DSN=MFIDPS.TEST.DSN,DISP=(MOD,DELETE)
//SYSIN    DD *
DATE    : 091222
/*
//
  • JCL Parameters Substitution Usage
  • System Parameters
  • Enabling Control-M AutoEdit Use
Parent topic: Micro Focus Batch Scheduler Integration


JCL Parameters Substitution Usage

JCL parameters substitution is handled by the MFBSI modules MFBSIPRM and MFBSICTM / MFBSICTG. All these modules must be available at execution time.

To enable JCL parameters substitution, add this setting to the mfbsi.cfg configuration file:

SkelProcessType=MFBSI

Enabling parameters substitution also creates a folder under the folder specified by the $MFBSI_DIR variable that stores the modified JCL file.

JCL parameters substitution is enabled when AutoEdit (command-line or through mfbsi.cfg) or PARMS … [END-PARMS] in a command line command are used. If not specified, no parameter substitution is done. If specified on the command line, parameters definition is started by the keyword PARMS and ended with END-PARMS. END-PARMS is not needed if it is the last keyword on the command line.

The maximum authorized command line length with MFBSIJCL is 8191 characters.

A parameter definition is formed by parameterName, followed by the equal sign =, followed by parameterValue. A total of 500 parameters is allowed.

parameterName can have a maximum of 32 characters, which are automatically translated to upper case as needed. In JCL, parameterName is prefixed by one or two special characters that identify the parameter. By default, the characters %% are used for the prefix. You can change the default characters used in JCL for parameterName with the setting SUBST-Prefix in the mfbsi.cfg configuration file.

A parameterName in a JCL member ends with:

  • A space, period, comma, equal sign, or the characters or.
  • Two consecutive plus signs (++).
  • A new parameter starting with %% or SUBST-Prefix.

parameterValue can have a maximum of 80 characters. To indicate a null value, use two consecutive double-quotes. Values that contain spaces should be enclosed by double-quotes.

Some or all parameters can be stored in a line sequential parameter file. Each parameterName=parameterValue pair must be on a single line and start in position 1. Prefix the full file location (path-baseName-extension) with the @ character. Delimit the file name using double quotes if it contains one or more spaces. For example:

MFBSIJCL ABC00231 PARMS HLQ=MF @"Y:\...\Parm File.Prm" WEEK=49
MFBSIJCL ABC02233 PARMS @/MF_ES/…/parmFile.prm END-PARMS

Parameters can also be specified as environment variables, using for example the OS command set / export parameterName=parameterValue. If PARMS … [END-PARMS] is not used, specify AUTOEDIT to enable substitution.

The search order for parameters value resolution is:

  • Command line and parameter file
  • System parameters automatically defined by MFBSI
  • Environment variables

If requested, an MFBSI user exit before submission, such as mfbsiue1.cbl invokes after parameters substitution has successfully completed. The variable ESue1-JCLfile contains the full name of the substituted JCL file.

In case of job restart, PARMS … [END-PARMS] or AUTOEDIT are not allowed. No JCL substitution is done.

Parent topic: JCL Parameter Substitution


System Parameters

MFBSI automatically defines the system variables that can be used in your JCL member. These variables are resolved before job submission and are not reevaluated during job execution.

Parameter / Variable | Description
SJOBID | JobID assigned by the scheduler. Contains a maximum of 16 characters, translated to upper case.
MEMNAME | JCL member name, translated to upper case.
BLANK | One blank ( space character X'20')
BLANKn | Resolves to n blanks, where n is a number from 1 through 80
TIMEID | Current time of day, in hhmmss format. This variable receives the current time only when it is first resolved in a job. Subsequent resolutions within that job do not update the variable.
TIME | Current time of day, in hhmmss format. This parameter receives the current time each time it is invoked.
$CENT | First two digits in the current year (for example, 20 in the year 2009)
DATE | Current system date (format yymmdd)
DAY | Current system day (format dd)
MONTH | Current system month (format mm)
YEAR | Current system year (format yy)
WEEK | Current week in the year (that is, 01 through 53)
WDAY | Current system day of the week (Example: 1=Sunday, 2=Monday and 0=Saturday)
JULDAY | Current system day (Julian format jjj)
$JULDAY | Current system day (Julian format yyyyjjj)
$DATE | Current system date (format yyyymmdd)
$YEAR | Current system year (format yyyy)
Parent topic: JCL Parameter Substitution


Enabling Control-M AutoEdit Use

MFBSI provides a measure of support for the BMC Control-M AutoEdit facility. The support assists migrating JCL using Control-M AutoEdit control statements or variables to the MSS server. This support does not cover full compatibility with Control-M for z/OS. Refer to the BMC Control-M for OS/390 and z/OS User Guide for information on using the Control-M AutoEdit facility.

Specify these parameters in the mfbsi.cfg configuration file to enable the Control-M AutoEdit facility.

SkelProcessType=MFBSICTM
AutoEdit
StartOfWeek=Sunday|Monday //Optional. Default is Monday
  • Variables Substitution
  • Date System Variables
  • Resolving Original Scheduling (%%O and %%$O) System Date Variables
  • %%IF, %%ELSE, and %%ENDIF
  • %%SET
  • %%GLOBAL and %%LIBSYM
  • %%INCLIB and %%INCMEM
  • %%GOTO and %%LABEL
  • Displaying the Symbols Pool in JCL Command Lines
  • Error Handling
Parent topic: JCL Parameter Substitution


Variables Substitution

AutoEdit variables can be defined using:

  • MFBSIJCL parameter names/values (including @parms_file)
  • OS environment variables
  • %%GLOBAL or %%LIBSYM control statements
  • %%SET control statement

MFBSI maintains a single variables pool. All variables are managed the same way in this pool. The MFBSI variable pool does not contain OS environment variables, except for system scheduling dates. See the topic on resolving original scheduling system date variables for more information.

The variables are searched in this order:

  • MFBSI variables pool
  • OS environment variables
  • AutoEdit system variables

Variable names are case insensitive. Variable values can have a maximum 80 character length.

Parent topic: Enabling Control-M AutoEdit Use


Date System Variables

The MFBSI system date variables for use with the Control-M AutoEdit facility are:

TIME | TIMEID | RDATE
DATE | ODATE | RJULDAY
JULDAY | OJULDAY | $RJULDAY
$JULDAY | $OJULDAY | RDAY
DAY | ODAY | RWDATE
WDAY | OWDAY | RMONTH
MONTH | OMONTH | RYEAR
YEAR | OYEAR | RWEEK
WEEK | OWEEK | $RCENT
$CENT | $OCENT |
Parent topic: Enabling Control-M AutoEdit Use


Resolving Original Scheduling (%%O and %%$O) System Date Variables

The Control-M AutoEdit facility can define or export these OS environment variables before executing MFBSIJCL or the script that executes MFBSIJCL.

  • ODATE [YYMMDD] [%%ODATE]
  • CENT [CC] [%%CENT]

PARMS ODATE=%%ODATE [CENT=%%CENT] may also be used in the MFBSIJCL command line to set %%ODATE and %%CENT.

When MFBSIJCL starts execution, it retrieves ODATE and CENT OS environment variable values. These are saved in the MFBSI symbols pool to resolve %%ODATE, %%ODAY, %%OMONTH and %%OYEAR found in the JCL member to be executed. Based on the values of these variables, additional Control-M AutoEdit variables are evaluated and stored in MFBSI symbols pool:

  • $OYEAR [CCYY]
  • $ODATE [CCYYMMDD]
  • OWEEK [nn] where nn = 01 - 53
  • OWDAY [d] where d = 1 -7
  • OJULDAY [JJJ] where JJJ = Julian date
  • $OCENT [CC]

When MFBSI is used with a scheduler other than Control-M, the OS variables ODATE, ODAY, OMONTH, OYEAR and CENT must be explicitly defined whenever %%ODATE, %%ODAY, %%OMONTH, %%OYEAR, %%$DATE, %%$OYEAR, %%OJULDAY, %%$OJULDAY, %%OWEEK, %%OWDAT or %%$CENT require resolution in the JCL. Control-M resolves these system variables based on the current OS system date.

If CENT is not defined in the OS environment, the current OS system century is used.

Example

This example shows a Control-M set/export ODATE=010201 (1 Feb.) and CENT=20 (year 2001) and variables defined in the MFBSI symbols pool at MFBSIJCL initialization.

9 //* %%LISTVAR
10 //*
--------------------------------------------------------------------<LISTVAR
11 //* ODATE = [010201] <LISTVAR
12 //* OYEAR = [01] <LISTVAR
13 //* OMONTH = [02] <LISTVAR
14 //* ODAY = [01] <LISTVAR
15 //* $ODATE = [20010201] <LISTVAR
16 //* $OYEAR = [2001] <LISTVAR
17 //* OWEEK = [05] <LISTVAR
18 //* OWDAY = [4] (if first day of week is defined as Monday) <LISTVAR
19 //* OJULDAY = [032] <LISTVAR
20 //* $OJULDAY = [2001032] <LISTVAR
21 //* $OCENT = [20] <LISTVAR
22 //*
--------------------------------------------------------------------<LISTVAR
Parent topic: Enabling Control-M AutoEdit Use


%%IF, %%ELSE, and %%ENDIF

MFBSI supports a maximum of three nested %%IF levels.

This example shows %%IF, %%ELSE, and %%ENDIF variable substitution:

Statement/Expression Resolves as...
//* %%SET %%STEP=STEP1

//* %%IF %%STEP EQ STEP1
//STEP1    EXEC PGM=IEFBR14
//*        => To be executed
//SYSOUT   DD SYSOUT=*
//* %%ELSE
//STEP2    EXEC PGM=IEFBR14
//*        => To be excluded
//SYSOUT   DD SYSOUT=*
//* %%ENDIF
//* => Always executed
//STEP3    EXEC PGM=IEFBR14
//*        => Always executed
//SYSOUT   DD SYSOUT=*

//* %%SET %%STEP=STEP1

//* %%IF STEP1 EQ STEP1
//STEP1    EXEC PGM=IEFBR14
//*        => To be executed
//SYSOUT   DD SYSOUT=*
//* %%ELSE

//* %%ENDIF
//* => Always executed
//STEP3    EXEC PGM=IEFBR14
//*        => Always executed
//SYSOUT   DD SYSOUT=*

//* %%IF %%STEP NE STEP1
//STEP1    EXEC PGM=IEFBR14,PARM='%%DATE'
//*        => To be excluded
//SYSOUT   DD SYSOUT=*
//* %%ELSE
//STEP2    EXEC PGM=IEFBR14,PARM='%%ODATE'
//*        => To be executed
//SYSOUT   DD SYSOUT=*
//* %%ENDIF
//* => Always executed
//STEP3    EXEC PGM=IEFBR14,PARM='%%RDATE'
//SYSOUT   DD SYSOUT=*

//* %%IF STEP1 NE STEP1

//* %%ELSE
//STEP2    EXEC PGM=IEFBR14,PARM='110716'
//*        => To be executed
//SYSOUT   DD SYSOUT=*
//* %%ENDIF
//* => Always executed
//STEP3    EXEC PGM=IEFBR14,PARM='110716'
//SYSOUT   DD SYSOUT=*

//* %%SET %%STEP=STEP2

//* %%IF   %%STEP   EQ STEP1
//* %%ELSE
//STEP1    EXEC PGM=IEFBR14
//*        => To be executed
//SYSOUT   DD SYSOUT=*
//* %%ENDIF
//STEP2    EXEC PGM=IEFBR14
//*        => Always executed
//SYSOUT   DD SYSOUT=*

//* %%SET %%STEP=STEP2

//* %%IF STEP2 EQ STEP1
//* %%ELSE
//STEP1    EXEC PGM=IEFBR14
//*        => To be executed
//SYSOUT   DD SYSOUT=*
//* %%ENDIF
//STEP2    EXEC PGM=IEFBR14
//*        => Always executed
//SYSOUT   DD SYSOUT=*
Parent topic: Enabling Control-M AutoEdit Use


%%SET

The valid syntax for %%SET in MFBSI is:

%%SET %%VarName[space(s)]=[space(s)]Expression

Expression can be:

  • Constant or AutoEdit variable(s)
  • AutoEditFunction
  • AutoEditFunction %%PLUS|%%MINUS Number|AutoEdit variable

This example shows %%SET variable substitution:

Statement/Expression Resolves as...
%%SET %%PARM=XYZ

%%PARM:      [XYZ]

%%SET   %%PARM  =XYZ

%%PARM:      [XYZ]

%%SET %%PARM  =    XYZ

%%PARM:      [XYZ]

%%SET %%PARM  =    X Y   Z

%%PARM:      [XYZ]

%%SET %%PARM=ABC  DEF

%%PARM:      [ABCDEF]

%%SET %%PARM=ABC%%BLANK2DEF

%%PARM:	     [ABC  DEF]

%%SET %%PARM=ABC%%BLANKDEF

%%PARM:	     [ABC DEF]

%%SET %%PARM=ABCDEF%%BLANK5

%%PARM:	     [ABCDEF     ]

%%SET %%PARM=ABCDEF%%BLANK3

%%PARM:	     [ABCDEF   ]

%%SET %%PARM='ABCDEF%%BLANK5'

%%PARM:	     ['ABCDEF     ']

%%SET %%PARM=%%$ODATE%%.ABC

%%PARM:	     [20110701ABC]

%%SET %%PARM=%%$ODATE.ABC

%%PARM:	     [20110701.ABC]

%%SET %%PARM=%%$ODATEABC
 Error: %%$ODATEABC can't be resolved.
Note: If it exists in the pool, value of %%PARM is left as-is.
  %%SET %%A=1
  %%SET %%B=2
  %%SET %%A2=100

//       TAPE=TAPE%%A%%B,
//       TAPE=TAPE%%A.%%B,
//       PARM=PRM%%A%%.%%B,
//       PARM=PRM%%A%%..%%B,
//       PARM='%%A%%%BLANK3%%B',
//DDN  DD DSN=HLQ.DATASET.A%%A.%%B,
//DDN  DD DSN=HLQ.DATASET.A%%A..%%B,
//DDN  DD DSN=HLQ.DATASET.A%%A%%..%%B,
//DDN  DD DSN=HLQ.DATASET.A%%A%%B,

//       TAPE=TAPE100,
//       TAPE=TAPE1.2,
//       PARM=PRM12,
//       PARM=PRM1.2,
//       PARM=’1   2’,
//DDN  DD DSN=HLQ.DATASET.A12,
//DDN  DD DSN=HLQ.DATASET.A1.2,
//DDN  DD DSN=HLQ.DATASET.A1.2,
//DDN  DD DSN=HLQ.DATASET.A100,

%%$ODATE%%BLANK5%%#AS-IS%%BLANK5%%WEEK

20110716     %%AS-IS     28

This example shows resolution of date functions in the %%SET control statement.

Statement/Expression Resolves as...
%%$YEARWK# %%$DATE
%%$YEARWK# 20010214
%%$YEARWK# 20050101
%%$YEARWK# 20011231

%%$YEARWK# 20101220
%%$YEARWK# 20101227
%%$YEARWK# 20110102
%%$YEARWK# 20110103

%%$CALCDTE %%$ODATE +D1
%%$CALCDTE   %%$ODATE +1

%%SET %%ADD_DATE=7
%%$CALCDTE %%$ODATE +%%ADD_DATE
%%$CALCDTE 20110101 -1
%%$CALCDTE 20101231 +1
%%$CALCDTE 20110228 +1
%%$CALCDTE 20110228 +1

[2011W28]
[2011W28]
[2011W28]
[2011W28]

[2011W28]
[2011W28]
[2011W28]
[2011W28]

[20110717]
[20110717]

[7]
[20110723]
[20101231]
[20110101]
[20110301]
[20110301]

This example shows resolution of %%PLUS / %%MINUS in the %%SET control statement:

Statement/Expression Resolves as...
%%SET %%_SCRATCH1=10 %%PLUS 25
%%SET %%_SCRATCH2=  %%B   %%MINUS   %%A
%%SET %%_SCRATCH3=%%A %%PLUS %%B

[35]
[1]
[3]

This example shows resolution of %%SUBSTR in the %%SET control statement:

Statement/Expression Resolves as...
%%SET %%STR=00-01-02
%%SET %%TAPE_01=%%SUBSTR %%STR 4 2
%%SET %%TAPE_02=EE100002
%%SET %%TAPE_03=EE100003
%%SET %%TAPE_04=EE100004
%%SET %%TAPE_05=EE100005
%%SET %%TAPE_06=EE100006
%%SET %%TAPE_07=EE100007
%%SET %%TAPE_08=EE100008
%%SET %%TAPE_09=EE100009
%%SET %%TAPE_10=EE100010
%%SET %%TAPE_11=EE100011
%%SET %%TAPE_12=EE100012

//    UNIT=TAPE,VOL=SER=TAPE%%TAPE_01,
//    UNIT=TAPE,VOL=SER=%%TAPE%%OMONTH,

[00-01-02]
[01]
[EE100002]
[EE100003]
[EE100004]
[EE100005]
[EE100006]
[EE100007]
[EE100008]
[EE100009]
[EE100010]
[EE100011]
[EE100012]

//    UNIT=TAPE,VOL=SER=TAPE01,
//    UNIT=TAPE,VOL=SER=EE100007,
Parent topic: Enabling Control-M AutoEdit Use


%%GLOBAL and %%LIBSYM

%%GLOBAL and %%LIBSYM values are stored in text files. In these text files:

  • Each record specifies the parameter name and the associated value.
  • Blank lines are ignored.
  • Comment lines start with a semicolon.
  • Values that contain explicit spaces are enclosed in double quotes.

This shows an example of symbol file contents:

; some comment
ABC=ABC

def="ABC DEF"
 Group    =     XYZ
 Parm2    =     "'123 567'"

The environment variable DAGLOBAL specifies the folder for the text file(s) used by %%GLOBAL. In a similar way, for %%LIBSYM members, the folder name is extracted from an environment variable or from the catalog.

This example shows resolution of %%GLOBAL and %%LIBSYM control statements:

Statement/Expression Resolves As…
//* %%GLOBAL MBRNAME

The environment variable DAGLOBAL specifies the location of the MBRNAME text file.

//* %%LIBSYM DATA.SET.NAME %%MEMSYM MBRNAME

The environment variable DATA.SET.NAME or DATA.SET.NAME as defined in the catalog specifies the MBRNAME text file location.

Parent topic: Enabling Control-M AutoEdit Use


%%INCLIB and %%INCMEM

The syntax for %%INCLIB and %%INCMEM are:

//* %%INCLIBDataSetName %%INCMEMmember

or

//* %%INCLIB DDNAME=ddName %%INCMEMmember

DataSetName or ddName must be exported as an environment variable and point to the folder where the file that defines member is found. Otherwise, the catalog is used. Extensions are not used in the syntax.

You can specify multiple paths with concatenation if using ddName. Each path is separated by a semicolon (Windows) or colon (UNIX/Linux).

Parent topic: Enabling Control-M AutoEdit Use


%%GOTO and %%LABEL

Use %%GOTO either subordinated to a conditional control statement such as %%IF or %%ELSE, or as an imperative statement. If used within a conditional control statement, %%GOTO implicitly terminates the conditional control statement.

The label names specified with %%GOTO or %% LABEL are constant, so they are resolved as a variable. The search for a %%LABEL associated to a %%GOTO is done in ascending order from the %%GOTO position.

Parent topic: Enabling Control-M AutoEdit Use


Displaying the Symbols Pool in JCL Command Lines

MFBSI has specific control statements that insert the existing symbols pool into JCL as command lines. Use the %%LISTVAR or %%LISTVARS control statements to do this.

9 //* %%LISTVAR
 10 //* --------------------------------------------------------------------<LISTVAR
 11 //* ODATE    = [010201]                                                 <LISTVAR
 12 //* OYEAR    = [01]                                                     <LISTVAR
 22 //* --------------------------------------------------------------------<LISTVAR
Parent topic: Enabling Control-M AutoEdit Use


Error Handling

When MFBSI detects an AutoEdit error, it inserts an error message in the JCL just before the statement in error. The error message text starts with //* ??? JCLSI0050E. The end of the message displays the number of the original JCL line.

For example:

 1 //MFIDPS01 JOB 'MFIDPS',CLASS=A,MSGCLASS=1
 2 //* %%GLOBAL				GLOBAL01
 3 //* %%LIBSYM    MFIDPS.CTRLM.SYMB %%MEMSYM SYMMBR01
 4 //* %%SET %%SYMBMBR=SYMMBR01
 5 //* %%LIBSYM MFIDPS.CTRLM.SYMB %%MEMSYM %%SYMBMBR
 6 //*
 7 //STEP1    EXEC PGM=IEFBR14
 8 //SYSOUT   DD SYSOUT=*
 9 //*??? JCLSI0050E For "DAGLOBAL(NOTFOUND)" file open error: 9/009. (9)
10 //* %%GLOBAL   NOTFOUND                                    << JCLin
11 //*

In case of AutoEdit error(s), MFBSI generates a bad JCL statement at the end of the JCL to abort the submitted job.

   21 //*
   22 // ***** MFBSI GENERATED JCL ERROR (AUTOEDIT FACILITY ERROR) *****
 **** JCLCM0409E INVALID OPERATOR
   23 //
 **** JCLCM0172E JOB FAILED - JCL ERROR

If this happens, the Control-M AutoEdit facility receives a get RC=208 message.

The submitted JCL can be found in the $MFBSI_DIR\JCLTemp folder.

Parent topic: Enabling Control-M AutoEdit Use


User Exit Before Submission to Enterprise Server/JCL

Introduction

If needed, the JCL file specified in the MFBSIJCL command can be edited before submission to JCL. This allows for any parameters substitution or additional site specific checking.

The parameter JCLExit specifies the name of the user exit module to be called. Use the mfbsiue1.cpy interface shown:

      *    -- copybook "MFBSIUE1" --

       01  ES-UserExit-JCLsubmit.
      **>  MFBSIJCL exit's common area
           05  ES-UE-CommonArea            pic x(1024).
      **>  Input parameters
           *>  OS Environment
           05  ESue1-OS                    pic x(1).
               88 ESue1-Windows              value '0'.
               88 ESue1-UNIX                 value '1'.
           *>  SJOBID
           05  ESue1-Scheduler-Job-ID      pic x(16).
           *>  User exit identifier
           05  ESue1-JCLexitID             pic x(32).
           *>  Execution mode: submit JCL or JOB restart
           05  ESue1-ExecutionMode         pic x(01).
               88  ESue1-ExecNormal          value 'N'.
               88  ESue1-ExecRESTART         value 'R'.
           05  filler                      pic x(14).
      *
      **>  Input/Output parameters
           05  ESue1-JCLfile               pic x(256).
      *
      **>  Output parameters
           05  ESue1-ReturnCode            pic x(2).
           05  ESue1-ReturnMsg             pic x(256).
      *
      **>  Delimiter
           05  ESue1-X00                   pic x(1).

The mfbsiue1.cpy copybook file can be found in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source.

User Exit usage

The user exit module retrieves the full path and filename of the original JCL file or substituted file name. You can use the optional parameter JCLExitID to specify work to be done by the user exit. The maximum length for this string is 32 characters.

Before returning, the user exit program sets the return code ESue1-ReturnCode to 00 and specifies the new file to submit (ESue1-JCLfile). If necessary, the submission process can be stopped. MFBSIJCL ends with a return code of 207. To do this:

  • Set the return code ESue1-ReturnCode <> "00".
  • Set your own error message with ESue1-ReturnMsg.
  • MFBSIJCL Termination User Exit
Parent topic: Micro Focus Batch Scheduler Integration


MFBSIJCL Termination User Exit

Just before terminating, MFBSIJCL can invoke a termination user exit.

Use the parameter TerminateExit to specify the name of the termination user exit module to be called. Use the Mfbsiue2.cpy interface as shown.

      *    -- copybook "MFBSIUE2" --

       01  ES-UserExit-MFBSIJCL-Terminate.
      **>  MFBSIJCL exit's common area
           05  ES-UE-CommonArea            pic x(1024).
      **>  Input parameters
           *>  OS Environment
           05  ESue2-OS                    pic x(1).
               88 ESue2-Windows              value '0'.
               88 ESue2-UNIX                 value '1'.
           *>  SJoBID
           05  ESue2-Job-ID                pic x(16).
           *>  ES server name
           05  ESue2-ESserver              pic x(8).
           *>  Full name of JCL file that was submitted
           05  ESue2-JCLfile               pic x(256).
           *>  MFBSI_DIR directory
           05  ESue2-MFBSI-DIR             pic x(256).
           *>  Execution mode: submit JCL or JOB restart
           05  ESue2-ExecutionMode         pic x(01).
               88  ESue2-ExecNormal          value 'N'.
               88  ESue2-ExecRESTART         value 'R'.
           05  filler                      pic x(14).
      *
      **>  Input/Output parameters
           05  ESue2-ReturnCode            pic 9(9) comp-5 .
      *
      **>  Delimiter
           05  ESue2-X00                   pic x(1).

This interface copybook file can be found in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source.

A sample COBOL program mfbsiue2.cbl can be found in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source.

User exit usage

This user exit module can be used for various duties, such as cleaning up files produced by the JCL exit functionality. If necessary, you can reset the return code returned by MFBSIJCL.

Parent topic: User Exit Before Submission to Enterprise Server/JCL


Additional Notes

  • User or System ABEND Handling
  • Enabling CTF Tracing for MFBSIEMX
  • Troubleshooting
  • To Display Configuration Information and Region State
  • To Display MFBSI Return Codes
Parent topic: Micro Focus Batch Scheduler Integration


User or System ABEND Handling

If a user or system abend occurs, MFBSIJCL returns the decimal value of the user or system status code by default. If this value is greater than 199, MFBSIJCL returns a final return code 16. Otherwise, the return code corresponds to the status code. For example, a user abend with return code 12 returns code 12.

A user or system JCL abend can return a specified return code to the scheduler. In the MFBSI configuration file, the parameters SYS-ABEND-RC and USR-ABEND-RC can be set to force the OS return code to be returned to the scheduler. SYS-ABEND-RC and USR-ABEND-RC cannot be set on the command line for MFBSIJCL.

This table shows the specific OS codes returned from MFBSIJCL.

Return Code | Description
200-231 | Indicates an error specific to MFBSIJCL, such as MFBSI_DIR not set, unknown or missing parameters, or error during job submission (CASSUB/CASOUT) See the topic on specific return codes issued by MFBSIJCL for descriptions of each return code.
208 | JCL error. Job not submitted.
209 | Unknown Server Enterprise Edition or Server Enterprise Edition/MSS not started. JCL file not found.
211 | Return code received from Server Enterprise Edition/MSS is not numeric
0-16 | Error code returned by Server Enterprise Edition/MSS JCL (job execution).
0 | Execution successful.
16 | Unsuccessful job execution.

In the job log written by MFBSIJCL, either in SJobId.Log or using STDOUT, messages provide additional information. For example:

JCLSI0004S SCHEDJ107  Parms: -rES-JCL -jC:\ES_JCL\ iefbr14.jcl END sjobid=J17 X=Yes
JCLSI0004S SCHEDJ107  Rc:203 Unknown parameter following " END ".

JCLSI0001I SCHEDJ109  Parms: CASSUB.exe -rES-CICS -jC:\ES_JCL\ iefbr14.jcl
Failed to connect to region ES-CICS return-code:    1-

The purpose of these messages is to allow additional scheduler error processing.

Message | Description
JCLSI0000I | Displays the version of MFBSIJCL
JCLSI0001I | The first line shows the CASSUB command used. the lines following show the output returned by CASSUB.
JCLSI0002I | JCL job execution started.
JCLSI0003I | JCL job execution completed.
JCLSI0004S | MFBSIJCL detects errors in parameters/configuration file.
JCLSI0005I | Job execution summary.
Parent topic: Additional Notes


Enabling CTF Tracing for MFBSIEMX

MFBSIEMX, the Event Manager user exit for MFBSI is CTF enabled. Its activity can be traced via the Micro Focus Consolidated Tracing Facility. Use this procedure to enable tracing for MFBSIEMX.

  1. Create a text file using this sample.
    # MFTRACE configuration file

#mftrace.emitter.textfile#Format = $(TIME) $(THREAD) $(COMPONENT) $(EVENT) $(LEVEL) :$(DATA)
#mftrace.emitter.textfile#location = C:\MicroFocus\Netxproj\ES_JCL\MFBSI\ES-MFBSI

mftrace.dest                     = binfile
mftrace.emitter.binfile#location = C:\MicroFocus\Netxproj\ES_JCL\MFBSI\ES-MFBSI

mftrace.level                 = none
mftrace.level.mfbsi           = info
mftrace.level.mfbsi.emx#all   = true

    Replace C:\MicroFocus\Netxproj\ES_JCL\MFBSI\ES-MFBSI with your CTF trace files folder. See a model of this in the MFBSI demo folder.

  2. Access your configuration information and add the line MFTRACE_CONFIG=[Full_Location_of_CTF_cfg.file] to your configuration file.

    For example:

    MFTRACE_CONFIG=C:\MicroFocus\Netxproj\ES_JCL\MFBSI\ES-MFBSI\ctf.cfg

  3. Stop and restart your enterprise server.
  4. In the CTF folder, verify that a file named either casevmgr.textfile.[Process-ID].log or casevmgr.binfile.[Process-ID].ctb exists (where [Process-ID] is the ID of the process. The file created is based on the emitter selection. In Windows, the bin file can be examined with the CTF Viewer.
    Event | Description
    0 | MFBSIEMX initialization started.
    1 | MFBSI_DIR setting not found.
    2

    File can not be created in the folder specified by MFBSI_DIR. Check the file status code.

    3 | MFBSIEMX initialization ended.
    9 | Enterprise server shutdown process started.
    10 | Job execution started.
    11 | Job execution ended.
    12 | Job concluded.
    19 | Batch SEP termination.
    20

    Unexpected file status during MFBSIEMX execution.

    Note: File status 0/005 in the associated data usually indicates a JCL error.
Parent topic: Additional Notes


Troubleshooting

For general MFBSI troubleshooting, perform the following steps to identify an issue:
  1. Shutdown the Server Enterprise Edition.
  2. Clean up the MFBSI_DIR folder by deleting all files except mfbsi.cfg.
  3. Start Server Enterprise Edition JCL from a command line. In Windows, from an Enterprise Developer command prompt (32-bit or 64-bit), enter casstart -rES_name. In UNIX/Linux, start a session for the defined Server Enterprise Edition user by entering. casstart -sTCP.
  4. Check the console log for a correct initialization of MFBSIEMX, and ensure that the Server Enterprise Edition Event Manager has not been stopped by MFBSIEMX.
  5. Verify that a file named ES_name.Started exists in the folder specified by the MFBSI_DIR environment variable (where ES_name is the name of the Server Enterprise Edition started with CASSTART). If this file does not exist, verify that you can create a file in the MFBSI_DIR folder.
  6. In Windows, from an Enterprise Developer command prompt (32-bit or 64-bit), validate MFBSIJCL by executing the command [run] mfbsijcl /show. In UNIX/Linux, validate MFBSIJCL in a user session that will submit JCL (UNIX), by executing the command [cobrun] mfbsijcl /show. The console output should be similar to:

  7. Enter the CASSUB command to validate that you can submit and execute a job in Server Enterprise Edition/MSS JCL. For example:
    • cassub -rES-name -jC:\...\JCL\rc00.jcl (Windows).
    • cassub -rES-name -j/.../JCL/rc00.jcl (UNIX/Linux).
    This creates a file named JOBnnnnn.sem in the MFBSI_DIR folder, where nnnnn is the job number assigned by the Server Enterprise Edition/MSS JCL.
  8. Execute MFBSIJCL from the command line using the same parameters, using STDOUT to output to the console. For example:
    • [run] mfbsijcl -rES-name -jC:\...\JCL\rc00.jcl SJOBID=StdOut (Windows).
    • [cobrun] mfbsijcl -rES-name -j/.../JCL\rc00.jcl SJOBID=StdOut (UNIX/Linux).
    Verify successful execution. The file JOB#####.sem is deleted when MFBSIJCL completes execution.
  9. Execute MFBSIJCL again from the command line using the same parameters, only specify a file for the output. For example:
    • [run] mfbsijcl -rES-name -jC:\...\JCL\rc00.jcl SJOBID=SJOB01 (Windows).
    • [cobrun] mfbsijcl -rES-name -j/.../JCL\rc00.jcl SJOBID=SJOB01 (UNIX/Linux).
    Verify successful execution. Review the log file SJOB01.log in the MFBSI_DIR folder to help troubleshoot your issue.
    Tip: Most issues in UNIX/Linux are the result of access denied, case sensitivity or authorization errors.
Parent topic: Additional Notes


To Display Configuration Information and Region State

You can output the current configuration from the MFBSI global configuration file and MFBSI region state to the console.
Do one of the following:
  • For Windows, Choose Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Compatibility Tools > Net Express Command Prompt (32-bit). Execute the command RUN mfbsijcl /Show from the command prompt.
  • For UNIX, from a session where your COBOL environment is defined, enter COBRUN mfbsijcl /Show.
Current configuration information and MFBSI region state output to STDOUT.
This is an example of the output.
JCLSI0000I MFBSIJCL FDS version 2.2.01

JCLSI0000I MFBSI_DIR: C:\MicroFocus\Netxproj\ES_JCL\MFBSI\ES-MFBSI
JCLSI0000I Region name: ES-MFBSI
JCLSI0000I MFBSI Global configuration file found:
JCLSI0000I       - ES-Server=-rES-MFBSI
JCLSI0000I       - SYS-ABEND-RC=20
JCLSI0000I       - USR-ABEND-RC=20
JCLSI0000I       - JCL-Submit=-jC:\MicroFocus\Netxproj\ES_JCL\MFBSI\JCL
JCLSI0000I       - JCL-Ext=Jcl
JCLSI0000I       - SJobID=JobNo
JCLSI0000I       - JESYSMSG
JCLSI0000I       - SkelProcessType=MFBSI
JCLSI0000I       - AutoEdit
JCLSI0000I MFBSI region state: up and running.
JCLSI0000I
JCLSI0000I Validate the Server state using the Web Administration.
------------------------------------------------------------------------
Note: The MFBSI determines region state based on the existence of the file [RegionName].Started or [RegionName].Shutdown in the folder defined by MFBSI_DIR.
Parent topic: Additional Notes


To Display MFBSI Return Codes

To display MFBSI Return codes, do one of the following:

  • For Windows, start a 32-bit or 64-bit command prompt and enter run mfbsijcl /rc.
  • For UNIX/Linux, from a session where your COBOL environment is defined, enter cobrun mfbsijcl /rc.

This is an example of the return codes output by the command.

-------------------------------------------------------------------------------
JCLSI0000I MFBSIJCL FDS version 2.2.03

JCLSI0000I Please have a look at Word document:
JCLSI0000I      "MFBSI Documentation [v2.2.03.docx]"
JCLSI0000I for HOW TO USE detailed instructions.
JCLSI0000I MFBSIJCL Specific Return codes:
JCLSI0000I     200  CASSUB parameters missing
JCLSI0000I     201  Too many parameters on the command line
JCLSI0000I     202  Unknown command line parameter detected
JCLSI0000I     203  Scheduler jobLog not assigned (SJobID)
JCLSI0000I     204  MFBSI_DIR environment variable not set
JCLSI0000I     205  MFBSI_DIR defines an invalid dir/folder
JCLSI0000I     206  Invalid numeric value for TimeOut
JCLSI0000I     207  JCL UserExit failed to execute / Rc <> 00
JCLSI0000I     208  JES/JCL error detected
JCLSI0000I     209  Job submission failed (See JobLog output)
JCLSI0000I     210  JobConcluded signal event not returned
JCLSI0000I     211  Job ended, no numeric Rc returned
JCLSI0000I     212  CommandLine parameters missing
JCLSI0000I     213  Configuration parameter unknown
JCLSI0000I     214  Unable to configure JCL to submit parameter
JCLSI0000I     215  TYPRUN=SCAN: scan succesfull
JCLSI0000I     216  TYPRUN=SCAN: scan failed
JCLSI0000I     217  JCL UserExit program missing or not found
JCLSI0000I     218  Terminate UserExit program missing or not found
JCLSI0000I     220  Restart failed
JCLSI0000I     221  Unable to call module "MFBSIPRM"
JCLSI0000I     222  Error during skeletal parameter(s) substitution
JCLSI0000I     223  MFBSI.cfg error: "SkelProcessType" unknown
JCLSI0000I     224  More than 10 ISPSLIB paths
JCLSI0000I     225  Server crashed/killed when job was waiting for execution
JCLSI0000I     226  SYS/USR-ABEND-RC=nnn in MFBSI.cfg not numeric or greater than 199.
JCLSI0000I     227  JESYSMSG-RC=Y(es) requires parameter JESYSMSG
JCLSI0000I     228  Server crashed/killed when job was running
JCLSI0000I     229  Server crashed/killed. MFBSIJCL ended.
JCLSI0000I     230  Max number of parameters to substitute reached
JCLSI0000I     231  Parameter file used to substitute not found
-------------------------------------------------------------------------------
Parent topic: Additional Notes


Using JCL User Exits

Certain events enable the user exit to alter the actions that follow the event. For example, when a job is submitted for execution, the user exit can modify the job or create a new one.

  • Introduction
  • Background Information
  • JCL/TSO Events and Actions
  • Event Scenarios
  • Event Logging
  • User Exit Interface Block (mfjdxit.cpy)
Parent topic: JCL Support


Introduction

The JCL component provides a facility called the JCL user exit, which enables you to monitor and control various events that occur during execution of a job or TSO session. Certain events enable the user exit to alter the actions that follow the event. For example, when a job is submitted for execution, the user exit can modify the job or create a new one.

Parent topic: Using JCL User Exits


Background Information

This section introduces information that you need to be familiar with before you can take advantage of JCL user exits.

  • MSS Processes
  • User Exit Invocation, Rules, and Guidelines
Parent topic: Using JCL User Exits


MSS Processes

When you submit a job (by clicking Submit on the JCL Control page of ESMAC, for example), a new process, called the parent process, is created in which job preparation and all resource allocation for all job steps of the job occurs. Then, if the job preparation and resource allocation is successful, for each program execution,MSS creates a child process in which the program runs. When the program finishes, the child process ends and the parent process wakes up to perform resource deallocation including such actions as disposition processing.

As far as the user exit is concerned, it has knowledge of the following:

  • All of the child process events in the child process for the execution of a single program only.
  • All of the parent process events in the parent process for the entire job (job and job step preparation for all of the job steps).

A user exit in the child process has no knowledge of events in the parent process, and vice versa.

Parent topic: Background Information


User Exit Invocation, Rules, and Guidelines

The user exit, which must be named MFJUXIT, is optional and is invoked as follows:

CALL 'MFJUXIT' USING JXIT

where JXIT is the user exit interface block (mfjdxit.cpy). It contains:
  • A header part that contains among other items, the event code of the event and the action code that represents the action that can be requested.
  • A data part that contains the data describing the event.
mfjdxit.cpy describes in detail all of the event codes, actions codes, and the data associated with each event. When looking at mfjdxit.cpy, note the following:
  • Field names containing -I- (for example JXIT-I-size) are input to the user exit and must not be modified.
  • Field names containing -U- (for example JXIT-U-PGM-alias) are used for input and output. On entry to the user exit, they are set as appropriate and may be changed by the user exit to an acceptable value upon return.
  • All character data is in ASCII (ANSI). Null values are those appropriate for the data type; that is blanks for character data, and zeros for numeric and binary data.

The user exit is called as events occur.

Most events occur in the batch initiator SEP. The exceptions are:
  • The Event-job-ready event occurs only in the normal SEP, not in the batch initiator SEP.
  • Event-job-concluded event occurs in the normal SEP only if the job is not intended for execution (that is, it has TYPRUN=COPY or TYPRUN=SCAN) or it has JCL errors.

A JCL user exit can remember only the events in the process from which it was invoked.

If the user exit fails for any reason, it is disabled in the failing process for all subsequent events.

Note:
  • The user exit must be named MFJUXIT. The source for the sample exit is available in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source. We recommend you use this as the base to build an exit to suit your needs. It uses a copybook for JXIT (the user exit interface block). The source for this copybook (mfjdxit.cpy) is in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source. A listing of mfjdxit.cpy is provided in the section User Exit Interface Block (mfjdxit.cpy).
  • The user exit must use the ASCII (ANSI) character set. We recommend that it uses the non-mainframe COBOL dialect "MF" as it is a PC-specific program.
  • The user exit is optional. The .int, .gnt or .dll file for the user exit must be placed in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source.
  • You must write the user exit in COBOL.
  • Directive NOOUTDD should be specified.
Parent topic: Background Information


JCL/TSO Events and Actions

For each event, this section defines the key (but not all) inputs and outputs and the actions that can be requested for the event. The following actions apply to all events:

  • The action-continue action code (which is the default action code) indicates to JCL/TSO that it should continue with normal processing as if the exit had never been invoked for that event..
  • The action-shut-exit action code indicates to JCL/TSO that it should stop calling the user exit for all future events in this process for the current job or TSO session. This is intended as a performance aid. The user exit should still be coded so that it can receive future events and ignore them using the default action code action-continue.

The event names listed below correspond in part to the level-88 name assigned to the event code. Similarly, action code names listed correspond in part to the level-88 name assigned to the action code. Having access to the mfjdxit.cpy file will help your understanding of the facilities being described here.

Important: Not all of the events described in this section are currently implemented. The description of an event indicates if it is not currently implemented. If any of the unimplemented events would be of use in your organization, please contact your Micro Focus Sales or Support representative.
  • Event-after-PGM-call
    Indicates that the program has returned control to the system. One of these events occurs for each Event-before-PGM-call. The purpose of this event is to enable your user exit to perform any processing (such as deleting of programs that were loaded when the Event-before-PGM-call occurred) after the end of the program.
  • Event-before-PGM-call
    Indicates that the initial program (equivalent to the PGM= JCL parameter) is about to be invoked. This event occurs once for each step (for PGM= program), once for each CALL command (for the program named on the command), and once for each RUN subcommand of the DSN command (for the program named on the subcommand).
  • Event-CALL-ended
    Indicates that the job step has ended.
  • Event-CALL-ready
    Indicates that a TSO CALL command is about to be executed.
  • Event-CALL-started
    This event indicates that the CALL command has started.
  • Event-job-ended
    Indicates that the job has ended. This event enables the user exit to examine or change job termination information.
  • Event-job-flushed
    Indicates that a job has been flushed, either because the user exit requested it to be done or for other reasons for which JCL may flush the job, for example an invalid job name or missing JOB card.
  • Event-job-JCL-error
    Indicates that the job failed with a JCL error.
  • Event-job-ready
    Indicates that a request to submit a job has been received, although the job being submitted has not been read and nothing has been done to it. Note that it is possible that the file containing the job does not even exist, but it very likely does. This event enables the user exit to verify or modify the job that is being submitted.
  • Event-job-concluded
    Indicates that the job execution has completely finished and any spool output is ready for viewing or printing. The purpose of this event is to allow the user exit (or processes triggered by it) to access the job’s log and other spool output.
  • Event-job-started
    Indicates that the job has been started.
  • Event-RUN-ended
    Indicates that the job step has ended.
  • Event-RUN-ready
    Indicates that a DSNRUN subcommand is about to be executed.
  • Event-RUN-started
    Indicates that the RUN subcommand of the DSN command has started.
  • Event-step-bypassed
    Indicates that the job step has been bypassed. Event-specific data is exactly is exactly the same as Event-job-started.
  • Event-step-ended
    Indicates that the job step has ended.
  • Event-step-ready
    Indicates that a job step is about to be executed. This event is similar to Event-before-PGM-call, except that this event occurs in the parent process and enables the user exit to change information such as program name, whereas Event-before-PGM-call does not.
  • Event-step-started
    Indicates that the job step has been started.
  • Event-TSO-ended
    Indicates that a TSO session has ended.
  • Event-TSO-started
    Indicates that a TSO session has been started.
Parent topic: Using JCL User Exits


Event-after-PGM-call

Indicates that the program has returned control to the system. One of these events occurs for each Event-before-PGM-call. The purpose of this event is to enable your user exit to perform any processing (such as deleting of programs that were loaded when the Event-before-PGM-call occurred) after the end of the program.

This event and Event-before-PGM-call occur in the child process. All other events occur in the parent process. Your exit cannot remember any events that occurred in the parent process.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Job termination type, for example, normal, user-abend, or system-abend.
  • Return or abend code and reason code.
  • All of the data presented for Event-job-started.

Actions:

You cannot request any actions for this event; only the default action will take place.

Parent topic: JCL/TSO Events and Actions
Related information
Event-before-PGM-call
Event-job-started


Event-before-PGM-call

Indicates that the initial program (equivalent to the PGM= JCL parameter) is about to be invoked. This event occurs once for each step (for PGM= program), once for each CALL command (for the program named on the command), and once for each RUN subcommand of the DSN command (for the program named on the subcommand).

For a job step, the difference between this event and Event-step-ready is that this event occurs in the child process giving the user exit the opportunity to do things on behalf of the program about to be invoked. For example, if you need to load special modules that the program will be using, this would be the time to do it. This event does not permit you to change data such as program name, whereas Event-step-ready does.

The purpose of this event is to allow your user exit to perform any processing (such a loading of programs to avoid name conflicts or for other reasons) before the program is invoked.

This event and Event-after-PGM-call occur in the child process. All other events occur in the parent process. Your exit cannot remember any events that occurred in the parent process.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Job number.
  • Job name.
  • Job start date and time.
  • Step start date and time.
  • Step name and number.
  • Procedure step name and number.
  • All of the data presented for Event-step-ready.

Actions:

You cannot request any actions for this event; only the default action will take place.

Parent topic: JCL/TSO Events and Actions
Related information
Event-after-PGM-call
Event-step-ready


Event-CALL-ended

Indicates that the job step has ended.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Job termination type, for example, normal, user-abend, or system-abend.
  • Return or abend code and reason code.
  • Step start date and time.
  • Step name and number.
  • All of the data presented for Event-job-started.

Actions:

The following actions can be requested for this event:

action-term-info
Indicates that JCL should use the modified version of information such as termination type and return/abend code.
Parent topic: JCL/TSO Events and Actions
Related information
Event-job-started


Event-CALL-ready

Indicates that a TSO CALL command is about to be executed.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Program name and alias.
  • Program parameter string; that is, the equivalent of the PARM= parameter of JCL.

Actions:

The following actions can be requested for this event:

action-PGM-info
Indicates that JCL should use the modified program alias and parameter string.
action-abend
Indicates that the step should be abended with the system abend S822 (Region not available). Execution of subsequent steps will be then be based on this abend.
Parent topic: JCL/TSO Events and Actions


Event-CALL-started

This event indicates that the CALL command has started.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Job number.
  • Job name.
  • Job start date and time.
  • Step start date and time.
  • Step name and number.
  • Procedure step name and number.
  • All of the data presented for Event-step-ready.

Actions:

You cannot request any actions for this event; only the default action will take place.

Parent topic: JCL/TSO Events and Actions
Related information
Event-step-ready


Event-job-ended

Indicates that the job has ended. This event enables the user exit to examine or change job termination information.

Event-specific data:

Data available for this event includes:

  • Job termination type, for example, normal, user-abend, or system-abend.
  • Return or abend code and reason code.
  • All of the data presented for Event-job-started.

Actions:

The following actions can be requested for this event:

action-term-info
Indicates that JCL should use the modified version of information such as termination type and return/abend code.
Parent topic: JCL/TSO Events and Actions
Related information
Event-job-started


Event-job-flushed

Indicates that a job has been flushed, either because the user exit requested it to be done or for other reasons for which JCL may flush the job, for example an invalid job name or missing JOB card.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Job number.

Actions:

You cannot request any actions for this event; only the default action will take place.

Parent topic: JCL/TSO Events and Actions


Event-job-JCL-error

Indicates that the job failed with a JCL error.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Job number.
  • Job name.
  • Job start date and time.

Actions:

You cannot request any actions for this event; only the default action will take place.

Parent topic: JCL/TSO Events and Actions


Event-job-ready

Indicates that a request to submit a job has been received, although the job being submitted has not been read and nothing has been done to it. Note that it is possible that the file containing the job does not even exist, but it very likely does. This event enables the user exit to verify or modify the job that is being submitted.

Event-specific data:

Data available for this event includes:

  • Job number assigned to the job.
  • Physical file name (and if available, MVS data set name) of the job that is to be submitted. The MVS data set name exists only if an MVS data set corresponding to the physical file exists. The SUBMIT command always has an MVS data set associated with it. For example, for a PDS member, the MVS data set name may be MFIDSA.CNTL(MYJOB) or for a PS, it may be S0310.S070508.J01364.D00002.SYSUT2 (data set name assigned to an INTRDR SYSOUT data set).
  • The type of job submission (scan only or job execution).
  • Whether the job will be animated; that is, executed in debug mode.

Actions:

The following actions can be requested for this event:

action-MVS-dsn
Indicates that JCL should use the modified MVS data set name and submit it as the job.
action-pc-fname-dsn
Indicates that JCL should use the modified physical filename and submit it as the job.
action-flush
Indicates that JCL should flush the job.
Parent topic: JCL/TSO Events and Actions


Event-job-concluded

Indicates that the job execution has completely finished and any spool output is ready for viewing or printing. The purpose of this event is to allow the user exit (or processes triggered by it) to access the job’s log and other spool output.

Event-specific data:

Data available for this event includes:

  • Job conclusion type:
    • normal
    • JCL error
    • user abend
    • system abend
  • Job conclusion return and reason (always zero) codes.

    These are not applicable to jobs that ended, abended, were cancelled, or failed authorization. For all other job conclusions, return code may be changed.

    Reason code, if changed, will be ignored.

Actions:

You cannot request any actions for this event; only the default action will take place.

Parent topic: JCL/TSO Events and Actions


Event-job-started

Indicates that the job has been started.

Event-specific data:

Data available for this event includes:

  • Job number.
  • Job name.
  • Job start date and time.

Actions:

You cannot request any actions for this event; only the default action will take place.

Parent topic: JCL/TSO Events and Actions


Event-RUN-ended

Indicates that the job step has ended.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Job termination type, for example, normal, user-abend, or system-abend.
  • Return or abend code and reason code.
  • Step start date and time.
  • Step name and number.
  • All of the data presented for Event-job-started.

Actions:

The following actions can be requested for this event:

action-term-info
Indicates that JCL should use the modified version of information such as termination type and return/abend code.
Parent topic: JCL/TSO Events and Actions
Related information
Event-job-started


Event-RUN-ready

Indicates that a DSNRUN subcommand is about to be executed.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Program name and alias.
  • Program parameter string; that is, the equivalent of the PARM= parameter of JCL.

Actions:

The following actions can be requested for this event:

action-PGM-info
Indicates that JCL should use the modified program alias and parameter string.
action-abend
Indicates that the step should be abended with the system abend S822 (Region not available). Execution of subsequent steps will be then be based on this abend.
Parent topic: JCL/TSO Events and Actions


Event-RUN-started

Indicates that the RUN subcommand of the DSN command has started.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Job number.
  • Job name.
  • Job start date and time.
  • Step start date and time.
  • Step name and number.
  • Procedure step name and number.
  • All of the data presented for Event-step-ready.

Actions:

You cannot request any actions for this event; only the default action will take place.

Parent topic: JCL/TSO Events and Actions
Related information
Event-step-ready


Event-step-bypassed

Indicates that the job step has been bypassed. Event-specific data is exactly is exactly the same as Event-job-started.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Job number.
  • Job name.
  • Job start date and time.

Actions:

You cannot request any actions for this event; only the default action will take place.

Parent topic: JCL/TSO Events and Actions
Related information
Event-job-started


Event-step-ended

Indicates that the job step has ended.

Event-specific data:

Data available for this event includes:

  • Job termination type, for example, normal, user-abend, or system-abend.
  • Return or abend code and reason code.
  • Step start date and time.
  • Step name and number.
  • All of the data presented for Event-job-started.

Actions:

The following actions can be requested for this event:

action-term-info
Indicates that JCL should use the modified version of information such as termination type and return/abend code.
Parent topic: JCL/TSO Events and Actions
Related information
Event-job-started


Event-step-ready

Indicates that a job step is about to be executed. This event is similar to Event-before-PGM-call, except that this event occurs in the parent process and enables the user exit to change information such as program name, whereas Event-before-PGM-call does not.

This event enables the user exit to examine or change program alias name, program name and parameter string information.

This event does not occur for TSO sessions.

Event-specific data:

Data available for this event includes:

  • Program name and alias.
  • Program parameter string; that is, the equivalent of the PARM= parameter of JCL.

Actions:

The following actions can be requested for this event:

action-PGM-info
Indicates that JCL should use the modified program name or program alias and/or parameter string. If the program name, as opposed to program alias, is changed, it is looked up in the alias list to determine if there is an alias for it. If so, the new alias will be used.
action-abend
Indicates that the step should be abended with the system abend S822 (Region not available). Execution of subsequent steps will be then be based on this abend.
Parent topic: JCL/TSO Events and Actions
Related information
Event-before-PGM-call


Event-step-started

Indicates that the job step has been started.

Event-specific data:

Data available for this event includes:

  • Job number.
  • Job name.
  • Job start date and time.
  • Step start date and time.
  • Step name and number.
  • Procedure step name and number.
  • All of the data presented for Event-step-ready.

Actions:

You cannot request any actions for this event; only the default action will take place.

Parent topic: JCL/TSO Events and Actions
Related information
Event-step-ready


Event-TSO-ended

Indicates that a TSO session has ended.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Job termination type, for example, normal, user-abend, or system-abend.
  • Return or abend code and reason code.
  • All of the data presented for Event-job-started.

Actions:

The following actions can be requested for this event:

action-term-info
Indicates that JCL should use the modified version of information such as termination type and return/abend code.
Parent topic: JCL/TSO Events and Actions
Related information
Event-job-started


Event-TSO-started

Indicates that a TSO session has been started.

This event is currently not implemented.

Event-specific data:

Data available for this event includes:

  • Job number.
  • Job name.
  • Job start date and time.

Actions:

You cannot request any actions for this event; only the default action will take place.

Parent topic: JCL/TSO Events and Actions


Event Scenarios

This section briefly describes the events that can occur in each of the following environments:

  • JCL Scenarios
  • TSO in Batch (IKJEFTxx JCL) Scenarios
Parent topic: Using JCL User Exits


JCL Scenarios

The events that can occur and their sequence are as follows:

  • Event-job-ready, followed by one of:
    • Event-job-flushed
    • Event-job-JCL-error
    • Event-job-started, followed by (for each step in the job, one or more times) :
      1. Event-step-ready, followed by one of :
        • Event-step-bypassed
        • Event-step-started, followed by:
          1. Event-before-PGM-call
          2. Event-after-PGM-call
          3. Event-step-ended
      2. Event-job-ended
Parent topic: Event Scenarios


TSO in Batch (IKJEFTxx JCL) Scenarios

The events that can occur and their sequence are as follows:

  • Event-job-ready, followed by one of:
    • Event-job-flushed
    • Event-job-JCL-error
    • Event-job-started, followed by (for each step in the job, one or more times):
      1. Event-step-ready, followed by one of
        • Event-step-bypassed
        • Event-step-started, followed by:
          1. Event-before-PGM-call, followed by any combinations of:
            • For each CALL command (zero or more times):
              1. Event-CALL-ready
              2. Event-CALL-started, followed by:
                1. Event-before-PGM-call
                2. Event-after-PGM-call
              3. Event-CALL-ended
            • For each DSNRUN subcommand (zero or more times):
              1. Event-RUN-ready
              2. Event-RUN-started, followed by:
                1. Event-before-PGM-call
                2. Event-after-PGM-call
              3. Event-RUN-ended
          2. Event-after-PGM-call
      2. Event-job-ended
Parent topic: Event Scenarios


Event Logging

There is no currently no support for logging Interactive TSO activity or for the TSO execution in JCL (TSO in batch). JCL activity is logged in the MVS data set MFMVS.SYSLOG.

You can use the user exit to control the logging of the implemented events as follows:

  • If log-event-on is set to true, the default, all events are logged along with the action requested by the user exit.
  • If log-event-on-action is set to true, only events that request an explicit action (action codes other than action-continue and action-shut-exit) are logged along with the action requested by the user exit.
  • If log-event-off is set to true, none of the events are logged.

This logging state persists until it is changed again by the user exit. You can change the logging state as often as required.

Parent topic: Using JCL User Exits


User Exit Interface Block (mfjdxit.cpy)

This section presents a listing of the mfjdxit.cpy copybook used by JXIT. The source for this copybook is in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source.

*===============================================================
*   Copyright (C) Micro Focus International Ltd.
*===============================================================
*
*  MFJDXIT - JCL User Exit Control Block
*    Contains interface information and is passed as a parameter
*    to the JCL user exit (MFJUXIT) which is invoked as
*       call  'MFJUXIT' using JXIT
*
*  Notes:
*    1. It should be included as follows (e.g.)
*         1 JXIT.
*         COPY MFJDXIT REPLACING ==(tag)== BY ==JXIT==.
*    2. Fields beginning with JXIT-I- ( (tag)-I- ) are Input
*       to the user exit and must not be modified
*       e.g. JXIT-I-size
*    3. Fields beginning with JXIT-U- ( (tag)-U- ) are Input and
*       Output. On entry to the user exit, they are set as
*       appropriate and may be changed by the user exit to an
*       acceptable value upon return.
*       e.g. (tag)-U-PGM-alias
*    4. All data is ASCII(ANSI). Null values are those appropriate
*       for the data type. i.e. blanks for character data,
*       zeros for numeric and binary data
*
*
*===============================================================

*===============================================================
* Header
*===============================================================
     3 (tag)-I-header.
*      Size of this block
       5 (tag)-I-size        pic s9(8) comp.
*      Unless otherwise noted, all events occur for
*      JCL, TSO, and TSO-in-batch (PGM=IKJEFTxx or IDAEFTxx)
*      Event code of event. Ignore undefined event codes.
       5 (tag)-I-event       pic s9(8) comp.
*        The following events occur for JCL and TSO-in-batch
*        and represent execution of a JCL JOB stream
         88 (tag)-I-event-job-ready        value  1.
         88 (tag)-I-event-job-flushed      value  2.
         88 (tag)-I-event-job-started      value  3.
         88 (tag)-I-event-job-JCL-error    value  4.
         88 (tag)-I-event-job-ended        value  5.
*        The following events occur for an interactive TSO
*        session only
         88 (tag)-I-event-TSO-started      value  6.
         88 (tag)-I-event-TSO-ended        value  7.
*        The following events occur for JCL and TSO-in-batch
*        and represnt execution of "EXEC PGM=" JCL stmt
         88 (tag)-I-event-step-ready       value  8.
         88 (tag)-I-event-step-started     value  9.
         88 (tag)-I-event-step-ended       value 10.
         88 (tag)-I-event-step-bypassed    value 11.
*        The following events occur for TSO and TSO-in-batch
*        (IKJEFT01) and
*        ... represent execution of the TSO "CALL pgm" command
         88 (tag)-I-event-CALL-ready       value 12.
         88 (tag)-I-event-CALL-started     value 13.
         88 (tag)-I-event-CALL-ended       value 14.
*        ... represent execution of the DSN subcommand
*            "RUN PROG(pgm)"
         88 (tag)-I-event-RUN-ready        value 15.
         88 (tag)-I-event-RUN-started      value 16.
         88 (tag)-I-event-RUN-ended        value 17.
*        All of the above events occur in the parent process,
*        The process in which the job/step preparation occurs.
*
*        The following events occur for all environments
*        for execution of a program following all
*        "...-started" events.
*        ***Note*** that these events occur in the child process
*        that executes the program. Any working storage used by
*        the user exit will not be the same as that for
*        other events which occur in the parent process.
*        In the parent process, your user exit will not remember
*        information prior to "event-before-PGM-call" or after
*        "event-after-PGM-call". Since both of these events
*        occur in the shild process, the user exit will be
*        able to remember information between these two events.
         88 (tag)-I-event-before-PGM-call  value 18.
         88 (tag)-I-event-after-PGM-call   value 19.

*===============================================================
* Action codes for all events. Upon return from the user exit,
* action code indicates next course of action to be taken.
* Upon entry to the user exit, it is set to zero.
*===============================================================
       5 (tag)-U-action      pic s9(8) comp.
*        The JCL engine should continue as if the exit were
*        never invoked. Any modified data will be ignored.
         88 (tag)-U-action-continue         value 0.
*        The JCL engine should not call the exit any more in
*        this process for this job/TSO session
         88 (tag)-U-action-shut-exit        value 1.

*===============================================================
*        Action codes for: event-job-ready
*===============================================================
*          The JCL engine should use all modified
*          fields except pc-fname
           88 (tag)-U-action-MVS-dsn        value 2.
*          The JCL engine should use all modified
*          fields except MVS-dsn
           88 (tag)-U-action-pc-fname       value 3.
*          The JCL engine should flush the job
           88 (tag)-U-action-flush          value 4.

*===============================================================
*        Action codes for: event-step-ready
*                          event-CALL-ready
*                          event-RUN-ready
*===============================================================
*          The JCL engine should use all modified fields
           88 (tag)-U-action-PGM-info       value 5.
*          The JCL engine should abend this step/program.
*          The step/program will be abended with
*          S822 (Region not available)
           88 (tag)-U-action-abend          value 6.

*===============================================================
*        Action codes for: event-job-ended
*                          event-TSO-ended
*                          event-step-ended
*                          event-CALL-ended
*                          event-RUN-ended
*===============================================================
*          The JCL engine should use all modified fields
           88 (tag)-U-action-term-info      value 7.

*===============================================================
*        Action codes for: event-job-started
*                          event-job-flushed
*                          event-job-JCL-error
*                          event-TSO-started
*                          event-step-bypassed
*                          event-step-started
*                          event-CALL-started
*                          event-RUN-started
*                          event-before-PGM-call
*                          event-after-PGM-call
*         - No Action codes defined other than 0
*===============================================================

       5                     pic x(20).

*===============================================================
* Event related data - varies by event
*===============================================================
     3 (tag)-I-data          pic x(368).

*===============================================================
* Data for: event-job-ready
*===============================================================
     3                                   redefines (tag)-I-data.
       5 (tag)-I-data-job-ready.
*        Job number
         7 (tag)-I-jobnum-assigned pic 9(5).
*        Fully qualified PC file name.
         7 (tag)-U-pc-fname      pic x(260).
*        If available, MVS data set name (including member if
*        a PDS) assoicated with pc-fname, otherwise blanks.
*        e.g. MFIDSA.CNTL(MYJOB) (for a PDS member) or
*             S0310.S070508.J01364.D00002.SYSUT2 (for PS)
         7 (tag)-U-MVS-dsn       pic x(54).
*
         7 (tag)-I-submit-type   pic x(1).
           88 (tag)-I-submit-type-exec value 'E'.
           88 (tag)-I-submit-type-scan value 'S'.
         7 (tag)-I-animate       pic x(1).
           88 (tag)-I-animate-on       value 'Y'.
           88 (tag)-I-animate-off      value 'N'.

*===============================================================
* Data for: event-job-flushed
*   See event-job-ready.
*     - Only the first field is relevant
*===============================================================

*===============================================================
* Data for: event-job-started
*           event-job-JCL-error
*           event-TSO-started
*           event-step-bypassed
*     - Field names containing "step" are irrelevant for non-step
*       related events
*===============================================================
     3                                   redefines (tag)-I-data.
       5 (tag)-I-data-job-started.
         7                       pointer.
         7                       pointer.
         7                       pointer.
*
*        Active System and Subsystems combinations are:
*               System Subsystem
*               ----------------
*               JCL    JCL
*               JCL    TSO  (IKJEFTxx)
*               JCL    IMS  (DFSRC000)
*               TSO    TSO
*               TSO    IMS  (CALL DFSRC000)
*               IMS    IMS
*               CICS   CICS
*
*        Active system
         7 (tag)-I-system          pic x.
           88  (tag)-I-system-JCL  value x'00'.
           88  (tag)-I-system-TSO  value x'01'.
           88  (tag)-I-system-ims  value x'02'.
           88  (tag)-I-system-cics value x'03'.
           88  (tag)-I-system-null value x'04'.
*        Active subsystem
         7 (tag)-I-subsystem           pic x.
           88  (tag)-I-subsystem-JCL   value x'00'.
           88  (tag)-I-subsystem-TSO   value x'01'.
           88  (tag)-I-subsystem-ims   value x'02'.
           88  (tag)-I-subsystem-cics  value x'03'.
           88  (tag)-I-subsystem-null  value x'04'.
         7 (tag)-I-jobname   pic x(8).
         7 (tag)-I-userid    pic x(8).
         7 (tag)-I-jobstep   pic x(8).
         7 (tag)-I-procstep  pic x(8).
         7 (tag)-I-jobnum    pic 9(5).
         7 (tag)-I-stepnum   pic 9(3).
         7 (tag)-I-procstepnum pic 9(3).
         7                   pic x(1).
         7                   pic x(1).
         7 (tag)-I-msgclass  pic x(1).
         7 (tag)-I-msglevel1 pic x(1).
         7 (tag)-I-msglevel2 pic x(1).
         7                   pic x.
         7                   pic x(1).
*        Dates in YYYYMMDD format, times in HHMMSShh
         7 (tag)-I-job-start-date pic 9(8).
         7 (tag)-I-job-start-time pic 9(8).
         7 (tag)-I-step-start-date pic 9(8).
         7 (tag)-I-step-start-time pic 9(8).

*===============================================================
* Data for: event-job-ended
*           event-TSO-ended
*           event-step-ended
*           event-CALL-ended
*           event-RUN-ended
*           event-after-PGM-call
*   See event-job-started
*     - plus the following data
*===============================================================
       5 (tag)-U-data-job-ended.
         7 (tag)-U-term-type                 pic x.
           88 (tag)-U-term-type-normal       value x'00'.
           88 (tag)-U-term-type-user-abend   value x'01'.
           88 (tag)-U-term-type-sys-abend    value x'02'.
           88 (tag)-U-term-type-RTS-err      value x'03'.
           88 (tag)-U-term-type-RU-err       value x'04'.
           88 (tag)-U-term-type-unknown      value x'05'.
         7                                   pic x(3).
         7 (tag)-U-term-return-code          pic s9(8) comp.
         7 (tag)-U-term-reason-code          pic s9(8) comp.

*===============================================================
* Data for: event-step-ready
*           event-step-started
*           event-CALL-ready
*           event-CALL-started
*           event-RUN-ready
*           event-RUN-started
*           event-before-PGM-call
*   See event-job-started
*     - Plus the following data
*     - Field names containing "step" are relevant
*===============================================================
       5 (tag)-I-data-step-ready.
         7 (tag)-I-PGM-name          pic x(8).
         7 (tag)-U-PGM-alias         pic x(8).
         7 (tag)-U-PGM-parm.
           9 (tag)-U-PGM-parm-len    pic s9(4) comp.
           9 (tag)-U-PGM-parm-txt    pic x(100).

*= End of MFJDXIT ==============================================
Parent topic: Using JCL User Exits


Using JCL Subsystem Exits

  • Introduction
  • SUBSYS with DD Statements and SVC 99 Text Units
  • Subsystem Exit Invocation, Rules, and Guidelines
  • Events and Actions
    For each event, this section defines the key (but not all) inputs and outputs and the actions that can be requested for the event.
  • Interaction with the Enterprise Server Printer Exit
  • Subsystem Exit Interface Block (mfjdsxit.cpy)
  • Subsystem Exit for OODA Subsystem (mfjyooda.cbl)
  • JCL (subsys1b.jcl)
Parent topic: JCL Support


Introduction

JCL provides a facility known as the JCL Subsystem Exit (SUBSYS), which allows an installation to customize the behavior required by a subsystem by monitoring events and controlling the resultant actions performed by the system.

Parent topic: Using JCL Subsystem Exits


SUBSYS with DD Statements and SVC 99 Text Units

SUBSYS can be specified as a keyword on a DD statement and as a Text Unit (TU) on SVC 99. In call cases, the syntax is equivalent to:

SUBSYS=(subsystem-name[,subsystem-subparameter]...)

Where :

  • subsystem-name is a 1-4 character subsystem name
  • subsystem-subparameter is 0-254 parameter strings, each 0-67 characters in length and separated by commas

For example, on the DD statement:

//someddn DD SUBSYS=(OODA,A,DKP39CPM,’PPP3’,STD,,USER),
    //           DSN=MFIDSA.SUBSYS1B.NEW.OODA.NOTUSED,
    //           OUTPUT=(*.OUTSJ,*.OUTHORSE)
  • subsystem-name is OODA
  • subsystem-subparameter strings are A, DKP39CPM, PPP3, etc. These treated as if it were coded as single 30-character string OODA,A,DKP39CPM,PPP3,STD,,USER
  • SUBSYS processing
Parent topic: Using JCL Subsystem Exits


SUBSYS processing

If the DD statement has the SUBSYS keyword and the subsystem-subparameter string contains DDNAME=x anywhere in the string, it is processed as if DDNAME=x was coded on the DD statement. This applies only to the JCL DD statement regardless of the subsystem-name. It does not apply to SVC99 Text Units (TUs).

For each DD with SUBSYS, the exit is given control once just before resource allocation. It is not given control during execution for other events such as OPEN, CLOSE and WRITE.

Parent topic: SUBSYS with DD Statements and SVC 99 Text Units


Subsystem Exit Invocation, Rules, and Guidelines

The user exit, which must be named MFJYssss, and where ssss is the subsystem-name, is optional and is invoked as follows:

CALL 'MFJYssss' USING SXIT

Where SXIT is the user exit interface block (mfjdsxit.cpy). It contains

  • A header part that contains among other items, the event code of the event and the action code that represents the action that can be requested.
  • A data part that contains the data describing the event.

mfjdsxit.cpy describes in detail all of the event codes, actions codes, and the data associated with each event. When looking at mfjdsxit.cpy, note the following:

  • Field names containing -I- (for example SXIT-I-size) are input to the subsystem exit and must not be modified.
  • Field names containing -U- (for example SXIT-U-PGM-alias) are used for input and output. On entry to the subsystem exit, they are set as appropriate and may be changed by the subsystem exit to an acceptable value upon return.
  • All character data is in ASCII (ANSI). Null values are those appropriate for the data type; that is blanks for character data, and zeros for numeric and binary data.

The subsystem exit is called as events occur.

If the user exit fails for any reason, it is disabled in the failing process for all subsequent events.

Note:
  • The user exit must be named mfjyssss.cbl. The source for each sample exit is available in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source. We recommend you use this as the base to build an exit to suit your needs. It uses a copybook for SXIT (the subsystem exit interface block). The source for this copybook, mfjdsxit.cpy, is in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source. A listing of mfjdsxit.cpy is provided in the topic Subsystem Exit Interface Block (mfjdsxit.cpy).
  • The subsystem exit must use the ASCII (ANSI) character set. We recommend that it uses the non-mainframe COBOL dialect as it is a PC-specific program.
  • The exit is optional. The .int, .gnt, or .dll file for the subsystem exit must be placed in a directory that is specified in the search path of PATH.
  • You must write the subsystem exit in COBOL.
Parent topic: Using JCL Subsystem Exits
Related information
Subsystem Exit Interface Block (mfjdsxit.cpy)


Events and Actions

For each event, this section defines the key (but not all) inputs and outputs and the actions that can be requested for the event.

Event-specific data

The following action applies to all events:
  • The action-continue action code (which is the default action code) indicates to the system that it should continue with normal processing as if the exit had never been invoked for that event.

The event names listed below correspond in part to the level-78 name assigned to the event code. Similarly, action code names listed correspond in part to the level-78 name assigned to the action code. Having access to mfjdsxit.cpy, mfjyooda.cbl and subsys1b.jcl files will help your understanding of the facilities being described here.

This event indicates that the source for the DD is about to be allocated. The purpose of this event is to allow the subsystem exit to verify and/or modify the DD that is being processed.

This event and Event-before-PGM-call occur in the child process. All other events occur in the parent process. Your exit cannot remember any events that occurred in the parent process.

Data available for this event includes:
  • The subsystem-subparameter string length
  • A pointer to the subsystem-subparameter string
  • A dataset name if available
  • The type of dataset (permanent, SYSOUT, etc.)
The exit can view or change the information and request that the system use the changed information. The information that can be changed includes:
  • The subsystem-subparameter string length
  • The subsystem-subparameter string
  • The type of dataset
Actions that can be requested:
  • action-use-updated-data
Parent topic: Using JCL Subsystem Exits


Interaction with the Enterprise Server Printer Exit

If the exit changes the DD to a SYSOUT, the printer exit is, in addition to accessing normal sysout related information such as OUTPUT statements, able to access subsystem-subparameter string information allowing further customization of the produced sysout output.

Parent topic: Using JCL Subsystem Exits


Subsystem Exit Interface Block (mfjdsxit.cpy)

This section presents a listing of the mfjdsxit.cpy copybook used by SXIT.

For the most up-to-date information refer to the source for this copybook in your product installation.

 *>==============================================================
      *> Copyright ©) 1997-2008 Micro Focus (IP) Ltd.
      *>   All rights reserved.
      *>
      *> This sample source code is provided for use by users of
      *> Micro Focus products (the "Software") and may be used,
      *> modified and distributed as part of your application provided
      *> that you properly acknowledge the copyright of Micro Focus in
      *> this material.
      *>
      *> All conditions, warranties and undertakings, express or implied,
      *> statutory or otherwise, on the part of Micro Focus are excluded,
      *> including without limitation those of merchantability or fitness
      *> for purpose. This shall not, however, purport to exclude or
      *> restrict the liability of Micro Focus to any extent not
      *> permitted by law.
      *>
      *> IN NO EVENT WILL MICRO FOCUS BE LIABLE FOR ANY INDIRECT,
      *> INCIDENTAL, SPECIAL, CONSEQUENTIAL OR OTHER DAMAGES ARISING OUT
      *> OF THE USE OF THE DEMONSTRATION PROGRAM DISTRIBUTED WITH THE
      *> SOFTWARE, WHETHER OR NOT INFORMED OF THE POSSIBILITIES OF
      *> DAMAGES IN ADVANCE.  THESE LIMITATIONS APPLY TO ALL CAUSES OF
      *> ACTION, INCLUDING BREACH OF CONTRACT, BREACH OF WARRANTY, STRICT
      *> LIABILITY, AND ANY ACTIONS IN TORTS.
      *>==============================================================

      *>==============================================================
      *> mfjdsxit - Micro Focus Subsystem user exit parameter block
      *>   Contains interface information and is passed as a parameter
      *>   to the subsystem exit which is ivoked as:
      *>      call  subsys-exit using sxit
      *>
      *> Notes:
      *>   1. It should be included as follows (e.g.)
      *>        copy mfjdsxit replacing ==()== by ==sxit==.
      *>   2. Fields beginning with sxit-I- ( ()-I- ) are Input
      *>      to the subsystem exit and must not be modified
      *>      e.g. sxit-I-size
      *>   3. Fields beginning with sxit-U- ( ()-U- ) are Input and
      *>      Output. On entry to the subsystem exit, they are set as
      *>      appropriate and may be changed by the subsystem exit to
      *>      an acceptable value upon return.
      *>      e.g. ()-U-ds-type
      *>   4. All data is ASCII(ANSI). Null values are those appropriate
      *>      for the data type. i.e. blanks for character data,
      *>      zeros for numeric and binary data
      *>==============================================================
         1 ().
           3 ()-header.
             5 ()-I-size           pic x(2) comp-x. *>Size of this blk
             5 ()-I-event          pic x(2) comp-x. *> event code
                  *> this event occurs before DD is allocated
               78 ()-I-event-dd-alloc-pre        value  1.
             5 ()-U-action         pic x(2) comp-x. *>action requested
               *> The system should continue as if the exit were
               *> never invoked. Do not modify any data.
               78 ()-U-action-continue            value 0.
               *> The system should use updated data and continue.
               78 ()-U-action-use-updated-data    value 4.
               *> Others - TBD
             5                     pic x(2) comp-x.
           3 ()-data.
             5 ()-I-jseb-ptr       pointer.
             5 ()-U-ds-name-ptr    pointer.
             5 ()-U-ds-type        pic x(1).
               78 ()-U-ds-type-perm     value x'00'.
               78 ()-U-ds-type-temp     value x'80'.
               78 ()-U-ds-type-dummy    value x'40'.
               78 ()-U-ds-type-sysout   value x'20'.
               78 ()-U-ds-type-terminal value x'10'.
               78 ()-U-ds-type-pc       value x'08'.
             5                     pic x(3).
               *>  DD statement SUBSYS= value length
             5 ()-U-subsys-len     pic x(4) comp-x.
               *> if SUBSYS= value length (previous field) is non-zero,
               *> a ptr to entire (including subsystem name, the 1st
               *> subparameter) DD SUBSYS= string
             5 ()-U-subsys-ptr     pointer.
             5                     pic x(20).
      *>==============================================================
Parent topic: Using JCL Subsystem Exits


Subsystem Exit for OODA Subsystem (mfjyooda.cbl)

This exit, for event-dd-alloc-pre, changes the following listed items and requests, with action-use-updated-data, that the changed information be used to allocate the DD, thus allocating it as a SYSOUT.
  • Dataset type to SYSOUT
  • Dataset name pointer to null

It also verifies that it received the expected subsystem-subparameter string.

For the most up-to-date information refer to the source for this copybook in your product installation.

 *>==============================================================
*> Use directives at least: /CHARSET"ASCII"
*> /DIALECT"MF"
/DEFAULTBYTE"00"
*>==============================================================
*> Copyright ©) 1997-2008 Micro Focus (IP) Ltd.
*> All rights reserved.
*>
*> This sample source code is provided for use by users of
*> Micro Focus products (the "Software") and may be used,
*> modified and distributed as part of your application provided
*> that you properly acknowledge the copyright of Micro Focus in
*> this material.
*>
*> All conditions, warranties and undertakings, express or implied,
*> statutory or otherwise, on the part of Micro Focus are excluded,
*> including without limitation those of merchantability or fitness
*> for purpose. This shall not, however, purport to exclude or
*> restrict the liability of Micro Focus to any extent not
*> permitted by law.
*>
*> IN NO EVENT WILL MICRO FOCUS BE LIABLE FOR ANY INDIRECT,
*> INCIDENTAL, SPECIAL, CONSEQUENTIAL OR OTHER DAMAGES ARISING OUT
*> OF THE USE OF THE DEMONSTRATION PROGRAM DISTRIBUTED WITH THE
*> SOFTWARE, WHETHER OR NOT INFORMED OF THE POSSIBILITIES OF
*> DAMAGES IN ADVANCE. THESE LIMITATIONS APPLY TO ALL CAUSES OF
*> ACTION, INCLUDING BREACH OF CONTRACT, BREACH OF WARRANTY, STRICT
*> LIABILITY, AND ANY ACTIONS IN TORTS.
*>==============================================================

*>==============================================================
*> Note that subsystem exit is ways named as MFJYssss, where
*> ssss is the subssystem name (1st sub-parameter of SUBSYS=)
*>==============================================================

*>==============================================================
*> SUBSYS Subsystem exit for OODA subsystem
*>==============================================================

identification division.
program-id. MFJYOODA.
environment division.
file-control.
data division.
*>=============================================================
working-storage section.
77 subsys-val-expected pic x(30)     value
                    'OODA,A,DKP39CPM,PPP3,STD,,USER'.
77 msg-dest-both       pic 9(8) comp value 0.
77 msg-len             pic 9(8) comp value 80.
77 msg-txt             pic x(80).
77 w-len               pic 99999.
linkage section. copy "mfjdsxit.cpy" replacing ==()== by ==sxit==.
01 subsys-val          pic x(32000).

*>=============================================================
procedure division using by reference sxit.

* Dsa temp >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
* call 'CBL_DEBUGBREAK'
* Dsa temp <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
            evaluate sxit-I-event
    when sxit-I-event-dd-alloc-pre
      *>=======================================================
      *> DD is about to be allocated. Change to SYSOUT=*
      *>=======================================================
      move sxit-U-ds-type-sysout to sxit-U-ds-type
      set sxit-U-ds-name-ptr to null
      move sxit-U-action-use-updated-data to sxit-U-action
      *>=======================================================
      *> The code below is informational only. Note that
      *> - sxit-U-subsys-ptr points to the the entire
      *>   SUBSYS string with syntactic quotes removed.
      *> - sxit-U-subsys-len is the length of the string
      set address of subsys-val to sxit-U-subsys-ptr
      if sxit-U-subsys-len <> length subsys-val-expected
        move sxit-U-subsys-len to w-len
        move ' ' to msg-txt
        string 'MFJYOODA - Length should be 30 but is '
                                            delimited by size
                w-len                       delimited by size
        into msg-txt
        call 'MFJZLOG' using msg-dest-both msg-len msg-txt
      end-if
      if subsys-val(1:length subsys-val-expected) <>
         subsys-val-expected
        move ' ' to msg-txt
        string 'MFJYOODA - Value incorrect. It is '
                                             delimited by size
                subsys-val(1:length subsys-val-expected)
                                             delimited by size
        into msg-txt
        call 'MFJZLOG' using msg-dest-both msg-len msg-txt
      end-if
      *> move subsys-val(1:sxit-U-subsys-len) to ...
      *>=======================================================
      goback
    when other
      *>=======================================================
      *> Ignore all other events
      *>=======================================================
      continue
  end-evaluate
  goback.
  *>===========================================================
Parent topic: Using JCL Subsystem Exits


JCL (subsys1b.jcl)

For the most up-to-date information refer to the source for this copybook in your product installation.

//MFIDSA1B JOB 'SUBSYS TESTS - VIA JCL',CLASS=A,MSGCLASS=A
  //OUTSJ    OUTPUT CLASS=X,DEST=SANJOSE.DAVINDER,DEFAULT=YES
  //OUTNWB   OUTPUT CLASS=Y,DEST=GARDEN.CLIVE,DEFAULT=YES
  //OUTHORSE OUTPUT CLASS=M,DEST=HORSES.THAIUSER,DEFAULT=NO
  //*-------------------------------------------------------------------
  //STEP1 EXEC PGM=IDCAMS
  //SYSPRINT DD SYSOUT=*
  //SYSUTX DD *
  REC1
  REC2
  //SYSIN DD *
  REPRO IFILE(SYSUTX) OFILE(OODA )
  REPRO IFILE(SYSUTX) OFILE(NONE )
  //OODA DD SUBSYS=(OODA,A,DKP39CPM,PPP3,STD,,USER),
 //        DSN=MFIDSA.SUBSYS1B.NEW.OODA.NOTUSED,
 //        OUTPUT=(*.OUTSJ,*.OUTHORSE)
 //NONE DD SUBSYS=(NONE,A,DKP39CPM,PPP3,STD,,USER),
 //        DSN=MFIDSA.SUBSYS1B.NEW.NONE.DELETED,
 //        OUTPUT=(*.OUTSJ,*.OUTHORSE)
//
Parent topic: Using JCL Subsystem Exits


REXX Support

  • Introduction
  • JCL Environment
  • Passing Parameters
  • Including Host Commands
  • Debugging an Exec
    You can use the REXX debugging facility to help you debug an exec. It lets you interact with the exec while it is running and monitor the values of variables.
  • Specifying Record Length for Zero-length Line Sequential Files
  • Specifying Alternative Characters for the OR, NOT and CONCAT Operators
  • Restrictions
Parent topic: JCL Support


Introduction

REXX is a high-level language with extensive facilities for manipulating text. CLISTs are not supported under Enterprise Server so we recommend that you convert your CLISTs to REXX programs.

For more information about the REXX language and how it is used, see the IBM OS/390 TSO/E REXX Reference and IBM OS/390 TSO/E REXX User's Guide.

A REXX program is called an exec. Before running an exec, you need to add the exec to your project, or download it from the mainframe, in the usual way. All REXX execs should start with a comment containing the character string REXX so that they can be distinguished from TSO CLISTs. For example:

/************** REXX **************/

REXX execs should have the file extension .rex.

Optionally, you can define an exec as a member of a partitioned data set (PDS). The DD names SYSEXEC and SYSPROC are normally used for PDSs containing REXX execs. More than one PDS can be allocated to each of these DD names. A SYSEXEC PDS can contain only execs.

MSS assumes that your execs are in the same location as your JCL applications, that is, the location specified in JES Program Path on the Edit Server > Properties > JES page.

MSS interprets an exec as it is run. There are no preceding compilation and linking stages.

MSS supports the use of REXX execs only in the JCL (non-TSO) environment. This can be used for execs that do not need interaction with the user and do not need access to TSO services.

Parent topic: REXX Support
Related information
JCL (non-TSO) environment


JCL Environment

In the JCL environment, you can use the IRXJCL utility to run a REXX exec.

For example, the following JCL jobstream runs the REXX exec named jcltest in the PDS named userid.rexx.exec that has been allocated to SYSEXEC.

//jobname  JOB ............
//*
//jobstep  EXEC PGM=IRXJCL,PARM='JCLTEST'
//SYSEXEC  DD DSN=USERID.REXX.EXEC,DISP=SHR
//SYSTSPRT DD SYSOUT=A
//SYSTSIN  DD *
input to exec
/*
//
Parent topic: REXX Support


Passing Parameters

You can pass parameters to a REXX exec in the usual way, for example:

  • rexx(add) 42 21 exec
  • add 42 21
  • %ADD 42 21
  • //jobstep  EXEC PGM=IRXJCL,PARM='ADD 42 21'

In the exec named add, you can use an ARG instruction to receive the two parameters, 42 and 21.

Parent topic: REXX Support


Including Host Commands

You can include a host command in a REXX exec by enclosing it in quotation marks, for example:

"EXECIO * DISKR MYINDD (FINIS STEM MYVAR"

The REXX language processor passes the command and any other source code that it does not recognize to the host command environment for execution.

MSS emulates the MVS host command environment. If you use a host command that is not recognized by the environment, the return-code variable RC is set to -3.

You can use the ADDRESS built-in function to find the name of the current environment and the ADDRESS instruction to change it.

Parent topic: REXX Support


Debugging an Exec

You can use the REXX debugging facility to help you debug an exec. It lets you interact with the exec while it is running and monitor the values of variables.

The TRACE instruction lets you start and control the debugging facility from within an exec.

Parent topic: REXX Support


Specifying Record Length for Zero-length Line Sequential Files

The MFREXX_LSEQ_RECSIZE_MAX environment variable enables you to specify the record length for the REXX EXECIO command when reading or writing a line sequential file that has been cataloged with a record length of zero.

You should set the environment variable before you start the enterprise server in the Configuration Information field on the Add Server or Edit Server pages of ES Admin, as follows:

[ES-Environment]
MFREXX_LSEQ_RECSIZE_MAX=rec-length

Alternatively, you can set in on the command line before you start the enterprise server:

SET MFREXX_LSEQ_RECSIZE_MAX=rec-length

where rec-length is the record length to use. The default is 255, which is the minimum value you can use. Specifying an invalid value, or a value less than 255, results in the default value being used.

Parent topic: REXX Support


Specifying Alternative Characters for the OR, NOT and CONCAT Operators

If you need to use characters other than the defaults for REXX's OR, NOT and CONCAT operators, MSS enables you to do this using three environment variables: MFREXX_OR, MFREXX_NOT and MFREXX_CONCAT. You must set these environment variables before you start the enterprise server for them to take effect, either in the Configuration Information field on the Add Server or Edit Server pages of ES Admin or on the command line.

You can specify one or more characters for each operator, and each character you specify is used in addition to the default operator; that is "|" for OR, "¬" for NOT and "||" for CONCAT. When specifying additional characters, you must ensure that each additional character is defined in single or double quotes, or in hexadecimal. When specifying more than one character, separate each one with a space or comma. Any error in the specification of the additional characters, including the specification of alphabetic or numeric characters, results in the environment variable being ignored.

  • Examples:
Parent topic: REXX Support


Examples:

[ES-Environment]
MFREXX_NOT="^"
MFREXX_NOT=0x5e "!"
MFREXX_NOT=X'5e' '!' "~"
Parent topic: Specifying Alternative Characters for the OR, NOT and CONCAT Operators


Restrictions

The following mainframe REXX facilities are not supported by MSS:

  • Sequence numbers in the last eight bytes of fixed-length source records are recognized but no checking is done on the order of these numbers. Sequence numbers in variable-length records are not recognized.
  • The TRACE S instruction is syntactically allowed but does not trace the remaining clauses in the exec. The exec is fully syntax checked when it is first loaded.
  • Numeric options entered during interactive debugging are not supported.
  • CICS REXX is not supported.
  • Compiled REXX execs are not supported.
  • APPCMVS, ATTACH, ATTACHMVS, ATTACHPGM, CONSOLE, CPICOMM, ISPEXEC, ISREDIT, LINK, LINKMVS, LINKPRM, and LU62 host command environments are not supported:
  • User-defined host command environments are not supported.
  • The following REXX programming services are not supported:
    • IRXEXCOM - variable access routine
    • IRXEXEC - exec processing routine
    • IRXHLT - halt condition routine
    • IRXIC - trace and execution control routine
    • IRXINIT - initialization routine
    • IRXLIN - LINESIZE function routine
    • IRXRLT - get result routine
    • IRXSAY - SAY instruction routine
    • IRXSUBCM - maintain entries in the host command environment table
    • IRXTERM - termination routine
    • IRXTXT - text retrieval routine
  • Replaceable routines and exits are not supported.
  • DBCS is not supported.
Parent topic: REXX Support


Integration with CICS Support

  • Overview
  • CICS Resources for the Internal Reader
  • Creating a CICS Application to write JCL
  • Creating a TN3270 Listener
  • Running the Application
Parent topic: JCL Support


Overview

You can submit JCL from a CICS application, using the Micro Focus emulation of the IBM External Writer, INTRDR.

Note: In Micro Focus documentation, an external writer is more accurately referred to as an internal reader when in a JCL context.

In order to submit JCL from a CICS application running in an enterprise server, you need to:

  1. Create some CICS resources in a new group and add them to the CICS application's startup list.
  2. Create a CICS application that writes the JCL to a transient data queue, or modify an existing application.
  3. Create a TN3270 listener for CICS applications, if you don't already have one.
Parent topic: Integration with CICS Support


CICS Resources for the Internal Reader

You need to create the following resources to enable a CICS application to submit JCL:

  • A resource group to contain the new resources. You should supply the following fields:
    Name | A name for the group, for example, CICSJCL
    Description | A suitable description, for example, "Submit JCL from CICS"
  • A DCT (destination control table) entry for the internal reader. A DCT entry describes a transient data queue. You should supply the following fields:
    Name | A name for the DCT entry, for example, IRDR
    Description | A suitable description, for example, "Internal reader DCT entry"
    Type | Choose Internal Rdr from the list
    Initial State | Choose Open from the list

When you have created these new resources, you should add the group to the startup list for JCL applications.

For these changes to take effect, you must stop then restart the enterprise server you are using.

Parent topic: Integration with CICS Support


Creating a CICS Application to write JCL

The CICS application should write the JCL job stream to the transient data queue (DCT) that you defined in ESMAC, using the CICS command WRITEQ TD.

You need to compile the program with a non-mainframe dialect specified, and with the CICSECM directive set.

Example

 working-storage section.
 78 78-table-size value 22.
 01 ws-table.
     02 value '//CPJTEST JOB ''CPJX'',CLASS=A,MSGCLASS=A ' pic x(80).
     02 value '//*   NOTIFY=CPJ,                         ' pic x(80).
     02 value '//*   USER=CPJ,                           ' pic x(80).
     02 value '//*   PASSWORD=WIBBLE                     ' pic x(80).
     02 value '//*                                       ' pic x(80).
     02 value '//STEP00   EXEC PGM=IEFBR14               ' pic x(80).
     02 value '//A DD DUMMY                              ' pic x(80).
     02 value '//*                                       ' pic x(80).
     02 value '//DUMMY EXEC PGM=IEFBR14                  ' pic x(80).
     02 value '//NEWDSN DD DSN=MFICPJ.WORK.DATA,         ' pic x(80).
     02 value '//       DISP=(,CATLG),                   ' pic x(80).
     02 value '//       DCB=(LRECL=80,RECFM=FB,DSORG=PS),' pic x(80).
     02 value '//       SPACE=(800,(10,10)),UNIT=SYSDA   ' pic x(80).
     02 value '//*                                       ' pic x(80).
     02 value '//GENER EXEC PGM=IEBGENER                 ' pic x(80).
     02 value '//SYSPRINT DD SYSOUT=*                    ' pic x(80).
     02 value '//SYSUT1 DD *                             ' pic x(80).
     02 value 'Rec 1                                     ' pic x(80).
     02 value 'Rec 2                                     ' pic x(80).
     02 value '//SYSUT2 DD SYSOUT=*                      ' pic x(80).
     02 value '//                                        ' pic x(80).
     02 value '/*EOF                                     ' pic x(80).
 01 redefines ws-table.
     02 ws-table-line occurs 78-table-size times           pic x(80).
 01  ws-queue   value 'IRDR'           pic x(4).
 01  ws-x                              pic x(4) comp-5.
 procedure division.
     exec cics enq
        resource(ws-queue)
     end-exec
     perform varying ws-x from 1 by 1
         until ws-x > 78-table-size
          exec cics writeq td
               queue(ws-queue)
               from (ws-table-line(ws-x))
          end-exec
     end-perform
     exec cics send from(ws-table) erase end-exec
     exec cics return end-exec
     stop run
     .
Parent topic: Integration with CICS Support


Creating a TN3270 Listener

In order for the enterprise server to accept the transaction, you need to define a listener for 3270 terminals.
  1. In the table of servers on the Home page of Enterprise Server Administration, click Details in the Communications Processes cell for the server to which you want to add the listener.
  2. Click Add in the Listeners column for the communications process to which you want to add the listener.
  3. In the Name field, specify a suitable name (for example, tn3270).
  4. Allow Endpoint Protocol to default to TCP.
  5. In Endpoint Address), set the port number for the listener to *.nnnn, where nnnn is a port number. You can use any number above 5000 that isn't in use.
  6. In the Supported Conversation Type group, click TN3270.
  7. Click Add.

    The Communications Processes page is redisplayed showing that the listener was added.

  8. Click Home.
  9. Stop the enterprise server.
  10. Restart the enterprise server.

    This has the effect of starting the listener.

Parent topic: Integration with CICS Support


Running the Application

  1. Associate a transaction ID with the application program. To do this, create a new PCT entry in ESMAC and enter the name of the application program in the Program Name field.
  2. Start your terminal emulator and clear the screen.
  3. Enter the transaction code, that is the name that you gave the PCT entry. This invokes the CICS application which submits the job by writing to the TD queue defined as the internal reader.
Parent topic: Integration with CICS Support


JCL API

There are a number of API calls that you can call from a COBOL program to carry out JCL-type tasks.

  • MFJZABND
    MFJZABND abends the current job step with a system or user abend.
  • MFJZLOG
    MFJZLOG writes a message to the syslog and/or the joblog.
  • MFJZS099
    MFJZS099 issues an SVC 99 call.
  • MFJZLPSA
    MFJZLPSA locates the Prefixed Save Area (PSA).
  • Using DYNamic ALLOCation (DYNALLOC - SVC99) Functions - MFJZS099
Parent topic: JCL Support


MFJZABND

Syntax:

call "MFJZABND" using abend-type abend-code

Parameters:

abend-code | pic 9(8) comp | The abend code.
abend-type | pic 9(8) comp | Type of abend to occur; 0 indicates a user abend; 1 indicates a system abend..
abend-sys | pic 9(8) comp value 1 |
abend-user | pic 9(8) comp value 0 |

Example:

Example 1. To cause an abend with user abend 1004:

77  abend-code                 pic  9(08) comp.
77  abend-type                  pic 9(08)  comp.
77  abend-sys                   pic  9(08) comp value 1.
77  abend-user                  pic  9(08) comp value 0.

...
Move 1004 to abend-code
call 'MFJZABND' using abend-user abend-code

Example 2. To cause an abend with system abend SDED (note that system abend codes are always hex not decimal):

77  abend-code                 pic  9(08) comp.
77  abend-type                  pic 9(08)  comp.
77  abend-sys                   pic  9(08) comp value 1.
77  abend-user                  pic  9(08) comp value 0.
...
Move h’ded’ to abend-code
call 'MFJZABND' using abend-sys abend-code
Parent topic: JCL API


MFJZLOG

Syntax:

call "MFJZLOG" using msg-dest msg-len msg-txt

Parameters:

msg-dest | pic 9(8) comp | Message destination; A value of 1 sends it to the joblog, a value of 2 sends it to syslog, and a value of 0 sends it to both.
msg-dest-both | pic 9(8) comp |
msg-dest-joblog | pic 9(8) comp |
msg-dest-syslog | pic 9(8) comp |
msg-len | pic 9(8) comp | Length of the message text. Message length should be less than 108 bytes if you want to keep the whole message on one line.
msg-txt | x(118) | Text of the message.

Comments:

The message length should be less than 108 bytes if you wish to keep the whole message on one line.

Note:
  • Where the characters in positions 6 ,7, 8 and 9 of your message string are digits (as is the case in the examples below) MFJZLOG assumes that you are supplying your own message code. In all other circumstances, it prepends your message with the default code, 'JCLXM0000I '.
  • If the message string contains the character 'I' at position 10 (as is the case where your original string is prepended with JCLXM0000I) the default user exit casumxit will exclude it from the system log.

Example:

Example 1. To write “MyMsg0001P Hi there!” to both the system log and the job log:

77 msg-dest-both     pic 9(8) comp value 0.
77 msg-dest-joblog   pic 9(8) comp value 1.
77 msg-dest-syslog   pic 9(8) comp value 2.
77  msg-txt          pic x(118) value ' MyMsg0001I Hi there!'.
77  msg-len          pic  9(08) comp value 20.

call 'MFJZLOG' using  msg-dest-both
                           msg-len
                           msg-txt

Example 2. To write “MyMsg0001P Hi there!” to just the job log:

77 msg-dest-both      pic 9(8) comp value 0.
77 msg-dest-joblog    pic 9(8) comp value 1.
77 msg-dest-syslog    pic 9(8) comp value 2.
77  msg-txt           pic x(118) value ' MyMsg0001I Hi there!'.
77  msg-len           pic  9(08) comp value 20.

call 'MFJZLOG' using msg-dest-joblog
                      msg-len
                      msg-txt
Parent topic: JCL API


MFJZS099

Syntax:

call "MFJZS099" using s99rb caller-id returning retcode

Parameters:

s99rb | See below | SVC 99 request block mapped by IDAS99RB.CPY. You may use IDAS99TU.CPY to assist you in the construction of the Text Units (TUs).
caller-id | See Below | While using this parameter is recommended, it is not a requirement for COBOL programs compiled as INTs and GNTs. For non-COBOL programs, it is required and is used by the SVC 99 handler to interpret format of addresses and CHARSET of the character data. Binary data must always in z/OS (Big-Endian) format.
retcode | pic 9(8) comp | SVC 99 return code that would have been placed in the general purpose register 15. All other error and info codes are stored in SVC99RB.

Comments:

SVC99 uses the high-order bit of a TU (Text Unit) address to interpret it as the last TU address in the TU address array.

When the calling program is compiled with NOAMODE, the high order bit of a TU address will not be interpreted as an indication of the last address in the TU pointer array. In this case, you have two options:

  • Make sure the last TU address is indicated by a value of either x’80000000’ or x’00000080’. This will keep the source compatible with the host. If either of these could potentially be a legitimate address on the computer you are running on, then the following option is the only alternative.
  • Specify a last address value of your choice in the extension portion of the SVC99 Request Block (S99RB).

If the calling program is compiled with AMODE, no changes are required. It is recommended that you use a null address to signify the last address. For example, set TU last address to x’80000000’.

Example:

A program running with NOAMODE:

copy idas99rb
        replacing ==()== by ==s99rb==.
    copy idas99tu
        replacing ==()== by ==s99tu==.
    01 caller-id.
       03 caller-id-char               pic x(04) value 'S099'.
       03 caller-id-ptr                pointer.*> ptr to s99rb
       03 caller-id-bin                pic 9(8) comp value 1.
       03 caller-id-float              comp-1 value 1.
    01 .
       03 tu-ptr-list.
          05 tu-ptr-ddn                pointer.
          05 tu-ptr-dsn                pointer.
          05 etc                       pointer.
          05	                       pic x(4) value s99rb-last-ptr-val-x4-val.

     move low-values to s99rb
     move s99rb-len-mf-ext to s99rb-len
     move s99rb-last-ptr-val-x4-val to s99rb-last-ptr-val-x4
     set s99rb-s99tu-array-ptr to address tu-ptr-list
     set caller-id-ptr to address s99rb

     call 'MFJZS099' using  s99rb caller-id returning retcode
     if retcode = 0
        *> SVC99 ok
     else
        *> SVC99 not ok – check for errors
     end-if

A program running with AMODE:

copy idas99rb
        replacing ==()== by ==s99rb==.
    copy idas99tu
        replacing ==()== by ==s99tu==.
    01 caller-id.
       03 caller-id-char               pic x(04) value 'S099'.
       03 caller-id-ptr                pointer.*> ptr to s99rb
       03 caller-id-bin                pic 9(8) comp value 1.
       03 caller-id-float              comp-1 value 1.
    01 .
       03 tu-ptr-list.
          05 tu-ptr-ddn                pointer.
          05 tu-ptr-dsn                pointer.
          05 etc                       pointer.
          05	                       pic x(4) value x'80000000'

     move low-values to s99rb
     move s99rb-len-mf-ext to s99rb-len
     move s99rb-last-ptr-val-x4-val to s99rb-last-ptr-val-x4
     set s99rb-s99tu-array-ptr to address tu-ptr-list
     set caller-id-ptr to address s99rb

     call 'MFJZS099' using  s99rb caller-id returning retcode
     if retcode = 0
        *> SVC99 ok
     else
        *> SVC99 not ok – check for errors
     end-if
Parent topic: JCL API


MFJZLPSA

Syntax:

call 'MFJZLPSA' returning psa-ptr
*   on exception  *> reqd only if run on the mainframe
*   continue
Where:
 psa-ptr will be set to the address of the PSA upon return.

Parameters:

77 psa-ptr pointer

Comments:

This service must be used to locate the PSA if you are running NOAMODE. It can be used all the time regardless of your AMODE or CHARSET.

Example:

77 psa-ptr  pointer.
      call 'MFJZLPSA' returning psa-ptr
      set address of psa   to psa-ptr
      set address of cvt   to psa-cvt
Parent topic: JCL API


Using DYNamic ALLOCation (DYNALLOC - SVC99) Functions - MFJZS099

TI, you can stop reading and keep doing what you are doing.

Note: The following infiormation DOES NOT apply if you are invoking SVC 99 via a z/OS Assembler routine that issues the SVC 99 machine instruction

You invoke the Micro Focus SVC 99 API, MFJZS099, as follows (skeletal code only is shown):

copy idas99rb replacing ==()== by ==s99rb==.
copy idas99tu replacing ==()== by ==s99tu==.
  1 caller-id.
  3 caller-id-char       pic x(04) value 'S099'.
  3 caller-id-ptr  pointer.     *> ptr to s99rb
  3 caller-id-bin pic 9(8) comp value 1.
  3 caller-id-float      comp-1 value 1.
1.
    3 tu-ptr-list.
    5 tu-ptr-ddn   pointer.
    5 tu-ptr-dsn    pointer.
    5 etc       pointer.
   3	  pic x(4) value
       --either—(1)
       x’80000000’
       --or--  (2)
          s99rb-last-ptr-val-x4-val.

     move low-values to s99rb
      --either— (3)
     move s99rb-len-host to s99rb-len
      --or--  (4)
     move s99rb-len-mf-ext to s99rb-len
     move s99rb-last-ptr-val-x4-val to s99rb-last-ptr-val-x4
      --and--
     set s99rb-s99tu-array-ptr to address tu-ptr-list
     set caller-id-ptr to address s99rb

     call 'MFJZS099' using  s99rb
         caller-id
         returning s99rb-retc

    if s99rb-retc = 0
      *> SVC99 ok
    else
      *> SVC99 not ok – check for errors
    end-if

The parameters are:

  • SVC 99 Request Block (mapped by IDAS99RB.CPY). You may use IDAS99TU.CPY to assist you in the construction of the Text Units (TUs).
  • Caller-id. While this parameter (caller-id) is recommended, COBOL programs compiled as INTs and GNTs can omit it. For non-COBOL programs, it is required and is used by the SVC 99 handler to interpret format of addresses and CHARSET of the character data, Binary data must always be in z/OS (Big-Endian) format.
  • Return value in retcode will be the SVC99 return code value that would have been placed in the general purpose register 15. All other error and info codes are stored in SVC99RB.

SVC99 uses the high-order bit of a TU (Text Unit) address to interpret it as the last TU address in the TU address array.

If the calling program is compiled with AMODE, you need not make any changes. It is recommended that you use a null address to signify the last address, i.e. set TU last address to x’80000000’ (see (1) above in declarations section).

When the calling program is compiled with NOAMODE, the high order bit of a TU (Text Unit) address will not be interpreted as an indication of the last address in the TU pointer array. In this case, you have one of two options:

  1. Make sure the last TU address is indicated by a value of either x’80000000’ or x’00000080’ (see (1) and (3) above in declarations section). This will keep the source compatible with the host. If either of these could potentially be a legitimate address on the computer you are running on, then option 2 is the only other alternative.
  2. Specify a specific last address value of your choice in the extension portion of the SVC99 Request Block (S99RB) (see (2 and 4) in the example code declarations section).

Examples

The following is a program running with NOAMODE in effect:

copy idas99rb replacing ==()== by ==s99rb==.
copy idas99tu replacing ==()== by ==s99tu==.
  1 caller-id.
    3 caller-id-char       pic x(04) value 'S099'.
    3 caller-id-ptr  pointer.     *> ptr to s99rb
    3 caller-id-bin pic 9(8) comp value 1.
    3 caller-id-float      comp-1 value 1.
  1  .
    3 tu-ptr-list.
    5 tu-ptr-ddn   pointer.
    5 tu-ptr-dsn    pointer.
    5 etc       pointer.

  4	pic x(4) value
                  s99rb-last-ptr-val-x4-val.

           move low-values to s99rb
           move s99rb-len-mf-ext to s99rb-len
           move s99rb-last-ptr-val-x4-val to s99rb-last-ptr-val-x4
           set s99rb-s99tu-array-ptr to address tu-ptr-list
           set caller-id-ptr to address s99rb

call 'MFJZS099' using  s99rb
                   caller-id
                   returning s99rb-retc
            if s99rb-retc = 0
                    *> SVC99 ok
            else
                    *> SVC99 not ok – check for errors
            end-if

The following is a program running with AMODE in effect:

copy idas99rb replacing ==()== by ==s99rb==.
copy idas99tu replacing ==()== by ==s99tu==.
  1 caller-id.
    3 caller-id-char       pic x(04) value 'S099'.
    3 caller-id-ptr  pointer.     *> ptr to s99rb
    3 caller-id-bin pic 9(8) comp value 1.
    3 caller-id-float      comp-1 value 1.
  1  .
    3 tu-ptr-list.
    5 tu-ptr-ddn   pointer.
    5 tu-ptr-dsn    pointer.
    5 etc       pointer.
  5     pic x(4) value
        x’80000000’

   move low-values to s99rb
   move s99rb-len-host to s99rb-len
   set s99rb-s99tu-array-ptr to address tu-ptr-list
   set caller-id-ptr to address s99rb

   call 'MFJZS099' using  s99rb
       caller-id
       returning s99rb-retc
    if s99rb-retc = 0
       *> SVC99 ok
    else
       *> SVC99 not ok – check for errors
    end-if
Parent topic: JCL API


Mainframe Emulation

  • Compatibility with the Mainframe Environment
  • Assembler Programs
  • Language Environment (LE) Support
Parent topic: Mainframe Programming


Compatibility with the Mainframe Environment

The following topics discuss compatibility with the mainframe.

  • Mainframe Pointers
  • Entry Point Mapping for COBOL Programs
  • Using SMS Data Classes
  • IBM Hexadecimal Format Floating Point Data
Parent topic: Mainframe Emulation


Mainframe Pointers

To provide compatibility with mainframe-style pointers in COBOL programs, this system:

  • Provides and sets the AMODE compiler directive
  • Enables continued access to the data of a canceled subprogram by the calling program
  • AMODE Compiler Directive
  • Accessing Data in a Canceled Program
Parent topic: Compatibility with the Mainframe Environment


AMODE Compiler Directive

You need the AMODE directive for any program module which:

  • Creates mainframe-style pointer items - using the syntax:
    SETpointer-item
TO ADDRESS OF data-item
  • Uses mainframe-style pointer items using the syntax:
    SET ADDRESS OFlinkage-item
TO pointer-item
  • Contains a Working-Storage item passed to a subprogram that creates a mainframe-style pointer item which points to that Working-Storage item

Studio Enterprise Edition also provides and sets the DATA Compiler directive that can control the placement of the Data Division of a program compiled using the AMODE Compiler directive.

The following table shows the settings for AMODE and DATA that are required for a number of COBOL dialects:
COBOL Dialect | Directive
COBOL 370 | AMODE(31) DATA(31)
VS COBOL II (all releases) | AMODE(31) DATA(31)
OS/VS COBOL | AMODE(24)

You must specify the appropriate settings for these directives depending on the dialect you are using.

Parent topic: Mainframe Pointers
Related reference
AMODE
DATA


Accessing Data in a Canceled Program

On the mainframe, a COBOL program can continue to use the data defined in the Data Division of a subprogram even after that subprogram has been canceled. This facility has been emulated in Studio Enterprise Edition, although we do not recommend it as good practice.

You can enable this facility by using the mfpm_access_cancelled_data tunable.

Before the subprogram is canceled, you should set pointer variables in the calling program to the addresses of the data in the subprogram that you want to continue to use. Then, after the subprogram is canceled, you can continue to use that data until Studio Enterprise Edition releases the Working-Storage Section of the canceled subprogram. This can occur if:

  • There is insufficient storage available to satisfy a new storage request
  • The canceled subprogram is reloaded. In this case, the old Working-Storage area is released and a new area allocated and initialized.
  • The application terminates

Any attempt to use a pointer variable that still points to a released Working-Storage area will have unpredictable results.

Parent topic: Mainframe Pointers
Related reference
mfpm access cancelled data


Entry Point Mapping for COBOL Programs

The Entry Point Mapping facility enables you to specify entry points in COBOL programs so that the application can find them at run time. You need to do this for any entry points in programs which will not have been loaded prior to them being called.

To appreciate the functions that this facility performs, you need to understand how calls to entry points are normally resolved using the run-time system.

When a program makes a call to an entry point in which the entry point has not been resolved by statically linking the program, the run-time system looks for the entry point to resolve it dynamically.

When a program is loaded, the name of the program and all the entry points in the program are recorded in a table. When a call to an entry point is made, the run-time system searches the table for the entry point-name. If it does not find the entry point-name, it looks on disk for an executable file of the same name. If it does not find one it returns an error.

Consequently, if your program calls an entry point that is not the name of an executable file or is not an entry point in a previously loaded program, the run-time system cannot find the entry point and your program fails. This is the only case where you need to use the Entry Point Mapper.

This problem often occurs when you take code that has been downloaded from a mainframe to the PC for further development. Mainframe programs often have several entry points in a single program. On the mainframe, entry points are resolved by linking, so calls can be made to a program and the entry point located whether or not the program has been called.

Using Studio Enterprise Edition, if the program containing the entry point has not already been called, the call to that entry point fails.

To get round this problem, you need to create an entry name map file containing an entry point table and make it available to the run-time system.

  • Creating an Entry Name Map File
  • Making Entry Name Map Files Available to the Run-time System
  • Creating an Alias
Parent topic: Compatibility with the Mainframe Environment


Creating an Entry Name Map File

You create your map file with a text editor. For each entry point you need to enter the following three lines:

[ENTRY-POINT] entry-point-name
[PROGRAM-NAME] main-program-name
[SUBPROGRAM-NAME] subprogram-containing-entry-point

Example

Consider a run unit with a main program A and subprogram C. Within the run unit, A calls entry point B which is in program C. The table entry in the entry name map file is:

[ENTRY-POINT] B
[PROGRAM-NAME] A
[SUBPROGRAM-NAME] C

You can also specify an optional [ALIASED-ENTRY-POINT] line following the [ENTRY-POINT] line. If specified, this line defines an entry point name onto which the entry point specified by [ENTRY-POINT] is aliased.

For example:

[ENTRY-POINT]  XYZ
[ALIASED-ENTRY-POINT] ENTA
[PROGRAM-NAME]  *
[SUBPROGRAM-NAME]  PGMA

causes XYZ to be aliased on the ENTA entry point in the program PGMA. This means that when XYZ is called by a program, entry point ENTA will be invoked.

Note: Notes:
  • A tag, that is, the text in square brackets, must be in upper case.
  • A line beginning with # is treated as a comment.
  • You can specify an asterisk (*) for program name to indicate that any program in the run unit can call entry point B in program C.
  • Entry point aliasing is only available for use with .int and .gnt programs.
Parent topic: Entry Point Mapping for COBOL Programs


Making Entry Name Map Files Available to the Run-time System

You use the entry_name_mapper tunable to indicate to the run-time system that you want to use entry name mapping. If entry_name_mapper is set, how the run-time system searches for entry name map files depends on whether the ENTRYNAMEMAP environment variable is set:

  • If ENTRYNAMEMAP is set, the run-time system searches in the semi-colon delimited list of folders and entry name map files it specifies. For each folder specified, the run-time system looks for an entry name map file called mfentmap.dat.
  • If ENTRYNAMEMAP is not set, the run-time system searches for an entry name map file called mfentmap.dat in each folder specified by the COBDIR environment variable.

In either case, the run-time system could find more than one entry name map file, which means that the same entry point could be defined differently in different files. If this happens, precedence is given to the definition in the entry name map file that was found first. To change the order in which the run-time system finds entry name map files you need to change the order in which the files appear in the COBDIR or ENTRYNAMEMAP environment variable paths.

See the topic on the tunable entry_point_mapper.

Parent topic: Entry Point Mapping for COBOL Programs
Related reference
entry point mapper


Creating an Alias

To create an alias you use the Entry Point Mapper to emulate the alias function of an IBM mainframe linkage editor, which redirects the system to execute a program accessed via an alias name. To do this you must edit the entry name map file using a text editor.

At run time, your COBOL run-time system first looks for a program with the original name. If it finds one, it does not invoke the Entry Point Mapper.

Enter the alias on the [ENTRY-POINT] line and the actual program name on the [SUB-PROGRAM] line.

  • Example 1
  • Example 2
Parent topic: Entry Point Mapping for COBOL Programs


Example 1

Consider a run unit with a main program named progroot. Within the run unit, progroot issues a call using the name pacct001. The actual name of the subprogram required is tacct001. The table entry in the mfentmap.dat file is:

[ENTRY-POINT] pacct001
[PROGRAM-NAME] progroot
[SUBPROGRAM-NAME] tacct001
Parent topic: Creating an Alias


Example 2

Consider the situation where you want to load a program by using a different name to that given to the source program. For example, your JCL might contain an instruction to load myprogx, whereas the actual name of the program is myprog. On the mainframe, you could achieve this by linking the program and giving it the required name. However, you cannot link COBOL programs in your COBOL development system; you therefore need to use the Entry Point Mapper to make an association between the name used to load the program and the actual program name.

For example, suppose your program is called myprog, but you instead want to use myprogx as the name to load to the program. The table entry required in the mfentmap.dat file is:

 [ENTRY-POINT] myprogx
 [PROGRAM-NAME] *
 [SUBPROGRAM-NAME] myprog

where [ENTRY-POINT] defines the alias name and [SUBPROGRAM-NAME] is the name of the executable program.

Parent topic: Creating an Alias


Using SMS Data Classes

A Storage Management Subsystem (SMS) data class is a template of data set attributes (such as record length and format) that you can specify is to be used when creating a new data set. Studio Enterprise Edition enables applications running in an enterprise server to make use of SMS data classes.

Data class definitions are stored in a file that you must create using Studio Enterprise Edition. Once you have created a data class definition file in Studio Enterprise Edition you need to enable SMS support then specify the data class definition file that you want to use for an enterprise server. The following steps show how to do this:

  1. Enable SMS support by setting the MF_SMS environment variable to ON.
  2. Specify the data class definition file to use by performing the following steps:
    1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server that you want to edit.
    2. Click the Properties tab then the General tab if they are not selected already.
    3. Specify the following in the Configuration Information field:
      MFUSERCAT_LOC=definition-file

      where definition-file is the fully-qualified location and name of the data class definition file to use.

    4. Click OK.

Once you have defined some data classes and made the data class definition file available you can refer to them using any of the following methods:

  • DATACLAS parameter of a JCL DD statement
  • DATACLASS parameter of a TSO ALLOCATE command
  • DATACLASS parameter of an IDCAMS DEFINE command
  • data class text unit (TU) of SVC 99 (DYNALLOC)

The same definitions file can be used by more than one enterprise server, ensuring consistency of data class definitions. Whenever a data class specification is missing, a default data class called MFEDFTDC is used, if it exists. This data class must exist in an enterprise server's data class definitions file for it to be available for that enterprise server.

For full information on SMS, see the DFSMSdfp Storage Administration Reference available from the IBM BookManager Server Library.

  • Using the SMS DATACLAS update utility
Parent topic: Compatibility with the Mainframe Environment


Using the SMS DATACLAS update utility

You can use the SMS DATACLAS update utility to create and modify SMS DATACLAS definitions. The SMS DATACLAS update utility is a batch utility that you execute using JCL, with the MFCMD program.

MFCMD allows you to access SMS maintenance. With the program, you use name/value pairs to supply parameters and corresponding values as

The SMS DATACLAS update utility takes input from SYSUT1 or SYSIN. MFCMD reads data from SYSIN if it is present, or from SYSUT1 if no SYSIN is present. The input consists of a DATACLAS definition identifier, folllowed by the name and value pairs that you want to set. The SMS DATACLAS update utility writes output to SYSPRINT and SYSUT2.

  • When using SYSUT1, you include the input as a text file. you can supply one to many records, one DATACLAS per record. The records can be any length up to 4096.
  • When using SYSIN, you are limited to 80 byte records and can specify only one DATACLAS with properties that can span multiple lines.
  • Setting up the environment
  • SMS DATACLAS functions
  • SMS DATACLAS Properties and values
  • Using the SMS DATACLAS update utility with input from SYSIN
  • Using the SMS DATACLAS update utility with input from SYSUT1
  • Using DATACLAS output
Parent topic: Using SMS Data Classes


Setting up the environment

Before you can use the utility, you need to set the following environment variables:

  • MFUSERCAT_NODE=SYSMFE1

    Sets that SMS is active. Specify exactly as shown.

  • MF_SMS=ON

    Sets that SMS is active. Specify exactly as shown.

  • MFUSERCAT_LOC=d:\estest\SMS.DAT

    Sets the fully qualified name of the SMS dataset. Supply the details for the dataset to use.

Parent topic: Using the SMS DATACLAS update utility


SMS DATACLAS functions

The following functions are available with the SMS DATACLAS update utility:

  • DLET deletes an item from the SMS DATACLAS
  • GN retrieves the next item in the SMS DATACLAS
  • GU retrieves a specific, named SMS DATACLAS
  • INSERT inserts a new item into the SMS DATACLAS
  • REPL replaces an existing named item in the SMS DATACLAS

For example, for the ABC dataclass, the following command:

DATACLAS NAME(ABC) RECFM(FB) LRECL(80) FUNC(ISRT)
  • Inserts a new DATACLAS named ABC
  • Sets the record format to FB
  • Sets the logical record length to 80 characters
Parent topic: Using the SMS DATACLAS update utility


SMS DATACLAS Properties and values

The following properties are available with the SMS DATACLAS update utility:

  • AVREC
  • AVVALUE
  • BLKSIZE
  • DIRECTORY
  • DSORG
  • KEYLEN
  • KEYOFF
  • LRECL
  • NAME
  • PRIMARY
  • RECFM
  • RECORG
  • SECONDARY
Parent topic: Using the SMS DATACLAS update utility


Using the SMS DATACLAS update utility with input from SYSIN

When using input from SYSIN, you are limited to 80 byte records and can specify only one DATACLAS with properties that can span multiple lines.

The following is an example of JCL that uses SMS DATACLAS with SYSIN.

//STEP20  EXEC PGM=MFCMD
//SYSUT1  DD DUMMY
//SYSIN DD *
   DATACLAS NAME(ABC) RECFM(FB) LRECL(80) FUNC(ISRT)
//SYSUT2 DD DSN=TEST.OUTPUT,DISP=OLD
//SYSPRINT DD SYSOUT=*
//SYSOUT DD SYSOUT=*
Parent topic: Using the SMS DATACLAS update utility


Using the SMS DATACLAS update utility with input from SYSUT1

Each record read from SYSUT1 must contain the complete set of data necessary for one operation on one DATACLAS. For example, to perform a GU operation followed by two GN operations, you would use the following.

   DATACLAS  NAME(ABC) RECFM(FB) LRECL(80) FUNC(GU)
   DATACLAS  FUNC(GN)
   DATACLAS  FUNC(GN)

The following is an example of JCL that uses SMS DATACLAS with SYSUT1.

//STEP20  EXEC PGM=MFCMD
//SYSUT1  DD DSN=TEST.CMDFILE,DISP=OLD
//SYSUT2  DD DSN=TEST.OUTPUT,DISP=OLD
//SYSPRINT DD SYSOUT=*
//SYSOUT   DD SYSOUT=*
Parent topic: Using the SMS DATACLAS update utility


Using DATACLAS output

SMS DATACLAS produces output to SYSPRINT and SYSUT2. Output to SYSPRINT is a report that shows the results of execution.

Output to SYSUT2 is the NAME and Parameter Values for any DATACLAS records successfully retrieved. For example, for the following two commands:

  • DATACLAS NAME(ABC) RECFM(FB) LRECL(80) FUNC(ISRT)
  • DATACLAS NAME(ABC) FUNC(GU)

SYSUT2 would contain the following record:

DATACLAS NAME(ABC) RECFM(FB) LRECL(80)

You then could, for example edit, the output file to add FUNC(ISRT) and use it to load DATACLAS values to another SMS file.

Parent topic: Using the SMS DATACLAS update utility


IBM Hexadecimal Format Floating Point Data

Studio Enterprise Edition enables you to use floating point data in either IEEE or IBM hexadecimal formats, enabling you to share floating point data seamlessly between mainframe and PC. This chapter describes how to use the different floating point formats in Studio Enterprise Edition.

  • Using Different Floating Point Formats
  • The MAINFRAME_FLOATING_POINT Environment Variable
  • Editing Data Files
  • Range
Parent topic: Compatibility with the Mainframe Environment


Using Different Floating Point Formats

The following sections describe how you use the different formats of floating point data in Studio Enterprise Edition.

  • Compiling
  • Running
Parent topic: IBM Hexadecimal Format Floating Point Data


Compiling

When compiling a program that always requires the use of a particular format of floating point data items, you use the NATIVE-FLOATING-POINT directive. Setting NATIVE-FLOATING-POINT specifies that IEEE format floating point data items are used, regardless of the setting of the MAINFRAME_FLOATING_POINT environment variable. Setting NONATIVE-FLOATING-POINT causes the floating point format to be determined by the MAINFRAME_FLOATING_POINT environment variable.

See the section Running for information on the MAINFRAME_FLOATING_POINT environment variable and NATIVE-FLOATING-POINT for more information on the NATIVE-FLOATING-POINT Compiler directive.

Parent topic: Using Different Floating Point Formats
Related reference
NATIVE-FLOATING-POINT
Related information
Running


Running

You control the floating point format that is used at run-time using either of the following:

  • mainframe_floating_point tunable. See mainframe_floating_point for more information.
  • MAINFRAME_FLOATING_POINT environment variable. See the section The MAINFRAME_FLOATING_POINT Environment Variable for more information.

If both are specified, the setting of the MAINFRAME_FLOATING_POINT environment variable overrides the setting of the mainframe_floating_point tunable.

Parent topic: Using Different Floating Point Formats
Related reference
Environment Variables
mainframe floating point
Related information
The MAINFRAME_FLOATING_POINT Environment Variable


The MAINFRAME_FLOATING_POINT Environment Variable

Possible formats for the MAINFRAME_FLOATING_POINT environment variable are IBM hexadecimal and IEEE.

  • Syntax
  • Parameters
  • Comments
Parent topic: IBM Hexadecimal Format Floating Point Data
Related information
Running


Syntax

SET MAINFRAME_FLOATING_POINT=fp-status
Parent topic: The MAINFRAME_FLOATING_POINT Environment Variable


Parameters

fp-status
Which format to use for floating point data items. This must be one of:
true
Specifies that IBM hexadecimal format floating point data items are to be used.
false
Specifies that IEEE format floating point data items are to be used.
Parent topic: The MAINFRAME_FLOATING_POINT Environment Variable


Comments

Setting MAINFRAME_FLOATING_POINT to anything other than "true" has the same effect as setting it to "false".

The setting of this environment variable can be overridden by the NATIVE-FLOATING-POINT directive. See NATIVE-FLOATING-POINT for more information.

You must set the MAINFRAME_FLOATING_POINT environment variable from aNet Express command prompt before you start Studio Enterprise Edition for it to take effect.

Parent topic: The MAINFRAME_FLOATING_POINT Environment Variable
Related reference
NATIVE-FLOATING-POINT


Editing Data Files

When editing data files, you can specify whether floating-point data items are interpreted as IEEE format or IBM hexadecimal format. To do this, you use a new drop-down list on the Data File Toolbar, as shown below:

Figure 1. File Toolbar Showing the Floating-point Format Drop-down List
File Toolbar Showing the Floating-point Format Drop-down List

Select the format you want to use from the list, and the floating-point data items are displayed in the format you choose. The default is determined by the setting of the MAINFRAME_FLOATING_POINT environment variable.

Note:

You cannot edit floating-point data in the Data File Editor.

Parent topic: IBM Hexadecimal Format Floating Point Data


Range

IBM hexadecimal format floating point data items must contain values in the following ranges:

Type | Minimum Value | Maximum Value
COMP-1 | 5.5E-79 | 7.2E75
COMP-2 | 5.5E-79 | 7.2E75
Parent topic: IBM Hexadecimal Format Floating Point Data


Assembler Programs

The product now contains a command line version of MFASM, the mainframe assembler emulator for IBM High Level Assembler programs, that allows users to create assembler executables or data tables within the Visual Studio environment. The MFASM component is an early adopter release intended to provide a test environment for COBOL applications to call needed assembler subroutines which have already been developed and debugged in other environments. This test environment is for Studio Enterprise Edition only and does not include a debug facility for assembler at this time. Assembler executables will not run in production environments.

  • MFASM
    Use the MFASM command to assemble and link Assembler applications in one step, producing executable subroutines, and debugging modules.
  • Using the Generalized Trace Facility
  • Diagnosing Abends
Parent topic: Mainframe Emulation


MFASM

Use the MFASM command to assemble and link Assembler applications in one step, producing executable subroutines, and debugging modules.

Syntax:

MFASM filename.mlc [option ...][;]

Parameters:

filename
The name of an Assembler source file.
option
An Assembler compiler directive

Comments:

MFASM produces the following files:

  • filename.obj - An object module used by the assembler linker
  • filename.idf and filename.idx - debugging files used by the Assembler debugger
  • filename.390 - An executable Assembler program.
The most commonly-used Assembler compiler directives are:
  • NOANIM
  • NOLIST
  • BAL
  • AMODE(31)

Examples:

MFASM test.mlc NOANIM

Here the NOANIM option is also used to suppress the generation of unnecessary debug files. To ensure that the resulting executable file, in this example TEST.390, is picked up by the COBOL runtime, move it to the same subdirectory as other COBOL executables in the application. At CALL time, the COBOL runtime searches for and loads executables with the .390 file extension as it would any other executable file with extensions such as .dll.

Example 2 - Producing Assembler Data Tables

Assembler data tables are produced by using the OMF (MOD) directive to generate files with the .mod extension as follows:

MFASM test.mlc OMF(MOD)NOANIM NOLIST

To ensure that the resulting .mod file, in this example test.mod, is loaded into memory along with other CICS programs by use of the EXEC CICS LOAD command, move it to the same subdirectory as other COBOL executables in the application.

Parent topic: Assembler Programs
Parent topic: Assembler Command Line Reference


Using the Generalized Trace Facility

The Assembler Generalized Trace Facility (GTF) is a debugging tool that helps speed up the process of isolating the location and cause of a problem in an Assembler program. You use the GTF tool to create a trace file showing the operations performed by the program. You do not have to compile the program for debugging. You can request different levels of detail: for example, you can run a trace requesting program level information and then run a further trace on a specific section by specifying the level of detail and the start and end points for the trace.

Note: Under the Enterprise Server environment any trace file will be locked for exclusive access by the server, so in order to examine the file you must first stop the server.

To turn on the Generalized Trace Facility, set the environment variable GTFFILE to the absolute path and file name of the trace file. You set this environment variable in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin\MF370CTL.CFG file.

Configuring GTF

You can specify the following GTF options after the GTFFILE environment variable:

Option | Description
GTFIMIN | The instruction count at which to start the trace. The default is 00000000.
GTFIMAX | The instruction count at which to end the trace. The default is FFFFFFFF.
GTFAMIN | The instruction address at which to start the trace. The default is 00000000.
GTFAMAX | The instruction address at which to end the trace. The default is FFFFFFFF.
GTFOPT The level of detail. You can set this environment variable to one or more of the following three-character codes separated by commas to indicate the level of detail you want:
INS
Trace each instruction
BAL
Trace each BALR, BASR, and BASSM instruction
SVC
Trace each SVC instruction
PGM
Trace each LOAD, DELETE, and LINK
FOC
Trace each file OPEN and CLOSE operation
FIO
Trace each file input and output operation, as well as each OPEN and CLOSE
MEM
Trace GETMAIN, FREEMAIN, and STORAGE
ALL
All of the above trace options
REG
Trace the 16 general-purpose registers at each trace event
The default value is BAL, PGM, FOC.

The size of a trace file depends on the options that you specify and can be very large. Therefore we recommend that you always begin by running a trace with the default options to find out the optimum starting point for a detailed trace. When you run a detailed trace, using options such as FIO, INS or ALL, specify the start and end points using the GTFIMIN and GTFIMAX or the GTFAMIN and GTFAMAX options.

You can also specify the REG option with any other option if you want the contents of the 16 general-purpose registers at each trace point. Note that this increases the size of the trace file by a factor of three. The contents of the registers are shown as they were just before the trace operation, hence the REG option is most useful with the following options:
  • INS, because this traces every instruction
  • MEM and PGM, because with these options the trace is performed at the end of the instructions affected such as LOAD and GETMAIN

Regardless of the trace options you have specified, whenever a program interruption occurs the trace file contains extra lines for the instruction causing the interruption. These lines show the program status word (PSW), which contains the interruption code in the low-order byte of the first word, and the registers.

The Trace File

You can view or print the GTF trace file using any ASCII-compatible editor or word processor. The file begins with the GTF options used to generate the file, and the date and time the trace started. The last line of the file shows the date and time the trace ended. If this line is not present, the trace is probably incomplete because it was not closed properly. This can happen if you are running an interactive debugging session using the Assembler debugger with the Generalized Trace Facility turned on, and an unrecoverable error occurs. To ensure that the GTF trace file is complete, you must allow the debugging session to end without being forced: press S(tep) or G(o) to record the program exception on the trace file and then stop the debugging session.

In between the information at the beginning of the file and the last line are individual trace records. Each of these includes the following items of information:
  • Instruction count. This is a hexadecimal counter showing the total number of instructions executed up to the trace point. This count is very useful when you want to work out where to start a detailed trace at a point deep into a complex application where the same code may be executed many times before the point of failure. You use the option GTFIMIN to set the starting instruction count for a trace.
  • Instruction address. This is the linear address of the next instruction at the current trace point. This address provides an alternative way of specifying where you want a detailed trace to start. You use the option GTFAMIN to set the starting instruction address for a trace.
  • Instruction operation. This field indicates the machine instruction or run-time operation being performed at the trace point. Additional information may follow depending on the type of trace line:
    Trace Line Type | Description
    INS | The hexadecimal machine instruction, which can be 2, 4, or 6 bytes in length
    PGM | The program name and entry for LOAD, DELETE, or LINK
    FOC and FIO | The DCB, ACB, or DTF control block address
    MEM | Length and address of memory allocated or deallocated
Default Trace Option
Use the default trace option GTFOPT=PGM,BAL,FOC to trace LOAD, DELETE, LINK, BALR, BASR, OPEN, and CLOSE operations. This enables you to get an overview of what an application is doing and to identify possible starting and ending points for more detailed traces if required.

Below is an example trace file for a default trace of an IMS COBOL and Assembler application:

GTF option GTFFILE =D:\MFUSER\CONFIG\GTF.LOG
GTF option GTFOPT  =BAL,FOC,PGM
GTF option GTFIMIN =00000000
GTF option GTFIMAX =FFFFFFFF
GTF option GTFAMIN =00000000
GTF option GTFAMAX =FFFFFFFF
GTF trace file DATE=000114 TIME=08495898
INS-CTR  INS-ADDR INS-OP
00000043 81000188 BALR     05EF
00000044 81005998 BALR     05F0
00000047 810059A2 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
00000051 810001E6 LOAD     NAME=LDDECTBL ENTRY=810059D8
000006DA 8100033A BALR     05EF
00000704 81005998 BALR     05F0
00000707 810059A2 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
00000762 81000E10 LOAD     NAME=CG#CTL   ENTRY=80012CF0
00000988 810059B0 BALR     05F0
0000098B 810059BA LINK     NAME=ASMTDLI  ENTRY=(COBOL)
00001051 8100033A BALR     05EF
0000107B 81005998 BALR     05F0
0000107E 810059A2 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
000012F7 810059B0 BALR     05F0
000012FA 810059BA LINK     NAME=ASMTDLI  ENTRY=(COBOL)
00001360 8100033A BALR     05EF
0000139C 81005998 BALR     05F0
0000139F 810059A2 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
00001618 810059B0 BALR     05F0
0000161B 810059BA LINK     NAME=ASMTDLI  ENTRY=(COBOL)
00001CDC 8100033A BALR     05EF
00001D06 81005998 BALR     05F0
00001D09 810059A2 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
00001F82 810059B0 BALR     05F0
00001F85 810059BA LINK     NAME=ASMTDLI  ENTRY=(COBOL)
00001F92 810003EA DELETE   NAME=LDDECTBL ENTRY=00000000
00001FED 81007628 BALR     05EF
00001FEE 8100CE38 BALR     05F0
00001FF1 8100CE42 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
00001FFB 81007686 LOAD     NAME=LDDECTBL ENTRY=80011228
00002684 810077DA BALR     05EF
000026AE 8100CE38 BALR     05F0
000026B1 8100CE42 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000270C 810082B0 LOAD     NAME=CG#CTL   ENTRY=8100CE78
00002932 8100CE50 BALR     05F0
00002935 8100CE5A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
00002FFB 810077DA BALR     05EF
.........................................
.........................................
0000B04A 81022160 BALR     05F0
0000B04D 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000B0AA 8101CAEA BALR     05EF
0000B0EF 81022148 BALR     05F0
0000B0F2 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000B114 81022160 BALR     05F0
0000B117 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000B174 8101CAEA BALR     05EF
0000B1B0 81022148 BALR     05F0
0000B1B3 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000B4A4 81022160 BALR     05F0
0000B4A7 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000B501 8101CAEA BALR     05EF
0000B519 81022160 BALR     05F0
0000B51C 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000BBE2 8101CAEA BALR     05EF
0000BC0C 81022148 BALR     05F0
0000BC0F 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000BE8D 81022160 BALR     05F0
0000BE90 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000BEED 8101CAEA BALR     05EF
0000BF32 81022148 BALR     05F0
0000BF35 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000BF51 81022160 BALR     05F0
0000BF54 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000BFB1 8101CAEA BALR     05EF
0000BFED 81022148 BALR     05F0
0000BFF0 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000C2E1 81022160 BALR     05F0
0000C2E4 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000C33E 8101CAEA BALR     05EF
0000C356 81022160 BALR     05F0
0000C359 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000C3BF 8101CAEA BALR     05EF
0000C3FB 81022148 BALR     05F0
0000C3FE 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000C67C 81022160 BALR     05F0
0000C67F 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000CD40 8101CAEA BALR     05EF
0000CD6A 81022148 BALR     05F0
0000CD6D 81022152 LINK     NAME=AIBTDLI  ENTRY=(COBOL)
0000CFEB 81022160 BALR     05F0
0000CFEE 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000CFFB 8101CB9A DELETE   NAME=LDDECTBL ENTRY=00000000
GTF trace file DATE=000114 TIME=08514748
Detailed Trace Option
Use the GTFOPT=ALL option to obtain a detailed trace.

Below is an example of a detailed trace of the last section of code starting with BALR (instruction count CFEB) in the default trace example above. Options GTFOPT=ALL and GTFIMIN=0000CFEB were used to obtain this trace.

GTF option GTFFILE =D:\MFUSER\CONFIG\GTF.LOG
GTF option GTFOPT  =ALL
GTF option GTFIMIN =0000CFEB
GTF option GTFIMAX =FFFFFFFF
GTF option GTFAMIN =00000000
GTF option GTFAMAX =FFFFFFFF
GTF trace file DATE=000114 TIME=09370586
INS-CTR  INS-ADDR INS-OP
0000CFEB 81022160 BALR     05F0
0000CFEC 81022162 ICM      BF08F00D
0000CFED 81022166 LA       41F0F00E
0000CFEE 8102216A SVC      0A27
0000CFEE 8102216A LINK     NAME=ASMTDLI  ENTRY=(COBOL)
0000CFEF 8102216C BCR      07FE
0000CFF0 8101DBFA L        58D0D004
0000CFF1 8101DBFE L        58E0D00C
0000CFF2 8101DC02 BCR      07FE
0000CFF3 8101CAEC L        58E0B092
0000CFF4 8101CAF0 BCR      07FE
0000CFF5 8101C864 BAS      4DE0B3B4
0000CFF6 8101CB7A ST       50E0B092
0000CFF7 8101CB7E CLC      D501300AB484
0000CFF8 8101CB84 BC       4770B40C
0000CFF9 8101CB88 L        5860B446
0000CFFA 8101CB8C BAL      4500B3D2
0000CFFB 8101CB98 SVC      0A09
0000CFFB 8101CB9A DELETE   NAME=LDDECTBL ENTRY=00000000
0000CFFC 8101CB9A LTR      12FF
0000CFFD 8101CB9C BC       4770B412
0000CFFE 8101CBA0 L        5810B4B6
0000CFFF 8101CBA4 L        5890B4BE
0000D000 8101CBA8 L        5860B442
0000D001 8101CBAC LR       1809
0000D002 8101CBAE LH       48F0B3EE
0000D003 8101CBB2 BC       47000003
0000D004 8101CBB6 SVC      0A78
0000D004 8101CBB8 FREEMAIN  LOC=  00010EC8 LEN=  00000359
0000D005 8101CBB8 LTR      12FF
0000D006 8101CBBA BC       4770B412
0000D007 8101CBBE L        5810B4D6
0000D008 8101CBC2 LH       48F0B4D2
0000D009 8101CBC6 LA       4120B49A
0000D00A 8101CBCA LH       4830B482
0000D00B 8101CBCE SR       1B55
0000D00C 8101CBD0 MVCL     0E24
0000D00D 8101CBD2 L        58E0B092
0000D00E 8101CBD6 BCR      07FE
0000D00F 8101C868 L        58D0B04E
0000D010 8101C86C ST       50FD0010
0000D011 8101C870 LM       98ECD00C
0000D012 8101C874 BCR      07FE
0000D013 80000860 SVC      0A00
GTF trace file DATE=000114 TIME=09375776
Program Interruption Information
Here is the trace file for a program that attempts to add 1 to a packed decimal field containing spaces. The PSW contains interrupt code 7 corresponding to the MVS abend 0C7 that would occur on the mainframe.
GTF option GTFFILE =GTF.LOG
GTF option GTFOPT  =ALL
GTF option GTFIMIN =00000000
GTF option GTFIMAX =FFFFFFFF
GTF option GTFAMIN =00000000
GTF option GTFAMAX =FFFFFFFF
GTF trace file DATE=000114 TIME=10565281
INS-CTR  INS-ADDR INS-OP
00000001 81007FE8 BALR     05C0
00000002 81007FEA LA       41100002
00000003 81007FEE AP       FA10C00CC00E
 R0-R7 00000000 00000002 00000000 00000000 00000000 00000000 00000000 00000000
 R9-RF 00000000 00000000 00000000 00000000 81007FEA 00002870 00000860 01007FE8
00000003 81007FF4 PGMCHK   PSW=0000000781007FF4
GTF trace file DATE=000114 TIME=10565286
Parent topic: Assembler Programs


Diagnosing Abends

Why does my program abort with 0C5 addressing error immediately when it is called from COBOL?
The default COBOL compile option under Studio Enterprise Edition is NOAMODE. This means any parameters passed to an assembler module will be in native PC addressing format and will generate an OC5 addressing error immediately at CALL time. To enable 370 mainframe style addressing in your COBOL program you must use the AMODE(24) or AMODE(31) compiler directive
Why does my program abend immediately when it is called from COBOL?
An abend can be caused by invalid 31 bit addresses being passed to a 24 bit assembler program. In this case, you should set the DATA(24) directive to force all COBOL working storage data addresses to be 24 bits.
What is the fastest way to get help debugging an abend in a large complex application?
Generating a GTF instruction trace might be the fastest way to find the problem. From a GTF trace file, you can determine the failing program, and the exact instruction path followed until the abend. Remember that the trace file gives the actual 370 machine code that is being emulated. This same machine code appears in assembler listing (.PRN) files and can be searched for with any text editor.
Parent topic: Assembler Programs


Language Environment (LE) Support

Language environment is a set of standard callable routines and run-time options that can be used in any MVS application that is written in a programming language that supports LE. It is intended to facilitate the development of mixed-language applications.

This system emulates a subset of LE for COBOL. See Callable Services for details of this subset. For a full description of LE, see the IBM Language Environment Programming Reference and IBM Language Environment Programming Guide.

  • Enable Language Environment (LE) Support
    Language Environment (LE) support is enabled using the INITCALL'mfleinit' Compiler directive or the ES_LE370_SUPPORT environment variable. The method used depends on how you intend to use the support.
  • LE Callable Services
  • LE Run-Time Options
  • LE Error Conditions
  • LE Run-Time Options Error Messages
  • LE Country Codes
Parent topic: Mainframe Emulation
Related information
IBM Language Environment Programming Reference
IBM Language Environment Programming Guide


Enable Language Environment (LE) Support

Enable LE support depending on your application type:

JCL

LE support is enabled by default unless the name of the program you are running begins with 'MF'. In which case, set the INITCALL"mfleinit" Compiler directive.

CICS

For CICS applications, set the environment variable ES_LE370_SUPPORT=Y.

Any other method

For any other method, for example, an IMS or standard COBOL program, set the INITCALL"mfleinit" Compiler directive.

Parent topic: Language Environment (LE) Support


LE Callable Services

  • Bit Manipulation Services
  • Condition-Handling Services
  • Date and Time Services
  • Dynamic-Storage Services
  • Dynamic File Allocation Services
  • General Services
  • Initialization and Termination Services
  • Locale Services
  • Math Services
  • Message-Handling Services
  • National Locale Support Services
Parent topic: Language Environment (LE) Support


Bit Manipulation Services

The following table shows the LE bit manipulation services that are supported by this COBOL system.

Routine | Description | Supported?
CEESICLR | Bit clear | Yes
CEESISET | Bit set | Yes
CEESISHF | Bit shift | Yes
CEESITST | Bit test | Yes
Note:

The FLGS data item in the FEED_BACK condition (FC) token is not set or used by this COBOL system.

Parent topic: LE Callable Services


Condition-Handling Services

The following table shows the LE condition-handling callable services that are supported by this COBOL system.

Routine | Description | Supported?
CEE3CIB | Return pointer to Condition Information Block | No *
CEE3GRN | Get name of routine that incurred condition | No *
CEE3GRO | Get offset of condition | No **
CEE3SPM | Query/modify LE/370 Hardware Condition Enablement | No *
CEE3SRP | Set resume point | No *
CEEDCOD | Decompose a condition token | Yes
CEEGPID | Retrieve the LE/370 version and platform ID | Yes
CEEGQDT | Retrieve q_data_token | No *
CEEHDLR | Register user-written condition handler | No *
CEEHDLU | Unregister user-written condition handler | No *
CEEITOK | Return initial condition token | No *
CEEMRCE | Move resume cursor explicit | No **
CEEMRCR | Move resume cursor | No *
CEENCOD | Construct a condition token | Yes
CEESGL | Signal a condition | No *
Note:
  • Calls to unsupported routines marked by '*' are accepted but no action occurs. In the FEED_BACK condition (FC) code, the severity is set to 4, the message number to 9999, and the facility-ID to MFX.
  • Calls to unsupported routines marked by '**' are not accepted and if used in a COBOL program result in the fatal run-time system error 173 ("Called program file not found in drive/directory").
  • The FLGS data item in the FEED_BACK condition (FC) token is not set or used by this COBOL system.
Parent topic: LE Callable Services


Date and Time Services

The following table shows the LE date and time callable services that are supported by this COBOL system.

Routine | Description | Supported?
CEECBLDY | Convert date to COBOL Lilian format | Yes
CEEDATE | Convert Lilian date to character format | Yes
CEEDATM | Convert seconds to a character timestamp | Yes
CEEDAYS | Convert date to Lilian format | Yes
CEEDYWK | Calculate day of week from Lilian date | Yes
CEEGMT | Get current Greenwich Mean Time (GMT) | Yes
CEEGMTO | Get difference between GMT and local time | Yes
CEEISEC | Convert integers to seconds | Yes
CEELOCT | Get the current local date or time | Yes
CEEQCEN | Get the century window | Yes
CEESCEN | Set the century window | Yes
CEESECI | Convert seconds to integers | Yes
CEESECS | Convert timestamp to number of seconds | Yes
CEEUTC | Get Coordinated Universal Time (alias of CEEGMT) | Yes
Note:

The FLGS data item in the FEED_BACK condition (FC) token is not set or used by this COBOL system.

Parent topic: LE Callable Services


Dynamic-Storage Services

The following table shows the LE dynamic-storage callable services that are supported by this COBOL system

Routine | Description | Supported?
CEE3RPH | Set report heading | No *
CEECRHP | Create new additional heap | Yes
CEECZST | Reallocate (change size of) storage | Yes
CEEDSHP | Discard heap | Yes
CEEFRST | Free heap storage | Yes
CEEGTST | Get heap storage | Yes
Note:
  • Calls to unsupported routines marked by '*' are accepted but no action occurs. In the FEED_BACK condition (FC) code, the severity is set to 4, the message number to 9999, and the facility-ID to MFX.
  • The FLGS data item in the FEED_BACK condition (FC) token is not set or used by this COBOL system.
Parent topic: LE Callable Services


Dynamic File Allocation Services

The following table shows the LE dynamic file allocation services that are supported by this COBOL system.

Routine | Description | Supported?
PUTENV | Dynamically allocate a missing DD | Yes
SETENV | Dynamically allocate a missing DD | Yes
Note:
  • The optional parameters (such as SHR, NEW, OLD. LRECL and DSORG) are supported to the same level they are supported for the TSO ALLOCATE command.
  • If you use PUTENV or SETENV with parameters that are not compatible with the TSO ALLOCATE command, the call is rejected and the return code is set to a non-zero value.
Parent topic: LE Callable Services


General Services

The following table shows the LE general callable services that are supported by this COBOL system.

Routine | Description | Supported?
CEE3DMP | Generate dump | No *
CEE3PRM | Query parameter string | Yes
CEE3USR | Set/query user area fields | Yes
CEERAN0 | Calculate uniform random numbers | Yes
CEETDLI | Invoke IMS | No **
CEETEST | Invoke debug tool | No *
Note:
  • Calls to unsupported routines marked by '*' are accepted but no action occurs. In the FEED_BACK condition (FC) code, the severity is set to 4, the message number to 9999, and the facility-ID to MFX.
  • Calls to unsupported routines marked by '**' are not accepted and if used in a COBOL program result in the fatal run-time system error 173 ("Called program file not found in drive/directory").
  • The FLGS data item in the FEED_BACK condition (FC) token is not set or used by this COBOL system.
Parent topic: LE Callable Services


Initialization and Termination Services

The following table shows the LE initialization and termination callable services that are supported by this COBOL system.

Routine | Description | Supported?
CEE3ABD | Terminate enclave with an abend | Yes
CEE3GRC | Get the enclave return code | No *
CEE3SRC | Set the enclave return code | No *
Note:
  • Calls to unsupported routines marked by '*' are accepted but no action occurs. In the FEED_BACK condition (FC) code, the severity is set to 4, the message number to 9999, and the facility-ID to MFX.
  • The FLGS data item in the FEED_BACK condition (FC) token is not set or used by this COBOL system
Parent topic: LE Callable Services


Locale Services

The following table shows the LE locale callable services that are supported by this COBOL system.

Routine | Description | Supported?
CEEFMON | Format monetary string | No **
CEEFTDS | Format time and date into a character string | No **
CEELCNV | Query locale numeric conventions | No **
CEEQDTC | Query locale date and time format | No **
CEEQRYL | Query the active locale environment | No **
CEESCOL | Compare collation weights of two strings | No **
CEESETL | Set locale operating environment | No **
CEESTXF | Transform strong characters into collation weights | No **
Note:

Calls to unsupported routines marked by '**' are not accepted and if used in a COBOL program result in the fatal run-time system error 173 ("Called program file not found in drive/directory").

Parent topic: LE Callable Services


Math Services

The following table shows the LE math callable services that are supported by this COBOL system.

Routine | Description | Supported?
CEESxABS | Absolute value |
 | CEESDABS | 64-bit double floating-point number | Yes
 | CEESEABS | 64-bit double floating-point complex number | No **
 | CEESIABS | 32-bit binary integer | Yes
 | CEESQABS | 128-bit extended floating-point number | No **
 | CEESRABS | 128-bit extended floating-point complex number | No **
 | CEESSABS | 32-bit single floating-point number | Yes
 | CEESTABS | 32-bit single floating-point complex number | No **
CEESxACS | Arccosine |
 | CEESDACS | 64-bit double floating-point number | Yes
 | CEESQACS | 128-bit extended floating-point number | No **
 | CEESSACS | 32-bit single floating-point number | Yes
 | CEESDASN | 64-bit double floating-point number | Yes
 | CEESQASN | 128-bit extended floating-point number | No **
 | CEESSASN | 32-bit single floating-point number | Yes
CEESxATH | Hyperbolic arctangent |
 | CEESDATH | 64-bit double floating-point number | Yes
 | CEESEATH | 64-bit double floating-point complex number | No **
 | CEESQATH | 128-bit extended floating-point number | No **
 | CEESRATH | 128-bit extended floating-point complex number | No **
 | CEESSATH | 32-bit single floating-point number | Yes
 | CEESTATH | 32-bit single floating-point complex number | No **
CEESxATN | Arctangent |
 | CEESDATN | 64-bit double floating-point number | Yes
 | CEESEATN | 64-bit double floating-point complex number | No **
 | CEESQATN | 128-bit extended floating-point number | No **
 | CEESRATN | 128-bit extended floating-point complex number | No **
 | CEESSATN | 32-bit single floating-point number | Yes
 | CEESTATN | 32-bit single floating-point complex number | No **
CEESxAT2 | Arctangent of two arguments |
 | CEESDAT2 | 64-bit double floating-point number | Yes
 | CEESQAT2 | 128-bit extended floating-point number | No **
 | CEESSAT2 | 32-bit single floating-point number | Yes
CEESxCOS | Cosine |
 | CEESDCOS | 64-bit double floating-point number | Yes
 | CEESECOS | 64-bit double floating-point complex number | No **
 | CEESQCOS | 128-bit extended floating-point number | No **
 | CEESRCOS | 128-bit extended floating-point complex number | No **
 | CEESSCOS | 32-bit single floating-point number | Yes
 | CEESTCOS | 32-bit single floating-point complex number | No **
CEESxCSH | Hyperbolic cosine |
 | CEESDCSH | 64-bit double floating-point number | Yes
 | CEESECSH | 64-bit double floating-point complex number | No **
 | CEESQCSH | 128-bit extended floating-point number | No **
 | CEESRCSH | 128-bit extended floating-point complex number | No **
 | CEESSCSH | 32-bit single floating-point number | Yes
 | CEESTCSH | 32-bit single floating-point complex number | No **
CEESxCTN | Cotangent |
 | CEESDCTN | 64-bit double floating-point number | Yes
 | CEESQCTN | 128-bit extended floating-point number | No **
 | CEESSCTN | 32-bit single floating-point number | Yes
 | CEESDDIM | 64-bit double floating-point number | Yes
 | CEESIDIM | 32-bit binary integer | Yes
 | CEESQDIM | 128-bit extended floating-point number | No **
 | CEESSDIM | 32-bit single floating-point number | Yes
CEESxDVD | Division | No **
CEESxERC | Error function complement | No **
CEESxERF | Error function | No **
 | CEESDEXP | 64-bit double floating-point number | Yes
 | CEESEEXP | 64-bit double floating-point complex number | No **
 | CEESQEXP | 128-bit extended floating-point number | No **
 | CEESREXP | 128-bit extended floating-point complex number | No **
 | CEESSEXP | 32-bit single floating-point number | Yes
 | CEESTEXP | 32-bit single floating-point complex number | No **
CEESxGMA | Gamma function | No **
CEESxIMG | Imaginary part of complex | No **
CEESxINT | Truncation |
 | CEESQINT | 128-bit extended floating-point number | No **
 | CEESSINT | 32-bit single floating-point number | Yes
 | CEESDINT | 64-bit double floating-point number | Yes
CEESxLG1 | Logarithm base 10 |
 | CEESDLG1 | 64-bit double floating-point number | Yes
 | CEESQLG1 | 128-bit extended floating-point number | No **
 | CEESSLG1 | 32-bit single floating-point number | Yes
CEESxLG2 | Logarithm base 2 |
 | CEESDLG2 | 64-bit double floating-point number | Yes
 | CEESQLG2 | 128-bit extended floating-point number | No **
 | CEESSLG2 | 32-bit single floating-point number | Yes
CEESxLOG | Logarithm base e |
 | CEESDLOG | 64-bit double floating-point number | Yes
 | CEESELOG | 64-bit double floating-point complex number | No **
 | CEESQLOG | 128-bit extended floating-point number | No **
 | CEESRLOG | 128-bit extended floating-point complex number | No **
 | CEESSLOG | 32-bit single floating-point number | Yes
 | CEESTLOG | 32-bit single floating-point complex number | No **
CEESxMOD | Modular arithmetic |
 | CEESDMOD | 64-bit double floating-point number | Yes
 | CEESIMOD | 32-bit binary integer | Yes
 | CEESQMOD | 128-bit extended floating-point number | No **
 | CEESSMOD | 32-bit single floating-point number | Yes
CEESxNIN | Nearest integer | Yes
CEESxNWN | Nearest whole number | Yes
 | CEESDSGN | 64-bit double floating-point number | Yes
 | CEESISGN | 32-bit binary integer | Yes
 | CEESQSGN | 128-bit extended floating-point number | No **
 | CEESSSGN | 32-bit single floating-point number | Yes
CEESxSIN | Sine |
 | CEESDSIN | 64-bit double floating-point number | Yes
 | CEESESIN | 64-bit double floating-point complex number | No **
 | CEESQSIN | 128-bit extended floating-point number | No **
 | CEESRSIN | 128-bit extended floating-point complex number | No **
 | CEESSSIN | 32-bit single floating-point number | Yes
 | CEESTSIN | 32-bit single floating-point complex number | No **
CEESxSNH | Hyperbolic sine |
 | CEESDSNH | 64-bit double floating-point number | Yes
 | CEESESNH | 64-bit double floating-point complex number | No **
 | CEESQSNH | 128-bit extended floating-point number | No **
 | CEESRSNH | 128-bit extended floating-point complex number | No **
 | CEESSSNH | 32-bit single floating-point number | Yes
 | CEESTSNH | 32-bit single floating-point complex number | No **
CEESxSQT | Square root |
 | CEESDSQT | 64-bit double floating-point number | Yes
 | CEESESQT | 64-bit double floating-point complex number | No **
 | CEESQSQT | 128-bit extended floating-point number | No **
 | CEESRSQT | 128-bit extended floating-point complex number | No **
 | CEESSSQT | 32-bit single floating-point number | Yes
 | CEESTSQT | 32-bit single floating-point complex number | No **
 | CEESDTAN | 64-bit double floating-point number | Yes
 | CEESETAN | 64-bit double floating-point complex number | No **
 | CEESQTAN | 128-bit extended floating-point number | No **
 | CEESRTAN | 128-bit extended floating-point complex number | No **
 | CEESSTAN | 32-bit single floating-point number | Yes
 | CEESTTAN | 32-bit single floating-point complex number | No **
CEESxTNH | Hyperbolic tangent |
 | CEESDTNH | 64-bit double floating-point number | Yes
 | CEESETNH | 64-bit double floating-point complex number | No **
 | CEESQTNH | 128-bit extended floating-point number | No **
 | CEESRTNH | 128-bit extended floating-point complex number | No **
 | CEESSTNH | 32-bit single floating-point number | Yes
 | CEESTTNH | 32-bit single floating-point complex number | No **
CEESxXPx | Exponential (**) |
 | CEESDXPD | 64-bit double floating-point raised to a 64-bit double floating-point | Yes
 | CEESEXPE | 64-bit double floating-point complex raised to a 64-bit double floating-point complex | No **
 | CEESDXPI | 64-bit double floating-point number raised to a 32-bit binary integer | Yes
 | CEESEXPI | 64-bit double floating-point complex number raised to a 32-bit binary integer | No **
 | CEESIXPI | 32-bit binary integer raised to a 32-bit binary integer | Yes
 | CEESQXPI | 128-bit extended floating-point number raised to a 32-bit binary integer | No **
 | CEESRXPI | 128-bit extended floating-point complex number raised to a 32-bit binary integer | No **
 | CEESSXPI | 32-bit single floating-point number raised to a 32-bit binary integer | Yes
 | CEESTXPI | 32-bit single floating-point complex number raised to a 32-bit binary integer | No **
 | CEESRXPR | 128-bit extended floating-point complex raised to a 128-bit extended floating-point complex | No **
 | CEESQXPQ | 128-bit extended floating-point raised to a 128-bit extended floating-point | No **
 | CEESTXPT | 32-bit single floating-point complex raised to a 32-bit single floating-point complex | No **
 | CEESSXPS | 32-bit single floating-pointing point raised to a 32-bit single floating-point | Yes
Note:

Calls to unsupported routines marked by '**' are not accepted and if used in a COBOL program result in the fatal run-time system error 173 ("Called program file not found in drive/directory").

Parent topic: LE Callable Services


Message-Handling Services

The following table shows the LE message-handling callable services that are supported by this COBOL system.

Routine | Description | Supported?
CEECMI | Store and load message-insert data | No *
CEEMGET | Get a message | No *
CEEMOUT | Dispatch a message | Yes
CEEMSG | Get, format, and dispatch a message | No *
Note:
  • Calls to unsupported routines marked by '*' are accepted but no action occurs. In the FEED_BACK condition (FC) code, the severity is set to 4, the message number to 9999, and the facility-ID to MFX.
  • The FLGS data item in the FEED_BACK condition (FC) token is not set or used by this COBOL system.
Parent topic: LE Callable Services


National Locale Support Services

The following table shows the LE national locale support callable services that are supported by this COBOL system.

Routine | Description | Supported?
CEE3CTY | Set/query default country | Yes
CEE3LNG | Set/query national language | Yes
CEE3MCS | Get default currency symbol | Yes
CEE3MDS | Get default decimal separator | Yes
CEE3MTS | Get default thousands separator | Yes
CEEFMDA | Get default date format | Yes
CEEFMDT | Get default date and time format | Yes
CEEFMTM | Get default time format | Yes
Note: The FLGS data item in the FEED_BACK condition (FC) token is not set or used by this COBOL system.
Parent topic: LE Callable Services


LE Run-Time Options

  • Supported LE Run-time Options
  • Unsupported LE Run-time Options
  • Specifying LE Run-time Options
Parent topic: Language Environment (LE) Support


Supported LE Run-time Options

The following table shows the LE run-time options that are supported by this COBOL system and gives other useful information about using them.

Option | Can be specified by parameter string? | Default
ALl31 | Yes | OFF
COUNTRy | Yes | US
Heap | Yes | 32K, 32K, ANYWHERE, KEEP, 8K, 4K
MSGFile | Yes | SYSOUT
NATlang | Yes | ENU
RPTOpts | No | OFF
RPTStg | No | OFF
STOrage | Yes | NONE, NONE, NONE, 8K
UPSI | Yes | 00000000
Note:
  • The shortest abbreviation you can use for each run-time option is shown in capital letters.
  • Specifying an invalid option results in error CEE3611I ("The run-time option option was an invalid run-time option").
  • Specifying an invalid suboption results in error CEE3616I ("The string string was not a valid suboption of the run-time option option").
Parent topic: LE Run-Time Options


Unsupported LE Run-time Options

The following table shows valid but unsupported run-time options. Specifying any of these options results in error MFX9999I ("The run-time option option is not supported in this release").

ABPERC | ERRCOUNT | PUNUNIT
ABTERMENC | ERRUNIT | RDRUNIT
AIX | FILEHIST | RECPAD
AIXBLD | FLOW, NOFLOW | NORTEREUS
ANYHEAP | INQPCOPN | SIMVRD
AUTOTASK | INTERRUPT | STACK
BELOWHEAP | LIBSTACK | TERMTHDACT
CBLOPTS | MSGQ | TEST
CBLPSHPOP | NONIPTSTACK | THREADHEAP
CBLQDA | OCSTATUS | TRACE
CHECK | PC | TRAP
DEBUG | PLITASKCOUNT | USRHDLR
DEPTHCONDLMT | POSIX | VCTRSAVE
ENVAR | PRTUNIT | XUFLOW

The following list shows LE run-time options that are valid but only supported by the C language or in a mainframe environment. Specifying any of these options results in error CEE3618I ("The run-time option option was not valid from the invocation command ").

ARGPARSE | EXECOPS | REDIR
ENV | PLIST | RTEREUS
Parent topic: LE Run-Time Options
Related information
Supported LE Run-time Options


Specifying LE Run-time Options

You can specify LE run-time options in a configuration file specified by the MFLECONFIG environment variable. MFLECONFIG must specify the filename, including path, of a text file that contains the run-time options you want to use. For example:

SET MFLECONFIG = c:\templates\prod\le_set1.cfg

You must specify each run-time option on a line of its own in the configuration file. The syntax for each option is the same as that defined in the IBM Language Environment Programming Reference.

You can use the IBM-defined abbreviations for the run-time options. The shortest abbreviation you can use for each run-time option is shown in capital letters in Supported LE Run-time Options. For example, you can abbreviate MSGFILE to MSGFIL, MSGFI or MSGF, but MSG will not be recognized.

The IBM-defined default values are used for any supported run-time options that you do not specify in the configuration file.

Parent topic: LE Run-Time Options
Related information
IBM Language Environment Programming Reference


LE Error Conditions

The following table lists the error conditions detected by LE support in this COBOL system.

Error condition | Routines | Message | Severity
Heap storage control information damaged | CEECRHP, CEECZST, CEEDSHP, CEEFRST, CEEGTST | CEE0802I | 4
Unsupported routine |  | MFX9999I | 4
Invalid case code | CEENCOD | CEE0401I | 3
Invalid control code | CEENCOD | CEE0402I | 3
Invalid security code | CEENCOD, CEEDCOD | CEE0403I | 3
Invalid facility-ID | CEENCOD | CEE0404I | 3
Invalid destination code | CEEMOUT | CEE0451I | 3
Heap identifier not recognized | CEEDSHP, CEEGTST | CEE0803I | 3
Initial size value invalid | CEECRHP | CEE0804I | 3
Increment size value invalid | CEECRHP | CEE0805I | 3
Option value not recognized | CEECRHP | CEE0806I | 3
Requested storage size not positive | CEECZST, CEEGTST | CEE0808I | 3
Storage address not recognized | CEECZST, CEEFRST | CEE0810I | 3
Invalid attempt to discard initial heap | CEEDSHP | CEE0812I | 3
Insufficient storage available | CEECRHP, CEEGTST | CEE0813I | 3
UCT/GMT offset not available | CEEGMT,CEEUTC | CEE2502I | 3
UCT/GMT offset not available | CEEGMTO | CEE2503I | 3
Input seconds not in range | CEEDATM, CEESECI | CEE2505I | 3
Insufficient data | CEECBLDY | CEE2507I | 3
Hours value not recognized | CEEISEC, CEESECS | CEE2510I | 3
Day value not recognized | CEEISEC | CEE2511I | 3
Lilian date not within range | CEEDATE, CEEDYWK | CEE2512I | 3
Year value not recognized | CEEISEC | CEE2514I | 3
Milliseconds value not recognized | CEEISEC | CEE2515I | 3
Date value not recognized | CEECBLDY | CEE2517I | 3
Invalid picture string | CEECBLDY | CEE2518I | 3
Seconds value not recognized | CEEISEC | CEE2519I | 3
Date string not matching picture | CEEBLDY | CEE2520I | 3
Invalid seed value | CEERAN0 | CEE2524I | 3
Local time not available from the system | CEELOCT | CEE2531I | 3
Only one language on stack | CEE3LNG | CEE3450I | 3
Invalid language | CEE3LNG | CEE3451I | 3
Function not recognized | CEE3LNG | CEE3452I | 3
Only one country code on stack | CEE3CTY | CEE3455I | 2
Invalid country code | CEE3CTY | CEE3456I | 3
Invalid function | CEE3CTY | CEE3457I | 3
Illegal century value | CEESCEN | MFX9999I | 3
Parameter string longer than 80 bytes | CEE3PRM | CEE3649I | 1
Parent topic: Language Environment (LE) Support


LE Run-Time Options Error Messages

The COBOL system can produce the following error messages while checking the syntax of a parameter string specifying run-time options.

  • MFX9999I The run-time option option is not supported in this release
    A run-time option has been specified which is defined in Language Environment but is not supported by this COBOL system.
  • CEE3601I The string string was found where a delimiter was expected following a quoted suboption for the run-time option option
    A quoted suboption must be followed by a comma, right parenthesis, or space.
  • CEE3602I An end quote delimiter did not occur before the end of the run-time option string
    A start quote, either single or double, does not have a matching end quote.
  • CEE3603I The character character is not a valid run-time option delimiter
    Options must be separated by either a space or a comma.
  • CEE3605I The string string was found where a delimiter was expected following the suboptions for the run-time option option
    Suboptions that are enclosed within parentheses must be followed by either a space or a comma.
  • CEE3606I The string string was too long and was ignored
    The maximum number of characters permitted for an option or suboption has been exceeded.
  • CEE3607I The end of the suboption string did not contain a right parenthesis
    A left parenthesis does not have a matching right parenthesis.
  • CEE3608I The following messages pertain to the invocation command run-time options
    The messages that follow this one, up to the next message of this type with a different source, refer to the run-time options specified on the invocation command.
  • CEE3610I The run-time option old-option was mapped to the run-time option le-option
    old-option was an option from a previous release that was supported by Language Environment for compatibility.
  • CEE3611I The run-time option option was an invalid run-time option
    An option has been specified which is not a valid option or is an option that is recognized by Language Environment for compatibility with a previous release.
  • CEE3612I Too many suboptions were specified for the run-time option option
    The number of suboptions exceeds the maximum number that can be specified for the specified option. The excess suboptions are ignored.
  • CEE3614I An invalid character occurred in the numeric string string of the run-time option option
    A numeric value does not contain all decimal numeric characters.
  • CEE3615I The installation default for the run-time option option could not be overridden
  • CEE3616I The string string was not a valid suboption of the run-time option option
    A suboption has been specified which is not one of the suboptions defined for the specified option.
  • CEE3617I The number number of the run-time option option exceeded the range of -2147483648 to 2147483647
    A numeric value is outside the range of -2147483648 to 2147483647.
  • CEE3618I The run-time option option was not valid from the invocation command
    A run-time option has been specified which is not valid on the invocation command.
  • CEE3619I The value value was not a valid MSGQ number
  • CEE3622I The option option quoted suboption string string was not one character long
    The only valid length for STORAGE suboptions within quotes is one.
  • CEE3623I The UPSI option suboption string string was not eight characters long
    The only valid length for the value of the UPSI suboption is eight.
  • CEE3633W The total length of the combined ENVAR strings exceeded 250 characters
    The total length of the combined ENVAR strings exceeded the maximum limit of 250 characters.
  • CEE3634I The number number of the run-time option option exceeded the range of -32768 to 32767
    number exceeded the range of -32768 to 32767.
  • CEE3635I The string string was not a valid RECFM suboption specification for run-time option option
    The RECFM suboption value must be F, FA, FB, FBA, FBS, FBSA, U, UA, V, VA, VB, or VBA.
  • CEE3636I The value number exceeded the maximum allowable LRECL or BLKSIZE of 32760 bytes
    The value of the LRECL or BLKSIZE suboption cannot be greater than 32760.
  • CEE3637I The number number specified in the suboption suboption of the run-time option option is not a valid hexadecimal number in the range 0 to FFFFFFFF
    An invalid hexadecimal numeral was specified or the range of the number exceeds 0 to FFFFFFFF.
  • CEE3638I The table size of size, specified in the TRACE run-time option, exceeds the maximum allowed value of 16777215
    size exceeded the maximum allowed value of 16777215.
Parent topic: Language Environment (LE) Support
Related information
Supported LE Run-time Options


MFX9999I The run-time option option is not supported in this release

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3601I The string string was found where a delimiter was expected following a quoted suboption for the run-time option option

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3602I An end quote delimiter did not occur before the end of the run-time option string

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3603I The character character is not a valid run-time option delimiter

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3605I The string string was found where a delimiter was expected following the suboptions for the run-time option option

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3606I The string string was too long and was ignored

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3607I The end of the suboption string did not contain a right parenthesis

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3608I The following messages pertain to the invocation command run-time options

Resolution:

No response is required.

Parent topic: LE Run-Time Options Error Messages


CEE3610I The run-time option old-option was mapped to the run-time option le-option

Resolution:

Consult the appropriate migration guide for a list of options supported for the language. Change the run-time options string to use the le-option instead.

Parent topic: LE Run-Time Options Error Messages


CEE3611I The run-time option option was an invalid run-time option

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3612I Too many suboptions were specified for the run-time option option

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3614I An invalid character occurred in the numeric string string of the run-time option option

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3615I The installation default for the run-time option option could not be overridden

Resolution:

Correct the run-time options to not specify this option.

Parent topic: LE Run-Time Options Error Messages


CEE3616I The string string was not a valid suboption of the run-time option option

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3617I The number number of the run-time option option exceeded the range of -2147483648 to 2147483647

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3618I The run-time option option was not valid from the invocation command

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3619I The value value was not a valid MSGQ number

Resolution:

Correct the value in the run-time options string to be greater than zero.

Parent topic: LE Run-Time Options Error Messages


CEE3622I The option option quoted suboption string string was not one character long

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3623I The UPSI option suboption string string was not eight characters long

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3633W The total length of the combined ENVAR strings exceeded 250 characters

Resolution:

Reduce the total length of the ENVAR strings to less than the 250-character maximum.

Parent topic: LE Run-Time Options Error Messages


CEE3634I The number number of the run-time option option exceeded the range of -32768 to 32767

Resolution:

Correct the run-time options string to be within the range of -32768 to 32767.

Parent topic: LE Run-Time Options Error Messages


CEE3635I The string string was not a valid RECFM suboption specification for run-time option option

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3636I The value number exceeded the maximum allowable LRECL or BLKSIZE of 32760 bytes

Resolution:

Correct the run-time options string.

Parent topic: LE Run-Time Options Error Messages


CEE3637I The number number specified in the suboption suboption of the run-time option option is not a valid hexadecimal number in the range 0 to FFFFFFFF

Resolution:

Correct the run-time options string to be a valid hexadecimal number in the range of 0 to FFFFFFFF.

Parent topic: LE Run-Time Options Error Messages


CEE3638I The table size of size, specified in the TRACE run-time option, exceeds the maximum allowed value of 16777215

Resolution:

Correct the TRACE run-time options to not exceed the maximum of 16777215.

Parent topic: LE Run-Time Options Error Messages


LE Country Codes

The following table lists the two-character codes for the countries that are supported by the COUNTRY run-time option and by the callable routine CEE3CTY. The only effect of these codes is to set the national currency symbol for the application.

Country | Code
Afghanistan | AF
Albania | AL
Algeria | DZ
Andorra | AD
Angola | AO
Antigua and Barbuda | AG
Argentina | AR
Australia | AU
Austria | AT
Bahamas | BS
Bahrain | BH
Bangladesh | BD
Barbados | BB
Belgium | BE
Benin | BJ
Bermuda | BM
Bolivia | BO
Bosnia/Herzegovina | BA
Botswana | BW
Brazil | BR
Brunei Darussalam | BN
Bulgaria | BG
Burkina Faso | BF
Burma | BU
Canada | CA
Cayman Islands | KY
Chad | TD
Chile | CL
China, Peoples Republic of | CN
China, Republic of | TW
Colombia | CO
Costa Rica | CR
Croatia | HR
Cuba | CU
Cyprus | CY
Czech Republic | CZ
Czechoslovakia | CS
Denmark | DK
Dominican Republic | DO
Ecuador | EC
Egypt | EG
El Salvador | SV
Estonia | EE
Ethiopia | ET
Finland | FI
France | FR
Gabon | GA
Gambia | GM
Germany | DE
Ghana | GH
Greece | GR
Guatemala | GT
Guinea-Bissau | GW
Guyana | GY
Haiti | HT
Honduras | HN
Hong Kong | HK
Hungary | HU
Iceland | IS
India | IN
Indonesia | ID
Iran | IR
Iraq | IQ
Ireland | IE
Israel | IL
Italy | IT
Jamaica | JM
Japan | JP
Jordan | JO
Kenya | KE
Korea, Republic of | KR
Kuwait | KW
Latvia | LV
Lebanon | LB
Lesotho | LS
Liberia | LR
Libya | LY
Liechtenstein | LI
Lithuania | LT
Luxembourg | LU
Macau | MO
Macedonia | MK
Madagascar | MG
Malawi | MW
Malaysia | MY
Mali | ML
Mauritania | MR
Mauritius | MU
Mexico | MX
Monaco | MC
Morocco | MA
Mozambique | MZ
Namibia | NA
Netherlands | NL
Netherlands Antilles | AN
New Caledonia | NC
New Zealand | NZ
Nicaragua | NI
Niger | NE
Nigeria | NG
Norway | NO
Oman | OM
Pakistan | PK
Panama | PA
Papua New Guinea | PG
Paraguay | PY
Peru | PE
Philippines | PH
Poland | PL
Portugal | PT
Puerto Rico | PR
Qatar | QA
Romania | RO
Russia | RU
Saint Lucia | LC
Saudi Arabia | SA
Senegal | SN
Seychelles | SC
Sierra Leone | SL
Singapore | SG
Slovakia | SK
Slovenia | SI
Somalia | SO
South Africa | ZA
Spain | ES
Sri Lanka | LK
Sudan | SD
Surinam | SR
Swaziland | SZ
Sweden | SE
Switzerland | CH
Syria | SY
Tanzania | TZ
Thailand | TH
Togo | TG
Tunisia | TN
Turkey | TR
Uganda | UG
USSR | SU
United Arab Emirates | AE
United Kingdom | GB
United States | US
Uruguay | UY
Vanatu | VU
Venezuela | VE
Western Samoa | WS
Yemen | YE
Yugoslavia | YU
Zaire | ZR
Zambia | ZM
Zimbabwe | ZW
Parent topic: Language Environment (LE) Support


HCO for SQL Server (HCOSS)

HCO for SQL Server (HCOSS) provides tools for migrating DB2 databases and applications to SQL Server 2008 databases and applications. It is a superset of OpenESQL; therefore applications that use HCOSS have access to all OpenESQL functionality.

For third-party software requirements, see the Database Access Support with Native COBOL topic.

  • Using HCOSS with Windows User Account Control (UAC)
    Describes how to use HCOSS with Windows UAC.
  • HCOSS Toolset
  • Working With HCOSS SQL CLR Stored Procedures and Result Sets
  • Scope - HCOSS SQL Compiler Directive Options
    Describes the scope of each HCOSS SQL compiler directive option with regard to its use at compile and run time.
  • Managing Connections
  • Migrating Databases
  • Migrating Applications
  • Deploying Native Applications
  • Managing Log Files
  • Customizing HCOSS
  • How to...
  • Reference
Parent topic: Mainframe Programming


Using HCOSS with Windows User Account Control (UAC)

Restriction: This topic applies to the Windows Vista and 7 operating systems and later. It does not apply to the Windows XP operating system.

When you have enabled the Windows User Account Control (UAC) feature, HCOSS exhibits different behavior depending on whether or not you are logged in as a standard user or an administrator, whether or not you are a member of the Windows Administrators group, and how you start the HCOSS user interface.

Standard User and Administrator Modes

You can run HCOSS as a standard user or as an administrator. When you run as an administrator, all HCOSS features are available to you. However, when you run HCOSS as a standard user, some features are limited. We recommend that you run HCOSS as an administrator when possible.

HCOSS UAC Behavior

When using UAC, HCOSS runs in either standard user or administrator mode, depending on these three factors:
  • The Windows group to which you belong - standard user or administrator
  • How you start HCOSS - from the Start menu or from within the Visual Studio IDE
  • The settings for HCOSS UAC Behavior options

To run HCOSS in standard user mode

The following scenarios show how to run HCOSS in standard user mode, limiting access to some features. In each scenario, the statement in each first-level bullet point must be true. Assume all HCOSS UAC Behavior options are set to their defaults:
Scenario 1
  • You are logged into Windows as a standard user
  • You are not part of the Administrator group
  • You start HCOSS as a standard user using either of the following methods:
    • From within the Visual Studio IDE by selecting Tools > Micro Focus COBOL Tools > HCO for SQL Server Tools
    • From the Start menu
Scenario 2
  • You are logged into Windows as a standard user
  • You are also part of the Windows Administrator group
  • You start HCOSS using either of the following methods:
    • From within the Visual Studio IDE by selecting Tools > Micro Focus COBOL Tools > HCO for SQL Server Tools
    • From the Start menu, answering No to any subsequent prompts.
Scenario 3
  • You are logged into Windows as an administrator
  • You start HCOSS from the Start menu, answering No to any subsequent prompts

To run HCOSS in administrator mode

The following scenarios show how to run HCOSS in administrator mode, providing full access to all features. In each scenario, the statement in each first-level bullet point must be true:
Scenario 1
  • You are logged into Windows as a standard user
  • You are a member of the Windows Administrator group
  • You start HCOSS using either of the following methods:
    • From the Start menu, answering Yes to any subsequent prompts
    • From the Start menu by right-clicking HCO for SQL Server and selecting Run as administrator
Scenario 2
  • You are logged into Windows as an administrator
  • You start HCOSS using any of the following methods:
    • From within the Visual Studio IDE by selecting Tools > Micro Focus COBOL Tools > HCO for SQL Server Tools
    • From the Start menu
    • From the Start menu by right-clicking HCO for SQL Server and selecting Run as administrator

HCOSS UAC Prompts

By default, HCOSS could prompt you at startup depending on the settings of the HCOSS UAC Behavior options. You might encounter one or both of the following prompts:
Relaunch HOCSS as Administrator
This prompt appears by default when:
  • You are a member of the Administrator group
  • You launch HCOSS from the Start menu without selecting Run as administrator

If you respond Yes to this prompt, HCOSS relaunches in administrator mode, and Windows displays the User Account Control dialog box. Respond to this prompt as appropriate.

If you respond No to this prompt, HCOSS resumes launching in standard user mode.

If you check Stop asking me, HCOSS changes the default setting of the Prompt to automatically run as Administrator option from True to False.

Running as Non-Administrator Information
When you are running HCOSS in standard user mode and you are not a member of the Administrators group, this dialog box appears to notify you that some features are limited in standard user mode.

If you check Do not tell me again, HCOSS changes the default setting of the Warn non-Administrator users of limited functionality option from True to False.

Note: You can change the default HCOSS behavior with regard to launching HCOSS with UAC and UAC prompts by setting the options manually. For information on setting HCOSS UAC Behavior options, see Options.
Parent topic: HCO for SQL Server (HCOSS)
Related tasks
To start HCO for SQL Server
To set HCOSS options
Related reference
Options


HCOSS Toolset

The HCOSS toolset includes:

  • Manage Connections Tool - Enables you to connect to both your mainframe's DB2 database and a SQL Server database running locally or remotely on a local area network.
  • Database Migration Tools
    • Extract Schema - Downloads the DB2 database schema objects and creates an XML schema file representing the schema structure.
    • Assess Data Migration - Produces an editable report of the information in your extracted schema.
    • Define Lists - Reads the XML schema file created using the Extract Schema tool and enables you to create a list of database objects to transfer to the SQL Server database.
    • Generate DDL - Reads both the XML schema file and the list of selected database objects and translates the information into a SQL Server DDL script.
    • Transfer Data - Builds and executes an SSIS package to move each specified database object to your SQL Server database.
    • Compare Data - Verifies the validity of newly imported data by comparing it with the original data.
  • Application Migration Tools
    • Assess Application Migration - Analyzes the EXEC SQL statements in your DB2 program and copybook code and flags statements that could potentially cause problems when migrating to SQL Server in different migration scenarios, with and without using HCOSS.
    • Manage Packages and Plans - Create and edit scripts that enable you to bind DBRM members, packages, and plans to your COBOL programs, and to free packages and plans.
  • Customization Tools
    • Customize Type Mappings - View or change the default type mappings for your SQL database.
    • Customize SQL Name Mappings - View or change the default SQL name mappings in your SQL database.
    • Options - Set properties for HCOSS.
Parent topic: HCO for SQL Server (HCOSS)
Related concepts
Manage Connections Tool
Migrating Databases
Migrating Applications
Why You Should Use the Assess Application Migration Tool
Related tasks
To start HCO for SQL Server
To set HCOSS options
Related reference
Options


Working With HCOSS SQL CLR Stored Procedures and Result Sets

An HCOSS SQL CLR stored procedure can:

  • Accept input parameters
  • Return output parameters
  • Accept and return input/output parameters
  • Return one or more result sets
Note: You can create HCOSS SQL CLR stored procedures using our Visual COBOL for Visual Studio product. In addition, applications that call SQL CLR stored procedures must be compiled with DBMAN=ODBC.

Calling a SQL CLR Stored Procedure that Returns No Result Sets

To call an HCOSS stored procedure that returns no result sets, use the CALL embedded SQL statement. For complete details on using the CALL statement, see the topic CALL.

Receiving Result Sets From a SQL CLR Stored Procedure

If a stored procedure returns one or more result sets, you receive the result sets using a series of embedded SQL statements. First, use the CALL statement to call the stored procedure. Next, use the ASSOCIATE LOCATORS statement to define an appropriate number of result sets. Then, issue one ALLOCATE CURSOR statement for defined result set. For example, the following code returns two result sets by associating two result set locators with two allocated cursors, in effect mapping the result sets to the cursors:

     EXEC SQL CALL MYPROC(:hv-country)
     END-EXEC
     EXEC SQL
        ASSOCIATE LOCATORS (:RS1,:RS2) WITH PROCEDURE MYPROC
     END-EXEC
     EXEC SQL
         ALLOCATE C1 CURSOR FOR RESULT SET :RS1
     END-EXEC
     EXEC SQL
         ALLOCATE C2 CURSOR FOR RESULT SET :RS2
     END-EXEC

At this point, use the FETCH statement to fetch each result set, just like any other SQL cursor. You can also interleave access to these cursors at the same time. For example, using the scenario provided above, you could fetch from C1, and then immediately fetch from C2.

Finally, when you are done with cursor processing, use the CLOSE statement to end result set processing.

Parent topic: HCO for SQL Server (HCOSS)
Related reference
GET NEXT RESULT SET


Scope - HCOSS SQL Compiler Directive Options

Each HCOSS SQL compiler directive option is used either at compile time, runtime, or both. The behavior at run time is described as Source file, meaning that when a source file specifies the directive, the value set in the source file is used.

For information on the scope of each HCOSS SQL compiler directive option, see its corresponding Reference topic.

Parent topic: HCO for SQL Server (HCOSS)
Related reference
ACCESS
BIND
DBRMLIB
DIALECT
MEMBER
PROMOTE
QUALIFIER
VERSION
TIMEDELIM
DATEDELIM
TSTAMPSEP
DETECTDATE


Managing Connections

To successfully migrate DB2 databases and applications to SQL Server, you must establish a connection to both databases. You can do this using the Manage Connections tool, or a combination of other connection utilities.

For ODBC connectivity, HCOSS supports SQL Server Native Client 10.0 and 11.0. We recommend that you always use the most recent version of this driver available when creating new connections. We also recommend that you upgrade existing connections to use the most recent driver when possible. HCOSS detects the ODBC driver version at startup, when creating, editing, and repairing SQL Server system or user connection types, and provides the option to upgrade where appropriate.

  • Manage Connections Tool
  • Connection Types
  • Advanced Connection Options
Parent topic: HCO for SQL Server (HCOSS)


Manage Connections Tool

The Manage Connections tool enables you to make the SQL Server and DB2 connections needed to run your applications.

It includes the following key functionality:

  • Creates ADO.NET connections to your mainframe DB2 database.
  • Maintains a catalog of DSN connections, including the provider used to access the connection and the connection parameters used by the provider.
  • Automatically creates both ADO.NET and ODBC connections to SQL Server using one set of connection parameters.
  • Sets both 32-bit and 64-bit connections on 64-bit operating systems using one set of connection parameters.
  • Enables you to define either system or user connection types.
  • Creates export XML files you can use to import connections into either the ADO.NET Connection Editor or the Manage Connections tool.
  • Provides the option to upgrade the ODBC driver where appropriate.
Note: The Manage Connections tool is not compatible with DB2 ODBC connections.
Parent topic: Managing Connections
Related concepts
HCOSS Toolset
Application Migration Process
Deploying Native Applications
Connection Types
Related tasks
To create a DB2 connection
To create a system or user SQL Server connection
To import a connection
To export a connection
To repair a connection
Related reference
Manage Connections Tool Log Files
Manage Connections Tool Error Messages
DB2 Connection tab
SQL Server Connection tab
Export tab
Import tab
Connection List tab


Connection Types

HCOSS provides the System and User connection types. For each, connection information is tracked and stored in a series of files.

System Connection Type

The Manage Connections tool tracks and stores connection information in the following files:
%PROGRAMDATA%\Micro Focus\HCOSS\Connections\ConnectionTracking.hcocon
A work file containing tracking information.
%WINDOWS%\Microsoft.NET\Framework\v2.0.50727\CONFIG\machine.config
A configuration file that stores 32-bit framework 2.0, 3.0, and 3.5 (CLR 2) system connection strings.
%WINDOWS%\Microsoft.NET\Framework\v4.0.30319\Config\machine.config
A configuration file that stores 32-bit framework 4.0 (CLR 4) system connection strings.
%WINDOWS%\Microsoft.NET\Framework64\v2.0.50727\CONFIG\machine.config
A configuration file that stores 64-bit framework 2.0, 3.0, and 3.5 (CLR 2) system connection strings.
%WINDOWS%\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config
A configuration file that stores 64-bit framework 4.0 (CLR 4) system connection strings.

User Connection Type

The Manage Connections tool tracks and stores connection information in the following files:
%LOCALAPPDATA%\Micro Focus\HCOSS\Connections\UserConnectionTracking.hcocon
A work file containing tracking information.
%LOCALAPPDATA%\Micro Focus\UserConnections32_v2.config
A configuration file that stores 32-bit framework 2.0, 3.0, and 3.5 (CLR 2) user connection strings.
%LOCALAPPDATA%\Micro Focus\UserConnections32_v4.config
A configuration file that stores 32-bit framework 4.0 (CLR 4) user connection strings.
%LOCALAPPDATA%\Micro Focus\UserConnections64_v2.config
A configuration file that stores 64-bit framework 2.0, 3.0, and 3.5 (CLR 2) user connection strings.
%LOCALAPPDATA%\Micro Focus\UserConnections64_v4.config
A configuration file that stores 64-bit framework 4.0 (CLR 4) user connection strings.
Parent topic: Managing Connections
Related concepts
Manage Connections Tool
Related tasks
To create a DB2 connection
To create a system or user SQL Server connection
To import a connection
To export a connection
To repair a connection
Related reference
Manage Connections Tool Log Files
Manage Connections Tool Error Messages


Advanced Connection Options

As an alternative to the Manage Connections tool, you can also establish appropriate connections using a combination of the Micro Focus ADO.NET Connection Editor and the Microsoft ODBC Data Source Administrator tool. This can be useful if you want to fine-tune your connection settings, including those that are set to defaults when you use the Manage Connections tool.

If you choose to use the ADO.NET Connection Editor and Microsoft ODBC Data Source Administrator to create and catalog your connections, be aware that your development environment can affect your connections.

In 64-bit environments, Microsoft provides 32-bit and 64-bit versions of the ODBC Administrator tool. You might need to create 32- and 64-bit versions of some connections. Here are the scenarios and required connections necessary for using a connection with HCOSS tools:

Scenario | Required Connections
Using HCOSS database migration tools in a 32-bit environment | 32-bit ADO.NET DB2 and ADO.NET SQL Server
Using HCOSS database migration tools in a 64-bit environment | 32- and 64-bit ADO.NET DB2 and ADO.NET SQL Server
Using HCOSS application migration tools in a 32-bit environment, and targeting a 32-bit environment (x86) | 32-bit ADO.NET SQL Server and ODBC SQL Server
Using HCOSS application migration tools in a 64-bit environment, and targeting a 32-bit environment (x86) | 32- and 64-bit ADO.NET SQL Server and 32-bit ODBC SQL Server
Using HCOSS application migration tools in a 64-bit environment, and targeting a 64-bit environment (x64) | 32- and 64-bit ADO.NET SQL Server and ODBC SQL Server

To specify 32-bit and 64-bit connections, use the radio buttons provided on the ADO.NET Connection Editor Connection tab, and the corresponding Microsoft ODBC Data Source Administrator tool.

In 64-bit environments, if UAC is turned on:
  • Run the ADO.NET Connection Editor as an administrator
  • If you want to change the connection list in Visual Studio, then run Visual Studio as an administrator as well.
Note: The ADO.NET Connection Editor and the ODBC Data Source Administrator are available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Data Tools > Data Connections.

You can also launch the ADO.NET Connection Editor from the OpenESQL Assistant in Visual Studio.

Parent topic: Managing Connections


Migrating Databases

HCO for SQL Server (HCOSS) provides tools and methods for migrating DB2 databases from the mainframe to SQL Server databases on a Local Area Network.

Note: For information about prerequisite third-party software and supported DB2 versions, see the HCO for SQL Server (HCOSS) section in the topic Database Access Support with Native COBOL.
  • DB2 Database Migration Process
  • Extract Schema Tool
  • Assess Data Migration Tool
  • Define Lists Tool
  • Generate DDL Tool
  • Transfer Data Tool
  • Compare Data Tool
Parent topic: HCO for SQL Server (HCOSS)
Related concepts
HCOSS Toolset


DB2 Database Migration Process

Use HCOSS to migrate the DB2 databases from your mainframe to SQL Server (2008) databases that run on Windows.

The basic process is as follows:

  1. Install prerequisite third-party software, including:
    • Microsoft .NET Framework 4.0.
    • SQL Server 2008 Enterprise Edition or Developer Edition, including Microsoft SQL Server Management Studio.
    • Microsoft OLE DB Provider for DB2 for SQL Server 2008. This is generally available as part of a SQL Server 2008 Feature Pack download.
    Note: If you intend to develop applications on your local machine, but deploy applications to a SQL Server database on a remote machine, install SQL Server Native Client 10.x for ODBC connectivity on your local machine instead of installing SQL Server 2008. For information on configuring a remote machine, see the topic Deploying to a Remote SQL Server.
  2. Get your mainframe user ID, password, network address and port, and the catalog and package collection names from your DBA.
  3. Run the Data Access Tool that comes with the OLE DB provider, and use it to:
    • Create a new data source to connect to the mainframe
    • Test the connection
    • Create the packages used by the provider
    • Run the sample query
  4. Create a destination SQL Server database using Microsoft SQL Server 2008 SQL Server Management Studio.
  5. Create a connection to your SQL Server database using the Manage Connections tool.
  6. Extract the DB2 schemas from your mainframe DB2 database to a local or shared directory using the Extract Schema tool.
  7. Optionally assess the data migration by viewing and editing the information in the schema extract file created by the Extract Schema tool.
  8. Define a list of extracted DB2 schema objects that you want to migrate to the SQL Server database using the Define Lists tool.
  9. Create an SQL script to create the DB2 schema objects in the new SQL Server database using the Generate DDL tool.
  10. Populate the SQL Server database with the selected schema objects from the DB2 database using the Transfer Data tool.
  11. Verify the results of the transferred data using the Compare Data tool.
Parent topic: Migrating Databases
Related concepts
Extract Schema Tool
Define Lists Tool
Generate DDL Tool
Transfer Data Tool
Compare Data Tool
Deploying Native Applications


Extract Schema Tool

Use the Extract Schema tool to download DB2 schema from the mainframe. This is the first step when migrating a DB2 database to a SQL Server database. You can run the tool either from the HCOSS user interface, or from the command line using the MFExtractSchemaInfo command.

Note: The user ID and password combination you use to connect to your mainframe must grant you read access to your DB2 system catalog tables. For a complete list of required tables, see the topic Required DB2 Catalog Tables.
The Extract Schema tool includes the following functionality:
  • Connects with the DB2 database
  • Requests a list of available schemas in the DB2 database
  • Populates the tool with the list of available schemas
  • Enables selection of specific schemas for migration
  • Enables selection of an estimated or actual table row count for each table in the schema
  • Generates an XML file containing a representation of the objects in the selected schemas, including:
    • Dependent objects such as dependent tables or views and tables referenced by a foreign key in a different table
    • Parameter values necessary to create the same schema objects in SQL Server 2008
  • Reports results

The login credentials used to connect to the mainframe DB2 database must grant READ access to the following DB2 system catalog tables:

Object Type | DB2 System Catalog Tables
tables, columns | SYSTABLES, SYSCOLUMNS, SYSSEQUENCES
indexes | SYSINDEXES, SYSKEYS
constraints (relational, check, key) | SYSCHECKS, SYSCHECKDEP, SYSCHECKS2, SYSCONSTDEP, SYSTABCONST, SYSKEYCOLUSE, SYSRELS, SYSFOREIGNKEYS
views | SYSVIEWS, SYSVIEWDEPENDENCY

The following shows the data tables extracted by the Extract Schema tool:

Table, Column, Index

HCOSS uses the generated schema extract file in the next step of the database migration process - defining lists of specific tables and views to migrate.

Parent topic: Migrating Databases
Related concepts
DB2 Database Migration Process
Related tasks
To extract DB2 schemas
Related reference
MFExtractSchemaInfo command
Extract Schema Tool Log Files
Extract Schema Tool Error Messages
Required DB2 Catalog Tables
Schema Extract tab
Results tab


Assess Data Migration Tool

The Assess Data Migration tool enables you to examine extracted DB2 schemas to estimate the table sizes, and to identify the tables you want to migrate to your SQL Server database using HCOSS.

The Assess Data Migration Tool provides the following functionality:

  • Reads the content of an extracted schema file created using the Extract Schema tool.
  • Shows the contents of the extracted schema, including the following information for each table represented in the schema:
    • Creator
    • Name
    • Row count
    • Count type
    • Maximum row size
    • Data volume
    • Transfer option
    • Date of last update
  • Provides two count type options for each table:
    • Actual - Determined by running a query against the DB2 table on the mainframe. Depending on the table size, this could be time consuming; however, the results are reliably accurate.
    • Estimated - Based on the statistics collected by the DB2 RUNSTATS utility. While this is the most time-efficient method for determining table size, it is not always accurate because the statistics can be out of date.
    The default setting is based on the Table Row Count option you selected when extracting the schema.
  • Provides two data migration transfer options for each table represented in the extracted schema:
    • HCOSS - to migrate all data in the table
    • OTHER - to bypass migration of the data in the table
  • Updates the schema extract file with your changes.
  • Provides a report of error messages encountered when updating the schema extract file.
  • Enables you to save the extracted schema information as a flat text file or in CSV format compatible with spreadsheet software.
Parent topic: Migrating Databases
Related tasks
To assess data migration
Related reference
Data Assessment Tasks tab
Create New Data Assessment Task dialog box
Results tab
Schema Extract tab


Define Lists Tool

Use the Define Lists tool to select specific tables and views with which to generate a list of objects to transfer to your SQL Server database. The Generate DDL tool uses this list to create SQL Server objects. You can run the tool either from the HCOSS user interface, or from the command line using the MFObjectList command.

The Define Lists tool includes the following functionality:
  • Reads the XML file generated by the Extract Schema tool
  • Provides a list of available objects
  • Enables selection of specific objects to transfer
  • Saves the transfer information to a file, enabling future editing of the list
    Note: You cannot change the source schema for an existing transfer list unless it is empty.

HCOSS uses the saved transfer information in the next step of the database migration process - generating DDL tasks to move the data.

Parent topic: Migrating Databases
Related concepts
DB2 Database Migration Process
Related tasks
To define an object transfer list
Related reference
MFObjectList command
Define Lists Tool Log Files
Define Lists Tool Error Messages
Transfer Lists tab
Create New List dialog box


Generate DDL Tool

Use the Generate DDL tool to create the DDL script used to migrate your DB2 schema objects to your SQL Server database. Each script you create is one DDL task. As with the other HCOSS tools, you name your DDL tasks and store them in a local or shared location.

You can run the Generate DDL tool either from the HCOSS user interface, or from the command line using the MFDDLConverter command.

To run the Generate DDL tool, you must have:
  • A schema extract file containing schema objects, created using the Extract Schema tool.
  • An object transfer list created using the Define Lists tool.
  • A connection to your production SQL Server database against which to execute your DDL scripts. Optional if you're using the tool only for the purpose of exporting a DDL script.
  • A connection to a test SQL Server database (optional).
The Generate DDL tool includes the following functionality:
  • Reads the schema extract file, filtered by the object transfer list that specifies the objects you want to migrate
  • Translates the database structure found in the extracted schema and transfer list, including schemas, tables, views, indexes, constraints, and relational information, into a SQL Server 2008 DDL script
  • Creates DDL script commands that drop and create objects, or restore missing objects in the SQL Server database
  • Maps DB2 data types to SQL Server 2008 data types
  • Creates tables using data type mappings defined in the Customize Type Mappings tool
  • Enables you to customize DDL at the object level
  • Enables you to edit schema mappings
  • Tests DDL task specifications against a test SQL Server data source
  • Executes generated DDL against your production SQL Server
  • Enables you to export the generated DDL as an SQL script
  • Reports results of DDL test runs and executions

HCOSS uses DDL tasks in the next step of the database migration process - transferring the data to the SQL database.

Note: HCOSS does not support XML indexes. Therefore, no XML indexes existing in the DB2 database are created in the DDL. Likewise, any column that is part of an index and is mapped to the SQL Server XML data type is not created. This is true even if the originating DB2 index and column are of XML type but are mapped to the XML data type.
Parent topic: Migrating Databases
Related concepts
DB2 Database Migration Process
Related tasks
To generate and execute DDL
To customize generated DDL
To customize schema mappings in DDL
Related reference
MFDDLConverter command
Generate DDL Tool Log Files
Generate DDL Tool Error Messages
DDL Tasks tab
Create New DDL Task dialog box
Customize DDL tab
Schema Mappings tab
Results tab


Transfer Data Tool

Use the Transfer Data tool to build and execute an SSIS package for each table you want to migrate from the DB2 database to the SQL Server database. Each transfer you define is one Transfer Data task. You can run the Transfer Data tool either from the HCOSS user interface, or from the command line using the MFDataTransferCtlr command.

As with the other HCOSS tools, you name your data transfer tasks and store them in a local or a shared location.

To run the Transfer Data tool, you must have:
  • A connection to your DB2 database
  • An associated DDL task
  • A connection to your SQL Server database
The Transfer Data tool includes the following functionality:
  • Reads the DDL task you created with the Generate DDL tool
  • Builds one SSIS package for each table specified in the associated DDL task
  • Executes SSIS packages to transfer data for all tables defined in the associated DDL task
  • Enables you to customize your Transfer Data tasks from the DB2 database to the SQL Server database by providing specifications for handling logs, errors, triggers, constraints, and source table row counts, and including WHERE and/or ORDER BY clauses in SELECT statements.
    Note: Ensure that the required schema objects are in place in the destination SQL Server database before executing a data transfer task.
  • Enables you to export SSIS packages
  • Reports results

The Transfer Data tool automatically names and saves each SSIS package it builds, and stores them in the same local or shared location as the transfer data tasks. SSIS package files use the following naming convention:

tableName_RunTimePackage.dtsx.

  • SSIS Packages
  • Data Type Support
  • Data Transform Types
Parent topic: Migrating Databases
Related concepts
DB2 Database Migration Process
Related tasks
To transfer data
To customize a transfer data task
Related reference
MFDataTransferCtlr command
Transfer Data Tool Log Files
Transfer Data Tool Error Messages
Transfer Data Tasks tab
Create New Transfer Data Task dialog box
Customize Transfer Data tab
Results tab


SSIS Packages

HCOSS transfers data from DB2 databases to SQL Server 2008 databases by building one SQL Server Integration Services (SSIS) package for each of the database tables selected for transfer, and then executing these packages.

An SSIS package is a collection of SQL script commands. When you execute an SSIS package, the SSIS engine runs each script in sequence. We chose SSIS packages as the mechanism to transfer data because they are a flexible and efficient deployment option. You can schedule, script, customize, extend, and integrate SSIS packages using SQL Server and Visual Studio tools. SSIS packages can also be reused by the Execute Package Utility of SQL Server Integration Services, and it can be loaded into the SQL Server Business Intelligence Development Studio for debugging purposes.

For more information about SSIS packages, see the documentation for the Microsoft SQL Server Development Center, available on the Microsoft Web site.

Parent topic: Transfer Data Tool


Data Type Support

While most of the data types in DB2 are supported by the tool, there are a few exceptions.

Lack of support may be due to a delay between a new type being added to DB2 and support for the new type being added to provider APIs, or because SQL Server does not have a suitable type to map the new DB2 type to. For instance, DECFLOAT (16 byte float) and XML are among the new data types added to DB2 for z/OS v9.1. Because there is no corresponding 16 byte float data type in SQL Server 2008, both the Microsoft and IBM OLE DB Providers output it as 8 byte float, suffering from potential loss of precision.

The BLOB data type is not supported by the current version (2.0) of Microsoft OLE DB Provider for DB2. Check with Microsoft to see when this data type will be supported. For the XML data type, neither Microsoft OLE DB Provider for DB2 supports it nor does IBM OLE DB Provider, in their current versions. The IBM DB2 .NET Data Provider is a promising alternative to the OLE DB Providers for DB2, as it supports the XML data type. It will be incorporated in the tool in the future. However, its current version (v9.5.3) wrongly outputs DECFLOAT(p) as Numeric(p,0) with 0 scale, where p stands for the precision.

For SQL Server 2008, the SQL Server OLE DB/Native Client supports all the incoming data types.

Parent topic: Transfer Data Tool


Data Transform Types

There are two types of data transforms that may occur in the data transfer process. The first type is explicit from the point view of an SSIS package, the conversion between Unicode characters and non-Unicode characters. This conversion is automatically handled by the tool, which adds an SSIS Data Transform component to the package.

The second type is implicit, the conversion between subtypes of the same data type, such as conversion between DataTime and DataTime2, conversion between REAL and FLOAT. This type of conversion is handled internally by the SQL Server Database engine and there is no need to add a Data Transform component to the package.

Parent topic: Transfer Data Tool


Compare Data Tool

Use the Compare Data tool after transferring data to verify and compare the newly imported data with the original data. As with the other HCOSS tools, you create and name compare data tasks and store them in a local or shared location. You can run the Compare Data tool either from the HCOSS user interface, or from the command line using the MFTestConversion command.

To run the Compare Data tool, you must have:
  • A connection to your DB2 database
  • An associated DDL task
  • A connection to your SQL Server database
The Compare Data tool includes the following functionality:
  • Reads the data from the DB2 database source connection and the SQL Server database destination connection
  • Compares the data found in each
  • Shows the results for each row of data that was transferred from the source connection to the destination connection
Parent topic: Migrating Databases
Related concepts
DB2 Database Migration Process
Related tasks
To compare transferred data
To run customized data comparisons
Related reference
MFTestConversion command
Compare Data Tool Log Files
Compare Data Tool Error Messages
Compare Data Tasks tab
Create New Compare Data Task dialog box
Customize Compare Data tab
Results tab


Migrating Applications

HCO for SQL Server (HCOSS) provides tools and methods for migrating mainframe-based DB2 applications to Windows-based SQL Server applications.

  • Assess Application Migration Tool
  • Application Migration Process
  • DB2 to SQL Server Conversion
  • Project Templates
  • Binding Applications
  • Manage Packages and Plans Tool
  • DSN Bind Utility
  • Managing DBRMs
  • Running Applications
Parent topic: HCO for SQL Server (HCOSS)
Related concepts
HCOSS Toolset
Why You Should Use the Assess Application Migration Tool


Assess Application Migration Tool

The Assess Application Migration tool provides you with a blueprint for how prepare your source code for successful migration to SQL Server by reporting the errors you might encounter when DB2 EXEC SQL statements are executed on SQL Server. This is done by providing detailed information for several conversion scenarios. Before migrating your applications to SQL Server, we strongly recommend that you analyze your application's migration potential using this tool.

  • Why You Should Use the Assess Application Migration Tool
  • Migration Scenarios
  • Supported Source Code
  • Processing Requirements
Parent topic: Migrating Applications
Related tasks
To assess application migration
To export assessment results
Related reference
Assessment Tasks tab
Create New Assessment Task dialog box
Results tab
Source Code tab


Why You Should Use the Assess Application Migration Tool

When considering application migration from mainframe DB2 to SQL Server, you need answers to these important questions:
  • How fast can I get my application migrated, up, and running on SQL Server?
  • How do I figure out how heavily my application relies on mainframe technology?
  • How can I eventually eliminate all reliance on mainframe technology such that my application uses SQL Server exclusively?
The Assess Application Migration tool helps you to analyze your COBOL and PL/I code with these questions in mind, and provides valuable information that guides you in determining the best migration option for your application. Using HCOSS, you have several options. You can:
Migrate your code as-is to SQL Server
Use this option if your goal is to get up and running as quickly as possible with SQL Server, without a dependency on mainframe compatibility or behavior. This is a great option if you have few statements to remediate, and you want to eliminate mainframe behavior dependency immediately.
Migrate converted DB2 statements to SQL Server statements
Use this option if you want to identify all SQL DB2 statements that require conversion to SQL Server statements to ensure 100% SQL Server compatibility after migration, and manually convert that code before migration. Contact Micro Focus SupportLine for more information on this approach.
Migrate your original code using HCOSS without the BIND option
Use this option if your goal is to get up and running as quickly as possible with SQL Server, but you do not want to BIND your application. This approach requires that you remediate SQL package and plan statements.
Migrate your original code using full HOCSS functionality
Use this option if your goal is to get up and running as quickly as possible with SQL Server. This option exploits all HCOSS functionality and ensures that your application runs with mainframe compatibility.
Parent topic: Assess Application Migration Tool
Related concepts
HCOSS Toolset
Migrating Applications
Application Migration Process
Migration Scenarios


Migration Scenarios

The Assess Application Migration tool runs a multi-phase process to determine the migration potential of each SQL statement contained in your original IBM z/OS mainframe DB2 SQL. The tool considers and reports on the following four scenarios for each source file containing DB2 EXEC SQL code:
  • As is - use existing DB2 SQL code as is.
  • Code convert - convert the DB2 SQL code to T-SQL code.
  • HCOSS no BIND - convert the DB2 SQL code using SQL(DIALECT) only.
  • HCOSS with BIND - convert the DB2 SQL code using both SQL(DIALECT) and SQL(DBRMLIB). For more information, see the Manage Packages and Plans Tool and DSN BIND utility topics.
For each scenario, the tool reports the total number of DB2 SQL statements that fall into these categories:
  • OK - statements that can be likely migrated to SQL Server without alteration
  • Must fix - statements that are not compatible with SQL Server and require a manual code change
  • In doubt - statements for which HCOSS cannot determine migration potential
Parent topic: Assess Application Migration Tool
Related concepts
Manage Packages and Plans Tool
DSN Bind Utility
Why You Should Use the Assess Application Migration Tool
Related tasks
To assess application migration
Related reference
DSN command


Supported Source Code

The Assess Application Migration tool supports COBOL and PL/I program and copybooks, and PL/I source code files to determine their migration potential. This includes files with the following file extensions:
  • .cob
  • .cbl
  • .cpy
  • .sqb
  • .pli
  • .pl1
  • .inc
  • .plinc
Parent topic: Assess Application Migration Tool


Processing Requirements

Before processing source files, the Assess Application Migration tool requires that you provide the following information:
  • A SQL Server connection name
  • A COBOL or PL/I source code and copybook root directory to examine
  • The COBOL or PL/I source code and copybook files to include
  • A default qualifier (optional)
  • The level of error reporting
Parent topic: Assess Application Migration Tool


Application Migration Process

Host Compatibility Option for SQL Server (HCOSS) and OpenESQL provides features and tools that assist in migration of mainframe applications that use DB2 to applications that run on Windows and use SQL Server. HCOSS also includes tools that enable you to migrate DB2 databases.

Note: All DB2 application components must reside either on your machine or on your local area network before beginning the migration to SQL Server.

You can use a combination of the following tools and features to achieve successful COBOL application migration, which includes building and binding an application:

  • HCOSS Assess Application Migration tool - used to determine the best method of migration you can use to automatically convert your DB2 SQL code to SQL Server.
  • HCOSS Manage Connections tool - used to create a connection to the SQL Server database.
  • Visual Studio HCOSS project templates - these templates automatically set up most of the Visual Studio and HCOSS environment that is required to migrate, build, and bind a mainframe COBOL application on Windows.
  • HCOSS Manage Packages and Plans tool - used to bind DBRM members into packages and plans, and to bind packages into plans. It also generates and saves BIND commands to bind script (.hcodsn) files you can execute using the DSN Bind utility.
  • DSN Bind utility - a free-standing Windows command-line utility used to achieve mainframe-like binding using a subset of the functionality of the mainframe DSN utility. This option is available if you do not create bind scripts that bind the application during the build process.
  • HCOSS-specific OpenESQL SQL compiler directive options - provide SQL syntax compatibility between DB2 and SQL and also provide binding functionality.

While you can choose from other methods of application migration using HCOSS, the basic and recommended process of COBOL and PL/I application migration includes:

  1. Using the HCOSS Manage Connections tool, connect to your SQL Server database.
  2. In Visual Studio, create a project based on one of the following COBOL Native templates:
    • HCOSS (CICS) Mainframe Subsystem Application template for JCL or CICS applications that run under Enterprise Server
    • HCOSS Application Managed template for applications that run directly on Windows
  3. Using the Assess Application Migration tool, determine the SQL conversion method that best fits your COBOL or PL/I source code.
  4. Take appropriate steps to convert your source code, based on your selected conversion method. This could include manually fixing your existing code based on the findings reported in the Assess Application Migration tool, or using HCOSS with our without the BIND option to convert the code based on the HCOSS DB2 to SQL Server Conversion mappings.
  5. Add mainframe or converted COBOL or PL/I source code to the project.
  6. Edit the preset SQL OpenESQL compiler directive options in the project properties.
  7. Also in the project properties, edit the post-build event to include the data source name of your SQL Server database.
  8. Build the application, automatically binding the application to the database.
  9. Run the application.
Parent topic: Migrating Applications
Related concepts
Building Applications
Running Applications
Binding Applications
Manage Connections Tool
Why You Should Use the Assess Application Migration Tool
Related tasks
To assess application migration
To bind as a post-build event


DB2 to SQL Server Conversion

You can set HCOSS to automatically convert DB2 statements to SQL Server statements. The conversion details are determined by a set of rules and defaults, some of which are customizable.

HCOSS DB2 to SQL Server conversion is triggered by setting the DIALECT compiler directive option to either MAINFRAME or MIXED. HCOSS converts all DB2 statements automatically, and converts DB2-compatible SQL Server statements as specified using statement prefixes.

The following topics provide important information on key features of HCOSS that enable you to optimize DB2 to SQL Server conversion:

  • HCOSS Conversion Rules
    Outlines the rules HCOSS uses to convert DB2 statements to SQL Server statements.
  • SQL Code Generation Options
    An overview of the SQL code generation options available with HCOSS.
  • DIALECT Statement Prefixes
    Explains the use of DIALECT statement prefixes to adjust DB2 to SQL Server conversion specifications on the statement level.
  • Application Progression from DB2 to SQL Server
    Provides a scenario for progressing an application from a DB2 mainframe application to a SQL Server application over time.
  • Building Applications
Parent topic: Migrating Applications
Related reference
Default Data Type Mappings
Default SQLCODE Mappings
Default SQL Name Mappings
DIALECT
Date and Time Data Types


HCOSS Conversion Rules

The HCOSS DB2 to SQL Server conversion process includes the following:
  • Converts DB2 functions and special registers to SQL Server functions and special registers according to a set of the defaults that best match one to the other. Customizable.
  • Converts DB2 data types to SQL Server data types according to a set of defaults that best match one to the other. Customizable.
  • Converts DB2 SQLCODE values to equivalent SQL Server SQLCODE values. Customizable.
  • Depending on the setting of the DETECTDATE directive, converts DB2-formatted date and time string values in character fields as follows:
    • DETECTDATE is turned on, HCOSS converts to ODBC format before sending the data to the server. ODBC format is:

      yyyy-mm-dd hh:mm:ss.n

    • DETECTDATE is turned off, HCOSS converts to a DB2-compatible format. The DB2-compatible format is:

      yyyy-mm-mm-hh.mm.ss.nnnnnn

  • Converts the following statements:
    SET host-variableAssignment
VALUES INTO host-variableAssignment
    Where the value of host-variableAssignment is not CURRENT PACKAGESET or CURRENT PACKAGE PATH, into equivalent SQL Server SELECT statements.
  • Converts LOCK TABLE statements to equivalent SQL Server select statements with appropriate TABLOCK or TABLOCKX and HOLDLOCK table hints.
  • Converts labeled durations to equivalent calls of the SQL Server DATEADD functions.
  • Converts isolation clauses in cursor selects to corresponding SQL Server table hints.
  • Converts SKIP LOCKED DATA clauses in cursor selects to corresponding READPAST table hints.
  • Converts the following following DB2 functions to corresponding SQL Server DATEPART functions:
    • DAY
    • DAYOFMONTH
    • DAYOFWEEK
    • DAYOFWEK ISO
    • DAYOFYEAR
    • HOUR
    • MICROSECOND
    • MINUTE
    • MONTH
    • SECOND
    • WEEK
    • WEEK ISO
    • YEAR
  • Converts the following DB2 type conversion functions to corresponding SQL Server CONVERT functions:
    • DATE
    • TIME
    • TIMESTAMP
    • TIMESTAMP ISO
  • Converts the DB2 DAYS function to the corresponding SQL Server DATEDIFF function.
Parent topic: DB2 to SQL Server Conversion
Related reference
Default Data Type Mappings
Default SQLCODE Mappings
Default SQL Name Mappings
DIALECT
Date and Time Data Types


SQL Code Generation Options

Before you begin compiling, testing, and executing your HCOSS code, consider what you want HCOSS to do for you.

To convert the mainframe SQL in my programs such that it works with SQL Server
Set the DIALECT SQL compiler directive option to MAINFRAME to convert all SQL, or MIXED to convert selected EXEC SQL statements in the code. To fully enable compile-time checking of converted SQL statements using SQL Server, set the DB, PASS and QUALIFIER directives along with DIALECT=MAINFRAME or DIALECT=MIXED. For additional information, see the DIALECT Statement Prefixes and the Application Progression from DB2 to SQL Server topics.
To mimic mainframe-style binding with my application
Specify the DBRMLIB SQL compiler directive option. If required to fully emulate your mainframe setup, you can also specify the MEMBER and VERSION directives. For additional information, see the Building Applications topic.
Note: Packages and plans are stored as SQL Server stored procedures.
To manage the application using SQL Server stored procedures
For HCOSS to manage your application using SQL Server stored procedures for your applicable SQL statements, but not manage them via packages or plans, specify either the ACCESS or BIND SQL compiler directive option.
Only to embed SQL into the generated code
To have HCOSS simply embed SQL into the generated code, no compiler directive options are required. This is the default behavior.

The following table provides a quick reference to the SQL compiler directive options that affect code generation. For complete information on each, see the appropriate Reference topic.

SQL Compiler Directive Option | Generation Specifics | Advantages
None (default) | SQL remains embedded in object code | Simplicity
ACCESS | Creates a stored procedure at compile time for most static SQL statements. | Convenient for testing when the BIND SQL compiler directive option is to be used for deployment.
BIND Enables deployment of application code by generating an SQL batch script that can be used with sqlcmd or SQL Server Management Studio to update the SQL Server database.
  • Security can be applied separately to procedures and data so that application users can only access and update data via the application.
  • DBAs can review SQL that is to be deployed without having to access source code.
DBRMLIB1 Enables generation of DBRMs containing the static SQL statements from COBOL programs, mimicking mainframe-style binding.
  • Mainframe deployment compatibility, meaning you can bind using existing JCL.
  • You can bind a DBRM multiple times using different parameters each time, such as different default qualifiers.
  • You can apply security separately to procedures and data so that application users can only access and update data via the application.
  • You can use the Manage Packages and Plans tool to manage DBRM binding and freeing.
  • Enables HCOSS to maintain mainframe-compatible metadata in the database for bound packages and plans.
  • DBAs can review SQL after binding by browsing stored procedures without having to access source code.
DIALECT2 Converts DB2 SQL statements that are not compatible with SQL Server into equivalent T-SQL statements in most cases.
  • You do not need to convert DB2 statements to T-SQL.
  • You can change the default schema when a program is bound, or in some cases, change the default schema at compile time using the QUALIFIER SQL compiler directive option.
1 For additional information, see also the Building Applications topic.

2 For additional information, see also the DIALECT Statement Prefixes and the Building Applications topics.

Parent topic: DB2 to SQL Server Conversion
Related concepts
DIALECT Statement Prefixes
Application Progression from DB2 to SQL Server
Building Applications
Related reference
ACCESS
BIND
DBRMLIB
DIALECT


DIALECT Statement Prefixes

DIALECT statement prefixes enable you to specify DB2 to SQL Server conversion details for individual EXEC SQL statements, including SQL Server statements that conform to DB2 syntax. In this way, you can apply certain overrides and conversion routines to DB2-compatible SQL Server statements, such as qualification of unqualified tables and views, on an as-needed basis.

Over time, your migrated applications can evolve to use syntax that is specific to SQL Server rather than DB2. When compiling an application using the DIALECT=MAINFRAME compiler directive option, by default HCOSS assumes all statements are DB2 statements and converts them to SQL Server statements using the specifications provided by defined HCOSS data type mappings, SQL name mappings, and SQLCODE mappings. HCOSS also applies qualifiers for unqualified tables and views based on the use of the SQL(QUALIFIER) compiler directive option or the QUALIFIER parameter on a BIND PACKAGE or BIND PLAN command. Also by default, HCOSS applies no conversions to existing SQL Server statements, submitting them directly to the SQL Server database.

When compiling with DIALECT=MIXED, the conversions described above are only performed for statements that have a prefix of [MAINFRAME], and HCOSS assumes that by default all statements are SQL Server statements.

The choice between DIALECT=MAINFRAME and DIALECT=MIXED depends on whether the majority of statements should be processed as DB2 or SQL Server statements.

Syntax:

A statement prefix is coded directly into an EXEC SQL statement as follows:
EXEC SQL [statementPrefix]... SQLStatement END-EXEC

Parameters:

statementPrefix
[NOPLAN]
The SQLStatement is not written to a DBRM even if SQL(DBRMLIB) is specified, but instead treats the statement as dynamic SQL at runtime. When used with other prefixes, [NOPLAN] must be specified first.
[MAINFRAME]
The SQLStatement is converted and qualified by HCOSS.
[NODIALECT]
The SQLStatement is neither converted nor qualified by HCOSS.
SQLStatement
Any DB2 statement, or DB2-compatible SQL Server statement.

Dependencies:

Statement prefixes must be used in conjunction with the DIALECT compiler directive option.

Examples:

All of the following examples assume that DIALECT is set to either MAINFRAME or MIXED, and all SQLStatements are DB2 compatible.

Example 1

The QUALIFIER compiler directive option is not set, and there is no specified QUALIFIER parameter.

EXEC SQL [NOPLAN] SQLStatement END-EXEC

The SQLStatement is converted but not qualified by HCOSS; it is not written to a DBRM, not written to a bind script file even when the BIND compiler directive option is set, and not used to create a stored procedure at compile time even when ACCESS compiler directive option is set.

Example 2

The QUALIFIER compiler directive option is set.

EXEC SQL [MAINFRAME] SQLStatement END-EXEC

The SQLStatement is converted and qualified by HCOSS.

Example 3

The QUALIFIER compiler directive option is set.

EXEC SQL [NOPLAN][MAINFRAME] SQLStatement END-EXEC

The SQLStatement is converted and qualified by HCOSS but is not written to a DBRM.

Example 4

The QUALIFIER compiler directive option is set.

EXEC SQL [NODIALECT] SQLStatement END-EXEC

The SQLStatement is neither converted nor qualified by HCOSS.

Example 5

The BIND or DBRMLIB compiler directive is set, along with the QUALIFIER compiler directive.

EXEC SQL [NOPLAN][NODIALECT] SQLStatement END-EXEC

The SQLStatement is neither converted nor qualified by HCOSS and is not written to a bind file or DBRM.

Parent topic: DB2 to SQL Server Conversion
Related concepts
Application Progression from DB2 to SQL Server
SQL Code Generation Options
Related reference
DIALECT
QUALIFIER
ACCESS
BIND


Application Progression from DB2 to SQL Server

As your application progresses from being a mainframe DB2 application to being a SQL Server application with no residual dependencies on mainframe characteristics, the combination of DIALECT settings and statement prefixes required when compiling and binding change, depending on the stage of the progression, to ensure optimal DB2 to SQL Server conversion results. The following scenario suggests each stage of application progression along with the combination of DIALECT and statement prefix settings recommended for each stage:
Stage 1 - All statements are DB2 compatible
Recommended settings:
DIALECT Setting | Statement Prefix
MAINFRAME | None
The preprocessor attempts to process all statements as DB2 statements and issues a DB2 compatibility warning on each statement that HCOSS does not recognize as a valid DB2 statement, but that is otherwise compatible with SQL Server. Only statements that compile without DB2 compatibility warnings are qualified by the QUALIFIER compiler directive or BIND parameter.
Stage 2 - Some statements are SQL Server specific; most are mainframe compatible
Recommended settings:
DIALECT Setting | Statement Prefix
MAINFRAME | [NODIALECT] on statements you want to flag as SQL Server compatible

The [NODIALECT] prefix suppresses the DB2 compatibility warning on statements that are only compatible with SQL Server. Since. due to the DIALECT=MAINFRAME setting, these statements are not qualified by the QUALIFIER compiler directive option or the BIND QUALIFIER parameter, ensure that the statements are either explicitly qualified in the source code or that the default schema for the connection points SQL Server to the correct schema.

Stage 3 - Most statements are SQL Server compatible
Recommended settings:
DIALECT Setting | Statement Prefix
MIXED | [MAINFRAME] on statements that fail with SQL(CHECK) and that are not ready for conversion to SQL Server

You may remove [NODIALECT] prefixes at this stage if you want, but it is not required.

Stage 4 - First class SQL Server Application
Recommended settings:
DIALECT Setting | Statement Prefix
NONE | None

Remove all [MAINFRAME] and [NODIALECT] statement prefixes specified for previous stages. These prefixes cause compilation errors when DIALECT is set to NONE. However, you can specify the [NOPLAN] prefix on statements of your choice.

Parent topic: DB2 to SQL Server Conversion
Related concepts
DIALECT Statement Prefixes
SQL Code Generation Options
Related reference
DIALECT
QUALIFIER


Building Applications

Because your migrated application originated in a mainframe environment, the run-time application expects to find all of the appropriate SQL statements in packages and/or plans that reference database request modules (DBRMs). DBRMs contain the SQL statements extracted from the application source code during compilation.

To mimic this mainframe behavior, HCOSS provides a set of SQL compiler directive options that enable you to extract the EXEC SQL statements in your application source code into DBRMs as you compile the application. In a post-compilation step, you then bind the DBRMs to the application so that they can be accessed at run time.

The following sample use case scenarios show typical SQL compiler directives you might set for HCOSS applications:

Type of Program | Scenario | SQL Compiler Directive Options
COBOL | Create DBRMs, and bind like the mainframe | SQL(DBMAN={ODBC | ADO}, TARGETDB=MSSQLSERVER, DB=databaseName, [PASS=userid.password, ]BEHAVIOR=MAINFRAME, DIALECT=MAINFRAME, DBRMLIB)1
COBOL | Create DBRMs, bind like the mainframe, but do not connect to the database during compilation | SQL(DBMAN={ODBC | ADO}, TARGETDB=MSSQLSERVER,BEHAVIOR=MAINFRAME, DIALECT=MAINFRAME, DBRMLIB, NOCHECK)1
COBOL | Do not create DBRMs, and do not create SQL Server stored procedures | SQL(DBMAN={ODBC | ADO}, TARGETDB=MSSQLSERVER, DB=databaseName, [PASS=userid.password, ] BEHAVIOR=MAINFRAME, DIALECT=MAINFRAME)1
COBOL | Do not create DBRMs, do not create SQL Server stored procedures, and do not connect to the database during compilation | SQL(DBMAN={ODBC | ADO}, TARGETDB=MSSQLSERVER, BEHAVIOR=MAINFRAME, DIALECT=MAINFRAME, NOCHECK)1
PL/I | Create DBRMs, and bind like the mainframe | SQL(DBMAN=ODBC, TARGETDB=MSSQLSERVER, DB=databaseName, [PASS=userid.password, ] BEHAVIOR=MAINFRAME, DIALECT=MAINFRAME, DBRMLIB)1
PL/I | Create DBRMs, bind like the mainframe, but do not connect to the database during compilation | SQL(DBMAN=ODBC, TARGETDB=MSSQLSERVER, DB=databaseName, [PASS=userid.password, ] BEHAVIOR=MAINFRAME, DIALECT=MAINFRAME, DBRMLIB, NOCHECK)1
1 DIALECT=MAINFRAME automatically sets CHECK, CHECKDUPCURSOR, CHECKSINGLETON, DETECTDATE, DATE=ISO, TIME=ISO

In Visual Studio, you compile applications by building the projects that contain them. When you build an HCOSS application, you must first set appropriate SQL compiler directive options, and in most cases, establish a connection to your SQL Server database.

In addition to the standard SQL compiler directive options, HCOSS includes these specific options to handle application binding and SQL compatibility between DB2 and SQL Server:
  • ACCESS
  • BIND
  • DATE
  • DBRMLIB (required)
  • DIALECT (required)
  • MEMBER
  • QUALIFIER
  • TIME
  • VERSION
At a minimum, edit your project's SQL properties to set the following compiler directive options for the OpenESQL ESQL preprocessor to ensure that the build process generates the appropriate DBRMs and converts DB2 SQL into SQL Server SQL where necessary.
  • DBMAN - set this to one of the following values:
    • ODBC - for native applications
    • ADO - for managed applications
  • TARGETDB - set this to a value of MSSQLSERVER.
  • DB - set this value to your SQL Server data source connection name
  • PASS - if your data source connection requires that you provide a user ID and password to connect, provide a user ID and password as follows:

    userID.password

  • DBRMLIB
  • DIALECT - set this to a value of MAINFRAME.
  • DETECTDATE
  • INIT
Note: The HCOSS template projects have several of the required directives preset.

Before compiling, unless you have specified the SQL(NOCHECK) directive, you must be connected to the database specified by the DB directive via an ODBC (native applications) or an ADO.NET (managed applications) connection.

Note: To set the SQL(NOCHECK) directive, you must add it such that it lists after the SQL(DBRMLIB) directive.
Parent topic: DB2 to SQL Server Conversion
Related concepts
Binding Applications
Application Migration Process
Project Templates
SQL Code Generation Options
Related reference
ACCESS
BIND
DATE
DBRMLIB
DIALECT
MEMBER
QUALIFIER
TIME
VERSION
Build Error Messages


Project Templates

We provide two Visual Studio project templates you can use when migrating a DB2 application to run on Windows and access a SQL Server Database. They are:

  • HCOSS (CICS) Mainframe Subsystem Application template - Use this template for migrating a CICS, JCL or IMS HCOSS application that runs under Micro Focus Enterprise Server.
  • HCOSS Application Managed template - Use this template for standalone applications that run directly on Windows.

Most properties in these templates are set for you to provide optimal performance. The templates also come with a pre-configured bind script file.

  • SQL Properties
  • COBOL Properties
Parent topic: Migrating Applications
Related concepts
Building Applications


SQL Properties

The HCOSS templates preset the following OpenESQL SQL compiler directive options:
  • SQL(DBMAN=ODBC)
  • SQL(TARGETDB=MSSQLSERVER)
  • SQL(BEHAVIOR=CICS) for CICS/MSS applications
  • SQL(BEHAVIOR=MAINFRAME) for migrated mainframe applications
  • SQL(DIALECT=MAINFRAME)
  • SQL(DBRMLIB)
  • SQL(DB=HCODB)
  • SQL(INIT) for CICS/MSS applications

Before building your application, you must change the value of the DB directive from the default value of HCODB to the name of your SQL Server data source name. Other changes are optional depending on the requirements of your application.

For complete information on HCOSS-specific OpenESQL SQL compiler directive options see the Compiler Directives reference.

Parent topic: Project Templates
Related reference
SQL Compiler Directive Options - HCOSS


COBOL Properties

The COBOL properties preset in the HCOSS templates include a post-build event to automatically bind your application immediately at the conclusion of the build process.

The HCOSS post-build event executes the DSN Bind utility, which binds the application and database. The default syntax of the DSN command executed is:

DSN SYSTEM(HCODB) @"$(ProjectDir)Application1.hcodsn"
Before building your application, you must make some changes to accommodate the specifics of your application.
  1. Replace HCODB with the data source name of your SQL Server database.
  2. Do one of the following:
    • Edit the Application1.hcodsn bind script file to include the BIND commands required to bind your application. By default, Application1.hcodsn contains the following BIND command:
      bind plan(PROGRAM1) action(REPLACE) MEMBER(PROGRAM1)
    • Specify an alternate bind script file:
      1. Create a new bind script file either using the Manage Packages and Plans tool, or by coding it manually.
        Note: For a listing of commands that are valid in HCOSS bind script files, see the topic Bind Script Commands.
      2. Add the bind script file to your Visual Studio project.
      3. Then edit the DSN command in your post-build event, replacing Application1.hcodsn with the name of your new bind script file.
Parent topic: Project Templates
Related concepts
Manage Packages and Plans Tool
Related tasks
To create a bind script file
To bind from the command line
To bind as a post-build event
To manually code a bind script file
Related reference
DSN command
Bind Script Commands


Binding Applications

Once you have built your application such that it generates the necessary DBRMs, you must bind the DBRMs to your application by directly binding the DBRMs, or by binding the DBRMs into packages and/or plans that can be accessed by your run-time application.

You have several options for binding applications:
  • Use the Manage Packages and Plans tool to generate bind script files (.hcodsn files) containing BIND script commands that you can execute immediately to achieve application binding, or that you can save for later execution.
  • Use the Manage Packages and Plans tool to create and save bind script files to execute using the DSN Bind utility at a command prompt or as a post-build event.
  • Manually code bind script files to execute using the DSN Bind utility at a command prompt or as a post-build event.
    Note: For a listing of commands that are valid in HCOSS bind script files, see the topic Bind Script Commands.
  • Bind from JCL by coding DSN commands directly into the JCL.

Whether you bind your applications via the Manage Packages and Plans tool or directly with the DSN Bind utility, the results are the same. This is because the Manage Packages and Plans tool actually runs the DSN Bind utility for you when you execute a script command.

We recommend that you bind your applications by creating collections and packages from DBRM members and then binding those packages to one or more plans. This method offers a significant advantage over binding DBRM members directly into a plan. For example, if you need to change the SQL in a single source member, and that source member is bound into a package that has been bound into a plan, you only need to rebind the changed member to its package. However, if the changed member is bound directly into a plan, you must rebind the entire plan to include the change.

Parent topic: Migrating Applications
Related concepts
DSN Bind Utility
Manage Packages and Plans Tool
Local DBRMs
Managing DBRMs
Shared DBRMs and Multi-User Environments
Building Applications
Running Applications
Application Migration Process
Related tasks
To create a bind script file
To open an existing bind script file
To create a new package
To create a new plan
To edit an existing BIND command
To execute one or all bind script lines
To bind from the command line
To bind as a post-build event
To manually code a bind script file
To bind from JCL
Related reference
BIND
DSN Bind Utility
Assessment Tasks tab
DSN command
Bind Script Commands
Bind Script Commands


Manage Packages and Plans Tool

Use the Manage Packages and Plans tool to create and edit bind script files that contain BIND commands. You can execute these scripts from the Manage Packages and Plans tool, or save them to execute later with the tool or using the DSN Bind utility. The tool also enables you to free (clean out) old or unused packages and plans from your SQL Server database.

With regard to binding applications, the Manage Packages and Plans tool provides the following functionality:
  • Generates BIND commands according to specifications you provide.
    Note: You can also bind applications on your deployment server as well as your development server; however, to do this you must have appropriate permissions on the deployment server machine.
  • Saves the commands in bind script files (.hcodsn files) to any location you specify so that you can open, edit, and execute the commands again at any time.
  • Reports BIND command errors.
  • Executes one, some, or all of the BIND commands in your script file to either generate stored procedures that populate the SYSIBM schema or remove stored procedures that already exist in your SQL Server database.
With regard to freeing packages and plans, the Manage Packages and Plans tool provides the following functionality:
  • Free packages, removing associated system table data and associated stored procedure(s) from your SQL Server database
  • Free plans, removing associated system table data and associated stored procedure(s) from your SQL Server database, and removing package associations to the plan
  • Package Specifications
  • Plan Specifications
  • Freeing Packages and Plans
Parent topic: Migrating Applications
Related concepts
Manage Packages and Plans Tool
Binding Applications
COBOL Properties
Deploying Native Applications
Migration Scenarios
Related tasks
To create a bind script file
To open an existing bind script file
To create a new package
To create a new plan
To edit an existing BIND command
To execute one or all bind script lines
Related reference
BIND
DSN Bind Utility
Assessment Tasks tab
Bind Scripts tab
Bind Packages tab
Bind Plans tab


Package Specifications

You must provide the following specifications to the Manage Packages and Plans tool to enable it to generate a valid BIND PACKAGE script command:
  • Collection name - You can specify any name you choose, and add one or more packages to that collection. HCOSS creates the collection the first time you execute a package that you specify to be stored in the collection.
  • Library name - the name of a library containing extracted DBRMs.
    • DBRM libraries are located under localHCOSSFiles\DBRMDataSets, where localHCOSSFiles represents the value of the Local HCOSS Directory HCOSS option.
    • When you compile your application using the SQL(DBRMLIB) directive without specifying a DBRM name, HCOSS puts all DBRMs into a default library directory named DBRMLIB.
    • If, when you compile, you specify a value for the DBRMLIB directive, the library directory name is the same as the value you specify.
    • The Manage Packages and Plans tool provides you with a list of the available libraries from which to select.
    • Each library contains one DBRM for each source code member.
    • Each DBRM contains the extracted EXEC SQL statements from a single source member.
  • Member name - the name of the DBRM from which you want to create the package. This is the program ID of the source code member from which the DBRM was extracted. If there is more than one DBRM in the specified library, you can select from a list of available members.
  • Default qualifier (optional) - the name of a schema to use as the default qualifier for this package.
  • Action - the action you want to take with regard to this package and the collection. If this package doesn't already exist in the collection, you can click Add to add it. If it does exist in the collection, you can click Replace to replace the current package version with an updated DBRM member, or you can replace a specific version by specifying the version identifier for the package that you want to replace and clicking Replace Version. HCOSS generates a new version for the package when you generate the DBRM.
Parent topic: Manage Packages and Plans Tool
Related tasks
To create a new package
To edit an existing BIND command
Related reference
Bind Packages tab


Plan Specifications

You must provide some or all of the following specifications to the Manage Packages and Plans tool to enable it to generate each BIND PLAN script command:
  • Plan name - You can specify any name you choose. HCOSS creates the plan the first time you bind it.
  • Default qualifier (optional) - the name of a schema to use as the default qualifier for this plan. HCOSS applies plan qualifiers to DBRM members specified in the plan; however, packages included in the plan use the qualifier specified for the package when it was executed, ignoring any specified plan qualifier.
  • Action - the action you want to take with regard to this plan. If the plan doesn't already exist, you can add it. If it does exist, you can replace it with modified specifications you provide.
  • Collections that contain packages you want to include in the plan.
  • Packages you want to include.
  • DBRM members you want to include in the plan.
  • DBRM libraries in which you want to search for specified DBRM members.
Parent topic: Manage Packages and Plans Tool
Related tasks
To create a new plan
To edit an existing BIND command
Related reference
Bind Plans tab


Freeing Packages and Plans

Over time, as a result of binding multiple DBRMs into multiple packages and plans, you might accumulate more data records and stored procedures in your SQL Server database than you need to run your application. In this case, you can use the Manage Packages and Plans tool to free (clean out) the packages and plans that you no longer need.

When you free a package, the Manage Packages and Plans tool removes associated system table data about the package and the stored procedure(s) associated with the package. You can remove all versions or a specific version of each package. You cannot restore a package that you have freed. Instead, you must bind the package again.

When you free a plan, the Manage Packages and Plans tool removes associated system table data about the plan and the stored procedure(s) associated with the plan. This includes removing all associations with packages bound into the plan. However, the packages themselves remain intact. Remember that a single package can be accessed individually and/or from any plan into which is has been bound. Therefore, even when you free a plan, its packages remain usable in those other contexts. If you want to also free the packages associated with a plan, you must free them separately.

You cannot restore a plan that you have freed. Instead, you must bind the plan again.

Parent topic: Manage Packages and Plans Tool


DSN Bind Utility

Using the DSN Bind utility, you can bind your database to your SQL Server application from the command line or as a post-build event.

The DSN Bind utility requires that you have an active connection to your SQL Server database, and that you provide a bind script file (.hcodsn file) containing the DSN commands you want to execute. You can create the bind script file using the Manage Packages and Plans tool, or create it manually in a text editor.
Note: For a listing of commands that are valid in HCOSS bind script files, see the topic Bind Script Commands.

A post-build event is a process executed automatically, immediately following the building of an application in Visual Studio.

The DSN Bind utility executes in two sequential phases each time you run it - the Schema Update execution phase followed by the Bind Script execution phase.

Schema Update Execution

In this phase of execution, DSN checks the SQL Server database to which you are connected to ensure that the tables and stored procedures it requires are present in the database, and that the table and function definitions are consistent with the version of HCOSS in use. If the checks return successfully, DSN moves on to the Bind Script Execution phase. However, if the checks fail, DSN performs a schema update before moving on.

DSN database checks fail, triggering a schema update, only when either of the following is true:
  • You run DSN against a new SQL Server database
  • You run DSN for the first time after installing an HCOSS upgrade
  • DSN determines that necessary tables and/or stored procedures are missing from the database
To perform a schema update, DSN executes the following SQL scripts against your SQL Server database:
  • InstallSYSIBM.sql - creates metadata tables that DSN uses to manage bound DBRMs.
  • InstallBindProcs.sql - creates stored procedures that DSN uses to manage these tables.
  • InstallDigitsFunction.sql - creates the following functions to emulate DB2 functions not provided by SQL Server:
    • DATEINTERVAL
    • DIGITS
    • JULIANDAY
    • LASTDAY
    • LPAD
    • MIDNIGHT_SECONDS
    • NEXTDAY
    • RPAD
    • STRIP
    • TIMEINTERVAL
    • TRANSLATE
    • TRUNCATE

These SQL scripts reside in your %ALLUSERSPROFILE%\Micro Focus\NetExpress\6.0 directory.

To ensure successful completion of the schema update process, connect to your SQL Server database using login credentials that include the following permissions:
  • CREATE SCHEMA
  • CREATE TABLE
  • DROP TABLE
  • CREATE INDEX
  • DROP INDEX
  • CREATE PROCEDURE in the SYSIBM schema
  • DROP and CREATE FUNCTION in the dbo schema
Important: This set of required permissions provides broader access to the SQL Server database than is necessary for the checking and binding done by DSN on a regular basis, that is, when database checks do not trigger the schema update process. If you routinely bind your applications by executing DSN from the command line or as a post-build event, and you prefer to restrict permissions for day-to-day use, you can avoid possible errors and prevent DSN from triggering an automatic schema update by completing the process manually immediately after creating a new SQL Server database and after each HCOSS upgrade. To perform a manual schema update, connect to your SQL Server database using login credentials that grant the required permissions, and then run the SQL scripts manually.

Permissions required to run database checking are the same as those required for bind script execution.

Bind Script Execution

In the Bind Script Execution phase, DSN:
  • Generates stored procedures that bind packages and plans, maintaining them as metadata in the following SQL Server database tables:
    SYSIBM.SYSDBRM
SYSIBM.SYSPACKAGE
SYSIBM.SYSPACKLIST
SYSIBM.SYSPLAN
  • For each DBRM package specified in a BIND PACKAGE command, generates a separate stored procedure for each static SQL statement, saving them to your SQL Server database using the following naming convention:

    PKG:collectionName.memberName consistencyToken$statementNumber

    Where consistencyToken is a DSN-generated string that provides a unique name for the stored procedure, and statementNumber is a DSN-generated number starting at 0. For example:

    PKG:COLLECTION1.MEMBERAEEEcKIKy$0

  • For each plan specified in a BIND PLAN command, generates stored procedures for specified packages/members, saving them to your SQL Server database using a similar naming convention:

    PLN:planNameconsistencyToken$statementNumber

    For example:

    PLN:MYPLAN1.MEMBERAFFFdLJLz$0

To ensure successful completion of the Bind Script Execution phase, connect to your SQL Server database using login credentials that include the following permissions:
  • CREATE SCHEMA
  • CREATE PROCEDURE
  • EXECUTE PROCEDURE in the SYSIBM schema
Parent topic: Migrating Applications
Related concepts
Manage Packages and Plans Tool
Binding Applications
Local DBRMs
Managing DBRMs
Shared DBRMs and Multi-User Environments
Deploying Native Applications
Migration Scenarios
Related tasks
To bind from the command line
To bind as a post-build event
To manually code a bind script file
Related reference
Assessment Tasks tab
ACCESS
BIND
DSN command
Bind Script Commands


Managing DBRMs

HCOSS manages DBRMs in DBRM libraries local to each user, and also in a shared DBRM library available to all HCOSS users. HCOSS ensures that each program and application is bound using DBRMs from the appropriate library.

  • Local DBRMs
    Explains how HCOSS manages local DBRMs.
  • Shared DBRMs and Multi-User Environments
    Explains how HCOSS ensures that the appropriate version of each DBRM is found and used when binding an application that is routinely accessed and maintained by more than one HCOSS user.
Parent topic: Migrating Applications
Related concepts
Shared DBRMs and Multi-User Environments
Binding Applications
DSN Bind Utility
Related reference
Options
PROMOTE
DBRMLIB


Local DBRMs

When compiling an HCOSS program or application with the DBRMLIB compiler directive option, DBRMs are generated and stored in one of two places:
  • The DBRMDataSets\DBRMLIB subdirectory of the directory specified in your Local HCOSS Directory HCOSS option (default).
  • A subdirectory of the DBRMDataSets directory, specified as argument to the DBRMLIB compiler directive option. When specified, this value overrides the default directory.

For users who are working on a single program or application, compiling and binding is done on the local level using DBRMs available in the local DBRM libraries.

Note: When binding a program or application for which there are no local DBRMs, HCOSS uses DBRMs found in the shared DBRM library. See Shared DBRMs and Multi-User Environments for more information.
Parent topic: Managing DBRMs
Related concepts
Shared DBRMs and Multi-User Environments
Binding Applications
DSN Bind Utility
Related reference
PROMOTE
DBRMLIB


Shared DBRMs and Multi-User Environments

HCOSS maintains a DBRM library that is located in the DBRMDataSets subdirectory of the directory specified in your Shared HCOSS Directory HCOSS option. This shared DBRM library provides a single location for all production DBRMs, regardless of which user generated them. This shared DBRM library is essential for binding large applications maintained in a Visual Studio project and accessed by multiple users.

Individual HCOSS users populate the shared DBRM library when compiling HCOSS programs and applications using both the DBRMLIB and the PROMOTE compiler directive options. DBRMLIB specifies the generation of DBRMs, and PROMOTE specifies that the generated DBRMS are stored in the shared HCOSS DBRM library, and that older versions of the same DBRMS in the user's local DBRM library are deleted. In this way, HCOSS retains only the promoted copy of each DBRM.

Important: In a multi-user environment, it is vital that each HCOSS user has the same physical location specified in his or her Shared HCOSS Directory HCOSS option.

Use Case Scenario

The following scenario illustrates how the shared DBRM library is maintained and accessed for a Visual Studio project containing a single HCOSS application comprised of multiple programs maintained by several different HCOSS developers.

Developer A
  1. Opens the Visual Studio project and edits one program within the project, Program A.
  2. Compiles Program A using the DBRMLIB option.

    This generates DBRMs in Developer A's local HCOSS DBRM library.

  3. Binds the DBRMs to Program A for testing.

    HCOSS looks for each DBRM in Developer A's local HCOSS library first, and if not found, then looks in the shared HCOSS library.

  4. Tests Program A.
  5. Recompiles Program A using both the DBRMLIB and the PROMOTE options.

    HCOSS generates DBRMs in the shared HCOSS library and deletes the older versions of the same DBRMs from Developer A's local HCOSS library.

Developer B
  1. Compiles the application that contains Program A, but without specifying DBRMLIB.

    All programs are compiled, but no DBRMs are generated.

  2. Binds the application.

    HCOSS binds using the DBRMs found in the shared DBRM library, including those for Program A, previously promoted by Developer A using the PROMOTE compiler directive.

Parent topic: Managing DBRMs
Related concepts
Shared DBRMs and Multi-User Environments
Binding Applications
DSN Bind Utility
Local DBRMs
Managing DBRMs
Related reference
Options
PROMOTE
DBRMLIB


Running Applications

Your run-time applications require access to the DBRMs containing your SQL Server information. Therefore, you must specify the package collection or plan to which you have bound the DBRMs needed for a particular application. The methods for specifying package collections and plans differ between JCL and CICS applications.

Note: Because plan selection is specific to a connection, HCOSS maintains separate settings of CURRENT PACKAGE PATH, CURRENT PACKAGESET and APPLICATION PLAN for each connection used by an application.
  • CICS Applications - DBRM Specification
  • JCL Applications - DBRM Specification
Parent topic: Migrating Applications
Related concepts
Binding Applications
Application Migration Process


CICS Applications - DBRM Specification

CICS applications migrated using HCOSS and running under Enterprise Server require that you specify a package collection, list of package collections, or a plan in which your application's DBRMs are bound. You can do this one of two ways:

  • Enterprise Server environment variables

    Depending on how you have bound your DBRMs, set one the following environment variables in the Configuration Information field on the Enterprise Server Administration Server > Properties > General tab for the enterprise server running the application:

    • ES_DB_APPLICATION_PLAN
    • ES_DB_PACKAGESET
    • ES_DB_PACKAGE_PATH

    These variables set the APPLICATION PLAN, CURRENT PACKAGESET or CURRENT PACKAGE PATH special registers. By setting one of these variables, you create a global setting for a CICS region.

  • In application source code

    Add one of the following statements to your source code:

    • SET APPLICATION PLAN
    • SET CURRENT PACKAGESET
    • SET CURRENT PACKAGE PATH

    Use SET APPLICATION PLAN or SET CURRENT PACKAGESET to explicitly set the plan name or collection name containing your DBRMs. Use SET CURRENT PACKAGE PATH to specify a list of collections from which to select.

    Note: This method is less desirable because it requires changes to application code.
Parent topic: Running Applications


JCL Applications - DBRM Specification

JCL run-time applications migrated with HCOSS require that you specify the plan or package collection(s) to which its DBRMs are bound. This is accomplished using one of three methods:
  • Explicitly on the JCL RUN command
    JCL passes the PLAN parameter value from the JCL RUN command to OpenESQL, which then uses this value to set the plan used by the application. For example:
    RUN PROG(progName) PLAN(planName)
  • Automatically by default
    If you do not specify a PLAN parameter in the JCL RUN command, JCL defaults to using the program name as the plan name. For example:
    RUN PROG(progName)
  • In application source code

    This method overrides the automatic default method. It also enables you to specify package collection(s) instead of a plan. Add one of the following statements to your source code:

    • SET APPLICATION PLAN - Explicitly set the plan name
    • SET CURRENT PACKAGESET - Explicitly set the collection name
    • SET CURRENT PACKAGE PATH - Specify a path containing collections from which to select
Parent topic: Running Applications
Related tasks
To bind from JCL
Related reference
Bind Script Commands


Deploying Native Applications

The software components required for successful HCOSS application deployment are:

Development Machine
  • Has Studio Enterprise Edition for Windows installed
  • If SQL Server 2008 or 2012 is not installed, you must have Microsoft SQL Server 2008 or 2012 Native Client installed
Development SQL Server Machine
  • Has SQL Server 2008 or 2012 installed
  • Can be the same machine as the development machine, but not required to be
Deployment Machine
  • Has Server Enterprise Edition for Windows installed
  • If SQL Server 2008 or 2012 is not installed, you must have Microsoft SQL Server 2008 or 2012 Native Client installed
Deployment SQL Server Machine
  • Has SQL Server 2008 or 2012 installed
  • Can be the same machine as the deployment machine, but not required to be

Deploy an Application Compiled Without DBRMLIB

To deploy a Studio Enterprise Edition HCOSS application that was not compiled using the DBRMLIB directive, meaning that you did not bind the DBRM files for your application, complete the steps presented in the topic Deploying COBOL Applications. The steps presented there are necessary to successfully deploy your application to the deployment machine.

In addition, you must also install Microsoft SQL Server 2008 or 2012 Native client on your deployment machine so your SQL Server application can communicate with a SQL Server instance.

Development Machine
  • Build and test the HCOSS application with a development SQL Server machine.
Deployment Machine
  • Follow the steps defined in Deploying COBOL Applications, moving your HCOSS application as specified
  • Create a connection to the deployment SQL Server machine
  • Test the HCOSS application with the deployment SQL Server machine

Deploy an Application Compiled With DBRMLIB

To bind a Studio Enterprise Edition HCOSS application using the DBRMLIB directive and deploy it to a deployment machine, you have two choices. For both, you must also install Microsoft SQL Server 2008 or 2012 Native client on your deployment machine so your SQL Server application can communicate with a SQL Server instance:

Bind the application from your development machine
Development Machine
  • Build and test the HCOSS application with a development SQL Server machine
  • Create a connection to the deployment SQL Server machine
  • Bind the HCOSS application to the deployment SQL Server machine using the connection you created
Deployment Machine

  • Follow the steps defined in Deploying COBOL Applications, moving your HCOSS application as specified

  • Create a connection to the deployment SQL Server machine
  • Test the HCOSS application with the deployment SQL Server machine
Bind the application from your deployment machine
Development Machine
  • Build and test the HCOSS application with a development SQL Server machine.
Deployment Machine
  1. Follow the steps defined in Deploying COBOL Applications.
  2. To ensure that your HCOSS application is properly migrated, install the following software:
    • Microsoft SQL Server 2008 or 2012 Native Client
    • Microsoft .NET 3.5 framework
  3. Copy your HCOSS application from the development machine to the appropriate directory structure on the deployment machine.
    Important: You must create some or all of the required directory structure manually.

    Specifically, copy database request modules (DBRMs), that is, the DBRMName.hcodbrm files, from the development machine to the equivalent directory on the deployment machine. The location of your DBRM files varies on your development machine depending on your HCOSS options, and the specified DBRMLIB directive. The location on your development machine is:

    localHCOSSFiles\DBRMDataSets\DBRMLIBName

    Where localHCOSSFiles represents the value of the Local HCOSS Directory HCOSS option, and DBRMLIBName represents the value of the DBRMLIB directive.

    Note: If no value is provided for the DBRMLIB directive, the default value is DBRMLIB. SQL(DBRMLIB) is the equivalent of SQL(DBRMLIB=DBRMLIB).

    On the deployment machine, you must put the DBRM files into a subdirectory of the default directory: %APPDATA%\Micro Focus\NetExpress\6.0\HCOSS\DBRMDataSets. The subdirectory name must match the DBRMLIB name.

    For example, assuming the following:

    Studio Enterprise Edition version | 6.0
    Development machine Windows user ID | devuser
    Deployment machine Windows user ID | exeuser
    DBRMLIB directive | SQL(DBRMLIB=REX.PROJECT.DEMO)
    Value of Local HCOSS Directory HCOSS option on both machines | Default setting, %APPDATA%\Micro Focus\NetExpress\6.0\HCOSS\DBRMDataSets

    You then copy the generated DBRM files using the following directory specifications:

    Development Machine | Deployment Machine
    c:\Users\devuser\AppData\Roaming\Micro Focus\NetExpress\6.0\HCOSS\DBRMDataSets\REX.PROJECT.DEMO | c:\Users\exeuser\AppData\Roaming\Micro Focus\NetExpress\6.0\HCOSS\DBRMDataSets\REX.PROJECT.DEMO
  4. Start HCO for SQL Server from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > HCO for SQL Server Tools > HCO for SQL Server.
  5. Using the Manage Connections tool, create a connection to the deployment SQL Server machine. For more information, see the Manage Connections Tool topic.
    Important: Be sure that the login credentials you use grant you the permissions necessary to successfully perform the tasks outlined in both the Schema Update Execution and Bind Script Execution sections of the DSN Bind Utility topic.
  6. Using the Manage Packages and Plans tool, bind the DBRM to your deployment SQL Server machine by creating and executing a BIND PACKAGE script command. For complete details, see the Manage Packages and Plans topic.
  7. Test your HCOSS application on the deployment SQL Server machine.
    Note: When running from the command line, if your Studio Enterprise Edition installation directory contains spaces, do not enclose the directory specification in quotes when you add it to the PATH environment variable.
Parent topic: HCO for SQL Server (HCOSS)
Related concepts
DB2 Database Migration Process
Manage Connections Tool
DSN Bind Utility
Manage Packages and Plans Tool
Deploying Native COBOL Applications
Deployment Licensing
Related reference
DSN command


Managing Log Files

Each of the following HCOSS tools generate one or more log files as you use the tool, storing them in folders as specified in your HCOSS options:
  • Manage Connections
  • Extract Schema
  • Define Lists
  • Generate DDL
  • Transfer Data
  • Compare Data
  • Manage Packages and Plans

Within the IDE, we provide a Log File tab for each of these tools where you can view the contents of the log files generated, and delete the log files of your choice. You can also configure your HCOSS options to automatically delete log files older than a given number of days.

Parent topic: HCO for SQL Server (HCOSS)
Related reference
Log Files tab


Customizing HCOSS

You can customize HCOSS by setting options, changing default conversion specifications, setting certain SQL compiler directive options, and calling the DSNTIAR or DSNTIAC facility from your programs.

  • Customizing Data Type Mappings
  • Customizing Functions and Special Registers
  • Customizing SQLCode Mappings
  • Customizing Return Codes
Parent topic: HCO for SQL Server (HCOSS)


Customizing Data Type Mappings

HCOSS converts DB2 data types to SQL Server data types automatically, using a set of defaults to map each DB2 data type to a corresponding SQL Server data type.

If you want to convert any of your DB2 database data types to SQL Server database data types using settings other than the defaults mapped by HCOSS, you can customize them.

From the HCOSS Customize Type Mappings tool, you can customize the following for each DB2 data type mapping:
  • Encoding
    • ASCII
    • EBCDIC
    • UNICODE
  • Data Storage Option
    • For bit data
    • Mixed data
    • None
    • SBCS data
  • SQL Server Data Type - any available

You can also add data type mappings using the Customize Type Mappings tool.

Parent topic: Customizing HCOSS
Related tasks
To customize data type mappings
Related reference
Default Data Type Mappings
Customize Type Mappings - Data Mappings tab


Customizing Functions and Special Registers

HCOSS converts DB2 functions and special registers to SQL Server functions or special registers automatically, using a set of defaults to map each DB2 function or special register to a corresponding SQL Server function or special register.

If you want to convert any of your DB2 database functions or special registers to SQL Server database functions or special registers using settings other than the defaults mapped by HCOSS, you can customize them.

From the HCOSS Customize SQL Name Mappings tool, you can customize the following for each DB2 function or special register:
  • The SQL Server equivalent
  • Whether SQL Server handles it as a function or a special register

Also from the Custom SQL Name Mappings tool, you can add DB2 functions and special registers defined in your DB2 database that are not represented in your SQL Server database.

Important: If you want to add a mapping for a DB2 function or special register that exists in your DB2 database but that is not represented in your SQL Server database, you must first create the SQL Server object in your SQL Server database. All objects must be present in the SQL Server database before you can create the mapping, and before you bind your application.
  • Function Customization Process
  • Function Customization Example
Parent topic: Customizing HCOSS
Related tasks
To customize SQL name mappings
Related reference
Default SQL Name Mappings
Customize SQL Name Mappings - SQL Name tab


Function Customization Process

DB2 comes with some built-in functions that are not represented in SQL Server. If your application uses any of these built-in functions, you must define an equivalent SQL Server function for each in your SQL Server database, and map each DB2 function to its corresponding user-defined SQL Server function using HCOSS. Do these things before binding the application.

SQL Server requires that all calls to user-defined functions are qualified with the schema name of the function. You can use HCOSS to map unqualified function names to qualified function names.

The process for customizing SQL Server to emulate a non-represented DB2 function is as follows:

  1. In your SQL Server database, define a function to serve as an equivalent of the DB2 built-in function.
  2. Qualify the new function, specifying its SQL Server schema. This is necessary because SQL Server requires that all calls to user-defined functions be qualified with the schema name.
  3. In HCOSS, map the DB2 built-in function to the newly created SQL Server function.
  4. When you build the application, set the HCOSS DIALECT directive to MAINFRAME. This tells HCOSS to consult the mapping entries to find qualified SQL Server functions based on the equivalent, original DB2 function definition.
Parent topic: Customizing Functions and Special Registers


Function Customization Example

In this example, we use the scenario that our migrated DB2 database uses a built-in function for math, atanh, that our SQL Server database does not support. We use Microsoft SQL Server Management Studio to create the function in the default dbo schema of our SQL Server database, and we use HCOSS to map the DB2 function to the newly created SQL Server user-defined function.

  1. In SQL Server Management Studio, create a user-defined function in your SQL Server database to serve as an equivalent for the DB2 atanh function by executing the following Transact-SQL.
    create function atanh (@in float) returns float
begin
    return log((1 + @in) / (1 - @in)) / 2
end
go
  2. Qualify the function in SQL Server Management Studio using the dbo schema by executing the following:
    declare @x float = 0.75
select dbo.atanh(@x)
  3. Map the newly defined dbo.atanh SQL Server function to the DB2 atanh.
    1. From the HCOSS interface, click Customize SQL Name Mappings and add the following to the blank row at the bottom of the page:
      • In DB2 Function/Special Register column type atanh.
      • In SQL Server Equivalent column type dbo.atanh.
      • Check the Is Function checkbox.
    2. Click Save.
  4. Set the DIALECT directive to MAINFRAME and build the application.
       $set sql(targetdb=mssqlserver db=HCODemo dialect=mainframe, init)
       identification division.
       program-id. Program1.

       environment division.
       configuration section.

       data division.
       working-storage section.

       exec sql include sqlca end-exec.

       01  mfsqlmessagetext    pic x(200).

       01  x           comp-2.

       01  atanh       comp-2.
       01  digits      comp-2

       procedure division.

           move 0.25 to x
           exec sql
               select atanh(:x)
                into :atanh
           end-exec

           display atanh

           goback.
Parent topic: Customizing Functions and Special Registers


Customizing SQLCode Mappings

HCOSS automatically maps OpenESQL SQLCode values to their equivalent DB2 SQLCode and SQLState values using the information defined in the mfhcocds.txt file. HCOSS comes with standard default SQLCode mappings. You can customize these mappings by directly editing the mfhcocds.txt file.

HCOSS stores the mfhcocds.txt file in one of the following folders:
Windows XP | %ALLUSERSPROFILE%\NetExpress\6.0
Windows Vista and Windows 7 | %ALLUSERSPROFILE%\Micro Focus\NetExpress\6.0

You can use any text editor to make changes to default settings or to add SQLCode mappings stored in the mfhcocds.txt file. The mappings are stored in a comma-delimited format with each line listing an OpenESQL SQLCode value followed by its DB2 SQLCode value equivalent followed by the SQLState value returned for the OpenESQL SQLCode value. For example, here is a listing of the default mfhcocds.txt contents:

* OESQL SQLCODE, DB2 SQLCODE, DB2 SQLSTATE DELIMITED BY COMMAS
-2601,-803,23505
-19519,-501,24501
-19516,-502,24502
-2714,-601,42710
-207,-204,42704
-208,-204,42704
Parent topic: Customizing HCOSS
Related reference
Default SQLCODE Mappings


Customizing Return Codes

HCOSS provides DSNTIAR and DSNTIAC facilities you can call from your program that emulate those available on the mainframe. These HCOSS facilities enable you convert your SQL run-time return codes into character string messages.

Parent topic: Customizing HCOSS
Related reference
DSNTIAR and DSNTIAC


How to...

  • To start HCO for SQL Server
  • Manage Connections Tasks
  • Migrate Databases Tasks
  • Assess Application Migration
  • Manage Packages and Plans Tasks
  • Bind Applications
  • Customize HCOSS
  • To start the Stored Procedure Test tool
  • To set Stored Procedure Test tool options
  • To edit the list of stored procedures displayed
  • To specify an input parameter value for a stored procedure
  • To edit an input parameter value for a stored procedure
  • To specify a side file for a parameter value
  • To specify a special register for a parameter value
  • To specify input, output, and generated COBOL filenames
  • To execute a stored procedure
  • To generate a stored procedure
  • To display saved results from output XML
  • To generate a test command
  • To generate an external table function
  • To generate an external scalar function
Parent topic: HCO for SQL Server (HCOSS)
Parent topic: Stored Procedures Test Tool


To start HCO for SQL Server

To start HCOSS in standalone mode:
  • Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > HCO for SQL Server Tools.
To start HCOSS from the Visual Studio IDE:
  • Click Tools > Micro Focus COBOL Tools > HCO for SQL Server Tools.
Note:
  • If HCOSS finds a more recent version of SQL Native Client available on your machine, it prompts you with the option to upgrade your existing system and user connections to use the updated driver. You can turn this functionality off by unchecking Enable Checking for New ODBC Drivers on the Connection List tab or by checking Stop asking me on the prompt dialog box.
  • If you are using Windows UAC, you might be prompted to run HCOSS as an administrator when you start HCOSS from the Start menu. See Using HCOSS with Windows User Account Control (UAC) for more information.
Parent topic: How to...
Related concepts
HCOSS Toolset
Using HCOSS with Windows User Account Control (UAC)
Related reference
Options


Manage Connections Tasks

  • To create a DB2 connection
  • To create a system or user SQL Server connection
  • To edit an existing connection
  • To import a connection
  • To export a connection
  • To repair a connection
Parent topic: How to...


To create a DB2 connection

  1. From the HCO for SQL Server interface, click Manage Connections.
  2. On the Connections List tab, select a Connection Type (System or User) for this DB2 connection.
  3. Click New DB2 Connection.
  4. Complete all fields on the form.
  5. If you want HCOSS to remember your ADO.NET password, check Allow Saving ADO.NET Connection Password. Otherwise, the system prompts you for a password each time you connect from other HCOSS tools.
  6. Click Test.
  7. When the connection tests successfully, click OK to clear the message; then click Save.

    The new connection appears on the Connections List located on the Connections List tab.

Parent topic: Manage Connections Tasks
Related concepts
Manage Connections Tool
Connection Types
Related reference
Manage Connections Tool Log Files
Manage Connections Tool Error Messages
DB2 Connection tab
Connection List tab
Required DB2 Catalog Tables


To create a system or user SQL Server connection

  1. Be sure you have added your SQL Server database to Microsoft SQL Server Management Studio.
  2. From the HCO for SQL Server interface, click Manage Connections.
  3. On the Connection List tab, select a Connection Type - System or User - for this SQL Server connection.
  4. From the Connection List tab, click New SQL Server Connection.
  5. Specify appropriate Connection Properties.
    Note: If you have selected Use SQL Server Login and want HCOSS to remember your ADO.NET password, check Allow Saving ADO.NET Connection Password. Otherwise, the system prompts you for a password each time you connect from other HCOSS tools.
  6. Specify appropriate Data Link Properties as follows:
    1. Specify a SQL Server Instance by selecting from the drop-down list, or by typing the name of your SQL Server instance into the field. If you type in the name of your SQL Server instance rather than selecting it from the drop-down list, you must also click Confirm Server.
    2. If you want to use a database other than the default database, check Use a database other than the default database: dbname, and then select an alternative database from the Database drop-down list.
  7. Click Test.
  8. When the connection tests successfully, click OK to clear the message.
  9. Click Save.

    The new connection appears on the Connections List located on the Connections List tab.

Parent topic: Manage Connections Tasks
Related concepts
Manage Connections Tool
Connection Types
Related reference
Manage Connections Tool Log Files
Manage Connections Tool Error Messages
SQL Server Connection tab
Connection List tab


To edit an existing connection

  1. From the HCO for SQL Server interface, click Manage Connections.
  2. On the Connection List tab, select a connection from the connection list; then click Edit.
  3. Modify the Connection Properties and Data Link Properties as appropriate.
  4. Click Test.
  5. When the connection tests successfully, click OK to clear the message.
  6. Click Save.
Note: When editing a SQL Server connection of the System or User connection type, if HCOSS finds a more recent version of SQL Native Client available on your machine, it prompts you with the option to upgrade the connection to use the updated driver. You can turn this functionality off by unchecking Enable Checking for New ODBC Drivers on the Connection List tab or by checking Stop asking me on the prompt dialog box.
Parent topic: Manage Connections Tasks


To import a connection

  1. From the HCO for SQL Server interface, click Manage Connections.
  2. On the Import tab, type the full path to and filename of an XML (.xml) file containing the exported connection(s) that you want to import, or click the browse button to select a file.
  3. Click Read Available Connections to populate the list.
  4. Select one or more connections to import.
  5. Click Import.
    Note:
    • If one or more of the selected connections uses a provider other than the Microsoft OLE DB Provider for DB2 or the SQL Native Client, or if you do not have the appropriate database provider installed, the Import button is disabled and you cannot import the connection.
    • When importing an OleDb Data Provider connection, whenever possible, HCOSS uses the same driver version that was in use when the connection was exported. For example, if the exported connection used SQL Server Native Client 10.0, and that version is installed and available for the import, HCOSS uses it. If the version specified is not installed or is not available, HCOSS uses the latest version available for that driver.
    • HCOSS cannot import a connection that has the same name as an existing connection. In this case, HCOSS notifies you that the connection already exists, and does not perform the import of that connection.
  6. When the import is complete, click OK to clear the message. You should see the imported connections on the Connection List found on the Connection List tab.
Parent topic: Manage Connections Tasks
Related concepts
Manage Connections Tool
Connection Types
Related reference
Manage Connections Tool Log Files
Manage Connections Tool Error Messages
Import tab


To export a connection

  1. From the HCO for SQL Server interface, click Manage Connections.
  2. From the connection list on the Export tab, select one or more connections you want to export.
  3. In the Export to File field, type the full path to and filename of a file to which you want to export the connection(s), or click the browse button to select or specify a file.
    Note:
    • The default file extension for exported connections is .xml.
    • If you don't specify a path, HCO for SQL Server puts the file into the base\bin directory of your installation.
    • If you specify an existing file, HCO for SQL Server prompts you to confirm the overwriting of that file.
  4. Click Export.
Parent topic: Manage Connections Tasks
Related concepts
Manage Connections Tool
Connection Types
Related reference
Manage Connections Tool Log Files
Manage Connections Tool Error Messages
Export tab


To repair a connection

  1. From the HCO for SQL Server interface, click Manage Connections.
  2. From the Connection List tab, select a Connection Type (System or User) to populate the Connection List grid with connections defined for that type.
  3. From the Connection List grid, select a connection that shows a status of Needs Repair.
  4. Click Repair.
Note: When repairing SQL Server connection of the System or User connection type, HCOSS attempts to use the ODBC driver specified when the connection was created, such as SQL Server Native Client 10.0. If the specified driver version is not available, HCOSS uses the latest available version.
Parent topic: Manage Connections Tasks
Related concepts
Manage Connections Tool
Connection Types
Related reference
Manage Connections Tool Log Files
Manage Connections Tool Error Messages


Migrate Databases Tasks

  • To extract DB2 schemas
  • To assess data migration
  • To export data assessment results
  • To define an object transfer list
  • To generate and execute DDL
  • To customize generated DDL
  • To customize schema mappings in DDL
  • To transfer data
  • To customize a transfer data task
  • To compare transferred data
  • To run customized data comparisons
Parent topic: How to...


To extract DB2 schemas

  1. From the HCOSS Extract Schema tool, click the Schema Extract tab.
  2. From the Source Connection drop-down list, select the DB2 connection you created using the Manage Connections tool that points to the DB2 database containing the schema objects that you want to extract.
  3. If prompted, provide your user ID and password.
  4. On the Select schema(s) to extract list, check the box that corresponds to each schema you want to extract.
  5. In the Schema Extract Name field, type a name for the generated schema extract file.
  6. Choose one of the following:
    Local | To save the generated schema extract file to the directory specified by the Local HCOSS Directory HCOSS option.
    Shared | To save the generated schema extract file to the directory specified by the Shared HCOSS Directory HCOSS option.
  7. In the Table Row Count group, select one of the following:
    • Estimated using schema statistics - to record the estimated table row count based on the schema statistics stored in SYSIBM.SYSTABLES. Use this option to improve performance.
    • Both Estimated using schema statistics and Actual using SELECT BIG_COUNT(*) - to record both the estimated table row count and the actual row count as retrieved using a SELECT BIG-COUNT(*) query. Use this option to provide accuracy.
  8. Click Extract.
  9. On the Results tab, verify that the schema extract file has been generated properly.
    Note: If you get a -551 SQL error extracting a table, no schema is extracted. To correct this, have your DB2 DBA grant you READ access to the table that generated the error; then rerun the Extract Schema tool.
Parent topic: Migrate Databases Tasks
Related concepts
Extract Schema Tool
Related reference
MFExtractSchemaInfo command
Extract Schema Tool Log Files
Extract Schema Tool Error Messages
Required DB2 Catalog Tables
Schema Extract tab
Results tab


To assess data migration

  1. From the HCOSS Assess Data Migration tool, click the Data Assessment Tasks tab.
  2. From the DB2 Connection drop-down list, select the DB2 connection that contains the extracted schema you want to assess.
  3. Do one of the following:
    • To define a new Data Assessment task:
      1. Click New.
      2. In the Name field, type a name for the data assessment task.
      3. From the Schema Extract drop-down list, select an existing schema extract file.
      4. Click OK.
    • To edit an existing data assessment task, select either the Local or Shared radio button; then select a task from the Available Assessments drop-down list.
  4. Choose one of the following to apply to the Available Assessments drop-down list:
    Local | To save the generated data assessment task to the directory specified by the Local HCOSS Directory HCOSS option.
    Shared | To save the generated data assessment task to the directory specified by the Shared HCOSS Directory HCOSS option.
  5. Choose one of the following to apply to the Associated Schema Extract drop-down list:
    Local | To show local extracted schemas on the Associated Schema Extract drop-down list.
    Shared | To show shared extracted schemas on the Associated Schema Extract drop-down list.
  6. From the Associated Schema Extract drop-down list, select an extracted schema created using the Extract Schema tool.

    This populates the Table List with information in the selected schema extract.

  7. Click Save to save the data assessment task so that it is available for future editing.

    At this point, you can browse the information in the schema extract file, and you can optionally make changes. If you want to make changes to the file, continue with step 8.

  8. From the DB2 Connection drop-down list, select the DB2 database connection you want to use when updating the schema extract file.
  9. To change the information in the extracted schema, optionally choose one of the following actions for each table on the grid:
    • Change the Count-Type. The default type listed for each column depends on which Table Row Count option you chose when you extracted the schema.
    • Change the Transfer Option from HCOSS to OTHER for tables containing data that you do not want to migrate.
  10. To update the schema extract file with changes on the Table List grid, click Update Row Count. Any error messages are shown in the Update Results window on the Results tab.
  11. Click Save Options to save the changes you've made in the Table List grid.
Parent topic: Migrate Databases Tasks
Related concepts
Assess Data Migration Tool
Related reference
Data Assessment Tasks tab
Create New Data Assessment Task dialog box
Results tab
Schema Extract tab


To export data assessment results

To export data assessment results as a CSV file:

  1. Perform the analysis.
  2. Click Export Details (csv).
  3. In the File Name field supply a filename and specify a location. If you specify a file name that doesn't exist, it is created. If you specify a file name that already exists, you will be prompted to confirm that you want to overwrite the existing file.

To export data assessment results as a text file:

  1. Perform the analysis.
  2. Click Export Report (txt).
  3. In the File Name field supply a filename and specify a location. If you specify a file name that doesn't exist, it is created. If you specify a file name that already exists, you will be prompted to confirm that you want to overwrite the existing file.
Parent topic: Migrate Databases Tasks


To define an object transfer list

  1. From the HCOSS Define Lists tool, click the Transfer Lists tab.
  2. Do one of the following:
    • To define a new transfer list:
      1. Click New.
      2. In the Name field, type a name for the transfer list file.
      3. Click OK.
    • To edit an existing transfer list, select an existing list from the Available Transfer Lists drop-down list.
  3. Choose one of the following to apply to the Available Transfer Lists drop-down list:
    Local | To save the generated transfer list file to the directory specified by the Local HCOSS Directory HCOSS option.
    Shared | To save the generated transfer list file to the directory specified by the Shared HCOSS Directory HCOSS option.
  4. Choose one of the following to apply to the Associated Schema Extract drop-down list:
    Local | To show local extracted schemas on the Associated Schema Extact drop-down list.
    Shared | To show shared extracted schemas on the Associated Schema Extact drop-down list.
  5. From the Associated Schema Extract drop-down list, select a schema extract file created using the Extract Schema tool.

    The objects available from the Schema Extract file appear on the Available Objects list.

  6. To filter the list of available objects, use the fields in the Object Filtering and Selection group. Optional.
  7. Do one or more of the following to select objects to transfer:
    • To transfer one or more objects on the Available Objects list, select each object you want to transfer using a combination of mouse clicks and the Ctrl or Shift keys; then click Add.
    • To transfer all of the objects on the Available Objects list, click Add All.
    Note: Objects dependent on selected objects are added automatically.
  8. To remove objects from the Selected Objects list, do one of the following:
    • To remove one or more of the objects on the Selected Objects list, select each object you want to remove using a combination of mouse clicks and the Ctrl or Shift keys; then click Remove.
    • To remove all of the objects on the Selected Objects list, click Remove All.
    Optional.
  9. Click Save.
Parent topic: Migrate Databases Tasks
Related concepts
Define Lists Tool
Related reference
MFObjectList command
Define Lists Tool Log Files
Define Lists Tool Error Messages
Transfer Lists tab
Create New List dialog box


To generate and execute DDL

  1. From the HCOSS Generate DDL tool, click the DDL Tasks tab.
  2. Do one of the following:
    • To define a new DDL task:
      1. Click New.
      2. In the Name field, type a name for the DDL task file.
      3. Click OK.
    • To edit an existing DDL task, select an existing task from the Available Tasks drop-down list.
  3. Choose one of the following to apply to the Available Tasks drop-down list:
    Local | To save the generated DDL task file to the directory specified by the Local HCOSS Directory HCOSS option.
    Shared | To save the generated DDL task file to the directory specified by the Shared HCOSS Directory HCOSS option.
  4. Choose one of the following to apply to the Associated Transfer List drop-down list:
    Local | To show local transfer lists on the Associated Transfer List drop-down list.
    Shared | To show shared transfer lists on the Associated Transfer List drop-down list.
  5. From the Associated Transfer Lists drop-down list, select a transfer list file created using the Define Lists tool.
  6. To define the DDL behavior, select either Drop and create objects or Restore missing objects.
  7. From the Connection for Execute drop-down list, select a SQL Server connection previously defined using the Manage Connections tool.
  8. Optionally, do one or more of the following:
    • To customize your generated DDL, click Customize. See To customize generated DDL for more information.
    • To change the default schema mappings, click Schema Mappings. See To customize schema mappings in DLL for more information.
    • To check the DDL task specifications against a test SQL Server data source, specify a SQL Server data source in the Connection for Check drop-down list; then click Check. Results are displayed on the Results tab.
    • To save the SQL generated for the DDL as an SQL script, click Export SQL Script.
  9. Click Save to save the DDL task.
  10. Click Execute.
  11. Click the Results tab to review the execution results.
Parent topic: Migrate Databases Tasks
Related concepts
Generate DDL Tool
Related tasks
To customize generated DDL
To customize schema mappings in DDL
Related reference
MFDDLConverter command
Generate DDL Tool Log Files
Generate DDL Tool Error Messages
DDL Tasks tab
Create New DDL Task dialog box
Customize DDL tab
Schema Mappings tab
Results tab


To customize generated DDL

  1. From the HCOSS Generate DDL tool, either create a new DDL task or open an available DDL task.
  2. Click the Customize DDL tab.
  3. On the Objects grid, click a schema object you want to customize.
  4. In the Customized DDL window, edit the DDL code to reflect the changes you desire.
  5. Click Save All to save your changes.
    Note: The code shown in the Generated DDL window is the DDL code that HCOSS generates by default. However, once you make and save changes to the code in the Customized DDL window, HCOSS generates your customized code instead of the default code.
  6. Repeat steps 3 through 5 for each schema object you want to customize.
Parent topic: Migrate Databases Tasks
Related concepts
Generate DDL Tool
Related tasks
To generate and execute DDL
Related reference
MFDDLConverter command
Generate DDL Tool Log Files
Generate DDL Tool Error Messages
DDL Tasks tab
Create New DDL Task dialog box
Customize DDL tab
Schema Mappings tab
Results tab


To customize schema mappings in DDL

  1. From the HCOSS Generate DDL tool, either create a new DDL task or open an available DDL task.
  2. Click the Schema Mappings tab.
  3. In the SQL Server Schema Name column, double-click the entry you want to change.
  4. Edit the mapping to reflect the appropriate SQL Server schema name.
    Note: The changes you make are automatically saved when you click outside of the SQL Server Schema Name column.
Parent topic: Migrate Databases Tasks
Related concepts
Generate DDL Tool
Related tasks
To generate and execute DDL
Related reference
MFDDLConverter command
Generate DDL Tool Log Files
Generate DDL Tool Error Messages
DDL Tasks tab
Create New DDL Task dialog box
Customize DDL tab
Schema Mappings tab
Results tab


To transfer data

  1. From the HCOSS Transfer Data tool, click the Transfer Data Tasks tab.
  2. Do one of the following:
    • To define a new transfer data task:
      1. Click New.
      2. In the Name field, type a name for the transfer data task file.
      3. Click OK.
    • To edit an existing transfer data task, select an existing task from the Available Tasks drop-down list.
  3. Choose one of the following to apply to the Available Tasks drop-down list:
    Local | To save the transfer data task file to the directory specified by the Local HCOSS Directory HCOSS option.
    Shared | To save the transfer data task file to the directory specified by the Shared HCOSS Directory HCOSS option.
  4. Choose one of the following to apply to the Associated DDL Task drop-down list:
    Local | To show local DDL tasks on the Associated DDL Task drop-down list.
    Shared | To show shared DDL tasks on the Associated DDL Task drop-down list.
  5. From the Associated DDL Task drop-down list, select a DDL task file created using the Generate DDL tool.
  6. From the Source Connection drop-down list, select a DB2 connection previously defined using the Manage Connections tool.
  7. From the Destination Connection drop-down list, select a SQL Server connection previously defined using the Manage Connections tool.
  8. To customize your transfer data task, click Customize. See To customize a transfer data task for more information. Optional.
  9. Click Save to save the transfer data task.
  10. To export the transfer data task as one or more SSIS packages, click Export as SSIS Packages. Optional.
  11. Click Transfer.
  12. On the Results tab, verify that the data transfer has completed properly.
Parent topic: Migrate Databases Tasks
Related concepts
Transfer Data Tool
Related tasks
To customize a transfer data task
Related reference
MFDataTransferCtlr command
Transfer Data Tool Log Files
Transfer Data Tool Error Messages
Transfer Data Tasks tab
Create New Transfer Data Task dialog box
Customize Transfer Data tab
Results tab


To customize a transfer data task

  1. From the HCOSS Transfer Data tool, either create a new transfer data task or open an available transfer data task.
  2. Click the Customize Transfer Data tab.
  3. Do one or more of the following to customize the task. All are optional:
    • Edit the Seq, Schema name, Name, or Buffer rows column for any entry on the Tables grid.
      Note:
      • Be careful that any new values you enter into column fields are valid within the context of the transfer task. Invalid values can cause Build Query failures.
      • Edits made directly to the Query column are not saved.
    • Change or set the controls in the Transfer Task Options group to affect all schemas and tables.
    • Build a WHERE or an ORDER BY into a SELECT statement:
      1. On the Tables grid, double-click the first column on the left-hand side of the grid for the object you want to customize.
      2. Use the fields and controls in the WHERE/ORDER BY in SELECT group to construct the clause.
      3. Click Update to add the WHERE or ORDER BY to the query statement.
    • Select a method for handling source row data from the Source Row Data Count group.
      Note:
      • The default setting for Source Row Data Count when you have not specified a WHERE clause is Estimate using schema statistics. If you have specified a WHERE clause, the default is Acutal using COUNT_BIG(*).
      • You can override the default by specifically selecting an option from the group with one exception. If the default setting is Acutal using COUNT_BIG(*), you cannot override it by setting it to Estimate using schema statistics.
  4. Click Save All to save all customizations.
  5. Optionally, click Transfer to immediately transfer the data.
    Note: You can also transfer the data from the Transfer Data Tasks tab.
Parent topic: Migrate Databases Tasks
Related concepts
Transfer Data Tool
Related tasks
To transfer data
Related reference
MFDataTransferCtlr command
Transfer Data Tool Log Files
Transfer Data Tool Error Messages
Transfer Data Tasks tab
Create New Transfer Data Task dialog box
Customize Transfer Data tab
Results tab


To compare transferred data

  1. From the HCOSS Compare Data tool, click the Compare Data Tasks tab.
  2. Do one of the following:
    • To define a new compare data task:
      1. Click New.
      2. In the Name field, type a name for the compare data task file.
      3. Click OK.
    • To edit an existing compare data task, select an existing task from the Available Tasks drop-down list.
  3. Choose one of the following to apply to the Available Tasks drop-down list:
    Local | To save the compare data task file to the directory specified by the Local HCOSS Directory HCOSS option.
    Shared | To save the compare data task file to the directory specified by the Shared HCOSS Directory HCOSS option.
  4. Choose one of the following to apply to the Associated DDL Task drop-down list:
    Local | To show local DDL tasks on the Associated DDL Task drop-down list.
    Shared | To show shared DDL tasks on the Associated DDL Task drop-down list.
  5. From the Associated DDL Task drop-down list, select a DDL task file created using the Generate DDL tool.
  6. From the Source Connection drop-down list, select a DB2 connection previously defined using the Manage Connections tool.
  7. From the Destination Connection drop-down list, select a SQL Server connection previously defined using the Manage Connections tool.
  8. To customize your compare data task, click Customize. See To run customized data comparisons for more information. Optional.
  9. Click Save to save the compare data task.
  10. Click Compare.
  11. On the Results tab, verify that the results of the comparison.
Parent topic: Migrate Databases Tasks
Related concepts
Compare Data Tool
Related tasks
To run customized data comparisons
Related reference
MFTestConversion command
Compare Data Tool Log Files
Compare Data Tool Error Messages
Compare Data Tasks tab
Create New Compare Data Task dialog box
Customize Compare Data tab
Results tab


To run customized data comparisons

  1. From the HCOSS Compare Data tool, either create a new compare data task or open an available compare data task.
  2. Click the Customize Compare Data tab.
  3. On the Source Schemas and Tables tree view, expand the tree and check a table you want to customize. This populates the Customized Query Pair window with the query associated with the checked table.
  4. Do one or more of the following:
    • Edit the query code in the Customized Query Pair window; then click Compare. Results are shown on the Results tab.
    • Build a WHERE or an ORDER BY clause into the SELECT statement:
      1. Use the fields and controls in the WHERE/ORDER BY in SELECT group to construct the clause. When you click > or <, HCOSS updates the code in the Customized Query Pair window.
      2. Click Compare. Results are shown on the Results tab.
      3. On the Customize Compare Data tab, click Save All to save the changes.
    Note: HCOSS does not save manual changes made to code in the Customized Query Pair window.
Parent topic: Migrate Databases Tasks
Related concepts
Compare Data Tool
Related tasks
To compare transferred data
Related reference
MFTestConversion command
Compare Data Tool Log Files
Compare Data Tool Error Messages
Compare Data Tasks tab
Create New Compare Data Task dialog box
Customize Compare Data tab
Results tab


Assess Application Migration

  • To assess application migration
  • To export assessment results
Parent topic: How to...


To assess application migration

  1. From the HCOSS Assess Application Migration tool, click the Assessment Tasks tab.
  2. Do one of the following:
    • To define a new assessment task:
      1. Click New.
      2. In the Name field, type a name for the assessment task file.
      3. Click the browse button and navigate to the directory containing your COBOL source files, or the parent directory to one or more subdirectories containing your COBOL source files.
      4. Click OK.
    • To edit an existing assessment task, select an existing task from the Available Assessments drop-down list.
  3. From the SQL Server Connection drop-down list, select an existing SQL Server connection to use in the assessment.
  4. If you have a schema you want to use as the default qualifier for this assessment, type its name into the Qualifier (default schema) field. Optional.
  5. If you want HCOSS to report errors related to schema specification, uncheck Ignore Schema Errors. Optional.
    Note: Do not uncheck this checkbox if you have not created your SQL Server database.
  6. In the Summary grid's Check for SQL column, uncheck any files that you do not want to include in the assessment. If you want to select all of the files, right-click in the column, and then click Select All from the popup menu.
    Note:
    • To view the source for any file listed on the Summary grid, double-click the file name in the File Path column. This opens the Source Code tab. Use the Next EXEC SQL and Previous EXEC SQL buttons to move from one SQL statement to another.
    • The code that appears on the Source Code tab is the original source file if you have not processed the assessment. If you have, the code that appears is the converted code.
  7. Click Save to save the assessment task.
  8. Click Process Files.
  9. On the Results tab, review the assessment results.
  10. To see a comparison of the original source code along with converted source code, double-click a file listed on the Error Details grid, and view the code in the SQL Conversion tab.
Parent topic: Assess Application Migration
Related concepts
Assess Application Migration Tool
Application Migration Process
Migration Scenarios
Related reference
Assessment Tasks tab
Create New Assessment Task dialog box
Results tab
Source Code tab


To export assessment results

To export application migration assessment results as a CSV file:

  1. Perform the analysis.
  2. Click Export Details (csv).
  3. In the File Name field supply a filename and specify a location. If you specify a file name that doesn't exist, it is created. If you specify a file name that already exists, you will be prompted to confirm that you want to overwrite the existing file.

To export application migration assessment results as a text file:

  1. Perform the analysis.
  2. Click Export Report (txt).
  3. In the File Name field supply a filename and specify a location. If you specify a file name that doesn't exist, it is created. If you specify a file name that already exists, you will be prompted to confirm that you want to overwrite the existing file.
Parent topic: Assess Application Migration
Related concepts
Assess Application Migration Tool
Related reference
Assessment Tasks tab
Create New Assessment Task dialog box
Results tab


Manage Packages and Plans Tasks

  • To create a bind script file
  • To open an existing bind script file
  • To create a new package
  • To create a new plan
  • To edit an existing BIND command
  • To execute one or all bind script lines
  • To free one or more packages
  • To free one plan or all plans
Parent topic: How to...


To create a bind script file

  1. From the HCOSS Manage Packages and Plans tool, click the Bind Scripts tab.
  2. If you have a script file open, click New to clear the page.
  3. Specify a SQL Server Connection.
  4. Add one or more bind script entries by creating one or more Packages or Plans.
  5. Click Save As to name and save the file to a location of your choosing. All bind script files are in XML format and have the file extension .hcodsn.
Parent topic: Manage Packages and Plans Tasks
Related concepts
COBOL Properties
Manage Packages and Plans Tool
Binding Applications
Related reference
Bind Scripts tab


To open an existing bind script file

  1. From the HCOSS Manage Packages and Plans tool, click the Bind Scripts tab.
  2. Click Open to locate and select an existing bind script file. Bind script files have the file extension .hcodsn.
Parent topic: Manage Packages and Plans Tasks
Related concepts
Manage Packages and Plans Tool
Binding Applications
Related reference
Bind Scripts tab


To create a new package

  1. From the HCOSS Manage Packages and Plans tool, either create or open a bind script file.
  2. Click New Package.
  3. In the Collection Name field, type a name for the collection in which to store the package.
  4. Select an action. If you select Replace Version, type the version you want to replace into the corresponding field.
  5. From the Library Name drop-down list, select the library that contains the source member from which you want to create the package. The default is DBRMLIB.
  6. From the Member Name drop-down list, select the member you want to action.
  7. If you have a qualifier you would like to specify, type it into the Default Qualifier field.
  8. Click Execute. This generates a script command and places it onto the list of Bind Script Entries on the Bind Scripts tab.
Parent topic: Manage Packages and Plans Tasks
Related concepts
Manage Packages and Plans Tool
Binding Applications
Package Specifications
Related reference
Bind Packages tab


To create a new plan

  1. From the HCOSS Manage Packages and Plans tool, either create or open a bind script file.
  2. Click New Plan.
  3. In the Plan Name field, type a name for the plan.
  4. Select an action.
  5. Do one of the following:
    • To bind packages into the plan, select Packages mode. In this case, all versions of each package are available to the plan.
    • To bind DBRM members directly to the plan, select DBRM Members mode. In this case, HCOSS expects to find these members in the default DBRM library.
    • To bind one or more DBRM libraries to the plan, including all of the members in those libraries, select DBRM Libraries mode. In this case, HCOSS searches the libraries for DBRM members in the order in which the libraries appear on the Selected Libraries list. HCOSS uses the first instance of a specified member that it finds.
  6. If you have a qualifier you would like to specify, type it into the Default Qualifier field.
    Note: HCOSS applies plan qualifiers to DBRM members specified in the plan; however, packages included in the plan use the qualifier specified for the package when it was executed, ignoring any specified plan qualifier.
  7. Depending on the mode you have selected, use the other lists and fields on this page to add packages or DBRM members to the plan, or to remove them from the plan. You can use the Search field above each list to narrow the scope of the list. Use the % character as a wild card.
  8. Click either Add to Script to add the generated script command to the list of Bind Script Entries on the Bind Scripts tab, or click Execute to add the generated script and also execute the script commands thereby updating the SQL Server database.
    Note: If you do not execute the command at this time, you can execute it from the Bind Scripts tab to update the SQL Server database. You must eventually execute the command for the bind to take place.
Parent topic: Manage Packages and Plans Tasks
Related concepts
Manage Packages and Plans Tool
Binding Applications
Plan Specifications
Related reference
Bind Plans tab


To edit an existing BIND command

  1. From the HCOSS Manage Packages and Plans tool, open a bind script file.
  2. Select a command on the Bind Script Entries list.
  3. Click Edit.
  4. Make any desired changes to the specification. For BIND PLAN commands, the available lists and fields on this page vary depending on the selected mode. You can use the Search field above each list to narrow the scope of the list. Use the % character as a wild card.
    Note: For BIND PLAN commands that include DBRM members, you can add one or more libraries in which to search for the specified DBRM members by selecting DBRM Libraries mode. In this case, you can click Move Up or Move Down to change the search order.
  5. Do one of the following:
    • Click Execute to generate and execute the BIND command and add it to your bind script.
    • Click Update in Script to generate the BIND command and add it to your script for execution at a later time.
Parent topic: Manage Packages and Plans Tasks
Related concepts
Manage Packages and Plans Tool
Binding Applications
Package Specifications
Plan Specifications
Related reference
Bind Packages tab
Bind Plans tab
Bind Scripts tab


To execute one or all bind script lines

  1. From the HCOSS Manage Packages and Plans tool, either create or open a bind script file.
  2. Ensure that the script lines on the Bind Script Entries list appear in the order in which you want to execute them. If not, select a line and click Move Up or Move Down to change its position.
  3. Do one of the following:
    • To execute one script line only, select the script line you want to execute; then click Execute Selected. In this case, if a script command fails, HCOSS displays an error message.
    • To execute all script lines in the order in which they appear on the list, click Execute All. In this case, if a script command fails, HCOSS displays an error message enabling you to click Cancel to cancel all further execution, or OK to continue with the next script command.
    Note:
    • You must successfully execute all BIND PLAN script lines to make the plans available to your run-time application.
    • All bind script execution results appear on the Results tab.
Parent topic: Manage Packages and Plans Tasks
Related concepts
Manage Packages and Plans Tool
Binding Applications
Related reference
Bind Scripts tab
Results tab


To free one or more packages

  1. From the HCOSS interface, use the Manage Connections tool to ensure you have an active connection to your SQL Server database.
  2. Click Manage Packages and Plans to start the tool.
  3. From the Bind Scripts tab, select a SQL Server Connection from the drop-down list.
  4. Click the Free Packages tab.
  5. Do one of the following:
    • To free all bound packages listed on the Bound Packages list, click Free All Packages.
    • To free one or more packages:
      1. To show version information for each package on the Bound Packages list, check Show package version information. This turns on the Version column within the grid (Optional).
      2. On the Bound Packages list, select one or more packages to remove from your SQL Server database.
        Note: To select or unselect all packages, right-click and choose the appropriate menu option.
      3. Click Free Package(s).
  6. Click OK to confirm.
Parent topic: Manage Packages and Plans Tasks


To free one plan or all plans

  1. From the HCOSS interface, use the Manage Connections tool to ensure you have an active connection to your SQL Server database.
  2. Click Manage Packages and Plans to start the tool.
  3. From the Bind Scripts tab, select a SQL Server Connection from the drop-down list.
  4. Click the Free Plans tab.
  5. Do one of the following:
    • To free all bound plans listed on the Bound Plans list, click Free All Plans.
    • To free a single plan:
      1. On the Bound Plans list, select a plan you want to remove from your SQL Server database.
      2. View the details of the plan by doing one or more of the following (optional):
        • Select either the Members or Packages mode to view the contents of the plan.
        • When in Packages mode, check Expand PKLIST to show package details if you want to view every package that resulted from the binding.
        • When Expand PKLIST to show package details is checked, you can also check Show package version information to display version information for each package.
      3. Click Free Plan.
  6. Click OK to confirm.
Parent topic: Manage Packages and Plans Tasks


Bind Applications

  • To bind from the command line
  • To bind as a post-build event
  • To manually code a bind script file
  • To bind from JCL
Parent topic: How to...


To bind from the command line

  1. Create a bind script file using the Manage Packages and Plans tool, or manually in a text editor. If you create the file in a text editor, be sure to give it a file extension of .hcodsn.
    Note: For a listing of commands that are valid in HCOSS bind script files, see the topic Bind Script Commands.
  2. Using the Manage Connections tool, connect to your SQL Server database with a login ID and password that grants you permission to update the SYSIBM table.
  3. Open a command prompt and change to the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory.
  4. Enter the following command:

    DSN SYSTEM(SQLServerConnection) @"bindScriptFile"

    where SQLServerConnection is the name of your SQL Server connection, and bindScriptFile is the full path to and filename of your bind script file.

Parent topic: Bind Applications
Related concepts
DSN Bind Utility
COBOL Properties
Binding Applications
Related tasks
To manually code a bind script file
Related reference
DSN command
Bind Script Commands


To bind as a post-build event

  1. Build your application using the DBRMLIB SQL compiler option to create DBRMs from your source code.
  2. Create a bind script file using the Manage Packages and Plans tool, or manually in a text editor. If you create the file in a text editor, be sure to give it a file extension of .hcodsn.
    Note: For a listing of commands that are valid in HCOSS bind script files, see the topic Bind Script Commands.
  3. Using the Manage Connections tool, connect to your SQL Server database with a login ID and password that grants you permission to update the SYSIBM table.
  4. In Visual Studio, open the properties for the project that contains your application.
  5. On the COBOL tab, click Build Events.
  6. In the Post-build event command line field, type the following:

    DSN SYSTEM(SQLServerConnection) @"bindScriptFile"

    where SQLServerConnection is the name of your SQL Server connection, and bindScriptFile is the full path to and filename of your bind script file.

  7. Click OK.
Parent topic: Bind Applications
Related concepts
DSN Bind Utility
COBOL Properties
Binding Applications
Application Migration Process
Related tasks
To manually code a bind script file
Related reference
DSN command
Bind Script Commands


To manually code a bind script file

  1. Open a text editor of your choice.
  2. Type each command on its own line.
    Note: For a listing of commands that are valid in HCOSS bind script files, see the topic Bind Script Commands.
  3. At the end of the file, type END.
  4. Save the file to a location of your choice, using a .hcodsn filename extension.
Parent topic: Bind Applications
Related concepts
DSN Bind Utility
COBOL Properties
Binding Applications
Related tasks
To bind from the command line
To bind as a post-build event
Related reference
DSN command
Bind Script Commands


To bind from JCL

  1. In your JCL, code a DSN statement followed by appropriate BIND statements.
    //SYSTSIN  DD *
  DSN SYSTEM(XAResourceName)
  BIND bindArguments
  [BIND...]
  END

    For example:

    //SYSTSIN  DD *
  DSN SYSTEM(HCODemo)
  BIND PLAN(TWOPACKAGESET) ACTION(REPLACE) LIBRARY(DBRMLIB) -
  MEMBER(TWOPACKAGESET) QUALIFIER(PROD)
  END
  2. Save your JCL.
Note: For a listing of DSN commands supported by HCOSS, see the topic Bind Script Commands.
Parent topic: Bind Applications
Related concepts
Binding Applications
JCL Applications - DBRM Specification
Related reference
Bind Script Commands


Customize HCOSS

  • To set HCOSS options
  • To customize data type mappings
  • To customize SQL name mappings
Parent topic: How to...


To set HCOSS options

  • If you started HCOSS from the Start menu:
    1. From the HCO for SQL Server interface, click Options.
    2. Set options as desired.
      Tip: Context help for each setting appears at the bottom of the window.
    3. Click OK to save your settings.
  • If you started HCOSS from the Visual Studio IDE:
    1. From the Visual Studio IDE, click Tools > Options > Micro Focus COBOL Tools > HCO for SQL Server.
    2. Set options as desired.
      Tip: Context help for each setting appears at the bottom of the window.
    3. Click OK to save your settings.
Parent topic: Customize HCOSS
Related concepts
HCOSS Toolset
Using HCOSS with Windows User Account Control (UAC)
Related reference
Options


To customize data type mappings

  1. From the HCO for SQL Server interface, click Data Type Mappings.
  2. To change default mappings, use the drop-down list to select a new value for any entry on the page.
  3. To add a new mapping:
    1. Scroll down to the bottom of the page.
    2. In the blank row at the bottom of the page, select values for each column.
    Note: Each time you click a field in the blank bottom row, a new blank row appears underneath to enable you to add another new mapping.
  4. Click Save.
Parent topic: Customize HCOSS
Related reference
Customizing Data Type Mappings
Default Data Type Mappings
Customize Type Mappings - Data Mappings tab


To customize SQL name mappings

  1. From the HCO for SQL Server interface, click SQL Name Mappings.
  2. To change default mappings, do one or more of the following:
    • To change the name of any DB2 Functions/Special Register or its SQL Server Equivalent, simply click in the field and type in your change.
    • To change the mapping type for any DB2 Function/Special Register, check one or both of its correponding check boxes.
  3. To add a new mapping:
    1. Scroll down to the bottom of the page.
    2. In the field at the bottom of the DB2 Function/Special Register column, type in the name of a DB2 function or special register that exists in your DB2 database but is not already listed as a default.
    3. Type a corresponding SQL Server equivalent name into the SQL Server Equivalent column.
    4. Depending on what applies to your new mapping, check the appropriate box or boxes in the Is Function or Special Register columns.
    Note: Each time you type into a field or check a box in the blank bottom row, a new blank row appears underneath to enable you to add another new mapping.
  4. Click Save.
Parent topic: Customize HCOSS
Related concepts
Customizing Functions and Special Registers
Related reference
Default SQL Name Mappings
Customize SQL Name Mappings - SQL Name tab


Reference

  • Command Line Reference
  • SQL Compiler Directive Options - HCOSS
  • Required DB2 Catalog Tables
  • DB2 to SQL Server Conversion Reference
  • Bind Script Commands
  • Messages
  • Log Files
  • User Interface Reference
Parent topic: HCO for SQL Server (HCOSS)


Command Line Reference

  • MFDataTransferCtlr command
    Executes the HCOSS Transfer Data tool from the command line.
  • MFDDLConverter command
    Executes the HCOSS Generate DDL tool from the command line.
  • MFExtractSchemaInfo command
    Executes the HCOSS Extract Schema tool from the command line.
  • MFObjectList command
    Executes the HCOSS Define Lists tool from the command line.
  • MFTestConversion command
    Executes the HCOSS Compare Data tool from the command line.
  • COMPARE Command File
    Explains how to code a COMPARE command file to use with the MFTestConversion command, IN parameter.
  • DSN command
    Executes the DSN Bind utility, which performs schema updates as necessary and executes the commands contained in an HCOSS bind script file.
Parent topic: Reference


MFDataTransferCtlr command

Executes the HCOSS Transfer Data tool from the command line.

Syntax:

MFDataTransferCtlr DB2=DB2dsn;
                   [U1=DB2userID;]
                   [P1=DB2Password;]
                   SRV=SQLServerDSN;
                   [U2=SQLServerUserID;]
                   [P2=SQLServerPassword;]
                   X=["]DataTransferList["];
                   [XLocal={TRUE | FALSE};]
                   [TRIG={TRUE | FALSE};]
                   [CONSTR={TRUE | FALSE};]
                   [ErrROW={TRUE | FALSE};]
                   [TYPELOG={CONSOLE | FILE | BOTH};]

Parameters:

DB2
The name of a cataloged and registered DB2 data source.
U1
The user ID required to access the DB2 data source specified by the DB2 parameter, if applicable.
P1
The password required for the user ID specified by the U1 parameter, if applicable.
SRV
The name of a cataloged and registered SQL Server data source.
U2
The user ID required to access the SQL Server data source specified by the SRV parameter. Not required when using Windows authentication.
P2
The password required for the user ID specified by the U2 parameter, if applicable.
X
The name of a transfer data task file containing a list of tables to be transferred and the queries required to transfer the data. Do not specify a file extension. The file extension for a transfer data task file is .hcodtt. If the transfer data task file name contains spaces, surround it with a set of double quotes ("). You can create a transfer data task file using the UI version of the HCOSS Transfer Data tool, or you can create one manually in a text editor. If you create a transfer data task file using the UI version of the tool, its location is determined by the selection of either the Local or Shared button for the transfer data task. If you create a data transfer task file manually, you must store it in the \DataTasks subdirectory of either the directory specified by the Local HCOSS Directory HCOSS option or the Shared HCOSS Directory HCOSS option.
XLocal
Determines the location of the transfer data task file. Transfer data task files are stored in the \DataTasks subdirectory of either of the following, depending on the value specified:
TRUE | Directory specified by the Local HCOSS Directory HCOSS option. Default.
FALSE | Directory specified by the Shared HCOSS Directory HCOSS option.
TRIG
Specifies whether or not to fire all triggers during the data transfer. Default is FALSE.
CONSTR
Specifies whether or not SQL Server performs all defined checks during the data transfer. Default is FALSE.
ErrROW
Specifies whether or not HCOSS logs errors encountered during the data transfer. Default is FALSE.
TYPELOG
Sets the type of logging to perform. Defaults to the equivalent of the value specified for the Type of logging to do HCOSS option.

Comments:

Before running this tool, be sure that the appropriate target tables exist in the SQL Server database.

Examples:

MFDataTransferCtlr DB2=MVS91; SRV=HCODemo; X=LocalTransferList
MFDataTransferCtlr DB2=MVS91; SRV=HCODemo; X=SharedTransferList; XLocal=FALSE
Parent topic: Command Line Reference
Related concepts
Transfer Data Tool
Related tasks
To transfer data
To customize a transfer data task
Related reference
Transfer Data Tool Log Files
Transfer Data Tool Error Messages


MFDDLConverter command

Executes the HCOSS Generate DDL tool from the command line.

Syntax

MFDDLConverter S=schemaExtractFile;
               [SLocal={TRUE | FALSE};]
               O=["]DDLOutputFile["];
               DROP={DR | CNE};
               SYSIBM={TRUE | FALSE};
               [M=["]dataMappingFile["];]
               [TYPE={TABLE | VIEW | ALL};]
               [SCHEMA=DB2Schema1[, DB2Schema2 ...];]
               [NAME=objectName;]
               [ROWSIZE={TRUE | FALSE};]
               [INCDEP={TRUE | FALSE};]
               [STITCH={TRUE | FALSE};]
               [TYPELOG={CONSOLE | FILE | BOTH};]
               [FOOTER={TRUE | FALSE};]

Parameters:

S
The name of a schema extract file generated using the HCOSS Schema Extract tool. Do not specify a file extension.
SLocal
Specifies the location of the generated schema extract file. Schema extract files are stored in the \Schemas subdirectory of either of the following, depending on the value specified:
TRUE | Directory specified by the Local HCOSS Directory HCOSS option. Default.
FALSE | Directory specified by the Shared HCOSS Directory HCOSS option.
O
The full path to and filename of the generated DDL command file (usually given a .sql file extension). If this specification contains spaces, enclose it in double quotes (").
DROP
Determines how objects are handled in the generated DDL.
DR | Drop and recreate all objects
CNE | Create a new database object for each object in the object list that does not already exist in the database
SYSIBM
Specifies whether or not to include the SYSIBM schema in the generated DDL. Both the SYSIBM schema and its dependent objects are included when set to TRUE; however, the SYSIBM schema and its dependent objects must be present in the schema extract file to be included in the generated DDL.
M
Full path to and filename of the HCOSS data mapping file. If this specification contains spaces, enclose it in double quotes ("). Defaults to %PROGRAMDATA%\Micro Focus\NetExpress\6.0\DataMappings.hcomap.
TYPE
Limits objects to tables only or views only. Default is ALL.
SCHEMA
The name of one or more valid DB2 schemas to include in the generated DDL. Separate schema names with a comma (,). You may also use the % wild card character in schema names. Defaults to all schemas in the object list file.
NAME
Filters the generated DDL to include only the specified DB2 table or view name. You may use the % wild card character in table and view names. Defaults to all table and view names.
ROWSIZE
Specifies whether or not to check table column widths to determine if they exceed the SQL Server row width limit of 8060 and write the information to the log file.
TRUE | Check table column widths.
FALSE | Do not check table column widths. Default.
INCDEP
Specifies whether or not to include table and view dependencies when processing objects.
TRUE | Include table and view dependencies.
FALSE | Do not include table and view dependencies. Default.
STITCH
Specifies whether or not to include a DDL header in the generated DDL:
TRUE | Include DDL header.
FALSE | Exclude DDL header. Default.
TYPELOG
Sets the type of logging to perform. Defaults to the equivalent of the value specified for the Type of logging to do HCOSS option.
FOOTER
Specifies whether or not to include a DDL footer in the generated DDL:
TRUE | Include DDL footer. Default.
FALSE | Exclude DDL footer.

Example:

MFDDLConverter S=MySchemaExtract; O=c:\ProgramData\MyDDL.sql; DROP=DR; SYSIBM=TRUE
Parent topic: Command Line Reference
Related concepts
Generate DDL Tool
Related tasks
To generate and execute DDL
To customize generated DDL
To customize schema mappings in DDL
Related reference
Generate DDL Tool Log Files
Generate DDL Tool Error Messages


MFExtractSchemaInfo command

Executes the HCOSS Extract Schema tool from the command line.

Syntax:

MFExtractSchemaInfo DB2=DB2Connection;
                    [U=DB2UserID;]
                    [P=DB2Password;]
                    OUT=SchemaExtractFileName;
                    [OUTLocal={TRUE | FALSE};]
                    {SCHEMA=DB2Schema1[, DB2Schema2 ...] |
                       TBS=DB2Tablespace1[, DB2Tablespace2 ...]};
                    [TYPELOG={CONSOLE | FILE | BOTH};]

Parameters:

DB2
The name of a cataloged DB2 connection.
U
The user ID required to access the DB2 database specified by the DB parameter, if applicable.
P
The password required for the user ID specified by the U parameter, if applicable.
OUT
The name of the generated schema extract file. Do not specify a file extension. The default file extension is .hcodbs.
OUTLocal
Determines the location of the generated schema extract file. Schema extract files are stored in the \Schemas subdirectory of either of the following, depending on the value specified:
TRUE | Directory specified by the Local HCOSS Directory HCOSS option. Default.
FALSE | Directory specified by the Shared HCOSS Directory HCOSS option.
SCHEMA
The name of one or more valid DB2 schemas to extract. Separate schema names with a comma (,). You may also use the % wild card character in schema names.
TBS
The name of one or more valid DB2 tablespaces to extract. Separate tablespace names with a comma (,).
TYPELOG
Sets the type of logging to perform. Defaults to the equivalent of the value specified for the Type of logging to do HCOSS option.

Example:

MFExtractSchemaInfo DB2=MVS91; OUT=LocalSchemaExtract; SCHEMA=MFIREX%,SDI002; TYPELOG=FILE
MFExtractSchemaInfo DB2=MVS91; OUT=SharedSchemaExtract; OUTLocal=FALSE; SCHEMA=MFIREX%,SDI002
Parent topic: Command Line Reference
Related concepts
Extract Schema Tool
Related tasks
To extract DB2 schemas
Related reference
Extract Schema Tool Log Files
Extract Schema Tool Error Messages


MFObjectList command

Executes the HCOSS Define Lists tool from the command line.

Syntax:

MFObjectList S=schemaExtractFile;
             [SLocal={TRUE | FALSE};]
             OUT=objectListOutputFile;
             [OUTLocal={TRUE | FALSE};]
             [M=["]dataMappingFile["];]
             [SYSIBM={TRUE | FALSE};]
             [TYPE={TABLE | VIEW | ALL};]
             [SCHEMA=DB2Schema1[, DB2Schema2 ...];]
             [NAME=objectName;]
             [TYPELOG={CONSOLE | FILE | BOTH};]

Parameters:

S
The name of a schema extract file generated using the HCOSS Schema Extract tool. Do not specify a file extension.
SLocal
Determines the location of the schema extract file specified by the S parameter. Schema extract files are stored in the \Schemas subdirectory of either of the following, depending on the value specified:
TRUE | Directory specified by the Local HCOSS Directory HCOSS option. Default.
FALSE | Directory specified by the Shared HCOSS Directory HCOSS option.
OUT
The name of the generated object list file. Do not specify a file extension. The default file extension is .hcolst.
OUTLocal
Determines the location of the generated object list file. Object list files are stored in the \TargetLists subdirectory of either of the following, depending on the value specified:
TRUE | Directory specified by the Local HCOSS Directory HCOSS option. Default.
FALSE | Directory specified by the Shared HCOSS Directory HCOSS option.
M
Full path to and filename of the HCOSS data mapping file. If this specification contains spaces, enclose it in double quotes ("). Defaults to %PROGRAMDATA%\Micro Focus\NetExpress\6.0\DataMappings.hcomap.
SYSIBM
Specifies whether or not to include the SYSIBM schema. Default is FALSE.
TYPE
Limits objects to tables only or views only. Default is ALL.
SCHEMA
The name of one or more valid DB2 schemas to include on the object list. Separate schema names with a comma (,). You may also use the % wild card character in schema names. Defaults to all schemas specified in the schema extract file.
NAME
Filters the object list to include only the specified DB2 table or view name. You may use the % wild card character in table and view names. Defaults to all table and view names.
TYPELOG
Sets the type of logging to perform. Defaults to the equivalent of the value specified for the Type of logging to do HCOSS option.
MFObjectList S=LocalSchemaExtract; OUT=LocalObjectList; SCHEMA=MFIREX%,SDI002; TYPELOG=FILE
MFObjectList S=SharedSchemaExtract; SLocal=FALSE; OUT=SharedObjectList; OUTLocal=FALSE; SCHEMA=MFIREX%,SDI002;
Parent topic: Command Line Reference
Related concepts
Define Lists Tool
Related tasks
To define an object transfer list
Related reference
Define Lists Tool Log Files
Define Lists Tool Error Messages


MFTestConversion command

Executes the HCOSS Compare Data tool from the command line.

Syntax:

MFTestConversion {X=["]compareDataTaskFile["] | IN=["]compareCommandsFile["]};
                 [XLocal={TRUE | FALSE};]
                 [INLocal={TRUE | FALSE};]
                 [DB2=DB2DataSource;]
                 [U1=DB2Userid;]
                 [P1=DB2Password;]
                 [SRV=SQLServerDataSource;]
                 [U2=SQLServerUserid;]
                 [P2=SQLServerPassword;]
                 [TYPELOG={CONSOLE | FILE | BOTH};]

Parameters:

X
The name of a compare data task file containing compare commands generated by the UI version of the Compare Data tool. Do not specify a file extension. The file extension for a compare data task file is .hcocpt. If the compare data task file name contains spaces, surround it with a set of double quotes ("). The location of a compare data task file is determined by the selection of either the Local or Shared button for the compare data task.
IN
A flat text input file containing HCOSS COMPARE commands designed to carry out a user-defined set of comparisons. You can code this file in any text editor. No filenaming convention is enforced for this file; however, if the file name contains spaces, surround it with a set of double quotes (").
XLocal
Specifies the location of the compare data task file. Compare data task files are stored in the \CompareTasks subdirectory of either of the following, depending on the value specified:
TRUE | Directory specified by the Local HCOSS Directory HCOSS option. Default.
FALSE | Directory specified by the Shared HCOSS Directory HCOSS option.
INLocal
Determines the location of the compare commands file. Compare commands files are stored in the \CompareTasks subdirectory of either of the following, depending on the value specified:
TRUE | Directory specified by the Local HCOSS Directory HCOSS option. Default.
FALSE | Directory specified by the Shared HCOSS Directory HCOSS option.
DB2
The name of a cataloged and registered DB2 data source. Required when using the IN parameter, and required when using the X parameter only to override the connection specified in the compare data task file.
U1
The user ID required to access the DB2 data source specified either by the DB2 parameter or within the data task file, if applicable, and if the user ID for the DB2 data source is not stored with the specified connection.
P1
The password required for the user ID specified by the U1 parameter, if applicable, and if the password for the user ID specified in the U1 parameter is not stored with the specified connection.
SRV
The name of a cataloged and registered SQL Server data source. Required when using the IN parameter, and required when using the X parameter only to override the connection specified in the compare data task file.
U2
The user ID required to access the SQL Server data source specified either by the SRV parameter or within the data task file. Not required when using Windows authentication. If not using Windows Authentication, this is required only if the user ID for the SQL Server data source is not stored with the specified connection.
P2
The password required for the user ID specified by the U2 parameter, if applicable, and if the password for the user ID specified in the U2 parameter is not stored with the specified connection.
TYPELOG
Sets the type of logging to perform. Defaults to the equivalent of the value specified for the Type of logging to do HCOSS option.

Comment:

Parameters may be given in any order.

Example:

MFDataTransferCtlr DB2=MVS91; SRV=HCODemo; X=LocalCompareData; TYPELOG=FILE
MFDataTransferCtlr DB2=MVS91; SRV=HCODemo; X=SharedCompareData; XLocal=FALSE
Parent topic: Command Line Reference
Related concepts
Compare Data Tool
Related tasks
To compare transferred data
To run customized data comparisons
Related reference
Compare Data Tool Log Files
Compare Data Tool Error Messages
COMPARE Command File


COMPARE Command File

Explains how to code a COMPARE command file to use with the MFTestConversion command, IN parameter.

Syntax:

USE DB2;
SELECT arguments;
USE SRV;
SELECT arguments;
COMPARE [integer ROWS] [SKIP COL integer1 [integer2 ...]]
[USE DB2;
SELECT arguments;
USE SRV;
SELECT arguments;
COMPARE [integer ROWS] [SKIP COL integer1 [integer2 ...]]
[...]]

Parameters:

USE DB2
Execute the following SQL SELECT command against the DB2 connection specified on the MFTestConversion command line.
USE SRV
Execute the following SQL SELECT command against the SQL Server connection specified on the MFTestConversion command line.
SELECT arguments
Any valid SQL SELECT statement returning a set of values to be compared. Each SELECT statement applies to the database specified in the USE statement that immediately precedes it. You must code at least one SELECT statement corresponding to the preceding USE DB2 and USE SQL statements respectively before coding a COMPARE statement. The returned values for both SELECT statements preceding a COMPARE statement should include the same list of columns in the same order to ensure success. Qualifiers for table names and column names can differ, depending on how the tables are defined in their respective databases.
COMPARE
With no arguments, compares all rows and all columns in the result sets for each preceding SELECT statement.
integer ROWS
Compare only the first integer rows, where integer represents any number greater than zero (0).
SKIP COL integer [integer ...]
Do not return compare information for each column number specified by integer, where integer represents any number greater than zero (0) and less than the number of columns in the SELECT list or 749; separate each specified integer with a space.

Comments:

Code a COMPARE command file using any text editor and save with the filename of your choice in either the directory specified by the Local HCOSS Directory or the directory specified by the Shared HCOSS Directory HCOSS option.

You can code multiple comparisons into a single COMPARE command file.

USE and COMPARE commands and their respective arguments are not case sensitive.

SQL SELECT statements might be case sensitive depending on how the database handles case sensitivity.

You can combine the ROWS and SKIP COL options.

Synonyms for COL are:
  • COLUMN
  • COLUMNS
  • COLS

Examples:

Compare all returned tables and rows:
USE DB2;
SELECT * FROM EMPINFO2;
USE SRV;
SELECT * FROM EMPINFO2;
COMPARE;
Compare a limited number of rows:
USE DB2;
SELECT * FROM EMPINFO2;
USE SRV;
SELECT * FROM EMPINFO2;
COMPARE 10 ROWS;
Skip certain columns:
USE DB2;
SELECT * FROM EMPINFO2;
USE SRV;
SELECT * FROM EMPINFO2;
COMPARE SKIP COLS 3 5 15;
Compare a limited number of rows and skip certain columns:
USE DB2;
SELECT * FROM EMPINFO2;
USE SRV;
SELECT * FROM EMPINFO2;
COMPARE 10 ROWS SKIP COLS 3 5 15;
Include more than one comparison in a single COMPARE command file:
USE DB2;
SELECT * FROM EMPINFO2;
USE SRV;
SELECT * FROM EMPINFO2;
COMPARE 10 ROWS SKIP COLS 3 5 15;
USE DB2;
SELECT * FROM EMPINFO3;
USE SRV;
SELECT * FROM EMPINFO3;
COMPARE;
Parent topic: Command Line Reference
Related reference
MFTestConversion command


DSN command

Executes the DSN Bind utility, which performs schema updates as necessary and executes the commands contained in an HCOSS bind script file.

Syntax

DSN SYSTEM(SQLServerConnection) @"bindScriptFile"
[ASUSER(userID.password)]

Parameters

SQLServerConnection | The name of an established connection to a SQL Server database.
bindScriptFile | The full path to and filename of the bind script (.hcodsn) file that contains the commands you want to execute.1
userID | The user ID required to log onto your SQL Server database. Enclose in double quotes (") if the user ID contains non-alphanumeric characters.2
password | The password required to log onto your SQL Server database. Enclose in double quotes (") if the password contains non-alphanumeric characters.2

1 For a listing of commands that are valid in HCOSS bind script files, see the topic Bind Script Commands.

2 The level of database access permissions required by these login credentials can vary. For details, see the topic DSN Bind Utility.

Comments

  • DSN.exe is in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory.
  • Execute DSN.exe either from a command prompt in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory, or execute it as a post-build event.
  • When deploying to a remote server, you can optionally execute DSN.exe on your deployment server instead of your development server; however, to do this you must have appropriate permissions on the deployment server machine.
  • Create the bind script file either with the Manage Packages and Plans tool, or manually in a text editor.
  • If you omit the ASUSER parameter, DSN uses Windows authentication, prompting you for a username and password if it fails.
Parent topic: Command Line Reference
Related concepts
DSN Bind Utility
COBOL Properties
Binding Applications
Migration Scenarios
Deploying Native Applications
Related tasks
To bind from the command line
To bind as a post-build event
To manually code a bind script file
Related reference
BIND
Bind Script Commands


SQL Compiler Directive Options - HCOSS

  • ACCESS
    Enables deployment of application code and SQL by updating the SQL Server database at compile time. Creates a stored procedure at compile time for most static SQL statements.
  • BIND
    Enables deployment of application code by generating an SQL batch script that can be used with sqlcmd or SQL Server Management Studio to update the SQL Server database.
  • DATE
    Controls the reformatting of date values in output parameters and in input parameter character host variables when DETECTDATE is also specified.
  • DATEDELIM
    Specifies a single character as the delimiter between the year, month, and day components to override the default delimiter determined by the HCOSS DIALECT or DATE directive specification.
  • DBRMLIB
    Enables generation of DBRMs containing the static SQL statements from COBOL programs, mimicking mainframe-style binding.
  • DETECTDATE
    Enables recognition of date, time and datetime values in character host variables.
  • DIALECT
    Enables SQL dialect compatibility features for HCOSS in the OpenESQL preprocessor, turning on automatic mapping of functions, special registers, data types, and all other automatic HCOSS conversions, and enabling the use of DIALECT statement prefixes. Converts DB2 SQL statements that are not compatible with SQL Server into equivalent T-SQL statements in most cases.
  • MEMBER
    Specifies a non-default name for the DBRM.
  • PROMOTE
    Saves generated DBRMs to the shared HCOSS DBRM library.
  • QUALIFIER
    Qualifies unqualified table and view names.
  • TIME
    Controls the reformatting of date values in output parameters and in input parameter character host variables when DETECTDATE is also used.
  • TIMEDELIM
    Specifies a single character as the delimiter between the hour, minute, and second components to override the default delimiter determined by the HCOSS DIALECT or TIME directive specification.
  • TSTAMPSEP
    Specifies a single character as the separator between the date and time parts of timestamp and date/time data.
  • VERSION
    Specifies a version for a DBRM.
Parent topic: Reference
Related concepts
SQL Properties
Related reference
SQL Compiler Directive Options
Related information
HCO for SQL Server Compiler Directive Options for PL/I


ACCESS

Syntax:

ACCESS=access-plan-name

Parameters:

access-plan-name
The name of the access plan.

Properties:

Default: ACCESS=prog-name

Where prog-name is the COBOL program name.

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - HCOSS SQL Compiler Directive Options for more information.

Advantages:

Convenient for testing when the BIND SQL compiler directive option is to be used for deployment.

Comments:

Less compatible with mainframe deployment behavior than using a combination of the DBRMLIB compiler directive and the DSN Bind utility.

HCOSS generates a separate stored procedure in the schema specified by your SQL Server connection for each static SQL statement in the program.

If stored procedures from a previous compilation are present in the schema, HCOSS drops them before creating new stored procedures.

Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Building Applications
DSN Bind Utility
DIALECT Statement Prefixes
Scope - HCOSS SQL Compiler Directive Options
SQL Code Generation Options
Related reference
BIND
DBRMLIB
QUALIFIER
DIALECT


BIND

Syntax

BIND=bind-script-file

Parameters:

bind-script-file
The name of the bind file.

Properties:

Default: BIND=prog-name

Where prog-name is the COBOL program name.

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - HCOSS SQL Compiler Directive Options for more information.

Advantages:

  • Security can be applied separately to procedures and data so that application users can only access and update data via the application.
  • DBAs can review SQL that is to be deployed without having to access source code.

Comments:

The filename extension for generated bind script files is .sql. For example, if you specify BIND=myprog, the generated bind script file name is myprog.sql.

To update the SQL Server database, run the generated bind script file using sqlcmd or from SQL Server Management Studio.

The generated bind script file contains commands to create a separate stored procedure in the schema specified by your SQL Server connection for each static SQL statement in the program.

If stored procedures from a previous compilation are present in the schema, HCOSS drops them before creating new stored procedures.

Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Manage Packages and Plans Tool
Binding Applications
Building Applications
DSN Bind Utility
DIALECT Statement Prefixes
Scope - HCOSS SQL Compiler Directive Options
SQL Code Generation Options
Related reference
ACCESS
DBRMLIB
QUALIFIER
DIALECT
DSN command
Bind Script Commands


DBRMLIB

Syntax, Format 1:

DBRMLIB[=DBRMLIBName]

Syntax, Format 2:

NODBRMLIB

Parameters:

DBRMLIBName
A name for the DBRM library. The value provided must conform to the syntax for mainframe Partitioned Data Set names as follows:
  • Maximum length is 44 bytes.
  • Must specify one or more simple names separated by periods (‘.’). A simple name can be up to eight bytes in length, starts with a character, and is made up of a combination of alphabetic characters, digits, or the following special characters: @, #, $, -

Properties:

Default: DBRMLIB

This is the equivalent of DBRMLIB=DBRMLIB.

Dependencies:

Requires that the TARGETDB SQL directive be set to TARGETDB=MSSQLSERVER.

Automatically sets the CHECK SQL directive.

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - HCOSS SQL Compiler Directive Options for more information.

Advantages:

  • Mainframe deployment compatibility, meaning you can bind using existing JCL.
  • You can bind a DBRM multiple times using different parameters each time, such as different default qualifiers.
  • You can apply security separately to procedures and data so that application users can only access and update data via the application.
  • You can use the Manage Packages and Plans tool to manage DBRM binding and freeing.
  • Enables HCOSS to maintain mainframe-compatible metadata in the database for bound packages and plans.
  • DBAs can review SQL after binding by browsing stored procedures without having to access source code.

Comments:

If required to fully emulate your mainframe setup, you can also specify the MEMBER and VERSION directives.

Before running your application, use the DSN command or the Manage Packages and Plans tool to bind DBRMs to packages and/or plans in the database.

Packages and plans are stored as SQL Server stored procedures.

When DBRMLIB is set, the precompiler and runtime system process the following statements:
SET CURRENT PACKAGESET
SET CURRENT PACKAGE PATH
SET APPLICATION PLAN

DBRMs are stored as XML files with an extension of .hcodbrm in the localHCOSSFiles\DBRMDataSets\DBRMLIBName directory, where localHCOSSFiles represents the value of the Local HCOSS Directory HCOSS option, and DBRMLIBName represents the value of the DBRMLIB directive.

DBRMLIB supports the following SET statements, with the runtime system processing them internally:
SET CURRENT PACKAGESET
VALUES INTO CURRENT PACKAGESET
SET CURRENT PACKAGE PATH
VALUES INTO CURRENT PACKAGE PATH

DBRMLIB enables use of the APPLICATION PLAN special register, that can be used in SET host-variableAssignment and VALUES INTO statements, and also supports the SET APPLICATION PLAN statement, which allows an application to set the application plan to be used when static SQL statements in DBRMs generated by the DBRMLIB directive are executed.

Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Building Applications
Managing DBRMs
Shared DBRMs and Multi-User Environments
Local DBRMs
Scope - HCOSS SQL Compiler Directive Options
SQL Code Generation Options
Related reference
ACCESS
BIND
MEMBER
VERSION
DIALECT
QUALIFIER


DIALECT

Syntax:

DIALECT={MAINFRAME | MIXED | NONE} [overrides]

Parameters:

MAINFRAME
  • All statements that are compatible with DB2 are converted by HCOSS
  • Unqualified table and view specifications in DB2-compatible statements can be qualified by the SQL(QUALIFIER) directive option or the QUALIFIER parameter on BIND PACKAGE and BIND PLAN commands
  • Supports the [NOPLAN], [NODIALECT] and [MAINFRAME] statement prefixes
  • When used with the [NODIALECT] statement prefix, conversion and qualification are disabled
MIXED
  • Performs no DB2 syntax conversion or table and view qualifications
  • Qualifications can be enabled for individual statements using the [MAINFRAME] statement prefix
NONE
  • Equivalent to not specifying DIALECT
  • Performs no DB2 syntax conversions or table and view qualifications
  • Supports only the [NOPLAN] statement prefix
overrides
SQL compiler directives, set to values other than their default values set by DIALECT, each separated by a space. The modified SQL compiler directives specified override the directives set as defaults by DIALECT.

Properties:

Default: DIALECT=MAINFRAME

Dependencies:

When set to MAINFRAME or OPENESQL, DIALECT sets the following regular SQL compiler directives:
  • CHECK
  • CHECKSINGLETON
  • CHECKUPDCURSOR
  • DETECTDATE
  • MARS
And the following HCOSS SQL compiler directives:
  • DATE=ISO
  • TIME=ISO
And also sets the OpenESQL precompiler to skip over the following EXEC SQL statements, generating a compile-time warning for each instead:
  • SET CURRENT APPLICATION ENCODING SCHEME
  • SET CURRENT DEGREE
  • SET CURRENT [LOCALE] LC_CTYPE
  • SET CURRENT MAINTAINED TABLE TYPES FOR OPTIMIZATION
  • SET CURRENT OPTIMIZATION HINT
  • SET CURRENT PRECISION
  • SET CURRENT REFRESH AGE
  • SET CURRENT RULES
  • SET CURRENT ENCRYPTION PASSWORD

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - HCOSS SQL Compiler Directive Options for more information.

Advantages:

  • You do not need to convert DB2 statements to T-SQL.
  • You can change the default schema when a program is bound, or in some cases, change the default schema at compile time using the QUALIFIER SQL compiler directive option.

Comments:

Both DIALECT=MAINFRAME and DIALECT=MIXED accept both [NODIALECT] and [MAINFRAME] statement prefixes. Using these in the appropriate combinations enables you to effectively switch between the two DIALECT settings on the statement level in a single application. However, you must remove the [NODIALECT] and [MAINFRAME] prefixes from the code compiling with DIALECT=NONE.

You can override the CHECK directive by specifying NOCHECK, or by setting the DB directive to identify your database connection. If the connection you specify does not use Windows authentication, then you must also set the PASS directive specifying a valid user ID and password for the connection.

In the context of HCOSS, CHECK verifies the following:
  • HCOSS-converted SQL syntax, to determine if the converted syntax is compatible with SQL Server. This provides early detection of incompatibilities between DB2 and SQL Server that have not been resolved by HCOSS.
  • converted database object names (tables, views, columns and functions) are valid in SQL Server.

To fully enable compile-time checking of converted SQL statements using SQL Server, set the DB, PASS and QUALIFIER directives along with DIALECT=MAINFRAME or DIALECT=MIXED.

Example:

SQL(DIALECT=MAINFRAME NOCHECK NODETECTDATE)
Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Building Applications
DB2 to SQL Server Conversion
HCOSS Conversion Rules
DIALECT Statement Prefixes
Application Progression from DB2 to SQL Server
Scope - HCOSS SQL Compiler Directive Options
SQL Code Generation Options
Related reference
Default Data Type Mappings
Default SQLCODE Mappings
Default SQL Name Mappings
TIMEDELIM
TSTAMPSEP
ACCESS
BIND
DBRMLIB
QUALIFIER
HCO for SQL Server Compiler Directive Options for PL/I


MEMBER

Syntax, Format 1:

MEMBER=mem-name

Syntax, Format 2:

NOMEMBER

Parameters:

mem-name
The name of a DBRM. A DBRM name can be up to eight bytes in length, starts with a character, and is made up of a combination of alphabetic characters, digits, or the following special characters: @, #, $, -

Properties:

Default: MEMBER=prog-name

Where prog-name is the COBOL program name.

Dependencies:

Requires that the DBRMLIB HCOSS directive also be set.

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - HCOSS SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Building Applications
Scope - HCOSS SQL Compiler Directive Options
Related reference
DBRMLIB
VERSION


PROMOTE

Syntax

[NO]PROMOTE

Properties:

Default: NOPROMOTE

Dependencies:

Requires that the DBRMLIB HCOSS directive also be set.

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - HCOSS SQL Compiler Directive Options for more information.

Comments:

When set to NOPROMOTE (default), DBRMs are saved under the DBRMLIB subdirectory to the path specified in the Local HCOSS Directory HCOSS option.

When set to PROMOTE:
  • DBRMs are saved under the DBRMLIB subdirectory to the path specified in the Shared HCOSS Directory HCOSS option
  • If a DBRM with the same name as a newly generated DBRM exists in the local HCOSS directories, the local DBRM is deleted automatically
Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Managing DBRMs
Shared DBRMs and Multi-User Environments
Local DBRMs
Scope - HCOSS SQL Compiler Directive Options


QUALIFIER

Syntax:

QUALIFIER=schema-name

Parameters:

schema-name
The name of the schema used to qualify unqualified table or view references in embedded SQL.

Dependencies:

Requires one of the following:
  • The ACCESS and/or BIND HCOSS directives are set
  • The DBRMLIB directive option is set, and the DIALECT directive option is set to MAINFRAME
  • To be valid on the statement level, all three of the following are required:
    • The DBRMLIB directive option is set
    • The DIALECT directive option is set to MIXED
    • Each targeted statement includes the [MAINFRAME] statement prefix

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - HCOSS SQL Compiler Directive Options for more information.

Comments:

When ACCESS and/or BIND is specified but DIALECT is either not specified or it is specified with a NOCHECK override, HCOSS qualifies table and view references in generated stored procedures using the value of the QUALIFIER directive.

When ACCESS and/or BIND is specified and DIALECT is specified with no override for CHECK, HCOSS qualifies table and view references in generated stored procedures using the value of the QUALIFIER directive before being sent to the SQL Server for the compile-time check.

When DBRMLIB is specified and DIALECT is either not also specified or it is specified with a NOCHECK override, HCOSS does not qualify table or view references.

When DBRMLIB is specified and DIALECT is also specified with no override for CHECK, HCOSS qualifies table and view references in generated stored procedures using the value of the QUALIFIER directive before being sent to the SQL Server for the compile-time check. In the generated DBRMLIB, unqualified table and view references are left unqualified. You can qualify them by specifying a qualifier when executing BIND PACKAGE or BIND PLAN commands.

Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Building Applications
DIALECT Statement Prefixes
Application Progression from DB2 to SQL Server
Scope - HCOSS SQL Compiler Directive Options
Related reference
ACCESS
BIND
DBRMLIB
DIALECT
HCO for SQL Server Compiler Directive Options for PL/I


VERSION

Syntax:

VERSION=version

Parameters:

version
The version of the DBRM. This can be up to 64 bytes in length and must consist of a letter followed by a sequence of zero or more letters, digits, or underscore characters.

Dependencies:

Requires that the DBRMLIB HCOSS directive also be set.

Scope:

Used at compile time: | Yes
Behavior at run time: | Source file

See Scope - HCOSS SQL Compiler Directive Options for more information.

Parent topic: SQL Compiler Directive Options - HCOSS
Related concepts
Building Applications
Scope - HCOSS SQL Compiler Directive Options
Related reference
MEMBER
DBRMLIB


Required DB2 Catalog Tables

The login credentials used to connect to the mainframe DB2 database must grant read access to the following DB2 system catalog tables:

Object Type | DB2 System Catalog Table
tables, columns | SYSTABLES, SYSCOLUMNS, SYSSEQUENCES
indexes | SYSINDEXES, SYSKEYS
constraints (relational, check, key) | SYSCHECKS, SYSCHECKDEP, SYSCHECKS2, SYSCONSTDEP, SYSTABCONST, SYSKEYCOLUSE, SYSRELS, SYSFOREIGNKEYS
views | SYSVIEWS, SYSVIEWDEPENDENCY
Parent topic: Reference
Related concepts
Extract Schema Tool
Related tasks
To create a DB2 connection
To extract DB2 schemas


DB2 to SQL Server Conversion Reference

  • Date and Time Data Types
    The default formats for DB2 and SQL Server date and time specifications.
  • Default Data Type Mappings
    The default mappings HCOSS uses to convert DB2 data types into SQL Server data types.
  • Default SQL Name Mappings
    The default mappings HCOSS uses to convert DB2 functions and special registers to SQL Server equivalents.
  • Default SQLCODE Mappings
    The default mappings HCOSS uses to convert DB2 SQLCODEs into SQL Server SQLCODEs.
  • DSNTIAR and DSNTIAC
    Converts SQL return codes to character-string messages.
Parent topic: Reference


Date and Time Data Types

These topics are included as a reference to assist you in determining conversion specifications for date and time data types going from DB2 to SQL Server.

  • Mainframe Date and Time Data Types
  • SQL Server Date and Time Data Types
Parent topic: DB2 to SQL Server Conversion Reference
Related concepts
DB2 to SQL Server Conversion
HCOSS Conversion Rules


Mainframe Date and Time Data Types

The mainframe date and time data types are date, time and timestamp. Date has a range from 0001-01-01 to 9999-12-31. Time has a range from 00:00:00 to 23:59:59. The special value 24:00:00 is equivalent to 24:00:00. The range of datetime is 1-1-1 00:00:00.000000 to 9999-12-31 23:59:59.999999.

Character string representation of date values

Format Name | Abbreviation | Date Format | Example
International Standards Organization | ISO | yyyy-mm-dd | 1987-10-12
IBM USA Standard | USA | mm/dd/yyyy | 10/12/1987
IBM European Standard | EUR | dd.mm.yyyy | 12.10.1987
Japanese industrial standard Christian era | JES | yyyy-mm-dd | 1987-10-12
Installation-defined | LOCAL |  |

Character string representation of TIME values

Format Name | Abbreviation | Date Format | Example
International Standards Organization | ISO | hh.mm.ss | 13.30.05
IBM USA Standard | USA | hh:mm AM or PM | 1:30 PM
IBM European Standard | EUR | hh.mm.ss | 13.30.05
Japanese industrial standard Christian era | JES | hh:mm:ss | 13:30:05
Installation-defined | LOCAL |  |

Character string representation of timestamp values

The default format is yyyy-mm-dd-hh-hh.mm.ss.nnnnnn.

The ODBC format is also accepted; this is yyyy-mm-dd hh:mm:ss.nnnnnn.

Parent topic: Date and Time Data Types


SQL Server Date and Time Data Types

SQL Server legacy data types are:
  • datetime
  • smalldatetime
However, these are not recommended for mainframe application migration. To facilitate migration, SQL Server 2008 added these data types:
Data Type | Range | Fractional Second Digits
date | 0001-01-01 to 9999-12-31 |
time | 00:00:00.0000000 to 23:59:59.9999999 | 0 to 7
datetime2 | 0001-01-01 00:00:00.0000000 to 9999-12-31 23:59:59.9999999 | 0 to 7
datetimeoffset |  |

SQL Server provides considerable flexibility in reading date and time data as character strings, only a subset that is most directly relevant for migrations is presented here.

Default output format

SQL Server outputs date, time and datetime values in the following formats: yyyy-mm-dd, hh:m:ss.nnnnnnn (n is dependent on the column definition) and yyyy-mm-dd hh:mm:ss.nnnnnnn (n is dependent on the column definition).

Character string representation of date values

Format Type | Date Format | Example
ANSI/ISO | yyyy-mm-dd | 1987-10-12
Alphabetic | The month is specified as a three character abbreviation or the full month name. | Apr 15 1996 15 Apr 1996 1996 Apr 15
Numeric | The month is specified as a number and the separator can be slash, hyphen or period. The order of day, month year parts can be changed by a TSQL SET DATEFORMAT or SET LANGUAGE statements. The initial order is determined from the default language for the login. The default format for us_english is mdy. The settings are stored in the table sys.syslanguages. | 15/04/1996 04.15.1996 1996-4-15

Character string representation of time values

SQL Server accepts time values in the following formats: 14:30, 14:30:20, 14:30:20:145943, 2 PM, 2:30 PM, 2:30:20 PM 2:30:20.145943 PM.

Character string representation of datetime values

SQL Server accepts datetime values in ISO 8601 and ANSI formats, which are: yyyy-mm-ddThh:mm:ss.nnnnnn and yyyy-mm-dd hh:mm:ss.nnnnnn, respectively.

Parent topic: Date and Time Data Types


Default Data Type Mappings

DB2 Data Type | Encoding | Data Storage | SQL Server Data Type
BIGINT | All | None | BIGINT
BINARY | All | None | BINARY
BLOB | All | None | VARBINARY(MAX)
CHAR | All | For bit data | BINARY
CHAR | ASCII and EBCDIC | None | CHAR
CHAR | UNICODE | None | NCHAR
CLOB | ASCII | None | NVARCHAR(MAX)
CLOB | ASCII | For bit data | NVARCHAR(MAX)
CLOB | EBCDIC | For bit data | NVARCHAR(MAX)
CLOB | UNICODE | None | NVARCHAR(MAX)
CLOB | UNICODE | For bit data | NVARCHAR(MAX)
CLOB | EBCDIC | None | NVARCHAR(MAX)
DATALINK | All | None | VARCHAR(2083)
DATE | All | None | DATE
DBCLOB | All | None | NVARCHAR(MAX)
DECFLOAT | All | None | FLOAT(53)
DECIMAL | All | None | DECIMAL
DOUBLE | All | None | DOUBLE PRECISION
FLOAT | All | None | FLOAT
GRAPHIC | All | None | NCHAR
INT | All | None | INT
INTEGER | All | None | INTEGER
LONG VARCHAR | All | For bit data | VARCHAR(MAX)
LONG VARCHAR | All | None | VARCHAR(MAX)
LONG VARGRAPHIC | All | None | NVARCHAR(MAX)
LONGVARBIN | All | None | VARBINARY(MAX)
NUMERIC | All | None | NUMERIC
REAL | All | None | REAL
ROWID | All | None | BINARY(40)
SMALLINT | All | None | SMALLINT
TIME | All | None | TIME(0)
TIMESTMP | All | None | DATETIME2(6)
VARBIN | All | None | VARBINARY
VARCHAR | All | For bit data | BINARY
VARCHAR | All | None | VARCHAR
VARGRAPHIC | All | None | NVARCHAR
XML | All | None | XML
Parent topic: DB2 to SQL Server Conversion Reference
Related concepts
DB2 to SQL Server Conversion
HCOSS Conversion Rules
Related tasks
To customize data type mappings
Related reference
Customizing Data Type Mappings
DIALECT


Default SQL Name Mappings

DB2 Function/Special Register | SQL Server Equivalent | Is Function | Is Special Register
VARIANCE | VAR | Yes |
IFNULL | COALESCE | Yes |
VALUE | COALESCE | Yes |
ASCII_CHR | CHAR | Yes |
LCASE | LOWER | Yes |
REPEAT | REPLICATE | Yes |
SUBSTR | SUBSTRING |  |
UCASE | UPPER | Yes |
LN | LOG | Yes |
CURRENT CLIENT_APPLNAME | APP_NAME() |  | Yes
CURRENT CLIENT_USERID | SYSTEM_USER |  | Yes
CURRENT CLIENT_WRKSTNNAME | HOST_NAME() |  | Yes
CURRENT DATE | CONVERT(date,SYSDATETIME()) |  | Yes
CURRENT TIME | CONVERT(time(0), SYSDATETIME()) |  | Yes
CURRENT TIMESTAMP | CONVERT(datetime2(6), SYSDATETIME()) |  | Yes
CURRENT_DATE | CONVERT(date,SYSDATETIME()) |  |
CURRENT_TIME | CONVERT(time(0), SYSDATETIME()) |  |
CURRENT_TIMESTAMP | CONVERT(datetime2(6), SYSDATETIME()) |  |
CURRENT LC_CTYPE | CONVERT(char(50), SERVERPROPERTY('collation')) |  | Yes
CURRENT_LC_CTYPE | CONVERT(char(50), SERVERPROPERTY('collation')) |  |
CURRENT LOCALE LC_CTYPE | CONVERT(char(50), SERVERPROPERTY('collation')) |  | Yes
CURRENT SCHEMA | CONVERT(varchar(128), SCHEMA_NAME()) |  | Yes
CURRENT_SCHEMA | CONVERT(varchar(128), SCHEMA_NAME()) |  |
CURRENT SERVER | CONVERT(char(16), SERVERPROPERTY('servername')) |  | Yes
CURRENT SQLID | USER |  | Yes
SESSION_USER | USER |  |
TRAN | "TRAN" |  |
APPLICATION | "APPLICATION" |  |
ORDER | "ORDER" |  |
DIGITS | dbo.digits | Yes |
LENGTH | DATALENGTH | Yes |
LPAD | dbo.LPAD | Yes |
RPAD | dbo.RPAD | Yes |
Parent topic: DB2 to SQL Server Conversion Reference
Related concepts
Customizing Functions and Special Registers
DB2 to SQL Server Conversion
HCOSS Conversion Rules
Related tasks
To customize SQL name mappings
Related reference
DIALECT


Default SQLCODE Mappings

DB2 SQLCODE Value | SQL Server SQLCODE Value | SQLSTATE Value
-2601 | -803 | 23505
-19519 | -501 | 24501
-19516 | -502 | 24502
-2714 | -601 | 42710
-207 | -204 | 42704
-208 | -204 | 42704
Parent topic: DB2 to SQL Server Conversion Reference
Related concepts
DB2 to SQL Server Conversion
HCOSS Conversion Rules
Related reference
Customizing SQLCode Mappings
DIALECT


DSNTIAR and DSNTIAC

Syntax

CALL 'DSNTIAR' USING comm-area
                     error-message
                     error-rec-length

or, for CICS applications:

CALL 'DSNTIAC' USING comm-area
                     error-message
                     error-rec-length

Parameters

comm-area | The program's Commarea, usually SQLCA. At run time, the SQLCODE field in the SQLCA structure should contain the code from which DSNTIAR/DSNTIAC generates the character-string message.
error-message An array of records of size error-rec-length used to store error message output. The two components of the error-message array are:

error-length

Containing an integer greater than or equal to 240, indicating the length of the second element, error-text.

error-text

Containing the text of the message. Generally this message is defined as an array of strings, each having a length of error-rec-length, and occurring n times so that error-length is the larger of 240 and error-rec-length * n.

error-rec-length | An integer between 71 and 241, indicating the logical record length of output messages. If the error-message length exceeds the length defined for error-rec-length, the message is stored in several logical records.

Return Codes

The following table shows the return codes that result from calling the DSNTIAR or DSNTIAC utility.

Code | Description
0 | Successful execution.
4 | More data is available than can fit into the provided message area.
8 | The error record length is not within acceptable limits, i.e., 72 <= error-rec-length <= 240.
12 | The message area was not large enough. Message length was >= 240.
16 | Error in message routine.

Example

01 ERROR-MESSAGE.
     02 ERROR-LENGTH PIC S9(4) COMP VALUE +288.
     02 ERROR-TEXT PIC X(72) OCCURS 4 TIMES.
 77 ERROR-REC-LENGTH PIC S9(9) COMP VALUE +72.
    ...
     CALL 'DSNTIAR' USING SQLCA ERROR-MESSAGE ERROR-REC-LENGTH
Parent topic: DB2 to SQL Server Conversion Reference
Related concepts
Customizing Return Codes


Bind Script Commands

The following mainframe DSN commands are supported in bind script files and as input to JCL:
DSN Command | Supported Parameters
BIND PACKAGE | ACTION, MEMBER, LIBRARY, PKLIST, QUALIFIER, FLAG1
BIND PLAN | ACTION, MEMBER, LIBRARY, PKLIST, QUALIFIER, FLAG1
FREE PACKAGE | FLAG
FREE PLAN | FLAG
REBIND PACKAGE2 | QUALIFIER, FLAG, DYNAMICRULES1
REBIND PLAN 2 | PKLIST, QUALIFIER, FLAG, DYNAMICRULES 1
END

1 HCOSS ignores any other parameters present on the command line and issues a warning for each ignored parameter.

2 You can specify this in a bind script file you create manually; however, you cannot generate this command using the Manage Packages and Plans tool.

Note: For complete information on the use of these DSN commands including syntax, see the IBM DB2 documentation for DSN commands and subcommands available on the IBM Web site.
Parent topic: Reference
Related concepts
DSN Bind Utility
COBOL Properties
Binding Applications
JCL Applications - DBRM Specification
Related tasks
To bind from the command line
To bind as a post-build event
To manually code a bind script file
To bind from JCL
Related reference
BIND
DSN command


Messages

Lists the error messages and other non-error messages that are produced by HCOSS tools.

  • Compare Data Tool Error Messages
  • Define Lists Tool Error Messages
  • Extract Schema Tool Error Messages
  • Generate DDL Tool Error Messages
  • Manage Connections Tool Error Messages
  • Transfer Data Tool Error Messages
  • Build Error Messages
Parent topic: Reference


Compare Data Tool Error Messages

This topic describes the error messages that are related to the Compare Data tool.

Error Message | Description or Cause | Resolution
A shared task cannot have a local transfer list | A shared task must associate a shared transfer list. | Make sure the shared radio button is checked for the transfer list.
Build Query failed | Build customized query by OpenESQL failed. | Make sure the source database connection is still open.
Command file is invalid or was not found | The file does not exist in the specified folder; or the file contains syntax errors. | Make sure the file exists and has correct syntax in its content.
Compare list file is empty | Compare list file has no meaningful content. | Add the desired content to the file.
Connection failed | Connection to either source database or destination database failed. | Make sure the user ID and password are correct.
Data comparison terminated for this table, error count exceeds mismatch limit | Error count exceeds the mismatch limit. | Check the mismatch errors to figure out which table causes the failure.
Data comparison test FAILED! | Data comparison test failed due to unmatched rows or columns. | Make sure the data in both source table and destination table are of the same set.
Data for following column does not match | The values of data in the two databases do not match. | Check if the data tables contain the same set of data in terms of rows, columns and ordering
Error in writing to file | Error in writing a task to XML file. | Check task name or path for illegal characters.
Execution Error | Execution of compare data failed due to connection failure. | Check database connections.
File Access Violation | Either READ or WRITE permission is not granted to the user. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user file access.
Following required parameter is missing | A required command line parameter is missing. | Provide the required parameter.
Invalid command line parameter | The specified parameter value is empty or out of range. | Assign a proper value to the parameter.
Invalid command line syntax | Some parameter names are incorrect. | Use the correct parameter names.
Invalid Data Source Name | The name of the data source or data destination is empty. | Add the name of the data source or data destination to the command line argument.
Invalid number of arguments | The command line has no arguments. | Add the required arguments to the command line.
Invalid target object list | The XML target list file has syntax errors. | Check the target list file content or try regenerating the target list.
No task name is set | No task name is set on GUI. | Select the desired task name on GUI.
Number of result set columns do not match | The number of table columns in the destination database does not match the corresponding one in the source database. | Check the DDL generation script.
Number of result set rows do not match | The number of rows in the destination table does not match that in the source table. | Rerun the Transfer Data tool.
Query Failed = … | Execution of the query failed. | Check query syntax, database connection, and database access permission.
The destination DSN is not found | The destination DSN is not set or it is not defined. | Specify an existing connection or create one if the connection you want to use does not exist.
The process does not have the READ permission to the file | The process does not have READ permission to the specific file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user READ permission.
The process does not have the WRITE permission to the file | The process does not have WRITE permission to the specific file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user WRITE permission.
The source DSN is not found | The source DSN is not set, or it is not defined. | Set the source DSN or create one if it does not exist.
The transfer list is not found in the directory | The transfer task file does not exist in the specified path. | Make sure the specified file exists in the path; or the file name is correct.
Unable to read list file | The transfer list file is corrupted. | Check the file content for syntax errors.
Parent topic: Messages
Related concepts
Compare Data Tool
Related tasks
To compare transferred data
To run customized data comparisons
Related reference
MFTestConversion command
Compare Data Tool Log Files


Define Lists Tool Error Messages

This topic describes the error messages that are related to the Define Lists tool.

Error Message | Description or Cause | Resolution
An unexpected error has occurred. Please report the following error to Micro Focus Support: | A generic error flag followed by a specific message. | See the following specific message for information.
Invalid XML schema input file | Errors in XML schema of the schema extract file. | Check the schema extract file (.hcodbs).
No schema files found. You must have at least one schema file to create object lists | No schema files in the specified directory. | Create schema files in the directory.
The process does not have the READ permission to the file | The process does not have READ permission to the specific file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user READ permission on the file.
The process does not have the WRITE permission to the file | The process does not have WRITE permission to the specific file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user WRITE permission on the file.
Unable to delete list file: | Unable to delete the specified list file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user DELETE permission on the file.
Unable to read list file: | Unable to read the specified list file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user READ permission on the file.
Unable to write list file: | Unable to write the specified list file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user WRITE permission on the file.
Parent topic: Messages
Related concepts
Define Lists Tool
Related tasks
To define an object transfer list
Related reference
MFObjectList command
Define Lists Tool Log Files


Extract Schema Tool Error Messages

This topic describes the error messages that are specific to the Extract Schema tool.

Error Message | Description or Cause | Resolution
Connection no longer open - processing terminated. Please re-select Schemas and try again | Connection time out. | Re-select the schemas (as to reconnect).
Could not open database connection | Either the database is not available or the connection parameters have errors. | Check the database availability, permission, network connectivity, and parameters in the connection string.
Error inserting in SysConsDep | Error in accessing table SYSIBM. SysConsDep in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysChkConstraints | Error in accessing table SYSIBM.SYSCHECKS in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysChkDepConstraints | Error in accessing table SYSIBM.SYSCHECKDEP in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysColumns | Error in accessing table SYSIBM. SysColumns in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysKeyColConstraints | Error in accessing table SYSIBM.SYSKEYCOLUSE in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysIndexes | Error in accessing table SYSIBM. SysIndexes in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysIndexCols | Error in accessing table SYSIBM.SYSKEYS in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysRelConstraints | Error in accessing table SYSIBM.SYSRELS in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysRelFkConstraints | Error in accessing table SYSIBM.SYSFOREIGNKEYS in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysTables | Error in accessing table SYSIBM. SysTables in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysTblConstraints | Error in accessing table SYSIBM.SYSTABCONST in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysViews | Error in accessing table SYSIBM. SysViews in DB2. | See the IBM SQL Message reference for the SQL error reported.
Error inserting in SysViewDep | Error in accessing table SYSIBM. SysViewDep in DB2. | See the IBM SQL Message reference for the SQL error reported.
Invalid command line parameter | The specified parameter value is empty or out of range. | Assign a proper value to the required parameter.
Invalid Data Source Name | The name of the data source or data destination is empty. | Add the name of the data source or data destination to the command line argument.
Parent topic: Messages
Related concepts
Extract Schema Tool
Related tasks
To extract DB2 schemas
Related reference
MFExtractSchemaInfo command
Extract Schema Tool Log Files


Generate DDL Tool Error Messages

This topic describes the error messages that are related to the Generate DDL tool.

Error Message | Description or Cause | Resolution
An unexpected error has occurred. Please report the following error to Micro Focus Support: | A generic error flag followed by a specific message. | See the following specific message for information.
Commit exception type: | Error in commit of DDL generation. | See the following message for details.
Connection failed | The target database connection failed. | Make sure the user ID and password correct.
Encountered problem reading source database schema | Error in reading the schema file. | See the preceding message for details.
Encountered problem during file/path checks | Error in the specified file name or path. | Check the specified file name and path.
Encountered problem reading XML mappings | Error in reading the mapping file. | Check the specified file name and path.
Encountered problem writing DDL command file | Error in writing the DDL file. | Check the file folder existence and WRITE permission.
Following required parameter is missing | A required parameter is not provided | Provide the specified parameter value
Invalid command line parameter | The specified parameter value is empty or out of range. | Assign a proper value to the parameter.
Invalid number of arguments | The command line has no arguments. | Add the required arguments to the command line.
Invalid DDL output directory | Error in creating the DDL file directory. | Check the file directory existence and WRITE permission.
Invalid XML mapping input file | Error in reading the DDL file. | Check the file existence and READ permission.
Invalid XML schema input file | Error in reading the schema file. | Check the file existence and READ permission.
No list files found. You must have at least one list file to create scripts. | The original list file has been deleted or renamed. | Recreate the list file or delete the current task.
Rollback exception type: | Error in rollback of DDL generation. | See the message for details.
The process does not have the READ permission to the file | The process does not have READ permission to the specific file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user READ permission.
The process does not have the WRITE permission to the file | The process does not have WRITE permission to the specific file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user WRITE permission.
Unable to create DDL output file | Error in creating the DDL file. | Check the file directory existence and WRITE permission.
Unable to create export file: | Unable to create the specified export file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user WRITE permission on the directory.
Unable to delete export file: | Unable to delete the specified export file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user DELETE permission on the file.
Unable to delete task file: | Error in deleting the task file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user DELETE permission.
Unable to read list file: | Unable to read the specified list file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user READ permission on the file.
Unable to read script file: | Unable to read the specified script file. | Check the file existence. Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user READ permission on the file.
Unable to return to previous task file | Unable to set the previous task. The previous file is either missing or renamed. | Recreate the task file.
Unable to write list file: | Unable to write the specified script file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user WRITE permission on the directory.
Parent topic: Messages
Related concepts
Generate DDL Tool
Related tasks
To generate and execute DDL
To customize generated DDL
To customize schema mappings in DDL
Related reference
MFDDLConverter command
Generate DDL Tool Log Files


Manage Connections Tool Error Messages

This topic describes error messages that are specific to the Manage Connections tool.

Error Message | Description or Cause | Resolution
32-bit ADO.NET connection failed | The specified 32-bit ADO.NET connection failed. | Check the connection parameters.
32-bit ODBC connection failed | The specified 32-bit ODBC connection failed. | Check the connection parameters.
64-bit ADO.NET connection failed | The specified 64-bit ADO.NET connection failed. | Check the connection parameters.
64-bit ODBC connection failed | The specified 64-bit ODBC connection failed. | Check the connection parameters.
(A connection) already exists and will not be imported | A warning message. | It can be ignored.
(A connection) cannot be imported. | An existing connection cannot be imported due to unsupported provider type. | Redefine the connection using a supported provider type.
An existing connection was found and no action was taken. If you wish to add or update an existing connection, please specify the FORCE=TRUE parameter. | An existing connection cannot be overwritten. | The user may choose to set the parameter FORCE=TRUE to overwrite, or do nothing.
An unexpected error has occurred. Please report the following error to Micro Focus Support: |  |
Following required parameter is missing | A required parameter is not provided. | Provide the specified parameter value.
Invalid command line parameter | The specified parameter value is empty or out of range. | Assign a proper value to the required parameter.
Invalid connection mode | The connection mode parameter “MODE” has no value. | Assign a value to the parameter.
Invalid connection name | The connection name parameter “DSN” has no value. | Assign a value to the parameter.
Invalid connection provider | The connection provider parameter “PROVIDER” has no value. | Assign a value to the parameter.
Invalid connection provider type | The connection provider type parameter “PTYPE” has no value. | Assign a value to the parameter.
Invalid connection save ADO.NET password flag | The connection save ADO.NET password flag parameter “ADOSAVEP” has no value. | Assign a value to the parameter.
Invalid connection server type | The connection server type parameter “STYPE” has no value. | Assign a value to the parameter.
Invalid connection type | The connection type parameter “CTYPE” has no value. | Assign a value to the parameter.
Invalid number of arguments | The command line has no arguments. | Add the required arguments to the command line.
The connection name specified already exists. Please provide a unique connection name. | The new connection name conflicts with an existing one. | Use a different name for the new connection.
The process does not have the WRITE permission to the file | The process does not have WRITE permission to the specific file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user WRITE permission.
Unable to list SQL Server instances | Unable to list SQL Server instances in the local area network. | Check the network connectivity.
Unable to write DSN tracking file | XML schema error. | Contact Micro Focus support.
Validation of command line parameters failed | Some of the command line parameters have syntax errors. | Correct the syntax errors by following the sample format provided in the command line usage documentation topic.
Parent topic: Messages
Related concepts
Manage Connections Tool
Connection Types
Related tasks
To create a DB2 connection
To create a system or user SQL Server connection
To import a connection
To export a connection
To repair a connection
Related reference
Manage Connections Tool Log Files


Transfer Data Tool Error Messages

This topic describes the error messages that are related to the Transfer Data tool.

Error Message | Description or Cause | Resolution
A shared task cannot have a local transfer list | A shared task must associate a shared transfer list. | Make sure the shared radio button is checked for the transfer list.
A wrong row is selected | A wrong row is selected when updating the customization. | Make sure the last changed row is selected/highlighted.
Connection failed | Source or destination connection failed. | Make sure the user ID and password correct.
Deletion result: Failure | The user does not have the permission of DELETE for the table or database. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user permission of DELETE.
(DSN’s provider) is not an OLE DB Provider | The underlying database provider is not of OLE DB type. | Recreate the DSN using the recommended Microsoft OLE DB provider.
Error in writing to file | Error in writing a task to XML file. | Check the task name and path for illegal characters.
File Access Violation | Either READ or WRITE permission is not granted to the user. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user file access.
Invalid command line parameter | The specified parameter value is empty or out of range. | Assign a proper value to the parameter.
Invalid Data Source Name | The name of the data source or data destination is empty. | Add the name of the data source or data destination to the command line argument.
Invalid number of arguments | The command line has no arguments. | Add the required arguments to the command line.
Invalid target object list | Syntax error. There is no “=” operator. | Add an “=” operator.
No query is selected for customization | An action button is clicked before a row of query is selected for customization. | Make sure the row is highlighted first.
No task name is set | No task name is set on GUI. | Select the desired task name on GUI.
SSIS package execution result: Failure | Data in the source database is not accessible. Data type mapping is incompatible. | Make sure the data accessible for SELECT statement. Check the version of SQL Server Native Client provider. It should be 10.x or above.
SSIS package validation result: Failure | Either the source or destination connection fails. | Check the connection(s).
Target table does not exist | The target table in the destination database has not been created. | Create the table in the destination database.
The destination DSN is not found | The destination DSN is not set or it is not defined. | Specify an existing connection or create one if the connection you want to use does not exist.
The process does not have the READ permission to the file | The process does not have READ permission to the specific file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user READ permission.
The process does not have the WRITE permission to the file | The process does not have WRITE permission to the specific file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user WRITE permission.
The source DSN is not found | The source DSN is not set, or it is not defined. | Set the source DSN or create one if it does not exist.
The transfer list is not found in the directory | The transfer task file does not exist in the specified path. | Make sure the specified file exists in the path; and the file name is correct.
There is no object list file in the location | No transfer list files in the specified “local” or “shared” folder. | Run through Define List tool again.
There is no table in the Data Transfer list | The data transfer task file contains no tables. | Add the desired tables to the task file.
Unable to read list file | Unable to read the transfer list file. | Depending on the security policy of the organization, the resolution can be either Run as Administrator or Grant the user READ permission on the file.
Validation of command line parameters failed | Some of the command line parameters have syntax errors. | Correct the syntax errors by following the required format.
Workflow Error | The workflow is not in correct order. | Make sure the workflow in correct order.
Parent topic: Messages
Related concepts
Transfer Data Tool
Related tasks
To transfer data
To customize a transfer data task
Related reference
MFDataTransferCtlr command
Transfer Data Tool Log Files


Build Error Messages

All build errors are a result of linking problems.
Error Message | Resolution
unresolved external symbol _MFHCOCD2@4 | In the Project Properties for your Visual Studio project, on the COBOL tab, click Link Settings and add the appropriate MFDSNTIAR.LIB file. This file resides in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\lib or %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\lib\WIN64 directory, depending on whether you are building a 32-bit or 64-bit application.
unresolved external symbol _mfsqlsmf@20 | In the Project Properties for your Visual Studio project, on the COBOL tab, click Link Settings and add the appropriate MFSQLSMF.LIB file. This file resides in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\lib or %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\lib\WIN64 directory, depending on whether you are building a 32-bit or 64-bit application. If the application does not run under Enterprise Server, you can compile the program with SQL(NOSMFTRACE) directive.
Parent topic: Messages
Related concepts
Building Applications


Log Files

  • Manage Connections Tool Log Files
  • Extract Schema Tool Log Files
  • Define Lists Tool Log Files
  • Generate DDL Tool Log Files
  • Transfer Data Tool Log Files
  • Compare Data Tool Log Files
  • Manage Packages and Plans Tool Log Files
Parent topic: Reference


Manage Connections Tool Log Files

Log File Generation

The Manage Connections Tool creates one log file per GUI session.

File Location

logFileDir\Connections

where logFileDir is the value of the Directory to write log files to HCOSS option.

File Name

CONMAN-year-month-day-generatedTimestamp.log

where generatedTimestamp is a six- to eight-digit string representing the timestamp.

File Contents

  • Parameter validation
  • Connection checking
  • Add actions
  • Update actions
  • Delete actions
Parent topic: Log Files
Related concepts
Manage Connections Tool
Connection Types
Related tasks
To create a DB2 connection
To create a system or user SQL Server connection
To import a connection
To export a connection
To repair a connection
Related reference
Manage Connections Tool Error Messages


Extract Schema Tool Log Files

Log File Generation

GUI Tool

The GUI version of the Extract Schema tool generates one log file per GUI session when you have set the Type of logging to do HCOSS option to either Write log messages just to file or Write log messages to both console and file.

MFExtractSchemaInfo Command

When running the Schema Extract tool from the command line, HCOSS generates a log file when you have set the TYPELOG directive to either FILE or BOTH, and when TYPELOG is not specified, defaults to the value of the Type of logging to do HCOSS option.

File Location

logFileDir\Schemas

where logFileDir is the value of the Directory to write log files to HCOSS option.

File Name

SCHEMCAP-year-month-day-generatedTimestamp.log

where generatedTimestamp is a six- to eight-digit string representing the timestamp.

File Contents

  • Processing information
  • Warning messages
  • Error messages
Parent topic: Log Files
Related concepts
Extract Schema Tool
Related tasks
To extract DB2 schemas
Related reference
MFExtractSchemaInfo command
Extract Schema Tool Error Messages


Define Lists Tool Log Files

Log File Generation

GUI Tool

The GUI version of the Define Lists tool generates one log file per GUI session when you have set the Type of logging to do HCOSS option to either Write log messages just to file or Write log messages to both console and file.

MFObjectList Command

When running the Define Lists tool from the command line, HCOSS generates log files when you have set the TYPELOG directive to either FILE or BOTH, and when TYPELOG is not specified, defaults to the value of the Type of logging to do HCOSS option.

File Location

logFileDir\TargetLists

where logFileDir is the value of the Directory to write log files to HCOSS option.

File Name

TLMAN-year-month-day-generatedTimestamp.log

where generatedTimestamp is a six- to eight-digit string representing the timestamp.

File Contents

  • Processing information
  • Warning messages
  • Error messages
Parent topic: Log Files
Related concepts
Define Lists Tool
Related tasks
To define an object transfer list
Related reference
MFObjectList command
Define Lists Tool Error Messages


Generate DDL Tool Log Files

Log File Generation

GUI Tool

The GUI version of the Generate DDL tool generates one log file per GUI session when you have set the Type of logging to do HCOSS option to either Write log messages just to file or Write log messages to both console and file.

MFDDLConverter Command

When running the Generate DDL tool from the command line, HCOSS generates log files when you have set the TYPELOG directive to either FILE or BOTH, and when TYPELOG is not specified, defaults to the value of the Type of logging to do HCOSS option.

File Location

logFileDir\DDLTasks

where logFileDir is the value of the Directory to write log files to HCOSS option.

File Name

GUI Tool

SCHEMMIG-year-month-day-generatedTimestamp.log

where generatedTimestamp is a six- to eight-digit string representing the timestamp.

File Contents

  • Parameter validation
  • Processing information
  • Object totals

    In some cases, when HCOSS encounters certain behavioral differences between DB2 and SQL Server, the total number of objects processed can exceed the original count of DB2 objects. For example, DB2 v7 and v8 support a primary key with no primary index. However, all primary keys in SQL Server, when defined, automatically create an associated index. In that case, you could have an extra index object in the SQL Server DDL. The opposite is true as well.

    Note: XML indexes are not currently supported by the DDL Converter tool. XML indexes existing in the DB2 database are not created in the DDL, nor are columns that are part of a index and are also mapped to the SQL Server XML data type. This is true even if the originating DB2 index and column are not of XML type.
  • Conversion information

    Where DB2 and SQL Server database formats have differences, HCOSS logs suggestions at each stage of operation as to possible workarounds.

Parent topic: Log Files
Related concepts
Generate DDL Tool
Related tasks
To generate and execute DDL
To customize generated DDL
To customize schema mappings in DDL
Related reference
MFDDLConverter command
Generate DDL Tool Error Messages


Transfer Data Tool Log Files

Log File Generation

GUI Tool

The GUI version of the Transfer Data tool generates one HCOSS log file per GUI session when you have set the Type of logging to do HCOSS option to either Write log messages just to file or Write log messages to both console and file. It also generates one SSIS log file for each table processed, regardless of the Type of logging to do setting.

MFDataTransferCtlr Command

When running the Transfer Data tool from the command line, HCOSS generates a transfer data log file when you have set the TYPELOG directive to either FILE or BOTH, and when TYPELOG is not specified, defaults to the value of the Type of logging to do HCOSS option. It also generates one SSIS log file for each table processed, regardless of the TYPELOG setting.

File Locations

Transfer Data Log Files

logFileDir\DataTasks

where logFileDir is the value of the Directory to write log files to HCOSS option.

SSIS Log Files

genHCOSSFiles\DataTasks

where genHCOSSFiles is the value of either the Local HCOSS Directory or Shared HCOSS Directory HCOSS option, depending on whether your data task is local or shared.

File Name

Transfer Data Log File

DATTRANS-year-month-day-generatedTimestamp.log

where generatedTimestamp is a six- to eight-digit string representing the timestamp.

SSIS Log Files

[SQLServerSchemaName]_[TableName]_RunTimeLog.log

File Contents

Transfer Data Log File

The HCOSS log file contains messages generated during package execution, including:
  • Package validation
  • Execution
  • Progress
  • Errors
  • Warnings
  • Diagnostics

SSIS Log File

The SSIS log file contains progress and error messages generated during the building of a package.

Parent topic: Log Files
Related concepts
Transfer Data Tool
Related tasks
To transfer data
To customize a transfer data task
Related reference
MFDataTransferCtlr command
Transfer Data Tool Error Messages


Compare Data Tool Log Files

Log File Generation

GUI Tool

The GUI version of the Compare Data tool generates one log file per GUI session when you have set the Type of logging to do HCOSS option to either Write log messages just to file or Write log messages to both console and file.

MFTestConversion Command

When running the Compare Data tool from the command line, HCOSS generates a log file when you have set the TYPELOG directive to either FILE or BOTH, and when TYPELOG is not specified, defaults to the value of the Type of logging to do HCOSS option.

File Location

logFileDir\CompareTasks

where logFileDir is the value of the Directory to write log files to HCOSS option.

File Name

DATACOMP-year-month-day-generatedTimestamp.log

where generatedTimestamp is a six- to eight-digit string representing the timestamp.

File Contents

  • Processing information
  • Warning messages
  • Error messages
Parent topic: Log Files
Related concepts
Compare Data Tool
Related tasks
To compare transferred data
To run customized data comparisons
Related reference
MFTestConversion command
Compare Data Tool Error Messages


Manage Packages and Plans Tool Log Files

Log File Generation

The Manage Packages and Plans tool generates one log file per GUI session when you have set the Type of logging to do HCOSS option to either Write log messages just to file or Write log messages to both console and file.

File Location

logFileDir\BindTasks

where logFileDir is the value of the Directory to write log files to HCOSS option.

File Name

BINDTASKS-year-month-day-generatedTimestamp.log

where generatedTimestamp is an eight-digit string representing the timestamp.

File Contents

  • Processing information
  • Warning messages
  • Error messages
Parent topic: Log Files


Manage Connections

  • Connection List tab
  • DB2 Connection tab
  • SQL Server Connection tab
  • Export tab
  • Import tab
  • Log Files tab
Parent topic: User Interface Reference


Connection List tab

Connection List
A list of all available connections.
Name
The data source name you specified for the connection when you created it.
Type
The type of database connection, SQL Server or DB2.
Status
The last known status of the connection:
Checking | HCOSS is checking the status of the connection
OK | Able to connect
Needs Repair | Unable to make the connection using the supplied information
Unknown | Shows for newly created or imported connections when your HCOSS Automatically Test Connections option is set to False, and before you Refresh the connection for the first time
New DB2 Connection
Switch to the DB2 Connection tab to create a new DB2 connection.
New SQL Server Connection
Switch to the SQL Server Connection tab to create a new SQL Server connection.
Edit
Switch to the SQL Server Connection or DB2 Connection tab, depending on the selected connection, where you can make changes to your connection specifications.
Remove
Remove the selected connection.
Repair
Repair a connection that reports Needs Repair in the Status column on the Connection List.
Refresh
Update information in the Status column for the selected connection.
Refresh All
Update the information in the Status column for all connections.
System
Create a system connection, and show only system connections on the Connections List grid.
User
Create a user connection, and show only user connections on the Connections List grid.
Encrypt ADO Connection Settings
Write ADO.NET connection specifications to appropriate .config files in encrypted format.
Enable Checking for New ODBC Drivers
When editing and repairing connections, HCOSS checks the current ODBC driver version and prompts you to upgrade if a more recent version is installed and available. Applies to System and User connection types only.
Parent topic: Manage Connections
Related concepts
Manage Connections Tool
Related tasks
To create a DB2 connection
To create a system or user SQL Server connection
To associate a CICS.NET region with a connection
To define an SQL user exit for a CICS.NET region


DB2 Connection tab

Data Source Name
Type a name for this connection.
User ID
Type the user ID you want to use for your DB2 database login.
Password
Type the password you want to use for your DB2 database login.
Allow Saving ADO.NET Connection Password
Set HCOSS to remember your ADO.NET password. When unchecked, the system prompts you for a password each time you connect from other HCOSS tools.
Network Address
The IP address used on your network to connect to your mainframe DB2 database.
Network Port
The port number used to access your mainframe DB2 database.
Initial Catalog
The name of the catalog used by your DB2 database.
Package Collection
The name of the package collection your DB2 database connection uses to talk to mainframe DB2.
Test
Verify that the information you have specified on this tab is sufficient to create a working DB2 database connection.
Save
Create a DB2 ADO.NET connection based on the information you have specified on this tab.
Parent topic: Manage Connections
Related concepts
Manage Connections Tool
Related tasks
To create a DB2 connection


SQL Server Connection tab

ODBC Driver
Shows the name and version of the ODBC driver in use for the current connection. Visible for System and User connection types only.
Data Source Name
Type a name for this connection.
Integrated Windows Authentication
Automatically send your Windows user ID and password as login credentials for this connection.
Use SQL Server Login
Send the User ID and Password supplied in the corresponding fields as login credentials for this connection.
User ID
Type the user ID you want to use for your SQL Server login. This is required only when you have selected Use SQL Server Login.
Password
Type the password you want to use for your SQL Server login. This is required only when you have selected Use SQL Server Login.
Allow Saving ADO.NET Connection Password
Set HCOSS to remember your ADO.NET password. When unchecked, the system prompts you for a password each time you connect from other HCOSS tools. This check box applies only when you have selected Use SQL Server Login.
SQL Server Instance
Select a SQL Server instance from the drop-down list, or type the name of a SQL Server instance. Use . or (local) to specify your local machine.
Refresh
Refresh the list of available SQL Server instances.
Confirm Server
When you specify a SQL Server instance by typing into the SQL Server Instance field rather than selecting from the drop-down list, click this to confirm the specified instance and test its validity.
Use a database other than the default database: dbname
Activates the Database drop-down list, enabling you to specify an alternative database for this connection.
Database
Select a database from the drop-down list, which includes all SQL Server databases available for the login credentials you specified for this connection.
Test
Verify that the information you have specified on this tab is sufficient to create a working SQL Server connection.
Save
Create an ODBC and an ADO.NET SQL Server connection, each based on the information you have specified on this tab.
Parent topic: Manage Connections
Related concepts
Manage Connections Tool
Related tasks
To create a system or user SQL Server connection
To associate a CICS.NET region with a connection
To define an SQL user exit for a CICS.NET region


Export tab

Select All
Select all entries listed on the connections grid.
Unselect All
Unselect all entries listed on the connections grid.
Name
The data source name you specified for the connection when you created it.
Type
The type of database connection, SQL Server or DB2.
Status
The last known status of the connection:
OK | The connection is established and working properly
Needs Repair | The connection is established but is not working properly
Unknown | Shows for newly created or imported connections when your HCOSS Automatically Test Connections option is set to False, and before you Refresh the connection for the first time
Export to file
The full path to and filename of an XML (.xml) file to which you want to save your connection information.
Export
Export the selected connections.
Parent topic: Manage Connections
Related concepts
Manage Connections Tool
Related tasks
To export a connection


Import tab

Import from file
The full path to and filename of an XML (.xml) file you want to import.
Read Available Connections
Loads all connections defined in the imported XML file into the connections grid.
Select All
Select all entries listed on the connections grid.
Unselect All
Unselect all entries listed on the connections grid.
Name
The name of the connection as specified by the <name> element in the imported XML file.
Connection String
The connection string required to create the connection, as specified in the <ConnectString> element of the imported XML file.
Import
Import the selected connections.
Progress
Shows the progress of the import process.
Parent topic: Manage Connections
Related concepts
Manage Connections Tool
Related tasks
To import a connection


Log Files tab

Log file path
Shows the full path to the folder containing your log files.
Log files
This grid lists each log file residing in the Log file path, in reverse chronological order.
Delete Selected
Delete the log files selected on the list.
Delete All
Delete all log files on the list.
Filter by
Select a filter to dictate the contents shown in the Log file contents window.
Log file contents
Shows the contents of the selected log file based on the selected filter.
Parent topic: Manage Connections
Parent topic: Extract Schema
Parent topic: Define Lists
Parent topic: Generate DDL
Parent topic: Transfer Data
Parent topic: Compare Data
Parent topic: Manage Packages and Plans
Related concepts
Managing Log Files


Extract Schema

  • Schema Extract tab
  • Results tab
  • Log Files tab
Parent topic: User Interface Reference


Schema Extract tab

Source Connection
The name of a DB2 data source connection.
Select schema(s) to extract
List of schemas available in the DB2 database available via the specified DB2 data source connection.
Schema Extract Name
A name for the schema extract file.
Local
Sets the Extract Schema tool to save the generated schema extract file to the directory specified by the Local HCOSS Directory HCOSS option.
Shared
Sets the Extract Schema tool to save the generated schema extract file to the directory specified by the Shared HCOSS Directory HCOSS option.
Estimated using schema statistics
Records the estimated table row count based on the schema statistics stored in SYSIBM.SYSTABLES. Use this option to improve performance.
Both Estimated using schema statistics and Actual using SELECT BIG_COUNT(*)
Records both the estimated table row count and the actual row count as retrieved using a SELECT BIG-COUNT(*) query. Use this option to provide accuracy.
Extract
Extract the schemas selected on the Select Schema(s) to Extract list.
Parent topic: Extract Schema
Related concepts
Extract Schema Tool
Assess Data Migration Tool
Related tasks
To extract DB2 schemas
To assess data migration


Results tab

Schema Extract Results
Shows the results of the schema extract process.
Parent topic: Extract Schema
Related concepts
Extract Schema Tool
Related tasks
To extract DB2 schemas


Assess Data Migration

  • Data Assessment Tasks tab
  • Create New Data Assessment Task dialog box
  • Results tab
Parent topic: User Interface Reference


Data Assessment Tasks tab

Available Assessments list
List of previously created data assessment tasks.
Available Assessments Local button
Show local transfer lists on the Available Transfer Lists list.
Available Assessments Shared button
Show shared transfer lists on the Available Transfer Lists list.
Associated Schema Extract list
List of local or shared extracted schemas created using the Extract Schema tool.
Associated Schema Extract Local button
Show local extracted schemas on the Associated Schema Extract list.
Associated Schema Extract Shared button
Show shared extracted schemas on the Associated Schema Extract list.
New
Create a new data assessment task.
Save
Save the data assessment task specified in the Available Assessments field.
Delete
Delete the data assessment task specified in the Available Assessments field.
DB2 Connection
The name of an existing DB2 connection.
Table List grid
Shows the information available in the extracted schema on a table-by-table basis.
Count-Type column
Select Actual to show the actual number of rows; select Estimated to show the estimated number of rows.
Transfer Option column
Change this from the default HCOSS to OTHER for tables you want to exclude from the schema extract files.
Update Row Count
Update the schema extract file with changed information from the Table list grid.
Save Options
Save the options as they appear on the Table list grid.
Export Report (txt)
Save the data assessment specifications as a text file.
Export Details (csv)
Export the data assessment specifications to a CSV file compatible with spreadsheet software.
Parent topic: Assess Data Migration
Related concepts
Assess Data Migration Tool
Related tasks
To assess data migration


Create New Data Assessment Task dialog box

Name
A name for the new data assessment task.
Schema Extract
Lists the schema extract files available to associate with the new data assessment task.
Parent topic: Assess Data Migration
Related concepts
Assess Data Migration Tool
Related tasks
To assess data migration


Results tab

Update Results
Shows any error messages generated while updating row count.
Parent topic: Assess Data Migration
Related concepts
Assess Data Migration Tool
Related tasks
To assess data migration


Define Lists

  • Transfer Lists tab
  • Create New List dialog box
  • Log Files tab
Parent topic: User Interface Reference


Transfer Lists tab

Available Transfer Lists list
List of previously created local or shared transfer lists.
Available Transfer Lists Local button
Show local transfer lists on the Available Transfer Lists list.
Available Transfer Lists Shared button
Show shared transfer lists on the Available Transfer Lists list.
Associated Schema Extract list
List of local or shared extracted schemas created using the Extract Schema tool.
Associated Schema Extract Local button
Show local extracted schemas on the Associated Schema Extract list.
Associated Schema Extract Shared button
Show shared extracted schemas on the Associated Schema Extract list.
New
Create a new transfer list.
Save
Save the transfer list specified in the Available Transfer Lists field.
Delete
Save the transfer list specified in the Available Transfer Lists field.
Type
Filter the Available Objects list by Table, View, or both (all).
Schema
Filter the Available Objects list by schemas available in the specified extracted schema.
Name
Filter the Available Objects list by schema items (tables or views) available in the specified extracted schema. The items on this list are filtered by the Type and Schema specifications.
Available Objects
Lists the objects available for transfer, filtered by the values specified in the Type, Schema, and Name fields.
Selected Objects
Lists the objects selected for transfer. Gray rows show objects that are dependent on a selected object but were not necessarily selected from the Available Objects list. The number in the Seq column shows dependency relationships.
Add All
Add all objects on the Available Objects list to the Selected Objects list.
Add
Add selected items on the Available Objects list to the Selected Objects list. Objects dependent on selected objects are added automatically.
Remove
Remove selected objects from the Selected Objects list. Objects dependent on a selected object are removed automatically.
Remove All
Remove all objects from the Selected Objects list.
Revert
Set the Available Objects and Selected Objects lists back to their last saved state.
Parent topic: Define Lists
Related concepts
Define Lists Tool
Related tasks
To define an object transfer list


Create New List dialog box

Name
A name for the new transfer list.
Schema Extract
Lists the schema extract files available to associate with the new transfer list.
Parent topic: Define Lists
Related concepts
Define Lists Tool
Related tasks
To define an object transfer list


Generate DDL

  • DDL Tasks tab
  • Create New DDL Task dialog box
  • Customize DDL tab
  • Schema Mappings tab
  • Results tab
  • Log Files tab
Parent topic: User Interface Reference


DDL Tasks tab

Available Tasks list
List of previously created local or shared generated DDL tasks.
Available Tasks Local button
Show local DDL tasks on the Available Tasks list.
Available Tasks Shared button
Show shared DDL tasks on the Available Tasks list.
Associated Transfer List list
List of local or shared transfer lists created using the Define Lists tool.
Associated Transfer List Local button
Show local transfer lists on the Associated Transfer List list.
Associated Transfer List Shared button
Show shared transfer lists on the Associated Transfer List list.
New
Create a new DDL task.
Save
Save the DDL task specified in the Available Tasks field.
Revert
Set changed fields and controls back to their last saved state.
Delete
Delete the DDL task specified in the Available Tasks field.
Drop and create objects
The generated DDL drops and creates objects in the destination SQL Server database. Default.
Restore missing objects
The generated DDL restores missing objects in the destination SQL Server database.
Connection for Check
The name of the SQL Server connection you want to use to test DLL task specifications. This defaults to the SQL Server data source specified for the Data source to use for testing DDL HCOSS Option, if set.
Connection for Execute
The name of the SQL Server connection you want to use when executing the DDL. This defaults to the SQL Server data source specified for the Name of the current/default target data source HCOSS Option, if set.
Check
Checks the DDL task specifications against the SQL Server data source specified as the Connection for Check, and takes you to the Results tab to view the results of the check.
Execute
Generates the DDL and then executes it against the SQL Server data source specified as the Connection for Execute, and takes you to the Results tab to view the results.
Customize
Takes you to the Customize DDL tab where you can customize the SQL generated for the DDL.
Schema Mappings
Takes you to the Schema Mappings tab where you can change the name of your SQL Server schema.
Export SQL Script
Save the SQL generated for the DDL as an SQL script.
Parent topic: Generate DDL
Related concepts
Generate DDL Tool
Related tasks
To generate and execute DDL
To customize generated DDL
To customize schema mappings in DDL


Create New DDL Task dialog box

Name
The name of the new DDL task.
Transfer List
Lists the transfer lists available to associate with the new DDL task.
Parent topic: Generate DDL
Related concepts
Generate DDL Tool
Related tasks
To generate and execute DDL
To customize generated DDL
To customize schema mappings in DDL


Customize DDL tab

Objects grid
Lists the schema objects available in the transfer list specified in the Associated Transfer List field on the DDL Tasks tab, in the sequence in which they appear on the transfer list.
Check All
Checks all schema objects listed on the Objects grid against a SQL Server data source and takes you to the Results tab to view the results of the check. To use this option, you must have a test SQL Server data source specified in the Data source to use for testing DDL field of your HCOSS Options.
Revert All
Removes all changes to SQL code made for all objects on the Objects grid, setting the code back to its last saved state. Once saved, you cannot revert your changes.
Save All
Saves all changes to SQL code made for all objects on the Objects grid. Once saved, you cannot revert your changes.
Generated DDL
Shows the DDL generated by default for the object selected on the Objects grid.
Customized DDL
Edit the default DDL code for the object selected on the Objects grid to customize the code generated into the DDL.
Revert
Removes all changes made to the SQL code in the Customized DDL field, setting the code back to its default state. Once saved, you cannot revert your changes.
Parent topic: Generate DDL
Related concepts
Generate DDL Tool
Related tasks
To generate and execute DDL
To customize generated DDL
To customize schema mappings in DDL


Schema Mappings tab

DB2 Schema Name
Lists the DB2 schemas available in the transfer list specified in the Associated Transfer List field on the DDL Tasks tab.
SQL Schema Name
Lists the SQL schema name mapped to each corresponding DB2 schema name. Default SQL schema names are the same as their corresponding DB2 schema names.
Parent topic: Generate DDL
Related concepts
Generate DDL Tool
Related tasks
To generate and execute DDL
To customize generated DDL
To customize schema mappings in DDL


Results tab

Attempted DDL Command(s)
Shows the DDL commands tested against the test SQL Server data source specified in the Data source to use for testing DDL field of your HCOSS Options, or executed using the connection specified in the Destination Connection field on the DDL Tasks tab.
SQL Server Results
Shows results for the executed commands.
Parent topic: Generate DDL
Related concepts
Generate DDL Tool
Related tasks
To generate and execute DDL
To customize generated DDL
To customize schema mappings in DDL


Transfer Data

  • Transfer Data Tasks tab
  • Create New Transfer Data Task dialog box
  • Customize Transfer Data tab
  • Results tab
  • Log Files tab
Parent topic: User Interface Reference


Transfer Data Tasks tab

Available Tasks list
List of previously created local or shared transfer data tasks.
Available Tasks Local button
Show local transfer data tasks on the Available Tasks list.
Available Tasks Shared button
Show shared transfer data tasks on the Available Tasks list.
Associated DDL Task list
List of local or shared DDL tasks created using the Generate DDL tool.
Associated DDL Task Local button
Show local DDL tasks on the Associated DDL Task list.
Associated DDL Task Shared button
Show shared DDL tasks on the Associated DDL Task list.
New
Create a new transfer data task.
Save
Save the transfer data task specified in the Available Tasks field.
Revert
Set changed fields and controls back to their last saved state.
Delete
Delete the transfer data task specified in the Available Tasks field.
Source Connection
The name of an existing DB2 connection.
Destination Connection
The name of an existing SQL Server connection.
Transfer
Execute the task and transfer the data.
Clear
Clear the data tables in the destination SQL Server database.
Customize
Takes you to the Customize Transfer Data tab where you can customize the transfer specifiations for individual tables.
Export as SSIS Packages
Generate an SSIS package containing the tables specified in the transfer data task. In the generation process, each table receives a sequence number to differentiate it from other tables in the package.
Parent topic: Transfer Data
Related concepts
Transfer Data Tool
Related tasks
To transfer data
To customize a transfer data task


Create New Transfer Data Task dialog box

Name
The name of the new transfer data task.
DDL Task
Lists the DDL tasks available to associate with the new transfer data task.
Parent topic: Transfer Data
Related concepts
Transfer Data Tool
Related tasks
To transfer data
To customize a transfer data task


Customize Transfer Data tab

Tables grid

Seq
The sequence in which each object is transferred from the DB2 database to the SQL Server database.
Schema
The names of schemas containing data to be transferred.
Name
The names of tables containing data to be transferred.
Buffer rows
The maximum number of rows that can be held in an individual buffer during the transfer.
Query
Perform the transfer by running a query against the SQL Server via the SSIS engine.

Transfer Task Options group

Fail on Error
The data transfer fails when it encounters an error.
Log Error Rows
The Transfer Data Tool logs an error for each row containing an error.
Ignore Error
The Transfer Data Tool ignores all errors and continues transferring data.
Fire Triggers
When checked, HCOSS fires all defined triggers during the data transfer. Default is unchecked.
Check Constraints
When checked, SQL Server performs all defined checks during the data transfer. Default is unchecked.

WHERE/ORDER BY in SELECT group

Build WHERE
Use the other controls in this group to build an WHERE clause for the query that corresponds to the tables selected on the grid.
Build ORDER BY
Use the other controls in this group to build an ORDER BY clause for the query that corresponds to the tables selected on the grid.
Column
Lists the columns available for the tables selected on the grid.
Conditional Operator
Lists valid conditional operators you can use for this clause.
AND
Inserts an AND into the clause.
OR
Inserts an OR into the clause.
Value
A literal value to insert into the clause.
>
Move completed clauses to the Predicate or Sort Order box.
<
Remove the clause from the Predicate or Sort Order box.
Predicate or Sort Order
Shows the code for a completed clause.

Transfer List Actions group

Update
Updates the selected query with the WHERE or ORDER BY clause in the Predicate or Sort Order box.
Save All
Saves all changes made to all table queries on the Objects list. Once saved, you cannot revert your changes.
Revert
Removes all changes made to the table queries selected on the Objects list, setting them back to their last saved state. Once saved, you cannot revert your changes.
Revert All
Removes all changes made to all table queries on the Objects list, setting them back to their last saved state. Once saved, you cannot revert your changes.

Source Table Row Count group

Estimate using schema statistics
Estimate the row count by querying CARDF in SYSIBM.SYSTABLES. Use this option for optimal performance if your schema statistics have been recently updated. This is the default setting when you have not specified a WHERE clause.
Acutal using COUNT_BIG(*)
Directly query the row count by executing SELECT COUNT_BIG(*) FROM targetTable. This option provides an accurate count of the rows to be transferred. This is the default setting when you specify a WHERE clause. Large tables can degrade performance.
Don't bother
Do not query for row count. Use this option when your database contains several large tables, and/or when your schema statistics are out of date.

Data Transfer Actions group

Clear
Clear the data tables in the destination SQL Server database.
Transfer
Transfer the data.
Parent topic: Transfer Data
Related concepts
Transfer Data Tool
Related tasks
To transfer data
To customize a transfer data task


Results tab

Transfer Results
Shows the results of the data transfer process.
Parent topic: Transfer Data
Related concepts
Transfer Data Tool
Related tasks
To transfer data
To customize a transfer data task


Compare Data

  • Compare Data Tasks tab
  • Create New Compare Data Task dialog box
  • Customize Compare Data tab
  • Results tab
  • Log Files tab
Parent topic: User Interface Reference


Compare Data Tasks tab

Available Tasks list
List of previously created local or shared compare data tasks.
Available Tasks Local button
Show local compare data tasks on the Available Tasks list.
Available Tasks Shared button
Show shared compare data tasks on the Available Tasks list.
Associated DDL Task list
List of local or shared DDL tasks created using the Generate DDL tool.
Associated DDL Task Local button
Show local DDL tasks on the Associated DDL Task list.
Associated DDL Task Shared button
Show shared DDL tasks on the Associated DDL Task list.
New
Create a new compare data task.
Save
Save the compare data task specified in the Available Tasks field.
Revert
Set changed fields and controls back to their last saved state.
Delete
Delete the compare data task specified in the Available Tasks field.
Source Connection
The name of an existing DB2 connection.
Destination Connection
The name of an existing SQL Server connection.
Compare
Execute the task to compare the data.
Customize
Takes you to the Customize Compare Data tab where you can customize the specifiations for making the comparison.
Parent topic: Compare Data
Related concepts
Compare Data Tool
Related tasks
To compare transferred data
To run customized data comparisons


Create New Compare Data Task dialog box

Name
The name of the new compare data task.
DDL Task
Lists the DDL tasks available to associate with the new compare data task.
Parent topic: Compare Data
Related concepts
Compare Data Tool
Related tasks
To compare transferred data
To run customized data comparisons


Customize Compare Data tab

Task Attributes group

Task Name
The name of the Compare Data task being customized.
List Name
The name of the data transfer list specified in the associated DDL task.
Location
The location of the data transfer list, local or shared.
Source Schemas and Tables
A tree view showing the tables available for comparison.

WHERE/ORDER BY in SELECT group

Table
Shows the table selected on the Source Schemas and Tables tree view.
Build WHERE
Use the other controls in this group to build an WHERE clause for the specified table.
Build ORDER BY
Use the other controls in this group to build an ORDER BY clause for the specified table.
Column
Lists the columns available for the specified table.
Conditional Operator
Lists valid conditional operators you can use for this clause.
AND
Inserts an AND into the clause.
OR
Inserts an OR into the clause.
Value
A literal value to insert into the clause.
>
Move completed clauses to Customized Query Pair.
<
Remove the clause from Customized Query Pair.
Predicate or Sort Order
Shows the code for a completed clause.
Customized Query Pair
SQL statements associated with the table(s) selected on the Source Schemas and Tables tree view and appropriate clauses as built in the WHERE/ORDER BY in SELECT group.

Compare List Actions group

Save All
Saves all changes made to tables on the tree view. Once saved, you cannot revert your changes.
Revert All
Removes all changes made to tables on the tree view, setting them back to their default state. Once saved, you cannot revert your changes.
Compare
Compare the data.
Parent topic: Compare Data
Related concepts
Compare Data Tool
Related tasks
To compare transferred data
To run customized data comparisons


Results tab

Comparison Results
Shows the results of the compare data process.
Parent topic: Compare Data
Related concepts
Compare Data Tool
Related tasks
To compare transferred data
To run customized data comparisons


Assess Application Migration

  • Assessment Tasks tab
  • Create New Assessment Task dialog box
  • Source Code tab
  • Results tab
Parent topic: User Interface Reference


Assessment Tasks tab

Assessment Properties group

Available Assessments
List of previously created assessment tasks.
SQL Server Connection
The name of an existing SQL Server connection.
Qualifier (default schema)
The name of a schema to use as the default qualifier for this assessment. Optional.
Ignore Schema Errors
When checked, errors related to schema specification and HCOSS table and function names are ignored and not reported in the results. Default is checked.
Note: Do not uncheck this checkbox if you have not installed HCOSS on the server machine that contains your SQL Server database.
Source Code Path
The directory containing your COBOL source files or the parent directory to one or more subdirectories containing your COBOL source files. Use the browse button to select a directory.
New
Create a new assessment task.
Save
Save the assessment task specified in the Available Tasks field.
Delete
Delete the assessment task specified in the Available Tasks field.

File Counts group

Total
Total number of files available for assessment.
NoSQL
Total number of files that contain no SQL code.
Processed
Total number of files that have completed processing.
Pending
Number of files awaiting processing.
Excluded
Number of files not processed in the completed assessment.
Dynamic SQL
Number of dynamic SQL statements encountered.

Statement Counts group

Total SQL Statements
The total number of DB2 SQL statements encountered in the processed files.
OK
For each of the As is, Code convert, HCOSS no BIND, and HCOSS with BIND conversion scenarios, reports the number of DB2 SQL statements that can be executed successfully in SQL Server.
Must fix
For each of the As is, Code convert, HCOSS no BIND and HCOSS with BIND conversion scenarios, reports the number of DB2 SQL statements that require a manual fix before they can execute successfully in SQL Server.
In doubt
For each of the As is, Code convert, HCOSS no BIND and HCOSS with BIND conversion scenarios, reports the number of DB2 SQL statements for which HCOSS cannot determine the potential for successful execution in SQL Server.
As is
Reports the number of DB2 SQL statements that fall into each of the OK, Must fix, and In doubt categories if you were to use the code in its original state.
Code convert
Reports the number of DB2 SQL statements that fall into each of the OK, Must fix, and In doubt categories if you were to you manually converted your SQL DB2 statements to T-SQL statements before compilation before migrating to SQL Server.
HCOSS no BIND
Reports the number of DB2 SQL statements that fall into each of the OK, Must fix, and In doubt categories if you were to use the code in its original state and compile your SQL Server application using the SQL(DIALECT) directive option without the SQL(DBRMLIB) directive option.
HCOSS with BIND
Reports the number of DB2 SQL statements that fall into each of the OK, Must fix, and In doubt categories if you were to use the code in its original state and compile your SQL Server application using both the SQL(DIALECT) and SQL(DBRMLIB) directive options. For more information, see the Manage Packages and Plans Tool and DSN BIND utility topics.
Unsupported
The number of processed SQL statements that are not ANSI SQL syntax compliant.

Error Counts group

Without HCOSS
The number of mainframe DB2 SQL statements that could not be executed by the OpenESQL runtime emulator.
With HCOSS
Of the mainframe DB2 SQL statements that could not be executed by the OpenESQL runtime emulator, the number of those statements that continue to be unexecutable even after applying an HCOSS conversion.

Summary grid

A file-by-file summary of the assessment, including a breakdown of the In doubt and Must fix counts represented in the Statement Counts group.

Assessment Actions group

Process Files
Run the assessment process.
Pause
Pause assessment processing.
Reset Status
After processing completes, clear all fields in preparation for rerunning the current assessment or for running a new assessment.
Export Report (txt)
Save the assessment specifications and results as a text file.
Export Details (csv)
Export the information in the Summary grid on the Results tab to a CSV file compatible with spreadsheet software.
Parent topic: Assess Application Migration
Related concepts
Assess Application Migration Tool
Manage Packages and Plans Tool
Binding Applications
DSN Bind Utility
Related tasks
To assess application migration
To export assessment results


Create New Assessment Task dialog box

Name
A name for the new assessment task.
Source Code Path
The directory containing your COBOL source files or the parent directory to one or more subdirectories containing your COBOL source files. Use the browse button to select a directory.
Parent topic: Assess Application Migration
Related concepts
Assess Application Migration Tool
Related tasks
To assess application migration
To export assessment results


Source Code tab

Source File
The full path to and filename of the selected source code file. If you have processed the assessment, this tab displays the converted code. Otherwise, it displays the original source code.
Next EXEC SQL
Search down and jump to the next EXEC SQL statement in the source code, wrapping back to the beginning of the file when it reaches the end.
Previous EXEC SQL
Search up and jump to the previous EXEC SQL statement in the source code, wrapping back to the end of the file when it reaches the beginning.
Parent topic: Assess Application Migration
Related concepts
Assess Application Migration Tool
Related tasks
To assess application migration


Results tab

Error Details (double-click to view SQL in context) grid

A file-by-file summary of errors found during the assessment or code conversion processes.

File Path
The paths to and filenames of source files listed in the column.
Line Num
Line number in the program where the SQL statement is found.
Error Type
The type of SQL error generated for the statement.
Error Message
The error returned for the original DB2 SQL statement.
HCOSS Message
The message returned for the SQL statement after HCOSS conversion.
DB2 SQL
The source code of the original DB2 SQL statement.
File Path
The path to and filename of the source file selected on the grid.
Line
The line number in the program where the SQL statement is found in the selected source file.
Error Type
The type of SQL error generated for the statement for the selected source file.
Error Message
The error returned for the original DB2 SQL statement found in the selected source file.
HCOSS Message
The message returned for the SQL statement after HCOSS conversion of the selected source file.
DB2 SQL
The source code of the original DB2 SQL statement found in the selected source file.
Parent topic: Assess Application Migration
Related concepts
Assess Application Migration Tool
Related tasks
To assess application migration
To export assessment results


Manage Packages and Plans

  • Bind Scripts tab
  • Bind Packages tab
  • Bind Plans tab
  • Free Packages tab
  • Free Plans tab
  • Results tab
  • Log Files tab
Parent topic: User Interface Reference


Bind Scripts tab

New
Create a new bind script file.
Open
Open an existing bind script file.
Save
Save the bind script file.
Save As
Save the bind script file under a new name.
Bind Script File
Full path to and name of the bind script file.
SQL Server Connection
The data source name for your SQL Server connection.
Bind Script Entries
The BIND PACKAGE and BIND PLAN commands in the bind script file.
New Package
Switch to the Bind Packages tab to create a new package in the SQL Server database by generating a BIND PACKAGE command for the bind script file, and executing the command.
New Plan
Switch to the Bind Plans tab to create a new plan in the SQL Server database by generating a BIND PLAN command for the bind script file, and optionally executing the command as well.
Edit
Switch to either the Bind Packages or the Bind Plans tab, depending on the selection, to modify the selected command and generate and execute the changes as a new BIND PACKAGE command, or generate and optionally execute the changes as a new BIND PLAN command.
Move Up
Reposition the selected bind script command to appear before the command listed just above it.
Move Down
Reposition the selected bind script command to appear after the command listed just below it.
Delete
Delete the selected bind script command.
Execute Selected
Execute the command selected on the Bind Script Entries list.
Execute All
Execute all commands listed on the Bind Script Entries list.
Parent topic: Manage Packages and Plans
Related concepts
Manage Packages and Plans Tool
Related tasks
To execute one or all bind script lines
To create a bind script file
To open an existing bind script file
To edit an existing BIND command


Bind Packages tab

Collection Name
The name of the collection in which to store the package.
Library Name
The name of the library containing the source member from which you want to create the package. The <default> is DBRMLIB.
Member Name
The name of (program ID of) the source member from which you want to create the package.
Default Qualifier
The name of a schema to use as the default qualifier for this package. Optional.
Add
If the package does not already exist in the specified collection, add it to the collection.
Replace
If this package already exists in the collection, replace it; if it doesn't already exist, add it to the collection.
Replace Version
Replace the package version specified in the corresponding field with the generated package version.
Revert
Return all settings changed since opening the Packages tab to their original settings.
Execute
Execute the package to create it in the specified SQL Server database in preparation for binding into a plan. After binding, all versions of the bound package are automatically available to the plan.
Parent topic: Manage Packages and Plans
Related concepts
Package Specifications
Manage Packages and Plans Tool
Related tasks
To create a new package
To edit an existing BIND command


Bind Plans tab

Plan Name
The name of a plan that you can bind to your application.
Default Qualifier
The name of a schema to use as the default qualifier for this plan. Optional.
Packages
Bind existing packages into the plan.
DBRM Members
Bind source members into the plan.
DBRM Libraries
Bind source libraries into the plan in the order they appear on the Selected Libraries list, which represents the order in which HCOSS searches the libraries for DBRM members, using the first-found instance of a specified member.
Add
If the plan does not already exist in the SQL Server database, add it to the database.
Replace
Replace an existing plan of the same name with this plan.
Revert
Return all settings changed since opening the Plans tab to their original settings.
Name
A search string on which to refine the options on the list below. You can use the wild-card character % to represent any string or string fragment.
Search
Refine the options on the list below to those matching the search string in the corresponding Name field.
Available Collections
List of collections available in the current SQL database. Available in Packages mode only.
Available Packages
Packages included in the collection selected on the Available Collections list. Available in Packages mode only.
Selected Packages
Packages selected to add to or replace in the plan. Available in Packages mode only.
Available Members
List of DBRM members available for binding into the plan. Available in DBRM Members mode only.
Selected Members
Members selected to add to or replace in the plan. Available in DBRM Members mode only.
Available Libraries
List of DBRM libraries available for binding into the plan. Available in DBRM Libraries mode only.
Selected Libraries
Libraries selected to add to or replace in the plan. The order in which the libraries appear on this list determines the search order HCOSS uses to locate specified DBRM members. Available in DBRM Libraries mode only.
Add
Add the items selected on the list or lists to the left to the list on the right.
Remove
Remove the items selected on the list to the right.
Move Up
Reposition the library selected on the Selected Libraries list to appear before the libary listed just above it, changing the order in which the libraries are searched for DBRM members. Available in DBRM Libraries mode only.
Move Down
Reposition the library selected on the Selected Libraries list to appear after the libary listed just below it, changing the order in which the libraries are searched for DBRM members. Available in DBRM Libraries mode only.
Add to Script
Generate a script line representing the settings on this tab, and add it to the list of bind script entries found on the Bind Scripts tab.
Execute
Generate and execute a command representing the settings on this tab, thereby updating the SQL Server database, and generate a script line with a command representing the settings on this tab and add it to the list of bind script entries found on the Bind Scripts tab.
Parent topic: Manage Packages and Plans
Related concepts
Manage Packages and Plans Tool
Plan Specifications
Related tasks
To create a new plan
To edit an existing BIND command


Free Packages tab

Bound Packages
Lists all available bound packages.
Show package version information
Toggle the Version column in the Bound Packages grid.
Free Package(s)
Free all packages selected on the Bound Packages list.
Free All Packages
Free all packages on the Bound Packages list.
Parent topic: Manage Packages and Plans


Free Plans tab

Bound Plans
Lists all available bound plans.
Members
For the plan selected on the Bound Plans list, populates the Bound Members list with the DBRM members bound into the plan.
Packages
For the plan selected on the Bound Plans list, populates the Bound Packages list with the packages bound into the plan.
Bound Members
Shows the DBRM members bound into the selected plan. Available only when Members is selected.
Bound Packages
Shows the packages bound into the selected plan. Available only when Packages is selected.
Expand PKLIST to show package details
View all packages that resulted when binding the plan. Available only when Packages is selected.
Show package version information
Show the version for each package listed. Available only when Expand PKLIST to show package details is checked.
Free Plan
Free the plan selected on the Bound Plans list.
Free All Plans
Free all plans on the Bound Plans list.
Parent topic: Manage Packages and Plans


Results tab

Command Results
Shows the results of the bind execution.
Parent topic: Manage Packages and Plans
Related tasks
To execute one or all bind script lines


Customize Type Mappings - Data Mappings tab

DB2 Data Type
The DB2 database column type.
Encoding
The encoding associated with the corresponding DB2 data type, ASCII, EBCDIC, or UNICODE.
Data Storage Options
The method of data storage for the DB2 data type, For bit data, Mixed data, None, or SBCS data.
SQL Server Data Type
The SQL Server database column type to which HCOSS maps the corresponding DB2 Data Type.
Restore Defaults
Restores the default setting for each changed entry.
Parent topic: User Interface Reference
Related tasks
To customize data type mappings
Related reference
Customizing Data Type Mappings


Customize SQL Name Mappings - SQL Name tab

DB2 Function/Special Register
The name of a DB2 function or special register from the originating application.
SQL Server Equivalent
The SQL Server equivalent function or special register to which the corresponding DB2 function or special register is migrated.
Is Function
Identifies corresponding DB2 and SQL Server entries as functions.
Is Special Register
Identifies corresponding DB2 and SQL Server entries as special registers.
Restore Defaults
Restores the default setting for each changed entry.
Parent topic: User Interface Reference
Related concepts
Customizing Functions and Special Registers
Related tasks
To customize SQL name mappings


Options

Compare Data Options

Compare interval refresh time
Time interval in seconds to refresh the compare progress in terms of row count. Default is 2.
Maximum number of failures
Stops the compare when the specified number of failures (non-matching rows) is reached. Default is 50.

HCOSS Connections

Automatically Test Connections
True | HCOSS automatically tests your established database connections and automatically updates their status. Default.
False | You must update the status of each connection using the Refresh button in the Manage Connections tool.
Data source to use for testing DLL
The name of the SQL Server connection you want to set as the default testing database when generating DDL. If you do not provide a SQL Server connection, HCOSS does not perform any tests when generating DLL. (optional)
Name of the current/default target data source
The name of the SQL Server connection that you want to set as the default connection. (optional)
Timeout value for each connection
When checking a connection status, the number of seconds HCOSS waits for a returned status before moving on to check the next connection listed on the Connection List tab of the Manage Connections tool. Applies only to the Connection List tab. The default is 5.

HCOSS Directories

Local HCOSS Directory
The parent directory to the subdirectory structure used to store local generated HCOSS files. The default is %APPDATA%\Micro Focus\NetExpress\6.0\HCOSS\genFileType.
Where genFileType is one of the following:
  • ApplicationAssessments
  • CompareTasks
  • DataTasks
  • DBRMDataSets
  • DDLTasks
  • Schemas
  • TargetLists
Shared HCOSS Directory
The parent directory to the subdirectory structure used to store shared generated HCOSS files. The default is %APPDATA%\Micro Focus\NetExpress\6.0\HCOSS\genFileType.
Where genFileType is one of the following:
  • ApplicationAssessments
  • CompareTasks
  • DataTasks
  • DBRMDataSets
  • DDLTasks
  • Schemas
  • TargetLists
Note: All users must have READ/WRITE access to this directory.

HCOSS UAC Behavior

Prompt to automatically run as Administrator
True | When you start HCO for SQL Server as a standard user from the Start menu, and you are a member of the Administrators group, HCOSS prompts you to run HCOSS as an Administrator. Default.
False | HCOSS does not prompt you to run HCOSS as an administrator.
Run as Administrator if in Administrators Group
True | When you start HCO for SQL Server as a standard user from the Start menu, and you are a member of the Administrators group, HCOSS automatically runs in administrator mode. At startup, a Windows UAC prompt appears.
False | HCOSS does not automatically run HCOSS as an administrator, but prompts you to start as an administrator when you launch HCOSS from the Start menu as a standard user. Default.
Warn non-Administrator users of limited functionality
True | When running HCOSS as a standard user, HCOSS presents this prompt at startup to warn you that some functionality is limited when running in standard user mode. Default.
False | HCOSS presents a prompt at startup to warn you of limited functionality.

Log File Options

Automatically delete log files
Enable or disable the automatic deletion of log files older than the number of days specified by the Days before automatically deleting log files option. The default is False.
Days before automatically deleting log files
The number of days to wait before automatically deleting log files. Valid when Automatically delete log files is set to True. The default is 30.
Directory to write log files to
The parent directory to the subdirectory structure used to store HCOSS-generated log files. The default is %APPDATA%\Micro Focus\NetExpress\6.0\HCOSS\genFileType.
Where logFileType is one of the following:
  • BindTasks
  • CompareTasks
  • Connections
  • DataTasks
  • DDLTasks
  • Schemas
  • TargetLists
Note: HCOSS does not create log files when Type of logging to do is set to Write log messages just to console, which is the default setting.
Type of logging to do
Set HCOSS to send log information to the console, a log file, or both. Default is Write log messages just to console.

Startup

HCOToolStartup
Specify the type of HCO for SQL Server startup environment, whether to start by loading information from the last session or to start with no previous information loaded. Default is Show empty environment.
Parent topic: User Interface Reference
Related concepts
HCOSS Toolset
Using HCOSS with Windows User Account Control (UAC)
Managing DBRMs
Shared DBRMs and Multi-User Environments
Related tasks
To start HCO for SQL Server
To set HCOSS options


PL/I Programming

  • CodeWatch User's Guide
  • Open PL/I User's Guide
Parent topic: Mainframe Programming


CodeWatch User's Guide

This book describes how to use CodeWatch, which provides interactive, source-level debugging capability for Open PL/I.

  • Overview
    This chapter provides an overview of the Micro Focus CodeWatch application.
  • Getting Started
    This chapter provides information to help get you up and running with CodeWatch. The following sections discuss program preparation, invoking the correct interface, CodeWatch files, multiple modules, and basic window and dialog navigation.
  • The Command-line Interface
    This chapter provides information on entering debugger commands. The command-line interface applies to the command-line version of the debugger (-classic), commands in action lists, and commands entered in the Command window of the graphical interface.
  • Debugging Concepts
    This chapter describes debugger concepts including action lists, pointers, environments, CodeWatch error messages, and program recovery.
  • CodeWatch Functionality
    This chapter describes the facilities that let you control the execution of your program, discusses environment control issues, explains how to examine, modify, and evaluate the contents of data items, and describes features such as the macro facility, debugger command files, and on-line help.
  • CodeWatch Commands
    This chapter lists and describes all of the CodeWatch commands in alphabetical order. The definitions consist of subsections that contain information on use, command syntax, a brief description, and a command-line example.
  • Debugging Open PL/I Programs
    This chapter describes CodeWatch features that relate to debugging PL/I programs and contains a sample command-line debugging session of an Open PL/I program. At the end of this chapter, the listing of the program used in the sample debugging session is provided. The source of the sample program is also available on the release media.
Parent topic: PL/I Programming


Overview

  • Introduction
  • Summary of Features
Parent topic: CodeWatch User's Guide


Introduction

Effective source-level debugging can help shorten the time spent on finding programming errors. A program may behave abnormally even after being successfully compiled. Although such a program's syntax is correct, the program still contains programming errors, or bugs, that cause unpredictable consequences such as unintended changes to the values of variables, infinite loops, incorrect output, or abnormal program termination.

Debugging is the process of discovering these bugs and eliminating them. Source-level debugging involves examining and modifying the source language elements of a program while it executes.

CodeWatch is a powerful software development tool that can help you locate bugs in programs. There are two flavors of CodeWatch available: one with a command-line interface and one with a windows interface. The command-line version offers a traditional line-oriented interface allowing you to interactively enter commands from the keyboard. The windows interface offers at least two main windows: one that allows you to enter commands and one that allows you to view your source code. You access CodeWatch commands through pull-down menus and dialogs.

CodeWatch keeps track of variables, subroutines, and data types in terms of the symbols used in the source language. You can reference these items without having to consider the underlying machine language or architecture. You can use CodeWatch to access the source text of the program, to identify and reference program entities, and to detect errors in the program's algorithms and logic.

Parent topic: Overview


Summary of Features

The following is a list of CodeWatch features.

Controlling Program Execution

CodeWatch has control over the execution of the program. Program execution can be started at a specified point, stopped and resumed at different points, transferred from one point to another, and terminated at any point.

  • Breakpointing: Breakpoints can be set to suspend execution at specified source program statements. The status of the program can then be evaluated or modified.
  • Catching: Process control can be returned to the debugger when a given signal is generated.
  • Stepping: Program execution can be stepped by one or more source program statements at a time. The debugger can also step into, over, or out of a called procedure.
  • Tracing: Tracepoints can be set at statements or at procedure and block entries to track program execution.
  • Watchpointing: Watchpoints can be set to monitor given variables. When the contents of a watched variable change, program execution stops and control is returned to the debugger.

Examining the Source Program

CodeWatch allows you to examine the source program, find specified text strings, move to specified line numbers, and examine included source files.

Environment Control

CodeWatch allows you to set the evaluation environment it uses to provide scope for referencing a specific instance of a variable or statement.

Symbolic Access

The value of a variable can be examined and/or altered as program execution continues. Procedure entries and exits can be monitored at the debugger command level. Expressions can be evaluated using the Evaluate command.

Action Lists

One or more of the debugger commands can be combined and executed at step and breakpoints.

Macro Facility

Macros can be defined as a sequence of debugger commands that will be used repeatedly throughout a debugging session. The macros can then be used like any other debugger command.

Command Files

Debugger command files can be created with a text editor or by logging commands to a specified file during a debugging session. These command files can then be used to execute the predefined sequence of debugging commands automatically during a debugging session.

Issuing Error Messages

CodeWatch identifies error conditions and issues meaningful, complete sentence error messages.

Parent topic: Overview


Getting Started

  • Program Preparation
  • Invoking CodeWatch
  • Debugging a Program with Multiple Modules
  • Ending a Debugging Session
  • Getting Started with the Graphical Interface
Parent topic: CodeWatch User's Guide


Program Preparation

A program must be compiled using the -deb option before it can be run under the control of the debugger. This is because the compiler generates a data base file referred to as the STB file. This file contains symbolic information that the debugger needs to reference to manipulate source program symbols and entities; set breakpoints, tracepoints, and watchpoints; and control program execution. A program is referred to as being compiled in debug mode when one or more of the program modules have been compiled with the -deb option.

For example, a PL/I program contained in a source file named primes. pl1 is compiled in debug mode by entering the following command line:

mfplx primes.pl1 -deb
Parent topic: Getting Started


Invoking CodeWatch

Once the program has been compiled in debug mode and linked, you can use CodeWatch to debug your program. To invoke CodeWatch, use one of the following command formats:

Graphical Interface (Windows only)

cwgui [-e]
      [-srcpath [source_directory [:source_directory] ...]]
      [-stbpath [STB_directory [:STB_directory] ...]]
      [-path [directory [:directory] ...]]
      [-usrin filename]
      [-usrout filename]
      [-8bit]
      [program-name]
      [program-arguments]

Command Line Interface

cwcmd [-classic]
      [-x]
      [-e]
      [-srcpath [source_directory [:source_directory] ...]]
      [-stbpath [STB_directory [:STB_directory] ...]]
      [-path [directory [:directory] ...]]
      [-usrin filename]
      [-usrout filename]
      [-8bit]
      [program-name]
      [program-arguments]

where:

-e (echo) | Specifies that every debugger command entered will be echoed back to the terminal.
-srcpath, -stbpath, and -path | Specify directory paths to be searched for source and STB files. See In Search of Source and STB Files for more information.
usrin and -usrout | Specify files to redirect user program input from or output to, respectively. See "Redirecting User Program I/O" for more information.
8bit | Allows CodeWatch to treat an extended set of ASCII characters as printable. See "Extended ASCII Character Support" for more information.
program-name | Is the name of the executable file to be debugged. If the debugger is invoked without a program-name argument, the a.out file in the current directory will be used if it exists; otherwise, CodeWatch comes up "standalone."
program-arguments | Are command-line arguments to be passed to the program.

CodeWatch does not require a program-to-debug at startup time. If no program-to-debug is supplied to CodeWatch, CodeWatch comes up standalone. However, on UNIX systems, it will first look for a.out as the default program name. When CodeWatch comes up standalone, a LOAD or ATTACH command must be used to specify the program to be debugged.

  • The STB File
  • Searching for Source and STB Files
  • Redirecting User Program I/O
  • Extended ASCII Character Support
  • Start-up Files
Parent topic: Getting Started
Related information
In Search of Source and STB Files


The STB File

When a program source file is compiled in debug mode, a file called the STB file (symbol table file) is created, which contains important information needed by the debugger during the debugging session. The name of this file is constructed by replacing the extension of the source file name (for example, .pl1 for a PL/I program), with an .stb extension. This STB file is placed by default in the directory in which the compilation took place.

  • Compressed STB Files
Parent topic: Invoking CodeWatch


Compressed STB Files

Code Watch handles compressed STB files. If you wish to compress your STB files, do so, and the debugger will uncompress them when it needs to access them. This happens, for example, when you step into a new evaluation environment for which the STB file has been compressed. An STB file is only uncompressed once during a debug session and remains uncompressed until you quit the debugger.

When you quit the debugger, you will be given a list of STB files that have been uncompressed during the debug session. You will be asked whether or not you would like to re-compress the files.

When quitting the debugger, you need not wait while all the STB files are being re-compressed. The re-compression process is forked off into another process.

Debug sessions run by another user accessing the same set of STB files with which you are working will not compress or uncompress an STB file out from under you. When the debugger is in the process of uncompressing an STB file, it writes a lock file to the directory in which your STB files reside, telling other debugger processes to wait until the uncompression is finished (for that STB file).

Note:

To write the lock file and to do the actual uncompression you must have write permission to the directory in which your STB files exist.

It is possible to use a compression utility other than compress. To do this, you must set the following three environment variables:

CW_COMPRESS_COMMAND | Set this environment variable to the command used to compress the STB files.
CW_UNCOMPRESS_COMMAND | Set this environment variable to the command used to uncompress the STB files.
CW_COMPRESS_SUFFIX | Set this environment variable to the suffix that denotes that the file is compressed (.Z for the compress utility).

The following are command-line examples for setting these environment variables:

setenv CW_COMPRESS_COMMAND   pack
setenv CW_UNCOMPRESS_COMMAND unpack
setenv CW_COMPRESS_SUFFIX    .z

The following command-line switches are used for the handling of compressed STB files:

-nocompress | Tells the debugger not to look for compressed STB files. If you are not going to compress your STB files, this is a good switch to use, because it saves the debugger that extra time of looking for compressed STB files.
-forcecompress | Causes the debugger to re-compress automatically any files that have been uncompressed during the debug session, without prompting you when you Quit out of the debugger. In the command-line interface, you will still be given a list of which files will be re-compressed, but in the Windows interface you will not be given this information.
Parent topic: The STB File


Searching for Source and STB Files

After the program is linked and CodeWatch is invoked with the loaded executable file as an argument, the debugger requires access to both the program source file(s) and the STB file(s).

The source file(s) will, by default, be searched for first in the directory that was specified to the compiler (relative to the current directory), and if not found, then in the current directory.

The STB file(s) will, by default, be searched for first in the current directory (where they are created), and if they are not found, they will be searched for in the directory that was specified to the compiler. This is the exact opposite of the search algorithm used for source files.

It is possible through the use of debugger command-line arguments and/or environment variables to specify alternate directories in which to search for both source and STB files before the default directories are searched.

The CodeWatch options -srcpath and/or -stbpath, followed by a list of directory names separated by colons (:), may be given to specify a list of directories to be searched before any other directories are searched. These directory lists will be searched (in order) for source files and/or STB files, respectively. If a directory list starts with a colon, the current directory (.) is assumed to be first (a trailing colon is ignored). The -path option followed by a directory list will be used in place of the -srcpath option and/or the -stbpath option if one or both is not given.

If the source and/or STB files are not yet found after searching any directories specified when invoking CodeWatch, the debugger will search directories specified by environment variables in a similar manner. The environment variables CODEWATCH_SRCPATH and/or CODEWATCH_STBPATH may be set to a list of directory names, separated by colons. These directory lists will be searched (in order) for source files and/or STB files, respectively. The environment variable CODEWATCH_PATH followed by a directory list will be used in place of the CODEWATCH_SRCPATH environment variables and/or the CODEWATCH_STBPATH environment variables if one or both is not given.

For example, the following command:

cwgui -srcpath :/pl1progs/src:/src/pl1progs\ -stbpath /pl1progs/stb:/pl1progs/obj program-name

will cause the debugger to search for the source files in the following directories in order:

  1. /pl1progs/src
  2. /src/pl1progs
  3. The directory specified at compilation (if other than the current directory)
  4. The current directory (.)

The debugger will search for the STB files in the following directories in order:

  1. /pl1 progs/stb and /pl1 progs/obj
  2. The current directory (.)
  3. The directory specified at compilation (if other than the current directory)
Parent topic: Invoking CodeWatch


Redirecting User Program I/O

When a user program is run under CodeWatch, there are three ways to specify that input and/or output be directed to/from another file.

  • The command options -usrin and -usrout. Each of these takes a filename operand.
  • The ">" (output) and the "<" (input) parameters for the RELOAD command. See Reload for more information. Both of these parameters also take a filename operand.
  • The Stdin and Stdout edit fields in the Reload dialog.

When either the input or output is redirected, CodeWatch attempts to open the specified file(s) in the appropriate mode. If the open fails, CodeWatch prints an error message and exits.

Note:

When the program normally continues to completion (for example, by using the Continue or Step command) and is automatically reloaded by CodeWatch, output redirection is preserved in append mode, while using an explicit Reload resets output redirection to the terminal.

Parent topic: Invoking CodeWatch


Extended ASCII Character Support

Normally, the debugger considers a range of ASCII characters to be unprintable. When the debugger evaluates a given data item, a dot "." is printed instead of each character within that range. The "unprintable" ASCII range is usually any character whose ASCII value is less than 32, within the range of 127 to 159 inclusive, or greater than 254. When using the -8bit command-line option, the debugger will not assume that the ASCII characters within the range of 127 to 159 inclusive are unprintable. As a result, printable characters within the extended ASCII character set, which are supported by some terminals, are allowed to be printed. This is especially useful for terminals that support languages other than English.

Parent topic: Invoking CodeWatch


Start-up Files

Upon invocation of the debugger, a command file containing debugger commands is automatically executed, if present. The debugger searches for this file in the following locations in the given order:

  1. In the file specified by the environment variable CODEWATCH_INIT.
  2. In the file .codewatch in the user's current directory.
  3. In the file .codewatch in the user's home directory.

As soon as one of these files is found, the debugger commands contained within it are executed, after which normal interactive debugging may continue. It is not required that a start-up file exist.

Parent topic: Invoking CodeWatch


Debugging a Program with Multiple Modules

Not all source modules need to be compiled in debug mode to use CodeWatch. You may compile in debug mode only those modules you want to debug.

If you debug a program with multiple modules and the main program is compiled in debug mode, the initial environment will always be the main program module.

If the main program is not compiled in debug mode, the initial environment will be the first debug module specified in the link step.

The COBOL program amort.cob is an example of a program with multiple modules. To debug just the subprogram MPCALC, only mpcalc.cob needs to be compiled in debug mode. To do this, use the following command sequence:

$ lpicobol amort.cob
$ lpicobol mpcalc.cob -deb
$ ldcobol amort.o mpcalc.o -o amort
$ cwcmd amort
Note:

The dollar character ($) in this command sequence is the system prompt.

The debugger is then invoked and MPCALC is the initial evaluation environment.

Parent topic: Getting Started


Ending a Debugging Session

To end a debugging session, enter the QUIT command at the command-line prompt or select Exit from the File menu in the Windows interface.

Using either method causes normal termination of the debugger and the termination of your program. Once the debugging session has been terminated, the system prompt will be displayed.

Keyboard interrupts while the debugger is accepting commands are ignored, but a keyboard quit (for example, <Ctrl \>) will terminate the debugging session.

Programs that terminate normally while running under the control of CodeWatch will automatically be re-initialized with any explicitly set breakpoints, watchpoints, and tracepoints (and any associated action-lists) preserved, so that execution may start from the beginning if desired. However, breakpoints that may have been set in shared libraries will not reset if the library is not loaded at program setup. The exit status with which the program exited is given. Refer to your UNIX documentation (exit (2)) for more information.

Parent topic: Getting Started


Getting Started with the Graphical Interface

The Codewatch graphical display consists of a source window, output window, and edit-line used for command-line input, plus a set of user customizable buttons.

The Codewatch display is illustrated for the Windows and UNIX platforms in the following two figures.

CodeWatch Display - Windows.

CodeWatch Display - UNIX.

  • Getting Started
  • Selecting Text and Line Numbers
Parent topic: Getting Started


Getting Started

The CodeWatch graphical interface is a simple and intuitive, easy-to-use interface. It is easy to learn, while allowing more advanced users to debug programs efficiently.

The graphical interface is closely connected to the command-line interface. It uses source and output windows to display text and customizable buttons, which allow you to quickly execute and/or edit commands.

All of the commands that the command-line interface supports are also supported in much the same way via the graphical interface Edit-line.

From the Menu Bar, clicking on Commands, Help, or Buttons presents the same popup command menu. This menu is divided into items that comprise functionality groups, and then subitems that correspond to all of the supported commands for that group. Hence, it is easy to see the functionality and commands that CodeWatch supports for, say, Program Control, and either get help for a command, execute or edit a command, or add a new button corresponding to a command.

  • Buttons
Parent topic: Getting Started with the Graphical Interface


Buttons

Buttons are a mechanism for quickly entering a command either immediately or via the Edit-line. Under Buttons on the Menu Bar, Button Mode allows for quick execution of clicked buttons, or an edit/confirm mode that allows editing and/or confirmation of the command.

When you use the quick button mode, most buttons execute immediately, as does "Step," while buttons that require arguments always use Edit/Confirm mode.

Parent topic: Getting Started


Selecting Text and Line Numbers

Buttons that require a text string or line number operate in "quick" mode if the text or line number is selected prior to the button selection.

  • To select a particular line, double-click anywhere within the text on that line.
  • To select text, click and drag the mouse over the text to be selected.

Note that on some systems, double-clicking causes the next blank-delimited text string to be selected. In this case, both a text and line number have been selected, and CodeWatch will use each appropriately for upcoming button selections.

For example, suppose you wish to Break on line 27. Use the scroll bar in the source window to move line 27 into view (if necessary), double-click anywhere on line 27, and then click the Break button. Clicking the Break button without having previously selected a line would have resulted in the Edit/Confirm mode being used.

Since the Breakpoint command (usually) requires a line number, clicking on Edit in the popup menu will place the cursor in the Edit-line. Press Return to execute the final command.

Similarly, for commands that operate on text strings, selecting text as described above and clicking a button will cause the selected text to be used as an argument to the command. For example, selecting the text string "count" from the Source window and clicking the Evaluate button will cause the variable name "count" to be evaluated in the current environment.

Thus, selecting text and line numbers for use in conjunction with buttons (and in fact, any command selected from the Command Menu in the menu bar), is actually a shorthand way of entering commands via the Edit-line.

  • Help
Parent topic: Getting Started with the Graphical Interface


Help

You can find a complete description for each of the Codewatch commands in the CodeWatch Commands chapter or by accessing Help from the Menu Bar.

Parent topic: Selecting Text and Line Numbers


The Command-line Interface

  • Special Symbols
  • CodeWatch Commands and Options
  • Entering CodeWatch Commands
Parent topic: CodeWatch User's Guide


Special Symbols

CodeWatch commands may include certain symbols that have special meaning. The table below lists these symbols and their meanings.

Symbol
 | Definition
+ | Unary plus sign, and addition
- | Unary minus sign, and subtraction
= | Right-hand side qualifier for Let
; | Command separator
[ ] | Action-list delimiters
' or " | String delimiters (' or " depending on source language)
/ | Command option indicator
\ | Statement reference qualifier
% | Command line continuator, statement label indicator, procedure entry point, and exit point indicator
: | Activation number indicator
{ } | Logical expression delimiters
Parent topic: The Command-line Interface


CodeWatch Commands and Options

A debugger command is made up of one or two keywords. The debugger command line contains a debugger command and optional or required arguments, depending on the command.

In the general format for the command-line, optional items are enclosed in oversized, square brackets. Note that the regular-sized square brackets in the action-list argument are required delimiters.

The general command-line format is as follows:

command [ /option ] [ argument ] [[action-list]]

where:

command | Names the specific debugger action to be performed.
/option | Modifies the action of the command.
argument | Supplies required or optional information to the command.
[action-list] | Lists one or more debugger commands.

Two examples of debugger commands using special symbols follow:

BREAKPOINT 90 [EVALUATE var1; E var2]

This example sets a breakpoint at line 90. The program variables var1 and var2 will be evaluated when this breakpoint is encountered.

BREAKPOINT LABEL1 + 8; LBREAKPOINT /ALL

This example sets a breakpoint eight statements past the label LABEL1 and then lists all breakpoints.

  • Command Variations
Parent topic: The Command-line Interface


Command Variations

Many of the debugger commands allow a number of prefixes, which specify a variation of the command function. The table below contains an explanation of these prefixes.

Prefix
 | Description | Example | Description
Lcommand | Lists information on command. | LMACRO | Lists information on the current macro definition.
Dcommand | Sets the default values for command. | DSTEP | Sets the default values for the Step command.
Ncommand | Removes the instance of command. | NBREAKPOINT | Removes the breakpoints.
Parent topic: CodeWatch Commands and Options


Entering CodeWatch Commands

Commands may be entered in either upper case or lower case. The debugger is not case-sensitive except when processing quoted literals. Commands will be shown in upper case in all command-line examples.

Enter the commands at the keyboard in response to the command-line prompt (CodeWatch>). For example, the PRINT command displays the current line from the source program:

CodeWatch> PRINT

Several commands can be entered on a single line, separated by semicolons, as shown in the following example:

CodeWatch> BREAKPOINT 25; EVALUATE DISTANCE

Using abbreviations, the previous command line can also be written as:

CodeWatch> B 25; E DISTANCE

Commands are executed one at a time, from left to right. If any command causes an error message to be displayed, the rest of the command line may be discarded. If any command causes the program to resume execution, the rest of the command line will be executed when the debugger resumes control. For example, the following series of commands will be executed only until CONTINUE is reached. EVAL COUNT is not executed until a breakpoint or other condition returns control to the debugger.

CodeWatch> B 93; FIND COUNT; CONTINUE; EVAL COUNT

If a command line is too long for a single line, it can be continued on the next line by entering a space and a percent character (%) as the last character on the line, followed by a carriage return. The percent character is not part of the command. It simply informs the debugger that you want to continue entering commands. The debugger prompts with ". . . >" indicating it is ready for the continuation of command input. For example:

CodeWatch> BREAKPOINT 123 [ STEP IN; FIND EXPENSES; %
...> EVALUATE EXPENSES; CONTINUE ]
Parent topic: The Command-line Interface


Debugging Concepts

  • Using Action Lists
  • Pointer Concepts
  • Environment Concepts
  • CodeWatch Error Messages
  • Aborted Program Recovery
Parent topic: CodeWatch User's Guide


Using Action Lists

An action list is a set of one or more CodeWatch commands specified for execution at breakpoints, after steps, at watchpoints, at tracepoints, or as macro definitions. The command-line syntax requires action lists to be surrounded by square brackets ( [ ] ). The commands must be separated by semicolons. You may use spaces after semicolons to aid readability. The commands that you enter in an action list are not checked for correctness until they are executed. The command-line syntax for the action list is as follows:

[ command1; command2; ...; commandn ]

A typical action list that could be set at a breakpoint is as follows:

EVALUATE COUNTER; STEP; E DISTANCE; CONTINUE

In more advanced debugging, commonly used sequences of commands can be defined as an action list with the Macro facility. The single macro name can then be used repeatedly throughout the debugging session to refer to a complex series of actions.

Parent topic: Debugging Concepts
Related information
Macro


Pointer Concepts

The debugger maintains two conceptual pointers: the execution pointer and the source file pointer. This section explains these pointers and how they are used during a debugging session.

  • The Execution Pointer
  • The Source File Pointer
Parent topic: Debugging Concepts


The Execution Pointer

The debugger maintains a pointer to the current execution point. This is the point at which execution resumes or begins following a Step or Continue. The execution pointer is reset during execution of the program. The Reload command sets the execution pointer to the start of the program. Only a Goto or Return can directly reset the execution pointer. The WHERE command will display the current execution point. In the Windows interface, the highlighted line in the Source window indicates the current execution point.

Parent topic: Pointer Concepts


The Source File Pointer

The debugger also maintains a pointer to the line in the source file currently being displayed. The CodeWatch Source command changes the current source file being displayed. The POINT and PRINT commands change and display the source file pointer, respectively. The Environment command without any operands resets the source file pointer to the current execution point.

Parent topic: Pointer Concepts


Environment Concepts

The environment is a frame of reference for the debugger to identify program entities such as certain instances of statements and variables. This section explains these entities and how to refer to them in the context of a debugging session.

  • Program Blocks
  • Block Activation Numbers
  • Statement Identifiers
  • Referencing Included or Copied Files
Parent topic: Debugging Concepts


Program Blocks

Program blocks are units of code that provide scope and context for the debugger. Program blocks are defined according to the source language. Refer to the appropriate language chapter for language-specific definitions of program blocks.

Parent topic: Environment Concepts


Block Activation Numbers

Activation numbers pertain to only recursive procedures and to languages that allow recursive procedures.

A procedure is active when it has been called during program execution. Each new call to a procedure counts as a new activation. The activation number specifies a unique activation of a procedure when more than one activation exists. Multiple activations occur when a procedure is recursive (A calls A) or indirectly recursive (A calls B calls A). Activation numbers are either absolute or relative.

  • Absolute Activation Numbers
  • Relative Activation Numbers
  • Using Activation Numbers
Parent topic: Environment Concepts


Absolute Activation Numbers

An absolute activation number is simply a positive integer. Number 1 denotes the first activation of a procedure, number 2 the second, and so forth. To refer to an activation of a procedure using absolute activation numbers, the procedure name is followed by a colon (:) and the positive integer that denotes the activation.

Parent topic: Block Activation Numbers


Relative Activation Numbers

A relative activation number is either zero or a negative integer. A relative activation number specifies the number of activations to count backwards from the most recent activation. The number 0 denotes the most recent activation. The activation directly preceding the most recent activation is denoted by -1. For example, if there have been five activations of the procedure FACTORIAL, FACTORIAL:0 refers to the fifth activation and FACTORIAL:-2 refers to the third activation. This activation can also be referred to as FACTORIAL:3 (that is, using the absolute activation number 3).

Parent topic: Block Activation Numbers


Using Activation Numbers

Each activation of a procedure has its own distinct values for automatic (or local) data, and each activation may have different actual parameters or arguments. An activation number can be used to specify the environment for evaluating or displaying variables and procedure arguments. An activation number can also be used when setting a breakpoint in a particular activation of a procedure.

If the activation number is omitted from the name, the debugger uses a default of 0, the most recent activation. The only exception to this is Breakpoint, where omitting the activation number means that a breakpoint is to be taken on every activation of the procedure.

Parent topic: Block Activation Numbers


Statement Identifiers

Commands such as Breakpoint require identification of statements within the program being debugged. Statement identifiers are either source line numbers or statement labels.

  • Line Numbers
  • Labels
  • Line Number and Statement Offsets
  • Entry and Exit Points
  • Statement Qualification by Environment
Parent topic: Environment Concepts


Line Numbers

The simplest way to refer to a statement is by using its source line number, that is, the physical line number in the source file on which the statement starts.

If an unqualified source file line number is specified (no environment reference), the first executable statement on the specified line, if present, or the first executable line following that line is used by the debugger.

If a source file line number is qualified by an environment reference, for example, "SIFT\18", the translation of the line number to an executable statement is executed in the same manner as described for unqualified line numbers, except that the set of executable statements that the line number can be translated to is restricted to those contained in the specified environment block.

Parent topic: Statement Identifiers


Labels

The way to refer to a labeled statement is to use its statement label. For any language in which statement labels are numbers, such as Pascal or FORTRAN, a percent character (%) must be used in front of the statement label. For example, in the following Pascal code

325:
326: 9999: writeln('ERROR: INVALID DATA.');
327: end. {Program Terminates}

the statement references 326 and %9999 both refer to the writeln statement.

In the following PL/I code:

 9:  DUMMY
10:  %INCLUDE 'MYFILE.PL1';/*PL/I sample */
11:  CHKPAGE:
12:  if I = 66 then
13:        do; put skip; I = 0; goto DONEIT;
14:  end;
15:  I = I + 1; DONEIT: J = 0; K = 0;
16:  L = 0;

the CodeWatch commands B 11 and B CHKPAGE are equivalent, and both refer to statement number 11.

Parent topic: Statement Identifiers


Line Number and Statement Offsets

A line number offset can be used to locate a statement when it is not labeled or its source line number is unknown. A line number offset is formed by placing a plus character (+) followed by a positive integer after a source line number or a statement label. For example, line 15 in the example below can be referred to by the program as 11 + 4 or as CHKPAGE + 4. Of course, 15 + 0 refers to the same line.

 9:  DUMMY
10:  %INCLUDE 'MYFILE.PL1';/*PL/I sample */
11:  CHKPAGE:
12:  if I = 66 then
13:        do; put skip; I = 0; goto DONEIT;
14:  end;
15:  I = I + 1; DONEIT: J = 0; K = 0;
16:  L = 0;

A statement offset must be used to refer to an unlabeled statement that is not the first statement on a line. A statement offset is formed by placing a period followed by a positive integer (indicating the number of statements from the beginning of the line) after the line number offset. (If the line number offset equals zero, a plus character must be used.) For example, the K = 0 statement on line 15 of the example above can be referred to by the debugger as 15 + 0.2 or CHKPAGE + 4.2.

Parent topic: Statement Identifiers


Entry and Exit Points

Every procedure has two special statements: the entry point to and the exit point from the procedure. The entry point is the place during execution at which the procedure has been called, but before other prelude code has run. A procedure's entry point is referred to within CodeWatch by specifying the procedure name followed by a backslash (\) and %ENTRY (or simply %E), for example,

READ_INPUT\%ENTRY.

The entry point to the current activation of a procedure may simply be referred to as %ENTRY (or %E).

The exit point is the place after which the return value (if any) has been computed and the return statement has been executed. All local variables are still defined. An exit point is referred to by the procedure name followed by a backslash and %EXIT (or %Ex), for example,

READ_INPUT\%EXIT.

The exit point to the current activation of a procedure may be referred to by %EXIT (or %Ex).

Entry and exit points may not be referred to in conjunction with statement offsets.

Parent topic: Statement Identifiers


Statement Qualification by Environment

A statement reference may need to be qualified by a reference to the environment in which the statement occurs. This is done by putting the block name of the environment (with an optional activation number) and a backslash in front of the statement reference. For example:

PRINT_OUT\10

Using just the backslash without the block name refers to the environment containing the current execution point.

Parent topic: Statement Identifiers


Referencing Included or Copied Files

Many source programs have the contents of separate files inserted into the program at compilation. Programs written in PL/I, BASIC, C, FORTRAN, or Pascal use an include statement or directive for this purpose; COBOL programs use a COPY statement.

When the debugger encounters one of these statements in a program, you can display the contents of the included file by using Source followed by the filename cited in the INCLUDE directive. The lines in the file will be numbered consecutively from the first line in the file. To return to displaying lines from the source file containing the current environment, simply use the Source command with no arguments.

Support for include file handling has been added for Open PL/I. This applies to include files that contain executable code. The current set of functionality is implemented as follows:

  • Stepping "into" an include file, for example, when the next statement is a %INCLUDE directive, will cause the screen display to switch to the specified include file. Commands that deal with the source file, for example, PRINT, POINT, and so on, work as expected using the current include file.
  • Stepping "through" an include file is allowed.
  • Setting breakpoints within an include is not allowed. The setting of a breakpoint unambiguously refers to the original containing source file.
  • Stepping "over" an include file, for example, when the next statement is a %INCLUDE directive, is not explicitly allowed. This may be accomplished by setting a breakpoint in the containing source file, followed by the CONTINUE command.
  • Stepping "out of" an include file before its last statement is accomplished similarly to stepping "over," that is, by setting a breakpoint in the containing source file followed by the CONTINUE command.

Using the macro preprocessor mfpp with CodeWatch is also allowed. CodeWatch will use the original source file (rather than the expanded preprocessed output of mfpp). Stepping "through" macros works similarly to the include file support described above.

For LPI-BASIC, LPI-COBOL, LPI-FORTRAN, and LPI-Pascal, executable code contained within included files cannot be debugged with CodeWatch.

Parent topic: Environment Concepts
Related information
Examining the Source Program


CodeWatch Error Messages

When CodeWatch encounters an error condition, a message is displayed at your terminal. The following sections describe common CodeWatch error messages.

  • Start-up Warnings
  • Start-up Errors
  • Syntax Errors
  • Semantic Errors
Parent topic: Debugging Concepts


Start-up Warnings

When the debugger session begins, the debugger may issue several different kinds of warnings.

A warning may be issued if the source file is newer than the program and/or STB file. Out-of-date files may be present for any of the following reasons:

  • The program has been edited but not re-compiled.
  • The program has been re-compiled but not re-linked.
  • The wrong SRCPATH is being used.
  • The wrong STBPATH is being used.

The following is an example of this type of warning message.

**Warning** Source file newer than program and .stb files for main.

A warning may be issued if an STB file for a module compiled in debug mode is not found. This would be an error if the debugger could not find any STB files; however, the debugger will issue a warning only if one or more (but less than all) STB files are missing.

The following is an example of this type of warning message.

**Warning** No debug data for environment
         ** Source file "y.pl1"
         ** Symbol table file "y.stb"
Parent topic: CodeWatch Error Messages


Start-up Errors

When the debugging session cannot begin, the debugger will display an error message at invocation. This indicates that a filename required by CodeWatch is an error because one or more of the following is true:

  • It does not exist or is not in the current directory.
  • The program file specified to be debugged is not an executable file.
  • None of the program modules in the program file was generated from a compilation using the -deb option.
  • The necessary debugger information files cannot be found in any of the specified or default directories.
Parent topic: CodeWatch Error Messages
Related information
In Search of Source and STB Files


Syntax Errors

The debugger issues a message when the command syntax is incorrect. The error message contains at least three lines of text: the first lines describe the error, the second to last line echoes the command line as it was entered, and the last line contains a caret ( ^ ), indicating the approximate location of the error in the command line above. After displaying an error message, the debugger issues a prompt and waits for another command. The following are examples of the message feature:

CodeWatch> TYPEPRIMES
**Error** Invalid Command
TYPEPRIMES
^
CodeWatch> TRACE EMTRY
**Error** Syntax error
TRACE EMTRY
      ^
Parent topic: CodeWatch Error Messages


Semantic Errors

Semantic errors occur when the debugger cannot correctly interpret a command line because of an incorrect variable name, an invalid argument, or some similar problem. With some semantic errors, the command line is echoed and a caret ( ^ ) is placed under it indicating the approximate location of the error. Two samples are shown from the command-line interface, as follows:

CodeWatch> EVALUATE ths_prime
**Error** Undefined variable or built-in function
EVALUATE ths_prime
                  ^
CodeWatch> BREAKPOINT 100000
**Error**   Statement 100000 not found in procedure
Parent topic: CodeWatch Error Messages


Aborted Program Recovery

CodeWatch has the ability to recover from and to reasonably debug user programs that have stopped because of certain operating system errors. When this occurs, the following are indicated by the debugger:

  • The error that caused the program to stop.
  • The current user program counter (the machine address of the execution point).
  • The name of the routine in which the error occurred.

If the routine in which the program stopped was compiled in debug mode, the source file line number of the execution point at the time of the error will also be given. The current evaluation environment will automatically be set to this environment and the debugging session may continue.

If the routine in which the program stopped was not compiled in debug mode, the environment of the most recently called routine that was compiled in debug mode is indicated, and the current evaluation environment is set to that environment. In this case, most debugger actions are allowed, including continuing execution from the point at which the program received the error. Note that it is not legal to use the Step or Goto commands from a non-debug routine.

Whether or not program execution stops because of a signal depends on the CodeWatch default catch settings for the signal. In most cases, you can modify the behavior by using the CATCH command.

The STACK command can provide a stack traceback to indicate the sequence of subroutine calls up to the time of the error.

Parent topic: Debugging Concepts
Related information
Catch


CodeWatch Functionality

  • Program Control
  • Environment Control
  • Symbolic Access
  • Examining the Source Program
  • Other Features
Parent topic: CodeWatch User's Guide


Program Control

This section explains the CodeWatch facilities that are used to control program execution. You may control the execution of your program in the following ways:

  • Setting breakpoints to suspend program execution at any executable statement.
  • Catching signals to return process control to the debugger.
  • Stepping through one or more executable statements at a time.
  • Setting watchpoints to monitor changes in specified variables.
  • Tracing statements and entries, allowing you to monitor every executable statement and the entry and exit points of a program.
  • Breakpoints
  • Catching Signals
  • Statement Stepping
  • Tracepoints
  • Watchpoints
  • Controlling Program Execution
Parent topic: CodeWatch Functionality


Breakpoints

Breakpoints are used to suspend program execution at specified locations so that you may execute various debugging actions, such as evaluating variables, single statement stepping, and so on. The Breakpoint facility is used to set a breakpoint at a specified statement or to modify the characteristics of a breakpoint already set at that statement. Up to 64 breakpoints can be active at any one time. Breakpoints may be conditional and may have associated action lists (sequences of debugger commands to be executed when the breakpoint is incurred).

There are three pertinent commands to the Breakpoint facility: BREAKPOINT, NBREAKPOINT, and LBREAKPOINT:

  • The BREAKPOINT command is used for adding new breakpoints and modifying existing breakpoints.
  • The NBREAKPOINT command removes either a specified breakpoint or all breakpoints.
  • The LBREAKPOINT command lists information about breakpoints.
Parent topic: Program Control


Catching Signals

You may specify whether or not process control should return to the debugger when a specified signal is generated. This is done with the Catch facility. You may also specify whether or not the user program is to continue as if it had or had not incurred the given signal. This is done with the Ignore option.

There are three pertinent commands to the Catch facility: CATCH, NCATCH, and LCATCH:

  • The CATCH command specifies that a signal should be caught and allows you to specify whether or not the signal is to be ignored by the user program.
  • The NCATCH command specifies that the signal should not be caught.
  • The LCATCH command lists Catch settings for a specified signal or all signals.
Parent topic: Program Control


Statement Stepping

Program execution may be single stepped one or more source-level statements at a time. It is possible to set default stepping modes:

  • You may specify that a Step should, by default, step into or over a call to a subroutine.
  • You may specify a default Step action list to be executed every time the debugger executes a Step.
  • You may also specify that a Step to a user-defined breakpoint should either execute the default Step action list, the breakpoint action list, or both.

There are three pertinent commands to the Step facility: STEP, DSTEP, and LSTEP.

  • The STEP command starts program execution at the current location of the execution pointer and stops execution after one or a specified number of statements.
  • The DSTEP command allows you to modify the default stepping modes and action list.
  • The LSTEP command lists the current stepping modes and action lists.
Parent topic: Program Control


Tracepoints

Tracing enables information about all block entries and statements to be announced as the program executes. Entry tracing allows an action list to be associated and may be conditional.

There are three pertinent commands to the Trace facility: TRACE, LTRACE, and NTRACE.

  • The TRACE command enables statement or entry tracing.
  • The LTRACE command lists the current tracing mode.
  • The NTRACE command turns off statement or entry tracing.
Parent topic: Program Control


Watchpoints

Watchpoints are used to monitor specified variables. The Watchpoint facility is used to designate a given variable to be watched. When the contents of the watched variable change, program execution stops and control is returned to the debugger. Watchpoints may be conditional and may have associated action lists (sequences of debugger commands to be executed when the watchpoint is incurred).

There are three pertinent commands to the Watch facility: WATCH, NWATCH, and LWATCH.

  • The WATCH command is used for adding new watchpoints and modifying existing watchpoints.
  • The NWATCH command removes either a specified watchpoint or all watchpoints.
  • The LWATCH command lists information about watchpoints.
Parent topic: Program Control


Controlling Program Execution

During a debugging session, CodeWatch maintains an execution pointer, which tracks the current point of program execution. When execution of the program has been halted by a debugger action, the pointer maintains the location as the current execution point. The current execution point can always be determined using the WHERE command. This allows you to control the execution of the program by using one of several simple debugger facilities.

The CONTINUE command is used to begin program execution or to resume execution following a breakpoint or a step operation.

The GOTO command moves the execution pointer to a specified statement. Program execution resumes at this point when a Continue or Step is issued. The statement is specified by a line number, a simple statement label, or a statement label followed by a line number offset or statement offset. The named statement must exist in the current program block. Once the debugger has executed the Goto, it displays the new execution point.

The RELOAD command restarts the user program, preserving any explicitly set breakpoints, tracepoints, and watchpoints with associated action lists. A subsequent Continue or Step will start program execution from the beginning of the program.

The RETURN command transfers the current execution point to the exit point of the current procedure. If the procedure returns a value, an expression must be given indicating the value to be returned. For more information, see the section Modifying Return Values.

The QUIT command causes termination of the debugging session. Selecting the Exit item in the File menu is equivalent to issuing the QUIT command.

CodeWatch does not require a program-to-debug at startup time. If no program-to-debug is supplied to Code Watch, CodeWatch comes up standalone. However, on UNIX systems, it will first look for a.out as the default program name. When CodeWatch comes up standalone, a LOAD or ATTACH command must be used to specify the program to be debugged.

The LOAD command loads the symbol table from a specified file into CodeWatch as the primary executable for debugging. It also purges the internal CodeWatch symbol table of any previously loaded executables or shared libraries.

The ATTACH command attaches CodeWatch to the "pid" (a decimal number) and performs a LOAD command, as described above. Attached programs that call exit () or that die are not automatically reloaded. Use the RELOAD command for this.

Programs may also be attached at the time of invocation, for example,

cwcmd -pid 3268 myprog.out
Parent topic: Program Control
Related information
Modifying Return Values


Environment Control

In many cases during a debugging session, it is necessary to refer to an environment to establish a frame of reference for identifying variables or statement identifiers. An environment is simply a program block, which the program refers to by specifying the name of the block or any statement within the block. This allows the debugger to find a specific instance of a variable or statement. Usually, a simple block name is adequate to specify an environment. It refers to the most recent activation of that block. To establish some other activation of the block as an environment, use a block activation number.

An active environment exists on the program stack as a stack frame containing automatic data for the environment. However, environments that do not exist on the program stack can also be referenced; such environments are called inactive environments. For example, a procedure that has not been called, and thus has no stack frame, is inactive. Another example of an inactive environment is one that is referenced by a block name followed by an activation number that is higher than the current activation of the block. It is possible to examine static and external data in inactive environments and to set breakpoints in them. An active environment must be specified to examine automatic data or procedure arguments.

  • Changing Environments
  • Stack Traceback
Parent topic: CodeWatch Functionality


Changing Environments

The Environment facility sets the current evaluation environment to provide scope to the debugger for identifying variables and statements. The environment specified can be a simple block name or a block name followed by an activation number or a statement identifier. An activation number is used to establish as an environment or an activation of a block other than the most recent one. A statement identifier is merely a convenient means of identifying the block that immediately contains the statement. If the environment argument is not specified, the evaluation environment is set to the environment containing the current execution point.

Whenever the debugger continues after program execution pauses (for example for a breakpoint or single step) the evaluation environment is reset to the environment containing the current execution point.

There are two pertinent commands to the Environment facility: ENVIRONMENT and LENVIRONMENT. The ENVIRONMENT command is used to change environments. The LENVIRONMENT command is used for listing information about environments.

Parent topic: Environment Control


Stack Traceback

The STACK command is used to print a traceback of a specified number of stack frames.

Parent topic: Environment Control


Symbolic Access

This section describes the various methods and facilities to access, modify, and display symbolic information.

  • Variable Names
  • Expression Evaluation
  • Variable Assignment
  • Listing Arguments
  • Modifying Return Values
  • Accessing Declaration Types
Parent topic: CodeWatch Functionality


Variable Names

The rules for identifying variables in the debugger are almost the same as the rules defined for the evaluation language. The same naming conventions are used, and all type and scope rules apply. One exception is that an environment name followed by a backslash (\) may be used to reference a variable in another program block. The names of variables are case-sensitive or case-insensitive, depending on the language of the module in which they are contained.

  • Referencing Elements of Arrays
Parent topic: Symbolic Access


Referencing Elements of Arrays

Elements of arrays are referenced using the constructs of the source language. CodeWatch allows access to array slices in programs written in Open PL/I, LPI-C, LPI-COBOL, LPI-FORTRAN, and LPI-PASCAL. See the language-specific chapters for information about exact syntax.

Parent topic: Variable Names


Expression Evaluation

The Evaluate command is used to evaluate and print the resultant value of expressions in the source language program. When the expression is evaluated, appropriate conversions are performed. Various display mode options (binary, decimal, octal, hexadecimal, and so on) are available.

Parent topic: Symbolic Access


Variable Assignment

The resultant value of an expression may be assigned to a named variable in the user program. When the expression is evaluated, appropriate type conversions are performed according to the rules of the source language. The resultant value is assigned to the named variable. If the type conversion is illegal, the debugger will issue an error message.

The LET command is used for variable assignment.

Note:

If the current environment is within a module compiled by LPI-C, the LET command or Change dialog is equivalent to evaluating an assignment expression. (In C, assignments are merely expression operators with side effects.)

Parent topic: Symbolic Access


Listing Arguments

The Arguments command prints the arguments for an environment. The environment specified must be the name of an active procedure. If an environment argument is omitted, the debugger defaults to the current evaluation environment.

The ARGUMENTS command lists the arguments for the given (or default) environment.

Parent topic: Symbolic Access
Related information
Environment Control


Modifying Return Values

The Return facility allows you to set the return value of a procedure. Execution control is transferred to the exit point of the current procedure, and if an expression is specified, it is used as the return value for that procedure.

There are two pertinent commands to the Return facility: RETURN and LRETURN. The RETURN command transfers control to the exit point of the current procedure and allows you to set the return value. The LRETURN command lists the return value for the current procedure.

Parent topic: Symbolic Access


Accessing Declaration Types

The TYPE command prints the resultant data type of an expression in terms of the data descriptions of the current source language.

The TYPE command is used to access declaration types.

Parent topic: Symbolic Access


Examining the Source Program

This section describes the CodeWatch facilities for searching, printing, and displaying different locations in the source file(s).

  • String Search
  • Changing Source Files
  • The WHERE Command
  • The POINT Command
  • The PRINT Command
Parent topic: CodeWatch Functionality


String Search

The FIND command locates a line in the source file containing a specified text string.

Parent topic: Examining the Source Program


Changing Source Files

The Source facility allows you to change the source file being displayed or to list information about the source files in the executable being debugged.

There are two pertinent commands to the Source facility: SOURCE and LSOURCE. The SOURCE command allows you to change the source file to be displayed. The LSOURCE command lists information about source files in the user program.

Parent topic: Examining the Source Program


The WHERE Command

The WHERE command reports either a specified location or the current point of execution. The specified location may be a name of a routine, a line number, or a statement label.

Parent topic: Examining the Source Program


The POINT Command

The POINT command locates a line number within the debug source file and reports that line. If no line number is specified, the line corresponding to the current source file pointer is printed. The source file pointer is the pointer to the current line in the current source file.

In the graphical interface, double clicking on a line is equivalent to using the POINT command.

Parent topic: Examining the Source Program


The PRINT Command

The PRINT command prints a specified number of source lines from the current debug source file or prints the current source line.

Parent topic: Examining the Source Program


Other Features

This section describes additional features of CodeWatch.

  • Command Macros
  • Debugger Command Files
  • On-line Help
Parent topic: CodeWatch Functionality


Command Macros

The Macro facility is used to define a macro as shorthand for a series of debugger commands that may be reused during the debugging session. Sixty-four macros may be defined at any one time. The series of debugger commands is specified as an action list. Once a macro has been defined, its name may be used just like any other debugger command name. The macro in the command line is replaced by the debugger commands specified in the action list. Those commands are executed normally.

Note:

Do not choose a macro name that is the same as a debugger command name because the macro name will override the debugger command for that debugging session.

If the last (or only) command in the series of debugger commands does not end with a semicolon, any additional arguments that appear on the command line after the macro name are supplied as arguments to the last command in the macro definition.

There are three pertinent commands to the Macro facility: MACRO, LMACRO, and NMACRO. The MACRO command creates new macros. The LMACRO command lists macros. The NMACRO command deletes macros.

Parent topic: Other Features
Related information
Using Action Lists


Debugger Command Files

The SAVE command writes out commands to a specified disk file to reset all current breakpoint, watchpoint, and/or macro settings for use in a later debugging session. The file can be read in by using the Read command.

The READ command is used to execute debugger command files, displaying each command to the screen as the command is executed.

The LOG command can be used to create debugger command files by causing all subsequent debugger commands to be logged to a specified file.

Parent topic: Other Features


On-line Help

Both the command-line interface and the graphical interface have a help facility. Click Help in the menu bar, or use the HELP command.

The HELP command with no parameters lists all of the available CodeWatch commands. If the HELP command is followed by command-name, help text for that command is displayed. If you need help for a specific command, you may specify the appropriate abbreviation for that command rather than the full command name.

Parent topic: Other Features
Related information
Help


CodeWatch Commands

  • Arguments
  • Attach
  • Breakpoint
  • Call
  • Catch
  • Commandline
  • Continue
  • Detach
  • Dstep
  • Environment
  • Evaluate
  • Find
  • Goto
  • Help
  • Kill
  • Lbreakpoint
  • Lcatch
  • Lenvironment
  • Let
  • Lmacro
  • Load
  • Log
  • Lreturn
  • Lsource
  • Lstep
  • Ltrace
  • Lwatch
  • Macro
  • Nbreakpoint
  • Ncatch
  • Nload
  • Nlog
  • Nmacro
  • Nmap
  • Nshlib
  • Ntrace
  • Nwatch
  • Peek
  • Point
  • Poke
  • Print
  • Quit
  • Read
  • Registers
  • Reload
  • Return
  • Save
  • Shlib
  • Source
  • Stack
  • Step
  • Trace Entry
  • Trace Statement
  • Type
  • Watch
  • Where
  • !
Parent topic: CodeWatch User's Guide


Arguments

Use

Prints the arguments of a specified procedure environment.

Command Syntax

ARGUMENTS [environment]

where:

environment
Name of an active procedure

Description

The ARGUMENTS command prints the arguments to a named procedure environment. The procedure environment can be any program block.

If the environment name is omitted, the debugger defaults to the current evaluation environment.

Example

In this example, the arguments to the "sift" procedure are displayed.

CodeWatch> ARGUMENTS sift
N = 10 { fixed binary (31) }
Parent topic: CodeWatch Commands
Related information
Environment Control
Environment
Evaluate
Let
Stack


Attach

Use

Attaches CodeWatch to a "pid" and executes a LOAD command.

Command Syntax

ATTACH pid filename

where:

pid
A decimal process identification number.
filename
Name of a file to be loaded

Description

The ATTACH command attaches CodeWatch to the pid (a decimal number) and performs a LOAD command. Attached programs that call exit () or that die are not automatically reloaded. Use the RELOAD command for this.

Programs may also be attached at the time of invocation, for example, cwcmd -pid 3268 myprog.out

Example:

CodeWatch> ATTACH 3768 myprog.out
Parent topic: CodeWatch Commands
Related information
Detach
Kill
Load
Nload


Breakpoint

Use

Suspends program execution to allow for debugger actions.

Command Syntax

BREAKPOINT [statement-id]
           [[action-list]]
           [/IF {logical-expr} [/ELSE[action-list]]]
           [/SKIP=n]
           [/IGNORE  |  /NIGNORE [/ALL]]
           [/SILENT  | /NSILENT]

where:

statement-id
Identifies the statement at which the breakpoint will be set or modified
action-list
Specifies a set of one or more CodeWatch commands separated by semicolons.
logical-expr
Can be any expression that may occur in the source language program, including references to simple as well as aggregate (such as array, record, and structure elements) type variables, returning a boolean value.

Description

The BREAKPOINT command is used to set a breakpoint at a specified statement or to modify the characteristics of a breakpoint already set at that statement. If the statement identifier is not specified, the breakpoint will be set at the current execution point; that is, the statement to be executed when program execution is resumed. The maximum number of breakpoints that can be active at one time is 64.

Breakpoints can be set at the entry point (%ENTRY) of external routines that have or have not been compiled in debug mode and at lines containing executable statements within routines that have been compiled in debug mode. Lines containing only comments or declarations, or only the keyword ELSE (else), are not valid breakpoint locations. If you try to set a breakpoint at one of these locations, the debugger will set the breakpoint at the first executable statement after the one named in the command.

Example

In the following example, a breakpoint is set at the entry point of the READ_INPUT procedure with an action list evaluating the value of MAXV.

CodeWatch> B READ_INPUT\%ENTRY [E MAXV]
CodeWatch> C
Break at PRIMES.READ_INPUT\%ENTRY
MAXV =                10 {fixed binary (31)}

In the following example, a conditional breakpoint is set on line 94. Program execution will stop if the variable COUNT is greater than 3; otherwise, the debugger will evaluate COUNT and continue.

CodeWatch> B SIFT\94 /IF {COUNT>3} /ELSE [E COUNT]
CodeWatch> CONTINUE
COUNT =              1 {fixed binary (31)}
COUNT =              2 {fixed binary (31)}
COUNT =              3 {fixed binary (31)}
Break at PRIMES.SIFT\94
  • Breaking at Specific Activations of a Block
  • Breakpoints with Action Lists
  • Skipping Multiple Iterations of a Breakpoint
  • Temporarily Ignoring Breakpoints
  • Suppressing the Breakpoint Message
  • Conditional Watchpoints
  • Incurring Breakpoints
Parent topic: CodeWatch Commands
Related information
Continue
Goto
Lbreakpoint
Nbreakpoint
Read
Save
Watch


Breaking at Specific Activations of a Block

If the statement identifier is qualified by a block name with an explicit activation number, the breakpoint applies only to that activation. If a block activation number is not specified, the breakpoint will be taken on every activation of the specified statement. The numbered activation may be higher than the most recent activation of the block. Relative activation numbers are converted to absolute activation numbers when the breakpoint is set.

Parent topic: Breakpoint
Related information
Block Activation Numbers


Breakpoints with Action Lists

If an action list is specified, it is set as the action to be performed when the breakpoint is taken. To remove an action list using command-line syntax, simply specify a null action-list, that is [ ]. To remove an action list using the Breakpoint dialog, simply delete the text in the Action List edit field. An action list of CONTINUE causes the breakpoint to act like a simple tracepoint; at each execution of the statement a message identifies the statement and execution continues.

Parent topic: Breakpoint


Skipping Multiple Iterations of a Breakpoint

A breakpoint counter is associated with each breakpoint. When the breakpoint is created, the counter is set to zero; each time the breakpoint is encountered the counter is incremented by one. All breakpoint counters are set to zero when the program is reloaded.

If a skip count is specified, a breakpoint skip counter is set to the value specified, causing the breakpoint to be skipped that number of times. Once the breakpoint skip counter is set, it remains in effect until its value decreases to zero.

Parent topic: Breakpoint


Temporarily Ignoring Breakpoints

If the Ignore option is specified, the breakpoint is flagged to be ignored and is not executed when it is encountered. The Ignore option is useful to temporarily disable a breakpoint. Turning off the Ignore flag sets the breakpoint in effect again. This is done by specifying the /NIGNORE option. It is possible to set all breakpoints to be ignored or not ignored. This is done by specifying the option /ALL in conjunction with /IGNORE or /NIGNORE.

Parent topic: Breakpoint


Suppressing the Breakpoint Message

When a breakpoint is encountered, CodeWatch normally prints a message specifying the line at which the breakpoint is set. This message can be suppressed by using the Silent option; this is especially useful if a debug-time "patch" is desired within your program. To create a patch, set a breakpoint at the beginning of the code that causes the program error. The breakpoint should include the Silent option and an action list that performs a work-around assignment ending with a GOTO command (to circumvent the program error) and a CONTINUE command. The debugger will then perform the specified action list at the breakpoint and continue execution without any interaction.

Parent topic: Breakpoint


Conditional Watchpoints

A conditional expression may be used to qualify the breakpoint; it must be the last option on the command line. When a breakpoint with the If option is set, the executing program will be suspended and the debugger will be activated whenever the breakpoint is encountered. The IF condition is then evaluated. The evaluation always takes place in the environment and language of the program statement. If the IF condition is false, program execution continues and the breakpoint is never reported. If the IF condition is true, the debugger incurs a breakpoint as usual.

Parent topic: Breakpoint


Incurring Breakpoints

When a breakpoint with a conditional expression is set at a particular program statement, the executing program will be suspended and the debugger will be activated whenever that program statement is about to be executed. The following will then occur:

  • The condition is evaluated; the evaluation always takes place in the environment and language of the program statement. If the condition is false and the Else action list has not been specified, program execution continues. If the condition is false and the Else action list has been specified, the Else action list is executed and program execution continues. If the condition is true, the debugger performs the following actions:
    • The breakpoint counter is incremented.
    • If the Ignore flag is on for this breakpoint, execution continues.
    • If the skip count for this breakpoint is non-zero, the count is decremented and execution continues. However, the skip count for an Ignored breakpoint is not affected.
    • The debugger reports an announcement of the breakpoint.
    • If an action list is specified, it is executed. The action list may specify that program execution is to continue.
Parent topic: Breakpoint


Call

Use

Calls a user procedure or function.

Command Syntax

CALL subroutine-name [(argument-list)]

where:

subroutine-name
Is a block name that may or may not return a value
argument-list
Is a list of variable names and/or constants separated by commas

Description

The CALL command will set up any given arguments and perform a subroutine call to the specified subroutine (function or procedure). If a breakpoint is set within a called subroutine (or in a routine which it in turn calls), then it is taken as usual. In this case, a new debugger prompt is used to indicate that a different level of debugger invocation has been entered. At this point, debugging can continue as usual, including stack tracebacks (with traceback only to the called routine), and calling another routine, thus entering yet a higher debugger invocation level. In this way, there is no change in the debugging environments across subroutine calls.

If the called subroutine is a function, the return value of the function will be printed at the end of the call. Functions may also be called through the use of Evaluate and Let, for example,

LET x = foo(y) * z

or:

EVALUATE foo(x) * foo(goo(y,foo(123))) / z

Functions that are defined or declared in the current execution environment may be called. In this case, the number and type of arguments given will be checked against the declaration or definition of the subroutine. If they do not match, an error will be given and the call will not be made.

It is not required that called functions be compiled in debug mode. If they are not, however, it will not be possible to set breakpoints within that function. The calling conventions of the source language of the environment from which the call is being made are properly upheld (for example, call-by-value versus call-by-reference).

Non-local Gotos within a called function are legal and executed only if the target is within an environment that has been called (that is, activated) subsequent to the initial call. If it is not, an error will be given and the call aborted.

The CALL command will not accept as an argument block names containing characters not allowed in a variable name for the source language of the current scope.

The maximum number of arguments allowed to be passed to a called routine is 240.

Illegal non-local Gotos within a called function do generate an appropriate error message and abort the call. However, the user program is terminated and must be reloaded using Reload to continue debugging.

Example

The following call takes no arguments.

CodeWatch> CALL page_in_info ()

The following is a function call returning an integer.

CodeWatch> CALL get_user_id(name)
174    { int }

The following is the same call as in the previous example, except that a breakpoint is incurred at the entry point of get_user_id.

CodeWatch> CALL get_user_id(name)
Break at get_user_id\%ENTRY
DEB(1:get_user_id)>

Related Commands

  • Evaluate
  • Let
Parent topic: CodeWatch Commands
Related reference
Evaluate
Let


Catch

Use

Returns process control to the debugger when the given signal is generated.

Command Syntax

CATCH {/DEFAULT | [/NIGNORE|/IGNORE] signal}

where:

signal
Can be either a signal name mnemonic (such as SIGALRM, SIGINT, and so on) or the signal number corresponding to that mnemonic. Signal names may be specified in either uppercase or lowercase letters

Description

The occurrence of a signal that is set to be caught and ignored will cause process control to return to the debugger. When the child (user) process is subsequently resumed (for example, by using Step or Continue), it will continue as if it had not incurred the given signal. The occurrence of a signal that is set to be caught and not ignored (/NIGNORE), will cause process control to return to the debugger. When the child process is subsequently resumed, it will continue as if it had incurred the given signal. The occurrence of a signal that is not set to be caught will not cause process control to return to the debugger.

By default, certain signals are caught by the debugger. The Default option will reset all CATCH settings back to the debugger's default settings.

Use the command LCATCH /ALL to get a list of current signal settings.

Note: The signals SIGILL and SIGTRAP are permanently set to be ignored by the debugger. These are special signals because they are used by the debugger for breakpointing. You cannot modify the settings for these two signals.

Example

In the following example, process control will return from the child process to the debugger when SIGALRM is generated.

CodeWatch> CATCH /IGNORE SIGALRM
Changing SIGALRM to be caught and ignored.

When the child process resumes, it will ignore the SIGALRM and continue as if it had never generated a SIGALRM.

In the following example, the number 28 represents the signal SIGWINCH. Process control will return from the child process to the debugger when a SIGWINCH is generated.

CodeWatch> CATCH /NIGNORE 28
Changing SIGWINCH to be caught and not ignored.

When the child process resumes, it will recognize the signal SIGWINCH and continue as if it had incurred a SIGWINCH.

Parent topic: CodeWatch Commands
Related information
Lcatch
Ncatch


Commandline

Use

Displays CodeWatch command-line arguments.

Command Syntax

COMMANDLINE

Description

The COMMANDLINE command displays the command-line arguments specified to the user program. Command- line arguments may be specified to the user program either on the CodeWatch command line upon invocation of the debugger, or by using the RELOAD command.

Example

In the following two separate examples, the command-line arguments are displayed. Note that the primes executable file being debugged takes no command-line arguments, whereas the myprog executable file was invoked with two command-line arguments.

CodeWatch> COMMANDLINE
Command line : "primes"

CodeWatch> COMMANDLINE
Command line : "myprog" "-b" "-verbose"
Parent topic: CodeWatch Commands
Related information
Reload


Continue

Use

Begins or continues program execution.

Command Syntax

CONTINUE

Description

The CONTINUE command is used to begin program execution initially or following a reload operation, or to resume program execution following a breakpoint or a step operation.

The CONTINUE command is often the last command in an action-list.

Example

In this example, program execution is continued until the breakpoint is encountered.

CodeWatch> CONTINUE
Break at PRIMES.READ_INPUT\%ENTRY

In the following example, a breakpoint is set at line 119 of the main program and a watchpoint is set on the variable n with an action list to continue program execution. The debugger will report when the contents of n have changed.

CodeWatch> BREAKPOINT 119
CodeWatch> WATCH n /ACTION [C]
CodeWatch> CONTINUE

Input maximum prime boundary: 10
Program Stopped due to a Watchpoint
Watched variable N modified about line PRIMES\118
New Value: 10 {fixed bin (31))
Break at PRIME\119
Parent topic: CodeWatch Commands
Related information
Breakpoint
Watch


Detach

Use

Detaches from the currently attached process.

Command Syntax

DETACH

Description

Detaches CodeWatch from the currently attached process.

Note: The DETACH command may not be supported on some systems.
Parent topic: CodeWatch Commands
Related information
Attach
Kill
Load
Nload


Dstep

Use

Sets the default mode and/or action-list for Step.

Command Syntax

DSTEP [ IN|OVER ]
      [ BACTION | SACTION | BOTH ]
      [ [action-list] ]

where:

action-list
Specifies a set of one or more CodeWatch commands separated by semicolons

Description

The DSTEP command sets the default stepping mode to either In or Over called routines and/or sets the default action-list for Step. If Dstep is not used, Over is the default stepping mode.

The Baction, Saction, and Both default stepping modes are intended to be used to step to a user-specified breakpoint. You may specify that the breakpoint action list be executed (Baction), the default step action list be executed (Saction), or both action lists be executed (Both).

Example

In the following example, the default stepping mode is set to In and the PRINT command is set as the default action to be executed at each step. When the subsequent Step is executed, the current execution point is displayed and the current source line is printed.

CodeWatch> DSTEP IN [PRINT]
CodeWatch> STEP
Step at PRIMES.SIFT\%ENTRY
  76: sift: procedure(n);
Parent topic: CodeWatch Commands
Related information
Lstep
Step


Environment

Use

Sets the current evaluation environment.

Command Syntax

ENVIRONMENT [environment]

where:

environment
Can be a simple block name or a block name followed by an activation number or a statement identifier

Description

The ENVIRONMENT command sets the current evaluation environment to provide scope to the debugger for identifying variables and statements.

An activation number is used to establish, as an environment, an activation of a block other than the most recent one. If the environment argument is not specified, the evaluation environment is set to the environment containing the current execution point, and the current source file pointer is set to the current execution point. Whenever the environment changes during program execution, the evaluation environment is reset to the environment containing the current execution point.

Example

In the following example, the current evaluation environment is changed to PRIMES, and then it is reset to the previous evaluation environment by using Environment without any arguments.

CodeWatch> ENVIRONMENT PRIMES
CodeWatch> E n
N =                5 {fixed binary (31)}
CodeWatch> ENV
Environment reset to PRIMES.READ_INPUT
Parent topic: CodeWatch Commands
Related information
Lenvironment


Evaluate

Use

Evaluates and prints the resultant value of expressions.

Command Syntax

EVALUATE [[/display mode] expression]
EVALUATE [[/display mode]
         [     /NSDM    |    /NSMF  |
               /SDM     |    /SMF   |
               /SM      |    /NSM   |
               /DM      |    /MF    |
               /ALL     |    /INTERNAL]
         [     /DERIVED ]
         [     /PRIVATE    | /PUBLIC  |
               /PROTECTED  |  /ACCESSIBLE ]…

EVALUATE [/STRING c-char-ptr]
EVALUATE [/MACRO c-macro-defn]

where:

display mode
One of ASCII, BIT, FLOAT, HEX, INTEGER, or OCTAL
expression
Can be any expression that may occur in the source language program, including references to simple as well as aggregate (such as array, record, and structure elements) type variables
c-char-ptr
Is a C expression whose resultant type is char *
c-macro-defn
Is a C preprocessor macro definition name

Description

The EVALUATE command evaluates and prints the value of expressions in the source language program. If the expression is omitted, Evaluate uses the previous expression that was evaluated. If no previous expression was evaluated, an error message generates.

The display mode is the mode in which the value of the expression is to be printed. The valid display modes are Ascii, Bit, Float, Hex, Integer, and Octal. The display modes are defined in the table below.

Display
 | Mode Definition
AScii | Displays the value as a series of Ascii characters.
Bit | Displays each bit in the value as a 1 or a zero.
Float | Displays the value as a single-precision floating-point number.
Hex | Displays the value as a series of hexadecimal numbers.
Integer | Displays the value as a series of signed decimal numbers.
Octal | Displays the value as a series of unsigned octal numbers.
Note: Codewatch allows evaluation of WIDECHAR variables only. Evaluation of WIDECHAR expressions is currently not supported.

For WIDECHAR variable evaluation, half byte-pairs outside the ASCII range display as a '.' character. Use the EVALUATE command with the /h option to display hexadecimal values for each byte-pair. For example:

dcl wc wchar (16) init('003900370038'Wx);

...

eval wc

WC = .9.7.8. . . . . . . . . . . . .  {widechar (16)}

eval /h wc

WC = 00 39 00 37 00 38 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 00 20 (hex)  {widechar (16)}

Example

In this example, the value of data items in the SIFT routine is evaluated.

CodeWatch> EVALUATE THIS_PRIME
THIS_PRIME =         7 {fixed binary (31))

In this example, a cross section of the array PRIMES from 1 to count -1, where count equals 4, is evaluated.

CodeWatch> EVALUATE PRIMES (1 : count - 1)
PRIMES(1) =              1 {fixed binary (31))
PRIMES(2) =              2 {fixed binary (31))
PRIMES(3) =              3 {fixed binary (31))
  • Changing Values of Variables
  • Array Evaluation
  • C Preprocessor Macros
  • Dereferencing C char Pointers
  • C Function Calls
Parent topic: CodeWatch Commands
Related information
Call
Let
Type


Changing Values of Variables

Using the command-line interface, it is possible to change the value of simple variables using the LET command.

Parent topic: Evaluate
Related reference
Let


Array Evaluation

Array evaluation and array slice evaluation is possible depending on the language of the current environment. All of the language-specific chapters in this manual have an "Array Evaluation" section that describes how each particular language evaluates arrays.

Parent topic: Evaluate


C Preprocessor Macros

Using CodeWatch, it is possible to evaluate C preprocessor macro definitions. This is because the LPI-C compilers contains an integrated preprocessor rather than use a stand-alone separate preprocessor. This allows information about preprocessor macro definitions to be passed along to the debugger. The EVALUATE and TYPE commands will display the macro definition of the specified name.

In the case of name conflicts (that is, when a preprocessor macro definition follows a declaration or definition of a variable in the source file), then the debugger will display information about both the macro and the variable. If only information about the macro definition is desired, then you may specify the Macro option.

The display mode option has no effect on the display of a preprocessor macro definition. If the macro displayed is passed parameters, they are reported as <mac-param-1>, <mac-param-2>, and so on.

Parent topic: Evaluate


Dereferencing C char Pointers

The String option may be used to dereference C char pointers; This allows you to evaluate the null-terminated sequence of characters to which a C pointer points.

Parent topic: Evaluate


C Function Calls

If the expression to be evaluated includes a function call, then a subroutine call to the specified function will be made. Breakpoints are disabled during function calls when using the EVALUATE command. If you want a breakpoint in a called routine to be incurred, use the CALL command.

Parent topic: Evaluate


Find

Use

Locates and prints a specified string.

Command Syntax

FIND [/IGNORE] [string]

where:

string
Is a sequence of characters

Description

The FIND command locates a line in the source file containing a specified string and reports that line.

Quotation marks may be used to delimit the string but they are not required. If the string is not specified, the default value will be the string specified in the previous Find. If there is no string specified in the first instance of Find, an error message will be generated.

The debugger finds the first occurrence of the string after the current file position in the source file, then prints the line containing that occurrence of the string. By default, Find is case-sensitive, so that string "ABC" differs from "abc" and "Abc". When the ignore case option is turned on with Find, it is case-insensitive, so that the string "ABC" is the same as the string "abc" and "Abc".

If the string is not found, the current source file pointer is positioned at the last line of the user program.

Example

In this example, the string "main" is located.

CodeWatch> FIND main
 108:       /* main procedure */

If the string is not identical in terms of case to the string in the source file, it will not be found. For example:

CodeWatch> FIND MAIN
String not found: "MAIN"

In the following example, the search is case-insensitive.

CodeWatch> FIND /IGNORE MAIN
 108:       /* main procedure */
Parent topic: CodeWatch Commands
Related information
Point
Print


Goto

Use

Moves the execution pointer to a specified statement.

Command Syntax

GOTO statement-id

where:

statement-id
Can be a line number, a simple statement label, or a statement label followed by a line number offset or statement offset

Description

The GOTO command moves the execution pointer to a specified statement. Program execution resumes at this point when a Continue or Step is issued. The named statement must exist in the current program block.

Note:

It is not valid to put an activation number on the statement-id. If the activation number of an existing previous block invocation is put on the statement-id, it is ignored; otherwise, the following error message is displayed:

specified activation does not
             exist

It is not possible to use Goto to go to the %EXIT point of a block. The RETURN command, however, can be used to go to the %EXIT point.

When a Goto is executed, the debugger displays the current execution point.

Example

In this example, the execution point is changed to line 21 from the previous execution point as displayed by the Where command.

CodeWatch> WHERE
Current execution point is PRIMES.READ_INPUT\%ENTRY
CodeWatch> GOTO 21
Execution point is now PRIMES.READ_INPUT\21
Parent topic: CodeWatch Commands
Related information
Where
Continue
Step


Help

Use

Displays help text for debugger commands.

Command Syntax

HELP [command-name]

where:

command-name
Is the full spelling of a CodeWatch command or its accepted abbreviation

Description

The HELP command with no parameters lists all of the available CodeWatch commands. If the HELP command is followed by command-name, help text for that command is displayed.

Example

The following is an excerpt of the text displayed when invoking the HELP command with the BREAKPOINT command name abbreviation.

CodeWatch> HELP B
The BREAKPOINT command suspends execution to allow for debugger actions.

Command Syntax
         Breakpoint [ statement-id ]
                    [[action-list] ]
                    [/IF { logical-expr } [/ELse [action-list] ]]
                    [/Skip=n]
                    [/Ignore | /Nlgnore [/All]]
                    [/SILent | /NSILent]
Parent topic: CodeWatch Commands


Kill

Use

Kills the current child process.

Command Syntax

KILL

Description

Kills the current child process, and purges the CodeWatch internal symbol table.

Example

CodeWatch> KILL
Parent topic: CodeWatch Commands
Related information
Attach
Detach
Load
Nload


Lbreakpoint

Use

Lists information on breakpoints.

Command Syntax

LBREAKPOINT  [statement-id|/ALL ]

where:

statement-id
Names the statement at which the breakpoint is to be listed

Description

The LBREAKPOINT command lists information on a single breakpoint or on all breakpoints.

If the statement identifier is omitted, information is listed on the breakpoint at the current execution point. If /ALL is specified, information is listed on all breakpoints. The information listed includes the skip count, execution count (the number of times the breakpoint has been encountered) and any specified action-list.

Example

In this example, all breakpoints are listed.

CodeWatch> LBREAKPOINT /ALL
Break set at PRIMES\114 (count = 1)
Break set at PRIMES\119 (count = 2)
Break set at PRIMES.READ_INPUT\%ENTRY (count=1) [E maxv;]
Break set at PRIMES.ISPRIME\%ENTRY (count = 1)
Parent topic: CodeWatch Commands
Related information
Breakpoint
Nbreakpoint


Lcatch

Use

Lists Catch settings for a given signal.

Command Syntax

LCATCH [/ALL | signal]

where:

signal
Can be either a signal name mnemonic (such as SIGALRM, SIGINT, and so on) or the signal number corresponding to that signal. Signal names may be specified in either uppercase or lowercase letters. If neither a signal name nor /ALL command is specified, all of the signals currently set to be caught are displayed

Description

The LCATCH command with no arguments lists all of the signals that are currently set to be caught. When used with the /ALL option, LCATCH lists two sets of signals, those that are currently set to be caught and those that are currently set to not be caught. The LCATCH command, with a signal name specified, lists Catch settings for that given signal.

Example

In the following example, the current Catch settings for the signal SIGALRM are listed.

CodeWatch> LCATCH SIGALRM
SIGALRM not being caught.

In this example, the signals currently set to be caught and those that are set not to be caught are listed.

CodeWatch> LCATCH /ALL

CATCHing signals:

SIGINT SIGQUIT SIGILL SIGTRAP SIGIOT SIGEMT SIGFPE
SIGKILL SIGBUS SIGSEGV SIGSYS SIGPIPE SIGTERM SIGURG
SIGSTOP SIGTTIN SIGTTOU SIGIO SIGXCPU SICXFSZ SIGPROF
SIGVTALRM

Not CATCHing signals:
SIGHUP SIGALRM SIGTSTP SIGCONT SIGCHLD SIGWINCH SIGLOST
SIGUSR2
Parent topic: CodeWatch Commands
Related information
Catch
Ncatch


Lenvironment

Use

Lists the current evaluation environment.

Command Syntax

LENVIRONMENT [/ALL ] [/FULL]

Description

The LENVIRONMENT command lists the current evaluation environment.

The All option lists all environments within the source file.

The Full option lists the current environment, the first and last source file line numbers in that environment, and the text offsets for the beginning and end of code in that environment. The offsets correspond to those found in the expanded listing generated by the Compiler.

Example

In this example, the current evaluation environment displayed is PRIMES.READ_INPUT.

CodeWatch> LENVIRONMENT
Evaluation environment is PRIMES.READ_INPUT
Parent topic: CodeWatch Commands
Related information
Environment


Let

Use

Assigns a value of an expression to a name.

Command Syntax

LET name = expression

where:

name
Is the name of any variable or destination construct (such as a substring or based reference in PL/I) that occurs in the source language program
expression
Can be any expression allowed by the source language whose value can be converted to the data type of the named variable

Description

The LET command assigns a value of an expression to a name. When the expression is evaluated, appropriate type conversions are performed. The resultant value is assigned to the named variable. If the type conversion is illegal, the debugger will issue an error message.

The value of a character string constant can be changed by enclosing the expression within single or double quotation marks, depending on the source language.

In C, assignments are merely expression operators with side effects. Therefore, Evaluate provides the same functionality as Let in other languages.

Breakpoints are disabled during function calls using the LET command. If you want a breakpoint in a called routine to be incurred, use the CALL command.

Example

In this example, the value of MAXV is assigned a new value (MAXV/ 2).

CodeWatch> EVALUATE MAXV
MAXV =             10 {fixed binary (31))
CodeWatch> LET MAXV = MAXV/2
CodeWatch> EVALUATE MAXV
MAXV =              5 [fixed binary (31))
Parent topic: CodeWatch Commands
Related information
Arguments
Call
Evaluate


Lmacro

Use

Lists the macro definitions.

Command Syntax

LMACRO { macro1, macro2, ..., macron | /ALL }

Description

The LMACRO command lists the definition of one or more specified macros or the definitions for all currently defined macros. The debugger lists the action-list that was defined for the macro. Either the indicated macro-name(s) or /ALL must be specified.

Example

In this example, all of the macro definitions are listed.

CodeWatch> LMACRO /ALL
FIG = [FIND /IGNORE]
INFO = [LB /A; LENV; LMA /A; WHERE]
Parent topic: CodeWatch Commands
Related information
Macro
Nmacro


Load

Use

Loads the symbol table from a specified file as the primary executable file.

Command Syntax

LOAD filename

Description

The LOAD command loads the symbol table from filename into CodeWatch as the primary executable file for debugging. It also purges the internal CodeWatch symbol table of any previously loaded executable files or shared libraries.

Example

CodeWatch> LOAD myprog.out
Parent topic: CodeWatch Commands
Related information
Attach
Detach
Kill
Nload


Log

Use

Logs debugger commands and, optionally, output to a specified file or files.

Command Syntax

LOG [/FuLL]filename

where:

filename
Is the pathname of any file allowing write permission to the user

Description

The Log command causes all subsequent debugger commands to be appended to the specified file.

The /FULL option specifies that all output from the debugger be logged to the specified file in addition to all debugger commands. It is possible to log commands to one file and commands-and-output to another file. This would be done by the commands:

CodeWatch> LOG filel
CodeWatch> LOG /FULL file2

The NLOG command takes an optional file name that tells the debugger which log session to stop. If no file name is given, the debugger will first check if commands are being logged to a file (no /FULL). If so, that log session is stopped. If there is no such log session, the debugger checks to see if commands-and-output to a file (/FULL) are being logged. If so, that log session is stopped.

Example

CodeWatch> LOG temp
CodeWatch> FIND Main
77 REM       ** Main Program **
CodeWatch> BREAKPOINT 89
CodeWatch> PRINT 20
   77:            REM    ** Main Program **
   78:            INTEGER max_value, max_primes, n
   79:            REM      REAL a
   80:
   81:            max_value  = 1000
   82:            max_primes = 500
CodeWatch> NLOG
Ending debugger command logging to "temp"
CodeWatch> !cat temp
FIND Main
BREAKPOINT 89
PRINT 20
Parent topic: CodeWatch Commands
Related information
Nlog
Read


Lreturn

Use

Lists the return value of a function.

Command Syntax

LRETURN

Description

When the current execution point is at the exit point of a function, Lreturn prints the value to be returned by the function.

Example

In this example, the return value for the PRIMES function is listed.

CodeWatch> LRETURN
Return value for PRIMES is 15 {fixed binary (31)}
Parent topic: CodeWatch Commands
Related information
Return


Lsource

Use

Prints the name of the current source file being displayed.

Command Syntax

LSOURCE [/ALL] [/FULL]

The All, Full, Both, and Map buttons access the Lsource dialog. The Lsource dialog is for information only and no action may be executed. Specifying the Both button is the same as specifying both the /ALL and /FULL command-line options.

Description

The LSOURCE command prints the name of the source file currently being displayed as well as the time and date of its creation. If the source file being displayed does not contain the current evaluation environment, Lsource also displays the source file that does contain the current evaluation environment.

If the Full option is specified, the name of the symbol table file associated with the source file containing the current evaluation environment will also be displayed. If the All option is specified, all of the source files in the program being debugged that were compiled in debug mode will be displayed.

Example

In this example, the name of the symbol table file associated with the source file containing the current evaluation environment, the source file, and the source file currently being displayed are listed.

CodeWatch> LSOURCE
Current display source file is "primes.pl1" (PL/I) Apr 11 11:06:51 1991
Parent topic: CodeWatch Commands
Related information
Source


Lstep

Use

Lists the current stepping mode and the default action-list.

Command Syntax

LSTEP

Description

The LSTEP command lists the current mode of stepping, that is, either In or Over, the default action-list, and the default action-list to be executed when stepping to a breakpoint.

Example

In this example, the default stepping mode is in, the step action-list contains the Print command, and the action-list that will be executed upon stepping to a user breakpoint is the step action (Print).

CodeWatch> LSTEP
Step IN; Execute STEP action
Action = [PRINT;]
Parent topic: CodeWatch Commands
Related information
Dstep
Step


Ltrace

Use

Lists the current tracing mode.

Command Syntax

LTRACE

Description

The LTRACE command lists the current mode of tracing, that is, statement and/or entry.

Example

In this example, the current tracing mode is listed. Note that no conditional expression is specified.

CodeWatch> LTRACE
TRACE ENTRY [C;] /IF {}
Parent topic: CodeWatch Commands
Related information
Ntrace
Trace Entry
Trace Statement


Lwatch

Use

Lists information on watchpoints.

Command Syntax

LWATCH {variable|/ALL}

where:

variable
Specifies a variable in the source program

Description

The LWATCH command lists information on the given watchpoint. If /ALL is specified, information is listed on all watchpoints. The information listed includes the skip count, execution count (the number of times the watchpoint has been incurred), specified switch settings, and any specified action-list.

Example

In the following example, all of the existing watchpoints are listed.

CodeWatch> LWATCH /ALL
Watchpoint set for N (count = 1) /NSILENT /NIGNORE [C;]
Parent topic: CodeWatch Commands
Related information
Nwatch
Watch


Macro

Use

Defines a macro.

Command Syntax

MACRO macro-name = [action-list]

where:

action-list
Specifies a set of one or more CodeWatch commands separated by semicolons

Description

The MACRO command is used to define a macro as shorthand for an action-list. Sixty-four macros can be defined at any one time.

Note: Do not choose a macro name that is the same as a debugger command name, because the macro name will override the debugger command.

The action-list is specified in the usual way.

Once a macro has been defined, its name may be used just like any other debugger command name. The macro in the command line is replaced by the debugger commands specified in the action-list. Those commands are then executed normally.

If the last (or only) command in the action-list does not end with a semicolon, any additional arguments to that command can appear on a command line after the macro name. For example, suppose the following macro has been defined:

FOO = [ LET A = A + ]

The command FOO 3 can then be entered to add 3 to A.

Example

In this example, the macro info is defined that lists all breakpoints, the current evaluation environment, all macros, and the current execution point.

CodeWatch> MACRO info = [LB /ALL; LENV; LMACRO /ALL; WHERE]
CodeWatch> info
Break set at PRIME\118 (count = 2)
Break set at PRIMES.READ_INPUT\%ENTRY
Break set at PRIME.ISPRIME\%ENTRY (COUNT = 1)
Evaluation environment is PRIMES.ISPRIME
   info = [LB /ALL; LENV; LMA /ALL; WHERE]
Current execution point is PRIMES.ISPRIME\%EXIT

In the following example, the macro fig is defined to perform a case-insensitive search for the string you wish to specify as an argument.

CodeWatch> MACRO fig = [FIND /IGNORE]
CodeWatch> fig MAIN
  /* Main program */
Parent topic: CodeWatch Commands
Related information
Using Action Lists
Lmacro
Nmacro
Read
Save


Nbreakpoint

Use

Removes breakpoints.

Command Syntax

N BREAKPOINT [statement-id | /ALL ]

where:

statement-id
Is used to name the statement at which the breakpoint is to be removed

Description

The NBREAKPOINT command removes the breakpoint at the specified statement.

If the statement-id is omitted, the breakpoint at the current execution point is removed. If /ALL is specified, all breakpoints currently set are removed.

Example

In the following example, the breakpoint at line 94 is removed.

CodeWatch> NB 94

In the following example, all breakpoints are removed.

CodeWatch> NBREAKPOINT /ALL
Parent topic: CodeWatch Commands
Related information
Breakpoint
Lbreakpoint


Ncatch

Use

Prevents process control from returning to the debugger when the given signal is generated.

Command Syntax

NCATCH signal

where:

signal
Can be either a signal name mnemonic (such as SIGALRM, SIGINT, and so on) or the signal number corresponding to that signal. Signal names may be specified in either uppercase or lowercase

Description

The NCATCH command prevents process control from returning to the debugger when the given signal is generated. The child (user) process continues without interruption, as if the given signal had been generated. This implies that user-defined handlers will be executed.

Example

In the following example, the process control will not return from the child process to the debugger when a SIGALRM is generated.

CodeWatch> NCATCH SIGALRM
Changing SIGALRM to now not be caught.

As a result, Ncatch allows the child process to continue uninterrupted when a SIGALRM is generated. If the user process has its own signal handler for a SIGALRM, that signal handler will be executed.

Parent topic: CodeWatch Commands
Related information
Catch
Lcatch


Nload

Use

Kills the current child process.

Command Syntax

NLOAD

Description

Kills the current child process and purges the CodeWatch internal symbol table.

Example

CodeWatch> NLOAD
Parent topic: CodeWatch Commands
Related information
Attach
Detach
Kill
Load


Nlog

Use

Stops the logging of debugger commands and/or commands-and-output to a file or files.

Command Syntax

NLOG [filename]

where:

filename
Is the name of a log file specified in a previous LOG command

Description

The NLOG command ceases logging of debugger commands or commands-and-output to a file or files specified in the previous LOG command.

Example

CodeWatch> LOG temp
CodeWatch> FIND Main
77  REM      ** Main Program **
CodeWatch> BREAKPOINT 89
CodeWatch> PRINT 20
   77:           REM      ** Main Program **
   78:            INTEGER max_value, max_primes, n
   79:           REM      REAL a
   80:
   81:            max_value  = 1000
   82:            max_primes = 500
CodeWatch> NLOG
Ending debugger command logging to "temp"
The file "temp" will contain
CodeWatch> !cat temp
FIND Main
BREAKPOINT 89
PRINT 20
Parent topic: CodeWatch Commands
Related information
Log
Read


Nmacro

Use

Removes macro definitions.

Command Syntax

NMACRO {macro1, macro2, …, macron, | /ALL }

Description

The NMACRO command removes the definition of one or more specified macros or the definitions of all currently defined macros. Either the specific macro name(s) or /ALL must be specified.

Example

In this example, the macro named info is removed.

CodeWatch> NMACRO info

In this example, all macro definitions are removed.

CodeWatch> NMACRO /ALL
Parent topic: CodeWatch Commands
Related information
Lmacro
Macro


Nmap

Use

Reads the dynamic loader map and displays information about the currently loaded shared libraries.

Description

Shared library debugging has these limitations: CodeWatch does not dynamically monitor the dynamic load map. If a shared library is loaded into CodeWatch via the SHLIB command, and that library is being programmatically loaded and unloaded, you must manually load and unload the symbols via SHLIB and NSHLIB, since there is no guarantee that the library will always be mapped to the same virtual address. However, use of the NMAP command and noting load addresses will indicate whether this is actually necessary.

Parent topic: CodeWatch Commands


Nshlib

Use

Purges the symbols of the shared library specified by slibfile from the CodeWatch internal symbol table.

Parent topic: CodeWatch Commands


Ntrace

Use

Disables entry or statement tracing.

Command Syntax

NTRACE {ENTRY | STATEMENT}

Description

The NTRACE command disables entry or statement tracing. If ENTRY is specified, any action-list and condition are removed as well.

Example

In this example, TRACE STATEMENT is disabled.

CodeWatch> NTRACE STATEMENT
Parent topic: CodeWatch Commands
Related information
Ltrace
Trace Entry
Trace Statement


Nwatch

Use

Removes watchpoints.

Command Syntax

NWATCH {variable|/ALL}

where:

variable
Specifies the variable being watched

Description

The NWATCH command removes the watchpoint for the given variable. If /ALL is specified, all watchpoints currently set are removed.

Example

In the following example, the watchpoint for the variable n is removed from the current listing.

CodeWatch> LWATCH /ALL
Watchpoint set for n (count = 1) /NSILENT /NIGNORE [C;]
CodeWatch> NWATCH n
CodeWatch> LWATCH /ALL
No watchpoints are currently set.
Parent topic: CodeWatch Commands
Related information
Lwatch
Watch


Peek

Use

Displays the contents of a specified area of user memory in a specified format.

Command Syntax

PEEK [/TEXT  | /DATA]
     [/HEX   | /DECIMAL  | /OCTAL]
     [/LONG  | /SHORT    | /BYTE]
     [/count] address

where:

count
Is a numeric constant
address
Is a numeric constant. (For format information, see the following Description section.)

Description

The PEEK command displays the contents of a designated amount of user program memory in a designated format starting at a given address.

If the Text option is specified, the user text segment of the program is read.

If the Data option is specified, the user data segment of the program is read. The Data option is the default.

The base of the displayed memory may be specified as being hexadecimal or decimal, depending on the options /HEX or /DECIMAL, respectively. /HEX is the default.

The size of each displayed memory unit may be specified as being 4 bytes (32 bits), 2 bytes (16 bits), or 1 byte (8 bits) by specifying the options /LONG, /SHORT, or /BYTE, respectively. When the option /BYTE is specified, the ASCII representation of the byte is also displayed. /LONG is the default.

The number of memory units to be displayed may be specified by using the /count option. This consists of a slash "/" followed by a decimal number. A count of one is the default.

The format of the given address may be either hexadecimal or decimal, depending on how it is written. A hexadecimal number must begin with a 0x or 0X or contain at least one of the hexadecimal digits "a" through "f" (case in-sensitive). A decimal number may contain only any of the decimal digits "0" through "9".

Example

The following PEEK command displays five lines (4-bytes) in hexadecimal format beginning at address 0x23d8.

Initial evaluation environment is PGM:(inactive)
CodeWatch> p12
    1:  pgm: proc options(main);
    2:
    3:      dcl string char (32) varying;
    4:
    5:      string = 'Hello World.';
    6:
    7:      put skip list (string);
    8:
    9:      put skip list (string);
   10:  end;
   11:  BOTTOM
CodeWatch> b 7
CodeWatch> c
Break at PGM\7
CodeWatch> e addr(string)
FFBFF94E (hex)  {pointer}
CodeWatch> peek /data /byte /7 0xFFBFF94E
<data> 0xffbff94e: 0x00   <nul>
<data> 0xffbff94f: 0x0c   CTRL-L
<data> 0xffbff950: 0x48   H
<data> 0xffbff951: 0x65   e
<data> 0xffbff952: 0x6c   l
<data> 0xffbff953: 0x6c   l
<data> 0xffbff954: 0x6f   o
CodeWatch> peek /next
<data> 0xffbff955: 0x20   <space>
<data> 0xffbff956: 0x57   W
<data> 0xffbff957: 0x6f   o
<data> 0xffbff958: 0x72   r
<data> 0xffbff959: 0x6c   l
<data> 0xffbff95a: 0x64   d
<data> 0xffbff95b: 0x2e   .
CodeWatch> s

Hello World. Step at PGM\9     <Note: prints ‘Hello World.’ 12 chars>
CodeWatch> po
    9:      put skip list (string);
CodeWatch> poke /data /short 0xFFBFF94E,5
<data> 0xffbff94e: 0x000c ---> 0x0005
CodeWatch> s

Hello Step at PGM\10           <Note: prints ‘Hello’ 5 chars>
CodeWatch> q
CodeWatch Quit...Bye!
Parent topic: CodeWatch Commands
Related information
Evaluate
Poke
Watch


Point

Use

Resets and displays the source file pointer within the current source file.

Command Syntax

POINT [+n|–n|n]

where:

n
Is the line number you specify

Description

The POINT command relocates the source file pointer within the current source file and prints that line.

If a sign is specified, the debugger relocates the source file pointer to the line that is n lines before (–) or after (+) the current source file pointer. Otherwise, the debugger relocates the source file pointer to the line specified by n. The debugger then prints out the new pointed to line. If n is omitted, the source file pointer is reset to the current execution point, and that line is printed.

Example

In the following example, the source file pointer is reset to line 116 and displayed.

CodeWatch> POINT 116
  116:  call read input (n);

In this example, the source file pointer is reset to two lines before the current source file pointer, and that line is displayed.

CodeWatch> POINT -2
  114:  put skip (2);
Parent topic: CodeWatch Commands
Related information
Print


Poke

Use

Changes the contents of a specified area of user memory in a specified format.

Command Syntax

POKE [/TEXT | /DATA]
     [/LONG | /SHORT | /BYTE]
     address, data-value

where:

address
Is an address value specifying the memory location to examine. The address value has the same format as the data-value described below. The data segment is the default.
data-value
The format of the given data value (or address) may be either hexadecimal or decimal depending on how it is written. A hexadecimal number must begin with a 0x or 0X or contain at least one of the hexadecimal digits "a" through "f" (case in-sensitive). A decimal number may contain only any of the decimal digits "0" through "9”.

Description

The /BYTE, /SHORT, and /LONG options, used with integer values, specify the size of memory to be altered (1, 2, or 4 bytes, respectively). /LONG is the default.

Example

The following POKE command stores the hexadecimal value 99 at address 0x7FFFE480.

Initial evaluation environment is PGM:(inactive)
CodeWatch> p12
    1:  pgm: proc options(main);
    2:
    3:      dcl string char (32) varying;
    4:
    5:      string = 'Hello World.';
    6:
    7:      put skip list (string);
    8:
    9:      put skip list (string);
   10:  end;
   11:  BOTTOM
CodeWatch> b 7
CodeWatch> c
Break at PGM\7
CodeWatch> e addr(string)
FFBFF94E (hex)  {pointer}
CodeWatch> peek /data /byte /7 0xFFBFF94E
<data> 0xffbff94e: 0x00   <nul>
<data> 0xffbff94f: 0x0c   CTRL-L
<data> 0xffbff950: 0x48   H
<data> 0xffbff951: 0x65   e
<data> 0xffbff952: 0x6c   l
<data> 0xffbff953: 0x6c   l
<data> 0xffbff954: 0x6f   o
CodeWatch> peek /next
<data> 0xffbff955: 0x20   <space>
<data> 0xffbff956: 0x57   W
<data> 0xffbff957: 0x6f   o
<data> 0xffbff958: 0x72   r
<data> 0xffbff959: 0x6c   l
<data> 0xffbff95a: 0x64   d
<data> 0xffbff95b: 0x2e   .
CodeWatch> s

Hello World. Step at PGM\9     <Note: prints ‘Hello World.’ 12 chars>
CodeWatch> po
    9:      put skip list (string);
CodeWatch> poke /data /short 0xFFBFF94E,5
<data> 0xffbff94e: 0x000c ---> 0x0005
CodeWatch> s

Hello Step at PGM\10           <Note: prints ‘Hello’ 5 chars>
CodeWatch> q
CodeWatch Quit...Bye!
Parent topic: CodeWatch Commands
Related information
Evaluate
Peek
Watch


Print

Use

Prints the next line or a number of lines.

Command Syntax

Print x

or

P x

where x is the number of lines that are going to be printed. x is optional and if it is omitted, only one line will be printed.

Description

Print displays a line or a number of lines in the output window. If you want to print a number of lines, specify the number after the PRINT command.

Example

This example shows the output of PRINT:

CodeWatch> P
  119: do while (n > 1);

Teh following exampel shows the output of PRINT plus a specified number of lines:

CodeWatch> PRINT 15
109       /* main procedure */
110
111       declare n fixed binary(31);
112
113       put skip;
114       put list (' *** Sieve of Eratosthenes ***');
115       put skip (2);
116
117       call read_input(n);
118
119       do while (n > 1);
120          call sift(n);
121          call read_input(n);
122       end;
123
124   end;
Parent topic: CodeWatch Commands


Quit

Use

Terminates a debugging session.

Command Syntax

QUIT

Description

Quit causes termination of the debugging session. Selecting the Exit item in the File menu is equivalent to issuing the QUIT command.

Example

This example shows the message the debugger displays as it exits.

CodeWatch> QUIT
CodeWatch Quit ... Bye!
Parent topic: CodeWatch Commands
Related information
Save


Read

Use

Reads and executes debugger commands from a specified file.

Command Syntax

READ filename

where:

filename
Is any file containing debugger commands. If the file is not in the current working directory, its pathname must be specified

Description

The READ command is used to execute debugger commands, which are contained in the specified filename. Each command is printed to the terminal as it is executed. Seven levels of Read commands may be nested in debugger command files.

Example

In this example, debugger commands are read in from a file called dbg. After all the commands are read and executed, the debugger prompts for the next command to be entered.

CodeWatch> READ dbg
**** Reading commands from "dbg" ...
CodeWatch> BREAKPOINT PRIMES\119 /SKIP=0
CodeWatch> BREAKPOINT PRIMES.READ_INPUT\%ENTRY /SKIP=0 [e maxv;]
CodeWatch> BREAKPOINT PRIMES.ISPRIME\%ENTRY /SKIP=0
CodeWatch> BREAKPOINT PRIMES.PRINT_OUT\60 /SKIP=0
CodeWatch> BREAKPOINT PRIMES.PRINT_OUT\59 /SKIP=0
CodeWatch> MACRO info=[ lb /a;lenv;lma /a; where ]
CodeWatch>
**** Done reading commands from "dbg"
Parent topic: CodeWatch Commands
Related information
Log
Nlog
Save


Registers

Use

Displays the contents of the general machine registers.

Command Syntax

REGISTERS

Description

The REGISTERS command displays the contents of all the machine registers as long hexadecimal values. Floating-point registers may or may not be displayed, depending on the target.

Example

The following input from the REGISTERS command is target-specific and may not match what is displayed on your system.

CodeWatch> REGISTERS

D0: 0x0000003C D1: 0x00000004 D2: 0x00000001 D3:0x00000000
D4: 0x00000000 D5: 0x00000000 D6: 0x00000000 D7:0x00000000
A0: 0x0EFFFD94 A1: 0x0002037C A2: 0x00000000 A3:0x0EFFFDC8
A4: 0x0EFFFDD0 A5: 0x00000000 A6: 0x0EFFFDB0 A7:0x0EFFFD90
SR: 0x00000000 PC: 0x000023D8

FO: 0x7FFF0000FFFFFFFFFFFFFFFF F1: 0x7FFF0000FFFFFFFFFFFFFFFF
F2: 0x7FFF0000FFFFFFFFFFFFFFFF F3: 0x7FFF0000FFFFFFFFFFFFFFFF
F4: 0x7FFF0000FFFFFFFFFFFFFFFF F5: 0x7FFF0000FFFFFFFFFFFFFFFF
F6: 0x7FFF0000FFFFFFFFFFFFFFFF F7: 0x7FFF0000FFFFFFFFFFFFFFFF

FPCR: 0x0000F400 FPSR: 0x00000000 FPIAR: 0x00000000
Parent topic: CodeWatch Commands


Reload

Use

Reloads the user program.

Command Syntax

RELOAD [/ARGUMENTS command-line-arguments]
       [/NEWARG command-line-arguments]
       [< filename]
       [> filename]

where:

command-line-arguments
Is a list of text strings to be passed to the user program as its arguments. This must be the last option on the RELOAD command line
filename
Is the pathname of any file

Description

The RELOAD command will reinitialize the user program while preserving any explicitly set breakpoints and any associated action lists. All breakpoint counters will be reset to zero.

A subsequent Continue or Step will execute the user program from the beginning.

Example

In this example, the debugging session is restarted in the original evaluation environment, with all breakpoints preserved and without returning to the system level.

CodeWatch> RELOAD
Command line : "primes"
Reloading..ok
Initial evaluation environment is PRIMES:(inactive)
CodeWatch>

In this example, user program output is redirected to the file primes.out

CodeWatch> RELOAD > primes.out
Reloading..ok
Initial evaluation environment is PRIMES:(inactive)
CodeWatch>
  • Changing Command-line Arguments
  • Redirecting User Program I/O
  • Redirecting I/O Back to the Terminal
Parent topic: CodeWatch Commands
Related information
Arguments
Continue
Step


Changing Command-line Arguments

If the Arguments option is not specified, the program will be initialized with the command-line arguments specified when CodeWatch was invoked. If the Arguments option is specified, the given arguments will be used as command-line arguments to the reinitialized program. If more than one argument is specified, they must be separated by a space. These command-line arguments will be in effect until the next time the program reloads.

If you want to permanently change the command-line arguments of the program being debugged, that is, for the remainder of the debugging session, this is possible using the /NEWARG command-line option. This specifies that the given command-line arguments be used for the remainder of the debugging session. These may be reset by again using the /ARGUMENTS or /NEWARG command-line options.

Parent topic: Reload


Redirecting User Program I/O

User program input may be redirected by either specifying the command-line option < filename or by entering a file name in the Stdin edit field of the Reload dialog box.

User program output may be redirected by either specifying the command-line option > filename or by entering a file name in the Stdout edit field of the Reload dialog box. Any error opening filename for either input or output will result in an error message and CodeWatch exiting.

Note:

In the RELOAD command-line syntax, there must be a space between the "<" or the ">" and the file name.

By default, user input and output is redirected to and from the xterm window from which CodeWatch was invoked. However, this may be changed using the RELOAD command.

Parent topic: Reload


Redirecting I/O Back to the Terminal

It is possible to redirect input or output back to the terminal after having redirected it elsewhere. To do this, specify the following:

RELOAD < /dev/tty

or:

RELOAD > /dev/tty

for input and output, respectively.

Parent topic: Reload


Return

Use

Transfers the execution pointer to the exit point of the current procedure and allows a return value to be set.

Command Syntax

RETURN [expression]

where:

expression
Can be any expression that may occur in the source language program, including references to simple as well as aggregate (such as array, record, and structure elements) type variables

Description

The RETURN command transfers the current execution pointer to the exit point (%EXIT) of the current procedure. If the procedure returns a value, an expression indicating the return value must be given. An expression should not be given if the procedure does not return a value.

If the current execution point is already at the exit point of the current procedure, no action is taken if the procedure does not return a value, or the return value is set to the given expression if the procedure does return a value.

Example

In this example, the return value of the ISPRIME routine is set to "15".

CodeWatch> RETURN 15
CodeWatch> LRETURN
Return value for PRIMES.ISPRIME is 15 {fixed binary(31)}
Parent topic: CodeWatch Commands
Related information
Lreturn


Save

Use

Writes out commands to reset all currently set breakpoints, watchpoints, and/or macros to a specified file.

Command Syntax

SAVE [{/BREAKPOINT |/WATCH |/MACRO}…|/ALL]
     filename

where:

filename
Is the specified file that will contain the breakpoints, watchpoints, and/or macros settings

Description

The SAVE command writes out commands to a specified disk file to reset all current breakpoint, watchpoint, and/or macro settings for use in a later debugging session. The file can be read in by using the READ command.

If no options or the All option is specified, commands to reproduce all breakpoint, watchpoint, and macro settings will be written to the specified file.

If the Breakpoint option is specified, the breakpoint commands for all current breakpoint settings will be written to the specified file. If the Watch option is specified, the watchpoint commands for all current watchpoint settings will be written to the specified file. If the Macro option is specified, the macro commands for all current macros will be written to the specified file. Any combination of Breakpoint, Watch, and Macro may be used.

The SAVE command will create, not append, the specified file. If the file already exists, the Save will fail and an error will be issued. For more information, see the section Read.

Example

In this example, two debugging sessions are used to demonstrate the SAVE command. In the first session, macros, breakpoints, and watchpoints are saved in the dbg file; in the second session, the saved commands are read from the dbg file.

Session one:

$ cwcmd primes
CodeWatch setting up "primes". Wait...

CodeWatch> BREAKPOINT PRIMES\114
CodeWatch> BREAKPOINT PRIMES\119
CodeWatch> BREAKPOINT PRIMES.READ_INPUT\%ENTRY [E maxv;]
CodeWatch> BREAKPOINT PRIMES.ISPRIME\%ENTRY
CodeWatch> WATCH N /ACTION [C;]
CodeWatch> MACRO fig = [FIND /IGNORE]
CodeWatch> MACRO info=[ LB /A;LENV;LMA /A; WHERE ]
CodeWatch> SAVE dbg
Environment saved to file "dbg"
CodeWatch> QUIT

Session two:

$ cwcmd primes
CodeWatch setting up "primes". Wait...

CodeWatch> READ dbg
**** Reading commands from "dbg" ...
CodeWatch> BREAKPOINT PRIMES\114 /SKIP=0
CodeWatch> BREAKPOINT PRIMES\119 /SKIP=0
CodeWatch> BREAKPOINT PRIMES.READ_INPUT\%ENTRY /SKIP=0 [E maxv;]
CodeWatch> BREAKPOINT PRIMES.ISPRIME\%ENTRY /SKIP=0
CodeWatch> WATCH N /ACTION [C;]
CodeWatch> MACRO fig = [FIND /IGNORE]
CodeWatch> MACRO info = [ LB /A;LENV;LMA /A; WHERE ]
CodeWatch>
**** Done reading commands from "dbg"
Parent topic: CodeWatch Commands
Related information
Read
Breakpoint
Macro
Watch


Shlib

Use

Loads the symbols from the specified shared library, slibfile, into the CodeWatch internal symbol table.

Description

If slibfile is compiled using the -deb option, the command ENV displays the shared library source and other normal symbolic debugging.

If slibfile is specified with a simple filename, such as file.sl, CodeWatch first searches the current directory for this shared library. Failing that, it uses the search path indicated by the LD_LIBRARY_PATH environment variable on Solaris 2 (which is the same variable that is used by the dynamic loader). If using the -L option at link time to specify library locations, slibfile must specify the full pathname for the shared library.

When executed, SHLIB attempts to load all the debug symbols for a .so (UNIX/Linux) or .dll (Windows). If SHLIB is not fully qualified, for example SHLIB MYSO.so, then any paths specified by the CODEWATCH_STBPATH environment variable are used to search for the .stb. If SHLIB is fully qualified, for example SHLIB /home1/hub/staff/opli/steplib1/MYSO.so, then the directory containing the shared object is searched first. If unsuccessful, any paths specified by CODEWATCH_STBPATH are used.

CODEWATCH_SRCPATH must be set to include the directories where the source resides. It does not look in directories referenced by the SHLIB command.

Parent topic: CodeWatch Commands


Source

Use

Changes the current source file to be displayed.

Command Syntax

SOURCE [filename]

where:

filename
Is the name of the source file to be displayed

Description

The SOURCE command changes the source file to be displayed. This may be used, for instance, when you want to look at the contents of "COPY" or "INCLUDE" files. Referencing these files is discussed in the section Referencing Included or Copied Files in the chapter Debugging Concepts.

If the filename is omitted, the current source file is set to the source file associated with the current execution point. The current source file pointer is not explicitly set. To reset the current source file pointer to the current execution pointer, use Environment without any arguments.

Activation of the SOURCE command applies to the current debugger action only. Its effect is lost when the program resumes execution; that is, the current source file is set to the source file associated with the current execution point.

Example

In the following example, the source file from which lines are to be displayed is var.in. The LSOURCE command prints the name of the current source file as well as the name of the source file for the current environment, because it is different.

CodeWatch> SOURCE var.in
CodeWatch> LSOURCE
Current display source file is "var.in"
Source file of current environment is "x.pl1"
Current display source file is "var.in" (PL/I) Apr 11 11 :06 :51 1991
Parent topic: CodeWatch Commands
Related information
Referencing Included or Copied Files
Lsource


Stack

Use

Displays information on a specified number of stack frames.

Command Syntax

STACK [nframes|/ALL]
      [/FULL]
      [/ARGUMENTS]
      [/LOCALS]

where:

nframes
Is an integer specifying the count of the most recent stack frames to be displayed

Description

The STACK command is used to display information on a specified number of stack frames.

If the All option is specified, all stack frames back to your main program are displayed. There are typically a number of system start-up routines called before your main program. The frames for these start-up routines will not be displayed unless the Full option is specified. The Full option is useful only if specified in conjunction with a specified Count or the All option. If neither a specified Count nor the All option is present, only the current stack frame is displayed.

If the Arguments option is specified, the arguments to each procedure are displayed.

If the Locals option is specified, all local variables for each stack frame are displayed.

Example

In this example, information is displayed on all stack frames and the arguments to each procedure.

CodeWatch> STACK /ARGUMENT /ALL

Stack contains 5 frame(s).
Current execution point is PRIMES.SIFT\94

5: Owner is "PRIMES.SIFT"
   Arguments:
     N = 10 {fixed binary (31)}
   Called from PRIMES\119

4: Owner is "PRIMES"
   Arguments: None
   Main program
Parent topic: CodeWatch Commands
Related information
Arguments
Environment


Step

Use

Executes a specified number of statements.

Command Syntax

STEP [OUT]
     [IN|OVER]
     [count]
     [[action-list]]

where:

count
Is an integer specifying the number of statements to be executed

Description

action-list specifies a set of one or more CodeWatch commands separated by semicolons.

The STEP command starts program execution at the current location of the execution pointer and stops execution after one or a specified number of statements.

To execute a single statement, use Step with no options specified. To execute a number of statements, specify a count parameter.

If Step Out is specified, the debugger steps to the exit point of the current routine. If Step Out is specified with a count parameter, the first step is to the exit point of the current routine, and each step thereafter is to a succeeding statement in the calling routine. Thus, if the execution pointer is in a called routine and you want to step to the next executable statement in the calling routine, issue STEP OUT 2. The first step is to the exit point of the current routine, and the second step returns and steps forward in the calling routine. If the execution pointer is already at the exit point of the called routine, issuing Step Out causes the execution pointer to step to the exit point of the calling routine.

If Step In is specified and the current execution point is at a subroutine call, the debugger steps to the entry point of the called routine. If Step In is specified with a count parameter, the entry point is the first step, the first executable statement is another, and so on.

If Step Over is specified, the debugger steps over calls to routines. Step Over is the default mode for the STEP command.

If an action-list is present, it is performed at the last step and is set as the action to be taken for any other Step. To remove the Step action-list, supply a null action-list as an argument to Step. Use the DSTEP command to do this without stepping.

At the completion of a step operation, the debugger issues a message indicating the current execution point in the following format:

Step at x

where x is the location of the current execution point, that is, the statement that is about to be executed.

Note:

Step cannot be used when the current execution point of the user program is at a non-local Goto.

Example

In the following example, the default stepping mode is set to step in and the stepping action-list is set to print the current source line. Two step commands are executed (the second command with a count of 2).

CodeWatch> DSTEP IN [P]
CodeWatch> STEP
Step at PRIMES.SIFT\95
  95: primes(count) = this_prime;
CodeWatch> S 2
Step at PRIMES.SIFT\97
  97: do while (k < n);

In the following example, the debugger steps out of the sift routine.

CodeWatch> STEP OUT
Number of primes found was (prime) 5

1  2  3    5  7

Step at PRIMES.SIFT\%EXIT
  106: end sift;
Parent topic: CodeWatch Commands
Related information
Continue
Dstep
Lstep


Trace Entry

Use

Displays all procedure and block entries information during program execution.

Command Syntax

TRACE ENTRY [[action-list]]
            [/IF {logical-expr}]

where:

action-list
Specifies a set of one or more CodeWatch commands separated by semicolons
logical-expr
Can be any expression that may occur in the source language program, including references to simple as well as aggregate (such as array, record, and structure elements) type variables, returning a boolean value

Description

Tracing enables information about all procedure and block entries to be reported as the program executes.

The TRACE ENTRY command sets tracepoints, which enable tracing of all procedure and block entries by printing a message each time a procedure or block is entered.

When entry tracing is enabled, the debugger will be activated as each procedure or block is entered, and activated again as each procedure or block is exited. The specified action-list applies only to the entry tracepoint; exit tracepoints always print a message and continue.

If an action-list is specified, the debugger will process the commands and print the results. If an action-list is omitted, a default action-list of [CONTINUE] is supplied. A common action-list is [ARGUMENTS; CONTINUE]. An action-list may not refer to statements or variables in a way that is dependent on scope. To take a breakpoint and enter interactive debugging at each entry, supply an explicit null action-list, that is, TRACE ENTRY [ ] .

If a conditional expression is specified, each time an entry point is reached, the value of the expression is evaluated, and if it is true, the message is printed; if it is false, no message is printed.

Example

In the following example, entry tracing is turned on and program execution is continued.

CodeWatch> TRACE ENTRY
CodeWatch> C
Input maximum prime boundary: 10
**** PRIMES.READ_INPUT\%EXIT
Break at PRIMES\119
  • Animating the Program in the Source Window
Parent topic: CodeWatch Commands
Related information
Continue
Ltrace
Ntrace
Trace Statement


Animating the Program in the Source Window

In the graphical interface, the TRACE ENTRY command is especially useful because it allows you to watch your code execute. Rather than simply issuing a message as entry and exit points are reached, CodeWatch updates the Source window with the source file for the current environment and highlights the line corresponding to each entry or exit point.

Parent topic: Trace Entry


Trace Statement

Use

Displays each source statement as it is executed.

Command Syntax

TRACE STATEMENT

Description

The TRACE STATEMENT command sets tracepoints, which enable the tracing of every statement by printing a message identifying the statement.

At each statement, if there is no other action to be performed (that is, if there is no breakpoint, entry trace, single step action, and so on), the identifying message is printed and execution continues.

Example

In the following example, statement tracing is turned on and program execution is continued.

CodeWatch> TRACE STATEMENT
CodeWatch> CONTINUE
**** PRIMES\112
**** PRIMES\113
Break at PRIMES\114
  • Animating the Program in the Source Window
Parent topic: CodeWatch Commands
Related information
Continue
Ltrace
Ntrace
Trace Entry


Animating the Program in the Source Window

In the graphical interface, the Trace Statement command is especially useful because it allows you to watch your code execute. Rather than simply issuing a message as statements are reached, CodeWatch updates the Source window with the source file for the current environment and highlights each line as it executes.

Parent topic: Trace Statement


Type

Use

Displays the resultant type of an expression.

Command Syntax

TYPE [/FULL] expression

where:

expression
Can be any expression that may occur in the source language program, including references to simple as well as aggregate (such as array, record, and structure elements) type variables

Description

The TYPE command prints the resultant type of an expression.

If the expression refers to a structure or record, the Full option can be used to display the entire structure or record.

Example

In the following example, declaration information about various data items is displayed.

CodeWatch> TYPE COUNT
COUNT fixed binary (31) automatic
CodeWatch> TY FLAGS
FLAGS(1:1000) bit (1) automatic
Parent topic: CodeWatch Commands


Watch

Use

Sets watchpoints on specified variables.

Command Syntax

WATCH variable
      [/SILENT|/NSILENT]
      [/IGNORE|/NIGNORE]
      [/SKIP=n]
      [/ACTION[action-list]
      [/IF{logical-expr}]

where:

variable
Specifies the variable to be watched
n
Is the value you assign to the skip counter
action-list
Specifies a set of one or more CodeWatch commands separated by semicolons
logical-expr
Can be any expression that may occur in the source language program, including references to simple as well as aggregate (such as array, record, and structure elements) type variables, returning a boolean value

Description

Watchpoints are used to monitor any changes to data. The WATCH command designates the given variable to be watched. When the contents of the watched variable change, program execution stops and control is returned to the debugger.

  • Suppressing the Watchpoint Message
  • Temporarily Ignoring Watchpoints
  • Skipping a Watchpoint Multiple Times
  • Watchpoints with Action Lists
  • Conditional Watchpoints
  • Incurring Watchpoints
Parent topic: CodeWatch Commands


Suppressing the Watchpoint Message

The Silent option will not output modified variables when a watchpoint is encountered; the output simply reports that the program has stopped because of a watchpoint. Turning off the Silent option allows the debugger to output the modified variable, the location of the change, and the old and new values of the watched variable.

Parent topic: Watch


Temporarily Ignoring Watchpoints

The Ignore option allows the debugger to disregard a watched variable. In other words, when the given watchpoint is encountered, it will not be reported and the program will continue without interruption. Turning off the Ignore option allows the debugger to recognize and report any occurrence of the given watchpoint.

Parent topic: Watch


Skipping a Watchpoint Multiple Times

A watchpoint counter is associated with each watchpoint. When the watchpoint is created, the counter is set to zero; each time the watchpoint is incurred, the counter is incremented by one. When a program is reloaded, all counters are set to zero.

The Skip option assigns a watchpoint skip counter to the given variable, which is set to the value you specify. As a result, the watchpoint will be skipped the specified number of times. Once the watchpoint skip counter is set, it remains in effect until the value decreases (resets) to zero.

Parent topic: Watch


Watchpoints with Action Lists

An action-list is one or more debugger commands separated by a semicolon, which may specify that program execution is to continue. Any specified action-list is executed when a watchpoint is incurred.

Note:

It is not necessary to enclose the action list for the Watch dialog in square brackets (as is necessary for the command syntax).

Parent topic: Watch


Conditional Watchpoints

A conditional expression may be used to qualify the watchpoint; it must be the last option on the command line. When a watchpoint with the If option is set, the executing program will be suspended and the debugger will be activated whenever the watched variable is changed. The IF condition is then evaluated. The evaluation always takes place in the environment and language of the program statement. If the IF condition is false, program execution continues and the watchpoint is never reported. If the IF condition is true, the debugger incurs a watchpoint as usual.

Parent topic: Watch


Incurring Watchpoints

Description

A watchpoint is incurred when a watched variable has changed, the skip counter is either zero or not specified, and the Ignore option is not specified. When a watchpoint is encountered, the following occurs:

  • If an IF condition is specified, it is evaluated.
  • The watchpoint counter is incremented.
  • If the Ignore option is set for the given watchpoint, execution continues.
  • If the skip count for this watchpoint is non-zero, the count is decremented and execution is continued; the skip count for an ignored watchpoint is not affected.
  • The debugger announces the occurrence of the watchpoint. Output from the WATCH command includes the block name, the activation number, the line number where the change occurred, and the new and old hexadecimal values of the variable.
  • If an action-list is specified, it is executed.
  • The debugger prompt appears on the screen.

Example

In the following example, a watchpoint is set on variable n with an action-list to continue program execution. The value of n is input from the user.

CodeWatch> WATCH n /ACTION [C]
CodeWatch> CONTINUE

Input maximum prime boundary: 10
Program Stopped due to a Watchpoint
Watched variable N modified about line PRIMES\118
New Value: 10 {fixed binary (31)}
Break at PRIME\119
Parent topic: Watch
Related reference
Lwatch
Nwatch
Read
Save


Where

Use

Displays either the current execution point or the location of a specified statement.

Command Syntax

WHERE [statement-id]

where:

statement-id
Is a statement label or a source line number

Description

The WHERE command prints a location as the name of a routine followed by a statement label.

If the statement identifier is a statement label, the name of the routine containing the label and the source line number of the label are printed. If the statement identifier is a source line number, the name of the routine is printed. If the statement identifier argument is omitted, the name of the routine and the line number of the current execution point are printed.

Example

In the following example, the next executable statement is located and the location is displayed.

CodeWatch> WHERE 108
Line 108 is not an executable statement ...
WHERE using statement PRIMES\112 instead.
PRIMES\112

In this example, the current execution point is displayed.

CodeWatch> WHERE
Current execution point is PRIMES.READ_INPUT\%ENTRY
Parent topic: CodeWatch Commands
Related information
Lenvironment
Point


!

Use

Invokes the host operating system command interpreter to perform a specified command. This command is available only on UNIX systems.

Command Syntax

! command
(Press <Return> to continue)

Description

The ! command invokes the command interpreter to read the remainder of the line following the ! command. Refer to your UNIX documentation for information on UNIX commands.

The ! command followed by the UNIX sh command pushes to a new command interpreter. To return to the debugger, type <Ctrl D> or exit.

Example

In this example, the UNIX pwd command is invoked, which lists the current working directory.

CodeWatch> !pwd
/usr/hicks/pllprogs
Parent topic: CodeWatch Commands


Debugging Open PL/I Programs

  • Program Blocks
  • Built-in Function Support
  • Referencing Arrays and Aggregate Structures
  • Support for Open PL/I Include Files
  • Sample CodeWatch Session Using Open PL/I
  • Program Listing
Parent topic: CodeWatch User's Guide


Program Blocks

Program blocks are units of code that provide scope and context for the debugger. An Open PL/I program block is a procedure block or a BEGIN block.

  • Block Names
  • Referencing Nested Blocks
Parent topic: Debugging Open PL/I Programs


Block Names

A procedure block is referred to by the name of that procedure. A begin block is referred to by its label (if present) or by the string %BEGIN followed immediately by the line number on which the block begins. For example, an unlabeled begin block that starts on line 119 of the source file is referred to as %BEGIN119.

Parent topic: Program Blocks


Referencing Nested Blocks

Open PL/I program blocks may be nested. Rules for naming nested blocks are as follows:

  1. If a block defined within the compilation unit is contained within or contains the debugger's current evaluation environment, the block may be referred to simply by its name. The name may need to be qualified to make it unique within the external procedure.

    If the block contains the debugger's current evaluation environment, the search for the referenced block begins from the current environment and continues through each successive containing (parent) block until the referenced block is found.

  2. If a block is in some other external procedure, it must be qualified with at least the external procedure name, and it may require further qualification. Furthermore, a fully qualified name to a block in some other external procedure may be the same as a partially qualified block name in the current procedure. To force the debugger to search outside the current procedure, qualify the block name with %EXTERN. (This is seldom necessary if ambiguous naming is avoided.)

    For example:

    A: proc;        /* 1 */        B: proc;             /* 8 */
  B: proc;      /* 2 */          C: proc;           /* 9 */
    C: proc;    /* 3 */            D: proc;         /* 10 */
      D: proc;  /* 4 */            end D;
      end D;                     end C;
    end C;                         B: proc;         /* 11 */
  end B;                             A: proc;       /* 12 */
  C: proc:      /* 5 */                A: proc      /* 13 */
    B: proc;    /* 6 */                  B: proc;   /* 14 */
      C:proc;   /* 7 */                  end B;
      end C;                           end A;
    end B;                           end A;
  end C;                           end B;
end A;                          end B;

The following describes how each block can be referenced given the current evaluation environment in the external procedure %EXTERN.A (block 1).

Block
 | Reference
1 | A or %EXTERN.A
2 | A.B, B, or %EXTERN.A.B
3 | B.C, A.B.C, or %EXTERN.A.B.C.
4 | D, C.D, B.C.D, A.B.C.D, %EXTERN.A.B.C.D, B.D, A.B.D, %EXTERN.A.B.D, A.D, or %EXTERN.A.D
5 | C, A.C, or %EXTERN.A.C
6 | C.B, A.C.B, or %EXTERN.A.C.B
7 | C.C, C.B.C, A.C.C, %EXTERN.A.C.C, A.C.B.C, or %EXTERN.A.C.B.C
8 | %EXTERN.B
9 | %EXTERN.B.C
10 | %EXTERN.B.D, or %EXTERN.B.C.D
11 | B.B or %EXTERN.B.B
12 | B.B.A or %EXTERN.B.B.A
13 | B.A.AB.B.A.A, %EXTERN.B.A.A, or %EXTERN.B.B.A.A
14 | B.B.B B.A.B B.A.A.B, B.B.A.B, %EXTERN.B.B.B, %EXTERN.B.A.B, %EXTERN.B.A.A.B, %EXTERN.B.B.A.B, or%EXTERN.B.B.A.A.B

If the current evaluation environment is in the internal procedure block %EXTERN.A.B.C.D (block 4), the following is true in the debugger:

B | refers to block 2
B.C | refers to block 3
C | refers to block 3
%EXTERN.B.A | is an ambiguous reference (block 12 or 13)
%EXTERN.B.B.A | refers to block 12
%EXTERN.B.C | refers to block 9

If the current evaluation environment is in the external procedure block %EXTERN.B (block 8), the following is true in the debugger:

A.B.C.D | refers to block 1
A | is an ambiguous reference (block 12 or 13)
B | refers to block 11
B.A | refers to block 12
A.B | refers to block 14
B.A.B | refers to block 14
Parent topic: Program Blocks


Built-in Function Support

The following PL/I built-in functions are supported by CodeWatch:

ADD | COLLATE | HBOUND | NULL
ADDR | COPY | HIGH | RANK
BINARY | DECIMAL | LBOUND | SUBSTR
BIT | DIMENSION | LENGTH | TRIM
BYTE | FIXED | LOW | UNSPEC
CHARACTER | FLOAT | MULTIPLY | VERIFY

The following abbreviations for PL/I built-in functions are recognized:

  • BIN for BINARY
  • CHAR for CHARACTER
  • DEC for DECIMAL
  • DIM for DIMENSION
Parent topic: Debugging Open PL/I Programs


Referencing Arrays and Aggregate Structures

Arrays and aggregate structures can be referenced in their entirety by referring to them by their array or structure name, or individual subfields or members can be referenced using the conventional PL/I syntax, as in REC_NAME.FIELD. A subfield can be referenced directly as long as its name is unique.

A specified range of an array can be evaluated using the following command-line syntax:

EVALUATE array-name [m:n]

or

EVALUATE array-name (m:n)

where m is the starting point of the array range and n is the ending point of the array range.

An asterisk (*) specifies that all elements of a dimension are to be evaluated. For example:

EVALUATE array-name[*,3:5]

or

EVALUATE array-name(*,3:5)

displays the third through fifth columns of all the rows in a two-dimensional array.

Specifying only the array name for PL/I will cause the evaluation of every element of every dimension of the array. Similarly, specifying a structure, record, or group name will cause the evaluation of every member of the group.

Parent topic: Debugging Open PL/I Programs


Support for Open PL/I Include Files

The following list describes the rules applying to CodeWatch support for Open PL/I include files. This support applies to include files that contain executable code. The rules are as follows:

  • Stepping into an include file, for example, when the next statement is a %INCLUDE directive, will cause the screen display to switch to the specified include file.
  • Commands that deal with the source file, such as PRINT and POINT, work as expected when using the current include file.
  • Stepping through an include file is allowed.
  • Setting breakpoints within an include file is NOT allowed. The setting of a breakpoint unambiguously refers to the original containing source file.
  • Stepping over an include file, for example, when the next statement is a %INCLUDE directive, is not explicitly allowed. This may may be accomplished by setting a breakpoint in the containing source file followed by the CONTINUE command.
  • Stepping out of an include file before its last statement is accomplished similarly to stepping over, that is, by setting a breakpoint in the containing source file followed by the CONTINUE command.
  • Using CodeWatch with the Open PL/I Macro Preprocessor
Parent topic: Debugging Open PL/I Programs


Using CodeWatch with the Open PL/I Macro Preprocessor

CodeWatch can be used with PL/I programs to which the Open PL/I macro preprocessor mfpp has been applied. CodeWatch uses the original source file (rather than the expanded preprocessed output of mfpp). Stepping through macros works similarly to the include file support described for include files.

Parent topic: Support for Open PL/I Include Files


Sample CodeWatch Session Using Open PL/I

This debugging session illustrates how to use the commands and features of CodeWatch when debugging programs compiled with Open PL/I. Following the session is the source listing of the sample PL/I program. The source file for this program is also available on the CodeWatch installation media.

The sample program, primes.pl1, calculates the number of prime numbers within a given range, but it doesn't do it very well. There is a bug somewhere that causes the program to print out too many values. Observe the following output:

*** Sieve of Eratosthenes ***

Input maximum prime boundary:
10
Number of primes found was     6
1      2      3      5      7      11

The program had been compiled using the -deb option to produce the necessary information for the debugger and the -l option to produce a listing file. It was then linked using Ipild. For example,

mfpli primes.pl1 -deb -l
ldpli primes.o -o primes

In this sample session, comments (which are not part of the session) are the bullet items. The system prompt is $. Note that user-supplied text is in bold typewriter font. For clarity, the abbreviated form of the command is used only after the command has been previously spelled out in its entirety.

  • Invoke CodeWatch at the system prompt.
    $ cwcmd primes

******************************************************************************
* CodeWatch, 08.00                                                           *
* ----------------                                                           *
* Copyright 2009 Micro Focus                                   *
******************************************************************************
Initial evaluation environment is PRIMES:(inactive)
  • Find the string "main".
    CodeWatch> FIND main
  109:    /* main procedure */
  • Print 20 lines.
    CodeWatch> PRINT 15
109       /* main procedure */
110
111       declare n fixed binary(31);
112
113       put skip;
114       put list (' *** Sieve of Eratosthenes ***');
115       put skip (2);
116
117       call read_input(n);
118
119       do while (n > 1);
120          call sift(n);
121          call read_input(n);
122       end;
123
124   end;
  • The program calls read_input on line 117 to get user input, so set a break at line 119 to see if things are still working correctly.
    CodeWatch> BREAK 119
  • Continue to the breakpoint. The program will request input; enter 10.
    CodeWatch> CONTINUE

*** Sieve of Eratosthenes ***

Input maximum prime boundary:
10
Break at PRIMES\119
  • Print a line of text. Evaluate n, which is the variable read in on line 117.
    CodeWatch> P
  119: do while (n > 1);
CodeWatch> EVALUATE n
N = 10 {fixed binary (31)}
  • Access the declaration type of n.
    CodeWatch> TYPE n
N fixed binary (31) automatic
  • Everything seems to be fine. Set the default stepping action list to print one line and Step.
    CodeWatch> DSTEP [P]
CodeWatch> STEP
Step at PRIMES\120
  120:      call sift(n);
  • Step into sift and see what's happening there.
    CodeWatch> S IN
Step at PRIMES.SIFT\%ENTRY
   77: sift: procedure (n);
  • Use the ARGUMENTS command to see the arguments to this routine.
    CodeWatch> ARGUMENTS
N = 10 {fixed binary (31)}
  • Do a stack traceback.
    CodeWatch> STACK /ALL

Stack contains 5 frame(s).
Current execution point is PRIMES.SIFT\%ENTRY

5: Owner is "PRIMES.SIFT"
      Called from PRIMES\120
4: Owner is "PRIMES"
      Main program
  • To demonstrate statement tracing, set the source file pointer to line 98 and print five lines.
    CodeWatch> POINT 98
   98:         do while (k < n);
CodeWatch> P 5
   98:         do while (k < n);
   99:           /* cancel all multiples */
  100:           flags(k) = FALSE;
  101:           k = k + this_prime;
  102:         end;
  • Set a break at line 100, which will put you in the middle of this small loop. Continue.
    CodeWatch> B 100
CodeWatch> C
Break at PRIMES.SIFT\100
  • Set statement tracing and continue twice. Each statement is reported as it is executed.
    CodeWatch> TRACE STATEMENT
CodeWatch> C
**** PRIMES.SIFT\101
**** PRIMES.SIFT\102
**** PRIMES.SIFT\98
Break at PRIMES.SIFT\100
CodeWatch> C
**** PRIMES.SIFT\101
**** PRIMES.SIFT\102
**** PRIMES.SIFT\98
Break at PRIMES.SIFT\100
  • Set a macro "fig" to do FIND/IGNORE. This will be useful; by default, the FIND command is case-sensitive. The /IGNORE option ignores case.
    CodeWatch> MACRO fig.=[FIND /IGNORE]
CodeWatch> fig PRINT_OUT
  105:    call print_out(primes,count);  /* should be count - 1 */
  • Break at line 105 (the call to print_out). Turn off statement tracing and delete the breakpoint at the current line (NBREAK with no parameter deletes the breakpoint at the current line). Continue to the call to print_out.
    CodeWatch> B 105
CodeWatch> NTRACE S
CodeWatch> NBREAK
CodeWatch> C
Break at PRIMES.SIFT\105
  • Evaluate count, which you are about to pass to print_out.
    CodeWatch> E count
COUNT = 6 {fixed binary (31)}
  • Six prime numbers are found. That's not right. Only five should have been found: 1, 2, 3, 5, and 7. Set a break at the entry point of sift, reload the program and continue execution (twice) to get back to the entry of sift. (Enter 10 again for input.)
    CodeWatch> B sift\%ENTRY
CodeWatch> RELOAD
Command line : "primes"
Reloading..ok
Initial evaluation environment is PRIMES:(inactive)
CodeWatch> C

*** Sieve of Eratosthenes ***

Input maximum prime boundary:
10
Break at PRIMES\119
CodeWatch> C
Break at PRIMES.SIFT\%ENTRY
  • Step once and print 15 lines.
    CodeWatch> S
Step at PRIMES.SIFT\85
   85:    do I = 1 to n;
CodeWatch> P 15
   85:    do I = 1 to n;
   86:      flags(I) = TRUE;
   87:    end;
   88:
   89:    count = 1;
   90:    primes(1) = 1;
   91:
   92:    do I = 1 to n;
   93:      if flags(I) = TRUE then do;
   94:        this_prime = I + 1;
   95:        count = count + 1;
   96:        primes(count) = this_prime;
   97:        k = I + this_prime;
   98:        do while (k < n);
   99:          /* cancel all multiples */
  • Set a break at line 95. This is a conditional breakpoint with an ELSE action list. The debugger will not break at line 95 unless count > 4. It will instead evaluate count and continue on. Continue.
    CodeWatch> B 95 /IF {count > 4} /ELSE [E count]
CodeWatch> C
COUNT = 1 {fixed binary (31)}
COUNT = 2 {fixed binary (31)}
COUNT = 3 {fixed binary (31)}
COUNT = 4 {fixed binary (31)}
Break at PRIMES.SIFT\95
  • Delete this breakpoint. Continue and print one line.
    CodeWatch> NB
CodeWatch> C;P
Break at PRIMES.SIFT\105
 105: call print_out(primes,count); /* should be count - 1 */
  • Back at the call to print_out. Evaluate count. Assign count-1 to count and continue. (Enter 10 again for input.)
    CodeWatch> E count
COUNT 6 {fixed binary (31)}
CodeWatch> LET count=count-1
CodeWatch> C
Number of primes found was            (prime itself)    5

1      2      3      5      7

Input maximum prime boundary:
10
Break at PRIMES\119
  • This appears to be the solution. Reload the program and delete all breakpoints.
    CodeWatch> R
Command line : "primes"
Reloading..ok
Initial evaluation environment is PRIMES:(inactive)
CodeWatch> NBREAK /ALL
  • You can do a run-time patch to the program, without even exiting the debugger. This is a temporary fix to see what source changes you may need to make. This breakpoint will not report itself (/SILENT); it will simply execute its action list and continue. Continue program execution. Try 10 and 100 for user input. Exit the program by entering 0.
    CodeWatch> B 105 /SILENT [LET count=count-1;C]
CodeWatch> C

*** Sieve of Eratosthenes ***

Input maximum prime boundary:
10
Number of primes found was      (prime itself)     5

1      2      3      5      7

Input maximum prime boundary:
100
Number of primes found was   26
1      2      3      5      7      11     13     17     19     23
29     31     37     41     43     47     53     59     61     67
71     73     79     83     89     97

Input maximum prime boundary:
0
Program exited with status 0
Reloading..ok
Initial evaluation environment is PRIMES:(inactive)
  • So now you know that if you change line 105 of primes. pl1 from:
    call print_out(primes,count);

    to:

    call print_out(primes,count-1);

    the program will work just fine! Quit out of the debugger session.

    CodeWatch> QUIT
CodeWatch Quit...Bye!
Parent topic: Debugging Open PL/I Programs


Program Listing

Compiler:  Open PL/I 08.00.B2 - Copyright (c) 2009 Micro Focus (IP) Limited
Date/Time: December 11, 2009 (15:35:27)
File:      primes.pl1
Directory: C:\Program Files\Micro Focus\Open PLI 8.0\EXAMPLES\OPEN-PLI
Options:   deb l noopt Pentium obj primes.obj list primes.lst
       1   /* Sieve of Eratosthenes: Copyright (c) 2009 Micro Focus (IP) Limited */
       2
       3   primes: procedure options (main);
       4
       5   %replace FALSE      by '0'B;
       6   %replace TRUE       by '1'B;
       7
       8   %replace MAX_VALUE  by 1000;
       9   %replace MAX_PRIMES by  500;
      10
      11
      12   read_input: procedure (maxv);
      13
      14       declare maxv fixed binary(31);
      15       declare instring char(4) varying;
      16
      17       declare ok bit(1);
      18
      19       ok = FALSE;
      20
      21       do while (^ok);
      22           put list ('Input maximum prime boundary:');
      23           put skip;
      24           get list (instring);
      25           maxv = decimal(instring);
      26           if maxv > MAX_VALUE then do;
      27               put list ('Value too big.  Try again.');
      28               put skip;
      29           end;
      30           else do;
      31               ok = TRUE;
      32           end;
      33       end;
      34
      35   end read_input;
      36
      37   isprime: procedure (number,values,total) returns (fixed binary(31));
      38
      39       declare number                fixed binary(31),
      40                   values(1:MAX_PRIMES)  fixed binary(31),
      41           total                 fixed binary(31);
      42       declare n                     fixed binary(31);
      43
      44           do n = 1 to total;
      45           if number = values(n) then
      46                  return (number);
      47           end;
      48
      49           return(-1);
      50
      51   end isprime;
      52
      53   print_out: procedure (values,total);
      54
      55       declare values(1:MAX_PRIMES) fixed binary(31),
      56           total                fixed binary(31);
      57
      58       declare i fixed binary(15);
      59
      60       put list ('Number of primes found was');
      61       if isprime (total,values,total) >= 0 then
      62           put list(' (prime itself)');
      63       put edit (total) (F(4));
      64       put skip (2);
      65
      66       do i = 1 to total;
      67           put edit (values(i)) (F(7));
      68           if mod(i,10) = 0 then do;
      69               put skip;
      70           end;
      71       end;
      72
      73       put skip (2);
      74
      75   end print_out;
      76
      77   sift: procedure (n);
      78
      79       declare n fixed binary(31);
      80
      81       declare (i, k, count, this_prime) fixed binary(31),
      82           flags(1:MAX_VALUE) bit(1),
      83           primes(1:MAX_PRIMES) fixed binary(31);
      84
      85       do i = 1 to n;
      86           flags(i) = TRUE;
      87       end;
      88
      89       count = 1;
      90       primes(1) = 1;
      91
      92       do i = 1 to n;
      93           if flags(i) = TRUE then do;
      94               this_prime = i + 1;
      95               count = count + 1;
      96               primes(count) = this_prime;
      97               k = i + this_prime;
      98               do while (k < n);
      99                   /* cancel all multiples */
     100                   flags(k) = FALSE;
     101                   k = k + this_prime;
     102               end;
     103           end;
     104       end;
     105       call print_out(primes,count);  /* should be count - 1 */
     106
     107   end sift;
     108
     109       /* main procedure */
     110
     111       declare n fixed binary(31);
     112
     113       put skip;
     114       put list ('*** Sieve of Eratosthenes ***');
     115       put skip (2);
     116
     117       call read_input(n);
     118
     119       do while (n > 1);
     120           call sift(n);
     121           call read_input(n);
     122       end;
     123
     124   end;
Parent topic: Debugging Open PL/I Programs


Open PL/I User's Guide

This book shows you how to operate Micro Focus's Open PL/I application.

  • Using Open PL/I
    This chapter explains how to install the Open PL/I Compiler and how to enter, compile, link, and run Open PL/I programs.
  • Language Concepts
    This chapter describes the Open PL/I language implementation for your system. For detailed information on the Open PL/I programming language, see your Open PL/I Language Reference Manual.
  • Open PL/I SQL Options
    This chapter describes the SQL Options available with Open PL/I. These include the DB2 SQL Option that provides support for IBM's DB2 on UNIX.
  • Open PL/I Compiler Diagnostic Messages
    This appendix describes the format of Open PL/I compiler diagnostic messages and their levels.
  • Open PL/I Run-time Error Messages
    This appendix contains information on Open PL/I run-time errors, UNIX system error codes, and Open File Manager (OFM) error codes. Run-time errors are detected by the Open PL/I run-time system, or by the operating system.
  • Value Table for ONCODE Built-in Function
    You may use the ONCODE built-in function in any unit to determine the nature of the error condition that caused invocation of that ON-unit. This appendix lists the values returned by the ONCODE built-in function and the errors or conditions corresponding to each value.
  • Character Sets
    This appendix provides you with the ASCII equivalents of EBCDIC characters.
  • Environment Variables
  • Migration to Micro Focus File Formats
Parent topic: PL/I Programming


Using Open PL/I

  • Compiling a Program
  • Linking a Program
  • Running a Program
  • Using Open PL/I with Other Software Products
  • Compiling, Linking and Debugging of Fetchable Procedures
Parent topic: Open PL/I User's Guide


Compiling a Program

Open PL/I consists of the following executable programs:

  • The Open PL/I Macro Preprocessor, named mfpp
  • A CICS Preprocessor
  • A DB2 Preprocessor
  • An OpenESQL Preprocessor
  • The Compiler itself, named mfpli
  • A command-line driver that allows compiling and linking in one step, named mfplx
  • An interactive menu-oriented program for managing indexed (VSAM) files, named mfvsam

Note that in the names mfpli and mfplx the fourth character is the lowercase letter "L".

mfpp is executed prior to the compilation, and its output is passed to the Open PL/I Compiler.

You can run mfpp directly, but the recommended way to run it is by use of the -macro option with mfplx when you are compiling your program. This allows the mfpp output to be automatically directed to the Compiler.

mfpli allows only one filename, accepts only Open PL/I Compiler options, and requires a separate ldpli step. The suffix of the filename to be compiled by mfpli is not restricted.

mfplx allows multiple filenames and accepts mfpli options as well as many standard UNIX or Windows system compiler and linker options, such as -c and -o. The -c option specifies compilation without linking. When -c is used, the -o option is passed to the compiler; when -c is not used, -o is passed to ldpli. Note that some file name suffixes are restricted to .pl1 or .pli when using mfplx.

mfvsam allows the creation of an indexed file, the addition or deletion of an index to an indexed file, and the display of information about an indexed file.

The CICS preprocessor converts EXEC statements into native PL/I code that is then possibly further macro processed and then finally compiled and linked.

The OpenESQL and DB2 preprocessors process SQL statements before the compilation.

See the following sections for descriptions of the syntax to invoke mfpp, mfpli, mfplx, or mfvsam.

  • mfpp Syntax
  • mfpli Syntax
  • mfplx Syntax
  • mfvsam Syntax
  • Preprocessor Order of Execution
  • mfplx Options
  • Macro Preprocessor Options
  • CICS Preprocessor Options
  • DB2 Preprocessor Options
  • Compiler Options
  • Compiler Listings
  • Open PL/I Compiler Implementation Limits
  • Compilation Statistics
  • Temporary Files
  • Optimization
Parent topic: Using Open PL/I


mfpp Syntax

The valid format for the mfpp command is:

mfpp [–ipath dir][-{isuffix|x} suffix] [–pp outfile]infile

where dir is a directory name, suffix defines a string to be appended to any unquoted filename in a %INCLUDE statement, infile specifies a source filename, and outfile specifies an output filename. At least one input file must be specified.

The preprocessor input is a file containing an Open PL/I source module, possibly including Open PL/I Macro Preprocessor statements. The preprocessor output is an Open PL/I source module containing no further preprocessor statements, but with the source code modified according to the semantics of the preprocessor statements that were encountered in the input file.

mfpp is usually run by use of the -macro option with mfplx.

Parent topic: Compiling a Program
Related information
Macro Preprocessor Options


mfpli Syntax

The valid format for the mfpli command is:

mfpli [option] ... file [option]...

where option represents a Compiler option and file represents any single specified source file. There is no restriction on the suffix of the filename. option arguments can go either before or after file. (An error may result if the -I or -o option appears before file without specifying a list filename or object filename.)

Parent topic: Compiling a Program


mfplx Syntax

The valid format for the mfplx command is:

 mfplx {option | source_file | object_file} ...

where option represents an Open PL/I Compiler option or a system Compiler or linker option.

source_file represents any specified source file. Files with a .pl1 or .pli suffix are passed to mfpli. On UNIX systems, files with an .s suffix are passed to the system assembler. On Windows systems, files with an .asm suffix are passed to the system assembler.

mfplx supports wildcard characters and indirect files (@files).

object_file represents any specified object file (with an .o suffix for UNIX systems or a .obj suffix for Windows systems) or any specified library (with an .a suffix for UNIX systems or an .lib suffix for Windows systems). Files with an .o (or .obj) or an .a (or .lib) suffix are passed to mfpli, as are specified files with unknown or absent suffixes. The command line that mfpli constructs for each of these invocations is limited to 4096 characters. The .o files can be linked (possibly with other object files and/or libraries) using ldpli or mfplx -o.

mfplx processes options in one of the following ways:

  • Passes the option to the preprocessor (mfpp).
  • Passes the option to the compiler (mfpli).
  • Passes the option to the linker (ldpli).
  • Executes the option (for example, -c) in a fashion similar to cc.
  • Ignores the option.

Program execution begins at the main entry point.

Parent topic: Compiling a Program
Related information
Compiler Options
Compiling a Program
Linking a Program
Main Procedure


mfvsam Syntax

The mfvsam utility is invoked by the command mfvsam. This utility offers the following options when invoked:

  1. Display information about a VSAM file.
  2. Create a VSAM file.
  3. Add an index to a VSAM file.
  4. Delete an index from a VSAM file.
  5. Exit.
Note:

The mfvsam utility currently produces indexed data files using the C-ISAM format only.

Parent topic: Compiling a Program


Preprocessor Order of Execution

The Open PL/I preprocessors are run by mfplx in the following order:

  1. Open PL/I Macro Preprocessor
  2. CICS Preprocessor
  3. Open PL/I Macro Preprocessor
  4. OpenESQL Preprocessor or DB2 Preprocessor

The ordering of the Compiler switches you use has no impact.

You may change the order, if necessary, by separately invoking the preprocessor you choose.

It is recommended that you run the preprocessors in this order via mfplx, but if you want to run the preprocessors separately, run mfplx with the preprocessor arguments you want and the -# flag to see what command lines are generated.

The running of the preprocessor is controlled by the following flags:

  • -macro [-pp [output_file]]
  • -cics [-ppcics [output_file]]
  • -db2 [-ppdb2 [output_file]]
  • -sql [-ppsql [output_file]]

-macro, -cics, -db2 and -sql cause respective preprocessors to run. -pp, -ppcics, -ppdb2 and -ppsql cause the preprocessor's output to be kept and the optional output_file says to give the output file a particular name.

  • Examples
Parent topic: Compiling a Program


Examples

Example 1: Equivalent to an ordinary compilation with -macro.

The command line

mfplx -macro sample.pl1 -#

produces:

mfpp sample.pl1 -pp sample.pp
mfpli sample.pp -o sample.o
rm -f sample.pp
ldpli sample.o

Example 2: Equivalent to an ordinary compilation with -macro and two preprocessors.

The command line

mfplx -db2 -macro sample.pl1 -cics -#

produces:

mfpp sample-pl1 -pp sample.pp
mfcics -i sample.pp -o sample.pp1
mfpp sample.pp1 –pp sample.pp2
mfdb2 -i sample.pp2 -o sample.pp3
mfpli sample.pp3 -o sample.o
rm -f sample.pp sample.pp1 sample.pp2 sample.pp3
ldpli sample.o

Example 3: Run macro preprocessor and CICS preprocessor only, preserving the intermediate output files.

The command line

mfplx -E sample.pl1 -macro -cics -#

produces:

mfpp sample.pl1 -pp sample.pp
mfcics -i sample.pp -o sample.pp1
mfpp sample.pp1 –pp sample.pp2

Example 4: Ordinary compile, preserving CICS preprocessor output.

The command line

mfplx -cics -ppcics cicsout.out sample.pl1 -#

produces:

kixplt -i sample.pl1 -o cicsout.pl1
mfpli cicsout.pl1 -o sample.o
ldpli sample.o

Example 5: Multiple compilations.

The command line

mfplx -db2 -cics sample.pl1 sample2.pl1 -#

produces:

sample.pl1:
mfpp sample.pl1 -pp sample.pp
mfcics -i sample.pp -o sample.pp1
mfpp sample.pp1 -pp sample.pp2
mfdb2 -i sample.pp2 -o sample.pp3
mfpli sample.pp3 -o sample.obj
del sample.pp sample.pp1 sample.pp2 sample.pp3
sample2.pl1:
mfpp sample2.pl1 -pp sample2.pp
mfcics -i sample2.pp -o sample2.pp1
mfpp sample2.pp1 -pp sample.pp2
mfdb2 -i sample.pp2 -o sample2.pp3
mfpli sample2.pp3 -o sample2.obj
del sample2.pp sample2.pp1 sample.pp2 sample2.pp3
ldpli -db2 sample.obj sample2.obj
Parent topic: Preprocessor Order of Execution


mfplx Options

mfplx allows multiple filenames and accepts mfpli options as well as many standard UNIX or Windows system compiler and linker options, such as -c and -o. The -c option specifies compilation without linking. When -c is used, the -o option is passed to the compiler; when -c is not used, -o is passed to ldpli. Some of the options available for use with the mfplx command are explained in the following table.

Option | Explanation
-cics | Invokes the CICS preprocessor.
-vtrace | Micro Focus Tracing Option
-ptrace | Micro Focus Tracing Option
-ctrace | Micro Focus Tracing Option
-littleendian | Default to LITTLEENDIAN integers.
-bigendian | Default to BIGENDIAN integers.
-deb | Generates debug code for CodeWatch.
-not_symbol | Selects alternate NOT symbol
-or_symbol | Selects alternate OR symbol
Parent topic: Compiling a Program


Macro Preprocessor Options

The options available for use with the mfpp command are explained in the following table. The -ipath and -suffix options obey the rules that apply when they are invoked as compiler options.

Option | Explanation
-currency_symbol | Provides a currency symbol for picture specification. It can take the character, decimal number, or hex constant of the form 0xDD, for example, -currency_symbol £, -currency_symbol 163, -currency_symbol 0xa3.
-define name[=value] | Causes value to be used in place of name wherever the identifier name appears.
-includes | Tells the preprocessor to process %INCLUDE statements.
-ipath dir | The -ipath and -suffix options obey the rules that apply when they are invoked as Compiler options.
-isuffix suffix (or -x suffix) | The -ipath and -suffix options obey the rules that apply when they are invoked as compiler options.
-margins I,r Sets the margins within which characters of the source file are interpreted as source code and outside which all characters are ignored by the Compiler. l is the column number of the leftmost character and r is the column number of the rightmost character to be interpreted as source code. Note that, if tabs are used, each tab is counted as a single character.

The -margins option on a *PROCESS card is ignored if the macro pre-processor is in use (either by executing mfpp or mfplx with the -macro option); in this case, if the source margins are not 1,256, the actual margins must be specified with the -margins option.

-nodebuginfo | Specifies that the preprocessor will not generate the normal debug information that it passes to the Compiler. This is useful if you wish to debug using the post-preprocessing PL/I source file rather than the original source file.
-noincludes | Tells the preprocessor not to handle %INCLUDE statements.
-[no]namesstring1 [string2] Provides extended character support. For example,
-names 'string1' ['string2']
where string1 are extralingual characters to add to identifiers, and string2 are optional corresponding uppercase characters. Hex constants of the form 0xDD are accepted in place of the strings. The default is -names.
-not_symbol | Provides a not symbol. It can take the character, decimal number, or hex constant of the form 0xDD.
-or_symbol | Provides an or symbol. It can take the character, decimal number, or hex constant of the form 0xDD.
-pp outfile (or -o outfile) | Names the output file the name you specify with outfile. If -pp is not specified, the default name of the file is xxx.pp, where xxxis the input filename up to, but not including, the last "." (if any) in the name. For example, if the input filename is prog.pl1, the default output filename is prog.pp.
-T | Causes the preprocessor to examine a %INCLUDE file name for the characters @, #, and $, and to replace @ with A, # with N, and $ with D.
-undefine name | Removes a definition for name, if name was created by a -define option, and leaves the identifier name in the source as name. It does not preclude a %REPLACE statement or %name=expr from changing the value of name.
-variant string | Supplies a string to be used in place of the VARIANT built-in function.
Parent topic: Compiling a Program


CICS Preprocessor Options

The CICS Preprocessor Options are explained in the following table.
Option | Explanation
-# | Displays the mfexecpp command line.
-i | Specifies input file.
-o | Specifies ouput file.
-margins | Specifies the margins (-margins left,right)
-or_symbol | Selects alternate OR symbol
-not_symbol | Selects alternate NOT symbol
-deb | Allows debugging.
-vtrace | Micro Focus Tracing Option
-ptrace | Micro Focus Tracing Option
-ctrace | Micro Focus Tracing Option
-bigendian | Default to BIGENDIAN integers. Note: It is applied by default.
-nonnative | Default to BIGENDIAN integers.
-native | Default to LITTLEENDIAN integers.
Parent topic: Compiling a Program


DB2 Preprocessor Options

The DB2 Preprocessor options are listed in the table below:

-action | Refer to the IBM DB2 documentation.
-bind | Specifies that a bind file should be created.
-bindname | Specifies name of bindfile to create.
-block | Specifies type (unambig, all or no) of row blocking.
-catalog | Refer to the IBM DB2 documentation.
-charsub | Refer to the IBM DB2 documentation.
-connect | Specifies if the CONNECT statement should be of type 1 or 2.
-collection | Specifies the collection shema name.
-datetime | Specifies date/time format (def, usa, eur, iso, jis, loc).
-dbname | Specifies name of database to precompile against.
-dec | Refer to the IBM DB2 documentation.
-decdel | Refer to the IBM DB2 documentation.
-degree | Refer to the IBM DB2 documentation.
-disconnect | Refers to disconnections (explicit, automatic or conditional).
-dynamicrules | Refer to the IBM DB2 documentation.
-explain | Refer to the IBM DB2 documentation.
-explsnap | Stores Explain snapshot (no, all or yes)
-funcpath | Specifies func path for types and functions in static SQL.
-insert | Refers to data buffering (def or buf).
-isolation | Specifies isolation level (ss, rr, ur).
-level | Refer to the IBM DB2 documentation.
-nobind | Specifies that no .bnd file is created.
-nooptimize | Specifies that no SQLDA initialization optimizations are done.
-package | Causes package creation.
-packagename | Specifies name of package. Implies -package.
-optimize | Specifies that SQLDA initialization optimizations are done.
-optlevel | Same as -optimize. Impacts initializations of SQLDAs.
-owner | Refer to the IBM DB2 documentation.
-queryopt | Optimization of static SQL. The default level is 5.
-qualifier | Refer to the IBM DB2 documentation.
-release | Refer to the IBM DB2 documentation.
-replver | Refer to the IBM DB2 documentation.
-retain | Refer to the IBM DB2 documentation.
-schema | Refer to the IBM DB2 documentation.
-sqlerror | Specifies action following error(s).
-sqlflag | Reports on deviationson SQL syntax.
-sqlrules | Refers to connects (std or db2).
-sqltwop | Performs two passes because variable usage proceeds declarations.
-sqlwarns | Refers to dynamic SQL.
-stds | Refer to the IBM DB2 documentation.
-syncpoint | Refers to commits or rollbacks (onephase, none, twophase)
-syntax | Suppresses package or binding. Validity checking.
-text | Refer to the IBM DB2 documentation.
-validate | Refer to the IBM DB2 documentation.
-version | Refer to the IBM DB2 documentation.
Parent topic: Compiling a Program


Compiler Options

The list below describes each of the Compiler options and its default setting, when applicable.

-#
Provides information on how the Compiler and linker would be invoked without actually invoking them. This option also shows which UNIX options are translated to Micro Focus options; for example, when the standard UNIX -O option is given on the driver command line, it is translated on the Compiler invocation line as -opt.
--agginit
Performs initialzation of aggregates (arrays and structures) compatible with 7.x versions of Open PL/I.

Example:

dcl myarr(4) fixed bin(31) static init (1);
put skip list (myarr);

results in:
             1               1               1               1

By default, without -agginit, only the first element is initialized.

-bigendian
Specifies that all fixed binary items are implicitly declared with the BIGENDIAN data attribute, unless the NATIVE attribute is explicitly applied to a data item.
-c
Suppresses linking and produces a relocatable object file. This option applies to mfplx only.
-coffdebug
Emits line number information for the Visual Studio debugger to enable breakpoints, statement tracing, and call stack information of Open-PLI source code.
Note: Evaluation of variables is not supported.
-currency_symbol
Allows an alternate currency symbol for picture specification. It can take a character, decimal number, or hex constant of the form 0xDD, for example, -currency_symbol £, -currency_symbol 163, -currency_symbol 0xa3.
-db2
Invokes the DB2 precompiler, mfdb2. The default DB2 precompiler output file name is xxx.pp2, where xxx is the name of the source file. If the -ppdb2 option is not specified, the file xxx.pp2 is deleted after the compilation phase is completed. The -db2 option applies to mfplx only.
-deb
Produces debugging information for CodeWatch, Micro Focus's source-level debugger. You must specify this option if you intend to use CodeWatch to debug this source. When using -deb, you may specify only optimization levels 1 or 2.
-default_binary
Causes the BINARY attribute to be assumed if the FIXED attribute is specified without BINARY or DECIMAL.
-default_decimal
Causes the DECIMAL attribute to be assumed if the FIXED attribute is specified without BINARY or DECIMAL. This option is the Compiler default.
-defext
Causes external variables to be defined in the .data section. You must use this option for programs using external files.

The -defext option causes the initialized values of STATIC EXTERNAL variables and external file constants to be defined. Each STATIC EXTERNAL variable that has an INITIAL value must be declared in one and only one module that has been compiled with -defext. Failure to do so causes the INITIAL value to have no effect. The default is -nodefext.

Also, each file constant must be declared in one and only one module that has been compiled with -defext. When -defext is used, file attributes specified in the file declaration will be merged with attributes specified when the file is opened. This is critical when doing VSAM/INDEXED I/O.

-E
Causes any specified precompilers or preprocessor (-macro, -unikix, -db2) to be run on the source file, and saves their output, but stops without running the Compiler.
-exp
Produces an expanded listing of the generated code in the form of assembly language statements in the listing file.
-fdasfb
Causes Float Decimal data to be internally coded as Float Binary. This option produces much faster code but loses precision in the least significant digits of arithmetic results. -fdasfb is the default. See also the -nofdasfb option.
-flag
Specifies the minimum diagnostic level of messages listed in the compiler listing.
-flag minimum diagnostic level
The minimum diagnostic level can be:
I
Emits diagnostic messages beginning at the Informational level (Lists all messages. This is the default).
W
Emits diagnostic messages beginning at the Warning level.
E
Emits diagnostic messages beginning at the Error level.
S
Emits diagnostic messages beginning at the Severe level.
A
Abort.
-fmaxp
Causes extended floating-point precision to be used for the trigonometric built-ins and for the following arithmetic built-ins: EXP, LOG, LOG10, LOG2, SQRT. -fmaxp is the default.
-highbif
This compile-time switch allows changing the value returned by the HIGH() built-in function. For example, -highbif 127 (the default value is 255; the value 127 maybe used for compatibility with earlier versions of Open PL/I).
-ipath dirlist
Directs the Compiler to search specified directories for files to be included in the source program text by use of the %INCLUDE statement. dirlist is an ordered list of directories of the form
dirname[:dirname] ...

-ipath instructs the Compiler to use these directories in the specified order in its search for files to satisfy %INCLUDE statements (except in cases where an absolute directory path is specified in the %INCLUDE statement).

For example, suppose the source program contains:

%INCLUDE partlist;

and the Compiler invocation command is:

mfplx source_file -ipath .:/u/libr1:/u/libr2

In this case, the Compiler will first search for "PARTLIST" in the current working directory, then /u/ libr1, and finally /u/ libr2. If that fails, it will search for "partlist" (lowercase) in the same directories.

In a Windows environment, the equivalent Compiler invocation is:

mfplx source_file -ipath .;drive:\libr1;drive:\libr2
-isuffix string
Causes string to be appended to the filename specified in %INCLUDE statements, except those in which the quoted filename form of the %INCLUDE statement is used.

For example, suppose the source program contains:

%INCLUDE partlist;

and the Compiler invocation command is:

mfplx source_file -isuffix .INC

In this case, the Compiler will search for a file named "PARTLIST.INC".

-l [ file]
Produces a Compiler listing where file is the name of the file to which the listing is output. If you do not supply a filename, you must place this option after the source filename on the command line; otherwise, an error message appears. The default name of the file containing the listing is xxx.list, where xxx is the source filename (excluding the pathname) up to, but not including, the last "." (if any) in the name. For example, if the source filename is prog.pl1, the default listing is prog.list (prog.lst for Windows systems). A Compiler listing is produced by default whenever -exp, -map, or -xref is specified.
-longint
Changes the default precision of Fixed Binary variables from (15) to (31).
-lowercase
Converts all uppercase names of internal and external variables and constants to lowercase.
-macro
Invokes the Open PL/I Macro Preprocessor, mfpp. The default preprocessor output file name is xxx.pp, where xxx is the name of the source file. If the -pp option is not specified, the xxx.pp file is deleted after the compilation phase is completed. The -macro option applies to mfplx only.
-map
Produces a storage allocation map at the end of the listing file.
-margins 1,r
Sets the margins within which characters of the source file are interpreted as source code and outside which all characters are ignored by the Compiler. 1 is the column number of the leftmost character, and r is the column number of the rightmost character to be interpreted as source code. Note that if tabs are used, each tab is counted as a single character. The -margins option can be overridden by a *PROCESS statement in the source.
Note: There must be no spaces around the comma separating the left and right margin.
-names
Adds extralingual characters to identifiers via the compiler options, similar in nature to *PROCESS NAMES().

Example:

-names 'string1' [ 'string2' ]
string1
Extralingual characters to add to identifier.
string2

Corresponding upper case characters. Optional.

The default is:

-names '$@#' '$@#'

When there are no extralingual characters, the compiler option is:

-nonames

-nonames and -names can't be used together as they are conflicting options and cause an error.

-nonames -names ...

For additional characters you must specify the default $@# or subset if desired, plus the additional lingual characters.

-names '$@#?'

For convenience, hex constants of the form 0xDD..DD are accepted in place of the strings above.

-names 0x402324a3
-nest
Indicates the nesting level on the listing of DO ... END, PROC ... END, and so on.
-nocicsdebug
Allows use of CodeWatch to debug the original source file, rather than the intermediate file generated by the CICS precompiler. Also, causes Compiler diagnostics to use line numbers referencing the original source file. This is the default. The -nocicsdebug command applies to mfplx and kixplt only.
-nofdasfb
Causes Float Decimal data to be internally coded as Binary Coded Decimal. The default setting is -fdasfb.
-nofmaxp
Causes standard PL/I conversion rules to be used to determine the precision of trigonometric and certain arithmetic built-ins. The default is -fmaxp.
-noincludes
Directs the Compiler not to include the contents of %INCLUDE files in the listing file. The default is to include file contents in the listing file.
-nomacro
Suppresses the invocation of the Open PL/I Macro Preprocessor. The default is -nomacro.
-[no]namesstring1 [string2]
Provides extended character support. For example,
-names 'string1' ['string2']
where string1 are extralingual characters to add to identifiers, and string2 are optional corresponding uppercase characters. Hex constants of the form 0xDD are accepted in place of the strings. The default is -names.
-noobj
Compiles for syntax and semantic checking only. Does not produce an object file.
-noopt
Compiles without optimization. This is the default.
-norange
Suppresses generation of code to check the validity of subscript references and substring bounds. This option should be used after your program has been debugged to improve execution time performance. The default is -norange.
-not_symbol
Allows an additional NOT symbol. It can take a character, decimal number, or hex constant of the form 0xDD. See also %PROCESS in the Language Reference Manual.
-nounixdebug
Avoids generating the additional object file data needed to report source file and line number when a fatal run-time error occurs, or for use by the ONLOC built-in function.
-nounrefexternals
Prevents external entry symbols that are not referenced in the program from being generated in the object file. This is the default.
-nowarn
Suppresses all WARNING level diagnostics.
-O
Invokes the optimization phase of the Compiler. This option applies to mfplx only and is equivalent to the -opt option.
-o file
Names the object file the name you specify with file. If -o is not specified, the default name of the file is xxx.o, where xxx is the source filename up to, but not including, the last "." (if any) in the name. For example, if the source filename is prog.pl1, the default object filename is prog.o (prog.obj for Windows).

If -c is specified, the -o option is passed to the compiler; if -c is not specified, -o is passed to ldpli.

-oldalign
Causes the Compiler to allocate Character Varying items and align structure members compatible with releases prior to Open PL/I 6.0.
-opt [level]
Specifies the level of optimization by the Open PL/I Compiler, where level stands for the level (1 – 3) of optimization. The default setting is -noopt. If level is not included, the program is optimized at level 3. If -deb is specified, -opt 2 is the maximum level allowed. Note, -opt -deb is equivalent to -opt 2 -deb.
-or_symbol
Allows an additional OR symbol. It can take a character, decimal number, or hex constant of the form 0xDD. See also %PROCESS in the Language Reference Manual.
-pass
Connects to a remote DB2 database. You can use this option with a specified username and password. The format is:
–pass myid.mypass

Where myid is the username and mypass is the password for the remote DB2 connection. mfplx first checks the -pass for a username/password and uses these values if specified. If not specified, it uses the values set for the DB2_USERNAME and DB2_PASSSWORD environment variables.

-pic
Generates position-independent code, suitable for linking into a shared library. This option is only available on Solaris, SUSE Linux and Red Hat Linux.
Use this option when compiling code for inclusion in a shared object.
-pl1g
Causes Open PL/I to retain the behavior of releases prior to Open PL/I 5.0 for certain operations that have been changed in such a way as to become incompatible with that former behavior. For example, TIME() returns a value including three fractional digits (thousandths), but -pl1g causes it to return only two fractional digits (hundredths).
-pp [file]
Specifies the file name for the output file of the Open PL/I Macro Preprocessor. An output file created with the -pp option is preserved after the compilation phase is completed. This option applies to mfplx and mfpp only.
-ppcics [file]
Specifies the file name for the output of the CICS precompiler. An output file created with the -ppcics option is preserved after the compilation phase is completed. This option applies to mfplx only.
-ppdb2 [file]
Specifies the file name for the output of the DB2 precompiler. An output file created with the -ppdb2 option is preserved after the compilation phase is completed. This option applies to mfplx only.
-proto
Provides more extensive prototype checking on arguments vs. parameters in entry declarations (also assumed by default when using -vax).

Example:

declare myproc external entry(
      fixed binary(31),
      fixed binary(15),
      fixed binary(15));

   myproc: procedure(a,b,c);        /* mismatch diagnosed, -proto and -vax */
      declare a fixed binary(15);
      declare b fixed binary(15);
      declare c fixed binary(15);

   end t660;
-range
Validates all static array bound references at compilation time, and generates code to check the run time validity of all subscript references, and substring bounds. Note that the checking code slows down execution time performance.

If array or string bounds are exceeded at run time, the SUBSCRIPTRANGE or STRINGRANGE conditions will be raised, as appropriate. We recommend that this option be used to debug programming errors relating to subscripting and substringing, and that the -norange option be used for debugged code. The default is -norange.

-report [file]
Specifies the file name for the output of the Open PL/I Source Checker. If this option is not used, the output of the checker will be directed to the standard error file. This option applies to mfplx only.
-setnull n
Designates a null pointer value n to be returned by the NULL built-in function, where n is a decimal value. If this option is not specified, the value of the NULL built-in function is an address with all bits set to 1.
-stardesc
Tells the Compiler to produce argument descriptors for calls only when array bounds or string lengths in the parameter declaration are represented by the asterisk (*) symbol. (This was compiler behavior in releases prior to release 7.0.) When this option is not used, the Compiler produces descriptors for array, structure, and string arguments, which can be a problem for very large structures.
-stat
Prints Compiler statistics to the standard output as each Compiler phase completes.
-unaligned
This compile-time switch has been added for use on RISC architectures. This switch causes byte instructions to be generated for all based references, which might point anywhere in memory.
-unikix
Invokes the CICS precompiler, kixplt. The default CICS precompiler output file name is xxx.pp1, where xxx is the name of the source file. If the -ppcics option is not specified, the file xxx.pp1 is deleted after the compilation phase is completed. The -unikix option applies to mfplx only.
-unrefexternals
Causes external entry symbols to be generated in the object file, even if they are not referenced in the program.
-v
Prints information to stdout relating to the compilation and link-step phases. This option applies to mfplx only.
-variant string
Passes the variant string string to the Open PL/I Macro Preprocessor. This option applies to mfplx only.
-vax
Makes the following adaptations for programs originally written with Digital Equipment Corporations's PL/I Compiler for the VAX platform:
  • Enables the Fixed Binary(p ? 7) data type as a one-byte signed binary integer.
  • Enables Float Binary(24) as equivalent to Float Binary(23).
  • Enables Float Binary(53) as equivalent to Float Binary(52).
  • Causes the BINARY attribute to be assumed if the FIXED attribute is specified without BINARY or DECIMAL.
-warn
Does not suppress level 1 (WARNING) messages. This is the default.
-xref
Produces cross-reference information in the listing file.
-zp1
Causes all structures to be mapped as if the UNALIGNED attribute is specified at the level 1 structure level. This option is for compatibility with versions of DEC VAX PL/I.
  • Intel-Specific Options
Parent topic: Compiling a Program
Related information
Optimization
The -exp Option
The -l Option
The -map Option
External Names
Open PL/I Compiler Diagnostic Messages
Compilation Statistics


Intel-Specific Options

The Intel-specific options and their default settings are listed below. Use the default settings of the Compiler options to generate the most efficient code for your system.

-codealign argument
Controls alignment of the generated code where argument is a concatenation of one or more of the following suboptions. Note that each suboption must be followed by a number that is one of 4, 8, or 16; this subargument is referred to as align in the descriptions.
j | Align each label that follows an unconditional jump or a return to be at an address such that mod(address, align)=0. The NOPs that are inserted are never executed.
e | Align each entry point such that mod(address, align)=0.
I | Align loop tops such that mod(address, align)=0.
h | Use heuristics to attempt to align labels that do not follow jumps such that mod(address, align)=0, but without inserting any NOP instructions. If align is followed by ".1", alignment will be such that mod(address, align)=0 or 1. The suboptions tell the Compiler where to insert NOP instructions to force the address of critical instructions in generated code to be aligned on boundaries that improve the performance of jumps and calls to those instructions.
-f287
Generates Intel287 floating-point coprocessor instructions where possible. This is the default if an Intel387 coprocessor is not present.
-f387
Generates Intel387 floating-point coprocessor instructions where possible. This is the default if an Intel 80387 coprocessor is present. If an Intel387 coprocessor is not present, the default generates Intel287 floating-point instructions.
-i386
Produces code for the Intel386 processor avoiding optimizations designed for the Intel486 processor. Programs compiled with the -i386 option run correctly on the Intel486, but may perform better when they are compiled with the -i486 option. -i386 is the default when the Compiler is run on an Intel386 processor.
-i486
Produces code for the Intel486 processor, using optimizations designed for the Intel486. Programs compiled with the -i486 option may not run on an Intel386 processor. -i486 is the default when the Compiler is run on an Intel486 processor.
-ix86
Produces code that will run well on both the Intel486 and the Pentium CPUs.
-Pentium
Produces code for the Pentium processor. This is the default when the Compiler is run on a Pentium processor.
Parent topic: Compiler Options


Compiler Listings

The Compiler listing options are:

  • -l (list)
  • -map (storage allocation map)
  • -xref (cross-reference)
  • -exp (expanded code)

All listing information is directed to the listing file. When any of the listing options are specified, the -l option is invoked by default.

  • The -l Option
  • The -map Option
  • The -xref Option
  • The -exp Option
Parent topic: Compiling a Program


The -l Option

The -l option produces a listing file, which is named by default with the source program name (up to but not including the last ".") and the suffix .list. You can choose another name for the listing file by specifying a name after the -l option, in the following format:

-l file

The listing file contains a program listing, which consists of a copy of the source program with line numbers beginning at 1 in a column to the left of the source line.

Parent topic: Compiler Listings


The -map Option

The -map option produces a storage allocation map, which displays the location and allocation size of each program entity. The map categorizes this information by name, class, size, location, and attributes.

This information is presented in five columns:

Column | Description
NAME | Indicates the name of each entity in the program.
CLASS | Indicates the storage class of each program entity; for example, AUTOMATIC, CONSTANT, STATIC, PARAMETER, CONTROLLED, or BASED.
SIZE | Indicates the size of the entity, usually in bytes. If the size is measured in bits, the size number is followed by a B. If the size of the entity is not constant, a -V- is displayed in the location listing. Entities of class ENTRY or BUILTIN have no size or location listing.
LOCATION Gives the offset location of the entity in hexadecimal notation.
  • For automatic variables, the location column gives the memory offset from the frame pointer
  • For static variables, it gives the memory offset from the beginning of static data
  • For controlled and based variables, it displays the value -V-
ATTRIBUTES Displays the data type of the entity, for example, FIXED DEC, FLOAT BIN, CHAR, CHAR VAR, BIT ALIGNED, and ENTRY.

Displays BUILTIN for an entity of BUILTIN class. Displays the precision and scale of the entity, where applicable, in parentheses: for example, FIXED BIN(15,0).

Program entities are listed in the order in which they appear in the procedure.

The map first lists external entry points to the program: external constants, subroutines, or programs, including the source program itself. These entry points are listed with name, class, and attributes.

The map then lists program procedures and entities by line number.

Parent topic: Compiler Listings


The -xref Option

The -xref option provides cross-reference information for each program entity, displaying the line number on which it was declared and the line numbers of all references to it.

The -xref listing for a program is added to the map listing; when you specify the -xref option, you receive a data storage allocation map by default. The cross-reference information appears on the map in the ATTRIBUTES column for each entity, after the line of map attributes information.

References to each entity are listed in the following format:

 DEF line_number REF line_number[...]

A sample map listing with the -xref option follows.

Figure 1-1 Sample Output from the -xref Option

EXTERNAL ENTRY POINTS
NAME         CLASS           SIZE  LOCATION  ATTRIBUTES
SYSPRINT     CONSTANT                        FILE EXTERNAL
                                             DEF 41 REF 41 48 49
PRIMES       CONSTANT                        ENTRY(MAIN)EXTERNAL
PROCEDURE PRIMES ON LINE 10
NAME         CLASS           SIZE  LOCATION  ATTRIBUTES
STORE_CLASS  CONSTANT                        ENTRY
                                             DEF 90 REF 45
ARITH_STR    CONSTANT                        ENTRY
                                             DEF 56 REF 43
PROCEDURE ARITH_STR ON LINE 56
NAME         CLASS           SIZE  LOCATION  ATTRIBUTES
DECIMAL      BUILTIN                   BUILTIN
ESC          AUTOMATIC 6     FFFFFFD8  PICTURED
FLT_BIN      AUTOMATIC 4     FFFFFFE4  FLOAT BIN(15)
                                       DEF 63 REF 71
FIX_DEC      AUTOMATIC 3     FFFFFFEC  FIXED DEC(4,2)
                                       DEF 62 REF 70
CHR_STR      AUTOMATIC 4     FFFFFFEO  CHAR(4)
                                       DEF 61 REF 69
BIT_STR      AUTOMATIC 4B    FFFFFFD4  BIT(4)
                                       DEF 60 REF 68
PROCEDURE STORE_CLASS ON LINE 90
NAME         CLASS     SIZE  LOCATION  ATTRIBUTES
NUMBER       AUTOMATIC 16B   FFFFFFE8  UNION
 FIXED_N     MEMBER    2     00000000  FIXED BIN(15,0)
 FIXED_N_BIT MEMBER    16B   00000000  BIT(16)
STAT_A_EX    STATIC    3     External  FIXED DEC(5,0)EXTERNAL
Y            BASED     4     -V-       FLOAT BIN(23)
Parent topic: Compiler Listings


The -exp Option

The -exp option produces an expanded code listing at the end of the listing file, providing the location and low-level language translation for each instruction and label in the program. The following information is displayed for each statement, in five columns:

Column | Displays
First | The source statement line number.
Second | The offset location of each instruction in the statement.
Third | The hexadecimal representation of each instruction.
Fourth | The instruction in a pseudo-assembly code dialect.
Fifth | Information about the operands used by each instruction.
Parent topic: Compiler Listings


Open PL/I Compiler Implementation Limits

The Compiler generates messages if your source program exceeds certain Open PL/I Compiler implementation limits. The following table lists these implementation limits.

Message | Limit
Depth of nesting of a structure | 16
Maximum length of an ‘external’ string constant | 30721
Maximum length of an ‘internal ’ string constant | 327672
Maximum length of a string constant with repeat specifier | 32767
Maximum length of source line | 320
Maximum length of an identifier | 100
Maximum size of storage for AREA data | 32767
Array dimensions | 8
Nesting level of INCLUDE statements | 7
Nesting of DO, PROCEDURE, BEGIN, SELECT, and simple ON-unit statements | 643
Number of arguments in a subroutine or function call | 239
Number of errors | 100
Maximum VSAM key size | 120 bytes
Scale factor of variables | 0 ? scale factor ? 128
Scale factor of a constant | 0 ? scale factor ? 127
Scale factor of a conversion built-in function | 0 ? scale factor ? 127
Value of a format's repeat, w, or d field | 254
Precision for a fixed binary number | 31
Precision for a fixed decimal number | 18
Precision for a float binary number | 52
Precision for a float decimal number | 16
Internal Limits |
Number of tokens in a statement | 20,000
Maximum number of 'Severe' diagnostics before termination 4 | 200
Parent topic: Compiling a Program
1

The spelling of an external string constant (as presented in the user program) is limited to 3072 characters, where the spelling includes the surrounding quotation marks, the extra quotation mark when two single quotation marks represent a single quotation mark inside the string, and the possible combination of postfix characters such as B or X.

2

The internal spelling of a character string constant (i.e., a compiler generated string constant as the result of Restricted Expression Evaluation) of is limited to 32767 characters, where the spelling includes the surrounding quotation marks.

3

64 including the top level procedure.

4 For other diagnostic levels (Info, Warnifng, Error and Abort) there is no limitation in the number.


Compilation Statistics

The -stat compiler option provides a listing of statistics for each phase of the compilation. The statistics are displayed at the terminal by default or can be redirected to a file. The following figure is a sample terminal display from a UNIX system.

Figure 1-2 Sample Output from the -stat Option (UNIX)

PHASE            USER     SYSTEM    CPU  REAL  13:43:26
Parser Pass 1    0.05       0.02   0.07     0  13:43:26
Declare          0.00       0.00   0.00     0  13:43:26
Parser Pass 2    0.08       0.03   0.11     0  13:43:26
Allocator        0.01       0.00   0.01     0  13:43:27
Code Generator   0.71       0.05   0.76     1  13:43:27
Total            0.85       0.10   0.95     1  13:43:27

Total source lines:                  38
Lines per minute (CPU):           2,400
Lines per minute (real):          2,280

Text size:                 2,574 bytes
Data size:                   914 bytes
Bss Size:                      0 bytes

The following names and describes each of the columns displayed in the printout.

Column | Description
PHASE | Defines the various phases of the compilation. Each phase and its corresponding statistics displays upon completion.
USER | Indicates the CPU time spent on this phase of compilation, excluding CPU time spent by the operating system on behalf of the Compiler.
SYSTEM | Indicates the CPU time used by the operating system while executing the corresponding phase.
CPU | Indicates the CPU time used by the Compiler while executing the corresponding phase. This is simply the sum of USER and SYSTEM.
REAL | Indicates the number of seconds elapsed during the corresponding phase.
The final column | Displays the current time of day in 24-hour notation (on Intel systems only).
Parent topic: Compiling a Program


Temporary Files

Compiler-generated temporary files are normally placed in the /tmp directory. If you wish to put them in your current working directory, use the command appropriate to your shell program.

Bourne/Korn shell users: | TMPDIR=. ; export TMPDIR
C shell users: | setenv TMPDIR .

To store Compiler-generated temporary files elsewhere, specify a pathname by using the command appropriate to your shell program.

Bourne/Korn shell users: | TMPDIR=pathname; export TMPDIR
C shell users: | setenv TMPDIR pathname
Windows users: | set TMPDIR=pathname
Parent topic: Compiling a Program


Optimization

By default, programs are not optimized during compilation. You can specify optimization at level 1, 2, or 3, using the following syntax:

-opt level

For example, "-opt 2". If you specify -opt with no level, level 3 optimizations are performed by default. (Remember that if you use the -deb option, only level 1 or 2 is allowed. If you use -deb and specify -opt with no level, level 2 optimizations are performed.) A brief description of the optimizations performed at each level follows.

Level | Description
1 | Operator pattern replacement and Boolean conditional expression optimizations.
2 | Common subexpression elimination; all level 1 optimizations.
3 All level 1 and level 2 optimizations plus the following:
  • branch chaining
  • dead code elimination
  • strength reduction
  • loop induction
  • loop invariant code motion
  • removal of redundant register saves and loads
  • removal of mathematical identities
Parent topic: Compiling a Program


Linking a Program

You can use either static or dynamic linking of Open PL/I applications. The Open PL/I run-time library is built as a static library (.lib). The ldpli link-step uses the static version of the Open PL/I run-time library by default. To link, use

ldpli -dll [options…]

You also need to add to the command one of the options below:

  • -mvs - for programs executed under the control of JCL.
  • -ims - for programs executed under the control of IMS.
  • -cics - for programs executed under the control of CICS.

To link an Open PL/I program, use either mfplx or ldpli.

  • mfplx compiles and links in one step, automatically invoking ldpli if the -c option is not used. For the use of mfplx, see the section mfplx Syntax .
  • ldpli references the components that were installed with this version of Open PL/I and is the recommended link command when using mfpli.
  • Link Options
  • Using ldpli
Parent topic: Using Open PL/I
Related information
mfplx Syntax


Link Options

The table below lists link options that permit the use of Open PL/I with other software products. For more information, see the section Using Open PL/I with Other Software Products.

Option | Explanation
-tisam | Enables the TISAM package from Transarc for VSAM/indexed files, using Transarc's SFS format.
-mvs | Allows linking of programs running under the control of JCL.
-ims | Allows linking of programs running under the control of IMS.
-cics | Allows linking of programs running under the control of CICS.
Parent topic: Linking a Program
Related information
Using Open PL/I with Other Software Products


Using ldpli

ldpli references the components, such as libraries, that were installed with Open PL/I. ldpli generates executable files from relocatable object files.

Note:

The first and fourth characters of the ldpli command are lowercase letter "L".

The ldpli command-line syntax is as follows:

ldpli [option] ... object_file [object_file] ... [optional_library] ...

where

ldpli | The command that invokes the linker.
option | Represents all valid linker options. Any of the valid UNIX or Windows system linker command options are accepted. See your operating system reference manual for a listing and description of all valid system linker options.
object_file | Specifies object files that are to be linked.
optional_library | Represents library specifications for libraries that are required for your special application. These are needed only if you explicitly CALL library routines from your program. The standard system libraries, such as libc.a on a UNIX system, are always included in the link.
  • Using ldpli with Windows Systems
Parent topic: Linking a Program


Using ldpli with Windows Systems

In addition to supporting all LINK32 options, ldpli includes the following support for Windows systems:

  • Indirect files (@ files).
  • The -# option, which echoes the command line used to invoke LINK32. This can also be used to redirect output for later use in indirect files.

ldpli enhances the default behavior of the following LINK32 options:

  • If -out:filename is not specified, ldpli will generate an executable file with an extension .exe using the basename of the first object file rather than defaulting to noname.exe.
  • If -map is specified without specifying the filename (-map:filename), ldpli will generate a map file with the extension .map using the basename of the first object file.

If -deb was used on the command line at compilation time for debugging purposes with CodeWatch, -deb must also be supplied on the command line to ldpli. If using mfplx for both compilation and linking, mfplx will automatically invoke ldpli with -deb.

Parent topic: Using ldpli


Running a Program

To run an Open PL/I program, invoke the executable object file produced by the link utility.

The name of the executable object file produced by the linker defaults to a.out. However, if you include the -o filename option on the link command line, the executable object file has the filename that you specified.

For example, "-o sample" on the mfplx command line produces an executable object file named "sample".

  • Run-time Errors
  • Accessing Command-Line Arguments in Open PL/I Programs
  • Associating a Logical Open PL/I File with a Physical Disk Data File
  • Using CodeWatch
  • Creating a DLL
Parent topic: Using Open PL/I


Run-time Errors

If an error occurs at run time, a message appears on the terminal.

You can use Open PL/I's ON statement to develop handlers for the conditions that can occur in your program. The ON ERROR statement can be used for arbitrary errors. The ONLOC built-in function can be used in an ON-unit to report the name of an entry in which a condition was raised, and the ONCODE built-in function can be used to report the status value of a run-time error.

Note:

If an error is not caught by an ON-unit, Open PL/I displays the source file and line number where the error occurred. For these features to work, however, you must have compiled the source file with the default option -unixdebug.

This feature is currently available only in the Sun Solaris 2 and IBM AIX versions of Open PL/I.

When a fatal error condition occurs at run time, a message is displayed naming the condition that has been raised; the program address where this occurred; and the source file, entry, and line number at which the condition was raised, as well as the lines in each procedure above it in the call stack. For example:

*** Condition ERROR raised
***Unhandled condition ZERODIVIDE at PC=00010233
CALCDIV line 26 in /dirl/dir2/calcs.pl1
SUBR3 line 444 in /dirl/dir2/subprog.pl1
MYPROG line 871 in /dirl/dir2/mainprog.pl1

In this example,

CALCDIV | Is the entry in which the "ZERODIVIDE" condition was raised.
SUBR3 | Is the entry that called "CALCDIV" (at line 444).
MYPROG | Is the program that called SUBR3.

If you have compiled your program using the -nounixdebug option, only the program address where the condition was raised will be displayed:

*** Condition ERROR raised
*** Unhandled condition ZERODIVIDE at PC=00010233
Parent topic: Running a Program
Related information
Open PL/I Run-time Error Messages


Accessing Command-Line Arguments in Open PL/I Programs

It is sometimes useful to be able to execute a program specifying one or more arguments on the command line in order to cause a variation in the program's behavior. For example, to run a departmental expense report program, you might issue the command deptexp summary to indicate that you wish to see only category totals rather than all the line items.

Command-line arguments can be accessed in a PL/I main program using the following technique:

/* PL/I main program accessing command line args. */

PMAIN: PROCEDURE OPTIONS(MAIN);

   DECLARE ARGC_     FIXED BIN(31) EXTERNAL STATIC;
   DECLARE ARGV_     POINTER EXTERNAL STATIC;
   DECLARE ARG(10)   POINTER BASED;
   DECLARE ARGS      CHAR(50) BASED;
   DECLARE ARGSV     CHAR(50) VARYING;
   DECLARE I         FIXED BIN(31);

   PUT SKIP EDIT(ARGC_)(f(2));
   DO I = 1 TO ARGC_;
      ARGSV = SUBSTR(ARGV_->ARG(I)->ARGS,1,
            INDEX(ARGV_->ARG(I)->ARGS,BYTE(0))-1);
      PUT SKIP EDIT('"',argsv,'"')(a,a,a);
      END;
   PUT SKIP;

   END PMAIN;

If your PL/I program is controlled by a C main program, you can pass the command-line arguments through to the PL/I program in the following manner:

/* C main program calling PL/I subroutine */

main(argc,argv)
   int argc;
   char **argv;
{
   PSUBR(argc,argv);
}

/* PL/I subroutine receiving command line args
   from C main program */

PSUBR: PROCEDURE(ARGC,ARGV);

   DECLARE ARGC      FIXED BIN(31) VALUE;
   DECLARE ARGV      POINTER VALUE;
   DECLARE ARG(10)   POINTER BASED;
   DECLARE ARGS      CHAR(50) BASED;
   DECLARE ARGSV     CHAR(50) VARYING;
   DECLARE I         FIXED BIN(31);

   PUT SKIP EDIT(ARGC)(f(2));
   DO I = 1 TO ARGC;
      ARGSV = SUBSTR(ARGV->ARG(I)->ARGS,1,
            INDEX(ARGV->ARG(I)->ARGS,BYTE(0)));
      PUT SKIP EDIT('"',ARGSV,'"')(a,a,a);
      END;
   PUT SKIP;

END PSUBR;
Parent topic: Running a Program


Associating a Logical Open PL/I File with a Physical Disk Data File

Open PL/I supports a number of ways to associate your physical disk data files with the logical file names used in Open PL/I sources.

  • Method 1 (Default)
  • Method 2
  • Method 3
Parent topic: Running a Program


Method 1 (Default)

The run-time environment will use the name of the file variable (or constant) used in the source, shifted to all uppercase.

Example

dcl Payroll file input;
open file(Payroll);

A file named PAYROLL will be used for all I/O operations using file Payroll.

Parent topic: Associating a Logical Open PL/I File with a Physical Disk Data File


Method 2

Using the TITLE option on the OPEN statement allows one to specify an explicit disk file name with an optional directory prefix. The use of the TITLE option takes precedence over method 1.

Example

dcl Payroll file input;
open file(Payroll) title ('/global/acct/sep-95.days')

A file named /global/acct/sep-95.days will be used for all I/O operations using file Payroll.

dcl Payroll file input;
dcl filename character(100) varying;
<assignment into filename>
open file(Payroll) title (filename);
                                   /* Using a variable name */

The value of filename determines the file that will be used for all I/O operations using file Payroll.

Note:

Once the file has been opened, changing the value of filename will have no impact. The association is made only once, at the time of the open.

Parent topic: Associating a Logical Open PL/I File with a Physical Disk Data File


Method 3

The physical disk file name can be specified with the use of UNIX shell environment variables. This method takes precedence over methods 1 and 2. This method allows you to easily alter the physical disk file used for different invocations of the same application.

The environment variable name is the value of the derived name from either of the above methods with MF_ or DD_ prefixed.

Example

dcl file data2 update;
dcl file specs output;

open file (data2);
open file (specs) title('report');

By setting the following environment variables:

  • setenv MF_DATA2 /common/data
  • setenv MF_REPORT /common/report

I/O operations for file data2 will access /common/data and I/O for file specs will access /common/report.

Note that to override the name for file variable "specs", the name MF_REPORT was used, because of the title option on its OPEN statement.

In the above example, environment variables of the names DD_DATA2 and DD_report would also be allowed.

Note:

To assign a physical file to the following special file declarations you will need to use the corresponding environment variables:

SYSIN | use DD_STDIN
SYSPRINT | use DD_STDOUT
SYSOUT | use DD_STDOUT
Parent topic: Associating a Logical Open PL/I File with a Physical Disk Data File


Using CodeWatch

CodeWatch is a powerful software development tool that can help you locate bugs in your Open PL/I programs. There are two versions of CodeWatch available with Open PL/I:

  • a command-line interface
  • a Windows interface

The command-line version offers a traditional line-oriented interface allowing you to interactively enter commands from the keyboard. The Windows interface offers at least two main windows: one that allows you to enter commands and one that allows you to view your source code. You access CodeWatch commands through pulldown menus and dialogs. The Windows interface runs on a graphical workstation running X-Windows.

CodeWatch enables you to control program execution to set breakpoints, monitor what is happening, examine static type data, and evaluate results. CodeWatch keeps track of variables, subroutines, and data types in terms of the symbols used in the source language. You can reference these items without having to consider the underlying machine language or architecture. You can use CodeWatch to access the source text of the program, to identify and reference program entities, and to detect errors in the program's algorithms and logic.

Note: Your programs must be compiled using the -deb option before they can be run under the control of the debugger. (Every module need not be compiled in -deb mode, but at least one must be; CodeWatch debugs only the modules compiled in -deb mode.) When executed with the -deb option, the Compiler generates a separate symbol table file, filename.stb, in the current directory. filename.stb contains symbolic information that the debugger uses to reference and manipulate source program symbols and entities; set breakpoints, tracepoints, and watchpoints; and control program execution.

See the CodeWatch User's Guide for detailed information on CodeWatch.

Parent topic: Running a Program


Creating a DLL

To create a .dll, you need to compile and link one or more object files. This is done by using the command below:

mfplx newdll.pli -deb -defext -dll

In this example, newdll.pli is your source file. You compile and link it in one step with the command-line driver mfplx.

-deb produces debugging information for CodeWatch.

-defext causes external variables to be defined in the .data section. You must use the link option -dll to create a .dll.

You also need to add to the command one of the options below:

  • -mvs - for programs executed under the control of JCL.
  • -ims - for programs executed under the control of IMS.
  • -cics - for programs executed under the control of CICS.
Parent topic: Running a Program


Using Open PL/I with Other Software Products

Because Open PL/I supports a wide range of data types and because it supports standard calling sequences, Open PL/I can be used with many other software products. These include other Micro Focus products as well as products from other companies. This section lists some of the products that Open PL/I is known to work with and gives some hints about using them with Open PL/I.

  • UniKix
  • DB2
  • C++/Views
  • Open PL/I and Informix
  • Open PL/I and Micro Focus
Parent topic: Using Open PL/I


UniKix

UniKix is UniKix Technologies' CICS system for open systems. Open PL/I supports and is supported by UniKix to enable you to develop On-Line Transaction Processing applications in PL/I.

To create UniKix screens, use UniKix's BMS screen generator utility. Within your screen definition place the command:

LANGUAGE = PLI

Open PL/I provides a CICS precompiler, kixplt, that you can use to process embedded EXEC CICS statements within your PL/I programs. For more information about using Open PL/I's CICS precompiler, see the section Precompiler and Preprocessor Order of Execution .

Note:

While the CICS precompiler can be invoked directly with kixplt, we recommend that you invoke it with the -unikix option to the mfplx command.

The following restrictions apply to Open PL/I programs being used as UniKix applications:

  • Ordinary PL/I input/output statements must not be used. There are EXEC CICS commands for accessing data files.
  • Open PL/I sort routines, PLISRTx, must not be used.
  • STATIC storage must be read-only. The INITIAL attribute can be used to assign values to variables in STATIC storage.
  • The following PL/I statements must not be used: DELAY, STOP.
  • Variables or structures must not be defined with variable names that are the same as variable names generated by the CICS precompiler. These names begin with "DFH."

If OPTIONS(MAIN) is specified in an application program, that program can be the first program of a transaction, or control can be passed to it by means of an EXEC CICS LINK or XCTL command.

The definition of the External Interface Block (EIB) is generated in each program based upon the pointer variable DFHEIPTR. In programs compiled with OPTIONS(MAIN), the DFHEIPTR variable is set by UniKix to address the EIB on entry; therefore, the CICS precompiler will insert DFHEIPTR and DFHCOMMAREA (pointer to the communications area) as parameters of the MAIN program. For example, the following source line

TEST: PROCEDURE OPTIONS(MAIN);

will be translated to

TEST: PROCEDURE(DFHEIPTR, DFHCOMMAREA) OPTIONS(CICSMAIN);

In programs other than those declared with OPTIONS(MAIN), addressability to the EIB is the user's responsibility. This can be achieved by using the CICS command

EXEC CICS ADDRESS EIB(DFHEIPTR);

or by passing the EIB address or the values of particular EIB fields as parameters.

To perform proper initialization and cleanup, all procedures declared with OPTIONS(MAIN) that contain EXEC CICS statements, or that are calling other procedures containing EXEC CICS statements, must be run through the CICS precompiler.

Open PL/I's UniKix support is license managed. You must obtain a special license from Micro Focus to use it. Of course, you must also have the UniKix product.

Parent topic: Using Open PL/I with Other Software Products
Related information
Precompiler and Preprocessor Order of Execution


DB2

Open PL/I can be used with the IBM's DB2 database system. Open PL/I has a precompiler for embedded EXEC SQL statements in your PL/I programs.

Note:

While the DB2 precompiler can be invoked directly with mfdb2, we recommend that you invoke it with the -db2 option to the mfplx command.

Open PL/I's DB2 support is license managed. You must obtain a special license from Micro Focus to use it. Of course, you must also have IBM's DB2 product.

Parent topic: Using Open PL/I with Other Software Products
Related information
Precompiler and Preprocessor Order of Execution
Open PL/I SQL Options


C++/Views

C++/Views is Intersolv's object-oriented graphical user interface (GUI) program framework. C++/Views includes an interactive graphical designer, as well as an extensive C++ class library. Using C++/Views, you can create the framework for an application with an attractive and efficient graphical user interface. Your C++ framework can then call procedures written with Open PL/I to do your ordinary data processing work.

A C++/Views example, PhoneList, is included in the product set. The example consists of a number of C++ source modules and one PL/I module, a readme file, and a makefile.

C++/Views is not yet available on the following platform supported by Open PL/I:

  • Intel-based computers running UNIX SVR4 or Windows
Parent topic: Using Open PL/I with Other Software Products


Open PL/I and Informix

Open PL/I follows the native C compiler's naming conventions. This allows you to mix subroutines and functions compiled with Open PL/I with any other language or third-party library that supports a C language interface. However, you must link the Open PL/I run-time libraries into the final stand-alone program. The -cisam link option enables the C-ISAM package from Informix for VSAM/indexed files.

Informix fully documents their Application Programming Interface for the C language. In general, you should follow the Informix directions for mixing Informix and C, simply treating the modules compiled with Open PL/I as C modules.

The following examples illustrate the command used to link an Open PL/I program that uses the Informix libraries. For the purposes of this illustration the Open PL/I Compiler and Informix modules are running on a Sun Solaris system. The Open PL/I modules are called "testobj1.o" and "testobj 2.o", the Open PL/I Compiler has been installed in /opt /pl1, and the environment variable $MFPLI_PRODUCT_DIR has been set to that directory.

ldpli testobj1.o testobj2.o -o testprogram
/opt/informix/lib/esql/libsql.a
/opt/informix/lib/esql/libgen.a
/opt/informix/lib/esql/libos.a
/usr/ucblib/libucb.a
/opt/SUNWspro/SC3.0/lib/cg92/_fstd.o

Note that the names and locations of the Open PL/I and Informix libraries are specific to your installation of Informix and Open PL/I. This illustrates a typical installation.

Parent topic: Using Open PL/I with Other Software Products
Related information
Language Concepts


Open PL/I and Micro Focus

Open PL/I follows the native C compiler's naming conventions. This allows you to mix subroutines and functions compiled with Open PL/I with any other language or third party library that supports a C language interface. You must link the Open PL/I run-time libraries into the final stand-alone program. Micro Focus fully documents inter-language calling between COBOL/2 and C. In general, you should follow the Micro Focus directions for mixing COBOL and C, simply treating the modules compiled with Open PL/I as C modules. The following test program illustrates a COBOL program that calls a PL/I function, passing a string as an argument.

The COBOL source code module:

WORKING-STORAGE SECTION. 01 STR PIC X(20).
*
PROCEDURE DIVISION.
CALL-PL1 SECTION.
DISPLAY "Calling the PL/I program".
CALL "PL1PROC" USING STR.
DISPLAY "Return from PL/I program".
DISPLAY STR.
STOP RUN.

The PL/I source code module:

PL1PROC: PROCEDURE ( CHARSTR );
DECLARE CHARSTR CHARACTER(20);

CHARSTR = 'This is a real test!';

END PL1PROC;

The commands to compile and link:

mfplx mfpll.pl1 -stat -c

cob mfcob.cbl mfpl1.o -o mf -v -V -x \
    /pl1dir/lib/dflock.o071030 \
    /pl1dir/lib/noofm.o071030\
    /pl1dir/lib/lpi.a071030

Note that the names and locations of the Open PL/I libraries are specific to your version of Open PL/I. This illustrates a typical installation.

Parent topic: Using Open PL/I with Other Software Products


Compiling, Linking and Debugging of Fetchable Procedures

  • Compiling and Linking of Programs That Are to Be Used As Fetchable Procedures
  • Debugging of Fetchable Procedures
Parent topic: Using Open PL/I


Compiling and Linking of Programs That Are to Be Used As Fetchable Procedures

To compile a program to be used as a fetchable procedure, enter the command:

mfplx -dll -defext myfetch.pli
Note: The compiler options -mvs, -ims, -cics should only be used for the OPTIONS(MAIN) programs. The use of -dll indicates that it is a dynamically linked called subroutine.
Parent topic: Compiling, Linking and Debugging of Fetchable Procedures
Related information
Restrictions


Debugging of Fetchable Procedures

To debug the logic contained within a fetchable procedure you need to use the shlib command to load its symbolic information into the debugger. If you want to stop the debugger just before the invocation of MYFETCH, use the following command:

shlib MYFETCH.dll

As result of this a breakpoint will be set when MYFETCH.dll is loaded and you can then use the env command to switch to the appropriate source code display within MYFETCH.dll and set breakpoints where you think it is appropriate.

If you do not issue the shlib command, the execution will work as expected but you won't be able to debug MYFETCH. Additionally, if a trap occurs within MYFETCH.dll you will not see the source line where the trap occurred but will simply receive a message indicating a hex offset with MYFETCH.

Parent topic: Compiling, Linking and Debugging of Fetchable Procedures


Language Concepts

This chapter describes the Open PL/I language implementation for your system. For detailed information on the Open PL/I programming language, see your Open PL/I Language Reference Manual.
  • Line Boundaries
  • Main Procedure
  • Data Types
  • Arithmetic Precision
  • External Procedures
  • Maximum Number of Arguments for a Function or Subroutine Call
  • Open PL/I Calling Conventions
Parent topic: Open PL/I User's Guide


Line Boundaries

A line boundary consists of a new-line character (CRLF on a Windows system), and the line boundary in a quoted string constant is considered part of the string constant.

Parent topic: Language Concepts


Main Procedure

Exactly one of the external procedures that is linked into an executable file must specify the main entry point to the program by including the OPTIONS(MAIN) clause on the PROCEDURE statement. This designates that procedure as the main entry point at which execution should begin, after some run-time initialization has been completed. This option must appear even if the entire program is a single procedure contained in a single source file. Failure to specify a main program, or specifying more than one main program, will cause errors to occur during program linkage.

The main procedure is not required to be a PL/I procedure; that is, it can be written in another language.

Parent topic: Language Concepts


Data Types

The table below lists the Open PL/I data types, along with the alignment and size of their machine representations.

Alignment is the same for HP PA-RISC, Intel, RS/6000, and Sun SPARC, unless otherwise specified.

Data Type | Size | Alignment: aligned data | Alignment: unaligned data
Fixed Binary ( p ? 7) 1 | 1 byte | 1 byte | byte
Fixed Binary (8 ? p ? 15) | 2 bytes | 2 bytes | byte
Fixed Binary (p > 15) | 4 bytes | 4 bytes | byte
Fixed Decimal (p,q) | [(p+2)/2] bytes | byte | byte
Float Binary (p ? 23) | 4 bytes | 4 bytes | byte
Float Binary (p > 23) | 8 bytes | 4 bytes (Intel), 8 bytes (non-Intel) | byte
Float Decimal (p) | 12 bytes | 4 bytes | byte
Character (n) | n bytes | byte | byte
Character (n) Varying | n+2 bytes | 2 bytes | byte
Widechar (n) | n*2 bytes | byte | byte
Widechar (n) Varying | n*2+2 bytes | Half-word | byte
Bit (n) | n bits | bit | bit
Bit (n) Aligned | [(n+7)/8] bytes | byte | –
Pointer | 4 bytes | 4 bytes | byte
Picture | n bytes | byte | byte
Label | 8 bytes | 4 bytes | byte
Entry Variable | 8 bytes | 4 bytes | byte
File Variable | 4 bytes | 4 bytes | byte
Structure2 | sum of members + gaps for alignment | max of members | byte
Area (n) | (((n+7)/8)*8)+8 bytes | 8 bytes | –
Offset | 4 bytes | 4 bytes | byte

Subsequent sections provide additional information about the size, alignment, internal representation including byte ordering, and range, where applicable.

The byte ordering on the HP PA-RISC, IBM RS/6000, and Sun SPARC platforms is Big Endian, while the Intel-based platforms have Little Endian byte ordering.

Note:

In the descriptions of data types that follow, the alignment specified is the default, which is ALIGNED for all data types except Bit. For the alignment of each data type with the UNALIGNED attribute, refer to the table above.

  • Fixed Binary (p ? 7)
  • Fixed Binary (8 ? p ? 15)
  • Fixed Binary (15 ? p ? 31)
  • Fixed Decimal (p,q)
  • Float Binary (p ? 23)
  • Float Binary (23 < p ? 52)
  • Float Decimal (p)
  • Character (n)
  • Character (n) Varying
  • Widechar (n)
  • Widechar (n) Varying
  • Bit (n)
  • Bit (n) Aligned
  • Pointer
  • Label
  • Picture
  • Entry
  • File Variable
  • Structure
  • Area (n)
  • Offset
Parent topic: Language Concepts
1

*Fixed Binary (p ? 7) is handled as a one-byte signed binary integer only if the -vax Compiler option is in effect. Otherwise, it is handled as Fixed Binary(15).

2 See the Structure topic for mapping conventions.


Fixed Binary (p ? 7)

Fixed Binary (p 7) is an 8-bit, signed, 2's complement binary integer. The low order 7 bits contain the integer, the high order bit contains the sign. The sign bit (S) is 1 if the value is negative, 0 if the value is positive or zero. This data type is available only when you use the -vax Compiler option.

Size | Alignment | Range
1 byte | 1 byte | -128 to 127
Parent topic: Data Types


Fixed Binary (8 ? p ? 15)

Fixed Binary (8 ? p ? 15) is a 16-bit, signed, 2's complement binary integer. The low order 15 bits contain the integer, the high order bit contains the sign. The sign bit (S) is 1 if the value is negative, 0 if the value is positive or zero.

Size | Alignment | Range
2 bytes | 2 bytes | -32768 to 32767
Parent topic: Data Types


Fixed Binary (15 ? p ? 31)

Fixed Binary (15 ? p ? 31) is a 32-bit, signed, 2's complement binary integer. The low order 31 bits contain the integer, the high order bit contains the sign. The sign bit (S) is 1 if the value represented is negative.

Size | Alignment | Range
4 bytes | 4 bytes | -2,147,483,648 to 2,147,483,647
Parent topic: Data Types


Fixed Decimal (p,q)

Fixed Decimal (p,q) is a fixed-point number that contains p digits, where q of those digits are fraction digits. Fixed decimal values are typically used only when fraction digits are required. Fixed-point decimal values are always stored as an accurate representation of decimal fractions. The most significant digits are stored at the lowest memory address, and the byte containing the least significant digit and the sign (hexadecimal C for positive or D for negative) is stored at the highest memory address.

Size | Alignment | Range
[(p+2)/2] bytes | byte | -(10p-q - 10-q) to +(10p-q -10-q
Parent topic: Data Types


Float Binary (p ? 23)

Float Binary (p ? 23) is a single-precision, basic format, binary floating-point number (ASCII/IEEE 754-1985 compliant). It contains a 1-bit sign, 8-bit biased exponent (bias = 127), and 23+(1)-bit binary fraction (hidden bit).

An exponent of 255 represents +/- infinity or not-a-number. +/- infinity is represented by an exponent of 255 and zero as the fraction part; the sign bit denotes the + or - infinity. Not-a-number is represented by an exponent of 255 and any non-zero value in the fraction part; the sign bit of not-a-number is not significant. An exponent of 0 denotes a denormalized small value of reduced precision. Both +0 and -0 are possible. Note that the range is approximate and indicates representable values, which include zero and both negative and positive numbers.

Size | Alignment | Approximate Absolute Value of Range
4 bytes | 4 bytes | 1.40E-45 to 3.40E+38
Parent topic: Data Types


Float Binary (23 < p ? 52)

Float Binary (23 < p ? 52) is a double-precision, basic format, binary floating-point number (ANSI/IEEE 754-1985 compliant). It consists of a 1-bit sign, 11-bit biased exponent (bias = 1023), and 52+(1)-bit binary fraction (hidden bit).

An exponent of 2047 represents +/- infinity or not-a-number. +/- infinity is represented by an exponent of 2047 and zero as the fraction part; the sign bit (S) denotes the + or - infinity. Not-a-number is represented by an exponent of 2047 and any non-zero value in the fraction part; the sign bit of not-a-number is not significant. An exponent of 0 denotes a denormalized value of reduced precision. Both +0 and -0 are possible. Note that the range is approximate and indicates representable values, which include zero and both negative and positive numbers.

Size | Alignment | Approximate Absolute Value of Range
Size | Alignment | Approximate Absolute Value of Range
Size | Alignment | Approximate Absolute Value of Range
8 bytes | 4 bytes (Little Endian) 8 bytes (Big Endian) | 4.9E-324 to 1.8E+308
8 bytes | 4 bytes (Little Endian) 8 bytes (Big Endian) | 4.9E-324 to 1.8E+308
8 bytes | 4 bytes (Little Endian) 8 bytes (Big Endian) | 4.9E-324 to 1.8E+308
Parent topic: Data Types


Float Decimal (p)

For compatibility with IBM PL/I, data declared as float decimal is stored and processed by default as 4-byte or 8-byte float binary. (If the specified precision is ? 6, 4-byte float binary is used.)

Alternatively, float decimal data can be stored and processed as 12-byte Binary Coded Decimal BCD float decimal data by using the -nofdasfb ("no float dec as float bin") compiler option. In this case, Float Decimal (p) is a decimal floating-point number, stored in packed decimal format. It consists of a sign, an exponent sign, two bits used for infinity, not-a-number (usually 0), a 3-digit (base 10) exponent and a 17-digit (base 10) fraction. Both the exponent and fraction have a separate sign bit. All digits are packed Binary Coded Decimal (BCD), such that the entire string fits in 96 bits (12 bytes). The fraction contains at least p decimal digits.

Size | Alignment | Approximate Absolute Value of Range
12 bytes | 4 bytes | 9.9999999999999999x10 -999 to 9.9999999999999999x10 999
Parent topic: Data Types


Character (n)

Character (n) is a character-string variable where n is an integer that specifies the length of the string value held by the variable. Character (n) is a sequence of 8-bit ASCll characters stored as 1 character per byte. In Open PL/I, the maximum length of a string variable is 32767 characters.

Size | Alignment
n bytes | byte
Parent topic: Data Types


Character (n) Varying

Character (n) Varying is a character-string variable. The VARYING attribute causes the string variable to hold values of varying length. The representation of a varying string variable in storage is such that any string up to n characters may be held by the variable, and the length of the current string is retained as part of the value. Character (n) Varying is stored as follows: the first two bytes contain the length of the string (represented by a Fixed Binary (15) number) followed by a sequence of 8-bit ASCII characters stored as 1 character per byte. In Open PL/I, the maximum length of a string value is 32767 characters.

Note that the character string is not terminated with a null (ASCII 0) character.

Size | Alignment
n+2 bytes | 2 bytes
Parent topic: Data Types


Widechar (n)

Widechar (n) is a character-string variable where n is an integer that specifies the length of the string value held by the variable. Widechar (n) is a sequence of "byte-pairs" stored as 1 wide character in adjacent bytes (Big Endian order). In Open PL/I, the maximum length of a wide string variable is 16383 wide characters.

Widechar byte table

Size | Alignment
n*2 bytes | byte
Parent topic: Data Types


Widechar (n) Varying

Widechar (n) Varying is a wide character-string variable. The VARYING attribute causes the string variable to hold values of varying length. The representation of a varying string variable in storage is such that any string up to n wide characters may be held by the variable, and the length of the current string is retained as part of the value. Widechar (n) Varying is stored as follows: the first two bytes contain the length of the string (represented by a Fixed Binary (15) number stored in machine native format) followed by a sequence of wide characters stored as 1 wide character (or "byte-pair") in adjacent bytes (Big Endian order). In Open PL/I, the maximum length of a wide string value is 16383 characters.

Widechar (n) Varying byte table

Size | Alignment
n*2+2 bytes | Half-word
Parent topic: Data Types


Bit (n)

Bit (n) is a bit-string variable where n is an integer valued expression that specifies the length of the string value held by the variable. Bit (n) is a sequence of binary digits (bits) that always occupies exactly n bits of storage.

Big-endian platforms:

If the high-order bit of the bit-string does not occur on a byte boundary, the remaining bits in the last byte might be part of another bit-string variable. Within each byte, the bits of the string are stored from the low-order to the high-order bit position. Note the bit positions are zero-relative similar to the hardware bit-numbering. For example, Bit (23) would be stored as follows:

Little-endian platforms:

If the low-order bit of the bit-string does not occur on a byte boundary, the remaining bits in the last byte might be part of another bit-string variable. Within each byte, the bits of the string are stored from the low-order to the high-order bit position. Note the bit positions are zero-relative similar to the hardware bit-numbering. For example, Bit (23) would be stored as follows:

On little-endian platforms, bit-strings are essentially stored "right-to-left" according the Intel hardware bit-ordering, but all bit operations are performed according to PL/I language semantics.

Note: Overlaying fixed bin and bit items is non-portable between big-endian and little-endian architectures.
Size | Alignment
n bits | bit (none)
Parent topic: Data Types


Bit (n) Aligned

Bit (n) Aligned is a bit-string variable. The ALIGNED attribute causes the bit-string variable for which it is declared to be byte-aligned, resulting in more efficient access. This attribute may also cause the variable to occupy more than n bits, but it does not increase the length of the value that can be stored in the variable. The ALIGNED attribute has no effect on operations performed on the variable, but is considered part of the data type for purposes of argument/parameter matching and storage sharing.

Bit (n) Aligned size is in bytes. If the length, n, is not a multiple of eight (for example, Bit (27) Aligned) then the remaining bits in the last byte are unused. Within each byte, the bits of the string are stored from the high-order to the low-order position. For example, Bit (27) Aligned would be stored as follows:

Size | Alignment
[(n+7)/8] bytes | byte
Parent topic: Data Types


Pointer

Pointer is a 4-byte, 32-bit word variable capable of holding the address of any variable except unaligned bit variables. Pointers are normally used to locate the storage of dynamically allocated BASED variables rather than as a mechanism for accessing another variable's storage. A pointer is used with a template to access the storage to which it points. A pointer value cannot be represented by a constant. Pointer values can be assigned, compared for equality or inequality, passed as arguments, and returned from functions. No calculations or conversions can be performed on them, and they cannot be transmitted in stream I/O.

Size | Alignment
4 bytes | 4 bytes
Parent topic: Data Types


Label

Label is an 8-byte, 32-bit word pair variable consisting of a 4-byte text address and a 4-byte frame pointer value. The text address identifies the first instruction of a labeled statement in the containing procedure. The frame pointer value identifies the address of the stack frame of the block containing the statement. Label values can be assigned, compared for equality or inequality, passed as arguments, and returned from functions. No calculations or conversions can be performed on them, and they cannot be transmitted in stream I/O.

Size | Alignment
8 bytes | 4 bytes
Parent topic: Data Types


Picture

Picture is a fixed-point decimal value stored internally as a character string. The string contains the characters that represent the numeric value, and may be formatted with special embedded symbols such as a period (.) or a comma (,). Picture data is best used to manipulate a quantity arithmetically and then print or display its value.

Size | Alignment
n bytes | byte
Parent topic: Data Types


Entry

Entry is an 8-byte, 32-bit word pair variable consisting of a 4-byte descriptor pointer and a 4-byte frame pointer value. The descriptor pointer points to a data area that specifies the text address of the procedure entry and the table of contents pointer for the procedure. The frame pointer (relevant only with internal procedures) designates the stack frame of the containing procedure, if any. For external procedures, the frame pointer value is zero (0).

Size | Alignment
8 bytes | 4 bytes
Parent topic: Data Types


File Variable

File Variable is represented internally as a 4-byte, 32-bit word containing the address of a file control block. When evaluated, the value of the file variable is the address of the file control block for the file with which the variable is associated. A file variable can be assigned any file value; it is declared using both the FILE and VARIABLE attributes.

Size | Alignment
4 bytes | 4 bytes
Parent topic: Data Types


Structure

Structure is a hierarchically ordered set of values that may be of different data types. The immediate components of a structure are called "members" of the structure. An entire structure can be transmitted in stream or record I/O, passed as an argument, or assigned to another structure of identical size and shape and having members of corresponding identical data types. No conversions or calculations can be performed on entire structures.

Size | Alignment
Sum of members + gaps for alignment | Most stringent of members' alignment requirements

In Open-PL/I, structure mapping is as follows:

  • Each member is aligned to its natural boundary (offset from the start of the structure) as determined by the native machine architecture. Each member offset is effectively "pushed ahead" to map to its natural boundary, and where necessary, pad bytes may be introduced.
  • The alignment of the top-level structure (and substructures) will inherit the most stringent alignment requirement of its members.
Parent topic: Data Types


Area (n)

Area (n) is a variable describing a region of storage whose size in bytes is defined by the integer n. An area variable is a region of storage in which based variables can be allocated and freed. An area can be passed as an argument or it can be assigned to another area. It can also be transmitted in its entirety in a record I/O operation. No other operations, calculations, or conversions can be performed on area variables.

Size | Alignment
n bytes rounded to 8 byte boundary, plus 8 byte header [ (((n+7)/8)*8)+8] bytes | 8 bytes

Related Topics

Offset

Parent topic: Data Types
Related information
Offset


Offset

An offset variable is a locator used only in conjunction with an area variable. The value of an offset variable specifies the location of a based variable within an area, relative to the beginning of the area.

Offset variables can be assigned, compared for equality and inequality, passed as arguments, and returned as function results. No calculations or conversions can be performed on them, except in the context of explicit conversion to a Pointer, using Open PL/I's POINTER built-in function.

Size | Alignment
4 bytes | 4 bytes
Parent topic: Data Types
Related information
Area n


Arithmetic Precision

Each arithmetic data type has a default precision and a maximum precision as specified in Table 2-2. The range of the scale factor of fixed-point decimal data is 0 through 18 (0 ? q ? 18).

Data Type | Maximum Precision | Default Precision
Fixed Binary | 31 | 15*
Fixed Decimal | 18 | 5
Float Binary | 52 | 23
Float Decimal | 16 | 6

* The -Iongint Compiler option changes the default precision of fixed binary from 15 to 31.

Parent topic: Language Concepts


External Procedures

Open PL/I adheres to the calling conventions of the native architecture. Programs compiled by Open PL/I can be linked with object modules produced by other language products, and the resulting object program will run if the following conditions are met:

  • The calling conventions used by other language product(s) also adhere to the calling conventions of the native architecture. Note that the system C compiler on UNIX and the Windows Visual C/C++ compiler meet this requirement.
  • Declarations for formal and actual parameters in the calling and called programs must be written in their respective languages, so that the data representations assumed in the declarations agree with each other.
  • External Names
Parent topic: Language Concepts


External Names

Certain rules apply with regard to name length and the use of lowercase letters when specifying an identifier name:

  1. Name length: Open PL/I allows names up to 256 characters long.
  2. Lowercase names: By default, Open PL/I treats all names, including external names, as if all lowercase letters were upper case. When interfacing with non-PL/I external procedures, it may be necessary to work around this. For example, the C language preserves the case of all external names.

    If Open PL/I is calling a C function or vice-versa, one of the following options is available.

    • Spell with uppercase letters the external names in the C function where needed.
    • Use the EXTERNAL('name') option on the PLI ENTRY declaration to specify the exact name of the external C entry point.
    • Use the Open PL/I -lowercase Compiler option, which maps all external names to lower case instead of upper case. Note that all external names produced are lower case, not just the entry point to a procedure.
Parent topic: External Procedures


Maximum Number of Arguments for a Function or Subroutine Call

The maximum number of arguments that may be passed in an Open PL/I program is given by the following formula, which holds generally for any function or subroutine call argument list:

N + M= 241

where:

N | Is the actual number of arguments specified.
M | Is the position of the last *-extent argument, or zero if none exists.

Example:

DECLARE (S, T, U, V) CHAR (32),
   (I, J, K, L) BINARY (15),
   MYSUB ENTRY (BINARY(15), BINARY (15), CHAR(*),
         CHAR(*), BINARY(15), BINARY(15));
.
.
.
   CALL MYSUB(I,J,K,S,T,L);

where:

N | = 6 (the number or arguments specified)
M | = 5 (the position of "T" in the argument list)

which gives:

N+ M = 11 (6 actual arguments; 3 dummy descriptors for I, J, and K; and 2 actual descriptors for S and T).
Parent topic: Language Concepts


Open PL/I Calling Conventions

The following sections describe the calling conventions for HP, Intel, RS/6000, and Sun Sparc systems. All LPI-series languages compilers use the following calling conventions and are compatible with Open PL/I.

  • Calling Other Languages
  • Argument Passing Conventions
  • Register Save Conventions
  • Function Result Conventions
  • Open PL/I Equivalent Data Types
Parent topic: Language Concepts


Calling Other Languages

If you are calling a function written in another language, the result type must be able to be mapped to a PL/I data type.

C often expects character strings to be null terminated, that is, the string is delimited by an '\0' byte immediately following the last character of interest. When constructing a character value in PL/I that is passed to a C function expecting a null terminator, the PL/I procedure must supply an explicit null character in the appropriate position. The BYTE built-in function can be used for this purpose, as shown in the following example.

call CFUNC('abcde' || BYTE(0))

or without the BYTE built-in using z-character constants,

call CFUNC('abcde'Z)
  • C Calling Conventions
Parent topic: Open PL/I Calling Conventions


C Calling Conventions

The following program illustrates how to declare and call two standard C library functions, "atoi" and "strtol":

int atoi(const char *str)

long strtol(const char *str, char **endptr, int base)

Please note the following points:

  1. Since C is case-sensitive and PL/I is not, use EXTERNAL('name') to map the PL/I name to the function's real name.
  2. Since C arguments are passed by immediate value, specify the VALUE attribute for FIXED BINARY parameters.
  3. Because PL/I arguments are normally passed by reference, the VALUE attribute is not necessary for char * arguments declared CHARACTER(n). However, when a char * argument is declared POINTER, as in the ATOI_2 declaration, the VALUE attribute is required.
  4. By convention, C strings are terminated with a NULL byte.
  5. In this example, although char * is declared CHARACTER(80), any length long enough to hold the string and a terminating null byte would be all right. Of course, if the C function expected a pointer to a character string of a certain length, the PL/I and C declarations should agree.
  6. Note the use of the z-character constants for compatibility with C-style null-terminated strings, and the use of the SYSNULL() built-in, which returns 0, as opposed to the NULL() built-in, which returns -1 by default.
    CALLC: PROCEDURE OPTIONS(MAIN);

DECLARE

ATOI   ENTRY(CHARACTER(80))
       RETURNS(FIXED BINARY(31))
       EXTERNAL('atoi'),

ATOI_2 ENTRY(POINTER VALUE)
       RETURNS(FIXED BINARY(31))
       EXTERNAL('atoi'),

STRTOL ENTRY(CHARACTER(80),
             POINTER VALUE,
             FIXED BINARY(31) VALUE)
       RETURNS(FIXED BINARY(31))
       EXTERNAL('strtol'),

BASE   FIXED BINARY(31),
ENDPTR POINTER,
INT    FIXED BINARY(31),
LONG   FIXED BINARY(31),
STR    CHARACTER(80),
STRPTR POINTER;

STR    = '2147483647'z;
INT    = ATOI(STR);

PUT SKIP LIST(INT);

STRPTR = ADDR(STR);
INT    = ATOI_2(STRPTR);

PUT SKIP LIST(INT);

STR    = '0x7fffffff'z;
ENDPTR = SYSNULL();
BASE   = 16;
LONG   = STRTOL(STR, ENDPTR, BASE);

PUT SKIP LIST(LONG);

PUT SKIP LIST(STRTOL('0x7fffffff'z, SYSNULL(), 16));

END CALLC;
Parent topic: Calling Other Languages


Argument Passing Conventions

The following sections detail the argument passing conventions for HP, Intel, RS/6000, and Sun Sparc platforms.

  • HP Argument Passing Conventions (32-bit)
  • Intel Argument Passing Conventions (32-bit)
  • RS/6000 Argument Passing Conventions (32-bit)
  • Sun Sparc Argument Passing Conventions (32-bit)
Parent topic: Open PL/I Calling Conventions


HP Argument Passing Conventions (32-bit)

Arguments are passed in General Purpose Registers (GR) 26–23, Single-Precision Floating-Point Registers (FR) 4–7, Double-Precision Floating-Point Registers (FR) 5 and 7, and in the parameter area of the stack, according to the Open PL/I standard calling conventions.

  • If the function returns a value in a temporary storage area, a pointer to that area is passed in GR28.
  • The argument list contains addresses of the actual arguments in order or their appearance. If any arguments have the VALUE attribute, the actual argument is passed.
  • If OPTIONS(VARIABLE) is used, any missing arguments are replaced by null pointers.
  • If any of the function's parameters have variable extents, for example, asterisks(*), the addresses of dope vectors describing the arguments are appended to the explicit argument list.
Parent topic: Argument Passing Conventions


Intel Argument Passing Conventions (32-bit)

  • The calling procedure pushes the addresses of the actual arguments (pointers) onto the stack in the reverse order of their appearance in an argument list. In other words, the address of the last argument is pushed first and the address of the first argument is pushed last.
  • A call to a function returning one of the data types that requires a return temporary must push a pointer to the area for the result value onto the stack.

The external procedure is called by executing a CALL instruction.

Parent topic: Argument Passing Conventions


RS/6000 Argument Passing Conventions (32-bit)

Arguments are passed in General Purpose Registers (GPR) 3–10, Floating-point Registers (FPR) 1–13, and in the parameter area of the stack according to the Open PL/I standard calling conventions.

  • If the function returns a value in a temporary storage area, a pointer to that area is passed in GPR3 and all other arguments are displaced by one.
  • The argument list contains addresses of the actual arguments in order of their appearance. If any arguments have the VALUE attribute, the actual argument is passed.
  • If OPTIONS(VARIABLE) is used, any missing arguments are replaced by null pointers.
  • If any of the function's parameters have variable extents, for example asterisks (*), the addresses of dope vectors describing the arguments are appended to the explicit argument list.
Parent topic: Argument Passing Conventions


Sun Sparc Argument Passing Conventions (32-bit)

External procedures are called using the CALL instruction and are returned using the RET and RESTORE sequence.

  • The first six parameters are passed in the output registers; that is, the first parameter is passed in register o0, the second in register o1 and the sixth one in register o5. Parameters beyond the sixth are passed on the stack.
  • If OPTIONS(VARIABLE) is used, any missing arguments in the call to the procedure are replaced by null pointers.
  • The external procedure is called by executing a CALL instruction.
Parent topic: Argument Passing Conventions


Register Save Conventions

The following sections detail the register save conventions for HP, Intel, and Sun Sparc systems.

  • HP Register Save Conventions (32-bit)
  • Intel Register Save Conventions (32-bit)
  • RS/6000 Register Save Conventions (32-bit)
  • Sun Sparc Register Save Conventions (32-bit)
Parent topic: Open PL/I Calling Conventions


HP Register Save Conventions (32-bit)

The called procedure is expected to save and restore values in registers GR3–GR18 and FR12–FR21. The calling procedure can assume that those registers are preserved across the call. The function result is in GR28, FR4, or the result temporary provided by the caller, depending on the result data type. For more information, see the section HP Function Result Conventions.

Parent topic: Register Save Conventions
Related information
HP Function Result Conventions


Intel Register Save Conventions (32-bit)

The contents of ebx, esi, and edi must be preserved across a subroutine call. If a subroutine uses one of these registers, it must save the original value and restore it before returning to the caller.

Registers eax, ecx, and edx are scratch registers. A subroutine can change the value in a scratch register without saving its previous value.

When the Intel floating-point coprocessor is used, the floating-point stack registers must be empty before entry and upon exit from a subroutine. However, if the subroutine returns a floating-point value, the value is returned on top of the stack in register fp0 and the remainder of the stack is empty.

A called procedure is responsible for establishing a new stack frame for itself and saving and restoring all preserved registers. The procedure establishes the stack frame with the following sequence:

pushl ebp
movl esp, ebp
subl #framesize, esp
pushl ebx         //only if used within function
pushl esi         //only if used within function
pushl edi         //only if used within function

Note that the code sequence may be abbreviated if -opt is specified.

A return must store any function result value, restore any preserved registers it used, pop its stack frame, and return to the caller.

A procedure that returns one of the data types that requires a return temporary must remove the extra pointer(s) from the stack entry; callers to such routines push these hidden arguments. The called routine must load register eax with the pointer to the return area that its caller passed before returning. Such a routine will start with the following code before establishing a frame:

popl edx
xchgl edx, 0 (esp)

Then it saves the return pointer in a local variable in its stack frame.

Parent topic: Register Save Conventions


RS/6000 Register Save Conventions (32-bit)

The called procedure is expected to save and restore values in registers GPR13 through GPR31 and FPR14 through FPR31. The calling procedure can assume that those registers are preserved across the call. The function result is in GPR3, FPR1, or the result temporary provided by the caller, depending on the result data type.

Parent topic: Register Save Conventions


Sun Sparc Register Save Conventions (32-bit)

The called procedure is expected to save and restore all local and input registers (10 through 17 and i0 through i7). The calling procedure can assume that only these registers are preserved across the call. The function result is general ally in o0, f0, or both f0 and f1, or the result temporary provided by the caller, depending on the result data type. For more information, see the section Sun Sparc Function Result Conventions.

A called procedure is responsible for establishing a new stack frame for itself and saving and restoring all local and input registers. This is accomplished by a SAVE instruction. Before returning, the called procedure must store any function result value, restore all local and input registers, and adjust the stack frame. This is accomplished by a load of i0, f0, or both f0 and f1, or a store to a result temporary and a RESTORE instruction.

Parent topic: Register Save Conventions
Related information
Sun Sparc Function Result Conventions


Function Result Conventions

A function returns its result to the caller in one of four ways. The following sections detail the function result conventions on HP, Intel, RS/6000, and Sun Sparc systems.

  • HP Function Result Conventions (32-bit)
  • Intel Function Result Conventions (32-bit)
  • RS/6000 Function Result Conventions (32-bit)
  • Sun Sparc Function Result Conventions (32-bit)
  • Return of Data Types
Parent topic: Open PL/I Calling Conventions


HP Function Result Conventions (32-bit)

A function procedure returns its result value to the calling procedure in one of three ways, depending upon the data type: in register GR28, in register FR4, or in a temporary storage area provided by the caller.

If the result is returned in a temporary storage area, the calling procedure provides the temporary area and passes its address in GR28.

Parent topic: Function Result Conventions


Intel Function Result Conventions (32-bit)

On Intel x86 systems, the result of a function is returned in one of the following three ways, depending upon the result's data type and if the floating-point coprocessor is used:

  • In register eax
  • In a temporary storage area provided by the caller
  • On top of the Intel floating-point coprocessor's stack in register fp0
Parent topic: Function Result Conventions


RS/6000 Function Result Conventions (32-bit)

A function procedure returns its result value to the calling procedure in one of three ways, depending upon the data type:

  1. In register GPR3
  2. In register FPR1
  3. In a temporary storage area provided by the caller

If the result is returned in a temporary storage area, the calling procedure provides the temporary area and passes its address as the first (hidden) parameter in the call.

Parent topic: Function Result Conventions


Sun Sparc Function Result Conventions (32-bit)

On the Sun Sparc, the result of a function is returned in one of the following four ways, depending upon the result's data type:

  1. In register o0
  2. In a temporary storage area
  3. In register f0
  4. In registers f0 and f1

On Sun Sparc systems, the calling procedure provides the temporary area and stores the address to the temporary area in the one-word hidden parameter of the user frame at %sp+0x40 prior to the call.

Parent topic: Function Result Conventions


Return of Data Types

The table below lists the Open PL/I data types and the registers to which they are returned on each platform.

Open PL/I Data Type | Register Returned in
 | HP | Intel | RS/6000 | Sun Sparc
Fixed Binary Character(1), not * or Varying Bit(1), not * Pointer Offset File | GR28 | eax | GPR3 | o0
Float Binary | FR4 | on top of the floating-point coprocessor stack | FPR1 | f0/f1
Fixed Decimal Float Decimal Character( n), n > 1 or n = * Character( n) Varying Bit( n), n > 1 or n = * Picture Label Entry | Returned in Temporary Storage Area
Parent topic: Function Result Conventions


Open PL/I Equivalent Data Types

Table 2-4 lists compatible data types for determining equivalent argument type correspondence. Some data types (for example, char in C) are used more than once in the table to show the correspondence of equivalent types in more than two languages. The subscripts used in the table have the following meanings:

PL/I
 | COBOL | C | C++ | FORTRAN | BASIC | PASCAL
Fixed Bin, P <= 7 | COMP PIC S9 (1) – S9 (2) | char | char | INTEGER*1 | – | –
Fixed Bin, 8 <= P <= 15 | COMP PIC S 9 (3) – S 9 (4) | short | short | INTEGER*2 | INTEGER (%) | Integer
Fixed Bin, P >15 | COMP PIC S 9 (5) – S 9 (9) | int or long | int or long | INTEGER*4 | – | Integer
– | – | char | char | INTEGER*1 | – | Packed Array[1...5]
Character (n) | DISPLAY A(n) or PIC X(n) | char [n] | char[n] | CHARACTER*n | – | –
Character (N) Varying | DISPLAY PIC X OCCURS num1 to num2 DEPENDING on N | struct {short s; char c[n];} | struct {short s; char c[n];} | – | – | Char
Character (1) | DISPLAY PIC X | char | char | CHARACTER*1 | – | –
Character (*) | – | char[ ] | char[ ] | – | – | –
Fixed Decimal | COMP–3 PIC S9 (n) | – | – | – | – | –
 | DISPLAY PIC S9(n) SIGN TRAILING | – | – | – | – | –
– | DISPLAY PIC S9(n) SIGN LEADING SEPARATE | – | – | – | – | –
– | DISPLAY PIC S9(n) SIGN TRAILING SEPARATE | – | – | – | – | –
Bit(1) | – | – | – | – | – | –
Bit(1) Aligned | – | char | char | – | – | Boolean
Bit(N) Aligned | COMP–5 PIC [S] 9 (n), n<5 | – | – | – | – | Set
– | – | int or long | int or long | LOGICAL*4 | – | –
– | – | short | short | LOGICAL*2 | – | –
– | – | char | char | LOGICAL*1 /BYTE | – | –
Float Bin, p > 23 | COMP–2 | double | double | REAL*8 | REAL (#) (MBASIC) | –
Float Bin, p <= 22 | COMP–1 | float | float | REAL*4 | REAL (1) (MBASIC) | Real
– | – | struct {float real, imaginary;} | struct {float real, imaginary;} | COMPLEX*8 | – | –
– | – | struct {double real; double imaginary} | #include <complex.h> class complex | COMPLEX*16 | – | –
Pointer | – | Pointer | Pointer | – | – | Pointer
Label | – | – | – | alternate return | – | –
Entry | DISPLAY PIC X(32) | – | – | Dummy procedure | – | –
Float Decimal | – | – | – | – | REAL (CBASIC) | –
– | – | – | – | – | STRING ($) | –
Area | – | – | – | – | – | –
Offset | COMP PIC S 9 (5) – S 9 (9) | int or long | int or long | INTEGER*4 | – | integer
Parent topic: Open PL/I Calling Conventions


Open PL/I SQL Options

  • DB2 SQL Support
  • HCO for SQL Server Compiler Directive Options for PL/I
    Using HCO for SQL compiler directive options with PL/I.
Parent topic: Open PL/I User's Guide


DB2 SQL Support

Open PL/I enables you to develop PL/I applications that make use of databases maintained by IBM DB2. Open PL/I's DB2 SQL precompiler allows you to compile and link PL/I applications containing embedded DB2 SQL statements to access these databases. This document gives the special instructions needed to code, compile, and link such Open PL/I applications.

Support for DB2 SQL is included in the standard Open PL/I product set, but you must obtain from Micro Focus a DB2 SQL license before it can be used. Also, before you can take advantage of EXEC SQL support, you must have installed and started IBM's DB2 product on your system.

You can code DB2 EXEC SQL statements in Open PL/I applications using the language defined in the IBM document DATABASE 2 Client/Server SOL Reference. Specific requirements for your SQL code are described in the sections that follow.

  • DB2 SQL Precompiler Options
  • Coding DB2 SQL Statements in Open PL/I Applications
  • Sample Programs
Parent topic: Open PL/I SQL Options


DB2 SQL Precompiler Options

The following DB2 SQL precompiler options are supported by the Open PL/I driver program, mfplx:

-bind or -nobind
Determines whether or not a bind file is created. The bind file's name is specified by the -bindname option, if that option is used. Otherwise, the name defaults to the name of the input source file with the suffix .bnd.
-bindname b
Specifies the bind file name, b, if one is created.
-block t
Specifies the type of record blocking, t, to be used and how ambiguous cursors are to be treated. The valid types are:
unambig | Blocking occurs for read-only cursors, those that are not specified as FOR UPDATE OF, have no static DELETE WHERE CURRENT OF statements, and have no dynamic statements. Ambiguous cursors can be updated.
all | Blocking occurs for read-only cursors, those that are not specified as FOR UPDATE OF, and for which no static DELETE WHERE CURRENT OF statements are executed. Ambiguous and dynamic cursors are treated as read-only.
no | No blocking is done on any cursors in the package. Ambiguous cursors can be updated.
-datetime d
Determines the date and time format used when date and time fields are assigned to string representations in host variables. The possible formats are:
def | Use the date/time format associated with the country code of the database. This is also the default if -datetime is not specified.
usa IBM standard for United States form:

mm/ddlyyyy hh:mm xM (AM or PM).

eur IBM standard for European form:

dd.mm.yyyy hh.mm.ss.

iso International Standards Organization form:

yyyy–mm–dd hh.mm.ss.

jis Japanese Industrial Standards form:

yyyy–mm–dd hh:mm:ss.

loc | Local form, not necessarily equal to def.
-db2
Specifies that the DB2 version of SQL is to be used.
-dbname d
Specifies the original or alias name of a database. This option directs the precompiler to process SQL statements against the specified database, d. If you omit this option, the precompiler uses the default database. The default database is specified by the environment variable DB2DBDFT.
-E
Allows you to run the DB2 SQL precompiler without running the Open PL/I compiler. The precompiler output is saved using the file specified by the -ppdb2 option, if that option is used. Otherwise, the name defaults to the name of the input source file with the suffix .pp2. This option is useful for a faster syntax and semantic checking of your SQL statements.
-isolation I
Specifies the isolation level at which your program runs. The values of Iare:
cs | Cursor stability
rr | Repeatable read
ur | Uncommitted read
-optimize or -nooptimize
If you specify -optimize, SQLDA initialization is optimized for SQL statements that use host variables. Do not specify this option when using AUTOMATIC host variables or in other situations when the address of a host variable might change during execution of the program. -nooptimize is the default.
-plan or -noplan
Determines whether or not an access plan is created.
-ppdb2 [f]
Specifies the DB2 SQL precompiler output file. This is useful when using the -E option.
-sqltwop
It is good programming practice to declare all SQL host variables before using them in SQL statements. However, if you are not able to do this, -sqltwop provides support for declarations of host variables subsequent to their use. This is done by making a preliminary pass over the source to detect all declarations, followed by a second pass to process the remaining SQL statements. In general, you should not need to use this option and incur the extra overhead it entails.
Parent topic: DB2 SQL Support


Coding DB2 SQL Statements in Open PL/I Applications

Specific requirements for your embedded SQL code are described in the sections that follow.

  • Defining the DB2 SQL Communications Area
  • Defining SQL Descriptor Areas
  • Embedding SQL Statements
  • Using Host Variables
  • Determining Equivalent SQL and PL/I Data Types
  • Determining Compatibility of SQL and PL/I Data Types
  • Using Host Structures
  • Using Indicator Variables
  • CONNECT TO Statement
  • COMPOUND Statement
  • Handling SQL Error Return Codes
Parent topic: DB2 SQL Support


Defining the DB2 SQL Communications Area

An Open PL/I program that contains SQL statements must include an SQL communications area (SQLCA). As shown in the example below, SQLCA includes an SQLCODE variable and an SQLSTATE variable.

The SQLCODE value is set by the Database Manager after each SQL statement is executed. An application can check the SQLCODE value to determine whether the last SQL statement was successful.

The SQLSTATE variable can be used as an alternative to the SQLCODE variable when analyzing the result of an SQL statement. Like the SQLCODE variable, the SQLSTATE variable is set by the Database Manager after each SQL statement is executed.

The SQLCA should be included by using the SQL INCLUDE statement:

exec sql include sqlca;

The SQLCA must not be defined within an SQL declare section. The scope of the SQLCODE and SQLSTATE declarations must include the scope of all SQL statements in the program.

/*--------------------------------------------------------------- */
/* DB2 SQL Communications Area                                    */
/* This should be included by the                                 */
/* 'EXEC SQL INCLUDE SQLCA;' statement.                           */
/* Do not place this within a SQL declare statement.              */
/*--------------------------------------------------------------- */
declare 1 sqlca,
  2 sqlcaid char(8),                 /* Eyecatcher = 'SQLA '      */
  2 sqlcabc fixed bin(31),           /* SQLCA size in bytes = 136 */
       2 sqlcode fixed bin(31),      /* SQL return code           */
       2 sqlerrm char(70) varying,   /* Error message tokens      */
       2 sqlerrp char (8),           /* Diagnostic information    */
       2 sqlerrd(1:6) fixed bin(31), /* Diagnostic information    */
       2 sqlwarn,                    /* Warning flags             */
         3 sqlwarn0 char(1),
         3 sqlwarnl char(1),
         3 sqlwarn2 char(1),
         3 sqlwarn3 char(1),
         3 sqlwarn5 char(1),
         3 sqlwarn6 char(1),
         3 sqlwarn7 char(1),
       2 sqltext,
         3 sqlwarn8 char(1),
         3 sqlwarn9 char(1),
         3 sqlwarna char(1),
         3 sqlstate char(5); /* State corresponding to SQLCODE */

/*    End of SQL Communications Area declaration */
Parent topic: Coding DB2 SQL Statements in Open PL/I Applications


Defining SQL Descriptor Areas

The following statements require an SQLDA:

  • PREPARE statement-name INTO descriptor-name FROM host-variable
  • EXECUTE ... USING DESCRIPTOR descriptor-name
  • FETCH ... USING DESCRIPTOR descnptor-name
  • OPEN ... USING DESCRIPTOR descriptor-name
  • DESCRIBE statement-name INTO descriptor-name

Unlike the SQLCA, there can be more than one SQLDA in a program, and an SQLDA can have any valid name. An SQLDA should be included by using the SQL INCLUDE statement:

exec sql include sqlda;

The SQLDA must not be defined within an SQL declare section.

The Open PL/I SQLDA template includes %REPLACE statements for the SQL data types.

/*-------------------------------------------------------------------------------- */
/* DB2 SQL Descriptor Template                                                         */
/* This should be included by the 'EXEC SQL INCLUDE SQLDA;' statement.                 */
/* Do not place this within an SQL declare statement.                                  */
/*------------------------------------------------------------------------------------ */
declare 1 sqlda based(sqldaptr),                                                       */
   2 sqldaid        char(8),                     /* Eye catcher 'SQLDA   '             */
   2 sqldabc fixed bin(31),                      /* SQLDA size in bytes 16 + 44 * SQLN */
   2 sqln           fixed bin(15),               /* Number of SQLVAR elements          */
   2 sqld           fixed bin(15),               /* Number of used SQLVAR elements     */
   2 sqlvar(1:sqlsize refer(sqln)),              /* Variable descriptor                */
     3 sqltype      fixed bin(15),               /* Variable data type                 */
     3 sqllen       fixed bin(15),               /* Variable length                    */
     3 sqldata      pointer,                     /* Pointer to variable data value     */
     3 sqlind       pointer,                     /* Pointer to null indicator          */
     3 sqlname      char(30) var;                /* Variable name                      */
declare sqlsize fixed bin(15);                   /* Number of sqlvars (sqln)           */
declare sqldaptr pointer;
/* End of SQL Descriptor Template declaration */

/* replaces for SQL type codes                                                         */
/* replaces of the SQL_TYP_Nxxnnn means with Null indicator                            */
%replace SQL_TYP_DATE      by 384; /* DATE */
%replace SQL_TYP_NDATE     by 385;
%replace SQL_TYP_TIME      by 388; /* TIME */
%replace SQL_TYP_NTIME     by 389;
%replace SQL_TYP_STAMP     by 392; /* TIMESTAMP */
%replace SQL_TYP_NSTAMP    by 393;
%replace SQL_TYP_VARCHAR   by 448; /* VARCHAR(I) varying length string I<=4000*/41)
%replace SQL_TYP_NVARCHAR  by 449;
%replace SQL_TYP_CHAR      by 452; /* CHAR(I) - fixed length string */
%replace SQL_TYP_NCHAR     by 453;
%replace SQL_TYP_LONG      by 456; /* LONG VARCHAR - varying length I > 4000 */
%replace SQL_TYP_NLONG     by 457;
%replace SQL_TYP_CSTR      by 460; /* varying length string for C */
%replace SQL_TYPNCSTR      by 461;
%replace SQL_TYP_VARGRAPH  by 464; /* VARGRAPHIC(I) - varying length */
%replace SQL_TYP_NVARGRAPH by 465;
%replace SQL_TYP_GRAPHIC   by 468; /* GRAPHIC(I) - fixed length graphic */
%replace SQL_TYP_NGRAPHIC  by 469;
%replace SQL_TYP_LONGRAPH  by 472; /* LONG VARGRAPHIC(I) - varying length */

%replace SQL_TYP_NLONGRAPH by 473;
%replace SQL_TYP_LSTR      by 476; /* varying length string for Pascal */
%replace SQL_TYP_NLSTR     by 477;
%replace SQL_TYP_FLOAT     by 480; /* FLOAT - 8-byte floating point */
%replace SQL_TYP_NFLOAT    by 481;
%replace SQL_TYP_DECIMAL   by 484; /* DECIMAL (p,q), sqllen q + (256 * p) */
%replace SQL_TYP NDECIMAL  by 485;
%replace SQL_TYP_ZONED     by 488; /* Zoned Decimal -> DECIMAL (m,n) */
%replace SQL_TYP_NZONED    by 489;
%replace SQL_TYP_INTEGER   by 496; /* INTEGER - 4-byte signed integer */
%replace SQL_TYP_NINTEGER  by 497;
%replace SQL_TYP_SMALL     by 500; /* SMALLINT - 2-byte signed integer*/
%replace SQL_TYP NSMALL    by 501;
%replace SQL_TYP_NUMERIC   by 504; /* NUMERIC -> DECIMAL (m,n) */
%replace SQL_TYP_NNUMERIC  by 505;

/* End of EXEC SQL INCLUDE SQLDA  -------------------------------------------------*/
Parent topic: Coding DB2 SQL Statements in Open PL/I Applications


Embedding SQL Statements

You can add SQL statements to your program wherever executable statements can appear. Each SQL statement must begin with EXEC (or EXECUTE) SQL and end with a semicolon (;).

For example, an UPDATE statement might be coded as follows:

exec sql update Department
   set Mgrno    = :Mgr_Num
   where Deptno = :Int_Dept;

Comments

PL/I comments can be included in embedded SQL statements wherever a blank is allowed.

Continuation

The line continuation rules for embedded SQL statements are the same as for other PL/I statements.

Including Code

SQL statements or PL/I host variable declaration statements can be included by placing the following SQL statement at the point in the source code where the statements are to be embedded:

exec sql include {filename | 'filename'};

filename can be enclosed in single quote characters ('). Quotes are required if filename contains any non-alphanumeric characters, as for example,

'inventory.db001'.

Names

Any valid PL/I variable name can be used for a host variable, subject to the following restriction: Do not use host variable names or external entry names that begin with "SQL". These names are reserved for the database manager or Open PL/I. The length of a host variable name must not exceed 30 characters.

Statement Labels

With the exception of the END DECLARE SECTION statement and the INCLUDE text-filename statement, executable SQL statements, like PL/I statements, can have a label prefix.

WHENEVER Statement

The target for a GOTO clause in an SQL WHENEVER statement must be a label in the PL/I source code and must be within the scope of any SQL statements affected by the WHENEVER statement.

Parent topic: Coding DB2 SQL Statements in Open PL/I Applications


Using Host Variables

All host variables used in SQL statements must be explicitly declared. A host variable used in an SQL statement must be declared prior to the first use of the host variable in an SQL statement, except when the -sqltwop precompiler option is used. In addition:

  • All host variables within an SQL statement must be preceded by a colon (:).
  • The names of host variables must be unique within a program, even if the host variables are in different blocks or procedures.
  • An SQL statement that uses a host variable must be within the scope of the statement in which the variable is declared.
  • A host variable cannot be declared as an array.
  • Declaring Host Variables
  • Numeric Host Variables
  • Character Host Variables
Parent topic: Coding DB2 SQL Statements in Open PL/I Applications


Declaring Host Variables

Host variable declarations can be made at the same places as ordinary PL/I variable declarations.

Not all PL/I data types are acceptable for host variables. The precompiler does not use the data attribute defaults specified in the PL/I DEFAULT statement. If the declaration for a variable is not recognized, any statement that references the variable may result in the message "The host variable token ID is not valid".

The SQL precompiler uses only the names and data attributes of host variable declarations; the alignment, scope, and storage class attributes are ignored.

Parent topic: Using Host Variables


Numeric Host Variables

The syntax for numeric host variable declarations is as follows:

DECLARE var-name-spec {BINARY | DECIMAL} scale-spec align-scope-storage ;

where:

var-name-spec | is {variable-name | (variable-name, ...) }
scale-spec | is {FIXED [(precision [,scale])] | FLOAT [(precision)]}
align-scope-storage | is any set of PL/I alignment, scope, or storage class attributes
Note:
  • BINARY | DECIMAL and FIXED | FLOAT can be specified in either order.
  • The precision and scale attributes can follow BINARY | DECIMAL instead of FIXED | FLOAT.
  • A value for scale can be specified only for DECIMAL FIXED.
  • DCL, BIN, and DEC are accepted as abbreviations for DECLARE, BINARY, and DECIMAL, respectively.

Parent topic: Using Host Variables


Character Host Variables

The syntax for character host variable declarations is as follows:

DECLARE var-name-spec CHARACTER [(length)] [VARYING] align-scope-storage ;

where:

var-name-spec | is {variable-name | (variable-name, ...) }
align-scope-storage | is any set of PL/I alignment, scope, or storage class attributes

Note:
  • For non-varying character host variables, length must be a constant no greater than the maximum length for SQL CHAR data.
  • For varying-length character host variables, length must be a constant greater than the maximum length for SQL LONG VARCHAR data.
  • DCL, CHAR, and VAR are accepted as abbreviations for DECLARE, CHARACTER, and VARYING, respectively.
Parent topic: Using Host Variables


Determining Equivalent SQL and PL/I Data Types

The base SQLTYPE and SQLLEN of host variables are determined according to the following table. If a host variable appears with an indicator variable, the SQLTYPE is the base SQLTYPE plus one.

PL/1 Data Type | SQLTYPE of Host Variable | SQLLEN of Host Variable | SQL Data Type
BIN FIXED(n), n < 16 | 500 | 2 | SMALLINT
BIN FIXED(n), 16 ? n ? 31 | 496 | 4 | INTEGER
DEC FIXED(p,s) | 484 | p (byte 1) s (byte 2) | DECIMAL(p,s)
BIN FLOAT(p), 24 ? n ? 52 | 480 | 8 | FLOAT
CHAR(n), 1 ? n ? 254 | 452 | n | CHAR(n)
CHAR(n) VARYING, 1 ? n ? 4000 | 448 | n | VARCHAR(n)
CHAR(n) VARYING, n > 4000 | 456 | n | LONG VARCHAR
  • For FLOAT data, only double-word BIN FLOAT is supported.
  • Precisions, where appropriate, must be specified with integer constants. Default values are not provided.
  • The SQLDA include file has %REPLACE statements for the SQL data types.

The following table can be used to determine the PL/I data type that is equivalent to a given SQL data type.

SQL Data Type | PL/I Equivalent | Notes
SMALLINT | BIN FIXED(15) |
INTEGER | BIN FIXED(31) |
DECIMAL(p,s) | DEC FIXED(p) or DEC FIXED(p,s) | 1 ? p ? 31 and 0 ? s ? p
FLOAT | BIN FLOAT(p) | 24 ? p ? 52
CHAR(n) | CHAR(n) | 1 ? n ? 254
VARCHAR(n) | CHAR(n) VAR | 1 ? n ? 4000
LONG VARCHAR | CHAR(n) VAR | 4000 < n
DATE | CHAR(n) | 10 ? n
TIME | CHAR(n) | 8 ? n
TIMESTAMP | CHAR(n) | 26 ? n
Parent topic: Coding DB2 SQL Statements in Open PL/I Applications


Determining Compatibility of SQL and PL/I Data Types

PL/I host variables in SQL statements must be type compatible with the columns that use them:

  • Numeric data types are compatible with each other. A SMALLINT, INTEGER, DECIMAL, or FLOAT column is compatible with a PL/I host variable of BIN FIXED(15), BIN FIXED(31), DECIMAL(p,s), or BIN FLOAT(n), where 24 ? n ? 53.
  • Character data types are compatible with each other. A CHAR or VARCHAR column is compatible with a fixed-length or varying-length PL/I character host variable. When necessary, the Database Manager automatically converts a fixed-length character string to a varying-length string or a varying-length string to a fixed-length string.
  • Datetime data types are compatible with character host variables. A DATE, TIME, or TIMESTAMP column is compatible with a fixed-length or varying-length PL/I character host variable.
Parent topic: Coding DB2 SQL Statements in Open PL/I Applications


Using Host Structures

A PL/I host structure name can be a structure name. For example:

dcl 1 A,
      2  B,
        3  C1 char(...),
        3  C2 char(...);

In this example, B is the name of a host structure consisting of the scalar members C1 and C2.

However, structures (whether level 1 structures or substructures) may not be referenced in SQL statements. Only scalar members may be so referenced.

A fully qualified member name must be no more than 30 characters in length.

Parent topic: Coding DB2 SQL Statements in Open PL/I Applications


Using Indicator Variables

An indicator variable is a two-byte integer (BIN FIXED(15)). On retrieval, an indicator variable is used to show whether its associated host variable has been assigned a null value. On assignment to a column, a negative indicator value is used to indicate that a null value should be assigned.

Indicator variables are declared in the same way as host variables and the declarations of the two can be mixed in any way that seems appropriate.

Given the statement:

exec sql fetch Cls_Cursor into  :Cls_Cd,
                                :Day  :Day_Ind,
                                :Bgn  :Bgn_Ind,
                                :End  :End_Ind;

the variables could be declared as follows:

exec sql begin declare section;
dcl Cls_Cd     char(7);
dcl Day        bin fixed(15);
dcl Bgn        char(8);
dcl End        char(8);
dcl (Day_Ind, Bgn_Ind, End_Ind) bin fixed(15);
Parent topic: Coding DB2 SQL Statements in Open PL/I Applications


CONNECT TO Statement

You can use a host variable to represent the database name you want your application to connect to. For example:

exec sql connect to :dbase;

If a host variable is specified:

  • It must be a character or character varying variable.
  • It must be preceded by a colon and must not be followed by an indicator variable.
  • The server-name that is contained within the host variable must be left-justified.
  • If the length of the server-name is less than the length of the fixed-length character host variable, it must be padded on the right with blanks.
    dcl dbase char(10);
dbase = 'SAMPLE';    /*four blanks are */
                     /* automatically appended */
exec sql connect to :dbase;
Parent topic: Coding DB2 SQL Statements in Open PL/I Applications


COMPOUND Statement

Open PL/I requires a trailing semicolon after the start of an SQL compound statement. For example:

exec sql begin compound atomic static;
      select count(*) into :tmp3 from department;
      select count(*) into :tmp4 from project;
end compound;
Parent topic: Coding DB2 SQL Statements in Open PL/I Applications


Handling SQL Error Return Codes

Your DB2 product includes a routine that translates SQLCODE error values into readable text messages. When you process your program source with Open PL/I's DB2 SQL precompiler, an %INCLUDE statement is inserted into your program, and the include file this incorporates into your program contains a declaration of this SQLCODE translator routine as an entry, as follows:

declare sqldb2err entry(fixed bin(15) value,
                                    /* Buffer Size   */
               fixed bin(15) value, /* Line Width    */
               any,                 /* SQLCA         */
               any)                 /* Buffer        */
      returns(fixed bin(15))
      external('sqlgintp');

The return code values are:

  • >0 Length of message
  • -1 Internal DB2 error
  • -2 No error, SQLCODE = 0
  • -3 Invalid SQLCODE, no such error
  • -4 Line width is 0
  • -5 Invalid SQLCA, bad buffer address or bad buffer size

Example:

declare errmsg character(200);

exec sql connect to MYDB;
if sqlca.sqlcode < 0 then do;
   put skip list('Connect failed');
   /* Now print out reason for failure for most */
   /* recent SQL statement (i.e., the connect) */
   msg_len = sqldb2err(size(errmsg),0,sqlca,errmsg);
   put skip list(substr(errmsg,1,msg_len));
   return;
   end;

You do not need to declare sqldb2err. This is done for you automatically, as described above.

For more information about this routine, see SQLGINTP (Get Error Message) in your IBM platform-specific DATABASE 2 Programming Reference manual.

Parent topic: Coding DB2 SQL Statements in Open PL/I Applications


Sample Programs

  • Open PL/I DB2 SQL Sample 1 Program
  • Compilation, Linking, and Execution
  • Open PL/I DB2 SQL Sample 2 Program
Parent topic: DB2 SQL Support


Open PL/I DB2 SQL Sample 1 Program

filename: sample1.sqp

sample1: proc options(main);

/*                                                  */
/* This program shows the usage of host-variables,  */
/* indicators, and some common SQL statements       */

/* The database this program uses is the IBMSAMPL   */
/* database that your DB2 product uses. You must be */
/* able to run the IBM DB2 demo sample program in   */
/* order to be able to run this program.            */
/*                                                  */

dcl idx fixed bin(15);
dcl errmsg character(200);
dcl msg_len fixed bin(15);

exec sql include sqlca;

exec sql begin declare section;
   dcl cnt fixed bin(15);
   dcl projno char(6);
   dcl projname char(24) varying;
   dcl deptno char(6);
   dcl respemp char(6);

   dcl prstaff float bin(24);
   dcl prstaff_ind fixed bin(15);

   dcl prstdate char(10);
   dcl prstdate_ind fixed bin(15);

   dcl prendate char(10);
   dcl prendate_ind fixed bin(15);

   dcl majproj char(6);
   dcl majproj_ind fixed bin(15);
exec sql end declare section;

/* Set up error label for all SQL statements. */
exec sql whenever sqlerror goto err_label;

/* Connect to the IBM DB2 sample demo data base */
exec sql connect to IBMSAMPL;

/* Determine how many rows are in table project. */
exec SQL SELECT COUNT(*) INTO :cnt from project;

put skip edit('Number of rows in table project:', cnt) (a(40),x,f(3,0));
put skip list('All the rows for project are:');
put skip;

/* Declare and use a cursor to fetch each row. */
exec sql declare cl cursor for
  select projno, projname, deptno, respemp, prstaff,
         prstdate, prendate, majproj
  from project;

exec sql open cl;
do idx = 1 to cnt;
   prstaff = 0;       /* re-init */
   prstdate = ' ';    /* re-init */
   prendate = ' ';    /* re-init */
   majproj = ' ';     /* re-init */
   exec sql fetch cl into :projno,
                          :projname,
                          :deptno,
                          :respemp,
                          :prstaff  :prstaff_ind,
                          :prstdate :prstdate_ind,
                          :prendate :prendate_ind,
                          :majproj  :majproj_ind;
   put edit (projno, projname, deptno, respemp, prstaff, prstdate,
             prendate, majproj)
            (a(6),x,a(24),x,a(3),x,a(6),x,f(5,2),x,a(10),x,a(10),x,a(6));
   put skip;
   end;

 return;

err_label:
   msg_len = sqldb2err(200,0,sqlca,errmsg);
   put skip list(substr(errmsg,1,msg_len));

end sample1;
Parent topic: Sample Programs


Compilation, Linking, and Execution

mfplx -db2 sample1.sqp -dbname sample db2api.lib

db2api.lib
Number of rows in table project:         20
All the rows for project are:
AD3100 ADMIN SERVICES        DO1 000010  6.50 01/01/1982 02/01/1983
AD3110 GENERAL ADMIN SYSTEMS D21 000070  6.00 01/01/1982 02/01/1983 AD3100
AD3111 PAYROLL PROGRAMMING   D21 000230  2.00 01/01/1982 02/01/1983 AD3110
AD3112 PERSONNEL PROGRAMMING D21 000250  1.00 01/01/1982 02/01/1983 AD3110
AD3113 ACCOUNT PROGRAMMING   D21 000270  2.00 01/01/1982 02/01/1983 AD3110
IF1000 QUERY SERVICES        CO1 000030  2.00 01/01/1982 02/01/1983
IF2000 USER EDUCATION        CO1 000030  1.00 01/01/1982 02/01/1983
MA2100 WELD LINE AUTOMATION  DO1 000010 12.00 01/01/1982 02/01/1983
MA2110 W L PROGRAMMING       Dl1 000060  9.00 01/01/1982 02/01/1983 MA2100
MA2111 W L PROGRAM DESIGN    Dl1 000220  2.00 01/01/1982 12/01/1982 MA2110
MA2112 W L ROBOT DESIGN      Dl1 000150  3.00 01/01/1982 12/01/1982 MA2110
MA2113 W L PROD CONT PROGS   D11 000160  3.00 02/15/1982 12/01/1982 MA2110
OP1000 OPERATION SUPPORT     E01 000050  6.00 01/01/1982 02/01/1983
0P1010 OPERATION             E11 000090  5.00 01/01/1982 02/01/1983 OP1000
0P2000 GEN SYSTEMS SERVICES  E01 000050  5.00 01/01/1982 02/01/1983
OP2010 SYSTEMS SUPPORT       E21 000100  4.00 01/01/1982 02/01/1983 OP2000
OP2011 SCP SYSTEMS SUPPORT   E21 000320  1.00 01/01/1982 02/01/1983 0P2010
OP2012 APPLICATIONS SUPPORT  E21 000330  1.00 01/01/1982 02/01/1983 0P2010
092013 DB/DC SUPPORT         E21 000340  1.00 01/01/1982 02/01/1983 0P2010
PL2100 WELD LINE PLANNING    B01 000020  1.00 01/01/1982 09/15/1982 MA2100
Parent topic: Sample Programs


Open PL/I DB2 SQL Sample 2 Program

filename: sample2.sqp

sample2: proc options(main);

   /* Sample program 2                                              */
   /* Example of using a user defined SQLDA                         */

   /* The database this program uses is the IBMSAMPL database that  */
   /* your DB2 product uses. You must be able to run the IBM DB2    */
   /* demo sample program in order to be able to run this program   */

   /* Uses a table of the form:                                     */
   /*    create table project                                       */
   /*       (projno char(6) not null,                               */
   /*       projname varchar(24) not null,                          */
   /*       deptno char(3) not null,                                */
   /*       respemp char(6) not null,                               */
   /*       prstaff dec(5,2),                                       */
   /*       prstdate date)                                          */

dcl k fixed bin(15);

exec sql include sqlca;
exec sql include sqlda;

exec sql begin declare section;
   dcl cnt fixed bin(15);
exec sql end declare section;

sqlsize 6;                     /* Lets only look at the 1st 6 columns */
allocate sqlda set(sqldapntr); /* sets sqln */
sqldaptr->sqld = 6;

dcl projno char(6) based;
sqldaptr->sqlda.sqlvar(1).sqltype = SQL_TYP_CHAR;
allocate projno set(sqldaptr->sqlda.sqlvar(1).sqldata);
sqldaptr->sqlda.sqlvar(1).sqllen = 6;

dcl projname char(24) var based;
saldaptr->sqlda.sqlvar(2).sqltype = SQL_TYP VARCHAR;
allocate projname set(sqldaptr->sqlda.sqlvar(2).sqldata);
sqldaptr->sqlda.sqlvar(2).sqllen = 24;

dcl deptno char(3) based;
sqldaptr->sqlda.sqlvar(3).sqltype = SQL_TYP_CHAR;
allocate deptno set(sqldaptr->sqlda.sqlvar(3).sqldata);
sqldaptr->sqlda.sqlvar(3).sqllen = 3;

dcl respemp char(6) based;
sqldaptr->sqlda.sqlvar(4).sqltype = SQL_TYP_CHAR;
allocate respemp set(sqldaptr->sqlda.sqlvar(4).sqldata);
sqldaptr->sqlda.sqlvar(4).sqllen = 6;

dcl prstaff float(24) binary based;
sqldaptr->sqlda.sqlvar(5).sqltype = SQL_TYP_FLOAT;
allocate prstaff set(sqldaptr->sqlda.salvar(5).sqldata);
sqldaptr->sqlda.sqlvar(5).sqllen = 8;

dcl prstdate char(10) based;
sqldaptr->sqlda.sqlvar(6).sqltype = SQL_TYP_CHAR;
allocate prstdate set(sqldaptr->sqlda.sqlvar(6).sqldata);
sqldaptr->sqlda.sqlvar(6).sqllen = 10;

exec sql connect to IBMSAMPL;
if SQLCA.SQLCODE < 0 THEN do;
   put skip list('Connect failed');
   return;
   end;
  else put skip list('Connect OK');
  put skip;
  exec sql whenever sqlerror goto err_label;
  put skip list('Projno Projname                 Dpt Respemp Prst Prstdate');
  put skip;

  exec sql declare cl cursor for select * from project;
  exec sql open cl;
  exec sql whenever not found go to done;
  do while ('1'b1);  /* do till fetch raises not found error */
     exec sql fetch c1 using descriptor :sqldaptr;
     put edit (sqldaptr->sqlda.sqlvar(1).sqldata->projno,
               sqldaptr->sqlda.sqlvar(2).sqldata->projname,
               sqldaptr->sqlda.sqlvar(3).sqldata->deptno,
               sqldaptr->sqlda.sqlvar(4).sqldata->respemp,
               sqldaptr->sqlda.sqlvar(5).sqldata->prstaff,
               sqldaptr->sqlda.sqlvar(6).sqldata->prstdate)
              (a(6),x,a(24),x,a(3),x,a(6),x,f(5,2),x,a(10));
     put skip;
     end;
done:
   exec sql whenever not found continue;   /* turn off */

   put skip;
   return;
err_label:
   put skip list('Branched to err_label');
   put skip list('sqlcode =', sqlcode);
   put skip list('sqlerrm =' , sqlerrm);
   put skip list('sqlstate =', sqlstate);
   return;

end sample2;

Output

Connect OK

Projno Projname              Opt Respemp  Prst Prstdate
AD3100 ADMIN SERVICES        D01 000010   6.50 01/01/1982
AD3110 GENERAL ADMIN SYSTEMS D21 000070   6.00 01/01/1982
AD3111 PAYROLL PROGRAMMING   D21 000230   2.00 01/01/1982
AD3112 PERSONNEL PROGRAMMING D21 000250   1.00 01/01/1982
AD3113 ACCOUNT PROGRAMMING   D21 000270   2.00 01/01/1982
1F1000 QUERY SERVICES        CO1 000030   2.00 01/01/1982
1F2000 USER EDUCATION        CO1 000030   1.00 01/01/1982
MA2100 WELD LINE AUTOMATION  DO1 000010  12.00 01/01/1982
MA2110 W L PROGRAMMING       D11 000060   9.00 01/01/1982
MA2111 W L PROGRAM DESIGN    D11 000220   2.00 01/01/1982
MA2112 W L ROBOT DESIGN      D11 000150   3.00 01/01/1982
MA2113 W L PROD CONT PROGS   D11 000160   3.00 02/15/1982
OP1000 OPERATION SUPPORT     E01 000050   6.00 01/01/1982
OP1010 OPERATION             E11 000090   5.00 01/01/1982
OP2000 GEN SYSTEMS SERVICES  E01 000050   5.00 01/01/1982
OP2010 SYSTEMS SUPPORT       E21 000100   4.00 01/01/1982
OP2011 SCP SYSTEMS SUPPORT   E21 000320   1.00 01/01/1982
0P2012 APPLICATIONS SUPPORT  E21 000330   1.00 01/01/1982
0P2013 DB/DC SUPPORT         E21 000340   1.00 01/01/1982
PL2100 WELD LINE PLANNING    B01 000020   1.00 01/01/1982
Parent topic: Sample Programs


HCO for SQL Server Compiler Directive Options for PL/I

Syntax

To set an HCO for SQL Server compiler directive option for the PL/I compiler, use the following syntax:
mfplx pliProgName –sql odbc –optsql "SQLPrecompilerOption [...]"

Recommended Options

We recommend that you set the following HCO for SQL Server compiler directive options for PL/I when emulating mainframe settings using SQL:

  • BEHAVIOR=MAINFRAME
  • CHECKDUPCURSOR
  • CHECKSINGLETON
  • DATE=USA
  • DBMAN=ODBC
  • DETECTDATE
  • DIALECT=MAINFRAME
  • MARS
  • NOCHECK
  • TARGETDB=MSSQLSERVER
  • TIME=USA
Note: Some of these options are specific to HCO for SQL Server, and some are available to both HCO for SQL Server and standard SQL.

Examples

Compiling
Compile a batch program to qualify tables using QUALIFIER directive:
mfplx TESTPGM.PLI –sql odbc –optsql "QUALIFIER=HCOSQL" -isuffix cblrtssi –nologo
Compiling, Linking, and Binding
Compile 3 subroutines with a main program that calls routines to object files so it can be linked and then bound:
mfplx defplan0.pli -sql odbc -optsql "DBRMLIB" -isuffix -f w –c
mfplx defplan1.pli -sql odbc -optsql "DBRMLIB" -isuffix -f w –c
mfplx defplan2.pli -sql odbc -optsql "DBRMLIB" -isuffix -f w –c
mfplx defplan3.pli -sql odbc -optsql "DBRMLIB" -isuffix -f w -c
Link object files:
ldpli defplan0.obj defplan1.obj defplan2.obj defplan3.obj cblrtssi -out:defplan0.exe
Bind:
dsn system(hcodemo) @defplan0.hcodsn
Parent topic: Open PL/I SQL Options
Related information
SQL Compiler Directive Options - HCOSS


Open PL/I Compiler Diagnostic Messages

  • Interpreting Diagnostic Messages
Parent topic: Open PL/I User's Guide


Interpreting Diagnostic Messages

The format for Open PL/I compilation diagnostic messages is as follows:

filename (line, col)  :  diagnostic level  MFPLI + diagnostic number + first letter of the diagnostic level :  diagnostic message
filename
The name of the file that caused the diagnostic message.
(line, col)
Line number and column number. If the column number is 0, the column is not available.
diagnostic level
There are five diagnostic levels: Info, Warning, Error, Severe and Abort.
MFPLI + diagnostic number + first letter of the diagnostic level
This consists of "MFPLI", the diagnostic number and the first letter of the diagnostic level (Info - "I", Warning - "W", Error - "E", Severe - "S" and Abort - "A").
diagnostic message
A brief statement of the diagnostic.

Example

hex2.pl1 (10,0) : Severe MFPLI01253S : The first argument of the HEX built-in function must be a variable reference.
Note: An object file is not generated if an error at the Severe or Abort level is encountered.
Parent topic: Open PL/I Compiler Diagnostic Messages
Related information
Compiler Options


Open PL/I Run-time Error Messages

  • Run-time Errors
  • LPI Run-time Error Codes
Parent topic: Open PL/I User's Guide


Run-time Errors

A run-time error is a program exception that occurs during execution. Some examples of program exceptions are:

  • Overflow on a floating-point computation
  • An invalid I/O operation on a file
  • A UNIX signal
  • An address violation trap
  • An invalid operand to a math routine.

When such errors occur, the LPI run-time system responds by raising an appropriate condition. If the program has established a handler for the particular condition, the handler is invoked; otherwise, the LPI run-time system performs a default action. A program establishes handlers for various conditions by means that differ from language to language: PL/I procedures can establish handlers by using ON-units, FORTRAN procedures can establish handlers for certain kinds of exceptions by using the ERR= and END= specifiers on I/O statements, and other languages provide no means of handling exceptions.

In the absence of a handler, the default action performed by the LPI run-time system for most conditions except the ENDPAGE (f), FINISH, UNDERFLOW, and ERROR conditions is simply to raise the ERROR condition.

  • As the default action for the UNDERFLOW condition, the Open PL/I run-time system substitutes a true zero for the result and continues the computation.
  • As the default action for the ENDPAGE condition, the Open PL/I run-time system does a PUT(f)PAGE.
  • As the default action for the ERROR condition, the LPI run-time system writes a message line to the standard output file (usually the terminal), closes all opened files, and terminates execution of the program.
  • As the default action for the FINISH condition, the Open PL/I run-time system continues execution.

The message line has the following form:

*** Condition ERROR raised

If the ERROR condition was raised as the default action for another condition, the above line is followed by another line:

*** Unhandled condition cccccc[for 000000 on file ffffff] at PC=xxxxxxxx

where

cccccc | Is the name of a condition and indicates the nature of the program exception as described in the remainder of this section.
000000 | Describes the I/O operation.
ffffff | Is the name of the file.
xxxxxxxx | Is the hexadecimal value of the PC at the time the error was detected (usually the address of an instruction in a routine from an LPI run-time library).

If the error is related to an I/O operation on a file, the optional part of the message appears.

I/O errors are program exceptions related to operations on files. End-of-file on sequential input may raise the ENDFILE condition, and errors opening a file usually raise the UNDEFINEDFILE condition. The condition name used by the LPI run-time system for other I/O errors has the form

I0_ERROR_nnn

where nnn is the error code for the particular error: either an LPI run-time system error code or a UNIX system error code.

The AREA condition is raised in two situations: (1) if an attempt is made to allocate a based variable within an area that has insufficient free storage for the allocation, or (2) if an attempt is made to assign one area to another where the maximum size of the source area exceeds that of the target area.

Floating point exceptions raise conditions OVERFLOW, UNDERFLOW, ZERODIVIDE, CONVERSION, INVALID_OPERAND, or INVALID_mmmm, where mmmm is the name of a floating-point function or operation.

OVERFLOW | Indicates that the magnitude of a computational result is too large to represent.
UNDERFLOW | Indicates that the magnitude of a computational result is too close to zero to represent.
ZERODIVIDE | Indicates an attempt to divide by zero (note that the special case of zero divided by zero raises SIGFPE, however). Note: This condition is not recognized in cases where integer division is performed. In this case, the ONCODE for a general computational error (99200) is returned.
CONVERSION | Is raised when a floating-point value cannot be correctly converted to an integer, to or from another floating-point value of a different size, or to or from a character string representation.
INVALID_OPERAND | Results when an operand to a floating-point function (such as SIN, COS, TAN, EXP, and LOG) is out of the range capable of being handled accurately by the system.
INVALID_mmmm | Usually denotes an invalid operand to the indicated floating-point function or operation: the operand is Not-a-Number, +/- infinity, or is outside the mathematical domain of the function or operation.

RTS errors are program exceptions detected by the LPI run-time system not related to I/O. The condition name raised for these errors has the form

 RTS_ERROR_nnn

where nnn is one of the error codes listed in Table B-1. An RTS error related to the conversion of a value from one data type to another is sometimes reported as the CONVERSION condition.

Finally, UNIX signals are errors detected by the system and reported to the program by the system's signaling mechanism. Signaled condition names have the form

SIGxxxx

where xxxx depends on the signal value. The various UNIX signal values are described in your UNIX documentation. On some UNIX systems, floating-point exceptions appear as SIGFPE.

Parent topic: Open PL/I Run-time Error Messages


LPI Run-time Error Codes

The table below lists the LPI run-time system error codes (100 –170). The UNIX system error codes (001 – 099) correspond exactly to the UNIX system error codes and are listed in your UNIX documentation.

Code | Meaning
100 | Duplicate record
101 | File not open
102 | Illegal argument
103 | Illegal key descriptor
104 | Too many files open
105 | Bad isam file format
106 | Non-exclusive access
107 | Record locked
108 | Key already exists
109 | Is primary key
110 | End of file reached
111 | No record found
112 | No current record
113 | File locked
114 | File name too long
115 | Can't create lock file
116 | Duplicate record (warning)
117 | Current record pointer undefined
118 | Can't allocate memory
119 | Bad custom collating
120 | Invalid operation
121 | Boundary violation on write
122 | Boundary violation on sequential file
123 | Not available, file locking or closed w/ lock
124 | Inconsistent attributes
125 | Open -APPEND on KEYED file
126 | Open -DAM on non-IDIRECT file
127 | Open -SAM on KEYED file
128 | File not open or is open for output only
129 | File not open or is open for input only
130 | Open on file not yet closed
131 | KEY specified on sequential file
132 | KEY specified on stream file
133 | No KEY specified on KEYED file
134 | Not a PRINT file
135 | Not a STREAM file
136 | CALL dataname name not found
137 | B-format error (35)
138 | BI format error (36)
139 | C format error (32)
140 | E format error (34)
141 | I/O stack overflow
142 | Conversion error
143 | LIST input item too long
144 | Implicit open failed
145 | EOF found while parsing edited input
146 | End of string on GET/PUT string
147 | Invalid format item for GET/PUT string
148 | Invalid format for GET
149 | Cannot initialize RPG screens
150 | File not open for input
151 | REWRITE on input file
152 | File not open on non-optional "sequential"
153 | File open on optional
154 | Sequential error on REW or DELE COBOL85
155 | Sequential error no next record COBOL85
156 | Bad record size on current record
157 | Cannot read log record
158 | Bad log record
159 | Cannot open log file
160 | Cannot write log file
161 | No transaction
162 | No shared memory
163 | No begin work yet
164 | Can't use nfs
165 | Audit trail exists
166 | F format error
167 | Record number too big for data item
168 | Open of wrong file type within transaction
169 | CLOSE REEL on non reel file
170 | No READ or WRITE before DELETE of record
171 | Return from subroutine specified a value
172 | Return from function did not specify a value
173 | Bad definition for creating a VSAM file
174 | No -defext used
175 | SET requires INDEXED or VSAM files
176 | Missing FROM on REWRITE and not VSAM
Parent topic: Open PL/I Run-time Error Messages


Value Table for ONCODE Built-in Function

  • Introduction
  • Table of Values Returned by ONCODE
Parent topic: Open PL/I User's Guide


Introduction

For more information on ON conditions, see the section ON in the chapter Statements and the section ONCODE Function in the chapter Open PL/I Built-Ins, both in your Open PL/I Language Reference Manual.

Note that the value returned by ONCODE for some conditions is implementation-dependent; in fact, some conditions that occur on one implementation may not be raised at all on another implementation, even by an identical source program run on both implementations. Further, subsequent releases of Open PL/I may change these ONCODE values. Therefore, to make programs more portable, avoid writing Open PL/I programs that depend on specific ONCODE return values to function properly; failing that, use replace constants to represent needed values so that implementation-specific values can be changed easily.

Parent topic: Value Table for ONCODE Built-in Function


Table of Values Returned by ONCODE

The table below lists the values (codes) in ascending order, in sections marked by error category.

Code | Meaning
0 | ONCODE has been used outside of an active ON-unit
System-Defined Condition Codes
001 – 099 | A UNIX system error has occurred; the value returned corresponds exactly to the UNIX system error codes as listed in your system documentation.
100 – 89999 | An LPI run-time error has occurred; the value returned corresponds exactly to the Open PL/I run-time error codes, as documented in Appendix C. (Note that 89999 is the highest possible error number and that not all error numbers are currently being used.)
9250 | A fetchable procedure was not found.
UNIX Signal Condition Codes
90000 | Shell exit for any reason other than UNIX signals, including EOF.
90nnn | UNIX signal number nnn has been caught by the LPI run-time system. The value nnn corresponds exactly with the signal number as defined in your system documentation, except for the following signals: SIGINT – Treated as PL/I ATTENTION condition. SIGFPE – Treated as computational error condition.
99001 | ERROR condition raised by SIGNAL ERROR statement.
99011 | FINISH condition
99020 | ATTENTION condition
99110 | ENDFILE condition
99120 | ENDPAGE condition
99130 | KEY condition
99140 | UNDEFINEDFILE condition
99150 | RECORD condition
99200 | Computational error; some operating systems indicate the precise cause of the error, in which case ONCODE will return the number corresponding to the more specific error description.
99201 | OVERFLOW condition
99202 | UNDERFLOW condition
99203 | ZERODIVIDE condition
99204 | SUBSCRIPTRANGE condition
99205 | CONVERSION condition
99206 | CONDITION condition
99207 | AREA condition
99210 | INVALID OPERAND condition
99211 | INVALID_ADD_SUBTRACT condition
99212 | INVALID_MULTIPLY condition
99213 | INVALID_DIVIDE condition
99214 | INVALID_MOD condition
99215 | INVALID_COMPARISON condition
99251 | INVALID_SQRT condition
99252 | INVALID_ASIN_ACOS condition
99253 | INVALID_ATAN2 condition
99254 | INVALID_LOG condition
99255 | INVALID_POWER condition
99256 | INVALID_ATANH condition
99257 | INVALID_COMPLEX_OPERAND condition
99301 | Stack unwind condition raised during non-local GOTO. This corresponds to the SS$_UNWIND value.
Parent topic: Value Table for ONCODE Built-in Function


Character Sets

  • EBCDIC/ASCII Equivalents
Parent topic: Open PL/I User's Guide


EBCDIC/ASCII Equivalents

Index | EBCDIC (Hex) | Character | ASCII (Hex) | Notes
000 | 00 | NUL | 00 | null
001 | 01 | SOH | 01 |
002 | 02 | STX | 02 |
003 | 03 | ETX | 03 |
004 | 04 | PF | EC |
005 | 05 | HT | 09 | horizontal tab
006 | 06 | LC | CA |
007 | 07 | DEL | 7F | delete
008 | 08 |  | E2 |
009 | 09 |  | D2 |
010 | OA | SMM | D3 |
011 | OB | VT | OB | vertical tab
012 | OC | FF | OC | form feed
013 | OD | CR | OD | carriage return
014 | OE | SO | OE |
015 | OF | SI | A9 |
016 | 10 | DLE | 10 |
017 | 11 | DC1 | 11 |
018 | 12 | DC2 | 12 |
019 | 13 | TM | 13 |
020 | 14 | RES | EF |
021 | 15 | NL | C5 |
022 | 16 | BS | 08 |
023 | 17 | IL | CB |
024 | 18 | CAN | 18 |
025 | 19 | EM | 19 |
026 | 1A | CC | DC |
027 | 1B | CU1 | D8 |
028 | 1C | IFS | 1C |
029 | 1D | IGS | 1D |
030 | 1E | IRS | 1E |
031 | 1F | IUS | 1F |
032 | 20 | DS | B7 |
033 | 21 | SOS | B8 |
034 | 22 | FS | B9 |
035 | 23 |  | BB |
036 | 24 | BYP | C4 |
037 | 25 | LF | OA | line feed (new line)
038 | 26 | ETB | 17 |
039 | 27 | ESC | 1B |
040 | 28 |  | CC |
041 | 29 |  | CD |
042 | 2A | SM | CF |
043 | 2B | CU2 | DO |
044 | 2C |  | D1 |
045 | 2D | ENQ | 05 |
046 | 2E | ACK | 06 |
047 | 2F | BEL | 07 | bell
048 | 30 |  | D9 |
049 | 31 |  | DA |
050 | 32 | SYN | 16 |
051 | 33 |  | DD |
052 | 34 | PN | DE |
053 | 35 | RS | DF |
054 | 36 | UC | E0 |
055 | 37 | EOT | 04 | end transmission
056 | 38 |  | E3 |
057 | 39 |  | E5 |
058 | 3A |  | E9 |
059 | 3B | CU3 | EB |
060 | 3C | DC4 | B0 |
061 | 3D | NAK | B1 |
062 | 3E |  | 9E |
063 | 3F | SUB | 1A |
064 | 40 | SP | 20 | space
065 | 41 |  | C9 |
066 | 42 |  | 83 |
067 | 43 |  | 84 |
068 | 44 |  | 85 |
069 | 45 |  | A0 |
070 | 46 |  | F2 |
071 | 47 |  | 86 |
072 | 48 |  | 87 |
073 | 49 |  | A4 |
074 | 4A | ¢ | D5 |
075 | 4B | . | 2E | period
076 | 4C | < | 3C |
077 | 4D | ( | 28 |
078 | 4E | + | 2B |
079 | 4F | I | 7C |
080 | 50 | & | 26 |
081 | 51 |  | 82
082 | 52 |  | 88 |
083 | 53 |  | 89 |
084 | 54 |  | 8A |
085 | 55 |  | A1 |
086 | 56 |  | 8C |
087 | 57 |  | 8B |
088 | 58 |  | 8D |
089 | 59 |  | E1
090 | 5A | ! | 21 |
091 | 5B | $ | 24 |
092 | 5C | * | 2A |
093 | 5D | ) | 29 |
094 | 5E | ; | 3B | semicolon
095 | 5F | ¬ | 7E | ASCII tilde (~)
096 | 60 | - | 2D | hyphen
097 | 61 | / | 2F |
098 | 62 |  | B2 |
099 | 63 |  | 8E |
100 | 64 |  | B4 |
101 | 65 |  | B5 |
102 | 66 |  | B6 |
103 | 67 |  | 8F |
104 | 68 |  | 80 |
105 | 69 |  | A5 |
106 | 6A |  | B3 |
107 | 6B | , | 2C | comma
108 | 6C | % | 25 |
109 | 6D | _ | 5F | underscore
110 | 6E | > | 3E |
111 | 6F | ? | 3F |
112 | 70 |  | BA
113 | 71 |  | 90 |
114 | 72 |  | BC |
115 | 73 |  | BD |
116 | 74 |  | BE |
117 | 75 |  | F3 |
118 | 76 |  | C0 |
119 | 77 |  | C1 |
120 | 78 |  | C2 |
121 | 79 | ´ | 60 | accent grave
122 | 7A | : | 3A | colon
123 | 7B | # | 23 |
124 | 7C | @ | 40 |
125 | 7D | ' | 27 | apostrophe (accent acute)
126 | 7E | = | 3D |
127 | 7F | " | 22 | quotation mark
128 | 80 |  | C3 |
129 | 81 | a | 61 |
130 | 82 | b | 62 |
131 | 83 | c | 63 |
132 | 84 | d | 64 |
133 | 85 | e | 65 |
134 | 86 | f | 66 |
135 | 87 | g | 67 |
136 | 88 | h | 68 |
137 | 89 | I | 69 |
138 | 8A |  | AE |
139 | 8B |  | AF |
140 | 8C |  | C6 |
141 | 8D |  | C7 |
142 | 8E |  | C8 |
143 | 8F |  | F1 |
144 | 90 |  | F8 |
145 | 91 | j | 6A |
146 | 92 | k | 6B |
147 | 93 | l | 6C |
148 | 94 | m | 6D |
149 | 95 | n | 6E |
150 | 96 | o | 6F |
151 | 97 | p | 70 |
152 | 98 | q | 71 |
153 | 99 | r | 72 |
154 | 9A |  | 5E | ASCII caret ( ^ )
155 | 9B |  | A7 |
156 | 9C |  | 91 |
157 | 9D |  | CE |
158 | 9E |  | 92 |
159 | 9F |  | 0F |
160 | A0 |  | E6 |
161 | A1 |  | A6 |
162 | A2 | s | 73 |
163 | A3 | t | 74 |
164 | A4 | u | 75 |
165 | A5 | v | 76 |
166 | A6 | w | 77 |
167 | A7 | x | 78 |
168 | A8 | y | 79 |
169 | A9 | z | 7A |
170 | AA |  | AD |
171 | AB |  | A8 |
172 | AC |  | D4 |
173 | AD |  | 5B | ASCII left bracket ( [ )
174 | AE |  | D6 |
175 | AF |  | D7 |
176 | B0 |  | 9B |
177 | B1 |  | 9C |
178 | B2 |  | 9D |
179 | B3 |  | FA |
180 | B4 |  | 9F |
181 | B5 |  | 15 |
182 | B6 |  | 14 |
183 | B7 |  | AC |
184 | B8 |  | AB |
185 | B9 |  | FC |
186 | BA |  | AA |
187 | BB |  | FE |
188 | BC |  | E4 |
189 | BD |  | 5D | ASCII right bracket (])
190 | BE |  | BF |
191 | BF |  | E7 |
192 | C0 |  | 7B | ASCII left brace ( { )
193 | C1 | A | 41 |
194 | C2 | B | 42 |
195 | C3 | C | 43 |
196 | C4 | D | 44 |
197 | C5 | E | 45 |
198 | C6 | F | 46 |
199 | C7 | G | 47 |
200 | C8 | H | 48 |
201 | C9 | I | 49 |
202 | CA |  | E8 |
203 | CB |  | 93 |
204 | CC |  | 94 |
205 | CD |  | 95 |
206 | CE |  | A2 |
207 | CF |  | ED |
208 | D0 |  | 7D | ASCII right brace ( } )
209 | D1 | J | 4A |
210 | D2 | K | 4B |
211 | D3 | L | 4C |
212 | D4 | M | 4D |
213 | D5 | N | 4E |
214 | D6 | O | 4F |
215 | D7 | P | 50 |
216 | D8 | Q | 51 |
217 | D9 | R | 52 |
218 | DA |  | EE |
219 | DB |  | 96 |
220 | DC |  | 81 |
221 | DD |  | 97 |
222 | DE |  | A3 |
223 | DF |  | 98 |
224 | E0 |  | 5C | ASCII backslash ( \ )
225 | E1 |  | F0 |
226 | E2 | S | 53 |
227 | E3 | T | 54 |
228 | E4 | U | 55 |
229 | E5 | V | 56 |
230 | E6 | W | 57 |
231 | E7 | X | 58 |
232 | E8 | Y | 59 |
233 | E9 | Z | 5A |
234 | EA |  | FD |
235 | EB |  | F5 |
236 | EC |  | 99 |
237 | ED |  | F7 |
238 | EE |  | F6 |
239 | EF |  | F9 |
240 | F0 | 0 | 30 |
241 | F1 | 1 | 31 |
242 | F2 | 2 | 32 |
243 | F3 | 3 | 33 |
244 | F4 | 4 | 34 |
245 | F5 | 5 | 35 |
246 | F6 | 6 | 36 |
247 | F7 | 7 | 37 |
248 | F8 | 8 | 38 |
249 | F9 | 9 | 39 |
250 | FA |  | DB |
251 | FB |  | FB |
252 | FC |  | 9A |
253 | FD |  | F4 |
254 | FE |  | EA |
255 | FF |  | FF |
Parent topic: Character Sets


Environment Variables

  • Environment Variables Summary
Parent topic: Open PL/I User's Guide


Environment Variables Summary

This is a list of the most commonly used environment variables.

Variable | Description
CODEWATCH_STBPATH | The location of STB files for the debugger to use if none are found in directories specified when invoking CodeWatch.
CODEWATCH_SRCPATH | The location of source files for the debugger to use if none are found in directories specified when invoking CodeWatch.
ES_PL1_MFFH | Enables Micro Focus File Handler to perform all Open PL/I I/O operations. The default value is "Y". If it is set to "N", then all I/O will be routed to old Liant file handlers.
ES_PL1_MFFH_JCL | Enables you to run Open PL/I programs that access JCL data definitions. The default value is "N".
ES_PLI_SUPPORT | Tells the CICS Emulation that it needs to load its subsystem support for PL/I user programs. The default value is "N".
MFPLI_PRODUCT_DIR | The location of the Open PL/I installation. It is used to find files needed for compiling and linking.
MF_USE_JAVA_CW | Enables you to use Java CodeWatch for debugging Open PL/I programs.
Parent topic: Environment Variables


Migration to Micro Focus File Formats

  • Overview
  • Reasons for Migrating to Micro Focus File Formats
  • Determine What File Formats You Are Using
  • Liant Indexed (aka) IBM/Informix CISAM
  • Liant Indexed (aka) IBM/Informix CISAM Conversion Process
  • Liant Variable Length Sequential Conversion Process
  • Liant Relative Record Conversion Process
  • Appendix - Unload Program
  • Appendix - Load Program
  • Appendix - Sample Shell Script to Build/Run
  • Appendix - Sample extfh.cfg
Parent topic: Open PL/I User's Guide


Overview

This guide shows you how to migrate your data to Micro Focus file formats so that it can be processed and manipulated using standard processes.

Parent topic: Migration to Micro Focus File Formats


Reasons for Migrating to Micro Focus File Formats

Micro Focus has its own file handler called Micro Focus ISAM that it has developed and enhanced for over two decades to provide file processing support for all Micro Focus COBOL based applications. Within version 8.1 of Open PL/I we have therefore switched to using this core technology from Micro Focus rather than relying on the 3 rd party file handler for Indexed files that was utilised originally within Open PL/I.

This will enable all Micro Focus to provide ongoing support for all file processing requirements of our Open PL/I customers from a single technology shared with all Micro Focus COBOL customers but it does require data to be unloaded from original files formats and loaded into new Micro Focus file formats. The following document gives guidance about how to go about this transition process.

Parent topic: Migration to Micro Focus File Formats


Determine What File Formats You Are Using

These are the available file formats:

  • Line Sequential - no conversion necessary
  • Liant Sequential Fixed Length - no conversion necessary
  • Liant Indexed (aka) - IBM/Informix CISAM - conversion necessary *
  • Liant Relative Record - conversion optional **
  • Liant Sequential (Variable Length) - conversion optional **
Parent topic: Migration to Micro Focus File Formats
* Conversion is necessary if utilizing PLI IO Verbs.
** Conversion is only necessary if you intend to utilize the data within Micro Focus Enterprise Server and/or share the files with Micro Focus COBOL Programs.


Liant Indexed (aka) IBM/Informix CISAM

If you are using native PL/I I/O Verbs, you must convert data to Micro Focus Indexed Format.

If you are using IBM/Informix "IsXXXXX" APIs, you have two options:
  • Convert API calls to native PL/I I/O Verbs (and convert data)
  • Purchase a copy of CISAM from IBM and continue to use your existing datasets and "IsXXXXX" APIs.
    ( isaddindex () isbuild () isclose () isdelcurr () isdelete () iserase () isindexinfo () isopen () isread () isrelease () isrewcurr () isrewrite () ISRELOCK () isstart () isdef () iswrite () )
Parent topic: Migration to Micro Focus File Formats


Liant Indexed (aka) IBM/Informix CISAM Conversion Process

Unload is a very simple generic program needing only maximum record length and file names.

Load is a very simple generic program needing only maximum record length, file names, and key offset and length. Sample code is provided in Appendix A.

Load requires use of extfh.cfg to prevent null bytes from being stripped from output.

Note: SCALARV in the diagram above stands for SCALARVARYING.

The source programs in Appendix A are small and very simple. If you find that you have a large number of files that need to be converted, then one approach would be to use a shell script to generate the unload and load programs.

The easiest way to automate the process and generate the conversion programs via scripts would be to place all of the %REPLACE statements and the VSAM File Declarations in a PLI %INCLUDE. You should then be able to compile up the programs and be off and running.

In our testing of this process we had both the Open PL/I 7.4 Compiler and Open PL/I 8.1 Compiler and RTS Environments running side by side with no problems.

Parent topic: Migration to Micro Focus File Formats


Liant Variable Length Sequential Conversion Process

Load and Unload programs are very simple generic programs needing only maximum record length and file names to be provided. Sample code provided in Appendix A can be easily modified.

Load requires use of extfh.cfg to prevent null bytes from being stripped from output.

Note: SCALARV in the diagram above stands for SCALARVARYING.
Parent topic: Migration to Micro Focus File Formats


Liant Relative Record Conversion Process

Load and Unload programs are very simple generic programs needing only maximum record length and file names to be provided. Sample code provided in Appendix A can be easily modified.

Load requires use of extfh.cfg to prevent null bytes from being stripped from output.

Note: SCALARV in the diagram above stands for SCALARVARYING.
Parent topic: Migration to Micro Focus File Formats


Appendix - Unload Program

unload_liant_files: proc() options(main);
%replace MAX_REC_LEN               by 100;
%replace MAX_REC_LEN_SV            by 102;
%replace INPUT_TITLE               by 'liantCISAM';
%replace OUTPUT_TITLE              by 'fixed_cisam.dat';
 dcl inputfile    file record         env(vsam  recsize( MAX_REC_LEN ) );
 dcl outputfile    file record output env(f recsize( MAX_REC_LEN_SV ));

 dcl record_buff char(MAX_REC_LEN ) varying;
 dcl fixed_buf   char( MAX_REC_LEN_SV ) based(addr(record_buff));
 dcl vsam_buff   char( MAX_REC_LEN );

 on endfile(inputfile) goto doneinputfile;

 open file(inputfile) title(INPUT_TITLE) keyed sequential input;
 open file(outputfile) title(OUTPUT_TITLE);

 substr(fixed_buf, 2, length(fixed_buf) - 2) = '';
 read file(inputfile) into(record_buff);
 do while(1);
    write file(outputfile) from (fixed_buf);
    substr(fixed_buf, 2, length(fixed_buf) - 2) = '';
    read file(inputfile) into(record_buff);
 end;

doneinputfile:
 close file(inputfile);
 close file(outputfile);
end;
Parent topic: Migration to Micro Focus File Formats


Appendix - Load Program

load_microfocus_files: proc() options(main);

%replace MAX_REC_LEN               by 100;
%replace MAX_REC_LEN_SV            by 102;
%replace INPUT_TITLE               by 'fixed_cisam.dat';
%replace OUTPUT_TITLE              by 'microfocusIndexed.dat';
%include ‘vsamrec.in’;

 dcl inputfile    file record input env(f recsize( MAX_REC_LEN_SV ));
 dcl outputfile    file record
     env(vsam  recsize( MAX_REC_LEN ) keyloc(11) keylength(10));
 dcl 1 fixed_buf based(addr(in_rec)),
       5 fixed_buf_len  fixed bin(15),
       5 fixed_buf_data char( MAX_REC_LEN );
 dcl in_rec    char( MAX_REC_LEN ) varying;
 on endfile(inputfile) goto done;
 open file(inputfile) title(INPUT_TITLE);
 open file(outputfile) title(OUTPUT_TITLE) keyed sequential output;
 read file(inputfile) into(fixed_buf);
 do while(1);
    string(vsam_rec) = in_rec;
    write file(outputfile) from (vsam_rec) keyfrom(last_name);
    read file(inputfile) into(fixed_buf);
 end;
done:
 close file(inputfile);
 close file(outputfile);
end;
Parent topic: Migration to Micro Focus File Formats


Appendix - Sample Shell Script to Build/Run

echo ‘Solaris Sparc Shell Script’
rm liant*
rm microfocus*
rm fixed_*

lpiplx -deb -defext -cisam create_liant_files.pli -o create_liant_files
lpiplx -deb -defext -cisam test_liant_files.pli   -o test_liant_files
lpiplx -deb -defext -cisam unload_liant_files.pli -o unload_liant_files

mfplx  -deb -defext load_microfocus_files.pli -o load_microfocus_files
mfplx  -deb -defext test_microfocus_files.pli -o test_microfocus_files

echo 'Running create_liant_files'
./create_liant_files
echo 'Running test_liant_files'
./test_liant_files
echo 'Running unload_liant_files'
./unload_liant_files
echo 'Running load_microfocus_files'
./load_microfocus_files
echo 'Running test_microfocus_files'
./test_microfocus_files
Parent topic: Migration to Micro Focus File Formats


Appendix - Sample extfh.cfg

[XFH-DEFAULT]
IDXFORMAT=8
INSERTNULL=OFF
Parent topic: Migration to Micro Focus File Formats
Related information
Configuration File


Service Interfaces Using the IMTK

Building service interfaces using the Interface Mapping Toolkit.

  • Service Interfaces with the IMTK
    Describes the Service Interfaces feature and provides information about creating, defining and deploying service interfaces, and generating clients to access the deployed services running on an enterprise server.
  • How to...
    Topics that provide step-by-step instructions on using the Service Interfaces feature.
  • Reference
    Reference information for the Service Interfaces feature.
Parent topic: Mainframe Programming


Service Interfaces with the IMTK

Describes the Service Interfaces feature and provides information about creating, defining and deploying service interfaces, and generating clients to access the deployed services running on an enterprise server.

A service interface is a mechanism for accessing a COBOL application running under Enterprise Server. It is a collection of input and output fields of a particular format used to communicate with the application via a particular protocol.

A service interface uses the fields available via:
  • A COBOL program's entry points
  • BMS screens
  • MFS screens
  • CICS commarea

You can provide access to all of the functionality of an application, or you can create one or more interfaces for specific pieces of an application. For example, if by design your application includes large amounts of information irrelevant to the common user, you can create a service interface that includes only the relevant information. For CICS and IMS applications, you can also consolidate screen fields from multiple maps into an interface that precisely targets your users.

You can create the following types of service interfaces:

  • Web Service
  • Java
  • .NET

The applications for which you create services interfaces run under Server Enterprise Edition. COBOL program applications can run with or without the Server Enterprise Edition Mainframe Subsystem Support (MSS). CICS and IMS applications must be deployed to an enterprise server configured for MSS.

The process of creating a working service interface includes the following:

  • Configuring an enterprise server to run the service
  • Creating a service interface in a Visual Studio project
  • Defining the details of the service interface
  • Deploying the service interface
  • Generating one or more clients to access the service running on the enterprise server

You can also optionally capture a workflow to use as a starting point for a service interface. This process from start to finish is documented in the remaining chapters of this book.

  • Preparing Applications for Enterprise Server
  • Configuring an Enterprise Server
  • Managing Service Interface Projects
  • Annotating Maps
  • Defining Service Interfaces
  • Capturing Workflows
  • Deploying Service Interfaces
  • Clients
Parent topic: Service Interfaces Using the IMTK


Configuring an Enterprise Server

Explains the process of configuring an enterprise server to run COBOL program, CICS, and IMS services created using the service interface feature.

Note: After creating and configuring an enterprise server, you must associate it with the project containing the service interface or interfaces you intend to run on the enterprise server.
  • Configuring an Enterprise Server for a COBOL Program service
  • Configuring an Enterprise Server for a CICS service
  • Configuring an Enterprise Server for an IMS service
Parent topic: Service Interfaces with the IMTK
Related information
To associate an enterprise server with a project


Configuring an Enterprise Server for a COBOL Program service

Enterprise Server provides a default enterprise server instance, ESDEMO, that is configured to run COBOL program-based services. However, if you want to create and configure an enterprise server to use specifically for your service, the process of adding and configuring an enterprise server is the same as for any COBOL program application.

Parent topic: Configuring an Enterprise Server
Related concepts
Managing Enterprise Server Instances
Related information
To Add an Enterprise Server Instance


Configuring an Enterprise Server for a CICS service

When you add an enterprise server instance using Enterprise Server Administration, configure it as follows:

  • Set the Working Mode to 32-bit or 64-bit, depending on your platform.
  • Set the Server Type to Micro Focus Enterprise Server with Mainframe Subsystem Support.
  • For screen-based CICS applications, set the number of Server Execution Processes to be twice as many as the peak number of concurrent service requests you anticipate receiving.
  • For commarea-based CICS applications, set the number of Server Execution Processes to be the same as the peak number of concurrent service requests you anticipate receiving.
  • Set the port for the TN3270 listener.

Further configure the enterprise server as follows:

  • If you want to debug your application when it is invoked from a service interface request, check Allow Dynamic Debugging. Optional.
  • Check Mainframe Subsystem Support enabled.
  • Set the System Initialization Table to IMTKCICS.
  • Set the port for the Endpoint Address for the Web Services and J2EE Listener to match the Service endpoint URL set in your service interface properties. The default Service endpoint URL is http://localhost:9003.
    Note: For a Web Service, if you do not specify an endpoint URL, the underlying communications calls resolve the service automatically regardless of the port setting of the Web Service and J2EE listener.
  • Point the Transaction Path to your program executables.
  • Point the File Path to your data files.
  • Point the Map Path to your BMS modules (.mod files).
  • Point the Resource Definition File Path to your resource definition (.rdf) file.
  • Update your application's existing resource definition files to include resource definitions that are required for CICS services. To do this, use the caspcupg utility, located in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Base\Bin directory. Execute the utility from aNet Express command prompt as follows:
    • Windows-based systems

      caspcupg /dp=resourcedefinitionpath /o

      Where resourcedefinitionpath is the path to your resource definition (.rdf) file.

    • UNIX-based systems

      caspcupg /r regionname /dp=resourcedefinitionpath /o

      Where regionname is the name of your CICS region, and resourcedefinitionpath is the path to your resource definition (.rdf) file.

    Caspcupg writes a list of updated or added resources to the screen and to a log file.

  • After updating the resource definition files, add the DFHBRDG group to your startup list. This is contained in the IMTKCICS system initialization table that we supply.
Parent topic: Configuring an Enterprise Server
Related concepts
Managing Enterprise Server Instances
Related information
To Add an Enterprise Server Instance
To debug a service interface
To deploy a service interface
Properties - Service Interface
Configuring CICS-enabled Enterprise Servers


Configuring an Enterprise Server for an IMS service

The process of configuring an enterprise server for an IMS COBOL Program service is the same as that of creating an enterprise server for any IMS COBOL Program application.

Parent topic: Configuring an Enterprise Server
Related concepts
Managing Enterprise Server Instances
Related information
To Add an Enterprise Server Instance
Configuring IMS-enabled Enterprise Servers


Managing Service Interface Projects

Before you can use the service interfaces feature, you must first create a Visual Studio project configured to support them. Once this project is in place, you can use Visual Studio functionality to do the following:

  • Add your COBOL application files to the project, such as COBOL programs and copybooks, and CICS and IMS screens
  • Create a new service interface
  • Import an existing service interface, either a service interface created using different software such as Net Express or a service interface from a different project
  • Set service interface properties
  • Create and edit service interfaces
  • Deploy service interfaces to run as services on an enterprise server
  • Generate clients to access deployed services
Parent topic: Service Interfaces with the IMTK
Related information
Manage Service Interface Projects


Annotating Maps

Using the Map Annotations Editor, you can annotate the maps included in your Visual Studio project to provide additional information for your service interfaces. This includes changing logical field names, defining fields as input, output, or input/output, defining groups of fields, and adding or changing field values. Any map annotations you make are valid only in the context of the service interfaces you create using the map. The annotations do not directly affect your application.

  • Changing Logical Field Names
  • Defining Field Direction
  • Grouping Fields
Parent topic: Service Interfaces with the IMTK


Changing Logical Field Names

The names assigned to map fields in the map's source file are the names referenced by the Map Annotations Editor and the Service Interfaces Editor as logical field names, with one exception. For CICS BMS maps, if the field name is a reserved COBOL word, -Reserved is appended to the field name.

You can change a logical field name to something that more clearly identifies the field. When you use the Service Interface Editor to create mappings with screen fields, having an easily recognized logical name for each field can be quite helpful, especially if the screen field names defined in the map's source file are somewhat cryptic.

Parent topic: Annotating Maps
Related information
To edit a logical screen map name


Defining Field Direction

As a default, each map field has a direction of input/output. You can change the direction of any map field to be input, output, or input/output.

Parent topic: Annotating Maps
Related information
To define a map field direction


Grouping Fields

You can group map fields to form an array of items, which can be helpful when you have several rows that contain the same data, each for a different record. The number of fields in the group can vary depending on your needs. The fields in a group must be consecutive.

Parent topic: Annotating Maps
Related information
To group map fields


Defining Service Interfaces

The Service Interfaces Editor is the tool that enables you to define your service interfaces. You can define a service interface for an application from a COBOL program, the screens it uses or, in the case of a CICS application that does not use screens, its commarea(s). The service interfaces you define can cover a broad range -- from those that provide access to a subset of the functions performed by your application, to interfaces that do more than your application in its original form.

For CICS or IMS screen-based service interfaces, you start with the screens of an application and build a new interface based on existing screen fields. You have a great deal of creative license as you build your new interface. The Service Interface Editor enables you to pick and choose the fields you want to use, how users interact with those fields, and how the fields map to your application.

For CICS commarea-based service interfaces, you start with the input and output commareas of a CICS program and build a new interface based on commarea fields.

The following topics describe the Service Interface Editor and the concepts important to using it successfully:

  • Layout of the Service Interfaces Editor
  • Operations
Parent topic: Service Interfaces with the IMTK
Related information
To create a service interface


Layout of the Service Interfaces Editor

The Service Interfaces Editor window is split into two parts, the left side presenting what we refer to as your COBOL fields. These are in the form of COBOL entry point fields, screen renderings, commarea fields and work fields. On the right are your interface fields, reusable fields, mappings, and assignments.

COBOL Program-based operations:
Left Side | Right Side
COBOL Entry Point pane | Operation details area
 | Interface Fields pane
 | Reusable Fields pane
 | COBOL Assignments pane
Screen-based operations:
Left Side | Right Side
Screen pane | Operation details area
Work Fields pane | Interface Fields pane
 | Mappings pane
 | Assignments pane
Commarea-based operations:
Left Side | Right Side
Input Commarea pane | Operation details area
Output Commarea pane | Interface Fields pane
Work Fields pane | Mappings pane
 | Assignments pane
Parent topic: Defining Service Interfaces


Operations

Once you have initially created the service interface, you define its functionality by creating a series of operations. Generally, an operation represents an interaction with a single program entry point. In the Service Interfaces Editor you work with one operation at a time. A single service interface typically contains multiple operations.

For COBOL program-based service interfaces, the operations are packaged together in one service, but each operation is independently executable (i.e., only one operation is invoked per service execution). In contrast, for all CICS/IMS-based service interfaces, a service driver program is generated that typically performs multiple operations within a single service execution. For example, you could define one operation for each screen that might be encountered during the execution of the service, or one for each commarea program invoked.

  • Creating COBOL Program-based Operations
  • Creating CICS or IMS Screen-based Operations
  • Creating CICS Commarea-based Operations
  • Defining Operation Details
  • Initialization or Termination Logic
Parent topic: Defining Service Interfaces


Creating COBOL Program-based Operations

COBOL program-based services require that you specify the program and entry point you want to use in the operation.

A typical scenario you might make is if you know that a single entry point leads to an EVALUATE statement choosing between different functions. You could make each of these functions into a separate operation. Often in such a program, one parameter is a code tested by this EVALUATE to see which function is wanted.

Parent topic: Operations
Related information
To create a COBOL program-based operation


Creating CICS or IMS Screen-based Operations

For CICS or IMS screen service interfaces, operations can specify any of the following:

  • Active Screen

    The screen that the operation is intended to process. It contains the fields you use in the operation. This screen appears in the CICS or IMS screen pane of the Service Interfaces Editor when you are defining the operation. The operation that is intended to be performed first has no active screen. Typically, the operation that is performed first starts an application using a transaction ID.

  • Previous Screen

    The screen that is presented immediately before the active screen is presented during execution of the service. Most of the time, you should set this to ANY SCREEN (see below). Specifying a particular previous screen is only important when you want to interact with a screen differently depending on which screen preceded it. In this case, you would create multiple operations with the same active screen and differentiate them by specifying a particular previous screen for one or more of the operations.

  • Transaction ID

    After any interaction with the active screen, this starts a new transaction using the ID specified. Most operations do not have a transaction ID. When you do not specify a transaction ID, the operation returns to the application with any data for the active screen.

    It is common practice for IMS applications to specify a transaction ID in the MFS MID definition. In this case, to ensure that offsets are calculated properly, select the USE TRANSACTION ID FROM SCREEN DEFINITION option when specifying the transaction ID for your operation.

Active and previous screens can be a screen derived from a map included in your project, or one of the following special screens:

  • EMPTY SCREEN - A screen that is devoid of any fields. For example, you can specify EMPTY SCREEN for the screen that appears after executing an operation that clears the screen.
  • TEXT-SENT SCREEN - A screen that appears as a result of the application executing a SEND TEXT command (CICS only).
  • ANY SCREEN - Indicates that the screen can be any screen and that the specification of a particular screen is either unnecessary or irrelevant to the operation.

You can also opt to automatically create default mappings between interface fields and all of the fields on the active screen.

In general, you want to create an initial operation to start your application. This operation consists of only a name and the transaction ID that starts the application. We recommend you use an operation name that clearly identifies this operation, such as Start.

Note:

Service interfaces written for IMS conversational applications must include an operation that enables the service to gracefully exit the application and ensure that the application’s state is properly maintained and that its SPA is properly cleared. While this type of operation is not required for other types of service interfaces, it is good practice to include one.

Parent topic: Operations
Related information
To create a screen-based operation


Creating CICS Commarea-based Operations

CICS commarea service interfaces require that you specify the input and output commareas you want to use in each operation. You do this by first specifying the COBOL source and then by identifying the commarea or commareas you want to use for input and output.

Parent topic: Operations
Related information
To create a CICS commarea-based operation


Defining Operation Details

The following topics explain the basics of using the Service Interfaces Editor to define the details of an operation:

  • Interface Fields
  • Mappings
  • COBOL Assignments
  • Reusable Fields
  • Assignments
  • Conditional Statements
  • Work Fields
Parent topic: Operations


Interface Fields

In the Interface Fields pane, you define the details of each field you want to include in your service interface. Interface fields are grouped by operation. Each operation shows how COBOL, CICS screen, IMS screen, or commarea fields are mapped between the interface fields. Only the interface fields for the current operation show in this pane. The full service interface is comprised of all of the interface fields for all of the operations combined, in two groups - input and output. They are ordered first by the order of operations and second by the field order in each operation.

Parent topic: Defining Operation Details
Related information
To create an interface field
To edit field properties
To group interface, work, or reusable fields


Mappings

A mapping is a designation of a relationship between a COBOL field and an interface field. You identify a COBOL field (entry point, screen, commarea, or work field) to map to the selected interface field and, in the case of screen- or commarea-based operations, optionally apply a condition to the mapping. If you have created the interface field by dragging and dropping, a mapping is done for you - the interface field maps to the field you dragged and dropped. For fields that are an array (have an OCCURS clause), all occurrences are automatically mapped by default.

An interface field that you define manually requires that you also define its mapping or mappings manually. You can define more than one mapping for each interface field. For an input field, this means that during execution, data received in the field is moved to all the data items the field is mapped to. For an output field it is meaningless (data from several COBOL fields would be sequentially moved to the one interface field, each value replacing the previous), unless the interface field has an Occurs property. In this case you can specify different values of the subscript in different mappings. Only elementary (non-grouped) interface fields and COBOL fields can be mapped.

If a field you are mapping is an array or part of an array, use an asterisk (*) to show that all occurrences of that field are mapped (default), or define it using a subscript to specify a particular occurrence. For example:

fieldname(*)

or

fieldname(4)

For CICS and IMS service interfaces, you can also make a mapping conditional by using a conditional statement.

You cannot normally change the field name from the Mapping dialog box because the purpose of the Mappings function is to specify the mappings for a particular interface field. However, if the interface field has the Occurs property, you can edit the field name so as to specify a subscript. Changing anything other than the subscript results in an error.

Note: When defining an operation for a COBOL program-based service interface, the Mappings pane is not available. You can see the mappings when you invoke the Mapping dialog box.

By default, for an item with the Occurs property, each occurrence is mapped to the corresponding occurrence of the COBOL data item. If the number in the Occurs column does not match the OCCURS clause of the originating data item, a warning message appears before the Mappings dialog box opens. In this case, use the Mappings dialog box to specify mappings for the individual occurrences.

When creating a Web Service service interface, take care not to map an output interface field defined as a string to a COBOL alphanumeric field that can contain a character value that is invalid for a SOAP string. Invalid character values are values less than x"20" except for x"09", x"10" and x"13". If you do create such a mapping, the client program might receive the message: "458 Illegal character in SOAP string".

  • USER ID and PASSWORD Fields
  • ABEND CODE, STATUS, and MESSAGE Fields
Parent topic: Defining Operation Details
Related information
To map an interface field
Conditional Statements


USER ID and PASSWORD Fields

For CICS screen-based service interfaces, you can use two special COBOL fields, USER ID and PASSWORD, to map to input interface fields. The purpose of these two fields is to control access to your application by collecting the user ID and password when you want to verify users before granting authorization to access the application.

You enable the run-time functionality for USER ID and PASSWORD by editing the merncntl.igc file, found in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\cntlfiles folder, as follows:

  1. Find these lines:
    % if not &defined(&cntl-security-on)
  % * &cntl-security-on = "yes"
  % &cntl-security-on = "no"
% end
  2. Remove the asterisk and its preceding space from the following line:
    % * &cntl-security-on = "yes"

    So that it reads:

    % &cntl-security-on = "yes"
  3. Add an asterisk and a space to the following line:
    % &cntl-security-on = "no"

    So that it reads:

    % * &cntl-security-on = "no"
  4. Save and close the file.

This changes the security setting from the default of no to yes, so that user IDs are validated against those defined in the Enterprise Server System Name Table (SNT).

Parent topic: Mappings


ABEND CODE, STATUS, and MESSAGE Fields

For CICS and IMS screen-based service interfaces, you can use three special COBOL fields -- ABEND CODE, STATUS, and MESSAGE -- to map to your output interface fields as follows:

  • ABEND CODE - contains return code information if the application were to end abnormally during the execution of the service
  • STATUS - contains a status code resulting from an abnormal application termination
  • MESSAGE - contains any message returned as a result of an abnormal termination
Parent topic: Mappings


COBOL Assignments

For COBOL program-based service interfaces, create a COBOL assignment when several operations go to the same entry point and the program takes different paths depending on the value of a parameter. Instead of defining an interface field to map to that parameter, place the value here that makes the program take the required path.

Parent topic: Defining Operation Details
Related information
To assign a value to a COBOL field


Reusable Fields

The Reusable Fields pane, available for COBOL program-based service interfaces, is primarily for convenience. In it, create fields you want to use across operations; then copy them from there to the Interface Fields pane for each operation. The Reusable Fields pane does not change when you display a different operation.

A reusable field, whether a group item or an elementary item, defines a complex data type. For a Web Service service interface, it defines a complex data type in the WSDL file. For a Java service interface, it creates a custom record according to the CustomRecord interface defined in the Common Client Interface (CCI) from Sun.

For a Web Service, use reusable fields to define groups of interface fields used in more than one operation rather than creating the same group in each operation. If you create the same group in several different operations, its complex type is declared several times in the WSDL; however, this is illegal in WSDL where each complex type must have a unique name. A single group of reusable fields does not cause this problem.

Interface fields created from reusable fields have as their type the name of the reusable field. If you double-click the Type column in the Interface Fields pane, you see listed there all the types you have defined, as well as the native types.

Reusable fields, being type declarations and not actual fields, have no direction.

Parent topic: Defining Operation Details
Related information
To create a reusable field


Assignments

In the Assignments pane (CICS and IMS service interfaces only) you can assign a value to any COBOL field. The value you specify can be a numeric or non-numeric literal or COBOL field value, or the result of a function using one or more such values. By assigning values to certain fields, you can streamline the service by reducing the amount of information that must be supplied by the user.

For example, let's say that your application adds, modifies, and deletes records in a database. In its original form, the application requires users to enter A for add, M for modify, or D for delete into a certain screen field. Let's also say that you want this service interface to add records but not modify or delete them. By assigning the literal A to the appropriate screen field, you eliminate the need for the user to enter a value.

As with mappings, you can only create assignments using elementary COBOL fields. If the assignment includes an array field, you can make the assignment using an asterisk (*) to show that all occurrences of that field are included, or you can use a subscript to specify a particular occurrence.

You can also make an assignment conditional.

  • Functions/Operators
  • ATTENTION ID
  • CURSOR POSITION
Parent topic: Defining Operation Details
Related information
To assign a value to a screen, commarea, or work field
To assign the result of an arithmetic function
To assign the summation of array elements
To assign the result of a concatenation
To assign an extracted string value
Conditional Statements


Functions/Operators

For CICS and IMS service interfaces, you can specify a function or an operator to generate a value for assignment. You can add, subtract, multiply, or divide two literal values or field values. You can also concatenate two string values or extract part of a string value.

Parent topic: Assignments
Related information
To assign the result of a concatenation
To assign an extracted string value
To assign the result of an arithmetic function


ATTENTION ID

For CICS and IMS screen-based service interfaces, the Service Interfaces Editor provides a special assignment field named ATTENTION ID. Assign this field to the name of a keyboard key to represent the user pressing that key when this screen is displayed. The Service Interfaces Editor provides a list of valid keys from which to choose. The most common value of ATTENTION ID is ENTER to represent transitioning from one screen to another.

Parent topic: Assignments
Related information
To assign a value to a screen, commarea, or work field


CURSOR POSITION

For CICS screen-based service interfaces, the Service Interfaces Editor provides a special assignment field named CURSOR POSITION that enables you to represent the placement of the cursor at a specific screen field.

Parent topic: Assignments
Related information
To assign a value to a screen, commarea, or work field


Conditional Statements

For CICS or IMS service interfaces, you can construct conditional statements to be evaluated to determine whether or not to perform a mapping or an assignment. You can build a collection of conditional statements for an operation. Using the collection, you can apply the same condition to multiple mappings or assignments without having to reconstruct the conditional statement for each.

Parent topic: Defining Operation Details
Related information
To create and apply a conditional statement
To edit conditions
To apply an existing condition
Mappings
Assignments


Work Fields

For CICS and IMS service interfaces, the Work Fields pane enables you to create additional non-interface fields for use by the service. You can think of work fields as an extension of the screen or commarea. Work fields persist across operations, so the contents of the Work Fields pane is the same for all operations of your service interface.

For example, to use data from one screen on another screen, in one operation you can assign the field containing that data to a work field. In another operation, you can assign that work field to a field on another screen.

Work fields can be alphanumeric or numeric. For all fields, you must specify a length and optionally the number of times the field occurs. For numeric fields, you can also specify the number of decimal places and whether or not the field is signed.

Parent topic: Defining Operation Details
Related information
To create a work field
To create an interface field
To group interface, work, or reusable fields


Initialization or Termination Logic

You can customize your service interfaces by coding initialization or termination logic. This can be helpful for handling application-level security, for housekeeping tasks, or for executing standard code. Initialization code executes before the first operation of a service, and termination code executes just after completion of the last operation.

Parent topic: Operations
Related information
To add initialization or termination code


Capturing Workflows

As an alternative to building your entire service interface from scratch, you can streamline some of the work for CICS and IMS screen service interfaces by capturing one or more workflows. For service interfaces that traverse a large number of screens, a workflow is the best starting point. A workflow stores details of an interactive session with your application via the Workflow Capture emulator, and contains a record of the session showing screens used, values entered, CICS or IMS transactions invoked, keys pressed, etc.

The Workflow Capture emulator is similar to a TN3270 emulator you would use to connect to an application running on an mainframe or on an enterprise server. Similarly, to use access your application via the Workflow Capture emulator, it must be accessible via a connection to a mainframe or an enterprise server.

  • Prerequisites
  • Workflow Capture Process
  • Creating a Service Interface from Workflows
Parent topic: Service Interfaces with the IMTK


Prerequisites

To capture a workflow, you must have the following in place:

  • Your CICS or IMS application accessible via a mainframe connection or an enterprise server
  • Java JRE 32-bit, version 5 or later installed and accessible on your PC
  • Workflow Capture Server installed on your local machine or one accessible through a local area network

Add the following to your system PATH environment variable:

JREInstallDir\bin;JREInstallDir\bin\client

Where JREInstallDir is your JRE installation directory.

Parent topic: Capturing Workflows
Related information
To specify a workflow capture server


Workflow Capture Process

The following outlines the process of capturing a workflow:
  1. In Visual Studio, specify a Workflow Capture server in your Service Interfaces Options. The default is localhost.
  2. Create a Visual Studio project using the Mainframe Subsystem Application template.
  3. Add a workflow item to the project.
  4. Set workflow properties.
  5. Start the workflow emulator.
  6. Start your application in the workflow emulator.
  7. Navigate the application to capture screens and transitions.
  8. Optionally edit workflow transitions.
  9. Optionally validate the workflow.

While capturing a workflow, you might want to run through the procedure several times, both successfully and deliberately unsuccessfully, to cover the different paths through the application. This ensures that all possible scenarios are addressed in the workflow and ultimately the service interface generated from it.

As you perform a workflow capture, screens that are accessed but not already listed on the project are brought into the project using the following naming convention:

HostScreennnnn

Where nnnn is a sequential number representing the order in which the screen was accessed during the workflow capture procedure. You cannot rename screens.

Parent topic: Capturing Workflows
Related information
To create a Visual Studio project for service interfaces
To specify a workflow capture server
To add a workflow to a project
To capture a workflow
To view or edit workflow transitions
To validate a service interface or workflow


Creating a Service Interface from Workflows

To create a service interface from one or more workflows, specify the workflow(s) when you create the service interface. The resulting service interface is prepopulated with the information collected during the capture process.

Each interaction with a screen is stored in the service interface as an operation bearing the name of that screen. You can rename the operations to better identify them.

A service interface based on one or more workflows cannot be immediately deployed. Before you can deploy it, edit it using the Service Interfaces Editor and make the following adjustments:
  • Remove extraneous information, if it exists.
  • Define output interface fields.
  • Change the direction of interface fields from input to output as necessary.
  • Provide any additional details or your service interface requires, including making improvements as you see fit. You are not limited to the functionality captured initially.

After making all of the appropriate adjustments, you can deploy and run your service interface just as you would a service interface created without workflows.

Parent topic: Capturing Workflows
Related information
To capture a workflow
To create a service interface
To create a screen-based operation
To edit field properties
To create an interface field
To deploy a service interface


Deploying Service Interfaces

This collection of topics explains the process of deploying a service interface such that it can run as a service on an enterprise server.

  • Deploying to an Enterprise Server
  • Deploying to an Enterprise Server under UNIX
  • Deploying to 64-bit Platforms
  • Deploying Java Service Interfaces
Parent topic: Service Interfaces with the IMTK


Deploying to an Enterprise Server

When you deploy a service interface, the appropriate files are copied to the location from which the associated entepriser server runs the service.

Before deploying a service, you must first set the appropriate deployment properties. For most applications, the default deployment settings are acceptable. However, you might want to check the following:

  • Set the appropriate Application character set, ASCII or EBCDIC, for your application.
  • If your CICS application interfaces with a terminal type other than MOD2, set the Facilitylike name as follows:
    Terminal Type | Facilitylike Name
    MOD3 | MER3
    MOD4 | MER4
    MOD5 | MER5
    Note:

    The Facilitylike name for MOD2 terminals can be blank (default) or you can set it to MER2.

  • For CICS and IMS service interfaces, optionally enable the tracing of service execution.

Once your service interface is deployed, you can generate a client for it.

Note: The process of deploying a Java service to an enterprise server and generating a client requires that you do some additional steps.
Parent topic: Deploying Service Interfaces
Related reference
imtkmake command
Related information
To deploy a service interface
Tracing Service Execution
Deploying Java Service Interfaces


Deploying to an Enterprise Server under UNIX

If your enterprise server is running on a UNIX installation of Server Enterprise Edition, you can still deploy a service to that enterprise server; however, after you deploy you must then compile the generated driver program for your service on the platform where Server Enterprise Edition is running. For CICS and IMS service interfaces, this requires that you install the Studio Enterprise Edition COBOL Development System such that it is licensed to compile and run CICS and/or IMS applications.

To compile the service driver program on the target UNIX machine:

  1. Log on to the target machine.
  2. Go to the package path folder. If you are using a telnet session originating from your development machine, you can paste the package path from the clipboard.
  3. Compile the service driver source using the cob command and appropriate directives, depending on the type of service interface as follows:
    Note:

    The service interface filename prefix ( SERVINTNAME ) is always upper case.

    Service Interface Type | Compiled As | Command Line
    CICS screen or EBCDIC commarea | GNT | cob –vu servintname.cbl –C “CICSECM() DIALECT(OS390) DEFAULTBYTE(00) WARNING(1) COPYEXT(cpy)”
    CICS screen or EBCDIC commarea | Shared Object | cob –vUz servintname.cbl –C “CICSECM() DIALECT(OS390) DEFAULTBYTE(00) WARNING(1) COPYEXT(cpy)”
    ASCII commarea | GNT | cob –vu servintname.cbl –C “CICSECM() DIALECT(OS390) CHARSET(ASCII) DEFAULTBYTE(00) WARNING(1) COPYEXT(cpy)”
    ASCII commarea | Shared Object | cob –vUz servintname.cbl –C “CICSECM() DIALECT(OS390) CHARSET(ASCII) DEFAULTBYTE(00) WARNING(1) COPYEXT(cpy)”
    IMS Screen | GNT | cob –vu servintname.cbl
    IMS Screen | Shared Object | cob –vUz servintname.cbl
Parent topic: Deploying Service Interfaces
Related reference
imtkmake command
Related information
To deploy a service interface


Deploying to 64-bit Platforms

A service interface is only compiled and included as part of the deployment package when the target enterprise server is running in the same working mode as the development environment. For example, if you deploy from a Windows 32-bit system to a 64-bit enterprise server, then the service driver program is not compiled and the compiled service driver program is not included in the deployment package. However, the COBOL source for the service driver program is always included in the deployment package, allowing for recompilation on the target server platform.

Parent topic: Deploying Service Interfaces
Related reference
imtkmake command
Related information
To deploy a service interface


Deploying Java Service Interfaces

When you deploy a Java service interface, this produces an EJB or Java Bean and several accompanying files that are copied to the appropriate enterprise server.

Once a Java service is ready for use in a production environment, you should deploy it to an enterprise server using the .car file generated during the last deployment.

Note: If you generate a client for your Java service, the .car file is deleted from the deployment folder. When setting up your service in a production environment, be sure to deploy this file before generating a client.

There are two methods of deploying the .car file:

Related information
Deploying to an Enterprise Server


Deploying Using the mfdepinst Command

The mfdepinst command handles the server-side part of the process of deploying a service to enterprise server. The tool installs the services contained in a .car onto the enterprise server. It is the equivalent of unpacking the .car file manually and adding the files using Enterprise Server Administration.

The mfdepinst command extracts the files (.int .idt and so on) from the .car file, updates the Directory Service directory for the new services and packages, and if the enterprise server is running tells it about the new services so they are available for use.

Parent topic: Deploying Java Service Interfaces
Related reference
mfdepinst command


Deploying the .car File Manually

You can also deploy manually by unpacking the files in the COBOL archive file .car for your service and adding these to enterprise server using Enterprise Server Administration. The .car file is created when you deploy your service interface.

The .car file is in your deployment folder \myservice\myservice.deploy. The significant files in the COBOL archive are:

  • The interface definition table (IDT). For example myservice.idt.
  • The implementation package. For example myprogram.int and myprogram.idy
  • The data required. For example mydata.idx and mydata.dat
  • The manifest file manifest.mf, which controls the deployment process.

To deploy the service interface manually, you use Enterprise Server Administration to:

  1. Add the implementation package. Among other things, you specify the path and name of the IDT, the executable file and the data files.
  2. Add the service. Among other things, you specify the listener to use on this service, and the implementation package that is to provide the service functionality.
  • To manually deploy a service interface
Parent topic: Deploying Java Service Interfaces
Parent topic: About IMTK Deployment
Related information
To manually deploy a service interface


Clients

This collection of topics explains the processes of generating, editing, and running clients for your deployed service.

  • Generating Clients
  • Editing Clients
  • Running Clients
  • Hosting ASP.NET Web Sites on 64-bit Operating Systems
  • Tracing Service Execution
Parent topic: Service Interfaces with the IMTK


Generating Clients

You can use a generated client to test a service, or as a sample of accessing a service. As part of the COBOL, WPF, Windows Forms and ASP.NET Web Site client generation, a proxy program is also generated. The proxy provides a standard mechanism for invoking the service, and is intended to be used by production clients.

All service types generate a console application client, and JSP clients are generated automatically for Java interfaces. However, you choose which clients to generate for Web Services and .NET interfaces by specifying them in your Service Interfaces Options. The following three clients can be generated for both:
  • WPF
  • Windows Forms
  • ASP.NET Web site

All clients are generated in the same Visual Studio project that contains the service interface they are generated from.

Note: When you generate a Java client, this produces an EJB or Java Bean in addition to the Java client files. Also during the generation process, the .car file created during deployment is deleted. Therefore, when setting up your Java service interface for production, you must deploy it using the .car file before generating a client.
  • EJB and Client Generation
Parent topic: Clients
Related information
To set service interface options


Editing Clients

You can edit clients to enhance their appearance and usability. With the exception of Java clients, clients are generated in the same Visual Studio project that contains the service interface they are generated from, and you can edit them directly from your Visual Studio project.

For Java clients, you should first extract (using a utility such as WinZip) the JSP file from the servintname.war archive file found in the deployment folder for your Visual Studio project.

Note:

If you edit the JSP file, add it back to the .war archive and save a copy of it to another location to ensure it does not get overwritten if you decide to redeploy the service interface.

Parent topic: Clients


Running Clients

You can run console, WPF, Windows Forms, and ASP.NET Web Site clients from your Visual Studio project. To do so, you must have your enterprise server started, your service deployed to your enterprise server, and your client generated.

Parent topic: Clients


Hosting ASP.NET Web Sites on 64-bit Operating Systems

To host ASP.NET Web site clients on 64-bit Windows operating systems, you must first enable support for 32-bit applications by setting the Enable 32 bit Applications property to True for the Internet Information Services (IIS) Application Pool associated with your ASP.NET Web site client. See your operating system's IIS documentation for details.

Parent topic: Clients


Tracing Service Execution

You can use the Trace utility to collect information on the execution of your CICS or IMS service.

  • Tracing CICS Service Execution
  • Tracing IMS Service Execution
Parent topic: Clients
Related information
Deploying to an Enterprise Server


Tracing CICS Service Execution

You configure tracing for CICS services by setting the Generated trace level, Runtime trace level, and Trace queue name properties for your service interface.

You set trace levels for two phases.

Set the Generated trace level property to specifiy the level of information you want to generate into your deployed service. This determines the level of trace information available at run time. The options are:

  • None - No trace information is generated into the deployed service
  • Low - Generate trace code showing the execution of service interface operations, input and output interface fields, and screen records
  • High - Generate trace code showing record names and paragraph names as they execute, in addition to the information generated by the Low setting

Set the Runtime trace level property to specifiy the level of information you want to to have written to the trace queue at run time. The options are:

  • RUN_LEVEL_1 - No information is written to the trace queue
  • RUN_LEVEL_2 - Writes trace records showing the execution of operations and the accessing of screen input and output records
  • RUN_LEVEL_3 - Writes trace records showing the names of paragraphs as they execute, input and output interface data, and screen records
  • RUN_LEVEL_4 - Writes low-level trace messages from bridge support modules
  • RUN_LEVEL_5 - Writes medium-level trace messages from bridge support modules
Note:
  • Because the Generated trace level setting determines the type of information generated into the deployed service, the runtime can only generate messages based on that stored information even if the Runtime trace level is set to write out higher-level messages.
  • The reporting for each trace level builds on the lower level or levels, meaning that the higher trace levels also include all trace messages associated with lower levels.
  • The file sizes for your deployed service grow in proportion with the level of reporting you specify. Larger files could slightly degrade run-time performance.

We provide a trace viewer you can run using a TN3270 emulator. You must have your service deployed to an enterprise server configured with a TN3270 listener. You can retrieve information about transactions and render screens.

Note:

Before redeploying your service for production, set the Generated trace level to None.

Parent topic: Tracing Service Execution
Related information
To trace the execution of a CICS service


Tracing IMS Service Execution

You can trace IMS service execution using the Micro Focus Consolidated Tracing Facility (CTF).

The process of enabling tracing is a combination of setting the appropriate service intreface properties and enabling the CTF. Deployment and client generation are not affected.

Two properties determine the level of trace information. They are:

  • Generate trace - Trace IMS service interface runtime information.
  • Enable system trace - Trace the service interface operation names.

You can enable either one or both of these properties depending on the type of trace information you want.

Note: Enable system trace can be particularly useful to identify the last operation that executed prior to a failure.

Before enabling the CTF, configure it by setting the MFTRACE_CONFIG environment variable to point to the ctf.cfg configuration file.

The following is an example of the contents of a typical ctf.cfg file:

mftrace.emitter.es#level             = 99999
mftrace.application                  = cassi
mftrace.dest                         = textfile
mftrace.emitter.textfile#Location    = c:\ctf
mftrace.level                        = debug
mftrace.comp.mf.rts#api              = true
mftrace.comp.mf.rts#container        = true
mftrace.comp.mf.rts#external         = true
mftrace.comp.mf.rts#fsys             = false
mftrace.comp.mf.rts#jsem             = false
mftrace.comp.mf.rts#memory           = false
mftrace.comp.mf.rts#mfentmap         = true
mftrace.comp.mf.rts#mfpm             = false
mftrace.comp.mf.rts#pgm              = true
mftrace.comp.mf.rts#pgmload          = true
mftrace.comp.mf.rts#pgmsearch        = false
mftrace.comp.mf.rts#syspgm           = true
mftrace.comp.mf.rts#signal           = true
Parent topic: Tracing Service Execution
Related information
To trace the execution of an IMS service
To enable CTF tracing


How to...

Topics that provide step-by-step instructions on using the Service Interfaces feature.

  • Manage Service Interface Projects
    Tasks related to managing service interface projects within Visual Studio.
  • Edit Map Annotations
    Tasks related to using the Map Annotations Editor.
  • Define Service Interfaces
    Tasks related to using the Service Interfaces Editor.
  • Capture Workflows
    Tasks related to capturing workflows for service interface projects within Visual Studio.
Parent topic: Service Interfaces Using the IMTK


Manage Service Interface Projects

Tasks related to managing service interface projects within Visual Studio.

  • To add or remove application files to deploy
  • To add a workflow to a project
  • To associate an enterprise server with a project
  • To create a Visual Studio project for service interfaces
  • To create a service interface
  • To debug a service interface
  • To deploy a service interface
  • To generate clients
  • To import a COBOL program service interface
  • To modify the classpath property
  • To refresh annotations
  • To set service interface options
  • To specify a workflow capture server
  • To trace the execution of a CICS service
  • To trace the execution of an IMS service
  • To validate a service interface or workflow
Parent topic: How to...
Related information
Managing Service Interface Projects


To add or remove application files to deploy

  1. In Solution Explorer, right-click a COBOL program-based service interface, and select Properties.
  2. In the Application files to deploy field, click the browse button.
  3. Add or remove application files as required.
Parent topic: Manage Service Interface Projects


To add a workflow to a project

  1. In Solution Explorer, right-click the project name; then click Add > New Item.
  2. Under Categories, expand Native; then click Mainframe Subsystem.
  3. Under Templates, click Workflow.
  4. In the Name field, type a name for your workflow capture; then click Add.
  5. On the Solution Explorer, right-click the newly added workflow; then click Properties.
  6. Set the Host code page, Host name, Host port, and Host terminal type properties that apply to your host machine.
  7. From the Visual Studio IDE, click Tools > Options.
  8. In the left pane, expand Projects and Solutions > COBOL Project Settings > Service Interfaces.
  9. In the Server name for workflow capture field, type the machine name or the IP address of your workflow capture server; then click OK.
Parent topic: Manage Service Interface Projects
Related information
Workflow Capture Process


To associate an enterprise server with a project

  1. In Visual Studio, add the server containing your enterprise server to the Server Explorer. If your enterprise server is on your local machine, specify localhost as the host name, and 86 as the port.
  2. On the Server Explorer, expand the server name to show a list of available enterprise servers.
  3. Right-click the enterprise server you want to associate with the project; then click Associate with project > projectName .
Parent topic: Manage Service Interface Projects
Related information
Configuring an Enterprise Server


To create a Visual Studio project for service interfaces

  1. From the Visual Studio IDE, click File > New > Project.
  2. Under Project types, expand COBOL Projects; then click Native.
  3. Under Templates, click one of the following:
    • Enterprise Server Application - for COBOL program service interfaces only. Use this template for service interfaces that do not require mainframe support.
    • Mainframe Subsystem Application - for CICS and IMS service interfaces, and COBOL program service interfaces that require mainframe support.
    Note:
    • For projects and solutions created with the Enterprise Server Application template, the Studio Enterprise Edition IDE does not display mainframe-related properties, tabs, fields, or other UI controls available for projects and solutions created using the Mainframe Subsystem Application template.
    • When creating a Visual Studio solution for a group of service interface projects, choose one of these templates based on whether or not the projects you intend to add to the solution require mainframe support.
  4. Complete the other fields as required.
Parent topic: Manage Service Interface Projects
Related information
Workflow Capture Process


To create a service interface

  1. In Solution Explorer, right-click a project; then click Add > New Item.
  2. Under Categories, expand Native.
  3. Under Templates, click Service Interface.
  4. In the Name field, type a name for your service interface; then click Add.
  5. Using the two drop-down lists, select an interface and source type.
  6. If you want to base this service interface on one or more workflow captures, select the workflow capture(s) on the list.
  7. Click OK.
Parent topic: Manage Service Interface Projects
Related information
Defining Service Interfaces
Service Interface
Creating a Service Interface from Workflows


To debug a service interface

  1. Be sure that you have enabled Allow Dynamic Debugging for the enterprise server that runs your service interface.
  2. In your Visual Studio project for your service interface, increase the values for both the Facility keep time (seconds) and Wait interval (seconds) service interface properties to a number representing several minutes. For example, we recommend 300 seconds (five minutes) or more for debugging.
    Important: For production, we recommend that you change both of these values back to their default of 30 seconds each or to change them to values suitable for your production applications.
  3. From the Solution Explorer, deploy your service interface to the appropriate enterprise server.
  4. Start the enterprise server.
  5. From the Solution Explorer, open the Properties window for the project that contains the CICS program invoked by your service interface.
    Note: The CICS program that is invoked by your service interface might reside in a different project than the service interface itself.
  6. On the Debug tab, set Choose Active Settings to CICS.
  7. On the CICS tab in the Transaction field, type the transaction code that starts the CICS application.
  8. From the Solution Explorer, right-click the program invoked by your service interface; then click Debug.
  9. When you are done debugging, click Debug > Stop Debugging.
Parent topic: Manage Service Interface Projects
Related information
To deploy a service interface
Configuring an Enterprise Server for a CICS service
Properties - Service Interface


To deploy a service interface

  1. Associate an enterprise server with the project containing the service interface you want to deploy.
  2. From the Enterprise Server Administration page, be sure that the enterprise server that runs your application is started.
  3. Set the appropriate deployment properties for your service interface.
  4. In Solution Explorer, right-click your service interface, and click Deploy.
Note:
  • Enterprise Server Administration lists your deployed service as a service of the enterprise server running your application. You must delete the service from Enterprise Server before you can redeploy it.
  • You can also deploy your service interface to an enterprise server running under UNIX.
Parent topic: Manage Service Interface Projects
Related reference
imtkmake command
Related information
To debug a service interface
Deploying to an Enterprise Server
Deploying to an Enterprise Server under UNIX
Deploying to 64-bit Platforms
Configuring an Enterprise Server for a CICS service
Properties - Service Interface
Creating a Service Interface from Workflows
To associate an enterprise server with a project
Deploying to an Enterprise Server under UNIX


To generate clients

  • In Solution Explorer, right-click a service interface, and click Generate Clients.
Parent topic: Manage Service Interface Projects


To import a COBOL program service interface

  1. In Solution Explorer for the project into which you want to import a service interface, use the Add > Existing Item option to add all programs, maps, and copybooks that apply to the service interface you want to import.
  2. Again using the Add > Existing Item option, browse to a .svi file in a different project, or a ServiceInterfaceName.xml file created using an older version of the service interfaces feature; then click Add.
Note: Studio Enterprise Edition does not support the importing of CICS Screen, CICS commarea or IMS Screen service interfaces.
Parent topic: Manage Service Interface Projects


To modify the classpath property

  1. In Solution Explorer, right-click a Java-based service interface, and select Properties.
  2. In the Classpath field, click the browse button.
  3. Add, remove, or reorder files and folders as required.
Parent topic: Manage Service Interface Projects
Related information
Add/Remove Items


To refresh annotations

  1. In Solution Explorer, right-click your project; then click Refresh Annotations for Services.
  2. Click either Programs or Maps to populate the list. Maps and programs containing annotations that are out of date and that require refreshing are listed with a red checkmark to the left.
  3. Click each program or map you want to refresh, or click Auto Select to select all maps or programs that contain annotations that are out of date.
  4. Click Refresh; then click Close.
Parent topic: Manage Service Interface Projects
Related information
Refresh Annotations


To set service interface options

  1. From the Visual Studio IDE, click Tools > Options.
  2. In the left pane, expand Projects and Solutions > COBOL Project Settings > Service Interfaces.
  3. Set the options as required; then click OK.
Parent topic: Manage Service Interface Projects
Related information
Generating Clients
Options - Service Interfaces


To specify a workflow capture server

  1. From the Visual Studio IDE, click Tools > Options.
  2. In the left pane, expand Projects and Solutions > COBOL Project Settings > Service Interfaces.
  3. In the Server name for workflow capture field, type the machine name or the IP address of your workflow capture server; then click OK.
Parent topic: Manage Service Interface Projects
Related information
Prerequisites
Workflow Capture Process


To trace the execution of a CICS service

  1. In Enterprise Server, be sure that you have enabled a TN3270 listener for the enterprise server instance that runs your service.
  2. From the Properties window for your service interface, set the Generated trace level, Runtime trace level, and Trace queue name properties.
    Note: If you leave the Trace queue name field blank, trace information goes to the default trace temporary storage (TS) queue, CEBRMQMW. By entering a name here you can specify your own trace TS queue.
  3. Deploy the service interface.
  4. If necessary, generate a client.
  5. Invoke your service, performing one or more transactions, then exit.
  6. Start your TN3270 emulator.
  7. On the initial panel of your TN3270 emulator, type one of the following:
    • MERQ queuename - For all CICS screen services, and for CICS commarea services for EBCDIC applications.
    • MARQ queuename - For CICS commarea services for ASCII applications.

    Where queuename is the trace queue name you specified in the Properties window, or the default name CEBRMQMW.

    This starts the trace viewer.

  8. Do one or more of the following:
    • To view details of a specific record, place your cursor at the beginning of the summary line for that record and press Enter.
    • To return to the summary page, press F3 or Enter.
  9. To exit the trace viewer, press F3.
Note: Other keys you can use to navigate in the trace viewer are:
F2 | Toggle the display to show ASCII characters, EBCDIC characters, or both
F4 | Purge the trace queue
F7 | Scroll back half the length of the panel
F8 | Scroll forward half the length of the panel
F9 | Scroll back the full length of the panel
F10 | Scroll forward the full length of the panel
F11 | Scroll to the top
F12 | Scroll to the bottom
Parent topic: Manage Service Interface Projects
Related information
Tracing CICS Service Execution


To trace the execution of an IMS service

  1. From the Properties window for your service interface, set the Generate trace, and/or Enable system trace properties to Yes.
  2. Configure and enable the Micro Focus Consolidated Tracing Facility.
  3. Deploy the service interface and generate a client.
  4. Execute the service.
  5. To review trace information, search the resulting logfile for the text string MFEBI, which starts the section where IMS service execution trace information begins.
Related information
Tracing IMS Service Execution
To enable CTF tracing


Edit Map Annotations

Tasks related to using the Map Annotations Editor.

  • To edit a logical screen map name
  • To define a map field direction
  • To group map fields
  • To add or delete map field values
Parent topic: How to...


To edit a logical screen map name

  1. In Solution Explorer, right-click a map file (.bms or .mfs).
  2. From the context menu, click Edit Annotations for Services; then click the name of the map you want to edit.
  3. In the Name column, double-click the field name you want to change.
  4. Type a name into the field.
  5. Click outside of the field or press Enter to commit the change.
Parent topic: Edit Map Annotations
Related information
Changing Logical Field Names
To add or change screen field values
To define screen field direction
To group screen fields


To define a map field direction

  1. From the Solution Explorer, right-click a map file (.bms or .mfs).
  2. From the context menu, click Edit Annotations for Services; then click the name of the map you want to edit.
  3. In the Direction column, double-click the row that corresponds to the field name whose direction you want to change.
  4. Choose a direction from the drop-down list.
  5. Click outside of the list to commit the change.
Parent topic: Edit Map Annotations
Related information
Defining Field Direction
To add or change screen field values
To edit a logical screen field name
To group screen fields


To group map fields

  1. In Solution Explorer, right-click a map file (.bms or .mfs).
  2. From the context menu, click Edit Annotations for Services; then click the name of the map you want to edit.
  3. Select the consecutive fields you want to group. Hold the Shift or Cntl key and click to select more than one.
  4. Right-click any selected field and click Group on the context menu.
  5. In the Number of fields in the group field, type the number of fields you want to include in each occurrence of the resulting array. This number must be less than the total number of fields you are grouping, and you must be able to divide the number of fields you have selected evenly by this number. For example, if your screen has five rows of data and each row contains seven fields, to group each row, specify 7 as the number of fields to appear in the new group.
  6. In the Group name prefix field, type any prefix to identify the group.
Parent topic: Edit Map Annotations
Related information
Grouping Fields
Group Fields
To add or change screen field values
To define screen field direction
To edit a logical screen field name


To add or delete map field values

  1. In Solution Explorer, right-click a map file (.bms or .mfs).
  2. From the context menu, click Edit Annotations for Services; then click the name of the map you want to edit.
  3. Click the Field Values tab at the bottom of the editor.
  4. In the Values column, double-click the row that corresponds to the field whose value you want to add or change.
  5. To add a value, type a value into the Value field; then click Add.
  6. To delete a value, click a value on the Values list; then click Delete.
  7. Click OK.
Parent topic: Edit Map Annotations
Related information
Field Values


Define Service Interfaces

Tasks related to using the Service Interfaces Editor.

  • To start the Service Interfaces Editor
  • To create a COBOL program-based operation
  • To create a screen-based operation
  • To create a CICS commarea-based operation
  • To create an interface field
  • To create a reusable field
  • To create a work field
  • To map an interface field
  • To edit field properties
  • To assign a value to a COBOL field
  • To assign a value to a screen, commarea, or work field
  • To group interface, work, or reusable fields
  • To create and apply a conditional statement
  • To apply an existing condition
  • To edit conditions
  • To view applied conditions
  • To assign an extracted string value
  • To assign the result of a concatenation
  • To assign the result of an arithmetic function
  • To assign the summation of array elements
  • To add initialization or termination code
Parent topic: How to...


To start the Service Interfaces Editor

  • In Solution Explorer, double-click a service interface.
Note: The Service Interfaces Editor starts automatically immediately after you create a service interface.
Parent topic: Define Service Interfaces


To create a screen-based operation

  1. In the Service Interfaces Editor, right-click Operation, and click New.
  2. In the Operation Name field, type a name for the operation.
  3. From the Active Screen drop-down list, click the screen name for the screen you want to process with the operation.
  4. From the Previous Screen drop-down list, click the screen that precedes the active screen.
  5. In the Transaction ID field, type the ID that starts the application.
  6. If you want to automatically create interface fields with default mappings for all of the fields on the active screen, check Create Default Mapping.
  7. Click OK.
Note:
  • Provide a transaction ID only when the operation you are defining starts a transaction.
  • It is common practice for IMS applications to specify a transaction ID in the MFS MID definition. In this case, to ensure that offsets are calculated properly, select the USE TRANSACTION ID FROM SCREEN DEFINITION option when specifying the transaction ID for your operation. This option is available only when you select an active screen other than <None>, ANY SCREEN, or EMPTY SCREEN.
Parent topic: Define Service Interfaces
Related information
Creating CICS or IMS Screen-based Operations
Operation Properties - Screen-based Services - General tab
Operation Properties - Transaction tab
Operation Reorder
Creating a Service Interface from Workflows


To create a CICS commarea-based operation

  1. In the Service Interfaces Editor, right-click Operation, and click New.
  2. Define the new operation by specifying:
    • A name for the new operation
    • A program
    • An input commarea, which you select from the list of commareas available in the program
    • An output commarea, which you select from the list of commareas available in the program
    • Any user exits that you require
  3. If you want to automatically create interface fields with default mappings for all of the fields in the input and output commareas, check Create Default Mapping.
Related information
Creating CICS Commarea-based Operations
Operation Properties - COBOL Program/CICS Commarea-based Services - General tab
Operation Properties - User Exits tab
Operation Reorder


To create an interface field

  • From the Service Interfaces Editor, drag a field from the COBOL Entry Point, Screen, Input Commarea, or Output Commarea pane and drop it in the Interface Fields pane.
Note:
  • Interface fields created in this manner are automatically mapped to the originating field.
  • The Direction property for an interface field is automatically set based on the direction of the originating field as follows:
    Direction of the originating field | Direction of the interface field
    Input | Input
    Input/Output | Input
    Output | Output
  • You can also create an interface field by one of the following methods:
    • Right-clicking the originating field and selecting New Input Field... or New Output Field... from the popup menu.
    • Rick-clicking in the Interface Fields pane and selecting New Interface Field from the popup menu. In this case, a default mapping is not generated for the new interface field. Therefore, be sure to map the new field manually.
Parent topic: Define Service Interfaces
Related information
Interface Fields
Work Fields
Creating a Service Interface from Workflows


To create a reusable field

  1. From the Service Interfaces Editor Reusable Fields pane, right-click, then click New Reusable Field from the popup menu.
  2. Complete the fields and click OK.
Note: Reusable fields are available for COBOL Program-based service interfaces only.
Parent topic: Define Service Interfaces
Related information
Reusable Fields


To create a work field

  1. From the Service Interfaces Editor Work Fields pane, right-click, then click New Work Field from the popup menu.
  2. Complete the fields and click OK.
Note: Work fields are available for CICS- and IMS-based service interfaces only.
Parent topic: Define Service Interfaces
Related information
Work Fields


To map an interface field

  1. From the Service Interfaces Editor, right-click an interface field on the Interface Fields pane and click Mapping from the popup menu.
  2. From the COBOL Field drop-down list, click a field you want to map to your interface field.
  3. Click Add; then click OK.
Note: By default, array fields appear with an asterisk, meaning that all occurrences are mapped. You can edit an array mapping, changing the asterisk to a subscript to point to a specific occurrence.
Parent topic: Define Service Interfaces
Related information
Mappings
Mapping


To edit field properties

  1. From the Service Interfaces Editor, right-click a field that appears in the Interface Fields or Work Fields pane and click Properties from the popup menu.
  2. Specify the appropriate properties, then click OK.
Related information
Interface Fields
Field Properties


To assign a value to a COBOL field

  1. From the From the Service Interfaces Editor COBOL Entry Point pane, drag a field to the COBOL Assignments pane.
  2. In the Value field, type a literal value to assign to the field specified in the Name field.
Note:
  • If you drag a group field, the New Assignment dialog box opens for each elementary item in turn. You can click Cancel if you do not want to set values for all of them.
  • You can also create a COBOL Assignment field by right-clicking in the COBOL Assignments pane and selecting New Assignment from the context menu.
Related information
COBOL Assignments
COBOL Assignment


To assign a value to a screen, commarea, or work field

  1. From the Service Interfaces Editor Assignments pane, right-click, then click New Assignment from the popup menu.
  2. From the Assign to drop-down list, click the field to which you want to assign a value.
  3. In the Field 1/Operand 1 field, do one of the following:
    • To assign a field value, click a field name from the drop-down list
    • To assign a numeric or non-numeric literal value, type the value into the field
  4. Click OK.
Note:
  • Fields that are part of an array appear on the Field/Operand drop-down lists with a subscript. The default subscript is the total number of occurrences of the field. To specify a specific occurrence, edit the subscript in the Field/Operand field. If you want to specify all occurrences, type an asterisk (*) as the subscript.
  • Any condition defined for the assignment appears in the Assignment Condition box at the bottom of the Assignment dialog box.
Parent topic: Define Service Interfaces
Related information
Assignments
ATTENTION ID
CURSOR POSITION
Assignment


To group interface, work, or reusable fields

  1. From the Service Interface Editor Interface Fields, Work Fields, or Reusable Fields pane, select the fields you want to group. Hold the Shift or Cntl key as you click to select more than one.
  2. Right-click any selected field and click Group from the popup menu.
  3. Type a name for the group into the Name field.
  4. Type the number of times you want the group to occur into the Occurs field.
  5. Click Input or Output to set a direction for the entire group, if applicable.
Note:

To ungroup previously grouped fields, right-click the group name and click Ungroup from the popup menu.

Parent topic: Define Service Interfaces
Related information
Interface Fields
Work Fields
Group Properties
To create a work field
To create an interface field
To map an interface field
To set field properties


To create and apply a conditional statement

  1. From the Service Interfaces Editor, right-click an entry in the Mappings or Assignments pane and click Apply Condition from the popup menu.
  2. In the New Name field, type a name for the condition, then click Create.
  3. Build a condition using the fields and controls of the Condition Editor, then click OK.
Note:
  • To use an existing condition as a starting point for building a new condition, click an existing condition from the Existing Condition drop-down list and then proceed with step 2 above. This can be useful, for example, to negate an existing condition without having to recreate the existing condition as you define its negation.
  • Only conditions defined for the current operation appear in the Condition Editor as existing conditions.
Parent topic: Define Service Interfaces
Related information
Conditional Statements
Apply Condition / Edit Conditions
Condition Editor


To apply an existing condition

  1. From the Service Interfaces Editor, right-click an entry from the Mappings or Assignments pane and click Apply Condition from the popup menu.
  2. From the Existing Conditions drop-down list, click the name of the condition you want to apply, then click OK.
Note: To remove a condition, right-click the mapping or assignment and click Remove Condition from the popup menu.
Parent topic: Define Service Interfaces
Related information
Conditional Statements
Apply Condition / Edit Conditions
Condition Editor


To edit conditions

  1. From the Service Interfaces Editor, click Operation > Edit Conditions.
  2. From the Existing Conditions drop-down menu, click a condition you want to edit, then click Edit.
  3. Edit the condition using the fields and controls of the Condition Editor, then click OK.
Parent topic: Define Service Interfaces
Related information
Conditional Statements
Apply Condition / Edit Conditions
Condition Editor


To view applied conditions

  1. From the Service Interfaces Editor, right-click a field on the Interface Fields pane, then click Mappings from the popup menu.
  2. Click Show Condition >>.
Note:

The Show Condition >> button acts as a toggle. If conditions are already showing, click it to hide them.

Parent topic: Define Service Interfaces


To assign an extracted string value

  1. From the Service Interfaces Editor Assignments pane, right-click, then click New Assignment from the popup menu.
  2. From the Assign to drop-down list, click the field to which you want to assign a value.
  3. Do one of the following:
    • From the Field 1/Operand 1 drop-down list, select a field.
    • Type a value into the Field 1/Operand 1 field.
  4. From the Function/Operator drop-down list, click SUBSTRING.
  5. In the Field 2/Operand 2 field, type a number representing the starting position of the extracted string. For example, if you want to extract a string that begins with the third character of the string, type 3.
  6. In the Field 3/Operand 3 field, type a number representing the total length of the extracted string. For example, if you want to start on the third character as in the example above, extracting it and the next 5 characters, type 6.
  7. Click OK.
Note:
  • Fields that are part of an array appear on the Field/Operand drop-down lists with a subscript. The default subscript is the total number of occurrences of the field. To specify a specific occurrence, edit the subscript in the Field/Operand field. If you want to specify all occurrences, type an asterisk (*) as the subscript.
  • Any condition defined for the assignment appears in the Assignment Condition box at the bottom of the Assignment dialog box.
Parent topic: Define Service Interfaces
Related information
Assignments
Functions/Operators
Assignment


To assign the result of a concatenation

  1. From the Service Interfaces Editor Assignments pane, right-click, then click New Assignment from the popup menu.
  2. From the Assign to drop-down list, click the field to which you want to assign a value.
  3. Do one of the following:
    • From the Field 1/Operand 1 drop-down list, select a field.
    • Type a value into the Field 1/Operand 1 field.
  4. From the Function/Operator drop-down list, click CONCAT.
  5. Repeat step 3 for the Field 2/Operand 2 field. This value gets appended to the value of the field or literal specified in Field 1/Operand 1.
  6. Click OK.
Note:
  • Fields that are part of an array appear on the Field/Operand drop-down lists with a subscript. The default subscript is the total number of occurrences of the field. To specify a specific occurrence, edit the subscript in the Field/Operand field. If you want to specify all occurrences, type an asterisk (*) as the subscript.
  • Any condition defined for the assignment appears in the Assignment Condition box at the bottom of the Assignment dialog box.
Parent topic: Define Service Interfaces
Related information
Assignments
Functions/Operators
Assignment


To assign the result of an arithmetic function

  1. From the Service Interfaces Editor Assignments pane, right-click, then click New Assignment from the popup menu.
  2. From the Assign to drop-down list, click the field to which you want to assign a value.
  3. Do one of the following:
    • From the Field 1/Operand 1 drop-down list, select a field.
    • Type a numerical value into the Field 1/Operand 1 field.
  4. From the Function/Operator drop-down list, select one of the following operators:
    • +
    • -
    • /
    • *
  5. Repeat step 3 for the Field 2/Operand 2 field.
  6. Click OK.
Note:
  • Fields that are part of an array appear on the Field/Operand drop-down lists with a subscript. The default subscript is the total number of occurrences of the field. To specify a specific occurrence, edit the subscript in the Field/Operand field. If you want to specify all occurrences, type an asterisk (*) as the subscript.
  • Any condition defined for the assignment appears in the Assignment Condition box at the bottom of the Assignment dialog box.
Parent topic: Define Service Interfaces
Related information
Assignments
Functions/Operators
Assignment
To assign a value to a screen, commarea, or work field
To assign an extracted string value
To assign the result of a concatenation
To assign the summation of array elements


To assign the summation of array elements

  1. From the Service Interfaces Editor Assignments pane, right-click, then click New Assignment from the popup menu.
  2. From the Assign to drop-down list, click the field to which you want to assign a value.
  3. From the Field 1/Operand 1 drop-down list, select an array field.
  4. From the Function/Operator drop-down list, click SUM.
  5. Click OK.
Note:
  • Fields that are part of an array appear on the Field/Operand drop-down lists with a subscript. The default subscript is the total number of occurrences of the field. To specify a specific occurrence, edit the subscript in the Field/Operand field. If you want to specify all occurrences, type an asterisk (*) as the subscript.
  • Any condition defined for the assignment appears in the Assignment Condition box at the bottom of the Assignment dialog box.
Parent topic: Define Service Interfaces
Related information
Assignments
Assignment


To add initialization or termination code

  1. Back up and then edit the following file:

    projdir\servintprojname\ UserRules\usermain.igl

    Where projdir is your Studio Enterprise Edition project directory, and servintprojname is the name of the project containing your service interface.

  2. Find the following code in the usermain.igl file:
    % if 0
    % defini $ebiz-user-initialisation-exit
        ebiz-user-initialisation-exit section.
            % * Code your ebiz initialisation exit logic here
            % * Change the preceeding '% if 0' to '% if 1'
            exit
            .
    % end
% end

% if 0
    % defini $ebiz-user-termination-exit
        ebiz-user-termination-exit section.
            % * Code your ebiz termination exit logic here
            % * Change the preceeding '% if 0' to '% if 1'
            exit
            .
    % end
% end
  3. To include initialization or termination code, change the % if 0 for the appropriate paragraph to % if 1. This change flags the paragraph for inclusion in the generated service driver program.
  4. Code your initialization or termination logic by replacing the appropriate comment line with COBOL code.
  5. Save your changes and exit your editor.
Parent topic: Define Service Interfaces
Related information
Initialization or Termination Logic


Capture Workflows

Tasks related to capturing workflows for service interface projects within Visual Studio.

  • To view or edit workflow transitions
Parent topic: How to...


To capture a workflow

  1. In the Solution Explorer, double-click a workflow file. This starts the Workflow Capture emulator.
  2. Start your application.
  3. Interact with your application, running through all of the sequences you want to capture. Click the keyboard button representations at the bottom of the emulator window with your mouse rather than pressing keyboard keys directly.
  4. When you have completed your sequences, click Disconnect in the emulator window.
    Note:
    • After completion of the capture process, a graphical representation of your capture sequences, including screens accesses and transitions from one screen to another, is displayed on the Transitions tab.
    • To add to an existing workflow, double-click it to start the emulator; then run through the sequences you want to add.
Related information
Workflow Capture Process
Creating a Service Interface from Workflows
Properties - Workflow


To view or edit workflow transitions

  1. In your Visual Studio project, double-click a workflow.
  2. If the workflow does not contain a capture sequence, interact with the application to capture screens and transitions.
  3. Click the Transitions tab.

    This tab presents a graphical representation of the workflow capture, showing transitions from one screen to another using arrows.

  4. To delete a transition, right-click a transition arrow; then click Delete transition....
  5. To delete a screen, right-click a screen icon; then click Delete....
Parent topic: Capture Workflows
Related information
Workflow Capture Process


Reference

Reference information for the Service Interfaces feature.

  • imtkmake command
    Enables you to create and deploy a COBOL program-based service interface, and generate a client to access the deloyed service running on an enterprise server.
  • mfdepinst command
    Deploys the service interface contained in a COBOL archive file (.car file) to an enterprise server.
  • COBOL to Service Interface Data Type Matches
    Describes which COBOL data types correspond to available Service Interface data types, including Web Service, Java, and .NET service interfaces.
  • User Interface Reference
    Provides help for the fields on each dialog box associated with the Service Interfaces feature.
  • Service Interface Abend Codes
    Abends relating to CICS memory issues
Parent topic: Service Interfaces Using the IMTK


imtkmake command

Enables you to create and deploy a COBOL program-based service interface, and generate a client to access the deloyed service running on an enterprise server.

Syntax:

imtkmake -defmap          service=service-name
                          src=program-name
                          type=service-type
                         [directives=Compiler-directives]
                         [settings=properties-filename]

imtkmake -generate        service=service-name
                          type=service-type
                         [appdir=directory-name]
                         [appserver=J2EE-application-server-name]
                         [bean=bean-name]
                         [classpath=pathname]
                         [ejbname=ejb-name]
                         [esruntime=esruntime-filename]
                         [exithandler=program-name]
                         [filename]...
                         [@filelistname]
                         [jarname=jar-filename]
                         [namespace=service-namespace]
                         [package=package-name]
                         [serverHost=host-name]
                         [serverPort=port-number]
                         [session={stateless|stateful}]
                         [settings=properties-filename]
                         [style={doclit|rpcenc}]
                         [transaction={application|container}]
                         [url=ip-address]

imtkmake -query
imtkmake -queryAppServerList
imtkmake -deploy          type=service-type
                         [carname=car-filename]
                         [password=secure-password]
                         [server=server-name,deployer-name]
                         [settings=properties-filename]
                         [username=secure-username]

imtkmake -showlog         deploydir=deployment-directory
imtkmake -genclient       service=service-name
                          type=service-type
                         [appserver=J2EE-application-server-name]
                         [clientdir=directory-name]
                         [j2eeVersion={1.3|1.4}]
                         [namespace=service-namespace]
                         [style={doclit|rpcenc}]
                         [url=ip-address]
imtkmake -genclientwsdl   clientwsdl=wsdl-filename
                         [clientdir=directory-name]
                         [defaultstringsize=string-size]
                         [defaultarraysize=array-size]
imtkmake -help

Parameters:

-defmap
Create a service interface using default mappings based on the COBOL program specified in the src= parameter.
-generate
Generate deployment files based on the parameters set, and generate a COBOL archive (.car) file containing the generated files for deployment to the enterprise server.
-query
List the enterprise servers available for deployment.
-queryAppServerList
List the J2EE application servers available.
-deploy
Deploy the .car file created with -generate parameter to the enterprise server. Execute imtkmake with the -deploy parameter from the servicename.deploy directory.
-showlog
Display the contents of the deployment log (deploylog.txt file).
-genclient
Generate a client from the service interface, according to the specified type, such as EJB or Web Services.
-genclientwsdl
Generate a COBOL client from WSDL.
-help
Display information about imtkmake functions and parameters.
appdir=directory-name
The path to the application files for the application running on the enterprise server.
appserver=J2EE-application-server-name
This is the name and version of the J2EE application server for which an EJB is generated and to which an EJB is deployed. This defines the deployment descriptors that are generated.

This is mandatory when generating EJBs and EJB clients. In other words, mandatory when using the -generate or -genclient functions with type set to EJB. The values must be within quotes since they contain spaces. For example:

  • "JBoss 4.2.3"
  • "WebSphere 6.0"

Note that this parameter must come after the other parameters.

See -queryAppServerList for how to list the available servers.

bean=bean-name
For EJB generation, the name of the bean to generate. Defaults to service-name.
carname=car-filename
The path to and name of the .car file to deploy. By default, this file is named service.car and is in the service.deploy directory. carname= is not required when you generate and deploy on the same command line.
classpath=pathname
For EJB generation, the classpath of the J2EE implementation classes on the J2EE application server. This is case sensitive. This is different for each J2EE application server and is the path to the following .jar files:
  • JBoss's jboss-j2ee.jar and servlet-api.jar
  • WebSphere's j2ee.jar
  • WebLogic's weblogic.jar
clientdir=directory-name
The directory in which to generate the client program. With the -genclientwsdl function, defaults to the WSDL file directory; otherwise defaults to the directory where the service is deployed
clientwsdl=wsdl-filename
The name of the WSDL file to generate the client program from which to generate it.
defaultarraysize=array-size
The default array size to use for unbounded arrays.
defaultstringsize=string-size
The default string size to use for unbounded strings.
deploydir=deployment-address
The URL of the deploylog.txt file. This URL is displayed by the -deploy function.
directives=Compiler-directives
The directives required for the program to compile correctly. Use a comma between directives.
ejbname=ejb-name
For EJB generation, the name of the EJB to generate. Defaults to service-nameEJB.
esruntime=esruntime-filename
The name of a file containing the run-time configuration settings to be applied when the deployed service is run. The file extension must be .rtc.
exithandler=program-name
For Web Services generation, the name of a user exit program to handle the exit points in the MFRHSOAP request handler.
@filelistname
The name of a file containing a list of additional files that need to be included in a .car file. Each file name must be on a new line.
filename
An additional file that needs to be included in a .car file. You can specify multiple additional files.
jarname=jar-filename
For EJB generation, the name of the .jar file to create. Defaults to service-name.jar.
namespace=service-namespace
For Web Services generation, EJB generation and client generation, the service namespace. Web Services generation and client generation defaults to http://tempuri.org/service-name. EJB generation defaults to service-name .
package=package-name
For EJB generation, the name of the package of Java classes to contain the bean. This is case-sensitive. Defaults to com.mypackage.service-name.
password=secure-password
The password to enable a service interface to be deployed to a secure server. This is required only when MFDS is configured to require it.
server=server-name,deployer-name
The destination of the deployment files. server-name is the enterprise server to which you want to deploy the service, and deployer-name is the name of a deployment service on that enterprise server. If you do not supply this parameter, the function lists the servers available for deployment and prompts you to choose one.
serverHost=host-name
The name of the host machine that is running the enterprise server for the J2SE Java bean.
serverPort=port-number
The port number of the enterprise server listener for the J2SE Java bean
service=service-name
The name of the service for mapping or generation.
session={stateless|stateful}
For EJB generation, the type of EJB to generate. Defaults to stateless.
settings=properties-filename
The name of a file containing the set properties for this service interface.
src=program-name
The program use for creating default mappings.
style={doclit | rpcenc}
The style to use for WSDL generation. The default is doclit.
transaction={application|container}
Specifies whether the service is application-managed or transaction-managed. The default is application.
type=service-type
The type of mapping to perform or type of client to generate (see defmapgenclient and generate above), where service-type can be one of the follwoing:
  • EJB
  • J2SE bean
  • WebService
url=ip-address
For Web Services and client generation, the IP address of the service. This is added to the WSDL document.
username=secure-username
The username that enables a service interface to be deployed to a secure server. This is required only when MFDS is configured to require it.

Comments:

  • Execute imtkmake from aNet Express command prompt in the directory that contains your COBOL program file.
  • This command performs several functions. You must execute the folloowing against the same program in the this order:
    • -defmap
    • -generate
    • -query (optional)
    • -deploy
    • -showlog (optional)
    • -genclient and/or -genwsdl (optional)
  • You can combine some functions on the same command line:
    • -defmap and -generate together, to create a service interface with default mappings and generate deployment files to be deployed at a later time.
    • -generate and -deploy together, to generate deployment files for an existing service interface, deploy them to an enterprise server.
    • -defmap, -generate, and -deploy together to perform all three functions.
    Note: When you combine two or more functions on the same command line, you do not need to repeat parameters that are common.
  • You can combine the use of the command line functions with the use of the Service Interfaces feature in Visual Studio. For example, you might create the service interface and customize it in Visual Studio. You could then use the command line to deploy the service interface.
  • If you use the Service Interfaces feature in Visual Studio to specify mapping properties for the service interface using the Mapping Properties dialog box, Visual Studio creates an XML file to hold the settings. You can specify this XML file to the -generate function using the settings=properties-filename parameter. The mapping properties XML file contains values for the optional parameters associated with the -generate function. If you specify any of those parameters on the command line, these override the values contained in the mapping properties XML file.
  • You can use () as delimiters around parameters rather than = before them, for example, src(book.cbl) instead of src=book.cbl.
  • When you deploy a service interface using imtkmake -deploy, imtkmake looks in the following places in the following order to find items to deploy, and uses the first instance of each deployable item found:
    • MFDS. If the deployment items are in MFDS, any configuration settings in the [destination] section are used. For example:
      [destination]
   server=ESDEMO
   listener=Web Services and J2EE
    • MFDS. If the deployment itemsare in MFDS, but there aren't any configuration settings, imtkmake uses the enterprise server that owns the service.

Examples:

The following command creates a service interface with default mapping for the program book.cbl:

imtkmake -defmap src=book.cbl service=wmapserv type=webservice

The following command generates a Web service for the wmapserv service interface:

imtkmake -generate service=wmapserv
                          type=webservice
                          exithandler=myhandler
                          namespace=http://corpuri.org/wmapserv

The following command generates an EJB for the JMapServ service interface:

imtkmake -generate service=JMapServ
                          type=ejb
                          bean=JMap
                          classpath=/usr/java131/lib/j2ee.jar
                          ejbname=JMapEJB
                          esruntime=jmapconf.rtc
                          jarname=JMap.jar
                          package=com.corp.jmap
                          session=stateful
                          appserver="WebLogic 9.0"

The following command generates a Web service for the wmapserv service interface and deploys it to the enterprise server ESDEMO. The additional data file data-files-path\bookfile.dat is deployed:

imtkmake -generate service=wmapserv type=webservice
         -deploy server=ESDEMO,Deployer data-files-path\bookfile.dat

The following command deploys a Web service that has already been generated in wmapserv.car to the enterprise server ESDEMO:

imtkmake -deploy carname=wmapserv.car server=ESDEMO,Deployer

This submit is a successful deployment, as indicated by the 202 return code, and the presence of the URL in the response message.

The following command displays the deploylog.txt file from the URL http://10.120.72.229:47704/uploads/cw_diYLq:

imtkmake -showlog deploydir=http://10.120.72.229:47704/uploads/cw_diYLq

The following command creates a COBOL client program for the service wmapserv:

imtkmake -genclient type=webservice service=wmapserv

The following command creates a COBOL client program for the service wmapserv using the service's WSDL file:

imtkmake -genclientwsdl clientwsdl=wmapserv.wsdl
Parent topic: Reference
Parent topic: Service Interfaces
Related reference
mfdepinst command
Related information
To deploy a service interface
Deploying to an Enterprise Server
Deploying to an Enterprise Server under UNIX
Deploying to 64-bit Platforms


mfdepinst command

Deploys the service interface contained in a COBOL archive file (.car file) to an enterprise server.

Syntax:

mfdepinst myservice.car

Parameters:

myservice.car
The name of the .car file containing the service to be deployed.

Dependencies:

Before running mfdepinst, copy the .mfdeploy file in the %ProgramFiles(x86)%\Micro Focus\Server Enterprise Edition x.x\bin if Server Enterprise Edition is installed stand alone, and %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\deploy if Server Enterprise Edition is installed as part of Studio Enterprise Edition to the parent directory of the directory that contains the .car file.

.mfdeploy specifies the location, name, and listener for the enterprise server to which the service interface is deployed. So, for example, if the .car file is in %COBDIR%\myservice\myservice.deploy , the .mfdeploy file must be in %COBDIR%\myservice .

Edit .mfdeploy as necessary to specify values other than the default values.

Run mfdepinst from aNet Express command prompt from the same directory that contains the .car file.

Comments:

mfdepinst extracts files from the .car file and installs them on the enterprise server specified in the .mfdeploy file.

mfdepinst records its progress in the file deploylog.txt in the current directory, overwriting any existing deploylog.txt. After mfdepinst completes, you can examine this file to find out if deployment succeeded.

Parent topic: Reference
Parent topic: Service Interfaces
Related reference
imtkmake command
Related information
Deploying Using the mfdepinst Command


COBOL to Service Interface Data Type Matches

Describes which COBOL data types correspond to available Service Interface data types, including Web Service, Java, and .NET service interfaces.

Table 1. Comp Fields
COBOL Data Item |  |  | Interface Field Default Type
Usage | Digits | Signed | Web Service | Java | .NET
comp fields other than comp-1 and comp-2 | 1-2 | Yes | byte | byte | SByte
 | 1-2 | No | unsignedByte | byte | Byte
 | 3-4 | Yes | short | short | Int16
 | 3-4 | No | unsignedShort | short | UInt16
 | 5-9 | Yes | int | int | Int32
 | 5-9 | No | unsignedInt | int | UInt32
 | 10-18 | Yes | long | long | Int64
 | 10-18 | No | unsignedLong | long | UInt64
 | 19+ |  | integer | BigInteger | Decimal
comp-1 |  |  | float | float | Single
comp-2 |  |  | double | double | Double
Table 2. Display and External Float Fields
COBOL Data Item |  | Interface Field Default Type
Type | Decimal Digits | Web Service | Java | .NET
Display, External Float | 0 | integer | BigInteger | Decimal
 | >0 | decimal | BigDecimal | Decimal
Table 3. Alphanumeric and Alphanumeric Edited Fields
COBOL Data Item | Interface Field Default Type
Type | Web Service | Java | .NET
Alphanumeric, Alphanumeric Edited | string | string | string
Table 4. Pointer and Index Fields
COBOL Data Item | Interface Field Default Type
Type | Web Service | Java | .NET
Pointer, Index | unsignedLong | long | UInt64
Parent topic: Reference
Parent topic: Service Interfaces


User Interface Reference

Provides help for the fields on each dialog box associated with the Service Interfaces feature.

  • Service Interface Projects
    Dialog boxes associated with Visual Studio projects containing Service Interfaces.
  • Map Annotations Editor
    Dialog boxes available from within the Map Annotations Editor.
  • Service Interfaces Editor
    Dialog boxes available from within the Service Interfaces Editor.
Parent topic: Reference


Service Interface Projects

Dialog boxes associated with Visual Studio projects containing Service Interfaces.

  • Add/Remove Items
  • Options - Service Interfaces
  • Properties - Service Interface
  • Properties - Workflow
  • Refresh Annotations
  • Service Interface
  • Username/Password
Parent topic: User Interface Reference


Add/Remove Items

Add File
Add a COBOL application file (for Application files to deploy property) or a .jar file (for Classpath property) to the list.
Add Folder
Add a folder to the Classpath property.
Remove
Remove the selected file or folder from the list.
Parent topic: Service Interface Projects
Related information
To modify the classpath property


Options - Service Interfaces

WPF Application
Generate Windows Presentation Foundation clients for Web services and .NET interfaces.
Windows Forms Application
Generate Windows Forms clients for Web services and .NET interfaces.
ASP.NET Web Site
Generate ASP.NET Web sites for Web services and .NET interfaces.
Server name for workflow capture
The machine name or IP address of your workflow capture server.
Parent topic: Service Interface Projects
Related information
To set service interface options


Properties - Service Interface

Interface type
The type of service interface, set when it was created.
Source type
The type of source files used by the service interface, set when it was created.

General

Application files to deploy
List of files included in the application. COBOL service interfaces only. Either specify the files here, or specify a Deployed application path.
Deployed application path
Location of the application files. COBOL services only. Either specify the path here, or specify Application files to deploy.
Enable ES runtime environment
Run this service using the Enterprise Server runtime configuration set in Enterprise Server Administration for this service.
Exit point handler name
The name of a user exit program that customizes the Micro Focus SOAP request handler, which handles messages received for Web services.
Service endpoint URL
The endpoint URL for the service. This must match the address of the Web Services and J2EE listener of the enterprise server that runs the service.
Service name
The name of the deployed service. This name is appended to the Service namespace, forming the name by which the service is invoked.
Service namespace
The namespace of the deployed service. This name is pre-pended to the Service name, forming the name by which the service is invoked. If there is no installation standard, leave it unchanged at the default http://tempuri.org/.
Service style
The style of the Web service. This affects the format of the SOAP messages that the Web service sends and receives.
Transaction management
The type of transaction, application or container. Application managed services must contain all necessary transactional logic to ensure that all resources are either committed or rolled back. Container managed services use databases and files, but do not contain any transactional logic. All CICS and IMS services are container managed.
Username/password required
Provide a user ID and password to the deployment server. When Yes, you are prompted for a user ID and password during the deployment process.

CICS/IMS

Application character set
The character set used to compile the application.
Driver program name
The name of the generated service driver program. The default is the first eight characters of the service interface name.
Enable system trace
For IMS services, traces the executed service using the Micro Focus Consolidated Tracing Facility. When a service fails, the final trace entry is the point at which it failed.
Facility keep time (seconds)
For CICS services, the number of seconds that the enterprise server environment stays active after each service operation. The default is 30.
Facilitylike name
The name of a virtual terminal to use for CICS applications that run under Enterprise Server/MSS. The default (blank) is for a MOD2 terminal. Specify MER3 for a MOD3 terminal, MER4 for a MOD4 terminal, MER5 for a MOD5 terminal.
Generate trace
For IMS services, generate trace information about the service driver program and runtime.
Generated trace level
For CICS services, the level of trace information generated into the deployed service.
Runtime trace level
For CICS services, the level of trace information written to the trace queue at runtime.
Trace queue name
For CICS services. The trace queue name must be in upper case and have a length of eight characters or fewer.
Wait interval (seconds)
For CICS services, the number of seconds that the service driver program should wait if it doesn't hear from the Server Enterprise Edition/MSS runtime. The default is 30.

JavaBean/EJB

Application server
The application server name and J2EE version to support EJB deployment. This ensures that the appropriate deployment descriptors are generated and included in the relevant archive files (.ear.jar.war).
Archive name
File prefix name for java archive files created during deployment. The default is the service interface name.
Bean name
The name of the JavaBean. The default is the service interface name. It is also the root name given to the home and remote interface classes.
Classpath
The path to the J2EE implementation classes.
Compiler
Full path to and filename of the Java compiler. Optionally type compiler directives following the compiler specification. Directives specified here override default java compiler directives. Default value is the Java compiler and directives specified in the mfj.cfg file.
Descriptor name
The name of the EJB. This name is recorded in the deployment descriptor and is used to identify the EJB when it is deployed in the J2EE application server.
EJB type
The location of the EJB, local or remote.
Java interface type
The type of java interface, EJB or JavaBean.
Package name
The name of the package of Java classes. It is located in a subdirectory of the same name located under the project directory, which is created when the deployment process generates the EJB.
Server host
The name of the machine hosting the enterprise server that runs this service.
Server port
The port number used by ISC listeners configured for the enterprise server that runs this service.
Session type
The session type for the EJB.
Parent topic: Service Interface Projects
Related information
To debug a service interface
To deploy a service interface
Configuring an Enterprise Server for a CICS service


Properties - Workflow

(Name)
The name of the workflow, set when it was created.

General

Host code page
The code page for the host.
Host name
The full name or IP address of the machine where the host application resides.
Host port
The port used to access the host.
Host terminal type
The type of terminal used by the host.

Misc

Full Path
The full path to and filename of the workflow.
Parent topic: Service Interface Projects
Related information
To capture a workflow


Refresh Annotations

Programs / Maps
Shows items of the selected type.
Auto Select
Selects all changed items on the list.
Refresh
Updates annotations for the selected items.
Parent topic: Service Interface Projects
Related information
To refresh annotations


Service Interface

Name
The name of the service interface.
Select the type of interface
Select the type of service interface to create.
Select the type of source
Select the type of source files to be used by the service interface.
Parent topic: Service Interface Projects
Related information
To create a service interface


Username/Password

Username
The user ID to pass to the deployment server.
Password
The password to pass to the deployment server.
Parent topic: Service Interface Projects


Map Annotations Editor

Dialog boxes available from within the Map Annotations Editor.

  • Field Values
  • Group Fields
Parent topic: User Interface Reference


Field Values

Delete
Delete the selected values.
Add
Add a new value.
Value
A new value for the field.
Values List
List of all values currently assigned to the field.
Parent topic: Map Annotations Editor
Related information
To add or delete map field values


Group Fields

Number of fields in the group
The number of fields you want to include in each occurrence of the resulting array. This number must be less than the total number of fields you are grouping, and you must be able to divide the number of fields you have selected evenly by this number.
Group name prefix
A prefix to identify the group.
Parent topic: Map Annotations Editor
Related information
To group map fields


Service Interfaces Editor

Dialog boxes available from within the Service Interfaces Editor.

  • Apply Condition / Edit Conditions
  • Assignment
  • COBOL Assignment
  • Condition Editor
  • Field Properties
  • Group Properties
  • Mapping
  • Operation Properties - COBOL Program/CICS Commarea-based Services - General tab
  • Operation Properties - Screen-based Services - General tab
  • Operation Properties - Transaction tab
  • Operation Properties - User Exits tab
  • Operation Reorder
Parent topic: User Interface Reference


Apply Condition / Edit Conditions

Existing Condition
Select an existing condition to edit, apply, or upon which to base the creation of a new condition.
New Name
Name for a new condition.
Create
Create a new condition.
Edit
Edit an existing condition.
Parent topic: Service Interfaces Editor
Related information
To create and apply a conditional statement
To edit conditions
To apply an existing condition


Assignment

Assign to
Select a screen field, commarea field, work field or a special field for which to make an assignment.
Field 1/Operand 1
Value to assign to the field selected in the Assign to field or to be used by the function/operator. Select a field from the drop-down list or type a literal value into the field.
Function/Operator
Select a function/operator that uses the values in the Field/Operand fields, and whose result is assigned to the field selected in the Assign to field
Field 2/Operand 2
Value to be used by the function/operator. Select a field from the drop-down list or type a literal value into the field
Field 3/Operand 3
Value to be used by the function/operator. Select a field from the drop-down list or type a literal value into the field
Assignment Condition
Shows any condition placed on the assignment.
Parent topic: Service Interfaces Editor
Related information
To assign a value to a screen, commarea, or work field
To assign the result of an arithmetic function
To assign the summation of array elements
To assign the result of a concatenation
To assign an extracted string value


COBOL Assignment

Name
The name of the COBOL field to receive the assigned value.
Value
The value to assign to the selected COBOL field.
Parent topic: Service Interfaces Editor
Related information
To assign a value to a COBOL field


Condition Editor

Field Attribute (Optional)
Optionally select a field attribute to use in the condition.
Field
Select a field to include in your conditional statement.
Operator
Select an operator to include in your conditional statement that compares the field to the left with the field or literal value to the right.
Field or Literal value
Select a field or type a literal value as part of your conditional statement.
And
Create a compound condition. After clicking this, complete the Field, Operator and Field or Literal Value fields for the sub-condition.
Or
Create a compound condition. After clicking this, complete the Field, Operator and Field or Literal Value fields for the sub-condition.
Not
Specify the negation of the conditional statement.
Del
Delete the selected sub-condition from your conditional statement.
Parent topic: Service Interfaces Editor
Related information
To create and apply a conditional statement
To edit conditions
To apply an existing condition


Field Properties

Name

The name of the interface, reusable, or work field. If you created this field by drag-and-drop, then the default name is the same as the field you dragged.

Type
The field type. For non-work fields, types available on the list are restricted to those pertaining to the service type, i.e., Web service, Java, or .NET. If you created this field by drag-and-drop, the default type is that which most closely matches the type of the dragged field.
Input
This field is received in incoming messages.
Output
This field is sent in outgoing messages.
I/O
This field is both received in incoming messages and sent in outgoing messages.
Occurs
The number of occurrences of this field. If you created this field by drag-and-drop, the default is the number of occurrences of the dragged COBOL field.
Length
The length of the field.
Decimal Positions
The number of decimal positions for a numeric field.
Signed
Include a sign for a numeric field.
Parent topic: Service Interfaces Editor
Related information
To edit field properties


Group Properties

Name

The name of the group.

Occurs
The number of times this group occurs.
Input
The fields in this group receive incoming messages.
Output
The fields in this group send outgoing messages.
I/O
The fields in this group both receive incoming messages and send outgoing messages.
Parent topic: Service Interfaces Editor
Related information
To group interface, work, or reusable fields


Mapping

Interface Field
The interface field to map.
COBOL Field
The COBOL, screen, or commarea field to map.
Add
Creates a mapping between the interface field and the COBOL, screen, or commarea field.
Mapping
Shows the mapping(s) between the interface field and the COBOL, screen, or commarea fields.
Show Condition
Shows the condition placed on the mapping between the interface field and the COBOL, screen, or commarea fields, if any.
Parent topic: Service Interfaces Editor
Related information
To map an interface field


Operation Properties - COBOL Program/CICS Commarea-based Services - General tab

Name
The name of the operation.
Select Program
Lists the programs in the project. For commarea-based services, only CICS programs are shown.
Select entry point (parameters shown at right)
Lists the available entry points for the selected program, and lists the parameters for the selected entry point.
Select input commarea (parameters shown at right)
Lists the available commareas for the selected program, and lists the parameters for the selected commarea.
Select output commarea (parameters shown at right)
Lists the available commareas for the selected program, and lists the parameters for the selected commarea.
Create Default Mapping
Automatically map all entry point/commarea fields to interface fields. Available for new operations only.
Parent topic: Service Interfaces Editor
Related information
To create a COBOL program-based operation
To create a CICS commarea-based operation


Operation Properties - Screen-based Services - General tab

Operation Name
The name of the operation.
Active Screen
The screen on which this operation is based.
Previous Screen
In cases where your application encounters the same Active Screen more than once, and you want to interact with it differently, select the screen that precedes the Active Screen in the context of this operation. Otherwise leave the default ANY SCREEN.
Transaction ID
The transaction ID that starts the transaction associated with this operation, if this operation starts a transaction.
Create Default Mapping
Automatically map all screen fields to interface fields. Available for new operations only.
Parent topic: Service Interfaces Editor
Related information
To create a screen-based operation


Operation Properties - Transaction tab

Container Managed Attributes
Specify the EJB transaction attribute for a container-managed transaction. This attribute appears in the EJB deployment descriptor.
Parent topic: Service Interfaces Editor
Related information
To create a screen-based operation


Operation Properties - User Exits tab

Request group

External data value modification
Enable the user exit point for external data value modification - input parameter (exit point 1).
Internal data value modification
Enable the user exit point for internal data value modification - input parameter (exit point 2).
End request
Enable the user exit point for end of request processing (exit point 4).

Response group

Begin response
Enable the user exit point for start of response processing (exit point 5).
External data value modification
Enable the user exit point for external data value modification - output parameter (exit point 6).
Internal data value modification
Enable the user exit point for internal data value modification - output parameter (exit point 7).
End Response
Enable the user exit point for end of response processing (exit point 8).
Parent topic: Service Interfaces Editor
Related information
To create a COBOL program-based operation
To create a CICS commarea-based operation


Operation Reorder

Move up
Move the selected operation to an earlier position.
Move down
Move the selected operation to a later position.
Note: Commarea-based services execute operations in the order listed.
Parent topic: Service Interfaces Editor
Related information
To create a screen-based operation
To create a COBOL program-based operation
To create a CICS commarea-based operation


Service Interface Abend Codes

Abends relating to CICS memory issues

When Micro Focus bridge support modules (MER1* and MER0*) attempt to acquire blocks of CICS storage and CICS is unable to satisfy the request, the programs will execute a CICS ABEND ABCODE command. The reason specified for the abend is given as one of the following codes:
Code | Description
ADS1 | This abend is issued by bridge support module MER1BRIP or MER0BRIP if its starting CICS task has timed out or has failed. The most likely cause of this occurring is not enough SEPs (Service Execution Processes ) specified for the for the server.
LERR | The length value specified on a CICS GETMAIN command is invalid. Typically, this would be a negative or zero value.
NSTG | CICS is unable to allocate the storage requested by a CICS GETMAIN command.
Parent topic: Reference


SQL Option for DB2

Note: Throughout this documentation, the terms XDB, SQL Option, and SQL Option for DB2 are equivalent.
  • SQL Option User Guide
    This collection of topics provides conceptual information about the main components of the SQL Option for DB2 feature.
  • SQL Option Server Administration Guide
    This collection of topics provides conceptual information about the architecture, configuration, and use of the XDB Server.
  • SQL Option Link Configuration Guide
    This collection of topics provides the information you need to configure SQL Option (XDB) Link to link your applications.
  • SQL Option Preprocesor Guide
    This collection of topics provides information on using the SQL Option Preprocessor to develop applications containing embedded SQL and test them against a full-featured, relational database system.
  • How to...
    Step-by-step instructions on how to use the main components of the SQL Option for DB2 feature.
  • Reference
    Topics that provide reference information on the use of commands and directives, and descriptions of each error message you might encounter when using the SQL Option for DB2 feature. This reference also includes topics that describe the user interface for each SQL Option for DB2 component.
Parent topic: Mainframe Programming


SQL Option User Guide

  • Introducing SQL Option for DB2
  • Bind Utility
  • Declaration Generator
  • SQL Option Link Utility
  • JDBC
  • Migrate Utility
  • Options Utility
  • SQL Wizard
  • Stored Procedures
Parent topic: SQL Option for DB2


Introducing SQL Option for DB2

With SQL Option, you can compile, debug and run programs that contain Embedded SQL statements from the IDE without requiring access to a mainframe or LAN-based database system.

SQL Option uses the same technology as the popular XDB database system. An XDB database behaves exactly like a mainframe DB2 database but it runs on the PC. A personal XDB Server is installed on your PC, providing you with a completely self-contained development and test environment for DB2 applications.

SQL Option allows the EBCDIC environment on the PC to be fully compatible with your mainframe's EBCDIC environment. See the section SQL Option NLS Environment for details.

If you are developing in a workgrouping environment, your system administrator can configure SQL Option so that you can access one or more shared, LAN-based XDB Servers in addition to your personal XDB Server. This two-tier configuration provides you with several further options for testing your application. For example, you can:

  • Maintain a complete copy or a subset of your mainframe test data on a shared XDB Server. Members of your workgroup can test against this directly or import the necessary tables into their personal XDB Server in situations where data needs to be isolated from other users.
  • Duplicate test data on the shared XDB Server and workgroup members' personal XDB Servers. The shared XDB Server can then be used for integration testing, with workgroup members performing development and unit tests against their personal XDB Servers.
  • Distribute data across a shared XDB Server and personal XDB Servers. For example, larger, more static tables can be left on the shared XDB Server, with smaller, more volatile tables being exported to the PC.

In addition, with appropriate configuration, you can access mainframe DB2 databases seamlessly with SQL Option's connectivity features. With this third tier configured, you have access to the full range of development and test options, giving you complete freedom to devise an effective workflow customized to your environment. For example, you can:

  • Use the mainframe DB2 test environment for all testing
  • Use the mainframe for integration testing, with workgroup members performing development and unit tests against either their personal XDB Servers or a shared XDB Server
  • Distribute test data across all three tiers, keeping very large tables on the mainframe and providing others on a shared XDB Server. Workgroup members can then download specific data to their personal XDB Server where necessary for isolation purposes.
  • SQL Option Components
  • SQL Option NLS Environment
  • Using Existing XDB Data
  • SQL Option Demonstration Programs
  • Tips
Parent topic: SQL Option User Guide


SQL Option Components

SQL Option for DB2 consists of an embedded SQL precompiler and a number of configuration tools and graphical data utilities:

  • XDB Server
  • SQLWizard
  • Migrate utility
  • Options utility
  • Bind utility
  • XDB Link
  • Gateway Profile utility
  • Declaration Generator utility
  • SQL Option Preprocessor

To access the components of SQL Option for DB2, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2.

Parent topic: Introducing SQL Option for DB2


SQL Option NLS Environment

SQL Option allows you to create XDB locations that emulate all the various mainframe EBCDIC code pages. When you access these locations with SQL Wizard or a COBOL program, your data in these locations appears identical to the data on the mainframe.

The five steps necessary to ensure complete compatibility with the mainframe and/or your COBOL development system are as follows:

  1. Decide which EBCDIC code page you want to emulate.

    Typically, you would use the mainframe's code page. (If you do not know what it is, you may be able to use XDB Link to find out.) If you do not have a mainframe, you can choose whichever code page you prefer.

  2. Create a local EBCDIC location for this code page.

    Use SQL Wizard's Create Location dialog box. Pick the EBCDIC code page you want in the Sort Sequence box.

  3. Ensure that your project's national language support (NLS) setting is the same as your EBCDIC location.

    When you compile a COBOL program with Studio Enterprise Edition, it can be associated with a particular EBCDIC code page.

  4. If you have XDB Link, configure it to access the mainframe.

    Use the Gateway Profile utility to define your DB/2 locations to the PC software, then specify the single Workstation Code Page as 911 (in the local Workstation Configuration). Next, use SQL Wizard to access the DB/2 location on the mainframe. A file named cpg_info.txt is created in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bindirectory by default, identifying the EBCDIC code page of the DB/2 location on the mainframe. The following table defines this EBCDIC code page number:

    NLS Setting | Code Page Number
    31 Dutch | 37
    33 French | 297
    34 Spanish | 284
    39 Italian | 280
    43 Austrian German | 273
    44 English (UK) | 285
    45 Danish | 277
    46 Swedish | 278
    47 Norwegian | 277
    49 German | 273
    351 Portugese | 37
    358 Finnish | 278
    437 English (US) | 37
    500 International | 500
  5. Populate your local EBCDIC location with data from the mainframe.

    If you have XDB Link for the mainframe, there are two ways to do this: using Migrate or using SQL Wizard.

    • To use Migrate, all you need to do is point to the DB/2 location on your mainframe as the source location, and point to the local EBCDIC location as the destination location.
    • To use SQL Wizard, first export your mainframe's data in DSNTIAUL format, then import it into SQL Wizard. When you use the DSNTIAUL format, you need to specify a code page translation for both exports and imports: for exports, use the PC's ANSI code page to EBCDIC code page translation; for imports, use the reverse translation. For example, suppose you want to extract from a Swedish EBCDIC DB/2 location. For the export, you would pick the ANSI to EBCDIC translation 1252 - 278, for the import, 278 - 1252.

    If you don't have XDB Link for the mainframe, extract the data from the mainframe into a file with DSNTIAUL format, then import the data into your local EBCDIC location using SQL Wizard's import function, citing the appropriate EBCDIC to ANSI code page translation.

XDB EBCDIC databases are stored using the default OEM character set for your machine (typically, code page 437 in the United States, or code page 850 almost everywhere else). The names of database objects such as tables and indexes are also validated using this character set. You can optionally specify that database object-names should be validated using any of the following character sets if, for example, you want to use accented characters in the names:

MS-DOS Code Page | Character Set
437 | US Latin 1
850 | International Latin 1
857 | Turkish
863 | French Canada
865 | Nordic
860 | Portuguese

To specify that an XDB Server should use one of the supported code pages for name validation, you must add two lines to the xdb.ini file in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\mfsql\cfg:

[SERVER] XDBCP=codepage

where codepage is the three-digit number of the code page you require.

Where a location has been created as an EBCDIC location (for example, the default location, MAINTAIN), data is automatically converted to EBCDIC before it is passed to the client application. Conversion between ASCII data on the PC and EBCDIC data on the mainframe is handled by the DB2 Link gateway if you are using the Migrate utility. If you are using the data import and export facilities in SQL Wizard, you can control the conversion used by choosing the DSNTIAUL data format and selecting an appropriate code page conversion. See the topics Import/Export NSL Considerations for more information.

For information about EBCDIC conversions and the Data File Converter, see the topic Converting Data Files.

Parent topic: Introducing SQL Option for DB2


Using Existing XDB Data

If you already use XDB databases, you might be able to access them using SQL Option for DB2, providing that the locations in which they were created are compatible.

Parent topic: Introducing SQL Option for DB2


SQL Option Demonstration Programs

To help you get working with SQL Option as quickly as possible, we supply several demonstration programs located in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\Mainframe\sql\xdb folder. The following lists each demonstration program and summarizes the functionality demonstrated by each:

test1.cbl | OPEN, FETCH, CLOSE, DELETE, and EXECUTE IMMEDIATE statements
test2.cbl | Scrolling through records and entering Y or N at the prompt
test3.cbl | CREATE TABLE, ALTER TABLE, UPDATE, and CREATE INDEX statements
test4.cbl | Joining tables
test5.cbl | Using Dynamic SQL PREPARE and EXECUTE statements
test6.cbl | OPEN, FETCH, UPDATE, DELETE, and CLOSE statements
OO_Sample.app | Coding an OO application for use with the SQL Option
Parent topic: Introducing SQL Option for DB2


Tips

  • Use the Query Design window in SQL Wizard when you want to add new DML commands to your program but are not sure of the correct syntax. Create your query and run it until you are happy that results are correct. Then open the SQL window and copy the SQL statements into your program, between the EXEC SQL and the end-of-procedure statements.
  • If you are writing a program that needs to create a table and you have a test table with the correct structure, use SQL Wizard's Export capabilities to generate the DDL commands for your program.
  • If you create date columns in a test table using the WITH DEFAULT constraint, you can use the Date Warp feature of the IDE to change the system date on a row-by-row basis, without having to restart the XDB Server.
  • SQL Option automatically commits changes to a database when the end of a program procedure is reached with no errors. If an error occurs or if you stop debugging prior to reaching the end of a procedure, a rollback is performed instead. You do not need to use the LOGOFF directive when running a COBOL application.
Parent topic: Introducing SQL Option for DB2


Bind Utility

The Bind utility enables you to create static SQL packages in a remote DB2 location accessed using DRDA, providing that the target location is registered appropriately at the DB2 Link gateway and that your AuthID has Bind authority at the target location.

The Bind Utility generates a static package in DB2 from the contents of a local database request module (DBRM). A package is a single, bound DBRM containing optimized access paths to data. A DBRM contains all the information needed to create a package in a remote database.

Every application that runs against DB2 (including XDB Link) must have an application package to support the execution of statically-bound and dynamic SQL contained in the program. You must create a default package for XDB Link for each DB2 location with which you want to use the Link. See the Link Configuration Guide for more information.

Use the Bind Utility if you are configuring the XDB Link and you are ready to create a default DBRM and package for the Link, or you used the Static Bind Administrator to generate a DBRM and package for your application and you would like to modify or drop the package.

To access the Bind Utility, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 > Configuration > Bind Utility.

Note:

You do not need to bind your application if you use the default SQL precompiler settings, as these enable Embedded SQL statements in your programs to be run dynamically against the remote system. Running Embedded SQL dynamically is useful in situations where you want to access remote DB2 data but do not want to keep rebinding your application as it changes; for example, while debugging the application. You can optionally change the precompiler settings to produce static SQL database request modules to bind the application for deployment purposes. For more information on the precompiler options, see the topic XDB Directive Options.

A package at a location is identified by a collection identifier, a program identifier, a version label and a consistency token. Typically, you would use the collection identifier as a way of grouping the packages used in a single application consisting of one or more programs. The precompiler creates a program identifier for a package from the root of the program filename. You can specify a version label or accept the default value (01). You do not have to specify a version label, because the current package can be identified from its consistency token, generated from a timestamp at the start of precompilation. Note that each time you recompile a DB2 application, the timestamp changes and you must rebind the application to the DB2 host location if you are using static SQL packages. An alternative approach to avoid having to rebind your application each time you compile it is to debug against data stored in an EBCDIC location on your personal XDB Server. You can then test it against mainframe data when you have achieved a satisfactory level of stability.

The Bind utility enables you to specify a number of options for an application, including a version number and the isolation level of the application. These options can be stored in a file for future use.

Parent topic: SQL Option User Guide


Declaration Generator

The Declaration Generator automates the process of creating copybooks to declare host variables. You specify the table for which you want to generate a copybook and the Declaration Generator creates a copybook with data declarations that match the data names and types used in the XDB system. The Declaration Generator can be used interactively or in batch mode and can create a separate copybook for each table or one copybook containing declarations for many tables.

You can use the Declaration Generator to declare a table in C, COBOL or PL/I. For each language, the Declaration Generator creates a complete SQL DECLARE statement and the appropriate record definition (COBOL) or structure (C and PL/I). Depending upon the language, the following file types are created:

Language | Declaration File
COBOL | Copybook file (.cpy file)
C | Header file (.h file)
PL/I | Include file (.inc file)

You can run the Declaration Generator interactively (from a dialog box) or in batch mode (from the command line). Batch mode is useful for generating declarations for many tables at one time.

Regardless of whether you run the Declaration Generator interactively or in batch mode, you must specify the following:

  • The name of the table for which you want to generate a declaration file. Unless you specify otherwise, the name of the table is used as the name of the structure (C and PL/I) or record (COBOL).
  • The programming language in which you want the declaration written.
  • The name of the file to which the declaration statements will be written. The Declaration Generator automatically affixes the correct extension to the file name depending upon the programming language you select. If you specify a file that already exists, you can replace it or append the new statements to it.

You can specify language-dependent options. For example, when you create a COBOL declaration, you can select the computation type for whole-number fields; when you create a C declaration, you can select upper or lowercase element names.

To access DB2 data from an application program, you need to create host variables that are common data items between the SQL statements in your query and in your program. A data item declaration in the program must have the same name as that used in your SQL statement and must conform to the relevant DB2 data type for the column concerned.

To access the Declaration Generator, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 > Client > Declaration Generator.

  • Examples
Parent topic: SQL Option User Guide


Examples

  • Example COBOL Declaration
  • Example C Structure
  • Example PL/I Structure Declaration
  • Example Transaction Statement
Parent topic: Declaration Generator


Example COBOL Declaration

The following shows the result of a COBOL declaration. In this example, level 2 was assigned to the record definition.

01 DCLEMPLOYEE.
  2 E-NO PIC S9(4) COMP.
  2 LNAME PIC X(10).
  2 FNAME PIC X(10).
  2 STREET PIC X(20).
  2 CITY PIC X(15).
  2 ST PIC X(2).
  2 ZIP PIC X(5).
  2 DEPT PIC X(4).
  2 PAYRATE PIC S9(13)V9(2) COMP-3.
  2 COM PIC SV9(2) COMP-3.
Parent topic: Examples


Example C Structure

The following shows the result of a C declaration. In this example, the structure was declared without using the Declare The Structure option. Therefore, the structure describes a data type (called dcl_employee), but does not declare it as a variable. In this example, field prefixing has not been used.

struct dcl_employee
  {
  short e_no;
  char lname[11];
  char fname[11];
  char street[21];
  char city[16];
  char st[3];
  char zip[6];
  char dept[5];
  double payrate;
  double com;
  };
  short c_employee_ind[10];

Note that an array called c_employee_ind is also declared after the structure. This array is to be used to hold the null indicators for this table. (for example, c_employee_ind[0] can hold the indicator for e-no, c_employee_ind[1] the indicator for lname, c_employee_ind[2] the indicator for fname, and so forth).

Parent topic: Examples


Example PL/I Structure Declaration

The following shows the result of a PL/I declaration. This sample was generated using the Generate Indicator Variables option.

DECLARE
  1 DCLEMPLOYEE,
  5 E_NO BIN FIXED(15),
  5 LNAME CHAR(10),
  5 FNAME CHAR(10),
  5 STREET CHAR(20),
  5 CITY CHAR(15),
  5 ST CHAR(2),
  5 ZIP CHAR(5),
  5 DEPT CHAR(4),
  5 PAYRATE DEC FIXED(15, 2),
  5 COM DEC FIXED(2, 2);
  DCL IEMPLOYEE(10) BIN FIXED(15);

Notice that the array of indicator variables was generated for you.

Parent topic: Examples


Example Transaction Statement

The following example shows a simple transaction statement. In this example, the Declaration Generator reads the EMPLOYEE table and writes a declaration file called EMP_FILE.CPY. Because a language is not specified, COBOL is assumed.

employee emp_file.cpy

In a batch declaration file with multiple transactions, each transaction must be entered on a separate line, with no blank lines between them. The following example shows a .DGE file containing three transactions.

employee employee.cpy l=cobol s=dclempl p=sales u=real c=4 v=4
employee employee.h l=c s=c_employee p=sales u=real
orders orders.h l=c s=c_orders u=n/a a=upper d=decl

This example produces COBOL and C language output for the EMPLOYEE table. C output is also created for the ORDERS table.

Parent topic: Examples


SQL Option Link Utility

Host (mainframe) teleprocessing applications are usually designed for standard terminal environments that access large enterprise data stores. These applications do not usually have the power and graphics capabilities of PCs. While host applications are limited in this way, PC applications are also usually limited to processing local data in development or limited-production modes.

With XDB Link, you can combine both environments in a distributed application running on the PC or host and have access to both host and PC relational databases.

XDB Link consists of 32-bit software components based on IBM's Distributed Relational Database Architecture (DRDA), which specifies a standard way for different relational databases on different operating systems to communicate over a network. XDB Link runs on Windows NT, Windows 95, and Novell NetWare servers, with a copy of the XDB Server relational database management system and a copy of a communication subsystem, such as:

  • SNA Server (Windows NT)
  • SAA Server (Novell NetWare)

These communication subsystems provide APPC and TCP/IP protocol support.

XDB Link uses client/server architecture that allows networked PCs access to host data using IBM's DRDA.

PCs have access to host data through XDB Link AR (Application Requester). The Application Requester allows remote DBMS platforms to broadcast requests for RDBMS access across the Systems Network Architecture (SNA) network.

  • Link AR
  • XDB Link AR Architecture
  • XDB Link AR Security
  • XDB Link Installation and Configuration
  • Gateway Profile Utility
  • Host Option for TCP/IP
  • Code Mappings
  • Troubleshooting XDB Link Issues
Parent topic: SQL Option User Guide


Link AR

XDB Link AR allows your PC applications to quickly and easily access different types of host data, bringing the power of PC processing and graphical user interfaces to enterprise-wide data applications. XDB Link AR gives you access to host data for both development and production PC applications.

PC production application support is provided by remote static bind access from the PC to create static SQL packages on the host. Code page translation between PC and host platforms is provided in XDB Link.

When using the optional XDB Link host option for MVS in conjunction with XDB Link AR, additional SQL and non-SQL host data can be accessed through the use of remote procedures and the Customer Information Control System (CICS). XDB Host option also provides TCP/IP access from the PC.

Parent topic: SQL Option Link Utility


XDB Link AR Architecture

XDB Link AR consists of two main components: the Gateway on the PC and the optional host component on the mainframe. XDB Link AR also enables SQL applications in a PC LAN environment to access host-based relational databases without providing special application code for network traversal or data type conversion.

Parent topic: SQL Option Link Utility


XDB Link AR Security

Security for XDB Link AR is handled by the XDB Server and your existing mainframe security scheme. The user is required to provide user ID and password before accessing local or remote data.

If Global Security is turned on and the location includes the XDB Server, then the security scheme is controlled by the existing scheme on the host. Otherwise, when using XDB Server, you must set up user IDs and passwords that match the user IDs and passwords on the remote DBMS. For example, if you have a user ID of 'DAVIDH' for DB2, you should also create a user ID of 'DAVIDH' for XDB Server. This is easily accomplished with the User Administration function of SQLWizard.

If you are using the host option of XDB Link AR, you can set up additional security on the mainframe. The host programs can be secured by external security managers, such as RACF or Top Secret, and can be maintained from the PC through XDB Link AR using the PEM utility. This process is described in the Link Configuration Guide.

Parent topic: SQL Option Link Utility


XDB Link Installation and Configuration

XDB Link provides a very powerful and easy-to-use method for cooperative processing to access both PC and mainframe data. XDB Link can be used in a variety of ways, depending upon corporate requirements. Listed below are the basic steps to get your application up and running with XDB Link. For more detailed instructions, see the Link Configuration Guide.

To install the client, some sort of client application is required. The client application can be another Micro Focus product, or, it could be an application developed using a Micro Focus interface.

The XDB Server software must be installed, configured, and started. It is the mechanism for transferring information to and from the mainframe, as well as maintaining XDB Server databases. This step assumes that the SNA or TCP/IP communications utility for your operating system has been installed on the XDB Server machine (such as NetWare SAA server). The Gateway installation and configuration procedure is outlined in the Link Configuration Guide

In addition (if not using Global Security), you must use SQLWizard to create user IDs to match those used on the mainframe. See the SQLWizard documentation for specific procedures.

If the host option was purchased, it must be installed and configured. This option is necessary if you want TCP/IP access to DB2 or if you want to use TCP/IP. See the Link Configuration Guide for details on installing the host software.

The host option does not need to be installed for DRDA access to remote locations.

Before the XDB Server can access mainframe locations, you must provide certain information about these locations. This information is registered in the communication database. Use the Gateway Profile utility to register mainframe locations that you want to access.

Use the Bind utility to create default database request modules (DBRM) for each of your DRDA locations. Bind this DBRM on each remote DRDA location you want to access via XDB Link AR. The package created when the DBRM is bound is used by all applications when accessing DRDA data via XDB Link AR.

Embed SQL statements in COBOL, use a Micro Focus application programming interface, or build your ODBC application. Create a program that has remote procedure calls.

Run the program you have created or run an XDB Server database management utility.

Be sure to read the instructions for installing and configuring XDB Link AR before attempting to access remote data.

Parent topic: SQL Option Link Utility


Gateway Profile Utility

Before clients can access data from remote locations, you must use the Gateway Profile Utility to:

  • Define remote locations to the XDB Link so that client applications can access data in those locations
  • Configure the settings the XDB Link needs to translate data correctly and control client conversations

After the initial configuration, you can use the Gateway Profile Utility to modify existing settings or define additional remote locations.

The XDB Link may be installed:

  • On an XDB Server machine as part of a gateway configuration

    or

  • On an client machine as part of a direct-connect configuration

If you are configuring the Link on an XDB Server machine as part of a gateway configuration, see the topic Configuring XDB Link with the Gateway Profile Utility before you run the Gateway Profile Utility.

To display the main window of the Gateway Profile Utility, double-click the Gateway Profile Utility icon.

Parent topic: SQL Option Link Utility
Related information
Configuring XDB Link with the Gateway Profile Utility
Configuring the Link for a Gateway Server


Host Option for TCP/IP

With the XDB Link Host Option for TCP/IP (or Host Option for TCP/IP) installed, the XDB Link can use the TCP/IP protocol to access DB2 data on the host. The XDB Link becomes a TCP/IP multi-user, multi-threaded server that processes DRDA-compliant requests for access to DB2 over a TCP/IP network.

The Host Option for TCP/IP consists of:

  • Scheduler Subsystem
  • LU 6.2 Communications Subsystem
  • TCP/IP Communications Subsystem
  • Administrative Subsystem
  • Trace Facility
  • Scheduler Subsystem
  • LU 6.2 Communications Subsystem
  • TCP/IP Communications Subsystem
  • Administrative Subsystem
  • Trace Facility
  • Issuing Commands to the Host Option for TCP/IP
  • Access List Message
Parent topic: SQL Option Link Utility


Scheduler Subsystem

The scheduler subsystem is the main task of the Host Option for TCP/IP. It initializes subtasks and creates an environment based on system parameters in the parameter file. It also initializes the access list.

Parent topic: Host Option for TCP/IP


LU 6.2 Communications Subsystem

The LU 6.2 communications subsystem opens the Host Option for TCP/IP and initializes control blocks to interface with ACF/VTAM. When a client requests a connection to the remote DB2 location, it initializes a PLU of the DB2 LU 6.2 block and allocates a conversation with client-supplied information such as user ID, password and DB2 APPLID LU name.

This subsystem fills all necessary Function Management Header (FMH5) file information including LUWID. It transfers DDM flow to the remote DB2 location and receives messages from DB2. In case of an LU 6.2 communication error, the LU 6.2 communications subsystem formats an error packet and schedules a transmission request to the TCP/IP subtask.

Parent topic: Host Option for TCP/IP


TCP/IP Communications Subsystem

This task handles all TCP/IP traffic to and from clients. It accepts client connection requests and validates requester's IP addresses based on the access list. It creates multitasking subtasks to communicate with multiple clients.

How to...

Parent topic: Host Option for TCP/IP


Administrative Subsystem

The administrative subsystem manages the task and displays:

  • Conversation status.
  • PLU status.
  • Information about an XDB Link-started task through WTOR operator console commands.
Parent topic: Host Option for TCP/IP


Trace Facility

The trace facility cuts GTF trace records for diagnostic purposes and to establish audit trails. A system administrator assigns the GTF event ID in the started task parameter.

Parent topic: Host Option for TCP/IP


Issuing Commands to the Host Option for TCP/IP

There are several administrative commands that can be issued to control the Host Option for TCP/IP and to check its status. These commands are entered as replies to the following WTOR (Write To Operator with Reply) message prompt (which is displayed on the system console when you start the Host Option for TCP/IP):

@08 Enter XDBLINK Command

All Host Option for TCP/IP commands are issued in the following format:

R nn,command

where:

nn is the reply number message related to the Host Option for TCP/IP, and

command is the name of the Host Option for TCP/IP command.

Parent topic: Host Option for TCP/IP


Access List Message

When the Host Option for TCP/IP is installed, a list of client IP addresses to be permitted or rejected is created (the Link Configuration Guide describes how to create this list). If the Host Option for TCP/IP receives a request from a client that is not in this list, a WTOR message is issued to the system console.

The operator can issue a PERMIT to accept the connection or REJECT to reject the connection. Issuing a PERMIT temporarily grants access to the requesting client.

The following example shows a WTOR message followed by both possible operator responses:

@08 Enter XDBLINK Action Command for IP: 204.177.148.64
R 8,PERMIT
R 8,REJECT
Parent topic: Host Option for TCP/IP


Code Mappings

  • SQLCODE (DB2 Mode)
  • SQLCODE (XDB Mode)
  • SQLERRD
  • SQLSTATE Values
  • SQLSTATE Values (sorted by DB2 Code)
  • SQLSTATE Values (sorted by SQLSTATE Code)
Parent topic: SQL Option Link Utility


SQLCODE (DB2 Mode)

SQLCODE is an element of the SQLCA that stores a warning or return code from an SQL process. If you are running in DB2 mode, the value in SQLCODE is a DB2 warning or return code. To determine the appropriate error code, you must translate it into an XDB error message ID using the formula listed in the table below.

SQLCODE Value | Error Type | Formula | Msg File
-1 to -999 | Remote DBMS Error | Take absolute value and prefix with "L" | XDBMF.ERR
-1001 to -1650 | Database Engine Error | Take absolute value, subtract 1000, prefix with "X". | XDBRES.ERR
-1651 to -3000 | Network Error | Take absolute value, subtract 1650, prefix with "N". | XDBNET.ERR
-3001 to -29,999 | Not used. | -- | --
-30,000 to -30,100 | Distributed DBMS Communication Error | Take absolute value and prefix with "L". | XDBMF.ERR
Note:

Error messages -1 through -999 and -30,000 through -30,100 that come back through XDB Link are native to the remote DBMS being accessed.

Parent topic: Code Mappings


SQLCODE (XDB Mode)

The following table describes the SQLCODE values when you are running in XDB mode.

SQLCODE is an element of SQLCA that stores the error code returned by an SQL process. If you are running in XDB mode, the value in SQLCODE is expressed as XDB error code. To determine the appropriate error code, you must translate it into an XDB error message ID using the formula listed in the table below.

SQLCODE Value | Error Type | Formula | Msg File
-1 to -650 | Remote DBMS Error | Take absolute value and prefix with "L". | XDBMF.ERR
-651 to -2000 | Database Engine Error | Take absolute value, subtract 1000, prefix with "X" | XDBRES.ERR
-2001 to -3000 | Network Error | Take absolute value, subtract 1650, prefix with "N" | XDBNET.ERR
-3001 to -3999 | Not used. | -- | --
-4000 to -4,100 | Distributed DBMS Communication Error | Take absolute value and prefix with "L". | XDBMF.ERR
Parent topic: Code Mappings


SQLERRD

The SQLERRD(1) element in SQLCA contains the XDB error code returned by an SQL process. If you are running in DB2 mode, the DB2-equivalent of this error code is contained in SQLCODE (See the topic SQLCODE (DB2 Mode)).

To determine the appropriate error code, you must translate it into an XDB error message ID using the formula listed in the table below.

SQLERRD(1) Value | Error Type | Formula | Msg File
-1 to -650 | Database Engine Error | Take absolute value and prefix with "X". | XDBRES.ERR
-651 to -2000 | Network Error | Take absolute value, subtract 650, prefix with "N". | XDBNET.ERR
-2001 to -3000 | Not Used | -- | --
-3001 to -3999 | Remote DBMS Error | Take absolute value, subtract 3000, prefix with "L". | XDBMF.ERR
-4000 to -4,100 | Distributed DBMS Communication | Take absolute value, add -26,000, and prefix with "L". | XDBMF.ERR
Parent topic: Code Mappings


SQLSTATE Values

The following table describes the ANSI equivalents to XDB mode and DB2 error codes. The ANSI error value is stored in the SQLSTATE element of SQLCA.

XDB mode SQLCODE | DB2 SQLCODE | ANSI SQLSTATE
+100 | N/A | 02000
0 | N/A | 00000
-2 | -198 | 37517
-4 | -405 | 53020
-6 | -102 | 54002
-7 | -10 | 37503
-9 | -206 | 52003
-11 | -401 | 53018
-12 | -401 | 53018
-16 | -501 | 24501
-18 | -803 | 23505
-19 | -101 | 54001
-20 | -84 | 37512
-23 | -302 | 22001
-26 | -129 | 54004
-28 | -159 | 52004
-32 | -913 | 40502
-35 | -913 | 40502
-40 | -803 | 23505
-43 | -402 | 53019
-44 | -685 | 58002
-46 | -602 | 54008
-47 | -107 | 54003
-48 | -601 | 52010
-50 | -614 | N/A
-51 | -603 | 22515
-54 | -117 | 53002
-55 | -121 | 52001
-56 | -601 | 52010
-57 | -117 | 53002
-58 | -408 | 53021
-59 | -404 | 22001
-61 | -680 | 54011
-66 | -125 | 53005
-71 | -412 | 53023
-72 | -112 | 37507
-73 | -122 | 53003
-75 | -122 | 53003
-76 | -913 | 40502
-79 | -150 | 56013
-80 | -127 | 56005
-82 | -421 | 53026
-83 | -415 | 53025
-86 | -407 | 23502
-87 | -107 | 54003
-88 | -107 | 54003
-91 | -551 | 42501
-103 | -119 | 53003
-104 | -607 | 53032
-106 | -155 | N/A
-108 | -153 | 56008
-118 | -601 | 52010
-119 | -107 | 54003
-124 | -607 | 53032
-125 | -514 | 26501
-127 | -414 | 53024
-130 | -618 | 53032
-138 | -156 | 53009
-140 | -160 | 53013
-141 | -161 | 23501
-144 | -652 | 23501
-146 | -616 | 23503
-153 | -913 | 40502
-154 | -913 | 40502
-155 | -913 | 40502
-156 | -911 | 40000
-157 | -913 | 40502
-158 | -913 | 40502
-159 | -913 | 40502
-160 | -913 | 40502
-174 | -601 | 52010
-177 | -107 | 54003
-179 | -604 | 37511
-185 | -126 | 53029
-188 | -305 | 22002
-212 | -104 | 37501
-214 | -502 | 24502
-215 | -501 | 24501
-227 | -531 | 23504
-228 | -532 | 23504
-229 | -530 | 23503
-231 | -510 | 53028
-244 | -118 | 56002
-246 | -534 | 21502
-247 | -181 | 22007
-277 | -551 | 42501
-278 | -553 | 42503
-279 | -107 | 54003
-280 | -204 | 52004
-281 | -601 | 52010
-284 | -637 | 37514
-287 | -513 | 56024
-288 | -512 | 56023
-289 | -644 | 37515
-290 | -620 | 53001
-291 | -199 | 37501
-305 | N/A | 22002
-343 | -925 | 56201
-344 | -926 | 40502
-803 | N/A | 23505
-811 | N/A | 21000
Parent topic: Code Mappings


SQLSTATE Values (sorted by DB2 Code)

The following table describes the ANSI equivalents to an XDB mode error codes. The ANSI error value is stored in the SQLSTATE element of the SQLCA.

DB2 SQLCODE | XDB mode SQLCODE | ANSI SQLSTATE
N/A | -811 | 21000
N/A | -803 | 23505
N/A | +100 | 02000
N/A | 0 | 00000
N/A | -305 | 22002
-10 | -7 | 37503
-84 | -20 | 37512
-101 | -19 | 54001
-102 | -6 | 54002
-104 | -212 | 37501
-107 | -47 | 54003
-107 | -87 | 54003
-107 | -88 | 54003
-107 | -119 | 54003
-107 | -177 | 54003
-107 | -279 | 54003
-112 | -72 | 37507
-117 | -54 | 53002
-117 | -57 | 53002
-118 | -244 | 56002
-119 | -103 | 53003
-121 | -55 | 52001
-122 | -73 | 53003
-122 | -75 | 53003
-125 | -66 | 53005
-126 | -185 | 53029
-127 | -80 | 56005
-129 | -26 | 54004
-150 | -79 | 56013
-153 | -108 | 56008
-155 | -106 | N/A
-156 | -138 | 53009
-159 | -28 | 52004
-160 | -140 | 53013
-161 | -141 | 23501
-181 | -247 | 22007
-198 | -2 | 37517
-199 | -291 | 37501
-204 | -280 | 52004
-206 | -9 | 52003
-302 | -23 | 22001
-305 | -188 | 22002
-401 | -11 | 53018
-401 | -12 | 53018
-402 | -43 | 53019
-404 | -59 | 22001
-405 | -4 | 53020
-407 | -86 | 23502
-408 | -58 | 53021
-412 | -71 | 53023
-414 | -127 | 53024
-415 | -83 | 53025
-421 | -82 | 53026
-501 | -16 | 24501
-501 | -215 | 24501
-502 | -214 | 24502
-510 | -231 | 53028
-512 | -288 | 56023
-513 | -287 | 56024
-514 | -125 | 26501
-530 | -229 | 23503
-531 | -227 | 23504
-532 | -228 | 23504
-534 | -246 | 21502
-551 | -91 | 42501
-551 | -277 | 42501
-553 | -278 | 42503
-601 | -48 | 52010
-601 | -56 | 52010
-601 | -118 | 52010
-601 | -174 | 52010
-601 | -281 | 52010
-602 | -46 | 54008
-603 | -51 | 22515
-604 | -179 | 37511
-607 | -104 | 53032
-607 | -124 | 53032
-614 | -50 | N/A
-616 | -146 | 23503
-637 | -284 | 37514
-644 | -289 | 37515
-652 | -144 | 23501
-680 | -61 | 54011
-685 | -44 | 58002
-803 | -18 | 23505
-803 | -40 | 23505
-911 | -156 | 40000
-913 | -32 | 40502
-913 | -35 | 40502
-913 | -76 | 40502
-913 | -153 | 40502
-913 | -154 | 40502
-913 | -155 | 40502
-913 | -157 | 40502
-913 | -158 | 40502
-913 | -159 | 40502
-913 | -160 | 40502
-925 | -343 | 56201
-926 | -344 | 40502
Parent topic: Code Mappings


SQLSTATE Values (sorted by SQLSTATE Code)

The following table describes the ANSI equivalents to an XDB mode error codes. The ANSI error value is stored in the SQLSTATE element of the SQLCA.

ANSI SQLSTATE | XDB mode SQLCODE | DB2 SQLCODE
N/A | -50 | -614
N/A | -106 | -155
00000 | 0 | N/A
02000 | +100 | N/A
21000 | -811 | N/A
21502 | -246 | -534
22001 | -23 | -302
22001 | -59 | -404
22002 | -188 | -305
22002 | -305 | N/A
22007 | -247 | -181
22515 | -51 | -603
23501 | -141 | -161
23501 | -144 | -652
23502 | -86 | -407
23503 | -229 | -530
23503 | -146 | -616
23504 | -227 | -531
23504 | -228 | -532
23505 | -18 | -803
23505 | -40 | -803
23505 | -803 | N/A
24501 | -16 | -501
24501 | -215 | -501
24502 | -214 | -502
26501 | -125 | -514
37501 | -291 | -199
37501 | -212 | -104
37503 | -7 | -10
37507 | -72 | -112
37511 | -179 | -604
37512 | -20 | -84
37514 | -284 | -637
37515 | -289 | -644
37517 | -2 | -198
40000 | -156 | -911
40502 | -32 | -913
40502 | -35 | -913
40502 | -76 | -913
40502 | -153 | -913
40502 | -154 | -913
40502 | -155 | -913
40502 | -157 | -913
40502 | -158 | -913
40502 | -159 | -913
40502 | -160 | -913
40502 | -344 | -926
42501 | -277 | -551
42501 | -91 | -551
42503 | -278 | -553
52001 | -55 | -121
52003 | -9 | -206
52004 | -28 | -159
52004 | -280 | -204
52010 | -48 | -601
52010 | -56 | -601
52010 | -118 | -601
52010 | -174 | -601
52010 | -281 | -601
53001 | -290 | -620
53002 | -54 | -117
53002 | -57 | -117
53002 | -54 | -117
53002 | -57 | -117
53003 | -73 | -122
53003 | -75 | -122
53003 | -103 | -119
53005 | -66 | -125
53009 | -138 | -156
53013 | -140 | -160
53018 | -11 | -401
53018 | -12 | -401
53019 | -43 | -402
53020 | -4 | -405
53021 | -58 | -408
53023 | -71 | -412
53024 | -127 | -414
53025 | -83 | -415
53026 | -82 | -421
53028 | -231 | -510
53029 | -185 | -126
53032 | -104 | -607
53032 | -124 | -607
53032 | -130 | -618
54001 | -19 | -101
54002 | -6 | -102
54003 | -47 | -107
54003 | -87 | -107
54003 | -88 | -107
54003 | -119 | -107
54003 | -177 | -107
54003 | -279 | -107
54004 | -26 | -129
54008 | -46 | -602
54011 | -61 | -680
56002 | -244 | -118
56005 | -80 | -127
56008 | -108 | -153
56013 | -79 | -150
56023 | -288 | -512
56024 | -287 | -513
56201 | -343 | -925
58002 | -44 | -685
Parent topic: Code Mappings


Troubleshooting XDB Link Issues

The following table gives a list of common problems and possible solutions.

Problem | Solution
A DOS system error is returned on startup of IBM LAN Requester. | Your Communications Manager, LAN feature profile is using a station address that is identical to another workstation's address. Change the station address to be unique within the LAN.
When booting the Communications Manager, LU 6.2 sessions are not allowed on the SNA gateway for a downstream Gateway. Only the 3270 session allocates on the SDLC/Token Ring Gateway. | Ensure you are using the correct CFG for Communications Manager and that it allows APPC. Ensure the CFG pointed to in config.sys for Communications Manager allows APPC.
The LAN Requester abends when selected from the Communications Manager main menu.

NetBIOS support is missing from config.sys and the Communications Manager CFG. Correct your Communications Manager CFG, access the LAN feature profiles section and configure the IEEE802 option (you may choose not to use Univ Admin Addresses and opt to create your own). Now you may reboot your machine and try to access the LAN Requester. If this fails to work, you must re-install Communications Manager. Remove the existing manager and re-install using the CFG file already modified above.
Import is taking a long time to transfer records. DB2 is slow. Timeout errors are occurring. Import was started without a commit interval being specified. Since no interval was specified, DB2 is filling up its buffer pool with a single unit of work. Run Import using the command:
xdbimpor /cnnn

where nnn is the commit interval. Try 50 to start.
Parent topic: SQL Option Link Utility


JDBC

The Micro Focus Direct Flight JDBC driver provides JDBC support for XDB Server. See the chapter SQL Option for DB2 for more information on XDB Server.

You can use the Direct Flight driver to:

  • Establish a connection to an XDB Server
  • Send SQL statements to an XDB Server
  • Process results from an XDB Server
Note:

Before you can connect to an XDB Server you must load the Direct Flight driver. See the topic Loading the Direct Flight Driver for more information.

To use the Direct Flight driver you must have:

  • Java 2 Version 1.2 or higher installed
  • Access to an XDB Server
  • Loading the Direct Flight Driver
  • Connecting to an XDB Server
  • Calling COBOL Stored Procedures
  • Debugging COBOL Stored Procedures
Parent topic: SQL Option User Guide


Loading the Direct Flight Driver

You must load the Direct Flight driver before you can connect to an XDB Server. The simplest way to load the driver is to use the following code:

Class.forName ("mf.jdbc.DFDriver");

Where DFDriver is the name of the Micro Focus Direct Flight driver.

This creates an instance of the mf.jdbc.DFDriver class which represents the Direct Flight driver and registers the driver with your Java development environment Driver Manager.

The following code examples demonstrate two other methods for loading the driver:

In this example, the driver is loaded before calling the DriverManager.getConnection method:

Connection login(String sUser, String sPassword)
throws SQLException {

String sURL = “jdbc.mf://myhost”;
Driver driver = new mf.jdbc.DFDriver();

return DriverManager.getConnection(sURL, sUser, sPassword);

}

In this example, mf.jdbc.DFDriver is instantiated within the static code of the class that connects to the XDB Server:

Class MyClass {
      static {
              try {
                      Driver driver = new mf.jdbc.DFDriver();
              }
              catch  (Exception e)
              {
                      e.printStackTrace();
              }
      }
}
Parent topic: JDBC


Connecting to an XDB Server

Once you have loaded the Direct Flight driver, you can connect to an XDB Server. You do this by passing information to one of the three overloads for the DriverManager.getConnection method. See the section Overloads for the DriverManager.getConnection Method for more information. The following table shows you where different types of information can be passed to the overloads:

Information | Passed Where? | Required?
The name of an XDB Server (or a list of XDB Servers for fault tolerance) | Only in the URL | Required
An AuthID and password recognized by the XDB Server As explicit parameters for Overload 1 or as properties:
  • In the URL
  • In a Properties Object
Required
Additional property values (including a data profile)
  • In the URL
  • In a Properties Object
Optional

See the sections Direct Flight URL Syntax, Direct Flight Data Connection Properties and Defining a JDBC Data Profile for more information.

There is an order of precedence for property value definitions. The order is:

  1. A URL overrides all other definitions
  2. A Property Object overrides values defined in a data profile
  3. A data profile does not override any other definitions
Note:

If you have defined a data profile and set its canoverride property to "No," the property values defined in the data profile are not overridden by values in the URL or Properties Object. See the section Defining a JDBC Data Profile for more information.

  • Overloads for the DriverManager.getConnection Method
  • Direct Flight URL Syntax
  • Direct Flight Data Connection Properties
  • Defining a JDBC Data Profile
Parent topic: JDBC


Overloads for the DriverManager.getConnection Method

The DriverManager.getConnection method has three overloads. The URL syntax is the same for all three overloads. See the section Direct Flight URL Syntax for more information.

You connect to an XDB Server by calling one of these overloads in your Java applet or application. The overload you choose depends on the parameters that are supported by your Java development environment and on the data connection properties that you need to specify.

This section describes the three overloads for the DriverManager.getConnection method and their parameters.

  • Overload 1
    URL, AuthID and password.
  • Overload 2
    URL and Properties Object.
  • Overload 3
    URL only.
Parent topic: Connecting to an XDB Server
Related information
Direct Flight URL Syntax


Overload 1

Parameters:

URL | The XDB Server URL (String)
AuthID | The AuthID used to log on to the XDB Server (String)
Password | The password associated with the AuthID (String)
Connection Properties | Data connection properties defined in the URL itself or in a data profile

Comments:

Use Overload 1 if you:

  • Only have a few properties values to set
  • Have defined a data profile in which most of the values of the data connection properties are set
  • Do not want to define a Properties Object
  • Need to change from using the Direct Flight driver to other JDBC drivers in your code

Examples:

Parent topic: Overloads for the DriverManager.getConnection Method


Overload 2

Parameters:

URL | The XDB Server URL (String)
Connection Properties | The data connection properties defined in a single instance of a Properties Object

Comments:

Use Overload 2 if you have a Java development environment that supports Properties Objects and you have a number of properties that you want to set for each data connection.

In addition to specifying the property values in a Properties Object, you can:

  • Override property values in the URL itself
  • Use predefined property values by specifying the name of a data profile in your Properties Object

Example:

Parent topic: Overloads for the DriverManager.getConnection Method


Overload 3

Parameters:

URL The XDB Server URL (String)

Comments:

If you need to, you can specify the AuthID and password for logging on to the XDB Server, as well as any other data connection properties, in the URL itself.

You can also include the name of a data profile in the URL.

Parent topic: Overloads for the DriverManager.getConnection Method


Direct Flight URL Syntax

The Direct Flight URL syntax is the same for all three overloads for the method. The URL is used to call the DriverManager.getConnection method. Your URL must use the following syntax:

jdbc:mf://server-list[/profile][@location][?property-list]

Where the parameters are:

server-list A comma-separated list of XDB Gateway Servers with the following format:
host1[:port1][,host2[:port2],...hostn[:portn]]

Where the parameters are:

server-list A comma-separated list of XDB Gateway Servers with the following format:
host1[:port1][,host2[:port2],...hostn[:portn]]

Where the parameters are:

profile | The name of a data profile defined in the SYSXDB.SYSPROFILES table. The default is the data profile specified in the data profile default property, if one has been specified. See the section Defining a JDBC Data Profile for more information on data profiles.
location | The name of the XDB location to which the applet or application connects. The default is the location specified in the data profile location property, if one has been specified. See the section Defining a JDBC Data Profile for more information on data profiles.
property-list An ampersand-separated list of property value pairs with the following format:
prop1=val1[[&prop2=val2]&...propn=valn]

Where the parameters are:

See the section Direct Flight Data Connection Properties for more information on the properties that you can set.

hostx | The DNS name, host name, or IP address of an XDB Server.
portx | The port number of the XDB Server on that machine. The default port for an XDB Server is 8898.
propx | The name of a data connection property.
valx | A valid value for the data connection property.
profile | The name of a data profile defined in the SYSXDB.SYSPROFILES table. The default is the data profile specified in the data profile default property, if one has been specified. See the section Defining a JDBC Data Profile for more information on data profiles.
location | The name of the XDB location to which the applet or application connects. The default is the location specified in the data profile location property, if one has been specified. See the section Defining a JDBC Data Profile for more information on data profiles.
property-list An ampersand-separated list of property value pairs with the following format:
prop1=val1[[&prop2=val2]&...propn=valn]

Where the parameters are:

See the section Direct Flight Data Connection Properties for more information on the properties that you can set.

Note:

You can add the prefix mf. to any property name in the URL except user and password.

Parent topic: Connecting to an XDB Server
Related information
Defining a JDBC Data Profile
Direct Flight Data Connection Properties


Direct Flight Data Connection Properties

This section describes the data connection properties that you can set in your Java applet or application. You can specify data connection properties in the URL or in a Properties Object. See the section Connecting to an XDB Server for more information.

  • user
    Sets the AuthID that an applet or application will use to log on to the XDB Server.
  • password
    Sets the password for the AuthID specified in the user property.
  • profile
    Sets the name of the data profile an applet or application will use to retrieve the values of data connection properties defined in the SYSXDB.SYSPROFILES table.
  • profile.location
    Sets the name of the location on the XDB Server where an applet or application will first log on.
  • profile.canoverride
    Determines whether the properties associated with profile can be overridden in the URL or in a Properties Object.
  • profile.default
    Determines whether the entry represents the default profile.
  • maxrows
    Sets the maximum number of rows the Direct Flight driver will return in response to a query.
  • maxfieldsize
    Sets the size of the largest data field the Direct Flight driver will return in response to a query.
  • numthreads
    Sets the number of threads for which the Direct Flight driver will optimize the data connection.
  • timeout
    Sets the number of milliseconds an applet or application will wait for a response from the XDB Server before causing an exception.
  • cache.numrecs
    Sets the maximum number of records that the Direct Flight driver will prefetch for read-only queries.
  • cache.size
    Sets the maximum number of bytes that the Direct Flight driver will prefetch for read-only queries.
  • cache.fetch.numrecs
    Sets the maximum number of records that the Direct Flight driver will fetch in one batch when prefetching records for read-only queries.
  • cache.fetch.size
    Sets the maximum number of bytes that the Direct Flight driver will fetch in one batch when prefetching records for read-only queries.
Parent topic: Connecting to an XDB Server
Related information
Connecting to an XDB Server


user

Properties:

Where it can be set: | In the URL or in a Properties Object
Possible Values: | Any valid AuthID with access to the data referenced in an applet or application
Default: | None

Comments:

You must specify a value for this property

Parent topic: Direct Flight Data Connection Properties


password

Properties:

Where it can be set: | In the URL or in a Properties Object
Possible Values: | The current password for the AuthID specified in the user property. For AuthIDs that have no password, use an empty string as the value for this property.
Default: | None

Comments:

You must specify a value for this property

Parent topic: Direct Flight Data Connection Properties


profile

Properties:

Where it can be set: | In the URL or in a Properties Object
Possible Values: | Any data profile name with one or more property entries defined in the SYSXDB.SYSPROFILES table in the system location of an XDB Server
Default: | None

Comments:

This property is optional. You can connect to an XDB Server without defining any properties in a data profile.

Parent topic: Direct Flight Data Connection Properties


profile.location

Properties:

Where it can be set: | In the URL, in a Properties Object or in a data profile in the SYSXDB.SYSPROFILES table
Possible Values: | The name of any location on the XDB Server
Default: | SYSTEM

Comments:

Make sure that you specify the correct location as the value for this property. Note that the default location (SYSTEM) is not suitable for most applets and applications.

If you specify the value of this property in a data profile, do not prefix the property name with the name of the profile (profile).

Parent topic: Direct Flight Data Connection Properties


profile.canoverride

Properties:

Where it can be set: | Only in a data profile in the SYSXDB.SYSPROFILES table
Possible Values: | Yes or no
Default: | Yes

Comments:

You can prevent users setting data connection properties to inappropriate values when they enter the URL, by setting canoverride to "No". If you want to use the canoverride property for this purpose, make sure that all the profiles have canoverride set to "No." If even one profile has canoverride set to "Yes," users can specify that profile and set other data connection properties to any values they choose.

To create a single profile that cannot be overridden, set this property to "No" and make sure that the default property entry is also present.

Do not prefix the property name with the name of the profile (profile).

Parent topic: Direct Flight Data Connection Properties


profile.default

Properties:

Where it can be set: | Only in a data profile in the SYSXDB.SYSPROFILES table.
Possible Values: | Anything
Default: | The presence of this entry in the table makes its profile the default

Comments:

Make sure that only one data profile includes this property. Using multiple default profiles generates unpredictable results.

Do not prefix the property name with the name of the profile (profile).

Parent topic: Direct Flight Data Connection Properties


maxrows

Properties:

Where it can be set: | In the URL or in a Properties Object
Possible Values: | Integer (representing the number of rows) or 0 (all rows – no limit)
Default: | 0 (all rows – no limit)

Comments:

This property and its default value match the JDBC standard. You can reset this limit within the scope of a statement in your code. Each individual statement uses the initial limit specified by the value of this property.

Parent topic: Direct Flight Data Connection Properties


maxfieldsize

Properties:

Where it can be set: | In the URL or in a Properties Object
Possible Values: | Integer (representing the number of rows) or 0 (all rows – no limit)
Default: | 0 (all rows – no limit)

Comments:

This property and its default value match the JDBC standard. You can reset this limit within the scope of a statement in your code. Each individual statement uses the initial limit specified by the value of this property.

Parent topic: Direct Flight Data Connection Properties


numthreads

Properties:

Where it can be set: | In the URL or in a Properties Object
Possible Values: | Integer (representing the number of threads)
Default: | 4

Comments:

You should set this value to the number of threads you expect to access the XDB Server at the same time, for optimum performance.

If you set numthreads too high, your application will drain system resources. If you set numthreads too low, your application performance will drop.

Parent topic: Direct Flight Data Connection Properties


timeout

Properties:

Where it can be set: | In the URL or in a Properties Object
Possible Values: | Integer (representing the number of milliseconds) or -1 (disable timeout)
Default: | 5000

Comments:

This value represents the milliseconds between the time a packet is sent and the time a packet is received.

Parent topic: Direct Flight Data Connection Properties


cache.numrecs

Properties:

Where it can be set: | In the URL or in a Properties Object
Possible Values: | Integer (representing the number of records) or -1 (disable limit)
Default: | -1 (disabled)

Comments:

Do not disable both cache.numrecs and cache.size. At least one of these properties must specify a limit. When both limits are enabled, the Direct Flight driver uses the smaller limit.

Parent topic: Direct Flight Data Connection Properties


cache.size

Properties:

Where it can be set: | In the URL or in a Properties Object
Possible Values: | Integer (representing the number of bytes) or -1 (disable limit)
Default: | 131072(128K)

Comments:

Do not disable both cache.numrecs and cache.size. At least one of these properties must specify a limit. When both limits are enabled, the Direct Flight driver uses the smaller limit.

Parent topic: Direct Flight Data Connection Properties


cache.fetch.numrecs

Properties:

Where it can be set: | In the URL or in a Properties Object
Possible Values: | Integer (representing the number of records) or -1 (disable limit)
Default: | 100

Comments:

Do not disable both cache.fetch.numrecs and cache.fetch.size. At least one of these properties must specify a limit. When both limits are enabled, the Direct Flight driver uses the smaller limit.

Parent topic: Direct Flight Data Connection Properties


cache.fetch.size

Properties:

Where it can be set: | In the URL or in a Properties Object
Possible Values: | Integer (representing the number of bytes) or -1 (disable limit)
Default: | 8196

Comments:

Do not disable both cache.fetch.numrecs and cache.fetch.size. At least one of these properties must specify a limit. When both limits are enabled, the Direct Flight driver uses the smaller limit.

Parent topic: Direct Flight Data Connection Properties


Defining a JDBC Data Profile

A data profile is a set of property values defined in one location and referred to, as often as required, by a single profile name. Using property values from a data profile enables you to keep the URL short. This is convenient for development environments where you are required to retype the URL. If you are developing multiple applications, you can use data profiles to centralize your data configurations on one XDB Server and perform all of your maintenance in a single location.

Defining a data profile is optional. You can also set property values in the URL or in a Properties Object, depending on which overload for the DriverManager.getConnection method you use. See the section Overloads for the DriverManager.getConnection Method for more information.

You define a data profile by adding a set of entries to the SYSXDB.SYSPROFILES table in the SYSTEM location of your XDB Server. Each entry in the SYSXDB.SYSPROFILES table defines a profile property. The following data connection properties are available:

  • location
  • canoverride
  • default

You can use the SQL Wizard to alter the SYSXDB.SYSPROFILES table. For instructions on how to alter tables, see the topic Altering a Table in your SQL Wizard Online Reference. To define your data profile:

  1. Choose a name for the data profile. The maximum name length is 32 characters.

    Make sure that you enter the name consistently for each entry you add to the table. The profile name in the table must be the same as the one you specify in the URL when you call the getConnection method.

  2. Add an entry for the location property. Set its value to the name of the XDB Server location where your applet or application will first log on when it is executed.

    A minimal profile definition could consist of just a location entry. All other profile properties have default values.

  3. Add an entry for the canoverride property. Set its value to "No" if you do not want to be able to override the property associated with this profile.

    Ignore this property or set its value to "Yes" if you want to be able to override these values in the URL or in a Properties Object.

  4. Add an entry for the default property, if you want this data profile to be the default profile.

    You do not need to specify a value for the default property.

Note:

Do not add the prefix mf. to any of the properties defined in a data profile.

You can prevent a specific profile from being overridden by setting its canoverride property value to "No" and ensuring that the default property is also present. If you specify multiple profiles, make sure that all canoverride values are set to "No". For example:

Profile Name | Property name | Property Value
DEF | location | PASSTHRU
DEF | canoverrride | no
DEF | default | yes

If you add a second profile and leave its canoverride value set to "Yes" (the default), it will defeat the purpose of the first profile. In the following example, a user could specify the ALT profile and successfully override the data connection properties of the DEF profile in the URL:

Profile Name | Property name | Property Value
DEF | location | PASSTHRU
DEF | canoverrride | no
DEF | default | yes
ALT | location | ALTERNATE
ALT | canoverride | yes
Parent topic: Connecting to an XDB Server
Related information
Overloads for the DriverManager.getConnection Method


Calling COBOL Stored Procedures

Restriction: This topic applies to Windows environments (local development) only.

You can augment your Java code by calling stored procedures written in COBOL. You can execute stored procedures with the XDB Server running either in the blue screen character mode or as a service. For information on setting up stored procedures using XDB Server, see the section Stored Procedures in your SQL Reference.

The demonstration program mfExample3.java, located in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\mfsql\demo directory, demonstrates calling the COBOL stored procedure salraise.cbl. Consult the JDBCDEMO readme.txt file for detailed instructions on running the program.

Parent topic: JDBC


Debugging COBOL Stored Procedures

You can debug (step through the source code of) COBOL stored procedures from a Java application. You can only do this when the XDB Server is used in the blue screen character mode and not as a service.

To debug your COBOL stored procedure:

  1. Add two lines to the [SERVER] section of the xdb.ini file located in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.xmfsql\cfg directory:
    [SERVER]
StProcLoadLib=c:\projects\MyProj\DEBUG
StProcAnimate=yes

    Where MyProj is the name of your project directory.

  2. Start the XDB Server.
  3. Set the timeout data connection property to -1. If you do not set this property, your application will time out while the XDB Server is preparing the debugging environment. See the topic timeout for more information.
  4. Compile the COBOL stored procedure.
  5. Register the stored procedure with the XDB Server by executing a CREATE PROCEDURE command either in SQL Wizard or embedded in a program.
  6. Run the Java application that calls the stored procedure. When the call is made to the XDB Server, a new window appears containing the COBOL stored procedure source code.
  7. Step through the source code of the stored procedure.

    A new window appears for each stored procedure you invoke via Java.

Parent topic: JDBC


Migrate Utility

Migrate provides an easy, interactive way to copy one or more data tables between XDB Server locations or between an XDB Server location and a DB2 subsystem. You can use Migrate to quickly download a copy of a table from a mainframe for development and testing purposes. Or, you can use it to regularly copy up-to-date information from a production database on an XDB Server to a DB2 database on the mainframe.

Migrate simplifies the process of copying data from one location or database to another by eliminating intermediate file transfers and by eliminating the hand-editing of indexes and foreign keys. With Migrate, you can copy keys, indexes and tables in a single step. You can also quickly copy a subset of a table (certain columns or rows) by extracting data with a SELECT statement.

For complex migrations, you can use the Migrate utility's referential-integrity feature to detect data dependencies automatically and copy tables in the correct order. You can also produce a preliminary "impact analysis" report, which describes the effect of a migration before it is performed. If you copy certain tables regularly, you can save the specification in a .mig file. You can then run this file in batch mode, enabling you to perform a migration without respecifying it manually.

If your system administrator has configured the mainframe connectivity facilities of SQL Option, you can use the Migrate utility to import or export data between XDB locations, or between an XDB location and a DB2 subsystem.

  • Migration Paths Overview
  • To migrate between XDB Servers
  • To migrate between an XDB Server and a mainframe
  • Catalog Browser Overview
  • Schema Viewer Overview
  • Generating Reports
  • The Impact Analysis Report
  • The Post Execution Analysis Report
  • The Error File
Parent topic: SQL Option User Guide


Migration Paths Overview

Migrate lets you copy data between the following kinds of locations:

  • Mainframe to Mainframe
  • Mainframe to Server
  • Server to Mainframe
  • Server to Server
Parent topic: Migrate Utility


To migrate between XDB Servers

Migrate can copy data between any locations that are accessible to the server to which you are connected. To migrate tables between two XDB Servers, the server you log onto must have access to the other server via server-to-server communications. For information about establishing server-to-server connectivity, see your XDB Server Administration Guide.

Parent topic: Migrate Utility


To migrate between an XDB Server and a mainframe

To migrate tables between a mainframe and an XDB Server, XDB Link must be installed on at least one of the XDB Servers to which you have access. See the XDB Link documentation for information about setting up a mainframe location for remote access.

Parent topic: Migrate Utility


Catalog Browser Overview

The Catalog Browser graphically represents XDB Server database objects. In Migrate, you use the Catalog Browser to select the table(s) you want to copy, or to recall a query that you have created and saved with a data management tool such as SQLWizard.

The Catalog Browser shows you all of the locations that are known to the server to which you are connected (even locations that are on another server or on a mainframe). Database objects, such as locations, tables and indexes, are graphically represented in a hierarchical structure. Using the + and - buttons, you can expand and collapse the hierarchy to show just the elements you want to work with.

Note:

If you don't see the location that you want to migrate tables to or from, use Options to verify that you are connected to the correct server. If your server connection is correct, verify that the locations are listed in the server's SYSIBM.SYSLOCATIONS table. Your server must have access to both the source and target locations. See your XDB Server Administration Guide or consult your XDB Server Administrator for information about setting up server-to-server communications.

Parent topic: Migrate Utility


Schema Viewer Overview

The Schema Viewer displays the schemas of tables selected for migration. If related tables are contained in the viewer, they are connected with arrowed lines.

You can add tables to the Schema Viewer by dragging them from the Catalog Browser (see The Catalog Browser). To remove a table from the Schema Viewer, select the table in the Schema Viewer, then choose the Remove command from the Object menu.

Parent topic: Migrate Utility


Generating Reports

Migrate can create selected reports during a migration. Reports are written to files that you specify in the Run dialog box. You can display a report by selecting it from the View menu. Once a report is open, you can print it using the Print command on the File menu.

Parent topic: Migrate Utility


The Impact Analysis Report

The Impact Analysis Report describes the schemas of the selected source and destination tables, and lists the options you have selected. You can use this report to review your specifications before you run a migration.

To create an Impact Analysis Report, select the Impact Analysis Report option in the Migrate Options dialog box before you run the migration. Type the name of the file to which you want the report written in the text-entry field next to the checkbox. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new report.

Note:

When an Impact Analysis Report is selected, Migrate does not execute the migration. It simply describes what would happen if it were performed.

To view the report after it has been generated, select the Impact Analysis command on the View menu. Migrate automatically displays the last Impact Analysis file specified. To display a report other than the last one, specify the file with the Migrate command on the Options menu before you select the Impact Analysis command.

If you want to print the report once it is displayed, choose Print from the File menu.

The following is an example of an Impact Analysis Report.

                   IMPACT ANALYSIS REPORT

  Generated: 07/09/1996

                   Source               Destination
                   --------------       -------------
  Location:        SALES                SALES

    Table:
      Name:        CUSTOMERS            CUSTOMERS
      Authid:      DEV001               DEV001
      Database:
      Tablespace:

      Definition:
         Migrate:  Yes                  *
         Columns:  name(CHAR(20))       name(CHAR(20))
                   city(CHAR(20))       city(CHAR(20))
                   state(CHAR(2))       state(CHAR(2))

      Primary Key: CKEY                 CKEY
          Migrate: No
          Columns: NAME                 NAME

      Comments:
          Migrate: No
      Src Table Comment:
      Dst Table Comment:

      Synonyms:
          Migrate: No

      Privileges:
          Migrate: No
Parent topic: Migrate Utility


The Post Execution Analysis Report

The Post Execution Analysis Report provides a listing of the tables that were copied during a migration. It also reports the source and destination locations of those tables.

To create a Post Execution Analysis Report, select the Post Execution Report checkbox in the Run dialog box when you execute your migration. Type the name of the file to which you want the report written in the text-entry field next to the checkbox. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new report.

Note:

You can specify the same filename for the Post Execution Analysis and the Error File to combine both reports into a single file.

To view the report after a migration has been executed, open the file using the Post Execution Analysis command on the View menu. Migrate automatically displays the last Post Execution file specified. To display a report other than the last one, specify the file with the Migrate command on the Options menu before you select the Post Execution Analysis command.

If you want to print the report once it is displayed, choose Print from the File menu.

The following is an example of a Post Execution Analysis Report.

                   POST EXECUTION REPORT

  Generated: 07/09/1996

                   Source              Destination
                   --------------      -------------
  Location:        SALES               TEST

    Table:
      Name:        CUSTOMERS           CUSTOMERS
      Authid:      DEV001              DEV001
      Database:
      Tablespace:

  Table created at 13:00:39 on 7/9/1996
  156 records inserted
Parent topic: Migrate Utility


The Error File

The Error File reports the number and type of errors detected while migrating your tables. An error file is created each time you select it in the Run dialog box; however, it will contain errors only if errors were generated by a migration.

To request an error file, select the Error File checkbox in the Run dialog box when you execute your migration. Type the name of the file to which you want the report written in the text-entry field next to the checkbox. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new report.

Note:

You can specify the same filename for the Error File and the Post Execution Analysis to combine both reports into a single file.

To view the error file after a migration has been executed, open the file using the Error File command on the View menu. Migrate automatically displays the last Error File specified. To display a report other than the last one, specify the file with the Migrate command on the Options menu before you select the Error File command.

If you want to print the report once it is displayed, choose Print from the File menu.

Parent topic: Migrate Utility


Options Utility

Use the Options utility for configuring the SQL Option client-side software and its connectivity with XDB and DB2 database servers.

The settings that you can change fall into the following categories:

  • Connect

    For configuring the connection between a client application (for example, SQL Wizard or a program that you have developed) and the XDB or DB2 database that it uses.

  • Paths

    For specifying where SQL Wizard and other SQL Option files are to be found or written.

  • Format

    For specifying formats for dates, times and numeric fields.

  • Multi-user

    For specifying options for a multi-user XDB Server in a networked environment. For example, you can control isolation levels and autocommit.

  • Browser

    For specifying which database objects are shown in the Catalog Browser window.

  • Query

    For specifying default options for working with queries. For example, you can specify whether unqualified table-names can be used and whether Cartesian products are permitted. These options can be overridden for a particular query when you are editing the query.

  • Query run

    For specifying options for running queries with SQL Wizard. For example, you can control whether the result is displayed in table or form view and limit the number of rows returned.

  • SQL

    For specifying defaults for various SQL operational parameters, including compatibility and sort sequence. For example, you can set DB2 or SQL/DS compatibility and whether to use ASCII or EBCDIC sort sequences. You can also set the escape character and SysAuthID.

  • Security

    For specifying security options. You can switch on client security (required if you want to use an XDB Server that has security switched on), as well as controlling the enforcement criteria for user passwords.

The Options utility has a Summary page that enables you to obtain a list of all the current configuration settings. You cannot make changes to any of the options from the Summary tab but you can print it for reference purposes.

To access the Options utility, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 > Configuration > Client Options.

The Options window is made up of several pages, each labeled with a tab. To view or change information on a particular page, click its tab.

The options that you select are stored in the xdb.ini file.

To ensure backward compatibility, the settings are also written to the config.xdb file. These files are usually found in your configuration directory. For more information about xdb.ini, see xdb.ini File Structure.

Note:

If SQLWizard is running when you change your preferences using Options, you must exit from SQLWizard and restart it before the changes will take effect.

Along the left edge of the window is a set of general-purpose buttons. Depending upon which tab you are working in, some or all of these buttons will be available to you.

OK | This button accepts the current configuration and writes the settings to the xdb.ini and CONFIG.XDB files, and any other configuration files used by your system. Exits Options.
Cancel | This button discards the changes made during the current session and exits Options.
Browse | This button becomes active when your cursor is in a field requiring a path, filename or location. Clicking Browse provides a dialog box for you to select a name.
Edit | This button is displayed when the current tab offers editable fields such as formats for days or months.
Help | This button displays a help window containing information about the current tab.
  • Picture Definitions Overview
  • US ASCII Table
  • xdb.ini File Structure
Parent topic: SQL Option User Guide
Related information
xdb.ini File Structure


Picture Definitions Overview

The Options utility permits you to define input and display pictures to be used as the default masks for various types of columns.

Note that once a format has been defined for a data type or a variable, the system will not accept values that are not consistent with or are outside the range defined by the picture. For numeric fields, enter masks to handle the largest values you expect to enter and display.

  • Numeric Masks Overview
  • Numeric Picture Characters
  • Numeric Picture Examples
  • Date Pictures Overview
  • Date Picture Elements
  • Date Picture Examples
  • Time Pictures Overview
  • Time Picture Elements
  • Time Picture Examples
  • Character Strings Overview
  • Character Picture Examples
Parent topic: Options Utility


Numeric Masks Overview

All numeric masks (that is: smallint, int, float, decimal and money) are defined in the same way. The basic format for a numeric mask is:

mask [$='money'] [.='decimal'] [,='grouping']

where:

mask is a picture that defines the appearance of the variable when displayed on the screen or sent to the printer.

money is a money symbol (enclosed in single quotes) to be substituted for a dollar sign in numeric pictures. The money clause is optional. Money symbols can be up to five characters long. For example, to use the money symbol DM in place of a dollar sign, use:

$='DM'

decimal is a decimal point character (enclosed in single quotes) to be substituted for a period in numeric pictures. The decimal clause is optional. The grouping character and decimal point character cannot be the same. For example, to use a comma as the decimal point character, and a period as a grouping character, you would use:

.=',' ,='.'

grouping is a grouping character (enclosed in single quotes) to be substituted for a comma in numeric pictures. This clause is optional. The grouping character and decimal point character cannot be the same, as demonstrated in the example above.

Note that the optional money, decimal and grouping clauses are used only for numeric variables. If omitted, the default will be the money, decimal and grouping symbols specified through the Options utility. When defining decimal masks, keep in mind that precision refers to the total number of digits (before and after the decimal place) and scale is the number of digits to the right of the decimal point. For example decimal (10,4) allows six digits to the left of the decimal point, and four digits to the right of the decimal point.

To use a character that does not appear on your keyboard in your edit mask, use the facilities provided by your operating environment for entering extended characters. For example:

  • In DOS, hold down Alt key while entering the ASCII decimal code for the character on your numeric keypad. In US ASCII, the >= symbol is created by holding down Alt key while pressing 156. (For a list of decimal codes for US ASCII, see the US ASCII Table.)
  • In Windows, use the Character Map application from the Accessories window to select special characters.

Given the picture:

$$,$$$,$$9.99 $='>='

the value 23456.78 is displayed as >=23,456.78.

For additional information, see Numeric Picture Characters.

Parent topic: Picture Definitions Overview


Numeric Picture Characters

The following table describes the special characters that can be used when defining numeric pictures. Some numeric masks are illustrated in Numeric Picture Examples.

Picture | Result
+ | Indicates position of the minus or plus sign. Sign is placed as close to significant digits as possible. If z, 9, or $ appear after +, the sign will never be closer to the decimal place than the last + sign.
- | Same as + except signs are not displayed.
9 | Indicates a digit. Leading zeroes are displayed.
z | Indicates a digit. Leading zeros are replaced with blanks to allow alignment of decimal points and money symbols. (Lower case z only.)
. | Indicates the position of the decimal point. To use a different symbol for the decimal point (a comma, for example), use the period in the picture, but redefine the decimal point character by adding the .= decimal clause (for example: .=',').
, | Comma indicates relative position of grouping character. Grouping length is counted from the right, beginning with the first nonfractional digit. Only the grouping character closest to the decimal point is required. To use a different symbol for the grouping character (for example `.'), use the comma in the picture, but redefine the grouping character by adding the ,=grouping clause (for example: ,='.').
$ | Indicates the position of the money symbol. When several dollar signs appear together ($$,$$$.99 for example) the dollar sign will be shown next to the left-most digit (or decimal point) displayed. Using the example picture, the variable value 12.34 will therefore be displayed as $12.34. To use a different money symbol (>= for example), Use the dollar sign in the picture, but then redefine the money symbol by adding the $=money clause to the PICTURE command ($='>=' for example).
r | Indicates the number is to be rounded. If used, must appear at very end of the mask (zz,zz9.99+r for example).
Parent topic: Picture Definitions Overview


Numeric Picture Examples

The following table shows the effect of various numeric picture formats.

Picture | Input | Output
9999 | 123 | 0123
zzz.99 | 13.456 | 13.45
zz99 | 123 | 123
+999.99 | -13.4 | -013.40
++++.99 | -013.4 | -13.40
+zz99.9 | -13.456 | - 13.4
+++z9.9 | -130.456 | -130.4
zzz.9r | -13.456 | -13.5
+++.99r | 13.456 | 13.46
+999.99r | -13.456 | -013.46
$999.99 | 40 | $040.00
$$$$.99 | 40 | $40.00
$$$$.99+ | -40 | $40.00-
$$$$$,$$9.99 $='£' | 13.456 | £13.45
zzzzz,zz9 ,='.' | 12345 | 12.345
Parent topic: Picture Definitions Overview


Date Pictures Overview

A Date picture contains the components used to define date display pictures. You may order the Day, Month, Year and Weekday components any way you like (for example: dd/mm/yy, mm/dd/yy, yy/mm/dd). You can include characters to separate the components. Data must be entered according to the picture format, with a day and year component required.

The strings used for the mmm and mmmm month and www and wwww weekday pictures are defined on the Options utility's FORMAT tab. Separators can be any other characters, and will be displayed in the relative position they occupy in the mask. Commonly used separators are slash (/), hyphen (-), space ( ), and comma (,). In procedures, a date cannot consist of simply a month component.

For additional information, see Date Picture Elements.

Parent topic: Picture Definitions Overview


Date Picture Elements

The following table describes the elements that can be included in a Date Picture. Examples are shown in Date Picture Examples.

Clause | Picture | Result
Day | d | Integer between 1 and 31, corresponding to day of month. Does not display leading zeroes.
 | dd | Integer between 1 and 31, corresponding to day of month. Displays leading zeroes.
 | ddd | Integer between 1 and 365 (366 in a leap year), corresponding to number of days since first of the year. Does not display leading zeroes.
Month | m | Integer between 1 and 12, corresponding to a month. Note that this format does not display leading zeroes.
 | mm | Integer between 1 and 12, corresponding to a month. Displays leading zeroes.
 | mmm | A three character abbreviation for the month corresponding to stored month number (for example: JAN, FEB, MAR,...).
 | mmmm | Month corresponding to the stored month number (for example: January, February, March,...).
Year | yy | Displays last two digits of stored year.
 | yyyy | Displays the stored year.
Weekday | ww | An integer corresponding to the day of the week (Monday=1, Tuesday=2, etc.)
 | www | Three-character abbreviation for the day of the week (for example: MON, TUE, WED,...).
 | wwww | The day of the week a date falls on.
Parent topic: Picture Definitions Overview


Date Picture Examples

The following examples show various date pictures using the date August 31, 1995:

Date Picture | Displayed Date
m/d/yy | 8/31/95
mm/dd/yy | 08/31/95
mm/dd/yyyy | 08/31/1995
dd-mm-yy | 31-08-95
yyyy-mm-dd | 1995-08-31
mmm-dd-yyyy | AUG-31-1995
mmmm dd, yy | August 31, 1995
yyddd | 95242
dd | 31
wwww, mmmm dd | Monday, August 31
mmm 'yy | AUG '95
wwww | Monday
Parent topic: Picture Definitions Overview


Time Pictures Overview

A Time Picture contains the components used to define time pictures. You can use optional separators to separate the Hour, Minute and Second components.

Data must be entered according to the picture format, with an hour and minute component required. Midnight is 12:00:00 am for 12 hour clocks, and 24:00:00 for 24 hour clocks. One second after midnight is 12:00:01 am for 12 hour clocks, and 00:00:01 for 24 hour clocks.

Separators can be any other characters, and will be displayed in the relative position they occupy in the mask.

Commonly used separators are colon (:), hyphen (-), and period (.).

For 12 hour clocks, you can include the characters AM in your picture in the location you want AM or PM to appear. Use the case you want used in the display.

For a 24 hour clock, place the number 24 at the end of the picture. For a 12 hour clock, place the number 12 at the end of the picture. If you do not specify the clock type, a 24 hour clock is assumed, unless you have set the default time format to a 12 hour clock through the Options utility. Note that in procedures a time picture cannot consist of a minute component alone.

For additional information, see Time Picture Elements.

Parent topic: Picture Definitions Overview


Time Picture Elements

The following table describes elements of a Time picture. Examples are shown in Time Picture Examples.

Clause | Picture | Result
Hour | h | An integer between 0 and 24 (inclusive), corresponding to the hour of the day. Does not display leading zeroes
 | hh | An integer between 0 and 24 (inclusive), corresponding to the hour of the day. Displays leading zeroes.
Minute | m | An integer between 0 and 59 (inclusive), corresponding to a number of minutes. Does not display leading zeroes.
 | mm | An integer between 0 and 59 (inclusive), corresponding to a number of minutes. Displays leading zeroes.
Second | s | An integer between 0 and 59 (inclusive), corresponding to a number of seconds. Does not display leading zeroes.
 | ss | An integer between 0 and 59 (inclusive), corresponding to a number of seconds. Displays leading zeroes.
Parent topic: Picture Definitions Overview


Time Picture Examples

The following examples show some time format masks and the resulting output, using the time 15:08:25.

Clock Format | Time Picture | Displayed Time
12 hour clock | hh:mm:ss am 12 | 03:08:25 pm
 | hh.mm 12 | 03.08
 | AM h-m-s 12 | PM 3-8-25
24 hour clock | hh:mm:ss 24 | 15:08:25
 | hh.mm 24 | 15.08
 | h-m-s 24 | 15-8-25
Parent topic: Picture Definitions Overview


Character Strings Overview

Character pictures are defined using the special characters. Character Picture Examples, contains examples.

Picture | Result
x | Any character can be displayed or entered in this position. A positive integer n, in parentheses after the `x' indicates the string can be up to n characters long.
u | Alphabetic characters in this position are to be displayed in upper case. Adding a positive integer n, in parentheses after the `u' forces the next n characters to be displayed in upper case, and limits the length of the string to n characters.
l | Alphabetic characters in this position are to be displayed in lower case. Adding a positive integer n in parentheses after the `l' forces the next n characters to be displayed in lower case, and limits the length of the string to n characters.
9 | Indicates a digit from 0 to 9.
Parent topic: Picture Definitions Overview


Character Picture Examples

The following table contains examples of Character Pictures. All examples use the string "Example String 10" as input.

Picture | Displayed String
x(5) | Examp
x(16) | Example String 1
u(5) | EXAMP
u(17) | EXAMPLE STRING 10
l(5) | examp
l(17) | example string 10
u(2)x(15) | EXample string 10
u(2)x(13)99 | EXample string 10
Parent topic: Picture Definitions Overview


US ASCII Table

The following table shows the US ASCII character set and codes (in decimal).

Note that the first 32 ASCII codes usually are nonprintable; they have alternate meanings as special signal codes. The first 32 ASCII codes cannot be used for picture definitions.

ASCII | Char | ASCII | Char | ASCII | Char | ASCII | Char
0 | NUL | 32 | space | 64 | @ | 96 | `
1 | SOH | 33 | ! | 65 | A | 97 | a
2 | STX | 34 | " | 66 | B | 98 | b
3 | ETX | 35 | # | 67 | C | 99 | c
4 | EOT | 36 | $ | 68 | D | 100 | d
5 | ENQ | 37 | % | 69 | E | 101 | e
6 | ACK | 38 | & | 70 | F | 102 | f
7 | BEL | 39 | ' | 71 | G | 103 | g
8 | BS | 40 | ( | 72 | H | 104 | h
9 | HT | 41 | ) | 73 | I | 105 | i
10 | LF | 42 | * | 74 | J | 106 | j
11 | VT | 43 | + | 75 | K | 107 | k
12 | FF | 44 | , | 76 | L | 108 | l
13 | CR | 45 | - | 77 | M | 109 | m
14 | SO | 46 | . | 78 | N | 110 | n
15 | SI | 47 | / | 79 | O | 111 | o
16 | DLE | 48 | 0 | 80 | P | 112 | p
17 | DC1 | 49 | 1 | 81 | Q | 113 | q
18 | DC2 | 50 | 2 | 82 | R | 114 | r
19 | DC3 | 51 | 3 | 83 | S | 115 | s
20 | DC4 | 52 | 4 | 84 | T | 116 | t
21 | MAK | 53 | 5 | 85 | U | 117 | u
22 | SYN | 54 | 6 | 86 | V | 118 | v
23 | ETB | 55 | 7 | 87 | W | 119 | w
24 | CAN | 56 | 8 | 88 | X | 120 | x
25 | EM | 57 | 9 | 89 | Y | 121 | y
26 | SUB | 58 | : | 90 | Z | 122 | z
27 | ESC | 59 | ; | 91 | [ | 123 | {
28 | FS | 60 | < | 92 | \ | 124 | |
29 | GS | 61 | = | 93 | ] | 125 | }
30 | RS | 62 | > | 94 | ^ | 126 |
31 | US | 63 | ? | 95 | _ | 127 | 
Parent topic: Options Utility


xdb.ini File Structure

Sample xdb.ini File

Below is an example xdb.ini file. You will make most of the changes to this file through the Options utility. Do not change any of the sections that contain a warning not to change them. In most cases such changes will have no effect on the system. You must change such settings through the Options utility.

[CLIENT]
XDBCFG=C:\Program Files (x86)\Micro Focus\Studio Enterprise Edition 6.0\mfsql\cfg\
[SERVER]
XDBSERVE=XDBLOCAL
XSRVCFG=C:\Program Files (x86)\Micro Focus\Studio Enterprise Edition 6.0\mfsql\cfg
[ConnectionDefaults]
AutoConnect=On
Protocol=Win32Local,NetBIOS,TCP/IP
ProtocolMap=64,1,8
Servers=XDBLOCAL
DefaultServerName=XDBLOCAL
NodeName=cXDBCLIENT
[ClientFormats]
DateFormat=USA
DatePicture=mm/dd/yyyy
TimeFormat=USA
TimePicture=hh:mm:ss 24
MoneyPicture=-$$$$$$$$$,$$9.99
DecimalPicture=-zzzzzzzzz,zz9.99
WeekdayPicture=www
FloatDecimalPlaces=2
TimeZone=0
ShortMonthNames=Jan,Feb,Mar,Apr,May,Jun,Jul,Aug,Sep,Oct,Nov,Dec
LongMonthNames=January,February,March,April,May,June,July,August,September,October,November,December
ShortWeekNames=Mon,Tue,Wed,Thu,Fri,Sat,Sun
LongWeekNames=Monday,Tuesday,Wednesday,Thursday,Friday,Saturday,Sunday
[MultiUser]
IsolationLevel=Cursor Stability
TimeOutInterval=10
AutoCommit=On
BackwardLog=Off
ForwardLog=Off
[Preferences]
Confirm=NO
SortMode=EBCDIC
SortSequence=EBCDIC
AbortCharacter=<27>
EscapeCharacter=`
CompatibilityMode=DB2
[QueryRunOption]
MaxRecords=ALL
Execute=First Command
ResultView=Table
AllowEditing=Off
AutoCommit=On
NoLookForPrimaryKey=Off
[QueryDefinition]
QueryUsing=3PartName
ProhibitCartesian=On
ShowTablename=Off
AutoJoinForeignKey=On
AutoJoinPrimaryKey=Off
AutoJoinLikeName=Off
[Browser]
ConfigType=-560
AutoRefresh=Off
AutoStartup=On
[SysAuthID]
SysIBM=SYSIBM
SysXdb=SYSXDB
[Security]
ClientSecurity=Off
PasswordEnforceLevel=1
[ClientPaths]
Executables=C:\Program Files (x86)\Micro Focus\Studio Enterprise Edition 6.0\mfsql\bin\
Application=C:\Program Files (x86)\Micro Focus\Studio Enterprise Edition 6.0\mfsql\cfg\
System=SYSTEM
Temporary=C:\Program Files (x86)\Micro Focus\Studio Enterprise Edition 6.0\mfsql\cfg\tmp\
Overflow=C:\Program Files (x86)\Micro Focus\Studio Enterprise Edition 6.0\mfsql\cfg\tmp\
[Connection XDBLOCAL]
Protocol=Win32Local
PrimaryAuthorizationID=TUTORIAL
CurrentLocation=SYSTEM

File Structure

The xdb.ini file contains values used by Micro Focus client applications (such as SQLWizard). It specifies which Server you will use, what protocol will be used, and other default values. You set set these values using Options before you start your client program.

All of the changes you will make to xdb.ini should be made through the Options utility, accessible from the Options icon in the Micro Focus group window. There are comments in xdb.ini indicating those sections that should not or cannot be edited by hand. Some of these items are actually duplicates of values found in other configuration files, maintained in xdb.ini to ensure backward compatibility with older products. Others have too many choices to be edited easily.

However, there are some parameters that must be edited by hand. xdb.ini is a text file that can be edited with any standard text editor.

Note: If xdb.ini is locked or in use by some other program (such as a text editor), SQLWizard (or your own client application program) will not operate correctly. In this case, when you start SQLWizard (or the clinet application), you will get an error that xdb.ini cannot be found. If you try to run queries, you will get no records back. To avoid this problem, make certain that xdb.ini is not being held open by some other program.

Each of the sections described below corresponds to an SQLWizard-related section of xdb.ini. There may be other sections in your xdb.ini file. These are used by other products, and are described in the related documentation.

For items that provide a choice of settings, the default is shown in bold.

[ConnectionDefaults]

The Connection Defaults section stores information about what to use as the default connection, and also about what protocols are available.

Servers=server1, server2

The Servers item lists all servers that you can access. When a new server becomes available, the server name is added to this list. Each server should have a corresponding [Connection server-name] section.

NodeName=client-name

This is the name by which your machine is known to all XDB Servers you use. This name should be unique among all machines that are trying to access any XDB Server or XDB Link on your network.

DefaultServerName=server-name

This is the name of the XDB Server you want to use.

AutoConnect=On|Off

If on, the Connect dialog box is not displayed when you start SQLWizard (unless security is also on). If off, the Connect dialog box will be displayed so that you can specify a Server, AuthID and Location when connecting.

Protocol=protocol1, protocol2
ProtocolMap=n1,n2

If you are running SQLWizard against an XDB Server Version 4 (or newer), you may need to add several values (separated by commas) to the Protocol and ProtocolMap parameters in the [ConnectionDefaults] section of your xdb.ini file. The xdb.ini file segment shown below adds TCP/IP and IPX/SPX protocol support to SQLWizard:

[ConnectionDefaults]
Protocol=local,netbios,tcpip,spx
ProtocolMap=32,1,8,4

The table below shows allowable values for the Protocol and ProtocolMap parameters:

Protocol | ProtocolMap
netbios | 1
namedpipes | 2
spx | 4
tcpip | 8
appc | 16
local | 32
win32local | 64
[ClientPaths]

The paths in this section of xdb.ini correspond to the paths that you set on the Paths tab of the Options utility. For more complete descriptions of these options, see Paths Tab.

Executables=default-directory

Path to the directory where executables are stored.

Application=application-path\

Path to the directory where the system should write or look for application files such as SQL scripts and import/export batch files.

Temporary=temporary-path\

Path to the directory where SQLWizard writes temporary files, such as temporary query result files.

Overflow=alternate-temporary-path

Not currently used. An alternative directory where SQLWizard can write temporary files.

System=system-location

The name of the system location.

[ClientFormats]

This section of xdb.ini corresponds to the items that you set on the Formats tab of the Options utility. For more complete descriptions of these options, see Format Tab.

DateFormat=USA|EUR|ISO|JIS|LOCAL

Indicates the default date format to be used when displaying or entering dates.

DatePicture=dd.mm.yyyy

Indicates the date picture to be used if DateFormat is set to LOCAL. See Date Pictures Overview for a description of the date picture format.

TimeFormat=USA|EUR|ISO|JIS|LOCAL

Indicates the time format to be used when displaying or entering dates.

TimePicture=hh.mm.ss 24

Indicates the time picture to be used if TimeFormat is set to LOCAL. See Time Pictures Overview for a description of the time picture format.

MoneyPicture=-$$$$$$$$$,$$9.99

The money picture to be used when displaying or entering monetary amounts. See Numeric Masks Overview for a description of the money picture format.

DecimalPicture=-zzzzzzzzz,zz9.99

The decimal picture to be used when displaying or entering decimal numbers. See Numeric Masks Overview for a description of the decimal picture format.

WeekdayPicture=WWW

The format to be used when displaying or entering weekdays. See the Date Picture Elements for the weekday picture format.

FloatDecimalPlaces=2

Number of decimal places to be displayed for float fields.

TimeZone=0

The timezone offset from Greenwich Mean time. This is used for time math.

ShortMonthNames=Jan,Feb,Mar,Apr,May,Jun,Jul,Aug,Sep,Oct,Nov,Dec

The strings to be used for the MMM formatted month portion of the date format.

LongMonthNames=January,February,March,April,May,June,July,August,September,October,November,December

The strings to be used for the MMMM formatted month portion of the date format.

ShortWeekNames=Mon,Tue,Wed,Thu,Fri,Sat,Sun

The strings to be used for the WWW formatted weekday portion of the date format.

LongWeekNames=Monday,Tuesday,Wednesday,Thursday,Friday,Saturday,Sunday

The strings to be used for the WWWW formatted weekday portion of the date format.

[MultiUser]

This section of xdb.ini corresponds to the items that you set on the Multiuser tab of the Options utility. For more complete descriptions of these options, refer to the Multiuser Tab.

IsolationLevel=Lock Current

Indicates the isolation level to be used by default.

AutoCommit=On|Off

Indicates whether AUTOCOMMIT should by default be turned on or off.

TimeOutInterval=n

Indicates (in seconds) how long to wait before retrying when a lock conflict occurs.

BackwardLog=On|Off

Indicates whether the Backward Log is on or off. Not used when accessing an XDB Server Version 5.0 or higher.

ForwardLog=On|Off

Indicates whether the forward log (used for recovery) is on or off. Ignored by remote XDB Servers (Win3.x).

[Preferences]

This section of xdb.ini corresponds to the items that you set on the SQL tab of the Options utility. For more complete descriptions of all of these options, refer to the SQL Tab.

Other xdb.ini items that correspond to items on the SQL tab are described later in the description of the [SysAuthID] section.

CompatibilityMode=DB2|XDB|ANSI

The SQL compatibility mode to be used. This option indicates which set of SQL rules will be enforced.

EscapeCharacter=`

The character used to precede a special character to turn it into a literal.

AbortCharacter=<27>

The character used to halt some operations. For future use.

SortSequence=Case Insensitive ASCII (A=a,...)

Specifies the sort sequence that is to be used as the default for creating a location.

[QueryRunOption]

This section of xdb.ini corresponds to the items that you set on the Query Run tab of the Options utility. For more complete descriptions of these options, refer to the Query Run Tab.

MaxRecords=ALL|n

Indicates if all records should be retrieved or only the first n records when a query is run.

Execute=All Commands|First Command|Current
     Command

Indicates if only the first, the current, or all commands in the current query window should be executed. The ALL and FIRST options apply to the SQL Edit window and batch SQL scripts. The CURRENT option applies only to the SQL Edit window.

ResultView=Table|Form

Indicates whether the default Result view should be a RESULT TABLE or a RESULT FORM window.

AllowEditing=On|Off

Indicates whether the system should by default try to go into Edit Mode when displaying a query result. If off, you must switch to Edit Mode yourself.

NoLookForPrimaryKey=On|Off

Specifies whether, during an edit-mode query, SQLWizard automatically searches the SYSINDEX and SYSKEYS tables and adds unique key fields to the query, even if the user has not explicitly selected them. Such action allows SQLWizard to generate the appropriate WHERE clause should the user subsequently choose to update any of the extracted data.

On certain databases (such as large DB2 3.x locations without a shadow catalog), the search for unique key fields can result in extremely long query times.

If your database has been designed so that a unique key is always selected, this option can be turned on to eliminate the search for unique keys, thereby improving performance.

AutoCommit=On|Off

Indicates whether AUTOCOMMIT should be on or off.

[QueryDefinition]

This section of xdb.ini corresponds to the items that you set on the Query tab of the Options utility. For more complete descriptions of these options, refer to the Query Tab.

QueryUsing=3PartName|2PartName|1PartName

Indicates if table names should be qualified when they are inserted into queries or dragged to the SQL Edit window from the Catalog Browser.

ShowTablename=On|Off

Indicates whether the default for the Query Design window should be to show table names in the Query Conditions Grid. If on, table names are shown.

ProhibitCartesian=On|Off

Indicates whether the default for prohibiting Cartesian products should be on or off.

AutoJoinForeignKey=On|Off

Indicates if tables should be automatically joined on foreign key relationships.

AutoJoinPrimaryKey=On|Off

Indicates if tables should be automatically joined on primary keys and columns with like names in another table.

AutoJoinLikeName=On|Off

Indicates if tables should be automatically joined on like column names. Turn off with care!

[Browser]

This section of xdb.ini corresponds to the items that you set on the Browser tab of the Options utility. For more complete descriptions of these options, refer to the Browser Tab.

ConfigType=n

Modify this option only through Options.

AutoRefresh=Off|On

Not currently used. Always off

AutoStartup=On|Off

If on, the Catalog Browser is automatically loaded when SQLWizard is started (you may want to do this to make SQLWizard load faster). If off, you must access the Catalog Browser through the View menu.

[SysAuthID]

This section of xdb.ini corresponds to the items that you set in the SysAuthID section of the SQL tab of the Options utility. Other xdb.ini items that correspond to items on the SQL tab are described previously in the description of the [Preferences] section. If you receive errors when you try to connect to DB2, you should suspect that you do not have privileges on the system catalog tables or views with the AuthIDs currently set. For more complete descriptions of all of these options, refer to the SQL Tab.

SysIBM=SYSIBM

Specifies the AuthID to be used when issuing queries against system catalog tables owned by SYSIBM. Often you will only have privileges on a view on the system catalog tables. Usually the view is created using the same table name, but a different AuthID than the underlying table. When running against XDB Link to DB2, you will usually use SYSIBM=XDB instead of SYSIBM=SYSIBM.

SysXdb=SYSXDB

Specifies the AuthID to be used when issuing queries against system catalog tables owned by SYSXDB. Often you will only have privileges on a view on the system catalog tables. Usually the view is created using the same table name, but a different AuthID than the underlying table. When running against XDB Link to DB2, you will usually use SYSXDB=XDB instead of SYSXDB=SYSXDB.

[Security]

This section of xdb.ini corresponds to the Client Security items that you set on the Security tab of the Options utility. For a more complete description of this option, refer to the Security Tab. (Other items that may appear in this section are used to configure server security.)

ClientSecurity=On|Off

If on, you will have to provide a password to connect to the XDB Server. If off, you will not be asked for a password.

[Connection server-name]

There should be an instance of this section for every server listed in the Servers statement in the [Connection Defaults] section. The items specified here indicate how to make a connection to the named server. They are used in the Options Connect page.

Protocol=protocol

This is the protocol to be used when accessing the specified server. See the Connection Defaults section for a list of protocols.

PrimaryAuthorizationID=authid

This is the default user name that will be used when you connect to this server.

CurrentLocation=location-name

This is the name of the default location that will be provided when you connect to this server.

[Client]

This section contains client-side parameters.

XDBCFG=configuration-directory

This is the path of the configuration directory on the client.

ReceiveBufferSize=size

This is the size of the communications buffer on the client side. The default is approximately 60 Kb.

BulkFetch=0|1

If 1, the default, bulkfetch is on.

ANSICP=ANSI-code-page

The ANSI code page to use on the client-side.

OEMCP=OEM-code-page

The OEM code page to use on the client-side.

[Server]

This section contains server side parameters

XDBSERVE=server-name

This is the name of the default server.

XSRVCFG=configuration-directory

This is the path of the configuration directory on the server.

ReceiveBufferSize=size

This is the size of the communications buffer on the server side. The default is approximately 60 Kb.

[Trace]

This section specifies parameters that need to be set if you want to generate debugging information by turning on client/server traces.

RedirSndRcvTrace=redir-trace-path

This is the path of the client redirector rrace file, for example, c:\redir.trace.

RouterTrace=router-trace-path

This is the path of the router trace file, for example, c:\router.trace.

TraceType=type

This is usually set to 1, although Micro Focus Technical Support representatives might ask you to change this setting.

FileName=engine-trace-path

This is the path of the engine trace file, for example, c:\server.trace.

Flush=0|1

This determines whether or not the trace file is flushed to disk after each trace file entry. The default is 1, which causes the trace file to be flushed to disk after each entry.

ErrorLog=log-file-path

This is the path of the error log file, for example, c:\xmem.errors.

Parent topic: Options Utility


SQL Wizard

SQL Wizard is a graphical utility that makes it easy to create, maintain and query XDB and DB2 databases. You can use SQL Wizard to:

  • Manage system security and priorities
  • Manage locations, tables and queries
  • Create and run queries
  • Enter data directly into a table
  • Import and export data
  • Run batch scripts
  • Managing Locations, Tables and Queries
  • Create and Manage Database Objects
  • Explore Your Database
  • Add Data to Your Tables
  • Importing and Exporting Data
  • Get Answers to Your Questions
  • Examine Your Results, Change Your Mind
  • Transport Your Data
  • Perform Batch Processing
  • Manage Users, Passwords, and Priorities
  • Connect Dialog Box Overview
  • Introducing the Catalog Browser
  • Common Database Management Features
  • Queries
  • Query Results
  • Data Entry
  • Batch SQL Scripts Overview
  • Import
  • Import NLS Considerations
  • Using Batch Import
  • Export
  • Export NLS Considerations
  • Using Batch Export
  • User Administration
  • Security and Authority Overview
Parent topic: SQL Option User Guide


Managing Locations, Tables and Queries

SQL Wizard's Catalog Browser window provides an easy way to manage locations, tables and queries, including XDB Server system tables (providing your AuthID has suitable authority). You can open it by clicking any entry on the View menu of SQL Wizard or by clicking
*
on the toolbar. The Catalog Browser has three tabs: Locations, Table and Query.

If you are a superuser, you can use the Locations tab to manage locations. A superuser can create, alter and drop locations, as well as set the currently active location. Other users can only view a list of available locations.

The Table tab displays the hierarchy of locations, AuthIDs, tables and columns. From this page you can create, open, alter and drop tables, as well as view table definitions and indexes, primary keys, foreign keys, views, aliases and synonyms. Note that only a superuser can edit system tables.

The Query tab displays all stored queries accessible to the current server under the Location, AuthID and Query hierarchy. From this page you can create, open, run and delete queries.

Parent topic: SQL Wizard


Create and Manage Database Objects

Using SQLWizard, you can create a new location (including the system catalog tables) with a touch of a button. You can also create a new table complete with indexes, keys, and foreign keys.

Advanced option dialog boxes generate the appropriate SQL commands for creating DB2 tables, indexes, and other objects.

Parent topic: SQL Wizard


Explore Your Database

The Catalog Browser provides instant access to SQLWizard's database management facilities. You can expand and collapse the levels to find the object or definition for which you are looking. Double click a table name to open the table. Drag a query to the workspace to edit it, or use the Create, Alter, and Drop buttons to manage database objects.

Parent topic: SQL Wizard


Add Data to Your Tables

Once you have created a table, you can enter data in several ways.

You can use the Import facility to read data from other file formats into a table.

You can open a table and type data directly into the rows displayed in a Result window.

You can run a program containing embedded SQL to insert data into the table. The Micro Focus application development products are available to assist you in creating programs using COBOL and C.

Parent topic: SQL Wizard


Importing and Exporting Data

SQL Option can import and export data in a variety of formats. You can specify import and export settings by clicking New > Import or New > Export on the File menu of SQL Wizard. You can optionally save these settings in an .imp or .exp file that you can subsequently run as a batch file for routine data conversions.

Use SQL Option's import capabilities to run programs against test data prepared in another file format. For example, you could export suitable test data held in a Microsoft Access database, or a Microsoft Excel or Lotus 1-2-3 spreadsheet, to delimited or fixed-field ASCII files. You could then import these files into XDB Server.

You can import data into an XDB database from any of the following sources:

  • Free ASCII files (Delimited)

    Imports data from delimited (free-format) ASCII files.

  • Fixed-format ASCII files (Columnar)

    Imports data from columnar (fixed-format) ASCII files.

  • DSNTIAUL

    Imports data downloaded from IBM's DB2 using IBM's DSNTIAUL facilities.

Use SQL Option's export capabilities to transfer data from an XDB database to a mainframe DB2 database if you do not have gateway connectivity, or to create the DDL commands required to create a table.

You can export data from an XDB database into any of the following targets:

  • Free ASCII files (Delimited)

    Exports data to delimited (free-format) ASCII files.

  • Fixed width ASCII files (Columnar)

    Exports data to columnar (fixed-format) ASCII files.

  • DSNTIAUL

    Exports data to DSNTIAUL files. DSNTIAUL files can be read into DB2 systems.

  • SQL statements

    Generates DDL commands that can be used to re-create a table, insert data into it and create indexes on the table. COMMENT, WHERE and SYNONYM statements can be included.

Parent topic: SQL Wizard


Get Answers to Your Questions

Once your tables are created and populated with data, you are ready to write queries that answer questions about your data. SQLWizard's Query Design facility assists both new and experienced users in writing SQL statements by providing interactive windows, online help, syntax checking, and access to database object information.

If you prefer, you can type and edit SQL statements yourself using the SQL Edit window. A key feature is the ability to execute SQL statements that contain host variables directly from SQLWizard. With support for cut/copy/paste (using the clipboard), you can copy SQL code directly from your host programs, paste it into an SQL Edit window, and test the SQL without having to execute the host program. Likewise, you can use SQLWizard's Query Design facility to create your queries, switch to the SQL Edit window, and copy/paste the SQL statement to your COBOL program.

Parent topic: SQL Wizard


Examine Your Results, Change Your Mind

Even after you run a query, you can make changes to it. For example:

  • You can rearrange the column order.
  • You can hide columns if you decide you don't need them.
  • You can lock one or more columns in place, so that you can keep an eye on them as you scroll through the other columns.
  • You can sort the retrieved result on any combination of columns.

You get this flexibility without having to continuously rewrite and rerun your queries.

Query Result windows support bi-directional scrolling, and can be viewed and edited in either form or tabular views. You can send the results to a printer, or output them to a file.

Parent topic: SQL Wizard


Transport Your Data

Import and Export facilities are integrated into SQLWizard. Using Import you can read data from other file formats into a new or an existing XDB Server table. Supported import formats include delimited and tabular ASCII files, DSNTIAUL files, and others.

Export allows you to extract entire or partial sets of data from XDB Server tables and write them to external file formats. You can also export to SQL commands (which results in batch SQL files containing appropriate CREATE and INSERT statements). The Export facility can export a subset of columns, reorder the columns, and apply WHERE criteria to selection of data.

Both interactive and batch modes are provided for Import and Export facilities.

Parent topic: SQL Wizard


Perform Batch Processing

SQLWizard supports batch processing of SQL statements, including SQL that contains host variables. You can use SQL Wizard to run the following kinds of batch scripts:

  • Prompted queries
  • SQL scripts, including DDL and DML
  • Import files
  • Export files

To run a batch script, click Run Batch on the File menu in SQL Wizard.

Several other SQL Option utilities can create batch files; you can also run these from the appropriate utility. For example:

  • Use the Migrate utility to create and run .mig files
  • Use the Declaration Generator to create and run .dge files

SQLWizard also offers batch export and import facilities.

Parent topic: SQL Wizard


Manage Users, Passwords, and Priorities

You can perform user administration functions from the Admin menu. You can assign AuthIDs and passwords to users, and establish groups of users who will share the same privilege sets.

Parent topic: SQL Wizard


Connect Dialog Box Overview

Use the Connect dialog box to specify the parameters needed to establish a connection between SQLWizard and an XDB Server. The information appearing in this dialog box reflects the entries in the Options utility.

  • Suppressing the Connect Dialog with Autoconnect
  • Using Security
Parent topic: SQL Wizard


Suppressing the Connect Dialog with Autoconnect

If security is off, you can turn on Autoconnect in the Options utility to prevent the Connect dialog box from displaying. When the dialog box is not displayed, the defaults you specified for the Server, Location, and AuthID in Options are used to establish the connection.

Parent topic: Connect Dialog Box Overview


Using Security

If you are connecting to a multi-user XDB Server on a LAN, or if you are using XDB Link to access DB2 or another database system, your XDB Server Administrator will most likely require you to run with Security on, and you will have to enter a password. (If you are running against an XDB Server that is running with its security feature on, then you must turn SQLWizard's security on.)

To turn SQLWizard's security on, enable the Client Security option on the Security tab in the Options utility. This option causes the Connect dialog box to appear when SQLWizard is loaded, allowing you to enter a password.

Parent topic: Connect Dialog Box Overview


Introducing the Catalog Browser

The Catalog Browser provides access to locations, tables, indexes, and other objects stored in your XDB Server databases. Buttons at each level of object access allow you to create, alter, drop, and open database objects, as well as run queries. Opening a table is as simple as locating the table's name and dragging it to the SQLWizard workspace, or clicking the Open button; much simpler than having to type SELECT * FROM tablename in an SQL Edit window.

Parent topic: SQL Wizard


Common Database Management Features

The information in this chapter explains how to create, alter, and drop various database objects. Several features are common to many of the windows that you use to perform these functions. These include:

  • SQL button
  • Comments (Remarks) field
  • Options button
  • Managing Locations
  • Managing Tables
  • Managing Indexes
  • Managing Table Relationships
  • Managing Synonyms
  • Managing Aliases
  • Comments (Remarks) Field
  • Options Button
Parent topic: SQL Wizard


Managing Locations

A location is a collection of tables, databases, and related objects organized in a specific structure. An XDB Server can have multiple locations, all managed by the same database server. Depending on the options you have installed, SQLWizard can also access locations managed by other XDB Servers, as well as DB2 and other DRDA systems. Through the use of a three-part naming convention and related security measures, you can access more than one location at a time, including remote locations.

Connecting to a location provides you direct access to that location, without having to qualify table names with a location name. You set your initial (default) location in the Options utility. You can choose a different location each time you start SQLWizard by selecting a location on the Connect dialog box. After SQLWizard is running, you can change your current location using the Set Location command from the Location menu.

SQLWizard displays the current location and current SQLID in the status bar at the lower right of the SQLWizard window. Whenever you create, alter, or access a data object, this location and SQLID is used to qualify the table names.

You will also see a SYSTEM location listed in the Catalog Browser dialog box. This location contains system administration and security information. Do not store your data objects in this location. It is reserved for system use. Keep your data in locations that you or your XDB Server Administrator create.

Note: An XDB Server location roughly corresponds to a DB2 subsystem. However, you cannot use the XDB Server location windows to manage a DB2 subsystem. These windows are intended only for use with XDB Server locations.
Parent topic: Common Database Management Features


Managing Tables

As a relational database management system, SQLWizard stores data in a collection of tables. A table is a named data object made up of columns and rows of data. The data in one or more columns can usually be used to uniquely identify the rows of a table. These identifying columns are known as the primary key columns. Tables can be related to each other based on the data in one or more columns of the related tables. Indexes can be built on the table to speed retrieval and enforce uniqueness among records.

Often a table is identified with a three-part naming convention, where the table name is preceded by the Location and AuthID. The three parts of the name are separated by periods. For example, the table name SYSTEM.SYSIBM.SYSTABLES identifies the SYSTABLES table as being in the SYSTEM location and owned by the SYSIBM AuthID.

Parent topic: Common Database Management Features


Managing Indexes

An index is a data structure that speeds retrieval or enforces certain constraints, such as uniqueness, on the records in a table. This data structure is separate from the table and can be deleted and recreated without affecting table data. There are three types of indexes:

  • Index

    An index is an organized set of pointers to the rows of a database. Each index is based on the values of data in one or more columns.

  • Unique Index

    A unique index prevents the table from containing two or more rows with the same value in the index key.

  • Primary Key Index (for Referential Integrity)

    A primary key is a column or set of columns used to uniquely identify a row. Primary keys are required for referential integrity relationships. A table may contain at most one primary key.

    You can specify a primary key when you create a new table or when you alter an existing table. You can alter or drop a primary key. The method for creating, altering, and dropping a primary key is the same as for an index. The only difference is that the Type option must be set to Primary Key.

    You must define all columns involved in a primary key either as NOT NULL or NOT NULL WITH DEFAULT. When you define a primary key for a table, the Column Definition Grid on the Create/Alter Table dialog box is modified automatically. Any column that was defined with nulls allowed (False in the Not Null column) is changed to NOT NULL (True in the Not Null column). You can change the value in the Column Definition Grid to w/Default if you wish.

Parent topic: Common Database Management Features


Managing Table Relationships

You can use SQLWizard to relate the information in one table to that in another table. But, to be able to match records, the foreign key in the dependent table must have a column or collection of columns that match primary key columns in a referenced table.

For example, consider the EMPLOYEE and DEPT tables. Each employee must work in a department that exists. If every existing department must have a row in the DEPT table, then a foreign key built on the Dept column of the Employee table references the primary key of the DEPT table, which is the DEPT column.

If you try to assign an employee to a department that does not exist, you will get an error. If you try to delete a department that has employees working in it, you will get an error. Depending on how you define the foreign key, SQLWizard could automatically delete the employees for you.

If you change the Department ID for a department, SQLWizard may cascade these changes to the employees in that department, or display an error message depending on how you define the foreign key.

Figure 1. *
*

Referential integrity constraints ensure that data from one table that must match data in another table is not altered inadvertently. If you look at the Create Relationship dialog box you see three options that help you to enforce referential integrity between your tables. Restrict is the default.

Parent topic: Common Database Management Features


Managing Synonyms

A synonym is another name given to an existing table or view. Usually a synonym is used to define a more meaningful name for a particular application or for the use of a particular set of users. You can use a synonym to refer only to a table or view in the current location. Use an alias to provide an alternate name for an object that can be accessed by users from other locations.

Parent topic: Common Database Management Features


Managing Aliases

An alias is an alternate name for a table or view, similar to a synonym. When you assign an alias to a table, you specify in which locations users can use that alias. You can specify the current location as well as remote locations. This differs from a synonym, which provides an alternate name for a table only to users in the location where the table resides.

Parent topic: Common Database Management Features


Comments (Remarks) Field

Most database objects (locations, tables, indexes, etc.) may be described by entering comments in the system catalog. In SQLWizard, this is accomplished by entering the comment or description in the Comments field of the Create or Alter dialog box. Comments entered in this manner appear in the Catalog Browser dialog box when the Details option is checked.

Parent topic: Common Database Management Features


Options Button

The primary Create, Alter, and Drop dialog boxes provide access to dialog boxes that allow you to enter additional information. These options are used to describe the database object or to specify some of the less common attributes for the object. In many (but not all) cases, these additional items relate to compatibility with DB2 or other non-XDB Server databases with which SQLWizard may be used.

*
To access these additional items, click the Options button. Specify any options desired, then close the Table Options dialog box to return to the dialog box you were using.

Parent topic: Common Database Management Features


Queries

  • What is a Query
  • Why Use Queries
  • Creating and Running SQL Queries
  • How are Queries Written
  • Query Design Window Overview
  • Table Display Area
  • Entering Data Directly into a Table
  • Query Conditions Grid
  • SQL Edit Window Overview
  • Results That Cannot Be Edited
  • Query Options
  • Querying Multiple Tables
Parent topic: SQL Wizard


What is a Query

A query is a question about your data that allows you to retrieve specific information from your database. It is an instruction to the database system to search for a particular set of data that is of interest to you, and to present it in a useful format.

A query is written as an SQL SELECT statement, as in the following example of a fairly complex query that finds the number of customers in each city in New York or California that has at least one customer. The result is sorted by state and city.

SELECT   St, City, Count(C_no)
FROM     Customer
WHERE    St="CA"  OR  City="New York"
GROUP BY St, City
HAVING   count(*) > 0
ORDER BY St, City

The SELECT statement consists of several important clauses.

  • SELECT Clause

    Lists the columns to be retrieved from the table(s).

  • FROM Clause

    Lists the tables from which data is to be retrieved.

  • WHERE Clause

    Consists of a set of conditions that the rows of data must satisfy.

  • GROUP BY Clause

    Organizes data into subsets or groups based on the values in the grouped columns. It is frequently used to create summary rows containing totals, sums, counts, averages, minimum values, and maximum values.

  • HAVING Clause

    Defines conditions that summary rows of data must satisfy.

  • ORDER BY Clause

    Specifies the order in which the rows of data should be sorted.

Parent topic: Queries


Why Use Queries

These are some of the reasons for writing a query:

  • To view all of the data in a table.
  • To view a subset of the columns in a table.
  • To view a subset of the rows in a table.
  • To sort the rows of a table.
  • To view new columns based on data in existing columns.
  • To provide data to be used as the basis of a report, or for processing by some other program.
Parent topic: Queries


Creating and Running SQL Queries

You can create SQL queries either by entering SQL statements directly into an SQL window (click
*
on the SQL Wizard toolbar), or by using a prompted query in the Query Design window (click
*
on the toolbar). You do not need to understand SQL to create a prompted query. The Query Design window is split into two areas:

  • A schema view that shows the tables involved in your query and any relationships between them. This area of the window is called the table display area.
  • A query-by-example view, which shows the columns resulting from your query with any filters that you have applied to them. This area of the window is called the query conditions grid.

When you create a prompted query, you first select the table and columns. Then you apply conditions and sort criteria to the columns to achieve the final result set. Further choices are available from the menus, including joins, the creation of computed columns and the use of built-in functions such as minimum, maximum and average.

As you create a prompted query, the equivalent SQL statements are built up by SQL Wizard. To see them, click
*
. You can edit the SQL statements directly but the changes you make do not appear in the Query Design window. To go back to the Query Design window, click
*
. It's a good idea to save your prompted query before you try editing it in the SQL window. You can run your query and see the results at any time by clicking
*
.

Parent topic: Queries


How are Queries Written

Queries to XDB Server and other supported database systems are always written in the form of an SQL SELECT statement. When you use SQLWizard to create a query, you can type the SELECT command yourself in an SQL Edit window, or you can use a Query Design window to assist you in generating the statement.

SQLWizard's Query Design facility assists both new and experienced users in writing SQL statements by providing interactive screens, online help, syntax checking, and access to database object information.

Because of the advantages of the prompted method of writing queries, we will focus primarily on this method. However, the section on the SQL Edit window will provide you with the information you need to know if you would rather type queries yourself. In addition, some SQL statements, including some variations of the SELECT statement, cannot be created or executed from the Query Design window. You will need to use the SQL Edit window to create and run these statements. Often you can use a Query Design window to help you write significant portions of these types of SQL statements.

Parent topic: Queries


Query Design Window Overview

As you use SQLWizard's prompted query facility to generate an SQL statement, you will become familiar with the Query Design window. You can have more than one copy of the Query Design window open at any given time. If a Query Design window is the active window, it will come to the front of other document windows and be known as the current query or active window.

The Query Design window consists of two sections:

  • The Table Display Area.
  • The Query Conditions Grid.

These sections are separated by a splitter bar. By positioning your mouse over the splitter bar and holding down the right mouse button, you can drag the splitter bar up or down to resize the two sections.

Parent topic: Queries


Table Display Area

The upper section of the Query Design window is known as the Table Display Area. The tables you select are added to the Table Display Area and are shown in Column Selection Lists. It is in this way that you can choose specific columns in a table for your query while in Query Design mode. The name of each table selected appears in the title bar of each Column Selection List. If there is a join relationship between two tables, you will see a line connecting the tables.

Parent topic: Queries


Entering Data Directly into a Table

SQL Wizard provides both a spreadsheet-like table view and a form view that enable you to enter and edit data directly. Use the table view to see many records at once and the form view to see one record at a time.

You must have appropriate access privileges to edit tables. Only a superuser can edit system tables. Ordinary users can edit tables created using either their own AuthID or a GroupID to which they belong. They can also edit tables to which they have specifically been given access using the GRANT statement. In all cases, you must select Allow Editing on the Record menu before editing is enabled.

You can open or create a table at any time from the Catalog Browser. See the topic Managing Locations, Tables and Queries for more information. The Table view opens automatically to show the result of a query.

Parent topic: Queries


Query Conditions Grid

The lower section of the Query Design window is known as the Query Conditions Grid. This is the area where you can Query-by-Example (QBE). Each column in your query appears as a column in the Query Conditions Grid. The rows of the grid allow you to type in conditions that the data in the columns must meet, as well as sort conditions, and other instructions for performing your query.

Parent topic: Queries


SQL Edit Window Overview

While there are many advantages to using the prompted query facility to generate your SELECT statements, there will be many times that you will need to type in SQL statements, or paste SQL statements from the clipboard. Using the SQL Edit window, you can write and execute any type of SQL statement.

You can also include multiple SQL statements in an SQL Edit window and execute each in turn, or skip through them one at a time, or run just the currently selected command.

Although many of the menu items and toolbar buttons used by the Query Design window are disabled in the SQL Edit window, you will run and save queries in the same way, regardless of which window you use.

Parent topic: Queries


Results That Cannot Be Edited

SQLWizard allows you to use the Result window to insert, update, and delete records after you run a query. However, some query results cannot be updated. For example, the query result for a query that includes a join, an ORDER BY clause, a GROUP BY clause, computed columns, or UNIONS is not updatable.

If you use the Query Design window to create a query that cannot be updated, the Allow Editing command on the Query menu is disabled before you run the query. In addition, the Allow Editing command on the Record menu in the Result window is disabled after you run the query.

Parent topic: Queries


Query Options

Query options are divided into two types: Query Design options, and Query Run options.

Query Design Options

These options control how your Query Design window appears, and how SQL is generated.

Define Query
3-Part Names | If checked, uses fully qualified table names in queries. If you get X28 errors, you should try checking this box.
2-Part Names | If checked, qualifies names with AuthID.
Unqualified Names | If checked, does not qualify names.
Show Table Names
If checked, adds a row to the Query Conditions Grid to show the name of the table from which a column comes.
Note:

*
Click the Show Table Names button to display the name of the table from which a column comes.

Auto Join Defaults
These options indicate the rules the system should use when automatically defining join conditions.
Join on Foreign Keys | If checked, automatically joins all columns involved in a foreign key relationship when the referenced and referencing tables appear in the Table Display Area of the Query Design window. This method of auto joining produces good results, since foreign keys are built on columns that are meant to be joinable.
Join on Primary Key With Like Names | If checked, automatically joins a primary key column with a column (or collection of columns) having the same name(s) in another table, provided both tables appear in the Table Display Area of the Query Design window. This method can result in some unintended joins if the primary key column name is a common name like CITY.
Join on Like Names | If checked, automatically joins a column with another column of the same name in another table, provided both tables appear in the Table Display Area of the Query Design window. This option should be used with care. It is frequently the case that columns that should not be joined have the same name as another column in a different table. If you use this option, you should carefully check each join that is generated automatically to make certain it is meaningful.
Prohibit Cartesian Products
If checked, looks for any queries that are executed from within this program to determine if they will yield Cartesian products.

Query Run Options

These options take effect when a query executes.

Execute
Only one of these options can be enabled at a time.
All Commands | If enabled, executes every command in the current SQL Edit window or .SQL script. If Step Mode is on, you have to use the Query menu Continue command to execute each step.
First Command | If enabled, executes only the first command in the SQL Edit window or .SQL script.
Current Command | If enabled, executes the command at the current cursor location if bounded by semicolons.
Default Result View
These options indicate if you want the default view for a result window to be a Result Table view (like a spreadsheet, showing multiple records at one time), or a Result Form view (shows one record at a time, with the fields arranged vertically). This option defines the default. You can switch to the other view at any time before or after a query is executed.
Edit Options
Allow Editing | If a query result can be edited, signals the system to go directly to edit mode. If a result cannot be edited, it has no effect and the Allow Editing option is grayed out.
AutoCommit | If a query result can be edited, indicates that the system should perform an automatic commit each time a record is updated, deleted, or inserted.
Max Records to Retrieve
You can limit run away queries by checking the First n Recordoption, and providing a reasonable value for n. Otherwise, every row has the potential of being retrieved. Note that SQLWizard tries to be intelligent when retrieving results. If you do not try to look at or otherwise access all of the rows in a result, it does not fetch all of them. However, if you perform a count, or if you print the result, or scroll to the bottom of the result, all rows will be retrieved, which could take some time depending on the query.
Parent topic: Queries


Querying Multiple Tables

Good database design usually results in a database with multiple tables related to each other by the values in certain columns. Even though the data is stored in separate tables, you will often want to see it in a single result. When you combine the data from two or more tables into a single result, you create a join.

Parent topic: Queries


Query Results

  • Introducing the Result Window
  • Result Window Views Overview
  • The Result Table View
  • The Result Form View
  • Current Record and Total Record Counts
Parent topic: SQL Wizard


Introducing the Result Window

The Result window displays when you successfully run a query or when you open a table using the Catalog Browser dialog box. Specifically, the Result window appears when you:

  • Run a query from the Query Design window using the Run command from the Query menu, or the Run button on the toolbar.
  • Run a query from the SQL Edit window using the Run command from the Query menu, or the Run button on the toolbar.
  • Execute a batch SQL script (.SQL file) Open or Run Batch commands from the File menu.
  • Open a table using the Catalog Browser dialog box.
Parent topic: Query Results


Result Window Views Overview

The Result window has two views: the Result Table view and the Result Form view. You can switch between these views by clicking the Result Table and Result Form buttons on the toolbar, or by using the Result Table and Result Form commands on the View menu.

Parent topic: Query Results


The Result Table View

The Result Table view displays the result of your query in a tabular grid-like format that shows multiple records at a time like a spreadsheet. Each row in the Result window corresponds to a row (or record) from the table. You may have to scroll horizontally to see all columns in the result, and scroll vertically to see all the rows in the result.

Note:

*
Click the Result Table button on the toolbar to place the Result window in Result Table view.

Parent topic: Query Results


The Result Form View

The Result Form view displays the results of your query one record at a time. The Result Form view shows each record (or as much as will fit in the window) with the fields arranged one above the other. If your records contain many fields or long fields, you may have to scroll horizontally to see all the fields of a given record.

Note:

*
Click the Result Form button to place the Result window in Result Form view.

Parent topic: Query Results


Current Record and Total Record Counts

While in the Result window, SQLWizard retrieves enough records to show a complete page in the window. Each time you scroll or page to display more records, you are commanding SQLWizard to retrieve the additional records. There are two major advantages to this approach:

  • Results are displayed more quickly.
  • Many records can be viewed simultaneously.
Note:

You can limit the total number of records that a query can retrieve by setting the Max Rows To Retrieve option in the Current Query Options dialog box or through the Options utility.

Notice that as you move the cursor to different records in a result, SQLWizard updates the RECORD n OF m message on the status bar at the bottom of the screen. The first number in this message is the current record number and the second is the total number of records in the query result. If the total number of records is unknown, you will see a ? in place of the record count. If you need to know the actual record count, you can request that the system perform a count by selecting the Count command on the Record menu.

To find the total record count for the result:

  1. Open the Record menu.
  2. Click the Count command.

    SQLWizard displays the current record number (relative to the retrieved set of records) and the total number of records in the result on the status bar.

    Note:

    Performing a count causes the SQLWizard to retrieve all of the records in the result. For some results, such as joins on large tables, this could take quite some time. This is why SQLWizard does not automatically perform a count for you.

Parent topic: Query Results


Data Entry

  • Using the Result Window for Data Entry Overview
  • Transaction Processing
  • Working in Autocommit Mode
  • Using Commit and Rollback
Parent topic: SQL Wizard


Using the Result Window for Data Entry Overview

SQLWizard allows you to use the Result window to insert, update, and delete records. To enter data, you must enable the Allow Editing option either before you run the query or after the result is displayed.

Parent topic: Data Entry


Transaction Processing

A transaction is an atomic unit of work, meaning that all of the steps in a transaction must be performed completely, all must be undone completely. SQLWizard supports the concept of a transaction by allowing you to commit or rollback all edits made to the result since the last commit or rollback.

Note: If accessing an XDB Server version 4.x or lower, you must turn on the Backward Log using the Options utility. If the Backward Log is not on, rollback commands will have no effect.
Parent topic: Data Entry


Working in Autocommit Mode

When SQLWizard is installed on your machine, the default setting for data entry transaction processing is Autocommit On. In this mode, all changes made to a record are committed as soon as you move to the next record. This means that you do not have to remember to commit periodically, and it frees any locks that might be held on records you are editing, so that other users have access to the data. However, it means that you have little chance to rollback changes.

For this reason, SQLWizard provides two undo commands. The Undo command in the Edit menu restores changes to the current field. The Undo command in the Record menu re-reads the current record from the database. Since the record changes were never written to the database, there is no need to perform a rollback. However, you cannot use the Undo command once you have left the modified record.

Parent topic: Data Entry


Using Commit and Rollback

If you turn Autocommit mode off, the Rollback and Commit commands in the Record menu are enabled. You can now make changes to several records, and then decide whether to commit (accept) or rollback (undo) all of these changes. Choose the appropriate command from the Record menu.

Note:

If accessing an XDB Server version 4.x or lower, you must turn on the Backward Log using the Options utility. If the Backward Log is not on, rollback commands will have no effect.

Parent topic: Data Entry


Batch SQL Scripts Overview

A batch script is a set of SQL statements that have been stored in a text file. A script is usually created by saving the contents of the SQL Edit window to an .SQL file. Once the script has been saved, it can be replayed at any time using the SQLWizard's Run Batch command. It can also be executed directly from your system's command line.

Any operation that can be performed interactively can be performed from a script-- you can create tables, insert and delete records, view query results, and more. A batch script is particularly useful to automate tasks that are run on a regular basis. Once you have created a script, it can be used over and over.

Parent topic: SQL Wizard


Import

  • Introducing Import
  • Using Other Import Features
  • Importing a File Overview
  • Source File Information
  • XDB Server Table Information
  • Import File Formats Overview
Parent topic: SQL Wizard


Introducing Import

SQLWizard Import allows you to insert data from various file formats into new or existing XDB Server tables or views. You can view the source file to be imported, set options for recording import process errors, have the system calculate a new table definition from your source file, and set up and run Batch Import commands.

Batch import is particularly useful if you repeatedly import data with the same or similar table definition. Each time you open an Import window and provide import specifications and then save the specifications to a file, you create a Batch Import file. Before using Batch Import, you should be familiar with interactive import for the file type you are importing.

The following is a list of file formats supported by SQLWizard. Depending on the format you select, you may need to specify a number of options before activating the import.

  • Free ASCII Files (Delimited)

    Imports data from delimited (free-format) ASCII files into XDB Server tables.

  • Fixed-format ASCII Files (Columnar)

    Imports data from columnar (fixed-format) ASCII files into XDB Server tables.

  • DSNTIAUL

    Imports data downloaded from IBM's DB2 using IBM's DSNTIAUL facilities.

Parent topic: Import


Using Other Import Features

Other features available with Import allow you to clear all import specifications from an Import window, specify error handling options, and view the contents of your source file or Batch Import file.

Parent topic: Import


Importing a File Overview

The Import window is separated into two sections. The Source File Information section is where you specify the file you want to import, specify the format of the file, and define other format-specific requirements. The XDB Server Table Information section is where you specify the destination XDB Server table. You can import data to an existing table (with options to append or replace data) or create a new table to hold the imported data.

Parent topic: Import


Source File Information

This section of the Import window is where you specify the name of the file from which you will import data, as well as the format of that file and any other parameters required for the selected format.

File Name | Enter the drive, path, and name of the file whose data you want to import.
Format | Use the drop-down list to select the format of the file you are importing. SQLWizard can import data from free- or fixed-format ASCII files, and DSNTIAUL files.
Other Source File Parameters | Depending on the format of the file being imported, additional parameters may be required.
Parent topic: Import


XDB Server Table Information

This section of the Import window is where you specify the name of the XDB Server Table that is to receive your imported data. You can import data into an existing XDB Server table, or create a new table and define its table definition structure right on the Import window.

Table
Enter the name of the XDB Server table that will receive your data.

To import data to an existing XDB Server table, use the Browse button to select a table. Check the Replace Data checkbox if you want the imported data to replace existing data in the table. To append the imported data to the existing data in the table, be sure the Replace Data checkbox is unchecked.

To use the imported data to create a new XDB Server table, check the Create Table checkbox and specify the items in the Table Definition Grid at the bottom of the window.

Create Table
Check this box when you want to use the imported data to create a new XDB Server table.
Replace Data
Check this box when importing data to an existing XDB Server table and you want to replace the existing data. When this option is checked, all data in the existing table is deleted and is replaced in its entirety with the new data coming from the file you are importing.
Table Definition Grid
When importing to an existing XDB Server table, this area of the screen shows the table structure.

When creating a new XDB Server table to hold your imported data, SQLWizard provides a suggested table definition. You can make changes as desired.

Name (Column Name)
If you do not specify column names when importing to a new table, Import attempts to read the field names from the source file (if the Heading checkbox is marked or the format indicates that field names are in the first record). Otherwise, the import program provides default names (Field1, Field2, ... Fieldn).
Type (Field Type)
When importing data to a new XDB Server table, you must specify field types. You do not necessarily need to use the same data types as in the source file. For example, you can redefine a NUMERIC field to be a CHARACTER field, but you should not redefine a CHARACTER field that contains non-numeric data as SMALLINT, INTEGER, OR FLOAT.
Length (Field Length)
If you choose to specify field lengths, you can specify the lengths of CHARACTER, VARCHAR, GRAPHIC, VARGRAPHIC, CHAR FOR BIT DATA, and VARCHAR FOR BIT DATA fields. You must also specify the precision and scale for DECIMAL fields (default is 5,0). Other field lengths refer to storage length and are provided automatically.
Null (Null Values)
Specify the null permission of the field. Indicate Yes if nulls are allowed, No if nulls are not allowed, and DEF if nulls should be converted to the default value for the field. The DEF option is the same as NOT NULL WITH DEFAULT.
Pic
Indicate if you want to use the mask specified on the Format tab in Options when importing MONEY, DECIMAL, DATE, and TIME fields:
  • Yes: Use the Options mask.
  • No: Do not use the Options mask. Instead, use the following default format masks:
    Type | Default Picture
    Time | hh:mm:ss
    Date | mm/dd/yyyy
    Decimal | <sign><digits>[.<digits>][E[+-]<digits>]
    Money | <sign><digits>[.<digits>][E[+-]<digits>]
    where:

    <sign> includes any combination of + - $ >=

    <digits> are 0 through 9; also comma (,) if to the left of the decimal place.
Src Off (Source Offset)
For importing fixed-format ASCII files. Should indicate the starting column number for each field in the source file. The system suggests offsets based on the white space found in the heading row of the source file.
Src Len (Source Length)
For importing fixed-format ASCII files. Should indicate the length of each data field. You might have to edit the Src Len column to correctly describe the source file.

When importing a fixed-format ASCII file to a new table, you must specify field lengths or use the HEADING= and SPACES= statements in your batch file. If the import program finds HEADING=Y and SPACES=1 or more, it will be able to determine the field lengths.

Parent topic: Import


Import File Formats Overview

This topic contains detailed information about each file format that you can import to an XDB Server table. These include:

  • Delimited (free-format) ASCII files
  • Columnar (fixed-format) ASCII files
  • DSNTIAUL files
  • Delimited (Free-Format) ASCII Files
  • Columnar (Fixed-format) ASCII Files
  • DSNTIAUL Files
  • Summary of Import Parameters by File Format
Parent topic: Import


Delimited (Free-Format) ASCII Files

Use this format to import data from delimited, free-format ASCII files. ASCII format is a common means of transferring data from one program to another. Many software applications (including SQLWizard) provide a means of creating and reading ASCII output files. There are two ASCII file formats:

  • Delimited, free-format ASCII Files allow variable field lengths-- each field is separated by a field delimiter.
  • Columnar, fixed-format ASCII Files have fixed field lengths-- data is arranged in columns. Every record fits into a standard form, so field delimiters are not required.

The new XDB Server table definition suggested by SQLWizard when it examines a free-format ASCII file depends entirely on the data found in the file. You can examine the file yourself by using the Source File command from the View menu. If needed, you can change the suggested table definition in the table display area on the Import window.

When you use the Browse button to choose a file to import, SQLWizard defaults the file listing to the *.fre extension. The file you are importing can have a different extension.

The default field delimiter assumed for free-format ASCII files is an @ symbol. You can change this on the Import window or you can change the default by using the Defaults command from the Import menu.

The following table shows you the delimited ASCII format options:

Field Delimiter You must specify the field delimiter that is used to indicate where each field ends. The field delimiter differs from the record delimiter. The field delimiter is entered as a keyboard character or as an ASCII decimal code for a character. Decimal codes must be enclosed in angled brackets. For example, if the source file uses a # as the field delimiter, enter the character # or the string <35>. To use the < or > character as a delimiter, you must enter the ASCII decimal codes <60> or <62>, respectively.

If you don't know what the field delimiter is, use the Source File command from the View menu to display the source file. Optionally, you can use an ASCII text editor to examine the contents of the source file. If the field delimiter contains nonvisible ASCII characters, you might have to use a hex editor to examine the contents of the file.

If you specify a field delimiter that is not found in the file, you will not be allowed to continue. If your data uses a delimiter character that also appears in the data values, the system might try to create a table with too many fields. You can use a delimiter that is found in the data values only if the data values are surrounded by double quotes.

If you use a double quote character as the delimiter, the fields cannot also be enclosed in quotes. Do not use a comma as the delimiter if your data contains numeric values having commas as a grouping character.
Record Delimiter | The record delimiter for standard ASCII files is a carriage-return followed by a line-feed, as indicated by the default <013><010>. If your file uses a different end-of-record delimiter, you can change this setting. For example, you can import a file using the record delimiter <005><010>.
Values In Quotes If field values in your data contain quotes, click the Quotes checkbox to select it. Otherwise, be sure the Quotes checkbox is deselected. If data values contain quotes, you cannot use a quote as the field or record delimiter.

If fields are enclosed in quotes (either double- or single-), any delimiter character found within a pair of quotes is treated as part of the string. For example, if you are using a comma as a delimiter, and your source file contains the string "Washington, DC 20021", the entire string will be treated as one field, even though it contains the delimiter character. There must be a matching quote character for every quote character in the file. If your fields are enclosed in quotes, do not use quotes as a delimiter.

The system suggests a character data type for any columns of data enclosed in quotes; you can change the data type on the Field Definitions Grid at the bottom of the Import window.
Heading

If the first row of the file you are importing contains field names, click the Heading checkbox to select it. This tells Import to use those names as the column names in the table you are creating. If record data begins in the first row, then uncheck the Heading checkbox to turn off inclusion of a heading row.
Insert Nulls As Defaults | Select this checkbox if you would like to insert the columns' default values in place of NULLs in the source file for those defined WITH DEFAULT.
Parent topic: Import File Formats Overview


Columnar (Fixed-format) ASCII Files

Use this format to import data from columnar, fixed-format ASCII files. This format is a common means of transferring data from one program to another. Many software applications (including SQLWizard) provide a means of creating and reading ASCII output files. There are two ASCII file formats:

  • Delimited, free-format ASCII Files allow variable field lengths-- each field is separated by a field delimiter.
  • Columnar, fixed-format ASCII Files have fixed field lengths-- data is arranged in columns. Every record fits into a standard form, so field delimiters are not required.

The new XDB Server table definition suggested by SQLWizard when it examines a free-format ASCII file depends on the data found in the file and the parameters you enter on the Import window. You can examine the file by using the Source File command from the View menu. If needed, you can change the suggested table definition in the table display area on the Import window. You must specify the following:

  • Spaces
  • Heading
  • Offset
  • Source Length

When you use the Browse button to choose a file to import, SQLWizard defaults the file listing to the *.fix extension. The file you are importing can have a different extension.

The following table shows you the fixed-format ASCII format options:

Spaces |  | The Import utility requires that you confirm the number of blank spaces between columns. This is done by providing a number in the Spaces entry field on the Import window.
Heading |  | If the first row of the file you are importing contains field names, click the Heading checkbox to select it. This tells Import to use those names as the column names in the table you are creating. If record data begins in the first row, then uncheck the Heading checkbox to turn off inclusion of a heading row.
Table Definition |  | When importing fixed-format ASCII files in interactive mode, SQLWizard suggests a table definition based on the contents of the data file. You must examine and modify the source file offsets and lengths in the suggested table definition before you import the file. This must be done for all fixed-format ASCII imports, even if you are importing to an existing XDB Server table.
 | Offsets | Each column of data in a fixed-format ASCII file begins at a fixed point. The Offsets parameter indicates the number of characters from the beginning of the record to the beginning of the column specified. The system examines the row containing the column names (if any) to determine the offset. If the column names appear in the first row and consist of a single word that is left-justified over the column, the system should find the correct offset for you. Otherwise you will have to examine the data to determine the offset, and enter it in the appropriate location in the Offset column of the Table Definition Grid. Use the Source File command from the View menu to display the source file. The ruler at the top of the window corresponds to the offset. Use the beginning column number as the offset for each column. For example, in the following file, the offset for the E_NO column is 1, the offset for the LNAME column is 11, etc.
 | Src Len (Source Length) | When importing fixed-format ASCII files, Source Length refers to the width of the column in the source file. This value is used to determine where a column of data ends. Even if the target XDB Server table already exists, you must supply the length of each column in the source file. SQLWizard suggests a length for fields based on the source file structure. You must check and correct the source length for all columns in the Table Definition Grid before attempting to import the table.
Parent topic: Import File Formats Overview


DSNTIAUL Files

Use this format to import data from files that were exported by IBM's DSNTIAUL facility.

When you use the Browse button to choose a file to import, SQLWizard defaults the file listing to the *.dsn extension. The file you are importing can have a different extension.

In DSNTIAUL files, all data fields are consecutive (no delimiters), and are padded for the full length of each field (similar to a columnar, fixed-format ASCII file). If nulls are allowed, a one-byte trailer after each field indicates null status:

  • A zero (0) indicates NOT NULL.
  • An EBCDIC question mark (?) indicates NULL.

Data is stored as follows:

  • Text data is stored in EBCDIC format.
  • Date, Time, and Timestamp fields are stored as text.
  • Decimal and Money fields are stored in BCD format.
  • Smallint fields are stored in binary format. Byte order is automatically transposed as it is read from the source file so that the data is stored in standard Intel format (that is, least significant byte first).
  • Integer fields are stored in binary format. Byte order is automatically transposed as it is read from the source file so that the data is stored in standard Intel format (that is, least significant byte first).
  • Float is stored in IBM370 format (different from PCs).
  • Varchar fields have a two-byte header containing the length of the text.

The DSNTIAUL file format is based on the characteristics of the table from which the file was created. When importing data using the DSNTIAUL format, the entire format, including null permissions and field lengths, must be the same for the original table and the XDB Server table. If the null permissions or the field lengths do not match, the data being imported could be corrupted or the import could fail.

The DSNTIAUL format uses page-oriented storage for each record in the table. The typical page size is approximately 4K bytes.

Note:

When you have a long varchar field (which is 4096 bytes long), information in this field may be truncated. The size of the long varchar field is truncated to the page size minus the sum of the sizes of the other fields in the table.

EBCDIC to ASCII Translation

Values of the following data types are usually stored in EBCDIC format in a DSNTIAUL file:

Duration Types | Character Types | Description
Date | Char | Char For Bit Data
Time | Varchar | Varchar For Bit Data
Timestamp | LongVarchar | Long Varchar For Bit Data

Import converts date, time, and timestamp values from EBCDIC into ASCII, and then into XDB Server's internal format. Character values are converted from EBCDIC to ASCII and then inserted into the XDB Server table as ASCII values.

You can specify whether a value of any of the above types is in EBCDIC by selecting Yes or No from the EBCDIC column in the specification grid on the Import window. If you specify that a value is not in EBCDIC, then Import will not perform any EBCDIC to ASCII translation on it.

By default, Import assumes character data is stored in a DSNTIAUL source file using the American EBCDIC character set and converts it to the American ASCII character set when inserting it into an XDB Server table.

You can have the Import utility translate character data containing characters from any international EBCDIC character set to any international ASCII character set using the code page feature in Import. For the ASCII code page number, use the default ASCII character set for your country. EBCDIC to ASCII translation is performed using the translation table that corresponds to the specific ASCII and EBCDIC code pages. This translation table is in the TRANSTAB field of the SYSIBM.SYSSTRINGS table in the SYSTEM location. Currently, you are responsible for loading this table with the translation tables that you use.

Code Page Support

If any translation tables are defined in SYSIBM.SYSSTRINGS, they will appear on the Import window in the Codepage list box. The format in the list box is FROM n1 TO n2, where n1 is the number of the code page being translated from and n2 is the number of the code page being translated to.

When you select an item from the Codepage list box, Import loads the translation table for that conversion and uses it to convert character data during the import operation. You can specify which fields to convert by selecting Yes or No in the EBCDIC column of the Table Definition Grid. Normally, a conversion is performed for all applicable fields.

The format of the SYSIBM.SYSTRINGS table is as follows:

Column Name | Type | Length | Description
INCCSID | int | 2 | Code page number to translate From.
OUTCCSID | int | 2 | Code page number to translate To.
TRANSTYPE | CHAR | 2 | Not used by Import.
ERRORBYTE | CHAR | 1 | Not used by Import.
SUBBTYPE | CHAR | 1 | Not used by Import.
TRANSPROC | CHAR | 8 | Not used by Import.
IBMREQD | CHAR | 1 | Not used by Import.
TRANSTAB | VARCHAR for bit data | 256 | Translation table to convert from INCCSID code page to OUTCCSID code page.
Parent topic: Import File Formats Overview


Summary of Import Parameters by File Format

The following table shows which import parameters are required for each file format.

Import Parameters |  | Batch Keyword | Free ASCII | Fixed ASCII | DSNTIAUL
Source File Name |  | FILENAME | Required | Required | Required
Fld names in 1st row? |  | HEADING | Required | Required |
Field delimiter |  | FLD_DELIMITER | Required |  |
End of rec delimiter |  | REC_DELIMITER | Required |  |
Values in quotes? |  | QUOTE | Required |  |
How many fields? |  |  |  | Required |
Insert Null as blank? |  | INS_NULL | Required | Required | Required
XDB Server Table name |  | TABLE | Required | Required | Required
If table exists: |  |  |  |  |
 | Append or Replace | REPLACE |  | Required | Required | Required
If table does not exist: |  |  |  |  |
 | Name | FIELDS |  | Required | Required | Required
 | Type | TYPES |  | Required | Required | Required
 | Length | LENGTH |  | Required | Required | Required
 | Null? | NULL_PERM |  | Required | Required | Required
 | PIC? | USE_PIC |  | Required | Required | Required
Source Offset |  | OFFSETS |  | Required |
Source Length |  | SRC_LENS |  | Required |
Source File type |  | FORMAT | Required | Required | Required
Convert EBCDIC values to ASCII |  | EBCDIC_TO_ASCII |  |  | Required
Code Page |  | EBCDIC_CODEPAGE |  |  | Required
 |  | ASCII_CODEPAGE |  |  |
Insert Mode |  | INSERT_MODE | Required | Required | Required
Commit Interval |  | COMMIT_INTERVAL | Required | Required | Required
Log Errors |  | ERR_LOG_FILE | Required | Required | Required
On Error |  | ON_ERROR | Required | Required | Required
Parent topic: Import File Formats Overview


Import NLS Considerations

You need to be aware of character set conversion issues when importing data, especially if:

  • Your data contains diacritical (accented) or other characters that lie outside the first half of the ASCII character set
  • Your data was created using a variety of EBCDIC code pages

If you are importing EBCDIC data using SQL Wizard, we recommend using the DSNTIAUL data format as this enables you to specify an appropriate EBCDIC to ANSI or ANSI to EBCDIC conversion.

You specify the appropriate conversion by picking an entry in the code page window. For example, to import a Spanish EBCDIC table, you would pick the EBCDIC to ANSI translation 284 - 1252.

Parent topic: SQL Wizard


Using Batch Import

When you enter import specifications and use the Save As command from the File menu, you are saving the contents of the Import window. The saved file is a Batch Import file containing one import transaction. It has an .imp file name extension. A Batch Import file can also be created using any ASCII text editor. You can preview how an import specification would look as a batch file by clicking on Batch Import Commands from the View menu.

Batch Import is particularly useful when you have a number of similar files to import, or when you import the same files on a regular basis. Once you have created a Batch Import file, you may use it over and over, with or without modification.

Parent topic: SQL Wizard


Export

  • Introducing Export
  • Using Other Export Features
  • Exporting a Table Overview
  • Saving and Reusing Export Specifications Overview
  • Export File Formats Overview
Parent topic: SQL Wizard


Introducing Export

SQLWizard Export allows you to transfer the contents of any XDB Server table or view into a file in any of the supported file formats. You can export the columns of an existing table in any order or export a subset of the columns. In addition, you can specify a WHERE condition to export only selected data from the original table. Features are available to log the export process, set your own defaults for various export options, and set up and run Batch Export commands.

Batch export is particularly useful if you repeatedly export data from the same tables. Each time you open an Export window and provide export specifications and then save the specifications to a file, you create a Batch Export file. Before using Batch Export, you should be familiar with interactive export for the type of file to which you are exporting.

The following is a list of file formats supported by SQLWizard. Depending on the format you select, you may need to specify a number of options before activating the export.

  • Free ASCII Files (Delimited)

    Exports data from XDB Server tables to delimited (free-format) ASCII files.

  • Fixed Width ASCII Files (Columnar)

    Exports data from XDB Server tables to columnar (fixed-format) ASCII files.

  • DSNTIAUL

    Exports data from XDB Server tables to DSNTIAUL files. DSNTIAUL files can be read into DB2 systems.

  • SQL Statements

    Generates SQL commands that can be used to re-create a table, insert data into it, and create indexes on the table. COMMENT, WHERE, and SYNONYM statements can be included.

Note: XDB Server indexes are specific to the XDB Server environment and are not relevant to any other environment. Index information is environment-specific and depends on the operating system. Therefore, SQLWizard Export will not export the indexes when it exports a table. However, if exporting to SQL statements, you can generate the SQL CREATE INDEX command that will re-create an index on an XDB Server or DB2 system.
Parent topic: Export


Using Other Export Features

Other features available with Export allow you to clear all export specifications from an Export window, specify error handling options, and view the contents of your target file or batch import or Batch Export files.

Parent topic: Export


Exporting a Table Overview

The Export window is divided into two sections. The Target File Information section is where you specify the file that will receive your exported data. The Source Table Information section is where you specify the table whose data you will be exporting. There are two versions of the Source Table Information section. You choose which one to use by selecting Design Mode or SQL Mode from the View menu, or by specifying your preference in the Export Default Settings dialog box.

Parent topic: Export


Saving and Reusing Export Specifications Overview

Export specifications can be saved and reused. Saving a specification as it appears on an Export window creates a Batch Export file containing one export transaction. The saved file can be redisplayed and run in an Export window, or can be run using the Batch Export facility. Using an editor, you can copy and paste to combine the contents of multiple batch files to run them as one job.

Parent topic: Export


Export File Formats Overview

This topic contains detailed information about each file format to which you can export XDB Server data. These include:

  • Delimited (Free Format) ASCII files
  • Columnar (fixed-format) ASCII files
  • DSNTIAUL files
  • SQL statements
  • Delimited (Free Format) ASCII Files
  • Columnar (Fixed-Format) ASCII Files
  • DSNTIAUL Files
  • SQL Statements Overview
Parent topic: Export


Delimited (Free Format) ASCII Files

Use this format to export data from an XDB Server table or view to a free-format ASCII file. ASCII format is a common means of transferring data from one program to another. Many software applications (including SQLWizard) provide a means of creating and reading ASCII files. There are two ASCII file formats:

  • Delimited Free Format ASCII Files allow variable field lengths - each field is separated by a field delimiter.
  • Fixed-format ASCII Files have fixed field lengths - data is arranged in columns. Every record fits into a standard form, so field delimiters are not required.

When you use the Browse button to choose a target file, Export will search for the selected file format. Free format is indicated by the file name extension .fre.

You must specify a field delimiter to indicate where each field ends. The field delimiter differs from the record delimiter. The field delimiter can be typed as keyboard characters or as ASCII decimal codes enclosed in angle brackets. For example, to use a colon for a field delimiter, enter the character : or the string <58>. To use an angle bracket character ( < or > ) as a delimiter, you must enter the ASCII decimal codes <60> or <62>, respectively.

When specifying a delimiter, take care not to use a character found in your data, or in the default masks for the data types in the exported table. For example, do not use a comma as the delimiter if your data contains numeric or money values grouped with a comma. The default delimiter is an @ symbol.

Record Delimiter | Enter a character to be used as the end-of-record delimiter. The record delimiter for standard ASCII files is a carriage-return followed by a line-feed, as indicated by the default <013><010>. You can specify a different record delimiter to handle other file structures. For example, you could specify the field delimiter as <008><010> and the record delimiter as <005><010>.
Quotes | Select the Quotes checkbox if you want character fields in your target file to be enclosed in quotes. When character fields are enclosed in quotes (either double- or single-), any delimiter character found within the quotes is treated as part of the string. For example, if you are using a comma as a delimiter, and your source file contains the string "Washington, DC 20021", the entire string will be treated as one field even though it contains the delimiter character. Note: If your fields are enclosed in quotes, do not use quotes as a delimiter.
Heading | Select this option if you want to insert the column names in the first row of the target file. If you do not want columns names to appear in the first row, deselect the Heading checkbox.
Parent topic: Export File Formats Overview


Columnar (Fixed-Format) ASCII Files

Use this format to export data from an XDB Server table or view to a fixed-format ASCII file. This format is a common means of transferring data from one program to another. Many software applications (including SQLWizard) provide a means of creating and reading ASCII files. There are two ASCII file formats:

  • Free Format ASCII Files allow variable field lengths-- each field is separated by a field delimiter.
  • Fixed-format ASCII Files have fixed field lengths-- data is arranged in columns. Every record fits into a standard form, so field delimiters are not required.

Because every record fits into a standard form, field delimiters are not required for this format. However, you do need to specify number of space characters to be entered between columns and whether or not a header row should be exported.

When you use the Browse button to choose a target file, export will search for the selected file format. Fixed-format is indicated by the file name extension .fix.

The following table shows you the columnar fixed-format ASCII format options:

Spaces | Enter a number to indicate how many space characters should be inserted between columns of data in the exported file.
Heading | Select this option if you want to insert the column names in the first row of the target file. If you do not want columns names to appear in the first row, deselect the Heading checkbox.
Parent topic: Export File Formats Overview


DSNTIAUL Files

Use this format to export data from an XDB Server table or view into the DSNTIAUL file format. DSNTIAUL is a mainframe format (File UNLOAD Utility) that is used with DB2.

When you use the Browse button to choose a target file, export will search for the selected file format. DSNTIAUL format is indicated by the file name extension .dsn.

In DSNTIAUL files, all data is consecutive (no delimiters), and padded for the full length of the field, making it more like a columnar (fixed-format) ASCII file. If nulls are allowed, a one-byte trailer after each field indicates null status:

  • A zero (0) indicates NOT NULL.
  • An EBCDIC question mark (?) indicates NULL.

Data types are exported as follows:

  • Text fields are stored in EBCDIC format.
  • Date, Time, and Timestamp fields are stored as text.
  • Decimal and Money fields are stored in BCD format.
  • Smallint fields are stored in binary format. As the field is read, its byte order is automatically transformed from standard Intel format (where the least significant byte is first) into standard binary format (where the most significant byte is first).
  • Integer fields are stored in binary format. As the field is read, its byte order is automatically transformed from standard Intel format (where the least significant byte is first) into standard binary format (where the most significant byte is first).
  • Float fields are stored in binary format (different from PCs).
  • Varchar fields have a two-byte header containing the length of the text.

The DSNTIAUL file format directly depends on the null permissions of the exported table. Therefore the null permissions of the table you import into must match the table's null permissions from which you exported.

The DSNTIAUL format uses a page-oriented storage for each record in the table. The typical page size is approximately 4K bytes. When the table contains a long varchar field (which is 4056 bytes long), information in this field may be truncated. The size of the long varchar field is truncated to the page size minus the sum of the sizes of the other fields in the table.

Export to DSNTIAUL format can make use of Code Page Support. This allows you to export objects to DSNTIAUL in EBCDIC and retain object names containing foreign characters. By default, Export assumes character data is stored in the source tables using the American ASCII character set and converts it to the American ASCII character set before writing it to a target file. See "ASCII Table" for a listing of the decimal ASCII character sets.

You can have the Export utility translate character data containing characters from any international EBCDIC character set using the code page feature in Export. For the EBCDIC code page, use the default EBCDIC character set for your country. Code page support is provided by the INCCSID and OUTCCSID fields in the SYSIBM.SYSSTRINGS table at the SYSTEM location.

The following table shows the structure of the SYSIBM.SYSSTRINGS table.

Column Name | Type | Length | Description
INCCSID | int | 2 | Code page number to translate FROM.
OUTCCSID | int | 2 | Code page number to translate TO.
TRANSTYPE | CHAR | 2 | Not used by Export.
ERRORBYTE | CHAR | 1 | Not used by Export.
SUBBTYPE | CHAR | 1 | Not used by Export.
TRANSPROC | CHAR | 8 | Not used by Export.
IBMREQD | CHAR | 1 | Not used by Export.
TRANSTAB | VARCHAR for bit data | 256 | Translation table to convert from INCCSID code page to OUTCCSID code page (ASCII to EBCDIC)

When the Export utility uses code page options, the values entered for INCCSID and OUTCCSID are compared with values in the system table SYSIBM.SYSSTRINGS. The matching record in the table contains the translation table used to convert XDB Server data in ASCII format to DSNTIAUL data in EBCDIC format.

Parent topic: Export File Formats Overview


SQL Statements Overview

Use this option to generate a file containing standard SQL CREATE, INSERT, INDEX, SYNONYM, CHECK, and COMMENT ON commands that will allow a table or view and the data it contains to be re-created in another SQL environment. This option generates a standard Batch SQL file that can be used directly by SQLWizard's Batch SQL or other SQL DBMS applications. You can run an exported SQL file on a mainframe DB2 system as a means of copying tables and data from XDB Server to DB2.

The standard SQL commands you can create with this Export format are:

  • CREATE TABLE
  • CREATE INDEX
  • CREATE SYNONYM
  • COMMENT ON
  • INSERT
  • ALTER TABLE...CHECK.

When you use the Browse button to choose a target file, export will search for the selected file format. The SQL Statement format is indicated by the file name extension .SQL.

Specify what types of SQL statements you would like to have generated from the source table or view by clicking on the desired SQL statement checkboxes. The table below describes each option.

SQL Option | Generated SQL Statements
CREATE | Generates a CREATE TABLE or CREATE VIEW statement that will re-create the table or view when the exported SQL file is run in Batch SQL.
INSERT | Generates INSERT INTO statement(s) that will insert the source table data into the re-created table or view when the exported file is run in Batch SQL.
INDEX | Generates CREATE INDEX statement(s) that will create index(es) for the recreated table when the exported file is run in Batch SQL.
SYNONYM | If synonyms exist for the source table (or view) or for any columns in the source table, this option generates CREATE SYNONYM statement(s) that will create the same synonyms when the exported file is run in Batch SQL.
CHECK | If exporting a table, this option generates an ALTER TABLE command with the CHECK option. You can modify the statement to define the conditions for the check constraint. If exporting a view that was originally created using the WITH CHECK OPTION, the WITH CHECK OPTION is included in the CREATE VIEW statement generated by this utility.
COMMENT | Generates COMMENT ON statement(s) for the table and for each column.
SQL Statement Option | Description
DB2 Options for CREATE TABLE | Enter DB2 options if you are planning to run your exported SQL file on a mainframe DB2 system. Click the Create (Create Table) checkbox to select it, and then click the DB2 button to the right of it to specify mainframe options for the IN DATABASE clause to be generated. These options make the SQL statements more compatible with your target environment.
DB2 Options for CREATE INDEX | Enter DB2 options if you are planning to run your exported SQL file on a mainframe DB2 system. Click the Index checkbox and then click the DB2 button to the right of it to specify DB2 Create Index options. These options make the SQL statements more compatible with your target environment.
Parent topic: Export File Formats Overview


Export NLS Considerations

You need to be aware of character set conversion issues when exporting data, especially if:

  • Your data contains diacritical (accented) or other characters that lie outside the first half of the ASCII character set
  • Your data was created using a variety of EBCDIC code pages

If you are exporting EBCDIC data using SQL Wizard, we recommend using the DSNTIAUL data format as this enables you to specify an appropriate EBCDIC to ANSI or ANSI to EBCDIC conversion.

You specify the appropriate conversion by picking an entry in the code page window. For example, suppose you want to export a Swedish EBCDIC table. During the export, you would pick the ANSI to EBCDIC translation 1252 - 278.

Parent topic: SQL Wizard


Using Batch Export

When you enter export specifications and use the Save As command from the File menu, you are to saving the contents of the Export window. The saved file is a Batch Export file containing one export transaction. It has a .exp file name extension. A Batch Export file also can be created using any ASCII text editor. You can preview how an export specification would look as a batch file by clicking on Batch Export Commands from the View menu.

Batch Export is particularly useful when you have a number of similar tables to export, or when you export the same table(s) on a regular basis. Once you have created a Batch Export file you can use it over and over, with or without modification.

Parent topic: SQL Wizard


User Administration

  • Introducing Administrative Features
  • Managing Users and XDB Server Access Overview
  • Managing Groups Overview
  • Setting XDB Server Priorities
Parent topic: SQL Wizard


Introducing Administrative Features

This topic provides information on setting up AuthIDs, Groups, and Privileges. In addition, access to the XDB Server can be limited using the Governor features.

The AuthID is used for identification and security purposes when you access an XDB Server, utilities, and database objects. Passwords provide additional access security. Groups enable XDB Server Administrators to easily grant privileges to subsets of the user population who have similar needs. The Governor is used to invoke special access limitations.

System security can be complex. A complete discussion of the inter-relationships of the various security options is provided in "Security and Authority." You should be familiar with that information before setting up system security, AuthIDs, groups, authorities, and privileges.

Information you enter using the Admin menu commands is transformed into standard SQL UPDATE, INSERT, and DELETE statements that are sent to the XDB Server for execution against the appropriate system tables. Other security measures can be activated through the use of the SQL GRANT and REVOKE commands.

Parent topic: User Administration


Managing Users and XDB Server Access Overview

The Users command on the Admin menu allows an XDB Server Administrator (super user) to add, view, and modify AuthID specifications for all users of the currently connected XDB Server, including whether a password is required at connect time and the type of user (user or super user). The XDB Server Administrator can also assign a selected user to one or more groups, thus providing an easier means of granting database privileges to subsets of the user population who have similar needs. In addition, XDB Server Administrators can remove users (temporarily or permanently), assign priorities to users for XDB Server access, and provide a SecondaryID. (SecondaryIDs provide an alternate means of assigning privileges to groups of users.

When the Users command is selected from the Admin menu, the Add/Modify User dialog box is displayed. This is where you will add, delete, and update AuthIDs.

Parent topic: User Administration


Managing Groups Overview

A group allows an XDB Server Administrator to control location, database, and table level privileges using a GroupID. An XDB Server Administrator can define groups and assign them to users using the Groups dialog box. Using the SQL GRANT command, database and table privileges are then assigned to the GroupID rather than to each individual user who needs access to those database objects. This method gives the same privilege set to each user in the group. If a user belongs to multiple groups, that user has the privileges of all those groups.

Once a group has been created, it appears in the Group Membership list on the Add/Modify User dialog box. This provides an alternate means of assigning a user to a group.

Note: In some cases it might be better to give users a common Secondary ID.
Parent topic: User Administration


Setting XDB Server Priorities

Priorities are a set of usage restrictions imposed on an AuthID. Setting priorities gives an XDB Server Administrator the ability to define XDB Server usage priorities for peak hour processing, or to restrict users who do particularly intensive queries to off-peak hours.

You control a user's access to an XDB Server by defining a priority (a set of usage restrictions) and then assigning the priority to the user's AuthID. An AuthID that exceeds any of the limits of it's assigned priority is disconnected from the XDB Server.

Note:

If you are not running against an XDB Server version that supports priorities, or if the XDB Server has the Governor feature turned off, the Priorities command is grayed out on the Admin menu.

A new or changed priority does not take effect until the XDB Server is shut down and restarted.

Priorities are defined through the Define Priority dialog box. Priorities can be defined to limit users by number of API calls, amount of time in the XDB Server SQL engine, amount of time processing calls, amount of idle time and/or the number of fetches. You can also set the times of the day when these limits are in effect.

All the limits set for a priority are checked by the Governor on the XDB Server. Using the Server Configuration utility, you set the MAXIMUM GOVERNOR CYCLE TIME to define how often the governor checks whether a user has exceeded priority limits. To turn off the XDB Server Governor, set this cycle time to zero. Because the frequency with which the governor checks the user's limit status is not infinitely small, it is possible for the limits to be slightly exceeded before the governor takes action. For more information about the Governor features of the XDB Server, see the description of the Maximum Governor Cycle Time option in the section Governor Cycle Timein the chapter Server Configuration Utility in your SQL Option Server Administration Guide.

Parent topic: User Administration


Security and Authority Overview

XDB Servers provide a full featured security system, including the ability to define Primary Authorization IDs (AuthIDs), SecondaryIDs, and groups for users, the ability to grant and revoke privileges for users and groups at system, database, table, and column levels, and a choice of using a four- to eight-character password mask (with conditions).

  • Security System Concepts
  • Managing System Security and Priorities
  • System Level Access Control
  • Password Enforcement Level
  • XDBACF Database
  • AuthID Types
  • Current SQLID
  • AuthID Ownership and Usage Rules
  • Effect of AuthIDs on Object Names and Usage
  • Granted Authorities and Privileges
  • Predefined XDB Server Authorities for GRANT and REVOKE
  • The DSNDB06 Database
  • Granting and Revoking Privileges
Parent topic: SQL Wizard


Security System Concepts

XDB Servers are shipped with security turned off to allow you unlimited access to the system. You can continue to operate without security indefinitely, if desired, even in a multi-user environment.

If you do plan to use the XDB Server security features, starting with security off gives you a flexible development environment. You can create locations, databases, and other objects, and set up the required AuthIDs (user names), passwords, groups, and privilege sets you will need for controlling user access before you turn on security.

In a multi-user environment, if security is on at the server, all users must have security on at their individual workstations. If security is off at the server, individual users can have security on, if desired, to protect against unauthorized access at the workstation.

After security is turned on, each user or process must log in with a valid AuthID. If the AuthID has a password defined and required, the password must be entered as well.

To turn server security off, a user must have a valid AuthID with appropriate privileges to be able to access the Security Option in the XDB Server Configuration utility or the Options window as appropriate.

One special AuthID, INSTALL, is created when you install the XDB Server. The INSTALL user is an XDB Server super user. If you do not turn on security, you will not need to be concerned with this special AuthID or its password.

Note:

As long as security remains off and you do not create additional AuthIDs, all objects you create will belong to the Primary AuthID indicated in your Profile (that AuthID becomes the qualifying name in the three-part object name:location-name.authid.object-name). When you install XDB Server, the default AuthID in Options is TUTORIAL. You might wish to change this AuthID if you plan to turn security on and add more users to your system at a later date.

You can change the AuthID that is used for object creator names by any of the following methods:

  • Change each client's Primary AuthID by entering the value into the AUTHID field of the Options dialog box's Connect tab.
  • Issue the SET CURRENT SQLID command before you create the object.
  • Explicitly specify a valid AuthID when you create the object (by specifying a two- or three-part name in the CREATE statement (if specifying a three-part name, the location part of the name must be the current location).

Alternatively, you can create several AuthIDs and grant a different privilege set to each, using these AuthIDs for different purposes. You can also create a group, which allows you to grant the same privilege set to several or many AuthIDs.

When security is on, the super user is a special user. A super user is the only one who can:

  • Create and drop locations.
  • Edit (update) system tables.
  • Assign super-user privileges to another AuthID.

The Admin menu commands are used to assign super-user privileges. The SQL Grant and Revoke commands cannot be used for assigning super-user privileges.

On a multi-user system (or any system where security is an issue), you should assign a password to the INSTALL SUPER USER AuthID. You might wish to set up a few additional AuthIDs with super-user privileges before you turn on security. This allows you to have several other trusted users as a backup to the XDB Server Administrator.

Parent topic: Security and Authority Overview


Managing System Security and Priorities

SQL Option is provided with the security and administration features you would expect of a database system. Depending on how you intend to use it, however, you might not need to enable the security features. For this reason, your personal XDB Server and its client tools and utilities are initally installed with security switched off.

Security is controlled separately at the server and at the client. If you switch security on for an XDB Server, it can only be accessed by clients that also have security switched on. (In this context, a client is one of the XDB configuration tools or graphical data utilities. The client applications that you develop are expected to handle authorization in the usual way by means of CONNECT statements). If you are developing a DB2 application that handles passwords, you may want to work with a test environment that has security switched on to enable user authentication.

Use the Admin menu of SQL Wizard to manage system security. You can control security at three levels:

  • All users
  • Named groups of users
  • Individual users

When security is switched off for an XDB Server, all users are effectively superusers because:

  • No passwords are required
  • All users share a common AuthID, specified on the Connect tab of the Options utility
  • All users have access to both client and server utilities

Server security status is set using the Server Configuration utility (accessible by clicking SQL For DB2 > XDB Server on the Options menu). Once security has been enabled, users must log on with a valid AuthID and, if required, password. The user's actual AuthID replaces the shared one, which means that a user cannot access a database unless they have been granted the appropriate access privileges by the database owner using GRANT and REVOKE statements.

An AuthID that has been assigned superuser status can change user, group and priority settings that affect all databases on an XDB Server. Initially an AuthID called INSTALL is set as the superuser. If you log on with this AuthID, you can create further superusers as required by clicking Users on the Admin menu and giving each user the appropriate status.

Ordinary users can use the Admin menu only to change their password. Ordinary users who want to change access privileges for specific databases and tables that they own should click New > SQL on the File menu and use the SQL statements GRANT and REVOKE to change access privileges. The AuthID of the creator of a table is deemed to be its owner.

As well as managing system security, a superuser can assign priorities to individual users or groups of users. Priorities control how much processing resource is available to the user or group, depending on criteria set by the superuser.

Note:

When you install SQL Option, the default AuthID is set to TUTORIAL. This AuthID has user privileges and is not authorized to access system tables. This means that, if you switch security on for your personal XDB Server, you cannot use this AuthID to log on to the client utilities.

You should log on using the default superuser AuthID, INSTALL. You can then either set the TUTORIAL AuthID to have superuser status or you can grant it suitable authority on system tables, as appropriate. The INSTALL superuser AuthID has no password assigned initially: you should allocate one to it as soon as possible after switching XDB Server security on.

Parent topic: Security and Authority Overview


System Level Access Control

System level access control refers to that part of the security system that controls the login process, passwords, the assignment of users to groups, and the definition of SecondaryIDs.

Parent topic: Security and Authority Overview


Password Enforcement Level

Before setting up initial passwords for users (or before users change their passwords), the XDB Server Administrator (super user) should select a password enforcement level from the options provided in the Options utility. Use the copy of this utility that resides on the XDB Server machine.

Password level options are:

  • Level 1 - Password must be four or more characters.
  • Level 2 - Password must be six or more characters and include at least one digit (numeric).
  • Level 3 - Password must be six or more characters, include at least one digit (numeric), and must include the two randomly generated characters that appear in the prompt message on the User Control screen.

Users can change their passwords by using the CHANGE PASSWORD command from the ADMIN menu.

Note:

If you are using XDB-Link, your XDB Server AuthID and password are passed to the mainframe as a login UserID and password. To successfully access a DB2 location, your XDB Server AuthID and password must be valid on the mainframe system.

Depending on your security needs, you might wish to establish two AuthID/Password accounts on XDB Server, one for times when you are working only on XDB Server locations and one for times when you plan to access a DB2 location.

If you are using a version 2.40 or 2.41 utility or tool with XDB Server Version 3.x (or higher) and XDB Link, other considerations may apply for DB2 access. See the SQL Option Link User's Guide for more information.

Parent topic: Security and Authority Overview


XDBACF Database

The system location for each XDB Server contains a database called XDBACF (XDB Access Control Facility). This database contains information you enter for each user and group via the Admin menu commands. Information in the XDBACF database applies to all users and all locations on the server.

The XDBACF database contains the following tables and columns. For the specific format of each of these tables, see the topic List Of System Tables.

SYSXDB.SYSACFUSERS Contains a list of all users, including the following information for each user:
  • AuthID
  • SecondaryID
  • Password
  • DateOP (date of password)
  • TimeOP (time of password)
  • AccessAuthority
  • RequirePassword
  • UserType
  • Remarks
Note:

If you are a super user, do not edit or update a user's PASSWORD or TIMEOP information in this table. Use the Admin menu commands instead.

SYSXDB.SYSACFGROUPS Contains a list of all GroupIDs that have been defined. Columns in this table are:
  • GroupAuthID
  • Remarks
SYSXDB.SYSACFMEMBERS Contains a list of AuthIDs and the GroupIDs that each is authorized to use. Each user (Primary AuthID) can have several entries, one entry for each GroupID that the person is authorized to use. Columns in this table are:
  • UserAuthID
  • GroupAuthID
SYSXDB.SYSGOVERNOR Contains information on the type of activities that can be performed by certain users during certain periods. Columns in this table are:
  • EndFreeTime
  • MaxFetches
  • MaxIdleTime
  • MaxNumApiCalls
  • MaxTimeEngine
  • MaxTimePerApi
  • Priority
  • StartFreeTime
SYSXDB.SYSUSERPRIORITY Contains information about priorities that have been assigned to users.
Parent topic: Security and Authority Overview
Related information
System Table Overview


AuthID Types

Primary AuthIDs, GroupIDs, and SecondaryIDs can be used in combination when setting up system security. These IDs are defined as follows:

  • Primary AuthID
  • Group or GroupID
  • SecondaryID (optional)
  • Current SQLID
  • Primary AuthID
  • Group or GroupID
  • SecondaryID (optional)
Parent topic: Security and Authority Overview


Primary AuthID

This is the primary identifier for all users of an XDB Server. A Primary AuthID can be assigned to a process or program that requires access to XDB Server data.

  • Used for logging in to an XDB Server.
  • Appears as an identifier on server screens that are used to monitor activity of users.
  • Used as the default for the AuthID portion of a database object's three-part name when the user creates the object. A different ID will become the default if the SET CURRENT SQLID command is issued or if a SecondaryID is defined.
  • Determines privileges when a user attempts to access a database object. If a different ID is in effect (from issuance of a SET CURRENT SQLID command), that ID's privileges are available also. If the Primary AuthID belongs to a group, the privileges granted to the GroupID also are available to the user of the Primary AuthID. If a SecondaryID is defined, the Primary AuthID's privileges are not valid, but rather the SecondaryID's privileges take effect (along with its groups, if any).
Parent topic: AuthID Types


Group or GroupID

This is a special identifier that can be assigned to one or more Primary AuthIDs. The privileges granted to the GroupID are available to every Primary AuthID to which the GroupID is assigned. In addition, each Primary AuthID can have multiple GroupIDs assigned to it, thus gaining the privileges of all of those groups combined. Other privileges can be granted to the Primary AuthID, providing the user with the assigned group privileges plus the privileges assigned specifically to the Primary AuthID.

Note:

If you specify a GroupID as the second part of an object's three-part name, all users who are assigned to that group will automatically have all privileges on the object. Privileges cannot be revoked from a user whose GroupID is the same as the object creator's AuthID. The GRANT and REVOKE commands have no effect on these privileges.

Parent topic: AuthID Types


SecondaryID (optional)

If defined, this AuthID replaces the Primary AuthID as soon as the user logs in to the XDB Server. The user (or process) is given the privileges that have been granted to the SecondaryID. If the Primary AuthID had privileges granted to it, those privileges would be ignored. When a user with a SecondaryID creates an object, the AuthID portion of the object's name is the SecondaryID. All other users who use the same SecondaryID will have all privileges on that object.

Note:
  • The XDB Server SecondaryID is not the same as the DB2 Secondary Authorization ID. The IBM method of defining multiple Secondary Authorization IDs and assigning them to Primary AuthIDs in RACF (Resource Access Control Facility) is similar to XDB Server's group concept.
  • If you use an object creator's AuthID as a SecondaryID for other users, those other users will all have all privileges on the object. A user with a SecondaryID is seen by the system as being the SecondaryID, and therefore has all privileges on all objects that carry that AuthID as the second part of the object name. Privileges cannot be revoked from the creator of an object, or from a user who's Current SQLID is the same as the object creator's AuthID. The GRANT and REVOKE commands have no effect on the privileges of an object's creator/owner.
Parent topic: AuthID Types


Current SQLID

The Current SQLID is a special register that keeps track of which AuthID is in effect for a given client session. A user with SYSADM or super-user authority can issue the SET CURRENT SQLID command to change the SQLID to any valid AuthID. If a user has a SecondaryID, the Current SQLID changes from the Primary AuthID to the SecondaryID at the start of the client session.

Parent topic: Security and Authority Overview


AuthID Ownership and Usage Rules

When security is on, the Primary AuthID and Password are used when each user (or process) logs in to the XDB Server. The system then checks the SYSXDB.SYSACFUSERS table for the existence of a SecondaryID. If present, the user (or process) assumes the identity of the SecondaryID and is accorded all privileges that have been defined for the SecondaryID. If no SecondaryID exists for the user, then privileges are based on what has been granted for the Primary AuthID and the group(s) to which it belongs.

Multiple users can be assigned the same SecondaryID. In effect, this provides an alternate method for granting a particular set of privileges to a group of users without having to define those privileges for each user individually. The privileges are granted to the SecondaryID (essentially just another AuthID). However, the preferred method for assigning the same privilege set to many users is to use the XDB Server Group, which is similar to the DB2 concept of assigning multiple secondary authorization IDs to a primary authorization in IBM's RACF (Resource Access Control Facility).

Note:

If several users have the same SecondaryID, all the objects they create will be owned by the SecondaryID and not by the individual users. All users having that same SecondaryID will have all privileges on those objects. The GRANT and REVOKE commands have no effect on privileges of an object's creator/owner, which in this case includes all users with the SecondaryID that is also the AuthID portion of the object's name. All of these users are seen by the system as being the owner of the object.

Parent topic: Security and Authority Overview


Effect of AuthIDs on Object Names and Usage

The following table illustrates how various GroupID and SecondaryID assignments can affect the naming of and access to database objects.

Primary AuthID | Secondary ID | Group Name | Creates Table...1 | Owner | Authorized Users
TECHPUBS | -- | -- | Created as a Primary AuthID. Privileges are assigned. Used as a SecondaryID for one or more Primary AuthIDs.
-- | -- | WRITER | Created as a group. Privileges are assigned to the group. GroupIDs are assigned to Primary AuthIDs.
ERIC | -- | -- | ERIC.TABLE1 | ERIC | ERIC
DEBBIE | -- | -- | DEBBIE.TABLE1 | DEBBIE | DEBBIE
DAVID | -- | WRITERS | DAVID.TABLE1 | DAVID | DAVID and, if access is granted to WRITERS, also ARLENE.
ARLENE | -- | WRITERS | ARLENE.TABLE1 | ARLENE | ARLENE and, if access is granted to WRITERS, also DAVID.
ROCHELLE | TECHPUBS | -- | TECHPUBS.TABLE1 | TECHPUBS | Users with TECHPUBS as SecondaryID (ROCHELLE, STEVE, PABLO, BRUCE) and, if access is granted to WRITERS, also DAVID, ARLENE.
STEVE | TECHPUBS | -- | TECHPUBS.TABLE2 | TECHPUBS | Users with TECHPUBS as SecondaryID (ROCHELLE, STEVE, PABLO, BRUCE) and, if access is granted to WRITERS, also DAVID, ARLENE.
PABLO | TECHPUBS | WRITERS (ignored)2 | TECHPUBS.TABLE3 | TECHPUBS | Users with TECHPUBS as SecondaryID (ROCHELLE, STEVE, PABLO, BRUCE)
BRUCE | TECHPUBS | WRITERS (ignored)2 | TECHPUBS.TABLE4 | TECHPUBS | Users with TECHPUBS as SecondaryID (ROCHELLE, STEVE, PABLO, BRUCE)

1All scenarios described here assume that the user does NOT specify an AuthID when creating the object and the user has NOT changed his Current SQLID.

2Pablo and Bruce do NOT have privileges defined for the group WRITERS because as soon as they log in, they both become TECHPUBS, and TECHPUBS is not assigned to the group WRITERS in this example.

As shown in the table above, the AuthID portion of the name assigned to a database object when it is created, and the users who have access to that object depend on how AuthIDs, GroupIDs, and SecondaryIDs are defined. The object naming and usage rules are as follows:

  • If a user belongs to a group and creates an object, the AuthID portion of the object name will be the user's own Current SQLID, and not the GroupID. This allows more than one user to create objects of the same name within the same location. For example:

    If user DAVID (who is in the WRITERS group) creates a table called STAFF in the location called BOOKS, the table's three-part name would be BOOKS.DAVID.STAFF. If user ARLENE (who is also assigned to the WRITERS group) attempts to create a table called STAFF, the table's three-part name would be BOOKS.ARLENE.STAFF. Since the three-part names of the two tables are unique, each user can have a table of the same one-part name within a location.

    Note:
    • If a user has no Secondary ID and has not otherwise changed his Current SQLID, the Current SQLID is the user's Primary AuthID.
    • If you specify a GroupID as the second part of an object's three-part name, all users who are assigned to that group will automatically have all privileges on the object. Privileges cannot be revoked from a user whose GroupID is the same as the object creator's AuthID. The GRANT and REVOKE commands have no effect on these privileges.
  • If a GRANT command gives privileges to a GroupID, all users who are members of that group will have those privileges.
  • If a user belongs to multiple-groups, the user has privileges that have been granted to all the groups.
  • If a user has a SecondaryID and creates an object, the AuthID portion of the object name will be the SecondaryID (assuming that the user has not changed his Current SQLID, which by default takes the value of the SecondaryID). Two users with the same SecondaryID cannot create objects of the same name within a location. For example:

    If user ROCHELLE (who has a SecondaryID of TECHPUBS) creates a table called STAFF in the location called BOOKS, the table's three-part name would be BOOKS.TECHPUBS.STAFF. If user STEVE (who also has TECHPUBS as his SecondaryID) attempts to create a table called STAFF, the table's three-part name would also be BOOKS.TECHPUBS.STAFF. This is not allowed.

  • Any object whose name has a SecondaryID as the AuthID qualifier can be accessed by any user who has that same SecondaryID as his Current SQLID. GRANT and REVOKE commands have no effect on these users' access to the objects because these users are all seen by the system as being the owner of the object. All users who have the SecondaryID that is the owner of the object will have all privileges on the object.

    Users ROCHELLE, STEVE, PABLO, and BRUCE all have all privileges on TECHPUBS.TABLE1, TECHPUBS.TABLE2, TECHPUBS.TABLE3, and TECHPUBS.TABLE4. GRANT and REVOKE commands for these users and tables will have no effect.

    If an object has a different owner, then granting privileges to the SecondaryID will give those privileges to all users who have that SecondaryID as their Current SQLIDs.

  • If a user has a SecondaryID (as his Current SQLID) and belongs to a group and creates an object, the AuthID portion of the object name will be the SecondaryID. Other users in the group do not have access to the object, because privileges on the object have not been granted to the group. The object is owned by the SecondaryID. Only users with the same SecondaryID (as their Current SQLIDs) can access the object. (However, the original user who created the object of this example can access other objects to which the group has been granted privileges.)
Parent topic: Security and Authority Overview


Granted Authorities and Privileges

When security is on, databases and tables are protected from being accessed and manipulated unless the user's Current SQLID is either the owner of the object or has been granted specific privileges in the location where the object resides. Privileges can be granted to a Primary AuthID, a GroupID or a SecondaryID.

An AuthID can also be granted an authority, which is a pre-defined set of privileges. Notice that the Authorities are suggestive of different levels of responsibility. These responsibilities might or might not suit your needs.

Privileges (and authorities) can be granted at the location level (SYSADM or SYSCTRL), database level (DBADM, DBCTRL or DBMAINT), or by table or column within a table. AuthIDs must be granted privileges within each location they are authorized to use. Privileges in one location do not carry over to another location.

Note: If using XDB-Link to access a DB2 location from an XDB Server, you must have appropriate authorities granted on DB2 for the objects you will be using in that mainframe location. Authorities and privileges granted on XDB Server (including INSTALL and SYSADM) are not used by the mainframe system.
Parent topic: Security and Authority Overview


Predefined XDB Server Authorities for GRANT and REVOKE

To assign privileges to a given AuthID in two or more locations, the XDB Server Administrator (super user) can set up groups. Each GroupID is then assigned privileges for one location. The groups that represent the locations for which the user is to be allowed privileges are then assigned to the user's AuthID.

To allow a user to have unlimited privileges throughout the system (all locations), the user's Primary AuthID must be given super-user privileges.

Note:

Only a super user can create locations, drop locations, edit (update) system tables, and assign super-user status to another user. Super-user privileges can be assigned with the ADMIN menu commands, or by editing the USERTYPE column in the user's record in the SYSXDB.SYSACFUSERS table.

Users cannot grant privileges to themselves and cannot revoke privileges from themselves. Likewise, GRANT and REVOKE commands have no effect on users whose AuthIDs (or SecondaryIDs or GroupIDs) are the same as the AuthID portion of an object's name.

Parent topic: Security and Authority Overview


The DSNDB06 Database

The DSNDB06 database, which is a system catalog database provided in each location, contains the specific authorities and privileges that you define for each AuthID, SecondaryID or GroupID with the SQL GRANT and REVOKE commands. This information is stored in the following security-related tables:

  • SYSIBM.SYSDBAUTH (Database Authorization)
  • SYSIBM.SYSUSERAUTH (User Authorization)
  • SYSIBM.SYSTABAUTH (Table Authorization)
  • SYSIBM.SYSCOLAUTH (Column Authorization)
Parent topic: Security and Authority Overview


Granting and Revoking Privileges

After the XDB Server Administrator (super user) has set up the AuthIDs, SecondaryIDs and groups, the privileges and authority for each can be defined. This is accomplished with the SQL GRANT and REVOKE commands. You can set up the granted privileges before or after turning on security. However, any grants you issue when security is off will not take effect until you turn security on.

Note: Be sure you are operating in the location for which you want to define privileges. Each location has its own DSNDB06 database for maintaining authorization information. (To change locations, use the SET LOCATION TO command or change your default location on the Options dialog box.)
Parent topic: Security and Authority Overview


Stored Procedures

A stored procedure is a compiled program that can execute SQL statements. Stored procedures are stored at a local or remote XDB Server. Local XDB Server applications or remote DRDA applications can use the SQL statement CALL to invoke a stored procedure.

Design the application to use stored procedures if the application program operates in a client/server environment, and if either of the following two problems apply:

  • The application accesses host variables for which you want to guarantee security and integrity.
  • The application executes a series of SQL statements, creating many network send and receive operations, which significantly increase CPU and elapsed time costs.

Use of stored procedures removes SQL applications from the workstation, which prevents workstation users from manipulating the contents of sensitive SQL statements and host variables. The use of stored procedures also allows you to combine many of your application's SQL statements into a single message to the DB2 subsystem or XDB Server, reducing network traffic to a single send and receive operation for a series of SQL statements.

Note: If you are running your stored procedure on DB2 MVS, through the XDB Link product, then see your IBM DB2 documentation for other steps necessary to run the stored procedure.

To get a stored procedure up and running:

  1. Code and prepare a stored procedure. See Writing and Preparing Stored Procedures for instructions.
  2. Code and prepare an application that calls the stored procedure. An SQL statement, CALL, in that application must use the same parameter list and linkage convention as the stored procedure that it invokes. See Writing and Preparing Applications to Use Stored Procedures for instructions.
  3. Define your stored procedure to the XDB Server by issuing a CREATE PROCEDURE command, which will place a row in the appropriate SYSIBM table(s). See Defining Stored Procedures under SQL Option for additional details.
  4. Compile and define a LOADLIB entry for your stored procedure. The LOADLIB entry tells the XDB Server where your stored procedure is. See Compiling Stored Procedures under SQL Option for additional details.
  5. Debug and test your stored procedure. See Debugging Stored Procedures under SQL Option for additional details.
  6. Access mainframe tables using stored procedures under SQL Option. The steps necessary to do this are in Accessing Mainframe Tables With Stored Procedures.
  7. Check the current Limitations with Stored Procedures under SQL Option if you experience problems.
  • How an Application Works With a Stored Procedure
  • What You Can Do in a Stored Procedure
  • Preparing Stored Procedures
  • Executing the SQL Statement CALL
  • Linkage Conventions
  • Using Indicator Variables to Speed Processing
  • Declaring Data Types for Passed Parameters
  • Defining Stored Procedures under SQL Option
  • Compiling Stored Procedures under SQL Option
  • Debugging Stored Procedures under SQL Option
  • Accessing Mainframe Tables with Stored Procedures under SQL Option
  • Limitations with Stored Procedures under SQL Option
  • Stored Procedures Test Tool
Parent topic: SQL Option User Guide


How an Application Works With a Stored Procedure

A typical stored procedure contains two or more SQL statements, and some manipulative or logical processing that you cannot include in an SQL statement. In this example, your application, CALLSTPR, runs on a workstation client and calls a stored procedure, STPROC1. The following process occurs:

  1. The workstation application establishes a connection to the XDB Server.
  2. The SQL statement CALL tells the XDB Server that the application is going to run the stored procedure, STPROC1. The calling application provides the necessary parameters.
  3. The XDB Server searches the catalog table SYSIBM. SYSROUTINES for rows associated with stored procedure STPROC1.
  4. The XDB Server passes information about the request to the stored procedure.
  5. The stored procedure executes SQL statements.
  6. The stored procedure assigns values to the output parameters and then exits.
  7. Control returns to the calling application, which receives the output parameters. The XDB Server:
    • Closes all cursors that the stored procedure opened that weren't defined as WITH RETURN. Cursors that were defined as WITH RETURN are closed by the XDB Server when a COMMIT WORK command is issued if the WITH HOLD attribute was not declared on the stored procedure generated cursor.
    • Discards all SQL statements that the stored procedure prepared.
    • Reclaims the working storage that the stored procedure used.

    The application can call more stored procedures or it can execute more SQL statements.

  8. Once control is returned to the program that invoked the stored procedure, the XDB Server will treat all the work generated by the stored procedure (and subsequently by the calling program) as a single transaction.
Parent topic: Stored Procedures


What You Can Do in a Stored Procedure

A stored procedure is similar to any other SQL application.

The following restrictions apply to stored procedures:

  • Both C and COBOL stored procedures must be dynamic link library (DLL) files. See the appropriate language documentation for further information.
  • The XDB Server returns an SQL error code when a location other than the current location is used in an alias or three part name.
  • Do not include these SQL statements in your stored procedure:
    • COMMIT
    • SET CURRENT SQLID

    When these statements are encountered, it places the thread in a must roll back state. When control returns to the calling program, it must do one of the following things:

    • Execute the ROLLBACK statement, so that it is free to execute other SQL statements after rollback is complete.
    • Terminate, causing an automatic rollback of the unit of work.
Parent topic: Stored Procedures


Preparing Stored Procedures

The following are tasks which must be completed before a stored procedure can be run on an XDB Server:

  1. Prepare the application according to your embedded SQL documentation for creating stored procedure DLLs.
  2. Define the stored procedure to the XDB Server. See Defining Stored Procedures under SQL Option.
  3. Place the stored procedure DLL on the XDB Server machine in a location accessible by the XDB Server. The XDB Server uses the appropriate operating system call for loading the stored procedure, and searches the directory cited by the StProcLoadLib entry in the XDB.INI's server section for that stored procedure.
Parent topic: Stored Procedures
Related information
Defining Stored Procedures under SQL Option
Stored Procedures


Executing the SQL Statement CALL

Use the CALL statement to execute each series of SQL statements in your application. For example, to call the stored procedure described in How an Application Works With a Stored Procedure, your application might use this statement:

EXEC SQL
  CALL STPROC1
    (:V1, :V2)
END-EXEC

If you use host variables in the CALL statement, you must declare them before using them.

  • The example above is based on the assumption that none of the input parameters can have null values. To allow null values, code a statement like this:
    EXEC SQL
  CALL STPROC1 (:V1 :IV1, :V2 :IV2)
END-EXEC

    where :IV1 and :IV2 are indicator variables for the parameters.

  • To pass integer or character string constants or the null value to the stored procedure, code a statement like this:
    EXEC SQL
  CALL STPROC1 (2, NULL)
END-EXEC
  • To use a host variable for the name of the stored procedure, code a statement like this:
    EXEC SQL
  CALL :PROCNAME (:V1, :V2)
END-EXEC

    Assume that the stored procedure name is STPROC1. The host variable PROCNAME is a character variable of length 254 or less that contains the value STPROC1. You should use this technique if you do not know in advance the name of the stored procedure, but you do know the parameter list convention.

  • To pass your parameters in a single structure, rather than as separate host variables, code a statement like this:
    EXEC SQL
  CALL STPROC1 USING DESCRIPTOR :ADDVALS
END-EXEC

    where ADDVALS is the name of an SQLDA.

  • To use a host variable name for the stored procedure with an SQLDA, code a statement like this:
    EXEC SQL
  CALL :PROCNAME USING DESCRIPTOR :ADDVALS
END-EXEC

    This form gives you extra flexibility because you can use the same CALL statement to invoke different stored procedures with different parameter lists.

    Your client program must assign a stored procedure name to the host variable PROCNAME and load the SQLDA ADDVALS with the parameter information before making the SQL CALL statement.

Each of the above CALL statement examples uses an SQLDA. If you do not explicitly provide an SQLDA, the precompiler generates the SQLDA based on the variables in the parameter list.

You can execute the CALL statement only from an application program. You cannot use the CALL statement dynamically.

Parent topic: Stored Procedures


Linkage Conventions

When an application executes the CALL statement, the XDB Server builds a parameter list for the stored procedure, using the parameters and values provided in the statement. The XDB Server obtains information about parameters from the catalog table SYSIBM. SYSPARMS See Defining Stored Procedures under SQL Option for more information. Parameters are defined as one of these types in SYSIBM.ROUTINES:

IN | Input-only parameters, which provide values to the stored procedure
OUT | Output-only parameters, which return values from the stored procedure to the calling program
INOUT | Input/output parameters, which provide values to or return values from the stored procedure

If a stored procedure fails to set one or more of the output-only parameters, the XDB Server does not detect the error in the stored procedure. Instead, the XDB Server returns the output parameters to the calling program, with the values established on entry to the stored procedure.

The XDB Server supports the DB2SQL linkage convention, as cited in detail for the CREATE PROCEDURE command.

Parent topic: Stored Procedures
Related information
Defining Stored Procedures under SQL Option
Stored Procedures


Using Indicator Variables to Speed Processing

If any of your output parameters require a great deal of storage, it is wasteful to pass the entire storage areas to your stored procedure. You can use indicator variables in the calling program to pass only a two-byte area to the stored procedure and to receive the entire area from the stored procedure. To accomplish this, declare an indicator variable for every large output parameter in your SQL statement CALL.

Note:

If you are using the SIMPLE WITH NULLS linkage convention, you must declare indicator variables for all of your parameters, so you do not need to declare another indicator variable for the large output parameters.

Assign a negative value to each indicator value associated with a large output variable. Then include the indicator variables in the CALL statement. This technique can be used whether the stored procedure linkage is SIMPLE or SIMPLE WITH NULLS.

For example, suppose that a stored procedure, STPROC2 defined with the SIMPLE linkage convention takes one integer input parameter and one character output parameter of length 5000. It is wasteful to pass the 5000 byte storage area to the stored procedure. Instead, a COBOL program containing these statements passes only two bytes to the stored procedure for the output variable and receives all 5000 bytes from the stored procedure:

INNUM    PIC S9(9) COMP
OUTCHAR  PIC X(5000)
IND    PIC S9(4) COMP
.
.
.
MOVE -1 TO IND
EXEC SQL CALL STPROC2(:INNUM, :OUTCHAR :IND);
Parent topic: Stored Procedures


Declaring Data Types for Passed Parameters

A stored procedure must declare each parameter passed to it. In addition, the TYPENAME column of the catalog table SYSIBM.SYSPARMS must contain a compatible SQL data type declaration for each parameter. For TYPENAME string and corresponding language declarations, see the SQL data types table in the appropriate precompiler manual.

Parent topic: Stored Procedures


Defining Stored Procedures under SQL Option

A stored procedure is unusable until it is defined - use the CREATE PROCEDURE command to do this. At the command's conclusion, a record is placed in the SYSIBM.SYSROUTINES This record is used by the XDB Server when the stored procedure is executed.

The following is an example of a CREATE PROCEDURE command:

  create procedure MYAUTHID.STPROC1 (
             in    in1    char(4),
             out  out1  char(4),
             out  out2   smallint
   )
   external name STPROC1
   parameter style general with nulls
   language cobol
   collid  MYCOLLID
   result sets 1
   commit on return no
   ;

The create procedure statement must uniquely identify a stored procedure. You cannot have more than one row in SYSIBM.SYSROUTINES with the same values for the PROCEDURE, AUTHID, and LUNAME columns because the combination of PROCEDURE, AUTHID, and LUNAME uniquely identifies a stored procedure. You also will provide specific application information, such as what language the stored procedure is written in, whether you are using result-sets, what parameters are passed, and how they are passed.

Parent topic: Stored Procedures
Related reference
CREATE PROCEDURE
Related information
SYSIBM.SYSROUTINES


Compiling Stored Procedures under SQL Option

To compile a stored procedure under SQL Option, carry out the following steps:

  1. The project used for stored procedure development should always be declared as "Uses SQL". To indicate that an existing project uses SQL, click Project Settings on the Project menu, then select Project uses SQL on the SQL tab.
  2. The build settings for a particular program can be viewed and changed on the Visual Studio Properties page associated with the program.
  3. To use the ECM SQL preprocessor, check the Preproc tab of the Build Settings dialog box and ensure that EXEC SQL is checked. If additional directives are needed, for instance the PKGSET directive to emulate SET CURRENT PACKAGESET functionality, click the More button next to the EXEC SQL checkbox and specify the directives there.
  4. SQL Option requires a LOADLIB directory to be able to find .dll files that execute as stored procedures. When Studio Enterprise Edition compiles programs, it typically places the .dll files in a LOADLIB directory under the project directory.
Parent topic: Stored Procedures


Debugging Stored Procedures under SQL Option

You can request that the server invokes the debugger on all stored procedures by using a setting in the xdb.ini file in the \mfuser\config directory. In the xdb.ini server section, the StProcAnimate variable should be set to "yes" to have the server invoke the debugger on all stored procedures. The server reads this variable every time it starts. The server must be shutdown and restarted for changes to the StProcAnimate variable to take effect. The following is an example of what the variable should look like:

[CLIENT]
XDBCFG=c:\mfuser\config\
[SERVER]
XDBSERVE=myserver
XSRVCFG=c:\mfuser\config
StProcLoadLib=c:\mfuser\projects\MyProject\LOADLIB
StProcAnimate=yes
.
.
.

When the server invokes the debugger for a stored procedure, a second window opens, showing the stored procedure code. All stored procedures that are debugged after this point appear in a new second window.

Do not make changes to stored procedure source code in the second window, as this window does not have a current project and is useful only for debugging a stored procedure. After a stored procedure has been debugged in a second window you may close this window. A new window appears for each stored procedure you are debugging.

The server runs the stored procedure as a separate process. Each call to a stored procedure from a user application will result in a new process being started. However, the process that is created for scalar and table functions will exist and be reused by the server until the original query containing the scalar and/or table function has been closed. Now, every stored procedure that gets loaded (even if it is a second copy of the same stored procedure) will get a new debug session.

Once a stored procedure exits, the debugging session terminates and can be closed. However in the case of scalar and table functions, the same debugging session will be used for each pass through the stored procedure because the stored procedure doesn't actually exit until the scalar/table function calling it is no longer needed. The stored procedure will exit in this case when the query that originally invoked the scalar/table function is closed. In the case of scalar/table functions, a breakpoint should be set on the first statement in the program if you want to stop and debug on successive calls to the stored procedure.

Parent topic: Stored Procedures


Accessing Mainframe Tables with Stored Procedures under SQL Option

You can set up a special location to debug stored procedures under SQL Option and access mainframe tables from that stored procedure. Since the stored procedure must run under the XDB engine, the current location must be an SQL Option location. Access to DB2 tables and views is provided by using aliases.

To activate this functionality, the STProcRemoteAccess variable must be set to one in the server section of the xdb.ini file in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\mfsql\cfg directory. The following is an example of setting the STProcRemoteAccess variable:

[CLIENT]
XDBCFG=c:\mfuser\config\
[SERVER]
XDBSERVE=myserver
XSRVCFG=c:\mfuser\config
StProcLoadLib=c:\mfuser\projects\MyProject\LOADLIB;c:\mfuser\projects\MyProject2\LOADLIB
StProcAnimate=yes
STProcRemoteAccess=1
.
.
.

You can easily create aliases for mainframe tables using the CREATE ALIAS SQL command. If you can use a three-part name to select from a table on the mainframe, the CREATE ALIAS command can be used to alias that table.

For instance, if the following command returns rows:

select * from MFLOCATION.MYAUTHID.MYTABLE;

an alias can be created in the MYLOCAL location using the following command:

create alias MYAUTHID.MYTABLE for MFLOCATION.MYAUTHID.MYTABLE;

CREATE ALIAS statements can be generated using SQL SELECT statements and the remote locations metadata. For instance, the following query will generate CREATE ALIAS syntax for all tables in a DB2 location that don't have a creator of SYSIBM:

SELECT 'CREATE ALIAS '
                  CONCAT
                  STRIP(CREATOR, TRAILING, ' ') CONCAT '.' CONCAT NAME
                  CONCAT
                  ' FOR '
                  CONCAT
                  STRIP(CURRENT SERVER, TRAILING, ' ') CONCAT '.' CONCAT
                  STRIP(CREATOR, TRAILING, ' ') CONCAT '.' CONCAT NAME
                  CONCAT
                  ';'
FROM SYSIBM.SYSTABLES
WHERE CREATOR NOT IN ('SYSIBM')
ORDER BY 1
FOR FETCH ONLY;

If the above query is run under SPUFI, you must take care to set up the SPUFI defaults appropriately - you need to ensure that settings such as MAX SELECT LINES in SPUFI are set to enable all the rows to be returned. Using SPUFI, the output data set will have output that looks as follows:

---------+---------+---------+---------+---------+---------+---------+---------
CREATE ALIAS MYAUTHID.PROC_TEST_TAB_1 FOR CSIMVSDB2.MYAUTHID.PROC_TEST_TAB_1;
CREATE ALIAS MYAUTHID.PROC_TEST_TAB_2 FOR CSIMVSDB2.MYAUTHID.PROC_TEST_TAB_2;
CREATE ALIAS MYAUTHID.PROC_TEST_TAB_3 FOR CSIMVSDB2.MYAUTHID.PROC_TEST_TAB_3;

The query can be adjusted to retrieve the tables necessary by using sub-queries or joins to limit the data retrieved. The following is an example of generating CREATE ALIAS commands for all tables and views within a particular DB2 database. Note that this query will not retrieve tables in other databases that are referenced by the views.

SELECT 'CREATE ALIAS '
       CONCAT
       STRIP(CREATOR, TRAILING, ' ') CONCAT '.' CONCAT NAME
       CONCAT
       ' FOR '
       CONCAT
       STRIP(CURRENT SERVER, TRAILING, ' ') CONCAT '.' CONCAT
       STRIP(CREATOR, TRAILING, ' ') CONCAT '.' CONCAT NAME
       CONCAT
       '; -- ALIAS OF TABLE'
  FROM SYSIBM.SYSTABLES
 WHERE DBNAME = 'MYDB2DB'
   AND TYPE = 'T'
 UNION
SELECT 'CREATE ALIAS '
       CONCAT
       STRIP(SVDP.DCREATOR, TRAILING, ' ') CONCAT '.' CONCAT SVDP.DNAME
       CONCAT
       ' FOR '
       CONCAT
       STRIP(CURRENT SERVER, TRAILING, ' ') CONCAT '.' CONCAT
       STRIP(SVDP.DCREATOR, TRAILING, ' ') CONCAT '.' CONCAT SVDP.DNAME
       CONCAT
       '; -- ALIAS OF VIEW'
  FROM SYSIBM.SYSTABLES  STBL,
       SYSIBM.SYSVIEWDEP SVDP
 WHERE STBL.DBNAME = 'MYDB2DB'
   AND STBL.TYPE = 'T'
   AND STBL.CREATOR = SVDP.BCREATOR
   AND STBL.NAME  = SVDP.BNAME
 ORDER BY 1
   FOR FETCH ONLY
;

Because the stored procedure is running under the SQL Option engine and DB2 is being used only for the retrieval of data, certain operations must still be set up under the SQL Option engine. In particular, SET CURRENT PACKAGE SET commands must be set up under SQL Option. SET CURRENT PACKAGE SET commands will not be passed to the mainframe DB2 region since the identification of data entities must take place under the SQL Option engine. Additionally, SYNONYMS must be created on the SQL Option location if your DB2 processing uses SYNONYMS.

Parent topic: Stored Procedures


Limitations with Stored Procedures under SQL Option

You should be aware of the following limitations when working with stored procedures under SQL Option:

  • Stored procedures cannot be debugged when the XDB server is running as a service.
  • We recommend you do not use STOP RUN statements within a stored procedure. If you use STOP RUN instead of GOBACK you will receive a -471 sqlcode on the EXEC SQL CALL STATEMENT.

    Note that IBM also recommends against the use of STOP RUN statements in stored procedures. This is because in the DB2 subsystem, a STOP RUN terminates the Language Environment enclave, so the next time a DB2 stored procedure is called, the Language Environment enclave has to be rebuilt. This extra work being done by the DB2 region severely impacts the benefits of running the stored procedure as a DB2 subprogram.

  • Currently, the VALIDATE preprocessor directive will provide minimal assistance with stored procedure SQL statements (CALL, ASSOCIATE, ALLOCATE).
  • No support is provided for performing a PREPARE statement using ALLOCATE CURSOR or ASSOCIATE LOCATORS syntax. ALLOCATE CURSOR and ASSOCIATE LOCATORS statements must be embedded within the SQL language EXEC SQL ... END-EXEC delimiters. ALLOCATE CURSOR and ASSOCIATE LOCATORS statements cannot be dynamically prepared.
Parent topic: Stored Procedures


Stored Procedures Test Tool

The Stored Procedure Test tool (SP Test tool) makes the testing of stored procedures easier. It enables you to test various input values for a stored procedure, see the results, and optionally create test scripts without having to write COBOL code to invoke the stored procedure. However, if you want to invoke the stored procedure from a COBOL program, the tool also provides an option that enables you to generate such a program containing all of the required COBOL host variables.

The Stored Procedure Test tool also provides three wizards that enable you to generate both the SQL and the COBOL code for stored procedures, external table functions, and external scalar functions:

The SP Test tool accesses your stored procedures by connecting to the XDB server you specify, building a list of stored procedures and functions defined for that server.

  • Options
  • Testing a Stored Procedure
  • Test Scripts
  • Debugging a Stored Procedure
  • Generating a COBOL Program
  • Command Line Interface
  • How to...
Parent topic: Stored Procedures


Options

The SP tool comes configured to test your stored procedures using a set of default options. You can change the default options to customize the behavior of the SP Test tool. For example, you can set startup, execution and testing options, control the generation of COBOL code and certain files, specify a particular editor, specify directories, and set Wizard options.

You can set the following options to control the behavior of the SP Test tool. Default settings appear in a regular typeface. Non-default settings, directories and filenames appear bold. Read-only options are grayed-out.
Generate COBOL Code Generates a COBOL program that invokes:
  • The stored procedure
  • Result sets generated by the stored procedure
  • Host variables required to invoke the appropriate functions

Default: True

COBOL Specifies the directory where the SP Test tool stores the COBOL it generates, if any.

Default: %LOCALAPPDATA%

Input Saved Parameters Specifies the directory where the SP Test tool retrieves the XML file containing input parameters.

Default: %LOCALAPPDATA%

Output Saved Parameters Specifies the directory where the SP Test tool stores the XML file it generates containing output parameters.

Default: %LOCALAPPDATA%

Stored Procedures Specifies the debug directory for stored procedures. You must set this option before attempting to debug a stored procedure to prevent it from hanging during execution.

Default: %LOCALAPPDATA%.

Use Project Settings Specifies whether or not to apply the settings defined for the current project to the SP Test tool as well.

Default: False

Debug Stored Procedure Invokes the Debugger when you execute the stored procedure.
Note:
  • To successfully debug your stored procedure, you must start the XDB Server in blue screen mode.
  • This option is not saved when you save options.

Default: False

Editor for Side Files Optionally provide the full path and executable filename of a non-Micro Focus editor you want to use to edit side files.

Default: Blank

Allow Output Side Files Enable the SP Test tool to save output results in a side file rather than viewing them on-screen. This is useful when large amounts of data are returned for a parameter.

Default: False

Alternate Entry Map Name Optionally specify the path to a directory that contains entry point map files.

Default: Blank

Timeout

The amount of time in milliseconds to process requests, such as REFRESH, before being prompted to continue waiting. To turn this option off, set the value to 0.

Default: 5000 (equivalent to 5 seconds)

Automatically Save Input File Save input files in XML format, automatically generating input filenames based on the value of the Format Input Filename field. This option is automatically set to False if you have set the Format Input Filename to No Default Format, and is automatically set to True when Format Input Filename is set to either Stored Procedure name + “_IN_” + current date or Stored Procedure name + “_IN_” + number.

Default: True

Encoding of Side Files Specify the type of encoding to use for side files. Available types are:
  • ASCII
  • EBCDIC
  • UNICODE
Note:

If you specify EBCDIC, the tool translates the value to ASCII using the Micro Focus codeset defined for your machine.

Default: ASCII

Format Input File Name Set a default filename format for generated XML input files, or specify no default filename format. The XDB Stored Procedure Test tool uses the specified format for input files when Automatically Save Input File is set to True. The options are:
  • Stored procedure name + “_IN_” + number
  • Stored procedure name + “_IN_” + current date
  • No default format

Default: Stored procedure name + “ _IN_” + number

Format Output File Name Set a default filename format for generated XML output files, or specify no default filename format. The options are:
  • Stored procedure name + number
  • Stored procedure name + current date
  • No default format

Default: Stored procedure name + number

Generate Output File Name Save output files in XML format, automatically generating ouput filenames based on the value of the Format Output Filename field. This option is automatically set to False if you have set the Format Output Filename to No Default Format, and is automatically set to True when Format Output Filename is set to either Stored Procedure name + current date or Stored Procedure name + number.

Default: True

Refresh List on Startup Build a new list of stored procedures and functions each time you invoke the XDB Stored Procedures Test tool, saved to a local XML file. For this option to work properly, you must have the XDB Server started before you invoke the tool.
Note: We recommend disabling this option in cases where the time required to rebuild the list is prohibitive, for example, when connecting to a mainframe DB2 server using XDB LINK. When disabled, the tool presents the list from your previous session. You can then refresh the list manually by clicking Refresh list of stored procedures.

Default: True

Test Coverage Config File Specify the configuration file to use when executing the stored procedure in test coverage mode. This is only applicable if you have set the Use Test Coverage option to True.

Default: Blank

Use Test Coverage Specify whether or not the tool executes stored procedures in test coverage mode.

Default: False

Test Script Generation Set the tool either to write the commands used to test a stored procedure to an ASCII command file, or to not save the commands. The options are:
  • Automatically save commands
  • Prompt before saving
  • Don't save commands

See the section Test Scripts for more information.

Default: Automatically save commands

Abend Options Specifies the behavior of the routine when it encounters a failure. The options are as follows:
  • Use Default Setting
  • STOP AFTER SYSTEM DEFAULT FAILURES
  • STOP AFTER nn FAILURES
  • CONTINUE AFTER FAILURE
Note: If you select STOP AFTER nn FAILURES, you must specify the number of failures (represnted by "nn") in the Abend field on the Wizard's Specify Options page.

Default: Use Default Setting1

ASU Time | Specifies the total amount of processor time, in CPU service units, that a single invocation of the routine can run. Default: 0
Commit on Return Specifies whether or not DB2 commits the transaction immediately upon return from the routine. The options are:
  • Use Default Setting
  • YES
  • NO

Default: Use Default Setting1

DBINFO Parameter Specifies whether or not additional status information is passed when the routine is invoked.
Note:

This parameter is used only when the Parameter Style option is set to SQL.

Default: False

DETERMINISTIC | Specifies whether or not the routine returns the same results each time it is called with the same IN and INOUT arguments. Default: False
Dynamic Result Sets | Specifies the maximum number of result sets that the routine can return. Default: 0
Execute on FINISH | Specifies whether or not the Wizard executes the generated routine when you click Finish. Default: False
Fenced | Specifies whether or not the routine runs in an external address space to prevent user programs from corrupting DB2 storage. Default: False
Parameter CCSID Specifies the encoding scheme for string parameters. The options are:
  • ASCII
  • EBCDIC
  • UNICODE

Default: EBCDIC

Parameter Style Specifies the linkage convention used to pass parameters to and return values from the routine. The options are:
  • GENERAL
  • GENERAL WITH NULLS
  • SQL

Default: GENERAL

Language Specifies the language used to interface with the routine. The options are:
  • COBOL
  • C
  • PLI
  • ASSEMBLER
  • REXX

Default: COBOL

Run-time options | Specifies the Language Environment run-time options for the routine. Default: none (blank)
Security Specifies how the routine interacts with an external security product to control access to non-SQL resources. The options are:
  • Use Default Setting
  • DB2
  • USER
  • DEFINER

Default: Use Default Setting1

SQL Statement Defaults Specifies which SQL statements, if any, can be executed in this routine or any routine that is called from this routine. The options are:
  • Modifies SQL Data
  • Reads SQL Data
  • Contains SQL
  • No SQL

Default: Modifies SQL Data

Stay Resident Specifies whether or not the routine's load module remains resident in memory when the routine ends.

Default: False

Use Default Special Register Specifies whether or not special registers are initialized to the default values.

Default: False

WLM Environment Specifies the name of the WLM (workload manager) environment in which the routine is to run when the DB2 stored procedure address space is WLM-established.

Default: Blank

1The default setting for this option depends on the type of code the Wizard is generating - stored procedure, external table function, or external scalar function. The default setting for each type of code is that which appears in the field corresponding to this option when you first invoke the Wizard's Specify Options page.

Note: You can override Wizard options on the Specify Options page of each wizard.
Parent topic: Stored Procedures Test Tool


Testing a Stored Procedure

Once you have started and configured the SP Test tool, you are ready to test your stored procedures. These are listed on the IDE by schema name in the tree view on the left under Stored Procedures. The procedure to test a stored procedure is as follows:

  1. Set input and output parameters
  2. Specify filenames for generated files
  3. Execute the stored procedure
  4. Read the results
  • Setting Input and Output Parameters
  • Specifying Filenames for Generated Files
  • Executing a Stored Procedure
  • Testing with Third-party Software
  • Reading Test Results
  • Displaying Saved Results
Parent topic: Stored Procedures Test Tool


Setting Input and Output Parameters

You can optionally provide a value for each input and/or output parameter associated with the stored procedure. All parameters defined in a stored procedure selected in the tree view appear on the Parms tab. Input parameters are identified by either a P (for input) or a B (for input/output) in the I/O column. Output parameters are identified by an O in the I/O column.

You assign a value to an input parameter using one of the following methods:

  • Type the value directly into the Value field
  • Type the value into the Edit Entry Value editor
  • Specify a side file (.dat file) to contain the value
  • Specify a special register that defines the value

If you want to store the value of an output parameter as the stored procedure executes, set the Allow Output Side Files option to True. This enables you to specify a side file or a special register to hold the value.

Note: If you want to specify an EBCDIC side file to contain the value but do not already have one available, you can create one.
Parent topic: Testing a Stored Procedure


Specifying Filenames for Generated Files

You can set your options to automatically generate filenames for XML input and output files, and to also automatically generate a filename for generated COBOL code using default file naming conventions. However, you can also specify your own filenames for these files from the Files tab.

Parent topic: Testing a Stored Procedure


Executing a Stored Procedure

You must have specified a default filenaming convention for input and output files via the Options dialog box or have specified input and output filenames via the Files tab before your stored procedure will execute. If no filename or filenaming convention is specified, the SP Test tool calls the Files tab before executing the stored procedure, requiring you to specify the appropriate filenames at that time.

The results of the stored procedure execution are automatically displayed on the Results tab following execution.

Parent topic: Testing a Stored Procedure


Testing with Third-party Software

You can use the SP Test tool to generate an ASCII or a hexadecimal text string command that can run your stored procedure in a third-party test tool. Before generating the command, be sure you have specified all of the appropriate input parameters.

Parent topic: Testing a Stored Procedure


Reading Test Results

The Results tab shows you the following information:

Type or RS Name

Shows whether this is a parameter or a result set. Result set names correspond to the cursor name defined in the DECLARE CURSOR statement.

Data Name

The parameter name or the column name of the data in the result set.

Row Number

Parameters display a row number of 0; result sets display the row number fetched from the result set that corresponds to the cursor name defined in the DECLARE CURSOR statement.

Value

  • Input - the value of the input parameter
  • Output - the value of the output parameter
  • Input only side file - the value that was found in the side file
  • Input/Output or Output side file - the side file name
  • Special register - the name of the special register (not the value of the special register)
Note:

Reporting the name of the special register rather than its value makes it somewhat easier to do regression testing in that you get consistent results when using special registers such as CURRENT DATE.

Parent topic: Testing a Stored Procedure


Displaying Saved Results

In addition to viewing the results each time you test a stored procedure, you can also view the results of any previously run stored procedure using the Display Saved Results command. This command enables you to choose any saved XML output file for viewing on the Results tab or on one or more customized tabs. Each customized tab displays one result set, and the name of the tab is the same as the SQL cursor name used to produce the result set. All information on customized tabs is displayed in a familiar tabular format with column names in the data grid taken from the columns names used in the query that selected the data.

Parent topic: Testing a Stored Procedure


Test Scripts

You can save the commands that the SP Test tool uses to test a stored procedure as a script that you can execute without having to reset options, input and output parameters, or filenames. This enables you to easily retest your stored procedures.

Test scripts are saved as ASCII command files in the following format:

TEST_storedprocedurename.cmd

Test script files are stored in the same directory as is specified for the COBOL option on the Options dialog box.

Each script includes the input and output file names used when the stored procedure is executed. The following is an example test script named TEST_GETEMPD.cmd:

MFXDBRUNSP IN=G:\temp\xml\GETEMPD_IN_0001.xml; OT=G:\temp\xml\GETEMPD_OUT_0001.xml;
MFXDBRUNSP IN=G:\temp\xml\GETEMPD_IN_0002.xml; OT=G:\temp\xml\GETEMPD_OUT_0002.xml;

This script runs two commands, one using XML input file GETEMPD_IN_0001.xml and another using XML input file GETEMPD_IN_0002.xml. The “OT” token specifies an output XML file.

The SP Test tool automatically creates a script file for each stored procedure you execute if you set the Test Script Generation option to Automatically save commands or Prompt before saving.

You can edit a generated test script in any text editor. You can also write your own test scripts by creating a command file that invokes individual stored procedure test scripts. See the topic Command Line Interface for additional commands you can specify in a test script.

Parent topic: Stored Procedures Test Tool


Debugging a Stored Procedure

The SP Test tool enables you to debug stored procedures without stopping the XDB server and then re-starting it. You can accomplish this in one of two ways. You can set the Debug Stored Procedure option to True. When this option is true, the context menu for the stored procedure appears with a check mark to the left of the Debug the Stored Procedure menu option. In this case, the SP Test tool debugs the stored procedure each time you run it. Alternatively, if the Debug Stored Procedure option is set to False, you can debug the stored procedure by selecting Debug the Stored Procedure from the context menu.

Note: You still need to use the XDB blue screen server if you debug from within the IDE.
Parent topic: Stored Procedures Test Tool


Generating a COBOL Program

When you set the Generate COBOL Code option to True, the SP Test tool automatically generates a COBOL program that calls the stored procedure. This COBOL program reflects the extent to which code was executed when you ran the stored procedure. If an error occurs within the stored procedure, the generated program is incomplete.

You can view the generated program on the Code tab after the stored procedure executes. Parameter values are generated as host variable names unless you specified a special register. In that case the special register name is generated as part of the EXEC SQL CALL statement. For example:
EXEC SQL
  CALL GETEMPD2 (CURRENT TIMESTAMP - 255 DAYS, :GETEMPD2-RSLT)
END EXEC
Parent topic: Stored Procedures Test Tool


Command Line Interface

You can run stored procedures generated by the SP Test tool from the command line using the following syntax:
inputfilename; OT=<outputfilename; CD=<COBOLfilename
Where inputfilename is the full path to and filename of the XML input file, outputfilename is the full path to and filename of the XML output file, and COBOLfilename is the name of the generated COBOL program file. To execute multiple commands separate each command with a semi-colon (;).
Parent topic: Stored Procedures Test Tool


To start the Stored Procedure Test tool

  • Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 > Client > Stored Procedure Tool.
Parent topic: How to...


To set Stored Procedure Test tool options

  1. From the SP Test tool toolbar, click Options Options.
  2. Scroll to the option you want to set and click its corresponding field in the right-hand column.
  3. Change the value in this field using one of the following mechanisms, depending on which is available:
    • Type a value directly into the field
    • Browse to a path and/or filename by clicking Browse Browse
    • Select a value from the drop-down menu
Note: Default settings appear in a regular typeface. Non-default settings, directories and filenames appear bold. Read-only options are grayed-out.
Parent topic: How to...


To edit the list of stored procedures displayed

  1. From the SP Test tool, right-click anywhere on the tree view; then click Edit List of Stored Procedures Displayed.
  2. If you have checked Also remove from database, the SP Test tool invokes the File Name to Save Drop Commands dialog box. Here, you specifiy the name of a command file that the SP Test tool generates to drop the checked stored procedures from their XDB location(s). The SP Test tool executes this command file when you click Save.
  3. Check the box to the right of each stored procedure you want to remove from the list.
  4. If you want to remove the checked stored procedures from the repository as well as the displayed list, check Also remove from database (optional).
  5. Click Remove to remove the checked stored procedures.
Note: If you leave Also remove from database unchecked, stored procedures you have removed from the list reappear when you start the Stored Procedure Test tool again, or when you click Refresh list of stored procedures Refresh list of stored procedures.
Parent topic: How to...


To specify an input parameter value for a stored procedure

  1. From the SP Test tool, click a stored procedure on the tree view.
  2. On the Parms tab, click the Value column corresponding to the parameter whose value you want to specify.
  3. Type the value of the parameter.
  4. Tab to another column to ensure that the value is saved properly.
Note:
  • Numeric parameter values must be valid for the stored procedure to execute properly.
  • You can also specify a value using the Edit Entry Value editor or by specifying a side file or special register.
  • Values typed directly into the Value field or into the Edit Entry Value editor are limited to the length of the parameter.
Parent topic: How to...


To edit an input parameter value for a stored procedure

  1. From the SP Test tool, click a stored procedure on the tree view.
  2. On the Parms tab, right-click the Value column corresponding to the parameter whose value you want to edit, then click Edit value.
  3. In the Edit Entry Values editor, type the value of the parameter.
  4. Click OK.
  5. Tab to another column to ensure that the value is saved properly.
Note:
  • To view or enter the value in hexadecimal, check Display value in hexadecimal.
  • Numeric parameter values must be valid for the stored procedure to execute properly.
  • You can also specify a value by entering it directly into the Value column or by specifying a side file or special register.
  • Values typed directly into the Value field or into the Edit Entry Value editor are limited to the length of the parameter.
Parent topic: How to...


To specify a side file for a parameter value

  1. From the SP Test tool, click a stored procedure on the tree view.
  2. On the Parms tab, right-click the Value column corresponding to the parameter whose value you want to edit, then click Insert side file.
  3. Navigate to the side file (.dat file) you want to use, or type the full path and filename of the side file into the File name field, then click Open.
  4. On the SP Test tool IDE, tab to another column to ensure that the value is saved properly.
Note:
  • The side file specification appears in the Value column in the following format:

    <SF=path/filename>

    If you have set the Encoding of Side Files option to EBCDIC, <ENC=E> is appended to the end.

  • Numeric parameter values must be valid for the stored procedure to execute properly.
  • For input parameters, you can also specify a value by entering it directly into the Value column, using the Edit Entry Values editor, or by specifying a special register.
  • You cannot specify a side file to store an output parameter value unless you have set the Allow Output Side Files option to True.
Parent topic: How to...


To specify a special register for a parameter value

  1. From the SP Test tool, click a stored procedure on the tree view.
  2. On the Parms tab, right-click the Value column corresponding to the parameter whose value you want to edit, then click Insert special register.
  3. From the drop-down menu that appears, click the special register you want to use to store the parameter value.
  4. Click Insert special register again to paste the reference into the Value column.
Note:
  • The special register specification appears in the Value column in the following format:

    <SR=specialregistername>

    Do not manually modify the SR= portion of this specification. Doing so can cause the stored procedure to execute improperly.

    However, you can modify the specialregistername portion of the specification by typing over it. For example, if you selected the CURRENT DATE special register, you could modify it to be CURRENT DATE - 100 DAYS which is then used instead of CURRENT DATE. Be advised that modified special registers cannot be validated.

  • Numeric parameter values must be valid for the stored procedure to execute properly.
  • For input parameters, you can also specify a value by entering it directly into the Value column, using the Edit Entry Values editor, or by specifying a side file.
  • You cannot specify a special register to store an output parameter value unless you have set the Allow Output Side Files option to True.
Parent topic: How to...


To specify input, output, and generated COBOL filenames

  1. From the SP Test tool, click a stored procedure on the tree view.
  2. On the Files tab in the appropriate field, type the full path to and filename of the file you want to specify, or click the field's corresponding Browse Browse button to navigate to and select an appropriate file.
Note:
  • The Files tab automatically appears when you run a stored procedure for which no input or output filenames have been specified either directly or by selecting filenaming conventions via the Options dialog box, enabling you to specify these filenames at that time.
  • If you have set your Options to automatically generate COBOL code but have not specified a filename on the Files tab, the Files tab appears automatically when you run the stored procedure, enabling you to specify the filename at that time.
Parent topic: How to...


To execute a stored procedure

  • From the SP Test tool, click a stored procedure on the tree view, then click Run Run.
Note:
  • The Files tab automatically appears when you run a stored procedure for which no input or output filenames have been specified either directly or by selecting filenaming conventions via the Options dialog box, enabling you to specify these filenames at that time.
  • If you have set your Options to automatically generate COBOL code but have not specified a filename on the Files tab, the Files tab appears automatically when you run the stored procedure, enabling you to specify the filename at that time.
  • If you have set the Prompt Save Script option to True, you are prompted after the stored procedure executes to save or not save the command in the test script. If the stored procedure encounters errors while executing you do not receive this prompt.
Parent topic: How to...


To generate a stored procedure

  1. Start the Stored Procedure Test tool.
  2. Click Create a new Stored Procedure Create new stored procedure.
  3. Complete each page of the Wizard. For help on a specific page and help on a specific field or control on a page, click Help.
Note: The Wizard writes one COBOL and one SQL file containing the generated code. The location of these files is specified in your SP Test tool Options, and the filenames are as follows:
  • SQL file - procedurename.sql
  • COBOL file - procedurename.cbl
Parent topic: How to...


To display saved results from output XML

  1. From the SP Test tool tree view, right-click the Stored Procedure for which you want to display saved results; then click Display Saved Results.
  2. From the Select Results to be Displayed dialog box, click the XML output file that contains the results you want to display; then click Open.
  3. Click the customized tab for the result set you want to view.
  4. Use Next and Previous to browse through the results sets.
Parent topic: How to...


To generate a test command

  1. From the SP Test tool tree view, right-click the Stored Procedure for which you want to generate a test command; then click Generate Test Command.
  2. From the Generate Stored Procedure Test Command dialog box, highlight the generated command.
  3. Right-click the highlighted command and click copy or cut from the menu.
    Note: If you want a hexadecimal equivalent for the command, check Display value in hexadecimal before copying or cutting the command.
  4. Click OK to close the Generate Stored Procedure Test Command dialog box.
  5. To run the command, paste it into an appropriate place in the third-party test tool of your choice and run it according to the instructions for that test tool.
Parent topic: How to...


To generate an external table function

  1. Start the Stored Procedure Test tool.
  2. Click Create a new (external) Table Function Create new table function.
  3. Complete each page of the Wizard. For help on a specific page and help on a specific field or control on a page, click Help.
Note: The Wizard writes one COBOL and one SQL file containing the generated code. The location of these files is specified in your SP Test tool Options, and the filenames are as follows:
  • SQL file - functionname.sql
  • COBOL file - functionname.cbl
Parent topic: How to...


To generate an external scalar function

  1. Start the Stored Procedure Test tool.
  2. Click Create a new (external) Scalar Function Create new scalar function.
  3. Complete each page of the Wizard. For help on a specific page and help on a specific field or control on a page, click Help.
Note: The Wizard writes one COBOL and one SQL file containing the generated code. The location of these files is specified in your SP Test tool Options, and the filenames are as follows:
  • SQL file - functionname.sql
  • COBOL file - functionname.cbl
Parent topic: How to...


SQL Option Server Administration Guide

The XDB Server, utilizing a high performance SQL engine, supports multiple locations and multiple databases within a location. The XDB Server, when combined with accompanying client software, provides a full-featured, client-server based database management system. The XDB Server and client software are available for a variety of operating platforms. In all cases, responsible parties need to understand the storage architecture and the various system and user configuration parameters.Note:If you want to access mainframe DB2 data directly, your system administrator must first install and configure a number of SQL connectivity components. Once this is done, your system administrator can advise you how to connect to mainframe data.

  • Client-Server Architecture
  • Advantages of Using SQL Option Server
  • Storage Architecture
  • Basic Tasks
  • Server Configuration Utility
  • Monitor Utility
  • Security and Authority
  • Server-to-server Connectivity
  • Multiserver Security
  • Backup and Recovery
  • Storage Requirements
  • Performance Tuning
  • Location Management
  • Environment Variables
  • Server Files
  • Troubleshooting
Parent topic: SQL Option for DB2


Client-Server Architecture

The XDB Server makes use of a client-server architecture, which allows an application to be split into front-end (client) and back-end (server) components. The front-end components correspond to the end user's view of the application. The back-end is the XDB Server, which performs the actual database processing functions.

The front-end and back-end can reside on the same machine or they can be installed on a back-end server machine, with front-end client sessions initiated from separate workstations.

Parent topic: SQL Option Server Administration Guide


Advantages of Using SQL Option Server

There are many advantages to using the XDB Server. A server allows people throughout the organization to share data and resources. With the database server located on a separate machine, more memory is available on client machines for other applications. The XDB Server also allows the transparent integration of clients and servers running different operating systems. The server's security system allows for a separation of responsibilities and access privileges, if desired.

Distributed processing and server-to-server connectivity are supported. This allows the user of a single-workstation XDB Server, for example, to access data from other XDB Servers.

Parent topic: SQL Option Server Administration Guide


Storage Architecture

The XDB Server uses a logical storage architecture modeled after the architecture used by IBM's DB2. This architecture allows you to use the same three-part naming conventions (location-name.authid.object-name) typically used on the mainframe.Because much of the physical storage architecture employed on the mainframe has no equivalent in PC environments, the physical storage between the environments differs significantly. However, the physical implementation of the XDB Server generally makes these differences transparent to the user.The XDB Server allows you to explicitly define where data is to be stored or to use the system-generated defaults. With either method, data is accessed by using the logical names of objects, not by referencing the physical storage locations. The XDB Server performs the mapping between physical and logical layers automatically.

  • Locations
  • Storage Groups (Stogroups)
  • Databases
  • Table Spaces, Tables, and Indexes
  • Summary and Example
Parent topic: SQL Option Server Administration Guide


Locations

At the highest level of the logical storage hierarchy is the location. You can have multiple locations defined and available under one copy of the XDB Server software. This differs slightly from the IBM DB2 concept of locations, but the naming convention of location-name.authid.object-name is the same on both platforms.

Note: Do not copy, alter, or move the files in locations. Doing so can corrupt the system location and jeopardize all the data managed by the XDB Server.
  • Mainframe DB2 Location (Subsystem) Structure. On a mainframe, each copy of DB2 software (subsystem) is assigned its own location name. There may be one or more databases (each containing multiple tables) within a location. Each database can have one or more table spaces and tables, with associated index spaces, indexes, views, and synonyms.

    A system catalog (a set of catalog tables) maintains information about each table and database and its components, including which tables belong to which databases and where objects are located on disk. There is one system catalog per copy of DB2 software (one catalog per location or subsystem).

  • XDB Location Structure. One XDB Server can manage one or more locations. A system location is provided by default. The "super" user (usually the database or system administrator) can create other locations.

    Like the mainframe, there may be one or more databases within a location. Each database can have one or more table spaces and tables, with associated indexes, views, and synonyms.

A system catalog database called DSNDB06 resides in each location to maintain information about the location and all tables and databases in that location, including which tables and indexes belong to which databases and where objects are located on disk. The system location also contains two other system-related databases: DSNDDF and XDBACF. The DSNDDF database contains tables such as SYSXDB.SYSLOCALS and SYSIBM.SYSLOCATIONS which together serve as an index to local and remote locations. The XDBACF database contains tables for system security.

Each location, including the system location, also contains a DSNDB04 database. This database is the default database for storing tables and other objects that a user creates without specifying a database name.

The mainframe system catalog tables have a two-part name, using SYSIBM as the AuthID qualifier (for example, SYSIBM.SYSDATABASES and SYSIBM.SYSTABLES). The XDB Server uses this same AuthID for all system tables that have a corresponding table on DB2. The XDB Server has additional system catalog tables that have no counterparts on mainframe DB2. These catalog tables are prefixed with the SYSXDB AuthID (except SYSIBM.SYSXDBMAP).

When you install the XDB Server, the system catalog databases in the SYSTEM location are stored in subdirectories under the SYSTEM subdirectory of your XDB Directory. (Your "XDB Directory" refers to the directory where you installed the XDB Server and related executable software.)

Note: Do not run DDL files in the SYSTEM location.

For example, if you install the XDB Server in c:\xdb\ , then the system databases will be placed in the following subdirectories:

  • c:\xdb\system\dsndb06\
  • c:\xdb\system\dsndb07\
  • c:\xdb\system\dsnddf\
  • c:\xdb\system\xdbacf\
  • c:\xdb\system\dsndb04\

Whenever you create a new location you must specify a Location Name (up to 16 characters long) according to the following guidelines:

  • You must place your data tables in locations other than the system location. (You can have one or more databases and/or tables per location.)
  • Two locations with the same name cannot exist simultaneously under the same XDB Server (or engine). An error message is presented if you attempt to create a location using an existing location name.
  • If Distributed Unit of Work (DUW) processing is anticipated, location names must be unique across the entire system, that is, across the multiple servers and/or geographic sites that will be included in remote processing activities. (See Distributed Processing for more information.)

In addition to specifying a location name when you create a new location, you must also specify a directory for it on disk, according to the conventions for your operating system. For example, you could use the command:

 CREATE LOCATION locat1 IN c:\xdb\locat1

When you issue this command, the XDB Server creates the directory on disk and adds information about the new location to the SYSXDB.SYSLOCALS and the SYSIBM.SYSLOCATIONS tables in the SYSTEM location. Other options are available on the CREATE LOCATION command to allow you to specify the sort sequence, forward log name and other items. You can edit the SYSXDB.SYSLOCALS table to change these parameters.

Note: In an XDB database, the sort sequence (EBCDIC, ASCII, etc.) is defined when the location is created. You can change the sort sequence of a location with the ALTER LOCATION command.

You can execute the following utility command any place you can issue SQL commands to specify the current location:

SET LOCATION TO location-name

Your default current location is maintained in your client configuration. See the setup and configuration documentation that came with your client application for details. If you want to use or create objects in a location other than your current location, use SET LOCATION TO prior to entering your other SQL statements. In embedded SQL, and to access remote locations, you must use the CONNECT command.

Note: Distributed Unit of Work (DUW) Processing is also available for accessing data in locations other than your own. See Distributed Processing for more information.
Parent topic: Storage Architecture


Storage Groups (Stogroups)

On a mainframe system, Storage Groups (Stogroups) provide a means of specifying the physical DASD volume where data will be stored. The XDB Server provides an analogous function by allowing you to associate a drive and pathname with a stogroup name.

You can define one or more stogroups in each location as needed. Later, when you create a database or table space in a location that has one or more stogroups defined, you can specify a stogroup to be used for storing the database or table(s). Thus, you can specifically define the physical location (on what volume-- disk drive and directory) of each database or table space.

Note: Use of stogroups is optional. Once you define a location directory, subdirectory paths for other objects are created automatically as needed when you create the objects (for example, CREATE DATABASE). The XDB System Catalog keeps track of where objects are stored for each location and database.

To use stogroups to their full advantage, you must create the path(s) on your operating system. Then use the CREATE STOGROUP command to specify the drive and path name to be associated with a stogroup name. Lastly, modify two columns in the SYSIBM.SYSVOLUMES table to define the path to the XDB Server. (It is also possible to define a stogroup without assigning a path in SYSIBM.SYSVOLUMES. This provides compatibility with mainframe DB2 in terms of maintaining the stogroup-related entries in system tables but allows the XDB Server database software to use its default path creation and naming routines.)

If you do not specify a path in SYSIBM.SYSVOLUMES and/or you do not specify stogroups for your table spaces, the XDB Server will create a subdirectory under the location name directory to store your database files when you create the database. A typical database path created by the XDB Server could be :\XDB\LOCAT1\DBNAME\ .

Note: The XDB SYSIBM.SYSVOLUMES table contains two columns that are not included in the analogous DB2 table. These columns are XDBPRIMEVOLPATH and XDBVOLPATH.

See the SQL Reference for detailed information regarding the storage structure and naming conventions that apply when creating various table and database objects, with and without stogroups.

Example

The following CREATE commands will create two storage groups (named STOR1 and STOR2) on two separate disk volumes (named MINE and YOURS). The UPDATE commands will then define the disk drive and directory for each of the named volumes.

CREATE STOGROUP stor1 VOLUMES (mine) VCAT xdb;
CREATE STOGROUP stor2 VOLUMES (yours) VCAT xdb;
UPDATE SYSIBM.SYSVOLUMES
    SET XdbPrimeVolPath = "y",
        XdbVolPath = "d:\stor1\"
    WHERE Volid = "mine";
UPDATE SYSIBM.SYSVOLUMES
    SET XdbPrimeVolPath = "y",
        XdbVolPath = "e:\stor2\"
    WHERE Volid = "yours";

Before you can create databases or table spaces in these stogroups, you must create the two directories (d:\stor1 and e:\stor2).

Note: The VCAT parameter is required only when running in DB2 compatible mode. It is checked for syntax only, and recorded in the appropriate system table.

To complete this example, you would use CREATE commands such as the following to specify storage locations for objects you create:

CREATE DATABASE xyz stogroup STOR1;

or

CREATE TABLESPACE abc IN xyz
    USING STOGROUP stor1;
Parent topic: Storage Architecture


Databases

A database object is a 1-to-8 character name assigned to a collection of tables and indexes. When creating a database (without specifying a stogroup) the XDB Server also creates a subdirectory on disk using the database name. The subdirectory is created under the directory of the current location. (For example: c:\xdb\locat1\dbname )

When you create a table, you can specify the name of the database with which you want it to be associated. If you are using table spaces, you specify the name of the database and table space. If you do not specify a database name, then the tables and other objects are stored in the DSNDB04 default database which is automatically included in each location.

If you have defined stogroups (see above), you can specify which stogroup should be the default stogroup for the database. The directory (path) defined for that stogroup will then be used to store the various database files (tables, indexes, etc.).

If you do not specify a stogroup for the database, the XDB Server uses the default stogroup (SYSDEFLT) which causes files for database objects to be stored under the ..\location-name\dbname\ structure described above. (It is also possible to specify a stogroup for each table space that you define for your tables and indexes, if you use table spaces.)

See the SQL Reference for detailed information regarding the storage structure and naming conventions that apply when creating various database objects with and without stogroups.

Parent topic: Storage Architecture


Table Spaces, Tables, and Indexes

On a mainframe system, table spaces and stogroups provide a means of organizing tables and indexes on specific disk storage devices. Generally, each table space and index is associated with a stogroup. A table can be created within a specific table space, which associates the table with the stogroup of the table space. When an index is created, it can be associated with a stogroup as well.

The XDB Server supports the table space/stogroup structure, and provides syntactical/semantic support for relating an index to a stogroup.

Note: Use of table spaces and stogroups is optional. If you choose to specify table spaces, you can do so with or without stogroups.

If you have defined stogroups in an XDB database, you can specify which stogroup should be used when you create a table space. For example:

CREATE TABLESPACE brspace
    IN databas1 USING STOGROUP stor1;

When you create tables and indexes in a database, use either or both of the following methods:

  • Allow the XDB Server to define table spaces and directory paths for the tables and indexes you create. For example:
    CREATE TABLE branch
    ( fld1 SMALLINT, fld2 CHAR 1 )
    IN databas1;
CREATE INDEX brindex ON branch(fld1);

    If the database has a stogroup defined, the XDB Server uses its path to store the table and index files.

    If the database does not have a stogroup defined, the XDB Server uses the SYSDEFLT stogroup routine which uses the ..\location-name\database-name\ path structure. In this situation, the XDB Server creates table and index files under the database-name subdirectory to store each table and index. For example:

    • c:\xdb\locat1\databas1\branch.tab
    • c:\xdb\locat1\databas1\brindex.idx
    • c:\xdb\locat1\databas1\brindex.ptr

    The table space name will be the first eight characters of the table or index name, as appropriate. If the eight character name would duplicate an existing table space name, the system creates a unique name for the table space.

  • Specify a pre-defined table space for a table. The index will be placed in the table space where its associated table resides. For example:
    CREATE TABLE branch
    ( fld1 SMALLINT, fld2 CHAR 1 )
    IN databas1.brspace;
CREATE INDEX brindex ON branch(fld1);

    In this case, all tables you create with the named table space will be stored under the stogroup directory that was defined for the table space. Indexes created on those tables will be stored in the same stogroup path.

    For example:

    • d:\stor1\branch.tab
    • d:\stor1\brindex.idx
    • d:\stor1\brindex.ptr
Note:

If your database is the default DSNDB04 database, you do not have to specify the database name in the above commands.

Any table you create without specifying a database name will be placed in DSNDB04 automatically.

To summarize, when you create a table, you usually specify the database in which you want it to be created. Optionally, if you created table spaces in the location, you can specify a table space name in which to store the data. The system catalog keeps track of which tables belong to each database and where they are located on disk.

When you create an index, you specify the table to which it applies. Again, the system catalog keeps track of which indexes belong to each database and table, and where they are located on disk.

See the SQL Reference for detailed information regarding the storage structure and naming conventions that apply when creating various database objects with and without stogroups.

Example

In this example, a database and two table spaces are created in the current location. The first table space does not specify a stogroup, and thus the default database subdirectory will be used to store tables for this table space ( c:\xdb\locat1\dbname\ ). The other table space will reside in one of the previously defined stogroup directories ( d:\stor1 ).

Notice that when tables are defined, they are qualified with an IN clause to specify to which database they belong (and optionally, which table space should be used to store the physical data). In this example, the first two tables use specific table spaces. The third table is defined without a table space. The index for the BRANCH table will reside in the same table space as the BRANCH table.

CREATE DATABASE databas1;
CREATE TABLESPACE brchspc IN databas1;
CREATE TABLESPACE acctspc IN databas1
    USING STOGROUP stor1;
CREATE TABLE branch (
           BRANCH_ID   INTEGER,
           BRANCH_BAL  DECIMAL(15,2) )
    IN databas1.brchspc;
CREATE INDEX BIDX ON BRANCH(BRANCH_ID);
CREATE TABLE account (
           ACCT_ID     INTEGER,
           BRANCH_ID   INTEGER,
           ACCT_BAL    DECIMAL(15,2) )
    IN databas1.acctspc;
CREATE TABLE history (
           ACCT_ID     INTEGER,
           BRANCH_ID   INTEGER,
           ACCT_BAL    DECIMAL(15,2) )
    IN databas1;
Parent topic: Storage Architecture


Summary and Example

The XDB Server fully supports the naming conventions and data storage structures that are available on a mainframe DB2 subsystem. Features include the following structures and objects:

  • Locations
  • Storage Groups
  • Databases
  • Table Spaces
  • Tables
  • Indexes

Example

The following is a scenario for creating a new location with two databases. Each database has a table space defined. One table in each database is created in a table space. The other table in each database is created without a table space.

Use the SQL Wizard to execute these commands. See the SQLWizard User's Guide or on-line help for information.

CREATE LOCATION testxdb
    IN c:\xdb\testxdb\;
SET LOCATION TO testxdb;
CREATE DATABASE testdb1;CREATE DATABASE testdb2;CREATE TABLESPACE ts4db1 IN testdb1;
CREATE TABLESPACE ts4db2 IN testdb2;
CREATE TABLE table1 (Field1 integer, Field2 integer)
    IN DATABASE testdb1;
CREATE TABLE table2 (Field3 integer, Field4 integer)
    IN testdb1.ts4db1;
CREATE TABLE tableA (FieldA integer, FieldB integer)
    IN DATABASE testdb2;
CREATE TABLE tableB (FieldC integer, FieldD integer)
    IN testdb2.ts4db2;
CREATE INDEX inx ON table1 (Field1);
Parent topic: Storage Architecture


Basic Tasks

  • Starting an XDB Server
  • Shutting Down an XDB Server
  • Client Sessions and Multiple Logins
  • Administrative (Authority) Levels
  • Administrative Tasks
Parent topic: SQL Option Server Administration Guide


Starting an XDB Server

A personal XDB Server is installed on your machine when you install SQL Option for DB2. This local copy of XDB Server is the default server. It must be running before you can debug or run client applications against a local XDB database. The personal XDB Server can be installed as a Windows Service that is started automatically.

You can also run the XDB Server Blue Screen mode.

After installing and configuring the XDB Server and at least one client, you are ready to run your XDB Server.

When the XDB Server completes its initialization, users can access the locations controlled by the XDB Server immediately. See the topic Shutting Down an XDB Server for information about shutting down an XDB Server.

Parent topic: Basic Tasks
Related information
Shutting Down an XDB Server
To start the XDB Server in blue screen mode


Shutting Down an XDB Server

Use either of the following procedures to shut down the server:

  • Press F10 when viewing the XDB Monitor Utility main menu. If users are active, the monitor asks you to confirm the action.
  • Issue the SQL SHUTDOWN command from a client program (i.e. SQLWizard ). If security is on, your AuthID must have super user authority. For information, about the SHUTDOWN command, see the SQL Reference.
  • Double-click the XDB Server icon in the Control Panel, and click Stop.

Keep the following in mind when you shut down an XDB Server:

  • If users are active when you shut down an XDB Server, their sessions are terminated in mid-transaction, as though the XDB Server crashed. When the XDB Server is restarted, all incomplete transactions are rolled back the next time that location is accessed. Use care, since user programs running on the workstations may not handle a case where the XDB Server no longer responds.
  • If a query is active when you shut down an XDB Server, the XDB Server waits until the query is complete before shutting down.
Parent topic: Basic Tasks


Client Sessions and Multiple Logins

An XDB client running on Windows or UNIX platforms can have several concurrent sessions. For example, a Windows user could open a window and start the SQLWizard. Next, the same user could open another window and start the XDB Migrate Utility, logging in to the XDB Server with the same AuthID and Node Name. The XDB Server will show two user sessions, both with the same AuthID and Node Name, but each running a different process, and each showing a different Session ID number. Likewise, a Windows client can start several sessions by clicking on multiple program icons. Again, the user's multiple sessions show up on the XDB Server, all having the same AuthID and Node Name but with unique Session ID numbers.

When a client session fails or otherwise aborts without logging out, the XDB Server automatically detects the aborted session and releases all resources and locks. Any in-process transactions are rolled back. If the user has other sessions running, they are not affected.

Parent topic: Basic Tasks


Administrative (Authority) Levels

Assign system administration activities and responsibilities to others, depending upon the size and complexity of your installation. With the exception of the special super user privilege set, all authorities are effective only within the location where they are defined.

Suggested responsibilities include:

  • Super User. A special set of XDB Server privileges that can be assigned to one or more system users. This privilege set is assigned automatically to the INSTALL AuthID during installation. Super user authority allows access to all functions on the system. Only the super user can create locations, drop locations and edit system tables.
  • System Administrator (SYSADM). A user who has access to almost all functions within the defined location, including the authority to grant and revoke privileges for other users in that location, but excluding the special super user privileges defined above.
  • System Control (SYSCTRL). A user whose privileges apply only to the location in which SYSCTRL is granted. These privileges include almost all privileges except access to user data.
  • Database Administrator (DBADM). A user who has all database-level privileges but only for a specified database.
  • Database Control (DBCTRL). A user who can use DROP on one specified database, and whose privileges include DBMAINT privileges.
  • Database Maintenance (DBMAINT). A user who can use CREATAB, CREATETS, STARTDB, AND STOPDB for one specified database.

With the exception of super user, any of these suggested responsibility levels can be granted by using the appropriate authority (DBADM, SYSCTRL, etc.) on the GRANT command. See the chapter Security and Authority for more information about security, including use of the GRANT and REVOKE commands.

Parent topic: Basic Tasks


Administrative Tasks

This collection of topics covers the following administrative tasks:

  • Configuring System Parameters
  • Managing System Structures and Space Requirements
  • Packing Data Files to Create Free Space
  • Insuring Database Integrity
  • Evaluating and Improving Database Performance
  • Controlling Access at the System, Database, and Table Levels
  • Backing Up and Restoring Data
  • Maintaining Storage Media
Parent topic: Basic Tasks


Configuring System Parameters

The database administrator should be responsible for setting parameters in the XDB Server Configuration utility for multiuser systems, and for assisting users with the parameters in their individual XDB Server Options and Server Configuration utilities.

Parent topic: Administrative Tasks


Managing System Structures and Space Requirements

The database administrator should also examine the structure of the various locations on the system and the databases defined within each location with an eye towards reducing unnecessary or redundant data storage. The XDB Server supports distributed processing at various levels. See the chapter Storage Architecture for more information about the system architecture.

The system catalog tables provide information about the tables in a database. To determine the space occupied by a given table or index, use the directory DIR command from your operating system prompt to list the tables in a given directory. The directory DIR command lists the amount of space occupied by each file in addition to the number of free bytes remaining on the disk. You can use the SQL SELECT command to query any of the system catalog tables. See the SQL Reference for a description of the SELECT command. See the chapter Storage Requirements for more information about estimating data storage requirements.

Parent topic: Administrative Tasks


Packing Data Files to Create Free Space

Tables, directories and locations should be periodically packed to improve performance and reduce storage requirements. The SQL COMPACT command can be used to:

  • Free space that was formerly occupied by deleted records.
  • Optimize the dictionary files by freeing space that was formerly used for tables that have since been altered or dropped.
  • Rebuild indexes:
    • When converting from a previous version of the XDB Server.
    • After performing many updates or deletions, to optimize space utilization.
    • To rebuild corrupt index files.
  • Re-order the data in a table according to the order of records in a clustered index.

You can call the SQL COMPACT command from any utility that allows you to issue standard SQL commands (such as the SQLWizard on Windows platform, or Interactive SQL on UNIX). You can also use the SQL COMPACT command in Embedded SQL in COBOL . For more information about this command, see the SQL Reference.

Note:

If you are using XDB Link, you cannot use the COMPACT command against DB2 objects on the mainframe. Instead, log on to the mainframe and use the REORG facility to perform this task.

Parent topic: Administrative Tasks


Insuring Database Integrity

The database administrator needs to oversee data entry and programming tasks that impact each database to insure that proper data validation techniques are enforced.

The XDB Server implements referential and domain integrity checks at the schema level. Data integrity can be directly controlled through the use of these integrity features. For more information, see the ALTER or CREATE command in the SQL Reference.

Parent topic: Administrative Tasks


Evaluating and Improving Database Performance

The database administrator determines if the performance of a database is satisfactory for the application environment. Some factors that influence database performance include:

  • Indexes
  • Optimizing the structure of SQL statements
  • Locking (in multiuser versions)
  • Clustering
  • Database design
  • Caching
  • Storage organization, including use of storage groups (stogroups)
Parent topic: Administrative Tasks


Controlling Access at the System, Database, and Table Levels

The database administrator is responsible for protecting the security of the system, locations, databases, and tables. This is accomplished by creating and deleting AuthIDs (user names) and groups, as well as granting and revoking privileges at various levels within the system.

Activate security privileges by turning security on with the XDB Server Configuration utility. Use the SQLWizard to add and delete AuthIDs. See the chapter Security and Authority for more information.

Privileges on system functions and database objects are managed through the SQL GRANT and REVOKE commands, which are described in the SQL Reference.

Parent topic: Administrative Tasks


Backing Up and Restoring Data

The database administrator is expected to establish a regular schedule for backing up locations and their log files. The frequency of backups depends on the frequency of database updates, the importance of data, and the difficulty involved in recreating the data. You should always backup a location during special operations, such as after using the COMPACT command or before installing a new version of XDB Server software.

Backups can be performed using the BACKUP LOCATION command or by using an operating system backup command.

If you operate a location with recovery turned on, log files are maintained (ideally on a different disk drive). The log files contain after images of records that were changed by database transactions within the location. In the event of a system failure, the log files can be applied to the latest restored backup of the location to recover the changes recorded in the log files. The XDB Server provides a ROLLFORWARD command for this purpose.

See the chapter Backup and Recovery for more information.

Parent topic: Administrative Tasks


Maintaining Storage Media

The database administrator is also expected to ensure that timely and proper procedures are implemented and observed for verifying the integrity of storage media. For example, all drives should be checked regularly for lost clusters, fragmentation and other damage that might accumulate over time to threaten data.

There are various commercially available utilities for checking and repairing disk problems. Check your operating system documentation for more information on this or other comparable commands.

Parent topic: Administrative Tasks


Server Configuration Utility

The Server Configuration utility enables you to change the configuration of your personal XDB Server. For example, you can change the following:
  • The XDB Server name
  • Whether XDB Server security is enabled or not
  • Which protocol is used to access the XDB Server
  • Whether other people can use the XDB Server
  • The amount of system resources available to XDB Server
  • Accessing the Server Configuration Utility
  • Server Configuration Parameters
Parent topic: SQL Option Server Administration Guide


Accessing the Server Configuration Utility

You can run the XDB Server Configuration utility in one of two modes:

  • Blue screen – the XDB Server Configuration utility runs as part of the development environment and is available on all Windows environments.

    To start the XDB Server Configuration utility in blue screen mode, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 > Server > XDB Server Monitor.

  • Service – the XDB Server Configuration utility runs as a Windows service.

    To start the XDB Server Configuration utility as a service, start your Windows Control Panel, double-click Micro Focus XDB Server, then click Configure.

Parent topic: Server Configuration Utility


Server Configuration Parameters

This collection of topics covers the following:

  • System Location Path
  • Temporary File Path
  • Server Security
  • Server Version
  • System Usage Monitor
  • Sort Space Size
  • Maximum Number Of Users
  • Lock Table Size
  • Maximum Number of Open Queries
  • Maximum Number of Open Files
  • Governor Cycle Time
  • XDB Server Name
  • Communications Protocols
  • Global Security and Global Security Location Name
  • Buffer Pool Size
Parent topic: Server Configuration Utility


System Location Path

The system location path specifies where the XDB Server looks for system tables containing information about all locations that are accessible to this XDB Server. These system tables are in addition to the system tables that are maintained in the DSNDB06 database for each location.

Enter a path to a specific drive (volume) and directory. Do not specify a location name.

Note: You specify this path when you install the XDB Server. Change the system path only when you need to physically move the files comprising your SYSTEM location.

To set the parameter on Windows 2000:

  1. Click the Paths tab.
  2. Enter the path in the System Location Path text box.
Parent topic: Server Configuration Parameters


Temporary File Path

Set the temporary path to identify where the system should write temporary files used by the XDB Server, such as temporary files that are written when a sort operation overflows the allocated Sort Space Size. Enter a path to a specific drive (volume) and directory. This directory must be accessible to the XDB Server.

To set the parameter on Windows 2000:

  1. Click the Paths tab.
  2. Enter the path in the Temporary File Path text box.
Parent topic: Server Configuration Parameters


Server Security

The XDB Server is shipped with security turned off. If you enable security at the server, you must also enable security at each client workstation accessing the XDB Server. Otherwise, the XDB Server will reject the client logon.

Enabling security requires each user to log in to the XDB Server using a valid AuthID (user name) and password. To set AuthIDs, groups and passwords, use the Admin menu of the SQLWizard. See the Security and Authority chapter, or User Administration in the SQLWizard User's Guide for more information.

If you enable security, the system will also check any privileges configured using the GRANT and REVOKE commands. For information about the GRANT and REVOKE commands, see the SQL Reference.

See the chapter Security and Authority for detailed information about how to plan and construct a security scheme.

To set the parameter on Windows 2000:

  1. Click the General tab.
  2. Mark the Server Security checkbox.
Note: There is no password protection provided by the XDB Server Configuration utility. Anyone with access to the server can run the utility and enable or disable the security. Make sure that the server is physically secure from unauthorized access.
Parent topic: Server Configuration Parameters


Server Version

The XDB Server is shipped with version set to DB2V6.

To set the parameter:

  1. Press F3 SQL Engine Options.
  2. Press F2 Server Version.
  3. Press F1 to select DB2V6 or F2 for DB2V7.
Parent topic: Server Configuration Parameters


System Usage Monitor

The Usage Monitor is a facility for recording location usage. While utilization monitoring is on, the system stores utilization information in the SYSXDB.SYSUSAGE table in the DSNDB06 subdirectory of the system location's directory. If you enable the usage monitor and security, the system will automatically maintain this table, and modify it each time a user logs in or out of a location. You can query the table to audit location usage.

Note: Because the Usage Monitor tracks usage data by individual user session, it contains worthwhile information only when server security is enabled, which forces users to log in.
Note: Enabling the Usage Monitor can decrease performance and require large amounts of disk space.

If the SYSXDB.SYSUSAGE table becomes too large, delete entries from the table using the DELETE or TRUNCATE TABLE command. After deleting entries, you must pack the SYSXDB.SYSUSAGE table using the COMPACT command. COMPACT frees space formerly occupied by deleted records. It is good practice to perform this procedure each time you back up the system location when using the System Usage Monitor.

See the SQL Reference for the structure of the SYSXDB.SYSUSAGE table, and for information about the DELETE, TRUNCATE TABLE, and COMPACT commands. As is the case for all XDB Server system tables, the structure of the SYSXDB.SYSUSAGE table is subject to change.

To set the parameter on Windows 2000:

  1. Click the General tab.
  2. Mark the System Usage Monitor checkbox.
Parent topic: Server Configuration Parameters


Sort Space Size

Set the sort space size to specify the maximum amount of memory that the XDB Server will attempt to acquire when performing a sort operation. Sort space is acquired on a per-sort basis. The sort space size does not define a common pool shared by all users, but rather the maximum amount of space provided for each individual sort request. If a particular sort process does not require the total amount of memory allocated by the Sort Space Size setting, the excess amount of memory is released back to the operating system.

Increasing the sort space size allows the system to process large sorts more quickly, and store larger amounts of data at a single time, requiring fewer merges of sorted information. However, if you set this value too high, relative to the number of concurrent sorts or users, query processing may slow down significantly due to over-allocated memory.

To set the parameter on Windows 2000:

  1. Click the Limits tab.
  2. Enter the desired size in the Sort Space Size text box, or drag the slider.
Note: Do not set the combined amounts of Sort Space Size and other cache to a number greater than the total amount of physical memory (RAM) available on a machine. Doing so can degrade performance due to operating system swapping. When determining how much cache to allocate, be sure to consider all types of caching, including the Caching Options, the XDB Server Sort Space Size option, and operating system cache.
Parent topic: Server Configuration Parameters


Maximum Number Of Users

Set the maximum number of concurrent users logged in the XDB Server to an integer between 1 and 128. Each user will require an additional 128 bytes of memory.

To set the parameter:

  1. Press F4 Configure System Minimums/Maximums.
  2. Press F2 Maximum Number of Users.
  3. Enter the desired number and press Enter.
Parent topic: Server Configuration Parameters


Lock Table Size

Set the size of the lock table to an integer between 4 and 1000 (kilobytes). The recommended setting is 60KB. The XDB Server returns an error code when the lock table is full.

To set the parameter (Windows):
  1. Click the Limits tab.
  2. Enter the desired size in the Lock Table Size text box, or drag the slider.
Parent topic: Server Configuration Parameters


Maximum Number of Open Queries

You can set the XDB Server to support anywhere from 10 to 9,999 open queries. Each additional query specified here requires an additional, but negligible amount of memory. However, specifying too large a number can impact performance because the array of queries is scanned each time a transaction completes. The more queries that are allowed, the longer the scan will be each time.

To set the parameter (Windows 2000):

  1. Click the Limits tab.
  2. Enter the desired number in the Maximum Open Queries text box, or drag the slider.
Parent topic: Server Configuration Parameters


Maximum Number of Open Files

Set the XDB Server to allow between 256 and 32,767 logically open files at any time. Each additional open file adds approximately 100 bytes of memory overhead to the XDB Server.

Once a file has been accessed, the XDB Server keeps the file logically open. A least recently used (LRU) algorithm determines which files to physically close when the limit is reached. The LRU significantly reduces the overhead related to physically opening and closing files during query processing.

If query processing is slow, increase the maximum number of open files.

To set the parameter (Windows:

  1. Click the Limits tab.
  2. Enter the desired number in the Maximum Open Files text box, or drag the slider.
Parent topic: Server Configuration Parameters


Governor Cycle Time

If security is enabled, set the governor cycle time to an integer between 1 and 255 to specify the frequency, in seconds, at which the server checks user activity against limits set in the SYSXDB.SYSGOVERNOR table.

The XDB Server terminates sessions of users who have passed their limits. Limit users by the:

  • Number of API calls
  • Amount of time in the SQL engine
  • Amount of time processing calls
  • Amount of idle time
  • Number of fetches

For example, if Governor Cycle Time is set to 30 seconds, the system checks user activity against governor limits every 30 seconds. A cycle that is too short increases system overhead and decreases performance.

For more information about the XDB Governor and how to assign restrictions to users, see the description in the chapter Security and Authority.

To set the parameter (Windows):

  1. Click the General tab.
  2. Mark the Governor checkbox (if it is not already enabled).
  3. Enter the desired cycle time in the Cycle Time text box, or drag the slider.
Parent topic: Server Configuration Parameters


XDB Server Name

Use this option to set the name by which this XDB Server is known to client applications. Multiple XDB Servers, each with a unique name, can coexist on the same network. Users must supply the appropriate XDB Server Name, using the Options Utility, to connect their client applications to a particular server.

The name given here must also be specified in other places, depending on the client-to-server communications protocol and operating system:

  • For servers using TCP/IP, the xdbnet.ini file contains additional protocol information about each XDB Server on the LAN.

Other networks or operating systems may have other naming conventions and restrictions. Consult your network or operating system documentation for more information.

To set the parameter on Windows:

  1. Click the About tab.
  2. Enter the name in the XDB Server Name text box.
Parent topic: Server Configuration Parameters


Communications Protocols

Local (Windows)
Turn this option on to enable communication between client and server on the same Windows machine.
TCP/IP (all platforms)
Turn this option on to enable communication between TCP/IP clients and the server.
To set the parameter:
  1. Click the General tab.
  2. Mark the checkbox next to the desired communications protocol.
Parent topic: Server Configuration Parameters


Global Security and Global Security Location Name

Once you enable server security, you may enable Global Security if this XDB Server will access another XDB Server or mainframe location for security information (such as AuthIDs and password validation). If you enable Global Security, you must enter the name of the location that contains the global security information.

  • If the global security location is on an XDB Server, you must set up server-to-server connections, including registering the security location of the remote XDB Server in the appropriate system tables of the local XDB Server. See the chapter Server-to-Server Connectivity for more information.

If Global Security is OFF and the XDB Server's regular security feature is ON, AuthID and password validation are performed on the local XDB Server's SYSXDB.SYSACFUSERS, SYSXDB.SYSACFGROUPS and SYSXDB.SYSACFMEMBERS tables in the SYSTEM location.

See the chapter Security and Authority, or User Administration in the SQLWizard User's Guide for information about setting up AuthIDs and groups for users. See the chapter Server-to-Server Connectivity for information about setting up server-to-server connectivity. See the chapter Multiserver Security for information about setting up global security.

When using global security, the following are granted on the XDB Server where the user will be accessing data: server-to-server connections and inbound/outbound mapping database privileges, governor limits, and similar user controls.

To set the parameter (Windows):

  1. Click the General tab.
  2. Mark the Global Security checkbox.
  3. Enter the global security location name in the Location text box.
Parent topic: Server Configuration Parameters


Buffer Pool Size

You can set a buffer pool size to allocate the total amount of memory, in kilobytes, available for caching table, index, and dictionary files. A buffer pool size can range from 16K to 131,072K. The value of BP(0) sets the buffer pool size for data, and the value of BP(1) sets the buffer pool size for indexes. However, if you set BP(0) to a value of zero, this sets the buffer pool size to zero for both data and indexes.

Micro Focus's buffer management system is designed to enhance performance. Memory is allocated by the cache manager at XDB Server start up and then released at XDB Server shut down.

Note: Do not set cache to a number greater than the total amount of physical memory (RAM) available on a machine. Doing so can degrade performance due to operating system swapping. When determining how much cache to allocate, be sure to consider all types of caching, including Caching Options, Sort Space Size, and operating system cache.

To set the cache size in blue screen mode:

  1. Press F6 Caching Options.
  2. Press F1 BP(0) Cache Size or F1 BP(1) Cache Size.
  3. Enter the appropriate cache size in KB and press Enter.
To set the cache size from the Windows XDB Server Configuration Utility service:
  1. Click the Cache tab.
  2. Type a cache size into each of the appropriate fields, or drag the slider to select a value for each.
  • About Caching
Parent topic: Server Configuration Parameters


About Caching

There is one buffer pool cache per XDB Server, and all applications connecting to the XDB Server share this global memory. The overall size of the buffer cache has a large impact on database performance. If the cache is large enough to keep the required data in memory, less disk activity occurs and performance increases. If the cache pool is not large enough, the overall performance of the XDB Server can decrease, with the XDB Server becoming I/O-bound, as physical disk activity is required to service application requests.

The buffer pool cache effectiveness increases with multiple users, when a large amount of repeated access to the same data and index pages occur, and when one primary location is accessed.

The cache manager stores pages (4K each) of database object data. (Therefore, the number of pages is the cache size divided by four.) These database objects consist of table, index, and dictionary pages for all accessed locations. The dictionary pages originate from the dictionary files that reside in every location. As an application requests data from one of these object types, pages containing the data are transferred from the disk into the buffer pool.

Pages are not written to disk until one of the following occurs:

  • The XDB Server is shut down.
  • A checkpoint occurs.
  • Another page needs to be read into a full buffer pool.

Consider the following when determining how much RAM to allocate to cache:

  • A large cache usually speeds up online transaction processing (OLTP). However, if the checkpoint frequency is too infrequent, there can be detectable processing delays each time the checkpoint causes data to be written to the location tables. If checkpoint delays are a problem, either lower the cache amount or increase the checkpoint frequency. For more information about the CHECKPOINT command and the Checkpoint Frequency parameter, see the SQL Reference and the chapter Backup and Recovery chapter in this guide.
  • Decision support systems usually benefit from a larger cache, but the amount of cache does not necessarily have to be as large as the combined size of the database tables and indexes. For example, in a database where much of the data is historical (and rarely accessed), the amount of cache would only have to be large enough to contain the currently active data -- such as the current month or quarter.
  • On systems where sort operations are heavy, you might find that an increase in Sort Space Size gives a better performance gain than increasing or decreasing the cache. Once the appropriate Sort Space Size is defined, you should find it easier to determine the amount of cache needed.

Use the Cache Statistics screen of the Monitor Utility to help determine the best amount of cache for your system. When your XDB Server has reached a steady state (work is well in progress), check the percentage shown for Pages in Use. If Pages in Use is running at or near 100% and the Number of Tosses is high, then most of your allocated cache is being used and you might want to try increasing it. If Pages in Use and Tosses are running low, you have more cache allocated than you need.

Parent topic: Buffer Pool Size
Related information
Performance Tuning


Monitor Utility

The Monitor Utility enables you to monitor the activity of the SQL Option Server.

  • Access and Control
  • Function Summary
  • User Activity
  • Server Status
  • User Resource Statistics
  • Memory Manager Statistics
  • Cache Statistics
  • Halt Query
  • Delete User
  • Shutdown Server
Parent topic: SQL Option Server Administration Guide


Access and Control

Once the XDB Server is running, you can monitor XDB Server activity in any of the following ways:

  • Direct Access. You can run the Monitor Utility xdbmonn.exe on the server machine.
  • Remote Access. You can run the Monitor Utility xdbmonn.exe from a client machine.
  • Virtual Statistics Queries. You can use SQL to query the Virtual Statistics Tables. See the chapter Performance Tuning for more information on Virtual Statistics Tables.
Parent topic: Monitor Utility


Function Summary

The Monitor utility provides access to the information described in the following table. The remainder of this chapter presents detailed information about each function.

Function | Description
User Activity | Displays information about each currently logged on user. Information includes isolation level and time logged on. An asterisk preceding an AuthID indicates that the user has a query open.
Server Status | Provides information on the number of users logged in, the number of queries open, and other useful information.
User Resource Statistics | Displays each user's system resource usage, including the number of queries, table locks (exclusive and shared), and record locks (exclusive and shared).
Memory Manager Statistics | Displays information about the amount of memory currently in use.
Cache Statistics | Displays caching and input/output statistics for the XDB Server cache manager. Monitor cache statistics when your system is running at steady state will help you determine the most effective amount of cache to allocate.
Halt Query | Stops a potentially long sort or query that is in progress.
Delete User | Aborts a user session when a user's workstation fails. The interrupted transaction is rolled back automatically.
Shutdown Server | Shuts down the XDB Server.
Parent topic: Monitor Utility


User Activity

User Activity displays information about the users currently logged in to the XDB Server. If the lines of data exceed the screen size, the information will scroll automatically, pausing at each section.

Note: When a user performs certain functions (such as viewing a list of locations) in text mode tools, the system creates a new internal user in order to access the system location. The monitor will display this user in the User Activity information (with a system-generated name) along with the other "real" users.
User Name
Generally, this is the AuthID used to log on to the XDB Server. If the value in this field is prefixed with an asterisk (*), the user has a query open.

When security is on, the USER NAME displayed is the AuthID under which the user logged into the XDB Server. If security is off, the USER NAME displayed is the same as the Primary AuthID for the client, as set through Options Utility.

If the user has a Secondary ID, the Secondary ID will be shown. If the user has been reassigned a different AuthID via server-to-server inbound or outbound mapping, the re-assigned (new) AuthID is shown.

Some user operations that access the SYSTEM location (such as displaying a list of tables or other browse features) temporarily create a pseudo user, PUBLIC1.

Node ID
This field displays the name of the node from which the user is working. The node name is set through Options Utility for SQLWizard clients on the client workstation. Each client machine must have a unique node name. If there are several clients (AuthIDs or sessions) with the same node name, the node name is appended with a number to indicate the session ID of the client session.

While the same AuthID and node name can be used to log in multiple times (from several different Wintel sessions, for example), the combination of AuthID, node name and session ID together are always unique.

Current Location
This field displays the name of the currently open location.
ILevel
This field displays the isolation level at which the user is currently working. The isolation level is set in any of the following ways:
  • Through the Options Utility
  • By using the SET ISOLATION command
  • By using the new WITH clause on certain SQL statements (DB2 4.x)

See the SQL Reference for information about the SET ISOLATION command and the WITH clause.

Autocommit
This field displays the user's current autocommit level. Set the autocommit level with the Options Utility, or use the SET AUTOCOMMIT command. See the SQL Reference for information about the SET AUTOCOMMIT command.
Logged in Since
This field displays the date and time the user logged in to the XDB Server.
Parent topic: Monitor Utility


Server Status

Server Status information includes the type and number of requests the XDB Server is currently processing and the XDB Server configuration settings.

Note:

When running remotely, the Monitor Utility cannot read the server configuration, and therefore cannot display all of the information in Server Status. The term "N/A" replaces unavailable information.

Server Status displays two types of information:

  • Dynamic information for the current and set maximum of a number of XDB Server parameters.
  • Static information that is constant while the XDB Server is running.
  • Dynamic Server Information
  • Static Server Information
Parent topic: Monitor Utility


Dynamic Server Information

Dynamic server information displays current server activity (CURRENT column), and the limit set in the server configuration (MAXIMUM column) for the following values:

Values | Description
Users | Number of users logged into the XDB Server.
Active Users | Number of users with open SELECT queries.
Open Locations | Number of locations with open SELECT queries.
Open Files | Number of logically open files.
Open Queries | Number of open SELECT queries.
Lock Blocks In Use | Number of lock blocks in use.

Use the XDB Server Configuration Utility to set the limits for open locations, open files, open queries, and lock table size.

Parent topic: Server Status


Static Server Information

Static server information is constant while the XDB Server is running, and includes:

Values | Description
Server Running Since | Date and time the XDB Server was started.
System Location Path | Path where the SYSTEM location for the XDB Server resides.
Temporary Path | Path where temporary files for the XDB Server are stored.
System Usage Monitor | Status of the system usage monitor (on or off).
System Security | Status of system security (on or off).
Packet Ver | Current XDB Server packet version.

Set the system location path, temporary path, system usage monitor, and system security parameters using the XDB Server Configuration utility.

Parent topic: Server Status


User Resource Statistics

User Resource Statistics information includes query and lock statistics for each AuthID/Node currently using the XDB Server. If the user information exceeds the screen size, use PgUp, PgDn, up-arrow, and down-arrow to scroll through the information.

User

Generally, this is the AuthID used to log on to the XDB Server. When security is on, the USER NAME displayed is the AuthID with which the user logged into the XDB Server. If security is off, the USER NAME displayed is the same as the Primary AuthID for the client, as set through the Options Utility.

If the user has a Secondary ID, the Secondary ID will be shown. If the user has been reassigned a different AuthID via server-to-server inbound or outbound mapping, the re-assigned (new) AuthID is shown.

Some user operations that access the SYSTEM location (such as displaying a list of tables or other browse features) temporarily create a pseudo user, PUBLIC1.

Information Description
Node

This field displays the node name from which the user is working. The node name is set through the Options Utility on the client workstation. Each client machine must have a unique node name. If there are several users (AuthIDs or sessions) with the same node name, the node name is appended with a number to indicate the session ID of the client session.

While the same AuthID and node name can be used to log in multiple times (from several different Windows sessions, for example), the combination of AuthID, node name and session ID together are always unique.

QDs

This field displays the number of open queries.

TsLocks

This field displays the number of shared table locks.

TxLocks

This field displays the number of exclusive table locks.

RsLocks

This field displays the number of shared record locks.

RxLocks

This field displays the number of exclusive record locks.

Parent topic: Monitor Utility


Memory Manager Statistics

The Memory Manager Statistics Screen displays information about the amount of memory currently in use as follows:

Information | Description
Total Memory From OS | Total Memory From OS displays the total number of bytes (cumulative) allocated from the operating system.
Number Allocations From OS | Number Allocations From OS is the total number of memory allocations from the operating system (cumulative).
Current Allocations From OS | Current Allocations From OS is the current number of outstanding memory allocations from the operating system.
Parent topic: Monitor Utility


Cache Statistics

The Cache Statistics screen displays caching statistics based on the cache option configured via the XDB Server Configuration utility. The screen displays information in units of 4K memory pages. You can use this information to analyze cache hit ratios and monitor cache effectiveness. The statistics include caching information for all table, dictionary, and index files.

Information | Description
Total Pages | Shows the number of pages in the cache.
Page Size | Size of each page in bytes.
Pages in Use | Percentage of the cache pages allocated to all files that use this cache.
Dirty | Percentage of total pages in the cache that have not yet been written to disk.
Cache Reads | Total number of pages requested from the cache.
Pages Read | Total number of pages read into the cache from disk.
Disk Reads | Total number of read I/O calls performed. Matches pages read, since pages are requested only one at a time.
Read Hit | Percentage of pages requested that did not require a disk read I/O operation.
Cache Writes | Total number of dirty pages released to the cache.
Pages Written | Total number of pages written to disk.
Disk Writes | Total number of disk write I/O calls performed. This number may be less than pages written since flushing causes a series of pages to be written to an accumulator first, and then all written together in one I/O.
Write Hit | Percentage of pages released dirty to the cache that were not written to the disk.
Tosses | Number of cache pages allocated to a file that were written out to disk to make room for a new page.
Checkpoints | Number of checkpoint calls made to this cache.
Parent topic: Monitor Utility


Halt Query

Use the Halt Query option to stop the processing of any DML command (DELETE, INSERT, SELECT, and UPDATE). Halt Query is especially useful when a user's workstation hangs or when a potentially long query needs to be aborted.

If security is on, you must have SYSADM authority on the SYSTEM location (or have super user privileges) to perform this operation.

To halt a query:

  1. Press F8. A window containing AuthIDs (user names) and nodes appears.
  2. Use the up-arrow and down-arrow keys to highlight the name of the user whose query you want to halt.
  3. Press Enter. Confirm the action when requested.
Parent topic: Monitor Utility


Delete User

Use the Delete User option to deactivate (cancel) a particular user session. If security is on, you must have SYSADM authority on the SYSTEM location (or have super user privileges) to perform this operation.

To delete a user:

  1. Press F9. A window containing AuthIDs (user names) and nodes appears.
  2. Use the up-arrow and down-arrow keys to highlight the name of the user whose query you want to halt.
  3. Press Enter. Confirm the action when requested.

If the logging system is on, the XDB Server will roll back and delete the session for the user selected.

Parent topic: Monitor Utility


Shutdown Server

You can press the F10 key to shut down the server. If users are active, the monitor asks you to confirm the action.

  • If users are active when you shut down an XDB Server, their sessions will be terminated in mid-transaction, as though the XDB Server crashed. When the XDB Server is restarted, all incomplete transactions will be rolled back the next time that location is accessed. Use care, since user programs running on the workstations may not handle a case where the XDB Server no longer responds.
  • If a query is active when you shut down an XDB Server, the XDB Server will wait until the function is completed before shutting down.
Parent topic: Monitor Utility


Security and Authority

  • Security System Concepts
  • Setting Up Security
  • System Level Access Control
  • Granted Authorities and Privileges
  • Security User Exit
  • AuthID List User Exit
Parent topic: SQL Option Server Administration Guide


Security System Concepts

XDB Servers are shipped with security turned off to allow you unlimited access to the system. You can continue to operate without security indefinitely, if desired, even in a multiuser environment.

In a multiuser environment, if security is on at the server, then all users must have security on at their individual workstations. After security is turned on, each user or process must log in with a valid AuthID (a "user ID"). If the AuthID has a defined and required password, the password must be entered as well. When the user attempts to access a table, the server also verifies that the user has privileges to that table, which were set up using the GRANT and REVOKE commands. Only someone with super user privileges can establish AuthIDs and passwords.

Super Users

Each XDB Server is shipped with one super user called INSTALL. A super user is the only user who can:

  • Create and drop locations.
  • Add and remove users
  • Edit (update) system tables.
  • Assign super user privileges to another user ID.

You can create other super users at your discretion using the SQLWizard Users command on the Admin menu.

Super user privileges should be limited to a few trusted users with database administration expertise.

Note: In effect, when security is off, all users are super users. As long as security remains off, the Primary AuthID indicated in your client configuration is used as the qualifying name in the three-part object name:

location-name.authid.object-name.

Note: The INSTALL user ID that is shipped with an XDB Server does not have a password assigned to it. Use the SQLWizard Users command or run the ALTER PASSWORD SQL command to assign a password to this user ID as soon as possible. The syntax for ALTER PASSWORD is as follows:
 ALTER PASSWORD old_password TO new_password
Parent topic: Security and Authority


Setting Up Security

The following is an overview of the process used to set up and activate security. This procedure must be performed by someone with super user authority.

Note: The following procedure assumes a single-server environment. If you are working in a multiserver environment or you are using a global security server, see the chapter Multiserver Security for additional setup procedures.

To set up security for an XDB Server:

  1. At the XDB Server, use the XDB Server Configuration utility to enable the server security option. See the chapter Server Configuration Utility for details.

    Note: No one else is allowed access to the server until you are finished setting up user IDs and passwords.
  2. At the XDB Server or at any client workstation attached to the XDB Server, use the client options utilities (Options Utility) to select the XDB Server, specify your super-user ID, and enable security in the Options Utility

    To set the options:

    • On the Connect tab, select the XDB Server on which you want to set up security.
    • On the Connect tab, specify your super user ID (e.g., INSTALL).
    • On the Security tab, enable the Client Security option.
    • On the Security tab, specify the Default Enforcement Level. This value determines the level of complexity that all passwords must have. See the topicPassword Enforcement Level for more information.

  3. Use SQLWizard's User command or the CREATE USER SQL syntax to create a user ID, password, and user type (user or super user) for each user of this XDB Server. Only the users that you define during this step will be allowed to log on to the Server, and they must present the proper user ID/password combination when they do so.

    Note: Apart from permitting access to an XDB Server, the user ID you create in this step also serves as a users default AuthID. You can override this default assignment by assigning a Secondary ID to the user, or the user can change it using the SET CURRENT SQLID command.
  4. A group ID allows you to assign location-level, database-level, and table-level privileges to a group of users. To set up group IDs, you can either use SQLWizard's Group command or run the following command:
     insert into sysxdb.sysacfgroups('group_name', '');

    You can also use a SecondaryID for this purpose. See the section AuthID Ownership and Usage Rules for a comparision of group IDs and SecondaryIDs.

  5. Run the SQL GRANT and REVOKE commands from an SQL utility (i.e. SQLWizard) to assign specific privileges (or pre-defined sets of privileges called authorities) to each AuthID or GroupID. Privileges and authorities are granted within each location. See the topic Granted Authorities and Privileges topic for more information.
  6. When you are finished creating users, run client options/configuration utilities at each user's workstation and turn on the Client Security option. On the Security tab, specify the Default Enforcement Level. Each client must agree with the server about the password enforcement level. See the section Password Enforcement Level for more information. You must also inform your users of their new user IDs and passwords. Once they log on, they can change their password using the SQLWizard Change Password command or run the ALTER PASSWORD SQL command.
Parent topic: Security and Authority


System Level Access Control

System-level access control refers to that part of the security system that controls the login process, passwords, the assignment of users to groups, and the definition of SecondaryIDs. These aspects of security are described in this topic.

  • Password Enforcement Level
  • XDBACF Database
  • AuthID Ownership and Usage Rules
Parent topic: Security and Authority


Password Enforcement Level

Before setting up initial passwords for users (or before users change their passwords), select a password enforcement level from the options provided on the Options Utility.

Password level options are:

Level | Options
Level 1: | Password must be four or more characters.
Level 2: | Password must be six or more characters and include at least one digit (numeric).
Level 3: | Password must be six or more characters, include at least one digit (numeric), and must include the two randomly generated characters that appear in the prompt message on the SQLWizard Add/Modify User screen. (From the SQLWizard Admin menu, select User.)

Users can change their passwords by using the SQLWizard Change Password command.

Note:

Depending on your security needs, you might wish to establish two AuthID/Password accounts on the server; one for Micro Focus locations and one for DB2 locations.

Parent topic: System Level Access Control


XDBACF Database

The system location for each XDB Server contains a database called XDBACF (Access Control Facility). This database contains information you enter for each user and group via the SQLWizard Admin menu. Information in the XDBACF database applies to all users and all locations on the server.

The XDBACF database contains the following tables and columns:

  • SYSXDB.SYSACFUSERS contains a list of all users, including the following information for each user:
    AuthID | AccessAuthority
    SecondaryID | RequirePassword
    Password | UserType
    DateOP (date of password) | Remarks
    TimeOP (time of password)
    Note:

    If you are a super user, do not edit or update a user's PASSWORD or TIMEOP in this table. Use the SQLWizard instead.

  • SYSXDB.SYSACFGROUPS contains a list of all GroupIDs that have been defined. Columns in this table are:
    GroupAuthID
    Remarks
  • SYSXDB.SYSACFMEMBERS contains a list of AuthIDs and the GroupIDs that each is authorized to use. Each user (Primary AuthID) can have several entries, one entry for each GroupID that the person is authorized to use. Columns in this table are:
    UserAuthID
    GroupAuthID
  • SYSXDB.SYSGOVERNOR contains information on the type of activities that can be performed by certain users during certain periods. Columns in this table are:
    Priority | MaxIdleTime
    MaxNumApiCalls | MaxFetches
    MaxTimeEngine | StartFreeTime
    MaxTimePerApi | EndFreeTime
  • SYSXDB.SYSUSERPRIORITY contains information about priorities that have been assigned to users.

See the SQL Reference for the specific format of each of these tables.

Parent topic: System Level Access Control


AuthID Ownership and Usage Rules

Primary AuthIDs, GroupIDs and SecondaryIDs can be used in combination when setting up system security. These IDs are defined and used as follows:

  • Primary AuthID. This is the primary identifier for all users of an XDB Server. A Primary AuthID can be assigned to a process or program that requires access to XDB Server data.
    • Used for logging in to an XDB Server.
    • Appears as an identifier on server screens that are used to monitor activity of users.
    • Used as the default for the AuthID portion of a database object's three-part name when the user creates the object. A different ID will become the default if the SET CURRENT SQLID command is issued, if a SecondaryID is defined, or if a security user exit modifies the Current SQLID. See the Security User Exit topic for information.
    • Used to determine privileges when user attempts to access a database object. If a different ID is in effect (from issuance of a SET CURRENT SQLID command), that ID's privileges are available also. If the Primary AuthID belongs to a group, the privileges granted to the GroupID also are available to the user of the Primary AuthID. If a SecondaryID is defined, the Primary AuthID's privileges are not valid, but rather the SecondaryID's privileges take effect (along with its groups, if any).
  • Group or GroupID. This is a special identifier that can be assigned to one or more Primary AuthIDs. The privileges granted to the GroupID are available to every Primary AuthID to which the GroupID is assigned. In addition, each Primary AuthID can have multiple GroupIDs assigned to it, thus gaining the privileges of all of those groups combined. Other privileges can be granted to the Primary AuthID, providing the user with the assigned group privileges plus the privileges assigned specifically to the Primary AuthID.
    Note: If you specify a GroupID as the second part of an object's three-part name, all users who are assigned to that group will automatically have all privileges on the object. Privileges cannot be revoked from a user whose GroupID is the same as the object creator's AuthID. The GRANT and REVOKE commands have no effect on these privileges.
  • SecondaryID (optional). If defined, this AuthID replaces the Primary AuthID as soon as the user logs in to the XDB Server. The user (or process) is given the privileges that have been granted to the SecondaryID. If the Primary AuthID had privileges granted to it, those privileges would be ignored. When a user with a SecondaryID creates an object, the AuthID portion of the object's name is the SecondaryID. All other users who use the same SecondaryID will have all privileges on that object.
    Note: The XDB Server SecondaryID is not the same as the DB2 Secondary Authorization ID. The IBM method of defining multiple Secondary Authorization IDs and assigning them to Primary AuthIDs in RACF (Resource Access Control Facility) is similar to Micro Focus' group concept.
    Note: If you use an object creator's AuthID as a SecondaryID for other users, those other users will all have all privileges on the object. A user with a SecondaryID is seen by the system as being the SecondaryID, and therefore has all privileges on all objects that carry that AuthID as the second part of the object name. Privileges cannot be revoked from the creator of an object, or from a user who's Current SQLID is the same as the object creator's AuthID. The GRANT and REVOKE commands have no effect on the privileges of an object's creator/owner.
  • Current SQLID. The Current SQLID is a special register that keeps track of which AuthID is in effect for a given client session. A user with SYSADM or super user authority can issue the SET CURRENT SQLID command to change the SQLID to any valid AuthID. If a user has a SecondaryID, the Current SQLID changes from the Primary AuthID to the SecondaryID at the start of the client session.

The table and the descriptions following it illustrate how various GroupID and SecondaryID assignments can affect the naming of and access to database objects.

When security is on, the Primary AuthID and Password are used when each user (or process) logs in to the XDB Server. The system then checks the SYSXDB.SYSACFUSERS table for the existence of a SecondaryID. If present, the user (or process) assumes the identity of the SecondaryID and is accorded all privileges that have been defined for the SecondaryID. If no SecondaryID exists for the user, then privileges are based on what has been granted for the Primary AuthID and the groups to which it belongs.

To grant a particular set of privileges to a group of users, without having to define those privileges for each user individually, assign multiple users to the same SecondaryID. Grant the privileges to the SecondaryID (essentially just another AuthID). However, the preferred method for assigning the same privilege set to many users is to use the XDB Group, which is similar to the DB2 concept of assigning multiple secondary authorization IDs to a primary authorization in IBM's RACF (Resource Access Control Facility).

Note: If several users have the same SecondaryID, all the objects they create will be owned by the SecondaryID and not by the individual users. All users having that same SecondaryID will have all privileges on those objects. The GRANT and REVOKE commands have no effect on privileges of an object's creator/owner, which in this case includes all users with the SecondaryID that is also the AuthID portion of the object's name. All of these users are seen by the system as being the owner of the object.
Primary AuthID | Secondary ID | Group Name | Creates Table... (see note 1) | Owner | Authorized Users
TECHPUBS | -- | -- | Created as a Primary AuthID. Privileges are assigned. Used as a SecondaryID for one or more Primary AuthIDs.
-- | -- | WRITERS | Created as a group. Privileges are assigned to the group. GroupIDs are assigned to Primary AuthIDs.
ERIC | -- | -- | ERIC. TABLE1 | ERIC | ERIC
DEBBIE | -- | -- | DEBBIE TABLE1 | DEBBIE | DEBBIE
DAVID | -- | WRITERS | DAVID. TABLE1 | DAVID | DAVID and if access is granted to WRITERS, then also ARLENE.
ARLENE | -- | WRITERS | ARLENE. TABLE1 | ARLENE | ARLENE and if access is granted to WRITERS, then also DAVID.
ROCHELLE | TECHPUBS | -- | TECHPUBS. TABLE1 | TECHPUBS | Users with TECHPUBS as SecondaryID (ROCHELLE, STEVE, PABLO, BRUCE) and if access is granted to WRITERS, then also DAVID, ARLENE.
STEVE | TECHPUBS | -- | TECHPUBS. TABLE2 | TECHPUBS | Users with TECHPUBS as SecondaryID (ROCHELLE, STEVE, PABLO, BRUCE) and if access is granted to WRITERS, then also DAVID, ARLENE.
PABLO | TECHPUBS | WRITERS (ignored, see note 2) | TECHPUBS. TABLE3 | TECHPUBS | Users with TECHPUBS as SecondaryID (ROCHELLE, STEVE, PABLO, BRUCE)
BRUCE | TECHPUBS | WRITERS (ignored, see note 2) | TECHPUBS. TABLE4 | TECHPUBS | Users with TECHPUBS as SecondaryID (ROCHELLE, STEVE, PABLO, BRUCE)

Table Notes

  1. All scenarios described here assume that the user does not specify an AuthID when creating the object and the user has not changed his Current SQLID.
  2. Pablo and Bruce do not have privileges defined for the group writers because as soon as they log in, they both become techpubs, and techpubs is not assigned to the group writers in this example.

As shown in the above table, the AuthID portion of the name assigned to a database object when it is created, and the users who have access to that object depend on how AuthIDs, GroupIDs and SecondaryIDs are defined. The object naming and usage rules are as follows:

  1. If a user belongs to a group and creates an object, the AuthID portion of the object name will be the user's own Current SQLID, and not the GroupID. This allows more than one user to create objects of the same name within the same location.

    For example, if user david (who is in the writers group) creates a table called staff in the location called books, the table's three-part name would be books.david.staff. If user arlene (who is also assigned to the writers group) attempts to create a table called staff, in the location called books, the table's three-part name would be books.arlene.staff. Since the three-part names of the two tables are unique, each user can have a table of the same one-part name within a location.

    Note: If a user has no Secondary ID and has not otherwise changed his Current SQLID, the Current SQLID is the user's Primary AuthID.
    Note: If you specify a GroupID as the second part of an object's three-part name, all users who are assigned to that group will automatically have all privileges on the object. Privileges cannot be revoked from a user whose GroupID is the same as the object creator's AuthID. The GRANT and REVOKE commands have no effect on these privileges.
  2. If a GRANT command gives privileges to a GroupID, all users who are members of that group will have those privileges.
  3. If a user belongs to multiple-groups, the user has all privileges that have been granted to each group.
  4. If a user has a SecondaryID and creates an object, the AuthID portion of the object name will be the SecondaryID (assuming that the user has not changed his Current SQLID, which by default takes the value of the SecondaryID). Two users with the same SecondaryID cannot create objects of the same name within a location.

    For example, if user rochelle (who has a SecondaryID of techpubs) creates a table called staff in the location called books, the table's three-part name would be books.techpubs.staff. If user steve (who also has techpubs as his SecondaryID) attempts to create a table called staff, the table's three-part name would also be books.techpubs.staff. This is not allowed.

  5. Any object whose name has a SecondaryID as the AuthID qualifier can be accessed by any user who has that same SecondaryID as his Current SQLID. GRANT and REVOKE commands have no effect on these users' access to the objects because these users are all seen by the system as being the owner of the object. All users who have the SecondaryID that is the owner of the object will have all privileges on the object.

    Users rochelle, steve, pablo, and bruce all have all privileges on techpubs.table1, techpubs.table2, techpubs.table3, and techpubs.table4. GRANT and REVOKE commands for these users and tables will have no effect.

    If an object has a different owner, then granting privileges to the SecondaryID will give those privileges to all users who have that SecondaryID as their Current SQLIDs.

  6. If a user has a SecondaryID (as his Current SQLID) and belongs to a group and creates an object, the AuthID portion of the object name will be the SecondaryID. Other users in the group do not have access to the object, because privileges on the object have not been granted to the group. The object is owned by the SecondaryID. Only users with the same SecondaryID (as their Current SQLIDs) can access the object. (However, the original user who created the object of this example can access other objects to which the group has been granted privileges.)
Parent topic: System Level Access Control


Granted Authorities and Privileges

When security is on, the user's Current SQLID must either be the owner of the object, or have specific privileges in the location where the object resides. You can grant privileges to a Primary AuthID, a GroupID or a SecondaryID. An AuthID can be granted an authority, which is a pre-defined set of privileges.

Authorities are suggestive of different levels of responsibility. These responsibilities might or might not suit your needs. See the SQL GRANT command in the SQL Reference for detailed information.

Privileges (and authorities) can be granted at the location level (SYSADM or SYSCTRL), database level (DBADM, DBCTRL or DBMAINT), or by table or column within a table. AuthIDs must be granted privileges within each location they are authorized to use. Privileges in one location do not carry over to another location.

To assign privileges to a given AuthID in two or more locations, set up groups, then assign privileges to each GroupID for one location. The groups that represent the locations for which the user is to be allowed privileges are then assigned to the user's AuthID.

To allow a user to have unlimited privileges throughout the system (all locations), grant super user privileges to the user's Primary AuthID.

Note:

Only a super user can create locations, drop locations, edit (update) system tables, and assign super user status to another user. Super user privileges can be assigned in SQLWizard or by editing the USERTYPE column in the user's record in the SYSXDB.SYSACFUSERS table.

Users cannot grant privileges to themselves and cannot revoke privileges from themselves. Likewise, GRANT and REVOKE commands have no effect on users whose AuthIDs (or SecondaryIDs or GroupIDs) are the same as the AuthID portion of an object's name.

  • The DSNDB06 Database
  • Granting and Revoking Privileges
Parent topic: Security and Authority


The DSNDB06 Database

The DSNDB06 database, which is a system catalog database provided in each location, contains the specific authorities and privileges that you define for each AuthID, SecondaryID or GroupID with the SQL GRANT and REVOKE commands. This information is stored in the following security-related tables:

  • SYSIBM.SYSDBAUTH (Database Authorization)
  • SYSIBM.SYSUSERAUTH (User Authorization)
  • SYSIBM.SYSTABAUTH (Table Authorization)
  • SYSIBM.SYSCOLAUTH (Column Authorization)

See the SQL Reference for a complete definition of each of these tables.

Parent topic: Granted Authorities and Privileges


Granting and Revoking Privileges

After you set up the AuthIDs, SecondaryIDs and groups, you can define the privileges and authority for each, using the SQL GRANT and REVOKE commands. Set up the granted privileges before or after turning on security. However, any grants you issue when security is off will not take effect until you turn security on.

Note: Warning:

Be sure you are operating in the location for which you want to define privileges. Each location has its own DSNDB06 database for maintaining authorization information. (To change locations, use the SET LOCATION TO command in interactive SQL or change your default location in the SQLWizard or Options Utility.)

The basic GRANT command formats supported by XDB Servers are shown below. The REVOKE command formats are similar.

  • Database Privileges
    GRANT privilege
    ON DATABASE database-name
    TO authid
    [ WITH GRANT OPTION ]
  • System Privileges
    GRANT privilege
    TO authid
    [ WITH GRANT OPTION ]
  • Table or View Privileges
    GRANT {ALL | privilege}
    ON TABLE table-name
    TO {PUBLIC | PUBLIC AT ALL LOCATIONS | authid}
    [WITH GRANT OPTION]
  • Column Privileges
    GRANT UPDATE(column-name)
    ON TABLE table-name
    TO {PUBLIC | PUBLIC AT ALL LOCATIONS | authid}
    [WITH GRANT OPTION]

where:

privilege | is one or more Authorities and/or privileges, separated by commas
authid | is a user's Primary AuthID, a SecondaryID or a GroupID.
UPDATE (column-name) | is one or more occurrences of this phrase separated by commas. You must enter the word UPDATE and the column name in parentheses for each column on which the update privilege is to be granted.
PUBLIC | is used to grant the privilege to all users at the current location.
PUBLIC AT ALL LOCATIONS | is used to grant the privilege to all users, including remote users who are accessing this location.

See the SQL Reference for detailed information about using these commands, including descriptions of the various privileges and authorities that are available for each.

Parent topic: Granted Authorities and Privileges


Security User Exit

The Security user exit allows you to use a security program other than the one provided by the XDB Server, such as a network security system or a custom written program.

A custom security system must be compiled into a dynamic link library. On Windows systems this dynamic link library is called XSEC41.DLL, and must be placed in the XDB directory. This security scheme is then used instead of the standard security system.

Parent topic: Security and Authority


AuthID List User Exit

AuthID list user exit allows you to retrieve AuthID, Current SQLID, group membership, and super user information from a source other than the XDB Server user database.

You must compile the AuthID List program into a dynamic link library. On Windows systems this dynamic link library is called XAUT41N.DLL, and must be placed in the XDB directory. This AuthID List is then used instead of the standard XDB Server user database.

Parent topic: Security and Authority


Server-to-server Connectivity

The server-to-server connectivity capability provided with the XDB Server allows a client accessing one XDB Server to actually access the data in a location controlled by another XDB Server in a distributed environment. Server-to-server connectivity extends the concepts of remote unit of work (RUW) and distributed unit of work (DUW) to encompass data controlled by multiple XDB Servers.Location access can be done in two ways: either by using a three-part name (location.authid.object) or alias; or by using the SET LOCATION command or embedded CONNECT command. Server-to-server connectivity removes the need to have to change the client settings to access another remote XDB Server.To allow access to a remote location, you must maintain the system tables to reflect known locations and server names.Throughout the XDB Server documentation, the term primary server is used to refer to the XDB Server to which the user is connected. The term remote server is the XDB Server elsewhere on the LAN that controls the location the user wishes to access.Whether three-part names or connect access is used, information about remote locations must be registered with the XDB Server to which you are currently connected. This is done by inserting information into tables in the system catalog. The system tables that must be updated, as well as sample entries, are listed in each section.Because the information is registered in the system catalog tables, the user does not have to know which XDB Server controls which location. You simply need to know the name of the location to be accessed.

  • Three-Part Name Access
  • Connect (Set Location) Access
Parent topic: SQL Option Server Administration Guide


Three-Part Name Access

One method of accessing data in a remote location involves using a three-part name. An application simply uses the fully qualified name (location.authid.object) of a table or view that resides in another location. Based on information in the system catalog tables on the current XDB Server, the request is sent to the appropriate XDB Server and data is returned. This configuration is also referred to as a distributed unit of work (DUW).

Multiple locations controlled by multiple XDB Servers can be queried in this way. A client application can request data from any XDB Server in the distributed environment, as long as the server and the locations it controls are registered in the system catalog tables.

An alias of a three-part name can also be used. Remember that aliases actually provide better location transparency because the first part of the three-part name need not be specified. Throughout the Server-to-Server Connectivity an alias can also be used wherever a three-part name can be used.

  • Disconnecting
  • Privileges
  • Examples
  • System Tables
  • Sample System Tables
  • Setting Up Server-to-Server Connectivity
Parent topic: Server-to-server Connectivity


Disconnecting

Generally, the connection between the primary and remote server is not broken until the client application ends the session by logging out of the primary server. If the access of the remote server was done interactively, it cannot explicitly disconnect from the remote server. If the access was done through embedded SQL, the program can use the CONNECT RESET command. See the SQL Reference for a description of the CONNECT RESET command.

Parent topic: Three-Part Name Access


Privileges

Control privileges at each individual server. Each server controls its own access security. Privileges granted at each server affect all users who connect to it, whether by logging in directly or accessing the server via a three-part name or alias. Additional access control can be had by using security mapping and global security. See the chapter Multiserver Security for a more detailed discussion of security mapping and global security.

Parent topic: Three-Part Name Access


Examples

Client1 is logged into the XDB Server xdbserve and is running the SQL Wizard. Client1 issues a SELECT command that references the table orders.eastern.may.

This request is received by the XDB Server xdbserve. The xdbserve server checks its system catalog table SYSIBM.SYSLOCATIONS. This table indicates that the location orders is controlled by the XDB Server sales.

The request is then passed on to the XDB Server sales, which processes the query. The query result is returned to xdbserve, which passes the data back to the SQL Wizard on client1.

Now consider that, in the next SQL statement issued, client1 references products.gui.productlist. Again, the same system catalog tables on xdbserve are checked.

This time, the request is sent to the XDB Server, develop.

Parent topic: Three-Part Name Access


System Tables

You must insert data into two XDB Server system tables, SYSIBM.SYSLUNAMES and SYSIBM.SYSLOCATIONS, on the primary XDB Server in order to use three-part names or aliases for server-to-server connectivity. This can be done through SQL commands in the SQL Wizard.

Note: When updating SYSLOCATIONS and SYSLUNAMES, do not change or delete any records that appear blank. These records contain a space character in certain columns and are required to define the locations controlled by your local machine.

You must insert values into columns labeled "required" in order to use server-to-server connectivity. All other columns can have NULL values. Several of the other columns in the SYSIBM.SYSLUNAMES table are used for security mapping. See the chapter Multiserver Security for more information on these values.

  • SYSIBM.SYSLUNAMES
  • SYSIBM.SYSLOCATIONS
Parent topic: Three-Part Name Access


SYSIBM.SYSLUNAMES

The columns of this table contain information on LUNAMES used for server-to-server or XDB Link connectivity.

Name | Type | Len | Description
LUNAME required | CHAR | 8 | Name of the XDB Server, if using server-to-server connectivity. Name of the LU for one or more accessible DB2 systems if using XDB Link. Blank indicates the current XDB Server.
SYSMODENAME | CHAR | 8 | Mode used to establish intersystem conversations.
USERSECURITY | CHAR | 1 | Acceptance option for a remote attach:
 |  |  | C | "Conversation." A request is checked by the internal security system and must include a password.
 |  |  | A | "Already Verified." A request does not need a password, although a password is checked if it is sent. A is the default.
 |  |  | Any character that is not C is treated as an A.
ENCRYPTPSWDS | CHAR | 1 | Included for DB2 compatibility only. Tells whether passwords for DB2 LUs are encrypted:
 |  |  | Y | Passwords are encrypted.
 |  |  | N | Passwords are not encrypted.
 |  |  | XDB Server always uses encrypted passwords, even if set to N.
MODESELECT | CHAR | 1 | Not used in XDB Server.
USERNAMES | CHAR | 1 | Whether an ID accompanying a remote attach request is subject to translation.
 |  |  | I | Inbound ID, from the corresponding LUNAME, is subject to translation.
 |  |  | O | Outbound ID, sent to the corresponding LUNAME, is subject to translation.
 |  |  | B | Both inbound and outbound IDs are subject to translation.
 |  |  | blank | No translation is done for either inbound or outbound IDs.
Parent topic: System Tables


SYSIBM.SYSLOCATIONS

The columns of this table contain information about all locations that are accessible for RUW and DUW processing, including local locations in SYSXDB.SYSLOCALS plus remote locations accessible using server-to-server connectivity or XDB Link.

Name | Type | Len | Description
LOCATION required | CHAR | 16 | Name of the location.
LOCTYPE required | CHAR | 1 | Indicates the location type:
 |  |  | X | XDB
 |  |  | R | RPC
 |  |  | C | CICS
 |  |  | D | DRDA
LINKNAME required | CHAR | 8 | Name of the XDB Server which controls the location, if using server-to-server connectivity. LUNAME for the accessible system if using XDB Link.
LINKATTR required | VARCHAR | 64 | Type of protocol used to connect to the XDB Server when using server-to-server connectivity:
 |  |  | S | SPX
 |  |  | B | NetBIOS
 |  |  | N | Named Pipes
 |  |  | T | TCP/IP (Set the hostname and IP address in the XDBNET.INI file.)
 |  |  | or The name of the mainframe program with which XDB Link will communicate if using XDB Link.
Parent topic: System Tables


Sample System Tables

The following table shows the values needed in the system table SYSIBM.SYSLUNAMES on the primary XDB Server xdbserve to execute the examples for three-part name or alias access.

LUNAME | SYSMODE-NAME | USER-SECURITY | ENCRYPT-PSWDS | MODE-SELECT | USER-NAMES
sales |  |  |  |  |
develop |  |  |  |  |

The first row indicates that the XDB Server sales can be accessed. The second row indicates that the XDB Server develop can be accessed.

The following table shows the values needed in SYSIBM.SYSLOCATIONS on the XDB Server xdbserve to execute the examples for three-part name or alias access.

LOCATION | LOCTYPE | LINKNAME | LINKATTR
staff | X |  |
orders | X | Sales | B
products | X | Develop | N

The first row indicates that the staff location is an XDB location controlled by the current (primary) XDB Server xdbserve.

The second row indicates that the orders location is an XDB location controlled by a remote XDB Server sales and can be reached via the NetBIOS protocol.

The third row indicates that the products location is an XDB location controlled by a remote XDB Server develop and can be reached via the Named Pipes protocol.

Parent topic: Three-Part Name Access


Setting Up Server-to-Server Connectivity

In order to set up server-to-server connectivity, you must configure both the primary XDB Server and the remote XDB Server. The primary XDB Server is the XDB Server which clients will log into. From this server, they will be able to access remote XDB locations by using either three-part names or aliases. The instructions in this topic discuss one primary server with one remote server.

If you wish to have a fully distributed environment, complete the Primary Server Configuration instructions for each XDB Server that you wish to be a primary XDB Server. Complete the Remote Server Configuration instructions for each XDB Server you wish to be a remote XDB Server.

The following instructions assume that security is turned on (through the XDB Server Configuration utility) for the primary XDB Server.

  • Primary Server Configuration
  • Remote Server Configuration
Parent topic: Three-Part Name Access


Primary Server Configuration

To configure a server as a primary XDB Server, you must update the system tables. In the examples, the primary XDB Server is xdbserve.

To update the system tables:

Note:

Do not delete any seemingly empty records; these contain space characters in some columns and refer to locations controlled by your local XDB Server.

  1. On any client logged in to the primary XDB Server, start SQL Wizard.
  2. Log in with an AuthID that has super user privileges, such as the INSTALL AuthID, provided with the XDB Server.
  3. Open an SQL Window and set the current location to the SYSTEM location:

    SET LOCATION TO system;

  4. Issue the following SQL command to insert information about a remote server into the SYSIBM.SYSLUNAMES table:
    INSERT INTO sysibm.syslunames
    VALUES ("remote-server","","","","","");

    where remote-server is the name of a remote XDB Server to be accessed. Several of the other columns in the SYSIBM.SYSLUNAMES table are used for security mapping. See the chapter Multiserver Security for more information on using these values.

    In the examples used in this topic, the SQL command:

    INSERT INTO sysibm.syslunames
    VALUES ("sales","","","","","");

    would have been issued on the XDB Server XDBSERVE.

  5. Issue the following SQL command to insert information about a remote location into the SYSIBM.SYSLOCATIONS table:
    INSERT INTO sysibm.syslocations
    VALUES ("remote-location","X",
            "remote-server","link-type");

    where:

    remote-location | is the name of the remote location to be accessed (unique among all locations on all servers that are used in distributed processing).
    X | indicates it is an XDB Server.
    remote-server | is the name of the remote server that controls the remote location.

    link-type is the communication protocol used to connect to the remote server.

    In the examples used in this topic, the SQL command:

    INSERT INTO sysibm.syslocations
    VALUES ("orders","X","sales","B");

    would have been issued on the XDB Server XDBSERVE.

  6. Repeat Steps 4 and 5 for each remote XDB Server and location that will be accessed from this primary server.
  7. Issue the following SQL command to refresh the system:
    REFRESH LOCATIONS;
  8. Exit SQL Wizard.
Parent topic: Setting Up Server-to-Server Connectivity


Remote Server Configuration

The remote XDB Server must be configured and started, and privileges must be granted. In the examples, the remote XDB Server is sales.

If security is on, clients must have privileges on the tables they wish to access on the remote server. Be sure to grant the appropriate privileges to each client on the remote server.

AuthIDs (usernames) are created using the SQL Wizard Admin menu. Privileges are granted using SQL GRANT command from the SQL Wizard. See the chapter Security and Authority for more information on AuthIDs and privileges.

AuthID mapping can make this task much easier in a large distributed environment. See the chapter Multiserver Security for more information about AuthID mapping.

Parent topic: Setting Up Server-to-Server Connectivity


Connect (Set Location) Access

The second method of accessing data in a remote location involves connecting to the remote XDB Server. To connect to the remote XDB Server interactively, use the SET LOCATION command (an SQL extension). To connect to the remote XDB Server with embedded SQL, use the CONNECT command.

A client interactively issues a SET LOCATION command or an application created using embedded SQL issues a CONNECT command. Based on information in the system catalog tables on the current XDB Server, the client's connection is transferred to the appropriate XDB Server and data is returned. This configuration is also referred to as a remote unit of work (RUW).

When a client is connected to a remote server while still logged in to the initial XDB Server, the system tables used for any new queries are the system tables on the remote location. Note that when connecting to a different XDB Server, you are not completely detached from previous XDB Servers. The routing software on each XDB Server is still used to determine from where the request came and to where it should go.

In this way, a client application can connect to any XDB Server in the distributed environment, as long as the Server and the locations it controls are registered in the system catalog tables.

  • Disconnecting
  • Privileges
  • Examples
  • System Tables
  • Configuring Server-to-Server Connectivity
Parent topic: Server-to-server Connectivity


Disconnecting

Note that when the client application is done with the location on the remote server, the client application can disconnect from the remote server (using the embedded SQL command CONNECT RESET). By disconnecting, all links to the remote server are removed and the connection is returned to the primary server. If multiple XDB Servers have been accessed in sequence, the connection will be returned to the XDB Server most recently controlling the client.

Note:

If SET LOCATION TO was used by any client to connect to the second server, there is no way to break the connection until the user ends the session.

Parent topic: Connect (Set Location) Access


Privileges

Control privileges at each individual server. Each server controls its own access security. Privileges granted at each server affect all users who connect to it, whether by logging in directly or accessing the server by connecting from another server. Additional access control can be had by using security mapping and global security. See the chapter Multiserver Security for a more detailed discussion of security mapping and global security.

Parent topic: Connect (Set Location) Access


Examples

All of the examples assume that each XDB Server has already been set up with the appropriate information in the system tables. If a request is made to connect to an unknown location not listed in the system tables, an X288 error message (Statement reference to remote object is invalid) is returned to the user.

Client1 is logged into the XDB Server xdbserve and is running the SQL Wizard. Client1 issues a SET LOCATION TO ORDERS command. The xdbserve server checks its system table SYSIBM.SYSLOCATIONS, which indicates that the location orders is controlled by the XDB Server sales.

The xdbserve server transfers the clients connection to the XDB Server sales. Note that each communication between client1 and the XDB Server sales must go through xdbserve (shown by the dashed lines through xdbserve).

Now, any requests that are sent by the client are verified by the system tables on the XDB Server sales. If client1 issues a SELECT query that references the table eastern.may without specifying a location, it is assumed that this table is in the location orders on the XDB Server sales.

To continue the example, client1 (who is logged in to xdbserve but connected to sales) issues a SET LOCATION TO PRODUCTS command. In this case, sales checks its system catalog table SYSIBM.SYSLOCATIONS, which indicates that the location products is controlled by the XDB Server develop.

Sales transfers the client's connection to the XDB Server develop. Any requests that are sent by the client are verified by the system catalog tables on the XDB Server develop. Communication between client1 and develop must still pass between the other XDB Servers to which it has been connected, xdbserve and sales. This communication is shown by the dashed lines through the XDB Servers.

Finally, consider that client1, connected to develop via xdbserve and sales, issues a SET LOCATION TO STAFF command. In this case, develop checks its system catalog table SYSIBM.SYSLOCATIONS, which indicates that the location staff is controlled by the XDB Server xdbserve.

This will create a communications loop back to xdbserve. This type of looping is not recommended, as the connections between the various servers creates congestion on each server. In addition, response time is increased because queries have to be passed between multiple servers.

Instead, keep track of the locations and servers you have accessed. If you are working interactively (for example, through the SQL Wizard), then log out and log back in. If you are using embedded SQL, issue CONNECT RESET commands after you no longer need the data on a particular server.

Parent topic: Connect (Set Location) Access


System Tables

You must insert data into two system tables, SYSIBM.SYSLUNAMES and SYSIBM.SYSLOCATIONS, on the primary XDB Server in order to use server-to-server connectivity via connect access. The tables on the primary server must be updated so that clients can get from the primary to the remote server.

Note: When updating SYSLOCATIONS and SYSLUNAMES, do not change or delete any records that appear blank. These records contain a space character in certain columns and are required to define the locations controlled by your local machine.

You must insert values into columns labeled "required" in order to use server-to-server connectivity. All other columns can have NULL values. Several of the other columns in the SYSIBM.SYSLUNAMES table are used for security mapping. See the chapter Multiserver Security for more information on these values.

  • SYSIBM.SYSLUNAMES
  • SYSIBM.SYSLOCATIONS
  • Sample System Tables
Parent topic: Connect (Set Location) Access


SYSIBM.SYSLUNAMES

The columns in this table contain information on LUNAMES used for server-to-server or Link connectivity.

Name | Type | Len | Description
LUNAME required | CHAR | 8 | Name of the XDB Server, if using server-to-server connectivity. Name of the LU for one or more accessible DB2 systems if using XDB Link. Blank indicates the current XDB Server.
SYSMODENAME | CHAR | 8 | Mode used to establish intersystem conversations.
USERSECURITY | CHAR | 1 | Acceptance option for a remote attach:
 |  |  | C | "Conversation." A request is checked by the internal security system and must include a password.
 |  |  | A | "Already Verified." A request does not need a password, although a password is checked if it is sent. A is the default.
 |  |  | Any character that is not C is treated as an A.
ENCRYPTPSWDS | CHAR | 1 | Included for DB2 compatibility only. Tells whether passwords for DB2 LUs are encrypted:
 |  |  | Y | Passwords are encrypted.
 |  |  | N | Passwords are not encrypted.
 |  |  | The XDB Server always uses encrypted passwords, even if set to N.
MODESELECT | CHAR | 1 | Not used in XDB Server.
USERNAMES | CHAR | 1 | Whether an ID accompanying a remote attach request is subject to translation.
 |  |  | I | Inbound ID, from the corresponding LUNAME, is subject to translation.
 |  |  | O | Outbound ID, sent to the corresponding LUNAME, is subject to translation.
 |  |  | B | Both inbound and outbound IDs are subject to translation.
 |  |  | blank | No translation is done for either inbound or outbound IDs.
Parent topic: System Tables


SYSIBM.SYSLOCATIONS

The columns in this table contain information about all locations that are accessible for RUW and DUW processing, including local locations in SYSXDB.SYSLOCALS plus remote locations accessible using server-to-server connectivity or XDB Link.

Name | Type | Len | Description
LOCATION required | CHAR | 16 | Name of the location.
LOCTYPE required | CHAR | 1 | Indicates the location type:
 |  |  | X | XDB
 |  |  | R | RPC
 |  |  | C | CICS
 |  |  | D | DRDA
LINKNAME required | CHAR | 8 | Name of the XDB Server which controls the location, if using server-to-server connectivity. LUNAME for the accessible system if using the XDB Link.
LINKATTR required | VARCHAR | 64 | Type of protocol used to connect to the XDB Server when using server-to-server connectivity:
 |  |  | S | SPX
 |  |  | B | NetBIOS
 |  |  | N | Named Pipes
 |  |  | T | TCP/IP (Set the hostname and IP address in the XDBNET.INI file.)
 |  |  | or The name of the mainframe program with which XDB Link will communicate if using XDB Link.
Parent topic: System Tables


Sample System Tables

The tables in this topic show the values needed in the system tables on various XDB Servers to execute the examples discussed.

The following table shows the values needed in the system table SYSIBM.SYSLUNAMES on the primary XDB Server xdbserve to execute the examples discussed in this topic for connect access.

LUNAME | SYSMODE-NAME | USER-SECURITY | ENCRYPT-PSWDS | MODE-SELECT | USER-NAMES
sales |  |  |  |  |

This table indicates that the XDB Server sales can be accessed from xdbserve.

The following table shows the values needed in SYSIBM.SYSLOCATIONS on the XDB Server xdbserve to execute the examples discussed in this topic for connect access.

LOCATION | LOCTYPE | LINKNAME | LINKATTR
staff | X |  |
orders | X | Sales | B

The first row indicates that the staff location is an XDB Server location controlled by the current (primary) XDB Server xdbserve.

The second row indicates that the orders location is an XDB Server location controlled by a remote XDB Server sales, and can be reached via the NetBIOS protocol.

  • Sales Server
  • Develop Server
Parent topic: System Tables


Sales Server

The following table shows the values needed in the system table SYSIBM.SYSLUNAMES on the XDB Server sales to execute the examples discussed in this topic for connect access.

LUNAME | SYSMODE-NAME | USER-SECURITY | ENCRYPT-PSWDS | MODE-SELECT | USER-NAMES
Develop |  |  |  |  |

This table indicates that the XDB Server develop can be accessed from sales.

The following table shows the values needed in SYSIBM.SYSLOCATIONS on the XDB Server sales to execute the examples discussed in this topic for connect access.

LOCATION | LOCTYPE | LINKNAME | LINKATTR
orders | X |  |
products | X | develop | N

The first row indicates that the orders location is an XDB Server location controlled by the current XDB Server sales.

The second row indicates that the products location is a location controlled by a remote XDB Server sales, and can be reached via the Named Pipes protocol.

Parent topic: Sample System Tables


Develop Server

The following table shows the values needed in the system table SYSIBM.SYSLUNAMES on the XDB Server develop to execute the examples discussed in this topic for connect access.

LUNAME | SYSMODE-NAME | USER-SECURITY | ENCRYPT-PSWDS | MODE-SELECT | USER-NAMES
xdbserve |  |  |  |  |
sales |  |  |  |  |

The first row indicates that the XDB Server xdbserve can be accessed from develop.

The second row indicates that the XDB Server sales can be accessed from develop.

The following table shows the values needed in SYSIBM.SYSLOCATIONS on the XDB Server develop to execute the examples discussed in this topic for connect access.

LOCATION | LOCTYPE | LINKNAME | LINKATTR
staff | X | xdbserve | B
products | X |  |

The first row indicates that the staff location is a location controlled by a remote XDB Server xdbserve, and can be reached via the NetBIOS protocol.

The second row indicates that the products location is an XDB location controlled the current XDB Server, develop.

Parent topic: Sample System Tables


Configuring Server-to-Server Connectivity

In order to set up server-to-server connectivity, you must configure both the primary XDB Server and the remote XDB Server. The primary XDB Server is the XDB Server which clients will log into. From this server, they will be able to access remote locations by connecting to the remote server. The instructions in this topic discuss one primary server with one remote server.

If you wish to have a fully distributed environment, complete the Primary Server Configuration instructions for each XDB Server that you wish to be a primary XDB Server. Complete the Remote Server Configuration instructions for each XDB Server you wish to be a remote XDB Server.

The following instructions assume that security is turned on (through the XDB Server Configuration utility) for the Primary XDB Server.

  • Primary Server Configuration
  • Remote Server Configuration
  • Configuring Server Access
Parent topic: Connect (Set Location) Access


Primary Server Configuration

To configure a server as a primary XDB Server, you must update the system tables. In the examples, the primary XDB Server is xdbserve.

To update the system tables:

Note: When updating system tables, do not delete any seemingly empty records; these contain space characters in some columns and refer to locations controlled by your local XDB Server.
  1. On any client logged in to the primary XDB Server, start SQL Wizard.
  2. Log in with an AuthID that has super user privileges, such as the INSTALL AuthID, provided with the XDB Server.
  3. From an SQL Window set the current location to the SYSTEM location:
    SET LOCATION TO system;
  4. Issue the following SQL command to insert information about a remote server into the SYSIBM.SYSLUNAMES table:
    INSERT INTO sysibm.syslunames
    VALUES ("remote-server","","","","","");

    where remote-server is the name of a remote XDB Server to be accessed. Several of the other columns in the SYSIBM.SYSLUNAMES table are used for security mapping. See the chapter Multiserver Security for more information on using these values.

    In the examples , the SQL command:

    INSERT INTO SYSIBM.SYSLUNAMES
    VALUES ("sales","","","","","");

    would have been issued on the XDB Server XDBSERVE.

  5. Issue the following SQL command to insert information about a remote location into the SYSIBM.SYSLOCATIONS table:
    INSERT INTO SYSIBM.SYSLOCATIONS
    VALUES ("remote-location","X",
            "remote-server","link-type");

    where:

    remote-location | is the name of the remote location to be accessed (unique among all locations on all servers that are used in distributed processing).
    X | indicates it is an XDB Server.
    remote-server | is the name of the remote server that controls the remote location.
    link-type | is the communication protocol used to connect to the remote server.

    In the examples used in this topic, the SQL command:

    INSERT INTO SYSIBM.SYSLOCATIONS
    VALUES ("orders","X","sales","B");

    would have been issued on the XDB Server XDBSERVE.

  6. Repeat Steps 4 and 5 for each remote XDB Server and location that will be accessed from this primary server.
  7. Issue the following SQL command to refresh the system:
    REFRESH LOCATIONS;
  8. Exit SQL Wizard.
Parent topic: Configuring Server-to-Server Connectivity


Remote Server Configuration

The remote XDB Server must be configured and privileges must be granted. In the examples, the remote XDB Server is sales.

If security is on, clients must have privileges on the tables they wish to access on the remote server. Be sure to grant the appropriate privileges to each client on the remote server.

AuthIDs are created using the SQL Wizard Admin menu. Privileges are granted using the SQL GRANT command via the SQL Wizard. See the chapter Security and Authority for more information on AuthIDs and privileges.

AuthID mapping can make this task much easier in a large distributed environment. See the chapter Multiserver Security for more information about AuthID mapping.

Parent topic: Configuring Server-to-Server Connectivity


Configuring Server Access

Once you have configured the primary and remote servers, use the following procedure to configure access:

  1. From the Client Options dialog box, Connect tab, configure the following:
    Control Group | Control Name | Value
    Network Info | Server Name | A new server name
    Communication Protocol | TCP/IP
    IP Address | The remote machine name or its IP address
    TCP Port | Port to use on the remote machine (8898 is the default)
    Connect To | Locations | A unique name for the remote location, different from all local location names
  2. Click OK.
  3. Using SQL Wizard, attempt to log onto the remote server. If you are not successful, verify that your settings are correct. To do this:
    1. At a command prompt, use the Windows ping command to verify that the machine name or IP address in the IP Address field is correct and can be resolved. If this doesn't work, verify with IT that the machine name or IP address can be resolved and the destination is reachable.
    2. At a command prompt, use the Windows telnet command to verify that you can establish a connection to the server (telnet machine port). If a connection is refused:
      • Verify that the remote server is running
      • Using the IPCONFIG on the remote machine, verify that the machine name/IP Address is valid
      • Using the NETSTAT command, verify that the server is running and listening on the proper port
      • Ensure that your firewall software isn't preventing the connection
  4. From the Connect tab on the Options dialog box, set the Server Name back to your local server; then click OK.
  5. From SQL Wizard, enter the following INSERT statements to add the server location to the local servers SYSTEM location:

    INSERT INTO SYSTEM.SYSIBM.SYSLUNAMES (LUNAME) VALUES (" ServerName ");

    INSERT INTO SYSTEM.SYSIBM.SYSLOCATIONS VALUES (" LocationName ","X", " ServerName ","T");

    where ServerName is the server name you specified in step 1, and LocationName is the name of the remote location you specified in step 1.

  6. Shut down and restart the local server to ensure that the local server picks up the new location.
  7. Start SQLWizard on the local machine.

The new location should now appear on the list of locations in the Catalog Browser. The remote location should be accessible through the SQLWizard Catalog Browser and available for any program or utility connecting to the local server.

Parent topic: Configuring Server-to-Server Connectivity


Multiserver Security

In a distributed environment with server-to-server connectivity, there will generally be more than two servers and a large number of users. There can be duplicate AuthIDs on different servers, such as a Bob in development and a Bob in sales.

Different servers can have different levels of privileges and table access. For example, on the XDB Server develop all users might be allowed access to all tables in the products location. On the XDB Server sales, access to the orders location might be restricted to a particular group or AuthID.

The XDB Server provides several methods of security and administration control. Outbound mapping allows you to translate an AuthID (username) and password before a request is sent to a remote XDB Server, providing another method of controlling communications with other XDB Servers. Inbound mapping translates an AuthID on a remote server after login, providing another method of controlling access on an XDB Server.

Trusting allows you to bypass verifying a name and password with the system catalog tables on the remote server, eliminating one step in the login and verification process. Global security allows you to set up one server to handle all security, eliminating redundancy and reducing the possibility of erroneous entries in the system catalog tables.

In a distributed environment with multiple administrators, users and servers, cooperation among administrators is imperative. Coordination can eliminate duplicate location names and AuthIDs. Rejected logins and lack of privileges can also be avoided.

Throughout this documentation, the term primary server is used to refer to the XDB Server to which the user is connected. The term remote server is the XDB Server elsewhere on the LAN that controls the location the user wishes to access.

Note:

Be sure to read this Multiserver Security topic carefully before attempting to map AuthIDs or passwords. When using multiple servers, mappings and trusting, it is very easy to miss one step and confuse everything.

  • Outbound Mapping
  • Inbound Mapping
  • Trusting
  • Global Security
  • Outbound, Inbound and Trusting Used Together
Parent topic: SQL Option Server Administration Guide


Outbound Mapping

Outbound mapping allows you to translate an AuthID and passwords before a request is sent to a remote XDB Server. A request can be sent that either references a remote location controlled by another XDB Server (using a three-part name) or the remote XDB Server itself (using CONNECT). The values in the system catalog table SYSIBM.SYSLUNAMES indicate that requests going to the remote XDB Server should be translated. Based on the values in SYSIBM.SYSUSERNAMES, the AuthID is mapped and the request is sent to the remote server as if it came from the newly mapped AuthID.

Mapping AuthIDs before they leave an XDB Server can be useful when a particular remote XDB Server is configured to accept requests from only one or two AuthIDs. This allows you to translate all AuthIDs going to that XDB Server into valid AuthIDs for a remote XDB Server. Outbound mapping can also be used to eliminate duplicate AuthIDs at different XDB Servers. Any potential duplicate AuthID (or all AuthIDs) can be mapped to different AuthIDs before requests are sent to remote XDB Servers.

While remote XDB Servers can be configured to allow all users access from your XDB Server, outbound mapping keeps the administration tasks on one XDB Server. In a distributed environment with many XDB Servers, it can quickly become confusing to have to track the current valid AuthIDs for all other XDB Servers in order to maintain your own system tables. Outbound mapping allows you to control how queries appear when leaving a particular XDB Server.

  • Privileges
  • Examples
  • System Tables
  • Sample System Tables
  • Setting up Outbound Mapping
Parent topic: Multiserver Security


Privileges

Control privileges at each individual server. Each server controls its own access security. When using outbound mapping, make sure that the new AuthID given is a valid AuthID at the remote XDB Server to which the request is being sent. The new AuthID must be a valid AuthID, created by the SQL Wizard Admin menu and listed in the SYSXDB.SYSACFUSERS table. If inbound mapping is not being used on the remote XDB Server, the AuthID sent must also have the appropriate privileges to access data.

Parent topic: Outbound Mapping


Examples

Bob is logged in to the XDB Server develop. He issues a SELECT command referencing orders.eastern.may. This request is received by the XDB Server develop. Develop determines that the orders location is controlled by the XDB Server sales. Develop checks its system catalog table SYSIBM.SYSLUNAMES, which indicates that any request going to sales is subject to outbound mapping.

Develop then checks the system table SYSIBM.SYSUSERNAMES, which indicates the AuthID of Bob should be translated to devbob for all requests to the XDB Server sales. The SELECT request referencing ORDERS.EASTERN.MAY is sent to sales with an AuthID of devbob.

The SELECT request is then received at the XDB Server sales. If inbound mapping is not being used, sales verifies that the AuthID devbob is a valid AuthID in the SYSXDB.SYSACFUSERS table. The SELECT query is processed, privileges are checked and a result is returned to Bob via the XDB Server develop.

As another example, consider that any user accessing develop issues a request referencing data on the XDB Server sales. According to the system table SYSIBM.SYSUSERNAMES on develop, the AuthID on all outbound requests to sales are mapped to developr.

In this case, the system administrator of the XDB Server sales needs to maintain only one account, developr, for users from the XDB Server develop. As users are added and removed from develop, the system administrator of sales does not need to modify accounts or system tables to reflect these changes. No matter what the AuthID on develop, it will be mapped to developr before it is sent to sales.

Parent topic: Outbound Mapping


System Tables

Outbound mapping requires you to update the SYSIBM.SYSLUNAMES and SYSIBM.SYSUSERNAMES tables with information for mapping users on the primary XDB Server that will be performing outbound mapping. This can be done through the SQL Wizard.

Note: When updating system tables, do not change or delete any records that appear blank. These records contain a space character in certain columns and are required to define the locations controlled by your local machine.

You must insert values into columns labeled "required" in order to use outbound mapping. All other columns can have NULL values. Other columns in SYSIBM.SYSLUNAMES are used for trusting. See the section Trusting for more information on these values.

  • SYSIBM.SYSLUNAMES
  • SYSIBM.SYSUSERNAMES
Parent topic: Outbound Mapping


SYSIBM.SYSLUNAMES

The columns in this table contain information on LUNAMES used for server-to-server or Link connectivity.

Name | Type | Len | Description
LUNAME required | CHAR | 8 | Name of the XDB Server, if using server-to-server connectivity. Name of the LU for one or more accessible DB2 systems if using XDB Link. Blank indicates the current XDB Server.
SYSMODENAME | CHAR | 8 | Mode used to establish intersystem conversations.
USERSECURITY | CHAR | 1 | Acceptance option for a remote attach:
 |  |  | C | "Conversation." A request is checked by the internal security system and must include a password.
 |  |  | A | "Already Verified." A request does not need a password, although a password is checked if it is sent. A is the default.
 |  |  | Any character that is not C is treated as an A.
ENCRYPTPSWDS | CHAR | 1 | Included for DB2 compatibility only. Tells whether passwords for DB2 LUs are encrypted:
 |  |  | Y | Passwords are encrypted.
 |  |  | N | Passwords are not encrypted.
 |  |  | The XDB Server always uses encrypted passwords, even if set to N.
MODESELECT | CHAR | 1 | Not used.
USERNAMES required | CHAR | 1 | Whether an ID accompanying a remote attach request is subject to translation.
 |  |  | I | Inbound ID, from the corresponding LUNAME, is subject to translation.
 |  |  | O | Outbound ID, sent to the corresponding LUNAME, is subject to translation.
 |  |  | B | Both inbound and outbound IDs are subject to translation.
 |  |  | blank | No translation is done for either inbound or outbound IDs.
Parent topic: System Tables


SYSIBM.SYSUSERNAMES

The columns in the following table contain information used by the XDB Server for processing requests to other XDB Servers using server-to-server connectivity or to DB2 locations through XDB Link.

Name | Type | Len | Description
TYPE required | CHAR | 1 | Indicates how the row is to be used:
 |  |  | I | For inbound IDs.
 |  |  | O | For outbound IDs.
AUTHID required | CHAR | 8 | An authorization ID that is allowed and perhaps translated. If blank, any AuthID with the corresponding LUNAME is translated in the same manner.
LUNAME required | CHAR | 8 | The name of the XDB Server, if using server-to-server connectivity, or LUNAME, if using XDB Link, for which the AuthID is to be translated. If blank, the corresponding AuthID is translated the same for all XDB Servers.
NEWAUTHID required | CHAR | 8 | The translated value of the AuthID. If blank, the translated AuthID and password are the same as the original AuthID.
PASSWORD required | CHAR | 8 | Password for an outbound request.
Parent topic: System Tables


Sample System Tables

The following table shows values needed in the system table SYSIBM.SYSLUNAMES on the primary XDB Server, develop, to implement the examples discussed in this topic for outbound mapping (without trusting).

LUNAME | SYSMODE-NAME | USER-SECURITY | ENCRYPT-PSWDS | MODE-SELECT | USER-NAMES
sales |  |  |  |  | O

This table indicates that all requests sent to the XDB Server sales are subject to outbound mapping.

The following table shows the values needed in the system table SYSIBM. SYSUSERNAMES on the XDB Server develop to implement the outbound mapping examples used in this topic. This table also shows several other valid records, explained after the table. Please note that the NO. column is not actually part of the table, and is only displayed for reference.

NO. | TYPE | AUTHID | LUNAME | NEWAUTHID | PASSWORD
1 | O | bob | sales | devbob | devbpass
2 | O | debbie | sales | developr | devpass
3 | O | bruce | sales | developr | devpass
4 | O | eric | sales |  | devepass
5 | O | david |  | devdavid | devdpass
6 | O | arlene |  |  | arlpass
7 | O |  | sales | developr | devpass

Row 1 maps Bob to devbob for all requests sent to sales. This is the configuration used in the examples on outbound mapping.

Rows 2 and 3 map Debbie and Bruce to developr for all requests sent to sales. Here, developr is assumed to be a group of people.

Row 4 does not map Eric when sending requests to sales. Eric is assumed to be an AuthID on SALES. If Eric tried to go to SALES, the Row 4 mapping would take precedence over the Row 7 mapping because it mentions a specific AuthID.

Row 5 maps David to devdavid anytime outbound requests are sent to any server.

Row 6 does not map Arlene when sending request to any remote servers. Arlene is assumed to be an AuthID on all other servers.

Row 7 maps all AuthIDs to developr when sending requests to sales. The mappings of rows 1 through 6 take precedence over Row 7 mapping because they mention specific AuthIDs.

Parent topic: Outbound Mapping


Setting up Outbound Mapping

In order to use outbound mapping, you must update system tables on the primary XDB Server which will perform the outbound mapping. On the remote XDB Server, you must set up the appropriate AuthIDs, mappings and privileges.

The instructions in each topic discuss outbound mapping on one XDB Server. If you wish to have a fully distributed environment, complete the Primary Server instructions on each XDB Server that will perform outbound mapping. Complete the Remote Server instructions on each XDB Server which will accept mapped AuthIDs.

All of the following instructions assume that security is turned on (through the XDB Server Configuration Utility) for both the Primary and Remote XDB Servers.

The instructions in this topic are written as if you have already set up server-to-server connectivity before setting up outbound mapping. These instructions also assume you will not be setting up inbound mapping on the remote server.

  • Primary Server Configuration
  • Remote Server Configuration
Parent topic: Outbound Mapping


Primary Server Configuration

These steps must be performed on the XDB Server that will be performing outbound mapping. In the examples, the XDB Server develop is performing outbound mapping.

To update the system tables:

Note: When updating system tables, do not delete any seemingly empty records; these contain space characters in some columns and refer to locations controlled by your local XDB Server.
  1. On any client logged in to the primary XDB Server, start SQL Wizard.
  2. Log in with an AuthID that has super user privileges, such as the INSTALL AuthID, provided with the XDB Server.
  3. From an SQL Window, set the current location to the system location:
    SET LOCATION TO system;
  4. Issue the following SQL command to update information in the SYSIBM.SYSLUNAMES table about server-to-server connectivity and outbound mapping.
    UPDATE sysibm.syslunames SET username = "O"
    WHERE luname = "remote-server";

    where:

    O | indicates that requests going to the remote XDB Server will be subject to outbound mapping.
    remote-server | is the name of a remote XDB Server for which AuthIDs will be mapped.

    Other columns in the SYSIBM.SYSLUNAMES table are used for trusting servers. See the section Trusting for more information on using these values.

    In the examples on outbound mapping used in this topic, the SQL command:

    UPDATE sysibm.syslunames SET username = "O"
    WHERE luname = "sales";

    would have been issued on the XDB Server develop.

  5. Issue the following SQL command to insert information into the SYSIBM.SYSUSERNAMES table about AuthIDs that will be subject to outbound mapping.
    INSERT INTO SYSIBM.SYSUSERNAMES
    VALUES("O","authid","servername",
           "newauthid","password");

    where:

    O | indicates outbound mapping will be performed.
    authid | is the name of the AuthID to be translated from.
    servername | is the name of the server for which this AuthID will be translated.
    newauthid | is the new AuthID that will be given.
    password | is the password to be used with the new AuthID. Enter the password as regular ASCII text. It will be encrypted by the engine before being stored. Subsequent displays of PASSWORD column data show the encrypted password.

    In the examples on outbound mapping used in this topic, the SQL command:

    INSERT INTO SYSIBM.SYSUSERNAMES
    VALUES("O","bob","sales", "devbob","devbpass");

    would have been issued on the XDB Server develop.

  6. Repeat Step 4 for each Server for which outbound requests will be mapped. Repeat Step 5 for each AuthID that will be subject to outbound mapping.
  7. Issue the following SQL command to refresh the system:
    REFRESH LOCATIONS;
  8. Exit SQL Wizard.
Parent topic: Setting up Outbound Mapping


Remote Server Configuration

The remote XDB Server that will receive the translated ID must be configured to accept the new AuthID and database privileges must be given. In the examples, the remote XDB Server is sales.

Make sure the translated AuthID is a valid AuthID in SYSXDB.SYSACFUSERS. Use the SQL Wizard to add users. In the examples used earlier, the AuthID of devbob would have to be a valid AuthID on the XDB Server sales.

If inbound mapping will not be used on the remote server, grant the appropriate privileges to the translated AuthID using the SQL GRANT command. In the examples used earlier, the AuthID of devbob would have to be given privileges on the XDB Server sales.

If inbound mapping will be used, make sure there is a record in the SYSIBM.SYSLUNAMES on the remote server that references the server from which the request comes. Also, make sure there is a record in SYSIBM.SYSUSERNAMES on the remote server that references the translated AuthID. See the section Outbound, Inbound and Trusting Used Together for more information.

Parent topic: Setting up Outbound Mapping


Inbound Mapping

Inbound mapping means that an AuthID (username) is mapped to a different value after logging in at an XDB Server. A request is received at either the remote server that references a location controlled by the remote server (using three-part names) or the server itself (using CONNECT).

The values in the SYSIBM.SYSLUNAME table indicate that requests coming from the primary XDB Server should be translated. If a password is present, the AuthID and password are checked against SYSXDB.SYSACFUSERS. See the section Trusting for more about password checking. Then, the SYSIBM.SYSUSERNAMES table is checked and the AuthID is mapped. Finally, the request is processed with the AuthID obtained by inbound mapping.

Mapping AuthIDs on an XDB Server that will accept requests from other XDB Servers allows you to have more control over which AuthIDs have access. If inbound mapping is not used, you must update the SYSXDB.SYSACFUSERS table with all AuthIDs that will have access. These users must also be given the appropriate privileges. In a distributed environment, this can mean keeping track of hundreds of individual AuthIDs. You can map incoming AuthIDs into a manageable number of AuthIDs. Then only the mapped AuthIDs must be given privileges to access data objects.

  • Privileges
  • Examples
  • System Tables
  • Sample System Tables
  • Setting Up Inbound Mapping
Parent topic: Multiserver Security


Privileges

Control privileges at each individual server. Each server controls its own access security. When using inbound mapping, make sure that the new AuthID has the appropriate privileges to access data.

Parent topic: Inbound Mapping


Examples

Debbie is logged in to the XDB Server develop. She issues a SELECT command referencing orders.eastern.may. This request is received by the XDB Server develop. Based on the system tables on develop, outbound mapping might occur. Assuming that outbound mapping does not occur, the SELECT request referencing orders.eastern.may is sent to sales with an AuthID of debbie.

The SELECT request is then received at the XDB Server sales. After the presence of a password is checked (see the section Trusting), the SYSIBM.SYSLUNAMES table is checked and indicates requests from the Server develop are subject to inbound mapping. The AuthID of debbie and the accompanying password are checked against the SYSXDB.SYSACFUSERS table.

Next, the values in SYSIBM.SYSUSERNAMES indicate that any request from the XDB Server develop should be mapped to an AuthID of developr. Finally, the SELECT command referencing orders.eastern.may is processed with an AuthID of developr. Privileges are checked and a result is returned to debbie via the XDB Server develop.

Parent topic: Inbound Mapping


System Tables

Inbound mapping requires you to update the SYSIBM.SYSLUNAMES and SYSIBM.SYSUSERNAMES tables with information for mapping users on the remote XDB Server that will be performing inbound mapping. This can be done through SQL commands in the SQL Wizard.

Note: When updating system tables, do not change or delete any records that appear blank. These records contain a space character in certain columns and are required to define the locations controlled by your local machine.

You must insert values into columns labeled "required" in order to use inbound mapping. All other columns can have NULL values. Other columns in SYSIBM.SYSLUNAMES are used for trusting. See the section Trusting for more information on these values.

  • SYSIBM.SYSLUNAMES
  • SYSIBM.SYSUSERNAMES
Parent topic: Inbound Mapping


SYSIBM.SYSLUNAMES

The columns of this table contain information on LUNAMES used for server-to-server or Link connectivity.

Name | Type | Len | Description
LUNAME required | CHAR | 8 | Name of the XDB Server, if using server-to-server connectivity. Name of the LU for one or more accessible DB2 systems if using XDB Link. Blank indicates the current XDB Server.
SYSMODENAME | CHAR | 8 | Mode used to establish intersystem conversations.
USERSECURITY | CHAR | 1 | Acceptance option for a remote attach:
 |  |  | C | "Conversation." A request is checked by the internal security system and must include a password.
 |  |  | A | "Already Verified." A request does not need a password, although a password is checked if it is sent. A is the default.
 |  |  | Any character that is not C is treated as an A.
ENCRYPTPSWDS | CHAR | 1 | Included for DB2 compatibility only. Tells whether passwords for DB2 LUs are encrypted:
 |  |  | Y | Passwords are encrypted.
 |  |  | N | Passwords are not encrypted.
 |  |  | The XDB Server always uses encrypted passwords, even if set to N.
MODESELECT | CHAR | 1 | Not used.
USERNAMES required | CHAR | 1 | Whether an ID accompanying a remote attach request is subject to translation.
 |  |  | I | Inbound ID, from the corresponding LUNAME, is subject to translation.
 |  |  | O | Outbound ID, sent to the corresponding LUNAME, is subject to translation.
 |  |  | B | Both inbound and outbound IDs are subject to translation.
 |  |  | blank | No translation is done for either inbound or outbound IDs.
Parent topic: System Tables


SYSIBM.SYSUSERNAMES

The columns in this table contain user information used by the XDB server for processing requests to other XDB Servers using server-to-server connectivity or to DB2 locations through XDB Link.

Name | Type | Len | Description
TYPE required | CHAR | 1 | Indicates how the row is to be used:
 |  |  | I | For inbound IDs.
 |  |  | O | For outbound IDs.
AUTHID required | CHAR | 8 | An authorization ID that is allowed and perhaps translated. If blank, any AuthID with the corresponding LUNAME is translated in the same manner.
LUNAME required | CHAR | 8 | The name of the XDB Server, if using server-to-server connectivity, or LUNAME, if using XDB Link, for which the AuthID is to be translated. If blank, the corresponding AuthID is translated the same for all XDB Servers.
NEWAUTHID required | CHAR | 8 | The translated value of the AuthID. If blank, the translated AuthID and password are the same as the original AuthID.
PASSWORD | CHAR | 8 | Password for an outbound request.
Parent topic: System Tables


Sample System Tables

The following table shows values needed in the system table SYSIBM.SYSLUNAMES on the remote XDB Server sales to implement the examples discussed in this topic for inbound mapping (without trusting).

LUNAME | SYSMODE-NAME | USER-SECURITY | ENCRYPT-PSWDS | MODE-SELECT | USER-NAMES
develop |  |  |  |  | I

This table indicates that all requests received from the XDB Server develop are subject to inbound mapping.

The following table shows the values needed in the system table SYSIBM. SYSUSERNAMES on the XDB Server sales to implement the inbound mapping examples used in this topic. This table also shows several other valid records, explained after the table. Please note that the NO. column is not actually part of the table, and is only displayed for reference.

NO. | TYPE | AUTHID | LUNAME | NEWAUTHID | PASSWORD
1 | i | debbie | develop | developr |
2 | i | arlene | develop | nora |
3 | i |  | develop | developr |
4 | i | harold |  | harry |

Row 1 maps Debbie to developr for all requests received from the XDB Server develop. This is the configuration used in the examples on inbound mapping.

Row 2 maps arlene to nora for all requests from the XDB Server develop.

Row 3 maps any AuthID to developr for request received from the XDB Server develop.

Row 4 maps harold to harry for requests received from any XDB Server.

In this example, rows 1, 2 and 4 take precedence over row 3 because they mention specific AuthIDs.

Parent topic: Inbound Mapping


Setting Up Inbound Mapping

In order to use inbound mapping, you must update system tables and privileges on each remote XDB Server that will perform the inbound mapping. If server trusting is not being used, nothing needs to be done on the servers sending requests.

The instructions in each topic discuss inbound mapping on one XDB Server. If you wish to have a fully distributed environment, complete the Remote Server instructions on each XDB Server that will perform inbound mapping.

All of the following instructions assume that security is turned on (through the XDB Server Configuration Utility) for both the primary and remote XDB Servers.

The instructions in this topic assume you have already setup server-to-server connectivity before setting up inbound mapping. These instructions also assume you will not be setting up outbound mapping on the primary server.

  • Primary Server Configuration
  • Remote Server Configuration
Parent topic: Inbound Mapping


Primary Server Configuration

On the primary XDB Server, simply setup server-to-server connectivity so that requests can reach the remote server. No additional configuration is needed on the primary XDB Server to use inbound mapping. However, if you wish to use inbound and outbound mapping together, consult the topic on Outbound, Inbound and Trusting Used Together for more information.

Parent topic: Setting Up Inbound Mapping


Remote Server Configuration

These steps must be performed on the XDB Server that will be performing inbound mapping. In the examples, the XDB Server sales is performing inbound mapping.

To update the system tables:

Note:

When updating system tables, do not delete any seemingly empty records; these contain space characters in some columns and refer to locations controlled by your local XDB Server.

  1. On any client logged in to the remote XDB Server, start the SQL Wizard.
  2. Log in with an AuthID that has super user privileges, such as the INSTALL AuthID, provided with the XDB Server.
  3. From an SQL Window, set the current location to the SYSTEM location:
    SET LOCATION TO system;
  4. Issue the following SQL command to update information in the SYSIBM.SYSLUNAMES table about server-to-server connectivity and inbound mapping.
    UPDATE sysibm.syslunames SET username = "I"
    WHERE luname = "servername";

    where:

    I | indicates inbound mapping will be performed.
    servername | is the name of another XDB Server from which AuthIDs will be mapped.

    Other columns in the SYSIBM.SYSLUNAMES table are used for trusting servers.

    In the examples on inbound mapping used in this topic, the SQL command:

    UPDATE sysibm.syslunames SET username = "I"
    WHERE luname = "develop";

    would have been issued on the XDB Server SALES.

  5. Issue the following SQL command to insert information into the SYSIBM.SYSUSERNAMES table about AuthIDs that will be subject to inbound mapping.
    INSERT INTO SYSIBM.SYSUSERNAMES
    VALUES("I","authid","servername",
           "newauthid","");

    where:

    I | indicates inbound mapping will be performed.
    authid | is the name of the AuthID to be translated from.
    servername | is the name of the server from which the AuthID to be translated will originate.
    newauthid | is the new AuthID that will be given.

    In the examples on inbound mapping used in this topic, the SQL command:

    INSERT INTO sysibm.sysusernames
    VALUES("I","debbie","develop","developr","");

    would have been issued on the XDB Server sales.

  6. Repeat Step 4 for each server from which inbound requests will be mapped. Repeat Step 5 for each AuthID that will be subject to inbound mapping.
  7. Issue the following SQL command to refresh the system:
    REFRESH LOCATIONS;
  8. Exit the SQL Wizard.

Use the SQL GRANT command to grant the appropriate privileges to the new AuthIDs. In the examples on inbound mapping in this topic, the AuthID developr would have to be granted SELECT privileges on the table MAY in the location orders.

Parent topic: Setting Up Inbound Mapping


Trusting

Without trusting, any time a login request is received by an XDB Server, the AuthID and password must be verified. Trusting (available only in conjunction with inbound mapping) allows an XDB Server to bypass verifying the password with SYSXDB.SYSACFUSERS each time a request is received via server-to-server connectivity. The remote server receives a request that references either a location controlled by the remote server (using three-part names) or the server itself (using CONNECT). If no password is sent to the remote XDB Server, SYSIBM.SYSLUNAMES is checked to ensure that the request from the primary server is already verified and a password is not needed.

The SYSIBM.SYSLUNAMES table is also checked to determine if inbound mapping is being used. If inbound mapping is being used the presence of a password is again checked. If a password was sent, the AuthID and password are verified with SYSXDB.SYSACFUSERS. If no password is included, then the AuthID is not verified because the information from that primary server can be trusted. Then, SYSIBM.SYSUSERNAMES is checked and the AuthID is mapped. Finally, privileges are checked and the query is processed.

If inbound mapping is not being used, the AuthID and password are verified with SYSXDB.SYSACFUSERS. Privileges are then checked and the query is processed.

Trusting can only been performed in conjunction with inbound mapping on a remote server. The remote server will be changing any AuthIDs received from a particular server. The AuthIDs to be mapped can be maintained in SYSXDB.SYSUSERNAMES.

  • Example
  • System Tables
  • Sample System Tables
  • Setting Up Trusting
Parent topic: Multiserver Security


Example

Bruce is logged in to the XDB Server develop. He issues a SELECT command referencing orders.eastern.may. This request is received by the XDB Server develop. Based on the system tables on develop, outbound mapping might occur. Assuming that outbound mapping does not occur, the SELECT request referencing orders.eastern.may is sent to sales with an AuthID of bruce and no password.

The SELECT request is then received at the XDB Server sales with an AuthID of bruce and no password. Since no password is present, SYSIBM.SYSLUNAMES is checked on sales. The values in this table indicate that all requests coming from the XDB Server develop are to be trusted. The values in SYSIBM.SYSLUNAMES also indicate that requests from the XDB Server develop are subject to inbound mapping.

Since no password accompanied the request, SYSIBM.SYSUSERNAMES is checked next. The values in this table indicate that any request from the XDB Server develop should be mapped to an AuthID of developr. Finally, the SELECT command referencing orders.eastern.may is processed with an AuthID of developr. Privileges are checked and a result is returned to bruce via the XDB Server develop.

Parent topic: Trusting


System Tables

Trusting requires you to update the SYSIBM.SYSLUNAMES table on the remote XDB Server that will be receiving requests. Updates can be performed using the SQL Wizard.

Note: When updating system tables, do not change or delete any records that appear blank. These records contain a space character in certain columns and are required to define the locations controlled by your local machine.

You must insert values into columns labeled "required" in order to use trusting.

  • SYSIBM.SYSLUNAMES
Parent topic: Trusting


SYSIBM.SYSLUNAMES

The columns in this table contain information on LUNAMES used for server-to-server or Link connectivity.

Name | Type | Len | Description
LUNAME required | CHAR | 8 | Name of the XDB Server, if using server-to-server connectivity. Name of the LU for one or more accessible DB2 systems if using XDB Link. Blank indicates the current XDB Server.
SYSMODENAME | CHAR | 8 | Mode used to establish intersystem conversations.
USERSECURITY required | CHAR | 1 | Acceptance option for a remote attach:
 |  |  | C | "Conversation." A request is checked by the internal security system and must include a password.
 |  |  | A | "Already Verified." A request does not need a password, although a password is checked if it is sent. A is the default.
 |  |  | Any character that is not C is treated as an A.
ENCRYPTPSWDS | CHAR | 1 | Included for DB2 compatibility only. Tells whether passwords for DB2 LUs are encrypted:
 |  |  | Y | Passwords are encrypted.
 |  |  | N | Passwords are not encrypted.
 |  |  | The XDB Server always uses encrypted passwords, even if set to N.
MODESELECT | CHAR | 1 | Not used.
USERNAMES required | CHAR | 1 | Whether an ID accompanying a remote attach request is subject to translation.
 |  |  | I | Inbound ID, from the corresponding LUNAME, is subject to translation.
 |  |  | O | Outbound ID, sent to the corresponding LUNAME, is subject to translation.
 |  |  | B | Both inbound and outbound IDs are subject to translation.
 |  |  | blank | No translation is done for either inbound or outbound IDs.
Parent topic: System Tables


Sample System Tables

The following table shows the values needed in the system table SYSIBM.SYSLUNAMES on the remote XDB Server sales to implement the trusting examples (without outbound mapping) used in this topic.

LUNAME | SYSMODE-NAME | USER-SECURITY | ENCRYPT-PSWDS | MODE-SELECT | USER-NAMES
develop |  | A |  |  | I

This table shows that sales should regard all requests from the XDB Server develop as coming from users who are already verified.

The values needed in the system table SYSIBM.SYSUSERNAMES to implement trusting are the same as those required for inbound mapping. The following table shows the values needed to implement the trusting example used in this topic. This table also shows other valid records for trusting, explained after the table.

TYPE | AUTHID | LUNAME | NEWAUTHID | PASSWORD
I | bruce | develop | developr |
I | david | develop |  |
I |  | develop |  |
I | arlene |  |  |

Row 1 maps bruce to developr for all requests received from the XDB Server develop. This is the configuration used in the examples on trusting.

Row 2 does not map david when requests are received from develop.

Row 3 does not map any AuthIDs from develop.

Row 4 does not map arlene when requests are received from any XDB Server.

In this example, rows 1, 2 and 4 take precedence over row 3 because they mention specific AuthIDs.

Parent topic: Trusting


Setting Up Trusting

In order to use trusting you must update system tables on the remote server which will trust the requests. On the remote XDB Server, you must also set up the appropriate AuthIDs, mappings and privileges.

The instructions in each topic discuss trusting between two XDB Servers. If you wish to have a fully distributed environment, complete the primary XDB Server instructions on each XDB Server from which request will be trusted. Complete the remote XDB Server instructions on each XDB Server which will trust requests.

All of the following instructions assume that security is turned on (through the XDB Server Configuration Utility) for both the primary and remote XDB Servers.

The instructions in this topic are written as if you have already set up server-to-server connectivity and inbound mapping before setting up trusting, and are not using outbound mapping.

  • Primary Server Configuration
  • Remote Server Configuration
Parent topic: Trusting


Primary Server Configuration

On the primary XDB Server, set up server-to-server connectivity so that requests can reach the remote server. No additional configuration on the primary XDB server is needed to use trusting. To use trusting in conjunction with outbound mapping, see the section Outbound, Inbound and Trusting Used Together for more information.

Parent topic: Setting Up Trusting


Remote Server Configuration

You must perform these steps on the XDB Server that will trust requests and perform inbound mapping. In the examples, the XDB Server sales is trusting and performing inbound mapping.

To update the system tables:

Note: When updating system tables, do not delete any seemingly empty records; these contain space characters in some columns and refer to locations controlled by your local XDB Server.
  1. On any client logged in to the remote XDB Server, start the SQL Wizard.
  2. Once inside the XDB Server Configuration Utility, press F5 to access the Multiuser Configuration screen.
  3. From an SQL Window, set the current location to the SYSTEM location:
    SET LOCATION TO system;
  4. Issue the following SQL command to update information in the SYSIBM.SYSLUNAMES table about server-to-server connectivity and inbound mapping and trusting.
    UPDATE sysibm.syslunames SET usersecurity = "A"
    WHERE luname = "servername" AND usernames = "I";

    where:

    A | indicates that requests from the XDB Server should be trusted.
    servername | is the name of another XDB Server from which AuthIDs will be mapped.
    I | indicates inbound mapping will be performed.

    In the examples on inbound mapping used in this topic, the SQL command:

    UPDATE sysibm.syslunames SET usersecurity = "A"
    WHERE luname = "develop" AND usernames = "I";

    would have been issued on the XDB Server sales.

  5. Issue the following SQL command to insert information into the SYSIBM.SYSUSERNAMES table about AuthIDs that will be subject to inbound mapping.
    INSERT INTO sysibm.sysusernames
    VALUES("I","authid","servername",
           "newauthid","");

    where:

    I | indicates inbound mapping will be performed.
    authid | is the name of the AuthID to be translated from.
    servername | is the name of the server from which the AuthID to be translated will originate.
    newauthid | is the new AuthID that will be given.

    In the examples on inbound mapping used in this topic, the SQL command:

    INSERT INTO sysibm.sysusernames
    VALUES("I","bruce","develop","developr","");

    would have been issued on the XDB Server sales.

  6. Repeat Step 4 for each server that will be subject to inbound mapping. Repeat Step 5 for each AuthID that will be subject to inbound mapping.
  7. Issue the following SQL command to refresh the system:
    REFRESH LOCATIONS;
  8. Exit the SQL Wizard.

Use the SQL GRANT command to grant the appropriate privileges to the new AuthIDs. In the examples on inbound mapping and trusting used in this topic, the AuthID developr would have to be granted SELECT privileges on the table may in the location orders.

Parent topic: Setting Up Trusting


Global Security

The XDB Server allows you to set up one location that will validate access security for all XDB Servers on a LAN. This eliminates duplicate AuthIDs and passwords in a distributed environment.

Using global security, each XDB Server in a distributed environment is configured to point to one location as the security server. This is done through the XDB Server Configuration Utility and by inserting values into the system catalog tables on each XDB Server.

Whenever a user attempts to login to any XDB Server using global security, the AuthID and password are passed to the global security location for verification. Global security extends server-to-server connectivity by allowing all XDB servers to use just one location for verifying passwords.

Note that a user must have a valid AuthID on each XDB Server in SYSXDB.SYSACFUSERS, with valid access to data, on every XDB Server that will be accessed. Global security only verifies AuthIDs and passwords.

The information in the global security system catalog tables can also be used to map AuthIDs and passwords. Be particularly careful when setting up this sort of scheme.

Multiple global security locations can be set up in a distributed environment. This allows you to have multiple security schemes for different XDB Servers. It also allows you to set up a redundant global security system to be used in case of hardware failure on your original global security server.

  • Example
  • System Tables
  • Setting Up Global Security
Parent topic: Multiserver Security


Example

The user Bob tries to login to the XDB Server develop, as shown in the following figure. Develop checks the server configuration settings (in SRVCONFG.XDB) and determines that it is using global security, and that the global security location is on the XDB Server XDBSERVE. The AuthID and password are sent to xdbserve for verification.

On XDBSERVE, the AuthID and password are verified against SYSXDB.SYSACFUSERS in the global security location. Verification is then returned from the XDB Server XDBSERVE and Bob is logged in to develop. Secondary IDs and privileges are then assigned.

Parent topic: Global Security


System Tables

You must insert data into two XDB system tables, SYSIBM.SYSLUNAMES and SYSIBM.SYSLOCATIONS on the primary XDB Server in order to use global security. The only system tables that must be modified on the global security server are modified by using the SQL Wizard. Updates can be made to the tables on the primary XDB Server using the SQL Wizard.

Note: When updating system tables, do not change or delete any records that appear blank. These records contain a space character in certain columns and are required to define the locations controlled by your local machine.

You must insert values into columns labeled "required" in order to use global security.

  • SYSIBM.SYSLUNAMES
  • SYSIBM.SYSLOCATIONS
  • Sample System Tables
Parent topic: Global Security


SYSIBM.SYSLOCATIONS

The columns in this table contain information about all locations that are accessible for RUW and DUW processing, including local locations in SYSXDB.SYSLOCALS plus remote locations accessible using server-to-server connectivity or XDB Link.

Name | Type | Len | Description
LOCATION required | CHAR | 16 | Name of the location.
LOCTYPE required | CHAR | 1 | Indicates the location type:
 |  |  | X | XDB
 |  |  | R | RPC
 |  |  | C | CICS
 |  |  | D | DRDA
LINKNAME required | CHAR | 8 | Name of the XDB Server which controls the location, if using server-to-server connectivity. LUNAME for the accessible system if using XDB Link.
LINKATTR required | VARCHAR | 64 | Type of protocol used to connect to the XDB Server when using server-to-server connectivity:
 |  |  | S | SPX
 |  |  | B | NetBIOS
 |  |  | N | Named Pipes
 |  |  | T | TCP/IP (Set the hostname and IP address in the XDBNET.INI file.)
 |  |  | or The name of the mainframe program with which XDB Link will communicate if using XDB Link.
Parent topic: System Tables


Sample System Tables

The following table shows the values needed in the system table SYSIBM.SYSLUNAMES on the primary XDB Server develop to implement the examples discussed in this topic for global security.

LUNAME | SYSMODE-NAME | USER-SECURITY | ENCRYPT-PSWDS | MODE-SELECT | USER-NAMES
xdbserve |  |  |  |  |

This table indicates that the XDB Server xdbserve can be accessed.

The following table shows the values needed in SYSIBM.SYSLOCATIONS on the XDB Server develop to implement the examples discussed above for global security.

LOCATION | LOCTYPE | LINKNAME | LINKATTR
sysglobal | X | xdbserve | B

This table indicates that the sysglobal location is an XDB location controlled by a remote XDB Server xdbserve and can be reached via the NetBIOS protocol.

Parent topic: System Tables


Setting Up Global Security

In order to set up global security, you must configure both the primary XDB Server and the global security XDB Server. The primary XDB Server is the XDB Server which clients will log into. The global security server will verify AuthIDs and passwords. The instructions in this topic discuss one primary server and one global security server.

If you wish to have a fully distributed environment, complete the Primary Server Configuration instructions (page 8-37) for each XDB Server that you wish to be a primary XDB Server. Complete the Global Security Configuration instructions (page 8-41) for each XDB Server you wish to be a global security XDB Server.

Note: We strongly recommend that you plan your global security scheme before implementing it, especially if you will be allowing outbound mapping, inbound mapping and trusting between servers using global security. Be sure to consider items that are assigned on a per server basis (groups and governor privileges) and those that are assigned on a per location basis (database and table privileges).

Because global security is an extension of server-to-server security, you must register the global security server and location as you would any other server or location. If you have already configured other locations on your global security server, you might need to update values in the system tables rather than insert new ones. See the chapter Server-to-Server Connectivity for detailed instructions.

  • Primary Server Configuration
  • Global Security Server Configuration
Parent topic: Global Security


Primary Server Configuration

To configure the primary server for global security, you must update the system tables before you configure the server. You must follow these procedures in the order in which they appear because you cannot configure the primary server to use a global security location that it cannot access.

To update the system tables:

Note: When updating system tables, do not delete any seemingly empty records; these contain space characters in some columns and refer to locations controlled by your local XDB Server.
  1. From the primary XDB Server, start the XDB Server.
  2. On any client logged in to the primary XDB Server, start SQL Wizard.
  3. Log in with an AuthID that has super user privileges, such as the INSTALL AuthID, provided with the XDB Server.
  4. From an SQL Window, set the current location to the SYSTEM location:
    SET LOCATION TO system;
  5. Issue the following SQL command to insert information about a remote server into the SYSIBM.SYSLUNAMES table:
    INSERT INTO sysibm.syslunames
    VALUES ("remote-server","","","","","");

    where

    remote-server is the name of a remote XDB Server to be accessed.
    Note:

    If you have already set up server-to-server connectivity for the global security server, use the UPDATE command to update existing records in the SYSIBM.SYSLUNAMES table.

    In the examples used in this topic, the SQL command:

    INSERT INTO SYSIBM.SYSLUNAMES
    VALUES ("xdbserve","","","","","");

    would have been issued on the XDB Server develop.

  6. Issue the following SQL command to insert information about the global security location into the SYSIBM.SYSLOCATIONS table:
    INSERT INTO SYSIBM.SYSLOCATIONS
    VALUES (remote-location,"X", remote-server,link-type);

    where:

    remote-location | is the name of the remote location to be accessed (unique among all locations on all servers that are used in distributed processing).
    X | indicates it is an XDB Server.
    remote-server | is the name of the remote server that controls the remote location.
    link-type | is the communication protocol used to connect to the remote server.

    In the examples used in this topic, the SQL command:

    INSERT INTO SYSIBM.SYSLOCATIONS
    VALUES ("sysglobal","X","xdbserve","B");

    would have been issued on the XDB Server develop.

  7. Issue the following SQL command to refresh the system:
    REFRESH LOCATIONS;
  8. Exit from SQL Wizard.
  9. Shut down the primary XDB Server, as you need to make some changes to the server's configuration.

To configure the server:

  1. From the primary XDB Server, run the XDB Server Configuration Utility.
  2. Press F5 to access Multiuser Configuration options.
  3. Press F9 to turn on Global Security.
  4. Enter the name of the global security location. All logins to the XDB Server will be verified against the SYSXDB.SYSACFUSERS table in the location you specify. In the examples in this topic, the global security location is sysglobal.
  5. Press Enter to save the new location. Then, exit the utility.

Windows 2000

  1. From the primary XDB Server, run the XDB Server Configuration Utility.
  2. Click the Multiuser tab.
  3. Mark the Global Security checkbox.
  4. Enter the name of the global security location. All logins to the XDB Server will be verified against the SYSXDB.SYSACFUSERS table in the location you specify. In the examples in this topic, the global security location is sysglobal.
  5. Click OK.

Even though AuthIDs (usernames) and passwords are verified by a global security server, clients must have access to the tables they wish to use on the primary server. This can be done by granting the appropriate privileges to each client on the primary server. AuthIDs are created using SQL Wizard. Privileges are granted using the SQL GRANT command from SQL Wizard. See the chapter Security and Authority for more information on creating users and setting privileges.

Parent topic: Setting Up Global Security


Global Security Server Configuration

The global security server must be configured to contain information about all of the AuthIDs and passwords that it will verify. In the examples, the global security XDB Server is xdbserve.

Before using global security, you must first create a global security location on the global security server. This process involves renaming your SYSTEM location with the name of your global security location. In the examples, the global security location is sysglobal.

To create a global security location:

  1. From the primary XDB Server, start the XDB Server.
  2. On any client logged in to the primary XDB Server, start the SQL Wizard.
  3. Log in with an AuthID that has super user privileges, such as the INSTALL AuthID, provided with the XDB Server.
  4. From an SQL Window, set the current location to the SYSTEM location:
    SET LOCATION TO system;
  5. Issue the following SQL command to update the information about the global security location in the SYSIBM.SYSLOCATIONS table:
    UPDATE sysibm.syslocations
    SET location = "global-security-location"
      WHERE location = "system";

    In the examples used in this topic, the SQL command:

    UPDATE sysibm.syslocations
    SET location = "sysglobal"
      WHERE location = "system";

    would have been issued on the XDB Server xdbserve.

  6. Issue the following SQL command to update the information about the global security location in the SYSXDB.SYSLOCALS table:
    UPDATE sysxdb.syslocals
    SET location = "global-security-location"
      WHERE location = "system";

    In the examples used in this topic, the SQL command:

    UPDATE sysxdb.syslocals
    SET location = "sysglobal"
      WHERE location = "system";

    would have been issued on the XDB Server xdbserve.

  7. Exit the SQL Wizard.

In order to verify AuthIDs (usernames) and passwords, there must be values in the appropriate system tables, primarily SYSXDB.SYSACFUSERS, on the global security server.

AuthIDs are created using the SQL Wizard Admin menu. Use this utility to enter AuthIDs and passwords for all users who will be accessing any XDB Server using this global security server.

  1. To enter AuthIDs and passwords from the global security XDB Server, start the XDB Server.
  2. On any client logged in to the global security XDB Server, start the SQL Wizard.
  3. Create AuthIDs and passwords for all users who will log into the primary XDB Server, and have their AuthIDs and passwords verified by the global security server.

To implement this topic's examples, create an AuthID Bob on XDBSERVE.

Parent topic: Setting Up Global Security
Related information
Security and Authority


Outbound, Inbound and Trusting Used Together

When used independently of each other, outbound mapping, inbound mapping, and trusting are easy procedures to set up. However, if you wish to use these features together, you should plan out your mapping and trusting scheme before implementing it.

Some concepts, such as AuthID, password, groups, and priorities are controlled on a per server basis. Others, such as database and table privileges, are controlled on a per location basis.

If you will be using inbound mapping and outbound mapping between two servers you must be sure that your system tables cover all possible mappings. For example, requests from Bob on the XDB Server develop to the XDB Server sales will be subject to outbound mapping on develop. Requests from Debbie on develop to sales will be subject to inbound mapping on sales.

To allow this scenario, you must have one additional row in the SYSIBM.SYSUSERNAMES tables on each XDB Server (sales and develop) that indicates requests from these users should not be mapped.

Parent topic: Multiserver Security


Backup and Recovery

  • Log Files
  • Server Configuration
  • Backing Up Locations
  • System Recovery
Parent topic: SQL Option Server Administration Guide


Log Files

Instead of building separate forward and backward logs, the unified logging system automatically builds and names a series of log files for each location when that location is created. These location log files provide protection against both transient system failures (e.g., power outages, operating system crashes), and media failures, such as a hard disk crash.

  • Log File Naming
  • Location of Log Files
  • Log Files During Recovery
  • Turning Logging On and Off
Parent topic: Backup and Recovery


Log File Naming

Each time a location is created the XDB Server logging system creates a file named anchor.log. This file holds information on how to recover the location after a transient system failure or media failure. As work commences in the location, the logging system automatically creates a second log file named a0000000.log, which records all current transaction information necessary for transient system failure recovery.

A series of log files (beginning with a0000000.log) are automatically created by the logging system to record all data table changes since the location was created (or since logging was reset for that location). Log files are named automatically by the system according to the following convention:

xyyyyyyy.log

where the x prefix is a letter of the alphabet, and each y represents a digit of a hexadecimal number (seven digits long). The first in the series of log files built is always named a0000000.log, with the hexadecimal portion of each subsequent log file name indexed upward by one (for example, a0000001.log, a0000002.log, etc.).

Parent topic: Log Files


Location of Log Files

All logging files are stored in the same log path directory, which by default is the parent location directory. This path can be (and should be) set to a separate physical storage device, providing greater protection against a system hard disk crash. The path for your location log files can be changed by issuing a SET LOG command from the SQL Wizard. Make sure that each location on the server has a unique log path.

Parent topic: Log Files


Log Files During Recovery

The server tries to find the anchor.log file each time a location is opened. If anchor.log is not there, the server creates a new one and initializes the new stream of log file names to begin with a0000000.log. If anchor.log is present and the location was shut down normally after its last use, the server will continue writing entries to the end of the last log file created.

If anchor.log is present and the location experienced transient system failure (due to a power outage, operating system failure, etc.) after its last use, the server automatically recovers the location to a logically consistent point. It ensures that all data that was committed before the crash is applied to the location tables, and all other data is rolled back. This recovery occurs when the first user accesses the location. The logging system then continues functioning normally, appending new work to the end of the last log file -- just as if the system had been shut down normally.

Parent topic: Log Files


Turning Logging On and Off

If you have SYSADM authority or higher and exclusive use of the server, you can temporarily turn the logging system off. When issued from the SQL Wizard, the SET LOG OFF command temporarily suspends logging for the location during the remainder of the current session. Turning logging off for a particular location is a temporary expedient for an exclusive user that does not want to incur the overhead of logging during administrative tasks.

Logging is turned off for the current session, only. Logging can be activated again in the current session by issuing a SET LOG ON command. Exiting the session toggles the status of location logging back to on (the default). The next session that accesses the location therefore has logging turned on. Setting the logging system on or off from the SQL Wizard does not affect the logging configuration settings in your xdbsrvco.ini file.

Parent topic: Log Files


Server Configuration

Control the behavior of the XDB Server logging system by setting the four parameters described in this topic.

  • Delete Old Logs (Recovery)
  • Log File Size
  • Log Buffer Size
  • Checkpoint Frequency
Parent topic: Backup and Recovery


Delete Old Logs (Recovery)

If you want to issue the ROLLFORWARD command to initiate location recovery, you must set the bDeleteOldLogs parameter to 0 (off).

To set the parameter (Windows):

  1. Click the Logging tab within the XDB Server Configuration Utility.
  2. Turn Recovery on.

See the section Media Failure Recovery and the SQL Reference for information about the ROLLFORWARD command.

CAUTION:
Run-time or mission-critical XDB Servers should always run with recovery turned on (bDeleteOldLogs=0).

Set bDeleteOldLogs to 1 (on) to allow developers to automatically delete location log files not needed for transient system failure recovery from the hard disk. Even with bDeleteOldLogs set to 1 (on), the server will recover to a logically consistent state after a transient system failure, such as terminating abnormally due to a power loss, or operating system failure. The logging system always preserves the last transaction.

To set the parameter (Windows):

  1. Click the Logging tab within the XDB Server Configuration Utility.
  2. Turn Recovery off.
Parent topic: Server Configuration


Log File Size

Set the log file size to specify a maximum size for individual log files (ranging from 1 MB to 10 MB). Log file size values are in increments of 1KB, with a default value of 1024 (1 MB). When the server writes the specified number of bytes out to the log file, it will close that file and create the next one. This feature allows users to backup individual log files while the system is up. You can configure log files to fit on a floppy diskette.

To set the parameter on Windows:

  1. Click the Logging tab within the XDB Server Configuration Utility.
  2. Enter the desired log file size in the Log File Size text box, or drag the slider.
Parent topic: Server Configuration


Log Buffer Size

The log buffer size parameter governs the size of the internal write buffer used by the logging system. Internal write buffer values are in increments of 1 KB, with a default value of 128.

Note: The quotient of the log file size divided by the buffer size must be a whole number. If this ratio is not an integer value, the logging system adjusts the buffer size and possibly the log file size until an integer ratio is achieved.
To set the parameter (Windows):
  1. Click the Logging tab within the XDB Server Configuration Utility.
  2. Enter the desired log buffer size in the Log Buffer Size text box, or drag the slider.
Parent topic: Server Configuration


Checkpoint Frequency

The checkpoint frequency parameter determines the amount of time between automatic logging system checkpoints. These automatic checkpoints cause the contents of log buffer cache to be written to table files on disk, removing the need for applications to issue checkpoints manually. See the SQL Reference for a description of the CHECKPOINT command.

The checkpoint frequency parameter is one of the factors affecting the length of time needed to return location data objects to a logically consistent state after a transient system failure, such as a power outage, or operating system failure. If you increase the checkpoint interval, the system requires more time for log recovery after a transient system failure. Conversely, a shorter checkpoint interval reduces average recovery time, but increases system overhead.

To set the parameter:
  1. Click the Logging tab within the XDB Server Configuration Utility.
  2. Enter the desired checkpoint frequency in seconds in the Checkpoint Frequency text box, or drag the slider.
Parent topic: Server Configuration


Backing Up Locations

We strongly recommend that you implement a regularly scheduled and frequent procedure for backing up your locations and data to avoid losses due to media, machine or operator failure. Backup rules for your installation will vary with each application. The frequency with which you run backups depends on the importance of the data, how often it changes, the maximum time needed to recover, and how large the data tables and location are. For each application, you must weigh the time and space costs of backups against the risk of data loss.

The BACKUP LOCATION and Restore batch files commands operate on a specific location and include all paths and files for all data objects in the location. In order to restore any combination of data objects from a particular location you must restore the entire location. The ROLLFORWARD command also operates on an entire location, applying a specified series of log files to a restored backup copy of the location data. See the following topics and the SQL Reference for detailed descriptions of the updated BACKUP LOCATION command and ROLLFORWARD command.

If you use an operating system backup command or another backup utility, be sure to back up all the files in all the paths that are defined for the location, including storage group (stogroup) paths and paths defined in various environment variables, if any. Be sure to archive and then delete the current series of log files after executing each location backup. Deleting the current log files resets location logging, causing a new series of log files to be built the next time the location is accessed.

Note:

If you want to use your operating system's backup, you must first shut down the server or take its locations off line, using the SQL OFFLINE command. See the SQL Reference for detailed descriptions of the ONLINE and OFFLINE commands.

  • BACKUP LOCATION Command
  • Resetting Location Logging
  • Restore
  • ROLLFORWARD Command
  • COMPACT Command
  • Backup Procedure
  • Other Backup Options
Parent topic: Backup and Recovery


BACKUP LOCATION Command

The BACKUP LOCATION command creates copies of all files that reside in the paths defined for the specified location. If stogroups are used in the location, appropriate files are also copied from all the drives and paths that are defined by the stogroups. If you have special paths defined by environment variables (such as XDB_index-name_location-name or XDBIDX_location-name) in the [Server] topic of your server machine's xdb.ini file, files in most of these paths are also backed up.

You can use the BACKUP LOCATION command only if the location being backed up is not currently in use by you or another user. The BACKUP LOCATION command copies the files to the target device and path you specify. The target directory must not already exist. See the BACKUP LOCATION command in the SQL Reference for more information. This can be a file server or a different hard disk drive. Tape drives and diskettes are not recommended.

The syntax of the BACKUP LOCATION command is:

BACKUP LOCATION location-name TO path-name [ AND INDEX | NOT INDEX ]

The AND INDEX | NOT INDEX parameter is optional. If not specified, AND INDEX is assumed and the system copies all appropriate index files along with the other files. If NOT INDEX is specified, the *.idx and *.ptr files are not copied. If you need to restore a location from a backup that did not include the index files, you will need to rebuild the indexes using the COMPACT LOCATION AND INDEX command.

Note:
  • To avoid confusion, always use a different path for each backup of each location. This will provide an xdbrest.cmd or xdbrest.bat file for each backup of each location.
  • BACKUP LOCATION does not copy files onto multiple diskettes.
Note:
  • If the contents of a location are too large to fit on one diskette, and you do not have an alternate high capacity device, use your operating system's backup command or an equivalent utility instead.
  • Be sure to back up all files in all relevant subdirectories.
  • Reset your log files after backing up a location. See the section Resetting Location Logging for more information.
Parent topic: Backing Up Locations


Resetting Location Logging

Whenever a new location is created, the logging system automatically creates a series of log files just for that location. For an existing location, we recommend that these location log files be manually reset after each location backup process. Manually resetting location logging immediately after backing up speeds recovery in the event of a serious media failure, since only log entries originating after your location backup need be replayed against your location tables.

The XDB Server logging system automatically creates a series of log files when a new location is created. Logging should be manually reset as a part of the location backup process.

To manually reset location logging:

  1. Shut down server.
  2. Copy log files from the location logging directory to a separate archive directory.
  3. Depending on whether you are using the BACKUP LOCATION command or an operating system backup command, do one of the following:
    • Bring the server back up and run the BACKUP LOCATION command from the SQL Wizard. (Be sure you execute the BACKUP LOCATION command from a location other than the one you are backing up.)
    • Run your operating system (or other) backup utility as appropriate (be sure to archive all directories associated with the XDB location).
  4. Shut down the server (if using BACKUP LOCATION).
  5. Delete all log files (*.log) from your location logging directory. The next time the location is accessed, a fresh series of log files will automatically be created by the logging system.

Location logging should be manually reset after any type of location backup (that is BACKUP LOCATION command or operating system backup).

Parent topic: Backing Up Locations


Restore

BACKUP LOCATION also creates a batch file (xdbrest.bat) that can be run from the operating system command line to restore the location's data objects. xdbrest.bat is created in the same path you designate for the backup files.

Parent topic: Backing Up Locations


ROLLFORWARD Command

The ROLLFORWARD command does not recover the following kinds of changes:

  • Data Control Language (DCL) commands, such as GRANT and REVOKE.
  • Utility commands such as SET.
  • Compact command.
  • TRUNCATE TABLE command.

Therefore, a backup should be performed after any of the above operations.

Parent topic: Backing Up Locations


COMPACT Command

You must always backup up your location and reset location logging (that is delete old location log files) after performing a COMPACT.

Note:

Never perform a COMPACT on a restored location before replaying log files. Compacting a location modifies the location table data and makes the old log files incompatible with the newly compacted location.

Parent topic: Backing Up Locations


Backup Procedure

The BACKUP LOCATION command will not archive off log files. Log files must be archived manually, after which location logging must be manually reset.

To backup a location using the BACKUP LOCATION command and reset location logging:

  1. Ensure that nobody is currently accessing the location you are backing up, and ensure that no incomplete transactions are in progress. You must be running in Isolation Level EU (exclusive use).
  2. Log into a location other than the one you are backing up (for example, SYSTEM location).
  3. Enter the BACKUP LOCATION command from the SQL Wizard.
  4. If you use removable storage media for your backups, carefully record vital information on the backup media's labels, including:
    • Location Name
    • Database Name
    • Stogroup and log file path names
    • Names of special paths that are defined in the server machine's xdb.ini file such as paths for indexes
    • Logging system information
    • Backup time and date
  5. Bring the server down.
  6. Archive the current series of log files. This series of files should be clearly marked and archived in a separate directory. They may be needed for playing against an older backup, in the event the latest location backup is corrupted or unavailable. Serial numbers can be used to ensure that the correct series of log files are applied to the correct backup copy of the location.
  7. Once Step 6 is complete, delete the current series log files from the location logging directory.
  8. Bring the server back up. Next time the location is accessed, a new set of log files is automatically created in the location logging directory.
Parent topic: Backing Up Locations


Other Backup Options

Most commercially available archival utilities can be used to back up locations. When using a backup utility, it is important to keep in mind that you must backup the contents of all directories for the entire location, including storage group paths (if any) and all subdirectories. This last point is important, as the server could have duplicate file names in different directories, which need to be kept separate on the backup device.

Note:
  • Do not attempt to shortcut the process by backing up only the *.tab files. a *.tab file is useless without the index files (*.idx and *.ptr) and other files associated with the tables.
  • If you want to copy tables or views between locations, use Migrate. See the Migrate User's Guide for more information. Do not use an operating system copy command to copy individual tables from one directory to another.
Parent topic: Backing Up Locations


System Recovery

If your system terminates abnormally due to transient system failure or media failure (disk crash), you can restore all previously committed work by following either the Transient System Failure or Media Failure scenario instructions.

  • Transient System Failure
  • Transient System Failure Recovery
  • Media Failure
Parent topic: Backup and Recovery


Transient System Failure

Transient system failure can occur from power outages, operating system crashes, or termination of the server with users still logged on.

Parent topic: System Recovery


Transient System Failure Recovery

In cases of transient system failure, system recovery occurs automatically either the next time any user attempts to login to a location in which a transaction was abnormally terminated or the next time a SET LOCATION command is issued against an affected location. For any transaction that was abnormally terminated before it completed, the before image stored in the location log files is used to automatically rollback all uncommitted transactions and restore the data tables involved to a logically consistent state.

This transient system failure recovery feature (the same functionality provided by backward logging in previous versions of the XDB Server) is permanently defaulted to on, with no user intervention required.

The average length of time necessary to bring all location data objects to a logically consistent state is affected by the value of the Checkpoint Frequency configuration parameter. This parameter allows the user to adjust the time between automatic logging system checkpoints. See the section Server Configuration for information about setting the Checkpoint Frequency parameter.

When the logging system issues a checkpoint, the contents of the entire log buffer cache are flushed to disk, that is, written to table files.

Parent topic: System Recovery


Media Failure

Media failure is a serious hardware mishap such as a disk crash.

Media Failure Recovery

You can restore a backup copy of a location's files and replay the contents of a discrete series of log files against the restored location using the ROLLFORWARD command.

A discrete series of log files consists of all changes made to the data objects within an location since the last time the logging system for that location was reset (usually after the last location backup). You must configure the server to ensure that your system is keeping log files. See the section Server Configuration - Delete Old Logs for more information.

If you have made periodic backups of your location (resetting the logging system after each backup), and you have configured your server to keep old logs, you can usually recover from a media failure.

To recover from a media failure:

  1. Shut down the server.
  2. For every location affected by a media failure, use your operating system copy command to archive the current series of log files to a drive and path that is different from any of the location directories you are recovering. Under ideal circumstances, the location log files should be on a different physical drive, separate from the corrupted location files.
  3. Delete current series of log files from the location logging directory.
  4. Locate the latest backup copy of the appropriate location, associated stogroup directories and other related directories.
  5. Restore the backup to the respective drives and paths, using one of the following sets of instructions:

    • If you used the BACKUP LOCATION command:

      Make sure that the server is shut down, and that all destination directories and subdirectories exist (the restore program will not create directories). Then, change to the drive and directory where the backup batch file resides and enter the following at the operating system command line:

      xdbrest

      Any files in the destination directories will be overwritten. Log files will not be restored.

    • If you used your operating system or other utility:

      You must restore files using the compatible operating system restore command prior to recovery.

      If you need to restore location files on a different drive or in different paths than they previously resided, be sure to edit the appropriate system tables to make the XDB Server aware of the new location names and paths. Edit SYSXDB.SYSLOCALS and SYSIBM.SYSLOCATIONS tables to specify location names and path names. Edit SYSIBM.SYSSTOGROUP and SYSIBM.SYSVOLUMES to specify stogroup information. Also check the server machine's configuration file for other special directories, such as index paths.

  6. Bring the server back up.
  7. Before replaying the log files with the ROLLFORWARD command, be sure you are running in Exclusive Use (EU) isolation level. Use the SET ISOLATION command or the Options Utility to change your isolation level. Running in EU gives you total control over the server. Likewise, no incomplete transactions can still be in progress.
  8. Even if only one or more tables within a location need to be restored, the ROLLFORWARD command reconstructs the entire location in question. The ROLLFORWARD command operates on the location level only, restoring one complete location with each execution.
  9. In preparation for replaying all outstanding series of log files against the restored location, create a temporary log file directory and copy the current series of log files (or the most current series of log files if more than one) into that directory. Although not strictly required, resetting location logging after each backup ensures that your current series of log files have recorded only those transactions occurring since the last backup.
  10. From the SQL Wizard, execute a ROLLFORWARD command naming the restored location and the temporary log file directory containing the log files.

    Issue the following SQL command:

    ROLLFORWARD location-name
    USING log-path

    where location-name is the name of the location containing the restored backup files and log-path is the drive and path name of the directory containing the anchor file and series of log files to be replayed against the restored location. This directory should contain the anchor.log file plus one or more log files beginning with the file named ?0000000.log (where ? = [a-z]).

    For example, the following ROLLFORWARD command would apply the log files contained in the directory c:\xdbnt\logfiles to the system location

    ROLLFORWARD system
    USING c:\xdbnt\logfiles

    During a ROLLFORWARD, all transactions contained in the location log files are replayed against the restored location.

  11. More than one series of log files may need to be replayed in cases where the location was not backed up (or the backup was corrupted or lost) each time location logging was reset. In these cases, multiple series of log files must be played against the last available backup beginning with the oldest series of log files and finishing with the most recent series.

    In cases where multiple series of log files are being replayed against an older location backup:

    1. Follow the directions in Step 9 to replay the oldest series of log files first (by indicating the directory containing this first series of log files in the ROLLFORWARD command).
    2. Repeat Step A with the next oldest series of log files, being sure to indicate a new directory containing these log files (the same directory can be used as long as the previously replayed series of log files are erased and replaced by the next series).
    3. When the most recent series of log files is ready to be replayed, follow Step 9 one last time to complete the location recovery.

    The sum total of all ROLLFORWARD operations applied against a restored location causes the logging system to run through all the transaction data contained in each series of log files, returning the location to the state it was in immediately before the system failure.

    When the recovery process is complete, press Esc to exit the SQL Wizard.

  12. Shut down the server.
  13. Reset the logging system. See the section Resetting Location Logging.
  14. Start the server. The server is now ready for normal operations to resume.

After all recent log files have been applied to the restored backup copy of the location, your data tables should be returned to a state existing prior to the media failure.

Parent topic: System Recovery


Storage Requirements

Disk storage space requirements depend on which version of the XDB Server you are using and the optional related products you have installed.Each location you create requires a minimal amount of overhead to account for system tables and the default database structure. The overhead for a location, not counting user tables, indexes, and other user objects is approximately 320K.

  • Table Storage Requirements
  • Index Space Requirements
  • Temporary Storage Requirements
  • Log Requirements
  • Other Storage Requirements
Parent topic: SQL Option Server Administration Guide


Table Storage Requirements

To estimate the bytes of disk space a table will occupy you must consider overhead as well as space occupied by data. You must also have a realistic idea of the maximum number of records to be stored in the table.

Formulas for estimating space requirements for tables are described in this topic. The formulas use the following variables:

E | Estimated table storage required (bytes)
I | Estimated index storage required (bytes)
P | Physical record length (maximum 32,767 bytes)
N | Number of records in the table (estimate)
T | Table overhead (88 bytes per table)
F | Field overhead (86 bytes per field)
R | Record overhead (2 bytes per record)
Di | Data storage requirement for field i per record (Depends on data type. See the following table.)
Oi | Overhead for field i per record (2 bytes) (While the number of bytes for data overhead is given as 2 for all data types, character fields of odd length actually require only 1 byte of overhead per record.)
f | Number of fields in table

The formula for calculating the physical record length, P, is:

The general formula for estimating bytes of storage required by a table is:

Substituting for P yields the formula:

Use the following table to find the data storage (D) and overhead (O) for the i-th field, depending on the data type.

Note:

The maximum physical record length is 32,767, which includes overhead. When determining the length of long records, use the formula for P, given earlier.

VARCHAR and LONG VARCHAR data types are provided for ANSI and DB2 compatibility only. Data for these types is currently stored as regular character data. All of the BLOB data types (image, binary, varbinary and long varbinary) are stored in separate files-- one file per blob column.

Data Type | D | O
smallint | 2 | 2
int | 4 | 2
float 4 | 4 | 2
float 8 | 8 | 2
money | 8 | 2
decimal | (precision/2)+1 | 2
date | 6 | 2
time | 6 | 2
char (odd length) | length | 1
char (even length) | length | 2
varchar (odd length) | length | 1
varchar (even length) | length | 2
long varchar | 4056 | 2
graphic (odd length) | length | 1
graphic (even length) | length | 2
vargraphic (odd length) | length | 1
vargraphic (even length) | length | 2
long vargraphic | 4056 | 2
blob (image, binary, varbinary or long varbinary) | stored in separate file; up to 2GB each | 4
Parent topic: Storage Requirements


Index Space Requirements

Estimating the amount of space occupied by an index is difficult. The XDB Server uses B-tree indexes. The values in an indexed field and a pointer to the record containing it are stored in the *.idx file for the index; pointers to each duplicate instance of the value are stored in the *.ptr file for the index. The *.ptr file will contain 0 bytes if the index was created using the UNIQUE option.

Before you start you must have an estimate of the number of records in the table and the number of distinct values in the index.

Formulas for estimating space requirements for indexes are described in this topic. The formulas use the following variables:

I | Estimated index storage required (bytes)
V | Number of distinct values in index (estimate)
N | Number of records in the table (estimate)
S | Storage requirement for index value (Depends on index type)
Dj | Data storage requirement for field j (Depends on data type. See the following table.)
Oj | Overhead for field j (Depends on data type. See the following table.)
f | Number of fields in index

The bytes of storage required for an index is calculated as follows:

Note that if the index is created using the UNIQUE option, the number of records is equal to the number of distinct values, and the equation for calculating index storage requirements is reduced to:

In either case, S, the storage requirement for indexed values, depends on the type of index.

Regular Index

To compute the storage requirement S for a single field index, use this formula:

Compound Index

To compute the storage requirement S for a compound index on f fields, use this formula:

Parent topic: Storage Requirements


Temporary Storage Requirements

You should have enough space in the temporary directory to store the largest result you anticipate retrieving from the database. As a rule of thumb, you should have at least two to three times the space required for your largest table in order to perform joins. However, the space required for your particular application might differ considerably.

Parent topic: Storage Requirements


Log Requirements

The amount of space required by location logs depends on several factors, including:

  1. Frequency of Location Backups.

    If you backup your locations (and the location log files) frequently, the location log will contain fewer entries, and will therefore require less space.

  2. Frequency and Number of Table Inserts, Updates, Deletes.

    The log file stores the after image and the before images of all records changed by a table transaction. If changes occur often, or changes involve many records, the log file will be large.

Parent topic: Storage Requirements


Other Storage Requirements

Storage requirements for static database components such as forms, report command files, and menus can be determined after each component is created. Use your operating system directory list command to view the size of files after they have been created.

While the size of various components might vary considerably, these files do not generally change size once the components are developed. You might use the size of a component that performs a similar function as an estimate for a new component you are developing.

Parent topic: Storage Requirements


Performance Tuning

  • Optimizing Query Processing
  • Improving Production Processing
  • Increasing Data Import Speed
  • Improving Performance During Object Creation
  • Administrative Performance Tools
Parent topic: SQL Option Server Administration Guide


Optimizing Query Processing

The Query Optimizer uses advanced performance optimizing techniques when processing queries, especially when appropriate indexes are available. Most of the query processing algorithms described in this section are automatic; they do not require user intervention. However, understanding how the various processing algorithms use indexes will help you to decide when indexes are needed as well as help you construct more efficient queries. A list of query guidelines is provided at the end of this section.

  • Indexes and Performance
  • Overriding the Optimizer
  • Retrieval Speed vs. Update Speed
  • List Prefetch
  • Aggregate Clause Processing
  • Predicates
  • Expressions
  • LIKE Predicate
  • Index Usage with AND and OR
  • Nested Queries
  • Correlated Queries
  • Join Optimization
  • Sorting
  • IN LIST with a Range Condition
  • Joins with Non-Join Predicates
  • Join Restrictive List Analysis
  • Query Performance Summary
Parent topic: Performance Tuning


Indexes and Performance

The XDB Server uses B-tree indexes to speed retrieval. Like a book index, a database index reduces the amount of data that must be searched to find an answer. The XDB Server performs automatic query optimization to select the best index to use for a query.

In general, the fewer records accessed, the faster the retrieval time. The XDB Server uses available indexes whenever they help to speed retrieval. But, while indexes generally speed up retrieval, they can slow down updates, inserts and deletes.

Usually, it is faster to execute a query using one or more indexes than to examine every record in the tables involved in the query. The XDB query optimization algorithms examine the indexes available and pick which indexes, if any, to use for a particular query. The user does not need to specify which indexes to use.

The query optimization algorithms analyze the selectivity of a column to determine how to process a query. Selectivity of a column is determined by calculating how unique the values in the column are. The more unique the values, the more likely the column will be a candidate for index use. Selectivity is determined by the formula, 1/x, where x is the number of distinct values in a column or index. The larger the number of distinct values, the more unique the column is and the lower the selectivity is. This increases the probability that the optimizer will use the index.

If a command does not contain a WHERE, ORDER BY, HAVING, or GROUP BY clause, the server generally will not perform an index search; instead, it processes the table sequentially. Some aggregate functions can cause an index to be used in certain cases. Usually, if a column in the WHERE clause is indexed, the index is a candidate for use. Other factors, such as the number of distinct values in an index, determine final index selection.

Parent topic: Optimizing Query Processing


Overriding the Optimizer

You can force the use of an index for a particular query, or force the system to not use an index.

To force the use of an index, enter an asterisk (*) in parentheses after the name of the indexed column when you construct the query. To force the system to ignore the index, use enter a hyphen (-) in parentheses after the name of the indexed column when you construct the query.

For example, assuming that an index exists on C_NO:

This query uses the C_NO index.

SELECT c_no, o_no, o_date
    FROM orders
    WHERE c_no(*)<20

This query does not use the index.

SELECT c_no, o_no, o_date
    FROM orders
    WHERE c_no(-)<20

The (*) and (-) options are valid only for column names that appear in a WHERE clause. You cannot use the (*) and (-) options in GROUP BY, HAVING or ORDER BY clauses.

Parent topic: Optimizing Query Processing


Retrieval Speed vs. Update Speed

There is a trade off between retrieval speed and update speed when indexes are used, since each time a value in an indexed column is changed, the system must also update the index. Overall database performance can actually deteriorate if indexes are built on columns that are seldom searched but are frequently updated. You might want to build a number of indexes on a read-only table, but limit a frequently updated table to a minimal set of indexes.

When importing data into a table, it is significantly faster to create indexes after the data has been inserted. Prior to importing, you should drop all indexes that are not required to enforce uniqueness. Use a batch SQL file or procedure to re-create indexes after importing.

Parent topic: Optimizing Query Processing


List Prefetch

List Prefetch is an Query Optimizer routine that extracts the Record IDs (RIDs) that match a specific search criteria from a particular index. These RIDs are sorted in ascending order, thereby enabling sequential table access. By accessing the table data pages in a sequential fashion, disk head seek time can be drastically reduced and data page prefetching performed. The server considers list prefetch when table data page access is required, when a multiple index access condition is detected, or if data needs to be retrieved in physical order.

Note: List prefetch can be affected by the size of the RID Pool buffer. See the section Improving Production Processing for more information.
Parent topic: Optimizing Query Processing


Aggregate Clause Processing

When all aggregate functions in a query are on the same indexed field, the system will determine the result from the index rather than by using the slower process of accessing the base table. For example, given the following query, the server does not need to look at the table file if an index exists on PAYRATE; the index alone is sufficient to give the result.

SELECT MAX(payrate), MIN(payrate), AVG(payrate)
    FROM employee

Likewise, any COUNT aggregate using a WHERE clause that can be resolved via an index will not access the base table. For example, if an index exists on columns A and B in TABLE1 and the following query is issued:

SELECT COUNT(*) FROM table1
    WHERE a=2 AND b=3;

the information will be available via the index. The base table (TABLE1) is not accessed.

Parent topic: Optimizing Query Processing


Predicates

In the case of a simple predicate involving an indexed column, the XDB Server will generally use the index to speed retrieval. For example, given an index on ZIP, that index will be used to process the following query:

SELECT * FROM employee
    WHERE zip = "20441"
Parent topic: Optimizing Query Processing


Expressions

If an indexed column appears in a query only as a part of an expression that alters the column, the index will not be used. For example, given the following query, an index on the PAYRATE column will not be used, even if it exists:

SELECT * FROM employee
    WHERE payrate * 1.10 > 13.00

Likewise, the index will not be used in the following query:

SELECT * FROM employee
    WHERE payrate > 13.00/1.10

Usually, it is best to perform the constant calculations prior to executing the query.

Parent topic: Optimizing Query Processing


LIKE Predicate

When constructing queries containing a LIKE predicate that involves an indexed column, try to avoid pattern matching strings that begin with percent (%) or underbar (_). If the string in a LIKE predicate begins with either of these two characters, it automatically indicates that a sequential search must be performed on the entire index. For example, given an index on LNAME, the query:

SELECT * FROM employee
    WHERE lname LIKE "_risp%"

might take significantly longer than the query:

SELECT * FROM employee
    WHERE lname LIKE "Krisp%"
      OR lname LIKE "Crisp%"

In the first case, the entire index must be searched for any names that have "risp" as the second through fifth letter. This is virtually the same as having no index at all. In the second case, the search is for two specific starting strings; these are more quickly found because the search does not have to go through the entire index.

Parent topic: Optimizing Query Processing


Index Usage with AND and OR

In the case of compound predicates connected with AND, the server will use all available indexes to find the intersection. For example, given indexes on columns ZIP and DEPT, both indexes might be used to process the following query:

SELECT * FROM employee
    WHERE zip = "20441"
      AND dept = "2020"
      AND payrate < 12.00

If an index had existed on PAYRATE, it would be used, but its absence does not prevent the use of the other indexes.

In the case of compound predicates connected with OR, the server uses an index, only if the two conditions reference the same column (and that column has an index). For example:

This query uses the index on the DEPT column:

SELECT * FROM employee
    WHERE dept = "2020"
       OR dept = "2021"

This query does not use the index on the DEPT or PAYRATE columns:

SELECT * FROM employee
    WHERE dept = "2020"
       OR payrate = 12.00
Parent topic: Optimizing Query Processing


Nested Queries

While algorithms exist on some systems to convert any nested query into a flat join, the benefit of such algorithms is not always significant. Therefore, the server does not perform the conversion. Instead, the server continually makes use of feedback from intermediate results to avoid unnecessary searches. If the server methodology is not the most efficient for your data, you can restructure the query as a flat join.

When processing a nested query, the server first evaluates the inner query (subquery). Consider the following query:

SELECT * FROM dept
    WHERE mgr IN
        SELECT e_no FROM employee
            WHERE city = "Wild Woods"

The XDB Server first finds all employees who live in Wild Woods, and modifies the nested query to process the outer query. If an index exists on MGR, it might be used after the nested query has been processed.

Parent topic: Optimizing Query Processing


Correlated Queries

When processing a correlated query, the outer query is processed first. The server compares the previous value to the current value to see if the inner query needs to be executed again. For example, given the following query to find the supplier who supplies the largest quantity of each product:

SELECT sno, pno FROM partsupp p
    WHERE qty =
        SELECT MAX(quantity) FROM items
            WHERE pno = p.pnoORDER BY pno

For each record in the PARTSUPP table, the inner query is evaluated to find the maximum quantity. If the next PARTSUPP record is for the same product, the maximum quantity is already known, and therefore the subquery is not performed. If PNO is indexed, then adding the ORDER BY PNO clause makes the query faster because the records with the same PNO values are all grouped together.

A correlated query whose correlated query block always evaluates to false is detected and does not continue to execute. If the correlation condition is not the condition that causes the query block to be false, the query block is always false.

For example, in this query:

SELECT * FROM table1 x
    WHERE EXISTS
        SELECT * FROM table2 y,table3 z
            WHERE y.f1 = z.f1
              AND x.f2 = z.f2
              AND y.f3 > 10;

if the inner SELECT does not retrieve any records without evaluating the correlation condition (X.F2=Z.F2), it can be determined that the query will not return any records; no records match the non-correlated criteria.

If only one correlation condition exists, the previous value of the correlation will unconditionally be saved for comparison with the next correlated value. (In previous versions of the XDB Server, this was only saved and compared if the correlated condition was not embedded in a NOT, AND or OR condition.)

Parent topic: Optimizing Query Processing


Join Optimization

The XDB Server uses a number of optimization techniques for processing joins. When performing a multitable join, performance might improve significantly if you specify all possible join conditions; this allows the system to perform the joins with the optimal selectivity ratio first, thus reducing the number of comparisons required.

For example, imagine three tables: EMPLOYEE, DEPARTMENT and PROJECT. Every employee works in a department. Every project is the responsibility of a department. Every project is managed by an employee from the responsible department.

Thus there are three possible join conditions that can be used to join the three tables:

  • DEPARTMENT.DEPT_ID=EMPLOYEE.DEPT_ID
  • DEPARTMENT.DEPT_ID=PROJECT.RESPONSIBLE_DEPT_ID
  • EMPLOYEE.EMPLOYEE_ID=PROJECT.PROJECT_MANAGER_ID

While it is sufficient to provide any two of these join conditions in your query, you might experience significant performance improvement if you provide all three join conditions.

As a general rule, when joining n tables, you should provide at least n-1 join conditions. When the context of a query permits, optimal performance might be achieved by providing any additional, valid join conditions. However the use of redundant join conditions must be balanced against the readability and parsing cost of the query.

Parent topic: Optimizing Query Processing


Sorting

When records are to be retrieved in a sorted order, indexes will speed up sorting.

If no appropriate indexes exist, qualifying records are located by performing a sequential search on the table. The resulting subset of records is sorted. The efficiency of the sort operation is affected by the Sort Space Size setting specified in the Configuration Utility.

If an index exists, a sequential search of the index (index walk) will be performed in some cases. For example, if an index exists on the PNO column, an index walk is performed to process the query:

SELECT * FROM part
    ORDER BY pno

In the following query, the index walk algorithm will make use of a compound index on the SNO and PNO columns:

SELECT * FROM partsupp
    ORDER BY sno, pno

When possible, the server uses the compound index if the first element in the compound index is referenced in a predicate or ORDER BY clause, even if the other columns are not referenced. For example, if the ORDER BY clause in the query above included only the SNO column, the compound index would be used. If the ORDER BY clause included only the PNO column, the index would not be used.

In the case of queries involving predicates and ORDER BY clauses, if appropriate indexes exist, the server will use the index to find the qualifying records, and then sort just those records. For example, given the following query, with indexes on PNO and QTY, the server uses the index on QTY to find the records that qualify, and then orders the result. The index on PNO is not currently used.

SELECT * FROM partsupp
    WHERE qty >= 200
    ORDER BY pno
Parent topic: Optimizing Query Processing


IN LIST with a Range Condition

If an IN LIST exists in conjunction with a range condition, a compound index can be used. In the following example, there is an index on columns A, B and C in TABLE1:

SELECT * FROM table1
    WHERE a = 3
      AND b IN (6,7)
      AND c BETWEEN 2 AND 20;
Parent topic: Optimizing Query Processing


Joins with Non-Join Predicates

Joins will take advantage of additional non-join predicates when compound indexes exist that involve both the join condition and the predicate.

For example, a compound index exists on TABLE2 (A,B,C):

SELECT * FROM table1,table2
    WHERE table1.a = table2.a
      AND table2.b = 3
      AND table2.c BETWEEN 1/1/1992 AND 12/31/1992;

If TABLE2 is an inner table of the join, the additional constraints will be applied when the join condition is applied.

Parent topic: Optimizing Query Processing


Join Restrictive List Analysis

If a restrictive list exists and has been prefetched on the inner table of a join, it might be discarded if the size of the list is larger than a certain percentage of the table size. If the restrictive list is discarded, the join index will be used (no merging is performed).

Parent topic: Optimizing Query Processing


Query Performance Summary

The guidelines listed below summarize the ways you can improve query performance.

  • If nested or correlated queries do not seem to process efficiently, restructure the query as a flat join to see if that method improves processing speed.
  • Use a correlated query instead of a nested query if the correlated column is indexed and the nested query returns a large amount of data.
  • Try to index the columns that have the lowest selectivity values (those with the largest number of different values), and construct your queries to include predicates involving these columns.
  • Try to avoid OR conditions on different columns. Use a union of queries containing AND conditions instead.
  • When creating compound indexes, try to list columns in the same order they appear in the ORDER BY clauses of your queries to allow the compound index to be used to speed up sorts.
  • Avoid numeric conversions. Try to make comparisons between columns of the same type.
  • Avoid the use of LIKE predicates beginning with % or __.
  • Avoid arithmetic expressions in a predicate, especially those that evaluate to a constant. Perform the calculation beforehand, if possible.
  • Select only the columns you need. Avoid SELECT * FROM when possible, especially when retrieving data across a network. Unneeded data creates unnecessary network traffic.
  • Avoid using COUNT(*) to check for existence.
  • Evaluate the benefits of single vs. compound indexes. Use compound index ordering if suitable. If possible, order the columns in the compound index by highest selectivity (that is, order the columns with the most unique values first).
  • Provide redundant information when joining tables, so that the system can select the lowest cost solution for you.
  • If a table is frequently updated or if most searches on the table are sequential searches (every record is accessed), avoid building any indexes on the table except for those used to enforce uniqueness.
  • Use views only when absolutely necessary. Each view access requires additional I/O and processing costs.
Parent topic: Optimizing Query Processing


Improving Production Processing

This section describes options that can help improve overall processing speed when using the XDB Server.

  • Integrity Constraints and Processing Speed
  • Locking Options
  • Caching
  • Special Read-Only Caching
  • Record ID (RID) Pool Buffer
  • Number of Open Files
  • Number of Open Queries
  • Governor Settings
  • Miscellaneous
  • Reducing Disk I/O Contention
Parent topic: Performance Tuning


Integrity Constraints and Processing Speed

The XDB Server supports schema level domain and referential integrity constraints. While integrity checking is a valuable facility, it can impact database performance considerably, especially on UPDATE, INSERT and DELETE operations.

You must determine whether the advantages of schema level integrity constraints outweigh the additional time required to enforce them. You might want to eliminate some of these checks at the schema level, and instead perform them through the validation facilities of the front-end data entry application. Remember that in a LAN environment use of integrity features creates additional network traffic.

Note that some indexes are automatically created and maintained by the system when integrity constraints are imposed on the database. These indexes can be dropped only by dropping the associated constraints.

For more information about referential constraints, see the following in the SQL Reference:

  • PRIMARY KEY, FOREIGN KEY and REFERENCES options on the CREATE or ALTER TABLE command.
  • WITH CHECK OPTION clause on the CREATE VIEW command.
Parent topic: Improving Production Processing


Locking Options

In multiuser systems, the time spent waiting for locks can be considerable. The XDB Server offers three means of adjusting the effect of locks on performance.

  • Isolation Level.

    Adjust the isolation level to increase or decrease the length of time that locks (especially shared or read-only locks) are held. The sooner a lock is released, the sooner the resource can be locked by another transaction. The trade-off for increased concurrency is decreased consistency.

    Each user can set a default isolation level in the client configuration. To specify the isolation level during a session, use the SET ISOLATION command.

    On a single-workstation XDB Server that will be operating only one client session at a time, using the Exclusive Use (EU) isolation level will eliminate locking overhead.

  • Lock Granularity.

    The time to perform many batch operations that affect many records of a table can often be greatly decreased by acquiring a table lock. Table locks are acquired by issuing the LOCK TABLE command. (See the SQL Reference for more information on the LOCK TABLE command.) Performance improves because there is no need to lock individual records as they are accessed. However, in some cases it will take a considerable amount of time to acquire a table lock. Also, other processes that need to access the locked table must wait until the table lock is released.

  • Timeout Period.

    Users can adjust the amount of time the system tries to acquire a lock. If the time is too short, performance might deteriorate because transactions cannot acquire locks and must be continuously rolled back. On the other hand, if the time is too long, performance might deteriorate because it takes longer to resolve potential deadlocks.

    Users can set their own timeout periods by setting the Lock Request Timeout in the client configuration.

Parent topic: Improving Production Processing


Caching

Caching is available for all database objects, including tables, indexes and data dictionary files. The cache size is specified at the server level using the Caching Options screen of the XDB Server Configuration Utility. Cache memory usage and other related information can be monitored on the XDB Cache Statistics screen while the server is running.

The major benefit of using cache is to keep frequently accessed disk blocks in RAM to ensure that subsequent access to these blocks requires no additional disk I/O. The buffer manager uses a searching algorithm to determine if a block exists in cache before deciding to retrieve that block from disk. If a block does not exist in the cache, this searching time can be classified as additional overhead because the search and the disk I/O must be performed.

The buffer manager also has a tossing algorithm. If the cache is full, some current cache blocks must be discarded before new blocks can be added. The determination of which blocks to discard is based upon a modified clock algorithm.

The cache manager can provide a performance boost only if the reduction in I/Os outweighs the CPU cost required to search and toss. The more objects there are to cache and the more random the access, the less useful a cache manager becomes.

For example, consider a database that is significantly larger than available RAM, with a large number of indexes (to optimize query processing) and data access patterns that are mostly random. All those indexes are eligible for caching, but the random access nature of the queries means that there will probably be a high percentage of cache tossing and low percentage of cache hits. This would indicate that each query was accessing either different I/O disk blocks or I/O blocks that had previously been tossed from the cache. In this situation, large cache sizes would have limited use.

If your system shows a high percentage of tossing and low percentage of cache hits, you should choose a cache size that would not assume I/O overlap between the query set, but would allow I/O reduction for an individual query. In this fashion, each individual query could benefit from common disk I/O access, while reducing the amount of CPU time required by the cache manager to search and toss.

It is important to check the cache hits and misses when all or most of your users are actively accessing data. Generally, the cache hit ratio increases as the number of users grows, especially when those users are performing similar tasks.

Parent topic: Improving Production Processing


Special Read-Only Caching

Outside of the normal cache manager, the server provides additional buffer management techniques specific to read-only data. These techniques are available when the user isolation level is set to dirty read (DR), snapshot read (SR) or exclusive use (EU).

In this cases, the server provides buffered I/O at the cursor level.

If sequential access of a database object is detected within an individual cursor, sequential prefetch of data can be triggered, allowing multiple data pages to be read into a buffer controlled by that individual cursor. This method of buffer management enjoys the benefits of reduced I/O without the normal cache manager overhead (search and toss), and eliminates the need for critical sections.

Parent topic: Improving Production Processing


Record ID (RID) Pool Buffer

The Query Optimizer makes use of a Record ID (RID) Pool Buffer when using the list prefetch algorithm for analyzing data access paths. See the section Optimizing Query Processing for more information on the list prefetch algorithm. List prefetch retrieves Record IDs from an index (in response to the constraints of a particular WHERE condition). The RID Pool Buffer is used to store the Record IDs. If required, the records are sorted before being stored in the RID Pool Buffer.

If the number of Record IDs fetched exceeds the available RID Pool size, the list prefetch is aborted and less efficient processing routines are used. For best performance, the size of the RID Pool Buffer should be large enough to contain the number of Record IDs expected from an index search.

The RID Pool size is specified in the XDBRIDPOOL environment variable in the server machine's configuration file. See XDBRIDPOOL in the appendix Environment Variables for more information on using this environment variable, and for a formula for calculating RID Pool Size.

Parent topic: Improving Production Processing


Number of Open Files

The XDB Configuration Utility allows you to specify the Maximum Number of Open Files. This setting, which represents the maximum number of files that can be kept logically open, should include only the required number of files. When a file is opened in response to a user request, the system scans an internal array to see if the file is already open. If it is, then processing time is improved.

Parent topic: Improving Production Processing


Number of Open Queries

The XDB Configuration Utility allows you to specify the Maximum Number of Open Queries. This setting, which represents the maximum number of queries that can be open at a given time, should include only the required number of queries. When an SQL statement is committed or rolled back, the system scans an internal array of open queries to find the one that should be closed. If the number specified for the Number of Open Queries is approximately the same as the number actually open at any given time, then processing time is usually improved. Specifying too large a number can increase processing time.

Parent topic: Improving Production Processing


Governor Settings

Use the Governor to limit user activity on the XDB Server. The settings you enter for the Governor can affect performance. The more frequently the Governor checks a user's activities, the slower the XDB Server will run. There is a trade-off among frequency of checking, performance, and how long the Governor will wait before terminating a user session.

Every n seconds, the Governor checks the status of the various options against actual server activity. Because the monitoring is not constant, the limits you set could be slightly exceeded before the Governor ends the user session. For example, a user might actually make 104 engine calls before the Governor sees that the user was allowed only 100 engine calls. You can make the Governor more accurate by setting the frequency for checking higher (such as every 10 seconds as opposed to every 30 seconds). However, there is a performance penalty for more frequent checking. See the chapter Server Configuration Utility for information about setting the governor cycle time.

Parent topic: Improving Production Processing


Miscellaneous

Some general guidelines that can improve processing speed include the following:

  • Close queries as soon as possible.
  • Commit transactions as soon as possible.
  • Change to dirty read (DR) when doing read-only operations where reading uncommitted changes are acceptable (some report writing, for example).
  • Balance work between the client CPU and the XDB Server CPU. For example, try to minimize ORDER BYs and aggregates. When writing COBOL programs, take advantage of the COBOL sort facility (which can process on the client's workstation) instead of using ORDER BY (which processes on the XDB Server).
  • To improve batch processing speed, consider turning off auto commit and forward logging if the process can be easily re-run.
  • When using embedded SQL in a program (any language), and you are executing many similar queries (same structure, but different values), use a PREPARE statement and multiple EXECUTE statements. For example, specify one PREPARE to set up the structure. Then EXECUTE repeatedly using different host variables for each.
Parent topic: Improving Production Processing


Reducing Disk I/O Contention

The XDB Server allows a single database to span multiple physical devices, as long as no single object of the database spans more than one physical device. Thus, while no database object (table or index) can exceed the size of its physical storage device, objects can be spread among many devices to reduce I/O contention.

For example:

  • Table Placement.

    Ideally, each table should be stored on a different disk drive so queries requiring access to multiple tables will not create I/O contention on one disk. If there are more tables than disk drives, tables can be arranged such that those least likely to be accessed in the same query would be grouped together.

  • Index Placement.

    Generally, indexes should not be placed on the same disk drive as other information (tables or indexes) that will likely be accessed by a query that uses the index. Some indexes, however, can be placed with any other object without creating disk I/O contention.

    If an index is used for list prefetch or an index contains coverage for a particular table (all columns referenced for a particular table are within the index), the index will not be accessed at the same time as the base table. See the section Optimizing Query Processing for more information on list prefetch. Thus, all indexes used for list prefetch can be placed on any physical device because these indexes are accessed once, and only once, during the processing of a particular query. Likewise, an index which contains full coverage and is not involved in a join will be the only object accessed in a particular query, and thus could be placed on any physical device as well.

  • Temporary File Placement.

    Temporary files should be written to or read from a disk drive other than the one used to store data and indexes, or a drive containing data that is little used by most queries. Temporary files are created when the SQL engine performs a sort that overflows the configured Sort Space Size (as specified in the Configuration Utility). Operations that perform sorts include CREATE INDEX statements and SELECTS that involve DISTINCT, ORDER BY, UNION or GROUP BY.

The guiding principle in determining object location is to spread the workload evenly among the drive controllers and disk heads. If disk head movement can be kept to a minimum and drive controller usage evenly dispersed, optimal performance can be obtained. Table and index caching can improve performance even more. See the section Improving Production Processing for more information.

Given that the server stores database objects in separate files, tuning of database object locations can be done at any time. By simply copying the database object file to a different physical device and updating the stogroup or environment variable pathname for that particular database object, different space allocation strategies can be tested.

Paths for stogroups are maintained in the SYSIBM.SYSVOLUMES table. If a table space was created without specifying a stogroup, the table space's path will be that of the database (either ..\loc-path\dbname or the path of the stogroup that was used to create the database). For greatest flexibility, each table should be associated with its own stogroup (drive and path) when it is created.

Paths for indexes and other objects can be specified in environment variables in the server machine's configuration file. (See the chapter Environment Variables for more information.)

Guidelines on how to position tables, indexes and temporary files are provided on the following pages.

  • Positioning Tables
  • Positioning Indexes
Parent topic: Improving Production Processing


Positioning Tables

Each database table can be associated with a physical device (drive and path) by using a stogroup and table space concept similar to that of DB2.

A stogroup is defined and associated with a physical device (drive and path). A database is then created using a particular stogroup. By default, any table subsequently created within that database is placed physically on the device (drive and path) specified by the database's stogroup.

To distribute tables to various disk drives, table spaces and stogroups are created. Each table space is associated with a stogroup, which in turn is associated with a drive and path. When a table is created, a table space can be specified, thus physically placing the table on the drive and path that is associated with the named table space.

For example, the following CREATE commands will create two stogroups (named STOR1 and STOR2) on two separate disk volumes (named MINE and YOURS). The UPDATE commands will define the disk drive and directory for each. (The directories must be created ahead of time using the operating system MAKE DIRECTORY (MD) command.)

CREATE STOGROUP stor1 VOLUMES (mine) VCAT xdb;
CREATE STOGROUP stor2 VOLUMES (yours) VCAT xdb;
UPDATE SYSIBM.SYSVOLUMES
    SET XdbPrimeVolPath = "y" ,
        XdbVolPath = "d:\stor1\"
    WHERE Volid = "mine";
UPDATE SYSIBM.SYSVOLUMES
    SET XdbPrimeVolPath = "y" ,
        XdbVolPath = "e:\stor2\"
    WHERE Volid = "yours";
Note: The fields XdbPrimeVolPath and XdbVolPath are XDB Server extensions to the SYSIBM.SYSVOLUMES table. These columns do not appear in DB2.

To complete the example, you would use CREATE commands such as the following to specify storage locations for objects you create, in this case tables.

CREATE DATABASE xyz STOGROUP stor1;
CREATE TABLESPACE abc in DATABASE xyz
    USING STOGROUP stor2;
CREATE TABLE firsttable
    (fld1 SMALLINT, fld2 CHAR 1)
    IN xyz;
CREATE TABLE secondtable
    (fld1 SMALLINT, fld2 CHAR 1)
    IN xyz.abc;

The table FIRSTTABLE will reside on d:\stor1 because it uses the stogroup defined for the database. The table SECONDTABLE will reside on e:\stor2 because it uses the stogroup defined for the table space. If desired, you can create a separate table space for each table, each with its own associated stogroup/path.

To move a table to a different device, copy the *.tab file to the desired drive and path, and update the path name for the associated stogroup in the SYSIBM.SYSVOLUMES table. If the index files (*.idx and *.ptr) are stored with the tables and do not have special paths defined for them in environment variables, be sure to copy them along with the related table. (See the section Positioning Indexes for more information about moving indexes.)

See the SQL Reference for more information about the storage architecture (including examples) and the commands shown here.

Parent topic: Reducing Disk I/O Contention


Positioning Indexes

An XDB index can be stored on a physical device different from the device where its related tables are stored by using an environment variable and an extension to the VCAT parameter of the CREATE INDEX command.

  • To store each index on its own path, use the XDB_index-name_ location-name environment variable to specify the path for storing each index. Then create each index using the VCAT NAME option on the CREATE INDEX command (using the index-name specified in the environment variable). If a qualifier is required for the index, you can enter a two-part name such as XDB_eric.orderidx_location1.
  • To store all indexes for a given location on the same path, use the XDBIDX_location-name environment variable to specify the path for storing all indexes for the location. Then create indexes for the location using the VCAT PATH option on the CREATE INDEX command.

For example:

  1. Enter the environment variable XDB_index-name_location-name in the computer's configuration file to specify a drive and path. You can create one or more index paths, such as:
    SET XDB_customerindex_location1= d:\indexes\customer
    SET XDB_ordersindex_location1= d:\indexes\orders
  2. Reboot.
  3. Create the indexes with the VCAT NAME parameter, as follows:
    CREATE INDEX customerindex ON customer(c_no)
    USING VCAT NAME;
    CREATE INDEX ordersindex ON orders(o_no)
    USING VCAT NAME;

    The VCAT NAME option causes the XDB Server to check the environment variable for the drive and path to use when creating the index. XDB index files are placed on the path associated with the environment variable for that particular index.

To move an index to a different device, simply copy the *.idx and *.ptr files to the desired drive and path, and change the path specification in the XDB_index-name_location-name or the XDBIDX_location-name environment variable. If the index path is not specified in an environment variable, then the index files must be in the same path as the related table.

See the CREATE INDEX command in the SQL Reference for more information about VCAT NAME and VCAT PATH. See the chapter Environment Variables for more information about the index environment variables.

Parent topic: Reducing Disk I/O Contention


Increasing Data Import Speed

The SQLWizard Import Utility provides interactive and batch capabilities for transferring data from various formats into tables, including the DSNTIAUL format that can be generated from mainframe DB2 data. The DSNTIAUL format stores data in its internal DB2 representation, thus requiring little or no conversion before insertion into the database.

One additional feature is available in the Import Utility, to speed the processing of import data even more, called Direct Write. This option bypasses all referential integrity features normally imposed by the SQL engine and eliminates all engine overhead that would be encountered during normal record insertions. Instead, information is written directly to the table file. This method of data loading achieves maximum performance.

See the SQLWizard User's Guide for more about the Import Utility and the Direct Write Import feature.

Parent topic: Performance Tuning


Improving Performance During Object Creation

XDB bufferpool caching is consolidated into a buffer management system. Instead of specifying separate cache sizes for table, index and dictionary buffers, a single unified cache size is specified for all accessed locations. The server also provides tuning options for improving the speed at which tables and indexes are created, as well as performance improvements that depend on the methods or options used during object creation. These include:

  • Specifying cache size
  • Using clustered indexes
  • Specifying the percentage of free space for indexes (read-only environments)
  • Specifying the blocking factor for duplicate Record IDs
  • Specifying sort buffer size
  • Buffer Management System
  • Clustered Indexes
  • Read-Only Environments
  • Block Size for Duplicate Record IDs
  • Sort Space Size
Parent topic: Performance Tuning


Buffer Management System

The buffer manager is designed to enhance performance. The buffer manager uses sophisticated search and toss algorithms and is tightly integrated with the log manager. You configure buffer manager memory as a single buffer as opposed to specifying memory amounts for each database object type. This single buffer manager handles access to tables, indexes and dictionary information, and simplifies configuration by allowing more intelligent cache use. Memory is allocated by the cache manager at server start up and released at server shut down.

Use the Configuration Utility to specify the cache size at the server level, and to set the checkpoint frequency parameter, which controls periodic purging of logging system cache. See the chapter Server Configuration Utility chapter for information.

Parent topic: Improving Performance During Object Creation


Clustered Indexes

In read-only environments, or for any table that does not have frequent inserts, it might be beneficial to define a clustered index. (You can have only one clustered index per table.) Specifying the CLUSTER option on the CREATE INDEX command gives you the option to later reorganize (re-order) the table's records into the same sequence as the related clustered index. For example:

CREATE INDEX pnoindex ON part (pno) CLUSTER

To reorganize the table's records into the same sequence as the clustered index's Record IDs, you must use the SQL COMPACT command with the CLUSTER BY INDEX option. For example:

COMPACT TABLE part CLUSTER BY INDEX pnoindex

Determining how often a table needs to be reorganized depends on how often records are added (inserted). The server leaves records in place when an update is issued (maintaining the order of records), but always inserts new records at the end of a table. A table that has many inserts would therefore need a reorganization more often than one that has few inserts.

Note:

If an update is made to the clustering key, the order of records in the table may be compromised. Use COMPACT to correct this situation.

See the CREATE INDEX and COMPACT command descriptions in the SQL Reference for more information about clustered indexes.

Parent topic: Improving Performance During Object Creation


Read-Only Environments

In a read-only environment, you can create all indexes with the parameter PCTFREE 0. This parameter allows all index blocks to be filled to capacity, thus reducing the size and number of index levels. This reduction in size allows faster index creation and searching.

Parent topic: Improving Performance During Object Creation


Block Size for Duplicate Record IDs

A blocking factor for duplicate key Record IDs can be specified using the DUPQTY parameter on the CREATE INDEX command. For best performance, the DUPQTY parameter for each index should closely resemble the index's distribution of duplicates. Indexes with high duplicate content should have high DUPQTY blocking factors, while more unique indexes should have low DUPQTY blocking factors.

Parent topic: Improving Performance During Object Creation


Sort Space Size

The XDB Server performs sorts in a variety of situations, such as the processing of ORDER BY, DISTINCT, UNION and other clauses that appear in SQL statements. Creating or rebuilding indexes, and re-clustering with the COMPACT command requires a significant amount of sorting.

To enhance sorting operations, you can set the amount of memory that the XDB Server will attempt to acquire for this purpose (use the XDB Configuration Utility). You might want to specify a higher amount when creating indexes or compacting/reclustering tables, and set it back to a lower amount for normal operations. The higher the number, the faster large sorts can be processed. Also, larger amounts of data can be processed at a single pass, thus requiring fewer merges of data. However, if set too high relative to the number of concurrent sorts, users or available RAM, processing of queries can be slowed.

The amount you allocate for sorting is the amount of memory that will be made available for each sort request that the system receives. This is not a common pool for all users, but rather a per-sort amount. If a particular sort request does not require the full amount allocated, the excess is released back to the operating system.

Parent topic: Improving Performance During Object Creation


Administrative Performance Tools

The following tools can help you determine how queries are being processed, how memory and cache are being used, and other performance-related information.

  • Virtual Statistics Tables
Parent topic: Performance Tuning


Virtual Statistics Tables

Virtual statistics tables allow you to run SQL queries against a snapshot of server usage data. The kinds of information you can extract depends on the query you construct and run against these special tables. For example, you can create such information as:

  • The number of users currently logged in.
  • A list of logged in users; most recent first (or last).
  • A list of users who have more than one query open and in repeatable read isolation level.
  • Number of users doing joins in a particular location.

The Virtual Statistics Tables contain dynamic information about the state of the server. The tables are populated when they are queried to give you current information. Apart from their dynamic nature, they can be accessed just like normal system tables, using joins, conditional clauses, sorts, aggregate functions, etc. Some of the information in these tables duplicates the data displayed on the various server screens, while some display other kinds of information.

All of the Virtual Statistics Tables have the AuthID XDBSTAT and are created (when queried) in the DSNDB07 database. They have no indexes. The format and content of the Virtual Statistics Tables are defined in detail in the SQL Reference. Examples of queries that can be run against these tables to extract information are presented below and on the next page.

  • Example: Number of Users Currently Logged In
    SELECT COUNT(DISTINCT nodename)
    FROM xdbstat.userlist;
  • Example: List of All Users, Most Recent First
    SELECT * FROM xdbstat.userlist

    ORDER BY attachts desc;

  • Example: List of All Users Having Greater than One Query Open in Repeatable Read (RR)
    SELECT username||"@"||nodename
    FROM xdbstat.userlist a, xdbstat.userresources b
    WHERE a.username = b.username
      AND a.nodename = b.nodename
      AND b.numqds >1
      AND a.ilevel = "RR";
  • Example: Number of Users Doing Joins in System Location
    SELECT COUNT(*)
  FROM xdbstat.queryinfo
  WHERE locname = "SYSTEM"
    AND numtables > 1;
Parent topic: Administrative Performance Tools


Location Management

This collection of topics provides information on configuring XDB Server and managing security, access, concurrency, locking, backup and recovery.

  • Security and Access Control
  • Transaction Processing
  • Concurrency Control
  • ROLLFORWARD Logging
  • Location Backup Options
  • Location Recovery and ROLLFORWARD
  • Distributed Processing
Parent topic: SQL Option Server Administration Guide


Security and Access Control

Table access may be performed interactively, or through a program running in batch mode, or through a CICS or IMS transaction. In all cases it is necessary to control access to the system and to the data stored in table objects. The XDB Server controls access to the system using Authorization IDs (AuthIDs) and passwords. The XDB Server controls access to location objects using privileges. The XDB Server supports both explicit and implicit privileges.

  • Turning Security On
  • User Control
  • Logging On to the XDB Server
  • Ownership
  • Granting and Revoking Privileges
  • Authorization IDs
  • Special Registers
  • Security for Distributed Processing
  • Auditing System Usage
  • The DSNDB06 Database
  • The XDBACF Database
  • Additional Security Information
Parent topic: Location Management


Turning Security On

The XDB Server provides various levels of security, including the ability to turn security on or off. When the XDB Server is initially installed, security is turned off by default. With security off, the system does not require a valid user ID or password to sign on to the system, nor does it check to see whether a user has privileges to perform an operation.

Security is turned on or off through the Configuration Utility. Turning security on or off is usually the responsibility of one of the database or system administrators, rather than of the individual user.

When you turn security on from a client you can also define a password enforcement level, which establishes rules for creating passwords, including password length, and permitted characters.

Once security is turned on you will usually be required to provide a valid user ID and password before you can connect to the system.

If security is on you must have authority to perform certain tasks.

Parent topic: Security and Access Control


User Control

You use theSQL Wizard to add new AuthIDs and GroupIDs to the system, and modify existing information, including passwords The information is stored in the system catalog, as described below. The SQL Wizard can also be used to make an AuthID a member of a group, so that the AuthID has the privileges of the group.

Note: It is possible to temporarily deny an AuthID access to the system by turning off access authority through the SQL Wizard (or by editing the appropriate row of the SYSXDB.SYSACFUSERS table). This method keeps all privileges and memberships intact. See the chapter Multiserver Security for various ideas on setting up security when using multiple XDB Servers.
Parent topic: Security and Access Control


Logging On to the XDB Server

If security is on, when you attempt to access the XDB Server or a local XDB Server, most programs will ask you to log on to the system. Usually you will see a window requesting a user name (or AuthID), followed by a password. When writing your own programs you can modify the log on procedure to meet your needs. This is described in the documentation for the language interface you are using.

Parent topic: Security and Access Control


Ownership

Implicit privileges exist for the owner of an object. For example, the owner of a table has all privileges on that table, including the privilege to drop or alter it. The default owner of an object is the SQLID at the time the object is created. However, a different owner can be recorded by using an AuthID to qualify the object (in the form creator-authid.object-name) when creating the object. For example, using the table name smith.orders when issuing a CREATE TABLE statement creates a table called orders that is owned by the AuthID smith. For additional information on ownership of a particular object, see the appropriate CREATE statement in the command reference topic of this manual.

Note:

If security is turned off, the server uses the default SQLID of the client as the creator of any database objects, and the grantor of privileges.

Parent topic: Security and Access Control


Granting and Revoking Privileges

Explicit privileges are conferred using the GRANT statement, and can be canceled using the REVOKE statement. Both are documented in detail in the command reference topic of this manual. Because the server provides a wide range of privileges covering database objects, components and activities, very precise control over data is achievable. For example, a user can be granted privileges to update, insert or delete rows of a table, to alter the structure of a table, to update specific columns of a table, to retrieve data from a table, and so on.

Privileges are generally associated with an object type. (For example, there are table privileges, column privileges, and database privileges.) In addition there are a number of special administration authorities used to confer comprehensive sets of privileges to certain types of users. See the chapter Security and Authority, and the topics on GRANT and REVOKE in the SQL Reference for more information. Included in these types of authorities are database administrator (DBADM), and super user authorities.

Information on privileges and authorities is stored in the system catalog tables. Each location stores privileges on objects within the location. In addition, the SYSTEM location stores information on administrator authorities for the system and for each location.

Parent topic: Security and Access Control


Authorization IDs

An Authorization ID (AuthID) is a string from one to eight characters long. While AuthIDs may logically represent a person, an organizational group, or a function, the server only acknowledges the unique AuthID string itself as the owner of a privilege or database object.

The XDB Server supports three types of AuthIDs to administer security: Primary AuthID, GroupID and SQL AuthID (SQLID). Individual Primary AuthIDs can also be mapped to something called a SecondaryID, which replaces the Primary AuthID as soon as the user logs in to the XDB Server.

How an AuthID is used at a given time determines the type of the AuthID. A given AuthID may be the Primary AuthID for one process, the SQLID for another, and a GroupID for a third. In order for an AuthID to be used as a Primary AuthID, however, it must be registered through the SQL Wizard. See the chapters Security and Authority and Multiserver Security for a full treatment of security issues.

  • Primary AuthID
  • SecondaryID
  • Group or GroupID
  • SQL AuthID (SQLID)
Parent topic: Security and Access Control


Primary AuthID

The Primary AuthID is the AuthID used to identify a process to XDB. Primary AuthIDs, and must be registered through the SQL Wizard. They are typically used with a password to verify that the user is actually entitled to use that particular AuthID. Note that while a Primary AuthID is usually associated with an individual, it might be used by a group of people. For example, if several users will be using a system at different times, they might all be able to log on using the same AuthID and password.

Generally, it is recommended that each individual who accesses the system be assigned a unique AuthID and password. In this way the system is able to maintain more accurate records of who is actually using the system, and password security is more effective because the passwords are not shared. If security is off, the default Primary AuthID stored in the client configuration is used for internal system identification. This default can be modified through the Options Utility.

Parent topic: Authorization IDs


SecondaryID

When the SQL Wizard is used to create a Primary AuthID (with its corresponding password), you are also allowed to specify a SecondaryID. If a SecondaryID is defined, it is used instead of the Primary AuthID to determine the actual privileges available to the session.

Once the user or process logs in, the value defined for the SecondaryID is used wherever the Primary AuthID would normally be used. It is as though the user or process had logged in using the SecondaryID instead of the Primary AuthID. For example, the SecondaryID appears in the special register USER, which normally contains the Primary AuthID of a session.

Note: The SecondaryID is not the same as the DB2 Secondary Authorization ID. The IBM method of defining multiple Secondary Authorization IDs and assigning them to Primary AuthIDs in RACF is similar to the GroupID concept.
Parent topic: Authorization IDs


Group or GroupID

Often an individual using a database system to perform a function is just one of many people who are authorized to perform that function. Rather than granting the privileges necessary to perform the function to each person, the privileges can be granted to an AuthID associated with a group, known as a GroupID. A GroupID is a special identifier that can be assigned to one or more Primary AuthIDs. The privileges granted to the GroupID are available to every Primary AuthID to which the GroupID is assigned.

Individual users can still log in using their own Primary AuthID, but because they are members of a group (with specifically defined privileges), they also possess the group privileges. A Primary AuthID can be a member of several groups -- in which case the AuthID possesses the combination of privileges granted directly to the Primary AuthID, plus the privileges defined for each group to which the Primary AuthID belongs.

All GroupIDs are recorded in the SYSXDB.SYSACFGROUPS table in the SYSTEM location. The relationship between a Primary and GroupID is established in the SQL Wizard by making the Primary AuthID a member of the group. The concept of the GroupID in the XDB Server is analogous to the Secondary Authorization ID in DB2.

Parent topic: Authorization IDs


SQL AuthID (SQLID)

The SQLID (also called SQL Authorization ID in DB2) is the AuthID used as the implicit qualifier for a table, view or index name in dynamic SQL statements, and for authorization checking of dynamic SQL statements. It also performs a special role as the default creator for CREATE statements, and as the grantor for GRANT statements.

Initially the SQLID is the Primary AuthID of a session. If a SecondaryID exists, the SQLID (and the Primary AuthID) is set to the SecondaryID. The SQLID in use by a particular user or process can be changed using the SET CURRENT SQLID statement, or through a Security User Exit. See Security User Exit for more information. See the SQL Reference for more information on the SET CURRENT SQLID statement. Usually the current SQLID must be the Primary AuthID, SecondaryID, or a GroupID of the session.

If security is off, the default Primary AuthID stored in the client configuration is used for internal system identification. This default can be modified through the Options Utility.

Parent topic: Authorization IDs


Special Registers

The XDB Server provides two special registers to store Authorization ID information. These registers can be used like column names in SQL commands.

USER

This register stores the Primary AuthID for the process. Note that if a Secondary AuthID exists for the Primary AuthID, the Secondary AuthID will appear in this register instead. If security is off, the Primary AuthID set through the Options Utility will appear in this register.

Current SQLID

This register is initially set to the value of the register USER. This register reflects the execution of a SET CURRENT SQLID command.

Parent topic: Security and Access Control


Security for Distributed Processing

Security for distributed processing is controlled by the AuthID privileges that have been granted in each location, regardless of which XDB Server controls the location. For a user to be able to access objects or data in a location other than his default location, his AuthID must have privileges at that other location for the objects he is accessing.

Parent topic: Security and Access Control


Auditing System Usage

The system catalog table called SYSXDB.SYSUSAGE audits system usage. If the Utilization Monitor is turned on at a user's workstation (using the Options Utility), the table stores audit information for that user's sessions, including location start time, end time, Primary AuthID, number of illegal access attempts, etc. To track utilization for all users, the Utilization Monitor must be turned on at the server using the XDB Configuration Utility. This overrides the Utility Monitor settings of individual users.

Note that the SYSXDB.SYSUSAGE table exists in the DSNDB06 database of the SYSTEM location only. Because of the overhead involved in maintaining the utilization data, this table should be purged periodically. See the chapter Server Configuration Utility, or the Options User's Guide for information on periodically purging the SYSXDB.SYSUSAGE table.

Parent topic: Security and Access Control


The DSNDB06 Database

Every location contains a set of system catalog tables, stored in the DSNDB06 database. The system catalog contains the following security-related tables, which store various types of authorities and privileges:

  • SYSIBM.SYSDBAUTH (Database Authorization)
  • SYSIBM.SYSUSERAUTH (User Authorization)
  • SYSIBM.SYSTABAUTH (Table Authorization)
  • SYSIBM.SYSCOLAUTH (Column Authorization)

Provided that you have the necessary authority, you can query these tables in the same way you would query any data table.

Parent topic: Security and Access Control


The XDBACF Database

The SYSTEM location contains a database called XDBACF (XDB Server Access Control Facility), which contains the following tables:

  • SYSXDB.SYSACFUSERS

    Contains a list of all users, including AuthIDs and Passwords for each user.

  • SYSXDB.SYSACFGROUPS

    Contains a list of all GroupIDs that have been defined.

  • SYSXDB.SYSACFMEMBERS

    Contains a list of users and the GroupIDs they are authorized to use. Each user (Primary AuthID) may have several entries, one entry for each group ID that the person is authorized to use.

See the SQL Reference for detailed information about the contents of these tables.

Parent topic: Security and Access Control


Additional Security Information

For more information on security, consult the references listed in the following table:

Document Topics
SQL Reference
  • SQL Commands
  • System Tables
The on-line help or the SQLWizard User's Guide
  • User Administration
Server Administration Guide
  • Configuration Utility
  • Security and Authority
  • Server-to-Server Connectivity
  • Multiserver Security
  • Security User Exit
  • AuthID List User Exit
Parent topic: Security and Access Control


Transaction Processing

A transaction is an atomic sequence of database operations. When a transaction is executed, either all or none of the operations are performed. The logging system automatically retains all table changes for any transaction in progress until that transaction is either rolled back or committed.

  • Committing a Transaction
  • Rolling Back a Transaction
Parent topic: Location Management


Committing a Transaction

When all of the data changes in a transaction are complete, commit the transaction using the COMMIT command. The effect of the COMMIT command is to request the system to accept permanently all of the data changes made by the transaction. The point of time at which the COMMIT operation occurs is known as a commit point. Normal exit from an XDB utility or application program causes the system to perform an implicit COMMIT. Alternatively, setting the autocommit feature causes all commands to automatically commit upon execution. See the section Autocommit for more information.

Parent topic: Transaction Processing


Rolling Back a Transaction

Sometimes an unacceptable condition is detected by a user or by the system after some changes have been made to the data. Additionally, two or more concurrently executing transactions could enter into a deadlock waiting for each other to release locked objects, and the system may force one of the transactions to abort. In all cases, all changes made to the data by an aborted transaction must be reversed in order to maintain the data in a consistent state. If the system detects a problem that requires the transaction to abort, it automatically reverses all the changes made to the data by the transaction. If the transaction decides to abort itself, it is the responsibility of the transaction to request a rollback of all changes it made to the data.

When a transaction is to be aborted, all of the changes made to the data during the current transaction must be undone. The ROLLBACK command is provided for this purpose. The effect of ROLLBACK is to undo all of the changes made to the data since the transaction began. Starting the server after a system failure triggers an automatic ROLLBACK of any incomplete transaction.

Note:

The XDB Server does not roll back or recover the Data Control Language (DCL) commands such as GRANT and REVOKE; or utility commands such as SET and DROP TABLE. When working in a production environment, it is recommended that you back up your location before and after such commands.

A program may contain multiple transactions. The first transaction begins when the program starts, and ends with either a ROLLBACK or COMMIT command. Subsequent transactions begin with the last COMMIT or ROLLBACK command, and end with the next COMMIT or ROLLBACK command.

Parent topic: Transaction Processing


Concurrency Control

Concurrency is the ability for multiple transactions to access table resources simultaneously. An integral consideration of data consistency is ensuring that changes made by one user do not negatively affect other users.

Locking is the method used to address both data consistency and concurrency requirements. A trade-off exists between database consistency and concurrency. It is necessary for the locking scheme to strike some sort of balance between consistency and concurrency.

The XDB Server controls concurrency by implementing locking schemes with choices of isolation levels. Each user may select the desired level of data locking.

  • Locking
  • Isolation Levels
  • Lock Compatibility
  • Timeout and Deadlock
  • Autocommit
Parent topic: Location Management


Locking

Locks have three basic attributes: object, mode and duration. Lockable objects include records and tables. Lock modes are shared and exclusive. Duration refers to the length of time a lock is held. Duration is dependent on the type of object locked, the lock mode, and the isolation level currently established.

The XDB Server supports automatic record level locking (R locks). Programs never have to request record level locks explicitly. The server can lock one record at a time, rather than a minimum of a page or block of data, which might result in reduced concurrency among users. In addition to record level locking, the XDB Server provides table locking. Table level exclusive (TX) and table level shared (TS) locks are acquired by using the LOCK command.

The server provides both shared and exclusive locks. In general, shared locks (S locks) are placed on an object when the object will be read only (not updated). This type of lock prevents any other transaction from changing the locked record for the duration of the lock. Other transactions may still read the locked record. The release of shared locks depends on the type and isolation level of the lock.

Exclusive locks (X locks) must be acquired before an object can be changed. When an exclusive lock is held on an object, no other transaction can reference the locked object. Exclusive locks are generally held until the end of the transaction that owns them (or until the transaction issues a COMMIT or ROLLBACK command).

Intentional table level locks will also be automatically acquired by the server. Before any shared record lock is granted, the server first places an intentional share lock (IS lock) on the table. Similarly, the server places an intentional exclusive lock (IX lock) on the table before an exclusive record lock is granted.

Parent topic: Concurrency Control


Isolation Levels

The isolation level in effect determines the manner in which locks are acquired and released by the system. The XDB Server provides the following isolation levels:

  • Level 1: Exclusive Use (EU). At Level 1 the system locks an entire location for the exclusive use of the current user. In essence, the system is operating in single user mode. This level of isolation should be used when performing such tasks as compacting the location, backing up the location, and recovering the location.
  • Level 2: Repeatable Read (RR). Level 2 guarantees that records read will not have been changed by another transaction from the time a lock is acquired on an object until the end of the transaction; that is, at this level of isolation all locks are held until the transaction is either committed or rolled back. This level provides a high degree of consistency and a relatively low degree of concurrency.
  • Level 3: Cursor Stability (CS). Cursor Stability is the default server isolation level. Under Level 3 exclusive locks are retained until commit or roll back, but record level share locks are released when the cursor leaves the record. The system automatically handles the release of all record locks types. This level of isolation provides less consistency and more concurrency than the RR level of isolation.

    The CS level of isolation is often used in combination with autocommit off by interactive applications where users may browse through records one at a time. In such an environment it is only necessary to maintain a lock on a record if the record is modified in some way. After the user moves to the next record, locks on unchanged records are released.

    Level 4: Lock Current (LC). At Level 4 the system acquires a lock when a record is referenced, but holds the lock only until the cursor moves to the next record. Note that exclusive locks are also released when the cursor moves to the next record; therefore this level should be used for read-only transactions, or used only when autocommit is turned on. Autocommit generates a commit command after each update takes place.

    Level 5: Dirty Read (DR). At Level 5 the system acquires no locks on a referenced record. The transaction operates in read-only mode and cannot make changes to database objects. This isolation level can be used to generate reports without delays while the system attempts to lock records. Records read at this isolation level may reflect changes made, but not committed. Note that these changes may be subsequently rolled back.

    Level 6: Snapshot Read (SR). At Level 6 a read-only snapshot of the data is made at the time of execution. No locks are held on the data, so other users can access and make changes to the data without waiting for the transaction working at SR to complete. The transaction working at SR isolation level is assured that the data it is working with will remain the same for the duration of the transaction. The SR transaction cannot make changes to the data.

The locks described above are automatically acquired by the system. At any isolation level it is also possible to explicitly request and release table level locks using the LOCK and UNLOCK commands. Table level locks may also be automatically acquired by the system if a command that affects the table definition is issued (for example, ALTER, RENAME, CREATE INDEX). Table level locks that are held at a commit point are automatically released, therefore it is not necessary to explicitly release a table level lock.

The default level of isolation for the XDB Server is CS (Cursor Stability). In order to ensure a different level of isolation it is necessary to issue a command to reset the isolation level. The startup isolation level is set through the Options Utility. You can also temporarily change the isolation level by using the SET ISOLATION command (described in this manual) and by using the WITH clause (available in DB2 4.x and beyond) on certain SQL statements.

It is important to consider how different users' isolation level settings impact the integrity of the database. The database administrator must coordinate the isolation level requirements for all users, and define those cases in which exceptions will be permitted.

Parent topic: Concurrency Control


Lock Compatibility

A transaction can acquire a lock on an object that is already locked only if the existing lock is compatible with the lock the transaction is trying to acquire.

In the lock compatibility matrices in the following two tables, table locks are exclusive (TX) or shared (TS), record locks are exclusive (RX) or shared (RS). In addition, IX and IS table locks are set by the system automatically when RX and RS locks are placed on records of that table.

 | TX | TS | IX | IS
TX | No | No | No | No
TS | No | Yes | No | Yes
IX | No | No | Yes | Yes
IS | No | Yes | Yes | Yes
 | RX | RS
RX | No | No
RS | No | Yes

For example, assume two transactions, a and b, want to access the part table. When transaction a reads a record in the part table, the system must acquire an RS lock on the record, and implicitly acquires an IS lock on the part table. If transaction b tries to read the same record, there is no conflict, so transaction b will be granted an RS lock on the record and an IS lock on the part table. If transaction b tries to update the current record, a conflict occurs because the RS lock held by transaction a, and the RX lock required by transaction b are incompatible.

The deadlock avoidance mechanism takes one of the following actions:

  • Permits transaction b to wait a user-defined period of time, during which the system periodically attempts to acquire the lock. If, by the end of the timeout period, the system has not acquired the RX lock for transaction b, the transaction must be rolled back and retried (if desired).
  • Withdraws the lock request immediately if it is determined that granting it might possibly result in a deadlock situation. Transaction b must be rolled back and retried (if desired).

However, if transaction b tries to update a different record in the part table, the system will acquire an RX lock on the record, and an IX lock on the table, and transaction b can be completed successfully. If transaction a had explicitly requested a TS lock on the part table, transaction b would not be allowed to update any record in the table, since both TX and IX locks are incompatible with a TS lock.

Parent topic: Concurrency Control


Timeout and Deadlock

The timeout period refers to the length of time a transaction waits to acquire a lock before it gives up. A deadlock occurs when two or more transactions are waiting for each other in a cyclic fashion.

When a transaction is waiting for a resource that is locked by another transaction, it waits until one of the following occurs:

  • The lock is granted.
  • The end of a timeout period occurs.

It is the responsibility of the program to roll back changes already applied, thereby releasing all locks. When a lock is not granted, a lock error message is returned to the program.

If the timeout period concludes before a lock is acquired, the transaction may perform other processing before attempting again to acquire a lock. Alternatively, it may roll back the entire transaction and retry it later. It is the responsibility of a program to retry a transaction that has been rolled back.

The timeout period is measured in seconds and can be set in the client configuration.

Parent topic: Concurrency Control


Autocommit

To shorten the length of time a lock is held and to reduce network overhead while maintaining a reasonable degree of database consistency, configure the system to automatically commit a command as soon as it is executed. Autocommit increases concurrency by immediately committing commands that change tables within a location. Since the transaction is a single command long, the use of ROLLBACK is limited to occasions when a failure occurs that automatically triggers a rollback. When using autocommit, it is important to remember that while you cannot explicitly roll back a transaction, the system is able to roll back a failed command.

For example, under autocommit, if you issue an UPDATE command from within the SQL Wizard, the command is executed and immediately committed if successful. If you issue a ROLLBACK command at this point, it will not roll back the completed UPDATE command; on the other hand, other programs do not wait for you to either explicitly commit the update command or exit from the SQL Wizard before they can acquire locks on the records you just updated.

If a system failure occurs during the UPDATE command (for example, the power goes off), the partially completed update command will be automatically rolled back when the system restarts. If the server discovers that an application node has failed, the server automatically rolls back any incomplete transaction belonging to the failed node.

When working at the LC (Lock Current) isolation level, autocommit should be turned on. The combination of the LC isolation level and autocommit are particularly useful in interactive processing. When a record is updated, inserted or deleted, the change is immediately committed, and all locks released.

Autocommit can be turned on or off through the Options Utility. Autocommit may also be turned on or off temporarily using the SET AUTOCOMMIT command.

Parent topic: Concurrency Control


ROLLFORWARD Logging

The logging system tracks all changes made to each location's tables since the last time the XDB Server BACKUP command was used on the location (or since the last time logging was reset for the location). The logging system maintains a separate series of log files for each location.

In the event of a serious system failure, such as a disk crash or other media failure, you can restore a backup copy of the location's tables and then issue the ROLLFORWARD command to apply the contents of the location's current log files to the restored location tables. These actions bring your tables up to date (to the time just prior to the system failure).

By default, the Forward Log path (where location log files are stored) is the same as your location path. You can and should change the name and path for your location log file storage. Ideally, log files should be placed on a different physical device than the location tables they are logging. This precaution protects against an independent media failure such as a hard disk crash.

You can change the current log path for a location by using the SET LOG command. See the SQL Reference for more information on the SET LOG command.

Location logging should be reset after using the BACKUP command to archive a location and its log files. If you use a different method to create your backups (such as an operating system BACKUP command), you can reset the location log files by deleting the current log files from your operating system prompt.

The logging system automatically creates a new series of location log files when you commence entering transactions. See the chapter Backup and Recovery for more information.

Parent topic: Location Management


Location Backup Options

The BACKUP command operates at the location level, including all paths and files for all tables in the location. Likewise, the ROLLFORWARD command, which applies the current series of location log files to a backup copy of the location data, also operates at the location level. If you have more than one database in a location and only one of those databases needs to be restored and rolled forward, you still have to restore and roll forward all of the databases in the location.

If you use an operating system backup command or other backup utility, and you intend to use the location's log files to reconstruct the data for that location, be sure that you have backed up all the files in all the paths that are defined for the location, including stogroup paths, if any. Also, be sure to reset the location logging after each backup is completed.

If your location backups are infrequent or if activity is high and the number of log files grows rapidly, you may wish to back up your location log files periodically to ensure that logging is available if you need it. Use an operating system BACKUP command or utility to back up the log files.

  • BACKUP Command
  • Other Backup Options
Parent topic: Location Management


BACKUP Command

The BACKUP command creates copies of all files that reside in the paths defined for the specified location, including paths associated with storage groups.

You can use the BACKUP command only if the location being backed up is not currently in use by you or another user. You can use the BACKUP command with or without using the roll forward logging feature.

When backing up a location you can specify whether you want to back up index files. If you need to restore a location from a backup that did not include the index files, you will need to rebuild the indexes using COMPACT LOCATION AND INDEX command.

BACKUP copies the files to the device and path you specify. This may be a tape drive, a file server, or a different disk drive. Use the Restore Utility to return the archived location to your hard disk.

Note: BACKUP does not copy files onto multiple diskettes. If the contents of the location are too large to fit on one diskette, use another backup option.

See the chapter Backup and Recovery and the SQL Reference for additional information on the BACKUP command.

Parent topic: Location Backup Options


Other Backup Options

Most commercially available archival utilities can be used to backup locations. When using a backup utility, it is important to keep in mind that you must backup the contents of all directories for the entire location, including stogroup paths (if any) and including all subdirectories. This last point is important since the server may have duplicate file names in different directories, which need to be kept separate on the backup device.

Parent topic: Location Backup Options


Location Recovery and ROLLFORWARD

If you are maintaining location log files and have made periodic backups of your location, you can usually recover from system failure by restoring the backup copies of the location files (this process copies the backed-up files into their proper directories and subdirectories in the location). Replay the current location log files against the restored location by using the ROLLFORWARD command. See the chapter Backup and Recovery for a more detailed description of this process.

Note: ROLLBACK and ROLLFORWARD do not recover Data Control Language (DCL) commands, such as GRANT and REVOKE, and utility commands, such as SET.
Note: Do not compact tables (or locations) before replaying log files. The log files must be applied to a non-compacted data object. Once a compact is performed, the current set of location log files is useless.
Parent topic: Location Management


Distributed Processing

Distributed processing is an integral part of the XDB Server architecture. It allows a session concurrent access to multiple locations. In conjunction with the multilocation architecture, support is provided for three-part object names (location-name.authid.object-name). These features allow users to access data outside of their default locations (restricted only by the security measures that have been implemented).

In a LAN environment, the locations can be distributed across various volumes on a network simply by specifying the desired path name when creating the location. Support of stogroups provides further opportunity to physically organize databases and tables (using table spaces) on specific volumes. Installation of XDB Link adds to the distributed processing capabilities by providing a transparent connection to a mainframe DB2 location using the Distributed Relational Database Architecture (DRDA) protocol.

  • Distributed Unit of Work (DUW) Processing.
  • Remote Unit of Work (RUW) Processing - XDB Locations
  • Remote Unit of Work (RUW) Processing - DB2 Locations
  • Server-to-Server Connectivity
  • DSNDDF Communications Database
Parent topic: Location Management


Distributed Unit of Work (DUW) Processing.

Use DUW processing to remain connected to your default (or current) location, and have the ability to execute a limited range of statements on data objects in another local or remote location. You can use INSERT, UPDATE, DELETE, and SELECT commands with three-part object names, while OPEN, FETCH and CLOSE commands are valid for DUW processing with embedded SQL.

An application simply uses the fully qualified name (location-name.authid.object-name) of a table or view that resides in the other location. Based on information in the system catalog tables on the current XDB Server, the request is sent to the appropriate XDB Server and data is returned.

Note:

Use of the DUW option requires that you reference no more than one location per SQL statement. If you need to work with objects in several locations, you must use multiple statements, one location per statement.

The XDB Server does not currently support two-phase commit or distributed queries.

Parent topic: Distributed Processing


Remote Unit of Work (RUW) Processing - XDB Locations

Use RUW processing to work with locations and applications at a local or remote location other than your normal (default) location. Remote locations run on another XDB Server on your network. With RUW, you are actually working at the other location. That is, the location you connect to becomes your current location.

You can specify either a local or remote location with which you wish to work by issuing the CONNECT command in embedded SQL, or the SET LOCATION TO command in interactive SQL.

Parent topic: Distributed Processing


Remote Unit of Work (RUW) Processing - DB2 Locations

This form of distributed processing operates in the same manner as the RUW for locations. If you use the SET LOCATION TO command in the SQL Wizard to attach to an XDB Link location, you can get back to a location through that same the SQL Wizard session from within that the SQL Wizard session. Within embedded SQL, a CONNECT RESET command can be used to return to a location.

XDB Link plus a few special entries in the XDB SYSTEM location's DSNDDF database are required to allow access to the mainframe DB2 Location. XDB Link provides transparent access to objects on the mainframe as though the mainframe were just another location on the server. The Distributed Relational Database Architecture (DRDA) is used in this configuration.

Parent topic: Distributed Processing


Server-to-Server Connectivity

Server-to-server connectivity allows a client accessing one XDB Server to access data in a location controlled by another XDB Server in a distributed environment. Server-to-server connectivity works only with SQL Data Manipulation Language (DML) statements, such as INSERT, UPDATE, DELETE and SELECT. Location access is done interactively, either by using a three-part-name (location-name.authid.object-name) or alias, or by using the SET LOCATION command.

Server-to-server connectivity eliminates the need to change the client configuration settings to access a remote XDB Server or DB2 location (through XDB Link). In order to access a remote location, a system administrator must maintain the system tables to reflect known locations and server names. See the chapter Server-to-Server Connectivity for further information on using server-to-server connectivity for RUW and DUW, and for server-to-server setup options.

Parent topic: Distributed Processing


DSNDDF Communications Database

Information about the local and remote locations that are accessible to users is stored in a communications database called DSNDDF in the SYSTEM location. This database contains the tables described below.

Data is entered automatically in the appropriate tables whenever a location is created with the SQL CREATE command, the XDB Server menu system, or the XDB conversion program. If necessary, you can edit these tables.

  • SYSXDB.SYSGATEWAY

    Contains information needed by XDB Link for accessing DB2 locations on a mainframe. For more information about XDB Link, see the XDB Link User's Guide.

  • SYSXDB.SYSGOVERNOR

    Contains information on the type of activities that can be performed by certain users during certain periods. See the SQLWizard User's Guide or on-line help for further information on governor features.

  • SYSXDB.SYSLOCALS

    Contains information about each "local" location, including all locations defined under the XDB Server to which this SYSXDB.SYSLOCALS table belongs.

  • SYSIBM.SYSLOCATIONS

    Contains information about all locations that are accessible for DUW and RUW processing including local locations in SYSXDB.SYSLOCALS, plus remote locations accessible using server-to-server connectivity and XDB Link. With DUW and RUW processing, any object that is referenced by a three-part name (location-name.authid.object-name) or a CONNECT command must have its location defined in this table. Remote locations may include mainframe DB2, DB2/VM or SQL/400 locations, or locations running under another XDB Server.

  • SYSIBM.SYSLUMODES

    Contains information needed by XDB Link for accessing DB2 locations. Each row provides mainframe VTAM with conversation limits for a specific LUNAME/MODENAME combination.

  • SYSIBM.SYSLUNAMES

    Contains LUNAME information needed by XDB Link and server-to-server connectivity. The table defines the name of each XDB Server if using server-to-server connectivity, or the name of the mainframe Logical Unit (LU) for one or more accessible DB2 systems if using the XDB Link. The names identified here are the same names identified in the LINKNAME column of the SYSIBM.SYSLOCATIONS catalog table.

  • SYSIBM.SYSMODESELECT

    Maintained for compatibility with DB2. Not used on XDB Server, but on the mainframe contains information for associating a MODENAME with any conversations created to support an outgoing SQL request.

  • SYSIBM.SYSUSERNAMES

    Contains user information needed by XDB Link for processing requests to and from a DB2 location, and for processing requests to other XDB Servers using XDB's server-to-server connectivity. Each row is used to carry out either an outbound or inbound ID translation or both.

Parent topic: Distributed Processing


Environment Variables

  • XDB_ index-name_ location-name
  • XDBCP
  • XDBIDX_ location-name
  • XDBINI
  • XDBNETINI
  • XDBRIDPOOL
  • XSRVCFG
Parent topic: SQL Option Server Administration Guide


XDB_ index-name_ location-name

XDB_index-name_location-name is an optional environment variable that is used in conjunction with the VCAT NAME option of the SQL CREATE INDEX command. To physically locate each index on a specific storage device (drive and path), specify a path in the [Server] topic of the xdb.ini file for each index/location combination, and subsequently create the index using the VCAT NAME option.

The format for this environment variable is:

XDB_index-name_location-name=drive-and-path

If a qualifier is required, enter a two-part name for the index-name, such as:

XDB_eric.orderidx_location1=m:\anypath

For example, to create and store an index called customerindex on d:\indexes\customer and another index called ordersindex on e:\indexes\orders (both for tables in the TUTORIAL location), you would make two entries in the xdb.ini file, and issue two SQL CREATE INDEX commands as follows:

  1. In the [Server] topic of the xdb.ini file, enter the following:
    XDB_customerindex_tutorial=d:\indexes\customer XDB_ordersindex_tutorial=e:\indexes\orders
  2. Using the USING VCAT Index Options under the Create/Alter Table function in SQL Wizard, issue the following commands:
    CREATE INDEX customerindex ON customer(c_no)
    USING VCAT NAME;
CREATE INDEX ordersindex ON orders(o_no)
    USING VCAT NAME;
Parent topic: Environment Variables


XDBCP

To support a number of non-American code page character sets, set the parameter XDBCP=codepage in the xdbsrvco.ini file [environment] group. Codepages that are directly supported are:

Number | Name
850 | MS-DOS Latin1 (used in the entire European Community except Greece)
863 | MS-DOS French Canada
865 | MS-DOS Nordic
942 | Japanese
949 | Korean
437 | MS-DOS Latin US
860 | MS-DOS Portuguese
Parent topic: Environment Variables


XDBIDX_ location-name

XDBIDX_location-name is an optional environment variable that is used in conjunction with the VCAT PATH option of the SQL CREATE INDEX command. To physically locate all indexes for a location on a specific storage device (drive and path), specify an index path in the xdb.ini file for each location, and subsequently create indexes using the VCAT PATH option.

The format for this environment variable is:

XDBIDX_location-name=drive-and-path

For example, to create and store all indexes for the TUTORIAL location in the path d:\indexes\tutorial , you would:

  1. Make the following entry in the XDB Server machine's configuration file:
    XDBIDX_tutorial=d:\indexes\tutorial
  2. Using the USING VCAT PATH Index Option under the Create/Alter Table function in SQLWizard, issue the following command:
    CREATE INDEX customerindex ON customer(c_no)
    USING VCAT PATH;
Parent topic: Environment Variables


XDBINI

The XDBINI variable specifies the directory where the xdb.ini file lives; this file contains both client and server side information for the SQL Option.

Parent topic: Environment Variables


XDBNETINI

The XDBNETINI variable specifies the directory containing the xdbnet.ini file is; this file contains the TCP/IP information necessary so SQL Option client-side software can speak to a XDB server.

Parent topic: Environment Variables


XDBRIDPOOL

XDBRIDPOOL is an optional environment variable that is specified in the [Server] topic of the xdb.ini file to enhance performance of the Query Optimizer.

The Query Optimizer may at times choose to use an algorithm called list prefetch when analyzing data access paths. This algorithm entails retrieving Record IDs (RIDs) from an index file and then sorting them. List prefetch is invoked when multiple index access is required or when data needs to be retrieved in physical order.

The format for this environment variable is:

XDBRIDPOOL=number-of-kilobytes

where number-of-kilobytes is the amount of memory to allocate for each statement's RID pool. The maximum size that can be specified is dependent on the amount of system memory that is available.

The RID Pool is the buffer that the server uses to store RIDs of this type. The default RID pool size is 512K per query. Since each RID contains 4 bytes, this default RID pool size can hold a maximum of 131,072 RIDs. If the RID pool size is exceeded, the list prefetch algorithm may be aborted, severely hampering performance.

The number of RIDs that can possibly enter the RID pool is determined by the selection criteria defined by a particular WHERE clause. A good rule of thumb for estimating an appropriate RID Pool Size is to determine the number of records that exist in the largest table, and then use the following formula:

RID Pool Size = (max records) * (.20) * (4 bytes per RID)

For example, a table containing 3,000,000 records would have an optimal RID Pool Size determined as shown below:

3,000,000 * .20 * 4 = 2,400,000 bytes

Converting this to kilobytes, we get:

2,400,000 / 1024 = 2344K

This RID Pool Size would allow an index condition that qualifies up to 20% of the table's rows to fit into the RID Pool.

The following XDBRIDPOOL environment variable setting would make available a 2400 kilobyte RID Pool per statement.

XDBRIDPOOL=2400
Parent topic: Environment Variables


XSRVCFG

XSRVCFG is an environment variable (an entry in the xdb.ini file) that indicates the drive and path on which the XDB Server configuration files reside:

  • The crvconfg.xdb file contains configuration parameters for the XDB Server as entered via the XDB Server Configuration utility.
  • The xdbsrvco file contains settings for the XDB Server logging and checkpoint features.
  • The xdbnet.ini file contains information for XDB Servers and clients who use TCP/IP.

The [Server] topic of the xdb.ini file contains various settings for the XDB Server, including the environment variables described in this chapter. If a copy of SQLWizard is on the same machine, it also uses xdb.ini to store configuration settings.

These files are usually located in the directory where the XDB Server software is installed. The XSRVCFG environment variable is entered in the [Server] section of the xdb.ini file when you install the XDB Server.

The format for this environment variable is:

XSRVCFG=drive-and-path

For example, if the XDB Server and its configuration files are located on the \xdbnt directory of the XDB Server machine (on theC drive if a Windows machine), the XSRVCFG environment variable would be entered as follows:

XSRVCFG=c:\xdbnt
Parent topic: Environment Variables


Server Files

  • Location and Database Files
  • Configuration Files
  • Help, Message and Error Files
Parent topic: SQL Option Server Administration Guide


Location and Database Files

Each location consists of a number of files and subdirectories to store location data, system catalog tables, and user-defined tables and indexes for each database in the location. Storage group (stogroup) directories might be used to organize the physical placement of some files. See the Data Storage Architecture for more information.

File Name | Description
numeric. * | Most file names are derived from the first 8 characters of their corresponding objects (location name, table name, etc.) If the first 8 characters do not produce a unique name, a random 8-digit number is generated by the XDB Server and is used as the file name.
location.ddt | Contains information on the tables in a location.
location.ddf | Contains information on the columns in tables in a location.
location.ddi | Contains information on indexes in a location.
location.ddv | Contains information on the XDB Server version.
sys*.tab | XDB Server system catalog tables. (Due to similarity of names, many system tables carry a numeric filename as explained above.)
table.tab | Contains the data stored in an XDB Server table.
index.idx | Contains index values for indexed columns.
index.ptr | Contains record pointers to duplicate occurrences of values. (Contain 0 bytes if the index is unique.)
Parent topic: Server Files


Configuration Files

There are a number of files used to store the configuration items you specify for your XDB Server operating environment. The stored configuration data are used as needed by the various XDB Server programs and utilities you run. These files generally reside in the Directory.

Other configuration files, such as config.sys, autoexec.bat or *.ini sometimes contain XDB information as well. See the appropriate installation guide for specific information.

File Name | Description
srvconfg.xdb | XDB Server environment configuration file. The environment variable XSRVCFG points to the location of this file.
product.ver | Contains version number for installed version of product. To see all .ver files found in the current directory, enter the command XDBVER on an operating system command line.
sort-sequence.seq | Pre-defined user sort sequence files that can be used in place of our standard ASCII or EBCDIC sort sequences.
Parent topic: Server Files


Help, Message and Error Files

Most XDB Server modules have help, message and error files associated with them. Generally, these files have the same file name as the module to which they refer. The extensions of these files use the following conventions:

  • Help and Message files end with the extension .hlp or .xsg.
  • Error files end with the extension .err or .xrr.

See the Error Messages book for a list and description of messages displayed by XDB Server software.

Parent topic: Server Files


Troubleshooting

This collection of topics describes troubleshooting scenarios and solutions for XDB Server, and accessing trace information.

  • Scenarios and Solutions
  • Tracing
Parent topic: SQL Option Server Administration Guide


Scenarios and Solutions

The following sections describe several trouble scenarios and their possible solutions.

  • My client cannot find my xdbnet.ini file.
  • My server-to-server TCP/IP connections are not working.
  • I get the message: Can't assign requested address bind() = 10049 when I try to bring up my XDB Server with TCP/IP threads.
  • I need to verify that a particular IP address is correct when configuring TCP/IP connections.
Parent topic: Troubleshooting


My client cannot find my xdbnet.ini file.

Ensure the xdbnet.ini file is placed in a directory pointed to by the XDBCFG or xdbnet.ini entry in the xdb.ini file. If both XDBCFG and xdbnet.ini have entries, then xdbnet.ini overrules XDBCFG.

Parent topic: Scenarios and Solutions


My server-to-server TCP/IP connections are not working.

  • First check that the basic XDB Server installation is functioning for each XDB Server by itself. If you have problems making a server-to-server connection, try connecting the client directly with each XDB Server (using the same protocol) and observe what happens. Also, if one protocol does not work for a particular connection, then try another one (if available).
  • Ensure that xdbnet.ini is built and present on your XDB Server machine.
  • Insert a single letter T (for TCP/IP) in the LINKATTR column of your SYSIBM.SYSLOCATIONS table. This single character value determines which address information in xdbnet.ini is used for the connection.
Parent topic: Scenarios and Solutions


I get the message: Can't assign requested address bind() = 10049 when I try to bring up my XDB Server with TCP/IP threads.

Ensure that your TCP/IP protocol is loaded. You may need to use the TCP/IP vendor's PING utility to help track down the problem. See the next scenario for information about using PING.

Parent topic: Scenarios and Solutions


I need to verify that a particular IP address is correct when configuring TCP/IP connections.

Use the PING utility (provided by your TCP/IP vendor) to test each XDB Server and client IP address in your Internet environment. PING takes the IP address as input and tests individual server-server, server-client and client-server machine connections for packet loss.

Perform the following PING tests to verify that your TCP/IP network connections are functioning properly:

  1. PING your XDB Server machine from your XDB Server machine.

    This verifies that your server-server machine TCP/IP connection is functioning properly, allowing local clients to both send and receive packets with your XDB Server.

  2. Because each remote client-server TCP/IP connection can employ a unique packet route in each direction across the internet, you should perform the following for each remote client that communicates with the XDB Server:
    • PING your XDB Server machine from your XDB Client machine.
    • PING your Client machine from your XDB Server machine.
Parent topic: Scenarios and Solutions


Tracing

Running a communications trace or an engine trace may help solve configuration and usage problems, and aid in performance tuning. For example, the engine trace file contains timing information that you can use to help you locate bottlenecks in your application. Micro Focus Technical Support will instruct you as to when and how to run a trace.

Contact Micro Focus Technical Support for assistance.

Parent topic: Troubleshooting


SQL Option Link Configuration Guide

  • System Requirements
  • Planning for XDB Link
  • Convening a Planning Meeting
  • Started Task Parameters
  • The Access List
  • xdbappc.ini Parameters
  • Code Page (CCSID) Tables
  • XDB Link Host Option Commands
  • Worksheets
Parent topic: SQL Option for DB2


System Requirements

Before you begin to configure your environment for XDB Link, review the following table and verify that you have the required hardware and software. Also check that your software is at the required levels.

Host System Requirements

 | XDB Link to host via TCP/IP | XDB Link to host via SNA
Hardware |  |
IBM S/390, S/370, or 100% compatible computer | Required | Required
Software |  |
MVS, Version 4.2 or higher | Required | Required
VTAM, Version 3.2 or higher | Required | Required
NCP, Version 4.3 or higher |  | Optional
IBM TCP/IP, Version 2.1 or higher or INTERLINK TCP/IP, Version 4.1 or higher | Required |
RACF or CA-ACF-2 or CA Top Secret | Optional | Optional
DB2/MVS Version 3.1 or higher | Required | Required

PC System Requirements

 |  | XDB Link to host via TCP/IP | XDB Link to host via SNA
Hardware |  |  |
80486-based microcomputer (or higher) |  | Required | Required
40-MB free hard-disk space |  | Required | Required
System and Communications Software |  |  |
If using Windows NT, you need: |  |  |
 | Windows NT 3.5 or higher | Required | Required
 | Microsoft SNA Server 2.1 or higher |  | Required
 | Winsock DLL | Required |
 | Winsock DLL | Required |
If using Windows 98, you need: |  |  |
 | Winsock DLL | Required |
Network |  |
One of the following protocols: |  |  |
 | SNA |  | Required
 | TCP | Required |
Note:

Minimum requirements (for native TCP/IP access) are DB2 V5.1 AND OS/390 V1R3. Review the PSP for HDB5510 and apply any PTF's applying to DDF and TCP/IP access. Complete the steps outlined in the DB2 for OS/390 Installation Guide (GC26-8970-00) chapter 3-3.

Parent topic: SQL Option Link Configuration Guide


Planning for XDB Link

After verifying that you have the appropriate hardware and software, you should do the following:

  1. Review and select the worksheets that apply to your environment. Micro Focus provides these worksheets to help you gather the information you need to configure the software on both your host system and the computer where XDB Link is installed. The worksheets also ensure that configuration values match, where necessary, across platforms and components.
  2. Convene a planning meeting.
Parent topic: SQL Option Link Configuration Guide


Convening a Planning Meeting

To launch the project, Micro Focus suggests that you schedule a meeting of the project team to plan the configuration effort and ensure that each organization understands its role in the process. The primary objectives of this meeting are to:

  • Identify who must do what and when.
  • Distribute and/or complete the worksheets.
  • Ensure that everyone has the information they need to successfully configure the component for which they are responsible.
  • Define the security measures you will implement between XDB Link and the host.

Because the configuration process involves steps on both the host and the server, some or all of the following people will need to attend:

  • VTAM systems programmers
  • Database administrators for all database systems that XDB Link will access
  • LAN system administrators
  • TCP/IP network administrators
  • Security systems administrators
Parent topic: SQL Option Link Configuration Guide


Started Task Parameters

Sample parameters are shipped in xdblink.v100.PARAM(PARMTCP). This file member contains the following definitions.

Note:

Do not use commas or periods when assigning a numeric value to a parameter.

Parameter Description
ORGANIZATION=
Specifies the organization ID of the owner of the XDB Link software license. The format is:

ORGANIZATION=org-id

where org-id is the organization ID. This parameter must be a string of up to 60 characters. There is no default.

PORT=
Specifies the port number that the Host Option will use. The format is:
PORT=port-number

where port-number is the number of the TCP/IP port dedicated to the XDB Link Host Option. This parameter must be an integer from 1 to 32767. There is no default.

BACKLOG=
 Specifies the length of the backlog queue maintained in TCP/IP for connection requests that have not yet been assigned sockets by the listener. The format is:
BACKLOG=backlog-length

where backlog-length is the length of the backlog queue. This parameter must be an integer from 1 to 32767. The default is 5.

NETWORK ID=
 Specifies the SSCP (system services control point) network ID for ACF/VTAM (the host node). The format is:
NETWORK ID=sscp-id

where sscp-id is the SSCP network ID. This must be a string of up to eight characters. There is no default.

LU6.2 APPLID=
 Specifies the APPLID (LU or ACBNAME) for XDB Link. The format is:
APPLID=applid

where applid is the APPLID for XDB Link. This is a string of up to eight characters, and equals the ACBNAME defined for the VTAM application. There is no default.

APPLID PASSWORD=
 Specifies the password of the APPLID defined in the PTRCT parameter of the VTAM APPLID definition. The format is:
APPLID PASSWORD=applid-pw

where applid-pw is the password. This must be a string of up to eight characters. There is no default.

TRACE=
 Specifies the trace facility name. The format is:
TRACE={GTF | WTOR | SYSPRINT}

This parameter can be set to GTF, WTOR, or SYSPRINT trace facilities. There is no default.

EID=
 Specifies the event ID of the GTF (Generalized Trace Facility) trace record. The format is:
EID=event-id

where event-id is the event ID of the GTF trace record. This must be a two-byte hexadecimal number (for example, 88FF), and it must match the USR value in the GTF trace parameter. There is no default.

TIME OUT FOR CONNECTION=
 Specifies the timeout period used for the TCP/IP accept call to get the connection request. The format is:
TIME OUT FOR CONNECTION=timeout

where timeout is the time out for connection in minutes. This must be an integer from 1 to 32767. Zero (0) specifies no timeout. There is no default.

COMPRESS=
 Not used.
ROUTE=
 Specifies the WTO (Write To Operator) and WTOR (Write To Operator with Reply) console route parameters.
ROUTE=(number1,number2)

Refer to the MVS/ESA SP V5 Auth Assembler Services Reference manual (GC28-1478) for descriptions of the values and their valid ranges. There are no defaults.

PRODUCT PASSWORD=
 Specifies the product password assigned for the software license. The format is:
PRODUCT PASSWORD=password

where password is the assigned product password. This is a six-byte hexadecimal number. The correct password will already be specified in this parameter, so there is no need for you to edit it. There is no default.

Example

The following is an example of a complete parameter definition. Lines beginning with "*" are comments.

****************************************************
  * *
  * XDB STARTED TASK INITIALIZATION PARAMETERS *
  * XDBLINK V1.00 *
  * *
  ****************************************************
  *
  * ORGANIZATION ID
  *
  ORGANIZATION=XDB SYSTEMS, INC.
  *
  * STARTED TASK TCPIP PORT NUMBER
  PORT=5170
  *
  * TCPIP LISTEN BACKLOG PARAMETER
  BACKLOG=5
  *
  * SNA NETWORK ID OF DB2 DDF
  NETWORK ID=USXDB
  *
  * STARTED TASK APPLID
  LU62 APPLID=XDB62APP
  *
  * STARTED TASK APPLID PASSWORD
  APPLID PASSWORD=XDB62APP
  *
  * TRACE OPTION
  TRACE=GTF
  *
  * GTF TRACE EID
  EID=00E9
  *
  * TCPIP ACCEPT TIME OUT PARAMETER
  TIME OUT FOR CONNECTION=0
  *
  * COMPRESSION OPTION
  COMPRESS=YES
  *
  ROUTE=(2,11)
  *
  * PRODUCT PASSWORD
  PRODUCT PSWD=2D0910D9A1C0
  *
  END
Parent topic: SQL Option Link Configuration Guide


The Access List

The access list in xdblink.v100.ACCESS determines whether the XDB Link Host Option accepts or rejects a packet from a particular IP address. You can use the access list to provide an extra layer of security between XDB Link and DB2. For example, you might use it to accept only packets that come from addresses on your company Intranet.

The XDB Link Host Option accepts requests from IP addresses specified by the PERMIT= parameters in the access list, and denies requests from addresses specified by the REJECT= parameters. If an address is not defined by either a PERMIT= or REJECT= parameter, a WTOR message is sent to the console, allowing the operator to reply "PERMIT" to accept the connection or "REJECT" to reject the connection.

The PERMIT= and REJECT= parameters are specified as follows:

PERMIT=IPaddress

REJECT=IPaddress

where IPaddress is the IP address in dotted decimal notation (for example, 204.177.148.255). You can mask an IP address by omitting trailing octets. For example, "PERMIT=204.177.148" accepts requests from IP addresses 204.177.148.0 to 204.177.148.255.

Examples

The following example accepts client connection requests from IP addresses 204.177.148.0 to 204.177.148.255, except for 204.177.148.244.

PERMIT=204.177.148

REJECT=204.177.148.244

The following example accepts client connection requests from IP addresses 198.202.128.18 and 98.2.82.0 to 98.2.82.255, but rejects addresses 204.0.0.0 to 204.255.255.255.

PERMIT=198.202.128.18

PERMIT=98.2.82

REJECT=204

Parent topic: SQL Option Link Configuration Guide


xdbappc.ini Parameters

The following table describes the parameters used by xdbappc.ini.

PU Definition Section

Parameter Description
PU
 Physical Unit name. This parameter must match the entry in the CSCON profile named "Peripheral CP Name."
Profile
 Profile name. This name must match the name of the profile configured with CSCON and loaded with CSLOAD.
Network
 Network Identifier. This parameter must match the entry in the CSCON profile named "SNA Network ID."
LuName
 Logical Unit Name. This is the LU name configured on the host that identifies this computer.
LuAlias
 Logical Unit Alias Name. This is the name of the LU as it will be known locally. We recommend that you use the XDB Server name as the alias.
LocAddr
 LU local address. This address must be 0 for independent LUs.
SessionLimit
 LU Session Limit. This value specifies the number of sessions this LU can have with the host. The value should be less than or equal to the entry in the CSCON profile named "Independent Sessions."
MaxTPs
 Maximum Transaction Program Limit. This entry indicates the number of transaction programs that can use this LU. It should be less than or equal to the session limit above. Each user connected through XDB Link gets an individual session and TP, so MaxTPs represents the maximum XDB Link connections possible with the host.
QueueDepth
 Depth of incoming allocate queue. This is the number of allocate requests that can be in the queue, waiting to be serviced by this LU.
PLU
 Partner Logical Unit Name. This specifies the remote database as it is known to the SNA network. For MVS/VTAM, this is the VTAM DB2 APPLID name.
Network ID
 Network Identifier. This is the name of the SNA network to which the partner LU belongs. This allows for a fully-qualified partner LU name.
Alias
 Partner Logical Unit Alias. This is the name of the partner LU as it will be known locally. The value of this parameter is used by the Gateway Profile Utility to identify the remote database.
Security
 Partner Logical Unit Security Capabilities.
  • 1 = Already Verified
  • 2 = Conversation Level security
  • 4 = Session Level security
  • 128 = Activate link to PLU at Attach LU time

Combinations of security capabilities can be added together. For Example: 3 is Conversation Level security and Already Verified (1 OR 2).

SessionLimit
 Partner Logical Unit Session Limit. This entry is the maximum number of sessions for which this partner is configured.
MaxMcSendLL
 Maximum Mapped Conversation Send Logical Length. Maximum size of data to send on a mapped conversation. The value 0 means use the largest possible value (32767).
DlcName
 Data Link Control Name. This entry identifies the connection type to the host system. Possible values are:
  • SDLC - Synchronous Data Link Control
  • ITRN - Token Ring or Ethernet
  • QLLC - Qllc connection
  • CUSTOM - Custom connection

AdaptNum
 Adapter Number. Indicates which adapter to use. For Token Ring use 0 to indicate the Primary adapter or 1 to indicate the Secondary adapter. All other DLCs should use 0.
AdaptAddr
 Adapter address:
  • SDLC - Omit this entry for this DLC type. It is not used.
  • ITRN - This is a 12-digit hexadecimal value of the locally administered address of a front-end processor (3174/37X5, PC gateway, etc.).
  • QLLC - Target name of the record in the call support layer (CSL) database defined in the NWSAA server. This entry can be up to 16 ASCII characters in length.
  • CUSTOM - Symbolic name used by the custom data link adapter. This entry can be up to 16 ASCII characters in length.

ModeName
 Mode Name. This entry is used to identify which mode definition to use for this partner LU.

Mode Definition Section

Parameter Description
Mode
 The Mode Name. The name of the mode to use for setting up sessions between the Local LU and the Partner LU. The recommended value is IBMRDB.
MaxRu
 Maximum Request/Response Unit. The maximum size (in bytes) of a Request/Response Unit.
MinRu
 Minimum Request/Response Unit. The minimum size (in bytes) of a Request/Response Unit.
MaxNegotiable
 The Maximum Negotiable Session Limit. This value is used to override the PLU max session limit.
Pacing
 Pacing Limit. The maximum number of Request/Response Units allowed before confirmation between LU and PLU.
Parent topic: SQL Option Link Configuration Guide


Code Page (CCSID) Tables

Code page files (TAB files) provided with this version of XDB Link include the following:

Decimal Rep | TAB files (Hex EBCDIC <==> ASCII)
290 - 1041 | 01220411.TAB / 04110122.TAB
300 - 301 | 012C012D.TAB / 012D012C.TAB
930 - 942 | 03A203AE.TAB / 03AE03A2.TAB
933 - 949 | 03A503B5.TAB / 03B503A5.TAB
437 - 37 | 01B50025.TAB / 002501B5.TAB
850 - 37 | 03520025.TAB / 00250352.TAB
273-37 | 01110025.TAB / 0025011.TAB
273 - 437 | 011101B5.TAB / 01B5011.TAB
273 - 500 | 011101F4.TAB / 01F40111.TAB
273 - 850 | 01110352.TAB / -352-111.TAB
500 - 437 | 01F401B5.TAB / 01B50352.TAB
500 - 37 | 01F40025.TAB / 002501F4.TAB
850 - 437 | 035201B5.TAB / 01B50352.TAB
850 - 500 | 035201F4.TAB / 01F40352.TAB

For every code page pair there are 2 TAB files having the format SSSSTTTT.TAB

where:

SSSS | is the source code page value in hex.
TTTT | is the target code page in hex.

Check to see whether the code pages you require are included in the XDB program directory. If you do not find the code pages you need, run the xcpgtab.exe program in the XDB Link program directory. This program will extract additional codes pages for the installed version of XDB Link.

If after running xcpgtab.exe you do not find the code pages you need, contact Micro Focus Technical Support.

Parent topic: SQL Option Link Configuration Guide


XDB Link Host Option Commands

Use the following commands to monitor and control the XDB Link Host Option. In the following command descriptions, stcname represents the name of the started task on MVS.

/F stcname, DISPLAY STATUS
 Displays the DB2 LU status, the conversation status, and the status of the started task.
/F stcname, DISPLAY LU
 Displays the DB2 LU status. If more than one DB2 connection exists, multiple LUs are displayed.
/F stcname, DISPLAY CONVERSATION
 Displays the status of LU6.2 conversations and TCP/IP connection information.
/F stcname, CANCEL
 Abruptly terminates the XDB Host Option without performing the standard shut-down procedure. Use this command only when the STOP command does not work.
/F stcname, STOP
 Stops the XDB Link Host Option using the standard shut-down procedure. It usually takes a few minutes for the program to complete its termination process after you have entered this command.
S stcname
 Starts the XDB Link Host Option.
P stcname
 Stops the XDB Link Host Option using the standard shut-down procedure. It usually takes a few minutes for the program to complete its termination process after you have entered this command.
Parent topic: SQL Option Link Configuration Guide


Worksheets

  • VTAM Worksheet
  • DB2 Worksheet
  • PC LAN Worksheet (Gateway Configuration)
  • SNA Server Worksheet (V2.11)
  • SNA Server Worksheet (V3.x)
  • xdbappc.ini Worksheet
  • TCP XDBPARM Worksheet
  • TCP Host/Service Worksheet
Parent topic: SQL Option Link Configuration Guide


VTAM Worksheet

Have a VTAM systems programmer complete this worksheet. Record your values in the space provided. Where suggested values are given, verify that your settings in VTAM match the suggested values.

Key

  • R denotes required information for XDB Link connections of this type. Settings must be verified or modified to match requirements.

    I denotes informational values may be useful in coordinating installation or in tracking down problems.

Note:

For VTAM, the minimum level is 3.2.

NCP is not required by XDB Link, but it must be at least version 4.2 if it is used.

TCP SNA Parameter Suggested Value Your Value Ref
R PU Definition
DLOGMOD=ANY3270
XID=YES
PUTYPE=2
STATOPT='XDB SAMPLE'

Accept system default for all other values

 A1
R PU Address

Used by SNA software on the PC

 A2
R PU CP Name

Used by SNA software on the PC

 A3
R IDNUM

Used by SNA software on the PC

 A4
R IDBLK

Used by SNA software on the PC

 05D for 3172 device A5
R LU6.2 Mode Entry

(MODEENT ID)

May be used by SNA software on the PC

 Use IBMRDB or the following:
TYPE = X'00'
FMPROF = X'13'
TSPROF = X'07'
PRIPROT = X'B0'
SECPROT = X'B0'
COMPROT = X'50B1'
RUSIZES = X'8989'
PSERVIC = X'060200000000000000002F00'
 A6
R LU Name for LU6.2 Terminals

Used by SNA software on the PC

XDBLU621 LU LOCADDR=0,MODETAB=RDBMODES,
RESSCB=20
 A7
I LU Name for 3270
XDB32701 LU LOCADDR=02,
          LOGAPPL=your3270mode
 A8
R R DB2 APPLID

Used by SNA software on the PC

See the IBM Manual Distributed Relational Database Connectivity Guide.

AUTH=(ACQ)
AUTOSES=1
SECACPT=ALREADYV
SRBEXIT=YES
VERIFY=NONE
VPACING=2

See your DB2 Administration Guide for other values

 A9
R TCP for APPLID, required only if using XDB Link Host Option.
APPL=YES,
AUTH=(ACQ),
DLOGMOD=IBMDB2LM,
DMINWNL=10,
DSESLIM=20,
SECACPT=ALREADYV,
SRBEXIT=YES,
VPACING=8
 A10

Please return this worksheet to the XDB Link Installation Coordinator.

Parent topic: Worksheets


DB2 Worksheet

Record your values in the space provided. Verify that the settings for DB2 meet the minimum requirements or match suggested values.

Parameter | Minimum Requirement | Suggested Value | Your Value | Ref
DB2 version | Version 3.1 or higher. |  |  | B1
DDF facility | Activated |  |  | B2
Security access to DDF | Required |  |  | B3
MAXDBAT in DSNZParms | MAXDBAT>=20 |  |  | B4
AuthID with authority to bind Used when creating XDB package or plan |  |  |  | B5
DB2 package name for XDB Used when binding XDB Link |  | XDBSYS |  | B6
DB2 collection ID for XDB Used when binding XDB Link |  | XDBDFT |  | B7
Users with plan access |  | PUBLIC/Specific users |  | B8
DB2 location name |  |  |  | B9
DB2 CCSID code page |  |  |  | B10

Please return this worksheet to the XDB Link Installation Coordinator.

Parent topic: Worksheets


PC LAN Worksheet (Gateway Configuration)

Give this worksheet to your PC LAN administrator or systems support staff. Verify that settings for the PC LAN and the XDB gateway machine meet the minimum requirements or match the suggested values. Record your values in the space provided.

Key:

  • R denotes required information for XDB Link connections of this type. Settings must be verified or modified to match requirements.
  • I denotes informational values that may be useful in coordinating installation or in tracking down problems.
TCP | SNA | Parameter | Minimum Requirement | Suggested Value | Your Value | Ref
R | R | Mainframe connection TCP/IP or SNA |  |  |  | C2
R | R | LAN ID Used by SNA software on the PC |  |  |  | C3
I | R | Cluster Controller Network Address Used by SNA software on the PC |  |  |  | C4
I | I | Communications cards Type of card in the gateway machine |  |  |  | C5
I | I | Max RU size for communication card | 512 |  |  | C6
I | I | 3270 access on gateway machine |  |  |  | C7
I | I | Client workstations | Verify that client workstations meet minimum software and hardware requirements specified in the XDB setup guide. |  |  | C8
R |  | IP address of host system |  |  |  | C9
I |  | IP address of gateway |  |  |  | C10

Please return this worksheet to the XDB Link Installation Coordinator.

Parent topic: Worksheets


SNA Server Worksheet (V2.11)

Give this worksheet to your PC LAN administrator or system support staff. Verify that settings for the SNA Server match the required value for the field in the specified dialog box. To help you determine the value to use when configuring SNA Server, the value's common name (nick name) and source definition are shown in the table below.

Record your values in the space provided. You will use your values when configuring the SNA Server.

Dialog boxes and field values that are not shown on this worksheet are not used by XDB Link.

Dialog Box | Field | Value Needed for XDB Link Configuration | Suggested Value | Your Value | Ref
Server Properties Network Name The SNA network name (NETID) for VTAM.1

Nick Name: NETID

Source: SYS1.VTAMLST (ACSTRxx)

 D1
Control Point The control point name (CPNAME) for this server as specified in the PU definition of VTAM or NCP.

Nick Name: CPNAME

Source: VTAM PU definition

 D2
Connection Properties | Connection Name | A name for the connection between this server and the remote system. This value is used internally by the SNA Server. | D3
Link Service The DLC type used to reach the host.(802.2 for either Ethernet or Token Ring.)
Note:

Verify that the selected protocol has been installed on the SNA Server machine.

 SnaDlc1 D4
Remote End One of the following system types
  • Host System
  • Peer System
  • Down Stream

For DB2 FOR OS/390, use Host System

 D5
Activation One of the following activation events that SNA Server will use to start this connection.
  • Startup
  • On Demand
  • Manually (by Admin)
 Startup D6
Connection Properties | Allowed Directions | Outgoing. Incoming optional. | Outgoing and Incoming | D7
SETUP Remote Network Address The 12-digit hexadecimal network address (MAC address) for this server. This address starts with 4000...for Token Ring, and with 02...for Ethernet.

Nick Name: Target Mac Address

Source: VTAM controller definition

 D8
Local Node Name Local Node ID The 8-digit hexadecimal local ID number for this server. The first three digits must match the IDNUM parameter in VTAM, and the last five digits must match IDBLK.

Nick Name: IDNUM & IDBLK

Source: VTAM PU definition

 D9
Remote Node Name Network Name The SNA network name (NETID) for VTAM. Can be blank for APPN Peer-to-Peer.1

Nick Name: NETID

Source: SYS1.VTAMLST (ATCSTRxx)

 D10
Control Point The system services control point name (SSCPNAME) of the host node as specified in the PU definition of VTAM or NCP. Can be blank for APPN Peer-to-Peer.

Nick Name: SSCPNAME

Source: SYS1.VTAMLST (ATCSTRxx)

 D11
XID Format | Format 3 | Format 3 | Format 3 | D12
Remote Node ID IDNUM and IDBLK parameter in VTAM

Nick Name: Remote target NODE ID

 blank D13
APPC LU Properties LU6.2 Type Independent

Nick Name: LOCADDR = 0

Source: VTAM LU definition

 Independent Independent D14
APPC LU Properties | LU Alias | A name that represents this machine in its local SNA communications configuration. We recommend that you use the XDB Server name as the alias. | XDBSERVE | D15
Network Name The SNA network name (NETID) for VTAM.1

Nick Name: NETID

Source: SYS1.VTAMLST (ATCSTRxx)

 D16
LU Name The LU name for this APPC LU. Must match the independent LU name specified in VTAM.

Nick Name: Independent LU Name

Source: VTAM LU Definition

 D17
Enable Automatic Partnering | Enabled | Enabled | Enabled | D18
Implicit Incoming | (None) | (None) | (None) | D19
APPC Remote LU Properties | LU Alias | A name that will represent the remote APPC LU in this server's SNA communication configuration. | D20
Network Name The SNA network name (NETID) for VTAM.1

Nick Name: NETID

Source: SYS1.VTAMLST (ATCSTRxx)

D21
LU Name VTAM APPLID for DB2 subsystem.

Nick Name: DB2 APPLID

Source: VTAM APPL definition

 D22
Uninterpreted LU Name VTAM APPLID for DB2 subsystem.

Nick Name: DB2 APPLID

Source: VTAM APPLS

 D23
Mode Mode Name IBMRDB or the mode name (DLOGMODE) defined for LU definition in VTAM.
Note:

MODETAB Name = VTAM mode table

DLOGMODE name = mode name for LU.

Nick Name: DLOGMODE

Source: ISTINCLM (or other specified name for the LOGMODE table)

 D24

1If you have a multi-domain network, use the parameter CDRM = (CDRM name). If you have a single-domain network, use the value found in library member SYS1.VTAMLIST(ATCSTRxx).

Please return this worksheet to the XDB Link Installation Coordinator.

Parent topic: Worksheets


SNA Server Worksheet (V3.x)

Give this worksheet to your PC LAN administrator or system support staff. Verify that settings for the SNA Server match the required value for the field in the specified dialog box. To help you determine the value to use when configuring SNA Server, the value's common name (nick name) and source definition are shown in the table below.

Record your values in the space provided. You will use your values when configuring the SNA Server.

Dialog boxes and field values not shown on this worksheet are not used by XDB Link.

Dialog/Tab | Field | Value Needed for XDB Link | Suggested Value | Your Value | Ref
SNA Servers General Network Name The SNA network name (NETID) for VTAM.1

Nick Name: NETID

Source: SYS1.VTAMLST (ATCSTRxx)

 E1
Control Point The control point name (CPNAME) for this server as specified in the PU definition of VTAM or NCP.

Nick Name: CPNAME

Source: VTAM PU definition

 E2
Connection General | Name | A name for the connection between this server and the remote system. This value is used internally by the SNA Server. | E3
Link Service The DLC type used to reach the host. (802.2 for either Ethernet or Token Ring.)
Note:

Verify that the selected protocol has been installed on the SNA Server machine.

 SnaDlc11 E4
Remote End One of the following system types
  • Host System
  • Peer System
  • Down Stream

For DB2 FOR OS/390, use Host System

 E5
Allowed Directions | Outgoing. Incoming optional. | Both | E6
Connection General Activation One of the following activation events that SNA Server will use to start this connection.
  • Startup
  • On Demand
  • Manually (by Admin)
 Startup E7
Connection Address Remote Network Address The 12-digit hexadecimal network address (MAC address) for this server. This address starts with 4000...for Token Ring, and with 02...for Ethernet.

Nick Name: Target Mac Address

Source: VTAM controller definition

 E8
Remote SAP Address SAP address defined by the hardware for this connection. VTAM controller definition

Source: Communications controller

 04 E9
Connection System Identification Network Name The SNA network name (NETID) for VTAM.1

Nick Name: NETID

Source: SYS1.VTAMLST (ATCSTRxx)

 E10
Control Point The control point name (CPNAME) for this server as specified in the PU definition of VTAM or NCP.

Nick Name: CPNAME

Source: VTAM PU definition

 E11
Local Node ID The 8-digit hexadecimal local ID number for this server. The first three digits must match the IDNUM parameter in VTAM, and the last five digits must match IDBLK

Nick Name: IDNUM & IDBLK

Source: VTAM PU definition

 E12
XID Type | Format 3 | Format 3 | Format 3 | E13
Connection System Identification Network Name The SNA network name (NETID) for VTAM. Can be blank for APPN Peer-to-Peer.1

Nick Name: NETID

Source: SYS1.VTAMLST (ATCSTRxx)

 E14
Control Point The system services control point name (SSCPNAME) of the host node as specified in the PU definition of VTAM or NCP. Can be blank for APPN Peer-to-Peer.

Nick Name: SSCPNAME

Source: SYS1.VTAMLST (ATCSTRxx)

 E15
Remote Node ID IDNUM and IDBLK parameter in VTAM

Nick Name: Remote target NODE ID

 blank E16
Connection 802.2 DLC Max BTU Length The maximum for the BTU length. Use one of the following:
  • Token Ring 4 MB = 4195
  • Token Ring 16MB = 16393
  • Ethernet = 1493

Nick Name: VTAMLST - MAXDATA value

Note: BTU value must be less than or equal to MAXDATA in the VTAM PU definition.

 E17
Local APPC LU Properties General | LU Alias | A name that represents this machine in its local SNA communications configuration. We recommend that you use the XDB Server name as the alias. | XDBSERVE | E18
Local APPC LU Properties General Network Name The SNA network name (NETID) for VTAM.1

Nick Name: NETID

Source: SYS1.VTAMLST (ATCSTRxx)

 E19
LU Name The LU name for this APPC LU. Must match the independent LU name specified in VTAM.

Nick Name: Independent LU Name

Source: VTAM LU Definition

 E20
Local APPC LU Properties Advanced | Member Def. Outgoing Local APPC LU Pool | Disabled | Disabled | Disabled | E21
Implicit Incoming | (None) | (None) | E22
LU6.2 Type Independent

Nick Name: LOCADDR = 0

Source: VTAM LU definition

 Independent Independent E23
SyncPoint Support | Disabled | Disabled | Disabled | E24
Remote APPC LU Properties General | Connection | Must match connection name in E3. | E25
LU Alias | An name that will represent the remote APPC LU in this server's SNA communication configuration. | E26
Network Name The SNA network name (NETID) for VTAM.

Nick Name: NETID

Source: SYS1.VTAMLST (ATCSTRxx)

 E27
Remote APPC LU Properties General LU Name VTAM APPLID for DB2 subsystem.

Nick Name: DB2 APPLID

Source: VTAM APPL definition

 E28
Uninterpreted LU Name VTAM APPLID for DB2 subsystem.

Nick Name: DB2 APPLID

Source: VTAM APPL definition

 E29
Remote APPC LU Properties Options | Supports Parallel Sessions | Enabled if the client is using an independent LU. | Enabled | E30
Implicit Incoming | (None) | (None) | E31
Session-Level Security | Only if using security keys | No Session-Level Security | E32
Mode General Mode Name IBMRDB or the mode name (DLOGMODE) defined for LU definition in VTAM.
Note:

MODETAB Name = VTAM mode table

DLOGMODE name = mode name for LU.

Nick Name: DLOGMODE

Source: ISTINCLM (or other specified name for the LOGMODE table)

 IBMRDB E33
Mode Limits Parallel Session Limit Defined by the number of users accessing the mainframe. Matches DSESLIM in your PU definition.

Nick Name: DSESLIM

Source: PU definition in SYS1_VTAMLST

 >E34

1If you have a multi-domain network, use the parameter CDRM = (CDRM name). If you have a single-domain network, use the value found in library member SYS1.VTAMLIST(ATCSTRXX).

Please return this worksheet to the XDB Link Installation Coordinator.

Parent topic: Worksheets


xdbappc.ini Worksheet

If you are using the SAA Server for NetWare, the XDB appc.ini file must be created in the root directory of the volume where XDB Link is installed. Verify that the settings in this file match the suggested values. Record your values in the space provided.

Section | Parameter | Minimum Requirement | Suggested Value | Your Value | Ref
PU Definition | Define PU | Must match the entry in the CSCON profile named "Peripheral CP Name" | NETWCP |  | H1
 | Profile | Must match the name of the profile configured with CSCON and loaded with CSLOAD | NETNODE |  | H2
 | Network | Must match the entry in the CSCON profile named "SNA Network ID" | XDBNET |  | H3
 | LuName | Must be configured for independent LU |  |  | H4
 | LuAlias | We recommend that you use the XDB Server name as the alias. | XDBSERVE |  | H5
 | LocAddr | Must be 0 for independent LUs |  |  | H6
 | SessionLimit | Should be less than or equal to the entry in the CSCON profile named "Independent Sessions" |  |  | H7
 | MaxTPs | Should be less than or equal to the session limit (SessionLimit) |  |  | H8
 | QueueDepth | Depth of incoming allocate queue |  |  | H9
PLU Definition | Define PLU | Define PLU name. For MVS/VTAM: The VTAM DB2 APPLID name |  |  | H10
 | Network | Network Identifier |  |  | H11
 | Alias | PLU alias | DRDAHOST |  | H12
 | Security | PLU security capabilities | 3 |  | H13
 | SessionLimit | PLU session limit |  |  | H14
PLU Definition | MaxMcSendLL | Maximum mapped conversation send logical length | 0 |  | H15
 | DlcName | Possible values: SDLC, ITRN, QLLC, CUSTOM |  |  | H16
 | AdaptNum | Token ring primary adapter, and all other DCLs use 0. Token ring secondary adapter use 1 |  |  | H17
 | AdaptAddr | Possible values: SDLC, ITRN, QLLC, CUSTOM |  |  | H18
 | ModeName | For sessions between Local LU and Partner LU | IBMRDB |  | H19
Mode Definition | Define Mode | Same as ModeName in PLU Definition Section | IBMRDB |  | H20
 | MaxRu | Maximum Request/Response Unit | 4096 |  | H21
 | MinRu | Minimum Request/Response Unit | 256 |  | H22
 | MaxNegotiable | Maximum Negotiable Session Limit | 16 |  | H23
 | Pacing | Pacing Limit | 4 |  | H24

Please return this worksheet to the XDB Link Installation Coordinator.

Parent topic: Worksheets
Related information
xdbappc.ini Parameters
Configure the PC


TCP XDBPARM Worksheet

Give this worksheet to your MVS systems programmer or system support staff if you are using the XDB Link Host Option on MVS. Record your values in the space provided. The XDBPARM file is located in a PDS file on the host (XDBLINK.V100.PARAM).

Parameter | Requirements | Suggested Value | Your Value | Ref
Organization | Organization ID | Your company name |  | I1
Port | Must match the port number defined in the SERVICES File | 5170 |  | I2
Backlog | A value greater than 0 | 5 |  | I3
Network ID | SNA Network ID |  |  | I4
LU6.2 APPLID | Must match the APPLID defined in the VTAMLST | XDB62APP |  | I5
APPLID Password | Must match the APPLID password defined in the VTAMLST | XDB62APP |  | I6
Trace | Must be GTF or WTOR | GTF |  | I7
GID | Must match the USR value in the GTF trace parameter | 0E9 |  | I8
Time Out for Connection | Between 1 and 32767 | 0 |  | I9
Compress | Not Used |  |  | I10
Route | A value for WTO and WTOR | (2,11) |  | I11
Product Password | Must be the password given by XDB |  |  | I12

Please return this worksheet to the XDB Link Installation Coordinator.

Parent topic: Worksheets


TCP Host/Service Worksheet

If you are using TCP/IP to connect XDB Link to the host system, you must edit the HOSTS and SERVICES files on the machine where XDB Link is installed to define the IP address and port number of the host system. Record your values in the space provided.

File | Parameter | Requirements | Suggested Value | Your Value | Ref
Hosts | IP address | The IP address defined for the host |  |  | J1
 | Host name | A name that represents this IP address |  |  | J2
Services | Service name | A name that represents this port number | We recommend that you use the name of the XDB Server as the service name. |  | J3
 | Port number | The port number assigned to the XDB Link Host Option | 5170 |  | J4
 | Protocol | TCP protocol | tcp | tcp | J5

Specify the IP address and host name values in the HOSTS file on the machine where XDB Link is installed. For example, you would enter the line:

240.195.165.202 LUDB2

to assign the host name LUDB2 to the IP address 240.195.165.202.

Specify the service name, port number, and protocol in the SERVICES file on the machine where XDB Link is installed. For example, you would enter the line:

XDBSRV 5170/tcp

to assign the service name XDBSRV to tcp port 5170.

Please return this worksheet to the XDB Link Installation Coordinator.

Parent topic: Worksheets


SQL Option Preprocesor Guide

  • Creating and Embedding SQL in COBOL
  • Using Dynamic SQL in COBOL
  • Static Binding
  • Security
  • DSNTIAR Facility
  • Preprocessor Directives and Options
Parent topic: SQL Option for DB2


Creating and Embedding SQL in COBOL

There are certain requirements your COBOL programs must meet before they can be compiled and debugged. This chapter outlines the processes for creating or modifying SQL code for COBOL programs. It also details the statements that all COBOL programs containing embedded SQL must contain.Use of dynamic SQL in your program is described in the chapter Using Dynamic SQL in COBOL.

  • Using Copybooks
  • Creating a Copybook
  • Representing Data
  • Using Directives
  • SQL Communications Area (SQLCA)
  • SQL Descriptor Area (SQLDA)
  • Sample COBOL Program with Embedded SQL
Parent topic: SQL Option Preprocesor Guide
Related information
Using Dynamic SQL in COBOL


Using Copybooks

In a typical development effort, different COBOL programs access the same data tables. Copybooks allow host variable definitions for a table's columns to be inserted within your COBOL code, allowing data from those columns to be used in your program. If a modification is made to a table (such as a change of data type or column length), then it is only necessary to modify the copybook rather than the source code definition for that table in all the programs that use it.

Parent topic: Creating and Embedding SQL in COBOL


Creating a Copybook

You can use the SQL Option Declaration Generator to create declarations of your tables. See the SQL Option Declaration Generator User's Guide for specific procedures.

  • Copybook Format
  • Including Copybooks in Programs
  • Host Variables
Parent topic: Creating and Embedding SQL in COBOL


Copybook Format

The format of a copybook is shown by the following example. This declaration defines the SQL Option EMPLOYEE table in the TUTORIAL location:

 01 EMP-TABLE.
     03 ENO PIC S9(4) COMP.
     03 LNAME PIC X(10).
     03 FNAME PIC X(10).
     03 STREET PIC X(20).
     03 CITY PIC X(15).
     03 ST PIC XX.
     03 ZIP PIC X(5).
     03 DEPT PIC X(4).
     03 PAYRATE PIC S9(13)V99 COMP-3.
     03 COM PIC S9V99 COMP-3.

All sample tables are shown in the SQL Reference manual.

Parent topic: Creating a Copybook


Including Copybooks in Programs

When including a copybook in your program, make sure that the Compiler can locate the copybook.

If a copybook contains embedded SQL or host variable declarations, include it using one of the following three methods:

  • EXEC SQL INCLUDE ... END-EXEC
  • COPY
  • -INC
Parent topic: Creating a Copybook


EXEC SQL INCLUDE ... END-EXEC

For example:

EXEC-SQL
    INCLUDE EMPREC
END-EXEC
Parent topic: Including Copybooks in Programs


COPY

For example:

COPY EMPREC.

The file named after the COPY verb can contain any COBOL statements that a copybook can, including EXEC SQL statements.

The SQL Option preprocessor works like the mainframe DB2 preprocessor does. However with the SQL Option preprocessor, you need to specify the preprocessor directive COPY to allow host variables to be defined in COPY statements.

Note:

If you specify EXEC SQL statements using the COPY verb, the SQL Option preprocessor will compile the program and will generate an error message for any host variable referenced from the copybook without the COPY directive being set. If you port the same program to the mainframe, the SQL code may not precompile unless your installation has a product that expands copybooks before passing them to the DB2 mainframe preprocessor.

Parent topic: Including Copybooks in Programs


-INC

For example:

-INC EMPREC

The file specified after the -INC verb can contain any COBOL statements that a copybook can, including EXEC SQL statements.

Parent topic: Including Copybooks in Programs


Host Variables

Host variables are used to hold data that is accessed by both COBOL and SQL commands. You define a host variable as a data structure that represents the column names and data types of the tables that are accessed by the COBOL program.

Host variables are usually defined in copybooks. Copybooks can be quickly created from any SQL Option or DB2 table using the SQL Option Declaration Generator utility.

There are two ways to use host variables:

  • To store information returned by the database engine as the result of an SQL statement.
  • To store information sent to the database engine and/or dynamic information that controls what is returned by a SELECT statement.

All host variables appearing inside an EXEC SQL ... END-EXEC block should be preceded by a colon, as shown for the host variable DEPT-NUM in the following example:

 EXEC SQL
     DECLARE EMPCURS CURSOR FOR
     SELECT LNAME, FNAME, PAYRATE, HOURS
       FROM EMPLOYEE
       WHERE DEPT = :DEPT-NUM
 END-EXEC

DB2 V5 does not require all host variables to be preceded by a colon, but DB2 V6 does. If you plan to upgrade in the future, you should set your message level to WARNING in the build setting for every SQL programs in the project.

The use of host variables allows you to design more flexible queries, and to interactively define the criteria for data selection. In the preceding example, the host variable specifies the department for which data will be selected.

For information about null values in host variables, see the section Using Indicator Variables .

Parent topic: Creating a Copybook


Representing Data

When you access data with SQL statements in COBOL programs, you must provide corresponding data definitions in your COBOL source code. This requirement is usually accomplished by stating the data definitions in a copybook and including that copybook in your COBOL source code.

The copybook EMPREC contains a COBOL representation of the column names and data types for the EMPLOYEE sample table. The Declaration Generator generates copybooks from tables, automatically creating a COBOL data definition for each table columnYou can modify the generated copybook file as needed. See the SQL Option Declaration Generator User's Guide for more information about using the SQL Option Declaration Generator.

Note: The SQL Option Precompiler does not accept all COBOL data types. If the COBOL data item you code is not consistent with those shown in the section Allowed Data Declarations, it will not be recognized as a host variable.

The following guidelines are offered to assist you in working with host variables and data declarations.

  • For data declarations of host variables use level number 01 to 77.
  • A varying-length character string data item must have group level 01. The group contains two, level 49 elementary items consisting of:
    • Length Item.

      The first elementary item must be a 2-byte integer variable; for example, PICTURE S9(4) COMP. It represents the length of the character string.

    • Value Item.

      The second elementary item must have the same description as a fixed-length character string; for example, PICTURE X(80), where 80 is the maximum length of the string. This item is used to contain the value of the character string. If you use the host variable to insert a character string into a table, the database manager inserts only as many characters as are indicated by the length item. Also, when data is placed into the field, only the number of characters defined in the length item is returned. This can cause previous information stored in this field not to be cleared.

    The data item and elementary items can have any acceptable COBOL name. However, in SQL statements, refer to this host variable by its group name.

  • COBOL host variables used in SQL statements must be of a type compatible with the database columns with which they are to be used.
    • Numeric data types are compatible with each other. A SMALLINT, INTEGER, DECIMAL, or FLOAT column is compatible with a COBOL host variable of COMP, COMP-2, COMP-3, COMP-4, or COMP-5.
    • Character data types such as CHAR and VARCHAR are compatible with each other. The database manager automatically converts a fixed-length character string to a varying-length string, or vice versa, when necessary.
  • Be careful of overflow. For example, if you retrieve an INTEGER column value into a PICTURE S9(4) host variable and the column value is larger than 32767 or smaller than -32768, you will get an overflow error.
  • Be careful of truncation. For example, if you retrieve an 80-character CHAR column value into a PICTURE X(70) host variable, the rightmost 10 characters of the retrieved string will not be included.

    Retrieving a floating-point or decimal column value into a COMP host variable removes any fractional value.

  • The COBOL declarations for SMALLINT and INTEGER data types are expressed as a number of decimal digits. The database manager uses the full size of the binary integers, and may place larger values than would be allowed in the specified number of digits in the COBOL declaration. This situation can cause data truncation. Ensure that the size of any numbers in your application is within the allowable number of digits.
  • The SQL Option preprocessor also supports using host variables defined with the SQL TYPE IS declaration. The actual data definition for the host variable is then determined by the preprocessor. For example, a host variable for a RESULT SET LOCATOR could be defined as:
    01 my-locator usage SQL TYPE IS RESULT-SET-LOCATOR varying.
  • Allowed Data Declarations
  • Allowed Data Declaration Abbreviations
  • Using Indicator Variables
Parent topic: Creating and Embedding SQL in COBOL


Allowed Data Declarations

The following table shows the COBOL declarations that are allowed for defining host variables. All other types of COBOL declarations will be rejected. Allowed abbreviations are shown in the section Allowed Data Declaration Abbreviations.

Data Type | COBOL Data Declaration | Comments
char | 01 identifier PIC X(n). 01 identifier PICTURE IS X(n). | n is a positive integer representing the length of the CHAR column value assigned to the host variable.
varchar | 01 identifier 49 identifier PIC S9(ni) COMP. 49 identifier PIC X(nc). | ni is a positive integer from 1 to 4, representing the length of the numeric column value assigned to the variable containing the string length. nc is a positive integer equal to the length of the largest VARCHAR column value that can be assigned to the host variable.
smallint | 01 identifier PIC S9(4) COMP. 01 identifier PIC S9(n) COMP. 01 identifier PIC S9(n) USAGE IS COMP. | n is a positive integer from 1 to 4, representing the variable length. No decimal points are allowed. Anything other than 9s in the Picture clause makes data item unacceptable as a host variable. PIC S and COMP are required. You may use COMP-4 or COMP-5 in place of COMP if necessary.
integer | 01 identifier PIC S9(9) COMP. 01 identifier PIC S9(n) COMP. 01 identifier PIC S9(n) USAGE IS COMP. | n is a positive integer from 5 to 9. No decimal point is allowed. Anything other than 9s in the Picture clause will make the data item unacceptable as a host variable. PIC S and COMP are required. You may use COMP-4 or COMP-5 in place of COMP if necessary.
decimal | 01 identifier PIC S9V COMP-3. 01 identifier PIC S9(n) V COMP-3. 01 identifier PIC S9(n) V9(m) COMP-3. 01 identifier PIC S9(n) V9(m) USAGE IS COMP-3. | n and m are positive integers; n + m cannot exceed 15. You must include a V to denote the decimal point. Anything other than 9s and a V in the Picture clause will make the data item unacceptable as a host variable. PIC S and COMP-3. are required.
float | 01 identifier COMP-2. 01 identifier USAGE IS COMP-3. | COMP-2. or COMP-3. is required.
date | 01 identifier PIC X(n). 01 identifier PICTURE IS X(n). | n must be an integer representing the length of the date string. For example, if the date string is in the format MM/DD/YY, n may equal 8. If in the format MM/DD/YYYY, n should equal 10. Make sure your date format is set correctly in the Options utility. See the Option utility's online help for information about modifying the date/time representation.
time | 01 identifier PIC X(n). 01 identifier PICTURE IS X(n). | n must be an integer representing the length of the time string. To include seconds, n must be at least 8. For example, a time string in the format HH:MM requires that n equal at least 5, while a time string in the format HH:MM:SS requires that n equal at least 8.
result set locator | 01 identifier SQL TYPE IS RESULT-SET- LOCATOR. | A 4-byte value used by DB2 to uniquely identify a query result set returned by a stored procedure.
Parent topic: Representing Data


Allowed Data Declaration Abbreviations

The following table shows the COBOL abbreviations allowed for host variables. For a complete list of allowed data types, see the topic Allowed Data Declarations.

Abbreviation | Can be used for...
PIC | PICTURE or PICTURE IS
COMP | COMPUTATIONAL or USAGE IS COMPUTATIONAL
PIC IS | PICTURE IS
USAGE | USAGE IS
S9(5) | S99999
X(10) | XXXXXXXXXX
Parent topic: Representing Data
Related information
Allowed Data Declarations


Using Indicator Variables

An indicator variable is a 2-byte integer variable that can be used for either of the following purposes:

  • To indicate whether its associated host variable has been assigned a null value. If the value for the column you are retrieving is null, a negative value is placed in the indicator variable.
  • To verify that a retrieved character string value has not been truncated. If the indicator variable contains a positive integer, it specifies the original length of the string.

When a column's value is retrieved, you can test the indicator variable. If the indicator variable's value is less than zero, you know the retrieved column's value is null. When a null value is retrieved, nothing is put into the associated host variable that is used to contain the column's value; thus, the value of the host variable is unchanged.

Define indicator variables in the same manner as small-integer host variables. Specify an indicator variable, preceded by a colon, immediately after the host variable to which it relates. For example:

 EXEC SQL
     SELECT PHONENO INTO :CBLPHONE :INDNULL FROM CORPDATA
       WHERE EMPNO = "EMPID"
 END-EXEC

You can then test INDNULL to see if it contains a negative value. If it does contain a negative value, then you know that a null value was retrieved for the row's PHONENO (that is, phone number) column, and you can disregard the contents of CBLPHONE.

When a column value is fetched using a cursor, you can use the same technique to determine whether the retrieved value is null or not.

You can also use an indicator variable to set a null value in a column. When processing UPDATE statements, the indicator variable is checked. If the indicator variable contains a negative value, set the column value to "null value." If the indicator variable is greater than -1, the associated host variable contains a value for the column.

Parent topic: Representing Data


Using Directives

Directives are compiler options that convey information to your compiler and the SQL Option Precompiler. For example, the DBRM directive is used to create a database request module during the compile.

Parent topic: Creating and Embedding SQL in COBOL
Related information
SQL Option Preprocessor Options


SQL Communications Area (SQLCA)

Every COBOL program containing embedded SQL must have an SQL Communications Area (SQLCA) or the field SQLCODE defined in its Working-Storage Section. This definition is normally accomplished by including the SQLCA copybook provided with your COBOL system. A complete description of the SQLCA structure is provided in the SQL Reference manual.

The SQLCA holds information on the status of the SQL statement last executed. It is updated after the execution of each EXEC SQL ... END-EXEC block of code.

Information in the SQLCA can be used in many ways. For example:

  • You can use it to debug your code. Use the debugger to view the SQLCA fields and examine its error codes and warning flags.
  • You can use it to control the flow of your program by testing its values. For example, when SQLCA indicates an error, you can branch to an error-processing routine. Similarly, you can use it to detect the end-of-data and exit a loop.

The following SQLCA codes are particularly useful:

Field | Description
SQLSTATE The SQL Option Preprocessor provides limited support for DB2-compliant SQLSTATE return codes within COBOL application programs. This limited support is provided on top of already existing support for SQLCODE. SQL Option maps a subset of SQLSTATE values from equivalent SQLCODE return values. SQLSTATE support is limited to applications running against an SQL Option Server in DB2 mode. If running against the SQL Option Link, support for the full range of SQLSTATE return codes is provided by DB2 directly. (Consult your DB2 documentation.) See the SQL Option Link User's Guide for a complete listing of SQLSTATE values supported by SQL Option, plus a table mapping error message return codes.

SQLSTATE values provide COBOL application programs with a standardized set of return codes corresponding to common SQL statement error conditions. SQLSTATE values are structured so that application programs can test for specific errors or classes of errors. In an application program, the SQLSTATE is a status parameter (similar to SQLCODE) that indicates either that an SQL statement completed successfully or that an exception condition was raised during execution. Unlike the SQLCODE (which is an integer parameter), the SQLSTATE is a character string parameter which for COBOL language applications is of data type COBOL PICTURE X(5).

SQLCODE The SQLCODE element in SQLCA contains a return code relating to the last SQL statement executed:
  • If an error occurred, the SQLCODE in the SQLCA will contain a negative number corresponding to the DB2. The equivalent SQL Option Server error code is returned in the SQLERRD (1) field. See Error Messages in your Reference Help for codes and meanings.
  • If SQLCODE is 0, the statement executed successfully but may have had warnings (as indicated in the SQLWARN fields).
  • A code of +100 indicates no more records.

The SQL Option DSNTIAR facility may be used to convert an SQL return code (from the SQLCODE field in SQLCA) to a character string. See the chapter DSNTIAR Facility for more information.

SQLERRD(3) | The SQLERRD (3) element in SQLCA holds the number of rows that were inserted, updated, or deleted by an SQL statement.
SQLERRML | The SQLERRML element in SQLCA is the length of SQLERRMC. If zero, the value of SQLERRMC is not pertinent. For more information, see the description for SQLERRMC.
SQLERRMC The SQLERRMC element in SQLCA holds a character string that describes an error condition. If there is an error, it will contain one or more tokens, separated by X'FF'.

The tokens are substituted for the variables in the descriptions of error messages (for example, the name of a file or table).

SQLWARN0 | The SQLWARN0 element in SQLCA is a warning flag that indicates if any other SQLWARNn field is signaling a potential problem. If SQLWARN0 is blank, then all other SQLWARNn fields are blank (no warnings exist). If SQLWARN0 contains a W, then at least one of the other SQLWARNn variables has a W. For information on the meanings of the other SQLWARNn fields, see the SQL Reference manual.
Parent topic: Creating and Embedding SQL in COBOL


SQL Descriptor Area (SQLDA)

COBOL programs that include dynamic SQL must have an SQL Descriptor Area (SQLDA) defined. This definition is usually accomplished by including the SQLDA copybook provided with your COBOL system.

The default SQLDA copybook used by the SQL Option preprocessor is not mainframe DB2 compatible. Instead it is designed for easy compatibility if you are upgrading from older version of XDB or SQL Option software.

A mainframe compatible SQLDA is provided in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source\xdb directory with filename of sqlda.cpy. If you want to use that copybook instead, just rename it. You then need to compile all programs that use this copybook or SQLDA's defined using the mainframe SQLDA structure with the SQL preprocessor directive SQLDA-VER=1 or the program will not map data properly and probably trap.

The SQLDA holds information about dynamic SQL queries, and is required for allocating the proper amount of space for the query.

For more information about dynamic SQL and the SQLDA, see the topic Using Dynamic SQL in COBOL. For a complete description of the SQLDA structure, see the SQL Reference. Refer to your preprocessor documentation on the use of pointer variables and for additional information on dynamic SQL in COBOL programs.

Parent topic: Creating and Embedding SQL in COBOL
Related information
Using Dynamic SQL in COBOL


Sample COBOL Program with Embedded SQL

The following program shows how SQL statements can be embedded in a COBOL program. Note that the copybook EMPREC has been included in the program using the INCLUDE statement.

This program declares a cursor, opens it, and then fetches data into a set of host variables. The host data is displayed. (Note the use of the indicator variable used with the commission variable COM.) When the end of data is reached, or when the user is finished viewing data, the loop is terminated, the cursor is closed, and the program ends.

 IDENTIFICATION DIVISION.

 PROGRAM-ID. TESTALL.
 AUTHOR-NAME. ME.

 ENVIRONMENT DIVISION.

 CONFIGURATION SECTION.
 SOURCE-COMPUTER. IBM-AT.
 OBJECT-COMPUTER. IBM-AT.

 INPUT-OUTPUT SECTION.
 FILE-CONTROL.

 DATA DIVISION.

 FILE SECTION.

 WORKING-STORAGE SECTION.

 EXEC SQL
   INCLUDE EMPREC
 END-EXEC.

 01 DISP-RATE PIC $$$,$$$,$$9.99.
 01 DISP-COM PIC Z.99.
 01 DISP-CODE PIC ----9.
 01 FAKE-CHAR PIC X.
 01 ANSS PIC X.
 01 COM-NULL-IND PIC S9(4) COMP.

 EXEC SQL
   INCLUDE SQLCA
 END-EXEC.

 PROCEDURE DIVISION.

 100-MAIN.
* declare cursor for select
     EXEC SQL
         DECLARE EMPTBL CURSOR FOR
         SELECT *
           FROM EMPLOYEE
         ORDER BY LNAME
     END-EXEC

* open cursor
     EXEC SQL
         OPEN EMPTBL
     END-EXEC
     MOVE SQLCODE TO DISP-CODE
     DISPLAY 'open ' DISP-CODE

* fetch a data item
     EXEC SQL
         FETCH EMPTBL INTO
           :ENO,:LNAME,:FNAME,:STREET,:CITY,
           :ST,:ZIP,:DEPT,:PAYRATE,
           :COM :COM-NULL-IND
     END-EXEC.

 100-test.
     MOVE SQLCODE TO DISP-CODE
     DISPLAY 'fetch ' DISP-CODE

* loop until no more data
     PERFORM UNTIL SQLCODE < 0 OR SQLCODE = 100

* display the record
     MOVE PAYRATE TO DISP-RATE
     MOVE COM TO DISP-COM
     DISPLAY 'department ' DEPT
     DISPLAY 'last name ' LNAME
     DISPLAY 'first name ' FNAME
     DISPLAY 'street ' STREET
     DISPLAY 'city ' CITY
     DISPLAY 'state ' ST
     DISPLAY 'zip code ' ZIP
     DISPLAY 'payrate ' DISP-RATE
     IF COM-NULL-IND < 0
         DISPLAY 'commission is null'
     ELSE
         DISPLAY 'commission ' DISP-COM
     END-IF
     DISPLAY 'Do you want to see the next record? (y/n)'
     ACCEPT ANSS
     IF ANSS = 'Y' OR 'y'
         EXEC SQL
           FETCH EMPTBL INTO
             :ENO,:LNAME,:FNAME,:STREET,:CITY,
             :ST,:ZIP,:DEPT,:PAYRATE,
             :COM :COM-NULL-IND
         END-EXEC
     ELSE
         GO TO CLOSE-LOOP
     END-IF
     MOVE SQLCODE TO DISP-CODE
     DISPLAY 'fetch ' DISP-CODE
     END-PERFORM

     DISPLAY 'All records in this table have been selected'.

 CLOSE-LOOP.
* close the cursor
     EXEC SQL
         CLOSE EMPTBL
     END-EXEC.

 100-EXIT.
     STOP RUN.
Parent topic: Creating and Embedding SQL in COBOL


Using Dynamic SQL in COBOL

Dynamic SQL refers to a special type of embedded SQL statement that is prepared and executed within an application program while the program is running. It differs from static embedded SQL in that part or all of the actual SQL commands may be stored in a host variable, whose value may change numerous times during execution of the program. In the extreme case, the SQL commands are generated in their entirety by the application program at run time.While dynamic SQL is more flexible than static embedded SQL, it does require additional overhead and more programming sophistication.

  • Overall Considerations
  • Non-Select SQL Statements
  • Fixed-List Select Statements
  • Varying-List Select Statements
Parent topic: SQL Option Preprocesor Guide


Overall Considerations

The varying-list SELECT requires use of the SQLDA and address functions (COBOL pointer variables). The other types of dynamic SQL may require those features under certain conditions.

The SQL Descriptor Area (SQLDA) is a data structure that holds information about the execution of dynamic SQL statements. See the SQL Reference for more information about including an SQLDA in your program. Also see your COBOL documentation for an explanation of the use of address functions.

Some SQL statements cannot be executed dynamically, usually because they are needed to enable dynamic SQL commands themselves. The SQL commands that cannot be executed dynamically are shown below.

  • BEGIN DECLARE SECTION
  • FETCH
  • CLOSE
  • INCLUDE
  • DECLARE
  • OPEN
  • DESCRIBE
  • PREPARE
  • END DECLARE SECTION
  • SELECT INTO
  • EXECUTE
  • SET host-variable
  • EXECUTE IMMEDIATE
  • WHENEVER
Parent topic: Using Dynamic SQL in COBOL


Non-Select SQL Statements

When non-SELECT statements are issued dynamically, the coding task is relatively easy because there is no need to dynamically allocate main storage.

To issue a non-SELECT statement dynamically:

  1. (Optional) Test each SQL statement using the SQLWizard to see that proper results are obtained.
  2. Load the SQL statement into a data area.
  3. Issue a PREPARE and then an EXECUTE (or EXECUTE IMMEDIATE) statement.

    Be sure to handle any errors that result.

The following example executes an UPDATE statement that gives every employee a 10 percent raise:

     MOVE 'update employee set payrate=payrate*1.10'
                                                TO SQLCMD
     EXEC SQL
         EXECUTE IMMEDIATE :sqlcmd
     END-EXEC
     ...
Parent topic: Using Dynamic SQL in COBOL


Fixed-List Select Statements

A fixed-list SELECT statement is a statement that returns a predictable number of data items of a known type from an open cursor. For each of these items, a host variable is required to accommodate incoming data.

To issue a fixed-list SELECT statement dynamically:

  1. (Optional) Test each SQL statement using the SQLWizard to see that proper results are obtained.
  2. Load the SQL statement into a data area.
  3. Use PREPARE to validate the statement and translate it into an executable form.
  4. Use DECLARE to declare a cursor for the statement.
  5. Use OPEN to open the cursor.
  6. Use FETCH to retrieve a row into a fixed list of variables.
  7. When the end of data is reached, use CLOSE to close the cursor.

    Be sure to handle any errors.

The following example shows how to execute a fixed-list SELECT statement dynamically.

* include SQLDA copybook
     EXEC SQL
         INCLUDE SQLDA
     END-EXEC

* assign value to variable sqlcmd.
     MOVE 'select e_no, ' &
          'lname from employee where dept="1050"' TO sqlcmd

* prepare SELECT command.
     EXEC SQL
         PREPARE q1 FROM :sqlcmd
     END-EXEC

* declare cursor for SELECT command.
     EXEC SQL
         DECLARE c1 CURSOR FOR q1
     END-EXEC

* open cursor.
     EXEC SQL
         OPEN c1
     END-EXEC

* fetch data into program variables EMPNO, LASTNME and
* FIRSTNME.
     EXEC SQL
         FETCH c1 INTO :EMPNO, :LASTNME
     END-EXEC

* close cursor.
     EXEC SQL
         CLOSE c1
     END-EXEC
Parent topic: Using Dynamic SQL in COBOL


Varying-List Select Statements

A varying-list SELECT statement is one that retrieves data items of varying number and format. Because the number and type of data items are not known, you cannot define host variables in advance.

However, by including the SQLDA in your program, you can use PREPARE to define a SELECT statement and follow it with a DESCRIBE statement. This process inserts the data item information into the SQLDA, which your program can use to execute a SELECT statement. Likewise, record fetches are performed using the SQLDA.

To issue a varying-list SELECT statement:

  1. Include the SQLDA copybook in your program.
  2. Use PREPARE to define a statement (either already in a statement buffer or to be read) so that it may be translated to executable form.
  3. Use DESCRIBE for the prepared statement to determine how many columns will be retrieved and their data types. You may use a PREPARE INTO to PREPARE and DESCRIBE in a single statement.
  4. If the SQLDA is not large enough to contain column descriptions for each column, your program must determine how much space is needed, obtain that storage space, build a new SQLDA, and DESCRIBE again.
  5. The program must now determine how much space is needed for the data in each column (and possibly an indicator variable). Storage must be obtained so that when a value is fetched, your program will know where to put the data. Acquiring this storage is accomplished by analyzing the SQLDA. For more information on the SQLDA, see the SQL Option SQL Reference.
  6. Execute the SELECT statement by declaring and opening a cursor for the prepared statement.
  7. Fetch a row of data by specifying USING DESCRIPTOR SQLDA on the FETCH statement.
  8. When end of data is reached, close the cursor.

The following program excerpt shows how to execute a varying-list SELECT statement dynamically.

* include SQLDA copybook.
     EXEC SQL
         INCLUDE SQLDA
     END-EXEC

* assign value to variable sqlcmd.
     MOVE 'select * from employee where dept="1050"'
                                                   TO sqlcmd

* prepare SELECT command.
     EXEC SQL
         PREPARE q1 FROM :sqlcmd
     END-EXEC

* allocate space for an SQLDA ...
     MOVE 20 TO SQLN

* describe SELECT command.
     EXEC SQL
         DESCRIBE q1 INTO SQLDA
     END-EXEC

* make sure SQLDA is big enough.
     IF (SQLN <= SQLD)
            PERFORM ...
             ...
             MOVE SQLD TO SQLN.
             EXEC SQL
                 DESCRIBE q1 INTO SQLDA
             END-EXEC
         END-PERFORM
     END-IF

* analyze results of DESCRIBE.
...
* allocate storage to hold one row of the result. ...
* declare cursor for SELECT command.
     EXEC SQL
         DECLARE c1 CURSOR FOR q1
     END-EXEC

* open cursor.
     EXEC SQL
         OPEN c1
     END-EXEC

* fetch data into program variables EMPNO, LASTNME and
* FIRSTNME.
     EXEC SQL
         FETCH c1 USING DESCRIPTOR SQLDA
     END-EXEC

* display results fetching next record as long as there
* is one.
     PERFORM UNTIL SQLCODE <> 0
         DISPLAY ...
         EXEC SQL
             FETCH c1 USING DESCRIPTOR SQLDA
         END-EXEC
     END-PERFORM
     DISPLAY 'END OF LIST'.

* close cursor.
     EXEC SQL
         CLOSE c1
     END-EXEC
Parent topic: Using Dynamic SQL in COBOL


Static Binding

  • Overview
  • Creating a DBRM
  • Binding a DBRM
  • Autobinding
  • Specifying Options with AUTOBIND
  • Binding SQL Statements With Literals
  • Using AUTHID to Change Table Qualifier
  • Examples of DBRM Directives
  • Examples of Autobinding Multiple DBRM's
Parent topic: SQL Option Preprocesor Guide


Overview

SQL Option, by default, uses dynamic SQL. However, depending on your application the use of static SQL can have a significant impact on performance. Most applications will run faster when executing static as opposed to dynamic SQL. Also, default qualifiers can be specified during the bind to allow a program to use a particular AUTHID to qualify one part table names when the user does not have authority to execute a SET CURRENT SQLID command. Many sites are reluctant to use SET CURRENT SQLID since it may require SYSADM authority to execute.

Parent topic: Static Binding


Creating a DBRM

To have your program use static SQL, you must create a DBRM (database request module) and bind it to the SQL Option server you are going to run against. To create a DBRM, you need to compile your program with at least the following SQL Option preprocessor directives:

  • DBRM=dbrm-name
  • COLLECTION-ID=collection-id
Parent topic: Static Binding


Binding a DBRM

You must bind the DBRM using the BIND utility provided with SQL Option. After you have bound the DBRM your application will be running static SQL. If you change any SQL statements in the program you will need to rebuild and rebind your DBRM. For details on how to BIND the DBRM, see the BIND Guide.

Parent topic: Static Binding


Autobinding

If you have too many programs to bind using the BIND utility or just don't want to have to manually bind each program, you can compile each program with the SQL Option preprocessor directive called AUTOBIND. When this directive is specified the preprocessor will call BIND for you and will automatically bind the DBRM at the end of the compile.

XDB now supports writing out multiple DBRM's for a single program and you can automatically bind up to 10 DBRM's. The directives that support multiple options are DBRM, COLLECTION-ID, AUTHID, and LOCATION. You must also specify AUTOBIND for this to work properly.

Parent topic: Static Binding
Related information
Preprocessor Directives and Options


Specifying Options with AUTOBIND

The Bind Guide specifies many bind options. New directives have been added so you can set these options using the AUTOBIND directive. These directives are optional - you do not need to specify them if you want to use default values (recommended in most cases). These additional directives are:

  • EXIST-CHECK
  • GRANT-EXECUTE
  • DEFAULT-CHAR
  • BLOCKING

If any errors occur during the automated bind process, no DBRM will be generated. However in its place will be a log file with name dbrm-name.log The log file will record all errors reported during the bind process. Consult your error documentation to resolve the error.

Parent topic: Static Binding
Related information
Preprocessor Directives and Options


Binding SQL Statements With Literals

If you have literals in your SQL statements, you need to make sure that the quote character matches your build settings or you could have problems binding the DBRM.

The SQL Option preprocessor defaults to the compiler setting for literals in the build settings. If you use the same character to enclose literals in your SQL statements as you did for COBOL literals, you don't have to do anything. If you use a different character for literals in SQL statements, then you have to use the preprocessor directive of either QUOTE or APOST.

Parent topic: Static Binding
Related information
Preprocessor Directives and Options


Using AUTHID to Change Table Qualifier

If you have two identical sets of tables, for example YYYYYYYY.table1 and XXXXXXXX.table1 and want to test against both sets of tables, you can use the AUTHID preprocessor directive to switch which qualifier is used.

For example, if you set it to:

XDB(AUTHID=XXXXXXXX)

XXXXXXXX becomes the default qualifier. To run against both sets of data all you need to do is change the value of the AUTHID directive to YYYYYYYY and recompile. The next time you run your application you will be pointing to YYYYYYY.table1.

Parent topic: Static Binding


Examples of DBRM Directives

The following are examples of various DBRM directives used together:

XDB(dbrm=mydbrm location=mvsprod grant-execute=public
    collection-id=nasecoll)
XDB(collection-id=nasecoll authid=naseprod autobind
    exist-check=required)

Directives can be entered on multiple lines or as one long string. Each string must start with "XDB", unless entered on the IDE/Build Settings/EXEC SQL/Preproc Additional directives entry field.

Parent topic: Static Binding


Examples of Autobinding Multiple DBRM's

The following are examples of how to autobind a program and generate multiple DBRM's:

XDB(dbrm=mydbrm1;mydbrm2 location=mvsprod;mvstest
    grant-execute=public collection-id=nasecoll;dbnats
    autobind)
XDB(collection-id=nasecoll authid=naseprod;nasetest
    autobind dbrm=testdbrm1;testdbrm2 exist-check=required )

When multiple directives are specified, they must be delimited by a semi-colon with no spaces in between. Commas and blanks are option delimiters and may cause the directive string to not be processed correctly.

Parent topic: Static Binding
Related information
Preprocessor Directives and Options


Security

SQL Option security measures control access to the system and protect data stored in table objects. If the security option is turned on at both the server and on the client, you will be prompted for a user ID and password when you compile using the VALIDATE preprocessor directive or execute a program containing embedded SQL.

  • Using the Logon and Logoff Commands
  • Validating Tables
Parent topic: SQL Option Preprocesor Guide


Using the Logon and Logoff Commands

Use the SQL Option Logon and Logoff commands to avoid repeatedly logging into an XDB Server or SQL Option Link during the compile and test phase of development.

To log on to the SQL Option Server once per session, follow these steps:

From the Tools menu, select SQL Option

Select Logon

Enter your user ID and password

The SQL Option Server will automatically reuse your user ID and password each time you compile or execute the program, until you select Logoff or restart your system.

Parent topic: Security


Validating Tables

The following describes how to set up your environment to validate tables during the compile process:

  • With Security Off, the user ID will be the same authorization ID defined as the primary ID unless you define a secondary ID.
  • With Security On, the user ID will be the same ID that you enter in the logon screen and optionally the secondary ID if defined (not applicable to SQL Option Link).

To access tables with the same user ID and authorization ID, use the VALIDATE preprocessor directive. To access tables with different user ID and authorization ID, do one of the following:

  • Use VALIDATE and AUTHID preprocessor directives.
  • Define group IDs or issue a GRANT to the user ID to have access to the authorization ID defined in the AUTHID preprocessor directive.
  • Define secondary IDs.
Parent topic: Security


DSNTIAR Facility

The SQL Option DSNTIAR facility, or DSNTIAC for CICS programs, converts an SQL return code into a character string error message (similar to the IBM DSNTIAR and DSNTIAC facility on the mainframe). It takes an SQL return code from the SQLCODE element of comm-area (usually, SQLCA), and converts it to a descriptive character string. The resulting string is placed in the output area error-message, which is an array. The first element of error-message indicates the length of the message to follow. The second element is the actual message, which is usually defined as a string of the logical record length, error-rec-length, occurring n times. If at run time, the length of the message to be output is larger than one logical record (error-rec-length), and the message is treated as a set of fixed length records of length error-rec-length. The message is word wrapped and indented based on the logical record length. Every logical record begins with a space for carriage control.

  • Calling DSNTIAR or DSNTIAC
  • Example
Parent topic: SQL Option Preprocesor Guide
Related information
Calling DSNTIAR or DSNTIAC


Calling DSNTIAR or DSNTIAC

The format for calling DSNTIAR from a COBOL program is:

CALL 'DSNTIAR' USING comm-area
                     error-message
                     error-rec-length

The format for calling DSNTIAC from a CICS COBOL program is:

CALL 'DSNTIAC' USING comm-area
                     error-message
                     error-rec-length

where:

comm-area | The communications area to be used, generally set to SQLCA. The SQLCODE element of this area should contain the error code for which DSNTIAR will generate a message.
error-message | An array of records of size error-rec-length used to store error message output. The two components of the error-message array are:
error-length | containing an integer indicating the length of the second element, error-text. error-length >= 240.
error-text | which is the actual message. Generally this message is defined as an array of strings, each having a length of error-rec-length, and occurring n times so that error-length is the larger of 240 and error-rec-length * n.
Code | Description
Error-rec-length | A n integer indicating the logical record length of output messages. 72 <= error-rec-length <= 240. If the message is longer than error-rec-length, several logical records will be used to store it.
0 | Successful execution.
4 | More data was available than could fit into the provided message area.
8 | The error-rec-length was not within acceptable limits. (72 <= error-rec-length <= 240)
12 | The message area was not large enough. Message length was >= 240.
16 | Error in message routine.

The following table shows the return codes that result from calling the DSNTIAR or DSNTIAC utility.

Code | Description
0 | Successful execution.
4 | More data was available than could fit into the provided message area.
8 | The error-rec-length was not within acceptable limits. (72 <= error-rec-length <= 240)
12 | The message area was not large enough. Message length was >= 240.
16 | Error in message routine.
Parent topic: DSNTIAR Facility


Example

 01 ERROR-MESSAGE.
     02 ERROR-LENGTH PIC S9(4) COMP VALUE +288.
     02 ERROR-TEXT PIC X(72) OCCURS 4 TIMES.
 77 ERROR-REC-LENGTH PIC S9(9) COMP VALUE +72.
    ...
     CALL 'DSNTIAR' USING SQLCA ERROR-MESSAGE ERROR-REC-LENGTH
Parent topic: DSNTIAR Facility


Preprocessor Directives and Options

The SQL Option Preprocessor uses a type of preprocessor interface called an External Compiler Module (ECM) interface which is tightly integrated with the Compiler and debugger. The ECM only gets passed statements that begin with EXEC SQL.

  • XDB Compiler Directive
  • Setting Additional Options Under the IDE
  • SQL Option Preprocessor Options
Parent topic: SQL Option Preprocesor Guide


XDB Compiler Directive

You can specify the XDB directive anywhere where you can specify any other compiler directive, that is:

  • In a $SET statement. For example:
    $set xdb(autobind collection-id=myschema)
  • On the cob command line. For example:
    cob -Vt testconn.cbl -C"anim xdb(autobind collection==myschema)"
  • In a cobol.dir file.
Parent topic: Preprocessor Directives and Options


Setting Additional Options Under the IDE

When you create a new project or add a new program to an existing project, a scan is done to determine if EXEC SQL statements are in the program. If they are, the XDB directive is automatically set for that program. You can set additional SQL Option preprocessor options by selecting Build Settings for that program and selecting the Preproc tab and clicking on the EXEC SQL More... button. Once all the preprocessor options have been set, just select "Compile" to compile a program.

Parent topic: Preprocessor Directives and Options


SQL Option Preprocessor Options

This SQL Option Preprocessor uses the XDB compiler directive, which is used with several options. Certain of these options, such as DB2, are automatically set to a default value. Most XDB directive options have an alternate (or negative) syntax whereby the condition established by the option can be turned off. The default syntax for each option is underlined. XDB directive options are not case sensitive. For a complete list of options for the XDB compiler directive, see the topic XDB Directive Options.

For a list of SQL Option preprocessor error messages, see the topic SQL Preprocessor Errors

Parent topic: Preprocessor Directives and Options
Related information
XDB Directive Options
SQL Preprocessor Errors


How to...

  • To access SQL Option for DB2
  • To add a Data Source Name (DSN) for the ODBC driver for SQL Option
  • To install and uninstall the ODBC driver for SQL Option
  • To log on to an XDB Server
  • To log off an XDB Server
  • Bind Utility
  • Declaration Generator
  • Link Configuration
  • Link Utility
  • Migrate Utility
  • Options Utility
  • SQL Wizard
  • SQL Option Server Administration
Parent topic: SQL Option for DB2


To access SQL Option for DB2

Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 and select a tool available from the submenus.

Parent topic: How to...


To add a Data Source Name (DSN) for the ODBC driver for SQL Option

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> ODBC Connection Tools > ODBC Data Source Administrator.
  2. On the System DSN tab, click Add.
  3. Select Micro Focus XDB for Studio 6.0, from the list of ODBC drivers.
  4. Click Finish.
  5. Configure the DSN by filling in the following fields:
    • Data Source Name - Any name you choose.
    • XDB Path – Accept the default of %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\mfsql\cfg.
    • Connection – Choose between local and remote. If you choose remote, specify the IpAddress and TcpPort of your XDB server.
    • Server – The name of your XDB Server.
    • Location – The XDB location you want to use.
    • User ID – The XDB userid to use when connecting with this data source.
    • Current SQLID – The authorization ID to use when connecting with this data source (optional). If you don't specify an SQLID, the UserID is used.
  6. Click OK to close the ODBC Driver Setup window.
  7. Click OK to close the ODBC Data Source Administrator.
Parent topic: How to...
Related information
To install and uninstall the ODBC driver for SQL Option


To install and uninstall the ODBC driver for SQL Option

  1. To install the ODBC driver:
    1. At aNet Express command prompt, enter:

      xdbodbcinst -i -p product-identifier

      Where product-identifier is one of the following:
      • MFE3.1
      • NETX5.1
      • NETX6.0
      • DX4.0
      Note: The NETX6.0 driver is installed by default when you install Studio Enterprise Edition.
    2. Create and configure Data Source Names (DSNs) for the driver.
  2. To uninstall the ODBC driver, enter the following at aNet Express command prompt:

    xdbodbcinst -u -p product-identifier.

Parent topic: How to...
Related information
To add a Data Source Name (DSN) for the ODBC driver for SQL Option


To log on to an XDB Server

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 > Client > Log On.
  2. Enter your user name (AuthID) and password.
  3. Click OK.
Note:

You need only log on to an XDB Server if server security is enabled. To access an XDB Server that has security enabled, you must enable client security before you try to log on.

Parent topic: How to...
Related information
To log off an XDB Server


To log off an XDB Server

  • Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> SQL Option for DB2 > Client > Log Off.

Parent topic: How to...
Related information
To log on to an XDB Server


Bind Utility

  • To bind an application to a DB2 database
  • To create a default DBRM and package in DB2 for XDB Link
  • To modify an existing package
  • To rebind
  • To drop a package from DB2
  • To bind a DBRM to DB2 from the command line
  • To create a bind transaction file
Parent topic: How to...


To bind an application to a DB2 database

  1. Build your application.
  2. Ensure that client security for SQL Option is enabled.
  3. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> SQL Option for DB2 > Configuration > Bind Utility.
  4. Select the location of the DB2 database from the Remote Location list.
  5. Type your current SQLID in SQLID.
  6. Click Bind.
  7. Make the selections you require on the Bind Package dialog box.
  8. Click OK.
Note:

You need only bind an application when you are executing static SQL against a remote DB2 location accessed using DRDA. The database must be configured in system tables on the gateway XDB Server. Contact your system administrator if you experience difficulty in locating or binding to a DB2 database.

Parent topic: Bind Utility
Related information
To enable client security


To create a default DBRM and package in DB2 for XDB Link

Before you can use XDB Link, you must create a default DBRM for the link, and bind it to DB2. The default DBRM creates a package that XDB Link uses to execute dynamic SQL statements from your application, and to execute statically-bound SQL statements contained in the XDB Link program itself.

Follow these directions only once for each DB2 location with which you will use the XDB Link. See the Link Configuration Guide for more information.

Note:

Do not use the same default package in DB2 for more than one user group or application. To support multiple user groups or applications, you must generate a separate default DBRM and package for each on. After the first application or group uses the Gateway Profile Utility's default values, the development team must agree on the package name and collection ID with which to identify the remaining default packages. See the Link Configuration Guide for more information.

  1. In the Bind Utility window, from the Remote Location drop-down list, select the desired DB2 location.
  2. Click Default. The Create Default DBRM dialog box appears.
  3. Specify the Collection ID, Package Name, Host System, and number of Dynamic Sections.
  4. Click Create. Bind generates a default DBRM that you will use to create a package for the Link. The DBRM is stored locally in your default working directory as a .DBR file.
    Note:

    The DBRM for XDB Link contains three packages. The name of these packages are derived by combining the XDB Link package name with the letters A, B and C. For example, if your package name is XDBSYS, packages XDBSYSA, XDBSYSB and XDBSYSC are created.

  5. In the Bind Utility main window, click Bind. The Bind Package dialog box appears.
  6. In the Bind Package dialog box, select the name of the DBRM file you just created from the DBRM File Name drop-down list.
  7. If desired, set the Package Version, Isolation Level, and Action.
  8. If desired, click the Bind... button to configure additional bind options.
  9. If desired, click the Format... button to specify data formats associated with the DBRM.
  10. Click Execute. Bind creates a package in the selected DB2 location and updates the relevant DB2 tables. The Status bar indicates when the procedure is complete.
Note:
  • The Bind Utility automatically grants execute privileges to all users. Use the SQLWizard to revoke GRANT EXECUTE privileges where necessary.
  • Each time you bind a DBRM, the Bind Utility creates a log file (.LOG) in which it records all errors that occur during the bind. The .LOG file is stored in locally in the same directory as your DBRM (.LOG).

    If no error has occurred during the binding of a particular DBRM, the log file does not exist.

Parent topic: Bind Utility


To modify an existing package

When you generate a DBRM in the Static Bind Administrator, it automatically binds the DBRM, using default bind options, to create the package in DB2.

Follow this procedure if you would like to modify the package by binding the DBRM again with different parameters.

  1. In the Bind Utility window, from the Remote Location drop-down list, select the DB2 location of your application's package.
  2. Click Bind. The Bind Package dialog box appears.
  3. Select the DBRM you want to bind from the DBRM File Name drop-down list.
  4. If desired, set the Package Version, Isolation Level, and Action.
  5. If desired, click the Bind... button to configure additional bind options.
  6. If desired, click the Format... button to specify data formats associated with the DBRM.
  7. Click Execute. Bind creates a package in the selected DB2 location and updates the appropriate DB2 system tables. The Status bar indicates when the procedure is complete.
Note:

Each time you bind a DBRM, the Bind Utility creates a log file (.LOG) in which it records all errors that occur during the bind. The .LOG file is stored in locally in the same directory as your DBRM (.DBR).

If no error has occurred during the binding of a particular DBRM, the .LOG file does not exist.

Parent topic: Bind Utility


To rebind

The Rebind procedure does not read the DBRM. Rather, it recalculates path optimizations for the DBRM information in the existing package.

If you want bind to read the DBRM, see To Modify an Existing Package.

  1. In the Bind Utility window, from the Remote Location drop-down list, select the host location of the package you want to rebind.
  2. Click Rebind. The Rebind Package dialog box appears.
  3. Select the package you want to rebind from the Package drop-down list.
  4. If desired, specify a Package Version and the Isolation Level.
  5. If desired, click Bind under Modify Options to set other rebind options.
  6. Click Execute. The Bind Utility rebinds the package using the options you specified.
Parent topic: Bind Utility


To drop a package from DB2

  1. In the Bind Utility window, from the Remote Location drop-down list, select the host location of the package you want to drop.
  2. Click Drop. The Drop Package dialog box appears.
  3. From the Package drop-down list, select the package you want to remove from the host
  4. Click Execute to drop the package.
Note:

When you drop a package, it is deleted immediately, without confirmation.

Parent topic: Bind Utility


To bind a DBRM to DB2 from the command line

Use the command line if you:

  • Need to run a bind unattended (from a scheduler, for example)
  • Run a particular bind routinely
  • Wish to bind multiple programs in a single operation

Enter the following at your system command line:

BIND40N /d dbr-file /l location [option option option ...]

or

BIND40N /f transaction-file [option option option ...]

where:

dbr-file
The name of the DBRM you want to bind. If you do not specify a path, your DBRM must be in the current directory or in the XDB application path (as specified by Options). If you do not specify an extension, your DBRM must have a .DBR extension.
location
The name of the location to which the DBRM will be bound. (This is the name of the DB2 subsystem as it is registered with XDB Link.)
transaction-file
The name of the bind transaction file (.BND). Be sure to include a space between /f and the filename.
/c stop-status
stop-status can take one of the following values:
N
causes the bind to stop if an error occurs. This is the default.
Y
causes the bind to continue when an error occurs.
/s sqlID
sqlID is the ID used to set the current SQL ID at the time the package is bound.
/name=userID
userID is the user ID that will be used when the Bind Utility logs on the XDB Server.

If the /name option is not specified, you will be prompted for a user ID when the Bind Utility begins to execute.

/pass=password
password is the password that will be used when the Bind Utility logs on the XDB Server.

If the /pass option is not specified, you will be prompted for a password when the Bind Utility begins to execute.

/l location
location is the name of the remote location to which the DBRM will be bound. (This is the name of the DB2 subsystem as it is registered on the XDB Link.)
/existencechecking check-status
check-status can take one of the following values:
optional
creates a package even if the required database objects do not exist. This is the default.
required
creates a package only if the objects exist.
/grantexecute priviliges
priviliges can take one of the following values:
public
grants execute privileges to public. This is the default.
authid
grants execute privileges to authid.
/blocking block-mode
block-mode can take one of the following values:
FSR
Forced Single Row does not use block fetching regardless of cursor type.
SR
Single Row uses block fetching for read-only cursors and fetches a row at a time for ambiguous cursors.
LB
Limited Block uses block fetching for read-only and ambiguous cursors. This is the default.
/defaultchar subtype
subtype can take one of the following values:
BITS
specifies that the target relational database uses the FOR BITS DATA SQL character subtype for all new character columns for which an explicit subtype is not specified.
SBCS
specifies that the target relational database uses the FOR SBCS DATA SQL character subtype for all new character columns for which an explicit subtype is not specified.
DBCS
specifies that the target relational database uses the FOR MIXED DATA SQL character subtype for all new character columns for which an explicit subtype is not specified.
SYSDEFAULT
specifies that the target relational database uses the system default character subtype for all new character columns for which an explicit subtype is not specified. This is the default (and recommended) setting.
/d dbr-file
dbr-file is the name of the DBRM you want to bind. If you do not specify a path, the file must be in the current directory or in the XDB application path (as specified by Options). If you do not specify an extension, your DBRM must have a .DBR extension.
Note:

If you are running a bind unattended, be sure to include the /name and /pass options.

Parent topic: Bind Utility


To create a bind transaction file

To run the Bind Utility in batch mode from the command line, you must create a .BND file that contains at least one transaction. A transaction is a statement that specifies the name of a DBRM file and the location to which it will be bound. A .BND file is an ASCII text file. It can contain multiple bind transactions.

Use any ASCII text editor and type each transaction using the following format. Be sure to include a semicolon at the end of each transaction.

/d dbr-file /l location [/s sqlID];

where:

dbr-file | is the name of the DBRM you want to bind. If you do not specify a path, the file must be in the current directory or in the XDB application path (as specified by Options).
location | is the name of the location to which the DBRM will be bound. (This is the name of the DB2 subsystem as it is registered on the XDB Link.)
sqlID | is the ID to which the current SQL ID will be set when the package is bound. If SqlID is not specified, the current SqlID assignment is used (the assignment specified on the XDBBIND command line or assigned to an earlier transaction in the .BND file, whichever is more recent). Otherwise, AuthID is used.
Parent topic: Bind Utility


Declaration Generator

  • To generate a copybook for a table
  • To run interactively
  • Creating a COBOL Copybook File
  • To create a C header file
  • Creating a PL/I Include File
  • Running From the Command Line
  • Running in Batch Mode
  • Creating a .DGE File
  • Running a .DGE File
Parent topic: How to...


To generate a copybook for a table

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> SQL Option for DB2 > Client > Declaration Generator.
  2. On the XDB Declaration Generator window, specify the table you require in the Table group.
  3. In the Declaration group, type a location and name for the copybook in the Output File field.
  4. Optionally, in the Structure Name field, type a name for the group data item to be created.
  5. Optionally, click Options to specify a level for the group data item to be created.
  6. In the Field Prefix group, type a prefix to be added to the column names in the table to create host variables. For example, you might use EMP as the column name prefix for a table called EMPLOYEES.
  7. Select Text if you want the column name to be appended to the specified prefix to create the host variable name.

    Alternatively, select Numbered if you want the column's numeric position in the table to be appended to the specified prefix to create the host variable name.

  8. In the Computation group, click the data format you require for the host variables.
  9. Click Generate.

A copybook containing host variables for accessing the specified table is created.

Tip:

Click Save As to save the settings you made on the Declaration Generator window. You can use the .DGE file that is produced to run the Declaration Generator in batch mode. For more information, see Running in Batch Mode in the Declaration Generator help.

Parent topic: Declaration Generator


To run interactively

To generate a declaration file in interactive mode (through a dialog box), start the Declaration Generator as described below. To specify the procedure from the command line, see Running From the Command Line.

To use the Declaration Generator utility:

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 > Client > Declaration Generator.
  2. Provide your AUTHID and desired LOCATION if the Connect dialog box is displayed.

    You must have SELECT privileges on the table for which you are generating a declaration and on the following system tables:

    • SysIBM.SYSLOCATIONS
    • SysIBM.SYSTABLES
    • SysXDB.SYSACFUsers
  3. In the Declaration Generator dialog box, select the language in which you want the declaration file written, and complete the remainder of the dialog box, then click GENERATE.
Parent topic: Declaration Generator
Related information
Running From the Command Line
Creating a COBOL Copybook File


Creating a COBOL Copybook File

In COBOL, a copybook file is used to define data elements that can be referenced by many programs. When the Declaration Generator creates a declaration for a COBOL program, it writes it to a copybook file (.cpy file).

To create a COBOL copybook, start the Declaration Generator utility, then follow the steps below:

  1. In the Language group box, click the COBOL button.
  2. In the Table group box, select the Location, AuthID and Table Name that identifies the table for which you want to create a copybook.
  3. If you want to change the name of the file to which the copybook is written, type a new name in the Output File field (the Declaration Generator automatically places a default name based on the table name in this field).

    If you don't specify a path, the copybook is written to the first directory specified in the COBCPY environment variable. If this variable isn't found, the copybook is written to the current application path (the application path is specified in the PATHS tab in Options).

    If you specify a file that already exists, you are given the choice of appending to it or overwriting it at run time.

  4. If you want to change the name of the record description, type a new name in the Structure field.
  5. If you want to add a prefix to each of the elementary item names, type it in the Field Prefix box. You can end the prefix with a special character such as a dash (-) to set it off from the rest of the name. For example, if a prefix of EMP- were specified, field names would be written as follows:
    EMP-lname PIC X(15)
        EMP-fname PIC X(10)
        EMP-dept PIC X(12)
        .
        .
        .

    Remember the COBOL variable-naming guidelines when assigning a prefix. Do not assign one containing characters that are disallowed by the compiler or one that might make the elementary item name too long.

  6. When you specify a prefix, you can optionally check the Numbered option to assign numbers instead of field names to the elementary items. If Numbered were checked using the EMP- prefix in last example, the declaration would be written as follows:
    EMP-001 PIC X(15)
        EMP-002 PIC X(10)
        EMP-003 PIC X(12)
        .
        .
        .
  7. In the Computation box, select the COMP type that you want use for the table's Int and Smallint fields.
  8. Click Options and set the following options as needed:
    For this option... | Specify...
    Level | The level number you want assigned to the record description. If you leave this field blank, Level 1 is assigned.
    Graphic Type | The PIC type you want to use for graphic, vargraphic and long vargraphic fields in the table.
    Page Size | The page size you want assigned to long varchar, long vargraphic, and long varbinary fields.
  9. Click OK to close the Declare Options dialog.
  10. If you want to save your specifications, click the Save As button, specify a file name and click OK. The specifications will be saved to a .DGE file, which can be used as input to the Declaration Generator's batch mode. See Running in Batch Mode for more information about .DGE files and batch mode.
  11. Click the Generate button to generate the COBOL copybook file.
Parent topic: Declaration Generator


To create a C header file

In C, a header file declares constants, functions and structures. The header file can be referenced (using the #include statement) by many programs. When the Declaration Generator creates a declaration for a C program, it writes the declaration to a header file (.h file). It also generates a corresponding array of short data types to hold the null-indicator variable for each column in the table.

To create a C header file, start the Declaration Generator utility, then follow the steps below:

  1. In the Language group box, click the C button.
  2. In the Table group box, select the Location, AuthID and Table that identifies the table for which you want to create a header file.
  3. If you want to change the name of the file to which the header file is written, type a new name in the Output File field (the Declaration Generator automatically places a default name based on the table name in this field).

    If you don't specify a path, the header file is written to the directory specified by the current application path (the application path is specified in the PATHS tab in Options).

    If you specify a file that already exists, you are given the choice of appending to it or overwriting it at run time.

  4. If you want to change the name of the structure, type a new name in the Structure field.
  5. If you want to add a prefix to each element name, type it in the Field Prefix box. You can end the prefix with a special character such as an underscore (_) to set it off from the rest of the name. For example, if a prefix of emp_ were specified, element names would be written as follows:
    char emp_lname[15];
        char emp_fname[10];
        char emp_dept[12];
        .
        .
        .

    Remember to take into account C variable-naming guidelines when assigning a prefix. Do not assign one containing characters that are disallowed by the compiler or one that might make the variable name too long.

  6. If you want to assign numbers instead of field names as element names, check the Numbered option. (This option can be selected only when a field prefix is used. See the previous step.) If the Numbered option were checked in the example above, the declaration would be written as follows:
    char emp_001[15];
        char emp_002[10];
        char emp_003[12];
        .
        .
        .
  7. Click the Options button.
  8. In the C Declaration Options dialog box, specify the way in which you want the structure written.
    • Use the options in the Structure Elements box to specify the case in which you want the element names written.
    • Use the Declare The Structure option to assign a variable name to the structure as shown in the following example. The variable name is derived from the Structure field specified in step 4).
      .
        .
        .
        double emp_payrate;
        double emp_com;
        } dcl_employee;

    If you don't set Declare The Structure, the structure is written as a data-type definition. The name specified in the Structure field is assigned as the name of the data type, as shown in the following:

    struct dcl_employee
        {
        short emp_ssn;
        char emp_lname[11];
        char emp_fname[11];
        .
        .
        .
  9. If you want to save your specifications, click the Save As button, specify a file name and click OK. The specifications will be saved to a .DGE file, which can be used as input to the Declaration Generator batch mode. See Running in Batch Mode for more information about .DGE files and batch mode.
  10. Click the Generate button to generate the C header file.
Parent topic: Declaration Generator
Related information
Running in Batch Mode
Example C Structure


Creating a PL/I Include File

In PL/I, an include (.inc) file declares constants, functions and structures. The include file can be referenced (using the %include statement or by EXEC SQL include ) by many programs. When the Declaration Generator creates a declaration for a PL/I program, it writes the declaration to a include file. If you choose, it also generates a corresponding array of null-indicator variables for each column in the table.

To create a PL/I include file, start the Declaration Generator utility, then follow the steps below:

  1. In the Language group box, click the PL/I button.
  2. In the Table group box, select the Location, AuthID and Table that identifies the table for which you want to create a header file.
  3. If you want to change the name of the file to which the include file is written, type a new name in the Output File field. (The Declaration Generator automatically places a default name based on the table name in this field.)

    If you don't specify a path, the include file is written to the first directory specified in the COBCPY environment variable. If this variable isn't found, the include file is written to the current application path (the application path is specified in the PATHS tab in Options).

    If you specify a file that already exists, you are given the choice of appending to it or overwriting it at run time.

  4. If you want to change the name of the structure, type a new name in the Structure field.
  5. If you want to add a prefix to each element name, type it in the Field Prefix box. You can end the prefix with a special character such as an underscore (_) to set it off from the rest of the name. For example, if a prefix of emp_ were specified, element names would be written as follows:
    DECLARE
        1 DCLEMPLOYEE,
        5 EMP_E_NO BIN FIXED(15),
        5 EMP_LNAME CHAR(10),
        5 EMP_FNAME CHAR(10),
        .

    Remember to take into account PL/I variable-naming guidelines when assigning a prefix. Do not assign one containing characters that are disallowed by the compiler or one that might make the variable name too long.

  6. If you want to assign numbers instead of field names as element names, check the Numbered option. (This option can be selected only when a field prefix is used. See the previous step.) If the Numbered option were checked in the example above, the declaration would be written as follows:
    DECLARE
        1 DCLEMPLOYEE,
        5 EMP_001 BIN FIXED(15),
        5 EMP_002 CHAR(10),
        5 EMP_003 CHAR(10),
  7. Click the Options button.
  8. In the PL/I Declaration Options dialog box, specify this option if you want the Declaration Generator to generate an array of indicator variables.
  9. If you want to save your specifications, click the Save As button, specify a file name and click OK. The specifications will be saved to a .DGE file, which can be used as input to the Declaration Generator batch mode. See Running in Batch Mode for more information about .DGE files and batch mode.
  10. Click the Generate button to generate the PL/I include file.
Parent topic: Declaration Generator


Running From the Command Line

You can create your declaration file without opening the Declaration Generator window. This is done by running the Declaration Generator and specifying its options from your Net Express command prompt.

To run the Declaration Generator from the Net Express command prompt, you call the dclg40n program using the following syntax:

dclg40n -tTableName [option1 option2 option3...]

where TableName specifies the name of the table for which a declaration file will be generated. Location and AuthID can be specified using location.authid.tablename notation.

The following table describes the command line options.

Option | Description
-a | Writes element names in a C structure in uppercase. If -a is not specified, element names are written in lowercase.
-cCompValue CompValue specifies the computation type assigned to COBOL binary integers.

CompValue must be one of the following numeric values:

  • 0 - uses COMP
  • 4 - uses COMP-4
  • 5 - uses COMP-5

If this option is not included, 0 (COMP) is used.

-d | Includes a variable declaration for the defined C structure. If -d is not specified, a C structure is defined, but it is not declared as a variable.
-fDecFileName DecFileName specifies the name of the file to which the Declaration Generator will write the declaration.

If you do not include this option, the source table name will be used as the declaration file name (with the extension .h for C, .cpy for COBOL, or .inc for PL//I).

If a path is not specified, the file is written to the directory specified in the application path. Do not include an extension with the file name.

If you specify a file name that already exists, and the -r option is not specified, the Declaration Generator will ask whether you want to replace or append to the file at run time. If -r is specified, the file will automatically be overwritten (see -r below).

-gPicType Pictype specifies the COBOL data type that will be used for graphic, vargraphic and long vargraphic fields.

Pictype must be one of the following:

  • PICN declares graphic fields as PIC N(x).
  • PICG declares graphic fields as PIC G(x) DISPLAY-1
  • PICX declares graphic fields as PIC X(x)

If this option is not included, PICN is used.

-h | Opens the Declaration Generator help file.
-iIniFileName IniFileName specifies the disk, directory, filename and extension of the initialization file to be used.

If this option is not included, the XDB.INI file in the current working directory is used.

-kPageSize PageSize specifies the page size that will be assigned to COBOL declarations for long varchar, long vargraphic, and long varbinary fields.

PageSize must be one of the following:

  • 4k
  • 32k

If this option is not included, 4K is used.

-lLanguage Language specifies the language in which the Declaration Generator will write the declaration file.

Language must be one of the following:

  • C
  • COBOL
  • PLI

If this option is not included, COBOL is used.

-n | Runs the Declaration Generator without stopping on errors or for user responses.
-pPrefix Prefix is a 1 - 27 character string to be prefixed to each field name to form an element name.

For example, if the option -pemp_ were used, the field names ssn and lname would become element names emp_ssn and emp_lname, respectively.

-r | Automatically replaces a declaration file if it already exists. If -r is not specified, the program asks whether to replace or append to a file that already exists.
-sStructure Structure specifies the name to be assigned to the record definition (COBOL) or structure (C).

If this option is not included, the table name is assigned to the structure.

-uNames Specifies whether field names will be concatenated with the string specified by -pPrefix (above), or whether they will be replaced with numbers.

If Names is set to real, field names are concatenated to Prefix.

If Names is set to n/a, a 3-digit, sequential number is concatenated to prefix.

For example, if the option -ureal were used, field names would be concatenated with the string specified in -pPrefix.

If -psales- and -un/a were used, the prefix sales- would be combined with a three-digit number to form element names such as sales-001, sales-002, and so on.

-vLevel | Level assigns a level number to a COBOL record description. If -v is not used, field-level definitions are set to 2.

Example Command Line

The following example shows the command line for a COBOL copybook created for an EMPLOYEE table on a Windows system.

dclg40n -ic:\xdb\xdb.ini -tinstall.employee -lcobol -femployee.cpy -sdclemployee -psales -ureal -c4 -v2

In this example, the Declaration Generator will assign the name dclemployee to the record definition, and will prefix each elementary item with the string sales. COMP-4 class will be assigned to int and smallint fields. Level 2 will be assigned to the field-level definitions.

Parent topic: Declaration Generator


Running in Batch Mode

If you have several tables for which you want to generate declaration files, you can create them using the Declaration Generator's "batch mode."

In batch mode, you can type the specifications for one or more tables in a .DGE file, then use the file as input to the Declaration Generator program. This process lets you generate declaration files for several tables in a single operation rather than generating them one-by-one interactively or from the command line.

Parent topic: Declaration Generator


Creating a .DGE File

To run the Declaration Generator in batch mode, you must create a .DGE file specifying the tables for which you want declaration files generated, and the language(s) in which you want the declaration files written.

A .DGE file can be created in two ways:

  • You can enter your specifications in the Declaration Generator window and save them with the SAVE AS button. See Running Interactively.
  • You can create a .DGE file using any ASCII text editor.

The .DGE file must be stored in the DEFAULT APPLICATION PATH as specified in Options, PATHS tab, and it must have a .DGE extension.

A .DGE file contains the instructions needed to generate one or more declaration files. Each line in the file specifies a single "transaction," which creates a single declaration file in a single language (COBOL, C or PL/I). A transaction is specified as follows:

            tablename
            decFileName [option1
            option2
            option3...]

Where:

tablename specifies the name of the table for which a declaration file is generated. You can specify location and AuthID information using location.authid.tablename notation.

decFileName specifies the name of the file to which the declaration statements are written.

  • Do not include path information in decFileName. The Declaration Generator automatically writes the file to the application path (the application path is specified in the PATHS tab of Options).
  • Do not include an extension in decFileName. An extension is automatically assigned based on the language you've specified.

The option parameters specify the programming language, structure name and other parameters, if you don't want to use the defaults. See

DGE File Transaction Options

The following table describes the optional parameters you can include in a transaction statement. If an option is not included in a transaction statement, a default value is used.

Option Description Example
a=Case Where Case determines whether C element names are written in upper or lower case.

If Case is set to upper, element names are written in uppercase.

If Case is set to lower, or if this option is not set, element names are written in lowercase.

 a=upper generates uppercase elements.
c=CompValue CompValue specifies the COMP type assigned to binary integers (for COBOL only; this option is ignored if language is set to C).

CompValue must be one of the following:

  • 0 - uses COMP
  • 4 - uses COMP-4
  • 5 - uses COMP-5
  • 0 (COMP) is the default.
 c=4 assigns COMP-4 to binary integers.
d=DStuc Where DStruc determines whether a C structure is written as a variable declaration.

If DStruc is set to decl, the structure is declared as a variable.

If DStruc is set to nodecl, or if this option is not set, the C structure is defined as a data type, but is not declared as a variable.

 d=decl creates a variable declaration from the structure.
g=PicType Where Pictype specifies the COBOL data type that will be used for graphic, vargraphic and long vargraphic fields.

Pictype must be one of the following:

  • PICN declares graphic fields as PIC N(x).
  • PICG declares graphic fields as PIC G(x) DISPLAY-1
  • PICX declares graphic fields as PIC X(x)
  • PICN is the default.
 g=PICG declares graphic fields as follows:

PIC G(x) DISPLAY-1,

k=PageSize Where PageSize specifies the page size that will be assigned to COBOL declarations for long varchar, long vargraphic, and long varbinary fields.

PageSize must be one of the following:

  • 4K
  • 32K
  • 4K is the default.
 k=32K assigns a 32k pages size to long variables.
l=Language Language specifies the language in which the declaration will be written. Language must be one of the following:
  • C
  • COBOL
  • COBOL is the default.
 l=C generates a C header file.

l=COBOL generates a COBOL copybook.
p=Prefix Prefix specifies the prefix that will be affixed to each of the element names.

Depending upon the state of the u=Names option, this prefix will either be concatenated with a field name or a number to form an element name.

See u=Names, below.

 p=sales- u=real

combines the prefix sales- with the field names to form element names such as sales-dept, sales-mgr, and so on.

p=sales- u=n/a

combines the prefix sales- with a three-digit number to form element names such as sales-001, sales-002, and so on.

s=Structure Structure specifies the name of the record definition (COBOL) or structure (C). This name must be valid for the chosen language.

If Structure is not specified, the following defaults are used:

  • For C: c_tablename
  • For COBOL: dcltablename
 s=c_SalesReps assigns the name c_SalesReps to the generated structure
u=Names Where Names specifies whether field names or numbers are concatenated to Prefix to form element names (see p=Prefix, above).

If Names is set to real, field names are concatenated to Prefix.

If Names is set to n/a, or if this option is not set, numbers are concatenated to Prefix.

 p=sales- u=real

combines prefix sales- with field names to form element names such as sales-dept,sales-mgr, and so on.

p=sales- u=n/a

combines the prefix sales- with a three-digit number to form element names such as sales-001, sales-002, and so on.

v=Level Where Level is an integer specifying the number to be assigned to the field-level definitions in a COBOL record description. v=3 writes level-3 field definitions, for example:
3 ST PIC X(2).
3 ZIP PIC X(5)
Parent topic: Declaration Generator


Running a .DGE File

Once you have created a batch declaration file, you can run the batch version of the Declaration Generator from your Net Express command prompt.

To run the Declaration Generator in batch mode, you call the dclg40n program using the following syntax:

dclg40n [-iIniFile -r -n]-b FileName

where:

IniFile specifies the disk, directory, filename and extension of the initialization file to use. If this option is not included, the initialization file in the current working directory is used.

FileName is the name of the .DGE file containing the transactions you want to run. If you don't specify a path, the Declaration Generator looks for the .DGE file in the application path (the application path is specified by in the PATHS tab in Options).

-r and -n are options that affect the presentation of error messages and the treatment of existing declaration files. For more information about these options, see Running From the Command Line.

The following example generates the declaration files specified by the EMPDATA.DGE file.

dclg40n -b c:\BATCH\EMPDATA

The following example generates the declaration files specified by the EMPDATA.DGE file, using the EMP.INI initialization file.

dclg40n -iEMP.INI -b c:\BATCH\EMPDATA
Parent topic: Declaration Generator
Related information
Running From the Command Line


Link Configuration

  • Configure the Host
  • Configure the PC
  • Configure DB2 Access
Parent topic: How to...


Configure the Host

  • Configuring the Host for TCP/IP Access to XDB Link
  • XDB Link Host Option
  • Installing and Configuring the XDB Link Host Option
  • Starting the XDB Link Host Option on the Mainframe
  • Configuring the Host for SNA Access to XDB Link
  • Configuring DB2 to Accept DRDA Requests
Parent topic: Link Configuration
Related information
Configure the PC
Configure DB2 Access


Configuring the Host for TCP/IP Access to XDB Link

If you are using TCP/IP to connect XDB Link to OS/390, and you are using a version of DB2 that does not support direct access to the DDF facility via TCP, you must install and configure the XDB Link Host Option on the host. This program receives TCP/IP packets containing DRDA-compliant requests from XDB Link and routes them to DB2 via APPC. If DB2 security is a concern, it is suggested the XDB Link be used in all cases.

Parent topic: Configure the Host
Related information
XDB Link Host Option
Installing and Configuring the XDB Link Host Option
Configure the Host


XDB Link Host Option

  1. Before installing the XDB Link Host Option, verify the host IP address and reserve a port number for XDB Link.
  2. Install and configure the XDB Link Host Option.
  3. Start the XDB Link Host Option on the mainframe.
  4. Work with the Access List.
Parent topic: Configure the Host
Related information
Installing and Configuring the XDB Link Host Option
Starting the XDB Link Host Option on the Mainframe
The Access List


Installing and Configuring the XDB Link Host Option

The following describes the steps to install and configure the XDB Link Host Option.

Note:

To install the software, you will need the information provided by your TCP/IP network administrator on the TCP XDBPARM worksheet. If you do not have a completed copy of this worksheet, get one before you begin.

To install the XDB Link Host Option

  1. Create and install JCL PDS with FB LRECL 80.
  2. Create and submit the following JCL to unload the INSTALL JCL file (file 1) of the installation tape:
    //jobname JOB jobcard information
        //STEP1 EXEC PGM=IEBGENER
        //SYSPRINT DD SYSOUT=A
        //SYSUT1 DD DSN=XDBLINK.V100T.INSTALL,DISP=OLD,
        // UNIT=inputdev,VOL=SER=volser,LABEL=(1,SL),
        // DCB=(RECFM=FB,LRECL=80,BLKSIZE=3120)
        //SYSUT2 DD DSN=xdblink.v100.INSTALL,
        // DISP=(,CATLG),
        // UNIT=dasd,VOL=SER=vvvvvv, // DCB=*.SYSUT1,SPACE=(TRK,(1,1))
        //SYSIN DD DUMMY

    where:

    inputdev | is the tape input device unit parameter
    volser | is the input tape volume serial number
    xdblink | is the XDB Link installation data set prefix
    v100 | is the high-level data set prefix
    dasd | is the DASD device unit of the install data set to be created
    vvvvvv | is the volume serial number of the install data set
  3. Edit and submit the JCL created by step 2 (xdblink.v100.INSTALL). Correct errors and rerun the job if the return code is not zero.
  4. Edit the sample VTAM application definition for XDB Link in xdblink.v100.CNTL(VTAMLST). The value of the LU62 APPLID parameter must match the ACBNAME of the XDB Link Host Option. Also, the value of the APPLID PASSWORD parameter must match the PRTCT parameter of the application definition.
  5. Edit the sample access list in xdblink.v100.ACCESS.
  6. If you are a RACF user, edit and submit the sample JCL (optional) in xdblink.v100.CNTL(RACFACC) to protect the access list. Otherwise, create and submit equivalent JCL.
  7. Edit the xdblink.v100.CNTL(XDBGTF) member (optional) and copy it to a cataloged procedure library. Modify the DSNAME for IEFRDER to conform to the naming standards for your site.
  8. Edit the xdblink.v100.CNTL(GTFXDB) member for the GTF procedure (optional). USR=(xxx) must match the EID parameter in the parameter member.
  9. Edit the sample parameter member in xdblink.v100.PARAM(PARMTCP).
  10. Copy the VTAM application definition to the active VTAMLST library and put the major node into the ATCCONxx member of the VTAMLST library. VTAM must be cycled for the updated ATCCONxx member to take effect.
    Note:

    To avoid cycling VTAM, use the VTAM vary command to activate the major node.

  11. Edit the sample started task xdblink.v100.CNTL(#PROCLNK) and copy it to a system procedure library.
Parent topic: Configure the Host
Related information
Started Task Parameters
Configure the Host


Starting the XDB Link Host Option on the Mainframe

The XDB Link Host Option must be running in order for XDB Link to access DB2 using TCP/IP. To start the Host Option, issue the following command from the system console:

S stcname

where stcname is the name of the started task created in step 11.

To display the status of the started task and verify that the correct port number is selected, use the following command:

F stcname, DISPLAY STATUS
Parent topic: Configure the Host


Configuring the Host for SNA Access to XDB Link

To use XDB Link with SNA:

  1. 1. Verify that VTAM is set up to allow independent LU6.2 access to host data. Have the VTAM systems programmer complete the VTAM Worksheet.
  2. Ensure that independent LU6.2 and 3270 support have been generated for the physical unit (PU) supporting XDB Link:
    • Create the PU.
    • Create an independent LU definition.
    • Create a mode entry that supports parallel sessions and is compatible with IBMRDB.
Note:

Do not discard the VTAM worksheet when you are finished configuring VTAM. It contains information that you will use to configure other parts of XDB Link.

Parent topic: Configure the Host
Related information
VTAM Worksheet
Configuring XDB Link for DB2 Access


Configuring DB2 to Accept DRDA Requests

To use XDB Link to access DB2 data on an OS/390 system, have a database administrator (DBA) or the DB2 system administrator configure DB2 to accept DRDA requests as described in the following steps.

To configure DB2 to accept DRDA requests from XDB Link

  1. Complete the DB2 worksheet and ensure that the Distributed Data Facility (DDF) is activated.
  2. Execute one of the following statements to add a record to the DB2 SYSIBM.LUNAMES table (for DB2 Version 5 and later) or to SYSIBM.SYSLUNAMES (for DB2 Version 4 and earlier). These statements enable any remote location (including XDB Link) to access DB2 if a valid user ID and password are supplied.

    For DB2 Version 4 and earlier, execute the following statement:

    INSERT INTO sysibm.syslunames (luname, sysmodename, usersecurity,encryptpswds, modeselect, usernames) VALUES (' ', ' ', 'C', 'N', 'N', ' ');

    For DB2 Version 5 and later, execute the following statement:

    INSERT INTO sysibm.lunames (luname, sysmodename, security_in, security_out, encryptpswds, modeselect, usernames) VALUES (' ', ' ', 'A', 'A', 'N', 'N', ' ');
  3. Execute the following statement to add a record to the DB2 SYSIBM.LOCATIONS table (for DB2 Version 5 and later) or to SYSIBM.SYSLOCATIONS (for DB2 Version 4 and earlier). This statement specifies the local location name for DB2:

    For DB2 Version 4 and earlier, execute the following statement:

    INSERT INTO sysibm.syslocations (location, loctype, linkname, linkattr) VALUES ('your-location-id', ' ', ' ', ' ');

    For DB2 Version 5 and later, execute the following statement:

    INSERT INTO sysibm.locations (location, loctype,   linkname, linkattr) VALUES ('your-location-id', ' ', ' ', ' ');
  4. Cycle DDF to put the updated tables into effect.
Note:

Do not discard the DB2 worksheet when you are finished configuring DB2. It contains information that you will use to configure other parts of XDB Link.

Parent topic: Configure the Host
Related information
DB2 Worksheet
Worksheets


Configure the PC

  • Configuring TCP/IP Software for the PC
  • Configuring the Microsoft SNA Server
  • Installing the DLC Protocol
  • Configuring SNA Server 2.11
  • Configuring SNA Server 3.0
Parent topic: Link Configuration
Related information
Configure the Host
Configure DB2 Access


Configuring TCP/IP Software for the PC

Use the following procedure to configure the TCP/IP software for XDB Link. Use your values from the TCP Host/Service worksheet to complete these steps.

To configure TCP/IP perform the following steps:

  1. Install a TCP/IP protocol. If a TCP/IP protocol is already installed (for example, Microsoft TCP/IP), ensure that it is enabled.
  2. Make a backup copy of the HOSTS and SERVICES files (under Windows 95, these files are called HOSTS.SAM and SERVICES.SAM).
    If you a running under... | Look for these files in...
    Windows NT | C:\WinNT\SYSTEM32\DRIVERS\ETC
    Windows 95 or 98 | C:\WINDOWS
  3. Add the following line to the HOSTS file:
    IPAddress IPName

    where:

    • IPAddress specifies the TCP/IP address of the host system. Use the value in J1 of the TCP Host/Service worksheet.
    • IPName is a name that you assign to this address. Type IPName in uppercase letters. Lowercase characters will cause problems under certain circumstances. Use the value in J2 of the TCP Host/Service Worksheet.

    For example: 204.17.148.230 LUDB2

    Note:

    If this is the last line in the HOSTS file, type a carriage return at the end of the line.

  4. Edit the SERVICES file by adding the following line:
    ServiceName Port/tcp

    where:

    ServiceName specifies a name that represents the port number on the host system. (You will use this name when you configure XDB Link in a later step.) Type the ServiceName in uppercase letters. Lowercase characters will cause problems under certain circumstances.

    Port specifies the dedicated TCP/IP port assigned to the XDB Link Host Option on the host system. Use the value in J4 of the TCP Host/Service worksheet.

    For example:

    XDBSRV 5170/tcp
    Note:

    If this is the last line in the SERVICES file, type a carriage return at the end of the line.

When connecting to DB2 with native TCP/IP:

  • Choose DRDA(TCP/IP) as your Connection Type
  • The Remote Host entry should match the mainframe's IP address entry in your HOSTS file.
  • The port entry should match the DB2 port entry in your SERVICES file. IBM's default port is 446/tcp but users should check with their administrators to find out what port their DB2 listens on.
Parent topic: Configure the PC
Related information
TCP Host/Service Worksheet
Worksheets


Configuring the Microsoft SNA Server

Use the following procedures to configure Microsoft SNA Server for XDB Link. After initially configuring the server, you can make additional modifications to boost throughput, add more users, or add another connection.

To configure the SNA Server

  1. Install the DLC protocol on your server
  2. Configure the SNA Server settings for for SNA Server 2.11 or SNA Server 3.0.
Parent topic: Configure the PC
Related information
Configure the PC
Installing the DLC Protocol


Installing the DLC Protocol

You must install the DLC protocol on your server machine before you configure the Microsoft SNA Server software.

This procedure assumes that you have installed the SNA Server. If you have not already done this, install this software before proceeding.

Note:

If the program cannot find the DLC Protocol files on your workstation, it will ask you to insert the Windows NT CD. Make sure you have this CD on hand during this procedure.

When the installation is finished, the program will ask you to reboot the system. If this is a production machine, you may want to schedule this task for a maintenance period or for off-peak hours.

To install the DLC protocol:

  1. In the Windows Control Panel, select Network.
  2. In the Network Settings dialog box, select the Protocols tab (4.0 only) and click Add or Add Software.
  3. Select DLC Protocol from the network settings list and click Continue or OK.
  4. Complete the installation process as directed by the instructions on the screen.
  5. After you reboot, make a backup copy of your current SNA configuration (optional) and then configure SNA Server Version 2.11 or SNA Server Version 3.0.
Note:

Micro Focus provides a sample configuration file, xdb_novl.sna, for you to examine and use as a guide. This file is located in your XDB application directory. It defines an Ethernet connection to a network node.

Parent topic: Configure the PC
Related information
Configuring SNA Server 3.0


Configuring SNA Server 2.11

This procedure describes the steps you use to configure the SNA Server 2.11 software. Be sure that you complete all four tasks.

Use the values from your SNA Server worksheet (V2.11).

  1. Configure server properties
    1. Start the SNA Server Admin program if it is not already running.
    2. If the Servers and Connections window is not open, double-click the Servers and Connections icon.
    3. In the left pane of the Servers and Connections window, double-click the name of your SNA Server to open the Server Properties dialog box.
      In this field... Specify...
      Network Name The SNA network name (NETID) of your VTAM system as defined in SYS1_VTAMLST(ATCSTRxx).

      Worksheet value D1.

      Control Point The control point name (CPNAME) for this server as specified in the PU definition of VTAM or NCP.

      Worksheet value D2.

    4. Click OK to apply your settings and close the Server Properties dialog box.
  2. Create and configure a connection
    1. In the left pane of the Servers and Connections window, highlight the name of your SNA Server, then select New Connection from the Services menu.
    2. In the Insert Connection dialog box, select 802.2, then click OK.
    3. In the Connection Properties dialog box, type a name for this connection in the Connection Name field. Use the value in D3 of the TCP Host/Service Worksheet.

      Then, complete the following:

      In this field... | Select...
      Link Service | SnaDlc1
      Remote End | Host System
      Activation The event that will activate this connection. We recommend that you select On Server Startup.

      Worksheet value D6.
      Allowed Directions | Outgoing Calls and Incoming Calls
    4. Click Setup to open the 802.2 Setup dialog box and specify the following:
      In this field... | Specify...
      Remote Network Address The 12-digit hexadecimal network address (MAC address) as defined in the MACADDR= parameter in VTAM or NCP controller definition.

      Worksheet value D8.

      Local Node ID The 8-digit hexadecimal local ID number for this SNA server. The first three digits must match the IDNUM parameter in VTAM, and the last five digits must match IDBLK

      Worksheet values D9.
      Network Name The SNA network name (NETID) of your VTAM system as defined in SYS1_VTAMLST(ATCSTRxx).

      Worksheet value D1.

      Control Point Name The system services control point name (SSCPNAME) of the host node as specified in the PU definition of VTAM or NCP.

      Worksheet value D11.

      Remote Node ID | Leave blank.
    5. Click Advanced>> to display the advanced options
    6. In the XID Type group box, select Format 3.
    7. Click OK to close the 802.2 Setup dialog box.
    8. Click OK to close the Connection Properties dialog box.
  3. Create and configure the Local APPC LU
    1. In the left pane of the Servers and Connections window, highlight the name of your SNA Server.
    2. Select the Insert command from the Edit menu.
    3. In the Insert dialog box, select APPC [Local] and click OK.
    4. In the New APPC LU Properties dialog box, complete the following:
      In this field... | Specify...
      LU6.2 Type | Independent
      LU Alias A name that represents this machine in its local SNA communications configuration.

      We recommend that you use the XDB Server name as the alias for this machine.

      Worksheet value D15.

      LU Name The LU name of this APPC LU as it is specified in VTAM.

      Worksheet value D17.

      Enable Automatic Partnering | Enable
      Implicit Incoming Remote LU | (None)
    5. Click OK to close the APPC LU Properties dialog box.
  4. Create and configure the remote APPC LU
    1. In the left pane of the Servers and Connections window, highlight the name of the Microsoft SNA server connection you created and select the Insert command from the Edit menu.
    2. In the Insert dialog box, select APPC [Remote] and click OK.
    3. In the New APPC Remote LU Properties dialog box, complete the following:
      In this field... | Specify...
      LU Alias A name to represent the remote APPC LU in this SNA server's communication configuration.

      Worksheet value D20.

      LU Name The VTAM APPLID for DB2.

      Worksheet value D22.

      Uninterpreted LU Name | The same VTAM APPLID specified in LU Name above, or nothing (leave blank).
      Supports Parallel Sessions | Enable
      Enable Automatic Partnering | Enable
      Implicit Incoming Mode IBMRDB, an independent mode definition that you have defined, or (None)

      If you use your own mode definition, it must support parallel sessions.

    4. Click Partners to open the LU6.2 Partner LUs dialog box, then click Add.
    5. In the Add APPC LU Partner dialog box, select the following:
      In this field... | Select...
      Partner LU | The Local LU you created when you configured Microsoft SNA Server.
      Mode | IBMRDB
    6. Click OK to close the Add APPC LU Partner dialog box. Click Close to close the LU6.2 Partner LUs dialog box, then click OK to close the New APPC Remote LU Properties dialog box.
    7. Select Save Configuration from the File menu to save the new configuration, then restart the server to put the new configuration into effect.

      The connection is ready to use with XDB Link.

Parent topic: Configure the PC


Configuring SNA Server 3.0

This procedure describes the steps for configuring the SNA Server, version 3.0. Be sure to complete all tasks. Use the values from your SNA Server Worksheet (3.0).

  1. Insert a Link Service
    1. Start the SNA Server Manager if it is not already running.
    2. In the Server Manager window, select the name of your SNA Server.
    3. Select the Link Service command from the Insert menu.
    4. Select DLC 802.2 Link Service in the Insert Link Service dialog box, then click Add.
    5. Click OK in the DLC 802.2 Link Services Properties dialog box to accept the default settings.
  2. Configure SNA Server Properties
    1. In the Server Manager window, select the name of your SNA Server.
    2. Select the Properties command from the View menu.
    3. On the General tab in the Properties dialog box, set the following:
      In this field... Specify the following...
      Network Name The SNA network name (NETID) of your VTAM system as defined in SYS1_VTAMLST(ATCSTRxx).

      Worksheet value E1.

      Control Point The control point name (CPNAME) for this server as specified in the PU definition of VTAM or NCP.

      Worksheet value E2.

    4. Click OK to close the Properties dialog box.
  3. Create and configure a connection
    1. In the Server Manager window, select the name of your SNA Server.
    2. Select the Connection command from the Insert menu, then select 802.2.
    3. On the General tab in the Connection Properties dialog box, set the following:
      In this field... | Specify...
      Name A name for this connection.

      Worksheet value E3.

      Link Service | SnaDlc1
      Support Dynamic Remote APPC LU Definition | Enable
      Remote End | Host System
      Allowed Directions | Both Directions
      Activation The event that will activate this connection. We recommend that you select Server Startup.

      Worksheet value E7.
    4. Select the Address tab in the Connection Properties dialog box and set the following:
      In this field... Specify...
      Remote Network Address The 12-digit hexadecimal network address (MAC address) as defined in the MACADDR= parameter in VTAM or NCP controller definition.

      Worksheet value E8.

      Remote SAP Address The remote SAP address. For most installations, the default value of 04 is appropriate.

      Worksheet value E9.

    5. Select the System Identification tab in the Connection Properties dialog box and set the following:
      In this field... | Specify...
      Network Name

      (Local)

              The SNA network name (NETID) of your VTAM system as defined in SYS1_VTAMLST(ATCSTRxx). (The Network Name specified in TASK 2 will automatically appear in this field.)

      Worksheet value E1.

      Control Point

      (Local)

              The control point name of your VTAM system as defined by the VTAM PU. (The Control Point name specified in TASK 2 will automatically appear in this field.)

      Worksheet value E11.
      Local Node ID The 8-digit hexadecimal local ID number for this server. The first three digits must match the IDNUM parameter in VTAM, and the last five digits must match IDBLK

      Worksheet value E12.

      XID Type | Format 3
      Network Name

      (Remote)

              The SNA network name (NETID) of your VTAM system as defined in SYS1_VTAMLST(ATCSTRxx).

      Worksheet value E1.

      Control Point

      (Remote)

              The system services control point name (SSCPNAME) of the host node as specified in the PU definition of VTAM or NCP.

      Worksheet value E15.

      Remote Node ID | Leave blank
    6. Select the 802.2 tab in the Connection Properties dialog box and verify that the Max BTU Length is less than or equal to MAXDATA in the VTAM PU definition.
    7. Click OK to close the Connection Properties dialog box.
  4. Create and configure the APPC Mode Definition
    1. In the Server Manager window, select the name of your SNA Server.
    2. Select the APPC command from the Insert menu, then select Mode Definition.
    3. On the General tab in the Remote APPC Mode Definition dialog box, set the following:
      In this field... Specify the following...
      Mode Name IBMRDB or an independent mode definition that you have defined in VTAM.

      If you use your own mode definition, it must support parallel sessions.

      Worksheet value E33.

    4. Select the Limits tab and set the following:
      In this field... | Specify the following...
      Parallel Session Limit The DSESLIM value for your PU definition in SYS1_VTAMLST.

      Worksheet value E34.

      Minimum Contention Winner Limit | Half the number specified in the Parallel Session Limit field.
    5. Complete the Limits tab by setting the following suggested values or specifying appropriate values for your network configuration:
      Field Name | Suggested Value...
      Partner Minimum Contention Winner Limit | 0
      Automatic Activation Limit | 0
    6. Select the Characteristics tab and set the following suggested values or use values appropriate for your network configuration:
      Field Name | Suggested Value...
      Pacing Send Count | 7
      Pacing Receive Count | 7
      Max Send RU Size | 4096
      Max Receive RU Size | 4096
      High Priority Mode | Enabled
    7. Click OK to close the Local APPC LU Properties dialog box.
  5. Create and configure the local APPC LU
    1. In the Server Manager window, select the name of your SNA Server.
    2. Select the APPC command from the Insert menu, then select Local LU.
    3. On the General tab in the Local APPC LU Properties dialog box, set the following:
      In this field... Specify...
      LU Alias A name that represents this machine in its local SNA communications configuration.

      We recommend that you use the XDB Server name as the alias for this machine.

      Worksheet value E18.

      Network Name The SNA network name (NETID) of your VTAM system as defined in SYS1_VTAMLST(ATCSTRxx). The Network Name specified earlier should automatically appear in this field.

      Worksheet value E1.

      LU Name The LU name of this APPC LU as it is specified in VTAM.

      Worksheet value E20
    4. Select the Advanced tab in the Local APPC LU Properties dialog box and set the following:
      In this field... | Specify the following...
      Member of Default Outgoing Local APPC LU Pool | Disable
      Implicit Incoming Remote LU IBMRDB, an independent mode definition that you have defined, or <None>.

      If you use your own mode definition, it must support parallel sessions.

      LU6.2 Type | Independent
      SyncPoint Support | Disabled
    5. Click OK to close the Local APPC LU Properties dialog box.
  6. Create and configure the Remote APPC LU
    1. In the Server Manager window, select the name of your SNA Server.
    2. Select the APPC command from the Insert menu, then select Remote LU.
    3. On the General tab in the Remote APPC LU Properties dialog box, set the following:
      In this field... | Specify...
      Connection | The name of your connection
      LU Alias A name to represent the remote APPC LU in this server's SNA communication configuration.

      Worksheet value E26.

      Network Name The SNA network name (NETID) of your VTAM system as defined in SYS1_VTAMLST(ATCSTRxx). The Network Name specified earlier should automatically appear in this field.

      Worksheet value E1.

      LU Name The VTAM APPLID for DB2.

      Worksheet value E28 and A9.

      Uninterpreted LU Name | The same VTAM APPLID specified in LU Name above, or nothing (leave blank).
    4. Select the Options tab in the Remote APPC LU Properties dialog box and set the following:
      Set this field... | To...
      Supports Parallel Sessions | Enabled
      Implicit Incoming IBMRDB, an independent mode definition that you have defined, or <None>

      If you use your own mode definition, it must support parallel sessions.

      Session-Level Security | No Session-Level Security
    5. Click OK to close the Local APPC LU Properties dialog box.
    6. Select the Save command on the File menu to save this configuration, then restart the server to put the new configuration into effect.

      The connection is ready to use with XDB Link.

Parent topic: Configure the PC
Related information
SNA Server Worksheet (V3.x)
Worksheets


Configure DB2 Access

  • Configuring XDB Link with the Gateway Profile Utility
  • Defining Remote XDBHOST Connection Types
  • Defining Remote DRDA(APPC) Connection Types
  • Binding XDB Link to DB2
  • Creating Required Tables and Views
  • Configuring the Client Workstation
  • Configuring XDB Link Security
  • Creating User IDs for XDB Link
  • Enabling Security on the Client Workstation
  • Configuring Communications Software on the PC
Parent topic: Link Configuration
Related information
Configure the Host
Configure the PC


Configuring XDB Link with the Gateway Profile Utility

You can use the Gateway Profile Utility to:

  • Define remote locations to XDB Link so that XDB client applications can access data in those locations.
  • Configure the settings XDB Link needs to translate data correctly and control client conversations.

If you have installed XDB Link on an XDB Server as part of a gateway configuration, you must:

  • Have super-user privileges on the XDB Server where XDB Link is installed.
  • Run the Gateway Profile Utility on the machine where XDB Link is installed.

If you need additional information about the Gateway Profile Utility while doing this procedure, see the topic Gateway Profile Utility.

To configure XDB Link using the Gateway Profile Utility

  1. If you are using XDB Link in a gateway configuration, start the XDB Server on the machine where XDB Link is installed.
  2. Start the Options utility. (If you are using the gateway configuration, do this at the machine where XDB Link is installed).
  3. When the Options window opens, set the following values on the Connect page:
    If you are using ... | Make these selections...
    Gateway configuration In the Server Name field, select the name of the XDB Server on which XDB Link is installed.

    In the Location field, select the SYSTEM location.

    In the Protocol field, select the Local protocol.

    Direct-connect configuration | In the Protocol field, select DRDA.
  4. Click OK to save your settings and close Options.
  5. Start the Gateway Profile Utility by selecting its icon in the XDB program group or folder. (If you are using the gateway configuration, do this at the machine where XDB Link is installed.) If prompted for a user ID, enter an ID that has super-user or SYSADM privileges.
  6. When the Gateway Profile Utility window opens, click Register to display the Location Configuration dialog box. You use this dialog box to add the remote database to XDB Link.
  7. In the Location Name field, type the name of the remote database from row B9 in your DB2 worksheet. This is the DB2 location name used by the DDF facility.
    Note:

    A common mistake is to specify theDB2 APPLID in VTAM or the 4-character SUBSYSTEM name for DB2. These names are usually NOT the same name as the DB2 location name (although your DB2 systems programmer may have decided that all three of these names should be the same.) See your DB2 systems programmer to determine the DB2 location name.

  8. Complete the configuration process using the appropriate steps for your connection type:
    If XDB Link will use ... | Follow the procedures in the section ...
    TCP/IP to access DB2 | Configuring XDB Link for DB2 Access.
    SNA to access DB2 | Configuring XDB Link for DB2 Access.
Parent topic: Configure DB2 Access
Related information
Gateway Profile Utility
Defining Remote XDBHOST Connection Types
Defining Remote DRDA(APPC) Connection Types


Defining Remote XDBHOST Connection Types

Use the following procedure to complete the Location Configuration dialog box if you are using TCP/IP to access DB2 through the XDB Link Host Option.

To define an XDBHOST connection

  1. Select XDBHOST(TCP/IP) from the Connection Type list box.
  2. In the DRDA Setup group box, specify the Package Name and Collection Identifier of the package that XDB Link will use to pass dynamic SQL to DB2. If your DBA or XDB administrator has already created a package on the host for XDB Link, make sure that you enter the package name and collection ID as it has been specified on the host.
    Note:

    If you have an earlier version of XDB Link, give this version a new package name. We suggest that you adopt a package naming convention that includes the XDB Link version number-- for example, XLNK600, XLNK601, XLNK602. In a multiple-gateway environment, this allows XDB Links with older software to continue to function. It also preserves the original package name in case you want to revert to the earlier version of XDB Link software.

  3. In the TCP/IP Setup group box, set the following values:
    In this field... Specify the following...
    Remote APPLID The APPLID of the remote DB2 subsystem.

    Worksheet row A9.
    Remote HOST The name of the host IP address as specified in the HOSTS file on this machine.

    Worksheet row J2.
    Port The name of the TCP/IP port dedicated to the XDB Link Host Option as specified in the SERVICES file on this machine.

    Worksheet row J3.
    Note:

    The Local HOST field in this group box displays the name of the XDB Server on which your XDB Link software resides. You cannot change this value.

  4. Modify other settings as you need or accept the defaults. See the XDB Bind Utility User's Guide for additional information about the Location Configuration dialog box.
    Note:

    The host code page values are the current default settings. The actual code page values used for this connection are dynamically determined when XDB Link connects with this remote host. (See Code Mappings for more information regarding host code pages.)

  5. Click Update to add this location to XDB Link.
  6. Click Exit to close the Location Configuration dialog box.
Parent topic: Configure DB2 Access


Defining Remote DRDA(APPC) Connection Types

Use the following procedure to complete the Location Configuration dialog box if you are using an SNA connection to access DB2.

To define a DRDA(APPC) connection

  1. Select DRDA(APPC) from the Connection Type list box.
  2. In the DRDA Setup group box, specify the Package Name and Collection Identifier of the package that XDB Link will use to pass dynamic SQL to DB2. If your DBA or XDB administrator has already created a package on the host for XDB Link, make sure that you enter the package name and collection ID as it has been specified on the host.
  3. Note:

    If you have an earlier version of XDB Link, give this version a new package name. We recommend that you adopt a package naming convention that includes the XDB Link version number-- for example, XLNK600, XLNK601, XLNK602. In a multiple-gateway environment, this allows XDB Links with older software to continue to function. It also preserves the original package name in case you want to revert to the earlier version of XDB Link software.

  4. In the APPC Setup group box, set the following values:
    In this field... | Specify the following...
    Local LU Alias The name that represents this machine in its local SNA communications configuration.

    This value must match the Local LU Alias that you assigned to this computer when you configured its SNA software.

    Worksheet row D15, E19, F13, or H5, depending on which SNA server you use.
    Partner LU Alias The name that represents the remote APPC LU in this machine's local SNA communications configuration.

    This value must match the Partner (or Remote) LU Alias you assigned to the host LU when you configured the SNA software on this machine.

    Worksheet row D20, E27F16, or H12, depending on which SNA server you use.
    Mode Name IBMRDB or the name of an independent LU6.2 mode definition that you have specified in the mode table (MODETAB) associated with this machine's LU definition in VTAM.

    If you use your own mode definition, it must support parallel sessions.

    VTAM worksheet row A6
    Transaction ID | X'07F6C4C2'
  5. Modify other settings as you need or accept the defaults. See the topic Location Configuration Window for information about the Location Configuration dialog box.
    Note:

    The host code page values are the current default settings. The actual code page values used for this connection are dynamically determined when XDB Link connects with this remote host. (See Code Mappings for more information regarding host code pages.)

  6. Click Update to add this location to XDB Link.
  7. Click Close to close the Location Configuration dialog box.
Parent topic: Configure DB2 Access


Binding XDB Link to DB2

Every DB2 application must have an application package to support the execution of statically-bound and dynamic SQL contained in the program. Under DB2, an application package is created when you bind the application using the BIND PACKAGE subcommand.

Because XDB Link runs against DB2, it must have an application package on the host. XDB Link uses its application package to process dynamic SQL from client applications (statically bound SQL is executed through the appropriate application package) and to execute statically-bound SQL statements contained in the XDB Link program itself.

To create the application package for XDB Link, you must create a database resource module (DBRM) for XDB Link and bind it to DB2 using the XDB Bind Utility.

Note:

You only need to bind XDB Link once. If this version of XDB Link has already been bound with your DB2 database, you can skip this procedure.

To perform these steps, you must have a valid user ID and password on the XDB Server where XDB Link is installed (if you are using XDB Link in a gateway configuration) and on the host system. Additionally, your user ID must have the following privileges under DB2 on the host.

  • BINDADD authority
  • BIND authority for XDB Link
  • CREATE authority for the XDB Link collection ID (needed only if your DB2 system imposes collection ID security)

If you do not have these privileges, you (or someone authorized to grant such privileges) must execute the following SQL statements on DB2.

GRANT BINDADD to UserID
GRANT BIND ON PACKAGE PackageName TO UserID
GRANT CREATE ON COLLECTION CollectionID TO UserID

where:

UserID | is your user ID
PackageName | is the name of the XDB Link package as specified in the Gateway Profile Utility
CollectionID | is the collection ID assigned to XDB Link in the Gateway Profile Utility

For additional information about these SQL statements, see your DB2 SQL Reference.

If you need additional information about the XDB Bind Utility while performing the following procedure, see the XDB Bind Utility User's Guide.

To create the default package for XDB Link

  1. On the machine where XDB Link is installed, start the communications software (SNA or TCP/IP) if it is not already running.
  2. If you are using XDB Link in a gateway configuration, start the XDB Server on the machine where XDB Link is installed.
  3. On the machine where XDB Link is installed, or from any client workstation with access to that machine, start Options by selecting its icon in the XDB program group or folder.
  4. When the Options window opens, set the following values on the Connect page:
    If you are using a... | Make these selections...
    Gateway configuration In the Server Name field, select the name of the XDB Server on which XDB Link is installed.

    In the Protocol field, select protocol this machine will use to commu-nicate with the XDB Server on which XDB Link is installed.
    Direct-connect configuration | In the Protocol field, select DRDA.
  5. Click OK to close Options and save your settings.
  6. Start the XDB Bind Utility by selecting its icon in the XDB program group or folder.
  7. When the XDB Bind Utility window opens, select the name of the host system from the Remote Location drop-down list.
  8. Click Default to display the Generate Default DBRM screen and complete the following:
    In this field... | Specify...
    Package Name | The package name for XDB Link. This value must match the package name assigned to XDB Link in the Gateway Profile Utility.
    Collection ID | The collection ID for XDB Link. This value must match the collection ID given to XDB Link in the Gateway Profile Utility.
    Host System The type of DRDA host to which you want to bind XDB Link.

    Select MVS if you are using a DB2 version that does not support stored procedures (versions below 4.1)

    Select MVS + SPC if you are using a version of DB2 that supports stored procedures (version 4.1 or higher).
    Dynamic Sections | The number of dynamic sections that DB2 will include in the package it builds for XDB Link. This value determines how many dynamic SQL statements a client can have open at one time. The default value (32) is appropriate for most applications.
  9. Click Create to generate the default DBRM in your XDB application directory.
  10. Click Cancel to return to the XDB Bind Utility window, then click Bind to display the Bind Package dialog box.
  11. In the DBRM File Name list, select the name of the DBRM file created in step 9. Modify the other settings in this dialog box as you need or accept the defaults.
  12. Click Execute to bind XDB Link to DB2.
  13. When the bind process is finished, click Cancel to exit the Bind Utility.
  14. Use SQLWizard or another database management tool execute the following statement to grant public EXECUTE privileges for XDB Link.
    GRANT EXECUTE ON PACKAGE collid.* TO PUBLIC

    where collid is the collection id of your XDB Link package.

Parent topic: Configure DB2 Access


Creating Required Tables and Views

A few Micro Focus development tools, such as SQLWizard and XDB Migrate, use special tables in which they maintain control information. These programs also need access to system tables. Before you can successfully use these tools with XDB Link, you must do the following in DB2:

  1. Create the special tables these programs need.
  2. Grant public access to these special tables or grant access to XDB Link users on a user-by-user basis.
  3. Create views of the system tables these programs use (optional).
  4. Grant public access to these system tables (or views), or grant access to XDB Link users on a user-by-user basis.

Micro Focus provides a script file (XDBLINK.SQL, in the XDB program directory) to create the necessary files and grant the required privileges. Ask your DB2 database administrator to examine this script file and customize it for your DB2 site. He or she may want to edit this script to:

  • create views of the system tables rather than allowing users direct access to them
  • grant access to all users (public access) or to specific users
  • create the new tables in a database other than the default

After the script is customized, run it against your DB2 location using a tool such as SPUFI on the host. Or, use the following steps to run the script with SQLWizard from an XDB client workstation.

To perform these steps, you must have SELECT privileges on the DB2 system tables and you must be authorized to create tables.

To run the XDBLINK script using SQLWizard

  1. On the machine where XDB Link is installed, start the communications software (SNA or TCP/IP) if it is not already running.
  2. If you are using XDB Link in a gateway configuration, start the XDB Server on the machine where XDB Link is installed.
  3. On the machine where XDB Link is installed, or from any client workstation with access to that machine, start Options by selecting its icon in the XDB program group or folder.
  4. When the Options window opens, set the following values on the Connect page:
    If you are using XDB Link in a... Make these selections...
    Gateway configuration In the Server Name field, select the name of the XDB Server on which XDB Link is installed.

    In the Location field, specify the name of the DB2 location.

    In the Protocol field, select protocol this machine will use to commu-nicate with the XDB Server on which XDB Link is installed.
    Direct-connect configuration In the Location field, specify the name of the DB2 location.

    In the Protocol field, select DRDA.
  5. Set these additional options:
    • On the Security page, enable the Client Security option.
    • On the SQL page, set SQL Compatibility Mode to DB2.
  6. Click OK to close Options and save your settings.
  7. Start SQLWizard by selecting its icon in the XDB program group or folder.
  8. Use the Run Batch command on the File menu to run the script file XDBLINK.SQL against each host location. This file is located in the XDB program directory.
Parent topic: Configure DB2 Access


Configuring the Client Workstation

To access a DB2 database through XDB Link from an XDB client application, you must use the Options program to point the workstation to the DB2 database and establish an operating environment compatible with the DB2 host system.

To configure the client workstation, take the following steps before you execute an XDB client application.

To configure an XDB client workstation for DB2

  1. On the machine where XDB Link is installed, start the communications software (SNA or TCP/IP), if it is not already running.
  2. If you are using XDB Link in a gateway configuration, start the XDB Server on the machine where XDB Link is installed.
  3. At the client workstation, start Options by selecting its icon from the XDB program group or folder.
  4. When the Options window opens, set the following values on the Connect page:
    If you are using a... Make these selections...
    Gateway configuration In the Server Name field, select the name of the XDB Server on which XDB Link is installed.

    In the Location field, specify the name of the DB2 location.

    In the Protocol field, select protocol this machine will use to communicate with the XDB Server on which XDB Link is installed.

    Direct-connect configuration In the Location field, specify the name of the DB2 location.

    In the Protocol field, select DRDA.

  5. Set these additional options:
    • On the Security page, enable the Client Security option.
    • On the SQL page, set SQL Compatibility Mode to DB2.
  6. Click OK to save your settings and close Options.
  7. Run the client application.
Parent topic: Configure DB2 Access
Related information
Enabling Security on the Client Workstation
Configure DB2 Access


Configuring XDB Link Security

Because of the security imposed by DB2 and the host system, you must implement the following security measures on your network.

  • On the machine where XDB Link is installed, create a user ID and password for each user that will access DB2 using XDB Link. (Gateway configuration only.)
  • On the machine where XDB Link is installed, set the XDB Server Security option using the XDB Server Configuration Utility (Gateway configuration only). For specific procedures, see the SQL Option Server Administration Guide.
  • On each client machine that will access DB2 though XDB Link, enable the XDB Client Security feature.
Parent topic: Configure DB2 Access
Related information
Creating User IDs for XDB Link
Configure DB2 Access


Creating User IDs for XDB Link

If you are using XDB Link in a gateway configuration, each user that will access DB2 through XDB Link, must have a valid user ID and password on the host, and must have a matching user ID and password on the machine where XDB Link is installed. This is because XDB Link automatically presents a client's XDB user ID and password to the host when the client requests data from DB2. If the XDB user ID and password are not also valid on the host machine, the user won't be allowed on the system.

To create user IDs and passwords on the XDB Server, use the Users or Groups command in SQLWizard (you must have super-user authority to do this). Make sure the user ID and password you create with SQLWizard match the user ID and password on the host.

Note:

When passwords are created, note the XDB software is case-sensitive.

For users who will connect only to DB2, and not to databases on an XDB Server, you can configure their user IDs to bypass the password checking process. Doing so eliminates a redundant password check and prevents confusion when a user changes a password on one machine and not another. You may also want to configure a system where the host system acts as a "global" security server.

For complete information about designing a security scheme, see the SQL Option Server Administration Guide. For more information about creating user IDs on an XDB Server, see the topic Managing Users and XDB Server Access Overview.

Parent topic: Configure DB2 Access


Enabling Security on the Client Workstation

To use XDB Link with DB2, you must enable the Client Security option on your workstation using Options. This option instructs the XDB runtime software to prompt you for a user ID (AuthID) and password when it connects to an location (including the location that represents DB2).

To enable security on a client workstation using Options

  1. At the client workstation, start Options by selecting its icon from the program group or folder.
  2. When the Options window opens, select the Security page and enable the Client Security option.
  3. Click OK to save your settings and close Options.
Parent topic: Configure DB2 Access


Configuring Communications Software on the PC

Use one of the following procedures to configure the communications software on the machine where XDB Link is installed:

  • If XDB Link will connect to the host via TCP/IP, follow the procedure described in the section Configuring TCP/IP Software for the PC.
  • If XDB Link will connect to the host via SNA, follow the procedure described in the section Configuring the Microsoft SNA Server . When the procedure asks you to enter the VTAM APPLID for DB2, enter the VTAM APPLID assigned to the XDB Link Host Option for PEM instead.
Parent topic: Configure DB2 Access
Related information
Configure the PC
Configuring TCP/IP Software for the PC
Configuring the Microsoft SNA Server


Link Utility

  • Configuring the Link for a Gateway Server
  • Starting a GTF Trace
  • Starting the Host Option for TCP/IP
Parent topic: How to...


Configuring the Link for a Gateway Server

To configure the Link for a Gateway Configuration, you must:

  • Run the Gateway Profile Utility locally on the machine where the XDB Server and Link are installed
  • Have super-user privileges that give you write access to the XDB Server's system location tables
  • Check your client application settings in Options to make sure they point to the system location of the local XDB Server

See the Options Utility Overview for instructions.

Parent topic: Link Utility
Related information
Starting a GTF Trace
Starting the Host Option for TCP/IP


Starting a GTF Trace

To start the GTF trace procedure, issue the following command from the MVS console:

S _GTF_procedure

or

S XDBGTF

Respond to the "AHL125A RESPECIFY TRACE OPTION OR REPLY U" message with:

R nn,U

where nn is the WTOR message number.

Parent topic: Link Utility
Related information
Configuring the Link for a Gateway Server
Starting the Host Option for TCP/IP


Starting the Host Option for TCP/IP

To start the Host Option for TCP/IP, issue the following command from the MVS system console:

S Catalogued Procedure name for Host Option for TCP/IP

or

S XDBLink

The following message is displayed on the system console:

@08 Enter XDBLINK Command

Next issue the following command to verify the status of the started task and verify the port number:

R nn,DISPLAY STATUS

where nn is the reply number message related to the Host Option for TCP/IP.

Parent topic: Link Utility
Related information
Configuring the Link for a Gateway Server
Starting a GTF Trace


Migrate Utility

  • To start the Migrate Utility
  • To open and close the Browser
  • To refresh the Catalog Browser
  • To open and close the Schema Viewer
  • To log onto a server
  • To migrate tables
  • To migrate one or more databases
  • To migrate certain rows and columns
  • To replicate data
  • To add SQL to a migration
  • To save your migration specifications
  • To recall a migration specification
  • To run a MIG file without opening it
  • To run a MIG File from the command line
  • To create an SQL script file of the migration
  • To transfer data and its metadata definitions between a DB2 subsystem and an XDB server
Parent topic: How to...


To start the Migrate Utility

  • Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Client > Migrate.
Parent topic: Migrate Utility
Related information
To log onto a server
The Migrate Window


To open and close the Browser

The Catalog Browser is automatically displayed when you open Migrate. To close the Browser, double-click the Control-menu (
*
) button.

*
To reopen the Catalog Browser after it has been closed, click the Catalog Browser button in the toolbar or select the Catalog Browser command from the View menu.

Parent topic: Migrate Utility


To refresh the Catalog Browser

*
To refresh the contents of the Catalog Browser, click the Catalog Browser button, or click Catalog Browser on the View menu. You must do this at the end of a migration in order to display the names of the newly migrated tables.

Parent topic: Migrate Utility


To open and close the Schema Viewer

The Schema Viewer is automatically displayed when you open Migrate. Only one Schema Viewer is active at a time. To close the Schema Viewer, double-click its Control-menu button in the upper-left corner.

Note:

When you close the Schema Viewer, the table and query specifications it contains are discarded.

To open a new Schema Viewer, select the New command from the File menu. When a new Schema Viewer is opened, Migrate clears the current table and query specifications. If you want to save these specifications, you must do so before opening a new Schema Viewer.

Parent topic: Migrate Utility


To log onto a server

When you start Migrate, it attempts to connect to your "default" XDB Server and location. Depending on how your AutoConnect and Security options are set, you receive either the Connect dialog box (from which you can select the server and location to which you want to connect) or you are automatically connected to your default server and location.

  • The Connect dialog box appears if the Security option in Options is enabled, or if AutoConnect is disabled.
  • The Connect dialog box is bypassed if the AutoConnect option in Options is enabled.

See the Options Utility online help for more information about the AutoConnect and Security options.

Parent topic: Migrate Utility


To migrate tables

The procedure in this section describes how to copy tables from one location to another. If you want to migrate only certain rows and/or columns of a table, see Migrating Certain Rows and Columns.

Before you begin, review the following:

  • If you are migrating tables to/from the mainframe, make sure XDB Link is installed and operating properly.
  • If you are migrating tables between servers, make sure the SYSLUNAMES and SYSLOCATIONS tables on the server to which you are connected are configured for all locations to which you need access. See your XDB Server Administration Guide or consult your XDB Server Administrator for information about setting up server-to-server communications.
  • Make sure you have SELECTprivileges on the tables you are migrating and on the following system catalog tables:
    SYSIBM.DATABASE | SYSIBM.SYSRELS
    SYSIBM.SYSCOLUMNS | SYSIBM.SYSSYNONYMS
    SYSIBM.SYSFOREIGNKEYS | SYSIBM.SYSTABLES
    SYSIBM.SYSINDEXES | SYSXDB.SYSLOCALS
    SYSIBM.SYSKEYS | SYSXDB.SYSPROMPTQUERY
    SYSIBM.SYSLOCATIONS | SYSXDB.SYSQUERY

    For more information about system catalog tables, see the SQL Reference or consult your XDB Server Administrator.

    Make sure the Catalog Browser and the Schema Viewer are open.

    *
    Open the Browser by selecting the Catalog Browser button on the toolbar. Open the Schema Viewer by selecting New from the File menu.

    Note:

    The location to which you want to migrate a table must exist. If it does not, you must first create it using a database management tool such as SQLWizard.

  1. In the Catalog Browser, locate and highlight the table you want to migrate.
    • Click the + buttons to expand the hierarchy and show subordinate objects.
    • Tables can be selected and migrated. Databases and locations cannot.

    For more information about using the Catalog Browser, see The Catalog Browser.

  2. Drag the highlighted table to the Schema Viewer. When you release the mouse button in the Schema Viewer, the table's schema displays in the viewer.
    Note:
    • You can double-click the table name to place it in the Schema Viewer.
    • You can hold the Shift or Ctrl key while you click the tables in the Catalog Browser to select multiple tables.
  3. If you want to migrate tables that are dependent on or referenced by a particular table (a referential integrity constraint), click the table in the Schema Viewer (its title bar will be highlighted indicating that it is "selected") and select the Show Dependent or Show Referenced command in the Object menu.

    When you select Show Dependent or Show Referenced, dependent and referenced tables (respectively) are automatically placed in the Schema Viewer along with arrowed lines showing their foreign key/primary key relationships.

    If all the rows of the referenced table are migrated, Migrate processes the DDL and DML so that the referential integrity constraints are not violated. However, if the user intends to restrict the domain of data being processed by Migrate, the domain (subset of the rows) must be defined by using the Define Query command on the Object menu. Queries can then be constructed against the referenced and dependent tables to ensure that only the rows matching the search criteria will be migrated. This will guarantee that foreign key values in the referenced and the dependent tables are consistent with each other. See Migrating Certain Rows and Columns for more information.

    Note:

    You can select the Show Dependent and Show Referenced commands from the control menu. To access this menu, click the Control-menu button in the upper-left corner of the table's schema window.

  4. Click the Table/Query Options * button in the toolbar or select the Table/Query Options command on the Object menu.
    In this field... | Specify the following...
    AuthID The name to be used as the creator of the destination table.

    If you want Migrate to use the source table's Auth ID by default, select the Default To Source checkbox next to the Auth ID text box in the Default Options dialog box before you select Table Options; Migrate will then automatically populate this field with the proper default value. Otherwise, you will need to specify an Auth ID by typing it in text box.

    Table | The name of the table to which you will be migrating the data. If this table doesn't exist, Migrate will create it for you.
    Tbl Space The table space name for the target table to which you will be migrating the data.

    If you want Migrate to use the name of the source table space by default, select the Default To Source checkbox next to the Tbl Space text box in the Default Options dialog box before you select Table Options; Migrate will then automatically populate this field with the proper default value. Otherwise, you will need to specify a table space name by typing it in this text box.

    Database The database name for the target table where you will be migrating the data.

    If you want Migrate to use the name of the source database from which the source table is selected by default, select the Default To Source checkbox next to the Database text box in the Default Options dialog box before you select Table Options; Migrate will then automatically populate this field with the proper default value. Otherwise, you will need to specify a database name by typing it in this text box. If this field is left blank, the default database name "DSNDB04" is used.

  5. In the Migrate group box, select the database objects you want to copy with the table. You can migrate primary keys, unique keys, indexes, foreign keys, synonyms, comments, privileges and distinct types.
    CAUTION:
    If you do not migrate primary keys, unique keys, and foreign keys, applications that are dependent on the database to implement these business rules may not work.
  6. In the If Table Already Exists group box, specify the action you want Migrate to take if the target table already exists.
    Select... | If you want Migrate to...
    Abort | End the migration.
    Append Data | Append the migrated records to the existing table.
    Replace Data | Replace all records in the existing table with the migrated records (all data in the existing table will be deleted).
    Replace Table | Drop the existing table and create a new table with the migrated records.

    For information about the Update No Insert, Update Insert, and Delete Match options, see the instructions for Replicating Data.

  7. In the Limit Data To group box, specify how much data you want Migrate to copy.
    Select... | If you want Migrate to...
    All Rows | Copy all records from the source table to the destination.
    No Data Copy no records from the source table to the destination. You might use this option to create an "empty" destination table (which will have a structure identical to the source) into which you can selectively copy records using Migrate's query feature.

    The behavior of this option depends on the following:

    If the destination table does not exist, an "empty" table is created.

    If the destination table exists, and the Replace Data or Replace Table option is used, the destination table's existing records are deleted and no records are copied (an "empty" table is created).

    If the destination table exists, and the Append Data option is used, no records are copied to it.

    First N Rows | Copy the first N records from the source table to the destination.
    Every Nth Row | Copy every N records from the source table to the destination.
  8. In the Commit Work After group box, specify the number of records Migrate should accrue before permanently writing them to disk (i.e., issuing a COMMIT statement). High Commit Work After values produce a faster migration but result in fewer records successfully written should the migration be interrupted.
  9. Click OK to confirm the settings.
  10. Repeat steps 1 through 9 for each table you want to migrate. If you want to remove a table that you have inadvertently added to the Schema Viewer, select the table in the Schema Viewer, then select the Remove command in the Object menu.
  11. Once all the tables you want to migrate are in the Schema Viewer, open the To drop-down list on the toolbar and select the location to which you want the tables copied.
    Attention: If a location to which you want to migrate records is not listed in the drop-down list, check that you are connected to the correct server and verify that the server has access to the location you need. See your XDB Server Administration Guide or consult your XDB Server Administrator for information about server-to-server communications.
  12. When you are ready to begin the migration, click the Run ( *) button in the toolbar, or from the Commands menu, select Run.
  13. In the Run dialog box, make sure the Execute Migrate checkbox is selected. If this box is not selected, Migrate will not copy any records to the destination. This option can be disabled if you want to generate SQL without performing a migration. See Creating an SQL Script File of the Migration.
  14. In the Migrate Options group box, select the kind of reports and SQL scripts you want Migrate to produce when it migrates your data.
    Select this option... To request...
    Generate SQL A copy of the SQL script used to execute the migration. (This script contains the DDL statements used to define the destination table, but does not contain the individual INSERT statements for each migrated record.)

    In the text-entry field next to the checkbox, type the name of the file to which you want the script written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new SQL script.

    Post Execution Report A report that lists the tables that were migrated.

    In the text-entry field next to the checkbox, type the name of the file to which you want the report written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new report.

    You can specify the same file name for the Post Execution Report and the Error File to combine these two reports into one file.

    Error File A report that lists any errors encountered during the migration. If there are no errors during the migration, this error file will be empty.

    In the text box, type the name of the file to which you want the errors written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new report.

    You can specify the same file name for the Error File and the Post Execution Report to combine these two reports into one file.

    Tip: If you want to produce a report describing the effect of the specified migration, select the Impact Analysis Report. This option gives you a report describing the schemas of the currently selected source and destination tables, without performing the migration. See Generating Reports for more information about this and other reports.
  15. Click OK to start the migration. The migration's progress is reported in the Status bar at the bottom of the window.
  16. When the migration is finished, click the Catalog Browser ( *) button to refresh the contents of the Catalog Browser. The destination tables, if they are new, do not appear in the Browser until you do this.
    Tip: You can save your migration as a MIG file to save time recreating it later. See Saving Your Migration Specifications.
Parent topic: Migrate Utility


To migrate one or more databases

  1. Start the Migrate Utility.
  2. Click Commands > Migrate Database.
  3. From the Database list, click a database you want to migrate, or press Shift or Cntl as you click to select more than one database. This populates the Migrate Tables list with the tables defined for the database or databases you selected.
  4. To exclude one or more tables from the migration, on the Migrate Tables list, select the tables to exclude. To select one table, click it. To select more than one, press Shift or Cntl as you click. Then click Exclude. This puts the table or tables you selected onto the Not Included list. Optional.
  5. To include one or more tables that you previously excluded, on the Not Included list, select the tables to include. Then click Add. This places the selected tables back onto the Migrate Tables list. Optional.
  6. To set options for a table on the Migrate Tables list, click the table, then click Options. On the Table Options dialog box, set the options for the selected table, then click OK. Optional.
    Note:

    The default options for each table are those defined on the Default Options dialog box.

  7. Click Save. In the File name field, type a name for the .mig script file you want to contain the information you specified for this migration, then click Save. Optional.
  8. Click Execute to invoke the Run dialog box.
  9. From the To drop-down list, select a location to migrate to.
  10. Make any necessary changes to the migration options by checking or unchecking the appropriate checkboxes. Optional.
  11. Click OK to perform the migration.
Note:
  • If you choose to save the migration information, the Migrate Utility generates a .mig script file. The script file created here works the same as any other .mig script file except that you cannot view it in the Schema Viewer. However, you can execute it using the Execute Batch command or from the command line as often as you would like. You cannot execute a saved .mig script file from the from the Migrate Database dialog box.
  • Information pertaining to migration execution appears in the Execution Information window. Following successful migration, you can close this window.
Parent topic: Migrate Utility


To migrate certain rows and columns

You can copy certain columns or certain rows from one table to another using Migrate's query feature. You can also use this feature to combine data from different tables into one result.

See Replicating Data if you wish to update, insert, or delete specific rows and columns.

Note:

Migrate's query feature is designed to migrate tables. It is not an all-purpose SQL processor. Do not use it to perform any SQL other than a single SELECT statement; for example, do not try to CREATE or DROP a location. If you need to include SQL with your migration, use prologue and epilogue scripts. See Adding SQL to a Migration.

The procedure in this section describes how to create a query and migrate its result. Before you begin, review the following prerequisites:

  • If you are migrating tables to/from the mainframe, make sure XDB Link is installed and operating properly.
  • If you are migrating tables between servers, make sure the SYSLUNAMES and SYSLOCATIONS tables on the server to which you are connected are configured for all locations to which you need access. See your XDB Server Administration Guide or consult your XDB Server Administrator for information about server-to-server communications.
  • Make sure that you connect to a "non-mainframe" location when you start Migrateyou will not be able to migrate data to any other location, otherwise. See Logging onto a Server.
  • Make sure the Catalog Browser and the Schema Viewer are open.

    *
    Open the Catalog Browser by selecting the Catalog Browser button on the toolbar. Open the Schema Viewer by selecting New from the File menu.

  • Make sure you have SELECTprivileges on the tables you are migrating and on the following system catalog tables:
    SYSIBM.DATABASE | SYSIBM.SYSRELS
    SYSIBM.SYSCOLUMNS | SYSIBM.SYSSYNONYMS
    SYSIBM.SYSFOREIGNKEYS | SYSIBM.SYSTABLES
    SYSIBM.SYSINDEXES | SYSXDB.SYSLOCALS
    SYSIBM.SYSKEYS | SYSXDB.SYSPROMPTQUERY
    SYSIBM.SYSLOCATIONS | SYSXDB.SYSQUERY

    For more information about system catalog tables, see the SQL Reference or consult your XDB Server Administrator.

Note:

The location to which you want to migrate the results of your query must already exist. If it does not, you must first create it using a database management tool such as SQLWizard.

  1. In the From drop-down list, select the location containing the tables you want to query.
  2. In the To drop-down list, select the location to which you want the query result migrated.
    Note:

    If a location to which you want to migrate records is not listed in the drop-down list, check that you are connected to the correct server and verify that the server has access to the location you need. See your XDB Server Administration Guide or consult your XDB Server Administrator for information about server-to-server communications.

  3. Select the Define Query command on the Object menu to display an empty Query window.
  4. In the upper pane of the Query window, enter a Table and AuthID for the result of the query.
    Note:

    If this table does not exist already, Migrate will create it for you. If it does exist, the result of your query must match the existing table's schema exactly. That is, it must produce the same number of columns, of the same size and type, and in the same order as the destination table.

  5. If you want the result stored to a specific database and table space, type their names in the Database and Tablespace fields.
  6. In the lower pane, type a single SELECT statement. If you want to open a saved query that you have created using SQLWizard, double-click its name in the Catalog Browser's Query tab. For more information about recalling a saved query, see The Query Tab.

    You can enter any valid SELECT statement, even those containing joins and unions.

    Note:

    To ensure a successful query, specify your tables using fully-qualified (i.e., three-part) names.

    The following are examples of valid query statements:

    SELECT *
        FROM tutorial.tutorial.employee
        WHERE city = 'miami'
        SELECT e_no, lname, city
        FROM tutorial.tutorial.employee
        SELECT pname, qty
        FROM tutorial.tutorial.part p1,
        tutorial.tutorial.partsupp p2
        WHERE p1.pno = p2.pno
  7. After you have entered a SELECT statement, click the Table/Query Options (
    *
    ) button in the toolbar or select the Table/Query Options command on the Object menu.
  8. In the Query Options dialog box, specify how you want the results of this query written, then click OK. You can specify what action Migrate should take if the destination table already exists, and how many total records should be copied.

    If you need specific information about an option in this dialog box, click Help or see Query Options.

  9. If you want to process multiple queries, repeat steps 1 - 8. Each SELECT statement must use a separate Query window (you can minimize a Query window to reduce screen clutter).
  10. When you have finished specifying the query(s), click the Run
    *
    button in the toolbar, or select the Run SQL command on the Commands menu.
  11. In the Run dialog box, make sure the Execute Migrate check box is selected. If this box is not selected, Migrate will not copy any records to the destination. This option can be disabled if you want to generate SQL without performing a migration. See Creating an SQL Script File of the Migration.
  12. In the Migrate Options group box, select the kind of reports and scripts you want Migrate to produce when it migrates your data.
    Select this option... To request...
    Generate SQL A copy of the SQL script used to execute the migration. (This script contains the DDL statements used to define the destination table, but does not contain the individual INSERT statements for each migrated record.)

    In the text-entry field next to the checkbox, type the name of the file to which you want the script written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new SQL script.

    Post Execution Report A report that lists the tables that were migrated.

    In the text-entry field next to the checkbox, type the name of the file to which you want the report written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new report.

    You can specify the same file name for the Post Execution Report and the Error File to combine these two reports into one file.

    Error File A report that lists any errors encountered during the migration. If there are no errors during the migration, this error file will be empty.

    In the text box, type the name of the file to which you want the errors written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new report.

    You can specify the same file name for the Error File and the Post Execution Report to combine these two reports into one file.

    Note:

    If you want to produce a report describing the effect of the specified migration, select the Impact Analysis Report. This option gives you a report that describes the schemas of the currently selected source and destination tables without performing the migration. See Generating Reports for more information about this and other reports.

  13. Click OK to start the migration. The migration's progress is reported in the Status bar at the bottom of the window and in a progress window.

    When a migration is processed, queries are processed after any tables in the Schema Viewer. When multiple queries are specified, they are processed in window-number order.

  14. When the migration is finished, click the Catalog Browser (
    *
    ) button to refresh the contents of the Catalog Browser. The destination tables, if they are new, do not appear in the Browser until you do this.
    Note:

    You can save your migration as a MIG file to save time recreating it later. See Saving Your Migration Specifications.

Parent topic: Migrate Utility


To replicate data

Production database users can specify insert, update, and delete actions for tables that already exist. The instructions for replicating data are the same as Migrating Certain Rows and Columns, with the following exceptions:

  • In the Query Options window, choose one of the following options from the "If table already exists" group:
    • Update No Insert

      update the information only if a row with the key already exists

    • Update Insert

      update the existing row, or insert new row

    • Delete Match

      delete existing matching row

  • In the Define Query window, if you selected either the Update No Insert option or the Update Insert option, click the Update Rule button. In the Query Update Rules window:
    1. Identify the key fields.
    2. The Update Rule value of each field will change between None and Replace, depending on whether or not the field is a key.
      • Replace

        overwrite existing data with new data

      • None

        take no action

Parent topic: Migrate Utility


To add SQL to a migration

Migrate gives you two ways to incorporate additional SQL in a migration.

  • You can execute a "prologue script" script before the migration to perform preparatory operations such as location creation and table initialization. A prologue script can be any batch SQL file containing valid SQL statements.

    To include a prologue script, select the Prologue option in the Migrate Options dialog box when you execute the migration. In the text box next to this option, specify the name of the SQL file that you want Migrate to run.

  • You can execute an "epilogue script" script after the migration to perform "housekeeping" operations such as dropping temporary tables or creating an index. An epilogue script can be any batch SQL file containing valid SQL statements.

    To execute an epilogue script, select the Epilogue option in the Migrate Options dialog box when you execute the migration. In the text box next to this option, specify the name of the SQL file that you want Migrate to run.

    Note:

    Prologue and Epilogue SQL statements are executed against the destination location.

Parent topic: Migrate Utility


To save your migration specifications

Once you have specified a migration, you can save your specifications so they can be reused at a future date. To save a migration, select the Save As command from the File menu. In the Specify Batch File dialog box, specify a file name and click OK.

Note:

If a Query window is active when you select Save As, you can save just the query (to an SQL file) or the entire migration (to a MIG file). To specify which type of file you want Migrate to create, select *.SQL or *.MIG in the Save As dialog box before you click OK.

Migration specifications are saved in MIG files. A MIG file records the following information about a migration:

  • Source and destination settings
  • Tables selected for migration
  • Query statements
  • Table, query and run option settings
  • Migration option settings, including prologue and epilogue script specifications.

Using a MIG file, you can run a migration in "batch mode" (that is, run the migration without respecifying its options manually). Batch mode is useful for executing a migration that is run on a regular basis, or for running a migration in unattended mode. For information about running a migration from a MIG file, see Recalling a Migrate Specification.

Parent topic: Migrate Utility


To recall a migration specification

If you have saved your migration specifications to a MIG file, you can recall the specifications using the Open command on the File menu.

Note:

When you open a MIG file, the specifications from the file replace the current migration specifications. If you want to preserve your current specifications, save them before opening a MIG file.

After opening a MIG file, you can examine and modify its specifications before executing the migration. (If you want to save the revised migration, use the Save or Save As command on the File menu.)

You can view the contents of a MIG file using the Batch Commands command on the View menu. After the file is displayed, you can print it using the Print command on the File menu.

Parent topic: Migrate Utility


To run a MIG file without opening it

Migrate's Execute Batch command lets you run a migration without opening the MIG file in the Migrate window. To run a MIG file in this way, select Execute Batch from the File menu. In the Select Batch File dialog box, select the MIG file you want to run. When you click OK, the migration is immediately executed.

The Execute Batch command does not affect the current migration settings (e.g., selected tables and options). Specifications in effect before Execute Batch is invoked will be in effect when execution of the MIG file is complete.

Parent topic: Migrate Utility


To run a MIG File from the command line

If you have saved your migration specifications to a MIG file, you can rerun the migration without opening Migrate. This is done by invoking Migrate from your development environment's command prompt and giving it the name of your MIG file.

The command used to invoke Migrate with a MIG file is as follows:

xmig40n -bMIGFile -iINIFile

where:

MIGFile | is the name of your MIG file. If this file isn't in the application path specified in the Path tabs of Options, you must specify the path in addition to the filename.
INIFile | is the name of the initialization file under which you want Migrate initialized. If you don't include the -i parameter, Migrate uses XDB.INI in the current working directory.
Parent topic: Migrate Utility


To create an SQL script file of the migration

To create a script file containing the DDL statements used to perform the migration, select the Generate SQL checkbox in the Run dialog box when you execute the migration. In the text-entry field next to the checkbox, type the name of the file to which you want the script written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new script.

Note:

The script that Migrate creates contains only the DDL statements that define the destination table. It does not contain individual INSERT statements for each migrated record.

You can use the SQL command on the View menu to display the contents of an SQL script file, including one to which you have saved migration SQL.

When the Select SQL File dialog box is displayed, select the SQL file and click OK.

After the file is displayed, you can print it using the Print command on the File menu.

Parent topic: Migrate Utility


To transfer data and its metadata definitions between a DB2 subsystem and an XDB server

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> SQL Option for DB2 > Client > Migrate.
  2. Specify the information required
  3. Click OK.
Parent topic: Migrate Utility


Options Utility

  • To enable client security
  • To change the default XDB Server
  • To define and configure remote DB2 data locations
  • To enable connection to a new remote XDB Server
  • To set up or configure an XDB Server's parameters
Parent topic: How to...


To enable client security

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> SQL Option for DB2 > Configuration > Client Options.
  2. Click the Security tab.
  3. Select Client Security Enabled.
  4. Click OK.
Parent topic: Options Utility


To change the default XDB Server

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> SQL Option for DB2 > Configuration > Client Options.
  2. Click the Connect tab.
  3. In the Network Info group, choose a server from the Server Name list.
  4. Click OK.
Parent topic: Options Utility
Related information
To start the XDB Server
To stop the XDB Server


To define and configure remote DB2 data locations

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 > Configuration > Link Profile.
  2. Specify the information required
  3. Click OK.
Parent topic: Options Utility


To enable connection to a new remote XDB Server

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> SQL Option for DB2 > Configuration > Client Options.
  2. Click the Connect tab.
  3. In the Network Info group, type the server name in the Server Name field.
  4. Select the communications protocol you want to use to connect to the XDB Server from the list.
  5. In the Connect To group, type a default location for the new server.
  6. Type the AuthID you want to user to connect to the new server.
  7. Click OK.
Note:

Some communications protocols require additional information to be specified in the xdb.ini file. Contact your system administrator if you experience difficulty in connecting to a new server.

Parent topic: Options Utility


To set up or configure an XDB Server's parameters

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x> SQL Option for DB2 > Configuration > Server Configuration.
  2. Specify the information required.
  3. Click OK.
Parent topic: Options Utility


SQL Wizard

  • To start SQL Wizard
  • To exit SQL Wizard
  • Use the Catalog Browser
  • Manage Databases
  • Query Databases
  • Work with Query Results
  • Use the Result Window for Data Entry
  • Import Files
  • Export Files
  • Use Batch SQL Scripts
  • Administer XDB Users and Groups
  • Implement Security and Authority
Parent topic: How to...


To start SQL Wizard

  • Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 > Client > SQL Wizard.

The Connect Dialog Box

The Connect dialog box is used to specify the XDB Server you want to use with SQLWizard and to enter a password if one is required.

The Connect dialog box may or may not be displayed when you start SQLWizard, depending on certain settings you make in the Options Utility. Likewise, certain items may or may not be selectable, depending on the settings in Options.

To use the Connect dialog box:

  1. Type the name of the XDB Server you want to access, or click the down arrow button next to the Server field to select an XDB Server from the drop-down list.

    To connect to an XDB Server that you never used before, run the Options utility before starting SQLWizard. Use the Connect tab in Options to set up the communication protocol, client node name, and default location.

    If the server name is displayed as a label rather than in a text-entry field, you cannot select or type a different server name.

  2. In the Location field, type the name of the location you want to access, or click the Browse button to select a location from the Browse Dialog box. The Browse Dialog box shows all locations known to the selected XDB Server.
    Note:

    Each time you access the Browse Dialog box, the selected XDB Server is checked for the list of all known locations available and you are logged in to the specified XDB Server with the current AuthID and password. If security is on, you must have SELECT privileges on the XDB Server's system location for this feature to operate correctly. (For more information, refer to the description of the WSQL043 message in online help.)

    If you do not click the location drop-down list, the XDB Server is not accessed until you connect.

  3. Type your AuthID in the Username field. If you need to access a multi-user XDB Server on the LAN, ask your XDB Server Administrator what AuthID to use.
  4. If security is turned on, type your password. Asterisks (*) are displayed for each character you type to prevent others from seeing your password.
    Note: Passwords are case-sensitive; be sure to use the correct combination of upper and lower case letters.

    If security is off, the Password field will not be displayed on the Connect dialog box.

  5. After making your selections, click OK to start SQLWizard and connect to the specified XDB Server and location.
    Note: If the Catalog Browser is set up to load on SQLWizard startup and the location you are trying to connect is an XDB Link location, a transaction dialog box appears. This dialog box asks you to complete the transaction to free up locks and close queries. Of the three options the dialog box presents you with, Commit and Rollback free the locks, while Proceed keeps them in place. Keeping the locks interferes with other DB2 users who are attempting to perform Data Definition Language (DDL) SQL statements.

If you enter your AuthID or password incorrectly, an error message is displayed. You have three chances to enter the correct AuthID and password.

Parent topic: SQL Wizard


To exit SQL Wizard

You exit SQLWizard in just the same way you exit most other standard Windows or Presentation Manager applications.

To exit SQLWizard:

  1. Click the File menu to open it.
  2. Click the Exit command.

Optionally, you can double click the Control Menu button in the top left corner of the SQLWizard main window.

If there are open windows on your SQLWizard screen and you have not yet saved changes, you will be asked if you want to save before exiting. If you answer yes, you may be asked to provide a name for the object being saved, just as if you had clicked the Save As command in the File menu. If you answer no, the changes will be discarded. If you click Cancel, SQLWizard remains running and all open windows remain open.

Parent topic: SQL Wizard


Use the Catalog Browser

  • Accessing the Catalog Browser
  • Closing the Catalog Browser
  • Opening Tables with the Catalog Browser
  • Opening Queries with the Catalog Browser
  • Selecting Items
  • Select and Drag
  • Filtering Items in the Catalog Browser
Parent topic: SQL Wizard


Accessing the Catalog Browser

To access the Catalog Browser, click the Catalog Browser button on the toolbar. Alternatively, click the Locations, Tables, or Queries command from the View menu.

Catalog Browser Button * | The Catalog Browser button on the toolbar makes the Catalog Browser dialog box active. This button is useful when the Catalog Browser dialog box is covered by other SQLWizard windows or when the Browser's AUTOSTARTUP feature has been turned off.
View Menu Commands | The first three commands in the View menu always change the active window to the Catalog Browser dialog box. The Locations command displays the Location tab. The Tables command displays the Table tab, and the Queries command displays the Query tab.
Parent topic: Use the Catalog Browser


Closing the Catalog Browser

By default, the Catalog Browser dialog box opens when you start SQLWizard. To prevent the Catalog Browser dialog box from automatically loading when you start SQLWizard, turn off AUTOSTARTUP on the Browser tab in the Options utility.

To close the Catalog Browser dialog box, use the Control or Close button in the title bar.

Note:

To provide quick access to system catalog information, the Catalog Browser dialog box is never actually closed while SQLWizard is active. When you close the Catalog Browser dialog box, SQLWizard just hides it. This improves performance by keeping the Catalog Browser dialog box active in memory, which reduces the need to continually re-query the system catalog tables.

Parent topic: Use the Catalog Browser


Opening Tables with the Catalog Browser

You can use the Catalog Browser to open a table for viewing or editing.

To examine and open tables from the Catalog Browser:

  1. Access the Catalog Browser dialog box, then click the Table tab. Notice the list of locations, each preceded by a + button.
  2. Click a Location's + button to display a list of AuthIDs. Each AuthID is preceded by a + button.

    Notice that as you click each + button, SQLWizard displays a list of the sub-items for that object, and replaces the + button with a - button. Click the + button to expand an object list and the - button to collapse the list. If no button appears next to an item, no sub-items are available.

  3. Click the + button preceding an AuthID. SQLWizard displays the Tables/Views/Synonyms/Aliases objects.
  4. Click the + button in front of Tables to see a list of the tables.
  5. Click the + button preceding a table. SQLWizard displays a list of columns in the table. The Catalog Browser lets you view the column names in your table without displaying the table. Click the - button to remove the columns from the Catalog Browser display.
  6. Click a table name to highlight it.
  7. Click the Open button, or click and drag the table's name to the SQLWizard desktop.

    SQLWizard displays the table in a Result window.

  8. Close the Result window using the Close command from the File menu, or double click the Control Menu box in the upper left corner of the window.
Parent topic: Use the Catalog Browser


Opening Queries with the Catalog Browser

You can use the Catalog Browser to open a previously saved query. Once open, you can run the query. If desired, you can change the query before running it. Optionally, you can use the Catalog Browser to run a query in Batch mode (without first opening and displaying it).

To examine and open queries from the Catalog Browser:

  1. With the Catalog Browser dialog box displayed, click the Query tab.

    The Catalog Browser lists the locations, the AuthIDs, and the queries available to you from your current server. If you do not see these three levels of organization, click the + buttons preceding locations and AuthIDs to expand the detail beneath them.

  2. Click a query name to highlight it.
  3. Click the Open button or drag the query's name to the SQLWizard desktop.

    SQLWizard displays the query for you to view, edit, or run.

Parent topic: Use the Catalog Browser


Selecting Items

To select an object in the Catalog Browser dialog box, click its name or on the object icon. SQLWizard highlights the object that you select.

Double clicking on an object performs the default command for that object. For example, double clicking on a table is the same as selecting the table and then clicking the Open button.

You can select more than one item by holding down Ctrl while you click an item with the mouse. For example, you can Ctrl+click to select multiple tables, release Ctrl, and then click Open to display the Result window.

You can select a contiguous group of objects by first using the mouse to click the name of the first one; then while holding down Shift, click another object further up or down the list to select all objects in between, including the first and last objects you clicked. Once the desired objects are highlighted, release Shift and click Open to display the Result window.

Parent topic: Use the Catalog Browser


Select and Drag

You can select (highlight) one or more tables and drag them to the Query Design or SQL Edit window. You can select multiple columns and drag them to an SQL Edit window or a Create/Alter Table window. Dragging a table name to the SQLWizard desktop will open the table (displaying the data in a Result window).

The mouse pointer changes shape to indicate where you can drop the object.

*
When the mouse pointer is in the Catalog Browser or in an area where you can drop the object, the mouse pointer appears as a pile of papers.

*
When the mouse pointer is in an area that cannot accept the object, the mouse pointer appears as the international NO symbol.

Note:

You can select from only one hierarchy level at a time.

Parent topic: Use the Catalog Browser


Filtering Items in the Catalog Browser

The Set Database/Authid/Table Filter dialog box (displayed by clicking Filter on the Catalog Browser's Location tab) enables you to control the databases, AuthIDs and table items that are displayed in the Catalog Browser for any particular location.

To specify the desired pattern of characters (or filters) for the database, AuthID, and table levels, specify values into the Database Pattern, Authid Pattern, and Table Pattern text boxes respectively. Clicking OK refreshes the Catalog Browser according to the filter settings entered in these text boxes. If no error occurs, the filter settings are saved to the xdb.ini file.

The values you specify in the Database Pattern, Authid Pattern, and Table Pattern text boxes must follow DB2's rules for specifying character patterns for the SQL LIKE predicate. The following examples use the TUTORIALS location:

  • Database Pattern: DSN%

    Authid Pattern: TUT%

    Table Pattern: PART%

    This set of filters will only make databases whose names begin with "DSN" visible in the Catalog Browser. If a database object is expanded, only tables that begin with the string "PART" under an authid that begins with the string "TUT" will be displayed. In this case, two tables, TUTORIAL.PARTS and TUTORIAL.PARTSUPPS would match.

  • Authid Pattern: TUTORIA_

    Table Pattern: PART____

    This set of filters uses the underscore character (_) to match any given character. In this case, there is one underscore at the end of the authid pattern (TUTORIA_) and four underscores in the Table Pattern (PART____) so table TUTORIAL.PARTSUPP would be a match.

Parent topic: Use the Catalog Browser


Manage Databases

  • To view and copy SQL statements
  • Changing Your Current Location and SQLID
  • Creating a Location
  • Altering a Location
  • Dropping a Location
  • Creating a Table
  • To create a new table
  • Altering a Table
  • To edit a table
  • Dropping a Table
  • To drop a table
  • To change the structure of a table
  • Creating an Index on a Table
  • Altering an Index
  • Dropping an Index
  • Creating a Foreign Key Relationship
  • Altering a Foreign Key Relationship
  • Dropping a Foreign Key Relationship
  • To create a new index or key
  • To change an index or key
  • To drop an index or key
  • To create new relationships
  • To change relationships
  • To drop relationships
  • Creating Synonyms
  • Dropping Synonyms
  • Creating Aliases
  • Dropping and Altering Aliases
Parent topic: SQL Wizard


To view and copy SQL statements

  1. Enter data into the fields on a Create, Alter, or Drop dialog box as described elsewhere.
  2. Click the SQL button to access the Show SQL window and display the resulting SQL statement.
  3. Use your mouse to highlight the desired text. Click the Copy command from the Edit menu.
  4. Switch to your editor or open an SQL Edit window (from the File menu, click New, then click SQL).
  5. With your cursor positioned in the desired destination text field, click Paste from the Edit menu.
  6. Return to SQLWizard and close the Show SQL window and return to the Create, Alter, or Drop dialog box you were using.
Parent topic: Manage Databases


Changing Your Current Location and SQLID

SQLWizard allows you to connect to a different location than the one you are currently using without exiting the program. If you have an alternate AuthID, you can change that also. These changes are made by clicking on the Set Location command from the Location menu or by clicking the Set button on the Catalog Browser dialog box.

In some cases, it may not be necessary to change to another location. For example, to query data that resides in another location of the XDB Server to which you are connected, simply enter a three-part name for the table being queried. It is also possible to set up alias names for tables in other locations.

Note: To change to a location on another XDB Server on your LAN, you must exit SQLWizard and restart it, choosing the desired server and location when the Connect dialog box appears. To change your default XDB Server and Location, use the Connect tab in the Options utility. If your organization uses the server-to-server connectivity features, you can access locations on multiple XDB Servers without having to log on to each individually.

To set the current location and SQLID:

  1. From the Location menu, choose the Set Location command.
    Note:

    *
    From the Catalog Browser dialog box, click the Location tab; then click the Set button.

    SQLWizard displays the Set Location/SQLID dialog box.

  2. Enter a location name in the Current Location field or select a location from the drop-down list. For more about setting locations, see the description for the Set Location command in the .
  3. Enter a new SQLID if you wish to work using a different name. (Note that you are still logged in as the AuthID you used at the Connect dialog box, even though you changed your SQLID to a different name.) For more about CURRENT SQLID, see the description for the Set Current SQLID command.
  4. Click OK to accept the changes. The current location and SQLID are displayed in the status bar at the bottom of the SQLWizard window.
Parent topic: Manage Databases


Creating a Location

When SQLWizard creates a location, the system creates a directory structure for the new location, as well as all of the system catalog tables required by the location. Information about the new location is added to the catalog tables in the SYSTEM location. You create a location using the Create command from the Location menu. See Create/Alter/Drop Location Dialog Box for an explanation of each option on this dialog box.

To create a location:

  1. Click the Create command from the Location menu.
    Note:

    *
    From the Catalog Browser dialog box, click the Location tab; then click the Create button.

    SQLWizard displays the Create Location dialog box.

  2. Provide a name for the new location in the Location Name field. The name can be up to 16 characters long. This name must be unique among all locations you can access on the current XDB Server. To be sure you do not attempt to use the name of an existing location, click the down-arrow button to view the existing names on the drop-down list.
  3. Provide a drive and directory in the Location Path field. SQLWizard creates the location in this directory. Use a different directory for each XDB Server location you create. Do not use an XDB Server location directory for storing anything else.
  4. If you want to change the name of the file to which the Forward Log is written, type a new name in the Forward Log Name field (in XDB Server version 4.x and earlier, only).
  5. If you want to change the directory to which the Forward Log is written, type a new path name in the Forward LogPath field (in XDB Server version 5 and later; the Backward Log is placed in this directory too).

    If possible, assign the log file to a physical device different from that of your database. This will ensure that you can recover if the disk containing your database fails.

    Note:

    You must specify a directory that will be used exclusively for this location's log files. Be certain not to specify a directory that is already assigned to another location.

    The directory path is limited to 255 bytes. This restriction is due to limits imposed by the XDB SYSTEM location.

  6. If you want to disable forward logging, clear the Forward Log On checkbox (XDB Server version 4.x and earlier, only; this checkbox will be grayed if you're running version 5 or later).

    Since the forward logging facility used by XDB Servers version 4.x and earlier increases your overhead, you may choose not to use it for performance reasons. Be aware, however, that disabling this option will significantly limit your ability to recover data in the event of a failure.

  7. Select a Sort Sequence for the location, or use the default specified. Click the down-arrow button to view the existing options on the drop-down list. The sort sequence is used for XDB Server indexes, as well as for user-program sorts.
  8. Click OK to create the location.
Parent topic: Manage Databases


Altering a Location

Once you have created a location, you cannot change its name, path, or sort sequence. You can change the Location Creator, Forward Log settings, and Remarks as necessary.

To alter a location:

  1. Click the Alter command from the Location menu.
    Note:

    *
    From the Catalog Browser dialog box, choose a location from the Location folder and click the Alter button.

    SQLWizard displays the Alter Location dialog box .

  2. Specify the name of the location you want to alter in the Location Name field. Click the down-arrow button to view the existing names on the drop-down list. SQLWizard reads the system catalog entries for the location and displays the appropriate information.

    Optionally, you can type a name in the Location Name field instead of choosing a name from the drop-down list. If you type a location name, be sure to click a different field on the window to let SQLWizard know that you are done typing.

  3. Modify fields by typing in new information.
    Note:

    You cannot change the Location Path. This field is disabled.

  4. Click OK to accept the location changes.
Parent topic: Manage Databases


Dropping a Location

When you drop a location, its directory and all of the tables, indexes, and associated files are deleted. You cannot reverse this process. Use the Drop command with care!

Note:

To drop a location, you must be connected to a different location. To change your current location, click Set Location on the Location menu.

You cannot drop a location to which you are attached. If you receive the error "X131:Attempt to drop location in use" when dropping a location, exit SQLWizard and restart the program, logging onto a different location. Then drop the other location.

To drop a location:

  1. Click the Drop command from the Location menu.
    Note:

    *
    From the Catalog Browser dialog box, choose a location from the Location folder and click the Drop button.

    SQLWizard displays the Drop Location dialog box.

  2. Specify the name of the location you want to drop in the Location Name field. Click the down-arrow button to view the existing names on the drop-down list. SQLWizard reads the system catalog entries for the location and displays the appropriate information.

    Optionally, you can type a name in the Location Name field instead of choosing a name from the drop-down list. If you type a location name, be sure to click a different field on the window to let SQLWizard know that you are done typing.

  3. Review the information to verify that this is the location you want to drop and that you are currently connected to a different location. Your current location is displayed in the status bar at the bottom right of the SQLWizard window.
  4. Click OK to drop the location.
  5. Click OK to confirm dropping the location.
Parent topic: Manage Databases


Creating a Table

You can use SQLWizard to create and manage your database tables. You can define indexes, primary keys, foreign keys, synonyms, and aliases using buttons available from the Create Table dialog box.

To create a table:

  1. Click the Create command from the Table menu.
    Note:

    *
    From the Catalog Browser dialog box, click the Table tab; then click the Create button.

    SQLWizard displays the Create Table dialog box.

  2. Type a name in the Table Name field. You can enter a one, two, or three-part name.
    Note:

    If you create a table in a different location than your current location, SQLWizard performs a connect to that location and then resets the location after the create is complete.

  3. Position the cursor in the Column Definition Grid in the lower half of the dialog box. Start in Field Name of Fld No. 1 and type a name for the first column of your table.

    You must define at least one column in the table when you create it. You can alter the table later to add, delete, or move columns.

  4. Position the cursor in the Data Type field to display a down-arrow button. Click the down-arrow button to display a drop-down list of data types. (This button does not become visible until the cursor is positioned in the Data Type field.) Choose a data type from the list.

    Alternatively, you can type a data type without displaying the list. Usually, the first letter you type is enough; SQLWizard completes the entry.

  5. Provide Length and Not Null information, or accept the defaults.
  6. Add, delete, or move rows as desired.

    Add rows to the table by clicking on the + button, while the cursor is inside the Column Definition Grid. The + button adds a row immediately after the row of the cursor's position. (Alternatively, press the keyboard down arrow cursor key to move the screen cursor down to a new row.)

    Delete a row by clicking on a number under the Fld. No. column to select a row. Click the - button to delete the selected field number from the list. You can select any number of rows to be deleted at one time.

    Move a column definition up or down in the list by selecting the row to move and clicking on its field number under the Fld No. column. Click the up or down arrow buttons to move the fields up or down the list, one row at a time. You can move more than one row at a time if you highlight contiguous rows by clicking on the field-number button on the left.

  7. If your table requires the specification of options relating to compatibility with DB2 or another supported database, click the Options button to display the Table Options dialog box. When you have finished specifying table options, click OK to return to the Create Table dialog box.
  8. Click OK to create the table.
Parent topic: Manage Databases


To create a new table

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. If the Catalog Browser window is not open, click
    *
    to open it.
  3. On the Catalog Browser window, ensure the Table tab is selected.
  4. Click Create.
  5. Type a name for the table in Table Name.

    If you use a three-part table name and the location is not the current one, a temporary connection to the new location is established.

  6. Define the columns (fields) in your table by typing a column name, data type, length and whether nulls are accepted in the appropriate fields.

    To define a new column, click +.

  7. When you have finished, click OK to create the table.
Parent topic: Manage Databases


Altering a Table

The Alter Table dialog box lets you add, change, or delete a table's columns, as well as to add or change an existing table's indexes, primary keys, foreign keys, synonyms, and aliases.

If you are running against an XDB Server (local or multi-user), just about any part of a table specification can be altered, even if the table already contains data. You can rename the table or its columns, change column data types, change the ordering of the columns, and add or drop columns.

Note:

If you are running against DB2, there are limits on the changes you can make to a table because the DB2 ALTER TABLE statement is not as comprehensive as the XDB Server ALTER TABLE statement. When connected to DB2 via XDB Link, only those functions that are supported on DB2 (such as adding columns) are enabled on the Alter Table dialog box.

To alter a table:

  1. Click the Alter command from the Table menu.
    Note:

    *
    From the Catalog Browser dialog box, click the Table tab and choose a table; then click the Alter button.

    SQLWizard displays the Open dialog box.

  2. Choose a table and click OK. SQLWizard displays the Alter Table dialog box.
  3. Modify the table specification as you wish. Making changes is similar to the initial entry of table specifications when creating a table.
    Note:

    If you wish to change the data type of an existing field, be sure that the new data type is compatible with the old data type. For example, you would not be allowed to change a date field to a decimal field. Other changes may be possible, but not desirable, such as changing an integer field to a character field.

  4. Click OK to alter the table.
  5. Click OK to confirm the table alterations.
Parent topic: Manage Databases


To edit a table

Before you start, ensure that the current location is set to the location where the table resides.

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. If the Catalog Browser window is not open, click
    *
    to open it.
  3. On the Catalog Browser window, ensure the Table tab is selected.
  4. Click the table you want to edit.
  5. Click Open.
  6. Enable editing by clicking Allow Editing on the Record menu.
  7. Edit the table as required.
  8. Close the Result Table window.
Parent topic: Manage Databases


Dropping a Table

When you drop an XDB Server table, SQLWizard deletes all files associated with the table and removes its entries from the system catalog. Related indexes, keys, and relationships are also dropped. You cannot reverse a drop table action. Use the Drop command with care!

To drop a table:

  1. Click the Drop command from the Table menu.
    Note:

    *
    From the Catalog Browser dialog box, click the Table tab and choose table; then click the Drop button.

    SQLWizard displays the Open dialog box.

  2. Choose a table and click OK. SQLWizard displays the Drop Table dialog box.

    The table definition is shown so that you can verify it is the table you wish to drop. All fields in this window are disabled except for the five main buttons on the right.

  3. Click OK to drop the table.
  4. Click OK to confirm dropping the selected table.
Parent topic: Manage Databases


To drop a table

To drop a table in the current location:

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. If the Catalog Browser window is not open, click
    *
    to open it.
  3. On the Catalog Browser window, ensure the Table tab is selected.
  4. Click the table you want to drop.
  5. Click Drop.
  6. Click OK to confirm your request.

SQL Wizard deletes the files associated with the table and removes the entries about the table from the system catalog.

Note: You cannot recover a table once it has been dropped.
Parent topic: Manage Databases


To change the structure of a table

Before you start, ensure that the current location is set to the location where the table resides.

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. If the Catalog Browser window is not open, click
    *
    to open it.
  3. On the Catalog Browser window, ensure the Table tab is selected.
  4. Click the table you want to alter.
  5. Click Alter.
  6. Change the column definitions, indexes, keys and relationships as required.

    You can look at the SQL statements that will be used to make your changes by clicking SQL at any time.

  7. Click OK.
Note: XDB databases support extensive alterations to a table, even if it contains data. DB2 databases support a much more restricted set of alterations. If the target database is a DB2 database, unsupported options are not available on the Alter Table window.
Parent topic: Manage Databases


Creating an Index on a Table

After defining the columns for your table, you are ready to define its indexes. You can define an index when you create the table, or you can use the Alter Table window to define an index for an existing table.

Options are provided for compatibility with DB2 and other XDB Server-supported databases.

To create an index:

  1. Click the Create command from the Table menu to display the Create Table or Alter Table dialog box, or click the Alter command to display the Open Table dialog box and choose a table. If you are creating a new table, or you need to change the column specifications for an existing table, make the column entries before proceeding.
    Note:

    *
    From the Catalog Browser dialog box, click the Table tab; then click the Create button, or choose a table and click the Alter button

  2. Click the Create button in the Indexes and Keys group box.

    SQLWizard displays the Create Index dialog box.

  3. Type a name for your index in the Index Name field.
  4. Choose the type of index by clicking one of the three types in the Type group box: Index, Unique Index, or Primary Key.
  5. Choose the column(s) you wish to use as the key for the index. Any column names included in the Index Columns list when you exit the Create Index dialog box are used as your index key(s). Use the following descriptions as a guide for choosing columns.

    To move a column name from one list to the other, click its name to highlight it; then click the right or left arrow button to move it to the other list. Alternatively, double-click a column name to move it to the other list.

    To select multiple contiguous items, hold down the Shift key when clicking on the first and last entry of the desired list of names. To select multiple non-contiguous items, hold down the Ctrl key while clicking on each item you want to select. When the desired items are highlighted, click the appropriate arrow button to move them to the other list.

    To move all column names from one list to the other, click a double-arrow button.

  6. To change the order of columns in the Index Columns list, click a column name and click the up- or down-arrow button.
  7. Click the Options button to specify additional index items.

    Most of these additional options are provided for compatibility with DB2 or other XDB Server-supported databases. For DB2, these include the equivalents of USING BLOCKS, FREE BLOCKS, CLUSTERS, BUFFER POOLS and other options.

  8. Click OK to accept the index definition.

    SQLWizard adds the name of the new index to the Indexes And Keys group box, preceded by a + sign to indicate a new index definition.

  9. Click OK from the Create/Alter Table dialog box to create the new index.

    SQLWizard creates the new index definition for the selected table.

Parent topic: Manage Databases


Altering an Index

When you alter an index, the index is actually dropped and recreated using your new specifications.

Additional options are provided for those requiring compatibility with mainframe DB2 or other XDB Server-supported databases.

To alter an existing index:

  1. Click the Alter command from the Table menu.

    SQLWizard displays the Open Table dialog box.

  2. Choose the desired table and click OK. If you need to change column specifications for an existing table, make these entries before proceeding.
    Note:

    *
    From the Catalog Browser dialog box, click the Table tab and choose a table; then click the Alter button.

  3. Choose an index from the Indexes And Keys list on the Alter Table dialog box either by double clicking on an index name or by highlighting a name and clicking the Alter button.
  4. Modify the column selection using the arrow buttons.
  5. Change any DB2-related index items by clicking on the Options button. These include the equivalents of Using Blocks, Free Blocks, Clusters, Buffer Pools and other options.
  6. Click OK to accept the changes.

    SQLWizard returns you to the Alter Table dialog box. An asterisk (*) precedes the index entry in the Indexes And Keys list to show that the index definition has been changed.

  7. Click OK to exit the Alter Table dialog box.
  8. Click OK to confirm altering the table.

    SQLWizard modifies the index specifications on the selected table.

Parent topic: Manage Databases


Dropping an Index

When you drop an index using the Alter Table facility, there is no effect on the table data because the index is a structure independent of the table.

Once index specifications are saved for a table, you can drop them by reopening the Create/Alter/Drop Table dialog box and accessing the Alter Index dialog box. You can also use the Undo button from this dialog box to cancel a drop index specification before resaving the table information from the Create/Alter/Drop Table dialog box. Once completed, SQLWizard drops the old index and creates a new one using the new specifications you provide, if any.

To drop an index:

  1. Click the Drop command from the Table menu.

    SQLWizard displays the Open Table dialog box.

  2. Choose the desired table and click OK.

    SQLWizard displays the Drop Table dialog box.

    Note:

    *
    From the Catalog Browser dialog box, click the Table tab and choose a table; then click the Drop button.

  3. Choose an index from the Indexes And Keys list on the Drop Table dialog box by highlighting a name and clicking the Drop button.

    SQLWizard modifies the index entry by preceding it with a - sign to indicate it will be dropped when exiting the Drop Table dialog box.

    Note:

    If you decide you want to keep an index before exiting the Drop Table dialog box, double click the name of the index to display the Drop Index dialog box. Click the Undo button. The - sign will be removed and the index will remain intact.

  4. Click OK from the Drop Table dialog box to drop all indexes that have the - sign.
  5. Click OK to confirm altering the table.

    SQLWizard drops the selected indexes on the selected table.

Parent topic: Manage Databases


Creating a Foreign Key Relationship

You can create a foreign key when you are creating or altering a table. Instructions on how to create a foreign key are provided below.

To create a foreign key relationship:

  1. Verify that your key columns in the referenced table and the dependent table have the same data types, sizes, and null status. You can examine these column attributes using the Catalog Browser dialog box.
  2. Display the Create Table or Alter Table dialog box for the dependent table. This is the table on which you are creating a foreign key.
  3. Click the Create button from the Relationships group box.

    SQLWizard displays the Create Relationship dialog box.

  4. Type a name for your foreign key in the Foreign Key Name field.
  5. Type the name of a table in the Referenced Table field, or click the Browse button and choose a table from the Open Table dialog box. When you specify a referenced table, remember that it must have a primary key already defined.
  6. The Table Columns list displays the column names from the dependent table (the EMPLOYEE table in the example above). These are available for you to match to the Referenced Columns that are displayed in the other list.
  7. Match a column name from the Table Columns list to each of the Referenced Columns. There are two ways to do this:
    • Highlight a column name and click the right arrow button.
    • Double-click a column name.

    SQLWizard moves the selected field from the dependent Table Columns list to the Foreign Key Cols list, next to the first available referenced column.

    If you make any errors in assigning fields, highlight the name in the Foreign Key Cols list and move it back to the Table Columns list by clicking on the left arrow button.

  8. To change the ordering of the foreign key columns, click a foreign key column and use the up and down arrows to reposition it next to the correct column from the referenced table. The column only moves up or down if there is another matching referenced column (i.e., the same data type, length, and null permission) above or below it in the list.
  9. Click OK to accept the relationship definition.

    SQLWizard displays the name of the foreign key in the Relationships group box on the Alter Table dialog box, preceded by a + sign to indicate a new relationship. The name of the referenced table appears in parentheses.

  10. Click OK from the Alter Table dialog box.
  11. Click OK to confirm altering the table.

    SQLWizard creates the foreign key on the selected table.

Parent topic: Manage Databases


Altering a Foreign Key Relationship

You can alter some of the specifications of a relationship, particularly the On Delete and On Update options.

Instructions for how to alter a relationship are provided below.

To alter a foreign key relationship:

  1. Display the Alter Table dialog box for the dependent table.
  2. In the Relationships group box, either highlight a relationship name and click the Alter button, or double click a relationship name. The Alter Relationship dialog box is displayed.
  3. Make changes to any field or selection in the foreign key definition.
  4. Click OK to accept the changes and return to the Alter Table dialog box.

    SQLWizard displays the name of the foreign key in the Relationships group box. The relationship name is preceded by an * to indicate that the foreign key specifications have been modified.

  5. Click OK to accept the foreign key changes.
  6. Click OK to confirm altering the table.
Parent topic: Manage Databases


Dropping a Foreign Key Relationship

To drop a foreign key, use the Alter Table dialog box. Instructions for how to drop a foreign key relationship are provided below.

To drop a foreign key relationship:

  1. Display the Alter Table dialog box for the dependent table.
  2. In the Relationships group box, highlight a relationship name and click the Drop button.

    SQLWizard displays a - sign preceding the foreign key name to indicate it will be dropped when you exit the Alter Table dialog box.

    Note:

    If you realize you want to keep a foreign key (relationship) before exiting the Alter Table dialog box, double click the name of the foreign key and display the Drop Relationship dialog box. Click the Undo button. The - sign will be removed, and the foreign key will remain intact.

  3. Click OK from the Alter Table dialog box to drop the foreign key.
  4. Click OK to confirm altering the table.
Parent topic: Manage Databases


To create a new index or key

To create an index or key on a table in the current location:

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. If the Catalog Browser window is not open, click
    *
    to open it.
  3. On the Catalog Browser window, ensure the Table tab is selected.
  4. Click the table you want.
  5. Click Alter.
  6. Click Create in the Indexes and Keys group.
  7. Type a name for your index or key.
  8. Select the type of index or key you want to create.
  9. Use the arrow pushbuttons to create a list of columns that define the index or key.
  10. When you have finished, click OK to close the Create Index dialog box.

    You can look at the SQL statements that will be used to make your changes by clicking SQL.

  11. Click OK to close the Alter Table window.
Parent topic: Manage Databases


To change an index or key

To change an index or key on a table in the current location:

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. If the Catalog Browser window is not open, click
    *
    to open it.
  3. On the Catalog Browser window, ensure the Table tab is selected.
  4. Click the table you want.
  5. Click Alter.
  6. In the Indexes and Keys group, select the index or key you want to change from the list.
  7. Click Alter.
  8. Make the changes you require.
  9. When you have finished, click OK to close the Alter Index dialog box.

    You can look at the SQL statements that will be used to make your changes by clicking SQL.

  10. Click OK to close the Alter Table window.
Parent topic: Manage Databases


To drop an index or key

To drop an index or key on a table in the current location:

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. If the Catalog Browser window is not open, click
    *
    to open it.
  3. On the Catalog Browser window, ensure the Table tab is selected.
  4. Click the table you want.
  5. Click Alter.
  6. In the Indexes and Keys group, select the index or key you want to change from the list.
  7. Click Drop.
  8. Click OK to close the Create Index dialog box.
  9. Click OK to close the Alter Table window.
Parent topic: Manage Databases


To create new relationships

To create relationships on columns in a table in the current location:

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. If the Catalog Browser window is not open, click
    *
    to open it.
  3. On the Catalog Browser window, ensure the Table tab is selected.
  4. Click the table you want.
  5. Click Alter.
  6. In the Relationships group, click Create.
  7. Type a name for the foreign key.
  8. Type the name of the parent (referenced) table for the foreign key or click Browse to search for it.
  9. Select the behaviour you require in the On Delete and On Update groups.
  10. Use the arrow pushbuttons to create a list mapping columns that you want to be foreign keys to the corresponding primary key columns in the parent table.
  11. When you have finished, click OK to close the Create Relationship dialog box.

    You can look at the SQL statements that will be used to make your changes by clicking SQL.

  12. Click OK to close the Alter Table window.
Parent topic: Manage Databases


To change relationships

To change relationships on columns in a table in the current location:

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. If the Catalog Browser window is not open, click
    *
    to open it.
  3. On the Catalog Browser window, ensure the Table tab is selected.
  4. Click the table you want.
  5. Click Alter.
  6. Select the name of the foreign key you want to alter from the list.
  7. In the Relationships group, click Alter.
  8. Make the changes you require.
  9. When you have finished, click OK to close the Alter Relationship dialog box.

    You can look at the SQL statements that will be used to make your changes by clicking SQL.

  10. Click OK to close the Alter Table window.
Parent topic: Manage Databases


To drop relationships

To drop relationships on columns in a table in the current location:

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. If the Catalog Browser window is not open, click
    *
    to open it.
  3. On the Catalog Browser window, ensure the Table tab is selected.
  4. Click the table you want.
  5. Click Alter.
  6. Select the name of the foreign key you want to drop from the list.
  7. In the Relationships group, click Drop.
  8. Click OK to close the Alter Table window.
Parent topic: Manage Databases


Creating Synonyms

You can create a synonym when you are creating or altering a table. Synonyms are defined on the Table Options dialog box.

To create a synonym:

  1. Display the Create Table or Alter Table dialog box.
  2. Click the Options button to display the Table Options dialog box.
  3. Click the Create button in the Synonyms group box.

    SQLWizard displays the Create Synonym dialog box.

  4. Type a name for the synonym in the Synonym Name field.
  5. Click OK to accept the synonym.

    Your new synonym is now listed in the Synonym group box of the Table Options window with a + sign preceding it.

  6. Click OK from the Table Options dialog box.
  7. Click OK from the Create Table or Alter Table dialog box to create the synonym.
  8. Click OK to confirm altering the table.

    SQLWizard creates the new synonym.

Parent topic: Manage Databases


Dropping Synonyms

A synonym is not dropped until you exit the Alter Table dialog box. Before you exit this dialog box, be sure you have made all appropriate changes and wish to save the table specifications.

To drop a synonym:

  1. Display the Alter Table dialog box for the table on which the synonym is defined.
  2. Click the Options button to display the Table Options dialog box.
  3. Highlight a synonym in the Synonyms group box and click the Drop button. The Table Options dialog box displays the synonym with a - sign preceding it to indicate that it will be dropped.
    Note:

    If you mark a Synonym name and then realize you want to keep it, before exiting the Alter Table dialog box, double click the name of the Synonym to display the Drop Synonym dialog box. Then click the Undo button. The - sign will be removed, and the original synonym will remain intact.

  4. Click OK from the Table Options dialog box and click OK in the Alter Table dialog box to drop the synonym.
  5. Click OK to confirm altering the table.
Parent topic: Manage Databases


Creating Aliases

Before you create an alias for a table, you must be connected to the location where the table resides.

To create an alias:

  1. Display the Create/Alter Table dialog box.
  2. Click the Options button.

    SQLWizard displays the Table Options dialog box.

  3. Click the Create button in the Aliases group box.

    SQLWizard displays the Create Alias dialog box.

  4. Type a name for the alias in the Alias Name field.
  5. Select target locations from the Target Location group box. These are the locations from which you want this alias to be accessible. Users in each of these locations can also use the alias to access the table.

    There are two ways to select location names:

    • Double click a location name on the Not Selected list to move it to the Selected list.
    • Click a location name on the Not Selected list; then click the right-arrow button to move it to the Selected list.
  6. Click OK to accept the information and return to the Table Options dialog box.

    Your new alias is now listed in the Aliases group box of the Table Options dialog box with a + sign preceding it.

  7. Click OK from the Table Options dialog box.
  8. Click OK from the Create Table or Alter Table dialog box to create the alias.
  9. Click OK to confirm altering the table.

    SQLWizard creates the new alias.

Parent topic: Manage Databases


Dropping and Altering Aliases

An alias is not dropped until you exit the Alter Table dialog box. Before you exit this window, be sure you have made all appropriate changes and wish to save the table specifications.

To drop an alias:

  1. Display the Alter Table dialog box for the table on which the alias is defined.
  2. Click the Options button from the Aliases group box to display the Table Options dialog box.
  3. Highlight an alias in the Aliases group box and click the Drop button. The Table Options dialog box displays the alias with a - sign preceding it to indicate that it will be dropped. Only aliases created in the same location as the table they are associated with will appear in the Aliases group box.
    Note:

    If you mark an alias name and then realize you want to keep it, before exiting the Create/Alter Table dialog box, double click the name of the alias to display the Drop Alias dialog box. Then click the Undo button. The - sign will be removed, and the original alias will remain intact.

  4. Click OK from the Table Options dialog box and click OK in the Alter Table dialog box to drop the alias.
  5. Click OK to confirm altering the table.
Parent topic: Manage Databases


Query Databases

  • Creating a Query
  • To create a query
  • Viewing Queries in SQL Edit Mode
  • Saving a Query
  • Opening a Saved Query
  • Running a Query
  • Viewing Results
  • Closing a Result Window
  • Example
  • Example
  • Setting Query Options
  • Choosing Columns
  • Moving Columns
  • Hiding Columns
  • Defining Conditions for a Single Column
  • Matching a Range of Values
  • Using AND and OR on One Column
  • Using AND and OR on Different Columns
  • Referring to Other Columns in Conditions
  • Including Calculations in Conditions
  • Selecting From a List of Values
  • Defining Computed Columns
  • Renaming Fields
  • Finding Distinct Values
  • Adding Extended Conditions (And and Where)
  • Specifying Sort Order
  • Retrieving Data From Two or More Tables
  • Displaying Table Names
  • Avoiding Cartesian Products
  • Prohibiting Cartesian Products
  • Manual Joins
  • Preventing Cartesian Products with Auto Joins
  • Non-equijoins
  • Outer Joins
  • Creating a Summary Query
  • Searching for Duplicate Values
  • Creating a Union
  • Creating a View
  • Creating a DELETE Statement
  • Creating an UPDATE Statement
  • Creating an INSERT Statement
Parent topic: SQL Wizard


Creating a Query

In this topic, you will learn to write a simple prompted query that retrieves everything in a table - all of the columns and rows. For this example, the Query Design window that produces a prompted query is used.

To create a new query:

  1. Open a new Query Design window.

    SQLWizard displays the Add Table dialog box.

  2. Click one of the tables from the Table Name list box. If you do not see the table you want to use, you may have to change the Location or AuthID.
  3. Once you have highlighted a table, click the Add button to copy the table to the Query Design window. Notice that the columns in the selected table are shown in a Column Selection List.
    Note: When adding tables to a Query Design window, you can pick more than one table. A query that gets data from more than one table is called a join. For now, just select a single table.
  4. Click the Done button to close the Add Table dialog box. If you click the Done button before you add a table to the query, you will need to use the Add Table command from the Query menu.
    Note:

    *

    *
    Click the Add button on the toolbar or, from the Catalog Browser dialog box, drag a table to the Table Display Area.

  5. Examine the Column Selection List in the Table Display Area of the Query Design window. The table name is shown in the title bar. Beneath the title bar is a list box containing all column names in the selected table. You can select one column to be added in your query or you can use the asterisk (*) to select all columns in the table.
  6. Click the asterisk in the Column Selection List to add all of the columns in the table to the query.

    Notice that the columns are added to the Query Conditions Grid in the order they appear in the Column Selection List.

Parent topic: Query Databases


To create a query

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. If the Catalog Browser window is not open, click
    *
    to open it.
  3. On the Catalog Browser window, ensure the Query tab is selected.
  4. Click New.
  5. Click the table names that you are interested in and click Add.
  6. When you have added all the required tables, click Done.
  7. In each table, click the fields that you are interested in.
  8. Under each field, type any conditions you require.
  9. Click Save As on the file menu to save your query.
  10. Close the Query Design window.
  11. Click Refresh, to see your new query listed.
Note: To execute your query, click on the query and click Batch.
Parent topic: Query Databases


Viewing Queries in SQL Edit Mode

You can examine the SQL statements generated by the Query Design window by switching to the SQL Edit window.

To switch to the SQL Edit window:

  1. Click the SQL command from the View menu.
    Note:

    *
    Click the SQL Edit button on the toolbar

    While in the SQL Edit view, you can make changes to your query that would be difficult to make through the prompted Query Design window. You can also edit other types of commands that are not currently supported by the Query Design window.

  2. Click the Design command from the View menu to return to the Query Design window.
    Note:

    *
    Click the Query Design button for Query Design mode.

Note:

If you make changes to the SQL statement while in the SQL Edit window, you will not be able to go back to the Query Design window without discarding those changes. You can, however, first save the prompted query in Query Design mode, switch to SQL Edit mode, and save the modified SQL statement as an SQL script file.

Parent topic: Query Databases


Saving a Query

If you think you will want to use a query, save the query before you try to run it. Saving a query places the information in the system catalog tables, where it can be accessed later by you (and others if you save it as a shared query).

To save a query that has never been named before, or to save a query under a different name:

  1. From the File menu, click the Save As command.
    Note:

    *
    Click the Save button on the toolbar

    SQLWizard displays the Save As dialog box.

  2. Type a name for the query. You may want to change the location and AuthID for the query before you save it.
  3. Click the Options button to display the Set Query Options dialog box and type a comment or description for your query. This description will appear in the list of queries on the Catalog Browser dialog box.
  4. In the Query Type group box, choose to save your query as a Prompted Query (to be retrieved later into the Query Design window) or as an SQL Edit Query (to be retrieved later into the SQL Edit window or run as a batch SQL script file).
    Note:

    If you are saving a query from the SQL Edit window, and that query has been changed so that it no longer can be used in the Query Design window, you will only be able to save it as an SQL Edit Query, and not as a Prompted Query.

  5. In the Access group box, choose to make the query Private (available only to you) or Shared (available to other users on the XDB Server). With a Shared Query, the other users must have appropriate access authority to read the tables that the query uses.
  6. Click OK to exit back to the Save As dialog box.
  7. Click OK to save the query.

To resave a query:

Once a query is saved, you can use the Save command on the File menu or the Save button on the toolbar to resave any changes. The Save command does not prompt for a query name and does not provide access to the Set Query Options dialog box if the query has already been saved with a name.

Parent topic: Query Databases


Opening a Saved Query

There are several ways to open a saved query.

To open a saved query from the menu:

  1. From the File menu, click the Open command.

    SQLWizard displays the Open dialog box.

  2. Click the down-arrow button for the List Objects Of Type field to display the object types drop-down list; click Queries.
  3. Click the desired query to open. Note that you may have to change the Location or AuthID to find the query you want to open.
  4. Click OK.
Note:

*

*
Click the Open button on the toolbar and choose the desired query or, from the Catalog Browser dialog box, click the Query tab, a query, and the Open button.

Parent topic: Query Databases


Running a Query

Running a query causes the SQL command to be sent to the XDB Server where the desired columns and rows are retrieved and sent back to SQLWizard to display in a Result window. Before you can run a query, you must have specified at least one table and one column.

To run an open query from a Query Design window:

  1. Click the Query Design window to make it the current window.
  2. From the Query menu, click the Run command
Note:

*

*
Click the Run button on the toolbar or, from the Catalog Browser dialog box, click the Query tab, a query, and the Batch button.

Related Topics

Parent topic: Query Databases


Viewing Results

When you run a query, the results of the query are displayed in a Result window. There are two result views: Result Table and Result Form. These are available from the View menu after a query is run.

A Result Table shows the rows of the result in a spreadsheet-like format. You can scroll in any direction to see the columns and rows of the result.

A Result Form shows the result one record at a time, with the fields displayed one beneath another. You move between records much like you turn the pages of a book. You can have multiple Query Result windows open at the same time.

To switch between Result Table and Result Form views:

  1. Click the Result Table command from the View menu, or click the window to make it active.
  2. Click the Result Form command from the View menu, or click the window to make it active.
Note:

*

*
Click the Result Table or Result Form button on the toolbar.

Parent topic: Query Databases


Closing a Result Window

To close the current Result window, click the Close command from the File menu, or double click the Window Control Menu box at the upper left corner of the Result window.

Parent topic: Query Databases


Example

The following example returns a list of all customer companies located in California. Even though the state column, St, appears in the Query Conditions Grid, it does not appear in the result.

  1. Open a new query.
  2. Add the CUSTOMER table and click Done to close the Add Table dialog box.
  3. Click the COMPANY column in the Column Selection List to add it to the Query Conditions Grid.
  4. Click the ST column to add it to the grid.
  5. Move down to the Query Conditions Grid and enter the string CA in the Conditions row under the ST column name.
  6. Click the ST column to select it.
  7. Click the Hide Column button on the toolbar (or use the Hide Column command from the Column menu).
  8. Run the query. Only the COMPANY column is shown in the Result window, displaying the names of only those companies in California.
  9. Close the Result window.
  10. Examine the SQL code generated for this command by clicking on the SQL button on the toolbar. Notice that the ST column does not appear in the SELECT clause of the query, but it is mentioned in the WHERE clause.
  11. Click the Query Design button on the toolbar to switch back to Query Design mode. Save the query if you want to keep it, and close the Query Design window.
Parent topic: Query Databases


Example

This example creates a query that shows all of the cities that employees live in, and summarizes employee information into a column containing the count of employees living in each city. There will be one row returned for each city, regardless of how many employees live in that city.

  1. Open a new query and select the table of interest. In this case, open the EMPLOYEE table. Add it to the query and then click the Done button.
  2. Click the columns you want displayed in the query. Do not include the columns that contain data that you want to summarize yet. For this example, add the CITY and STATE columns.

  3. *
    Click the Create Computed Column button on the toolbar (or the Create Computed Column command from the Column menu) to display the Create Computed Column dialog box.
  4. From the Aggregate Function drop-down list, double-click Count.
  5. From the Table/Column drop-down list, double-click E_NO.

    It is a good idea, when generating a count, to choose a column that uniquely identifies the records that you want to count. You could also use an asterisk, which indicates that you want a count of all the records. The column name should be positioned inside the parentheses that appear after the count function.

  6. A column name is provided for the column, but you may want to change it to something more meaningful. Click the Column Name field and type in EmployeeCount.
    Note:

    Column names must satisfy the rules for a long identifier, discussed in the SQL Reference. That is, they may be up to 18 characters long and must begin with a letter. They cannot contain spaces.

  7. Click OK to accept the Computed Column.
  8. Now examine the Query Conditions Grid. You will notice that a new column called EMPLOYEECOUNT has been added at the end of the column list. The Order/Group row has also been added to the grid. You first saw this row when you defined a sort order for a query. Now it contains some new icons. The
    *
    symbol indicates that the column is a computed column. If you click this symbol, the Modify Computed Column dialog box for this column is displayed so that you can modify the column definition.
  9. In addition, a
    *
    symbol appears in the STATE and CITY columns. Whenever an aggregate function appears in a query, all other columns must be grouped. SQLWizard does this for you automatically. Click the
    *
    symbol.

    The Group By dialog box is displayed. Notice that there are two lists. The UnGrouped Columns includes the computed column EMPLOYEECOUNT, which SQLWizard will not allow you to group. The Grouped Columns include the CITY and STATE columns, which SQLWizard will not allow you to ungroup unless you delete the EMPLOYEECOUNT column.

  10. The order in which columns appear in the GROUP BY clause is important. SQLWizard places the columns in the list in the order in which they appear on the Query Conditions Grid. If this is not the correct order for your query, you should rearrange them. To do so, click a column to select it, and then use the Up and Down buttons to reposition the column. When positioning the columns, keep in mind that a column that contains a subset of the rows of another column should appear later in the list. In this example, the CITY column should appear after the STATE column, because there are a number of cities in each state. Move the STATE column to the top of the list.
  11. Once you have ordered the columns correctly, click OK to close the Group By dialog box. Notice the number that appears to the right of the GROUP symbol shows that STATE is the first grouped column, and CITY is the second grouped column.

  12. *
    You have now created a query containing summary rows. Use the SQL button on the toolbar to examine the SELECT statement generated for this command. Notice the COUNT function and the GROUP BY clause.

  13. *
    Use the Query Design button on the toolbar to return to the Query Design window.
  14. Save the query if you would like to keep it.

  15. *
    Click the Run button to run the SQL command. When the result appears you will see a row for every city in the EMPLOYEE table. The number of EMPLOYEE records that have a matching CITY value will appear in the EMPLOYEECOUNT column.
  16. Exit from the Result window
Parent topic: Query Databases


Setting Query Options

SQLWizard provides options for designing and running your queries. You can set the defaults for all queries using the Options utility, as well as set specific options for a currently open Query Design or SQL Edit window.

To set options for the current query:

  1. From the Query menu, click the Current Query Options command.

    SQLWizard displays the Query Options dialog box.

  2. Make changes to the available items as desired.
  3. Click OK to accept the changes.
Parent topic: Query Databases


Choosing Columns

There may be times when you do not want to show all of the columns in a table in your result. You can specify which columns to show, and the order in which they will appear in the Result window.

To add a single column to the Query Conditions Grid:

  1. Open or create a new query.
  2. Scroll through the list in the Column Selection List to find the column you want to add.
  3. Click the column to add it to the Query Conditions Grid. The column will be highlighted in the Column Selection List to show that it is added to the grid.
  4. Continue adding columns by clicking on them. As you click the names, they appear in the Query Conditions Grid. If you click a name by mistake, click it again to remove it.

    Notice that as you add a column to the query, it is added at the end of the set of columns in the Query Conditions Grid.

Note: If you decide you do not like your current column selection, you can easily start over by clicking once on the asterisk in the Column Selection List to select all columns, and a second time to remove all columns from the Query Conditions Grid.
Parent topic: Query Databases


Moving Columns

The order in which columns appear in the Query Conditions Grid determines the order they appear in your result window.

To change the order of columns:

  1. Click a column name in the Query Conditions Grid to select it.
  2. Click and drag the column to a new location on the grid.
  3. Drop the column over the divider between two columns. The selected column will be repositioned between these two columns.

    You can also wait and rearrange the columns after the query is run.

Note: You can select and move more than one column at a time. Simply hold down Ctrl while you click a collection of column names. Or hold down Shift while you click a second column name to pick all columns between (and including) the first and second selection.
Parent topic: Query Databases


Hiding Columns

If you want to specify a condition on a column in one of your tables, but you do not want the column to appear in your result, you can hide the column. There are several ways to hide a column that appears in the Query Conditions Grid:

  • Double click the column title to toggle the selected column between visible and hidden states. A column is visible if the title appears as a button. A column is hidden if it appears as a pressed button.
  • Click the column to select it, and use the Hide Column command from the Column menu to hide the column.
  • Click the Select Hidden Column command from the Column menu. The Select Hidden Column(s) dialog box allows you to move columns between a Visible and Hidden list by selecting and using the buttons between the lists. Click OK to accept the column specification on the dialog box.
Parent topic: Query Databases


Defining Conditions for a Single Column

Usually when you define a Select command, you want to add filter conditions to restrict the rows retrieved.

To add simple search conditions on the columns in a query:

  1. Open the query.
  2. Click the Conditions row of one of the columns.
  3. Type in a value that the column should match. For example, under the ST column, enter the values DC, MD, and VA on separate rows. Quotes appear around the values if they are needed. The three values are treated as OR conditions.
Note: If you want to compare a column with another field, you will use the join mechanism.
Parent topic: Query Databases


Matching a Range of Values

You can specify a range of values that a column should satisfy using the BETWEEN predicate. Type the condition BETWEEN followed by a number, then the keyword AND, then another number. For example:

Between 2 and 8
Parent topic: Query Databases


Using AND and OR on One Column

You can enter a compound condition containing an AND or an OR in a single cell of the Query Conditions Grid. This condition will be enclosed in parentheses in the SQL statement. For example, you could enter the following condition in the LNAME column of the EMPLOYEE table:

"Hurwood" OR "Kerin"
Parent topic: Query Databases


Using AND and OR on Different Columns

Values in different columns on the same row are treated as AND conditions. Values in different rows are treated as OR conditions. Look at the following Query Conditions Grid example.

This yields the following SELECT statement:

SELECT  E1.e_no, E1.lname, E1.payrate, E1.st, E1.com
FROM    TUTORIAL.TUTORIAL.EMPLOYEE E1
WHERE    ((E1.e_no Between 2 and 8)
        OR (E1.lname like ""hur%"")
        OR ((E1.payrate >4
            AND E1.payrate < 15)
            AND (E1.com is null))
            OR (E1.st <> "MD"))
Parent topic: Query Databases


Referring to Other Columns in Conditions

You can refer to another column in the query from within a cell. For example, you type the following condition into the LNAME column of the EMPLOYEE table to test for a last name equal to a first name:

=fname
Parent topic: Query Databases


Including Calculations in Conditions

If you want to include an expression in a condition, simply type it in. For example, you could include the following condition in the COM column of the EMPLOYEE table:

> (payrate*1.25)
Parent topic: Query Databases


Selecting From a List of Values

You can use the IN predicate to check for a records having values that match a member of a list of values. For example, you could type the following into a cell of the EMPLOYEE table's ST column:

IN ('MD', 'VA', 'DC', 'NY')
Parent topic: Query Databases


Defining Computed Columns

You can create a computed column that compares two or more columns in a table and produces aggregate and/or scalar results.

To create a computed column:

  1. *
    Click the Create Computed Column command from the Column menu, or click the Computed Column button on the toolbar.
  2. In the Computed Column dialog box, type or pick from the function and column lists to create a calculated field. For example, the following uses the string concatenation operator to combine last and first names into a single name.
      lname||","||fname
Parent topic: Query Databases


Renaming Fields

If you want to rename the columns that appear in your result, you can create a computed column that contains, as an expression, just the name of the column you want to rename. Type in a new name in the Computed Column Name field. Your result column is automatically renamed. If you do not provide a name, a default (Column 1) is used.

Note:

This option is not supported by DB2 version 3.x and earlier. Therefore, it is not available in DB2 mode.

Parent topic: Query Databases


Finding Distinct Values

You can create a computed column using the DISTINCT keyword to try to find all unique values in a column. When the DISTINCT keyword is used (instead of the default ALL), duplicate values are discarded. For example, querying the EMPLOYEE table enter the formula:

DISTINCT lname

and the computed column and resulting query do not show two rows with the LNAME Hurwood.

Parent topic: Query Databases


Adding Extended Conditions (And and Where)

Some of the conditions on columns that can be added to a query cannot be expressed easily using the Query Conditions Grid. In these cases, you have two alternatives:

  • Edit the SQL statement, in which case you can include any valid condition (including nested SELECTS).
  • Include an extended search condition.

An extended search condition is simply another set of conditions that are appended to the Query Conditions Grid as AND conditions.

To define an extended search condition:

  1. Open a new or existing query.
  2. Click the Where (?) button on the toolbar.

    SQLWizard displays the Search Condition dialog box. You compose a series of extended search conditions at the top of this dialog box, one per row.

  3. On the first row, the first drop-down list contains only the NOT qualifier. You should use this if you want to negate the condition you create on this row.
  4. The next field is used to specify the left-hand side of the expression. Move to this field and type in the expression, or compose it using the tools at the bottom of the dialog box. There are drop-down lists containing functions, as well as operators and column names that are used to build the expression.
  5. The next control is a drop-down list containing comparison operators, including SQL predicates such as BETWEEN and IN. Select an operator from this list.
  6. The next field is used to specify the right-hand side of the expression. Move to this field and complete the expression.
  7. The last control on the row is a button to add another condition row to the dialog box. Click it to add another condition row.
  8. Move to the next row and click the down-arrow button on the first drop-down list. While in the first row, the drop-down list only contains the NOT option, in the second and subsequent rows, this list contains connection operators AND and OR, with or without the NOT qualifier. Choose one of the connection operators.
  9. Complete the expression on this row as you did for the previous row.
  10. When you are finished with the extended search condition, click OK to accept the changes.
  11. Examine the Query Conditions Grid. You will see that a new area labeled AND has been added, showing the conditions that you just defined. If you want to make changes to the conditions, double click the area to redisplay the Search Condition dialog box.

If you want to add conditions that cannot be expressed through the Query Conditions Grid columns or the Search Condition dialog box, switch to the SQL view and edit the SQL statement directly. Note that once you have made changes to the statement in the SQL Edit window, you will not be able to switch back to the Query Design window without discarding the changes. Therefore, you should save your query in the Query Design window before switching to the SQL Edit window, and save it from the SQL Edit window using a different name if you make changes.

Parent topic: Query Databases


Specifying Sort Order

Often you will want to make data easier to understand by presenting it in a particular order. You can sort the result at the time the query is executed by creating an ORDER BY clause for the SELECT statement, or you can sort columns after the result is returned.

The advantages of sorting the query results using an ORDER BY clause are:

  • You can sort on columns that you do not retrieve.
  • Because the sort criteria are stored as part of the query, the query will always be properly sorted each time you run it.

The disadvantages of sorting the result using an ORDER BY clause are:

  • You are asking the database server to do additional work, which may affect the speed of other applications that are trying to use the database server.
  • If you are creating an ad hoc query, and don't know if you need all of the rows of the result, you still need to wait until they are retrieved and sorted before you can see any of the rows of the result.

This topic teaches you how to use SQLWizard's Query Design window to add an ORDER BY clause to your query.

To create an ORDER BY clause on a single column:

  1. Add the column you want to sort on to the Query Conditions Grid. If you do not want to see the column in the result, still add it to the grid, and then double click the title to hide it in the result.
  2. Click the title of the column to select the column.
  3. Click the Sort Column command from the Column menu.
  4. Choose Ascending or Descending from the Sort Column submenu. Ascending means the columns are sorted from 0 to 9 and A to Z (or as appropriate for international versions). Descending means the columns are sorted from 9 to 0 and Z to A (or as appropriate for international versions).
    Note: You can repeat the process above as many times as you like. Each time you add another column, it is appended to the ORDER BY clause. To see or modify all of the columns in the ORDER BY clause, switch to the SQL view, or follow the instructions for creating an ORDER BY clause on multiple columns.

To create an ORDER BY clause on multiple columns:

  1. Add all of the columns that you want to see in the result to the Query Conditions Grid.
  2. If there are columns that you do not want to see in the result, but that you want to use for ordering the result, add them to the Query Conditions Grid as well. For these columns, double click the column name to exclude the column from the columns displayed in the query result.
  3. Click the Sort command from the Query menu or use the Sort button on the toolbar.

    SQLWizard displays the Order By dialog box. This dialog box contains two lists: one containing all of the columns in the Query Conditions Grid, and the other containing the columns that will be included in the ORDER BY clause used to sort the result records. When you display the Order By dialog box for the first time, the list of Sorted columns is empty.

  4. To add a column to the ORDER BY clause, locate the column in the Unsorted Columns list and click it to select it. Then click the > button to move the name from the Unsorted Columns list to the Sorted Columns list. You can remove a column from the Sort Columns list by selecting it and using the < key. The >> button moves all columns in the Unsorted Columns list to the Sorted Columns list, while the << button moves all columns from the Sorted Columns list to the Unsorted Columns list.
  5. Once you have picked the columns you want to use for ordering the result, you can rearrange the order in which they appear in the ORDER BY clause. The first column in the ORDER BY clause is the primary sort column. Each additional column sorts the records in the group defined by the previous column. To move a column up in the list, click it and use the Up or Down buttons.
    Note: The first column in the list is the most significant column. Data is first sorted by this column, and each of the other columns are applied to the sorted rows in turn.
  6. You can also specify whether an ascending or descending sort sequence is to be used in sorting by a particular field. Ascending sorts go from 0-9 and A-Z (or as appropriate for international versions). Descending sort sequences go from 9-0 and Z-A (or as appropriate for international versions). To toggle between Ascending and Descending, click the arrow buttons beside a column name in the Sorted Columns list.

    *
    indicates ascending order.

    *
    indicates descending order.

  7. Once you are satisfied with the Sorted Columns list, click OK to close the dialog box.
  8. Now examine the Query Conditions Grid. You now see a new row labeled ORDER/GROUP, containing numbers and icons. The number indicates the order of the column in the ORDER BY clause, and the
    *
    or
    *
    symbol indicates whether the column is to be sorted in ascending or descending sequence.
  9. You can change the ORDER BY clause by redisplaying the Order By dialog box and modifying the Sorted Columns list as described above. Or you can click the ORDER/GROUP row and change the number and ascending/descending specification.
Parent topic: Query Databases


Retrieving Data From Two or More Tables

In order to create a join, you need to have two or more tables visible in the Table Display Area.

To add more tables to create a join:

  1. From the Query Design window, click the Add Table button on the toolbar or the Add Table command from the Query menu.

    SQLWizard displays the Add Table dialog box.

  2. Click on the table you want to add.
    Note:

    Attempting to run a query involving tables from different locations will generate an error.

  3. Click the Add button to copy the table to the Table Display Area.
  4. Continue to add tables in this way until you have added all of the tables you want to join.
  5. When you are finished adding tables, click the Done button.
    Note:

    There is a limit of 15 tables in a FROM clause when running against XDB Server or DB2. Adding more than this number of tables will generate an error when you attempt to run the query.

    You can create nested SELECT statements that access many more tables than this limit. The limit applies to a single FROM clause.

Parent topic: Query Databases


Displaying Table Names

When you are creating queries involving multiple tables, it is often useful to see the names of the table from which a column comes in the Query Conditions Grid. To add a row containing table names, click the Show Table Names button in the toolbar, or use the Show Table Names item in the Query menu.

Parent topic: Query Databases


Avoiding Cartesian Products

The following method may be used to avoid Cartesian products when you create a join.

  • Usually you should have at least t-1 join conditions for a join between t tables.
  • If there are multi-column primary keys on a referenced table, there should be as many join conditions between the child table and the referenced table as there are columns in the primary key of the referenced table.
  • Turn on the Prohibit Cartesian Products option.
Parent topic: Query Databases


Prohibiting Cartesian Products

If you do not want to rely solely on your own tests for avoiding Cartesian products, you can set an option to prohibit Cartesian products. With this option set, each time you run a query, it is tested to determine whether or not there are join conditions between the tables. If there are no join conditions, an error results.

The test does not determine whether or not the join conditions are logical or correct for your application. However, by blocking Cartesian products in this way, you will reduce the chance that you will forget to put any join conditions on your query.

Note:

This test is only effective for queries run from within the SQLWizard. Queries embedded in host programs or executed from other programs are not affected. You may want to test your queries in SQLWizard before running them in other programs.

Another way to minimize the chance that you will generate a Cartesian product is to make use of SQLWizard's Auto Join facilities.

To prohibit (block) Cartesian products:

  1. From the Query menu, click the Current Query Options command (or, in the Micro Focus Program Group or Folder, click the Options icon).
  2. If using Options to set this item as your default, click the Query tab to access the Query options.
  3. Click the Prohibit Cartesian Products checkbox to select it.
  4. Close the Query Options dialog box (or Options window, as appropriate).

    Now when you run an SQL query in SQLWizard, it will be tested to determine if it might return a Cartesian product.

Parent topic: Query Databases


Manual Joins

When you put more than one table into the Schema View of a prompted query, you should define a join condition. SQLWizard provides several methods for doing this, including Auto Join capabilities.

The following are steps to define a join on your own:

To define a join manually:

  1. Click the New Query button, or click the New command from the File menu followed by the Query command from the submenu.

    SQLWizard displays the Add Table dialog box.

  2. Click the EMPLOYEE and DEPT tables and click the Add button to add them to the query.
  3. Click the Done button to close the Add Table dialog box. When the Query Design window is displayed, you will see both tables side by side in the Table Display Area.
  4. Select some columns from each table by clicking on them. You now have a join, but it is the type of join known as a Cartesian product, which is a combination of all the rows in one table with all of the rows in the other table.

    To prevent the occurrence of a Cartesian product, you need to define a join condition, which relates a column in one table to a column in another table. The EMPLOYEE and DEPT tables are joined on the DEPT field. Scroll through the EMPLOYEE table's Column Selection List until you see the DEPT field. Click it, and drag to the DEPT field in the DEPT table. A line representing the join will appear.

Parent topic: Query Databases


Preventing Cartesian Products with Auto Joins

When you select from more than one table without defining a join condition that maps the rows of one table to the rows of another table, you create a Cartesian product, which is generally an expensive result that includes every combination of records between the tables, and usually has no real meaning.

SQLWizard supports automatic joining of columns in three cases. Note that the third case is not usually a very good method for automatically joining tables. Frequently, there are like column names that have no join relationship with each other. It is recommended that you use the first two options whenever possible, or manually define joins.

To define an automatic join, click the Current Query Options command from the Query menu to display the Query Options dialog box, and check the desired auto join methods. Alternatively, click the Auto Join command from the Query menu to display a submenu of the desired methods. Note that if you change the auto join options after having selected your tables, you are asked if you want to apply the join criteria after the fact.

The three cases on which automatic joins can be performed between the columns of two tables are when:

  • There exists a foreign menu key relationship between two tables.
  • There exists a primary key column in one table, and a column with the same name in another table.
  • There is a column in one table that has a name that matches a column in the other table.
Parent topic: Query Databases


Non-equijoins

An equijoin is the most common kind of join condition. It tests whether the two sides of the condition are equal. A non-equijoin uses a comparison operator other than =. You can test if a column from one table contains values that are >, ?, <, ? or < > values in another column.

To create a non-equijoin condition:

  1. Define a regular equijoin using the auto join facilities, or by dragging from one column to another.
  2. Double click the = operator in the small box on the join line.

    SQLWizard displays the Join Options dialog box.

  3. Select a comparison operator from the drop-down list in the center of the dialog box. The operators that contain a + are for defining outer joins.
  4. Click OK. The new comparison operator appears in the join condition.

    When the Join Options dialog box closes, the new operator appears on the join line between the joined tables.

Parent topic: Query Databases


Outer Joins

Suppose you wanted to display information about all suppliers and the parts they supply. Joining the SUPPLIER and PARTSUPP tables will retrieve this information for every supplier that has provided parts. But you would not see any information for suppliers that have not yet supplied parts. You would have no indication that such a supplier even existed.

An outer join is a special kind of join that solves this problem by finding all of the matches between the joined columns, just like a regular join. However, unlike a regular join, those records in one table that have no match at all in the second table are identified.

An outer join is designated by a plus sign in parentheses on the side of the child table. The parent table is the one for which you want rows even if there are no matching child records in the other table.

To create an outer join condition:

  1. Define a regular equijoin using the auto join facilities, or by dragging from one column to another.
  2. Double click the = operator in the small box on the join line.

    SQLWizard displays the Join Options dialog box.

  3. Select a comparison operator from the drop-down list in the center of the dialog box. Make sure the operator includes the (+) on the child side - that is, on the side where you expect to see null values.
  4. Click OK. The new comparison operator appears in the join condition.
  5. When you run the command you should see some rows with values for the parent table fields, but only null values for the child rows.
    Note:

    Outer joins are not supported against all database systems. For example, outer joins are not supported against XDB Server in DB2 mode, or when running against DB2.

Parent topic: Query Databases


Creating a Summary Query

There may be times when you want to generate rows of data that summarize data in your tables. For example, you may want to find a sum or an average for the values in a column. To do this, you create a computed column that includes aggregate (column) functions.

If a computed column involving an aggregate function is added to a query, the system automatically defines a GROUP BY clause for you. If you want to modify this system-defined GROUP BY clause, or if you want to add a GROUP BY clause for a query that does not require one, use the Group command from the Query menu or the Group button on the toolbar.

To add a column to the GROUP BY clause, move it from the left list box to the right list box using the arrow buttons. To change the relative order of columns within the GROUP BY clause, use the Up and Down buttons.

Note:

When including aggregate functions in queries, SQLWizard requires that non-aggregate columns be grouped. SQLWizard automatically performs this grouping for you, and will not allow you to make illegal moves between boxes. You can, however, change the order of the columns in the GROUP BY list.

Uses for summary queries include:

  • Finding the total number of records in a query.
  • Finding the number of records in a group.
  • Finding the sum of a column for the set of records in a group.
  • Finding the sum of a column for all records in a query.
  • Finding the min or max of a set of values.
  • Finding the min or max for all records in a query.
  • Finding the average for all records in a query.
  • Finding the average of a column for all records in a group.
  • Finding rows that contain duplicate values.
  • Finding rows that contain unique values.
  • Finding rows that match the average, min, or max value in a column.
Parent topic: Query Databases


Searching for Duplicate Values

Before you can create a unique index on a column, you must make certain that there are no duplicate values in the column. An easy way to do this is to use a summary query that groups records based on the index fields, and include a HAVING condition that tests to see if the count of records in any group is greater than 1.

To search for duplicate values:

  1. Open or create a query that includes just the columns on which you want to build a unique index. These are the columns you need to test for duplicates.
  2. Open the Group By dialog box using the Group button on the toolbar or select the Group command from the Query menu.
  3. Move all columns to the Grouped Columns list by clicking the >> button.
  4. The order of the columns in the GROUP BY clause is not important in this particular query. However, it is always a good idea to list the columns in hierarchical order. For example, City should come after State, because each state can contain many cities.
  5. Click the OK button to accept the Group specification.
  6. Click the Having command on the Query menu .
  7. Enter the expression Count(*) > 1, as shown below.
  8. Click OK to accept the Having specifications.
  9. The query is now ready to run or save. When you run the query, you see the list of records that have duplicate values in the candidate index columns.
Parent topic: Query Databases


Creating a Union

A union is a set of SELECT statements pasted together with a UNION clause. The union returns the combined result sets from both queries. You can use SQLWizard to help you build a union .

Note:

SQLWizard allows you to combine up to approximately 33 query results using the UNION operator (the maximum number will depend upon the complexity of your query). You must make certain when writing these queries that the data types of the columns in the SELECT clause match.

To create a union:

  1. Create the first query using the Query Design window.
  2. Create the second query using another Query Design window. Make certain that there is a one-to-one correspondence between the columns in each SELECT clause.
  3. Now switch to SQL view by clicking on the SQL button on the toolbar.
  4. Copy the SELECT statement to the clipboard by selecting it and then clicking the Copy command from the Edit menu.
  5. Click the other Query Design window, and switch it to the SQL view.
  6. Go to the end of the second SELECT statement and type the keyword UNION.
  7. Now paste the query from the clipboard after the UNION keyword to complete the union. You are ready to save or run.
Note:

When you save, you must save from the SQL view because UNION is not supported by the Query Design window. When you save the query, you will be warned that you will lose your prompted SQL changes.

Parent topic: Query Databases


Creating a View

A view is a virtual table that is logically defined over one or more tables. Its definition includes a SELECT statement that determines the fields as well as the values it can contain at any point in time. Views permit you to query subsets of data or joins of multiple tables as though they are an actual table. Only the view definitions are stored - not the data retrieved by the view. Some views can be updated. An update of a view affects the underlying table. Views may make it easier to access data by organizing it in more meaningful ways, or by restricting the rows retrieved to those that pertain to the needs of a particular application. Views can also be used for security reasons, since privileges can be granted on a view instead of on the underlying table.

You can use a SELECT command generated through the Query Design window as the basis of a CREATE VIEW statement.

To create a view from a SELECT statement:

  1. Create a new query or open a saved query. It is a good idea to run the query to see if it was correctly designed, and that it retrieves the rows you expected it would.
  2. Switch to SQL view using the SQL button on the toolbar.
  3. Position the cursor in front of the SELECT clause of your query.
  4. To create a view called TodaysOrders, type the clause CREATE VIEW TodaysOrders AS in front of the SELECT statement.
    Note:

    You cannot create a view using a SELECT statement that contains an ORDER BY or UNION.

    The simplest way to determine whether or not a view is updatable is to try to create it with the WITH CHECK OPTION clause. If the view cannot be updated, an error will occur when you try to create it.

Parent topic: Query Databases


Creating a DELETE Statement

The easiest way to delete individual records is to run a query and switch to ALLOW EDIT mode. However, if you want to perform a batch delete, you can use the WHERE condition generated for a query as the WHERE condition for a DELETE statement.

To convert a SELECT command to a DELETE command:

  1. Create a query that retrieves the rows that you want to delete. You may want to test the query to make certain it retrieves the correct rows. You should also save the query before proceeding if you want to access it again in the Query Design window. You must include at least one column in this query.
  2. Switch to SQL view.
  3. Block the SELECT clause and click the DEL key to delete it.
  4. In place of the SELECT clause, type the keyword DELETE.
  5. Run or save the SQL statement from the SQL Edit window.
Parent topic: Query Databases


Creating an UPDATE Statement

The easiest way to update individual records is to run a query, and switch to ALLOW EDIT mode. However, if you want to perform a batch update, you can use the WHERE condition generated for a query as the WHERE condition for an UPDATE statement.

To convert a SELECT command to an UPDATE statement:

  1. Create a query that retrieves the columns and rows that you want to update. You may want to test the query to make certain it retrieves the correct rows. You should also save the query before proceeding if you want to access it again in the Query Design window.
  2. Switch to SQL view.
  3. Replace the keyword SELECT with the keyword UPDATE.
  4. Enter the name of the table you are updating, and follow it with the keyword SET.
  5. After each of the column names, enter an = and an expression. If you decide you do not want to update the column, delete it from the list.
  6. Run or save the SQL statement from the SQL Edit window.
    Note: You cannot update a join or a query that contains DISTINCT, ORDER BY, GROUP BY, UNION, or Computed Columns.
Parent topic: Query Databases


Creating an INSERT Statement

The easiest way to insert individual records is to run a query, and switch to ALLOW EDIT mode. However, if you want to perform a batch insert, you can use a query as the basis for an INSERT with SELECT statement.

To convert a SELECT statement to an INSERT statement :

  1. Create a query that retrieves the columns and rows from one table that you want to insert in another table. You may want to test the query to make certain it retrieves the correct rows. You should also save the query before proceeding if you want to access it again in the Query Design window.
  2. Switch to SQL view.
  3. In front of the SELECT keyword, enter the keywords INSERT INTO followed by the name of the table into which you want to insert rows.
  4. If the order of the columns in your SELECT clause does not match the order of the target columns in the table you are adding records to, you will have to create a comma-separated list of columns inside of parentheses. This list should be placed immediately after the name of the target table, and before the SELECT clause. You can drag the column names from the Catalog Browser so you don't have to type them.
  5. Run or save the SQL Statement from the SQL Edit window.
    Note: Insert Into is an XDB Server SQL extension. It is not available when running against non-XDB Server databases or when running in DB2 mode.
Parent topic: Query Databases


Work with Query Results

  • Working with Columns Overview
  • Fixing a Column in Place
  • Rearranging Result Columns
  • Hiding Columns
  • Printing a Result
  • Changing the Result View
  • Saving a Result to a File
Parent topic: SQL Wizard


Working with Columns Overview

The Column menu commands are available only if a Result window is active and data is displayed in Result Table view. These commands operate on the currently selected column(s).

To select a column, double click the column name.

Parent topic: Work with Query Results


Fixing a Column in Place

You can lock one or more columns against the left edge of the Result window to use for reference while you horizontally scroll the other columns.

To fix a column in place:

  1. Double click a column name to highlight the column.
  2. Click the Fix command from the Column menu.

    The column will be locked against the left edge of the window (if you selected a non-edge column, it will automatically be moved to the left edge). Note that when you scroll the Result window horizontally, the fixed column remains in place, while the other columns scroll by.

  3. Repeat steps 1 and 2 for each column you want to lock to the left side of the window. The columns will appear in the order in which you fixed them.

To free a fixed column:

  1. Click the Free command in the Column menu.

    The right-most fixed column is released. The scroll bar is readjusted to allow horizontal scrolling of this column.

  2. Repeat step 1 for each column you want to release.
    Note: Fixed columns that had initially occupied a non-edge position in the table are not returned to their original position when they are freed. If you want to return a column to its original position, you may do so by dragging it back into place.
Parent topic: Work with Query Results


Rearranging Result Columns

When you are in the Result Table view, you can rearrange the columns on your Result window by dragging them to a new position. Changes you make to the result by rearranging the columns only affects the current Result window. The next time you run the query, the columns will be in the order designated by the query. You can change the order of columns in the SELECT clause of the query if you want them to always appear in a specific order. Regardless of the order in which columns are shown in a result, the order of columns stored in the database is not changed.

To move columns in a Result Table view:

  1. Click the name of a column and hold down the left mouse button.

    SQLWizard displays a phantom outline the size of the column title.

  2. Keeping the mouse button pressed, drag the outline right or left to a position between two other columns. Release the mouse button to drop the column in the new position.

    SQLWizard rearranges the columns to move the dragged column between the other two columns.

Parent topic: Work with Query Results


Hiding Columns

You may find times when it would be easier to examine your result if you could temporarily exclude one or more columns from the Result window. SQLWizard allows you to do this in two ways.

To temporarily remove a single column from the result table view:

  1. Double click a column name to select the column you want to hide.
  2. Click the Hide Column command from the Column menu. The selected column will be removed from the Result window.
    Note:

    You cannot hide fixed columns. You must free a fixed column before you can hide it.

To temporarily remove or redisplay several columns on a result table view:

  1. Click the Select Hidden Column command on the Column menu to display the Select Hidden Column(s) dialog box.
  2. Move each column name to the desired list. The columns listed in the Displayed Columns list will be displayed on the Result Table when the dialog box is closed; those in the Hidden Columns list will be temporarily removed from the Result table.

    To move a column from one list to the other, click its name to highlight it; then click the appropriate arrow button to move it to the other list. Alternatively, double click a field name to move it to the other list.

    To select multiple contiguous names on a list, hold down the Shift key while clicking on the first and last entry of the desired list of names. To select multiple non-contiguous names, hold down the Ctrl key while clicking on each name you want to select.

    When the selected names are highlighted, click the appropriate arrow button to move the highlighted names to the other list.

  3. When the columns are in the desired lists, click the OK button to return to the Result window.

    When the Result window redisplays, you will be able to scroll to see all of the columns you placed in the Displayed Columns list, but those in the Hidden Columns list will not be shown.

Parent topic: Work with Query Results


Printing a Result

To print the contents of a Result window:

  1. Be sure that the Result window you want to print is the active window.
  2. Click the Print command from the File menu to display the Print dialog box.
  3. Specify your desired print options.
  4. Click OK to send the results to the printer or print queue.
Parent topic: Work with Query Results


Changing the Result View

When you successfully run a query or open a table, SQLWizard displays the results in the view you specify. You specify the desired views in any of the following ways:

  • You can set a default view using the Options utility.
  • You can set a default view for the session using the Current Query Options command from the Query menu.
  • You can select a result view before you run the query, using the Result Table View or Result Form View command on the Query menu.
  • After a Result window is displayed, you can switch between Table and Form views using either the Result Table or Result Form command from the Query menu, or by clicking on the Table View or Form View button on the toolbar.
Parent topic: Work with Query Results


Saving a Result to a File

To output the contents of a Result window to a file rather than to the printer, choose the Output command from the File menu.

To save the contents of a Result window to a file:

  1. Make certain that the Result window you want to save is the active window.
  2. Click the Output command from the File menu to display the Output File (Save As) dialog box.
  3. Specify a file name.
  4. Click OK to save the results to a file.
Parent topic: Work with Query Results


Use the Result Window for Data Entry

  • Enabling Edit Mode
  • Updating Records
  • Inserting New Records
  • Deleting Records
  • Undeleting a Deleted Record
Parent topic: SQL Wizard


Enabling Edit Mode

Because there is additional overhead in preparing a query result for Edit mode, the default is to disable Edit mode when a query is run. If you want to make Edit mode the default for all queries that you run, use the Query Run tab in the Options utility to set Allow Editing on.

Note: Certain query results are not editable. For example, a join cannot be edited. Also, if you are running against a database other than XDB Server, and the Check Unique Key option is enabled, your tables must have a primary key or unique index defined before you will be allowed to enable Edit mode.

To enable Edit mode:

  • To enable Edit mode before you run a query, click the Allow Editing command on the Query menu.
  • To enable Edit mode after you run a query (a Result window is active), click the Allow Editing command on the Record menu.
Parent topic: Use the Result Window for Data Entry


Updating Records

When you are in Edit mode, you can type in changes directly on the Result Table or Result Form. As you make the changes, they will be reflected in the Result window.

You can use the clipboard features of your operating environment to copy data from records and paste it into other applications. When you are in Edit mode you can copy data from one field and paste it into another field in the Result window.

Note: You can only cut, copy, or paste the data from one field at a time. You cannot copy an entire record or set of records to the clipboard.
Note: When cutting, copying, or pasting large amounts of data (such as in a varchar or longvarchar field), it may be faster to open a zoom window instead of working in the cell of the Result window. To open a zoom window, double click the desired field in the Result window, or place your cursor in the field and click Zoom from the View menu.
Parent topic: Use the Result Window for Data Entry


Inserting New Records

SQLWizard allows you to type in the values for a new record by moving to the blank record provided at the end of every Result window or by using Data Entry mode. If you are working with a large result set, and do not want to take the time to move to the end of the result set, you can switch to Data Entry mode, which shows only newly inserted records.

To insert a record in a result window:

  1. Make certain you are in Edit mode by checking the Allow Editing command in the Record menu.
  2. Click the New command from the Record menu. This will move the cursor to a blank record at the end of the result set, marked with an @ symbol.
  3. Begin typing the data for the new record. As you type, a new blank record is appended at the end of the result set, so that you will be ready to insert the next record.
  4. Move out of the current record to insert it into the database.

To insert records in Data Entry mode:

Data Entry mode provides you with a special view of a Result window that only shows newly inserted records. All existing records are temporarily hidden from view.

  1. Make certain that you are in Edit mode by checking the Allow Editing command on the Record menu.
  2. Click the Data Entry command from the Record menu. The Result window will be redisplayed. Initially you will only see a blank record into which you enter data for a new record.
  3. Enter data into the new record. A new blank record will appear at the bottom of the result set.
  4. As you enter the data for each record and move to the next record, the new record is inserted into the database.
Parent topic: Use the Result Window for Data Entry


Deleting Records

You can delete a single record from the Result window. If you want to delete many records at once, you should write an SQL DELETE statement.

To delete a record:

  1. Click the record number in the left column to select the record.
  2. From the Record menu, click the Delete command.
  3. At the confirmation dialog box, click OK to confirm the delete action.
Parent topic: Use the Result Window for Data Entry


Undeleting a Deleted Record

After you delete a record, you can undo the delete operation using the Undo Delete command on the Record menu. The record will be marked undeleted and will reappear in the Result window.

To undo a delete:

  1. Open the Record menu.
  2. Click the Undo Delete command, if it is enabled.

    If the Undo Delete command is not enabled, the record cannot be undeleted from the Result window. If you are working with Autocommit turned off, you may still be able to rollback the operation.

Parent topic: Use the Result Window for Data Entry


Import Files

  • Accessing the Import Utility
  • To import data downloaded from a mainframe
  • To import data from a PC application
  • Choosing a File Format and Source File
  • Choosing an Existing Table to Receive Your Data
  • Creating a New Table to Receive Your Data
  • Saving an Import Specification
  • Opening an Import Specification
  • Clearing Specifications from the Import Window
  • Resolving Import Errors
  • Viewing Your Source File
  • Viewing Your Batch Command File
  • Setting Import Options
  • Setting Import Defaults
  • Constructing a Batch Import File
  • Running a Batch Import File
  • Running Batch Import from the Command Line
Parent topic: SQL Wizard


Accessing the Import Utility

The SQLWizard Import utility is accessed using the New command on the File menu.

To access the Import window:

  1. From the File menu, click the New command.
  2. Click Import from the submenu.

    SQLWizard displays the Import window.

    Notice that the name in the title bar remains untitled until you save the specifications to an import batch file. This is accomplished using the Save As command from the File menu or by exiting the Import window. When you exit the Import window without saving, you are prompted to save the Import file. This will save an import batch file to the path and file name you specify.

Parent topic: Import Files


To import data downloaded from a mainframe

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. Click New on the File menu.
  3. Click Import.
  4. On the Import window, select the type of file from the Format list.
  5. Change the settings as appropriate for the type of file you are importing.
  6. Click Browse to find the file you want to import (or type its location and name and press Enter).

The data structure appears in the XDB Table Information group.

  1. Make any changes you require to the data types and other table structure information.
  2. Select Create Table if you want to create a new table.
  3. Select Replace Data if the table already exists and you want to replace its data with the imported data.
  4. Click Browse to specify the table's location and name (or type the location and name in the Table field and press Enter).
  5. Click Run on the Import menu.

A new table is created or an existing table is updated with the imported data.

Parent topic: Import Files


To import data from a PC application

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. Click New on the File menu.
  3. Click Import.
  4. On the Import window, select the type of file from the Format list.
  5. Change the settings as appropriate for the type of file you are importing:
    • Delimited (Free-Format) ASCII Files - fields are delimited by a fixed character, usually a comma or a tab
    • Columnar (Fixed-format) ASCII Files - fields and records have fixed lengths
  6. Click Browse to find the file you want to import (or type its location and name and press Enter).

    The data structure appears in the XDB Table Information group.

  7. Make any changes you require to the data types and other table structure information.
  8. Select Create Table if you want to create a new table.
  9. Select Replace Data if the table already exists and you want to replace its data with the imported data.
  10. Click Browse to specify the table's location and name (or type the location and name in the Table field and press Enter).
  11. Click Run on the Import menu.

    A new table is created or an existing table is updated with the imported data.

Parent topic: Import Files
Related information
Delimited (Free-Format) ASCII Files
Columnar (Fixed-format) ASCII Files


Choosing a File Format and Source File

The first step when importing a file into an XDB Server table is to choose a source file and specify the format of that source file. Some source file formats require you to specify additional parameters. The following steps are required when importing most source file types.

To specify a source file:

  1. Choose a format that reflects the type of file you want to import from the drop-down list.
  2. Specify the format items required for the selected format. As you choose different formats, the requirements displayed in the Source File Information section vary.
  3. Click the Browse button in the Source File Information section to display the Open Import dialog box. Use the List Files Of Type drop-down list to select the type of files to display.
  4. Choose the path and name of a source file. The default path is the application path. Click OK.

    SQLWizard examines the source file, creates a suggested table definition for the table (if not DSNTIAUL) and displays it in the XDB Table Information section of the window.

    Note:

    If importing large files, use the Options command from the Import menu to limit the number of records that will be read to determine the suggested table definition.

  5. At this point, you have two options for the destination of your imported data.
    • You can specify an existing XDB Server table as the destination for your data. In this case, you can choose to overwrite or append the import data.
    • You can create a new table to receive the imported data. You can use the suggested table format or modify the format as desired.
Parent topic: Import Files


Choosing an Existing Table to Receive Your Data

The following steps are required when choosing an existing XDB Server table into which you want to insert the imported data.

To choose a table to receive your imported data:

  1. Specify the file whose contents you want to import.
  2. Click the Browse button in the XDB Table Information section on the Import window.

    SQLWizard displays the Open dialog box.

  3. Choose the desired location, AuthID, and table name of the destination table and click OK.

    The selected location, AuthID, and table name appear in the Table field on the Import window. Also, SQLWizard retrieves the table definition from the system catalog and displays it in the Table Definition Grid at the bottom of the Import window.

    Note:

    *
    Instead of selecting a destination table as described in steps 2 and 3, click the Table tab in the Catalog Browser dialog box, and drag a table name to the Table field on the Import window.

  4. You can now choose whether to append or replace data. If you wish to replace (overwrite) the data that exists in the selected table, click the Replace Data checkbox. Otherwise, new data from the file will be appended to the existing data in the table.
  5. Click the Run button or click the Run command from the Import menu to import the data.

    The status of the import operation is displayed in the status bar across the bottom of the window. When the import completes, this line indicates that the import is complete and lists the number of records imported.

Parent topic: Import Files


Creating a New Table to Receive Your Data

You can use SQLWizard Import to create a table to hold the data you are importing.

To create a new table to receive your imported data:

  1. Specify the file whose contents you want to import.
  2. Review the suggested table definition and decide if you need to change it. There are two ways to change the table definition:
    • Revise specifications on the Table Definition Grid on the Import window, as explained in Step 3.
    • Use the definition of an existing XDB Server table as a template for creating the new table. To do this, choose an existing table using the Browse button in the XDB Server Table Information section or drag a table from the Catalog Browser dialog box. Then change the name of the table. The Create Table checkbox will automatically be checked. You can make any desired changes to this new table's definition as described in Step 3.
  3. You can modify any of the non-gray fields in the Table Definition Grid. To make a change, click the desired field and change any information. If there are multiple entries for the selected field, a drop-down list appears as shown below. Otherwise, type the desired information.
    Note: If you need to restore the XDB Server-suggested table definition (based on the source file), use the Recalculate command on the Import menu. This command will reread the source file and recalculate a table definition from it.

  4. *
    When you have finished entering your specifications, click the Run command on the Import menu or click the Run button on the toolbar.

    The status of the import operation appears in the status bar at the bottom of the window. When the import completes, a completion message appears and the number of imported records is listed.

Parent topic: Import Files


Saving an Import Specification

You save an import specification in the same manner as you would save any file. You can save an import specification before or after you run it.

To save an import specification:

  1. *
    Click the Save button on the toolbar, or click the Save or Save As command from the File menu. If you click Save As, or if you click Save and this file has never been saved before, the standard Save dialog box is displayed.
  2. Choose a destination drive and path where you want to store the Batch Import file. Enter or select a file name. The default path is the current Application Path. The default file extension is .imp.
Parent topic: Import Files


Opening an Import Specification

An import specification that has been saved can be opened and reused to save time respecifying the import options.

To open an import specification:

  1. *
    Click the Open button on the toolbar or click the Open command from the File menu.

    SQLWizard displays the Open dialog box. If an Import window is active, the List Objects Of Type field shows the *.imp extension and all files with that extension are listed. If an Import window is not active, click the down-arrow button for the List Objects Of Type field to display the drop-down list; select the *.imp extension.

  2. Choose the name of the import file you want to open to display its specifications in the Import window.
    Note:

    Only batch files containing one import transaction can be opened into an Import window. To run a Batch Import file containing more than one transaction, use the Run Batch command from the File menu.

Parent topic: Import Files


Clearing Specifications from the Import Window

After an import process completes, you can clear the contents of the Import window before entering specifications for the next file you want to import.

To clear current import specifications from the Import window, click the Clear Form command from the Import menu. The current specifications are removed from the Import window and are replaced with default settings where appropriate. Defaults are based on your settings in the Import Options dialog box and the Default Settings dialog box

Parent topic: Import Files


Resolving Import Errors

SQLWizard Import allows you to set error handling options on the Import Options dialog box. You can specify the action to be taken when an error is encountered, and you can have Import generate two different kinds of log files.

If you encounter errors, use the Source File command from the View menu to compare the source file against selections made on the Import window. This is most effective with free- and fixed-format ASCII files.

Parent topic: Import Files


Viewing Your Source File

The Import utility allows you to view the contents of your source file. If the file has delimiters, this feature allows you to see what the delimiter characters are. For fixed column files, you can use this feature to check the column lengths and starting positions.

To view the contents of a source file:

  1. Click the Source File command from the View menu.

    SQLWizard displays the Open Source File dialog box.

  2. Choose the source file you want to view.
  3. Click OK.

    The contents of your source file are displayed in a scrollable, sizable window. You can view source files of any format. However, this feature is most effective with ASCII files (see note regarding binary files, below).

    A ruler is provided so that you can quickly assess the column positions in your source file. Use the cursor keys to navigate through the source file contents.

    Note:

    If you are viewing a binary file, you may find that the viewer stops displaying data before it reaches the end of your file. This will occur if your data contains a null character (00 hex), which to the viewer, signals the end of data.

Parent topic: Import Files


Viewing Your Batch Command File

The Import utility allows you to view the current import specifications as they would appear if they were saved to a Batch Import file. You can copy these commands to any text editor. This allows you to use SQLWizard to create any number of Batch Import transactions, and copy/append them in a file in your text editor. Later, you can use SQLWizard to run the series of import transactions as a batch file.

To view import specifications in Batch Import file format:

  1. Enter your import specifications.
  2. Click Batch Import Commands from the View menu.

    The import specifications are displayed in a scrollable and sizable window. Use the cursor keys to navigate through the import specifications. Use the Save As command from the File menu to save the import command as a Batch Import file.

Parent topic: Import Files


Setting Import Options

Options you select on the Import Options dialog box remain in effect for the duration of the current session or until you change them. In this case, a session is defined as an open occurrence of the Import window. You can have multiple Import windows open at the same time and each Import window can be using a different set of values for the options.

Instructions for how to set import options are provided below.

To set import options:

  1. Click the Options command from the Import menu.

    SQLWizard displays the Import Options dialog box.

  2. Click to choose an Insert Mode.
    Note:

    Be aware of the limitations of using Engine Direct Write.

  3. Click to choose an On Error option to control error handling.
  4. For the Recalculate option, choose All or specify the number of records to be examined when SQLWizard suggests a table definition for the file you are importing.
  5. To specify a Commit Interval, click the checkbox in this section and enter a value to indicate how many records should be imported between each commit.
  6. To convert data from one code page to another, select an entry from the ASCII Conversion box. Leave the field set to (None) if no conversion is required.
  7. Click to choose the desired Logging methods. To track overall import errors, select the Errors checkbox and provide a file name. To track bad records and have them inserted in a file, select the Records checkbox and provide a file name.
  8. Click OK.
Parent topic: Import Files


Setting Import Defaults

The Default Settings dialog box allows you to specify your preferred settings for import options. Choosing your own defaults means that each time you open a new Import window, your preferred settings will be in effect automatically. You can revert to SQLWizard's suggested default values at any time by clicking the Defaults button.

Default values can be set for Free-format ASCII, Fixed-format ASCII, and DSNTIAUL formats. In addition, you can set default values for the insert mode, commit interval, existing table append/replace option, and number of records to be read for the recalculate table function.

Instructions for how to set import options are provided below.

To set default parameters for Import:

  1. Click the Defaults command from the Import menu.

    SQLWizard displays the Default Settings dialog box.

  2. Select the desired defaults in each section of the dialog box. To revert to SQLWizard's suggested defaults, click the Defaults button.
  3. Click OK. The new defaults are available the next time you open a new Import window.
Parent topic: Import Files


Constructing a Batch Import File

A Batch Import file may include many transactions to import many files of the same or different types, as necessary. A complete transaction must be defined for each file being imported. Collectively, the batch commands for a given transaction are a set of parameters that describe the source file and the destination table.

Perhaps the easiest way to construct a Batch Import file containing multiple imports is to let SQLWizard create the batch commands for you. For each file you want to include in your Batch Import file, fill in the required information on an Import window. Then use the Save As command from the File menu to save the Batch Import specifications. After you have created these individual Batch Import files, use any text editor to copy and paste all of the batch commands into one file. Add comments as desired.

When constructing a Batch Import file, keep in mind the following:

  • Each transaction in a Batch Import file must begin with a name or label in square brackets to separate each set of batch commands. For example, you might want to enter the name of the table to identify the transaction, such as [EmployeeTable].
  • Each Batch Import command must end with a semicolon (;).
  • You may include spaces and blank lines as needed to improve readability. The spaces and blank lines are ignored by SQLWizard.
  • C-style comments can be used in the specifications. For example: /* comment */.
  • All commands are case-insensitive. You may use any combination of upper and lower case letters (for example, INSERT_MODE is the same as Insert_Mode).

Not all Batch Import commands are required for all file types. For instance, the field and record delimiter (FLD_DELIMITER and REC_DELIMITER, respectively) commands are required only for importing delimited, free-format ASCII files. Likewise, the OFFSETS command is required only for importing from columnar, fixed-format ASCII files.

Parent topic: Import Files


Running a Batch Import File

Saved Batch Import files have a file name extension of *.imp and are typically saved in the current application path. You can specify a different path for your batch file when you save it.

To run a Batch Import session:

  1. From the File menu, click the Run Batch command.
  2. Choose the desired Batch Import file.
  3. Click OK. If you choose an old-format batch file, import will prompt you to convert the file so that SQLWizard can run it.
    Note:

    If you are running under Windows, you can start a batch session by double clicking the .imp file name in the File Manager.

    Commands initiated from the .imp file begin to run in batch mode. If any bad data is found, error messages will be displayed depending on the way you set up your import options. (To set import options, use the Options command from the Import menu.)

    Import processing messages are displayed across the bottom of the SQLWizard window in the status bar.

Parent topic: Import Files


Running Batch Import from the Command Line

In addition to running Batch Import from within SQLWizard, you can run it directly from the development environment's command prompt.

To run an import from the development environment's command prompt, call the xwiz40n program file, and pass it the name of your Batch Import file as shown below:

xwiz40n [-iiniFile] filename.IMP

where:

iniFile | specifies which .ini file Wizard should use when it runs the import. If you do not specify an .ini file, xdb.ini in the working directory is used.
filename | is the name of your Batch Import file. The filename must include the extension .imp in its name (such as imfile.imp). If you do not specify the path to filename, the .imp file must be in the current application path (the application path is specified on the PATHS tab).

The following example shows how a Batch Import file called "iempfile" would be run. In this example, the contents of file emp.ini is used to establish SQLWizard's operating configuration.

xwiz40n -ic:\emp.ini iempfile.imp
Parent topic: Import Files


Export Files

  • Accessing the Export Utility
  • To export data for uploading to a mainframe
  • To export data to a PC application
  • To export DDL commands
  • Choosing a Target File and File Format
  • Specifying the Source Table in Design Mode
  • Specifying the Source Table in SQL Mode
  • Saving an Export Specification
  • Opening Export Specifications
  • Clearing Specifications from the Export Window
  • Resolving Export Errors
  • Viewing Your Target File
  • Viewing Batch Command Files
  • Setting Export Options
  • Setting Export Defaults
  • Constructing a Batch Export File
  • Running a Batch Export Session
  • Running Batch Export From the Command Line
Parent topic: SQL Wizard


Accessing the Export Utility

The SQLWizard Export utility is accessed using the New command on the File menu.

To access the Export window:

  1. From the File menu, click the New command.
  2. Click Export from the submenu.

    SQLWizard displays the Export window.

    When you access the Export window, notice that the name in the title bar remains untitled until you save the specifications to a Batch Export file. This is accomplished using the Save As command from the File menu or by exiting the Export window. If you exit the Export window without saving, you are prompted to save the Export file specification. You can save the specification to a batch import or Batch Export file.

Parent topic: Export Files


To export data for uploading to a mainframe

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. In SQL Wizard, click New > Export on the File menu.
  3. On the Export window, in the Source Table Information group, click Browse to specify the table's location and name (or type the location and name in the Table Name field and press Enter).

    The names of all columns in the table appear in the Included list.

  4. Remove the names of any columns you don't want to export by clicking them in the list and clicking <<.
  5. Optionally, change the order of columns in the table by selecting a column name and clicking Up or Down to change its position in the list.
  6. Optionally, type a condition (in SQL syntax) in the Where Condition field to export a subset of rows in the table. For example: CUST_NO < 12850
  7. In the Target File Information group, select the type of file from the Format list.
  8. Change the settings as appropriate for the type of file you want to create.
  9. Click Browse to specify a location and name for the file you want to create (or type a location and name and press Enter).
  10. Click Run on the Export menu.

    A new file is created containing the data you specified.

Parent topic: Export Files


To export data to a PC application

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. In SQL Wizard, click New > Export on the File menu.
  3. On the Export window, in the Source Table Information group, click Browse to specify the table's location and name (or type the location and name in the Table Name field and press Enter).

    The names of all columns in the table appear in the Included list.

  4. Remove the names of any columns you don't want to export by clicking them in the list and clicking <<.
  5. Optionally, change the order of columns in the table by selecting a column name and clicking Up or Down to change its position in the list.
  6. Optionally, type a condition (in SQL syntax) in the Where Condition field to export a subset of rows in the table. For example: CUST_NO < 12850
  7. In the Target File Information group, select the type of file from the Format list.
  8. Change the settings as appropriate for the type of file you are importing:
    • Delimited (Free-Format) ASCII Files - fields are delimited by a fixed character, usually a comma or a tab
    • Columnar (Fixed-format) ASCII Files - fields and records have fixed lengths
  9. Click Browse to specify a location and name for the file you want to create (or type a location and name and press Enter).
  10. Click Run on the Export menu.

    A new file is created containing the data you have specified.

Parent topic: Export Files
Related information
Delimited (Free-Format) ASCII Files
Columnar (Fixed-format) ASCII Files


To export DDL commands

  1. Click SQL for DB2 on the Tools menu; then click SQL Wizard.
  2. In SQL Wizard, click New > Export on the File menu.
  3. On the Export window, in the Source Table Information group, click Browse to specify the table's location and name (or type the location and name in the Table Name field and press Enter).

    The names of all columns in the table appear in the Included list.

  4. Remove the names of any columns you don't want to export by clicking them in the list and clicking <<.
  5. Optionally, change the order of columns in the table by selecting a column name and clicking Up or Down to change its position in the list.
  6. Optionally, type a condition (in SQL syntax) in the Where Condition field to export a subset of rows in the table. For example: CUST_NO < 12850
  7. In the Target File Information group, select SQL Statements from the Format list.
  8. Check any options you want to include.
  9. Click Browse to specify a location and name for the file you want to create (or type a location and name and press Enter).
  10. Click Run on the Export menu.

    A new file is created containing the DDL corresponding to the options you selected.

Parent topic: Export Files


Choosing a Target File and File Format

The first step in exporting table data to a file is to specify a file to receive the data and the format for that file. Some file formats require you to specify additional parameters. Instructions for defining the Target File are provided below.

To specify a target file to receive data:

  1. Click the Browse button to display the Open Export File dialog box and select an existing file. Alternatively, you can type a path and file name in the File Name field.
  2. Choose a format for the selected target file. Click the down-arrow button from the Format field to display a drop-down list. Notice that as you choose different formats, the requirements displayed in the Target File Information section vary.
  3. Specify the format items required for the selected format.
  4. At this point, you have two options for how to specify the source table from which you will be exporting data. You can use Design mode or SQL mode to specify this information.
    • Export Design mode allows you to select a table to export and specify a WHERE condition to limit the number of records that will be exported. In addition, you can select specific fields to export and change the order of the fields exported. Design mode is the default export display for the Export window unless you change your default to SQL mode using the Defaults command from the Export menu. See Specifying the Source Table in Design ModeSpecifyingtheSourceTableinDesignMode.307 to continue setting up your export specifications.
      Note:

      *
      Click the Export Design button on the toolbar to switch to Design Mode.

    • Export SQL mode allows you to specify export criteria using an SQL SELECT statement.
      Note:

      *
      Click the Export SQL button on the toolbar to switch to SQL Mode.

    Note:

    If you switch from Design mode to SQL mode after specifying table, column, and WHERE clause information, all of these specifications will be shown as an SQL SELECT statement in the SQL Query section of the Export window.

Parent topic: Export Files


Specifying the Source Table in Design Mode

In Design mode, you choose an XDB Server table and the fields you want to include or exclude in the Source Table Information section of the Export window. You can add a WHERE condition to limit the data that will be exported from the table. If you do not specify a WHERE condition, all rows in the table will be exported.

Note: XDB Server indexes are not exported with the table. One exception to this rule is that if the table uses indexes and you export the table specifications and data to SQL Statements format, you can choose to have Export generate the SQL statement to re-create the indexes.

Instructions on how to choose a source table using Design mode are provided below.

To specify source table information and export using Design Mode:

  1. Click the Browse button in the Source Table Information section on the Export window.

    SQLWizard displays the Open dialog box. (Alternatively, you can type a fully qualified table name and skip to Step 3.)

  2. Choose the desired location, AuthID, and table; then click OK.

    The selected table name appears in the Table field as a three-part name. If you have not already entered a destination file name in the Source File Information area at the top of the Export window, a default target file name is entered for you. The default name uses the first eight characters of the table name and the extension for the format that has been specified.

    Note:

    *
    From the Catalog Browser dialog box, click the Table tab and drag a table name to the Table field on the Export window.

  3. Choose which columns you want to export by moving them to the Included and Not Included lists as desired. The default is to export all columns.

    To move a column from one list to the other, click its name to highlight it, then click the appropriate arrow button to move it to the other list. Alternatively, double click a column name to move it to the other list.

    To select multiple contiguous items on a list, hold down the Shift key while clicking on the first and last entry of the desired list of items. To select multiple non-contiguous items, hold down the Ctrl key while clicking on each name you want to select. When the selected items are highlighted, click the appropriate arrow button to move the highlighted items to the other list. To move all columns from one list to the other, click the appropriate double-arrow button.

  4. If desired, you can re-arrange the order of the columns. Your exported data can list the columns of information in a different order than the original table.

    To move a column within the Selected list, click its name to highlight it, then click the Up or Down button as desired.

  5. If desired, you can limit the number of records to be exported by specifying a WHERE condition. This allows you to export only those records that meet the condition. If you do not specify a WHERE condition, all rows in the specified XDB Server table will be exported.

    To specify a WHERE condition, type a standard SQL WHERE clause. You do not need to type the word where.

  6. Click the Run command from the Export menu to start the export process.
    Note:

    *
    Click the Run button on the toolbar to start the export process.

    SQLWizard displays the progress of the export operation in the status bar. When the export is complete, the status bar reports the number of records exported.

Parent topic: Export Files


Specifying the Source Table in SQL Mode

When in SQL mode, the Export window permits direct entry of an SQL SELECT statement in the Query area to specify the table and columns to be exported. You can include a WHERE condition to limit the number of records that are selected for export.

Note:

*
Click the SQL Mode button on the toolbar to change from Design Mode to SQL Mode.

If you enter table, column, or WHERE condition information while in Design Mode, and then switch to SQL Mode, the SELECT statement will be generated for you. You can modify it as desired and export the table, or copy the SQL statement to a text editor.

Likewise, you can copy an SQL statement from the SQL Edit window or your text editor and paste it into the Query field on the Export window.

Note:

If you modify the SELECT statement in certain ways (add a JOIN, for example) you will not be able to switch to Design Mode.

Instructions on how to choose a source table using SQL mode are provided below.

To specify and export a source table using SQL mode:

  1. Click in the Query display area of the Export window to position your cursor in the text entry box.
  2. Type an SQL SELECT statement. Enter a WHERE clause if desired. Alternatively, you can copy a select statement from another SQLWizard window or from a text editor, and paste it into the Query display area of the Export window.
  3. Click the Run command from the Export menu.
    Note:

    *
    Click the Run button on the toolbar to start the export process.

    SQLWizard displays the progress of the export operation in the status bar. When the export is complete, the status bar reports the number of records exported.

Parent topic: Export Files


Saving an Export Specification

You save an export specification in the same manner as you would save any file. You can save the export specification before or after you run it.

To save an export specification:

  1. Select the Save or Save As command from the File menu.
    Note:

    *
    Click the Save button on the toolbar.

    If you select the Save As command, or if save and this file has never been saved before, SQLWizard displays the standard Save As dialog box.

  2. Choose a destination drive and path, and enter or select a name for the export specification. The default paths are the current application path. The default file extension is .exp.
Parent topic: Export Files


Opening Export Specifications

You can retrieve an Export specification that you previously saved with SQLWizard, and display it in an Export window.

To open an export specification:

  1. Click the Open command from the File menu.
    Note:

    *
    Click the Open button on the toolbar.

    SQLWizard displays the Open dialog box. If an Export window is active, the List Objects Of Type field shows the *.exp extension and all files with that extension are listed. If an Export window is not active, you may need to click the List Files Of Type drop-down menu to select the *.exp extension.

  2. Choose the name of the export file you want to open. Once selected, the specifications will display in the Export window.
    Note:

    Only batch files containing one export transaction can be opened into an Export window. To run a Batch Export file containing more than one transaction, use the Run Batch command from the File menu.

Parent topic: Export Files


Clearing Specifications from the Export Window

After completing an export process, you can clear the contents of the Export window before entering specifications for the next table you want to export.

To clear current export specifications from the Export window, click the Clear Form command from the Export menu. The current specifications are removed from the Export window and are replaced with default settings where appropriate. Defaults are based on your settings in the Export Options dialog box and the Default Settings dialog box.

Parent topic: Export Files


Resolving Export Errors

SQLWizard Export allows you to set error handling options on the Export Options dialog box. You can specify the action to be taken when an error is encountered, and you can have Export generate a log file.

If you encounter errors , use the Target File command from the View menu to compare the file containing the exported data against selections made on the Export window. This is most effective with free- and fixed-format ASCII files.

Parent topic: Export Files


Viewing Your Target File

After you export a table, you can view the contents of the target file.

To view the contents of a target file:

  1. Click the Target File command from the View menu.

    SQLWizard displays the File Open dialog box.

  2. Choose the target file you want to view.
  3. Click OK.

    SQLWizard displays the contents of your target file in a scrollable and sizable window. You can view target files of any format. A ruler is provided so that you can quickly assess information about your target file.

Parent topic: Export Files


Viewing Batch Command Files

The Export utility allows you to view the current export specifications as that would appear if they were saved to a Batch Export file.

Likewise, you can view the Batch Import commands that would be generated from the information currently appearing on the Export window. This is the SQL that would be saved if you use the Save or Save As command and saved the file as an Import (*.IMP) file.

Generating a batch import file at the time you are exporting data can help you when you plan to import the data onto another XDB Server. You would take the exported data file and the corresponding batch import file to the other XDB Server. Then use batch import on that machine to transfer the data onto that XDB Server.

To view export specifications in batch file formats:

  1. Enter specifications on the Export window.
  2. Click Batch Export Commands from the View menu to display the Batch Export form of the specifications in a scrollable, sizable window.
  3. Click Batch Import Commands from the View menu to display the batch import form of the specifications.
  4. If you plan to reuse this specification, click the Save As command from the File menu to save the batch file.
Parent topic: Export Files


Setting Export Options

Options you select on the Export Options dialog box remain in effect for the duration of the current session or until you change them. In this case, a session is defined as an open occurrence of an Export window. You can have multiple Export windows open at the same time, and each Export window can be using a different set of values for the options.

Instructions for how to set export options are provided below.

To set export options:

  1. Click the Options command from the Export menu.

    SQLWizard displays the Export Options dialog box.

  2. Click to choose an On Error option to control error handling.
  3. To convert data from one code page to another, select an entry from the ASCII Conversion box. Leave the field set to (None) if no conversion is required.
  4. If you want to log errors that may be encountered during an export process, click the On checkbox in the Error Logging section and type a fully qualified file name. To choose an existing file for logging errors, click the Browse button to display the File Open dialog box.
  5. Click OK to save your preferences.
Parent topic: Export Files


Setting Export Defaults

The Default Settings dialog box allows you to specify your preferred settings for exporting to Free ASCII, Fixed ASCII, and DSNTIAUL formats. In addition, you can specify which view of the Export window you would rather use: Design Mode or SQL Mode. Choosing your own defaults means that each time you open a new Export window, your preferred settings will be in effect automatically. You can revert to XDB Server's suggested default values at any time by clicking the Defaults button.

Instructions for how to set export defaults are provided below.

To set default format parameters for Export:

  1. Click the Defaults command from the Export menu.

    SQLWizard displays the Default Settings dialog box.

  2. Type your own defaults to use for each format.
  3. Click OK to save your defaults. These defaults will be used each time you open a new Export window.
Parent topic: Export Files


Constructing a Batch Export File

A Batch Export command file can include many transactions to export many tables of the same or different types. A complete transaction must be defined for each table being exported. Collectively, the batch commands for a given transaction are composed of a set of parameters that describe the source table and the destination file.

Perhaps the easiest way to construct a Batch Export file containing multiple exports is to let SQLWizard create the batch commands for you. For each file you want to include in your Batch Export file, fill in the required information on an Export window. Then use the Save As command from the File menu to save the Batch Export specifications. After you have created these individual Batch Export files, use any text editor to copy and paste all of the batch commands into one file. Add comments as desired.

When construction a Batch Export file, keep in mind the following:

  • Each transaction in a Batch Export file must begin with a name or label in square brackets to separate each set of batch commands. For example, you might want to enter the name of the table to identify the transaction, such as [EmployeeTable].
  • Each Batch Export command must end with a semicolon ( ; ).
  • You may include spaces and blank lines as needed to improve readability. The spaces and blank lines are ignored by SQLWizard.
  • C-style comments (/*  comment  */) can be used in the specifications.
  • All commands are case-insensitive. You may use any combination of upper and lower case letters. (For example, FORMAT= FIXASC; is the same as Format = FIXasc.)

Not all commands are required for all file types. For instance, the FLD_DELIMITER and REC_DELIMITER commands are required only for exporting to free-format ASCII files. The SPACE command is required only for fixed-format ASCII files.

Parent topic: Export Files


Running a Batch Export Session

Saved Batch Export files have a file name extension of .exp and are typically saved in the current application path. You can specify a different path for your batch file when you save it.

To run the Batch Export session:

  1. Click the Run Batch command from the File menu.
  2. Choose the desired Batch Export file.
  3. Click OK. If you choose an old-format batch file, Export will prompt you to convert the file so that SQLWizard can run it.
    Note:

    If you are running under Windows, you can start a batch session by double clicking the .exp file in the File Manager.

Commands initiated from the .exp file begin to run in batch mode. If any bad data is found, error messages will be displayed depending on the way you set up your Export Options. (To set Export options, use the Options command from the Export menu.)

Export processing messages are displayed across the bottom of the SQLWizard window in the status bar.

Parent topic: Export Files


Running Batch Export From the Command Line

In addition to running Batch Export from within SQLWizard, you can run it directly from the development environment's command prompt.

To run an export from the development environment's command prompt, call the xwiz40n program file, and pass it the name of your Batch Export file as shown below:

xwiz40n [-iiniFile] filename.EXP

where:

iniFile | specifies which .ini file Wizard should use when it runs the export. If you don't specify an .ini file, xdb.ini in the working directory is used.
filename | is the name of your Batch Export file. The filename must include the extension exp in its name (for example, xfile.exp). If you do not specify the path to filename, the .exp file must be in the current application path (the application path is specified on the PATHS tab.

In following example, a Batch Export file called "xempfile" would be run. In this example, the contents of file emp.ini is used to establish SQLWizard's operating configuration.

xwiz40n -ic:\xdb\emp.ini xempfile.exp
Parent topic: Export Files


Use Batch SQL Scripts

  • Creating a Script File
  • Saving and Reusing a Script
  • Running a Script
  • Running in Step Mode
  • Running From the Command Line
  • Using Host Variables
  • Changing Host Variable Values
Parent topic: SQL Wizard


Creating a Script File

A script file is generally created by saving SQL statements from the SQL Edit window. For example, you can create a script by performing a query, then switch to the Edit window to incorporate additional SQL commands. You can also incorporate any of the special batch SQL commands, which functionality specific to batch operation.

SQLWizard's Export facility provides another way to create a script file. When you export data from XDB Server, you can optionally include SQL statements with it. This process creates a script file that, when run, automatically recreates the table from the exported data.

If you prefer, you can create a script by typing your SQL statements directly into a file using any ASCII text editor. Regardless of how you create your script file, the following script-file syntax must be observed:

  • Commands can be placed on separate lines terminated by a semicolon (;) or on the same line terminated by a semicolon (;).
  • Commands may be typed in upper or lower case.
  • Spaces and blank lines can be included to improve readability. Spaces and blank lines are ignored by SQLWizard.
  • Spaces are not required before and after an equal sign ( = ), however they can be included to improve readability.
  • Comments can be inserted by bracketing them in comment characters (e.g., /*comment text */), or by prefixing them with two hyphens.

    Both comment types are shown below.

      /* Get customer list with company & state   */
  /* List customers with balance over $2,000. */
  SELECT company, state, balance  --retrieve columns
  FROM customer             --from customer table
  WHERE balance>$2,000;        --show records with
  --balance over $2000
Parent topic: Use Batch SQL Scripts


Saving and Reusing a Script

You can save the contents of an SQL Edit window to a .SQL file and retrieve it later to edit or run.

To save an SQL script from an active SQL Edit window:

  1. From the File menu, click the Save As command.

    SQLWizard displays the Save As dialog box.

  2. Choose SQL Scripts (*.SQL) from the list of Object Types.
  3. Provide a name for the file.
  4. Click OK to save the file.

To open an SQL script from an active SQL Edit window:

  1. From the File menu, click the Open command.
  2. Choose SQL Scripts (*.SQL) from the list of Object Types.
  3. Locate and select the file you want to open; then click OK.

    The script is opened in an SQL Edit window.

  4. Edit the file adding and deleting the necessary SQL commands. You can also incorporate batch commands.
Parent topic: Use Batch SQL Scripts


Running a Script

You can run a batch script from within SQLWizard, with or without opening the script file in an SQL Edit window. You can also execute a script without opening SQLWizard, by calling the file from your development environment's command prompt.

To run a batch SQL script from an active SQL Edit window:

  1. From the File menu, click the Run Batch command.
  2. When the Run Batch dialog box appears, select the .SQL script file you want to run.
  3. Click OK. The batch SQL script is loaded and immediately begins to execute.

    After execution, a message box is displayed telling you that you will not be able to edit the contents of the selected batch SQL script in the current SQL Edit window. To edit the script, reopen it in a separate SQL Edit window.

  4. Click Continue.

    The results are displayed in the Result window.

Parent topic: Use Batch SQL Scripts


Running in Step Mode

Use "step mode" to execute your batch SQL script one SQL command at a time.

To use the Step Mode feature:

  1. From the Query menu, click the Current Query Options command.

    SQLWizard displays the Query Options dialog box.

  2. Select the All Commands option in the Execute group box. This option ensures that the entire script is executed at run time.
  3. Click OK.
  4. From the Query menu, click Step Mode.
  5. Follow the steps described in Running a Script to run your batch SQL script.

    SQLWizard steps through the script one SQL command at a time, and displays the results of each command in a separate Result window.

Parent topic: Use Batch SQL Scripts


Running From the Command Line

In addition to running a SQL script from SQLWizard, you can run it directly from your development environment's command prompt.

Note: You can run a script file by double clicking the SQL file name in the Windows File Manager.

To run a script from the development environment's command prompt, call the xwiz40n program file, and pass it the name of your script file as shown below:

xwiz40n [-iiniFile] filename.SQL

where:

iniFile | is the initialization file that SQLWizard uses when it runs the script. If you don't specify an initialization file, XDB.INI in the working directory is used.
filename | is the name of your SQL script file. If you do not specify the path to filename the script file must be in the current application path (the application path is specified on the Paths tab. Note: The filename must include the extension "SQL" in its name (for example, sfile.sql).

The following example shows how a script called "newmember" would be called. In this example, the contents of file member.ini will establish SQLWizard's operating configuration.

xwiz40n -ic:\member.ini newmember.sql
Parent topic: Use Batch SQL Scripts


Using Host Variables

When you include host variables in batch SQL scripts, you are prompted for values. You can also specify values for host variables by using the Parameters command from the Query menu so that you will not be prompted at run time for values.

To run a batch SQL script that uses host variables:

  1. Select the Run Batch command from the File menu.

    SQLWizard displays the Run Batch dialog box.

  2. Choose the .SQL file you want to run; then click OK.

    The selected batch SQL script is loaded and it begins to execute.

  3. When prompted for host variables, type in the value.
  4. Click the Quotes checkbox if the value needs to be enclosed in quotes.

    Results of the batch SQL script are displayed in the Result window.

Parent topic: Use Batch SQL Scripts


Changing Host Variable Values

After a query containing host variables has run (you have entered values for the host variables when prompted), the host variable values are saved. This allows you to re-run the query without being prompted each time.

It you need to change the values of the host variables, use the Parameters command from the Query menu. You can also use this command to preset the values for the host variables so that you are not prompted at run time.

To change or preset host variable values:

  1. From the Query menu, click the Parameters command.

    The Enter Host Variable Values dialog box is displayed containing all of the host variables for the current query, if previously run or previously specified.

  2. Make changes as needed.
  3. Click OK.
Parent topic: Use Batch SQL Scripts


Administer XDB Users and Groups

  • Adding Users to the System
  • Deleting an AuthID
  • Updating an Existing User Specification
  • Adding a New Group and Assigning Users
  • Deleting a Group
  • Updating Your Group Information
  • Adding Priorities
  • Deleting Priorities
  • Updating Priorities
Parent topic: SQL Wizard


Adding Users to the System

*
The Add button on the Add/Modify User dialog box allows you to add a new AuthID and its associated specification into the appropriate XDB Server system tables using the information currently displayed on the dialog box. Once information for a user has been inserted, it remains on the dialog box. You can type another new AuthID (using the previous AuthID's information as a template) to add more users.

When connecting to an XDB Server, the AuthID is checked against values in XDB Server System tables on the XDBACF database in the SYSTEM location to determine if there are any SecondaryIDs or groups associated with it. All available groups are displayed in a scrollable list. Groups to which a particular AuthID is assigned (if any) are highlighted.

Instructions for adding new users to an XDB Server's list of AuthIDs are provided below. See the description of the Add/Modify User dialog box for information about each item on that dialog box.

To add a new AuthID and privileges for a new user:

  1. Click the Users command from the Admin menu to display the Add/Modify User dialog box.
  2. Type a new AuthID in the User ID field or click the User ID drop-down arrow and select an existing user. You can use an existing user's specifications for a new user by typing a new AuthID over the old one.
  3. In the Security Options group:
    • Select Password Required if this user will be required to enter a password when connecting to the XDB Server.
    • Select Access Authority to enable this user to access the XDB Server. You can temporarily disable an existing AuthID by deselecting the Access Authority box, leaving all other AuthID information intact.
  4. If you checked Password Required, type a Password according to the required Enforcement Level setting at the bottom of the dialog box. Retype the same password in the Verification field. Be sure to tell the user the password you have assigned, and explain how the user can change it.
  5. In the User Types section, click User or Super User. A super user has special system-wide privileges as explained in the description of the Add/Modify User dialog box. Super-user status is usually reserved for XDB Server Administrators and their assistants.
  6. Specify optional items: Comments, Groups, and Priorities.

    If desired, type a comment in the User Comments field.

    If you have created groups, they will be displayed in the Group Membership list. Assign the user to one or more groups by clicking on the desired group name(s). (You can also assign users to groups when you create the groups.

    If you have created priorities, they will be displayed in the Priorities list. Assign the user to one or more priorities by clicking on the desired priority name(s).

    Note: To select multiple, contiguous names on a list, hold down Shift while clicking on the first and last entry of the desired list of names. To select multiple non-contiguous names, hold down Ctrl while clicking on each name you want to select.
  7. Click the Add button to insert this user's information to SQLWizard security tables.
  8. Add, delete or update other users if desired. When done, click the Close button to exit the Add/Modify User dialog box.
Parent topic: Administer XDB Users and Groups


Deleting an AuthID

*
The Delete button allows you to remove an AuthID from the system based on the AuthID displayed. Confirmation is required before an AuthID is removed.

Note: You can temporarily deny a user's access to the system without deleting the AuthID or changing any specifications. To deny access, de-select the Access Authority checkbox, then click the Update button.

Instructions for deleting AuthIDs from an XDB Server's list of AuthIDs are provided below. See the description of the Add/Modify User dialog box for information about each item on that dialog box.

To delete an AuthID:

  1. Click the Users command from the Admin menu to display the Add/Modify User dialog box.
  2. Use the User Name drop-down list to choose the AuthID to be removed.
  3. Click the Delete button. SQLWizard prompts you to confirm the removal of the selected AuthID.
  4. Add, delete, or update other users if desired. When done, click the Close button to exit the Add/Modify User dialog box.
Parent topic: Administer XDB Users and Groups


Updating an Existing User Specification

*
The Update button changes information for an existing AuthID. Any modifications you make for an AuthID on the Add/Modify User dialog box are not saved to the system tables until you click the Update button.

Instructions for modifying AuthID specifications are provided below. See the description of the Add/Modify User dialog box for information about each item on that dialog box.

To update modified specifications for an existing AuthID:

  1. Click the Users command from the Admin menu to display the Add/Modify User dialog box.
  2. Use the User Name drop-down list to choose the AuthID to be changed.
  3. Modify the desired specifications for the selected AuthID.
  4. Click the Update button to save your changes to the XDB Server security database.
  5. Add, delete or update other users if desired. When done, click the Close button to exit the Add/Modify User dialog box.
Parent topic: Administer XDB Users and Groups


Adding a New Group and Assigning Users

*
Groups provide a method for controlling location, database, and table level access according to GroupID (GROUP NAME). Users with certain system needs can be given the required access by being in a group that has been granted privileges. When you grant an authority or privilege to a GroupID (using the SQL GRANT command), all users who are members of that group will have the privilege assigned to the group.

Instructions for how to create a new group and assign users to it are provided below. (If a group already exists, you also have the option to assign users to the group by using the Add/Modify User dialog box.

To add a new group and assign users:

  1. Click the Groups command from the Admin menu to display the Groups dialog box.
  2. Type a name in the Group Name (GroupID) field. The GroupID can be up to eight characters long and must follow the rules for a short identifier.
  3. If desired, type a comment about the new GroupID or its purpose in the Comments field. You can enter up to 254 characters.
  4. While you are still viewing the Groups dialog box, you can assign users to the group you are now creating by moving their AuthIDs from the User ID list to the Member Of list. AuthIDs remaining on the User ID list will not be members of the group. You can also assign a user to a group from the Add/Modify User dialog box.

    To move an AuthID from one list to the other, click its name to highlight it and then click the appropriate arrow button to move it to the other list. Alternatively, double click an AuthID to move it to the other list. Use a double-arrow button to move all AuthIDs to the other list.

    To select multiple contiguous names on a list, hold down Shift while clicking on the first and last entry of the desired list of names. To select multiple non-contiguous names, hold down Ctrl while clicking on each name you want to select. When the selected AuthIDs are highlighted, click the appropriate arrow button to move the highlighted AuthIDs to the other list.

  5. Click the Add button to create the group and its assigned members.
  6. Add, delete, or update other groups if desired. When done, click the Close button to exit the Groups dialog box.
Parent topic: Administer XDB Users and Groups


Deleting a Group

*
When you delete a GroupID, all privileges associated with that group are deleted and all members of the deleted group are dissociated from that group.

Instructions for how to delete a group are provided below. See the description of the Groups dialog box for information about each item on that dialog box.

To delete a group:

  1. Click the Groups command from the Admin menu to display the Groups dialog box.
  2. Click the Group Name drop-down list to select the GroupID you want to delete.
  3. Click the Delete button. You are prompted to confirm deletion of the selected group.
  4. Add, delete, or update other groups if desired. When done, click the Close button to exit the Groups dialog box.
Parent topic: Administer XDB Users and Groups


Updating Your Group Information

*
There are two items of information you can change in a group definition. You can modify the comment that describes the group or its purpose and you can change the list of users who are members of the group. (Another way to change group membership is by accessing an AuthID using the Add/Modify User dialog box.

Instructions for how to change items in a group definition are provided below. See the description of the Groups dialog box for information about each item on the that dialog box.

To modify an existing GroupID's comment and/or membership:

  1. Click the Groups command from the Admin menu to display the Groups dialog box.
  2. Click the Group Name drop-down list to select the GroupID you want to change.
  3. Change the comment or memberships as desired.
  4. Click the Update button. A message box is displayed giving you a summary of the modifications you made.
  5. Add, delete, or update other groups if desired. When done, click the Close button to exit the Groups dialog box.
Parent topic: Administer XDB Users and Groups


Adding Priorities

*
Instructions for defining a new priority are provided below. See the description of the Define Priority dialog box for information about each item on that dialog box.

To add a new set of priorities:

  1. Click the Priorities command from the Admin menu to display the Define Priority dialog box.
  2. Click in the Priority Name field and type a name for the new priority set. (Click the Priority Name drop-down list to view the names of existing priorities.)
  3. Click in each field on the dialog and type the desired setting. (You can use Tab to move from field to field.
  4. Click the Add button to add the new priority and its specifications.

    As soon as a priority is defined, it can be assigned to an AuthID (use the Users command from the Admin menu.). However, it will not take effect until the XDB Server has been shut down and restarted.

  5. Add, delete or update other priorities if desired. When done, click the Close button to exit the Define Priority dialog box.
Parent topic: Administer XDB Users and Groups


Deleting Priorities

*
When you delete a priority, all users who were assigned that priority are no longer restricted by any Governor limitations.

Instructions for deleting a priority are provided below. See the description of the Define Priority dialog box for information about each item on that dialog box.

To remove a priority from the system:

  1. Click the Priorities command from the Admin menu to display the Define Priority dialog box.
  2. Click the Priority Name drop-down list and select the priority you want to drop.
  3. Click the Delete button. A message box is displayed asking you to confirm deleting the currently displayed Priority.
  4. Add, delete or update other priorities if desired. When done, click the Close button to exit the Define Priority dialog box.
Parent topic: Administer XDB Users and Groups


Updating Priorities

*
You can change any of the fields on the Define Priority dialog box, and update the system tables to reflect the new restrictions. Any user who has been assigned that priority will be under the new restrictions the next time the XDB Server is shut down and restarted.

Instructions for updating a priority are provided below. See the description of the Define Priority dialog box for information about each item on that dialog box.

To change an existing priority:

  1. Click the Priorities command from the Admin menu to display the Define Priority dialog box.
  2. Click the Priority Name drop-down list and select the priority you want to change.
  3. Click in each field on the dialog that you want to change and type the desired setting. (You can use Tab to move from field to field.)
  4. Click the Update button. A message box is displayed stating that the priority has been updated.
  5. Add, delete, or update other priorities if desired. When done, click the Close button to exit the Define Priority dialog box.
Parent topic: Administer XDB Users and Groups


Implement Security and Authority

  • Setting Up Security
Parent topic: SQL Wizard


Setting Up Security

The following is an overview of the process used to set up and activate security on an XDB Server. This procedure must be performed by someone with super-user authority.

Note: The following procedure assumes a single-server environment. If you are working in a multi-server environment or you are using a "global" security server, see your SQL Option Server Administration Guide for additional setup procedures.
  1. the XDB Server, use the XDB Server Configuration utility to enable the server security option. See your SQL Option Server Administration Guide for details.
  2. From the XDB Server or from any client workstation attached to the XDB Server, use Options to select the XDB Server, specify your super-user ID, and enable security. Set the options as follows:
    • On the Connect tab, select the XDB Server on which you want to set up security.
    • On the Connect tab, specify your super-user ID (e.g., INSTALL).
    • On the Security tab, enable the Client Security option.
  3. Use SQLWizard to create a "user ID" and password for each user of this XDB Server. Only the users that you define during this step will be allowed to log on to the Server, and they must present the proper user ID/password combination when they do so.
    Note: Apart from permitting access to an XDB Server, the user ID you create in this step 2 also serves as a user's default AuthID. You can override this default assignment by assigning a Secondary ID to the user, or the user can change it using the SET CURRENT SQLID command.

    When you create a user ID, you must also specify whether that user will have user or super user privileges. A super user can access any table on the Server and can perform operations such as creating and dropping locations. An XDB Server is shipped with one super user called INSTALL. You can create others at your discretion. However, super-user privileges should be limited to a few trusted users with database administration expertise. There are other classes of privileges you can assign to other users using the GRANT command. For details, see your SQL Option Server Administration Guide and topics for the GRANT command.

  4. When you are finished creating users, run the Options utility at each user's workstation and turn on the Client Security option. You must also inform your users of the user ID and password you assigned to them in step 3. Once they log on, they can change their password using SQLWizard's Change Password command.
Parent topic: Implement Security and Authority


SQL Option Server Administration

  • To start the XDB Server
  • To start the XDB Server in blue screen mode
  • To stop the XDB Server
Parent topic: How to...


To start the XDB Server

  • From the XDB Service Controller, click Start.
Parent topic: SQL Option Server Administration
Related information
To shut down the XDB Server
To log on to an XDB Server
To log off an XDB Server


To start the XDB Server in blue screen mode

  1. From your desktop, click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Compatibility Tools > Net Express Command Prompt (32-bit).
  2. Enter xcplet20.
Parent topic: SQL Option Server Administration


To stop the XDB Server

  • From the XDB Service Controller, click Stop.
Parent topic: SQL Option Server Administration
Related information
To start the XDB Server
To log on to an XDB Server
To log off an XDB Server


Reference

  • SQL Reference
  • XDB Directive Options
  • Batch SQL Commands
  • Batch Import Commands
  • Batch Export Commands
  • Error Messages
  • User Interface Reference
Parent topic: SQL Option for DB2


SQL Reference

  • Overview
  • SQL Commands
  • Syntax Notation
  • DB2 Support
  • SQL Statements
  • Clauses
  • Functions Overview
  • System Table Overview
  • Overview of XDB Server Specifications
  • XDB Server Reserved Words
  • SQL Communications Area (SQLCA)
  • SQL Descriptor Area (SQLDA)
  • SQL Option Server TUTORIAL Location
  • Objects Used by the SQL Option Server
Parent topic: Reference


Overview

In the relational model, data are logically presented in two dimensional tables made up of rows and columns, as shown in the figure below. The intersection of a row and a column is known as a field. Fields contain individual data items called field values. The rows of a table, also known as records, are made up of a sequence of values that describes an occurrence of an entity (for example, a set of values that describes a particular employee). The columns of a table consist of a collection of attributes, which are characteristics of an entity. For example, each employee has an employee ID and a name.

When creating database objects, you must follow certain conventions. For example, every table must have a unique name, and within a table, every column must have a unique column name and a data type. When you ask the XDB Server to retrieve or modify data, it performs the job on the set of rows and columns you specify. An action may affect rows, columns or fields.

Colums and Rows

There exists no universally accepted standard for database terminology. Throughout this reference and other XDB Server documentation, we use a number of relational terms that have specific meanings that may differ from normal usage.

  • Database
  • Data Objects
  • Language Elements
  • Naming Conventions
  • Three-Part Names
  • Code Page Support
  • Data Types
  • Other Data Types
  • Assignment And Comparison
  • Constants
  • Special Registers
  • Labeled Duration
Parent topic: SQL Reference


Database

The use of the term database varies widely in the industry. The term database, as used in XDB Server documentation, has two meanings:

  • Relational Database

    In the generic sense, a database is an entire collection of data managed by a database management system. It is in this sense that the term database is used most often in XDB Server documentation.

  • XDB Server Database

    In a more specialized sense, a database is a named object created using the CREATE DATABASE command. A database consists of a collection of tables or a collection of table spaces and index spaces. Generally, if used in this sense, the term database is followed by the database name (if it is not clear from the context that an XDB Server database object is being discussed).

Parent topic: Overview


Data Objects

Most of the following terms are named data elements or objects that together allow you to organize data to best suit your needs. Both simple data models and complex systems that mirror mainframe configurations can be constructed with the building blocks provided. Except for records (rows), all database objects are created using one of the forms of the CREATE statement.

  • Alias
  • AuthID
  • Catalog
  • Column
  • Database
  • Index
  • Index Space
  • Key
  • Location
  • Query
  • Record
  • Storage Group
  • Synonym
  • Table
  • Table Space
  • View
Parent topic: Overview


Alias

An alias is an alternate one-part name for the three-part name of a table or view. An alias can be assigned to a table in the current location or in a remote location. This differs from a synonym, which can rename an object only in the current location. Aliases can be used by anyone, while synonyms can only be used by the AuthID that created them.

For example, the one-part name, EMPLOYEE, can be created as an alias for the three-part name, TUTORIAL.TUTORIAL.EMPLOYEE. Thereafter, the alias, EMPLOYEE , can be used to reference TUTORIAL.TUTORIAL.EMPLOYEE.

Parent topic: Data Objects


AuthID

An authorization ID, or AuthID, is a name associated with a user or process for auditing, monitoring and security purposes. An AuthID is also the second part of a three part name.

Parent topic: Data Objects


Catalog

The system catalog is a collection of special system defined tables that contain information about objects in the system. Most of the system tables are automatically maintained by the system when administrative tasks are performed, but there are some that must be updated manually. The XDB Server catalog consists of DB2-compatible tables (created with AuthID SYSIBM) and XDB Server-specific tables (created with AuthID SYSXDB.)

Parent topic: Data Objects


Column

A column is an attribute (or characteristic) of the entities described by the rows of a database table or result table. Each column is associated with a column name and a data type. Although the terms field and column are frequently used interchangeably in discussions of SQL programming; when we use the term field in the context of relational tables, we are referring to the intersection of a row and a column in a table or query result.

Parent topic: Data Objects


Database

An XDB Server database is a collection of tables, indexes and table spaces. Each database definition occupies a separate directory. A database consists of a number of files that may span several directories and disks if stogroups are used. Database names are stored in the system table SYSIBM.SYSDATABASE. A database is created using the CREATE DATABASE statement. Every location contains a default database (DSNDB04) and a system catalog database (DSNDB06). In addition a location may include a number of user-defined databases. The SYSTEM location includes two additional databases: XDBACF (stores information on security and access) and DSNDDF (stores information on other locations.)

Parent topic: Data Objects


Index

An index is an optional data structure used to speed retrieval of data or enforce certain constraints (such as uniqueness) on the records in a table. When you create an index on a column (or columns), the XDB Server stores an appropriately ordered list of all the values in that column as a separate index file. While this can greatly improve the performance of queries, maintaining an index slows down DML update operations (such as INSERT and DELETE) somewhat, and the index itself takes up memory. You must make a decision about creating indexes each time you create a table.

Parent topic: Data Objects


Index Space

An index space is a defined area of mainframe disk storage that is used to store the entries of an index. The XDB Server currently provides only syntactical support for index spaces. No entries are made into the system catalog when index space commands are executed.

Parent topic: Data Objects


Key

A key is one or more columns used to identify a row, or to establish a constraint such as uniqueness or referential integrity relationships. When you create or alter a table, you can establish keys which place constraints on the values that can be entered into that table's columns. Establishing a Foreign Key, for example, causes the XDB Server to reject any column values that violate the criteria defined for that Foreign Key constraint. The XDB Server supports three types of keys: primary, candidate and foreign.

Parent topic: Data Objects


Location

A location is a collection of tables, databases and related objects organized in a structured fashion. An XDB Server database system can have multiple locations, all managed by the same XDB Server. Through the use of a three-part naming scheme and other security measures, users can access more than one location at a time, as well as access remote locations, which are managed by other copies of an XDB Server, or by DB2 (accessed through XDB Link). The current location is set using the SET LOCATION TO or the CONNECT statement.

In order to operate, the XDB Server requires a SYSTEM location, which contains information on other locations, as well as security information. It is strongly recommended that you store your own data in a location other than the SYSTEM location.

Parent topic: Data Objects


Query

A query is a SELECT command that generates a result table or an intermediate result table. A query may be a subcomponent of another type of SQL statement, such as an INSERT or CREATE VIEW command. A nested query may also be part of a search condition. There are three forms of a query: subselect, fullselect and select-statement. For more information on these three query forms (as well as the SELECT INTO statement), see the SELECT command in SQL Commands. See also SELECT Clause, FROM Clause, and WHERE Clause. Queries are not named data objects, however XDB Server provides special facilities for saving and recalling queries as though they were named objects. Also, when writing programs containing embedded SQL, queries are usually associated with a cursor, which can be equated with a query name in the scope of the program.

Parent topic: Data Objects


Record

A record is a row of a table that presents information about a particular object, event or relationship. The words row and record are used interchangeably in this reference. A record is identified by the values contained in its fields. Note that a record is not a named data object. It is uniquely identified by the data it holds.

Parent topic: Data Objects


Storage Group

A storage group (stogroup) is a name assigned to a specific drive and directory used for physical storage. When using XDB Link to access DB2, a stogroup refers to a set of DASD volumes on which data is stored.

Parent topic: Data Objects


Synonym

A synonym is another name given to an existing table or view. Usually a synonym is used to define a more meaningful name for use by a particular application, or by a particular set of users. Synonyms are frequently used to replace two or three-part object names with one-part names (synonyms themselves can only be defined as one-part names). Synonyms can only be used to refer to a data objects in the current location, and can only be used by the AuthID that created them. This differs from aliases, which can rename objects in other locations, and can be used by anyone.

Parent topic: Data Objects


Table

A table is named data object that consists of a collection of homogeneously defined rows, all with consistent column names and data types. A table is the data object that actually stores the data that describes an entity or relationship. A result table is the output of a query (SELECT command). A result table also presents data in a two-dimensional format consisting of rows and columns. However, a result table is unnamed and transient.

Parent topic: Data Objects


Table Space

A table space is a physical area of disk space that holds a table. The table space object is provided for compatibility with DB2, and its use is optional when running against an XDB Server database. The XDB Server records all information about table spaces in the system catalog, but does not actually create table spaces.

Parent topic: Data Objects


View

A view is a virtual table that is logically defined over one or more tables in a location. Its definition includes a SELECT statement that determines the columns displayed, as well as the values it contains at any point in time. Views permit you to query subsets of data or joins of multiple tables as though they are an actual table. Only the view definition is stored in the location -- not the data retrieved by a view. Some views are updatable. Update commands performed on views actually affect the underlying table(s). Views may make it easier to access data by organizing it in more meaningful ways, or by restricting the rows retrieved to those that pertain to the needs of a particular application. Views can also be used for security reasons. For example, a user might be given access to only a specified set of records or columns.

Parent topic: Data Objects


Language Elements

This topic describes the basic syntax elements used to construct SQL keywords, command statements and object names.

More:

  • Characters
  • Tokens
  • Identifiers
  • NULL Value
  • Characters
  • Tokens
  • Identifiers
  • NULL Value
Parent topic: Overview


Characters

The elementary symbols of the SQL language are ASCII characters -- which may be classified as letters, digits and special characters -- plus non-English characters (or extended character sets) provided by IBM standard code pages.

  • Letters

    These are the letters of the alphabet (A-z). Letters are stored as entered by the user, however the sort sequence used for ordering and comparing data (including case sensitivity) is set by the XDB Server administrator for a particular location. A user can use the location default or define a special sort sequence.

  • Digits

    These are the numeric characters between 0 and 9.

  • Special Characters

    These are all characters other than letters and digits.

  • Extended Character Sets

    These are non-English characters.

Parent topic: Language Elements


Tokens

The syntactical elements of the SQL language are called tokens. Tokens are divided into two types:

  • Ordinary Tokens

    These are numeric constants, ordinary identifiers, or keywords. Ordinary tokens cannot include spaces, and must be followed by either delimiter tokens or spaces.

  • Delimiter Tokens

    These are string constants, delimited identifiers, operators (=, <=, <, >=, >, !=, ^=), or special characters identified in command syntax.

When a command extends to more than one line, tokens cannot be broken in the middle.

Parent topic: Language Elements


Identifiers

Identifiers are tokens used to form names. They fall into two categories:

  • Ordinary Identifiers

    These must begin with a letter (A-z), and may include letters (including standard IBM code page extended characters), digits and the special characters #$%&{}. The maximum length of ordinary identifiers depends on the object they name, as shown below. See XDB Server Specifications for a complete list of identifier limits.

    Short Identifiers. These are up to 8 characters long. Examples are database names and AuthIDs.

    Long Identifiers. These are up to 18 characters long (except location names are up to 16 characters.) Examples are column and table names.

    Follow the character selection rules below when naming short or long identifiers:

    • The first character can be chosen only from the letters of the alphabet (A-z) if using XDB mode.
    • If using DB2 mode, the letters of the alphabet (A-z), the special characters @#$, and IBM Code Page extended characters can be chosen for the first character position.
    • All following characters can follow the rules for Ordinary Identifiers defined above (which apply equally to XDB mode and DB2 mode).
  • Delimited Identifiers

    These consist of one or more characters enclosed within double (") or single quotes ('). A delimited identifier may contain either double quotes or apostrophes (or single quotes), in which case the identifier is usually delimited by the other type of quote. For example, the string Joe's Place can be used as a delimited identifier when written as:

    "Joe's Place"

    You can place both " and ' characters within the same string by using "" for " if you are using " as the string delimiter, or '' for ' if you are using ' as the string delimiter. For example, to enter the string value 5'11" into a character field, use a command like:

    UPDATE patient
SET height='5''11"'
WHERE name="o'HARA"
Parent topic: Language Elements


NULL Value

A NULL value is an undefined value for a field, indicating there is no data available. For sorting purposes, the NULL value's ordinal value depends on its location's definition. The XDB server considers NULL values to be the smallest possible value in all non-EBCDIC environments and with sensitive EBCDIC locations. In all other EBCDIC locations, NULL is sorted as the highest possible value.

Note that NULL values are not the same as blank or zero. NULL values are treated as undefined in mathematical operations, with the result that many expressions involving NULL are in turn resolved as NULL, or undefined.

Parent topic: Language Elements


Naming Conventions

On an XDB Server, database objects are assigned names, or identifiers, made up of ASCII characters (with the option of specifying extended character sets). Naming conventions depend on the object being named. The following list defines the terms used for certain types of database object names. Keep in mind that a short identifier is up to 8 characters long, while a long identifier is up to 18 characters long.

More:

  • AuthID
  • Column Name
  • Database Name
  • Index Name
  • Location Name
  • Table Name
  • Table Space Name
  • View Name
  • AuthID
  • Column Name
  • Database Name
  • Index Name
  • Location Name
  • Table Name
  • Table Space Name
  • View Name
Parent topic: Overview


AuthID

A short identifier that is associated with a user or process for auditing, monitoring and security purposes. AuthIDs must be unique within the system. However, an AuthID can be used by more than one individual or session.

Parent topic: Naming Conventions


Column Name

A long identifier that designates a table, view or result column. A column-name may be qualified or unqualified. A qualified column-name is prefixed with a qualifier followed by a period. A qualifier may be a table-name, view-name, correlation-name, or query-name.

The column name can be used to:

  • Define the name of the column in a table or view, as in a CREATE TABLE command.
  • Identify a column in a table or view, as in a CREATE INDEX or a COMMENT ON command.
  • Specify values of a column or intermediate result, as in a function, expression, GROUP BY clause, ORDER BY clause, or search condition.

In the above contexts only, column names may be qualified by prefixing them with a table name, view name or correlation name, followed by a period. Qualification is used to express correlated references, or to resolve ambiguous references. It can also be used simply as a matter of convenience.

Note that column names must be qualified when appearing in COMMENT ON commands.

Parent topic: Naming Conventions


Database Name

A short identifier that designates a database. Database-names must be unique within a location.

Parent topic: Naming Conventions


Index Name

A long identifier that designates an index. An index-name qualified by an AuthID must be unique within a location.

Parent topic: Naming Conventions


Location Name

An identifier that designates a subsystem. For compatibility with DB2, a location-name is limited to 16 characters in length, but otherwise follows the rules for a long identifier. Location-name must be unique within all locations to be accessed by a particular copy of the XDB Server.

Parent topic: Naming Conventions


Table Name

A long identifier that designates a table. A table name may be qualified or unqualified. A qualified table name is prefixed with a qualifier followed by a period. Table names that are qualified by location name and AuthID are known as three-part-names. A table name must be unique within all locations when it is qualified by location name and AuthID. An unqualified table name must be unique among all tables within a location that have the same owner.

Parent topic: Naming Conventions


Table Space Name

A short identifier that designates a table space. A table space name must be unique within a physical XDB Server database.

Parent topic: Naming Conventions


View Name

A long identifier that designates a view. It must satisfy the same rules as a table name, and must be unique among table names.

Parent topic: Naming Conventions


Three-Part Names

A data object name can be partially or fully qualified, or unqualified -- consisting of the table-identifier alone. Three-part names are provided by the XDB Server to support the concept of distributed units of work (DUW), which allows an application to access data at different servers and locations.

More:

  • Fully Qualified Table Names
  • Partially Qualified Table Names
  • Fully Qualified Table Names
  • Partially Qualified Table Names
Parent topic: Overview


Fully Qualified Table Names

A fully qualified (or three-part) table name consists of three distinct elements separated by periods:

location-name.authid.table-identifier

The first qualifier, location-name, indicates which location should be searched for the table. On an XDB Server, there can be multiple locations per server, while in DB2 the location name designates the DBMS (or subsystem) at which the table is stored. The SYSTEM.SYSIBM.SYSLOCATIONS table catalogs all locations accessible to the XDB Server.

The second qualifier, authid, is the Authorization ID (AuthID) that designates the owner of the table.

Parent topic: Three-Part Names


Partially Qualified Table Names

Partially qualified table names can be one-part or two-part names. A two-part table name consists of the table-identifier qualified by the authid, and implicitly qualified by the location-name of the current location.

A one-part table name consists of the table-identifier only, which is implicitly qualified by the location-name of the current location, and the Current SQLID special register. The value of the Current SQLID special register is determined by the following rules:

  • For static SQL statements, the Current SQLID is the identifier specified in the QUALIFIER option of the BIND command used to bind the SQL statements, or the owner of the plan or package.
  • For dynamic SQL statements, the Current SQLID is the identifier contained in the Current SQLID special register -- initially the same as USER, but changing to reflect execution of a SET CURRENT SQLID command. The Current SQLID can also be influenced by security exits and SecondaryID specifications.
Note:

Aliases and synonyms can be used for alternative names for a table or view. Aliases can be used to assign alternative names for tables and views that are not in the current location. Synonyms can only be used to rename tables or views in the current location.

Parent topic: Three-Part Names


Code Page Support

The character set used for naming database objects includes code page support for several standard IBM Code Pages. Code pages allow you to choose from a wide range of non-English characters when naming database objects. The XDB Server supports several IBM standard code pages that provide an extended character set when naming database objects, and when typing data into tables. The code pages supported and their character set definitions are shown in Code Page Character Sets.

The code page characters are in addition to the base character set. The base character set depends on the SQL Compatibility Mode under which you are running:

  • In XDB mode, the base character set includes: a-z, A-Z, 0-9, and the special characters # $ % & { } and _.
  • In DB2 mode, the base character set includes: a-z, A-Z, 0-9, and the special characters # @ $ and _. (Do not use an underscore (_) in an AuthID.)

The SQL Compatibility Mode is set in the Options Utility. For more information on the SQL Compatibility Mode, see the Options User's Guide. Characters from the selected code page may be used in:

Alias Names | Index Space Names
AuthIDs | Stogroup Names
Collection Names | Synonyms
Column Names | Table Names
Constraint Names | Table Space Names
Data Entry | View Names
Index Names |

Do not use any code page characters in a database name or location name. To maintain consistency with DB2, database and location names are restricted to the characters in the base character set.

Parent topic: Overview


Data Types

A column can contain any of the data types discussed in this topic. The following table lists the limits (minimum and maximum values) for each data type in XDB mode. The limits of XDB Server and DB2 data types are identical, except in the cases of float and char types. (See the footnotes in the table). The system rejects, or truncates (depending on the data type) values that fail to satisfy the rules for a data type.

Type | Minimum | Maximum | Storage
Smallint | -32,768 | 32,767 | 2 bytes
Int[eger] | -2,147,483,648 | 2,147,483,647 | 4 bytes
float (single) (See note 1.) | 1.2E-38 | 3.4E+38 | 4 bytes
float (double) (See note 1.) | 2.2E-308 | 1.8E+308 | 8 bytes
Dec[imal] | 1-10E+31 | 10E+31 | (precision/2)+1
Money | -10E+12 | 10E+12 | 8 bytes
DATE | 1/1/0001 | 12/31/9999 | 6 bytes
TIME | 00:00:01 | 24:00:00 | 6 bytes
Timestamp | 0001-1-01- 00.00.000000 | 9999-12-31- 24.00.000000 | 12 bytes
Char(See note 2.) | 1 byte | 254/4056 bytes (See note 3.) | n bytes
varchar (See note 2.) | 1 byte | 32706 | >= n bytes
long varchar (See note 2.) | 1 byte | 32706 | <= n bytes
Graphic | 2 bytes | 127 bytes | <= n bytes
Vargraphic | 2 bytes | 16353 | <= n bytes
Long Vargraphic | 2 bytes | 16353 | <= n bytes
BLOB(See note 4.) | zero bytes | 2 GB | separate file

Table Notes:

  1. The DB2 limits are 5.4E-79 to 7.2E+75 and 5.4E-79 to 7.2E+75 for single and double precision floating point values respectively.
  2. Can be defined as FOR BIT DATA, which means the column's fields contain a stream of bits that are not to be interpreted as ASCII (or EBCDIC) character codes.
  3. Character fields can store up to 4056 bytes in XDB mode, but only 254 bytes in DB2 mode.
  4. Includes image, binary, varbinary, and long varbinary data types.

More:

  • Smallint
  • Int[eger]
  • Float
  • Dec[imal]
  • Money
  • Date
  • Time
  • Timestamp
  • Char
  • Varchar
  • Long Varchar
  • Graphic
  • Vargraphic
  • Long Vargraphic
  • BLOB
  • Smallint
  • Int[eger]
  • Float
  • Dec[imal]
  • Money
  • Date
  • Time
  • Timestamp
  • Char
  • Varchar
  • Long Varchar
  • Graphic
  • Vargraphic
  • Long Vargraphic
  • BLOB
Parent topic: Overview


Smallint

This data type defines a field that holds whole numbers between -32,768 and 32,767. Smallint fields require 2 bytes of storage. Fractional values inserted into a small integer field are truncated. If the field is specified as NOT NULL WITH DEFAULT, null values will be replaced by zero.

Parent topic: Data Types


Int[eger]

Defines a field containing a whole number between -2,147,483,648 and 2,147,483,647. Fractional values inserted into an integer field are truncated. If the field is specified as NOT NULL WITH DEFAULT, null values will be replaced by zero.

Parent topic: Data Types


Float

FLOAT [(integer)]

This data type defines an IEEE standard 754 floating-point field. Floating-point fields can be defined as single or double (default) precision based on the value of integer. If the value of integer is between 1 and 21, the type is single precision floating-point, which requires 4 bytes of storage. If the value of integer is between 22 and 53 inclusive, the type is double precision floating-point, which requires 8 bytes of storage. If the field is specified as NOT NULL WITH DEFAULT, null values will be replaced by zero.

Parent topic: Data Types


Dec[imal]

DEC[IMAL][(precision[,scale])]

This type of field holds fixed decimal point numbers between approximately 1-10E+31 and 10E+31. Precision is the total allowed number of digits including decimal places. The maximum precision is 31. The default precision is 5. Scale is the number of fractional digits (or decimal places.) The default scale is 0. Scale cannot be greater than precision. If only one parameter is given, it is treated as precision, and the default scale 0 is used. To estimate the storage requirement for decimal fields, round up the result of precision divided by two. If the field is specified as NOT NULL WITH DEFAULT, null values will be replaced by zero.

Parent topic: Data Types


Money

This data type contains a dollar amount between -10E+12 and 10E+12. Money fields are stored as decimal (15,2) fields, and are displayed in a user-defined format. To specify special money formats (for example, foreign currencies), see the Options User's Guide. If the field is specified as NOT NULL WITH DEFAULT, null values will be replaced by zero.

Parent topic: Data Types


Date

Dates designate a point in time according to the Gregorian calendar. Historical dates may not follow this calendar. Arithmetic may be performed on dates within the range shown in the table under Data Types. The standard input format for this data type is mm/dd/yy or mm/dd/yyyy (automatic conversion is performed between these two formats). Character representations of other date formats shown in the following table are permitted in SQL commands. When included in SQL commands, these special date formats must be enclosed in quotes.

When the XDB Server encounters a string in a location where it expects a date, it determines which of the formats is being used, and performs the internal conversion required. For more information on date formats, see the Options User's Guide. Dates are stored as three 2-byte integers. If the field is specified as NOT NULL WITH DEFAULT, null values will be replaced by current date.

Format | Name | Date Format | Example
ISO | International Standards Organization | yyyy-mm-dd | 1992-03-20
USA | IBM USA Standard | mm/dd/yyyy | 03/20/1992
EUR | IBM European Standard | dd.mm.yyyy | 20.03.1992
JIS | Japanese Industrial Standard Christian Era | yyyy-mm-dd | 1992-03-20
LOCAL | Installation-defined | any defined format |
Parent topic: Data Types


Time

The time field data type is defined by the standard input format of hh:mm:ss, using a 24-hour clock. Character representations of other time formats shown in the following table are permitted in SQL commands. Note that when included in SQL commands, these special time formats must be enclosed in quotes. When the XDB Server encounters a string in a location where it expects a time, it determines which of the formats is being used, and performs the internal conversion required. Time requires 3 bytes of storage. If a time field is specified as NOT NULL WITH DEFAULT, null values will be replaced by the current time.

Format | Name | Date Format | Example
ISO | International Standards Organization | hh.mm.ss | 14:30:05
USA | IBM USA Standard | hh:mm AM or PM | 2:30 PM
EUR | IBM European Standard | hh.mm.ss | 14.30.05
JIS | Japanese Industrial Standard Christian Era | hh.mm.ss | 14.30.05
LOCAL | Installation-defined | Any defined format |
Parent topic: Data Types


Timestamp

This combination date and time data type is displayed in the format yyyy-mm-dd-hh.mm.ss.nnnnnn. The following table describes the various components of this field. As an example, the timestamp for 7:45:34pm on June 18, 1992 would be 1992-06-18-19.45.34.000000. When including a timestamp value in an SQL command, enclose it in quotes. Timestamp requires 12 bytes of storage. If the column is specified as NOT NULL WITH DEFAULT, null values will be replaced by the current timestamp.

Format | Description
YYYY | An integer from 0001 to 9999, representing a year.
MM | An integer from 1 to 12 representing a month.
DD | An integer from 1 to 31 (maximum depends on the month and year) representing the day of the month.
hh | An integer from 0 to 24, representing the hour.
mm | An integer from 0 to 59, representing minutes.
ss | An integer from 0 to 59 representing seconds (default 0).
nnnnnn | An integer (up to 6 digits) representing microseconds. If any trailing digit is omitted, 0 is assumed.
Parent topic: Data Types


Char

CHAR (field-length)

A data type containing a fixed length alphanumeric string with a maximum length of field-length characters. The field-length must be a positive number not exceeding 4056 in XDB mode (254 in DB2 mode). This data type can be defined as FOR BIT DATA. If the column is specified as NOT NULL WITH DEFAULT, null values will be replaced by spaces.

Parent topic: Data Types


Varchar

VARCHAR (field-length)

This data type consists of variable length alphanumeric string values with a maximum length of field-length characters. field-length must be a positive number not exceeding 32,706. See the CREATE TABLE command for more information on determining lengths of VARCHAR and LONG VARCHAR variables. Can be defined as FOR BIT DATA. If the column is specified as NOT NULL WITH DEFAULT, null values will be replaced by spaces.

Note: Currently all varchar and vargraphic fields are stored as fixed length fields. In future releases the storage required for these field types will vary according to the data to be stored.
Parent topic: Data Types


Long Varchar

A data type containing variable length alphanumeric strings (maximum length of 32,706 characters). See the CREATE TABLE command for more information on determining lengths of LONG VARCHAR and VARCHAR variables. The storage required depends on the actual length of the value stored. Can be defined as FOR BIT DATA. If the field is specified as NOT NULL WITH DEFAULT, null values are replaced by spaces.

Parent topic: Data Types


Graphic

GRAPHIC (field-length)

Fields of this data type contain fixed length strings (field-length characters long), intended for storing double byte data. The field-length must be a positive number not exceeding 127.

Parent topic: Data Types


Vargraphic

VARGRAPHIC (field-length)

This data type holds variable length strings (maximum length of 2028 characters), intended for storing double byte data. The amount of storage required depends on the actual length of the value stored.

Parent topic: Data Types


Long Vargraphic

This data type contains variable length strings (maximum length of 2028 characters), intended for storing double byte data. The amount of storage required depends on the actual length of the value stored.

Parent topic: Data Types


BLOB

BLOB is a generic term describing any arbitrarily sized block of data. This data type can also be referred to as image, binary or bitdata. A BLOB can be created using one of four syntaxes -- all of which are functionally equivalent. Various syntaxes are provided for compatibility with industry standards and different vendors. The available BLOB data type syntaxes are:

  • image[BLOCK SIZE n]
  • binary(x)
  • varbinary(x)
  • long varbinary

where n is the size of the block used for storage. The x parameter for the binary, varbinary and long varbinary syntaxes is not currently used. The minimum size of a BLOB data type is zero bytes. BLOB data types do not have NULLs. Since BLOB fields can not be used in WHERE clauses or aggregate functions, there is no need for NULLs. However, any BLOB can have a length of zero, which can only be determined by using an API call from a host application.

The BLOB data type allows you to save and manage binary disk files, such as image and sound files. Unlike char, int, and decimal, which have defined purposes and semantics, BLOB data is considered to be "unstructured" and "anonymous" and is not interpreted in any way by the database. Apart from certain limitations, BLOB fields can be accessed and manipulated like any other column in a table.

Tables can have more than one BLOB field; and tables with BLOB fields can be joined in any fashion. There is no maximum size for a BLOB data type. Data stored as a BLOB data type is not stored in the XDB Server table (.TAB) file as other data types are. Instead, each BLOB field is stored as a separate file in the same storage group as the XDB Server table file. Each BLOB file name has the same root file name as the .TAB file.

Each BLOB field in a table is stored in a separate file. The files are partitioned into blocks, and each BLOB record is stored as a linked-list of blocks. The default block size is 2K, and can be set (using the BLOCK SIZE clause) to any value between 64 bytes and 32K during table creation. A free list of blocks is maintained and blocks are reused.

Note:

BLOB data types are not supported with the DOS single-user engine.

Parent topic: Data Types


Other Data Types

For ANSI compatibility, the XDB Server allows you to issue commands to create or alter tables using the following data types. These data types are converted to appropriate XDB Server data types, as shown.

More:

  • Double Precision
  • Numeric
  • Real
  • Double Precision
  • Numeric
  • Real
Parent topic: Overview


Double Precision

When creating or altering a column as a DOUBLE or DOUBLE PRECISION data type, the column is created as (or modified to) a double precision FLOAT type.

Parent topic: Other Data Types


Numeric

NUMERIC[(precision[, scale])]

If the data type NUMERIC is used when creating or altering a table, the column is created as (or modified to) a data type DECIMAL, with the specified precision and scale.

Parent topic: Other Data Types


Real

When creating or altering a column as a REAL data type, the column is created as (or modified to) a single precision FLOAT type.

Parent topic: Other Data Types


Assignment And Comparison

When running against an XDB Server, character strings, dates, times and numbers are not compatible. That is, one type of value cannot always be compared or assigned to an object of another type. NULL values can be assigned to any type of column, except those defined as NOT NULL.

More:

  • Assignment
  • Comparison
  • Assignment
  • Comparison
Parent topic: Overview


Assignment

If an attempt is made to assign a numeric value to a column not large enough to hold it, the fractional part may be truncated. If the integer portion cannot be assigned to a column, an error message is displayed. If an attempt is made to assign a character string to a target field that is too short, the value will be truncated on the right.

Parent topic: Assignment And Comparison


Comparison

Numeric values are compared according to their algebraic values. Character strings are compared by comparing the two strings according to the sort sequence specified for the location, beginning with the leftmost characters. For more information on specifying a sort sequence, see the Options User's Guide and the SQLWizard User's Guide. The default sort sequence is a modified ASCII sequence that does not distinguish between upper and lower case letters.

Parent topic: Assignment And Comparison


Constants

Constants are specific values. Constants may be classified as character string, date, time, timestamp or numeric constants. Character string constants appear inside quotes (single or double) in SQL commands. Numeric constants are subdivided into integer (including both integer and smallint), float, and money constants, according to the data type into which they fall. In SQL commands, date constants should be in the form mm/dd/yy or mm/dd/yyyy (the slash ( / ) is not interpreted as a division operator if the value is determined to be a date). If another date format is used, the date string must be enclosed in quotes. In SQL commands, time constants should be of the format hh:mm:ss. If another time format is used, the date string must be enclosed in quotes. Timestamp constants should be in the format yyyy-mm-dd-hh.mm.ss.nnnnnn.

Parent topic: Overview


Special Registers

The XDB Server supports a set of special keywords that refer to the contents of system variables, which can be referenced in SQL commands.

More:

  • BOTTOM
  • CURRENT DATE
  • CURRENT DEGREE
  • CURRENT PACKAGESET
  • CURRENT RULES
  • CURRENT SERVER
  • CURRENT SQLID
  • CURRENT TIME
  • CURRENT TIMESTAMP
  • CURRENT TIMEZONE
  • LEVEL
  • NULL
  • ROWID
  • BOTTOM
  • CURRENT DATE
  • CURRENT DEGREE
  • CURRENT PACKAGESET
  • CURRENT RULES
  • CURRENT SERVER
  • CURRENT SQLID
  • CURRENT TIME
  • CURRENT TIMESTAMP
  • CURRENT TIMEZONE
  • LEVEL
  • NULL
  • ROWID
Parent topic: Overview


BOTTOM

Lowest recursion level (used with PREVIOUS function). The Data type is smallint.

Parent topic: Special Registers


CURRENT DATE

Today's date, read from system clock. (Also TODAY in XDB mode.) The data type is date. XDB Server also recognizes CURRENT_DATE as a synonym for the CURRENT DATE special register.

Parent topic: Special Registers


CURRENT DEGREE

This special register is supported functionally in that it returns the default value or a value specified with the SET CURRENT DEGREE command. This value does not actually reflect the "degree of parallelism."

Parent topic: Special Registers


CURRENT PACKAGESET

This special register is syntactically supported by the XDB Server for the SET CURRENT PACKAGESET command and the SET Host Variable command. On mainframe DB2 systems, CURRENT PACKAGESET is used to specify the Collection ID of a package that will be used to execute subsequent SQL statements. The data type is CHAR(18) and is padded with blanks to fill out the field. The initial value is blanks.

Parent topic: Special Registers


CURRENT RULES

The new special register CURRENT RULES allows you to specify the SQL rules that apply to the execution of SQL statements. The value in CURRENT RULES also effects the enforcement of table check constraints. See the SET CURRENT RULES statement for further information.

Parent topic: Special Registers


CURRENT SERVER

This special register is similar to the CURRENT SERVER in DB2. The Current Server special register identifies the DBMS to which your application is actively connected.

When running against an XDB Server, this is the name of the current location to which you are connected.

Parent topic: Special Registers


CURRENT SQLID

The CURRENT SQLID is initially the same as USER. The value changes to reflect execution of a SET CURRENT SQLID command. The data type is char(8). CURRENT SQLID can also be influenced by security exits and SecondaryID specifications.

Parent topic: Special Registers


CURRENT TIME

The CURRENT TIME register value is read from the system clock. The data type is time. (Also XTIME in XDB mode.) The XDB Server also recognizes CURRENT_TIME as a synonym for the CURRENT TIME special register.

Parent topic: Special Registers


CURRENT TIMESTAMP

The CURRENT TIMESTAMP register value consists of the current date and time, both of which are read from the system clock. The data type is timestamp. The XDB Server also recognizes CURRENT_TIMESTAMP as a synonym for the CURRENT TIMESTAMP special register.

Parent topic: Special Registers


CURRENT TIMEZONE

A time duration between -24 and 24 hours representing difference in hours between local time and Greenwich Mean Time (GMT). The data type is decimal(6,0). The default returned by CURRENT TIMEZONE is 0.

Parent topic: Special Registers


LEVEL

Recursion level (number of times the PREVIOUS function's recursion algorithm is applied). The data type is smallint.

Parent topic: Special Registers


NULL

Absence of a value. NULL can be used for any data type.

Parent topic: Special Registers


ROWID

DB2 mode only. Data type is integer. Contains the physical row number of the current record. The XDB Server reports this value when a referential integrity error occurs or when a duplicate value is detected in a unique index. You can use ROWID anywhere an expression can be used. For example:

SELECT * FROM CUSTOMER WHERE ROWID = 22;

gets the record in physical row 22. And,

SELECT ROWID,NAME,ADDRESS, FROM CUSTOMER;

gets the row numbers along with other fields in the CUSTOMER table.

When ROWID is used with a join, it represents the row number of the first table in the join.

Parent topic: Special Registers


Labeled Duration

The following table contains keywords known as labeled durations. Each labeled duration keyword corresponds to a specific time unit, interpreted as it normally would be against a calendar or clock. A labeled duration can only be used in an arithmetic expression having date, time or timestamp expressions (or columns) as one of the operands. The expression must resolve to the proper data type. For example, DATE("1993-12-12") + DAY is a valid expression, as is BIRTHDATE + 15 YEARS + 8 MONTHS.

The expression BIRTHDATE + (15 YEARS + 8 MONTHS), on the other hand, cannot be resolved because the system would attempt to add the expression in parentheses first, which contains no date or time operand.

A labeled duration is converted into a decimal (15,0) number before it is applied. If present, decimal places are truncated. All of the keywords listed in the following table can also be used in singular form as labeled durations (for example, YEAR is the same as YEARS, MONTH is the same as MONTHS, etc.)

Duration | Example
YEARS | goldenanniv = weddingdate + 50 years
MONTHS | eligibledate = hiredate + 6 months
DAYS | nextcall = current date + 14 days
HOURS | endshift = beginshift + 8 hours
MINUTES | sampletime = current time + 10 minutes
SECONDS | eta = depart + second(travel) seconds
MICROSECONDS | adjustedtime=recordedtime - 200 microseconds
Parent topic: Overview


SQL Commands

  • SQL Command Category Overview
  • Data Definition Language (DDL)
  • Data Manipulation Language (DML)
  • Data Control Language (DCL)
  • Utility Commands
  • Embedded and Dynamic SQL
Parent topic: SQL Reference


SQL Command Category Overview

Standard SQL statements supported by the XDB Server can be divided into three functional command categories:

  • Data Definition Language (DDL) statements create, alter and drop relational database objects such as databases, tables and indexes.
  • Data Manipulation Language (DML) statements select, update, insert, and delete data values within relational database tables.
  • Data Control Language (DCL) statements establish system security by controlling access to data objects, plus regulating concurrency and transaction processing.

In addition, there are utility commands (that perform administrative functions on the XDB Server) and embedded and dynamic SQL commands.

Parent topic: SQL Commands


Data Definition Language (DDL)

Data Definition Language (or DDL) includes those SQL statements that create and drop locations, databases and database objects such as tables and indexes. DDL also includes statements to alter database objects and impose integrity constraints on tables. All DDL statements automatically update the appropriate system catalog tables.

  • ALTER DATABASE

    Changes information parameters for a database under the currently set XDB Server location.

  • ALTER INDEX

    Changes the configuration of an existing index (DB2). This command is supported syntactically by the XDB Server to maintain compatibility with DB2.

  • ALTER LOCATION

    Converts a location to DB2 Version 4 or DB2 Version 5 compatibility.

  • ALTER SEQUENCE

    Changes the attributes of a sequence at the current server.

  • ALTER STOGROUP

    Changes the specifications of an existing storage group (stogroup) defined within the current XDB Server location.

  • ALTER TABLE

    Adds, removes or renames table columns, or changes the data types of columns. In XDB mode, the ALTER TABLE command can create or drop UNIQUE, PRIMARY, FOREIGN KEY and CHECK constraints used to enforce referential and domain integrity, plus uniqueness (the DB2-specific syntax of the ALTER TABLE statement is supported in DB2 mode).

  • ALTER TABLESPACE

    Changes the specifications of a table space within the currently set XDB Server location.

  • ALTER VIEW

    Regenerates a view using an existing view definition at the current server.

  • COMMENT ON

    Places a remark about an object in the catalog tables at the currently set location.

  • CREATE ALIAS

    The CREATE ALIAS command defines an alias for an existing table or view, and records the alias definition in the catalog tables at the currently set location. It is not required that the table or view be described under the same location as the alias.

  • CREATE DATABASE

    Defines a logical database, which under default operating conditions consists of a subdirectory of the same name, under the active location root directory. The database directory, normally under the location root directory, holds the physical table and index files that are logically associated with the database. By using stogroups (described in the Server Administration Guide), users have the option of implicitly specifying different storage directories for individual database objects (or groups of objects).

  • CREATE GLOBAL TEMPORARY TABLE

    Creates a description of a temporary table at the current server.

  • CREATE INDEX

    Creates an index on one or more columns of a table. Indexes speed data retrieval and can enforce uniqueness constraints.

  • CREATE LOCATION

    Creates a new XDB Server location in a subdirectory path specified by the user. A location on an XDB Server is similar to a DB2 subsystem. In addition to a SYSTEM location (used for overall system administration and security), the XDB Server allows additional user-defined locations to be created.

  • CREATE SEQUENCE

    Creates a sequence at the application server.

  • CREATE STOGROUP

    Creates a DB2 style storage group (stogroup) that can be associated with a directory path. Stogroups are used to define a physical directory area for storing database objects.

  • CREATE SYNONYM

    Creates an alternate name for a table or view within the currently set location.

  • CREATE TABLE

    Creates a table by defining all columns in the table, including the data type and field length of each column. Primary and Foreign keys for the table also can be created using this command.

  • CREATE TABLESPACE

    Creates a DB2 style table space that can be used with a stogroup to store tables from the same logical database in different directory paths.

  • CREATE VIEW

    Defines a virtual table that usually restricts data retrieval and updating to a subset of columns and rows from one or more base tables.

  • DROP ALIAS

    Deletes an alternate name for a table or view from the location's system catalog.

  • DROP DATABASE

    Deletes a database defined within the current location. Also deletes all objects logically associated with the database, and then deletes the database subdirectory. If the database subdirectory is empty (with no objects logically associated with that database), then this command removes the empty subdirectory.

  • DROP INDEX

    Deletes an index existing at the current location. Note that an index created as the result of a UNIQUE, PRIMARY or FOREIGN KEY constraint can only be dropped by first dropping the existing constraint with the ALTER command.

  • DROP LOCATION

    Removes a user-defined XDB Server location, along with accompanying catalog tables and directory structure. Also deletes all objects associated with the location.

  • DROP STOGROUP

    Deletes a stogroup defined within the currently set location. This action severs the logical connection between any data objects that were defined using the stogroup, and the directory path specified in the deleted stogroup definition (does not delete objects associated with the stogroup) -- USE WITH CAUTION.

  • DROP SYNONYM

    Deletes an alternate name for a table or view from the location's system catalog.

  • DROP TABLE

    Deletes a table created under the current location, along with all associated indexes, views and synonyms built on that table.

  • DROP TABLESPACE

    Deletes a table space defined within the current location, along with all tables logically associated within that table space.

  • DROP VIEW

    Deletes a view from the system catalog of the current location. In addition, all other views defined on the dropped view are dropped also.

  • LABEL ON

    Replaces or adds descriptive text labels to the catalog tables of the currently set location. These text labels describe tables, views, aliases, or columns existing at the current location.

  • RENAME

    Changes a table name.

Parent topic: SQL Commands


Data Manipulation Language (DML)

Data Manipulation Language (or DML) consists of SQL statements used to retrieve, insert, update and delete records from database tables. DML statements are the only statements that can be rolled back or recovered.

  • DELETE

    Deletes specified rows from a table. Also has a special format (DELETE WHERE CURRENT OF) for embedded SQL.

  • INSERT

    Inserts a specified number of rows into a table.

  • SELECT

    Retrieves data from one or more tables. Also has a special format (SELECT INTO) for embedded SQL.

  • UPDATE

    Modifies data in specified rows of a table. Also has a special format (UPDATE WHERE CURRENT OF) for embedded SQL.

Parent topic: SQL Commands


Data Control Language (DCL)

Data Control Language (or DCL) consists of statements that control security and concurrent access to table data.

  • COMMIT

    Instructs the XDB Server to make permanent all data changes resulting from DML statements executed by a transaction.

  • CONNECT

    Connects the application process (or user) to a designated XDB Server or DB2 location. This location becomes the current location for the application process or user.

  • GRANT (Database Privileges)

    Assigns access privileges to XDB Server users or applications.

  • GRANT (Sequence Privileges)

    Grants privileges on a user-defined sequence.

  • LOCK TABLE

    Extends XDB Server's automatic record and table level locking functions (in a multi-user system) by acquiring explicit locks on a particular table.

  • REVOKE (Database Privileges)

    Cancels access privileges for XDB Server users or applications.

  • REVOKE (Sequence Privileges)

    Revokes the privileges on a user-defined sequence.

  • ROLLBACK

    Instructs the XDB Server to reverse the effect of any DML commands executed on a database by a transaction. Information recorded in a backward log is used to restore the database to a state existing before the transaction.

  • UNLOCK TABLE

    Removes table locks (in a multi-user system) acquired with the LOCK TABLE command.

Parent topic: SQL Commands


Utility Commands

Utility commands perform administrative functions on the XDB Server.

  • ALTER PASSWORD

    Enables you to change passwords.

  • BACKUP LOCATION

    Makes a backup copy of an entire XDB Server location to a specified directory path.

  • BULK [ON | OFF]

    BULK ON turns the Bulk Upload feature on for all subsequent transactions. Bulk uploading allows data to be transferred to the client in bulk, instead of one row at a time (used with XDB Link). BULK OFF turns the Bulk Upload feature off.

  • CHECKPOINT

    Flushes the entire logging system cache buffer to disk and flushes database cache buffer.

  • COMPACT

    Recycles unused disk space by packing tables, rebuilding indexes and reorganizing directory files.

  • CREATE USER

    Creates additional XDB user accounts.

  • DISABLE LOGIN

    Prevents additional users from logging on to the server.

  • ENABLE LOGIN

    Permits users to log on to the server again after a DISABLE LOGIN command has been issued.

  • EXPLAIN

    Acquires access path selection information about an "explainable" SQL statement, and inserts the information into a special table (automatically created by the XDB Server) named PLAN_TABLE. Users have the option of creating their own plan_table structure.

  • HALT QUERY FROM

    Terminates a specific query.

  • REFRESH LOCATIONS

    Directs the XDB Server to re-read the information contained in the SYSIBM.SYSLOCATIONS catalog table. REFRESH LOCATIONS is typically issued after information in this table has been manually updated by the user.

  • REFRESH TABLE

    Refreshes the data in a materialized query table.

  • ROLLFORWARD

    Applies all DML changes recorded in a forward log file to a location backup copy. The ROLLFORWARD command restores the information in a location to the condition existing before the last location backup.

  • SET AUTOCOMMIT

    Sets the autocommit feature on or off. Setting autocommit to "on" causes a commit to be automatically generated after any DML command.

  • SET CURRENT MAINTAINED TABLE TYPES FOR OPTIMIZATION

    Changes the value of the CURRENT MAINTAINED TABLE TYPES FOR OPTIMIZATION special register.

  • SET CURRENT PACKAGE PATH

    Assigns a value to the CURRENT PACKAGE PATH special register.

  • SET CURRENT PACKAGESET

    Assigns a value to the CURRENT PACKAGESET special register.

    Note: This command is supported only syntactically by the XDB Server, where packages are bound with a particular qualifier.
  • SET CURRENT REFRESH AGE

    Changes the value of the CURRENT REFRESH AGE special register.

  • SET CURRENT RULES

    Assigns a value to the CURRENT RULES special register.

  • SET CURRENT SQLID

    Changes the AuthID value stored in the CURRENT SQLID special register.

  • SET ISOLATION

    Defines the isolation level used to determine appropriate lock acquiring and lock releasing procedures for an executing transaction.

  • SET LOCATION location-name OFFLINE/ONLINE

    Lets the system administrator prevent or permit access to a specific location.

  • SET LOCATION TO

    Logs a user onto a new location, creating an implied connection between the user's current session and the specified location. The value of the CURRENT LOCATION special register is temporarily updated to reflect the new active location. The user's default location is not changed.

  • SET LOG

    Allows database administrators (with SYSADM authority or higher) to suspend logging system operation during an administrative session, and change the path where location log files are stored.

  • SET SCHEMA

    Assigns a value to the CURRENT SCHEMA special register.

  • SET SORTSPACE

    Changes the size of the sort space while the XDB Server is running.

  • SHUTDOWN

    Stops an XDB Server from a remote client.

  • START DATABASE

    Allows users to have access to the contents of the named database.

  • STOP DATABASE

    Restricts all access to the named database.

  • TRUNCATE TABLE

    Deletes records from a table much like the DELETE command, but proceeds much faster since the deleted data is not logged.

Parent topic: SQL Commands


Embedded and Dynamic SQL

XDB Server statements that are used in embedded and dynamic SQL programming are summarized below. While most SQL commands can be embedded in host programming languages (for example, COBOL, C and PL/I), the following commands can only appear as embedded or dynamic SQL statements.

  • ALLOCATE CURSOR

    Defines a cursor and associates it with a result set locator variable.

  • ASSOCIATE LOCATORS

    Gets the result set locator value for each result set returned by a stored procedure.

  • BEGIN DECLARE SECTION

    Marks the beginning of declarations for host variables to be used by SQL commands (optional in COBOL).

  • CALL

    Runs stored procedures on the mainframe (through XDB Link), or procedures on an XDB Server, from an application.

  • CLOSE

    Closes a previously opened cursor (OPEN command).

  • DECLARE CURSOR

    Defines a cursor.

  • DECLARE STATEMENT

    Identifies prepared SQL statements for later use in application programs.

  • DECLARE TABLE

    Provides the precompiler with information for checking embedded SQL statements. DECLARE TABLE is also used for application program documentation.

  • DESCRIBE

    Obtains information about either a prepared statement (PREPARE command), or an existing table or view.

  • DESCRIBE CURSOR

    Obtains information about the result set that is associated with the cursor and places the information into a descriptor.

  • DESCRIBE PROCEDURE

    Obtains information about the result sets returned by a stored procedure, and places the information into a descriptor.

  • END DECLARE SECTION

    Marks the end of declarations for host variables to be used by SQL commands (required if BEGIN DECLARE SECTION statement is used).

  • EXECUTE

    Executes a prepared (PREPARE command) SQL statement.

  • EXECUTE IMMEDIATE

    Prepares (PREPARE command) and executes (EXECUTE command) an SQL statement in one step.

  • FETCH

    Positions a cursor on the next row of a result, and assigns the values of that row to host program variables.

  • GET DIAGNOSTICS

    Provides diagnostic information about the last SQL statement (other than a GET DIAGNOSTICS statement) that was executed.

  • INCLUDE

    Inserts declarations or code into a source program for use by SQL, as well as the host language.

  • OPEN

    Opens a previously prepared (PREPARE command) cursor prior to fetching (FETCH command) result rows.

  • PREPARE

    Prepares an SQL statement for execution.

  • SELECT INTO

    Retrieves one row of values from a table or view, and then assigns these values to one or more host variables specified in the SELECT INTO command statement.

  • SET Host Variable

    Assigns special register values to host variables.

  • WHENEVER

    Specifies the host language statement to be executed whenever a specified exception condition takes place.

Parent topic: SQL Commands


Syntax Notation

The SQL statement syntax in this reference shows all the clauses, object types and predicates that can be incorporated into a particular statement. The following standard notation conventions are used in the statement syntax:

  • Italics are used to distinguish general parameter information and data object categories in a statement syntax. The clause "PASSWORD password," for example, contains the keyword PASSWORD, and the parameter password (indicating that the user should supply a password).
  • Square brackets ( [ ] ) enclose optional items in a command statement. Do not type the brackets. For example, the statement "COMMIT [WORK]" indicates that the keyword COMMIT must be used, but the keyword WORK is optional.
  • Ellipses ( ... ) indicate that the preceding item may be repeated one or more times. Do not type the ellipses.
  • Ellipses are sometimes preceded with a comma ( ,... ) indicating that the preceding item may be repeated one or more times, with each repeated item separated from the last by a comma. For example, the clause "column-name [,...]" indicates that at least one column name must be specified, with an option to add any number of other column names (with each column name separated from the last by a comma).
  • Vertical bars ( | ) indicate that whatever item precedes the bar can be replaced by the item following the bar. This character operates as an OR conjunction, offering a choice between the item appearing before and after. Do not type the vertical bar.
  • Braces ( { } ) group items to be selected as a single element of the command statement. One item within the braces must be chosen. For example, "{A | B}" means choose either A or B. Do not type the braces.
  • Parentheses appearing within the statement syntax are part of the statement syntax and need to be typed as shown.
  • Underlined items indicate a default option. For example, "PRIQTY {3 | integer}" indicates that the PRIQTY clause has a default value of three. The statement "SELECT [ALL | DISTINCT]" indicates that SELECT (by itself) is interpreted the same as SELECT ALL.

More:

  • Syntax Support Only
  • Case Sensitivity
  • Comments
  • Line Continuation
  • Syntax Support Only
  • Case Sensitivity
  • Comments
  • Line Continuation
Parent topic: SQL Reference


Syntax Support Only

A DB2-mainframe statement that has no functional equivalent on the XDB Server. It is fully supported only when running against a DB2-mainframe location using XDB Link. If running against an XDB Server location, only the syntax of these clauses is checked. An error message is returned to the user if a spelling or syntax error is found. Refer to the appropriate DB2 documentation for full explanations of these commands.

Parent topic: Syntax Notation


Case Sensitivity

To enhance readability in this reference, command keywords always appear in capital letters. For actual database operations, however, XDB Server keywords are not case sensitive and may be entered in either all upper case, all lower case, or any combination of upper and lower case letters.

The character sort sequence for each XDB Server location defaults to case insensitive -- which can be changed to standard ASCII, standard EBCDIC or a user defined sorting scheme. XDB Server Administrators can change the sort sequence for an XDB Server location. Users can choose to use the default location sort or specify their own sort through client configuration, described in your client tools documentation.

Parent topic: Syntax Notation


Comments

The XDB Server receives and processes SQL commands as continuous, nondelimited strings. Comments can be included anywhere in an SQL command, provided they are bracketed by the characters /* and */. The XDB Server ignores all characters enclosed between these special characters. For example, the following command statement has the comment string "info on parts & suppliers" attached:

SELECT *
    FROM partsupp /* info on parts & suppliers */

An alternative means of entering comments is provided in SQLWizard, where users may place comments at the end of a statement line, separating them from the statement text by a double hyphen (--). Anything on the line after the double hyphen is ignored by the system.

Parent topic: Syntax Notation


Line Continuation

Although the XDB Server requires that an SQL commands be processed as a single string of text characters, in most XDB Server environments you can split commands over several lines without requiring special line continuation marks. A semicolon generally indicates the end of a complete command statement.

Parent topic: Syntax Notation


DB2 Support

When running in DB2-mode, the XDB Server provides either full or partial DB2-mainframe support for all SQL statements and clauses. When running against a mainframe location using XDB Link, XDB Link effectively becomes the DB2 subsystem, providing complete DB2-mainframe support for all SQL statements issued by the user.

However, when running against an XDB Server location in a non-mainframe environment, some combination of the following three categories of DB2-mainframe support applies to each SQL statement and clause:

  • Functionally Supported

    These clauses actually perform some function within the XDB Server. This implementation may not exactly mirror the DB2-mainframe implementation, but is functional in some respect.

  • Syntactically Supported

    None of the information contained within these clauses has a functional purpose within the XDB Server. XDB technology does, however, check the spelling and syntax of these clauses, returning an error to the user if the syntax deviates from correct DB2-mainframe usage. It is also possible that some clause information may be recorded within XDB Server catalog tables. These clauses appear as bold text in syntax statements.

Parent topic: SQL Reference


SQL Statements

  • ALLOCATE CURSOR
    The ALLOCATE CURSOR statement defines a cursor and associates it with a result set locator variable.
  • ALTER DATABASE
    The ALTER DATABASE statement changes the description of the specified database under the currently set XDB Server location.
  • ALTER FUNCTION
    The ALTER FUNCTION statement changes the description of an external scalar or external table function at the current server.
  • ALTER FUNCTION (SQL)
    The ALTER FUNCTION (SQL) statement changes the description of a user-defined SQL scalar function at the current server.
  • ALTER INDEX
    On a mainframe DB2 subsystem, this statement changes the configuration of an existing index. See the ALTER TABLE command for information on altering indexes that result from UNIQUE, PRIMARY and FOREIGN keys. In some cases, it may be necessary to drop an index and re-create it using the DROP INDEX and CREATE INDEX commands.
  • ALTER LOCATION
    The ALTER LOCATION statement converts (upgrades) a location to DB2 Version 6, 7 or 8 compatibility.
  • ALTER PASSWORD
    The ALTER PASSWORD statement enables you to change passwords.
  • ALTER PROCEDURE (external)
    The ALTER PROCEDURE statement changes the description of a stored procedure at the current server.
  • ALTER PROCEDURE (SQL)
    The XDB Server operating environment only provides syntax support for external Procedures (SQL) at this time.
  • ALTER SEQUENCE
    The ALTER SEQUENCE statement changes the attributes of a sequence at the current server. Only future values of the sequence are affected by the ALTER SEQUENCE statement.
  • ALTER STOGROUP
    The ALTER STOGROUP statement changes the specifications of an existing storage group (stogroup) defined within the current XDB Server location.
  • ALTER TABLE
    The ALTER TABLE statement changes the description of a table at the current server.
  • ALTER TABLESPACE
    The ALTER TABLESPACE statement changes the specifications of a table space within the currently set XDB Server location.
  • ALTER VIEW
    The ALTER VIEW statement regenerates a view using an existing view definition at the current server.
  • ASSOCIATE LOCATORS
    The ASSOCIATE LOCATORS statement gets the result set locator value for each result set returned by a stored procedure.
  • BACKUP LOCATION
    This XDB Server utility command copies the entire contents of an XDB Server location to the specified drive and path while the XDB Server location is still generally available.
  • BEGIN DECLARE SECTION
    The BEGIN DECLARE SECTION statement (embedded SQL only) marks the beginning of a host variable declare section in an application program.
  • BULK
    The BULK ON command activates the Bulk Upload feature which increases the efficiency of your transactions between the mainframe and XDB Link. The BULK OFF command turns off the Bulk Upload feature.
  • CALL
    The XDB Server can run a stored procedure on the mainframe (through XDB Link) or on an XDB Server through use of the CALL statement.
  • CHECKPOINT
    CHECKPOINT is an SQL command which flushes the database and log files.
  • CLOSE
    The CLOSE command (embedded SQL only) closes a cursor previously opened by a DECLARE CURSOR command. If a temporary table is created as a result of the cursor, that table is deleted when the cursor is closed.
  • COMMENT ON
    The COMMENT ON statement adds or replaces descriptive text comments for aliases, columns, distinct types (currently not supported), stored procedures, tables, triggers, user-defined functions, and views located within the current XDB Server location. All comments are stored in the catalog tables belonging to that location.
  • COMMIT
    The COMMIT statement is used to mark the end of a transaction (unit of work) and preserve all of the database changes made by the transaction.
  • COMPACT
    Use the COMPACT command to pack table, index and dictionary files in order to reuse disk storage space.
  • CONNECT
    The CONNECT statement (embedded SQL only) connects the application process to the specified XDB Server or DB2 (through XDB Link) location. This location becomes the current location for the application process.
  • CREATE ALIAS
    The CREATE ALIAS command defines an alternate name for an existing table or view, and records the alias definition in the XDB Server system catalog at the currently set location. It is not required that the table or view be in the current location.
  • CREATE AUXILIARY TABLE
    The CREATE AUXILIARY TABLE statement creates an auxiliary table at the current server for storing LOB data.
  • CREATE DATABASE
    The CREATE DATABASE command creates a logical database structure at the currently set XDB Server location.
  • CREATE DISTINCT TYPE
    The CREATE DISTINCT TYPE statement defines a distinct type, which is a data type that a user defines. A distinct type must be sourced on one of the built-in data types. Successful execution of the statement also generates:
  • CREATE FUNCTION
    The CREATE FUNCTION statement registers a user-defined function with an application server. You can register three different types of functions with this statement, each of which is described separately.
  • CREATE FUNCTION (external scalar)
    This CREATE FUNCTION statement registers a user-defined external scalar function with an application server.
  • CREATE FUNCTION (external table)
    This CREATE FUNCTION statement registers a user-defined external table function with an application server.
  • CREATE FUNCTION (sourced)
    This CREATE FUNCTION statement registers a user-defined function that is based on an existing scalar or column function with an application server.
  • CREATE FUNCTION (SQL Scalar)
    This statement is used to define a user-defined SQL scalar function. A scalar function returns a single value each time it is invoked. Specifying a function is generally valid wherever an SQL expression is valid.
  • CREATE GLOBAL TEMPORARY TABLE
    Create a temporary table to store the intermediate results of SQL transactions. The CREATE GLOBAL TEMPORARY TABLE statement creates a description of a temporary table at the current server.
  • CREATE INDEX
    Creates an index on one or more columns of a table at the current location.
  • CREATE LOCATION
    The CREATE LOCATION command allows you to define multiple XDB Server locations under the same XDB Server. Each XDB Server location contains a set of catalog tables for that location.
  • CREATE PROCEDURE
    The CREATE PROCEDURE command defines a Stored Procedure to the SQL engine. You can then embed an SQL CALL statement in a program to invoke the stored procedure.
  • CREATE PROCEDURE
    The CREATE PROCEDURE statement defines an SQL procedure at the current server and specifies the source statements for the procedure.
  • CREATE SEQUENCE
    The CREATE SEQUENCE statement creates a sequence at the application server.
  • CREATE STOGROUP
    The CREATE STOGROUP command creates an XDB Server stogroup which associates a user-specified directory path with the named stogroup. Once the SYSIBM.SYSVOLUMES catalog table has been updated to reflect this path assignment, newly created objects can be physically stored in this directory path by designating the named stogroup when creating the objects.
  • CREATE SYNONYM
    The CREATE SYNONYM command is used to define alternate names for tables or views within the currently set location.
  • CREATE TABLE
    The CREATE TABLE statement defines a table. The definition must include its name and the names and attributes of its columns. The definition can include other attributes of the table, such as its primary key and its table space.
  • CREATE TABLESPACE
    This statement defines a table space in the current location. A table space in the XDB Server system architecture is logically compatible with DB2 table spaces. However, an XDB Server table space does not physically store XDB Server table (.TAB) files. This XDB Server interpretation of table spaces differs from a DB2 subsystem, where a table space can physically store multiple tables. Refer to the appropriate DB2 documentation for details on the mainframe implementation of table spaces.
  • CREATE TRIGGER
    The CREATE TRIGGER statement defines a trigger in a schema and builds a trigger package at the current server.
  • CREATE USER
    The CREATE USER statement enables you to create additional XDB user accounts.
  • CREATE VIEW
    The CREATE VIEW command is used to define a view or virtual table that is based on one or more tables or views. The view definition is stored at the current location. While a view does not actually contain data, it provides indirect access to data contained in the tables upon which the view is based. Views may be used to define subsets of tables, or to combine data from several tables into a logical view. Views may contain expressions that are computed from other columns, including aggregate functions such as averages, totals, etc.
  • DECLARE CURSOR
    The DECLARE CURSOR command (embedded SQL only) is used to define a cursor, which is a named control structure that points to a row in a set of records defined by a query.
  • DECLARE GLOBAL TEMPORARY TABLE
    The DECLARE GLOBAL TEMPORARY TABLE statement defines a declared temporary table for the current application process and instantiates an empty instance of the table for the process.
  • DECLARE STATEMENT
    The DECLARE STATEMENT command (embedded SQL only) identifies prepared SQL statements for later use in application programs.
  • DECLARE TABLE
    The DECLARE TABLE statement (embedded SQL only) is used for application program documentation and providing the precompiler with information for checking embedded SQL statements.
  • DELETE (Positioned)
    The DELETE statement removes any number of records from a table or view. The table or view can be within the current location or any other location with which the XDB Server can establish a connection, provided that the user has privileges in that other location. Deleting a row from a view actually deletes the row from the base table on which the view was created (if it is an updatable view).
  • DELETE (Searched)
    The DELETE statement removes any number of records from a table or view. The table or view can be within the current location or any other location with which the XDB Server can establish a connection, provided that the user has privileges in that other location. Deleting a row from a view actually deletes the row from the base table on which the view was created (if it is an updatable view).
  • DESCRIBE
    The DESCRIBE statement (embedded SQL only) obtains information about a previously prepared (PREPARE command) SQL statement and places this information inside an SQL Descriptor Area (SQLDA). This information is needed in dynamic SQL queries that utilize a varying-list SELECT statement. A varying-list SELECT statement is a SELECT statement where the number of columns retrieved is not known before runtime. Alternatively, the DESCRIBE statement can provide information about a specified table or view.
  • DESCRIBE CURSOR
    The DESCRIBE CURSOR statement gets information about the result set that is associated with the cursor. The information, such as column information, is put into a descriptor. Use DESCRIBE CURSOR for result set cursors from stored procedures. The cursor must be defined with the ALLOCATE CURSOR statement.
  • DESCRIBE INPUT Example
  • DESCRIBE PROCEDURE
    The DESCRIBE PROCEDURE statement gets information about the result sets returned by a stored procedure. The information, such as the number of result sets, is put into a descriptor.
  • DISABLE LOGIN
    Use this command to prevent all users, except those with SYSADM privileges, from logging on to the XDB Server. This command does not affect users who are already logged on.
  • DROP
    The DROP statement removes (erases) an object from the current location. When an object is deleted, its description is also deleted from the system catalog at the current location.
  • ENABLE LOGIN
    Use this command to return a server to service after it has been taken out of service with the DISABLE LOGIN command.
  • END DECLARE SECTION
    The END DECLARE SECTION statement (embedded SQL only) marks the end of a host variable declaration block in an application program.
  • END DECLARE SECTION Example
  • EXECUTE
    The EXECUTE command (embedded SQL only) executes a previously prepared nonquery statement. To prepare and execute in one step, see the EXECUTE IMMEDIATE command.
  • EXECUTE IMMEDIATE
    The EXECUTE IMMEDIATE statement (embedded SQL only) prepares an executable statement from a character string and then immediately executes the statement.
  • EXPLAIN
    The EXPLAIN statement uses the optimizer to acquire access path selection information about SELECT, INSERT (and the searched form of UPDATE or DELETE) statements. This information is placed by the XDB Server into a table named PLAN_TABLE. The XDB Server creates this table automatically if it has not already been created by the user.
  • FETCH
    The FETCH command (embedded SQL only) positions a cursor on a row of its result table. It can return zero, one, or multiple rows and assigns the values of the rows to host variables if there is a target specification.
  • FREE LOCATOR
    The FREE LOCATOR statement removes the association between a LOB locator variable and its value.
  • GET DIAGNOSTICS
    The GET DIAGNOSTICS statement provides diagnostic information about the last SQL statement (other than a GET DIAGNOSTICS statement) that was executed. This diagnostic information is gathered as the previous SQL statement is executed. Some of the information available through the GET DIAGNOSTICS statement is also available in the SQLCA.
  • GRANT (Database Privileges)
    The GRANT command confers database, table or view, and system privileges to AuthIDs. The XDB Server supports three separate GRANT statement formats for granting database, table and system privileges. All relevant objects must be located in the current location's catalog tables. Granted privileges are recorded in the system catalog for the current location. Specific privileges may later be revoked (see REVOKE statement).
  • GRANT (Function or Procedure Privileges)
    This form of the GRANT statement grants privileges on user-defined functions, cast functions that are generated for distinct types, and stored procedures.
  • GRANT (Table or View Privileges)
    The GRANT command confers database, table or view, and system privileges to AuthIDs. The XDB Server supports three separate GRANT statement formats for granting database, table and system privileges. All relevant objects must be located in the current location's catalog tables. Granted privileges are recorded in the system catalog for the current location. Specific privileges may later be revoked (see REVOKE statement).
  • GRANT (Sequence Privileges)
    This form of the GRANT statement grants privileges on a user-defined sequence.
  • GRANT (System Privileges)
    The GRANT command confers database, table or view, and system privileges to AuthIDs. The XDB Server supports three separate GRANT statement formats for granting database, table and system privileges. All relevant objects must be located in the current location's catalog tables. Granted privileges are recorded in the system catalog for the current location. Specific privileges may later be revoked (see REVOKE statement).
  • HALT QUERY FROM
    Use the HALT QUERY FROM command to terminate a running query. You can specify the query by user ID or by node name. This command is useful for canceling a query operation that is monopolizing the server computer.
  • HOLD LOCATOR
    The HOLD LOCATOR statement allows a LOB locator variable to retain its association with a value beyond a unit of work. The XDB operating environment does not support the LOB data type at this time.
  • INCLUDE
    The INCLUDE statement (embedded SQL only) inserts declarations or code into source programs from external files.
  • INSERT
    The INSERT command is an SQL command used to insert zero or more rows of data values (or records) into an existing table or view. The table or view receiving the new rows can be at the current location or any other location accessible to the XDB Server. Inserting a row into a view also inserts the row into that view's underlying table (if the view is updatable).
  • LABEL ON
    The LABEL ON statement adds or replaces descriptive text labels in the system catalog for the current location. These text labels describe tables, views, aliases, or columns existing at the current location.
  • LOCK TABLE
    The LOCK TABLE statement is used to acquire a shared or exclusive lock on a table at the current location.
  • OPEN
    The OPEN command (embedded SQL only) opens a previously declared cursor creating a result table containing row data.
  • PREPARE
    The PREPARE statement (embedded SQL only) transforms a character string form of an SQL statement into an executable form of the same statement. The resulting executable statement is known as a prepared statement, while the original character string is known as the statement string.
  • REFRESH LOCATIONS
    REFRESH LOCATIONS is an XDB Server utility command (not supported in DB2 mode) that re-reads the SYSIBM.SYSLOCATIONS catalog table and updates the system with any new location changes. The REFRESH LOCATIONS command is necessary only if a location has been manually inserted into SYSIBM.SYSLOCATIONS. If a new location is created using the CREATE LOCATION command, the system is automatically reset (and the catalog tables updated) to include the new location information.
  • REFRESH TABLE
    The REFRESH TABLE statement refreshes the data in a materialized query table. The statement deletes all rows in the materialized query table, executes the fullselect in the table definition to recalculate the data from the tables specified in the fullselect, inserts the calculated result into the materialized query table, and updates the catalog for the refresh timestamp and cardinality of the table. The table can exist at the current server or at any DB2 subsystem with which the current server can establish a connection.
  • RELEASE (connection)
    The RELEASE statement places one or more connections in the release pending state.
  • RELEASE SAVEPOINT
    The RELEASE SAVEPOINT statement releases the identified savepoint and any subsequently established savepoints within a unit of recovery.
  • RENAME
    The RENAME statement renames an existing table.
  • REVOKE (Database Privileges)
    The REVOKE command cancels database, table or view, or system privileges held by specified AuthIDs. The XDB Server supports three separate REVOKE formats, one each for revoking database, table or view, and system privileges. All relevant objects must be located in the current location. Revoked privileges are recorded in the system catalog for the current location.
  • REVOKE (Function or Procedure Privileges)
    This form of the REVOKE statement revokes privileges on user-defined functions, cast functions that were generated for distinct types, and stored procedures.
  • REVOKE (Sequence Privileges)
    This form of the REVOKE statement revokes the privileges on a user-defined sequence.
  • REVOKE (System Privileges)
    The REVOKE command cancels database, table or view, or system privileges held by specified AuthIDs. The XDB Server supports three separate REVOKE formats, one each for revoking database, table or view, and system privileges. All relevant objects must be located in the current location. Revoked privileges are recorded in the system catalog for the current location.
  • REVOKE (Table or View Privileges)
    The REVOKE command cancels database, table or view, or system privileges held by specified AuthIDs. The XDB Server supports three separate REVOKE formats, one each for revoking database, table or view, and system privileges. All relevant objects must be located in the current location. Revoked privileges are recorded in the system catalog for the current location.
  • ROLLBACK
    ROLLBACK is used to mark the end of a transaction and back out of all changes made by the transaction at the current location. The XDB Server does not rollback data definition language (DDL) commands such as CREATE, DROP, ALTER; data control language (DCL) commands such as GRANT, and REVOKE; or utility commands such as SET and COPY. When working in a production environment, it is recommended that you backup your location before and after such commands.
  • ROLLFORWARD
    ROLLFORWARD allows users to roll forward the transactions stored in supplied log files to a specified location. This command must be run while in exclusive use mode.
  • SAVEPOINT
    The SAVEPOINT statement sets a savepoint within a unit of recovery to identify a point in time within the unit of recovery to which relational database changes can be rolled back.
  • SELECT
    SELECT commands (or queries) all retrieve information from data tables and display this information in a results table. For purposes of classification, SELECT commands can be subdivided into three general categories including, subselects (and subqueries), fullselects and select statements.
  • SELECT INTO
    The SELECT INTO command (embedded SQL only) retrieves one row of values from a table or view, and then assigns these values to one or more host variables specified in the SELECT INTO command statement.
  • SET AUTOCOMMIT
    The SET AUTOCOMMIT command is used to turn autocommit on or off. When autocommit is on, a command is automatically committed as soon as it is successfully executed.
  • SET COMPATIBILITY
    The SET COMPATIBILITY command is used to specify a mode of operation. When a particular mode is in effect, SQL commands must adhere to the syntax of that mode.
  • SET CONNECTION
    The SET CONNECTION statement establishes the application server of the process by identifying one of its existing connections.
  • SET CURRENT DEGREE
    This command is supported only syntactically by the XDB Server.
  • SET CURRENT LOCALE LC_CTYPE
    The SET CURRENT LOCALE LC_CTYPE statement assigns a value to the CURRENT LOCALE LC_CTYPE special register. The special register allows control over the LC_CTYPE locale for statements that use a function that refers to a locale, such as LCASE, UCASE, and TRANSLATE (with a single argument).
  • SET CURRENT MAINTAINED TABLE TYPES FOR OPTIMIZATION
    The SET CURRENT MAINTAINED TABLE TYPES FOR OPTIMIZATION statement changes the value of the CURRENT MAINTAINED TABLE TYPES FOR OPTIMIZATION special register.
  • SET CURRENT OPTIMIZATION HINT
    The SET CURRENT OPTIMIZATION HINT statement assigns a value to the CURRENT OPTIMIZATION HINT special register.
  • SET CURRENT PACKAGE PATH
    The SET CURRENT PACKAGE PATH assigns a value to the CURRENT PACKAGE PATH special register.
  • SET CURRENT PACKAGESET
    On mainframe DB2 and XDB Servers, this command assigns a value to the CURRENT PACKAGESET special register. This command is partially supported by the XDB Server, which adopts the CURRENT SQLID as the qualifier for the package.
  • SET CURRENT PATH
    The SET CURRENT PATH statement assigns a value to the CURRENT PATH special register.
  • SET CURRENT REFRESH AGE
    The SET CURRENT REFRESH AGE statement changes the value of the CURRENT REFRESH AGE special register.
  • SET CURRENT RULES
    The SET CURRENT RULES statement assigns a value to the CURRENT RULES special register.
  • SET CURRENT SQLID
    The SET CURRENT SQLID statement changes the AuthID value stored in the CURRENT SQLID special register.
  • SET Host Variable
    The SET host-variable assignment statement assigns values, either of expressions or NULL values, to host variables.
  • SET Transitional Variable
    The SET transition-variable assignment statement assigns values, either of expressions or NULL values, to transition variables.
  • SET ISOLATION
    The SET ISOLATION command is used to set the isolation level for locking in multi-user versions.
  • SET LOCATION TO
    The SET LOCATION command logs a user onto a new location, creating an implied connection between the user's sessions and the specified location. The value of the CURRENT SERVER special register is also updated to reflect the new active location.
  • SET LOCATION
    Use this command to prevent all users, except for those with SYSADM privileges, from logging on to a location on the XDB Server. This command does not affect users who are already using the location.
  • SET LOG
    The SET LOG command allows Database Administrators (with SYSADM authority or higher) to suspend logging system operation during an administrative session, and change the path where location log files are stored.
  • SET SCHEMA
    The SET SCHEMA statement assigns a value to the CURRENT SCHEMA special register. If the package is bound with the DYNAMICRULES BIND option, this statement does not affect the qualifier that is used for unqualified database object references.
  • SET SORTSPACE
    Use this command to dynamically reset the size of the sort space on the XDB Server. Active sorts are not affected by this command.
  • SHUTDOWN
    Use the SHUTDOWN command to close the XDB Server program at a specified time. You can also use a variant of this command to cancel a SHUTDOWN request that you have issued.
  • SIGNAL SQLSTATE
    The SIGNAL SQLSTATE statement is used to signal an error. It causes an error to be returned with the specified SQLSTATE and error description.
  • START DATABASE
    The START DATABASE command allows users access to the contents of a named database.
  • START PROCEDURE
    The START PROCEDURE command checks the argument list for a stored procedure already defined to the SQL engine. If the stored procedure meta-data has been imported from another system, this command can be used to check that the argument list is compatible with XDB syntax rules.
  • STOP DATABASE
    The STOP DATABASE command restricts all access to the named database.
  • TRUNCATE TABLE
    The TRUNCATE TABLE command performs the same function as the DELETE command, except TRUNCATE TABLE removes all records from a table without recording the changes in the Forward and Backward Log files.
  • UNLOCK TABLE
    UNLOCK TABLE is used in multi-user versions to release table locks acquired using the LOCK TABLE command.
  • UPDATE (Searched)
    The UPDATE command modifies the values of specified columns in rows of a table or view, if the view is updatable. Modifying a row of a view also modifies the underlying base table of the view. The UPDATE command statement has two configurations, depending on whether a searched update or positioned update is performed. A searched update modifies zero or more rows of a table. These updated rows can be optionally selected with a search condition. A positioned update modifies only one row -- derived as the current position of a previously declared and opened cursor. The table or view being updated can exist at the current location or at any other location accessible from the XDB Server.
  • UPDATE (Positioned)
    The UPDATE command modifies the values of specified columns in rows of a table or view, if the view is updatable. Modifying a row of a view also modifies the underlying base table of the view. The UPDATE command statement has two configurations, depending on whether a searched update or positioned update is performed. A searched update modifies zero or more rows of a table. These updated rows can be optionally selected with a search condition. A positioned update modifies only one row -- derived as the current position of a previously declared and opened cursor. The table or view being updated can exist at the current location or at any other location accessible from the XDB Server.
  • VALUES
    The VALUES statement provides a method for invoking a user-defined function from a trigger. Transition variables and transition tables can be passed to the user-defined function.
  • VALUES INTO
    The VALUES INTO statement assigns one or more values to host variables.
  • WHENEVER
    The WHENEVER statement (embedded SQL only) has three different forms, each of which changes the execution of a host language program according to the occurrence of specified exception conditions.
Parent topic: SQL Reference


ALLOCATE CURSOR

Invocation

This statement can be embedded in an application program. It is an executable statement that can be dynamically prepared. It cannot be issued interactively.

Authorization

No authorization is required for this statement.

Syntax

ALLOCATE CURSOR cursor-name
CURSOR FOR RESULT SET rs-locator-variable

Parameters:

cursor-name | Names the cursor. The name must not identify a cursor that has already been declared in the source program.
rs-locator-variable | Names a result set locator variable that has been declared in the application program. The result set locator variable must contain a valid result set locator value, as returned by the ASSOCIATE LOCATORS or DESCRIBE PROCEDURE statements. In the ALLOCATE CURSOR statement, rs-locator-variable is always a host variable.

Description

When an ALLOCATE CURSOR statement is dynamically prepared, the EXECUTE statement with the USING clause must be used to execute the prepared statement. As with all dynamically prepared statements, parameter markers (question marks) must appear where the host variables would appear in the prepared statement. The USING clause of the EXECUTE statement should specify the host variables for which the values are to be substituted for the parameter markers in the dynamically prepared ALLOCATE CURSOR statement.

You cannot use a statement identifier for an ALLOCATE CURSOR statement if the same statement identifier has been used for a DECLARE CURSOR statement.

The following rules apply when you use an allocated cursor:

  • For this statement to be successful, an application must be currently connected to the site where the stored procedure was executed.
  • You cannot open an allocated cursor by using the SQL OPEN cursor statement.
  • You can close an allocated cursor by using the SQL CLOSE cursor statement. This closes the cursor in the stored procedure as well.
  • You can allocate only one cursor to each result set.

Rollback, and an implicit and explicit close destroy allocated cursors. A commit destroys allocated cursors that are not defined WITH HOLD by the stored procedure. Destroying an allocated cursor closes the associated cursor in the stored procedure.

Parent topic: SQL Statements


ALTER DATABASE

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

To execute the ALTER DATABASE command, users must possess either DBADM or DBCTRL authority for the database, DROP privilege on the database, overall SYSADM or SYSCTRL authority for the location, or be the owner of the database affected.

Syntax

ALTER DATABASE database-name

[BUFFERPOOL bpname]
    [INDEXBP bpname]
    [STOGROUP stogroup-name]
    [CCSID ccsid-value]

Parameters:

database-name | Identifies the database to be altered. The database must exist within the currently set location.
BUFFERPOOL bpname | Identifies the default buffer pool for the table spaces within the database. It does not apply to table spaces that already exist within the database. The 4K bufferpools are named BP0, BP1, BP2...BP49. The 32K bufferpools are named BP32K, BP32K1, BP32K2...BP32K9 If the database is a work file database, 8KB and 16KB buffer pools cannot be specified.
INDEXBP bpname | Identifies the default buffer pool for the indexes within the database. It does not apply to indexes that already exist within the database. The name must identify a 4KB buffer pool. INDEXBP cannot be specified for a work file database.
stogroup-name | Identifies an optional stogroup for this database, if stogroups are used.
ccsid-value | Identifies the default CCSID for table spaces within the database. It does not apply to existing table spaces in the database. ccsid-value must identify a CCSID value that is compatible with the current value of the CCSID for the database. CCSID cannot be specified for a work file data base or a TEMP database.

Description

The ALTER DATABASE command offers users the option of assigning a stogroup designation to a logical database. This command can also specify whether or not the database is used as a Read-Only Shared database.

BUFFERPOOL

This clause has no functional equivalent in the XDB Server operating environment. However, for DB2 compatibility purposes, the XDB Server records any of the sixty possible bufferpools (BP0...BP49, BP32K, BPK1...BPK9). The first fifty bufferpools are for tables with 4K page sizes, while the last ten are for tables with 32K page sizes. Although not functionally supported, this new information is semantically checked and recorded in the XDB Server catalog tables.

CCSID

This clause has no functional equivalent in the XDB Server operating environment.

STOGROUP

This clause allows the user to change the default stogroup to which all objects created under this database will be physically stored. This clause does not affect the storage locations of tables and indexes already created under the database. On an XDB Server, a stogroup designates a particular drive (and/or directory) on which all objects created under a logical database are physically stored. A stogroup is usually assigned to a database, or table space within a database, when these objects are created.

Example:

Change the default buffer pool for both table spaces and indexes within database ABCDE to BP2.

ALTER DATABASE ABCDE
    BUFFERPOOL BP2
    INDEXBP BP2;
Parent topic: SQL Statements


ALTER FUNCTION

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

To execute the ALTER FUNCTION command, users must possess either overall SYSADM or SYSCTRL authority for the location, or be the owner of the function affected.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

ALTER FUNCTION function-name [(parameter-type[,...])] |
SPECIFIC FUNCTION specific-name
    [EXTERNAL NAME {'string' | identifier}]
    [LANGUAGE {ASSEMBLE | C | COBOL | PLI}]
    [[NOT] DETERMINISTIC]
    [{RETURNS NULL ON NULL INPUT | CALLED ON NULL INPUT}]
    [{CONTAINS SQL | READS SQL DATA | MODIFIES SQL DATA | NO SQL}]
    [[NO] EXTERNAL ACTION]
    [{NO SCRATCHPAD | SCRATCHPAD length}]
    [[NO] FINAL CALL]
    [{ALLOW PARALLEL | DISALLOW PARALLEL}]
    [[NO] DBINFO]
    [CARDINALITY integer]
    [{NO COLLID | COLLID collection-id}]
    [WLM ENVIRONMENT {name | (name,*)}]
    [ASUTIME {NO LIMIT | LIMIT integer}]
    [STAY RESIDENT {NO | YES}]
    [PROGRAM TYPE {SUB | MAIN}]
    [SECURITY {DB2 | USER | DEFINER}]
    [STOP AFTER SYSTEM DEFAULT FAILURES |
      STOP AFTER integer FAILURES |
      CONTINUE AFTER FAILURE]
    [RUN OPTIONS run-time-options]

parameter-type:

{data-type [AS LOCATOR] | TABLE LIKE table-name as LOCATOR}

data-type:

{built-in-data-type | distinct-type-name}

built-in-data-type:

[SMALLINT]
[INTEGER | INT]
[{DECIMAL | DEC | NUMERIC} [(integer[,...])]
[{FLOAT [(integer)] | REAL [PRECISION] | DOUBLE}]
[{ {CHARACTER | CHAR} [(integer)] | {CHARACTER | CHAR} VARYING (integer) | VARCHAR (integer) } [FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | I} |[{ {CHARACTER | CHAR} [(integer)] | {CHARACTER | CHAR} VARYING (integer) | VARCHAR (integer) }
    [FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII}] |
    {{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(integer [K|M|G])] }
    [FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII}] }]
[{BINARY LARGE OBJECT | BLOB} [(integer [K|M|G])]]
[{GRAPHIC [(integer)] | VARGRAPHIC (integer) | DBCLOB [(integer [K|M|G])] } [CCSID {EBCDIC | ASCII}]]
[DATE | TIME | TIMESTAMP]
[ROWID]

Description

One of the following three clauses identifies the function to be changed.

FUNCTION function-name

Identifies the external function by its function name. The name is implicitly or explicitly qualified with a schema name. If the name is not explicitly qualified, it is implicitly qualified with a schema name according to the following rules:

  • If the statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not specified, the schema name is the owner of the plan or package.
  • If the statement is prepared dynamically, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

The identified function must be an external function. There must be exactly one function with function-name in the schema. The function can have any number of input parameters. If the schema does not contain a function with function-name or contains more than one function with this name, an error occurs.

FUNCTION function-name (parameter-type,...)

Identifies the external function by its function signature, which uniquely identifies the function.

function-name | gives the function name of the external function. If the function name is not qualified, it is implicitly qualified with a schema name as described in the preceding description for FUNCTION function-name.
(parameter-type,...) | identifies the number of input parameters of the function and their data types.

The data type of each parameter must match the data type that was specified in the CREATE FUNCTION statement for the parameter in the corresponding position. The number of data types and the logical concatenation of the data types are used to uniquely identify the function. Therefore, you cannot change the number of parameters or the data types of the parameters.

For data types that have a length, precision, or scale attribute, you can specify a value or use a set of empty parentheses:

  • Empty parentheses indicate that XDB ignores the attribute when determining whether the data types match.FLOAT cannot be specified with empty parentheses because its parameter value indicates different data types (REAL or DOUBLE).
  • If you use a specific value for a length, precision, or scale attribute, the value must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.
  • The specific value for FLOAT(n) does not have exactly match the defined value of the source function because 1<=n<= 21 indicates REAL and 22<=n<=53 indicates DOUBLE. Matching is based on whether the data type is REAL or DOUBLE.
  • If length, precision, or scale is not explicitly specified, and empty parentheses are not specified, the default length of the data type is implied. For example:
    CHAR | CHAR(1)
    GRAPHIC | GRAPHIC(1)
    DECIMAL | DECIMAL(5,0)
    FLOAT | DOUBLE (length of 8)

The implicit length must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement

For data types with a subtype or encoding scheme attribute, specifying the FOR DATA clause or CCSID clause is optional. Omission of either clause indicates that XDB ignores the attribute when determining whether the data types match. If you specify either clause, it must match the value that was implicitly or explicitly specified in the CREATE FUNCTION statement.

A function with the function signature must exist in the explicitly or implicitly specified schema; otherwise, an error occurs.

SPECIFIC FUNCTION specific-name

Identifies the external function by its specific name. The name is implicitly or explicitly qualified with a schema name. A function with the specific name must exist in the schema; otherwise, an error occurs.

If the specific name is not qualified, it is implicitly qualified with a schema name as described in the preceding description for FUNCTION function-name.

The following clauses change the description of the function that has been identified to be changed.

EXTERNAL NAME 'string' or identifier

Identifies the name of the module that contains the user-written code that implements the logic of the function. The external program name can be a string constant that is no longer than 8 characters or a short identifier.

The module is created when the program that contains the function body is compile . The module does not need to exist when the ALTER FUNCTION statement is executed. However, it must exist and be accessible by the current server when the function is invoked.

LANGUAGE

Specifies the application programming language in which the function is written. All programs must be designed to run in IBM's Language Environment environment .

ASSEMBLE | The function is written in Assembler. (Not currently available with XDB Server)
C | The function is written in C or C++. (Not currently available with XDB Server)
COBOL | The function is written in COBOL, including the object-oriented language extensions.
PL/I | The function is written in PL/I. (Not currently available with XDB Server)

NOT DETERMINISTIC or DETERMINISTIC

Specifies whether the function returns the same results for identical input arguments.

NOT DETERMINISTIC The function might not return the same result for identical input arguments. The function depends on some state values that affect the results. XDB uses this information when processing a SELECT, UPDATE, DELETE, or INSERT statement to disable merging of views that refer to the function. An example of a function that is not deterministic is one that generates random numbers, or any function that contains SQL statements.

Some functions that are not deterministic can receive incorrect results if the function is executed by parallel tasks. Specify the DISALLOW PARALLEL clause for these functions.

If a view or a materialized query table definition refers to the function, the function cannot be changed to NOT DETERMINISTIC. To change the function, drop any views or materialized query tables that refer to the function first.

DETERMINISTIC The function always returns the same result for identical input arguments. XDB can use this information to optimize view processing for SELECT, UPDATE, DELETE, or INSERT statements. An example of a deterministic function is a function that calculates the square root of the input.

XDB does not verify that the function program is consistent with the specification of DETERMINISTIC or NOT DETERMINISTIC.

RETURNS NULL ON NULL INPUT or CALLED ON NULL INPUT

Specifies whether the function is called if any of the input arguments is null at execution time.

RETURNS NULL ON NULL INPUT | The function is not called if any of the input arguments is null. For an external scalar function, the result is the null value. For an external table function, the result is an empty table, which is a table with no rows.
CALLED ON NULL INPUT | The function is called regardless of whether any of the input arguments is null, making the function responsible for testing for null argument values. For an external scalar function, the function can return a null or nonnull value. For an external table function, the function can return an empty table, depending on its logic.

NO SQL, MODIFIES SQL DATA, READS SQL DATA, or CONTAINS SQL

Indicates whether the function issues any SQL statements and, if so, what type.

NO SQL | The function cannot execute any SQL statements.
MODIFIES SQL DATA | The function can execute any SQL statement except those statements that are not supported in any function. Do not specify MODIFIES SQL DATA for external table functions or with ALLOW PARALLEL.
READS SQL DATA | The function cannot execute SQL statements that modify data. SQL statements that are not supported in any function return a different error.
CONTAINS SQL | The function cannot execute any SQL statements that read or modify data. SQL statements that are not supported in any function return a different error.

NO EXTERNAL ACTION or EXTERNAL ACTION

This clause has no functional equivalent in the XDB Server operating environment.

NO SCRATCHPAD or SCRATCHPAD

Specifies whether XDB provides a scratchpad for the function. It is strongly recommended that external functions be reentrant, and a scratchpad provides an area for the function to save information from one invocation to the next.

NO SCRATCHPAD A scratchpad is not allocated and passed to the function.
SCRATCHPAD When the function is invoked for the first time, XDB allocates memory for a scratchpad. A scratchpad has the following characteristics:
  • Length must be between 1 and 32767. The default value is 100 bytes.
  • XDB initializes the scratchpad to all binary zeros (X'00's).
  • The scope of a scratchpad is the SQL statement. For each reference to the function in an SQL statement, there is one scratchpad. For example, assuming that function UDFX was defined with the SCRATCHPAD keyword, three scratchpads are allocated for the three references to UDFX in the following SQL statement:
    SELECT A, UDFX(A) FROM TABLEB WHERE UDFX(A) > 103 OR UDFX(A) < 19;

    If the function is run under parallel tasks, one scratchpad is allocated for each parallel task of each reference to the function in the SQL statement. This can lead to unpredictable results. For example, if a function uses the scratchpad to count the number of times that it is invoked, the count reflects the number of invocations done by the parallel task and not the SQL statement. Specify the DISALLOW PARALLEL clause for functions that do not work correctly with parallelism.

  • The scratchpad is persistent. XDB preserves its content from one invocation of the function to the next. Any changes that the function makes to the scratchpad on one call are still there on the next call. XDB initializes the scratchpads when it begins to execute an SQL statement. XDB does not reset scratchpads when a correlated subquery begins to execute.
  • The scratchpad can be a central point for the system resources that the function acquires. If the function acquires system resources, specify FINAL CALL to ensure that XDB calls the function one more time so that the function can free those system resources.

Each time that the function is invoked, XDB passes an additional argument to the function that contains the address of the scratchpad.

NO FINAL CALL or FINAL CALL

Specifies whether a final call is made to the function. A final call enables the function to free any system resources that it has acquired. A final call is useful when the function has been defined with the SCRATCHPAD keyword and the function acquires system resource and anchors them in the scratchpad.

The effect of NO FINAL CALL or FINAL call depends on whether the external function is a scalar function or a table function.

For an external scalar function:

NO FINAL CALL

A final call is not made to the external scalar function. The function does not receive an additional argument that specifies the type of call.

FINAL CALL

A final call is made to the external scalar function. See the following description of call types for the characteristics of a final call. When FINAL CALL is specified, the function receives an additional argument that specifies the type of call to enable the function to differentiate between a final call and another type of call.

For an external table function:

NO FINAL CALL

A first and final call are not made to the external table function.

FINAL CALL

A first call and final call are made to the external table function in addition to one or more other types of calls.

ALLOW or DISALLOW PARALLEL

This clause has no functional equivalent in the XDB Server operating environment.

NO DBINFO or DBINFO

Specifies whether specific information that XDB knows is passed to the function when it is invoked.

NO DBINFO | Additional information is not passed.
DBINFO | An additional argument is passed when the function is invoked. The argument is a structure that contains information such as the application run-time authorization ID, the schema name, the name of a table or column that the function might be inserting into or updating, and identification of the database server that invoked the function. For details about the argument and its structure, see your DB2 Application Programming and SQL Guide.

CARDINALITY integer

Specifies an estimate of the expected number of rows that the function returns. The number is used for optimization purposes. The value of integer must range from 0 to 2147483647.

If a function has an infinite cardinality--the function never returns the "end-of-table" condition and always returns a row, then a query that requires the "end-of-table" to work correctly, will need to be interrupted. Thus, avoid using such functions in queries that involve GROUP BY and ORDER BY.

Do not specify CARDINALITY for external scalar functions.

NO COLLID or COLLID collection-id

Identifies the package collection that is used when the function is executed.

NO COLLID | The package collection for the function is the same as the package collection of the program that invokes the function. If a trigger invokes the function, the collection of the trigger package is used. If the invoking program does not use a package, XDB resolves the package by using the CURRENT PACKAGE PATH special register or the CURRENT PACKAGESET special register.
COLLID collection-id | The name of the package collection that is used when the function is executed.

WLM ENVIRONMENT

This clause has no functional equivalent in the XDB Server operating environment

ASUTIME

Specifies the total amount of processor time, in CPU service units, that a single invocation of the function can run. The value is unrelated to the ASUTIME column of the resource limit specification table.

When you are debugging a function, setting a limit can be helpful if the function gets caught in a loop.

NO LIMIT | There is no limit on the service units.
LIMIT integer | The limit on the service units is a positive integer in the range of 1 to 2GB. If the function uses more service units than the specified value, the function is canceled.

The XDB Server operating environment only provides NO LIMIT at this time.

STAY RESIDENT

Specifies whether the load module for the function remains resident in memory when the function ends.

NO | The load module is deleted from memory after the function ends. Use NO for non-reentrant functions.
YES | The load module remains resident in memory after the function ends. Use YES for reentrant functions.

The XDB Server provides an operating environment where the function does not remain resident.

PROGRAM TYPE

Specifies whether the function program runs as a main routine or a subroutine.

SUB | The function runs as a subroutine.
MAIN | The function runs as a main routine.

SECURITY

This clause has no functional equivalent in the XDB Server operating environment.

STOP AFTER SYSTEM DEFAULT FAILURES, STOP AFTER integer FAILURES, or CONTINUE AFTER FAILURE

Specifies whether the routine is to be put in a stopped state after some number of failures. The following options must not be specified for SQL functions or sourced functions.

  • STOP AFTER SYSTEM DEFAULT FAILURES.
  • STOP AFTER integer FAILURES.
  • CONTINUE AFTER FAILURE.

This clause is only implemented syntactically in the XDB Server operating environment.

RUN OPTIONS run-time-options

This clause has no functional equivalent in the XDB Server operating environment.

Note:

Changes are immediate: Any changes that the ALTER FUNCTION statement causes to the definition of an external function take effect immediately. The changed definition is used the next time that the function is invoked.

Examples:

Assume that there are two functions CENTER in the PELLOW schema. The first function has two input parameters with INTEGER and FLOAT data types, respectively. The specific name for the first function is FOCUS1. The second function has three parameters with CHAR(25), DEC(5,2), and INTEGER data types.

Using the specific name to identify the function, change the WLM environment in which the first function runs from WLMENVNAME1 to WLMENVNAME2.

ALTER SPECIFIC FUNCTION PELLOW.FOCUS1 WLM ENVIRONMENT WLMENVNAME2;

Change the second function that is described above so that it is not invoked when any of the arguments are null. Use the function signature to identify the function,

 ALTER FUNCTION PELLOW.CENTER (CHAR(25), DEC(5,2), INTEGER)
     RETURNS NULL ON NULL INPUT;

You can also code the ALTER FUNCTION statement without the exact values for the CHAR and DEC data types:

 ALTER FUNCTION PELLOW.CENTER (CHAR(), DEC(), INTEGER)
     RETURNS NULL ON NULL INPUT;

If you use empty parentheses, XDB ignores the length, precision, and scale attributes when looking for matching data types to find the function.

Parent topic: SQL Statements


ALTER FUNCTION (SQL)

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared only if DYNAMICRULES run behavior is implicitly or explicitly specified.

Authorization

The privilege set defined below must include at least one of the following:

  • Ownership of the function
  • The ALTERIN privilege on the schema
  • SYSADM or SYSCTRL authority

The authorization ID that matches the schema name implicitly has the ALTERIN privilege on the schema.

If the statement is embedded in an application program, the privilege set is the privileges that are held by the authorization ID of the owner of the plan or package.

If the statement is dynamically prepared, the privilege set is the privileges that are held by the authorization IDs of the process. The specified function name can include a schema name (a qualifier). However, if the schema name is not the same as one of these authorization IDs, one of the following conditions must be met:

  • The privilege set includes SYSADM or SYSCTRL authority.
  • An authorization ID of the process has the ALTERIN privilege on the schema.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

ALTER {FUNCTION function-name [(parameter-type[,...])] |
    SPECIFIC FUNCTION specific-name}
    option-list

parameter-type

{data-type [AS LOCATOR] | TABLE LIKE table-name AS LOCATOR}

data-type

{built-in-type | distinct-type-name}

built-in-type

[SMALLINT]
[INTEGER | INT]
[DECIMAL | DEC | NUMERIC} [(5,0) | (integer [,integer])]
[FLOAT [(53) | (integer)] | REAL [PRECISION] | DOUBLE}]
[{{CHARACTER | CHAR} [(1) | (integer)] | {CHARACTER | CHAR} VARYING (integer) | VARCHAR (integer) }
    [FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII | UNICODE}] |
    {{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(1M) | (integer [K | M | G])] }
    [FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII | UNICODE}] }]
[{GRAPHIC [(1) | (integer)] | VARGRAPHIC (integer) | DBCLOB [(1M) | (integer [K | M | G])]}
    [CCSID {ASCII | EBCDIC | UNICODE}]]
[{BINARY LARGE OBJECT | BLOB} [(1M) | (integer [K | M | G])]]
[DATE | TIME | TIMESTAMP]
[ROWID]

option-list

LANGUAGE SQL
    [DETERMINISTIC | NOT DETERMINISTIC]
    [EXTERNAL ACTION | NO EXTERNAL ACTION]
    [CONTAINS SQL | READS SQL DATA]
    [STATIC DISPATCH CALLED ON NULL INPUT]
Parent topic: SQL Statements


ALTER INDEX

Invocation

When issued against an XDB Server, this statement only supports the ADD COLUMN clause, but is fully supported when issued against a DB2 database through XDB Link.

Syntax

ALTER INDEX index-name
    [BUFFERPOOL bpname]
    [CLOSE {YES | NO}]
    [COPY {YES | NO}]
    [DSETPASS password]
    [PART integer]
    [FREEPAGE integer]
    [PCTFREE integer]
    [USING {VCAT catalog-name
            | STOGROUP stogroup-name}]
    [PRIQTY {3 | integer}]
    [SECQTY {3 | integer}]
    [ERASE {YES | NO}] [GBPCACHE {CHANGED | ALL}]
    [CONVERT TO {TYPE 1 [SUBPAGES {4 | 1 | 2 | 8 | 16}] | TYPE 2}]
    [PIECESIZE integer {K | M | G}]
    [PART integer [VALUES (constant[,...])]
        [[using-block | free-block | gbpcache-block][...]][,...]]
    [{CLUSTER | NOT CLUSTER}]
    [{PADDED | NOT PADDED}]
    [ADD COLUMN (column-name [{ASC | DESC}] )]

Parameters:

bpname A name that identifies a bufferpool. The 4K bufferpools are named BP0, BP1, BP2...BP49. The 32K bufferpools are named BP32K, BP32K1, BP32K2...BP32K9.

Description

index-name

Identifies the index to be altered. The name must identify a user-created index that exists at the current server. The name must not identify an index that is defined on a declared temporary table.

BUFFERPOOL

This clause has no functional equivalent within the XDB Server operating environment. However, for DB2 compatibility purposes, the XDB Server records any of the sixty possible bufferpools (BP0...BP49, BP32K, BPK1...BPK9). The first fifty bufferpools are for indexes with 4K page sizes, while the last ten are for indexes with 32K page sizes. Although not functionally supported, this new information is semantically checked and recorded in the XDB Server catalog tables.

COPY

Indicates whether the COPY utility is allowed for the index.

NO | Does not allow full image or concurrent copies or the use of the RECOVER utility on the index.
YES | Allows full image or concurrent copies and the use the RECOVER utility on the index.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

PIECESIZE integer

Specifies the maximum addressability of each piece (data set) for a nonpartitioning index. Be very aware that when you alter the PIECESIZE value, the index is placed into REBUILD-pending (PSRBD) status and the entire index space becomes inaccessible. You must run the REBUILD INDEX or the REORG TABLESPACE utility to remove that status.

The subsequent keyword K, M, or G, indicates the units of the value specified in integer.

K | Indicates that the integer value is to be multiplied by 1 024 to specify the maximum piece size in bytes. The integer must be a power of two between 256 and 67 108 864.
M | Indicates that the integer value is to be multiplied by 1 048 576 to specify the maximum piece size in bytes. The integer must be a power of two between 1 and 65 536.
G | Indicates that the integer value is to be multiplied by 1 073 741 824 to specify the maximum piece size in bytes. The integer must be a power of two between 1 and 64

The piece size limit for partitioned table spaces with more than 254 partitions is 4096.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

Using Block for Nonpartitioning Indexes

For nonpartitioning indexes, the USING clause specifies whether the data sets for the index are to be managed by the user or managed by DB2. The USING clause applies to every data set that can be used for the index. (A nonpartitioning index can have more than one data set if PRIQTY+118 * SECQTY is at least 2 gigabytes.)

If you specify USING, the index must be in the stopped state when the ALTER INDEX statement is executed.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

USING Block for Partitioning Indexes:

For a partitioning index, there is an optional PART clause for each partition. A using-block can be specified at the global level or at the partition level. A using-block within a PART clause applies only to that partition. A using-block specified before any PART clauses applies to every partition except those with a PART clause with a using-block.

For DB2-managed data sets, the values of PRIQTY, SECQTY, and ERASE for each partition are given by the first of these choices that applies:

  • The values of PRIQTY, SECQTY, and ERASE given in the using-block within the PART clause for the partition. Do not use more than one using-block in any PART clause.
  • The values of PRIQTY, SECQTY, and ERASE given in a using-block before any PART clauses
  • The current values of PRIQTY, SECQTY, and ERASE

For data sets that are being changed from user-managed to DB2-managed, the values of PRIQTY, SECQTY, and ERASE for each partition are given by the first of these choices that applies:

  • The values of PRIQTY, SECQTY, and ERASE given in the using-block within the PART clause for the partition. Do not use more than one using-block in any PART clause.
  • The values of PRIQTY, SECQTY, and ERASE given in a using-block before any PART clauses
  • The default values of PRIQTY, SECQTY, and ERASE, which are:

    PRIQTY 12

    SECQTY 12, if PRIQTY is not specified in either using-block, or 10% of PRIQTY or 3 times the index page size (whichever is larger) when PRIQTY is specified

    ERASE NO

Any partition for which USING or ERASE is specified (either explicitly at the partition level or implicitly at the global level) must be in the stopped state when the ALTER INDEX statement is executed.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

VCAT catalog-name

Specifies a user-managed data set with a name that starts with the specified catalog name. You must specify the catalog name in the form of a short identifier. Thus, you must specify an alias if the name of the integrated catalog facility catalog is longer than eight characters.

If n is the number of the partition, the identified integrated catalog facility catalog must already contain an entry for the nth data set of the index. Refer to appropriate DB2 documentation for a full explanation of DB2 naming conventions for data sets.

One or more DB2 subsystems could share integrated catalog facility catalogs with the current server. To avoid the chance of having one of those subsystems attempt to assign the same name to different data sets, select a value for catalog-name that is not used by the other DB2 subsystems.

DB2 assumes one and only one data set for each partition.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

STOGROUP stogroup-name

If USING STOGROUP is used, stogroup-name must identify a storage group that exists at the current server and the privilege set must include SYSADM authority, SYSCTRL authority, or the USE privilege for the storage group.

DB2 assumes one and only one data set for each partition.

Omitting or specifying -1 for the PRIQTY or SECQTY clause implicitly specifies the default value for that clause. For more information on the PRIQTY, SECQTY, and ERASE clauses, see the description of those clauses for nonpartitioning indexes.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

FREEPAGE integer

Specifies how often to leave a page of free space when index entries are created as the result of executing a DB2 utility. One free page is left for every integer pages. The value of integer can range from 0 to 255. The change to the description of the index or partition has no effect until it is loaded or reorganized using a DB2 utility.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

PCTFREE integer

Determines the percentage of free space to leave in each nonleaf page and leaf page when entries are added to the index or partition as the result of executing a DB2 utility. The first entry in a page is loaded without restriction. When additional entries are placed in a nonleaf or leaf page, the percentage of free space is at least as great as integer.

The value of integer can range from 0 to 99, however, if a value greater than 10 is specified, only 10 percent of free space will be left in nonleaf pages. The change to the description of the index or partition has no effect until it is loaded or reorganized using a DB2 utility.

If the index is partitioning, the values of FREEPAGE and PCTFREE for a particular partition are given by the first of these choices that applies:

  • The values of FREEPAGE and PCTFREE given in the PART clause for that partition. Do not use more than one free-block in any PART clause.
  • The values given in a free-block before any PART clauses.
  • The current values of FREEPAGE and PCTFREE for that partition.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

GBPCACHE

Specifies what index pages are written to the group buffer pool in a data sharing environment. In a non-data-sharing environment, you can specify this option, but it is ignored.

CHANGED | When there is inter-DB2 R/W interest on the index or partition, updated pages are written to the group buffer pool. When there is no inter-DB2 R/W interest, the group buffer pool is not used. Inter-DB2 R/W interest exists when more than one member in the data sharing group has the index or partition open, and at least one member has it open for update. If the index is in a group buffer pool that is defined as GBPCACHE(NO), CHANGED is ignored and no pages are cached to the group buffer pool.
ALL | Indicates that pages are to be cached to the group buffer pool as they are read in from DASD, with one exception. When the page set is not GBP-dependent and one DB2 data sharing member has exclusive R/W interest in that page set (no other group members have any interest in the page set), no pages are cached in the group buffer pool. Hiperpools are not used for indexes or partitions that are defined with GBPCACHE ALL. If the index is in a group buffer pool that is defined as GBPCACHE(NO), ALL is ignored and no pages are cached to the group buffer pool.
NONE | Indicates that no pages are to be cached to the group buffer pool. DB2 uses the group buffer pool only for cross-invalidation. If you specify NONE, the index or partition must not be in group buffer pool recover pending (GRECP) status.

If the index is partitioned, the value of GBPCACHE for a particular partition is given by the first of these choices that applies:

  1. The value of GBPCACHE given in the PART clause for that partition. Do not use more than one gbpcache-block in any PART clause.
  2. The value given in a gbpcache-block before any PART clauses.
  3. The current value of GBPCACHE for that partition.

If you specify GBPCACHE in a data sharing environment, the index or partition must be in the stopped state when the ALTER INDEX statement is executed. You cannot alter the GBPCACHE value for the following indexes on catalog table SYSIBM.SYSINDEXES: DSNDXX01, DSNDXX02, DSNDXX03.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

PART integer

Identifies a partition of the index. For an index that has n partitions, you must specify an integer in the range 1 to n. You must not use this clause if the index is nonpartitioned. You must use this clause if the index is partitioned and you specify the VALUES clause.

VALUES(constant,...) Specifies the highest value of the index key for the identified partition of the partitioning index. In this context, highest means highest in the sorting sequences of the index columns. In a column defined as ascending (ASC), highest and lowest have their usual meanings. In a column defined as descending (DESC), the lowest actual value is highest in the sorting sequence.

You must use at least one constant after VALUES in each PART clause. You can use as many constants as there are columns in the key. The concatenation of all the constants is the highest value of the key in the corresponding partition of the index. The length of each highest key value (also called the limit key) is the same as the length of the partitioning index.

The use of the constants to define key values is subject to these rules:

  • The first constant corresponds to the first column of the key, the second constant to the second column, and so on. Each constant must have the same data type as its corresponding column.
  • If a key includes a ROWID column (or a column with a distinct type that is sourced on a ROWID data type), the values of the ROWID column are assumed to be in the range of X'000...00' to X'FFF...FF'. Only the first 17 bytes of the constant that is specified for the corresponding ROWID column are considered.
  • The precision and scale of a decimal constant must not be greater than the precision and scale of its corresponding column.
  • If a string constant is longer or shorter than required by the length attribute of its column, the constant is either truncated or padded on the right to the required length. If the column is ascending, the padding character is X'FF'; if the column is descending, the padding character is X'00'.
  • Using fewer constants than there are columns in the key has the same effect as using the highest possible values for all omitted columns for an ascending index. For a descending index, it has the same effect as using the lowest possible values for all omitted columns.
  • The highest value of the key in any partition must be lower than the highest value of the key in the next partition.
  • The highest value of the key in the last partition depends on how the table space was defined. For table spaces created without the LARGE or DSSIZE option, the constants you specify after VALUES are not enforced. The highest value of the key that can be placed in the table is the highest possible value of the key.For table spaces created with the LARGE or DSSIZE options, the constants you specify after VALUES are enforced. The value specified by the constants is the highest value of the key that can be placed in the table. Any keys that are made invalid after the ALTER statement is executed are placed in a discard data set when you run REORG. If the last partition is in REORG pending, regardless of whether you changed its limiting key values, you must specify a discard data set when you run REORG.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

CLUSTER or NOT CLUSTER

Specifies whether the index is the clustering index for the table.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

CLUSTER

The index is used as the clustering index for the table. This change takes effect immediately. Any subsequent INSERT statements will use the new clustering index. Existing data remains clustered by the previous clustering index until the table space is reorganized.

The implicit or explicit clustering index is ignored when data is inserted into a table space that is defined with MEMBER CLUSTER. Instead of using cluster order, DB2 chooses where to locate the data based on available space. The MEMBER CLUSTER attribute affects only data that is inserted with the INSERT statement; data is always loaded and reorganized in cluster order.

Do not specify CLUSTER if the table is an auxiliary table or if CLUSTER was used already for a different index on the table.

NOT CLUSTER

The index is not used as the clustering index of the table. If the index is already defined as the clustering index, it continues to be used as the clustering index by DB2 and the REORG utility until clustering is explicitly changed by specifying CLUSTER for a different index.

Specifying NOT CLUSTER for an index that is not a clustering index is ignored.

If the index is the partitioning index for a table that uses index-controlled partitioning, the table is converted to use table-controlled partitioning. The high limit key for the last partition is set to the highest possible value for ascending key columns or the lowest possible value for descending key columns.

NOT PADDED or PADDED

Specifies how varying-length string columns are to be stored in the index. If the index contains no varying-length columns, this option is ignored, and a warning message is returned.

The XDB server operating environment syntactically verifies this clause, and records information in the appropriate catalog tables.

NOT PADDED

Specifies that varying-length string columns are not to be padded to their maximum length in the index. The length information for a varying-length column is stored with the key.

NOT PADDED is ignored and has no effect if the index is on an auxiliary table. Indexes on auxiliary tables are always padded.

When PADDED is changed to NOT PADDED, the index key length is recalculated with the varying-length formula (2000 - n - 2m, where n is the number of columns that can contain null values and m is the number of varying-length columns in the key). If it is possible that the index key length may exceed the maximum length (because before when it was padded, the formula 2000 - n was used), an error occurs.

PADDED

Specifies that varying-length string columns within the index are always padded with the default pad character to their maximum length.

When an index with at least one varying-length column is changed from PADDED to NOT PADDED, or vice versa, the index is placed in restricted REBUILD-pending status (RBDP). The index cannot be accessed until it is rebuilt from the table (REBUILD INDEX, REORG TABLESPACE, or LOAD REPLACE utility). For nonpartitioned secondary indexes (NPSIs), the index is placed in page set REBUILD-pending status (PSRBD), and the entire index must be rebuilt. In addition, plans and packages that are dependent on the table are quiesced, and dynamically cached statements that are dependent on the index are invalidated.

ADD COLUMN column-name

Adds column-name to the index. column-name must be unqualified, must identify a column of the table, must not be one of the existing columns of the index, and must not be a LOB column or a distinct type column based on a LOB data type. The total number of columns for the index cannot exceed 64.

For PADDED indexes, the sum of the length attributes of the columns must not be greater than 2000 - n, where n is the number of columns that can contain null values.

For NOT PADDED indexes, the sum of the length attributes of the columns must not be greater than 2000 - n -2m, where n is the number of nullable columns and m is the number of varying-length columns.

The index cannot be any of the following types of indexes:

  • A system-defined catalog index
  • An index that enforces a primary key, unique key, or referential constraint
  • A partitioning index when index-controlled partitioning is being used
  • A unique index required for a ROWID column defined as GENERATED BY DEFAULT
  • An auxiliary index

If the column is added to the table and that same column is added to an associated index within the same commit scope and within that commit scope no data rows were inserted, the index is left in advisory REORG-pending (AREO*) state; otherwise, the index is left in REBUILD-pending (RBDP) state.

  • ASC - Index entries are put in ascending order by the column.
  • DESC - Index entries are put in descending order by the column.

Examples:

Alter the index DSN8610.XEMP1. Indicate that XDB is not to close the data sets that support the index when there are no current users of the index.

 ALTER INDEX DSN8610.XEMP1
     CLOSE NO;

Alter the index DSN8610.XPROJ1. Use BP1 as the buffer pool that is to be associated with the index, indicate that full image or concurrent copies on the index are allowed, and change the maximum size of each data set to 8 megabytes.

 ALTER INDEX DSN8610.XPROJ1
     BUFFERPOOL BP1
     COPY YES
     PIECESIZE 8M;
Parent topic: SQL Statements


ALTER LOCATION

Note:

By default, XDB Server creates locations that are compatible with DB2 Version 6, 7 or 8.

Invocation

ALTER LOCATION is an executable command that can be issued interactively, embedded in a host language or dynamically prepared.

Authorization

To execute the ALTER LOCATION command, users must have INSTALL or SYSADM privileges.

Syntax

ALTER LOCATION location-name TO {VERSION {V41 | V51 | V60 | V71 | V80} | SORT SEQUENCE language-name EBCDIC}

Parameters:

location-name

Identifies the location to be converted.

  • swedish
  • classic
  • dutch
  • french
  • spanish
  • italian
  • uk
  • danish
  • norwegian
  • finnish
  • german
  • austrian
  • portuguese
  • us
  • international
  • turkish

Description

You can use most DB2 Version 7.0 and Version 8.0 features without converting your existing XDB Server locations. However, you cannot use new DDL-related features without upgrading. Once you convert a location to DB2 Version 7.0 and Version 8.0 compatibility, you cannot use it with an earlier version of the XDB Server.

Example:

alter location jbl to sort sequence german ebcdic;
Parent topic: SQL Statements


ALTER PASSWORD

Syntax

ALTER PASSWORD old_password TO new_password
Parent topic: SQL Statements


ALTER PROCEDURE (external)

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

To execute the ALTER PROCEDURE command, users must possess either overall SYSADM or SYSCTRL authority for the location, or be the owner of the stored procedure affected.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

ALTER PROCEDURE procedure-name
    [DYNAMIC RESULT {SET | SETS} integer]
    [EXTERNAL NAME {'string' | indentifier}]
    [LANGUAGE {ASSEMBLE | C | COBOL | COMPJAVA | PLI | REXX}]
    [PARAMETER STYLE {DB2SQL | GENERAL | GENERAL WITH NULLS | JAVA}]
    [{DETERMINISTIC | NOT DETERMINISTIC}]
    [{CONTAINS SQL | READS SQL DATA | MODIFIES SQL DATA | NO SQL}]
    [{DBINFO | NODBINFO}]
    [{NO COLLID | COLLID collection-id}]
    [{WLM ENVIRONMENT {name | (name,*)}} | NO WLM ENVIRONMENT}]
    [ASUTIME {NO LIMIT | LIMIT integer}]
    [STAY RESIDENT {NO | YES}]
    [PROGRAM TYPE {SUB | MAIN}]
    [SECURITY {DB2 | USER | DEFINER}]
    [RUN OPTIONS run-time-options]
    [COMMIT ON RETURN {NO | YES}]
    [CALLED ON NULL INPUT]
    [{STOP AFTER SYSTEM DEFAULT FAILURES |
     STOP AFTER integer FAILURES |
     CONTINUE AFTER FAILURE}]

Description

procedure-name

Identifies the stored procedure to be altered. The name is implicitly or explicitly qualified by a schema name. If the name is not explicitly qualified, it is implicitly qualified with a schema name according to the following rules:

  • If the statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER option when the plan or package was created or last rebound. If QUALIFIER was not specified, the schema name is the owner of the plan or package.
  • If the statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

DYNAMIC RESULT SET integer or DYNAMIC RESULT SETS integer

Specifies the maximum number of query result sets that the stored procedure can return. The value must be between 0 and 32767.

EXTERNAL NAME 'string' or identifier

Identifies the program that runs when the procedure name is specified in a CALL statement.

The name can be a string constant that is no longer than 8 characters or a short identifier.

The program does not need to exist when the ALTER PROCEDURE statement is executed. However, it must exist and be accessible by the current server when a CALL statement for the stored procedure is issued.

LANGUAGE

Specifies the application programming language in which the stored procedure is written. Assembler, C, COBOL, and PL/I programs must be designed to run in IBM's Language Environment.

ASSEMBLE | The stored procedure is written in Assembler. (Not currently available with XDB Server.)
C | The stored procedure is written in C or C++. (Not currently available with XDB Server.)
COBOL | The stored procedure is written in COBOL, including the OO-COBOL language extensions.
COMPJAVA | The stored procedure is written in Java and is a compiled program. (Not currently available with XDB Server.)
PL/I | The stored procedure is written in PL/I. (Not currently available with XDB Server.)
REXX | The stored procedure is written in REXX. Do not specify LANGUAGE REXX when PARAMETER STYLE DB2SQL or NO WLM ENVIRONMENT is in effect. (Not currently available with XDB Server.)

PARAMETER STYLE

Identifies the linkage convention used to pass parameters to the stored procedure. All of the linkage conventions provide arguments to the stored procedure that contain the parameters specified on the CALL statement. Some of the linkage conventions pass additional arguments to the stored procedure that provide more information to the stored procedure. For more information on linkage conventions, refer to appropriate DB2 documentation for a full explanation.

DB2SQL In addition to the parameters on the CALL statement, the following arguments are also passed to the stored procedure:
  • A null indicator for each parameter on the CALL statement
  • The SQLSTATE to be returned to DB2
  • The qualified name of the stored procedure
  • The specific name of the stored procedure
  • The SQL diagnostic string to be returned to DB2

If DBINFO is specified, an additional parameter, the DB2INFO structure, might also be passed. Do not specify DB2 SQL when LANGUAGE REXX is in effect.

GENERAL | Only the parameters on the CALL statement are passed to the stored procedure. The parameters cannot be null.
GENERAL WITH NULLS | In addition to the parameters on the CALL statement, another argument is also passed to the stored procedure. The additional argument contains a vector of null indicators for each of the parameters on the CALL statement that enables the stored procedure to accept or return null parameter values.
JAVA | The stored procedure uses a convention for passing parameters that conforms to the Java and SQLJ specifications. INOUT and OUT parameters are passed as single-entry arrays. The DBINFO structure is not passed. JAVA can be specified only if LANGUAGE is COMPJAVA. For REXX stored procedures (LANGUAGE REXX), GENERAL and GENERAL WITH NULLS are the only valid values for PARAMETER STYLE. For LANGUAGE COMPJAVA, JAVA is the only valid value.

NOT DETERMINISTIC or DETERMINISTIC

Specifies whether the stored procedure returns the same result from successive calls with identical input arguments.

NOT DETERMINISTIC | The stored procedure might not return the same result from successive calls with identical input arguments.
DETERMINISTIC | The stored procedure returns the same result from successive calls with identical input arguments. XDB does not verify that the stored procedure code is consistent with the specification of DETERMINISTIC or NOT DETERMINISTIC.

NO SQL, MODIFIES SQL DATA, READS SQL DATA, or CONTAINS SQL DATA

Indicates whether the stored procedure issues any SQL statements and, if so, what type.

NO SQL | The stored procedure cannot execute any SQL statements.
MODIFIES SQL DATA | The stored procedure can execute any SQL statement except those statements that are not supported in any stored procedure.
READS SQL DATA | The stored procedure cannot execute SQL statements that modify data. SQL statements that are not supported in any stored procedure return a different error.
CONTAINS SQL | The stored procedure cannot execute any SQL statements that read or modify data. SQL statements that are not supported in any stored procedure return a different error.

NO DBINFO or DBINFO

Specifies whether specific information known by XDB is passed to the stored procedure when it is invoked.

NO DBINFO | Additional information is not passed.
DBINFO | An additional argument is passed when the stored procedure is invoked. The argument is a structure that contains information such as the application run-time authorization ID, the schema name, the name of a table or column that the procedure might be inserting into or updating, and identification of the database server that invoked the procedure.

NO COLLID or COLLID collection-id

Identifies the package collection that is used when the stored procedure is executed.

NO COLLID | The package collection for the stored procedure is the same as the package collection of the program that invokes the stored procedure. If a trigger invokes the stored procedure, the collection of the trigger package is used. If the invoking program does not use a package, XDB resolves the package by using the CURRENT PACKAGE PATH special register or the CURRENT PACKAGESET special register.
COLLID collection-id | The name of the package collection that is used when the function is executed.

WLM ENVIRONMENT

This clause has no functional equivalent in the XDB Server operating environment.

NO WLM ENVIRONMENT

Indicates that the stored procedure is to run in the XDB-established stored procedure address space.

Do not specify NO WLM ENVIRONMENT if the definition of the stored procedure implicitly or explicitly includes the following clauses or parameters:

  • The PROGRAM TYPE SUB clause
  • The SECURITY USER or SECURITY DEFINER clause
  • The LANGUAGE REXX clause
  • Parameters with a LOB data type or a distinct type based on a LOB data type

To change the procedure to run in the XDB-established stored procedure address space, you must have appropriate authority for the XDB-established stored procedure address space.

ASUTIME

Specifies the total amount of processor time, in CPU service units, that a single invocation of a stored procedure can run. The value is unrelated to the ASUTIME column in the resource limit specification table.

When you are debugging a stored procedure, setting a limit can be helpful in case the stored procedure gets caught in a loop.

NO LIMIT | There is no limit on the service units.
LIMIT integer | The limit on the service units is a positive integer in the range of 1 to 2GB. If the stored procedure uses more service units than the specified value, the stored procedure is canceled.

The XDB Server operating environment only provides NO LIMIT at this time.

STAY RESIDENT

Specifies whether the stored procedure load module remains resident in memory when the stored procedure ends.

NO | The load module is deleted from memory after the stored procedure ends. Use NO for non-reentrant stored procedures.
YES | The load module remains resident in memory after the stored procedure ends.

The XDB Server provides an operating environment where the function does not remain resident.

PROGRAM TYPE

Specifies whether the stored procedure runs as a main routine or a subroutine.

SUB | The stored procedure runs as a subroutine.
MAIN | The stored procedure runs as a main routine.

SECURITY

This clause has no functional equivalent in the XDB Server operating environment.

RUN OPTIONS run-time-options

This clause has no functional equivalent in the XDB Server operating environment.

COMMIT ON RETURN

Indicates whether XDB commits the transaction immediately on return from the stored procedure.

NO XDB does not issue a commit when the stored procedure returns.
YES XDB issues a commit when the stored procedure returns if the following statements are true:
  • The SQLCODE that is returned by the CALL statement is not negative.
  • The stored procedure is not in a must abort state.

The commit operation includes the work that is performed by the calling application process and the stored procedure.

If the stored procedure returns result sets, the cursors that are associated with the result sets must have been defined WITH HOLD to be usable after the commit.

CALLED ON NULL INPUT

Specifices that the stored procedure will be called even if any of the input arguments is null, making the procedure responsible for testing for null argument values. The result is the null value.

Note:

Changes are immediate: Any changes that the ALTER PROCEDURE statement cause to the definition of a procedure take effect immediately.

The changed definition is used the next time that the procedure is called.

Restrictions for nested stored procedures: A stored procedure, user-defined function, or trigger cannot call a stored procedure that is defined with the COMMIT ON RETURN clause.

STOP AFTER SYSTEM DEFAULT FAILURES, STOP AFTER integer FAILURES, or CONTINUE AFTER FAILURE

Specifies whether the routine is to be put in a stopped state after some number of failures.

  • STOP AFTER SYSTEM DEFAULT FAILURES.
  • STOP AFTER integer FAILURES.
  • CONTINUE AFTER FAILURE.

This clause is only implemented syntactically in the XDB Server operating environment.

Example:

Assume that stored procedure SYSPROC.MYPROC is currently defined to run in WLM environment PARTSA and that you have appropriate authority on that WLM environment and WLM environment PARTSEC. Change the definition of the stored procedure so that it runs in PARTSEC.

ALTER PROCEDURE SYSPROC.MYPROC WLM ENVIRONMENT PARTSEC;
Parent topic: SQL Statements


ALTER PROCEDURE (SQL)

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

To execute the ALTER PROCEDURE command, users must possess either overall SYSADM or SYSCTRL authority for the location, or be the owner of the stored procedure affected.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

ALTER PROCEDURE procedure-name
    [DYNAMIC RESULT {SET | SETS} integer]
    [EXTERNAL NAME {'string' | identifier}]
    [{DETERMINISTIC | NOT DETERMINISTIC}]
    [{CONTAINS SQL | READS SQL DATA | MODIFIES SQL DATA}]
    [{NO COLLID | COLLID collection-id}]
    [{WLM ENVIRONMENT {name | (name,*)}} | NO WLM ENVIRONMENT}]
    [ASUTIME {NO LIMIT | LIMIT integer}]
    [STAY RESIDENT {NO | YES}]
    [PROGRAM TYPE {SUB | MAIN}]
    [SECURITY {DB2 | USER | DEFINER}]
    [RUN OPTIONS run-time-options]
    [COMMIT ON RETURN {NO | YES}]
    [INHERIT SPECIAL REGISTERS | DEFAULT SPECIAL REGISTERS]
    [{STOP AFTER SYSTEM DEFAULT FAILURES |
     STOP AFTER integer FAILURES |
     CONTINUE AFTER FAILURE}]

Description

procedure-name

Identifies the stored procedure to be altered. The name is implicitly or explicitly qualified by a schema name. If the name is not explicitly qualified, it is implicitly qualified with a schema name according to the following rules.

  • If the statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER option when the plan or package was created or last rebound. If QUALIFIER was not specified, the schema name is the owner of the plan or package.
  • If the statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

DYNAMIC RESULT SET integer or DYNAMIC RESULT SETS integer

Specifies the maximum number of query result sets that the stored procedure can return. The value must be between 0 and 32767.

EXTERNAL NAME 'string' or identifier

Specifies the name of the MVS load module for the program that runs when the procedure name is specified in an SQL CALL statement. The value must conform to the naming conventions for MVS load modules: the value must be less than or equal to 8 bytes, and it must conform to the rules for an ordinary identifier with the exception that it must not contain an underscore.

NOT DETERMINISTIC or DETERMINISTIC

Specifies whether the stored procedure returns the same result from successive calls with identical input arguments.

NOT DETERMINISTIC | The stored procedure might not return the same result from successive calls with identical input arguments.
DETERMINISTIC | The stored procedure returns the same result from successive calls with identical input arguments. XDB does not verify that the stored procedure code is consistent with the specification of DETERMINISTIC or NOT DETERMINISTIC.

MODIFIES SQL DATA, READS SQL DATA, or CONTAINS SQL DATA

Indicates whether the stored procedure can execute any SQL statements and, if so, what type.

MODIFIES SQL DATA | The stored procedure can execute any SQL statement except those statements that are not supported in any stored procedure.
READS SQL DATA | The stored procedure cannot execute SQL statements that modify data. SQL statements that are not supported in any stored procedure return a different error.
CONTAINS SQL | The stored procedure cannot execute any SQL statements that read or modify data. SQL statements that are not supported in any stored procedure return a different error

NO COLLID or COLLID collection-id

Identifies the package collection that is used when the stored procedure is executed.

NO COLLID | The package collection for the stored procedure is the same as the package collection of the program that invokes the stored procedure. If a trigger invokes the stored procedure, the collection of the trigger package is used. If the invoking program does not use a package, XDB resolves the package by using the CURRENT PACKAGE PATH special register or the CURRENT PACKAGESET special register.
COLLID collection-id | The name of the package collection that is used when the stored procedure is executed.

WLM ENVIRONMENT

This clause has no functional equivalent in the XDB Server operating environment.

ASUTIME

Specifies the total amount of processor time, in CPU service units, that a single invocation of a stored procedure can run. The value is unrelated to the ASUTIME column of the resource limit specification table.

When you are debugging a stored procedure, setting a limit can be helpful in case the stored procedure gets caught in a loop.

NO LIMIT | There is no limit on the service units.
LIMIT integer | The limit on the service units is a positive integer in the range of 1 to 2 GB. If the stored procedure uses more service units than the specified value, the stored procedure is canceled.

The XDB Server operating environment only provides NO LIMIT at this time.

STAY RESIDENT

Specifies whether the stored procedure load module remains resident in memory when the stored procedure ends.

NO | The load module is deleted from memory after the stored procedure ends.
YES | The load module remains resident in memory after the stored procedure ends.

The XDB Server provides an operating environment where the function does not remain resident.

PROGRAM TYPE

Specifies whether the stored procedure runs as a main routine or a subroutine.

SUB | The stored procedure runs as a subroutine.
MAIN | The stored procedure runs as a main routine.

SECURITY

This clause has no functional equivalent in the XDB Server operating environment.

RUN OPTIONS run-time-options

This clause has no functional equivalent in the XDB Server operating environment.

COMMIT ON RETURN

Indicates whether XDB commits the transaction immediately on return from the stored procedure.

NO XDB does not issue a commit when the stored procedure returns.
YES XDB issues a commit when the stored procedure returns if the following statements are true:
  • The SQLCODE that is returned by the CALL statement is not negative.
  • The stored procedure is not in a must abort state.

The commit operation includes the work that is performed by the calling application process and the stored procedure.

If the stored procedure returns result sets, the cursors that are associated with the result sets must have been defined as WITH HOLD to be usable after the commit.

Note:

Any changes that the ALTER PROCEDURE statement cause to the definition of a procedure take effect immediately.

The changed definition is used the next time that the procedure is called.

A stored procedure, user-defined function, or trigger cannot call a stored procedure that is defined with the COMMIT ON RETURN clause.

STOP AFTER SYSTEM DEFAULT FAILURES, STOP AFTER integer FAILURES, or CONTINUE AFTER FAILURE

Specifies whether the routine is to be put in a stopped state after some number of failures.

  • STOP AFTER SYSTEM DEFAULT FAILURES.
  • STOP AFTER integer FAILURES.
  • CONTINUE AFTER FAILURE.

This clause is only implemented syntactically in the XDB Server operating environment.

Example:

Modify the definition for an SQL procedure so that SQL changes are committed on return from the SQL procedure and the SQL procedure runs in the WLM environment named WLMSQLP.

 ALTER PROCEDURE UPDATE_SALARY_1
    COMMIT ON RETURN YES
    WLM ENVIRONMENT WLMSQLP;
Parent topic: SQL Statements


ALTER SEQUENCE

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared only if DYNAMICRULES run behavior is implicitly or explicitly specified.

Authorization

The privilege set that is defined below must include at least one of the following:

  • Ownership of the sequence
  • The ALTER privilege for the sequence
  • The ALTERIN privilege on the schema
  • SYSADM or SYSCTRL authority

The authorization ID that matches the schema name implicitly has the ALTERIN privilege on the schema.

If the statement is embedded in an application program, the privilege set is the privileges that are held by the authorization ID of the owner of the plan or package. If the statement is dynamically prepared, the privilege set is the privileges that are held by the SQL authorization ID of the process.

Syntax

ALTER SEQUENCE sequence-name {RESTART [WITH numeric-constant] |
     INCREMENT BY numeric-constant |
     {MINVALUE numeric-constant | NO MINVALUE} |
     {MAXVALUE numeric-constant | NO MAXVALUE} |
     {CYCLE | NO CYCLE} |
     {CACHE integer-constant | NO CACHE} |
     {ORDER | NO ORDER}
     } [...]

Description

SEQUENCE sequence-name
Identifies the sequence. The combination of sequence name and the implicit or explicit qualifier must identify an existing sequence at the current server. sequence-name must not identify a sequence that is generated by the system for an identity column.
RESTART
Restarts the sequence. If numeric-constant is not specified, the sequence is restarted at the value specified implicitly or explicitly as the starting value on the CREATE SEQUENCE statement that originally created the sequence.
WITH numeric-constant
Specifies the value at which to restart the sequence. The value can be any positive or negative value that could be assigned to a column of the data type that is associated with the sequence without non-zero digits existing to the right of the decimal point.

If RESTART is not specified, the sequence is not restarted. Instead, it resumes with the current values in effect for all the options after the ALTER statement is issued.

After a sequence is restarted or changed to allow cycling, sequence numbers may be duplicates of values generated by the sequence previously.

INCREMENT BY numeric-constant
Specifies the interval between consecutive values of the sequence. The value can be any positive or negative value (including 0) that could be assigned to a column of the data type that is associated with the sequence without any non-zero digits existing to the right of the decimal point. The default is 1.

If INCREMENT BY numeric-constant is positive, the sequence ascends. If INCREMENT BY numeric-constant is negative, the sequence descends. If INCREMENT BY numeric-constant is 0, the sequence is treated as an ascending sequence.

The absolute value of INCREMENT BY can be greater than the difference between MAXVALUE and MINVALUE.

NO MINVALUE
Specifies that the minimum end point of the range of values for the sequence has not been specified explicitly. In such a case, the value for MINVALUE becomes one of the following:
  • For an ascending sequence, the value is the original starting value.
  • For a descending sequence, the value is the minimum of the data type that is associated with the sequence.
MINVALUE MINVALUEnumeric-constant
Specifies the minimum value at which a descending sequence either cycles or stops generating values, or an ascending sequence cycles to after reaching the maximum value. The last value that is generated for a cycle of a descending sequence will be equal to or greater than this value. MINVALUE is the value to which an ascending sequence cycles to after reaching the maximum value.

The value can be any positive or negative value that could be assigned to the a column of the data type that is associated with the sequence without non-zero digits existing to the right of the decimal point. The value must be less than or equal to the maximum value.

NO MAXVALUE
Specifies either explicitly or implicitly that the minimum end point of the range of values for the sequence has not be set. In such a case, the default value for MAXVALUE becomes one of the following:
  • For an ascending sequence, the value is the maximum value of the data type that is associated with the sequence
  • For a descending sequence, the value is the original starting value.

If NO MAXVALUE is explicitly specified in the ALTER SEQUENCE statement, the value of the MAXVALUE column in the catalog table is reset to the maximum value of the data type associated with the sequence if the sequence is ascending or the value stored in the START column of the catalog table if the sequence is descending. Whether the sequence is ascending or descending depends on whether or not the INCREMENT BY option is reset. If it is, the new INCREMENT BY VALUE determines if the sequence is ascending or descending. If it is not explicitly reset, the value stored in the INCREMENT column of the catalog table determines if the sequence is ascending or descending.

MAXVALUE numeric-constant
Specifies the maximum value at which an ascending sequence either cycles or stops generating values or a descending sequence cycles to after reaching the minimum value. The last value that is generated for a cycle of an ascending sequence will be less than or equal to this value. MAXVALUE is the value to which a descending sequence cycles to after reaching the minimum value.

The value can be any positive or negative value that could be assigned to the a column of the data type that is associated with the sequence without non-zero digits existing to the right of the decimal point. The value must be greater than or equal to the minimum value.

CYCLE

Specifies that the sequence continue to generate values after either the maximum or minimum value has been reached. If this option is used, after an ascending sequence reaches its maximum value, it generates its minimum value. After a descending sequence reaches its minimum value, it generates its maximum value. The maximum and minimum values for the sequence defined by the MINVALUE and MAXVALUE options determine the range that is used for cycling.

When CYCLE is in effect, duplicate values can be generated by the sequence. When a sequence is defined with CYCLE, any application conversion tools for converting applications from other vendor platforms to DB2 should also explicitly specify MINVALUE, MAXVALUE, and START WITH values.

NO CYCLE
Specifies that the sequence cannot generate more values once the maximum or minimum value for the sequence has been reached.
NO CACHE
Specifies that values of the sequence are not to be preallocated. This option ensures that there is not a loss of values in the case of a system failure. When NO CACHE is specified, the values of the sequence are not stored in the cache. In this case, every request for a new value for the sequence results in synchronous I/O.
CACHE integer-constant
Specifies the maximum number of sequence values that XDB can preallocate and keep in memory. Preallocating values in the cache reduces synchronous I/O when values are generated for the sequence. The actual number of values that XDB caches is always the lesser of the number in effect for the CACHE option and the number of remaining values within the logical range. Thus, the CACHE value is essentially an upper limit for the size of the cache.

In the event of a system failure, all cached sequence values that have not been used in committed statements are lost (that is, they will never be used). The value specified for the CACHE option is the maximum number of sequence values that could be lost in case of system failure.

The minimum value is 2.

In a data sharing environment, you can use the CACHE and NO ORDER options to allow multiple XDB members to cache sequence values simultaneously.

NO ORDER
Specifies that the sequence numbers do not need to be generated in order of request.
ORDER
Specifies that the sequence numbers are generated in order of request. Specifying ORDER may disable the caching of values. There is no guarantee that values are assigned in order across the entire server unless NO CACHE is also specified. ORDER applies only to a single-application process.

In a data sharing environment, if the CACHE and NO ORDER options are in effect, multiple caches can be active simultaneously, and the requests for next value assignments from different members may not result in the assignment of values in strict numeric order. For example, if members DB2A and DB2B are using the same sequence, and DB2A gets the cache values 1 to 20 and DB2B gets the cache values 21 to 40, the actual order of values assigned would be 1,21,2 if DB2A requested for next value first, then DB2B requested, and then DB2A again requested. Therefore, to guarantee that sequence numbers are generated in strict numeric order among multiple members using the same sequence concurrently, specify the ORDER option.

Comments:

  • The changes to the attributes of a sequence take effect after the ALTER SEQUENCE statement is committed. If the ALTER SEQUENCE request results in an error or is rolled back, nothing is changed; however, unused cache values may be lost. You cannot use the ALTER SEQUENCE statement to change the data type of a sequence. To change the data type, drop the sequence and recreate it. Altering a sequence may cause unused cache values to be lost.
  • To provide compatibility with previous releases, XDB supports the following keywords:
    • NOCACHE (single key word) as a synonym for NO CACHE
    • NOCYCLE (single key word) as a synonym for NO CYCLE
    • NOMINVALUE (single key word) as a synonym for NO MINVALUE
    • NOMAXVALUE (single key word) as a synonym for NO MAXVALUE
    • NOORDER (single key word) as a synonym for NO ORDER
Parent topic: SQL Statements


ALTER STOGROUP

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

To execute this command, users must either be the owner of the referenced stogroup, or possess SYSADM or SYSCTRL authority for the location.

Syntax

ALTER STOGROUP stogroup-name
    [PASSWORD password]
    [ADD VOLUMES (volume-id[,...])]
    [REMOVE VOLUMES (volume-id[,...])]

Parameters:

stogroup-name | Identifies the stogroup to be altered. The stogroup identified must exist within the currently set XDB Server location.
volume-id | Refers to the volume serial number of a mainframe storage volume.

Description

ALTER STOGROUP allows users to add and remove logical volume ID designations from an existing stogroup. The XDB Server also records any mainframe assigned password in the location catalog tables (DB2 mode).

PASSWORD

This option is utilized in the mainframe-DB2 environment. Any password parameter values are recorded in the catalog tables for the current XDB Server location.

ADD VOLUMES (volume-id,...) or ADD VOLUMES('*',...)

XDB records the volumes added to a stogroup in the catalog tables for that location. One or more volume-id numbers (corresponding to volume serial numbers) can be specified in this clause, each with a maximum of six characters (specified as an identifier or a string constant).

A volume-id must not be specified if any volume of the storage group is designated by an asterisk (*). An asterisk must not be specified if any volume of the storage group is designated by a volume-id.

You cannot add a volume that is already in the storage group unless you first remove it with REMOVE VOLUMES.

REMOVE VOLUMES (volume-id,...) or REMOVE VOLUMES('*',...)

XDB Server can associate up to 133 volumes with one stogroup. The REMOVE VOLUMES option removes one or more volumes (identified by volume-id) associated with the storage group. The XDB Server applies the REMOVE VOLUMES clause to the current list of stogroup volumes, before applying any ADD VOLUMES clauses.

Parent topic: SQL Statements


ALTER TABLE

Altering the structure of a table may require a time consuming reorganization of the table. The original table is not recoverable; take care when using this command. ALTER TABLE (in XDB mode and DB2 mode) alters the structure of an existing table. Use ALTER TABLE to add new columns, and create and drop integrity constraints.

In XDB mode, the ALTER TABLE command includes the following additional options: delete, rename and modify existing columns, add and drop unique keys and check conditions, and specify any parent table unique key (also called a candidate key) when adding a foreign key reference.

ALTER TABLE clauses can add and drop check constraints, along with WITH RESTRICT ON DROP clauses. Columns with user-defined defaults or check constraints can also be added.

Invocation

This statement can be embedded in an application program or issued interactively.

The ALTER TABLE command can be dynamically prepared (PREPARE command).

Authorization

To execute an ALTER TABLE statement, users must possess either DBADM authority on the database, the ALTER privilege on the table being altered, overall SYSADM or SYSCTRL authority for the location, or ownership of the table affected. If a FOREIGN KEY clause is included in the ALTER TABLE statement, the user must possess the ALTER privilege on the parent table.

Additional privileges might be required in the following cases:

  • FOREIGN KEY, DROP PRIMARY KEY, DROP FOREIGN KEY, or DROP CONSTRAINT is specified
  • the data type of a column that is added to the table is a distinct type
  • A fullselect is specified
  • A column is defined as a security label column

Syntax

Bold text indicates clauses or options that are supported only syntactically.

ALTER TABLE table-name
    [ALTER [COLUMN] column-alteration | partition-alteration]
                ROTATE partition-rotation

    [ADD column-definition]
                [VALIDPROC {program-name | NULL}]
    [AUDIT {NONE | CHANGES | ALL}]
    [[ADD] PRIMARY KEY key-name (column-list)]
    [ADD check-constraint]
                [ADD add-partition]
                [ADD partitioning-clause]
    [DROP CHECK constraint-name]
    [[ADD] referential-constraint]
    [DATA CAPTURE {NONE | CHANGES}]
                [{VOLATILE | NOT VOLATILE} [CARDINALITY]]
    [DROP PRIMARY KEY]
    [DROP FOREIGN KEY constraint-name]
    [DROP CONSTRAINT constraint-name]
    [{ADD | DROP} RESTRICT ON DROP]
{
    | DELETE column-name[,...]
    | RENAME old-column-name new-column-name[,...]
    | MODIFY column-name column-type [FOR BIT DATA]
        [NOT NULL [WITH DEFAULT]] [,...]
    | UNIQUE KEY key-name (column-list)
    | FOREIGN KEY [constraint-name] (column-list)
        REFERENCES referenced-table [key-name]
        [ON UPDATE {RESTRICT | CASCADE| SET NULL}]
    | DROP KEY key-name
    | CHECK (search-condition)
    | DROP CHECK
    | ADD [[MATERIALIZED] QUERY] materialized-query-definition
    | DROP [MATERIALIZED] QUERY
    | ALTER [MATERIALIZED] QUERY materialized-query-definition
                }

column-alteration:

[COLUMN] column-name
 {SET DATA TYPE altered-data-type |
                generation-alteration |
  [generation-alteration] identity-alteration}

altered-data-type

SMALLINT |
{INTEGER | INT} |
{DECIMAL | DEC | NUMERIC} [integer[,...] | (5,0)] |
{FLOAT [integer | 53] | REAL [PRECISION] | DOUBLE} |
{ {CHARACTER | CHAR} [(integer) | (1)] |
  {CHARACTER | CHAR} VARYING (integer) |
  VARCHAR (integer) }
[FOR {SBCS | MIXED | BIT} DATA]  |
{{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(integer [K|M|G]) | (1M)] }
[FOR {SBCS | MIXED} DATA] } |
{GRAPHIC [(integer) | (1M)] | VARGRAPHIC (integer)

generation-alteration

SET GENERATED {ALWAYS | BY DEFAULT}

partition-rotation:

PARTITION FIRST TO LAST ENDING [AT] (constant[,...]) [INCLUSIVE] RESET

materialized-query-definition:

(fullselect) refreshable-table-options

refreshable-table-options:

DATA INITIALLY DEFERRED REFRESH DEFERRED
[MAINTAINED BY SYSTEM | MAINTAINED BY USER]
[ENABLE QUERY OPTIMIZATION | DISABLE QUERY OPTIMIZATION]

referential-constraint:

FOREIGN KEY [constraint-name] (column-name[,...]
REFERENCES referenced-table [column-name ,...]
[ON DELETE {RESTRICT | CASCADE | SET NULL | NO ACTION}]

references-clause:

REFERENCES referenced-table
    [column-name ,...]
    [ON DELETE {RESTRICT | CASCADE | SET NULL | NO ACTION}]
    [ENFORCED | NOT ENFORCED]
    [ENABLE QUERY OPTIMIZATION]

check-constraint:

[CONSTRAINT constraint-name] CHECK (check-condition)

add-partition:

PARTITION ENDING [AT] (constant) [,...] [INCLUSIVE]

partitioning-clause:

PARTITION BY [RANGE] (partition-expression[,...]) (partition-element[,...])

partition-expresion:

                column-name [NULLS LAST] [ASC | DESC]

partition-element:

PARTITION integer ENDING [AT] (constant[,...]) [INCLUSIVE]

partition-alteration:

PARTITION integer ENDING [AT] (constant[,...]) [INCLUSIVE]

column-definition:

column-name data-type
    [NOT NULL]
    [FOR {BIT | SBCS | MIXED} DATA]
    [default-clause]
    [GENERATED {ALWAYS | BY DEFAULT} [as-identity-clause]]
    [references-clause]
    [check-constraint]
                [FIELDPROC program-name [(constant[,...])]]
    [AS SECURITY LABEL]

data-type:

{built-in-data-type | distinct-type-name}

built-in-data-type:

SMALLINT | {INTEGER | INT} |
{DECIMAL | DEC | NUMERIC} [integer[,...]] |
{FLOAT [integer] | REAL [PRECISION] | DOUBLE} |
{ {CHARACTER | CHAR} [(integer)] | {CHARACTER | CHAR} VARYING (integer) | VARCHAR (integer) }
[FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII}] |
{{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(integer [K|M|G])] }
[FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII}] } |
                {BINARY LARGE OBJECT | BLOB} (integer [K|M|G]) |
{GRAPHIC [(integer)] | VARGRAPHIC (integer) | DBCLOB (integer [K|M|G])} [CCSID {EBCDIC | ASCII}] |
{DATE | TIME | TIMESTAMP} |
ROWID

default-clause:

[WITH] DEFAULT [{constant | USER | CURRENT SQLID | NULL | cast-function-name ({constant |
   USER | CURRENT SQLID | NULL})}]

as-identity-clause:

AS IDENTITY
    [({START WITH {numeric-constant | 1}
     | INCREMENT BY {numeric-constant | 1}
     | {MINVALUE numeric-constant | NO MINVALUE} |
     | {MAXVALUE numeric-constant | NO MAXVALUE} |
     | {CYCLE | NO CYCLE} |
     | {CACHE 20 | NO CACHE | CACHE integer}}
     | [ORDER | NO ORDER] ])[,..]]

Parameters

table-name | Identifies the table to be altered. The name must identify a table that exists at the current server. The name must not identify an auxiliary table, declared temporary table, or view. If the name identifies a catalog table, DATA CAPTURE CHANGES is the only clause that can be specified.
column-name | Identifies a column in the table.
column-type Identifies a valid XDB Server column data type. Valid data types are detailed in Basic Concepts. If the column data type is CHAR or VARCHAR, and no character length is specified when altering (or creating) the table, a default character length of one becomes part of the column type specification. If the column type is DECIMAL, precision and scale may also be specified (default is 5,0).

FOR BIT DATA is an optional keyword for CHAR, VARCHAR, and LONG VARCHAR data columns. The presence of these keywords indicates that the contents of the column data values are to be treated as bit (binary) data. This option is important for COBOL programming that uses character and variable character fields to store integers, structures, etc. If not specified as FOR BIT DATA, the column is assumed (by default) to contain ASCII characters. Default character modes (such as EBCDIC) are set using the CREATE LOCATION statement. Note that the FOR BIT DATA keywords must precede any NULL specification for that column.

NOT NULL is an optional instruction that prevents the column from containing null values.

NOT NULL WITH DEFAULT prevents columns from containing null values. When an attempt is made to place a NULL value in a column field, a default value depending on the data type is inserted instead.

key-name | Designates an original name for a UNIQUE KEY.
column-list Identifies one or more columns (separated by commas) on which the key is created. Up to 64 columns can be included in a key constraint. For information on the total character (or byte) limitations of an XDB Server key constraint (or index), see the CREATE INDEX statement.

When establishing a PRIMARY KEY, a unique index must already be created on the table. The PRIMARY KEY constraint must contain the same column names, in the same order, as the unique index. If these requirements are met, the unique index is transformed into the PRIMARY KEY for that table.

constraint-name Identifies a FOREIGN KEY constraint. If a constraint name is not specified in the command, the system generates a constraint name by taking the first eight characters of the first column name, and checking for uniqueness. If these characters are not unique, the XDB Server adds a number to the first seven characters of the first column name. If still not unique, then two numbers are added to the first six characters, etc. -- until the new constraint name becomes unique among all constraint names for that table.

Also defines a table CHECK constraint within the CONSTRAINT...CHECK clause, and constraints within the DROP FOREIGN KEY, DROP CONSTRAINT and DROP CHECK clauses. The constraint-name is an SQL long identifier. A constraint-name cannot be specified more than once for the same table. (See the CONSTRAINT, DROP CONSTRAINT, DROP CHECK, and DROP keywords.)

check-condition | Can consist of a single predicate, or two or more predicates joined by AND or OR. The first operand of each predicate must be the name of a column of the table. The second operand can be a column name or a constant. A check-condition can evaluate to unknown if a column that is an operand of the predicate is null. A check-condition that evaluates to unknown does not violate the check constraint (see CHECK clause).
referenced-table Identifies the parent table referenced by the FOREIGN KEY clause. ON DELETE tells the XDB Server how to handle dependent records in the referencing table when an attempt is made to delete a referenced record in the parent table. The RESTRICT option (default) prevents the referenced record from being deleted from the parent table.

The CASCADE option deletes the dependent records from the referencing table, and also deletes the parent record. The SET NULL option causes the FOREIGN KEY data values in the dependent records to be set to NULL before the parent record is deleted.

search-condition | Represents any search condition, except a join condition or a subselect.

Description

In XDB mode, only one optional clause can be included in any ALTER TABLE statement. For example, one ALTER TABLE command might ADD one or more columns, while another ALTER TABLE command could DELETE one or more columns. In DB2 mode, multiple clauses can be included in each ALTER TABLE statement, as long as the same clause is not specified more than once. Information contained in the VALIDPROC, AUDIT and DATA CAPTURE clauses is recorded in the XDB Server catalog tables for the current location, but is not otherwise used by the XDB Server. These clauses are operational when used against a DB2 database through XDB Link.

ALTER COLUMN column-alteration

Alters the definition of an existing column, including the attributes of an existing identity column. Only the attributes specified are altered. Other attributes remain unchanged. Only future values of the column are affected by the changes made with an ALTER TABLE ALTER COLUMN statement.

The table being altered must not be in an incomplete state because of a missing unique index on a unique constraint (primary or unique key). A column can only be referenced once in an ALTER COLUMN clause in a single ALTER TABLE statement. However, that same column can be referenced multiple times for adding or dropping constraints in the same ALTER TABLE statement. An ALTER TABLE ALTER COLUMN statement may not be processed in the same unit of work as an INSERT, DELETE, or UPDATE statement. A column cannot be altered if the table is used in a materialized query table definition or if the table is a materialized query table.

You can modify all the attributes of an existing identity column, except for the data type of the column. To change the data type of an identity column, drop the table containing the column and recreate it.

column-name Identifies the column to be altered. The name must not be qualified and must identify an existing column in the table being altered when the ALTER statement is processed. The column must not be part of a referential constraint or have a field procedure. The column must not be defined as a security label column. When the attributes of an identity column are altered, the column of the specified column-name must exist in the specified table and must have been defined with the IDENTITY attribute.
SET DATA TYPE (altered-data-type) Specifies the new data type of the column to be altered. For a character or CLOB column, you can also use the clause to change the definition of the subtype that is stored in the XDB catalog and OBD.The column cannot be an identity column. The new data type must be compatible with the existing data type of the column. The existing data type of the column cannot be a ROWID, LOB, date, time, timestamp, or distinct type.

If the data type is a character or graphic string, the new length attribute must be at least as large as the existing length attribute of the column. If the data type is a numeric data type, the specified precision and scale must be at least as large as the existing precision and scale. If a decimal fraction is being converted to floating point, the ALTER statement will fail if there is a unique index or a unique constraint on the column.

If the specified column has a default value, the existing default value must represent a value that could be assigned to a column with the new data type in accordance with the rules for assignment. The default value is updated to reflect the new data type.

If the column is specified in a unique constraint (unique key or primary key) or unique index, the new column length must not exceed the limit on an index size. For PADDED indexes, the sum of the length attributes of the columns must not be greater than 2000-n, where n is the number of columns that can contain null values. For NOT PADDED indexes, the sum of the length attributes of the columns must not be greater than 2000-n-2m, where n is the number of nullable columns and m is the number of varying length columns.

The total byte count of columns after the alteration must not exceed the maximum row size. If the column is in the partitioning key, the new partitioning key cannot exceed 255-n.

The following numeric data type alterations are supported for SET DATA TYPE:

The following character data type alterations are supported for SET DATA TYPE:

When columns are converted from CHAR to VARCHAR, normal assignment rules apply, which means that trailing blanks are kept instead of being stripped out. If you want varying length character strings without trailing blanks, use the STRIP function for data in the column after changing the data type to VARCHAR.

If the table being altered has an edit procedure or valid procedure, an error occurs. If a materialized query table is defined on this table or if this table is defined as being a materialized query table, then an error also occurs.

The table space that contains the table being altered is left in an advisory REORG-pending (AREO) status. If the column being altered is part of an index, an exception state may be set for the index as shown in the table below:

The length of more than one column can be changed in a single ALTER TABLE statement if each ALTER COLUMN clause identifies a unique column of the table. The ALTER COLUMN clause and ADD CHECK CONSTRAINT clause can identify the same column.

ADD column-definition

Adds a column to the table. Except for a ROWID column and an identity column, all values of the column in existing rows are set to its default value. If the table has n columns, the ordinality of the new column is n+1. The value of n cannot be greater than 749. For a dependent table, n cannot be greater than 748.

The column cannot be added if the increase in the total byte count of the columns exceeds the maximum row size. The maximum row size for the table is eight less than the maximum record size. A column also cannot be added to a table that has an edit procedure.

If you add a LOB column and the table does not already have a ROWID column, XDB creates a hidden ROWID column. You cannot add a LOB or ROWID column to a created temporary table.

You cannot add an identity column to a table that has an identity column or to a created temporary table.

column-name | Is the name of the column you want to add to the table. Do not use the name of an existing column of the table. Do not qualify column-name.
built-in-data-type | Specifies the data type of the column is one of the built-in data types.
distinct-type-name | Specifies the distinct type (user-defined data type) of the column. User-defined data types are not yet supported by the XDB Server operating environment.

NOT NULL

Prevents the column from containing null values. If NOT NULL is specified, the DEFAULT clause must be used to specify a nonnull default value for the column unless the column has a row ID data type or is an identity column. For a ROWID column, NOT NULL must be specified, and DEFAULT must not be specified. For an identity column, although NOT NULL can be specified, DEFAULT must not be specified

For example, the ALTER statement below adds three new data columns to the SUPPLIER table:

ALTER TABLE supplier
    ADD state CHAR 2, zip CHAR 5,
        founded DATE NOT NULL WITH DEFAULT

To disallow NULL values in a new column, first add data to the column, and then issue another ALTER TABLE statement with the MODIFY clause to specify the column as NOT NULL.

DEFAULT

The default value assigned to the column in the absence of a value specified on INSERT or LOAD. Do not specify DEFAULT for a ROWID column, an identity column (a column that is defined AS IDENTITY) or a security label column (a column that is defined AS SECURITY LABEL); XDB generates default values. If a value is not specified after the DEFAULT keyword and the column is not nullable, the default value depends on the data type of the column.

Data Type | Default Value
numeric | 0
date | current date
time | current time
timestamp | current date and time
character | Blanks
Varchar | Blanks
graphic | Blanks

For example, if you want to record the identity of anyone inserting rows into a table, define the table with two additional columns:

PRIMARY_ID

CHAR(8)

WITH DEFAULT USER,

SQL_ID

CHAR(8)

WITH DEFAULT CURRENT SQLID,

You can allow updates and inserts to the table only through a view that omits those columns. Then, the primary authorization ID and the SQLID of the process are added by default.

constant

Specifies a constant as the default value for the column. The value of the constant must conform to the rules for assigning that value to the column.

A character or string constant must be short enough so that its UTF-8 representation requires no more than 1536 bytes. In addition, a hexadecimal graphic string (GX) constant cannot be specified.

USER

Specifies the value of the USER special register at the time of INSERT or LOAD as the default for the column. If USER is specified, the data type of the column must be a character string with a length greater than or equal to the length attribute of the USER special register. For existing rows, the value is that of the USER special register at the time the ALTER TABLE statement is processed.

CURRENT SQLID

Specifies the value of the SQL authorization ID of the process at the time of INSERT or LOAD as the default for the column. If CURRENT SQLID is specified, the data type of the column must be a character string with a length greater than or equal to the length attribute of the CURRENT SQLID special register. For existing rows, the value is the SQL authorization ID of the process at the time the ALTER TABLE statement is processed.

NULL

Specifies null as the default value for the column.

cast-function-name

The XDB Server operating environment does not currently provide this functionality.

GENERATED

Indicates that XDB generates values for the column. GENERATED is applicable only to ROWID columns and identity columns. If the data type of the column is a ROWID (or a distinct type that is based on a ROWID), the default is GENERATED ALWAYS.

ALWAYS Indicates that XDB will generate a value for the column when a row is inserted into the table. ALWAYS is the recommended value unless you are using data propagation.

If you specify ALWAYS, you must not specify a value for the column when a row is inserted into the table. Also, you cannot update the value of the column

BY DEFAULT Indicates that XDB will generate a value for the column when a row is inserted unless a value is specified.into the table only if a value is not specified. Otherwise, XDB uses the value that you specify.

For a ROWID column, XDB uses a specified value only if it is a valid row ID value that was previously generated by XDB and the column has a unique, single-column index. Until this index is created on the ROWID column, the SQL INSERT statement and the LOAD utility cannot be used to add rows to the table. If the value of special register CURRENT RULES is 'STD' when the ALTER TABLE statement is processed, XDB implicitly creates the index on the ROWID column. The name of this index is 'I' followed by the first ten characters of the column name followed by seven randomly generated characters. If the column name is less than ten characters, XDB adds underscore characters to the end of the name until it has ten characters. The implicitly created index has the COPY NO attribute.

For an identity column, XDB inserts a specified value but does not verify that it is a unique value for the column unless the identity column has a unique, single-column index; without a unique index, XDB can guarantee unique values only among the set of system-generated values.

BY DEFAULT is the recommended value only when you are using data propagation.

AS SECURITY LABEL

Indicates that the table is defined with multilevel security with row level granularity and specifies that the column will contain the security label values. A table can have only one security label column. To define a table with a security label column, the primary authorization ID of the statement must have a valid security label, and the RACF SECLABEL class must be active. In addition, the following conditions are also required:

  • The data type of the column must be CHAR(8).
  • The subtype of the column must be SBCS.
  • The column does not have any field procedures, check constraints, or referential constraints.
  • The column must be defined as NOT NULL and WITH DEFAULT clauses.
  • The table does not have an edit procedure.
  • The table is not the source table for a materialized query table.
  • You are using z/OS Version 1 Release 5 or later.

For existing rows in the table, the value of the security label column defaults to the security label of the user at the time the ALTER statement is executed.

AS IDENTITY

Specifies that the column is an identity column for the table. A table can have only one identity column. AS IDENTITY can be specified only if the data type for the column is an exact numeric type with a scale of zero (SMALLINT, INTEGER, DECIMAL with a scale of zero, or a distinct type based on one of these types). Separator commas between identity column attribute specifications are optional when the identity column is defined.

An identity column is implicitly NOT NULL. When adding an identity column to a table, you must also specify GENERATED ALWAYS or GENERATED BY DEFAULT.

START WITH numeric-constant | Specifies the first value for the identity column. The value can be any positive or negative value that could be assigned to the column without non-zero digits exisitng to the right of the decimal point. The default is 1.
INCREMENT BY numeric-constant | Specifies the interval between consecutive values of the identity column. The value can be any positive or negative value (including 0) that does not exceed the value of a large integer constant and could be assigned to the column without any non-zero digits existing to the right of the decimal point. The default is 1. If the value is positive, the sequence of values for the identity column ascends. If the value is negative, the sequence of values descends.

MINVALUE or NO MINVALUE

Specifies the minimum value at which a descending identity column either cycles or stops generating values or an ascending identity column cycles to after reaching the maximum value.

NO MINVALUE

Specifies that the minimum end point of the range of values for the identity column has not been specified explicitly. In such a case, the value for MINVALUE becomes one of the following:

  • For an ascending identity column, the value is the START WITH value or 1 if START WITH was not specified.
  • For a descending identity column, the value is the minimum value of the data type of the column.

MINVALUE numeric-constant

Specifies the numeric constant that is the minimum value that is generated for this identity column. This value can be any positive or negative value that could be assigned to this column without non-zero digits existing to the right of the decimal point. The value must be less than or equal to the maximum value.

MAXVALUE or NO MAXVALUE

Specifies the maximum value at which a ascending identity column either cycles or stops generating values or a descending identity column cycles to after reaching the minimum value.

NO MAXVALUE

Specifies that the minimum end point of the range of values for the identity column has not be set. In such a case, the default value for MAXVALUE becomes one of the following:

  • For an ascending identity column, the value is the maximum value of the data type of the column.
  • For a descending identity column, the value is the START WITH value or -1 if START WITH is not specified.

MAXVALUE numeric-constant

Specifies the numeric constant that is the maximum value that is generated for this identity column. This value can be any positive or negative value that could be assigned to this column without non-zero digits existing to the right of the decimal point. The value must be greater than or equal to the minimum value.

NO CYCLE or CYCLE

Specifies whether this identity column should continue to generate values after reaching either its maximum or minimum value.

NO CYCLE

Specifies that values will not be generated for the identity column after the maximum or minimum value has been reached. This is the default.

CYCLE

Specifies that values continue to be generated for this column after the maximum or minimum value has been reached. If this option is used, after an ascending identity column reaches the maximum value, it generates its minimum value. After a descending identity column reaches its minimum value, it generates its maximum value. The maximum and minimum values for the identity column determine the range that is used for cycling.

When CYCLE is in effect, duplicate values can be generated by XDB for an identity column. However, if a unique index exists on the identity column and a non-unique value is generated for it, an error occurs.

CACHE or NO CACHE

This clause has no functional equivalent in the XDB Server operating environment.

NO ORDER or ORDER

Specifies whether the sequence numbers must be generated in order of request.

NO ORDER

Specifies that the values do not need to be generated in order of request.

ORDER

Specifies that the values are generated in order of request. Specifying ORDER may disable the caching of values. ORDER applies only to a single-application process.

In a data sharing environment, if the CACHE and NO ORDER options are in effect, multiple caches can be active simultaneously, and the requests for identity values from different XDB members may not result in the assignment of values in strict numeric order. For example, if members DB2A and DB2B are using the identity column, and DB2A gets the cache values 1 to 20 and DB2B gets the cache values 21 to 40, the actual order of values assigned would be 1,21,2 if DB2A requested a value first, then DB2B requested, and then DB2A again requested. Therefore, to guarantee that identity values are generated in strict numeric order among multiple XDB members using the same identity column, specify the ORDER option.

REFERENCES

The references portion of the referential-constraint clause is a separate clause. A single column can be identified as a foreign key of a referential constraint by using the references-clause in a column definition.

Do not specify references-clause in the definition of a LOB, ROWID column, or security label column because a LOB, ROWID, or security label column cannot be a foreign key.

The parent key of the referential constraint is composed of the identified columns. The identified column cannot be a LOB, ROWID, or security label column. The same column must not be identified more than once.

Define a key that consists of more than one column by listing the column names. A foreign key can reference a unique key or a primary key. When a foreign key refers to a nonprimary unique key, you must specify the columns of the key.

If the foreign key includes a column defined as a distinct type, the corresponding column of the nominated parent key must be the same distinct type. If a column of the foreign key has a field procedure, the corresponding column of the nominated parent key must have the same field procedure and an identical field description. A field description is a description of the encoded value as it is stored in the database for a column that has been defined to have an associated field procedure.

ENFORCED or NOT ENFORCED

Indicates whether or not the referential constraint is enforced by the database manager during normal operations, such as insert, update, or delete.

ENFORCED

Specifies that the referential constraint is enforced by the database manager during normal operations (such as insert, update, or delete) and that it is guaranteed to be correct. This is the default.

NOT ENFORCED

Specifies that the referential constraint is not enforced by the database manager during normal operations, such as insert, update, or delete. This option should only be used when the data that is stored in the table is verified to conform to the constraint by some other method than relying on the database manager.

ENABLE QUERY OPTIMIZATION

Specifies that the constraint can be used for query optimization. XDB uses the information in query optimization using materialized query tables with the assumption that the constraint is correct. This is the default.

ADD RESTRICT ON DROP

Indicates that the table cannot be dropped. Also, the database and table space that contain the table cannot be dropped.

DROP RESTRICT ON DROP

Removes the restriction on dropping the table and the database and table space that contain the table.

CONSTRAINT

Names a table check constraint. If a constraint-name is not specified, a unique constraint name is derived from the name of the first column in the check-condition specified in the definition of the table check constraint.

Do not specify a check constraint in the definition of a LOB, ROWID, or security label column.

DROP CONSTRAINT

Drops the constraint constraint-name. The constraint-name must identify an existing check constraint or referential constraint defined on the table.

CHECK

Table check constraints can be defined on individual columns within both the CREATE TABLE and ALTER TABLE command statements. The check constraint is the check condition that defines the values that designated columns of the table can contain.

Do not specify a table check constraint in the definition of a ROWID column.

ADD PARTITION

Specifies that a partition is added to the table and each partitioned index on the table. The new partition is the next physical partition not being used until the maximum for the table space has been reached. ADD PARTITION must not be specified for nonpartitioned tables. If the table uses index-controlled partitioning, it is converted to use table-controlled partitioning.

The maximum number of partitions allowed depends on how the table space was originally created. If DSSIZE was specified when the table space was created, it is non-zero in the catalog. The maximum number of partitions allowed is shown in the following table.

DSSIZE | Page size 4Kb | Page size 8 Kb | Page size 16 Kb | Page size 32 Kb
1-4 Gb | 4096 | 4096 | 4096 | 4096
8 Gb | 2048 | 4096 | 4096 | 4096
16 Gb | 1024 | 2048 | 4096 | 4096
32 Gb | 512 | 1024 | 2048 | 4096
64 Gb | 256 | 512 | 1024 | 4096

If LARGE was specified when the table space was created, the maximum number of partitions is shown in the fourth row of the following table. For more than 254 partitions when LARGE or DSSIZE is not specified, the maximum number of partitions is determined by the page size of the table space.

Type of table space | Number of existing partitions | Maximum partitions
non-large | 1-16 | 16
non-large | 17-32 | 32
non-large | 33-64 | 64
large | N/A | 4096

The existing table space PRIQTY and SECQTY attributes of the previous logical partition are used for the space attributes of the new partition. For each partitioned index, the existing PRIQTY and SECQTY attributes of the previous partition are used.

To specify specific space attributes for the new partition, use additional ALTER TABLESPACE and ALTER INDEX statements.

Adding a partition is not allowed if the table is a materialized query table or a materialized query table is defined on the table. A partition cannot be added if the table space definition is incomplete because a partitioning key or partitioning index is missing.

This clause is only implemented syntactically in the XDB Server operating environment.

ENDING AT(constant, ...)

Specifies the high key limit for the new partition. The new partition's key limit must be higher when partitioning is ascending and lower when it is descending. Specify at least one constant after ENDING AT in the PARTITION clause. You can use as many values as there are columns in the key. The concatenation of all the constants is the highest value of the key in the corresponding partition of the index. The use of constants to define key values is subject to the following rules:

  • The first constant corresponds to the first column of the key, the second constant to the second column, and so on. Each constant must have the same data type as its corresponding column. A hexadecimal graphic string constant (GX) cannot be specified.

    Using fewer constants than there are columns in the key has the same effect as using the highest or lowest values for the omitted columns, depending on whether they are ascending or descending.

  • The highest value of the key in any partition must be lower than the highest value of the key in the next partition.
  • The constants specified for the last partition are enforced. The value specified for the last partition is the highest value of the key that can be placed in the table. If the limit was not previously enforced, any existing key values greater than the value specified for the added partition are placed into the discard data set when REORG is run.
  • The precision and scale of a decimal constant must not be greater than the precision and scale of its corresponding column.
  • If a string constant is longer or shorter than required by the length attribute of its column, the constant is either truncated or padded on the right to the required length. If the column is ascending, the padding character is X'FF'. If the column is descending, the padding character is X'00'.
  • If a key includes a ROWID column or a column with a distinct type that is based on a ROWID data type, then 17 bytes of the constant that is specified for the corresponding ROWID column are considered.

INCLUSIVE

Specifies that the specified range values are included in the data partition.

ADD PARTITION BY RANGE

Specifies the range partitioning scheme for the table (the columns used to partition the data). When this clause is specified, the table uses table-controlled partitioning. The number of partitions specified in the ADD PARTITION BY RANGE clause has to be the same as the number of partitions defined in the table space.

This clause applies only to tables in a partitioned table space. If the table is already complete by having established either table-controlled partitioning or index-controlled partitioning, the ADD PARTITION BY RANGE clause is not allowed. If this clause is used, then the ENDING AT clause cannot be used on a subsequent CREATE INDEX statement for this table.

This clause is only implemented syntactically in the XDB Server operating environment.

partition-expression

Specifies the key data over which the range is defined to determine the target data partition of the data.

column-name

Specifies the columns of the key. Each column-name must identify a column of the table. Do not specify more than 64 columns, the same column more than once, a LOB column, a column with a distinct type that is based on a LOB data type, or a qualified column name. The sum of length attributes of the columns must not be greater than 255 - n, where n is the number of columns that can contain null values.

NULLS LAST

Specifies that null values are treated as positive infinity for purposes of comparison.

ASC

Puts the entries in ascending order by the column. ASC is the default.

DESC

Puts the entries in descending order by the column.

partition-element

Specifies ranges for a data partitioning key and the table space where rows of the table in the range will be stored.

PARTITION integer

Identifies the partition to apply the boundary specified in the subsequent ENDING AT clause. It must be in the range of 1 to n where n is the number of partitions in the table.

ENDING AT(constant, ...)

Specifies the highest value of the partitioning key for the new partition. Specify at least one constant after ENDING AT in each PARTITION clause. You can use as many constants as there are columns in the key. The concatenation of all the constants is the highest value of the key in the corresponding partition. The length of each highest key value (the limit key) is the same as the length of the partitioning key. The use of constants to define key values is subject to the rules listed for the ENDING AT clause for a partition definition.

INCLUSIVE

Specifies that the specified range values are included in the data partition.

ALTER PARTITION

Specifies that the partitioning limit key for the identified partition is to be altered. Specify ALTER PARTITION only if the table is partitioned.

This clause applies only to tables in a partitioned table space. If the table is already complete by having established either table-controlled partitioning or index-controlled partitioning, the ADD PARTITION BY RANGE clause is not allowed. If this clause is used, then the ENDING AT clause cannot be used on a subsequent CREATE INDEX statement for this table.

This clause is only implemented syntactically in the XDB Server operating environment.

integer

If integer is specified, it must be in the range 1 to n, where n is the number of partitions in the table. Altering a partition boundary is not allowed if the table is a materialized query table or if a materialized query table is defined on this table. When this option is specified for any partition except for the last, both the identified partition and the partition following are placed in REORG-pending (REORP) status.

ENDING AT(constant, ...)

Specifies the highest value of the partitioning key for the identified partition.

In this context, highest means highest in the sorting sequences of the columns. In a column defined as ascending (ASC), highest and lowest have their usual meanings. In a column defined as descending (DESC) the lowest actual value is highest in the sorting sequence.

Specify at least one constant after ENDING AT in each ALTER PARTITION clause. You can use as many constants as there are columns in the key. The concatenation of all the constants is the highest value of the key in the corresponding partition. The length of each highest key value (the limit key) is the same as the length of the partitioning key. The use of constants to define key values is subject to the rules listed for the ENDING AT clause for a partition definition. The value that is specified must not be equal to or beyond the range of the partition boundaries of the adjacent partitions.

INCLUSIVE

Specifies that the specified range values are included in the data partition.

If the table uses index-controlled partitioning, it is converted to use table-controlled partitioning. The high limit key for the last partition is set to the highest possible value for ascending key columns or the lowest possible value for descending key columns.

ROTATE PARTITION FIRST TO LAST

Specifies that the first logical partition should be rotated to become the last logical partition. This keyword must be followed by the ENDING AT clause, which specifies the new high key limit for this partition, which is now logically last. The new partitioning key value must be higher than the current high key limit if partition values are ascending. If partition values are descending, the new key limit must be lower than the current low key limit.

Rotating a partition occurs immediately. If there is a referential constraint with DELETE RESTRICT on the table, the ROTATE might fail. If the table uses index-controlled partitioning, it is converted to use table-controlled partitioning.

If the table has a security label column, the user must have a valid security label to rotate partitions. In addition, if write-down is in effect, the user must have the write-down privilege.

This clause is only implemented syntactically in the XDB Server operating environment.

ENDING AT(constant, ...)

The ENDING AT clause specifies the new high key limit for the existing partition holding the oldest data.

In this context, highest means highest in the sorting sequences of the columns. In a column defined as ascending (ASC), highest and lowest have their usual meanings. In a column defined as descending (DESC) the lowest actual value is highest in the sorting sequence.

Specify at least one constant after ENDING AT. You can use as many constants as there are columns in the key. The concatenation of all the constants is the highest value of the key in the corresponding partition. The length of each highest key value (the limit key) is the same as the length of the partitioning key. The use of constants to define key values is subject to the rules listed for the ENDING AT clause for a partition definition.

INCLUSIVE

Specifies that the specified range values are included in the data partition.

RESET

Specifies that the existing data in the oldest partition is deleted. In a partitioned table with limit values that are in ascending sequence, ALTER TABLE ALTER PARTITION ROTATE FIRST TO LAST logically operates as if the partition with the lowest high key limit were dropped and then a new partition was added with the specified high key limit. The partition's new key limit must be higher than any other partition in the table. For descending limit keys, the rotation operates as the partition with the highest limit values becomes the partition with the lowest limit values.

If the partition contains referential integrity parent relationships, has DATA CAPTURE logging enabled, or has a delete row trigger, then each data row in the partition must be deleted individually. If a table does not have any of these attribute settings, then the data rows are removed by deleting and redefining the underlying data sets.

SYSCOPY and SYSLGRNGX rows associated with the partition being reset are deleted. This includes the rows for the table space partition, partitioned index partitions, LOB table spaces, and auxiliary indexes.

This clause is only implemented syntactically in the XDB Server operating environment.

ADD MATERIALIZED QUERY materialized-query-definition

Changes a base table to a materialized query table. Supplies a definition for a regular table to make it a materialized query table. The table specified by table-name and the result columns of the fullselect must not have the following characteristics:

  • Be already defined as a materialized query table
  • Have any primary keys, unique constraints (unique indexes), referential constraints (foreign keys), check constraints, or triggers defined
  • Be referenced in the definition of another materialized query table
  • Be directly or indirectly referenced in the fullselect
  • Be in an incomplete state

If table-name does not meet these criteria, an error occurs. fullselect defines the query on which the table is based. The columns of the existing table must meet the following characteristics:

  • Have the same number of columns
  • Have exactly the same column definitions
  • Have the same column names in the same ordinal positions

If fullselect is specified, the owner of the table being altered must have the SELECT privilege on the tables or views referenced in the fullselect. Having SELECT privilege means that the owner has at least one of the following authorizations:

  • Ownership of the tables or views referenced in the fullselect
  • The SELECT privilege on the tables and views referenced in the fullselect
  • SYSADM authority
  • DBADM authority for the database in which the table of the fullselect reside

If the owner of the table does not have the SELECT privilege, the following authorization IDs must have SYSADM authority or DBADM authority for the database in which the tables of the fullselect reside:

  • For embedded statements, the authorization ID of the owner of the plan or package
  • For dynamically prepared statements, the SQL authorization ID of the process

Altering a table to change it from a base table to a materialized query table with REFRESH DEFERRED causes any plans and packages dependent on the table to be invalidated.

This clause is only implemented syntactically in the XDB Server operating environment.

refreshable-table-options

Specifies the materialized query table options for altering a regular table to a materialized query table.

DATA INITIALLY DEFERRED

Specifies that the data in the table is not validated as part of the ALTER TABLE statement. A REFRESH TABLE statement can be used to make sure the data in the materialized query table is the same as the result of the query in which the table is based.

REFRESH DEFERRED

Specifies that the data in the table can be refreshed at any time using the REFRESH TABLE statement. The data in the table only reflects the result of the query as a snapshot at the time when the REFRESH TABLE statement is processed or as updated by the user for a user-maintained materialized query table.

MAINTAINED BY SYSTEM or MAINTAINED BY USER

Specifies how the data in the materialized query table is maintained.

MAINTAINED BY SYSTEM

Specifies that the data in the materialized query table table-name is to be maintained by the system. Only the REFRESH TABLE statement is allowed on the table.

MAINTAINED BY USER

Specifies that the data in materialized query table table-name is to be maintained by the user, who can use LOAD utility or the INSERT, DELETE, UPDATE, and REFRESH TABLE statements on the table.

ENABLE QUERY OPTIMIZATION or DISABLE QUERY OPTIMIZATION

Specifies whether this materialized query table can be used for optimization.

ENABLE QUERY OPTIMIZATION

Specifies that the materialized query table can be used for query optimization. If the fullselect specified does not satisfy the restrictions for query optimization, an error occurs.

DISABLE QUERY OPTIMIZATION

Specifies that the materialized query table cannot be used for query optimization. The table can still be queried directly.

DROP MATERIALIZED QUERY

Changes a materialized query table so that it is no longer considered a materialized query table. The table specified by table-name must be defined as a materialized query table. The definition of columns and data of the name are not changed, but the table can no longer be used for query optimization and is no longer valid for use with the REFRESH TABLE statement.

Altering a table to change from a materialized query table to a base table with the DROP MATERIALIZED QUERY clause causes any plans and packages dependent on the table to be invalidated.

This clause is only implemented syntactically in the XDB Server operating environment.

ALTER MATERIALIZED QUERY materialized-query-table-alteration

Changes attributes of a materialized query table. The table-name must identify a materialized query table.

This clause is only implemented syntactically in the XDB Server operating environment.

SET refreshable-table-alteration

Changes how the table is maintained or whether the table can be used in query optimization.

MAINTAINED BY SYSTEM

Specifies that the data in a materialized query table table-name is to be maintained by the system.

MAINTAINED BY USER

Specifies that the data in the materialized query table table-name is to be maintained by the user.

ENABLE QUERY OPTIMIZATION

Specifies that materialized query table table-name can be used in query optimization. If the fullselect specified for the materialized query table does not satisfy the restrictions for automatic query optimization, an error occurs.

DISABLE QUERY OPTIMIZATION

Specifies that materialized query table table-namecannot be used for query optimization. The table can still be queried directly.

DROP CHECK

Drops the check constraint constraint-name. The constraint-name must identify an existing check constraint defined on the table.

DELETE

This clause (available in XDB mode only) deletes one or more data columns from an existing table, by listing the column names (separated by commas) after the DELETE keyword. The corresponding field values are actually removed from each record in the table; all data values in the deleted columns are lost. The ALTER TABLE statement below removes the three columns that were added in the ADD example shown above:

ALTER TABLE supplier
    DELETE state, zip, founded

RENAME

This clause (available in XDB mode only) renames one or more existing columns within an existing table. For each column to be renamed, list the old-column-name, a space, followed by the new-column-name. If more than one column needs renaming, separate the pairs of old and new names with commas.

For example:

ALTER TABLE supplier
    RENAME sno Supplier_No, sname Supplier_Name

MODIFY

This clause (available in XDB mode only) changes the data type or null permission for one or more existing table columns. The new data type must be compatible with the old data type, with conversion being performed whenever possible. The following example changes the character length of the STATUS and CITY columns:

ALTER TABLE supplier
    MODIFY status CHAR 2, city CHAR 15

If the conversion cannot be performed because of incompatible data field types or possible loss of data, an error message is displayed. If a character field is not long enough to hold a string value, the string is truncated on the right.

The following table defines the data conversions permitted. The "Y" values indicate that the intersecting data types are compatible (meaning one type can be switched to the other). The "N" values indicate that the intersecting data types are not compatible.

From/To | small- int | int | float | float4 | dec | Money | date | time | Time- stamp | char | vchar (See note 1) | graph | vgraph (See note 2)
smallint | Y | Y | Y | Y | Y | Y | N | N | N | Y | Y | Y | Y
integer | Y | Y | Y | Y | Y | Y | N | N | N | Y | Y | Y | Y
float | Y | Y | Y | Y | Y | Y | N | N | N | Y | Y | Y | Y
float(4) | Y | Y | Y | Y | Y | Y | N | N | N | Y | Y | Y | Y
decimal | Y | Y | Y | Y | Y | Y | N | N | N | Y | Y | Y | Y
money | Y | Y | Y | Y | Y | Y | N | N | N | Y | Y | Y | Y
date | N | N | N | N | N | N | Y | N | Y | Y | Y | Y | Y
time | N | N | N | N | N | N | N | Y | Y | Y | Y | Y | Y
timestamp | N | N | N | N | N | Y | Y | Y | Y | Y | Y | Y | Y
char | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y
varchar | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y
graphic | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y
vargraph | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y | Y
image | This BLOB data type cannot be modified within SQL.
Note:
  • Varchar and Long Varchar are treated the same way for data type conversions.
  • Vargraphic and Long Vargraphic are treated the same way for data type conversions.

In addition to changing data types and null permissions, the MODIFY clause can change character string lengths, along with decimal scale and precision. For example, to change the length of the column named SNAME in the SUPPLIER table to ten characters, enter the following command:

ALTER TABLE supplier
    MODIFY sname CHAR 10

Note that the length of INT and MONEY column fields cannot be changed. To increase the length of a SMALLINT field, change it to INT type. You can also change numeric field types to DECIMAL or FLOAT if you need to accommodate larger numbers.

The MODIFY option can also specify whether or not null values are permitted in a column. The NULL or NOT NULL keywords should appear after the name and data type specifications of the data column. Use the NULL keyword to permit null values in the data column, and the NOT NULL keywords to restrict null values in the column. Use the NOT NULL WITH DEFAULT option to insert default data values in place of null values (current time, current date, zero, etc.).

An error message is displayed if a MODIFY clause attempts to change a data column containing NULL values to NOT NULL. If a null option is not specified in the ALTER TABLE command, no change is made to the null permission currently defined for that column. For example, if the SNO column in the SUPPLIER table was originally defined as "sno CHAR(4)," you can change the null permission to prevent entry of null values using the following command. Note that the data type must be specified, even though it is not changed:

ALTER TABLE supplier
    MODIFY sno char(4) NOT NULL

You can change both field length and null permission to permit nulls by entering:

ALTER TABLE supplier
    MODIFY sno CHAR(6) NULL

UNIQUE KEY

Defines a unique key composed of the identified columns with the specified constraint-name. If a constraint-name is not specified, a name is generated. Each column name must be an unqualified name that identifies a column of the table except a LOB or ROWID column, and the same column must not be identified more than once. Each identified column must be defined as NOT NULL. The number of identified columns must not exceed 64. In addition, the sum of the length attributes of the columns must not be greater than 2000 - n for padded indexes and 2000 - n - 2m for nonpadded indexes, where n is the number of columns that can contain null values and m is the number of varying-length columns in the key.

Note:

The various domain and referential constraints discussed in these paragraphs utilize indexes in the background to implement the checks efficiently.

When key-name refers to a unique index created on a parent table (other than the PRIMARY KEY), or when the key-name optionally appears after the referenced-table parameter in the REFERENCES clause of an ADD FOREIGN KEY clause (XDB mode only), that special type of unique index can also be referred to as a candidate-key.

The example below creates a unique index named pskey that constrains each row of the PARTSUPP table to contain a unique set of values in the PNO and SNO columns:

ALTER TABLE partsupp
    UNIQUE KEY pskey (pno, sno)

When the ALTER TABLE...UNIQUE command is issued, the system checks the table to verify whether there are duplicate values in the specified columns. The system creates and maintains a unique index called pskey on the named columns. The index created as a result of a uniqueness constraint cannot be dropped using the DROP INDEX command, since it is required to enforce the uniqueness constraint. To drop the index you must drop the uniqueness constraint.

PRIMARY KEY

The purpose of the primary key is to enforce entity integrity -- that is, to uniquely identify each row of a table. A PRIMARY KEY constraint is similar to a UNIQUE constraint, except that a table can have at most one constraint condition specified as a PRIMARY KEY.

Note that the fields in the primary key must be defined as NOT NULL. The column names must appear in the CREATE UNIQUE INDEX command in exactly the same order as in the PRIMARY KEY constraint. This index will be designated as the primary key of the table. If there is more than one index that satisfies the criteria for a primary key, one is selected arbitrarily as the primary key.

For example, to define columns PNO and SNO as the primary key of the PARTSUPP, use the command:

ALTER TABLE partsupp
    PRIMARY KEY (pno, sno)

To define the column SNO as the primary key of the SUPPLIER table, use a command like:

ALTER TABLE supplier
    PRIMARY KEY (sno)

Again, a unique index must exist on the SUPPLIER table SNO column.

Each column name must be an unqualified name that identifies a column of the table except a LOB or ROWID column, and the same column must not be identified more than once. The number of identified columns must not exceed 64. In addition, the sum of the length attributes of the columns must not be greater than 2000 -2m, where m is the number of varying-length columns in the key. The table must not have a primary key and the identified columns must be defined as NOT NULL.

FOREIGN KEY

A FOREIGN KEY constraint is used to enforce referential integrity -- the relationship between a referencing or dependent table and a referenced or parent table. The referential integrity rule requires that, for any value in the dependent column(s), there must exist a row in the parent table such that the value of the dependent column(s) equals the value of the corresponding column(s) in the primary key of the parent table. This is enforced as follows:

  1. When an update or insert is performed on the dependent table, the set of values placed in the referencing columns must match a set of values that exists in the parent table.
  2. If an attempt is made to delete or update a row of the parent table that contains values matching those in a dependent table, the system uses the ON DELETE (or ON UPDATE) clause to determine the delete rule to be used. The options are:
    • RESTRICT

      Prevents records from being deleted from the parent table if dependents exist. This is the default setting.

    • NO ACTION

      Prevents records from being deleted from the parent table (as in the RESTRICT option), except the referential constraint is enforced at the end of the statement. This is the default setting if the CURRENT RULES special register is STD (SQL standard).

    • CASCADE

      Deletes the dependent records from the current table and then deletes the parent records.

    • SET NULL

      Causes each nullable column in the foreign key of each dependent record to be set to NULL before the corresponding parent records are deleted.

Note that whenever a cyclical situation exists (for example a foreign key of table B references the primary key of table A, and a foreign key of table A references a primary key of table B), the delete rules should be the same for all foreign keys, and the SET NULL option should not be used.

To create a referential integrity constraint you must create a FOREIGN KEY constraint on the referencing table. The FOREIGN KEY constraint must reference the existing PRIMARY KEY or UNIQUE KEY of the referenced table.

FOREIGN KEY columns do not have to have the same names as the corresponding columns in the PRIMARY KEY of the referenced table, but the columns must match in type, number and order.

A constraint-name is used to uniquely identify the FOREIGN KEY constraint. The constraint-name should be a short identifier (up to eight characters) that is unique among all constraints built on the table. The constraint-name is stored in the RELNAME column of the SYSIBM.SYSFOREIGNKEYS catalog table, and is displayed in the error message generated when the constraint is violated.

It is a good practice to provide a meaningful constraint-name, however, if a constraint-name is not supplied, the system automatically generates one by first checking the first eight characters of the first column name (in the column list) for uniqueness. If these eight characters are not unique, the XDB Server truncates the last character and substitutes a number -- checking again for uniqueness. If necessary, one letter at a time is removed from the end of the constraint name and replaced with a number until the constraint name becomes unique among all constraint names that exist on the table.

The foreign key of the referential constraint is composed of the identified columns. Each column-name must be an unqualified name that identifies a column of T1 except a ROWID column or security label column, and the same column must not be identified more than once. The number of identified columns must not exceed 64 and the sum of their length attributes must not exceed 255 minus the number of columns that allow null values. The referential constraint is a duplicate if the FOREIGN KEY and the parent table are the same as the FOREIGN KEY and parent table of an existing referential constraint on T1. The specification of a duplicate referential constraint is ignored with a warning.

Indexes on Foreign Keys

The XDB Server automatically builds an index on your FOREIGN KEY columns. The system will generate the name of the index and store it in the REFKEYNAME column of theSYSIBM.SYSREF catalog table. DB2, in contrast, does not automatically create an index on FOREIGN KEY columns.

If you are using your DB2 data definition language (DDL) script, and this script contains CREATE INDEX commands on FOREIGN KEY columns, you can end up with redundant indexes. For optimal performance, you should modify your DB2 DDL script to remove any CREATE INDEX commands on FOREIGN KEY columns.

To demonstrate the use of a FOREIGN KEY constraint, consider the SUPPLIER and PARTSUPP tables (see XDB Server Tutorial Location). There should not be any values in the SNO column of the PARTSUPP table that do not appear in the SUPPLIER table, since you cannot order from a supplier that does not exist. To enforce this rule, a PRIMARY KEY is built on the SNO column of the SUPPLIER table. Next a FOREIGN KEY constraint is built on the SNO column of the PARTSUPP table. The PARTSUPP table is the referencing table and the SUPPLIER table is the referenced table. The example below adds a foreign key constraint named ps_fkey to the PARTSUPP table:

ALTER TABLE partsupp
    FOREIGN KEY ps_fkey (sno)
    REFERENCES supplier

If an attempt is made to remove a supplier from the SUPPLIER table, it will be permitted only if there are no matching records in the PARTSUPP table. It is possible, therefore, to delete the row where SNO equals S5, since supplier S5 supplies no parts. But the row where SNO equals S1 cannot be deleted, since supplier S1 supplies many parts. Each matching record in the PARTSUPP table must be deleted before the S1 record could be deleted from the SUPPLIER table.

If the command was specified using the ON DELETE CASCADE option, as shown below, the SUPPLIER record S5 could be deleted, but all PARTSUPP records for S5 would also be deleted.

ALTER TABLE partsupp
    FOREIGN KEY ps_fkey (sno)
    REFERENCES supplier
    ON DELETE CASCADE

CHECK

In XDB mode, you can also add a CHECK constraint to a table, consisting of a search condition that must be true for every row of the table. If an attempt is made to update or insert a row that does not satisfy the search condition, an error results. Any SQL search condition can be used. CHECK conditions are stored in the SYSIBM.SYSCHECK table (see XDB Server System Tables).

Note:

The system does not check the data currently in the table to verify whether it satisfies the CHECK constraint. You should delete or update the rows that violate the constraint before issuing the ALTER TABLE...CHECK statement.

For example, to impose the constraint that no part be supplied in quantities greater than 500, use the following ALTER TABLE statement:

ALTER TABLE partsupp
    CHECK qty <= 500

A CHECK constraint may be a compound condition. For example, you may issue the command:

ALTER TABLE employee
    CHECK (payrate <= 20
           AND hours <= 60
           AND dept = 2020)
           OR (payrate <= 25
               AND hours <= 40
               AND dept = 1050)

This constraint always checks to verify that employees in Department 2020 are not paid more than $20.00 an hour, and do not work more than 60 hours a week. On the other hand, employees in department 1050 cannot receive pay greater than $25.00 an hour or work more than 40 hours a week.

You may use nested queries and nested joins in the CHECK condition, if desired.

DROP

This option is used to drop uniqueness, referential or check constraints. If no constraint is found, the command has no effect.

For example, to drop the PRIMARY KEY on the employee table, issue the statement:

ALTER TABLE employee
    DROP PRIMARY KEY

To drop a UNIQUE KEY named ps_key on the PARTSUPP table columns SNO and PNO, issue the statement:

ALTER TABLE partsupp
    DROP KEY ps_key

To drop a FOREIGN KEY constraint called ps_fkey on the PARTSUPP table, issue the statement:

ALTER TABLE partsupp
    DROP FOREIGN KEY ps_fkey

To drop a CHECK constraint on the PARTSUPP table, issue the statement:

ALTER TABLE partsupp
    DROP CHECK
Note:

When using ALTER TABLE, there are restrictions for adding columns. You cannot add:

  • A column to a table that has an edit procedure
  • A ROWID column to a table that already has a ROWID column
  • An identity column to a table that already has an identity column
  • A ROWID, or identity column to a created temporary table

Adding a ROWID column

When you add a ROWID column to an existing table, XDB ensures that the same, unique row ID value is returned for a row whenever it is accessed. Reorganizing a table space has no effect on the values in a ROWID column.

Altering the length of a column

Only the length of VARCHAR columns can be changed. When changing the length of a column, be aware of the following information about indexes, limit keys, check constraints, and invalidation.

The length of a VARCHAR column cannot be changed if any of the following conditions are true:

  • The column is referenced in a referential constraint or view.
  • The column has a field procedure routine
  • The table has an edit or validation routine
  • The table is defined with DATA CAPTURE CHANGES
  • The table is a created temporary table

The XDB Server operating environment does not currently provide this functionality.

Indexes

After the ALTER TABLE statement is executed, each index on the table with a key that includes a column whose length was increased remains available. However, SQL operations against such an index are not allowed until the changes from the ALTER TABLE statement are committed.

The maximum number of distinct alters that increase the index key length is sixteen or less. If the maximum number of alters is exceeded, SQLCODE -148 is returned, and the index must be reorganized or rebuilt. An alter is considered distinct when it occurs in a different unit of work than the previous alter. For example, changing an index column length, committing database changes, and changing the column length of that index column or another index column counts as two distinct alters. Whereas, changing an index column length twice before committing any changes counts as one distinct alter; the second changes replace the first because it was in the same commit scope. Changing the length of two different index columns before committing the changes also counts as one distinct alter.

Check constraints

If a table check constraint refers to the column being altered, the length of the column is also changed in the check constraint.

Examples

Column DEPTNAME in table DSN8610.DEPT was created as a VARCHAR(36). Increase its length to 50 bytes. Also, add the column BLDG to the table DSN8610.DEPT. Describe the new column as a character string column that holds SBCS data.

 ALTER TABLE DSN8610.DEPT
   ALTER COLUMN DEPTNAME SET DATA TYPE VARCHAR(50)
   ADD BLDG CHAR(3) FOR SBCS DATA;

Assign a validation procedure named DSN8EAEM to the table DSN8610.EMP.

 ALTER TABLE DSN8610.EMP
   VALIDPROC DSN8EAEM;

Disassociate the current validation procedure from the table DSN8610.EMP. After the statement is executed, the table no longer has a validation procedure.

 ALTER TABLE DSN8610.EMP
   VALIDPROC NULL;

Define ADMRDEPT as the foreign key of a self-referencing constraint on DSN8610.DEPT.

 ALTER TABLE DSN8610.DEPT
   FOREIGN KEY(ADMRDEPT)
      REFERENCES DSN8610.DEPT ON DELETE CASCADE;

Add a check constraint to the table DSN8610.EMP which checks that the minimum salary an employee can have is $10,000.

 ALTER TABLE DSN8610.EMP
   ADD CHECK (SALARY >= 10000);

Alter the PRODINFO table to define a foreign key that references a non-primary unique key in the product version table (PRODVER_1). The columns of the unique key are VERNAME, RELNO.

 ALTER TABLE PRODINFO
   FOREIGN KEY (PRODNAME,PRODVERNO)
      REFERENCES PRODVER_1 (VERNAME,RELNO) ON DELETE RESTRICT;

The check pending status prevents further updating or reading by other SQL applications. It does not affect the application process that issues ALTER TABLE. However, we do not recommend that a process create or alter a permanent table and then access it.

Parent topic: SQL Statements


ALTER TABLESPACE

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

To execute the ALTER TABLESPACE command, users must possess either DBADM authority for the database, overall SYSADM or SYSCTRL authority for the location, or be the owner of the table space affected.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

ALTER TABLESPACE [database-name.]tablespace-name
    [BUFFERPOOL bpname]
    [CLOSE {YES | NO}]
    [DSETPASS password]
    [PART integer]
    [FREEPAGE integer]
    [PCTFREE integer]
    [USING {VCAT catalog-name | STOGROUP stogroup-name}]
    [PRIQTY integer]
    [SECQTY integer]
    [ERASE {YES | NO}]
    [COMPRESS {NO | YES}]
    [GBPCACHE {CHANGED | ALL | SYSTEM | NONE}]
    [LOCKMAX {SYSTEM | integer}]
    [LOCKSIZE {ANY | TABLESPACE | TABLE | PAGE | ROW | LOB}]
    [TRACKMOD {YES | NO}]
    [LOG {YES | NO}]
    [LOCKPART {NO | YES}]
    [MAXROWS integer]

Parameters:

database-name.tablespace-name | Identifies the table space to be altered. The table space must exist at the currently set XDB Server location. If the database-name qualifier is omitted, then the XDB Server assumes the table space is located in the default DSNDB04 database (within the current location).
bpname | A name that identifies a bufferpool. The 4K bufferpools are named BP0, BP1, BP2...BP49. The 32K bufferpools are named BP32K, BP32K1, BP32K2...BP32K9.
password | Consists of a short identifier.
integer | Specifies a whole number in the range of 1 to n.

Description

Although all of the information contained in the following ALTER TABLESPACE optional clauses is recorded in the XDB Server catalog tables, the XDB Server system architecture does not physically support many of these options. Refer to appropriate DB2 documentation for complete descriptions of these mainframe-specific options.

BUFFERPOOL

This clause has no functional equivalent withing the XDB Server operating environment. However, for DB2 compatibility purposes, the XDB Server records any of the sixty possible bufferpools (BP0...BP49, and BP32K, BP32K1...BP32K9). The first fifty bufferpools are for table spaces with 4K page sizes, while the last ten are for table spaces with 32K page sizes. Although not functionally supported, this new information is semantically checked and recorded in the XDB Server catalog tables.

LOCKSIZE

Specifies the size of locks used within the table space and, in some cases, also the threshold at which lock escalation occurs. Do not specify LOCKSIZE for a table space in a work file database or a TEMP database.

In most cases, DB2 uses LOCKSIZE PAGE LOCKMAX SYSTEM for non-LOB table spaces and LOCKSIZE LOB LOCKMAX SYSTEM for LOB table spaces. However, when the number of locks acquired for the table space exceeds the maximum number of locks allowed for a table space (an installation parameter), the page or LOB locks are released and locking is set at the next higher level. If the table space is segmented, the next higher level is the table. If the table space is nonsegmented, the next higher level is the table space.

TABLESPACE | Specifies table space locks.
TABLE | Specifies table locks. Use TABLE only for a segmented table space.
PAGE | Specifies page locks. Do not use PAGE for a LOB table space.
ROW | Specifies row locks. Do not use ROW for a LOB table space.
LOB | Specifies LOB locks. Use LOB only for a LOB table space.

This option is semantically checked and recorded in the XDB Server system catalog tables. See DB2 documentation for a full discussion of keyword options.

TRACKMOD

Specifies whether DB2 tracks modified pages in the space map pages of the table space or partition. Do not specify TRACKMOD for a LOB table space. For a table space in a TEMP database, DB2 uses TRACKMOD NO regardless of the value specified.

YES | DB2 tracks changed pages in the space map pages to improve the performance of incremental image copy. For data sharing, changing TRACKMOD to YES causes additional SCA (shared communication area) storage to be used until after the next full or incremental image copy is taken or until TRACKMOD is set back to NO.
NO | DB2 does not track changed pages in the space map pages. It uses the LRSN value in each page to determine whether a page has been changed.

LOCKMAX

Specifies the maximum number of page, row, or LOB locks an application process can hold simultaneously in the table space. If a program requests more than that number, locks are escalated. The page, row, or LOB locks are released and the intent lock on the table space or segmented table is promoted to S or X mode. If you specify LOCKMAX a for table space in a TEMP database, DB2 ignores the value because these types of locks are not used.

For an application that uses Sysplex query parallelism, a lock count is maintained on each member.

Integer | Specifies the number of locks allowed before escalating, in the range 0 to 2 147 483 647. Zero (0) indicates that the number of locks on the table or table space are not counted and escalation does not occur.
SYSTEM | Indicates that the value of field LOCKS PER TABLE(SPACE) on installation panel DSNTIPJ specifies the maximum number of page, row, or LOB locks a program can hold simultaneously in the table or table space.

If you change LOCKSIZE and omit LOCKMAX, the following results occur:

LOCKSIZE | Resultant LOCKMAX
TABLESPACE or TABLE | 0
PAGE ROW, or LOB | Unchanged
ANY | SYSTEM

If the lock size is TABLESPACE or TABLE, LOCKMAX must be omitted, or its operand must be 0.

CLOSE

When the limit on the number of open data sets is reached, specifies the priority in which data sets are closed.

YES | Eligible for closing before CLOSE NO data sets. This is the default unless the table space is in a TEMP database.
NO | Eligible for closing after all eligible CLOSE YES data sets are closed.

For a table space in a TEMP database, DB2 uses CLOSE NO regardless of the value specified.

This option is semantically checked and recorded within the XDB Server system catalog tables. See DB2 documentation for a full discussion of keyword options.

DSETPASS

This option records a password for a DB2 subsystem dataset inside the XDB Server system catalog. To remove a password, specify a delimited string of blank characters as the password name. For example:

DSETPASS " "

PART

XDB does not physically support partitioned table spaces, however, this clause can be used to identify a table space partition number (integer) defined within a DB2 subsystem that is being accessed through XDB Link. Do not use this clause if the DB2 table space is not partitioned.

If the DB2 table space is partitioned, the PART clause must be used if the FREEPAGE, PCTFREE, USING, PRIQTY, SECQTY, or ERASE clause appears in the ALTER TABLESPACE statement. Under these circumstances, all alterations specified in the later clause options apply specifically to the table space partition identified in the PART clause.

FREEPAGE

This option specifies the number of pages left free within a segmented table space defined on a DB2 subsystem. The integer whole number value can range from 0 to 255, but must be less than the SEGSIZE value. In situations where the number of pages free is greater than or equal to the SEGSIZE, the number of pages free is corrected downward to the SEGSIZE value minus one.

PCTFREE

This option specifies a whole number value (integer) ranging from 0 to 99. This clause is semantically checked after which the values are recorded in the appropriate XDB Server catalog tables. See DB2 documentation for a full discussion of keyword options.

USING

This clause specifies either a user-managed or DB2-managed dataset for a table space or partition in a DB2 subsystem. For partitioned table spaces, the USING clause is applied only to the dataset within the partition identified in the PART clause. For nonpartitioned table spaces, the USING clause is applied to every dataset that is eligible for a particular table space.

VCAT catalog-name | Designates a user-managed dataset starting with catalog-name. The catalog-name must be a short identifier.
STOGROUP stogroup-name | Identifies a stogroup described in the DB2 catalog. Before applying a new description for a table space, the storage group description must include at least one volume serial number. This volume serial number is entered into the SYSIBM.SYSVOLUMES catalog table, and can be used to locate tables created in this table space on different physical paths (see CREATE STOGROUP).

If the current dataset for the table space or partition is DB2-managed and USING STOGROUP is specified, then omitting the PRIQTY clause implicitly defines the current PRIQTY value. Additionally, omitting the SECQTY clause implicitly defines the current SECQTY value, while omitting the ERASE clause implicitly specifies the current ERASE rule.

If the current dataset for the table space or partition is user-managed and USING STOGROUP is specified, then the omission of the various clauses below implicitly specifies the following:

  • PRIQTY values of 12 for a table space with 4K pages and 96 for a table space with 32K pages, when omitting the PRIQTY clause.
  • SECQTY values of 12 for a table space with 4K pages and 96 for a table space with 32K pages, when omitting the SECQTY clause.
  • Default value of ERASE NO, when omitting the ERASE clause.

PRIQTY

Indicates the replacement value for the last primary space allocation for the table space or partition dataset. This clause can be specified only under one of the following conditions:

  • USING STOGROUP is also specified.
  • The USING clause is not specified, and the table space or partition dataset is DB2-managed.

The value integer is the primary space allocation in kilobytes. Any whole number can be specified up to a limit of 4,194,304. Values greater than 4,194,304 are reduced to 4,194,304. When specifying a number less than 12 for a table space with a page size of 4K, the system increases the number to 12. When specifying a number less than 96 for a table space with a page size of 32K, the system increases the number to 96. If PRIQTY -1 is specified, DB2 uses a default value for the primary space allocation.

If PRIQTY is specified, the primary space allocation is at least n kilobytes, where n is the value of integer with the following exceptions:

  • For 4KB page sizes, if integer is less than 12, n is 12.
  • For 8KB page sizes, if integer is less than 24, n is 24.
  • For 16KB page sizes, if integer is less than 48, n is 48.
  • For 32KB page sizes, if integer is less than 96, n is 96.
  • For any page size, if integer is greater than 4194304, n is 4194304.

For LOB table spaces, the exceptions are:

  • For 4KB pages sizes, if integer is less than 200, n is 200.
  • For 8KB pages sizes, if integer is less than 400, n is 400.
  • For 16KB pages sizes, if integer is less than 800, n is 800.
  • For 32KB pages sizes, if integer is less than 1600, n is 1600.
  • For any page size, if integer is greater than 4194304, n is 4194304.
  • Do not specify the PRIQTY clause for user-managed datasets.

SECQTY

Indicates the replacement value for the last secondary space allocation for the table space or partition dataset. This clause can be specified only under one of the following conditions:

  • USING STOGROUP is also specified.
  • The USING clause is not specified, and the table space or partition dataset is DB2-managed.

The value integer is the secondary space allocation in kilobytes. For a dataset or table space using 4K pages, any whole number can be specified up to a limit of 131,068. Values greater than 131,068 are reduced to 131,068. The maximum allowable secondary allocation for 32K page size datasets is 131,040. If a value of zero is specified, the dataset cannot be extended. If SECQTY -1 is specified, DB2 uses a default value for the secondary space allocation.

If SECQTY is specified, the secondary space allocation is at least n kilobytes, where n is the value of integer with the following exceptions:

  • If integer is greater than 4194304, n is 4194304. A value of 0 for integer indicates that no data set can be extended.

For LOB table spaces the exceptions are:

  • For 4KB page sizes, if integer is greater than 0 and less than 200, n is 200.
  • For 8KB page sizes, if integer is greater than 0 and less than 400, n is 400.
  • For 16KB page sizes, if integer is greater than 0 and less than 800, n is 800.
  • For 32KB page sizes, if integer is greater than 0 and less than 1600, n is 1600.
  • For any page size, if integer is greater than 4194304, n is 4194304.

Do not specify the SECQTY clause for user-managed datasets.

ERASE

This clause can be specified only under one of the following conditions:

  • USING STOGROUP is also specified.
  • The USING clause is not specified, and the table space or partition dataset is DB2-managed.

Do not specify the ERASE clause for user-managed datasets.

COMPRESS

Specifies whether data compression applies to the rows of the table space or partition. Do not specify COMPRESS for a LOB table space.

Either the option specified or the default value is recorded in the SYSIBM.SYSTABLEPART system catalog table. This option does not compress data in any way.

GBPCACHE

In a data sharing environment, specifies what pages of the table space or partition are written to the group buffer pool in a data sharing environment. In a non-data-sharing environment, you can specify GBPCACHE for a table space other than one in a work file or TEMP database, but it is ignored. Do not specify GBPCAHCE for a table space in a work file database or in a TEMP database in either environment (data sharing or not).

CHANGED When there is inter-DB2 R/W interest on the table space or partition, updated pages are written to the group buffer pool. When there is no inter-DB2 R/W interest, the group buffer pool is not used. Inter-DB2 R/W interest exists when more than one member in the data sharing group has the table space or partition open, and at least one member has it open for update.

If the table space is in a group buffer pool that is defined to be used only for cross-invalidation (GBPCACHE NO), CHANGED is ignored and no pages are cached to the group buffer pool.

ALL Indicates that pages are to be cached in the group buffer pool as they are read in from DASD.

Exception: In the case of a single updating DB2 when no other DB2s have any interest in the page set, no pages are cached in the group buffer pool.

Hiperpools are not used for table spaces or partitions that are defined with GBPCACHE ALL.

If the table space is in a group buffer pool that is defined to be used only for cross-invalidation (GBPCACHE NO), ALL is ignored and no pages are cached to the group buffer pool.

SYSTEM Indicates that only changed system pages within the LOB table space are to be cached to the group buffer pool. A system page is a space map page or any other page that does not contain actual data values.

SYSTEM is the default for a LOB table space. Use SYSTEM only for a LOB table space.

NONE Indicates that no pages are to be cached to the group buffer pool. DB2 uses the group buffer pool only for cross-invalidation.

If you specify NONE, the table space or partition must not be in recover pending status.

If you specify GBPCACHE in a data sharing environment, the table space or partition must be in the stopped state when the ALTER TABLESPACE statement is executed. You cannot alter the GBPCACHE value for the following table spaces:

  • DSNDB06.SYSDBASE
  • DSNDB06.SYSDBAUT
  • DSNDB06.SYSPKAGE
  • DSNDB06.SYSPLAN
  • DSNDB06.SYSUSER (exception: the attribute can be altered if authorization includes installation SYSADM authority.)

LOG

Specifies whether changes to a LOB column in the table space are to be written to the log. Use LOG only for a LOB table space.

YES Indicates that changes to a LOB column are to be written to the log. You cannot use YES if the auxiliary table in the table space stores a LOB column that is greater than 1 gigabyte in length.

When you change the value of LOG to YES, the LOB table space is placed in copy pending status.

NO Indicates that changes to a LOB column are not to be written to the log.

LOG NO has no effect on a commit or rollback operation; the consistency of the database is maintained regardless of whether the LOB value is logged. All committed changes and changes that are rolled back reflect the expected results.

Even when LOG NO is specified, changes to system pages and to the auxiliary index are logged. During the log apply operation of the RECOVER utility, LPL recovery, or GPB recovery, all LOB values that were not logged are marked invalid and cannot be accessed by a SELECT or FETCH statement. Invalid LOB values can be updated or deleted.

LOCKPART

You can specify the LOCKPART clause, but it has no effect. Starting with Version 8, DB2 treats all partitioned table spaces as if they were defined as LOCKPART YES. LOCKPART YES specifies the use of selective partition locking. When all the conditions for selective partition locking are met, DB2 locks only the partitions that are accessed. When the conditions for selective partition locking are not met, DB2 locks every partition of the table space.

Running utilities

You cannot execute the ALTER TABLESPACE statement while a DB2 utility has control of the table space.

Altering more than one partition

To change FREEPAGE, PCTFREE, USING, PRIQTY, SECQTY, COMPRESS, ERASE, or GBPCACHE for more than one partition, you must use separate ALTER TABLESPACE statements.

Altering storage attributes

The USING, PRIQTY, SECQTY, and ERASE clauses define the storage attributes of the table space or partition. If you specify USING or ERASE when altering storage attributes, the table space or partition must be in the stopped state when the ALTER TABLESPACE statement is executed. You can use a STOP DATABASE...SPACENAM... command to stop the table space or partition.

If the catalog name changes, the changes take effect after you move the data and start the table space or partition using the START DATABASE...SPACENAM... command. The catalog name can be implicitly or explicitly changed by the ALTER TABLESPACE statement. The catalog name also changes when you move the data to a different device

Changes to the secondary space allocation (SECQTY) take effect the next time DB2 extends the data set; however, the new value is not Reflected in the integrated catalog until you use the REORG, RECOVER, or LOAD REPLACE utility on the table space or partition. The changes to the other storage attributes take effect the next time the page set is reset. For a non-LOB table space, the page set is reset when you use the REORG, RECOVER, or LOAD REPLACE utilities on the table space or partition. For a LOB table space, the page set is reset when RECOVER is run on the LOB table space or LOAD REPLACE is run on its associated base table space. If there is not enough storage to satisfy the primary space allocation, a REORG might fail. If you change the primary space allocation parameters or erase rule, you can have the changes take effect earlier if you move the data before you start the table space or partition

Examples:

Alter table space DSN8S61E in database DSN8D61A. CLOSE NO means that the data sets of the table space are not to be closed when there are no current users of the table space.

 ALTER TABLESPACE DSN8D61A.DSN8S61E
     CLOSE NO;

Alter table space DSN8S61D in database DSN8D61A. BP2 is the buffer pool associated with the table space. PAGE is the level at which locking is to take place.

 ALTER TABLESPACE DSN8D61A.DSN8S61D
     BUFFERPOOL BP2
     LOCKSIZE PAGE;
Parent topic: SQL Statements


ALTER VIEW

The XDB Server operating environment only provides syntax support for this statement at this time.

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared only if DYNAMICRULES run behavior is implicitly or explicitly specified.

Authorization

The privilege set that is defined below must include at least one of the following:

  • Ownership of the view
  • SYSADM authority
  • SYSCTRL authority

If the statement is embedded in an application program, the privilege set is the privileges that are held by the authorization ID of the owner of the plan or package. If the statement is dynamically prepared, the privilege set is the union of the privilege sets that are held by each authorization ID of the process.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

ALTER VIEW view-name REGENERATE

Description

view-name
Identifies the view to be regenerated. The name must identify a view that exists at the current server.
REGENERATE
Specifies that the view is to be regenerated. The view definition in the catalog is used, and existing authorizations and dependent views are retained. The catalog is updated with the regenerated view definition. If the view cannot be successfully regenerated, an error is returned.
Parent topic: SQL Statements


ASSOCIATE LOCATORS

Invocation

This statement can be embedded in an application program. It is an executable statement that can be dynamically prepared. It cannot be issued interactively.

Authorization

No authorization is required for this statement.

Syntax

ASSOCIATE [RESULT SET] {LOCATOR | LOCATORS}
    (rs-locator-variable ,...)
    WITH PROCEDURE {procedure-name | host-variable}

Parameters:

rs-locator-variable | Identifies a result set locator variable that has been declared according to the rules for declaring result set locator variables. One result set locator variable is required for each result set that is returned by the stored procedure. If the stored procedure returns fewer result sets than the number of result set locator variables specified, the extra variables are assigned a value of 0.
procedure-name | Identifies the stored procedure that returned result set locators by the specified procedure name.
host-variable | Identifies the stored procedure that returned result set locators by the procedure name contained in the host variable.

Description

The ASSOCIATE LOCATORS statement assigns result set locator values from the SQLVAR sections of the SQLDA to result set locator variables so that the first SQLDATA field is assigned to the first locator variable, the second SQLDATA field to the second locator variable, and so on.

More than one locator can be assigned to a result set. You can issue the same ASSOCIATE LOCATORS statement more than once with different result set locator variables.

If the number of result set locator variables listed in the ASSOCIATE LOCATORS statement is less than the number of locators returned by the stored procedure, all variables in the statement are assigned a value, and a warning is issued.

If the number of result set locator variables listed in the ASSOCIATE LOCATORS statement is greater than the number of locators returned by the stored procedure, the extra variables are assigned a value of 0.

When the ASSOCIATE LOCATORS statement is executed, the procedure name or specification must identify a stored procedure that the requestor has already invoked using the CALL statement.

Note: For this statement to be successful, the application must be currently connected to the site at which the stored procedure was executed.

WITH PROCEDURE {procedure-name | host-variable}

Identifies the stored procedure that returned result set locators by the specified procedure name or the procedure name contained in the host variable.

A procedure name is a qualified or unqualified name. Each part of the name is a long SQL identifier that must be composed of SBCS characters:

  • A fully qualified procedure name is a three-part name. The first part is a location name that identifies the DBMS where the procedure is stored. The next two parts identify the stored procedure. A period must separate each of the parts. Any or all of the parts can be a delimited identifier.
  • An implicitly qualified procedure name is a two-part name that is qualified by the location name of the current server. The two parts identify the schema name and the name of the stored procedure. A period must separate the two parts. The first part identifies the stored procedure at the server. The location name of the first part depends on the application server.
  • An unqualified procedure name is a one-part name with two implicit qualifiers. The first implicit qualifier is the location name of the current server. The second implicit qualifier identifies the stored procedure at the server. The meaning of the second implicit qualifier depends on the application server (for MVS, it is SYSPROC). The name and its implicit qualifiers identifies a stored procedure.

    Successful execution of the ASSOCIATE LOCATOR statement only requires that the unqualified procedure name in the statement is the same as the procedure name in the most recently executed CALL statement that was specified with an unqualified procedure name. (The implicit schema name for the unqualified name in the CALL statement is not considered in the match.) The rules for how the procedure name must be specified are described below.

If a host variable is used:

  • It must be a character string variable with a length attribute that is not greater than 254.
  • It must be preceded by a colon and must not be followed by an indicator variable.
  • The value of the host variable is a specification that depends on the application server. Regardless of the application server, the specification must:
    • Be left justified within the host variable
    • Not contain embedded blanks
    • Be padded on the right with blanks if its length is less than that of the host variable

The procedure name in the ASSOCIATE LOCATORS statement must be specified the same way that it was specified on the CALL statement. For example, if a two-part name was specified on the CALL statement, you must use a two-part name in the ASSOCIATE LOCATORS statement. However, there is one condition under which the names do not have to match. If the CALL statement was made with a three-part name and the current server is the same as the location in the three-part name, you can omit the location name and specify a two-part name.

RESULT SET

This optional item has no effect on the execution of the statement. Use it only if you wish to improve readability of the statement.

Note:

More than one locator can be assigned to a result set. You can issue the same ASSOCIATE LOCATORS statement more than once with different result set locator variables.

If the number of result set locator variables that are listed in the ASSOCIATE LOCATORS statement is less than the number of locators returned by the stored procedure, all variables in the statement are assigned a value, and a warning is issued.

If the number of result set locator variables that are listed in the ASSOCIATE LOCATORS statement is greater than the number of locators returned by the stored procedure, the extra variables are assigned a value of 0.

The ASSOCIATE LOCATORS statement assigns result set locator values from the SQLVAR sections of the SQLDA to result set locator variables. For languages other than REXX, the first SQLDATA field is assigned to the first locator variable, the second SQLDATA field to the second locator variable, and so on. For REXX, the first SQLLOCATOR field is assigned to the first locator variables, the second SQLLOCATOR field to the second locator variable, and so on.

If a stored procedure is called more than once with a one-part name at the same location, only the most recent result sets are accessible.

Examples:

The statements in the following examples are assumed to be in COBOL programs.

Use result set locator variables LOC1 and LOC2 to get the result set locator values for the two result sets returned by stored procedure P1. Assume that the stored procedure is called with a one-part name from current server SITE2.

 EXEC SQL CONNECT TO SITE2;
 EXEC SQL CALL P1;
 EXEC SQL ASSOCIATE RESULT SET LOCATORS (:LOC1, :LOC2)
          WITH PROCEDURE P1;

Repeat the scenario above, but use a two-part name to specify an explicit schema name for the stored procedure to ensure that stored procedure P1 in schema MYSCHEMA is used.

 EXEC SQL CONNECT TO SITE2;
 EXEC SQL CALL MYSCHEMA.P1;
 EXEC SQL ASSOCIATE RESULT SET LOCATORS (:LOC1, :LOC2)
          WITH PROCEDURE MYSCHEMA.P1;

Use result set locator variables LOC1 and LOC2 to get the result set locator values for the two result sets that are returned by the stored procedure named by host variable HV1. Assume that host variable HV1 contains the value SITE2.MYSCHEMA.P1 and the stored procedure is called with a three-part name.

 EXEC SQL CALL SITE2.MYSCHEMA.P1;
 EXEC SQL ASSOCIATE LOCATORS (:LOC1, :LOC2)
          WITH PROCEDURE :HV1;

The preceding example would be invalid if host variable HV1 had contained the value MYSCHEMA.P1, a two-part name. For the example to be valid with that two-part name in host variable HV1, the current server must be the same as the location name that is specified on the CALL statement as the following statements demonstrate. This is the only condition under which the names do not have to be specified the same way and a three-part name on the CALL statement can be used with a two-part name on the ASSOCIATE LOCATORS statement.

 EXEC SQL CONNECT TO SITE2;
 EXEC SQL CALL SITE2.MYSCHEMA.P1;
 EXEC SQL ASSOCIATE LOCATORS (:LOC1, :LOC2)
          WITH PROCEDURE :HV1;
  • ASSOCIATE LOCATORS Examples
Parent topic: SQL Statements


ASSOCIATE LOCATORS Examples

The statements in the following examples are assumed to be in COBOL programs.

Use result set locator variables LOC1 and LOC2 to get the result set locator values for the two result sets returned by stored procedure P1. Assume that the stored procedure is called with a one-part name from current server SITE2.

 EXEC SQL CONNECT TO SITE2;
 EXEC SQL CALL P1;
 EXEC SQL ASSOCIATE RESULT SET LOCATORS (:LOC1, :LOC2)
          WITH PROCEDURE P1;

Repeat the scenario above, but use a two-part name to specify an explicit schema name for the stored procedure to ensure that stored procedure P1 in schema MYSCHEMA is used.

 EXEC SQL CONNECT TO SITE2;
 EXEC SQL CALL MYSCHEMA.P1;
 EXEC SQL ASSOCIATE RESULT SET LOCATORS (:LOC1, :LOC2)
          WITH PROCEDURE MYSCHEMA.P1;

Use result set locator variables LOC1 and LOC2 to get the result set locator values for the two result sets that are returned by the stored procedure named by host variable HV1. Assume that host variable HV1 contains the value SITE2.MYSCHEMA.P1 and the stored procedure is called with a three-part name.

 EXEC SQL CALL SITE2.MYSCHEMA.P1;
 EXEC SQL ASSOCIATE LOCATORS (:LOC1, :LOC2)
          WITH PROCEDURE :HV1;

The preceding example would be invalid if host variable HV1 had contained the value MYSCHEMA.P1, a two-part name. For the example to be valid with that two-part name in host variable HV1, the current server must be the same as the location name that is specified on the CALL statement as the following statements demonstrate. This is the only condition under which the names do not have to be specified the same way and a three-part name on the CALL statement can be used with a two-part name on the ASSOCIATE LOCATORS statement.

 EXEC SQL CONNECT TO SITE2;
 EXEC SQL CALL SITE2.MYSCHEMA.P1;
 EXEC SQL ASSOCIATE LOCATORS (:LOC1, :LOC2)
          WITH PROCEDURE :HV1;
Parent topic: ASSOCIATE LOCATORS


BACKUP LOCATION

Invocation

BACKUP LOCATION can be executed interactively, embedded in a host language, or dynamically prepared.

Authorization

To use the BACKUP LOCATION command you must be a super user.

Syntax

BACKUP LOCATION location-name TO path-name
[INCREMENTAL]

Parameters:

location-name | Identifies the location to be backed up.
path-name | Specifies the parent target directory where backups are stored. Inside this directory, a subdirectory will be created that contains this backup’s contents. This subdirectory’s name is of the form xdbYYYYMMDDHHMMSSnnnnnn, where YYYYMMDDHHMMSS is the time of the backup, and nnnnnn is a relative sequence number.
INCREMENTAL | Indicates that you want to backup only your log files. Omitting this option results in your log files and your location’s database files being backed up.

Description

The BACKUP LOCATION command is used for backing up locations (including all associated databases, tables, catalog tables, and log files) to a secure device, such as a file server, or a different disk drive.

This is useful for avoiding losses due to media or machine failure. For instance, if the drive where your XDB location was located becomes inoperable, provided that you have issued a BACKUP LOCATION command that saved the entire contents of that location to another disk you can ROLLFORWARD that backup to recreate the corrupted location.

While the standard BACKUP LOCATION command copies both database and log files, in addition to creating a recovery script (xdbdata.bat), a BACKUP LOCATION INCREMENTAL backs up only the log files for your location.

After performing a standard backup (which is mandatory for all recovery scenarios), which type of backup you perform is up to you. Always performing standard backups takes longer than performing incremental backups but the recovery process from them is much easier and quicker. Performing incremental backups is quicker than performing standard backups but more ROLLFORWARD steps might be necessary to recreate your location.

Examples:

  • BACKUP LOCATION (Standard) Example
  • BACKUP LOCATION (Incremental) Example
  • Recovery with Standard Backups Example
  • Recovery with Incremental Backups Example
  • BACKUP LOCATION (Standard) Example
  • BACKUP LOCATION (Incremental) Example
  • Recovery with Standard Backups Example
  • Recovery with Incremental Backups Example
Parent topic: SQL Statements


BACKUP LOCATION (Standard) Example

The following command creates a directory, such as d:\backuplocs\xdb20051017151315000001, that contains an xdbdata.bat script, database files and log files:

BACKUP LOCATION MYLOC TO D:\BACKUPLOCS
Parent topic: BACKUP LOCATION


BACKUP LOCATION (Incremental) Example

The following command creates a directory, such as d:\backuplocs\xdb20051017151315000002, that contains only log files:

BACKUP LOCATION MYLOC TO D:\BACKUPLOCS INCREMENTAL
Parent topic: BACKUP LOCATION


Recovery with Standard Backups Example

The following sequence of events shows the typical steps in performing standard backups and subsequently recovering from a media failure:

  1. On Friday afternoon perform a standard backup using the following command:
    BACKUP LOCATION MYLOC TO D:\BACKUPLOCS
  2. On Monday afternoon perform a standard backup using the following command:
    BACKUP LOCATION MYLOC TO D:\BACKUPLOCS
  3. On Tuesday afternoon perform a standard backup using the following command:
    BACKUP LOCATION MYLOC TO D:\BACKUPLOCS
  4. On Wednesday morning recover from a media failure using the following steps:
    1. Stop the XDB Server.
    2. Copy the contents of the current logs to another directory, such as d:\currlocs.
    3. Remove the contents of the original XDB location.
    4. Run the xdbdata.bat script in Tuesday afternoon’s d:\backuplocs subdirectory.
    5. Start the XDB Server in exclusive use mode.
    6. Issue the following ROLLFORWARD command:
      ROLLFORWARD MYLOC USING D:\CURRLOGS
    7. Stop the XDB Server.
    8. Restart the XDB Server for general availability.
Parent topic: BACKUP LOCATION


Recovery with Incremental Backups Example

The following sequence of events shows the typical steps in performing incremental backups and subsequently recovering from a media failure:

  1. On Friday afternoon perform a standard backup using the following command:
    BACKUP LOCATION MYLOC TO D:\BACKUPLOCS
  2. On Monday afternoon perform an incremental backup using the following command:
    BACKUP LOCATION MYLOC TO D:\BACKUPLOCS INCREMENTAL

    This creates directory xdb20051015153015000002, for instance.

  3. On Tuesday afternoon perform an incremental backup using the following command:
    BACKUP LOCATION MYLOC TO D:\BACKUPLOCS INCREMENTAL

    This creates directory xdb20051016144416000003, for instance.

  4. On Wednesday morning recover from a media failure using the following steps:
    1. Stop the XDB Server.
    2. Copy the contents of the current logs to another directory, such as d:\currlocs.
    3. Remove the contents of the original XDB location.
    4. Run the xdbdata.bat script in Friday afternoon’s d:\backuplocs subdirectory.
    5. Start the XDB Server in exclusive use mode.
    6. Issue the following ROLLFORWARD commands:
      ROLLFORWARD MYLOC USING D:\BACKUPLOCS\XDB20051015153015000002
ROLLFORWARD MYLOC USING D:\BACKUPLOCS\XDB20051016144416000003
ROLLFORWARD MYLOC USING D:\CURRLOGS
    7. Stop the XDB Server.
    8. Restart the XDB Server for general availability.
Parent topic: BACKUP LOCATION


BEGIN DECLARE SECTION

Invocation

BEGIN DECLARE SECTION is not an executable statement. It can only be embedded in a host language.

Authorization

No special authorization is required.

Syntax

BEGIN DECLARE SECTION

Description

BEGIN DECLARE SECTION may be used in an application program to mark the beginning of the section of code where host variables are declared. If a BEGIN DECLARE SECTION is used, the host variable declaration section must end with the END DECLARE SECTION statement.

When programming in C, or when the DECLARE or ANSI COBOL preprocessor directives are used, BEGIN and END DECLARE SECTION commands must surround the declarations for all host variables, to create host variable declaration blocks. As illustrated in the COBOL example below, a host variable declaration block can appear anywhere that the host language allows variable declarations:

EXEC SQL BEGIN DECLARE SECTION;
        short int cust_num = 28;
        char name[30];
EXEC SQL END DECLARE SECTION;

The following rules are enforced by the precompiler, only if C is the host language, or if the DECLARE or ANSI COBOL precompiler option is specified:

  • Variables referenced within SQL statements must be declared within the variable declaration section of the host program.
  • There must be a paired set of BEGIN DECLARE SECTION and END DECLARE SECTION statements.
Note:

Only if the DECLARE or the ANSI COBOL precompiler directive is specified or the host language is C, are host variable declaration sections required. Any source program, in any host language, can be made to conform to the SAA definition of SQL by specifying a declare section. If variable declaration sections are used when they are not required, all variables declared outside the declare section must have a name different from all variable names declared within the declare section.

Parent topic: SQL Statements


BULK

Invocation

BULK ON and BULK OFF are not executable statements. They can only be embedded in a host language.

Note:

To use the BULK ON and BULK OFF commands, you must include the XDBFUNCS directive as explained in your COBOL precompiler manual.

Authorization

No special authorization is required.

Syntax

BULK [ON | OFF]

Description

The BULK ON command optimizes communications between the mainframe and XDB Link. BULK ON sets internal indicators allowing XDB Link to operate in Bulk Upload mode -- whereby INSERT, UPDATE and DELETE statements are sent to the mainframe as usual, but the SQLCA response buffers are not sent back to the XDB Link until a bulk interval has been reached. This reduction in the number of SQLCA responses optimizes upload performance by reducing the number of LU6.2 line turn-around events associated with the upload procedure.

The bulk interval for the upload is determined by the Upload Pacing Limit value specified in the Location Configuration dialog box in the Gateway Profile Utility or by a COMMIT statement. If, for example, the interval is set to 10, then every tenth SQL upload statement (such as INSERT, UPDATE and DELETE) contains an active SQLCA indicating the true SQLCODE for the bulk process.

Bulk Upload mode can be deactivated by issuing a BULK OFF statement, which terminates Bulk Upload mode for all subsequent transactions. If an SQL error has occurred in the bulk upload interval, it is returned in the next live SQLCA. A live SQLCA (reporting the true status of the bulk interval) is returned either at the end of a bulk interval or with the next statement following a BULK OFF command.

Note:

A live SQLCA is also returned if a SELECT statement is inadvertently issued in the middle of a bulk upload process. It must be noted that this SQLCA is reporting the status of the bulk interval, and not the SELECT statement.

Error Handling

With any SQL error, a nonzero SQLCODE is returned. The SQLERRD[3] field of the SQLCA indicates the first statement to fail in the bulk interval. You can also terminate the interval with a COMMIT. The COMMIT in this case is not executed, and you can choose to re-issue the COMMIT (not recommended) or ROLLBACK the entire bulk upload interval.

SQLCA Status

SQLCA information is loaded after each SQL call. The status of the SQLCA is indicated by the SQLERRD[3] field:

SQLERRD[3] = -1

Inactive SQLCA. A pseudo-SQLCA is being sent to the client because the client application is in the middle of a bulk upload interval.

SQLERRD[3] = 0

Active SQLCA. Indicates a successful return of all SQLCAs for all SQL statements in the bulk upload interval. Along with the SQLCODE, shows the status of the bulk process.

SQLERRD[3] > 0

Active SQLCA. An error has occurred in this bulk interval. SQLERRD[3] is indicating the number of SQL statements that qualify for failure based on the first SQL statement failure. SQLCODE shows the SQL error for the failing SQL statement.

Examples:

In the following scenario the Bulk Interval is set to a value of 10, with the third SQL statement in error:

SQLERRD[3] = 8

Indicates that eight SQL statements (the third through the tenth) are in doubt (with the first two being all right).

SQLCODE = -551

Indicates that an authorization error occurred on the third (or failed) SQL statement.

You could choose to ROLLBACK this bulk process, and re-execute (using BULK OFF) to monitor each failure.

The following steps are recommended for turning off bulk upload mode, and checking for errors:

EXEC SQL BULK OFF
EXEC SQL COMMIT

Finally, test the SQLCODE value for errors. If errors are found, issue a ROLLBACK.

Parent topic: SQL Statements


CALL

Invocation

This statement can only be embedded in an application program. It is an executable statement that cannot be dynamically prepared.

Authorization

The privileges required to execute the CALL statement are determined by the owner of the package or plan that contains the CALL statement. If the server is DB2 for MVS/ESA (or an XDB Server), that AuthID must have either the EXECUTE privilege on the package associated with the stored procedure, ownership of the package associated with the stored procedure, PACKADM authority for the package's collection, or SYSADM authority.

The authorization ID that must have the EXECUTE privilege on the stored procedure depends on the form of the CALL statement:

  • For static SQL programs that use the syntax CALL procedure, the owner of the plan or package that contains the CALL statement must have one of the following:
    • The EXECUTE privilege on the stored procedure
    • Ownership of the stored procedure
    • SYSADM authority
  • For static SQL programs that use the syntax CALL host variable (ODBC applications use this form of the CALL statement), the authorization ID of the plan or package that contains the CALL statement must have one of the following:
    • The EXECUTE privilege on the stored procedure
    • Ownership of the stored procedure
    • SYSADM authority

The authorization that is required to run the stored procedure package and any packages that are used under the stored procedure apply to any form of the CALL statement as follows:

Stored procedure package

One of the authorization IDs that are defined below under Set of authorization IDs must have at least one of the following on the stored procedure package:

  • The EXECUTE privilege on the package
  • Ownership of the package
  • PACKADM authority for the package's collection
  • SYSADM authority

A PKLIST entry is not required for the stored procedure package.

Syntax

CALL {procedure-name | host-variable}
[({expression | NULL | TABLE transition-table-name}[,...]) |
USING DESCRIPTOR descriptor-name]

Parameters:

procedure-name | A qualified or unqualified name that identifies the stored procedure. Procedure names can be three-part, two-part or unqualified one-part names. A fully qualified procedure name begins with a location name that identifies the DBMS at which the procedure is stored. The second and third parts identify the stored procedure. A period must separate each of the parts.
host-variable-1 | Character string variable with a maximum length of 254 bytes that identifies the stored procedure by the value of the specified host variable. This host variable must be preceded by a colon and must not be followed by an indicator variable.
host-variable-2 | Identifies a parameter of the CALL statement. The host variable must identify a host variable (not a structure) described in the program according to the rules for declaring host variables. The data type of the variable must be compatible with the data type of the corresponding parameter of the stored procedure.
constant | A parameter of the stored procedure expressed as a constant in the CALL statement. The data type of the constant must be compatible with the corresponding parameter of the stored procedure and that parameter must be defined as IN.
NULL | A parameter of the stored procedure expressed as a NULL value in the CALL statement. The corresponding parameter of the stored procedure must be defined as IN, and the description of the stored procedure must allow for null parameters.
descriptor-name | Identifies an SQLDA that must contain a valid description of host variables. In C, the descriptor-name can be a pointer to an SQLDA.

Description

A stored procedure is invoked by the CALL statement, which passes a list of parameters to the procedure. When the CALL statement is executed, the procedure name specified must identify a stored procedure that exists at the application server. If the server is DB2 for MVS/ESA (or an XDB Server), the last or only part of the name must be equal to some value of the NAME column of the SYSIBM.SYSROUTINES catalog table.

DB2 and the XDB Server use the information stored in SYSIBM.SYSROUTINES and SYSIBM.SYSPARMS to automatically activate a stored procedure definition, which includes identification of the parameter list used to implement the stored procedure. The parameters issued in your procedure's CALL statement must correspond to the parameters defined in SYSIBM.SYSPARMS.

procedure-name or host-variable

Identifies the stored procedure to call. The procedure name can be specified as a character string constant or within a host variable.

A procedure name is a qualified or unqualified name. Each part of the name must be composed of SBCS characters:

  • A fully qualified procedure name is a three-part name. The first part is a long identifier that contains the location name that identifies the DBMS at which the procedure is stored. The second part is a short identifier that contains the schema name of the stored procedure. The last part is a long identifier that contains the name of the stored procedure. A period must separate each of the parts. Any or all of the parts can be a delimited identifier.
  • A two-part procedure name has one implicit qualifier. The implicit qualifier is the location name of the current server. The two parts identify the schema name and the name of the stored procedure. A period must separate the two parts.
  • An unqualified procedure name is a one-part name with two implicit qualifiers. The first implicit qualifier is the location name of the current server. The second implicit qualifier depends on the application server. If the server is DB2 for OS/390, the implicit qualifier is the schema name. DB2 uses the SQL path to determine the value of the schema name.
  • If the procedure name is specified as a literal on the CALL statement (CALL procedure-name), the SQL path is the value of the PATH bind option that is associated with the calling package or plan.
  • If a host variable is specified for the procedure name on the CALL statement (CALL host-variable), the SQL path is the value of the CURRENT PATH special register.

DB2 searches the schema names in the SQL path from left to right until a stored procedure with the specified schema name is found in the DB2 catalog. When a matching schema.procedure-name is found, the search stops only if the following conditions are true:

  • The user is authorized to call the stored procedure.
  • The number of parameters in the definition of the stored procedure matches the number of parameters specified on the CALL statement.
  • The create timestamp for the stored procedure must be older than the bind timestamp for the package or plan in which the procedure is invoked.

If the list of schemas in the SQL path is exhausted before the procedure name is resolved, an error is returned.

If a host variable is used:

  • It must be a character string variable with a length attribute that is not greater than 255.
  • It must not be followed by an indicator variable.
  • The value of the host variable is a specification that depends on the application server. Regardless of the application server, the specification must:
    • Be left justified within the host variable
    • Not contain embedded blanks
    • Be padded on the right with blanks if its length is less than that of the host variable

In addition, the specification can:

  • Contain upper and lowercase characters. Lowercase characters are not folded to uppercase.
  • Use a delimited identifier for any part of a the three-part procedure name.

When the CALL statement is executed, the procedure name or specification must identify a stored procedure that exists at the application server.

When the package that contains the CALL statement is bound, the stored procedure that is invoked must be created if VALIDATE(BIND) is Specified. Although the stored procedure does not need to be created at bind time if VALIDATE(RUN) is specified, it must be created when the CALL statement is executed.

Parameters (Expression, Null, Table Transition-Table-Name)

Identifies a list of values to be passed as parameters to the stored procedure. If USING DESCRIPTOR is specified, each host variable described by the identified SQLDA is a parameter of the CALL statement. If host structures are not specified in the CALL statement, the nth parameter of the CALL statement corresponds to the nth parameter in the stored procedure, and the number of parameters in each must be the same. Otherwise, each reference to a host structure is replaced by a reference to each of the variables contained in that host structure, and the resulting number of parameters must be the same as the number of parameters defined for the stored procedure.

Each parameter of a stored procedure is described at the server. In addition to attributes such as data type and length, the description of each parameter indicates how the stored procedure uses it:

  • IN means as an input value
  • OUT means as an output value
  • INOUT means both as an input and an output value

When the CALL statement is executed, the value of each of its parameters is assigned to the corresponding parameter of the stored procedure. In cases where the parameters of the CALL statement are not an exact match to the data types of the parameters of the stored procedure, each parameter specified in the CALL statement is converted to the data type of the corresponding parameter of the stored procedure at execution. The conversion occurs according to the same rules as assignment to columns.

Conversion can occur when precision, scale, length, encoding scheme, or CCSID differ between the parameter specified in the CALL statement and the data type of the corresponding parameter of the stored procedure. Conversion might occur for a character string parameter specified in the CALL statement when the corresponding parameter of the stored procedure has a different encoding scheme or CCSID. For example, an error occurs when the CALL statement passes mixed data that actually contains DBCS characters as input to a parameter of the stored procedure that is declared with an SBCS subtype. Likewise, an error occurs when the stored procedure returns mixed data that actually contains DBCS characters in the parameter of the CALL statement that has an SBCS subtype.

expression

The parameter is the result of the specified expression, which is evaluated before the stored procedure is invoked.

If expression is a single host variable, the corresponding parameter of the procedure can be defined as IN, INOUT, or OUT. Otherwise, the corresponding parameter of the procedure must be defined as IN. In addition, the host variable can identify a structure. Any host variable or structure that is specified must be described in the application program according to the rules for declaring host structures and variables. A reference to a host structure is replaced by a reference to each of the variables contained in the host structure.

If the result of the expression can be the null value, either the description of the procedure must allow for null parameters or the corresponding parameter of the procedure must be defined as OUT.

The following additional rules apply depending on how the corresponding parameter was defined in the CREATE Procedure statement for the procedure:

  • expression can contain references to multiple host variables. expression cannot include a column name or column function or a user-defined function that is sourced on a column function.
  • INOUT or OUT expression can only be a single host variable.

NULL

The parameter is a null value. The corresponding parameter of the procedure must be defined as IN and the description of the procedure must allow for null parameters.

TABLE transition-table-name

The parameter is a transition table and it is passed to the procedure as a table locator. . You can use the CALL statement with the TABLE clause only within the definition of the triggered action of a trigger. The name of a transition table must be specified in the CALL statement if the corresponding parameter of the procedure was defined in the TABLE LIKE clause of the CREATE PROCEDURE statement.

The XDB Server operating environment does not currently provide this functionality.

USING DESCRIPTOR descriptor-name

Identifies an SQLDA that contains a valid description of the host variables that are to be passed as parameters to the stored procedure. If the stored procedure has no parameters, an SQLDA is ignored.

Before the CALL statement is processed, the user must set the following fields in the SQLDA:

  • SQLN to indicate the number of SQLVAR occurrences provided in the SQLDA. This number must not be less than SQLD. This field is not part of the REXX SQLDA and therefore does not need to be set for REXX programs.
  • SQLDABC to indicate the number of bytes of storage allocated for the SQLDA. This number must be not be less than SQLN*44+16. This field is not part of the REXX SQLDA and therefore does not need to be set for REXX programs.
  • SQLD to indicate the number of variables used in the SQLDA when processing the statement. This number must be the same as the number of parameters of the stored procedure.
  • SQLVAR occurrences to indicate the attributes of the variables.

Variable Usage

Each specification of a host-variable, constant or NULL is a parameter of the CALL statement. If USING DESCRIPTOR is specified, each host variable described by the identified SQLDA is a parameter of the CALL statement. The nth parameter of the CALL statement corresponds to the nth parameter of the stored procedure. When the CALL statement is executed, the number of parameters of the stored procedure and each pair of corresponding parameters must be consistent.

A description of each parameter describes how that parameter is used by the stored procedure. In addition to parameter attributes such as data type and length, the following information on each parameter is also stored in SYSIBM.SYSPROCEDURES:

  • IN: used only as an input value
  • OUT: used only as an output value
  • INOUT: used as both input and output value
Note:

When a trigger issues a CALL statement to invoke a stored procedure, the parameters that are specified in the CALL statement cannot be host variables and the USING DESCRIPTOR clause cannot be specified.

A program that is executing as a stored procedure, a user-defined function, or a trigger can issue a CALL statement. When a stored procedure, user-defined function, or trigger calls a stored procedure, user-defined function, or trigger, the call is considered to be nested. Stored procedures, user-defined functions, and triggers can be nested up to 16 levels deep on a single system. Nesting can occur within a single DB2 subsystem or when a stored procedure or user-defined function is invoked at a remote server.

If a stored procedure returns any query result sets, the result sets are returned to the caller of the stored procedure. If the SQL CALL statement is nested, the result sets are visible only to the program that is at the previous nesting level.

Some stored procedures cannot be nested. A stored procedure, user-defined function, or trigger cannot call a stored procedure that is defined with the COMMIT ON RETURN attribute. A stored procedure can call another stored procedure only if they execute in the same type of address space; they must both execute in a DB2-established address space or in a WLM-established address space.

Example:

The following CALL statement activates a stored procedure named alpha:

EXEC SQL CALL alpha (:P1, :A1, :ED1, :type, :code)
Parent topic: SQL Statements


CHECKPOINT

Invocation

CHECKPOINT is an executable command that can be issued interactively or embedded in a host language.

Authorization

SYSADM or higher authority is required to use the CHECKPOINT command.

Syntax

CHECKPOINT

Description

Under normal operating conditions CHECKPOINT commands are issued automatically by the logging system at regular time intervals (see lCheckpointFreq Parameter below). Some occasions, however, warrant issuing a CHECKPOINT command within SQLWizard as a precautionary measure. If you know (or suspect) that the server must be taken down, and you can still access SQLWizard, then issue a CHECKPOINT. This action minimizes crash recovery time when the server is brought back up.

lCheckpointFreq Parameter

One of the factors affecting the length of time needed to return location data objects to a logically consistent state after a transient system failure (for example, power outage, operating system failure) is the value of the lCheckpointFreq configuration parameter. Changing the value of this parameter (set in the [XDBLogManager] section of thexdbsrvco.ini file) allows the user to increase or decrease the time interval between automatic checkpoints issued by the logging system.

lCheckpointFreq is defaulted to a value of 300 seconds, which means that the logging system automatically performs a checkpoint every five minutes. If this checkpoint interval is adjusted upward, more time could be necessary for log recovery after a transient system failure. Conversely, a shorter checkpoint interval could reduce average recovery time, but increase system overhead. See the Server Administration Guide for more information on the lCheckpointFreq parameter.

Parent topic: SQL Statements


CLOSE

Invocation

CLOSE is an executable command that can only be embedded in a host language. CLOSE cannot be dynamically prepared.

Authorization

See Authorization under the DECLARE CURSOR command topic for the authorization required to use a cursor.

Syntax

CLOSE cursor-name

Parameters:

cursor-name: Identifies the cursor opened by a DECLARE CURSOR command.

Description

A CLOSE command is checked for all syntactical elements. The cursor must have been previously declared relative to the source program line in which CLOSE is encountered.

Example:

The following example (in the C language) declares a cursor named deptemp using the EMPLOYEE table, and then closes the cursor:

EXEC SQL
    DECLARE CURSOR deptemp FOR
        SELECT * FROM employee
            WHERE dept = :deptno
;....
EXEC SQL
    CLOSE deptemp;
Note: If the WITH HOLD option is not specified in the declaration of a cursor, then that cursor (when opened) is implicitly closed when a unit of work is terminated. Performance can be improved, however, by explicitly closing cursors as soon as possible. A CLOSE command does not necessarily commit or rollback system changes or updates (unless AUTOCOMMIT is on).
Parent topic: SQL Statements


COMMENT ON

Invocation

COMMENT ON is an executable command that can be issued interactively or embedded in a host language. COMMENT ON can be dynamically prepared.

Authorization

For a comment on a table, view, alias, index, or column, the privilege set that is defined below must include at least one of the following:

  • Ownership of the table, view, alias, or index
  • DBADM authority for its database (tables and indexes only)
  • SYSADM or SYSCTRL authority

For a comment on a distinct type, stored procedure, trigger, or user-defined function, the privilege set that is defined below must include at least one of the following:

  • Ownership of the distinct type, stored procedure, trigger, or user-defined function
  • The ALTERIN privilege on the schema (for the addition of comments)
  • SYSADM or SYSCTRL authority

For a comment on a plan or package, the privilege set that is defined below must include at least one of the following:

  • Ownership of the plan or package
  • SYSADM or SYSCTRL authority

For a comment on a sequence, the privilege set that is defined below must include at least one of the following:

  • Ownership of the sequence
  • The ALTER privilege for the sequence
  • The ALTERIN privilege on the schema
  • SYSADM or SYSCTRL authority

Syntax

COMMENT ON
{
TABLE {table-name | view-name}
    | COLUMN {table-name | view-name}.column-name
    | ALIAS alias-name
    | DISTINCT TYPE distinct-type-name
    | FUNCTION function-name [(parameter-type[,...])]
    | PROCEDURE procedure-name
    | SPECIFIC FUNCTION specific-name
    | TRIGGER trigger-name
    | PACKAGE collection-id.package-name [VERSION | version-id]
    | PLAN plan-name
    | PROCEDURE procedure-name
    | SEQUENCE sequence-name
}
IS string-constant

or:

COMMENT ON {table-name | view-name}
(column-name IS string-constant [,...])

Parameters:

table-name or view-name or alias-name | Identifies the table, view or alias affected.
column-name | Identifies the name of the column affected. When the COLUMN keyword is used, column names must be qualified with the name of the table or view that contains them.
string-constant | Specifies the comment you want to place in the system table. The string may be up to 254 characters in length, enclosed in double or single quotation marks.

Description

The COMMENT ON statement is used for adding a comment to, or replacing an existing comment in the REMARKS column of the SYSIBM.SYSCOLUMNS or SYSIBM.SYSTABLES table. These comments prove very useful in documenting the purpose of tables, views, columns and aliases, and may be selected using a SELECT command, and incorporated into application documentation. Remarks columns are defined as character fields, with a maximum length of 254 characters.

ALIAS alias-name

The ALIAS clause is used to comment on an alias. If you use the COMMENT ON ALIAS format, the comment is placed in the REMARKS column of the SYSIBM.SYSTABLES table, in the row describing the specified table or view.

COLUMN table-name.column-name or view-name.column-name

Identifies the column to which the comment applies. The name must identify a column of a table or view that exists at the current server. The name must not identify a column of a declared temporary table. The comment is placed into the REMARKS column of the SYSIBM.SYSCOLUMNS catalog table, for the row that describes the column.

Do not use TABLE or COLUMN to comment on more than one column in a table or view. Give the table or view name and then, in parentheses, a list in the form:

  • column-name IS string-constant,
  • column-name IS string-constant,...

The column names must not be qualified, each name must identify a column of the specified table or view, and that table or view must exist at the current server.

DISTINCT TYPE distinct-type-name

Identifies the distinct type to which the comment applies. distinct-type-name must identify a distinct type that exists at the current server.

The comment is placed in the REMARKS column of the SYSIBM.SYSDATATYPES catalog table for the row that describes the distinct type.

FUNCTION

Identifies the function to which the comment applies. The function must exist at the current server, and it must be a function that was defined with the CREATE FUNCTION statement or a cast function that was generated by a CREATE DISTINCT TYPE statement. The comment is placed in the REMARKS column of the SYSIBM.SYSROUTINES catalog table for the row that describes the function.

If the function was defined with a table parameter (the LIKE TABLE was specified in the CREATE FUNCTION statement to indicate that one of the input parameters is a transition table), the function signature cannot be used to identify the function. Instead, identify the function with its function name, if unique, or with its specific name.

FUNCTION function-name

Identifies the particular function, and is valid only if there is exactly one function with function-name.

FUNCTION function-name (parameter-type,...)

Provides the function signature, which uniquely identifies the function.

function-name | Identifies the name of the function.
(parameter-type,...) | Identifies the parameters of the function.

The data types of the parameters must match the data types that were specified on the CREATE FUNCTION statement in the

corresponding position. The number of data types and the logical concatenation of the data types are used to identify the specific function.

For data types that have a length, precision, or scale attribute, you can specify a value or use a set of empty parentheses:

  • Empty parentheses indicate that DB2 ignores the attribute when determining whether the data types match.

    FLOAT cannot be specified with empty parentheses because its parameter value indicates different data types (REAL or DOUBLE).

  • If you use a specific value for a length, precision, or scale attribute, the value must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.

    The specific value for FLOAT(n) does not have exactly match the defined value of the source function because 1<=n<= 21 indicates REAL and 22<=n<=53 indicates DOUBLE. Matching is based on whether the data type is REAL or DOUBLE.

  • If length, precision, or scale is not explicitly specified, and empty parentheses are not specified, the default length of the data type is implied. For example:

    CHAR CHAR(1)

    GRAPHIC GRAPHIC(1)

    DECIMAL DECIMAL(5,0)

    FLOAT DOUBLE (length of 8)

The implicit length must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.

For data types with a subtype or encoding scheme attribute, specifying the FOR DATA clause or CCSID clause is optional. Omission of either clause indicates that DB2 ignores the attribute when determining whether the data types match. If you specify either clause, it must match the value that was implicitly or explicitly specified in the CREATE FUNCTION statement.

SPECIFIC FUNCTION specific-name

Identifies the particular function using the specific name either specified or defaulted to when the function was created.

PROCEDURE procedure-name

Identifies the stored procedure to which the comment applies. procedure-name must identify a stored procedure that has been defined with the CREATE PROCEDURE statement at the current server. The comment is placed in the REMARKS column of the SYSIBM.SYSROUTINES catalog table for the row that describes the stored procedure.

TABLE table-name or view-name

Identifies the table or view to which the comment applies. table-name or view-name must identify a table, auxiliary table, or view that exists at the current server. table-name must not identify a declared temporary table. The comment is placed in the REMARKS column of the SYSIBM.SYSTABLES catalog table for the row that describes the table or view.

TRIGGER trigger-name

Identifies the trigger to which the comment applies. trigger-name must identify a trigger that exists at the current server. The comment is placed in the REMARKS column of the SYSIBM.SYSTRIGGERS catalog table for the row that describes the trigger.

PACKAGE collection-id.package-name

Identifies the package to which the comment applies. You must qualify the package name with a collection ID. collection-id.package-name must identify a package that exists at the current server. The name plus the implicitly or explicitly specified version-id must identify a package that exists at the current server. Omitting version-id is an implicit specification of the null version.

PLAN plan-name

Identifies the plan to which the comment applies. plan-name must identify a plan that exists at the current server.

PROCEDURE procedure-name

Identifies the stored procedure to which the comment applies. procedure-name must identify a stored procedure that has been defined with the CREATE PROCEDURE statement at the current server. The comment is placed in the REMARKS column of the SYSIBM.SYSROUTINES catalog table for the row that describes the stored procedure.

SEQUENCE sequence-name

Identifies the sequence to which the comment applies. The combination of name and implicit or explicit schema name must identify an existing sequence at the current server. If no sequence by this name exists in the explicitly or implicitly specified schema, an error occurs. sequence-name must not be the name of an internal sequence object that is generated by the system for an identity column. The comment is placed in the REMARKS column of the SYSIBM.SYSSEQUENCES catalog table for the row that describes the sequence.

IS string-constant

Introduces the comment that you want to make. string-constant can be any SQL character string constant of up to 254 characters.

Examples:

To place a comment on the PART table, use a command like:

COMMENT ON TABLE part
    IS "Information on all parts in use."

To place a comment on a view named redparts use a command like:

COMMENT ON TABLE redparts
    IS "View of parts table containing info on all red parts in use."

To place a comment on the CITY column of the SUPPLIER table, use a command like:

COMMENT ON COLUMN supplier.city
    IS "City where supplier is headquartered."

To place a comment on both the COMPANY and BALANCE columns of the CUSTOMER table, use the command below:

COMMENT ON customer
    (company IS "Corporate name of the client",
     balance IS "Outstanding as of last billing")
Parent topic: SQL Statements


COMMIT

Invocation

COMMIT is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared. COMMIT cannot be used in CICS or IMS environments.

Authorization

No special authorization is required.

Syntax

COMMIT [WORK]

Description

A transaction begins when a previous transaction ends or when logging begins (see the SET LOG command). A transaction is terminated by a COMMIT or ROLLBACK command.

Only the results of SQL commands executed within a single, uncommitted transaction are affected by the COMMIT command. When the COMMIT command is issued, all table changes caused by EXPLAIN, GRANT, REVOKE, COMMENT ON, LABEL ON, INSERT, UPDATE, and DELETE commands in the transaction are made permanent, and can no longer be rolled back (the CREATE, DROP and ALTER commands can never be rolled back).All savepoints that were set within the transaction are released

In DB2 mode, open cursors declared without the WITH HOLD option are closed and any statements prepared for those cursors are destroyed. All open cursors declared with the WITH HOLD option are preserved, along with any statements that were prepared for these cursors. In XDB mode, all cursors remain open at commit time.

For existing connections, all LOB locators are disassociated, except for those locators for which a HOLD LOCATOR statement has been issued without a corresponding FREE LOCATOR statement.

All implicitly acquired locks are released, except:

  • Locks that are required for the cursors that were not closed
  • Table and table space locks when the RELEASE parameter on the bind command was not RELEASE(COMMIT)
  • LOB locks and LOB table space locks that are required for held LOB locators

An implicit COMMIT is always performed when exiting from the current session. All locks acquired during a transaction are released by the COMMIT command.

All rows of every declared temporary table of the application process are deleted with these exceptions:

  • The rows of a declared temporary table that is defined with the ON COMMIT PRESERVE ROWS atttribute are not deleted.
  • The rows of a declared temporary table that is defined with the ON COMMIT DELETE ROWS attribute are not deleted if any program in the application process has an open WITH HOLD cursor that is dependent on that table.

The optional keyword WORK is provided for compatibility with the SAA definition of SQL, and is available in DB2. COMMIT and COMMIT WORK perform identically.

Parent topic: SQL Statements


COMPACT

Invocation

This command can be embedded in a host language or executed interactively.

Authorization

No special authorization is required.

Syntax

COMPACT
{
    LOCATION [AND INDEX] [NO CLUSTER] [NOSTOP] [RULES DB2]|
    DIRECTORIES |
    TABLE table-name [AND INDEXES] [NO CLUSTER] [RULES DB2]|
    TABLES [LIKE pattern] [IN DATABASE db-name] [NOSTOP] [CLUSTER BY INDEX index-name] [RULES DB2]|
    INDEXES [LIKE pattern] [IN DATABASE db-name] [NOSTOP]
}
Note:

Keyword order is significant. When used, keywords must appear in the order specified below.

Parameters:

table-name | Identifies the name of the table that you want to compact.
index-name | Identifies the name of a table index that determines the physical order of records in the table.
db-name | Identifies the name of the database that you want to compact.
pattern | Defines pattern-matching criteria for a 2-part table name (use same pattern-matching syntax as for the LIKE Operator). For example, SYS%.SYSC% and SALES%.%.

Description

XDB Server locations consist of table, index and dictionary files. When these object are altered or deleted, the files may become disorganized, increasing the amount of space occupied and the amount of time required to perform searches. To optimize table and dictionary file structures, you can pack specific location objects using the COMPACT command.

During processing, the COMPACT command must create a temporary copy of the specified file(s).. If the size of the largest file exceeds the free space on the storage device you are using, an error results, and the object being packed is restored to its original condition.

LOCATION

If the keyword LOCATION appears in the command syntax, the entire location is packed (including all tables and dictionary files), and all location indexes rebuilt. If a clustered index exists on a table, then the records in that table are also reclustered (swapped so they are arranged in the same physical order as the clustering index), unless the NO CLUSTER option is specified.

Use the RULES DB2 clause to pad char fields (non-FOR BIT DATA only) with blank characters during the compacting process. This option is useful for converting tables initially populated in XDB mode to standard DB2 format for character data.

Use the NOSTOP clause to enable the XDB Server to continue processing after an error. Without the NOSTOP clause, the server stops executing the COMPACT command as soon as it encounters the first error. With the NOSTOP clause, if the server encounters an error as it processes a table, it writes the error to a trace file then continues packing the next table. This option is useful for performing a COMPACT in unattended mode.

Note: We strongly recommend that you make a backup copy of the location to be compacted before executing the COMPACT LOCATION command.

DIRECTORIES

The keyword DIRECTORIES packs only location dictionary files to remove information about deleted data objects. Table and index files are not affected.

TABLE

The TABLE keyword is used to compact a single table. The optional AND INDEXES and NO CLUSTER clauses function the same on a single table as with multiple tables (when using the TABLES keyword).

The optional CLUSTER BY INDEX clause is used to physically reorder the table records according to the index-name specified. The CLUSTER BY INDEX and NO CLUSTER clauses are mutually exclusive. If you use both CLUSTER BY INDEX and NO CLUSTER, the NO CLUSTER clause is ignored.

Use the RULES DB2 clause to pad char fields (non-FOR BIT DATA only) with blank characters during the compacting process. This option is useful for converting tables initially populated in XDB mode to standard DB2 format for character data.

TABLES

If the keyword TABLES appears without the AND INDEXES clause, only the table files within the current location are compacted. Indexes are rebuilt only if a table contains deleted records. If a table contains deleted records and a clustered index, then the clustered index is rebuilt and the table records reordered (unless the NO CLUSTER clause is added).

Including the optional AND INDEXES clause forces all table indexes in the location (including all primary, unique and foreign keys) to be dropped and rebuilt. All tables with clustered indexes are therefore reclustered, unless the NO CLUSTER clause is specified.

Use the NOSTOP clause to enable the XDB Server to continue processing after an error. Without the NOSTOP clause, the server stops executing the COMPACT command as soon as it encounters the first error. With the NOSTOP clause, if the server encounters an error as it processes a table, it writes the error to a trace file then continues packing the next table. This option is useful for performing a COMPACT in unattended mode.

Use the RULES DB2 clause to pad char fields (non-FOR BIT DATA only) with blank characters during the compacting process. This option is useful for converting tables initially populated in XDB mode to standard DB2 format for character data.

INDEXES

The INDEXES keyword rebuilds location indexes only and leaves the tables alone. If clustered indexes exist on any tables, those tables are reclustered unless NO CLUSTER is specified.

Use the NOSTOP clause to tell the XDB Server to automatically continue to with the next index when an error occurs in the one it is processing. (If this option is not used, the entire process terminates immediately on error.) COMPACT writes the error to a trace file (XDBTRACE.OUT) before continuing to the next index. This option is useful for performing a COMPACT in unattended mode.

Example:

To compact the CUSTOMER table use the command:

COMPACT TABLE customer

To compact only the dictionary files of the current location, use the command:

COMPACT DIRECTORIES

To compact the entire current location, including the dictionary files and all tables, use the command:

COMPACT LOCATION

To compact the EMPLOYEE table, and physically reorder the records by PAYRATE column values (assuming the index payidx has already been built on the PAYRATE column of the EMPLOYEE table) use the following command:

COMPACT TABLE employee CLUSTER BY INDEX payidx

If the payidx index was built as a clustered index the command:

COMPACT TABLE employee

could be used without the explicit CLUSTER BY INDEX clause.

To rebuild all indexes that exist on the EMPLOYEE table, issue the command:

COMPACT TABLE employee AND INDEX

To compact all tables in the current location, issue the command:

COMPACT TABLES

To compact all indexes in the current log, issue the command:

COMPACT INDEXES

To compact all XDB Server system tables, issue the command:

COMPACT TABLES LIKE SYSXDB%.%
Parent topic: SQL Statements


CONNECT

Invocation

CONNECT is an executable statement that can only be embedded in an application program. It cannot be dynamically prepared.

Authorization

The primary AuthID for the application process must be authorized to connect to the specified location. The specific AuthID required is determined by that location, with the authorization check also performed by that location.

Syntax

CONNECT
    [TO {location-name | host-variable}]
    [RESET]

Parameters:

location-name | Identifies a specific XDB Server system location.
host-variable | Names a host variable name containing a location name.

Description

The CONNECT statement is the embedded SQL equivalent of the interactive SET LOCATION TO command. The CONNECT statement connects an application process to a designated location or a host-variable containing a location name. When the CONNECT statement is executed, the location name must be known to the local XDB Server running the application, or the location name must appear in the LOCATION column of the SYSIBM.SYSLOCATIONS catalog within the SYSTEM location.

Host variables must conform to the following requirements:

  • Must be a character string variable with a length attribute of at least 16 characters.
  • Must be preceded by a colon and not be followed by an indicator variable.
  • Within the host variable, the location name must be left-justified and conform to the rules for forming an ordinary location identifier.
  • If the location name length is less than the length of the host variable, the remainder of the host variable must be padded on the right with blanks.

If the CONNECT statement execution is successful:

  • The application process is connected to the identified location.
  • The CURRENT SERVER special register is updated to contain the specified location name.
  • The SQLERRP field of the SQLCA is set to contain information about the location. This information has the format pppvvrrm, where:
    ppp | identifies the product (for example, XDB or DB2)
    vv | contains a two-digit version identifier (for example, '04')
    rr | contains a two-digit release identifier (for example, '00')
    m | is a one-letter operating system indicator as follows:
    D

    DOS

    N

    Windows NT

    O

    OS/2

    For example, if running XDB Server for OS/2, the SQLERRP is XDB0400O.

Examples:

The following code excerpt connects the application process to the system location:

EXEC SQL
    CONNECT TO system;

To connect the application to a location named in the host variable nameloc, execute the following command:

EXEC SQL
    CONNECT TO :nameloc;

The XDB Server implements the CONNECT command identically to DB2, except that the XDB Server improves performance by leaving the old location open after connecting with the new location.

CONNECT RESET

The CONNECT RESET statement is equivalent to a CONNECT TO specifying the local XDB Server location.

Note:

Issuing this command is the only way to get back to an XDB Server location after connecting to a DB2 subsystem through the XDB Link.

CONNECT

The keyword CONNECT by itself returns information about the currently set XDB Server location. This information is placed in the SQLERRP field of the application SQLCA.

Note:

The initial server of an application process is the currently set XDB Server location. An explicit or implicit execution of a CONNECT [TO] statement can establish a different location. A CONNECT [TO] statement directed to the currently set location is treated like any other CONNECT [TO]. The CURRENT SQLID special register is not reinitialized when CONNECT [TO] is used to connect back to the currently set location.

Parent topic: SQL Statements


CREATE ALIAS

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

To execute the CREATE ALIAS command, you must possess either the CREATEALIAS privilege, or overall SYSADM or SYSCTRL authority for the location. If the alias-name specified includes an authorization name qualifier that does not match the AuthID, the privilege set must include SYSADM or SYSCTRL authority for the location. When the specified alias-name includes an authorization name qualifier that does not match the process AuthID, any authorization name qualifier is valid, if the application process privilege set includes SYSADM or SYSCTRL authority.

Syntax

CREATE ALIAS alias-name
    FOR {table-name | view-name}

Parameters:

alias-name | Names the alias, and must not match the name of any table, view, alias, or synonym that already exists at the currently set location.
table-name or view-name | Identifies the table or view for which the alias is defined. If a table is identified, it must not be an auxiliary table or a declared temporary table. The table or view need not exist at the time the alias is defined. If it does exist, it can be at the current server or at another server. The name must not be the same as the alias name and must not identify an alias that exists at the current server.

Description

The alias name can be either a one-part, two-part or three-part qualified name (location-name.AuthID.alias-name). The AuthID qualifier within alias-name identifies the alias owner. If the CREATE ALIAS statement is dynamically prepared and the alias name is unqualified, the application process AuthID becomes the alias owner.

The table or view need not exist when the CREATE ALIAS statement is executed. Already defined tables or views can exist at either the currently set location or a different location. The table or view name must not match the alias name, and must not match any other alias names described in the catalog at the current XDB Server location.

An alias can be defined for a table, view or other alias whose name does not exist under the current XDB Server location. In this case, the existence of the referenced object is not verified by the XDB Server when the alias is created. The XDB Server can detect an alias specified for a location other than the current location. In these cases, the full three-part name that the alias references is substituted in the query for the alias name. The new query is then sent to the location specified in the three-part name.

Example:

The following example creates an alias called bob, and then uses that alias in a query:

CREATE ALIAS bob FOR tutorial.tutorial.customer

When the query shown below references bob, the three-part name value defined above is substituted, and the query sent to the TUTORIAL location.

SELECT * FROM bob
  • CREATE ALIAS Example
Parent topic: SQL Statements


CREATE ALIAS Example

The following example creates an alias called bob, and then uses that alias in a query:

CREATE ALIAS bob FOR tutorial.tutorial.customer

When the query shown below references bob, the three-part name value defined above is substituted, and the query sent to the TUTORIAL location.

SELECT * FROM bob
Parent topic: CREATE ALIAS


CREATE AUXILIARY TABLE

Invocation

Do not use this statement if the value of special register CURRENT RULES is 'STD' when the statement is executed. When the register's value is 'STD' and a base table is created with LOB columns or altered such that LOB columns are added, DB2 automatically creates the LOB table space, auxiliary table, and index on the auxiliary table for each LOB column. DB2 chooses the names and characteristics of these objects.

This statement can be embedded in an application program or issued interactively if the value of special register CURRENT RULES is 'DB2' when the statement is executed.

Authorization

The privilege set that is defined below must include at least one of the following:

  • The CREATETAB privilege for the database implicitly or explicitly specified by the IN clause
  • DBADM, DBCTRL, or DBMAINT authority for the database
  • SYSADM or SYSCTRL authority

Privilege set

If the statement is embedded in an application program, the privilege set is the privileges that are held by the authorization ID of the owner of the plan or package. If the specified table name includes a qualifier that is not the same as this authorization ID, the privilege set must include SYSADM or SYSCTRL authority, DBADM authority for the database, or DBCTRL authority for the database.

If the statement is dynamically prepared, the privilege set is the privileges that are held by the SQL authorization ID of the process. However, if the specified table name includes a qualifier that is not the same as this authorization ID, the following rules apply:

  1. If the privilege set includes SYSADM or SYSCTRL authority, DBADM authority for the database, or DBCTRL authority for the database, any qualifier is valid.
  2. If the privilege set does not include any of the authorities listed in item 1 above, the qualifier is valid only if it is the same as one of the authorization IDs of the process and the privilege set that are held by that authorization ID includes all privileges needed to create the table.

Syntax

CREATE {AUXILIARY | AUX} TABLE aux-table-name
    IN [database-name] table-space-name STORES table-name
    COLUMN column-name [PART integer]

Parameters:

aux-table-name Names the auxiliary table. The name must not identify a table, view, alias, or synonym that exists at the current server.

If qualified, the name can be a two-part or three-part name. If a three-part name is used, the first part must match the value of field DB2 LOCATION NAME on installation panel DSNTIPR at the current server. (If the current server is not the local DB2, this name is not necessarily the name in the CURRENT SERVER special register.) Whether the name is two-part or three-part, the authorization ID that qualifies the name is the table's owner.

If the table name is unqualified and the statement is embedded in a program, the owner of the table is the authorization ID that serves as the implicit qualifier for unqualified object names. This is the authorization ID in the QUALIFIER operand when the plan or package was created or last rebound. If QUALIFIER was not used, the owner of the table is the owner of the package or plan.

If the table name is unqualified and the statement is dynamically prepared, the SQL authorization ID is the owner of the table.

IN database-name.table-space-name or IN table-space-name Identifies the table space in which the auxiliary table is created. The name must identify an empty LOB table space that currently exists at the current server.

If you specify a database and a table space, the table space must belong to the specified database. If you specify only a table space, it must belong to database DSNDB04.

Description

AUXILIARY or AUX

Specifies a table that is used to store the LOB data for a LOB column (or a column with a distinct type that is based on a LOB data type).

STORES table-name COLUMN column-name

Identifies the base table and the column of that table that is to be stored in the auxiliary table. If the base table is nonpartitioned, an auxiliary table must not already exist for the specified column. If the base table is partitioned, an auxiliary table must not already exist for the specified column and specified partition.

The encoding scheme for the LOB data stored in the auxiliary table is the same as the encoding scheme for the base table. It is either ASCII or EBCDIC depending on the value of the CCSID clause when the base table was created.

The auxiliary table can store a BLOB, CLOB, or DBCLOB value that is greater than 1 gigabyte in length only if the LOB table space for the auxiliary table was defined with LOG NO.

PART integer

Specifies the partition of the base table for which the auxiliary table is to store the specified column. You can specify PART only if the base table is defined in a partitioned table space, and no other auxiliary table exists for the same LOB column of the base table.

Note:

The number of auxiliary tables to create depends on the number of LOB columns in the base table and whether the base table is partitioned. If the base table is nonpartitioned, you need one LOB table space and one auxiliary table for each LOB column in the base table. If the base table is partitioned, you need one LOB table space and one auxiliary table for each partition for each LOB column. For example if the base table has four partitions and two LOB columns, you need to create a total of eight auxiliary tables in eight different LOB table spaces.

Example:

Assume that a column named EMP_PHOTO with a data type of BLOB(110K) has been added to sample employee table DSN8610.EMP for each employee's photo. Create auxiliary table EMP_PHOTO_ATAB to store the BLOB data for the BLOB column in LOB table space DSN8D61A.PHOTOLTS.

CREATE AUX TABLE EMP_PHOTO_ATAB
    IN DSN8D61A.PHOTOLTS
    STORES DSN8610.EMP
    COLUMN EMP_PHOTO;
Parent topic: SQL Statements


CREATE DATABASE

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

To execute the CREATE DATABASE command, you must possess either CREATEDBA or CREATEDBC privileges, or overall SYSADM or SYSCTRL authority for the location.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

CREATE DATABASE database-name
    [BUFFERPOOL bpname]
    [INDEXBP bpname]
    [ROSHARE {OWNER | READ}]
    [AS {WORKFILE | TEMP} [FOR member-name]]
    [STOGROUP stogroup-name]
    [CCSID {ASCII | EBCDIC | UNICODE}]

Parameters:

database-name | Names the new database, which must not already exist at the current location.
bpname | A name that identifies a bufferpool. The 4K bufferpools are named BP0, BP1, BP2...BP49. The 32K bufferpools are named BP32K, BP32K1, BP32K2...BP32K9.
member-name | The name of the DB2 subsystem that the database will become part of.
stogroup-name | Identifies a user-defined XDB Server stogroup (drive and path) where database files can be stored.

Description

The CREATE DATABASE command creates a logical database the current XDB Server location. If a subdirectory for the database does not exist and a stogroup is not specified, a new subdirectory is created under the current location path (with the subdirectory taking on the name of the newly created database). The creator of a database is given DBADM authority for the database.

The CREATE DATABASE command has been enhanced to reflect the new XDB Server system architecture. The BUFFERPOOL clause (DB2-mainframe only) along with the ROSHARE and STOGROUP clauses have been added. The ROSHARE clause is used to create XDB Server read-only shared (ROSHARE) databases, while the STOGROUP clause allows you to store database objects within a user defined XDB Server stogroup (or directory path).

With DB2 V7, XDB locations (either EBCDIC or ASCII) can now contain Unicode data. If you create a database with CCSID UNICODE, all character data in corresponding tables is stored in UTF-8 format and all graphic data is stored in UTF-16 format.

BUFFERPOOL bpname

This clause has no functional equivalent within the XDB Server operating environment. However, for DB2 compatibility purposes, The XDB Server records any of the sixty possible bufferpools (BP0...BP49, and BP32K, BP32K1...BP32K9). The first fifty bufferpools are for tables with 4K page sizes, while the last ten are for tables with 32K page sizes. Although not functionally supported, this new information is semantically checked and recorded in the XDB Server system catalog tables.

Specifies the default buffer pool name to be used for table spaces created within the database. If the database is a work file database, 8KB and 16KB buffer pools cannot be specified.

If you omit the BUFFERPOOL clause, the buffer pool specified for user data on installation panel DSNTIP1 is used. The default value for the user data field on that panel is BP0.

INDEXBP bpname

Specifies the default buffer pool name to be used for the indexes created within the database. The name must identify a 4KB buffer pool.If the database is a work file database, INDEXBP cannot be specified.

If you omit the INDEXBP clause, the buffer pool specified for user indexes on installation panel DSNTIP1 is used. The default value for the user indexes field on that panel is BP0.

AS WORKFILE or AS TEMP

Indicates that this is a work file database or a database for declared temporary tables (a TEMP database).

AS WORKFILE | Specifies the database is a work file database. AS WORKFILE can be specified only in a data sharing environment. Only one work file database can be created for each DB2 member.
AS TEMP | Specifies the database is for declared temporary tables only. AS TEMP must be specified to create a database that will be used for declared temporary tables; otherwise, the database will not be used for declared temporary tables. Only one TEMP database can be created for each DB2 subsystem or data sharing member. A TEMP database cannot be shared between DB2 subsystems or data sharing members. PUBLIC implicitly receives the CREATETAB privilege (without GRANT authority) to define a declared temporary table in the TEMP database. This implicit privilege is not recorded in the DB2 catalog and cannot be revoked.

FOR member-name

Specifies the member for which this database is to be created. Specify FOR member-name only in a data sharing environment.

If FOR member-name is not specified, the member is the DB2 subsystem on which the CREATE DATABASE statement is executed.

ROSHARE

This optional clause is used for the creation of read-only shared (or ROSHARE) databases. The OWNER keyword identifies the database as the owner created and controlled database, while the READ keyword identifies a reading (or dummy) database that can only read (or SELECT) data from the owner database.

STOGROUP

Identifies an optional XDB Server-created stogroup where database objects (tables, indexes, views, etc.) can be stored (stogroups allow you to define a path for storing data). To use the defined stogroup, first modify the special XDBPRIMEVOLPATH and XDBVOLPATH column values in the SYSIBM.SYSVOLUMES table to associate the stogroup's VOLID column value with the stogroup path (see CREATE STOGROUP command summary). If a stogroup is specified when creating the database, the XDB Server does not create a database subdirectory under the current location path, but uses the stogroup path instead.

If the optional STOGROUP clause is omitted, the stogroup associated with the new database defaults to SYSDEFLT -- a system default, not representing any physical storage entity on the XDB Server. This omission of a stogroup name causes the XDB Server to create a new database subdirectory under the currently set location directory path, with this information being recorded within the current location system tables.

CCSID

The CCSID clause is only syntactically supported for EBCDIC and ASCII. This is because the definition of the XDB location itself defines how character data is stored.

If you specify UNICODE, your character and graphic data is stored as UNICODE within the database.

Examples:

Create database DSN8D61P. Specify DSN8G610 as the default storage group to be used for the table spaces and indexes in the database. Specify 8KB buffer pool BP8K1 as the default buffer pool to be used for table spaces in the database, and BP2 as the default buffer pool to be used for indexes in the database.

CREATE DATABASE DSN8D61P
    STOGROUP DSN8G610
    BUFFERPOOL BP8K1
    INDEXBP BP2;

Create database DSN8TEMP. Use the defaults for the default storage group and default buffer pool names. Specify ASCII as the default encoding scheme for data stored in the database.

CREATE DATABASE DSN8TEMP
    CCSID ASCII;
Parent topic: SQL Statements


CREATE DISTINCT TYPE

  • A function to cast between the distinct type and its source type
  • A function to cast between the source type and its distinct type
  • As appropriate, support for the use of comparison operators with the distinct type

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

The privilege set that is defined below must include at least one of the following:

  • The CREATEIN privilege for the schema or all schemas
  • SYSADM or SYSCTRL authority

The authorization ID that matches the schema name implicitly has the CREATEIN privilege on the schema.

Privilege set

If the statement is embedded in an application program, the privilege set is the privileges that are held by the authorization ID

of the owner of the plan or package.

If the statement is dynamically prepared, the privilege set is the privileges that are held by the SQL authorization ID of the process. The specified distinct type name can include a schema name (a qualifier). However, if the schema name is not the same as the SQL authorization ID, one of the following conditions must be met:

  • The privilege set includes SYSADM or SYSCTRL authority.
  • The SQL authorization ID of the process has the CREATEIN privilege on the schema.

Syntax

CREATE DISTINCT TYPE distinct-type-name AS source-data-type
    [WITH COMPARISONS]

source-data-type:

SMALLINT |
{INTEGER | INT} |
{DECIMAL | DEC | NUMERIC} [integer[,...]] |
{FLOAT [integer] | REAL [PRECISION] | DOUBLE} |
{ {CHARACTER | CHAR} [(integer)] |
  {CHARACTER | CHAR} VARYING (integer) |
  VARCHAR (integer) }
[FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII}] |
{{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(integer [K|M|G])] }
[FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII}] } |
{BINARY LARGE OBJECT | BLOB} (integer [K|M|G]) |
{GRAPHIC [(integer)] | VARGRAPHIC (integer) | DBCLOB (integer [K|M|G])} [CCSID {EBCDIC | ASCII}]|
{DATE | TIME | TIMESTAMP} |
ROWID

Description

distinct-type-name

Names the distinct type. The name is implicitly or explicitly qualified by a schema name. The name, together with the implicit or explicit schema name, must not identify a distinct type that exists at the current server.

The unqualified form of distinct-type-name is a long SQL identifier.

distinct-type-name must not be the name of a built-in data type, BOOLEAN, or any of following system-reserved keywords even if you specify them as delimited identifiers:

ALL | LIKE | UNIQUE
AND | MATCH | UNKNOWN
ANY | NOT | =
BETWEEN | NULL | ¬=
DISTINCT | ONLY | <
EXCEPT | OR | <=
EXISTS | OVERLAPS | ¬<
FALSE | SIMILAR | >
FOR | SOME | >=
FROM | TABLE | ¬>
IN | TRUE | <>
IS | TYPE |

The unqualified name is implicitly qualified with a schema name according to the following rules:

  • If the CREATE DISTINCT TYPE statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not specified, the schema name is the owner of the plan or package.
  • If the CREATE DISTINCT TYPE statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

The qualified form of distinct-type-name is a short SQL identifier (the schema name) followed by a period and a long SQL identifier.

The schema name can be 'SYSTOOLS' if the user who executes the CREATE statement has SYSADM or SYSCTRL privilege. Otherwise, the schema name must not begin with 'SYS' unless the schema name is 'SYSADM'.

The owner of the distinct type is determined by how the CREATE DISTINCT TYPE statement is invoked:

  • If the statement is embedded in a program, the owner is the authorization ID of the owner of the plan or package.
  • If the statement is dynamically prepared, the owner is the SQL authorization ID in the CURRENT SQLID special register.

Although the information is not recorded in the catalog, the owner is given the USAGE privilege on the distinct type. The owner is also given the EXECUTE privilege with the GRANT option on each of the generated cast functions.

source-data-type

Specifies the data type that is used as the basis for the internal representation of the distinct type. The data type must be a built-in data type. You can use any of the built-in data types that are allowed for the CREATE TABLE statement except LONG VARCHAR or LONG VARGRAPHIC. Use VARCHAR or VARGRAPHIC with an explicit length instead.

If you do not specify a specific value for the data types that have length, precision, or scale attributes (CHAR, GRAPHIC, DECIMAL, NUMERIC, FLOAT), the defaults are as follows:

CHAR | CHAR(1)
GRAPHIC | GRAPHIC(1)
DECIMAL | DECIMAL(5,0)
FLOAT | DOUBLE (length of 8)

If the distinct type is sourced on a character string data type, the FOR clause indicates the subtype. If you do not specify the FOR clause, the distinct type is defined with the default subtype. The default is SBCS when the value of field MIXED DATA on installation panel DSNTIPF is NO. The default is MIXED when the value is YES.

If the distinct type is sourced on a string data type, the CCSID clause indicates whether the encoding scheme of the data is ASCII or EBCDIC. If you do not specify CCSID ASCII or CCSID EBCDIC, the encoding scheme is the value of field DEF ENCODING SCHEME on installation panel DSNTIPF.

WITH COMPARISONS

Specifies that system-generated comparison operators are to be created for comparing two instances of the distinct type. Do not specify WITH COMPARISONS if the source data type is BLOB, CLOB, or DBCLOB; otherwise, a warning occurs and the comparison operators are not generated. You must specify WITH COMPARISONS for all other source data types.

DB2 implicitly creates comparison functions for the following comparison operators for use with the distinct type:

BETWEEN | IS NULL | < | ¬<
NOT BETWEEN | IS NOT NULL | > | ¬>
IN | = | <= | >=
NOT IN | ¬= | <>

The name of the function is the same as the comparison operator. You cannot invoke the comparison functions using function notation syntax, for example, '<'(C1,C2). Instead, use the syntax C1 < C2.

You must not specify the comparison operations for distinct types that are sourced on a CLOB, BLOB, or DBCLOB, or that have a length greater than 255 bytes. (Distinct types that are sourced on a VARCHAR or VARGRAPHIC can have a length greater than 255 bytes).

Source data types with DBCS or mixed data

If you specify a GRAPHIC source type and the ASCII encoding scheme, or a string source type with a mixed data subtype (FOR MIXED DATA), the value of field FOR MIXED DATA on installation panel DSNTIPF must be YES; otherwise, an error occurs. In addition, to create a distinct type on a GRAPHIC data type, the corresponding CCSID must be defined for the implicitly or explicitly specified encoding scheme.

Generated cast functions

The successful execution of the CREATE DISTINCT TYPE statement causes DB2 to generate the following cast functions:

  • A function to convert from the distinct type to its source data type
  • A function to convert from the source data type to the distinct type
  • A function to cast from a data type A to distinct type DT, where A is promotable to the source data type S of distinct type DT

For some source data types, DB2 supports an additional function to convert from:

  • INTEGER to the distinct type if the source type is SMALLINT
  • VARCHAR to the distinct type if the source type is CHAR
  • VARGRAPHIC to the distinct type if the source type is GRAPHIC
  • DOUBLE to the distinct type if the source type is REAL

The cast functions are created as if the following statements were executed:

CREATE FUNCTION source-type-name (distinct-type-name)
    RETURNS source-type-name ...
CREATE FUNCTION distinct-type-name (source-type-name)
    RETURNS distinct-type-name ...

Even if you specified a length, precision, or scale for the source data type in the CREATE DISTINCT TYPE statement, the name of the cast function that converts from the distinct type to the source type is simply the name of the source data type. The data type of the value that the cast function returns includes any length, precision, or scale values that you specified for the source data type.

The name of the cast function that converts from the source type to the distinct type is the name of the distinct type. The input parameter of the cast function has the same data type as the source data type, including the length, precision, and scale.

For example, assume that a distinct type named T_SHOESIZE is created with the following statement:

CREATE DISTINCT TYPE CLAIRE.T_SHOESIZE AS VARCHAR(2) WITH COMPARISONS

When the statement is executed, DB2 also generates the following cast functions. VARCHAR converts from the distinct type to the source type, and T_SHOESIZE converts from the source type to the distinct type.

FUNCTION CLAIRE.VARCHAR (CLAIRE.T_SHOESIZE) RETURNS SYSIBM.VARCHAR (2)
FUNCTION CLAIRE.T_SHOESIZE (SYSIBM.VARCHAR (2)) RETURNS CLAIRE.T_SHOESIZE

Notice that function VARCHAR returns a value with a data type of VARCHAR(2) and that function T_SHOESIZE has an input parameter with a data type of VARCHAR(2).

The schema of the generated cast functions is the same as the schema of the distinct type. No other function with the same name and function signature must already exist in the database.

In the preceding example, if T_SHOESIZE had been sourced on a SMALLINT, CHAR, or GRAPHIC data type instead of a VARCHAR data type, another cast function would have been generated in addition to the two functions to cast between the distinct type and the source data type. For example, assume that T_SHOESIZE is created with this statement:

CREATE DISTINCT TYPE CLAIRE.T_SHOESIZE AS CHAR(2) WITH COMPARISONS

When the statement is executed, DB2 generates these cast functions:

FUNCTION CLAIRE.CHAR (CLAIRE.T_SHOESIZE) RETURNS SYSIBM.CHAR (2)
FUNCTION CLAIRE.T_SHOESIZE (SYSIBM.CHAR (2)) RETURNS CLAIRE.T_SHOESIZE
FUNCTION CLAIRE.T_SHOESIZE (SYSIBM.VARCHAR (2)) RETURNS CLAIRE.T_SHOESIZE

Notice that the third function enables the casting of a VARCHAR(2) to T_SHOESIZE. This additional function is created to enable casting a constant, such as 'AB', directly to the distinct type. Without the additional function, you would have to first cast 'AB', which has a data type of VARCHAR, to a data type of CHAR and then cast it to the distinct type.

You cannot explicitly drop a generated cast function. The cast functions that are generated for a distinct type are implicitly dropped when the distinct type is dropped with the DROP statement.

Built-in functions

When a distinct type is defined, the built-in functions (such as AVG, MAX, and LENGTH) are not automatically supported for the distinct type. You can use a built-in function on a distinct type only after a sourced user-defined function, which is based on the built-in function, has been created for the distinct type.

Example:

Create a distinct type named SHOESIZE that is sourced on an INTEGER data type.

CREATE DISTINCT TYPE SHOESIZE AS INTEGER WITH COMPARISONS;

The successful execution of this statement also generates two cast functions. Function INTEGER(SHOESIZE) returns a value with data type INTEGER, and function SHOESIZE(INTEGER) returns a value with distinct type SHOESIZE.

Create a distinct type named MILES that is sourced on a DOUBLE data type.

CREATE DISTINCT TYPE MILES AS DOUBLE WITH COMPARISONS;

The successful execution of this statement also generates two cast functions. Function DOUBLE(MILES) returns a value with data type DOUBLE, and function MILES(DOUBLE) returns a value with distinct type MILES.

Parent topic: SQL Statements


CREATE FUNCTION

External Scalar

CREATE FUNCTION (external scalar)

The function is written in a programming language and returns a scalar value. The external executable is registered with an application server along with various attributes of the function.

External Table

CREATE FUNCTION (external table)

The function is written in a programming language and returns a complete table. The external executable is registered with an application server along with various attributes of the function.

Sourced

CREATE FUNCTION (sourced)

The function is implemented by invoking another function (either built-in, external, or sourced) that is already registered with an application server.

Parent topic: SQL Statements


CREATE FUNCTION (external scalar)

A scalar function returns a single value each time it is invoked.

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

The privilege set defined below must include at least one of the following:

  • The CREATEIN privilege for the schema or all schemas
  • SYSADM or SYSCTRL authority

The authorization ID that matches the schema name implicitly has the CREATEIN privilege on the schema.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

CREATE FUNCTION function-name ([parameter-declaration[,...]])
RETURNS {data-type2 [AS LOCATOR] |
    data-type3 CAST FROM data-type4 [AS LOCATOR]} option-list

option-list:

[SPECIFIC specific-name]
[EXTERNAL [NAME {'string' | identifier}] LANGUAGE {ASSEMBLE | C | COBOL | PLI}]
[PARAMETER STYLE DB2SQL [DETERMINISTIC | NOT DETERMINISTIC] [FENCED]]
[RETURNS NULL ON NULL INPUT | CALLED ON NULL INPUT]
[READS SQL DATA | NO SQL | MODIFIES SQL DATA | CONTAINS SQL]
[EXTERNAL ACTION | NO EXTERNAL ACTION]
[NO SCRATCHPAD | SCRATCHPAD [100 | length]]
[FINAL CALL | NO FINAL CALL]
[ALLOW PARALLEL | DISALLOW PARALLEL]
[DBINFO | NODBINFO]
[NO COLLID | COLLID collection-id]
[WLM ENVIRONMENT {name | (name)}]
[ASUTIME NO LIMIT | ASUTIME LIMIT integer]
[STAY RESIDENT NO | STAY RESIDENT YES]
[PROGRAM TYPE SUB | PROGRAM TYPE MAIN]
[SECURITY DB2 | SECURITY {USER | DEFINED}]
[STOP AFTER SYSTEM DEFAULT FAILURES |
 STOP AFTER integer FAILURES |
 CONTINUE AFTER FAILURE]
[INHERIT SPECIAL REGISTERS | DEFAULT SPECIAL REGISTERS]
[RUN OPTIONS run-time-options]

parameter-declaration:

[parameter-name] parameter-type

parameter-type:

{data-type [AS LOCATOR] | TABLE LIKE {table-name | view-name} [AS LOCATOR]}

data-type:

{built-in-data-type | distinct-type-name}

built-in-data-type:

SMALLINT |
{INTEGER | INT} |
{DECIMAL | DEC | NUMERIC} [integer[,...]] |
{FLOAT [integer] | REAL [PRECISION] | DOUBLE} |
{ {CHARACTER | CHAR} [(integer)] |
    {CHARACTER | CHAR} VARYING (integer)|
    VARCHAR (integer) }
[FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII}] |
{{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(integer [K|M|G])] }
[FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII}] } |
{BINARY LARGE OBJECT | BLOB} (integer [K|M|G]) |
{GRAPHIC [(integer)] |
VARGRAPHIC (integer) |
DBCLOB (integer [K|M|G])} [CCSID {EBCDIC | ASCII}] |
{DATE | TIME | TIMESTAMP} |
ROWID

Description

function-name

Names the user-defined function. The name is implicitly or explicitly qualified by a schema name. The combination of name, schema name, the number of parameters, and the data type of each parameter (without regard for any length, precision, scale, subtype or encoding scheme attributes of the data type) must not identify a user-defined function that exists at the current server.

You can use the same name for more than one function if the function signature of each function is unique.

The unqualified form of function-name is a long SQL identifier. The name must not be any of the following system-reserved keywords even if you specify them as delimited identifiers:

ALL | LIKE | UNIQUE
AND | MATCH | UNKNOWN
ANY | NOT | =
BETWEEN | NULL | ¬=
DISTINCT | ONLY | <
EXCEPT | OR | <=
EXISTS | OVERLAPS | ¬<
FALSE | SIMILAR | >
FOR | SOME | >=
FROM | TABLE | ¬>
IN | TRUE | <>
IS | TYPE |

The unqualified function name is implicitly qualified with a schema name according to the following rules:

  • If the statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not specified, the schema name is the owner of the plan or package.
  • If the statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

The qualified form of function-name is a short SQL identifier (the schema name) followed by a period and a long SQL identifier.

The schema name can be 'SYSTOOLS' if the user who executes the CREATE statement has SYSADM or SYSCTRL privilege. Otherwise, the schema name must not begin with 'SYS' unless the schema name is 'SYSADM'.

The owner of the function is determined by how the CREATE FUNCTION statement is invoked:

  • If the statement is embedded in a program, the owner is the authorization ID of the owner of the plan or package.
  • If the statement is dynamically prepared, the owner is the SQL authorization ID in the CURRENT SQLID special register.

The owner is implicitly given the EXECUTE privilege with the GRANT option for the function.

(parameter-declaration,...)

Identifies the number of input parameters of the function, and specifies the data type of each parameter. All the parameters for a function are input parameters. There must be one entry in the list for each parameter that the function expects to receive. Although not required, you can give each parameter a name.

A function can have no parameters. In this case, you must code an empty set of parentheses, for example:

CREATE FUNCTION WOOFER()

parameter-name

Specifies the name of the input parameter. The name is a long SQL identifier, and each name in the parameter list must not be the same as any other name.

data-type

Specifies the data type of the input parameter. The data type can be a built-in data type or a distinct type.

ALL | LIKE | UNIQUE
AND | MATCH | UNKNOWN
ANY | NOT | =
BETWEEN | NULL | ¬=
DISTINCT | ONLY | <
EXCEPT | OR | <=
EXISTS | OVERLAPS | ¬<
FALSE | SIMILAR | >
FOR | SOME | >=
FROM | TABLE | ¬>
IN | TRUE | <>
IS | TYPE |
built-in-data-type | The data type of the input parameter is a built-in data type. You can use the same built-in data types as for the CREATE TABLE statement except LONG VARCHAR or LONG VARGRAPHIC. Use VARCHAR or VARGRAPHIC with an explicit length instead. If you do not specify a specific value for the data types that have length, precision, or scale attributes (CHAR, GRAPHIC, DECIMAL, NUMERIC, FLOAT), the defaults are as follows:
CHAR | CHAR(1)
GRAPHIC | GRAPHIC(1)
DECIMAL | DECIMAL(5,0)
FLOAT | DOUBLE (length of 8)
distinct-type-name | The data type of the input parameter is a distinct type. Any length, precision, scale, subtype, or encoding scheme attributes for the parameter are those of the source type of the distinct type.
data-type2 | Specifies the data type of the output.
AS LOCATOR | Specifies that the function returns a locator to the value rather than the actual value. You can specify AS LOCATOR only if data-type4 is a LOB data type or a distinct type based on a LOB data type.
data-type3 CAST FROM data-type4 Specifies the data type of the output of the function (data-type4) and the data type in which that output is returned to the invoking statement (data-type3). The two data types can be different For example, for the following definition, the function returns a DOUBLE value, which DB2 converts to a DECIMAL value and then passes to the statement that invoked the function:
CREATE FUNCTION SQRT(DECIMAL(15,0))
    RETURNS DECIMAL(15,0) CAST FROM DOUBLE
ASSEMBLE | The function is written in Assembler. (Not currently available with XDB Server.)
C | The function is written in C or C++. (Not currently available with XDB Server.)
COBOL | The function is written in COBOL, including the object-oriented language extensions.
PLI | The function is written in PL/I. (Not currently available with XDB Server.)
NOT DETERMINISTIC The function might not return the same result for identical input arguments. The function depends on some state values that affect the results. XDB uses this information when processing a SELECT, UPDATE, DELETE, or INSERT statement to disable merging of views that refer to the function. An example of a function that is not deterministic is one that generates random numbers, or any function that contains SQL statements.

NOT DETERMINISTIC is the default.

Some functions that are not deterministic can receive incorrect results if the function is executed by parallel tasks. Specify the DISALLOW PARALLEL clause for these functions.

DETERMINISTIC The function always returns the same result for identical input arguments. XDB can use this information to optimize view processing for SELECT, UPDATE, DELETE, or INSERT statements. An example of a deterministic function is a function that calculates the square root of the input.

DB2 does not verify that the function program is consistent with the specification of DETERMINISTIC or NOT DETERMINISTIC.

RETURNS NULL ON INPUT | The function is not called if any of the input arguments is null. The result is the null value.
CALLED ON NULL INPUT | The function is called regardless of whether any of the input arguments is null, making the function responsible for testing for null argument values. The function can return a null or nonnull value.
NO SQL | The function cannot execute any SQL statements.
MODIFIES SQL DATA | The function can execute any SQL statement except those statements that are not supported in any function. Do not specify MODIFIES SQL DATA when ALLOW PARALLEL is in effect.
READS SQL DATA The function cannot execute SQL statements that modify data. SQL statements that are not supported in any function return a different error.

READS SQL DATA is the default.

CONTAINS SQL | The function cannot execute any SQL statements that read or modify data. SQL statements that are not supported in any function return a different error.
NO SCRATCHPAD

A scratchpad is not allocated and passed to the function. NO SCRATCHPAD is the default.

SCRATCHPAD length

When the function is invoked for the first time, XDB allocates memory for a scratchpad.

NO FINAL CALL | A final call is not made to the external scalar function. The function does not receive an additional argument that specifies the type of call.
FINAL CALL | A final call is made to the external scalar function. See the following description of call types for the characteristics of a final call. When FINAL CALL is specified, the function receives an additional argument that specifies the type of call to enable the function to differentiate between a final call and another type of call.
NO DBINFO | Additional information is not passed.
DBINFO | An additional argument is passed when the function is invoked. The argument is a structure that contains information such as the application run-time authorization ID, the schema name, the name of a table or column that the function might be inserting into or updating, and identification of the database server that invoked the function. For details about the argument and its structure, see your DB2 Application Programming and SQL Guide.
NO COLLID | The package collection for the function is the same as the package collection of the program that invokes the function. If a trigger invokes the function, the collection of the trigger package is used. If the invoking program does not use a package, XDB resolves the package by using the CURRENT PACKAGE PATH special register or the CURRENT PACKAGESET special register.
COLLID collection-id | The name of the package collection that is used when the function is executed.
NO LIMIT | There is no limit on the service units. NO LIMIT is the default.
LIMIT integer | The limit on the service units is a positive integer in the range of 1 to 2GB. If the function uses more service units than the specified value, the function is canceled.
NO | The load module is deleted from memory after the function ends. Use NO for non-reentrant functions. NO is the default.
YES | The load module remains resident in memory after the function ends. Use YES for reentrant functions.
SUB | The function runs as a subroutine. SUB is the default.
MAIN | The function runs as a main routine.

Parameters with a datetime data type or a distinct type are passed to the function as a different data type:

  • A datetime type parameter is passed as a character data type, and the data is passed in ISO format.
  • A distinct type parameter is passed as the source type of the distinct type.

AS LOCATOR

Specifies that a locator to the value of the parameter is passed to the function instead of the actual value. Specify AS LOCATOR only for parameters with a LOB data type or a distinct type based on a LOB data type. Passing locators instead of values can result in fewer bytes being passed to the function, especially when the value of the parameter is very large.

The AS LOCATOR clause has no effect on determining whether data types can be promoted, nor does it affect the function signature, which is used in function resolution.

The XDB Server operating environment does not support the LOB data type at this time.

TABLE LIKE table-name or view-name AS LOCATOR

Specifies that the parameter is a transition table. However, when the function is invoked, the actual values in the transition table are not passed to the function. A single value is passed instead. This single value is a locator to the table, which the function uses to access the columns of the transition table. A function with a table parameter can only be invoked from the triggered action of a trigger.

The use of TABLE LIKE provides an implicit definition of the transition table. It specifies that the transition table has the same number of columns as the identified table or view. The columns have the same data type, length, precision, scale, subtype, and encoding scheme as the identified table or view, as they are described in catalog tables SYSCOLUMNS and SYSTABLESPACES.

The name specified after TABLE LIKE must identify a table or view that exists at the current server. The name must not identify a declared temporary table. The name does not have to be the same name as the table that is associated with the transition table for the trigger. An unqualified table or view name is implicitly qualified according to the following rules:

  • If the CREATE FUNCTION statement is embedded in a program, the implicit qualifier is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not used, the implicit qualifier is the owner of the plan or package.
  • If the CREATE FUNCTION statement is dynamically prepared, the implicit qualifier is the SQL authorization ID in the CURRENT SQLID special register.

When the function is invoked, the corresponding columns of the transition table identified by the table locator and the table or view identified in the TABLE LIKE clause must have the same definition. The data type, length, precision, scale, and encoding scheme of these columns must match exactly. The description of the table or view at the time the CREATE FUNCTION statement was executed is used.

XDB Server operating environment does not support transition table parameters at this time.

RETURNS

Identifies the output of the function. Consider this clause in conjunction with the optional CAST FROM clause.

data-type2 | Specifies the data type of the output.
AS LOCATOR | Specifies that the function returns a locator to the value rather than the actual value. You can specify AS LOCATOR only if data-type4 is a LOB data type or a distinct type based on a LOB data type.
data-type3 CAST FROM data-type4 Specifies the data type of the output of the function (data-type4) and the data type in which that output is returned to the invoking statement (data-type3). The two data types can be different For example, for the following definition, the function returns a DOUBLE value, which DB2 converts to a DECIMAL value and then passes to the statement that invoked the function:
CREATE FUNCTION SQRT(DECIMAL(15,0))
    RETURNS DECIMAL(15,0) CAST FROM DOUBLE

The value of data-type4 must not be a distinct type and must be castable to data-type3. The value for data-type3 can be any built-in data type or distinct type.

SPECIFIC specific-name

Specifies a unique name for the function. The name is implicitly or explicitly qualified with a schema name. The name, including the schema name, must not identify the specific name of another function that exists at the current server.

The unqualified form of specific-name is a long SQL identifier. The qualified form is a short SQL identifier (the schema name) followed by a period and a long SQL identifier.

If you do not specify a schema name, it is the same as the explicit or implicit schema name of the function name (function-name). If you specify a schema name, it must be the same as the explicit or implicit schema name of the function name.

If you do not specify the SPECIFIC clause, the default specific name is the name of the function. However, if the function name does not provide a unique specific name or if the function name is a single asterisk , XDB generates a specific name in the form of:

SQLxxxxxxxxxxxx

where xxxxxxxxxxxx is a string of 12 characters that make the name unique.

The specific name is stored in the SPECIFIC column of the SYSROUTINES catalog table. The specific name can be used to uniquely identify the function in several SQL statements (such as ALTER FUNCTION, COMMENT ON, DROP, GRANT, and REVOKE). However, the function cannot be invoked by its specific name.

EXTERNAL

Specifies that the function being registered is based on code that is written in an external programming language and adheres to the documented linkage conventions and interface of that language.

If you do not specify the NAME clause, 'NAME function-name' is implicit. In this case, function-name must not be longer than 8 characters.

NAME 'string' or identifier

Identifies the name of the MVS load module that contains the user-written code that implements the logic of the function. The name can be a string constant that is no longer than 8 characters or a short identifier, The name must conform to the naming conventions for MVS load modules.

DB2 loads the load module when the function is invoked. The load module is created when the program that contains the function body is compiled and link-edited. The load module does not need to exist when the CREATE FUNCTION statement is executed. However, it must exist and be accessible by the current server when the function is invoked.

You can specify the EXTERNAL clause in one of the following ways:

EXTERNAL
EXTERNAL NAME PKJVSP1
EXTERNAL NAME 'PKJVSP1'

If you specify an external program name, you must use the NAME keyword. For example, this syntax is not valid:

EXTERNAL PKJVSP1

LANGUAGE

Specifies the application programming language in which the function program is written. All programs must be designed to run in IBM's Language Environment environment.

ASSEMBLE | The function is written in Assembler. (Not currently available with XDB Server.)
C | The function is written in C or C++. (Not currently available with XDB Server.)
COBOL | The function is written in COBOL, including the object-oriented language extensions.
PLI | The function is written in PL/I. (Not currently available with XDB Server.)

PARAMETER STYLE DB2SQL

Specifies the linkage convention that the function program uses to receive input parameters from and pass return values to the invoking SQL statement.

DB2SQL indicates that parameters for indicator variables are associated with each input and return value to allow for null values. The parameters that are passed between the invoking SQL statement and the function include:

  • The first n parameters are the input parameters that are specified for the function
  • A parameter for the result of the function
  • n parameters for the indicator variables for the input parameters
  • A parameter for the indicator variable for the result
  • The SQLSTATE to be returned to DB2
  • The qualified name of the function
  • The specific name of the function
  • The SQL diagnostic string to be returned to DB2

Zero to three additional parameters might also be passed:

  • The scratchpad, if SCRATCHPAD is specified
  • The call type, if NO FINAL CALL is specified
  • The DBINFO structure, if DBINFO is specified

NOT DETERMINISTIC or DETERMINISTIC

Specifies whether the function returns the same results for identical input arguments.

NOT DETERMINISTIC | The function might not return the same result for identical input arguments. The function depends on some state values that affect the results. XDB uses this information when processing a SELECT, UPDATE, DELETE, or INSERT statement to disable merging of views that refer to the function. An example of a function that is not deterministic is one that generates random numbers, or any function that contains SQL statements. NOT DETERMINISTIC is the default. Some functions that are not deterministic can receive incorrect results if the function is executed by parallel tasks. Specify the DISALLOW PARALLEL clause for these functions.
DETERMINISTIC | The function always returns the same result for identical input arguments. XDB can use this information to optimize view processing for SELECT, UPDATE, DELETE, or INSERT statements. An example of a deterministic function is a function that calculates the square root of the input. DB2 does not verify that the function program is consistent with the specification of DETERMINISTIC or NOT DETERMINISTIC.

FENCED

This clause has no functional equivalent in the XDB Server operating environment.

RETURNS NULL ON NULL INPUT or CALLED ON NULL INPUT

Specifies whether the function is called if any of the input arguments is null at execution time.

RETURNS NULL ON INPUT | The function is not called if any of the input arguments is null. The result is the null value.
CALLED ON NULL INPUT | The function is called regardless of whether any of the input arguments is null, making the function responsible for testing for null argument values. The function can return a null or nonnull value.

NO SQL, MODIFIES SQL DATA, READS SQL DATA, or CONTAINS SQL

Indicates whether the function can execute any SQL statements and, if so, what type.

NO SQL | The function cannot execute any SQL statements.
MODIFIES SQL DATA | The function can execute any SQL statement except those statements that are not supported in any function. Do not specify MODIFIES SQL DATA when ALLOW PARALLEL is in effect.
READS SQL DATA | The function cannot execute SQL statements that modify data. SQL statements that are not supported in any function return a different error. READS SQL DATA is the default.
CONTAINS SQL | The function cannot execute any SQL statements that read or modify data. SQL statements that are not supported in any function return a different error.

EXTERNAL ACTION or NO EXTERNAL ACTION

This clause has no functional equivalent in the XDB Server operating environment.

NO SCRATCHPAD or SCRATCHPAD

Specifies whether XDB provides a scratchpad for the function. It is strongly recommended that external functions be reentrant, and a scratchpad provides an area for the function to save information from one invocation to the next.

NO SCRATCHPAD | A scratchpad is not allocated and passed to the function. NO SCRATCHPAD is the default.
SCRATCHPAD length | When the function is invoked for the first time, XDB allocates memory for a scratchpad.

A scratchpad has the following characteristics:

  • length must be between 1 and 32767. The default value is 100 bytes.
  • XDB initializes the scratchpad to all binary zeros (X'00''s).
  • The scope of a scratchpad is the SQL statement. For each reference to the function in an SQL statement, there is one scratchpad. For example, assuming that function UDFX was defined with the SCRATCHPAD keyword, three scratchpads are allocated for the three references to UDFX in the following SQL statement:
    SELECT A, UDFX(A) FROM TABLEB
    WHERE UDFX(A) > 103 OR UDFX(A) < 19;

    If the function is run under parallel tasks, one scratchpad is allocated for each parallel task of each reference to the function in the SQL statement. This can lead to unpredictable results. For example, if a function uses the scratchpad to count the number of times that it is invoked, the count reflects the number of invocations done by the parallel task and not the SQL statement. Specify the DISALLOW PARALLEL clause for functions that will not work correctly with parallelism.

  • The scratchpad is persistent. XDB preserves its content from one invocation of the function to the next. Any changes that the function makes to the scratchpad on one call are still there on the next call. XDB initializes the scratchpads when it begins to execute an SQL statement. XDB does not reset scratchpads when a correlated subquery begins to execute.
  • The scratchpad can be a central point for the system resources that the function acquires. If the function acquires system resources, specify FINAL CALL to ensure that XDB calls the function one more time so that the function can free those system resources.

    Each time the function invoked, XDB passes an additional argument to the function that contains the address of the scratchpad.

NO FINAL CALL or FINAL CALL

NO FINAL CALL | A final call is not made to the external scalar function. The function does not receive an additional argument that specifies the type of call.
FINAL CALL | A final call is made to the external scalar function. See the following description of call types for the characteristics of a final call. When FINAL CALL is specified, the function receives an additional argument that specifies the type of call to enable the function to differentiate between a final call and another type of call.

ALLOW or DISALLOW PARALLEL

This clause has no functional equivalent in the XDB Server operating environment.

NO DBINFO or DBINFO

Specifies whether specific information that XDB knows is passed to the function when it is invoked.

NO DBINFO | Additional information is not passed.
DBINFO | An additional argument is passed when the function is invoked. The argument is a structure that contains information such as the application run-time authorization ID, the schema name, the name of a table or column that the function might be inserting into or updating, and identification of the database server that invoked the function. For details about the argument and its structure, see your DB2 Application Programming and SQL Guide.

NO COLLID or COLLID collection-id

Identifies the package collection that is used when the function is executed.

NO COLLID | The package collection for the function is the same as the package collection of the program that invokes the function. If a trigger invokes the function, the collection of the trigger package is used. If the invoking program does not use a package, XDB resolves the package by using the CURRENT PACKAGE PATH special register or the CURRENT PACKAGESET special register.
COLLID collection-id | The name of the package collection that is used when the function is executed.

WLM ENVIRONMENT

This clause has no functional equivalent in the XDB Server operating environment.

ASUTIME

Specifies the total amount of processor time, in CPU service units, that a single invocation of the function can run. The value is unrelated to the ASUTIME column of the resource limit specification table.

When you are debugging a function, setting a limit can be helpful if the function gets caught in a loop.

NO LIMIT | There is no limit on the service units. NO LIMIT is the default.
LIMIT integer | The limit on the service units is a positive integer in the range of 1 to 2GB. If the function uses more service units than the specified value, the function is canceled.

The XDB Server operating environment only provides NO LIMIT at this time.

STAY RESIDENT

Specifies whether the load module for the function remains resident in memory when the function ends.

NO | The load module is deleted from memory after the function ends. Use NO for non-reentrant functions. NO is the default.
YES | The load module remains resident in memory after the function ends. Use YES for reentrant functions.

The XDB Server provides an operating environment where the function does not remain resident.

PROGRAM TYPE

Specifies whether the function program runs as a main routine or a subroutine.

SUB | The function runs as a subroutine. SUB is the default.
MAIN | The function runs as a main routine.

SECURITY

This clause has no functional equivalent in the XDB Server operating environment.

STOP AFTER SYSTEM DEFAULT FAILURES, STOP AFTER integer FAILURES, or CONTINUE AFTER FAILURE

Specifies whether the routine is to be put in a stopped state after some number of failures.

  • STOP AFTER SYSTEM DEFAULT FAILURES.
  • STOP AFTER integer FAILURES.
  • CONTINUE AFTER FAILURE.

This clause is only implemented syntactically in the XDB Server operating environment.

RUN OPTIONS run-time-options

This clause has no functional equivalent in the XDB Server operating environment.

Choosing data types for parameters

When you choose the data types of the input and output parameters for your function, consider the rules of promotion that can affect the values of the parameters. For example, a constant that is one of the input arguments to the function might have a built-in data type that is different from the data type that the function expects, and more significantly, might not be promotable to that expected data type. Based on the rules of promotion, using the following data types for parameters is recommended:

  • INTEGER instead of SMALLINT
  • DOUBLE instead of REAL
  • VARCHAR instead of CHAR
  • VARGRAPHIC instead of GRAPHIC

For portability of functions across platforms that are not DB2 for OS/390, do not use the following data types, which might have different representations on different platforms:

  • FLOAT. Use DOUBLE or REAL instead.
  • NUMERIC. Use DECIMAL instead.

Determining the uniqueness of functions in a schema

At the current server, the function signature of each function, which is the qualified function name combined with the number and data types of the input parameters, must be unique. If the function has more than 30 input parameters, only the data types of the first 30 are used to determine uniqueness. This means that two different schemas can each contain a function with the same name that have the same data types for all of their corresponding data types. However, a single schema must not contain multiple functions with the same name that have the same data types for all of their corresponding data types.

When determining whether corresponding data types match, XDB does not consider any length, precision, scale, subtype or encoding scheme attributes in the comparison. XDB considers the synonyms of data types (DECIMAL and NUMERIC, REAL and FLOAT, and DOUBLE and FLOAT) a match. Therefore, CHAR(8) and CHAR(35) are considered to be the same, as are DECIMAL(11,2), DECIMAL(4,3), and NUMERIC(4,2).

Assume that the following statements are executed to create four functions in the same schema. The second and fourth statements fail because they create functions that are duplicates of the functions that the first and third statements created.

CREATE FUNCTION PART (INT, CHAR(15)) ...
CREATE FUNCTION PART (INTEGER, CHAR(40)) ...
CREATE FUNCTION ANGLE (DECIMAL(12,2)) ...
CREATE FUNCTION ANGLE (DEC(10,7)) ...

Overriding a built-in function

Giving an external function the same name as a built-in function is not a recommended practice unless you are trying to change the functionality of the built-in function.

If you do intend to create an external function with the same name as a built-in function, be careful to maintain the uniqueness of its function signature. If your function has the same name and data types of the corresponding parameters of the built-in function but implements different logic, XDB might choose the wrong function when the function is invoked with an unqualified function name. Thus, the application might fail, or perhaps even worse, run successfully but provide an inappropriate result.

Example:

Assume that you want to write an external function program in C that implements the following logic:

output = 2 * input – 4

The function should return a null value if and only if one of the input arguments is null. The simplest way to avoid a function call and get a null result when an input value is null is to specify RETURNS NULL ON NULL INPUT on the CREATE FUNCTION statement or allow it to be the default.

Write the statement needed to register the function, using the specific name MINENULL1.

CREATE FUNCTION NTEST1 (SMALLINT)
    RETURNS SMALLINT
    EXTERNAL NAME 'NTESTMOD'
    SPECIFIC MINENULL1
    LANGUAGE C
    DETERMINISTIC
    NO SQL
    FENCED
    PARAMETER STYLE DB2SQL
    RETURNS NULL ON NULL INPUT
    NO EXTERNAL ACTION;

Assume that user Smith wants to register an external function named CENTER in schema SMITH. The function program will be written in C and will be reentrant. Write the statement that Smith needs to register the function, letting DB2 generate a specific name for the function.

CREATE FUNCTION CENTER (INTEGER, FLOAT)
    RETURNS FLOAT
    EXTERNAL NAME 'MIDDLE'
    LANGUAGE C
    DETERMINISTIC
    NO SQL
    FENCED
    PARAMETER STYLE DB2SQL
    NO EXTERNAL ACTION
    STAY RESIDENT YES;

Assume that user McBride (who has administrative authority) wants to register an external function named CENTER in the SMITH schema. McBride plans to give the function specific name FOCUS98. The function program uses a scratchpad to perform some one-time only initialization and save the results. The function program returns a value with a FLOAT data type. Write the statement McBride needs to register the function and ensure that when the function is invoked, it returns a value with a data type of DECIMAL(8,4).

CREATE FUNCTION SMITH.CENTER (FLOAT, FLOAT, FLOAT)
    RETURNS DECIMAL(8,4) CAST FROM FLOAT
    EXTERNAL NAME 'CMOD'
    SPECIFIC FOCUS98
    LANGUAGE C
    DETERMINISTIC
    NO SQLFENCED
    PARAMETER STYLE DB2SQL
    NO EXTERNAL ACTION
    SCRATCHPAD
    NO FINAL CALL;
Parent topic: SQL Statements


CREATE FUNCTION (external table)

A scalar function returns a single value each time it is invoked.

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

The privilege set defined below must include at least one of the following:

  • The CREATEIN privilege for the schema or all schemas
  • SYSADM or SYSCTRL authority

The authorization ID that matches the schema name implicitly has the CREATEIN privilege on the schema.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

CREATE FUNCTION function-name ([parameter-declaration[,...]])
    RETURNS TABLE (column-name data-type [AS LOCATOR] [,...]) option-list

option-list:

    [SPECIFIC specific-name]
    [EXTERNAL [NAME {'string' | identifier}] LANGUAGE {ASSEMBLE | C | COBOL | PLI}]
    [PARAMETER STYLE DB2SQL [DETERMINISTIC | NOT DETERMINISTIC]
    [FENCED]]
    [RETURNS NULL ON NULL INPUT | CALLED ON NULL INPUT]
    [READS SQL DATA | NO SQL | MODIFIES SQL DATA | CONTAINS SQL]
    [EXTERNAL ACTION | NO EXTERNAL ACTION]
    [NO SCRATCHPAD | SCRATCHPAD [100 | length]]
    [FINAL CALL | NO FINAL CALL]
    [DISALLOW PARALLEL]
    [DBINFO | NODBINFO]
    [CARDINALITY integer]
    [NO COLLID | COLLID collection-id]
    [WLM ENVIRONMENT {name | (name)}]
    [ASUTIME NO LIMIT | ASUTIME LIMIT integer]
    [STAY RESIDENT NO | STAY RESIDENT YES]
    [PROGRAM TYPE SUB | PROGRAM TYPE MAIN]
    [SECURITY DB2 | SECURITY {USER | DEFINED}]
    [RUN OPTIONS run-time-options]
    [STOP AFTER SYSTEM DEFAULT FAILURES |
     STOP AFTER integer FAILURES |
     CONTINUE AFTER FAILURE]

parameter-declaration:

    [parameter-name] parameter-type

parameter-type:

    {data-type [AS LOCATOR] | TABLE LIKE {table-name | view-name} [AS LOCATOR]}

data-type:

    {built-in-data-type | distinct-type-name}

built-in-data-type:

    SMALLINT |
    {INTEGER | INT} |
    {DECIMAL | DEC | NUMERIC} [integer[,...]] |
    {FLOAT [integer] | REAL [PRECISION] | DOUBLE} |
    { {CHARACTER | CHAR} [(integer)] | {CHARACTER | CHAR} VARYING (integer)|
    VARCHAR (integer) }
        [FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII}] |
        {{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(integer [K|M|G])] }
        [FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII}] } |
    {BINARY LARGE OBJECT | BLOB} (integer [K|M|G])
    |{GRAPHIC [(integer)] | VARGRAPHIC (integer) | DBCLOB (integer [K|M|G])} [CCSID {EBCDIC | ASCII}] |
    {DATE | TIME | TIMESTAMP} |
    ROWID

Description

function-name

Names the user-defined function. The name is implicitly or explicitly qualified by a schema name. The combination of name, schema name, the number of parameters, and the data type of each parameter (without regard for any length, precision, scale, subtype or encoding scheme attributes of the data type) must not identify a user-defined function that exists at the current server.

You can use the same name for more than one function if the function signature of each function is unique.

The unqualified form of function-name is a long SQL identifier. The name must not be any of the following system-reserved keywords even if you specify them as delimited identifiers:

ALL | LIKE | UNIQUE
AND | MATCH | UNKNOWN
ANY | NOT | =
BETWEEN | NULL | ¬=
DISTINCT | ONLY | <
EXCEPT | OR | <=
EXISTS | OVERLAPS | ¬<
FALSE | SIMILAR | >
FOR | SOME | >=
FROM | TABLE | ¬>
IN | TRUE | <>
IS | TYPE

The unqualified function name is implicitly qualified with a schema name according to the following rules:

  • If the statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not specified, the schema name is the owner of the plan or package.
  • If the statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

The qualified form of function-name is a short SQL identifier (the schema name) followed by a period and a long SQL identifier.

The schema name can be 'SYSTOOLS' if the user who executes the CREATE statement has SYSADM or SYSCTRL privilege. Otherwise, the schema name must not begin with 'SYS' unless the schema name is 'SYSADM'.

The owner of the function is determined by how the CREATE FUNCTION statement is invoked:

  • If the statement is embedded in a program, the owner is the authorization ID of the owner of the plan or package.
  • If the statement is dynamically prepared, the owner is the SQL authorization ID in the CURRENT SQLID special register.

The owner is implicitly given the EXECUTE privilege with the GRANT option for the function.

(parameter-declaration,...)

Identifies the number of input parameters of the function, and specifies the data type of each parameter. All the parameters for a function are input parameters. There must be one entry in the list for each parameter that the function expects to receive. Although not required, you can give each parameter a name.

A function can have no parameters. In this case, you must code an empty set of parentheses, for example:

CREATE FUNCTION WOOFER()

parameter-name

Specifies the name of the input parameter. The name is a long SQL identifier, and each name in the parameter list must not be the same as any other name.

data-type

Specifies the data type of the input parameter. The data type can be a built-in data type or a distinct type.

ALL | LIKE | UNIQUE
AND | MATCH | UNKNOWN
ANY | NOT | =
BETWEEN | NULL | ¬=
DISTINCT | ONLY | <
EXCEPT | OR | <=
EXISTS | OVERLAPS | ¬<
FALSE | SIMILAR | >
FOR | SOME | >=
FROM | TABLE | ¬>
IN | TRUE | <>
IS | TYPE
CHAR | CHAR(1)
GRAPHIC | GRAPHIC(1)
DECIMAL | DECIMAL(5,0)
FLOAT | DOUBLE (length of 8)
distinct-type-name | The data type of the input parameter is a distinct type. Any length, precision, scale, subtype, or encoding scheme attributes for the parameter are those of the source type of the distinct type.
column-name | Specifies the name of the column. The name is a long identifier and must be unique within the RETURNS TABLE clause for the function.
data-type | Specifies the data type of the column. The data type can be any built-in data type, except LONG VARCHAR or LONG VARGRAPHIC. The data type can also be any distinct type.
AS LOCATOR | Specifies that the function returns a locator to the value rather than the actual value. You can specify AS LOCATOR only for a LOB data type or a distinct type based on a LOB data type.
ASSEMBLE | The function is written in Assembler. (Not currently available in XDB Server.)
C | The function is written in C or C++. (Not currently available in XDB Server.)
COBOL | The function is written in COBOL, including the object-oriented language extensions.
PLI | The function is written in PL/I. (Not currently available in XDB Server.)
NOT DETERMINISTIC | The function might not return the same result for identical input arguments. The function depends on some state values that affect the results. XDB uses this information when processing a SELECT, UPDATE, DELETE, or INSERT statement to disable merging of views that refer to the function. An example of a function that is not deterministic is one that generates random numbers, or any function that contains SQL statements. NOT DETERMINISTIC is the default. Some functions that are not deterministic can receive incorrect results if the function is executed by parallel tasks. Specify the DISALLOW PARALLEL clause for these functions.
DETERMINISTIC | The function always returns the same result for identical input arguments. XDB can use this information to optimize view processing for SELECT, UPDATE, DELETE, or INSERT statements. An example of a deterministic function is a function that calculates the square root of the input. XDB does not verify that the function program is consistent with the specification of DETERMINISTIC or NOT DETERMINISTIC.
RETURNS NULL ON INPUT | The function is not called if any of the input arguments is null. The result is an empty table, which is a table with no rows. RETURNS NULL ON NULL INPUT is the default.
CALLED ON NULL INPUT | The function is called regardless of whether any of the input arguments is null, making the function responsible for testing for null argument values. The function can return an empty table, depending on its logic.
NO SQL | The function cannot execute any SQL statements.
READS SQL DATA | The function cannot execute any SQL statements that modify data. SQL statements that are not supported in any function return a different error. READS SQL DATA is the default.
CONTAINS SQL | The stored procedure cannot execute any SQL statements that read or modify data. SQL statements that are not supported in any function return a different error.
NO SCRATCHPAD | A scratchpad is not allocated and passed to the function. NO SCRATCHPAD is the default.
SCRATCHPAD | length When the function is invoked for the first time, XDB allocates memory for a scratchpad. A scratchpad has the following characteristics:
First call | A first call occurs only if the function was defined with FINAL CALL. Before a first call, the scratchpad is set to binary zeros. Argument values are passed to the function, and the function might acquire memory or perform other one-time only resource initialization. However, the function should not return any data to XDB, but it can set return values for the SQL-state and diagnostic-message arguments.
Open call | An open call occurs unless the function returns an error. The scratchpad is set to binary zeros only if the function was defined with NO FINAL CALL. Argument values are passed to the function, and the function might perform any one-time initialization actions that are required. However, the function should not return any data to XDB.
Fetch call | A fetch call occurs unless the function returns an error during the first call or open call. Argument values are passed to the function, and XDB expects the function to return a row of data or the end-of-table condition. If a scratchpad is also passed to the function, it remains untouched from the previous call.
Close call | A close call occurs unless the function returns an error during the first call, open call, or fetch call. No SQL-argument or SQL-argument-ind values are passed to the function, and if the function attempts to examine these values, unpredictable results may occur. If a scratchpad is also passed to the function, it remains untouched from the previous call. The function should not return any data to XDB, but it can set return values for the SQL-state and diagnostic-message arguments. Also on close call, a function that is defined with NO FINAL CALL should release any system resources that it acquired. (A function that is defined with FINAL CALL should release any acquired resources on the final call.)
Final | The final call balances the first call, and like the first call, occurs only if the function was defined with FINAL CALL. The function can set return values for the SQL-state and diagnostic-message arguments. The function should also release any system resources that it acquired. A final call occurs at these times:
NO DBINFO | No additional information is passed. NO DBINFO is the default.
DBINFO | An additional argument is passed when the function is invoked. The argument is a structure that contains information such as the application run-time authorization ID, the schema name, the name of a table or column that the function might be inserting into or updating, and identification of the database server that invoked the function.
NO COLLID | The package collection for the function is the same as the package collection of the program that invokes the function. If a trigger invokes the function, the collection of the trigger package is used. If the invoking program does not use a package, XDB resolves the package by using the CURRENT PACKAGE PATH special register or the CURRENT PACKAGESET special register.
COLLID collection-id | The name of the package collection that is used when the function is executed.
NO LIMIT | There is no limit on the service units. NO LIMIT is the default.
LIMIT integer | The limit on the service units is a positive integer in the range of 1 to 2GB. If the function uses more service units than the specified value, the function is canceled.
NO | The load module is deleted from memory after the function ends. Use NO for non-reentrant functions. NO is the default.
YES | The load module remains resident in memory after the function ends. Use YES for reentrant functions.
SUB | The function runs as a subroutine. SUB is the default.
MAIN | The function runs as a main routine.

Parameters with a datetime data type or a distinct type are passed to the function as a different data type:

  • A datetime type parameter is passed as a character data type, and the data is passed in ISO format.
  • A distinct type parameter is passed as the source type of the distinct type.

AS LOCATOR

Specifies that a locator to the value of the parameter is passed to the function instead of the actual value. Specify AS LOCATOR only for parameters with a LOB data type or a distinct type based on a LOB data type. Passing locators instead of values can result in fewer bytes being passed to the function, especially when the value of the parameter is very large.

The AS LOCATOR clause has no effect on determining whether data types can be promoted, nor does it affect the function signature, which is used in function resolution.

The XDB operating environment does not support the LOB data type at this time.

TABLE LIKE table-name or view-name AS LOCATOR

Specifies that the parameter is a transition table. However, when the function is invoked, the actual values in the transition table are not passed to the function. A single value is passed instead. This single value is a locator to the table, which the function uses to access the columns of the transition table. A function with a table parameter can only be invoked from the triggered action of a trigger.

The use of TABLE LIKE provides an implicit definition of the transition table. It specifies that the transition table has the same number of columns as the identified table or view. The columns have the same data type, length, precision, scale, subtype, and encoding scheme as the identified table or view, as they are described in catalog tables SYSCOLUMNS and SYSTABLESPACES.

The name specified after TABLE LIKE must identify a table or view that exists at the current server. The name must not identify a declared temporary table. The name does not have to be the same name as the table that is associated with the transition table for the trigger. An unqualified table or view name is implicitly qualified according to the following rules:

  • If the CREATE FUNCTION statement is embedded in a program, the implicit qualifier is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not used, the implicit qualifier is the owner of the plan or package.
  • If the CREATE FUNCTION statement is dynamically prepared, the implicit qualifier is the SQL authorization ID in the CURRENT SQLID special register.

When the function is invoked, the corresponding columns of the transition table identified by the table locator and the table or view identified in the TABLE LIKE clause must have the same definition. The data type, length, precision, scale, and encoding scheme of these columns must match exactly. The description of the table or view at the time the CREATE FUNCTION statement was executed is used.

The XDB operating environment does not support transition table parameters at this time.

RETURNS TABLE(column-name data-type ...)

Identifies that the output of the function is a table. The parentheses that follow the keyword enclose the list of names and data types of the columns of the table.

column-name | Specifies the name of the column. The name is a long identifier and must be unique within the RETURNS TABLE clause for the function.
data-type | Specifies the data type of the column. The data type can be any built-in data type, except LONG VARCHAR or LONG VARGRAPHIC. The data type can also be any distinct type.
AS LOCATOR | Specifies that the function returns a locator to the value rather than the actual value. You can specify AS LOCATOR only for a LOB data type or a distinct type based on a LOB data type.

SPECIFIC specific-name

Specifies a unique name for the function. The name is implicitly or explicitly qualified with a schema name. The name, including the schema name, must not identify the specific name of another function that exists at the current server.

The unqualified form of specific-name is a long SQL identifier. The qualified form is a short SQL identifier (the schema name) followed by a period and a long SQL identifier.

If you do not specify a schema name, it is the same as the explicit or implicit schema name of the function name (function-name). If you specify a schema name, it must be the same as the explicit or implicit schema name of the function name.

If you do not specify the SPECIFIC clause, the default specific name is the name of the function. However, if the function name does not provide a unique specific name or if the function name is a single asterisk , XDB generates a specific name in the form of:

SQLxxxxxxxxxxxx

where xxxxxxxxxxxx is a string of 12 characters that make the name unique.

The specific name is stored in the SPECIFIC column of the SYSROUTINES catalog table. The specific name can be used to uniquely identify the function in several SQL statements (such as ALTER FUNCTION, COMMENT ON, DROP, GRANT, and REVOKE). However, the function cannot be invoked by its specific name.

EXTERNAL

Specifies that the function being registered is based on code that is written in an external programming language and adheres to the documented linkage conventions and interface of that language.

If you do not specify the NAME clause, 'NAME function-name' is implicit. In this case, function-name must not be longer than 8 characters.

NAME 'string' or identifier

Identifies the name of the MVS load module that contains the user-written code that implements the logic of the function. The name can be a string constant that is no longer than 8 characters or a short identifier, The name must conform to the naming conventions for MVS load modules.

XDB loads the load module when the function is invoked. The load module is created when the program that contains the function body is compiled and link-edited. The load module does not need to exist when the CREATE FUNCTION statement is executed. However, it must exist and be accessible by the current server when the function is invoked.

You can specify the EXTERNAL clause in one of the following ways:

EXTERNAL
EXTERNAL NAME PKJVSP1
EXTERNAL NAME 'PKJVSP1'

If you specify an external program name, you must use the NAME keyword. For example, this syntax is not valid:

EXTERNAL PKJVSP1

LANGUAGE

Specifies the application programming language in which the function program is written. All programs must be designed to run in IBM's Language Environment environment.

ASSEMBLE | The function is written in Assembler. (Not currently available in XDB Server.)
C | The function is written in C or C++. (Not currently available in XDB Server.)
COBOL | The function is written in COBOL, including the object-oriented language extensions.
PLI | The function is written in PL/I. (Not currently available in XDB Server.)

PARAMETER STYLE DB2SQL

Specifies the linkage convention that the function program uses to receive input parameters from and pass return values to the invoking SQL statement.

DB2SQL indicates that parameters for indicator variables are associated with each input and return value to allow for null values. The parameters that are passed between the invoking SQL statement and the function include:

  • The first n parameters are the input parameters that are specified for the function
  • A parameter for the result of the function
  • n parameters for the indicator variables for the input parameters
  • A parameter for the indicator variable for the result
  • The SQLSTATE to be returned to DB2
  • The qualified name of the function
  • The specific name of the function
  • The SQL diagnostic string to be returned to DB2

Zero to three additional parameters might also be passed:

  • The scratchpad, if SCRATCHPAD is specified
  • The call type, if NO FINAL CALL is specified
  • The DBINFO structure, if DBINFO is specified

NOT DETERMINISTIC or DETERMINISTIC

Specifies whether the function returns the same results for identical input arguments.

NOT DETERMINISTIC | The function might not return the same result for identical input arguments. The function depends on some state values that affect the results. XDB uses this information when processing a SELECT, UPDATE, DELETE, or INSERT statement to disable merging of views that refer to the function. An example of a function that is not deterministic is one that generates random numbers, or any function that contains SQL statements. NOT DETERMINISTIC is the default. Some functions that are not deterministic can receive incorrect results if the function is executed by parallel tasks. Specify the DISALLOW PARALLEL clause for these functions.
DETERMINISTIC | The function always returns the same result for identical input arguments. XDB can use this information to optimize view processing for SELECT, UPDATE, DELETE, or INSERT statements. An example of a deterministic function is a function that calculates the square root of the input. XDB does not verify that the function program is consistent with the specification of DETERMINISTIC or NOT DETERMINISTIC.

FENCED

This clause has no functional equivalent in the XDB Server operating environment.

RETURNS NULL ON NULL INPUT or CALLED ON NULL INPUT

Specifies whether the function is called if any of the input arguments is null at execution time.

RETURNS NULL ON INPUT | The function is not called if any of the input arguments is null. The result is an empty table, which is a table with no rows. RETURNS NULL ON NULL INPUT is the default.
CALLED ON NULL INPUT | The function is called regardless of whether any of the input arguments is null, making the function responsible for testing for null argument values. The function can return an empty table, depending on its logic.

NO SQL, READS SQL DATA, or CONTAINS SQL

Indicates whether the function can execute any SQL statements and, if so, what type.

NO SQL | The function cannot execute any SQL statements.
READS SQL DATA | The function cannot execute any SQL statements that modify data. SQL statements that are not supported in any function return a different error. READS SQL DATA is the default.
CONTAINS SQL | The stored procedure cannot execute any SQL statements that read or modify data. SQL statements that are not supported in any function return a different error.

EXTERNAL ACTION or NO EXTERNAL ACTION

This clause has no functional equivalent in the XDB Server operating environment.

NO SCRATCHPAD or SCRATCHPAD

Specifies whether XDB provides a scratchpad for the function. It is strongly recommended that external functions be reentrant, and a scratchpad provides an area for the function to save information from one invocation to the next.

NO SCRATCHPAD | A scratchpad is not allocated and passed to the function. NO SCRATCHPAD is the default.
SCRATCHPAD | length When the function is invoked for the first time, XDB allocates memory for a scratchpad. A scratchpad has the following characteristics:
  • length must be between 1 and 32767. The default value is 100 bytes.
  • XDB initializes the scratchpad to all binary zeros (X'00''s).
  • The scope of a scratchpad is the SQL statement. For each reference to the function in an SQL statement, there is one scratchpad. For example, assuming that function UDFX was defined with the SCRATCHPAD keyword, three scratchpads are allocated for the three references to UDFX in the following SQL statement:
    SELECT A, UDFX(A) FROM TABLEB WHERE UDFX(A) > 103 OR UDFX(A) < 19;

    If the function is run under parallel tasks, one scratchpad is allocated for each parallel task of each reference to the function in the SQL statement. This can lead to unpredictable results. For example, if a function uses the scratchpad to count the number of times that it is invoked, the count reflects the number of invocations done by the parallel task and not the SQL statement. Specify the DISALLOW PARALLEL clause for functions that will not work correctly with parallelism.

  • The scratchpad is persistent. XDB preserves its content from one invocation of the function to the next. Any changes that the function makes to the scratchpad on one call are still there on the next call. XDB initializes the scratchpads when it begins to execute an SQL statement. XDB does not reset scratchpads when a correlated subquery begins to execute.
  • The scratchpad can be a central point for the system resources that the function acquires. If the function acquires system resources, specify FINAL CALL to ensure that XDB calls the function one more time so that the function can free those system resources.

    Each time the function invoked, XDB passes an additional argument to the function that contains the address of the scratchpad.

FINAL CALL or NO FINAL CALL

Specifies whether a first call and a final call are made to the function.

FINAL CALL

A first call and final call are made to the function in addition to one or more open, fetch, or close calls. FINAL CALL is the default.

NO FINAL CALL

A first call and final call are not made to the function.

The types of calls are:

First call | A first call occurs only if the function was defined with FINAL CALL. Before a first call, the scratchpad is set to binary zeros. Argument values are passed to the function, and the function might acquire memory or perform other one-time only resource initialization. However, the function should not return any data to XDB, but it can set return values for the SQL-state and diagnostic-message arguments.
Open call | An open call occurs unless the function returns an error. The scratchpad is set to binary zeros only if the function was defined with NO FINAL CALL. Argument values are passed to the function, and the function might perform any one-time initialization actions that are required. However, the function should not return any data to XDB.
Fetch call | A fetch call occurs unless the function returns an error during the first call or open call. Argument values are passed to the function, and XDB expects the function to return a row of data or the end-of-table condition. If a scratchpad is also passed to the function, it remains untouched from the previous call.
Close call | A close call occurs unless the function returns an error during the first call, open call, or fetch call. No SQL-argument or SQL-argument-ind values are passed to the function, and if the function attempts to examine these values, unpredictable results may occur. If a scratchpad is also passed to the function, it remains untouched from the previous call. The function should not return any data to XDB, but it can set return values for the SQL-state and diagnostic-message arguments. Also on close call, a function that is defined with NO FINAL CALL should release any system resources that it acquired. (A function that is defined with FINAL CALL should release any acquired resources on the final call.)
Final | The final call balances the first call, and like the first call, occurs only if the function was defined with FINAL CALL. The function can set return values for the SQL-state and diagnostic-message arguments. The function should also release any system resources that it acquired. A final call occurs at these times:
  • End of statement: When the cursor is closed for cursor-oriented statements, or the execution of the statement has completed.
  • End of transaction: When normal end of statement processing does not occur. For example, the logic of an application, for some reason, bypasses closing the cursor.

If a commit operation occurs while a cursor defined as WITH HOLD is open, a final call is made when the cursor is closed or the application ends. If a commit occurs at the end of a parallel task, a final call is made regardless of whether a cursor defined as WITH HOLD is open.

If a commit, rollback, or abort operation causes the final call, the function cannot issue any SQL statements when it is invoked.

DISALLOW PARALLEL

This clause has no functional equivalent in the XDB Server operating environment.

NO DBINFO or DBINFO

Specifies whether specific information that DB2 knows is passed to the function when it is invoked.

NO DBINFO | No additional information is passed. NO DBINFO is the default.
DBINFO | An additional argument is passed when the function is invoked. The argument is a structure that contains information such as the application run-time authorization ID, the schema name, the name of a table or column that the function might be inserting into or updating, and identification of the database server that invoked the function.

CARDINALITY integer

Specifies an estimate of the expected number of rows that the function returns. The number is used for optimization purposes. The value of integer must range from 0 to 2147483647.

If you do not specify CARDINALITY, DB2 assumes a finite value. The finite value is the same value that DB2 assumes for tables for which the RUNSTATS utility has not gathered statistics.

If a function has an infinite cardinality--the function never returns the "end-of-table" condition and always returns a row, then a query that requires the "end-of-table" to work correctly will need to be interrupted. Thus, avoid using such functions in queries that involve GROUP BY and ORDER BY.

NO COLLID or COLLID collection-id

Identifies the package collection that is used when the function is executed.

NO COLLID | The package collection for the function is the same as the package collection of the program that invokes the function. If a trigger invokes the function, the collection of the trigger package is used. If the invoking program does not use a package, XDB resolves the package by using the CURRENT PACKAGE PATH special register or the CURRENT PACKAGESET special register.
COLLID collection-id | The name of the package collection that is used when the function is executed.

WLM ENVIRONMENT

This clause has no functional equivalent in the XDB Server operating environment.

ASUTIME

Specifies the total amount of processor time, in CPU service units, that a single invocation of the function can run. The value is unrelated to the ASUTIME column of the resource limit specification table.

When you are debugging a function, setting a limit can be helpful if the function gets caught in a loop.

NO LIMIT | There is no limit on the service units. NO LIMIT is the default.
LIMIT integer | The limit on the service units is a positive integer in the range of 1 to 2GB. If the function uses more service units than the specified value, the function is canceled.

The XDB Server operating environment only provides NO LIMIT at this time.

STAY RESIDENT

Specifies whether the load module for the function remains resident in memory when the function ends.

NO | The load module is deleted from memory after the function ends. Use NO for non-reentrant functions. NO is the default.
YES | The load module remains resident in memory after the function ends. Use YES for reentrant functions.

The XDB Server provides an operating environment where the function does not remain resident.

PROGRAM TYPE

Specifies whether the function program runs as a main routine or a subroutine.

SUB | The function runs as a subroutine. SUB is the default.
MAIN | The function runs as a main routine.

SECURITY

This clause has no functional equivalent in the XDB Server operating environment.

RUN OPTIONS run-time-options

This clause has no functional equivalent in the XDB Server operating environment.

STOP AFTER SYSTEM DEFAULT FAILURES, STOP AFTER integer FAILURES, or CONTINUE AFTER FAILURE

Specifies whether the routine is to be put in a stopped state after some number of failures.

  • STOP AFTER SYSTEM DEFAULT FAILURES.
  • STOP AFTER integer FAILURES.
  • CONTINUE AFTER FAILURE.

This clause is only implemented syntactically in the XDB Server operating environment.

Example:

The following registers a table function written to return a row consisting of a single document identifier column for each known document in a text management system. The first parameter matches a given subject area and the second parameter contains a given string.

Within the context of a single session, the table function will always return the same table; therefore, it is defined as DETERMINISTIC. In addition, the DISALLOW PARALLEL keyword is added because table functions cannot operate in parallel.

Although the size of the output for DOCMATCH is highly variable, CARDINALITY 20 is a representative value, and is specified to help DB2.

CREATE FUNCTION DOCMATCH (VARCHAR(30), VARCHAR(255))
        RETURNS TABLE (DOC_ID CHAR(16))
    EXTERNAL NAME ABC
    LANGUAGE C
    PARAMETER STYLE DB2SQL
    NO SQL
    DETERMINISTIC
    NO EXTERNAL ACTION
    FENCED
    SCRATCHPAD
    FINAL CALL
    DISALLOW PARALLEL
    CARDINALITY 20;
Parent topic: SQL Statements


CREATE FUNCTION (sourced)

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

The privilege set defined below must include at least one of the following:

  • The CREATEIN privilege for the schema or all schemas
  • SYSADM or SYSCTRL authority

The authorization ID that matches the schema name implicitly has the CREATEIN privilege on the schema.

Syntax

CREATE FUNCTION function-name ([parameter-declaration[,...]])
RETURNS data-type2 [AS LOCATOR] [SPECIFIC specific-name]
SOURCE {function-name | SPECIFIC specific-name | function-name (parameter-type [,...])}

parameter-declaration:

[parameter-name] parameter-type

parameter-type:

{data-type [AS LOCATOR] | TABLE LIKE {table-name | view-name} [AS LOCATOR]}

data-type:

{built-in-data-type | distinct-type-name}

built-in-data-type:

SMALLINT |
{INTEGER | INT} |
{DECIMAL | DEC | NUMERIC} [integer[,...]] |
{FLOAT [integer] | REAL [PRECISION] | DOUBLE} |
{ {CHARACTER | CHAR} [(integer)] | {CHARACTER | CHAR} VARYING (integer)
| VARCHAR (integer) }
[FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII}] |
{{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(integer [K|M|G])] }
[FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII}] } |
{BINARY LARGE OBJECT | BLOB} (integer [K|M|G]) |
{GRAPHIC [(integer)] | VARGRAPHIC (integer) | DBCLOB (integer [K|M|G])} [CCSID {EBCDIC | ASCII}] |
{DATE | TIME | TIMESTAMP} |
ROWID

function-name

Names the user-defined function. The name is implicitly or explicitly qualified by a schema name. The combination of name, schema name, the number of parameters, and the data type of each parameter (without regard for any length, precision, scale, subtype or encoding scheme attributes of the data type) must not identify a user-defined function that exists at the current server.

If the function is sourced on an existing function to enable the use of the existing function with a distinct type, the name can be the same name as the existing function. In general, more than one function can have the same name if the function signature of each function is unique.

The unqualified form of function-name is a long SQL identifier. The name must not be any of the following system-reserved keywords even if you specify them as delimited identifiers:

ALL | LIKE | UNIQUE
AND | MATCH | UNKNOWN
ANY | NOT | =
BETWEEN | NULL | ¬=
DISTINCT | ONLY | <
EXCEPT | OR | <=
EXISTS | OVERLAPS | ¬<
FALSE | SIMILAR | >
FOR | SOME | >=
FROM | TABLE | ¬>
IN | TRUE | <>
IS | TYPE |

The unqualified function name is implicitly qualified with a schema name according to the following rules:

  • If the statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not specified, the schema name is the owner of the plan or package.
  • If the statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

The qualified form of function-name is a short SQL identifier (the schema name) followed by a period and a long SQL identifier.

The schema name must not begin with 'SYS' unless the schema name is 'SYSADM'.

The owner of the function is determined by how the CREATE FUNCTION statement is invoked:

  • If the statement is embedded in a program, the owner is the authorization ID of the owner of the plan or package.
  • If the statement is dynamically prepared, the owner is the SQL authorization ID in the CURRENT SQLID special register.

The owner is implicitly given the EXECUTE privilege with the GRANT option for the function.

(parameter-declaration,...)

Identifies the number of input parameters of the function, and specifies the data type of each parameter. All the parameters for a function are input parameters. There must be one entry in the list for each parameter that the function expects to receive. Although not required, you can give each parameter a name.

A function can have no parameters. In this case, you must code an empty set of parentheses, for example:

CREATE FUNCTION WOOFER()

parameter-name

Specifies the name of the input parameter. The name is a long SQL identifier, and each name in the parameter list must not be the same as any other name.

data-type

Specifies the data type of the input parameter. The data type can be a built-in data type or a distinct type.

ALL | LIKE | UNIQUE
AND | MATCH | UNKNOWN
ANY | NOT | =
BETWEEN | NULL | ¬=
DISTINCT | ONLY | <
EXCEPT | OR | <=
EXISTS | OVERLAPS | ¬<
FALSE | SIMILAR | >
FOR | SOME | >=
FROM | TABLE | ¬>
IN | TRUE | <>
IS | TYPE |
built-in-data-type | The data type of the input parameter is a built-in data type. You can use the same built-in data types as for the CREATE TABLE statement except LONG VARCHAR or LONG VARGRAPHIC. Use VARCHAR or VARGRAPHIC with an explicit length instead. If you do not specify a specific value for the data types that have length, precision, or scale attributes (CHAR, GRAPHIC, DECIMAL, NUMERIC, FLOAT), the defaults are as follows:
CHAR | CHAR(1)
GRAPHIC | GRAPHIC(1)
DECIMAL | DECIMAL(5,0)
FLOAT | DOUBLE (length of 8)
distinct-type-name | The data type of the input parameter is a distinct type. Any length, precision, scale, subtype, or encoding scheme attributes for the parameter are those of the source type of the distinct type.
CHAR | CHAR(1)
GRAPHIC | GRAPHIC(1)
DECIMAL | DECIMAL(5,0)
FLOAT | DOUBLE (length of 8)
data-type2 Specifies the data type of the output.

You can specify any built-in data type or distinct type that can be cast to from the data type of the source function's result. To specify a LONG VARCHAR or LONG VARGRAPHIC, use VARCHAR or VARGRAPHIC with an explicit length instead.

AS LOCATOR | Specifies that the function returns a locator to the value rather than the actual value. You can specify AS LOCATOR only if the output from the function has a LOB data type or a distinct type based on a LOB data type.
function-name | Identifies the function name of the source function. If you specify an unqualified name, XDB searches the schemas of the SQL path; otherwise, XDB searches the named schema.
parameter-type,... Provides a list of data types, separated by commas, that must match the data types of the parameters of the source function. XDB uses the number of data types and the logical concatenation of the data types to identify the source function.

For data types that have length, precision, or scale attributes, you can either specify a value for the attribute or use a set of empty parentheses (with the noted exceptions):

Empty parentheses indicate that XDB ignores the attribute when determining whether the data types match. For example, DEC() will match a parameter whose data type is DEC(7,2).FLOAT cannot be specified with empty parentheses because its parameter value indicates different data types (REAL or DOUBLE).

If you use a specific value for a length, precision, or scale attribute, the value must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement for the source function. For example, DECIMAL(7,4) does not match a parameter whose data type is DECIMAL(7,2). Coding specific values for length, precision, scale, subtype, and encoding scheme attributes ensures that the source function you intend to use is used.

The specific value for FLOAT(n) does not have exactly match the defined value of the source function because 1<=n= 21 indicates REAL and 22<=n<=53 indicates DOUBLE. Matching is based on whether the data type is REAL or DOUBLE.

If length, precision, or scale is not explicitly specified, and empty parentheses are not specified, the default length of the data type is implied. For example:

The implicit length must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.

Parameters with a datetime data type or a distinct type are passed to the function as a different data type:

  • A datetime type parameter is passed as a character data type, and the data is passed in ISO format.
  • A distinct type parameter is passed as the source type of the distinct type.

You can specify any built-in data type or distinct type that matches or can be cast to the data type of the corresponding parameter of the source function (the function that is identified in the SOURCE clause). Length, precision, or scale attributes do not have be specified for data types with these attributes. When specifying data types with these attributes, follow these rules:

An empty set of parentheses can be used to indicate that the length, precision, or scale is the same as the source function.

If length, precision, or scale is not explicitly specified, and empty parentheses are not specified, the default length of the data type is implied. For example:

CHAR | CHAR(1)
GRAPHIC | GRAPHIC(1)
DECIMAL | DECIMAL(5,0)
FLOAT | DOUBLE (length of 8)

AS LOCATOR

Specifies that a locator to the value of the parameter is passed to the function instead of the actual value. Specify AS LOCATOR only for parameters with a LOB data type or a distinct type based on a LOB data type. Passing locators instead of values can result in fewer bytes being passed to the function, especially when the value of the parameter is very large.

The AS LOCATOR clause has no effect on determining whether data types can be promoted, nor does it affect the function signature, which is used in function resolution.

The XDB operating environment does not support the LOB data type at this time.

TABLE LIKE table-name or view-name AS LOCATOR

Specifies that the parameter is a transition table. However, when the function is invoked, the actual values in the transition table are not passed to the function. A single value is passed instead. This single value is a locator to the table, which the function uses to access the columns of the transition table. A function with a table parameter can only be invoked from the triggered action of a trigger.

The use of TABLE LIKE provides an implicit definition of the transition table. It specifies that the transition table has the same number of columns as the identified table or view. The columns have the same data type, length, precision, scale, subtype, and encoding scheme as the identified table or view, as they are described in catalog tables SYSCOLUMNS and SYSTABLESPACES.

The name specified after TABLE LIKE must identify a table or view that exists at the current server. The name must not identify a declared temporary table. The name does not have to be the same name as the table that is associated with the transition table for the trigger. An unqualified table or view name is implicitly qualified according to the following rules:

  • If the CREATE FUNCTION statement is embedded in a program, the implicit qualifier is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not used, the implicit qualifier is the owner of the plan or package.
  • If the CREATE FUNCTION statement is dynamically prepared, the implicit qualifier is the SQL authorization ID in the CURRENT SQLID special register.

When the function is invoked, the corresponding columns of the transition table identified by the table locator and the table or view identified in the TABLE LIKE clause must have the same definition. The data type, length, precision, scale, and encoding scheme of these columns must match exactly. The description of the table or view at the time the CREATE FUNCTION statement was executed is used.

XDB Server operating environment does not support transition table parameters at this time.

RETURNS

Identifies the output of the function.

data-type2 | Specifies the data type of the output. You can specify any built-in data type or distinct type that can be cast to from the data type of the source function's result. To specify a LONG VARCHAR or LONG VARGRAPHIC, use VARCHAR or VARGRAPHIC with an explicit length instead.
AS LOCATOR | Specifies that the function returns a locator to the value rather than the actual value. You can specify AS LOCATOR only if the output from the function has a LOB data type or a distinct type based on a LOB data type.

SPECIFIC specific-name

Specifies a unique name for the function. The name is implicitly or explicitly qualified with a schema name. The name, including the schema name, must not identify the specific name of another function that exists at the current server.

The unqualified form of specific-name is a long SQL identifier. The qualified form is a short SQL identifier (the schema name) followed by a period and a long SQL identifier.

If you do not specify a schema name, it is the same as the explicit or implicit schema name of the function name (function-name). If you specify a schema name, it must be the same as the explicit or implicit schema name of the function name.

If you do not specify the SPECIFIC clause, the default specific name is the name of the function. However, if the function name does not provide a unique specific name or if the function name is a single asterisk , XDB generates a specific name in the form of:

SQLxxxxxxxxxxxx

where xxxxxxxxxxxx is a string of 12 characters that make the name unique.

The specific name is stored in the SPECIFIC column of the SYSROUTINES catalog table. The specific name can be used to uniquely identify the function in several SQL statements (such as ALTER FUNCTION, COMMENT ON, DROP, GRANT, and REVOKE). However, the function cannot be invoked by its specific name.

SOURCE

Specifies that the function that you are registering is a sourced function. A sourced function is implemented by another function (the source function). The source function can be any previously created user-defined function except an external table function. The source function can also be any built-in function except the following (if a particular syntax is shown, only the indicated form cannot be specified):

  • COUNT(*)
  • COUNT_BIG(*)
  • CHAR(datetime-expression, second-argument) where second-argument is ISO, USA, EUR, JIS, or LOCAL
  • COALESCE
  • NULLIF
  • RAISE-ERROR
  • STRIP with any optional parameters specified
  • VALUE

If you base the sourced function directly or indirectly on an external scalar function, the sourced function inherits the attributes of the external scalar function. This can involve several layers of sourced functions. For example, assume that function A is sourced on function B, which in turn is sourced on function C. Function C is an external scalar function. Functions A and B inherit all of the attributes that are specified on the EXTERNAL clause of the CREATE FUNCTION statement for function C.

EXECUTE authority is required on the source function.

To specify a built-in function as the source function, use the last syntax variation in the following list, function-name (parameter-type, ...).

function-name

Identifies the function to be used as the source function by its function name. A schema name implicitly or explicitly qualifies the name. Only one function with this name must exist in the schema.

If you specify an unqualified function-name, XDB uses the SQL path of the authorization ID (the value of the CURRENT PATH special register) to locate the function. The first schema that has only one function with this name on which the user has EXECUTE authority is selected. XDB returns an error if it cannot find a function or encounters a schema that has more than one function with this name.

If you specify a qualified function-name, XDB returns an error if there is no function with this name in the named schema or more than one function with this name exists in the schema.

SPECIFIC specific-name

Identifies the function to be used as the source function by its specific name. A schema name implicitly or explicitly qualifies the name.

If you specify an unqualified specific-name, XDB uses the SQL path of the authorization ID (the value of the CURRENT PATH special register) to locate the schema. XDB searches the SQL path and selects the first schema that contains a function with this specific name for which the user has EXECUTE authority. XDB returns an error if it cannot find a function with the specific name in one of the schemas in the SQL path.

If you specify a qualified specific-name, XDB searches the named schema for the function. XDB returns an error if it cannot find a function with the specific name.

function-name (parameter-type,...)

Identifies the function to be used as the source function by its function signature. You must use this form of the syntax if the source function is a built-in function. You cannot use this form of the syntax if the source function was defined with a table parameter (the LIKE TABLE was specified in the CREATE FUNCTION statement to indicate that one of the input parameters is a transition table). Instead, identify the function with its function name, if unique, or with its specific name.

XDB does not use function resolution to select the source function because the function signature uniquely identifies the function.

ALL | LIKE | UNIQUE
AND | MATCH | UNKNOWN
ANY NOT =
BETWEEN NULL ¬=
DISTINCT ONLY <
EXCEPT OR <=
EXISTS OVERLAPS ¬<
FALSE SIMILAR >
FOR SOME >=
FROM TABLE ¬>
IN TRUE <>
IS | TYPE
built-in-data-type The data type of the input parameter is a built-in data type. You can use the same built-in data types as for the CREATE TABLE statement except LONG VARCHAR or LONG VARGRAPHIC. Use VARCHAR or VARGRAPHIC with an explicit length instead.

If you do not specify a specific value for the data types that have length, precision, or scale attributes (CHAR, GRAPHIC, DECIMAL, NUMERIC, FLOAT), the defaults are as follows:

distinct-type-name | The data type of the input parameter is a distinct type. Any length, precision, scale, subtype, or encoding scheme attributes for the parameter are those of the source type of the distinct type.
GRAPHIC | GRAPHIC(1)
DECIMAL | DECIMAL(5,0)
data-type2 Specifies the data type of the output.

You can specify any built-in data type or distinct type that can be cast to from the data type of the source function's result. To specify a LONG VARCHAR or LONG VARGRAPHIC, use VARCHAR or VARGRAPHIC with an explicit length instead.

AS LOCATOR | Specifies that the function returns a locator to the value rather than the actual value. You can specify AS LOCATOR only if the output from the function has a LOB data type or a distinct type based on a LOB data type.
parameter-type,... Provides a list of data types, separated by commas, that must match the data types of the parameters of the source function. XDB uses the number of data types and the logical concatenation of the data types to identify the source function.

For data types that have length, precision, or scale attributes, you can either specify a value for the attribute or use a set of empty parentheses (with the noted exceptions):

Empty parentheses indicate that XDB ignores the attribute when determining whether the data types match. For example, DEC() will match a parameter whose data type is DEC(7,2).FLOAT cannot be specified with empty parentheses because its parameter value indicates different data types (REAL or DOUBLE).

If you use a specific value for a length, precision, or scale attribute, the value must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement for the source function. For example, DECIMAL(7,4) does not match a parameter whose data type is DECIMAL(7,2). Coding specific values for length, precision, scale, subtype, and encoding scheme attributes ensures that the source function you intend to use is used.

The specific value for FLOAT(n) does not have exactly match the defined value of the source function because 1<=n= 21 indicates REAL and 22<=n<=53 indicates DOUBLE. Matching is based on whether the data type is REAL or DOUBLE.

If length, precision, or scale is not explicitly specified, and empty parentheses are not specified, the default length of the data type is implied. For example:

The implicit length must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.

CHAR | CHAR(1)
GRAPHIC | GRAPHIC(1)
DECIMAL | DECIMAL(5,0)
FLOAT | DOUBLE (length of 8)

For either empty parentheses or specific values, the synonyms for data types are considered a match. For example, DEC and NUMERIC will match.

If you omit the FOR DATA or CCSID clause for data types with a subtype or encoding scheme attribute, XDB ignores the attribute when determining whether the data types match.

If no function with the specified signature exists in the explicitly or implicitly specified schema, an error occurs.

The number of input parameters in the function that is being created must be the same as the number of parameters in the source function. If the data type of each input parameter is not the same as or castable to the corresponding parameter of the source function, an error occurs. The data type of the final result of the source function must match or be castable to the result of the sourced function.

Choosing data types for parameters

When you choose the data types of the input and output parameters for your function, consider the rules of promotion that can affect the values of the parameters. For example, a constant that is one of the input arguments to the function might have a built-in data type that is different from the data type that the function expects, and more significantly, might not be promotable to that expected data type. Based on the rules of promotion, using the following data types for parameters is recommended:

  • INTEGER instead of SMALLINT
  • DOUBLE instead of REAL
  • VARCHAR instead of CHAR
  • VARGRAPHIC instead of GRAPHIC

For portability of functions across platforms that are not DB2 for OS/390, do not use the following data types, which might have different representations on different platforms:

  • FLOAT. Use DOUBLE or REAL instead.
  • NUMERIC. Use DECIMAL instead.

Determining the uniqueness of functions in a schema

At the current server, the function signature of each function, which is the qualified function name combined with the number and data types of the input parameters, must be unique This means that two different schemas can each contain a function with the same name that have the same data types for all of their corresponding data types. However, a single schema must not contain multiple functions with the same name that have the same data types for all of their corresponding data types.

When determining whether corresponding data types match, XDB does not consider any length, precision, scale, subtype or encoding scheme attributes in the comparison. XDB considers the synonyms of data types (DECIMAL and NUMERIC, REAL and FLOAT, and DOUBLE and FLOAT) a match. Therefore, CHAR(8) and CHAR(35) are considered to be the same, as are DECIMAL(11,2), DECIMAL(4,3), and NUMERIC(4,2).

Assume that the following statements are executed to create four functions in the same schema. The second and fourth statements fail because they create functions that are duplicates of the functions that the first and third statements created.

CREATE FUNCTION PART (INT, CHAR(15)) ...
CREATE FUNCTION PART (INTEGER, CHAR(40)) ...
CREATE FUNCTION ANGLE (DECIMAL(12,2)) ...
CREATE FUNCTION ANGLE (DEC(10,7)) ...

Rules for creating sourced functions

For the discussion in this section, assume that the function that is being created is named NEWF and the source function is named SOURCEF. Consider the following rules when creating a sourced function:

  • The unqualified names of the sourced function and source function can be different (NEWF and SOURCEF).
  • The number of input parameters for NEWF and SOURCEF must be the same; otherwise, an error occurs when the CREATE FUNCTION statement is executed.
  • When specifying the input parameters and output for NEWF, you can specify a value for the precision, scale, subtype, or encoding scheme for a data type with any of these attributes or use empty parentheses.

    Empty parentheses, such as VARCHAR(), indicate that the value of the attribute is the same as the attribute for the corresponding parameter of SOURCEF, or that is determined by data type promotion. If you specify any values for the attributes, XDB checks the values against the corresponding input parameters and returned output of SOURCEF as described next.

  • When the CREATE FUNCTION statement is executed, XDB checks the input parameters of NEWF against those of SOURCEF. The data type of each input parameter of NEWF function must be either the same as, or promotable to, the data type of the corresponding parameter of SOURCEF; otherwise, an error occurs.

    This checking does not guarantee that an error will not occur when NEWF is invoked. For example, an argument that matches the data type and length or precision attributes of a NEWF parameter might not be promotable if the corresponding SOURCEF parameter has a shorter length or less precision. In general, do not define the parameters of a sourced function with length or precision attributes that are greater than the attributes of the corresponding parameters of the source function.

  • When the CREATE FUNCTION statement is executed, XDB checks the data type identified in the RETURNS clause of NEWF against the data type that SOURCEF returns. The data type that SOURCEF returns must be either the same as, or promotable to, the RETURNS data type of NEWF; otherwise, an error occurs.

    This checking does not guarantee that an error will not occur when NEWF is invoked. For example, the value of a result that matches the data type and length or precision attributes of those specified for SOURCEF's result might not be promotable if the RETURNS data type of NEWF has a shorter length or less precision. Consider the possible effects of defining the RETURNS data type of a sourced function with length or precision attributes that are less than the attributes defined for the data type returned by source function.

Examples:

Assume that you created a distinct type HATSIZE, which you based on the built-in data type INTEGER. You want to have an AVG function to compute the average hat size of different departments. Create a sourced function that is based on built-in function AVG.

CREATE FUNCTION AVE (HATSIZE) RETURNS HATSIZE
    SOURCE SYSIBM.AVG (INTEGER);

When you created distinct type HATSIZE, two cast functions were generated, which allow HATSIZE to be cast to INTEGER for the argument and INTEGER to be cast to HATSIZE for the result of the function.

After Smith registered the external scalar function CENTER in his schema, you decide that you want to use this function, but you want it to accept two INTEGER arguments instead of one INTEGER argument and one FLOAT argument. Create a sourced function that is based on CENTER.

CREATE FUNCTION MYCENTER (INTEGER, INTEGER)
    RETURNS FLOAT
    SOURCE SMITH.CENTER (INTEGER, FLOAT);
Parent topic: SQL Statements


CREATE FUNCTION (SQL Scalar)

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared only if DYNAMICRULES run behavior is implicitly or explicitly specified.

Authorization

The privilege set defined below must include at least one of the following:

  • The CREATEIN privilege for the schema or all schemas
  • SYSADM or SYSCTRL authority

The authorization ID that matches the schema name implicitly has the CREATEIN privilege on the schema.

Syntax

CREATE FUNCTION function-name ([parameter-declaration[,...]])
RETURNS data-type2
[LANGUAGE SQL] option-list RETURN-statement

parameter-declaration:

[parameter-name] parameter-type

parameter-type:

{data-type [AS LOCATOR] | TABLE LIKE {table-name | view-name} [AS LOCATOR]}

data-type:

{built-in-data-type | distinct-type-name}

built-in-data-type:

SMALLINT |
{INTEGER | INT} |
{DECIMAL | DEC | NUMERIC} [integer[,...]] |
{FLOAT [integer] | REAL [PRECISION] | DOUBLE} |
{ {CHARACTER | CHAR} [(integer)] | {CHARACTER | CHAR} VARYING (integer)
| VARCHAR (integer) }
[FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII}] |
{{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(integer [K|M|G])] }
[FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII}] } |
{BINARY LARGE OBJECT | BLOB} (integer [K|M|G]) |
{GRAPHIC [(integer)] | VARGRAPHIC (integer) | DBCLOB (integer [K|M|G])} [CCSID {EBCDIC | ASCII}] |
{DATE | TIME | TIMESTAMP} |
ROWID

Description

function-name

Names the user-defined function. The name is implicitly or explicitly qualified by a schema name. The combination of name, schema name, the number of parameters, and the data type each parameter (without regard for any length, precision, scale, subtype, or encoding scheme attributes of the data type) must not identify a user-defined function that exists at the current server.

If the function is sourced on an existing function to enable the use of the existing function with a distinct type, the name can be the same name as the existing function. In general, more than one function can have the same name if the function signature of each function is unique.

  • The unqualified form of function-name is an SQL identifier.

    The name must not be any of the following system-reserved keywords even if you specify them as delimited identifiers:

    ALL | LIKE | UNIQUE
    AND | MATCH | UNKNOWN
    ANY NOT =
    BETWEEN NULL ¬=
    DISTINCT ONLY <
    EXCEPT OR <=
    EXISTS OVERLAPS ¬<
    FALSE SIMILAR >
    FOR SOME >=
    FROM TABLE ¬>
    IN TRUE <>
    IS | TYPE

    The unqualified function name is implicitly qualified with a schema name according to the following rules:

    • If the statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not specified, the schema name is the owner of the plan or package.
    • If the statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.
  • The qualified form of function-name is an SQL identifier (the schema name) followed by a period and an SQL identifier.

    The schema name can be "SYSTOOLS" if the user who executes the CREATE statement has SYSADM or SYSCTRL privilege. Otherwise, the schema name must not begin with "SYS" unless the schema name is "SYSADM".

The owner of the function is determined by how the CREATE FUNCTION statement is invoked:

  • If the statement is embedded in a program, the owner is the authorization ID of the owner of the plan or package.
  • If the statement is dynamically prepared, the owner is the SQL authorization ID in the CURRENT SQLID special register.

The owner is implicitly given the EXECUTE privilege with the GRANT option for the function.

(parameter-declaration,...)

Specifies the number of input parameters of the function and the data type of each parameter. All the parameters for a function are input parameters and are nullable. There must be one entry in the list for each parameter that the function expects to receive. Although not required, you can give each parameter a name.

A function can have no parameters. In this case, you must code an empty set of parentheses, for example:

CREATE FUNCTION WOOFER()

parameter-name

Specifies the name of the input parameter. The name is an SQL identifier, and each name in the parameter list must not be the same as any other name.

data-type

Specifies the data type of the input parameter. The data type can be a built-in data type or a distinct type.

built-in-type

The data type of the input parameter is a built-in data type.

You can use the same built-in data types as for the CREATE TABLE statement.

For parameters with a character or graphic data type, the PARAMETER CCSID clause or CCSID clause indicates the encoding scheme of the parameter. If you do not specify either of these clauses, the encoding scheme is the value of field DEF ENCODING SCHEME on installation panel DSNTIPF.

distinct-type-name

The data type of the input parameter is a distinct type. Any length, precision, scale, subtype, or encoding scheme attributes for the parameter are those of the source type of the distinct type.

The implicitly or explicitly specified encoding scheme of all the parameters with a string data type must be the same - either all ASCII, all EBCDIC, or all UNICODE.

Although parameters with a character data type have an implicitly or explicitly specified subtype (BIT, SBCS, or MIXED), the function program can receive character data of any subtype. Therefore, conversion of the input data to the subtype of the parameter might occur when the function is invoked.

Parameters with a datetime data type or a distinct type are passed to the function as a different data type:

  • A datetime type parameter is passed as a character data type, and the data is passed in ISO format.

    The encoding scheme for a datetime type parameter is the same as the implicitly or explicitly specified encoding scheme of any character or graphic string parameters. If no character or graphic string parameters are passed, the encoding scheme is the value of field DEF ENCODING SCHEME on installation panel DSNTIPF.

  • A distinct type parameter is passed as the source type of the distinct type.

You can specify any built-in data type or distinct type that matches or can be cast to the data type of the corresponding parameter of the source function (the function that is identified in the SOURCE clause). Length, precision, or scale attributes do not have be specified for data types with these attributes. When specifying data types with these attributes, follow these rules:

  • An empty set of parentheses can be used to indicate that the length, precision, or scale is the same as the source function.
  • If length, precision, or scale is not explicitly specified, and empty parentheses are not specified, the default values are used.

AS LOCATOR

Specifies that a locator to the value of the parameter is passed to the function instead of the actual value. Specify AS LOCATOR only for parameters with a LOB data type or a distinct type based on a LOB data type. Passing locators instead of values can result in fewer bytes being passed to the function, especially when the value of the parameter is very large.

The AS LOCATOR clause has no effect on determining whether data types can be promoted, nor does it affect the function signature, which is used in function resolution.

The XDB operating environment does not support the LOB data type.

TABLE LIKE table-name or view-name AS LOCATOR

Specifies that the parameter is a transition table. However, when the function is invoked, the actual values in the transition table are not passed to the function. A single value is passed instead. This single value is a locator to the table, which the function uses to access the columns of the transition table. A function with a table parameter can only be invoked from the triggered action of a trigger.

The use of TABLE LIKE provides an implicit definition of the transition table. It specifies that the transition table has the same number of columns as the identified table or view. The columns have the same data type, length, precision, scale, subtype, and encoding scheme as the identified table or view, as they are described in catalog tables SYSCOLUMNS and SYSTABLESPACE. The number of columns and the attributes of those columns are determined at the time the CREATE FUNCTION statement is processed. Any subsequent changes to the number of columns in the table or the attributes of those columns do not affect the parameters of the function.

The name specified after TABLE LIKE must identify a table or view that exists at the current server. The name must not identify a declared temporary table. The name does not have to be the same name as the table that is associated with the transition table for the trigger. An unqualified table or view name is implicitly qualified according to the following rules:

  • If the CREATE FUNCTION statement is embedded in a program, the implicit qualifier is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not used, the implicit qualifier is the owner of the plan or package.
  • If the CREATE FUNCTION statement is dynamically prepared, the implicit qualifier is the SQL authorization ID in the CURRENT SQLID special register.

When the function is invoked, the corresponding columns of the transition table identified by the table locator and the table or view identified in the TABLE LIKE clause must have the same definition. The data type, length, precision, scale, and encoding scheme of these columns must match exactly. The description of the table or view at the time the CREATE FUNCTION statement was executed is used.

Additionally, a character FOR BIT DATA column of the transition table cannot be passed as input for a table parameter for which the corresponding column of the table specified at the definition is not defined as character FOR BIT DATA. (The definition occurs with the CREATE FUNCTION statement.) Likewise, a character column of the transition table that is not FOR BIT DATA cannot be passed as input for a table parameter for which the corresponding column of the table specified at the definition is defined as character FOR BIT DATA.

The XDB operating environment does not support transition table parameters.

RETURNS

Identifies the output of the function.

data-type2

Specifies the data type of the output. The output is nullable.

You can specify any built-in data type or distinct type that can be cast to from the data type of the source function's result.

AS LOCATOR

Specifies that the function returns a locator to the value rather than the actual value. You can specify AS LOCATOR only if the output from the function has a LOB data type or a distinct type based on a LOB data type.

The XDB operating environment does not support the LOB data type.

SPECIFIC specific-name

Provides a unique name for the function. The name is implicitly or explicitly qualified with a schema name. The name, including the schema name, must not identify the specific name of another function that exists at the current server.

The unqualified form of specific-name is an SQL identifier. The qualified form is an SQL identifier (the schema name) followed by a period and an SQL identifier.

If you do not specify a schema name, it is the same as the explicit or implicit schema name of the function name (function-name). If you specify a schema name, it must be the same as the explicit or implicit schema name of the function name.

If you do not specify the SPECIFIC clause, the default specific name is the name of the function. However, if the function name does not provide a unique specific name or if the function name is a single asterisk, XDB generates a specific name in the form of:

SQLxxxxxxxxxxxx

where xxxxxxxxxxxx is a string of 12 characters that make the name unique.

The specific name is stored in the SPECIFIC column of the SYSROUTINES catalog table. The specific name can be used to uniquely identify the function in several SQL statements (such as ALTER FUNCTION, COMMENT ON, DROP, GRANT, and REVOKE). However, the function cannot be invoked by its specific name.

PARAMETER CCSID

Indicates whether the encoding scheme for string parameters is ASCII, EBCDIC, or UNICODE. The default encoding scheme is the value specified in the CCSID clauses of the parameter list or RETURNS clause, or in the field DEF ENCODING SCHEME on installation panel DSNTIPF.

This clause provides a convenient way to specify the encoding scheme for all string parameters. If individual CCSID clauses are specified for individual parameters in addition to this PARAMETER CCSID clause, the value specified in all of the CCSID clauses must be the same value that is specified in this clause.

This clause also specifies the encoding scheme to be used for system-generated parameters of the routine such as message tokens and DBINFO.

SOURCE

Specifies that the new function is being defined as a sourced function. A sourced function is implemented by another function (the source function). The source function must be a scalar or aggregate function that exists at the current server, and it must be one of the following types of functions:

  • A function that was defined with a CREATE FUNCTION statement
  • A cast function that was generated by a CREATE DISTINCT TYPE statement
  • A built-in function

If the source function is not a built-in function, the particular function can be identified by its name, function signature, or specific name.

If the source function is a built-in function, the SOURCE clause must include a function signature for the built-in function. The source function must not be any of the built-in functions shown in the table below. If a particular syntax is shown, only the indicated form cannot be specified.

Type of Function | Restricted Functions
Aggregate | COUNT(*)
 | COUNT_BIG(*)
 | Scalar function | CHAR(datetime-expression, second-argument) where second-argument is ISO, USA, EUR, JIS, or LOCAL
COALESCE
DECRYPT_CHAR where second argument is DEFAULT
GETVARIABLE where second argument is DEFAULT
MAX
NULLIF
XML2CLOB
XMLELEMENT
XMLNAMESPACES

If you base the sourced function directly or indirectly on an external scalar function, the sourced function inherits the attributes of the external scalar function. This can involve several layers of sourced functions. For example, assume that function A is sourced on function B, which in turn is sourced on function C. Function C is an external scalar function. Functions A and B inherit all of the attributes that are specified on the EXTERNAL clause of the CREATE FUNCTION statement for function C.

function-name

Identifies the function that is to be used as the source function. The source function can be defined with any number of parameters. If more than one function is defined with the specified name in the specified or implicit schema, an error is returned.

If you specify an unqualified function-name, XDB searches the schemas of the SQL path. XDB selects the first schema that has only one function with this name on which the user has EXECUTE authority. An error is returned if a function is not found or a schema has more than one function with this name.

function-name (parameter-type,...)

Identifies the function that is to be used as the source function by its function signature, which uniquely identifies the function. Thefunction-name (parameter-type,...) must identify a function with the specified signature. The specified parameters must match the data types in the corresponding position that were specified when the function was created. XDB uses the number of data types and the logical concatenation of the data types to identify the specific function instance. Synonyms for data types are considered a match.

If function-name() is specified, the identified function must have zero parameters.

To use a built-in function as the source function, this syntax variation must be used. You cannot use this form of the syntax if the source function was defined with a table parameter (the LIKE TABLE was specified in the CREATE FUNCTION statement to indicate that one of the input parameters is a transition table). Instead, identify the function with its function name, if unique, or with its specific name.

function-name

Identifies the function name of the source function. If you specify an unqualified name, XDB searches the schemas of the SQL path. Otherwise, XDB searches for the function in the specified schema.

parameter-type,...

Identifies the parameters of the function.

If an unqualified distinct type name is specified, XDB searches the SQL path to resolve the schema name for the distinct type.

Empty parentheses are allowed for some data types that are specified in this context. For data types that have a length, precision, or scale attribute, use one of the following specifications:

  • Empty parentheses indicate that XDB ignores the attribute when determining whether the data types match. For example, DEC() is considered a match for a parameter of a function that is defined with a data type of DEC(7,2). However, FLOAT cannot be specified with empty parentheses because its parameter value indicates a specific data type (REAL or DOUBLE).
  • If a specific value for a length, precision, or scale attribute is specified, the value must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement. If the data type is FLOAT, the precision does not need to exactly match the value that was specified because matching is based on the data type (REAL or DOUBLE).
  • If length, precision, or scale is not explicitly specified, and empty parentheses are not specified, the default attributes of the data type are implied. The implicit length must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.

If you omit the FOR subtype DATA clause or the CCSID clause for data types with a subtype or encoding scheme attribute, XDB is to ignore the attribute when determining whether the data types match.An exception to ignoring the attribute is FOR BIT DATA. A character FOR BIT DATA parameter of the new function cannot correspond to a parameter of the source function that is not defined as character FOR BIT DATA. Likewise, a character parameter of the new function that is not FOR BIT DATA cannot correspond to a parameter of the source function that is defined as character FOR BIT DATA.

The number of input parameters in the function that is being created must be the same as the number of parameters in the source function. If the data type of each input parameter is not the same as or castable to the corresponding parameter of the source function, an error occurs. The data type of the final result of the source function must match or be castable to the result of the sourced function.

AS LOCATOR

Specifies that the function is defined to receive a locator for this parameter. If AS LOCATOR is specified, the data type must be a LOB or distinct type that is based on a LOB.

SPECIFIC specific-name

Identifies the function to be used as the source function by its specific name.

If you specify an unqualified specific-name, XDB searches the SQL path to locate the schema. XDB selects the first schema that contains a function with this specific name for which the user has EXECUTE authority. XDB returns an error if it cannot find a function with the specific name in one of the schemas in the SQL path.

If you specify a qualified specific-name, XDB searches the named schema for the function. XDB returns an error if it cannot find a function with the specific name.

Choosing data types for parameters

When you choose the data types of the input and output parameters for your function, consider the rules of promotion that can affect the values of the parameters. For example, a constant that is one of the input arguments to the function might have a built-in data type that is different from the data type that the function expects, and more significantly, might not be promotable to that expected data type. Based on the rules of promotion, we recommend using the following data types for parameters:

  • INTEGER instead of SMALLINT
  • DOUBLE instead of REAL
  • VARCHAR instead of CHAR
  • VARGRAPHIC instead of GRAPHIC

For portability of functions across platforms that are not DB2 UDB for z/OS, do not use the following data types, which might have different representations on different platforms:

  • FLOAT. Use DOUBLE or REAL instead.
  • NUMERIC. Use DECIMAL instead.

Specifying the encoding scheme for parameters

The implicitly or explicitly specified encoding scheme of all the parameters with a string data type (both input and output parameters) must be the same--either all ASCII, all EBCDIC, or all UNICODE.

Determining the uniqueness of functions in a schema

At the current server, the function signature of each function, which is the qualified function name combined with the number and data types of the input parameters, must be unique. This means that two different schemas can each contain a function with the same name that have the same data types for all of their corresponding data types. However, a schema must not contain two functions with the same name that have the same data types for all of their corresponding data types.

When determining whether corresponding data types match, XDB does not consider any length, precision, scale, subtype or encoding scheme attributes in the comparison. XDB considers the synonyms of data types (DECIMAL and NUMERIC, REAL and FLOAT, and DOUBLE and FLOAT) a match. Therefore, CHAR(8) and CHAR(35) are considered to be the same, as are DECIMAL(11,2), DECIMAL(4,3), and NUMERIC(4,2).

Assume that the following statements are executed to create four functions in the same schema. The second and fourth statements fail because they create functions that are duplicates of the functions that the first and third statements created.

    CREATE FUNCTION PART (INT, CHAR(15)) ...
    CREATE FUNCTION PART (INTEGER, CHAR(40)) ...

    CREATE FUNCTION ANGLE (DECIMAL(12,2)) ...
    CREATE FUNCTION ANGLE (DEC(10,7)) ...

Rules for creating sourced functions

For the discussion in this section, assume that the function that is being created is named NEWF and the source function is named SOURCEF. Consider the following rules when creating a sourced function:

  • The unqualified names of the sourced function and source function can be different (NEWF and SOURCEF).
  • The number of input parameters for NEWF and SOURCEF must be the same; otherwise, an error occurs when the CREATE FUNCTION statement is executed.
  • When specifying the input parameters and output for NEWF, you can specify a value for the precision, scale, subtype, or encoding scheme for a data type with any of these attributes or use empty parentheses.

    Empty parentheses, such as VARCHAR(), indicate that the value of the attribute is the same as the attribute for the corresponding parameter of SOURCEF, or that is determined by data type promotion. If you specify any values for the attributes, XDB checks the values against the corresponding input parameters and returned output of SOURCEF as described next.

  • When the CREATE FUNCTION statement is executed, XDB checks the input parameters of NEWF against those of SOURCEF. The data type of each input parameter of NEWF function must be either the same as, or promotable to, the data type of the corresponding parameter of SOURCEF; otherwise, an error occurs.

    This checking does not guarantee that an error will not occur when NEWF is invoked. For example, an argument that matches the data type and length or precision attributes of a NEWF parameter might not be promotable if the corresponding SOURCEF parameter has a shorter length or less precision. In general, do not define the parameters of a sourced function with length or precision attributes that are greater than the attributes of the corresponding parameters of the source function.

  • When the CREATE FUNCTION statement is executed, XDB checks the data type identified in the RETURNS clause of NEWF against the data type that SOURCEF returns. The data type that SOURCEF returns must be either the same as, or promotable to, the RETURNS data type of NEWF; otherwise, an error occurs.

    This checking does not guarantee that an error will not occur when NEWF is invoked. For example, the value of a result that matches the data type and length or precision attributes of those specified for SOURCEF's result might not be promotable if the RETURNS data type of NEWF has a shorter length or less precision. Consider the possible effects of defining the RETURNS data type of a sourced function with length or precision attributes that are less than the attributes defined for the data type returned by source function.

Scrollable cursors specified with user-defined functions

A row can be fetched more than once with a scrollable cursor. Therefore, if a scrollable cursor is defined with a nondeterministic function in the select list of the cursor, a row can be fetched multiple times with different results for each fetch. Similarly, if a scrollable cursor is defined with a user-defined function with external action, the action is executed with every fetch.

Parent topic: SQL Statements


CREATE GLOBAL TEMPORARY TABLE

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared.

Authorization

Your privilege set must include at least one of the following:

  • The CREATETMTAB system privilege
  • The CREATETAB database privilege for any database
  • DBADM, DBCTRL, or DBMAINT authority for any database
  • SYSADM or SYSCTRL authority

You may require additional authorization if you use the LIKE keyword.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

CREATE GLOBAL TEMPORARY TABLE table-name
    (column-spec ,...)
    [LIKE {table-name | view-name}]
    [CCSID {ASCII | EBCDIC}]

column-spec:

column-name data-type
    [FOR {BIT | MIXED | SBCS} DATA]
    [NOT NULL]

Parameters:

table-name | Names the temporary table. The name, including the implicit or explicit qualifier, must not identify a table, view, alias, synonym, or temporary table that exists at the current server. In the LIKE clause, table-name specifies that the columns of the table have the exact same name and description as the columns of the identified table.
view-name | Specifies that the columns of the table have exactly the same name and description as the columns of the identified view.
column-name | Names the column. The name must not be qualified and must not be the same as the name of another column in the table.
data-type | Specifies the data type of the column. The types allowed and the rules followed are the same as those for the CREATE TABLE statement.

FOR {BIT | MIXED | SBCS} DATA

Specifies a subtype for a character string column. The subtypes allowed and the rules followed are the same as those for the CREATE TABLE statement.

data-type

Specifies the data type of the column. The data type can be a built-in data type or a distinct type.

built-in-data-type | Any built-in data type that can be specified for the CREATE TABLE statement with the exception that you cannot define a temporary table with a LOB or ROWID column.
distinct-type | Any distinct type except one that is based on a LOB or ROWID data type. The privilege set must implicitly or explicitly include the USAGE privilege on the distinct type.

NOT NULL

Specifies that the column cannot contain nulls. Omission of NOT NULL indicates that the column can contain nulls.

LIKE {table-name | view-name}

Specifies that the columns of the table have exactly the same name and description as the columns of the identified table or view. The name specified after LIKE must identify a table, view, or temporary table that exists at the current server. The privilege set must implicitly or explicitly include the SELECT privilege on the identified table or view.

This clause is similar to the LIKE clause on CREATE TABLE, but it has the following differences:

  • If any column of the identified table or view has an attribute value that is not allowed for a column in a temporary table, that attribute value is ignored. The corresponding column in the new temporary table has the default value for that attribute unless otherwise indicated.
  • If any column of the identified table or view allows a default value other than null, then that default value is ignored and the corresponding column in the new temporary table has no default value. A default value other than null is not allowed for any column in a temporary table.
Parent topic: SQL Statements


CREATE INDEX

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

To execute the CREATE INDEX command, users must possess either INDEX privileges on the table, DBADM authority on the database containing the table, overall SYSADM or SYSCTRL authority for the location, or be the owner of the table. If the index name specified is qualified with another AuthID (different from the application AuthID), the user must possess SYSADM or SYSCTRL authority for the location.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

CREATE [TYPE 2] [UNIQUE [WHERE NOT NULL]]
INDEX index-name
    ON {table-name (column-name [ASC | DESC] [,...]) | aux-table-name}
    [using-block | free-block | gbpcache-block | DEFINE {YES|NO}] [...]
    [GBPCACHE {CHANGED | ALL}]
    [DUPQTY number-records]
    [[CLUSTER | NOT CLUSTER]
    [PARTIONED]
    [PADDED | NOT PADDED]
    [using-block]
    [free-block]
    [gbpcache-block]
    [DEFINE YES | DEFINE NO] [...]]
    [PARTITION BY [RANGE] (partition-element
    [using-block | free-block | gbpcache-block] [...] [,...])]]
    [SUBPAGES {4 | 1 | 2 | 8 | 16}]
    [BUFFERPOOL bpname]
    [CLOSE {YES | NO}]
    [DSETPASS password]
    [DEFER {NO | YES}]
    [COPY YES]
    [PIECESIZE integer {K | M | G}]

using-block:

USING
{
VCAT {WITH | ROOT | PATH | NAME}
| STOGROUP stogroup-name
    [PRIQTY {3 | integer}]
    [SECQTY {3 | integer}]
    [ERASE {NO | YES}]
}

free-block:

[FREEPAGE {0 | integer}]
[PCTFREE {10 | integer}]

partition-element:

PARTITION integer
[ENDING [AT] (constant[,...]) [INCLUSIVE]]

Parameters:

index-name | Uniquely identifies the index among the other indexes and keys in the database. Index names must follow the rules for long identifiers.
table-name | Names the table being indexed.
column-name | Name of the column on which the index is created. If more than one column name is listed, a compound index is built on the named columns. A maximum of 64 columns may be included in a compound index.
integer | A whole number value from zero to 99, specifying the percentage of index space to be left free.
number-records | Specifies the amount of space to allocate for each .ptr block to hold duplicate record numbers.
bpname | A name that identifies a bufferpool. The 4K bufferpools are named BP0, BP1, BP2...BP49. The 32K bufferpools are named BP32K, BP32K1, BP32K2...BP32K9.

Description

The CREATE INDEX command syntactically checks many mainframe-specific clauses(bold text). You can specify various XDB Server index file storage options with the USING VCAT clause.

Any number of indexes can be created on a table. An index can be created or dropped at any time. Indexes are maintained automatically by the system. While indexes can speed up retrieval, they do require storage space. Therefore, the tradeoff between space and retrieval speed might become an issue in larger databases. Since it takes time to maintain indexes there also exists a tradeoff between retrieval, and update, delete and insert speed.

Indexes can be created on any or all columns of a table. Only the first 190 characters of the combined indexed field values are used in creating a compound index. The actual number of characters permitted depends on the number and type of columns in the index, with single field character indexes using up to the first 254 characters of a value in an index.

TYPE 2

Specifies a type 2 index. The TYPE 2 clause is not required. A type 2 index is always created.

UNIQUE

This optional keyword (when appearing without the WHERE NOT NULL clause) creates a unique index with no duplicate values allowed. While indexes are generally used to speed data retrieval, unique indexes are also used to prevent the entry of duplicate values in a column or compound key (such as, a key made up of several column values).

A table also requires a unique index if there is a ROWID column that is defined as GENERATED BY DEFAULT.

A unique index cannot be created on a materialized query table.

WHERE NOT NULL

When preceded with the UNIQUE keyword, a single-column index key defined with the UNIQUE WHERE NOT NULL clause can contain more than one null value, but all other non-null values must be unique. A good example would be a table of client data containing a column for Internet addresses. An index on NETADDR, defined with UNIQUE WHERE NOT NULL, allows any number of null values for clients with no Internet address, while still ensuring that any Internet addresses added or updated are unique.

In the case of an index key on multiple columns defined with the UNIQUE WHERE NOT NULL clause, any of the key columns in a particular record can be null and still be a valid key value. An index created with the attribute UNIQUE WHERE NOT NULL is recorded in the catalog table SYSIBM.SYSINDEXES with the value 'N' in the UNIQUERULE column.

ON table-name or aux-table-name

Identifies the table on which the index is created. The name can identify a base table, a declared temporary table, or an auxiliary table.

table-name

Identifies the base table or declared temporary table on which the index is created. The name must identify a table that exists at the current server. (The name of a declared temporary table must be qualified with SESSION.) The name must not identify a created temporary table.

(column-name,...) Specifies the columns of the index key.

Each column-name must identify a column of the table. Do not specify more than 64 columns, the same column more than once, or a LOB column (or a column with a distinct type that is based on a LOB data type). Do not qualify column-name.

The sum of the length attributes of the columns must not be greater than the following limits, where n is the number of columns that can contain null values and m is the number of varying-length columns in the key:

  • 2000 - n for a padded, nonpartitioning index
  • 2000 - n - 2m for a nonpadded, nonpartitioning index
  • 255 - n for a partitioning index (padded or nonpadded)

aux-table-name

Identifies the auxiliary table on which the index is created. The name must identify an auxiliary table that exists at the current server. If the auxiliary table already has an index, do not create another one. An auxiliary table can only have one index.

Do not specify any columns for the index key. The key value is implicitly defined as a unique 19-byte value that is system generated.

If qualified, table-name or aux-table-name can be a two-part or three-part name. If a three-part name is used, the first part must match the value of the field DB2 LOCATION NAME of installation panel DSNTIPR at the current server. (If the current server is not the local DB2, this name is not necessarily the name in the CURRENT SERVER special register.) Whether the name is two-part or three-part, the authorization ID that qualifies the name is the owner of the index.

ASC & DESC

These keywords are supported syntactically only. The XDB Server always creates indexes in ascending (ASC) order.

CLUSTER or NOT CLUSTER

Specifies whether the index is the clustering index for the table.

This clause is only implemented syntactically in the XDB Server operating environment.

CLUSTER

The index is to be used as the clustering index of the table. Do not specify CLUSTER for an index on an auxiliary table.

NOT CLUSTER

The index is not to be used as the clustering index of the table.

PARTITIONED

Specifies that the index is data partitioned (that is, partitioned according to the partitioning scheme of the underlying data). A partitioned index can be created only on a partitioned table space. The types of partitioned indexes are partitioning and secondary.

An index is considered a partitioning index if the specified index key columns match or comprise a superset of the columns specified in the partitioning key, are in the same order, and have the same ascending or descending attributes.

If PARTITION BY was not specified when the table was created, the CREATE INDEX statement must have the ENDING AT clause specified to define a partitioning index and use index-controlled partitioning. This index is created as a partitioned index even if the PARTITIONED keyword is not specified. When a partitioning index is created, if both the PARTITIONED and ENDING AT keywords are omitted, the index will be nonpartitioned. If PARTITIONED is specified, the USING block with PRIQTY and SECQTY specifications are optional. If these space parameters are not specified, default values are used.

A secondary index is any index defined on a partitioned table space that does not meet the definition of the partitioning index. For partitioned secondary indexes (data-partitioned secondary indexes), the ENDING AT clause is not allowed because the partitioning scheme of the index is predetermined by that of the underlying data. UNIQUE and UNIQUE WHERE NOT NULL are also not allowed. If a partitioned secondary index is created on a table that uses index-controlled partitioning, the table is converted to use table-controlled partitioning.

This clause is only implemented syntactically in the XDB Server operating environment.

NOT PADDED or PADDED

Specifies how varying-length string columns are to be stored in the index. If the index contains no varying-length columns, this option is ignored, and a warning message is returned. Indexes that do not have varying-length string columns are always created as physically padded indexes.

NOT PADDED

Specifies that varying-length string columns are not to be padded to their maximum length in the index. The length information for a varying-length column is stored with the key.

NOT PADDED is ignored and has no effect if the index is being created on an auxiliary table. Indexes on auxiliary tables are always padded.

PADDED

Specifies that varying-length string columns within the index are always padded with the default pad character to their maximum length.

When the index contains at least one varying-length column, the default for the option depends on the value of field PAD INDEXES BY DEFAULT on installation panel DSNTIPE:

  • When the value of this field is NO, which is the default for sites that newly installed Version 8, new indexes are not padded unless PADDED is specified.
  • When the value of this field is YES, which is the default value for sites that migrated to Version 8, new indexes are padded unless NOT PADDED is specified.

PCTFREE

This option leaves a percentage of the space free in the index block. The default percentage is 20. The range is 0 to 99. Read-only indexes should be created with PCTFREE 0.

Do not specify PCTFREE for an index on a declared temporary table.

DUPQTY

XDB uses B-tree indexes. Each index consists of two files, with the file extensions .IDX and .PTR. The .PTR extension file will be empty if there are no duplicate values in the indexed column. The DUPQTY option specifies the duplicate index block size. XDB Server index-name.PTR files contain Record IDs (RIDs) of duplicate index values. The DUPQTY clause uses the number-records parameter to specify the amount of space to allocate for each .PTR block (to hold record numbers of duplicate index values).

When one .PTR block is full, it links to another block of the same size. The more links that are required, the slower the system performs when accessing duplicate index RIDs. The smaller the DUPQTY value, the smaller the disk space required. The default is 16 records. Specify a value that is closest to the average number of duplicates per index value. For more information on estimating the storage requirements of an index, see the Server Administration Guide.

DEFER

This clause is supported syntactically and currently does NOT affect when the index is created (since it is always created immediately).

PIECESIZE integer

Specifies the maximum addressability of each piece (data set) for a secondary index . The subsequent keyword K, M, or G, indicates the units of the value specified in integer.

K | Indicates that the integer value is to be multiplied by 1 024 to specify the maximum piece size in bytes. The integer must be a power of two between 256 and 67 108 864.
M | Indicates that the integer value is to be multiplied by 1 048 576 to specify the maximum piece size in bytes. The integer must be a power of two between 1 and 65 536.
G | Indicates that the integer value is to be multiplied by 1 073 741 824 to specify the maximum piece size in bytes. The integer must be a power of two between 1 and 64.

This clause is only implemented syntactically in the XDB Server operating environment.

COPY

Indicates whether the COPY utility is allowed for the index. Do not specify COPY for an index on a declared temporary table.

NO | Does not allows full image or concurrent copies or the use of the RECOVER utility on the index. NO is the default.
YES | Allows full image or concurrent copies and the use of the RECOVER utility on the index.

This clause is only implemented syntactically in the XDB Server operating environment.

PARTITION BY RANGE

Specifies the partitioning index for the table, which determines the partitioning scheme for the data in the table.

This clause is only implemented syntactically in the XDB Server operating environment.

partition-element

Specifies the range for each partition.

PARTITION integer

A PARTITION clause specifies the highest value of the index key in one partition of a partitioning index. In this context, highest means highest in the sorting sequences of the index columns. In a column defined as ascending (ASC), highest and lowest have their usual meanings. In a column defined as descending (DESC), the lowest actual value is highest in the sorting sequence.

If you use CLUSTER, and the table is contained in a partitioned table space, you must use exactly one PARTITION clause for each partition (defined with NUMPARTS on CREATE TABLESPACE). If there are p partitions, the value of integer must range from 1 through p.

The length of the highest value of a partition (also called the limit key) is the same as the length of the partitioning index.

This clause is only implemented syntactically in the XDB Server operating environment.

ENDING AT(constant,...)

Specifies that this is the partitioning index and indicates how the data will be partitioned. The table space is marked complete after this partitioning index is created. You must use at least one constant after ENDING AT in each PARTITION clause. You can use as many as there are columns in the key. The concatenation of all the constants is the highest value of the key in the corresponding partition of the index unless the VALUES statement was already specified when the table or previous index was created.

The use of the constants to define key values is subject to these rules:

  • The first constant corresponds to the first column of the key, the second constant to the second column, and so on. Each constant must conform to the rules for assigning that value to the column. A hexadecimal string constant (GX) cannot be specified.
  • If a key includes a ROWID column (or a column with a distinct type that is based on a ROWID data type), only the first 17 bytes of the constant that is specified for the corresponding ROWID column are considered.
  • The precision and scale of a decimal constant must not be greater than the precision and scale of its corresponding column.
  • If a string constant is longer or shorter than required by the length attribute of its column, the constant is either truncated or padded on the right to the required length. If the column is ascending, the padding character is X'FF'; if the column is descending, the padding character is X'00'.
  • Using fewer constants than there are columns in the key has the same effect as using the highest possible values for all omitted columns.
  • The highest value of the key in any partition must be lower than the highest value of the key in the next partition.
  • The combination of the number of table space partitions and the corresponding limit key size cannot exceed the number of partitions * (106 + limit key size in bytes) <65394.
  • If the key exceeds 255 bytes, only the first 255 bytes are considered.
  • The highest value of the key in the last partition depends on the type of table space. For table spaces that are not large partitioned table spaces, the constants you specify after ENDING AT are not enforced. The highest value of the key that can be placed in the table is the highest possible value of the key.

    For large partitioned table space, the constants you specify are enforced. The value specified for the last partition is the highest value of the key that can be placed in the table. Any key values greater than the value specified for the last partition are out of range.

    When you define a table space with DSSIZE, you automatically give the same size to all indexes that point to that table space.

    ENDING AT can be specified only if the ENDING AT clause was not specified on a previous CREATE or ALTER TABLE statement for the underlying table.

INCLUSIVE

Specifies that the specified range values are included in the data partition.

BUFFERPOOL

This clause has no functional equivalent within the XDB Server operating environment. However, for DB2 compatibility purposes, the XDB Server records any of the sixty possible bufferpools (BP0...BP49, and BP32K, BP32K1...BP32K9). The first fifty bufferpools are for indexes with 4K page sizes, while the last ten are for indexes with 32K page sizes. Although not functionally supported, this new information is semantically checked and recorded in the XDB Server system catalog tables.

The default is the default buffer pool for indexes in the database.

USING VCAT

USING VCAT allows you to specify one of the four values below. This XDB Server extension to the VCATNAME specification allows you to specify various storage location options when creating individual indexes.

Do not specify VCAT for an index on a declared temporary table.

WITH | The default value, stores the index files in the same subdirectory as the table file.
ROOT | Stores the index files in the root directory of the current location.
PATH Stores the index files in the path previously specified in the XDB Server index path environment variable.

To use the VCAT PATH option, you must have the XDBIDX_location-name environment variable set, generally in your computer's configuration file. Enter an index path for each location's index files. For example, statements similar to the following might be included in the OS/2 config.sys file:

SET XDBIDX_location1 = e:\xdb\loc1\indexes
SET XDBIDX_location2 = p:\xdb\loc2\indexes
NAME Stores an individual index file on the path specified by the XDB Server_index name_location name environment variable (OS/2 only). Allows the files for individual indexes to be located on separate storage devices.

Take, for example, an index named COIDX that is to be created in the TUTORIAL location. The physical files for the index are to be placed in C:\IDXSTORE. Given this scenario, first set the following environment variable in your CONFIG.SYS file:

SET XDB_COIDX_TUTORIAL=C:\IDXSTORE

Then issue the following command (from SQLWizard, for example):

CREATE INDEX COIDX ON COMPANY(COKEY) USING VCAT NAME;

By allowing storage on a per index basis, the system can more flexibly use multiple physical devices, thereby increasing capacity and performance.

PRIQTY integer

Specifies the minimum primary space allocation for a DB2-managed data set. When you specify PRIQTY (with a value other than -1), the primary space allocation is at least n kilobytes, where n is:

  • 12 if integer is less than 12
  • integer if integer is between 12 and 4194304
  • 4194304 if integer is greater than 4194304

If you do not specify PRIQTY or specify PRIQTY -1, DB2 uses a default value for the primary space allocation.

If you specify PRIQTY and do not specify a value of -1, DB2 specifies the primary space allocation to access method services using the smallest multiple of 4KB not less than n. The allocated space can be greater than the amount of space requested by DB2. For example, it could be the smallest number of tracks that will accommodate the space requested.

When determining a suitable value for PRIQTY, be aware that two of the pages of the primary space are used by DB2 for purposes other than storing index entries.

This clause is only implemented syntactically in the XDB Server operating environment.

SECQTY integer

Specifies the minimum secondary space allocation for a DB2-managed data set. If you do not specify SECQTY, DB2 uses a formula to determine a value.

If you specify SECQTY and do not specify a value of -1, DB2 specifies the secondary space allocation to access method services using the smallest multiple of 4KB not less than n. The allocated space can be greater than the amount of space requested by DB2. For example, it could be the smallest number of tracks that will accommodate the space requested.

This clause is only implemented syntactically in the XDB Server operating environment.

GBPCACHE

In a data sharing environment, specifies what index pages are written to the group buffer pool. In a non-data-sharing environment, the option is ignored unless the index is on a declared temporary table. Do not specify GBPCAHCE for an index on a declared temporary table in either environment (data sharing or non-data-sharing).

CHANGED When there is inter-DB2 R/W interest on the index or partition, updated pages are written to the group buffer pool. When there is no inter-DB2 R/W interest, the group buffer pool is not used. Inter-DB2 R/W interest exists when more than one member in the data sharing group has the index or partition open, and at least one member has it open for update. GBPCACHE CHANGED is the default.

If the index is in a group buffer pool that is defined as GBPCACHE( NO), CHANGED is ignored and no pages are cached to the group buffer pool.

ALL Indicates that pages are to be cached in the group buffer pool as they are read in from DASD.

Exception: In the case of a single updating DB2 when no other DB2s have any interest in the page set, no pages are cached in the group buffer pool.

Hiperpools are not used for indexes or partitions that are defined with GBPCACHE ALL.

If the index is in a group buffer pool that is defined as GBPCACHE(NO), ALL is ignored and no pages are cached to the group buffer pool.

NONE Indicates that no pages are to be cached to the group buffer pool. DB2 uses the group buffer pool only for cross-invalidation.

If the index is partitioning, the value of GBPCACHE for a particular partition is given by the first of these choices that applies:

  1. The value of GBPCACHE given in the PART clause for that partition. Do not use more than one gbpcache-block in any PART clause.
  2. The value given in a gbpcache-block that is not in any PART clause.
  3. The default value is CHANGED.

This clause is only implemented syntactically in the XDB Server operating environment.

Regular Index

The following example creates an index called suppidx on the SNO column of the SUPPLIER table:

CREATE INDEX suppidx
    ON supplier (sno)

This index is used to speed data retrieval.

Unique Index

Unique indexes provide a means of preventing the insertion of duplicate data in a column which should have only one occurrence of a given value (including NULL values). For example, in the table PART, there should be only one part with the number P1. Building a unique index on PNO will prevent the entry of another P1. The command to build this index is:

CREATE UNIQUE INDEX pnoidx
    ON part (pno)

The system also can use unique indexes to speed data retrieval.

Compound Index

A compound index is an index made up of multiple columns. The XDB Server's compound indexes can contain up to 64 columns of a table, with a combined length of up to 190 characters. A compound index can be used to speed up processing of records that are usually ordered according to the field values in the index columns. However, the primary purpose of a unique compound index is to prevent entry of duplicate keys in a table.

A key consists of one or more table columns, the field values of which are used to identify records in a table. If the PARTSUPP table has a unique key containing the PNO and SNO columns, then there should exist one and only one record for each part supplied by a particular supplier. This can be ensured by creating a unique compound index with the command:

CREATE UNIQUE INDEX psidxON partsupp(pno, sno)
Note:

For a primary key constraint to function when running in DB2 mode, you must have created a unique index on the PNO and SNO columns of the PARTSUPP table using a command like:

CREATE UNIQUE INDEX ps_key
    ON partsupp (pno, sno)

The system checks for duplicate keys in the table when an attempt is made to create a unique compound index. If you are unable to create a unique compound index because your table creates duplicate keys, you should execute a query to determine which values have duplicates. To do this, select and group by all compound fields by using a clause such as:

HAVING COUNT(*) > 1

For example, if you want to create a unique compound index on the PNO and SNO columns of the PARTSUPP table, first execute the following command to verify whether there are any duplicate keys:

SELECT pno, sno
    FROM partsupp
    GROUP BY pno, sno
    HAVING COUNT(*) > 1

If this query retrieves any records, they are duplicates, and must be removed before creating the unique compound index.

Clustered Index

A clustered index is an index that physically orders the table data in the same sequence as the index. Only one clustered index is allowed per table. Building a clustered index causes all other indexes on the table to be rebuilt. Therefore, if the table is large (and contains many indexes) be sure to create the clustered index first.

The DUPQTY, CLUSTER and PCTFREE clauses can appear in any order after the CREATE INDEX clause. For example:

CREATE INDEX aidx ON employee(e_no)
    PCTFREE 10 CLUSTER;
CREATE INDEX aidx ON employee(lname)
    CLUSTER PCTFREE 30;
CREATE INDEX aidx ON employee(fname)
    CLUSTER;
CREATE INDEX aidx ON employee(payrate)
    PCTFREE 50 DUPQTY 16;

Examining Index Definitions

Creating or dropping an index causes the system to automatically update system tables for that location. You can query the system catalog tables for table, view, column, and index information. The query results can be formatted into your own reports. See XDB System Tables for descriptions of the system tables.

You can use the Catalog Browser function of SQLWizard to list table, view and index definitions using the format:

If a column is indexed, the name(s) of the index or indexes are listed after the column name, separated by a slash (/). Index type indicators consisting of a letter or a number may appear within parentheses after the index name.

Indicator | Meaning
no letter | Regular index (duplicate values permitted)
p | Primary key
c | Candidate (Unique) key
f | Foreign key
u | Unique index
no number | Single column index
# | Compound index; # is sequence number indicating order of column in a compound index

Next, the data type of the column is listed. The NOT NULL or NOT NULL WITH DEFAULT keywords specifies the null permission of the column. If omitted, nulls are permitted in the column.

Dropping an Index

Partitioning indexes can only be dropped by dropping the associated table space. Nonpartitioning indexes that are not indexes on auxiliary tables can be dropped simply by dropping the indexes. An empty index on an auxiliary table can be explicitly dropped; a populated index can be dropped only by dropping other objects.

Examples

Create a unique index, named DSN8610.XDEPT1, on table DSN8610.DEPT. Index entries are to be in ascending order by the single column DEPTNO. DB2 is to define the data sets for the index, using storage group DSN8G610. Each data set (piece) should hold 1 megabyte of data at most. Use 512 kilobytes as the primary space allocation for each data set and 64 kilobytes as the secondary space allocation. These specifications enable each data set to be extended up to 8 times before a new data set is used--512KB + (8*64KB)= 1024KB.

The data sets can be closed when no one is using the index and do not need to be erased if the index is dropped.

CREATE UNIQUE INDEX DSN8610.XDEPT1
    ON DSN8610.DEPT(DEPTNO ASC)
    USING STOGROUP DSN8G610
        PRIQTY 512
        SECQTY 64
        ERASE NO
    BUFFERPOOL BP1
    CLOSE YES
    PIECESIZE 1 M;

For the above example, the underlying data sets for the index will be created immediately, which is the default (DEFINE YES). Assuming that table DSN8610.DEPT is empty, if you wanted to defer the creation of the data sets until data is first inserted into the index, you would specify DEFINE NO instead of accepting the default behavior.

Create a cluster index, named XEMP2, on table EMP in database DSN8610. Put the entries in ascending order by column EMPNO. Let DB2 define the data sets for each partition using storage group DSN8G610. Make the primary space allocation be 36 kilobytes, and allow DB2 to use the default value for SECQTY, which for this example is 12 kilobytes (3 times 4KB). If the index is dropped, the data sets need not be erased.

There are to be 4 partitions, with index entries divided among them as follows:

Partition 1 | entries up to H99
Partition 2 | entries above H99 up to P99
Partition 3 | entries above P99 up to Z99
Partition 4 | entries above Z99

Associate the index with buffer pool BP1 and allow the data sets to be closed when no one is using the index. Enable the use of the COPY utility for full image or concurrent copies and the RECOVER utility.

CREATE INDEX DSN8610.XEMP2
    ON DSN8610.EMP(EMPNO ASC)
    USING STOGROUP DSN8G610
        PRIQTY 36
        ERASE NO
    CLUSTER(
        PART 1 VALUES('H99'),
        PART 2 VALUES('P99'),
        PART 3 VALUES('Z99'),
        PART 4 VALUES('999'))
    BUFFERPOOL BP1
    CLOSE YES
    COPY YES;

Create a nonpartitioning index, named DSN8610.XDEPT1, on table DSN8610.DEPT. Put the entries in ascending order by column DEPTNO. Assume that the data sets are managed by the user with catalog name DSNCAT and each data set (piece) is to hold 1 gigabyte of data at most before the next data set is used.

CREATE UNIQUE INDEX DSN8610.XDEPT1
    ON DSN8610.DEPT(DEPTNO ASC)
    USING VCAT DSNCAT
    PIECESIZE 1048576 K;

Assume that a column named EMP_PHOTO with a data type of BLOB(110K) was added to the sample employee table for each employee's photo and auxiliary table EMP_PHOTO_ATAB was created in LOB table space DSN8D61A.PHOTOLTS to store the BLOB data for the column. Create an index named XPHOTO on the auxiliary table. The data sets are to be user-managed with catalog name DSNCAT.

CREATE UNIQUE INDEX DSN8610.XPHOTO
    ON DSN8610.EMP_PHOTO_ATAB
    USING VCAT DSNCAT
    COPY YES;

In this example, no columns are specified for the key because auxiliary indexes have implicitly generated keys.

Parent topic: SQL Statements
Related information
Syntax Support Only
System Table Overview


CREATE LOCATION

Invocation

CREATE LOCATION is an executable command that can be issued interactively, embedded in a host language or dynamically prepared.

Authorization

Users must possess the INSTALL authority (or be a super user) to create or drop XDB Server locations.

Syntax

CREATE LOCATION <location-name> IN <location-path>
        SORT SEQUENCE {<language-name> EBCDIC | EBCDIC | INSENSITIVE | SENSITIVE | USER}]
    [XDB SYSTEM TABLES]
    [VERSION V23 | V31 | V41 | V51 | V60| V71| V80]

Parameters:

location-name | Specifies a 1 to 16 character name for a new user-created location. This name must be unique among all location names created under this XDB Server.
location-path | Preceded by the keyword IN, specifies a path for storing the new location files. This path is usually a subdirectory under the XDB Server directory, but can be any user-specified path.

Description

When the CREATE LOCATION command is issued, the XDB Server creates a directory structure for the new location and adds information about the new location to the SYSXDB.SYSLOCALS, and SYSIBM.SYSLOCATIONS catalog tables in the SYSTEM location.

A unique name must be specified for each location (following the rules for long identifiers), along with a directory path for the location's files and database subdirectories. The first eight characters of the location-name parameter also serve as the file name for a set of dictionary files, which are automatically created by the XDB Server for each new location, and stored in the location's root directory (location-path parameter).

location-name.DDT | Contains information about the tables associated with a location.
location-name.DDF | Contains information about the table columns associated with a location.
location-name.DDI | Contains information about the indexes associated with a location.
location-name.DDV | Contains information on the XDB Server version used to create the location.

These location dictionary files are automatically maintained and updated by the XDB Server and cannot be accessed by users.

SORT SEQUENCE

This clause allows you to choose between a case SENSITIVE, case INSENSITIVE, EBCDIC, or USER defined sort sequence for the new location. The XDB Server default is case INSENSITIVE.

FORWARD LOG

If Forward Log archiving for the location is desired, you can assign both a Forward Log name and optional path designation. If no Forward Log name is specified, the XDB Server creates a default log name by taking the first eight characters of the location name and appending a .FWD file extension. Forward Log files should ideally be stored on separate disk drives, allowing for extra insurance in the event of a location drive failure. Forward Log options are stored in the SYSXDB.SYSLOCALS catalog table in the SYSTEM location.

VERSION

Since system catalog tables differ with each XDB Server version, locations created with an older version XDB Server are not compatible with a newer version XDB Server. This optional clause creates an XDB Server location compatible with DB2 3.1, 4.1, 5.1, 6.0, 7.1 or 8.0 by using a value of V31, V41, V51, V60, V71 or V80 within the VERSION clause. V23, V31, V41, V51, V60, V71 and V80 are the only valid options for the VERSION clause.

Example:

The following command creates a location subdirectory named locat1 under the XDB Server directory (C:\XDB60):

CREATE LOCATION jbl IN d:\qa\jbl sort sequence german ebcdic;
Parent topic: SQL Statements


CREATE PROCEDURE

Invocation

CREATE PROCEDURE is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

To execute the CREATE PROCEDURE command, users must possess one (or more) privileges listed in the SYSADM or SYSCTRL authority.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

CREATE PROCEDURE procedure-name
    [(parameter-declaration [,...])]
    option-list

parameter-declaration

[IN | OUT | INOUT] [parameter-name] parameter-type

parameter-type

{data-type [AS LOCATOR] | TABLE LIKE {table-name | view-name} AS LOCATOR}

data-type

{built-in-type | distinct-type-name}

built-in-type

{SMALLINT |
{INTEGER | INT} |
{DECIMAL | DEC | NUMERIC} [(5,0) | (integer [,integer])] |
{FLOAT [(1) | (integer)] | REAL [PRECISION] | DOUBLE} |
{{{CHARACTER | CHAR} [(1) | (integer)] | {{CHARACTER | CHAR} VARYING | VARCHAR} (integer)}
    [FOR {SBCS | MIXED | BIT} DATA] [CCSID {ASCII | EBCDIC | UNICODE}] |
 {{CHARACTER |CHAR} LARGE OBJECT | CLOB} [(1M) | (integer [K | M | G])] [FOR {SBCS | MIXED} DATA]
    [CCSID {ASCII | EBCDIC | UNICODE}] } |
{{GRAPHIC [(1) | (integer)] | VARGRAPHIC (integer) | DBCLOB [(1M) | (integer [K | M | G])]}
    [CCSID {ASCII | EBCDIC | UNICODE}]} |
{{BINARY LARGE OBJECT | BLOB} [(1M) | (integer [K | M | G])]} |
{DATE | TIME | TIMESTAMP} |
ROWID}

option-list

[DYNAMIC RESULT SETS 0 | DYNAMIC RESULT SETS integer]
[PARAMETER CCSID {ASCII | EBCDIC | UNICODE}]
[EXTERNAL [NAME {'string' | identifier}]]
[LANGUAGE {ASSEMBLE | C | COBOL | JAVA | PLI | REXX}]
[MODIFIES SQL DATA | READS SQL DATA | CONTAINS SQL | NO SQL]
[PARAMETER STYLE {SQL | GENERAL | GENERAL WITH NULLS | JAVA}]
[DETERMINISTIC | NOT DETERMINISTIC]
[FENCED]
[DBINFO | NO DBINFO]
[COLLID collection-id | NO COLLID]
[WLM ENVIRONMENT {name | (name,*)}]
[ASUTIME NO LIMIT | ASUTIME LIMIT integer]
[STAY RESIDENT YES | STAY RESIDENT NO]
[PROGRAM TYPE {SUB | MAIN}]
[SECURITY {DB2 | USER | DEFINER}]
[STOP AFTER SYSTEM DEFAULT FAILURES | STOP AFTER integer FAILURES | CONTINUE AFTER FAILURE]
[RUN OPTIONS run-time-options]
[COMMIT ON RETURN YES | COMMIT ON RETURN NO]
[INHERIT SPECIAL REGISTERS | DEFAULT SPECIAL REGISTERS]
[CALLED ON NULL INPUT]

Parameters:

Procedure-name | If unqualified, the procedure name is any long identifier that uniquely names the procedure. A qualified procedure name is schema name (short identifier), a period, and then a long identifier. If unqualified, the schema name is the SQL authorization ID in the CURRENT SQLID special register.The schema name can be 'SYSIBM' or 'SYSPROC'. It can also be 'SYSTOOLS' if the user who executes the CREATE statement has SYSADM or SYSCTRL privilege. Otherwise, the schema name must not begin with 'SYS' unless the schema name is 'SYSADM'.
Load-module-name | Load module name is a short identifier naming the procedure executable module. The load module name specifies the name of a DLL file.

Comments:

If no length is specified for CHAR, VARCHAR, GRAPHIC, or VARGRAPHIC, the default length is 1. If precision is not specified for DECIMAL, the default is DECIMAL (5,0).

Parameter-name:

A parameter name is a long identifier naming the parameter.

RESULT SETS clause:

Specifies the maximum number of result sets that the stored procedure can return to the invoking program. The default is RESULT SETS 0, indicating there are no result sets being returned.

PARAMETER STYLE clause:

Identifies the convention used to pass arguments to the stored procedure. When using GENERAL, none of the arguments can be null. GENERAL WITH NULLS passes an additional argument after the arguments on the CALL PROCEDURE statement. The additional argument is an array of null indicators, one for each of the defined arguments for the stored procedure.

PROGRAM TYPE clause:

For stored procedures defined as LANGUAGE COBOL or PLI, there is no difference between MAIN or SUB.

COMMIT ON RETURN clause:

This default for this clause is NO. If COMMIT ON RETURN YES is specified, the SQL engine will issue a commit when the stored procedure returns if the transaction is not in a must rollback state. If the stored procedure uses the WITH RETURN clause to define cursors that will be returned as result sets, the cursors must also be defined as WITH HOLD if COMMIT ON RETURN YES is specified or the cursors will be closed by the SQL engine.

Parent topic: SQL Statements


CREATE PROCEDURE

The XDB Server operating environment only provides syntax support for external Procedures (SQL) at this time.

Invocation

This statement can only be dynamically prepared, but the DYNAMICRULES run behavior must be specified implicitly or explicitly. It is intended to be processed using one of the following methods:

  • JCL
  • The DB2 UDB for z/OS SQL procedure processor (DSNTPSMP)

Issuing the CREATE PROCEDURE statement from another context will result in an incomplete procedure definition even though the statement processing returns without error.

Authorization

The privilege set that is defined below must include at least one of the following:

  • The CREATEIN privilege on the schema
  • SYSADM or SYSCTRL authority

The authorization ID that matches the schema name implicitly has the CREATEIN privilege on the schema.

The privilege set is the privileges that are held by the SQL authorization ID of the process.

If the statement is dynamically prepared, the privilege set is the privileges that are held by the SQL authorization ID of the process. The specified procedure name can include a schema name (a qualifier). However, if the schema name is not the same as the SQL authorization ID, one of the following conditions must be met:

  • The privilege set includes SYSADM or SYSCTRL authority.
  • The SQL authorization ID of the process has the CREATEIN privilege on the schema.

The authorization ID that is used to create the stored procedure must have authority to create programs that are to be run either in the DB2-established stored procedure address space or the specified workload manager (WLM) environment.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

CREATE PROCEDURE procedure-name
    [(parameter-declaration [,...])] LANGUAGE SQL
    option-list SQL-routine-body

parameter-declaration

[IN | OUT | INOUT] parameter-name parameter-type

parameter-type

{built-in-type | TABLE LIKE table-name AS LOCATOR}

built-in-type

[SMALLINT]
[INTEGER | INT]
[DECIMAL | DEC | NUMERIC} [(5,0) | (integer [,integer])]
[FLOAT [(53) | (integer)] | REAL [PRECISION] | DOUBLE}]
[{{CHARACTER | CHAR} [(1) | (integer)] | {CHARACTER | CHAR} VARYING (integer) | VARCHAR (integer) }
    [FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII | UNICODE}] |
    {{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(1M) | (integer [K | M | G])] }
    [FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII | UNICODE}] }]
[{GRAPHIC [(1) | (integer)] | VARGRAPHIC (integer) | DBCLOB [(1M) | (integer [K | M | G])]}
    [CCSID {ASCII | EBCDIC | UNICODE}]]
[{BINARY LARGE OBJECT | BLOB} [(1M) | (integer [K | M | G])]]
[DATE | TIME | TIMESTAMP]
[ROWID]

option-list

[DYNAMIC RESULT SETS 0 | DYNAMIC RESULT SETS integer]
[PARAMETER CCSID {ASCII | EBCDIC | UNICODE}]
[EXTERNAL [NAME {'string' | identifier}]]
[MODIFIES SQL DATA | READS SQL DATA | CONTAINS SQL]
[DETERMINISTIC | NOT DETERMINISTIC]
[FENCED]
[NO DBINFO]
[COLLID collection-id | NO COLLID]
[WLM ENVIRONMENT {name | (name,*)}]
[ASUTIME NO LIMIT | ASUTIME LIMIT integer]
[STAY RESIDENT YES | STAY RESIDENT NO]
[PROGRAM TYPE {SUB | MAIN}]
[SECURITY {DB2 | USER | DEFINER}]
[STOP AFTER SYSTEM DEFAULT FAILURES | STOP AFTER integer FAILURES | CONTINUE AFTER FAILURE]
[RUN OPTIONS run-time-options]
[COMMIT ON RETURN YES | COMMIT ON RETURN NO]
[INHERIT SPECIAL REGISTERS | DEFAULT SPECIAL REGISTERS]
[CALLED ON NULL INPUT]
Parent topic: SQL Statements


CREATE SEQUENCE

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared only if DYNAMICRULES run behavior is implicitly or explicitly specified.

Authorization

The privilege set that is defined below must include at least one of the following:

  • The CREATEIN privilege on the schema
  • SYSADM or SYSCTRL authority

The authorization ID that matches the schema name implicitly has the CREATEIN privilege on the schema.

If the statement is embedded in an application program, the privilege set is the privileges that are held by the authorization ID of the owner of the plan or package.

If the statement is dynamically prepared, the privilege set is the privileges that are held by the SQL authorization ID of the process.

If the data type of the sequence is a distinct type, the privilege set must include the USAGE privilege on the distinct type.

Syntax

CREATE SEQUENCE sequence-name [AS {INTEGER | data-type} |
     START WITH numeric-constant |
     {INCREMENT BY 1 | INCREMENT BY numeric-constant} |
     {MINVALUE numeric-constant | NO MINVALUE} |
     {MAXVALUE numeric-constant | NO MAXVALUE} |
     {CYCLE | NO CYCLE} |
     {CACHE 20 | CACHE integer-constant | NO CACHE} |
     {ORDER | NO ORDER}
     ] [,...]
Note: The same clause must not be specified more than once. Separator commas may or may not be specified between sequence attributes when a sequence is defined.

Description

SEQUENCE sequence-name

Names the sequence. The combination of name and the implicit or explicit name must not identify an existing sequence at the current server, including the internal names generated by DB2 for identity names.

The unqualified form of sequence-name is an SQL identifier. The unqualified name is implicitly qualified with a schema name according to the following rules:

  • If the CREATE SEQUENCE statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not specified, the schema name is the owner of the plan or package.
  • If the CREATE SEQUENCE statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

The contents of the SQL PATH are not used to determine the implicit qualifier of a sequence name.

The qualified form of sequence-name is a schema followed by a period and an SQL identifier. The schema name must not begin with 'SYS' unless the schema name is 'SYSADM'.

The owner of the sequence is determined by the following conditions. If the CREATE SEQUENCE statement is embedded in a program, the owner is the authorization ID of the owner of the plan or package. If the CREATE SEQUENCE statement is dynamically prepared, the owner is the SQL authorization ID contained in the CURRENT SQLID special register. The owner has the ALTER and USAGE privileges on the new sequence with the GRANT option. These privileges can be granted by the owner and cannot be revoked from the owner.

AS data-type

Specifies the data type to be used for the sequence value. The data type can be any exact numeric data type (SMALLINT, INTEGER, or DECIMAL with a scale of zero), or a user-defined distinct type for which the source type is an exact numeric data type with a scale of zero. The default is INTEGER.

START WITH numeric-constant

Specifies the first value for the sequence. The value can be any positive or negative value that could be assigned to the a column of the data type that is associated with the sequence without non-zero digits existing to the right of the decimal point.

If the START WITH key word is not explicitly specified with a value, the default is the MINVALUE for ascending sequences and MAXVALUE for descending sequences.

This value is not necessarily the value that a sequence would cycle to after reaching the maximum or minimum value of the sequence. The START WITH clause can be used to start a sequence outside the range that is used for cycles. The range used for cycles is defined by MINVALUE and MAXVALUE.

INCREMENT BY numeric-constant

Specifies the interval between consecutive values of the sequence. The value can be any positive or negative value (including 0) that could be assigned to a column of the data type that is associated with the sequence without any non-zero digits existing to the right of the decimal point. The default is 1.

If INCREMENT BY is positive, the sequence ascends. If INCREMENT BY is negative, the sequence descends. If INCREMENT is 0, the sequence is treated as an ascending sequence.

The absolute value of INCREMENT BY can be greater than the difference between MAXVALUE and MINVALUE.

MINVALUE or NO MINVALUE

Specifies the minimum value at which a descending sequence either cycles or stops generating values or an ascending sequence cycles to after reaching the maximum value. The default is NO MINVALUE.

MINVALUE numeric-constant

Specifies the minimum end of the range of values for the sequence. The last value that is generated for a cycle of a descending sequence will be equal to or greater than this value. MINVALUE is the value to which an ascending sequence cycles to after reaching the maximum value.

The value can be any positive or negative value that could be assigned to the a column of the data type that is associated with the sequence without non-zero digits existing to the right of the decimal point. The value must be less than or equal to the maximum value.

NO MINVALUE

Specifies that the minimum end point of the range of values for the sequence has not been specified explicitly. In such a case, the default value for MINVALUE becomes one of the following:

  • For an ascending sequence, the value is the START WITH value or 1 if START WITH is not specified.
  • For a descending sequence, the value is the minimum value of the data type that is associated with the sequence.

MAXVALUE or NO MAXVALUE

Specifies the minimum value at which an ascending sequence either cycles or stops generating values or an descending sequence cycles to after reaching the minimum value. The default is NO MAXVALUE.

MAXVALUE numeric-constant

Specifies the maximum end of the range of values for the sequence. The last value that is generated for a cycle of an ascending sequence will be less than or equal to this value. MAXVALUE is the value to which a descending sequence cycles to after reaching the minimum value.

The value can be any positive or negative value that could be assigned to the a column of the data type that is associated with the sequence without non-zero digits existing to the right of the decimal point. The value must be greater than or equal to the minimum value.

NO MAXVALUE

Specifies the maximum end point of the range of values for the sequence has not been specified explicitly. In such a case, the default value for MAXVALUE becomes one of the following:

  • For an ascending sequence, the value is the maximum value of the data type that is associated with the sequence.
  • For a descending sequence, the value is the START WITH value or -1 if START WITH is not specified.

CYCLE or NO CYCLE

Specifies whether or not the sequence should continue to generate values after reaching either its maximum or minimum value. The boundary of the sequence can be reached either with the next value landing exactly on the boundary condition or by overshooting it. The default is NO CYCLE.

CYCLE

Specifies that the sequence continue to generate values after either the maximum or minimum value has been reached. If this option is used, after an ascending sequence reaches its maximum value, it generates its minimum value. After a descending sequence reaches its minimum value, it generates its maximum value. The maximum and minimum values for the sequence defined by the MINVALUE and MAXVALUE options determine the range that is used for cycling.

When CYCLE is in effect, duplicate values can be generated by the sequence. When a sequence is defined with CYCLE, any application conversion tools for converting applications from other vendor platforms to DB2 should also explicitly specify MINVALUE, MAXVALUE, and START WITH values.

NO CYCLE

Specifies that the sequence cannot generate more values once the maximum or minimum value for the sequence has been reached. The NO CYCLE option (the default) can be altered to CYCLE at any time during the life of the sequence.

When the next value is being generated for a sequence if the maximum value (for an ascending sequence) or the minimum value (for a descending sequence) of the logical range of the sequence is exceeded and the NO CYCLE option is in effect, an error occurs.

CACHE or NO CACHE

Specifies whether or not to keep some preallocated values in memory for faster access. This is a performance and tuning option.

CACHE integer-constant

Specifies the maximum number of values of the sequence that XDB can preallocate and keep in memory. Preallocating values in the cache reduces synchronous I/O when values are generated for the sequence. The actual number of values that XDB caches is always the lesser of the number in effect for the CACHE option and the number of remaining values within the logical range. Thus, the CACHE value is essentially an upper limit for the size of the cache.

In the event of a system failure, all cached sequence values that have not been used in committed statements are lost (that is, they will never be used). The value specified for the CACHE option is the maximum number of sequence values that could be lost in case of system failure.

The minimum value is 2. The default is CACHE 20.

In a data sharing environment, you can use the CACHE and NO ORDER options to allow multiple XDB members to cache sequence values simultaneously.

NO CACHE

Specifies that values of the sequence are not to be preallocated. This option ensures that there is not a loss of values in the case of a system failure. When NO CACHE is specified, the values of the sequence are not stored in the cache. In this case, every request for a new value for the sequence results in synchronous I/O.

ORDER or NO ORDER

Specifies whether the sequence numbers must be generated in order of request. The default is NO ORDER.

ORDER

Specifies that the sequence numbers are generated in order of request. Specifying ORDER may disable the caching of values. There is no guarantee that values are assigned in order across the entire server unless NO CACHE is also specified. ORDER applies only to a single-application process.

NO ORDER

Specifies that the sequence numbers do not need to be generated in order of request.

In a data sharing environment, if the CACHE and NO ORDER options are in effect, multiple caches can be active simultaneously, and the requests for next value assignments from different members may not result in the assignment of values in strict numeric order. For example, if members DB2A and DB2B are using the same sequence, and DB2A gets the cache values 1 to 20 and DB2B gets the cache values 21 to 40, the actual order of values assigned would be 1,21,2 if DB2A requested for next value first, then DB2B requested, and then DB2A again requested. Therefore, to guarantee that sequence numbers are generated in strict numeric order among multiple members using the same sequence concurrently, specify the ORDER option.

Note:
  • MINVALUE must not be greater than MAXVALUE. Although MINVALUE is typically less than MAXVALUE, MINVALUE can equal MAXVALUE. If START WITH were the same value as MINVALUE and MAXVALUE, the sequence would be constant. The request for the next value in a constant sequence appears to have no effect because all of the values that are generated by the sequence are in fact the same value.
  • When you define a sequence, you can choose to have it cycle automatically or not when the maximum or minimum value for the sequence has been reached.
    • Implicitly or explicitly defining a sequence with NO CYCLE causes the sequence to not cycle automatically after the boundary is reached. However, you can use the ALTER SEQUENCE statement to cycle the sequence manually. ALTER SEQUENCE allows you to restart or extend the sequence, which causes sequence values to continue to be generated.
    • Explicitly defining a sequence with CYCLE causes the sequence to cycle automatically after the boundary is reached. Sequence values continue to be generated after the sequence cycles.

      When a sequence is defined to cycle automatically, the maximum or minimum value that is generated for a sequence may not be the actual MAXVALUE or MINVALUE value that is specified if the increment is a value other than 1 or -1. For example, the sequence defined with START WITH=1, INCREMENT=2, MAXVALUE=10 will generate a maximum value of 9, and will not generate the value 10.

      When a sequence is defined with CYCLE, any application conversion tools (for converting applications from other vendor platforms to DB2) should also explicitly specify MINVALUE, MAXVALUE, and START WITH.

  • You can define a sequence such that it always returns the same (or a constant) value. To create a constant sequence, use either of these techniques when defining the sequence:
    • Specify an INCREMENT value of zero and a START WITH value that does not exceed MAXVALUE.
    • Specify the same value for START WITH, MINVALUE, and MAXVALUE, and specify CYCLE. A constant sequence can be used as a numeric global variable. You can use ALTER SEQUENCE to adjust the values that are generated for a constant sequence.
  • After XDB generates a value for a sequence, that value can be said to be "consumed" regardless of whether or not that value is utilized by the application or not. The value is not reused within the current cycle. A consumed value may not be utilized when the statement that caused the value to be generated fails for some reason or is rolled back after the value was generated. Generated but unused values may constitute gaps in a sequence.
  • Consecutive values in a sequence differ by the constant INCREMENT BY value specified for the sequence. However, gaps can be introduced in a sequence in situations like the following ones:
    • A transaction has advanced the sequence and then rolls back.
    • The SQL statement leading to the generation of the next value fails after the value was generated.
    • The NEXT VALUE expression is used in the SELECT statement of a cursor in a DRDA environment where the client uses block-fetch and not all retrieved rows are fetched by the application.
    • The sequence is altered and then the alteration is rolled back.
    • The sequence is dropped and then the dropping is rolled back.

      Values of such gaps are not available for the current cycle, unless the sequence is altered and restarted in a specific way to make them available.

      A sequence is incremented independently of a transaction. Thus, a given transaction increments the sequence two times may see a gap in the two numbers that it receives if other transactions concurrently increment the same sequence. Most applications can tolerate these instances as these are not really gaps.

  • It is possible the duplicate values can be generated for a sequence. Duplicate values are most likely to occur when a sequence is defined with the CYCLE option, is defined as a constant sequence, or is altered. For example, the following situations could cause duplicate sequence values:
    • A sequence is defined with the attributes START WITH=2, INCREMENT BY 2, MINVALUE=2, MAXVALUE=10, and CYCLE.
    • The ALTER SEQUENCE statement is used to restart the sequence with a value that has already been generated.
    • The ALTER SEQUENCE statement is used to reverse the ascending direction of a sequence by changing the INCREMENT BY value from a positive to a negative.
  • A sequence can be referenced using a sequence reference. A sequence reference can appear in most places that an expression can appear. A sequence reference can specify whether the value to be returned is a newly generated value or the previously generated value. A NEXT VALUE sequence expression is used to generate a new value. A PREVIOUS VALUE sequence expression is used to obtain the last assigned value of a sequence.
  • To provide compatibility with previous releases, XDB supports the following keywords:
    • NOMINVALUE (single key word) as a synonym for NO MINVALUE
    • NOMAXVALUE (single key word) as a synonym for NO MAXVALUE
    • NOCYCLE (single key word) as a synonym for NO CYCLE
    • NOCACHE (single key word) as a synonym for NO CACHE
    • NOORDER (single key word) as a synonym for NO ORDER
Parent topic: SQL Statements


CREATE STOGROUP

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

The XDB Server checks to verify whether the AuthID issuing this command has either the CREATESG privilege, or SYSADM or SYSCTRL authority for the location.

Syntax

CREATE STOGROUP stogroup-name
    VOLUMES (volume-id[,...])
    VCAT catalog-name [PASSWORD password]

Parameters:

stogroup-name | Identifies the stogroup. This 1 to 8 characters name must be unique among stogroup names created at the currently set location.
volume-id | Identifies one or more Volume IDs, any of which can be associated (by updating the SYSIBM.SYSVOLUMES table) with a path designated specifically for the named stogroup.
catalog-name | Identifies an Integrated Catalog Facility catalog existing on a DB2-mainframe system.
password | Furnishes a VSAM control or master level password for the ICF catalog on a DB2-mainframe system.

Description

The stogroup feature allows XDB Server users greater control in assigning objects to specific directory paths. For example, you can assign storage of individual data objects to specially created stogroup directories (such as E:\STOR1\ or D:\STOR2\).

VOLUMES

This clause assigns a series of volume-id values (limit of 133) to the named stogroup. The XDB Server stores these values in the VOLID column of the SYSIBM.SYSVOLUMES catalog table. Whenever the stogroup is specified in an object creation command, the XDB Server uses these volume-id values to physically store the new objects on the path recorded in SYSIBM.SYSVOLUMES for the named stogroup. Users must first manually update the XDBPRIMEVOLPATH and XDBVOLPATH columns in SYSIBM.SYSVOLUMES. These columns associate a physical path with the value recorded in the VOLID column.

Asterisks are recognized only by Storage Management Subsystem (SMS). Contact your site's storage administrator to determine if the SMS Guaranteed Space attribute applies. If SMS Guaranteed Space does not apply for SMS-managed data sets, it is recommended that the VOLUMES clause be specified with one asterisk, VOLUMES('*' ). If SMS Guaranteed Space does apply, contact your site storage manager and refer to DFSMS/MVS: Access Method Services for the Integrated Catalog and DFSMS/MVS: Storage Administration Reference for DFSMSdfp for information on how to specify the VOLUMES clause.

Note:

There is no specific limit on the number of volumes that can be defined for a storage group. However, the maximum number of volumes that can be managed for a storage group is 133. Thus, there is no point in creating a storage group with more than 133 volumes.

VCAT

Although this clause has no physical functionality within the XDB Server system architecture, the keyword VCAT and a catalog-name value of "xdb" must be specified when working in DB2 mode. This information is recorded in the catalog tables for the current XDB Server location. The password parameter is also mainframe-specific, and is recorded in the XDB Server catalog tables.

Example:

The following command (executed in DB2 mode) creates a stogroup named STOR1 and assigns a volume-id value of "myid" to the VOLID column of the SYSIBM.SYSVOLUMES catalog table:

CREATE STOGROUP stor1 VOLUMES (myid) VCAT xdb;

The next example updates the SYSIBM.SYSVOLUMES catalog table by associating a user-created path (D:\STOR1) with myid:

UPDATE SYSIBM.SYSVOLUMES
    SET xdbprimevolpath = "y"
    , xdbvolpath = "d:\stor1\"
WHERE volid = "myid";
Parent topic: SQL Statements


CREATE SYNONYM

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

No special authorization is required. However, you must possess the appropriate privileges on the object to which the synonym refers before you can use the synonym. If dynamically prepared, the synonym is owned by the CURRENT SQLID.

In the case of users with SYSADM authority, ownership can be assigned to other users by first changing the CURRENT SQLID special register value, and then issuing the CREATE SYNONYM statement. The originally recorded AuthID for a synonym is the only AuthID for which the synonym is defined, and the only AuthID that can drop the synonym.

Syntax

CREATE SYNONYM synonym
FOR authorization-name.{table-name | view-name}

Parameters:

synonym | Specifies the alternate name you want to define. The synonym may be up to 18 characters long, and must meet all other criteria for a table or view name. The synonym must be unique among the set of all table names, view names and synonyms in the current location.
authorization-name.{table-name or view-name} | Identifies an existing table or view (with associated AuthID) to which you intend to assign a synonym. The name must consist of two parts and must identify a table, view, or alias that exists at the current server. If a table is identified, it must not be an auxiliary table or a declared temporary table. If an alias is identified, it must be an alias for a table or view at the current server and the synonym is defined for that table or view.

Description

Synonyms can be used to assign alternate names to existing tables or views at the current location. Synonyms may be used interchangeably with their corresponding view or table names in SQL commands. If using a synonym name when granting or revoking privileges or creating indexes, the actual table or view name is substituted for the synonym name before the command is executed.

If a CREATE SYNONYM command denotes an alias name instead of an actual table or view, that table or view (not the named alias) is recorded in the system catalog as the object of the synonym. In these cases the connection between the synonym and alias is severed. If the original alias name is later dropped and redefined, the synonym naming the original table or view is still in effect.

Example:

The example below assigns the alternate name syscolumns for the system table SYSIBM.SYSCOLUMNS:

CREATE SYNONYM syscolumns FOR SYSIBM.SYSCOLUMNS

Once this synonym is created, the query:

SELECT * FROM syscolumns

returns the same result as:

SELECT * FROM SYSIBM.SYSCOLUMNS
Parent topic: SQL Statements


CREATE TABLE

CREATE TABLE clauses have been extended to include options for defining and dropping table check constraints, and specifying columns with user-defined defaults.

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

To execute the CREATE TABLE command, users must possess one (or more) privileges listed in at least one of the following:

  • DBADM, DBCTRL, DBMAINT or CREATETS authority for the database.
  • Overall SYSADM or SYSCTRL authority for the location.
  • CREATETAB privilege for the database that is implicitly or explicitly specified by the IN clause.

Additional privileges might be required in the following conditions:

  • The clause IN, LIKE or FOREIGN KEY is specified.
  • The data type of a column is a distinct type.
  • The table space is implicitly created.
  • A fullselect is specified.
  • A column is defined as a security label column.

If the statement is embedded in an application program, the privilege set is the privileges that are held by the authorization ID of the owner of the plan or package.

  • If the privilege set lacks SYSADM or SYSCTRL authority, DBADM authority for the database, or DBCTRL authority for the database, the qualifier (owner) of the table must be the same as the authorization ID of the owner of the plan or package.
  • If the privilege set includes SYSADM or SYSCTRL authority, DBADM authority for the database, or DBCTRL authority for the database, the qualifier (owner) of the table can be any authorization ID.

If the statement is dynamically prepared, the privilege set is the privileges that are held by the SQL authorization ID of the process.

  • If the privilege set lacks SYSADM or SYSCTRL authority, DBADM authority for the database, or DBCTRL authority for the database, the qualifier (owner) of the table must be the same as one of the authorization IDs of the process and the privilege set that is held by that authorization ID includes all privileges needed to create the table.
  • If the privilege set includes SYSADM or SYSCTRL authority, DBADM authority for the database, or DBCTRL authority for the database, the qualifier (owner) of the table can be any authorization ID.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

CREATE TABLE table-name
{
    (column-definition
        [unique-constraint]
        [referential-constraint]
        [select-command]
        [check-constraint] [,...])
     | LIKE {table-name | view-name} [INCLUDING IDENTITY [COLUMN ATTRIBUTES]]
     | materialized-query-definition
}
    [WITH RESTRICT ON DROP]
    [{IN [database-name.]tablespace-name
        | IN DATABASE database-name}]
    [partitioning-clause]
    [EDITPROC program-name]
    [VALIDPROC program-name]
    [AUDIT {NONE | CHANGES | ALL}]
    [OBID integer]
    [DATA CAPTURE {NONE | CHANGES}]
    [WITH RESTRICT ON DROP]
    [CCSID {ASCII | EBCDIC | UNICODE}]
     [{VOLATILE | NOT VOLATILE} [CARDINALITY]]

unique-constraint:

{UNIQUE | PRIMARY KEY}(column-name[,...])

referential-constraint:

FOREIGN KEY [constraint-name] (column-name[,...])
    references-clause

references-clause:

REFERENCES referenced-table
    [column-name ,...]
    [ON DELETE {RESTRICT | NO ACTION | CASCADE | SET NULL}]
    [ENFORCED | NOT ENFORCED]
    [ENABLE QUERY OPTIMIZATION]

check-constraint:

[CONSTRAINT constraint-name] CHECK (check-condition)

column-definition:

column-name data-type
    [NOT NULL]
    [column-constraint]
    [{UNIQUE | PRIMARY KEY}]
    [FOR {BIT | SBCS | MIXED} DATA]
    [default-clause]
    [GENERATED {ALWAYS | BY DEFAULT} [as-identity-clause]
    [references-clause]
    [check-constraint]
    [FIELDPROC program-name [(constant[,...])]]
    [AS SECURITY LABEL]

default-clause:

[WITH] DEFAULT
[{constant | USER | CURRENT SQLID | NULL | cast-function-name ({constant | USER | CURRENT SQLID | NULL})}]

data-type:

{built-in-data-type | distinct-type-name}

built-in-data-type:

SMALLINT |
{INTEGER | INT} |
{DECIMAL | DEC | NUMERIC} [integer[,...]] |
{FLOAT [integer] | REAL [PRECISION] | DOUBLE} |
{ {CHARACTER | CHAR} [(integer)] | {CHARACTER | CHAR} VARYING (integer) | VARCHAR (integer) }
[FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII}] |
{{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(integer [K|M|G])] }
[FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII}] } |
{BINARY LARGE OBJECT | BLOB} (integer [K|M|G]) |
{GRAPHIC [(integer)] | VARGRAPHIC (integer) | DBCLOB (integer [K|M|G])} [CCSID {EBCDIC | ASCII}] |
{DATE | TIME | TIMESTAMP} |
ROWID

as-identity-clause:

AS IDENTITY
[({START WITH {numeric-constant | 1}
| INCREMENT BY {numeric-constant | 1}
| MINVALUE numeric-constant | NOMINVALUE
| MAXVALUE numeric-constant | NOMAXVALUE
| CYCLE | NOCYCLE
| ORDER | NO ORDER
| {CACHE 20 | NO CACHE | CACHE integer}}][,..])]

partitioning-clause:

PARTITION BY [RANGE] (partition-expression[,...]) (partition-element[,...])

partition-expresion:

column-name [NULLS LAST] [ASC | DESC]

partition-element:

PARTITION integer ENDING [AT] (constant[,...]) [INCLUSIVE]

materialized-query-definition:

[(column-name[,...])] AS (fullselect)
{WITH NO DATA [copy-options] | refreshable-table-options}

copy-options:

[EXCLUDING IDENTITY [COLUMN ATTRIBUTES] |
INCLUDING IDENTITY [COLUMN ATTRIBUTES]]
[EXCLUDING [COLUMN] DEFAULTS | INCLUDING [COLUMN] DEFAULTS | USING TYPE DEFAULTS]

refreshable-table-options:

DATA INITIALLY DEFERRED REFRESH DEFERRED
[[MAINTAINED BY SYSTEM | MAINTAINED BY USER]
[ENABLE QUERY OPTIMIZATION | DISABLE QUERY OPTIMIZATION] ...]

Parameters:

table-name | Any long identifier naming the table. The name must uniquely identify the table, and must not match any other table, view, alias, or synonym name existing within the current location. If qualified, the table name consists of a two-part or three-part name. If a three-part name is specified, the first part must match the value of the CURRENT SERVER special register -- that is, the current location. In any case, the AuthID qualifying the table name is the table owner.
column-name | Any long identifier naming the column. Each column in a table must have an unqualified column name, unique within the table. Dependent tables (tables containing a foreign key referencing a primary key in another table) can have up to 749 columns named, while nondependent tables (tables containing the primary key) may have 750 named columns. Column names are optional only when the select-command statement is included, in which case the column names from the source table are used.
constant FIELDPROC clause: a parameter passed to the field procedure when it is invoked during execution of the CREATE TABLE statement. A parameter list is optional, and the number of parameters and the data type of each are determined by the field procedure. The maximum length of the parameter list is 254 bytes, including commas but excluding insignificant blanks and the delimiting parentheses.

[WITH] DEFAULT clause: names the default value for the column. The value of the constant must conform to the rules for assigning that value to the column. A default value can be specified for a column with a data type of LONG VARCHAR or LONG VARGRAPHIC and a maximum length of 254 bytes.

A character or graphic string constant must be short enough so that its UTF-8 representation requires no more than 1536. In addition, a hexadecimal graphic string constant (GX) cannot be specified.

data-type Specifies the column data type. Data type is optional only when a select-command statement is included. FOR BIT DATA is optional; it is for use with CHAR, VARCHAR and LONG VARCHAR columns to indicate that the contents of the field values are to be treated as bit (binary) data. This is important for COBOL programs that use character and variable character fields to store integers, structures, etc. If not specified as FOR BIT DATA, the field is assumed to contain ASCII characters. Note that the FOR BIT DATA clause must precede the NULL specification for the field.

To conform with DB2 mainframe-specific operations, the XDB Server also records the FOR SBCS DATA and FOR MIXED DATA clause options in the appropriate system catalog tables.

NOT NULL is an optional instruction that prevents the column from containing null values.

NOT NULL WITH DEFAULT prevents columns from containing null values. When an attempt is made to place a NULL value in such a column, a default value is inserted. The default value is dependent on the data type as shown in the following table.

built-in-data-type Specifies the data type of the column as one of the following built-in data types, and for character string data types, specifies the subtype. If you define the table with a LOB column (CLOB, DBCLOB, or BLOB), you must also define a ROWID column.

[WITH] DEFAULT clause: In a given column definition neither NOT NULL nor DEFAULT can be specified more than once. Both NOT NULL and DEFAULT cannot be specified. Omitting NOT NULL and DEFAULT implies that DEFAULT NULL is intended.

Data Type | Default Value
Numeric | 0
Date | current date
Time | current time
Timestamp | current timestamp
Character | Blanks
Varchar | Blanks
Graphic | Blanks
Column Name | Data Type
Data Type | Default Value
select-command | Can consist of any SELECT statement that retrieves data values from a database and inserts them into the newly created table. See CREATE With SELECT below.
column-name | Names a column on which a key is to be created. Up to 64 columns can be included in the key. If creating a PRIMARY key, a unique index must be created on the table; in this index exactly the same column names must appear, in exactly the same order as in the PRIMARY KEY constraint. The index will be designated the primary key. See PRIMARY KEY below and the CREATE GLOBAL TEMPORARY TABLE command for more information.
constraint-name Defines a FOREIGN KEY constraint (which cannot be a unique index). If constraint-name is not specified in the command, the system generates a constraint name by taking the first eight characters of the first column name and checking for uniqueness. If not unique, the XDB Server adds a number to the first seven characters of the this first column name, and checks for uniqueness again. If necessary, additional character(s) at the end of the column name string are replaced with numbers until the name becomes unique among all constraint names on the table.

Also defines a table CHECK constraint within the CONSTRAINT...CHECK clause. The constraint-name is an SQL long identifier. A constraint-name cannot be specified more than once for the same table (see CONSTRAINT keyword).

check-condition

Provides a shorthand method of defining a check constraint that applies to a single column.

A check condition can consist of a single predicate, or two or more predicates joined by AND or OR. The first operand of each predicate must be the name of a column of the table. The second operand can be a column name or a constant. A check-condition can evaluate to unknown if a column that is an operand of the predicate is null. A check-condition that evaluates to unknown does not violate the check constraint (see CHECK clause).

For conformance with the SQL standard, if CHECK is specified in the column definition of column C, no columns other than C should be referenced in the check condition of the check constraint. The effect is the same as if the check condition were specified as a separate clause.

referenced-table Identifies the table referenced by the referential integrity constraint (or the parent table containing the primary key referenced).

The ON DELETE or ON UPDATE (XDB mode only) clause tells the system how to handle dependent records in this table when a corresponding record in the parent table is being deleted. The RESTRICT option (default) prevents the record from being deleted from the parent table. The CASCADE option deletes or updates the dependent records from the current table, and allows the deletion or updating of the parent record. The SET NULL option causes the foreign key fields in the dependent records to be set to NULL before the parent record is deleted.

item_no | SMALLINT (nulls not permitted)
Description | CHAR 12
Model | CHAR 6
Type | CHAR 12
Weight | FLOAT
Qoh | INTEGER
unit_cost | DECIMAL(6,3)
Price | MONEY
SBCS | Column holds single-byte data.
MIXED | Column holds mixed data. Do not specify MIXED if the value of field MIXED DATA on installation panel DSNTIPF is NO.
BIT | Column holds BIT data. Do not specify BIT for a CLOB column.
Numeric | 0
Fixed-length string | Blanks
Varying-length string | A string of length 0
Date | CURRENT DATE
Time | CURRENT TIME
Timestamp | CURRENT TIMESTAMP
Distinct type | The default of the source data type
ALWAYS | Indicates that XDB will always generate a value for the column when a row is inserted into the table. ALWAYS is the recommended value unless you are using data propagation.
BY DEFAULT Indicates that XDB will generate a value for the column when a row is inserted into the table unless a value is specified.

For a ROWID column, XDB uses a specified value only if it is a valid row ID value that was previously generated by XDB and the column has a unique, single-column index. Until this index is created on the ROWID column, the SQL INSERT statement and the LOAD utility cannot be used to add rows to the table. If the value of special register CURRENT RULES is 'STD' when the CREATE TABLE statement is processed, XDB implicitly creates the index on the ROWID column. The name of this index is 'I' followed by the first ten characters of the column name followed by seven randomly generated characters. If the column name is less than ten characters, XDB adds underscore characters to the end of the name until it has ten characters. The implicitly created index has the COPY NO attribute.

For an identity column, XDB inserts a specified value but does not verify that it is a unique value for the column unless the identity column has a unique, single-column index. Without a unique index, XDB can guarantee unique values only among the set of system-generated values.

BY DEFAULT is the recommended value only when you are using data propagation.

START WITH numeric-constant | Specifies the first value for the identity column. The value can be any positive or negative value that could be assigned to the column without non-zero digits exisiting to the right of the decimal point. The default is 1.
INCREMENT BY numeric-constant Specifies the interval between consecutive values of the identity column. The value can be any positive or negative value (including 0) that does not exceed the value of a large integer constant, and could be assigned to the column without any non-zero digits existing to the right of the decimal point. The default is 1.

If this value is negative, the values for the identity column descend. If this value is 0 or positive, the values for the identity column ascend. The default is 1.

PRIMARY_ID | CHAR(8) | WITH DEFAULT USER,
PRIMARY_ID | CHAR(8) | WITH DEFAULT USER,
SQL_ID | CHAR(8) | WITH DEFAULT CURRENT SQLID,

Description

XDB Server tables can be created using the CREATE TABLE command. Tables can also be created using SQLWizard. For more information on SQLWizard, see the SQLWizard User's Guide. The XDB Server supports a CREATE with SELECT command which allows a table to be created and populated in one command execution. The CREATE LIKE command allows the creation of a table using an existing table or view specification. See CREATE LIKE below.

The following example creates the table INVENT:

CREATE TABLE invent
    (item_no SMALLINT NOT NULL,
     description CHAR (12),
     model CHAR (6),
     type CHAR 12,
     weight FLOAT,
     qoh INTEGER,
     unit_cost DECIMAL(6,3),
     price MONEY)

The INVENT table will have the structure shown in the following table:

Column Name | Data Type
item_no | SMALLINT (nulls not permitted)
Description | CHAR 12
Model | CHAR 6
Type | CHAR 12
Weight | FLOAT
Qoh | INTEGER
unit_cost | DECIMAL(6,3)
Price | MONEY

Once a table has been created, data can be entered or indexes created. The column types and the number of columns can be changed using the ALTER TABLE command. The table name can be changed by the RENAME command. The table can also be altered or renamed using SQLWizard. (For more information on SQLWizard, see the SQLWizard User's Guide.)

With DB2 V7, XDB locations (either EBCDIC or ASCII) can now contain Unicode data. If you create a table with CCSID UNICODE, all character data in corresponding tables is stored in UTF-8 format and all graphic data is stored in UTF-16 format.

FOR subtype DATA

Specifies a subtype for a character string column, which is a column with a data type of CHAR, VARCHAR, LONG VARCHAR, or CLOB. Do not use the FOR DATA clause with columns of any other data type (including any distinct type). subtype can be one of the following:

SBCS | Column holds single-byte data.
MIXED | Column holds mixed data. Do not specify MIXED if the value of field MIXED DATA on installation panel DSNTIPF is NO.
BIT | Column holds BIT data. Do not specify BIT for a CLOB column.

If you do not specify the FOR clause, the column is defined with a default subtype. The default is SBCS when the value of field MIXED DATA on installation panel DSNTIPF is NO. The default is MIXED when the value is YES.

A security label column is always considered SBCS data, regardless of the encoding scheme of the table.

XDB Server operating environment does not support the CLOB data type at this time.

GRAPHIC (integer)

For a fixed-length graphic string of length integer, which can range from 1 to 127. If the length specification is omitted, a length of 1 character is assumed.

VARGRAPHIC (integer)

For a varying-length graphic string of maximum length integer, which must range from 1 to n/2, where n is the maximum row size minus 2 bytes. An integer longer than 127 defines a long string column.

ROWID

For a row ID type.

A table can have only one ROWID column. The values in a ROWID column are unique for every row in the table and cannot be updated. You must specify NOT NULL with ROWID.

NOT NULL

Prevents the column from containing null values.

PRIMARY KEY

Provides a shorthand method of defining a primary key composed of a single column. Thus, if PRIMARY KEY is specified in the definition of column C, the effect is the same as if the PRIMARY KEY(C) clause is specified as a separate clause.

The NOT NULL clause must be specified with this clause. Each column-name must be an unqualified name that identifies a column of the table except a LOB or ROWID column (including a distinct type that is based on a LOB or ROWID), and the same column must not be identified more than once. The number of identified columns must not exceed 64. In addition, the sum of the length attributes of the columns must not be greater than 2000 -2m, where m is the number of varying-length columns in the key.

The table is marked as unavailable until its primary index is explicitly created unless the CREATE TABLE statement is processed by the schema processor. In that case, DB2 implicitly creates an index to enforce the uniqueness of the primary key and the table definition is considered complete.

UNIQUE

Provides a shorthand method of defining a unique key composed of a single column. Thus, if UNIQUE is specified in the definition of column C, the effect is the same as if the UNIQUE(C) clause is specified as a separate clause.

The NOT NULL clause must be specified with this clause. UNIQUE cannot be specified more than once in a column definition and must not be specified if the PRIMARY KEY clause is specified in the column definition or if the definition is for a LOB column. The number of identified columns must not exceed 64. In addition, the sum of the length attributes of the columns must not be greater than 2000 -2m, where m is the number of varying-length columns in the key.

Each column-name must be an unqualified name that identifies a column of the table except a LOB column, and the same column must not be identified more than once.

DEFAULT

The default value assigned to the column in the absence of a value specified on INSERT or LOAD. Do not specify DEFAULT for a ROWID column, an identity column (a column that is defined AS IDENTITY) or a security label column (a column that is defined AS SECURITY LABEL); DB2 generates default values. If a value is not specified after DEFAULT, the default value depends on the data type of the column, as follows:

Data Type | Default Value
Numeric | 0
Fixed-length string | Blanks
Varying-length string | A string of length 0
Date | CURRENT DATE
Time | CURRENT TIME
Timestamp | CURRENT TIMESTAMP
Distinct type | The default of the source data type

A default value other than the one that is listed above can be specified in one of the following forms, except for a LOB column. The only form that can be specified for a LOB column is DEFAULT NULL. Unlike other varying-length strings, a LOB column can only have the default value of a zero-length string as listed above or null.

GENERATED

Specifies that XDB generates values for the column. GENERATED must be specified if the column is to be considered an identity column. If the data type of the column is a ROWID (or a distinct type that is based on a ROWID), the default is GENERATED ALWAYS.

ALWAYS Indicates that XDB will always generate a value for the column when a row is inserted into the table. ALWAYS is the recommended value unless you are using data propagation.
BY DEFAULT Indicates that XDB will generate a value for the column when a row is inserted into the table unless a value is specified.

For a ROWID column, XDB uses a specified value only if it is a valid row ID value that was previously generated by XDB and the column has a unique, single-column index. Until this index is created on the ROWID column, the SQL INSERT statement and the LOAD utility cannot be used to add rows to the table. If the value of special register CURRENT RULES is 'STD' when the CREATE TABLE statement is processed, XDB implicitly creates the index on the ROWID column. The name of this index is 'I' followed by the first ten characters of the column name followed by seven randomly generated characters. If the column name is less than ten characters, XDB adds underscore characters to the end of the name until it has ten characters. The implicitly created index has the COPY NO attribute.

For an identity column, XDB inserts a specified value but does not verify that it is a unique value for the column unless the identity column has a unique, single-column index. Without a unique index, XDB can guarantee unique values only among the set of system-generated values.

BY DEFAULT is the recommended value only when you are using data propagation.

AS SECURITY LABEL

Specifies that the column will contain security label values. This also indicates that the table is defined with multilevel security with row level granularity. A table can have only one security label column. To define a table with a security label column, the primary authorization ID of the statement must have a valid security label, and the RACF SECLABEL class must be active. In addition, the following conditions are also required:

  • The data type of the column must be CHAR(8).
  • The subtype of the column must be SBCS.
  • The column must be defined with the NOT NULL and WITH DEFAULT clauses.
  • No field procedures, check constraints, or referential constraints are defined on the column.
  • An edit procedure is not defined on the table.
  • You are using z/OS Version 1 Release 5 or later.

AS IDENTITY

Specifies that the column is an identity column for the table. A table can have only one identity column. AS IDENTITY can be specified only if the data type for the column is an exact numeric type with a scale of zero (SMALLINT, INTEGER, DECIMAL with a scale of zero, or a distinct type based on one of these types).

An identity column is implicitly NOT NULL.

START WITH numeric-constant | Specifies the first value for the identity column. The value can be any positive or negative value that could be assigned to the column without non-zero digits exisiting to the right of the decimal point. The default is 1.
INCREMENT BY numeric-constant | Specifies the interval between consecutive values of the identity column. The value can be any positive or negative value (including 0) that does not exceed the value of a large integer constant, and could be assigned to the column without any non-zero digits existing to the right of the decimal point. The default is 1. If this value is negative, the values for the identity column descend. If this value is 0 or positive, the values for the identity column ascend. The default is 1.

MINVALUE or NO MINVALUE

Specifies the minimum value at which a descending identity column either cycles or stops generating values or an ascending identity column cycles to after reaching the maximum value. The default is NO MINVALUE.

NO MINVALUE

Specifies that the minimum end point of the range of values for the identity column has not be set. In such a case, the default value for MINVALUE becomes one of the following:

  • For an ascending identity column, the value is the START WITH value or 1 if START WITH was not specified.
  • For a descending identity column, the value is the minimum value of the data type of the column.

MINVALUE numeric-constant

Specifies the numeric constant that is the minimum value that is generated for this identity column. This value can be any positive or negative value that could be assigned to this column without non-zero digits existing to the right of the decimal point. The value must be less than or equal to the maximum value.

MAXVALUE or NO MAXVALUE

Specifies the maximum value at which an ascending identity column either cycles or stops generating values or a descending identity column cycles to after reaching the minimum value. The default is NO MAXVALUE.

NO MAXVALUE

Specifies that the minimum end point of the range of values for the identity column has not be set. In such a case, the default value for MAXVALUE becomes one of the following:

  • For an ascending identity column, the value is the maximum value of the data type of the column.
  • For a descending identity column, the value is the START WITH value or -1 if START WITH is not specified.

MAXVALUE numeric-constant

Specifies the numeric constant that is the maximum value that is generated for this identity column. This value can be any positive or negative value that could be assigned to this column without non-zero digits existing to the right of the decimal point. The value must be greater than or equal to the minimum value.

NO CYCLE or CYCLE

Specifies whether this identity column should continue to generate values after reaching either its maximum or minimum value.

NO CYCLE

Specifies that values will not be generated for the identity column after the maximum or minimum value has been reached. This is the default.

CYCLE

Specifies that values continue to be generated for the identity column after the maximum or minimum value has been reached. If this option is used, after an ascending identity column reaches the maximum value, it generates its minimum value. After a descending identity column reaches its minimum value, it generates its maximum value. The maximum and minimum values for the identity column determine the range that is used for cycling.

When CYCLE is in effect, duplicate values can be generated by DB2 for an identity column. However, if a unique index exists on the identity column and a non-unique value is generated for it, an error occurs.

CACHE or NO CACHE

This clause has no functional equivalent in the XDB Server operating environment.

NO ORDER or ORDER

Specifies whether the identity column values must be generated in order of request. The default is NO ORDER.

NO ORDER

Specifies that the values do not need to be generated in order of request.

ORDER

Specifies that the values are generated in order of request. Specifying ORDER may disable the caching of values. ORDER applies only to a single-application process.

In a data sharing environment, if the CACHE and NO ORDER options are in effect, multiple caches can be active simultaneously, and the requests for identity values from different DB2 members may not result in the assignment of values in strict numeric order. For example, if members DB2A and DB2B are using the identity column, and DB2A gets the cache values 1 to 20 and DB2B gets the cache values 21 to 40, the actual order of values assigned would be 1,21,2 if DB2A requested a value first, then DB2B requested, and then DB2A again requested. Therefore, to guarantee that identity values are generated in strict numeric order among multiple DB2 members using the same identity column, specify the ORDER option.

PARTITION BY RANGE

Specifies the range partitioning scheme for the table (the columns used to partition the data). When this clause is specified, the table space is complete, and it is not necessary to create a partitioned index on the table. If this clause is used, the ENDING AT clause cannot be used on a subsequent CREATE INDEX statement for this table.

If this clause is specified, the IN database-name.table-space-name clause is required. This clause applies only to tables in a partitioned table space.

This clause is only implemented syntactically in the XDB Server operating environment.

partition-expression

Specifies the key data over which the range is defined to determine the target data partition of the data.

column-name

Specifies the columns of the key. Each column-name must identify a column of the table. Do not specify more than 64 columns, the same column more than once, a LOB column, a column with a distinct type that is based on a LOB data type, or a qualified column name. The sum of length attributes of the columns must not be greater than 255 - n, where n is the number of columns that can contain null values.

NULLS LAST

Specifies that null values are treated as positive infinity for purposes of comparison.

ASC

Puts the entries in ascending order by the column. ASC is the default.

DESC

Puts the entries in descending order by the column.

partition-element

Specifies ranges for a data partitioning key and the table space where rows of the table in the range will be stored.

PARTITION integer

integer is the physical number of a partition in the table space. A PARTITION clause must be specified for every partition of the table space. In this context, highest means highest in the sorting sequences of the columns. In a column defined as ascending (ASC), highest and lowest have their usual meanings. In a column defined as descending (DESC), the lowest actual value is highest in the sorting sequence.

This clause is only implemented syntactically in the XDB Server operating environment.

ENDING AT(constant, ...)

constant defines the limit key for a partition boundary. Specify at least one constant after ENDING AT in each PARTITION clause. You can use as many constants as there are columns in the key. The concatenation of all the constants is the highest value of the key for ascending and the lowest for descending. The use of constants to define key values is subject to the following rules:

  • The first constant corresponds to the first column of the key, the second constant to the second column, and so on. Each constant must conform to the rules for assigning that value to the column. A hexadecimal string constant (GX) cannot be specified.

    Using fewer constants than there are columns in the key has the same effect as using the highest or lowest values for the omitted columns, depending on whether they are ascending or descending.

  • The highest value of the key in any partition must be lower than the highest value of the key in the next partition for ascending cases.
  • The constants specified for the last partition are enforced. The value specified for the last partition is the highest value of the key that can be placed in the table. Any key values greater than the value specified for the last partition are out of range.
  • The precision and scale of a decimal constant must not be greater than the precision and scale of its corresponding column.
  • If a string constant is longer or shorter than required by the length attribute of its column, the constant is either truncated or padded on the right to the required length. If the column is ascending, the padding character is X'FF'. If the column is descending, the padding character is X'00'.
  • If a key includes a ROWID column or a column with a distinct type that is based on a ROWID data type, then 17 bytes of the constant that is specified for the corresponding ROWID column are considered.

INCLUSIVE

Specifies that the specified range values are included in the data partition.

CREATE With SELECT

The CREATE command may include an optional SELECT command (XDB mode only) that selects data from an existing table to insert into the new table. The order of the selected columns defines the column order of the new table. However, the number of columns selected does not need to match the number of columns defined for the new table. If the new table has more columns than the SELECT statement, the extra columns are assigned NULL values. If the new table has fewer columns than the SELECT command, the system uses only as many of the first columns as will fit into the new table. If no column names are given in the create command, the column names listed in the SELECT command are used to create the table.

Any search condition can be used in the SELECT statement including a join condition or a subselect. See WHERE Clause for more information on search conditions. The columns selected do not have to match the data type of the new table columns, but they must be type-compatible. The new table, for example, accepts floating point data in a column defined as an integer -- however, the fractional part of the data is truncated. See the ALTER TABLE command for a type compatibility matrix. When converting from character data to another type, if the conversion is not possible the new value will be NULL.

Three examples of CREATE with SELECT are given below:

CREATE TABLE parispno
    (pno CHAR 2, pname CHAR 6, city CHAR 6,
     weight DECIMAL(4,3))
    SELECT pno, pname, city
        FROM part
        WHERE city = "PARIS"
CREATE TABLE lowinv
    SELECT *
        FROM partsupp
        WHERE qty < 400
CREATE TABLE (a, b, c)
    SELECT A.a, B.b, C.c
        FROM A, B, C
        WHERE A.x = B.x
          AND B.x = C.x

Subselects and Locations

When populating new tables with subselects, the subselect cannot reference a location other than the one referenced elsewhere in the command. That is, a referenced table and all subselects in a single SQL statement must be from the same location.

Invalid:

CREATE TABLE tutorial.tutorial.sample
    SELECT * FROM tutorial.tutorial.employee
        WHERE e_no IN
            SELECT e_no FROM debloc.debbie.employee
                WHERE st = "MD";

Valid:

CREATE TABLE tutorial.tutorial.sample
    SELECT * FROM tutorial.tutorial.employee
        WHERE e_no IN
            SELECT e_no FROM tutorial.debbie.employee
                WHERE st = "MD";

CREATE LIKE

The LIKE table-name or LIKE view-name clause is used to create a new table with the same definition as an existing table or view. The columns of the table will have exactly the same names and column specifications (data type, null permission, etc.) as the source table or view. However, neither the primary nor foreign keys, nor any check option existing on the source table or view are defined for the new table. Data from the source table is NOT transferred to the new table.

An example of the CREATE TABLE...LIKE command is:

CREATE TABLE personnel LIKE employee

Creating a table like a view

If the LIKE clause is specified and the definition of the table is being based on a view, the view must not include a ROWID column or an identity column. A view column is considered to be an identity column if the corresponding column of the table or view indirectly or directly maps to the name of an identity column in a base table with these exceptions:

  • The select-list of the view definition identifies the same identity column more than once.
  • The select-list of the view definition references multiple identity columns and thus involves a join.
  • A column in the view definition includes an expression that refers to an identity column.

IN or IN DATABASE

Specifies a database-name alone (preceded by keyword IN DATABASE), or both a tablespace-name with an optional database-name qualifier (preceded by keyword IN). If a database is named, it must be described in the system catalog for the current location, and must not be the DSNDB06 catalog database.

If a table space name is not explicitly specified, a table space is created implicitly within database-name. In these cases, the XDB Server checks the privileges held by the user for either SYSADM or SYSCTRL authority for the location, DBADM, DBCTRL or DBMAINT authority for the database, or the CREATETS privilege for the database. The table space name is taken from the table name specified in the CREATE TABLE command. Except for the name, the other attributes of this table space match those that would result from a CREATE TABLESPACE statement minus all its optional clauses.

If tablespace-name is specified, this name must not reference an already existing table space that was implicitly created. If both a database and table space are specified, the table space must belong to the named database. If only a table space is named, it must belong to the default DSNDB04 database for the current location. If the table space references a stogroup, then any tables created with that table space name are stored in the path specified for the stogroup.

A subselect and an IN DATABASE clause cannot be used in the same CREATE TABLE statement. Instead, create the table in the database and then use an INSERT INTO command with a subselect to populate the table.

For example:

Invalid:

CREATE TABLE tutorial.debbie.employee
SELECT * FROM tutorial.tutorial.employee
    WHERE st = "MD"
IN DATABASE debdb;

Valid:

CREATE TABLE tutorial.debbie.employee (e_no SMALLINT NOT NULL,
    lname CHAR 10 NOT NULL,
    fname CHAR 10 NOT NULL, street CHAR 20,
    city CHAR 15, st CHAR 2, zip CHAR 5,
    dept CHAR 4, payrate MONEY, com DECIMAL(2,2))
IN DATABASE debdb;
INSERT INTO tutorial.debbie.employee
    SELECT * FROM tutorial.tutorial.employee
        WHERE st = "MD";

OBID integer

Identifies the OBID to be used for this table. An OBID is the identifier for an object's internal descriptor.

The OBID keyword option is used with ROSHARE databases, and can be viewed by querying the SYSIBM.SYSTABLES catalog table. The integer must not identify an existing or previously used OBID of the database. If you omit OBID, DB2 generates a value.

The following statement retrieves the value of OBID:

SELECT OBID
    FROM SYSIBM.SYSTABLES
    WHERE CREATOR = 'ccc' AND NAME = 'nnn';

Here, nnn is the table name and ccc is the table's creator

UNIQUE

Defines a unique key composed of the identified columns. Each column name must be an unqualified name that identifies a column of the table, and the same column must not be identified more than once. A unique key is a duplicate if it is the same as the primary key or a previously defined unique key. A unique key on a single column can be defined in a column definition. In a given column definition neither UNIQUE nor PRIMARY KEY can be specified more than once, nor can UNIQUE and PRIMARY KEY both be specified for the same column.

PRIMARY KEY

A table can have at most one constraint condition specified as a PRIMARY KEY. The purpose of the primary key is to enforce entity integrity -- that is, to uniquely identify each row of a table. Note that the columns in the primary key must be defined as NOT NULL when the columns are specified.

Note:

You must create an index for a primary key or a unique key if the CREATE TABLE statement is processed by the XDB Server. XDB Server does not implicitly create an index.

A primary key on a single column can be defined in a column definition. In a given column definition neither UNIQUE nor PRIMARY KEY can be specified more than once, nor can UNIQUE and PRIMARY KEY both be specified for the same column.

You cannot create foreign keys on tables that are in a pending state. A table is in a pending state if a primary key clause has been specified but a unique index has not been built on those columns.

For example, to define the SNO and PNO columns as the primary key of the PARTSUPP table, use the command:

CREATE TABLE partsupp(sno SMALLINT NOT NULL,
    pno SMALLINT NOT NULL,
    qty SMALLINT, PRIMARY KEY (sno, pno))

To define the SNO column as the primary key of the SUPPLIER table, use a command like:

CREATE TABLE supplier(sno CHAR 3 NOT NULL,
    sname CHAR 5, status SMALLINT,
    city CHAR 6, PRIMARY KEY (sno))

FOREIGN KEY

A FOREIGN KEY constraint is used to enforce referential integrity -- the relationship between a referencing (or dependent) table and a referenced (or parent) table. The referential integrity rule requires that, for any value in the dependent columns, there must exist a row in the parent table such that the value of the dependent columns equals the value of the corresponding columns in the primary key of the parent table. This is enforced as follows:

  1. When an update or insert is performed on the dependent table, the set of values placed in the referencing columns must match a set of values that exists in the parent table.
  2. If an attempt is made to delete or update a row of the parent table that contains values matching those in a dependent table, the system uses the ON DELETE or ON UPDATE (XDB Server extension only, not available on DB2 or other modes) clause to determine the delete rule to use. The options are:
    • RESTRICT

      Prevents record deletion from the parent table if dependents exist. RESTRICT is the default value.

    • NO ACTION

      Prevents records from being deleted from the parent table (as in the RESTRICT option), except the referential constraint is enforced at the end of the statement. This is the default setting if the CURRENT RULES special register is STD (SQL standard).

    • CASCADE

      Deletes the dependent records from the current table and then deletes the parent records.

    • SET NULL

      Causes each nullable column in the foreign key of each dependent record to be set to NULL before the corresponding parent records are deleted.

Note that whenever a cyclical situation exists (for example a foreign key of table B references the primary key of table A, and a foreign key of table A references a primary key of table B, the delete rules should be the same for all foreign keys, and the SET NULL option should not be used.

In order to create a referential integrity constraint you must create a FOREIGN KEY constraint on the referencing table. The FOREIGN KEY constraint must reference the existing PRIMARY KEY of the referenced table.

Foreign key columns do not need to have the same names as the corresponding columns in the PRIMARY KEY of the referenced table, but the columns must match in type, number and order.

Each column-name must be an unqualified name that identifies a column of the table except a LOB, ROWID, or security label column, and the same column must not be identified more than once. The number of identified columns must not exceed 64, and the sum of their length attributes must not exceed 255 minus the number of columns that allow null values. The referential constraint is a duplicate if the FOREIGN KEY and parent table are the same as the FOREIGN KEY and parent table of a previously defined referential constraint. The specification of a duplicate referential constraint is ignored with a warning.

A constraint name is used to uniquely identify a FOREIGN KEY constraint, and is stored in the appropriate system catalog table. The constraint name should be a short identifier (up to eight characters) that is unique among all constraints built on the table. Since this constraint name is also used in error messages to indicate constraint violation, it is important to use a meaningful name.

Although it is good practice to provide a meaningful constraint name, if one is not supplied, the system automatically generates one by taking the first eight characters of the first column (appearing in the column list) and then checking for uniqueness. If this name is not unique, the XDB Server takes the first seven characters of the first column name plus a number. If necessary one letter at a time is removed from the end of this constraint name and replaced with a number, until the constraint name becomes unique among all constraint names existing for the table.

Indexes on Foreign Keys

The XDB Server automatically builds an index on your FOREIGN KEY columns. The system will generate the name of the index and store it in the REFKEYNAME column of the SYSIBM.SYSREF catalog table. DB2, in contrast, does not automatically create an index on FOREIGN KEY columns. If you are using your DB2 data definition language (DDL) script, and this script contains CREATE INDEX commands on FOREIGN KEY columns, you can end up with redundant indexes. For optimal performance, you should modify your DB2 DDL script to remove any CREATE INDEX commands on FOREIGN KEY columns.

REFERENCES

The references portion of the referential-constraint clause is a separate clause. A single column can be identified as a foreign key of a referential constraint by using the references-clause in a column definition. Define a key that consists of more than one column by listing the column names to which the REFERENCES privilege applies.

Do not specify references-clause in the definition of a LOB, ROWID, or security label column; a LOB, ROWID, or security label column cannot be a foreign key.

A foreign key can reference a unique key or a primary key. When a foreign key refers to a nonprimary unique key, you must specify the columns of the key. If the foreign key includes a column defined as a distinct type, the corresponding column of the nominated parent key must be the same distinct type.

ENFORCED or NOT ENFORCED

Indicates whether or not the referential constraint is enforced by DB2 during normal operations, such as insert, update, or delete.

ENFORCED

Specifies that the referential constraint is enforced by the DB2 during normal operations (such as insert, update, or delete) and that it is guaranteed to be correct. This is the default.

NOT ENFORCED

Specifies that the referential constraint is not enforced by DB2 during normal operations, such as insert, update, or delete. This option should only be used when the data that is stored in the table is verified to conform to the constraint by some other method than relying on the database manager.

ENABLE QUERY OPTIMIZATION

Specifies that the constraint can be used for query optimization. DB2 uses the information in query optimization using materialized query tables with the assumption that the constraint is correct. This is the default.

LIKE table-name or view-name

Specifies that the columns of the table have exactly the same name and description as the columns of the identified table or view. The name specified after LIKE must identify a table or view that exists at the current server, and the privilege set must implicitly or explicitly include the SELECT privilege on the identified table or view. An identified view must not include a column that is an explicitly defined ROWID column (including a distinct type that is based on a ROWID) or an identity column.

The use of LIKE is an implicit definition of n columns, where n is the number of columns in the identified table or view. The implicit definition includes all attributes of the n columns as they are described in SYSCOLUMNS with these exceptions:

  • When a table is identified in the LIKE clause and a column in the table has a field procedure, the corresponding column of the new table has the same field procedure and the field description. However, the field procedure is not invoked during the execution of the CREATE TABLE statement.
  • When a table is identified in the LIKE clause and a column in the table an identity column, the corresponding column of the new table inherits only the data type of the identity column; none of the identity attributes of the column are inherited unless the INCLUDING IDENTITY clause is specified.
  • When a table is identified in the LIKE clause and a column in the table is a security label column, the corresponding column of the new table inherits only the data type of the security label column; none of the security label attributes of the column are inherited.
  • When a table is identified in the LIKE clause and the table contains a ROWID column (explicitly-defined, hidden, or both), the corresponding columns of the new table inherits the ROWID columns.
  • When a view is identified in the LIKE clause, the default value that is associated with the corresponding column of the new table depends on the column of the underlying base table for the view. If the column of the base table does not have a default, the new column does not have a default. If the column of the base table has a default, the default of the new column is:
    • Null if the column of the underlying base table allows nulls.
    • The default for the data type of the underlying base table if the underlying base table does not allow nulls.
  • When a table that uses table-controlled partitioning is identified in the LIKE clause, the new table does not inherit that table's partitioning scheme. If desired, these partition boundaries can be added by specifying ALTER TABLE with the ADD PARTITION BY RANGE clause.
  • The CCSID of the column is determined by the implicit or explicit CCSID clause.

The above defaults are chosen regardless of the current default of the base table column. Also, no column in the new table has a field procedure because the catalog descriptions of view columns do not include field procedures.

The implicit definition does not include any other attributes of the identified table or view. For example, the new table does not have a primary key or foreign key. The table is created in the table space implicitly or explicitly specified by the IN clause, and the table has any other optional clause only if the optional clause is specified.

EXCLUDING IDENTITY COLUMN ATTRIBUTES or INCLUDING IDENTITY COLUMN ATTRIBUTES

Specifies whether identity column attributes are inherited from the definition of the source of the result table.

EXCLUDING IDENTITY COLUMN ATTRIBUTES

Specifies that identity column attributes are not inherited from the source result table definition. This is the default.

INCLUDING IDENTITY COLUMN ATTRIBUTES

Specifies that, if available, identity column attributes (such as START WITH, INCREMENT BY, and CACHE values) are inherited from the definition of the source table. These attributes can be inherited if the element of the corresponding column in the table, view, or fullselect is the name of a column of a table or the name of a column of a view that directly or indirectly maps to the column name of a base table with the identity attribute. In other cases, the columns of the new temporary table do not inherit the identity attributes. The columns of the new table do not inherit the identity attributes in the following cases:

  • The select list of the fullselect includes multiple instances of an identity column name (that is, selecting the same column more than once).
  • The select list of the fullselect includes multiple identity columns (that is, it involves a join).
  • The identity column is included in an expression in the select list.
  • The fullselect includes a set operation (union).

Using an identity column

When a table has an identity column, DB2 can automatically generate unique, sequential numeric values for the column as rows are inserted into the table. Thus, identity columns are ideal for primary keys. Identity columns and ROWID columns are similar in that both types of columns contain values that DB2 generates and guarantees as unique. ROWID columns are used in large object (LOB) table spaces and can be useful in direct-row access. ROWID columns contain values of the ROWID data type, which returns a 40-byte VARCHAR value that is not regularly ascending or descending. ROWID data values are therefore not well suited to many application uses, such as generating employee numbers or product numbers. For data that is not LOB data and that does not require direct-row access, identity columns are usually a better approach, because identity columns contain existing numeric data types and can be used in a wide variety of uses for which ROWID values would not be suitable.

When a table is recovered to a point-in-time, it is possible that a large gap in the sequence of generated values for the identity column might result. For example, assume a table has an identity column that has an incremental value of 1 and that the last generated value at time T1 was 100 and DB2 subsequently generates values up to 1000. Now, assume that the table space is recovered back to time T1. The generated value of the identity column for the next row that is inserted after the recovery completes will be 1001, leaving a gap from 100 to 1001 in the values of the identity column.

Sometimes you may need to change the attributes of an identity column, For example, if you had defined an identity column with a data type of SMALLINT and then run out of assignable values, you need to redefine the column as INTEGER. To change the attributes of an identity column, you unload the data from the table, drop the table, recreate the table, and reload athe data.

But when you recreate the table, you must specify GENERATED BY DEFAULT and a new START WITH value for the identify column.Using GENERATED BY DEFAULT allows LOAD to reload the previously existing identity column values. You cannot use GENERATED ALWAYS in this case, but not using it is not a problem since DB2 always generates a value if a column value is not provided during insertion of an identity column defined as GENERATED BY DEFAULT. The new START WITH value should be the next value in the sequence from where the original sequence of values left off; this value is the next value that DB2 would generate first.

WITH RESTRICT ON DROP

Indicates that the table cannot be dropped. Also, the database and table space that contain the table cannot be dropped.

If a table space is named, it must not be one that was created implicitly, be a partitioned table space that already contains a table, or be a LOB table space. If you name a partitioned table space, you cannot load or use the table until its partitioned index is created.

CCSID

The CCSID clause is only syntactically supported for EBCDIC and ASCII. This is because the definition of the XDB location itself defines how character data is stored.

If you specify UNICODE, your character and graphic data is stored as UNICODE within the table.

VOLATILE or NOT VOLATILE

Specifies how DB2 is to choose access to the table.

VOLATILE

Specifies that index access should be used on this table whenever possible for SQL operations. However, be aware that list prefetch and certain other optimization techniques are disabled when VOLATILE is used.

One instance in which use of VOLATILE may be desired is for a table whose size can vary greatly. If statistics are taken when the table is empty or has only a few rows, those statistics might not be appropriate when the table has many rows. Another instance in which use of VOLATILE may be desired is for a table that contains groups of rows, as defined by the primary key on the table. All but the last column of the primary key of such a table indicate the group to which a given row belongs. The last column of the primary key is the sequence number indicating the order in which the rows are to be read from the group. VOLATILE maximizes concurrency of operations on rows within each group, since rows are usually accessed in the same order for each operation.

NOT VOLATILE

Specifies that SQL access to this table should be based on the current statistics. NOT VOLATILE is the default.

CARDINALITY

An optional keyword that currently has no effect, but that is provided for DB2 family compatibility.

materialized-query-definition

Specifies that the column definitions are based on the result of a fullselect. If materialized-query-table-options are specified, the table is a materialized query table and the REFRESH TABLE statement can be used to populate the table with the results of the fullselect.

column-name

Names the columns in the table. If a list of column names is specified, it must consist of as many names as there are columns in the result table of the fullselect. Each column-name must be unique and unqualified. If a list of column names is not specified, the columns of the table inherit the names of the columns of the result table of the fullselect.

A list of column names must be specified if the result table of the fullselect has duplicate column names or an unnamed column. An unnamed column is a column derived from a constant, function, expression, or set operation that is not named using the AS clause of the select list.

AS(fullselect)

Specifies that the table definition is based on the column definitions from the result of a query expression. The use of AS (fullselect) is an implicit definition of n columns for the table, where n is the number of columns that would result from the fullselect. The columns of the new table are defined by the columns that result from the fullselect. Every select list element must have a unique name. The AS clause can be used in the select-clause to provide unique names. The implicit definition includes the column name, data type, and nullability characteristic of each of the result columns of fullselect.

If the fullselect is specified, for the statement that is embedded or prepared dynamically, the owner of the table being created must have the SELECT privilege on the tables or views referenced in the fullselect, or the privilege set must include SYSADM or DBADM authority for the database in which the tables of the fullselect reside. Having SELECT privilege means that the owner has at least one of the following authorizations:

  • Ownership of the tables or views referenced in the fullselect
  • The SELECT privilege on the tables and views referenced in the fullselect
  • SYSADM authority
  • DBADM authority for the database in which the tables of the fullselect reside

The rules for establishing the qualifiers for names used in the fullselect are the same as the rules used to establish the qualifiers for table-name. The fullselect must not refer to host variables or include parameter markers.

When WITH NO DATA is specified, the fullselect must not:

  • Reference a remote object.
  • Result in a column having a ROWID data type or a distinct type based on ROWID.
  • Result in a column having a BLOB, CLOB, or DBCLOB data type or a distinct type based on these data types.
  • Contain PREVIOUS VALUE or a NEXT VALUE expression.
  • Include an INSERT statement in the FROM clause. When a materialized query table is defined, the column attributes, such as DEFAULT and IDENTITY, are not inherited from the fullselect.

When DISABLE QUERY OPTIMIZATION is specified, the following additional restrictions apply:

  • The fullselect cannot contain a reference to a created global temporary table or a declared global temporary table.
  • The fullselect cannot reference another materialized query table.

When a materialized query table is defined with ENABLE QUERY OPTIMIZATION specified, the following additional restrictions apply:

  • The fullselect must be a subselect.
  • The subselect cannot include a function that is nondeterministic or has external actions. For example, a user-defined function that is defined with either EXTERNAL ACTION or NOT DETERMINISTIC or the RAND built-in function cannot be referenced.
  • The subselect cannot contain any predicates that include subqueries.
  • The subselect cannot contain:
    • A nested table expression or view that requires temporary materialization
    • A join using the INNER JOIN syntax
    • An outer join
    • A special register
    • A scalar fullselect
    • A row expression predicate
    • Sideway references
  • The outermost SELECT list of the subselect must not reference data that is encoded with different CCSID sets.
  • If the subselect references a view, the fullselect in the view definition must satisfy the preceding restrictions.

When fullselect does not satisfy the restrictions, an error occurs.

WITH NO DATA

Specifies that the query is used only to define the attributes of the new a table. The table is not populated using the results of the query and the REFRESH TABLE statement cannot be used. When the WITH NO DATA clause is specified, the table is not considered a materialized query table.

The columns of the table are defined based on the definitions of the columns that result from the fullselect.

copy-options

Specifies whether identity column attributes and column defaults are inherited from the definition of the source of the result table.

EXCLUDING IDENTITY COLUMN ATTRIBUTES or INCLUDING IDENTITY COLUMN ATTRIBUTES

Specifies whether identity column attributes are inherited.

EXCLUDING IDENTITY COLUMN ATTRIBUTES

Specifies that identity column attributes are not inherited from the definition of the source of the result table. This is the default.

INCLUDING IDENTITY COLUMN ATTRIBUTES

Specifies that, if available, identity column attributes (such as START WITH, INCREMENT BY, and CACHE values) are inherited from the definition of the source table. These attributes can be inherited if the element of the corresponding column in the table, view, or fullselect is the name of a column of a table or the name of a column of a view that directly or indirectly maps to the column name of a base table with the identity attribute. In other cases, the columns of the new temporary table do not inherit the identity attributes. The columns of the new table do not inherit the identity attributes in the following cases:

  • The select list of the fullselect includes multiple instances of an identity column name (that is, selecting the same column more than once).
  • The select list of the fullselect includes multiple identity columns (that is, it involves a join).
  • The identity column is included in an expression in the select list.
  • The fullselect includes a set operation (union).

EXCLUDING COLUMN DEFAULTS, INCLUDING COLUMN DEFAULTS, or USING TYPE DEFAULTS

Specifies whether column defaults are inherited.

EXCLUDING COLUMN DEFAULTS

Specifies that the column defaults are not inherited from the definition of the source table. The default values of the column of the new table are either null or there are no default values. If the column can be null, the default is the null value. If the column cannot be null, there is no default value, and an error occurs if a value is not provided for a column on INSERT for the new table.

INCLUDING COLUMN DEFAULTS

Specifies that column defaults for each updatable column of the definition of the source table are inherited. Columns that are not updatable do not have a default defined in the corresponding column of the created table.

USING TYPE DEFAULTS

Specifies that the default values for the table depend on data type of the columns that result from fullselect, as follows:

Data type | Default value
Numeric | 0
Fixed-length string | Blanks
Varying-length string | A string length of 0
Date | CURRENT DATE
Time | CURRENT TIME
Timestamp | CURRENT TIMESTAMP

refreshable-table-options

Specifies the options for a refreshable materialized query table.

DATA INITIALLY DEFERRED

Specifies that the data is not inserted into the materialized query table when it is created. Use the REFRESH TABLE statement to populate the materialized query table, or use the INSERT statement to insert data into a user-maintained materialized query table.

REFRESH DEFERRED

Specifies that the data in the table can be refreshed at any time using the REFRESH TABLE statement. The data in the table only reflects the result of the query as a snapshot at the time when the REFRESH TABLE statement is processed or when it was last updated for a user-maintained materialized query table.

MAINTAINED BY SYSTEM or MAINTAINED BY USER

Specifies how the data in the materialized query table is maintained.

MAINTAINED BY SYSTEM

Specifies that the materialized query table is maintained by the system. Only the REFRESH statement is allowed on the table. This is the default.

MAINTAINED BY USER

Specifies that the materialized query table is maintained by the user, who can use the LOAD utility or the INSERT, DELETE, UPDATE, SELECT FOR UPDATE, or REFRESH TABLE statements on the table.

ENABLE QUERY OPTIMIZATION or DISABLE QUERY OPTIMIZATION

Specifies whether this materialized query table can be used for optimization.

ENABLE QUERY OPTIMIZATION

Specifies that the materialized query table can be used for query optimization. If the fullselect specified does not satisfy the restrictions for query optimization, an error occurs. This is the default.

DISABLE QUERY OPTIMIZATION

Specifies that the materialized query table cannot be used for query optimization. The table can still be queried directly.

CONSTRAINT

Names a table check constraint. If a constraint-name is not specified, a unique constraint name is derived from the name of the first column in the check-condition specified in the definition of the table check constraint.

CHECK

Table check constraints can be defined on individual columns within the CREATE TABLE command. The check constraint is the check condition that defines the values that designated columns of the table can contain, with the following restrictions:

  • It can refer only to columns of table table-name; however, the columns cannot be LOB or ROWID columns.
  • It can be up to 3800 bytes long, not including redundant blanks.

It must not contain any of the following:

  • Subselects
  • Built-in or user-defined functions
  • Cast functions other than those created when the distinct type was created
  • Host variables
  • Parameter markers
  • Special registers
  • Columns that include a field procedure
  • CASE Expressions
  • Quantified predicates
  • EXISTS predicates
  • Row expressions
  • DISTINCT predicates
  • GX literals (hexadecimal graphic string constants)

For example, the CREATE TABLE command below builds the EMPLOYEE table with the following constraints:

  • Employee names must be a value other than NULL (this constraint is equivalent to specifying NOT NULL).
  • The Department number must be 1050.
  • The commission rate must be less than or equal to six percent.
CREATE TABLE EMPLOYEE
(
e_no         SMALLINT
lname        CHAR 10              CHECK (lname IS NOT NULL),
fname        CHAR 10              CHECK (fname IS NOT NULL),
street       CHAR 20,
city         CHAR 15,
st           CHAR 2,
zip          CHAR 5,
dept         CHAR 4               CHECK (dept='1050'),
payrate      MONEY,
com          DECIMAL(2,2),
CONSTRAINT   com CHECK (com <= 06)
)

A table check constraint is not enforced on the default value of a column when the constraint is defined. A table check constraint is enforced on the default value of a column when rows are inserted or updated.

The syntax of a table check constraint is checked when the constraint is defined but the meaning is not checked. A table check constraint is not checked for consistency with other types of constraints.

Check Constraint Storage

Table check information is stored in two new catalog tables:

  • SYSIBM.SYSCHECKS

    Contains one row for each table check constraint defined on a table.

  • SYSIBM.SYSCHECKDEP

    Contains a row for each reference to a column in a table check constraint.

Enforcing Check Constraints

After table check constraints are defined on a table, any change must satisfy those constraints if it is made by an INSERT or UPDATE statement. A row satisfies a check constraint if its condition evaluates either to true or to unknown. A condition can evaluate to unknown for a row if one of the columns named contains the null value for that row. For INSERT or UPDATE statements, table check constraints are enforced on views and their underlying tables.

CURRENT RULES Special Register

For populated tables, the enforcement of a table check constraint is determined by the value, STD or DB2, of the CURRENT RULES special register.

  • If the value is STD, a check constraint is enforced immediately when it is defined. If a row does not conform, the table check constraint is not added to the table and an error occurs.
  • If the value is DB2, the check constraint is added to the table description but its enforcement is deferred. Because there might be rows in the table that violate the check constraint, the table is placed in check pending status.

DEFAULT

You can define a table column that has a default value other than null. When a row is inserted and no value is specified for the column, the default you defined is assigned to the column.

The default value depends on the data type of the column. The DEFAULT clause allows you to specify a default value in one of the following forms:

  • A constant
  • The execution time value of the USER special register
  • The SQL authorization ID (SQLID) of the process
  • The null value

NOT NULL clause

In a given column definition neither NOT NULL nor DEFAULT can be specified more than once. Both NOT NULL and DEFAULT cannot be specified. Omitting NOT NULL and DEFAULT implies that DEFAULT NULL is intended.

For example, if you want to record the identity of anyone inserting rows into a table, define the table with two additional columns:

PRIMARY_ID | CHAR(8) | WITH DEFAULT USER,
SQL_ID | CHAR(8) | WITH DEFAULT CURRENT SQLID,

You can allow updates and inserts to the table only through a view that omits those columns. Then, the primary authorization ID and the SQLID of the process are added by default.

Example:

Constraint Examples

Batch SQL Example

  • Constraint Examples
  • Batch SQL Example
Parent topic: SQL Statements


Constraint Examples

The following table shows how referential integrity can be used to enforce common business rules by defining relationships between the CUSTOMER, ORDERS, PRODUCTS, ITEMS, and EMPLOYEE tables in the TUTORIAL location.

Business Rule | Database Relationships
1. | An order can be placed for a customer only if complete customer information is available. | Before inserting or updating into the ORDERS table, check for matching C_NO values in the CUSTOMER table. Do not delete CUSTOMER table record if orders for customer exist in the ORDERS table.
Business Rule | Database Relationships
1. | An order can be placed for a customer only if complete customer information is available. | Before inserting or updating into the ORDERS table, check for matching C_NO values in the CUSTOMER table. Do not delete CUSTOMER table record if orders for customer exist in the ORDERS table.
2. | Orders must be taken by an employee of the company. If a salesperson for an order is unknown, the order is treated as a house order. | Before updating or inserting into the ORDERS table, check whether S_NO value has matching E_NO in the EMPLOYEE table. Before deleting EMPLOYEE table records, set S_NO of corresponding ORDERS table records to null.
Business Rule | Database Relationships
1. | An order can be placed for a customer only if complete customer information is available. | Before inserting or updating into the ORDERS table, check for matching C_NO values in the CUSTOMER table. Do not delete CUSTOMER table record if orders for customer exist in the ORDERS table.
2. | Orders must be taken by an employee of the company. If a salesperson for an order is unknown, the order is treated as a house order. | Before updating or inserting into the ORDERS table, check whether S_NO value has matching E_NO in the EMPLOYEE table. Before deleting EMPLOYEE table records, set S_NO of corresponding ORDERS table records to null.
3. | A request for an item must always be associated with a specific order. | Before inserting or updating the ITEMS table, check whether O_NO columns have matching O_NO values in the ORDERS table. If ORDERS record is deleted, delete matching ITEMS table records.
Business Rule | Database Relationships
1. | An order can be placed for a customer only if complete customer information is available. | Before inserting or updating into the ORDERS table, check for matching C_NO values in the CUSTOMER table. Do not delete CUSTOMER table record if orders for customer exist in the ORDERS table.
2. | Orders must be taken by an employee of the company. If a salesperson for an order is unknown, the order is treated as a house order. | Before updating or inserting into the ORDERS table, check whether S_NO value has matching E_NO in the EMPLOYEE table. Before deleting EMPLOYEE table records, set S_NO of corresponding ORDERS table records to null.
3. | A request for an item must always be associated with a specific order. | Before inserting or updating the ITEMS table, check whether O_NO columns have matching O_NO values in the ORDERS table. If ORDERS record is deleted, delete matching ITEMS table records.
4. | Only items that are carried can be requested on an order. | Before inserting or updating records in ITEMS, make sure P_NO matches a P_NO in the PRODUCTS table. Prevent deletion of a PRODUCTS table record if dependent ITEMS table records exist.
Primary key: | customer(c_no)
Foreign key: | orders(o_no)
Delete rule: | RESTRICT
Primary key: | employee(e_no)
Foreign key: | orders(s_no)
Delete rule: | SET NULL
Primary key: | orders(o_no)
Foreign key: | items(o_no)
Delete rule: | CASCADE
Primary key: | products(p_no)
Foreign key: | items(p_no)
Delete rule: | RESTRICT
2. | Orders must be taken by an employee of the company. If a salesperson for an order is unknown, the order is treated as a house order. | Before updating or inserting into the ORDERS table, check whether S_NO value has matching E_NO in the EMPLOYEE table. Before deleting EMPLOYEE table records, set S_NO of corresponding ORDERS table records to null.
3. | A request for an item must always be associated with a specific order. | Before inserting or updating the ITEMS table, check whether O_NO columns have matching O_NO values in the ORDERS table. If ORDERS record is deleted, delete matching ITEMS table records.
4. | Only items that are carried can be requested on an order. | Before inserting or updating records in ITEMS, make sure P_NO matches a P_NO in the PRODUCTS table. Prevent deletion of a PRODUCTS table record if dependent ITEMS table records exist.
3. | A request for an item must always be associated with a specific order. | Before inserting or updating the ITEMS table, check whether O_NO columns have matching O_NO values in the ORDERS table. If ORDERS record is deleted, delete matching ITEMS table records.
4. | Only items that are carried can be requested on an order. | Before inserting or updating records in ITEMS, make sure P_NO matches a P_NO in the PRODUCTS table. Prevent deletion of a PRODUCTS table record if dependent ITEMS table records exist.
4. Only items that are carried can be requested on an order. Before inserting or updating records in ITEMS, make sure P_NO matches a P_NO in the PRODUCTS table. Prevent deletion of a PRODUCTS table record if dependent ITEMS table records exist.

All of the tables named already exist in the TUTORIAL location. However, if the tables did not already exist (or if you create them in another location), you could specify the referential integrity constraints at the same time you created the table.

Note that the order in which the commands are executed is important. You cannot create a table that references another table until the referenced table is created. For example, the CUSTOMER table must be created before the ORDERS table.

Parent topic: CREATE TABLE


Batch SQL Example

As presented, these commands could be run through interactive or batch SQL (with SQLWizard).

CREATE TABLE customer (c_no SMALLINT NOT NULL,
    company CHAR(25), address CHAR(20), city CHAR(15),
    state CHAR(2), zip CHAR(5), phone CHAR(14),
    balance MONEY,
PRIMARY KEY (c_no));
CREATE UNIQUE INDEX custpkey ON customer(c_no)
CREATE TABLE employee (e_no SMALLINT NOT NULL,
    lname CHAR(10), fname CHAR(10), street CHAR(20),
    city CHAR(15), st CHAR(2), zip CHAR(5), dept CHAR(4),
    payrate MONEY, com DECIMAL(2,2),PRIMARY KEY (e_no));
CREATE UNIQUE INDEX emppkey ON employee(e_no)
CREATE TABLE products (p_no SMALLINT NOT NULL,
    description CHAR(18), price MONEY,PRIMARY KEY (p_no));
CREATE UNIQUE INDEX prodpkey ON products(p_no)
CREATE TABLE orders (o_no SMALLINT NOT NULL,
    c_no SMALLINT, o_date DATE, s_no SMALLINT,
    PRIMARY KEY (o_no),
    FOREIGN KEY bad_cust (c_no)
        REFERENCES customer ON DELETE RESTRICT,
    FOREIGN KEY bad_emp (s_no)
        REFERENCES employee ON DELETE SET NULL);
CREATE UNIQUE INDEX ordpkey ON orders(o_no)
CREATE TABLE items (o_no SMALLINT, p_no SMALLINT,
    quantity SMALLINT, price MONEY,
    FOREIGN KEY bad_ord(o_no)
        REFERENCES orders ON DELETE CASCADE,
    FOREIGN KEY bad_prod(p_no)
        REFERENCES products ON DELETE CASCADE);

If the tables already exist you can specify the referential constraints using the ALTER TABLE command. This simply requires that you append the appropriate PRIMARY KEY and FOREIGN KEY clauses onto an ALTER TABLE table-name clause. The CREATE INDEX commands would remain the same, but should be issued before the ALTER TABLE ... PRIMARY KEY commands.

Examining the System Catalog

Creating, dropping or altering a table causes the system to automatically update the sysibm.systables and sysibm.syscolumns tables. You can query the system catalog tables for table, view, column and index information. The query results can be formatted into your own reports. See XDB Server System Tables for a description of the system catalog tables.

Optionally, you can use SQLWizard to examine table definitions interactively. In addition, the Catalog Browser function of SQLWizard lists table, view and index definitions.

If a column is indexed, the name(s) of the index or indexes are listed after the column name, separated by a slash (/). Index type indicator codes (see the following table) appear in parentheses after the index name.

Next, the data type of the column is listed. The NOT NULL or NOT NULL WITH DEFAULT clauses specifies the null permission of the column. If omitted, nulls are permitted in the column.

Indicator | Meaning
no letter | Regular index (duplicate values permitted)
p | Primary key
c | Candidate (Unique) key
f | Foreign key
u | Unique index
no number | Single column index
# | Compound index; # is sequence number indicating order of column in a compound index
Parent topic: CREATE TABLE


CREATE TABLESPACE

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

To execute the CREATE TABLESPACE command, users must possess either DBADM, DBCTRL or DBMAINT authority for the database, overall SYSADM or SYSCTRL authority for the location, or the CREATETS privilege for the database.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

CREATE [LARGE | LOB] TABLESPACE tablespace-name
    [IN {DSNDB04 | database-name}]
    [using-block]
    [free-block]
    [GBPCACHE {CHANGED | ALL}]
    [trackmod-block]
    [LOG {YES | NO}]
    [DEFINE {YES | NO}]
    [DSSIZE integer G]
    [{NUMPARTS integer]
    [(PART integer {using-block | free-block | gbpcache-block | trackmod-block | COMPRESS {YES | NO})]
    [COMPRESS {NO | YES}] [,...])]|
    SEGSIZE integer}]
    [BUFFERPOOL bpname]
    [CLOSE {YES | NO}]
    [DSETPASS password]
    [COMPRESS {NO | YES}]
    [LOCKSIZE {ANY | TABLESPACE | TABLE | LOB | {PAGE | ROW}
    [LOCKMAX {0 | integer | SYSTEM}]}]
    [CCSID {ASCII | EBCDIC | UNICODE}]
    [LOCKPART {NO | YES}]
    [MAXROWS integer]

using-block:

USING {VCAT catalog-name
        | STOGROUP stogroup-name
            [PRIQTY {3 | integer}]
             [SECQTY {3 | integer}]
             [ERASE {NO | YES}]}

free-block:

[FREEPAGE {0 | integer}]
[PCTFREE {5 | integer}]gbpcache-block:[GBPCACHE {CHANGED | ALL | SYSTEM | NONE}]

trackmod-block:

[TRACKMOD {YES | NO}]

Parameters:

tablespace-name | Identifies a unique table space name under the current location. The table space can be explicitly qualified with a database name by using the IN database-name clause.but must not identify a table space, index space, or LOB table space that exists at the current server. If a database is not specified, the table space will be associated with the dsndb04 default database for the location.
database-name | Identifies a unique database name (under the current location) in which the table space is created. The system catalog database (dsndb06) must not be specified for any type of table space and a work file database must not be specified for a LOB table space. The default database is the DSNDB04 database for the current location.
bpname | A name that identifies a bufferpool. The 4K bufferpools are named BP0, BP1, BP2...BP49. The 32K bufferpools are named BP32K, BP32K1, BP32K2...BP32K9.

Description

In DB2, when you create tables in a table space, all of the tables are physically stored in the same DASD volume (assuming no storage groups). Both logically and physically, each table is in the same table space. On an XDB Server, you can create a table space and have several different tables logically associated with that table space. Physically, however, the tables are stored in their own .TAB files.

All mainframe-specific option clauses of the CREATE TABLESPACE command are recorded in the XDB Server system catalog. The XDB Server also checks the syntax for each option. The XDB Server system architecture does not physically support many of these clauses. Refer to appropriate DB2 documentation for complete descriptions of these mainframe-specific options.

With DB2 V7, XDB locations (either EBCDIC or ASCII) can now contain Unicode data. If you create a table space with CCSID UNICODE, all character data in corresponding tables is stored in UTF-8 format and all graphic data is stored in UTF-16 format.

LARGE

Identifies that each partition of a partitioned table space has a maximum partition size of 4 GB, which enables the table space to contain more than 64 GB of data. The preferred method to specify a maximum partition size of 4 GB and larger is the DSSIZE clause. The LARGE clause is for compatibility of releases of DB2 for OS/390 prior to Version 6. Do not specify LARGE if LOB or DSSIZE is specified.

LOB

Identifies the table space as LOB table space. A LOB table space is used to hold LOB values.

The LOB table space must be in the same database as its associated base table space.

PRIQTY integer

Specifies the minimum primary space allocation for a DB2-managed data set. The primary space allocation is at least n kilobytes, where n is the value of integer with the following exceptions:

If PRIQTY integer is specified:

  • For 4KB page sizes, if integer is less than 12, n is 12.
  • For 8KB page sizes, if integer is less than 24, n is 24.
  • For 16KB page sizes, if integer is less than 48, n is 48.
  • For 32KB page sizes, if integer is less than 96, n is 96.
  • For any page size, if integer is greater than 4194304, n is 4194304.
  • If PRIQTY is omitted, n is 12, 24, 48, or 96 for 4KB, 8KB, 16KB, and 32KB page sizes, respectively.

For LOB table spaces, the exceptions are:

If PRIQTY integer is specified:

  • For 4KB page sizes, if integer is less than 200, n is 200.
  • For 8KB page sizes, if integer is less than 400, n is 400.
  • For 16KB page sizes, if integer is less than 800, n is 800.
  • For 32KB page sizes, if integer is less than 1600, n is 1600.
  • For any page size, if integer is greater than 4194304, n is 4194304.
  • If PRIQTY is omitted, n is 200, 400, 800, or 1600 for 4KB, 8KB, 16KB, and 32KB page sizes, respectively.

If you do not specify PRIQTY or specify PRIQTY -1, DB2 uses a default value for the primary space allocation.

DB2 specifies the primary space allocation to access method services using the smallest multiple of pKB not less than n, where p is the page size of the table space. The allocated space can be greater than the amount of space requested by DB2.

For example, it could be the smallest number of tracks that will accommodate the request. The amount of storage space requested must be available on some volume in the storage group based on VSAM space allocation restrictions. Otherwise, the primary space allocation will fail. To more closely estimate the actual amount of storage, see the description of the DEFINE CLUSTER command in DFSMS/MVS: Access Method Services for the Integrated Catalog.

Executing this statement causes only one data set to be created. However, you might have more data than this one data set can hold. DB2 automatically defines more data sets when they are needed. Regardless of the value in PRIQTY, when a data set reaches its maximum size, DB2 creates a new one. To avoid wasting space, use the following formula to make sure that PRIQTY and its associated secondary extent values do not exceed the maximum size of the data set:

PRIQTY + (number of extents * SECQTY) <= DSSIZE (implicit or explicit)

This clause is only implemented syntactically in the XDB Server operating environment.

SECQTY integer

Specifies the minimum secondary space allocation for a DB2-managed data set. If you do not specify SECQTY DB2 uses a formula to determine a value.

If you specify SECQTY and do not specify a value of -1, DB2 specifies the secondary space allocation to access method services using the smallest multiple of p KB not less than n, where p is the page size of the table space. The allocated space can be greater than the amount of space requested by DB2. For example, it could be the smallest number of tracks that will accommodate the request.

The secondary space allocation is at least n kilobytes, where n is the value of integer with the following exceptions:

  • If SECQTY integer is specified and integer is greater than 4194304, n is 4194304. A value of 0 for integer indicates that no data set can be extended.
  • If SECQTY and PRIQTY are omitted:
    • For 4KB page sizes, n is 12.
    • For 8KB page sizes, n is 24.
    • For 16KB page sizes, n is 48.
    • For 32KB page sizes, n is 96.
  • If SECQTY is omitted and PRIQTY is specified, n is either 10% of PRIQTY or 3 times the page size of the table space, whichever is larger.

For LOB table spaces the exceptions are:

  • If SECQTY integer is specified:
    • For 4KB page sizes, if integer is greater than 0 and less than 200, n is 200.
    • For 8KB page sizes, if integer is greater than 0 and less than 400, n is 400.
    • For 16KB page sizes, if integer is greater than 0 and less than 800, n is 800.
    • For 32KB page sizes, if integer is greater than 0 and less than 1600, n is 1600.
    • For any page size, if integer is greater than 4194304, n is 4194304.
  • If SECQTY is omitted, n is either 10% of PRIQTY or 50 times the page size of the table space, whichever is larger.

DB2 specifies the secondary space allocation to access method services using the smallest multiple of pKB not less than n, where p is the page size of the table space. The allocated space can be greater than the amount of space requested by DB2. For example, it could be the smallest number of tracks that will accommodate the request.

This clause is only implemented syntactically in the XDB Server operating environment.

PCTFREE integer

Indicates what percentage of each page to leave as free space when the table is loaded or reorganized. integer can range from 0 to 99. The first record on each page is loaded without restriction. When additional records are loaded, at least integer percent of free space is left on each page.

The default is PCTFREE 5. Do not specify PCTFREE for a LOB table space, or a table space in a work file database or a TEMP database.

This clause is only implemented syntactically in the XDB Server operating environment.

TRACKMOD

Specifies whether DB2 tracks modified pages in the space map pages of the table space or partition. Do not specify TRACKMOD for a LOB table space. For a table space in a TEMP database, DB2 uses TRACKMOD NO regardless of the value specified.

YES DB2 tracks changed pages in the space map pages to improve the performance of incremental image copy. YES is the default unless the table space is in a TEMP database.
NO DB2 does not track changed pages in the space map pages. It uses the LRSN value in each page to determine whether a page has been changed.

If the table space is partitioned, the value of TRACKMOD for a particular partition is given by the first of these choices that applies:

  1. The value of TRACKMOD given in the PART clause for that partition.
  2. The value given in a trackmod-block that is not in any PART clause.

The default value YES.

This clause is only implemented syntactically in the XDB Server operating environment.

LOG

Specifies whether changes to a LOB column in the table space are to be written to the log. You can use the LOG clause only for a LOB table space.

YES Indicates that changes to a LOB column are to be written to the log. You cannot use YES if the auxiliary table in the table space stores a LOB column that is greater than 1 gigabyte in length.

YES is the default.

NO Indicates that changes to a LOB column are not to be written to the log.

LOG NO has no effect on a commit or rollback operation; the consistency of the database is maintained regardless of whether the LOB value is logged. All committed changes and changes that are rolled back reflect the expected results.

Even when LOG NO is specified, changes to system pages and to the auxiliary index are logged. During the log apply operation of the RECOVER utility, LPL recovery, or GPB recovery, all LOB values that were not logged are marked invalid and cannot be accessed by a SELECT or FETCH statement. Invalid LOB values can be updated or deleted.

This clause is only implemented syntactically in the XDB Server operating environment.

DSSIZE integer G

A value in gigabytes that indicates the maximum size for each partition or, for LOB table spaces, each data set. If you specify DSSIZE, you must also specify NUMPARTS or LOB.The following values are valid:

1G | 1 gigabyte
2G | 2 gigabytes
4G | 4 gigabytes
8G | 8 gigabytes
16G | 16 gigabytes
32G | 32 gigabytes
64G | 64 gigabytes

To specify a value greater than 4G, the following conditions must be true:

  • DB2 is running with DFSMS Version 1 Release 5.
  • The data sets for the table space are associated with a DFSMS data class that has been specified with extended format and extended addressability.

For all table spaces except LOB table spaces, if DSSIZE (or LARGE) is omitted, the default for the maximum size of each partition depends on the value of NUMPARTS:

If NUMPARTS is ...Maximum partition size is...

1 to 16 | 4 GB
17 to 32 | 2 GB
33 to 64 | 1 GB
65 to 254 | 4 GB

The partition size shown is not necessarily the actual number of bytes used or allocated for any one partition; it is the largest number that can be logically addressed. Each partition occupies one data set.

For LOB table spaces, if DSSIZE is not specified, the default for the maximum size of each data set is 4 GB. The maximum number of data sets is 254.

When you give a table space a DSSIZE value, you also give the same size to all the indexes that point to that tablespace.

This clause is only implemented syntactically in the XDB Server operating environment.

NUMPARTS integer

Indicates that the table space is partitioned.

Integer is the number of partitions, and can range from 1 to 254 inclusive. NUMPARTS must be specified if DSSIZE is specified and LOB is omitted, or LARGE is specified.

The maximum size of each partition depends on the value specified for DSSIZE or LARGE. If DSSIZE or LARGE is not specified, the number of partitions specified determines the maximum size of each partition

If you omit NUMPARTS, the table space is not partitioned and initially occupies one data set. Do not specify NUMPARTS for a LOB table space, or a table space in a work file database or a TEMP database.

LOCKSIZE

Specifies the size of locks used within the table space and, in some cases, also the threshold at which lock escalation occurs. Do not use this clause for a table space in a work file database or a TEMP database.

ANY | Specifies that DB2 can use any lock size. Currently, DB2 never chooses row locks, but reserves the right to do so. In most cases, DB2 uses LOCKSIZE PAGE LOCKMAX SYSTEM for non-LOB table spaces and LOCKSIZE LOB LOCKMAX SYSTEM for LOB table spaces. However, when the number of locks acquired for the table space exceeds the maximum number of locks allowed for a table space (an installation parameter), the page or LOB locks are released and locking is set at the next higher level. If the table space is segmented, the next higher level is the table. If the table space is nonsegmented, the next higher level is the table space.
TABLESPACE | Specifies table space locks.
TABLE | Specifies table locks. Use TABLE only for a segmented table space.
PAGE | Specifies page locks. Do not use PAGE for a LOB table space.
ROW | Specifies row locks. Do not use ROW for a LOB table space.
LOB | Specifies LOB locks. Use LOB only for a LOB table space.

This clause is only implemented syntactically in the XDB Server operating environment.

CCSID

The CCSID clause is only syntactically supported for EBCDIC and ASCII. This is because the definition of the XDB location itself defines how character data is stored.

If you specify UNICODE, your character and graphic data is stored as UNICODE within the table space.

LOCKMAX

Specifies the maximum number of page, row, or LOB locks an application process can hold simultaneously in the table space. If a program requests more than that number, locks are escalated. The page, row, or LOB locks are released and the intent lock on the table space or segmented table is promoted to S or X mode. If you specify LOCKMAX for table space in a TEMP database, DB2 ignores the value because these types of locks are not used.

Integer | Specifies the number of locks allowed before escalating, in the range 0 to 2 147 483 647. Zero (0) indicates that the number of locks on the table or table space are not counted and escalation does not occur.
SYSTEM | Indicates that the value of LOCKS PER TABLE(SPACE), on installation panel DSNTIPJ, specifies the maximum number of page, row, or LOB locks a program can hold simultaneously in the table or table space.
LOCKSIZE | Resultant LOCKMAX
ANY | SYSTEM
TABLESPACE, TABLE, PAGE ROW, or LOB | 0

If the lock size is TABLESPACE or TABLE, LOCKMAX must be omitted, or its operand must be 0.

For an application that uses Sysplex query parallelism, a lock count is maintained on each member.

This clause is only implemented syntactically in the XDB Server operating environment.

USING

XDB records either the catalog-name (preceded by VCAT keyword), or the stogroup-name (preceded by STOGROUP) that is associated with the table space. If the USING clause is left out, a default stogroup for the database must already exist. If a path has already been associated with stogroup-name (through the SYSIBM.SYSVOLUMES catalog table), then any objects created within the table space are implicitly located in that stogroup path.

CLOSE

When the limit on the number of open data sets is reached, specifies the priority in which data sets are closed.

YES | Eligible for closing before CLOSE NO data sets. This is the default unless the table space is in a TEMP database.
NO | Eligible for closing after all eligible CLOSE YES data sets are closed.

For a table space in a TEMP database, DB2 uses CLOSE NO regardless of the value specified.

COMPRESS

Either the option specified or the default value is recorded in the SYSIBM.SYSTABLEPART system catalog table. This option does not compress data in any way. Do not specify COMPRESS for a LOB table space or a table space in a TEMP database.

SEGSIZE integer

Indicates that the table space will be segmented. integer specifies how many pages are to be assigned to each segment. integer must be a multiple of 4 such that 4 <= integer <= 64. If the SEGSIZE clause is not specified, the table space is not segmented.

SEGSIZE must be specified for a table space in a TEMP database because the table space must be segmented. Do not specify SEGSIZE for a LOB table space or a table space in work file database; neither can be segmented.

A segmented table space cannot be partitioned. Therefore, do not specify NUMPARTS if you specify SEGSIZE.

This clause is only implemented syntactically in the XDB Server operating environment.

MAXROWS integer

Specifies the maximum number of rows that DB2 will consider placing on each data page. The integer can range from 1 through 255. This value is considered for INSERT, LOAD, and REORG. For LOAD and REORG (which do not apply for a table space in the TEMP database), the PCTFREE specification is considered before MAXROWS; therefore, fewer rows might be stored than the value you specify for MAXROWS.

If you do not specify MAXROWS, the default number of rows is 255.

Do not use MAXROWS for a LOB table space or a table space in a work file database.

This clause is only implemented syntactically in the XDB Server operating environment.

BUFFERPOOL

This clause has no functional equivalent within the XDB Server operating environment. However, for DB2 compatibility purposes, the XDB Server records any of the sixty possible bufferpools (BP0...BP49, and BP32K, BP32K1...BP32K9). The first fifty bufferpools are for table spaces with 4K page sizes, while the last ten are for table spaces with 32K page sizes. Although not functionally supported, this new information is checked syntactically and recorded in the XDB Server system catalog tables.

If the table space is in a group buffer pool that is defined to be used only for cross-invalidation (GBPCACHE NO), CHANGED is ignored and no pages are cached to the group buffer pool.

Note:

When a table space is created in a workfile database, the following clauses are not allowed:

DEFINE NO | LOB | NUMPARTS
FREEPAGE | LOG | PCTFREE
GBPCACHE | LOCKSIZE | SEGSIZE

When a table space is created in a TEMP database, the following clauses are not allowed:

CCSID | GBPCACHE | LOG
COMPRESS | LARGE | MEMBER CLUSTER
DEFINE NO | LOB | NUMPARTS
DSSIZE | LOCKSIZE | PCTFEE
FREEPAGE | LOCKPART | TRACKMOD

When a LOB table space is created, the following clauses are not allowed:

CCSID | LOCKSIZE PAGE | PCTFREE
COMPRESS | LOCKSIZE ROW | SEGSIZE
FREEPAGE | NUMPARTS | LOCKSIZE TABLE
TRACKMOD |  |

If neither LOB, NUMPARTS, nor SEGSIZE are specified, the table space that is created is a simple table space.

Example:

The following example creates a table space named abc within the xyz database, while specifying the stor1 stogroup for that table space:

CREATE TABLESPACE abc IN xyz
    USING STOGROUP stor1;

In the above case, all objects created within the abc table space are stored in the path associated with the stor1 stogroup. This last result is true even if the logical database xyz is associated with a different stogroup.

In this example, assume that a column named EMP_PHOTO with a data type of BLOB(110K) has been added to the sample employee table for each employee's photo. Create LOB table space PHOTOLTS in database DSN8D61A for the auxiliary table that will hold the BLOB data.

Let DB2 define the data sets for the table space, using storage group DSN8G610. For each data set, the primary space allocation is 3200 kilobytes, and the secondary space allocation is 1600 kilobytes. The data sets do not need to be erased before they are deleted.

CREATE LOB TABLESPACE PHOTOLTS
    IN DSN8D61A
    USING STOGROUP DSN8G610
        PRIQTY 3200
        SECQTY 1600
    LOCKSIZE LOB
    BUFFERPOOL BP16K0
    GBPCACHE SYSTEM
    LOG NO
    CLOSE NO;
Parent topic: SQL Statements


CREATE TRIGGER

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

The privilege set that is defined below must include all of the following:

Either of these privileges:

  • The CREATEIN privilege for the schema or all schemas
  • SYSADM or SYSCTRL authority

The TRIGGER privilege on the table. The privilege set must include at least one of the following:

  • The TRIGGER privilege on the table on which the trigger is defined
  • The ALTER privilege on the table on which the trigger is defined
  • DBADM authority on the database that contains the table
  • SYSADM or SYSCTRL authority

The SELECT privilege on the table on which the trigger is defined if any transition variables or transition tables are specified

The SELECT privilege on any table or view to which the search condition of triggered action refers

The EXECUTE privilege on any user-defined function or stored procedure that is invoked in the triggered action

The necessary privileges to invoke the triggered SQL statements in the triggered action

Syntax

CREATE TRIGGER trigger-name {NO CASCADE BEFORE | AFTER}
    {INSERT | DELETE | UPDATE [OF column-name[,...]]} ON table-name
    [REFERENCING {OLD [AS] correlation-name |
                  NEW [AS] correlation-name |
                  OLD TABLE [AS] identifier |
                  NEW TABLE [AS] identifier}
    {FOR EACH ROW | FOR EACH STATEMENT} MODE DB2SQL triggered-action]

triggered-action:

[WHEN (search-condition) BEGIN ATOMIC triggered-SQL-statement;... END]

Description

trigger-name

Names the trigger. The name is implicitly or explicitly qualified by a schema. The name, including the implicit or explicit schema name, must not identify a trigger that exists at the current server.

The name is also used to create the trigger package; therefore, the name must also not identify a package that is already described in the catalog. The schema name becomes the collection-id of the trigger package.

  • The unqualified form of trigger-name is a short SQL identifier. The unqualified name is implicitly qualified with a schema name according to the following rules:

    If the statement is embedded in a program, the schema name of the trigger is the authorization ID in the QUALIFIER bind option when the plan or package was created or last rebound. If QUALIFIER was not used, the schema name of the trigger is the owner of the package or plan.

    If the statement is dynamically prepared, the schema name of the trigger is the SQL authorization ID of the process.

  • The qualified form of trigger-name is a short SQL identifier (the schema name) followed by a period and a short SQL identifier. The schema name must not begin with 'SYS' unless the name is 'SYSADM'. The schema name that qualifies the trigger name is the trigger's owner.

The owner of the trigger is determined by how the CREATE TRIGGER statement is invoked:

  • If the statement is embedded in a program, the owner is the authorization ID of the owner of the plan or package.
  • If the statement is dynamically prepared, the owner is the SQL authorization ID in the CURRENT SQLID special register.

NO CASCADE BEFORE

Specifies that the trigger is a before trigger. XDB executes the triggered action before it applies any changes caused by an insert, delete, or update operation on the triggering table. It also specifies that the triggered action does not activate other triggers because the triggered action of a before trigger cannot contain any updates.

AFTER

Specifies that the trigger is an after trigger. XDB executes the triggered action after it applies any changes caused by an insert, delete, or update operation on the triggering table.

INSERT

Specifies that the trigger is an insert trigger. XDB executes the triggered action whenever there is an insert operation on the triggering table.

However, if the insert trigger is defined on PLAN_TABLE, DSN_STATEMNT_TABLE, or DSN_FUNCTION_TABLE, and the insert operation was

caused by XDB adding a row to the table, the triggered action is not be executed.

DELETE

Specifies that the trigger is a delete trigger. XDB executes the triggered action whenever there is a delete operation on the triggering table.

UPDATE

Specifies that the trigger is an update trigger. XDB executes the triggered action whenever there is an update operation on the triggering table.

If you do not specify a list of column names, an update operation on any column of the triggering table, including columns that are subsequently added with the ALTER TABLE statement, activates the triggered action.

OF column-name,... Each column-name that you specify must be a column of the subject table and must appear in the list only once. An update operation on any of the listed columns activates the triggered action.

ON table-name

Identifies the subject table with which the trigger is associated. The name must identify a base table at the current server. It must not identify a temporary table, an auxiliary table, an alias, a synonym, or a catalog table.

REFERENCING

Specifies the correlation names for the transition variables and the table names for the transition tables. For the rows in the subject table that are modified by the triggering SQL operation (insert, delete, or update), a correlation name identifies the columns of a specific row. A table name identifies the complete set of modified rows.

Each row that is modified by the triggering operation is available to the triggered action by using column names that are qualified with correlation names that are specified as follows:

OLD AS correlation-name | Specifies the correlation name that identifies the state of the row prior to the triggering SQL operation.
NEW AS correlation-name | Specifies the correlation name that identifies the state of the row as modified by the triggering SQL operation and by any SET statement in a before trigger that has already been executed.

The complete set of rows that is modified by the triggering operation is available to the triggered action by using a temporary table name that is specified as follows:

OLD TABLE AS identifier | Specifies the name of a temporary table that identifies the state of the complete set of rows that are modified rows by the triggering SQL operation prior to any actual changes. identifier is a long SQL identifier.
NEW TABLE AS identifier | Specifies the name of a temporary table that identifies the state of the complete set of rows as modified by the triggering SQL operation and by any SET statement in a before trigger that has already been executed. identifier is a long SQL identifier.

At most, the trigger definition can include two correlation names (OLD and NEW) and two table names (OLD TABLE and NEW TABLE). All the names must be unique from one another.

FOR EACH ROW

Specifies that XDB executes the triggered action for each row of the subject table that the triggering SQL operation modifies. If the triggering SQL operation does not modify any rows, the triggered action is not executed.

FOR EACH STATEMENT

Specifies that XDB executes the triggered action only once for the triggering SQL operation. Even if the triggering SQL operation does not modify any rows, the triggered action is executed once. Do not specify FOR EACH STATEMENT for a before trigger.

MODE DB2SQL

Specifies the mode of the trigger. Currently, XDB supports only MODE DB2SQL.

triggered-action

Specifies the action to be performed when the trigger is activated. The triggered action is composed of one or more SQL statements and by an optional condition that controls whether the statements are executed.

WHEN (search-condition) | Specifies a condition that evaluates to true, false, or unknown. The condition for a before trigger must not include a subselect that references the triggering table. The triggered SQL statements are executed only if the search condition evaluates to true, or if WHEN is omitted.
BEGIN ATOMIC triggered-SQL-statement;... END | Specifies the SQL statements that are to be executed for the triggered action. The statements are executed in the order in which you specify them. The keywords BEGIN ATOMIC and END are required only if you specify more than one SQL statement. In which case, you must enclose the SQL statements in these keywords and end each statement with a semicolon (;).

The statements in the triggered action have these restrictions:

  • They must not refer to host variables, parameter markers, undefined transition variables, or declared temporary tables.
  • They must only refer to a table or view that is at the current server.
  • They must only invoke a stored procedure or user-defined function that is at the current server. An invoked routine can, however, access a server other than the current server.
  • They must not contain a fullselect that refers to the subject table if the trigger is defined as BEFORE

The triggered action may refer to the values in the set of affected rows. This action is supported through the use of transition variables and transition tables.

Transition variables use the names of the columns in the subject table qualified by a specified name that identifies whether the reference is to the old value (before the update) or the new value (after the update). A transition variable can be referenced in search-condition or triggered-SQL-statement of the triggered action wherever a host variable is allowed in the statement if it were issued outside the body of a trigger.

Transition tables can be referenced in the triggered action of an after trigger. Transition tables are read-only. Transition tables also use the name of the columns of the subject table but have a name specified that allows the complete set of affected rows to be treated as a table. The name of the transition table can be referenced in triggered-SQL-statement of the triggered action whenever a table name is allowed in the statement if it were issued outside the body of a trigger. The name of the transition table can be specified in search-condition or triggered-SQL-statement of the triggered action whenever a column name is allowed in the statement if it were issued outside the body of a trigger.

In addition, a transition table can be passed as a parameter to a user-defined function or procedure specifying the TABLE keyword before the name of the transition table. When the function or procedure is invoked, a table locator is passed for the transition table.

A transition variable or transition table is not affected after being returned from a procedure invoked from within a triggered action regardless of whether the corresponding parameter was defined in the CREATE PROCEDURE statement as IN, INOUT, or OUT.

The implicitly created trigger package

When you create a trigger, DB2 automatically creates a trigger package with the same name as the trigger name. The collection name of the trigger package is the schema name of the trigger, and the version identifier is the empty string. Multiple versions of a trigger package are not allowed.

The user executing the triggering SQL operation does not need authority to execute a trigger package. The trigger package does not need to be in the package list for the plan that is associated with the program that contains the SQL statement.

A trigger package becomes invalid if an object or privilege on which it depends is dropped or revoked. The next time the trigger is activated, DB2 attempts to rebind the invalid trigger package. If the automatic rebind is unsuccessful, the trigger package remains invalid.

You cannot create another package from the trigger package, such as with the BIND COPY command. The only way to drop a trigger package is to drop the trigger or the triggering table. Dropping the trigger drops the trigger package; dropping the subject table drops the trigger and the trigger package.

DB2 creates the trigger package with the following attributes:

  • ACTION(ADD)
  • CURRENTDATA(YES)
  • DBPROTOCOL(DRDA)
  • DEGREE(1)
  • DYNAMICRULES(BIND)
  • ENABLE(*)
  • EXPLAIN(NO)
  • FLAG(I)
  • ISOLATION(CS)
  • NOREOPT(VARS) and NODEFER(PREPARE)
  • OWNER(authorization ID)
  • QUERYOPT(1)
  • PATH(path)
  • RELEASE(COMMIT)
  • SQLERROR(NOPACKAGE)
  • QUALIFIER(authorization ID)
  • VALIDATE(BIND)

The values of OWNER, QUALIFIER, and PATH are set depending on whether the CREATE TRIGGER statement is embedded in a program or issued interactively. If the statement is embedded in a program, OWNER and QUALIFIER are the owner and qualifier of the package or plan. PATH is the value from the PATH bind option. If the statement is issued interactively, both OWNER and QUALIFIER are the SQL authorization ID. PATH is the value in the CURRENT PATH special register.

This functionality is only implemented syntactically in the XDB Server operating environment.

Activating a trigger

Only the SQL statements INSERT, DELETE, or UPDATE, or an update or delete operation that occurs as the result of a referential constraint with ON DELETE SET NULL or ON DELETE CASCADE can activate a trigger. Loading a table with the LOAD utility does not activate any triggers that are defined for the table.

This functionality is only implemented syntactically in the XDB Server operating environment.

Simultaneously activated triggers

Multiple triggers that have the same triggering SQL operation and activation time (BEFORE or AFTER) can be defined on a table. The triggers are activated in the order in which they were created. For example, the trigger that was created first is executed first; the trigger that was created second is executed second; and so on.

This functionality is only implemented syntactically in the XDB Server operating environment.

Adding columns to subject tables or tables that the triggered action references

If a column is added to a table for which a trigger is defined (the subject table), the following rules apply:

  • If the trigger is an update trigger that was defined without an explicit list of column names, an update to the new column activates the trigger.
  • If the SQL statements in the triggered action refer to the subject table, the new column is not accessible to the SQL statements until the trigger package is rebound.
  • The transition tables contain the new column. If the transition tables are passed to a user-defined function or a stored procedure, the user-defined function or stored procedure must be recreated with the new definition of the table (that is, the function or procedure must be dropped and recreated), and the package for the user-defined function or stored procedure must be rebound.

If a column is added to any table to which the SQL statements in the triggered action refers, the new column is not accessible to the SQL statements until the trigger package is rebound.

This functionality is only implemented syntactically in the XDB Server operating environment.

Adding triggers to enforce constraints

Creating a trigger on a table that already has rows does not cause the triggered action to be executed. Thus, if the trigger is designed to enforce constraints on the data in the table, the data in the existing rows might not satisfy those constraints.

Defining triggers on plan, statement, and function tables: You can create a trigger on PLAN_TABLE, DSN_STATEMNT_TABLE, or DSN_FUNCTION_TABLE. However, insert triggers that are defined on these tables are not activated when XDB adds rows to the tables.

This functionality is only implemented syntactically in the XDB Server operating environment.

Renaming triggering tables or tables that the triggered action references

You cannot rename a table for which a trigger is defined (the triggering table). Except for the triggering table, you can rename any table to which the SQL statements in the triggered action refer. After renaming such a table, drop the trigger and then re-create the trigger so that it refers to the renamed table.

Dependencies when dropping objects and revoking privileges: The following dependencies apply to a trigger:

  • Dropping the subject table (the table on which the trigger is defined) causes the trigger and its package to also be dropped.
  • Dropping any table, view, alias, or index that is referenced or used within the SQL statements in the triggered action causes the trigger and its package to be invalidated. Dropping a referenced synonym has no effect.
  • Dropping a user-defined function that is referenced by the SQL statements in the triggered action is not allowed. An error occurs.
  • Revoking a privilege on which the trigger depends causes the trigger and its package to be invalidated.

This functionality is only implemented syntactically in the XDB Server operating environment.

Result sets for stored procedures

If a trigger invokes a stored procedure that returns result sets, the application that activated the trigger cannot access those result sets.

Values of special registers

The values of the special registers are saved before a trigger is activated and are restored on return from the

trigger.

Errors when binding triggers

When a CREATE TRIGGER statement is bound, the SQL statements within the triggered action may not be fully parsed. Syntax errors in those statements might not be caught until the CREATE TRIGGER statement is executed.

Errors when executing triggers

Severe errors that occur during the execution of triggered SQL statements are returned with SQLCODE -901, -906, -911, and -913 and the corresponding SQLSTATE. Non-severe errors raised by a triggered SQL statement that is a SIGNAL SQLSTATE statement or that contains a RAISE_ERROR function are returned with SQLCODE -438 and the SQLSTATE that is specified in the SIGNAL SQLSTATE statement or the RAISE_ERROR condition. Other non-severe errors are returned with SQLCODE -723 and SQLSTATE 09000.

Warnings are not returned.

Limiting processor time

XDB's resource limit facility allows you to specify the maximum amount of processor time for a dynamic, manipulative SQL statement (SELECT, INSERT, UPDATE, and DELETE). The execution of a trigger is counted as part of the triggering SQL statement.

Example:

Create two triggers that track the number of employees that a company manages. The subject table is the EMPLOYEE table, and the triggers increment and decrement a column with the total number of employees in the COMPANY_STATS table. The tables have these columns:

EMPLOYEE table: ID, NAME, ADDRESS, and POSITION

COMPANY_STATS table: NBEMP, NBPRODUCT, and REVENUE

This example shows the use of transition variables in a row trigger to maintain summary data in another table.

Create the first trigger, NEW_HIRE, so that it increments the number of employees each time a new person is hired; that is, each time a new row is inserted into the EMPLOYEE table, increase the value of column NBEMP in table COMPANY_STATS by 1.

CREATE TRIGGER NEW_HIRE
    AFTER INSERT ON EMPLOYEE
    FOR EACH ROW MODE DB2SQL
    BEGIN ATOMIC
        UPDATE COMPANY_STATS SET NBEMP = NBEMP + 1;
    END

Create the second trigger, FORM_EMP, so that it decrements the number of employees each time an employee leaves the company; that is, each time a row is deleted from the table EMPLOYEE, decrease the value of column NBEMP in table COMPANY_STATS by 1.

CREATE TRIGGER FORM_EMP
    AFTER DELETE ON EMPLOYEE
    FOR EACH ROW MODE DB2SQL
    BEGIN ATOMIC
        UPDATE COMPANY_STATS SET NBEMP = NBEMP - 1;
    END
Parent topic: SQL Statements


CREATE USER

Syntax

CREATE USER username
         TYPE [ USER | SUPERUSER ]
         PASSWORD password REQUIRED [ YES | NO ]
         option_list

option-list:

SECONDARY ID authid
        GROUPS group_list
        PRIORITY priority
        ACCESS AUTHORITY [ YES | NO ]
        COMMENT quoted-string

Description

Requirements for XDB passwords can be controlled on an XDB user basis. ACCESS AUTHORITY set to NO completely disables an XDB user id. The SECONDARY ID, GROUPS, and PRIORITY concepts are all discussed in the section System Level Access Control in the Security and Authority chapter in your SQL Option Server Administration Guide

Parent topic: SQL Statements


CREATE VIEW

Invocation

This statement can be embedded in an application program or issued interactively.

Authorization

For every table or view identified in the subselect of the CREATE VIEW statement, you must possess either DBADM authority for the database, SELECT privilege on the table or view, overall SYSADM or SYSCTRL authority for the location, or be the owner of the source table or view.

Authority requirements for using the view depend on the owner assigned to the view. (See the view-name parameter description under Syntax.) In order to use a view you must have the appropriate SELECT, UPDATE, INSERT, or DELETE privilege on the view.

The following authorization rules apply with using CREATE VIEW with an XDB Server:

  • If the AuthID for the application process possesses SYSADM authority, the view owner can be any AuthID.
  • If the view satisfies the rule in the previous bullet, and if the CREATE VIEW statement is error-free, the view is created, whether or not the owner has privileges on the tables and views identified in the view subselect.
  • If the AuthID for the application process does not possess SYSADM or SYSCTRL authority, only the AuthIDs of the process can own the view. In these circumstances, the view privileges match those held by the AuthID selected for ownership.

Syntax

CREATE VIEW view-name [(view-col-name[,...])]
    AS subselect [WITH [CASCADED | LOCAL] CHECK OPTION]

Parameters:

view-name Is any long identifier naming the view. This view name cannot have the same name as another view, table or synonym in the same location. If qualified, the name can be two-part or three-part name. If the name has three-parts, the first part must match the value of the CURRENT LOCATION register. The AuthID that qualifies the view name becomes the view owner. If the view name is unqualified in the CREATE VIEW statement, then the view owner is the SQL AuthID of the application process.

The view owner always acquires the authority to drop the view, as well as the SELECT privilege on the view. The owner must already possess grantable SELECT privileges on every table or view identified in the first FROM clause of the view subselect statement, in order to obtain a grantable SELECT privilege on the view. These grantable privileges must be acquired by the owner before the creation of the view.

INSERT, UPDATE and DELETE privileges on the view are also acquired by the owner if the view is not "read only." In these cases, the first FROM clause of the subselect identifies a single table or view only. If the owner already has either INSERT, UPDATE or DELETE privileges on this table or view, the owner acquires that privilege on the newly created view. These privileges are grantable only if the object privileges from which the view was derived are also grantable. These privileges must be acquired by the owner before the new view is created.

view-col-name | Any long identifier specifying a column in the view. Column names for views must satisfy the same naming criteria as table column names. If multiple view-col-name items are specified, the number of these columns must match the number of columns in the result table specified in the subselect. If the view-col-name list is missing, the view columns take the names of the columns specified in the subselect result table. If the result table of the subselect has duplicate column names or unnamed columns derived from constants, functions or expressions, a view-col-name list must be specified.
subselect | A SELECT command statement (following the keyword AS) producing a results table constituting the data contained in the view.

When creating views with subselects all referenced table(s) and all subselects in a single SQL statement must be from the same location -- which must also be the current location. subselect must not refer to any declared temporary tables. It must also not refer to host variables or include parameter markers (question marks). CREATE VIEW is not a DUW or RUW capable command.

Description

When a view is created or dropped, the system automatically updates the appropriate system catalog tables containing the definitions of all views in the current location. When a user queries the view, the system reads the view definition, and performs the corresponding query to obtain the result.

Note:

If you modify the underlying tables used by a view, you should drop the view and recreate it.

Updatable Views

When data in a view is updated, the changes are reflected in the underlying database table. For views to be updatable, the subselect used to define the view must satisfy the following criteria:

  • The query cannot contain DISTINCT.
  • The SELECT clause can contain only column names (no expressions or functions, including aggregate functions.)
  • The FROM clause can contain only one table name.
  • GROUP BY, ORDER BY or HAVING clauses are not permitted.

A simple way to determine whether a view can be defined as an updatable view is to attempt to create it using the WITH CHECK OPTION clause. If the view cannot be defined as updatable view, an error message is displayed.

CHECK OPTION must not be specified if any of the following conditions are true:

  • The view is read-only.
  • The search condition of the view includes a subquery, or the search condition of an underlying view includes a subquery.
  • The search condition of the view includes a user-defined function that is nondeterministic or has an external action.
  • The subselect refers to a created temporary table.

Expressions

Expressions, including those involving aggregate functions, are permitted in views. If expressions are selected, you must explicitly name all columns of the view. Such views are read-only views.

Joins

You may create views by joining other tables and views. The SELECT statement must explicitly name all columns if the tables or views being joined contain duplicate names. Views containing joins are read-only views.

GROUP BY and HAVING

Views defined using GROUP BY cannot be joined with another table or view. These views cannot be updated. HAVING clauses are allowed in view definitions containing GROUP BY.

ORDER BY

ORDER BY clauses are not permitted in the SELECT statement that defines a view.

UNION

The UNION operator cannot be used in the definition of a view.

WITH CHECK OPTION

The search condition of a view is specified in the first WHERE clause of the subselect that defines the view. The WITH CHECK OPTION specifies that every row of the view must conform to the search condition of this WHERE clause. The XDB Server enforces this constraint whenever rows of the view are inserted or updated. If an updatable view is created using the WITH CHECK OPTION clause, the system automatically tests whether inserts or updates to the view will satisfy the WHERE clause of the view definition. If they do not, the system signals an error, and any changes to the underlying tables are aborted.

To prevent the search condition of the view from checking insert or update operations, omit the WITH CHECK OPTION clause. This omission allows the insertion of "nonconforming" rows of data into the underlying table, as well as the updating of table rows in such a way that these rows will no longer be retrievable by the original view.

The two forms of the check option (CASCADED and LOCAL) are meaningful only when views are defined on each other. The view upon which another view is directly or indirectly defined is an underlying view.

  • CASCADED

    Update and insert operations must satisfy the search conditions of the view and underlying views, regardless of whether the underlying views were defined with a check option. This value is the default.

  • LOCAL

    Update and insert operations must satisfy the search conditions of the view and underlying views that are defined with a check option.

View Definitions

Creating or dropping a view causes the system to automatically update the SYSIBM.SYSTABLES, SYSIBM.SYSCOLUMNS and SYSIBM.SYSVIEWS catalog tables. Dropping a table or view causes all views dependent on that table or view to be dropped as well. You can query the system catalog tables for table, view, column and index information. The query results can be formatted into your own reports. See XDB Server System Tables for a list of the system catalog tables used for this purpose.

You can use SQLWizard to examine table definitions interactively. In addition, the Catalog Browser function of SQLWizard lists table, view and index definitions.

Read-only views

A view is read-only if one or more of the following statements is true of its definition:

  • The first FROM clause identifies more than one table or view, or identifies a table function
  • The first SELECT clause specifies the keyword DISTINCT
  • The outer subselect contains a GROUP BY clause
  • The outer subselect contains a HAVING clause
  • The first SELECT clause contains a column function
  • It contains a subquery such that the base object of the outer subselect, and of the subquery, is the same table
  • The first FROM clause identifies a read-only view

A read-only view cannot be the object of an INSERT, UPDATE, or DELETE statement. A view that includes GROUP BY or HAVING cannot be referred to in a subquery of a basic predicate.

Examples:

The following example defines a view that is a subset of the PART table. The optional view column list is omitted. The view column names will be the same as the PART table column names:

CREATE VIEW redparts AS
    SELECT *
        FROM part
        WHERE color = 'RED'
        WITH CHECK OPTION

If you retrieve all records from the REDPARTS view, the result would be:

pno | pname | color | weight | city
P1 | NUT | RED | 12 | LONDON
P4 | SCREW | RED | 14 | LONDON
P6 | COG | RED | 19 | LONDON

This view is not updatable. However, since the view was created using the WITH CHECK OPTION clause, you cannot update the view or insert any records into the view that do not satisfy the condition color = 'RED'.

The next example shows a read-only view defined by joining three tables, PART, SUPPLIER and PARTSUPP:

CREATE VIEW s_ps_p
    (s#, supplier, p#, part, quantity) AS
        SELECT sno, sname, pno, pname, qty
            FROM supplier s, partsupp ps, part p
            WHERE s.sno = ps.sno
              AND p.pno = ps.pno

If you retrieve all records from the S_PS_P view, the result would be:

s# | supplier | p# | part | quantity
S1 | SMITH | P1 | NUT | 300
S1 | SMITH | P3 | CAM | 400
S2 | JONES | P2 | BOLT | 400
S3 | BLAKE | P2 | BOLT | 200
S1 | SMITH | P2 | BOLT | 200
S1 | SMITH | P4 | SCREW | 200
S1 | SMITH | P5 | CAM | 100
S1 | SMITH | P6 | COG | 100
S2 | JONES | P1 | NUT | 300
S4 | CLARK | P2 | BOLT | 200
S4 | CLARK | P4 | SCREW | 300
S4 | CLARK | P5 | CAM | 400

The following is an example of a read-only view containing aggregate functions and a GROUP BY clause:

CREATE VIEW order_statistics
    (o_no, total_items, total_order) AS
    SELECT o_no, COUNT(p_no), SUM(quantity * price)
        FROM items
        GROUP BY o_no

Selecting all records from the view would produce the following result:

o_no | tot_items | total_order
1 | 1 | $120.00
2 | 2 | $985.00
3 | 1 | $240.00
4 | 2 | $830.00
5 | 2 | $2,070.00
Parent topic: SQL Statements


DECLARE CURSOR

Invocation

DECLARE CURSOR is not an executable statement. It can only be embedded in an application language.

Authorization

For each table (or view) identified in the SELECT portion of the DECLARE CURSOR statement, users must possess either DBADM authority for the corresponding database (tables only), the SELECT privilege on the table or view, overall SYSADM or SYSCTRL authority for the location, or be the owner of the table or view.

The SELECT statement specified as an argument within the DECLARE CURSOR statement can be either a standard SELECT statement (select-statement) or a dynamically prepared (PREPARE command) select statement stored in a declared SQL statement (statement-name). Each of these distinct SELECT statement types must have access to different sets of authorization privileges in order to execute.

If a select-statement is specified, then the privileges available for this SELECT statement match those held by the CURRENT SQLID when the cursor is opened.

If a statement-name is specified, the available privileges for the prepared SELECT statement are a combination of the privileges held by the AuthID of the application process. The authorization check is performed when the SELECT statement is prepared. The cursor cannot be opened (OPEN command) unless the SELECT statement has been successfully prepared.

Syntax

DECLARE cursor-name
    [[NOSCROLL] | {ASENSITIVE | INSENSITIVE} SCROLL | SENSITIVE [DYNAMIC | STATIC] SCROLL]
    CURSOR [holdability | returnability | rowset-positioning [...]]
    FOR {select-statement | statement-name}

holdability

[WITH HOLD | WITHOUT HOLD]

returnability

[WITH RETURN [TO CALLER] | WITHOUT RETURN]

rowset-positioning

[WITH ROWSET POSITIONING | WITHOUT ROWSET POSITIONING]

Parameters:

cursor-name | Any valid identifier that names the new cursor and does not identify an already declared cursor in the source program.
select-statement | Specifies an actual query (SELECT statement) represented by the cursor. This SELECT statement can include host variables, the declarations for which must precede the DECLARE CURSOR statement in the source program.
statement-name | Indicates that the query occurring when opening the cursor originated from a prepared SELECT statement identified by statement-name. The statement-name must not match any other statement-name specified within any other DECLARE CURSOR statement in the source program.

Description

The DECLARE CURSOR command is only available when SQL is embedded in a host language such as COBOL or C. The DECLARE CURSOR command is checked for the following syntactical elements:

  • Is the command a SELECT or a statement-name? The SELECT may be a full select statement as defined in this reference. If it is a statement-name, it must be the name of a previously prepared SELECT command.
  • The DECLARE CURSOR statement must precede all commands that explicitly reference the cursor defined by the DECLARE CURSOR command.
  • A cursor may only be referenced within the source program in which it is defined.
Note:

The sample programs contain examples of declaring cursors.

NO SCROLL or SCROLL

Specifies whether the cursor is scrollable or not scrollable.

NO SCROLL

Specifies that the cursor is not scrollable. This is the default.

SCROLL

Specifies that the cursor is scrollable. For a scrollable cursor, whether the cursor has sensitivity to inserts, updates, or deletes depends on the cursor sensitivity option in effect for the cursor. If a sensitivity option is not specified, ASENSITIVE is the default. The sensitivity options include the following ones:

asensitivity

Specifies the desired sensitivity of the cursor to inserts, updates, or deletes that made to the rows underlying the result table. The sensitivity of the cursor determines whether XDB can materialize the rows of the result into a temporary table.

ASENSITIVE

Specifies that the cursor should be as sensitive as possible. This is the default.

A cursor that defined as ASENSITIVE will be either insensitive or sensitive dynamic; it will not be sensitive static.

INSENSITIVE

Specifies that the cursor does not have sensitivity to inserts, updates, or deletes that are made to the rows underlying the result table. As a result, the size of the result table, the order of the rows, and the values for each row do not change after the cursor is opened. In addition, the cursor is read-only. The SELECT statement or attribute-string of the PREPARE statement cannot contain a FOR UPDATE clause, and the cursor cannot be used for positioned updates or deletes.

SENSITIVE

Specifies that the cursor has sensitivity to changes that are made to the database after the result table is materialized. The cursor is always sensitive to updates and deletes that are made using the cursor (that is, positioned updates and deletes using the same cursor). When the current value of a row no longer satisfies the select-statement or statement-name, that row is no longer visible through the cursor. When a row of the result table is deleted from the underlying base table, the row is no longer visible through the cursor.

If XDB cannot make changes visible to the cursor, then an error is issued at bind time for OPEN CURSOR. XDB cannot make changes visible to the cursor when the cursor implicitly becomes read-only. Such is the case when the result table must be materialized, as when the FROM clause of the SELECT statement contains more than one table or view.

The default is DYNAMIC.

DYNAMIC

Specifies that the result table of the cursor is dynamic, meaning that the size of the result table may change after the cursor is opened as rows are inserted into or deleted from the underlying table, and the order of the rows may change. Rows that are inserted, deleted, or updated by statements that are executed by the same application process as the cursor are visible to the cursor immediately. Rows that are inserted, deleted, or updated by statements that are executed by other application processes are visible only after the statements are committed. If a column for an ORDER BY clause is updated via a cursor or any means outside the process, the next FETCH statement behaves as if the updated row was deleted and re-inserted into the result table at its correct location. At the time of a positioned update, the cursor is positioned before the next row of the original location and there is no current row, making the row appear to have moved.

If a SENSITIVE DYNAMIC cursor is not possible, an error is returned. For example, if a temporary table is needed (such as for processing a FETCH FIRST n ROWS ONLY clause), an error is returned. The SELECT statement of a cursor that is defined as SENSITIVE DYNAMIC cannot contain an INSERT statement.

STATIC

Specifies that the size of the result table and the order of the rows do not change after the cursor is opened. Rows inserted into the underlying table are not added to the result table regardless of how the rows are inserted. Rows in the result table do not move if columns in the ORDER BY clause are updated in rows that have already been materialized. Positioned updates and deletes are allowed if the result table is updatable. The SELECT statement of a cursor that is defined as SENSITIVE STATIC cannot contain an INSERT statement.

A STATIC cursor has visibility to changes made by this cursor using positioned updates or deletes. Committed changes made outside this cursor are visible with the SENSITIVE option of the FETCH statement. A FETCH SENSITIVE can result in a hole in the result table (that is, a difference between the result table and its underlying base table). If an updated row in the base table of a cursor no longer satisfies the predicate of its SELECT statement, an update hole occurs in the result table. If a row of a cursor was deleted in the base table, a delete hole occurs in the result table. When a FETCH SENSITIVE detects an update hole, no data is returned (a warning is issued), and the cursor is left positioned on the update hole. When a FETCH SENSITIVE detects a delete hole, no data is returned (a warning is issued), and the cursor is left positioned on the delete hole.

Updates through a cursor result in an automatic re-fetch of the row. This re-fetch means that updates can create a hole themselves. The re-fetched row also reflects changes as a result of triggers updating the same row. It is important to reflect these changes to maintain the consistency of data in the row.

Using a nondeterministic function (built-in or user-defined) in the WHERE clause of the select-statement or statement-name of a SENSITIVE STATIC cursor can cause misleading results. This situation occurs because XDB constructs a temporary result table and retrieves rows from this table for FETCH INSENSITIVE statements. When XDB processes a FETCH SENSITIVE statement, rows are fetched from the underlying table and predicates are re-evaluated. Using a nondeterministic function can yield a different result on each FETCH SENSITIVE of the same row, which could also result in the row no longer being considered a match.

A FETCH INSENSITIVE on a SENSITIVE STATIC SCROLL cursor is not sensitive to changes made outside the cursor, unless a previous FETCH SENSITIVE has already refreshed that row; however, positioned updates and delete changes with the cursor are visible.

STATIC cursors are insensitive to insertions.

WITH HOLD Clause

This optional clause prevents a commit operation from closing the cursor. Instead, a COMMIT statement logs all the changes from the current unit of work, leaving in place those locks required to maintain the cursor. After the commit operation, a single FETCH statement must initially be executed before a subsequently positioned UPDATE or DELETE statement can be executed on the cursor. After this FETCH, the cursor pointer can be advanced onto the next cursor row (or the row following the current row before the COMMIT). A ROLLBACK command, however, will close the cursor.

Omitting the WITH HOLD option from the cursor declaration causes that cursor to be implicitly closed by a COMMIT operation. A CONNECT or ROLLBACK operation also implicitly closes all cursors.

Closing a cursor before a COMMIT operation, has the same effect as declaring the cursor without the WITH HOLD option.

WITH RETURN Clause

This optional clause specifies that the cursor, if it is declared in a stored procedure, can return a result set to the caller.

Result Table

A result table is a temporary table of row data created when an OPEN command is issued against a previously declared cursor. This temporary table remains in memory until a CLOSE command is issued against the cursor (or a COMMIT or ROLLBACK occurs). The query criteria specified in the cursor's original PREPARE statement determines the row data retrieved into the result table. An opened (OPEN command) cursor consists of both a result table and a position pointer that moves among the table rows.

Read-Only Result Tables

A read-only result table occurs in any of the following situations:

  • When the first FROM clause of the cursor query identifies more than one table or view.
  • The first SELECT clause specifies the keyword DISTINCT.
  • The outer subselect contains either a GROUP BY or HAVING clause.
  • The first SELECT clause contains a column function.
  • The cursor contains a subquery in which the base table of the outer subselect is the same as the subquery table.
  • The first FROM clause of the cursor query identifies either a read-only view or a catalog table with no updatable columns.
  • The first FROM clause identifies a table function
  • The first FROM clause contains a nested table expression
  • A UNION or UNION ALL operator is present in the cursor query.
  • An ORDER BY clause or a FOR FETCH ONLY clause is present in the cursor query.

COBOL Usage

In COBOL source programs, a DECLARE CURSOR command is checked to verify whether host variables exist in either the LINKAGE or WORKING STORAGE section. In COBOL applications (as mentioned above), an application called from another application cannot use a cursor that was declared by the calling application. The scope of the cursor is the source program in which it is defined, which limits cursor references to statements precompiled along with the cursor declaration.

ExampleS:

The following COBOL language examples illustrate PREPARE, DECLARE, OPEN, and FETCH cursor statements:

EXEC SQL
    DECLARE d1 CURSOR FOR
        SELECT deptno, dname
            FROM dept
            WHERE mgrno = :mgrno
END-EXEC

or:

EXEC SQL
    PREPARE emp_in_dept FROM
        SELECT e_no, lname
            FROM employee
            WHERE dept = ?
END-EXEC

EXEC SQL
    DECLARE e1 CURSOR FOR emp_in_dept
END-EXEC

EXEC SQL
    OPEN e1 USING :deptnum
END-EXEC

EXEC SQL
    FETCH e1 INTO :enum, :last_name
END-EXEC
Parent topic: SQL Statements


DECLARE GLOBAL TEMPORARY TABLE

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared.

Authorization

None required, unless the LIKE clause is specified when additional privileges might be required.

PUBLIC implicitly has the following privileges without GRANT authority for declared temporary tables:

  • The CREATETAB privilege to define a declared temporary table in the database that is defined AS TEMP, which is the database for declared temporary tables.
  • The USE privilege to use the table spaces in the database that is defined as TEMP.
  • All table privileges on the table and authority to drop the table. (Table privileges for a declared temporary table cannot be granted or revoked.)

These implicit privileges are not recorded in the DB2 catalog and cannot be revoked.

Syntax

DECLARE GLOBAL TEMPORARY TABLE table-name
{
    (column-spec[,...]) |
    LIKE {table-name | view-name} [INCLUDING INDENTITY [COLUMN ATTRIBUTES]] |
    AS (subselect) DEFINITION ONLY [as-attribute]
}
    [CCSID {EBCDIC | ASCII}]
    [ON COMMIT PRESERVE ROWS]

column-spec:

column-name data-type
[NOT NULL]
[[WITH] DEFAULT [constant | USER | CURRENT SQLID | NULL]]
[GENERATED {ALWAYS | BY DEFAULT} [as-identity-clause}]

as-attribute:

[INCLUDING IDENTITY [COLUMN ATTRIBUTES]]
[INCLUDING [COLUMN] DEFAULTS]
[USING TYPE DEFAULTS]

as-identity-clause:

AS IDENTITY
    [({START WITH {numeric-constant | 1} | INCREMENT BY {numeric-constant | 1} |
    {CACHE 20 | NO CACHE | CACHE integer}}][,..])]

table-name

Names the temporary table. The qualifier, if specified explicitly, must be SESSION. If the qualifier is not specified, it is implicitly defined to be SESSION.

If a table, view, synonym, or alias already exists with the same name and an implicit or explicit qualifier of SESSION:

  • The declared temporary table is still defined with SESSION.table-name. An error is not issued because the resolution of a declared temporary table name does not include the persistent and shared names in the XDB catalog tables.
  • Any references to SESSION.table-name will resolve to the declared temporary table rather than to any existing SESSION.table-name whose definition is persistent and is in the XDB catalog tables.

PUBLIC implicitly acquires ALL PRIVILEGES on the table and authority to drop the table. These implicit privileges are not recorded in the XDB catalog and cannot be revoked.

column-spec

Defines the attributes of a column for each instance of the table. The number of columns defined must not exceed 750. The maximum record size must not exceed 32714 bytes. The maximum row size must not exceed 32706 bytes (8 bytes less than the maximum record size).

column-name

Names the column. The name must not be qualified and must not be the same as the name of another column in the table.

data-type

Specifies the data type of the column. The data type can be any built-in data type that can be specified for the CREATE TABLE statement except for a LOB (BLOB, CLOB, and DBCLOB) or ROWID type. The FOR subtype DATA clause can be specified as part of data-type.

NOT NULL

Specifies that the column cannot contain nulls. Omission of NOT NULL indicates that the column can contain nulls.

DEFAULT

The default value assigned to the column in the absence of a value specified on INSERT. Do not specify DEFAULT for a column that is defined AS IDENTITY (an identity column); XDB generates default values.

If DEFAULT is not specified, the default value for the column is the null value.

If DEFAULT is specified without a value after it, the default value of the column depends on the data type of the column, as follows:

Data type | Default value
Numeric | 0
Fixed length string | Blanks
Varying-length string | A string of length 0
Date | CURRENT DATE
Time | CURRENT TIME
Timestamp | CURRENT TIMESTAMP

A default value other than the one that is listed above can be specified in one of the following forms:

Constant | Specifies a constant as the default value for the column. The value of the constant must conform to the rules for assigning that value to the column.
USER | Specifies the value of the USER special register at the time of INSERT or LOAD as the default value for the column. If USER is specified, the data type of the column must be a character string with a length attribute greater than or equal to the length attribute of the USER special register, which is 8 bytes.
CURRENT SQLID | Specifies the value of the SQL authorization ID of the process at the time of INSERT or LOAD as the default value for the column. If CURRENT SQLID is specified, the data type of the column must be a character string with a length attribute greater than or equal to the length attribute of the CURRENT SQLID special register, which is 8 bytes.
NULL | Specifies null as the default value for the column.

In a given column definition:

  • NOT NULL and DEFAULT NULL cannot both be specified.
  • DEFAULT cannot be specified for an identity column.
  • Omission of NOT NULL and DEFAULT for a column other than an identity column is an implicit specification of DEFAULT NULL. For an identity column, it is an implicit specification of NOT NULL, and XDB generates default values.

GENERATED

Specifies that XDB generates values for the column. You must specify GENERATED if the column is to be considered an identity column (a column defined with the AS IDENTITY clause).

ALWAYS | Specifies that XDB always generates a value for the column when a row is inserted into the table.
BY DEFAULT | Specifies that XDB generates a value for the column when a row is inserted into the table unless a value is specified. BY DEFAULT is the recommended value only when you are using data propagation.
AS IDENTITY | Specifies that the column is an identity column for the table. A table can have only one identity column. AS IDENTITY can be specified only if the data type for the column is an exact numeric type with a scale of zero (SMALLINT, INTEGER, DECIMAL with a scale of zero).

LIKE table-name or view-name

Specifies that the columns of the table have exactly the same name and description as the columns of the identified table or view. The name specified must identify a table, view, synonym, or alias that exists at the current server. The identified table must not be an auxiliary table or a declared temporary table.

The privilege set must include the SELECT privilege on the identified table or view.

This clause is similar to the LIKE clause on CREATE TABLE, but it has the following differences:

  • If LIKE results in a column having a LOB data type, a ROWID data type, or distinct type, the DECLARE GLOBAL TEMPORARY TABLE statement fails.
  • In addition to these data type restrictions, if any column has any other attribute value that is not allowed in a declared temporary table, that attribute value is ignored. The corresponding column in the new temporary table has the default value for that attribute unless otherwise indicated.

When the identified object is a table, the column name, data type, nullability, and default attributes are determined from the columns of the specified table; any identity column attributes are inherited only if the INCLUDING IDENTITY COLUMN ATTRIBUTES clause is specified. When the identified object is a view, only the column name, data type, and nullability attributes are determined from the columns of the specified view.

INCLUDING IDENTITY COLUMN ATTRIBUTES Specifies that the new table inherits all of the identity attributes of the identity column. If the table identified by LIKE does not have an identity column, the INCLUDING IDENTITY clause is ignored. If the LIKE clause identifies a view, INCLUDING IDENTITY COLUMN ATTRIBUTES cannot be specified.

AS (subselect) DEFINITION ONLY

Specifies that the columns of the table are to have the same name and description as the columns that would appear in the derived result table of the subselect if the subselect were to be executed. The use of AS subselect is an implicit definition of n columns for the table, where n is the number of columns that would result from the subselect.

DEFINITION ONLY indicates that the subselect is not executed. Therefore, there is no result table with a set of rows with which to automatically populate the declared temporary table. However, you can use the INSERT INTO statement with the same subselect specified in the AS clause to populate the declared temporary table with the set of rows from the result table of the subselect.

The implicit definition includes all the attributes of the n columns of subselect that are applicable for a declared temporary table with the exception of these column attributes:

  • The default value assigned to a column when a value is not specified on INSERT
  • The identity attribute, if any

The behavior of these column attributes are controlled with the INCLUDING or USING TYPE DEFAULTS clauses, which are defined below.

If subselect results in a column having a LOB data type, a ROWID data type, or a distinct type, the DECLARE GLOBAL TEMPORARY statement fails.

If subselect results in other column attributes that are not applicable for a declared temporary table, those attributes are ignored in the implicit definition for the declared temporary table.

The implicitly defined columns of the declared temporary table inherit the names of the columns from the result table of the subselect. Therefore, a column name must be specified in the subselect for all result columns. For result columns that are derived from expressions, constants, and functions, the subselect must include the AS column-name clause immediately after the result column.

The subselect must not refer to host variables or include parameter markers (question marks).

INCLUDING IDENTITY COLUMN ATTRIBUTES

Specifies that the declared temporary table inherits the identity attribute, if any, of the columns resulting from subselect. In general, the identity attribute is copied if the element of the corresponding column in the table, view, or subselect is the name of a table column or the name of a view column that directly or indirectly maps to the name of a base table column with the identity property. The columns of the new table do not inherit the identity attribute in the following cases:

  • The select list of the subselect includes multiple instances of an identity column name (that is, selecting the same column more than once).
  • The select list of the subselect includes multiple identity columns (that is, it involves a join).
  • The identity column is included in an expression in the select list.
  • The subselect includes a set operation (union).

If INCLUDING IDENTITY is not specified, the declared temporary table will not have an identity column.

INCLUDING COLUMN DEFAULTS

Specifies that the declared temporary table inherits the default values of the columns resulting from subselect. A default value is the value assigned to a column when a value is not specified on an INSERT.

Do not specify INCLUDING COLUMN DEFAULTS, if you specify USING TYPE DEFAULTS.

If neither INCLUDING COLUMN DEFAULTS nor USING TYPE DEFAULTS is specified, the default values of the columns of the declared temporary table are either null or there are no default values. If the column can be null, the default is the null value; if the column cannot be null, there is no default value, and an error occurs if a value is not provided for a column on an INSERT for the declared temporary table.

USING TYPE DEFAULTS

Specifies that the default values for the declared temporary table depend on the data type of the columns that result from subselect, as follows:

Data type | Default value
Numeric | 0
Fixed-length string | Blanks
Varying-length string | A string of length 0
Date | CURRENT DATE
Time | CURRENT TIME
Timestamp | CURRENT TIMESTAMP

Do not specify USING TYPE DEFAULTS, if you specify INCLUDING COLUMN DEFAULTS.

ON COMMIT commit-action ROWS

Specifies whether the contents of the table are to be deleted or preserved across a commit operation.

DELETE | The rows of the table are deleted if no WITH HOLD cursors are open on the table. DELETE is the default.
PRESERVE | The rows of the table are preserved. Thread reuse capability is not available to any application process or thread that contains, at its most recent COMMIT, an active declared temporary table that was defined with the ON COMMIT PRESERVE ROWS clause.

Example:

Define a declared temporary table with column definitions for an employee number, salary, commission, and bonus.

DECLARE GLOBAL TEMPORARY TABLE SESSION.TEMP_EMP
   (EMPNO   CHAR(6)        NOT NULL,
    SALARY  DECIMAL(9, 2),
    BONUS   DECIMAL(9, 2),
    COMM    DECIMAL(9, 2))
    CCSID EBCDIC
    ON COMMIT PRESERVE ROWS;
Parent topic: SQL Statements


DECLARE STATEMENT

Invocation

DECLARE STATEMENT is not an executable statement. It can only be embedded in an application language.

Authorization

None required.

Syntax

DECLARE statement-name[,...] STATEMENT

Parameters:

statement-name Names one or more prepared SQL statements to be used in an application program.

Description

This nonexecutable statement is used in application programs to identify statement-name variables that can later be substituted for various kinds of SQL statements.

Example:

The C language example below first declares an SQL statement variable named mystatement. Next the contents of the host variable hostvar (typically the text of an SQL statement assembled in the host application) are placed into mystatement using the PREPARE command:

EXEC SQL
    DECLARE mystatement STATEMENT
;
...

EXEC SQL
    PREPARE mystatement FROM :hostvar
;
...
Parent topic: SQL Statements


DECLARE TABLE

Invocation

DECLARE TABLE is not an executable statement. It can only be embedded in an application language.

Authorization

None required.

Syntax

This command is supported only syntactically.

DECLARE {table-name | view-name}
    TABLE (column-name {built-in-data-type | distinct-type-name}
    [NOT NULL]
    [NOT NULL WITH DEFAULT] [,...])

This command is supported only syntactically.

DECLARE {table-name | view-name}
    TABLE (column-name {built-in-data-type | distinct-type-name}
    [NOT NULL]
    [NOT NULL WITH DEFAULT] [,...])

Parameters:

table-name or view-name Is the name of the table or view you want to document. If the table is defined in your application program, the description of the table in the SQL statement in which it is defined (for example, CREATE TABLE or DECLARE GLOBAL TEMPORARY TABLE statement) and the DECLARE TABLE statement must be identical.
column-definition One or more column definitions (separated by commas) can be chosen as specified below:
column-name data-type [NOT NULL]
[NOT NULL WITH DEFAULT]

Description

The XDB Server supports the DECLARE TABLE command syntactically only. The VALIDATE directive can be used to achieve the same functionality when precompiling. Use the Declaration Generator utility to generate declarations for tables and views. Mainframe DB2 users should use the DCLGEN utility.

built-in-data-type

Is the built-in data type of the column. Use one of the built-in data types.

distinct-type-name

Is the distinct type (user-defined data type) of the column. An implicit or explicit schema name qualifies the name.

Parent topic: SQL Statements


DELETE (Positioned)

Invocation

DELETE is an executable command that can be issued interactively or embedded in a host language. DELETE can be dynamically prepared. The Positioned DELETE command (explained below) can be used only with embedded SQL.

Authorization

Authorization requirements depend on whether the object identified in the statement is a table or a view. To execute the DELETE command on a table, users must possess either DBADM authority for the database containing the table, DELETE privilege on the table, overall SYSADM authority for the location, or be the owner of the table.

To execute the DELETE command on a view, users must possess the DELETE privilege on the view or have overall SYSADM authority. For more information on view privileges, see CREATE VIEW. If a subselect is specified within the view or table, the user must have the necessary privileges to execute the subselect.

To execute a DELETE at another location, the set of available privileges consists only of those privileges recorded in the system catalog at the location where the DELETE statement is to be executed.

Syntax

DELETE FROM {table-name | view-name}
    [correlation-name]
    WHERE CURRENT OF cursor-name
    [FOR ROW [host-variable | integer-constant] OF ROWSET]

Parameters:

table-name or view-name | Names an object (table or view) from which records are to be deleted. If a view name is identified, the view must be an updatable view since the underlying table will be affected. The named table or view may exist at a location other than the current location, as long as the correct location is either implicitly specified (SET LOCATION TO or CONNECT command precedes the DELETE command) or explicitly specified in the object name (location-name.AuthID.object-name).
correlation-name | Identifies an optional correlation name that then qualifies table or view column references within the search-condition.
search-condition | Determines which records to delete. Can be any valid query search condition, with each column name (other than in a subquery) identifying a column in table-name or view-name. The search condition must not include a subquery that also operates on either table-name or view-name.
cursor-name | Identifies a previously defined, opened, and fetched cursor, which points to the row to be deleted.

Description

Both Searched DELETE and Positioned DELETE are supported -- with the first type of command deleting one or more rows (with the option of including a WHERE clause), and the second type deleting only one row at a time, using the row pointer position within a cursor result table. When the DELETE command is embedded in a host language such as COBOL, C, or PL/I, it can contain host variables.

The Positioned DELETE can only be used in embedded SQL, since it involves the use of a previously defined cursor. When a positioned DELETE is executed, the row that the cursor currently points to is deleted.

When a record is deleted, the XDB Server simply marks the record as deleted. The data are still present in the table. If the Backward Log is set to ON, the ROLLBACK command can remove these delete markers and return the records to their former state. See the SELECT command for information on how to view records marked for deletion.

Index Considerations

If an index exists on a table, deleting records automatically updates the index. This could lead to a performance penalty if many records are deleted because each record deleted will cause the index to be updated. When deleting a large number of records from a table, it is sometimes more efficient to drop the index, delete the records, then re-create the index.

FOREIGN KEY Considerations

When deleting records from a table involved in a FOREIGN KEY constraint, the rule defined for the FOREIGN KEY will be followed. See the ALTER TABLE and CREATE TABLE commands for more information on deleting records containing FOREIGN KEYs.

DELETE vs. TRUNCATE TABLE

When deleting all records from a table, the TRUNCATE TABLE command can save time and system overhead. TRUNCATE TABLE deletes all records in a table without logging the deleted records or maintaining the table indexes. The system will not be able to rollback the deleted records. This command is not allowed on a table containing a primary key, since it may be referenced by another table.

WHERE CURRENT OF

This keyword clause identifies the cursor to be used in a positioned DELETE statement. The cursor-name specified must identify an already declared cursor. When a DELETE statement is executed, the cursor must already be positioned on the row to be deleted. After deleting the row, a FETCH statement should be executed to retrieve the next result table row.

QUERYNO integer

Specifies the number to be used for this SQL statement in EXPLAIN output and trace records. The number is used for the QUERYNO columns of the plan tables for the rows that contain information about this SQL statement.

If the clause is omitted, the number associated with the SQL statement is the statement number assigned during precompilation. Thus, if the application program is changed and then precompiled, that statement number might change.

Using the QUERYNO clause to assign unique numbers to the SQL statements in a program is helpful for simplifying the use of optimization hints for access path selection, if hints are used.

Examples:

A sample DELETE statement appears below:

DELETE FROM partsupp
    WHERE sno = "S1"

This command deletes all the records where the supplier is S1.

The more complex example shown below deletes all suppliers who supply part P4:

DELETE FROM supplier
    WHERE sno IN
    SELECT sno
    FROM partsupp
    WHERE pno = "P4"

If the optional WHERE clause is not included, all records in the table are deleted. After the DELETE command is issued, the table will not contain any active records, but the table still exists and still appears in the directory of active tables. You cannot recover deleted records if DELETE is issued without a WHERE condition. You can reenter new data at any time using either the INSERT command or the SQLWizard data entry facility. For example, the following command removes all of the records from the SUPPLIER table:

DELETE FROM supplier

When the DELETE command is embedded in a host language, it must appear within the "EXEC SQL ... END-EXEC" or "EXEC SQL ...;" delimiters, as required by the XDB Server host language preprocessor. The following COBOL language example shows a positioned DELETE command. It is assumed that the cursor EMPTBL has been declared, opened and fetched to the row desired:

EXEC SQL
    DELETE FROM employee
    WHERE CURRENT OF emptbl;
Parent topic: SQL Statements
Related reference
CREATE VIEW
SELECT
ALTER TABLE
CREATE TABLE
DELETE (Searched)


DELETE (Searched)

Invocation

DELETE is an executable command that can be issued interactively or embedded in a host language. DELETE can be dynamically prepared.

Authorization

Authorization requirements depend on whether the object identified in the statement is a table or a view. To execute the DELETE command on a table, users must possess either DBADM authority for the database containing the table, DELETE privilege on the table, overall SYSADM authority for the location, or ownership of the table.

To execute the DELETE command on a view, users must possess the DELETE privilege on the view or have overall SYSADM authority. For more information on view privileges, see CREATE VIEW. If a subselect is specified within the view or table, the user must have the necessary privileges to execute the subselect.

To execute a DELETE at another location, the set of available privileges consists only of those privileges recorded in the system catalog at the location where the DELETE statement is to be executed.

The SELECT privilege is required in addition to the DELETE privilege when the option for the SQL standard is set as follows:

  • For static SQL statements, if the SQLRULES (STD) bind option was specified
  • For dynamic SQL statements, if the CURRENT RULES special register is set to STD

Syntax

DELETE FROM {table-name | view-name} [correlation-name]
    [WHERE search-condition]
    [WITH {CS | RR}][QUERYNO integer]

Description

Both Searched DELETE and Positioned DELETE are supported -- with the first type of command deleting one or more rows (with the option of including a WHERE clause), and the second type deleting only one row at a time, using the row pointer position within a cursor result table. When the DELETE command is embedded in a host language such as COBOL, C, or PL/I, it can contain host variables.

The Searched DELETE uses the standard SQL syntax for a DELETE statement, which relies on a WHERE condition to determine the records to be deleted. The WHERE condition is defined in the same way as it would be for a SELECT command. To determine which records a searched DELETE command will delete, first SELECT from the table using the same WHERE condition. See WHERE Clause for more information on searching for records.

When using subselects as search conditions, the subselect cannot reference a location other than the one referenced elsewhere in the command. That is, a referenced table and all subselects in a single SQL statement must be from the same location.

Invalid:

DELETE FROM tutorial.tutorial.employee
    WHERE e_no IN
        SELECT e_no FROM debloc.debbie.employee
            WHERE st = "MD";

Valid:

DELETE FROM tutorial.tutorial.employee
    WHERE e_no IN
        SELECT e_no FROM tutorial.debbie.employee
            WHERE st = "MD";
Note:

If no WHERE condition is specified, all records in the table are deleted.

When a record is deleted, the XDB Server simply marks the record as deleted. The data are still present in the table. If the Backward Log is set to ON, the ROLLBACK command can remove these delete markers and return the records to their former state. See the SELECT command for information on how to view records marked for deletion.

Index Considerations

If an index exists on a table, deleting records automatically updates the index. This could lead to a performance penalty if many records are deleted because each record deleted will cause the index to be updated. When deleting a large number of records from a table, it is sometimes more efficient to drop the index, delete the records, then re-create the index.

FOREIGN KEY Considerations

When deleting records from a table involved in a FOREIGN KEY constraint, the rule defined for the FOREIGN KEY will be followed. See the ALTER TABLE and CREATE TABLE commands for more information on deleting records containing FOREIGN KEYs.

DELETE vs. TRUNCATE TABLE

When deleting all records from a table, the TRUNCATE TABLE command can save time and system overhead. TRUNCATE TABLE deletes all records in a table without logging the deleted records or maintaining the table indexes. The system will not be able to rollback the deleted records. This command is not allowed on a table containing a primary key, since it may be referenced by another table.

WHERE

This keyword identifies rows to be deleted in a searched DELETE. If WHERE is omitted, all rows of the table or view named are deleted. The search condition following the WHERE keyword is applied to each row of the named table or view, deleting all rows for which the search condition is true. A subquery with no correlated references will be executed just once. A subquery with a correlated reference will be executed once for each row identified in the WHERE clause.

WITH Clause

Specifies an isolation level with which the statement is executed in Searched DELETE statements. You can override the isolation level of the statement using the new WITH {RR | CS} clause. Because WITH UR only applies to read only operations, you cannot use it on a DELETE statement. The WITH clause overrides the default isolation level only for the statement in which it appears.

QUERYNO integer

Specifies the number to be used for this SQL statement in EXPLAIN output and trace records. The number is used for the QUERYNO columns of the plan tables for the rows that contain information about this SQL statement.

If the clause is omitted, the number associated with the SQL statement is the statement number assigned during precompilation. Thus, if the application program is changed and then precompiled, that statement number might change.

Using the QUERYNO clause to assign unique numbers to the SQL statements in a program is helpful for simplifying the use of optimization hints for access path selection, if hints are used.

Searched DELETE and SQL standard rules

If SQL standard rules are in effect and the search-condition in a searched DELETE contains a reference to a column of the table or view, the privilege set must include at least one of the following:

  • The SELECT privilege on the table or view
  • SYSADM authority

SQL standard rules are in effect as follows:

  • For static SQL statements, if the SQLRULES(STD) bind option was specified
  • For dynamic SQL statements, if the CURRENT RULES special register is set to 'STD

Examples:

A sample DELETE statement appears below:

DELETE FROM partsupp
    WHERE sno = "S1"

This command deletes all the records where the supplier is S1.

The more complex example shown below deletes all suppliers who supply part P4:

DELETE FROM supplier
    WHERE sno IN
        SELECT sno
            FROM partsupp
            WHERE pno = "P4"

If the optional WHERE clause is not included, all records in the table are deleted. After the DELETE command is issued, the table will not contain any active records, but the table still exists and still appears in the directory of active tables. You cannot recover deleted records if DELETE is issued without a WHERE condition. You can reenter new data at any time using either the INSERT command or the SQLWizard data entry facility. For example, the following command removes all of the records from the SUPPLIER table:

DELETE FROM supplier

When the DELETE command is embedded in a host language, it must appear within the "EXEC SQL ... END-EXEC" or "EXEC SQL ...;" delimiters, as required by the XDB Server host language preprocessor. The following COBOL language example shows a searched DELETE command containing a host variable in the WHERE clause:

EXEC SQL
    DELETE FROM employee
    WHERE lname = :ENAME
END-EXEC
Parent topic: SQL Statements
Related reference
CREATE VIEW
SELECT
ALTER TABLE
CREATE TABLE
DELETE (Positioned)
Related information
WHERE Clause Syntax and Description


DESCRIBE

Invocation

DESCRIBE is an executable command that can only be embedded in a host language. DESCRIBE cannot be dynamically prepared.

Authorization

No special privileges are required when describing a prepared statement. However, when describing a table or view, the privileges held by the AuthID owning the application must include either ownership of the table, SELECT, INSERT, UPDATE, or DELETE privilege on the table or view, ALTER or INDEX privilege on the table, DBADM authority over the database containing the object (tables only), or SYSADM or SYSCTRL authority for the location.

See the PREPARE statement description for authorization privileges required to prepare a command.

Syntax

DESCRIBE {statement-name | TABLE host-variable}
    INTO descriptor-name [USING {NAMES | LABELS | ANY | BOTH}]

Parameters:

statement-name | Identifies an SQL statement already prepared by an application process at the current location.
host-variable | The combination of the keyword TABLE followed by host-variable, identifies a table or view. The name must not identify an auxiliary table
descriptor-name | preceded by the keyword INTO, names an SQL Descriptor Area (SQLDA) variable.

Description

You may have a uniquely named SQLDA defined for every cursor utilized in an application process. When the DESCRIBE statement is applied to a prepared query statement, the information returned to the specified SQLDA describes the columns of the result table (for that cursor). When a table or view is named in the DESCRIBE statement, the information returned in the SQLDA defines the columns in the table or view.

The SQLDA must be allocated before the DESCRIBE statement is executed. Once allocated, the SQLDA consists of the SQLDAID, SQLDABC, SQLN, and SQLD fields followed by the SQLVAR array structure (containing one or more occurrences). The number of elements within the SQLVAR must be equal to or greater than the number of columns in the described table. For more details on the SQLDA, see XDB Server SQL Descriptor Area (SQLDA).

Before executing the DESCRIBE statement, the SQLN field in the SQLDA must be set to indicate the number of SQLVAR occurrences in the SQLDA (this value is not changed by the XDB Server). Once SQLN is determined, performance can be improved by resetting this value after the DESCRIBE statement is first executed. With the exception of SQLN, all other SQLDA fields are set by the XDB Server software or are ignored, as indicated in the field descriptions below. Please note that the following descriptions do not necessarily apply to SQLDA usage with PREPARE, EXECUTE, OPEN, and FETCH statements:

  • SQLDAID is set to "SQLDA" by the XDB Server software.
  • SQLDABC is the length of the SQLDA in bytes, and equals SQLN*44+16 (as set by the XDB Server software).
  • SQLD is set to either the number of columns in the object being described or to zero (if DESCRIBE is applied to a nonquery statement). In order for the SQLDA to be large enough for the information requested, the returned value of SQLD must be less than or equal to the value of SQLN. If SQLD is larger than SQLN, no information is returned from the query into the SQLDA.
  • SQLVAR array values are assigned for each column in the object being described, such that the first array value describes the first column in the object, the second array value describes the second column, etc.
  • SQLTYPE is a code indicating the data type of the column and whether or not the column can contain null values.
  • SQLLEN is the length of the result column, which varies according to the data type of the column.
  • SQLDATA stores a dynamic memory address for the column.
  • SQLIND stores an indicator variable address for nullable columns.
  • SQLNAME is the unqualified name of the column.

Allocating SQLDA

To aid in the allocation of SQLDA memory space, first execute a DESCRIBE statement into an SQL Descriptor Area where the SQLN variable is deliberately set to zero. The value returned for the SQLD variable will equal the number of columns that need to be processed in the select list (which is the required value of SQLN). Use this returned value of SQLD to allocate another SQLDA, with the SQLN value preset to at least SQLD (or more) occurrences of the SQLVAR array. Execute the DESCRIBE statement again specifying this new SQLDA.

  • First technique

    Allocate an SQLDA with enough occurrences of SQLVAR to accommodate any select list that the application will have to process. At the extreme, the number of SQLVARs could equal three times the maximum number of columns allowed in a result table. After the SQLDA is allocated, the application can use the SQLDA repeatedly.

    This technique uses a large amount of storage that is never deallocated, even when most of this storage is not used for a particular select list.

  • Second technique

    Repeat the following for every processed select list:

    1. Execute a DESCRIBE statement with an SQLDA that has no occurrences of SQLVAR; that is, an SQLDA for which SQLN is zero.
    2. Allocate a new SQLDA with enough occurrences of SQLVAR. Use the values that are returned in SQLD and SQLCODE to determine the number of SQLVAR entries that are needed. The value of SQLD is the number of columns in the result table, which is either the required number of occurrences of SQLVAR or a fraction of the required number If the SQLCODE is +236, +237, +238, or +239, the number of SQLVAR entries that is needed is two or three times the value in SQLD, depending on whether USING BOTH was specified. Set SQLN to reflect the number of SQLVAR entries that have been allocated.
    3. Execute the DESCRIBE statement again, using the new SQLDA.

    This technique allows better storage management than the first technique, but it doubles the number of DESCRIBE statements.

  • Third technique

    Allocate an SQLDA that is large enough to handle most (hopefully, all) select lists but is also reasonably small. If an execution of DESCRIBE fails because SQLDA is too small, allocate a larger SQLDA and execute the DESCRIBE statement again.

    For the new larger SQLDA, use the values that are returned in SQLD and SQLCODE from the failing DESCRIBE statement to calculate the number of occurrences of SQLVAR that are needed, as described in technique two. Remember to check for SQLCODEs +236, +237, +238, and +239, which indicate whether extended SQLVAR entries are needed because the data includes LOBs or distinct types.

    This third technique is a compromise between the first two techniques. Its effectiveness depends on a good choice of size for the original SQLDA.

SQLDAID

XDB sets the first 6 bytes to 'SQLDA ' (5 letters followed by the space character) and the eighth byte to a space character. The seventh byte is set to indicate the number of SQLVAR entries that are needed to describe each column of the result table as follows:

space

The value of space occurs when:

  • USING BOTH was not specified and the columns being described do not include LOBs or distinct types. Each column only needs one SQLVAR entry. If the SQL standard option is yes, XDB sets SQLCODE to warning code +236. Otherwise, SQLCODE is zero.
  • USING BOTH was specified and the columns being described do not include LOBs or distinct types. Each column needs two SQLVAR entries. XDB sets SQLD to two times the number of columns of the result table. The second set of SQLVARs is used for the labels.

2

Each column needs two SQLVAR entries. Two entries per column are required when:

  • USING BOTH was not specified and the columns being described include LOBs or distinct types or both. XDB sets the second set of SQLVAR entries with information for the LOBs or distinct types being described.
  • USING BOTH was specified and the columns include LOBs but not distinct types. XDB sets the second set of SQLVAR entries with information for the LOBs and labels for the columns being described.

3

Each column needs three SQLVAR entries. Three entries are required only when USING BOTH is specified and the columns being described include distinct types. The presence of LOB data does not matter. It is the distinct types and not the LOBs that cause the need for three SQLVAR entries per column when labels are also requested. XDB sets the second set of SQLVAR entries with information for the distinct types (and LOBs, if any) and the third set of SQLVAR entries with the labels of the columns being described.

SQLD

If the prepared statement is a query, XDB sets the value to the number of columns in the object being described (the value is actually twice the number of columns in the case where USING BOTH was specified and the result table does not include LOBs or distinct types).

Otherwise, if the statement is not a query, XDB sets the value to 0.

SQLVAR

An array of field description information for the column being described. There are two types of SQLVAR entries--the base SQLVAR and the extended SQLVAR.

If the value of SQLD is 0, or is greater than the value of SQLN, no values are assigned to any occurrences of SQLVAR. If the value of SQLN was set so that there are enough SQLVAR occurrences to describe the specified columns (columns with LOBs or distinct types and a request for labels increase the number of SQLVAR entries that are needed), the values are assigned to the first n occurrences of SQLVAR so that the first occurrence of SQLVAR contains a description of the first column, the second occurrence of SQLVAR contains a description of the second column, and so on. This first set of SQLVAR entries are referred to as base SQLVAR entries. Each column always has a base SQLVAR entry.

If the DESCRIBE statement included the USING BOTH clause, or the columns being described include LOBs or distinct types, additional SQLVAR entries are needed. These additional SQLVAR entries are referred to as the extended SQLVAR entries. There can be up to two sets of extended SQLVAR entries for each column.

The base SQLVAR

SQLTYPE | A code that indicates the data type of the column and whether the column can contain null values.
SQLLEN | A length value depending on the data type of the result columns. SQLLEN is 0 for LOB data types.
SQLDATA | The CCSID of a string column.
SQLIND | Reserved.
SQLNAME | The unqualified name or label of the column, depending on the value of USING (NAMES, LABELS, ANY, or BOTH). The field is a string of length 0 if the column does not have a name or label.

The extended SQLVAR

SQLLONGLEN | The length attribute of a BLOB, CLOB, or DBCLOB column.
* | Reserved.
SQLDATALEN | Not Used.
SQLDATATYPE-NAME | For a distinct type, the fully qualified distinct type name. Otherwise, the value is the fully qualified name of the built-in data type. For a label, the label for the column.

USING

Indicates what value to assign to each SQLNAME variable in the SQLDA. If the requested value does not exist, SQLNAME is set to a length of 0.

NAMES | Assigns the name of the column. This is the default.
LABELS | Assigns the label of the column. (Column labels are defined by the LABEL ON statement.)
ANY | Assigns the column label, and if the column has no label, the column name.
BOTH | Assigns both the label and name of the column. In this case, two or three occurrences of SQLVAR per column, depending on whether the result set contains distinct types, are needed to accommodate the additional information. To specify this expansion of the SQLVAR array, set SQLN to 2¦n or 3¦n, where n is the number of columns in the object being described. For each of the columns, the first n occurrences of SQLVAR, which are the base SQLVAR entries, contain the column names. Either the second or third n occurrences of SQLVAR, which are the extended SQLVAR entries, contain the column labels. If there are no distinct types, the labels are returned in the second set of SQLVAR entries. Otherwise, the labels are returned in the third set of SQLVAR entries.

For a declared temporary table, the name of the column is assigned regardless of the value specified in the USING clause because declared temporary tables cannot have labels.

Performance considerations

Although XDB does not change the value of SQLN, you might want to reset this value after the DESCRIBE statement is executed. If the contents of SQLDA from the DESCRIBE statement is used in a later FETCH statement, set SQLN to n (where n is the number of columns of the result table) before executing the FETCH statement.

Example:

EXEC SQL
    DESCRIBE getcust INTO mydesc
END-EXEC

where mydesc is a defined SQLDA in working storage and getcust is a previously prepared command.

Parent topic: SQL Statements


DESCRIBE CURSOR

Invocation

This statement can be embedded in an application program only. It is an executable statement that cannot be dynamically prepared.

Authorization

No authorization is required for this statement.

Syntax

DESCRIBE CURSOR {cursor-name | host-variable}
    INTO descriptor-name

Parameters:

cursor- name | Indentifies a cursor by the specified cursor name. The name must identify a cursor that has already been allocated in the source program.
host-variable | Indentifies a cursor by the cursor name contained in the host variable. The name must identify a cursor that has already been allocated in the source program.
descriptor-name | Identifies an SQL descriptor area (SQLDA). The information returned in the SQLDA describes the columns in the result set associated with the named cursor.
Note:

For the statement to execute successfully, the application program must be connected to the site at which the stored procedure was executed.

Parent topic: SQL Statements


DESCRIBE INPUT Example

Execute a DESCRIBE INPUT statement with an SQLDA that has enough SQLVAR occurrences to describe any number of input parameters a prepared statement might have. Assume that five parameter markers at most will need to be described and that the input data does not contain LOBs.

/* STMT1_STR contains INSERT statement with VALUES clause */

EXEC SQL PREPARE STMT1_NAME FROM :STMT1_STR;

/* code to set SQLN to 5 and to allocate the SQLDA */

EXEC SQL DESCRIBE INPUT STMT1_NAME INTO :SQLDA;
Parent topic: SQL Statements


DESCRIBE PROCEDURE

Invocation

This statement can be embedded in an application program only. It is an executable statement that cannot be dynamically prepared.

Authorization

No authorization is required for this statement.

Syntax

DESCRIBE PROCEDURE {procedure-name | host-variable}
    INTO descriptor-name

Parameters:

procedure-name | Identifies the stored procedure to describe by the specified procedure name.
host-variable | Identifies the stored procedure to describe by the procedure name contained in the host variable.
descriptor-name | Identifies an SQL descriptor area (SQLDA). The information returned in the SQLDA describes the result sets returned by the stored procedure. Considerations for allocating and initializing the SQLDA are similar to those for DESCRIBE TABLE.

Description

When the DESCRIBE PROCEDURE statement is executed, the procedure name or specification must identify a stored procedure that the requestor has already invoked by using a CALL statement.

A procedure name is a qualified or unqualified name. Each part of the name is a long SQL identifier that must be composed of SBCS characters:

  • A fully qualified procedure name is a three-part name. The first part is a location name that identifies the DBMS at which the procedure is stored. The next two parts identify the stored procedure. The last part is a long identifier that contains the name of the stored procedure. A period must separate each of the parts.
  • An implicitly qualified procedure name is a two-part name that is qualified by the location name of the current server. The name and its implicit qualifier identifies a stored procedure. A period must separate the two parts. The first part identifies the stored procedure at the server. The meaning of the first part depends on the application server.
  • An unqualified procedure name is a one-part name with two implicit qualifiers. The first implicit qualifier is the location name of the current server. The second implicit qualifier identifies the stored procedure at the server. The meaning of the second implicit qualifier depends on the application server (for MVS, the qualifier is SYSPROC). The name and its implicit qualifiers identifies a stored procedure.

If a host variable is used:

  • It must be a character string variable with a length attribute that is not greater than 254.
  • It must be preceded by a colon and must not be followed by an indicator variable.
  • The value of the host variable is a specification that depends on the application server. Regardless of the application server, the specification must:
    • Be left justified within the host variable
    • Not contain embedded blanks
    • Be padded on the right with blanks if its length is less than that of the host variable

The procedure name in the DESCRIBE PROCEDURE statement must be specified the same way that it was specified on the CALL statement. For example, if a two-part name was specified on the CALL statement, you must use a two-part name in the DESCRIBE PROCEDURE statement. However, there is one condition under which the names do not have to match. If the CALL statement was made with a three-part name and the current server is the same as the location in the three-part name, you can omit the location name and specify a two-part name.

Example:

The statements in the following examples are assumed to be in PL/I programs.

Place information about the result sets returned by stored procedure P1 into the descriptor named by SQLDA1. Assume that the stored procedure is called with a one-part name from current server SITE2.

EXEC SQL CONNECT TO SITE2;
EXEC SQL CALL P1;
EXEC SQL DESCRIBE PROCEDURE P1 INTO :SQLDA1;
Parent topic: SQL Statements


DISABLE LOGIN

This command is useful for removing the XDB Server from service for routine maintenance, upgrades or repairs.

To make the server available again, use the ENABLE LOGIN command.

Note:

This command functions only when server security is on.

Invocation

This command can be embedded in a host language or executed interactively .

Authorization

Any of the following:

  • A super user
  • A user with SYSADM privileges

Syntax

DISABLE LOGIN
Parent topic: SQL Statements


DROP

Note:

With the exception of removed storage groups, any objects directly or indirectly dependent on the deleted object are also removed.

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared only if DYNAMICRULES run behavior is implicitly or explicitly specified.

Authorization

The XDB Server checks to ensure that users dropping different kinds of objects possess the following privileges as appropriate:

  • To drop a table, table space, or index, users must possess either DBADM for the database, SYSADM or SYSCTRL authority for the location, or be the owner of the object.
  • To drop an alias, storage group or view, users must possess either SYSADM or SYSCTRL authority or be the owner of the object.
  • To drop a database, users must possess either SYSADM or SYSCTRL authority for the location, DBADM or DBCTRL authority for the database or the DROP privilege on the database.
  • To drop a synonym, users must be owners of the synonym.

To drop a distinct type, stored procedure, trigger, or user-defined function, users must possess ownership of the object, the DROPIN privilege for the schema or all schemas, or SYSADM or SYSCTRL authority.

The DROP statement has access to the same privileges held by the combined AuthIDs of the application process.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

DROP
{
    ALIAS alias-name
    | DATABASE database-name
    | DISTINCT TYPE distinct-type-name RESTRICT
    | FUNCTION function-name (parameter-type[,...]) RESTRICT
    | INDEX index-name
    | SEQUENCE sequence-name
    | STOGROUP stogroup-name
    | LOCATION location-name
    | SYNONYM synonym
    | TABLE table-name
    | TABLESPACE [database-name.]tablespace-name
    | VIEW view-name
    | {PACKAGE | PROGRAM} collection-id.package.id[[VERSION] version-id]
    | PROCEDURE procedure-name RESTRICT
    | SPECIFIC FUNCTION specific-name RESTRICT
    | TRIGGER trigger-name
}

parameter-type:

{data-type [AS LOCATOR]}

data-type:

{built-in-data-type | distinct-type-name}

built-in-data-type:

SMALLINT |
{INTEGER | INT} |
{DECIMAL | DEC | NUMERIC} [integer[,...]] |
{FLOAT [integer] |
REAL [PRECISION] | DOUBLE} |
{ {CHARACTER | CHAR} [(integer)] |
    {CHARACTER | CHAR} VARYING (integer) |
    VARCHAR (integer) } [FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII}] |
{{CHARACTER | CHAR} LARGE OBJECT | CLOB} [(integer [K|M|G])] }
    [FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII}] } |{BINARY LARGE OBJECT | BLOB} (integer [K|M|G]) |
{GRAPHIC [(integer)] | VARGRAPHIC (integer) | DBCLOB (integer [K|M|G])} [CCSID {EBCDIC | ASCII}] |
{DATE | TIME | TIMESTAMP} |
ROWID

Parameters:

alias-name | Identifies the alias to be dropped. The name must identify an alias that exists at the current server. Dropping an alias has no effect on any view, materialized query table, or synonym that was defined using the alias.
database-name | Identifies the database to be dropped.
location-name | Identifies a user-created location to be dropped.
index-name | Identifies the index to be dropped.
stogroup-name | Identifies the storage group to be dropped.
synonym | Identifies the synonym to be dropped.
table-name | Identifies the table to be dropped.
[database-name.]tablespace-name | Identifies the table space (optionally qualified with a database name) to be dropped.
view-name | Identifies the view to be dropped.

Description

DELETE command rules do not apply when using the DROP command. When dropping a table, for instance, parent and dependent table relationships are not a consideration.

If the user-defined storage group for a database is dropped, then that database no longer has an active default storage group. A USING clause must be specified when creating future table space or indexes within that database. The USING clause must be specified until either another storage group is created with the same name (using CREATE STOGROUP) or another default storage group is designated for the database (using ALTER DATABASE).

ALIAS

This keyword indicates that an alias is to be dropped. The alias must exist at the current location. Dropping an alias does not affect any view or synonym previously defined using the dropped alias.

DATABASE

The keyword indicates that a database is to be dropped. This database must not be a system database (DSNDB04, DSNDB06, DSNDDF, XDBACF, etc.), and must exist at the current location. The database, along with all table spaces, tables and indexes associated with the database are dropped.

DISTINCT TYPE distinct-type-name RESTRICT

Identifies the distinct type to be dropped. The name must identify a distinct type that exists at the current server. The default keyword RESTRICT indicates that the distinct type is not dropped if any of the following dependencies exist:

  • The definition of a column of a table uses the distinct type.
  • The definition of an input or result parameter of a user-defined function uses the distinct type.
  • The definition of a parameter of a stored procedure uses the distinct type.
  • A sequence exists for which the data type of the sequence is the distinct type.

Whenever a distinct type is dropped, all privileges on the distinct type are also dropped. In addition, the cast functions that were generated when the distinct type was created and the privileges on those cast functions are also dropped.

FUNCTION

Identifies the user-defined function to be dropped. The name must identify a function that has been defined with the CREATE FUNCTION statement at the current server. The name must not identify a cast function that was generated for a distinct type or a function that is in the SYSIBM schema. The required keyword RESTRICT enforces the rule that the function is not dropped if any of the following dependencies exist:

  • Another function is sourced on the function.
  • A view uses the function.
  • A trigger package uses the function.

Whenever a function is dropped, all privileges on the user-defined function are also dropped. Any plans or packages that are dependent on the function dropped are made inoperative.

You can identify the particular function to be dropped by its name, function signature, or specific name. If the function was defined with a table parameter (the LIKE TABLE was specified in the CREATE FUNCTION statement to indicate that one of the input parameters is a transition table), the function signature cannot be used to identify the function. Instead, identify the function with its function name, if unique, or with its specific name.

FUNCTION function-name RESTRICT | Identifies the function by its name. There must be exactly one function with function-name in the implicitly or explicitly specified schema; otherwise, an error occurs.
FUNCTION function-name (parameter-type,...) RESTRICT | Provides the function signature, which uniquely identifies the function. There must be exactly one function with the function signature in the implicitly or explicitly specified schema; otherwise, an error occurs. If the function was defined with a table parameter (the LIKE TABLE was specified in the CREATE FUNCTION statement to indicate that one of the input parameters is a transition table), the function signature cannot be used to uniquely identify the function. Instead, use one of the other syntax variations to identify the function with its function name, if unique, or its specific name.
function-name | Identifies the name of the function.
(parameter-type,...) | Identifies the parameters of the function.

If an unqualified distinct type name is specified, XDB searches the SQL path to resolve the schema name for the distinct type.

The data types of the parameters must match the data types that were specified on the CREATE FUNCTION statement in the corresponding position. The number of data types and the logical concatenation of the data types are used to identify the function.

For data types that have a length, precision, or scale attribute, you can specify a value or use a set of empty parentheses:

  • Empty parentheses indicate that XDB ignores the attribute when determining whether the data types match.

    FLOAT cannot be specified with empty parentheses because its parameter value indicates different data types (REAL or DOUBLE).

  • If you use a specific value for a length, precision, or scale attribute, the value must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.
  • The specific value for FLOAT(n) does not have exactly match the defined value of the source function because 1<=n<= 21 indicates REAL and 22<=n<=53 indicates DOUBLE. Matching is based on whether the data type is REAL or DOUBLE.
  • If length, precision, or scale is not explicitly specified, and empty parentheses are not specified, the default length of the data type is implied. For example:
    CHAR | CHAR(1)
    GRAPHIC | GRAPHIC(1)
    DECIMAL | DECIMAL(5,0)
    FLOAT | DOUBLE (length of 8)

The implicit length must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.

For data types with a subtype or encoding scheme attribute, specifying the FOR DATA clause or CCSID clause is optional. Omission of either clause indicates that XDB ignores the attribute when determining whether the data types match. If you specify either clause, it must match the value that was implicitly or explicitly specified in the CREATE FUNCTION statement.

SPECIFIC FUNCTION specific-name RESTRICT Identifies the function by its specific name, which was explicitly specified or implicitly created when the function was created. There must be exactly one function with specific-name in the implicitly or explicitly specified schema.

INDEX

The name must identify a user-defined index that exists at the current server but must not identify a populated index on an auxiliary table. A populated index on an auxiliary table can only be dropped by dropping the base table.

If the index that is dropped was created by specifying the ENDING AT clause to define partition boundaries, the table is converted to use table-controlled partitioning. The high limit key for the last partition is set to the highest possible value for ascending key columns or the lowest possible value for descending key columns.

Whenever an index is directly or indirectly dropped, its index space is also dropped. The name of a dropped index space cannot be reused until a commit operation is performed.

If the index is a unique index used to enforce a unique constraint (primary or unique key), the unique constraint must be dropped before the index can be dropped. In addition, if a unique constraint supports a referential constraint, the index cannot be dropped unless the referential constraint is dropped.

However, a unique index (for a unique key only) can be dropped without first dropping the unique key constraint if the unique key was created in a release of DB2 before Version 7 and if the unique key constraint has no associated referential constraints.

If a unique index is dropped and that index was defined on a ROWID column that is defined as GENERATED BY DEFAULT, the table can still be used, but rows cannot be inserted into that table.

If an empty index on an auxiliary table is dropped, the base table is marked incomplete.

LOCATION

This keyword indicates that a user-created location is to be dropped. All database and other objects stored within the location are also dropped. INSTALL authority is needed to drop a location. When dropping a location, not all files are cleaned up. Some files may be left in the directory that contained the location. If you attempt to create another location in the same directory, these files will be overwritten. If you wish to clean up your hard drive, delete these files -- just make sure that you are deleting files from an already deleted location.

Note:

You cannot drop a location that was created in the same session. You must first exit the interactive SQL session during which you created the location, and then start another interactive SQL session to drop the newly created location.

PROCEDURE procedure-name RESTRICT

Identifies the stored procedure to be dropped. The name must identify a stored procedure that has been defined with the CREATE PROCEDURE statement at the current server. The required keyword RESTRICT prevents the procedure from being dropped if a trigger definition contains a CALL statement with the name of the procedure.

When a procedure is directly or indirectly dropped, all privileges on the procedure are also dropped. In addition, any plans or packages that are dependent on the procedure are made inoperative.

SEQUENCE sequence-name

Identifies the sequence to be dropped. The name must identify an existing sequence at the current server. If no sequence by this name exists in the explicitly or implicitly specified schema, an error occurs.

sequence-name must not be the name of an internal sequence object that is generated by the system for an identity column. Sequences generated by the system for identity columns cannot be dropped with the DROP SEQUENCE statement. A sequence object for an identity column is implicitly dropped when the table containing the identify column is dropped.

The default keyword RESTRICT indicates that the sequence is not dropped if any of the following dependencies exist:

  • A trigger that uses the sequence in a NEXT VALUE or PREVIOUS VALUE expression exists.
  • An inline SQL function that uses the sequences in a NEXT VALUE or PREVIOUS VALUE expression exists.

Whenever a sequence is dropped, all privileges on the sequence are also dropped, and the plans and packages that refer to the sequence are invalidated. Dropping a sequence, even if the drop process is rolled back, results in the loss of the still-unassigned cache values for the sequence.

STOGROUP

This keyword indicates that a stogroup is to be dropped. The storage group must exist at the current location and must not be the default storage group (SYSDEFLT) or a storage group still used by any table space or index space. Objects defined within a stogroup are not automatically dropped when the stogroup is dropped. Users must first drop the individual objects in the stogroup or alter the objects to utilize a different stogroup. An error occurs when attempting to drop a stogroup being used by a table space.

SYNONYM

This keyword indicates that a synonym is to be dropped. In a dynamic DROP SYNONYM statement, the synonym identified must be owned by the CURRENT SQLID. Dropping a synonym does not affect any view or alias previously defined using the synonym. A user with SYSADM privileges can drop synonyms owned by other users.

Dropping a synonym has no effect on any view, materialized query table, or alias that was defined using the synonym, nor does it invalidate any plans or packages that use such views, materialized query tables, or aliases.

TABLE

This keyword indicates that a table is to be dropped. The table must exist at the current location and must not be a system catalog table. When a table is dropped (either directly or indirectly), all privileges on the table are dropped. Additionally, all parent or dependent referential constraints built on the table, all synonyms, views, and indexes defined on the table are also dropped.

A table in a partitioned table space can only be dropped by dropping the table space. A populated auxiliary table can only be dropped by dropping the associated base table.

Whenever a table is directly or indirectly dropped, all materialized query tables defined on the table are also dropped. Whenever a materialized query table is directly or indirectly dropped, all privileges on the materialized query table and all synonyms, views, and indexes that are defined on the materialized query table are also dropped. Any alias defined on the materialized query table is not dropped. Any plans or packages that are dependent on the dropped materialized query table are marked invalid.

If a table with LOB columns is dropped, the auxiliary tables associated with the table and the indexes on the auxiliary tables are also dropped. Any LOB table spaces that were implicitly created for the auxiliary tables are also dropped.

If an empty auxiliary table is dropped, the definition of the base table is marked incomplete.

If the table has a security label column, the primary authorization ID of the DROP statement must have a valid security label, and the RACF SECLABEL class must be active.

TABLESPACE

This keyword indicates that a table space is to be dropped. All tables in the dropped table space are also dropped.

The table space must exist at the current location (and must not be in the DSNDB06 database). Table spaces that were created implicitly cannot be dropped. If a database name qualifier is not included, than the default DSNDB04 database for that location is implicitly specified.

A table space in a TEMP database can be dropped only if it does not contain an active declared temporary table. A LOB table space can be dropped only if it does not contain an auxiliary table.

Whenever a base table space that contains tables with LOB columns is dropped, all the auxiliary tables and indexes on those auxiliary tables that are associated with the base table space are also dropped.

TRIGGER trigger-name

Identifies the trigger to be dropped. The name must identify a trigger that exists at the current server.

Whenever a trigger is directly or indirectly dropped, all privileges on the trigger are also dropped and the associated trigger package is freed. The name of that trigger package is the same as the trigger name and the collection ID is the schema name.

VIEW

This keyword indicates that a view is to be dropped. The name must identify a view that exists at the current server.

Whenever a view is directly or indirectly dropped, all privileges on the view and all synonyms and views that are defined on the view are also dropped. Whenever a view is directly or indirectly dropped, all materialized query tables defined on the view are also dropped.

Dependencies when dropping objects

Whenever an object is directly or indirectly dropped, other objects that depend on the dropped object might also be dropped. (The catalog stores information about the dependencies of objects on each other.) The following semantics determine what happens to a dependent object when the object that it depends on (the underlying object) is dropped:

Cascade (D) | Dropping the underlying object causes the dependent object to be dropped. However, if the dependent object cannot be dropped because it has a restrict dependency on another object, the drop of the underlying object fails.
Restrict (R) | The underlying object cannot be dropped if a dependent object exists.
Inoperative (O) | Dropping the underlying object causes the dependent object to become inoperative.
Invalidation (V) | Dropping the underlying object causes the dependent object to become invalidated.

Example:

The statements in the following examples are assumed to be in PL/I programs.

Place information about the result sets returned by stored procedure P1 into the descriptor named by SQLDA1. Assume that the stored procedure is called with a one-part name from current server SITE2.

EXEC SQL CONNECT TO SITE2;
EXEC SQL CALL P1;
EXEC SQL DESCRIBE PROCEDURE P1 INTO :SQLDA1;
Parent topic: SQL Statements


ENABLE LOGIN

Note:

This command functions only when server security is on.

Invocation

This command can be embedded in a host language or executed interactively.

Authorization

Any of the following:

  • A super user
  • A user with SYSADM privileges

Syntax

ENABLE LOGIN
Parent topic: SQL Statements


END DECLARE SECTION

Invocation

END DECLARE SECTION is not an executable statement. It can only be embedded in a host language.

Authorization

No special authorization is required.

Syntax

END DECLARE SECTION

Description

END DECLARE SECTION may be used in an application program to mark the end of the section of code where host variables are declared. If an END DECLARE SECTION is used, the host variable declaration section must begin with the BEGIN DECLARE SECTION statement.

When programming in C, or when the DECLARE or ANSI COBOL preprocessor directives are used, BEGIN and END DECLARE SECTION commands must surround the declarations for all host variables, creating host variable declaration blocks. The host variable declaration blocks can appear anywhere the host language allows variable declarations, but they cannot be nested.

Example:

EXEC SQL BEGIN DECLARE SECTION;
    short in cust_num = 28;
    char name[30];
EXEC SQL END DECLARE SECTION;
Parent topic: SQL Statements


END DECLARE SECTION Example

EXEC SQL BEGIN DECLARE SECTION;
    short in cust_num = 28;
    char name[30];
EXEC SQL END DECLARE SECTION;
Parent topic: SQL Statements


EXECUTE

Invocation

EXECUTE is an executable command that can only be embedded in a host language. EXECUTE cannot be dynamically prepared.

Authorization

The user must have the authority to use the previously prepared command.

Syntax

EXECUTE statement-name
    [USING {host-variable[,...] |
    DESCRIPTOR descriptor-name} |
    multiple-row-insert]

multiple-row-insert

USING {{host-variable-array | host-variable} [,...]}
   | DESCRIPTOR descriptor-name}
   [FOR {host-variable | integer-constant} ROWS]

Parameters:

statement-name | Identifies a previously prepared nonquery statement to be executed.
host-variable | Identifies a variable described in the application program in accordance with the rules for declaring host variables in the application language.
descriptor-name | Identifies an SQLDA containing a valid description of the host variables to be inserted into the prepared statement during execution.

Description

The EXECUTE command is always used in conjunction with the PREPARE statement, since the main argument for EXECUTE is a previously prepared SQL statement. The PREPARE statement tells the XDB Server about the statement to be executed, while the EXECUTE statement executes that statement, substituting host variable values where specified.

USING

This optional keyword precedes a list of host variables whose values are substituted for the parameter markers (question marks) in the prepared statement. If the prepared statement includes parameter markers, the USING clause must be included in the EXECUTE statement.

The total number of host variables specified must equal the total number of parameter markers in the prepared statement. The order of host variables specified determines their order of substitution into the prepared statement -- with the first variable substituting for the first parameter marker in the prepared statement, etc.

DESCRIPTOR

This keyword indicator precedes a valid SQL Descriptor Area (SQLDA) name. The total number of host variables (as stored in SQLD) must match the total number of parameter markers in the prepared statement. The length of the SQLDA (as stored in SQLDABC) must be sufficient to accommodate all host variables. As with ordinary host variables, there is an ordered one-to-one correspondence between each host variable described in the SQLDA, and the parameter markers inside the prepared statement.

The SQLDA must have enough storage to contain all SQLVAR occurrences.

Parameter Marker Replacement

Before the prepared statement is executed, each parameter marker in the prepared statement string is essentially replaced by a corresponding host variable from the application. This replacement operation transfers the value of the host variable (source) to the corresponding parameter marker (target) within the prepared SQL statement string. The attribute of each host variable -- once transferred into its new "target position" within the SQL statement string -- depends on the original location (and role) of the replaced parameter marker.

Example:

In COBOL, host-variables are data structures defined in working storage. In the following example, we PREPARE inscust and substitute the values of the host variables c_no and company.

EXEC SQL
    PREPARE inscust
        FROM
            INSERT INTO customer(c_no, company) VALUES(?, ?)
END-EXEC
EXEC SQL
    EXECUTE inscust USING :CNO, :CNAME
END-EXEC
Parent topic: SQL Statements
Related information
EXECUTE IMMEDIATE


EXECUTE IMMEDIATE

Invocation

EXECUTE IMMEDIATE is an executable command that can only be embedded in a host language. EXECUTE IMMEDIATE cannot be dynamically prepared.

Authorization

The authorization required for EXECUTE IMMEDIATE conforms exactly with whatever authorization is needed to dynamically prepare the SQL statement indicated in the statement string argument. Consult individual SQL command descriptions in this reference for authorization requirements.

Syntax

EXECUTE IMMEDIATE
    {string-expression | host-variable}

Parameters:

string-expression | A delimited character string that can contain any valid SQL command except CLOSE, DESCRIBE, EXECUTE, EXECUTE IMMEDIATE, FETCH, INCLUDE, OPEN, PREPARE, WHENEVER, or SELECT.
host-variable | Identifies a variable defined in working storage (according to the rules for declaring character string variables in the host language) that contains a valid string expression (statement string).

Description

The EXECUTE IMMEDIATE command prepares and executes non-SELECT SQL commands within a statement string. You should check the syntax of the SQL statement you plan to use before placing that statement into an EXECUTE IMMEDIATE command. This check can be performed with SQLWizard.

The statement string cannot contain parameter markers (question marks) or references to host variables. The statement cannot begin with EXEC SQL or end with END-EXEC (or a semicolon). If the SQL command appearing in the statement string is invalid, an error condition is reported to the SQLCA.

The statement string must be one of the following SQL statements:

ALTER | RENAME
COMMENT ON | REVOKE
COMMIT | ROLLBACK
CREATE | SET CURRENT DEGREE
DELETE | SET CURRENT LOCALE LC_CTYPE
DROP | SET CURRENT OPTIMIZATION HINT
EXPLAIN | SET CURRENT PATH
GRANT | SET CURRENT PRECISION
INSERT | SET CURRENT RULES
LABEL ON | SET CURRENT SQLID
LOCK TABLE | UPDATE

Examples:

Host variables cannot be used in the string expressions.

EXEC SQL
    EXECUTE IMMEDIATE
    'DELETE FROM employee WHERE fname = "Elvis"'
END-EXEC

EXEC SQL
    EXECUTE IMMEDIATE
        'UPDATE employee
    SET fname = "Elvis"
    WHERE e_no = 1'
END-EXEC

Another example of EXECUTE IMMEDIATE embedded in COBOL appears below:

MOVE 'UPDATE employee SET fname = "Elvis"
    WHERE e_no = 1'
    TO exstr

EXEC SQL
    EXECUTE IMMEDIATE :exstr
END-EXEC
Parent topic: SQL Statements


EXPLAIN

Optionally, EXPLAIN can also obtain and place information in two additional tables. A user-supplied statement table can be populated with information about the estimated cost of executing the explainable statement. A user-supplied function table can be populated with information about how DB2 resolves the user-defined functions that are referred to in the explainable statement.

Invocation

EXPLAIN is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

The authorization privileges needed for an EXPLAIN statement are the same privileges required to execute the SQL statement for which you are requesting explanation.

If the EXPLAIN statement is embedded in an application program, the authorization rules that apply are those defined for embedding the specified SQL statement in an application program. In addition, the authorization ID of the owner of the plan or package must also have one of the following characteristics:

  • Be the owner of a plan table named PLAN_TABLE
  • Have an alias on a plan table named owner.PLAN_TABLE and have SELECT and INSERT privileges on the table

If the EXPLAIN statement is dynamically prepared, the authorization rules that apply are those defined for dynamically preparing the specified SQL statement. In addition, the SQL authorization ID of the process must also have one of the following characteristics:

  • Be the owner of a plan table named PLAN_TABLE
  • Have an alias on a plan table named owner.PLAN_TABLE and have SELECT and INSERT privileges on the table.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

EXPLAIN { {PLAN | ALL} [SET QUERYNO=integer]
    FOR explainable-sql-statement
    | STMTCACHE {STMTID {id-host-variable|integer-constant} |
                 STMTTOKEN {token-host-variable|string-constant}} }

Parameters:

integer Preceded by the keywords SET QUERYNO=, specifies an integer to be inserted into the QUERYNO column of the plan_table.
explainable-sql-statement Preceded by the keyword FOR, specifies the SQL statement for which information is returned to the plan table. Only SELECT and INSERT statements or the searched form of an UPDATE or DELETE statement, can be the SQL statement in an EXPLAIN command. The statement must not be a statement-name or a host-variable, and must refer to objects at the current location.

explainable-sql-statement must not contain a QUERYNO clause. To specify the value of the QUERYNO column in plan table for the statement being explained, use the SET QUERYNO = clause of the EXPLAIN statement.

If embedded in an application program, the EXPLAIN statement can contain host variable references. These host variables must be defined in the application program.

SET QUERYNO=

When these optional keywords are specified, the plan table column QUERYNO is given the value integer for each subsequent row inserted by the EXPLAIN statement. If this clause is not specified, XDB Server assigns its own number to QUERYNO.

STMTCACHE STMTID id-host-variable or integer-constant

Specifies that the cached statement with the specified statement ID is to be explained. The value contained in id-host-variable or specified by integer-constant identifies the statement ID. The statement ID is an integer that uniquely identifies a statement that has been cached in the dynamic statement cache. The statement ID of a cached statement can be retrieved through IFI monitor facilities from IFCID 316 or 124. Some diagnostic trace records, such as 173, 196, and 337, also show the statement ID.

For every row that the EXPLAIN statement inserts into the plan table, statement table, or function table, the QUERYNO column contains the value of the statement ID.

STMTCACHE STMTOKEN id-host-variable or integer-constant

Specifies that the cached statements with the specified statement token are to be explained. The value contained in token-host-variable or specified by string-constant identifies the statement token. The statement token must be a character string that is no longer than 240 bytes. The application program that originally prepares and inserts a statement into the cache associates a statement token with the cached statement. The program can make this association with the RRSAF SET_ID function, or the sqleseti API if the program is connected remotely.

For every row that the EXPLAIN statement inserts into the plan table, statement table, or function table, the STMTTOKEN column contains the value of the statement token, and the QUERYNO column contains the value of the statement ID for the cached statement with the statement token.

PLAN_TABLE Output

The XDB Server explain facility is highly compatible with the explain facility in DB2. While a one-to-one correspondence exists in the order and naming of XDB Server and DB2 PLAN_TABLE columns, differences do occur in some of the values which the optimizer writes to the PLAN_TABLE columns. In those cases where the optimizer produces a PLAN_TABLE column value that varies from that produced by a comparable EXPLAIN statement under DB2, the variation is noted.

If it does not already exist, the XDB Server creates an empty table named PLAN_TABLE for the user's CURRENT SQLID at the current location. Each time an EXPLAIN statement is executed, the XDB Server appends another row of information to the PLAN_TABLE. This information accumulates, allowing comparison and analysis of individual query information.

The following table describes the standard column arrangement in PLAN_TABLE. Each step in the execution of a query or subquery (in an explainable statement) is described in its own row in PLAN_TABLE. Each column value in a row identifies an aspect of the execution step -- such as the query or subquery, which tables are involved, and the access path used to carry out the step.

Column Name | Description
integer | Preceded by the keywords SET QUERYNO=, specifies an integer to be inserted into the QUERYNO column of the plan_table.
explainable-sql-statement Preceded by the keyword FOR, specifies the SQL statement for which information is returned to the plan table. Only SELECT and INSERT statements or the searched form of an UPDATE or DELETE statement, can be the SQL statement in an EXPLAIN command. The statement must not be a statement-name or a host-variable, and must refer to objects at the current location.

explainable-sql-statement must not contain a QUERYNO clause. To specify the value of the QUERYNO column in plan table for the statement being explained, use the SET QUERYNO = clause of the EXPLAIN statement.

If embedded in an application program, the EXPLAIN statement can contain host variable references. These host variables must be defined in the application program.

QUERYNO | A number identifying the explained statement. Can be specified with the SET QUERYNO clause.
QBLOCKNO | A number to identify subqueries.
APPLNAME | BLANK (XDB Server currently only explains individual queries)
PROGNAME | BLANK (XDB Server currently only explains individual queries)
PLANNO | Constant value of "1" (since only one individual query can be described per EXPLAIN command)
METHOD | Constant value of "1" (the XDB Server currently processes all joins using the "nested loop" method)
CREATOR | Creator of the table accessed.
TNAME | The name of the table accessed.
TABNO | A number distinguishing multiple references to the same table.
ACCESSTYPE Method of accessing the table:
I
An index (identified in ACCESSCREATOR and ACCESSNAME)
I1
One-fetch index scan
N
Index scan when predicate contains keyword IN
R
Sequential scan of its pages (commonly called table space scan)
M
Multiple index scan; followed by MX, MI, or MU
MX
Index scan on the index named in ACCESSNAME
MI
Intersection of multiple indexes
MU
Union of multiple indexes
blank
Not applicable to current row
MATCHCOLS | The number of index keys matched in the index scan. Zero (0) for a nonmatching index scan.
ACCESSCREATOR | The creator of the index named in ACCESSNAME.
ACCESSNAME | Name of the index referred to in ACCESSTYPE.
INDEXONLY | "Y" if data pages need not be accessed.
SORTN_UNIQ | Always "N"
SORTN_JOIN | Always "N"
SORTN_ORDERBY | Always "N"
SORTN_GROUPBY | Always "N"
SORTC_UNIQ | "Y" if sort on result table is required to remove duplicate rows.
SORTC_JOIN | Always "N"
SORTC_ORDERBY | "Y" if sort on result table is required for ORDER BY.
SORTC_GROUPBY | Always "N"
TSLOCKMODE | Always "IS"
TIMESTAMP | The time at which the EXPLAIN statement was processed.
REMARKS | Optional user remarks.
PREFETCH Whether or not prefetch can be used to read pages in advance:
P
Pure sequential prefetch
L
Prefetch through a page list
COLUMN_FN_EVAL Normally Blank. Contains a nonblank value "R" only when the XDB Server can evaluate the function directly from the index.

If the statement:

SELECT COUNT(field1)
    FROM table1
    WHERE field1 = ?

did not contain a WHERE clause, then the aggregate would be evaluated from the index (providing a simple index exists on field1).

MIXOPSEQ | A number indicating the sequence in which the steps of a multiple index operation are preformed. Zero (0) if ACCESSTYPE is other than MX, MI or MU.
VERSION | Always Blank.
COLLID | Always Blank.

Comments:

Table Creation Options

Plan tables can function with fewer columns than those described in the previous table. The XDB Server accepts three configurations (corresponding to different DB2 versions) of plan tables. The PLAN_TABLE format on the XDB Server defaults to the same 30 column table as used in DB2. Users have the option of explicitly creating their own 25, 28 or 30 column PLAN_TABLE:

  • A 30 column table ending with the COLLID column (used with DB2 Version 2.3).
  • A 25 column table ending with the REMARKS column.
  • A 28 column table ending with the MIXOPSEQ column.

A plan table must include one of the following sets of columns:

  • All the columns up to and including REMARKS (COLCOUNT = 25)
  • All the columns up to and including MIXOPSEQ (COLCOUNT = 28)
  • All the columns up to and including COLLID (COLCOUNT = 30)
  • All the columns up to and including JOIN_PGROUP_ID (COLCOUNT = 34)
  • All the columns up to and including IBM_SERVICE_DATA (COLCOUNT = 43)
  • All the columns up to and including BIND_TIME (COLCOUNT = 46)
  • All the columns shown in the CREATE statement (COLCOUNT = 58)

Whichever option is used, the columns must appear in the same order indicated in the previous table. A plan table can be modified with an ALTER TABLE command, as long as the final table configuration matches one of the three options above.

When using the 58-column format for the plan table, remember that many columns (PROGNAME, COLLID, CREATOR, TNAME, ACCESSCREATOR, ACCESSNAME, CORRELATION_NAME) must be defined as VARCHAR(128). In previous releases of DB2, these columns were smaller.

Plan table migration

You can migrate existing plan tables to subsequent releases or fall back to prior releases. If you fall back to a prior release, the extra columns are simply ignored when EXPLAIN is executed. If you migrate to a subsequent release, the missing columns are likewise ignored.

Example:

The following example places a description of the steps taken by the XDB Server to execute the SELECT statement shown into the user's plan table. The QUERYNO value of "1212" uniquely marks the PLAN_TABLE row entries as pertaining to this SELECT statement:

EXPLAIN PLAN SET QUERYNO = 1212 FOR
    SELECT pno, shipcost = weight * 1.15
        FROM part
        WHERE city = "LONDON"

To retrieve the PLAN_TABLE row entries belonging solely to the SELECT statement "explained" above, query the PLAN_TABLE by specifying a value of "1212" for the QUERYNO column:

SELECT *
    FROM plan_table
    WHERE queryno = 1212
Parent topic: SQL Statements


FETCH

There are two forms of this statement:

  • Single row fetch: positions the cursor and, optionally, retrieves data from a single row of the result table.
  • Multiple row fetch: positions the cursor on zero or more rows of the result table and, optionally, returns data if there is a target specification.

Invocation

This statement can only be embedded in an application program. It is an executable statement that cannot be dynamically prepared.

Authorization

To execute a FETCH command on an opened cursor, the user requires the same authority needed to declare that cursor for a given table or set of tables.

Syntax

FETCH [SENSITIVE | INSENSITIVE] fetch-orientation [FROM]
    cursor-name [single-row-fetch | multiple-row-fetch]

fetch-orientation

{BEFORE |
 AFTER |
 row-positioned |
 rowset-positioned}

row-positioned

[NEXT |
 PRIOR |
 FIRST |
 LAST |
 CURRENT |
 ABSOLUTE {host-variable | integer-constant} |
 RELATIVE {host-variable | integer-constant}]

rowset-positioned

[NEXT ROWSET |
 PRIOR ROWSET |
 FIRST ROWSET |
 LAST ROWSET |
 CURRENT ROWSET |
 ROWSET STARTING AT {ABSOLUTE | RELATIVE} {host-variable | integer-constant}]

single-row-fetch

[INTO {host-variable [,...] | DESCRIPTOR descriptor-name}]

multiple-row-fetch

[FOR {host-variable | integer-constant} ROWS]
[INTO {host-variable-array [,...] | DESCRIPTOR descriptor-name}]

Description

The FETCH command retrieves data from the next row of a cursor result table. A cursor defines the current row of the result. A FETCH statement also advances this cursor to the next available row in the result table. The result table is a collection of rows of data that satisfy the conditions of a SELECT statement defined in a DECLARE CURSOR statement.

If currently positioned before a row of its result table, the FETCH command moves the cursor onto that row and assigns the column values in that row to the host variables as specified by either the INTO or USING clauses. If positioned on a row (other than the last row), the FETCH command moves the cursor onto the next row, assigning the column values of that row to the host variables specified. Once the cursor becomes positioned on or after the last row, a value of +100 is assigned to the SQLCODE indicator field (SQLCA), and the FETCH command positions the cursor after the last row. No values are assigned to the host variables indicated.

INSENSITIVE

Returns the row from the result table as it is. If the row has been previously fetched with a FETCH SENSITIVE, it reflects changes made outside this cursor before the FETCH SENSITIVE statement was issued. Positioned updates and deletes are reflected with FETCH INSENSITIVE if the same cursor was used for the positioned update or delete.

INSENSITIVE can only be specified for cursors declared as INSENSITIVE or SENSITIVE STATIC (or if the cursor is declared as ASENSITIVE and DB2 defaults to INSENSITIVE). Otherwise, if the cursor is declared as SENSITIVE DYNAMIC (or if the cursor is declared as ASENSITIVE and DB2 defaults to SENSITIVE DYNAMIC), an error occurs and the FETCH statement has no effect. For an INSENSITIVE cursor, specifying INSENSITIVE is optional because it is the default.

SENSITIVE

Updates the fetched row in the result table from the corresponding row in the base table of the cursor's SELECT statement and returns the current values. Thus, it reflects changes made outside this cursor. SENSITIVE can only be specified for a sensitive cursor. Otherwise, if the cursor is insensitive, an error occurs and the FETCH statement has no effect. For a SENSITIVE cursor, specifying SENSITIVE is optional because it is the default.

When the cursor is declared as SENSITIVE STATIC and a FETCH SENSITIVE is requested, the following steps are taken:

  1. SQL Option retrieves the row of the database that corresponds to the row of the result table that is about to be fetched.
  2. If the corresponding row has been deleted, a "delete hole" occurs in the result table, a warning is issued, the cursor is repositioned on the "hole", and no data is fetched. (SQL Option marks a row in the result table as a "delete hole" when the corresponding row in the database is deleted.)
  3. If the corresponding row has not been deleted, the predicate of the underlying SELECT statement is re-evaluated. If the row no longer satisfies the predicate, an "update hole" occurs in the result table, a warning is issued, the cursor is repositioned on the "hole," and no data is fetched. (SQL Option marks a row in the result table as an "update hole" when an update to the corresponding row in the database causes the row to no longer qualify for the result table.)
  4. If the corresponding row does not result in a delete or an update hole in the result table, the cursor is repositioned on the row of the result table and the data is fetched.

AFTER

Positions the cursor after the last row of the result table. Values are not assigned to host variables. The number of rows of the result table are returned in the SQLERRD1 and SQLERRD2 fields of the SQLCA for cursors with an effective sensitivity of INSENSITIVE or SENSITIVE STATIC.

BEFORE

Positions the cursor before the first row of the result table. Values are not assigned to host variables.

row-positioned

Positioning of the cursor with row-positioned fetch orientations NEXT, PRIOR, and RELATIVE is done in relation to the current cursor position. Following a successful row-positioned FETCH statement, the cursor is positioned on a single row of data. If the cursor is enabled for rowsets, positioning is performed relative to the first row of the current rowset, and the cursor is positioned on a rowset consisting of a single row.

NEXT

Positions the cursor on the next row or rows of the result table relative to the current cursor position, and returns data if a target is specified. NEXT is the only row-positioned fetch operation that can be explicitly specified for cursors that are defined as NO SCROLL. NEXT is the default if no other cursor positioning is specified. If a specified row reflects a hole, a warning is issued and data values are not assigned to host variables for that row.

The following table shows situations for different cursor positions and the results when NEXT is used.

Current state of the cursor | Result of FETCH NEXT
Before the first row | Cursor is positioned on the first row and data is returned if requested.
On the last row or after the last row | A warning occurs, values are not row assigned to host variables, and the cursor is positioned after the last row.
Before a hole | For a SENSITIVE STATIC cursor, a warning occurs for a delete hole or an update hole, values are not assigned to host variables, and the cursor is positioned on the hole.
Unknown | An error occurs, values are not assigned to host variables, and the cursor position remains unknown.

PRIOR

Positions the cursor on the previous row or rows of the result table relative to the current cursor position, and returns data if a target is specified. If a specified row reflects a hole, a warning is issued, and data values are not assigned to host variables for that row.

The following table shows situations for different cursor positions and the results when PRIOR is used.

Current state of the cursor | Result of FETCH PRIOR
Before or on the first row | A warning occurs, values are not first row assigned to host variables, and the cursor is positioned before the first row.
After a hole | For a SENSITIVE STATIC cursor, a warning occurs for a delete hole or an update hole, values are not assigned to host variables, and the cursor is positioned on the hole.
After the last row | Cursor is positioned on the last row.
Unknown | An error occurs, values are not assigned to host variables, and the cursor position remains unknown.

FIRST

Positions the cursor on the first row of the result table, and returns data if a target is specified. For a SENSITIVE STATIC cursor, if the first row of the result table is a hole, a warning occurs for a delete hole or an update hole and values are not assigned to host variables.

LAST

Positions the cursor on the last row of the result table, and returns data if a target is specified. The number of rows of the result table is returned in the SQLERRD1 and SQLERRD2 fields of the SQLCA for an insensitive or sensitive static cursor. For a SENSITIVE STATIC cursor, if the last row of the result table is a hole, a warning occurs for a delete hole or an update hole and values are not assigned to host variables.

CURRENT

The cursor position is not changed, data is returned if a target is specified. If the cursor was positioned on a rowset of more than one row, then the cursor position is on the first row of the rowset.

The following table shows situations in which errors occur with CURRENT.

Current state of the cursor | Result of FETCH CURRENT
Before the first row or after the last row | A warning occurs, values are not last row assigned to host variables.
On a hole | For a SENSITIVE STATIC or a SENSITIVE DYNAMIC cursor, a warning occurs for a delete hole or an update hole, values are not assigned to host variables, and the cursor is positioned on the hole. A hole is detected for a SENSITIVE DYNAMIC cursor when the current row is deleted or updated so that it no longer meets the selection criterion, and a FETCH CURRENT or a FETCH RELATIVE +0 is executed without repositioning the cursor.
Unknown | An error occurs, values are not assigned to host variables, and the cursor position remains unknown.

ABSOLUTE

host-variable or integer-constant is assigned to an integral value k. If a host-variable is specified, it must be an exact numeric type with zero scale and must not include an indicator variable. The possible data types for the host variable are DECIMAL(n,0) or integer. The DECIMAL data type is limited to DECIMAL(18,0). An integer-constant can be up to 31 digits, depending on the application language.

If k=0, the cursor is positioned before the first row of the result table. Otherwise, ABSOLUTE positions the cursor to row k of the result table if k>0, or to k rows from the bottom of the table if k<0. For example, "ABSOLUTE -1" is the same as "LAST".

Data is returned if the specified position is within the rows of the result table, and a target is specified.

If an absolute position is specified that is before the first row or after the last row of the result table, a warning occurs, values are not assigned to host variables, and the cursor is positioned either before the first row or after the last row. If the resulting cursor position is after the last row for INSENSITIVE and SENSITIVE STATIC scrollable cursors, the number of rows of the result table are returned in the SQLERRD1 and SQLERRD2 fields of the SQLCA. If row k of the result table is a hole, a warning occurs and values are not assigned to host variables.

FETCH ABSOLUTE 0 results in positioning before the first row and a warning is issued. FETCH BEFORE results in positioning before the first row and no warning is issued.

The following table shows some synonymous specifications.

Specification | Alternative
ABSOLUTE 0 (but with a warning) | BEFORE (without a warning)
ABSOLUTE +1 | FIRST
ABSOLUTE -1 | LAST
ABSOLUTE -m, 0<m=n | ABSOLUTE n+1-m
ABSOLUTE n | LAST
ABSOLUTE -n | FIRST
ABSOLUTE x (with a warning) | AFTER (without a warning)
ABSOLUTE -x (with a warning) | BEFORE (without a warning)

RELATIVE

host-variable or integer-constant is assigned to an integral value k. If a host-variable is specified, it must be an exact numeric type with zero scale and must not include an indicator variable. The possible data types for the host variable are DECIMAL(n,0) or integer. The DECIMAL data type is limited to DECIMAL(18,0). An integer-constant can be up to 31 digits, depending on the application language.

Data is returned if the specified position is within the rows of the result table, and a target is specified.

RELATIVE positions the cursor to the row in the result table that is either k rows after the current row if k>0, or ABS(k) rows before the current row if k<0. For example, "RELATIVE -1" is the same as "PRIOR". If k=0, the position of the cursor does not change (that is, "RELATIVE 0" is the same as "CURRENT").

If a relative position is specified that results in positioning before the first row or after the last row, a warning is issued, values are not assigned to host variables, and the cursor is positioned either before the first row or after the last row. If the resulting cursor position is after the last row for INSENSITIVE and SENSITIVE STATIC scrollable cursors, the number of rows of the result table is returned in the SQLERRD1 and SQLERRD2 fields of the SQLCA. If the cursor is positioned on a hole and RELATIVE 0 is specified or if the target row is a hole, a warning occurs and values are not assigned to host variables. If the cursor position is unknown and RELATIVE 0 is specified, an error occurs.

The following table shows some synonymous specifications.

Specification | Alternative
RELATIVE +1 | NEXT
RELATIVE -1 | PRIOR
RELATIVE 0 | CURRENT
RELATIVE +r (with a warning) | AFTER (without a warning)
RELATIVE -r (with a warning) | BEFORE (without a warning)

rowset-positioned

Positioning of the cursor with rowset-positioned fetch orientations NEXT ROWSET, PRIOR ROWSET, and ROWSET STARTING AT RELATIVE is done in relation to the current rowset. The number of rows in the rowset is determined either explicitly or implicitly. The FOR n ROWS clause in the multiple-row-fetch clause is used to explicitly specify the size of the rowset. Following a successful rowset-positioned FETCH statement, the cursor is positioned on all rows of the rowset.

A rowset-positioned fetch orientation must not be specified if the current cursor position is not defined to access rowsets. NEXT ROWSET is the only rowset-positioned fetch orientation that can be specified for cursors that are defined as NO SCROLL.

If a row of the rowset reflects a hole, a warning is returned, data values are not assigned to host variable arrays for that row (that is, the corresponding positions in the target host variable arrays are untouched), and -3 is returned in all provided indicator variables for that row. If a hole is detected, and at least one indicator variable is not provided, an error occurs.

NEXT ROWSET

Positions the cursor on the next rowset of the result table relative to the current cursor position, and returns data if a target is specified. The next rowset is logically obtained by fetching the row that follows the current rowset and fetching additional rows until the number of rows that is specified implicitly or explicitly in the FOR n ROWS clause is obtained or the last row of the result table is reached.

If a row of the rowset reflects a hole, the following actions occur:

  • A warning is returned.
  • Data values are not assigned to the host-variable-arrays for that row (that is, the corresponding positions in the target host-variable-arrays are untouched).
  • A value of -3 is returned in all of the indicator variables that are provided for the row.

If a hole is detected and at least one indicator variable is not provided, an error is returned.

If the cursor is not positioned because of a prior error, values are not assigned to the host-variable-array, and an error is returned. If a row of the rowset would be after the last row of the result table, values are not assigned to host-variable-arrays for that row and any subsequent requested rows of the rowset, and a warning is returned.

NEXT ROWSET is the only rowset positioned fetch orientation that can be explicitly be specified for cursors that are defined as NO SCROLL.

PRIOR ROWSET

Positions the cursor on the previous rowset of the result table relative to the current position, and returns data if a target is specified.

The prior rowset is logically obtained by fetching the row that follows the current rowset and fetching additional rows until the number of rows that is specified implicitly or explicitly in the FOR n ROWS clause is obtained or the last row of the result table is reached.

If a row would be before the first row of the result table, the cursor is positioned on a partial rowset that consists of only those rows that are prior to the current position of the cursor starting with the first row of the result table, and a warning is returned. Values are not assigned to the host-variable-arrays for the rows in the rowset for which the warning is returned.

Although the rowset is logically obtained by fetching backwards from before the current rowset, the data is returned to the application starting with the first row of the rowset, to the end of the rowset.

If a row of the rowset reflects a hole, the following actions occur:

  • A warning is returned.
  • Data values are not assigned to the host-variable-arrays for that row (that is, the corresponding positions in the target host-variable-arrays are untouched).
  • A value of -3 is returned in all of the indicator variables that are provided for the row.

If a hole is detected and at least one indicator variable is not provided, an error is returned.

If the cursor is not positioned because of a prior error, values are not assigned to the host-variable-array, and an error is returned.

FIRST ROWSET

Positions the cursor on the first rowset of the result table, and returns data if a target is specified.

If a row of the rowset reflects a hole, the following actions occur:

  • A warning is returned.
  • Data values are not assigned to the host-variable-arrays for that row (that is, the corresponding positions in the target host-variable-arrays are untouched).
  • A value of -3 is returned in all of the indicator variables that are provided for the row.

If a hole is detected and at least one indicator variable is not provided, an error is returned.

If the result table contains fewer rows than specified implicitly or explicitly in the FOR n ROWS clause, values are not assigned to host-variable-arrays after the last row of the result table, and a warning is returned.

LAST ROWSET

Positions the cursor on the last rowset of the result table and returns data if a target is specified. The last rowset is logically obtained by fetching the last row of the result table and fetching prior rows until the number of rows in the rowset is obtained or the first row of the result table is reached. Although the rowset is logically obtained by fetching backwards from the bottom of the result table, the data is returned to the application starting with the first row of the rowset, to the end of the rowset, which is also the end of the result table.

If a row of the rowset reflects a hole, the following actions occur:

  • A warning is returned.
  • Data values are not assigned to the host-variable-arrays for that row (that is, the corresponding positions in the target host-variable-arrays are untouched).
  • A value of -3 is returned in all of the indicator variables that are provided for the row.

If a hole is detected and at least one indicator variable is not provided, an error is returned.

If the result table contains fewer rows than specified implicitly or explicitly in the FOR n ROWS clause, the last rowset is the same as the first rowset, values are not assigned to host-variable-arrays after the last row of the result table, and a warning is returned.

CURRENT ROWSET

If the FOR n ROWS clause specifies a number different from the number of rows specified implicitly or explicitly in the FOR n ROWS clause on the most recent FETCH statement for this cursor, the cursor is repositioned on the specified number of rows, starting with the first row of the current rowset. Otherwise, the position of the cursor on the current rowset is unchanged. Data is returned if a target is specified.

With isolation level UR or a sensitive dynamic scrollable cursor, it is possible that different rows will be returned than the FETCH that established the most recent rowset cursor position. This can occur while refetching the first row of the rowset when it is determined to not be there anymore. In this case, fetching continues moving forward to get the first row of data for the rowset. This can also occur when changes have been made to other rows in the current rowset such that they no longer exist or have been logically moved within (or out of) the result table of the cursor.

If the cursor is not positioned because of a prior error, values are not assigned to the host-variable-array, and an error occurs.

If the current rowset contains fewer rows than specified implicitly or explicitly in the FOR n ROWS clause, values are not assigned to host-variable-arrays after the last row, and a warning is returned.

ROWSET STARTING AT ABSOLUTE or RELATIVE host-variable or integer-constant

Positions the cursor on the rowset beginning at the row of the result table that is indicated by the ABSOLUTE or RELATIVE specification, and returns data if a target is specified.

host-variable or integer-constant is assigned to an integral value k. If host-variable is specified, it must be an exact numeric type with scale zero, and must not include an indicator variable. The possible data types for the host variable are DECIMAL(n,0) or integer, where the DECIMAL data type is limited to DECIMAL(18,0). If a constant is specified, the value must be an integer.

If a row of the result table would be after the last row or before the first row of the result table, values are not assigned to host-variable-arrays for that row and a warning is returned.

ABSOLUTE

If k=0, an error occurs. If k>0, the first row of the rowset is row k. If k<0, the rowset is positioned on the ABS(k) rows from the bottom of the result table. Assume that ABS(k) is equal to the number of rows for the rowset and that there are enough row to return a complete rowset:

  • FETCH ROWSET STARTING AT ABSOLUTE -k is the same as FETCH LAST ROWSET.
  • FETCH ROWSET STARTING AT ABSOLUTE 1 is the same as FETCH FIRST ROWSET.

RELATIVE

If k=0 and the FOR n ROWS clause does not specify a number different from the number most recently specified implicitly or explicitly for this cursor, then the position of the cursor does not change (that is, "RELATIVE ROWSET 0" is the same as "CURRENT ROWSET"). If k=0 and the FOR n ROWS clause specifies a number different from the number most recently specified implicitly or explicitly for this cursor, then the cursor is repositioned on the specified number of rows, starting with the first row of the current rowset. Otherwise, RELATIVE repositions the cursor so that the first row of the new rowset cursor position is on the row in the result table that is either k rows after the first row of the current rowset cursor position if k>0, or ABS(k) rows before the first row of the current rowset cursor position if k<0. Assume that ABS(k) is equal to the number of rows for the resulting rowset

  • FETCH ROWSET STARTING AT RELATIVE -k is the same as FETCH PRIOR ROWSET.
  • FETCH ROWSET STARTING AT RELATIVE k is the same as FETCH NEXT ROWSET.
  • FETCH ROWSET STARTING AT RELATIVE 0 is the same as FETCH CURRENT ROWSET.

When ROWSET STARTING AT RELATIVE -n is specified and there are not enough rows between the current position of the cursor and the beginning of the result table to return a complete rowset:

  • A warning is returned.
  • Values are not assigned to the host-variable-arrays.
  • The cursor position remains unchanged.

If a row of the rowset reflects a hole, If a row of the rowset reflects a hole, the following actions occur:

  • A warning is returned.
  • Data values are not assigned to the host-variable-arrays for that row (that is, the corresponding positions in the target host-variable-arrays are untouched).
  • A value of -3 is returned in all of the indicator variables that are provided for the row.

If a hole is detected and at least one indicator variable is not provided, an error is returned. If a row of the rowset is unknown, values are not assigned to host variable arrays for that row, and an error is returned. If a row of the rowset would be after the last row or before the first row of the result table, values are not assigned to host-variable-arrays for that row, and a warning is returned.

cursor-name

Identifies the cursor to be used in the fetch operation. The cursor name must identify a declared cursor, as explained in the description of the DECLARE CURSOR statement in "DECLARE CURSOR" in topic 5.42, or an allocated cursor, as explained in "ALLOCATE CURSOR" in topic 5.2. When the FETCH statement is executed, the cursor must be in the open state.

If a single-row-fetch or multiple-row-fetch clause is not specified, the cursor position is adjusted as specified, but no data is returned to the user.

single-row-fetch

When single-row-fetch is specified, SENSITIVE or INSENSITIVE can be specified though there is a default. The default depends on the sensitivity of the cursor. If the sensitivity of the cursor is INSENSITIVE, then the default is INSENSITIVE. If the effective sensitivity of the cursor is SENSITIVE DYNAMIC or SENSITIVE STATIC, then the default is SENSITIVE. The single-row-fetch or multiple-row-fetch clause must not be specified when the FETCH BEFORE or FETCH AFTER option is specified. They are required when FETCH BEFORE or FETCH AFTER is not specified. If an individual fetch operation causes the cursor to be positioned or to remain positioned on a row if there is a target specification, the values of the result table are assigned to host variables as specified by the single-fetch-clause.

INTO host-variable,...

Specifies a list of host variables. Each host-variable must identify a structure or variable that is described in the application program in accordance with the rules for declaring host structures and variables. A reference to a structure is replaced by a reference to each of its variables. The first value in the result row is assigned to the first host variable, the second value to the second host variable, and so on.

INTO DESCRIPTOR descriptor-name

Identifies an SQLDA that contains a valid description of the host output variables. Result values from the associated SELECT statement are returned to the application program in the output host variables.

Before the FETCH statement is processed, you must set the following fields in the SQLDA:

  • SQLN to indicate the number of SQLVAR occurrences provided in the SQLDA

    A REXX SQLDA does not contain this field.

  • SQLABC to indicate the number of bytes of storage allocated in the SQLDA
  • SQLD to indicate the number of variables used in the SQLDA when processing the statement
  • SQLVAR occurrences to indicate the attributes of the variables

The SQLDA must have enough storage to contain all SQLVAR occurrences. Each SQLVAR occurrence describes a host variable or buffer into which a value in the result table is to be assigned. If LOBs are present in the results, there must be additional SQLVAR entries for each column of the result table. If the result table contains only base types and distinct types, multiple SQLVAR entries are not needed for each column. However, extra SQLVAR entries are needed for distinct types as well as for LOBs in DESCRIBE and PREPARE INTO statements.

SQLD must be set to a value greater than or equal to zero and less than or equal to SQLN.

multiple-row-fetch

Retrieves multiple rows of data from the result table of a query. The FOR n ROWS clause of the FETCH statement controls how many rows are returned on a single FETCH statement. The fetch orientation determines whether the resulting cursor position (for example, on a single row, rowset, before, or after the result table). Fetching stops when an error is returned, all requested rows are fetched, or the end of data condition is reached.

Fetching multiple rows of data can be done with scrollable or non-scrollable cursors. The operations used to define, open, and close a cursor used for fetching multiple rows of data are the same as for those used for single row FETCH statements.

If the BEFORE or AFTER option is specified, neither single-row-fetch or multiple-row-fetch can be specified.

FOR host-variable or integer-constant ROWS

host-variable or integer-constant is assigned to an integral value k. If a host variable is specified, it must be an exact numeric type with a scale of zero and must not include an indicator variable. Furthermore, k must be in the range, 0<k<=32767.

This clause must not be specified if a row-positioned fetch-orientation clause was specified. This clause must also not be specified for a cursor that is defined without rowset access.

If a rowset fetch orientation is specified and this clause is not specified, the number of rows in the resulting rowset is determined as follows:

  • If the most recent FETCH statement for this cursor was a rowset-positioned FETCH, the number of rows of the rowset is implicitly determined by the number of rows that was most recently specified (implicitly or explicitly) for this cursor.
  • When the most recent FETCH statement for this cursor was either FETCH BEFORE or FETCH AFTER and the most recent FETCH statement for this cursor prior to that was a rowset-positioned FETCH, the number of rows of the rowset is implicitly determined by the number of rows that were most recently specified (implicitly or explicitly) for this cursor.
  • Otherwise, the rowset consists of a single row.

For result set cursors, the number of rows for a rowset cursor position, established in the procedure that defined the rowset, is not inherited by the caller when the rowset is returned. Use the FOR n ROWS clause on the first rowset FETCH statement for the result set in the calling program to establish the number of rows for the cursor. Otherwise, the rowset consists of a single row.

The cursor is positioned on the row or rowset that is specified by the orientation clause (for example, NEXT ROWSET), and those rows are fetched if a target is specified. After the cursor is positioned on the first row being fetched, the next k-1 rows are fetched. Fetching moves forward from the cursor position in the result table and continues until the end of data condition is returned, k-1 rows have been fetched, or an assignment error is returned.

The resulting cursor position depends on the fetch orientation that is specified:

  • For a row-positioned fetch orientation, the cursor is positioned at the last row successfully retrieved.
  • For a rowset-positioned fetch orientation, the cursor is positioned on all the rows retrieved.

The values from each individual fetch are placed in data areas that are described in the INTO or USING clause. If a target specification is provided for a rowset-positioned FETCH, the host variable arrays must be specified as the target specification, and the arrays must be defined with a dimension of 1 or greater. The target specification must be defined as an array for a rowset-positioned FETCH even if the number of rows that is specified implicitly or explicitly is one.

INTO host-variable-array

Identifies for each column of the result table a host-variable-array to receive the data that is retrieved with this FETCH statement. If the number of host-variable-arrays is less than the number of columns of the result table, the SQLWARN3 field of the SQLCA is set to 'W'. No warning is given if there are more host-variable-arrays than the number of columns in the result table.

Each host-variable-array must be defined in the application program in accordance with the rules for declaring an array. A host-variable-array is used to return the values for a column of the result table. The number of rows to be fetched must be less than or equal to the dimension of each of the host-variable-arrays.

An optional indicator array can be specified for a host-variable-array. It should be specified if the SQLTYPE of any SQLVAR occurrence indicates that the column of the result table is nullable. Additionally, if an operation may result in null values, such as an UPDATE operation that results in a hole, is performed in the application, an indicator array should be specified. Otherwise an error occurs if null values are encountered. The indicators are returned as small integers.

INTO DESCRIPTOR descriptor-name

Identifies an SQLDA that must contain a valid description of zero or more host-variable-arrays or buffers into which the values for a column of the result table are to be returned.

Before the FETCH statement is processed, you must set the following fields in the SQLDA:

  • SQLN to indicate the number of SQLVAR occurrences provided in the SQLDA.
  • SQLABC to indicate the number of bytes of storage allocated for the SQLDA.
  • SQLD to indicate the number of variables used in the SQLDA when processing the statement.
  • SQLVAR occurrences to indicate the attributes of an element of the host-variable-array. Within each SQLVAR representing an array:
    • SQLTYPE indicates the data type of the elements of the host-variable-array.
    • SQLDATA field points to the first element of the host-variable-array.
    • The length fields (SQLLEN and SQLLONGLEN) are set to indicate the maximum length of a single element of the array.
    • SQLNAME - The length of SQLNAME must be set to 8, and the first two bytes of the data portion of SQLNAME must be initialized to X'0000'. The fifth and sixth bytes must contain a flag field and the seventh and eighth bytes must be initialized to a binary small integer (half word) representation of the dimension of the host-variable-array, and the corresponding indicator array, if one is specified.

The SQLVAR entry for the number of rows must also contain a flag value. The number of rows to be fetched must be less than or equal to the dimension of each of the host variable arrays.

You set the SQLDATA and SQLIND pointers to the beginning of the corresponding arrays. The SQLDA must have enough storage to contain all SQLVAR occurrences. Each SQLVAR occurrence describes a host-variable-array or buffer into which the values for a column in the result table are to be returned. If any column of the result table is a LOB, two SQLVAR entries must be provided for each SQLVAR, and SQLN must be set to two times the number of SQLVARS. SQLD must be set to a value greater than or equal to zero and less than or equal to SQLN.

Example:

The host-variables parameter identifies a list of COBOL variables defined in working storage. The following is an example of a FETCH statement. We assume that custbl is a cursor previously defined in a DECLARE CURSOR statement.

EXEC SQL
    FETCH custbl
    INTO :CNO, :CNAME
END-EXEC
Parent topic: SQL Statements


FREE LOCATOR

The XDB Server operating environment does not provide support for FREE LOCATOR at this time.

Invocation

This statement can only be embedded in an application program. It cannot be issued interactively. It is an executable statement that can be dynamically prepared. However, the EXECUTE statement with the USING clause must be used to execute the prepared statement. FREE LOCATOR cannot be used with the EXECUTE IMMEDIATE statement.

Authorization

None required.

Syntax

FREE LOCATOR {host-variable}

Description

host-variable,...

Identifies a host-variable locator variable that must have been previously declared according to the rules for declaring host-variable locator variables. The locator variable type must be a binary large object locator, a character large object locator, or a double-byte character large object locator.

After the FREE LOCATOR statement is executed, each locator variable in the host-variable list is no longer associated with the string value it represented.

If a locator variable is not an established locator within the current unit of work, an invalid locator error occurs. When this error occurs and more than one host variable was specified in the FREE LOCATOR statement, only the locators up to the first invalid locator are freed. Locators listed after the first invalid locator are not freed.

Example:

Assume that the employee table contains columns RESUME, HISTORY, and PICTURE and that locators have been established in a program to represent the column values. Free the CLOB locator variables LOCRES and LOCHIST, and the BLOB locator variable LOCPIC.

EXEC SQL FREE LOCATOR :LOCRES, :LOCHIST, :LOCPIC
Parent topic: SQL Statements


GET DIAGNOSTICS

Invocation

This statement can only be embedded in an application program. It is an executable statement that cannot be dynamically prepared.

Authorization

None required.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

GET DIAGNOSTICS {statement-information | condition-information | combined-information}

statement-information:

{host-variable1 = statement-information-item-name | host-variable1 = DB2_GET_DIAGNOSTICS_DIAGNOSTICS} [,...]

statement-information-item-name:

{DB2_LAST_ROW | DB2_NUMBER_PARAMETER_MARKERS | DB2_NUMBER_RESULT_SETS |
        DB2_RETURN_STATUS | DB2_SQL_ATTR_CURSOR_HOLD |
        DB2_SQL_ATTR_CURSOR_ROWSET | DB2_SQL_ATTR_CURSOR_SCROLLABLE |
        DB2_SQL_ATTR_CURSOR_SENSITIVITY | DB2_SQL_ATTR_CURSOR_TYPE |
        MORE | NUMBER | ROW_COUNT} [,...]

condition-information:

CONDITION {host-variable2 | integer}
       {host-variable3 = {condition-information-item-name | connection-information-item-name}} [,...]

condition-information-item-name:

{CATALOG_NAME | CONDITION_NUMBER | CURSOR_NAME | DB2_ERROR_CODE1 |
DB2_ERROR_CODE2 | DB2_ERROR_CODE3 | DB2_ERROR_CODE4 | DB2_INTERNAL_ERROR_POINTER |
DB2_MESSAGE_ID | DB2_MODULE_DETECTING_ERROR | DB2_ORDINAL_TOKEN_n | DB2_REASON_CODE |
DB2_RETURNED_SQLCODE | DB2_ROW_NUMBER | DB2_SQLERRD_SET | DB2_SQLERRD1 | DB2_SQLERRD2 |
DB2_SQLERRD3 | DB2_SQLERRD4 | DB2_SQLERRD5 | DB2_SQLERRD6 | DB2_TOKEN_COUNT | MESSAGE_TEXT |
RETURNED_SQLSTATE | SERVER_NAME}

connection-information-item-name:

{DB2_AUTHENTICATION_TYPE | DB2_AUTHORIZATION_ID | DB2_CONNECTION_STATE |
DB2_CONNECTION_STATUS | DB2_ENCRYPTION_TYPE | DB2_SERVER_CLASS_NAME | DB2_PRODUCT_ID}

combined-information:

host-variable4 = ALL {STATEMENT | {CONDITION | CONNECTION} [host-variable5 | integer]} [,...]
Note:
  • STATEMENT can only be specified once.
  • CONDITION and CONNECTION can only be specified once if host-variable5 or integer is not also specified.

Description

Diagnostic information is provided in three main areas: statement information, condition information, and combined information. After the execution of an SQL statement, information about the execution of the statement is provided as statement information, and at least one instance of condition information is provided. The number of instances of the condition information is indicated by the NUMBER item that is available in the statement information. Combined information contains a text representation of all the information gathered about the execution of the SQL statement.

The diagnostic information that is provided is specific to the server. If you are connected to a server other than DB2 UDB for z/OS, see that product's documentation for the diagnostic information that is returned.

statement-information

Provides information about the last SQL statement executed.

host-variable1

Identifies a variable described in the program in accordance with the rules for declaring host variables. The data type of the host variable must be the data type as specified in Data types for GET DIAGNOSTICS items.

The host variable is assigned the value of the specified statement information item. If the value is truncated when assigning it to the host variable, a warning is returned and the GET_DIAGNOSTICS_DIAGNOSTICS item of the diagnostics area is updated with the details of this condition. If a DIAGNOSTICS item is not set, then the host variable is set to a default value, based on its data type: 0 for an exact numeric field, an empty string for a VARCHAR field, and blanks for a CHAR field.

DB2_GET_DIAGNOSTICS_DIAGNOSTICS

Contains textual information about errors or warnings that may have occurred in the execution of the GET DIAGNOSTICS statement. The format of the information is similar to what would be returned by a GET DIAGNOSTICS :hv = ALL statement.

statement-information-item-name:

DB2_LAST_ROW

For a multiple-row FETCH statement, contains a value of +100 if the last row currently in the table is in the set of rows that have been fetched. For cursors that are not sensitive to updates, there would be no need to do a subsequent FETCH, because the result would be an end-of-data indication. For cursors that are sensitive to updates, a subsequent FETCH may return more data if a row had been inserted before the FETCH was executed. For statements other than multiple-row FETCH statements, or for multiple-row FETCH statements that do not contain the last row, this variable contains the value 0.

DB2_NUMBER_PARAMETER_MARKERS

For a PREPARE statement, contains the number of parameter markers in the prepared statement. Otherwise, or if the server only returns an SQLCA, the value zero is returned.

DB2_NUMBER_RESULT_SETS

For a CALL statement, contains the actual number of result sets returned by the procedure. Otherwise, or if the server only returns an SQLCA, the value zero is returned.

DB2_NUMBER_ROWS

If the previous SQL statement was an OPEN or a FETCH that caused the size of the result table to be unknown, returns the number of rows in the result table. For SENSITIVE DYNAMIC cursors, this value can be thought of as an approximation because rows that are inserted and deleted will affect the next retrieval of this value. If the previous SQL statement was a PREPARE statement, returns the estimated number of rows in the result table for the prepared statement. Otherwise, or if the server only returns an SQLCA, the value zero is returned.

DB2_RETURN_STATUS

Identifies the status value returned from the stored procedure associated with the previously executed SQL statement, provided that the statement was a CALL statement that invoked a procedure that returns a status. . Otherwise, or if the server only returns an SQLCA, the value zero is returned.

DB2_SQL_ATTR_CURSOR_HOLD

For an ALLOCATE or OPEN statement, indicates whether a cursor can be held open across multiple units of work.

  • N indicates that this cursor does not remain open across multiple units of work.
  • Y indicates that this cursor remains open across multiple units of work.

Otherwise, a blank is returned.

DB2_SQL_ATTR_CURSOR_ROWSET

For an ALLOCATE or OPEN statement, indicates whether or not a cursor can be accesses using rowset positioning.

  • N indicates that this cursor supports only row positioned operations.
  • Y indicates that this cursor supports rowset positioned operations.

Otherwise, a blank is returned.

DB2_SQL_ATTR_CURSOR_SCROLLABLE

For an ALLOCATE or OPEN statement, indicates whether or not a cursor can be scrolled forward and backward.

  • N indicates that this cursor is not scrollable.
  • Y indicates that this cursor is scrollable.

Otherwise, a blank is returned.

DB2_SQL_ATTR_CURSOR_SENSITIVITY

For an ALLOCATE or OPEN statement, indicates whether or not a cursor does or does not show updates to cursor rows made by other connections.

  • I indicates insensitive.
  • S indicates sensitive.

Otherwise, a blank is returned.

DB2_SQL_ATTR_CURSOR_TYPE

For an ALLOCATE or OPEN statement, indicates the type of cursor, whether a cursor type is forward-only, static, or dynamic.

  • F indicates a forward cursor.
  • D indicates a dynamic cursor.
  • S indicates a static cursor.

Otherwise, a blank is returned.

MORE

Indicates whether some of the warning and errors from the previous SQL statement were stored or discarded.

  • N indicates that all the warnings and errors from the previous SQL statement are stored in the diagnostic area.
  • Y indicates that some of the warnings and errors from the previous SQL statement were discarded because the amount of storage needed to record warnings and errors exceeded 65535 bytes.

NUMBER

Returns the number of errors and warnings detected by the execution of the previous SQL statement, other than a GET DIAGNOSTICS statement, that have been stored in the diagnostics area. If the previous SQL statement returned an SQLSTATE of 00000 or no previous SQL statement has been executed, the number returned is one.

The GET DIAGNOSTICS statement itself may return information via the SQLSTATE parameter, but does not modify the previous contents of the diagnostics area, except for the DB2_GET_DIAGNOSTICS_DIAGNOSTICS item.

ROW_COUNT

Identifies the number of rows associated with the previous SQL statement that was executed.

If the previous SQL statement is a DELETE, INSERT, or UPDATE statement, ROW_COUNT identifies the number of rows deleted, inserted, or updated by that statement, excluding rows affected by either triggers or referential integrity constraints.

If the previous SQL statement is a multiple-row FETCH, ROW_COUNT identifies the number of rows fetched.

A value of -1 indicates a mass delete from a table in a segmented table space.

Otherwise, or if the server only returns an SQLCA, the value zero is returned.

condition-information

Assigns the values of the specified condition information to the associated host variables. The host variable specified must be of the data type that is compatible with the data type of the specified diagnostic-ID or an error occurs. If the value of the condition is truncated when assigning it to the host variable, an error occurs. If an indicator variable was provided, the length of the value is returned in the indicator variable.

If a DIAGNOSTICS item is not set, then the host variable is set to a default value, based on the data type of the item. The specific value will be 0 for a numeric field, an empty string for a VARCHAR field, and blanks for a CHAR field.

host-variable2 or integer

Identifies the diagnostic for which information is requested. Each diagnostic that occurs while executing an SQL statement is assigned an integer. The value 1 indicates the first diagnostic, 2 indicates the second diagnostic, and so on. If the value is 1, the diagnostic information that is retrieved corresponds to the condition that is indicated by the SQLSTATE value actually returned by the execution of the previous SQL statement (other than a GET DIAGNOSTICS statement). The host variable specified must be a numeric data type or an error occurs. An indicator variable is not allowed for this host variable. If a value is specified that is less than or equal to zero or greater than the number of available diagnostics, an error occurs.

host-variable3

Identifies a variable described in the program in accordance with the rules for declaring host variables. The data type of the host variable must be the data type as specified in Data types for GET DIAGNOSTICS items for the indicated condition-information item.

condition-information-item-name:

CATALOG_NAME

If the returned SQLSTATE is any one of the following values, the constraint that caused the error is a referential, check, or unique constraint. The location (RDB) name of the server that generated the condition is returned.

  • Class 09 (Triggered Action Exception)
  • Class 23 (Integrity Constraint Violation)
  • Class 27 (Triggered Data Change Violation)
  • 40002 (Transaction Rollback - Integrity Constraint Violation)
  • 40004 (Transaction Rollback - Triggered Action Exception)

If the returned SQLSTATE is class 42 (Syntax Error or Access Rule Violation), the server name of the table that caused the error is returned.

If the returned SQLSTATE is class 44 (WITH CHECK OPTION Violation), the server name of the view that caused the error is returned.

Otherwise, the empty string is returned.

The actual server name may be different than the server name specified, either implicitly or explicitly, on the CONNECT statement because of the use of aliases or synonyms.

CONDITION_NUMBER

Returns the number of the diagnostic returned.

CURSOR_NAME

If the returned SQLSTATE is class 24 (Invalid Cursor State), the name of the cursor is returned. Otherwise, the empty string is returned.

DB2_ERROR_CODE1

Returns an internal error code (SQLERRD1). Otherwise, or if the server only returns an SQLCA, the value 0 is returned.

DB2_ERROR_CODE2

Returns an internal error code (SQLERRD2). Otherwise, or if the server only returns an SQLCA, the value 0 is returned.

DB2_ERROR_CODE3

Returns an internal error code (SQLERRD3). Otherwise, or if the server only returns an SQLCA, the value 0 is returned.

DB2_ERROR_CODE4

Returns an internal error code (SQLERRD4). Otherwise, or if the server only returns an SQLCA, the value 0 is returned.

DB2_INTERNAL_ERROR_POINTER

For some errors, this is a negative value that is an internal error pointer. Otherwise, the value 0 is returned.

DB2_MESSAGE_ID

Corresponds to the message that is contained in the MESSAGE_TEXT diagnostic item (for example, DSNT102I or DSNU180I).

DB2_MODULE_DETECTING_ERROR

Returns an identifier indicating which module detected the error. For a SIGNAL statement that is issued from a routine, the value 'ROUTINE' is returned. Otherwise, the string 'DSN ' is returned.

DB2_ORDINAL_TOKEN_n

Returns the nth token. n must be a value from 1 to 100. For example, DB2_ORDINAL_TOKEN_1 would return the value of the first token, DB2_ORDINAL_TOKEN_2 the second token, and so on. A numeric value for a token is converted to characters before being returned. If there is no value for the token, or if the server only returns an SQLCA, an empty string is returned.

DB2_REASON_CODE

Contains the reason code for errors that have a reason code token in the message text. Otherwise, the value zero is returned.

DB2_RETURNED_SQLCODE

Returns the SQLCODE for the specified diagnostic.

DB2_ROW_NUMBER

Returns the number of the row where the condition was encountered, when such information is available and applicable.

DB2_SQLERRD_SET

A value of Y indicates that the DB2_SQLERRD1 through DB2_SQLERRD items might be set. These items are set only when communicating with a server that returns the SQLCA SQL communications area and not the new diagnositics area. Otherwise, a blank is returned.

DB2_SQLERRD1

Returns the value of sqlerrd(1) from the SQLCA that is returned by the server. Otherwise, the value zero is returned.

DB2_SQLERRD2

Returns the value of sqlerrd(2) from the SQLCA that is returned by the server. Otherwise, the value zero is returned.

DB2_SQLERRD3

Returns the value of sqlerrd(3) from the SQLCA that is returned by the server. Otherwise, the value zero is returned.

DB2_SQLERRD4

Returns the value of sqlerrd(4) from the SQLCA that is returned by the server. Otherwise, the value zero is returned.

DB2_SQLERRD5

Returns the value of sqlerrd(5) from the SQLCA that is returned by the server. Otherwise, the value zero is returned.

DB2_SQLERRD6

Returns the value of sqlerrd(6) from the SQLCA that is returned by the server. Otherwise, the value zero is returned.

DB2_TOKEN_COUNT

Returns the number of tokens available for the specified diagnostic ID.

MESSAGE_TEXT

Returns the message text that is associated with the SQLCODE. This is the short text, including substituted tokens. The message text does not contain the message number.

RETURNED_SQLSTATE

Returns the SQLSTATE for the specified diagnostic.

SERVER_NAME

If the previous SQL statement is a CONNECT, DISCONNECT, or SET CONNECTION statement, returns the name of the server specified in the previous statement is returned. Otherwise, the name of the server where the statement executes is returned.

connection-information-item-name

Provides information about the last SQL statement executed if it was a CONNECT statement.

DB2_AUTHENTICATION_TYPE

Contains an authentication type value of:

  • 'S' for a server authentication
  • 'C' for client authentication
  • Otherwise, or if the server only returns an SQLCA, a blank is returned

DB2_AUTHORIZATION_ID

Authorization ID used by connected server. Because of user ID translation and authorization exits, the local user ID may not be the authorized ID used by the server.

DB2_CONNECTION_STATE

Contains the connection state:

  • -1 if the connection is unconnected
  • 1 if the connection is connected

Otherwise, or if the server only returns an SQLCA, the value zero is returned.

DB2_CONNECTION_STATUS

Contains a value of:

  • 1 if committable updates can be performed on the connection for this unit of work
  • 2 if no committable updates can be performed on the connection for this unit of work

Otherwise, or if the server only returns an SQLCA, the value zero is returned.

DB2_SERVER_CLASS_NAME

For a CONNECT or SET CONNECTION statement, contains one of the following values:

  • QAS for DB2 UDB for iSeries(TM)
  • QDB2 for DB2 UDB for OS/390 and z/OS
  • QDB2/2 for DB2 UDB for OS/2
  • QDB2/6000 for DB2 UDB for AIX
  • QDB2/6000 PE for DB2 UDB for AIX Parallel Edition
  • QDB2/AIX64 for DB2 UDB for AIX 64-bit
  • QDB2/HPUX for DB2 UDB for HP-UX
  • QDB2/HP64 for DB2 UDB for HP-UX 64-bit
  • QDB2/LINUX for DB2 UDB for Linux
  • QDB2/LINUX390 for DB2 UDB for Linux
  • QDB2/LINUXIA64 for DB2 UDB for Linux
  • QDB2/LINUXPPC for DB2 UDB for Linux
  • QDB2/LINUXPPC64 for DB2 UDB for Linux
  • QDB2/LINUXZ64 for DB2 UDB for Linux
  • QDB2/NT for DB2 UDB for NT
  • QDB2/NT64 for DB2 UDB for NT 64-bit
  • QDB2/PTX for DB2 UDB for NUMA-Q
  • QDB2/SCO for DB2 UDB for SCO UnixWare
  • QDB2/SGI for DB2 UDB for Silicon Graphics
  • QDB2/SNI for DB2 UDB for Siemens Nixdorf
  • QDB2/SUN for DB2 UDB for SUN Solaris
  • QDB2/SUN64 for DB2 UDB for SUN Solaris 64-bit
  • QDB2/Windows 95 for DB2 UDB for Windows 95 or Windows 98
  • QSQLDS/VM for DB2 for VM and VSE
  • QSQLDS/VSE for DB2 for VM and VSE

Otherwise, the empty string is returned.

DB2_ENCRYPTION_TYPE

The level of encryption for the connection:

  • A indicates only the authentication tokens (authid and password) are encrypted.
  • D indicates all data is encrypted for the connection.

Otherwise, a blank is returned.

DB2_PRODUCT_ID

Returns a product signature. If the application server is an IBM relational database product, the form is pppvvrrm, where:

  • ppp identifies the product as follows:
    • ARI for DB2 Server for VSE & VM
    • DSN for DB2 UDB for z/OS
    • QSQ for DB2 UDB for iSeries
    • SQL for all other DB2 UDB products
  • vv is a two-digit version identifier such as '08'
  • rr is a two-digit release identifier such as '01'
  • m is a one-digit maintenance level identifier such as '5' (Values 0, 1, 2, 3, and 4 are for maintenance levels in compatibility and enabling-new-function mode. Values 5, 6, 7, 8, and 9 are for maintenance levels in new-function mode.)

For example, if the application server is Version 8 of DB2 UDB for z/OS in new-function mode with the latest maintenance, the value would be 'DSN08015'.

combined-information

Provides a text representation of all the information gathered about the execution of the SQL statement.

ALL

Indicates that all diagnostic items that are set for the last SQL statement executed are to be combined into one string. The format of the string is a semicolon separated list of all of the available diagnostic information in the form:

item-name[(condition-number)]=value-converted-to-character;... as shown in the following example:

NUMBER=1;RETURNED_SQLSTATE=02000;DB2_RETURNED_SQLCODE=+100;

host-variable4

Identifies a variable described in the program in accordance with the rules for declaring host variables. The data type of the host variable must be VARCHAR. If the length of host-variable4 is not sufficient to hold the full returned diagnostic string, the string is truncated, a warning is returned, and the GET_DIAGNOSTICS_DIAGNOSITICS item of the diagnostics area is updated with the details of this condition.

STATEMENT

Indicates that all statement-information-item-name diagnostic items that are set for the last SQL statement executed should be combined into one string. The format is the same as described for the ALL option.

CONDITION

Indicates that all condition-information-item-name diagnostic items that are set for the last SQL statement executed should be combined into one string. If host-variable5 or integer is supplied after CONDITION, the format is the same as described above for the ALL option. If host-variable5 or integer is not supplied, the format includes a condition number entry at the beginning of the information for that condition in the form:

CONDITION_NUMBER=X;item-name=value-converted-to-character;... where X is the number of the condition, as shown in the following example:

CONDITION_NUMBER=1;RETURNED_SQLSTATE=02000;RETURNED_SQLCODE=100;

  CONDITION_NUMBER=2;RETURNED_SQLSTATE=01004;

CONNECTION

Indicates that all connection-information-item-name diagnostic items that are set for the last SQL statement executed should be combined into one string. If host-variable5 or integer is supplied after CONNECTION, the format is the same as described for the ALL option. If host-variable5 or integer is not supplied, then the format includes a condition number entry at the beginning of the information for that condition in the form:

CONNECTION_NUMBER=X;item-name=value-converted-to-character;... where X is the number of the condition, as shown in the following example:

CONNECTION_NUMBER=1;CONNECTION_NAME=SVL1;DB2_PRODUCT_ID=DSN08010;

host-variable5 or integer

Identifies the diagnostic for which ALL CONDITION or ALL CONNECTION information is requested. The host variable specified must be a numeric data type or an error occurs. An indicator variable is not allowed for this host variable or an error occurs. If a value is specified that is less than or equal to zero or greater than the number of available diagnostics, an error occurs.

Note:

The GET DIAGNOSTICS statement does not change the contents of the diagnostics area (SQLCA). If an SQLSTATE or SQLCODE special variable is declared in the SQL procedure, these are set to the SQLSTATE or SQLCODE returned from issuing the GET DIAGNOSTICS statement. The SQLSTATE and SQLCODE values from before the GET DIAGNOSTICS statement was issued are still available in the diagnostics area by issuing a GET DIAGNOSTICS for RETURNED_SQLSTATE and DB2_RETURNED_SQLCODE.

Data types for GET DIAGNOSTICS items

Item | Data Type
Statement Information
DB2_GET_DIAGNOSTICS_DIAGNOSTICS | VARCHAR(32672)
DB2_LAST_ROW | INTEGER
DB2_NUMBER_PARAMETER_MARKERS | INTEGER
DB2_NUMBER_RESULT_SETS | INTEGER
DB2_NUMBER_ROWS | DECIMAL(31,0)
DB2_RETURN_STATUS | INTEGER
DB2_SQL_ATTR_CURSOR_HOLD | CHAR(1)
DB2_SQL_ATTR_CURSOR_ROWSET | CHAR(1)
DB2_SQL_ATTR_CURSOR_SCROLLABLE | CHAR(1)
DB2_SQL_ATTR_CURSOR_SENSITIVITY | CHAR(1)
DB2_SQL_ATTR_CURSOR_TYPE | CHAR(1)
MORE | CHAR(1)
NUMBER | INTEGER
ROW_COUNT | DECIMAL(31,0)
CATALOG NAME | VARCHAR(128)
CONDITION_NUMBER | INTEGER
CURSOR_NAME | VARCHAR(128)
DB2_ERROR_CODE1 | INTEGER
DB2_ERROR_CODE2 | INTEGER
DB2_ERROR_CODE3 | INTEGER
DB2_ERROR_CODE4 | INTEGER
DB2_INTERNAL_ERROR_POINTER | INTEGER
DB2_MESSAGE_ID | CHAR(10)
DB2_MODULE_DETECTING_ERROR | CHAR(8)
DB2_ORDINAL_TOKEN_n | VARCHAR(515)
DB2_REASON_CODE | INTEGER
DB2_RETURNED_SQLCODE | INTEGER
DB2_ROW_NUMBER | DECIMAL(31,0)
DB2_TOKEN_COUNT | INTEGER
MESSAGE_TEXT | VARCHAR(32672)
RETURNED_SQLSTATE | CHAR(5)
SERVER_NAME | VARCHAR(128)
Connection Information
DB2_AUTHENTICATION_TYPE | CHAR(1)
DB2_AUTHORIZATION_ID | VARCHAR(128)
DB2_CONNECTION_STATE | INTEGER
DB2_CONNECTION_STATUS | INTEGER
DB2_ENCRYPTION_TYPE | CHAR(1)
DB2_PRODUCT_ID | VARCHAR(8)
DB2_SERVER_CLASS_NAMED | CHAR(128)
ALL | VARCHAR(32672)
Note:
  • The GET DIAGNOSTICS statement is supported from a DB2 UDB for z/OS Version 8 client, regardless of the level of the server (a DB2 UDB for z/OS Version 7 or a DB2 UDB for Windows Version 7, for example). When connected to servers that do not support the Open Group Version 3 DRDA standard, a subset of diagnostic information is generated based on the returned SQLCA. The condition contains the following information:
    • The DB2_RETURNED_SQLCODE is set based on the SQLCODE.
    • The RETURNED_SQLSTATE is set based on the SQLSTATE.
    • The DB2_GET_DIAGNOSTICS_DIAGNOSTICS item contains the information from the SQLCA that came from the server.

    Only if you are using multi-row fetch or insert is there a need to have the extended diagnostic information that is provided by servers that support the Open Group Version 3 DRDA standard.

  • To provide compatibility with previous releases of DB2 or other products in the DB2 UDB family, DB2 supports the following keywords:
    • RETURN_STATUS as a synonym for DB2_RETURN_STATUS
    • EXCEPTION as a synonym for CONDITION
Parent topic: SQL Statements


GRANT (Database Privileges)

The XDB Server syntactically supports the collection, package, and plan classes of GRANT/REVOKE privilege commands. Also syntactically supported are the use class of GRANT/REVOKE privileges, including the USE OF ALL BUFFERPOOLS clause. Since the XDB Server does not functionally use these types of privileges, they are not detailed in this reference. Users are encouraged to consult their DB2 documentation for information on these four classes of privilege commands.

Invocation

GRANT is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

To grant privileges on an object, users must either possess a specific privilege WITH GRANT OPTION for the object, be the owner of the object, or possess overall SYSADM authority for the location. Users with DBADM authority over a database also possess GRANT option privileges on tables (except for views) within that database, provided DBADM authority was acquired with the GRANT option. When embedded in a host language or dynamically prepared, the GRANT command has access to the same privileges held by the CURRENT SQLID of the application process.

Syntax

This format is used to grant privileges on a specified database. Please note that to grant the CREATETAB privilege, you must also grant CREATETS privileges for that database to the same AuthID. One or more privilege option keywords (separated with commas) may be specified after GRANT, allowing multiple privileges to be granted in one statement.

For a TEMP database, PUBLIC implicitly has the CREATETAB privilege (without GRANT authority) to define declared temporary tables; this privilege is not recorded in the DB2 catalog, and it cannot be revoked.

In every case, the privileges chosen are granted only to the logical database(s) named in the GRANT statement.

GRANT
        [DBADM[, ]]
        [DBCTRL[, ]]
        [DBMAINT[, ]]
        [CREATETAB[, ]]
        [CREATETS[, ]]
        [DROP[, ]]
        [STARTDB[, ]]
        [STATS[, ]]
        [STOPDB[, ]]
    ON DATABASE database-name[,...]
    TO [AuthID][,...][PUBLIC]
    [WITH GRANT OPTION]

Parameters:

DBADM | Database administrator authority.
DBCTRL | Database control authority.
DBMAINT | Database maintenance authority.
CREATETAB | Privilege to create new tables.
CREATETS | Privilege to create new table spaces.
DROP | Privilege to issue the DROP or ALTER DATABASE statements for the designated databases.
STARTDB | Privilege to issue the START DATABASE command.
STOPDB | Privilege to issue the STOP DATABASE command.
Note: The DISPLAYDB, IMAGCOPY, LOAD, RECOVERDB, REORG and REPAIR, and STATS database grant/revoke privileges are specific to the DB2 mainframe environment, and control specific authorities for running mainframe utilities (for example, CHECK, RUNSTATS and QUIESCE). The XDB Server does not functionally support these privileges. However, to maintain maximum compatibility with mainframe DB2 operations, the XDB Server syntactically checks these privileges (if encountered) and updates the appropriate catalog tables.
database-name | Identifies a database on which privileges are to be granted. The grantor must already possess all the privileges specified with the GRANT option, for each database named. Each database named must exist at the current location.
AuthID | Identifies a user authorization ID being granted the privilege(s) specified. The PUBLIC keyword option can be specified along with (or in place of) an AuthID (or a list of AuthIDs), granting privileges to all valid authorization IDs at the current location.

Description

The GRANT command is used to confer system, database, table and view privileges to specified AuthID(s). The XDB Server supports three separate formats for the GRANT command, depending on the type of privilege granted. Database privileges include CREATETAB, DBADM and DROP privileges. Table privileges include ALTER, DELETE, INDEX, INSERT, SELECT, and UPDATE privileges. System privileges that imply other privileges are also characterized as authorities.

The privileges resulting from the execution of a GRANT command statement are recorded as one or more individual grants in the current location system catalog. Each individual grant involves the granting of one privilege by a grantor to one grantee. A grantee can be any AuthID (as recorded in the system catalog for that location), plus the PUBLIC or PUBLIC AT ALL LOCATIONS designations. The status of each privilege granted is recorded in the system catalog for each AuthID.

The same privilege can be granted to a single grantee by several different grantor AuthIDs. The grantee retains the privilege as long as one (or more) of these grants remains recorded in the system catalog. Individual grants (or groups of grants) can be removed from the system catalog by executing REVOKE commands.

WITH GRANT OPTION

If the WITH GRANT OPTION clause is used, the grantee can grant the privileges specified in the GRANT command to other valid AuthIDs. If users attempt to assign GRANT authority to either PUBLIC or PUBLIC AT ALL LOCATIONS, the privileges named in the GRANT command are granted, but without GRANT authority. Specifying WITH GRANT OPTION is valid but unnecessary when granting SYSADM privileges, since whoever is granted this high-level system privilege automatically receives the ability to assign privileges to other AuthIDs.

PUBLIC

Privileges may be granted to a specific set of users by listing their AuthIDs in the TO clause of the GRANT statement. To grant privileges to all system users in the location, use the keyword PUBLIC. To GRANT to all users system-wide, use PUBLIC AT ALL LOCATIONS in the TO clause of the GRANT statement. Users who have not been specifically granted any privileges have only those privileges granted to PUBLIC. When a privilege is granted to PUBLIC, the system continues to maintain the list of user names that have been specifically granted the privilege.

Example:

To grant database administrator (DBADM) authority on the EMPLOYEE database to AuthID usera:

GRANT DBADM
    ON DATABASE employee
    TO usera;
Parent topic: SQL Statements


GRANT (Function or Procedure Privileges)

Syntax

GRANT EXECUTE ON
{   FUNCTION {function-name [(parameter-type[,...])] | * } |
    SPECIFIC FUNCTION specific-name[,...] |
    PROCEDURE {procedure-name[,...] |
    *
}
    TO {authorization-name[,...] | PUBLIC} [WITH GRANT OPTION]

parameter-type:

{data-type [AS LOCATOR]}

data-type:

{built-in-data-type | distinct-type-name}

built-in-data-type:

SMALLINT |
{INTEGER | INT} |
{DECIMAL | DEC | NUMERIC} [integer[,...]] |
{FLOAT [integer] | REAL [PRECISION] | DOUBLE} |
{ {CHARACTER | CHAR} [(integer)] | {CHARACTER | CHAR} VARYING (integer) | VARCHAR (integer) }
    [FOR {SBCS | MIXED | BIT} DATA] [CCSID {EBCDIC | ASCII}] |
{ {CHARACTER | CHAR} LARGE OBJECT | CLOB} [(integer [K|M|G])] }
    [FOR {SBCS | MIXED} DATA] [CCSID {EBCDIC | ASCII}] } |
{BINARY LARGE OBJECT | BLOB} (integer [K|M|G]) |
{GRAPHIC [(integer)] | VARGRAPHIC (integer) | DBCLOB (integer [K|M|G])} [CCSID {EBCDIC | ASCII}] |
{DATE | TIME | TIMESTAMP} |
ROWID

EXECUTE

Grants the privilege to run the identified user-defined function, cast function that was generated for a distinct type, or stored procedure.

FUNCTION or SPECIFIC FUNCTION

Identifies the function on which the privilege is granted. The function must exist at the current server, and it must be a function that was defined with the CREATE FUNCTION statement or a cast function that was generated by a CREATE DISTINCT TYPE statement.

If the function was defined with a table parameter (the LIKE TABLE was specified in the CREATE FUNCTION statement to indicate that one of the input parameters is a transition table), the function signature cannot be used to identify the function. Instead, identify the function with its function name, if unique, or with its specific name.

FUNCTION function-name

Identifies the function by its name. You can identify a function by its name only if there is exactly one function with function name in the schema. If you do not explicitly qualify the function name with a schema name, the function name is implicitly qualified with a schema name according to the following rules:

  • If the statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER option when the plan or package was created or last rebound. If QUALIFIER was not used, the schema name is the owner of the plan or package.
  • If the statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

An * can be specified for a qualified on unqualified function-name. An * (or schema-name.*) indicates that the privilege is granted on all the functions in the schema including those that do not currently exist. Specifying an * does not affect any EXECUTE privileges that are already granted on a function.

FUNCTION function-name (parameter-type,...)

Identifies the function by its function signature, which uniquely identifies the function.

function-name Specifies the name of the function. If you do not explicitly qualify the function name with a schema name, the function name is implicitly qualified with a schema name as described in the preceding description for FUNCTION function-name.
(parameter-type,...) Identifies the number of input parameters of the function and their data types.

The data type of each parameter must match the data type that was specified in the CREATE FUNCTION statement for the parameter in the corresponding position. The number of data types and the logical concatenation of the data types is used to uniquely identify the function.

For data types that have a length, precision, or scale attribute, you can specify a value or use a set of empty parentheses:

  • Empty parentheses indicate that DB2 ignores the attribute when determining whether the data types match.

    FLOAT cannot be specified with empty parentheses because its parameter value indicates different data types (REAL or DOUBLE).

  • If you use a specific value for a length, precision, or scale attribute, the value must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.

    The specific value for FLOAT(n) does not have exactly match the defined value of the source function because 1<=n<= 21 indicates REAL and 22<=n<=53 indicates DOUBLE. Matching is based on whether the data type is REAL or DOUBLE.

  • If length, precision, or scale is not explicitly specified, and empty parentheses are not specified, the default length of the data type is implied. For example:
    • CHAR implies CHAR(1)
    • GRAPHIC implies GRAPHIC(1)
    • DECIMAL implies DECIMAL(5,0)
    • FLOAT implies DOUBLE (length of 8)

    The implicit length must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.

    For data types with a subtype or encoding scheme attribute, specifying the FOR DATA clause or CCSID clause is optional. Omission of either clause indicates that DB2 ignores the attribute when determining whether the data types match. If you specify either clause, it must match the value that was implicitly or explicitly specified in the CREATE FUNCTION statement.

SPECIFIC FUNCTION specific-name

Identifies the function by its specific name.

PROCEDURE procedure-name

Identifies a stored procedure that is defined at the current server. If you do not explicitly qualify the procedure name with a schema name, the procedure name is implicitly qualified with a schema name according to the following rules:

  • If the statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER option when the plan or package was created or last rebound. If QUALIFIER was not used, the schema name is the owner of the plan or package.
  • If the statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

An * can be specified for a qualified or unqualified procedure-name. An * (or schema-name.*) indicates that the privilege is granted on all the stored procedures in the schema including those that do not currently exist. Specifying an * does not affect any EXECUTE privileges that are already granted on a stored procedure.

Example:

Grant the EXECUTE privilege on function CALC_SALARY to user JONES. Assume that there is only one function in the schema with function name CALC_SALARY.

GRANT EXECUTE ON FUNCTION CALC_SALARY TO JONES;

Grant the EXECUTE privilege on procedure VACATION_ACCR to all users at the current server.

GRANT EXECUTE ON PROCEDURE VACATION_ACCR TO PUBLIC;

Grant the EXECUTE privilege on function DEPT_TOTALS to the administrative assistant and give the assistant the ability to grant the EXECUTE privilege on this function to others. The function has the specific name DEPT85_TOT. Assume that the schema has more than one function that is named DEPT_TOTALS.

GRANT EXECUTE ON SPECIFIC FUNCTION DEPT85_TOT TO ADMIN_A
    WITH GRANT OPTION;

Grant the EXECUTE privilege on function NEW_DEPT_HIRES to HR (Human Resources). The function has two input parameters with data types of INTEGER and CHAR(10), respectively. Assume that the schema has more than one function that is named NEW_DEPT_HIRES.

GRANT EXECUTE ON FUNCTION NEW_DEPT_HIRES (INTEGER, CHAR(10))
    TO HR;

You can also code the CHAR(10) data type as CHAR().

Parent topic: SQL Statements
Related information
GRANT (Table or View Privileges)
GRANT (System Privileges)
GRANT (Database Privileges)


GRANT (Table or View Privileges)

The XDB Server syntactically supports the collection, package, and plan classes of GRANT/REVOKE privilege commands. Also syntactically supported are the use class of GRANT/REVOKE privileges, including the USE OF ALL BUFFERPOOLS clause. Since the XDB Server does not functionally use these types of privileges, they are not detailed in this reference. Users are encouraged to consult their DB2 documentation for information on these four classes of privilege commands.

Invocation

GRANT is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

To grant privileges on an object, users must either possess a specific privilege WITH GRANT OPTION for the object, be the owner of the object, or possess overall SYSADM authority for the location. Users with DBADM authority over a database also possess GRANT option privileges on tables (except for views) within that database, provided DBADM authority was acquired with the GRANT option. When embedded in a host language or dynamically prepared, the GRANT command has access to the same privileges held by the CURRENT SQLID of the application process.

Syntax

This format is used to grant privileges on individual tables or views. One or more of the privilege keywords defined below (separated with commas) or the optional keyword(s) ALL [PRIVILEGES] may be specified after GRANT, allowing multiple table privileges to be evoked in one GRANT statement. Does not include ALTER, INDEX, REFERENCES, or TRIGGER for a grant to PUBLIC AT ALL LOCATIONS.

GRANT
{
        [ALTER[, ]]
        [DELETE[, ]]
        [INDEX[, ]]
        [INSERT[, ]]
        [SELECT[, ]]
        [UPDATE [(column-name[,...])]]
        [TRIGGER]
        [REFERENCES [(column-name [,...])]]
        | ALL [PRIVILEGES]
}
    ON [TABLE] {table-name[,...] | view-name[,...]}
    TO [AuthID][,...][PUBLIC [AT ALL LOCATIONS]]
    [WITH GRANT OPTION]

This format is used to grant privileges on individual tables or views. One or more of the privilege keywords defined below (separated with commas) or the optional keyword(s) ALL [PRIVILEGES] may be specified after GRANT, allowing multiple table privileges to be evoked in one GRANT statement. Does not include ALTER, INDEX, REFERENCES, or TRIGGER for a grant to PUBLIC AT ALL LOCATIONS.

GRANT
{
        [ALTER[, ]]
        [DELETE[, ]]
        [INDEX[, ]]
        [INSERT[, ]]
        [SELECT[, ]]
        [UPDATE [(column-name[,...])]]
        [TRIGGER]
        [REFERENCES [(column-name [,...])]]
        | ALL [PRIVILEGES]
}
    ON [TABLE] {table-name[,...] | view-name[,...]}
    TO [AuthID][,...][PUBLIC [AT ALL LOCATIONS]]
    [WITH GRANT OPTION]

Parameters:

ALTER | Privilege to use the ALTER TABLE statement ALTER cannot be granted to PUBLIC AT ALL LOCATIONS. (cannot specify an auxiliary table or view).
DELETE | Privilege to use the DELETE statement.
INDEX | Privilege to use the CREATE INDEX statement (cannot specify a view).
INSERT | Privilege to use the INSERT statement (cannot be granted on an auxiliary table.)
SELECT | Privilege to use the SELECT statement. (cannot be granted on an auxiliary table.)
UPDATE | Privilege to use the UPDATE statement on all columns of the tables named in the ON clause. When followed by (column-name[,...]), the update privilege applies only to the columns specified in parentheses.( must not identify a column of an auxiliary table.)
REFERENCES | Privilege to create/drop a foreign key. (cannot specify an auxiliary table or view).
column-name | Specifies an individual column in a table for which the UPDATE or the REFERENCES privilege is being granted. If you specify a list of columns after the REFERENCES keyword, each column-name must be the unqualified name of a column in a table that is identified in the ON clause.
table-name or view-name | Preceded by the keyword(s) ON [TABLE], identifies a table or view affected.
authID | Identifies a user authorization ID being granted the privilege(s) specified. The optional PUBLIC [AT ALL LOCATIONS] keyword(s) can be specified along with (or in place of) an AuthID (or a list of AuthIDs). The PUBLIC AT ALL LOCATIONS keyword option grants the specified table privileges to all users at every location.
Note:

To grant privileges to all tables (or views) contained within a database, simply grant the privilege to the database.

If the ALL [PRIVILEGES] keywords are specified following GRANT, all table or view privileges (for which the issuer has GRANT authority) are granted for the objects identified in the ON clause.

In every case, the privileges specified are granted only on the tables or views named in the ON [TABLE] clause. Multiple table and/or view names can be listed, provided they are separated by commas. Table privileges may be granted by users possessing DBADM for the database or by the creator of the table or view the privilege is granted on. ALTER or INDEX privileges are not included in a grant to PUBLIC AT ALL LOCATIONS.

For an auxiliary table, only the INDEX privilege can be granted. DELETE, INSERT, SELECT, and UPDATE privileges on the base table that is associated with the auxiliary table extend to the auxiliary table.

Description

The GRANT command is used to confer system, database, table and view privileges to specified AuthID(s). The XDB Server supports three separate formats for the GRANT command, depending on the type of privilege granted. Database privileges include CREATETAB, DBADM and DROP privileges. Table privileges include ALTER, DELETE, INDEX, INSERT, SELECT, and UPDATE privileges. System privileges that imply other privileges are also characterized as authorities.

The privileges resulting from the execution of a GRANT command statement are recorded as one or more individual grants in the current location system catalog. Each individual grant involves the granting of one privilege by a grantor to one grantee. A grantee can be any AuthID (as recorded in the system catalog for that location), plus the PUBLIC or PUBLIC AT ALL LOCATIONS designations. The status of each privilege granted is recorded in the system catalog for each AuthID.

The same privilege can be granted to a single grantee by several different grantor AuthIDs. The grantee retains the privilege as long as one (or more) of these grants remains recorded in the system catalog. Individual grants (or groups of grants) can be removed from the system catalog by executing REVOKE commands.

WITH GRANT OPTION

If the WITH GRANT OPTION clause is used, the grantee can grant the privileges specified in the GRANT command to other valid AuthIDs. If users attempt to assign GRANT authority to either PUBLIC or PUBLIC AT ALL LOCATIONS, the privileges named in the GRANT command are granted, but without GRANT authority. Specifying WITH GRANT OPTION is valid but unnecessary when granting SYSADM privileges, since whoever is granted this high-level system privilege automatically receives the ability to assign privileges to other AuthIDs.

PUBLIC

Privileges may be granted to a specific set of users by listing their AuthIDs in the TO clause of the GRANT statement. To grant privileges to all system users in the location, use the keyword PUBLIC. To GRANT to all users system-wide, use PUBLIC AT ALL LOCATIONS in the TO clause of the GRANT statement. Users who have not been specifically granted any privileges have only those privileges granted to PUBLIC. When a privilege is granted to PUBLIC, the system continues to maintain the list of user names that have been specifically granted the privilege.

Example:

The example below grants authority for the individuals with the AuthIDs userb and userc to update the PART table.

GRANT UPDATE
    ON part
    TO userb, userc

To grant privileges to all users in the location to select, update, insert, and delete records from the PART and SUPPLIER tables, use the command:

GRANT SELECT, UPDATE, INSERT, DELETE
    ON part, supplier
    TO PUBLIC

To grant privileges on a subset of the columns in the EMPLOYEE table to usera, and at the same time give usera the ability to grant the privilege to other users, issue the command:

GRANT UPDATE(address, city, state, zip, phone)
    ON employee
    TO usera
    WITH GRANT OPTION

In this case AuthID usera does not have the ability to update employee number, name, department, or pay rate values.

To grant all privileges on the EMPLOYEE table to AuthID usera:

GRANT ALL
    ON TABLE employee
    TO usera;
Parent topic: SQL Statements
Related information
REVOKE (Table or View Privileges)
GRANT (Database Privileges)
GRANT (System Privileges)
GRANT (Function or Procedure Privileges)


GRANT (Sequence Privileges)

Syntax

GRANT {ALTER | USAGE} [,...] ON SEQUENCE sequence-name [,...]
TO {authorization-name | PUBLIC} [,...] [WITH GRANT OPTION]
Note: The keyword SELECT is an alternative keyword for USAGE.

Description

ALTER

Grants the privilege to alter a sequence or record a comment on a sequence.

USAGE

Grants the USAGE privilege to use a sequence. This privilege is needed when the NEXT VALUE or PREVIOUS VALUE expression is invoked for a sequence name.

SEQUENCE sequence-name

Identifies the sequence. The name, including the implicit or explicit schema qualifier, must uniquely identify an existing sequence at the current server. If no sequence by this name exists in the explicitly or implicitly specified schema, an error occurs. sequence-name must not be the name of an internal sequence object that is generated by the system for an identity column.

TO

Specifies to what authorization IDs the privileges are granted.

authorization-name,...

Lists one or more authorization IDs. The value of CURRENT RULES determines whether you can use the ID of the GRANT statement itself (to grant privileges to yourself). When CURRENT RULES is:

DB2 | You cannot use the ID of the GRANT statement.
STD | You can use the ID of the GRANT statement.

PUBLIC

Grants the privileges to all users at the current server, including database requesters using DRDA access.

PUBLIC AT ALL LOCATIONS

Grants the privileges to all users in the network. Applies to table privileges only, excluding ALTER, INDEX, REFERENCES, and TRIGGER. PUBLIC AT ALL LOCATIONS applies to DB2 private protocol access only.

WITH GRANT OPTION

Allows the named users to grant the privileges to others. Granting an administrative authority with this option allows the user to specifically grant any privilege belonging to that authority. If you omit WITH GRANT OPTION, the named users cannot grant the privileges to others unless they have that authority from some other source. GRANT authority cannot be passed to PUBLIC or to PUBLIC AT ALL LOCATIONS. When WITH GRANT OPTION is used with either of these, a warning is issued, and the named privileges are granted, but without GRANT authority.

Parent topic: SQL Statements


GRANT (System Privileges)

The XDB Server syntactically supports the collection, package, and plan classes of GRANT/REVOKE privilege commands. Also syntactically supported are the use class of GRANT/REVOKE privileges, including the USE OF ALL BUFFERPOOLS clause. Since the XDB Server does not functionally use these types of privileges, they are not detailed in this reference. Users are encouraged to consult their DB2 documentation for information on these four classes of privilege commands.

Invocation

GRANT is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

To grant privileges on an object, users must either possess a specific privilege WITH GRANT OPTION for the object, be the owner of the object, or possess overall SYSADM authority for the location. Users with DBADM authority over a database also possess GRANT option privileges on tables (except for views) within that database, provided DBADM authority was acquired with the GRANT option. When embedded in a host language or dynamically prepared, the GRANT command has access to the same privileges held by the CURRENT SQLID of the application process.

Syntax

This format is used to grant system privileges. In every case, the system privileges specified are granted only to the AuthID(s) specified in the TO clause. One or more of the privilege option keywords defined below (separated with commas) may be specified after GRANT, allowing multiple system privileges to be granted in one GRANT statement.

GRANT
        [CREATEALIAS[, ]]
        [CREATEDBA[, ]]
        [CREATEDBC[, ]]
        [CREATETMTAB[, ]]
        [CREATESG[, ]]
        [SYSADM[, ]]
        [SYSCTRL[, ]]
    TO [AuthID][,...][PUBLIC]
    [WITH GRANT OPTION]

This format is used to grant system privileges. In every case, the system privileges specified are granted only to the AuthID(s) specified in the TO clause. One or more of the privilege option keywords defined below (separated with commas) may be specified after GRANT, allowing multiple system privileges to be granted in one GRANT statement.

GRANT
        [CREATEALIAS[, ]]
        [CREATEDBA[, ]]
        [CREATEDBC[, ]]
        [CREATETMTAB[, ]]
        [CREATESG[, ]]
        [SYSADM[, ]]
        [SYSCTRL[, ]]
    TO [AuthID][,...][PUBLIC]
    [WITH GRANT OPTION]

Parameters:

CREATEALIAS | Privilege to use the CREATE ALIAS statement.
CREATEDBA | Privilege to issue the CREATE DATABASE statement and acquire DBADM authority over those databases.
CREATEDBC | Privilege to issue the CREATE DATABASE statement and acquire DBCTRL authority over those databases.
CREATETMTAB | Privilege to issue the CREATE GLOBAL TEMPORARY TABLE statement.
CREATESG | Privilege to create new storage groups.
SYSADM | Grants system administrator authority for the location, which includes all privileges except for a few reserved for INSTALL authority. These privileges are all grantable, including the SYSADM authority itself.
SYSCTRL | Grants the system control authority for the location, allowing the holder most of the privileges of a system administrator, but excluding privileges to read or change user data.
Note:

The ARCHIVE, BINDADD, BINDAGENT, BSDS, DISPLAY, MONITOR1, MONITOR2, RECOVER, STOPALL, STOSPACE, SYSOPR, and TRACE system privileges are specific to the DB2 mainframe environment, and control specific authorities for running mainframe utilities (for example, CHECK, RUNSTATS and QUIESCE). The XDB Server does not functionally support these privileges. However, to maintain maximum compatibility with mainframe DB2 operations, the XDB Server syntactically checks these privileges (if encountered) and updates the appropriate catalog tables.

AuthID Identifies a user authorization ID being granted the specified privilege(s). The PUBLIC keyword option can be specified along with (or in place of) an AuthID (or a list of AuthIDs), granting privileges to each valid AuthID at the current location.

Description

The GRANT command is used to confer system, database, table and view privileges to specified AuthID(s). The XDB Server supports three separate formats for the GRANT command, depending on the type of privilege granted. Database privileges include CREATETAB, DBADM and DROP privileges. Table privileges include ALTER, DELETE, INDEX, INSERT, SELECT, and UPDATE privileges. System privileges that imply other privileges are also characterized as authorities.

The privileges resulting from the execution of a GRANT command statement are recorded as one or more individual grants in the current location system catalog. Each individual grant involves the granting of one privilege by a grantor to one grantee. A grantee can be any AuthID (as recorded in the system catalog for that location), plus the PUBLIC or PUBLIC AT ALL LOCATIONS designations. The status of each privilege granted is recorded in the system catalog for each AuthID.

The same privilege can be granted to a single grantee by several different grantor AuthIDs. The grantee retains the privilege as long as one (or more) of these grants remains recorded in the system catalog. Individual grants (or groups of grants) can be removed from the system catalog by executing REVOKE commands.

WITH GRANT OPTION

If the WITH GRANT OPTION clause is used, the grantee can grant the privileges specified in the GRANT command to other valid AuthIDs. If users attempt to assign GRANT authority to either PUBLIC or PUBLIC AT ALL LOCATIONS, the privileges named in the GRANT command are granted, but without GRANT authority. Specifying WITH GRANT OPTION is valid but unnecessary when granting SYSADM privileges, since whoever is granted this high-level system privilege automatically receives the ability to assign privileges to other AuthIDs.

PUBLIC

Privileges may be granted to a specific set of users by listing their AuthIDs in the TO clause of the GRANT statement. To grant privileges to all system users in the location, use the keyword PUBLIC. To GRANT to all users system-wide, use PUBLIC AT ALL LOCATIONS in the TO clause of the GRANT statement. Users who have not been specifically granted any privileges have only those privileges granted to PUBLIC. When a privilege is granted to PUBLIC, the system continues to maintain the list of user names that have been specifically granted the privilege.

Example:

The following example grants SYSADM authority for the TUTORIAL location to the individual with the AuthID usera. With SYSADM authority AuthID usera acquires authority to perform all functions on the TUTORIAL location, including authority to grant privileges.

GRANT SYSADM TO usera
Parent topic: SQL Statements


HALT QUERY FROM

Note:

The HALT QUERY FROM command affects only running queries--ones that are literally in process on the XDB Server at the moment the command is issued. It does not cancel queries that are not actively under execution; for example, ones in which the client is simply fetching records from a result table. A query in this state is active, but is not running on the server. To cancel a query in this state, you must terminate it from the client application or force the user off the system using the XDB Server Monitor.

Invocation

This command can be embedded in a host language or executed interactively.

Authorization

Any of the following

  • The owner of the query
  • A super user
  • A user with SYSADM or SYSCTRL privileges

Syntax

HALT QUERY FROM USER user-name

or ...

HALT QUERY FROM node-name

Parameters:

user-name | Is the user ID of the user (or program) that initiated the query. The HALT QUERY FROM USER command cancels all running queries for the specified ID. For example, if three users were each running a query program that logged on to the server using the same ID, all three queries would be canceled. If you need to cancel one specific user's query, use HALT QUERY FROM node-name instead
node-name | Is the name of the node from which the query was issued. To display a list of the active node names, use the XDB Server Monitor or query the Virtual Statistics table (XDBSTAT.USERLIST). Specify the entire name of the node as displayed by the XDB Server Monitor or listed in the Virtual Statistics table, including the :number part of the name
Parent topic: SQL Statements


HOLD LOCATOR

Invocation

This statement can only be embedded in an application program. It cannot be issued interactively. It is an executable statement that can be dynamically prepared. However, the EXECUTE statement with the USING clause must be used to execute the prepared statement. HOLD LOCATOR cannot be used with the EXECUTE IMMEDIATE statement.

Authorization

None required.

Syntax

HOLD LOCATOR {host-variable}

Description:

host_variable,...

Identifies a host-variable locator variable that must have been previously declared according to the rules for declaring host variables. The locator variable type must be a binary large object locator, a character large object locator, or a double-byte character large object locator.

After the HOLD LOCATOR statement is executed, each locator variable in the host-variable list has the hold property. If a locator variable is not an established locator within the current unit of work, an invalid locator error occurs. When this error occurs and more than one host variable was specified in the HOLD LOCATOR statement, only the locators up to the first invalid locator are held. Locators listed after the first invalid locator are not held.

A host-variable LOB locator variable that has the hold property is freed (has its association between it and its value removed) when:

  • The SQL FREE LOCATOR statement is executed for the locator variable.
  • The SQL ROLLBACK statement is executed.
  • The SQL session is terminated.

Example:

Assume that the employee table contains columns RESUME, HISTORY, and PICTURE and that locators have been established in a program to represent the values represented by the columns. Give the CLOB locator variables LOCRES and LOCHIST, and the BLOB locator variable LOCPIC the hold property.

EXEC SQL HOLD LOCATOR :LOCRES, :LOCHIST, :LOCPIC
Parent topic: SQL Statements


INCLUDE

Invocation

INCLUDE can only be embedded in a host language. INCLUDE is not an executable command and cannot be dynamically prepared.

Authorization

No special authorization is needed for INCLUDE.

Syntax

INCLUDE {SQLCA | SQLDA | member-name}

Parameters:

member-name The member name (or file name) can contain any host language source statements or SQL statements, except the INCLUDE statement. In COBOL, the statement "INCLUDE member-name" must not appear anywhere other than the DATA DIVISION or the PROCEDURE DIVISION section. See your XDB Server precompiler documentation for specifics about the member-name parameter.

Description

The INCLUDE statement is used to bring external files (containing either data definitions or segments of program code that must be precompiled) into an application. When precompiled, the INCLUDE statement is replaced by the source statements. The INCLUDE statement must therefore be specified at a point in the application program where the resulting source statements are accepted by the compiler. The INCLUDE statement cannot introduce source statements that themselves contain INCLUDE statements. Depending on the host language used, INCLUDE can also identify SQL communication and descriptor areas.

SQLCA

Indicates an SQL communication area (SQLCA) description is to be included. Do not specify INCLUDE SQLCA more than once in the same application program. See XDB Server SQL Communications Area (SQLCA) for more information about the SQLCA.

SQLDA

Indicates an SQL descriptor area (SQLDA) description is to be included. See XDB Server SQL Descriptor Area (SQLDA) for more information about the SQLDA.

Example:

The file must reside in the directory specified by the environment variable COBCPY (Micro Focus) or SYSLIB (CA-Realia II). The XDB Server precompiler looks for the file extensions .CPY and .CBL if the XDBCPY directive is active. With CA-Realia II, the XDB Server precompiler looks for the .COB extension by default. Consult your XDB Server precompiler documentation for further details.

EXEC SQL
    INCLUDE emprec
END-EXEC
Parent topic: SQL Statements


INSERT

Invocation

INSERT is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

Authority requirements depend on whether the object identified in the statement is a table or view. When rows are inserted into a table, the privileges held by the user must include either the INSERT privilege on the table, ownership of the table, DBADM authority on the database containing the table, or overall SYSADM authority for the location. When rows are inserted into a view, the privileges held by the user must include either the INSERT privilege on the view, or overall SYSADM authority.

Users should be aware that a view owner (unlike a table owner) may not have INSERT authority on the view, since the nature of the view itself could preclude its use for INSERT. Alternatively, the view owner might possess INSERT authority, but be unable to grant it to others. Additionally, if a subselect is specified, the user must possess authority to execute the subselect.

If the INSERT command is prepared at a location other than the current location, the total available privileges include all privileges recorded in the system catalog where the INSERT is executed.

If an expression that refers to a function is specified, the privilege set must include any authority that is necessary to execute the function.

If the statement is embedded in an application program, the privilege set is the privileges that are held by the authorization ID of the owner of the plan or package. If the statement is dynamically prepared, the privilege set is determined by the DYNAMICRULES behavior in effect (run, bind, define, or invoke.)

Syntax

INSERT INTO {table-name | view-name}
    [(column-name [,...])]
    [OVERRIDING USER VALUE]
    {VALUES {{expression | DEFAULT | NULL} | ({expression | DEFAULT | NULL}[,...]) |
    [WITH common-table-expression [,...]] fullselect [isolation-clause] [QUERYNO integer] |
    multiple-row-insert}

isolation-clause

WITH {RR | RS | CS

multiple-row-insert

VALUES {expression | host-variable-array | NULL | DEFAULT |
    ({expression | host-variable-array | NULL | DEFAULT} [,...]})
    [FOR [host-variable | integer-constant] ROWS]
    [ATOMIC | NOT ATOMIC CONTINUE ON SQLEXCEPTION]

Parameters:

table-name or view-name | Preceded by the keyword INTO, identifies the object (table or view) of the INSERT statement. If a view, the view must be updatable, in which case the underlying table is affected. A catalog table (or a view of a catalog table) or an auxiliary table cannot be specified.
column-list | Specifies an optional list of columns into which the data is to be inserted. The column list, if specified, must be enclosed in parentheses, with each column name separated by a comma. If the column list is omitted, all columns in the target table or view are assigned values -- proceeding in order from left to right.
value-list | Preceded by the keyword VALUES, specifies one row of values (composed of constants, host-variables, NULLs, or special-registers) to be inserted into the target table or view. Each host variable named must represent a declared variable or structure, properly described in the application program in accordance with the rules for declaring variables and structures in the host language.
subselect | Indicates a subselect that retrieves data from another table to insert into the table named in the INSERT command. The same table cannot be the base object of both the INSERT command and the subselect (or any subquery of the subselect). An INSERT command cannot include both a subselect statement and a VALUES clause.

Tables referenced in all selects (or subselects) contained in a single INSERT command must be from the same location as the table or view into which data is being inserted. That is, you cannot INSERT into the TUTORIAL location and select from the DEBLOC location.

Invalid:

INSERT INTO tutorial.tutorial.practice
    SELECT * FROM debloc.tutorial.employee
        WHERE e_no IN
            SELECT e_no FROM debloc.debbie.employee
                WHERE st = "MD";

Valid:

INSERT INTO tutorial.tutorial.practice
    SELECT * FROM tutorial.tutorial.employee
        WHERE e_no IN
            SELECT e_no FROM tutorial.debbie.employee
                WHERE st = "MD";

Description

The INSERT command is used to insert one or more record(s) into an existing table. Data inserted with the INSERT command can be specified by the user in the INSERT command or retrieved from other tables using a subselect statement. The INSERT command takes on one of the following two configurations:

  • The INSERT statement using the VALUES keyword inserts a single row into the table or view, using the values provided or referenced.
  • The INSERT statement with a subselect inserts zero or more rows into the table or view, using values retrieved from other tables and/or views by the subselect.

OVERRIDING USER VALUE

Specifies that the value specified in the VALUES clause or produced by a subselect for a column that is defined as GENERATED ALWAYS is ignored. Instead, a system-generated value is inserted, overriding the user-specified value.

Specify OVERRIDING USER VALUE only if the insert involves a column defined as GENERATED ALWAYS, such as a ROWID column or an identity column.

VALUES

The number of individual data items in the VALUES clause must equal the number of items in the column list. The first data item in the value list is inserted in the first column in the column list, the second value in the second column, etc. A value list must be included if a subselect is not specified. The value list must be enclosed in parentheses. Values must be separated from each other by commas. Character strings should appear in quotes (single or double). If the value to be inserted in a column is null, the keyword NULL should appear in the appropriate location in the value list.

expression | Any expression of the type described in "Expressions" in topic 3.19. The expression must not include a column name. If expression is a single host variable, the host variable can identify a structure. Any host variable or structure that is specified must be described in the application program according to the rules for declaring host structures and variables.
DEFAULT | The default value assigned to the column. If the column is a ROWID column or an identity column, DB2 will generate a unique value for the column. You can specify DEFAULT only for columns that have an assigned default value, ROWID columns, and identity columns.
NULL | The null value.

WITH Clause

Overrides the isolation level of the statement using the WITH {RR | CS} clause, specifying the isolation level with which a searched INSERT statement is executed. The WITH clause specifies an isolation level only for the INSERT statement in which it appears. WITH UR only applies to read only operations, and cannot be used in INSERT statements. The WITH clause overrides the default isolation level for the statement in which it appears.

QUERYNO integer

Specifies the number to be used for this SQL statement in EXPLAIN output and trace records. The number is used for the QUERYNO columns of the plan tables for the rows that contain information about this SQL statement.

If the clause is omitted, the number associated with the SQL statement is the statement number assigned during precompilation. Thus, if the application program is changed and then precompiled, that statement number might change.

Using the QUERYNO clause to assign unique numbers to the SQL statements in a program is helpful for simplifying the use of optimization hints for access path selection, if hints are used.

Data Compatibility

If the insert value for a column is a number, the column must be configured as a numeric data type column with the capability of representing the integral part of the inserted number value. If the insert value for a column is a string, the column must be configured either as a string column (with a length greater than or equal to the string length) or a datetime column (if the string represents a date, time, or timestamp).

If a table (or the base table of a view) named in an INSERT statement contains unique indexes, then each row of values inserted into the table must comply with the uniqueness constraints imposed by these indexes. If the table has a check constraint, each row of data must comply with the check condition.

When a view named in an INSERT statement includes a WITH CHECK OPTION clause in its definition, each row inserted into the view must comply with the view as specified in its definition. If the named view contains other views in its definition -- and these views happen to contain WITH CHECK OPTION clauses in their definitions, the row data values inserted must also comply with these other views as specified in their definitions. An INSERT statement might cause triggers to be activated. A trigger might cause other statements to be executed or raise error conditions based on the insert values.

A named view with no WITH CHECK OPTION clause in its definition can allow nonconforming rows to be inserted into the view's base table(s). However, these rows cannot be retrieved again using the view. Additionally, each non-null insert value must conform to any foreign and parent key relationships defined for target tables -- such that a value inserted into a column defined as a foreign key must equal some value in the primary key column of the parent table.

Locking

Unless appropriate locks already exist, one or more exclusive locks are acquired at the execution of a successful INSERT statement. Until a commit or rollback operation releases the locks, only the application process that performed the insert can access the inserted row. If LOBs are not inserted into the row, application processes that are running with uncommitted read can also access the inserted row. The locks can also prevent other application processes from performing operations on the table. However, application processes that are running with uncommitted read can access locked pages and rows.

Example:

An example of the INSERT command is:

INSERT INTO part
    VALUES ("P7", "WHEEL", "WHITE", 2, "ATHENS")

This statement inserts P7, a two pound white wheel made in Athens, into table PART. To perform this operation correctly, you must enter the data in exactly the order it is to appear in the table. If the column list is specified, it determines the insertion sequence.

To insert a NULL (empty) value, enter NULL in the appropriate column location of the INSERT command statement. Any table column can record inserted NULL values, unless a CREATE or ALTER TABLE command originally defined the column as either NOT NULL or NOT NULL WITH DEFAULT. In the later case, NULL values can be inserted, but will not be recorded in the table (the default values for the column data type will be recorded instead). For example, if the weight and color of the part we are about to insert are not known, type:

INSERT INTO part
    VALUES ("P7", "WHEEL", NULL, NULL, "ATHENS")

If a value list is not specified for the INSERT command, a SELECT command must be specified. The order of the columns selected must match the order in the column list specification. However, the number of columns selected does not need to match the number of columns defined in the column list. If the column list has more columns than the SELECT command, the extra columns will be assigned NULL values. If the column list has fewer columns than the SELECT command, the system will use only as many columns as are available.

The columns selected do not need to match the data type of the column list. They must, however, be type compatible. See the ALTER TABLE command for the definition of compatible conversions.

Try the following sequence of commands using the part-supplier database. First enter the command:

CREATE TABLE bluparts(pno CHAR 2, pname CHAR 5)

This creates a new table called BLUPARTS. Next enter the command:

INSERT INTO bluparts
    (pno, pname)
    SELECT pno, pname
        FROM part
        WHERE color = "blue"

Note that because the PART table has a different number of columns than the BLUPARTS table, you should be careful when specifying the columns selected from the PART table to insert into the BLUPARTS table.

Parent topic: SQL Statements


LABEL ON

Invocation

LABEL ON is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

To execute the LABEL ON command, users must possess either DBADM authority on the database, overall SYSADM or SYSCTRL authority for the location, or be the owner of the table, view, or alias affected.

If the statement is embedded in an application program, the privilege set is the privileges that are held by the authorization ID of the owner of the plan or package. If the statement is dynamically prepared, the privilege set is determined by the DYNAMICRULES behavior in effect (run, bind, define, or invoke.)

Syntax

LABEL ON
{
    TABLE {table-name | view-name} |
    ALIAS alias-name |
    COLUMN {table-name.column-name | view-name.column-name}
}
    IS string-constant

Use the following syntax of the LABEL ON command when labeling more than one column per statement.

LABEL ON {table-name | view-name}
    (column-name IS string-constant[,...])

Parameters:

table-name or view-name | Identifies the table or view described by the label (string-constant).
alias-name | Identifies the alias to which the comment (string-constant) applies.
column-name | Preceded with an optional qualifier of [table-name.] or [view-name.], identifies a column to which the comment (string-constant) applies.
string-constant | Preceded by the keyword IS, any character string constant (up to 30 bytes in length) enclosed in quotes.

Description

Choose one of the following object keywords (with corresponding object name) for labeling in the system catalog.

TABLE

Keyword indicating that a table or view is being labeled. The identified object must exist at the current location. The string-constant specified in the LABEL ON command is recorded in the SYSIBM.SYSTABLES catalog table, in the LABEL column of the row describing the table or view. table-name must not identify a declared temporary table.

ALIAS

Keyword indicating that an alias is being labeled. The alias identified must exist at the current location. The string-constant specified in the LABEL ON command is recorded in the SYSIBM.SYSTABLES catalog table, in the LABEL column of the row describing the alias.

COLUMN

Keyword indicating that a column is being labeled. The column identified must belong to a table or view existing at the current location. The string-constant specified in the LABEL ON command is recorded in the SYSIBM.SYSCOLUMNS catalog table -- in the LABEL column of the row describing the column. The column name must not identify a column of a declared temporary table.

Parent topic: SQL Statements


LOCK TABLE

Invocation

LOCK TABLE is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

To execute the LOCK TABLE command, users must either possess DBADM authority on the database, overall SYSADM or SYSCTRL authority for the location, SELECT privilege on the table identified, or be the owner of the table.

If the statement is embedded in an application program, the privilege set is the privileges that are held by the authorization ID of the owner of the plan or package. If the statement is dynamically prepared, the privilege set is determined by the DYNAMICRULES behavior in effect (run, bind, define, or invoke.)

Syntax

Bold text indicates clauses or options that are supported only syntactically.

LOCK TABLE table-name [PARTITION integer]
    IN {SHARE | EXCLUSIVE} MODE

Parameters:

table-name Identifies the table to be locked. The table must exist at the current server, and cannot be a view, temporary table (created or declared) or system catalog table.

Description

Locking is effective in multi-user environments only. However, the command is accepted in single-user environments, so that you can run your applications unchanged in either environment. The XDB Server automatically acquires record level locks as required during processing, so it is not necessary to acquire table level locks. However, table level locks may reduce the amount of time required to process large numbers of records in the same table. Two table locking modes are supported: exclusive and shared. All types of locks are released by a ROLLBACK or COMMIT command. For more information about the use of locks, see the Server Administration Guide.

IN EXCLUSIVE MODE

The keyword EXCLUSIVE is used to acquire an exclusive lock on an existing table, usually when the intent of the transaction is to modify a number of records in the table. Until the lock is released, it prevents concurrent processes from executing any operations on the table. However, unless the lock is on a LOB table space, concurrent processes that are running at an isolation level of uncommitted read (UR) can execute read-only operations on the table.

When an exclusive table level lock is acquired, update transactions progress more quickly because there is no delay waiting for individual record level locks. However, an exclusive lock may take longer to acquire, and it does reduce concurrency by preventing any other transactions from accessing the locked table. For these reasons, the exclusive mode should be reserved for use by high volume record update transactions or when a transaction has a high priority. The loss of concurrency and the possible need to undo many changes when the transaction is rolled back can be minimized by keeping transactions as short as possible.

IN SHARE MODE

The keyword SHARE is used to acquire a shared lock on an existing database table, usually when the intent of the transaction is to read many records or perform repeatable reads. When a shared lock is acquired on a table, other users may read the records in that table, but cannot perform inserts, updates or deletes. Other users must acquire an exclusive record level lock on the table first, before executing INSERT, UPDATE and DELETE transactions.

All table level locks may be released by the UNLOCK TABLE command. The XDB Server protects against deadlock by regulating the persistency of lock requests. You can change the timeout interval through the Options utility. A single attempt to acquire a lock will last no longer than the period specified.

Example:

The example below shows the command to acquire an exclusive lock on the PART table:

LOCK TABLE part IN EXCLUSIVE MODE

The next example shows the command to acquire a shared lock on the PARTSUPP table:

LOCK TABLE partsupp IN SHARE MODE

Acquiring a table lock on a table ensures the correctness of "repeatable reads." For example, the query

SELECT SUM(qty)
    FROM partsupp

will be correct because no other transaction will have the opportunity to change values in the QTY column while the lock is held.

Parent topic: SQL Statements


OPEN

Invocation

OPEN is an executable command that can only be embedded in a host language. OPEN cannot be dynamically prepared.

Authorization

The privileges required to execute an OPEN statement correspond to those privileges required for declaring the cursor being opened. See the authorization description under the DECLARE CURSOR command.

Syntax

OPEN cursor-name
    [USING {host-variable[,...]
    | DESCRIPTOR descriptor-name }]

Parameters:

cursor-name | Identifies a previously declared cursor.
host-variable | Identifies a variable described in the application program in accordance with the rules for declaring host variables.
descriptor-name | Preceded by the keyword DESCRIPTOR, identifies an SQLDA containing a valid description of application program host variables, which contains certain field values that must be set in order prior to executing an OPEN statement.

Description

The cursor must be in the closed state in order to execute an OPEN command. The OPEN command has two basic configurations. The first syntax format is the simple OPEN command, consisting of the keyword OPEN followed by the name of a previously declared cursor name. The second syntax format is used in dynamic SQL applications, and includes a USING clause. The USING clause introduces either a list of host variables (previously defined in the application) or an SQL Descriptor Area (SQLDA) also containing host variable information (including SELECT statement column information) previously described into the SQLDA. (See the DESCRIBE command.)

The cursor select statement can either be a SELECT statement specified in the DECLARE CURSOR statement or a previously prepared (see PREPARE command) SELECT statement identified by a statement name, which can also be specified in the DECLARE CURSOR statement. The OPEN command evaluates the cursor select statement and determines a result table for that cursor. This result table includes current values of any special registers specified in the cursor select statement, as well as the current values of any host variables specified in either the cursor select statement or the USING clause of the OPEN statement.

Result table rows can be determined either during the execution of the OPEN statement (in which case a temporary table will be created to hold them) or these rows can be determined during the execution of subsequent FETCH statements preformed on the opened cursor. In either case, the cursor is opened, and the cursor pointer is positioned before the first row of the result table. If the table happens to be empty, the cursor pointer is considered to be positioned after the last (nonexistent) row. The XDB Server does not alert users to an empty result table when the OPEN statement is executed, but does indicate an empty table by returning an SQLCODE value of +100 upon execution of the first FETCH statement on that result table.

USING

Before the OPEN statement is executed, each target parameter marker in the cursor query is assigned the value of its corresponding host variable. The USING clause introduces a list of host variables whose values are substituted for the parameter markers (question mark characters) appearing in a prepared SELECT statement. The number of host variables must equal the number of parameter markers. The USING clause must be specified if the DECLARE CURSOR statement names a prepared statement containing parameter markers. If the prepared statement has no parameter markers, the XDB Server ignores the USING clause.

The USING clause is intended primarily for cursors declared with prepared select statements containing parameter markers. When the prepared select statement of the cursor is evaluated, each parameter marker is replaced by its corresponding host variable listed in the USING clause. The USING clause also functions in those cases when the DECLARE CURSOR statement contains the actual select statement, which typically includes host variables rather than parameter markings. In these cases, the OPEN statement is executed as if each host variable in the cursor select statement is a parameter marker. The values of the cursor select statement host variables are replaced by the values of the host variables specified in the USING clause.

If an SQLDA is specified (preceded by the keyword DESCRIPTOR), the user must have already set the value of certain SQLDA fields. The SQLN field must contain a value indicating the number of values in the SQLVAR array variable. Additionally, the SQLDABC field must indicate the bytes of storage allocated for the SQLDA, while the SQLD field value must denote the total number of variables used in the SQLDA when processing the OPEN statement. Lastly, each entry in the SQLVAR array must describe the attributes of an individual variable. If LOBs or distinct types are present in the results, there must be additional SQLVAR entries for each input host variable.

The value stored in SQLDABC must be calculated according to the formula SQLN*44+16, in order for the SQLDA to contain enough storage for all SQLVAR array values. Additionally, the SQLD field must be set to a value greater than or equal to zero, and less than or equal to the value of the SQLN field. This field value must equal the number of parameter markers in the prepared statement.

Note:

FETCH statements retrieve rows from the result table of a cursor when the cursor is open. The only way to open a closed cursor is by executing an OPEN statement. All cursors in an application process are in a closed state when the application process is started or when a new unit of work for the application process is commenced (unless WITH HOLD is specified in the DECLARE CURSOR statement). Additionally, performing a CONNECT closes any open cursors in an application.

Example:

The parameter host-variables is a list of host variables defined in the Working-Storage Section.

Assume that CUSTBL is a cursor opened on a command that was previously prepared. This prepared command will have one substitution parameter. Note that HOSTVAR1 must be defined in the Working-Storage Section of your COBOL program.

EXEC SQL
    OPEN custbl
END-EXEC
EXEC SQL
    OPEN custbl USING :hostvar1
END-EXEC
Parent topic: SQL Statements
Related reference
DECLARE CURSOR
DESCRIBE
PREPARE


PREPARE

Invocation

PREPARE is an executable command that can only be embedded in a host language. PREPARE cannot be dynamically prepared.

Authorization

Users must have authorization to execute the command in the PREPARE statement.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

PREPARE statement-name
    [INTO descriptor-name [USING {NAMES | LABELS | ANY | BOTH}]]
    {[ATTRIBUTES attr-host-variable] FROM host-variable |
     FROM string-expression}

attr-host-variable

{{ASENSITIVE | INSENSITIVE | SENSITIVE [DYNAMIC | STATIC]} |
{SCROLL | NOSCROLL} |
holdability |
returnability |
rowset-positioning |
fetch-first-clause |
{read-only-clause | update-clause} |
optimize-clause |
isolation-clause |
{FOR MULTIPLE ROWS | FOR SINGLE ROW} |
{ATOMIC | NOT ATOMIC CONTINUE ON SQLEXCEPTION} [...] }

holdability

[WITH HOLD | WITHOUT HOLD]

returnability

[WITH RETURN [TO CALLER] | WITHOUT RETURN]

rowset-positioning

[WITH ROWSET POSITIONING | WITHOUT ROWSET POSITIONING]

Parameters:

statement-name | Names the prepared statement. If a prepared statement by that name already exists, then that prepared statement is destroyed and replaced by the newer version specified in this PREPARE statement.
descriptor-name | Preceded by the keyword INTO, identifies an SQLDA containing a valid description of host variables. See Overview for information about SQLDA.
host-variable | Preceded by the keyword FROM, must identify a variable (containing an SQL statement) described in the application program in accordance with the rules for declaring character string variables in the host language.

Description

The PREPARE statement is used by application programs to dynamically prepare an SQL statement for later use by an EXECUTE statement. Any SQL statement other than CLOSE, COMMIT, DECLARE CURSOR, DESCRIBE, EXECUTE, EXECUTE IMMEDIATE, FETCH, INCLUDE, OPEN, PREPARE, ROLLBACK, and WHENEVER may be prepared.

The prepared statement may not begin with an EXEC SQL or end with a statement terminator. Neither may the prepared statement contain references to host variables nor include comments. Although a statement may not contain host variables, it may include parameter markers. A parameter marker is a question mark character that will be replaced by a host variable at execution time.

INTO

The optional INTO clause places information about the prepared statement into the SQLDA specified in descriptor-name. This optional clause has the same effect as executing an extra DESCRIBE statement for the SQLDA (see DESCRIBE statement).

USING

Indicates what value to assign to each SQLNAME variable in the SQLDA when INTO is used. If the requested value does not exist, SQLNAME is set to length 0.

NAMES | Assigns the name of the column. This is the default.
LABELS | Assigns the label of the column. (Column labels are defined by the LABEL ON statement.)
ANY | Assigns the column label, and, if the column has no label, the column name.
BOTH | Assigns both the label and name of the column. In this case, two or three occurrences of SQLVAR per column, depending on whether the result set contains distinct types, are needed to accommodate the additional information. To specify this expansion of the SQLVAR array, set SQLN to 2¦n or 3¦n, where n is the number of columns in the object being described. For each of the columns, the first n occurrences of SQLVAR, which are the base SQLVAR entries, contain the column names. Either the second or third n occurrences of SQLVAR, which are the extended SQLVAR entries, contain the column labels. If there are no distinct types, the labels are returned in the second set of SQLVAR entries. Otherwise, the labels are returned in the third set of SQLVAR entries.

Parameter markers

The two types of parameter markers are typed and untyped:

Typed parameter marker

A parameter marker that is specified with its target data type. A typed parameter marker has the general form:

CAST(? AS data-type)

This notation is not a function call, but rather is a "promise" that the data type of the host variable at run time will be the same as, or can be converted to, the data type that was specified.

In the following example, the value of the argument that is provided for the TRANSLATE function at run time must be VARCHAR(12) or a data type that can be converted to VARCHAR(12).

UPDATE EMPLOYEE
    SET LASTNAME = TRANSLATE(CAST(? AS VARCHAR(12)))
    WHERE EMPNO = ?

Untyped parameter marker

A parameter marker that is specified without its target data type. An untyped parameter marker has the form of a single question mark. The context in which the parameter marker appears determines its data type. For example, in the above UPDATE statement, the data type of the untyped parameter marker in the predicate is the same as the data type of the EMPNO column.

Typed parameter markers can be used in dynamic SQL statements wherever a host variable is supported and the data type is based on the promise made in the CAST function.

Example:

In COBOL the host-variable must be a varying-length string variable defined in working storage of the code.

EXEC SQL
    PREPARE getcust
        FROM 'SELECT cno, name FROM cust'
END-EXEC

Another example of PREPARE also involving EXECUTE:

EXEC SQL
    PREPARE inscust FROM INSERT
        INTO cust(cno, name)
        VALUES (?, ?)
END-EXEC
.
. assign values to CNO and CNAME
.
EXEC SQL
    EXECUTE inscust
        USING :CNO, :CNAME
END-EXEC

Alternatively, it is possible to move an SQL string into a host variable and prepare that:

MOVE 'INSERT INTO cust (cno, name) VALUES (?, ?)'
    TO HOLD
EXEC SQL
    PREPARE inscust FROM :HOLD END-EXEC
.
. assign values to CNO and CNAME
.
EXEC SQL
    EXECUTE inscust
        USING :CNO, :CNAME
END-EXEC
Parent topic: SQL Statements
Related reference
DESCRIBE
Related information
Syntax Support Only


REFRESH LOCATIONS

Invocation

REFRESH LOCATIONS is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

REFRESH LOCATIONS requires no special privilege or authority. However, only a super user can edit the SYSIBM.SYSLOCATIONS catalog table.

Syntax

REFRESH LOCATIONS

Description

In order for the XDB Server to take advantage of Remote Unit of Work (RUW) or Distributed Unit of Work (DUW) processing, location information must be recorded in the SYSIBM.SYSLOCATIONS catalog table. This location information is read into memory the first time any application or user logs into the XDB Server.

If new location information is manually inserted into SYSIBM.SYSLOCATIONS (after the initial logging on), a REFRESH LOCATIONS command must be issued to reset the system to recognize this newly recorded location. The CREATE LOCATION command, however, automatically resets the system with the new location information.

Parent topic: SQL Statements


REFRESH TABLE

This command is only implemented syntactically in the XDB Server operating environment.

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared only if DYNAMICRULES run behavior is implicitly or explicitly specified.

Authorization

The privilege set for REFRESH TABLE must include at least one of the following authorities:

  • Ownership of the materialized query table
  • DBADM or DBCTRL authority on the database that contains the materialized query table
  • SYSADM or SYSCTRL authority

If the statement is embedded in an application program, the privilege set is the privileges that are held by the authorization ID of the owner of the plan or package. If the statements dynamically prepared, the privilege set is determined by the DYNAMICRULES behavior in effect (run, bind, define, or invoke).

Syntax

Bold text indicates clauses or options that are supported only syntactically.

REFRESH TABLE table-name [QUERYNO integer]

Description

table-name

Identifies the table to be refreshed. The name must identify a materialized query table. REFRESH TABLE evaluates the fullselect in the materialized-query-definition clause to refresh the table. The isolation level for the fullselect is the isolation level of the materialized query table recorded when CREATE TABLE or ALTER TABLE was issued.

QUERYNO integer

Specifies the number to be used for this SQL statement in EXPLAIN output and trace records. The number is used for the QUERYNO column of the plan table for the rows that contain information about this SQL statement. This number is also used in the QUERYNO column of the SYSIBM.SYSSTMT and SYSIBM.SYSPACKSTMT catalog tables.

If the clause is omitted, the number associated with the SQL statement is the statement number assigned during precompilation. Thus, if the application program is changed and then precompiled, that statement number might change.

Note:
  • Automatic query rewrite using materialized query tables is not attempted for the fullselect in the materialized query table definition during the processing of REFRESH TABLE statement.
  • After successful execution of a REFRESH TABLE statement, the SQLCA field SQLERRD(3) will contain the number of rows inserted into the materialized query table.
  • The EXPLAIN output for REFRESH TABLE table-name is the same as the EXPLAIN output for INSERT INTO table-name fullselect where fullselect is from the materialized query table definition.
  • The REFRESH TABLE statement is supported over DRDA protocol, but not supported over DB2 private protocol.
  • If the materialized query table has a security label column, the REFRESH TABLE statement does not do any checking for multilevel security with row-level granularity when it deletes and repopulates the data in the table by executing the fullselect. Instead, DB2 performs the checking for multilevel security with row-level granularity when the materialized query table is exploited in automatic query rewrite or is used directly.
Parent topic: SQL Statements


RELEASE (connection)

Invocation

This statement can only be embedded in an application program, except in REXX programs. It is an executable statement that cannot be dynamically prepared.

Authorization

None required.

Syntax

RELEASE {location-name | host-variable | CURRENT | ALL [SQL] | ALL PRIVATE}

Description

location-name or host-variable

Identifies an SQL connection or a DB2 private connection by the specified location name or the location name contained in the host variable. If a host variable is specified:

  • It must be a character string variable with a length attribute that is not greater than 16. (A C NUL-terminated character string can be up to 17 bytes.)
  • It must not be followed by an indicator variable.
  • The location name must be left-justified within the host variable and must conform to the rules for forming an ordinary location identifier.
  • If the length of the location name is less than the length of the host variable, it must be padded on the right with blanks.

The specified location name or the location name contained in the host variable must identify an existing SQL connection or DB2 private connection of the application process.

If the RELEASE statement is successful, the identified connection is placed in the release pending status and will therefore be ended during the next commit operation. If the RELEASE statement is unsuccessful, the connection state of the application process and the states of its connections are unchanged.

CURRENT

Identifies the current SQL connection of the application process. The application process must be in the connected state.

If the RELEASE statement is successful, the identified connection is placed in the release pending state and will therefore be ended during the next commit operation. If the RELEASE statement is unsuccessful, the connection state of the application process and the states of its connections are unchanged.

ALL or ALL SQL

Identifies all existing connections (including local, SQL, and DB2 private connections) of the application process and places these connections in the release pending status. These connections are ended during the next commit operation. An error or warning does not occur if no connections exist when the statement is executed.

ALL PRIVATE

Identifies all existing DB2 private connections of the application process and places these connections in the release pending status. These DB2 private connections are ended during the next commit operation. An error or warning does not occur if no DB2 private connections exist when the statement is executed.

Example:

The SQL connection to TOROLAB1 is not needed in the next unit of work. The following statement causes it to be ended during the next commit operation:

EXEC SQL RELEASE TOROLAB1
Parent topic: SQL Statements


RELEASE SAVEPOINT

Invocation

This statement can be imbedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared.

Authorization

None required.

Syntax

RELEASE [TO] SAVEPOINT svpt-name

svpt-name

A savepoint identifier that identifies the savepoint to release. If the named savepoint does not exist, an error occurs. The named savepoint and all the savepoints that were subsequently established in the unit of recovery are released. After a savepoint is released, it is no longer maintained and rollback to the savepoint is no longer possible.

Example:

Assume that a main routine sets savepoint A and then invokes a subroutine that sets savepoints B and C. When control returns to the main routine, release savepoint A and any subsequently set savepoints. Savepoints B and C, which were set by the subroutine, are released in addition to A.

RELEASE SAVEPOINT A;
Parent topic: SQL Statements


RENAME

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared. However, if the bind option DYNAMICRULES(BIND) applies, the statement cannot be dynamically prepared.

Authorization

The privileges set defined below must include at least one of the following:

  • Ownership of the table
  • DBADM, DBCTRL, or DBMAINT authority for the database that contains the table
  • SYSADM or SYSCTRL authority

Privilege Set: If the statement is embedded in an application program, the privilege set is the privileges held by the authorization ID of the owner of the plan or package. If the statement is dynamically prepared, the privilege set is the union of the privilege sets held by each authorization ID of the process.

If the name of the existing table includes a qualifier that is different from the authorization ID of the statement, the privileges held by the authorization ID of the statement must include administrative authority.

Syntax

RENAME [TABLE] source-table-name TO target-table-name

Parameters:

source-table-name | Identifies the table to be renamed.
target-table-name | Is the new table name.

Description

The source table name, including the implicit or explicit qualifier, must identify a table that already exists at the current server. The name must not identify a table that has a trigger defined on it, a declared temporary table, a catalog table, an active RLST table, a view, or a synonym. The new table name must be a legal table name that does not already exist in the location. The specified source table is renamed to the new name. All privileges and indexes on the table are preserved.

Parent topic: SQL Statements


REVOKE (Database Privileges)

The XDB Server syntactically supports the collection, package, and plan classes of GRANT/REVOKE privilege commands. Also syntactically supported are the use class of GRANT/REVOKE privileges, including the USE OF ALL BUFFERPOOLS clause. The XDB Server cannot functionally utilize these types of privileges, although future catalog support is planned. DB2 users should consult their DB2 documentation for information on these four classes of privilege commands.

Invocation

REVOKE is an executable statement that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

In most instances, the authority needed to revoke a specific privilege must be identical to the authority that originally issued the privilege -- which means that privileges individually granted by a specific AuthID are generally revoked individually by the same AuthID.

Syntax

This format is used to revoke privileges on specified databases. One or more of the privilege option keywords defined below (separated with commas) may be specified after REVOKE, allowing multiple privileges to be revoked in one statement. In every case, the privileges chosen are revoked only from the logical database(s) named in the REVOKE command.

REVOKE
        [DBADM[, ]]
        [DBCTRL[, ]]
        [DBMAINT[, ]]
        [CREATETAB[, ]]
        [CREATETS[, ]]
        [DROP[, ]]
        [STARTDB[, ]]
        [STATS[, ]]
        [STOPDB[, ]]
    ON DATABASE database-name[,...]
    FROM AuthID[,...][PUBLIC]
    [BY AuthID[,...][ALL]]

This format is used to revoke privileges on specified databases. One or more of the privilege option keywords defined below (separated with commas) may be specified after REVOKE, allowing multiple privileges to be revoked in one statement. In every case, the privileges chosen are revoked only from the logical database(s) named in the REVOKE command.

REVOKE
        [DBADM[, ]]
        [DBCTRL[, ]]
        [DBMAINT[, ]]
        [CREATETAB[, ]]
        [CREATETS[, ]]
        [DROP[, ]]
        [STARTDB[, ]]
        [STATS[, ]]
        [STOPDB[, ]]
    ON DATABASE database-name[,...]
    FROM AuthID[,...][PUBLIC]
    [BY AuthID[,...][ALL]]

Parameters:

DBADM | Database administrator authority.
DBCTRL | Database control authority.
DBMAINT | Database maintenance authority.
CREATETAB | Privilege to create new tables.
CREATETS | Privilege to create new table spaces.
DROP | Privilege to issue the DROP or ALTER DATABASE statements for the designated databases.
STARTDB | Privilege to issue the START DATABASE command.
STOPDB | Privilege to issue the STOP DATABASE command.
Note:

The DISPLAYDB, IMAGCOPY, LOAD, RECOVERDB, REORG, REPAIR, and STATS database grant/revoke privileges are specific to the DB2 mainframe environment, and control specific authorities for running mainframe utilities (for example, CHECK, RUNSTATS and QUIESCE). The XDB Server does not functionally support these privileges. However, to maintain maximum compatibility with mainframe DB2 operations, the XDB Server syntactically checks these privileges (if encountered) and updates the appropriate catalog tables.

database-name | Identifies a database on which privileges are to be revoked. Each database named must exist at the current location. The XDB Server does not support cascading revoke.
AuthID | Identifies a user authorization ID from which the specified privilege(s) are being revoked. The PUBLIC keyword option can be specified along with (or in place of) an AuthID (or a list of AuthIDs), revoking the specified privileges from all valid AuthIDs at the current location.

Description

The REVOKE command is used to remove system, database, table, and view privileges from designated AuthID(s). There are three formats for the REVOKE command, depending on the type of privilege being revoked. Database privileges include CREATETAB, DBADM and DROP privileges. Table privileges include ALTER, DELETE, INDEX, INSERT, SELECT, and UPDATE privileges. System privileges that imply other privileges are also characterized as authorities.

For a TEMP database, you cannot revoke the privilege from PUBLIC. When a TEMP database is created, PUBLIC implicitly receives the CREATETAB privilege (without GRANT authority); this privilege is not recorded in the DB2 catalog, and it cannot be revoked.

Individual grants (or groups of grants) are removed from the catalog tables by executing REVOKE command statements. Each individual revoke (as registered in the catalog tables) involves the removal of one privilege by one revoker from one revokee. The removal of privileges with the REVOKE statement is recorded in the system catalog for the current location. The status of each individual granted or revoked privilege (for each AuthID) is recorded in the catalog tables.

Note:

Since the same privilege can be granted to a single grantee AuthID by several different grantor AuthIDs, the grantee AuthID retains the privilege as long as one (or more) of these grants remains recorded in the system catalog.

Privileges may be revoked from a specific set of users by listing their AuthIDs in the FROM clause of the REVOKE statement. To revoke privileges from all AuthIDs in the current location, use the keyword PUBLIC in the FROM clause. When a privilege is revoked from PUBLIC, the system catalog continues to maintain the list of AuthIDs that were individually granted the privilege.

Example:

The following example revokes DBADM authority for a database named PICTURES from the individual(s) with AuthID usera.

REVOKE DBADM
    ON DATABASE pictures
    FROM usera
Parent topic: SQL Statements
Related reference
REVOKE (Table or View Privileges)
REVOKE (System Privileges)
REVOKE (Function or Procedure Privileges)


REVOKE (Function or Procedure Privileges)

Syntax

REVOKE EXECUTE ON
       {FUNCTION {function-name [(parameter-type[,...])] | * } |
        SPECIFIC FUNCTION specific-name[,...] |
        PROCEDURE {procedure-name[,...] | *}
    FROM {authorization-name[,...] | PUBLIC} [BY {authorization-name[,...] | ALL}]
    RESTRICT

Description

EXECUTE

Revokes the privilege to run the identified user-defined function, cast function that was generated for a distinct type, or stored procedure.

FUNCTION or SPECIFIC FUNCTION

Identifies the function on which the privilege is granted. The function must exist at the current server, and it must be a function that was defined with the CREATE FUNCTION statement or a cast function that was generated by a CREATE DISTINCT TYPE statement.

If the function was defined with a table parameter (the LIKE TABLE was specified in the CREATE FUNCTION statement to indicate that one of the input parameters is a transition table), the function signature cannot be used to identify the function. Instead, identify the function with its function name, if unique, or with its specific name.

FUNCTION function-name

Identifies the function by its name. You can identify a function by its name only if there is exactly one function with function name in the schema. If you do not explicitly qualify the function name with a schema name, the function name is implicitly qualified with a schema name according to the following rules:

  • If the statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER option when the plan or package was created or last rebound. If QUALIFIER was not used, the schema name is the owner of the plan or package.
  • If the statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

An * can be specified for a qualified on unqualified function-name. An * (or schema-name.*) indicates that the privilege is revoked for all the functions in the schema. You (or the indicated grantors) must have granted the privilege on FUNCTION * to all identified users (including PUBLIC if specified). Privileges granted on specific functions are not affected.

FUNCTION function-name (parameter-type,...)

Identifies the function by its function signature, which uniquely identifies the function.

function-name Specifies the name of the function. If you do not explicitly qualify the function name with a schema name, the function name is implicitly qualified with a schema name as described in the preceding description for FUNCTION function-name.
(parameter-type,...) Identifies the number of input parameters of the function and their data types.

The data type of each parameter must match the data type that was specified in the CREATE FUNCTION statement for the parameter in the corresponding position. The number of data types and the logical concatenation of the data types is used to uniquely identify the function.

For data types that have a length, precision, or scale attribute, you can specify a value or use a set of empty parentheses:

  • Empty parentheses indicate that DB2 ignores the attribute when determining whether the data types match.

    FLOAT cannot be specified with empty parentheses because its parameter value indicates different data types (REAL or DOUBLE).

  • If you use a specific value for a length, precision, or scale attribute, the value must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.

    The specific value for FLOAT(n) does not have exactly match the defined value of the source function because 1<=n<= 21 indicates REAL and 22<=n<=53 indicates DOUBLE. Matching is based on whether the data type is REAL or DOUBLE.

  • If length, precision, or scale is not explicitly specified, and empty parentheses are not specified, the default length of the data type is implied. For example:

    The implicit length must exactly match the value that was specified (implicitly or explicitly) in the CREATE FUNCTION statement.

    For data types with a subtype or encoding scheme attribute, specifying the FOR DATA clause or CCSID clause is optional. Omission of either clause indicates that DB2 ignores the attribute when determining whether the data types match. If you specify either clause, it must match the value that was implicitly or explicitly specified in the CREATE FUNCTION statement.

SPECIFIC FUNCTION specific-name

Identifies the function by its specific name.

PROCEDURE procedure-name

Identifies a stored procedure that is defined at the current server. If you do not explicitly qualify the procedure name with a schema name, the procedure name is implicitly qualified with a schema name according to the following rules:

  • If the statement is embedded in a program, the schema name is the authorization ID in the QUALIFIER option when the plan or package was created or last rebound. If QUALIFIER was not used, the schema name is the owner of the plan or package.
  • If the statement is dynamically prepared, the schema name is the SQL authorization ID in the CURRENT SQLID special register.

An * can be specified for a qualified or unqualified procedure-name. An * (or schema-name.*) indicates that the privilege is revoked for all the procedures in the schema. You (or the indicated grantors) must have granted the privilege on PROCEDURE * to all identified users (including PUBLIC if specified). Privileges granted on specific procedures are not affected.

RESTRICT

Prevents the EXECUTE privilege from being revoked on a user-defined function or stored procedure if the revokee owns any of the following objects:

  • A function that is sourced on the function
  • A view that uses the function
  • A trigger package that uses the function or stored procedure
  • A table that uses the function in a check constraint or user-defined default clause

Example:

Revoke the EXECUTE privilege on function CALC_SALARY for user JONES. Assume that there is only one function in the schema with function CALC_SALARY.

REVOKE EXECUTE ON FUNCTION CALC_SALARY FROM JONES RESTRICT;

Revoke the EXECUTE privilege on procedure VACATION_ACCR from all users at the current server.

REVOKE EXECUTE ON PROCEDURE VACATION_ACCR FROM PUBLIC RESTRICT;

Revoke the privilege of the administrative assistant to grant EXECUTE privileges on function DEPT_TOTAL to other users. The administrative assistant will still have the EXECUTE privilege on function DEPT_TOTALS.

REVOKE EXECUTE ON FUNCTION DEPT_TOTALS
    FROM ADMIN_A RESTRICT;

Revoke the EXECUTE privilege on function NEW_DEPT_HIRES for HR (Human Resources). The function has two input parameters with data types of INTEGER and CHAR(10), respectively. Assume that the schema has more than one function that is named NEW_DEPT_HIRES.

REVOKE EXECUTE ON FUNCTION NEW_DEPT_HIRES (INTEGER, CHAR(10))
    FROM HR RESTRICT;

You can also code the CHAR(10) data type as CHAR().

Parent topic: SQL Statements
Related information
REVOKE (Table or View Privileges)
REVOKE (System Privileges)
REVOKE (Database Privileges)


REVOKE (Sequence Privileges)

Syntax

REVOKE {ALTER | USAGE} [,...] ON SEQUENCE sequence-name [,...]
FROM {authorization-name | PUBLIC} [,...]
[BY {authorization-name | ALL} [,...]]
[RESTRICT]
Note: The keyword SELECT is an alternative keyword for USAGE.

Description

ALTER

Revokes the privilege to alter a sequence or record a comment on a sequence.

USAGE

Revokes the USAGE privilege to use a sequence. This privilege is needed when the NEXT VALUE or PREVIOUS VALUE expression is invoked for a sequence name.

SEQUENCE sequence-name

Identifies the sequence. The name, including the implicit or explicit schema qualifier, must uniquely identify an existing sequence at the current server. If no sequence by this name exists in the explicitly or implicitly specified schema, an error occurs. sequence-name must not be the name of an internal sequence object that is generated by the system for an identity column.

FROM

Specifies from what authorization IDs the privileges are revoked.

authorization-name,...

Lists one or more authorization IDs. Do not use the same authorization ID more than once. The value of CURRENT RULES determines if you can use the ID of the REVOKE statement itself (to revoke privileges from yourself). When CURRENT RULES is:

DB2 | You cannot use the ID of the REVOKE statement.
STD | You can use the ID of the REVOKE statement.

PUBLIC

Revokes a grant of privileges to PUBLIC.

PUBLIC AT ALL LOCATIONS

Revokes a grant of privileges to PUBLIC AT ALL LOCATIONS.

BY

Lists grantors who have granted privileges and revokes each named privilege that was explicitly granted to some named user by one of the named grantors. Only an authorization ID with SYSADM or SYSCTRL authority can use BY, even if the authorization ID names only itself in the BY clause.

authorization-name,...

Lists one or more authorization IDs of users who were the grantors of the privileges named. Do not use the same authorization ID more than once. Each grantor listed must have explicitly granted some named privilege to all named users.

ALL

Revokes each named privilege from all named users who were explicitly granted the privilege, regardless of who granted it.

RESTRICT

Prevents the USAGE privilege from being revoked on a sequence if the revokee owns one of the following objects and does not have the USAGE privilege from another source:

  • A trigger that specifies the sequence in a NEXT VALUE or PREVIOUS VALUE expression
  • An inline SQL function that specifies the sequence in a NEXT VALUE or PREVIOUS VALUE expression
Parent topic: SQL Statements


REVOKE (System Privileges)

The XDB Server syntactically supports the collection, package, and plan classes of GRANT/REVOKE privilege commands. Also syntactically supported are the use class of GRANT/REVOKE privileges, including the USE OF ALL BUFFERPOOLS clause. The XDB Server cannot functionally utilize these types of privileges, although future catalog support is planned. DB2 users should consult their DB2 documentation for information on these four classes of privilege commands.

Invocation

REVOKE is an executable statement that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

In most instances, the authority needed to revoke a specific privilege must be identical to the authority that originally issued the privilege -- which means that privileges individually granted by a specific AuthID are generally revoked individually by the same AuthID.

Syntax

This format is used to revoke system privileges. In every case, the system privileges chosen are revoked only for those AuthID(s) specified in the FROM clause. One or more of the privilege option keywords defined below (separated with commas) may be specified after REVOKE, allowing multiple system privileges to be revoked in one REVOKE statement.

Bold text indicates clauses or options that are supported only syntactically.

REVOKE
        [CREATEALIAS[, ]]
        [CREATEDBA[, ]]
        [CREATEDBC[, ]]
        [CREATETMTAB[, ]]
        [CREATESG[, ]]
        [SYSADM[, ]]
        [SYSCTRL[, ]]
    FROM AuthID[,...][PUBLIC]
    BY {AuthID[,...] | ALL}

Parameters:

CREATEALIAS | Privilege to use the CREATE ALIAS statement.
CREATEDBA | Privilege to issue the CREATE DATABASE statement and acquire DBADM authority over those databases.
CREATEDBC | Privilege to issue the CREATE DATABASE statement and acquire DBCTRL authority over those databases.
CREATETMTAB | Privilege to issue the CREATE GLOBAL TEMPORARY TABLE statement.
CREATESG | Privilege to create new storage groups.
SYSADM | Revokes system administrator authority for the location.
SYSCTRL | Revokes the system control authority for the location.
Note:

The ARCHIVE, BINDADD, BINDAGENT, BSDS, DISPLAY, MONITOR1, MONITOR2, RECOVER, STOPALL, STOSPACE, SYSOPR, and TRACE system privileges control specific authorities for running mainframe utilities (for example, CHECK, RUNSTATS and QUIESCE). The XDB Server does not functionally support these privileges. However, to maintain maximum compatibility with mainframe DB2 operations, The XDB Server syntactically checks these privileges (if encountered) and updates the appropriate catalog tables.

AuthID Identifies a user authorization ID for which the specified privilege(s) are being revoked. The PUBLIC keyword option can be specified along with (or in place of) an AuthID (or a list of AuthIDs), revoking privileges from each valid AuthID at the current location.

Description

The REVOKE command is used to remove system, database, table, and view privileges from designated AuthID(s). There are three formats for the REVOKE command, depending on the type of privilege being revoked. Database privileges include CREATETAB, DBADM and DROP privileges. Table privileges include ALTER, DELETE, INDEX, INSERT, SELECT, and UPDATE privileges. System privileges that imply other privileges are also characterized as authorities.

Individual grants (or groups of grants) are removed from the catalog tables by executing REVOKE command statements. Each individual revoke (as registered in the catalog tables) involves the removal of one privilege by one revoker from one revokee. The removal of privileges with the REVOKE statement is recorded in the system catalog for the current location. The status of each individual granted or revoked privilege (for each AuthID) is recorded in the catalog tables.

Note:

Since the same privilege can be granted to a single grantee AuthID by several different grantor AuthIDs, the grantee AuthID retains the privilege as long as one (or more) of these grants remains recorded in the system catalog.

FROM

Privileges may be revoked from a specific set of users by listing their AuthIDs in the FROM clause of the REVOKE statement. To revoke privileges from all AuthIDs in the current location, use the keyword PUBLIC in the FROM clause. When a privilege is revoked from PUBLIC, the system catalog continues to maintain the list of AuthIDs that were individually granted the privilege.

DISPLAY

Revokes the privilege to use the following commands:

  • The DISPLAY ARCHIVE command for archive log information
  • The DISPLAY BUFFERPOOL command for the status of buffer pools
  • The DISPLAY DATABASE command for the status of all databases
  • The DISPLAY FUNCTION SPECIFIC command for statistics about accessed external user-defined functions
  • The DISPLAY LOCATION command for statistics about threads with a distributed relationship
  • The DISPLAY PROCEDURE command for statistics about accessed stored procedures
  • The DISPLAY THREAD command for information on active threads with in DB2
  • The DISPLAY TRACE command for a list of active traces
Parent topic: SQL Statements
Related reference
REVOKE (Database Privileges)
REVOKE (Table or View Privileges)
REVOKE (Function or Procedure Privileges)
Related information
Syntax Support Only


REVOKE (Table or View Privileges)

The XDB Server syntactically supports the collection, package, and plan classes of GRANT/REVOKE privilege commands. Also syntactically supported are the use class of GRANT/REVOKE privileges, including the USE OF ALL BUFFERPOOLS clause. The XDB Server cannot functionally utilize these types of privileges, although future catalog support is planned. DB2 users should consult their DB2 documentation for information on these four classes of privilege commands.

Invocation

REVOKE is an executable statement that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

In most instances, the authority needed to revoke a specific privilege must be identical to the authority that originally issued the privilege -- which means that privileges individually granted by a specific AuthID are generally revoked individually by the same AuthID.

Syntax

This format is used to revoke privileges on tables or views. In every case, the privileges chosen are revoked only from the tables or views named in the ON [TABLE] clause. One or more of the privilege keywords (separated with commas) defined below and/or the optional keyword(s) ALL [PRIVILEGES] may be specified after REVOKE, allowing multiple privileges to be revoked in one REVOKE statement.

Bold text indicates clauses or options that are supported only syntactically.

REVOKE
{       [ALTER[, ]]
        [DELETE[, ]]
        [INDEX[, ]]
        [INSERT[, ]]
        [SELECT[, ]]
        [TRIGGER[, ]]
        [UPDATE] | ALL [PRIVILEGES]
}
    ON [TABLE] {table-name[,...] | view-name[,...]}
    FROM AuthID[,...][PUBLIC [AT ALL LOCATIONS]]
    [BY {AuthID[,...] | ALL}]

Parameters:

ALTER | Privilege to use the ALTER TABLE statement (cannot specify a view).
DELETE | Privilege to use the DELETE statement.
INDEX | Privilege to use the CREATE INDEX statement (cannot specify a view).
INSERT | Privilege to use the INSERT statement.
SELECT | Revokes the privilege to create a view or read data from the specified table or view. A view or a materialized query table is dropped when the SELECT privilege that was used to create it is revoked, unless the owner of the view or materialized query table was directly granted the SELECT privilege from another source before the view or materialized query table was created.
TRIGGER | Revokes the privilege to use the CREATE TRIGGER statement
UPDATE | Privilege to use the UPDATE statement on all columns of the tables named in the ON [TABLE] clause. When followed by (column-name[,...]), the update privileges are revoked only from the columns specified in parentheses. Note that (unlike the corresponding GRANT command) the UPDATE privilege can only be revoked from a list of individual column names in XDB mode.
column-name | Specifies an individual column in a table from which the UPDATE privilege is being revoked.
table-name or view-name | Preceded by the keyword(s) ON [TABLE], identifies a table or view from which privileges are being revoked.
AuthID | Identifies a user authorization ID from which the privilege(s) specified are being revoked. The optional PUBLIC [AT ALL LOCATIONS] keyword(s) can be specified along with (or in place of) an AuthID (or a list of AuthIDs). The PUBLIC AT ALL LOCATIONS keyword option revokes the specified table privileges from all users at every location.

ALL [PRIVILEGES]

If the ALL or ALL PRIVILEGES keywords are specified, all table or view privileges (for which the issuer has REVOKE authority) are revoked for the objects identified in the ON [TABLE] clause.

Description

The REVOKE command is used to remove system, database, table, and view privileges from designated AuthID(s). There are three formats for the REVOKE command, depending on the type of privilege being revoked. Database privileges include CREATETAB, DBADM and DROP privileges. Table privileges include ALTER, DELETE, INDEX, INSERT, SELECT, and UPDATE privileges. System privileges that imply other privileges are also characterized as authorities.

Individual grants (or groups of grants) are removed from the catalog tables by executing REVOKE command statements. Each individual revoke (as registered in the catalog tables) involves the removal of one privilege by one revoker from one revokee. The removal of privileges with the REVOKE statement is recorded in the system catalog for the current location. The status of each individual granted or revoked privilege (for each AuthID) is recorded in the catalog tables.

For a declared temporary table, no privileges can be revoked because none can be granted. When a declared temporary table is defined, PUBLIC implicitly receives all table privileges (without GRANT authority) for the table. These privileges are not recorded in the DB2 catalog.

Note: Since the same privilege can be granted to a single grantee AuthID by several different grantor AuthIDs, the grantee AuthID retains the privilege as long as one (or more) of these grants remains recorded in the system catalog.

FROM

Privileges may be revoked from a specific set of users by listing their AuthIDs in the FROM clause of the REVOKE statement. To revoke privileges from all AuthIDs in the current location, use the keyword PUBLIC in the FROM clause. When a privilege is revoked from PUBLIC, the system catalog continues to maintain the list of AuthIDs that were individually granted the privilege.

Examples:

The following example revokes authority for the individuals with the AuthIDs userb and userc to update the PART and SUPPLIER tables.

REVOKE UPDATE
    ON part, supplier
    FROM userb, userc

To revoke privileges from PUBLIC to select, update, delete and insert records in the PART table, use the command:

REVOKE SELECT, UPDATE, DELETE, INSERT
    ON part
    FROM PUBLIC

To revoke the select privilege on all tables from AuthID usera, you might use a command like:

REVOKE SELECT
    ON ALL
    FROM usera

To revoke privileges (XDB mode only) on a subset of the columns in the EMPLOYEE table from AuthID usera, issue the command:

REVOKE UPDATE(address, city, state, zip, phone)
    ON employee
    FROM usera
Parent topic: SQL Statements


ROLLBACK

Invocation

ROLLBACK is an executable command that can be issued interactively or embedded in a host language. ROLLBACK can be dynamically prepared.

Authorization

No special authorization is required for ROLLBACK.

Syntax

ROLLBACK [WORK] [TO SAVEPOINT [svpt-name]]

Description

A transaction begins when a previous transaction ends. A transaction is terminated by a COMMIT or ROLLBACK command. Only the results of SQL commands executed within a single, uncommitted transaction are affected by the ROLLBACK command. When the ROLLBACK command is issued, all changes caused by INSERT, UPDATE and DELETE commands of the transaction are undone. All locks acquired during a transaction are released by the ROLLBACK command. If AUTOCOMMIT is on, a user-invoked ROLLBACK has no effect. However, the system will rollback a failed command.

Backward Logging

If you are using XDB Server Version 5.0 or higher, the ROLLBACK command is available. Previous versions of XDB required a feature called Backward Logging to be turned on in order to use the ROLLBACK command. The functionality provided by the old Backward Logging feature has been incorporated into the XDB Server logging system as a permanent default.

TO SAVEPOINT

Specifies that the unit of recovery is not to be ended and that only a partial rollback (to a savepoint) is to be performed. If a savepoint name is not specified, rollback is to the last active savepoint. For example, if in a unit of recovery, savepoints A, B, and C are set in that order and then C is released, ROLLBACK TO SAVEPOINT causes a rollback to savepoint B.

svpt-name A savepoint-identifier that identifies the savepoint to which to roll back. If the named savepoint does not exist, an error occurs.

All database changes (including changes made to a declared temporary tables but excluding changes made to created temporary tables) that were made after the savepoint was set are backed out. Changes that are made to created temporary tables are not logged and are not backed out; a warning is issued instead. (A warning is also issued when a created temporary table is changed and there is an active savepoint.)

In addition, none of the following items are backed out:

  • The opening or closing of cursors
  • Changes in cursor positioning
  • The acquisition and release of locks
  • The caching of the rolled back statements

Any savepoints that are set after the one to which rollback is performed are released. The savepoint to which rollback is performed is not released.

ROLLBACK with or without the TO SAVEPOINT clause has no effect on connections.

Parent topic: SQL Statements


ROLLFORWARD

Invocation

ROLLFORWARD can be executed interactively, embedded in a host language, or dynamically prepared.

Authorization

To use the ROLLFORWARD command you must be a super user.

Syntax

ROLLFORWARD location-name USING log-file-path

Parameters:

location-name | Identifies the location to be recovered.
log-file-path | Specifies the directory containing the log files that need to be applied to the appropriate location. These log files must have been created as the result of a standard or incremental BACKUP command.

Description

The ROLLFORWARD command is used to roll forward transactions contained in log files for a specified location. These log files must have been created by a standard or incremental BACKUP command.

The ROLLFORWARD command is used when a media or disk failure has occurred. After placing a backup of a location back on disk, ROLLFORWARD commands specifying the appropriate log files can bring the backup location up to date, so that its state is consistent with the location at the time of the crash.

After performing a standard backup (which is mandatory for all recovery scenarios), which type of backup you perform is up to you. Always performing standard backups takes longer than performing incremental backups but the recovery process from them is much easier and quicker. Performing incremental backups is quicker than performing standard backups but more ROLLFORWARD steps might be necessary to recreate your location.

The XDB Server's logging system automatically creates a series of log files when a new location is created. For an existing location, logging should be manually reset as a part of the location backup process.

Follow the steps below to manually reset location logging:

  1. Shut down server.
  2. Copy log files from the location logging directory to a separate archive directory.
  3. Depending on whether you are using the BACKUP LOCATION command or an operating system backup command, do one of the following:
    • Bring the server back up and run the BACKUP LOCATION command from SQLWizard (be sure you execute the BACKUP LOCATION command from a location other than the one you are backing up).
    • Run your operating system (or other) backup utility as appropriate (be sure to archive all directories associated with the XDB Server location).
  4. Shut down the server (if using BACKUP LOCATION).
  5. Delete all log files (*.LOG) from your location logging directory. The next time the location is accessed, a fresh series of log files will automatically be created by the logging system.

Since using a COMPACT command on a location renders that location's current log files useless, a location should be backed up (and the log files for that location reset) immediately after any COMPACT commands are issued against that location. Log files contain internal information that maps to a particular table structure. COMPACT commands alter the table structure of the location, changing this log-to-table mapping, and making ROLLFORWARD with the previous log files impossible.

Examples:

  • ROLLFORWARD Example
  • Recovery with Standard Backups Example
  • Recovery with Incremental Backups Example
  • ROLLFORWARD Example
Parent topic: SQL Statements


ROLLFORWARD Example

The following command rolls forward the transactions in MYLOC, using the log files specified in d:\backuplocs\xdb20051017151315000001:

ROLLFORWARD MYLOC USING D:\BACKUPLOCS\XDB20051017151315000001
Parent topic: ROLLFORWARD


SAVEPOINT

Invocation

This statement can be imbedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared.

Authorization

None required.

Syntax

SAVEPOINT svpt-name [UNIQUE]
    ON ROLLBACK RETAIN CURSORS
    [ON ROLLBACK RETAIN LOCKS]

Description

svpt-name

A savepoint identifier that names the savepoint. (A savepoint identifier is like an SQL identifier except that it has maximum length of 128 bytes.)

UNIQUE

Specifies that the application program cannot reuse the savepoint name within the unit of recovery. An error occurs if a savepoint with the same name as svpt-name already exists within the unit of recovery.

Omitting UNIQUE indicates that the application can reuse the savepoint name within the unit of recovery. If svpt-name identifies a savepoint that already exists within the unit of recovery and the savepoint was not created with the UNIQUE option, the existing savepoint is destroyed and a new savepoint is created. Destroying a savepoint to reuse its name for another savepoint is not the same as releasing the savepoint.

Reusing a savepoint name destroys only one savepoint. Releasing a savepoint with the RELEASE SAVEPOINT statement releases the savepoint and all savepoints that have been subsequently set.

ON ROLLBACK RETAIN CURSORS

Specifies that any cursors that are opened after the savepoint is set are not tracked, and thus, are not closed upon rollback to the savepoint.

Although these cursors remain open after rollback to the savepoint, they might not be usable. For example, if rolling back to the savepoint causes the insertion of a row upon which the cursor is positioned to be rolled back, using the cursor to update or delete the row results in an error.

ON ROLLBACK RETAIN LOCKS

Specifies that any locks that are acquired after the savepoint is set are not tracked, and thus, are not released upon rollback to the savepoint.

Example:

Assume that you want to set three savepoints at various points in a unit of recovery. Name the first savepoint A and allow the savepoint name to be reused. Name the second savepoint B and do not allow the name to be reused. Because you no longer need savepoint A when you are ready to set the third savepoint, reuse A as the name of the savepoint.

SAVEPOINT A ON ROLLBACK RETAIN CURSORS;
 . . .
SAVEPOINT B UNIQUE ON ROLLBACK RETAIN CURSORS;
 . . .
SAVEPOINT A ON ROLLBACK RETAIN CURSORS;
Parent topic: SQL Statements


SELECT

Invocation

SELECT is an executable command that can be issued interactively or embedded in a host language. SELECT can be dynamically prepared.

Authorization

In order to select data from a table or view, users must possess either SELECT authority on the table or view accessed, DBADM authority on the database, SYSADM or SYSCTRL authority for the location, or be the owner of the table or view.

Syntax

SELECT command statements can be composed of six different types of clauses. The SELECT clause and the FROM clause are required for all SELECT commands.

WHERE clauses are permitted in all SELECT commands. You can force the use of an index for a particular indexed column or force the system to not use an index in the query. To force the use of an index when constructing the query, enter an asterisk (*) in parentheses after the name of the indexed column in the WHERE clause.

To force the system to ignore the index, enter a hyphen (-) in parentheses after the name of the indexed column. The (*) and (-) options are valid only for column names that appear in a WHERE clause. You cannot use the (*) and (-) options in GROUP BY, HAVING or ORDER BY clauses (see SELECT Clause for examples).

Depending on the other clauses they contain, SELECT commands may be grouped into the following three classes:

Subselect

A subselect specifies a result table derived from the tables or views identified in the FROM clause of the query.

The subselect syntax appears below:

select-clause from-clause [where-clause] [group-by-clause] [having-clause]

Parameters

select-clause | Required component of a subselect. See SELECT Clause Syntax and Description for a complete syntax analysis of SELECT clauses.
from-clause | Required component of a subselect. See FROM Clause Syntax and Description for a complete syntax analysis of FROM clauses.
where-clause | Optional clause of a subselect. See WHERE Clause Syntax and Description for a complete syntax analysis of WHERE clauses.
group-by-clause | Optional clause of a subselect. See GROUP BY Clause for a complete syntax analysis of GROUP BY clauses.
having-clause | Optional clause of a subselect. See GROUP BY Clause for a complete syntax analysis of HAVING clauses.

Description

In addition to standing on its own, a subselect can be a component of the fullselect or incorporated into CREATE TABLE, UPDATE, INSERT, DELETE, and CREATE VIEW statements. Subselects can also be components of certain predicates, in which case they can be called subqueries. Subselects can contain GROUP BY or HAVING clauses, and the WHERE clause of a subselect can also contain nested subselects. Subselects cannot contain the UNION operator or an ORDER BY clause.

Subselects and Locations

The subselect cannot reference a location other than the one referenced elsewhere in the command. That is, a referenced table and all subselects in a single SQL statement must be from the same location.

Invalid:

SELECT * FROM tutorial.tutorial.employeeWHERE e_no IN SELECT e_no FROM debloc.debbie.employee WHERE st = "MD";

Valid:

SELECT * FROM tutorial.tutorial.employeeWHERE e_no IN SELECT e_no FROM tutorial.debbie.employee WHERE st = "MD";

Fullselect

A fullselect can consist of one or more subselects connected with one or more UNION operators. Fullselects can also be issued from SQLWizard -- causing a result table to be displayed. See SELECT Clause for examples of fullselect queries.

Syntax:

The fullselect syntax appears below:

subselect [(fullselect)] [UNION | UNION ALL] [subselect [(fullselect)]]

Description

A fullselect that contains no UNION or UNION ALL clauses is simply a subselect. A fullselect can combine multiple subselects (and fullselects) by repeated use of the UNION and UNION ALL keywords. Only the final query in a fullselect ends with a semicolon. The absence of semicolons after the preceding queries is what makes SQL cognizant that these queries are part of a UNION.

UNION

Combines the results output of columns from two separate tables as though they were one. The column headings are omitted in the result because no columns produced by a union are directly extracted from a single table. In order for two or more queries to undergo a union, their output columns must be union compatible. This means that the queries must each specify the same number of columns and in such an order that the first, second, third, and so on, of each is of a compatible data type with the first, second, third, and so on, of all the others.

UNION ALL

Same as UNION, but includes all duplicate data rows in the output (UNION eliminates all redundant combinations of data values, therefore making every row of result data unique).

AS

The AS clause affects column names in the results of fullselects. If the nth result columns of two queries combined in a UNION have the same result column name (defined with an AS clause), then the nth column of the final UNION result has the same defined column name.

Select Statement

The select statement is the form of a query that can be directly specified in a DECLARE CURSOR statement or prepared and then referenced in a DECLARE CURSOR statement.

Syntax

The select statement syntax appears below:

fullselect [order-by-clause] [update-clause]
    {[FOR FETCH ONLY] [FOR READ ONLY]}
    [optimize-for-clause]
    [with-clause]
    [queryno-clause]
    [fetch-first-clause]

order-by-clause:

ORDER BY {column-name | integer}
    {ASC | DESC}[,...]

update-clause:

FOR UPDATE OF column-name[,...]

optimize-for-clause:

OPTIMIZE FOR integer {ROWS | ROW}

with-clause:

WITH {CS | RR | UR}

queryno-clause:

QUERYNO integer

fetch-first-clause:

FETCH FIRST {1 | integer} {ROW | ROWS} ONLY

Parameters:

column-name | Uniquely identifies a column of the result table. A named column may be identified by an integer or column-name. An unnamed column must be identified by an integer (below).
integer | An integer value greater than zero, and not greater than the number of columns in the result table. The integer n identifies the nth column of the result table.

Description

The table specified by the select statement is the result of a fullselect. The tables or views identified can reside in the currently set location or at any other accessible location under the XDB Server. To access other locations, specify a three-part name (or alias) or issue a CONNECT or SET LOCATION TO command prior to issuing the select statement.

FOR FETCH ONLY

Including this clause or the FOR READ ONLY clause (in DB2 Version 4.1), declares that the result table is read-only. A read-only result table must not be referred to by any UPDATE or DELETE statements. These limitations apply to result tables that are intrinsically read-only (such as those based on read-only views), and those for which the FOR FETCH ONLY or FOR READ ONLY clause is specified by the user.

Cursors with read-only result tables cannot be referred to in positioned UPDATE and DELETE statements, since data is fetched between client and server in large blocks. However, if no positional updates are needed, the FOR FETCH ONLY clause can still be used to improve fetch performance.

Specifying FOR FETCH ONLY activates Bulk Fetching, which improves the performance of FETCH operations. When a query is Bulk Fetched, data is transferred to the client in bulk, instead of one row at a time. The bulk size depends on the number of records that can be transferred, which in turn is influenced by the number of columns selected, data types and the overhead.

ORDER BY

This clause specifies an order for result table rows. If one column-name is identified, the rows are ordered by the data values within the column. If more than one column-name is identified, the rows are ordered by the values of the first column, then by the values of the second column, etc. ASC uses the values of the identified column in ascending order (default), while DESC uses the values of the column in descending order. If the ORDER BY clause is not specified, the rows of the result table have an arbitrary order.

The inclusion of an AS clause in the fullselect allows a named column to be identified by a column name. An unnamed column must be identified by an integer. A column is unnamed if the AS clause is not specified and it is derived from a constant, an expression with operators, or a function. If the fullselect includes a UNION operator, the fullselect rules on named columns apply.

FOR UPDATE OF

The UPDATE clause identifies the columns that can be updated in a later positioned UPDATE statement. The FOR UPDATE OF clause restricts the table columns that can be updated to those specified in the column-name list. These column names must be defined for the table or view appearing in the first FROM clause of the fullselect, and must not be qualified. FOR UPDATE OF cannot be used if the result table is read-only, nor can it be used in a statement containing a FOR FETCH ONLY clause.

OPTIMIZE FOR

This optional clause can be placed either before or after any accompanying FOR FETCH ONLY clause. OPTIMIZE FOR tells the XDB Server to proceed under the assumption that "at most a total of integer rows are to be retrieved from the result table." Without this clause, the XDB Server will assume that all rows of the result table are to be retrieved (and optimized accordingly).

OPTIMIZE FOR does not actually affect the composition or ordering of the result table. Optimizing for a limited (integer) number of rows can improve fetch performance if subsequent fetches are limited to integer rows. Any number of rows can be fetched after using the OPTIMIZE FOR clause, but after a total of integer rows are fetched, subsequent fetch performance may degrade.

WITH

You can override the isolation level for all SQL statements specified in a statement with the ISOLATION option by using the WITH clause on individual SQL statements. The WITH clause overrides the default isolation level only for the statement in which it appears. The WITH clause cannot be used on subselects.

The following three isolation levels can be specified:

CS | Cursor stability
RR | Repeatable read
UR | Uncommitted read

WITH UR can be specified only after SELECT, and only if the result table is read-only. A simple way to assure that a result table is read-only is to specify FOR FETCH ONLY or FOR READ ONLY. More information on isolation levels can be found in the Server Administration Guide.

FETCH FIRST

The FETCH FIRST clause limits the number of rows that can be fetched. It can improve the performance of queries with potentially large result sets when only a limited number of rows are needed. If the clause is specified, the number of rows retrieved will not exceed n, where n is the value of the integer. An attempt to fetch n+1 rows is handled the same way as normal end of data. The value of integer must be positive and non-zero. The default is 1.

If the OPTIMIZE FOR clause is not specified, a default of "OPTIMIZE FOR integer ROWS" is assumed. If both the FETCH FIRST and OPTIMIZE FOR clauses are specified, the lower of the integer values from these clauses is used to influence optimization and the communications buffer size.

If both the FETCH FIRST clause and the ORDER BY clause are specified, the ordering is performed on the entire result set prior to returning the first n rows.

More On SELECT

Due to the relative importance and complexity of SELECT commands (and supporting clauses), this command is described in detail (including numerous examples) in the following topics:

  • SELECT Clause - includes selecting DISTINCT values, retrieving all column values, and selecting constants and expressions.
  • FROM Clause - discusses how to select data from one or more tables or views, and how to use correlation names to qualify the source of data. The newly supported join syntax is also covered.
  • WHERE Clause - describes how to construct simple and complex search conditions using a variety of operators, how to perform string pattern matching using LIKE, how to create join conditions. Covers nested queries using ALL, ANY, EXISTS, etc., and correlated subselects.
  • Other Clauses - include the GROUP BY, HAVING, ORDER BY and FOR UPDATE OF clauses, and the UNION operator.
  • Functions - describes standard SQL functions, as well as special XDB Server functions, including recursive inference functions, aggregate functions, date functions, math functions, and string functions -- most of which can be incorporated into SELECT command statements.
Parent topic: SQL Statements
Related information
SELECT Clause Syntax and Description
FROM Clause Syntax and Description
WHERE Clause Syntax and Description
GROUP BY Clause
Functions Overview


SELECT INTO

Invocation

SELECT INTO is an executable command that can only be embedded in a host language. SELECT cannot be dynamically prepared. Tables or views identified in the SELECT INTO statement can exist at the current location or any other location existing under (or accessible from) the XDB Server.

Authorization

In order to select data from a table or view users must possess either SELECT or EXECUTE authority on the table or view accessed, DBADM authority on the database, SYSADM or SYSCTRL authority for the location, or be the owner of the table or view.

Syntax

SELECT projection-list INTO host-var-list
    FROM table-view-list
    [WHERE search-condition]
    [group-by-clause]
    [having-clause]
    [order-by-clause]
    [WITH {RR [lock-clause] | RS [lock-clause] | CS | UR}]
    [QUERYNO integer]
    [FETCH FIRST [1] {ROW | ROWS} ONLY]
order-by-clause
ORDER BY {sort-key [ASC | DESC] [,...] | INPUT SEQUENCE}
sort-key
{column-name | integer | expression}
lock-clause
USE AND KEEP {EXCLUSIVE | UPDATE | SHARE} LOCKS

Parameters:

projection-list | Preceded by the keyword SELECT, lists one or more columns and/or expressions.
host-var-list | Preceded by the keyword INTO, lists one or more host variables (separated by commas) that have been described in the host program according to the rules for describing host variables. See the examples for additional language specific information.
table-view-list | Preceded by the keyword FROM (see FROM Clause Syntax and Description), lists one or more tables or views separated by commas.
search-condition | Preceded by the keyword WHERE (see WHERE Clause Syntax and Description), describes one or more row selection criteria. Multiple selection conditions can be specified together using the AND and OR logical operators.

Description

A SELECT INTO command can retrieve at most one row from a table or view. If the selected table is empty, the SQLCODE indicator field in the SQLCA is assigned a value of +100. If the statement retrieves more than one row of data an error condition results (assigning SQLCODE a value of -811).

The SELECT INTO command statement differs from other types of SELECT commands in that retrieved row values are assigned directly to host variables specified in the INTO clause. Retrieved table values are derived by first evaluating the FROM clause, followed by the WHERE and SELECT clauses.

The INTO clause cannot appear in nested SELECT commands. ORDER BY and UNION are not allowed in SELECT commands containing an INTO clause. When a SELECT command includes an INTO clause, GROUP BY and HAVING are allowed only in nested select statements.

If no rows are retrieved, +100 is placed in SQLCODE, and the host variables are unchanged. If an error occurs when evaluating any column in the projection list a null value is placed in the host variable. To retrieve multiple rows of table values using an embedded SELECT statement, use a DECLARE CURSOR command statement along with the FETCH command.

WITH Clause

Specifies an isolation level with which the statement is executed. You can override the isolation level of the statement using the WITH {CS | RS | RR | UR} clause. You can only specify the isolation levels that specifically apply to a statement. WITH UR can be specified only after SELECT and only if the result table is read-only. The WITH clause overrides the isolation level only for the statement in which it appears.

When you specify WITH RR KEEP UPDATE LOCKS, XDB Server acquires an exclusive (X) lock, instead of a shared (S) lock, on all the pages or rows that fall within the range of the selection expression. All the X locks are retained until the next commit point.

See the Server Administration Guide for information about locking and isolation levels.

QUERYNO integer

Specifies the number to be used for this SQL statement in EXPLAIN output and trace records. The number is used for the QUERYNO columns of the plan tables for the rows that contain information about this SQL statement.

If the clause is omitted, the number associated with the SQL statement is the statement number assigned during precompilation. Thus, if the application program is changed and then precompiled, that statement number might change.

Using the QUERYNO clause to assign unique numbers to the SQL statements in a program is helpful for simplifying the use of optimization hints for access path selection, if hints are used.

Example:

The hostvarlist parameter is a list of host variables, the total of which are equal to the number of columns in projection-list.

Here is an example of a SELECT INTO statement. The record returned will be read into the host variables CNO and NAME (like FETCH):

EXEC SQL
    SELECT cno, name
        INTO :CNO, :NAME
        FROM cust
        WHERE name = :incno
END-EXEC
Parent topic: SQL Statements


SET AUTOCOMMIT

Invocation

SET AUTOCOMMIT is an executable XDB Server utility command that can be issued interactively or embedded in a host language. SET AUTOCOMMIT can be dynamically prepared.

Authorization

No special authorization is required to set autocommit on or off.

Syntax

SET AUTOCOMMIT {ON | OFF}

Description

You can use autocommit to automatically commit a command as soon as it is successfully executed. If autocommit is on, an implicit COMMIT is issued at command completion or the close of a cursor (for SELECT statements). If Backward Logging is turned on, the autocommit feature causes the contents of the Backward Log to be cleared after each transaction. However, the release of resources such as locks and cursors occurs independently of Backward Logging.

Example:

The command to turn autocommit on is:

SET AUTOCOMMIT ON

To turn autocommit off:

SET AUTOCOMMIT OFF
Parent topic: SQL Statements


SET COMPATIBILITY

Invocation

SET COMPATIBILITY is an executable XDB Server utility command that can be issued interactively or embedded in a host language. SET COMPATIBILITY can be dynamically prepared.

Authorization

No special authorization is required to specify an XDB Server compatibility mode.

Syntax

SET COMPATIBILITY {DB2 | XDB | ANSI}

Description

This command allows compatibility to change dynamically so you can mix compatible commands only available in certain modes within a particular program. (The functionality of this command is identical to the DB2 command SET CURRENT RULES.) This is useful within an application that executes predominantly in one mode, but in which you need to change to another mode for a particular operation.

Example:

To specify the DB2 compatibility mode enter the following:

SET COMPATIBILITY DB2
Parent topic: SQL Statements


SET CONNECTION

Invocation

This statement can only be embedded in an application program, except in REXX programs. It is an executable statement that cannot be dynamically prepared.

Authorization

None required.

Syntax

SET CONNECTION {location-name | host-variable}

Description

Identifies the SQL connection by the specified location name or the location name contained in the host variable. If a host variable is specified:

  • It must be a character string variable with a length attribute that is not greater than 16. (A C NUL-terminated character string can be up to 17 bytes.)
  • It must not be followed by an indicator variable.
  • The location name must be left-justified within the host variable and must conform to the rules for forming an ordinary location identifier.
  • If the length of the location name is less than the length of the host variable, it must be padded on the right with blanks.

Let S denote the specified location name or the location name contained in the host variable. S must identify an existing SQL connection of the application process. If S identifies the current SQL connection, the state of S and all other connections of the application process are unchanged. The following rules apply when S identifies a dormant SQL connection.

If the SET CONNECTION statement is successful:

  • SQL connection S is placed in the current state.
  • S is placed in the CURRENT SERVER special register.
  • Information about application server S is placed in the SQLERRP field of the SQLCA. If the application server is an IBM product, the information has the form pppvvrrm, where:
    ppp

    One of:

    ARI | DB2 Server for VSE & VM
    DSN | DB2 for OS/390
    QSQ | OS/400
    SQL | all other DB2 products
    vv

    is a two-digit version identifier such as '06'.

    rr

    is a two-digit release identifier such as '01'.

    m

    is a one-digit modification level such as '0'.

For example, if the server is Version 6 of DB2 for OS/390 with the latest maintenance, the value of SQLERRP is 'DSN06011'. Any previously current SQL connection is placed in the dormant state.

If the SET CONNECTION statement is unsuccessful, the connection state of the application process and the states of its SQL connections are unchanged.

Examples:

Execute SQL statements at TOROLAB1, execute SQL statements at TOROLAB2, and then execute more SQL statements at TOROLAB1.

EXEC SQL CONNECT TO TOROLAB1;

(execute statements referencing objects at TOROLAB1)

EXEC SQL CONNECT TO TOROLAB2;

(execute statements referencing objects at TOROLAB2)

EXEC SQL SET CONNECTION TOROLAB1;

(execute statements referencing objects at TOROLAB1)

The first CONNECT statement creates the TOROLAB1 connection, the second CONNECT statement places it in the dormant state, and the SET CONNECTION statement returns it to the current state.

Parent topic: SQL Statements


SET CURRENT DEGREE

Invocation

SET CURRENT DEGREE is an executable statement that can be embedded in an application program, issued interactively, or dynamically prepared.

Authorization

No special authorization is required.

Syntax

This command is supported only syntactically.

SET CURRENT DEGREE =
    { string-constant | host-variable }

This command is supported only syntactically.

SET CURRENT DEGREE =
    { string-constant | host-variable }

Parameters:

string-constant | When used with DB2, this string constant value must be a character string not longer than three bytes, and enclosed in quotation marks (see DB2 documentation for allowed values).
host-variable | When used with DB2, this host variable value must be a character string not longer than three bytes (see DB2 documentation for allowed values).

Description

On mainframe DB2 systems, this command assigns a value to the CURRENT DEGREE special register. On the XDB Server, this command also places a value in the CURRENT DEGREE special register, although the "degree of parallelism" is not affected. See your DB2 documentation for more information.

Example:

The following example sets the CURRENT DEGREE special register to the string "ANY".

SET CURRENT DEGREE = 'ANY'
Parent topic: SQL Statements
Related information
Syntax Support Only


SET CURRENT LOCALE LC_CTYPE

This command is supported only syntactically by the XDB Server.

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared.

Authorization

None required.

Syntax

SET {[CURRENT [LOCALE]] LC_CTYPE | CURRENT_LC_CTYPE}
    [=]
    {string-constant | host-variable}

Description

The value of CURRENT LOCALE LC_CTYPE is replaced by the string constant or host variable specified. The value must be a CHAR or VARCHAR character string that is no longer than 50 bytes.

If a host variable is specified, its value must not be null. If it has an associated indicator, the value of the indicator value must not indicate a null value. The locale must:

  • Be left justified within the host variable
  • Be padded on the right with blanks if its length is less than that of the host variable

The value of CURRENT LOCALE LC_CTYPE is replaced by the value specified. The value must not be longer than 50 bytes and must be a valid locale.

string-constant

A character string constant that must not be longer than 50 bytes and must represent a valid locale.

host-variable

A variable with a data type of CHAR or VARCHAR and a length that is not longer than 50 bytes. The value of host-variable must not be null and must represent a valid locale. If the host variable has an associated indicator variable, the value of the indicator variable must not indicate a null value.

The locale must:

  • Be left justified within the host variable
  • Be padded on the right with blanks if its length is less than that of the host variable

A locale can be specified in uppercase characters, lowercase characters, or a combination of the two.

Some examples of locales include:

  • Fr_BE
  • Fr_FR@EURO
  • En_US
  • Ja_JP

Example:

Set the CURRENT LOCALE LC_CTYPE special register to the locale 'En_US'.

EXEC SQL SET CURRENT LOCALE LC_CTYPE = 'En_US';
Parent topic: SQL Statements


SET CURRENT MAINTAINED TABLE TYPES FOR OPTIMIZATION

This command is only supported syntactically by the XDB Server.

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared.

Authorization

None required.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

SET CURRENT MAINTAINED [TABLE] TYPES [FOR OPTIMIZATION]
     [=] {ALL | NONE | SYSTEM | USER | host-variable}

Description

The value indicates which materialized query tables that are enabled for optimization are considered when optimizing the processing of dynamic SQL queries.

ALL

Indicates that all materialized query tables will be considered.

NONE

Indicates that no materialized query tables will be considered.

SYSTEM

Indicates that only system-maintained materialized query tables that are refresh deferred will be considered.

USER

Indicates that only user-maintained materialized query tables that are refresh deferred will be considered.

host-variable

A variable of type CHAR or VARCHAR. The length of the contents of host-variable must not exceed 255 bytes. It cannot be set to null. If host-variable has an associated indicator variable, the value of that indicator variable must not indicate a null value.

The characters of host-variable must be left justified. The content of the host variable must be a string that would match what can be specified as keywords for the special register in the exact case intended as there is no conversion to uppercase characters.

Note:
  • The initial value of the CURRENT MAINTAINED TABLE TYPES FOR OPTIMIZATION special register is determined by the value on the CURRENT MAINT TYPES field on installation panel DSNTIP8. The default value of the field is SYSTEM.
  • The CURRENT REFRESH AGE special register needs to be set to a value other than zero in order for the specified types of objects to be considered for optimizing the processing of dynamic SQL queries.
  • The CURRENT MAINTAINED TABLE TYPES FOR OPTIMIZATION special register affects dynamic statement cache matching.
Parent topic: SQL Statements


SET CURRENT OPTIMIZATION HINT

This command is supported only syntactically by the XDB Server.

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared.

Authorization

None required.

Syntax

SET CURRENT OPTIMIZATION HINT = {string-constant | host-variable}

Description

The value of special register CURRENT OPTIMIZATION HINT is replaced by the value of the string constant or host variable. The value must be a character string that is not longer than 8 bytes.

The initial value of the CURRENT OPTIMIZATION HINT special register is set to the value that was used for the OPTHINT bind option. The OPTHINT bind option specifies whether optimization hints are used in determining the access path of static statements and identifies which user-defined hint (rows in the authid.PLAN_TABLE) is used. Therefore, if the SET CURRENT OPTIMIZATION HINT statement is not executed to change the value of the special register, DB2 uses the same optimization hint for dynamic statements that it uses for static statements. The default of OPTHINT for BIND PLAN and BIND PACKAGE is all blanks. All blanks indicate that DB2 uses normal optimization techniques and ignores optimization hints.

Example:

Assume that delimited identifier 'NOHYB' identifies a user-defined optimization hint in authid.PLAN_TABLE. Set the CURRENT OPTIMIZATION HINT special register so that DB2 uses this optimization hint to generate the access path for dynamic statements.

SET CURRENT OPTIMIZATION HINT = 'NOHYB'
Parent topic: SQL Statements


SET CURRENT PACKAGE PATH

This command is only supported syntactically by the XDB Server.

Invocation

This statement can be embedded only in an application program. It is an executable statement that cannot be dynamically prepared.

Authorization

None required.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

SET CURRENT PACKGE PATH [=]
     {collection-id |
      USER |
      CURRENT PACKAGE PATH |
      host-variable |
      string-constant} [,...]
Note: USER, CURRENT PACKAGE PATH, and CURRENT PATH can be specified only once on the right side of the statement.

Description

The value of CURRENT PACKAGE PATH is replaced by the values specified.

collection-id

Identifies a collection. collection-id must not be a delimited identifier that is empty or contains only blanks.

USER

Specifies the value of the USER special register.

CURRENT PACKAGE PATH

Specifies the value of the CURRENT PACKAGE PATH special register before the execution of the SET CURRENT PACKAGE PATH.

CURRENT PATH

Specifies the value of the CURRENT PATH special register.

host-variable

Specifies a host variable that contains one or more collection IDs, separated by commas. The host variable must:

  • Have a data type of CHAR or VARCHAR. The actual length of the contents of the host variable must not exceed the maximum length of the CURRENT PACKAGE PATH special register.
  • Not be the null value if an indicator variable is provided.
  • Contain an empty or blank string, or one or more collection IDs that are separated by commas.
  • Be padded on the right with blanks if the host variable is fixed-length, or if the actual length of the host variable is longer than the content.
  • Not contain a delimited identifier that is empty or contains only blanks.

string-constant

Specifies a string constant that contains one or more collection IDs, separated by commas. The string constant must:

  • Have a length that does not exceed the maximum length of the CURRENT PACKAGE PATH special register.
  • Contain an empty or blank string, or one or more collection IDs separated by commas.
  • Not contain a delimited identifier that is empty or contains only blanks.
Note:
  • The contents of a host variable or string constant are interpreted as a list of collection IDs if the value contains at least one comma. If multiple collection IDs are specified, they must be separated by commas. Each collection ID in the list must conform to the rules for forming an ordinary identifier or be specified as a delimited identifier.
  • No validation that the collections exist is made at the time that the CURRENT PACKAGE PATH special register is set. For example, a collection ID that is misspelled is not detected, which could affect the way subsequent SQL operates. At package execution time, authorization to the specific package is checked, and if this authorization check fails, an error is issued.
  • The special register string is built by taking each collection ID specified and removing trailing blanks, delimiting with double quotation marks, doubling any double quotation marks within the collection ID as necessary, and then separating each collection ID by a comma. If the same collection ID appears more than once in the list, the first occurrence of the collection is used. The length of the resulting list cannot exceed the length of the special register. For example, assume that the following statements are issued:
    SET CURRENT PACKAGE PATH = MYPKGS, "ABC E", SYSIBM
  SET :HVPKLIST = CURRENT PACKAGE PATH

    These statements result in the value of the host variable being set to: "MYPKGS", "ABC E", "SYSIBM". A collection ID that does not conform to the rules for an ordinary identifier must be specified as a delimited collection ID and must not be specified within a host variable or string constant.

  • A difference exists between specifying a single keyword, such as USER, as a single keyword or as a delimited identifier. To indicate that the current value of a special register that is specified as a single keyword should be used in the package path, specify the name of the special register as a keyword. If you specify the name of the special register as a delimited identifier, it is interpreted as a collection ID of that value. For example, assume that the current value of the USER special register is SMITH and that the following statement is issued:
    SET CURRENT PACKAGE PATH = SYSIBM, USER, "USER"

    The result is that the value of the CURRENT PACKAGE PATH special register is set to: "SYSIBM, "SMITH", "USER".

  • Because a host variable (SQL variable) in an SQL procedure does not begin with a colon, DB2 uses the following rules to determine whether a value that is specified in a SET PACKAGE PATH = name statement is a variable or a collection ID:
    • If name is the same as a parameter or SQL variable in the SQL procedure, DB2 uses name as a parameter or SQL variable and assigns the value in name to the package path.
    • If name is not the same as a parameter or SQL variable in the SQL procedure, DB2 uses name as a collection ID and assigns and the value in name is the package path.
  • The SET CURRENT PACKAGE PATH statement is executed by the database server and, therefore, is classified as a non-local SET statement in DRDA. The SET CURRENT PACKAGE PATH statement requires a new level of DRDA support. If SET CURRENT PACKAGE PATH is issued when connected to the local server, the SET CURRENT PACKAGE PATH special register at the local server is set. Otherwise, when SET CURRENT PACKAGE PATH is issued when connected to a remote server, the SET CURRENT PACKAGE PATH special register at the remote server is set.
Parent topic: SQL Statements


SET CURRENT PACKAGESET

Invocation

SET CURRENT PACKAGESET is an executable statement that can only be embedded in an application program. It cannot be dynamically prepared.

Authorization

No special authorization is required.

Syntax

SET CURRENT PACKAGESET =
    { USER | string-constant | host-variable }

Parameters:

USER | The value contained in the USER special register.
string-constant | When used with DB2, this string constant value must be a character string not longer than 128 bytes, and enclosed in quotation marks (see DB2 documentation for allowed values).
host-variable | The CURRENT PACKAGESET special register value can be assigned to a host variable in your program using the SET Host Variable command. When used with DB2, this host variable value must be a character string not longer than 128 bytes (see DB2 documentation for allowed values).

Description

In DB2, each program is bound with a default SQLID. Likewise, each package accessed by a program can be bound with a different default SQLID. The AuthID values comprising these various default SQLIDs must somehow be retrieved into the CURRENT SQLID special register within XDB Server whenever package access changes during program execution. The contents of the CURRENT SQLID special register provides the implicit AuthID qualifier support necessary for one-part table names, and this register value must be updated to match the default SQLID of the currently executing package.

The XDB Server does not directly support binding, but emulates this functionality by retrieving default package SQLIDs into the CURRENT SQLID special register. This retrieval needs to happen whenever a SET CURRENT PACKAGESET command switches package access within an executing program. Therefore, the value of the CURRENT SQLID special register in XDB Server can change depending on the name of the executing program, and the contents of the CURRENT PACKAGESET special register.

XDB Server Precompiler

To take advantage of the packageset functionality above, the program must be precompiled using the PKGSET directive. This directive causes the program name to be passed to the engine for all SQL calls within any program precompiled with this directive. The engine, in turn, uses the program name to look up package information in the system tables.

System Tables

Records must also be manually added to the SYSIBM.SYSPACKLIST and SYSIBM.SYSPACKAGE tables for all programs requiring packageset functionality. These tables will be automatically created with the CREATE LOCATION command. Alternatively, they will be created when a package command is issued. To create these system tables in an existing location, issue the following command from SQLWizard:

SET CURRENT PACKAGESET = 'test'

The records for these tables currently need to be added manually (using SQLWizard or Migrate.). Ideally, these records can be imported directly from DB2. The XDB Server software does not add these records automatically at precompile and compile time. Because these are system tables, the user who edits the records must be a super user. The only record fields that must be added to the SYSIBM.SYSPACKAGE table are the LOCATION, COLLID and QUALIFIER column values. All other data is inconsequential. Likewise, the only field values that must be added to the SYSIBM.SYSPACKLIST table are the LOCATION and COLLID column values.

The SET CURRENT PACKAGESET command functional support consists of the following steps:

  1. When a program precompiled with the PKGSET directive accesses the engine the following query is performed:
    SELECT x.qualifier, x.collid, y.seqno
    FROM sysibm.syspackage x, sysibm.syspacklist y
    WHERE y.name IN ('*', program_name)
      AND y.location IN (' ', current_location)
      AND x.collid = y.collid
      AND x.name = program_name
    ORDER BY y.seqno
  2. If the CURRENT PACKAGESET special register is not empty, the following predicate will be added to the query above:
    AND x.collid = current_packageset_special_register
  3. If a record matches the criteria, the CURRENT SQLID special register is updated with the QUALIFIER column contents of the first record retrieved by the query (lowest SEQNO column value). This new value becomes the implicit AuthID for one-part table names.
  4. Once a value is retrieved for a particular program name and package combination, it is cached. Subsequent calls check the cache prior to checking the catalog using the above query.
  5. If either the program name (due to a subroutine call) or CURRENT PACKAGESET special register (due to a SET CURRENT PACKAGESET COMMAND) changes, an automatic lookup is triggered and the CURRENT SQLID is changed accordingly.

special register with stored procedures and user-defined functions

The initial value of the CURRENT PACKAGESET special register in a stored procedure or user-defined function is the value of the COLLID parameter with which the stored procedure or user-defined function was defined. If the routine was defined without a value for the COLLID parameter, the value of the special register is inherited from the calling program. A stored procedure or user-defined function can use the SET CURRENT PACKAGESET statement to change the value of the special register. This allows the routine to select the version of the DB2 package that is used to process the SQL statements in a called routine that is not defined with a COLLID value.

Example:

The following example assigns a value of 'Staff' to the CURRENT PACKAGESET special register.

SET CURRENT PACKAGESET = 'Staff'
Parent topic: SQL Statements


SET CURRENT PATH

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared.

Authorization

None required.

Syntax

SET {[CURRENT [FUNCTION]] PATH | CURRENT_PATH} [=]
{   schema-name
    | SYSTEM PATH
    | USER
    | {[CURRENT [FUNCTION]] PATH | CURRENT_PATH}
    | CURRENT PACKAGE PATH
    | host-variable
    | string-constant
} [,...]

Description

The value of CURRENT PATH is replaced by the values specified.

schema-name
Identifies a schema. DB2 does not verify that the schema exists. For example, a schema name that is misspelled is not detected, which could affect the way subsequent SQL operates.
SYSTEM PATH
Specifies the schema names "SYSIBM", "SYSFUN" , "SYSPROC". SYSTEM PATH can be specified only once.
USER
Specifies the value of the USER special register. USER can be specified only once.
CURRENT PATH
Specifies the value of the CURRENT PATH special register before the execution of this statement. CURRENT PATH can be specified only once.
host-variable
A variable with a data type of CHAR or VARCHAR. The value of host-variable must not be null and must represent a valid schema name.

The schema name must:

  • Be left justified within the host variable
  • Be padded on the right with blanks if its length is less than that of the host variable
string-constant

A character string constant that represents a valid schema name.

If the schema name specified in string-constant will also be specified in other SQL statements and the schema name does not conform to the rules for ordinary identifiers, the schema name must be specified as a delimited identifier in the other SQL statements.

Restrictions on SET CURRENT PATH
These restrictions apply to the SET CURRENT PATH statement:
  • If the same schema name appears more than once in the path, the first occurrence of the name is used and a warning is issued.
  • The length of the CURRENT PATH special register limits the number of schema names that can be specified. DB2 builds the string for the special register by taking each schema name specified and removing any trailing blanks from it, adding two delimiters around it, and adding one comma after each schema name except the last one. The length of the resulting string cannot exceed 254 bytes.
Specifying SYSIBM and SYSPROC
Schemas SYSIBM and SYSPROC do not need to be specified in the special register. If either of these schemas is not explicitly specified in the CURRENT PATH special register, the schema is implicitly assumed at the front of the SQL path; if both are not specified, they are assumed in the order of SYSIBM, SYSPROC.
Specifying USER versus "USER"

There is a difference between specifying USER with and without escape characters. To indicate that the value of the USER special register should be used in the SQL path, specify the keyword USER. If you specify USER as a delimited identifier instead (for example, "USER"), it is interpreted as a schema name of "USER". For example, assuming that the current value of the USER special register is SMITH, SET CURRENT PATH = SYSIBM, SYSPROC, USER, "USER" results in SYSIBM, SYSPROC, SMITH, USER being used in the SQL path.

Specifying a schema name in an SQL procedure

Because a host variable (SQL variable) in an SQL procedure does not begin with a colon, DB2 uses the following rules to determine whether a value that is specified in a SET CURRENT PATH=name statement is a variable or a string constant:
  • If name is the same as a parameter or SQL variable in the SQL procedure, DB2 uses name as a parameter or SQL variable and assigns the value in name to CURRENT PATH.
  • If name is not the same as a parameter or SQL variable in the SQL procedure, DB2 uses name as a string constant and assigns the value name to CURRENT PATH.

Examples:

Set the CURRENT PATH special register to the list of schemas: "SCHEMA1", "SCHEMA#2", "SYSIBM".

SET CURRENT PATH = SCHEMA1,"SCHEMA#2", SYSIBM;

If the special register provides the SQL path, then SYSPROC, which was not explicitly specified in the special register, is implicitly assumed at the front of the SQL path, making the effective value of the path:

SYSPROC, SCHEMA1, SCHEMA#2, SYSIBM
Parent topic: SQL Statements


SET CURRENT REFRESH AGE

The CURRENT REFRESH AGE value corresponding to ANY (99 999 999 999 999) cannot be used in timestamp arithmetic operations because the result would be outside the valid range of dates.

This command is only supported syntactically by the XDB Server.

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared.

Authorization

None required.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

SET CURRENT REFRESH AGE [=] {numeric-constant | ANY | host-variable}

numeric-constant

A DECIMAL(20,6) value representing a timestamp duration. The value must be 0 or 99 999 999 999 999, the microseconds of which is ignored and thus can be any value.

0 | Indicates that query optimization using materialized query tables will not be attempted.
99999999999999 | Indicates that any materialized query tables identified by the CURRENT MAINTAINED TABLE TYPES FOR OPTIMIZATION special register may be used to optimize the processing of a query. This value represents 9999 years, 99 months, 99 days, 99 hours, 99 minutes, and 99 seconds.

ANY

Shorthand for 99999999999999.

host-variable

A variable of type DECIMAL(20,6) or other type that is assignable to DECIMAL(20,6). It cannot be set to null. If host-variable has an associated indicator variable, the value of that indicator variable must not indicate a null value. The value of host-variable must be 0 or 99 999 999 999 999, the microseconds of which is ignored and thus can be any value.

Note:
  • Materialized query tables created or altered with DISABLE QUERY OPTIMIZATION specified are not eligible for automatic query rewrite. Thus, they are not affected by the setting of this special register.
  • Setting the CURRENT REFRESH AGE special register to a value other than zero should be done with caution. Allowing a materialized query table that may not represent the values of the underlying base table to be used to optimize the processing of a query may produce results that do not accurately represent the data in the underlying table. This situation may be acceptable when you know the underlying data has not changed or you are willing to accept the degree of error in the results based on your knowledge of the data.
Parent topic: SQL Statements


SET CURRENT RULES

Invocation

SET CURRENT RULES is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

None required.

Syntax

SET CURRENT RULES = {'DB2' | 'STD' | host-variable}

Parameters:

DB2 | Causes commands to execute according to DB2 rules.
STD | Causes commands to execute according to ANSI/ISO rules.
host-variable | Names a host variable (character string not longer than eight bytes) containing the value to be assigned to the special register CURRENT RULES. The value must be either 'DB2' or 'STD', and must be a character string three bytes in length.

Description

This statement replaces the value of the CURRENT RULES special register with the value of the string constant or host variable. The functionality of this command is identical to the XDB Server command SET COMPATIBILITY. One particular application of this special register value is that it controls the way table check constraints are enforced. The contents of CURRENT RULES chooses one of two distinct SQL rules that will apply to already populated tables containing check constraints. If the value is STD, a check constraint is enforced as soon as it is defined. If a row does not conform, the table check constraint is not added to the table and an error occurs. If the value is DB2, the check constraint is added to the table description but its enforcement is deferred. Because there might be rows in the table that violate the check constraint, the table is placed in check pending status.

Example:

The example below sets the CURRENT RULES special register to a value of DB2.

SET CURRENT RULES = 'DB2'
Parent topic: SQL Statements


SET CURRENT SQLID

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared. The value to which special register CURRENT SQLID is set is used as the SQL authorization ID and the implicit qualifier for dynamic SQL statements only if DYNAMICRULES run behavior is in effect. The CURRENT SQLID value is ignored for the other DYNAMICRULES behaviors.

Authorization

In most cases, the CURRENT SQLID value must equal one of the AuthIDs of the session. If one of these session AuthIDs possesses SYSADM authority for the location, then CURRENT SQLID can be set to any valid AuthID within the location.

Syntax

SET CURRENT SQLID = {USER | string-constant | host-variable}

Parameters:

USER | Is the special register USER, containing a valid AuthID of the session.
string-constant | A character string -- not longer than eight bytes and surrounded by quotes -- identifying a valid AuthID of the session.
host-variable | Identifies a host variable containing a character string (not longer than eight bytes) identifying a valid AuthID of the session.

Description

The initial value of the SQL AuthID (SQLID) is established during connection or XDB Server log on. The value specified in the SET CURRENT SQLID statement remains the SQLID until the XDB Server connection is terminated, the SQLID is changed by executing a new SET CURRENT SQLID statement or when a SET LOCATION command is issued. SET LOCATION resets the SQLID to either the Primary AuthID value stored in CONFIG.XDB (if security is off) or the initial Primary AuthID value established during your security login.

The CURRENT SQLID value is the AuthID used for authorization checking on CREATE, GRANT and REVOKE statements. CURRENT SQLID is also used in all other permission situations, such as SELECT statements or any other DML commands.

Additionally, the CURRENT SQLID owns whatever table spaces, databases, storage groups, or synonyms that are created. CURRENT SQLID is also the implicit AuthID qualifier of all table, view, alias, and index names specified in any SQL statements.

Interactive SQL

When you enter an interactive SQL session, the default AuthID becomes the initial value of the CURRENT SQLID special register. The initial value of this register can also be controlled by a SecondaryIDs specified with the SQLWizard Admin Menu commands or a security exit. The CURRENT SQLID special register retains this default value until you issue a SET CURRENT SQLID command -- replacing the initial AuthID value of CURRENT SQLID with another valid primary AuthID.

Changing CURRENT SQLID

During an interactive SQL session, the AuthID value stored within the CURRENT SQLID special register can be changed only by issuing a SET CURRENT SQLID command (or a SET PACKAGESET command). From that point on, the new AuthID value becomes the owner of any databases, tables, or synonyms created within that interactive SQL session. This new AuthID also becomes the implicit qualifier of all table, view, alias, and index names appearing in any SQL statements issued within the interactive SQL session.

Security

Whenever you start an XDB Server session with security off, the Primary AuthID value specified in the Options Utility becomes the CURRENT SQLID for that XDB Server session. If the Primary AuthID specified in the User Profile maps to a SecondaryID, then that SecondaryID becomes the default session SQLID. When security is on and you start an XDB Server session, the UserID entered becomes the CURRENT SQLID. If the UserID entered by the user has a SecondaryID, then the SecondaryID becomes the CURRENT SQLID.

Parent topic: SQL Statements


SET Host Variable

Invocation

SET Host Variable is an executable statement that can only be embedded in a host program. The statement cannot be dynamically prepared.

Authorization

The privileges that are held by the current authorization ID must include those required to execute any of the expressions.

Syntax

SET host-variable =
{   {CURRENT SERVER | CURRENT PACKAGESET}
    | host-variable = {expression | NULL}
    | (host-variable[,...]) = ({expression | NULL} [,...] | VALUES {{expression | NULL} | ({expression | NULL}[,...])}})}

Parameters:

host-variable | Identifies one or more host variables or transition variables that are used to receive the corresponding expression or NULL value on the right side of the statement.
expression | Specifies the value to be assigned to the corresponding host-variable.
special-register | Names the special register value to be placed in the host variable.

Description

If the SET Assignment statement is used in the triggered action of a CREATE TRIGGER statement, each host-variable must identify a transition variable. If the statement is used in any other context, each host-variable must identify a host variable.

The value to be assigned to each host-variable can be specified immediately following the item reference, for example, host-variable = expression, host-variable=expression. Or, sets of parentheses can be used to specify all the host-variables and then all the values, for example, (host-variable, host-variable) = (expression, expression).

Each host variable must be defined in the program as described under the rules for declaring host variables. A parameter marker must not be specified in place of host-variable.

When the host-variables are enclosed within parentheses, for example, (host-variable, host-variable, ...) = (expression, expression, ...), the first value is assigned to the first host variable in the list, the second value to the second host variable in the list, and so on.

Specifies the null value and can only be specified for host variables that have an associated indicator variable.

Specifies the value to be assigned to the corresponding host variable. When more than one value is specified, the values must be enclosed in parentheses. Each value can be an expression or NULL, as described above. The following syntax is equivalent:

(host-variable, host-variable) = (VALUES(expression, NULL))

(host-variable, host-variable) = (expression, NULL)

Local special registers can be referenced only in a VALUES host-variable statement that results in the assignment of a single host variable and not those that result in setting more than one value.

Special registers that can be defined to a host variable include:

CURRENT DATE | CURRENT PACKAGESET
CURRENT TIME | CURRENT SERVER
CURRENT TIMESTAMP | CURRENT SQLID
CURRENT TIMEZONE | USER

For example: SET :your-var-name = CURRENT SERVER

The value of CURRENT SQLID can be changed by issuing a SET CURRENT SQLID command. The CURRENT PACKAGESET special register (and the SET CURRENT PACKAGESET command) currently have limited functional support by the XDB Server.

For information about each of these special registers, see Special Registers.

Parent topic: SQL Statements


SET Transitional Variable

Invocation

This statement can be used as a triggered SQL statement in the triggered action of a before trigger whose granularity is FOR EACH ROW.

Authorization

The privileges that are held by the current authorization ID must include those required to execute any of the expressions or assignments to transition variables.

Syntax

SET transition-variable =
{   {expression | NULL}
    | (transition-variable[,...]) = ({{expression | NULL} | VALUES {{expression | NULL} | ({expression | NULL}[,...])})
}

Description

Identifies a column in the set of affected rows for the trigger that is used to used to receive the corresponding expression or NULL value on the right side of the statement.

The value to be assigned to each transition-variable can be specified immediately following the transition variable, for example, transition-variable = expression, transition-variable=expression. Or, sets of parentheses can be used to specify all the transition-variables and then all the values, for example, (transition-variable, transition-variable) = (expression, expression).

correlation-name | Identifies the correlation name given for referencing the NEW transition variables. The name must match the correlation name specified following NEW in the REFERENCING clause of the CREATE TRIGGER statement.
 | If OLD is not specified in the REFERENCING clause, correlation-name defaults to the correlation name following NEW.
column-name | Identifies the column to be updated. The name must identify a column of the triggering table. The name can identify an identity column that is defined as GENERATED BY DEFAULT but not one defined as GENERATED ALWAYS. You must not specify the same column more than once.
 | The effect of a SET transition-variable statement is equivalent to the effect of an SQL UPDATE statement.

Specifies the value to be assigned to the corresponding transition-variable. A reference to a local special register is the value of that special register at the server when the trigger body is activated.

An expression can contain references to OLD and NEW transition variables that are qualified with a correlation name.

All expressions are evaluated before any result is assigned to a transition variable. If an expression refers to a transition variable that is used in the list of transition variables, the value of the variable in the expression is the value of the variable prior to any assignments.

Assignments are made in sequence through the list. When the transition-variables are enclosed within parentheses, for example, (transition-variable, transition-variable, ...) = (expression, expression, ...), the first value is assigned to the first transition variable in the list, the second value to the second transition variable in the list, and so on.

Specifies the null value and can only be specified for nullable transition variables.

Specifies the value to be assigned to the corresponding transition variable. When more than one value is specified, the values must be enclosed in parentheses. Each value can be an expression or NULL, as described above. The following syntax is equivalent:

  • (transition-variable, transition-variable) = (VALUES(expression, NULL))
  • (transition-variable, transition-variable) = (expression, NULL)

Assume that you want to create a before trigger that sets the salary and commission columns to default values for newly inserted rows in the EMPLOYEE table and that you will define the trigger only with NEW in the REFERENCING clause. Write the SET statement that assigns the default values to the SALARY and COMMISSION columns.

SET (SALARY, COMMISSION) = (50000, 8000);
Parent topic: SQL Statements


SET ISOLATION

Invocation

SET ISOLATION is an executable XDB Server utility command that can be issued interactively or embedded in a host language. SET ISOLATION can be dynamically prepared.

Authorization

SYSADM or SYSCTRL authority for the location is required for setting isolation level to EU (exclusive use).

Syntax

SET ISOLATION { EU | RR | CS | LC | DR | SR }

Parameters:

EU (Exclusive Use) | Locks the database for the exclusive use of the user issuing the command.
RR (Repeatable Read) | Guarantees identical results if the user issues the same SQL query more than once in a transaction. This isolation level provides minimum concurrency and maximum consistency.
CS (Cursor Stability) | Creates a lock on a record that allows the record to be read but not modified. This lock is held only while the record is the current record. Locks on modified records are held until the transaction is committed. Shared table locks can be unlocked before the end of a transaction using the UNLOCK TABLE command. The CS isolation level provides more concurrency and less consistency than RR.
LC (Lock Current) | Holds a lock on a record only while it is the current record. The LC isolation level provides a high degree of concurrency, and a very low degree of consistency, unless used for read-only operations, or with autocommit on.
DR (Dirty Read) or UR (Uncommitted Read) | Does not acquire locks on records, but reads records regardless of the locks held by others. This isolation level is be used strictly for read-only operations.
SR (Snapshot Read) | Causes a snapshot of the data to be made at the time of execution. Other users can make changes to the data without waiting for the transaction to complete, and the user is ensured that the data will be the same for the life of the transaction. The transaction is limited to read-only operations.

Description

The XDB Server permits you to set an isolation level to control the concurrency and consistency within a multi-user environment.

As described above, six isolation levels are supported. Both Repeatable-Read (RR) and Cursor Stability (CS) provide the following data isolation from other users:

  • An active transaction cannot modify or read any data which other active transactions have modified.
  • A transaction cannot modify a record currently being read by another transaction.

In addition, under Repeatable-Read (RR) no active transaction can modify a record which has been read by another active transaction specifying an RR level of isolation.

Cursor Stability (CS) is used if your application will generate or encounter many lock conflicts.

Exclusive Use (EU) locks are used for those procedures that require that the database be in a quiet state.

Lock Current (LC) locks are used for read-only operations or with autocommit set on. With autocommit on, this level of isolation is very useful for interactive sessions.

Example:

Some sample SET ISOLATION commands appear below:

SET ISOLATION EU
SET ISOLATION RR
SET ISOLATION CS
SET ISOLATION LC
SET ISOLATION DR
SET ISOLATION SR
Note:

If the isolation level is set to any setting other than Repeatable Read, for optimization the isolation level is changed to Dirty Read whenever an ORDER BY or GROUP BY is performed. In future versions of the XDB Server, the isolation level optimization will be configurable by the user.

Parent topic: SQL Statements


SET LOCATION TO

Invocation

SET LOCATION is an executable XDB Server utility command that can be issued interactively or embedded in a host language. SET LOCATION can be dynamically prepared.

Authorization

Users must have the CONNECT privilege on the new location, as well as authority to access and/or modify objects stored at that location.

Syntax

SET LOCATION TO location-name

Parameters:

location-name Identifies a location accessible to the XDB Server.

Description

All XDB Server operations are performed and recorded under the currently set (or default) XDB Server location. The default value of the CURRENT SERVER special register is maintained in the XDB Server configuration file CONFIG.XDB. To create objects in a location other than the current location, use the SET LOCATION statement prior to entering other SQL statements.

Use of this command does not permanently change the user's current location, but only sets the location for the commands that immediately follow. The location remains set until the user either issues another SET LOCATION command or exits the utility where the SET LOCATION command was issued.

The SET LOCATION command differs in several respects from the CONNECT command. The CONNECT command can be used only in embedded SQL, and refers solely to locations recorded in the SYSIBM.SYSLOCATIONS catalog table (which includes remote locations). The SET LOCATION command, also refers to locations recorded in the SYSXDB.SYSLOCALS catalog table (which must be local).

XDB Link Locations

If you issue a SET LOCATION command to an XDB Link location, you cannot return to your XDB Server by issuing another SET LOCATION command (DB2 cannot read XDB Server catalog tables). If your application needs this type of functionality, use the CONNECT and CONNECT RESET commands from embedded SQL.

Example:

Take a typical scenario where the user is connected to LOC1 as the current default location, but the user needs to temporarily access another location (LOC2) in order to create a database object there. This user could access SQLWizard and issue the following command:

SET LOCATION TO loc2

All transactions for that user in the current (old) location are automatically committed and acquired locks released. Any SQL commands issued next (object creation or otherwise) operate on the new location specified above. When the user exits SQLWizard, the original default location (LOC1) returns.

Note:

The XDB Server 2.4x (and earlier) SET DATABASE command syntax can still be used to change the active location. However, a location name must be used for the argument.

Parent topic: SQL Statements


SET LOCATION

Note:

The XDB Server does not allow you to take a location offline while it is in use. You can use the DISABLE LOGIN command to prevent new users from logging on to the server. If you need to take the location offline immediately, you can force active users off the location using the XDB Server Monitor.

Invocation

This command can be embedded in a host language or executed interactively.

Authorization

Any of the following:

  • A super user
  • A user with SYSADM privileges

Syntax

SET LOCATION location-name {OFFLINE | ONLINE}

Parameters:

location-name Identifies the location that you want to place online or offline.
Parent topic: SQL Statements


SET LOG

Invocation

SET LOG is an executable XDB Server utility command that can be issued interactively or embedded in a host language. SET LOG can be dynamically prepared.

Authorization

Database Administrator, Install or SYSADM authority is required to turn the logging system on or off or to set the path where logging files are stored.

Syntax

SET LOG {ON | OFF}
SET LOG FOR location-name TO path-name WITH {MOVE | COPY}

SET LOG FOR location-name TO path-name
         ( ROLLFORWARD [OFF | ON] |
           LOG FILE SIZE n        |
           ROLLFORWARD {OFF | ON} LOG FILE SIZE n }
    WITH RESTART}

SET LOG FOR location-name
         ( ROLLFORWARD [OFF | ON] |
           LOG FILE SIZE n        |
           ROLLFORWARD {OFF | ON} LOG FILE SIZE n }
    WITH REPLACE}

Parameters:

location-name | Identifies an existing XDB Server location.
path-name | New path for the location log files.
n | An integer specifying the new maximum size (in kilobytes) of an individual log file..

Description

The XDB Server automatically maintains a series of log files for each XDB Server location for use in recovery. This new logging system is normally always defaulted to on. The SET LOG command accommodates the location structure of the XDB Server. Log files operate on a specified XDB Server location, recording all changes made to any objects in that location. The directory path where the log files are stored can be changed using the TO path-name option.

Log files record all changes made to the location since the last back up. In the event of a media failure, the log files can be replayed against a backup copy of the location tables, reconstructing the location data to the state immediately preceding the system failure.

The SET LOG command automatically commits the current transaction. See the Server Administration Guide for more information about backup and recovery options.

Interactive SQL

If you have SYSADM authority or higher and exclusive use of the location, you can temporarily turn the logging system off. When issued from SQLWizard, the SET LOG OFF command temporarily suspends logging for the location during the remainder of the current session. Turning logging off for a particular location is a temporary expedient for an exclusive user that does not want to incur the overhead of logging during administrative tasks.

Logging is turned off for the current session, only. Logging can be activated again in the current session by issuing a SET LOG ON command. Exiting the session toggles the status of location logging back to on (the default). The next session that accesses the location therefore has logging turned on. Setting the logging system on or off from an interactive SQL session does not affect the logging configuration settings in your XDBSRVCO.INI file.

ROLLFORWARD [ OFF | ON ]

If set to Off, this keyword deletes old, unneeded logs automatically. If set to On, this keyword keeps log files.

MOVE

This keyword copies (deleting the originals) all logs files from the named location to the path indicated by path-name, and also changes the current log path for the location to the new path named.

COPY

This keyword copies all logs files from the named location to the path indicated by path-name, and also changes the current log path for the location to the new path named.

RESTART

This keyword closes all log files on the current location log file path and opens new log files in the path indicated by path-name. The log path for the named location is also changed to the new path.

REPLACE

This keyword replaces all log files in the current log file path with new log files. The log path for the log file location stays the same.

Discontinued Commands

Because XDB Server Version 5.0 and above no longer support Forward or Backward logs, the old SET FORWARD LOG and SET BACKWARD LOG commands have been discontinued and replaced with the new SET LOG command. The FWDLOGON field in the SYSXDB.SYSLOCALS system table is no longer used.

Comments

If you are setting the value of LOG FILE SIZE or ROLLFORWARD, you cannot specify WITH COPY or WITH MOVE. If the TO path has not been specified, you must specify WITH REPLACE; in this case, the old logs will be removed and replaced with new logs. If the TO path is specified, you must specify WITH RESTART when moving the logs; in this case, the old logs will be left in the old path and the new log files will be created in the new path.

The XDBSTAT.LOGINFO table is available in all local locations. Querying this table gives the current settings for the log files in that particular location. The columns within the table are:

LOG_PATH | Contains the path to the log files for the location.
LOG_STATE | Shows the state of the logs as either CLEAN or DIRTY to indicate whether a transaction has modified the log files.
LOG_VERSION | Internal XDB logging version.
ROLLFORWARD_STATUS | Shows either OFF or ON, where OFF means that logs no longer required for transaction rollback will be purged at the next checkpoint, and ON means that logs will never be purged by the XDB Server.
LOG_FILE_SIZE | Maximum size in bytes of an individual log file. New log files will be created once this limit has been reached.

ExampleS:

The SET LOG command only requires the name of the location when changing the log file path using the MOVE, COPY or RESTART keywords. To turn OFF logging for the current location, issue the following command:

SET LOG OFF

To turn logging back ON for the current location, issue the following command:

SET LOG ON

You can also use the SET LOG command to change the directory where the location's log files will be stored. For example:

SET LOG FOR tutorial TO d:\recover WITH COPY
SET LOG FOR tutorial TO d:\log-path2 WITH MOVE
SET LOG FOR tutorial TO d:\log-path2 WITH RESTART
Parent topic: SQL Statements


SET SCHEMA

Restriction: This command is only supported syntactically by the XDB Server.

Invocation

This statement can be embedded in an application program or issued interactively. It is an executable statement that can be dynamically prepared.

Authorization

None required.

Syntax

Bold text indicates clauses or options that are supported only syntactically.

SET {SCHEMA | CURRENT SCHEMA | CURRENT_SCHEMA} [=]
     {schema-name |
      USER |
      host-variable |
      string-constant |
      DEFAULT}

Description

schema-name
Identifies a schema. No validation that the schema exists is made at the time the CURRENT SCHEMA is set. For example, if a schema name is misspelled, it could affect the way subsequent SQL operates.
USER
Specifies the value of the USER special register.
host-variable
Specifies a host variable that contains a schema name. The content is not folded to uppercase. The host variable must:
  • Be a CHAR, VARCHAR, GRAPHIC, or VARGRAPHIC variable. The actual length of the contents of the host-variable must not exceed the length of a schema name.
  • Not be set to null. If host-variable has an associated indicator variable, the value of that indicator variable must not indicate a null value.
  • Include a schema name that is left justified and conforms to the rules for forming an ordinary identifier or delimited identifier. If the identifier is delimited, it must not be empty or contain only blanks.
  • Be padded on the right with blanks if the host variable is fixed length.
  • Not contain USER or DEFAULT.
string-constant
Specifies a string constant that contains a schema name. The content is not folded to uppercase. The string constant must:
  • Have a length that does not exceed the maximum length of a schema name.
  • Include a schema name that is left justified and conforms to the rules for forming an ordinary identifier or delimited identifier. If the identifier is delimited, it must not be empty or contain only blanks.
  • Not contain USER or DEFAULT.
DEFAULT
Specifies that CURRENT SCHEMA is to be set to its initial value, as if it had never been explicitly set during the application process.
Note:
  • There is a difference between specifying a single keyword (such as USER or DEFAULT) as a single keyword or as a delimited identifier. To indicate that the current value of the USER special register should be used for setting the current schema, specify USER as a keyword. To indicate that the special register should be set to its default value, specify DEFAULT as a keyword. If USER or DEFAULT is specified as a delimited identifier instead (for example, "USER"), it is interpreted as a schema name of that value ("USER").
  • The SET SCHEMA statement is not a commitable operation. ROLLBACK has no effect on CURRENT SCHEMA.
  • The value of the CURRENT SCHEMA special register, as set by this statement, is used as the schema name in all dynamic SQL statements. The QUALIFIER bind option specifies the schema name for use as the qualifier for unqualified database object names in static SQL statements.
  • Setting the CURRENT SCHEMA special register does not affect any other special register. Therefore, the CURRENT SCHEMA is not be included in the SQL path that is used to resolve the schema name for unqualified references to function, procedures and user-defined types in dynamic SQL statements. To include the current schema value in the SQL path, whenever the SET SCHEMA statement is issued, also issue the SET PATH statement including the schema name from the SET SCHEMA statement.
Parent topic: SQL Statements


SET SORTSPACE

The new sort space size remains in effect until you restart the server or execute another SET SORTSPACE command.

Note:

This command does not write the SORTSPACE value to the server's configuration file, so that when you restart the server, sort space is reset to its original size.

Invocation

This command can be embedded in a host language or executed interactively.

Authorization

Any of the following:

  • A super user
  • A user with SYSCTRL or SYSADM privileges

Syntax

SET SORTSPACE=Kbytes
SET SORTSPACE=1000

Parameters:

bytes Is the size of the sort space in kilo-bytes. See the Server Administration Guide for guidelines on setting an appropriate size.

For example, the following command sets the sort space to roughly one megabyte (1 million bytes):

SET SORTSPACE=1000
Parent topic: SQL Statements


SHUTDOWN

Invocation

This command can embedded in a host language or executed interactively.

Authorization

Any of the following:

  • A super user
  • A user with SYSADM or SYSCTRL privileges

Syntax for SHUTDOWN AT

Use this command to shut down the server at a specific time or on a specific date. The syntax appears below:

SHUTDOWN AT {date-constant | time-constant | timestamp-constant}

For example:

SHUTDOWN AT 23:30:10
SHUTDOWN AT 10/09/1991
SHUTDOWN AT "1991-10-09-23.30.10.0"

Note that the timestamp value must be in double quotes. All users will be rolled back before shutdown.

Syntax for SHUTDOWN IN

Use this command to shut down the server in a specified length of time. The syntax appears below:

SHUTDOWN IN integer-constant duration
integer-constant | Represents any short or long integer.
duration | Represents a time duration descriptor.

For example:

SHUTDOWN IN 10 seconds
SHUTDOWN IN 2 hours
SHUTDOWN IN 6 months

All users will be rolled back before shutdown.

Syntax for SHUTDOWN ON LAST DISCONNECT

Use this command to shut down the server when the last user logs off the system. SHUTDOWN ON LAST DISCONNECT does not prevent new users from logging on to the server while the SHUTDOWN command is pending-- contrast this command with SHUTDOWN QUIESCE, below. If any new users log on to the server while the command is pending, the server will not shut down until after those users disconnect.

The syntax appears below:

SHUTDOWN ON LAST DISCONNECT

Syntax for SHUTDOWN QUIESCE

Use this command to disable new login requests and shut down the server when the last user logs off the system. SHUTDOWN QUIESCE prevents new users from logging on to the server while the SHUTDOWN command is pending-- contrast this command with SHUTDOWN ON LAST DISCONNECT, above.

The syntax appears below:

SHUTDOWN QUIESCE

Syntax for SHUTDOWN CANCEL

Use this command to cancel a SHUTDOWN command that is pending. The syntax appears below:

SHUTDOWN CANCEL
Parent topic: SQL Statements


SIGNAL SQLSTATE

Invocation

This statement can only be used in the triggered action of a trigger.

Authorization

None required.

Syntax

SIGNAL SQLSTATE sqlstate-string-constant
    (diagnostic-string-constant)

sqlstate-string-constant

Represents an SQLSTATE. It must be a character string constant with exactly 5 characters that follow these rules for application-defined SQLSTATEs:

  • Each character must be from the set of digits ('0' through '9') or non-accented uppercase letters ('A' through 'Z').
  • The SQLSTATE class (first two characters) cannot be '00', '01' or '02' because these are not error classes.
  • If the SQLSTATE class (first two characters) starts with the character '0' through '6' or 'A' through 'H', the subclass (last three characters) must start with a character in the range 'I' through 'Z'.
  • If the SQLSTATE class (first two characters) starts with the character '7', '8', '9', or 'I' through 'Z', the subclass (last three characters) can be any of '0' through '9' or 'A' through 'Z'.

diagnostic-string-constant

A character string of up to 70 bytes that describes the error condition. If the string is longer than 70 bytes, it is truncated.

Example:

Consider a trigger for an order system that allows orders to be recorded in an ORDERS table (ORDERNO, CUSTNO, PARTNO, QUANTITY) only if there is sufficient stock in the PARTS tables. When there is insufficient stock for an order, SQLSTATE '75001' is returned along with an appropriate error description.

CREATE TRIGGER CK_AVAIL
    NO CASCADE BEFORE INSERT ON ORDERS
    REFERENCING NEW AS NEW_ORDER
    FOR EACH ROW MODE DB2SQL
    WHEN (NEW_ORDER.QUANTITY > (SELECT ON_HAND FROM PARTS
                                    WHERE NEW_ORDER.PARTNO = PARTS.PARTNO))
        BEGIN ATOMIC
            SIGNAL SQLSTATE '75001' ('Insufficient stock for order');
        END
Parent topic: SQL Statements


START DATABASE

Invocation

START DATABASE is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

To execute the START DATABASE command, users must possess either overall SYSADM, SYSCTRL for the location, DBADM authority on the database, or the STARTDB privilege for the database.

Syntax

START DATABASE (database-name) [ACCESS (RW | RO)]

Parameters:

database-name Identifies the database to be started.

Description

The START and STOP DATABASE commands are used primarily in conjunction with setting up and accessing Read Only Shared (ROSHARE) databases. A START DATABASE command must be issued after a STOP DATABASE command in order to make the tables in a ROSHARE database accessible to other locations.

The START DATABASE command is permanent until a STOP DATABASE command is executed, even if the user logs out or the Server is brought down. When a START DATABASE command is issued to start a database in RW mode, a value of "W" is placed in the IBMREQ column of the SYSIBM.SYSDATABASE table.

The ACCESS clause introduces either the default read-write (RW) option or the read-only (RO) option. ACCESS (RO) must be added to the START DATABASE command to start a ROSHARE database in read-only mode. Read-only mode allows users at other locations to directly read (select) data in the ROSHARE database.

ROSHARE database owners must issue a START DATABASE command (RW option default) before attempting to insert, update or delete records in the database.

Parent topic: SQL Statements


START PROCEDURE

Invocation

START PROCEDURE is an executable command that can be issued interactively.

Authorization

To execute the START PROCEDURE command, users must possess one (or more) privileges listed in the SYSADM or SYSCTRL authority.

Syntax

START PROCEDURE (Proc-item-list)

Proc-item-list:

Proc-item [, Proc-item]

Proc-item:

{ Procedure-name | * }

Parameters:

Procedure-name The procedure name is any long identifier that names the procedure. The procedure name can be a partial name followed immediately by an asterisk. The partial name will identify a set of stored procedures to be checked. If an asterisk is used by itself, all procedures defined to the location will be checked. The SQL engine will stop when it encounters the first error.
Parent topic: SQL Statements


STOP DATABASE

Invocation

STOP DATABASE is an executable command that can be issued interactively, embedded in a host language, or dynamically prepared.

Authorization

To execute the STOP DATABASE command, users must possess either overall SYSADM or SYSCTRL authority for the location, DBADM authority on the database, or the STOPDB privilege for the database.

Syntax

STOP DATABASE (database-name)

Parameters:

database-name Identifies the database to be stopped.

Description

The STOP and START DATABASE commands are used primarily in conjunction with setting up and accessing Read Only Shared (ROSHARE) databases. A STOP DATABASE command must be issued on the "dummy" database before the owner of the physical (ROSHARE) database can create or alter tables. A STOP command must also be issued against the physical database and all related dummy databases before the ROSHARE database owner can drop tables.

The STOP DATABASE command can also be used by any database owner to restrict access (of any kind) to the database -- perhaps before a backup operation. Users must remember to issue a START command on the "stopped" database, when normal access is desired.

Parent topic: SQL Statements


TRUNCATE TABLE

Invocation

TRUNCATE TABLE is an executable command that can be issued interactively or embedded in a host language. TRUNCATE TABLE can be dynamically prepared.

Authorization

To execute the TRUNCATE TABLE command, users must possess either DBADM authority for the database containing the table, the DELETE privilege on the table, overall SYSADM authority for the location, or be the owner of the table to be truncated.

Syntax

TRUNCATE TABLE table-name

Parameters:

table-name Identifies the table to be truncated.

Description

The TRUNCATE TABLE command has the same functionality as DELETE FROM table-name, but is faster since deletes will not be logged and indexes are not incrementally maintained. The system will not be able to rollback the deleted records. This command is not allowed on a table containing a primary key, since it may be referenced by another table. Additionally, use of the TRUNCATE TABLE command alleviates the need to issue a COMPACT command on the table after records are deleted (to reclaim and reuse storage space).

Note:

The "records deleted" message produced after issuing the TRUNCATE TABLE command can indicate more records removed than originally present in the table. TRUNCATE TABLE does not stop to determine if a record was previously deleted from the table, it just truncates the table file -- counting all records equally, including those marked for deletion.

Parent topic: SQL Statements


UNLOCK TABLE

Invocation

UNLOCK TABLE is an executable command that can be issued interactively or embedded in a host language. UNLOCK TABLE can be dynamically prepared.

Authorization

You must be the user who locked the table.

Syntax

UNLOCK TABLE table-name

Parameters:

table-name Identifies the table or view that was locked using a LOCK TABLE command.

Description

The UNLOCK TABLE command is available in both single and multi-user environments; however it is effective only in multi-user environments.

All table locks acquired by the user with the LOCK command can be held until COMMIT or ROLLBACK is issued. If a table is locked in Exclusive Use mode, no record level locks will be recorded by the system. Be sure to COMMIT or ROLLBACK before unlocking a table that has an Exclusive Use lock. Otherwise, uncommitted changes to the database may be lost.

Parent topic: SQL Statements


UPDATE (Searched)

Invocation

UPDATE is an executable command that can be issued interactively or embedded in a host language. UPDATE can be dynamically prepared.

Authorization

Authority requirements for the UPDATE command depend on whether a table or view is being modified. If modifying a table, users need either UPDATE privileges on (or ownership of) the table, DBADM authority on the database containing the table, or overall SYSADM or SYSCTRL (some catalog tables only) authority for the location. If updating a view, users need UPDATE privileges on the view or SYSADM authority for the location.

The SELECT privilege is required on a searched update if the option for the SQL standard is set as follows:

  • For static SQL statements, if the SQLRULES(STD) bind option was specified
  • For dynamic SQL statements, if the CURRENT RULES special register is set to STD

If an expression that refers to a function is specified, the privilege set must include any authority that is necessary to execute the function.

Syntax

UPDATE {table-name | view-name}[correlation-name]
    SET assignment-clause
    [WHERE search-condition]
    [WITH {CS | RR | RS}]
    [QUERYNO integer]

assignment-clause:

{column-name = {expression | NULL | scalar-subselect}
| (column-name[,...] = {{expression | NULL} [,...] | row-select}}[,...]

Parameters:

table-name or view-name Identifies the table or view to be updated. If a view, the view must be updatable. The name must not identify:
  • An auxiliary table
  • A created temporary table or a view of a created temporary table
  • A catalog table with no updatable columns or a view of a catalog table with no updatable columns
  • A read-only view.
correlation-name Can be used within search-condition or a positioned UPDATE to designate the table or view.

When updating tables with subselects, the subselect cannot reference a location other than the one referenced elsewhere in the command. That is, a referenced table and all subselects in a single SQL statement must be from the same location.

Invalid:

UPDATE tutorial.tutorial.practice
    SET pay = pay + 5 WHERE e_no IN
        SELECT e_no FROM debloc.debbie.employee
            WHERE st = "MD";

Valid:

UPDATE tutorial.tutorial.practice
    SET pay = pay + 5
    WHERE e_no IN
        SELECT e_no FROM tutorial.debbie.employee
            WHERE st = "MD";

Description

The Searched UPDATE, command locates all records that satisfy the conditions specified in the WHERE clause (providing all index, integrity and check conditions are met and reverified). If the WHERE clause is omitted in a Searched UPDATE all records in the table will be updated. The WHERE search condition may be an expression or a nested query. Note that the UPDATE command cannot include an ORDER BY clause.

When performing a Positioned UPDATE, the WHERE CURRENT OF clause must specify the name of an open cursor. Only the current record (as defined in the opened cursor) will be updated, with the SET clause specifying the new values for the indicated columns.

Introduces a list of one or more column names and the values to be assigned to the columns.

column-name Identifies a column to be updated. column-name must identify a column of the specified table or view, but must not identify a ROWID column, an identity column that is defined as GENERATED ALWAYS, or a view column that is derived from a scalar function, constant, or expression. The column names must not be qualified, and the same column must not be specified more than once.

For a positioned update, allowable column names can be further restricted to those in a certain list. This list appears in the FOR UPDATE OF clause of the SELECT statement for the associated cursor. If the SELECT statement is dynamically prepared, the FOR UPDATE OF clause must always be present.

A view column derived from the same column as another column of the view can be updated, but both columns cannot be updated in the same UPDATE statement.

expression Indicates the new value of the column. Specifies an expression made up of constants, column-names, and arithmetic operators +, -, *, / (or the keyword NULL) that will become the new value of column-name. It must not include a column function.

A column-name in an expression must identify a column of the table or view. For each row that is updated, the value of the column in the expression is the value of the column in the row before the row is updated.

NULL | Specifies the null value as the new value of the column. Specify NULL only for nullable columns.
scalar-subselect Specifies a subselect that returns a single row with a single column. The column value is assigned to the corresponding column-name. If the subselect returns no rows, the null value is assigned; an error occurs if the column to be updated is not nullable. An error also occurs if there is more than one row in the result.
The subselect must not contain a GROUP BY or HAVING clause, and the subselect (or subquery within the subselect) cannot use the table or view being updated as its target. The subselect, however, can refer to columns of the table or view to be updated. The value of such a column in the subselect is the value of the column in the row before the row is updated. Correlated references to these columns are allowed only in a searched UPDATE and only in the search condition of the subselect. For example, the following syntax is valid:
UPDATE TABLE T1
    SET COL1 = (SELECT COUNT(*)
        FROM TABLE2 T2
        WHERE T2.COL5 = T2.COL3)
    WHERE COL3 = 'ABC'
row-subselect Specifies a subselect that returns a single row. The number of columns in the row must match the number of column-names that are specified. The column values are assigned to each corresponding column-name. If the subselect returns no rows, the null value is assigned; an error occurs if the column to be updated is not nullable. An error also occurs if there is more than one row in the result.

The subselect must not contain a GROUP BY or HAVING clause, and the subselect (or subquery within the subselect) cannot use the table or view being updated as its target. The subselect, however, can refer to columns of the table or view to be updated. The value of such a column in the subselect is the value of the column in the row before the row is updated. Correlated references to these columns are allowed only in a searched UPDATE and only in the search condition of the subselect.

search-condition | Preceded by the keyword WHERE, specifies a search condition for the optional WHERE clause.

Specifies an isolation level with which the statement is executed during a Searched UPDATE. You can override the isolation level of the statement using the WITH {RR | CS} clause. Because WITH UR only applies to read only operations, you cannot use it in an UPDATE statement. The WITH clause overrides the isolation level only for the statement in which it appears.

Specifies the number to be used for this SQL statement in EXPLAIN output and trace records. The number is used for the QUERYNO columns of the plan tables for the rows that contain information about this SQL statement.

If the clause is omitted, the number associated with the SQL statement is the statement number assigned during precompilation. Thus, if the application program is changed and then precompiled, that statement number might change.

Using the QUERYNO clause to assign unique numbers to the SQL statements in a program is helpful for simplifying the use of optimization hints for access path selection, if hints are used.

Unless appropriate locks already exist, one or more exclusive locks are acquired by the execution of a successful UPDATE statement. Until a commit or rollback operation releases the locks, only the application process that performed the insert can access the updated row. If LOBs are not updated, application processes that are running with uncommitted read can also access the updated row. The locks can also prevent other application processes from performing operations on the table. However, application processes that are running with uncommitted read can access locked pages and rows.

When a view is updated, the changes are reflected in the underlying database table. For a view to be updatable, the query used to define the view must satisfy the following criteria:

  • The query cannot contain DISTINCT.
  • The SELECT clause can contain only column names (no expressions or functions).
  • The FROM clause can contain only one table name.
  • No GROUP BY or HAVING clauses are permitted.

Examples:

The following are examples of Searched UPDATE commands. The first example changes the value of the COLOR column for part number P2 to BROWN, and then adds 5 to its WEIGHT column value.

UPDATE part
    SET color = "BROWN", weight = weight + 5
    WHERE pno = "P2"

The next command doubles the STATUS column value of all London suppliers:

UPDATE supplier
    SET status = status * 2
    WHERE city = "LONDON"

The WHERE clause may also include a nested query, as in the following example, which updates the PARTSUPP table records containing the part numbers of any part made in Paris:

UPDATE partsupp
    SET qty = qty-100
    WHERE pno IN
        SELECT pno
            FROM part
            WHERE city = "PARIS"

While an update command can only update one table, its WHERE clause may consist of a nested query that is a join of several tables. For example:

UPDATE supplier
    SET status = 30
    WHERE sno IN
        SELECT sno
            FROM partsupp, part
            WHERE partsupp.pno = part.pno
              AND qty > 50
Parent topic: SQL Statements
Related reference
UPDATE (Positioned)


UPDATE (Positioned)

Invocation

UPDATE is an executable command that can be issued interactively or embedded in a host language. UPDATE can be dynamically prepared.

Authorization

Authority requirements for the UPDATE command depend on whether a table or view is being modified. If modifying a table, users need UPDATE privileges on (or ownership of) the table, DBADM authority on the database containing the table, or overall SYSADM or SYSCTRL (some catalog tables only) authority for the location. If updating a view, users need UPDATE privileges on the view or SYSADM authority for the location.

Syntax

The Positioned UPDATE command can only be used with embedded SQL. In DB2 mode the cursor must have been defined with a FOR UPDATE OF clause (or the program precompiled with the NOFOR directive).

The syntax for the Positioned UPDATE appears below:

UPDATE {table-name | view-name} [correlation-name]
    SET assignment-clause WHERE CURRENT OF cursor-name
    [FOR ROW {host-variable | integer-constant} OF ROWSET]

assignment-clause:

{column-name = {expression | NULL | scalar-subselect}
| (column-name[,...] = {{expression | NULL} [,...] | row-select}}[,...]

Parameters:

table-name or view-name Identifies the table or view to be updated. If a view, the view must be updatable. The name must not identify:
  • An auxiliary table
  • A created temporary table or a view of a created temporary table
  • A catalog table with no updatable columns or a view of a catalog table with no updatable columns
  • A read-only view.
correlation-name Can be used within search-condition or a positioned UPDATE to designate the table or view.

Explicit Update to Null (DB2 Mode)

In DB2 mode, you cannot perform an explicit update to null on a table column defined as NOT NULL WITH DEFAULT. For example:

UPDATE empl SET perf = NULL

returns an error message if the column named perf was originally declared as NOT NULL WITH DEFAULT.

Description

The Searched UPDATE, command locates all records that satisfy the conditions specified in the WHERE clause (providing all index, integrity and check conditions are met and reverified). If the WHERE clause is omitted in a Searched UPDATE all records in the table will be updated. The WHERE search condition may be an expression or a nested query. Note that the UPDATE command cannot include an ORDER BY clause.

When performing a Positioned UPDATE, the WHERE CURRENT OF clause must specify the name of an open cursor. Only the current record (as defined in the opened cursor) will be updated, with the SET clause specifying the new values for the indicated columns.

SET Clause

Introduces a list of one or more column names and the values to be assigned to the columns.

column-name Identifies a column to be updated. column-name must identify a column of the specified table or view, but must not identify a ROWID column, an identity column that is defined as GENERATED ALWAYS, or a view column that is derived from a scalar function, constant, or expression. The column names must not be qualified, and the same column must not be specified more than once.

For a positioned update, allowable column names can be further restricted to those in a certain list. This list appears in the FOR UPDATE OF clause of the SELECT statement for the associated cursor. If the SELECT statement is dynamically prepared, the FOR UPDATE OF clause must always be present.

A view column derived from the same column as another column of the view can be updated, but both columns cannot be updated in the same UPDATE statement.

expression Indicates the new value of the column. Specifies an expression made up of constants, column-names, and arithmetic operators +, -, *, / (or the keyword NULL) that will become the new value of column-name. It must not include a column function.

A column-name in an expression must identify a column of the table or view. For each row that is updated, the value of the column in the expression is the value of the column in the row before the row is updated.

NULL | Specifies the null value as the new value of the column. Specify NULL only for nullable columns.
scalar-subselect Specifies a subselect that returns a single row with a single column. The column value is assigned to the corresponding column-name. If the subselect returns no rows, the null value is assigned; an error occurs if the column to be updated is not nullable. An error also occurs if there is more than one row in the result.

The subselect must not contain a GROUP BY or HAVING clause, and the subselect (or subquery within the subselect) cannot use the table or view being updated as its target. The subselect, however, can refer to columns of the table or view to be updated. The value of such a column in the subselect is the value of the column in the row before the row is updated. Correlated references to these columns are allowed only in a searched UPDATE and only in the search condition of the subselect. For example, the following syntax is valid:

UPDATE TABLE T1
    SET COL1 = (SELECT COUNT(*)
        FROM TABLE2 T2
        WHERE T2.COL5 = T2.COL3)
    WHERE COL3 = 'ABC'
row-subselect Specifies a subselect that returns a single row. The number of columns in the row must match the number of column-names that are specified. The column values are assigned to each corresponding column-name. If the subselect returns no rows, the null value is assigned; an error occurs if the column to be updated is not nullable. An error also occurs if there is more than one row in the result.

The subselect must not contain a GROUP BY or HAVING clause, and the subselect (or subquery within the subselect) cannot use the table or view being updated as its target. The subselect, however, can refer to columns of the table or view to be updated. The value of such a column in the subselect is the value of the column in the row before the row is updated. Correlated references to these columns are allowed only in a searched UPDATE and only in the search condition of the subselect.

cursor-name | Preceded by the keywords WHERE CURRENT OF, identifies a previously declared and opened cursor.

Specifies the number to be used for this SQL statement in EXPLAIN output and trace records. The number is used for the QUERYNO columns of the plan tables for the rows that contain information about this SQL statement.

If the clause is omitted, the number associated with the SQL statement is the statement number assigned during precompilation. Thus, if the application program is changed and then precompiled, that statement number might change.

Using the QUERYNO clause to assign unique numbers to the SQL statements in a program is helpful for simplifying the use of optimization hints for access path selection, if hints are used.

Unless appropriate locks already exist, one or more exclusive locks are acquired by the execution of a successful UPDATE statement. Until a commit or rollback operation releases the locks, only the application process that performed the insert can access the updated row. If LOBs are not updated, application processes that are running with uncommitted read can also access the updated row. The locks can also prevent other application processes from performing operations on the table. However, application processes that are running with uncommitted read can access locked pages and rows.

When a view is updated, the changes are reflected in the underlying database table. For a view to be updatable, the query used to define the view must satisfy the following criteria:

  • The query cannot contain DISTINCT.
  • The SELECT clause can contain only column names (no expressions or functions).
  • The FROM clause can contain only one table name.
  • No GROUP BY or HAVING clauses are permitted.

Example:

The following Positioned UPDATE statement changes the current PART table record (pointed to by the cursor PARTCUR) by setting the COLOR column to "BROWN" and the WEIGHT column to 25.

    MOVE "BROWN" TO NEWCOLOR
    MOVE 25 TO NEWWGT
    EXEC SQL
        UPDATE part
            SET color = :NEWCOLOR, weight = :NEWWGT
            WHERE CURRENT OF partcur
    END-EXEC

The following Positioned UPDATE command changes the status of the supplier record (pointed to by the cursor supcur) to a value of ten:

newstatus = 10;
    EXEC SQL
        UPDATE supplier
            SET status = :newstatus
            WHERE CURRENT OF supcur;
Parent topic: SQL Statements
Related reference
UPDATE (Searched)


VALUES

Invocation

This statement can only be used in the triggered action of a trigger.

Authorization

EXECUTE authority is needed on any user-defined function that is referenced in the VALUES clause.

Syntax

VALUES {expression | (expression[,...])}

Description

Specifies one or more expressions. If more than one expression is specified, the expressions must be enclosed within parentheses.

The expressions are evaluated, but the resulting values are discarded and are not assigned to any output variables.

If a user-defined function is specified as part of an expression, the user-defined function is invoked. If a negative SQLCODE is returned when the function is invoked, DB2 stops executing the trigger and rolls back any triggered actions that were performed.

Example:

Create an after trigger EMPISRT1 that invokes user-defined function NEWEMP when the trigger is activated. An insert operation on table EMP activates the trigger. Pass transition variables for the new employee number, last name, and first name to the user-defined function.

CREATE TRIGGER EMPISRT1
    AFTER INSERT ON EMP
    REFERENCING NEW AS N
    FOR EACH ROW
    MODE DB2SQL
    BEGIN ATOMIC
        VALUES(NEWEMP(N.EMPNO, N.LASTNAME, N.FIRSTNAME));
    END
Parent topic: SQL Statements


VALUES INTO

Invocation

This statement can only be embedded in an application program. It is an executable statement that cannot be dynamically prepared.

Authorization

EXECUTE authority is needed on any user-defined function that is referenced in the VALUES statement.

Syntax

VALUES {{expression | NULL} | {expression | NULL}[,...]} INTO host-variable[,...]

Description

VALUES

Introduces one or more values. If more than one value is specified, the list of values must be enclosed within parentheses.

expression | Must not include a column name.
NULL | The null value. NULL can only be specified for host variables that have an associated indicator variable.

INTO

Introduces one or more host variables. The values that are specified in the VALUES clause are assigned to these host variables. The first value specified is assigned to the first host variable, the second value to the second host variable, and so on.

host-variable Identifies a variable that is described in the program according to the rules for declaring host variables.

Example:

Assign the value of the CURRENT PATH special register to host variable HV1.

EXEC SQL VALUES(CURRENT PATH)
    INTO :HV1;
Parent topic: SQL Statements


WHENEVER

Invocation

WHENEVER is not an executable command. It can only be embedded in a host language. WHENEVER cannot be dynamically prepared.

Authorization

No special type of authorization is required.

Syntax

WHENEVER {NOT FOUND | SQLERROR | SQLWARNING}
    {CONTINUE | GO TO host-label}

Parameters:

host-label Preceded by the keywords GO TO (or GOTO), specifies a host language statement to which program execution is transferred.

Description

The NOT FOUND, SQLERROR or SQLWARNING clauses are used to look for a certain types of exception conditions resulting from the execution of an SQL statement. The NOT FOUND construction looks for a returned SQL code of +100, while SQLERROR looks for an SQL statement that has returned a negative error code. SQLWARNING looks for a return code value occurring in SQLWARN1 through SQLWARN7 of the SQLCA to determine the type of warning. For more information, see XDB Server SQL Communications Area (SQLCA).

Each occurrence of a WHENEVER statement applies to all SQL statements that follow in the source listing, until the next WHENEVER statement (of that type) is encountered. In a COBOL application, if a single WHENEVER statement is placed at the beginning of the PROCEDURE DIVISION, that statement applies to all SQL statements executed by the application program. Once the WHENEVER statement determines that an error condition has occurred, the CONTINUE option transfers program control to the next sequential statement, while the GO TO clause transfers program control to the application paragraph named in host-label.

Example:

The host-label parameter is a valid section name or unqualified paragraph name.

This assumes that error-proc is a named procedure in your COBOL program.

EXEC SQL
    WHENEVER SQLERROR
        GO TO error-proc
END-EXEC
Parent topic: SQL Statements


Clauses

  • SELECT Clause Syntax and Description
  • FROM Clause Syntax and Description
  • WHERE Clause Syntax and Description
Parent topic: SQL Reference


SELECT Clause Syntax and Description

Each SQL query statement must contain both a SELECT and a FROM clause. The combination of these two clauses determine the table columns that are searched by the query. The WHERE clause and other advanced clauses further limit data retrieval to specific table rows. The sample queries presented throughout this reference utilize the training tables contained in the TUTORIAL location. See FROM Clause, WHERE Clause, Other Clauses, and XDB Server Tutorial Location for more information.

The SELECT clause specifies the columns from which data values are to be retrieved by the query. Data retrieval is limited to the columns specified. When selecting from two or more tables having duplicate column names, it may be necessary to qualify column names with table or view names. Prefixing column names with a table or view name ensures that the query retrieves the correct column (in the correct table).

Syntax

The SELECT clause format appears below:

SELECT [ALL | DISTINCT] {* | projection-list[,...]}

projection-list:

 {
        expression [[AS] name] | (CASE-statement) AS name |
        {table-name | view-name | correlation-name}.*
   }

CASE-statement:

 (CASE WHEN condition THEN expression [WHEN condition THEN expression] [...]
        ELSE expression END) AS name

Parameters:

ALL

Option (default) which selects all rows that satisfy the WHERE condition. Duplicates are not eliminated.

DISTINCT

Option that eliminates duplicate rows from the result.

* Represents a list of names that identify the columns of the final result table. The first name in the list identifies the first column, the second name identifies the second column, and so on. To retrieve all columns in a table or view, enter a single asterisk in place of projection-list.
expression | A list of one to 750 column names (separated by commas) and possibly including constants, functions, host-variables, special registers, labeled durations and various operators. If duplicate column names from different tables must appear in the list, prefix the column name in the SELECT clause with that column's table name to resolve any ambiguity. To force the use of an index on a particular column during a query, append an asterisk enclosed in parentheses (*) to the name of the indexed column. See the XDB Server Administration Guide for guidelines on using indexes with queries.

AS

The XDB Server includes support for the keyword AS, which can be used to name result columns in a SELECT clause. This is particularly useful for a column derived from an expression or from a function applied to a column value. You can use the name in a GROUP BY clause.

The name of a result column of a subselect is determined as follows:

  • If the AS clause is specified, the name of the result column is the name specified on the AS clause.
  • If the AS clause is not specified and the result column is derived from a column name, the result column name is the unqualified name of that column.
  • All other result columns are unnamed.
CASE-statement XDB Mode only. Allows an item to be conditionally specified in the projection list. For example the CASE statement,
SELECT (CASE
  WHEN A=2
    THEN FIRST_NAME
  ELSE
    LAST_NAME
  END)

inserts the column name FIRST_NAME or LAST_NAME into the projection list, depending on the value of the variable A.

condition | An expression that evaluates to TRUE or FALSE,
expression | (In the CASE statement.) An expression specifying a projection list item. (See expression description above). When condition is TRUE, expression is resolved,
name | A name you assign to the column produced by the CASE statement. (When you include the CASE statement, you must include the AS clause.)
name.* | When selecting columns from one or more tables or views, you can select all columns from a particular table by qualifying the special asterisk character with the table name. name.* represents a list of names that identify the columns of name. name can be a table-name, view-name, or correlation-name, and must designate a table or view named in the FROM clause. The first name in the list identifies the first column of the table or view, the second name in the list identifies the second column of the table or view, and so on.
  • Select Clause Examples
  • SELECT ALL vs. DISTINCT
  • Retrieving All Columns with the SELECT Clause
  • SELECT Expressions
Parent topic: Clauses


Select Clause Examples

In the sample query statement below, the prefix "part" in front of the CITY column (separated with a period) tells the system to use the CITY column from the PART table, rather than from the SUPPLIER table.

SELECT pno, part.city, qty, sname
FROM partsupp, supplier, part
WHERE part.pno = partsupp.pno
  AND partsupp.sno = supplier.sno

If columns are not prefixed with the name of the owner table, the XDB Server queries the first column with that name that the system encounters.

The next sample query adds a five percent surcharge on all outstanding customer balances in the state of Maryland, and then lists the new adjusted balance for each affected company.

SELECT company,
  balance + balance * .05 AS New_Balance
FROM customer
WHERE state = MD

The AS clause expression calculates the adjusted balance, which it displays under the heading New_Balance.

Parent topic: SELECT Clause Syntax and Description


SELECT ALL vs. DISTINCT

The SELECT clause of a query statement can include two optional keywords -- ALL or DISTINCT, followed by the projection-list. If the ALL keyword is specified, duplicate rows are not removed from the query result. If the DISTINCT option is specified, all duplicate rows of data values are excluded from the query result. If neither ALL nor DISTINCT are specified, the SELECT clause defaults to ALL.

For example, the query below selects all of the supplier numbers SNO from the PARTSUPP table, including duplicate numbers.

SELECT ALL sno
FROM partsupp

The query results are displayed below:

sno
S1
S1
S2
S3
S1
S1
S1
S1
S2
S4
S4

If we replaced the ALL keyword with DISTINCT, the query retrieves the following set of records:

sno
S1
S2
S3
S4

The DISTINCT keyword, along with the aggregate function COUNT, can be used to tally the distinct records satisfying a WHERE clause condition. See Functions and WHERE Clause for more information. The DISTINCT option keyword may only be used once in a SELECT clause.

Parent topic: SELECT Clause Syntax and Description


Retrieving All Columns with the SELECT Clause

When an * character is used in the projection-list portion of a SELECT statement, the system retrieves all columns from the tables appearing in the FROM clause. For example, suppose we need to display all columns in the SUPPLIER table. The SELECT statement below would accomplish this objective:

SELECT *
FROM supplier

The result for this query is shown in the table below:

sno | sname | status | city
S1 | SMITH | 20 | LONDON
S2 | JONES | 10 | PARIS
S3 | BLAKE | 30 | PARIS
S4 | CLARK | 20 | LONDON
S5 | ADAMS | 30 | ATHENS

The last query above returns the same result as the longer query statement shown below:

SELECT sno, sname, status, city
FROM supplier

When selecting columns from one or more tables or views, users may select all columns from a particular table by qualifying the special asterisk character with the table name. The sample query statement below demonstrates this approach:

SELECT supplier.*, pno, qty
FROM supplier, partsupp
WHERE supplier.sno = partsupp.sno

The result of the query statement above is the same as the statement below:

SELECT sno, sname, status, city, pno, qty
FROM supplier, partsupp
WHERE supplier.sno = partsupp.sno
Parent topic: SELECT Clause Syntax and Description


SELECT Expressions

The projection-list of a SELECT clause may contain column names, constants and/or expressions. It is sometimes advantageous to use an expression that incorporates data values from one or more columns. Any legal arithmetic expression involving column values, numeric or string constants, functions, and arithmetic operators is permitted in an expression. See Functions In SELECT Clauses. Parentheses may be used as necessary to define evaluation order.

Column names generally match those specified in the SELECT clause. In the case of expressions or column names made up of multiple words (column names over 30 characters long), the XDB Server substitutes the special name Columnn where the second n is the column number -- counting from the left side of the result display.

Numeric constants and string constants can be "selected" just like column names. String constants can be enclosed in single or double quotes. For instance, the query below uses a string constant in the SELECT statement:

SELECT "Supplier", sname, "is located in", city
FROM supplier

The previous query produces the following results display:

Supplier | sname | Column3 | city
Supplier | SMITH | is located in | LONDON
Supplier | JONES | is located in | PARIS
Supplier | BLAKE | is located in | PARIS
Supplier | CLARK | is located in | LONDON
Supplier | ADAMS | is located in | ATHENS

The query below uses an arithmetic expression in the SELECT clause to display shipping costs for each part received from London:

SELECT pno, weight * 1.15
FROM part
WHERE city = "LONDON"

The column rename feature can assign a name to a new column of output computed from an arithmetic expression. For example, the results of the following query would appear under two separate columns named PNO and shipcost:

SELECT pno, shipcost = weight * 1.15
FROM part
WHERE city = "LONDON"
Note:

A NULL value generates a NULL result when used in arithmetic expressions other than aggregate functions. Consider the expression x * y, where the "x" value is NULL. For any "y" value, the XDB Server evaluates this entire expression as NULL. In contrast, NULL values are ignored when determining the results of aggregate functions. For example, consider the query:

SELECT SUM(qty)
FROM partsupp

If the ith record data value in the qty column contains a NULL value, the SUM(qty) function is calculated as if the ith record does not exist.

More:

  • CASE Expressions
  • Concatenation
  • Functions In SELECT Clauses
  • Examples
  • CASE Expressions
  • Concatenation
  • Functions In SELECT Clauses
  • Examples
Parent topic: SELECT Clause Syntax and Description


CASE Expressions

Use CASE expressions to create conditional logic.

Syntax

CASE {searched-when-clause | simple-when-clause}
  [ELSE NULL | ELSE result-expression]
  END
searched-when-clause:
WHEN search-condition THEN
{result-expression | NULL} ...
simple-when-clause:
expression WHEN expression THEN
  {result-expression | NULL} ...

where:

searched-when-clause | Specifies a search condition that is applied to each row or group of table data presented for evaluation and the result when that condition is true.
simple-when-clause | Specifies that the value of the expression prior to the first WHEN keyword is tested for equality with the value of each expression that follows a WHEN keyword. Also, specifies the result for each WHEN keyword when the expressions are equal.
result-expression | Specifies the result of a case-expression if no case is true. Also, specifies the result of a searched-when-clause or a simple-when-clause when true. There must be at least one result-expression in the CASE expression.
search-condition | Specifies a condition that is true, false, or unknown about a row or group of rows. The search-condition in a searched-when-clause cannot contain a subselect.

Example

Assume that in the a table named EMPLOYEE, the first character of a department number represents the division in the organization. Use a CASE expression to list the full name of the division to which each employee belongs:

SELECT EMPNO, LASTNAME
  CASE SUBSTR(WORKDEPT,1,1)
  WHEN 'A' THEN 'Administration'
  WHEN 'B' THEN 'Human Resources'
  WHEN 'C' THEN 'Design'
  WHEN 'D' THEN 'Operations'
  END
FROM EMPLOYEE
Parent topic: SELECT Expressions


Concatenation

The special symbol || (also called the concatenation operator) is used to attach string constants and data values appearing in query results. The output rows have the same length as the sum of the individual string constants and data values attached. If any component of the concatenation expression is null (such as a data value from a column), the entire expression is null. The following query uses the concatenation operator to displays last names, followed by a comma and space, and then first names.

SELECT lname||", "||fname
FROM employee
Parent topic: SELECT Expressions


Functions In SELECT Clauses

The XDB Server provides both ANSI standard and special XDB Server functions that can be used in SELECT clause expressions. Functions (mathematical, string, and date) supported by the XDB Server are listed in Functions.

For example, the XCONCAT function (similar to the || operator) can be nested within itself to concatenate two or more string and column values, as shown by the following query:

SELECT XCONCAT(XCONCAT(color, " "), pname)
FROM part

This query produces the following results:

column1
RED NUT
GREEN BOLT
BLUE CAM
RED SCREW
BLUE CAM
RED COG

When a SELECT clause combines aggregate functions (sum, count, avg, etc.) with column names, the query statement must include a GROUP BY clause. (See Other Clauses for more information on the GROUP BY clause.) Additionally, the column-list of the GROUP BY clause must include all column names that appear in the SELECT clause.

Parent topic: SELECT Expressions


Examples

The query statement below would generate an error message because there is no GROUP BY clause that instructs the XDB Server to group records on the selected SNO column -- for purposes of calculating average quantities:

SELECT sno, AVG(qty)
FROM partsupp

The next query of the PARTSUPP table is corrected to include the GROUP BY clause:

SELECT sno, AVG(qty)
FROM partsupp
GROUP BY sno

The query results follow:

sno | avg(qty)
S1 | 216.67
S2 | 350.00
S3 | 200.00
S4 | 300.00

If there is no GROUP BY clause, only aggregate functions may be selected in queries that include a HAVING clause.

Note: The GROUP BY and HAVING clauses are covered in Other Clauses. Aggregate functions are covered in Functions.
Parent topic: SELECT Expressions


FROM Clause Syntax and Description

The FROM clause (like the SELECT clause) must appear in every SQL query statement. See SELECT Clausefor more information. While the SELECT clause specifies from which columns data values are retrieved during query execution, the FROM clause specifies the table(s) in which these data columns are located.

The FROM clause names one or more tables (or views) from which data values are retrieved by the query. Data retrieval is limited to the tables (or views) specified. The XDB Server also allows you to explicitly specify right, left, and full outer joins, and use subselects or nested table expressions. The FROM clause either names a single table or view or produces an intermediate result table that is the result of a subselect or an inner or outer join operation.

The FROM clause is required in a SELECT statement to identify the tables and/or views that are being queried. When more than one table or view is specified in the FROM clause, each of these object names can also be assigned a correlation name. In XDB mode, the FROM clause is extended to allow explicit expression of inner and outer join operations and a subselect or nested table expression.

Syntax

The FROM clause format appears below:

FROM table-ref [,...]

table-ref:

{
  [{table-name | view-name} [[AS] correlation-name]
  | [(subselect) [AS] correlation-name]
  | [joined-table]}
}

joined-table:

table-ref [INNER] | [{LEFT | RIGHT | FULL} [OUTER]]
  JOIN table-ref join-condition
| [(joined-table)]

join-condition:

ON join-expression { = | <> | > | < | >= | <= }
  join-expression AND [...]

join-expression:

column-name [{VALUE | COALESCE} (column-name [,...])]

Parameters:

table-name or view-name | A list of one or more table or view names (separated by commas), from which data values are to be retrieved. Must identify a table or view described in the system catalog of the database subsystem identified by the implicitly or explicitly specified location name.
correlation-name | Can be specified for a table reference, either immediately following the table reference or after the AS keyword which follows the table reference. A correlation name must be specified for a nested table expression that is enclosed in parentheses.
joined-table | Specifies an intermediate result table that is the result of either an inner equi-join or an outer join. The table is derived by applying one of the join-operators; INNER, RIGHT OUTER, LEFT OUTER, or FULL OUTER, to its operands. If a join-operator is not specified, INNER is implicit. The order in which a LEFT OUTER or RIGHT OUTER JOIN is performed can affect the result. A joined-table can be used in any context in which any form of the SELECT statement is used. Both a view and a cursor is read-only if its SELECT statement includes a joined-table.
joined-condition | Defines a search condition in which predicates can be combined only with the keyword AND, and each predicate has the form 'expression operator expression'. The '=' operator is the only operator allowed for a FULL OUTER JOIN or a FULL JOIN.
join-expression | Must include a column name. Only columns and the VALUE and COALESCE functions are allowed in the expression. VALUE and COALESCE are allowed only when the join operator is FULL JOIN or FULL OUTER JOIN. One expression of the predicate must reference only columns of one of the operand tables of the associated join operator, and the other expression of the predicate must reference only columns of the other operand table. Before this rule is applied, column references are resolved using the rules for resolution of column name qualifiers.
  • Correlation Names
  • INNER JOIN
  • FULL [OUTER] JOIN
  • LEFT [OUTER] JOIN
  • RIGHT [OUTER] JOIN
  • VALUE
  • Nested Table Expressions
  • Querying Views
Parent topic: Clauses


Correlation Names

Correlation names are used in place of the actual table or view name when qualifying columns within a query statement. The correlation name appears immediately after the corresponding table or view name in the FROM clause (separated by a single space). Correlation names must satisfy the same naming conventions as table names, and must be unique among all table, view and other correlation names within a query. The correlation name qualifies columns that appear in either SELECT or WHERE clauses. See WHERE Clause for more information.

The following query shows a correlation name of "p" being assigned to the PART table, and a correlation name of "ps" being assigned to the PARTSUPP table.

SELECT pname, qty
  FROM part p, partsupp ps
  WHERE p.pno = ps.pno

More information on joins and correlation names appears in WHERE Clause and Other Clauses.

  • Using AS
Parent topic: FROM Clause Syntax and Description


Using AS

The AS keyword is available before correlation names, and after the following:

  • Nested table expressions
  • Table names
  • View names
  • Aliases
  • Synonyms
Parent topic: Correlation Names


INNER JOIN

When a FROM clause contains two or more tables (or views), that FROM clause is said to join the data values appearing in the two or more tables listed. Up to ten table or view names may be listed in a FROM clause, with each object name separated with a comma. The familiar operation of joining two or more tables, as carried out in XDB Server Versions 5.0 and earlier, can now be called an inner join. This distinction is made in order to distinguish inner joins syntactically from left, right, and full (outer) joins. For example, the inner join queries below (on the PART and PARTSUPP tables) produce the same results:

SELECT part.pno, pname, qty
  FROM part, partsupp
  WHERE part.pno = partsupp.pno

or

SELECT part.pno, pname, qty
  FROM part INNER JOIN partsupp
  ON part.pno = partsupp.pno

In both of these queries the PART and PARTSUPP tables are joined on their commonly named PNO columns. Notice that the second query explicitly defines this query as an inner join, not an outer join. You can use the key words INNER JOIN in the from clause instead of the traditional comma (the comma still works for an inner join). To be consistent with this syntax, you should also use an ON clause when you explicitly state a join condition (however, the WHERE clause will work).

The results of these inner joins cannot contain any unmatched rows from either table. For example, if the PART table contained a record for a RIVET with a PNO column value of P8, this RIVET information would not be retrieved in either of the previous queries, since there is no matching record in the partsupp table with a PNO column value of P8.

Parent topic: FROM Clause Syntax and Description


FULL [OUTER] JOIN

In contrast to inner joins, outer joins can contain some or all nonmatching rows from both joined tables. Missing values in a row of the result table are filled with nulls. The following sample query creates a full outer join between the PART and PARTSUPP tables:

SELECT part.pno, pname, qty
  FROM part FULL OUTER JOIN partsupp
  ON part.pno = partsupp.pno

The results of this full outer join (the keyword OUTER is optional) contain all matched as well as unmatched rows from either table. For example, if the PART table contained a nonmatching record for a RIVET with a PNO column value of P8, this RIVET information would be part of the result, even though there is no matching record in the PARTSUPP table (with a PNO column value of P8). Likewise, if the PARTSUPP table contained a nonmatching record with a PNO column value of P7, this record information would also appear in the result even though there is no matching P7 PNO column value in the PART table.

Using the FULL [OUTER] JOIN syntax includes nonmatched rows from both joined tables. Full outer joins can only use the equal (=) comparison operator in the join condition (left and right outer joins can use all the comparison operators).

Parent topic: FROM Clause Syntax and Description


LEFT [OUTER] JOIN

Left outer joins (the keyword OUTER is again optional) include nonmatching rows only from the table named before the LEFT [OUTER] JOIN clause. Missing values in a row are filled with nulls. The following sample query creates a left outer join between the PART and PARTSUPP tables:

SELECT part.pno, pname, qty
  FROM part LEFT OUTER JOIN partsupp
  ON part.pno = partsupp.pno

The results of this query contains all matched rows, plus unmatched rows from the PART table (or, the table on the left hand side of the LEFT OUTER JOIN clause). For example, if the PART table contained a nonmatching record for a WASHER with a PNO column value of P9, this WASHER information would be part of the result, even though there is no matching record in the PARTSUPP table with a PNO column value of P9. If, however, the PARTSUPP table also contained an unmatched record, this record information would not appear in the result rows. Using the LEFT [OUTER] JOIN syntax includes nonmatched rows from only the joined table on the left of the LEFT OUTER JOIN clause.

Parent topic: FROM Clause Syntax and Description


RIGHT [OUTER] JOIN

Right outer joins (the keyword OUTER is optional) include nonmatching rows only from the table named after the RIGHT [OUTER] JOIN clause. Missing values in a row are filled with nulls. The following sample query creates a right outer join between the PART and PARTSUPP tables:

SELECT part.pno, pname, qty
  FROM part RIGHT OUTER JOIN partsupp
  ON part.pno = partsupp.pno

The results of this query contains all matched rows, plus nonmatched rows from the PARTSUPP table (or, the table on the right hand side of the RIGHT OUTER JOIN clause). For example, if the PARTSUPP table contained a nonmatching record for a PNO column value of P9, this information would be part of the result. If, however, the PART table also contained an nonmatched record, this record information would not appear in the result rows. Using the RIGHT [OUTER] JOIN syntax includes nonmatched rows from only the joined table on the right of the RIGHT OUTER JOIN clause.

  • ON Clause
Parent topic: FROM Clause Syntax and Description


ON Clause

Clause that can be used in place of the WHERE clause when explicitly stating an INNER JOIN condition (however, the WHERE clause still works). For LEFT and RIGHT OUTER JOIN clauses, however, the join condition must begin with the ON clause.

Parent topic: RIGHT [OUTER] JOIN


VALUE

The VALUE or COALESCE function (COALESCE is the keyword specified by the ANSI/ISO standard of 1992 as a synonym for the VALUE function of IBM SQL), by either name, can be particularly useful in join operations. Suppose, for example, that in the full outer join sample query below, the PARTSUPP table contained a nonmatched row entry of P9 in the PNO column:

SELECT part.pno, pname, qty
  FROM part FULL OUTER JOIN partsupp
  ON part.pno = partsupp.pno

In this case, the P9 entry would not appear in the first column of the result. The problem is that the PNO column is in the PARTSUPP table, and is not included in the SELECT list of the query. We can, however, capture the PNO column of the PARTSUPP table by using the VALUE (or COALESCE) function as shown in the following query:

SELECT VALUE(part.pno, partsupp.pno) AS
    partnum, pname, qty
  FROM part FULL OUTER JOIN partsupp
  ON part.pno = partsupp.pno

The VALUE clause forces the query to first search the PNO column in the PART table for result data; and if none is found, search the PNO column of the PARTSUPP table. In the example above, the AS clause (AS partnum) provides a synonym for the result of the VALUE function. (See AS clause in SELECT Clause).

Parent topic: FROM Clause Syntax and Description


Nested Table Expressions

An operand of a join can be more complex than the name of a single table or view. A subselect can be used as a complex operand in the FROM clause. Such an operand is called a nested table expression. Suppose we wanted to join the result of the last sample query with the SUBPART table, which includes a column named SUBPART (containing data similar to the commonly named PNO columns in the PART and PARTSUPP tables). The SUBPART table contains several rows with part numbers (SUBPART column) values that do not appear in either the PART or PARTSUPP tables.

The following sample query joins the SUBPART table with the result of the outer join of the PART and PARTSUPP table (three way join), displaying the nonmatching part number values from SUBPART in the result:

SELECT product, VALUE(subpart.subpart, partnum) AS
    partnum, pname, subpart.qty
  FROM subpart LEFT JOIN
  (SELECT VALUE(part.pno, partsupp.pno) AS
    partnum,pname, subpart.qty
    FROM part FULL OUTER JOIN partsupp
    ON part.pno = partsupp.pno) AS temp
  ON subpart.subpart = partnum

In this example, the correlation name is temp. The optional keyword AS is useful as an eye catcher for the correlation name that follows.

The following restrictions on nested table expressions apply:

  • Must be enclosed in parentheses
  • Must have a correlation name. In our example, the correlation name is temp.
Parent topic: FROM Clause Syntax and Description


Querying Views

You may query a view just like a table, provided you have SELECT authority on the view. For example, assume that the redparts view was originally defined as follows:

CREATE VIEW redparts
  AS SELECT *
  FROM part
  WHERE color = 'RED'

The following query retrieves a subset of column values from this view (the view itself being a subset of the original PART table):

SELECT pno, city
  FROM redparts

The query result appears below:

pno | city
P1 | LONDON
P4 | LONDON
P6 | LONDON

The next example also queries the redparts view:

SELECT *
  FROM redparts
  WHERE weight < 15

The query results appear below:

pno | pname | color | weight | city
P1 | NUT | RED | 12 | LONDON
P4 | SCREW | RED | 14 | LONDON
Parent topic: FROM Clause Syntax and Description


WHERE Clause Syntax and Description

Relational databases typically contain many rows of data, with each row constituting a separate record. Most relational database queries retrieve only a portion of the records contained in a table. The WHERE clause qualifies the query command statement to limit the data retrieved to specific rows in the table

The WHERE clause is generally used with a SELECT statement to specify search criteria for retrieving rows of data from a table or group of tables. The WHERE clause can also appear in DELETE and UPDATE command statements.

The optional WHERE clause sets conditions that each record must meet before that record is retrieved by a query. If the SELECT command statement does not include a WHERE clause, every row in the table or tables queried appears in the result.

A predicate states selection criteria that is applied to each row of data values in the table being queried by the SELECT statement. If the data in a particular record matches the selection criteria, then that record is retrieved by the query, otherwise the record is passed over. See Predicates for more information.

WHERE clause selection criteria may include nested subqueries or may connect two or more tables together in a join condition.

Syntax

The WHERE clause format appears below:

WHERE search-condition

where:

search-condition Specifies a predicate (or one or more predicates connected with the AND, OR, or NOT operators).

More:

  • Predicates
  • Joins
  • Predicates
  • Overriding the XDB Optimizer
  • Joins
  • Nested Queries
  • GROUP BY Clause
  • HAVING Clause
  • OPTIMIZE FOR Clause
  • ORDER BY Clause
  • FOR UPDATE OF Clause
  • UNION Clause
Parent topic: Clauses


Predicates

This topic identifies the many different kinds of predicates that can appear in WHERE clauses. The XDB Server uses the test conditions defined in WHERE clause predicates to qualify table row (record) retrieval in a SELECT command statement. Any of the following predicates may also qualify records in UPDATE and DELETE command statements.

More:

  • Simple Predicates
  • Compound Predicate
  • BETWEEN Operator
  • IN Operator
  • IS [NOT] NULL Operator
  • LIKE Operator
  • SOUNDS LIKE Operator
  • WHERE Clause Expressions
  • CASE Expressions
  • Simple Predicates
  • Compound Predicate
  • BETWEEN Operator
  • IN Operator
  • IS [NOT] NULL Operator
  • LIKE Operator
  • SOUNDS LIKE Operator
  • WHERE Clause Expressions
  • CASE Expressions
Parent topic: WHERE Clause Syntax and Description


Simple Predicates

Predicates using the following operators in their selection conditions are called simplepredicates:

Operator | Evaluated as
= | equal to
<> | not equal to
!= | not equal to
^= | not equal to
> | greater than
>= | greater than or equal to
!> | not greater than
< | less than
<= | less than or equal to
!< | not less than

The following query displays all rows in the SUPPLIER table containing a value of 20 in their STATUS column:

SELECT *
  FROM supplier
  WHERE status = 20

The query results appear below:

sno | sname | status | city
S1 | SMITH | 20 | LONDON
S4 | CLARK | 20 | LONDON

The WHERE clause in the next example compares a character string "PARIS" with the CITY column. The query below retrieves SNO (supplier number) and STATUS column data for all suppliers in Paris:

SELECT sno, status
  FROM supplier
  WHERE city = "PARIS"

Note that character strings can be enclosed in either double (") or single (') quotes. The display result appears below:

sno | status
S2 | 10
S3 | 30

When one column value is compared against another column value in a query -- and the column data types are different, the XDB Server tries to convert one of the data values to a data type compatible with the other data value before performing the comparison. For example, if integer and float column values are compared, the INT data value is converted to a FLOAT value before the XDB Server performs the comparison.

Spaces in data values are considered when evaluating retrieval conditions. Right justified data with leading spaces does not equal left justified data with trailing spaces. For example, the string "Jones" is read as a completely different value, depending on the number of preceding or trailing blank spaces attached. The LIKE predicate operator (see the LIKE Operator) allows string pattern matching without strict adherence to character string content and order.

All three of the < > or ! = or ^ = predicate operators specify records for retrieval that do not meet the specified condition. For example, the following query retrieves the PNO (part number) column values of all PART table records with a COLOR column value other than "RED."

SELECT pno
  FROM part
  WHERE color != "RED"
Parent topic: Predicates


Compound Predicate

Compound predicates use the operators OR and AND. For example, to display the SNO column values for all suppliers in "PARIS" with a STATUS column value greater than 20, use the following query:

SELECT sno
  FROM supplier
  WHERE city = "PARIS"
    AND status > 20

Shown next is the same query written with the OR operator rather than the AND operator. This SELECT command statement retrieves PNO column values for those parts that are either "RED" or weigh more than 15 pounds.

SELECT pno
  FROM part
  WHERE color = "RED"
    OR weight > 15

In complex queries, parentheses can be used to indicate the order of evaluation. The condition(s) surrounded by the innermost pair of parentheses are applied first.

SELECT pno, pname
  FROM part
  WHERE color = "green"
    OR (city = 'LONDON'
    AND weight < 15)

This last query retrieves PNO and PNAME column values of all parts that are either green or are both made in London, and have a weight less than 15.

The query result is displayed below:

pno | pname
P1 | NUT
P2 | BOLT
P4 | SCREW
Parent topic: Predicates


BETWEEN Operator

The BETWEEN operator allows the XDB Server to evaluate whether or not data values sort between a range of values indicated in the predicate.

The format for a predicate with a BETWEEN operator is shown below:

expres1 [NOT] BETWEEN expres2 AND expres3

Each occurrence of the expression expres1 is evaluated to determine if it sorts between and including the range values indicated by expres2 and expres3 (the range values in the BETWEEN clause are also part of the result set). The three variable expressions above can consist of any combination of column data values, constants, etc.

The next query selects all PART table records with WEIGHT column values between 15 and 18:

SELECT pno, pname
  FROM part
  WHERE weight BETWEEN 15 AND 18

The following records are retrieved:

pno | pname
P2 | BOLT
Parent topic: Predicates


IN Operator

The IN (and NOT IN) operators cause an enumerated list of values appearing in the WHERE clause predicate to be evaluated for a true condition.

SELECT sno, sname
  FROM supplier
  WHERE sno IN ("S1", "S2", "S3")

All data values in the SNO column must match one of the three string constants in order for their corresponding records to be retrieved. This query retrieves the following data values:

sno | sname
S1 | SMITH
S2 | JONES
S3 | BLAKE
Parent topic: Predicates


IS [NOT] NULL Operator

The IS NULL operator can be used in WHERE clause predicates to match null values occurring in a specified data column. For example, the query below retrieves all PART table records that do not have a NULL value in their COLOR data column:

SELECT *
  FROM part
  WHERE color IS NOT NULL

When used in a predicate, the NULL operator keyword must be preceded with either the IS or IS NOT keywords. Operators such as =, != or ^= can not be used with NULL.

Parent topic: Predicates


LIKE Operator

The XDB Server supports the DB2 implementation of the LIKE string pattern matching operator. The syntax for a LIKE pattern match predicate appears below:

expression [NOT] LIKE
{special-register | host-variable | string-constant}
[ESCAPE {host-variable | string-constant}]

where:

expression | The expression parameter string value is compared to the pattern string, and can be any valid expression-- as long as the result of the expression is a string. The expression can consist of a single table column name or contain a column name as part of the expression.
special-register | Indicates that the string is stored in the named special register.
host-variable | Indicates that the string is in the named host variable. The host variable must be already be defined in accordance with the rules for declaring string host variables.
string-constant | Includes the pattern as a string constant within the predicate.

In each case, the pattern string value represented by either the special-register, host-variable or string-constant parameter is matched against the string value of expression -- for each table record specified by the query.

Pattern Strings

The host-variable and string-constant parameters can utilize two special reserved characters (wild card characters) -- the percent sign ( % ) and the underscore ( _ ) to perform pattern match searches against the string values in expression. The percent sign character matches any string (of any length), while the underscore character matches any single string character.

ESCAPE

The optional ESCAPE clause designates a special escape character, which if placed immediately before a percent ( % ) or underline ( _ ) character causes that percent or underline character to be literally interpreted as part of the pattern string. The escape character value can be specified with either a string-constant (enclosed in quotes) or host-variable (must not be a structure).

  • LIKE Examples
Parent topic: Predicates


LIKE Examples

The query shown next retrieves data for those PART table records containing a PNAME column value that begins with "C":

SELECT pno, pname, weight
  FROM part
  WHERE pname LIKE "C%"

In the following example, the query match string "% of Total" is used to search the statistic column of a table called stats:

SELECT *
  FROM stats
  WHERE statistic LIKE "\% of Total"
    ESCAPE "\"

Note that in DB2 mode (for purposes of LIKE operator string comparison) trailing blanks are significant for data values located in fixed length CHAR data type columns. For example, if a character data type column with the a field length of ten contains a data value of "Sales ", a query containing the LIKE operator string "%s " would return a match. However, a LIKE operator string of "%s" in the same query would not return a match.

Parent topic: LIKE Operator


SOUNDS LIKE Operator

The XDB Server supports a SOUNDS LIKE operator that uses a soundex algorithm to pattern match strings that sound alike. The syntax for a SOUNDS LIKE condition is:

field-name SOUNDS LIKE string

where:

field-name | Refers to a specific column containing the data values to be searches for a match.
string | Is any character string (enclosed in quotes) to be matched against the value of the field-name column in each data record.

For example, the following query retrieves all records from the EMPLOYEE table where the LNAME column value sounds like "herwood":

SELECT fname, lname
  FROM employee
  WHERE lname SOUNDS LIKE "herwood"

The query results appear next:

fname | lname
Roger | Hurwood
Susan | Hurwood
Parent topic: Predicates


WHERE Clause Expressions

Expressions that compute values from one or more columns can be used advantageously in the WHERE clause of a query. Any legal arithmetic expression involving columns, constants, functions and arithmetic operators (+, -, * and /) is permitted in a WHERE clause. Parentheses may be used as necessary to define evaluation order.

Note:

If null values appear in an expression the result will be null.

The following query is an example of an expression appearing in the WHERE clause of a query:

SELECT pno, weight FROM part
  WHERE city = "LONDON"
    AND weight * 2 > 25
Parent topic: Predicates


CASE Expressions

Use CASE expressions to create conditional logic.

Syntax

CASE {searched-when-clause | simple-when-clause}
  [ELSE NULL | ELSE result-expression]
  END
searched-when-clause:
WHEN search-condition THEN
{result-expression | NULL} ...
simple-when-clause:
expression WHEN expression THEN
  {result-expression | NULL} ...

where:

searched-when-clause | Specifies a search condition that is applied to each row or group of table data presented for evaluation and the result when that condition is true.
simple-when-clause | Specifies that the value of the expression prior to the first WHEN keyword is tested for equality with the value of each expression that follows a WHEN keyword. Also, specifies the result for each WHEN keyword when the expressions are equal.
result-expression | Specifies the result of a case-expression if no case is true. Also, specifies the result of a searched-when-clause or a simple-when-clause when true. There must be at least one result-expression in the CASE expression.
search-condition | Specifies a condition that is true, false, or unknown about a row or group of rows. The search-condition in a searched-when-clause cannot contain a subselect.

Example

From a table named EMPLOYEE, find all employees who earn more than 25 percent of their income from commission, but who are not fully paid on commission.

SELECT EMPNO, WORKDEPT, SALARY+COMM FROM EMPLOYEE
WHERE (CASE WHEN SALARY=0 THEN 0
  ELSE COMM/(SALARY+COMM) END >0.25;

Note that this example uses the CASE expression to avoid "division by zero" errors.

Parent topic: Predicates


Overriding the XDB Optimizer

Usually, it is faster to execute a query using one or more indexes than to examine every record in the tables involved in the query. XDB Server's query optimization algorithms automatically examine the indexes available and pick which indexes, if any, to use for a particular query. The user normally does not need to specify which indexes to use.

You can force the use of an index for a particular query or force the system to not use an index. To force the use of an index, enter an asterisk (*) in parentheses after the name of the indexed column when you construct the query. To force the system to ignore the index, enter a hyphen (-) in parentheses after the name of the indexed column when you construct the query.

For example, assuming that an index exists on C_NO:

This query uses the C_NO index.

SELECT c_no, o_no, o_date
  FROM orders
  WHERE c_no(*)<20

This query does not use the index.

SELECT c_no, o_no, o_date
  FROM orders
  WHERE c_no(-)<20

The (*) and (-) options are valid only for column names that appear in a WHERE clause. You cannot use the (*) and (-) options in SELECT, GROUP BY, HAVING or ORDER BY clauses.

Parent topic: WHERE Clause Syntax and Description


Joins

A join is a form of query that occurs any time more than one table or view name appears in the FROM clause of a query statement -- resulting in column data being retrieved from each table. The XDB Server allows up to 10 table names to appear within each level of a query.

More:

  • Equijoin
  • Non-equijoin
  • Correlation Names
  • Multi-table Joins
  • Outer Join
  • Equijoin
  • Non-equijoin
  • Correlation Names
  • Multi-table Joins
  • Outer Join
Parent topic: WHERE Clause Syntax and Description


Equijoin

The equijoin is the most commonly used kind of table join. Equijoins include a join condition requiring the values derived from one column of a table or view to equal the values derived from another column of a different table or view. Join conditions may be created on any combination of columns, provided the qualified column names being compared in the WHERE clause have compatible data types.

For example, suppose the supplier numbers and city names for all suppliers that supply part "P2" are needed. The next query illustrates how this could be accomplished:

SELECT sno, city
  FROM partsupp, supplier
  WHERE partsupp.sno = supplier.sno
    AND pno = "P2"

The query results appear below:

sno | city
S2 | PARIS
S3 | PARIS
S1 | LONDON
S4 | LONDON

As demonstrated in the previous query, when the tables to be joined have a common column name appearing in the WHERE clause join condition, these column names should be prefixed (qualified) with their table names to resolve any ambiguity. In the above query, the qualified column name PARTSUPP.SNO specifies that the SNO column of the PARTSUPP table is to be compared with the SNO column of the SUPPLIER table (SUPPLIER.SNO).

Note:

If you do not qualify a column name that is contained in more than one query statement table, the system uses column data from the first table it finds containing the specified column name. This situation can produce unexpected results, and it is advisable to prefix common column names their specific "owning" table names.

If a join condition (such as, partsupp.sno = supplier.sno) is not included in a equijoin query, the result is a Cartesian product. This type of join concatenates every record from a table with every record from the other tables listed in the FROM clause, producing all this information in the query result. Cartesian products have limited practical value and can result in extremely large and often nonsensical results.

Parent topic: Joins


Non-equijoin

The join condition in the WHERE clause may use operators other than the equal sign (=). For example, to find all employees that are not (!=) managers, the following query can be used:

SELECT lname, fname
  FROM dept, employee
  WHERE employee.e_no != dept.mgr
    AND employee.dept = dept.dept

The query result appears below:

lname | fname
Hurwood | Roger
Gross | Mary
Wilson | Arthur
Chung | Yung
Cox | John
Crisp | Keith
Hurwood | Susan
Haley | Olaf
Parent topic: Joins


Correlation Names

To avoid repeatedly typing a full table name, a substitute correlation name for the same table may be designated, if desired. For example, to avoid repeating the table name qualifiers "supplier" and "partsupp" throughout the query, single letter correlation names can be assigned to replace the original table names henceforth in the same query.

Correlation names are designated in the FROM clause (immediately following the table name, and separated with a space) to serve as substitutes for qualifying table names later on in the WHERE clause. For example, to display the supplier number and city of all vendors who provide part "P2", the correlation names "p" and "s" can be used as qualifying prefixes instead of the table names (SUPPLIER and PARTSUPP).

SELECT sno, city
  FROM partsupp p, supplier s
  WHERE p.sno = s.sno
    AND pno = "P2"

Notice the correlation names appearing as column name prefixes in the WHERE clause join condition above.

It is possible to join a table to itself, if a correlation name is used to qualify each instance of the table appearing in the WHERE clause. For example, consider a table named personnel containing the columns staff_id, salary, and super_id. The result of the self-join query shown next displays all staff members who earn more than their supervisors:

SELECT a.staff_id
  FROM personnel a, personnel b
  WHERE a.salary > b.salary
    AND a.super_id = b.staff_id
Parent topic: Joins


Multi-table Joins

The next query joins four tables in the TUTORIAL location to find the name of the customer, order date, product names, and quantities ordered -- for all orders with order number greater than three:

SELECT company, o_date, description, quantity
  FROM customer c, orders o, products p, items i
  WHERE c.c_no = o.c_no
    AND p.p_no = i.p_no
    AND o.o_no = i.o_no
    AND o.o_no > 3

The XDB Server will choose the optimal order for performing the join. Due to query optimization, a join performed on indexed columns may retrieve records in a different order than a join performed on nonindexed columns.

It is not possible to update, delete or insert into table records retrieved by performing a join. However, UPDATE and DELETE commands may contain joins embedded as subqueries in the WHERE clause to specify the target records in a table.

Parent topic: Joins


Outer Join

An outer join creates two distinct kinds of query output one after the other -- all in the same result (not available in DB2 mode). Records satisfying the join condition appear first in the result, followed immediately by records that do not satisfy the join condition.

For example, an ordinary join between the SUPPLIER and PARTSUPP table could be performed using the following query:

SELECT supplier.sno, sname, pno, qty
  FROM supplier, partsupp
  WHERE supplier.sno = partsupp.sno

However, the output result would not include any information on supplier "S5", since this is the one supplier that does not supply any parts. (See the sample tables in XDB Server TUTORIAL Location.)

By performing an outer join, it is possible to retrieve the information on supplier "S5" from the SUPPLIER table (specifically the SNO and SNAME column values), even though the join condition of the WHERE clause (supplier.sno = partsupp.sno) is not being met for this row of joined output.

SELECT supplier.sno, sname, pno, qty
  FROM supplier, partsupp
  WHERE supplier.sno = partsupp.sno(+)

The sample query above illustrates the syntax for an outer join. Appending a plus sign within parentheses (+) to the PARTSUPP table name in the join condition yields the following results:

sno | sname | pno | qty
S1 | SMITH | P1 | 300
S1 | SMITH | P3 | 400
S1 | SMITH | P2 | 200
S1 | SMITH | P4 | 200
S1 | SMITH | P5 | 100
S1 | SMITH | P6 | 100
S2 | JONES | P2 | 400
S2 | JONES | P1 | 300
S3 | BLAKE | P2 | 200
S4 | CLARK | P2 | 200
S4 | CLARK | P4 | 300
S4 | CLARK | P5 | 400
S5 | ADAMS |  |

Even though the PARTSUPP table contains no rows with a matching "S5" value, the outer join causes the "S5" row of the SUPPLIER table to be output anyway (immediately after all the rows matching the join condition). Since there are no matching PNO or QTY column values from the PARTSUPP table for that joined row of output, the outer join inserts null values in the PNO and QTY columns for this result row.

The outer join conditions must be columns and not expressions. There is a maximum of five outer join conditions per table. Only one master table can be defined.

Parent topic: Joins


Nested Queries

A nestedquery consists of two or more ordinary queries nested in such a way that the results of each inner query (subselect) are used in the comparison test for the selection clause of the next outer query (or another command statement). The three basic formats for nested queries (also called subqueries) are shown below:

WHERE expression [NOT] IN subselect
WHERE expression operator [ALL | ANY] subselect
WHERE [NOT] EXISTS subselect

where:

expression | Consists of any valid expression.
subselect | Consists of any valid subselect (ORDER BY and UNION clauses not allowed).
operator | Is any of the standard relational operators ( =, <>, !=, ^=, <, <=, >, >= ).
IN | Evaluates to true if at least one value retrieved by the subselect matches the predicate condition (operates the same as the =ANY predicate).
NOT IN | Evaluates to true if no matching values are retrieved by the subselect (operates the same as the !=ALL or ^=ALL predicates).
ALL | Is used with the standard relational operators ( =, >, >=, <, <=, <>, != or ^= ), and evaluates to true if every record retrieved by the subselect satisfies the condition.
ANY | Is used with the standard relational operators ( =, >, >=, <, <=, <>, != or ^= ), and evaluates to true if at least one record retrieved by the subselect satisfies the condition.
EXISTS | Evaluates as true if the subselect retrieves at least one value.
NOT EXISTS | Evaluates as true if the subselect retrieves no values.

The number of levels of subselect nesting permitted by the XDB Server is limited only by system storage. The actual number of nested queries that can be executed depends on the complexity of the queries, and the number of concurrently open queries. When accessing the XDB Server, the number of concurrently opened queries can be set with the XDB Server Configuration Utility.

During subselect execution, the innermost query is executed first, with that result determining the outcome of the comparison test in the next higher level query -- and so on for each nested query level. There are a number of comparison tests that can be performed using nested queries.

More:

Subselects and Locations

IN Special Operator

ALL Special Operator

ANY vs. SOME Operators

Single Value Comparisons

EXISTS Special Operator

Multiple Level Nesting

  • Subselects and Locations
  • IN Special Operator
  • ALL Special Operator
  • ANY vs. SOME Operators
  • Single Value Comparisons
  • EXISTS Special Operator
  • Multiple Level Nesting
  • Correlated Subqueries
Parent topic: WHERE Clause Syntax and Description


Subselects and Locations

A subselect cannot reference a location different from the one referenced elsewhere in the command. That is, a referenced table and all subselects in a single SQL statement must be from the same location.

Invalid:

SELECT * FROM tutorial.tutorial.employee
WHERE e_no IN
  SELECT e_no FROM debloc.debbie.employee
  WHERE st = "MD";

Valid:

SELECT * FROM tutorial.tutorial.employee
WHERE e_no IN
  SELECT e_no FROM tutorial.debbie.employee
  WHERE st = "MD";
Parent topic: Nested Queries


IN Special Operator

One of the most frequently used nested query comparison tests determines if a value retrieved by a query is IN (or NOT IN) the set of data values retrieved by a lower level subselect. The following sample query retrieves the names of suppliers who carry part number "P2":

SELECT sname
FROM supplier
WHERE sno IN
  SELECT sno
  FROM partsupp
  WHERE pno = "P2"

The inner (or lower) query is referred to as a nested query (or subselect) since it is located within an outer query statement. To execute the nested query, the system first tests for the PNO (part number) column values of records located in the PARTSUPP table that match "P2". The subselect statement (or subselect) next retrieves SNO (supplier number) column values for the records containing the correct part number.

The results of this first nested subselect appear below:

sno
S1
S2
S3
S4

The final result (shown below) is then produced by the outer query, which retrieves the four SNAME column values from the SUPPLIER table corresponding to the supplier numbers retrieved in the inner query.

sname
SMITH
JONES
BLAKE
CLARK

Note that the last nested query could have been written as a table join, as follows:

SELECT sname
  FROM supplier, partsupp
  WHERE supplier.sno = partsupp.sno
    AND partsupp.pno = "P2"

The processing that occurs for a table join is very similar to that occurring during a nested query execution. This processing consists of selecting a subset of records from one of the tables that meet all conditions except the join condition. The records in the other table are then tested for the join condition against the first subset of records.

The major difference between processing a join and a nested query is that the XDB Server can perform query optimization when a join is executed. For example, query optimization allows the system to decide which table to process first to achieve the most efficient performance. When a nested query is executed, however, the innermost query is always performed first.

Algorithms exist for transforming nested queries into joins (or flat queries) before processing. However, these algorithms are complex and time consuming, and therefore have not been implemented by XDB Server.

When nesting queries, the boolean operator NOT can be included to select those records that do not meet the test conditions set forth in selection criteria. For example, the following query returns the SNO and SNAME column values for all suppliers not found in the PARTSUPP table:

SELECT sno, sname
FROM supplier
WHERE sno NOT IN
  SELECT sno
  FROM partsupp

Supplier S5 (or "ADAMS") is the only supplier that meets this condition.

Parentheses can be added to complex SQL statements to enhance clarity or to change the execution order of the various subqueries and table joins. For example, the following statement performs a series of XDB Server operations equivalent to the descriptive text summary below:

Find all parts carried by suppliers, where the suppliers either have a status of 10 or are located in "PARIS".

SELECT DISTINCT pno, pname
FROM part, partsupp
WHERE part.pno = partsupp.pno
  AND sno IN
    SELECT sno
    FROM supplier
    WHERE status = 10
      OR city = "PARIS"

This last query retrieves the following results:

pno | pname
P1 | NUT
P2 | BOLT

If parentheses are added to the previous complex query, the results are interpreted differently.

The following reformatted query statement is equivalent to the descriptive text summary below:

Find all parts carried by suppliers having a status of 10 or a part made in "PARIS".

SELECT DISTINCT pno, pname
FROM part, partsupp
WHERE part.pno = partsupp.pno
  AND sno IN
    (SELECT sno
    FROM supplier
    WHERE status = 10)
  OR city = "PARIS"

This modified query yields the following result:

pno | pname
P1 | NUT
P2 | BOLT
P3 | CAM
P5 | CAM
Parent topic: Nested Queries


ALL Special Operator

When the ALL special operator is used in a nested query, the test condition is true only if every record retrieved by the subselect satisfies the condition. The example nested query that follows illustrates how an ordinary relational operator is used in conjunction with the ALL special operator. This query retrieves the supplier numbers and part numbers of all parts supplied in at least as large a quantity as parts "P1" and "P6":

SELECT sno, pno
FROM partsupp
WHERE qty >= ALL
  (SELECT qty
  FROM partsupp
  WHERE pno = "P1"
    OR pno = "P6")

The result of the previous query appears below:

sno | pno
S1 | P1
S1 | P3
S2 | P2
S2 | P1
S4 | P4
S4 | P5
Parent topic: Nested Queries


ANY vs. SOME Operators

Special care must be taken when performing test conditions with the ANY special operator, since the test may not conform to the common English interpretation. For example, while the English phrase "not equal any" would normally be evaluated as true if there are no values that match, the interpretation of the SQL equivalent operator !=ANY (or ^=ANY) is different. SQL interprets !=ANY to mean that the comparison is true, if there is at least one value that does not match.

The English equivalent for the SQL condition represented by !=ANY is, in fact, "any not equal". Since this test operator is equivalent to the more readily understood NOT IN, we recommend using NOT IN instead of !=ANY. Similar caution is required when using any other operator in conjunction with ANY. We recommended that the SOME special operator be used in place of ANY. The result is the same, however, the query is more intuitively understood.

The difference between the SOME and ALL special operators is illustrated with the nested query below. This query (except for the keyword SOME) is identical to the previous nested query (which used ALL):

SELECT sno, pno
FROM partsupp
WHERE qty > SOME
  (SELECT qty
  FROM partsupp
  WHERE pno = "P1"
    OR pno = "P6")

The following results illustrate how the SOME special operator retrieves a much larger subset of data than the ALL operator:

sno | pno
S1 | P1
S1 | P3
S2 | P2
S3 | P2
S1 | P2
S1 | P4
S2 | P1
S4 | P2
S4 | P4
S4 | P5
Parent topic: Nested Queries


Single Value Comparisons

In those cases where a nested query can only retrieve one value (as with an aggregate function), the special operators SOME, ANY and ALL may be omitted from the comparison condition.

The next sample query finds the names of all suppliers with a status greater than the average supplier status:

SELECT sname
FROM supplier
WHERE status >
  (SELECT AVG(status)
  FROM supplier)

The results of this query follow:

sname
BLAKE
ADAMS
Parent topic: Nested Queries


EXISTS Special Operator

To test whether or not a subselect retrieves any records, the EXISTS or NOT EXISTS special operators are used. The following query retrieves the names of all suppliers only if there is at least one part being supplied in quantities greater than zero:

SELECT sname
FROM supplier
WHERE EXISTS
  (SELECT sno
  FROM partsupp
  WHERE qty > 0)
Parent topic: Nested Queries


Multiple Level Nesting

Queries can be nested up to six levels. For example, retrieve all supplier names -- for suppliers who supply at least one red part -- can be written as the following two level nested query:

SELECT sname
FROM supplier
WHERE sno IN
  (SELECT sno
  FROM partsupp
  WHERE pno IN
    (SELECT pno
    FROM part
    WHERE color = "RED"))

Note that the parentheses around the subqueries are optional. The system first executes the lowest level query to find the part numbers of red parts. The next higher level query is then executed, which finds the supplier numbers for those red parts. Finally, the outer level query (or main query) retrieves the names of the red part suppliers.

Parent topic: Nested Queries


Correlated Subqueries

In all of the other nested query examples in this reference, the subqueries have been evaluated completely before performing the outer query. In some cases, however, it is necessary to test the subselect against each row in the outer query. This type of query is known as a correlatedsubquery.

The correlated subquery is executed once for each row retrieved by the outer query. One or more tables in the outer level query are given a correlation name, which is used to prefix the correlated columns located in the subqueries. The correlation name is an alternate name that is defined immediately after the corresponding table name or view name in the SELECT statement of the outer level query.

One common use of correlated subqueries is to test for existence. The following query first performs the subquery to qualify each SUPPLIER table record by testing whether or not there is a part made in the city where the supplier is located:

SELECT *
FROM supplier x
WHERE EXISTS
  (SELECT *
  FROM part
  WHERE city = x.city)

The correlation name "x" tells the system that the column name "x.city" is actually referring to the CITY column of the SUPPLIER table that appears in the outer level query. The results of this query are as follows:

sno | sname | status | city
S1 | SMITH | 20 | LONDON
S2 | JONES | 10 | PARIS
S3 | BLAKE | 30 | PARIS
S4 | CLARK | 20 | LONDON

The next sample query finds all employees with a pay rate greater than the average pay rate for the department they work in:

SELECT dept, fname, lname, payrate
FROM employee e
WHERE payrate >
  (SELECT AVG(payrate)
  FROM employee
    WHERE dept = e.dept)

In this example, both the inner and outer SELECT command statements query the EMPLOYEE table. The correlation name "e" tells the system that the column name "e.dept" comes from the outer level EMPLOYEE table.

Parent topic: Nested Queries


GROUP BY Clause

When a query statement includes a GROUP BY clause, the SELECT clause for that query may list (in addition to ordinary column names) one or more aggregate functions (SUM, COUNT, AVG, etc.) operating on groups of data values in other columns.

The GROUP BY clause contains a column-list argument that must include all simple column names that appear in the SELECT clause. Columns can also be named using the AS Clause (see SELECT Clause). Simple column names are called grouping columns, since they group together records with identical data in that column. This record grouping allows mathematical operations to be performed on the other columns specified as arguments in the aggregate functions. Records can also be grouped by any valid expression appearing in the SELECT clause argument. In these cases, the expression must also be referenced in the GROUP BY clause by a whole number representing its relative column position in the SELECT clause (or output result).

Syntax

The GROUP BY clause format appears below:

GROUP BY column-list

where:

column-list Consists of an ordered list of column names or numbers, separated by commas.
  • GROUP BY Example
Parent topic: WHERE Clause Syntax and Description


GROUP BY Example

The following query uses functions to produce three output columns in the query results. The query calculates the number of parts made in each city, and the maximum and minimum weight of those parts (in each city):

SELECT city, COUNT(*), MIN(weight), MAX(weight)
FROM part
  GROUP BY city

The query results are as follows:

city | count(*) | min(weight) | max(weight)
LONDON | 3 | 12 | 19
PARIS | 3 | 12 | 17

The next example (not available in DB2 mode) finds the number of orders placed each month, grouping the results by the first output column:

SELECT XMONTH(o_date), COUNT(*)
FROM orders
  GROUP BY 1

The query results are as follows:

column1 | count(*)
9 | 1
10 | 4
Parent topic: GROUP BY Clause


HAVING Clause

Commonly used in conjunction with the GROUP BY clause, the HAVING clause qualifies aggregate record group results that appear in the query output.

The optional HAVING clause is used to qualify groups of records within a query result, and requires the use of aggregate functions. HAVING can be used with or without a GROUP BY clause. If no GROUP BY clause is specified, the SELECT clause in the query statement may only list aggregate functions -- in which case the conditions specified in the HAVING clause are applied to each aggregate group value. Each item in the search-condition must compare one aggregate property of a group with a constant, expression, nested query result, or another aggregate property of the same group. Nested queries are permitted within a HAVING clause.

Syntax

The HAVING clause format appears below:

HAVING search-condition

where:

search-condition A set of one or more conditions that group values must satisfy in order to qualify for retrieval.
  • HAVING Example
Parent topic: WHERE Clause Syntax and Description


HAVING Example

The following sample query finds the average quantity of parts supplied for any part distributed by more than one supplier:

SELECT pno, AVG(qty)
FROM partsupp
  GROUP BY pno
  HAVING COUNT(*) >= 2

The query results appear as follows:

pno | AVG(qty)
P1 | 300
P2 | 250
P4 | 250
P5 | 250

The aggregate property evaluated in a HAVING clause may be an expression involving another aggregate function. Aggregate functions in HAVING clauses are demonstrated in the following query:

SELECT pno, AVG(qty)
FROM partsupp
  GROUP BY pno
  HAVING AVG(qty) * 2 > COUNT(*) * 200

The test condition in a HAVING clause may also include nested queries, as illustrated in the following query:

SELECT pno, AVG(qty)
FROM partsupp
GROUP BY pno
  HAVING AVG(qty) * 2 >
    (SELECT qty
    FROM partsupp
    WHERE pno = "P2"
      AND sno = "S2")
Parent topic: HAVING Clause


OPTIMIZE FOR Clause

This optional clause for a SELECT statement is currently syntactically supported only by the XDB Server. It may appear before or after any accompanying FOR FETCH ONLY clause.

On mainframe DB2 systems, the OPTIMIZE FOR clause allows you to specify how many retrieved rows are to be used when optimizing. If no row limit is specified with the OPTIMIZE FOR clause, the system optimizes according to the total number of rows actually fetched. If more rows are fetched than are specified in this clause, performance could degrade. If the same number or fewer rows are fetched than are specified in this clause, performance should improve. The OPTIMIZE FOR clause does not alter the result table or the order in which the rows are fetched.

Syntax

The OPTIMIZE FOR clause format appears below:

OPTIMIZE FOR integer { ROW | ROWS }

where:

integer Identifies the number of rows expected to be retrieved from the cursor.

See also the OPTIMIZE directive in the precompiler manual for your compiler, and the OPTIMIZE FOR clause under the SELECT command in SQL Commands.

Parent topic: WHERE Clause Syntax and Description


ORDER BY Clause

The ORDER BY clause specifies the order of rows retrieved by a fullselect. It sorts the rows of a query result according to the data values contained in a sort column (or columns). Sort columns are specified in the ORDER BY clause using either column names or column numbers separated by commas. Columns can also be named using the AS Clause (see SELECT Clause). The first column specified in the ORDER BY clause is the primary sort column. Output rows are ordered first according to the value in the primary sort column. If duplicate values occur in the primary sort column, the secondary sort column values are used to provide the final ordering.

The actual row order of the results depends on the data type of the column being sorted. Character columns are ordered according to the sort sequence specified during installation of the XDB Server (the default is a case insensitive ASCII sequence). Optional ordering parameters ASC (ascending) and DESC (descending) may be specified for each sort column.

When appearing in an SQL query statement, the ORDER BY clause is always the very last clause in the statement. Only one ORDER BY clause is permitted per query. ORDER BY clauses are not permitted in queries used to define views.

Please note that the ORDER BY clause only sorts the row output of query results, not the rows of the base table. To physically sort rows of data values in a base table, issue a CREATE table statement (with the same column configuration as the original table) combined with a SELECT query and ORDER BY clause. This single SQL command statement reproduces the original base table with the rows arranged according to the ORDER BY clause. The original base table remains unchanged.

Syntax

The ORDER BY clause format appears below:

ORDER BY sort-list

where:

sort-list Identifies up to 750 sort column names or numbers. The row order of query results can then be arranged according to the values of the sort column (or columns). Items in the sort list must be separated by commas, and may include an ordering parameter -- ASC (ascending) and DESC (descending) -- for each column name in the list. The default ordering parameter is ASC.
  • ORDER BY Example
Parent topic: WHERE Clause Syntax and Description


ORDER BY Example

In the following sample query, the retrieved rows are first ordered by supplier number, and then by descending part number order -- within the same supplier number grouping.

SELECT sno, pno, qty
FROM partsupp
  ORDER BY sno, pno DESC

The query results are as follows:

sno | pno | qty
S1 | P6 | 100
S1 | P5 | 100
S1 | P4 | 200
S1 | P3 | 400
S1 | P2 | 200
S1 | P1 | 300
S2 | P2 | 400
S2 | P1 | 300
S3 | P2 | 200
S4 | P5 | 400
S4 | P4 | 300
S4 | P2 | 200
Parent topic: ORDER BY Clause


FOR UPDATE OF Clause

The FOR UPDATE OF clause identifies the columns that can be updated in a later positioned UPDATE statement. It restricts the table columns that can be updated to those specified in the column-name list. These column names must be defined for the table or view appearing in the first FROM clause of the fullselect, and must not be qualified. FOR UPDATE OF cannot be used if the result table is read-only, nor can it be used in a statement containing a FOR FETCH ONLY clause.

Syntax

The FOR UPDATE OF clause format appears below:

FOR UPDATE OF column-name[,...]

where:

column-name An unqualified column name that must be a column of the table or view identified in the first FROM clause of the fullselect.
  • FOR UPDATE OF Examples
Parent topic: WHERE Clause Syntax and Description


FOR UPDATE OF Examples

The following sample query changes salaries, bonuses, and commissions in a hypothetical table named earnings. These changes are accomplished with positioned updates using a cursor named alter_up, and are limited to departments A1 and H12.

EXEC SQL DECLARE alter_up CURSOR FOR
  SELECT dept, empno, salary, bonus, comm
  FROM earnings
  WHERE dept IN ('A1','H12')
  FOR UPDATE OF salary, bonus, comm

The columns to be updated are indicated in the FOR UPDATE OF clause in the cursor declaration.

Parent topic: FOR UPDATE OF Clause


UNION Clause

The UNION clause combines the results of two or more subselects into a single output. It combines the output of from 2 through 33 subselect statements into a single result. The actual number of subselect results that can be attached with UNION clauses depends on the complexity of the queries, and the number of other queries open at the time of execution. The data types and lengths of each column in any two subselect tables must be identical in order for query results to be merged. The column names displayed in the result are taken from the first subselect table. When processing the subqueries of a UNION clause, the XDB Server removes duplicate rows (unless UNION ALL is specified).

Syntax

The format for UNION clause queries appears below:

subselect [(fullselect)]
  [UNION | UNION ALL]
  [subselect [(fullselect)]]

where:

subselect | Components referring to any valid subselect.
ALL | Causes duplicate rows to be included in the output results.
  • Example: UNION Clause
Parent topic: WHERE Clause Syntax and Description


Example: UNION Clause

The following query retrieves the supplier numbers for all suppliers having a status equal to 30 or more, and then appends to this result the numbers of suppliers who carry green parts.

SELECT sno
FROM supplier
WHERE status >= 30
  UNION
SELECT sno
FROM part p, partsupp ps
WHERE p.pno = ps.pno
  AND p.color = "GREEN"

This query yields the results shown below. Notice that duplicate rows have been omitted from the result since UNION ALL was not specified:

sno
S1
S2
S3
S4
S5

If an ORDER BY clause is used to sort the combined row results of a UNION query, the ORDER BY clause must specify the number of an output column on which to sort the combined output. The first query output column listed in the SELECT clause is column 1, the second column 2, etc.

Also notice in the following sample query how the string "Part" is padded with spaces to make it the same length as the "Supplier" string. Output columns combined with a UNION clause must be of the same data type and character width.

SELECT "Part    ", pno, "Made in England   "
FROM part
WHERE city = "LONDON"
  UNION
SELECT "Supplier", sno, "Located in England"
FROM supplier
WHERE city = "LONDON"
  ORDER BY 2 DESC

The result of this query is:

column1 | pno | column3
Supplier | S4 | Located in England
Supplier | S1 | Located in England
Part | P6 | Made in England
Part | P4 | Made in England
Part | P1 | Made in England

In the final sample query below, two corresponding columns of two hypothetical tables, PART_ON_HAND and PART_ON_ORDER are both defined as Total_Value by the AS clause.

SELECT 'Available', partnum,
  q_on_hn * price AS Total_Value
  FROM part_on_hand
UNION ALL
SELECT 'On Order', partnum,
  q_on_ord * price AS Total_Value
  FROM part_on_order
ORDER BY partno, Total_Value

The corresponding column of the union of the two tables is also named Total_Value, even though it is the result of derived columns.

Parent topic: UNION Clause


Functions Overview

A function is a syntactic structure that returns a value derived from applying the function to its arguments. The XDB Server provides standard SQL functions, including SUM, MIN, MAX, COUNT, and AVG, as well as XDB Server-specific extensions, which usually begin with an "X".

Functions are frequently used in the SELECT clause and WHERE clause of SELECT commands, as well as in the WHERE clause of UPDATE and DELETE commands. Functions may also appear in HAVING clauses. Their use is not limited to these cases, however. For example, functions that involve arguments that can be evaluated as constants can be used in the VALUES clause of INSERT commands.

For maximum flexibility, many of the functions can be nested within one another. In addition, functions can make use of the special keywords (for example, CURRENT DATE, CURRENT TIME).

  • Compatibility Modes
  • Recursive Inference Functions
  • Aggregate Functions
  • Date And Time Functions (XDB Mode)
  • Date And Time Functions (DB2 Mode)
  • Date/Time Arithmetic
  • Numeric Functions
  • String Functions
Parent topic: SQL Reference


Compatibility Modes

The XDB Server functions which are provided in addition to the standard SQL functions are normally available only when running in XDB mode. Check the following table or check the mode key below each function name. A diamond character (X) means the function is supported in that mode. The SQL compatibility mode can be set in your client configuration or with the SET COMPATIBILITY command.

 | ANSI | DB2 | XDB
AGE |  |  | X
ASCII |  |  | X
AVG | X | X | X
CEILING |  |  | X
CHAR |  | X | X
CHR |  |  | X
COUNT | X | X | X
DATE |  | X | X
DAY |  | X | X
DAYOFYEAR |  |  | X
DAYS |  | X | X
DECIMAL |  | X | X
DIGITS |  | X | X
FACTORIAL |  |  | X
FINDANY |  |  | X
FINDNOTIN |  |  | X
FINDSTR |  |  | X
FLOAT |  | X | X
FLOOR |  |  | X
HEX |  | X | X
HOUR |  | X | X
INITCAP |  |  | X
INTEGER |  | X | X
LENGTH |  | X | X
LEVEL |  |  | X
LTRIM |  |  | X
MAX | X | X | X
MICROSECOND |  | X | X
MIN | X | X | X
MINUTE |  | X | X
MOD |  |  | X
MONTH |  | X | X
MONTHBEG |  |  | X
MONTHSBTWN |  |  | X
NULLIF | X | X | X
PI |  |  | X
PREVIOUS |  |  | X
QUARTER |  |  | X
QUARTERBEG |  |  | X
REPLICATE |  |  | X
REVCHAR |  |  | X
ROUND |  |  | X
RTRIM |  |  | X
SECOND |  | X | X
SIGN |  |  | X
STRIP |  | X | X
SUBSTR |  | X | X
SUM | X | X | X
TIME |  | X | X
TIMESTAMP |  | X | X
TODAY |  |  | X
TRUNCATE |  |  | X
VALUE |  | X | X
WEEKDAY |  |  | X
WEEKOFYEAR |  |  | X
WEEKSBTWN |  |  | X
XABS |  |  | X
XCONCAT |  |  | X
XDATE |  |  | X
XEXP |  |  | X
XLEFT |  |  | X
XLN |  |  | X
XLOG |  |  | X
XLOWER |  |  | X
XPOWER |  |  | X
XRIGHT |  |  | X
XSQRT |  |  | X
XSTDDEV |  |  | X
XTRIM |  |  | X
XUPPER |  |  | X
XVAR |  |  | X
YEAR |  | X | X
YEARBEG |  |  | X
Parent topic: Functions Overview


Recursive Inference Functions

Recursive inference is the process of using data already found in a table to infer a relationship with other, related column data (not available in DB2 mode). Recursive inference is frequently used in solving parts assembly problems or the classic "bill-of-materials" problem.

The LEVEL condition is normally used in conjunction with the PREVIOUS function in queries to implement recursive inference. It could be helpful to first read the PREVIOUS function description, before returning to the LEVEL condition description below.

More:

  • LEVEL
  • PREVIOUS
  • LEVEL
  • PREVIOUS
Parent topic: Functions Overview


LEVEL

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

The LEVEL condition may be used in conjunction with each PREVIOUS function to qualify the result on the basis of the number of recursions performed. Any of the operators =, <, <=, >, >=, != or ^= may be used in the LEVEL condition, and the right hand side may be either a positive integer (level numbers begin with 0) or the keyword BOTTOM, which indicates the bottom level of each of the recursive branches constructed by the PREVIOUS function.

All other search conditions (except those applied by GROUP BY and HAVING clauses) are applied to the original table before the recursion is performed. After the table has been "exploded" GROUP BY, HAVING and ORDER BY clauses are applied.

For example, if you wanted to know only the second level subparts used in making product P11 (see PREVIOUS function), you could execute the following query. Note that level numbers begin with 0, therefore the second level is level 1.

SELECT subpart
FROM subpart
WHERE product = PREVIOUS(subpart)
  AND LEVEL = 1
  AND product = "P11"

The result of this query is:

subpart
P5
P7
P8
P1
P2

For a graphic depiction of the various levels of recursive inference in the above example, see the figure in the PREVIOUS function description.

Parent topic: Recursive Inference Functions


PREVIOUS

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

The PREVIOUS function (XDB mode only) is used in combination with the LEVEL condition to give queries recursive inference capabilities. One PREVIOUS function is permitted per subselect.

The SUBPART table contains the following records:

product | subpart | qty
P7 | P1 | 2
P7 | P2 | 4
P7 | P6 | 6
P8 | P4 | 8
P8 | P7 | 1
P9 | P5 | 3
P9 | P7 | 5
P9 | P8 | 7
P10 | P1 | 9
P10 | P2 | 1
P11 | P9 | 2
P11 | P10 | 3

The SUBPART column lists the part numbers of all subparts used in assembling a complete product, while the part numbers of all products that contain the assembled subparts appear in the PRODUCT column. For instance, product P8 is made up of subparts P4 and P7. However, since product P7 is also made up of subparts P1, P2 and P6, we can infer that subparts P1, P2 and P6 are also required by a completed product P8. Standard SQL cannot easily detect interrelationships between products and subparts in this table.

The following query uses the PREVIOUS function to determine all the subparts which go into the making of a single product P11.

SELECT subpart
FROM subpart
WHERE product = PREVIOUS(subpart)
  AND LEVEL = BOTTOM
  AND product = "P11"

The PREVIOUS function (in combination with the LEVEL condition) uses recursive inference to "explode" the data in the SUBPART column (see the following figure) to match each product with all the subparts required for its assembly.

See the description of the LEVEL condition for a discussion of the BOTTOM keyword. In the example above, BOTTOM causes only the "bottom" level of subpart numbers (only those subparts that are not themselves composed of other subparts) contained in each recursive branch of the figure to appear in the result.

Parent topic: Recursive Inference Functions


Aggregate Functions

The XDB Server supports a number of aggregate functions that are used with the SELECT command to operate on the values from a specified column. The column-name that follows the function must be enclosed in parentheses. The result of an aggregate function is a single value for every group in the query result. If the query result is not grouped, the entire result is treated as a single group, and the result of an aggregate function is a single value.

More:

  • AVG
  • COUNT
  • MAX
  • MIN
  • SUM
  • XSTDDEV
  • XVAR
  • Example: Aggregate Functions
  • AVG
  • COUNT
  • MAX
  • MIN
  • SUM
  • XSTDDEV
  • XVAR
  • Example: Aggregate Functions
Parent topic: Functions Overview


AVG

ANSI | DB2 | SQL/DS | XDB
X | X | X | X

Averages the values in each group of a column. This function is for numeric fields only. Null values will be ignored. The format appears below:

AVG([DISTINCT]x)

where the parameter x is a numeric field. Note that in DB2 mode, performing an AVG on data of type integer or data of type small integer gives a result of an integer with decimal places truncated.

Parent topic: Aggregate Functions


COUNT

ANSI | DB2 | SQL/DS | XDB
X | X | X | X

COUNT is a standard SQL function that counts the number of records in each group satisfying the condition(s) specified. COUNT(*) returns the number of rows in the table.

For all modes except DB2 mode, the formats below return the number of non-NULL values in column-name or expression:

COUNT(column-name)

or:

COUNT(expression)

Allowable formats for all modes appear below:

COUNT(*)

or:

COUNT(DISTINCT expression)

which filters out duplicate values to return the number of distinct values in expression. For example, to discover how many suppliers are currently supplying parts, you could use the query:

SELECT COUNT(DISTINCT sno)
FROM partsupp
Parent topic: Aggregate Functions


MAX

ANSI | DB2 | SQL/DS | XDB
X | X | X | X

Selects the maximum value in each group of a column. Null values will be ignored. The format appears below:

MAX([DISTINCT]x)

where the parameter x is a column name.

Parent topic: Aggregate Functions


MIN

ANSI | DB2 | SQL/DS | XDB
à | à | à | à

Selects the minimum value for each group of a column. Null values will be ignored. The format appears below:

MIN([DISTINCT]x)

where the parameter x is a column name.

Note:

The DISTINCT keyword is ignored in the MAX and MIN functions.

Parent topic: Aggregate Functions


SUM

ANSI | DB2 | SQL/DS | XDB
X | X | X | X

Adds up all the values in each group of a column. Null values will be ignored. The format appears below:

SUM([DISTINCT] x)

where the parameter x is a numeric field or expression, and the keyword DISTINCT is used to filter out duplicate values prior to summing. Note that DISTINCT can be used with either a column name or an expression.

Parent topic: Aggregate Functions


XSTDDEV

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

An XDB Server statistical function for finding the standard deviation of a column. Null values are ignored. The format appears below:

XSTDDEV(x)

where the parameter x is a numeric column.

Note that XSTDDEV(x) is the same as (XVAR(x))E+1/2. The formula used for computing standard deviation is:

Formula for standard deviation

Parent topic: Aggregate Functions


XVAR

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

An XDB Server statistical function used for finding the variance of a column of data. The format appears below:

XVAR(x)

where x is a column name. The parameter x must be a numeric field.

Note that XVAR(x) is the same as (XSTDDEV(x))E+2. The formula used for computing variance is:

Formula for variance

Parent topic: Aggregate Functions


Example: Aggregate Functions

All of the aggregate functions are applied only to the set of records retrieved by the SELECT command. Examples of each of the functions are given below.

To find the number of "CAM" parts in the table, enter:

SELECT COUNT(pno) FROM part
WHERE pname = "CAM"

The result is 2. To find the total quantity of P2 supplied, enter:

SELECT SUM(qty) FROM partsupp
WHERE pno = "P2"

The result is 1000. To find the weight of the heaviest part, enter:

SELECT MAX(weight) FROM part

More than one function can be used in a command, as in the query:

SELECT COUNT(pno), AVG(weight), MIN(weight),
  MAX(weight), XSTDDEV(weight)
FROM part

Commands containing both an aggregate function and a simple field-name are not allowed unless the result is grouped by the simple field. For example, the following query is illegal:

SELECT SUM(qty), pno
FROM partsupp

To correct it, add a GROUP BY clause, as shown below:

SELECT SUM(qty), pno
  FROM partsupp
  GROUP BY pno

The next example finds the average weight, and number of parts for every part color that has two or more parts, and displays them in color order.

SELECT color, AVG(weight), COUNT(*)
  FROM part
  GROUP BY color
    HAVING COUNT(*) >= 2
  ORDER BY color

The result is:

color | avg(wt) | count(*)
BLUE | 12 | 2
RED | 15 | 3
Parent topic: Aggregate Functions


Date And Time Functions (XDB Mode)

Date calculations are fully supported in XDB mode using the following date, time and timestamp functions. The XDB Server also supports date-time arithmetic in XDB mode and DB2 mode, although the results in DB2 mode are different. The expressions and functions documented in this topic can appear in a SELECT or WHERE clause any place a column name for the appropriate column type might appear. Date functions operate on dates between 1/1/0001 and 12/31/9999. Historical dates may differ from the dates under the Gregorian calendar used.

More:

  • AGE
  • CHAR
  • DATE
  • DAY
  • DAYOFYEAR
  • DAYS
  • HOUR
  • MICROSECOND
  • MINUTE
  • MONTH
  • MONTHBEG
  • MONTHSBTWN
  • QUARTER
  • QUARTERBEG
  • SECOND
  • TIME
  • TIMESTAMP
  • TODAY
  • WEEKDAY
  • WEEKOFYEAR
  • WEEKSBTWN
  • YEAR
  • YEARBEG
  • XDATE
  • AGE
  • CHAR
  • DATE
  • DAY
  • DAYOFYEAR
  • DAYS
  • HOUR
  • MICROSECOND
  • MINUTE
  • MONTH
  • MONTHBEG
  • MONTHSBTWN
  • QUARTER
  • QUARTERBEG
  • SECOND
  • TIME
  • TIMESTAMP
  • TODAY
  • WEEKDAY
  • WEEKOFYEAR
  • WEEKSBTWN
  • YEAR
  • YEARBEG
  • XDATE
Parent topic: Functions Overview


AGE

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Calculates the difference in years between date1 and date2. The format appears below:

AGE(date1, date2)

For example, the query below retrieves the names of tasks begun less than 5 years as of TODAY:

SELECT task_name FROM tasks
WHERE AGE(startdate, TODAY) < 5

The AGE function also has a single parameter format that calculates the difference in years between today's date and date1. The format appears below:

AGE(date1)

The following query finds the age of each employee in the EMPLOYEE table.

SELECT lname, AGE(birth)
FROM employee
Parent topic: Date And Time Functions (XDB Mode)


CHAR

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

The CHAR function can take a mask (XDB mode only) as an optional second parameter. The format appears below:

CHAR(date[,mask])

The parameter mask must be a quoted string that contains a mask for a date or a time, based on existing masking rules.

For example:

SELECT CHAR(datefld, "www") FROM datetable

will give the day of the week (for example, "MON"). For more information on masks, see the SQLWizard User's Guide and the Options User's Guide.

Parent topic: Date And Time Functions (XDB Mode)


DATE

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

The DATE function is used to convert a value into a date. The format appears below:

DATE(expres)

The parameter expres can be a character string, a timestamp, a date, a positive number less than 3,652,059, or a null value. If expres is a date, the result is the date. If expres is a timestamp, the result is the date portion of the timestamp. If expres is a character string, it must be in one of the following formats that XDB Server recognizes:

yyyy-mm-dd | ISO or JIS format.
mm/dd/yyyy | USA format.
dd.mm.yyyy | EUR format.

If expres is a number, the result is the number of days since January 1, 0001 (including January 1, 0001). An example of the DATE function is:

UPDATE orders
  SET o_date = DATE("1989245")
  WHERE o_no = 5
Parent topic: Date And Time Functions (XDB Mode)


DAY

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

The DAY function (also XDAY) extracts the day of the month from a date or timestamp. The format appears below:

DAY(date-expr)

The following query finds the quantity of parts ordered on the first day of the month:

SELECT p_no, SUM(quantity)
  FROM orders, items
  WHERE DAY(o_date) = 1
  GROUP BY p_no
Parent topic: Date And Time Functions (XDB Mode)


DAYOFYEAR

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

The DAYOFYEAR function give the number of days (1-366) since the beginning of the year for specified date (a.k.a. Julian date). The format appears below:

DAYOFYEAR(date)

For example:

DAYOFYEAR(06/21/1991) = 173
Parent topic: Date And Time Functions (XDB Mode)


DAYS

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

The DAYS function is used to obtain an integer that corresponds to the number of days between January 1, 0001 and the date in date-expr (including January 1, 0001). The format appears below:

DAYS(date-expr)

The parameter date_expr can be a date, timestamp, or a valid string representation of a date. An example is:

SELECT DAYS(TODAY) - DAYS(o_date)
FROM orders
Parent topic: Date And Time Functions (XDB Mode)


HOUR

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

The HOUR function is used to extract the hour part of a time or timestamp. The result is an integer between 0 and 24 (or null if time-expr evaluates to a null value). The format appears below:

HOUR(time-expr)

For example:

SELECT HOUR(starttime)
FROM tasks
Parent topic: Date And Time Functions (XDB Mode)


MICROSECOND

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

This function is used to extract the microsecond part of a timestamp. The result is an integer between 0 and 999999 (or null if time-expr evaluates to a null value). The format appears below:

MICROSECOND(time-expr)

For example:

SELECT MICROSECOND(audit_time)
FROM tasks
Parent topic: Date And Time Functions (XDB Mode)


MINUTE

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

This function is used to extract the minute part of a time or timestamp. The result is an integer between 0 and 59 (or null if time-expr evaluates to a null value).

The format appears below:

MINUTE(time-expr)

For example:

SELECT MINUTE(endtime)
FROM tasks
Parent topic: Date And Time Functions (XDB Mode)


MONTH

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

This function (also XMONTH) extracts the month from a date or timestamp. The format appears below:

MONTH(date-expr)

For example, a query lists the quantity of parts ordered in January:

SELECT p_no, SUM(quantity)
  FROM orders
  WHERE MONTH(o_date) = 1
  GROUP BY p_no
Parent topic: Date And Time Functions (XDB Mode)


MONTHBEG

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

This function is used to extract the first day of the month the date resides in. The format appears below:

MONTHBEG(date)

For example:

MONTHBEG(2/14/1991) = 2/1/1991
Parent topic: Date And Time Functions (XDB Mode)


MONTHSBTWN

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

This function is used to obtain the difference between dates in months. The format appears below:

MONTHSBTWN(date1,date2)

For example:

MONTHSBTWN(07/24/1991,10/13/1991) = 3
Parent topic: Date And Time Functions (XDB Mode)


QUARTER

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

This function is used to obtain the numeric value (1-4) of the quarter in which the date resides. The format appears below:

QUARTER(date)

For example:

QUARTER(2/14/1991) = 1
QUARTER(5/14/1991) = 2
Parent topic: Date And Time Functions (XDB Mode)


QUARTERBEG

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

This function is used to obtain the date of the first day of the quarter in which the date resides. The format appears below:

QUARTERBEG(date)

For example:

QUARTERBEG(2/14/1991) = 1/1/1991
QUARTERBEG(5/14/1991) = 4/1/1991
Parent topic: Date And Time Functions (XDB Mode)


SECOND

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

This function is used to extract the seconds part of a time or timestamp. The result is an integer between 0 and 59 (or null if time-expr evaluates to a null value). The format appears below:

SECOND(time-expr)

For example:

SELECT SECOND(endtime)
FROM tasks
Parent topic: Date And Time Functions (XDB Mode)


TIME

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

The TIME function is used to convert a value into a time. The format appears below:

TIME(expres)

The parameter expres can be a character string, a timestamp, a time, or a null value. If expres is a time, the result is the time. If expres is null, the result is the null value. If expres is a timestamp, the result is the time portion of the timestamp. If expres is a character string, it must be in one of the following formats that XDB Server recognizes:

hh.mm.ss | ISO, EUR or JIS format
hh:mm: AM | PM | USA format

For example:

UPDATE tasks
SET endtime = TIME(audit_time)
Parent topic: Date And Time Functions (XDB Mode)


TIMESTAMP

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

The TIMESTAMP function is used to generate a timestamp. The format appears below:

TIMESTAMP(expres1 [, expres2])

If only one argument is specified, expres1 can be a timestamp or a valid string representation of a timestamp. If two arguments are specified, expres1 must be a date or date string, and expres2 must be a time or time string. If any argument that can be null is null, the result is null.

For example:

UPDATE task
SET audit_time = TIMESTAMP(startdate, starttime)
Parent topic: Date And Time Functions (XDB Mode)


TODAY

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

The XDB Server recognizes the keyword TODAY as a reserved name for the current date (data type is date). For compliance with DB2, the XDB Server also recognizes CURRENT DATE as being the same as TODAY within SQL. The XDB Server recognizes the keyword XTIME as a reserved name for the current time (data type is time). For compliance with DB2, The XDB Server also recognizes CURRENT TIME as being the same as XTIME within the SQL Language.

Parent topic: Date And Time Functions (XDB Mode)


WEEKDAY

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

This function is used to extract the numeric value (1-7) of the day of the week. The format appears below:

WEEKDAY(date)

For example:

WEEKDAY(tuesday) = 2
Parent topic: Date And Time Functions (XDB Mode)


WEEKOFYEAR

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

This function is used to obtain the number of weeks (1-53) since the beginning of the year for the specified date. The format appears below:

WEEKOFYEAR(date)

The number of weeks is determined by the number of Sundays. The function starts at week one and adds a week every time a Sunday occurs. For example, if January 6, 1991, is a Sunday:

WEEKOFYEAR(1/5/1991) = 1
WEEKOFYEAR(1/6/1991) = 2
WEEKOFYEAR(1/7/1991) = 2
Parent topic: Date And Time Functions (XDB Mode)


WEEKSBTWN

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

This function is used to obtain the difference between dates in weeks. The format appears below:

WEEKSBTWN(date1, date2)

The difference in weeks is determined by the number of Sundays between the two dates, including the first date but not the second. For example, if January sixth is a Sunday, and January thirteenth is a Sunday:

WEEKSBTWN(01/06/1991, 01/13/1991) = 1
Parent topic: Date And Time Functions (XDB Mode)


YEAR

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

The YEAR function (also XYEAR, XDB mode only) extracts the year from a date or timestamp. The format appears below:

YEAR(date-expr)

For example, the following query finds all employees born the same year as employee Smith:

SELECT lname FROM bdaylist
WHERE YEAR(birth) IN
  (SELECT YEAR(birth) FROM bdaylist
  WHERE lname = "SMITH")
Parent topic: Date And Time Functions (XDB Mode)


YEARBEG

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

This function is used to extract the date of the first day of the year in which the date resides. The format appears below:

YEARBEG(date)

For example:

YEARBEG(2/14/1991) = 1/1/1991
Parent topic: Date And Time Functions (XDB Mode)


XDATE

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

The XDATE function takes 3 integers and converts them into a date. The format appears below:

XDATE(m, d, y)

The m parameter is an expression that evaluates to an integer representing a month of the year (1-12). The d parameter is an expression that evaluates to an integer representing a day of the month (1-31). The y parameter is an expression that evaluates to an integer representing a year. For example, the following command creates an employee birthday calendar for the current year.

SELECT "Birthday for", fname, lname,"is",
  XDATE(XMONTH(birth), XDAY(birth), XYEAR(TODAY))
FROM bdaylist
Parent topic: Date And Time Functions (XDB Mode)


Date And Time Functions (DB2 Mode)

XDB Server's Date and Time arithmetic functions have been enhanced to provide full DB2 compatibility when operating in DB2 mode. Included are addition and subtraction of date and time field values as well as durations. When operating in XDB mode, arithmetic operations on dates and times are calculated as explained in the Date And Time Functions (XDB mode) section.

SQL Compatibility Mode is set either in the client configuration or by issuing a SET COMPATIBILITY command. Consult your DB2 documentation for further information on date/time functions and expressions.

Date-Time arithmetic under DB2 mode can involve date, time and timestamp field values or durations. The types of durations supported when running in DB2 mode are:

More:

  • Labeled Duration
  • Date Duration
  • Time Duration
  • Timestamp Duration
  • Labeled Duration
  • Date Duration
  • Time Duration
  • Timestamp Duration
Parent topic: Functions Overview


Labeled Duration

This type of duration represents a specific unit of time as expressed by a number followed by one of the following keywords:

YEAR | YEARS
MONTH | MONTHS
DAY | DAYS
HOUR | HOURS
MINUTE | MINUTES
SECOND | SECONDS
MICROSECOND | MICROSECONDS

The value of the labeled duration can be the result of an expression. It is treated as a DECIMAL(15,0) number. To use a labeled duration in a date-time computation, the other arithmetic operator must be a DATE, TIME or TIMESTAMP data field. Consider the following expression examples where ORDERDATE is a date field being added to two labeled durations (2 MONTHS and 14 DAYS).

ORDERDATE + 2 MONTHS + 14 DAYS
This is a valid entry because the expression is resolved from left to right, with ORDERDATE + 2 MONTHS yielding a DATE. The labeled duration 14 DAYS is then added to the new DATE. This expression is the same as (ORDERDATE + 2 MONTHS) + 14 DAYS.
ORDERDATE + (2 MONTHS + 14 DAYS)
This is not a valid entry because a labeled duration cannot be added to another labeled duration (2 MONTHS cannot be added to 14 DAYS).
Parent topic: Date And Time Functions (DB2 Mode)


Date Duration

In DB2 mode, this type of duration represents a number of years, months or days expressed as a DECIMAL(8,0) number (in XDB mode the number is expressed in days). The number must have the format YYYYMMDD. For example, the result of subtracting one DATE value from another (such as SHIPDATE-ORDERDATE) is a date duration (in XDB mode the units of the result are days).

Parent topic: Date And Time Functions (DB2 Mode)


Time Duration

In DB2 mode, this type of duration represents a number of hours, minutes or seconds as expressed as a DECIMAL(6,0) number (in XDB mode the number is expressed in seconds). The number must have the format HHMMSS. For example, the result of subtracting one TIME value from another is a time duration.

Parent topic: Date And Time Functions (DB2 Mode)


Timestamp Duration

This duration is a DECIMAL(20,6) number that represents an interval of time. In DB2 mode and XDB Modes, the result of subtracting two TIMESTAMP values is a TIMESTAMP duration. The TIMESTAMP duration format yyyyxxddhhmmsszzzzzz defines the years (yyyy), months (xx), days (dd), hours (hh), minutes (mm), seconds (ss), and microseconds (zzzzzz) of the time interval.

Parent topic: Date And Time Functions (DB2 Mode)


Date/Time Arithmetic

If a date-time value is the operand of addition, the other operand must be a duration. The rules for subtracting are different because a date-time value cannot be subtracted from a duration, and subtracting two date-time values differs from subtracting a duration from a date-time value. The rules for date-time arithmetic are shown in the following table.

Addition Rules

If one operand is a... ...the other operand must be a...
Date
  • Date Duration
  • Labeled Duration of years, months or days
Time
  • Time Duration
  • Labeled Duration of hours, minutes or seconds
Timestamp
  • Timestamp Duration
  • Labeled Duration of years, months, days, hours, minutes or seconds

Subtraction Rules

If the FIRST operand is a... ...the SECOND operand must be a...
Date
  • Date
  • Date Duration
  • String representation of a date
  • Labeled duration of years, months or days
Time
  • Time
  • Time Duration
  • String representation of a time
  • Labeled duration of hours, minutes or seconds
Timestamp
  • Timestamp
  • Timestamp Duration
  • Date Duration
  • Time Duration
  • String representation of a timestamp
  • Labeled duration of years, months, days, hours, minutes or seconds
If the SECOND operand is a... ...the FIRST operand must be a...
Date
  • Date
  • String representation of a date
Time
  • Time
  • String representation of a time
Timestamp
  • Timestamp
  • String representation of a timestamp

More:

  • Subtracting Dates
  • Incrementing and Decrementing Dates
  • Subtracting Times
  • Incrementing and Decrementing Times
  • Subtracting Timestamps
  • Incrementing and Decrementing Timestamps
  • Examples: Date/Time Arithmetic
  • Subtracting Dates
  • Incrementing and Decrementing Dates
  • Subtracting Times
  • Incrementing and Decrementing Times
  • Subtracting Timestamps
  • Incrementing and Decrementing Timestamps
  • Examples: Date/Time Arithmetic
Parent topic: Functions Overview


Subtracting Dates

In DB2 mode, when one date is subtracted from another, the result is a date duration that indicates the number of years, months and days. For example, the result of:

DATE('2/25/2000') - '12/20/1999'

is 205 (duration of 0 years, 2 months and 5 days). The data type of the result is DECIMAL(8,0).

The rules that apply to the date subtraction calculation are as follows:

  • If DATE1 is greater than or equal to DATE2, then DATE2 is subtracted from DATE1.
  • If DATE1 is less than DATE2, DATE1 is subtracted from DATE2 and the result is negative.

Using the operation RESULT = DATE1 - DATE2, these rules can be illustrated as follows:

If  DAY(DATE2) <= DAY(DATE1)
  Then  DAY(RESULT) = DAY(DATE1) - DAY(DATE2)
If DAY(DATE2) > DAY(DATE1)
  Then  DAY(RESULT) = N + DAY(DATE1) - DAY(DATE2)
  Where  N is the last day of MONTH(DATE2)
  MONTH(DATE2) is then incremented by 1
If MONTH(DATE2) <= MONTH(DATE1)
  Then  MONTH(RESULT) = MONTH(DATE1) - MONTH(DATE2)
If MONTH(DATE2) > MONTH(DATE1)
  Then  MONTH(RESULT) =
        12 + MONTH(DATE1) - MONTH(DATE2)
  And  YEAR(DATE2) is incremented by 1
YEAR(RESULT) = YEAR(DATE1) - YEAR(DATE2)
Parent topic: Date/Time Arithmetic


Incrementing and Decrementing Dates

When adding durations to dates or subtracting durations from dates, the results are dates between January 1, 0001 and December 31, 9999.

  • Adding/Subtracting Years

    When a duration of years is added or subtracted, only the year portion of the date is affected (except for February 29). If the result of the calculation would be February 29 of a non-leap year, the day portion of the result is set to February twenty-eighth.

  • Adding/Subtracting Months

    When a duration of months is added or subtracted, the month is changed and if necessary, the year. The day portion of the date is changed only if the result would be an invalid date (such as September 31). In this case, the day is set to the last day of the month.

  • Adding/Subtracting Days

    When a duration of days is added or subtracted, the day will change and if necessary the month and year.

    Both positive and negative durations can be added or subtracted when working with date arithmetic. The sequence in which the date is incremented (or decremented) depends on the following:

    • When a positive date duration is added to a date or when a negative date duration is subtracted from a date, the date is incremented by the specified years, months and days in that order.

      For example, entering DATE1+x, where x is a positive decimal number, is equivalent to the expression:

      DATE1 + YEAR(x) YEARS + MONTH(x) MONTHS + DAY(x) DAYS
    • When a positive date duration is subtracted from a date or a negative date duration is added to a date, the date is decremented by the specified number of days, months and years in that order.

      For example, entering DATE1-x, where x is a positive decimal number, is equivalent to the expression:

      DATE1 - DAY(x) DAYS - MONTH(x) MONTHS - YEAR(x) YEARS
Parent topic: Date/Time Arithmetic


Subtracting Times

In DB2 mode, when one time is subtracted from another, the result is a time duration that indicates the number of hours, minutes and seconds between the two times. For example, the result of:

TIME('10:22:16') - '00:34:46'

is 94730, (duration of 9 hours, 47 minutes and 30 seconds). The data type of the result is DECIMAL(6,0).

The rules that apply to the time subtraction calculation are as follows:

  • If TIME1 is greater than or equal to TIME2, then TIME2 is subtracted from TIME1.
  • If TIME1 is less than TIME2, TIME1 is subtracted from TIME2 and the result is negative.

Using the operation RESULT = TIME1 - TIME2, these rules can be illustrated as follows:

If  SECOND(TIME2) <= SECOND(TIME1)
  Then  SECOND(RESULT) =
    SECOND(TIME1) - SECOND(TIME2)
If SECOND(TIME2) > SECOND(TIME1)
  Then  SECOND(RESULT) =
    60 + SECOND(TIME1) - SECOND(TIME2)
  And  MINUTE(TIME2) is then incremented by 1
If MINUTE(TIME2) <= MINUTE(TIME1)
  Then  MINUTE(RESULT) =
    MINUTE(TIME1) - MINUTE(TIME2)
If MINUTE(TIME2) > MINUTE(TIME1)
  Then  MINUTE(RESULT) =
    60 + MINUTE(TIME1) - MINUTE(TIME2)
  And  HOUR(TIME2) is incremented by 1
HOUR(RESULT) = HOUR(TIME1) - HOUR(TIME2)
Parent topic: Date/Time Arithmetic


Incrementing and Decrementing Times

When adding durations to times or subtracting durations from times, the results are always times. Overflow or underflow hours are discarded to ensure that the result is always a valid time.

When adding or subtracting hours, only the hours portion of the time is affected. Adding 24 hours to the time '00:00:00' results in the time '24:00:00' while adding 24 hours to any other time results in the same time (for example, adding 24 hours to the time '12:29:37' results in the time '12:29:37').

When adding or subtracting minutes, minutes are changed and if necessary, the hours are changed. The seconds do not change.

When adding or subtracting seconds, seconds are changed and if necessary, the minutes and hours are changed.

Both positive and negative time durations can be added or subtracted. The result is a time that has been incremented (or decremented) by the specified number of hours, minutes and seconds in that order. For example, entering TIME1+x, where x is a positive decimal number, is equivalent to the expression:

TIME1 + HOUR(x)HOURS + MINUTE(x)MINUTES
  + SECOND(x)SECONDS
Parent topic: Date/Time Arithmetic


Subtracting Timestamps

In DB2 mode and XDB mode, when one timestamp is subtracted from another, the result is a timestamp duration that indicates the number of years, months, days, hours, minutes, and seconds. The data type of the result is DECIMAL(20).

The rules that apply to timestamp subtraction are as follows:

  • If TIMESTAMP1 is greater than or equal to TIMESTAMP2, then TIMESTAMP2 is subtracted from TIMESTAMP1.
  • If TIMESTAMP1 is less than TIMESTAMP2, TIMESTAMP1 is subtracted from TIMESTAMP2 and the result is negative.

Using the operation RESULT = TS1 - TS2, these rules can be illustrated as follows:

If  MICROSECOND(TS2) <= MICROSECOND(TS1)
  Then  MICROSECOND(RESULT) = MICROSECOND(TS1) -
      MICROSECOND(TS2)
If  MICROSECOND(TS2) > MICROSECOND(TS1)
  Then  MICROSECOND(RESULT) = 1000000 +
      MICROSECOND(TS1) - MICROSECOND(TS2)
  And  SECOND(TS2) is incremented by 1
Note:

The rules for subtracting times determine how the time portions of the timestamps are subtracted.

If  HOUR(TS2) <= HOUR(TS1)
  Then  HOUR(RESULT) = HOUR(TS1) - HOUR(TS2)
If  HOUR(TS2) > HOUR(TS1)
  Then  HOUR(RESULT) = 24 + HOUR(TS1) - HOUR(TS2)
  And  DAY(TS2) is incremented by 1
Note:

The rules for subtracting dates determine how the date portions of the timestamps are subtracted.

Parent topic: Date/Time Arithmetic


Incrementing and Decrementing Timestamps

Adding a duration to a timestamp or subtracting a duration from a timestamp returns a timestamp -- while subtracting a timestamp from a timestamp returns a timestamp duration. An overflow or underflow of hours is carried into the date portion of the result.

Parent topic: Date/Time Arithmetic


Examples: Date/Time Arithmetic

The examples appearing below reference a table called tasks created with the following command:

CREATE TABLE tasks(task_no SMALLINT, task_name CHAR(10),
  est_hrs_reqd SMALLINT, startdate DATE, enddate
  DATE,starttime TIME, endtime TIME, audit_time
  TIMESTAMP)

date1-date2

In XDB mode, this expression calculates the difference in days between the two dates date1 and date2 (in DB2 mode, subtraction of two dates results in a date duration). As an example (using the TUTORIAL tables), the query below finds the number of orders placed for part P2 during the past 30 days:

SELECT SUM(quantity)
  FROM orders, items
  WHERE TODAY - o_date < 30

time1-time2

In XDB mode, this expression calculates the difference in seconds between the two times time1 and time2. To find the number of minutes, divide the difference between times by 60. To find the number of hours, divide the difference between times by 3600. For example, to find the total number of hours elapsed between the two stored time values starttime and endtime, you could use the query:

SELECT (endtime-starttime)/3600
FROM tasks
Note:

In DB2 mode the difference between two dates or times is expressed in Date/Time Duration values -- consisting of years/months/days or hours/minutes/seconds.

timestamp1-timestamp2

In XDB mode and DB2 mode, this expression calculates the difference between the two timestamps timestamp1 and timestamp2. This difference is expressed as a timestamp duration, where the format yyyyxxddhhmmsszzzzzz defines the years (yyyy), months (xx), days (dd), hours (hh), minutes (mm), seconds (ss), and microseconds (zzzzzz) of the timestamp duration.

time1 + n

In XDB mode, calculates the time generated by adding n seconds to time time1. The parameter n can be any expression that evaluates to a number. To add minutes to a time, multiply the number of minutes by 60. To add hours to a time, multiply the number of hours by 3600. For example, to find out what the estimated end time will be, given an estimated task time in hours, you could use the query:

SELECT "Estimated hours to completion: ",
  starttime + (est_hrs_reqd * )
FROM tasks
Note:

In DB2 mode, you must specify the duration type. For example, n SECONDS, n HOURS, and so on.

Parent topic: Date/Time Arithmetic


Numeric Functions

These functions can be used any place a numeric value is required. The parameters x and y can be any expression that evaluates to a number. Money fields can only be used in the FLOAT, INTEGER or XABS functions.

The operators +, -, /, and * are also available. In DB2 mode, integer division (/) results in an integer with decimal places truncated.

Note: DB2 truncates expression results. The XDB Server rounds. For example, if result type is 5,2 and expression value is 123.555, DB2 mode retrieves 123.55 while XDB mode retrieves 123.56.

More:

  • CEILING
  • DECIMAL
  • FACTORIAL
  • FLOAT
  • FLOOR
  • INTEGER
  • MOD
  • PI
  • ROUND
  • SIGN
  • TRUNCATE
  • XABS
  • XEXP
  • XLN
  • XLOG
  • XPOWER
  • XSQRT
  • CEILING
  • DECIMAL
  • FACTORIAL
  • FLOAT
  • FLOOR
  • INTEGER
  • MOD
  • PI
  • ROUND
  • SIGN
  • TRUNCATE
  • XABS
  • XEXP
  • XLN
  • XLOG
  • XPOWER
  • XSQRT
Parent topic: Functions Overview


CEILING

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Finds the smallest integer greater than or equal to expr. The format appears below:

CEILING(expr)

For example:

CEILING(12.25) = 13
CEILING(12) = 12
Parent topic: Numeric Functions


DECIMAL

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

Transforms a number to the decimal representation of the numeric value having a specified precision and scale. The format appears below:

DECIMAL(x [, precision [, scale]])

The parameter precision, if specified, must be between 1 and 31, inclusive. If precision is omitted, the default precision depends on the data type of the first argument. If x is a floating point number or decimal, the default precision is 15. If the parameter x is an integer the default precision is 11. If x is a small integer, the default precision is 5. The parameter scale, if specified, must be in the range of 0 to precision. If omitted, scale is assumed to be 0. For example:

SELECT DECIMAL(quantity, 5, 2)
FROM items
Parent topic: Numeric Functions


FACTORIAL

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Returns the value of expr factorial. The format appears below:

FACTORIAL(expr)

The value of the parameter expr must be greater than or equal to 0 and less than or equal to 167. For example:

FACTORIAL(6) = 720
Parent topic: Numeric Functions


FLOAT

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

Converts a number into the floating point representation of the number, as if the value were assigned to a FLOAT field. The format appears below:

FLOAT(x)

In DB2 compatibility mode, the parameter x cannot be a string. In XDB mode, x can be a string.

Parent topic: Numeric Functions


FLOOR

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Finds the largest integer less than or equal to the value of expr. The format appears below:

FLOOR(expr)

For example:

FLOOR(12.25) = 12
FLOOR(12) = 12
Parent topic: Numeric Functions


INTEGER

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

Converts a number into an integer value, in the same way that the value would be converted if assigned to an INTEGER field. The format appears below:

INTEGER(x)

In DB2 compatibility mode, the parameter x cannot be a string. In XDB mode, x can be a string.

Parent topic: Numeric Functions


MOD

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Returns the remainder of expr1/expr2. The format appears below:

MOD(expr1,expr2)

For example:

MOD(10,4) = 2
MOD(2,10) = 2
Parent topic: Numeric Functions


PI

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Returns an approximation of the value of Pi. For example:

PI() = 3.1415926535897936
Parent topic: Numeric Functions


ROUND

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Rounds expr1 to the precision specified in int_expr. The format appears below:

ROUND(expr1,int_expr)

Can also round to negative numbers. For example:

ROUND(549.55,1) = 549.6
ROUND(549.55,-1) = 550.00
ROUND(549.55,-2) = 600.00
Parent topic: Numeric Functions


SIGN

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Returns the sign of the parameter expr. The format appears below:

SIGN(expr)

A value of one is returned if expr is positive, and a value of zero is returned if expr is zero, and -1 is returned if expr is negative. For example:

SIGN(-234.4) = -1
SIGN(234) = 1
SIGN(0) = 0
Parent topic: Numeric Functions


TRUNCATE

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Truncates expr1 to the precision specified in int_expr. The format appears below:

TRUNCATE(expr, int_expr)

Can truncate to negative decimals. For example:

TRUNCATE(549.55,1) = 549.5
TRUNCATE(549.55,-1) = 540.00
TRUNCATE(549.55,-2) = 500
Parent topic: Numeric Functions


XABS

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Calculates the absolute value of parameter x. The format appears below:

XABS(x)
Parent topic: Numeric Functions


XEXP

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Finds the exponential function of parameter x (for example, eE+x). The format appears below:

XEXP(x)
Parent topic: Numeric Functions


XLN

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Finds the natural log of parameter x. The format appears below:

XLN(x)
Parent topic: Numeric Functions


XLOG

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Finds base 10 logarithm of parameter x. The format appears below:

XLOG(x)
Parent topic: Numeric Functions


XPOWER

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Finds the value of parameter x raised to the power of parameter y. The format appears below:

XPOWER(x, y)
Parent topic: Numeric Functions


XSQRT

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Finds the square root of parameter x. The format appears below:

XSQRT(x)
Parent topic: Numeric Functions


String Functions

A string can consist of any combination of letters, digits or special characters contained in the standard ASCII character set. String functions can return string values from arguments consisting of other data types or manipulate combinations of existing string arguments to return another string value.

More:

  • ASCII
  • CHAR
  • CHR
  • DIGITS
  • FINDANY
  • FINDNOTIN
  • FINDSTR
  • HEX
  • INITCAP
  • LENGTH
  • LTRIM
  • NULLIF
  • REPLICATE
  • REVCHAR
  • RTRIM
  • STRIP
  • SUBSTR
  • VALUE
  • XCONCAT
  • XLEFT
  • XLOWER
  • XRIGHT
  • XTRIM
  • XUPPER
  • ASCII
  • CHAR
  • CHR
  • DIGITS
  • FINDANY
  • FINDNOTIN
  • FINDSTR
  • HEX
  • INITCAP
  • LENGTH
  • LTRIM
  • NULLIF
  • REPLICATE
  • REVCHAR
  • RTRIM
  • STRIP
  • SUBSTR
  • VALUE
  • XCONCAT
  • XLEFT
  • XLOWER
  • XRIGHT
  • XTRIM
  • XUPPER
Parent topic: Functions Overview


ASCII

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Returns the ASCII code value of the leftmost character of char_expr. The format appears below:

ASCII(char_expr)

For example:

ASCII("XDB") = 88
Parent topic: String Functions


CHAR

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

Transforms date, time or timestamp value into a character string. The format appears below:

CHAR([x [, format]])

If present, x must evaluate to a date, time or timestamp value. If x is null, the result is null. The parameter format is a string format for date or time, as shown in the table below. If omitted, the system default format is used. The format parameter cannot be specified if x is a timestamp.

Format | Name | Date Format | Time Format
ISO | International Standards Organization Standard | yyyy-mm-dd | hh.mm.ss
USA | IBM USA Standard | mm/dd/yyyy | hh:mm AM or PM
EUR | IBM European Standard | dd.mm.yyyy | hh.mm.ss
JIS | Japanese Industrial Standard Christian Era | yyyy-mm-dd | hh.mm.ss
LOCAL | Configured through the Options Utility. | User Defined | User Defined

Examples are:

CHAR(birth_date, USA)
CHAR(airtime, ISO)
CHAR(auditstamp)
Parent topic: String Functions


CHR

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Converts an ASCII code into a character (ASCII code values must be between 0 and 255). The format appears below:

CHR(int_expr)

For example:

CHR(81) = "Q"
Parent topic: String Functions


DIGITS

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

Returns a string representation of a number, without decimal points. The x parameter must be an integer or decimal number. The format appears below:

DIGITS(x)

In DB2 compatibility mode, the result is unsigned and padded with leading zeroes so that the string length is 5 if the argument is a small integer, 10 if the argument is an integer, or p if the argument is a decimal number with precision p. In XDB mode the result is a variable length string and may include a sign. An example of the use of DIGITS is:

SELECT DIGITS(o_no)
FROM orders
Parent topic: String Functions


FINDANY

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Searches for any of the characters specified by charexpr2 in charexpr1 and returns the offset from the beginning where the first occurrence is found. The format appears below:

FINDANY(charexpr1, charexpr2)

For example:

FINDANY("abcdef","zd") = 4

because "d" is found at the fourth character. A return value of zero signifies not found.

Parent topic: String Functions


FINDNOTIN

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Finds the offset of the first character in charexpr1 that is not in charexpr2. The format appears below:

FINDNOTIN(charexpr1, charexpr2)

For example:

FINDNOTIN("abdblm","dba") = 5

because "l" is the first character not in the "dba" set. A return value of zero indicates all characters are in the string.

Parent topic: String Functions


FINDSTR

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Searches for charexpr2 in charexpr1 and returns the offset from beginning of string when found. The format appears below:

FINDSTR(charexpr1, charexpr2)

For example:

FINDSTR("abcdef", "cd") = 3

A return value of zero means not found, 1 is the first character, etc.

Parent topic: String Functions


HEX

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

Returns a string that is the hexadecimal representation of x, where the parameter value x can be any value other than a long string. The format appears below:

HEX(x)

The result is a string of hexadecimal digits, with each consecutive pair of digits representing a byte of the argument, so that the length is twice the length of the argument. In DB2 compatibility mode, bytes are swapped for smallint, integer and date fields. In XDB mode, PC Intel format is used for smallint, int and date fields.

If the location sort sequence is EBCDIC, character fields display in HEX based upon the EBCDIC code page. Also, performing a HEX function on a date field in DB2 mode shows the result as if stored in DB2 format instead of XDB mode format. DB2 format is 4 packed decimal bytes with the year in the first two, the month in the next one, and the day in the next one. For example, the value 19900101 would be displayed if the HEX function was applied to date 01/01/1990.

Parent topic: String Functions


INITCAP

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Capitalizes the first character of each word and makes the rest of each word lower case. The format appears below:

INITCAP(charexpr)

For example:

INITCAP("xdb SYSTEMS") = "Xdb Systems"
Parent topic: String Functions


LENGTH

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

Finds the length of x, where x is any field value. XDB mode recognizes either LENGTH or XLENGTH, while DB2 mode only recognizes LENGTH. The format appears below:

LENGTH(x)

The character count returned depends on the compatibility setting in effect at the time the data value was inserted into the table -- not your current compatibility setting. For example, if you inserted the field value when in DB2 mode, the LENGTH function includes trailing blanks in the character count (up to the length of the column). If you inserted the field value when in XDB mode, the LENGTH function does not count trailing blanks.

For example, if the lname column values were inserted while in XDB mode, the following query produces the result shown:

SELECT lname, LENGTH(lname)
FROM employee
lname

length(lname)
Kerin | 5
Wilson | 6
Crisp | 5
Hopkins | 7
Parent topic: String Functions


LTRIM

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Trims leading spaces. The format appears below:

LTRIM(charexpr)

For example:

LTRIM("   XDB") = "XDB"
Parent topic: String Functions


NULLIF

ANSI | DB2 | SQL/DS | XDB
X | X |  | X

Use the NULLIF function wherever an expression is used to return null if the two arguments are equal; otherwise, the value of the first argument is returned. The two arguments must be compatible. The attributes of the result are the attributes of the first argument.

For example, if the result of the first argument is a character string, the result of the other must also be a character string; if the result of the first argument is a number, the result of the other must also be a number.

The format of the NULLIF function appears below:

NULLIF (expression,expression)

where:

expression Specifies a single value.
Parent topic: String Functions


REPLICATE

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Repeats charexpr for integer number of times. The format appears below:

REPLICATE(charexpr,integer)

For example:

REPLICATE("*",10) = "**********"
Parent topic: String Functions


REVCHAR

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Reverses the order of characters in charexpr. The format appears below:

REVCHAR(charexpr)

For example:

REVCHAR("abc") = "cba"

Data returned are character data.

Parent topic: String Functions


RTRIM

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Trims trailing spaces. The format appears below:

RTRIM(charexpr)

For example:

RTRIM("XDB   ") = "XDB"
Parent topic: String Functions


STRIP

ANSI | DB2 | SQL/DS | XDB
 | X | X | X

Use the STRIP function to remove blanks or another specified character from the end, beginning, or both ends of a string expression. The format appears below:

STRIP (expression [,BOTH [,strip-character]|,LEADING |,TRAILING])

where:

expression | A string expression.
strip-character | A single character constant that indicates the character that is to be removed.
Parent topic: String Functions


SUBSTR

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

Extracts n characters from x, beginning with the mth character (also written XMID in XDB mode). The format appears below:

SUBSTR(x, m [,n])

The parameter x is any expression that evaluates to a string. The parameter m is a positive integer indicating the offset from the beginning of the string, and the parameter n is a positive integer indicating the number of characters to extract. If two arguments are specified, the implicit length is LENGTH(x)-m+1 for fixed length fields or the larger of 0 or LENGTH(x)-m+1 for varying length fields. If x is null, the result is null.

For example, suppose the serial number for a deluxe widget is SW1234-4356, where the first two characters indicate the department that made it, the next 4 the model, and the rest the specific unit from the lot. To find the model number "1234" for deluxe widgets:

SELECT SUBSTR(serial_no, 3, 4)
  FROM products
  WHERE description = "Deluxe Widget"
Parent topic: String Functions


VALUE

ANSI | DB2 | SQL/DS | XDB
 | X |  | X

If x is evaluated as null, VALUE returns the value of the first non-null y. The format appears below:

VALUE(x, y1 [,...yn])

For example, in the query below, the column named COM is null for some employees; the desired value is then the employee's payrate or, failing that, simply the value 10. For example:

SELECT e_no, VALUE(com * $300, payrate, $10)
  FROM employee
  WHERE st = "VA"
e_no

column2
2 | $17.50
4 | $17.50
7 | $9.00
9 | $17.00
Parent topic: String Functions


XCONCAT

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

String concatenation can be performed using the XCONCAT function (concatenation can also be performed with the "||" operator). The format appears below:

XCONCAT(expres1, expres2)

The parameters expres1 and expres2 are expressions that evaluate two strings to be concatenated.

Parent topic: String Functions


XLEFT

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Extracts the n leftmost characters from a string. The format appears below:

XLEFT(x, n)

The parameter x is any expression that evaluates to a character string, and the parameter n is a positive integer indicating the number of characters to extract. For example, suppose you want to extract the area code from all customer phone numbers, you can use the query:

SELECT company, XLEFT(phone, 3)
FROM customer

If n is longer than the string extracted, the string is right padded with spaces until it is n characters long.

For example:

SELECT XLEFT(color, 10)||pname
FROM part
Column1

RED | NUT
GREEN | BOLT
BLUE | CAM
RED | SCREW
BLUE | CAM
RED | COG
Parent topic: String Functions


XLOWER

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Converts a character string to lower case. The parameter x is any expression that evaluates to a character string. The format appears below:

XLOWER(x)

For example:

SELECT XLOWER(lname)
  FROM employee
  WHERE st = "VA"
xlower(lname)
kerin
wilson
crisp
hopkins
Parent topic: String Functions


XRIGHT

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Extracts the last n characters from x. The format appears below:

XRIGHT(x, n)

The parameter x is any expression that evaluates to a character string and the parameter n is a positive integer indicating the number of characters to extract. For example, the following query retrieves phone numbers without the area codes:

SELECT XRIGHT(phone, 8)
FROM customer

If the value of n is longer than the string extracted, the string will be padded on the left with spaces until it is n characters long. For example, to right justify character strings, use a query like:

SELECT XRIGHT(pname, 14)
FROM part
column1
NUT
BOLT
CAM
SCREW
CAM
COG
Parent topic: String Functions


XTRIM

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Trims trailing spaces from a character string. The format appears below:

XTRIM(x)

The parameter x is any expression that evaluates to a character string. For example:

SELECT XTRIM(lname)
FROM employee
Parent topic: String Functions


XUPPER

ANSI | DB2 | SQL/DS | XDB
 |  |  | X

Converts a character string to upper case. The format appears below:

XUPPER(x)

The parameter x is any expression that evaluates into a character string. For example:

SELECT XUPPER(lname)
  FROM employee
  WHERE st = "VA"
xupper(lname)
KERIN
WILSON
CRISP
HOPKINS
Parent topic: String Functions


System Table Overview

To view the contents of any system table, use the SQL SELECT command as follows:

SELECT * FROM authid.table-name

where authid is the owner of the table. The AuthID for system tables is either sysxdb, sysibm or xdbstat.

Only a super user has authority to edit (update) the system tables. A user with sysadm authority can edit selected columns in some of the tables within the authorized location. These sysadm-editable columns are so noted in the column descriptions.

All locations, including the system location, contain a set of system catalog tables. These are stored in the dsndb06 database in each location. Additional system tables reside in the xdbacf and dsnddf databases in the system location.

Important: For complete information on system tables, see the documentation for DB2 catalog tables located on the IBM Web site.
Parent topic: SQL Reference


Overview of XDB Server Specifications

The tables in this topic show the limits imposed by the XDB Server while in XDB mode. (See also Data Types in Basic Concepts) Some XDB Server tools and utilities may have further restrictions, which are described in the applicable documentation.

More:

  • Maximum Identifier Lengths (in bytes)
  • Maximum String Length Limits
  • Date and Time Values
  • Numeric Limits
  • System and Operational Limits
  • Maximum Identifier Lengths (in bytes)
  • Maximum String Length Limits
  • Date and Time Values
  • Numeric Limits
  • System and Operational Limits
Parent topic: SQL Reference


Maximum Identifier Lengths (in bytes)

Item | Limit
Alias Name | 18
AuthID | 8
Collection ID | 18
Column Name | 18
Correlation Name | 18
Cursor Name | 18
Database Name | 8
Index Name | 18
Location Name | 16
Procedure Name | 18
Referential Constraint Name | 8
Statement Name | 18
Storage Group (stogroup) Name | 8
Synonym Name | 18
Table Name | 18
Table Space Name | 8
View Name | 18
Parent topic: Overview of XDB Server Specifications


Maximum String Length Limits

Item | Limit
Maximum length of a CHAR field (bytes) | 4,056
Maximum length of a VARCHAR field (bytes) | 32,706
Maximum length of a LONGVARchar field (bytes) | 32,706
Maximum length of a GRAPHIC field | 127
Maximum length of a VARGraphic field | 16,353
Maximum length of a LONGVARGraphic field | 16,353
Parent topic: Overview of XDB Server Specifications


Date and Time Values

Item | Limit
Smallest DATE Value (shown in ISO format) | 0001-01-01
Largest DATE value (shown in ISO format) | 9999-12-31
Smallest TIME value (shown in ISO format) | 00.00.00
Largest TIME value (shown in ISO format) | 24.00.00
Smallest TIMESTAMP value | 0001-01-01-00.00.00.000000
Largest TIMESTAMP value | 9999-12-31-24.00.00.000000
Parent topic: Overview of XDB Server Specifications


Numeric Limits

Item | Limit
Smallest SMALLINT value | -32,768
Largest SMALLINT value | 32,767
Smallest INTEGER value | -2,147,483,648
Largest INTEGER value | 2,147,483,647
Smallest DECIMAL value | 1-10E+31
Largest DECIMAL value | 10E+31-1
Largest decimal precision | 31
Smallest 4-byte float value | 1.2E-38
Largest 4-byte float value | 3.4E+38
Smallest 8-byte float value | 2.2E-308
Largest 8-byte float value | 1.8E+308
Largest money value | $10E+12
Smallest money value | -$10E+12
Parent topic: Overview of XDB Server Specifications


System and Operational Limits

Item | Limit
Maximum number of columns in a table or view | 750
Maximum record length (in bytes) (See note 1.) | 32,767
Maximum number of volume IDs in a storage group | 133
Maximum number of queries open at one time | 50 per user
Maximum length of an SQL statement | 32,767
Maximum projected columns in a SELECT list | 750
Maximum UNION operators in a SELECT statement | 32
Maximum number of predicates in a WHERE or HAVING clause | No Limit
Maximum number of columns in a GROUP BY clause | 750
Maximum number of columns in an ORDER BY clause | 750
Maximum number of tables in a FROM clause (number of tables per JOIN) | 15
Maximum bytes in a compound index | 203
Maximum index field length (in bytes) (See note 2.) | 4056
Maximum number of indexes per table | No limit
Maximum number of columns in an index key | 64
Maximum number of records per table | 2 billion +
Maximum number of databases (See note 3.) | No limit
Maximum number of locations open at a time (single user) | 10
Maximum nested query levels | Limited only by system storage
Maximum queries per level | Limited only by system storage
Maximum recursion levels for PREVIOUS function with index (no limit without index) | 20
Maximum sort fields | 750
Maximum number of elements in a SELECT list | 750

Table Notes:

  1. Including 2 byte record overhead plus 1 byte overhead for odd length character fields and 2 byte overhead for other field types.
  2. Only the first 254 characters of a field are actually used in creating the index.
  3. Limited by storage space and operating system.
Parent topic: Overview of XDB Server Specifications


XDB Server Reserved Words

This topic lists reserved words or keywords used by the XDB Server and utilities. Other words which may become reserved are listed as well.

XDB Server SQL reserved words should not be used as object (for example, locations, databases, tables, indexes, columns) names. Some XDB Server tools and utilities may place other restrictions on database object names. In general, XDB Server reserved words are not case sensitive.

More:

  • Reserved Words: DB2 Mode
  • Reserved Words: DB2 Mode
  • Reserved Words: XDB Mode
  • Future Reserved Words
Parent topic: SQL Reference


Reserved Words: DB2 Mode

These words are reserved if you are running in DB2 Mode.

add | delete | grant | obid | stogroup
all | descriptor | group | of | synonym
alter | distinct |  | on |
and | drop | having | optimize | table
any |  |  | or | tablespace
as | editproc | immediate | order | to
audit | end-exec | in |  |
 | erase | index | package | union
between | escape | insert | part | update
bufferpool | except | into | plan | user
by | execute | is | priqty | using
 | exists |  | privileges |
cluster |  | key | program | validproc
collection | fetch |  |  | values
column | fieldproc | like | row | vcat
concat | for | locksize |  | view
count | from |  | secqty | volumes
current |  | not | select |
cursor | go | null | set | where
 | goto | numparts | some | with
database |  |  |  |
Parent topic: XDB Server Reserved Words


Reserved Words: XDB Mode

These words are reserved if you are running in XDB Mode.

add | distinct | key | select | where
all | double |  | set | with
alter | drop | level | some |
and |  | like | sounds | xabs
any | editproc |  | stogroup | xconcat
as | erase | modify | synonym | xdate
audit | escape | money |  | xday
 | except |  | table | xexp
between | exists | not | tablespace | xleft
bottom |  | null | to | xlength
bufferpool | fetch |  | today | xln
by | fieldproc | of |  | xlog
 | for | on | undelete | xlower
cluster | from | or | union | xmid
coalesce |  | order | unique | xmonth
collection | grant |  | unlock | xpower
column | group | package | update | xright
concat |  | previous | user | xsqrt
connect | having | priqty | using | xstddev
count | host | privileges |  | xtime
current |  | program | validproc | xtimestamp
 | in |  | values | xtoday
database | index | rename | variable | xtrim
datetime | insert | row | vcat | xupper
delete | into |  | view | xvar
directories | is | secqty | volumes | xyear
Parent topic: XDB Server Reserved Words


Future Reserved Words

The following words are IBM or ANSI SQL reserved words (or possible SQL future reserved words) that are not reserved by the XDB Server. We recommend you avoid the use of these for object names.

applpath | tmppath
dbpath | xdbpath
sysdbpath |

In addition, note that XDB Server extensions will generally use keywords that begin with the letter X. It is therefore recommended that you avoid names beginning with X.

Parent topic: XDB Server Reserved Words


SQL Communications Area (SQLCA)

The SQL Communications Area (SQLCA) is a data area used to store information on the execution of SQL commands. The SQLCA is used as a diagnostic tool to determine whether an SQL statement executed correctly. The SQLCA is updated after each SQL statement is executed.

  • SQLCA Description
  • SQLCA Structure For COBOL
  • SQLCA Structure For C
  • SQLCA Structure For PL/I
Parent topic: SQL Reference
Related information
SQLCA Description
SQLCA Structure For COBOL
SQLCA Structure For C
SQLCA Structure For PL/I


SQLCA Description

The SQLCA is described in the following table, including the field names used in each language, the data type, and a discussion of the purpose of each field.

COBOL Name | C Name | Data Type | Purpose
SQLCAID | sqlcaid | char(8) | A character string (SQLCA) that identifies the beginning of the SQLCA.
SQLCABC | sqlcabc | integer | Specifies the length of the SQLCA. Value is always 136.
SQLCODE | sqlcode | integer | Contains a return code pertaining to the most recent SQL statement executed. Important values are: 0 Statement executed successfully (may have had warnings). >0 Executed successfully but with an exception condition. <0 An error occurred. 100 End of data reached.
SQLERRML | sqlerrml | smallint | The length of the SQLERRMC string (0 to 70). If 0, the value of SQLERRMC is not pertinent.
SQLERRMC | sqlerrmc | varchar (70) | One or more tokens, separated by x'ff', that are substituted into error messages to provide specific information about an error condition.
SQLERRP | sqlerrp | char(8) | Indicates the product signature in the format pppvvrrm where: ppp = XDB vv = XDB version number rr = XDB release number m = Operating system: N = NT O = OS/2 D = DOS
SQLERRD(1) | sqlerrd[0] | integer | Reserved for internal use.
SQLERRD(2) | sqlerrd[1] | integer | Reserved for internal use.
SQLERRD(3) | sqlerrd[2] | integer | Number of rows affected by an INSERT, UPDATE or DELETE command.
SQLERRD(4) | sqlerrd[3] | integer | Not used by XDB Server.
SQLERRD(5) | sqlerrd[4] | integer | Contains the position or column of a syntax error for a PREPARE or EXECUTE IMMEDIATE statement.
SQLERRD(6) | sqlerrd[5] | integer | Not used by XDB Server.
SQLWARN0 | sqlwarn0 | char(1) | Flag used to signal warning condition. If blank, then all other SQLWARN variables are blank. If value is W, then at least one other SQLWARN has a W.
SQLWARN1 | sqlwarn1 | char(1) | If value is W, then at least one column's value was truncated when stored in a host variable.
SQLWARN2 | sqlwarn2 | char(1) | If value is W, then at least one null value was eliminated from the argument of a column function. May not be set to W for a MIN function because its results are not dependent on the elimination of null values.
SQLWARN3 | sqlwarn3 | char(1) | If value is W, then the number of columns is larger than the number of host variables. Contains Z if fewer locators were provided in the ASSOCIATE LOCATORS statement than the stored procedure returned.
SQLWARN4 | sqlwarn4 | char(1) | If value is W, then a prepared UPDATE or DELETE statement does not contain a WHERE clause.
SQLWARN5 | sqlwarn5 | char(1) | If value is W, your program tried to create an index that contains a field that exceeds the maximum length for an index. This use is XDB Server-specific.
SQLWARN6 | sqlwarn6 | char(1) | Not used by XDB Server.
SQLWARN7 | sqlwarn7 | char(1) | Not used by XDB Server.
SQLWARN8 | sqlwarn8 | char(1) | Not used by XDB Server.
SQLWARN9 | sqlwarn9 | char(1) | Contains Z if the stored procedure returned multiple result sets.
SQLWARNA | sqlwarna | char(1) | Not used by XDB Server.
SQLSTATE | sqlstate | char(5) | Contains SQLSTATE value for this error.
Parent topic: SQL Communications Area (SQLCA)


SQLCA Structure For COBOL

The structure of the SQLCA is defined in the copybook sqlca.cpy. It must be included in every COBOL program that contains embedded SQL.

The SQLCA structure for COBOL is as follows:

 01 SQLCA.
     05  SQLCAID         PIC X(8)         VALUE "SQLCA   ".
     05  SQLCABC         PIC S9(9) COMP-5 VALUE 136.
     05  SQLCODE         PIC S9(9) COMP-5 VALUE 0.
     05  SQLERRM.
         49  SQLERRML    PIC S9(4) COMP-5.
         49  SQLERRMC    PIC X(70).
     05  SQLERRP         PIC X(8).
     05  SQLERRD         PIC S9(9) COMP-5 OCCURS 6 VALUE 0.
     05  SQLWARN.
         10  SQLWARN0    PIC X.
         10  SQLWARN1    PIC X.
         10  SQLWARN2    PIC X.
         10  SQLWARN3    PIC X.
         10  SQLWARN4    PIC X.
         10  SQLWARN5    PIC X.
         10  SQLWARN6    PIC X.
         10  SQLWARN7    PIC X.
         10  SQLWARN8    PIC X.
         10  SQLWARN9    PIC X.
         10  SQLWARN10   PIC X.
         10  SQLWARNA    PIC X REDEFINES SQLWARN10.
     05  SQLSTATE    PIC X(5).
Parent topic: SQL Communications Area (SQLCA)


SQLCA Structure For C

The structure of the SQLCA is defined in the include file SQLCA.H. It must be included in every C program that contains embedded SQL.

#ifndef SQLCODE
struct sqlca
{
  unsigned char  sqlcaid[8];
  long      sqlcabc;
  long      sqlcode;
  short      sqlerrml;
  unsigned char  sqlerrmc[70];
  unsigned char  sqlerrp[8];
  long      sqlerrd[6];
  unsigned char  sqlwarn[11];
  unsigned char  sqlstate[5];
};
#define SQLCODE  sqlca.sqlcode
#define SQLWARN0  sqlca.sqlwarn[0]
#define SQLWARN1  sqlca.sqlwarn[1]
#define SQLWARN2  sqlca.sqlwarn[2]
#define SQLWARN3  sqlca.sqlwarn[3]
#define SQLWARN4  sqlca.sqlwarn[4]
#define SQLWARN5  sqlca.sqlwarn[5]
#define SQLWARN6  sqlca.sqlwarn[6]
#define SQLWARN7  sqlca.sqlwarn[7]
#define SQLWARN8  sqlca.sqlwarn[8]
#define SQLWARN9  sqlca.sqlwarn[9]
#define SQLWARNA  sqlca.sqlwarn[10]
#define SQLSTATE  sqlca.sqlstate
#endif
struct sqlca sqlca;
Parent topic: SQL Communications Area (SQLCA)


SQLCA Structure For PL/I

The SQLCA structure for PL/I is as follows:

dcl
   1 sqlca,
     2 sqlcaid    char(8),
     2 sqlcabc    fixed bin(31),
     2 sqlcode    fixed bin(31),
     2 sqlerrm    char(70) varying,
     2 sqlerrp    char(8),
     2 sqlerrd(6) fixed bin(31),
     2 sqlwarn,
       3 sqlwarn0 char(1),
       3 sqlwarn1 char(1),
       3 sqlwarn2 char(1),
       3 sqlwarn3 char(1),
       3 sqlwarn4 char(1),
       3 sqlwarn5 char(1),
       3 sqlwarn6 char(1),
       3 sqlwarn7 char(1),
     2 sqlext,
       3 sqlwarn8 char(1),
       3 sqlwarn9 char(1),
       3 sqlwarna char(1),
       3 sqlstate char(5);
Parent topic: SQL Communications Area (SQLCA)


SQL Descriptor Area (SQLDA)

The SQL Descriptor Area (SQLDA) is a data area that holds information about dynamic SQL commands. An SQLDA might be used in a DESCRIBE statement to find out information about columns returned by a query, and then reused for a FETCH statement when the values are actually selected.

The SQLDA consists of four variables, followed by a variable number of SQLVAR structures. SQLVAR structures describe columns if OPEN, FETCH or EXECUTE statements are involved. For DESCRIBE and PREPARE statements, the SQLVAR structures describe host variables.

This topic provides descriptions of the information provided in the SQLDA and shows the structure for COBOL, PL/I and C.

More:

  • SQLDA Elements
  • SQLVAR Elements
  • SQLDA Structure For COBOL
  • SQLDA Elements
  • SQLVAR Elements
  • SQLTYPE Values
  • SQLLEN Values
  • SQLDA Structure For COBOL
  • SQLDA Structure For C
  • SQLDA Structure For PL/I
Parent topic: SQL Reference


SQLDA Elements

The SQLDA consists of the four elements shown in the table below, followed by the number of SQLVAR structures specified in SQLN.

Each occurrence of SQLVAR describes a column (for DESCRIBE and PREPARE statements) or host variable (for OPEN, FETCH and EXECUTE statements), depending on the type of statement being executed. The number of SQLVAR elements appearing in the SQLDA is defined by the SQLN element of SQLDA, thus the SQLDA structure is variable length. The SQLVAR structure is shown in the following table.

COBOL Name | C Name | PL/I Name | Data Type | Usage in DESCRIBE and PREPARE INTO | Usage in FETCH, OPEN or EXECUTE
SQLDAID | sqldaid | sqldaid | char(8) | The character string (SQLDA) that identifies the beginning of the SQLDA structure. | Same.
SQLDABC | sqlabc | sqlabc | integer | Length of the SQLDA. Computed as SQLN*44+16. | Same.
SQLN | sqln | sqln | smallint | Number of occurrences of SQLVAR. (See the SQLVAR Elementsfor more about SQLVAR.) | Same.
SQLD | sqld | sqld | smallint | Number of columns described by occurrences of SQLVAR. If the statement is not a query, the value is zero. (See the SQLVAR Elementsfor more about SQLVAR.) | Number of host variables described by occurrences of SQLVAR.
Parent topic: SQL Descriptor Area (SQLDA)


SQLVAR Elements

COBOL Name | C Name | PL/I Name | Data Type | Usage in DESCRIBE and PREPARE INTO | Usage in FETCH, OPEN or EXECUTE
SQLTYPE | sqltype | sqltype | smallint | Code indicating the data type of the column and if null values are allowed. See the table in SQLTYPE Values for SQLTYPE codes. | Indicates the data type of a host variable and if an indicator variable is provided. See the table in SQLTYPE Values for SQLTYPE codes.
SQLLEN | sqllen | sqllen | smallint | Indicates the length attribute of the columns. For date/time columns, the length of the string representation of the value is used. See the table under SQLLEN Values for SQLLEN values. | Indicates the length attribute of the host variable. See the table under SQLLEN Values for SQLLEN values.
SQLDATA | sqldata | sqldata | pointer to a buffer | Contains the CCSID indicator for bit data Format is x'0000'zzzz' where zzzz is X'FFFF' | Contains the address of the host variable.
SQLIND | sqlind | sqlind | pointer | Undefined. | Contains the address of an associated indicator variable if SQLTYPE is odd.
SQLNAME | sqlname | sqlname | char(30) | Name of the column (or a string of length zero if no name exists). | Not used in XDB Server.

More:

  • SQLTYPE Values
  • SQLLEN Values
Parent topic: SQL Descriptor Area (SQLDA)


SQLTYPE Values

The meanings of SQLTYPE values depend on the type of statement executed, as shown in the table below. The following differences should be noted:

  • For DESCRIBE and PREPARE

    The codes for DB2 mode differ depending on whether or not null values are allowed in the column. An even value for SQLTYPE indicates that the column does not allow nulls. An odd value indicates that the column does allow nulls. In XDB mode, the codes do not differ.

  • For FETCH, OPEN and EXECUTE

    Codes differ depending on whether or not indicator variables are provided for use with the host variable. An even value for SQLTYPE means no indicator variable is provided, an odd value indicates that SQLIND contains the address of an indicator variable.

    In addition, because host variables do not include DATE, TIME or TIMESTAMP data types, these values are usually retrieved using fixed length character strings.

    Data Type | DESCRIBE & PREPARE | FETCH, OPEN & EXECUTE
    DB2 Mode: XDB Mode No Indicator Indicator
    date

    (See note 1.)

             384 385 4 384 385
    time

    (See note 1.)

             388 389 7 388 389
    timestamp

    (See note 1.)

             392 393 11 392 393
    varying-length character string | 448 | 449 | 9 | 448 | 449
    fixed-length character string | 452 | 453 | 6 | 452 | 453
    long varying length character string | 456 | 457 | 10 | 456 | 457
    varying length graphic string | 464 | 465 | 17 | 464 | 465
    fixed length graphic string | 468 | 469 | 16 | 468 | 469
    long varying length graphic string

    (See note 2.)

             472 473 22 472 473
    floating point | 480 | 481 | 3 | 480 | 481
    packed decimal | 484 | 485 | 8 | 484 | 485
    money | 484 | 485 | 5 | 484 | 485
    large integer | 496 | 497 | 2 | 496 | 497
    small integer | 500 | 501 | 1 | 500 | 501

Table Notes:

  1. For host variable, a fixed-length character string representation of the date, time or timestamp is used.
  2. For host variable, a long graphic string.
Parent topic: SQL Descriptor Area (SQLDA)


SQLLEN Values

The value of SQLLEN depends on the data type of the columns. SQLLEN gives the length of data (in bytes), depending on data type.

Data Type | SQLLEN Value for DESCRIBE | SQLLEN Value for FETCH, OPEN and EXECUTE
date (See note 1.) | 10 bytes | length attribute of the host variable
time (See note 1.) | 8 bytes | length attribute of host variable
timestamp (See note 1.) | 26 bytes | length attribute of the host variable
character strings - varying-length - fixed-length - long varying-length | length attribute of the column | length attribute of the host variable
graphic strings - varying-length - fixed length - long varying-length (See note 2.) | length attribute of the column | length attribute of the host variable
floating point | 4 for single precision 8 for double precision | 4 for single precision 8 for double precision
packed decimal | precision in byte 1 scale in byte 2 | precision in byte 1 scale in byte 2
integer | 4 bytes | 4 bytes
small integer | 2 bytes | 2 bytes

Table Notes:

  1. For host variable, a fixed-length character string representation of the date, time or timestamp is used.
  2. For host variable, a long graphic string.
Parent topic: SQL Descriptor Area (SQLDA)


SQLDA Structure For COBOL

The SQLDA structure is provided in the copybook sqlda.cpy. Include this copybook in all COBOL programs that make use of dynamic SQL.

 01 SQLDA sync.
     05 SQLDAID               PIC X(8)  VALUE "SQLDA  ".
     05 SQLDABC               PIC S9(9) COMP-5 value 0.
     05 SQLN                  PIC S9(4) COMP-5 value 0.
     05 SQLD                  PIC S9(4) COMP-5 value 0.
     05 SQLVAR OCCURS 0 TO 1489 TIMES DEPENDING ON SQLD.
         10 SQLTYPE            PIC S9(4) COMP-5.
         10 SQLLEN             PIC S9(4) COMP-5.
         10 SQLDATA            USAGE POINTER.
         10 SQLIND             USAGE POINTER.
         10 SQLNAME.
             15 SQLNAMEL        PIC S9(4) COMP-5.
             15 SQLNAMEC        PIC X(30).

If you are using the Precompiler directive SQLDA-VER = 0, you must copy the file sqlda.old to sqlda.cpy. The structure of this SQLDA is below:

01 SQLDA.
  03 SQLDAID    PIC X(8).
  03 SQLDABC    PIC S9(9) COMP.
  03 SQLN    PIC S9(4) COMP.
  03 SQLD    PIC S9(4) COMP.
  03 SQLVAR OCCURS 300.
    05 SQLTYPE  PIC S9(4) COMP.
    05 SQLLEN  PIC S9(4) COMP.
    05 SQLDATA  PIC X(4).
    05 SQLIND  PIC X(4).
    05 SQLNAME  PIC X(30).
Parent topic: SQL Descriptor Area (SQLDA)


SQLDA Structure For C

The SQLDA structure is provided in the file sqlca.h. Include this file in all C programs that make use of dynamic SQL.

#ifndef SQLDASIZE
struct sqlda
{
  unsigned char  sqldaid[8];
  long      sqldabc;
  short      sqln;
  short      sqld;
  struct sqlvar
  {
    short      sqltype;
    short      sqllen;
    unsigned char    *sqldata;
    short      *sqlind;
    struct sqlname
    {
      short      length;
      unsigned char    data[30];
    } sqlname;
  } sqlvar[1];
};
#define SQLDASIZE(n) (sizeof(struct sqlda)+
      (n-1)*sizeof(struct sqlvar))
#endif
Parent topic: SQL Descriptor Area (SQLDA)


SQLDA Structure For PL/I

The SQLDA structure is provided in the copybook SQLDA.INC. Include this copybook in all PL/I programs that make use of dynamic SQL.

dcl sqlsize fixed binary(15);
dcl sqldaptr ptr;
dcl
   1 sqlda based (sqldaptr),
     2 sqldaid    char(8),
     2 sqldabc    fixed bin(31),
     2 sqln       fixed bin(15),
     2 sqld       fixed bin(15),
     2 sqlvar     (sqlsize refer (sqln)),
       3 sqltype  fixed bin(15),
       3 sqllen   fixed bin(15),
       3 sqldata  ptr,
       3 sqlind   ptr,
Parent topic: SQL Descriptor Area (SQLDA)


SQL Option Server TUTORIAL Location

  • Overview of the Tutorial Tables
  • CONSTANT Table
  • CUSTOMER Table
  • DEPT (Department) Table
  • EMPLOYEE Table
  • ITEMS Table
  • ORDERS Table
  • PART Table
  • PARTSUPP Table
  • PRODUCTS Table
  • QMT_STAFF Table
  • SUBPART Table
  • SUPPLIER Table
Parent topic: SQL Reference


Overview of the Tutorial Tables

Most of the examples in this and other SQL Option Server references are based on the tutorial tables listed below. You can execute the example SQL statements appearing throughout this reference. Any results displayed from these examples should exactly correspond to the results obtained if you execute the same example against the tutorial tables listed below.

  • CONSTANT Table
  • CUSTOMER Table
  • DEPT (Department) Table
  • EMPLOYEE Table
  • ITEMS Table
  • ORDERS Table
  • PART Table
  • PARTSUPP Table
  • PRODUCTS Table
  • QMT_STAFF Table
  • SUBPART Table
  • SUPPLIER Table
Parent topic: SQL Option Server TUTORIAL Location


CONSTANT Table

o_no | c_no | e_no
6 | 22 | 11
Parent topic: SQL Option Server TUTORIAL Location


CUSTOMER Table

c_no | company | address | city | state | zip | phone | balance
1 | Great Software | 123 Main St | Baltimore | MD | 21212 | 301 222-2222 | 828.60
2 | Unique Systems | 111 First St | Atlanta | GA | 30303 | 404 987-6543 | 3434.00
3 | Commuter Communication | 333 Last St | Washington | DC | 20002 | 202 123-4567 | 648.00
4 | Popular Consulting | 321 Home Dr | Berkeley | CA | 94004 | 516 444-5555 | 2209.00
5 | Unlimited Supply | 213 River Rd | Berkeley | CA | 94004 | 516 555-6789 | 772.00
6 | ABC Corp. | 1 Any Place | Somewhere | MD | 12345 | 301 456-7890 | 63.60
7 | Perfect Software | 1 Address St | Citytown | CA | 12345 | 516 222-3333 | 0.00
8 | Business Technology | 123 Main St | College Park | MD | 20740 | 301 222-3333 | 418.70
9 | Performance Software | 1 First St | Baltimore | MD | 21212 | 301 999-9999 | 2244.20
10 | Problem Solver | 123 Broadway St | Chicago | IL | 54321 | 555 888-8888 | 2000.00
11 | Technology Leader | 100 Oneway St | New York | NY | 98765 | 777 555-5555 | 3000.00
12 | New Startup, Inc. | 101 Nosuch Rd | New York | NY | 87654 | 777 777-7777 | 2345.00
13 | Database Experts | 123 Expert Rd | College Park | MD | 20740 | 301 232-3232 | 1234.00
14 | Instant Success Corp | 111 Goodluck Rd | Niceplace | NY | 13579 | 777 246-1357 | 123.00
15 | Ace Debug Co. | 999 Last St | Littletown | NJ | 11111 | 999 888-7777 | 987.00
16 | Non Stop Systems | 100 Running Rd | Computown | CA | 99999 | 516 222-3333 | 5000.00
17 | Reliable Software | 1000 Longlive St | Oldtown | CA | 99999 | 516 555-5555 | 7606.10
18 | Brandname Systems | 1001 Wellknown St | Popular | IL | 54321 | 555 444-3333 | 543.00
19 | Survival Technology | 100 Deadend St | Nowhere | IL | 56789 | 555 666-7777 | 5678.00
20 | Success Business | 123 Lucky St | College Park | MD | 20740 | 301 333-2222 | 3407.90
21 | Advanced Systems | 100 Fast St | Bulletown | CA | 54321 | 516 222-1111 | 100.00
Parent topic: SQL Option Server TUTORIAL Location


DEPT (Department) Table

dept | dname | mgr
1050 | Sales | 9
2020 | Accounting | 2
Parent topic: SQL Option Server TUTORIAL Location


EMPLOYEE Table

e_no | lname | fname | street | city | st | zip | dept | payrate | com
1 | Hurwood | Roger | 1234 Stirrup La | Green Valley | MD | 20441 | 2020 | 16.00 |
2 | Kerin | Linda | 802 Wilderness Dr | Wild Woods | VA | 33256 | 2020 | 17.50 |
3 | Gross | Mary | 303 Stagecoach Rd | Green Valley | MD | 20441 | 2020 | 10.00 |
4 | Wilson | Arthur | 211 Main St | Yellow Fountain | VA | 33210 | 2020 | 17.50 |
5 | Chung | Yung | 422 Maple St | Garden City | MD | 20331 | 1050 | 12.25 | 0.05
6 | Cox | John | 555 Magnolia Dr | Garden City | MD | 20331 | 2020 | 14.70 |
7 | Crisp | Keith | Rt 2, Box 43 | Yellow Fountain | VA | 33210 | 1050 | 9.00 | 0.05
8 | Hurwood | Susan | 1234 Stirrup La | Green Valley | MD | 20441 | 2020 | 11.25 |
9 | Hopkins | James | 345 Forest Dr | Yellow Fountain | VA | 33210 | 1050 | 17.00 | 0.03
10 | Haley | Olaf | 334 Market St | Green Valley | MD | 20441 | 1050 | 13.70 | 0.06
Parent topic: SQL Option Server TUTORIAL Location


ITEMS Table

o_no | p_no | quantity | price
1 | 101 | 1 | 50.00
2 | 102 | 1 | 279.00
2 | 103 | 2 | 125.00
3 | 101 | 2 | 50.00
4 | 101 | 2 | 50.00
4 | 103 | 2 | 125.00
5 | 102 | 3 | 279.00
5 | 103 | 3 | 125.00
Parent topic: SQL Option Server TUTORIAL Location


ORDERS Table

o_no | c_no | o_date | s_no
1 | 1 | 09/10/1991 | 5
2 | 2 | 10/10/1991 | 7
3 | 4 | 10/12/1991 | 5
4 | 1 | 10/25/1991 | 5
5 | 9 | 10/30/1991 | 7
Parent topic: SQL Option Server TUTORIAL Location


PART Table

pno | pname | color | weight | city
P1 | NUT | RED | 12 | LONDON
P2 | BOLT | GREEN | 17 | PARIS
P3 | CAM | BLUE | 12 | PARIS
P4 | SCREW | RED | 14 | LONDON
P5 | CAM | BLUE | 12 | PARIS
P6 | COG | RED | 19 | LONDON
Parent topic: SQL Option Server TUTORIAL Location


PARTSUPP Table

sno | pno | qty
S1 | P1 | 300
S1 | P3 | 400
S2 | P2 | 400
S3 | P2 | 200
S1 | P2 | 200
S1 | P4 | 200
S1 | P5 | 100
S1 | P6 | 100
S2 | P1 | 300
S4 | P2 | 200
S4 | P4 | 300
S4 | P5 | 400
Parent topic: SQL Option Server TUTORIAL Location


PRODUCTS Table

p_no | description | price
101 | Floppy Disk Drive | 50.00
102 | 9600B Modem | 279.00
103 | VGA Graphics Card | 125.00
104 | Mouse | 85.00
201 | 304M Hard Disk | 539.00
202 | Sound Card | 189.00
203 | Game Card | 30.00
204 | VGA Monitor | 329.00
301 | CD ROM Drive | 354.00
302 | Math Coprocessor | 199.00
303 | Tape Backup | 269.00
304 | Laser Printer | 1594.00
Parent topic: SQL Option Server TUTORIAL Location


QMT_STAFF Table

EMPID | LNAME | FNAME | DEPARTMENT | JOB | YEARS | SALARY | COMMISSION
110 | SIMPSON | MIKE | 120 | MGR | 7 | 18,380.15 | 000500.00
120 | PETREE | STEVE | 120 | SALES | 8 | 18,193.90 | 01,664.73
130 | MILES | LISA | 138 | MGR | 5 | 17,529.00 |
145 | BACON | CARL | 138 | SALES | 2 | 15,000.00 | 01,008.66
150 | HANSON | KATHY | 115 | MGR | 10 | 20,682.45 |
165 | MYERS | ROGER | 138 | SALES | 3 | 16,830.00 | 01,102.23
170 | RODMAN | CHUCK | 115 | SALES | 7 | 16,525.48 | 02,204.28
180 | JASON | JOHN | 120 | CLERK |  | 13,527.25 | 01,180.48
190 | BEAGLE | HUTCH | 142 | SALES | 6 | 18,024.40 | 02,438.98
200 | WENTZ | STEVEEN | 142 | MGR | 7 | 18,375.45 |
210 | ARNA | ISMETT | 115 | CLERK | 5 | 12,530.85 | 01,258.88
225 | MACKEY | DONNA | 138 | CLERK | 1 | 12,077.00 | 000139.28
230 | YAMAGUCHI | KATRINA | 142 | CLERK | 6 | 10,528.55 | 01,127.88
240 | FRITZE | MARY ANN | 151 | MGR | 6 | 21,172.65 |
250 | WILLIAMS | DOUG | 151 | SALES | 6 | 19,479.15 | 01,689.93
260 | MOLITOR | MITCH | 110 | MGR | 7 | 22,981.85 | 01,500.00
270 | KERMIT | JASON | 115 | CLERK | 4 | 12,281.15 | 01,162.38
280 | ABLE | OTTO | 138 | CLERK | 3 | 12,032.00 | 01,288.78
290 | SNEAD | XIAOLIN | 120 | CLERK | 8 | 14,275.40 | 01,178.78
300 | SCOTT | ARLENE | 142 | CLERK |  | 11,531.25 | 01,136.48
310 | KUANG | CHUNG | 110 | MGR | 10 | 20,032.65 |
320 | SMITHERS | JOHN | 151 | SALES | 7 | 17,677.15 | 02,045.08
330 | LILLY | CRAIG | 151 | CLERK | 3 | 13,392.45 | 01,241.93
340 | DAVISON | DAJUN | 110 | MGR | 5 | 19,282.90 |
350 | WHITEHURS | MIKE | 151 | CLERK | 6 | 14,482.65 | 01,565.58
360 | JANNET | JIM | 110 | MGR | 12 | 21,256.65 |
370 | STROM | RAYMOND | 166 | MGR | 9 | 18,578.15 |
380 | WILLIAMS | ROBERT | 166 | SALES | 9 | 18,697.15 | 01,863.78
390 | QUILT | CHRISTINE | 184 | MGR | 10 | 19,840.65 |
400 | DAVIDSON | STORM | 184 | SALES | 5 | 15,477.15 | 01,858.38
410 | GRASON | BILLY | 166 | SALES | 13 | 21,022.65 | 01,252.58
420 | GONZALES | RENEA | 166 | SALES | 4 | 16,880.85 | 01,896.28
430 | BURRELS | RUSTY | 166 | CLERK | 1 | 11,010.65 | 01,107.78
440 | EDEN | EDDIE | 184 | SALES | 7 | 17,866.65 | 02,337.28
450 | GAGNEY | GREG | 184 | CLERK | 5 | 13,053.15 | 01,240.28
140 | BROOKS | DAVID | 138 | SALES | 6 | 25,000.00 | 02,008.66
160 | MISSON | STEVEN | 138 | SALES | 3 | 16,800.00 | 01,900.23
220 | MASSON | STEFANIE | 138 | CLERK | 5 | 22,077.00 | 02,139.28
142 | STANCEL | WILLIAM | 138 | SALES |  | 12,000.00 | 000088.66
133 | ELDER | NANCY | 138 | MGR | 2 | 16,529.00 |
255 | KENNER | CAL | 151 | SALES | 2 | 13,479.15 | 01,000.00
Parent topic: SQL Option Server TUTORIAL Location


SUBPART Table

product | subpart | qty
P7 | P1 | 2
P7 | P2 | 4
P7 | P6 | 6
P8 | P4 | 8
P8 | P7 | 1
P9 | P5 | 3
P9 | P7 | 5
P9 | P8 | 7
P10 | P1 | 9
P10 | P2 | 1
P11 | P9 | 2
P11 | P10 | 3
Parent topic: SQL Option Server TUTORIAL Location


SUPPLIER Table

sno | sname | status | city
S1 | SMITH | 20 | LONDON
S2 | JONES | 10 | PARIS
S3 | BLAKE | 30 | PARIS
S4 | CLARK | 20 | LONDON
S5 | ADAMS | 30 | ATHENS
Parent topic: SQL Option Server TUTORIAL Location


Objects Used by the SQL Option Server

This topic describes the paths and object names that are created and/or used by the SQL Option Server when you create various data objects in SQL Option Server locations. The storage structure and object names depend on the options you specify in your CREATE statements. In the chart, the first two columns of a given row define the condition that is described in the remaining columns of that row (by reading across).

If stogroup is sysdeflt, the location path is used as the stogroup path. When objects are created, the ..\loc-path\dbname\ path is used.

To generate file names for objects that have names greater than 8 characters (for example, 18-character table names), The SQL Option Server truncates the long name to 8 characters. If the resulting file name would not be unique, a unique file name is generated automatically.

The following list explains the abbreviations used in the chart:

Abbreviation | Meaning
Dbname | Database name
Tsname | Table space name
Sto-name | Storage Group name
Dbsto-path | Disk drive and path defined for the database (DB) stogroup.
Tssto-path | Disk drive and path defined for the table space (TS) stogroup.
Loc-path | Disk drive and path defined for the location.

This chart does not list all possible combinations of creation conditions. Only the more common conditions are shown.

If you create a | And you specify a | The SQL Option Server creates or uses ..
 |  | Path | Stogroup | Database | Table/Index Space
Stogroup | Volumes Vcat (No path defined) | ..\loc-path\dbname\ path is used when objects are created | Sto-name you enter | n/a | n/a
Stogroup | Volumes Vcat XdbVolPath | XdbVolPath you enter in SYSIBM.SYSVOLUMES (for example, c:\sto-path) | Sto-name you enter | n/a | n/a
Database | ------ | c:\loc-path\dbname\ | SYSDEFLT | DBname you enter | n/a
Database | Stogroup | c:\DBsto-path\ | Sto-name you enter | DBname you enter | n/a
Table Space | Database | c:\loc-path\dbname\ | SYSDEFLT | DBname you enter | TSname you enter
Table Space | Database Stogroup (Sto-path for the named stogroup is missing from SYSIBM. SYSVOLUMES) | c:\loc-path\dbname\ | SYSDEFLT | DBname you enter | TSname you enter
Table Space | Database Stogroup (Sto-path exists in SYSIBM. SYSVOLUMES and on op system) | c:\TSsto-path\ | Sto-name you enter | DBname you enter | TSname you enter
Table | ------ | c:\loc-path\DSNDB04\*.tab | SYSDEFLT | DSNDB04 | TSname is first 8 characters of table name (or system generated unique name, if needed)
Table | Database (DB has NO stogroup) | c:\loc-path\dbname\*.tab | SYSDEFLT | DBname you enter | TSname is first 8 characters of table name (or system generated unique name, if needed)
Table | Database (DB has a stogroup) | c:\DBsto-path\*.tab | Same sto-name as the database's stogroup | DBname you enter | TSname is first 8 characters of table name (or system generated unique name, if needed)
Table | Database Tablespace (DB has NO stogroup; TS has NO stogroup) | c:\loc-path\dbname\*.tab | SYSDEFLT | DBname you enter | TSname you enter
Table | Database Tablespace (DB has NO stogroup; TS has a stogroup) | c:\TSsto-path\*.tab | Same sto-name as the table space's stogroup | DBname you enter | TSname you enter
Table | Database Tablespace (DB has a stogroup; TS has NO stogroup) | c:\DBsto-path\*.tab | Same sto-name as the database's stogroup | DBname you enter | TSname you enter
Table | Database Tablespace (DB has a stogroup; TS has a stogroup) | c:\TSsto-path\*.tab | Same sto-name as the table space's stogroup | DBname you enter | TSname you enter
Index | Tablename (DB has NO stogroup) | Same path as associated table..\*.idx and ..\*.ptr | SYSDEFLT | DBname to which associated table belongs | Index space name is same as index name
Index | Tablename (DB has a stogroup) | Same path as associated table..\*.idx and ..\*.ptr | Same sto-name as the database's stogroup | DBname to which associated table belongs | Index space name is same as index name
Index | Tablename Stogroup | Same path as associated table..\*.idx and ..\*.ptr | Sto-name you enter | DBname to which associated table belongs | Index space name is same as index name
Parent topic: SQL Reference


XDB Directive Options

  • ALLOW-HYPHEN
    Enables the preprocessor to allow hyphens in SQL identifiers.
  • APOST
    Causes the preprocessor to recognize apostrophes to delimit literals for quote character in SQL statements.
  • AUTHID
    Causes the preprocessor to include code at SQL initialization that sets the value of your current SQLID to any valid authorization ID.
  • AUTOBIND
    Causes the preprocessor to automatically call the SQL Option Bind utility from within the debugging session after the compiler finishes generating the DBRM if no SQL errors were detected and if the DBRM preprocessor directive was set.
  • AUTOCLOSE
    Causes the SQL Option Server to automatically open and close statements after an insert, update, or delete command.
  • BIND-SQLID
    Sets the current SQLID to this AuthID.
  • BLOCKING
    Specifies the type of block fetching to use.
  • CHANGE-CONTROL
    Controls package creation during the bind process.
  • COLLECTION-ID
    Specifies the collection at the remote DRDA server where the package will be bound.
  • CONCAT
    Specifies the ANSI character code to use for the CONCAT symbol (|).
  • COPY
    Causes the precompiler to expand copybooks included in your source code using standard COBOL COPY statements. Allows EXEC SQL statements and use of host variables to be defined within a COPY statement.
  • CTRACE
    Creates a trace file for submission to technical support if requested.
  • DATE
    Specifies the date format to be used with this program.
  • DB2
    Causes the SQL Option Server to return DB2 error codes and messages when compiling and running, and to close all open cursors at COMMIT and ROLLBACK (the DB2 standard).
  • DB2CLOSE
    Causes the SQL Option Server to close all open statements and cursors at COMMIT and ROLLBACK (the DB2 standard).
  • DB2ERROR
    Causes the SQL Option Server to return DB2 error codes and messages when the program is compiled or executed.
  • DB2VER
    Causes the SQL Option preprocessor to use DB2 version 5, 6 or 7 syntax checking.
  • DBRM
    Causes the SQL Option preprocessor to produce a DBRM file.
  • DECLARE
    Tells the preprocessor that host variables are declared in a BEGIN/END DECLARE section of a COBOL program.
  • DEFAULT-CHAR
    Specifies character subtype for all new character columns for which an explicit subtype is not specified.
  • DIRECTIVES
    Causes the SQL Option preprocessor to read the preprocessor directives contained in a separate user-created directives file or in the EXEC SQL options specified in the Build settings.
  • EXIST-CHECK
    Specifies whether to create a package if some DBRM objects do not exist.
  • FILLSYSCAT
    Causes the preprocessor to insert information about EXEC SQL statement in the program into the SYSDBRM and SYSSTMT system catalog tables when the COBOL program is compiled.
  • GENSQLCA
    Generates a SQLCA structure in the program if none is defined.
  • GRANT-EXECUTE
    Specifies AUTHID to grant execute privileges on the package to.
  • HYPHEN-IN-CURSOR
    Permits hyphens in cursor names.
  • IGNORE-NESTED
    Specifies in programs with nested subroutines, the program-id at which to start generating database interface code.
  • ISOLATION-LEVEL
    Controls the way in which locks are acquired and released by the system.
  • LIBINCLUDE
    Causes the precompiler to expand and include copybooks coded with ++INCLUDE or –INC syntax.
  • LOCATION
    Specifies the location to which a DBRM is bound when the AUTOBIND preprocessor directive is used.
  • MAXSQL
    Specifies the maximum number of EXEC SQL statements the preprocessor can handle.
  • NEVERCLOSE
    This directive prevents the closing of open statements or cursors at commit or rollback.
  • NOFOR
    Causes the SQL Option runtime not to require FOR UPDATE clause in DECLARE CURSOR statements when UPDATE CURRENT OF CURSOR is specified.
  • NOT
    Specifies the ASCII character code to use for NOT character (¬).
  • OPTIMIZE
    This directive optimizes the code generated by the precompiler specifically for use on either PC or mainframe.
  • PACKAGE-OWNER
    Specifies the AuthID assigned to the package. This AuthID must have authority to execute all the SQL in the package.
  • PKGSET
    Causes the SQL Option run-time program to send additional information to set the current package set.
  • QUOTE
    Causes the preprocessor to recognize double quotes to delimit literals for quote character in SQL statements.
  • SAVE-RETURN-CODE
    Causes the SQL Option precompiler to save and then restore RETURN-CODE when calling SQL Option functions
  • SQLDA-VER
    The SQLDA structure used in the program for dynamic SQL statements.
  • SQLDS
    Allows the SQL Option Server to accept a PREPARE statement before a DECLARE statement in your source code (which is allowed in SQL/DS)
  • STRICT-DB2
    Enforces strict support for certain DB2 features that are generally permitted in default DB2 mode.
  • TIME
    Specifies the time format to be used with this program.
  • VALIDATE
    Causes the SQL Option preprocessor to verify all data objects referenced in your program's embedded SQL statements against the SQL Option system tables.
  • VALIDATE-ERR-LVL
    Specifies the error level to use for errors produced when the VALIDATE directive is used.
  • VALIDATE-LOGIN
    Causes the SQL Option preprocessor to ensure communications with an SQL Option Server prior to attempting to validate any SQL statements. If the log in fails, a fatal error is generated.
  • VERSION
    Specifies the new version identifier for a replacement package.
  • XDBFUNCS
    Allows use of all SQL Option commands (including SQL Option extensions) in embedded SQL.
Parent topic: Reference


ALLOW-HYPHEN

Syntax:

[NO]ALLOW-HYPHEN

Parameters:

None

Properties:

Default: NOALLOW-HYPHEN

Comments:

This directive is only supported in version DB2 V7 or later. Before DB2 V7, hyphens were not allowed in SQL identifiers and caused the token to be flagged as an error.

Parent topic: XDB Directive Options


APOST

Syntax:

[NO]APOST

Parameters:

None

Properties:

Default: NOAPOST

Comments:

Only set APOST if you are using apostrophes to delimit literals in SQL statements and you have set the project BUILD settings for quote character to be QUOTES.

Parent topic: XDB Directive Options


AUTHID

Syntax:

[NO]AUTHID
AUTHID[=authorization-ID#1;authorization-ID#2;...;authorization-ID#10]

Parameters:

authorization-ID | A valid authorization ID defined via SQL Wizard
NOAUTHID | No code will be generated

Properties:

Default: NOAUTHID

Comments:

If AUTHID is used without authorization ID, the current AUTHID is set to the default value specified via Options > SQL for DB2 from the IDE menus.

If you are doing static binding, the AUTHID directive also sets the value of the default qualifier. Mutliple authorization IDs are only supported when doing AUTOBIND, IDs must be delimited by a semi-colon with no spaces in the string. A maximum of 10 IDs are supported but the same number of DBRMs must be specified or the number of IDs greater than DBRMs will be ignored.

Parent topic: XDB Directive Options


AUTOBIND

Syntax:

[NO]AUTOBIND

Parameters:

None

Properties:

Default: NOAUTOBIND

Comments:

If you don't use AUTOBIND, you can use the SQL Option Bind Utility to bind the program. See your SQL Option Link User's Guide for specific procedures.

The LOCATION preprocessor directive can be used with the AUTOBIND preprocessor directive to specify the location to which the DBRM is bound. If the LOCATION directive is not used, the Bind Utility uses the location specified via the IDE Options > SQL menu.

Parent topic: XDB Directive Options


AUTOCLOSE

Syntax:

[NO]AUTOCLOSE

Parameters:

None

Properties:

Default: AUTOCLOSE

Comments:

Under NOAUTOCLOSE (which is not DB2-compatible), the SQL Option Server allows multiple execution of insert/update/delete commands without closing the statement. Closing is done at commit. This option is used for performance reasons.

Parent topic: XDB Directive Options


BIND-SQLID

Syntax:

BIND-SQLID=authid

Parameters:

authid Any valid AuthID.

Properties:

Default: None

Comments:

This option only has meaning when program has been statically bound.

Parent topic: XDB Directive Options


BLOCKING

Syntax:

BLOCKING={FSR | SR | LB}

Parameters:

block-code The code for type of block fetching to perform when program is statically bound:
FSR | (Forced Single Row) does not use block fetching regardless of cursor type
SR | (Single Row) uses block fetching for read-only cursors and fetches a row at a time for ambiguous cursors
LB | (Limited Block) uses block fetching for read-only and ambiguous cursors
Default: LB

Properties:

Default: LB

Comments:

This directive only has meaning when program has been statically bound.

Multiple collection-ids are only supported when doing AUTOBIND, Collection-ids must be delimited by a semi-colon with no spaces in the string. A maximum of 10 collection-ids are supported but the same number of DBRMs must be specified or the number of collection-ids greater than DBRMs will be ignored. Also, you must specify at least one collection-id or a compile error SQL0335 will be generated when using multiple binds.

Parent topic: XDB Directive Options


CHANGE-CONTROL

Syntax:

CHANGE-CONTROL=[ERROK][NOERR]

Parameters:

ERROK | Creates a package even if an error occurs during the bind process.
NOERR | Does not create a package if an error occurs during the bind process.

Properties:

Default: NOERR

Comments:

This option only has meaning when program has been statically bound.

Parent topic: XDB Directive Options


COLLECTION-ID

Syntax:

COLLECTION-ID=collection-id#1;collection-id#2;...;collection-id#10

Parameters:

collection-id The name of the collection to bind package to

Properties:

Default: No bind is done.

Comments:

This directive must be set if the STATIC-DRDA directive is used.

Mutliple collection-ids are only supported when doing AUTOBIND. Collection-ids must be delimited by a semi-colon with no spaces in the string. A maximum of 10 collection-ids are supported but the same number of DBRMs must be specified or the number of collection-ids greater than DBRMs will be ignored. Also, you must specify at least one collection-id or a compile error SQL0335 will be generated when using multiple binds.

Parent topic: XDB Directive Options


CONCAT

Syntax:

CONCAT=(ansi-character-code}

Parameters:

ansi-character-code The ANSI character code to be mapped to the standard CONCAT symbol

Properties:

Default: 33

Comments:

DB2 uses the symbol (|) as the concatenation character. If your source contains a different character it can be mapped to the correct symbol.

Parent topic: XDB Directive Options


COPY

Syntax:

[NO]COPY

Parameters:

None

Properties:

Default: NOCOPY

Comments:

This directive must be set if you want to use host variables with a COPY statement. Care should be taken since this may cause compilation errors when porting code to the mainframe unless your installation has software that expands copybooks before passing source to the DB2 precompiler.

Parent topic: XDB Directive Options


CTRACE

Syntax:

[NO]CTRACE

Parameters:

None

Properties:

Default: NOCTRACE

Comments:

The filename of the file that is created is sqltrace.txt. You also may be requested to use Compiler directive CHKECM(TRACE) which will create file ecmtrace.txt.

Parent topic: XDB Directive Options


DATE

Syntax:

DATE={date-format}

Parameters:

date-format
The format in which date information is to be returned. One of:
ISO | yyyy-mm-dd
EUR | dd.mm.yyyy
JIS | yyyy-mm-dd
USA | mm/dd/yyyy
LOCAL | format needs to be defined from the IDE, using Options > SQL for DB2 .

Properties:

Default: Use the default settings defined by the IDE, using Options > SQL for DB2 .

Comments:

Use this directive to override the default settings.

Parent topic: XDB Directive Options


DB2

Syntax:

[NO]DB2

Parameters:

None

Properties:

Default: DB2

Comments:

The DB2 directive combines the DB2CLOSE and DB2ERROR directive. If the WITH HOLD clause is included in your SQL statement, cursors remain open after a COMMIT, even if the DB2 preprocessor directive is specified.

Parent topic: XDB Directive Options


DB2CLOSE

Syntax:

[NO]DB2CLOSE

Parameters:

None

Properties:

Default: DB2CLOSE

Comments:

If the WITH HOLD clause is included in your SQL statement, cursors remain open after a COMMIT, even if the DB2CLOSE preprocessor directive is specified.

Parent topic: XDB Directive Options


DB2ERROR

Syntax:

[NO]DB2ERROR

Parameters:

None

Properties:

Default: DB2ERROR
Parent topic: XDB Directive Options


DB2VER

Syntax:

DB2VER={version}

Parameters:

version The DB2 version syntax checking to use. Values are V5 (to use DB2 V5 rules), V6 (to use DB2 V6 syntax checking) or V7 (to use DB2 V7 syntax checking).

Properties:

Default: V7

Comments:

DB2 V6 or later causes VALIDATE to be turned on by default. This is because some of the syntax checking takes place on the server when in DB2 V6 mode or later.

You need to specify NOVALIDATE if you do not want SQL statements to be validated. Note that doing this could cause many errors to not be reported until the SQL statement is executed. VALIDATE also requires all referenced tables and columns to be defined.

Parent topic: XDB Directive Options


DBRM

Syntax:

NODBRM or DBRM=filename#1;filename#2;...;filename#10

Parameters:

filename Name of file to write DBRM to

Properties:

Default: NODBRM

Comments:

By default, the SQL Option preprocessor produces only expanded source code. You must specify the DBRM preprocessor directive in order to produce a DBRM. When you specify NODBRM, no file is generated.

Multiple DBRM files can be written only if AUTOBIND is also specified. DBRM file names must be delimited by a semi-colon with no spaces in the string. A maximum of 10 DBRM files are supported. If only one DBRM is specified and more than one collection-id, authid or location is specified, a compile error SQL0334 is generated. If more than one DBRM is specified, then multiple collection-ids, authids and locations can be specified but are limited to the number of DBRM file names specified. Any number in excess are ignored. These options do not have to have the same number as the number of DBRM file names specified as the values used will then default to the previous value if a new one is not specified.

Parent topic: XDB Directive Options


DECLARE

Syntax:

[NO]DECLARE

Parameters:

None

Properties:

Default: NODECLARE

Comments:

The default is NODECLARE, which makes the BEGIN/END DECLARE section optional.

Parent topic: XDB Directive Options


DEFAULT-CHAR

Syntax:

DEFAULT-CHAR={BITS | SBCS | DBCS | SYSDEFAULT}

Parameters:

default-code
BITS | specifies that the target relational database uses the FOR BITS DATA SQL
SBCS | specifies that the target relational database uses the FOR SBCS DATA SQL
DBCS | specifies that the target relational database uses the FOR MIXED DATA SQL
SYSDEFAULT | (recommended) specifies that the target relational database uses the system default character subtype.
Default: SYSDEFAULT

Properties:

Default: SYSDEFAULT

Comments:

This directive only has meaning when program has been statically bound.

Parent topic: XDB Directive Options


DIRECTIVES

Syntax:

NODIRECTIVES
or
DIRECTIVES=filename

Parameters:

filename Name of file to get preprocessor directives from

Properties:

Default: NODIRECTIVES

Comments:

When you specify NODIRECTIVES, the system uses only preprocessor directives set in Build settings.

The filename parameter can include a full path, or an environment variable pointing to a path.

Parent topic: XDB Directive Options


EXIST-CHECK

Syntax:

EXIST-CHECK={REQUIRED|OPTIONAL}

Parameters:

REQUIRED | Specifies that a package will be created only if all DBRM objects exist.
OPTIONAL | Specifies that a package will be created even if some DBRM objects do not exist.

Properties:

Default: OPTIONAL

Comments:

This directive is only relevant for a program that has been statically bound.

Parent topic: XDB Directive Options


FILLSYSCAT

Syntax:

[NO]FILLSYSCAT

Parameters:

None

Properties:

Default: NOFILLSYSCAT

Comments:

The default is NOFILLSYSCAT, which causes no catalog information to be created or saved. Use of this directive may slow processing while the preprocessor logs on to the SQL Option Server and writes the information to the system tables. You must have SYSADM privileges on the system tables to use this directive. See the SQL Option SQL Reference for a description of the columns in these system tables.

Parent topic: XDB Directive Options


GENSQLCA

Syntax:

[NO]GENSQLCA

Parameters:

None

Properties:

Default: NOGENSQLCA

Comments:

The structure will be defined if the structure SQLCA is not defined or included. If a separate field SQLCODE is defined in the program, the field SQLCODE in structure will be defined as SQLCADE.

Parent topic: XDB Directive Options


GRANT-EXECUTE

Syntax:

GRANT-EXECUTE={PUBLIC | NONE |(authorization-ID)}

Parameters:

PUBLIC | Grants execute privileges on the package to public.
NONE | No execute privileges granted.
authorization-ID | Grants execute privileges to the given authorization ID, which must be a valid authorization ID defined via SQL Wizard.

Properties:

Default: PUBLIC

Comments:

  • This directive has meaning only when the program has been statically bound.
  • If you do not specify this directive, execute privileges on the package are automatically granted to PUBLIC.
  • To disable this directive, specify GRANT-EXECUTE=NONE.
Parent topic: XDB Directive Options


HYPHEN-IN-CURSOR

Syntax:

[NO]HYPHEN-IN-CURSOR

Parameters:

None

Properties:

Default: | NOHYPHEN-IN-CURSOR
Synonym: | HYPHEN

Comments:

The default is NOHYPHEN-IN-CURSOR (or NOHYPHEN), which does not allow hyphens in cursor names. Specify HYPHEN-IN-CURSOR (or HYPHEN) for backward compatibility with older DB2 mode programs that use hyphenated cursor names.

Parent topic: XDB Directive Options


IGNORE-NESTED

Syntax:

IGNORE-NESTED={program-id}

Parameters:

program-id Any nested program encountered before the given program-id is ignored and no database interface code is generated for it. You must specify a program-id in the COBOL source code; otherwise, a compile error results.

Properties:

Default: If you specify IGNORE-NESTED without a parameter, the program-id defaults to the program name with the filename extension replaced by .CBL

Comments:

You can only generate database interface code in one program in nested programs. If you need to have SQL statements in multiple programs, compile the subroutines as separate programs.

Parent topic: XDB Directive Options


ISOLATION-LEVEL

Syntax:

ISOLATION-LEVEL=[CS][ALL][RR][CHANGE][NC]

Parameters:

CS | The execution of SQL statements in the package and the current row in which the database cursor is positioned are protected from the actions of concurrent users for changes the requester makes.
ALL | The execution of SQL statements in the package is protected from the actions of concurrent users for rows the requester reads and changes.
RR | The execution of SQL statements in the package and the current row in which the database cursor is positioned are protected from the actions of concurrent users for rows the requester reads and changes, as well as phantom rows.
CHANGE | The execution of SQL statements in the package is protected from the actions of concurrent users for changes the requester makes.
NC | Commitment control is not used. COMMIT and ROLLBACK statements are not required for changes to be visible to concurrent users.

Properties:

Default: CS

Comments:

This option only has meaning when program has been statically bound.

Parent topic: XDB Directive Options


LIBINCLUDE

Syntax:

[NO]LIBINCLUDE

Parameters:

None

Properties:

Default: LIBINCLUDE

Comments:

This directive is automatically turned on if you use the PANVALET or LIBRARIAN directive. If you don't want to allow host variables in a –INC or ++INCLUDE copybook, set the NOLIBINCLUDE directive.

Parent topic: XDB Directive Options


LOCATION

Syntax:

LOCATION=location-name#1;location-name#2;...;location-name#10

Parameters:

location-name Location name to bind DBRM to

Properties:

Default: Use the location specified via the IDE Options > SQL menu.

Comments:

By default, the AUTOBIND preprocessor directive uses the location specified via the IDE Options>SQL menu unless this directive is specified.

Multiple locations are only supported when doing AUTOBIND. Locations must be delimited by a semi-colon with no spaces in the string. A maximum of 10 locations are supported but the same number of DBRMs must be specified or the number of locations greater than DBRMs will be ignored.

Parent topic: XDB Directive Options


MAXSQL

Syntax:

MAXSQL={ number }

Parameters:

number The maximum number of EXEC SQL statements to process.

Properties:

Default: 750

Comments:

The preprocessor can handle up to 750 EXEC SQL statements per program by default. If your program gets a compiler error COBSQL0299S, use this preprocessor directive to increase the maximum.

Parent topic: XDB Directive Options


NEVERCLOSE

Syntax:

[NO]NEVERCLOSE

Parameters:

None

Properties:

Default: NONEVERCLOSE

Comments:

Under NEVERCLOSE (which is not DB2-compatible), the SQL Option Server does not close cursors or open statement when a commit or rollback is encountered. This option is used for performance reasons.

Parent topic: XDB Directive Options


NOFOR

Syntax:

[NO]FOR

Parameters:

None

Properties:

Default: FOR

Comments:

If not specified, UPDATE CURRENT OF CURSOR clause will generate a SQL error when statement executed.

You cannot specify FOR explicitly.

Parent topic: XDB Directive Options


NOT

Syntax:

NOT={ansi-character-code }

Parameters:

ansi-character-code The ANSI character value to be mapped to the ¬ symbol.

Properties:

Default: 172

Comments:

For compatibility with DB2 on the mainframe this COBOL system allows the use of the NOT symbol in SQL statements. If your source uses a different ANSI code for the NOT symbol, this directive allows you to specify the ANSI value to be mapped for the NOT symbol.

Parent topic: XDB Directive Options


OPTIMIZE

Syntax:

OPTIMIZE= run-time-environment

Parameters:

run-time-environment Specify OPTIMIZE=MAINFRAME if your program uses COMP as data type for most numeric fields including fields described in SQLCA and SQLDA copybooks.

Specify OPTIMIZE=PC if your program uses COMP-5 as data type for most numeric fields including fields described in SQLCA and SQLDA copybooks.

Properties:

Default: OPTIMIZE=MAINFRAME

Comments:

The precompiler will generate code to swap bytes for all numeric host variables that don't match the optimize setting except for variables defined in an SQLDA. Variables defined in the SQLDA must match the optimize setting or an error message is generated. Obviously, if you intermix defining numeric variables using a mix of COMP/COMP-5 fields, more code is generated by the precompiler to handle this which also affects portability and performance.

Parent topic: XDB Directive Options


PACKAGE-OWNER

Syntax:

PACKAGE-OWNER=authid

Parameters:

authid Any valid AuthID.

Properties:

Default: None

Comments:

This option only has meaning when program has been statically bound.

Parent topic: XDB Directive Options


PKGSET

Syntax:

[NO]PKGSET

Parameters:

None

Properties:

Default: NOPKGSET

Comments:

The default is NOPKGSET, which prevents additional information from being sent to the server, and any set current package set SQL command will fail.

Parent topic: XDB Directive Options


QUOTE

Syntax:

[NO]QUOTE

Parameters:

None

Properties:

Default: NOQUOTE

Comments:

Only set QUOTE if you are using double quotes to delimit literals in SQL statements and you have set the project BUILD settings for quote character to be APOST.

Parent topic: XDB Directive Options


SAVE-RETURN-CODE

Syntax:

[NO]SAVE-RETURN-CODE

Parameters:

None

Properties:

Default: SAVE-RETURN-CODE

Comments:

Use NOSAVE-RETURN-CODE if your COBOL dialect doesn't recognize the COBOL special register RETURN-CODE.

Parent topic: XDB Directive Options


SQLDA-VER

Syntax:

SQLDA-VER={version}

Parameters:

version
Number to identify type of SQLDA structure used.
0 | XDB structure
1 | DB2 mainframe structure

Properties:

Default: 0

Comments:

Set SQLDA-VER=1 when mainframe style SQLDA's are used in the program. Also, all SQLDA structures used in the program must use the same structure. They must all be mainframe style or XDB style or an error message is generated.

Parent topic: XDB Directive Options


SQLDS

Syntax:

[NO]SQLDS

Parameters:

None

Properties:

Default: NOSQLDS
Parent topic: XDB Directive Options


STRICT-DB2

Syntax:

[NO]STRICT-DB2

Parameters:

None

Properties:

Default: NOSTRICT-DB2

Comments:

Mainframe DB2 does not let you declare a cursor before including the SQLCA (something allowed by the DB2 mode of SQL Option. STRICT-DB2 forces SQL Option (when running in DB2 mode) to generate an error in this circumstance. STRICT-DB2 also ensures that an SQLCA is provided by the program.

Parent topic: XDB Directive Options


TIME

Syntax:

TIME={time-format}

Parameters:

time-format The format in which time information is to be returned. One of:
ISO | hh.mm.ss
EUR | hh.mm.ss
JIS | hh.mm.ss
USA | hh.mm.ss AM or PM
LOCAL | format needs to be defined from the IDE, using Options > SQL for DB2.
Default: Use the default settings defined by the IDE, using Options > SQL for DB2.

Properties:

Default: Use the default settings defined by the IDE, using Options > SQL for DB2.

Comments:

Use this directive to override the default settings.

Parent topic: XDB Directive Options


VALIDATE

Syntax:

[NO]VALIDATE

Parameters:

None

Properties:

Default: VALIDATE if in DB2 V6 mode or NOVALIDATE if in DB2 V5 mode.

Comments:

When VALIDATE is specified, the SQL Option preprocessor attempts to log on to the SQL Option Server where it checks whether SQL statements can be executed and whether all referenced tables and columns are present. Note that the SQL Option Server must be available when using VALIDATE or a COBSQ0013W error occurs.

Parent topic: XDB Directive Options


VALIDATE-ERR-LVL

Syntax:

VALIDATE-ERR-LVL = (error-lvl-code)

Parameters:

error-lvl-code A one-byte character code to indicate what error level to generate when an SQL error results from validating an SQL statement. Choose from one of the following codes:
I | Informational
W | Warning
E | Error
S | Severe error
Default: W

Properties:

Default: W
Parent topic: XDB Directive Options


VALIDATE-LOGIN

Syntax:

[NO]VALIDATE-LOGIN

Parameters:

None

Properties:

Default: NOVALIDATE-LOGIN

Comments:

The default is NOVALIDATE-LOGIN, which produces a warning message if communications with the SQL Option Server cannot be established. This directive only affects compilation, not run time.

Parent topic: XDB Directive Options


VERSION

Syntax:

VERSION=version-id

Parameters:

version-id A valid version identifier. This can be up to 64 bits in length.

Properties:

Default: None

Comments:

This option only has meaning when program has been statically bound.

Parent topic: XDB Directive Options


XDBFUNCS

Syntax:

[NO]XDBFUNCS

Parameters:

None

Properties:

Default: NOXDBFUNCS

Comments:

The default is NOXDBFUNCS, which limits the embedded SQL functions to standard DB2 SQL functions, and does not permit SQL Option extensions.

Parent topic: XDB Directive Options


Batch SQL Commands

  • Batch SQL Commands Overview
  • DISPLAY
  • DUMP
  • ERRSTOP
  • IF FAIL
  • IF SUCCEED
  • NODISPLAY
  • NOSTOP
  • SCROLL
  • TERSE
  • VERBOSE
  • WRAP
  • Examples
Parent topic: Reference


Batch SQL Commands Overview

Batch SQL commands are a set of special commands that can be included in a script file to present messages, display results, and detect errors.

Batch commands can be added to your script file using the SQL Edit window or using an ASCII text editor.

Parent topic: Batch SQL Commands


DISPLAY

This batch SQL command causes the system to display the query result on the Result window. Since this is the default mode, the DISPLAY command is typically used to return to normal display operation following the execution of a NODISPLAY command (see NODISPLAY command, below).

The syntax is:

DISPLAY;

The DISPLAY command must be placed immediately after the query statement on which you want it to take effect.

For example:

SELECT pno, pname FROM part WHERE color='BLUE';
DISPLAY;

When the system encounters this DISPLAY command, it displays the Result window containing the part number and name for all blue parts.

Once a DISPLAY command is executed, it will remain in effect for the rest of the script, or until a NODISPLAY command is encountered. Together, the DISPLAY and NODISPLAY commands can be used to selectively display or suppress the Result screens at certain points in the batch file.

For example:

SELECT * FROM customer
WHERE state="CA"
NODISPLAY;            --Suppress Result Screen
IF FAIL EXIT;
UPDATE customer SET balance = balance - $50
WHERE state="CA";
SELECT customer.*, orders.o_no, orders.o_date
FROM customer, orders
WHERE state = "CA";
DISPLAY;            --Display Result Screen

This example suppresses the Result window of the first query and displays it for the second.

The Display command only works when the batch script is run from SQLWizard. To see query results when running a script from a command prompt, use the Dump or Print batch SQL command to output the results to files.

Parent topic: Batch SQL Commands


DUMP

This batch SQL command outputs the query result to a file

The syntax is:

DUMP file_name;

The file name specified by this command is the destination of the output of the query result. If the same file name is used in multiple DUMP commands, each query result set is appended to the one that precedes it in that file.

The DUMP command must be placed immediately after each query statement on which you want it to take effect.

For example:

SELECT * FROM customer
WHERE state="CA"
DUMP ResultSet1.out;  --Write result set to a file named ResultSet1.out

SELECT * FROM customer
WHERE state="MD"
DUMP ResultSet1.out;  --Append result set to ResultSet1.out

SELECT * FROM customer
WHERE state="NY"
DUMP ResultSet2.out;  --Write result set to a file named ResultSet2.out

The DUMP command is only effective when the batch script is run from the development environment's command prompt; it has no effect if the batch script is run from SQLWizard.

Parent topic: Batch SQL Commands


ERRSTOP

This batch SQL command causes the system to pause for a keystroke when it encounters an error. Since this is the default mode, the ERRSTOP command is typically used to return to ERRSTOP operation following the execution of a NOSTOP command (see NOSTOP command, below).

The syntax is:

ERRSTOP;

The ERRSTOP command must be placed immediately after the query on which you want it to start taking effect. Once an ERRSTOP command is executed, it will remain in effect for the rest of the script, or until a NOSTOP command is encountered. Together, the ERRSTOP and NOSTOP commands can be used to selectively enable or disable error processing at certain points in the batch file.

For example:

UPDATE employee
SET com = 0
WHERE dept = "2020";
NOSTOP;          --Do not stop on error
UPDATE customer SET balance=0
WHERE balance > 0;
ERRSTOP;          --Stop on error

In this example, the system ignores errors that occur when updating the EMPLOYEE table, but stops on errors that occur when updating the CUSTOMER table.

Parent topic: Batch SQL Commands


IF FAIL

This batch SQL command displays a message or terminates the batch process in the following circumstances:

  • an error occurs.
  • a query retrieves no records.
  • a DELETE, UPDATE or INSERT command affects no records.

The syntax is:

IF FAIL {"message" | EXIT };

where message is the message to be displayed upon failure. After displaying the message, the system waits for the user to press Enter or click OK before continuing with the batch file.

If EXIT is used, the system terminates the batch process when a failure occurs.

The IF FAIL command must be placed after the query statement to which it will apply. If other batch commands are associated with this statement (e.g., DISPLAY, TERSE), IF FAIL must be placed after them.

For example:

UPDATE partsupp
  SET qty=qty*1.25
  WHERE sno IN
(SELECT sno
     FROM supplier
     WHERE city = 'LONDON');
DISPLAY;
IF FAIL "No records updated. Aborting";
IF FAIL exit;

This example updates the partsupp table and displays an error message if the UPDATE command does not update any records. The second IF FAIL terminates the script after the user acknowledges the error message.

Parent topic: Batch SQL Commands


IF SUCCEED

This batch SQL command displays a message or terminates the batch process if the SQL command retrieves or affects at least one record.

The syntax is:

IF SUCCEED {"message" | EXIT};

where message is the message displayed. After displaying the message, the system waits for the user to press Enter or click OK before continuing with the batch file.

If EXIT is used, the system terminates the batch process.

The IF SUCCEED command must be placed after the query statement to which it will apply. If other batch commands are associated with this statement (e.g., DISPLAY, TERSE), IF SUCCEED must be placed after them.

For example:

UPDATE partsupp
  SET qty=qty*1.25
  WHERE sno IN
(SELECT sno
     FROM supplier
     WHERE city = 'LONDON');
NODISPLAY;
IF SUCCEED "Update successful.";

This example updates the partsupp table and displays a message if the UPDATE command updates any record. Processing continues when the user acknowledges the message.

Parent topic: Batch SQL Commands


NODISPLAY

This batch SQL command suppresses the query Result window. When NODISPLAY is in effect, query results are not displayed on the Result window.

The syntax is:

NODISPLAY;

The NODISPLAY command must be placed immediately after the query statement on which you want it to take effect.

For example:

SELECT pno, pname FROM part WHERE color='BLUE';
NODISPLAY;

In this example, the results of the SELECT statement will not be displayed.

Once a NODISPLAY command is executed, it will remain in effect for the rest of the script, or until a DISPLAY command is encountered. Together, the DISPLAY and NODISPLAY commands can be used to selectively display or suppress the Result windows at certain points in the batch file.

For example:

SELECT * FROM customer
WHERE state="CA";
NODISPLAY;            --Suppress Result Screen
IF FAIL EXIT;
UPDATE customer SET balance = balance - $50
WHERE state="CA";
SELECT customer.*, orders.o_no, orders.o_date
FROM customer, orders
WHERE state = "CA";
DISPLAY;            --Display Result Screen

This example suppresses the Result screen of the first query and displays it for the second.

Parent topic: Batch SQL Commands


NOSTOP

This batch SQL command instructs the system to process errors without pausing for user acknowledgment.

The syntax is:

NOSTOP;

The NOSTOP command must be placed immediately after the query on which you want it to start taking effect. Once a NOSTOP command is executed, it will remain in effect for the rest of the script, or until a ERRSTOP command is encountered. Together, the ERRSTOP and NOSTOP commands can be used to selectively enable or disable error processing at certain points in the batch file.

For example:

UPDATE employee
SET com = 0
WHERE dept = "2020";
NOSTOP;          --Do not stop on error
UPDATE customer SET balance=0
WHERE balance > 0;
ERRSTOP;          --Stop on error

This example directs the system to ignore errors that occur when updating the EMPLOYEE table, but to stop on errors that occur when updating the CUSTOMER table.

Parent topic: Batch SQL Commands


SCROLL

The SCROLL batch SQL command is provided for compatibility with scripts created by earlier versions of XDB Server. This command, when executed, will produce the same results as the DISPLAY command. If you are writing a new script, use DISPLAY rather than SCROLL.

Parent topic: Batch SQL Commands


TERSE

The TERSE batch SQL command sets "quiet" mode. In quiet mode, SQLWizard suppresses the display of command and status messages. It also automatically responds to all prompts with a "Y." In quiet mode, only system-generated error messages are displayed. TERSE operation can be turned off by issuing the VERBOSE command.

The TERSE command must be placed immediately after the query on which you want it to start taking effect. Once a TERSE command is executed, it will remain in effect for the rest of the script, or until a VERBOSE command is encountered. Together, the TERSE and VERBOSE commands can be used to selectively enable or disable quiet mode operation at certain points in the batch file.

Parent topic: Batch SQL Commands


VERBOSE

The VERBOSE batch SQL command is used to set "normal" display mode. Under normal mode, all messages, commands and prompts are displayed on the screen. Since VERBOSE is the default mode, this command is typically used to return to normal operation following the execution of a TERSE command (see TERSE command, above).

The VERBOSE command must be placed immediately after the query on which you want it to start taking effect. Once a VERBOSE command is executed, it will remain in effect for the rest of the script, or until a TERSE command is encountered. Together, the TERSE and VERBOSE commands can be used to selectively enable or disable quiet mode operation at certain points in the batch file.

Parent topic: Batch SQL Commands


WRAP

The WRAP batch SQL command is provided for compatibility with scripts created by earlier versions of XDB Server. This command, when executed, produces the same results as the DISPLAY command. If you are writing a new script, use DISPLAY rather than WRAP.

Parent topic: Batch SQL Commands


Examples

The example below shows a batch SQL file prompting for a host variable called hDeptName.

SELECT * from dept WHERE dname = :hDeptName;
CREATE TABLE temp
  SELECT dname, e_no, lname, fname
  FROM dept, employee
  WHERE dept.Dept = employee.Dept
  AND dept.Dname = :hDeptName;
SELECT dname, e_no, lname, fname, o_no
  FROM temp, orders
  WHERE temp.e_no = orders.s_no;
UPDATE employee
  SET payrate = payrate * 1.1
  WHERE e_no IN
  (SELECT e_no
  FROM temp);
DROP TABLE temp;

When this script is executed, the user will be prompted to enter a department name, and this value will be is substituted into the query.

The example below shows the same batch SQL file, but this one includes additional batch commands that provide display and error-processing instructions. Notice that there is a semicolon ';' at the end of each command, including the batch commands.

SELECT * from dept WHERE dname = :hDeptName;
NODISPLAY;            --Suppress Result Screen
CREATE TABLE temp
  SELECT dname, e_no, lname, fname
  FROM dept, employee
  WHERE dept.Dept = employee.Dept
  AND dept.Dname = :hDeptName;
SELECT dname, e_no, lname, fname, o_no
  FROM temp, orders
  WHERE temp.e_no = orders.s_no;
DISPLAY;            --Display Result Screen
IF FAIL "No Records Found";  --If no records selected,
IF FAIL EXIT;          --show Message and Exit
UPDATE employee
  SET payrate = payrate * 1.1
  WHERE e_no IN
  (SELECT e_no
  FROM temp);
DROP TABLE temp;
Parent topic: Batch SQL Commands


Batch Import Commands

  • APPEND_ERR_FILE
  • APPEND_REC_FILE
  • ASCII_CODEPAGE (DSNTIAUL format)
  • BAD_REC_FILE
  • EBCDIC_CODEPAGE (DSNTIAUL format)
  • EBCDIC_TO_ASCII
  • ERR_LOG_FILE
  • FIELDS
  • FILENAME
  • FLD_DELIMITER (Free-format ASCII)
  • FORMAT
  • HEADING
  • INSERT_MODE
  • INS_NULL
  • NULL_PERM
  • ON_ERROR
  • OFFSETS
  • QUOTES
  • REC_DELIMITER
  • REPLACE
  • SPACES
  • SRC_LENS
  • TABLE
  • TYPES
  • USE_PIC
  • Batch Import Examples
Parent topic: Reference


APPEND_ERR_FILE

Appends errors to an existing error log file. The syntax is:

APPEND_ERR_FILE = { Y | N };

If APPEND_ERR_FILE is set to Y, then errors are appended to the existing error message log file. If APPEND_ERR_FILE is set to N (default), then the old error message log file is overwritten.

The log file appended to is the one specified in the ERR_LOG_FILE command. APPEND_ERR_FILE is an optional Batch Import command.

For example:

APPEND_ERR_FILE = Y;

causes any error messages produced as a result of the Batch Import to be appended to the existing error log file.

Parent topic: Batch Import Commands


APPEND_REC_FILE

Appends errors to an existing record log file. The syntax is:

APPEND_REC_FILE = { Y | N };

If APPEND_REC_FILE is set to N (default), then the old record log file is overwritten. If APPEND_REC_FILE is set to Y, then records are appended to the existing log file.

The log file appended to is the one specified in the most recent BAD_REC_FILE command. APPEND_REC_FILE is an optional Batch Import command.

For example:

APPEND_REC_FILE = Y;

causes any error messages produced as a result of the Batch Import to be appended to the existing record log file.

Parent topic: Batch Import Commands


ASCII_CODEPAGE (DSNTIAUL format)

Specifies the destination character set. The syntax is:

ASCII_CODEPAGE = n

where n is the code page number.

By default, Import assumes character data is stored in a DSNTIAUL source file (using the EBCDIC character set) and converts it to the American ASCII character set by inserting it into an XDB Server table.

You can have the Import utility translate character data containing characters from any international EBCDIC character set to any international ASCII character set using the code page feature in Import. For the ASCII code page number, use the default ASCII character set for your country. EBCDIC to ASCII translation is performed using the translation table that corresponds to the specific ASCII and EBCDIC code pages. This translation table is in the TRANSTAB field of the SYSIBM.SYSSTRINGS table in the SYSTEM location.

When the Import utility uses code page options, the values entered for EBCDIC_CODEPAGE and ASCII_CODEPAGE are compared with values for INCCSID and OUTCCSID, respectively, in the system table SYSIBM.SYSSTRINGS. The matching record in the table contains the translation table used to convert DSNTIAUL data in EBCDIC format to XDB Server data in ASCII.

Parent topic: Batch Import Commands


BAD_REC_FILE

Causes records containing errors to be written to the file (called the record log file) with the file name specified after this command. This command only used for fixed-format ASCII, free-format ASCII, and DSNTIAUL file formats. The syntax is:

BAD_REC_FILE = filename;

where filename is the name of the file, including extension and path, for the record log file. If you don't specify a path, the record log file is put in your current directory.

If a record contains multiple errors, a copy of that record is written to the record log file for each error.

Note:

If this batch command is used for a batch import of a file type other than DSNTIAUL, Free- or Fixed-format ASCII file, then a warning is generated as a reminder that a record log file is not generated for the import of other file types.

For example:

BAD_REC_FILE = C:\LOGFILES\BATCH.BRF;

saves records with errors to the file batch.brf.

Parent topic: Batch Import Commands


EBCDIC_CODEPAGE (DSNTIAUL format)

Specifies the source character set. The syntax is:

EBCDIC_CODEPAGE = n

where n is the code page number.

By default, Import assumes character data is stored in a DSNTIAUL source file using the American EBCDIC character set and converts it to the American ASCII character set before inserting it into an XDB Server table. See "ASCII Table" for a listing of ASCII character sets.

You can have the Import utility translate character data containing characters from any international EBCDIC character set to any international ASCII character set using the code page feature in Import. For the EBCDIC code page number, use the default EBCDIC character set for your country. EBCDIC to ASCII translation is performed using the translation table that corresponds to the specific ASCII and EBCDIC code pages. This translation table is in the TRANSTAB field of the SYSIBM.SYSSTRINGS table in the SYSTEM.

When the Import utility uses code page options, the values entered for EBCDIC_CODEPAGE and ASCII_CODEPAGE are compared with values for INCCSID and OUTCCSID, respectively, in the system table SYSIBM.SYSSTRINGS. The matching record in the table contains the translation table used to convert DSNTIAUL data in EBCDIC format to XDB Server data in ASCII format.

Parent topic: Batch Import Commands


EBCDIC_TO_ASCII

Specifies whether EBCDIC data should be converted to ASCII during DSNTIAUL imports. The syntax is:

EBCDIC_TO_ASCII = {Y | N | NA} [,{Y | N | NA}]...;

where the number of Ys, Ns and NAs is equal to the number of fields in the table. If EBCDIC_TO_ASCII is set to N, data are not converted to ASCII. If EBCDIC_TO_ASCII is set to Y (default), the data are assumed to be EBCDIC and are converted to the ASCII equivalent. If EBCDIC_TO_ASCII is set to NA, conversion is not applicable for the field type.

EBCDIC_TO_ASCII is an optional Batch Import command.

Note: When saving specifications for DB2 DSNTIAUL format, an EBCDIC_TO_ASCII statement is included with all fields set to Y (yes).

For example:

EBCDIC_TO_ASCII = n,n,n,n;

defines this import command so that none of the fields of a four-column table are converted to ASCII in this transaction.

Parent topic: Batch Import Commands


ERR_LOG_FILE

Causes error messages from the Import batch transaction to be written to the file name specified after this command (called the error log file). The syntax is:

ERR_LOG_FILE = filename;

where filename is the name of the file, including extension and path, for the error log file.

If you don't specify a path, the error log file is put in your current directory. Error messages are still displayed on the screen. ERR_LOG_FILE is an optional batch Import command.

For example:

ERR_LOG_FILE = C:\LOGFILES\BATCH.ELF;

saves error messages to the batch.elf file.

Parent topic: Batch Import Commands


FIELDS

Specifies the names of the fields for the XDB Server table being created. The syntax of the statement is:

FIELDS = field-name1 [, field-name2]. . .;

where the field names are listed in order, and separated by commas (,).

The FIELDS Batch Import command is required for every transaction when importing a file that does not include the table headings (as specified with the HEADING Batch Import command). If field names are provided in the file being imported, those names can be used as default field names. Otherwise the field names must be specified.

For example:

FIELDS = e_no,lname,fname,street,city,st,zip,dept,payrate,com;

will import a file into a new table with field names similar to the EMPLOYEE table in the TUTORIAL location.

Parent topic: Batch Import Commands


FILENAME

Specifies the path name of the source file. The syntax of the statement is:

FILENAME = filename

where filename is the full path specification and file of the source file.

For example:

FILENAME = C:\XDB\APPS\employee.asc;

specifies the location of the source file as c:\xdb\apps and the file name employee.asc.

Parent topic: Batch Import Commands


FLD_DELIMITER (Free-format ASCII)

Specifies the delimiter(s) that separate the fields in delimited, free-format ASCII files. You may specify the delimiter(s) as:

  • A Character String. Quotes are optional when specifying a character string for the delimiter If desired, you may enclose the string in double quotes (" "). Quotes in a delimiter specification are ignored by the Import program. For example, "@@" is the same as @@.
  • ASCII Decimal Notation. If you specify the delimiter in ASCII decimal notation, enclose each ASCII code in angle brackets. For example, to use the decimal notation for a semicolon (;), enter the string <059> either with or without quotes.
  • Combination Character String and ASCII Code. You can mix ASCII codes with keyboard characters to form a delimiter. For example: <59>ab<32>c would be a valid delimiter. See "ASCII Table" for a list of ASCII decimal codes.

The syntax of the FLD_DELIMITER command is:

FLD_DELIMITER = {xx|<ascii1>} [xx|<ascii2>] [...];

where :

xx | is one or more keyboard characters
ascii | is an ASCII decimal code. The angle brackets around the ASCII code are required. Quote marks around delimiters are optional.

For example, to instruct the SQLWizard Import utility that your file uses a comma as the delimiter, use the command:

FLD_DELIMITER = ,;
Note:

You must determine the field delimiter prior to executing the Import function. If you specify a field delimiter that is not found in the file, the Batch Import program will abort and an error message will be displayed.

Use the Source File command from the View menu (or a text editor) to examine the file. If the field delimiter is an invisible ASCII character, you may have to use a hexadecimal editor to examine the contents of the file.

Parent topic: Batch Import Commands


FORMAT

Specifies the file type of the file being imported. The syntax is:

FORMAT = source-file-type;

where source-file-type is one of the following options:

Source File Type | Used For
DSNTIAUL | IBM DSNTIAUL files
FIXASC | Fixed-format ASCII files
FREASC | Free-format ASCII files

FORMAT is a required Batch Import command for every transaction.

For example:

FORMAT = dsntiaul;

specifies the importing of a DSNTIAUL file.

Parent topic: Batch Import Commands


HEADING

Specifies that the first row of the source file is a heading that contains field names for the XDB Server table being created. The syntax is:

HEADING = {Y | N}

Set HEADING equal to N if there is no heading in the source file. Set HEADING equal to Y if the first row is to be considered a heading in the source file. All other rows are treated as data.

For example:

HEADING = N;

specifies that there is no heading in the source file.

Parent topic: Batch Import Commands


INSERT_MODE

Specifies use of the NORMAL, ENGINE DIRECT WRITE. The syntax is:

INSERT_MODE = { NORMAL | EDR};

where NORMAL (default) indicates regular import mode and EDR indicates ENGINE DIRECT WRITE import.

The ENGINE DIRECT WRITE import option bypasses all referential integrity and data checking features normally imposed by the XDB Server.

INSERT_MODE is an optional Batch Import command.

For example:

INSERT_MODE = EDR;

causes data to be imported using Engine Direct Write insert mode.

Parent topic: Batch Import Commands


INS_NULL

Specifies whether null character data is to be inserted as null values, or blanks. The correct syntax is:

INS_NULL = { Y | N | NULLABLE };

If INS_NULL is set to NULLABLE, the null character data is imported as a NULL if the field is defined to allow null values, and as a space if the field is defined as NOT NULL.

If INS_NULL is set to N, then empty character fields are imported as a space.

If INS_NULL is set to Y (default), then a null character value is imported as a NULL. If the field is defined as NOT NULL, an error is returned if a null value is encountered.

INS_NULL is an optional Batch Import command.

For example:

INS_NULL = N;

will import null characters as spaces.

Parent topic: Batch Import Commands


NULL_PERM

Specifies null permissions for a field: NULLS ALLOWED, NOT NULL, or NOT NULL WITH DEFAULT. If a table exists then this command is ignored. The syntax is:

NULL_PERM = {Y | N | D} [, {Y | N | D}] ...;

where the specification is listed in the same order as the corresponding field names, and delimited by commas.

If NULL_PERM is Y then null values are permitted in the column. If NULL_PERM is N, then the column is prevented from containing null values. If NULL_PERM is D, then null values are converted to a specified default value for the column (NOT NULL WITH DEFAULT). The default value is dependent on the data type.

For example:

NULL_PERM = n,n,n,y,y,d,d;
Parent topic: Batch Import Commands


ON_ERROR

Specifies the automatic response to an error condition resulting from reading a field in a data file. The syntax is:

ON_ERROR = { SKIP | INS_NULL | QUIT | END_ALL};

If ON_ERROR is set to SKIP, a record that contains invalid data is skipped and import goes on to the next record. If ON_ERROR is set to INS_NULL then a null is placed in the field if the field is nullable. If ON_ERROR is set to QUIT, then the Batch Import will be terminated if invalid data is found. If ON_ERROR is set to END_ALL (default), then all Batch Import processing is terminated.

ON_ERROR is an optional Batch Import command.

For example:

ON_ERROR = NULL;

will cause Batch Import to place a null in a field that has caused an error, and to continue with the import despite the error.

Parent topic: Batch Import Commands


OFFSETS

Specifies the starting positions of fields being imported from fixed-format ASCII files. The syntax is:

OFFSETS = start-pos1 [, start-pos2]. . .;

where the starting positions are listed in the same order as the corresponding field names, and delimited by commas.

To determine the starting positions, it might be necessary to examine the file. (Use the Source File command from the View menu, or use a text editor.) The OFFSETS Batch Import command is required for every transaction when importing a fixed-format ASCII file into XDB Server.

For example:

OFFSETS = 1,11,23,35,57,74,78,85,91,113;

specifies the starting positions of the columns in a fixed-format ASCII source file.

Parent topic: Batch Import Commands


QUOTES

Used when importing free-format ASCII files to specify whether or not character strings are surrounded by double quotes. The syntax is:

QUOTES = {Y | N};

Set QUOTES to N (default) if there are no quotes around character strings in the source file. Set QUOTES to Y if the character strings in the source file are surrounded by quotes. It is common to surround character strings with double quotes in comma-delimited ASCII files. QUOTES is an optional Batch Import command.

For example:

QUOTES = Y;

will import a free-format ASCII file that has character strings enclosed in quotes.

Parent topic: Batch Import Commands


REC_DELIMITER

Specifies the end-of-record delimiter used to separate records in modified free-format ASCII files. The syntax is:

REC_DELIMITER = {"xx" | "<ascii>"...};

where:

xx | is a character string delimiter
ascii | is an ASCII decimal code. The angled brackets around the ASCII code are required. The default delimiter is a space character (ASCII code <032>).

The end-of-record delimiter can be specified as a character string or in ASCII decimal notation. If the delimiter is specified in ASCII decimal notation, enclose each ASCII code in angled brackets. For example, to use the decimal notation for a semicolon, enter the string <059>.

The delimiter cannot be a character found within the data values unless the values are enclosed in quotes. The most common record delimiter found in ASCII files is a carriage return followed by a line feed.

The REC_DELIMITER Batch Import command is required for every transaction when importing free-format ASCII files into XDB Server.

For example:

REC_DELIMITER = "<013><010>";

sets the record delimiter to a carriage return/line feed combination.

Parent topic: Batch Import Commands


REPLACE

Specifies whether the data being imported is to be appended to existing data in the table or is to replace it. The syntax is:

REPLACE = {Y | N};

If REPLACE is set to N (default), the imported data will appended to the existing data. If REPLACE is set to Y, the imported data will replace the data in the table.

This command is ignored if the named table does not exist; a new table is then created. The default is to append the data to the end of existing data in the table if found. REPLACE is an optional Batch Import command.

For example:

REPLACE  = N;

will append data to an existing table.

Parent topic: Batch Import Commands


SPACES

Specifies the number of spaces that separate columns in a fixed-format ASCII data file. The syntax is:

SPACES = {n}

where n is some number between 0-99. The default is 2.

Parent topic: Batch Import Commands


SRC_LENS

S pecifies the maximum number of spaces a field can use in a fixed-format ASCII source file being read. The syntax is:

SRC_LENS = length1 [, length2] ...;

where the lengths are listed in the same order as the corresponding field names, and delimited by commas.

When importing fixed-format ASCII files, the SRC_LENS command is used to determine the source file length. To determine the field length for ASCII files, it might be necessary to examine the files. (Use the Source File command from the View menu or a text editor.)

The SRC_LENS Batch Import command is required for every transaction when importing a fixed-format ASCII file into XDB Server.

For example:

SRC_LENS = 8,10,20,15,2,5,4,20,30;

specifies the column widths of the fixed-format ASCII source file being read.

Parent topic: Batch Import Commands


TABLE

S pecifies the name of the XDB Server table to be created by Import. The syntax is:

TABLE = table-name;

where table-name is the name of the table.

If you have super-user privilege, you can qualify the table name with a different AuthID (of up to eight characters), so the table is created with a different owner. The table will be created in the current location. To create it in a different location, enter a three-part name using the format location.authid.tablename.

TABLE is a required Batch Import command for every transaction.

For example:

TABLE = salaries;

sets the name of the imported table to SALARIES.

Parent topic: Batch Import Commands


TYPES

S pecifies the field types for the XDB Server table being created. The syntax is:

TYPES = field-type1 [, field-type2]. . .;

where field types are listed in the same order as corresponding field names, and delimited by commas. Valid field types are shown below. The two-letter designation defines the field type.

Symbol | Field Type | Symbol | Field Type
CH[(n)] | Char (Character) | LB | Long Varchar For Bit Data
CB[(n)] | Character For Bit Data | LG | Long Vargraphic
DT[(p[s])] | Date | MN | Money
DC | Decimal | SI | Smallint (Small Integer)
SF | Float (4-byte) | TM | Time
FL | Float | TS | Timestamp
GR | Graphic | VC[(n)] | Varchar (Variable Character)
LI | Integer | VB[(n)] | Varchar For Bit Data
LV | Long Varchar | VG[(n)] | Vargraphic
Note:

When importing ASCII files, you can specify a data type of JU (for Julian) to import Julian dates into XDB Server date fields. The system will read dates in the format yyddd (where ddd is the number of days since the beginning of the year) and write them in the regular XDB Server date format.

When specifying fields as DECIMAL, CHARACTER, VARCHAR, CHAR-FOR-BIT-DATA, VARCHAR-FOR-BIT-DATA, GRAPHIC and VARGRAPHIC, include the field length or precision and scale in parentheses immediately after the letter specifying the data type.

TYPES is a required Batch Import command for every transaction.

For example:

TYPES = ch(10),dc(10,2),dt,si;

sets the field types in the imported table to:

  • Character (10 characters field length)
  • Decimal (precision 10, scale 2)
  • Date
  • Small Integer
Parent topic: Batch Import Commands


USE_PIC

S pecifies whether the format picture (specified in Options) for a DATE, TIME, DECIMAL, or MONEY field is to be used when reading source data. The syntax is:

USE_PIC = {Y | N| NA} [, {Y | N | NA}] ...;

where the specification (Y, N, or NA) is listed in the same order as the corresponding field names, and delimited by commas.

If a field specification is set to Y (default), then Import will apply the Option utility's picture format to the data in that field (be sure the data in the source file matches the PIC format you've specified). If a field specification is set to N, then Import will apply the default mask for that data type, as described in the table below.

Type | Default Picture
Time | hh:mm:ss
Date | mm/dd/yyyy
Decimal | <sign><digits>[.<digits>][E[+-]<digits>]
Money | <sign><digits>[.<digits>][E[+-]<digits>]
 | where: <sign> includes any combination of + - $ >=
 | <digits> are 0 through 9; also comma (,) if to the left of the decimal place.

For fields that are not of type DATE, TIME, DECIMAL, or MONEY, the field specification should be set to NA (not applicable).

Note:

If you know that the format of the file is the same as the SQLWizard Import defaults, you do not need to use the USE_PIC statement.

USE_PIC is an optional Batch Import command.

For example:

USE_PIC = n,n,n,n,n,n,n,n,y,y;

specifies that the ninth and tenth fields are to have profile masks applied to them.

Parent topic: Batch Import Commands


Batch Import Examples

The following Batch Import command file contains examples of Batch Import transactions for the more common file formats. The [FREE ASCII] import transaction shows an example of error logging. In this example, all of the transactions are grouped into a single Batch Import file.

[DSNTIAUL]
TABLE = TUTORIAL.TUTORIAL.EMPLOYEE;
FILENAME = C:\XDBWIN\TUTORIAL\EMPLOYEE.DSN;
FORMAT = DSNTIAUL;
FIELDS = e_no,lname,fname,street,city,st,zip,dept,payrate,com;
TYPES = si,ch(10),ch(10),ch(20),ch(15),ch(2),ch(5),
  ch(4),dc(15,2),dc(2,2);
NULL_PERM = n,n,n,y,y,y,y,y,y,y;
USE_PIC = na,na,na,na,na,na,na,na,y,y;
INS_NULL = n,n,n,y,y,y,y,y,y,y;
EBCDIC_TO_ACSII = y,y,y,y,y,y,y,y,y,y;
REPLACE = y;
INSERT_MODE = normal;
[FREE ASCII]
TABLE = TUTORIAL.TUTORIAL.EMPLOYEE;
FILENAME = C:\XDBWIN\TUTORIAL\EMPLOYEE.FRE;
FORMAT = FREASC;
FIELDS = e_no,lname,fname,street,city,st,zip,dept,payrate,com;
TYPES = si,ch(10),ch(10),ch(20),ch(15),ch(2),ch(5),ch(4),
  dc(15,2),dc(2,2);
NULL_PERM = n,n,n,y,y,y,y,y,y,y;
USE_PIC = na,na,na,na,na,na,na,na,y,y;
INS_NULL = n,n,n,y,y,y,y,y,y,y;
HEADING = y;
QUOTES = y;
FLD_DELIMITER = "@";
REC_DELIMITER = "<013><010>";
REPLACE = y;
INSERT_MODE = normal;
ERR_LOG_FILE = c:\xdbwin\tutorial\errors.log;
APPEND_ERR_FILE = y;
BAD_REC_FILE = c:\xdbwin\tutorial\freerecs.log;
APPEND_REC_FILE = n;
[Fixed ASCII]
TABLE = TUTORIAL.TUTORIAL.EMPLOYEE;
FILENAME = C:\XDBWIN\TUTORIAL\EMPLOYEE.FIX;
FORMAT = FIXASC;
FIELDS = e_no,lname,fname,street,city,st,zip,dept,payrate,com;
TYPES = si,ch(10),ch(10),ch(20),ch(15),ch(2),ch(5),ch(4),
  dc(15,2),dc(2,2);
NULL_PERM = n,n,n,y,y,y,y,y,y,y;
USE_PIC = na,na,na,na,na,na,na,na,y,y;
INS_NULL = n,n,n,y,y,y,y,y,y,y;
HEADING = y;
SPACES = 2;
OFFSETS = 1,11,23,35,57,74,78,85,91,114;
SRC_LENS = 8,10,10,20,15,2,5,4,21,4;
REPLACE = y;
INSERT_MODE = normal;
Parent topic: Batch Import Commands


Batch Export Commands

  • APPEND_ERR_FILE
  • ASCII_CODEPAGE (DSNTIAUL format)
  • EBCDIC_CODEPAGE (DSNTIAUL format)
  • ERR_LOG_FILE
  • FIELDS
  • FILENAME
  • FLD_DELIMITER
  • FORMAT
  • HEADING
  • ON_ERROR
  • QUERY
  • QUOTES
  • REC_DELIMITER
  • REPLACE
  • SPACES
  • SQL_OPTS
  • TABLE
  • WHERE
  • Batch Export Examples
Parent topic: Reference


APPEND_ERR_FILE

Appends errors to an existing error log file. The syntax is:

APPEND_ERR_FILE = { Y | N };

If APPEND_ERR_FILE is set to Y, then errors are appended to the existing error log file. If APPEND_ERR_FILE is set to N (default), then the old error log file is overwritten.

The log file appended to is the one specified in the recent ERR_LOG_FILE command. APPEND_ERR_FILE is an optional Batch Export command.

For example:

APPEND_ERR_FILE = Y;

causes any error messages produced as a result of the Batch Export to be appended to the existing error log file.

Parent topic: Batch Export Commands


ASCII_CODEPAGE (DSNTIAUL format)

Specifies the ASCII character set. The syntax is:

ASCII_CODEPAGE = n

where n is the code page number.

By default, Export assumes character data is stored in a DSNTIAUL source file using the American ASCII character set and converts it into the American EBCDIC character set by inserting it into a DSNTIAUL target file.

You can have the Export utility translate character data containing characters from any international ASCII character set to any international EBCDIC character set using the code page feature in Export. For the ASCII code page number, use the default ASCII character set for your country. ASCII to EBCDIC translation is performed using the translation table that corresponds to the specific ASCII and EBCDIC code pages. This translation table is in the TRANSTAB field of the SYSIBM.SYSSTRINGS table in the SYSTEM location.

When the Export utility uses code page options, the values entered for ASCII_CODEPAGE and EBCDIC_CODEPAGE are compared with values for INCCSID and OUTCCSID, respectively, in the system table SYSIBM.SYSSTRINGS. The matching record in the table contains the translation table used to convert XDB Server data in ASCII format to DSNTIAUL data in EBCDIC format.

Parent topic: Batch Export Commands


EBCDIC_CODEPAGE (DSNTIAUL format)

Specifies the EBCDIC character set. The syntax is:

EBCDIC_CODEPAGE = n

where n is the code page number.

By default, Export assumes character data is stored in a DSNTIAUL source tables using the American ASCII character set and converts it to the American EBCDIC character set inserting it into an XDB Server table.

You can have the Export utility translate character data containing characters from any international ASCII character set to any international EBCDIC character set using the code page feature in Export. For the EBCDIC code page number, use the default EBCDIC character set for your country. ASCII to EBCDIC translation is performed using the translation table that corresponds to the specific ASCII and EBCDIC code pages. This translation table is in the TRANSTAB field of the SYSIBM.SYSSTRINGS table in the SYSTEM. See the section titled "Code Page Support" for the structure of the SYSIBM.SYSSTRINGS table.

When the Export utility uses code page options, the values entered for ASCII_CODEPAGE and EBCDIC_CODEPAGE are compared with values for INCCSID and OUTCCSID, respectively, in the system table SYSIBM.SYSSTRINGS. The matching record in the table contains the translation table used to convert XDB Server data in ASCII format to DSNTIAUL data in EBCDIC format.

Parent topic: Batch Export Commands


ERR_LOG_FILE

Causes error messages from the Export batch transaction to be written to the filename specified after this command (called the error log file). The syntax is:

ERR_LOG_FILE = filename;

where filename is the name of the file, including extension and path, for the error log file.

If you don't specify a path, the error log file is put in your current directory. Error messages are still displayed on the screen. ERR_LOG_FILE is an optional Batch Export command.

For example:

ERR_LOG_FILE = C:\LOGFILES\BATCH.ELF;

saves error messages to the batch.elf file.

Parent topic: Batch Export Commands


FIELDS

Specifies the names of the fields for the XDB Server table being created. The syntax of the statement is:

FIELDS = field-name1 [, field-name2]. . .;

where the field names are listed in order, and separated by commas (,).

The FIELDS command is optional if you are creating your own Batch Export file and you are querying all fields in a table. If specific fields are being queried, those fields must be specified using the FIELDS command.

For example:

FIELDS = e_no,lname,fname,street,city,st,zip,dept,payrate,com;

will export a file into a new table with field names similar to the EMPLOYEE table in the tutorial.

Parent topic: Batch Export Commands


FILENAME

Specifies the destination directory and file name for the target file produced by the export transaction. The syntax is:

FILENAME = filename

where filename is the full path specification and filename for the target file.

For example:

FILENAME= A:\filename;
Parent topic: Batch Export Commands


FLD_DELIMITER

Specifies the delimiter used to separate fields in free-format ASCII files. The default delimiter is a comma. The syntax is:

FLD_DELIMITER = {"xx" | "<ascii>"...};

where:

xx | is a character string delimiter
ascii | is an ASCII decimal code.

Delimiters can be specified as a character string or in ASCII decimal notation. If the delimiter is specified as a character string it must be enclosed in double-quotation marks (" "). If the delimiter is specified in ASCII decimal notation, enclose each ASCII code in angled brackets. For example, to use the decimal notation for a semicolon, enter the string <59>. (The angled brackets around the ASCII code are required.)

Note:

You must determine the field delimiter prior to executing the Export function. If you specify a field delimiter that is not found in the file, the Batch Export program will abort and an error message will be displayed.

Use the Target File command from the View menu (or a text editor) to examine the file. If the field delimiter is an nonvisible ASCII character, you may have to use a hexadecimal editor to examine the contents of the file.

Take care not to choose a character found in your data as a delimiter. For example, do not use a comma as the delimiter if your data contains numeric or money fields grouped with a comma.

For example:

FLD_DELIMITER = ",";

separates the data with a comma.

Parent topic: Batch Export Commands


FORMAT

Specifies the file type you are exporting to. The syntax is:

FORMAT = target-file-type;

where target-file-type is one of the following options:

Target File Type | Used For
FIXASC | Fixed-format ASCII files
FREASC | Free format ASCII files
DSNTIAUL | IBM DSNTIAUL files
SQL | SQL statements

This statement is required for each Batch Export transaction.

For example:

FORMAT = fixasc;

sets the export file type to fixed-format ASCII.

Parent topic: Batch Export Commands


HEADING

Specifies whether the field names are to be included in the first row of free or fixed-format ASCII files. The syntax is:

HEADING = {Y | N};

If HEADING is set to N, then no heading is included in the target file. When HEADING is set to Y (default), the column headings are included as the first record of the file.

For example:

HEADING = N;

will prevent a heading from being included in the target file.

Parent topic: Batch Export Commands


ON_ERROR

Specifies the automatic response to an error condition resulting from reading a field in a data file. The syntax is:

ON_ERROR = {CONTINUE | QUIT | END_ALL};

If ON_ERROR is set to CONTINUE, then Batch Export will try to recover from any error that occurs. If ON_ERROR is set to QUIT (default), then Batch Export will quit if any errors occur. If ON_ERROR is set to END_ALL, then Batch Export terminates.

For example:

ON_ERROR = CONTINUE;

will cause Batch Export to try to recover from any errors.

Parent topic: Batch Export Commands


QUERY

Used to hold an SQL SELECT statement that the export is based on. The syntax is:

QUERY = SELECT dept, dname, mgr FROM dept
WHERE dname = "sales" AND mgr > 5;

In the syntax example above, the dept, dname, and mgr fields are selected from the DEPT table only when the dname field is equal to sales and the mgr field is greater than five. This allows specific information to be exported from the selected table.

Parent topic: Batch Export Commands


QUOTES

Used when exporting free-format ASCII files to specify whether or not character strings are to be surrounded by double quotes. The syntax is:

QUOTES = {Y | N};

If QUOTES is set to N (default), then quotes will not be placed around character strings. If QUOTES is set to Y, then character strings will be surrounded by quotes.

Surrounding character strings with double quotes is a common practice in the creation of comma-delimited ASCII files.

For example:

QUOTES = Y;

will cause the data in the exported file to be enclosed in quotes.

Parent topic: Batch Export Commands


REC_DELIMITER

Specifies the delimiter for free-format ASCII export types. The syntax is:

REC_DELIMITER = {'xx' | "<ascii>"};

where:

xx | is a character string delimiter
ascii | is an ASCII decimal code. The angled brackets around the ASCII code are required. The default delimiter is a space character (ASCII code <032>).

The end-of-record delimiter can be specified as a character string or in ASCII decimal notation. If the delimiter is specified in ASCII decimal notation, enclose each ASCII code in angled brackets. For example, to use the decimal notation for a semicolon, enter the string <059>.

The delimiter cannot be a character found within the data values unless the values are enclosed in quotes. The most common record delimiter found in ASCII files is a carriage-return, followed by a line-feed.

The REC_DELIMITER Batch Export command is required for every transaction when exporting Free ASCII files to XDB Server.

For example:

REC_DELIMITER = "<013><010>";

sets the record delimiter to a carriage-return/line-feed combination.

Parent topic: Batch Export Commands


REPLACE

Specifies that the data being exported is to replace the current contents of the destination file. The syntax is:

REPLACE = {Y | N};

If REPLACE is set to N (default), then if the destination file exists, the data is appended. If REPLACE is set to Y, then the data in the target file will be replaced.

If no file of the same name exists, the data in the table being exported will be placed in a newly created file regardless of the parameter specified with the REPLACE command. If the REPLACE command is not included, and the destination file already exists, the data is appended to the file.

This statement is supported for the following formats:

  • Free ASCII
  • Fixed ASCII
  • SQL

With all other formats, the file is replaced instead of being appended to regardless of how REPLACE is set.

For example:

REPLACE = Y;

will cause the exported file to overwrite any existing file with the same name.

Parent topic: Batch Export Commands


SPACES

Specifies the number of spaces the separate columns in a Fixed ASCII target file. The syntax is:

SPACES = n;

where n is an integer corresponding to the number of spaces (between 0 and 99) to insert between the columns of data. The default is 2.

For example:

SPACE = 1;

will ensure that one space is placed between every field in the exported file.

Parent topic: Batch Export Commands


SQL_OPTS

Used to specify which SQL statements should be generated when the SQL export type is chosen. The syntax is:

SQL_OPTS = statement-type [, statement-type, ...];

where statement-type is one of the types shown in the table below.

Statement type | SQL Statement
CREATE | CREATE TABLE and CREATE VIEW commands
INSERT | INSERT INTO commands
INDEX | CREATE INDEX commands
SYNONYM | CREATE SYNONYM commands
CHECK | ALTER TABLE ... CHECK commands
COMMENT | COMMENT ON commands

For example:

SQL_OPTS = CREATE, INDEX;

selects CREATE TABLE, CREATE VIEW, and CREATE INDEX SQL commands for use in the target file.

Parent topic: Batch Export Commands


TABLE

Specifies the name of the XDB Server table or view to be exported. The syntax is:

TABLE = table-name;

where table-name is the name of the XDB Server table or view.

If you are have super-user privilege, you can qualify the table name with a different AuthID (of up to eight characters), so the table is created with a different owner. The table will be created in the current location. To create it in a different location, enter a three-part name using the format location.authid.tablename.

TABLE is a required command for every transaction.

For example:

TABLE = employee;

causes data from the EMPLOYEE table to be exported.

Parent topic: Batch Export Commands


WHERE

Used with a SELECT statement to specify search criteria for retrieving rows of data from a table or group of tables. The syntax is:

WHERE search-condition;

The WHERE clause can also be used with DELETE and UPDATE. For example:

WHERE city = "Columbia" OR "Annapolis";

will cause all records that have a city of Columbia or Annapolis to be pulled from the table and exported into the desired target file.

Parent topic: Batch Export Commands


Batch Export Examples

The following Batch Export file contains examples of transactions for each file type. All the transactions are contained into a single file.

[FREE ASCII]
TABLE = SYSTEM.TUTORIAL.QMT_STAFF;
WHERE = "YEARS <= 3";
FILENAME = C:\XDBWIN\SYSTEM\QMT_STAFF.FRE;
FORMAT = FREASC;
REPLACE = y;
FIELDS = EMPID,LNAME,FNAME,DEPARTMENT,JOB,YEARS;
HEADING = y;
QUOTES = y;
FLD_DELIMITER = ",";
REC_DELIMITER = "<013><010>";
ON_ERROR = CONTINUE;
ERR_LOG_FILE = c:\xdbwin\tutorial\errors.log;
APPEND_ERR_FILE = y;
[FIXED ASCII]
TABLE = SYSTEM.TUTORIAL.QMT_STAFF;
WHERE = "YEARS <= 3";
FILENAME = C:\XDBWIN\SYSTEM\QMT_STAFF.FIX;
FORMAT = FIXASC;
REPLACE = y;
FIELDS = EMPID,LNAME,FNAME,DEPARTMENT,JOB,YEARS;
HEADING = y;
SPACES = 2;
ON_ERROR = CONTINUE;
ERR_LOG_FILE = c:\xdbwin\tutorial\errors.log;
APPEND_ERR_FILE = y;
[DSNTIAUL]
TABLE = SYSTEM.TUTORIAL.QMT_STAFF;
WHERE = "YEARS <= 3";
FILENAME = C:\XDBWIN\SYSTEM\QMT_STAFF.DSN;
FORMAT = DSNTIAUL;
REPLACE = y;
FIELDS = EMPID,LNAME,FNAME,DEPARTMENT,JOB,YEARS;
[SQL Statement]
TABLE = SYSTEM.TUTORIAL.QMT_STAFF;
WHERE = "YEARS <= 3";
FILENAME = C:\XDBWIN\SYSTEM\QMT_STAFF.SQL;
FORMAT = SQL;
REPLACE = y;
FIELDS = EMPID,LNAME,FNAME,DEPARTMENT,JOB,YEARS;
SQL_OPTS = INSERT,CHECK,COMMENT;
Parent topic: Batch Export Commands


Error Messages

  • COBSQ - SQL ECM Preprocessor Error Messages
  • L - Link Error Messages
  • N - Network Error Messages
  • PIC - Picture Error Messages
  • SQL - SQL PL/I Precompiler Error Messages
  • WADM - SQLWizard Administrator Error Messages
  • WCRT - SQL Wizard Create/Alter Table Error Messages
  • WDG - SQL Wizard Declaration Generator Error Messages
  • WE - SQL Wizard Export Error Messages
  • WI - SQL Wizard Import Error Messages
  • WSQL - SQL Wizard Interactive SQL Error Messages
  • X - Engine Error Messages
  • XMIG - Migrate Error Messages
  • XU - Library Error Messages
Parent topic: Reference


COBSQ - SQL ECM Preprocessor Error Messages

  • COBSQ0000 - COBSQ0099
    Lists the SQL ECM error messages from COBSQ0000 through COBSQ0099.
  • COBSQ0100 - COBSQ0149
    Lists the SQL ECM error messages from COBSQ0100 through COBSQ0149.
  • COBSQ0150 - COBSQ0199
    Lists the SQL ECM error messages from COBSQ0150 through COBSQ0199.
  • COBSQ0200 - COBSQ0399
    Lists the SQL ECM error messages from COBSQ0200 through COBSQ0399.
  • COBSQ0400 - COBSQ0499
    Lists the SQL ECM error messages from COBSQ0400 through COBSQ0499.
  • COBSQ0900 - COBSQ0999
    Lists the SQL ECM error messages from COBSQ0900 through COBSQ0999.
Parent topic: Error Messages


COBSQ0000 - COBSQ0099

  • COBSQ0002: token is badly defined
  • COBSQ0003 Program contains more than one definition of token
  • COBSQ0004 Nested or multi-source programs not allowed.
  • COBSQ0005: An error occurred whilst processing the internal dictionary.
  • COBSQ0006 No DB engine could be found.
  • COBSQ0007 Source file name is invalid.
  • COBSQ0012: Host variable used without a colon.
  • COBSQ0013: Login failed. : program-name.
  • COBSQ0015 Host variables data types in UNION do not match.
  • COBSQ0016 This statement will Delete an entire table
  • COBSQ0017 HostVariable is not preceded by a colon.
  • COBSQ0018 SQL statement not currently supported - converted to comment.
  • COBSQ0019 Operation is assumed to apply to Allocate Cursor.
  • COBSQ0021 SQL Option must be selected and available
  • COBSQ0024 EXEC SQL statement found within COPY statement, COPY directive not set. May cause compile error on mainframe.
Parent topic: COBSQ - SQL ECM Preprocessor Error Messages


COBSQ0100 - COBSQ0149

  • COBSQ0101: Expected token1 found token2.
  • COBSQ0102: Host variable mismatch.
  • COBSQ0104: Illegal symbol variable.
  • COBSQ0106: variable Invalid/Not Declared
  • COBSQ0107: INTO not allowed for DECLARE.
  • COBSQ0110: No INTO clause specified.
  • COBSQ0111: No FROM clause specified.
  • COBSQ0112: Invalid positioning of FROM.
  • COBSQ0114: Invalid file name.
  • COBSQ0115: Token array overflow.
  • COBSQ0117: Invalid in data division.
  • COBSQ0118: Invalid WHENEVER.
  • COBSQ0120: Not valid in current compatibility mode.
  • COBSQ0124: Group variable token is not allowed in the WHERE clause.
  • COBSQ0125: Cursor not found.
  • COBSQ0126: A _ is illegal in a host variable.
  • COBSQ0127: A ( is illegal in the INTO clause.
  • COBSQ0131: SQLCA not found OR comp/comp-5 mixup in SQLCA.
  • COBSQ0135: Host variable type mismatch.
  • COBSQ0137: Indicator variable token is not SMALLINT type.
  • COBSQ0138: The length of a host variable on CONNECT is greater than 16.
  • COBSQ0141: PREPARE before DECLARE is illegal.
  • COBSQ0144: Statement not identified.
  • COBSQ0147: Multiple INTO's only allowed with a UNION.
  • COBSQ0149: Illegal token found on CONNECT line.
Parent topic: COBSQ - SQL ECM Preprocessor Error Messages


COBSQ0150 - COBSQ0199

  • COBSQ0151: Cursor already DECLARED.
  • COBSQ0154: Login failed.
  • COBSQ0163: Invalid Cursor name
  • COBSQ0164: Syntax error in INTO Clause
  • COBSQ0170: Login failed. Unable to VALIDATE SQL
  • COBSQ0184 Illegal token ':' found. Check to see if previous token was an indicator variable.
  • COBSQ0185 Syntax error, last symbol read is token.
  • COBSQ0189 'ORDER BY' clause not permitted.
  • COBSQ0190 GROUP BY clause on a SELECT INTO will not bind.
  • COBSQ0191 HAVING clause on a SELECT INTO will not bind.
  • COBSQ0198: DB2 emulation mismatch - SERVER is in DB2 V6 mode
  • COBSQ0199: DB2 emulation mismatch - SERVER is in DB2 V5 mode
Parent topic: COBSQ - SQL ECM Preprocessor Error Messages


COBSQ0200 - COBSQ0399

  • COBSQ0201 Illegal token variable found on SET line.
  • COBSQ0202 Number of host variables specified in UNION do not match.
  • COBSQ0299 Internal EXEC SQL statement table overflow - use directive MAXSQL to override default.
  • COBSQ0312 Undefined or unusable host variable token
  • COBSQ0324 SQLDA fields defined with incompatible fields for XDB OPTIMIZE directive setting.
  • COBSQ0325 Multiple types of SQLDA's detected - all SQLDA's must use same structure.
  • COBSQ0326 SQL statements not supported in nested subroutine.
  • COBSQ0327 Invalid BLOCKING option specified – valid options are: FSR, SR, or LB.
  • COBSQ0328 Invalid DEFAULT-CHAR option specified – valid options are: BITS, SBCS, DBCS, or SYSDEFAULT.
  • COBSQ0329 Invalid EXIST-CHECK option specified – valid options are: REQUIRED or OPTIONAL.
  • COBSQ0330 Required directive AUTOBIND not specified with directive directive.
  • COBSQ0331 Invalid DATE format specified - valid options are: ISO, EUR, JIS, USA or LOCAL.
  • COBSQ0332 Invalid TIME format specified - valid options are: ISO, EUR, JIS, USA or LOCAL.
  • COBSQ0333 Invalid number of values specified, maximum is 10 per option: token .
  • COBSQ0334 Only one DBRM specified when multiple other directives specified for AUTOBIND.
  • COBSQ0335 No collection-id specified, option required for AUTOBIND.
Parent topic: COBSQ - SQL ECM Preprocessor Error Messages


COBSQ0400 - COBSQ0499

  • COBSQ0401 Statement is too long.
  • COBSQ0402 Statement contains too many host variables.
  • COBSQ0403 variable does not have a suitable definition to be used as a host variable.
  • COBSQ0404 Bad SQL data declaration.
  • COBSQ0405 Syntax error.
  • COBSQ0406 Filename too long.
  • COBSQ0407 File token not found.
  • COBSQ0408 token is non-unique and should be qualified.
  • COBSQ0409: token is not a data item
  • COBSQ0410 Statement contains more than one SQLDA.
  • COBSQ0411 token is not a table of null indicator variables.
  • COBSQ0412 token should not be a defined with an OCCURS clause.
  • COBSQ0413 token should not be a subordinate to an item defined with an OCCURS clause.
  • COBSQ0415 Statement not allowed in the PROCEDURE DIVISION.
  • COBSQ0416 An error occurred whilst processing the trace file.
  • COBSQ0418 Mismatched DECLARE.
  • COBSQ0419 Host variable name is too long.
  • COBSQ0420 Internal error - dictionary handle is too big.
  • COBSQ0422 Nested INCLUDE's not supported.
Parent topic: COBSQ - SQL ECM Preprocessor Error Messages


COBSQ0900 - COBSQ0999

  • COBSQ0900 An internal error occurred. Create a trace file using the compiler directive CHKECM(TRACE) and contact your support representative.
  • COBSQ0901 This error prevents SQL processing from continuing - further EXEC SQL statements will be ignored.
Parent topic: COBSQ - SQL ECM Preprocessor Error Messages


L - Link Error Messages

  • L000 - L099
    Lists the Link error messages from L000 through L099.
  • L100 - L149
    Lists the Link error messages from L100 through L149.
  • L150 - L199
    Lists the Link error messages from L150 through L199.
  • L200 - L299
    Lists the Link error messages from L200 through L299.
  • L300 - L399
    Lists the Link error messages from L300 through L399.
  • L400 - L449
    Lists the Link error messages from L400 through L449.
  • L450 - L499
    Lists the Link error messages from L450 through L499.
  • L500 - L549
    Lists the Link error messages from L500 through L549.
  • L550 - L599
    Lists the Link error messages from L550 through L599.
  • L600 - L649
    Lists the Link error messages from L600 through L649.
  • L650 - L699
    Lists the Link error messages from L650 through L699.
  • L700 - L799
    Lists the Link error messages from L700 through L799.
  • L800 - L899
    Lists the Link error messages from L800 through L899.
  • L900 - L999
    Lists the Link error messages from L900 through L999.
  • L1000 - L1099
    Lists the Link error messages from L1000 through L1099.
  • L30000 - L30099
    Lists the Link error messages from L30000 through L30099.
Parent topic: Error Messages


L000 - L099

  • L007: Statement contains the illegal character character.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -007, for information.
  • L010: The string constant beginning character is not terminated.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -010, for information.
  • L029: INTO clause required.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -029, for information.
  • L060: Invalid type specification: spec.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -060, for information.
  • L084: UNACCEPTABLE SQL STATEMENT.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -084, for information.
Parent topic: L - Link Error Messages


L100 - L149

  • L101: The statement is too long or too complex.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -101, for information.
  • L102: Size of string constant starting string is too great.
    See the Error SQLCODES section of your IBM Database Messages and Codes Manual, message -102, for information.
  • L103: literal is an invalid numeric literal.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -103, for information.
  • L104: Illegal symbol token. Valid symbols are token-list.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -104, for information.
  • L105: Invalid string.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -105, for information.
  • L107: The name name is too long. Maximum allowable size is size.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -107, for information.
  • L108: THE NAME name IS QUALIFIED INCORRECTLY
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -108, for information.
  • L109: clause clause is not permitted.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -109, for information.
  • L110: Invalid hex literal beginning string.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -110, for information.
  • L111: A column function does not include a column name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -111, for information.
  • L112: The operand of a column function is another column function.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -112, for information.
  • L113: Invalid character found in name: name. Reason code - reason-code.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -113, for information.
  • L114: THE LOCATION NAME location DOES NOT MATCH THE CURRENT SERVER
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -114, for information.
  • L115: A predicate is invalid because operation operation is followed by a list, any or all.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -115, for information.
  • L117: The number of insert values is not the same as the number of object columns.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -117, for information.
  • L118: The object table or view of the insert/delete/update is in a FROM clause.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -118, for information.
  • L119: A column in a HAVING clause is not included in the GROUP BY clause.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -119, for information.
  • L120: A WHERE clause or a SET clause includes a column function.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -120, for information.
  • L121: Column name is used more than once in insert or update.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -121, for information.
  • L122: Select with no GROUP BY has column name/function or a column name not in GROUP BY.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -122, for information.
  • L123: THE PARAMETER IN POSITION n IN THE FUNCTION name MUST BE A CONSTANT OR KEYWORD
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -123, for information.
  • L125: An integer in the ORDER BY clause does not identify a column of the result.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -125, for information.
  • L126: The SELECT statement contains both an UPDATE clause and an ORDER BY clause.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -126, for information.
  • L127: Distinct is specified more than once in a subselect.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -127, for information.
  • L128: Invalid use of NULL in a predicate.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -128, for information.
  • L129: The statement contains too many table names.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -129, for information.
  • L130: Escape clause with more than one char or string contains invalid esc char.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -130, for information.
  • L131: Statement with LIKE predicate has incompatible data types.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -131, for information.
  • L132: AN OPERAND OF value IS NOT VALID
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -132, for information.
  • L133: Column function in subquery of HAVING invalid because expression applies op to corr ref.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -133, for information.
  • L134: IMPROPER USE OF LONG STRING COLUMN column-name OR AN EXPRESSION OF MAXIMUM LENGTH GREATER THAN 255.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -134, for information.
  • L136: Sort cannot be executed because sort key length > 4000 bytes.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -136, for information.
  • L137: THE LENGTH RESULTING FROM operation IS GREATER THAN maximum-length
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -137, for information.
  • L138: The second or third argument of the SUBSTR function is out of range.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -138, for information.
  • L142: THE SQL STATEMENT IS NOT SUPPORTED
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -142, for information.
  • L144: Invalid section number number.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -144, for information.
  • L147: ALTER FUNCTION function-name FAILED BECAUSE SOURCE FUNCTIONS CANNOT BE ALTERED
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -147, for information.
  • L148: THE SOURCE TABLE source-name CANNOT BE RENAMED OR ALTERED
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -148, for information.
Parent topic: L - Link Error Messages


L150 - L199

  • L150: The INSERT, DELETE or UPDATE object is a view and is not permitted.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -150, for information.
  • L151: Update is invalid because the descr of column name cannot be updated.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -151, for information.
  • L152: THE DROP clause CLAUSE IN THE ALTER STATEMENT IS INVALID BECAUSE constraint-name IS A constraint-type
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -152, for information.
  • L153: The CREATE VIEW statement does not include a required column list.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -153, for information.
  • L154: CREATE VIEW failed because definition with union, union all, or remote object.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -154, for information.
  • L156: The statement does not identify a table.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -156, for information.
  • L157: name is not the name of a table needed for a foreign key clause.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -157, for information.
  • L158: Number of columns specified for view is not equal to number of columns in select.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -158, for information.
  • L159: DROP or COMMENT ON token identifies a(n) token.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -159, for information.
  • L160: The WITH CHECK OPTION cannot be used for the specified view.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -160, for information.
  • L161: INSERT or UPDATE not allowed because result row does not satisfy view definition.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -161, for information.
  • L164: authid does not have privilege to create a view with qualification authorization.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -164, for information.
  • L170: The number of arguments specified for function is invalid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -170, for information.
  • L171: The data type, length, or value of argument argument of function is invalid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -171, for information.
  • L173: UR IS SPECIFIED ON THE WITH CLAUSE BUT THE CURSOR IS NOT READ-ONLY
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -173, for information.
  • L180: The string representation of a datetime value has invalid syntax.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -180, for information.
  • L181: The string representation of a datetime value is not a valid datetime value.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -181, for information.
  • L182: An arithmetic expression with a datetime value is invalid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -182, for information.
  • L183: Arithmetic operation on date or timestamp has result not in valid range.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -183, for information.
  • L184: Arithmetic expression with a datetime value contains a parameter marker.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -184, for information.
  • L185: Local format option was used with date or time with no local exit.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -185, for information.
  • L186: Local date or time length was increased and the execute program uses old length.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -186, for information.
  • L187: Reference to a current date/time special register is invalid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -187, for information.
  • L188: The string representation of a name is invalid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -188, for information.
  • L189: CCSID ccsid is unknown or invalid for the data type or subtype.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -189, for information.
  • L190: ATTRIBUTES OF column-name IN table-name ARE NOT COMPATIBLE WITH EXISTING COLUMN
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -190, for information.
  • L191: A string cannot be used because it is invalid mixed data.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -191, for information.
  • L197: QUALIFIED NAMES IN ORDER BY NOT PERMITTED WITH UNION OR UNION ALL
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -197, for information.
  • L198: Operand of the PREPARE or EXECUTE IMMEDIATE statement is blank or empty.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -198, for information.
  • L199: Illegal use of keyword keyword. Token token was expected.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -199, for information.
Parent topic: L - Link Error Messages


L200 - L299

  • L203: A reference to column name is ambiguous.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -203, for information.
  • L204: name is an undefined name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -204, for information.
  • L205: col is not a column of table tablename.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -205, for information.
  • L206: name is not a column of a table in an INSERT, UPDATE or FROM clause.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -206, for information.
  • L207: ORDER BY invalid because the column name applies to result of UNION or UNION ALL.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -207, for information.
  • L208: ORDER BY invalid because column name is not part of the result table.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -208, for information.
  • L212: name IS MULTIPLY SPECIFIED IN TRIGGER REFERENCING CLAUSE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -212, for information.
  • L219: The required explanation table name does not exist.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -219, for information.
  • L220: Column name in explanation table name is not defined properly.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -220, for information.
  • L221: "opt cols" in explanation table name is incomplete. Opt col name is missing.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -221, for information.
  • L240: THE PART CLAUSE OF A LOCK TABLE STATEMENT IS INVALID
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -240, for information.
  • L250: Local location name is not defined when procession a 3-part object name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -250, for information.
  • L251: Token name is not valid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -251, for information.
Parent topic: L - Link Error Messages


L300 - L399

  • L301: Value of input host variable number number not used because wrong data type.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -301, for information.
  • L302: Value of input variable number number is invalid for the target column.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -302, for information.
  • L303: Cannot assign value to output host variable number number. Types not comparable.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -303, for information.
  • L304: Value with data type type cannot go in host variable at position number.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -304, for information.
  • L305: Output host variable number number cannot be NULL when there is no indicator.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -305, for information.
  • L309: Predicate is invalid because a referenced host variable has the NULL value.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -309, for information.
  • L310: DECIMAL HOST VARIABLE OR PARAMETER number CONTAINS NON-DECIMAL DATA
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -310, for information.
  • L311: Length of input host variable number number is negative or greater than the max.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -311, for information.
  • L312: Undefined or unusable host variable name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -312, for information.
  • L313: Number of host variables specified "< >" to number of parameter markers.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -313, for information.
  • L314: The statement contains an ambiguous host variable reference.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -314, for information.
  • L327: CANNOT INSERT ROW BECAUSE IT IS OUTSIDE THE BOUND OF THE PARTITION RANGE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -327, for information.
  • L330: String cannot be translated. Reason reason, char code-point, host var number.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -330, for information.
  • L331: String cannot be assigned to a host variable. Reason reason, char code-point, pos number.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -331, for information.
  • L332: SYSSTRINGS does not define a translation CCSID ccsid to ccsid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -332, for information.
  • L333: String variable subtype not same as bind time and diff cannot be resolved.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -333, for information.
  • L338: AN ON CLAUSE IS INVALID
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -338, for information.
  • L350: INVALID SPECIFICATION OF A LARGE OBJECT COLUMN
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -350, for information.
  • L351: UNSUPPORTED SQLTYPE IN POSITION position-number OF SELECT-LIST
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -351, for information.
  • L352: UNSUPPORTED SQLTYPE IN POSITION position-number OF INPUT-LIST
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -352, for information.
  • L355: A LOB COLUMN IS TOO LARGE TO BE LOGGED
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -355, for information.
  • L372: ONLY ONE COLUMN DEFINED AS ROWID IS ALLOWED IN A TABLE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -372, for information.
  • L390: FUNCTION function-name (specific-name), NOT VALID IN THAT CONTEXT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -390, for information.
  • L392: SQLDA PROVIDED FOR cursor HAS BEEN CHANGED FROM PREVIOUS FETCH
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -392, for information.
  • L396: object-typeobject-name EXECUTED SQL STATEMENT DURING FINAL CALL PROCESSING
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -396, for information.
  • L397: GENERATED OPTION SPECIFIED ON COLUMN THAT IS NOT TYPE ROW ID
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -397, for information.
  • L398: LOCATOR REQUESTED FOR HOST VARIABLE position-number BUT VARIABLE NOT A LOB
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -398, for information.
  • L399: ATTEMPTED TO INSERT AN INVALID VALUE INTO A ROWID COLUMN
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -399, for information.
Parent topic: L - Link Error Messages


L400 - L449

  • L400: THE CATALOG HAS THE MAXIMUM NUMBER OF USER DEFINED INDEXES
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -400, for information.
  • L401: Operands of an arithmetic or comparison operation are not comparable.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -401, for information.
  • L402: Arithmetic function/operator "< >" applied to character/datetime data.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -402, for information.
  • L404: THE SQL STATEMENT SPECIFIES A STRING THAT IS TOO LONG
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -404, for information.
  • L405: Numeric literal literal is out of range.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -405, for information.
  • L406: A calculated or derived numeric value not within range of its object column.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -406, for information.
  • L407: COLUMN column-name CANNOT CONTAIN NULL VALUES IN INSERT, UPDATE OR SET
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -407, for information.
  • L408: THE VALUE IS NOT COMPATIBLE WITH THE DATA TYPE OF ITS TARGET
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -408, for information.
  • L409: Invalid operand of a count function.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -409, for information.
  • L410: Floating point literal literal contains more than 30 characters.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -410, for information.
  • L411: Current datetime, SQLID or user keyword cannot be used as specified.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -411, for information.
  • L412: The SELECT clause of a subquery specifies multiple columns.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -412, for information.
  • L413: OVERFLOW OCCURRED DURING NUMERIC DATA TYPE CONVERSION
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -413, for information.
  • L414: Numeric or datetime column name is specified in a LIKE predicate.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -414, for information.
  • L415: Cols, number, of the operands of a union do not have comparable col. descr.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -415, for information.
  • L416: An operand of a union contains a long string column.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -416, for information.
  • L417: PREPARE string includes parameter markers as operand of same operator.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -417, for information.
  • L418: A string to be prepared contains an invalid use of parameter markers.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -418, for information.
  • L419: Decimal divide operation is invalid because the result has a negative scale.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -419, for information.
  • L420: STRING ARGUMENT VALUE NOT ACCEPTABLE TO FUNCTION function-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -420, for information.
  • L421: Operand of a union or union all does not have the same number of columns.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -421, for information.
  • L423: INVALID VALUE FOR LOCATOR IN POSITION position-number
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -423, for information.
  • L426: Dynamic commit not valid at application server where updates not allowed.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -426, for information.
  • L427: Dynamic rollback not valid at application server where updates not allowed.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -427, for information.
  • L430: routine-typeroutine-name (specific-name) HAS ABNORMALLY TERMINATED
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -430, for information.
  • L433: VALUE value IS TOO LONG
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -433, for information.
  • L435: INVALID SQLSTATE sqlstate SPECIFIED IN RAISE_ERROR OR IN A SIGNAL SQLSTATE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -435, for information.
  • L438: APPLICATION RAISED ERROR WITH DIAGNOSTIC TEXT: text
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -438, for information.
  • L440: NO routine-type NAMED routine-name WITH COMPATIBLE ARGUMENTS WAS FOUND
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -440, for information.
  • L441: INVALID USE OF 'DISTINCT' OR 'ALL' WITH SCALAR FUNCTION function-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -441, for information.
  • L443: function-name (specific-name) RETURNED WITH DIAGNOSTIC TEXT msg-text
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -443, for information.
  • L444: USER PROGRAM name COULD NOT BE FOUND
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -444, for information.
  • L449: INVALID EXTERNAL NAME CLAUSE FOR FUNCTION OR PROCEDURE routine-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -449, for information.
Parent topic: L - Link Error Messages


L450 - L499

  • L450: FUNCTION/STORED PROCEDURE name, PARAMETER NUMBER parmnum, OVERLAYED MEMORY
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -450, for information.
  • L451: INVALID data-item DEFINITION IN function-name, INVALID DATA TYPE type
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -451, for information.
  • L453: PROBLEM WITH THE RETURNS CLAUSE FOR FUNCTION function-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -453, for information.
  • L454: SIGNATURE FOR FUNCTION function-name NOT UNIQUE WITHIN SCHEMA
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -454, for information.
  • L455: function-name, SCHEMA schema-name1 IN SPECIFIC NAME DOES NOT MATCH schema-name2
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -455, for information.
  • L456: FUNCTION function-name, SPECIFIC specific-name EXISTS IN THE SCHEMA
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -456, for information.
  • L457: ILLEGAL USE OF name; IT IS RESERVED FOR SYSTEM USE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -457, for information.
  • L458: FUNCTION function-name COULD NOT BE FOUND BY SIGNATURE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -458, for information.
  • L461: VALUE OF TYPE source-data-type CANNOT BE CAST TO target-data-type
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -461, for information.
  • L463: routine-name (specific-name) RETURNED sqlstate, DIAGNOSTIC TEXT text
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -463, for information.
  • L469: CALL STATEMENT NEEDS AN OUTPUT HOST VARIABLE FOR PARAMETER number
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -469, for information.
  • L470: CALL STATEMENT SPECIFIED A NULL VALUE FOR INPUT PARAMETER number
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -470, for information.
  • L471: INVOCATION OF FUNCTION/PROCEDURE name FAILED DUE TO REASON rc
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -471, for information.
  • L472: CURSOR cursor-name LEFT OPEN BY FUNCTION function-name (specific-name)
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -472, for information.
  • L473: USER DEFINED TYPE CANNOT BE THE SAME NAME AS A BUILT-IN TYPE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -473, for information.
  • L475: type-1 RESULT CANNOT BE CAST TO type-2 RETURN TYPE OF THE function-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -475, for information.
  • L476: FUNCTION function-name NAMED WITHOUT SIGNATURE, FUNCTION NOT UNIQUE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -476, for information.
  • L478: ACTION ON type1 CANNOT BE PROCESSED; name OF TYPE type2 DEPENDENT ON IT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -478, for information.
  • L480: PROCEDURE procedure-name HAS NOT YET BEEN CALLED
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -480, for information.
  • L482: PROCEDURE procedure-name RETURNED NO LOCATORS
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -482, for information.
  • L483: PARMS FOR function-name DOES NOT MATCH NUMBER OF PARMS OF SOURCE FUNCTION
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -483, for information.
  • L487: object-typeobject-name USED SQL BUT WAS CREATED WITH NOSQL OPTION
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -487, for information.
  • L491: FUNCTION function-name MUST HAVE RETURNS, AND EITHER EXTERNAL OR SOURCE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -491, for information.
  • L492: function-name PARAMETER number HAS MISMATCH WITH A SOURCE FUNCTION
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -492, for information.
  • L495: EST COST OF estimate-amount1 PROCESSOR SECONDS EXCEEDS RESOURCE LIMIT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -495, for information.
  • L496: SQL STATEMENT REFERENCES A RESULT SET NOT CREATED BY THE CURRENT SERVER
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -496, for information.
  • L497: INTERNAL IDENTIFIERS LIMIT HAS BEEN EXCEEDED FOR DATABASE database-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -497, for information.
  • L499: CURSOR cursor-name ALREADY ASSIGNED TO procedure-name RESULT SET
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -499, for information.
Parent topic: L - Link Error Messages


L500 - L549

  • L500: IDENTIFIED CURSOR WAS CLOSED WHEN THE CONNECTION WAS DESTROYED
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -500, for information.
  • L501: Cursor identified in a FETCH or CLOSE statement is not open.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -501, for information.
  • L502: The cursor identified in an OPEN statement is already open.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -502, for information.
  • L503: Column cannot be updated because it is not in the UPDATE clause of the select.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -503, for information.
  • L504: The cursor name name is not defined.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -504, for information.
  • L507: The cursor identified in the UPDATE or DELETE statement is not open.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -507, for information.
  • L508: Cursor identified in an update or delete is not positioned on a row.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -508, for information.
  • L509: The table in an UPDATE or DELETE is not a table designated by cursor.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -509, for information.
  • L510: Table designated by cursor of UPDATE/DELETE statement cannot be modified.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -510, for information.
  • L511: FOR UPDATE clause invalid because cursor cannot be modified.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -511, for information.
  • L512: Statement reference to remote object is invalid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -512, for information.
  • L513: The alias name must not be defined by another local or remote alias.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -513, for information.
  • L514: The cursor name is not in a prepared state.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -514, for information.
  • L516: The described statement does not identify a prepared statement.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -516, for information.
  • L517: Cursor name does not identify a prepared SELECT statement.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -517, for information.
  • L518: The EXECUTE statement does not identify a valid prepared statement.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -518 for information.
  • L519: PREPARE identifies SELECT statement of the open cursor name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -519, for information.
  • L525: SQL cannot execute, error at bind for section sectno, package pkgname, consistency token Xcontoken.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -519, for information.
  • L526: REQUESTED FUNCTION DOES NOT APPLY TO GLOBAL TEMPORARY TABLES
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -526, for information.
  • L530: The INSERT or UPDATE value of foreign key name is invalid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -530, for information.
  • L531: Primary key in parent has dependent rows in relation name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -531, for information.
  • L532: The relation name restricts the deletion of row with RID X number.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -532, for information.
  • L533: Invalid multiple-row insert.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -533, for information.
  • L534: The primary key cannot be updated because of multiple-row update.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -534, for information.
  • L535: Invalid update or delete with WHERE CURRENT OF.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -535, for information.
  • L536: Delete is invalid because table name can be affected by the operation.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -536, for information.
  • L537: Primary key/foreign key identifies column name more than once.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -537, for information.
  • L538: Foreign key name does not match description of primary key of table name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -538, for information.
  • L539: Table name does not have a primary key.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -539, for information.
  • L540: Definition of table name does not have primary index.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -540, for information.
  • L541: FOREIGN KEY key-name HAS DUPLICATE REFERENTIAL CONSTRAINT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -541, for information.
  • L542: name cannot be a column of primary key because it can contain NULL values.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -542, for information.
  • L543: CANNOT DELETE ROW IN PARENT TABLE; RESTRICTED BY CONSTRAINT check-constraint
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -543, for information.
  • L544: CANNOT ADD CHECK CONSTRAINT; EXISTING ROW VIOLATES THE CHECK CONSTRAINT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -544, for information.
  • L545: The requested operation is not allowed because of the check constraint CheckConstraint.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -545, for information.
  • L546: CHECK CONSTRAINT constraint-name IS INVALID
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -159, for information.
  • L548: A CHECK CONSTRAINT THAT IS DEFINED WITH column-name IS INVALID
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -548, for information.
  • L549: The Statement statement is not allowed for ObjectType1ObjectName because the bind option dynamicrules in the ObjectType2 is in effect.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -549, for information.
Parent topic: L - Link Error Messages


L550 - L599

  • L551: Authid does not have privileges to perform operation Name on this object.
    If you are using the ODBC Smart Driver to monitor or record SQL, check that the specified authid has permission to access the ODBC_* tables used by the Static Bind Administrator. For a list of these tables and the permissions required to access them, see the GRANT statements in the ODBCSQL.SQL file located in your Micro Focus program directory.
  • L552: authid does not have the privileges to perform operation operation.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -552, for information.
  • L553: authid specified is not one of the valid AuthIDs.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -553, for information.
  • L554: An AuthID cannot grant a privilege to itself.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -554, for information.
  • L555: An AuthID cannot revoke a privilege from itself.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -555, for information.
  • L556: A privilege cannot be revoked because it is not possessed by authid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -556, for information.
  • L557: Inconsistent grant/revoke keyword keyword. Permitted keywords are keyword-list.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -557, for information.
  • L558: Invalid clause or combination of clauses on a grant or revoke.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -558, for information.
  • L559: All authorization functions have been disabled.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -559, for information.
  • L567: bind-type AUTHORIZATION ERROR FOR auth-idpackage-nameprivilege
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -567, for information.
  • L571: The statement would result in a multiple site update.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -571, for information.
  • L573: table-name DOES NOT HAVE UNIQUE KEY WITH SPECIFIED COLUMN NAMES
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -573, for information.
  • L574: THE DEFAULT VALUE CONFLICTS WITH DEFINITION OF COLUMN column-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -574, for information.
  • L577: DEFINITION OF object-typeobject-name DID NOT SPECIFY MODIFY DATA
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -577, for information.
  • L579: DEFINITION OF object-typeobject-name DID NOT SPECIFY READ OR MODIFY DATA
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -579, for information.
  • L580: THE RESULT-EXPRESSIONS OF A CASE EXPRESSION CANNOT ALL BE NULL
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -580, for information.
  • L581: RESULT-EXPRESSION DATA TYPES OF CASE EXPRESSION ARE NOT COMPATIBLE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -581, for information.
  • L582: WHEN-CLAUSE CONDITION CANNOT BE QUANTIFIED, IN, OR EXISTS PREDICATE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -582, for information.
  • L583: INVALID USE OF FUNCTION; function-name NOT DETERMINISTIC/EXTERNAL ACTION
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -583, for information.
  • L585: SCHEMA NAME schema-name CANNOT APPEAR MORE THAN ONCE IN THE CURRENT PATH
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -585, for information.
  • L586: TOTAL LENGTH OF CURRENT PATH SPECIAL REGISTER CANNOT EXCEED 254 CHARACTERS
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -586, for information.
  • L587: A LIST OF ITEM-REFERENCES ARE NOT IN THE SAME FAMILY
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -587, for information.-587, for information.
  • L590: PARAMETER parameter-name NOT UNIQUE FOR ROUTINE routine-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -590, for information.
  • L592: NOT AUTHORIZED TO CREATE FUNCTIONS/PROCEDURES IN WLM ENV env-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -592, for information.
Parent topic: L - Link Error Messages


L600 - L649

  • L601: Name of the object to be created identical to existing name name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -601, for information.
  • L602: Too many columns specified in a CREATE INDEX.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -602, for information.
  • L603: Unique index cannot be created. The table has rows with duplicate columns.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -603, for information.
  • L604: Column definition specifies an invalid length, precision, or scale attribute.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -604, for information.
  • L607: Operation operation is not defined for system tables.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -607, for information.
  • L611: ONLY LOCKMAX 0 CAN BE SPECIFIED WHEN LOCK SIZE IS TABLESPACE OR TABLE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -611, for information.
  • L612: name is a duplicate column name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -612, for information.
  • L613: The primary key is too long or has too many columns.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -613, for information.
  • L614: Cannot create index. Sum of internal lengths of columns > allowable.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -614, for information.
  • L615: op is not allowed on a package in use.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -615, for information.
  • L616: obj-typeobj-name CANNOT BE DROPPED; REFERENCED BY obj-typeobj-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -616, for information.
  • L617: TYPE 1 INDEX IS NOT VALID FOR TABLE table-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -617, for information.
  • L618: Operation operation is not allowed on system databases.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -618, for information.
  • L619: Operation disallowed because the workfile database is not stopped.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -619, for information.
  • L620: Keyword keyword not allowed for tablespace in workfile database.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -620, for information.
  • L621: Duplicate dbid dbid was detected and previously assigned to dbname.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -621, for information.
  • L622: FOR MIXED DATA is invalid because MIXED DATA inst opt is NO.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -622, for information.
  • L623: A clustering index already exists on table name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -623, for information.
  • L624: Table name already has a primary key.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -624, for information.
  • L625: TABLE table-name DOES NOT HAVE INDEX TO ENFORCE UNIQUENESS OF PARENT KEY
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -625, for information.
  • L626: ALTER statement is not executable because the pageset is not stopped.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -626, for information.
  • L627: ALTER statement is invalid because the pageset has user-managed data set.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -627, for information.
  • L628: THE CLAUSES ARE MUTUALLY EXCLUSIVE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -628, for information.
  • L629: No set NULL because foreign key name cannot contain NULL values.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -629, for information.
  • L630: WHERE NOT NULL SPECIFICATION IS INVALID FOR TYPE 1 INDEXES
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -630, for information.
  • L631: Foreign key name is too long or has too many columns.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -631, for information.
  • L632: Cannot define table as dependent of name due to delete rule restriction.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -632, for information.
  • L633: The delete rule must be delete.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -633, for information.
  • L634: The delete rule must not be cascade.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -634, for information.
  • L635: The delete rules cannot be different or cannot be set NULL.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -635, for information.
  • L636: Partitioning keys not specified in ascending/descending order.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -636, for information.
  • L637: Duplicate keyword keyword.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -637, for information.
  • L638: Table name cannot be created. Column definition is missing.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -638, for information.
  • L639: Column of foreign key with delete rule of set NULL cannot be in partition index.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -639, for information.
  • L640: LOCKSIZE ROW CANNOT BE SPECIFIED; TABLE HAS TYPE 1 INDEX
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -640, for information.
  • L642: TOO MANY COLUMNS IN UNIQUE CONSTRAINTS
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -642, for information.
  • L643: CHECK CONSTRAINT EXCEEDS MAXIMUM ALLOWABLE LENGTH
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -643, for information.
  • L644: INVALID VALUE SPECIFIED FOR KEYWORD keyword IN statement-type STATEMENT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -644, for information.
  • L646: Cannot create table name in partitioned default tablespace name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -646, for information.
  • L647: Bufferpool name cannot be specified. It has not been activated.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -647, for information.
Parent topic: L - Link Error Messages


L650 - L699

  • L650: THE ALTER INDEX CANNOT BE EXECUTED, REASON reason-code
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -650, for information.
  • L651: TABLE DESCRIPTION EXCEEDS MAXIMUM SIZE OF OBJECT DESCRIPTOR
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -651, for information.
  • L652: Violation of installation-defined edit or validation procedure proc.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -652, for information.
  • L653: Table name in partitioned tablespace name not available.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -653, for information.
  • L655: CREATE OR ALTER STOGROUP IS INVALID
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -655, for information.
  • L658: object-type CANNOT BE DROPPED USING THE statement STATEMENT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -658, for information.
  • L660: Cannot create index name on partitioned tablespace name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -660, for information.
  • L661: Cannot create index name on partitioned tablespace name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -661, for information.
  • L662: Cannot create a partitioned index on a non-partitioned tablespace name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -662, for information.
  • L663: Number of key limit values is 0, or > number of columns in key of index.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -663, for information.
  • L664: Internal length of limit-key fields for partitioned index name is too long.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -664, for information.
  • L665: The PART clause of an ALTER statement is omitted or invalid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -665, for information.
  • L666: stmt-verbobject cannot be executed because of something in progress.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -666, for information.
  • L667: Clustering index for partitioned tablespace cannot be explicitly dropped.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -667, for information.
  • L668: Cannot add column to the table because the table has an edit procedure.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -668, for information.
  • L669: A table in a partitioned tablespace cannot be explicitly dropped.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -669, for information.
  • L670: The record length of the table exceeds the page size limit.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -670, for information.
  • L671: Cannot alter buffpool attr of tablespace because pg size of tablespace would change.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -671, for information.
  • L672: OPERATION DROP NOT ALLOWED ON TABLE table-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -672, for information.
  • L676: A 32K page bufferpool may not be used for an index.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -676, for information.
  • L677: Insufficient virtual storage for bufferpool expansion.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -677, for information.
  • L678: literal specified for index limit key must conform to data type type.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -678, for information.
  • L679: Object name cannot be created. A drop is pending on the object.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -679, for information.
  • L680: Too many columns specified for a table.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -680, for information.
  • L681: Column name in violation of installation-defined field procedure name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -681, for information.
  • L682: Field procedure proc could not be loaded.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -682, for information.
  • L683: Invalid column type for fieldproc or bit data option, column.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -683, for information.
  • L684: The length of literal list beginning string is too long.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -684, for information.
  • L685: Invalid field type column.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -685, for information.
  • L686: Cannot compare column defined by one field procedure to one defined by another.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -686, for information.
  • L687: Field types incomparable.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -687, for information.
  • L688: Incorrect data returned from field procedure, column, msgno.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -688, for information.
  • L689: Too many columns defined for a dependent table.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -689, for information.
  • L690: Statement is rejected by data def ctrl support, reason reason.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -690, for information.
  • L691: The required registrations table table does not exist.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -691, for information.
  • L692: Unique index index-name in table table-name does not exist.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -692, for information.
  • L693: Column column is not defined properly.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -693, for information.
  • L694: DDL STMT CANNOT EXECUTE; DROP PENDING ON DDL REGISTRATION TABLE table-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -694, for information.
  • L696: TRIGGER trigger-name CONTAINS INVALID USE OF NAME name, REASON reason-code
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -696, for information.
  • L697: CORR. NAMES NOT ALLOWED IN TRIGGER WITH "FOR EACH STATEMENT" OR "BEFORE"
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -697, for information.
Parent topic: L - Link Error Messages


L700 - L799

  • L713: REPLACEMENT VALUE value FOR special-register IS INVALID
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -713, for information.
  • L715: Prog program dep on function of the release from which fallback has occurred.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -715, for information.
  • L716: Program program precompiled with wrong level for this release.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -716, for information.
  • L717: object dependent on function of release from which fallback has occurred.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -717, for information.
  • L718: REBIND failed because IBMREQD of ibmreqd is invalid.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -718, for information.
  • L719: BIND ADD error, package package already exists.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -719, for information.
  • L720: Attempt to replace package package with existing version version.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -720, for information.
  • L721: BIND err CONTOK = contoken X cannot be created because it is not unique.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -721, for information.
  • L722: Package package does not exist.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -722, for information.
  • L723: ERROR IN TRIGGER trigger-name, SECTION NUMBER section-number
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -723, for information.
  • L724: ACTIVATION OF object-typeobject-name WOULD EXCEED MAXIMUM OF SQL CASCADING
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -724, for information.
  • L725: SPECIAL REGISTER register AT location WAS SUPPLIED INVALID VALUE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -725, for information.
  • L726: Cannot replace package package. Enable or disable entries also with package.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -726, for information.
  • L728: DATA TYPE data-type IS NOT ALLOWED IN DB2 PRIVATE PROTOCOL PROCESSING
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -728, for information.
  • L729: COMMIT ON RETURN STORED PROCEDURE CANNOT BE IN NESTED CALL STATEMENT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -729, for information.
  • L730: The parent of a table in a read-only database must also be in the database.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -730, for information.
  • L731: User-defined dataset dsname must be defined with SHAREOPTIONS(1,3).
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -731, for information.
  • L732: Table space or index space has not been defined on the owning subsystem.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -732, for information.
  • L733: The description of a table space, index space or ROSHARE READ db must be consistent.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -733, for information.
  • L734: The ROSHARE attr of a database cannot be altered from ROSHARE READ.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -734, for information.
  • L735: Database dbid is not longer a shared database.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -735, for information.
  • L736: Invalid OBID obid specified.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -736, for information.
  • L737: Implicit table space not allowed.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -737, for information.
  • L739: ALTER function-name FAILED; PARALLEL PROCESSED FUNCTIONS CANNOT MODIFY DATA
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -739, for information.
  • L740: FUNCTION name THAT MODIFIES SQL DATA IS NOT VALID IN CURRENT CONTEXT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -740, for information.
  • L741: WORK FILE DATABASE IS ALREADY DEFINED FOR MEMBER member-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -741, for information.
  • L742: DSNDB07 IS THE IMPLICIT WORK FILE DATABASE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -742, for information.
  • L746: SQL STATEMENT IN name VIOLATES THE NESTING SQL RESTRICTION
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -746, for information.
  • L747: table-name NOT AVAILABLE UNTIL AUX TABLES AND INDEXES HAVE BEEN CREATED
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -747, for information.
  • L748: AN INDEX ALREADY EXISTS ON AUXILIARY TABLE table-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -748, for information.
  • L750: TABLE source-name CANNOT BE RENAMED; REFERENCED BY EXISTING DEFINITIONS
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -750, for information.
  • L751: object-typeobject-name (specific-name) ATTEMPTED TO EXECUTE statement
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -751, for information.
  • L752: CONNECT statement invalid because the process is not in the connectable state.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -752, for information.
  • L763: INVALID TABLE SPACE NAME table-space-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -763, for information.
  • L764: LOB TABLE SPACE AND ITS BASE TABLE SPACE MUST BE IN SAME DATABASE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -764, for information.
  • L765: TABLE IS NOT COMPATIBLE WITH DATABASE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -765, for information.
  • L766: REQUESTED OPERATION NOT PERMITTED ON AUXILIARY TABLE OF STATEMENT OBJECT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -766, for information.
  • L767: MISSING OR INVALID COLUMN SPECIFICATION FOR INDEX index-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -767, for information.
  • L768: AUXILIARY TABLE ALREADY EXISTS FOR THE SPECIFIED COLUMN OR PARTITION
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -768, for information.
  • L769: SPECIFICATION OF AUX TABLE DOES NOT MATCH CHARACTERISTICS OF BASE TABLE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -769, for information.
  • L770: TABLE table-name CANNOT HAVE LOB COLUMN UNLESS IT ALSO HAS ROWID COLUMN
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -770, for information.
  • L771: INVALID SPECIFICATION OF A ROWID COLUMN
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -771, for information.
  • L797: ATTEMPT TO CREATE TRIGGER trigger-name WITH AN UNSUPPORTED SQL STATEMENT
  • L798: ATTEMPT TO INSERT VALUE INTO ROWID GENERATED ALWAYS COLUMN column-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -798, for information.
Parent topic: L - Link Error Messages


L800 - L899

  • L802: EXCEPTION ERROR exception-type OCCURRED DURING operation-type OPERATION ON data-type DATA
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -802, for information.
  • L803: INSERT/UPDATE INVALID;INDEX SPACE index-space-name RESTRICTS DUP COLUMNS, RID row-id
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -803, for information.
  • L804: Error found in application program input parameters for the SQL statement.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -804, for information.
  • L805: Program name name not found in plan name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -805, for information.
  • L807: Access denied to package pkg.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -807, for information.
  • L808: CONNECT STATEMENT IS NOT CONSISTENT WITH THE FIRST CONNECT STATEMENT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -808, for information.
  • L811: Result of embedded select statement is a table with more than one row.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -811, for information.
  • L812: BLANK COLLECTION-ID IN CURRENT PACKAGE SET; PGM program-name.consistency-token USING PLAN plan-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -812, for information.
  • L815: GROUP BY/HAVING clause specified in embedded select statement/subquery.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -815, for information.
  • L817: Cannot execute INSERT/UPDATE/DELETE/DLL/AUTHORIZATION statement.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -817, for information.
  • L818: Timestamp in load module is not the same as bind timestamp built from the DBRM.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -818, for information.
  • L819: Cannot process view. Length of its parse tree in the catalog is zero.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -819, for information.
  • L820: Cannot process SQL statement. catalog contains a value not valid in version.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -820, for information.
  • L822: SQLDA contains invalid data address or indicator variable address.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -822, for information.
  • L840: Too many items returned in a select or insert list.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -840, for information.
  • L842: A CONNECTION TO location-name ALREADY EXISTS
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -842, for information.
  • L843: SET CONNECTION OR RELEASE STATEMENT MUST SPECIFY AN EXISTING CONNECTION
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -843, for information.
  • L870: NUMBER OF HOST VARIABLES IN STATEMENT NOT EQUAL TO NUMBER OF DESCRIPTORS
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -870, for information.
  • L872: A VALID CCSID HAS NOT YET BEEN SPECIFIED FOR THIS SUBSYSTEM
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -872, for information.
  • L873: DATA ENCODED WITH DIFFERENT CCSIDS CANNOT BE REFERENCED IN SAME STATEMENT
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -873, for information.
  • L874: object-type ENCODING SCHEME MUST BE SAME AS THE CONTAINING TABLE SPACE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -874, for information.
  • L875: operand CANNOT BE USED WITH THE ASCII DATA REFERENCED
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -875, for information.
  • L876: 'object' CANNOT BE CREATED, REASON 'reason'
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message
  • L877: CCSID ASCII IS NOT ALLOWED FOR THIS DATABASE OR TABLE SPACE
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -877, for information.
  • L878: THE PLAN_TABLE USED FOR EXPLAIN CANNOT BE ASCII
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -878, for information.
  • L879: object-name CANNOT DEFINE OBJECT MIXED/GRAPHIC WITH ENCODING SCHEME encoding-scheme
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -879, for information.
Parent topic: L - Link Error Messages


L900 - L999

  • L900: Cannot EXEC SQL because application is not connected to application server.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -900, for information.
  • L901: System error caused failed execution so subsequent SQL may be successful.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -901, for information.
  • L902: Pointer to the essential ctrl block (CT/RDA) has value 0, rebind required.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -902, for information.
  • L904: Unavailable resource caused failed exec. type type of resource name.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -904, for information.
  • L905: Fail exec due to resource limit, resource name name limit amount.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -905, for information.
  • L906: Cannot execute SQL statement. Function disabled due to a prior error.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -906, for information.
  • L907: Unable to determine if commit of updates made at a remote site failed.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -907, for information.
  • L908: bind error using authid authority no bind or rebind are allowed.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -908, for information.
  • L909: The object has been deleted.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -909, for information.
  • L910: SQL statement cannot access object on which a drop/alter is pending.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -910, for information.
  • L911: Rollback due to a deadlock/timeout. Reason code.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -911, for information.
  • L913: Failed execution cause by deadlock/timeout. Reason code code.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -913, for information.
  • L917: Bind package failed.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -917, for information.
  • L918: SQL cannot be executed because connection has been lost.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -918, for information.
  • L919: A ROLLBACK OPERATION IS REQUIRED
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -919, for information.
  • L922: AUTHORIZATION FAILURE: error-type ERROR. REASON reason-code
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -922, for information.
  • L923: CONNECTION NOT ESTABLISHED: DB2 condition REASON reason-code, TYPE resource-type, NAME resource-name
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -923, for information.
  • L924: DB2 CONNECTION INTERNAL ERROR, function-code, return-code, reason-code
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -924, for information.
  • L925: Commit not valid in IMS/VS or CICS environment.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -925, for information.
  • L926: Rollback not valid in IMS/VS or CICS environment.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -926, for information.
  • L927: Language interface called when the connecting environment was not established.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -927, for information.
  • L929: FAILURE IN A DATA CAPTURE EXIT: token
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -929, for information.
  • L939: ROLLBACK REQUIRED DUE TO UNREQUESTED ROLLBACK OF A REMOTE SERVER
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -939, for information.
  • L947: STATEMENT FAILED;WILL CHANGE TABLE DEFINED BUT DATA CANNOT BE PROPAGATED
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -947, for information.
  • L948: DISTRIBUTED OPERATION IS INVALID
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -948, for information.
  • L950: Location name is invalid or not in comm db.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -950, for information.
  • L981: STATEMENT FAILED;CONNECTION DOES NOT ALLOW SQL OPERATIONS, REASON reason-code.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -981, for information.
  • L991: CrossAccess Data Access error ErrorNum (ConditionCode) for IMS/VSAM. Consult CrossAccess System Messages documentation.
    CrossAccess experienced the specified data error while processing an SQL request against IMS/VSAM. For additional information about this error, see your CrossAccess User Documentation.
  • L992: CrossAccess System error ErrorNum while accessing IMS/VSAM. Contact mainframe systems programming.
    CrossAccess has experienced the specified system error while attempting to access IMS/VSAM. For additional information about this error, see your CrossAccess User Documentation.
Parent topic: L - Link Error Messages


L1000 - L1099

  • L1000: Exec failed. Protocol error: Reason reason (type)
  • L1020: Exec failed with dealloc. Protocol error: reason 1218 (02)
    Manager dependency error detected at other node.
  • L1021: :Execution failed. Manager manager at level level not supported.
    Managers must support certain levels.
  • L1040: Unavail resource caused perm failure. Reason Alloc type type.
    Type = Semaphore
  • L1041: Unavail resource caused perm failure. Reason Alloc type type.
    Type = Semaphore
  • L1050: command command or SQL invalid while bind in progress.
    A binding must be completed before other SQL can be issued.
  • L1051: Bind with specified package name and consistency token not active.
    A section of a package could not be bound because a BEGIN BIND has not been called.
  • L1052: Program preparation assumptions are incorrect.
    The program preparation assumptions in effect for binding a statement (i.e. BINDSQLSTT command) are incorrect.
  • L1053: Owner authorization failure.
    A command could not be executed because the user is not authorized.
  • L1060: RDB authorization failure.
    The user is not authorized to access the location specified.
  • L1061: RDB not found.
    The location name is not valid.
  • L1070: command command not supported.
    The code point indicates a request data stream structure that is not supported.
  • L1071: object object not supported error.
    The code point indicates an object data stream structure that is not supported.
  • L1072: parameter parameter not supported error.
    The code point indicates that a data stream structure parameter is not supported.
  • L1073: value parameter value not supported error.
    The code point indicates that a data stream structure parameter value is not supported.
  • L1074: Reply message with codepoint (severity) not supported.
    The reply message returned from the target is not recognized.
  • L1080: Communication error primary (secondary).
    An unmapped APPC error has occurred.
  • L1090: Remote operation invalid for application execution environment.
    An update operation or a dynamic commit or rollback was attempted at a server that was supporting an application that was in a read-only execution environment (IMS or CICS).
Parent topic: L - Link Error Messages


L30000 - L30099

  • L30000: Distribution protocol error: reason reason-code.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30000, for information.
  • L30020: Distribution protocol error cause deallocation reason: reason-code.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30020, for information.
  • L30021: Distribution protocol error: manager manager at level level not supported.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30021, for information.
  • L30030: Not committed, SQLCODE = orig-sqlcode and SQLSTATE = orig-sqlstate.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30030, for information.
  • L30040: Unavailable resource. Reason reason-code type rsrc-type, name rsrc-name, id pppvvrrm, RDBNAME rdbname.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30040, for information.
  • L30041: Unavailable resource. Reason reason-code type resource-type name resource-name id pppvvrrm RDBNAME rdbname.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30041, for information.
  • L30050: command or SQL statement invalid while bind.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30050, for information.
  • L30051: Bind process with specified package name and consistency token not active.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30051, for information.
  • L30052: Program preparation assumptions are incorrect.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30052, for information.
  • L30053: Owner authorization failure.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30053, for information.
  • L30060: RDB authorization failure.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30060, for information.
  • L30061: RDB not found.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30061, for information.
  • L30070: command command not supported.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30070, for information.
  • L30071: object object not supported.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30071, for information.
  • L30072: parameter: subcode parameter not supported.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30072, for information.
  • L30073: parameter: subcode parameter value not supported.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30073, for information.
  • L30074: Reply message with codepoint (SRVCOD) not supported.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30074, for information.
  • L30080: Communication error code.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30080, for information.
  • L30090: Remote operation invalid for application execution.
    See the section Error SQLCODES in your IBM Database Messages and Codes manual, message -30090, for information.
Parent topic: L - Link Error Messages


N - Network Error Messages

  • N000 - N099
    Lists the Network error messages from N000 through N099.
  • N300 - N399
    Lists the Network error messages from N300 through N399.
  • N400 - N449
    Lists the Network error messages from N400 through N449.
  • N450 - N499
    Lists the Network error messages from N450 through N499.
  • N500 - N599
    Lists the Network error messages from N500 through N599.
Parent topic: Error Messages


N000 - N099

  • N001: Illegal buffer length value.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N002: Undocumented NetBIOS error.
    Undocumented NetBIOS error.
  • N003: Invalid network command.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N004: Undocumented NetBIOS error.
    Undocumented NetBIOS error.
  • N005: NetBIOS command timed out.
    If this error was received while trying to log into the server, then the XDB Server name could not be found. Otherwise, an internal NetBIOS error occurred. Contact Micro Focus Technical Support.
  • N006: Incomplete network message.
    Communications packet was larger than the maximum Receive Buffer size specified by user, either at the server or at the client. If the error was received at the server, check the settings in the XDB Server Configuration utility; if received at the client, check the settings in Options.
  • N008: Illegal local session number number.
    Either the NetBIOS connection to the server was broken (an N024 error preceded this or was ignored) or the connection was never established. For example, this error will occur when a COBOL program attempts and fails to successfully log into the server.
  • N009: Resource is not available.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N010: Session # number closed.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N011: Command canceled.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N012: Undocumented NetBIOS error.
    Undocumented NetBIOS error.
  • N013: Duplicate name name in local name table.
    This error should not be reported to the user. Contact Micro Focus Technical Support if you receive this error.
  • N014: Network name table is full.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N015: Command completed, name has active session and is now de-registered.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N017: Local session table is full.
    Either the maximum number of users specified through the XDB Server Configuration utility are logged into the XDB Server, or the maximum number of NetBIOS sessions allowed by the network software has been reached. In case of the latter, check with your LAN supervisor.
  • N018: Cannot open network session.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N019: Illegal session name identification number.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N020: Cannot find name called or no answer.
    Either the XDB Server is not running, or you are trying to log into an XDB Server that does not exist. Access Options and change the server name. See the XDB Server Administration Guide for instructions on configuring the XDB Server. You may need to increase the timeout period on the client. Also check that NetBIOS is loaded and that your NetBIOS settings are compatible between the server and the client.
  • N021: Name name not found.
    Either the XDB Server is not running, or you are trying to log into an XDB Server that does not exist. Access Options and change the server name. See the XDB Server Administration Guide for instructions on configuring the XDB Server. You may need to increase the timeout period on the client. Also check that NetBIOS is loaded and that your NetBIOS settings are compatible between the server and the client.
  • N022: Name name in use on remote adapter.
    Either the specified server name (if error was received on an XDB Server) or the workstation node name already exists on the network. Try using a different node name. See your Setup guide or the XDB Server Administration Guide for information about configuring the node name for a client workstation or an XDB Server, respectively.
  • N023: Name name was deleted.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N024: Session ended abnormally.
    This error message will appear when the connection between the client and the server is broken. Check to see that the server is up and that there is no problem with the network.
  • N025: Name conflict detected.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N026: Incompatible remote device.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N027 - N032: Undocumented NetBIOS errors.
    Undocumented NetBIOS error.
  • N033: Interface busy.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N034: Too many commands outstanding.
    Internal NetBIOS error. Too many NetBIOS request threads were specified in the XDB Server Configuration. Either reduce the number or edit your NET.CFG for Novell and increase NetBIOS and/or Named Pipe sessions (or in the case of a LAN server increase the number of sessions in the NETBEUI_NIF section of PROTOCOL.INI).
  • N035: Invalid number in NCB_LANA_NUM field.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N036: Command completed while cancel occurring.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N037: Attempt to use reserved name as a group name.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N038: Attempt to issue a command out of sequence.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N040 - N049: Unusual network conditions.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
  • N050: NetBIOS is not loaded.
    The XDB Server requires a NetBIOS-compatible network with NetBIOS running. Check with your Network Administrator. Also you must have both IBM and Novell NetWare in your CONFIG.SYS in OS/2.
  • N051 - N254: Unusual network conditions.
    Internal NetBIOS error. Contact Micro Focus Technical Support.
Parent topic: N - Network Error Messages


N300 - N399

  • N300: TCP Error errmsgfunction( ) = errorcode
    The indicated TCP/IP error occurred. The list below shows possible error codes and their associated error messages.
  • N301: SPX Error: errmsgfunction() = errcode
    The indicated IPX/SPX error occurred. The list below shows possible error codes and their associated error messages:
  • N302: NETBIOS Error errmsgfunction = errorcode
    The specified NETBIOS error has occurred. For example, if you attempt to connect to a server using an invalid server name, or if the specified server is not up and running, the following message is displayed:
  • N357: Invalid Named Pipe function call (ERROR_INVALID_FUNCTION).
    Internal Named Pipes Error. Contact Micro Focus Technical Support.
  • N358: Invalid path path specified for Named Pipe (ERROR_FILE_NOT_FOUND).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N359: Cannot find Named Pipe name (ERROR_PATH_NOT_FOUND).
    Make sure that the XDB Server configuration (XDBSRVCO.EXE or XDBSRVBT.EXE) setting for the number of Named Pipes threads is greater than zero, and that the Named Pipes protocol is turned on.
  • N360: Access denied to Named Pipe name (ERROR_ACCESS_DENIED).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N361: Invalid handle to Named Pipe specified (ERROR_INVALID_HANDLE).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N362: Not enough memory for Named Pipe operation (ERROR_NOT_ENOUGH_MEMORY).
    Close or remove some programs from your machine or acquire more RAM.
  • N363: Invalid format specified for Named Pipe (ERROR_BAD_FORMAT).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N364: No more structures available for Named Pipe name (ERROR_OF_STRUCTURES).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N365: Invalid parameter specified for Named Pipe call (ERROR_INVALID_PARAMETER).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N366: Named Pipes system call interrupted (ERROR_INTERRUPT).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N367: Named Pipe name is broken (ERROR_BROKEN_PIPE).
    The connection has been broken between the server and the client. Check to see that the server is up and that there is no problem with the network. Check that your Named Pipes configuration matches that in the XDB Server Configuration utility.
  • N368: Buffer too small for Named Pipe (ERROR_BUFFER_OVERFLOW).
    The communications packet was larger than the maximum. See error N006.
  • N369: Semaphore not found (ERROR_SEM_TIMEOUT).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N370: Invalid name name specified for Named Pipe (ERROR_INVALID_NAME).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N371: Invalid level parameter (ERROR_INVALID_LEVEL).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N372: Invalid name name specified for Named Pipe (ERROR_SEM_NOT_FOUND).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N373: Handle does not refer to Named Pipe (ERROR_BAD_PIPE).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N374: All available instances of Named Pipe name are in use (ERROR_PIPE_BUSY).
    The maximum number of users communicating via Named Pipes is logged into the XDB Server. To correct this problem, try increasing the number of Named Pipe Receive Threads (XDB Server Configuration utility, Multi-user Options). Also, if embedding SQL in COBOL, check your code to be sure you have not used the LOGON and LOGOFF directives in subprograms. See the XDB Server Administration Guide for configuration information.
  • N375: Data unavailable on non-blocking read (ERROR_NO_DATA).
    Internal Named Pipes error. Contact Micro Focus Technical Support.
  • N376: Named Pipe name currently not connected (ERROR_PIPE_NOT_CONNECTED).
    The connection has been broken between the server and the client.
  • N377: Buffer too small for Named Pipe name (ERROR_MORE_DATA).
    The communications packet was larger than the maximum. Check the settings in the XDB Server Configuration utility and in Options.
  • N396: Undocumented Named Pipes error number.
    Internal error. If number = 53, and using Novell NetWare, you must put your server name after NPDAEMON.EXE in your CONFIG.SYS file. You may be starting an OS/2 client against a local OS/2 server (make sure the OS/2 environment variable XDBSERVE is set to LOCAL). Otherwise, contact Micro Focus Technical Support.
Parent topic: N - Network Error Messages


N400 - N449

  • N406: Bad transaction program identifier: identifier.
    The tp_id parameter of the APPC verb is not valid. Either the TP_STARTED verb has failed or the tp_id returned after issuing the TP_STARTED verb was not moved into the current verb control block.
  • N407: Bad conversation identifier: identifier.
    The conv_id parameter used in an APPC verb is invalid. The most likely cause of this error is a failure on the remote system that is severe enough to deallocate the conversation.
  • N408: Bad logical unit alias: alias.
    The local LU alias referenced is not defined. A local LU name in communication manager must be defined with an alias that matches the name of the XDB Server.
  • N409: Allocation failure no retry. Sense code: code.
    A conversation cannot be started due to a permanent error condition requiring intervention. The sense code can be used to isolate the problem.
  • N410: Allocation failure retry. Sense code: code.
    A conversation cannot be started. On a system that has allocated conversations successfully in the past, the error might be recoverable without intervention. The sense code could be used to isolate the problem.
  • N411: Invalid data segment.
    The memory block used to send and receive data is invalid.
  • N412: Bad conversation type parameter.
    The conversation_type APPC verb parameter is invalid. Only basic conversations and mapped conversations are supported.
  • N413: Bad synchronization level parameter.
    The sync_level APPC verb parameter value is invalid. XDB Server uses NONE for DRDA level 1.
  • N414: Bad security parameter.
    The security APPC verb parameter value is invalid. XDB Server uses PGM security.
  • N415: Bad return control parameter.
    The return_control APPC verb parameter value is invalid. XDB Server uses WHEN_SESSION_ALLOCATED.
  • N416: Program initialization parameter length incorrect.
    The pip_data_length APPC parameter value is too large.
  • N417: Use of SNASVCMG or CPSVCMG for mode not allowed.
    The mode names SNASVCMG and CPSVCMG are reserved and should not be used when allocating a conversation.
  • N418: Unknown partner mode/alias:"<".
    The partner LU alias referenced is not defined. A partner LU in communication manager must have an alias that matches the PLU alias name entered when defining a location using XDBGPROF.EXE.
  • N419: Dealloc bad type parameter.
    The type APPC verb parameter value is invalid.
  • N420: Dealloc flush bad state.
    The dealloc APPC verb type parameter value is incorrect for the state of the conversation.
  • N421: Dealloc confirm bad state.
    The dealloc APPC verb type parameter value is incorrect for the state of the conversation.
  • N422: Dealloc not logical length body.
    An incomplete logical record was sent when the dealloc was issued.
  • N423: Dealloc log logical length wrong.
    The log_data_length APPC verb parameter value does not match the LL field.
  • N424: Receive and wait bad state.
    The conversation is not in Receive or Send state.
  • N425: Receive and wait not logical length body.
    An incomplete logical record was sent in Send state when the Receive was issued.
  • N426: Receive and wait bad fill parameter.
    The fill APPC verb parameter value is invalid.
  • N427: Bad return status with data parameter.
    The return_status_with_data APPC verb parameter value is invalid.
  • N428: Bad logical length.
    The Logical record length of the data buffer in invalid. Invalid values are X''0000'', X''0001'', X''8000'', and X''8001''.
  • N429: Send data not in send state.
    An attempt was made to send data when the conversation was in Receive state.
  • N430: Send data invalid type parameter.
    The type APPC verb parameter value is invalid.
  • N431: Send data confirm with synchronization none.
    The type APPC verb parameter value is incorrect for type of the conversation.
  • N432: Send data not logical length body.
    An incomplete record was sent in Send state.
  • N433: Bad type.
    The type APPC verb parameter value is invalid.
  • N434: Undefined transaction program name: name.
    The tp_name referenced was not found. The transaction program must be defined on the host system and match the value configured using XDBGPROF.EXE. When connecting to DB2 using DRDA the tp_name is X07F6C4C2 and the tp runs in the DDF address space.
  • N435: Attach manager already inactive.
    The APPC attach manager is not processing receive_allocate verbs.
  • N436: Allocate not pending.
    A receive_allocate APPC verb was issued and timed out before an incoming allocate request was received.
  • N437: Invalid process.
    A process issued a receive_allocate verb that was not started by the attach manager.
  • N438: Security not valid.
    The partner LU rejected the UserID or password used in the allocate call. Turn on security at the client using the Configuration utility. Make sure the UserID and password are valid for the host environment.
  • N439: Transaction program not available retry.
    The partner LU rejected the allocate call because the transaction program could not be started immediately.
  • N440: Transaction program not available no retry.
    The partner LU rejected the allocate call because the transaction program could not be started.
  • N441: Transaction program name not recognized.
    The partner LU rejected the allocate call because the tp_name was not recognized at the partner location.
  • N442: Program initialization parameter not allowed.
    The partner LU rejected the allocate call because it does not support PIP data or the TP has no PIP variables defined.
  • N443: Program initialization parameter not specified correctly.
    The partner LU rejected the allocate call because the number of PIP variables defined by the local TP does not match the number defined for the remote TP.
  • N444: Conversation type mismatch.
    The partner LU rejected the allocate call because the conversation type of the local TP does not match the conversation type of the remote TP.
  • N445: Synchronization level not supported.
    The sync_level APPC verb parameter value is not supported.
  • N446: Parameter check.
    A verb was issued with an invalid parameter value.
  • N447: State check.
    A verb was issued in a state that was not compatible with the verb.
  • N448: Allocation error.
    APPC failed to allocate a conversation with a remote TP.
  • N449: Dealloc abend.
    The conversation has ended abnormally.
Parent topic: N - Network Error Messages


N450 - N499

  • N450: Dealloc abend program.
    The conversation has ended abnormally and has been cleaned up.
  • N451: Dealloc abend switched virtual circuit.
    The conversation has ended abnormally and has been cleaned up.
  • N452: Dealloc abend timer.
    The conversation has ended abnormally and has been cleaned up.
  • N453: Dealloc normal.
    The conversation has ended normally.
  • N454: Program error no truncation.
    The remote TP has issued a send_error APPC verb.
  • N455: Program error truncation.
    The remote TP has issued a send_error APPC verb and some of the data received locally was truncated.
  • N456: Program error purging.
    The remote TP has issued a send_error APPC verb and some of the data sent to the remote TP was truncated.
  • N457: Conversation failure retry.
    A temporary failure has ended the conversation.
  • N458: Conversation failure no retry.
    A permanent failure has ended the conversation.
  • N459: Switch virtual circuit error no truncation.
    The remote TP has issued a send_error APPC verb.
  • N460: Switch virtual circuit error truncation.
    The remote TP has issued a send_error APPC verb and some of the data received locally was truncated.
  • N461: Switch virtual circuit error purging.
    The remote TP has issued a send_error APPC verb and some of the data sent to the remote TP was truncated.
  • N462: Unsuccessful.
    An APPC verb could not execute.
  • N463: Conversation type mixed.
    The TP has issued both basic and mapped conversation verbs on the same conversation.
  • N464: Transaction program is busy.
    An APPC verb could not execute because Communication Manager is processing another thread.
  • N465: Communication subsystem abended.
    Communication Manager has ended abnormally and will have to be restarted.
  • N466: Communication subsystem is not loaded.
    Either Communications Manager has not been started or it is not properly configured for APPC.
  • N467: Invalid verb segment.
    The verb crosses a segment boundary.
  • N468: Unexpected DOS error.
    An OS/2 system call in Communication Manager has failed unexpectedly.
  • N469: Stack too small.
    APPC has determined that the TP stack size is too small.
  • N476: Security Location Not Configured.
    First, install the Password Expiration Manager (PEM) on the mainframe (see the host installation and configuration instructions). Then, configure access to the remote host PEM software using the Gateway Profile utility. Select location type PEM (APPC) or PEM (TCP).
  • N477: Invalid Host Authorization.
    The AUTHID used to access the host database is not valid. Check your AUTHID and try again.
  • N478: Invalid Host Password.
    The AUTHID is valid, but the password is not. Check your password and try again.
  • N479: Host Authorization Has Expired.
    Your password has expired. See your host system administrator for assistance.
  • N480: Host Authorization Has Been Revoked.
    The AUTHID used to access the host database has been revoked. See your host system administrator for assistance.
  • N486: Nucleus loopback error.
    AS multiple database support problem. Contact Micro Focus Technical Support.
  • N487: AS target not supported.
    AS multiple database support problem.
  • N488: An AS target module failed to load.
    AS multiple database support problem.
  • N489: An AS target module function address was not found.
    AS multiple database support problem.
  • N496: Protocol memory allocation failure.
    Protocol module problem. Contact Micro Focus Technical Support.
  • N497: Transaction identifier is invalid.
    Protocol module problem. Contact Micro Focus Technical Support.
  • N498: Connection identifier is invalid.
    Protocol module problem. Contact Micro Focus Technical Support.
  • N499: Unsupported protocol.
    Protocol module problem.
Parent topic: N - Network Error Messages


N500 - N599

  • N500: A protocol module failed to load.
    Protocol module problem.
  • N501: A protocol module function address was not found.
    Protocol module problem.
  • N506: No available connections.
    In memory module problem.
  • N507: Open semaphore failure.
    In memory module problem.
  • N508: Create semaphore failure.
    In memory module problem.
  • N509: Shared memory failure.
    In memory module problem.
  • N510: Open process failure.
    In memory module problem.
  • N511: Cannot communicate with server.
    The client application cannot establish communications with the specified server. An "accept connection" failure has occurred.
  • N512: Connection is closed.
    In memory module problem.
Parent topic: N - Network Error Messages


PIC - Picture Error Messages

  • PIC000: Error system error: Unknown error errorID.
    The program attempted to display an error that was not found in this error file.
  • PIC001 Syntax error in mask definition.
    The Numeric Format specified in the Options is invalid.
  • PIC002 Grouping character found twice or in illegal position.
    The Numeric Format defined in Options contains two grouping characters (e.g., two commas) or the grouping character is in the wrong position (e.g., after the decimal point).
  • PIC003 No grouping length.
    A serious internal error has occurred in Option's picture parser. Contact Micro Focus Technical Support.
  • PIC004 Decimal character found twice or in illegal position.
    The Numeric Format defined in Options contains two decimal characters (e.g., two decimal points) or the decimal character is in the wrong position (e.g., 99.99,).
  • PIC005 Rounding character in illegal position.
    The Numeric Format defined in Options contains an incorrectly placed rounding character (r). This character, when used, must be the very last character in the picture string (e.g., xxx,9.99+r).
  • PIC006 Illegal character in picture specification.
    A character, other than those allowed, is included in the Date, Time or NumericFormat specified in Options.
  • PIC007 $ character found on both sides of decimal.
    The Numeric Format defined in Options contains a money character (e.g., $) on both sides of the decimal character (e.g., $$$$.$$ is invalid). This character can appear only on the left side of the decimal.
  • PIC008 Sign character found on both sides of the decimal.
    The Numeric Format defined in Options contains a sign character (e.g., +) on both sides of the decimal character (e.g., +$99.99+r is invalid). This character can be placed on the left or the right of the decimal point, but not both.
  • PIC009 Error in substitution portion of picture definition.
    The $=, .=, or ,= clause in the Numeric Format defined in Options is invalid. It may, for example, contain an invalid character or be missing the required delimiters.
  • PIC010 Illegal decimal found in picture.
    The Numeric Format defined in Options contains an invalid decimal sign character. Only a period can be used in the picture portion of a Numeric Format. For example: 999.99 .=',' is valid; 999,99 .=',' is not.
  • PIC011 Illegal rounding character found in picture.
    The Numeric Format defined in Options contains an invalid rounding character. Only an "r" can be used to indicate rounding, and this character must appear at the end of the picture string.
  • PIC012 Illegal dollar sign found in picture.
    The Numeric Format defined in Options contains an invalid money character. Only a dollar sign can be used in the picture portion of the format. For example: $$9.99 .='>=' is valid; >=>=9,99 .='>=' is not.
  • PIC013 Closing single quote not found in substitution string.
    The substitution character string defined in the $=, .=, or ,= clause in the Numeric Format defined in Options does not end with a single quote. For example: $999.99 .$='fl' is valid; $999,99 .='fl is not.
  • PIC014 Value too wide for picture field.
    The numeric value being entered or displayed is larger than the Numeric Format picture defined in Options.
  • PIC015 Error in time/date picture definition.
    The Time Format or the Date Format in Options is incorrectly specified.
  • PIC016: Error trying to identify the picture format type.
    A serious internal error has occurred because the active program received an illegal data type. Contact Micro Focus Technical Support.
  • PIC017 Invalid year value.
    The date value being entered or displayed is inconsistent with the Date Format specified in Options.
  • PIC018 Invalid separator in value.
    The numeric or money value being entered or displayed contains a separator character (e.g., the comma in 1,000) that is inconsistent with the Numeric Format currently specified in Options.
  • PIC019 Invalid character in value.
    A value that is being entered or displayed contains a character that is inconsistent with a picture currently specified in Options.
  • PIC020 Money value error.
    The money value being entered or displayed is inconsistent with the Money Format currently specified in Options.
  • PIC021 Numeric value error.
    The numeric value being entered or displayed is inconsistent with the Numeric Format currently specified in Options.
  • PIC022 Illegal Integer value.
    The integer value that is being entered or displayed is out of range. It contains more digits than specified by the NumericFormat in Options.
  • PIC023 Illegal Time value.
    The time value that is being entered or displayed is inconsistent with the Time Format currently specified in Options.
  • PIC024 Illegal Date value.
    The date value that is being entered or displayed is inconsistent with the Date Format currently specified in Options.
  • PIC025 Scale is bigger than precision.
    The Float Decimal Places value (i.e., scale) specified in Options is larger than the total number of digits allowed for a float value on your system (i.e., precision).
  • PIC026 Invalid separator in time value.
    The time value being entered or displayed contains a separator character (e.g., the colon in 4:00) that is inconsistent with the Time Format currently specified in Options.
  • PIC027 Invalid separator in date value.
    The date value being entered or displayed contains a separator character (e.g., the dash in 03-30-86) that is inconsistent with the Date Format currently specified in Options.
  • PIC028 Invalid separator in timestamp value.
    The timestamp being entered or displayed contains a separator character (e.g., the colon 04:00) that is inconsistent with the Time Format currently specified in Options.
Parent topic: Error Messages


SQL - SQL PL/I Precompiler Error Messages

  • SQL0001S DECLARE syntax error, last token read: token
    A syntax error has occurred in the DECLARE section. Check at or near token to find the problem.
  • SQL0002S identifier too long
    The current identifier is too long to be a valid identifier.
  • SQL0003S engine check error: message
    Error message message is being returned from the engine. Refer to message to determine the problem and its resolution.
  • SQL0004S identifier token not defined
    An identifier is being used that is not defined.
  • SQL0005S host variable used without colon
    The host variable is defined without a colon in the SQL statement.
  • SQL0006S UNION of SELECT INTO is deprecated feature with undefined results
    A UNION SQL statement that contains a SELECT INTO has been detected. This feature is no longer supported and the results are undefined.
  • SQL0101S error creating DBRM file: file
    Cannot create the DBRM file file. Likely reasons are that the file already exists or there is a permissions/sharing problem.
  • SQL0102S error opening input file: file
    Cannot open the input file file. Likely reasons are that the file does not exist or there is a permissions/sharing problem.
  • SQL0103S error creating output file: file
    Cannot create the output file file. Likely reasons are that the file already exists or there is a permissions/sharing problem.
  • SQL0104S error writing DBRM file
    Cannot write to the DBRM file. Likely reasons are that it does not exist or there is a permissions/sharing problem.
  • SQL0105S error reading input file
    Cannot read the input file. Likely reasons are that it does not exist or there is a permissions/sharing problem.
  • SQL0106S error writing output file
    Cannot write to the output file. Likely reasons are that it does not exist or there is a permissions/sharing problem.
  • SQL0107S scope mismatch
    The scope of a variable is ambiguous. Check to make sure only one variable is visible to a section with the same name.
  • SQL0108S end of file before end of quoted string
    A closing quote is missing.
  • SQL0109S end of file before end of comment
    A comment was not closed before the end of the file.
  • SQL0110S token buffer overflow
    The internal buffer for the lexical analyzer is full due to an object being too large.
  • SQL0111S statement buffer overflow
    The internal buffer for statement parsing is full due to a statement being too large to parse.
  • SQL0112S parser stack overflow
    The internal buffer for generic parsing is full due to an object being too large to parse.
  • SQL0113S include file file not found
    Cannot find the include file file in the current program path.
  • SQL0114S host variable error in sqlda
    Sqlda is reporting either too many or too few host variables.
  • SQL0115S illegal host variable marker '?'
    The '?' character cannot be used as a host variable marker.
  • SQL0116S invalid directives: directive
    The directives currently being used are invalid.
  • SQL0117S same name specified for the input file and the output file
    The same name is being used for both the input and output files. Modify the name of one of them.
  • SQL0118S host variable hostvar not found
    The preprocessor could not find the host variable hostvar.
  • SQL0119S declaration stack overflow
    The internal buffer for declaration parsing is full due to a declaration is too large to parse.
  • SQL0120S SQL syntax error, last token read: token
    The SQL Option generic syntax parser found an error in the SQL statement.
  • SQL0121S cursor cursor not declared
    An OPEN, FETCH or CLOSE statement references a cursor name that was not DECLAREd.
  • SQL0122S cursor cursor already declared
    The current cursor cursor has already been declared. Make sure the cursor name is valid and remove or rename it.
  • SQL0123S invalid host variable: hostvar
    Host variables must be valid PL/I identifiers
  • SQL0124S invalid null indicator variable: hostvar
    A null indicator variable must be a 2-byte integer.
  • SQL0125S statement statement not declared
    The current statement statement has not been declared.
  • SQL0126S statement statement already declared
    The current statement statement has already been declared.
  • SQL0127S host variable hostvar ambiguous
    The same variable name is being used twice in the same scope.
Parent topic: Error Messages


WADM - SQLWizard Administrator Error Messages

  • WADM002: Passwords don't match.
    The password you re-entered did not match the one entered previously. Make sure you enter the same password twice.
  • WADM003: You must enter a UserID before entering a password.
    A UserID must be entered before you will be permitted to enter a password. Enter a UserID.
  • WADM004: Expected number record(s), got number.
    Internal error. Contact Micro Focus Technical Support.
  • WADM005: Password must have at least number characters.
    The password you have entered does not meet the length criterion required by the password enforcement level specified in the Configuration utility.
  • WADM006: Password must contain at least one digit.
    Each password entered must contain at least one digit in order to meet the criteria required by the password enforcement level specified in the Configuration utility.
  • WADM007: Password must contain the characters character and character.
    Each password entered must contain the specified characters in order to meet the criteria required by the password enforcement level specified in the Configuration utility.
  • WADM008: Incomplete information retrieved from table name.
    Internal error. Contact Micro Focus Technical Support.
  • WADM009: User userid belongs to unregistered group name.
    According to the SYSXDB.SYSACFMEMBERS table in the SYSTEM location, user userid belongs to group name. However, group name is missing from the SYSXDB.SYSACFGROUPS table. Any group in SYSASCMEMBERS must also be in SYSACFGROUPS. You may remedy this situation by inserting group name into SYSACFGROUPS by selecting the Insert Group option under the Groups menu in XADMIN. Or you can delete group name from SYSACFMEMBERS by running the following interactive SQL command:
  • WADM010: userid is not a registered user.
    The user you are attempting to update or delete does not exist. Add the user, or enter another UserID.
  • WADM011: Unknown table format in table name.
    Internal error. Contact Micro Focus Technical Support.
  • WADM012: No password specified.
    There is no password specified for this user. A password is required in order to add or update this user. Enter a password.
  • WADM013: User userid is already registered.
    The user you have specified already has an entry in the SYSXDB.SYSACFUSERS table. UserIDs must be unique. Enter a new UserID.
  • WADM014: No UserID specified.
    You must specify a UserID in order to add, delete or update the user.
  • WADM016: No User Comment specified.
    You must specify a user comment in order to add or update the user.
  • WADM017: Memory allocated insufficient for the number of groups found.
    Memory allocated insufficient for the number of groups found.
  • WADM018: Group name already exists.
    You have attempted to create a new group using a group authorization ID that already exists in the SYSXDB.SYSACFGROUPS table. Group auth-IDs must be unique.
  • WADM019: No Group Authorization ID specified.
    You have attempted to add, update, or delete a group but did not specify a group authorization ID. The auth-ID is required to identify the group.
  • WADM020: Group name does not exist.
    You have attempted to delete or update a group, but no group was found in the SYSXDB.SYSACFGROUPS table whose authorization ID matches the one you entered.
  • WADM022: name is not a valid group name.
    The group name you have entered is not a valid database object name. See the SQLWizard online help for the allowable syntax for database object names.
  • WADM023: The priority name does not exist.
    You must enter an existing priority in order to update or delete.
  • WADM027: The User ID entered is invalid.
    The User ID should conform to Ordinary Identifiers. See the SQL Reference for more details.
  • WADM028: Valid range for value value is > 0 and < number.
    One of the governor values was out of the legal range. Enter a valid value.
  • WADM029: name is not a valid priority name.
    The priority name you have entered is not valid.
  • WADM030: No Priority Name specified.
    You must specify a priority in order to add, delete or update a priority.
  • WADM031: Priority name already exists.
    You have attempted to create a new priority using a priority that already exists in the SYSXDB.SYSGOVERNOR table. Priorities must be unique.
  • WADM032: An error occurred while updating an internal list (name).
    Internal error. Contact Micro Focus Technical Support.
  • WADM033: The SecondaryID name is invalid.
    The SecondaryID should conform to Ordinary Identifiers. See the SQL Reference for more details.
  • WADM034: Cannot delete yourself ('name') as a User.
    You are currently logged in as user 'name', so it is not possible to delete 'name' as a user.
Parent topic: Error Messages


WCRT - SQL Wizard Create/Alter Table Error Messages

  • WCRT000: Error system error: Unknown error error id.
    SQLWizard attempted to display an error that was not found in the XCRT.XRR error file.
  • WCRT001: Illegal identifier identifier specified for object Name. Last symbol read was symbol.
    An invalid name was specified for the object of type object-type. SQLWizard was only able to validate the name up to the symbol symbol.
  • WCRT004: The data type and/or length of column col1 does not match that of primary key column col2.
    When specifying the foreign key columns of a relationship, you must choose those that match both in data type and length to that of its corresponding primary key column. Check the data type and length of both the foreign key and primary key column to be sure they match.
  • WCRT005: No columns specified for the object.
    Make sure you choose columns for the index or relationship definition. If you are specifying an index, make sure you specify column names in the Index Columns list. If you are specifying a relationship, make sure a foreign key column is specified for each primary key column in the list.
  • WCRT006: Identifier identifier exceeds its maximum length of length for object-type name.
    The identifier specified exceeded its maximum limit of length for an object of type object-type. Enter a shorter name and try again.
  • WCRT007: Incomplete table specification. No object specified.
    A table was incompletely defined. Enter a valid value for the missing item.
  • WCRT008: Referenced table table does not contain a primary key.
    When choosing a referenced table for a relationship, be sure to choose a table that contains a primary key.
  • WCRT009: The index index does not exist for the table table.
    An index with the name index-name was not found in the system catalog for the table table-name.
  • WCRT010: The location name does not exist.
    A location with the name location-name was not found in the SYSXDB.SYSLOCALS catalog table.
  • WCRT011: The synonym/alias name does not exist in the database.
    A synonym/alias with the name name was not found in the system catalog.
  • WCRT012: Incomplete location specification. No object specified.
    A location was incompletely defined. Enter a valid value for the missing item.
  • WCRT013: No name specified for field # fieldnum.
    A field was specified without a name. Specify a valid name for the field.
  • WCRT014: No data type specified for field # fieldnum.
    A field was specified without a data type. Choose a data type from the drop-down list provided in the Data Type entry field.
  • WCRT015: No length specified for field # fieldnum.
    A field was specified without a length. Specify a valid length for the field. Some data types (e.g. Smallint, Integer, Float, Date, Time, etc.) have a fixed length and do not require a length to be entered. Others (e.g. Decimal, Char, Varchar, Graphic, & Vargraphic) require a length to be specified.
  • WCRT016: No column with a matching type found.
    An attempt was made to move a foreign key column to a new position within the Foreign Key Cols -> Referenced Key Cols list. However, no referenced column with a matching data type and length was found in the direction you tried to move. Remember that foreign key columns and referenced key columns must match in data type and length.
  • WCRT017: No foreign key name specified.
    Specify a valid foreign key name and try again.
  • WCRT018: No index name specified.
    Specify a valid index name and try again.
  • WCRT019: No alias name specified.
    Specify a valid alias name and try again.
  • WCRT020: No synonym name specified.
    Specify a valid synonym name and try again.
  • WCRT021: Cannot undo the Drop designation for this primary key index due to the existence of another primary key specification.
    An attempt was made to remove a Drop designation for a primary key index. However, another primary key index has been specified for this table. Since allowing this operation would yield more than one primary key for the table, and only one is allowed per table, this is illegal.
  • WCRT022: No referenced table specified for the relationship.
    The relationship specification is incomplete. Specify a referenced table to complete the specification. Be sure that this referenced table contains a primary key.
  • WCRT023: object name name is already defined for this table.
    An object of type object-type with the name name has already been specified for this table. Choose another name and try again.
  • WCRT024: Location specified in Alias Name.
    There is no need to qualify the alias name with a location, as the location may be chosen from the list. Please enter a one-part (i.e. alias name alone) or a two-part name (i.e. sqlid.alias-name), and specify the locations from the list.
  • WCRT025: No target location(s) specified for the Alias.
    When creating an alias you must specify at least one location where it is to be created. Choose locations from the Target Locations Not Selected list to move over to the Target Locations Selected list.
  • WCRT026: Index creator. index-name already exists in location location.
    All indexes must have unique names within a location. The index name specified already exists in the SYSIBM.SYSINDEXES catalog table for the particular location. Choose another name.
  • WCRT027: Table/View/Synonym/Alias creator. name already exists in location location.
    All tables/views/synonyms/aliases must have unique names within a location. The name specified already exists in the system catalog tables for that particular location. Choose another name.
  • WCRT028: Location name already exists.
    XDB Server locations must be given unique names. The location name specified already exists in the SYSXDB.SYSLOCALS catalog table. Choose another name.
  • WCRT029: Cannot alter/drop table with over number columns using this method.
    This error should not occur under normal circumstances. If you receive this error, please contact Micro Focus Technical Support.
  • WCRT030: The directory directory-name does not exist.
    The directory directory-name does not exist. You have to create this directory before you proceed with the creation of the location.
  • WCRT031: Log cannot be forwarded to a directory-name. It appears to be used by a different location.
    Specify a directory that is not already in use by another location and try again.
  • WCRT032: Invalid format for directory directory-name.
    Specify a valid directory name and try again.
  • WCRT033: Illegal null permission for field Field specified.
    Global temporary tables cannot contain "unique" or "with default" fields.
  • WCRT034: You cannot alter a Global Temporary Table.
    You have tried to alter a global temporary table. This is not allowed.
  • WCRT035: You can not alter a table that contains a distinct type
    An attempt was made to alter a table with a distinct data type. This is not allowed.
  • WCRT036: Altering a table that contains a BLOB column is not supported
    An attempt was made to alter a table with a BLOB column. This is not supported.
Parent topic: Error Messages


WDG - SQL Wizard Declaration Generator Error Messages

  • WDG001: name is not a legal table name.
    The table name you have entered is invalid. Select a valid table name.
  • WDG005: Unknown field type in table tablename.
    An illegal field type was specified in the table named.
  • WDG008: name is not a legal language name.
    The target language you have entered is invalid. Valid language names are COBOL, PL/I and C. Enter a valid name.
  • WDG010: Illegal computational value.
    The computation value must be > 0 and < 10.
  • WDG015: Error number spawning editor name.
    This error is not used. May be used in future versions.
  • WDG016: Accessing file name.
    The Declaration Generator cannot access the specified file. Please make sure that it exists and is not locked by any other user.
  • WDG017: Invalid location name nameerrortype.
    The specified location does not exist. Please select an existing location.
  • WDG018: No filename on command line.
    The Declaration Generator was run in batch mode with no batch filename on the command line. Please reissue the batch command with a legal batch filename.
  • WDG019: No table on command line.
    The Declaration Generator was run in batch mode with no batch filename or table name on the command line. Please reissue the batch command with a legal batch filename or a table name on the command line.
  • WDG020: Invalid option on command line.
    The Declaration Generator was run in batch mode with an illegal parameter on the command line. Please check you parameters.
  • WDG021: No filename on command line.
    The Declaration Generator was run in batch mode with no batch filename or output file name on the command line. Please reissue the batch command with a legal output filename on the command line.
  • WDG022: Can't create batch file.
    The Declaration Generator cannot create the selected file to contain a batch file. Make sure that the path exists and the destination file is not read only or locked by another user.
  • WDG023: No table name.
    No table name was specified. There is nothing to do.
  • WDG024: No filename.
    No output filename was specified. Declaration Generator needs to know where to put the output.
  • WDG025: No structure name.
    No output structure name was specified. Declaration Generator needs to know the name of the output structure.
  • WDG026: Error updating the status bar.
    Internal error. Declaration Generator could not display a message on its status bar. Please note what operation was being performed and contact Micro Focus Technical Support.
Parent topic: Error Messages


WE - SQL Wizard Export Error Messages

  • WE000 - WE049
    Lists the SQL Wizard Export error messages from WE000 through WE049.
  • WE050 - WE099
    Lists the SQL Wizard Export error messages from WE050 through WE099.
  • WE100 - WE149
    Lists the SQL Wizard Export error messages from WE100 through WE149.
Parent topic: Error Messages


WE000 - WE049

  • WE001: Unable to create document window, XVT error error.
    An error occurred while attempting to create a child window. You may be low on resources. Try unloading some programs, or closing other child windows. If you are still having problems, please contact Micro Focus Technical Support.
  • WE002: No query exists on the query screen.
    An internal error has occurred. Please contact Micro Focus Technical Support.
  • WE003: Index is damaged.
    An internal error has occurred. Please contact Micro Focus Technical Support.
  • WE004: Unable to query auth-id.SYSTABLES to get information about item.
    An internal error has occurred. Please contact Micro Focus Technical Support.
  • WE005: Invalid value value for APPEND_ERR_FILE command in group number, groupname.
    The batch file command APPEND_ERR_FILE can only take the values "y" or "n".
  • WE006: No translation table exists with specified INCCSID and OUTCCSID.
    There is no record in the SYSIBM.SYSSTRINGS table whose values in the INCCSID and OUTCCSID fields match the numbers found in XDB.INI. If you are exporting in the DSNTIAUL format, check InCCSID and OutCCSID in the [Export] section of XDB.INI. If you are exporting in a different format, check AscSrcCodePage and AscDstCodePage.
  • WE007: Unable to add field name name to Included list.
    The system was unable to add the specified name to the name of columns that are to be included in the current export specification. You may be out of memory.
  • WE008: Cannot open file filename.
    Couldn't open the specified file.
  • WE009: No more Export windows can be created.
    You have created the maximum allowable number of Export windows. The maximum is 10. To create a new window you must close an existing window.
  • WE010: Table table is empty.
    No data can be exported because the table specified is empty.
  • WE011: Invalid value value for TIMESTAMP command in group number, groupname.
    The batch file command TIMESTAMP can only take the values "y" or "n".
  • WE012: Invalid field type specified for field fieldname.
    An illegal field type was specified for the field named. Check the documentation for a list of valid field types.
  • WE013: Unable to retrieve field information.
    An error occurred when attempting to retrieve field information from a batch specification.
  • WE014: Batch Export file file-name not found.
    Select a batch export file that exists.
  • WE015: Keyboard navigation error.
    An error occurred when trying to resolve the next/previous object in the keyboard navigation list. Contact Micro Focus Technical Support.
  • WE016: No fields in table specification.
    The export cannot proceed because there are no fields in the 'Included' listbox on the screen.
  • WE017: Internal error getting text from screen. Contact Micro Focus Technical Support.
    The system could not process an entry on the screen. Contact Micro Focus Technical Support.
  • WE018: Internal error opening table window. Contact Micro Focus Technical Support.
    The system was unable to open the export specification. Contact Micro Focus Technical Support.
  • WE019: Internal error opening query window. Contact Micro Focus Technical Support.
    The system was unable to open the export specification.
  • WE020: Batch Export file file-name does not contain a group heading
    The first line of a batch export file must be a group heading.
  • WE024: Query result does not contain any records.
    The current query does not retrieve any rows, so there is nothing to export. Check the WHERE condition to make certain it is correct.
  • WE025: Data file filename is empty.
    The file you wish to view does not contain any data.
  • WE026: Float value in field fieldname is larger than the IBM370 limit.
    The float value is not supported by IBM370.
  • WE027: Data exceeds 4K page size.
    The size of a record in the table you are exporting is greater than 4K. When exporting to the DSNTIAUL format, each record must fit within a 4K page size. If the record contains one or more columns of type LONG VARCHAR, the data in those columns is truncated if possible to make the record fit into 4K. However, if the other column lengths are large enough, this won't reduce the size sufficiently.
  • WE028: No output filename specified.
    You have not specified a filename for your export file.
  • WE030: Invalid output file specification filename.
    The file name specified is not a valid file specification.
  • WE031: Invalid table name.
    You have entered a table name that does not satisfy table-naming criterion. In general, names must begin with a letter, can contain letters and digits, and the characters # $ % & _ { } in XDB mode or @ # $ _ in DB2 mode.
  • WE032: No table name specified.
    You have not specified the name of the table you wish to export. The table name is required when exporting and when saving an export specification to a batch export or batch import file.
  • WE033: Error writing to file filename.
    It was not possible to write to the specified DSNTIAUL file. Your hard disk may be full.
  • WE034: Can't display a join of multiple tables on Export's Design screen.
    You cannot switch to the Design view because the current query contains multiple tables in the FROM clause.
  • WE035: Field fieldname specified in query does not exist in table tablename.
    You have specified a field that is not found in the table named in the FROM clause.
  • WE036: Invalid query.
    The query was not recognized as a valid SQL statement.
  • WE037: Invalid record delimiter delimiter.
    When specifying a delimiter using decimal notation, use the format <nnn>, where nnn is an integer between 0 and 255. The record delimiter for standard ASCII files is a carriage-return followed by a line-feed, as indicated by the default <013><010>. SQLWizard allows you to specify an alternate end-of-record delimiter to handle other file structures.
  • WE038: Invalid field delimiter delimiter.
    When specifying a delimiter using decimal notation, use the format <nnn>, where nnn is an integer between 0 and 255. When selecting a field delimiter, be sure you do not use a character found in your data or in the default masks for the data types in the exported table. For example, do not use a comma as the delimiter if your data contains numeric or money values grouped with a comma.
  • WE039: Invalid value for number of spaces between fields.
    The number of spaces between fields should be an integer from 0 to 99.
  • WE040: Batch file filename is invalid.
    The specified batch file is not a valid batch export file.
  • WE041: Batch file contains more than one transaction.
    Export cannot display a batch file that contains more than one transaction.
  • WE042: Error opening log file filename.
    An attempt to open the specified log file failed.
  • WE043: Invalid error log file name filename.
    The specified name is an invalid file name for the underlying operating system. Check your operating system documentation for a description of valid file names.
  • WE044: Invalid ON_ERROR value value.
    The ON_ERROR value must be PROMPT, CONTINUE, QUIT, or END_ALL.
  • WE045: Invalid batch file name filename.
    The specified file name is not a valid file name for your operating system. See your operating system documentation for a description of valid file names.
  • WE046: Invalid data file name filename.
    The specified file name is not a valid file name for your operating system. See your operating system documentation for a description of valid file names.
  • WE048: Invalid value for DSETPASS.
    The value must be a valid database object name. In general, names must begin with a letter, can contain letters and digits, and the characters # $ % & _ { } in XDB mode or @ # $ _ in DB2 mode.
  • WE049: Invalid STOGROUP name.
    STOGROUP names must follow the rules for short identifiers. The STOGROUP used is invalid.
Parent topic: WE - SQL Wizard Export Error Messages


WE050 - WE099

  • WE050: PRIQTY value must be an integer in the range 12 to 4,194,304.
    See the CREATE INDEX command description in the SQL Reference for information on the correct parameters.
  • WE051: SECQTY value must be an integer in the range 0 to 131,068.
    See the CREATE INDEX command description in the SQL Reference for information on the correct parameters.
  • WE052: FREEPAGE value must be an integer in the range 0 to 255.
    See the CREATE INDEX command description in the SQL Reference for information on the correct parameters.
  • WE053: PCTFREE value must be an integer in the range 0 to 99.
    See the CREATE INDEX command description in the SQL Reference for information on the correct parameters.
  • WE054: No tables found with authid auth-id in location location-name.
    See the CREATE INDEX command description in the SQL Reference for information on the correct parameters.
  • WE055: Invalid DATABASE name.
    Database names must follow the rules for short identifiers. The database name used is invalid.
  • WE056: Invalid TABLESPACE name.
    Tablespace names must follow the rules for long identifiers. The Tablespace used is invalid.
  • WE057: Invalid EDITPROC name.
    EDITPROC names must follow the rules for short identifiers. The name used is invalid.
  • WE058: Invalid VALIDPROC name.
    VALIDPROC names must follow the rules for short identifiers. The name used is invalid.
  • WE059: Internal error reading batch file.
    The system was unable to read the batch file. Check to make sure the file is a valid Export batch script.
  • WE060: Unable to access code page information.
    The system encountered an error when attempting to access the specified code page. Make sure that the code page has been defined in SYSTEM.SYSIBM.SYSSTRINGS, and that it has been correctly specified in the batch script.
  • WE061: Invalid error log file name file-name specified in batch file.
    The specified name is an invalid filename for the underlying operating system. Check your operating system documentation for a description of valid filenames.
  • WE062: Float value in field fieldname is smaller than the IBM370 limit.
    The float value is not supported by IBM370.
  • WE063: Unable to open View Batch window, probably out of memory.
    The system tried to open the view window, but was unable to do so. Try closing down other SQLWizard windows, or other applications that are using system resources.
  • WE064: Unable to open View Data window, probably out of memory.
    The system tried to open the view window, but was unable to do so. Try closing down other SQLWizard windows, or other applications that are using system resources.
  • WE065: Unrecognized value value for SQL_OPTS command in group number, groupname.
    Export found an illegal setting in the batch file. The syntax of this command is:
  • WE066: Invalid value value for ASCII_CODEPAGE in group number, groupname.
    Export found an error in the current batch export file. The syntax of this command is:
  • WE067: Invalid value value for EBCDIC_CODEPAGE in group number, groupname.
    Export found an error in the current batch export file. The syntax of this command is:
  • WE068: Invalid value value for FORMAT command in group number, groupname.
    Export found an error in the current batch export file. The syntax of this command is:
  • WE069: Batch file filename is empty.
    The specified file does not contain any batch specifications.
  • WE070: Unknown batch command command in group number, groupname.
    The batch export file contains invalid or unknown commands.
  • WE071: Invalid value value for FLD_DELIMITER command in group number, groupname.
    The syntax of this command is:
  • WE072: Invalid value value for REC_DELIMITER command in group number, groupname.
    The syntax of this command is:
  • WE073: Invalid value value for HEADING command in group number, groupname.
    The syntax of this command is:
  • WE074: Invalid value value for FILENAME command in group number, groupname.
    The syntax of this command is:
  • WE075: Invalid value value for TABLE command in group number, groupname.
    The syntax of this command is:
  • WE076: Invalid value value for PAGE_SIZE command in group number, groupname.
    The syntax of this command is:
  • WE077: Invalid value value for FIELDS command in group number, groupname.
    The syntax of this command is:
  • WE078: Invalid value value for QUOTES command in group number, groupname.
    The syntax of this command is:
  • WE079: Invalid value value for SPACES command in group number, groupname.
    The syntax of this command is:
  • WE080: Unable to get information about fields in table tablename.
    The system failed in an attempt to get information about the columns in the specified table. Make sure you have privileges on the catalog tables or views, and that the SYSIBM and SYSXDB items in the SQL page of the Options are set to the correct AuthID values.
  • WE081: Invalid value value for REPLACE command in group number, groupname.
    The syntax of this command is:
  • WE082: Invalid value value for DATABASE command in group number, groupname.
    The value must be a valid database object name. In general, names must begin with a letter, can contain letters and digits, and the characters # $ % & _ { } in XDB mode or @ # $ _ in DB2 mode.
  • WE083: Invalid value value for TABLESPACE command in group number, groupname.
    The value must be a valid database object name. In general, names must begin with a letter, can contain letters and digits, and the characters # $ % & _ { } in XDB mode or @ # $ _ in DB2 mode.
  • WE084: Invalid value value for EDITPROC command in group number, groupname.
    The value must be a valid database object name. In general, names must begin with a letter, can contain letters and digits, and the characters # $ % & _ { } in XDB mode or @ # $ _ in DB2 mode.
  • WE085: Invalid value value for VALIDPROC command in group number, groupname.
    The value must be a valid database object name. In general, names must begin with a letter, can contain letters and digits, and the characters # $ % & _ { } in XDB mode or @ # $ _ in DB2 mode.
  • WE086: Invalid value value for AUDIT command in group number, groupname.
    AUDIT value must be one of NONE, CHANGES or ALL.
  • WE087: Invalid value value for VCAT command in group number, groupname.
    VCAT value must be one of WITH, ROOT, PATH or NAME.
  • WE088: Invalid value value for STOGROUP command in group number, groupname.
    The value must be a valid database object name. In general, names must begin with a letter, can contain letters and digits, and the characters # $ % & _ { } in XDB mode or @ # $ _ in DB2 mode.
  • WE089: Invalid value value for PRIQTY command in group number, groupname.
    PRIQTY value must be a number from 0 to 4,194,309.
  • WE090: Invalid value value for SECQTY command in group number, groupname.
    SECQTY value must be a number from 0 to 131,068.
  • WE091: Invalid value value for ERASE command in group number, groupname.
    ERASE value must be either Y or N.
  • WE092: Invalid value value for FREEPAGE command in group number, groupname.
    FREEPAGE value must be a number from 0 to 255.
  • WE093: Invalid value value for PCTFREE command in group number, groupname.
    PCTFREE value must be a number from 0 to 99.
  • WE094: Invalid value value for DUPQTY command in group number, groupname.
    DUPQTY value must be either 8, 16, 32, 64 or 128.
  • WE095: Invalid value value for CLUSTER command in group number, groupname.
    CLUSTER value must either Y or N.
  • WE096: Invalid value value for SUBPAGES command in group number, groupname.
    SUBPAGES value must be either 1, 2, 4, 8 or 16.
  • WE097: Invalid value value for BUFFERPOOL command in group number, groupname.
    BUFFERPOOL value must be in one of the following formats:
  • WE098: Invalid value value for DSETPASS command in group number, groupname.
    The value must be a valid database object name. In general, names must begin with a letter, can contain letters and digits, and the characters # $ % & _ { } in XDB mode or @ # $ _ in DB2 mode.
  • WE099: Invalid value value for CLOSE command in group number, groupname.
    CLOSE value must be either Y or N.
Parent topic: WE - SQL Wizard Export Error Messages


WE100 - WE149

  • WE100: Invalid value value for DEFER command in group number, groupname.
    DEFER value must be either Y or N.
  • WE101: Error opening batch file for writing.
    Unable to open file for writing import or export specifications.
  • WE102: Error writing to batch file.
    Unable to write import or export specifications to current batch file.
  • WE103: Invalid value value for SRC_ASCII_CODEPAGE command in group number, groupname.
    Codepage must be a positive integer or 0.
  • WE104: Invalid value value for DST_ASCII_CODEPAGE command in group number, groupname.
    Codepage must be a positive integer or 0.
  • WE105: Warning: No translation table matches the default ASCII source and destination codepages pagenopageno in XDB.INI.
    The values in XDB.INI in the [Export] section for AscSrcCodePage and AscDstCodePage do not correspond to the INCCSID and OUTCCSID values of any record in SYSTEM.SYSIBM.SYSSTRINGS.
  • WE106: Invalid Where clause.
    The WHERE condition specified in the Export window is invalid. Check it for syntax errors.
  • WE107: Export to SQL can't export a query that contains more than one table.
    There is more than one table specified in the FROM clause of your Export query statement. This is not allowed when you are exporting to SQL Statements. In SQL mode, edit the FROM clause so that it contains a single table name, or change to another export format.
  • WE108: Query doesn't start with SELECT.
    The Export query statement doesn't begin with the SELECT keyword. In SQL mode, edit the statement so that it begins with the word SELECT. Make sure that it forms a valid query statement.
  • WE109: Export doesn't understand the query. Last symbol read was symbol.
    SQLWizard could not interpret the SELECT statement in the Export window. Check it for syntax errors. Symbol indicates where the error occurred. See the SQL Reference for a description of the SELECT statement syntax.
  • WE110: Query contains a string that is too long for Export to process.
    The SELECT statement in the Export window contains a name (e.g., field name, table name) that is too long. Names exceeding 1024 characters cannot be processed by Export.
  • WE112: Internal error getting For Bit Data info. Contact Micro Focus Technical Support.
    Export has experienced an internal error while processing the SELECT statement. Contact Micro Focus Technical Support.
  • WE113: Internal error getting Nullable info. Contact Micro Focus Technical Support.
    Export has experienced an internal error while processing the SELECT statement. Contact Micro Focus Technical Support.
  • WE114: Invalid record delimiter – escape character character is not allowed.
    The escape character specified on the SQL tab of Options cannot be used as a record delimiter.
  • WE115: Invalid field delimiter – escape character character is not allowed.
    The escape character specified on the SQL tab of Options cannot be used as a field delimiter.
Parent topic: WE - SQL Wizard Export Error Messages


WI - SQL Wizard Import Error Messages

  • WI000 - WI049
    Lists the SQL Wizard Import error messages from WI000 through WI049.
  • WI050 - WI099
    Lists the SQL Wizard Import error messages from WI050 through WI099.
  • WI100 - WI149
    Lists the SQL Wizard Export error messages from WI100 through WI149.
Parent topic: Error Messages


WI000 - WI049

  • WI001: Premature end of line found, record record.
    Encountered an unexpected end of line on the record specified.
  • WI002: Number field(s) were found in record number; record should contain number field(s).
    A record containing the wrong number of fields exists in the file you are importing. Check the record in your source file (record n) and make sure that it has the same number of fields as the target table.
  • WI003: The character character in position position in heading line of Fixed ASCII file filename is not allowed in a column name.
    A field name in your fixed-ASCII data file contains a character that is not permitted in a database object name. See your SQL Reference for a list of characters that can be used in a column name.
  • WI004: The maximum number of open Import windows has been reached.
    You have opened the maximum number of Import windows. Close some of the Import windows before you continue.
  • WI005: Table name is not specified.
    You must provide a table name for the target table.
  • WI007: Invalid value number for varchar length; length must be no greater than number.
    The length of a varchar field is greater than the page size set for each record.
  • WI008: No translation table exists with specified INCCSID and OUTCCSID.
    There is no record in the SYSIBM.SYSSTRINGS table whose values in the INCCSID and OUTCCSID fields match the numbers found in XDB.INI. If you are importing in the DSNTIAUL format, check InCCSID and OutCCSID in the [Import] section of XDB.INI. If you are importing in a different format, check AscSrcCodePage and AscDstCodePage.
  • WI009: Keyboard navigation error.
    Internal error. Contact Micro Focus Technical Support.
  • WI010: Invalid value value for DSN_CRLF command in group number, groupname.
    The batch file command DSN_CRLF can only take the values "y" or "n".
  • WI011: No source file name specified.
    You must enter the full pathname of the data file you want to import in the File Name edit box of the Source File Information area.
  • WI012: Unable to open Grid window.
    An internal error is preventing SQLWizard from creating the table area in the Import window. This may be caused by insufficient memory. Close any unnecessary applications, then retry the Import command. If this does not resolve the problem, clear memory by restarting SQLWizard or by rebooting.
  • WI013: Data in field fieldname of record record-name is number characters long but field definition inumber characters.
    The data found in a character field in the source file is longer than the length of that field in the target table.
  • WI014: End-of-line delimiter delimiter not found while counting fields in record.
    The current record in your free format ASCII file does not contain the Field Delimiter specified on the screen.
  • WI015: Invalid value value for APPEND_ERR_FILE command in group number, groupname.
    The batch file command APPEND_ERR_FILE can only take the values "y" or "n".
  • WI016: Invalid value value for APPEND_REC_FILE command in group number, groupname.
    The batch file command APPEND_REC_FILE can only take the values "y" or "n".
  • WI017: DSNTIAUL file file-name does not contain a complete record.
    A record in the DSN file contains a record with size that is smaller than the record size in the destination table.
  • WI018: Invalid value value for TIMESTAMP command in group number, groupname.
    The batch file command TIMESTAMP can only take the values "y" or "n".
  • WI019: Batch import file file-name not found.
    Select a batch import file that exists.
  • WI020: Batch Import file filename does not contain a group heading.
    The first line of a batch import file has to be a group heading.
  • WI021: Record number contains more than the maximum of number fields, or end of record not found.
    Import has detected more fields in the current record than are specified in the table definition. Either your data file contains extra fields in this record, or the record delimiter is missing from this record, causing Import to interpret the data in the next record as part of the data for this record.
  • WI022: Table name is not specified in group number, groupname.
    No value was assigned to the batch file command TABLE.
  • WI023: Error writing to logfile filename, errno = error-number.
    The attempt to write to the specified log file failed. Check your operating system documentation for the meaning of the error specified by the errno value.
  • WI024: Error opening logfile filename.
    An attempt to open the specified log file failed. Either it does not exist or is in use.
  • WI025: End quote missing in field fieldname, record record of data file filename.
    A quote is missing from a character field in a free format ASCII file.
  • WI026: Data exceeds 4K page size.
    The size of a record in a DSNTIAUL file must be no greater than 4096 bytes.
  • WI027: Length specification missing from Char, Varchar, Graphic, or, VarGraphic data type, line line-number.
    Specify these types in the following format:
  • WI029: Number fields were specified, but number fields were found in file.
    There are more fields in the fixed-ASCII source file than there are in the target table. Check the source file to make sure that the length of its records matches that of your destination table.
  • WI030: Unable to open file filename.
    Either the file was not found in the indicated directory, is in use, or is invalid. Check to be sure that you have specified the correct file name and directory.
  • WI031: More field names were found than the number of fields specified.
    The number of fields specified for your table is less than the number of fields found in your data file.
  • WI034: Field name for field number, fieldname, is longer than number characters.
    Field names may not be longer than number characters.
  • WI035: Incorrect field type type in ConvertDataStrToInternal().
    Internal error. Call Micro Focus Technical Support.
  • WI036: Invalid field delimiter delimiter.
    When specifying a delimiter using decimal notation, use the format <nnn>, where nnn is an integer between 0 and 255. See your SQLWizard User's Guide for further information on entering delimiters.
  • WI037: Invalid record delimiter delimiter.
    When specifying a delimiter using decimal notation, use the format <nnn>, where nnn is an integer between 0 and 255.
  • WI038: Invalid source file name filename.
    See your operating system documentation for an explanation of valid file names.
  • WI039: Invalid table name.
    See your documentation for an explanation of valid table names. Also see WSQL045.
  • WI040: Invalid value for number of spaces between fields.
    The number of spaces between fields should be an integer from 0 to 99.
  • WI041: Data file filename is empty.
    It is not possible to import the specified data file, as it contains no data.
  • WI044: Invalid character (character) found in field name in field number in header line of data file.
    An illegal column name was found in the source file. See the SQL Reference for rules for identifiers for XDB Server and DB2. Also see WSQL045.
  • WI047: Invalid length in type specification type, field number.
    The length in the specified field is invalid for the field type.
  • WI048: Invalid length in Character or Varchar type specification type, field number.
    Character and Varchar lengths must be no longer than 4048.
  • WI049: Invalid length in Graphic type specification type, field number.
    Graphic length must be no longer than 127.
Parent topic: WI - SQL Wizard Import Error Messages


WI050 - WI099

  • WI050: Invalid length in Vargraphic type specification type, field number.
    Vargraphic length must be no longer than 2028.
  • WI051: Batch file contains more than one transaction.
    SQLWizard cannot create an Import window for a batch file that contains more than one transaction.
  • WI052: Batch file filename is invalid.
    The file does not exist, or the file is not a valid Batch Import file.
  • WI054: Can't get info from fixed ASCII file that doesn't contain a header line.
    You must provide a complete specification for the ASCII file, since the system is unable to use a header line to help build a specification.
  • WI055: Error opening table file filename.
    Import in Local Direct Write mode encountered an error when trying to open the file specified. The file may not exist, you may not have privileges on the file or on the path, or the file may be in use.
  • WI057: Error writing to table file filename.
    Import in Local Direct Write mode encountered an error when trying to write to an underlying table file directly. Make certain that the table file can be accessed from the client machine.
  • WI058: Can't access table file filename, probably locked by the XDB Server.
    The table file may already be in use by the database server. You must have exclusive use of the file in order to proceed.
  • WI059: Invalid error log file name filename.
    The file name is not a valid file name.
  • WI060: Invalid record log file name filename.
    The file name is not a valid file name.
  • WI063: Invalid error log file name filename specified in batch file filename.
    The file name is not a valid file name for the underlying operating system. Check your operating system documentation for valid filename format.
  • WI064: Invalid record log file name filename specified in batch file filename.
    The file name is not a valid file name for the underlying operating system. Check your operating system documentation for valid file name format.
  • WI065: Unable to access code page information.
    You have specified a translation table to use for DSNTIAUL EBCDIC-to-ASCII conversion, or non-DSNTIAUL ASCII-to-ASCII conversion. However, Import was unable to load the translation from the system table SYSIBM.SYSSTRINGS.
  • WI066: Number of records to recalculate must be an integer from 0 to 4,294,967,296.
    The number you specified is not in range.
  • WI067: Commit interval must be an integer from 0 to 4,294,967,296.
    The number you specified is not in range.
  • WI069: Quotes missing around character value string.
    You have specified that character values are enclosed in quotes, but the specified character value is not quoted.
  • WI071: Float value in field number, fieldname of record number is larger than IBM370's limit.
    The float value is not supported by IBM370.
  • WI072: Float value in field number, fieldname of record number is smaller than IBM370's limit.
    The float value is not supported by IBM370.
  • WI073: Unable to open View Batch window, probably out of memory.
    Check system resources. Close down other SQLWizard windows, or other applications to free resources.
  • WI074: Unable to open View Data window, probably out of memory.
    Check system resources. Close down other SQLWizard windows, or other applications to free resources.
  • WI077: Internal error reading batch file.
    An error occurred when trying to read the batch file. It is most likely a memory allocation error.
  • WI078: Invalid value value for PAGE_SIZE command in group number, groupname.
    The syntax of this command is:
  • WI079: Invalid value string for FORMAT command in group number, groupname.
    Valid formats are FREASC, FIXASC, and DSNTIAUL.
  • WI080: Can't import into a non-XDB Server location using Engine Direct Write
    Engine Direct Write mode is only supported against XDB Server locations.
  • WI082: Data file filename does not contain any data.
    The file appears to be empty.
  • WI083: Invalid value value for ASCII_CODEPAGE command in group number, groupname.
    This must be a positive integer or 0.
  • WI084: Invalid value value for EBCDIC_CODEPAGE command in group number, groupname.
    This must be a positive integer or 0.
  • WI085: Invalid value value for FLD_DELIMITER command in group number, groupname.
    The syntax of the FLD_DELIMITER command is:
  • WI086: Invalid value value for REC_DELIMITER command in group number, groupname.
    The syntax of the REC_DELIMITER command is:
  • WI087: Invalid value value for HEADING command in group number, groupname.
    The correct syntax of this command is:
  • WI088: Invalid value value in position number for EBCDIC_TO_ASCII command in group number, groupname.
    The syntax of this command is:
  • WI089: Invalid value value in position number for SRC_LENS command in group number, groupname.
    The syntax of this command is:
  • WI090: Invalid value value in position number for OFFSETS command in group number, groupname.
    The syntax of this command is:
  • WI091: Invalid value value for SPACES command in group number, groupname.
    The syntax of this command is:
  • WI092: Invalid value value for QUOTES command in group number, groupname.
    The syntax of this command is:
  • WI093: Invalid value value for REPLACE command in group number, groupname.
    The syntax of this command is:
  • WI094: Invalid value value for INSERT_MODE command in group number, groupname.
    The syntax of this command is:
  • WI095: Invalid value value in position number for NULL_PERM command in group number, groupname.
    The syntax of this command is:
  • WI096: Invalid value value in position number for USE_PIC command in group number, groupname.
    The syntax of this command is:
  • WI097: Invalid value value in position number for TYPES command in group number, groupname.
    The syntax of this command is:
  • WI098: Invalid value value in position n for FIELDS command in group number, groupname.
    The syntax of this command is:
  • WI099: Invalid value value for TABLE command in group number, groupname.
    The syntax of this command is:
Parent topic: WI - SQL Wizard Import Error Messages


WI100 - WI149

  • WI100: Invalid value value for FILENAME command in group number, groupname.
    The syntax of this command is:
  • WI101: Invalid value value for ON_ERROR command in group number, groupname.
    The syntax of this command is:
  • WI102: Invalid value value for COMMIT_INTERVAL command in group number, groupname.
    The syntax of this command is:
  • WI103: The number of values for the FIELDS command in group number, groupname does not match the number of fields found in a previous command.
    The number of items in all of the field-list commands must be consistent.
  • WI104: The number of values for the TYPES command in group number, groupname does not match the number of fields found in a previous command.
    The number of items in all of the field-list commands must be consistent.
  • WI105: The number of values for the USE_PIC command in group number, groupname does not match the number of fields found in a previous command.
    The number of items in all of the field-list commands must be consistent.
  • WI106: The number of values for the NULL_PERM command in group number, groupname does not match the number of fields found in a previous command.
    The number of items in all of the field-list commands must be consistent.
  • WI107: The number of values for the OFFSETS command in group number, groupname does not match the number of fields found in a previous command.
    The number of items in all of the field-list commands must be consistent.
  • WI108: The number of values for the SRC_LENS command in group number, groupname does not match the number of fields found in a previous command.
    The number of items in all of the field-list commands must be consistent.
  • WI109: The number of values for the EBCDIC_TO_ASCII command in group number, groupname does not match the number of fields found in a previous command.
    The number of items in all of the field-list commands must be consistent.
  • WI110: Batch file filename is empty.
    The file does not contain any batch import specifications.
  • WI111: Unknown batch command command in group number, groupname.
    There are invalid commands in the batch file. See your SQLWizard User's Guide for valid batch commands.
  • WI112: Short float value in field number, fieldname of record number is larger than IBM370's limit.
    Float value not supported for IBM370.
  • WI113: Short float value in field number, fieldname of record number is smaller than IBM370's limit.
    Float value not supported for IBM370.
  • WI115: Error opening batch file for writing.
    There is not enough memory to create the internal structure required to write an Import specification file (an IMP file). Close any unnecessary applications, then retry the operation. If this does not resolve the problem, clear memory by restarting SQLWizard or by rebooting.
  • WI116: Error writing to batch file.
    An error has occurred while writing an Import specification file (an IMP file). Check that nothing is preventing a file from being written. For example, check that the drive is operational and that it has sufficient space. Also check that the file is not write protected.
  • WI117: Invalid value value for SRC_ASCII_CODEPAGE command in group Tnumber, Tname.
    The value assigned to a SRC_ASCII_CODEPAGE statement in your Import specification file (IMP file) is incorrect. It must be a positive integer. The error is located in the transaction represented by Tnumber (e.g., Tnumber 1 is the first transaction in the IMP file) and Tname (Tname is the bracketed string at the top of each transaction). Allowed values are listed in the SQLWizard User's Guide.
  • WI118: Invalid value value for DST_ASCII_CODEPAGE command in group Tnumber, Tname.
    The value assigned to a DST_ASCII_CODEPAGE statement in your Import specification file (IMP file) is incorrect. It must be a positive integer. The error is located in the transaction represented by Tnumber (e.g., Tnumber 1 is the first transaction in the IMP file) and Tname (Tname is the bracketed string at the top of each transaction). Allowed values are listed in the SQLWizard User's Guide.
  • WI119: Invalid batch file name filename.
    An invalid file name has been given to an Import specification file (IMP file). If you are saving an IMP file, check that you have typed a name allowed by your operating system. If you are running a batch import from the command line, verify that a valid IMP filename was entered on the command line. See your SQLWizard User's Guide for command line syntax.
  • WI121: Can't import data file filename into table tablename because data file has number columns but table has number columns.
    The source file and the target table in your Import operation do not have the same number of fields. If you are running a batch import, verify that the TABLE statement in the IMP file is set to the correct target table. Also verify that the FIELDS, TYPES, NULL_PERM, SRC_LENS, OFFSETS, USE_PIC and EBCDIC_TO_ASCII statements in your IMP file reflect the actual number of columns in your source and destination. See your SQLWizard User's Guide for a complete description of the IMP file and its contents.
  • WI122: Batch specification in group Tnumber, Tname in file filename is not sufficient to create new table tablename.
    A TYPES and/or FIELDS statement for this transaction was not found in the Import specification file (IMP file). The error is located in the transaction represented by Tnumber (e.g., Tnumber 1 is the first transaction in the IMP file) and Tname (Tname is the bracketed string at the top of each transaction). Edit your IMP file and enter the missing statement(s). See your SQLWizard User's Guide for a complete description of the IMP file and its contents.
  • WI123: Table tablename contains number columns but batch file specifies number columns.
    The target table specified in the Import specification file (IMP file) doesn't contain the same number of fields as the source file. Verify that the TABLE statement in the IMP file is set to the correct target table. Also verify that the FIELDS, TYPES, NULL_PERM, SRC_LENS, OFFSETS, USE_PIC and EBCDIC_TO_ASCII statements in your IMP file reflect the actual number of columns in your source and destination. See your SQLWizard User's Guide for a complete description of the IMP file and its contents.
  • WI124: Invalid value Value for varchar length. Length must be no greater than page size Size.
    The import process has been terminated because the DSNTIAUL file you are importing contains a varchar value that exceeds the current page size.
  • WI125: Invalid record delimiter - escape character character is not allowed.
    The escape character specified on the SQL tab of Options cannot be used as a record delimiter.
  • WI126: Invalid field delimiter – escape character character is not allowed.
    The escape character specified on the SQL tab of the Options utility cannot be used as a field delimiter.
Parent topic: WI - SQL Wizard Import Error Messages


WSQL - SQL Wizard Interactive SQL Error Messages

  • WSQL001: XDB Engine is not loaded.
    The system was unable to load the SQL Engine. Make certain that you have correctly installed and configured SQL RDBMS (or the equivalent) or that you have installed the correct network redirector.
  • WSQL002: Error allocating memory.
    An attempt was made to allocate a block of memory, but that attempt failed. Try removing other programs from memory, and then repeat the task. Try saving your work and exiting from SQLWizard, and then reload it. If the operating system is using a temporary PAGEFILE, make sure there is at least 2MB of free disk space. If attempts to increase available resources fail, contact Micro Focus Technical Support.
  • WSQL003: Error opening file filename.
    An attempt was made to open the file named, but it failed. This usually occurs if the file could not be found. Check that the file exists, and that you have privileges to access it. Make sure the file is not in use by another application. Check to be sure there is enough disk space available, and that the target directory is a valid path.
  • WSQL004: Error creating name window.
    The system was unable to create the window, probably because resources (such as memory) are low. Close down some windows (or other applications) and try again. See WSQL002.
  • WSQL005: Error creating name dialog.
    The system was unable to create the dialog, probably because resources (such as memory) are low. Close down some windows (or other applications) and try again. See WSQL002.
  • WSQL006: Error creating name text editor.
    The system was unable to create the window, or open the specified application. Close down some windows (or other applications) and try again.
  • WSQL007: Error adding line to text editor.
    The system could not add additional text to the current edit control. System resources may be low. Try freeing resources by closing unnecessary programs.
  • WSQL008: Prohibit Cartesian products.
    The system has been set to prohibit Cartesian products. The query you are trying to run has been evaluated as a Cartesian product, and cannot be executed unless you turn off the Prohibit Cartesian Products option through the Query|Current Query Options dialog.
  • WSQL009: Query result cannot be edited.
    The current query result has been evaluated as a non-editable result, and therefore the system cannot switch to edit mode. Reasons for a query to be evaluated as non-editable are that it is/contains a: a) Join b) Union c) GROUP BY clause d) HAVING clause e) Expression or it accesses a read-only view.
  • WSQL010: Error executing menu.
    An error occurred when trying to process the last menu command.
  • WSQL011: Printing failed.
    An error occurred when attempting to print. Check the print manager for additional information.
  • WSQL012: Cannot list windows.
    The system was unable to list the currently open windows.
  • WSQL013: Too many windows.
    The system cannot open another window. Try closing down some of the currently open child windows.
  • WSQL014: Window does not have METRICS data.
    Unable to process window commands.
  • WSQL015: Incomplete line in string.
    Incomplete line in string.
  • WSQL016: No default value in string.
    No default value in string.
  • WSQL017: Prompted number number is out of range, should be 1-100.
    An SQL statement references a variable &n where n is not between 1 and 100. Modify the SQL statement to change &n so that n is within the acceptable range, or change &n to a host variable in the form :hv.
  • WSQL018: Error adding item to prompted list.
    An error occurred attempting to add an item to the prompted query design list. Contact Micro Focus Technical Support.
  • WSQL019: Cannot find the prompted number number.
    An error occurred trying to specify or rebuild a prompted query design. The table SYSXDB.SYSPROMPTQUERY may be damaged or has been incorrectly edited.
  • WSQL020: Invalid characters in string.
    There are illegal characters in the string shown. Correct and try again.
  • WSQL021: Cannot find query.
    The system was unable to find the query in SYSXDB.SYSQUERY or SYSXDB.SYSPROMPTQUERY. You may have entered the name incorrectly. The query may have been deleted from the query catalog, or there may be an error reading the catalog tables.
  • WSQL022: Argument is NULL.
    A required argument is NULL. Correct and try again.
  • WSQL023: Cannot open temporary file.
    The system was unable to open a temporary file. Check whether you have privileges to read and write on the temporary path, and that there is enough disk space to write the file.
  • WSQL024: Cannot create temporary file.
    The system was unable to write a temporary file. Check whether you have privileges to read and write on the temporary path, and that there is enough disk space to write the file.
  • WSQL025: You must have a valid connection to use all of SQLWizard's options.
    If you cannot connect to the database engine, you will not be able to access SQLWizard. This error sometimes occurs when you have not connected properly to a remote database server.
  • WSQL026: Invalid entry in field fieldname.
    An attempt was made to enter invalid data in the named field. Modify the data to match the data type.
  • WSQL027: Window does not have METRICS data.
    Unable to process window commands.
  • WSQL028: Cannot open query.
    The system was unable to open a query in SYSXDB.SYSQUERY or SYSXDB.SYSPROMPTQUERY. The query may have been partially deleted from the query catalog, or there may be an error reading the catalog tables.
  • WSQL029: Error running batch SQL.
    The system encountered an error in trying to process a batch SQL script.
  • WSQL030: No such Query.
    The system was unable to find the query in SYSXDB.SYSQUERY or SYSXDB.SYSPROMPTQUERY. You may have entered the name incorrectly. The query may have been deleted from the query catalog, or there may be an error reading the catalog tables.
  • WSQL031: No column needs order by.
    There are no unsorted columns in the query. Use the Query|Sort option if you want to remove some columns from the query. You cannot sort by a column that is not selected if you are in DB2 mode (this is a restriction of DB2).
  • WSQL032: Cannot create toolbar.
    The system failed in an attempt to create the toolbar. Check whether resources are low.
  • WSQL033: Error saving file filename.
    An error occurred when trying to save the named file. Make certain the path is valid, the file name is valid, that there is enough space for the file, or that the file does not already exist and is locked by another application.
  • WSQL034: Error seeking file.
    A file could not be found. A seek error occurred when trying to locate it. Make certain the file specification is correct, and that the file exists.
  • WSQL035: Error seeking query.
    A query could not be found. You can query the SYSXDB.SYSQUERY table to see if the query exists in the location that you are querying. You may need to make the location where the query exists the current location.
  • WSQL036: Cannot find table name.
    A table by the specified name could not be found.
  • WSQL037: Cannot paste table name.
    The system was unable to paste a table name into the current context.
  • WSQL038: Cannot open init file.
    The system was unable to open one or more initialization files. Run Options to check XDB.INI. Check the command line of XWIZ40N.EXE for the INI file in use.
  • WSQL039: Cannot paste query.
    An attempt was made to paste an SQL statement into a Query Design window, or to paste a Query Design into an SQL Edit window. Try using the Open button to open the query. Change to SQL view if necessary, and copy the query, then paste to the target SQL Edit window.
  • WSQL040: The editor is read-only.
    You cannot edit or paste into the current edit field.
  • WSQL041: Cannot open a synonym under a different location or AuthID.
    Synonyms can only be accessed from the location in which they are created. Make the synonym location your current location before attempting to open the synonym.
  • WSQL042: Error in querying SYSACFUSERS.
    The system encountered an error when attempting to retrieve information on users from the system catalog. This error occurs if you have not been granted privileges against the system catalog tables. You will be allowed to continue if you receive this error, but you will be connected as a regular user, not a super user.
  • WSQL043: Cannot access SYSIBM tables using AuthID authid.
    This error occurs if you attempt to start SQLWizard when you have not been granted privileges for the system catalog tables.
  • WSQL044: Cannot access SYSXDB tables using AuthID authid.
    This error normally occurs if the current user does not have select privileges on the SYSXDB catalog tables, or on the equivalent views. Check the SYSXDB setting in the Options SQL page to see what AuthID the system is trying to use for SYSXDB catalog views, and contact your administrator to see if you have select privileges on the views created with this AuthID. If you do not, have the administrator grant you the privileges you need to access the catalog tables. If the SYSXDB.SYSQUERY table does not exist, you may see this error. You will still be allowed to access SQLWizard, but you may not be able to list or save queries in the catalog tables. You should still be able to save and run queries in SQL script files.
  • WSQL045: Name name is invalid.
    The name shown is not a valid name based on the current SQL mode, or the system requirements. In general, names must begin with a letter, can contain letters and digits, and the characters # $ % & _ { } in XDB mode or @ # $ _ in DB2 mode.
  • WSQL046: Cannot save query. Please check if disk is full.
    Something is preventing SQLWizard from saving this query.
  • WSQL047: The query has been corrupted.
    SQLWizard cannot open the selected query because it contains corrupt data. This might happen if the SYSPROMPTQUERY table was edited directly.
  • WSQL049: SELECT error. May not have privileges.
    SQLWizard cannot complete this task because you do not have privileges to the specified object.
  • WSQL050: Cannot edit tables with renamed columns.
    You are attempting to edit a table that contains a renamed column. This is not allowed. This error would occur, for example, if you attempted to edit the result of the following query (which changes the name of the e_no column to xemp):
  • WSQL051: Batch error in command number number.
    SQLWizard has encountered an error while processing a batch SQL script.
  • WSQL052: End of statement delimiter not found.
    SQLWizard could not find an end of statement delimiter.
  • WSQL053: Filters yield no results. Filters are reset.
    The filter value entered for the immediate sub-item (database, or AuthID) beneath the location level returns an empty result set. The Catalog Browser display will be refreshed using the latest valid set of filter values stored in XDB.INI.
  • WSQL054: Cannot display result set containing a LOB field.
    The result set contains a Large Object (LOB), which is not displayable.
  • WSQL055: Invalid value, terminator_character, specified for TERMINATOR.
    The SQL terminator character specified in a --#SET TERMINATOR statement is invalid. The following characters are not allowed to be a SQL terminator: blank, comma, double quote, left parenthesis, right parenthesis, single quote, and underscore.
Parent topic: Error Messages


X - Engine Error Messages

  • X000 - X049
    Lists the Engine error messages from X000 through X049.
  • X050 - X099
    Lists the Engine error messages from X050 through X099.
  • X100 - X149
    Lists the Engine error messages from X100 through X149.
  • X150 - X199
    Lists the Engine error messages from X150 through X199.
  • X200 - X249
    Lists the Engine error messages from X200 through X249.
  • X250 - X299
    Lists the Engine error messages from X250 through X299.
  • X300 - X349
    Lists the Engine error messages from X300 through X349.
  • X350 - X399
    Lists the Engine error messages from X350 through X399.
  • X400 - X449
    Lists the Engine error messages from X400 through X449.
Parent topic: Error Messages


X000 - X049

  • X001: Cannot perform operation (errornum) on file filename.
    An attempt to close/open/read/write/seek on the file specified failed. File mode may conflict. Device may be full or damaged, or file may not exist. Also, make sure that your temporary path is set to an existing path.
  • X002: Empty query string.
    An attempt was made to execute a command that was discovered to be an empty string. You may have accidentally pressed an execute option before issuing a command. You may have used an empty (NULL) string as the input for a PREPARE command, or for an xcommand() or xprepare() function.
  • X003: INI Error errmsg
    The error message returned can be any of the messages listed under Possible Error Messages below. Each possible error message is followed by a typical XDBNET.INI file error that could have caused the error message. The following notation definitions apply for each possible error message:
  • X004: Number value overflow.
    An attempt was made to place a value that is too large or too small into a numeric field (float, int, smallint, etc.). See XDB Server Specifications in the SQL Reference for maximum and minimum values permitted in numeric data types. Check picture specifications.
  • X005: Date value error.
    An attempt was made to place an illegal date in a date field or attempt to perform date arithmetic on an invalid date. XDB Server performs leap year checking, and verifies that month and day are correct. Check picture specifications.
  • X006: String constant too long.
    String constants selected in a query may be up to 4056 characters long. Varchar and long varchar columns can be longer, so you could store a longer value in a table and retrieve it.
  • X007: Incomplete string. Check for missing quotes.
    A quote without a matching quote was found in a command sent to the SQL Engine. You may use either single or double quotes around character strings. If a single quote is to appear within a string, surround the string with double quotes. For example:
  • X008: Version number incompatibility in user exit file.
    The structure being returned by the user exit procedure procedure is incompatible with this version. Contact your system administrator.
  • X009: Illegal field name name.
    A reference was made to a field that does not exist in the table specified by a command. If using a precompiler to catch an error at precompile time, then add VALIDATE directive in XDBCOB.DIR file. Make sure that all fields are defined in the declaration.
  • X010: No more RAM memory available.
    Insufficient memory (RAM) was available to execute a command sent to the SQL Engine. Try running the application from outside the main menu or application menu to see if that gives you enough memory to continue.
  • X011: Type mismatch within expression.
    A data type conflict occurred within an expression. For example, you may have attempted to perform date arithmetic with a character string.
  • X012: Type mismatch while doing comparison.
    An attempt was made to compare two incompatible data types. Numeric types may be compared to other numeric types (including, for example, money and numeric results of date arithmetic or string functions); dates can only be compared to dates, character strings to character strings, times to times.
  • X013: Order by clause invalid on singleton select statement.
    An embedded SQL singleton select might not contain an older BY clause. The statement should be modified to use the OPEN CURSOR construct.
  • X014: Set location can only be used for local locations.
    The system was unable to locate a table or view in the relational directory (.DDT file), or the table/view is not found in the referenced query control block. In order to add a table or view to the relational directory you must create it using the CREATE command. You can copy tables from one location to another using the COPY command. To include a table or view in a query control block, you must include it in the FROM clause of a query.
  • X015: Attempt to close an unopened location directory.
    An attempt was made to close a location directory that was not open at the time. Check for subroutines that close the location, or logout of subprograms.
  • X016: Undefined query identifier or location not open.
    An attempt was made to access a query control block that does not exist, or to run a command against an unopened location. This error condition may occur if you prematurely close a query or (if using an application programming interface) if you forget to open the location. Also a subroutine may have logged out, automatically closing the location.
  • X017: Illegal record position.
    An attempt was made to access a record at a location outside the result of the query. Typically this occurs when using the application programming interface function xdirect() to move the cursor to a record that does not exist in the current table. To find the position of a record, use the xgetpos() function. It is possible that the record has been modified since the position was saved and re-execution of the query did not include the record in the new result set.
  • X018: Duplicate value in unique index name.
    An attempt was made to insert a duplicate value in a field on which a unique index or primary key exists. Possible fixes: Check for a rollback file (.RB extension) and delete it; Delete all indices and rebuild them; Check if the data is wrapped; Delete all files from temporary storage before transferring new data to the storage area.
  • X019: Query too long.
    The system was unable to allocate enough space to process the query. XDB Server uses dynamic allocation for this task, so the length of query permitted depends on the amount of memory available. Reduce the length of the query, or remove unnecessary programs from memory and try again. See X010 and X050.
  • X020: Syntax error. Last symbol read was string.
    The SQL Engine was unable to parse a command it was sent. When this error occurs, the system tries to display the last token it read. Check the command syntax in the SQL Reference. Make sure that all products are using the same character set (ASCII, EBCDIC, etc.). If using the COBOL, look in the errmc element of the SQLCA structure for the error tokens. SQLCA errd[4] contains the column position of the token. In CAPI, call the function xgeterr() to get the error tokens.
  • X021: Pathname too long.
    XDB Server accepts paths of up to 48 characters.
  • X022: Too many queries open at same time.
    There is no room to open additional query control blocks. A user may open up to 50 queries at one time. The actual number of queries open at one time depends on the complexity of the queries. Try rewriting your program so that it is not necessary to hold so many queries open at the same time. In server versions, use the XDB Server Configuration utility to increase the number of available query control blanks.
  • X023: Length of value exceeds length of destination.
    An attempt was made to place a value in a field too small to accommodate it.
  • X024: Index Name has been damaged.
    The index specified cannot be used by the system. You must drop the index and rebuild it before continuing. NOTE: If you compact a table with deleted records or use the AND INDEX clause, all indices are automatically rebuilt for you.
  • X025: Incomplete comment.
    Comments sent to the SQL Engine should begin with the characters /* and end with the characters */. The system found one comment marker, but not the other.
  • X026: Exceeds max number of tables/views permitted in query.
    You may access up to 15 tables or views per FROM clause; the limit depends on the complexity of the query, as well as the number of expressions and multi-table views involved. In addition, the number of queries already open may impact on the number of tables allowed in a query.
  • X027: Maximum of number connected client nodes has been exceeded.
    The XDB Server cannot process your connection request because the maximum number of licensed users is already attached to the server.
  • X028: Cannot find table/view/synonym name.
    The table, view, or synonym specified does not have a readable entry in the database directory. You may have entered an incorrect table name, or be in the incorrect database. The database directory (.DD? file) may have been damaged or overwritten. You cannot simply copy a .TAB file to a database directory and then access it through XDB Server. You must use the CREATE or COPY commands to create a table or move a table between databases.
  • X029: Invalid hex constant.
    The XDB Server cannot execute the current statement because it contains an invalid hex constant. For example, a closing quote may be missing, or the hex value may contain an invalid character.
  • X030: Invalid field number.
    A low level CAPI function call (e.g. Xdbxgetrec or Xdbxputrec) to access a field failed; the specified field number does not exist in the query.
  • X031: Cannot truncate log file.
    Unable to truncate the backward log file; cannot COMMIT or ROLLBACK. Check access privileges on the drive containing the database. Run operating system program CHKDSK on the database drive. Use Options to turn the Backward Log OFF.
  • X032: Lock Conflict.
    Two or more users are accessing the same object.
  • X033: Column name is ambiguous.
    If the column specified is ambiguous, then you must reference it by a two-part column name (i.e., table/view.column).
  • X034: Illegal correlation name name.
    A query references a correlation name not specified in the FROM clause.
  • X035: Length of input host variable number number is invalid.
    The length of the specified host variable is too long or too short.
  • X036: Default specification for field name is invalid.
    An unexpected internal error occurred when accessing the defined default value for column name.
  • X037: Invalid timeout specification.
    Timeout specification should be an integer greater than 0 and less than 32,767.
  • X038: Cannot acquire read/write access on specified path.
    Unable to read or write any files on a path the system has tried to access as result of a command you issued. If using a network file server, check the current user's privileges. If using a multiuser system, make sure another user is not accessing the file.
  • X039: Abort code.
    The system aborted the current operation upon receipt of an abort code. When you press Esc in most environments, programs send an abort code to the SQL Engine, instructing it to terminate the transaction it is currently processing for you. A partial result may be displayed in some modules. Incomplete transactions involving updates, inserts or deletes are rolled back if the backward log is turned on. You can specify the abort characters through Options.
  • X040: Log system couldn't operation.
    An operation in the log system has failed.
  • X041: Left side of expression incompatible with right side.
    The system is unable to compare the left hand side of an expression to the right hand side of the expression. This is generally due to incompatible data types (e.g. comparing a time field to a date field).
  • X042: Field type not compatible with nested query results.
    The field type of a nested query result is not compatible with the field type it is being compared to.
  • X043: Aggregate function on invalid type.
    An attempt was made to find a numeric aggregate function result for a non-numeric field (e.g. AVG of a character field.)
  • X044: Invalid data type indicator.
    The SQL Engine received an invalid data type indicator from the calling program. This problem is generally due to a programming error in user programs that use one of the language interfaces. Refer to interface documentation for valid data type indicators.
  • X045: Invalid element in structure structure in function function.
    The values structure in CAPI function Xdbxputrec() contains invalid information. Length may be out of range, or type may be invalid.
  • X046: Illegal number of fields specified for compound index.
    An attempt was made to create an index on more than 64 columns.
  • X047: Index name too long.
    An index name is currently limited to 18 characters in length, except when using mainframe syntax.
  • X048: Index name already exists.
    An attempt was made to create an index with the same name as an existing index in the current database. You can view index names in the current database using the query:
  • X049: Duplicate name name in create index list.
    A field name can appear only once in a CREATE INDEX statement. When creating foreign keys, a field name can appear only once in the indexed field list of a referenced table, and only once in the indexed field list of the referencing table.
  • X050: No more RAM available to REDIRECTOR.
    The network redirector (network communications) was unable to allocate the necessary memory required (either for packet transmission or reception).
Parent topic: X - Engine Error Messages


X050 - X099

  • X051: Duplicate key value when creating unique index indexname.
    Unable to create unique index because a value appears more than once in the column(s).
  • X052: Cannot update field to incompatible type.
    An attempt was made to update a field using an incompatible value. Check the field types of the table you are updating.
  • X053: String length is larger than field length.
    An attempt was made to insert a character string into a field too short to hold it. Check to see if you are using DB2 compatibility.
  • X054: Unequal number of fields and values.
    When inserting a record, an attempt was made to insert more values than the table has fields. If you supply too few values, the system automatically places NULL values in the other fields.
  • X055: Duplicate names name in insert/alter/create list.
    A field name appears more than once in an INSERT, ALTER, or CREATE command.
  • X056: Table/View name already exists.
    All tables and views in a database must have unique names. To obtain a list of the tables or views in a database, you can perform the query:
  • X057: Specified more fields or values than the table has.
    The number of values listed in an INSERT command exceeds the number of fields in the table named.
  • X058: Field name type incompatible with type type.
    Unable to perform a command because the type of the field named is incompatible with the type displayed (e.g. a time field is incompatible with a date field for comparison operations).
  • X059: Inserting character constant larger than field length specified.
    A character string in an INSERT command values list is longer than the target character field. Value is truncated.
  • X060: value is outside allowable field length boundary.
    See the SQL Reference for description of data type ranges.
  • X061: number is greater than maximum allowable number of fields.
    Tables are limited to 750 fields.
  • X062: Value value is too large to insert into field name.
    Unable to insert the value into the field specified, because it is larger or longer than maximum value permitted.
  • X063: Index name not found.
    Reference was made to an index not found in the current database. For a list of the currently active indices in the current database, execute the query:
  • X064: Not a proper command or command not implemented.
    An attempt was made to execute a command that is not a valid XDB Server or SQL command, or to execute a command that is not yet implemented.
  • X065: Illegal field name name in order specification.
    A field or column in an ORDER BY clause was not selected in the SELECT clause of the query, or does not exist in the table.
  • X066: Illegal number number in order/group specification.
    There is no matching column number for a column number listed in the ORDER BY or GROUP BY clause of the query.
  • X067: Aggregates not allowed in WHERE clause of query.
    XDB Server does not permit an aggregate function in the WHERE clause of a query. Aggregate functions should appear in a HAVING clause if used as a selection criterion.
  • X068: Selecting an expression with a GROUP BY clause.
    XDB Server does not permit use of expressions (other than aggregate functions) in a query having a GROUP BY clause unless you include the expression in the GROUP BY clause using its column number.
  • X069: Too many set clauses in update command.
    There are more SET clauses in the UPDATE command than there are fields in the table being updated.
  • X070: Ordering by field name that is not selected.
    In DB2 mode, the ORDER BY clause must specify one of the fields in the SELECT clause.
  • X071: Selecting more than one item in a nested query.
    The SELECT clause of a subquery can consist of only one column. If you want to select more than one field, try concatenating the fields using the XCONCAT function.
  • X072: Cannot nest aggregate functions.
    Aggregate functions cannot be nested one inside the other. For example, you cannot select:
  • X073: Fields selected must appear in GROUP BY clause or inside an aggregate function.
    If a query selects an aggregate function, any field appearing outside the aggregate function in the SELECT clause must also appear in the GROUP BY clause of the query. This is a common cause of confusion; although users may think they do not want to group a result by a particular column, they often find that adding the column name to the end of the GROUP BY clause yields the desired result.
  • X074: GROUP BY clause invalid on current query.
    A GROUP BY clause can only be used if the SELECT clause of the query includes one or more column names, or one or more aggregate functions (such as COUNT, and AVG.)
  • X075: Cannot mix fields with aggregates without GROUP BY.
    If a query selects an aggregate function, any field appearing outside the aggregate function in the SELECT clause must also appear in a GROUP BY clause.
  • X076: Luname servername does not exist in tablename SYSLUNAMES table.
    You are inbound/outbound mapping to or from a server name that does not exist in SYSLUNAMES. Insert a record for that server name in the SYSLUNAMES table or insert a dummy generic record with blanks.
  • X077: Cannot include join in table expansion.
    PREVIOUS clause cannot be used on a join.
  • X078: Illegal level value for table expansion.
    LEVEL clause specifies a non-positive or non-integer level, or a level beyond the maximum recursive relationship level.
  • X079: Insert/Delete/Update function not allowed on sorted query.
    You cannot perform a positioned update/insert/delete on a query that requires sorting. Queries that may require sorting are those involving ORDER BY, GROUP BY, DISTINCT, and UNION.
  • X080: Only one DISTINCT clause allowed per query.
    XDB Server only allows one DISTINCT clause per query. For example, you cannot:
  • X081: Exceeds maximum number of UNIONed queries.
    A maximum of 32 subselects may be connected by the UNION operator (i.e. UNION should appear no more than 31 times in a command).
  • X082: Each query in a UNION must have the same number of projected fields.
    The number and type of columns selected in subselects connected with the UNION operator must match exactly.
  • X083: Data types in column name do not match.
    When performing a UNION, the data types of each column in one subselect must be type compatible with the corresponding column in all UNIONed subselects.
  • X084: ORDER BY items must be constants for union of queries.
    When the UNION operator and the ORDER BY clause appear in the same query, the ORDER BY criteria must use column numbers instead of column names.
  • X085: ORDER BY must follow all queries when performing a union.
    The ORDER BY clause should be the last clause in any query containing a UNION operator.
  • X086: NULL not allowed in field name.
    An illegal attempt was made to place a NULL in the field named. The field is specified as NOT NULL. You can obtain information on NULL permission from the SYSCOLUMNS table.
  • X087: Table/View name exceeds maximum length of number.
    Table, view and synonym names are limited to the number of characters shown. Some compatibility modes allow longer table names than others.
  • X088: Field name length exceeds maximum length of number characters.
    Table names are limited to the number of characters shown. Some compatibility modes allow longer field names than others.
  • X089: Cannot open location on path. Check location path setting.
    The system is unable to find or open the location-name.DDT or location-name.DDF files on the path specified. These files contain essential information on location table and field specifications. Check whether there is a location in the path specified. Check whether there is more than one set of .DDT or .DDF files in your location directory. Check to see if the location name matches the location name in the SYSXDB.SYSLOCALS table. Verify whether the path is accessible by the program accessing the location. For example, in multi-user, use the drive specifier.
  • X090: Too many users registered.
    The number of users registered is equal to the maximum number of users permitted to register at one time.
  • X091: User has no privilege privilege on objectname.
    The current user has not been granted the privilege to perform the operation attempted on the table, view or database shown. For a listing of privileges available to a user, query the SYSTABAUTH and SYSDBAUTH tables.
  • X092: User account has been disabled.
    The user name has been deactivated. See your database administrator, who can enable the user account.
  • X093: Unknown user name.
    The user name entered is not found in the system, because it has not been registered on the system. See your database administrator. Query the SYSXDB.SYSACFUSERS table in the system location for a list of valid user names.
  • X094: User userid cannot GRANT/REVOKE on table/view/database name.
    User has no authority to grant or revoke privileges on the database, table or view named. For a list of privileges available to a user, query the SYSTABAUTH and SYSDBAUTH tables.
  • X095: Invalid receipt. (Should register first.)
    User did not obtain a valid process ID before entering a module. Exit to the operating system and try reentering the program. In extreme cases you may need to unload the SQL Engine, or in multi-user environments, kill a user session.
  • X096: Illegal password.
    Password does not match password saved for the user name entered. Repeated attempts to log on with an incorrect password will cause this program to abort. If you have forgotten your password, see your database administrator.
  • X097: Illegal attempt to open more than one location.
    XDB Server permits a user to access only one location at a time. This error condition occurs when a programmer attempts to call the C API Xdbxopen() function before closing the current location.
  • X098: Cannot grant a privilege to yourself.
    A user is not permitted to grant a privilege to him/herself. The privilege must be granted by another user possessing sufficient authority to do so.
  • X099: User already exists.
    A user with the same user name is already entered in the SYSXDB.SYSACFUSERS table. User names must be unique.
Parent topic: X - Engine Error Messages


X100 - X149

  • X100: Memory Resident Engine not loaded!
    XDB client-side software could not communicate with the XDB Server. Check to make sure that the XDB Server is up. If it is up and listening on the appropriate communications protocol, contact Micro Focus Technical Support.
  • X101: Illegal function code passed to engine.
    Programmer attempted to call the SQL Engine with an illegal function code. Refer to your Application Programming Interface documentation for valid function codes. Another possible cause for this error could be that you are inadvertently trying to access the wrong engine. This can occur if you have been working with a single-user engine on your own computer and then switch to using a multi-user XDB Server.
  • X102: Cannot find view name.
    Unable to find the view named in the SYSVIEWS table, or in the system directory files.
  • X103: Must select aggregates if using HAVING clause with no GROUP BY.
    A HAVING clause can only appear in a query that selects only aggregate functions, or that has a GROUP BY clause.
  • X104: A password is required for connection with LU servername.
    You are trying to connect to a server name that doesn't trust you. You need a password to be connected.
  • X105: Operation not allowed on view name.
    XDB Server cannot perform the operation attempted on the view named. For example, multi-table views are not currently updateable.
  • X106: No translation row in tablename SYSUSERNAMES for LU servername.
    You are trying to do inbound/outbound mapping without specifying a translation row to the AuthID in SYSUSERNAMES.
  • X107: Current AuthID can't be used to reference remote object.
    The XDB Server cannot execute the requested operation because the specified AuthID is not valid for the remote location.
  • X108: Field list must be provided when expressions are selected.
    The SELECT clause of commands that define views can contain expressions only if the resulting columns are explicitly named. For example:
  • X110: Cannot operation logfile filename. Check logpath setting.
    An operation on the logfile named filename has failed. Check the log path in the SYSXDB.SYSLOCALS table to see if it is pointing to the correct directory. Also check to see that there is still disk space left for writing the file.
  • X111: Maximum number records per table in trial version.
    You are running the SQL Engine shipped with Learn, which limits the number of records in tables. The record limit includes deleted records that have not been removed using COMPACT. If you need to add more records to the table you must have a full version of XDB Server.
  • X112: Cannot perform operation (errno) on index index-name.
    An attempt to read/write/seek/open on the files that make up the index named failed. Check to see that the files index-name.IDX and index- name.PTR exist in the database directory. Check whether there is sufficient disk space to write to the index files. Check whether the file has been read or write protected. Increase the number of files in CONFIG.SYS to more than 100. See X001 for a description of operation errors.
  • X113: Cannot perform operation (errno) on table table-name.
    An attempt to read/write/seek on the files that make up the table named failed. Check to see that the file table-name.TAB exists in the database directory. Check whether there is sufficient disk space to write to the index files. Check whether the file has been read or write protected. See X001 for a description of operation errors. Compact the table (or drop it) and rebuild the indices.
  • X114: Cannot close current database. Please exit.
    Internal error code. Please contact Micro Focus Technical Support.
  • X115: Location already exists in the path specified.
    XDB Server permits one location per directory. XDB Server locations must be given unique names. This error condition occurs if you attempt to create a location in a directory that already contains a location, or if you attempt to create a location using a location name found in the SYSXDB.SYSLOCALS table.
  • X116: Time value error.
    An attempt was made to process a command containing an invalid time value. Check time picture specification.
  • X117: Maximum number of open locations exceeded.
    Maximum number of locations open exceeds the number specified through the XDB Server configuration.
  • X118: Location name table already exists.
    XDB Server permits one location per directory. XDB Server locations must be given unique names. This error condition occurs if you attempt to create a location in a directory that already contains a location, or if you attempt to create a location using a location name found in the SYSXDB.SYSLOCALS table.
  • X119: Location name exceeds maximum length of number.
    XDB Server location names are limited to the number of characters specified. Use a shorter location name.
  • X120: Cannot find location name in SYSXDB.SYSLOCALS table.
    An attempt was made to perform an operation on a location not found in the SYSXDB.SYSLOCALS table. Check the location path or location name specified in your command. When a location is created using the CREATE LOCATION command, an entry is inserted into the SYSXDB.SYSLOCALS table. If you are using a location that was not created with the CREATE LOCATION command, you may use the INSERT command to insert a record into the SYSXDB.SYSLOCALS table for the location.
  • X121: Operation requires system level privilege.
    An attempt was made to perform an operation that requires database administrator privileges. Check the authority required for the command you are trying to execute. If you do not have the proper authority, see your database administrator.
  • X122: Incorrect location files on path path.
    This error occurs if a specified location is not found. This might be caused by trying to access files that have been deleted, or by entering a path instead of a location. Otherwise, the problem is with SYSXDB.SYSLOCALS. You might want to check the path selections in Options.
  • X123: Cannot open system location on path path.
    The system was unable to open the system location on the system location path specified. To change the system location path, use the Configuration utility, described in the XDB Server Administration Guide.
  • X124: Illegal operation on system object.
    An illegal attempt was made to alter, insert, update or delete from a system object. XDB Server objects are for system use; they are automatically created and maintained by the system. Users may query the objects but, in general, cannot update or change them except through special commands (e.g. COMMENT ON). See XDB Server System Tables in the SQL Reference for descriptions of the system objects and how they are maintained.
  • X125: Must execute statement before fetch.
    When using dynamic SQL, before issuing a FETCH command you must PREPARE and EXECUTE the command.
  • X126: Cannot GROUP BY an aggregate function.
    Aggregate functions cannot appear in a GROUP BY clause.
  • X127: Pattern matching allowed on character fields only.
    LIKE searches, which use wild card pattern matching, can only be performed on character fields. You may perform range searches on other field types, including date and time. If you want to search a date field by day, month, or year, use XDAY, XMONTH or XYEAR, respectively.
  • X128: Target table cannot also be source table.
    You cannot insert records selected from a table into the same table. In addition, you cannot copy a table to itself.
  • X129: Attempt to insert invalid data into field name.
    An attempt was made to place incompatible data in the field named. Check the command, the data, and the field type, and make any corrections needed.
  • X130: Attempt to drop system location.
    The system location cannot be dropped using the DROP LOCATION command, since it contains the SYSXDB.SYSLOCALS table. If you must drop the system location, use operating system commands to delete all files and remove the location directory.
  • X131: Attempt to drop location in use.
    You cannot drop the current location. Before dropping a location, you must change to another location.
  • X132: Cannot find location name name in SYSXDB.SYSLOCALS table.
    The location named in the command does not have an active entry in the SYSXDB.SYSLOCALS table in the system location. Check the command and the SYSXDB.SYSLOCALS table for the correct location name.
  • X133: Cannot use reserve word word in table/index definition.
    XDB Server and SQL reserved words cannot be used as database object names (e.g. table and field names). For a list of reserved words, see the SQL Reference.
  • X134: error: DOMAIN ERROR.
    A mathematical function contains an argument outside the domain of the function. For example, you cannot use a column containing a negative number as the argument for XSQRT.
  • X135: error: RANGE ERROR.
    The result of a mathematical function is too large to be represented in the data type the system is trying to use.
  • X136: Functionality not available with LITE engine.
    The LITE Server cannot process this statement because it contains commands that are not supported by the LITE software.
  • X137: Cannot perform operation (errno) on location file name.
    The system was unable to perform the operation specified on the location file specified.
  • X138: Illegal operation on view.
    An attempt was made to perform an operation not permitted on a particular view, or not yet implemented in XDB Server. For example, you cannot currently update a multi-table view.
  • X139: Record size exceeds the maximum.
    XDB Server records are limited to 32,767 bytes, including record overhead. For odd length character fields, overhead is one byte; for even length character fields overhead is 2 bytes. For most other data types, overhead is 2 bytes per field in DOS.
  • X140: WITH CHECK OPTION clause not allowed on read only view.
    You cannot specify a CHECK OPTION for a view that is not updateable. For example, you cannot currently update views involving multi-table joins.
  • X141: Record does not satisfy view definition.
    An illegal attempt was made to update or insert an invalid record into a view created using the CHECK OPTION clause. You can see the CHECK OPTION for the view by querying the SYSCHECK table.
  • X142: Operation not allowed on read only view.
    An attempt was made to perform an operation not permitted on a particular view, or not yet implemented in XDB Server. For example, you cannot currently update a multi-table view.
  • X143: Table already has check condition.
    You may only create one CHECK CONDITION per table. However, this CHECK CONDITION may be very complex (to the detriment of performance). If you want to add conditions to the CHECK CONDITION, you must drop and recreate the CHECK CONDITION.
  • X144: Record does not satisfy table name check condition.
    An illegal attempt was made to update or insert an invalid record into a view created using the CHECK OPTION clause. You can see the CHECK OPTION for the view by querying the SYSCHECK table.
  • X145: Key key not found when analyzing referential constraint.
    One of the keys involved in a referential constraint is missing. You must create a key before you can refer to it in a FOREIGN KEY constraint.
  • X146: Violation of constraint between key key1 and key key2.
    An attempt to update, insert or delete a record violates a FOREIGN KEY constraint involving the keys listed. See the ALTER command description in the SQL Reference for a description of FOREIGN KEY.
  • X147: Cannot find key key.
    The command references a key that does not exist. You must create a key before you can refer to it in a FOREIGN KEY constraint.
  • X148: Primary key key already exists on this table.
    Only one PRIMARY KEY is permitted per table; other candidate keys may be defined as UNIQUE.
  • X149: Primary/Unique key fields must be specified as NOT NULL.
    Before creating a PRIMARY KEY, you must specify that the fields involved are NOT NULL. You can do this through the Create/Alter Table module, or by using the ALTER command.
Parent topic: X - Engine Error Messages


X150 - X199

  • X150: Referenced fields must be specified as NOT NULL.
    Before you can create a FOREIGN KEY, you must specify that the referenced fields involved are NOT NULL. You can do this through the Create/Alter Table module, or by using the ALTER command.
  • X151: Location path exceeds maximum length of 48.
    Path names are restricted to 48 characters in length.
  • X152: Invalid transaction number.
    Internal error code. Contact Micro Focus Technical Support.
  • X153: No space for locks.
    There is no space to record additional record locks. If the transaction requires many locks on the same table, it is a good idea to lock the entire table, instead of attempting to lock each record. In multi-user XDB Server versions the size of lock tables can be configured through the XDB Server Configuration program.
  • X154: Cannot find table/record lock.
    Internal error code. Contact Micro Focus Technical Support.
  • X155: Table/record currently locked by user at node.
    A lock conflict exists. A record or table lock on the object you are attempting to lock is held by the user at the node (workstation) specified.
  • X156: Table/record currently locked by user at node.
    A lock conflict exists. A record or table lock on the object you are attempting to lock is held by the user at the node (workstation) specified. Note: With CICS, you must commit or use the Dirty Read (DR) option.
  • X157: Cannot obtain exclusive lock or drop lock in isolation level 5 or 6.
    When working at isolation level 5 (dirty read) or level 6 (snapshot read), a transaction cannot acquire or drop exclusive locks on any database object. Levels 5 and 6 are intended for read only. You cannot insert, update, delete, or alter database objects at these levels. You can change the isolation level using the following command:
  • X158: Cannot obtain or delete table locks in isolation level 5 or 6.
    When working at isolation level 5 (dirty read) or level 6 (snapshot read), a transaction cannot acquire or drop table locks. Levels 5 and 6 are intended for read only. You cannot insert, update, delete, or alter database objects at these levels. Tables are accessible by other users.
  • X159: Current location is locked by user at node.
    A lock conflict exists. The location you are attempting to access is locked for exclusive use by the user working at the node specified.
  • X160: Cannot obtain isolation level EU due to existing locks.
    The database you are attempting to lock is in use by others. Isolation level EU (exclusive use) not available until all other users close the database.
  • X161: Not enough memory free on XDB Server to process request.
    The minimum contiguous memory block is a configurable parameter (0-64K) for the XDB Server. The XDB Server does not currently have enough memory to process the request. Increase the size of the memory block. Increase the amount of free space on the server.
  • X162: Logging in to XDB Server name requires security on at user node.
    Security has been turned on at the XDB Server named. Security must also be turned on at the user node via the Configuration utility.
  • X163: No network node name specified. Must be set through XDBCONFIG.
    In the multi-user system, each network node must have a unique name, specified via the Configuration utility. The system is shipped without a default name since names must be unique.
  • X164: Operation cannot be performed in isolation level DR or SR.
    The user is trying to perform an operation other than reading a record while in the Dirty Read (DR) or Snapshot Read (SR) isolation level. Change to a different isolation level using the SET ISOLATION LEVEL command, or through Options.
  • X165: Redirector version does not match XDB Server version.
    The LAN redirector you are using does not generate communication packets that the XDB Server understands.
  • X166: Operation requires isolation level EU (Exclusive Use) with this server.
    Compacting database can only be performed at using an exclusive use isolation level (EU).
  • X167: Redirector does not support the selected protocol protocol.
    The communications protocol specified in Options is not supported by the redirector currently in use. For example, a DOS client can use NetBIOS, but cannot use Named Pipes.
  • X168: User has been deleted by DBA at XDB Server.
    The user's account on the XDB Server has been deleted. Please contact your Database Administrator.
  • X169: Attempted to examine the status of an un-executed command.
    An application issued a set of calls to the Server but not all were executed. An error exists in the application being run. Make sure you are using the correct AuthID for your location, and that you are pointing to the correct server. If the application is a Micro Focus program, please contact Micro Focus Technical Support.
  • X170: Referenced key field type(s) must match foreign key field type(s)
    The fields, taken in order, of the PRIMARY or UNIQUE KEY referenced by a FOREIGN KEY must match the type of the fields in the foreign key.
  • X171: Foreign key already exists on field(s) specified.
    Only one FOREIGN key is permitted on any set of fields. For example, if building a foreign key on item (o_no) that references the ORDERS table, you cannot build a another foreign key in the item (o_no) field.
  • X172: Cannot create directory on path path.
    An attempt to create a directory in the path specified failed. The path may already exist, or an attempt may have been made to create a subdirectory for a directory that does not exist.
  • X173: Cannot flush location file contents to disk.
    An attempt to commit a DDL operation (e.g. CREATE) failed. Disk may be full.
  • X174: Synonym/Table name already exists.
    You cannot create a synonym using a name already used by another synonym, table or view.
  • X175: Synonyms cannot be created on other synonyms.
    Synonyms may be created on tables and views only.
  • X176: Synonym name does not exist.
    You cannot drop a synonym that does not exist.
  • X177: Maximum identifier size exceeded.
    Table names, view names, index names, column names and synonyms are limited to 18 characters.
  • X178: Precision must be a value between 1 and 31.
    XDB Server accepts precision between 1 and 31. Precision is the total number of digits, including scale (number of decimal places) permitted in a decimal field.
  • X179: Scale must be a value between 0 and the precision.
    XDB Server accepts precision between 1 and 31. Precision is the total number of digits, including scale (number of decimal places) permitted in a decimal field. Scale cannot exceed the total number of digits permitted in the decimal field.
  • X180: Cannot truncate table file.
    When deleting all records from a table using the DELETE FROM table-name command, the tables and indices are simply truncated. An error occurred when attempting to truncate a file. Check your disk.
  • X181: Cannot truncate index file.
    When deleting all records from a table using the DELETE FROM table-name command, the tables and indices are simply truncated. An error occurred when attempting to truncate a file. Check your disk.
  • X182: Cannot perform table on forward log file name.
    An error occurred when attempting to read, write, search or truncate the forward log file specified. Check your disk. See X001.
  • X183: Cannot perform operation on backward log file name.
    An error occurred when attempting to read, write, search or truncate the backward log file specified. Check your disk. See X001.
  • X184: Illegal outer join conditions.
    Only five outer join conditions per query are currently permitted.
  • X185: FOR UPDATE OF not allowed with GROUP BY or ORDER BY clause.
    The FOR UPDATE OF clause cannot be used on a query that is not updateable. GROUP BY and ORDER BY queries are not updateable.
  • X186: Maximum number of open files exceeded.
    The system cannot process the current command because it is unable to open another file. You may need to close some queries, remove some indices from your table, or change the limit on the number of concurrently open files. In DOS, the number of files that can be concurrently opened by the system is specified in you computer's CONFIG.SYS file, as described in your Installation documentation.
  • X187: Referenced key and foreign key must have same number of fields.
    When defining a FOREIGN KEY, you must reference an existing key with the same number of fields.
  • X188: Attempt to place NULL value in host variable with no indicator variable.
    Embedded SQL only. If you retrieve a NULL value, you must have a special null indicator variable assigned for it. See the SQL Reference for further information.
  • X189: Source and Target locations have the same name.
    This error occurs when two locations with the same name exist in a system, and an attempt is made to copy a table from one to the other. You should rename one of the locations before attempting the copy.
  • X190: Cannot copy table/view to itself.
    XDB Server does not permit the same table to be used as the source and target for a copy operation. This error may occur when two databases with the same name exist in a system, and an attempt is made to copy a table from one to the other. Rename one of the databases before attempting the copy.
  • X191: View definition too large for memory buffer.
    There is not enough memory to process a view definition. If you have multiple queries open, or if you have unnecessary programs loaded into memory, close or remove them, and try again.
  • X192: Error in source view definition.
    Unable to copy view because of an error in the source view definition. You may need to redefine the view in the source database before attempting to copy it.
  • X193: Outer join condition not allowed on expression predicates.
    Outer join conditions are allowed on fields only and not on expression predicates.
  • X194: Attempt to divide by zero.
    An attempt was made to divide by zero within an expression.
  • X195: User does not have privileges necessary for renaming a table.
    You must be the creator of the table or have DBADM privileges on the database in order to rename a table.
  • X196: Expression in GROUP BY/ORDER BY clause not allowed.
    Only a field name or field number is permitted in a GROUP BY clause. Only a field name or column number is permitted in a ORDER BY clause.
  • X197: Expression not allowed on left side of set clause.
    The left-hand side of a SET clause must be a valid keyword, such as DATABASE or BACKWARD LOG. Expressions, when permitted, may appear only on the right-hand side of the SET clause.
  • X198: Expression not allowed for field of insert clause.
    When specifying the target fields for an INSERT command, you must use field names; expressions are not allowed.
  • X199: Illegal foreign key constraint.
    A FOREIGN KEY cannot be referenced by another FOREIGN KEY. If you want A to reference B, and B to reference C, then instead have A reference C and B reference C.
Parent topic: X - Engine Error Messages


X200 - X249

  • X200: Illegal attempt to log out of parent process when dependents exist.
    Internal error. Contact Micro Focus Technical Support.
  • X201: User does not have privilege necessary for operation.
    The user does not have the privilege required for the attempted operation. Check the SQL Reference for privileges required for specific operations.
  • X202: Check condition does not exist.
    An attempt was made to drop a non-existent check condition.
  • X204: Referenced key must be a primary/candidate key.
    Foreign key must reference a Primary or Candidate (Unique) key.
  • X205: Invalid character representation of numeric data.
    A character string that contains invalid or non-numeric data is used in a location that requires numeric data.
  • X206: Compatibility index must be set to group by number.
    The ability to perform a GROUP BY using column numbers in the specification is not supported in any compatibility modes other than the XDB mode. Change compatibility mode or write specification using column names.
  • X207: Check condition/view name incompatible with current version.
    The structure of underlying tables has changed since the view or check conditions were created. Drop the view or condition and recreate using the new database definitions.
  • X208: Table/View exists in target location. Use WITH REPLACE to overwrite.
    If table exists in target location, you must either drop it before overwriting, or use the COPY command with the WITH REPLACE option.
  • X209: Cannot perform GROUP BY on a view containing a GROUP BY.
    If a view contains a GROUP BY clause, a command using the view cannot also contain a GROUP BY clause.
  • X210: Cannot perform join with a view containing a GROUP BY.
    A view containing a GROUP BY clause cannot be joined to other tables.
  • X211: Cannot perform aggregate function on a view containing a GROUP BY.
    If a view contains a GROUP BY clause, no command using that view may contain an aggregate function.
  • X212: Function not available under current compatibility setting.
    The current compatibility setting set through Options does not permit the function being attempted. The setting must be modified to one that allows the functionality/syntax being attempted. See the Options User's Guide.
  • X213: Internal error encountered in function function. Contact Micro Focus.
    An unexpected internal error occurred. Contact Micro Focus Technical Support.
  • X214: The cursor identified in an open statement is already open.
    The application program attempted to execute an OPEN statement for a cursor that was already open. Correct the logic of the application program to ensure that it does not attempt this action.
  • X215: The cursor identified in a fetch/close statement is not open.
    The application program attempted to either (1) FETCH using a cursor, or (2) CLOSE a cursor at a time when a specified cursor was not open. In DB2 mode commit and rollback implicitly close cursor. After a cursor is closed, FETCHes or CLOSE cursor statements will generate this error code.
  • X216: Exceeded maximum outer join conditions.
    An outer join condition is one that contains a plus sign (+) next to a field. The number of outer join conditions allowed has been exceeded. Currently, five outer joins are allowed per query. To proceed, reduce the number of these conditions.
  • X217: Specified more than one primary key clause.
    The CREATE TABLE specified more than one primary key. By definition, a table may not have more than one primary key. Other candidate keys may be defined as unique keys.
  • X218: Referenced table does not contain a primary key.
    The table nominated as the parent in a FOREIGN KEY clause cannot be defined as a parent because it does not have a primary key defined. Correct the statement so that the table nominated as the parent in the FOREIGN KEY clause references a table with a primary key, or define a primary key for the table nominated as parent.
  • X219: Relationship name name already exists on this table.
    The constraint name specified in the FOREIGN KEY must be unique among all constraint names specified for this table. Change the name to one that is unique.
  • X220: Operation not allowed on table with incomplete definition.
    The reference to the table is invalid because it has a primary key, but no primary index. The reference is in a FOREIGN KEY clause or an SQL manipulative statement. Define a unique primary index on the table before referencing it.
  • X221: ALTER TABLE PRIMARY KEY requires existing unique index.
    The ALTER TABLE statement is invalid because the table does not have a unique index with a key that is identical to the nominated PRIMARY KEY. Make sure the key list specified on the ALTER TABLE statement identifies an existing unique index of the table.
  • X222: Relationship name must be less than 8 characters.
    The relationship name specified in the FOREIGN KEY clause is too long. Shorten the name to 8 characters or less.
  • X223: Self-Referencing tables must use the CASCADE delete rule.
    The delete rule specified in the FOREIGN KEY clause of the ALTER statement is invalid. A self-referencing constraint must specify the delete rule of CASCADE. Change the delete rule in the FOREIGN KEY clause.
  • X224: One or more foreign key fields must be nullable for SET NULL rule.
    The SET NULL clause of the FOREIGN KEY statement is invalid because no column of the key allows NULL values. Change a column of the key to allow NULL values, or change the delete rule.
  • X225: Primary key clause does not exist.
    The ALTER DROP PRIMARY KEY command was attempted on a table that does not contain a primary key.
  • X226: Relationship name name cannot be found in system table SYSREF.
    The ALTER DROP FOREIGN KEY command specified a constraint name that could not be found on the SYSREF table. Check the name to make sure it is a valid constraint name.
  • X227: Attempt to update parent having dependents in relationship name.
    An UPDATE operation attempted to update a primary key in the specified row of the object table; however, the primary key in the specified row had dependent rows associated with it. The value of a primary key in a parent row cannot be updated if the parent row has dependent rows. Examine the primary key of the object table and the foreign key of the dependent table to determine if the value of the primary key should be changed. If this does not solve the problem, examine the contents of the object table and the dependent table to determine the cause of the problem.
  • X228: The relationship name restricts the deletion of row with ID number.
    A DELETE operation attempted to delete a specified parent row in the object table and all related dependent rows in the dependent tables. However, a delete rule of RESTRICT was specified for one or more dependent tables.
  • X229: The insert/update value of foreign key name is invalid.
    An UPDATE or INSERT operation attempted to place a value in a foreign key of the object table; however, this value was not equal to some value of the primary key of the parent table.
  • X230: Index name is not compatible with current version.
    The index was not created with the current version and is incompatible. Rebuild the index with the current version. All indices in the location can be rebuilt using the COMPACT LOCATION AND INDEX command. All indices for a particular table can be rebuilt using the COMPACT TABLE `table-name' and INDEX command.
  • X231: Cursor must be declared as FOR UPDATE OF.
    The application program attempted to execute an UPDATE WHERE CURRENT OF statement on a cursor not defined as FOR UPDATE OF. Declare the cursor FOR UPDATE OF.
  • X232: Index name sort sequence different from current setting.
    An attempt was made to access an index that was created using a sort sequence different from the current sort sequence setting. When an index is created, it is sorted using the sort sequence specified in Options. To access this index, your default sort sequence setting must be consistent with that of the index. Rebuild the index with the default sort sequence setting or modify the setting in Options to be consistent with the index. Alternatively, you can drop the index and then recreate it with the new sort sequence setting.
  • X233: Non-quantified predicate followed by a list of values.
    If using a predicate without an ANY or ALL clause, only one value is allowed.
  • X234: Function not available with engine as database engine.
    DB2 link CAPI function not implemented with this engine.
  • X235: XDBXDIRECT function not supported on GROUP BY cursor.
    The Xdbxdirect function is not supported with queries containing a GROUP BY clause.
  • X236: Must use ALTER TABLE DROP PRIMARY KEY to drop index pending.
    An attempt was made to drop the `pending' index, which is a temporary name for a PRIMARY KEY which has not yet had a unique index created for it. To drop this index, use the ALTER TABLE DROP PRIMARY KEY statement.
  • X237: operation not allowed on table name while in use.
    Another user attempted an operation on the specified table while the table was in use. Skip the operation or retry it later.
  • X238: Attempt to update a deleted record.
    The record you are attempting to update has been deleted.
  • X239: Invalid DEGREE specified.
    The SET CURRENT DEGREE command contains an invalid value.
  • X240: Cannot delete field name which has existing referential key.
    An attempt was made to delete a field containing a referential key. To delete the field, first drop the referential key.
  • X241: Cannot modify field name which has existing referential key.
    An attempt was made to modify a field containing a referential key. To modify the field, first drop the referential key.
  • X242: Maximum number of sort fields exceeded.
    The query has exceeded the maximum number of sort fields allowed. The current maximum number of sort fields is 750.
  • X243: Host variable not allowed in current command.
    The command executed does not support host variables.
  • X244: Object table is referenced in nested query FROM clause.
    In DB2 mode, the table that is the object of an update, insert or delete cannot also be referenced in a nested query FROM clause.
  • X245: Requested packet is larger than max buffer size.
    The amount of data being sent from the application program to the engine is too large. Increase the receive buffer size on both the client-side and the server-side.
  • X246: Primary key cannot be target of multiple-row update.
    In DB2 mode, a primary key cannot be updated if an update clause retrieves more than one record.
  • X247: String representation of a date/time value is invalid.
    The character representation of a date or time value is not being recognized. The engine can recognize ISO, JIS, EUR, USA, and LOCAL formats. Compare your date/time representation with the picture specified in CONFIG.XDB through Options.
  • X248: AuthID not allowed on synonym table reference.
    In DB2 mode, a synonym cannot be referenced in a FROM clause with an AuthID. Remove the AuthID.
  • X249: Invalid picture specification.
    The picture used in the CHAR function is not legal.
Parent topic: X - Engine Error Messages


X250 - X299

  • X250: Invalid PCTFREE value.
    Valid percent free values are 0 through 99.
  • X251: Only one clustered index allowed per table.
    XDB Server currently supports only one clustered index per table. Make all other indices non-clustered.
  • X252: Truncate not allowed on primary key table.
    The TRUNCATE clause is not allowed on tables that have a PRIMARY KEY.
  • X253: Compact cluster by clause must specify existing clustered index.
    When using the CLUSTER BY clause in a COMPACT statement, and the table has a clustered index, then you must specify the clustered index that already exists. If the table does not have a clustered index, then any index can be specified.
  • X254: DUPQTY value must be 8, 16, 32, 64 or 128.
    The only legal values when using the DUPQTY clause are 8, 16, 32, 64 and 128.
  • X255: Communication Manager out of memory.
    The XDB Server ran out of memory. You may want to reconfigure your system to increase available memory. See the XDB Server Administration Guide for specific performance tuning procedures.
  • X256: Stored Procedure ProcName failed due to reason ReasonCode.
    The XDB Server is not able to execute the CALL statement for the stored procedure ProcName.
  • X257: Engine configuration maximums too large. Reconfigure them smaller.
    The configuration parameters for Windows must fit into 64K. The options selected require more than 64K. Use the XDB Server Configuration utility to reconfigure the options.
  • X258: Out of memory for expressions.
    The total amount of memory required by the query for expressions exceeded the maximum memory that can be supported by XDB Server.
  • X259: Error on Operation (size) Server (server).
    An error has occurred with server-to-server access.
  • X260: Operation cannot be performed on current location version.
    The current location format does not include support for the command. Creating a new location or upgrading the system location will bring the current location version up to date.
  • X261: Redirector not loaded!
    The redirector associated with the selected protocol is not currently running. If your protocol is currently set to NetBIOS, run the NetBIOS redirector.
  • X262: Invalid parameter. A valid window handle was expected.
    A valid window handle is not zero. Pass a valid window handle returned from the CreateWindow() function.
  • X263: XdbWinInit() has not been called. XdbWinInit() must be called first.
    Under Windows, the function XdbWinInit() must be called before all other functions. See your C documentation.
  • X264: A necessary window could not be created.
    A window could not be created due to the number of windows already open or the amount of system resources in use. Close other windows or shut down other applications and try again.
  • X265: User program ProgramName could not be found.
    The XDB Server cannot find the DLL or the function associated with the procedure specified in your SQL CALL statement.
  • X266: Server is shutting down. Accepting no more logins.
    The server has been configured to shut down on last disconnect. No new connections are allowed.
  • X267: Invalid parameter in function function.
    An internal error has occurred. The XDB Server has received an invalid parameter or a different number of parameters than it expected.
  • X268: Server shutdown already in progress.
    Only one server shutdown command may be active at any one time.
  • X269: Illegal shutdown parameter.
    Internal error in shutdown processing. Contact Micro Focus Technical Support.
  • X270: Update/Delete on invalid cursor position.
    An application program tried to update or delete on an invalid cursor position. This is an internal error. If the application is a Micro Focus program, contact Micro Focus Technical Support.
  • X271: The Server failed when trying to begin a thread.
    The maximum number of threads allowed was exceeded. You must reconfigure the number of threads needed to a smaller number. The XDB Server Configuration utility options that affect this are:
  • X272: Cannot open file name. Increase the max number of open files in the XDB Server Configuration utility.
    The specified file could not be opened because the maximum number of open files set in the server configuration was exceeded. Increase the maximum number of open files in XDB Server Configuration utility.
  • X273: AuthID exceeds the maximum length.
    The maximum length of an AuthID is 8 characters.
  • X274: Location name exceeds the maximum length.
    The maximum length of a location name is 16 characters.
  • X275: Column name in explanation table name is not defined properly.
    An error occurred during the insertion of a row into the explanation table. The table is improperly defined for one or both of the following reasons: columns are defined in the wrong order; or a column description is invalid because of its name, data type, length or NULL attributes. Correct the definition of the required explanation table.
  • X276: Invalid number of fields (number) in explanation table name.
    The explanation table does not have a valid number of fields. Correct the definition of the required explanation table.
  • X277: userid does not have privilege to create with qualification authid.
    The specified user attempted to create an object with an invalid AuthID. Only if your AuthID is SYSADM, DBADM or DBCTRL can you create an object with an AuthID other than your valid primary or secondary AuthID. Ensure that AuthID is one of your valid AuthIDs.
  • X278: auth specified is not one of the valid AuthIDs.
    The specified AuthID is not the user's current primary or secondary AuthID. Specify a valid AuthID.
  • X279: Name name is too long. Maximum allowable size is number.
    The specified name has exceeded the maximum allowable length of number characters. Columns, tables, views, indices, aliases and synonyms have a maximum length of 18 characters. Locations have a maximum length of 16 characters. Table qualifiers, view qualifiers, storage group names, database names, tablespace names, and constraint names specified in CREATE or ALTER TABLE statements have a maximum length of 8 characters. Volume serial numbers must contain 6 characters or fewer, and labels must contain 30 characters or fewer. Enter a shorter name for the object.
  • X280: name is an undefined name.
    The object specified by name does not exist in the XDB Server location. Be sure you have entered the correct name.
  • X281: Object name name of object type type already exists.
    There is already an object of the type specified with the name specified. Drop the existing object or enter another name for the new object.
  • X282: Too many volume serial numbers specified.
    The CREATE or ALTER STOGROUP command specified a list of volumes that exceeds the maximum of 133. Shorten the list of volumes specified.
  • X283: The PART clause of an ALTER statement is omitted or invalid.
    The ALTER TABLESPACE command or ALTER INDEX command has an invalid partition clause. Check to be sure that the tablespace or index to be altered is partitioned. If so, be sure you have identified the correct partition; if not, do not include a PART clause.
  • X284: Duplicate keyword keyword.
    The specified keyword has a duplicate specification in the SQL statement. Change the statement so that it only contains one specification for the keyword.
  • X285: Attempt to drop stogroup used by a tablespace.
    An attempt was made to drop a storage group that is being used by one or more tablespaces. You must first alter or drop all tablespaces that use the stogroup before the stogroup itself can be dropped. You can query the STORNAME field of the SYSIBM.SYSTABLEPART system table to find all tablespaces that are dependent on the stogroup.
  • X286: Operation not allowed on system database.
    The attempted operation may not be performed on a system database.
  • X287: Alias name must not be defined on another alias.
    The specified name identifies an alias, which is defined on another alias. Do not use aliases to define other aliases; they should only define base tables or views.
  • X288: Statement reference to remote object is invalid.
    This error can be caused by any of the following conditions:
  • X289: Invalid value specified for keyword keyword.
    The value specified for the keyword is invalid. See the SQL Reference for valid keyword values.
  • X290: Keyword keyword not allowed for tablespace in workfile database.
    The specified keyword cannot be used for a tablespace in the workfile database. Change the SQL statement.
  • X291: Illegal use of keyword keyword.
    A syntax error exists in the SQL statement at the point where the specified keyword appears. Check the statement for errors.
  • X292: Unable to perform operation operation on database name.
    The requested operation is not legal or valid on the specified database.
  • X293: Table/Index ObjectName in use.
    The XDB Server cannot execute the STOP DATABASE command because the specified table or index is being used.
  • X294: Unable to operation stopped database name.
    It is illegal to perform the specified operation on the specified stopped database.
  • X295: Database ROSHARE can only be altered from OWNER to NONE.
    XDB Server only supports the altering of Read-Only Shared Databases from a value of OWNER to a value of NONE. You must create a new ROSHARE database in order to obtain other share options.
  • X296: Location name is not converted. Run location conversion program.
    The location specified is not compatible with the current version of the XDB Server database engine. You must convert the location by running the XDB Server conversion program CONVERT.EXE.
  • X297: FOR FETCH ONLY and FOR UPDATE OF are mutually exclusive clauses.
    You cannot specify both a FOR FETCH ONLY clause and a FOR UPDATE OF clause in your query. If a cursor is to be both fetched and updated you should not specify either clause in the SELECT statement.
  • X298: Synonym target must include an explicit authorization ID.
    The object to which a synonym applies must specify a two-part name that includes a valid AuthID. Modify the table or view name to include an AuthID.
  • X299: A segmented tablespace may not be partitioned.
    The CREATE TABLESPACE statement contains both the SEGSIZE and NUMPARTS specification, but they are mutually exclusive.
Parent topic: X - Engine Error Messages


X300 - X349

  • X300: Cannot open configuration file CONFIG.XDB. Check XDBCFG setting.
    CONFIG.XDB was not found in the current directory, or in the directory specified by the XDBCFG environment variable.
  • X301: Cannot open configuration file CONFIG.XDB. Check XDBCFG setting.
    CONFIG.XDB was not found in the current directory, or in the directory specified by the XDBCFG environment variable.
  • X302: Cannot read configuration file CONFIG.XDB.
    The system is unable to open CONFIG.XDB. The file may be missing, damaged, or read-locked.
  • X305: Cannot open help file name.
    The file named was not found in the home directory. The `home' directory is set using Options.
  • X306: Syntax error in mask definition.
    The system was unable to parse a mask definition. Check the mask definition against the Options User's Guide.
  • X307: Grouping character found twice or in illegal position.
    The grouping character cannot appear to the right of the decimal point. A money symbol cannot appear between the grouping symbol and any numeric mask characters.
  • X308: No grouping length.
    No grouping character (,) was found in the mask; therefore, the grouping character cannot be reassigned.
  • X309: Decimal character found twice or in illegal position.
    A decimal point can only appear once in a numeric picture. Make sure you are not using a decimal point as a grouping character.
  • X310: Rounding character in illegal position.
    The rounding character (r) should appear as the rightmost character in a picture.
  • X311: Illegal character in picture specification.
    A character other than one of the characters in +-$,.9zr was found in a numeric picture specification.
  • X312: "$" character found on both sides of decimal.
    A dollar sign can only appear on one side of the decimal point in a money picture. Usually the dollar sign appears to the left. If the dollar sign appears to the right of the decimal point, only one dollar sign should appear.
  • X313: Sign character found on both sides of the decimal.
    A negative (-) or plus (+) sign can only appear on one side of the decimal point in a numeric picture. Usually the sign appears to the left of the decimal point. If the sign appears to the right of the decimal point, only one sign should appear in the picture.
  • X314: Error in substitution portion of picture definition.
    The decimal (.), grouping (,) and money ($) symbols are used when creating a numeric picture. You may substitute other characters for the decimal, grouping or money symbols by assigning a new value to these symbols after specifying the mask, for example:
  • X315: Illegal decimal found in picture.
    Cannot reassign the decimal character as requested, or the period character is not used as a decimal point in the mask portion of the picture.
  • X316: Illegal rounding character found in picture.
    Cannot interpret the rounding character r in its current location in the picture.
  • X317: Illegal dollar sign found in picture.
    Cannot reassign the money character as requested, or $ is not used as a money symbol in the mask portion of the picture.
  • X318: Closing single quote not found in substitution string.
    An expression assigning a new decimal, grouping or money symbol is missing a closing quote.
  • X319: Value too wide for picture field.
    An attempt was made to assign a value, or display a value using a picture that is unable to accommodate the value; for example, an attempt to display the value 1234 in a variable or column with a picture of 999.
  • X320: Error in time/date picture definition.
    The system is unable to parse a time or date picture. See the Options User's Guide for information on creating time and date pictures.
  • X321: Invalid CONFIG.XDB. Run XDBPROFI to reconfigure system.
    The configuration file, CONFIG.XDB, which is stored in the Micro Focus directory, has been damaged or is incompatible with the current version. Run Options as described in the Options User's Guide.
  • X322: Invalid year value.
    The user input an illegal value in the specified field type. See the SQL Reference for information on data type ranges and domains. Also check the default format specified for the data type through Options (described in the Options User's Guide). Check to make sure that pictures and data match.
  • X323: Invalid separator in value.
    The user input an illegal value in the specified field type. See the SQL Reference for information on data type ranges and domains. Also check the default format specified for the data type through Options (described in the Options User's Guide). Check to make sure that pictures and data match.
  • X324: Invalid character in value.
    The user input an illegal value in the specified field type. See the SQL Reference for information on data type ranges and domains. Also check the default format specified for the data type through Options (described in the Options User's Guide). Check to make sure that pictures and data match.
  • X325: Money value error.
    The user input an illegal value in the specified field type. See the SQL Reference for information on data type ranges and domains. Also check the default format specified for the data type through Options (described in the Options User's Guide). Check to make sure that pictures and data match.
  • X326: Numeric value error.
    The user input an illegal value in the specified field type. See the SQL Reference for information on data type ranges and domains. Also check the default format specified for the data type through Options (described in the Options User's Guide). Check to make sure that pictures and data match.
  • X327: Integer value error.
    The user input an illegal value in the specified field type. See the SQL Reference for information on data type ranges and domains. Also check the default format specified for the data type through Options (described in the Options User's Guide). Check to make sure that pictures and data match.
  • X328: No more RAM memory available.
    Insufficient RAM available to continue processing. Remove unnecessary programs from memory. For example, bypass the Loader or the Micro Focus application menu.
  • X329: COMMAND.COM not found.
    Please contact Micro Focus Technical Support.
  • X330: Cannot execute program.
    An error occurred when attempting to use the shell facility to temporarily exit to the operating system (possibly insufficient memory). In order to reach the operating system, you will have to exit normally, instead of using the shell facility.
  • X332: Index name does not exist.
    The index named was not found in the current database. Check the database path and the name of your index.
  • X333: Unknown field type in table name.
    An unknown field type was found. A different version of XDB Server may have been used to create the table, or the system path may be set to an earlier version. Check the version.
  • X334: Index name has been damaged.
    Either the named index has been damaged or a different version of XDB Server is running than the one that created the index. Use the version that created the index. The system path may be set to an earlier version. Check the version.
  • X335: Key name does not exist.
    The key named was not found in the current database. Check the database path and the name of your key.
  • X336: Key name has been damaged.
    Either the named key has been damaged or a different version is running than the one that created the key. Use the version that created the key. The system path may be set to an earlier version. Check the version.
  • X337: Synonym name does not exist.
    The synonym named was not found in the current database. Check the database path and the name of your synonym.
  • X338: Table/View name does not exist.
    The table or view named was not found in the current database. Check the database path and the name of your table or view.
  • X339: Error opening file FileName for Page1 to Page2 translation.
    The XDB Server was not able to open this file, which is needed for code page translation.
  • X340: Not enough memory to perform action.
    There was not enough memory to execute the command. A smaller command may be possible. Remove all memory resident tools that you are not currently using and try again.
  • X341: Illegal decimal precision.
    The number has an illegal precision. Check your data and your data type; they are probably not the same.
  • X342: Called function is not compatible with current version.
    This error occurs only when running the COBOL Precompiler. You must precompile and compile your program again for compatibility.
  • X343: An explicit COMMIT is illegal in an IMS/CICS program.
    IMS/CICS performs an implicit COMMIT. This is mainframe-compatible.
  • X344: An explicit ROLLBACK is illegal in an IMS/CICS program.
    IMS/CICS performs an implicit ROLLBACK. This is mainframe-compatible.
  • X345: A negative or zero ABSOLUTE FETCH is illegal.
    An absolute fetch needs a value specifying the offset from the current cursor position, and the offset must be a positive number.
  • X346: Cannot locate files in the directory specified.
    Files needed by the system cannot be found in the path specified by the XDBPATH environment variable. Make sure that you have specified the correct directory in the XDBPATH environment variable. Also make sure that your server names match in Options and the XDB Server Configuration utility.
  • X347: Illegal function code passed to the COBOL interface.
    Internal error. Contact Micro Focus Technical Support.
  • X348: No application path specified.
    There is no application path specified in CONFIG.XDB. IMS/CICS performs an implicit ROLLBACK. This is mainframe-compatible.
Parent topic: X - Engine Error Messages


X350 - X399

  • X352: Server violation.
    The server experienced a protection exception while processing a user's command. The exception handling code has rolled back the user's current transaction and logged the user out.
  • X354: Error loading server communications DLL(name).
    Make sure you have the DLL named in the correct DLL subdirectory.
  • X355: Error connecting to remote server(name).
    An error has occurred while trying to connect to server name. Make sure you have enough remote engine threads and that the server-to-server connectivity setup is correct in your system catalogs.
  • X356: Error sending to remote server(name).
    An error has occurred while trying to send to server name. Make sure you have enough remote engine threads and that the server-to-server connectivity setup is correct in your system catalogs.
  • X357: Error receiving from remote server(name).
    An error has occurred while trying to receive from server name. Make sure you have enough remote engine threads and that the server-to-server connectivity setup is correct in your system catalogs.
  • X358: Governor limit exceeded.
    One of the governor limits has been exceeded, and the server logged out the user. You could increase the governor limit for that user. The governor will be active only if the server security is ON.
  • X359: Error initializing remote server gateway.
    An error has occurred while trying to connect to a remote server.
  • X360: Incorrect version of the server configuration file.
    You have an old version of SRVCONFG.XDB. Delete your old SRVCONFG.XDB and run the new XDB Server Configuration utility to create a new one.
  • X361: No remote thread available to process request.
    A client has tried to connect to a remote server and the primary server does not have any thread available to handle the request. In these cases, there are no remote threads set for the primary server, or all the remote threads are already in use.
  • X362: Index error during recovery.
    While XDB Server was recovering a location, a fatal error occurred. You must compact and re-index the location immediately. Do not use the location until the compact and re-index has finished.
  • X363: No protocol threads available to process request.
    The number of protocol threads for TCP/IP, SPX, or Named Pipes must equal the number of users using the protocol.
  • X364: The describe statement does not identify a prepared statement.
    In order to describe a query, the query must first be prepared.
  • X365: Log path cannot be set to path.
    The logging system cannot set the log to the path specified. Ensure that the path exists, and that there are no other logs present in the path.
  • X366: Error replacing alias name with actual table name.
    XDB Server encountered an internal error when forming the alias substitution string. Contact Micro Focus Technical Support with the details of the query.
  • X367: GROUP BY/HAVING not allowed in subquery/embedded select.
    XDB Server and DB2 does not allow a GROUP BY or HAVING clause on a nested query.
  • X368: Illegal string string found.
    XDB Server received a different string than it expected. For example: SET CURRENT RULES <parm> must be either DB2 or STD. Using a different parameter will return an x368.
  • X369: Invalid index type.
    The index type must be 1 or 2.
  • X370: The target location needs to be compatible with DB2 version version.
    An attempt was made to perform new DB2 functionality against an XDB Server location that was created with this functionality. See the ALTER LOCATION command and CREATE LOCATION command in the SQL Reference and the readme file.
  • X371: The selected locksize and lockmax options do not match.
    The DDL is illegal. See the SQL Reference for correct values.
  • X372: Illegal attempt to convert location to a lower version.
    An ALTER LOCATION can only be used to move forward in DB2 functionality, not backwards (i.e., an ALTER LOCATION cannot be used to convert a location to a lower version).
  • X373: Invalid number of parameters (number expected) for stored procedure ProcName.
    The number of parameters specified in your SQL CALL statement exceeds the number of parameters allowed by the ProcName stored procedure.
  • X374: Stored procedure ProcName received a null value for parameter number.
    The SQL CALL statement for stored procedure ProcName contains a null value in its parameter list, and this stored procedure does not accept null values.
  • X375: Stored procedure ProcName has been placed in a must rollback state.
    The stored procedure ProcName issued one of the following operations:
  • X376: Missing OBID clause when creating a table in a ROSHARE READ database.
    The OBID clause was not specified in the CREATE TABLE command. The OBID clause is required whenever the database containing the table is defined as ROSHARE READ.
  • X377: A privilege cannot be revoked because it is not possessed by AuthID authid.
    An AuthID can revoke only the privileges that it has explicitly granted to other AuthIDs, unless the AuthID has SYSADM or SYSCTRL authority and specifies the BY clause.
  • X378: Attempt to disable login with security off.
    A DISABLE LOGIN command was issued while security was off on the XDB Server.
  • X379: The login was rejected due to logins being disabled.
    The database administrator has disabled logins for this XDB Server, so your login command was rejected.
  • X380: The XDB Server has rejected this connection due to load balance requirements.
    Your connection request was rejected because the XDB Server has exceeded the load balancing limits configured by the database administrator.
  • X381: Cannot connect with requested location. Location is offline.
    The location you have requested is currently offline. (Your database administrator may have taken it offline for maintenance purposes.)
  • X382: Cannot take requested location offline. Location is in use.
    The XDB Server cannot take the requested server offline because it is being used. You are allowed to take a location offline only when there are no users attached to it.
  • X383: Sequence error for reason code (ReasonCode) Message.
    The XDB Server has received a request out of order.
  • X384: Invalid handle.
    The XDB Server has received an invalid handle. This is an internal error.
  • X385: Login error with Reason Code ReasonCode Message (returned Number).
    An error has occurred while logging on to the XDB Server through the Direct Flight software.
  • X386: Conflicting definitions for the same variable or parameter. Description
    The SQL Server has received a parameter or host variable from the client application that does not match the data type it expected.
  • X387: Option conflict with location rules
    The statement being executed has an option that is incompatible with the current location type.
  • X388: Invalid token 'token' found in PARMLIST for procedure proc-name
    A Stored Procedure or Trigger definition has a syntax error.
  • X389: Illegal operation on temporary table
    The current operation is not allowed on a temporary table. Temporary tables are not allowed to have primary/unique keys, or to be referenced by foreign keys. Also, update/delete operations on records in temporary tables are not allowed.
  • X390: Check option not allowed on temporary table
    A view of a temporary table must not specify the CHECK OPTION clause.
  • X391: WITH DEFAULT clause not allowed on CREATE GLOBAL TEMPORARY TABLE
    WITH DEFAULT clauses are not allowed on a CREATE GLOBAL TEMPORARY TABLE statement.
  • X392: Your SQL Option (for DB2 emulation) has expired.
    The XDB component (e.g., XDB Server, XDB Link) you are attempting to use does not have a valid license from Micro Focus.
  • X393: Output host variable PositionNumber is incompatible with the query result.
    The XDB Server is not able to return the result of a CALL, FETCH, or SELECT statement because the data type of the variable at PositionNumber in the output SQLDA (to which the result was to be written) does not match the data type of the result.
  • X394: Input host variable PositionNumber is incompatible with the current query.
    The XDB Server is not able to execute the requested SELECT statement because it contains a host variable whose data type is not correct. (For example, the WHERE clause may be using a numeric host variable to select from a DATE field in the database.) The host variable causing the problem is located at PositionNumber in the input SQLDA.
  • X395: Value for data type Type is out of range for host variable PositionNumber.
    The XDB Server cannot return the requested value because the returned value is larger than the host variable at PositionNumber in the output SQLDA (to which the value was to be written) can accept.
  • X396 ColumnName is not a column of specified table or view in the query.
    The specified name is not a column in the table or view referenced. A bad column name in a FOR UPDATE OF clause can generate this error.
  • X397 Decimal host variable or parameter Identifier contains non-decimal data.
    Data could not be used as specified in the statement because the data is not valid for this type.
  • X398 ColumnName is not an updateable column; it is not identified in the update clause.
    In order to update this column, you need to specify its name in the FOR UPDATE OF clause for this cursor.
  • X399 Improper use of long string data, StringValue.
    The operation is not supported on a long string value in DB2 mode.
Parent topic: X - Engine Error Messages


X400 - X449

  • X400 Named cursor already assigned to a result set locator.
    The named cursor could not be reused.
  • X401 Statement can't be issued until the stored procedure has been called.
    Either a DESCRIBE PROCEDURE or an ASSOCIATE LOCATOR statement has been executed prior to the CALL to the stored procedure.
  • X402 Invalid result set locator.
    The result set locator was never assigned a valid value. Result set locators are returned by the ASSOCIATE LOCATORS statement.
  • X403 Cursor name CursorName was not defined.
    The named cursor was not defined.
  • X404 A Rollback is required.
    The transaction is in a must rollback state.
  • X405 An ON clause in a JOIN operator is invalid.
    An ON clause used to specify a JOIN condition is invalid. VALUE/COALESCE functions are only allowed in FULL OUTER JOINs. Only an '=' operator is valid in FULL OUTER JOINs. Also, column may be inappropriately referenced from within the JOIN clause.
  • X406 Stored procedure StoredProcName parameter ParameterName is larger than declared.
    The stored procedure has used a value that is too large for the definition declared in the SYSIBM.SYSPROCEDURES PARMLIST field.
  • X407 Stored procedure StoredProcName requires a host variable for parameter ParameterName.
    The parameter in the stored procedure PARMLIST definition in SYSIBM.SYSPROCEDURES is defined as OUT or INOUT. A host variable must be supplied in the call for that parameter.
  • X408 Stored procedure StoredProcName did not return result sets.
    The stored procedure has not returned any results sets to the caller. Verify that the stored procedure has been coded correctly.
  • X409: Error in trigger trigger-name, section number trigger-section
    A trigger trigger-name executed during an INSERT, UPDATE, or DELETE statement contained an SQL statement that returned an SQL error. The section number trigger-section identifies the statement in error.
  • X410: Function function-name named without signature, function not unique
    The signature of the user defined function function-name is not unique within its schema. Either the CURRENT PATH must be changed or the SPECIFIC name of the function must be used.
  • X411: Signature for function function-name not unique within schema
    The function function-name that is being created does not have a unique signature within the schema.
  • X412: Set transition variable is used for before trigger per row only
    SET transition-variable can only be used within a before trigger whose granularity is FOR EACH ROW.
  • X413: Invalid insert into column %s defined as generated always
    No input value is allowed for a column defined as GENERATED ALWAYS.
  • X414: Internal error, identity column definition not found
    An internal error has occurred. The identity column definition could not be found.
  • X415: Only one rowid or identity column is allowed in a table
    A table contains more than one row ID or identity column. This is not allowed.
Parent topic: X - Engine Error Messages


XMIG - Migrate Error Messages

  • XMIG000: Error system error: Unknown error errorID.
    Migrate attempted to display an error that was not found in the error file. This usually happens because an obsolete copy of the error file, XMIG.XRR, has somehow been copied into the directory.
  • XMIG001: No more RAM memory available.
    Migrate has experienced an internal error caused by a shortage of memory.
  • XMIG002: No Column in table.
    Migrate has experienced a serious internal error.
  • XMIG003: Cannot open file filename.
    Migrate is not able to open the specified file.
  • XMIG004: Syntax Error.
    Migrate is unable to interpret an SQL command that has been included in your migration.
  • XMIG005: Destination location has not been defined.
    Migrate is attempting to copy records, but a destination location has not been specified.
  • XMIG006: Destination table has not been defined.
    Migrate is attempting to copy records, but a destination table name has not been specified.
  • XMIG007: Error in internal query querystring.
    Migrate is attempting to access the SYSXDB.SYSQUERY table and the table is not in the expected format. Usually this is because the table is in an older format that does not include two fields required by Migrate.
  • XMIG008: Table tablename does not exist.
    The table name was not found in the specified source location.
  • XMIG009: Check source location data consistency.
    Migrate cannot create a foreign key because there is invalid value in the table.
  • XMIG010: Error saving file name.
    Migrate experienced an error when saving the named file.
  • XMIG011: Query window contains more than one query.
    Migrate has found an end-of-statement delimiter in the Query window. Only a single SELECT statement is allowed in this window.
  • XMIG012: Query must be a SELECT statement.
    Migrate has found an invalid SQL statement in the Query window. Only a single SELECT statement is allowed in this window.
  • XMIG013: Table already exists. Illegal with current settings.
    Select Table/Query Options from the Object menu, and check the "If table already exists" settings.
  • XMIG014: Field names in query may not match the field names of the destination table.
    An X009 was returned when the query from a Query window was executed. The database table has been altered since the .MIG file was saved, or there is some other problem with the validity of the SELECT statement in the Query window.
  • XMIG015: No key fields specified in replication query.
    A Query window used for replication must have at least one column defined as the key. Click the Update Rules button, and select True or False under the Key heading for each column returned by the SQL statement defined in the Query window.
  • XMIG017: Cannot find information in system_table for 'table_name'.
    SQL Migrate failed to retrieve information for the specified table from a system table when attempting to add it to the schema viewer.
  • XMIG049: SELECT error. May not have privileges.
    Migrate cannot complete this task because you do not have privileges on the specified object.
  • XMIG053: Filters yield no results. Filters are reset.
    The filter value entered for the immediate sub-item (database, or AuthID) beneath the location level returned an empty result set. The Catalog Browser display will be refreshed using the latest valid set of filter values stored in XDB.INI.
Parent topic: Error Messages


XU - Library Error Messages

  • XU001: No more RAM memory available to application.
    Insufficient memory (RAM) was available to execute a command sent to the SQL Engine. Try running the application from outside the main or application menu to see if that gives you enough memory to continue. If you have other memory resident programs loaded, remove them and try again. Load network drivers into high memory or remove them. Reduce DOS memory consumption by using fewer FILES= and fewer BUFFERS= in CONFIG.SYS.
  • XU002: No more EXTENDED memory available to application.
    Insufficient extended memory is available to run the application. Try bypassing the XDB Server Main Menu, or removing other programs from memory. See error XU001.
  • XU004: Filename name is too long.
    The filename you have entered exceeded the maximum length. Filenames must be 8 characters or fewer. Enter a shorter filename.
  • XU005: File name not found.
    Cannot find the file specified. Check to make sure that the correct directory is being used, and that the specified file exists there.
  • XU006: Error opening file name. error-descr.
    The system could not open the file named due to the specific operating system error. See your operating system manual for the error described and make any necessary corrections.
  • XU007: Error reading file name. error-descr.
    The system could not read from the file named due to the specified operating system error. See your operating system manual for the error described and make any necessary corrections.
  • XU008: Error writing file name. error-descr.
    The system could not write to the file named due to the specified operating system error. See your operating system manual for the error described and make any necessary corrections.
  • XU009: Error closing file name. error-descr.
    The system could not close the file named due to the specified operating system error. See your operating system manual for the error described and make any necessary corrections.
  • XU010: Error deleting file name. error-descr.
    The system could not delete the file named due to the specified operating system error. See your operating system manual for the error described and make any necessary corrections.
  • XU011: Error seeking file name. error-descr.
    The system could not seek the file named due to the specified operating system error. See your operating system manual for the error described and make any necessary corrections.
  • XU014: Incorrect file version in file name.
    The file specified is not the current version. If it is a help file or error file, you must recompile the file using the current version of the help compiler, XDBHELPC. If the file is a message file, you must recompile it using the message compiler, XDBMSGC.
  • XU015: Corrupted file format in file name.
    The file specified could not be entirely read. Check to see if it is the correct file. You may consider trying a backup file name.
  • XU016: Invalid file or path specification.
    The directory you have specified cannot be accessed.
  • XU017: The file FileName does not have correct read/write permissions.
    FileName has permission settings that prevent the software from reading or writing to it.
  • XU018: Invalid drive in search path.
    The drive letter you have specified does not exist.
  • XU020: Maximum of 3 unsuccessful attempts to login.
    You have attempted to log on to a XDB Server using an invalid user ID and/or password three consecutive times, so XDB Server will automatically exit the client application.
  • XU021: More than 15 errors...
    The active program has issued more error messages than this dialog box can display. Only the first 15 are shown.
  • XU022: Invalid server name.
    The string of characters you have entered does not constitute a valid server name. For example, the string contains an illegal character (such as a space) or is too long.
  • XU023: Invalid location name.
    The string of characters you have entered does not constitute a valid location name. For example, the string contains an illegal character (such as a space) or is too long.
  • XU025: Unknown system error. Errno = ErrNumber. Doserrno = DErrNumber.
    An internal error has occurred, and the error number is out of range.
  • XU030: Object name not found in SYSIBM.SYSTABLES while checking if it's an alias.
    An internal operation did not find a record for the requested alias in SYSIBM.SYSTABLES. This usually indicates an inconsistency in your catalog tables.
  • XU031: Object name is not an alias.
    The alias requested by an internal operation is not defined as an alias in the SYSIBM.SYSTABLES. This usually indicates an inconsistency in your catalog tables.
  • XU032: Error Querying SYSTABLES
    An internal operation encountered an error while attempting to get alias information from SYSTABLES.
Parent topic: Error Messages


Bind Utility

  • Bind Utility Window
  • Bind Package Dialog Box
  • Bind Options Dialog Box
  • Format Options Dialog Box
  • Rebind Package Dialog Box
  • Rebind Options Dialog Box
  • Drop Package Dialog Box
  • Create Default DBRM Dialog Box
Parent topic: User Interface Reference


Bind Utility Window

The following fields and controls are used in the Bind Utility window:

Remote Location
The drop-down list contains all the registered remote locations on the XDB Link. You cannot bind, rebind or drop a package until you select a location from this list.

Use the Gateway Profile Utility to register remote locations.

Current SQLID
Specifies the AuthID under which the bind will be executed. By default, your AuthID appears here.
Note: Do not change this field if you are creating the default package for XDB Link. The AuthID used to log on with the Bind Utility must match the primary AuthID on DB2, and must have the authority (in DB2) to run the initial bind.
Continue on Error
Enables the Bind Utility to continue processing when an error occurs.
Bind
To create a default package for XDB Link, or to modify an existing package, click the Bind button.
Rebind
To change options for an existing package without reading the DBRM, click the Rebind button.
Drop
To delete a package from the DB2 location, click the Drop button.
Default
To create a default DBRM, which you will need in order to create the default package for XDB Link, click Default.
Parent topic: Bind Utility


Bind Package Dialog Box

The following fields and controls are used in the Bind Package dialog box:

Bind Location
The Remote Location you selected in the Bind Utility main window. You cannot modify this field. Click Cancel to return to the main window if you need to select a different Remote Location.
Collection Identifier
The Collection ID of the DBRM you select from the DBRM File Name drop-down list. You cannot modify this field.
Package Name
The package name of the DBRM you select from the DBRM File Name drop-down list. The Bind Utility assigns this name to the package it creates. You cannot modify this field.
DBRM File Name
The drop-down list contains all of the DBRMs (.DBR files) in the XDB application directory on your workstation.
Package Version
If you are maintaining multiple versions of a program, assign a different number for each version of the package. This field is optional.
Note:

If the host on which you are binding this package does not support package versions, leave this field blank.

Isolation Level
Controls the manner in which locks are acquired and released by the system.
No Commit
Allows your program to read modified records even if they haven’t been committed by another process.
Change
If you are using a read-only cursor:
  • Allows your program to read modified records even if they haven’t been committed by another process.
  • Allows other processes to change a record that your application reads, even if your cursor is on that record.

If you are using a non-read-only cursor:

  • Prevents your program from reading a modified record that hasn’t been committed by another process.
  • Prevents other processes from changing a record while your cursor is on it.
Cursor Stability
Allows other processes to change a row that your application reads, but does not change, as long as your cursor is not on that row.

Prevents other processes from changing records that your application has changed until your program commits them or terminates.

Prevents your program from reading a modified record that hasn’t been committed by another process.

All
Prevents other processes from changing records that are read or changed by your application until your program commits them or terminates.

Prevents your application from retrieving a modified record that hasn’t yet been committed by another process when it opens a read-only database cursor.

If your program opens the same query during a single unit of work under this isolation level, the results table may differ from the previous one because it may include committed changes from other processes.

Repeatable Read
Prevents other processes from changing records that are read or changed by your application (including phantom records) until your program commits them or terminates.

Prevents the application from reading a modified record that hasn’t been committed by another process.

If your program opens the same query during a single unit of work under this isolation level, the results table will be identical to the previous table. However, it may contain updates made by your program.

No Commit
Allows your program to read modified records even if they haven't been committed by another process.
Change
If you are using a read-only cursor:
  • Allows your program to read modified records even if they haven't been committed by another process.
  • Allows other processes to change a record that your application reads, even if your cursor is on that record.

If you are using a non-read-only cursor:

  • Prevents your program from reading a modified record that hasn't been committed by another process.
  • Prevents other processes from changing a record while your cursor is on it.
Cursor Stability
Allows other processes to change a row that your application reads, but does not change, as long as your cursor is not on that row.

Prevents other processes from changing records that your application has changed until your program commits them or terminates.

Prevents your program from reading a modified record that hasn't been committed by another process.

All
Prevents other processes from changing records that are read or changed by your application until your program commits them or terminates.

Prevents your application from retrieving a modified record that hasn't yet been committed by another process when it opens a read-only database cursor.

If your program opens the same query during a single unit of work under this isolation level, the results table may differ from the previous one because it may include committed changes from other processes.

Repeatable Read
Prevents other processes from changing records that are read or changed by your application (including phantom records) until your program commits them or terminates.

Prevents the application from reading a modified record that hasn't been committed by another process.

If your program opens the same query during a single unit of work under this isolation level, the results table will be identical to the previous table. However, it may contain updates made by your program.

Action
One of the following options:
  • Replace replaces an existing package with a new package. To replace the version label, enter a new label in the Replace Version field in the Bind Options dialog box.
  • Add creates a new package if one does not already exist. If a package with the current Collection ID already exists, the bind process will fail.
Bind
To set optional parameters for the bind, click the Bind button. This command button is available only when you select a file from the DBRM File Name drop-down list.
Format
To specify data formats associated with the selected DBRM, click the Format button. This command button is available only when you select a file from the DBRM File Name drop-down list.
Parent topic: Bind Utility


Bind Options Dialog Box

The following fields and controls are used in the Bind Options dialog box:

Replace Version | Specifies the new version name for a replacement package. This field is available only when you select the Replace option from the Action drop-down list in the Bind Package dialog box.
Replace Authorization One of the following options:
  • Retain uses the SQLID assigned to the existing package on the host.
  • Revoke uses the current SQLID specified in the Bind Utility window.

This field is available only when you select the Replace option from the Action drop-down list in the Bind Package dialog box.

Creation Control One of the following options:
  • No Error Allowed does not create a package if an error occurs during the bind process.
  • Error Allowed creates a package even if an error occurs during the bind process.
  • Check Only executes the bind without creating a package. Use this option to test the bind operation without actually creating a package.
Existence Checking One of the following options:
  • Optional creates a package even if database objects referenced in the DBRM do not exist. Use this option to create a package prior to defining all data objects.
  • Required creates a package only if all database objects referenced in the DBRM exist.
Blocking Protocol One of the following options:
  • Single Row returns data one row at a time for all cursors that are read-only or are ambiguous. This option provides maximum control of data transfer.
  • Limited Block returns data in blocks (of the size you have specified in the Gateway Profile Utility) for all cursors that are read-only or are ambiguous. This option can improve performance significantly. It provides maximum data-transfer speed. For more information about specifying block size, see your Link Configuration Guide.
  • Forced Single Row returns data one row at a time regardless of the read-only status of the cursor.
Resource Release One of the following options:
  • Commit releases database resources after a commit. Provides a high level of concurrency.
  • Deallocation releases database resources when the connection is terminated.
Explain One of the following options:
  • No Statements disables the EXPLAIN option to create the package without generating descriptive information.
  • All Statements enables the EXPLAIN option to write descriptive information about the package to owner.PLAN_TABLE. This table must exist before you execute the bind.
Package Owner | The AuthID assigned to the package. This DB2 AuthID must have authority to execute all the SQL in the package.
Default Qualifier | The AuthID used to complete any unqualified (one-part) table names in the DBRM file. If you leave this field blank, the Bind Utility uses the current SQLID.
Dynamicrules Controls the behavior of dynamic SQL with regard to one part name qualification and permissions checking:
  • DYNAMIC RULES RUN: The AuthID used for checking permissions of dynamic SQL statements will be the value of the CURRENT SQLID special register. The default value of the CURRENT SQLID special register is the AuthID of the process. Users with SYSADM authority can change their CURRENT SQLID special register to any value and users with secondary AuthIDs can change their CURRENT SQLID special register to be any of their secondary AuthIDs.

    The AuthID used for qualifying one part names of tables, views, etc. will be the value of the CURRENT SQLID special register. As stated above, the special register value can be changed under certain circumstances.

There are no restrictions on commands that can be executed.

  • DYNAMIC RULES BIND: The AuthIDs of the package is used for checking permissions of dynamic SQL statements.

    The value of the Default Qualifier text box will be used for qualifying one part names of tables, views, etc. If the Default Qualifier text box is left blank, the AuthIDs of the package is used for qualifying one part names of tables, views, etc.

    When this option is in effect, you cannot issue the following dynamic SQL statements: ALTER, CREATE, DROP, GRANT, RENAME, and REVOKE.

If left blank, this option defaults to DYNAMIC RULES RUN.

Parent topic: Bind Utility


Format Options Dialog Box

The following fields and controls are used in the Format Options dialog box:

String Delimiter
The type of quotes (single or double) used to represent constant string values that are referenced by the SQL in the DBRM. This option should match the option used to delimit the literal strings referenced by your embedded SQL.
Note: When you are binding the default DBRM for XDB Link, you must use the Single Quote option.
Decimal Delimiter
You must set this field if the DBRM file contains a decimal literal that does not match the host system's default value.
  • Period indicates that the decimal point is represented with a period (for example 3.17).
  • Comma indicates that the decimal point is represented with a comma (for example 3,17).
Default Decimal Precision
One of the following options:
  • 0 uses the system default value.
  • 15 specifies a decimal precision of 15 places.
  • 31 specifies a decimal precision of 31 places.
Default Char Subtype
Options for storing ambiguous character data in the database:
  • System Default specifies the system default value of the DB2 location to which you are binding.
  • SBCS specifies a single-byte character set.
Parent topic: Bind Utility


Rebind Package Dialog Box

The following fields and controls are used in the Rebind Package dialog box:

Bind Location
The Remote Location you selected in the Bind Utility main window. You cannot modify this field. Click Cancel to return to the main window if you need to select a different Remote Location.
Collection Identifier
The Collection ID of the package selected from the Package drop-down list. You cannot modify this field.
Package Name
The name of the package selected from the Package drop-down list. You cannot modify this field.
Package
The drop-down list contains all of the packages on the host that are owned by the current SQLID.
Package Version
If you are maintaining multiple versions of a program, assign a different number for each version of the package. This field is optional.
Note: If the host on which you are binding this package does not support package versions, leave this field blank.
Isolation Level
Controls the manner in which locks are acquired and released by the system.

The options are:

No Commit
Allows your program to read modified records even if they haven’t been committed by another process.
Change
If you are using a read-only cursor:
  • Allows your program to read modified records even if they haven’t been committed by another process.
  • Allows other processes to change a record that your application reads, even if your cursor is on that record.

If you are using a non-read-only cursor:

  • Prevents your program from reading a modified record that hasn’t been committed by another process.
  • Prevents other processes from changing a record while your cursor is on it.
Cursor Stability
Allows other processes to change a row that your application reads, but does not change, as long as your cursor is not on that row.

Prevents other processes from changing records that your application has changed until your program commits them or terminates.

Prevents your program from reading a modified record that hasn’t been committed by another process.

All
Prevents other processes from changing records that are read or changed by your application until your program commits them or terminates.

Prevents your application from retrieving a modified record that hasn’t yet been committed by another process when it opens a read-only database cursor.

If your program opens the same query during a single unit of work under this isolation level, the results table may differ from the previous one because it may include committed changes from other processes.

Repeatable Read
Prevents other processes from changing records that are read or changed by your application (including phantom records) until your program commits them or terminates.

Prevents the application from reading a modified record that hasn’t been committed by another process.

If your program opens the same query during a single unit of work under this isolation level, the results table will be identical to the previous table. However, it may contain updates made by your program.

Bind
To set optional parameters for the package you are rebinding, click the Bind button.
Parent topic: Bind Utility
Related information
Overview


Rebind Options Dialog Box

The following fields and controls are used in the Rebind Options dialog box:

Existence Checking
One of the following options:
  • Optional creates a package even if database objects referenced in the DBRM do not exist. Use this option to create a package prior to defining all data objects.
  • Required creates a package only if all database objects referenced in the DBRM exist.
Resource Release
One of the following options:
  • Commit releases database resources after a commit. Provides a high level of concurrency.
  • Deallocation releases database resources when the connection is terminated.
Explain
One of the following options:
  • No Statements disables the EXPLAIN option to create the package without generating descriptive information.
  • All Statements enables the EXPLAIN option to write descriptive information about the package to owner.PLAN_TABLE. This table must exist before you execute the bind.
Package Owner
The AuthID assigned to the package. This DB2 AuthID must have authority to execute all the SQL in the package.
Default Qualifier
The AuthID used to complete any unqualified (one-part) table names in the DBRM file. If you leave this field blank, the Bind Utility uses the current SQLID.
Parent topic: Bind Utility


Drop Package Dialog Box

The following fields and controls are used in the Drop Package dialog box:

Bind Location
The Remote Location you selected in the Bind Utility main window. You cannot modify this field. Click Cancel to return to the main window if you need to select a different Remote Location.
Collection Identifier
The Collection ID of the package selected from the Package drop-down list. You cannot modify this field.
Package Name
The name of the package selected from the Package drop-down list. You cannot modify this field.
Package Name
The drop-down list contains all of the packages on the host that are owned by the current SQLID.
Parent topic: Bind Utility


Create Default DBRM Dialog Box

The following fields and controls are used in the Create Default DBRM dialog box:

Collection ID
The Default Collection ID value you specified in the Gateway Profile utility when you configured XDB Link for the mainframe location.
Package Name
The default Package Name you specified in the Gateway Profile utility when you configured XDB Link for the mainframe location.
Host System
The drop-down list contains options for specifying the type of host system to which you want to bind XDB Link.
Dynamic Sections
The number of statements that the XDB Link package can prepare for a single user.
Parent topic: Bind Utility


The Declaration Generator Window

The following fields and controls in the Declaration Generator window are used to create declaration files in COBOL, C or PL/I.

Generate | Generates a declaration file according to the specifications that have been defined in the Declaration Generator window.
Save As Saves the current specifications to a .DGE file. A .DGE file can be used as input to the Declaration Generator when it is run in batch mode. See Running in Batch Mode for more information about .DGE files and batch mode.

If you specify the name of an existing .DGE file, you will be asked whether the current specification should replace the existing file or be appended to it.
Options | Allows you to set options that are specific to the language you have selected.
Exit | Closes the Declaration Generator window.
Location | Specifies the location of the table.
AuthID Specifies the access authority under which you will access the table. In order to create a declaration file, you must have SELECT privileges on the table for which you are generating a declaration, and on the following system tables:
  • SysIBM.SYSLOCATIONS
  • SysIBM.SYSTABLES
  • SysXDB.SYSACFUsers
Table Name | Identifies the table for which the declaration file will be generated.
Declaration | The fields in this group box determine how the declaration file is written.
Output File Specifies the file to which the declaration statements will be written. If you do not specify a path, the file is written to the application path (specified in the PATHS tab in Options) when you select C, or the value of the COBCPY environment variable when you select COBOL or PL/I.

A default file name is automatically created based on the name of the table you select and the language you specify. You can change this name by typing a new one in this field.

If you specify a file that already exists, you will be prompted at run time to choose whether you want to replace the existing file or append the statements to it.
Structure Name | Specifies the name of the record definition (COBOL), structure (C) or declaration structure (PL/I) written to the declaration file. A default name is automatically created based on the name of the table you select and the language you specify. You can change this name by typing a new one in this field.
Language | The LANGUAGE group box is used to select the programming language in which you want the declaration written. You can select COBOL, C or PL/I.
Text Assign a prefix to each field name as it is written into the declaration file. The following shows how field names would be treated if a prefix of emp_ were used.

Remember to take into account your compiler's variable-naming guidelines when assigning a prefix. Do not assign one containing characters that are disallowed by the programming language or that make the variable's name too long.
Generate | Generates a declaration file according to the specifications that have been defined in the Declaration Generator window.
Save As Saves the current specifications to a .DGE file. A .DGE file can be used as input to the Declaration Generator when it is run in batch mode. See Running in Batch Mode for more information about .DGE files and batch mode.

If you specify the name of an existing .DGE file, you will be asked whether the current specification should replace the existing file or be appended to it.
Options | Allows you to set options that are specific to the language you have selected.
Exit | Closes the Declaration Generator window.
Location | Specifies the location of the table.
AuthID Specifies the access authority under which you will access the table. In order to create a declaration file, you must have SELECT privileges on the table for which you are generating a declaration, and on the following system tables:
  • SysIBM.SYSLOCATIONS
  • SysIBM.SYSTABLES
  • SysXDB.SYSACFUsers
Table Name | Identifies the table for which the declaration file will be generated.
Declaration | The fields in this group box determine how the declaration file is written.
Output File Specifies the file to which the declaration statements will be written. If you do not specify a path, the file is written to the application path (specified in the PATHS tab in Options) when you select C, or the value of the COBCPY environment variable when you select COBOL or PL/I.

A default file name is automatically created based on the name of the table you select and the language you specify. You can change this name by typing a new one in this field.

If you specify a file that already exists, you will be prompted at run time to choose whether you want to replace the existing file or append the statements to it.
Structure Name | Specifies the name of the record definition (COBOL), structure (C) or declaration structure (PL/I) written to the declaration file. A default name is automatically created based on the name of the table you select and the language you specify. You can change this name by typing a new one in this field.
Language | The LANGUAGE group box is used to select the programming language in which you want the declaration written. You can select COBOL, C or PL/I.
Text Assign a prefix to each field name as it is written into the declaration file. The following shows how field names would be treated if a prefix of emp_ were used.

Remember to take into account your compiler's variable-naming guidelines when assigning a prefix. Do not assign one containing characters that are disallowed by the programming language or that make the variable's name too long.
Numbered | Replaces a field name with a number in the declaration file. This option can be selected only when a field prefix is assigned in the TEXT field. The following example shows how field names would be treated if the NUMBERED option were set with a prefix of emp_.
If the Field name is... | It will be written as...
ssn | emp_ssn
lname | emp_lname
fname | emp_fname
If the Field name is... | It will be written as...
ssn | emp_001
lname | emp_002
fname | emp_003
 | Numbered | Replaces a field name with a number in the declaration file. This option can be selected only when a field prefix is assigned in the TEXT field. The following example shows how field names would be treated if the NUMBERED option were set with a prefix of emp_.
Computation | Specifies the internal storage format assigned to binary integers in a COBOL record description. The choices are COMP, COMP-4 and COMP-5.
Computation Specifies the internal storage format assigned to binary integers in a COBOL record description. The choices are COMP, COMP-4 and COMP-5.
Parent topic: User Interface Reference


Link Utility

  • Gateway Facility Main Window Options
  • Location Configuration Window
  • Workstation Configuration Window
Parent topic: User Interface Reference


Gateway Facility Main Window Options

Select the task you need to perform, or click Close to close this window and exit the Gateway Profile Utility. If you are configuring the Link on a machine where the XDB Server is installed, the Status field shows the status of your connection to the server.

Register... Displays the Location Configuration window, which you use to add, modify, and delete remote locations. Each remote data location (including the location for Password Expiration Manager) must be configured with the Gateway Profile utility before it can be accessed through the Link.
Local... Displays the Workstation Configuration window, which you use to configure the:
  • Code pages the Link uses to translate data
  • Number of clients that can connect to a data source through the Link
  • Settings that control client conversations with the host
Parent topic: Link Utility
Related information
Location Configuration Window
Workstation Configuration Window


Location Configuration Window

Use the Location Configuration window to:

  • Define a new remote location to the Link
  • Modify an existing definition for a remote location
  • Delete an existing definition for a remote location

You must define a remote location to the Link before client applications can access the data in that location. Remote locations include data sources such as DB2 subsystems and other XDB Servers. If you plan to use XDB's Password Expiration Manager (PEM), you must configure a connection between the Link and the PEM module on the mainframe by defining a remote location.

To open the Location Configuration window, click Register on the main window of the Gateway Profile Utility.

The Location Configuration window is divided into the following sections:

  • General controls (those with no label) and Host Code Pages settings apply to all location types.
  • APPC Setup applies only to DRDA(APPC) and PEM(APPC) connection types.
  • TCP/IP Setup applies only to DRDA(TCP/IP), XDBHOST, and PEM(TCP/IP) connection types.
  • DRDA Setup applies only to DRDA(APPC) and DRDA(TCP/IP) connection types.
Parent topic: Link Utility
Related information
Gateway Facility Main Window Options
Workstation Configuration Window


Workstation Configuration Window

Use the Workstation Configuration window to configure settings that XDB Link uses to control conversations between the client application and the host system.

To access the Workstation Configuration window, click Local in the Gateway Profile Utility window.

Workstation Code Pages

The values in this group box specify the code pages that represent the national-language format for client workstations using XDB Link. If you are using English (US) machines, leave these settings at their default values. For any other language, enter the code page value for that language. If you are using the XDB Server as your gateway server, you must restart the XDB Server after changing any code page values.
Single Specify the single-byte code page value for client machines connecting to the host through XDB Link. XDB Link converts single-byte character data received from the host through this code page before sending it to the client workstation. It also uses this as the code page identifier for single-byte character data that it transmits to the host. The default is 850.

If you connect through a gateway server, enter the PC's OEM code page. In the United States, the default is 437.

If you connect as a direct client to DB2, enter the ANSI code page value. In the United States, the default is 1252.

If you use binary data or for bit data fields with COBOL programs, set the single code page setting to 911. If you are using the 911 code page while connected to a DB2 host and want to connect to a DB2 host which uses a different code page than that of the current DB2 host, you must restart the server prior to connecting to the new host.

To determine your PC's OEM and ANSI code page settings: at a DOS prompt, change (cd) to the install directory and type codepage.
Mixed | Specify the mixed-byte code page value for client machines connecting to the host through XDB Link. XDB Link converts mixed-byte character data received from the host through this code page before sending it to the client workstation. It also uses this as the code page identifier for mixed-byte character data that it transmits to the host. The default is 932.
Double | Specify the double-byte code page value for client machines connecting to the host through XDB Link. XDB Link converts double-byte character data received from the host through this code page before sending it to the client workstation. It also uses this as the code page identifier for double-byte character data that it transmits to the host. The default is 301.
Close Conversation | Select the setting that determines when XDB Link closes an LU 6.2 conversation. At Dealloc closes the conversation when the client application terminates. At Commit closes the conversation after the client application executes a COMMIT statement. Use the default value, At Dealloc, unless you are tuning the system for OLTP applications or you want to prevent an application from tying up host resources when a client leaves it idle for an extended period of time.
Maximum Clients | Specify the maximum number of concurrent client sessions that XDB Link can carry. Permitted values are 1 to 128. For an XDB Server, select a value that will comfortably accommodate the number of users that will simultaneously access the host system through XDB Link. In a Direct Configuration, use a small value to reduce XDB Link's memory requirements (unused client sessions needlessly consume memory on your machine).
User Buffer Size Specify the size (in kilobytes) of the bulk packet that XDB Link uses to download data from the host. Permitted values are 1 to 63. For most environments, the default value is sufficient. However, adjusting the value can optimize certain client applications:
  • For client applications that frequently download large amounts of data, a large buffer size can improve response time.
  • For client applications that perform brief, online transactions, a small buffer will maximize memory on the machine where XDB Link is installed.
Parent topic: Link Utility
Related information
Gateway Facility Main Window Options
Location Configuration Window


Migrate Utility

  • The Migrate Window
  • The Table Tab
  • The Query Tab
  • The Migrate Options Dialog Box
  • The Migrate Database Dialog Box
  • The Table Options Dialog Box
  • The Run Dialog Box
  • The Default Options Dialog Box
  • The Query Options Dialog Box
  • The Query Update Rules Dialog Box
  • The Control Menu
  • The File Menu
  • The Edit Menu
  • The View Menu
  • The Object Menu
  • The Commands Menu
  • The Options Menu
  • The Help Menu
  • The Window Menu
Parent topic: User Interface Reference


The Migrate Window

Once a connection to a server is established, the Migrate window appears. This window contains tools and controls for selecting source tables, specifying a destination and setting migration parameters.

The Menu bar contains Migrate commands you can use to specify migrate options and launch a migration. For a description of each command on the Menu bar, see The Migrate Menus.

The Toolbar contains the following icons that provide quick access to a particular command or function.

Icon | Description
* | Opens the Catalog Browser if it is not already open. If the Catalog Browser is open, this button refreshes its contents.
* | Lets you specify options for the selected table or a query.
* | Runs a migration of the specified tables using the specified parameters.
* | Opens Migrate help.

The Catalog Browser is used to select tables and queries that you want to migrate to another location (i.e., specify the source tables or queries). For more information about the Catalog Browser, see The Catalog Browser.

The Schema Viewer graphically displays the source tables that have been selected for migration. From this window, you can set options, and display dependent and referenced tables. For more information about the Schema Viewer, see The Schema Viewer.

Parent topic: Migrate Utility


The Table Tab

*
Use the Table tab in the Catalog Browser to locate and select the tables you want to migrate. To show tables in the Browser, click the Table tab on left side of the Catalog Browser window.

To locate a table, click the + buttons to expand the database hierarchy until the table name appears.

To select a table for migration, do one of the following:

  • double-click the table name in the Catalog Browser, or
  • highlight the table name, then drag it into the Schema Viewer.

If you want to select multiple tables, hold the Ctrl or Shift key when you click the table name. Shift lets you select a group of consecutive names in the listCtrl lets you select multiple, non-consecutive names.

For information about migrating tables that you have placed in the Schema Viewer, see Migrating Tables.

Parent topic: Migrate Utility


The Query Tab

*
Use the Query tab in the Catalog Browser to recall a saved query that has been created with a data management tool such as SQLWizard. For information about using a query during a migration, see Migrating Certain Rows and Columns.

To view a list of the available saved queries, click the Query tab on the left side of the Browser window.

To locate a query, click the + buttons to expand the database hierarchy until the query name appears.

To recall a saved query from the Query tab, do one of the following:

  • double-click the query name, or
  • highlight the query name, then drag it into the Schema Viewer.

The recalled query is displayed in the Query window. You can edit the query or accept it as is.

Note:

If your recalled query contains SQL statements besides SELECT, we recommend that you remove them before running the migration. The Query window should contain only a single SELECT statement to specify the data that is to be migrated to another table. For more information about migrating data from a query, see Migrating Certain Rows and Columns.

Parent topic: Migrate Utility


The Migrate Options Dialog Box

The Migrate Options dialog box is used to set the default migration options that appear in the Run dialog box when you perform a migration.

The Migrate Options dialog box contains the following controls:

The Output group box

Use this to select defaults for migration output. You can also control whether to execute the migration or not.

Impact Analysis Report
Sets the Impact Analysis Report as a default migration option. The Impact Analysis Report provides detailed information on the tables that will be affected by the migration as it is currently specified. This report is used to analyze the effect of a migration without actually executing it.
Attention: If this report is selected, Migrate will not migrate any information.
Generate SQL
Saves the SQL script file that processes your migration as a default migration option. In the field next to the checkbox, type the name of the file to which you want the SQL script written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new script.
Post Execution Report
Sets the Post Execution Analysis Report as a default migration option This report generates a listing of the source and destination tables that are a part of the migration. In the field next to the checkbox, type the name of the file to which you want the report written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new report.

You can specify the same file name for the Post Execution Report and the Error File to combine these two reports into one file.

Attention: If the Impact Analysis Report checkbox is selected, you can not run a Post Execution Analysis Report.
Error File
Sets the Error File as a default migration option. The error file records migration errors. In the field next to the checkbox, type the name of the file to which you want the report written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new report.

You can specify the same file name for the Post Execution Report and the Error File to combine these two reports into one file.

Browse
Use the Browse button to view a list of filenames on your system. If you want to use an existing file for output, you can select its name from the list.

The Input Files group box

Use this to specify SQL files to be executed during your migration.

Prologue
Causes Migrate to process an SQL script file before it processes the specified tables and queries. In the field next to the checkbox, type the name of the SQL script file to be used.
Epilogue
Causes Migrate to process an SQL script file after it processes the specified tables and queries. In the field next to the checkbox, type the name of the SQL script file to be used.
Parent topic: Migrate Utility


The Migrate Database Dialog Box

Database list | Lists all of the databases defined to SQL Option for DB2.
Migrate Tables list | Lists all of the tables defined in the database or databases selected on the Database list.
Exclude button | Click this to exclude any tables selected on the Migrate Tables list, moving the table name down to the Not Included list.
Options button | Click this to set table options for the selected tables.
Add button | Click this to add tables selected on the Not Included list back to the Migrate Tables list.
Save button | Click this to generate a .mig script file containing the migration information set on this dialog box.
Execute button | Click this to invoke the Run dialog box, where you specify a location to migrate to and kick off the migration process.
Parent topic: Migrate Utility


The Table Options Dialog Box

The Table Options dialog box is used to specify destination parameters and define objects you want migrated with the selected table. You can also use this dialog box to determine how to handle duplicate migrations and how to commit data records.

The Table Options dialog box contains the following controls:

Source | Displays information about the selected source table.
AuthID | Displays the owner of the source table.
Table | Displays the name of the source table.
Tbl Space | Displays the table space name for the source table.
Database | Displays the name of the database the source table was selected from.
Destination | Use the Destination group box to specify information about the destination table.
Auth ID Enter the AuthID associated with the destination table. Changing this field assigns a new owner to the destination table.

If you want Migrate to use the source table's Auth ID by default, select the Default To Source checkbox next to the Auth ID text box in the Default Options dialog box before you select Table Options; Migrate will then automatically populate this field with the proper default value. Otherwise, you will need to specify an Auth ID by typing it in text box.

Table | Enter a name for the destination table.
Tbl Space Enter the table space name for the destination table.

If you want Migrate to use the name of the source table space by default, select the Default To Source checkbox next to the Tbl Space text box in the Default Options dialog box before you select Table Options; Migrate will then automatically populate this field with the proper default value. Otherwise, you will need to specify a table space name by typing it in this text box.

Database Enter the database name for the destination table.

If you want Migrate to use the name of the source database from which the source table is selected by default, select the Default To Source checkbox next to the Database text box in the Default Options dialog box before you select Table Options; Migrate will then automatically populate this field with the proper default value. Otherwise, you will need to specify a database name by typing it in this text box. If this field is left blank, the default database name "DSNDB04" is used.

Primary Key | Select this checkbox if you want primary-key columns in the source table to also be primary-key columns in the destination table.
Unique Keys | Select this checkbox if you want unique-key columns in the source table to also be unique-key columns in the destination table.
Indexes | Select this checkbox if you want the index key in the source table to also be the index key in the destination table.
Foreign Keys | Select this checkbox if you want foreign-key columns in the source table to also be foreign-key columns in the destination table.
Synonyms | Select this checkbox if you want any alternate names for the source table to also be alternate names for the destination table.
Comments | Select this checkbox to migrate comments in the source table to be included on the destination location table.
Privileges | Select this checkbox to migrate privileges. The privileges checkbox lets you place the same security standards on the destination tables as on the source tables.
If Table Already Exists | Use the If Table Already Exists group box to specify what Migrate should do if the table you are migrating already exists at its destination.
Abort | Select this option if you want Migrate to terminate the migration if the destination table already exists.
Append Data Select this option if you want Migrate to append the new table to the existing destination table. If the destination table has no primary key, all records are appended to the destination. You can use this option with the No Data option (see below) to migrate just an index.
Note:

You can end up with duplicate records if you use this option on a table without a primary key.
Replace Data | Select this option if you want Migrate to replace all existing records in the destination table with records from the source table. All data in the existing table will be deleted.
Replace Table | Select this option if you want Migrate to drop the destination table and create a new table containing the result of this migration.
Data Options | Use the Data Options group box to specify how much data should be migrated and to specify a commit rate.
Limit Data To Select the number of records you want to copy.
  • Select All Rows to migrate all data records from the source table to the destination.
  • Select No Data to migrate none of the records from the source table to the destination. You might use this option to create an "empty" destination table (which will have a structure identical to the source) into which you can selectively copy records using Migrate's query feature. Or, you might use it to copy certain table attributes without copying any data.

    The behavior of this option depends on the following:

    • If the destination table does not exist, an "empty" table is created.
    • If the destination table exists, and the Replace Data or Replace Table option is used, the destination table's existing records are deleted and no records are copied (an "empty" table is created).
    • If the destination table exists, and the Append Data option is used, no records are copied to it (you could use this combination of options to copy just an index).
  • Select First N Rows if you only want to migrate the first N records from the source table to the destination.
  • Select Every Nth Row if you want to copy every N records from the source table to the destination.
Commit Work After

Specify the number of records Migrate should accrue before permanently writing them to disk (i.e., issuing a COMMIT statement). You can specify any number between 0 and 32,767. High Commit Work After values produce a faster migration but result in fewer records successfully written should the migration be interrupted.
Parent topic: Migrate Utility


The Run Dialog Box

Use the Run dialog box to execute the currently specified migration. It also can specify certain options for the migration before you begin, and optionally select scripts that can be executed before and/or after the migration is processed. Clicking OK in this dialog starts the migration.

The Run dialog box contains the following controls:

Migrating | Displays the source and destination of the migration. If the destination is not displayed or is incorrect, change it in the To entry box .
 | From | Displays the location of the source table(s). If you have placed tables in the Schema Viewer, this field displays the location of these tables. Note: If you are migrating tables from the Schema Viewer do not change this field. Changing the From field will clear the Schema Viewer.
 | To | Select the location to which you want the selected tables and/or query results migrated. Note: The destination location must exist in order to migrate a table to it. If it does not, you must first create it using a database management tool such as SQLWizard.
Migrate Options | Use Migrate Options to select the reports and files you want Migrate to produce.
 | Execute Migrate | Determines whether or not any data is migrated when you run a migration. When enabled, Migrate performs a normal migration. When disabled, Migrate executes the migration but does not actually copy any data to the specified destination. This lets you obtain an SQL stream without actually migrating any data. Note: If this checkbox is selected, you cannot generate an Impact Analysis Report.
 | Impact Analysis | Select this checkbox to generate a report that provides detailed information about the migration as it is currently specified. This report lets you analyze the effect of a migration without actually executing it. Type the name of the file to which you want the report written in the field next to the checkbox. Note: When this report is selected, Migrate will not create or copy any information. The entire migration, including queries is executed step-by-step, but no tables are created and no data is written.
 | Generate SQL | Select this checkbox if you want to save the SQL that processes your migration. In the field next to the checkbox, type the name of the file to which you want the SQL script written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new script.
 | Post Execution Analysis Report | Select this checkbox to generate a listing of the source and destination tables that are part of the migration. In the field next to the checkbox, type the name of the file to which you want the report written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new report. You can specify the same file name for the Post Execution Report and the Error File to combine these two reports into one file.
 | Error File | Select this checkbox to record migration errors in a file. In the field next to the checkbox, type the name of the file to which you want the report written. If this file does not exist, Migrate creates it. If it exists, Migrate overwrites it with the new report. You can specify the same file name for the Post Execution Report and the Error File to combine these two reports into one file.
Parent topic: Migrate Utility


The Default Options Dialog Box

The Default Options dialog box is used to assign default migration options for tables and queries.

The Default Options dialog box contains the following controls:

Destination | The options in this group box specify the default destination information for the selected table or query.
Auth ID Enter the AuthID associated with the destination table. Changing this field assigns a new owner to the destination table.

Select the Default To Source checkbox next to this field to indicate that you want to use the source table's Auth ID by default.

Tbl Space Enter the table space name for the destination table.

Select the Default To Source checkbox next to this field to indicate that you want to use the name of the source table space by default.

Database Enter the database name for the destination table.

Select the Default To Source checkbox next to this field to indicate that you want to use the name of the source database by default.

If Table Already Exists | Use the If Table Already Exists group box to specify what Migrate should do if the table you are migrating already exists at its destination.
Abort | Select this option if you want Migrate to terminate the migration if the destination table already exists.
Append Data Select this option if you want Migrate to append the new table to the existing destination table. If the destination table has no primary key, all records are appended to the destination. You can use this option with the No Data option (see below) to migrate just an index.
Note:

You can end up with duplicate records if you use this option on a table without a primary key.
Replace Data | Select this option if you want Migrate to replace all existing records in the destination table with records from the source table. All data in the existing table will be deleted.
Replace Table | Select this option if you want Migrate to drop the destination table and create a new table containing the result of this migration.
Limit Data To Select the number of records you want to copy.
  • Select All Rows to migrate all data records from the source table to the destination.
  • Select No Data to migrate none of the records from the source table to the destination. You might use this option to create an "empty" destination table (which will have a structure identical to the source) into which you can selectively copy records using Migrate's query feature. Or, you might use it to copy certain table attributes without copying any data.

    The behavior of this option depends on the following:

    • If the destination table does not exist, an "empty" table is created.
    • If the destination table exists, and the Replace Data or Replace Table option is used, the destination table's existing records are deleted and no records are copied (an "empty" table is created).
    • If the destination table exists, and the Append Data option is used, no records are copied to it (you could use this combination of options to copy just an index).
  • Select First N Rows if you only want to migrate the first N records from the source table to the destination.
  • Select Every Nth Row if you want to copy every N records from the source table to the destination.
Commit Work After | Specify the number of records Migrate should accrue before permanently writing them to disk (i.e., issuing a COMMIT statement). You can specify any number between 0 and 32,767. High Commit Work After values produce a faster migration but result in fewer records successfully written should the migration be interrupted.
Migrate

Use the Migrate group box to select the objects you want to migrate with a table.
Primary Key | Select this checkbox if you want primary-key columns in the source table to also be primary-key columns in the destination table.
Unique Keys | Select this checkbox if you want unique-key columns in the source table to also be unique-key columns in the destination table.
Indexes | Select this checkbox if you want the index key in the source table to also be the index key in the destination table.
Foreign Keys | Select this checkbox if you want foreign-key columns in the source table to also be foreign-key columns in the destination table.
Synonyms | Select this checkbox if you want any alternate names for the source table to also be alternate names for the destination table.
Comments | Select this checkbox to migrate comments in the source table to be included on the destination location table.
Privileges | Select this checkbox to migrate privileges. The privileges checkbox lets you place the same security standards on the destination tables as on the source tables.
Distinct Type | Select this checkbox to migrate distinct types used by the source table.
Parent topic: Migrate Utility


The Query Options Dialog Box

The Query Options dialog box is used to specify how you want the results of a query migrated. For example, you can specify what action Migrate should take if the destination table already exists, or how many total records from the result should be copied.

The Query Options dialog box contains the following controls:

Destination | This group box displays the destination information for the selected query.
Auth ID | Enter the AuthID associated with the table produced by the query.
Table | Enter a table name for the table produced by the query.
Tbl Space Enter the table space name for the result of the query.

If a table space name isn't specified, the destination table name is used.
Database Enter the database name for the table produced by the query.

If a database name isn't specified, the default database name "DSNDB04" is used.
If Table Already Exists | Use the If Table Already Exists group box to determine what to do if the there is an existing table with the same name as the table produced by the query.
Abort | Select this option if you want Migrate to terminate the migration if the destination table already exists.
Append Data Select this option if you want Migrate to append the new table to the existing destination table. If the destination table has no primary key, all records are appended to the destination. You can use this option with the No Data option (see below) to migrate just an index.
Note:

You can end up with duplicate records if you use this option on a table without a primary key.
Replace Data | Select this option if you want Migrate to replace all existing records in the destination table with records from the source table. All data in the existing table will be deleted.
Replace Table | Select this option if you want Migrate to drop the destination table and create a new table containing the result of this migration.
Update No Insert | Select this option if you want Migrate to update data only if the row with they key already exists.
Update Insert | Select this option if you want Migrate to update existing data or insert the row if it doesn't already exist.
Delete Match | Select this option if you want Migrate to delete an existing matching row.
Limit Data To Select the number of records you want to copy.
  • Select All Rows if you want to migrate all data records of the query result.
  • Select No Data to migrate none of the records from the source table to the destination. You might use this option to create an "empty" destination table (which will have a structure identical to the source) into which you can selectively copy records using Migrate's query feature. Or, you might use it to copy certain table attributes without copying any data.

    The behavior of this option depends on the following:

    • If the destination table does not exist, an "empty" table is created.
    • If the destination table exists, and the Replace Data or Replace Table option is used, the destination table's existing records are deleted and no records are copied (an "empty" table is created).
    • If the destination table exists, and the Append Data option is used, no records are copied to it (you could use this combination of options to copy just an index).
  • Select First N Rows if you only want to migrate the first N records from the source table to the destination.
  • Select Every Nth Row if you want to copy every N records from the source table to the destination.
Commit Work After | Specify the number of records Migrate should accrue before permanently writing them to disk (i.e., issuing a COMMIT statement). You can specify any number between 0 and 32,767. High Commit Work After values produce a faster migration but result in fewer records successfully written should the migration be interrupted.
Parent topic: Migrate Utility


The Query Update Rules Dialog Box

The Query Update Rules dialog box appears when you click the Update Rule button from the Query dialog box. It is available only if you chose the Update No Insert or Update Insert options in the Query Options dialog box. Use this window to specify the key field, and to select specific update rules for each field in the selected row.

Parent topic: Migrate Utility


The Control Menu

Each table in the Schema Viewer has a Control menu you can use to set table options, select referenced tables and remove a table from a migration. Click the table's Control-menu button to select these commands.

The Control menu contains the following commands:

Table Options Specifies the table's destination parameters and to define objects you want migrated with the table. You can also use this command to specify how to handle duplicate migrations and how to commit data records.

Each table in a migration has its own distinct set of table options. You can use the Table/Query Defaults command on the Options menu to set default table options for your migration.

The Table Options command performs the same function as the Table/Query Options command on the Object menu.
Migrate Determines whether the table is migrated or not. A check mark next to the Migrate command includes the table in the migration. If you deselect the Migrate command (i.e., remove the check mark), the table remains in the Schema Viewer, but is excluded from the migration.
Show Dependent Automatically migrates any table that references the selected table. When you select this command, Migrate automatically places this table's dependent tables in the Schema Viewer.

This Show Dependent command performs the same function as the Show Dependent command on the Object menu.
Show Referenced Automatically migrates any table that is referenced by this table. When you select this command, Migrate automatically places this table's referenced tables in the Schema Viewer.

This Show Referenced command performs the same function as the Show Referenced command on the Object menu.
Remove Takes the table out of the Schema Viewer. If a table is removed from the Schema Viewer, it is not included in the migration. (Only tables within the Schema Viewer are migrated.)

This Remove command performs the same function as the Remove command on the Object menu.
Parent topic: Migrate Utility


The File Menu

The File menu contains commands for opening new or existing migrate files, (MIG), and other objects, as well as for printing and saving. The Exit command is located under this menu.

The File menu contains the following commands:

New | Opens a new Schema Viewer window. If a Schema Viewer is already open, it is closed before the new one is opened.
Open Displays a dialog box to open existing migration (MIG) files.

When you open a MIG file, the specifications from the file replace the current migrations specifications. If you want to preserve your current specifications, save them using the Save or Save As command before opening a MIG file.
Close | Closes the active window.
Save Saves your current Migrate specifications to the open MIG file. (A MIG file records your table, query and option choices so that you can rerun a migration without having to respecify it manually.)
Note:

You must activate the Schema Viewer to use the Save command. If the Catalog Browser or a Query window is active, the Save command is grayed.

If Migrate specifications have not yet been saved, the Save command displays the Specify Batch File dialog box for you to specify a directory and file name.

Migrate specifications can be saved only after you have completed the Table Options dialog box.
Save As Displays the Save As dialog box to save the current Migrate specifications to a new MIG file. (A MIG file records your table, query and option choices so that you can rerun a migration without having to respecify it manually.)

The Save As command can also be used to save the contents of a Query window to an SQL file. If a Query window is active when you select Save As, you can select *.SQL in the List Files of Type field to save the active query to an SQL script file, or you can select *.MIG to save all migration specifications to a MIG file.

Migrate specifications can be saved only after you have completed the Table Options dialog box.
Execute Batch Runs a migration that has been saved to a MIG file. This command displays the Select Batch File dialog box from which you can select the MIG file you want to run. When you click OK, the migration is immediately executed.

Running a migration with the Execute Batch command does not affect the current migration specifications.

Print Prints the contents of the active window. The contents of the Query window, the SQL window and Migrate report windows (such as an Impact Analysis Report) can be printed. To print a Migrate report, you must first open it using the report commands on the View menu (e.g., the Post Execution Analysis command).

Selecting Print displays a dialog box, letting you specify the pages and number of copies you want to print.
Exit | Exits the program. Before exiting, Migrate prompts you to save any open windows that have changed.
Parent topic: Migrate Utility


The Edit Menu

The Edit menu allows you to cut, copy and paste data to and from the Query window.

The Edit menu contains the following commands:

Cut | Removes statements from the SQL window or the Query window and copies them to the Clipboard.
Copy | Copies statements from the Query window to the Clipboard.
Paste | Pastes statements from the Clipboard into the Query window.
Parent topic: Migrate Utility


The View Menu

The View menu lets you redisplay the Catalog Browser if it has been closed. It also lets you display Migrate reports. Once a migration report is displayed, you can print it by selecting Print on the File menu.

The View menu contains the following commands:

View Browser | Displays the Catalog Browser. You can also use the View Browser * button on the toolbar to invoke this command.
Refresh Browser | Refreshes the contents of the Catalog Browser. You must do this at the end of a migration to display the names of the newly-migrated tables.
Impact Analysis | Displays the Impact Analysis Report. To display a report other than the last one, specify the file using Migrate on the Options menu before you select Impact Analysis. You can review this report online or print it using Print on the File menu.
Post Execution Analysis | Displays the Post Execution Analysis Report generated by the last migration. This report displays an analysis of the migration after you execute a migration. To display a report other than the last one, specify the file using Migrate on the Options menu before you select Post Execution Analysis. You can review this report online or print it using Print on the File menu.
SQL | Opens and views an SQL script file. Once a script is open, you can print it or cut and paste it to a Query window.
Batch Commands | Enables you to view the contents of a MIG file. A MIG file contains complete specifications for running a migration. A MIG file can be recalled using Open on the File menu; it can be executed using Execute Batch on the File menu or by calling it from your system command line.
Error File | Displays the error file generated by the last migration. To display a report other than the last one, specify the file using Migrate on the Optionsmenu before you select Error File. You can review this report online or print it using Print on the File menu.
Parent topic: Migrate Utility


The Object Menu

The Object menu provides different commands for manipulating tables, such as, defining defaults, displaying related tables, and how tables are to be displayed. It is also used to define a query.

The Object menu contains the following commands:

Define Query | Opens a Query window. Using this window, you can define a specific SELECT statement to migrate certain rows or columns of a table or to combine data from different tables into one result.
Table/Query Options | Displays the Table Options or Query Options dialog box (depending on whether a Query window or a table in the Schema Viewer is active). Use this command to set specific options for the selected table or query window. Note: To set default options for all subsequent tables and queries, use Table/Query Defaults on the Options menu.
Show Dependent | Automatically places in the Schema Viewer all tables that are dependent on the selected table. You can also invoke this command from the table's Control-menu * button.
Show Referenced | Automatically places in the Schema Viewer all tables that are referenced by the selected table. You can also invoke this command from the table's Control-menu * button.
Remove | Removes the selected table from the Schema Viewer. You can also invoke this command from the table's Control-menu * button.
Roll Up | Displays tables in the Schema Viewer in abbreviated form. When rolled-up, tables are represented by just a table name. Column information is not shown.
Roll Down | Displays tables in the Schema Viewer in detailed form. When rolled-down, the names of columns are listed with the table.
Arrange | Arranges the tables within the Schema Viewer so that lines of reference can be easily seen.
Parent topic: Migrate Utility


The Commands Menu

The Commands menu allows you to execute a migration or a query.

The Commands menu contains the following commands:

Run | Migrates the selected tables and query results. The Run command is available only when a table in the Schema Viewer is selected. You can also use the Run * button on the toolbar to invoke the Run command.
Run SQL | Executes the SQL in the open Query windows without migrating tables that are in the Schema Viewer. Queries are executed in Query window order. The Run SQL command is available only when a Query window is selected.
Parent topic: Migrate Utility


The Options Menu

The Options menu lets you set default options for migrations.

The Options menu contains the following commands:

Migrate | Displays the Migrate Options dialog box. Use this dialog box to select default migration options. Choices selected on this dialog box will be reflected in the Run dialog box
Table/Query Defaults | Displays the Default Options dialog box. Use this dialog box to set default migrate options. Note: The Table/Query Defaults command does not affect the option settings for tables already in the Schema Viewer and/or queries that are already open. Defaults are applied only to tables and queries that are specified from this point forward.
Parent topic: Migrate Utility


The Help Menu

The Help Menu command provides access to Migrate's online help system.

The Help menu contains the following commands:

Contents | Displays the table of contents for Migrate's online help system.
Search For Help On | Displays the Search dialog box, which lets you search for a specific topic by keyword.
Getting Started | Gives you an overview of Migrate.
How Do I . . .? | Displays a list of procedures for using Migrate.
About Migrate | Displays the program's version and copyright information.
Parent topic: Migrate Utility


The Window Menu

The Window menu is a standard system menu used to arrange and size windows and icons, as well as to switch between the currently open document windows.

The Window menu contains the following commands:

Tile | Arranges all open windows in side-by-side fashion (no windows overlap one another).
Cascade | Arranges all open windows in a layered fashion, leaving their title bars and left borders visible.
Arrange Icons | Aligns icons for all minimized windows along the bottom of the application window.
Parent topic: Migrate Utility


Options Utility

  • The Paths Tab
  • The Format Tab
  • The Multiuser Tab
  • The Browser Tab
  • The Query Tab
  • The Query Run Tab
  • The SQL Tab
  • The Security Tab
  • The Summary Tab
  • The Connect Tab
Parent topic: User Interface Reference


The Paths Tab

The PATHS tab allows you to specify where SQLWizard files and other executable files are to be found or written.

XDB Executables Path | Full path specification for the directory where the executable files are found. The Executables Path, also referred to as the default directory, is the directory in which the system searches when looking for executable files, help files and error files.
Default Application Path | The default path for all application files, such as SQL scripts and files used by the batch modes of various Micro Focus utilities. This path is also the default path in which output files are placed by the various utilities. When you save or open an application file, SQLWizard gives you the opportunity to choose a different directory.
Temporary Path | This is the path where the system writes temporary files, such as temporary query result files. Do not enter the root directory of your hard disk, as this could cause problems.
Overflow Temporary Path | This is the full path specification to an alternative directory where the system can write temporary files. Do not enter the root directory of your hard disk, as this could cause problems.
Parent topic: Options Utility


The Format Tab

The FORMAT tab allows you to specify the formats for dates, times, numeric fields, etc.

Date Format | Used to create a picture of the date display format that is used when displaying or entering date values. Choose an International Standard from the list box. Choose LOCAL to define your own date format. You can also set special month and weekday formats. For more information on defining pictures, see Picture Definitions Overview.
 | Standard | Description | Format
 | USA | IBM USA Standard | mm/dd/yyyy
 | EUR | IBM European Standard | dd.mm.yyyy
 | JIS | Japanese Industrial Standard Christian Era | yyyy-mm-dd
Date Picture | A display of the date format you selected. If you select LOCAL for the DATE FORMAT, you can type your own format in the DATE PICTURE field.
Months | Select a picture of the month portion of the date format.
Weekdays Select a picture of the day-of-week portion of the date format. Three formats are available: WW, WWW and WWWW:
  • The WW format causes a number between 1 and 7 to be displayed. 1 corresponds to Monday, 2 to Tuesday, etc.
  • The WWW format displays a three-character text abbreviation (Mon, Tue, etc.).
  • The WWWW format is a string of up to 9 characters that displays the full day of the week in text (Monday, Tuesday, etc.)

For more information on defining pictures, see Picture Definitions Overview.
Time Format This section allows you to specify the default format for displaying or printing time fields. The format is also used for data entry input.

Because the format you select is used as the default time format for display and input in most Micro Focus applications, it is important to select the time mask with care. In some utilities you can override the default time mask by defining masks or pictures for specific columns.

Select from a list of predefined formats (ISO, USA, EUR and JIS). To edit your own time picture position select LOCAL. The cursor will be positioned so that you can enter your own time format. For rules on defining time formats, see Time Pictures Overview.

The following table shows the available time formats.
Standard | Description | Format
USA | IBM USA Standard | hh:mm AM or PM
EUR | IBM European Standard | hh.mm.ss
JIS | Japanese Industrial Standard Christian Era | hh.mm.ss
Time Picture | A display of the time format you selected. If you select LOCAL for the TIME FORMAT, you can type your own format in the TIME PICTURE field.
Time Zone | Used to define the time zone offset from Greenwich Mean Time; this is the difference between your system clock and Greenwich Mean Time (GMT). The intent of the field is to simplify conversion of a timestamp to GMT. To standardize times in your geographically-distributed databases, select the offset from the Time Zone list box. Enter the number of hours offset (-24 to 24) from GMT.
Timestamp Format | Displays the timestamp format used when storing this information in system tables. You cannot change this format.
Numeric Formats | Use this section to specify the following numeric formats. Because the formats you select are used as the default formats for display and input in most Micro Focus utilities, it is important to select the masks with care.
Money Format | Used to define money display/input format. This function allows you to specify the default format for use when displaying or printing money fields. The format is also be used for input in some data entry utilities. Money values are always stored in XDB Server databases as decimal(15,2), but you can set the default money display and input format using this option. Money pictures should be defined according to the rules for numeric picture. See Numeric Masks Overview.
Decimal Format | Used to define decimal display/input format. Decimal values are stored in databases according to the precision and scale you specify, but you can set the default decimal input and display format using this option. Decimal pictures should be defined according to the rules for numeric picture. See Numeric Masks Overview.
Float Decimal Places | Used to specify the default number of decimal places when displaying or printing float fields. XDB Server provides precision of up to 15 places for all float calculations, comparisons and displays. The default precision is set at 2. If you need more than 15 decimal places, use a decimal format instead of float. Decimals can have up to 31 decimal places.
Parent topic: Options Utility


The Multiuser Tab

The Multiuser tab allows you to specify options relating to the use of a multiuser, XDB Server in a networked environment.

Isolation Level XDB Server provides six levels of isolation so users can control the tradeoff between concurrency and consistency:
  • Concurrency is the ability for multiple transactions to access database resources simultaneously.
  • Consistency is the degree to which changes made by one user have no negative effects on other transactions in a multiuser environment.

Within the maximum degree of consistency and minimum degree of concurrency, the isolation levels are:

Exclusive Use | The entire database is locked for exclusive use of the current transaction.
Repeatable Read | All locks are held until commit point to guarantee that transactions can be done serially.
Cursor Stability | Exclusive (read-write) locks are held until commit, and shared (read-only) locks are released when the next record is accessed.
Lock Current | Only the current record is locked. This level should be used with AUTOCOMMIT ON, or for read-only operations.
Dirty Read | No locks are obtained. Uncommitted record changes are read regardless of locks (other than database locks). A DR transaction is read-only; records cannot be modified.
Snapshot Read | At this level, a snapshot of the data is made at the time of execution. Other users can make changes to the data without waiting for the transaction to complete and the user is ensured that the data will be the same for the life of the transaction. An SR transaction is read-only
Time-out Interval | This is the length of time (in seconds) to wait before retrying, when a lock conflict occurs.
AutoCommit | With AUTOCOMMIT on, an SQL command is committed as soon as it is successfully completed. If AUTOCOMMIT is off, the user needs to explicitly commit transactions by issuing an SQL COMMIT command or by selecting COMMIT from a menu in an application. AUTOCOMMIT is not supported against XDB Link locations.
Backward Logging This option is used only when accessing XDB Server Versions 3.x and 4.x. If using XDB Server Version 5.0 or higher, logging is automatic and this option is ignored.

To perform a rollback operation when using the older XDB Server versions, it is necessary to maintain a log of before images of all changes made to the database during a transaction. This information is stored in a backward log. The backward log contains only the information necessary to roll back the current transaction. Every time a transaction is committed or rolled back, the backward log is erased. When the log is turned off, rollback is not possible, but changes to the database take less time because before images are not written to the log.

For more about backward logging on the older XDB Server versions, see the Backup and Recover chapter of the XDB Server Administration Guide for the XDB Server version you are using.

Parent topic: Options Utility


The Browser Tab

The Browser tab allows you to specify which database objects you want to display on the Catalog Browser window.

Display | Object types that are checked will appear in the Catalog Browser hierarchy. If unchecked, they are not displayed. Instead the next level in the hierarchy is displayed, if appropriate. The default is to display all objects except databases.
Startup Options | These options specify what the catalog browser will do on startup.
 | AutoRefresh | Not used.
 | AutoStartup | If checked, the Catalog Browser is automatically loaded when SQLWizard is started. If not checked, you can access the Catalog Browser from the View menu or toolbar.
Parent topic: Options Utility


The Query Tab

The Query tab allows you to specify default options for working with Queries. These options can be overridden for a particular query when you are editing the query. See also the section titled Query Run Tab.

3 Part Names | If checked, queries are defined using fully qualified table names in the format location.authid.table-name.
2 Part Names | If checked, queries are defined using 2-part table names in the format authid.table-name.
Unqualified Names | If checked, queries are defined using unqualified table names.
Show Table Names | If checked, a row is added to the Query Conditions Grid on the Query Design window to show the table where each column resides. This feature is especially helpful when your query joins two or more tables.
Foreign Keys | If checked, the Query Design window automatically defines joins between the columns of any tables that are involved in a foreign key relationship
Primary Keys with Like Name | If checked, the Query Design window automatically creates a join condition between the primary-key columns in one table and any set of primary-key columns with the same names in another table in the query.
Like Column Names | If checked, the Query Design window automatically creates a join condition between tables in the query that have columns with the same name.
Prohibit Cartesian Products | If marked, returns an error if you try to run a join that does not have a WHERE condition involving the joined tables. This only applies to queries run from the Query Design Window.
Parent topic: Options Utility


The Query Run Tab

The Query Run tab allows you to specify the following options for running queries with SQLWizard. See also Query Tab.

Execute | These options apply to the SQL Edit window and SQL Scripts. They do not affect the running of queries from the Query Design window.
All Commands | Select if you want to run all commands that appear in the current SQL Edit window or SQL script when you begin a run.
First Command | Select if you want to run only the first command in the current SQL Edit window or SQL script when you begin a run.
Current Command | Select if you want to run the currently selected command in the current SQL Edit window when you begin a run.
Edit Options
Allow Editing | Enables the ALLOW EDITING option on for any query you run. The ALLOW EDITING option lets you to enter and change data on the Results window.
Check Unique Key If checked, enables unique-key checking. When this option is set, SQLWizard automatically searches the SYSINDEX and SYSKEYS tables during an edit-mode query, and adds unique key fields to the query, even if the user has not explicitly selected them.

Such action allows SQLWizard to generate the appropriate WHERE clause should the user subsequently choose to update any of the extracted data. On certain databases (e.g., large DB2 3.x locations without a shadow catalog), the search for unique key fields can result in extremely long query times.

If your database has been designed so that a unique key is always selected, this option can be disabled to eliminate the search for unique keys, thereby improving performance.
Read-Only Alert | Enables a pop-up box warning when a query is not editable. Disables the result set "Allow Editing" feature for the SQL Window.
Result Table | If checked, the default view for a Query Result window is the Result Table format. This format displays multiple records in a grid format that looks similar to a spreadsheet.
Result Form | If checked, the default view for a Query Result window is the Result Form. This format displays one record at a time.
NULL= | Select a color from the drop-down list to specify the color you want to use to represent null values. Once you have specified a color, you can toggle the colorization of null values on and off using the Highlight Nulls option on the Query menu when viewing an SQL window, and on the View menu when viewing a Result Table or Result Form window.
Max Records to Retrieve
All | Enable this option if you want to retrieve all rows that meet the criteria of the query and displays them in a Result window.
First n Records | Enable this option if you want to retrieve only the first n rows that meet the criteria of the query and displays them in a Result window. This allows you to limit the amount of data coming back and is very useful when testing a query. If you choose this option, be sure to enter the number of records you want to set as your limit.
For Bit Data Display
Use Hex Format | If checked, columns that are defined as FOR BIT DATA will be displayed in hex in the result set browser. This allows SQLWizard to build a query with a where clause which uses the hex literals of FOR BIT DATA fields to identify the row you would like to delete or update in the result set browser.
No Display | Will suppress the display of empty result sets. If running in interactive mode, a pop-up box will appear notifying you that no rows were retrieved. If running in interactive batch mode (running a batch SQL script from the menu by clicking Run Batch on the File menu) it will prevent the displaying of empty result windows without any warning.
Parent topic: Options Utility


The SQL Tab

This tab provides a means of setting defaults for various SQL operational parameters, including compatibility and sort sequence defaults.

The SQL tab contains the following settings:

SQL Compatibility Mode Used to set the SQL dialect that XDB Server uses. XDB Server permits you to specify which SQL implementation rules are to be enforced. Options are:
  • XDB
  • DB2
  • ANSI

The XDB mode option has extensions not found in DB2 SQL.

If you are running against an XDB Link gateway to access data on a mainframe or other database system, be sure to select the correct SQL Compatibility Mode. When SQL statements do not provide the results you expect, you should always check your SQL mode to make certain it is correct for your application.
Escape Character In many Micro Focus utilities and client applications, you can use an escape character before some special keys to instruct the system to treat the character as a literal. The default escape character is a backward quote ( ` ). You can redefine the key used as the escape character. For example, to insert a question mark into the database from the Data Entry utility (OS/2), you would type `?. You can also use the escape character in front of % or _ if you want these characters interpreted as literals rather than as pattern matching characters.
Note:

In Micro Focus documentation, the key you select for the escape character is referred to as <EscChar>. For example, the default <EscChar> = `
Embedded COBOL

Specify how you want to treat quoting characters around literals and SQL identifiers (such as column names and table names) when using precompiled COBOL with Embedded SQL.

DEFAULT | Behavior of quoting characters is determined by usage.
APOST | Apostrophe characters are used to quote string literals (and quotation marks are used as escape characters for SQL identifiers)
QUOTE | Quotation marks are used to quote string literals (and apostrophe characters are used as escape characters for SQL identifiers)
By default, SQL Option for DB2 tries to determine the behavior of quoting characters (apostrophe or quotation mark) based upon their usage. In the default mode, either an apostrophe or quotation mark can be used as the string delimiter. If the usage of either quoting character is ambiguous, SQL Option for DB2 assumes that the quoting character is used as a string delimiter surrounding a string literal. Ambiguity typically arises when a one-part object name is quoted and used where either object-names or string literals can be present, as shown in the following example:
SELECT D.'IBMREQD', 'IBMREQD' FROM SYSIBM.SYSDUMMY1 AS D;

In this query, SQL Option for DB2 assumes that the first set of apostrophe characters are being used as SQL escape characters and they surround a column name. This assumption is made because of the two-part dot notation. However, the second set of apostrophe characters are assumed to be string delimiters and the second IBMREQD is assumed to be a literal string.

This can lead to problems when one-part names for database objects are quoted and their usage is not explicit in the statement. For instance, a string literal cannot legally be used in the FROM clause of an SQL statement, so quoting characters in the FROM clause are always considered as escape characters surrounding SQL identifiers. However, as both string literals and SQL identifiers can be present in a SELECT clause, the usage can be ambiguous.

To illustrate this, the following query produces three different results in the three different modes:

SELECT 'IBMREQD', "IBMREQD" FROM SYSIBM.SYSDUMMY1

When using the default, the query returns the following:

-----------------
|IBMREQD|IBMREQD|
-----------------

When using APOST, the query returns the following:

-----------------
|IBMREQD|N |
-----------------

When using QUOTE, the query returns the following:

-----------------
|N |IBMREQD|
-----------------
Default Sort Sequence Choose the default sort sequence to use when creating a location.
Note:

After you define a user defined sort sequence and use it for one or more locations, do not re-define it. The locations using the original sort sequence are likely to have index and other problems.

The sort sequence options are as follows. The first three are standard computer sort sequences.
Case Insensitive ASCII | (A=a, B=b, etc.)
ASCII | Standard ASCII sort
EBCDIC Sensitive | Standard EBCDIC sort where null values sort low
User Defined If you select USER DEFINED, you must specify a sort sequence file that is named with the extension .SEQ. This file is used as the sort sequence for any location that is created with a user defined sort sequence.

To operate with a user-defined sort sequence, you must create a sort sequence file (use any ASCII text editor). The file can be up to 256 lines. Each line represents a rank in the sort sequence. On each line, enter an ASCII decimal code or a character, enclosed in double quotes. (See the US ASCII Table for a list of ASCII decimal codes.) If a rank is shared by multiple characters, enter them on the same line, separated by commas.

Below is a partial sort sequence file. In this example, the decimal code 0 (null) appears on line 1, and is the first element in the sort sequence. The letter A appears on line 2, and is therefore assigned rank 2. Because both upper and lower case A appear on the same line, A is not case-sensitive. The same is true of B, C, etc. The letter E was entered using ASCII decimal codes (69='E' and 101='e'). ASCII decimal codes and characters in quotes can be used interchangeably.

  • 0
  • "A","a"
  • "B","b"
  • "C","c"
  • "D","d"
  • 69,101
  • ...

If characters are missing from your sort sequence file, the missing characters will be treated as null by the system. Save the file with the name of your choosing, and the extension .SEQ.
Classic EBCDIC | Standard EBCDIC sort where null values sort high. This mimics the mainframe sort sequence.
Language EBCDIC | Includes French EBCDIC, Spanish EBCDIC, Italian EBCDIC, UK EBCDIC, Danish (Norwegian) EBCDIC, Swedish (Finnish) EBCDIC, German (Austrian) EBCDIC, US (Portuguese, Dutch) EBCDIC, International EBCDIC, and Turkish EBCDIC. Each sort sequence is the same as the corresponding character set, with null values sorting high.
SysAuthID | These items allow SQLWizard to find the system catalog tables that contain the information to be displayed in the Catalog Browser.
SysXDB Specify the AuthID to be used when issuing queries against system catalog tables owned by SYSXDB. Often you will only have privileges on a view on the system catalog tables. Usually the view is created using the same table name, but a different AuthID than the underlying table. When running against XDB-Link to DB2, you will usually use SYSXDB=XDB instead of SYSXDB=SYSXDB.

If the SYSXDB= setting is incorrect and you get the message:

ISQL043: Cannot access SYSIBM tables using AuthID authid.

then you may not have privileges on the catalog tables. SQLWizard provides script files that grant access to the catalog tables. These scripts must be run by a Database Administrator, or by someone who has SYSADM authority. See your Setup Guide for information about these script files.
Parent topic: Options Utility


The Security Tab

The Security tab allows you to set your security options. The CLIENT SECURITY option is important if you want to turn security on for your copy of the XDB Server.

Only if security is on for the XDB Server will password security be fully enforced. The global security options are only available with XDB Server 4.0 or later.

If security is on at the XDB Server you will be accessing, you must check the CLIENT SECURITY check box. If security at the XDB Server is off, you can check or not check this box as desired. Using CLIENT SECURITY when security is not required by the XDB Server will provide password security at your workstation.

Specifies the rules that must be satisfied by your password. The password enforcement levels are:

  • Level 1: Password must be four or more characters.
  • Level 2: Password must be six or more characters and include at least one digit.
  • Level 3: Password must be six or more characters, include at least one digit and must include the two randomly generated characters that appear in the prompt message when the user creates or modifies their password.

The passwords created or modified by users must meet the criteria for the current password enforcement level.

Parent topic: Options Utility


The Summary Tab

The Summary tab presents a scrollable list of all of the configuration settings that are set through the Options window. You cannot make changes to any of the options from the Summary tab, but you can print it for reference.

Parent topic: Options Utility


The Connect Tab

The Connect tab provides options for configuring the connection between a client application (such as SQLWizard or a program that you have developed) and the XDB Server you will be accessing.

Locations | Specify the name of the default location you want to access when a connection is made (click the BROWSE button if you want to select from a list of locations). You will be able to override this selection at run time if the Connect dialog box is displayed (the AUTOCONNECT option is off and/or CLIENT SECURITY, on the Security tab, is on).
AuthID | Specify the AuthID (user name) you want to appear as the default in the Connect dialog box. You will be able to override this at run time if the Connect dialog box is displayed when you start SQLWizard (i.e., the AUTOCONNECT option is off and/or CLIENT SECURITY, on the Security tab, is on). If security is off, the AuthID entered in Options will automatically become your current SQLID and will be used as the AuthID portion of any database objects you create.
AutoConnect | If AUTOCONNECT is on and CLIENT SECURITY, on the Security tab, is off, the Connect dialog box is suppressed. In this case, you connect to the default Server, Location and AuthID that you specified in Options.
AutoLogoff | Check this to have the user automatically logged off from the system when you exit the Options Utility if you have made any changes to your connection specifications.
Communication Protocol | Specify which protocol you want to use to communicate with the XDB Server specified in Server Name. Options are:
 | Local [or Windows(LOCAL)] | (Windows 3.x only) Communicates with a local XDB Server. If you have an XDB Server on the same machine as your client application, you can use this server to communicate with it using the proprietary internal protocol instead of using the network.
 | Win32Local | (Win32 only) Communicates with a local XDB Server. If you have an XDB Server on the same machine as your client application, you can use this server to communicate with it using the proprietary internal protocol instead of using the network.
 | NetBIOS | Communicates across the network to a remote, multiuser XDB Server using the NetBIOS protocol.
 | Names Pipes | Communicates across the network to a remote, multiuser XDB Server using the Named Pipes protocol. (Also may be used to access a local XDB Server that supports local Named Pipes.)
 | TCP/IP | Communicates across the network to an XDB Server or XDB Link using the TCP/IP protocol. If you choose the TCP/IP protocol, enter the server's IP address in the IP Address text box, and the port number on which the server will receive connection requests in the TCP Port text box. The same port number must be specified on the XDB Server and all clients of the XDB Server. Check with your system administrator if you do not know this information.
 | IPX/SPX | Communicates across the network to an XDB Server or XDB Link using the IPX/SPX protocol. Note: You may need to add information to your xdb.ini file to successfully use some of these protocols. See the PROTOCOL= and PROTOCOLMAP= parameters in the [CONNECTION DEFAULTS] section of the xdb.ini file for more information. Check with your network administrator and your XDB Server Administrator to determine which protocols are supported on your network and on your XDB Server.
Client Node Name | This is the name by which your machine is known to the XDB Server. The name should be unique among all machines that are trying to access any XDB Server or XDB Link on your network.
Parent topic: Options Utility


SQL Wizard

  • SQLWizard Menus Overview
  • Keyboard Navigation Overview
  • Completing the Connect Dialog Box
  • Create/Alter/Drop Location Dialog Box
  • Create/Alter/Drop Table Dialog Box
  • Table Options Dialog Box
  • Catalog Browser Tabs
  • Add/Modify User Dialog Box
  • Groups Dialog Box
  • Define Priority Dialog Box
Parent topic: User Interface Reference


SQLWizard Menus Overview

SQLWizard's menu bar also changes as different windows become active. For example, menus displayed when the Query Design window is active are different from the menus displayed when an Import window is active.

There are several menus that are always present and that remain fairly constant. These are:

  • File Menu
  • Edit Menu
  • View Menu
  • Location Menu
  • Table Menu
  • Admin Menu
  • Window Menu
  • Help Menu
  • File Menu
  • Edit Menu
  • View Menu
  • Location Menu
  • Table Menu
  • Admin Menu
  • Window Menu
  • Help Menu
Parent topic: SQL Wizard


File Menu

The File menu provides commands for opening new or existing queries and other objects, as well as for printing and saving. The Exit command is located on this menu.

New | Provides a submenu for opening various types of SQLWizard documents or Windows.
Open | Displays the Open dialog box for opening queries, import and export specifications, and batch SQL scripts and tables.
Save | Saves the contents of the current window. If the object has not yet been named, the Save As dialog box will be displayed.
Save As | Displays the Save As dialog box you use to specify the name of an object to be saved.
Close | Closes the window that is active.
Close All | Closes all windows that are open, including the active window. If any window contains unsaved data or specifications, a prompt is provided to give you the opportunity to save it.
Run Batch | Displays the Run Batch dialog box, asking you to select an SQL file to load and run.
Print | Prints the contents of the current window or prints the associated report for the current window. When you select Print, the following Print dialog box appears, allowing you to specify the number of copies and the pages you want to print. The Setup button will display the Printer Setup dialog box. When you click OK, SQLWizard formats the data in the active window and sends it to your printer or print queue. Status of the print job is shown in a message box, which constantly updates to indicate the page number that is currently being sent.
Output | Transfers the contents of the current window or the associated report for the current window to a file. When you select Output, your system's standard Save As dialog box appears titled as Output File. The Save As dialog boxes for other operating environments are similar. See your operating system documentation for more information.
Printer Setup | Displays your system's Print Setup dialog box, allowing you to select a printer and set printer options. The Print Setup dialog box for other operating environments are similar. See your operating system documentation for more information.
Exit | Exits SQLWizard. If any windows contain data that has not yet been saved, you are prompted to save it.
Parent topic: SQLWizard Menus Overview


Edit Menu

Although it is not available when SQLWizard first starts, the Edit menu is available when working with many of SQLWizard's features. The Edit menu typically provides functions to undo the last changes, cut/copy/paste using the clipboard, and perform other edit functions. This menu changes depending on the window that is active.

Undo | If there are changes to the current field that can be restored to their previous state, click this command to undo them.
Redo | If there are changes to the current field that can be entered again, click this command. (This command only appears on the menu when appropriate to the task at hand.)
Cut | Removes the currently selected text or object and saves it to the clipboard.
Copy | Copies the currently selected text or object to the clipboard.
Paste | Pastes the current clipboard contents at the cursor position. If the data on the clipboard is not compatible, it is not pasted.
Delete | Deletes the selected item or the text at the cursor position.
Other menu items | Depending on what kind of SQLWizard window is active, other commands may appear on this menu, such as the Insert Row and Delete Row commands that are used when using a Result table to do data entry. The 72-column Format command is available when a SQL Edit window is the current window.
Parent topic: SQLWizard Menus Overview


View Menu

The View menu provides access to the Catalog Browser. You also use it to switch between different views of the current window depending on the editing mode you are using. For example, if a Query Design window is active, the View menu provides commands to switch to SQL view.

The three Catalog Browser commands are described here. Specialty View menu commands are described in their respective chapters.

Locations | Brings the Catalog Browser to the front with the Location tab selected so that you can work with locations.
Tables | Brings the Catalog Browser to the front with the Table tab selected so that you can work with tables.
Queries | Brings the Catalog Browser to the front with the Query tab selected so that you can work with queries.
Parent topic: SQLWizard Menus Overview


Location Menu

You use the Location menu to set and manage locations.

Set Location | Displays the Set Location/SQLID dialog box, which allows you to change your current location and SQLID.
Create | Displays the Create Location dialog box, which allows you to define specifications for a new location and create it.
Alter | Displays the Alter Location dialog box, which allows you to change a location's parameters.
Drop | Displays the Drop Location dialog box, which allows you to drop (delete) the specified location and all its tables.
Parent topic: SQLWizard Menus Overview


Table Menu

Use the Table menu to open and manage tables.

Open | Opens a table by selecting all columns and rows from it and displaying it in a Result Table window.
Create | Displays the Create Table dialog box so that you can define and create a new table along with its associated indexes, keys, synonyms, and aliases.
Alter | Allows you to select a table for modification. Once you have selected a table, the Alter Table dialog box is displayed so that you can alter the table's specifications, as well as create, alter, or drop its associated indexes, keys, synonyms, and aliases.
Drop | Allows you to select a table that you want to delete from your database. Once you have selected a table, SQLWizard asks for confirmation before actually performing the drop.
Parent topic: SQLWizard Menus Overview


Admin Menu

Use the Admin menu to create and manage AuthIDs, passwords, groups, and XDB Server priorities.

Change Password | Allows users to change their own passwords and allows a super user to change the passwords of others. You must have the appropriate privileges to change any password other than your own.
Users | Allows you to define, modify, or delete AuthIDs, and assign users to groups. You must be a super user to access this command.
Groups | Allows you to define, modify, or delete user groups. You must be a super user to access this command.
Priorities | Allows you to define, modify, or delete priority definitions to control access to the database and limit XDB Server usage. You must be a super user to access this command.
Parent topic: SQLWizard Menus Overview


Window Menu

The Window menu is a standard system menu used to arrange and size windows and icons, as well as to switch between the currently open document windows.

Tile | Divides the SQLWizard parent window evenly among the currently open child windows, and resizes the child windows to fit in the space allocated.
Cascade | Makes all of the child windows a standard size and displays them one below the other and slightly offset to the right.
Arrange Icons | Evens out the arrangement of any minimized child windows along the bottom of the parent window.
List of Open SQLWizard Windows | A numbered list of open child windows appears at the bottom of the menu. By clicking on the name of a window, you make that window the active window.
Parent topic: SQLWizard Menus Overview


Help Menu

The Help menu provides comprehensive help on the SQLWizard interface as well as an online SQL Reference. SQLWizard makes use of the native help system for your operating environment. If you are not familiar with how Help works in your environment, consult your operating environment documentation or click the How To Use Help command on the SQLWizard Help menu.

Contents | This command displays the contents of the SQLWizard help file.
Search for Help On | (Windows systems only.) Displays the Help Search dialog box to assist you in locating a help topic.
How To Use Help | Accesses a general help file that describes how to use help.
SQL Command Tutor | Opens the SQL Option Help, which contains descriptions and syntax for all SQL commands supported by XDB Server. This online reference can assist you in writing SQL statements. You can use help facilities to copy example code to the SQL Edit window or to your editor.
About SQLWizard | Describes the SQLWizard application.

In addition to the Help menu, you can access help to display information about the current context by:

  • Pressing F1.
  • Clicking the Help button on the toolbar.
  • Clicking a Help button on a dialog box.
Parent topic: SQLWizard Menus Overview


Keyboard Navigation Overview

SQLWizard uses a graphical user interface oriented to mouse usage. However, you can navigate almost all of SQLWizard's windows, dialog boxes and menus using the keyboard.

Menu items can be accessed using the standard keystrokes for your operating environment. For example, in Windows you can hold down Alt while typing the underlined character on the menu you want to use. Many menu commands have keystroke shortcuts, such as Ctrl+O to open a file or Ctrl+S to save a file. These are displayed on the menus.

Navigating within a window or dialog box uses the standard keystrokes for your operating environment. In most cases, you can move from one item to the next on a window or dialog box by pressing Tab. (Use Shift+Tab to tab within a data entry field.)

You can select an item from a drop-down list by tabbing to the list and then pressing Down Arrow. Likewise, to select an item from a group of radio buttons, you can tab to one of the items in the group and press Down Arrow to select it. Use the space bar to press a command button or to change the setting of a checkbox after tabbing to it.

Note:

There are some situations where the customary keystrokes cannot be used, and you will need to use your mouse.

Parent topic: SQL Wizard


Completing the Connect Dialog Box

The Connect dialog box contains four fields: Server, Location, AuthID, and Password.

Server Use this field to specify the name of the XDB Server you wish to access. You can select from any server in the drop-down list. If you don't see the server you want to use, exit SQLWizard and run the Options utility to add the server to your system. For more information about adding servers to SQLWizard, see the Options utility online help.
Location Use this field to specify the location to which you want to connect. You can type a name or click the Browse button to select a name from the Browse dialog box. The Browse dialog box shows all locations known to the selected XDB Server.
Note: Each time you access the Browse Dialog box, the selected XDB Server is checked for the list of all known locations available and you are logged in to the specified XDB Server with the current AuthID and password. If security is on, you must have SELECT privileges on the XDB Server's system location for this feature to operate correctly.

If you do not click the Browse button, the XDB Server is not accessed until you connect.

AuthID Use this field to specify the AuthID you wish to use when logging in. The AuthID is used for access security, object ownership, and determining database privileges.

The default AuthID that appears in this field reflects your AUTHID entry in the Options utility. You can type in a different name if desired.

Note: Your AuthID may be remapped to a SecondaryID by your XDB Server Administrator. If you have a SecondaryID, you will log in using one AuthID and appear to be doing work as another AuthID.
Password The Password field appears only if Security is turned on in the Options utility. Security must be on in the Options utility if you are accessing an XDB Server that is running with security on. If you are accessing an XDB Server that does not require security to be on, you can choose whether to turn security on or off for your own workstation.

The password you enter must be between four and eight characters and must follow the rules for a short identifier. Your password must meet the specifications for the current "password enforcement level" defined for the XDB Server you are accessing.

Parent topic: SQL Wizard


Create/Alter/Drop Location Dialog Box

Use the Create/Alter/Drop Location dialog box to define, change, or delete XDB Server locations. You access the Create/Alter/Drop Location dialog box using the Create, Alter, and Drop commands on the Location menu. Regardless of whether you are creating, altering, or dropping a location, this dialog box is essentiallythe same.

The following describes all fields on the Create/Alter/Drop Location dialog box.
Location A location is a collection of databases, tables, indexes, and related objects organized in a specific structure. An XDB Server can have multiple locations, all managed by the same database server.
Name
Specifies the name of the location. A location name may be up to 16 characters long, and must be unique among all of the locations that reside on a given XDB Server.
Creator
Specifies the AuthID of the person who created the location. The default is to use your current SQLID, but you can change this if you are authorized to use a different SQLID.
Path
Specifies the directory where your location files are stored. When creating a location, if you name a directory that does not exist, SQLWizard creates it for you.
Forward Log If using XDB Server version 4.x and earlier, you must specify the name of the file used for forward logging. In XDB Server version 5 and later, this file is automatically created by the system, however you can specify the directory to which it is stored.
Name
Specifies the name of the file that will be used as the Forward Log. SQLWizard uses up to eight characters of the location name as a default forward log file name. You can change it if desired.
Path
Specifies the directory in which the Forward Log will be stored (under XDB Server version 5 and later; the Backward Log is placed in this directory too). SQLWizard uses the location path as the default, but if possible, it is best to use a different physical drive for the Forward Log. Keeping the Forward Log on a different drive will enable you to restore your database in the event of a disk failure on the drive containing your location and database files.
Sort Sequence SQLWizard allows you to specify the sort sequence to be used for ordering and comparing data on a per location basis. Select one of these sort sequences from the drop-down list:
  • Case Insensitive ASCII
  • ASCII
  • EBCDIC Sensitive
  • User Defined
  • Classic EBCDIC
  • Language EBCDIC
Remarks | Type any comments about the location in this field. Comments can be up to 30 characters.
SQL | Click this to examine the SQL statements represented by the entries you have made.
Parent topic: SQL Wizard


Create/Alter/Drop Table Dialog Box

Through the Create/Alter/Drop Table dialog box, SQLWizard provides an interactive means of creating, altering, and dropping tables. In addition to allowing changes to a table's column definition, the Create Table and Alter Table dialog boxes let you add or change an existing table's indexes, primary keys, foreign keys, synonyms, and aliases.

The following describes all fields on the Create/Alter/Drop Table dialog box.

Table Name | Specifies a table name using a three-part, two-part, or unqualified table name, as appropriate. If you are altering or dropping a table, you can choose the table name from the Catalog Browser dialog box or the Open Table dialog box when you first access the Alter/Drop Table dialog box.
Comments | Describes the table. The comment is stored in the Remarks column in the SYSIBM.SYSTABLES table.
Indexes and Keys | Contains a list of the current or pending indexes on the table. You can choose one of the buttons to create, alter, or drop an index or key.
Relationships | Contains a list of current foreign keys on this table. You can choose one of the buttons to create, alter, or drop a foreign key.
OK button | Accepts all table definition information as shown on the Create/Alter Table dialog box and executes the SQL commands to effect them. On the Drop Table dialog box, the OK button executes the SQL command to drop the table and all its related files and database objects.
Cancel Button | Discards all entries or changes that may have been made on the Create/Alter/Drop dialog box.
Options Button | Accesses the Table Options dialog box where you can define synonyms and aliases, as well as other important options for your table specification.
SQL Button | Opens the Show SQL window to display the pending SQL command(s). Information shown on the Create/Alter/Drop Table dialog box are used by SQLWizard to generate the SQL command(s).
Field (Column) Definitions The grid at the bottom of the Create/Alter/Drop Table dialog box is used to define the columns in your table. Except for the field name, you can either use the default values provided, or change the fields as described below.
Fld. No.
Shows the number of the table row.
Primary Key
The key icon indicates whether the column is part of a primary key. A primary key is used to uniquely identify the rows in a table. Once you have defined a primary key for the table, a key icon appears next to the column.
Field (Column) Name
Identifies each column in a table, view, or result. A column name can be up to 18 characters and must satisfy the rules for a long identifier.
Data Type
Defines the kind or type of data a column may hold. The following lists all available data types:
  • Char
  • Char for bit data
  • Long Varchar
  • Graphic
  • Long Vargraphic
  • Varchar
  • Varchar for bit data
  • Long Varchar for bit data
  • Vargraphic
  • Rowid
  • Time
  • Date
  • Integer
  • Float
  • Float (4)
  • Decimal
  • Money
  • Timestamp
Length
For data types with flexible lengths, type a field length to replace the default field length. If the data type does not have a flexible length, the field length is automatically filled in for you and the field is disabled.
Note: The length shown for some data types is the physical number of bytes used to store the data, rather than a limit on the number of digits or characters in the field. For example, even though the length of a smallint field is shown as 2, a smallint field can contain values between + and - 32767.
Not Null
Allows you to specify whether or not Null values are allowed in the column. Click the down-arrow button to display a drop-down list of options. You may also choose from the list by typing the first character of the option.
False
The column can be null.
True
The column cannot be null. It must contain data.
w/ Default
If the field is null, SQLWizard inserts a default.
Unique
For NOT NULL UNIQUE, used by DB2. If a column is defined as NOT NULL UNIQUE, DB2 allows at most one record to contain a null value.
Comments
Optional. Shows text up to 254 characters for each column in the table. These comments appear in the Catalog Browser dialog box when the Details option is checked.
Parent topic: SQL Wizard


Table Options Dialog Box

When you create or alter a table, the Table Options dialog box allows you to create, alter, or drop synonyms and aliases related to the table and specify DB2-related options (including the database and table space the table resides in, edit and validation procedures, and audit, data capture, and OBID options). These DB2-related options are provided for those who transfer data between XDB Server and mainframe DB2. For more information on these items, consult your DB2 documentation.

Database/Tablespace
Provides options for organizing your tables and indexes.
Database (In Database clause) An XDB Server database is a collection of tables, indexes, and table spaces. Each database definition occupies a separate directory. A database can consist of a number of files that span several directories. If you use stogroups, it can also span several disks.
Note: The database and/or stogroup must exist before you create the table. To create a database or stogroup, open an SQL Edit window and issue a CREATE DATABASE or CREATE STOGROUP command as explained in the SQL Reference.

Database names are stored in the system catalog table SYSIBM.SYSDATABASE. Every location contains a default database (DSNDB04) for user-defined tables and two XDB Server catalog databases (DSNDB06 and DSNDB07). Also, a location may include any number of additional user-defined databases. The SYSTEM location includes two additional databases: XDBACF, which stores information on security and access, and DSNDDF, which stores information on other locations.

Tablespace (In Tablespace clause) A table space is a physical area of disk space that holds a table. The table space object provides compatibility with DB2, and is optional in XDB Server. By default, XDB Server assumes a table space name that is the same as the table name, and each table is stored in its own table space.
Note: The table space must exist before you create the table. To create a table space, open an SQL Edit window and issue a CREATE TABLESPACE command as explained in the SQL Reference.

In DB2, table spaces and stogroups provide a means of organizing tables and indexes on specific disk storage devices. Generally, you associate each table space and index with a stogroup. You create a table within a specific table space. When you create an index, you can associate it with a stogroup.

Audit
Identifies the types of table access that causes auditing. Audit options are provided for mainframe DB2 compatibility. The options are:
None | Default.
Changes | The table is audited during the first insert, update, or delete operation by each unit of work.
All | The table is audited when the table is accessed during the first operation of any kind by each unit of work. The appropriate audit-trace class must be active and audit is not done when the table is accessed by COPY, RECOVER, REPAIR, or a stand-alone utility.
Procedures
Allows you to enter two kinds of procedures. These procedures are provided for mainframe DB2 compatibility.
Edit Proc | Names an edit routine for the table that is provided by the current server's site. Default is none.
Valid Proc | Names a validation exit routine for the table. Default is none.
OBID
Names the table's internal descriptor within the XDB Server SYSTEM catalog. The OBID option is used with ROSHARE databases.
Data Capture
Specifies if the log records for SQL INSERT, UPDATE, and DELETE commands can contain additional information. This option is provided for mainframe DB2 compatibility.
None | Do not record additional information to the log.
Changes | Write additional data about SQL updates to the log.
Global Temp. Table
Allows you to create the table as a global temporary table.
Synonyms and Aliases
Allows you to create, alter, or drop synonyms and aliases for the table. Altering an alias or a synonym is used only when you wish to remove a dropped status.
Parent topic: SQL Wizard


Catalog Browser Tabs

There are three tabs arranged along the left side of the Catalog Browser dialog box. Use these tabs to switch between different hierarchical views of the system catalog. Each view provides a different set of buttons on the right side of the Catalog Browser dialog box.

Location Tab | Shows information about known locations, and provides access to location management commands.
*
Table Tab | Shows information about tables and related objects such as databases, indexes, keys, and columns. Also provides access to table management commands.
*
Query Tab | Shows information about queries and SQL statements stored in the system catalog tables, and accessible by the current server.
*
  • Location Tab Buttons
  • Table Tab
  • Query Tab Buttons
  • Object Icons
  • Expanding and Collapsing the Hierarchy
  • Query Window
  • Result Window
  • Import Window
  • Export Window
  • Target File Information
  • Source Table Information (Design Mode)
  • Source Table Information (SQL Mode)
  • Export Options Dialog Box
Parent topic: SQL Wizard


Location Tab Buttons

The following are the buttons available for the Location view of the Catalog Browser.

Create | The Create button displays the Create Location dialog box.
Alter | The Alter button displays the Alter Location dialog box for the currently selected location.
Drop | The Drop button displays the Drop Location dialog box for the currently selected location.
Set | The Set button displays the Set Location dialog box, allowing you to select a new current location and/or SQLID. This button is available only if a location name is highlighted (selected) on the list of locations. Locations that can be selected in this manner apply only to the server to which you are currently connected. Note: To connect to a location managed by another XDB Server (including XDB Link), use the Set Location command on the Location menu.
Refresh | The Refresh button queries the system catalog to find out current details for all locations. Click this button after you or someone else has made changes to objects, such as inserting, altering, or dropping locations, tables, indexes, queries, etc.
Detail | The Detail checkbox indicates if comments on the locations should be shown to the right of each location name. If checked, comments are displayed. To add comments to a location, use the Alter Location dialog box, and type a remark. Click the OK button to confirm the Alter command. When you return to the Catalog Browser, click the Refresh button to view the changes.
Parent topic: Catalog Browser Tabs


Table Tab

The following buttons are available from the Table view of the Catalog Browser.

Create * | The Create button displays the Create Table dialog box, allowing you to specify parameters for a new table in the current location.
Alter * | The Alter button displays the Alter Table dialog box to let you change the currently selected table.
Drop * | The Drop button displays the Drop Table dialog box for the currently selected table.
Open * | The Open button displays the contents (data) of the selected table in a Result window. Clicking Open is the same as executing the SQL command: SELECT * FROM tablename FOR FETCH ONLY
Refresh * | The Refresh button queries the system catalog to find out current details for all tables and related objects. Click this button after you or someone else has made changes to objects, such as inserting, altering, or dropping locations, tables, indexes, queries, etc.
Filter * | The Filter button enables you to specify filters to control the databases, AuthIDs and table items that are displayed in the Catalog Browser for any particular location.
Detail * | The Detail checkbox indicates whether comments on the tables, columns, or other objects should be shown to the right of the object name. If checked, comments are displayed. At the column level, the column definition, including data type, is also displayed. You may have to increase the width of the Catalog Browser to see all of the information for each object.
Parent topic: Catalog Browser Tabs


Query Tab Buttons

The following buttons are available from the Query view of the Catalog Browser.

New * | The New button opens a new Query Design window, and prompts you to select tables for your query.
Batch | The Batch button executes the highlighted query in batch mode. If the Quiet option is on, the query runs in the background. If the Quiet option is off, the query is displayed in an SQL Edit window as it runs; each step is highlighted to show progress as the query executes. To set the Quiet option on or off, you must run the query using the Run Batch command from the File menu.
Delete * | The Delete button deletes a highlighted query from the system catalog. After deleting a query, you need to click the Refresh button to see the updated list of queries.
Open * | The Open button displays the highlighted query for further modification or execution. If the query was saved as a Prompted Query, it is opened in a Query Design window; otherwise, it is opened in an SQL Edit window.
Refresh * | The Refresh button runs a query on the system catalog to find out current details on all objects. Click this button after you or someone else has made changes to objects, such as inserting, altering, or dropping tables, indexes, queries, etc.
Detail * | The Detail checkbox indicates whether comments on the queries or SQL statements should be shown to the right of the query name. If checked, comments are displayed. You may have to increase the width of the Catalog Browser to see all of the information for each object.
Parent topic: Catalog Browser Tabs


Object Icons

The object icons are displayed next to the name of each object in the Catalog Browser dialog box to help you visually interpret the levels of the hierarchy. Some appear when any tab (Location, Table or Query) is selected and some appear only under one tab. You can configure which levels appear in the hierarchy using the Browser tab of the Options utility.

Parent topic: Catalog Browser Tabs


Expanding and Collapsing the Hierarchy

The Expand and Collapse buttons appear to the left of the object icons to indicate if an item's subordinate objects are hidden or displayed.

Expand | The Expand button indicates that the item may have sub-items beneath it that are not currently visible. Click the button to open the item and display the sub-items. When you expand the levels, you may need to drag the border of the Catalog Browser dialog box to make it wide enough to read all of the information as shown below.
Collapse | The Collapse button indicates that the item has been expanded, and that the sub-items are currently visible in the hierarchy. Click this button to collapse the hierarchy and hide the sub-items.
Note:

If an Expand button disappears when you click it and there is no replacement Collapse button, then there are no objects in that list.

Parent topic: Catalog Browser Tabs


Query Window

  • Query Window Menus Overview
  • Query Toolbar
Parent topic: Catalog Browser Tabs


Query Window Menus Overview

When a Query Design window or the SQL Edit window is active, the Query menu and Column menu are displayed. Depending on which of these windows is active, certain items may be disabled.

In addition to the Query and Column menus, other menus (such as File menu and Edit menu) are available for use when working with queries.

Note: The Column menu that appears when working on a Query is different from the Column menu that appears when viewing a Query Result window.
  • File Menu
  • Edit Menu
  • View Menu
  • Query Menu
  • Column Menu
Parent topic: Query Window


File Menu

The File menu provides options for opening new or existing queries and other objects, as well as for printing and saving. File menu commands relating to your work with writing queries are listed below.

New |  | Creates a new query. Clicking the New command displays a cascading submenu from which you can select:
 | Query | Opens the Add Table dialog box, allowing you to select tables for your query and place them in a new Query Design window. From this window, you can specify parameters for your query and then run the query.
 | SQL | Opens a new SQL Edit window where you can type your own SQL command statement, save it as a batch SQL script file, and then run it in batch mode.
Open |  | Opens a previously saved query or batch SQL script file. Optionally, use the Catalog Browser dialog box to open an existing query.
Run Batch |  | Allows you to choose a previously saved batch SQL script file and run it in batch mode.
Parent topic: Query Window Menus Overview


Edit Menu

The Edit menu provides basic editing commands such as Undo, Cut, Copy, and Paste. The Edit menu also provides commands that are specifically for use with the Query Design window.

Insert Row | Inserts a row into the Query Conditions Grid so you can enter additional search conditions.
Delete Row | Deletes the current row from the Query Conditions Grid.

The Edit menu also provides a command that is used only with the SQL Edit window.

72-column Format When this option is selected, SQL statements are allowed to span multiple lines of 72 characters as in IBM mainframe utilities.
Parent topic: Query Window Menus Overview


View Menu

The View menu allows you to access the Catalog Browser dialog box or switch the views of the current query window between Query Design mode and SQL Edit mode.

Design | If checked, shows the current query in the Query Design window, instead of in an SQL Edit window.
SQL | If checked, shows the current query in the SQL Edit window, instead of in a Query Design window.
Arrange Tables | Rearranges the Column Selection Lists in the Table Display Area in a uniform fashion.
Parent topic: Query Window Menus Overview


Query Menu

The Query menu provides options for running and designing queries. This menu is available only if a Query Design window or an SQL Edit window is the currently active window.

Run | Executes the statement or statements in the current Query Design or SQL Edit window. If the window contains a SELECT statement, a Query Result window is displayed. If it contains non-SELECT statements, these are executed, and the execution status is shown in the status bar at the bottom of the window.
Step Mode | If checked, steps through one SQL command at a time when there are multiple commands. This command is enabled only if the Execute All Commands option is in effect. See the Query Run tab in the Options utility online help.
Add Table | Displays the Add Table dialog box so that you can add a table to the current Table Display Area of the Query Design window.
Delete Table | Deletes the currently selected table from the Query Design window, thus removing it from the query.
And... | Displays a dialog box so that you can specify an extended WHERE condition or nested query.
Sort... | Displays the Order By dialog box so that you can specify the columns on which the result is to be sorted.
Group... | Displays the Group By dialog box so that you can specify the GROUP BY clause used to create a summary result.
Having... | Displays the Having dialog box so that you can specify search conditions that summary rows must satisfy.
Show Table Names | If checked, adds a row to the Query Conditions Grid. This row displays the name of the table from which each column comes.
Parameters | Displays the Parameters dialog box, so that you can supply values for the host variables in an SQL statement. You can fill this out before running your query, or just run the query and let the system prompt you to supply values for the parameters. Note: The values entered in the Parameters dialog box are saved for use each time you run commands from this window. Use this PARAMETERS command if you want to make changes to the values.
Auto Join | Displays the Auto Join submenu. A checked option causes the system to generate an automatic join condition.
Result Table View | If checked, opens the Result window in the multi-record Result Table view when a query is run.
Result Form View | If checked, opens the Result window in the single-record Result Form view when a query is run.
Highlight Nulls | Check this to enable the highlighting of null values in the color selected in the Options utility. When checked, the highlighting differentiates null values from spaces.
Allow Editing | If checked, attempts to open the Result window directly into Edit mode when a query is run. There is some additional overhead in doing this, so the default is to not go directly to Edit mode.
AutoCommit | If checked, sets AUTOCOMMIT on when a Result window switches to Edit mode.
Show Positive SQL Code | Check this to set SQL Wizard to display a warning message when the server returns either a positive or a negative SQL return code. When unchecked, SQL Wizard displays warnings for negative return codes only.
Current Query Options | Displays the Query Options dialog box for the current query. From this dialog box, you can set query design and query run options, such as the maximum number of rows to retrieve.
Parent topic: Query Window Menus Overview


Column Menu

The options found in the Column menu are applied to the currently selected column (or columns) of the Query Conditions Grid on the Query Design window. To select a column, double click the column name displayed in the Query Conditions Grid.

Note:

The Column menu that appears when working on a Query is different from the Column menu that appears when viewing a Query Result window.

Create Computed Column | Displays the Create Computed Column dialog box, so that you can define a column based on an expression.
Hide Column | Sets the currently selected column to hidden mode, so that it will not be included in the SELECT clause of the query. If a column is hidden before you run the query, you will not be able to select it from the hidden column list in the Query Result window.
Select Hidden Column | Displays the Select Hidden Column dialog box, and lets you move columns between a list of hidden columns and a list of displayed columns.
Sort Column | Displays the Sort Column submenu. When you pick either ascending or descending order from the submenu, the currently selected columns will be added to the Order By clause with the appropriate sequence.
Function | Displays the Function submenu. When you pick a function, the current column is converted into a computed column by using it as an argument for the function. Since the functions are all aggregate functions, the computed columns defined will retrieve summary rows. For the current column you can:
Delete Column | Deletes the currently selected column(s) from the Query Conditions Grid.
Parent topic: Query Window Menus Overview


Query Toolbar

When a query window is the active window, the query toolbar is displayed, as shown below. Depending on whether you are in the Query Design window or the SQL Edit window, certain buttons may be disabled.

Figure 1. *
*
Parent topic: Query Window


Result Window

  • Result Window Menus Overview
  • Directional Commands and Buttons
  • Goto Command
  • Scroll Bars
  • Cut
  • Copy
  • Paste
Parent topic: Catalog Browser Tabs


Result Window Menus Overview

When a Result window is active, the Result window menu bar is displayed. Depending on whether you are in Result Table view or Result Form view, certain items may be disabled.

Also, some commands (such as Data Entry) are available only if Edit mode is active.

The primary menus used for working with a Result window are:

  • File menu (for printing and saving)
  • Record menu
  • Column menu
  • View menu (for switching between Result Table and Result Form)
  • File Menu
  • Edit Menu
  • View Menu
  • Record Menu
  • Column Menu (Result Table View Only)
Parent topic: Result Window


File Menu

The File menu provides commands for opening new or existing queries and other objects, as well as for printing and saving. File menu commands relating to your use of a query result are listed below:

  • Save
  • Save As
  • Close
  • Print
  • Output
  • Printer Setup
  • Exit
Parent topic: Result Window Menus Overview


Edit Menu

The Edit menu provides functions to undo the last changes, to cut/copy/paste using the clipboard, and to perform other edit functions. Information about using these commands with a Result window are described below.

Undo | If there are changes to the current field that can be undone, click this command to undo them. This command is available only if Allow Editing is on. To reverse the last change (insert, update, or delete) to a record, use the Undo Record command from the Record menu.
Redo | If there are changes to the current field that can be redone, click this command to redo them. This command is available only if Allow Editing is on.
Cut | Moves the currently selected text or object to the clipboard. This command is available only if Allow Editing is on.
Copy | Copies the currently selected text or object to the clipboard. This command is available only if Allow Editing is on.
Paste | Pastes the current clipboard contents at the cursor location. If the clipboard contents is not compatible, it is not pasted. This command is available only if Allow Editing is on.
Delete | Deletes the currently selected text or object. This command is available only if Allow Editing is on.
Parent topic: Result Window Menus Overview


View Menu

The View menu allows you to access the Catalog Browser dialog box, switch the view of the active Result window between Result Table view and Result Form view, and view or edit text for a particular field in a zoom window.

The following View menu commands are applicable to your use of a Result window.

Result Table | If checked, the active Result window is shown in Result Table view. Multiple records are shown in a spreadsheet-like format.
Result Form | If checked, the active Result window is shown in Result Form view. One record is shown at a time, with fields arranged vertically down the screen.
Highlight Nulls | Check this to enable the highlighting of null values in the color selected in the Options utility. When checked, the highlighting differentiates null values from spaces.
Zoom | Displays a window containing the contents of the result field on which the cursor is positioned. This supplemental window is useful for reading or editing data in large character fields where data may be spread over several lines or paragraphs. You can open a Zoom window by clicking on the Zoom command from the View menu, or by double clicking on the desired field in the Result window display.
Parent topic: Result Window Menus Overview


Record Menu

The Record menu provides commands for moving among records, updating records, and performing other data entry functions. Most of these commands require that you have the Allow Editing command checked. The Record menu is available only when a Result window is the active window.

Update | Explicitly writes the current record's changes to the database. If Autocommit is on, you do not need to click Update; simply moving your cursor to another record or closing the Result window will automatically update the record your cursor was on. The Update command is enabled only if there have been changes to the field(s) of the current record since it was last read from the database. The Allow Editing command must be checked for this command to be enabled.
Delete | Deletes the current record from the database. The Allow Editing command must be checked for this command to be enabled.
Undo Removes the changes made to the record that the cursor is on by re-reading the record from the table. The Undo command is available only if you have made changes to the fields of the current record since you last read it, and you have not moved to another record.

If the last undo-able action is a delete, this command changes to Undo Delete, and choosing it will undelete (restore) the deleted record.

Append Duplicate | Appends a copy of the selected record to the end of a result table when Allow Editing is enabled. If there is a unique index on any of the fields in the record you are appending, you must change the values in these fields before moving from the appended row.
Data Entry | Switches to Data Entry view of the Result window, in which only newly inserted records are displayed. Initially, you see only a blank record into which you enter data for a new record. As you enter the data for each record and move to the next record, the new record is inserted into the database. Enabled only if the Allow Editing command is checked.
Show All Records | Switches from Data Entry view (which only shows newly inserted records) to a regular view that shows all records in the result.
Moving and Scrolling Commands | When using any of the following moving and scrolling commands, SQLWizard updates the current record before moving the cursor and redisplaying the requested records. The directional arrow buttons on the toolbar perform the same functions as these commands.
First

Moves the cursor to the first record of the entire set of results records.
Previous Page

Moves the cursor and displays the results of the previous page of records. This command is only visible in Result Table view.
Previous

Moves the cursor to the previous record. In Result Table view, SQLWizard scrolls the display if the previous record is not completely visible.
Next

Moves the cursor to the next record. In Result Table view, SQLWizard scrolls the display if the next record is not completely visible.
Next Page

Moves the cursor and changes the results display to the next page of records. Next Page is available only in Result Table view.
Last

Moves the cursor to the last record of the entire set of results records. In Result Table view SQLWizard scrolls the table if the last record is not completely visible.
New

Moves to the end of the result set and displays a blank record where you can enter data. Only available if Allow Editing is checked.
Note:

If your result is very large (has many records), the New command will have a negative performance impact because the system must seek to the end of the result set before the data entry can occur. If you want to insert a record without seeking to the end of the result set, switch to Data Entry mode using the Data Entry command on the Record menu.

Goto Click the Goto command to display the Goto Record dialog box. Type the number of the record to which you want to move and click OK. This is particularly useful for very large tables.

If you enter a record number higher than the highest in the table, the last record in the table is displayed.

Refresh Redisplays the current Results table by re-running your original query. The cursor moves to the first record.

If you have changed any fields of the current record, SQLWizard updates that record before refreshing the display. If you made changes to the table which you have not committed (if running with Autocommit off), SQLWizard prompts you to commit changes before refreshing the table.

Commit | Makes all the changes in your current transaction, as well as the current record, permanent, as it saves them to the disk. Commit is not available if you checked Autocommit.
Rollback Rollback is like an Undo. If the Rollback command is active (and the Backward Log is turned on through the Options utility), you can click Rollback to return your data to the condition of the last commit.

Rollback is not available if you checked Autocommit on the Record menu because when Autocommit is on, XDB Server automatically commits each record as you complete it.

See Transaction Processing for more information about the Commit, Rollback, and Autocommit concepts,.

Autocommit When you check Autocommit, changes are saved to each record as soon as you move your cursor to another record. When Autocommit is off, you must explicitly commit changes to the table. You may be able to rollback changes since the last commit; see Rollback command above.

When you click Autocommit on, SQLWizard automatically commits any changes to fields that you have not already committed.

SQLWizard lets you set a default initial setting for Autocommit on the Query Run tab of the Options utility. The status of Autocommit on the Record menu always over-rides the default in the Options utility.

Count

Refreshes the data in the status bar at the bottom of the SQLWizard window, to reflect the current count of records in the result, and the record number where the cursor is currently located.

Sort Displays the Order By dialog box allowing you to sort the records in the result. You can sort the result by one or more columns.

To select a column to sort by, double click its name to move it to the Sorted Columns list. To deselect a column, double click its name to move it to the Unsorted Columns list. You can select one or more columns for your sort.

To indicate if the sort should be ascending or descending for each column, click the Arrow-Toggle button next to each name in the Sorted Columns list.

If sorting by more than one column, you can define your sort priority by re-arranging the items in the Sorted Columns list. To move a column name up or down the list, click to highlight the column name, then click the up or down arrow buttons to the right of the Sorted Columns list to reposition the column name.

Allow Editing If you select Allow Editing, the system attempts to reopen the Result window in Edit mode so that you can update, delete, and insert records. When editing is allowed, SQLWizard displays a check mark next to Allow Editing. You will not be able to check Allow Editing if the query does not support updates, as would be the case if you run a join query.

When you check the Allow Editing command, the following edit commands become available on the Record menu: Update, Delete, Undo, New, Data Entry, Commit, Rollback, and Autocommit. Other requirements may restrict the availability of these features.

If you uncheck Allow Editing, you cannot make changes to the records. SQLWizard disables editing commands on the Record menu.

Note:

When running against a non-XDB Server data source such as mainframe DB2, you will not be able to edit a result table unless the result includes a unique index (or primary key), or unless the Check Unique Key option is disabled.

Parent topic: Result Window Menus Overview


Column Menu (Result Table View Only)

The Column menu provides commands for controlling how you view data in a Result window. Most of the commands in the Column menu are applied to the currently selected column(s).

To select a column, double click the column name displayed across the top row of the Result window. The Column menu is available only when a Result window is the active window.

Fix Locks the selected column(s) against the left margin of the Result table grid. When you scroll horizontally, other columns scroll past but the fixed column(s) remain in view. This lets you keep one or more identifying columns visible as you look at the information to the right of the spreadsheet grid.
Free Unlocks fixed columns. This command is available only if you select (double click) one or more fixed columns.

Another way to free a fixed column is to drag it to the right, dropping a it one or more columns away from the left fixed boundary of the table. You can monitor this by watching the left arrow on the horizontal scroll bar, as it relocates when you free the fixed fields.
Hide Removes the selected columns from the Result table display. You can hide as many columns as you want, individually or as a group. To redisplay a column, use the Select Hidden command.
Note:

Hiding a column only affects your viewing of the result display. It does not affect the table, where all columns and data remain intact.
Select Hidden Displays the Select Hidden Columns dialog box, allowing you to select which columns should be displayed or hidden. This dialog box displays two lists Hidden Columns and Displayed Columns.

You can move columns between the lists in either of two ways:

  • Click a column name to highlight it. Then clicking on an arrow button to move it to the other list.
  • Double click a column name to move it to the other list.

When you click OK, SQLWizard rearranges the result display to reflect the new set of hidden and displayed columns
Parent topic: Result Window Menus Overview


Directional Commands and Buttons

In the Record menu you will find commands to go to the First, Previous Page, Previous Record, Next Record, Next Page, and Last rows of a result. These menu commands correspond to the directional arrow buttons you see in the toolbar when a Result window is active.

Figure 1. *
*
Parent topic: Result Window


Goto Command

There is a Goto command in the Record menu which allows you to move directly to a specific row of the result without having to scroll.

Parent topic: Result Window


Scroll Bars

You can use the scroll bars to quickly move through a Result window. The behavior of the scroll bars depends on the result view. The Result Table view shows many records at once and Result Form view shows a single record at a time.

To view additional columns in a record:

  • If you are in Result Table view, use the horizontal scroll bar to scroll through the columns in your result.
  • If you are in Result Form view, use the vertical scroll bar to move through all of the fields in a record.

To view other records:

  • If you are in Result Table view, use the vertical scroll bar to move through the rows of your result.
  • If you are in Result Form view, use the toolbar buttons or Record menu items to move from one record of the result to the next.
Parent topic: Result Window


Cut

*
Deletes the highlighted text from Result window and holds it on the clipboard for a future paste. You can also use the appropriate keystroke for cut in your operating environment. For example, in Microsoft Windows you can use Ctrl+X to cut data to the clipboard.

Parent topic: Result Window


Copy

*
Copies the highlighted text from Result window and holds it on the clipboard for a future paste. You can also use the appropriate keystroke for cut in your operating environment. For example, in Microsoft Windows you can use Ctrl+C to copy data to the clipboard.

Parent topic: Result Window


Paste

*
Pastes the clipboard text to the field that the cursor is on in a Result window. You can also use the appropriate keystroke for cut in your operating environment. For example, in Microsoft Windows you can use Ctrl+V to paste data from the clipboard.

Note:

If the pasted data contains more characters than are allowed by the size of the column you are pasting into, the data is truncated.

Parent topic: Result Window


Import Window

  • Import Window Menus Overview
  • Import Window Toolbar
Parent topic: Catalog Browser Tabs


Import Window Menus Overview

Once you open an Import window, you can use the File, View, and Import menus to work with your import specifications and batch commands. The primary menus used for working with an Import window are:

  • File Menu
  • View Menu
  • Import Menu
  • File Menu
  • View Menu
  • Import Menu
Parent topic: Import Window


File Menu

The File menu provides commands for opening an Import window, for saving and retrieving import specifications, and for running Batch Import files. File menu commands relating to your use of an Import specification are provided below.

New | Opens a new Import window where you can enter specifications for importing data.
Open | Presents the Open dialog box, allowing you to retrieve previously saved SQLWizard import specifications into an Import window.
Run Batch | Presents the Run Batch dialog box, allowing you to run a previously saved SQLWizard Batch Import (*.imp) file.
Parent topic: Import Window Menus Overview


View Menu

In addition to the standard View menu commands, the following commands become available when an Import window is active:

Source File | Opens a window to show the contents of the source file that is specified in the Import window. If no file is specified in the Import window, a File Open dialog box is presented, allowing you to choose a file.
Batch Import Commands | Opens a window showing the Batch Import commands that would be generated from the information currently appearing on the Import window. This is the SQL that would be saved if you use the Save or Save As command.
Parent topic: Import Window Menus Overview


Import Menu

The Import menu appears in the title bar when an Import window is active. The following functions are available when importing most source file types into XDB Server table definitions:

Run | After you have entered all required information on the Import windows, starts importing your source file into the desired table definition. Optionally, you can click the Run button from the toolbar. When the process is completed, the system shows the number of records imported in the status bar at the bottom of the window. You can then process another file.
End Current | Allows you to abort an import operation while it is running. Data that was already imported up to that point remains imported. When you select this command while running an import batch file that has several transactions, the transaction currently running is ended and the next transaction is started.
End All | Aborts all batch processing when you have more than one transaction in an Batch Import file.
Clear Form | Clears all the current import specifications from the Import window. Values are set to their user-defined defaults as specified in the Defaults dialog box.
Recalculate | When you select a source file to import, automatically calculates a table definition for the data (except for the DSNTIAUL format). This command allows you to prompt the system to reanalyze the currently selected source file and get the system to suggest a table definition. This gives you the ability to revert to the original interpretation of the file's table definition. If you are creating a new table, you can then redefine any fields that are not grayed out in the table-definition display area.
Options Displays the Options dialog box, which allows you to customize your import processes. You can set the import speed to run in Normal or Engine Direct Write modes. You can also write errors to a log file and write records containing errors to a log file.

You can also set error handling options that allow you to:

  • Skip any invalid data and go on to the next record.
  • Insert NULL in fields when invalid data is encountered if the field is nullable.
  • Quit the current import process and continue with the next if an error is encountered.
  • End all Batch Import processing.
Defaults | Displays the Default Settings dialog box. The defaults consist of preset parameters. You can use this command to set format parameters of your own, or you can use the XDB Server defaults when you click the Defaults button. Default settings can be provided for Free-format ASCII, Fixed-format ASCII, and DSNTIAUL formats.
Parent topic: Import Window Menus Overview


Import Window Toolbar

When an Import window is active, the Import toolbar will be displayed as shown below.

Figure 1. *
*
Parent topic: Import Window


Export Window

  • Export Window Menus Overview
  • Export Window Toolbar
Parent topic: Catalog Browser Tabs


Export Window Menus Overview

Once you open an Export window, you can use the File, View, and Export menus to work with your export specifications and batch commands. The primary menus used for working with an Export window are:

  • File Menu (for opening, saving, and printing)
  • View Menu
  • Export Menu
  • File Menu
  • View Menu
  • Export Menu
Parent topic: Export Window


File Menu

The File menu provides commands for opening an Export window, for saving and retrieving export specifications, and for running Batch Export files. File menu commands relating to your use of an export specification are provided below.

New | Opens a new Export window where you can enter specifications for exporting data.
Open | Presents the Open dialog box, allowing you to retrieve previously saved SQLWizard export specifications into an Export window.
Save or Save As | Allows you to save the specifications that appear in the active Export window. You can save these specifications as a Batch Export file or as a Batch Import file.
Run Batch | Presents the Run Batch dialog box, allowing you to run a previously saved SQLWizard Batch Export file (*exp).
Parent topic: Export Window Menus Overview


View Menu

In addition to the standard View menu commands, the following commands become available when an Export window is active:

Design Export | Displays the standard Export window, allowing you to interactively select a table to export, specify a file to receive the exported data, specify various format-specific options, and specify a WHERE condition. An alternate Export window view is available if you select the SQL command from the View menu.
SQL | Provides an alternate view of your Export specifications, allowing you enter an SQL SELECT statement instead of using the standard Export window to specify the source table and WHERE condition.
Target File | Allows you to view the data as it appears in the file to which you exported data.
Batch Export Commands | Opens a window showing the Batch Export commands that would be generated from the information currently appearing on the Export window. This is the command list that would be saved if you use the Save or Save As command. It can later be run as a Batch Export file.
Batch Import Commands | Opens a window showing the Batch Import commands that would be generated from the information currently appearing on the Export window. This is the command list that would be saved if you use the Save or Save As command and saved the file as an Import (*.imp) file. Generating a batch import file at the time you are exporting data can help you when you plan to import the data onto another XDB Server. You would take the exported data file and the corresponding batch import file to the other XDB Server. Then use batch import on that machine to transfer the data onto that XDB Server.
Parent topic: Export Window Menus Overview


Export Menu

The Export menu appears in the SQLWizard title bar when you access the Export utility. The following functions are available from the Export menu when exporting an XDB Server table into a target file:

Run | Starts exporting the desired XDB Server table into a target file. Click the Run button from the toolbar, or click the Run command from the Export menu. When the process is completed, the system shows the number of records exported in the status bar at the bottom of the window.
End Current | Allows you to end an export process while it is running. Data that was already exported up to that point will appear in the destination file. If you select this command while running a Batch Export file that has multiple transactions, the transaction currently running is aborted and the next transaction is started.
End All | Aborts all batch processing when you have more than one transaction in a Batch Export file.
Clear Form | Clears all of the current export specifications from the Export window. Values are set to their user-defined defaults as specified from the Defaults dialog box.
Options | Displays the Export Options dialog box where you can specify error handling preferences.
Defaults | Displays the Export Default Settings dialog box where you can set preferences for various options. These preferences take effect whenever you open a new Export window. You can set default format parameters for each export file type (Free- and fixed-format ASCII and DSNTIAUL) and specify which view of the Export window you prefer (Design mode or SQL mode).
Parent topic: Export Window Menus Overview


Export Window Toolbar

When an Export window is active on the SQLWizard desktop, the Export toolbar will be displayed as shown below.

Figure 1. *
*
Parent topic: Export Window


Target File Information

This section of the Export window is where you specify the name of the file to which you want to export your XDB Server data, as well as the format to be used in that file and any other parameters required by the particular format.

File Name | Enter the drive, path, and name of the file to which you want to export data. If you enter the name of a non-existent file, SQLWizard will create it. You can use the Browse button to select an existing file that you want to over-write.
Format | Click the down-arrow button to display the drop-down list; select the format for your target file. SQLWizard can export data to free or fixed ASCII files, and mainframe-readable DSNTIAUL files. SQLWizard can also create SQL statements that you can run on another SQL database system to re-create the source table on that other system. You can include the data from the source file or just the table structure.
Other Target File Parameters | Depending on the format of the target file, additional parameters may be required.
Parent topic: Catalog Browser Tabs


Source Table Information (Design Mode)

This section of the Export window is where you specify exactly what you want to export. You can export an entire table, selected columns, or selected data.

Table Name | Enter the name of the XDB Server table that you want to extract data from. Use the Browse button to select a table from the Open dialog box.
Not Included/Included Lists | The Not Included and Included lists allow you to choose the columns of the source table that you want to export. Only the columns appearing in the Included list when you run the export will be transferred to the target file. Double click a column name to move it to the other list. You can also re-arrange the order of the columns. For example, if your source table has columns called FIRSTNAME and LASTNAME in that order, you can switch the order to LASTNAME FIRSTNAME in the exported data. After selecting the columns you want to include in the exported data, click a name to highlight it, then move it up or down the Included list until the column names are in the order you want.
WHERE Condition | You can limit the amount of data that will be exported by entering an SQL WHERE clause. For example, when exporting data from the TUTORIAL.TUTORIAL.EMPLOYEE table, you can export information about employees who live in Maryland by entering ST="MD" in the WHERE Condition box. You do not have to type the word WHERE. Note: When the SQL format is selected, the WHERE Condition field is available only when INSERT mode is selected.
Parent topic: Catalog Browser Tabs


Source Table Information (SQL Mode)

This section of the Export window is where you specify exactly what you want to export. You can export an entire table, selected columns, or selected data.

Query Enter a standard SQL SELECT query to define the data you want to export. The data will be retrieved from the database and stored in the target file and format you specify.
Parent topic: Catalog Browser Tabs


Export Options Dialog Box

Items appearing on the Export Options dialog box are described below.

On Error |  | Sets error handling options.
 | Continue | Continues processing after encountering a recoverable error.
 | Quit | Aborts the current export transaction. If running a Batch Export file containing multiple transactions, starts the next transaction.
 | End All | Aborts all export processing. If running a Batch Export file containing multiple transactions, cancels all subsequent transactions.
 | Prompt | If an error is encountered, prompts for further action.
ASCII Conversion |  | Translates the character data in the export's output file by indicating the appropriate code page translation to use. This translation happens after the data is presented by the XDB engine.
Error Logging |  | Keeps a list of all errors encountered during an export process. After the export process completes, you can view the listing of errors by editing the file with an ASCII text editor.
 | On | Indicates that you want to write errors to a log file.
 | File | Specifies the name of a file to receive the error listing.
Parent topic: Catalog Browser Tabs


Add/Modify User Dialog Box

The fields and controls in the Add/Modify User dialog box are described below.

Add | Adds a new AuthID to the system.
Delete | Permanently removes the display AuthID from the system. To temporarily deny access to a user (leaving all AuthID specifications intact), de-select the Access Authority checkbox.
Update | Changes a user's access information using the information currently displayed on the dialog box.
Close | Closes the Add/Modify User dialog box.
User ID | The AuthID (user name or UserID) is used for security purposes when you access the XDB Server, utilities, and database objects. It is also used to determine ownership of database objects. Only an XDB Server Administrator who has super-user authority can change the AuthID.
Password The password must be between four and eight characters long and must follow the rules for a short identifier. If an XDB Server is being accessed and security is on, the password specified for the user must meet the specifications for the current Password Enforcement Level as defined for that XDB Server. The user can specify a higher level access authority using the Options utility. Any super user can modify the password for an existing user, but cannot delete a user's password.

Because XDB Server passwords are stored in an encrypted format, neither a user nor an administrator can view any user's existing password. The password entered is never displayed. Instead, an asterisk (*) is displayed for each character entered.

SQLWizard has three password enforcement levels:

  • Level 1 password must be four or more characters.
  • Level 2 password must be six or more characters and include at least one digit.
  • Level 3 password must be six or more characters, include at least one digit, and must include the two randomly generated characters that appear in the prompt message when the password is created or modified.
    Note:

    Passwords are case sensitive. Be sure to always enter your password in the same combination of upper and lower case characters.

Verification | The Verification field is used to confirm entry of a password. It reassures that you have entered the correct password for a user.
Secondary ID The SecondaryID field is provided so that a variety of users can have the same AuthID for processing queries or for object ownership, but have different accounts for connecting to the XDB Server. The SecondaryID can be up to eight characters long and must follow the rules for a short identifier.

The SecondaryID value is used only when security is on. When a user with a SecondaryID creates an object, the AuthID portion of the object's name is the SecondaryID. All other users who have the same SecondaryID will have all privileges granted to that ID.

It is in this way that users can have controlled access to specific tables and information. An XDB Server Administrator can also grant location, database and table level privileges by assigning GroupIDs to AuthIDs. See Appendix A, "Security and Authority" for more information on using GroupIDs versus SecondaryIDs.

Security Options These options are applicable when accessing an XDB Server with security on. These options are ignored when accessing an XDB Server with security off. Note that these options relate only to accessing the XDB Server itself. An administrator must still grant appropriate location, database, and/or table privileges to each account.

The available security options include:

Password Required | If checked, the user must enter a password when connecting to an XDB Server.
Access Authority | If checked, the user can connect to the XDB Server. If not checked, the user is denied access to the XDB Server. This option provides a temporary way of restricting a user's access without deleting the AuthID and other information from the system.
User Type This option grants the user either User or Super User privileges. The default setting is User. Only a super user can create locations, edit system tables, and give super-user privileges to another user. If you wish to limit a user's access to certain locations or tables, you must use the GRANT and REVOKE commands.

The available User Types include:

User | Those users who are assigned USER for user type can only change their own password. They cannot modify their AuthID, SecondaryID, user comment, priority, user type, security options, or group information and cannot create locations.
Super User If you are granted super-user privileges you can add, delete, and update information for users, groups and priorities. Super users can also create locations, directly edit system catalog tables, and perform other administration functions.
Note:

If security for the XDB Server is off, all users are effectively super users.

User Comments | A descriptive comment about the user or the AuthID. The comment may be longer than the display area (use cursor keys to scroll left and right in this field). The user comment can be up to 254 characters in length.
Group Membership A group is another method available (in addition to using the SecondaryID) for an administrator to control system and location level access. All available groups are displayed in a scrollable list. If no groups exist, the list will be empty.

Groups can be added using the Groups command from the Admin menu. The advantage of using groups is that you can grant/revoke privileges to one group instead of to many individual users. A user can be added to or removed from any group by clicking to highlight the desired group name(s) on the displayed list. Users can have multiple group assignments thus gaining the privileges of all of those groups combined.

Priorities Priorities are a set of usage restrictions imposed on an AuthID. Setting priorities gives an XDB Server Administrator the ability to define XDB Server usage priorities for peak hour processing, or to restrict users who do particularly intensive queries to off-peak hours. A user who exceeds the limits that are set, is disconnected from the XDB Server. This gives an administrator the ability to regulate XDB Server usage for users.

All available priorities are displayed in a scrollable list. If no priorities exist, the list will be empty. Priorities can be added using the Priorities command from the Admin menu. Users can be assigned or removed from any priority by selecting the priority name(s) from the list displayed. If you are not running against an XDB Server version that supports priorities, or if the XDB Server has the Governor feature turned off, the Priorities command is grayed out on the Admin menu.

For more information about the Governor features of the XDB Server, see the description of the Maximum Governor Cycle Time option in the section Governor Cycle Timein the chapter Server Configuration Utility in your SQL Option Server Administration Guide

Parent topic: SQL Wizard
Related information
Governor Cycle Time


Groups Dialog Box

Items appearing on the Groups dialog box are described in this topic.

Add | Creates a new GroupID. If AuthIDs appear in the MEMBER OF list, they are assigned to the group when the group is added.
Delete | Removes a group and dissociates all assigned AuthIDs from the GroupID.
Update | Changes a GroupID's information, including comments and/or memberships.
Close | Closes the Groups dialog box.
Group Name | Identifies the group. This field is up to eight characters long and must follow the rules for a short identifier.
Comment | Allows for the storage of additional information about the group or its purpose. The comment can be up to 254 characters in length.
Group Membership | Indicates which users belong to the displayed group. AuthIDs in the USER ID list on the left are not members of the group. AuthIDs in the MEMBER OF list on the right are members of the group.
Parent topic: SQL Wizard


Define Priority Dialog Box

Items appearing on the Define Priority dialog box are shown below.

Add | Defines a new set of priorities for XDB Server usage. Priorities are assigned to AuthIDs to limit server usage.
Delete | Permanently removes an XDB Server usage priority specification.
Update | Changes the parameters that define a priority specification for XDB Server usage.
Close | Closes the Define Priority dialog box.
Priority Name | Identifies a priority. This entry can be up to eight characters long.
Number of API Calls Specifies the maximum number of Application Programming Interface (API) calls allowed during a single session on the XDB Server.

This entry must be greater than or equal to zero. The entry must be greater than or equal to zero, up to a maximum of 999,999,999. When this entry is zero, users with this priority are not limited by the number of API calls in the XDB Server SQL engine.

APIs are routines that are invoked by calls to the SQL engine from the user's application. The number of API calls that users cause the XDB Server engine to invoke is an accurate gauge of their overall use of system resources. The purpose of limiting API calls is to control user access to the system resources.

To limit users to a certain number of API calls, you need to know how many calls the users generally need during the course of their work. In many cases, determining this number is complex because it is dependent on the size of the tables the user accesses. In this case it might be best to set the number of API calls to zero (unlimited number of API calls) while limiting the user with one of the other priorities.

Max Time in Engine | Specifies the maximum cumulative time (in seconds) a user with this priority can use the XDB Server SQL engine during a single session on the XDB Server (called being "in the engine"). This number must be greater than or equal to zero, up to a maximum of 999,999,999 seconds (31 years, 259 days, 1 hour, 40 minutes, and 39 seconds). When set to zero, users with this priority will be allowed unlimited time in the engine. The purpose of this limit is to control the use of system resources.
Max Time Per API | Specifies the maximum time allowed (in seconds) per API from a user with this priority. This number must be greater than or equal to zero, up to a maximum of 9,999 seconds. When set to zero, users with this priority will not be limited by how much SQL engine time is used by an API. The purpose of this limit is to prevent the use of too much SQL engine time on a single API.
Max Idle Time | Specifies the maximum time a user with this priority can be connected to the XDB Server without running any operation on the engine (called "idle time"). This number must be greater than or equal to zero, up to a maximum of 999,999,999 seconds. When set to zero, users with this priority will be allowed unlimited idle time. The purpose of this limit is to prevent users from taking up engine threads while not using the engine.
Max Fetches | Limits a user with this priority to a specified number of records returned (fetches). This number must be greater than or equal to zero, up to a maximum of 999,999,999 fetches. When set to zero, users with this priority will be allowed an unlimited number of fetches. The purpose of this limit is to control the use of system resources.
Start Enforcement Specifies the start of a time period (which ends with END ENFORCEMENT) when engine restrictions are enforced for a user with this priority. The format of the entry is dependent on the time picture defined in Options.
Note:

If the start and end free times are equal and not null (blank entry), then all priority limits are effectively canceled. This is equivalent to saying that the full 24-hour period is free time.
End Enforcement Specifies the end of the time period (which begins with Start Enforcement) when engine restrictions are enforced for a user with this priority. The format of the entry is dependent on the time picture defined in Options.
Note:

If the start and end free times are equal and not null (blank entry), then all priority limits are effectively canceled. This is equivalent to saying that the full 24-hour period is free time.
Comments | Adds an optional description (up to 254 characters) about the general purpose or scope of this priority.
Parent topic: SQL Wizard


Communications and Client/Server Binding

  • Client/Server Binding
    This chapter explains how Client/Server Binding works. It also describes how to connect your user programs to the generic client/server modules.
  • Client/Server Binding for Enterprise Server
    This chapter describes the introduction of Client/Server Binding support for Enterprise Server, and describes the key differences between this and previous implementations.
Parent topic: Mainframe Programming


Client/Server Binding

  • Introduction
  • How the Client/Server Binding Works
  • How to Use the Client/Server Binding
  • The Client/Server Binding Copyfile
  • The Client/Server Binding Configuration File
  • Connecting Your Client Program to mfclient
  • Connecting Your Server Program to mfserver
  • Running a Client/Server Binding Application
  • Debugging Your Application
  • Managing the Server
  • Advanced Topics
  • Client/Server Binding Limitations
Parent topic: Communications and Client/Server Binding


Introduction

The Client/Server Binding is a simple, light-weight, Remote Procedure Call (RPC) mechanism, for use with 300 clients or fewer, that enables you to implement a client/server architecture without having to worry about communications programming. The AAI (Application to Application Interface) component of the Client/Server Binding is provided for backward compatibility with applications developed with other products such as Net Express.

You should ensure that the capabilities and performance provided by the Client/Server Binding are adequate for your business needs. For many applications, this is the case and the Client/Server Binding offers a solution which is both easy to implement and cost-effective to deploy.

The Client/Server Binding removes the requirement for you to include communications code in your application. It provides four modules, mfclient, mfserver, aaiclnt, and aaisrvr, which include all the necessary communications code. aaiclnt and aaisrvr are only required when AAI is used with client/ server binding.

Based on information contained in a configuration file, these modules manage the communications link and the transfer of data and are able to interact with user-defined programs at each end of the link. The mfclient module is called by a user-written client program (which may, for example, handle the user interface) while mfserver calls a user-written server program (which may, for example, handle data access and business logic).

The user-written client and server programs use the copyfile mfclisrv.cpy to interact with the generic client/server modules.

Supplied with Net Express is an example application which demonstrates how the client/server binding can be used. This example application, which transfers file data between a client and a server, is installed in the sub-directory Csbind in your Net Express installdir\Examples\Net Express IDE directory. A further example application based on the Dialog System CUSTOMER demonstration, is installed in your Net Express installdir\Examples\Dialog System\CSBIND directory.

Parent topic: Client/Server Binding


How the Client/Server Binding Works

When used with CCI, the Client/Server Binding works by having a nondedicated copy of mfserver running on the server tier; this copy of mfserver communicates with any and all clients using an agreed server name. The mfserver module can be run using its built-in defaults, as its only function is to receive requests from the client to establish or terminate a connection.

The flow of information is explained below (the program files from the demonstration application Csbind are used as example client and server programs):

  1. The user-written client program (netxcli.cbl) performs any application initialization code, prompts the user for the name of a file, checks that the file exists and then calls mfclient.
  2. The first time mfclient is called, it reads configuration information from the configuration file netxdem.cfg.
  3. mfserver receives the connection request.
  4. mfserver spawns a secondary server for each client. The server name is internally generated, based on the name of the initial server with a numeric ID added (for example, mfserver01). Alternatively, you can specify a name in the configuration file.
  5. mfserver sends the secondary server name (mfserver01) back to mfclient and terminates the conversation.
  6. mfclient connects with the secondary server (mfserver01), passing parameters obtained from the configuration file via the LNK-PARAM-BLOCK. For more information see the section The Client/Server Binding Copyfile.
  7. mfserver01 calls the user-written server program (netxserv.cbl), passing the parameters received from mfclient via the Linkage Section.
  8. The first time the user-written server program (netxserv.cbl) is called, it performs any application initialization code, and exits the program. Control is returned to mfserver01.
  9. mfserver01 returns control to mfclient.
  10. mfclient ensures contact has been established and returns control to the user-written client program (netxcli.cbl).
  11. The client program (netxcli.cbl) opens the file specified by the user, reads a record from it and calls mfclient to pass the data via the Linkage Section.
  12. mfclient passes the data to mfserver01 via its internal buffer.
  13. mfserver01 passes the data to the user server program (netxserv.cbl) which creates a file and writes the record to it.

    This read record/write record loop continues until the user-written client program (netxcli.cbl) reaches end-of-file, at which point it closes the file and sends an indication that it is about to terminate to the server. The server responds by sending the name of the directory into which the file was copied.

  14. The client program (netxcli.cbl) displays the name of the file which has been created on the server and calls mfclient with LNK-CNTRL-FLAG set to "client-ending" and then terminates.
  15. mfclient passes the "client-ending" parameter to mfserver01 which passes it to the user-written server program (netxserv.cbl) which terminates itself.
  16. mfclient informs the base server (mfserver), that the secondary server (mfserver01) has terminated.

The process is different when Client/Server Binding is used with AAI. Your application still calls mfclient, but mfclient simply calls aaiclnt, which handles all client-tier interaction with AAI. Client/Server Binding can be used with the full AAI product or the AAI Thin Client. On the server tier, AAI starts an instance of mfserver for each request, and mfserver calls aaisrvr. (AAI can also be configured to invoke aaisrvr directly.) See the AAI documentation for more information.

Parent topic: Client/Server Binding
Related information
The Client/Server Binding Copyfile


How to Use the Client/Server Binding

To use the Client/Server Binding in your application, you need to:

  • Create a configuration(.cfg) file to control the behaviour of the mfclient and mfserver modules and the communications connection. The configuration file is an ASCII text file containing parameters allowing you to specify key information such as:
    • which communications protocol to use
    • the name of the user program to be called by mfserver
  • Add code to your client program to call the mfclient module.
  • Add code to your server program to enable it to be called by the mfserver module.

Each of these steps is explained in more detail below.

Parent topic: Client/Server Binding


The Client/Server Binding Copyfile

The mfclient and mfserver modules pass information to each other via the parameter block, LNK-PARAM-BLOCK, defined in the copyfile mfclisrv.cpy. The modules also use this parameter block to pass information to any user programs they have been requested to call. The mfclisrv.cpy copyfile must be included in any of your COBOL programs which use the mfclient and mfserver modules.

The mfclisrv.cpy copyfile is installed in the SOURCE directory in the base installation directory of your COBOL development system.

Parent topic: Client/Server Binding


The Client/Server Binding Configuration File

The Client/Server Binding configuration file controls the behaviour of the mfclient and mfserver modules as well as the communications link.

The Client/Server Binding configuration file is an ASCII text file which must have a .cfg extension. If you do not supply a configuration filename yourself, the default configuration filename, mfclisrv.cfg is used.

You can have separate configuration files for each application or you can supply multiple entries in a single file. If you are using multiple entries, each application must have its own tag entered in the file, followed by the list of parameters for that application. You must then specify this tag-name in your client program using the LNK-TAGNAME field in the LNK-PARAM-BLOCK parameter block. This technique can be used to reduce your command line length by specifying your multiple entries in the default configuration file, mfclisrv.cfg.

If your client/server application is incorrectly set up, any invalid entries found in the configuration file will cause the programs reading them to terminate with a message displayed on the screen detailing the invalid entries.

These errors are also logged in the mfclisrv.log file, which is created in the current directory, or in the directory indicated by the MFLOGDIR environment variable. This enables a server which is not directly connected to a terminal to log messages.

  • Configuration File Parameters
  • Minimum Required Configuration File Entries
  • Locating the Configuration File
Parent topic: Client/Server Binding


Configuration File Parameters

Listed below are all of the possible entries for the mfclisrv.cfg configuration file. Entries are listed in alphabetical order. Any entries which you do not specify in your configuration file assume the default values.

aaiservice=name PIC X(128) [default: MFCLISRV]

Name of the AAI Service to connect to when using Csbind with AAI. This is the logical service name entry in the AAI administration system.
cblksize=nnnn PIC X(4) COMP-X [default: 0]

Size of Dialog System control block. For use with Dialog System only.
clierrprog=name PIC X(128) [default: none]

Name of the program which will handle communication errors instead of mfclient. You can enter a name of SAME to use the calling program to handle any mfclient errors.

This parameter is not supported with AAI.
commsapi=api PIC X(4) [default: CCI]

The communications API; valid values are CCI, AAI or NONE. The special entry NONE can be used when developing two tier applications to allow testing to be undertaken on a single PC without any communications products. Data is passed directly between mfclient and the user-written server program, bypassing mfserver and the communications requirement.

Note: You cannot use this option if an existing application is being deployed as the user-written server program.
compress=nnn PIC 9(3) [default: 000]

The number of the compression routine to be used, for example, 001 indicates that routine CBLDC001 will be used. Setting this parameter to 0 indicates that data compression will not be used.
dblksize=nnnn PIC X(4) COMP-X [default: 0]

The size of the user data area used to pass data between the user-written client and server programs. For Dialog System applications this will be the size of the Dialog System datablock.

CAUTION:
Unpredictable results can occur if this entry is less than the actual size of the data area being used.
eblksize=nnnn PIC X(4) COMP-X [default: 0]

The size of the optional Dialog System Event block.

This parameter is not supported with AAI.
machinename=name PIC X(34)

The name of the machine on which the server specified in the servername entry is located. This prevents the system searching for the first match of the defined name.

This parameter is not supported with AAI.
maxtimeout=nnnn PIC X(4) COMP-5 [default: 0]

Limits the number of timeouts before mfclient gives up trying to connect to the server. The default value of 0 means no limit; that is, keep trying until the connection succeeds.
maxtrans=nn PIC 99 [default: 0]

The maximum transfer package size in Kilobytes. Setting maxtrans to 0 causes CSBIND to use an in-built maximum size. This is larger than 62k. If the total buffer size exceeds this amount, the system will make multiple transfers of maxtrans size until the total buffer is transferred.

This parameter is not supported with AAI.
midconfig=filename PIC X(128) [default: none]

The name of the configuration file to be used by mfclient when called by mfserver as part of a cross-tier solution. Specifying this entry causes mfserver to act as a router passing data to a local mfclient module. This mfclient module uses this configuration file to locate and communicate with another server. This allows protocols and communications APIs to be changed across the machines used.

This parameter is not supported with AAI.
protocol=protocol PIC X(8) [default: CCITC32]

The CCI protocol to be used. This entry is only applicable if commsapi is set to CCI. You can specify any of the supported CCI protocols: Novell IPX (enter CCIIX32), NetBEUI (enter CCINB32), Dynamic Data Exchange (enter CCIDE32) or TCP/IP (enter CCITC32). Note that if commsapi is set to CCI (which is the default) and you do not specify a protocol, the Client/Server Binding defaults to TCP/IP (CCITC32).

This parameter is not supported with AAI.
scrntype=type PIC X(4) [default: none]

If, for example, the user program supports both GUI and character interfaces this entry can be used as an indicator to tell the client program which type of interface is being used. scrntype is not validated by the Client/Server Binding modules.

This parameter is not supported with AAI.
servername=server PIC X(14) [default: MFCLISRV]

The servername to be used for communications.

This parameter is not supported with AAI.
setenv=namevalue PIC X(148) [default: none]

Environment variable to be set on the server before the execution of any server programs. The format is:

variable name PIC X(20)

variable value PIC X(128)

The name and value fields must be separated by at least one space character. Up to nine setenv entries can be specified.

This parameter is not supported with AAI.
srvanim=x PIC X(16) [default: N]

Y or N. Setting this parameter to Y enables debugging of the user programs running on the server. This means that mfserver does not have to be stopped and restarted with COBSW=+A as this is set up dynamically.

On UNIX systems only, you can specify a value of x,filename to enable cross-session debugging of your programs. See the section Debugging your Application for more details.

This parameter is not supported with AAI.
srverrprog=name PIC X(128) [default: none]

Name of the program which will handle communication errors instead of mfserver. You can enter a name of SAME to use the name set in the srvprog entry for mfserver errors.

This parameter is not supported with AAI.
srvprog=name PIC X(128)

Name of the user-written program to be called by mfserver.
srvtier=name PIC X(128) [default: mfserver]

The name of the server tier program. When specified, it indicates that mfserver will be called by this program.

This parameter is not supported with AAI.
subserver=base-name PIC X(14) [default: none]

The base-name to be used for communicating with sub-server processes. The default server-name is mfclisrv and sub-servers are named mfclisrv00001,mfclisrv00002 and so on. Setting this parameter to newserv results in sub-server names of newserv00001, newserv00002 and so on. This enables application-specific sub-server names to be used without changing the base server name.

This parameter is not supported with AAI.
timeout=nnnn PIC X(4) COMP-5 [default: 120 secs)

You can use this parameter to override the system timeout default. The timeout period is specified in 1/10 (tenths) of a second. Previously issued calls retain the timeout period that was in use when they were originally invoked.

This parameter is not supported with AAI.
ublksize=nnnn PIC X(4) COMP-X [default: 0]

Size of optional user data block.
useraudit=x PIC X [default: N]

Y or N. Setting this parameter to Y results in the logging of client connect and disconnect details. When set, the following details are logged by both client and server: date, time, connect/disconnect indicator, servername, machinename, and protocol. These details are written to the system log file, see Creating Audit Trails and System Log File below.
Parent topic: The Client/Server Binding Configuration File
Related information
Debugging your Application
Creating Audit Trails
System Log File


Minimum Required Configuration File Entries

The minimum entries required in the configuration file vary according to:

  • The application being used.
  • The number of servers being run.
  • The communications protocol being used.

You must always have the following entries:

dblksize | The size of the user data area used for data transfer
srvprog | The name of the program that mfserver calls to perform the server-side processing. This is the user program on the server machine (that is,the COBOL program performing data access and business logic).

When running multiple servers, you must supply the name of the server to be used via the servername entry.

If you do not intend to use TCP/IP, you must set the protocol entry.

Any configuration file entries which are unset assume the specified default values.

Parent topic: The Client/Server Binding Configuration File


Locating the Configuration File

Your configuration file can be located where it best suits you. The mfclient and mfserver programs attempt to locate the configuration file as follows:

  1. They look for the MFCSCFG environment variable and use the supplied filename if one is specified.
  2. They examine the command line and use any filename defined there in preference to that supplied via the MFCSCFG environment variable.
  3. If neither of the above yields a filename, the default filename mfclisrv.cfg is assumed and searched for in the current directory.
  4. If mfclisrv.cfg is not found, the default settings for the configuration entries are used.

In each case a full pathname of up to 128 characters can be used to identify the location of the configuration file.

Parent topic: The Client/Server Binding Configuration File


Connecting Your Client Program to mfclient

The mfclient and mfserver modules pass information to each other via a parameter block described in the mfclisrv.cpy copyfile. The modules use the same parameter block, LNK-PARAM-BLOCK, to pass information to user programs.

You must add code to your program, as in the example below, to enable it to pass parameters to mfclient.

$SET ANS85

 WORKING-STORAGE SECTION. ......

*--- mfclisrv.cpy must be included in the working storage
*--- section of the client program and in the linkage
*--- section of the server program.

 COPY "MFCLISRV.CPY".

 LINKAGE SECTION. ......

*--- Input-Rec is the area used for transfering data
*--- between the user client and the server programs.
*--- The size of this data area is defined by the user
*--- in the Client/Server Binding configuration file
*--- which is read by the mfclient module. mfclient
*--- sets up the required memory for this area and
*--- returns a pointer to this area back to the user
*--- client program (see below).

 01 INPUT-REC               PIC X(32767)

 PROCEDURE DIVISION.

 CLIENT-CONTROL SECTION.

     PERFORM UNTIL END-CONNECTION

*--- lnk-client holds the name "mfclient".
*--- The first time through we initialize mfclient and
*--- establish contact with the server.

         CALL LNK-CLIENT USING LNK-PARAM-BLOCK

         EVALUATE TRUE

*--- Make the user data area (Input-Rec) accessible by
*--- assigning the address returned by mfclient.

          WHEN START-CONNECTION
             SET ADDRESS OF INPUT-REC TO LNK-DBLOCK-PTR

          WHEN END-CONNECTION
             EXIT PERFORM

          WHEN OTHER

*--- Perform your application client logic. For example,
*--- display and accept user interface data.

              ......

         END-EVALUATE

*--- Set a user defined flag (eg. EXIT-FLG-TRUE) to indicate
*--- that client processing has terminated. For example, you
*--- may have clicked on the EXIT push button on your
*--- application interface.

         IF EXIT-FLG-TRUE
            SET CLIENT-ENDING TO TRUE
         END-IF

     END-PERFORM.

 CLIENT-CONTROL-END.
     STOP RUN.

If you want to control the number of clients running an application, or you choose to handle error message displays yourself, you will need to add code similar to the following to your program's initial EVALUATE statement:

           WHEN TOO-MANY-CLIENTS
              PERFORM OVER-CLIENT-LIMIT

           WHEN COMMS-ERROR
              PERFORM SHOW-ERROR

           ......

 OVER-CLIENT-LIMIT SECTION.
     DISPLAY SPACES AT 0101 WITH BACKGROUND-COLOR 7
        "MAXIMUM NUMBER OF CLIENTS EXCEEDED - SESSION ENDED"
        AT 1012 WITH FOREGROUND-COLOR 4
     SET EXIT-FLG-TRUE
     SET CLIENT-ENDING TO TRUE
     EXIT.

 SHOW-ERROR SECTION.
     DISPLAY LNK-ERROR-LOC AT 2201
     DISPLAY LNK-ERROR-MSG AT 2301
             WITH SIZE LNK-ERROR-MSG-LEN.
     EXIT.

If asynchronous requests are to be handled, you must add to the EVALUATE statement additional code similar to the following:

Note: ASYNC-REQUEST is not necessary if you are using AAI.
WHEN START-CONNECTION
   PERFORM GET-USER-INPUT
   IF MAKE-ASYNC-REQUEST <* user asynchronous option
      SET ASYNC-REQUEST TO TRUE
   END-IF

WHEN ASYNC-OK
   SET TEST-ASYNC-RESULT TO TRUE
   PERFORM DELAY-LOOP

WHEN ASYNC-INCOMPLETE
   DISPLAY "REQUEST STILL BEING PROCESSED" AT 1010
   PERFORM DELAY-LOOP
   SET TEST-ASYNC-RESULT TO TRUE

WHEN RESULT-OK
   DISPLAY "REQUEST-COMPLETED " AT 1010
   PERFORM GET-USER-INPUT

WHEN ASYNC-NOT-STARTED
WHEN ASYNC-FAILED
   DISPLAY "ASYNCHRONOUS REQUEST FAILURE " AT 1010
   PERFORM SHOW-ERROR
   PERFORM GET-USER-INPUT

WHEN COMMS-ERROR
   PERFORM SHOW-ERROR
Parent topic: Client/Server Binding


Connecting Your Server Program to mfserver

The mfclient and mfserver modules pass information to each other via a parameter block described in the mfclisrv.cpy copyfile. The modules use the same parameter block to pass information to any user programs.

Your server program must include the copyfile, mfclisrv.cpy in the Linkage Section. You must also modify the Procedure Division header to include the parameter block, LNK-PARAM-BLOCK, which is used to pass parameters from mfserver.

This is shown below in the example server code:

 LINKAGE SECTION.

 01 INPUT-REC                 PIC X(32767).

 COPY "MFCLISRV.CPY".*--- lnk-param-block is the record definition in mfclisrv.cpy

 PROCEDURE DIVISION USING LNK-PARAM-BLOCK.

 CONTROLLING SECTION.

*-----------------------------------------------------------*
*  associate the user data area with the pointer in
*  lnk-parm-block.
*-----------------------------------------------------------*

     SET ADDRESS OF INPUT-AREA TO LNK-DBLOCK-PTR.

     EVALUATE TRUE

      WHEN START-CONNECTION
         PERFORM PROGRAM-INITIALIZE

      WHEN OTHER
         PERFORM PROGRAM-BODY

     END-EVALUATE.
     EXIT PROGRAM.

 PROGRAM-INITIALIZE SECTION.

*--- This code would include the initialization code
*--- for your server program eg. opening your application
*--- data files.

     ......

 PROGRAM-BODY SECTION.

*--- This section would include your application
*--- processing code eg. read and writing of data
*--- files.

     ......

If you choose to handle error message displays yourself, you will need to add code similar to the following to your program's initial EVALUATE statement:

           WHEN COMMS-ERROR
              PERFORM SHOW-ERROR

           ......

 SHOW-ERROR SECTION.
     DISPLAY LNK-ERROR-LOC AT 2201
     DISPLAY LNK-ERROR-MSG AT 2301 WITH SIZE LNK-ERROR-MSG-LEN.
     EXIT.
Parent topic: Client/Server Binding


Running a Client/Server Binding Application

The mfserver module is provided in .int code format so that it can be run as it is or generated into .gnt code.

If you have a UNIX system running Micro Focus COBOL 3.2 or later, you can move the .int module to your UNIX system and link it with other programs to create an executable module.

The mfclient and mfserver modules are run as standard COBOL programs, with both the client and server components started manually.

Note: Client/Server Binding for CCI supports both 32 and 64 bit modes.

To run the Client/Server Binding, first start the server program, then start the client program.

Windows:

The command line to start the server program on Windows is:

run mfserver [-b] [-p protocol] [-s server-name] [-v]

UNIX:

and on UNIX:

cobrun mfserver [-b] [-p protocol] [-s server-name] [-v]

where:

-b | Allows you to run the server as a background process. On UNIX systems, the command line should be terminated with the '&' character. Any error messages produced by the server will be stored in the log file (mfclisrv.log).
-p protocol | Specifies the communications protocol.
-s server-name | Indicates a server-name other than the default (mfclisrv).
-v | Displays the mfserver version number.
Note: To use mfserver in 64-bit mode, you must start it using "cobrun64 mfserver [options]", not "cobrun mfserver [options]".

The command line to start the client program is:

run program-name [config-filename]

where:

program-name | Specifies the name of the user interface program.
config-filename | Specifies the name of the configuration file to be used.
Parent topic: Client/Server Binding


Debugging Your Application

You can debug your client program using the standard debug facilities of Studio Enterprise Edition.

You can debug your server program by setting a configuration file parameter, srvanim=y (see Configuration File Parameters).

On PC servers, the Debugger is started automatically when a client connects to the server if srvanim=y is set.

On UNIX servers, the Debugger is run on the terminal from which mfserver was started and so requires mfserver to be running in foreground mode. This can cause problems as it is preferable to run mfserver as a background process. A further restriction is that only one user can debug through mfserver at any one time. These problems can be avoided by setting srvanim=x,filename where filename is a file created using the touch command. On the terminal that you want to use to display Debugger output, set COBANIM_2=animator and then run the command anim filename. On the terminal that you want to use for your standard input and output, run your application in the normal way, having added srvanim=x,filename to your configuration file.

Parent topic: Client/Server Binding


Managing the Server

The behaviour of the server can be altered by running the program mfcsmgr and passing it the required parameters and values. These parameters can be divided into two groups: location and action. The parameters in the location group allow you to locate the target server, and can have settings m, p, and s. The action parameters control how the target server will be affected and can have settings a, c, o, r and t. Certain action parameters cannot be specified in combination with any other, these are o, r and t.

The mfcsmgr program has no effect on applications running under AAI control.

  • Shutting Down mfserver
  • Managing Authorisation Passwords
  • Setting the Maximum Number of Clients
  • Enabling Server Override
Parent topic: Client/Server Binding


Shutting Down mfserver

The spawned servers are terminated by the client program when the client makes a normal exit. The initial server program does not terminate when its clients terminate, so if you want to shut down this server you must do so manually.

Parent topic: Managing the Server


Managing Authorisation Passwords

To prevent accidental shutdown of an active server, it is possible to assign a password to each server. This password must be supplied before the server can be stopped or its parameters changed.

Parent topic: Managing the Server


Setting the Maximum Number of Clients

The default number of clients the server can support is 300 when using CCI, but you can set a lower limit using one of the mfcsmgr functions. The number you select is stored in the password file and will be used each time the server is started. Client/Server Binding does not limit the number of clients when using AAI.

Parent topic: Managing the Server


Enabling Server Override

The server can support override options for the servername, protocol, and machinename. As the server does not use a configuration file the override parameters are supplied using the mfcsmgr program. This generates a short exchange between the client and the server which processes the selected function.

The command line syntax for mfcsmgr is:

Windows:

run mfcsmgr [-a] [-c nnnnn] [-d] [-i filename]
                  [- m machine-name] [-p protocol] [-s server-name]
            [-o m, machine-name] [-o p, protocol] [-o r]
            [-o s, server-name] [-t] [-v]

UNIX:

cobrun mfcsmgr [-a] [-c nnnnn] [-d] [-i filename]
               [- m machine-name] [-p protocol]
               [-s server-name] [-o m, machine-name]
               [-o p, protocol] [-o r] [-o s, server-name]
               [-t] [-v]

where:

-a | Changes the authorisation password associated with the target server.
-c,nnnnn | Sets the number of clients the server can support.
-d | Deletes the local overide file (mfcsovrd.cfg) when the client exits.
-i filename | Installs the specified file in the client's local directory when the client exits.
-m machine-name | Specifies the name of the machine on which the target server is running. This is required if the same server-name is used on more than one platform.
-p protocol | Specifies the communications protocol being used: TCP/IP (CCITC32), NetBEUI (CCINB32), Novell IPX (CCIIX32) or Dynamic Data Exchange (CCIDE32).
-s server-name | Indicates a server-name other than the default (mfclisrv).
-o m,machine-name | Specifies the machine-name on which the overriding is running.
-o p,protocol | Uses this protocol to access the overriding server.
-o r | Resets active override. Reverts to original settings.
-o s,server-name | Overrides connections to the target server by directing them to this server.
-t | Terminates the server
-v | Displays the mfclient version number.

All the above flags can be specified with a - or /, and are not case-sensitive.

Parent topic: Managing the Server


Advanced Topics

  • System Log File
  • Creating Audit Trails
  • Overriding Configuration File Entries
  • Using Dialog System 'Callout'
  • Using an existing Dialog System program as the server module
  • Using the In-line Configuration Facility
  • The Reduced Data Transfer Facility
  • Server Controlled File Management Facility
Parent topic: Client/Server Binding


System Log File

Both mfclient and mfserver maintain a log of errors and messages. All entries are date- and time-stamped and are kept in a file called mfclisrv.log which is stored in the directory in which the programs were started or in the directory named in the MFLOGDIR environment variable. Check this log from time to time to ensure that your system is performing correctly.

Parent topic: Advanced Topics


Creating Audit Trails

You can create an audit trail of dates and times that clients connected to servers. To enable this feature, simply set useraudit=y in your configuration file.

This information is created in the system log file described above.

Parent topic: Advanced Topics


Overriding Configuration File Entries

During the start-up process for each client, once the configuration file has been read, the Client/Server Binding searches for a file called mfcsovrd.cfg. It searches for this file in the system log file directory. If the file is found, its contents are used to override any parameters previously set up using the configuration file. The format of the override file is identical to that of the standard configuration file with the exception of a single additional entry, override-cntrl. This entry is used to indicate the subject of the override which may be a server name or a tag-name. If a server name is specified, any clients using that server have their parameters modified by the contents of the override file. If a tag-name is specified, only those clients using the specified tag-name have their parameters altered.

The client override facility can be used, for example, if a server is unavailable and applications need to be run on another machine. You could of course change the individual configuration files, but a single override file can be used to re-route any number of applications.

The override facility can also be used on the server, but in this case the server machine needs to be up and running. As before, either server names or tag-names can be overridden.

An entry is added to the log file whenever an override file is detected, and all parameters which are subject to the override process are logged.

The following example shows how the override facility can be used to re-route clients to another server:

[override-cntrl]
override=servername
[oldserver]
servername=newserver

In this example the [override-cntrl] section specifies that the subject of the override is a server name (override=servername) and then, under the the old server name ([oldserver]), the new server name (servername=newserver) is specified. This would result in the following log file entries:

20/04/1998 11:01:02 Using Local File: mfcsovrd.cfg
Overriding Entries for Servername:OLDSERVER
servername=newserver
20/04/1998 11:01:02 Override Completed:

The following example shows how the override facility can be used to override the server being used by all those clients which are using a specified tag:

[override-cntrl]
override=tagname
[mf-clisrv]
servername=newserv

In this example the [override-cntrl] section specifies that the subject of the override is a tag-name (override=tagname) and then, under the tag-name ([mf-clisrv]), the parameter to be overridden (in this case the server name) is specified (servername=newserv). This would result in the following log file entries:

20/04/1998 11:04:02 Using Local File: mfcsovrd.cfg
Overriding Entries for Tagname:MF-CLISRV
servername=newserv
20/04/1998 11:04:02 Override Completed:
Parent topic: Advanced Topics


Using Dialog System 'Callout'

If you wish to use the callout facility of Dialog System with the Client/Server Binding, you have to make a small change to your user client program, and create programs to service the callout request at either end of the connection. You need to add two lines and a directive to your user client program, as follows-:

At the start of the program:

$set ans85 linkcount(128)

In Working-Storage:

 01  lnk-param-block-addr         POINTER EXTERNAL.

In the Procedure Division:

     SET lnk-param-block-addr
              TO ADDRESS OF lnk-param-block

The reason for this is so that the program called by dialog to handle the callout request has access to the same parameter entries as your user client program. This is achieved by use of an external data pointer. The callout program needs to have code similar to that in the example below:

$set ans85
 WORKING-STORAGE SECTION.

 01  lnk-param-block-addr         POINTER EXTERNAL.

 LINKAGE SECTION.

 COPY "mfclisrv.cpy".

 01  user-data-block              PIC X(30).

 PROCEDURE DIVISION.
 Controlling SECTION.
     SET ADDRESS OF lnk-param-block TO lnk-param-block-addr
     SET ADDRESS OF user-data-block TO lnk-ublock-ptr
     SET ds-callout TO TRUE
     MOVE "callosrv" TO user-data-block
     CALL lnk-client USING lnk-param-block
     EXIT PROGRAM.

The name of the program which will receive the callout request on the server is setup in the user-data-block. If the name of this program can only be determined from data in any of the control blocks used by Dialog System, you will have to make these accessible using coding similar to that in the following program-:

$set ans85 linkcount(128)
 WORKING-STORAGE SECTION.

 01  lnk-param-block-addr         POINTER EXTERNAL.

 LINKAGE SECTION.

 COPY "mfclisrv.cpy".

 01  user-data-block              PIC X(30).

     COPY "DS-CNTRL.MF".
     COPY "CUSTOMER.CPB".

 PROCEDURE DIVISION USING ds-control-block customer-data-block.
 Controlling SECTION.
     SET ADDRESS OF lnk-param-block TO lnk-param-block-addr
     SET ADDRESS OF user-data-block TO lnk-ublock-ptr
     SET ds-callout TO TRUE
     EVALUATE cust-callout-flg
      WHEN 1
         MOVE "callprog1" TO user-data-block
      WHEN 2
         MOVE "callprog2" TO user-data-block
     END-EVALUATE
     CALL lnk-client USING lnk-param-block
     EXIT PROGRAM.

The callout program on the server side will look something like this-:

$set ans85

 LINKAGE SECTION.

     COPY "DS-CNTRL.MF".
     COPY "CUSTOMER.CPB".

 PROCEDURE DIVISION USING ds-control-block customer-data-block.
 Controlling SECTION.
       ............ Code to
           ........... process callout
               ............ request....
           EXIT PROGRAM.
Parent topic: Advanced Topics


Using an existing Dialog System program as the server module

When used with CCI, the Client/Server Binding has the ability to use an existing Dialog System program as the user server module. It does this when srvtier=your-program (for details, see Configuration File Parameters).

In this instance, mfserver expects to be called with a set of parameters which conform to the Dialog System API. When used in this way, the user program makes calls to mfserver to transfer data to the client and so becomes the controlling element on the server. It is possible to have other programs perform the same function, as long as they conform to the API used by Dialog System.

The Client/Server Binding normally checks certain items within the first parameter of the API, and performs particular functions based on the value found. This behaviour can be prevented by setting these items to HIGH-VALUES. You need to call mfserver with two parameters:

  • The first parameter represents the Dialog Control Block and needs to be between 6 and 399 bytes in length. The sixth byte is checked so this needs to be set to HIGH-VALUES to avoid calls being made to Dialog System. The rest of this parameter can be made use of or ignored as required.
  • The second parameter is the user data block, and this can be any size you wish.

The size of both these items needs to be defined in the configuration file used to run the application. A pair of demo programs and the necessary configuration file have been provided here as an example, they are:

  • nodscli.cbl - The client module:
    $set ans85
 WORKING-STORAGE SECTION.
 01  w-prog-id                pic x(30) value
      '"@(#) nodscli.cbl 1.1.1"'.

  copy "mfclisrv.cpy".

 01  ws-scrn-pos.
     03  ws-line              pic 99 value 07.
     03  ws-col               pic 99 value 1.

 LINKAGE SECTION.
 01  ds-control-block         pic x(6).

 01  NODS-DATA-BLOCK.
     03  NODS-PARAM           PIC 99.
     03  NODS-DATA            PIC X(120).

 procedure division.
 000-control section.
* Make initial contact with the server
     call lnk-client using lnk-param-block
     if start-connection
         set address of ds-control-block to lnk-cblock-ptr
         set address of nods-data-block to lnk-dblock-ptr
     end-if

     display spaces at 0101
             "Starting Test Session" at 0510
     perform 010-run-test until nods-param = 10
* Send disconnect request
     set client-ending to true
     call lnk-client using lnk-param-block
     display "Test Session Completed" at 2010
     stop run.

 010-run-test section.
* Get data from server
     call lnk-client using lnk-param-block
     add 1 to ws-line
     display nods-data(1:80) at ws-scrn-pos
     exit.
  • nodssrv.cbl - The server module:
    $set ans85
 working-storage section.
 01  w-prog-id                 pic x(30) value
     '"@(#) nodssrv.cbl 1.1.1"'.

 01  dummy-cntrl-block         pic x(6) value high-values.

 01  NODS-DATA-BLOCK.
    03  NODS-PARAM            PIC 99.
    03  NODS-DATA             PIC X(120).

     copy "mfclisrv.cpy".

 01  ws-sub                    pic 99.
 01  ws-table.
    03  ws-letts               pic x occurs 10.

 procedure division.
 controlling section.

     move "ABCDEFGHIJ" to ws-table
     move 0 to nods-param
*
* Establish contact with the client.
* This needs to be done as early as possible to stop the
* Client timing out and 'polling' the network looking for
* the server.
*
     call "mfserver" using dummy-cntrl-block nods-data-block
*
* You must ensure that you don't call 'mfserver' after the
* client has issued a shutdown request. In this system
* nods-param = 10 causes to client to issue the shutdown
* request and ends the driving loop in this program.
*
     perform varying nods-param from 1 by 1
             until nods-param > 10
         perform varying ws-sub from 1 by 1
                 until ws-sub > 80
             move ws-letts(nods-param)
                       to nods-data(ws-sub:1)
         end-perform
         call "mfserver" using dummy-cntrl-block
                                nods-data-block
     end-perform
     stop run.
  • nods.cfg - The configuration file:
    *********************************************************
* Micro Focus - Client Server Module Configuration File *
*********************************************************

[mf-clisrv]
srvtier=nodssrv
cblksize=6
dblksize=122
servername=nods

When compiled and run, the server program passes data to the client without losing its position which would occur if it was a called program and had to use an 'EXIT PROGRAM' each time data needed to be passed to the client. If your existing program is unable to conform to the required Dialog System API, you can still use the above method by introducing a small bridge program as decribed below.

 WORKING-STORAGE SECTION.

 01  dummy-control-block          PIC X(6) VALUE HIGH-VALUES.
 01  grouped-data-block.
   03  ws-param-1                PIC X(50).
    03  ws-param-2                PIC X(120).
    03  ws-param-3                PIC X(18).
    03  ws-param-4                PIC X(48).

 LINKAGE SECTION.

 01  lnk-param-1                  PIC X(50).
 01  lnk-param-2                  PIC X(120).
 01  lnk-param-3                  PIC X(18).
 01  lnk-param-4                  PIC X(48).

 PROCEDURE DIVISION USING
         lnk-param-1 lnk-param-2
         lnk-param-3 lnk-param-4.

     MOVE lnk-param-1 TO ws-param-1
     MOVE lnk-param-2 TO ws-param-2
     MOVE lnk-param-3 TO ws-param-3
     MOVE lnk-param-4 TO ws-param-4

     CALL "mfserver" USING dummy-control-block
                            grouped-data-block

     MOVE ws-param-1 TO lnk-param-1
     MOVE ws-param-2 TO lnk-param-2
     MOVE ws-param-3 TO lnk-param-3
     MOVE ws-param-4 TO lnk-param-4

     EXIT PROGRAM.
Parent topic: Advanced Topics


Using the In-line Configuration Facility

One of the most powerful features of the Client/Server Binding is the ability to control the communications requirements from configuration files. This does mean, however, that end-users can affect the way an application runs by changing entries in these files, and this may not be desirable.

It is possible, therefore, to provide all the configuration parameters within the client program. This means that the end-user cannot alter the way an application behaves because it no longer uses a configuration file. There is still no need to write complex communications code, you simply supply the required parameters within your client program. The process is started by setting load-inline-cfg and completed by setting end-inline-cfg. Each parameter entry is loaded into the lnk-error-msg field and mfclient is called to process it. The parameters have to be supplied before the main processing loop is entered. An example is given below.

In-line configuration is not supported when using AAI.

 WORKING-STORAGE SECTION.

  COPY "mfclisrv.cpy".

 LINKAGE SECTION.

 01 INPUT-REC                 PIC X(32767)

 PROCEDURE DIVISION.

 Client-Control SECTION.

     SET load-inline-cfg TO TRUE
     MOVE "clierrprog=same" TO lnk-error-msg
     CALL lnk-client USING lnk-param-block

     MOVE "srverrprog=same" TO lnk-error-msg
     CALL lnk-client USING lnk-param-block

     MOVE "servername=mainserv" TO lnk-error-msg
     CALL lnk-client USING lnk-param-block

     SET end-inline-cfg TO TRUE

*  The main loop is repeated until the connection with
*  the server ends

     PERFORM UNTIL End-Connection

*  'lnk-client' holds the name 'mfclient'
*  The first time through we initialize the system and
*  establish contact with the server.

     CALL lnk-client USING lnk-param-block

     EVALUATE TRUE

      WHEN start-connection

      ........ The rest of the program is standard from this
      ........... point onwards  ............

It is also possible to combine an external configuration file with the in-line configuration facility. This provides the best of both worlds in that the end-user can modify the system to their own requirements, but ultimate control remains within the client program. The configuration file is processed first followed by the in-line entries. This means that any unwanted parameters supplied in the configuration file can be overwritten by the in-line entry. In this case the process is started by setting use-combined-cfg and completed as before by setting end-inline-cfg.

 WORKING-STORAGE SECTION.

 COPY "mfclisrv.cpy".

 LINKAGE SECTION.

 01 INPUT-REC                 PIC X(32767)

 PROCEDURE DIVISION.

 Client-Control SECTION.

     SET use-combined-cfg TO TRUE
     CALL lnk-client USING lnk-param-block

     SET load-inline-cfg TO TRUE
     MOVE "servername=mainserv" TO lnk-error-msg
     CALL lnk-client USING lnk-param-block

     SET end-inline-cfg TO TRUE

*  The main loop is repeated until the connection with
*  the server ends

     PERFORM UNTIL End-Connection

*  'lnk-client' holds the name 'mfclient'
*  The first time through we initialize the system and
*  establish contact with the server.

     CALL lnk-client USING lnk-param-block

     EVALUATE TRUE
      WHEN start-connection

      ........ The rest of the program is standard from this
      ........... point onwards  ............
Parent topic: Advanced Topics


The Reduced Data Transfer Facility

The Client/Server Binding assigns a buffer large enough to hold the data blocks defined in the configuration file. This buffer is transferred back and forth whenever control is shifted between the client and server programs. This can impose a load on the network which some users may find unacceptable. Imagine you have a buffer of 24K which contains a 22K record area. If the file which holds these records has a 10-byte key, sending the key from client to server uses 24K when only 10 bytes are actually required. In reality, you do need one or two bytes more than the size of the data, but much less than the size of the entire buffer. This is what Reduced Data Transfer (RDT) provides, a way for you to control the amount of data being passed across the network and for you to limit this data to the absolute minimum required. When Client/Server Binding is used with AAI, the RDT functions are ignored.

Reduced Data Transfer requires a contol flag (use-rdt) and three parameters:

lnk-usr-fcode | The user function indicator. This indicates to the receiver what to do with the data that has just arrived.
lnk-usr-retcode | The buffer start point. This indicates which of the four data areas will be used as the start point for the transfer. Valid values are: 1=cblock, 2=dblock, 3=eblk, and 4=ublk. The numbers 11 through 14 can also be used to indicate the same address areas but using data compression. Data compression must have been enabled via a configuration file entry or the base (un-compressed) option will be used. A value of zero results in nothing being transferred. This allows you to have a NULL operation without changing the flow of your code by adding various IF statements. This is useful if you choose to process certain functions locally in order to further reduce network traffic.
lnk-data-length | The length of data to be transferred.

Consider an application which allows you to add, delete, and load customer details to/from an index file. The record key for the customer details file is a customer code. The application also has an option to clear all customer information from the interface. The code extract below is based on this example application and uses the user-data-block area to hold the record key which is six bytes long. The data block area (dblksize) used by the application to pass the customer record details between the client and the server is called customer-data-block. The data item customer-c-code is a 6-byte data item within customer-data-block and is used to store the record key.

On the client, the code would be similar to:

     EVALUATE TRUE

      WHEN customer-load-flg-true

*--- User has entered customer code and selected the "LOAD"
*--- option on the interface to read and display the customer
*--- details relating to that code.

          MOVE customer-c-code TO user-data-block
          SET use-rdt TO TRUE
          MOVE 1 TO lnk-usr-fcode
          MOVE 4 TO lnk-usr-retcode
          MOVE 6 TO lnk-data-length

       WHEN customer-del-flg-true

*--- User has entered a customer code selected the DELETE
*--- option to delete the customer record from the file.

          MOVE customer-c-code TO user-data-block
          SET use-rdt TO TRUE
          MOVE 2 TO lnk-usr-fcode
          MOVE 4 TO lnk-usr-retcode
          MOVE 6 TO lnk-data-length
          initialize customer-data-block

       WHEN customer-clr-flg-true

*--- User has selected the CLEAR option to clear the current
*--- customer details from the screen.

          SET use-rdt TO TRUE
          MOVE 0 TO lnk-usr-retcode
          initialize customer-data-block
          PERFORM Set-Up-For-Refresh-Screen
      END-EVALUATE

The clear option uses a NULL operation because clearing the record is done locally so there is no need to contact the server. Below is an extract from the server program showing the code required to process Reduced Data Transfer. The Client/Server Binding sets the flag send-via-rdt so that you can check the values of lnk-usr-fcode. On the server, the code would be similar to:

       WHEN send-via-rdt
          EVALUATE lnk-usr-fcode
           WHEN 1

*--- For the LOAD function the server program reads the
*--- customer details from the data file and sends the data
*--- back to the client using the data area customer-data-
*--- block rather using the RDT faclity.  Unless the RDT
*--- flag is set the client/server bindings will always pass
*--- the complete data area (defined by dblksize in the
*--- configuration file) between the client and the server.
              MOVE user-data-block TO customer-c-code
              SET customer-load-flg-true TO TRUE
              PERFORM ....... rest of program.......
           WHEN 2
              MOVE user-data-block TO customer-c-code
              SET customer-del-flg-true TO TRUE
              PERFORM ....... rest of program.......
          END-EVALUATE

The Csbind demonstration application uses the Reduced Data Transfer facility.

Parent topic: Advanced Topics


Server Controlled File Management Facility

One of the problems that accompanies any client/server solution, especially as the number of clients increases, is the management of client program updates and other changes.

The override facility (see Overriding Configuration File Entries) enables you to re-route client applications while server maintenance is carried out without having to change each client's configuration file entries. The override can be either local or remote but installing and removing a local override file on each client can be time-consuming.

The mfcsmgr program enables you to install and delete override files on the client using the -i and -d options respectively (see Managing the Server). The installation/deletion is carried out as the client program exits.

In fact, the -i option of the mfcsmgr program enables you to install any type of file on the client system (in the client's local directory). This means that you can use it to install new screensets or program files, enabling updates to be distributed from a central point. For security reasons, the delete option has not been similarly enhanced, it will only delete an override file, that is, a file called mfcsovrd.cfg.

Files to be installed using the -i option must be located on the server. If the file is in the directory that mfserver was started from, you need only specify the filename. If it is anywere else, you must supply a full pathname in such a way that the filename can be extracted from the path, for example, /u/live/update/newprog.int, d:\testprog.int and $LIVE/newtest.int are all valid but $newfile is not.

No programming changes are required to use these functions, a message is displayed informing the client that a file is being transferred and the details are recorded in the system log file.

Like other mfcsmgr functions, Server Controlled File Management is not supported with AAI.

Parent topic: Advanced Topics


Client/Server Binding Limitations

The Client/Server Binding imposes very few limitations, but you should be aware of the following issues.

  • You can run the Client/Server Binding modules in .int or .gnt format. In addition, on UNIX platforms, the Client/Server Binding modules can be linked with a user-written application program to create an executable object.
  • When using CCI, the maximum number of clients that each server will support is 300. The number of clients may be limited by the capabilities of the server, the network protocol or the performance requirements of your end-users. On UNIX, for example, the limit is set by the number of sub-processes that can be spawned by mfserver. When a user logs onto a UNIX machine, he is assigned a unique process-id which can support a limited number of sub-processes. When clients connect via the Client/Server Binding, they all become sub-processes of the base server. Of course, you can get around this limitation by altering the number of sub-processes permitted, or by running multiple base servers. If your UNIX machine is configured to support many hundreds of direct login users, the Client/Server Binding running on the same machine should support the same number of clients once the sub-process limit issue has been resolved.
  • The Client/Server Binding has no recovery facilities. If the network goes down, data will be lost. Both ends of the connection will be aware of the failure and the information will be logged but that is all. The same is true of any RTS errors that cause termination of the user programs at either end of a connection. The Client/Server Binding does not provide anything more than the standard RTS in this regard.
  • You cannot use Client/Server Binding with CCI direct connection for TCP/IP.
Parent topic: Client/Server Binding


Client/Server Binding for Enterprise Server

  • Prerequisites
  • Overview
  • How It Works
  • Summary of Changes
  • Not Supported in this Release
  • Supported in this Release
  • New Features in this Release
  • Improvements
  • Client Side Requirements
  • Server Side Requirements
  • Development and Sample files
  • What You Need To Do
  • Starting the Directory Server
  • Deploying the Default Service
  • Adding Extra Services
  • Installing the Server Module
  • Start the Enterprise Server
  • Setting the Service Status
  • Setting the Listener Status
  • Migration Considerations
  • Notes and Recommendations
Parent topic: Communications and Client/Server Binding


Prerequisites

You should be familiar with the use of Client/Server Binding as described in the chapter Client/Server Binding.

Parent topic: Client/Server Binding for Enterprise Server
Related information
Client/Server Binding


Overview

Writing client/server applications typically requires you to include complex code to manage communications. Client/Server Binding refers to a Micro Focus middleware feature that enables you to write client/server applications in COBOL using a simple call interface.

The introduction of Client/Server Binding for Enterprise Server enables you to run the server part of such an application under Enterprise Server. It also provides a number of features that were not available in previous releases, along with improvements in performance, reliability and robustness.

As with previous releases, the client part of your Client/Server Binding application is a conventional COBOL program running under Net Express, Server Express or Enterprise Server.

The server part is run by a service on your enterprise server. Each service can run servers for one or many applications. However, you may want to configure a separate service for each application. Clients can use dynamic name resolution to locate the service.

If you do not want to run your servers under Enterprise Server, you can still use Client/Server Binding with CCI and AAI as with previous versions.

Parent topic: Client/Server Binding for Enterprise Server
Related information
Client/Server Binding


How It Works

Server Enterprise Edition provides an execution environment for your COBOL programs. It exposes these programs as services that can be called by clients. Client/Server Binding for Enterprise Server supplies a service package, CSBIND, that runs the server programs of your client/server applications, and handles their communication requirements.

CSBIND is provided in a COBOL archive file which you deploy to the enterprise server of your choice. When you do this, CSBIND is installed along with the default client/server service, MFCLISRV. This service exposes CSBIND so that clients can call it. You can create additional services that expose CSBIND. Each service is associated with one or more listeners, which listen for service requests.

Your client program calls the supplied client module, MFCLIENT, which resolves the service name by contacting a Micro Focus Directory Server. MFCLIENT then connects to an appropriate listener on your enterprise server. The enterprise server runs the CSBIND module and passes it the client request. The CSBIND module then calls your server program. The response is returned via the listener connection to your client.

CSBIND runs in a conversational mode and does not exit when the response is returned to the client. When the client is prepared to make its next request, it again calls MFCLIENT which sends the request over the existing connection, continuing the conversation with the same CSBIND process.

Note: Enterprise Server runs service programs within Server Execution Processes (SEPs). When a service completes, the SEP that ran it is available to handle further service requests. A conversational program, like CSBIND, may run for a long period of time, and only terminates when the conversation with the client is complete. While the program is running, the SEP is occupied and is not available to handle other service requests. Therefore, for each CSBIND conversation that is taking place, Enterprise Server starts an additional SEP to ensure that it has sufficient to deal with new service requests.
Parent topic: Client/Server Binding for Enterprise Server


Summary of Changes

Previous versions of Client/Server Binding used the transport mechanisms provided by Micro Focus Common Communications Interface (CCI) or the legacy middleware Application to Application Interface (AAI). This new version uses the new Micro Focus Common Client (MFCC) and the Micro Focus Communications Server (MFCS). It supports most of the features available with the previous versions. Those features not supported are detailed in the section Not Supported in this Release. You still have the option of using the CCI and AAI transports.

Client/Server Binding for Enterprise Server uses the same APIs and the same configuration file format as previous versions of Client/Server Binding. With a few exceptions it will work correctly with existing compiled Client/Server Binding applications.

Parent topic: Client/Server Binding for Enterprise Server
Related information
Not Supported in this Release


Not Supported in this Release

  • Parameters specific to another transport, e.g. "aaiservice"
  • cblksize greater than 2KB, eblksize or ublksize greater than 1KB, or dblksize greater than 64KB. Contact Micro Focus Support if you need a larger area for your application.
  • Server error program (srverrprog)
  • Maximum transmission size (maxtrans); this is not required for Client/Server Binding with Enterprise Server
  • Cross-tier architecture and the "Use an existing Dialog System program as the server" feature (midconfig and srvtier)
  • Screen type (scrntype)
  • Server animation (srvanim); use Dynamic Debugging instead. Note, with Dynamic Debugging you need to use the J2EE tab of the Start Animating dialog to specify service details. The service name that you will specify is the service that runs your server program. The default service for Client/Server Binding is MFCLISRV.
  • Asynchronous requests
  • The server manager (mfcsmgr) utility; use MFDS instead
  • Server overrides and Server-Controlled File Management (using mfcsmgr)
  • Client overrides (mfcsovrd.cfg)
Parent topic: Client/Server Binding for Enterprise Server


Supported in this Release

  • Base API for clients and servers
  • Client configuration file syntax
  • Client- and server-side log files
  • Configuration filename specified on command line or in environment
  • Multiple entries in the configuration file (LNK-TAGNAME)
  • COBOL compression (compress)
  • Direct addressing of server (machinename)
  • Timeout control (timeout and maxtimeout)
  • Multiple servers (servername)
  • Server program environment settings (setenv)
  • User logging (useraudit)
  • Reduced Data Transfer (RDT)
  • In-line configuration (load-inline-cfg)
  • Client error program (clierrprog)
Parent topic: Client/Server Binding for Enterprise Server


New Features in this Release

  • Multiple conversations: the client can start another conversation to the server after the first has ended
  • Message integrity: Client/Server Binding for Enterprise Server has several internal mechanisms to check for lost or corrupt messages, and the underlying MFCC middleware can be configured to include an MD5 or SHA-1 message digest with each message (see below)
  • Message compression: Client/Server Binding for Enterprise Server can be configured to use MFBINP Run-Length Encoding (RLE) compression using the new configuration option "mfbinp-compress=rle". (This is essentially the same as the AAI Thin Client compression available in CSBIND/AAI when used with the AAI Thin Client.)
  • New configuration option "cwd" sets server program's current directory
  • Support for Secure Sockets Layer (SSL) when used in conjuction with the Micro Focus Security Features AddPack (forthcoming). SSL can be used completely transparently to the application just by enabling it on the server (if dynamic service resolution is used).
Parent topic: Client/Server Binding for Enterprise Server


Improvements

  • Advantages over Implementations using CCI
  • Advantages over Implementations using AAI
Parent topic: Client/Server Binding for Enterprise Server


Advantages over Implementations using CCI

  • Performance: Client/Server Binding for Enterprise Server is faster, particularly when beginning a conversation, because it does not need to start a subserver and open a second connection
  • Firewalls: Client/Server Binding for Enterprise Server only uses a single TCP port on the server, and the server can be configured to always use the same port, which simplifies firewall configuration
  • Direct addressing: using the machinename parameter, the client can specify the hostname and port number of the ES listener for the server
  • Middleware features: the MFBINP protocol used by Client/Server Binding for Enterprise Server has additional features such as message digests and compression (see below)
  • Server administration: Client/Server Binding for Enterprise Server server programs run under Enterprise Server hosted CSBIND services, so they are administered using the Micro Focus Directory Server (MFDS). MFDS maintains the server configuration information and can automatically start your Enterprise Server at system boot, so servers do not need to be started manually with Client/Server Binding for Enterprise Server.
  • Server environment: Client/Server Binding for Enterprise Server application server modules run in Enterprise Server application containers.
  • No preset limit on the number of clients.
Parent topic: Improvements


Advantages over Implementations using AAI

  • More features are supported
  • Server Enterprise Edition application execution environment has advantages over AAI for running COBOL programs (see Server Enterprise Edition documentation for details)
Parent topic: Improvements


Client Side Requirements

Component/Module | Description
Runtime system | This is installed with COBOL development system products and COBOL run-time server products.
Micro Focus Common Client component (mclient.dll) version 1.9.0 or later | Also installed with COBOL development system products and COBOL run-time server products.
mfclient.int | This is the new client runtime that handles the MFCC API
mfoldcsb.int | This is the client runtime module that handles the CCI API
aaiclnt.int | This is the client runtime module that handles the AAI API

For development, the mfclisrv.cpy copybook is required.

Parent topic: Client/Server Binding for Enterprise Server


Server Side Requirements

Server Enterprise Edition |
Micro Focus Communications Server version 1.10.0 or later | Installed with Server Enterprise Edition. To check your version of Micro Focus Communications Server, use mfcs -v at the command line.
mfdepinst version 1.4.0 or later | This is supplied with Server Enterprise Edition and is used to install the default service that will run the server part of your application. You can also do the service installation manually.

You also need to deploy the CSBIND service (provided in COBOL archive file csbind.car) to your enterprise server. This is the default service for running the server parts of your client/server applications. You can use the package that it contains to create additional services. See the section Deploying the default service

Parent topic: Client/Server Binding for Enterprise Server
Related information
Deploying the default service


Development and Sample files

  • mfclisrv.cpy (copybook)
  • netxcli.cbl (sample client)
  • netxdem.cfg (sample configuration file)
  • netxserv.cbl (sample server)
Parent topic: Client/Server Binding for Enterprise Server


What You Need To Do

  • Create a configuration(.cfg) file to control the behaviour of the mfclient and mfes-csbsrvr modules and the communications connection.
  • In the configuration file, set the "commsapi" parameter to "es". This enables the use of the Enterprise Server transport.
  • In the configuration file, set the "servername" parameter to the name of the service that you are using to run your server program. The service name is case-sensitive, so you must make sure that it is the same in your configuration file as it is on the enterprise server. The default service supplied with Client/Server Binding for Enterprise Server is MFCLISRV.
  • Add code to your client program to call the mfclient module.
  • Add code to your server program to enable it to be called by the mfserver module.
  • Make sure that the Micro Focus Directory Server that manages your enterprise server is started.
  • Deploy the default service to your enterprise server.
  • Install your client program on the client machine.
  • Install your server program on the server machine.

To run your application, you also need to ensure that:

  • Your enterprise server is started
  • The Client/Server Binding service or services are configured as AVAILABLE
  • The listener for the service(s) is started
Parent topic: Client/Server Binding for Enterprise Server
Related information
The Client/Server Binding Configuration File
Deploying the Default Service
Connecting Your Client Program to MFCLIENT
Connecting your Server Program to MFSERVER
Starting the Directory Server
Install the Server Module
Starting the Enterprise Server
Set the Service Status
Set the Listener Status


Starting the Directory Server

On Windows, when Server Enterprise Edition is installed, the Directory Server is started automatically as a Windows service. You can stop the Directory Server and start it again using the Windows Control Panel.

On UNIX, depending on how Server Enterprise Edition has been installed, either you can use the mfds command to start it, or it can start automatically when the machine is started. To stop the Directory Server, you use a menu option of the Web interface.

Parent topic: Client/Server Binding for Enterprise Server


Deploying the Default Service

The default service, MFCLISRV, is provided in a COBOL archive file, csbind.car. You can install the service to your enterprise server using the imtkmake or mfdepinst utilities.

For example, to deploy the MFCLISRV service under the ESDEMO server using the default configuration:

  1. At the command prompt, change to the deployment directory for ESDEMO; this is %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\deploy.
  2. Create a subdirectory named "csbind" and change to it.
  3. Copy csbind.car to the csbind directory.
  4. Run mfdepinst csbind.car.
  5. When mfdepinst completes, look at the file deploylog.txt in the current directory to see if deployment completed successfully.

The deployment process extracts the files needed to run servers under Server Enterprise Edition. These are:

  • mfes-csbsrvr.int, the program that runs the servers
  • mfcsbind.idt, the Interface Definition Table file for the service

It then creates two new objects in the Micro Focus Directory Server repository, under the enterprise server where the service is being installed. These are:

  • A package named "CSBIND", which specifies mfes-csbsrvr.int as the package module and mfcsbind.idt as the interface definition. This package can be used for all CSBIND services for this Enterprise Server.
  • A service named "MFCLISRV" is created. MFCLISRV uses the CSBIND package and is associated with the default listener for services deployed to this server ("Web Services and J2EE" in the default configuration).

You can use the MFCLISRV as the service for all of your Client/Server Binding applications or you can use Enterprise Server Administration to create additional services that use the CSBIND package (see the section Adding Extra Services). The client part of the application supplies the name of the server program when making the connection, so more than one application can use the same service.

Parent topic: Client/Server Binding for Enterprise Server
Related information
Adding Extra Services


Adding Extra Services

After you have deployed the default server, you can add extra services that expose the CSBIND package. You do this with Enterprise Server Administration.

When you add the service, you select CSBIND as the package, and MFRHBINP as the handler.

For example, to add a CSBIND service called CSTEST, which uses the "Web Services and J2EE" listener, to ESDEMO:

  1. On your server machine, start a web browser and enter the URL http://localhost:86.

    This displays the Enterprise Server Administration home page. The current status column tells you whether or not a server is started.

  2. Click the Edit button in the left hand column for ESDEMO.

    This displays a screen containing tabs that provide detailed administrative options.

  3. Click Services.
  4. Click Add.
  5. In Name, type CSTEST.
  6. Choose the type of transaction management appropriate to this service: check Container unless your application does explicit commits and rollbacks.
  7. In Available Listeners, click the "Web Services and J2EE" listener and then click Add.

    This places the "Web Services and J2EE" listener in the list of accepting listeners for this service.

  8. In Available Request Handlers, click MFRHBINP and then click Select Handler. The selection is active immediately.
  9. In Available Packages, click CSBIND and then click Select Package. The selection is active immediately.
  10. Choose a status for the service from the list in Initial status. By default the initial status is Available.
  11. Click Add.
Parent topic: Client/Server Binding for Enterprise Server


Installing the Server Module

The simplest way to install your program is to put it into the same directory as you used for deploying the default service. This directory contains the CSBIND package module. In the example given in the topic Deploying the Default Service, the directory is %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\deploy\csbind.

Alternatively, you can place your server module in a directory that is on the COBPATH for your enterprise server. When an enterprise server starts, it inherits its environment from the Directory Server. However, you can set environment variables for an enterprise server by using Enterprise Server Administration.

Parent topic: Client/Server Binding for Enterprise Server
Related information
Deploying the Default Service


Start the Enterprise Server

You do this using Enterprise Server Administration.

For example, to start ESDEMO.

  • On your server machine, start a web browser and enter the URL http://localhost:86.

    This displays the Enterprise Server Administration home page. The current status column tells you whether or not a server is started.

  • If ESDEMO is stopped, click Start in the Current Status column.
Parent topic: Client/Server Binding for Enterprise Server


Setting the Service Status

You can set status of a service to Available or Disabled. If you set the status to Disabled, your client programs will no longer be able to establish a connection to that service. In effect, this is the same as closing down the master server under CCI.

To alter the availability of a service, you use Enterprise Server Administration.

For example, to alter the availability of MFCLISRV on ESDEMO:

  1. On your server machine, start a web browser and enter the URL http://localhost:86.

    This displays the Enterprise Server Administration home page. The current status column tells you whether or not a server is started.

  2. Click Details in the Objects column for ESDEMO.
  3. Click Edit in the Operation column MFCLISRV.
  4. Choose the new status from the list in New Status.
  5. Click Apply.
Parent topic: Client/Server Binding for Enterprise Server


Setting the Listener Status

Typically, you will configure a separate service for each of your Client/Server Binding applications, and you will have one listener (such as the "Web Services and J2EE" listener included with the sample configuration) which receives the requests. You can also give CSBIND requests their own listener, or multiple listeners.

If you change the status of the service's listener to "Blocked", then all services belonging to that listener will be hidden. If you change the status of the listener to "Stopped", then it will stop accepting new conversations until it is changed back to "Started" or the enterprise server is restarted. If you set the status to "Disabled" the listener will be stopped and will not be restarted when the enterprise server is restarted.

For example, to change the status of the Web Services listener for ESDEMO.

  1. On your server machine, start a web browser and enter the URL http://localhost:86.
  2. Click Details in the Communications Processes column for ESDEMO.
  3. Choose All from the Process list.
  4. Click Edit in the row for the Web Services listener.
  5. Choose the new status from the list in New Status.
  6. Click OK.
Parent topic: Client/Server Binding for Enterprise Server


Migration Considerations

Client/Server Binding for Enterprise Server uses the same APIs and configuration file format as other versions of Client/Server Binding, and in most cases should work correctly with existing compiled Client/Server Binding-based application program modules.

As with CCI and AAI, Enterprise Server mode for Client/Server Binding is selected using the "commsapi" parameter in the client's configuration file. This lets developers easily compare Client/Server Binding for Enterprise Server with other Client/Server Binding transports simply by changing their configuration. To use Client/Server Binding for Enterprise Server , follow the steps in the section What You Need To Do.

Once Client/Server Binding for Enterprise Server servers have been configured, existing Client/Server Binding clients can be upgraded to Client/Server Binding for Enterprise Server simply by upgrading Server Enterprise Edition to the latest version (or at least installing the MFCC modules, listed below) and updating the client configuration file. It's possible to run CSBIND/ES and CSBIND/CCI or CSBIND/AAI servers in parallel on the same system, in order to gradually upgrade a large client base.

  • Understanding the Changes in Server Management
Parent topic: Client/Server Binding for Enterprise Server
Related information
What You Need To Do


Understanding the Changes in Server Management

Client/Server Binding with CCI required a non-dedicated server module, MFSERVER, to run on the server machine. For each new client conversation, this spawned a dedicated instance of itself to handle the server part of the application. The non-dedicated module was usually started manually, either by a user from the command line or by a system script. When a system administrator wanted to stop the server, the usual mechanism was to run the "mfcsmgr" utility with the "-t" option.

With Client/Server Binding using AAI (CSBIND/AAI), the spawning of the dedicated server module was controlled by AAI, and the system administrator would start and stop it by starting and stopping the AAI subsystem.

Client/Server Binding for Server Enterprise Edition is similar to AAI in this area, though it is more flexible. It provides a service package, CSBIND, which runs the server part of your application. The package can be associated with one or more services and one or more listeners (which receive client requests and pass them to the package module). Typically, you will configure a separate service for each of your Client/Server Binding applications, and you will have one listener (such as the "Web Services and J2EE" listener included with the sample configuration) which receives the requests. You can also give CSBIND requests their own listener, or multiple listeners.

If the CSBIND services are configured as "Available" and their listeners are configured to start when the enterprise server is started - the default configuration - then your Client/Server Binding servers will be available whenever that enterprise server is running.

If you change the status of a CSBIND service to "Disabled" while your enterprise server is running, your client programs will no longer be able to establish a connection with that service. If you change the status of the service's listener to "Blocked", then all services belonging to that listener will be hidden from all clients (except for clients which connect directly using the "machinename" configuration option - see below). If you change the status of the listener to "Stopped", then it will stop accepting new conversations until it is changed back to "Started" or the enterprise server is restarted.

Parent topic: Migration Considerations


Notes and Recommendations

  • Configuring Micro Focus Common Client
  • Using a Fixed TCP Port
  • Using the machinename parameter
  • Using the New Configuration Options
  • Performance Planning
  • Restrictions
Parent topic: Client/Server Binding for Enterprise Server


Configuring Micro Focus Common Client

Client/Server Binding for Enterprise Server uses Micro Focus Common Client (MFCC), as its client communications API. MFCC is configured using a text file, which by default is mf-client.dat in the base\bin directory. You can create your own configuration file of any name or location, but you must identify it using the MFC_CONFIG environment variable.

Some MFCC configuration parameters deserve special mention in the context of Client/Server Binding applications:

  • MFBINP digest: MFBINP messages, such as those used by Client/Server Binding for Enterprise Server, can optionally include a message digest which provides a way of checking that the message has not been accidentally altered in transit (e.g. by a network error). You can set the parameter mfbinp-digest in the "[defaults]" section to "md5" (case-insensitive) to enable an MD5 digest with every message, or "sha1" to enable an SHA-1 digest. We recommend setting this option if you are concerned about possible message corruption; the choice of MD5 versus SHA-1 is relatively unimportant in this application.
    Note: The message digest will not protect against deliberate alteration if the attacker also updates the digest data.
  • Timeouts: While Client/Server Binding provides a timeout configuration parameter to set timeouts for connecting to the server, and sending and receiving data, MFCC allows you to set separate connect and send/receive timeouts, This is useful for some applications. In particular, some administrators may want the application to time out quickly on connection, because they expect to contact the server almost immediately if it is running, but to have a much longer timeout for receiving data, because the server may take a while to process a request. To configure different connection and send/receive timeouts, do not use the Client/Server Binding timeout parameter. Instead, use the connect-timeout and timeout options in the "[defaults]" section of mf-client.dat. (You can also set these values using the MFC_CONNECT_TIMEOUT and MFC_TIMEOUT environment variables.)
Parent topic: Notes and Recommendations


Using a Fixed TCP Port

You can use a fixed TCP port on the server machine for Client/Server Binding conversations. Simply configure the listener that is used by the service or services for your applications to use a fixed port in Enterprise Server Administration.

Note: Regardless of how your listener is configured, Client/Server Binding for Enterprise Server uses only one port for each conversation. This contrasts with Client/Server Binding when used with CCI, which opened a new port every time a client connected.
Parent topic: Notes and Recommendations


Using the machinename parameter

Under Client/Server Binding for Enterprise Server, the "machinename" parameter has somewhat different behavior and syntax than with previous versions. When using Client/Server Binding with CCI, specifying a machinename simply told CCI to look for the named service on the given machine. CCI still had to query the service directory on the named machine to find the service.

Client/Server Binding for Enterprise Server uses Micro Focus Common Client (MFCC), the configuration file of which specifies the directories to query. The machinename parameter is now used to tell the client exactly where to connect to the service's listener - just like a URL for a web page. When machinename is used, there is no directory lookup.

Using machinename has some advantages. First, the client (and the user) knows exactly which service it will connect to. Second, it is faster than querying a directory. Third, it is useful for penetrating a firewall, since the firewall does not have to be configured to allow Micro Focus Directory Server (MFDS) queries.

However, using directory lookup (and not using machinename) also has advantages. It frees the client (and the user) from having to know where the service is located. It lets the system administrator move the service from one machine to another, or change the port of its listener, or let the operating system select the port. It permits simple failover (if the service is supplied on multiple machines, directory search will find a running instance) and load balancing (MFCC will pick an available instance of the service at random, so clients will be spread roughly equally among servers).

Broadly speaking, directory lookup is more resilient and direct addressing using machinename gives you more control. Your application requirements and execution environment will determine which is better for you.

When you use the machinename parameter with Client/Server Binding for Enterprise Server, the value can be in several forms:

  • URL form: "mfbinp://hostname:port" where "hostname" is the name of the system where the service is running, and "port" is the listener's port. The default port is 9003 (the port of the "Web Services and J2EE" listener in the ESDEMO configuration).
  • MFDS form: "tcp:hostname:port". This is basically identical to URL form, except with "tcp:" instead of "mfbinp://". If you have the Micro Focus Security AddPack installed, you can use SSL with this form by specifying "tcpssl:" instead of "tcp:" (assuming the listener is SSL-enabled).
  • Simple form: "hostname:port" or "hostname". This form simply assumes the "tcp:" prefix. Again, the default port is 9003.
Parent topic: Notes and Recommendations


Using the New Configuration Options

cwd
Set this parameter to make the server program run in the specified directory.
mfbinp-compress
Setting this to RLE will enable MFBINP Run Length Encoding compression, a simple compression scheme that can compress long sequences of the same byte value.

MFBINP RLE is not as sophisticated as the COBOL compression programs CBLDC001, etc, which are activated using the compress parameter. However, since it operates on the entire CSBIND message, it can compress areas that the compress option cannot. You can use it in place of COBOL compression or in addition to it, depending on your compression needs.

On fast networks, compression typically has no observable effect. On moderately slow networks, using only mfbinp-compress=rle will probably have the best results, unless your data areas contain double-byte characters, in which case you should use compress=003. On very slow networks, using both mfbinp-compress=rle and compress=001 (or 003) may be worthwhile.

Parent topic: Notes and Recommendations


Performance Planning

The number of clients that a Client/Server Binding for Enterprise Server application can run is dependent on the hardware and software environment to which it is deployed. With a suitable small server configuration, it can support up to 1000 clients.

Parent topic: Notes and Recommendations


Restrictions

Server Enterprise Edition does not support 64 bit applications.

Parent topic: Notes and Recommendations


Managed COBOL Programming

  • Managed COBOL Programming
  • Interoperability
    Managed COBOL can invoke and be invoked by code in any other managed language. Managed COBOL can also invoke native COBOL. In addition, managed code in languages other than COBOL and native COBOL can interoperate by going through managed COBOL code.
  • Multi-threaded Programming
Parent topic: Programming


Managed COBOL Programming

  • Background to .NET
  • Native COBOL Compared with Managed COBOL
    Native COBOL and managed COBOL differ in how they compile and how the run-time management services, such as security, threading and memory management are provided.
  • 64-Bit Applications in the .NET Environment
    .NET COBOL applications running on a 64-bit platform can use either the 32-bit or the 64-bit Common Language Runtime (CLR).
  • Multiple User COBOL Applications in .NET
    In a multiple user environment, COBOL applications must use multiple run units, with each instance of the application running in its own run unit.
  • Code Page Conflicts in .NET Managed COBOL
    Code page conflicts can occur when interacting with rich code page support of the .NET framework.
Parent topic: Managed COBOL Programming


Background to .NET

The Microsoft .NET Framework is a language-independent programming model that simplifies the process of building distributed applications. Any programs written for .NET can interact with one another, regardless of the programming language in which the programs were written.

.NET has two core components:

  • The Common Language Runtime (CLR). The CLR is responsible for run-time code management, undertaking such tasks as memory and thread management, and security enforcement. Programs that are written to make use of the CLR are known as managed code. Programs that do not make use of the CLR are known as unmanaged code.
  • .NET Framework class library. The class library is an object-oriented collection of types that are closely integrated with the CLR. By inheriting functionality defined in the .NET Framework class library, you can reduce the amount of code you need to write.

To create an application for .NET, you use Microsoft Visual Studio, a development environment that enables you to develop applications that work with .NET regardless of the programming language in which they are written.

For more information on .NET, go to the Microsoft .NET Web site:

Microsoft .NET

Parent topic: Managed COBOL Programming


Native COBOL Compared with Managed COBOL

Native COBOL and managed COBOL differ in how they compile and how the run-time management services, such as security, threading and memory management are provided.

Managed COBOL on the .NET platform compiles to Microsoft Intermediate Language (IL) , and native COBOL compiles to machine code. This means that native COBOL has to be compiled for the operating system on which it is going to run, whereas compiled managed COBOL can run on any Windows platform.

For .NET managed code, the management services are provided by the Microsoft Common Language Runtime (CLR). For native COBOL, the management services are available in the operating system, and your code has to call the appropriate services depending on the operating system. The management services are:

  • The .NET CLR, which provides automatic memory management.
  • The .NET framework, which provides a large library of building blocks to simplify many application programming tasks. It provides APIs for everything from dates and times to thread management. These features are less useful for procedural COBOL programs, but once you have migrated them to managed code, you can use them to add new features.
  • Seamless interoperation of COBOL programs with programs in other managed languages.
  • The ability to write object-oriented COBOL.

What Is .NET Managed Code?

.NET managed code compiles to Microsoft Intermediate Language (IL). The IL is stored in an assembly, along with meta data that describes the classes, methods, and attributes (such as security requirements) of the code you've created. This assembly is relatively easy to deploy and often involves only copying the assembly to the server where your run-time system is.

.NET managed code runs in the Microsoft Common Language Runtime (CLR). The CLR does Just In Time (JIT) compilation. That is, when you load an assembly, the CLR JITs the assembly code the first time it is executed. There is a small performance penalty as an application loads, but because the CLR compiles your code, it doesn't do it again (until next time you restart it).

The CLR is responsible for managing your application code at run time, and provides security, memory management and so on.

Building Native and Managed COBOL Applications

You use the IDE to develop, compile and debug your applications, for both native and managed code. You can write new COBOL code or you can recompile existing COBOL as managed or native code, potentially without any code changes.

You can deploy and further debug the application under the run-time system provided by Server Enterprise Edition. .NET COBOL applications are deployed to Windows platforms running the .NET Framework.

Parent topic: Managed COBOL Programming
Related information
Visual Studio and COBOL
IDE Differences Between Micro Focus IDEs


64-Bit Applications in the .NET Environment

.NET COBOL applications running on a 64-bit platform can use either the 32-bit or the 64-bit Common Language Runtime (CLR).

The 64-bit CLR is used by default. This corresponds to setting the project property Platform Target to AnyCPU. To use the 32-bit CLR, you set the Platform Target to a 32-bit platform.

Note: When compiling for .NET using SQL(DBMAN=ODBC), set the Platform Target to specify the appropriate platform.

Most COBOL programs can run on 64-bit systems without recompilation. However, there are some cases where you need to ensure that COBOL pointer items in your application are allocated as 64 bits in size rather than the default of 32 bits. To do this you set the project property Generate 64-bit Pointers.

You need to generate 64-bit pointers when:

  • The combined data of all the programs in your application requires more than a 32-bit address space
  • Your managed COBOL is calling native COBOL on the 64-bit CLR and the managed COBOL is passing parameters that contain structures with pointers

If your application uses native COBOL code, and you need to execute that code on a 64-bit CLR, you need to ensure it is recompiled to target the appropriate 64-bit processor.

Parent topic: Managed COBOL Programming
Related reference
COBOL Properties


Multiple User COBOL Applications in .NET

  • Background to Multiple Run Units and .NET
  • Demonstration of a Multiple Run Units Application
  • Run the MultiRunUnits Demonstration
  • Walkthrough the MultiRunUnits Demonstration
  • Developing an Application for Multiple Run Units in .NET
  • To call managed COBOL in a multiple user environment
Parent topic: Managed COBOL Programming
Related reference
TRACELEVEL


Background to Multiple Run Units and .NET

.NET server applications, such as ASP.NET and .NET remoting, typically have multiple users, each user running a session simultaneously with other users, whereas COBOL applications traditionally run single sessions each independent of each other. In .NET, server applications are executed and controlled by application domains. Each application domain can execute multiple instances of an application at the same time.

By default, when a procedural COBOL application runs in an application domain, it is executed in the default COBOL run unit and it uses threads that share the same address space, by definition. If the application is executed several times simultaneously, that same run unit is used and consequently the same data is shared between all executions, which can cause problems.

In a multiple user environment, the COBOL application must use multiple run units, with each instance of the application running in its own run unit. To do this, you need to:

  • Compile the COBOL that you want to call. For procedural COBOL programs use the NOILSTATIC directive, which is the default. This enables any COBOL classes created to be instantiated.
  • Call the COBOL class (or program) within its own run unit. To do this, the calling program creates a run unit and creates an instance of the COBOL class. Then the program instance can be invoked within the new run unit.
  • Include the run-time support for multiple run units, by adding a reference to the MicroFocus.COBOL.RuntimeServices assembly.

Note that you leave the existing procedural COBOL unchanged.

Any COBOL program or CLASS with instance data/methods can be used with multiple run units providing you do not compile with the REENTRANT or ILSTATIC directives.

Parent topic: Multiple User COBOL Applications in .NET


Demonstration of a Multiple Run Units Application

The MultiRunUnits demonstration shows why and how procedural COBOL is compiled and invoked in a multiple user environment. The application is an ASP.NET Web Service and you invoke it through the ASP.NET Development Server, which is installed as part of Visual Studio.

This demonstration is available in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\MultiRunUnits folder by default. It comprises the WebSite.sln solution.

Parent topic: Multiple User COBOL Applications in .NET


Run the MultiRunUnits Demonstration

To run the demonstration:

  1. Open the Web site and browse to the demo files, located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Examples\Visual Studio Integration\MultiRunUnits by default.
  2. Build the Web site.
  3. Start the Web Service by clicking Debug > Start Without Debugging and then clicking service.asmx.
  4. Start a second Web Service in the same way.
  5. Click AddTwoNumbers in both browsers.
  6. In one browser, enter 1 as the first operand and anything as the second operand.
  7. In the second browser, enter any operands (except 1) in each field.

To see the data being shared incorrectly, enter False in the UsingMultiRunUnits field, in both browsers. Click Invoke in the browser where you entered 1, and then click Invoke in the second browser. The first result to come back is correct, but the other result is the same as the first, which is wrong. Here's what happens:

  1. The first instance creates a default run unit and sends its data to that run unit and waits.
  2. The second instance uses the default run unit and in doing so, it overwrites the data in the default run unit.
  3. The second instance adds the two numbers and returns the correct result.
  4. When the first instance finishes waiting, it uses the default run unit and adds the two numbers, which are now those from the second instance. It returns the wrong result, the result for the second instance.

Now repeat the demonstration, but this time enter True in the first field. The correct results are returned. Here's what happens:

  1. The first instance creates its own run unit and sends its data to that run unit and waits.
  2. The second instance creates another own run unit and sends its data to its own run unit.
  3. The second instance adds the two numbers and returns the correct result.
  4. When the first instance finishes waiting, it uses its own run unit. It adds the correct two numbers and returns the correct result.
Parent topic: Multiple User COBOL Applications in .NET


Walkthrough the MultiRunUnits Demonstration

The MultipleRunUnits demonstration shows an instance of a procedural COBOL program being run within its own run unit.

The demonstration Web site contains the procedural COBOL program Sum.cbl with a program-ID of sum. When the program is compiled, it is represented as a class that can be instantiated. When the program is used, an instance of the program is created and a run unit is created. The program instance is then run within its new run unit.

The Web site contains the following references, which you can see in the Solution View:

  • MicroFocus.COBOL.RuntimeServices assembly - This provides the run-time support for multiple run units
  • MicroFocus.COBOL.Runtime - This provides COBOL run-time support and is needed in any non-COBOL projects that call COBOL ones

The Web site contains a calling program in COBOL, service.cbl. This has several lines of interest:

        ...
1       class COBOL-RunUnit as "MicroFocus.COBOL.RuntimeServices.RunUnit"
        ...
2       invoke COBOL-RunUnit::"New" returning MyRunUnit
3       try
4          invoke MyRunUnit::"Call"("AddNumbers", op1, op2) returning res
           ...
5       end-try
        ...
6       invoke MyRunUnit::"StopRun"(0)

Line 1:

    class COBOL-RunUnit as "MicroFocus.COBOL.RuntimeServices.RunUnit"

Defines the class that is used on line 2. Notice that MicroFocus.COBOL.RuntimeServices is included in the project references.

Line 2:

invoke COBOL-RunUnit::"New" returning MyRunUnit

Creates a run unit using the support in the MicroFocus.COBOL.RuntimeServices assembly.

Lines 3 and 5:

try
...
catch

Ensures that the run unit is destroyed even if the called program fails.

Line 4:

invoke MyRunUnit::"Call"("sum",op1, op2) returning res

Implicitly creates an instance of the AddNumbers() method and then calls it within the new run unit. The parameters are passed by reference and automatically marshalled to match the data types used in the called program.

Line 6:

invoke MyRunUnit::"StopRun"(0)

Destroys the run unit now that it is finished with.

Note: You can use C# or any .NET language to call COBOL in a similar way as the above program calls COBOL. For some examples, see the Help on the MicroFocus.COBOL.RuntimeServices assembly: RunUnit Class.
Parent topic: Multiple User COBOL Applications in .NET


Developing an Application for Multiple Run Units in .NET

Note: The following applies to .NET managed COBOL only.

You can use any existing COBOL program in a multiple user environment in .NET. Do this as follows:

  1. Create a COBOL class library project and add your procedural COBOL program to that project.
  2. Rebuild the project.

    The COBOL program is now represented as a class that can be instantiated. It is packaged as a library (.dll); it is not compiled as an executable that can be run directly.

Whether the COBOL program to be called is procedural or OO COBOL, you need a program to call it, and this program can be in any .NET language, such as C# or COBOL. You need to:

  1. Create a project for the calling program, which can be more or less any project type, and add a reference to the:
    • MicroFocus.COBOL.RuntimeServices assembly.
    • MicroFocus.COBOL.Runtime assembly. You need this only if the calling program is in a .NET language other than COBOL.
    • Project containing the COBOL class library that you want to call.
  2. In the calling program, create a run unit using the MicroFocus.COBOL.RuntimeServices.RunUnit constructor.

    Use the Try ... Finally syntax to ensure that the program destroys the run unit if the program fails.

    Either use the RunUnit.Call() method to call the COBOL class, or:

    • Make sure that any parameters use .NET standard data types, and make sure that the called COBOL can receive these .NET standard data types.
    • Create an instance of the procedural COBOL program to be called.
    • Add the program instance to the new run unit, using the RunUnit.Add() method.
    • Invoke the program instance within the new run unit.

    Use the StopRun() method to destroy the run unit when you have finished with it.

Note:
  • If the run unit causes a run-time error, a System.ApplicationException is thrown.
  • In OO COBOL programs in a mixed language environment, be careful how you use static methods and data. Use static methods and data only where they need to be shared by all run units. In addition, ensure that data access is synchronized (as the run units will be executing in different threads).

For details of the RunUnit class in the MicroFocus.COBOL.RuntimeServices assembly, see: RunUnit Class.

Parent topic: Multiple User COBOL Applications in .NET
Related information
MicroFocus.COBOL.RuntimeServices


To call managed COBOL in a multiple user environment

  1. If the COBOL to be called is procedural, create a COBOL class library project and add your procedural COBOL to that project.
  2. Create a project for the calling program and add a reference to the:
    • MicroFocus.COBOL.RuntimeServices assembly.
    • MicroFocus.COBOL.Runtime assembly. You need this only if the calling program is in a .NET language other than COBOL.
    • Project containing the COBOL class library that you want to call.
  3. Write a program that calls the COBOL class within its own run unit. To do this, you create a run unit using the MicroFocus.COBOL.RuntimeServices.RunUnit class. Then you instantiate the COBOL class and invoke this instance within the new run unit.

See the MultiRunUnits example, which is with the Visual Studio examples in the examples folder in the installation of your COBOL development system.

Parent topic: Multiple User COBOL Applications in .NET
Related information
MicroFocus.COBOL.RuntimeServices
Developing an Application for Multiple Run Units in .NET


Code Page Conflicts in .NET Managed COBOL

  • Avoiding Code Page Conflicts in .NET Managed COBOL
  • Example of Code Page Conflicts in .NET Managed COBOL
  • To Avoid Code Page Conflicts in .NET Managed COBOL
Parent topic: Managed COBOL Programming


Avoiding Code Page Conflicts in .NET Managed COBOL

Note: The following applies to .NET managed COBOL only.

Code pages are not often a consideration for traditional COBOL application development. However, they require attention in the advanced system Studio Enterprise Edition, which interacts with the rich code page support of the Microsoft .NET framework.

Studio Enterprise Edition follows the default behavior of Visual Studio by creating all auto-generated code files as UTF-8. The Compiler automatically compensates for this by detecting if the source code can be read as UTF-7/ASCII. If it cannot, all the files in a solution are saved as the appropriate code page, thereby avoiding corruption of PICTURE clause data items.

Code page conflicts can impact WPF and WCF projects, where by default:

  • Visual Studio auto-generates code in UTF-8 encoding. The code page of the auto-generated COBOL matches the code page of the source XML code.
  • Existing or new programmer-generated COBOL have the code page of the platform locale.
Parent topic: Code Page Conflicts in .NET Managed COBOL


Example of Code Page Conflicts in .NET Managed COBOL

Note: The following applies to .NET managed COBOL only.

Visual Studio creates partial classes in COBOL to give programmatic access to WPF and WCF user interfaces. These partial classes are auto-generated and can then be updated by you or Visual Studio.

In the following example:

  • Window1.xaml.cbl is the source code of a WPF (or WCF) user inteface.
  • CodePageStuff.Window1 is the partial class generated from the above source. Because this file is auto-generated, it is encoded using the UTF-8 code page by default.
  • PicLen.cbl is in the same project. This files stores the source code for a simple COBOL program for assessing the content length of c PIC X(1024) field which is space filled.

If PicLen.cbl is previously existing code or is a new hand-entered source file, it is not encoded using the platform default code page. For example, in the United Kingdom this is code page 1252, or on a Japanese locale machine, it is most likely the Shift-JIS code page 932.

When PicLen is called from WindowStuff, as follows, one code page calls another:
       call "PicLen" using stuff lStuff

Calling one code page from another is not supported directly. When the application runs, it might fail under some conditions, due to corrupt PICTURE clause data items.

Parent topic: Code Page Conflicts in .NET Managed COBOL


To Avoid Code Page Conflicts in .NET Managed COBOL

Note: The following applies to .NET managed COBOL only.

To avoid code page conflicts, save all the auto-generated developer-editable .cbl files using the platform locale that matches the developer-generated of previously existing files, as follows:

  1. Ensure the source code from the file is displayed in the editor.
  2. Click File > Advanced Save Options.

    The advanced save dialog is displayed indicating the current code page for the file it UTF-8.

  3. Change the encoding to the platform default.
  4. Repeat the above for each auto-generated .cbl file.
  5. Save all the .cbl files under the same locale.
  6. Rebuild the solution.
Parent topic: Code Page Conflicts in .NET Managed COBOL


Interoperability

Managed COBOL can invoke and be invoked by code in any other managed language. Managed COBOL can also invoke native COBOL. In addition, managed code in languages other than COBOL and native COBOL can interoperate by going through managed COBOL code.
  • Overview of Interoperability
    Broadly, there are three Microsoft techniques for calling between native COBOL and managed code: CCW, RCW and Platform Invoke.
  • Data Marshaling and Type Conversion for Managed Code Interoperation
    Data type compatibility is one of the main issues when managed COBOL interoperates with code in non-COBOL managed languages. Often, you need to manipulate the COBOL data into compatible types.
  • Calling a .NET Class from Native COBOL, Using CCW
    The COM-callable-wrapper (CCW) is a .NET technique for COM interoperability. CCW wraps managed code as a COM object so that native code can call it like any other COM object.
  • CCW Example
  • Calling a Native COBOL COM Object, Using RCW
    The runtime-callable-wrapper (RCW) is a .NET technique for COM interoperability. RCW wraps a COM object so that the .NET runtime system can call it. It effectively exposes a COM interface so that managed code can call it.
  • RCW Example
  • Platform Invoke and Calling Native COBOL
    Platform Invoke is a .NET technique that enables managed code to call unmanaged functions implemented in dynamic link libraries (.dlls).
  • PInvoke Example
    The supplied PInvoke sample demonstrates Platform Invoke.
  • Callable Attribute in .NET COBOL Interoperation
    To call methods from COBOL safely, you need to set the MicroFocus.COBOL.RuntimeServices.CallableAttribute attribute on the non-COBOL methods and on the class and assembly containing them
  • Mixed Language Programming with Native COBOL
    This section covers parameters, return codes and call conventions for mixed language development with native COBOL.
Parent topic: Managed COBOL Programming


Overview of Interoperability

Microsoft provides the technology for interoperability between native and managed code. They have published much excellent documentation, which explains the options and gives advice on the strategies you can adopt.

Broadly, there are three techniques for calling between native COBOL and managed code (whether managed COBOL or other managed languages):

  • CCW for calling a .NET component or managed code from native COBOL. CCW wraps the managed code in a COM Callable Wrapper, which you can call from native COBOL.

    To do this, you register the managed class for COM interop. When you build the project, the class is registered and thereby made available to native COBOL.

  • RCW for calling native COBOL as a COM object from .NET managed code. RCW wraps the native COBOL in a Runtime Callable Wrapper, which you can call from managed code.

    To do this, first you package the native COBOL as a COM object and register it. Then you add the COM object as a reference in your project. When you build the project, the RCW is generated, thereby exposing the COM class as a managed proxy class.

  • Platform Invoke for calling native API functions from managed code. Platform Invoke enables you to call any function in any managed language.

    To do this, first you first you package the native COBOL as a .dll, with the appropriate entry points. Then you add the .dll and the COBOL run-time system support as a reference in your project. The managed code can now call into you must redeclare the function's signature in the managed source code.

For native COBOL and managed COBOL to interoperate, you don't need to worry about data type conversion. Native types are understood and converted to the appropriate managed types when the COBOL is compiled.

However, for native COBOL to interoperate with managed code in other languages, the COBOL must use data types that are compatible with those languages. Often there is not a strict one-to-one correspondence between types in different languages and so you need to manipulate the code to ensure compatibility. For example, for integers (such as PIC S9(9) comp-5), you might use the predefined type binary-long, which corresponds to int in both C# and Java.

COM Support from Micro Focus

COM is a feature of Microsoft Windows which enables one application to load and send messages to any application registered with the operating system as a COM Automation server.

Micro Focus COM support enables you to send messages to COM objects from COBOL programs and classes (where this COBOL is behaving as a COM client). You can also create COM objects, enabling you to manipulate a COBOL class through COM Automation.

The terminology used to describe COM components - servers, classes, clients, and objects - can be confusing. In this documentation, we use these terms as follows:

  • COM class - COBOL class that you write based on existing COBOL programs
  • COM server or COM Automation server - an application created using COM classes
  • COM client - any program that accesses a COM server application
  • COM object or component - an instance of a COM server application received by a client

COM objects are built using Microsoft's Component Object Model (COM). There are two main differences between COM and a language such as native OO COBOL:

  • COM does not support inheritance. When you write a new COM class, you can't inherit functionality from any of your existing COM or non-COM classes.
  • COM does not support class methods and class data.

Microsoft also support a distributed version of COM, which works across a network, called DCOM. DCOM enables you to send messages to an object residing on a different machine.

Parent topic: Interoperability


Data Marshaling and Type Conversion for Managed Code Interoperation

Data type compatibility is one of the main issues when managed COBOL interoperates with code in non-COBOL managed languages. Often, you need to manipulate the COBOL data into compatible types.
  • Type Compatibility in Interoperation with Managed Code
    For COBOL to interoperate with managed code in other languages, the COBOL must use data types that are compatible with those languages. Often there is not a strict one-to-one correspondence between types in different languages and so you need to manipulate the code to ensure compatibility.
  • Type Mappings from Native COBOL to Managed Code
    COBOL data items are exposed as managed types, when the code is compiled with the ILSMARTLINKAGE directive.
  • Write a Proxy or Edit the COBOL for Managed Interoperation?
    If the COBOL types are incompatible with the managed non-COBOL you want to interoperate with, you can either re-engineer the existing COBOL, or write a proxy COBOL class to act as an interface between the existing COBOL and the non-COBOL.
  • Examples of Compatible Types for Native and Managed COBOL
    The InterfacingWithStdCOBOL.sln solution contains six projects. There are three pairs of projects, where each pair comprises a C# client console project and a COBOL project. Each client C# project makes a reference to its corresponding COBOL project so that it can use the implicit or explicit COBOL methods that are exposed.
Parent topic: Interoperability


Type Compatibility in Interoperation with Managed Code

For COBOL to interoperate with managed code in other languages, the COBOL must use data types that are compatible with those languages. Often there is not a strict one-to-one correspondence between types in different languages and so you need to manipulate the code to ensure compatibility.

The Microsoft Common Language Specification (CLS) defines a set of basic language features, including the rules for the common type system. In theory, your COBOL must use CLS-compliant types. However, in practice, you can use .NET types that are not CLS-compliant, providing the non-COBOL language supports them. This is true of many C# types.

Some ISO 2002 (or more precisely ISO/IEC 1989:2002) data types, such as binary-long and float-short are available, and we recommend you use these where appropriate. See COBOL Type Compatibility for details.

The techniques for ensuring data type compatibility include the following:

  • For integers, you could use the predefined type binary-long, which corresponds to int in both C# and Java.
  • For display types (PIC X fields), you could use a .NET System.String, a java.lang.String, or a portable string type.
  • For numeric types (PIC 9 fields), you could use a .NET System.Decimal, or in JVM a com.microfocus.cobol.program.ScaledInteger, and then you move the number out of there to whatever COBOL numerical field it was
  • For group items, you could use a value type to expose the items in the group.
  • For occurs types, you could use a .NET System.Collections.ArrayList, or java.util.ArrayList.
  • For other complex structures that are not CLS-compliant, you could use COBOL classes and value types with properties.
  • For object pointers, you could use a proxy class.

    For example, a program might invoke COBOL and want to pass an object pointer, where the object has properties containing the data to be passed. The called COBOL method has to extract the data required from the object properties and convert it into COBOL types, such as a group item containing PIC X fields. You could use a proxy class with properties to do this. The original COBOL can then handle the data in its traditional form.

Parent topic: Data Marshaling and Type Conversion for Managed Code Interoperation
Related information
Write a Proxy or Edit the COBOL for Managed Interoperation?
Compatible Types Example in .NET COBOL Interoperation
Group Items Example in .NET COBOL Interoperation
Occurs Clause Example in .NET COBOL Interoperation
Type Compatibility of Managed COBOL with Other Managed Languages


Type Mappings from Native COBOL to Managed Code

COBOL data items are exposed as managed types, when the code is compiled with the ILSMARTLINKAGE directive.

COBOL data items are exposed as the following managed types, when the code is compiled with the ILSMARTLINKAGE directive:

Native COBOL | C# type | Java type | Managed COBOL
PIC X(n) | string | String | string
PIC S9(n) where n <= 2 | sbyte | byte | binary-char
PIC 9(n) where n <= 2 | byte | byte | binary-char unsigned
PIC S9(n) where 2 < n <= 4 | short | short | binary-short
PIC 9(n) where 2 < n <= 4 | ushort | short | binary-short unsigned
PIC S9(n) where 4 < n <= 9 | int | int | binary-long
PIC S9(n) where 4 < n <= 9 | uint | int | binary-long unsigned
PIC 9(n) where 9 < n <= 19 | long | long | binary-double
PIC 9(n) where 9 < n <= 19 | ulong | long | binary-double unsigned
PIC 9(n)V9(m) | decimal | ScaledInteger | decimal
PIC 9(n)V9(m) | decimal | ScaledInteger | decimal
COMP-1 | float | float | float-short
COMP-2 | double | double | float-long
PIC Z9 (and any numeric edited) | string | String | string
PIC A(n) | string | String | string
Group item | string | String | string
Parent topic: Data Marshaling and Type Conversion for Managed Code Interoperation
Parent topic: Concepts - Managed COBOL
Related reference
Type Specifier
Procedure Division Header
Related information
Types and Type Conversion
Type Compatibility of Managed COBOL with Other Managed Languages
Data Types - in COBOL and C#


Write a Proxy or Edit the COBOL for Managed Interoperation?

If the COBOL types are incompatible with the managed non-COBOL you want to interoperate with, you can either re-engineer the existing COBOL, or write a proxy COBOL class to act as an interface between the existing COBOL and the non-COBOL.

If the COBOL types are incompatible with the managed non-COBOL you want to interoperate with, you can either re-engineer the existing COBOL, or write a proxy COBOL class to act as an interface between the existing COBOL and the non-COBOL.

These two options have the following implications:

  • Editing the existing COBOL

    You manipulate the types so that the Linkage section uses compatible types. You might need to re-engineer the COBOL if there is more than one point of EXIT or GOBACK, so that you move data back into the new Linkage Section. Alternatively, you can re-engineer your COBOL as an OO COBOL class with one or more methods. Be aware that the more methods you use the more re-engineering you have to do.

    You compile your COBOL module to IL, which exposes the module and its entry points as instance methods. Your managed code can then use the CobLoad method of the Interop class in MicroFocus.COBOL.RuntimeServices to get the instance of the program and can then invoke the COBOL methods directly, just like any other methods.

  • Writing a proxy COBOL class

    You write a proxy class in managed COBOL, which adds a thin layer between the existing COBOL and the non-COBOL managed code. This class interfaces between COBOL and the managed application using objects and properties, using the standard COBOL CALL "program" USING… syntax.

    You recompile the existing COBOL to IL (and in many cases there will be only a very few changes, particularly in non-UI COBOL subroutines).

    Your managed code can then invoke the proxy class, which in turn invokes the original COBOL.

The advantages of calling the COBOL directly are:

  • There might be a slight performance improvement, since there is no proxy layer
  • There are fewer modules to maintain
  • You don't need to write a proxy class

The advantages of using a proxy class are:

  • The same COBOL sources can be used in both managed and traditional applications and so they are usable on other platforms
  • The architecture is cleaner and easier to maintain
  • You don't need to modify the Linkage section of the original COBOL, or provide code to unpackage the data passed as properties in an object
  • If the proxy class implements an interface then standard coding patterns can be applied; that is, the implementation is separated from the definition.
Parent topic: Data Marshaling and Type Conversion for Managed Code Interoperation
Related information
Type Compatibility in Interoperation with Managed Code


Examples of Compatible Types for Native and Managed COBOL

The InterfacingWithStdCOBOL.sln solution contains six projects. There are three pairs of projects, where each pair comprises a C# client console project and a COBOL project. Each client C# project makes a reference to its corresponding COBOL project so that it can use the implicit or explicit COBOL methods that are exposed.

The InterfacingWithStdCOBOL.sln solution is supplied with the examples.

  • Compatible Types Example in .NET COBOL Interoperation
    The first pair of projects, StdCbl01.*, shows a COBOL program using types that are compatible with C# types.
  • Group Items Example in .NET COBOL Interoperation
    The second pair of projects, StdCbl02*, shows a COBOL program using group items.
  • Occurs Clause Example in .NET COBOL Interoperation
    The third pair of projects, StdCbl03*, shows a COBOL program using occurs clauses.
Parent topic: Data Marshaling and Type Conversion for Managed Code Interoperation


Compatible Types Example in .NET COBOL Interoperation

The first pair of projects, StdCbl01.*, shows a COBOL program using types that are compatible with C# types.

In the InterfacingWithStdCOBOL.sln solution, the first pair of projects, StdCbl01.*, shows a COBOL program using types that are compatible with C# types. Although this works, it is a somewhat fictitious example, as COBOL modules usually use other data types and more complex structures that don't correspond to .NET types.

The StdCbl01 projects include the following programs:

  • StdCbl01.cbl. This program uses types that are directly compatible with C# types. This means that you can invoke the COBOL from the C# client, without changing the COBOL. For example:

    Lines 21-31

    LINKAGE SECTION.
...
01  F-SBYTE-COMP5 PIC S9(02) COMP-5. *>   map to C# sbyte
01  F-SHORT-COMP5 PIC S9(04) COMP-5. *>   map to C# short
01  F-INT-COMP5   PIC S9(09) COMP-5. *>   map to C# int
01  F-LONG-COMP5  PIC S9(18) COMP-5. *>   map to C# long
01  F-COMP1                  COMP-1. *>   map to C# float
01  F-COMP2                  COMP-2. *>   map to C# double

    This program is procedural COBOL. When you compile it to managed code, you create a class and an instance method is implicitly exposed. The Class and method names are derived from the PROGRAM-ID, StdCbl01. In this way, the program is exposed as a method so that any managed code can use it directly. For example:

    Line 12:

    PROGRAM-ID. StdCbl01. *> PROGRAM-ID is used both as class name
                      *> and as the only INSTANCE method available
    By default, the COBOL language translates all names and identifiers to upper case. If you want to maintain and expose a name in its original case, you must use the keyword AS. For example the following would expose the class and method as StdCbl01 in a C# program.
    PROGRAM-ID. StdCbl01 AS “StdCbl01”
  • StdCbl01Client.cs. This is the C# client, which passes data to the COBOL, and receives data back. This C# code invokes the COBOL program by fetching the COBOL program instance and then invoking the method in the same way that it would invoke any other managed code method, as follows:

    Line 37:

    STDCBL01 stdCbl01 = (STDCBL01)Interop.CobLoad("StdCbl01");
COBOLrc = stdcbl01.STDCBL01(ref CSsbyte, ref CSshort,
                                 ref CSint, ref CSlong,
                                 ref CSfloat, ref CSdouble);
Parent topic: Examples of Compatible Types for Native and Managed COBOL
Related information
Type Compatibility in Interoperation with Managed Code


Group Items Example in .NET COBOL Interoperation

The second pair of projects, StdCbl02*, shows a COBOL program using group items.

In the InterfacingWithStdCOBOL.sln solution, the second pair of projects, StdCbl02*, shows a COBOL program using group items. This is more representative of real COBOL than the StdCbl01 program. C# doesn't have the concept of group items, so we write a proxy class to manipulate the data and act as an interface between the COBOL and the C#.

The StdCbl02 projects contain the following programs:

  • StdCbl02.cbl. This program is procedural COBOL. It is compiled to managed code without any changes.
  • StdCbl02.cpy. This copybook defines group items, which contain the parameters passed to and from StdCbl02.cbl, as follows:

    Lines 06-09:

    01 INPUT-FIELDS.
   03 IN-FIELD01     PIC  X(01).
   03 IN-FIELD02     PIC  9(03).
   03 IN-FIELD03     PIC S9(05)V99    COMP-3.
  • ooiStdCbl02.cbl. This program acts as an interface (a proxy) between the C# and the unchanged COBOL StdCbl02.cbl. It manipulates the group items as follows:
    • Defines object properties to contain the data passed to and from the client C# program, as follows:

      Lines 33-35

01 InField01  Object Reference StringClass  property AS "InField01".
01 InField02  Binary-Short                  property AS "InField02".
01 InField03  Object reference DecimalClass property AS "InField03".
    • Takes the input data from the object properties set in the C# client program and puts this data into the COBOL fields defined in the copybook, as follows:

      Lines 52-54:

      Set IN-FIELD01              to InField01
Set IN-FIELD02              to InField02
Set IN-FIELD03              to InField03
  • StdCbl02Client.cs. This is the client program, written in C#. It does the following:
    • Sets the object properties of the class OOiStdCbl02

      Lines 25-27

objStdCbl02.InField01  = "A";
objStdCbl02.InField02  = 999;
objStdCbl02.InField03  = 12345.67M;
    • Invokes the method ExecStdCbl02 in the newly written proxy class, as follows:

      Line 31:

      objStdCbl02.ExecStdCbl02();
Parent topic: Examples of Compatible Types for Native and Managed COBOL
Related information
Type Compatibility in Interoperation with Managed Code


Occurs Clause Example in .NET COBOL Interoperation

The third pair of projects, StdCbl03*, shows a COBOL program using occurs clauses.

In the InterfacingWithStdCOBOL.sln solution, the third pair of projects, StdCbl03*, shows a COBOL program using occurs clauses. In the same way as the StdCbl02 projects, this project uses a proxy class to manipulate the COBOL data to and from object properties, so that these properties are exposed to the C# client.

The StdCbl03 projects contain the following programs:

  • StdCbl03.cbl. This uses two occurs clauses (defined in the copybook). One of these occurs clauses is as follows:

    Lines 11-16:

    01 INOUT-FIELDS.
  03 INOUT-FIELD01                PIC  9(02)       COMP.
  03 INOUT-FIELD02                PIC  X(26).
  03 INOUT-TABLE          OCCURS 3.
    05 INOUT-TABLE-FIELD01        PIC  X(15).
    05 INOUT-TABLE-FIELD02        PIC    S9(09)V9(5)  COMP-3.

    We can view this occurs group as if it had three occurrences of two fields or an array of size three where each position in the array has two fields or properties. If each occurrence is an object with two properties, you can code it neatly as a .NET ArrayList.

  • OOiInoutfields.cbl. This program defines a COBOL class that exposes the input/output fields as object properties. This class is instantiated by StdCbl03Client.cs and each object created is saved in an ArrayList item. This ArrayList is then passed to OOiStdCbl03.Cbl. For example:

    Lines 7-33

        *> OO COBOL class for OUT-TABLE table
 class-id. OOiOutFields.
 working-storage section.
    *> using native .NET Type and/or classes
 01 OutTableField01      type System.Double property.
 01 OutTableField02      type System.Double property.

 end class.
  • OOiOutfields.cbl. Similar to the above program, this program defines a COBOL class that exposes the output fields as object properties for use in StdCbl03Client.cs as ArrayList items.
  • OOiStdCbl03.cbl. This is the newly-written proxy COBOL program that manipulates the occurs groups, as follows:
    • Uses the arrays that are passed to and from the .NET managed client.

      Line 31 in the Working Storage section of the method ExecStdCbl03:

      01 obj-InoutFieldsItem    type OOiInoutFields

      Line 59 in the Linkage section:

      01 obj-InoutFieldsArray   Object Reference ArrayListClass.

      Line 36:

      procedure division using obj-InoutFieldsArray as type System.Collections.ArrayList
                         obj-OutFieldsArray   as type System.Collections.ArrayList.
    • For each occurrence in each ArrayList, take the object's properties and populate the original occurs group (defined in the copybook).

      Lines 47-51:

      Move 1 to Idx
Perform varying obj-InoutFieldsItem through obj-InoutFieldsArray
             Set INOUT-TABLE-FIELD01(Idx) to
                       obj-InoutFieldsItem::"InOutTableField01"
    Move obj-InoutFieldsItem::"InOutTableField02" to
                       INOUT-TABLE-FIELD02(Idx)
             Add 1 to Idx
    End-Perform

      The ArrayList now contains three objects each with two properties. It contains the equivalent of three occurrences of two fields in an occurs group.

    • Call the existing COBOL module from the proxy COBOL class, passing the original data structure with its occurs group. See the program OOiStdCbl03.cbl

      Line 53:

      Call "StdCbl03"
         using INPUT-FIELDS INOUT-FIELDS OUTPUT-FIELDS
  • StdCbl03Client.cs. This is the client program, written in C#. It does the following:
    • Creates a NET ArrayList (or more precisely System.Collections.ArrayList), as follows:

      Lines 31:

      ArrayList InOutArray = new ArrayList(3);
    • Sets the object properties of the ArrayList items, as follows:

      Lines 36-39:

      OOiInoutFields inOutFieldsItem0 = new OOiInoutFields();
inOutFieldsItem0.InOutTableField01 = "Item #1";
inOutFieldsItem0.InOutTableField02 = 111.111;
InOutArray.Add(inOutFieldsItem0);
    • Invokes the method ExecStdCbl03 in the newly written proxy class, as follows:

      Line 55:

      objStdCbl03.ExecStdCbl03(ref InOutArray, ref OutArray );

The result is a .NET ArrayList (or more precisely System.Collections.ArrayList) that you can pass to and from C# or any .NET managed code. You can work with it in many ways, including binding it to a DataGrid.

Parent topic: Examples of Compatible Types for Native and Managed COBOL
Related information
Type Compatibility in Interoperation with Managed Code


Calling a .NET Class from Native COBOL, Using CCW

The COM-callable-wrapper (CCW) is a .NET technique for COM interoperability. CCW wraps managed code as a COM object so that native code can call it like any other COM object.

The COM-callable-wrapper (CCW) is a .NET technique for COM interoperability. CCW wraps managed code as a COM object so that native code can call it like any other COM object. It effectively exposes a .NET managed class in any language as a COM interface. For more background, see the Visual Studio Help topic COM Callable Wrapper.

To expose a .NET class as a COM object, you configure the project so that the class is registered for COM interop. When you build the project, the class is registered and thereby made available to native COBOL.

All public methods defined and implemented in the .NET class are exposed as a COM interface. Your COM client application can then invoke those methods as if they were methods of a COM object.

To call a .NET class from native COBOL

  1. In Visual Studio, open the project containing the .NET class to expose, by clicking File > Open > Project and browsing to the project.
  2. Click Project > myProject Properties.
  3. On the COBOL tab, check Register for COM interop in the Output section.

To call the exposed .NET class from native COBOL

The native COBOL calls the .NET class as if it were a COM object, by including the following elements of code:

  1. Set the Checker directive OOCTRL(+P) in your program:
    $SET OOCTRL(+P)

    This checker directive enables the run-time system to map from COBOL data types to COM data types.

  2. Map each COM class to an OO COBOL proxy class in the CLASS-CONTROL paragraph. Give the COM class an OO COBOL class-name, and specify that it is in the COM domain, using a statement of the form:
    class-name IS CLASS "$OLE$windows-registry-name"

    where windows-registry-name is one of the following:

    • the ProgID for the server
    • the CLSID for the server

    The ProgID and CLSID are defined in the Windows registry.

  3. Create an instance of the OO COBOL COM class.

    Send the message "new" to the OO COBOL proxy class. This starts the COM server if it is not already running. You are returned an OO COBOL handle which you can use to send messages to the COM server.

  4. Send messages to the COM server.
  5. To access properties, prefix the property name with "Set" to set a property or "Get" to retrieve a property.

    When setting a property, pass a single parameter. When getting a property the value is returned as the RETURNING parameter.

Parent topic: Interoperability
Related information
To use CCW to expose a .NET class to native COBOL
CCW Example


CCW Example

See the CCW example, which is with the Visual Studio examples in the examples folder of the installation of your COBOL development system. This example contains a .NET solution and a COBOL application.

The .NET solution ManagedCOM contains the following programs:

  • ManagedCOM.cbl. This simple .NET class implements an interface defined in InterfaceDef.cbl. The project has been configured to register this class as a COM object. See Project > ManagedCOMProperties > Configuration Properties > Build > Register for COM interop.
  • InterfaceDef.cbl. This is the definition of the interface which is implemented by the .NET class in ManagedCOM.cbl. The methods are all public by default and so they are exposed by the COM object registered by the build process. The interface will be exposed by the COM object as ICustomInterface.
  • PrivateClass.cbl. By default, all public classes are exposed to COM clients when registering for COM interop and this is not always desirable. By using the class level attribute ComVisible we can hide this class.

The project has been configured so that when you build it, it will:

  • Register the ManagedCOM class as a COM object. See Project > ManagedCOMProperties > Configuration Properties > Build > Register for COM interop.
  • Set COMDemo as the default namespace to use for the classes in this assembly. See Common Properties > General.

The COBOL application client.app contains the following program:

  • callcom.cbl. This is unmanaged COBOL and not part of the project. This is the client program that uses the .NET class ManagedCOM.cbl.

    This program invokes methods in the .NET class as if the class was any other COM object, by using the COM programmatic ID of the .NET class. This ID takes the form DefaultNamespace.Class. Where DefaultNamespace is defined as described above and Class is the name of the source file containing the class.

    When you use COM objects in COBOL you prefix the COM class name (or prog ID) with $OLE$. So the program refers to the class as:

    class ManagedCOM as "$OLE$COMDemo.ManagedCOM"

To run the example:

  1. In Visual Studio, open the solution ManagedCOM.sln and rebuild it.
  2. In Net Express, animate the program callcom and step through it.
Parent topic: Interoperability
Related information
To use CCW to expose a .NET class to native COBOL
Calling a .NET Class from Native COBOL, Using CCW


Calling a Native COBOL COM Object, Using RCW

The runtime-callable-wrapper (RCW) is a .NET technique for COM interoperability. RCW wraps a COM object so that the .NET runtime system can call it. It effectively exposes a COM interface so that managed code can call it.

The runtime-callable-wrapper (RCW) is a .NET technique for COM interoperability. RCW wraps a COM object so that the .NET runtime system can call it. It effectively exposes a COM interface so that managed code can call it. For more background, see the Visual Studio Help topic Runtime Callable Wrapper.

RCW enables the COBOL CALL statement to call native COBOL that is packaged as a COM object.

Note: The COM object must have a type library for it to be usable in the .NET environment.

To call a native COBOL from managed code, first you package the COBOL as a COM object and then you register it. You then add the COM object as a reference in your project. When you build the project, the RCW is generated, thereby exposing the COM class as a managed proxy class. When you run the application, the managed code accesses the COBOL COM object running as a COM automation server.

The benefit of using RCW is that your managed program just sees the COM object as a managed class (and you get the benefit of IntelliSense). The .NET run-time system manages the data type manipulation to convert .NET types to COM types for you.

To call a native COBOL COM object

  1. Package the native COBOL as a COM object.

    Note that in .NET, COM objects must have a type library.

  2. Register the COM object using the command:
    regsvr32 myCOMObject.dll
  3. Add the COM object to your Studio Enterprise Edition project as a reference. To do this:
    1. Right-click References in Solution Explorer.
    2. Click Add reference.
    3. Browse to your COM object and select it.
  4. In your managed code, invoke the COM object in the same way as any other managed object. The following example invokes the Calculate method on the object theLoanCalculator:
    invoke theLoanCalculator::"Calculate"
Parent topic: Interoperability
Related information
To use RCW to call native COBOL
RCW Example


RCW Example

The .NET solution loancalc.sln contains the following of interest:

  • LoanCalc.cbl. This is the managed COBOL program. It uses the COM object comploan.dll.
  • Interop.comploan. This is a reference to the COM object and is listed in the References folder of the project. It is the COM object's proxy assembly, which is generated by the project. It is marked with a warning triangle if you have not created the COM object yet.

    The source code for the COM object is not included in the project, because the source is remaining as unmanaged code. Only the built COM object is required within the project.

The COBOL application comploan\compdll.app contains the following programs:

  • comploan.cbl. This is the existing OO COBOL source for the COM object. The code is based on the original CompLoan demonstration in Net Express. It has been updated to include a type library, which is required for COM objects in the .NET environment.
  • comploanTrigger.cbl. The is the legacy trigger program. This is unchanged for interoperating with .NET.
  • comploan\debug\comploan.dll. This is the built COM object. This is not shipped because you will create it when you compile the project.

To run the example:

  1. In Net Express, compile the project compdll.app to create the COM object.
  2. Register the COM object at a command prompt. To do this, go to the folder where you created the COM object, comploan.dll, and type:

    regsvr32 comploan.dll

  3. In Visual Studio, close the solution loancalc.sln and reopen it to pick up the newly referenced COM object. You can see it now listed without the warning triangle.
  4. Build the solution and step through it.
Parent topic: Interoperability
Related information
To use RCW to call native COBOL
Calling a Native COBOL COM Object, Using RCW


Platform Invoke and Calling Native COBOL

Platform Invoke is a .NET technique that enables managed code to call unmanaged functions implemented in dynamic link libraries (.dlls).

For more information on Platform Invoke see the Visual Studio Help topic Consuming Unmanaged Code.

Platform invoke is similar to an API call. It enables managed COBOL to use the COBOL CALL statement to call native COBOL that is built as a .dll.

If you have existing COBOL that you want to call from managed code, you must first build it as a native .dll with the entry points that you need to call. You then add the .dll as a reference to your .NET project.

In your .NET project, you write a managed COBOL program and use CALL statements to call functions in the .dll. These CALL statements generate a platform invoke call if the CALL matches an entry in the native .dll.

To use Platform Invoke to call native COBOL

  1. Package your native COBOL as a .dll with the necessary entry points into the code.If you have Net Express installed, you can do this in the Net Express IDE.
  2. Add the .dll and the COBOL run-time system support to your COBOL project as references, as follows:
    1. Right-click References in the solution view on the right.
    2. Click Add reference.
    3. Browse to MicroFocus.COBOL.Runtime and select it.
    4. On the Projects tab, browse to your .dll and select it.
  3. Write some .NET managed COBOL to call your .dll, using the standard COBOL CALL statement, such as:
    CALL myNativeLibrary USING myParams
  4. Now non-COBOL managed code can invoke the above managed COBOL, which in turn calls the native COBOL .dll.
Parent topic: Interoperability
Related information
To use Platform Invoke to call native COBOL
PInvoke Example


PInvoke Example

The supplied PInvoke sample demonstrates Platform Invoke.

See the Pinvoke example, which is with the Visual Studio examples. This example contains the following of interest:

  • Pinvoke.cbl. This program is managed COBOL. It uses the standard COBOL CALL statement to call the sub program and to send it the message buffer to display, as follows:
           call "SUB" using messageBuffer
  • sub.dll. This program is existing native COBOL.

    The built sub.dll is included as a reference in the project, whereas the source file sub.cbl is not included, because it is native code and not compiled as part of the project. You can view the source file by opening it from the File menu.

To run the example:

  1. Build the solution by clicking Build > Build pinvoke.
  2. Step through the program, using Debug > Step into.
Parent topic: Interoperability
Related information
To use Platform Invoke to call native COBOL
Platform Invoke and Calling Native COBOL


Callable Attribute in .NET COBOL Interoperation

To call methods from COBOL safely, you need to set the MicroFocus.COBOL.RuntimeServices.CallableAttribute attribute on the non-COBOL methods and on the class and assembly containing them

Because both COBOL-enabled methods and .NET Framework methods can have the same name and signature, you might get unexpected results when using the COBOL CALL verb.

Set the MicroFocus.COBOL.RuntimeServices.CallableAttribute attribute on the non-COBOL methods and on the class and assembly containing them in order to call the methods from COBOL safely.

Parent topic: Interoperability
Related information
The CALL Statement
CallableAttribute Class


Multi-threaded Programming

  • Introduction to Multi-threading
  • Synchronizing Execution and Resolving Contention
  • Writing Multi-threaded Applications
  • Multi-threading Compiler Directives
Parent topic: Managed COBOL Programming


Introduction to Multi-threading

Multi-threading is a term used to describe: A facility provided by the operating system that enables an application to create threads of execution within a process Applications whose architecture takes advantage of the multi-threading provided by the operating system.

  • Multi-threading and the Operating System
  • Multi-threading and the Application
  • Multi-threading and the Command Line
Parent topic: Multi-threaded Programming
Related information
Synchronizing Execution and Resolving Contention
Writing Multi-threaded Applications
Multi-threading Compiler Directives


Multi-threading and the Operating System

On most modern operating systems, many different users can run programs (processes) at what appears to be the same time. If the operating system is hosted by a hardware system with a single Central Processing Unit (CPU) then these processes are not running at exactly the same time - it just appears that they are. The operating system allocates the CPU and other system resources to the processes that need them and (preemptively) switches these resources from one running program to another. This switching of resources gives the appearance that the programs are running at the same time.

In a very similar way, many modern operating systems allow multiple threads to exist within each process. Again, the operating system handles the allocation of the CPU and various resources to individual threads and switches these allocations from one running thread. Again, this gives the appearance that the threads are running at the same time.

If process and threads are handled in a similar way by the operating system, what distinguishes them from each other?

All processes have distinct address spaces, open files and other system resources; this enables each process to run with minimal or no effect on other processes running at the same time. However, this separation of resources has a run-time cost:

  • Each process consumes system memory for its address space
  • The operating system must update a lot of internal information whenever it switches execution context from one process to another

Because threads run within a single process, all of the threads associated with a process share the same data and code address space, the same open files and most other resources. Each thread also has its own register set and stack space. Creation of a thread, therefore, does not require extensive system memory. When the operating system finds it has to switch execution context from one thread to another within the same process, about the only thing the operating system needs to do is switch CPU ownership and register sets. This is the reason that threads are often called `light-weight processes'.

Parent topic: Introduction to Multi-threading


Multi-threading and the Application

A multi-threaded application is an application whose architecture takes advantage of the multi-threading provided by the operating system. Usually, these applications assign specific jobs to individual threads within the process and the threads communicate, through various means, to synchronize their actions. For example, a data processing application might be designed so that the graphical user interface is completely handled by a single thread, while the actual work of the application is performed by another thread. This architecture would allow the complete separation of the business logic from the user-interface logic within the application.

Another interesting use for multi-threading within an application is in the server side of a client/server application. The server could be designed so that for each service request submitted to a main controller/communications thread, a separate service thread is created to process that request and communicate the results back to the controller. The controller would then communicate these results back to the client. The main benefit of such a design is that the server is not tied up acting on one client's request to the extent that it cannot respond to other client's requests quickly.

Of course, client-server applications that have immediate (or very fast) server response have been written without multi-threading for years. This is usually accomplished by a main controller/communications process creating separate service processes for each client request. So why does an application like this need multi-threading? The main answer is: efficient use of system resources.

The creation of a thread requires very little operating system resource (memory, context swap overhead and so on) and the sharing of files and other resources is simplified. The creation of a process requires more system resources and it tends to be much more difficult to communicate and share files between processes. Multi-threading allows you to make the best use out of your existing hardware resources and also allows simple resource sharing.

There are, of course, disadvantages in using multi-threaded applications. Each thread must be aware of the resources that it might be sharing with other threads in the same process. The programmer must remember that threads execute at the same time and that if two threads write to the same data item, without any form of execution synchronization, the data-item is likely to be corrupted.

For example, consider the following code fragments:

Working-Storage Section.
01 group-item.
  05 field-1  pic x.
  05 field-2  pic x.
procedure division.
move 'A' to field-1
move 'B' to field-2
display group-item

Working-Storage Section.
01 group-item.
  05 field-1  pic x.
  05 field-2  pic x.
procedure division.
move 'C' to field-2
move 'D' to field-1
display group-item

Consider the following possible order of thread execution:

Processing step Thread 1 execution Thread 2 execution
1
move 'A' to field-1
2
move 'C' to field-2
3
move 'B' to field-2
4
move 'D' to field-1
5
display group-item
6
display group-item

In this example, neither thread will display its expected result. The intended result of Thread 1 was to display 'AB', while the intended result of Thread 2 was to display 'DC'. However, the actual result is that both threads display 'DB'. If you are creating multi-threaded applications, you must synchronize execution between threads, and avoid and resolve data contention between threads, as described in the chapter Synchronizing Execution and Resolving Contention.

Parent topic: Introduction to Multi-threading


Multi-threading and the Command Line

To run a multi-threaded application from the command prompt, you must use the runm command rather than the run command.

To run a .NET managed multi-threaded application, you can run the executable like any .NET application, that is, without a trigger program.

Parent topic: Introduction to Multi-threading


Synchronizing Execution and Resolving Contention

This section describes how to control multi-threading within an application by synchronizing execution of threads, and resolving data contention between threads.

  • Introduction
  • Multi-threaded Program Attributes
  • Use of Data Attributes
  • Using Synchronization Primitives
Parent topic: Multi-threaded Programming
Related information
Introduction to Multi-threading
Writing Multi-threaded Applications
Multi-threading Compiler Directives


Introduction

Uncontrolled multi-threading within an application can cause unpredictable end results. To achieve predictable results from an application, you need to synchronize execution of threads, and resolve data contention between threads; there are various methods you can use to achieve this. The methods you use depend on the characteristics of your application's data access, and the requirements for true multi-threading within the individual COBOL programs that make up your application. You can use:

  • Program attributes assigned by Compiler directives
  • The attributes of a data item to determine if there is a possibility that threads will contend for access to data items
  • Synchronization primitives
Parent topic: Synchronizing Execution and Resolving Contention


Multi-threaded Program Attributes

There are three main program attributes that affect multi-threading within a COBOL program. These attributes are assigned by including or omitting one of multi-threading Compiler directives when you compile your program. The directives used affect the allocation of the program's system work areas and can cause automatic system locking of the compiled program.

  • Specifying No Multi-threading
  • Serial Programs
  • Reentrant Programs
Parent topic: Synchronizing Execution and Resolving Contention


Specifying No Multi-threading

You can specify that a program is not a multi-threading program, by omitting any of the multi-threading Compiler directives when you compile your program.

If you do this, system work areas are allocated statically, and are thus subject to contention. This approach has several advantages, call speed and efficient stack usage among them, but it is up to your application to make sure that only one thread executes within a non-multi-threading program at a time. This can be accomplished through implicit program logic in any calling program; for example, when the application, by design, has only one thread calling a non-multi-threaded program. Alternatively, one of the synchronization primitives (such as a mutex) can be locked in the calling program just before the called program is entered and then unlocked when the called program has returned.

Parent topic: Multi-threaded Program Attributes


Serial Programs

In a program that has the serial attribute, system work areas are allocated statically, and the program is locked on entry and unlocked on exit.

This allows only one thread to execute the program at a given time and so eliminates any contention on system or user work areas. No other explicit application logic is required.

A program can be given the serial attribute by specifying the SERIAL Compiler directive when you compile it.

By specifying a traditional COBOL program as a serial program it can be included in a multi-threaded application without any source changes.

The disadvantages of serial programs are that:

  • The level of multi-threading is limited within the application. Ideally, a multi-threaded application should allow free execution of as much code as possible to allow maximum performance.
  • Locking and unlocking the program can have a major run-time cost. This can significantly affect call speed and overall application performance. For this reason, as few modules as possible should be compiled with this directive and, you should ensure that called programs have the no-multi-threading attribute. For example, if program A is to be compiled with the serial attribute and program A is the only program in the application that calls programs B and C, then by application design, program B and C are already serialized and can be compiled with the no-multi-threading attribute.
Parent topic: Multi-threaded Program Attributes


Reentrant Programs

You can specify that a multi-threaded program is to be reentrant by compiling it with the REENTRANT Compiler directive. You should use reentrant programs for most (if not all) of the modules in a multi-threaded application.

If you specify REENTRANT(1), all compiler-generated temporary work areas are allocated on a per-thread basis. All user data and FD file areas allocated in the Environment and Data Divisions are shared by all threads. It is the responsibility of the programmer to ensure serialization to the program's data by use of the CBL_ synchronization calls.

If you specify REENTRANT(2), all Working-Storage Section and File Section data, as well as system work areas, are allocated on a per-thread basis. Local storage is allocated dynamically on the stack. This eliminates thread contention on these areas, so that the program behaves safely if called from multiple threads concurrently. No program locking or unlocking is needed. The disadvantage with this Compiler directive setting is that there is no data shared (other than any data defined as EXTERNAL) between the threads.

REENTRANT(2) is a quick and simple way of getting a program running in a multi-threaded application, but you should aim to compile with REENTRANT(1).

A reentrant program must itself resolve all possible contention on data items in its Working-Storage Section and File Section. One or more of the techniques for resolving data contention must be used to accomplish this; see the next section for details.

Parent topic: Multi-threaded Program Attributes


Use of Data Attributes

The attributes of a data item determine if threads that access it can contend for it. Threads can never contend for data items defined:

  • In the Local-Storage Section or Thread-Local-Storage Section
  • With the THREAD-LOCAL data attribute

Any other data items defined within the program are shared between threads, so contention is possible. Contention might occur for:

  • Data defined in the Working-Storage Section and the File Section
  • Various other implicitly defined data items such as file-status fields
  • Data stored in some Compiler special registers (except the RETURN-CODE register)

Data defined in the Local-Storage Section is traditionally used in recursive COBOL programs; for every recursion of the program a new instance of this data is allocated on the stack. Since each thread in a multi-threaded application has its own stack, this attribute is ideal for defining contention-free temporary and work items within reentrant programs. By design, a reentrant COBOL program also allows recursion within a single thread.

The disadvantage of using data defined in the Local-Storage Section is that a data item disappears when the reentrant or recursive program exits. If a program has exited, then on the next entry into that program the data items defined in the Local-Storage Section have undefined values. If a thread requires the program to preserve state across calls, some other mechanism must be used.

Data defined as thread-local, either in the Thread-Local-Storage Section, or by the THREAD-LOCAL attribute, resolves these problems. Thread-local data is unique to each thread, persists across calls and can be initialized with value clauses. Thread-local data can be viewed as a thread-specific Working-Storage data item. This kind of data is very useful for resolving contention problems in most reentrant programs. In many cases, a program that does no file handling can be made completely reentrant by simply changing the Working-Storage Section header to a Thread-Local-Storage Section header. You can fine-tune data allocation by defining all read-only constants in the Working-Storage Section, and all read-write data items in Thread-Local-Storage Section.

The use of thread-local data has the following disadvantages:

  • Data values are not easily communicated between threads; for this it is better to define data in the Working-Storage Section and use appropriate thread synchronization.
  • It adds an overhead to program calls; if it is used in a high-traffic module then overall application performance can be seriously affected.
  • It is not possible to have EXTERNAL items within the Thread-Local-Storage Section. Currently, if thread-local data must be shared between application modules, the CBL_TSTORE_n routines must be used

Sometimes threads require more than just private data. Most multi-threaded applications communicate and coordinate thread execution through shared data that is accessed by each thread under a strict protocol. In COBOL this is accomplished through the use of Working-Storage Section or File Section data in conjunction with the use of various synchronization primitives that resolve any possibility for destructive contention on the data. See the next section for details of the synchronization primitives.

Parent topic: Synchronizing Execution and Resolving Contention


Using Synchronization Primitives

Synchronizing threads that access shared data is critical for predictable results in a multi-threaded application. Understanding the nature of the various data accesses between threads is the first step in determining what synchronization primitives and regimes should be used. Once the data access has been characterized, it is a simple matter to follow a synchronization regime for data items among all threads. The following sections outline common data sharing problems and their solutions.

  • Using a Mutex
  • Using a Monitor
  • Using a Semaphore
  • Using an Event
Parent topic: Synchronizing Execution and Resolving Contention


Using a Mutex

The simplest form of a data sharing problem is when multiple threads require mutually exclusive access to shared data at some point during their processing. The area of code that accesses this shared data is called a critical section and these critical sections can be protected by the use of a mutex that is logically associated with the shared data items. The term mutex comes from the phrase mutual exclusion. The mutex associated with the data items is locked before a critical section is entered and unlocked when that critical section is finished.

It is vital that all threads lock the mutex before accessing any of the data that is being protected. If even one thread fails to follow this regime, then unpredictable results could occur.

For example, the following code illustrates the protection of two critical sections that access a table, adding to it or counting items in it. The working storage data items table-xxx are protected by table-mutex.

Example

In this example the mutex is required to prevent a thread from adding data to the table while another thread reads the table at the same time.

 Working-Storage Section.
 78  table-length        value 20.
 01  table-mutex         usage mutex-pointer.
 01  table-current       pic x(4) comp-x value 0.
 01  table-max           pic x(4) comp-x value 0.
 01  table-1.
    05  table-item-1     pic x(10) occurs 20.

 Local-Storage Section.
 01  table-count         pic x(4) comp-x.
 01  table-i             pic x(4) comp-x.

* Initialization code executed while in single-threaded mode
     move 0 to table-max
     open table-mutex

* Add an item to table-1, this is a critical section
     set table-mutex to on
     if table-current < table-length
         add 1 to table-current
         move 'filled in' to table-item-1(table-current)
     end-if
     set table-mutex to off

* Count items in table-1, this is a critical section
     set table-mutex to on
     move 0 to table-count
     perform varying table-i from 1 by 1
             until table-i > table-current
         if  table-item-1(table-i) = 'filled in'
             add 1 to table-count
         end-if
     end-perform
     set table-mutex to off

One problem with using a mutex is that it can severely limit the level of multi-threading within an application. For example, say you have an application in which some programs add items to a table or count items in a table. In order to maximize multi-threading, you would want multiple threads to be able to count items in the table simultaneously. However, if a program was adding items to a table, you would not want a program to add items or count them.

A solution to this problem would be given by a synchronization primitive that enables multiple threads to be active in read-only critical sections but prevents any other access when a thread is active in a writer critical section; such a synchronization primitive is the monitor.

Parent topic: Using Synchronization Primitives


Using a Monitor

Monitors provide a solution to particular access problems not handled easily by mutexes. For example, you might want many threads to be able to simultaneously read data, but only one thread to be able write data. While the thread writes data, you might want to block read access by other threads.

A monitor is used by a critical section to declare what type of data access the critical section will be performing on the protected data; that is, reading, writing, or browsing.

The monitor synchronization facility can be extended to provide a critical section for browsing; this can be very useful in real world applications. A browser reads data and, depending on conditions you have set, might or might not write to protected data items. While a browser is active, any number of critical sections that simply read the data are allowed, while any other critical sections that browse or write are not allowed. If the browser thread determines that it needs to write to the protected data, it requests a conversion of the browse lock to a write lock. The conversion process waits until all critical sections that read the data are finished, and then bars any other critical sections that read or write data from accessing the data. The browser proceeds to write with exclusive access to the protected data items (whose state is guaranteed to be the same as it was when the browser was just reading the protected data).

Example

The following example code shows a monitor that controls the access of multiple threads that count items in, or add items to, a table. The code:

  • Enables multiple threads to access data for counting
  • Disables any threads that add items to the table when a thread that counts items is active
  • Enables one thread that adds items to a table; while this thread is active, the code disables access to the table by any thread that counts items
 Working-Storage Section.
 78  table-length                   value 20.
 01  table-monitor              usage monitor-pointer.
 01  table-current              pic x(4) comp-x value 0.
 01  table-1.
     05  table-item-1           pic x(10) occurs table-length.

 Local-Storage Section.
 01  table-count                pic x(4) comp-x.
 01  table-i                    pic x(4) comp-x.
  . . .
*> Initialization code, executed while in single
*> threaded mode
     move 0 to table-current
     open table-monitor

* Add an item to table-1, this is a writer critical section
     set table-monitor to writing
     if table-current < table-length
         add 1 to table-current
         move 'filled in' to table-item-1(table-current)
     end-if
     set table-monitor to not writing

* Count items in table-1, this is a reader critical section
     set table-monitor to reading
     move 0 to table-count
     perform varying table-i from 1 by 1
             until table-i > table-current
         if table-item-1 (table-i) = 'filled in'
             add 1 to table-count
         end-if
     end-perform
     set table-monitor to not reading

Example

The following is an example of a browser critical section:

 Working-Storage Section.
 01  data-monitor       usage monitor-pointer.
 01  data-value         pic x(4) comp-x value 0.

* Initialization code, executed while in single threaded
* mode
     open data-monitor

* Add an item to table-1, this is a browser critical section
     set data-monitor to browsing
     if data-value < 20
         set data-monitor to writing
             converting from browsing
         add 5 to data-value
         set data-monitor to not writing
     else
         set data-monitor to not browsing
     end-if

We do not recommend that you use a browse lock for such a simple check. Usually, you need only use a browser if a significant amount of work has to be done to determine if a write lock is actually required, and you want to maximize multi-threading throughout your application. There are various other monitor conversions available to help you maximize the level of multi-threading in your application

Parent topic: Using Synchronization Primitives


Using a Semaphore

A semaphore is a synchronization primitive that acts like a gate that lowers to prevent passage of a thread through code and raises to allow passage (of another thread) through that code. A semaphore is similar to a mutex, and can be used instead of a mutex.

Example

The following code illustrates the use of semaphores:

 Working-Storage Section.
 01  data-semaphore     usage semaphore-pointer.
 01  data-value         pic x(4) comp-x value 0.

* Initialization code executed while in single threaded mode
     open data-semaphore
     set data-semaphore up by 1      *> Initialize as raised

* Add change data-value, this is a critical section
     set data-semaphore down by 1
     add 1 to data-value
*  Allow other thread to pass semaphore
     set data-semaphore up by 1

Note that just after the OPEN verb, the semaphore is raised by 1. This enables the first acquisition of the semaphore to succeed but any following acquisitions to be blocked until the semaphore is released again.

A semaphore is less efficient than a mutex, but it is more flexible: one thread can simply release a semaphore while any other thread can then acquire it. Contrast this with a mutex. A mutex must always be acquired before it can be released, and the operations of acquiring and releasing it must happen within the same thread. Semaphores provide a way of signaling from one thread to another.

Example

The following code sample uses two different semaphores to establish handshaking between two threads. This handshaking enables one thread to signal the production of a new data value and the other thread to signal the corresponding consumption of that data value:

 Working-Storage Section.
 01  produced-semaphore         usage semaphore-pointer.
 01  data-value                 pic x(4) comp-x value 0.
 01  consumed-semaphore         usage semaphore-pointer.

* Initialization code executed while in single threaded mode
     open produced-semaphore
     open consumed-semaphore
     set consumed-semaphore up by 1

* This code is executed once to produce a data value
     set consumed-semaphore down by 1
     add 10 to data-value
*  Signal that data value has changed
     set produced-semaphore up by 1

* Another thread, waiting for the data-value to change,
* executes this code once as well.
     set produced-semaphore down by 1
     display data-value
*  Signal data value used
     set consumed-semaphore up by 1

This example illustrates another common synchronization problem known as the Producer-Consumer Problem. The simplest Producer-Consumer Problem is where there is one thread that produces data, and one thread that consumes that data, and you need to synchronize execution between the producing and consuming threads so that when the consumer is active it always has data to operate on.

The semaphores in this example count the number of releases that are outstanding on a semaphore and allow that many acquires to pass unblocked. This kind of counting semaphore enables the producer to produce multiple data values (usually in an array) before blocking to wait for the consumer to catch up.

Example

The following code illustrates a simple example of a producer/consumer pair where the producer is allowed to create data values until the data table cannot handle any more - at which point the producer blocks the creation of values until some values are consumed:

 Working-Storage Section.
 78  table-size    value 20.
 01  produced-semaphore   usage semaphore-pointer.
 01  filler.
     05  table-data-value pic x(4) comp-x
             occurs table-size times value 0.
 01  consumed-semaphore   usage semaphore-pointer.

 Local-Storage Section.
 01  table-i     pic x(4) comp-x.

* Initialization code executed while in single threaded mode
     open produced-semaphore
     open consumed-semaphore
*  Start raised 20 times
     set consumed-semaphore up by table-size

* Producer thread
     move 1 to table-i
     perform until 1 = 0
         set consumed-semaphore down by 1
         add table-i to table-data-value(table-i)
         set produced-semaphore up by 1
         add 1 to table-i
         if  table-i > table-size
             move 1 to table-i
         end-if
     end-perform.

* Consumer thread
     move 1 to table-i
     perform until 1 = 0
         set produced-semaphore down by 1
         display 'Current produced value is'
                 table-data-value(table-i)
         set consumed-semaphore up by 1
         add 1 to table-i
         if  table-i > table-size
             move 1 to table-i
         end-if
     end-perform.
Parent topic: Using Synchronization Primitives


Using an Event

An event is similar to a semaphore in that it enables one thread to signal to another that something has happened that requires attention. For several reasons an event is more flexible and slightly more complex. One reason is that an event, once posted, must be explicitly cleared.

Example

The following is an example of code that solves the Producer-Consumer problem by using event synchronization instead of semaphore synchronization:

 Working-Storage Section.
 01  produced-event     usage event-pointer.
 01  data-value         pic x(4) comp-x value 0.
 01  consumed-event     usage event-pointer.

* Initialization code executed while in single threaded mode
     open produced-event
     open consumed-event
     set consumed-event to true  *> Initialize as 'posted'

* Protocol for the producer side
     wait for consumed-event
     set consumed-event to false *> Clear event
     add 10 to data-value

* Signal that data value has changed
     set produced-event to true  *> Post event

* Protocol for the consumer side, waiting for the data-value
* to change
     wait for produced-event
     set produced-event to false *> Clear event
     display data-value

* Signal other thread that it can proceed, this thread has
* data-value
     set consumed-event to true  *> Post event

If there are only two threads (the producer and consumer threads) executing the above code, then everything will work as expected. If another thread comes in and starts executing as a producer or consumer, unexpected events will occur. This is because an event, once posted, wakes up all threads waiting for that event, unlike a semaphore which enables only one thread to pass after the semaphore has been released. After an event has been posted, and the waiting threads are woken, it is necessary for each of the woken threads to determine if it should take some form of action on the event (including clearing the event).

The last point can make events difficult to work with when there are multiple waiting threads but it also enables the building of custom synchronization objects for special needs.

Parent topic: Using Synchronization Primitives


Writing Multi-threaded Applications

This section describes and provides examples of writing multi-threaded applications.

  • Overview
  • Run-time System for Multi-threaded Applications
  • Considerations When Creating Reentrant Programs
  • Multi-threading Library Routines
  • Manipulating Threads
  • Canceling Called Programs
  • Optimizations and Programming Tips
  • Multi-threading in the .NET Framework
Parent topic: Multi-threaded Programming
Related information
Introduction to Multi-threading
Synchronizing Execution and Resolving Contention
Multi-threading Compiler Directives


Overview

When you create a multi-threaded application you need to consider how each program in the application should operate: as a standard COBOL program, as a serial program, or as a reentrant program. Of the three types of program, programs compiled as REENTRANT(1) programs need most attention.

You also to need to consider how to:

  • Initialize applications
  • Manipulate threads
  • Create thread-local data

You should also be aware of common problems with multi-threaded programming .

Parent topic: Writing Multi-threaded Applications


Run-time System for Multi-threaded Applications

The run-time system for multi-threaded applications needs to handle both multi-threaded and single-threaded applications. As a result, the multi-threaded run-time system incurs many of the synchronization costs that a standard multi-threaded COBOL application would. Further, most of these costs are incurred regardless of whether the application is multi-threaded or single-threaded. Because of this, and in order to enable single-threaded applications to run at maximum speed, Micro Focus provides two separate run-time systems: a multi-threaded run-time system that supports all applications, and a single-threaded run-time system that supports only single-threaded applications. You can choose between these run-time systems either when you run your application or when you link your application.

The files you need to ship with an application will depend in some cases on whether your application has been linked to the single-threaded or multi-threaded run-time system.

Parent topic: Writing Multi-threaded Applications


Considerations When Creating Reentrant Programs

Not every program can be compiled as reentrant. Use of some COBOL features will preclude reentrant compilation; most of these COBOL features are obsolete or archaic in ANSI Standard COBOL and their use should be discontinued. Programs that use the following features cannot be compiled with the REENTRANT directive:

  • The ALTER statement
  • The ON statement
  • The COBOL DEBUG facility
  • Procedure Division overlays - note this can be overcome by using either the NOSEG or NOOVL directives
  • The IS INITIAL clause of the PROGRAM-ID statement - note this can be overcome by using REENTRANT"2"
  • The STICKY-LINKAGE Compiler directive
  • The STICKY-PERFORM Compiler directive

If you are creating a reentrant program, there are also other restrictions you should be aware of:

  • Most file handling verbs need explicit user protection with one of the synchronization primitives discussed earlier. Internally, the file handler is thread-safe; however, within the user program, file records, buffers and status fields are set without the benefit of locking. This can lead to contention and resulting corruption of these fields. You should take measures to protect file handling verbs.
  • Execution of any file operation is serialized within the file-handler with a global file-handling mutex. This means that only one thread can access any file at a given time. This could lead to problems if a read from a file is delayed for some reason; for example, because of a record lock. In this case, no other thread can perform any file handling operations until the delayed read is finished.
  • Execution of any sort operations is serialized within the sort handler with the global file-handling mutex. While a sort is occurring no other thread can perform other sort or file handling operations. Execution of the INPUT and OUTPUT procedures occur in the thread that started the sort operation. File handling within these procedures executes normally.
  • Execution of the DISPLAY verb requires user protection with one of the synchronization primitives. Internally, the console display handler is thread-safe; however, each complex display is broken down into multiple calls to the display handler. This can lead to interleaved displays of data items. In general, it is best to assign only one thread to console I/O within a multi-threaded application.
  • Nested programs cannot be the starting point of a newly created thread. Only ENTRY points, outermost programs in a compilation unit and other-language external entry points can be the starting point for thread creation.
  • Execution of the ACCEPT verb is serialized within the accept handler. This means that all other threads are prevented from doing any ACCEPT or DISPLAY operations while the original ACCEPT is outstanding.

The following performance and resource penalties are incurred in reentrant COBOL programs within a multi-threaded application:

  • Use of the THREAD-LOCAL-STORAGE section can incur significant program entry costs. If possible, use LOCAL-STORAGE instead for thread-local work variables. Program entry overhead can be minimized by the use of CALL speed optimizations.
  • A reentrant program consumes more stack space than either a standard or a serialized COBOL program. This is because system work-areas must be allocated on the stack, instead of statically.
Parent topic: Writing Multi-threaded Applications


Multi-threading Library Routines

Call-by-name library routines provide a programming interface through which you can implement and control multi-threading in your applications. While many facilities of multi-threading are accessible through the COBOL syntax, all facilities are also accessible through COBOL run-time library routines. The run-time library routines also offer advanced multi-threading programming capabilities that are unavailable through the COBOL syntax.

  • Thread-control Routines
  • Thread-synchronization Routines
  • Routines for Handling Thread-specific Data
  • Initializing Applications
Parent topic: Writing Multi-threaded Applications


Thread-control Routines

The library routines for controlling threads can be used to implement threads that wait for another thread to terminate and then pick up a return value.

You should terminate any thread created using these library routines by one of the following methods:

  • Exit using STOP RUN
  • Exit using CBL_THREAD_EXIT
  • Be killed by CBL_THREAD_KILL
  • Return from the original entry point

A thread might not have been created by the thread-control routines. However, such a thread might still be known to the run-time system by the thread's use of run-time system services. Such a thread can be accessed via the thread-control library routines; it can use:

  • The CBL_THREAD_LIST_START, CBL_THREAD_LIST_NEXT, and CBL_THREAD_LIST_END routines. The thread will also show up in the lists provided by these routines.
  • The CBL_THREAD_IDDATA_ALLOC and CBL_THREAD_IDDATA_GET routines.
  • The CBL_THREAD_SELF routine to get information on itself.
  • The CBL_THREAD_SUSPEND and CBL_THREAD_RESUME routine. For managed applications using the .NET Framework, these routines are deprecated. See Multi-threading in the .NET Framework.
  • The CBL_THREAD_DETACH routine to detach itself while still alive; however this call is effectively a noop. Irrespective of any detach call, the resources of the thread from a program in another language are freed when it finishes using the run-time system and calls cobthreadtidy(). It is illegal for a thread from a program in another language to terminate without first calling cobthreadtidy().

In a mixed-language environment, any thread known to the run-time system from its use of the run-time system, but not created by the run-time system or any of the thread control routines, must do one of the following:

  • Call cobthreadtidy() before terminating. This call informs the run-time system that the thread no longer needs its services and allows it to cleanup its thread-state data. For managed applications using the .NET Framework, this routine is deprecated. See Multi-threading in the .NET Framework.
  • Call cobtidy() to indicate that the COBOL run-time system will not be needed again in this application run.For managed applications using the .NET Framework, this routine is deprecated. See Multi-threading in the .NET Framework.
  • Call cobexit() to terminate the run unit. For managed applications using the .NET Framework, this routine is deprecated. See Multi-threading in the .NET Framework.
  • Not be killed by another thread calling CBL_THREAD_KILL. The user should use the kill mechanism that matches how the thread was created originally.
  • Not be waited on by another thread calling CBL_THREAD_WAIT. The user should use the wait mechanism that matches how the thread was created originally.
  • Not exit by using the routine CBL_THREAD_EXIT. The user should use the termination mechanism that matches how the thread was created originally.

An application can check that the run-time system used by a program supports the thread-control routines by calling either CBL_GET_OS_INFO or CBL_THREAD_SELF.

Example - Checking Which Run-time System a Program Supports

     call "CBL_THREAD_SELF" using thread-id
      on exeception
*       no cbl_thread routines support
     end-call
     if  return-code = 1008
*       running in a single-threaded-only rts
     end-if
Parent topic: Multi-threading Library Routines


Thread-synchronization Routines

This COBOL system provides four types of synchronization object: monitors, semaphores, mutexes, and events. Control of these synchronization objects is provided by COBOL syntax, and also by call-by-name library routines.

Parent topic: Multi-threading Library Routines


Routines for Handling Thread-specific Data

You can create dynamic data whose lifetime is that of the creating thread, or selective or external thread-local data, using the run-time library routine CBL_ALLOC_THREAD_MEM and the library routines CBL_TSTORE_n.

Parent topic: Multi-threading Library Routines


Initializing Applications

The initialization of multi-threaded applications needs some care. First, as good programming practice, the application should determine if it is running with a run-time system that supports multi-threading. See the following example.

Example - Checking the Run-time System

 Working-Storage Section.
 01 thread-id     usage pointer.
 . . .
* Initialization code executed while in single-threaded
* mode to check if the run-time system supports
* multi-threading or the CBL_THREAD_ routines.
     call 'CBL_THREAD_SELF' using thread-id
      on exception
*        No cbl_thread routines support
     end-call
     if return-code = 1008
*        Running in a single-threaded rts
     end-if

This example makes use of the run-time library routine CBL_THREAD_SELF to determine if the run-time system supports multi-threading.

After the application has determined that the run-time system supports multi-threading, all synchronization primitives should be be initialized using the appropriate OPEN syntax. It is easiest to do this as part of the main program, before any other threads are created within the application. However, if this not possible, either because of the way the application is designed, or because of modularity or mixed-language considerations, Micro Focus have provided a single pre-initialized mutex per program. This mutex is accessed using the CBL_THREAD_PROG_LOCK and CBL_THREAD_PROG_UNLOCK run-time library routines. Using these routines, it is possible to ensure that any handles for program -local synchronization primitives are initialized once (and only once) during the execution of the application.

Example - Thread Locking Using Library Routines

The following code illustrates a sample use of these routines for program initialization while running in multi-threaded mode:

 Working-Storage Section.
 01 first-flag         pic x comp-x value 1.
    88 first-time       value 1.
    88 not-first-time   value 0.

* Initialization code executed while in multi-threaded mode.
* Ensures that program local data is initialized properly.

     if first-time then
         call 'CBL_THREAD_PROG_LOCK'
         if first-time then
* Initialize program local data and synchronization objects
               ...
             set not-first-time   to true
         end-if
         call 'CBL_THREAD_PROG_UNLOCK'
     end-if

Note the double checking of the first-time level-88 data item. This is a good optimization technique in multi-threaded applications. The idea of the optimization is to avoid the overhead of locking a mutex if the intended action has already been performed. In this case, if multiple threads enter the program before it is properly initialized, they will all find that first-time is true and so issue a call to CBL_THREAD_PROG_LOCK. However, only one will acquire the lock while first-time is still true. This is the thread that will do the initialization.

After the initialization is completed, and while the initializing thread still owns the lock, the first-time flag is set to false. All successive threads acquiring the lock can see that the initialization has already been done, as first-time is now false, and unlock the program immediately. Any following threads that enter after initialization will also see the first-time flag is false and will not attempt to acquire the program lock (and so reduce program entry overhead).

The flag that specifies whether initialization has occurred should as simple as possible (that is, a single byte data item).

Parent topic: Multi-threading Library Routines


Manipulating Threads

The multi-threaded run-time system supports threads created by the run-time system itself, via the START verb or the CBL_THREAD_n library routines, and also other-language threads created directly by the operating system. Since the COBOL syntax and the CBL_THREAD_n routines are portable, these are the preferred methods of thread manipulation. Furthermore, the CBL_THREAD_n routines can also be called from programs written in other languages, allowing any multi-threaded application to take full advantage of the advanced facilities provided by the run-time system.

  • Thread Handles
  • Creating and Terminating a Thread
  • Canceling a Thread
  • Suspending a Thread
  • Identifying a Thread
  • Threads in Other Languages
Parent topic: Writing Multi-threaded Applications


Thread Handles

In general, threads are identified to the run-time system by thread handles. Thread handles are provided to:

  • The module that creates a thread, as a return value from the START verb, or from the CBL_THREAD_CREATE routine
  • An individual thread by the return value from the CBL_THREAD_SELF routine.

The thread handle uniquely identifies the thread to the various multi-threading COBOL verbs or to CBL_THREAD_n routines. With reasonable care, thread handles can be used by any of the active threads in the run-unit, not just the creator of a thread. It is important to remember that the lifetime of a thread and that of its thread handle might not be the same. Depending on how a thread was created and what operations have been done on it, a thread handle could still be valid even if the thread has terminated. In order to enable the system to recover the resources associated with the handle, it is up to the user to explicitly detach the handle for a thread.

A handle can become detached from its thread in one of several ways. When a thread is created with the START verb or CBL_THREAD_CREATE routine, its handle is, by default, created as detached. When another-language thread becomes known to the run-time system, its handle is automatically and always created as detached. A non-detached handle can be detached with a call to CBL_THREAD_DETACH. In any case, a detached handle must always be used with care, as when the thread terminates the handle immediately becomes invalid. If a thread with a non-detached handle has already terminated, then a call to CBL_THREAD_DETACH with that thread handle will immediately cause the handle to become invalid.

A non-detached handle is useful for retrieval of return values (via the WAIT verb or CBL_THREAD_WAIT routine), and for inspection of thread identification data (via the CBL_THREAD_IDDATA_GET routine) after a thread has potentially terminated. The START verb provides a way of identifying a newly created thread by returning a non-detached thread handle. The CBL_THREAD_CREATE routine provides a flag to indicate that the thread should be created and a non-detached handle returned.

Parent topic: Manipulating Threads


Creating and Terminating a Thread

Threads are either created by one of the following methods:

  • START verb
  • CBL_THREAD_CREATE routine
  • Specific operating system call for thread creation

Threads created by the first two methods are called COBOL threads. Threads created directly by the operating system are called other-language threads.

As the creation and manipulation of COBOL threads is portable, and the preferred method, we will only deal with them here.

The starting point for a thread must be either a non-nested Program-Id, a COBOL entry-point or an externally visible routine written in another language, such as C. It must not be a nested program, or a section or paragraph name.

The name of the starting point can be specified as a text string. The overhead in using a text string to find the entry point is equivalent to resolving the verb CALL identifier. It is possible to avoid this overhead by using a procedure pointer as the object of a START verb.

The starting point for every created thread is provided with only one parameter. If the BY CONTENT phrase is used in passing this parameter, a copy of it is made by the system before the thread is created, leaving the calling thread free to modify the original parameter upon return from the START verb.

Creation of a thread with a non-detached handle (via the IDENTIFIED BY clause) enables the return value to be obtained later by the WAIT verb. After the WAIT verb has completed the specified thread handle becomes invalid and all resources associated with the subject thread are released.

A STOP RUN RETURNING statement in the created thread does not end the run unit; it simply provides a return value and terminates the thread. It is equivalent to:

call 'CBL_THREAD_EXIT' using by value address of thread-parm.

A STOP RUN statement in other-language threads or in the main thread of a run unit not created by CBL_THREAD_CREATE will wait for all active COBOL threads to finish and then terminate the run unit.

Return values from threads are always pointers. This allows you to return both simple and complex data structures.

A thread can terminate itself with STOP RUN or a call to CBL_THREAD_EXIT. A thread also terminates normally when the starting point program exits via EXIT PROGRAM or GOBACK. It is also sometimes useful for another thread to cause a COBOL thread to be terminated. The CBL_THREAD_KILL routine achieves this.

Example - Creating and Terminating a Thread

$set reentrant

 Data Division.
 Working-Storage Section.
 01 thread-handle           usage pointer.
 01 thread-return           usage pointer.

 Linkage Section.
 01 thread-parm             picture x(32).
 01 thread-return-record    picture x(32).
 Procedure Division.
*> Starting point
     call 'CBL_THREAD_CREATE'
           using    'CREATED ' *> Note the space before the second single-quotation-mark
                    'This is a 32 character parameter'
           by value 0  *> Optional parameter size
                    1  *> Flag to create non-detached
                    0  *> Default priority
                    0  *> Default stack
           by reference thread-handle
     if return-code = 0
         call 'CBL_THREAD_WAIT' using
                             by value thread-handle
                             by reference thread-return
         set address of thread-return-record
                                          to thread-return
         display thread-return-record
     end-if
     stop run.

 Entry "CREATED" using thread-parm.
     display thread-parm
     stop run returning address of thread-parm.

This application simply creates a thread with the starting point CREATED. The thread displays its parameter and returns the address of that parameter for use in the parent thread. The STOP RUN RETURNING in the CREATED thread does not end the run unit, instead it simply provides a return value and terminates the thread. It is equivalent to:

call 'CBL_THREAD_EXIT' using by value address of thread-parm.
Parent topic: Manipulating Threads


Canceling a Thread

Threads created with CBL_THREAD_CREATE can be canceled with the CBL_THREAD_KILL routine. You cannot use CBL_THREAD_KILL to kill threads created in other ways. This call causes immediate, abnormal termination of a COBOL thread but, in general, it should not be used as part of general application thread control. The main reason for this is that some user and system synchronization resources will not be properly unlocked and/or freed when the thread terminates. This can affect the synchronization within the user application and the run-time system, which can cause serious problems with the application.

CBL_THREAD_KILL can reasonably be used within a critical error handler in the main thread. In this error handler, thread handles can be acquired by way of the CBL_THREAD_LIST_n routines, all threads can be canceled and the application can then exit via STOP RUN. This is less dangerous than the random use of CBL_THREAD_KILL as it minimizes the chance of needing a locked synchronization primitive but there is still a possibility of file corruption or deadlock during run-unit termination.

In any case, most applications should avoid using CBL_THREAD_KILL. This can be achieved by creating thread identification data (through the CBL_THREAD_IDDATA_ALLOC routine) that has a terminate flag in it. That data can then be polled in each thread at a level where no locks are held. If the terminate flag is set, then the polling thread can exit gracefully.

Example - Creating Thread Identification Data and Terminate Flags

      ******************** MAINPROG.CBL ********************
       identification division.
       program-id. mainprog.

       Data Division.
       Local-Storage Section.
       01  ret-ptr                 usage pointer.
       01  iddata-ptr              usage pointer.
       01  sub-iddata-ptr          usage pointer.
       01  sub-handle              usage thread-pointer.
       Linkage Section.
       01  iddata-record.
           05  iddata-name         pic x(20).
           05  iddata-term         pic x comp-x value 0.

       Procedure Division.

      * Establish identification data - don't provide
      * initialization data when it is allocated, instead
      * initialize it after the pointer is retrieved.

           call 'CBL_THREAD_IDDATA_ALLOC' using
                                      by value zero
                                  length of iddata-record
           call 'CBL_THREAD_IDDATA_GET'   using iddata-ptr
                                                omitted
           set address of iddata-record to iddata-ptr
           move 'main' to iddata-name

      * Create sub-thread

      * Starting point
           call 'CBL_THREAD_CREATE' using
                                 'SUBPROG '
                        by value 0   *> No parameters
                                 0   *> Optional - parameter size
                                 0   *> Flag to create detached
                                 0   *> Default priority
                                 0   *> Default stack
                    by reference sub-handle
           if  return-code not = 0
               display 'unable to create thread'
               stop run
           end-if

      * Wait until child creates its iddata and then flag
      * termination

           set sub-iddata-ptr to NULL
           perform until 1 = 0
               call 'CBL_THREAD_IDDATA_GET'
                      using    sub-iddata-ptr
                      by value sub-handle
               end-call
               if  sub-iddata-ptr not = null
                   exit perform
               end-if
               call 'CBL_THREAD_YIELD'
           end-perform
           set address of iddata-record to sub-iddata-ptr
           move "stop" to iddata-name
           move 1 to iddata-term

      * Wait till the child exits
           wait for sub-handle

           display 'All synchronization is complete on ' &
                   'RTS termination'
           stop run.
       end program mainprog.

      *************** SUBPROG.CBL  ********************************
       identification division.
       program-id. subprog.

       Data Division.
       Working-Storage Section.
       01 sub-iddata.
          05  sub-name             pic x(20) value 'sub'.
          05  sub-term             pic x comp-x value 0.
       Local-Storage Section.
       01  iddata-ptr              usage pointer.
       01  thread-handle           usage pointer.
       01  thread-state            pic x(4) comp-x.
       01  parent-handle           usage pointer.
       Linkage Section.
       01  iddata-record.
           05  iddata-name         pic x(20).
           05  iddata-term         pic x comp-x value 0.
       Procedure Division.

      * Establish identification data - provide initialization data
           call 'CBL_THREAD_IDDATA_ALLOC' using
                                        sub-iddata
                               by value length of sub-iddata

      * Find our parent thread and resume him
      *
           call 'CBL_THREAD_LIST_START' using thread-handle
                                              thread-state
                                              iddata-ptr
           set parent-handle to NULL
           perform until thread-handle = null
                      or return-code not = 0
               if iddata-ptr not = null
                   set address of iddata-record to iddata-ptr
                   if  iddata-name = 'main'
                       set parent-handle to thread-handle
                       exit perform
                   end-if
               end-if
               call 'CBL_THREAD_LIST_NEXT' using thread-handle
                                                 thread-state
                                                 iddata-ptr
           end-perform
           call 'CBL_THREAD_LIST_END'
           if  parent-handle = NULL
               display 'synchronization error'
               stop run
           end-if
           call 'CBL_THREAD_IDDATA_GET'   using iddata-ptr
                                                omitted
           set address of iddata-record to iddata-ptr
           perform until iddata-term = 1
               call 'CBL_THREAD_YIELD'
           end-perform
           exit program.
       end program subprog.

This rather lengthy example doesn't actually do anything but establish handshaking for thread and application termination. Before going into any discussion on it, it is worth noting that this kind of handshaking could have been accomplished more easily by passing the main thread's handle into the child as a parameter. This would have avoided the need to rely on identification data or to step through the thread list.

Consider the following points about the example application:

  • Thread identification data is created in two ways:
    • In the parent thread, data is created uninitialized; the thread then retrieves the iddata pointer and initializes the area of memory that was allocated.
    • The child thread provides initialization data to eliminate any possible execution window between iddata allocation and iddata initialization by the application.

    The method you use in your application depends on what level of contention you expect on identification data.

  • The loop in the parent thread waits for the child to create its thread identification data; the loop in the child thread waits for the parent to flag termination. The call to CBL_THREAD_YIELD prevents these loops from being hard busy waits, but would have been better coded using an event or condition synchronization object.
  • The use of CBL_THREAD_LIST, which enables a thread to step through all threads known to the run-time system, obtaining the thread handle, thread state and identification data pointer. The example relies only on the handle and identification data pointer but the state information can also be useful, as it lets the calling thread know if the subject thread is detached, suspended or an other-language thread.

    If a thread uses the CBL_THREAD_LIST routine:

    • That thread is limited in which other CBL_THREAD_n routines it can use
    • Other threads cannot use any CBL_THREAD_n routines, and the use of some other library routines is restricted

    For this reason you should:

    • Mimimize the amount of code executed while stepping the list
    • Avoid file or user I/O while the list is locked

    These restrictions are removed only after stepping is terminated by a call to CBL_THREAD_LIST_END.

Parent topic: Manipulating Threads


Suspending a Thread

In many multi-threaded applications it is not uncommon for a thread to 'run out of work' but not need to terminate just yet. In a client-server architecture, for example, the main service thread could be polling an input queue for requests and if it finds none then it makes sense to allow another process or thread to have the CPU before polling the input queue again. This is simply done by calling CBL_THREAD_YIELD which yields the processor to some other thread in the application (or some other thread in another process, depending on the operating system).

Another possibility is that a thread needs to yield the CPU indefinitely and obtain it only when some sort of event has definitely happened. CBL_THREAD_SUSPEND allows suspension of the calling thread until some other thread does a CBL_THREAD_RESUME using the thread handle for the suspended thread. A thread can call CBL_THREAD_RESUME one or more times before the targeted thread suspends itself and, in this case, the call to CBL_THREAD_SUSPEND returns to the calling thread immediately and does not give up ownership of the CPU. This operation is very similar to that of a counting semaphore; in fact, the Producer-Consumer problem can be solved using only the CBL_THREAD_SUSPEND and CBL_THREAD_RESUME routines.

CAUTION:
For managed applications in the .NET Framework, Microsoft mandates that you "do not use the System.Threading.Thread.Suspend and System.Threading.Thread.Resume methods to synchronize the activities of threads. You have no way of knowing what code a thread is executing when you suspend it. If you suspend a thread while it holds locks during a security permission evaluation, other threads in the System.AppDomain might be blocked. If you suspend a thread while it is executing a class constructor, other threads in the System.AppDomain that attempt to use that class are blocked. Deadlocks can occur very easily."

You can use the Compiler directive WARNINGS(2) to issue warnings when suspend and resume are being used.

Parent topic: Manipulating Threads


Identifying a Thread

It is sometimes useful for a thread to distinguish itself from any other created threads in an application. For example, if two threads in a four thread application establish a producer-consumer relationship, it can be useful for the two cooperating threads to find out what each other's thread handles are. Once these handles are obtained, all synchronization can be done using only the CBL_THREAD_SUSPEND and CBL_THREAD_RESUME calls. If each thread in the application creates a name for itself (and the name relates to its functionality) and associates the name with its thread handle, then the cooperating threads can scan the thread name list and find each other's handle.

Another possible use for associating globally accessible data to each thread and its handle is to hold a termination flag, obviating the possible need to use CBL_THREAD_KILL. Each thread in the application can poll its termination flag to check for a termination request. The terminating thread can then make sure no locks are held and no synchronization actions are required before terminating normally.

Globally accessible data for a thread is associated with the thread handle by the CBL_THREAD_IDDATA_ALLOC routine executed within the thread. This data is retrieved by the CBL_THREAD_IDDATA_GET routine, if the thread handle is already known, or by the CBL_THREAD_LIST_n routines if the thread handle is not yet known.

Example - Associating Globally Accessible Data With a Thread Handle

The following example shows how to associate globally accessible data with the thread handle by using the CBL_THREAD_IDDATA_ALLOC call executed within the thread. The data is retrieved by the CBL_THREAD_IDDATA_GET call, if the thread handle is already known, or by the CBL_THREAD_LIST_n routines if the thread handle is not yet known.

      *************** MAINPROG.CBL ************************
       identification division.
       program-id. mainprog.

       Data Division.
       Local-Storage Section.
       01 ret-wait         usage pointer.
       01 iddata-ptr       usage pointer.
       01 sub-iddata-ptr   usage pointer.
       01 sub-handle       usage thread-pointer.
       Linkage Section.
        01 iddata-record.
           05 iddata-name  pic x(20).
         05 iddata-term    pic x comp-x value 0.

       Procedure Division.

      * Establish identification data - don't provide
      * initialization data when it is allocated, instead
      * initialize it after the pointer is retrieved.

           call 'CBL_THREAD_IDDATA_ALLOC' using
                                          by value zero
                                          length of iddata-record
           call 'CBL_THREAD_IDDATA_GET'   using iddata-ptr
                                                omitted
           set address of iddata-record to iddata-ptr
           move 'main' to iddata-name

      * Create sub-thread

           start 'SUBPROG '  identified by sub-handle

      * Wait until child creates its iddata and then flag
      * termination

           set sub-iddata-ptr to NULL
           perform until 1 = 0
               call 'CBL_THREAD_IDDATA_GET' using sub-iddata-ptr
                                            by value sub-handle
               if sub-iddata-ptr not = null
                   exit perform
               end-if
               call 'CBL_THREAD_YIELD'
           end-perform
           set address of iddata-record to sub-iddata-ptr
           move 1 to iddata-term

      * Wait until the child ends
           wait for sub-handle   *> clear up thread's resources

           display 'All synchronization is complete on ' &
                   'RTS termination'
           stop run.
       end program mainprog.

      *************** SUBPROG.CBL ************************

       identification division.
       program-id. subprog.

       Data Division.
       Working-Storage Section.
       01 sub-iddata.
          05 sub-name	          pic x(20) value 'sub'.
          05 sub-term	          pic x comp-x value 0.
       Local-Storage Section.
       01 iddata-ptr            usage pointer.
       01 thread-handle         usage pointer.
       01 thread-state          pic x(4) comp-x.
       01 parent-handle         usage pointer.
       Linkage Section.
       01 iddata-record.
          05 iddata-name        pic x(20).
          05 iddata-term        pic x comp-x value 0.
       Procedure Division.

      * Establish identification data - provide
      * initialization data
           call 'CBL_THREAD_IDDATA_ALLOC'
                                using sub-iddata
                                by value length of sub-iddata

      * Find our parent thread and resume him

           call 'CBL_THREAD_LIST_START'
                             using thread-handle
                                   thread-state
                                   iddata-ptr
           set parent-handle to NULL
           perform until thread-handle = null
                      or return-code not = 0
               if iddata-ptr not = null
                   set address of iddata-record  to iddata-ptr
                   if iddata-name = 'main'
                       set parent-handle to thread-handle
                       exit perform
                  end-if
               end-if
               call 'CBL_THREAD_LIST_NEXT' using thread-handle
                                                 thread-state
                                                 iddata-ptr
           end-perform
           call 'CBL_THREAD_LIST_END'
           if parent-handle = NULL
               display 'synchronization error'
               stop run
           end-if
           call 'CBL_THREAD_IDDATA_GET' using iddata-ptr
                                              omitted
           set address of iddata-record to iddata-ptr
           perform until iddata-term = 1
               call 'CBL_THREAD_YIELD'
           end-perform
           exit program.
       end program subprog.

This example establishes handshaking for thread and application termination. Note that this kind of handshaking could have been accomplished more easily by passing the handle of the main thread into the child as a parameter. This would have avoided the need to rely on identification data or to step through the thread list.

Consider the following points about this example:

  • Thread identification data is created in two ways:
    • In the parent thread, data is created uninitialized; the thread then retrieves the iddata pointer and initializes the area of memory that was allocated.
    • The child thread provides initialization data to eliminate any possible execution window between iddata allocation and iddata initialization by the application.

    The method you use in your application depends on what level of contention you expect on identification data.

  • The loop in the parent thread waits for the child to create its thread identification data; the loop in the child thread waits for the parent to flag termination. The call to CBL_THREAD_YIELD prevents these loops from being hard busy waits, but would have been better coded using an event or condition synchronization object.
  • The use of CBL_THREAD_LIST_n routines, which enable a thread to step through all threads known to the run-time system, obtaining the thread handle, thread state and identification data pointer. The example relies only on the handle and identification data pointer but the state information can also be useful, as it lets the calling thread know if the subject thread is detached, suspended or an other-language thread.

    If a thread uses the CBL_THREAD_LIST_n routines:

    • That thread is limited in which other CBL_THREAD_n routines it can use
    • Other threads cannot use any CBL_THREAD_n routines, and the use of some other library routines is restricted

    For this reason you should:

    • Mimimize the amount of code executed while stepping the list
    • Avoid file or user I/O while the list is locked

    These restrictions are removed only after list stepping is terminated by a call to CBL_THREAD_LIST_END.

Parent topic: Manipulating Threads


Threads in Other Languages

In a mixed language environment, threads created directly by operating system facilities and not by the START verb or the CBL_THREAD_CREATE routine have several restrictions and requirements on them:

  • They must be terminated by the approved operating system method of thread termination and not by any function in the CBL_THREAD_n routines (for example, CBL_THREAD_EXIT or CBL_THREAD_KILL).
  • Their handles are always created detached. This means that they cannot be waited on by the WAIT verb or by the CBL_THREAD_WAIT routine, and no return value is available from them.
  • They must issue the call cobthreadtidy() or cobtidy() when the thread or the application, respectively, no longer needs COBOL run-time system services. This allows the run-time system to free memory and clean up thread-state information. For managed applications using the .NET Framework, these routines are deprecated. See Multi-threading in the .NET Framework.
  • cobtidy(), cobexit() or the COBOL STOP RUN statement will cause the calling thread to be treated as the 'main' thread. As a result, the run-time system will wait for all CBL_THREAD_CREATE threads to terminate before any run-time system cleanup processing is completed. For managed applications using the .NET Framework, these routines are deprecated. See Multi-threading in the .NET Framework.
Note: All the multi-threading functions supported by the run-time system detect handles created by threads in other languages, and reports invalid use of them. It is, however, entirely up to the application to ensure that run-time system resources are freed for any thread that has executed any COBOL or run-time system code in the course of its existence (as detailed above).
Parent topic: Manipulating Threads


Canceling Called Programs

As the CANCEL operation takes a finite time to complete it is possible for a thread to enter the canceled module before the CANCEL operation has finished. You are advised, therefore, not to use the CANCEL statement in multi-threaded applications.

Parent topic: Writing Multi-threaded Applications


Optimizations and Programming Tips

To create optimized and efficient programs, note the following:

  • Always add code to your application that checks whether the application is running under the single-threaded or multi-threaded run-time system.
  • Use the NOREENTRANT and NOSERIAL Compiler directives (the default) wherever possible. This minimizes stack space and call entry overhead but it is up to the programmer to ensure that a program that uses these directives is only active in one thread at a time.
  • The use of the REENTRANT(1) Compiler directive increases stack space usage but does not significantly affect the call speed of the program.
  • The use of the SERIAL program attribute significantly affects the speed of calls but does not affect the stack space requirements of the program.
  • Use the Local-Storage Section to hold thread work variables. While this increases stack space requirements, the allocation of data is very fast.
  • Using the Thread-Local-Storage Section significantly effects call speed. Replacing the Working-Storage Section with the Thread-Local-Storage Section is an easy way to make some applications to be made entirely thread-safe.
  • Use mutexes for simple locking. These are the fastest of the synchronization structures.
  • Use monitors to provide maximum multi-threading in programs that might cause readers and writers based problems.
  • If possible, initialize all synchronization data items while in single-threaded execution. If this is not possible, then use a first time flag which is checked once before a CBL_THREAD_PROG_LOCK and checked again after obtaining the lock.
  • Remember the difference between a thread and a thread handle. Create a non-detached thread only if necessary.
  • Use CBL_THREAD_KILL only if absolutely necessary and if you do use it, terminate the run-unit as soon as possible afterwards. Where possible, use termination polling instead.
  • Use CBL_THREAD_SUSPEND in preference to CBL_THREAD_YIELD. Avoid busy waits.
  • Keep the amount of work done between CBL_THREAD_LIST_START and CBL_THREAD_LIST_END calls to a minimum.
  • In certain circumstances, the application can conserve per thread memory by using the CBL_TSTORE_n routines in preference to the Thread-Local-Storage Section.
  • Try to avoid deadlock rather than attempting to correct it once it has occurred.
  • Avoid nesting read locks on monitors and, if you must, then be aware of the possibility of single thread deadlock.

The Compiler directives available for multi-threaded applications can affect the performance of your multi-threaded and single-threaded applications.

Parent topic: Writing Multi-threaded Applications


Multi-threading in the .NET Framework

Multi-threading is fully supported in managed code under the .NET Framework.

If your application uses Windows forms, you can use the threading support. However if you are using COBOL in a ThreadPool, do not use the threading support. Instead, you should invoke COBOL using the multipel run units. See MicroFocus.COBOL.RuntimeServices.

Note the following with regard to multi-threading in managed code:

  • If your application uses Windows forms, you can use the threading support. However you need to understand ThreadPools to do this. See the ThreadPool class in the .Net Framework Help. An alternative is to invoke COBOL using multiple run units. See MicroFocus.COBOL.RuntimeServices.
  • The CBL_THREAD_SUSPEND and CBL_THREAD_RESUME routines are deprecated in managed code and their use is bound by Microsoft restrictions.
    CAUTION:

    For managed applications in the .NET Framework, the CBL_THREAD_SUSPEND and CBL_THREAD_RESUME routines are provided but are implemented using obsolete APIs (Thread.Suspend/Thread.Resume) and as such their use is bound by restrictions imposed by the .NET Framework.

    Microsoft mandates that you "do not use the System.Threading.Thread.Suspend and System.Threading.Thread.Resume methods to synchronize the activities of threads. You have no way of knowing what code a thread is executing when you suspend it. If you suspend a thread while it holds locks during a security permission evaluation, other threads in the System.AppDomain might be blocked. If you suspend a thread while it is executing a class constructor, other threads in the System.AppDomain that attempt to use that class are blocked. Deadlocks can occur very easily."

    You can use the Compiler directive WARNINGS(2) to issue warnings when suspend and resume are being used.

  • cobthreadtidy(), cobtidy(), and cobexit() routines are are deprecated in managed code. Their work is done automatically.
Parent topic: Writing Multi-threaded Applications


Multi-threading Compiler Directives

Compiler directives you can use with multi-threading programs.

  • Directives for Serial and Reentrant Programs
  • Directives that Optimize Performance
Parent topic: Multi-threaded Programming
Related information
Introduction to Multi-threading
Synchronizing Execution and Resolving Contention
Writing Multi-threaded Applications


Directives for Serial and Reentrant Programs

The following two directives effect the serialization and reentrancy of multi-threaded programs:

  • REENTRANT - Controls reentrancy of a program
  • SERIAL - Controls serialization of a program
Parent topic: Multi-threading Compiler Directives


Directives that Optimize Performance

The following Compiler directives can optimize the performance of multi-threading programs:

  • PARAMCOUNTCHECK - Controls checking of number of entry point parameters
  • FASTCALL - Controls the behavior of a called program

The following directive settings are made by default:

  • PARAMCOUNTCHECK
  • NOFASTCALL
  • NOREENTRANT
  • NOSERIAL

If you want your program to be optimized for speed, set the directives as follows:

  • NOPARAMCOUNTCHECK
  • FASTCALL
  • NOREENTRANT
  • NOSERIAL

However, you might have to change your program to take advantage of these Compiler directives.

Parent topic: Multi-threading Compiler Directives


Problem Determination and Diagnostic Tools

  • Protection Violations
  • FaultFinder
  • Introduction to the Consolidated Tracing Facility
  • Profiler
Parent topic: Programming


Protection Violations

  • Overview - Protection Violations
  • Correcting Protection Violations
  • Debugging Techniques
Parent topic: Problem Determination and Diagnostic Tools


Overview - Protection Violations

Your COBOL development system is thorough in preventing or trapping potentially illegal code. However, it is still possible for your programs to generate code that is illegal in some way, and when this happens the error might be trapped as a general protection violation by the operating system or a COBOL protection violation by this COBOL system.

  • What Are Protection Violations?
  • General Protection Violations
  • COBOL Protection Violations
  • Unflagged Protection Violations
Parent topic: Protection Violations


What Are Protection Violations?

A protection violation occurs when a machine instruction tries to execute and is found to be illegal in the context of the currently running process. This might be because the instruction is not recognized by the processor (as is the case if data is executed as if it were a procedure), or if a valid instruction references a memory location or other resource that is invalid in the context of the currently running process. There are two classes of protection violation, general and COBOL protections violations.

Parent topic: Overview - Protection Violations


General Protection Violations

Operating systems typically allocate only a portion of a computer's resources to each process and monitor each process to see that it does not exceed its allocation. If the operating system detects a process exceeding its allocation, it takes some error action. The action it takes is a general protection violation (also known as an exception) or some other action, depending on the operating system.When the operating system detects a general protection violation, it runs a special program called an exception handler before abandoning the process that caused the exception. The exception handler might be one specifically associated with the program that caused the exception. Alternatively, if there is no specific handler, the operating system runs its own default exception handler.

Parent topic: Overview - Protection Violations
Related information
Correcting Protection Violations


COBOL Protection Violations

Where appropriate, this COBOL system provides facilities to monitor a COBOL application (or non-COBOL program running under the control of the COBOL system) to ensure that it does not exceed the resources allocated to it by the COBOL system. A COBOL protection violation occurs when your COBOL system sees a program behaving in this way. Whether the COBOL system detects a protection violation depends on which resources are monitored, how they are monitored, and how the resources are allocated. The hardware and operating system determine how effectively the COBOL system can monitor COBOL protection violations. A COBOL program might appear to run correctly in one environment, but might fail if available resources change or the operating system changes.

Parent topic: Overview - Protection Violations


Unflagged Protection Violations

Protection violations typically occur when a process tries to access a memory location that lies outside the memory allocated to that process for the type of access it is attempting. Clearly the process miscalculated the location it wants to access.

However, if the same process moves, is rearranged in memory, or grows in size, the memory location might eventually lie in the range of the process. In such a case, the process would not give rise to a protection violation even though we would like it to.

If this is the case, the primary effect is that a statement in the program returns an incorrect result. If the application does not use that result, you will not notice a problem. However, if subsequent execution relies on the value returned by that statement, the program might exhibit unexpected behavior. Possible secondary effects can be split into two categories depending on the memory area that your program modifies:

  • If the memory area lies in an unprotected COBOL system area, the COBOL system might exhibit unexpected behavior, including that resulting from executing data as if it were procedure. This could lead to a general protection violation or infinite loop.
  • If the memory area lies in the program area, the program could produce incorrect results or fail at a later point as a result of a legitimate access to the memory area that had previously been corrupted.
Parent topic: Overview - Protection Violations


Correcting Protection Violations

This section describes some of the common causes of protection violations (and RTS errors associated with COBOL protection violations) and suggests how you can overcome these problems.

  • Errors in Non-COBOL Portions of an Application
  • Parameter Mismatches in a CALL Statement
  • Stack Overflow
  • Illegal Reference Modification
  • Illegal Values for Pointers
  • Subscript Out of Range
  • Incorrect Linking Options or Procedures
Parent topic: Protection Violations


Errors in Non-COBOL Portions of an Application

Because of the success of this COBOL system at detecting COBOL protection violations, it is uncommon for COBOL applications to result in general protection violations. In contrast, other programming languages, such as C, typically make heavy use of pointers which increase the probability of causing general protection violations. If your application fails with a general protection violation and contains a part that is written in a language other than COBOL, we recommend that you closely investigate the part of the application that is not written in COBOL. In most cases, that is where the general protection violation is caused.

Parent topic: Correcting Protection Violations


Parameter Mismatches in a CALL Statement

The CALL statement provides a number of areas where general protection violations can occur if you make a mistake in specifying the call.The following are things you should check if you suspect that a CALL statement might be causing a general protection violation:

  • The number, size, and usage of parameters in the calling program must match those in the called program.
  • The REFERENCE, CONTENT, and VALUE clauses in the calling program must match the definitions of the parameters in the called program.These factors become more difficult to manage when one of the calling or called programs is not COBOL. As a result, protection violations are more likely in such applications. You must ensure that the non-COBOL language conforms with the default calling convention for COBOL, or COBOL conforms to the calling convention of the non-COBOL language (by using the CALL-CONVENTION clause). The effects of a mismatch in the calling interface between two programs can be extremely varied depending on the interaction between the mismatch in question and the calling conventions used.
Parent topic: Correcting Protection Violations


Stack Overflow

A less obvious cause for a general protection violation is stack overflow. The stack is the system area in which called parameters and the calling program return address are temporarily stored for a CALL statement. Stack overflow occurs when the level of nesting of called subprograms, or the size or number of passed parameters is greater than the stack can manage.Stack overflow can occur due to excessive use of the stack, or because the default or requested stack size is small. You should bear in mind that operating system support routines might also make use of the stack and reduce its effective size, and that different versions of the same operating system can make different use of the stack, thus varying its effective size.

Parent topic: Correcting Protection Violations


Illegal Reference Modification

Using reference modification you can easily reference an area of memory that lies outside the named data item. The results of illegal reference modification depend on the location of the area of memory that your program accesses:

  • The area of memory lies outside the data item but still in the program's data area. This does not usually result in a general protection violation.
  • The area of memory lies in the program's procedure area. The operating system might trap a general protection violation.
  • The area of memory lies outside the address range allocated to the program. This COBOL system recognizes this, and produces RTS error 114 ("Attempt to access item beyond bounds of memory").

In the example below, the reference modification results in RTS error 114 ("Attempt to access item beyond bounds of memory") when run. This is caused by setting a to be greater than the maximum length of b. The first use of a reference modified item is a source field, so results in incorrect data being passed into c. This problem is detected by this COBOL system.The second use of a reference modified item is potentially more dangerous, as the reference modified item is a target field. Again, this COBOL system detects this problem and produces RTS error 114 ("Attempt to access item beyond bounds of memory").This example is used in the following sections to illustrate how to debug the program in various environments.

 program-id. "buggy".
 working-storage section.
 01 a pic 9(6).
 procedure division.
     move 999999 to a
     call "bug" using a
     stop run.
 end program "buggy".

 program-id. "bug".
 working-storage section.
 01 b pic x(20).
 01 c pic x.
 linkage section.
 01 a pic 9(6).
 procedure division using a.
     move b(a:1) to c
     move "1" to b(a:1)
 exit program.
Parent topic: Correcting Protection Violations


Illegal Values for Pointers

Data items that you define with usage POINTER or PROCEDURE-POINTER must contain valid addresses when they are used. Using a pointer that does not contain a valid address results in RTS error 114 ("Attempt to access item beyond bounds of memory"), because this COBOL system traps the error that would otherwise result in a general protection violation.

In the example below, data item undefined-pointer is defined as a pointer to a procedure, but is not given a value before it is used. As a result, the CALL statement fails, giving RTS error 114 ("Attempt to access item beyond bounds of memory").

 working-storage section.
 01 undefined-pointer  usage procedure-pointer.
 procedure division.
     call undefined-pointer
 stop run.
Parent topic: Correcting Protection Violations


Subscript Out of Range

The values of subscripts and index items are checked by this COBOL system, with an RTS error 153 ("Subscript out of range") given if they are found to be out of range. However, checking subscripts and index items decreases the performance of your application to some extent. To avoid this decrease in performance you can use the NOBOUND directive to disable such checking. If the NOBOUND directive is used and a subscript or index item is out of range when referencing a table, a protection violation might occur. If you get unexpected results or a protection violation error in an application that has been compiled or generated with the NOBOUND directive, you should recompile the program without the directive and rerun it to determine if the fault is caused by a subscript error.

The following programs show how you could experience unexpected results as a result of inadvertently using an out of range subscript when the NOBOUND directive is specified. Because of the value passed from Bound-main, Build-sub moves "1" to the 21st element of an array that is only 20 elements in size. Because the NOBOUND directive is specified, this COBOL system permits this operation, which overwrites the next data item, c. If the NOBOUND directive was not set, the COBOL system would have given RTS error 153 ("Subscript out of range") when the MOVE was performed.

 program-id. "bound-main".
 working-storage section.
 01 a pic 99.
 procedure division.
     move 21 to a
     call "bound-sub" using a
     stop run.
 end program "bound-main".

$set align(2) nobound
 program-id. "bound-sub".
 working-storage section.
 01 b pic x occurs 20.
 01 c pic xx.
 linkage section.
 01 a pic 99.
     procedure division using a.
     move (1) to b(a)
 exit program.
Parent topic: Correcting Protection Violations


Incorrect Linking Options or Procedures

There are a number of linking options that if used incorrectly might indirectly cause a general protection violation. Problems commonly occur when either the wrong objects or libraries are linked, or the correct objects or libraries are used, but incorrect versions of them. If you suspect that this might be the case, you should check that old versions of objects or libraries have not been left in search paths and that new versions have been installed correctly.

Parent topic: Correcting Protection Violations


Debugging Techniques

This section describes the techniques you use to debug an application when you encounter a protection violation or an RTS error.

The techniques you use to debug a program depend on how the program is loaded or built. For example, if a program is built as an operating system executable file (such as an .exe file or a .dll file) the operating system loads the program and uses special privileges to partition memory for different usages and trap inappropriate references. For example it might split data and procedures and trap attempts to execute data or write over procedure code. In general, the run-time system cannot use the operating system's special privileges to load the COBOL program into protected areas. Instead, where appropriate, the COBOL system sets up its own COBOL traps in conjunction with the operating system general protection violation traps.

Parent topic: Protection Violations
Related information
Correcting Protection Violations


FaultFinder

FaultFinder is an aid to debugging production applications. It enables you to obtain a text-based report on the state of an application at the time of any abnormal application termination. The report is a snapshot of the application at the time of failure and identifies items such as open files, file buffers, loaded programs, and so on.

  • FaultFinder Tunables
    FaultFinder is controlled by tunables.
  • FaultFinder Report
    The FaultFinder report shows the state of an application at the time of any abnormal application termination
  • FaultFinder Listing Generator
    To help you analyze a FaultFinder report, you can take a snapshot of a program's source code, and its compiled characteristics, before shipping the program to your end-users.
Parent topic: Problem Determination and Diagnostic Tools


FaultFinder Tunables

FaultFinder is controlled by tunables.

To turn on FaultFinder set the run-time tunable faultfind_level to a positive value. Then, if the application terminates abnormally, the run-time-system automatically invokes FaultFinder which in turn generates the report.

The following run-time tunables control the operation and output of FaultFinder:

faultfind_config=n Controls the inclusion of program memory data in the output file, where value indicates the action to perform and the type of memory as follows:

0 = Include all types of memory (default)

1 = Exclude working storage

2 = Exclude thread-local storage

4 = Exclude dynamically allocated memory

These values can be combined to suppress combinations of types of memory, for example, a value of 5 will exclude working storage and dynamically allocated memory.

faultfind_level=n | Turns on FaultFinder and enables tracing of events. n can be any positive value less than or equal to 1024 and enables the last n events to be dumped. The default value is 0.
faultfind_outfile="filename" The file to which the analysis is written. The default filename is fltfnd.out in the current working directory. If, for some reason, the specified file cannot be opened, output is directed to the screen.

You can specify the filename as follows:

"fault%option.log"

Where option can be:

d = replaced with the date of the fault in the format <yyyymmdd>

p = replaced with the process ID of the faulting process

t = replaced with the time of the fault in the format <hhmmss>

faultfind_recsize="record_size" | A numerecord_sizeric value, in bytes, that specifies the amount of extra data that is to be kept for each trace operation. record_size can be any non-negative value less than or equal to 1024. The default value is 64.

Example:

set faultfind_config=5
set faultfind_level=5
set faultfind_outfile="applflt.log"
set faultfind_recsize=1024

FaultFinder Performance

Enabling FaultFinder event tracing (that is, setting faultfind_level to a value greater than 0) does have a performance impact, although it should not be noticeable in most cases. The number of events traced does not significantly impact performance; tracing one event is not significantly faster than tracing 1000. The most expensive operations to trace are file operations; the worst case for FaultFinder is a file handling benchmark. Even if this is the case, you would expect no more than a 5% performance degradation. Most applications which perform a mixture of operations should see minimal impact on performance.

FaultFinder Listing Generator

To help you analyze a FaultFinder report, you can take a snapshot of a program's source code, and its compiled characteristics, before shipping the program to your end users. You can create a snapshot using the FaultFinder Listing Generator.

Parent topic: FaultFinder
Related reference
faultfind_config
faultfind_level
faultfind_outfile
faultfind_recsize
Related information
FaultFinder Report
FaultFinder Listing Generator


FaultFinder Report

The FaultFinder report shows the state of an application at the time of any abnormal application termination

This information is contained in titled sections in the report. You can search for sections in the report by their titles.

For threaded programs (run with the multi-threading run-time system), additional information is output; this is discussed in the relevant sections.

Note:
  • On most systems only one process can have debug control over a target. If your target process is already being debugged by the Debugger, you might not be able to obtain a FaultFinder report.
  • It takes a finite amount of time to obtain the information used by FaultFinder. During this time, the target process is stopped and unable to respond to any user input.
  • FaultFinder Report - Environment
  • FaultFinder Report - Call Stack
  • FaultFinder Report - Loaded Programs
  • FaultFinder Report - Logically Canceled Programs
  • FaultFinder Report - Open Files
  • FaultFinder Report - Trace Back
Parent topic: FaultFinder
Related information
FaultFinder


FaultFinder Report - Environment

The Environment section of the report describes:

  • The application command line
  • The run-time system error (both number and message) that caused the problem
  • The date and time at which the dump was taken
  • For threaded applications, the identifier of the failing thread
  • The settings of all current environment variables
  • The settings of all the run-time tunables
Parent topic: FaultFinder Report


FaultFinder Report - Call Stack

The Call Stack section of the report contains, for each thread running at the time of failure, a call stack traceback. Programs are listed with full pathname and extension (where available). Entry points are not listed. The information for each thread is listed in a reverse calling hierarchy, so that:

  • The last program running (the program executing at time of termination) is listed first
  • Any programs that called the program that terminated, and any programs that called these programs are then listed
  • Finally, the initial program in the call hierarchy is listed

If the program contains Local-Storage and/or Linkage Sections, these sections are dumped with the corresponding call stack instance. For these sections, the following information is dumped:

  • Local-storage. The starting address is given followed by the contents. This information is dumped in hexadecimal and ASCII. Duplicate lines are not repeated but replaced by a single asterisk (*).
  • Linkage:
    • Addresses of Using parameters (in USING order)
    • Addresses of Linkage pointers (in Linkage Section order)

For .int files, the current program-counter is also dumped.

Parent topic: FaultFinder Report


FaultFinder Report - Loaded Programs

The Loaded Programs section of the report contains all currently loaded ("live") programs, with their reentrant and non-reentrant data areas. The non-reentrant data area has separate areas for working-storage and each instance of user-allocated data (using CBL_ALLOC_MEM, flag=0). A separate reentrant data area exists for each thread executing that program and has separate areas for thread-local storage and thread-local allocated data (using CBL_ALLOC_MEM, flag=8). Each chunk of data states the hexadecimal address of the data item and the dump (in hexadecimal and ASCII with duplicate lines not repeated but replaced by a single vertical bar (|)) of the data.

Note: The working-storage section includes all of the non-user program specific data areas, as in the file-control and file sections, as well as system needed non-reentrant space. To better define the start of the program's actual working-storage section, it is recommended that you insert a special data item as the first item in working-storage and give it a value that can easily be searched for.
Parent topic: FaultFinder Report


FaultFinder Report - Logically Canceled Programs

This section of the report contains a list of logically canceled programs, with full pathname and filename extensions.

Files that have been logically canceled are still known to the run-time system, so can be loaded and run directly without having to be loaded from disk. Files that are physically canceled release all their memory and no longer exist to the run-time system.

No other information is available in this section of the report.

Parent topic: FaultFinder Report


FaultFinder Report - Open Files

This section of the report contains information about all opened files, both local (non-external) and externally opened files. For each file the information listed is:

  • The filename
  • The exit status of a file operation
  • The record length
  • The organization
  • The open mode
  • For local files, which program it was opened by
  • The last record
  • The file control descriptor
  • The last operations performed on this file

The entire last record and the file control descriptor (FCD) are both dumped (with address) in hexadecimal and ASCII.

The operation trace records the basic operation (READ, WRITE, OPEN and so on) as well as the:

  • Exact operation code
  • Return status for that operation
  • Thread performing the operation
  • Dump of record data for the file operation

The last two items are only recorded when applicable.

Parent topic: FaultFinder Report


FaultFinder Report - Trace Back

The Trace Back section of the report lists the last n events for each thread, where n is defined by the run-time tunable faultfind_level. For each thread, the operations traced are:

  • CBL_ALLOC_MEM
  • CBL_ALLOC_DYN_MEM
  • CBL_ALLOC_SHMEM
  • CBL_ALLOC_THREAD_MEM
  • All file operations.

This section is broken down by thread; it records all operations for thread 1, followed by all operations recorded for thread 2, and so on. There are typically two events per operation: one as the operation begins, and another as it finishes.

Parent topic: FaultFinder Report


FaultFinder Listing Generator

To help you analyze a FaultFinder report, you can take a snapshot of a program's source code, and its compiled characteristics, before shipping the program to your end-users.
  • Using the FaultFinder Listing Generator
  • The FaultFinder Source Listing
Parent topic: FaultFinder


Using the FaultFinder Listing Generator

You can create a snapshot using the FaultFinder Listing Generator, which provides information in the form of a detailed listing file.

To create a listing file:

  1. Compile the program for debug
  2. Run the fflst command

To run the FaultFinder Listing Generator, use the command:

fflst options filename [listfile]

where the parameters are:

options
Specifies the level of detail in the FaultFinder listing. options can be any combination of:

If you specify no options, the Listing Generator produces the full source, data map, procedure map and cross-reference listing. For details of these listings, see below.

s | Suppresses the source listing
d | Suppresses the data map listing
-p | Suppresses the procedure map listing
-x | Suppresses the cross reference listing
-ln | Specifies a page size of n lines. The default is 66 lines
-v | Verbose output with version information
filename
The name of the .idy file to be processed. You do not have to specify the .idy file extension as this is the default file type.
listfile
The name of the file to which the listing is saved. If you do not specify this parameter, the listing is directed to the screen.
Note: The FaultFinder Listing Generator always uses the .idy file, not the COBOL source file.

For example, if you have a program appsource.cbl, the following command generates a full listing minus any cross-reference information in the listing file appsource.ffl:

cobol appsource.cbl anim;
fflst -x appsource.idy appsource.ffl
Parent topic: FaultFinder Listing Generator


The FaultFinder Source Listing

The FaultFinder listing is composed of several parts.

The examples of output in the topics describing these parts were generated using the following program:

 program-id. 'funbar'.
 working-storage section.
 01 ws-var-1    pic x(255).

 thread-local-storage section.
 01 tls-var-1   pic x(1021).

 local-storage section.
 01 ls-var-1    pic x(511).

 linkage section.
 01 lnks-var-1  pic x(2011).
 01 lnks-var-1r pic a(1024) redefines lnks-var-1.
 01 lnks-var-2  pic x(3096).

 procedure division using lnks-var-1 lnks-var-2.
     move tls-var-1 to ws-var-1
     if ws-var-1 = lnks-var-1
         display ls-var-1
     end-if
     stop run.

This program was compiled to generated code, and the FaultFinder listing generated using the commands:

cobol fun.cbl;
cbllink fun.obj
fflst –l19 fun.idy fun.lst
  • FaultFinder Source Listing - Header
  • FaultFinder Source Listing - Source
  • FaultFinder Source Listing - Map
  • FaultFinder Source Listing - Xref
Parent topic: FaultFinder Listing Generator


FaultFinder Source Listing - Header

The header to the listing provides useful information on the compilation of the program. An example header appears below, with additional notes describing the information presented below:

* * * * * * * * * * * * * COMPILATION SUMMARY * * * * * * * * * * *

        Micro Focus Net Express        V1.1 revision 000

        Product ID   : HXCTG/AA0/00000
        Compiler ref : GNR-071060000AD

        Date compiled: 05-Oct-99
        Time Compiled: 18:20

        Source File: fun.cbl
        .idy File  : fun.id   y
        Program ID : funbar
        Compiled to: Gnt/object with xref information

- - - - - - - - - - - - - - - - Sizes  - - - - - - - - - - - - - - -

 INT Code Proc:   000059  Data: 0001C4  Local: 000200 Thread: 0003FE
 GNT Code User:   000178  Full:   0002C8

- - - - - - - - - - - - -  02 Linkage Item(s) - - - - - - - - - - - -

 LNKS-VAR-1                 :   2011 bytes (h"000007DB")
 LNKS-VAR-1R                :   1024 bytes (h"00000400") (redef)
 LNKS-VAR-2                 :   3096 bytes (h"00000C18")

- - - - - - - - - - - -  Key Compilation Directives - - - - - - - - -

 noP64 INTLEVEL(3) noREENTRANT  CHARSET(ASCII)
 MF    noOSVS      noVSC2       CHECKDIV        PERFORM-TYPE(MF)
 noBOUND         TRUNC(ANSI)
 noSPZERO        noIBMCOMP

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Information section

The first section of the listing provides information on the Compiler and the sources compiled. For the Compiler, the product name, product version, product ID and compiler reference number are given. These values are often useful to Micro Focus support representatives. For the source code, the files compiled, the resulting .idy file, the main entry point of the program and target mode of the compilation are given.

Sizes

The Sizes section of the report shows the sizes of the various segments defined in the program, in particular:

  • Intermediate code created during the syntax-check phase
  • Machine code generated during the generate phase
  • The Working-Storage Section, Local-Storage Section and the Thread-Local-Storage Section.

In the example listing above:

  • The syntax-check phase generated h"59" bytes of intermediate code
  • The generate phase created h"178" bytes of machine code as a result of user application code, and h"2C8" bytes of machine code in total
  • The Working-Storage Section is h"1C4" bytes long
  • The Local-Storage Section is h"200" bytes long
  • The Thread-Local-Storage Section is h"3FE" bytes long

Linkage items

The Linkage Item(s) section of the report lists the Linkage Section data items defined in this program, and their sizes. As these sizes are significant in interprogram communication, they warrant their own section. In the example above, the item LNKS-VAR-1R is a redefinition of LNKS-VAR-1, so there are effectively only two distinct linkage items.

Key Compilation Directives

The Key Compilation Directives section of the report lists the Compiler directives that affect run-time behavior.

Parent topic: The FaultFinder Source Listing


FaultFinder Source Listing - Source

There are two kinds of source listings that appear in the output, the Data Division listing and Procedure Division listing.

Data Division Listing

The Data Division listing looks like this:

fun.cbl, line 1
Line    Loc   :Size  ----+-*A-1-B--+----2----+----3----+----4----+---...-8
000001                        program-id. 'funbar'.
000002                        working-storage section.
000003  000050:0000FF         01 ws-var-1     pic x(255).
000004  000005                thread-local-storage section.
000006  000000:0003FD         01  tls-var-1   pic x(1021).
000007  000008                local-storage section.
000009  000000:0001FF         01  ls-var-1    pic x(511).
000010  000011                linkage section.
000012  000000:0007DB         01  lnks-var-1  pic x(2011).
000013  000000:000400         01  lnks-var-1r pic a(1024) redefines lnks-var-1.
000014  000000:000C18         01  lnks-var-2  pic x(3096).
000015  000016               procedure division using lnks-var-1 lnks-var-2.

The listing contains a page header, not shown in the example above, that gives product and compilation information. This is followed by the name of the source module that the first line of page originates from and its sequence number relative to that module. For example, the first line of page 1 in the example source listing originates from the module fun.cbl and is line 1 in that module.

After the line showing the module is a column scale; this indicates the COBOL areas of the source line (that is, Area A, Area B, and so on). In the example above, this scale is compressed to allow notations. In this scale line, there is also a header for the sequence line of the source lines being displayed.

Following the column scale is the Data Division code. The first 80 characters of each source line that was compiled are displayed in the body of the source listing. If a source line exceeds 80 characters, the excess characters are not shown.

The header indicates that the location (Loc) and size (Size) of each data item definition is displayed (in hexadecimal) immediately before the actual source line that defines the data item. For example, on line 3, the data item ws-var-1 is defined and it has an offset from the start of statically allocated data of h"50" and a size of h"ff" (decimal 255). Similarly, at line 6 the variable tls-var-1 has an offset of h"00" and a size of h"3FD" (decimal 1021).

Procedure Division Listing

The Procedure Division Listing looks like this:

fun.cbl, line 17
IntAddr:GntAddr----+-*A-1-B--+----2----+----3----+----4----+--- ... -8   Xref
000017  00002e                 sec1 section.                          =000017
000018  000030                 par1.                                  =000018
000019  000031:00000CC             move tls-var-1 to ws-var-1          000006 >000003
000020  000039:00000F4             if ws-var-1 = lnks-var-1           ?000003 ?000012
000021  000042:0000160                display ls-var-1                 000009
000022  000049                     end-if
000023  00004B:000016C         stop run.
000024

The listing contains a page header, not shown in the example above, that gives product and compilation information. This is followed by the name of the source module that the first line of the page originates from and its sequence number relative to that module. For example, the first line of page 2 in the listing originates from the module fun.cbl and is line 17.

After the line showing the module is a column scale that indicates the COBOL areas of the source line (that is, Area A, Area B, and so on). In the example listing above, this scale is compressed to allow notations. In the scale line there is also a header for the sequence line of the source lines being displayed.

The column scale contains the headers IntAddr and GntAddr, under which are shown the intermediate code address and the generated/object code address relative to the start of the module, of the actual source line from which the generated code was created. For example, for the syntax at line 19, the intermediate code address is h"31" and the generated/object code address is h"CC". The column scale aslo contains the header Xref, under which is shown the definition line of the data items that are manipulated in the statement, and any operations performed on the data items in the statement. The type of operations is indicated by a character:

= | Definition
> | Modification
? | Test

For example, on line 18 of the listing above, par1 is defined; on line 19, there is a reference to tls-var-1 which is defined on line 6 and there is a modification to ws-var-1 which is defined on line 3. On line 20, there is a test of ws-var-1, which is defined on line 3, and of lnks-var-1, which is defined on line 12.

Parent topic: The FaultFinder Source Listing


FaultFinder Source Listing - Map

There are two map listings, one for data items and one for procedural items.

Data Item Map Listing

The data item map listing looks like this:

* Data Map Listing
* Line   Name                           Addr   Size   Sec  Usage   Picture string
  000003 WS-VAR-1                       000050 0000FF WS   Alnum   PIC X(255)
  000006 TLS-VAR-1.                     000000 0003FD TS   Alnum   PIC X(1021)
  000009 LS-VAR-1                       000000 0001FF Lcl  Alnum   PIC X(511)
  000012 LNKS-VAR-1                     000000 0007DB Lnk  Alnum   PIC X(2011)
  000013 LNKS-VAR-1R.                   000000 000400 Lnk  Alpha   PIC A(1024)
  000014 LNKS-VAR-2                     000000 000C18 Lnk  Alnum   PIC X(3096)
  000000 RETURN-CODE                    000150 000002 WS   Comp    PIC S9(4) COMP
  000000 SORT-RETURN                    000154 000002 WS   Comp    PIC S9(4) COMP

This listing shows:

  • The line at which the data item was defined
  • The hexadecimal address and size of the data item
  • The section in which the data item was defined, identified by:
    WS | Working-Storage Section
    FS | File Section
    TS | Thread-Local Storage Section
    Lcl | Local Storage Section
    Lnk | Linkage Section
    Obj | Object-Storage Section
    SRg | Compiler Special Register
  • The usage defined for the data item, such as alphanumeric, alphabetic or computational
  • The picture of the data item

Procedural Item Map Listing

The procedural item map listing looks like this:

*  Procedure Map Listing
*  Line   Name                           Seg IntAddr  GntAddr  Sec/Par
   000017 SEC1                               000002E           Sec
   000018 PAR1
   0000030                                   00000CC           Par

This listing shows:

  • The line at which the procedural item was defined
  • The address in the intermediate and/or generated code at which the procedural item was defined
  • Whether the procedural item is a section or paragraph
Parent topic: The FaultFinder Source Listing


FaultFinder Source Listing - Xref

The Xref listing provides a sorted list of data names. It looks like this:

*  Xref Map Listing
*  Def'd  Name                    References, ?Tests, >Modifications
   000012 LNKS-VAR-1              0000013 0000016 ?0000020
   000013 LNKS-VAR-1R.
   000014 LNKS-VAR-2              0000016
   000009 LS-VAR-1                0000021
   000018 PAR1
   000017 SEC1
   000006 TLS-VAR-1               0000019
   000003 WS-VAR-1                >0000019 ?0000020
   000016 funbar*
   000001 funbar@

For each data item, the listing shows:

  • The line at which the data item was defined
  • The lines at which the data item is used
  • The operations performed on the data item on particular lines

The header to the third column, References, ?Tests, >Modifications, shows the type of operations that are recognized, and the indicators for these operations. For example, lnks-var-1 is defined at line 12, referenced at lines 13 and 16, and tested at line 20, while ws-var-1 is defined at line 3, modified at line 19 and tested at line 20.

A name suffixed with an asterisk (*) indicates the line at which that program's Procedure Division begins, while a name suffixed with the at sign (@) indicates the line at which that program's program id is defined.

Parent topic: The FaultFinder Source Listing


Introduction to the Consolidated Tracing Facility

The Consolidated Tracing Facility (CTF) is a tracing infrastructure that enables you to quickly and easily produce diagnostic information detailing the operation of Micro Focus software components and your own programs.

To create tracing information using CTF, you need to set up the environment appropriately.

You also need to create a side file, the CTF configuration file, to define the tracing information you want to capture. For example, you can define:

  • The application to trace. Tracing information of a number of Micro Focus software components can be enabled. See Components Traced by CTF .

    You can also produce tracing information for your own programs by using library routines that give you access to CTF infrastructure. See Consolidated Tracing Facility Routines.

  • The severity level of tracing messages to capture. See CTF Configuration File.
  • The emitters to produce the tracing information (such as text or binary). See Emitter List.
  • To enable CTF tracing
  • CTF Trace File Formats
  • Components Traced by CTF
  • Configuration File for CTF
  • Emitter List
  • Demonstration Programs
  • Tracing Examples
Parent topic: Problem Determination and Diagnostic Tools


To enable CTF tracing

  1. Set the MFTRACE_CONFIG environment variable to point to the configuration file, before you invoke the application. For example:
    set MFTRACE_CONFIG=c:\ctf\ctf.cfg
  2. Specify the format of CTF trace files you require by adding the appropriate lines in the configuration file ctf.cfg, or, if developing .NET managed code, a configuration file app.cfg located in the same folder as the associated app.exe file, such as:
    mftrace.dest = binfile
mftrace.emitter.binfile#location  = c:\logs
mftrace.level.mf.rts              = info
mftrace.comp.mf.rts#pgm           = true
mftrace.comp.mf.rts#pgmload       = true
mftrace.comp.mf.rts#syspgm        = true
  3. Set the MFTRACE_LOGS environment variable to specify the location in which to create the CTF log files. If MFTRACE_LOGS is not set, the current folder is used.
    Note: The Net Express command prompt, 32-bit, sets MFTRACE_LOGS to %PUBLIC%\Micro Focus\MFTRACE\Logs. The Net Express command prompt, 64-bit sets MFTRACE_LOGS to %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Base\MFTRACE\Logs.
  4. Run the application from the environment you set up.
  5. If you are using the .NET environment, instead of setting the MFTRACE_CONFIG variable you can configure CTF tracing in an app.config file in the same folder as its associated app.exe file. The configuration statements must be inserted in an <mftrace_config> section in the <configSections> as CDATA. For example:
    <?xml version ="1.0"?>
  <configuration>
    <configSections>
      <sectionGroup name="MicroFocus.COBOL.Tracing">
        <section name="mftrace_config"
         type="MicroFocus.COBOL.Runtime.CdataSectionHandler,
         MicroFocus.COBOL.Runtime.Win32,Version=4.0.0.0,Culture=neutral,
         PublicKeyToken=0412c5e0b2aaa8f0" />
      </sectionGroup>
    </configSections>
    <MicroFocus.COBOL.Tracing>
      <mftrace_config>
        <![CDATA[>
mftrace.dest                           = binfile
mftrace.emitter.binfile#location       = c:\logs
mftrace.level.mf.rts                   = info
mftrace.comp.mf.rts#pgm                = true
mftrace.comp.mf.rts#pgmload            = true
mftrace.comp.mf.rts#syspgm             = true
        <]]>
      </mftrace_config>
    </MicroFocus.COBOL.Tracing>
  </configuration>
    Note: If the MFTRACE_CONFIG variable is set, CTF uses it in preference to an app.config file.
Parent topic: Introduction to the Consolidated Tracing Facility
Related information
Tracing IMS Service Execution


CTF Trace File Formats

You can view the results of a trace in one of two formats. The default is as a simple text file, or you can create a compressed binary file, which can be viewed using the CTF Viewer.

Text format trace files have the advantage that you can view them in a text editor, but there are a number of disadvantages:

  • Trace files can get very large very quickly.
  • The trace record format needs to be specified before tracing begins (e.g. when tracing a multi-threaded application, the $(THREAD) pseudo-variable needs to be specified to ensure that the thread id appears in each trace record).
  • Trace events are meaningless to nearly everyone except the developer who trace-enabled the application/component.

Binary format trace files cannot be viewed in a text editor, but they provide the following advantages:

  • Compressed format. Usually at least 50% the size of an equivalent text-format trace file.
  • No record format needs to be specified before tracing begins. All relevant information about a trace event is recorded, such as the process id, thread id, date, time, component id, event id, trace data and so on.
Parent topic: Introduction to the Consolidated Tracing Facility
Related concepts
Example CTF Configuration Files
Related reference
TEXTFILE Emitter Properties
BINFILE Emitter Properties


Components Traced by CTF

The Consolidated Tracing Facility (CTF) can produce tracing information for the components listed below:

  • mf.ede.mfeditor Properties
    Editor engine
  • mf.ede.textmgr Properties
    Editor text manager
  • mf.esmq Properties
    This component provides calls to the MQSeries XA switch module.
  • mf.esxa Properties
    This component provides diagnostics on the various SQL operations invoked by the switch modules when executing SQL applications that have been deployed under Enterprise Server.
  • mf.ide Properties
    This component provides behavior of the integrated development environment (IDE).
  • mf.idmr Properties
    This component handles the interface mapping between a SOAP/BINP message and COBOL fields.
  • mf.mffh.fs Properties
    This component provides Fileshare processing.
  • mf.mffh.xfh Properties
    This component provides the Micro Focus File Handler system.
  • mf.mffh.xsm Properties
    This component provides the Micro Focus Sort module.
  • mf.mvs.casspool Properties
    This component provides JCL workload management, such as job submission, dispatch, printing and held SYSOUT.
  • mf.mvs.mvscatio Properties
    This component supports the JES system catalog, which maintains the relationship between the native file system and the MVS/VSE form of data set names.
  • mf.mvs.mfjcl Properties
    This component provides the main JCL processing functionality.
  • mf.rts Properties
    This component provides behavior of the run-time system.
  • mf.mvs.le37 Properties
    This component provides language environment services support.
Parent topic: Introduction to the Consolidated Tracing Facility


mf.ede.mfeditor Properties

Editor engine

The following table lists the properties of the mf.ede.mfeditor component and shows the event information that can be included in the trace for each property.

The properties of the mf.ede.mfeditor component provide information about the behavior of the editor engine, which provides support for the common interactions that are performed when editing source files.

Property | Property Description | Level | Event Id | Event Description
CLOSE | Close functions. | DEBUG | 3 | Text strings indicating the results of the different functions and callbacks that occur when a file is closed in the editor.
COPYBOOK | Copybook functions. | DEBUG | 3 | Text strings indicating the results of copybook-related operations within a given source stream. Information is also returned on searches for copybooks using .idy files or COBCPY and other environment variables.
CUTCOPY | Clipboard functions. | DEBUG | 3 | Text strings indicating the results of cut, copy and paste functions.
ENTRY | Entry to and exit from the editor functions. | DEBUG | 3 | Text string indicating entry to or exit from the editor fuctions, return code and function codes.
SAVE | Save functions. | DEBUG | 3 | Text strings indicating the results of save functions.
Parent topic: Components Traced by CTF
Related information
Introduction to the Consolidated Tracing Facility
Components Traced by CTF


mf.ede.textmgr Properties

Editor text manager

The following table lists the properties of the mf.ede.textmgr component and shows the event information that can be included in the trace for each property.

The properties of the mf.ede.textmgr component provide information about the behavior of the editor's text manager, which provides the low-level support for editing source files.

Property | Property Description | Level | Event Id | Event Description
CLOSE | Close functions. | DEBUG | 3 | Text strings indicating the results of the different functions and callbacks that occur when a file is closed in the editor.
COPYBOOK | Copybook functions. | DEBUG | 3 | Text strings indicating the results of copybook-related operations within a given source stream. Information is also returned on searches for copybooks using .idy files or COBCPY and other environment variables.
CUTCOPY | Clipboard functions. | DEBUG | 3 | Text strings indicating the results of cut, copy and paste functions.
ENTRY | Entry to and exit from the editor functions. | DEBUG | 3 | Text string indicating entry to or exit from the editor fuctions, return code and function codes.
SAVE | Save functions. | DEBUG | 3 | Text strings indicating the results of save functions.
Parent topic: Components Traced by CTF
Related information
Introduction to the Consolidated Tracing Facility
Components Traced by CTF


mf.esmq Properties

This component provides calls to the MQSeries XA switch module.

The following table lists the properties of the mf.esmq component and shows the event information that can be included in the trace for each property.

Property | Property Description | Level | Event Id | Event Description
ALL | Enables all of the tracing properties | - | - | -
MQLOAD | Switch load file events | DEBUG | 3 | Switch load file loaded
START | Start of work units | DEBUG | 3 | Unit of work started
END | End of work units | DEBUG | 3 | Unit of work finished
OPEN | Opening of MQI channels | DEBUG | 3 | MQI channel to the server queue manager opened
CLOSE | Closing of MQI channels | DEBUG | 3 | MQI channel to the server queue manager closed
COMMIT | Commit decisions | DEBUG | 3 | Decision made to commit the unit of work
ROLLBACK | Rollback decisions | DEBUG | 3 | Decision made to rollback the unit of work
PREPARE | Commit preparation | DEBUG | 3 | Preparation to commit the unit of work started
Parent topic: Components Traced by CTF


mf.esxa Properties

This component provides diagnostics on the various SQL operations invoked by the switch modules when executing SQL applications that have been deployed under Enterprise Server.

The following table lists the properties of the mf.esxa component, and shows the event information that can be included in the trace for each property.

ESMSSQL
Event Level | Event ID | Event Description
INFO | 1 | Initialization of module
ERROR | 2 | Incorrect XA Open String provided
INFO | 3 | SQL CONNECT
INFO | 4 | Microsoft Distributed Transaction Coordinator (DTC) initialization
INFO | 5 | Begin DTC Transaction
INFO | 6 | Enlist in DTC Transaction
INFO | 7 | DTC Commit
INFO | 8 | DTC Rollback
INFO | 9 | SQL DISCONNECT
INFO | 10 | End DTC Transaction
ESODBCXA
Event Level | Event ID | Event Description
INFO | 21 | BEGIN TRANSACTION
INFO | 22 | SQL COMMIT
INFO | 23 | SQL ROLLBACK
INFO | 24 | SQL DISCONNECT
INFO | 26 | Initialization of module
ERROR | 27 | Incorrect XA Open String
INFO | 28 | SQL CONNECT
ESDB2XA
Event Level | Event ID | Event Description
INFO | 41 | xa_start()
INFO | 42 | xa_end()
INFO | 43 | xa_open() - database connection
INFO | 44 | xa_close()
INFO | 45 | xa_commit()
INFO | 46 | xa_rollback()
INFO | 47 | xa_prepare()
INFO | 48 | Call to IBM DB2 LUW XA initialization
ESDB2OPC
Event Level | Event ID | Event Description
ERROR | 61 | Incorrect XA Open String
INFO | 62 | SQL CONNECT
INFO | 63 | SQL COMMIT
INFO | 64 | SQL ROLLBACK
INFO | 65 | SQL DISCONNECT
INFO | 66 | Before SQL CONNECT
INFO | 67 | Before SQL COMMIT
INFO | 68 | Before SQL ROLLBACK
INFO | 69 | Before SQL DISCONNECT
ESORAXA
Event Level | Event ID | Event Description
INFO | 81 | xa_start()
INFO | 82 | xa_end()
INFO | 83 | xa_open() - database connection
INFO | 84 | xa_close()
INFO | 85 | xa_commit()
INFO | 86 | xa_rollback()
INFO | 87 | xa_prepare()
INFO | 88 | Load of Enterprise Server callback module
INFO | 89 | Load of Oracle client-side support
INFO | 90 | Call to Oracle XA initialization entry point
ESORAOPC
Event Level | Event ID | Event Description
ERROR | 101 | Incorrect XA Open String
INFO | 102 | SQL CONNECT
INFO | 103 | SQL COMMIT
INFO | 104 | SQL ROLLBACK
INFO | 105 | SQL DISCONNECT
INFO | 106 | Before SQL CONNECT
INFO | 107 | Before SQL COMMIT
INFO | 108 | Before SQL ROLLBACK
INFO | 109 | Before SQL DISCONNECT
Parent topic: Components Traced by CTF


mf.ide Properties

This component provides behavior of the integrated development environment (IDE).

The following table lists the properties of the mf.ide component and shows the event information that can be included in the trace for each property.

Property | Property Description | Level | Event Id | Event Description
DEBUG | Debugging of enterprise server SEPs. | DEBUG | 3 | Text strings indicating the status of various debugging operations.
EDIT | Editor functions. | DEBUG | 3 | Text strings indicating the status of editing-related operations that span more than one section of the IDE.
IDELOAD | IDE loading. | DEBUG | 3 | Text strings indicating the progress of loading, finishing when the IDE is loaded and initialized.
IDEVCS | Source code control system support. | DEBUG | 3 | Text strings indicating interaction with source code control systems.
SPFEDIT | SPF edit functions and all SPF line commands and the lines upon which they are operating. | DEBUG | 3 | Text strings indicating line commands, the line upon which the operation is occurring, and the results of processing.
VSXPRJ | Calls to Micro Focus Common Client (MFCC). The IDE uses the MFCC infrastructure to determine which enterprise servers to interact with. | DEBUG | 3 | Progress through MFCC calls and returned values along with an indication of logic flow.
 |  | ERROR | 3 | Text string indicating an enterprise server repository that has been found to be corrupt.
VSXREST 1 | VSXREST functions. | DEBUG | 3 | Text strings indicating different trace points in the VSXREST section of the IDE.
Parent topic: Components Traced by CTF
Related information
Introduction to the Consolidated Tracing Facility
Components Traced by CTF
1 VSXREST is the part of the IDE responsible for editing and debugging.


mf.idmr Properties

This component handles the interface mapping between a SOAP/BINP message and COBOL fields.

The following table lists the properties of the mf.idmr component and shows the event information that can be included in the trace for each property.

ALL
Enables/disables all of the other properties
API
API events.
Level | Event ID | Event Description
INFO | 211 | Mapper initialization
INFO | 212 | Mapper termination
INFO | 213 | Set implementation field
INFO | 214 | Get implementation field
INFO | 215 | API completed successfully
ERROR | 216 | API error
CLIENT
Enterprise Server client handler events.
Level | Event ID | Event Description
INFO | 31 | Start of client request
INFO | 32 | End of client request
INFO | 33 | Start of client response
INFO | 34 | End of client response
INFO | 35 | Start of client termination
INFO | 36 | End of client termination
INFO | 38 | Set behavior options
INFO | 39 | Set special registers
INFO | 40 | Get fault information
INFO | 41 | Call program
ERROR | 37 | Client handling error
GEN
IDT generation events.
Level | Event ID | Event Description
INFO | 121 | Start of IDT generation
INFO | 122 | Start of implementation section
INFO | 123 | Start of service section
INFO | 124 | Start of configuration section
INFO | 125 | Set schema location
INFO | 126 | Validate service definition
INFO | 128 | Operation completed successfully
INFO | 129 | Free IDT
INFO | 130 | Set behaviour options
INFO | 131 | Load configuration information
INFO | 132 | Free configuration information
ERROR | 127 | IDT generation error
IDT
IDT processing events.
Level | Event Id | Event Description
INFO | 181 | Get configuration information
MAP
Run-time interface mapping events.
Level | Event ID | Event Description
INFO | 501 | External information events
INFO | 502 | Implementation information
INFO | 503 | IDT information
INFO | 504 | Configuration information
INFO | 505 | Exit handling information
INFO | 506 | Arguments size
INFO | 507 | External message size
INFO | 508 | External message argument count
INFO | 509 | Start of parameter
INFO | 510 | End of parameter
INFO | 511 | Set implementation field
INFO | 512 | Set implementation constant
INFO | 513 | Get implementation field
INFO | 514 | Start of server request mapping
INFO | 515 | End of server request mapping
INFO | 516 | Start of server response mapping
INFO | 517 | End of server response mapping
INFO | 518 | Start of client request mapping
INFO | 519 | End of client request mapping
INFO | 520 | Start of client response mapping
INFO | 521 | End of client response mapping
INFO | 522 | No execution
SERVER
Enterprise Server request handler events.
Level | Event ID | Event Description
INFO | 0 | Start of server request
INFO | 1 | End of server request
INFO | 2 | Start of server response
INFO | 3 | End of server response
INFO | 4 | Start of server termination
INFO | 5 | End of server termination
ERROR | 6 | Server handling error
SYS
System IDT events.
Level | Event ID | Event Description
INFO | 151 | Generate system IDT

Parent topic: Components Traced by CTF


mf.mffh.fs Properties

This component provides Fileshare processing.

The following table lists the properties of the mf.mffh.fs component and shows the event information that can be included in the trace for each property.

ALL
Enables all of the XFH properties
FILE:*
Enable/Disable tracing on all files.
FILE: <filename>
Enable/Disable tracing on specific file
BASE
Base events.
Level | Event Id | Event Description
DEBUG/INFO | 200 | Entry
DEBUG/INFO | 201 | Exit
COMMS
COMMS Call (Send receive in FHRSUB only).
Level | Event Id | Event Description
DEBUG | 202 | COMMS Entry
DEBUG | 203 | COMMS Return
Parent topic: Components Traced by CTF


mf.mffh.xfh Properties

This component provides the Micro Focus File Handler system.

The following table lists the properties of the mf.mffh.xfh component and shows the event information that can be included in the trace for each property.

ALL
Enables all of the XFH properties
FILE:*
Enable/Disable tracing on all files.
FILE: <filename>
Enable/Disable tracing on specific file
BASE
Enable/Disable base events.
Level | Event Id | Event Description
INFO | 1 | Entry
INFO | 2 | Exit
INFO | 3 | Call File Handler
INFO | 4 | File Handler Exit
INFO | 5 | Initialization Start
INFO | 6 | Initialization End
INFO | 7 | Final Start
INFO | 8 | Final End
INFO | 9 | Processing other Exit
INFO | 11 | Base Entry Point
INFO | 18 | Call Module
DEBUG | 19 | Allocate Handle
DEBUG | 20 | De-allocate Handle
DEBUG | 21 | Dynamic Custom File Handler Library loaded
DEBUG | 22 | Dynamic Custom File Handler Load Failure
DEBUG | 23 | Dynamic Custom File Handler Loaded
DEBUG | 24 | Dynamic Custom File Handler Environment Parsing Failure
DEBUG | 25 | Dynamic Custom File Handler environment set
MEMORY
Memory allocation and de-allocation events.
Level | Event Id | Event Description
DEBUG/ERROR | 12 | Memory allocated
DEBUG/ERROR | 13 | Memory Re-allocated
BSIO
Byte Steam layer events.
Level | Event Id | Event Description
INFO | 100 | Open
INFO | 101 | Open output
INFO | 102 | Delete
INFO | 103 | Copy
INFO | 104 | Rename
INFO | 105 | Close
INFO | 106 | Read
INFO | 107 | Seek end
INFO | 108 | Write
INFO | 109 | Set sema
INFO | 110 | Release sema
INFO | 111 | Lock file
INFO | 112 | Unlock file
INFO | 113 | Unlock
INFO | 114 | Test lock
INFO | 115 | Get lock
INFO | 116 | Release lock
INFO | 117 | Flush file
INFO | 118 | Configuration info
INFO | 119 | Message
INFO | 120 | Pass through
INFO | 121 | Get parameters
JSEB
Calls to JSEB events.
Level Event Id Event Description
- 16 JSEB Base
CATALOG
Calls to Catalog events.
Level Event Id Event Description
- 17 Catalog Base
CONFIG
Configuration setting events.
Level | Event Id | Event Description
INFO | 10 | Processing name
INFO | 14 | Change Processing name
INFO | 15 | 9/139 Error
Parent topic: Components Traced by CTF


mf.mffh.xsm Properties

This component provides the Micro Focus Sort module.

The following table lists the properties of the mf.mffh.xsm component and shows the event information that can be included in the trace for each property.

Property | Property Description | Level | Event Id | Event Description
ALL |  | - | - | Enables all of the XFH properties
 |  | DEBUG | 1 | EXTSM Entry
 |  |  | 2 | EXTSM Exit
 |  |  | 300 | Flush temp file

Parent topic: Components Traced by CTF


mf.mvs.casspool Properties

This component provides JCL workload management, such as job submission, dispatch, printing and held SYSOUT.

The following table lists the properties of the mf.mvs.casspool component and shows the event information that can be included in the trace for each property.

Property | Property Description | Level | Event Id | Event Description
ACTIVE | Movement of a job into active status. The job is given to the batch initiator for execution and upon completion of the job the batch initiator signals that it is ready for more work. | DEBUG | 4 | Compiled JCL has been executed.
COMP | Submission of JCL by Enterprise Server to be syntax checked. | DEBUG | 2 | A JCL file has been submitted for syntax scanning.
DELETE Removal of a job from the input, output, held, printing or active queues. DEBUG 7 A job has been removed from one of these quese. This could have occurred for the following reasons:
  • an active job has been killed
  • output has been requeued
  • a purge has taken place
DISP | Movement of a job from the input queue so that it can be executed by a batch initiator. | DEBUG | 3 | The next available compiled JCL for a given class and priority has been requested for scheduling in an available batch initiator.
OPEN | Opening and closing of the casspool.dat file. | DEBUG | 10 | casspool.dat is accessed when starting and stopping an initiator, initializing and terminating an enterprise server, and restarting a generic SEP.
OUTPUT | Movement of a job that has completed from the active queue to the output queue and performing of any associated cleanup tasks. | DEBUG | 5 | Compiled JCL has finished executing.
PRINT | Routing of a job to a batch printer or a batch printer exit. | DEBUG | 9 | This routing occurs upon job completion for active batch printers or when a SYSOUT is driven to the printer by requeuing.
REPL Replacement of a job that has either been made active or had been requested for execution into either the input or output queues. DEBUG 6 A job bas been replaced. This could have happened for the following reasons:
  • the job was previously active and canceled
  • a protection violation occurred in the batch initiator
  • a protection violation occurred in one of your programs
  • job was canceled by the operator

If the job was previously active it is moved to the output queue for review. If it was never made active then it is replaced in the input queue.

RETRIEVE | Requests to retrieve information about a job or SYSOUT DDs that are associated with a job. | DEBUG | 8 | These requests typically occur because of an interaction with ESMAC or when the casout utility needs to retrieve SYSOUT information.
Parent topic: Components Traced by CTF
Related information
Introduction to the Consolidated Tracing Facility
Components Traced by CTF


mf.mvs.mvscatio Properties

This component supports the JES system catalog, which maintains the relationship between the native file system and the MVS/VSE form of data set names.

The following table lists the properties of the mf.mvs.mvscatio component and shows the event information that can be included in the trace for each property.

Property | Property Description | Level | Event Id | Event Description
BUFFER | Buffer for MVSCATIO files. | DEBUG | 5 | The buffer used for MVSCATIO files in binary format. This is useful for subrecord tracing.
DELETE | Functions that occur when an MVSCATIO DLET function code is executed. | DEBUG | 3 | Unexpected failures, and information such as whether a file was able to be physically deleted or if alternate indexes were processed.
ENQUE | Enqueues on a record. | DEBUG | 3 | Data set records that are being locked and waited for.
ENTRY | Entry to or exit from MVSCATIO. | DEBUG | 3 | Primary key, file status, and return codes for a given call to MVSCATIO. This is very useful for diagnosing general problems with MVSCATIO.
MFALU | Mainframe Access lookups and their success or failure. | DEBUG | 3 | MVSCATIO calls that caused a Mainframe Access lookup to occur and whether or not the lookup was successful.
PHYS | Physical file name associated with a catalog entry. | DEBUG | 7 | The physical file name. This is useful in conjunction with the ENTRY property when trying to establish which physical files are associated with a given MVS name.
RECORDS | Catalog records. | DEBUG | 6 | The entire catalog record for a given I/O operation in binary form. This provides additional information that is not available when using the ENTRY property.
Parent topic: Components Traced by CTF
Related information
Introduction to the Consolidated Tracing Facility
Components Traced by CTF


mf.mvs.mfjcl Properties

This component provides the main JCL processing functionality.

The following table lists the property of the mf.mvs.mfjcl component and shows the event information that can be included in the trace for it.

Property | Property Description | Level | Event Id | Event Description
memstomp | Memory corruption event | ERROR | 79 | Memory has been corrupted.
Parent topic: Components Traced by CTF
Related information
Introduction to the Consolidated Tracing Facility
Components Traced by CTF


mf.rts Properties

This component provides behavior of the run-time system.

The following table lists the properties of the mf.rts component and shows the event information that can be included in the trace for each property.

no property
Event Level | Event Id | Event Description
INFO | 128 | Start of run-time system initialization. This event applies to native COBOL only.
INFO | 129 | End of run-time system initialization
INFO | 130 | Start of run-time system de-initialization
INFO | 131 | End of run-time system de-initialization
INFO | 132 | Entered a COBOL container. This event applies to native COBOL only.
INFO | 133 | Exited a COBOL container. This event applies to native COBOL only.
INFO | 134 | Link level entered. This event applies to .NET managed code only.
INFO | 135 | Link level exited. This event applies to .NET managed code only.
INFO | 136 | Memory validating. This event applies to native COBOL only.
INFO | 137 | Memory validated. This event applies to native COBOL only.
INFO | 254 | STOP RUN
ERROR | 255 | Run-time system error
ALL
Enables/disables all of the other properties.
API
This property is for .NET managed code only. API events:
Event Level | Event Id | Event Description
INFO | 56 | Entry to API. This event applies to native COBOL only..
INFO | 57 | Exit from API.
CONFIG
This property is for native COBOL only. Run-time configuration event:
Event Level | Event Id | Event Description
INFO | 61 | Run-time configuration operation (e.g. cobconfig file location and entries).
CONTAINER
This property is for native COBOL only. COBOL container events:
Event Level | Event Id | Event Description
DEBUG | 40 | Server initialization (start/finish)
DEBUG | 41 | Server de-initialization (start/finish)
DEBUG | 42 | Server context initialization (start/finish)
DEBUG | 43 | Server callback (start/finish)
DEBUG | 49 | Request handler function (start/finish)
INFO | 9 | Initializing environment for application running in the COBOL container (start/finish)
INFO | 10 | Invoking application in the COBOL container (start/finish)
INFO | 11 | Restoring initial state following the execution of an application in the COBOL container (start/finish)
INFO | 25 | Request handler trace event
INFO | 46 | Service lookup callback (start/finish)
ERROR | 0 | Request handler "start/next request" error
ERROR | 1 | Request handler "response" error
ERROR | 2 | Request handler "end processing" error
ERROR | 3 | Error loading the main program of the application identified by the request handler "start/next request"
ERROR | 4 | Error loading the package containing the application identified by the request handler "start/next request"
ERROR | 5 | Syncpoint failure
ERROR | 12 | Application termination due to exit from Debugger
ENV
This property applies to native COBOL only. Environment variable events:
Event Level | Event Id | Event Description
INFO and WARN | 60 | Environment variable operation
EXTERNAL
External data events.
Event Level | Event Id | Event Description
INFO | 26 | External data item created
INFO | 27 | External data item destroyed. This event applies to native COBOL only.
ERROR | 28 | External data item size mismatch
FSYS
This property is for native COBOL only. Low-level I/O level events:
Event Level | Event Id | Event Description
INFO | 52 | Entry to I/O function
INFO | 53 | Exit from I/O function
INFO | 54 | Specific I/O operation
JSEM
This property is for native COBOL only. MVS Job Step Execution Manager events:
Event Level | Event Id | Event Description
INFO | 44 | JSEM function entry
INFO | 45 | JSEM function exit
MEMORY
This property applies to native COBOL only. Memory allocation and de-allocation events:
Event Level | Event Id | Event Description
INFO | 13 | Memory allocated
INFO | 14 | Memory freed
INFO | 15 | Memory re-allocated (resized)
INFO | 16 | Re-allocated memory freed
INFO | 17 | Memory remaining allocated at RTS termination
ERROR | 48 | Insufficient low-memory available for PL/I. This property is for native COBOL only.
ERROR | 248 | Memory allocation failure
ERROR | 249 | Memory corruption detected
MFENTMAP
This property applies to native COBOL only. Entry Point Mapper event:
Event Level | Event Id | Event Description
INFO | 55 | Entry Point Mapper function
MFPM
This property applies to native COBOL only. Mainframe Pointer Manager events (AMODE programs):
Event Level | Event Id | Event Description
INFO | 29 | Absolute memory registration
INFO | 30 | External data registration
INFO | 31 | Memory registration
INFO | 32 | Working-storage memory registration
INFO | 33 | External data de-registration
INFO | 34 | Memory de-registration
INFO | 35 | Working-storage memory de-registration
INFO | 36 | Local-storage memory registration
INFO | 37 | Local-storage memory de-registration
ERROR | 250 | MFPM error.
PGM
User program entry, exit, chain, and link events:
Event Level | Event Id | Event Description
INFO | 6 | Program entry
INFO | 7 | Program exit
INFO | 8 | Program chain. This event applies to native COBOL only.
INFO | 18 | Program link. This event applies to native COBOL only.
PGMLOAD
Program load events:
Event Level | Event Id | Event Description
DEBUG | 50 | Subsystem function. This event applies to native COBOL only.
INFO | 19 | .int or .gnt program load
INFO | 20 | Logical cancel
INFO | 21 | Physical cancel. This event applies to native COBOL only.
INFO | 22 | Logical canceled program made live again. This event applies to native COBOL only.
INFO | 23 | DLL or shared object load. This event applies to native COBOL only.
INFO | 24 | DLL or shared object unload. This event applies to native COBOL only.
INFO | 38 | .lbr load. This event applies to native COBOL only.
INFO | 39 | .lbr unload. This event applies to native COBOL only.
ERROR | 251 | Program load error. This event applies to native COBOL only.
PGMSEARCH
Program searcher events:
Event Level | Event Id | Event Description
DEBUG | 58 | Entry to program searcher.
DEBUG | 59 | Exit from program searcher.
SIGNAL
This property applies to native COBOL only. Signal handling events:
Event Level | Event Id | Event Description
ERROR | 252 | Apply previously ‘held’ signal
ERROR | 253 | Signal caught
SYSPGM
System program entry, exit, chain, and link events:
Event Level | Event Id | Event Description
INFO | 6 | Program entry
INFO | 7 | Program exit
INFO | 8 | Program chain. This event applies to native COBOL only.
INFO | 18 | Program link. This event applies to native COBOL only.
THREAD
Threading and synchronization events:
Event Level | Event Id | Event Description
INFO | 56 | Entry to API (Threading and synchronization APIs)
INFO | 57 | Exit from API (Threading and synchronization APIs)
Parent topic: Components Traced by CTF
Related information
Introduction to the Consolidated Tracing Facility
Components Traced by CTF


mf.mvs.le37 Properties

This component provides language environment services support.

The table below lists the properties of the mf.mvs.le37 component and shows the event information that can be included in the trace for each property.

Property | Property Description | Level | Event Id | Event Description
ENTRY | Entry and exit to each program | DEBUG | 1 | Entry and exit to each program
 |  |  | 2 | Retrieve product and platform information
ENVIR | Environment Values | DEBUG | 3 | Report environment values that affect LE
SETPP | Setting procedure entry points | DEBUG | 4 | Report the setting of procedure entry points
CALL | Calling programs | DEBUG | 5 | Report the call to and response from a program
FILE | Reading configuration files | DEBUG | 6 | Report the actions and contents of LE configuration files
CGPIINFO | Call stack | DEBUG | 7 | Report program call stack
Parent topic: Components Traced by CTF


Configuration File for CTF

You can configure the behavior of CTF using the CTF configuration file ctf.cfg, whose location is set in the MFTRACE_CONFIG environment variable. If you are using the .NET environment, you can alternatively use an app.config file located in the folder containing the associated app.exe file.

CTF configuration files are processed during run-time system initialization and must be text files. You specify the configuration information as name-value pair entries, with each entry on a separate line, and with lines beginning with ‘#’ treated as comments.

A sample CTF configuration file ctf.cfg is supplied in your COBOL development system ...\examples directory.

You can use the following entries in configuration files:

  • mftrace.application
    Restricts tracing to a specific application.
  • mftrace.comp.component-name#property
    Sets a component's property.
  • mftrace.dest
    Specifies the default output destinations that are to be used when tracing. If you specify multiple mftrace.dest definitions for a given emitter in the configuration file their effect is cumulative.
  • mftrace.dest.component-name
    Specifies additional (or replacement) output destinations that are to be used when tracing a component.
  • mftrace.emitter.emitter-name#property
    Sets an emitter property.
  • mftrace.level
    Specifies the default tracing level to use for all components.
  • mftrace.level.component-name
    Specifies the tracing level to use for a single component.
  • Example CTF Configuration Files
Parent topic: Introduction to the Consolidated Tracing Facility


mftrace.application

Restricts tracing to a specific application.

Syntax:

mftrace.application=executable-name

Parameters:

executable-name
The name of the executable for the application for which tracing is to be performed. This can be either a fully-qualified or unqualified name. Enclosing the executable name within parentheses indicates that the application is being run under a trigger program (such as run ), and that the second program of the command line is to be used as the real executable name.

Default:

All applications are traceable if you do not set mftrace.application.

Comments:

Use mftrace.application to restrict tracing to a specific application. If the name of the application's executable does not match executable-name, all preceding configuration entries are ignored and the remainder of the configuration file is not processed.

Examples:

To restrict tracing to the myapp executable:

...
mftrace.application=myapp
...

To restrict tracing to the otherapp executable being run under a trigger program:

...
mftrace.application=(otherapp)
...
Parent topic: Configuration File for CTF


mftrace.comp.component-name#property

Sets a component's property.

Syntax:

mftrace.comp.component-name#property-name=property-value

Parameters:

component-name
The name of the component for which the property is to be set. See Component List for a list of available components.
property-name
The name of the component property to set.
property-value
The value of the component property to be set.
If any of the following well-known property case-insensitive values are used, they are held in two forms: the string as given, and a corresponding numeric value. A component can then use CBL_CTF_COMP_PROPERTY_GET to retrieve the numeric value of the property directly without needing to perform its own string conversion.
String Value | Maps to
ON | 1
OFF | 0
YES | 1
Y | 1
NO | 0
N | 0
TRUE | 1
FALSE | 0
ENABLED | 1
DISABLED | 0
numeric-string | n

Component names and property names are case insensitive.

Default:

The properties and their associated values depend on the component.

Comments:

Use mftrace.comp.component-name#property to set the property with the given name and value for the given component. You can set any property name and value, regardless of whether the component actually makes use of it.

You can specify multiple mftrace.comp.component-name#property entries in the configuration file, but an entry that specifies a property for a component that has previously been set overrides the previous property value.

Properties are intended to be used for defining the areas of tracing that are required for the component.

Examples:

To set the Memory and PgmLoad properties for the mf.rts component:

...
mftrace.comp.mf.rts#memory=on
mftrace.comp.mf.rts#pgmload=enabled
...
Parent topic: Configuration File for CTF
Related information
Components Traced by CTF
mf.rts Component Properties
To enable CTF tracing
Configuration File for CTF


mftrace.dest

Specifies the default output destinations that are to be used when tracing. If you specify multiple mftrace.dest definitions for a given emitter in the configuration file their effect is cumulative.

Syntax:

mftrace.dest=emitter-list

Parameters:

emitter-list
A list of comma- or space-separated emitter names. See Emitter List for a list of available emitters.

Emitter names are case-insensitive.

Default:

mftrace.dest=TEXTFILE

Comments:

TEXTFILE is assumed if no mftrace.dest entry is specified in the configuration file.

Examples:

To specify that tracing events are to be output to file in binary format:

...
mftrace.dest=BINFILE
...

To specify that tracing events are to be output to file in text format and also in binary format:

...
mftrace.dest=TEXTFILE,BINFILE
...

or alternatively:

...
mftrace.dest=TEXTFILE
mftrace.dest=BINFILE
...
Parent topic: Configuration File for CTF
Related information
Emitter List
To enable CTF tracing
Configuration File for CTF


mftrace.dest.component-name

Specifies additional (or replacement) output destinations that are to be used when tracing a component.

Syntax:

mftrace.dest.component-name=[(]emitter-list[)]

Parameters:

component-name
The component whose trace entries are to be routed to the output destinations identified by emitter-list.
emitter-list
A list of comma-or space-separated emitter names. See Emitter List for a list of available emitters.

If emitter-list is enclosed in parentheses, the component’s trace events will only be routed to those output destinations specified by emitter list and not to any inherited from its parent.

Emitter names are case-insensitive.

Default:

If not set, a component’s output destinations are inherited from its parent.

Comments:

If you specify multiple mftrace.dest.component-name definitions for a given component in the configuration file their effect is cumulative.

Examples:

To specify that tracing events from the mf.rts component are output to a binary file in addition to the default text file that trace events from all other components will be output to. All components that inherit from the mf.rts component (such as mf.rts.err and mf.rts.mem) also have their trace events routed to the a binary file and the default text file:

...
mftrace.level=INFO
mftrace.dest=TEXTFILE
mftrace.dest.MF.RTS=BINFILE
...

To specify that tracing events from the mf.rts component are to be output only to a binary file. All components that inherit from the mf.rts component (such as mf.rts.err and mf.rts.mem) also have their trace events output only to a binary file. All other components’ trace events are output to the default text file:

...
mftrace.level=INFO
mftrace.dest=TEXTFILE
mftrace.dest.MF.RTS=(BINFILE)
...
Parent topic: Configuration File for CTF
Related information
Emitter List
To enable CTF tracing
Configuration File for CTF


mftrace.emitter.emitter-name#property

Sets an emitter property.

Syntax:

mftrace.emitter.emitter-name#property-name=property-value

Parameters:

emitter-name
The name of the emitter for which the property is to be set.
property-name
The name of the emitter property to set.
property-value
The value of the emitter property to be set.
If any of the following property case-insensitive values are used, they are held in two forms: the string as given, and a corresponding numeric value. A component can then use CBL_CTF_EMITTER_PROPERTY_GET to retrieve the numeric value of the property directly without needing to perform its own string conversion.
String Value | Maps to
ON | 1
OFF | 0
YES | 1
Y | 1
NO | 0
N | 0
TRUE | 1
FALSE | 0
ENABLED | 1
DISABLED | 0
numeric-string | n

Emitter names and property names are case insensitive.

Default:

The properties and their associated values depend on the emitter.

Comments:

Use mftrace.emitter.emitter-name#property to set the property with the given name and value for the given emitter. You can set any property name and value, regardless of whether the emitter actually makes use of it.

You can specify multiple mftrace.emitter.emitter-name#property entries in the configuration file, but an entry that specifies a property for an emitter that has previously been set overrides the previous property value.

Examples:

To set the trace file name, the number of backup files, and the maximum size of each file in the backup set for the TEXTFILE emitter:

...
mftrace.emitter.textfile#location=e:\logs
mftrace.emitter.textfile#file=mytrace.dat_$(GEN)
mftrace.emitter.textfile#maxgeneration=3
mftrace.emitter.textfile#maxfilesize=200
...

This specifies that mytrace.dat, mytrace.dat_1, mytrace.dat_2, and mytrace.dat_3 would be created in the directory e:\mylogs and each of these files would have a maximum size of 200 Kb.

Parent topic: Configuration File for CTF
Related information
Emitter List
To enable CTF tracing
Configuration File for CTF


mftrace.level

Specifies the default tracing level to use for all components.

Syntax:

mftrace.level=trace-threshold-level

Parameter:

trace-threshold-level
One of the following case-insensitive values:
NONE | No events are to be traced.
DEBUG | All events are traced. This produces the most verbose output.
INFO | All INFO, WARN, ERROR, and FATAL events are traced.
WARN | All WARN, ERROR, and FATAL events are traced
ERROR | All ERROR and FATAL events are traced
FATAL | Only FATAL events are traced

Default:

mftrace.level=NONE

Comments:

You can specify multiple mftrace.level entries in the configuration file, but an entry specifying a level overrides any level previously specified.

You can override this default tracing level by using mftrace.level.component entries.

Examples:

To set the INFO tracing threshold level:

...
mftrace.level=info
...
Parent topic: Configuration File for CTF
Related information
To enable CTF tracing
Configuration File for CTF


mftrace.level.component-name

Specifies the tracing level to use for a single component.

Syntax:

mftrace.level.component-name=trace-threshold-level

Parameters:

component-name
The component whose trace threshold level is to be set. Component names are case-insensitive.
trace-threshold-level
One of the following case-insensitive values:
NONE
No events are to be traced.
DEBUG
All events are traced. This produces the most verbose output.
INFO
All INFO, WARN, ERROR, and FATAL events are traced.
WARN
All WARN, ERROR, and FATAL events are traced
ERROR
All ERROR and FATAL events are traced
FATAL
Only FATAL events are traced

Default:

If not set, a component’s trace threshold level is inherited from its parent, or the default trace level if the component does not have a parent. A component's parent is the component that appears to the left of it in component-name. For example, if component-name is mf.rts.subsystem, mf is the parent of rts, and rts is the parent of subsystem.

Comments:

Use mftrace.level.component to specify the level of tracing that is to be performed by the specified component and any components that inherit from it. You can specify multiple mftrace.level.component entries in the configuration file, but an entry that specifies a tracing level for a component that has previously been set overrides the previous setting.

Examples:

To set the WARN tracing threshold level for the mf.rts component and the DEBUG tracing threshold level for all other components:

...
mftrace.level=debug
mftrace.level.mf.rts=warn
...
Parent topic: Configuration File for CTF
Related information
Components Traced by CTF
To enable CTF tracing
mftrace.application
mftrace.comp.component-name#property
mftrace.emitter.emitter-name#property
mftrace.level


Example CTF Configuration Files

Example ctf.cfg file 1

This configuration file traces the COBOL programs' loads, entries, exits and cancels, and creates a text file:

mftrace.emitter.textfile#Format = $(TIME) $(THREAD) $(COMPONENT) $(EVENT) $(LEVEL) :$(DATA)
mftrace.level.mf.rts              = info
mftrace.comp.mf.rts#pgm           = true
mftrace.comp.mf.rts#pgmload       = true
mftrace.comp.mf.rts#syspgm        = true

Example ctf.cfg file 2

This configuration file traces the COBOL programs' loads, entries, exits and cancels, and creates a text file:

mftrace.dest                      = binfile
mftrace.emitter.binfile#location  = c:\logs
mftrace.level.mf.rts              = info
mftrace.comp.mf.rts#pgm           = true
mftrace.comp.mf.rts#pgmload       = true
mftrace.comp.mf.rts#syspgm        = true

where:

  • c:\logs is the location where the trace files for the application is created.
  • binfile indicates that a binary trace file is to be generated

Example configuration file for Assembler

This configuration file traces Assembler programs, and creates a text file:

#
#  Demo CTF config file for use with demo CTF programs.
#

mftrace.dest=textfile

mftrace.emitter.textfile#Format = $(TIME) $(THREAD) $(COMPONENT) $(EVENT) $(LEVEL) :$(DATA)
mftrace.emitter.es#level = 9999

# Where do you want the logs to go?
mftrace.emitter.textfile#location = c:\logs

# Maximum file size in "k" bytes
mftrace.emitter.textfile#MaxFilesize = 6000

# Maximum number of log files to keep.
mftrace.emitter.textfile#MaxGeneration = 4

################################################
# CASSPOOL Tracing
################################################

mftrace.level.mf.asm             = debug

mftrace.comp.mf.asm#INS          = true
mftrace.comp.mf.asm#SVC          = true
mftrace.comp.mf.asm#BAL          = true

mftrace.comp.mf.asm#ABEND        = true
mftrace.comp.mf.asm#LOAD         = true
mftrace.comp.mf.asm#DELETE       = true
mftrace.comp.mf.asm#LINK         = true
mftrace.comp.mf.asm#GETMAIN      = true
mftrace.comp.mf.asm#FREEMAIN     = true
#mftrace.comp.mf.asm#REGS         = true

where:

  • INS - trace all instructions
  • SVC - trace all svc calls
  • BAL - trace all branch instructions
  • ABEND - trace abends
  • LOAD - trace all loads
  • DELETE - trace all delete calls
  • LINK - trace all link commands
  • GETMAIN - trace all memory allocation commands
  • FREEMAIN - trace all free memory commands

Example app.config file

(For .NET environment only.) This configuration file traces the COBOL programs' loads, entries, exits and cancels, and creates a text file:

<?xml version ="1.0"?>
  <configuration>
    <configSections>
      <sectionGroup name="MicroFocus.COBOL.Tracing">
        <section name="mftrace_config"
         type="MicroFocus.COBOL.Runtime.CdataSectionHandler,
         MicroFocus.COBOL.Runtime.Win32,Version=4.0.0.0,Culture=neutral,
         PublicKeyToken=0412c5e0b2aaa8f0" />
        </sectionGroup>
    </configSections>
    <MicroFocus.COBOL.Tracing>
      <mftrace_config>
        <![CDATA[>
mftrace.dest                           = binfile
mftrace.emitter.binfile#location       = c:\logs
mftrace.level.mf.rts                   = info
mftrace.comp.mf.rts#pgm                = true
mftrace.comp.mf.rts#pgmload            = true
mftrace.comp.mf.rts#syspgm             = true
        <]]>
      </mftrace_config>
    </MicroFocus.COBOL.Tracing>
  </configuration>
Parent topic: Configuration File for CTF


Emitter List

The Consolidated Tracing Facility can output its trace information using any of the emitters listed below:

  • BINFILE Emitter Properties
    Set the BINFILE emitter properties to control the behavior and appearance of the binary trace file when viewed using the CTF Viewer.
  • IDEDBG Emitter Properties
    Set the IDEDBG emitter properties to output trace information to a debugger that is attached to a running process.
  • TEXTFILE Emitter Properties
    Set the TEXTFILE emitter properties to control the behavior and appearance of the text trace file.
  • WINEVENT Emitter Properties
    Set the WINEVENT emitter properties to output trace information to the Windows log file.
Parent topic: Introduction to the Consolidated Tracing Facility


BINFILE Emitter Properties

Set the BINFILE emitter properties to control the behavior and appearance of the binary trace file when viewed using the CTF Viewer.

The format of the trace files is platform independent, so you can use CTF Viewer to view binary trace files that were created on UNIX, for example.

To enable the BINFILE emitter, specify the following statement in the Consolidated Tracing Facility configuration file:

mftrace.dest = BINFILE

The following list shows the properties you can set to control the behavior of the BINFILE emitter:

Property | Description | Default
FILE The name of the trace file to be written. You can use the following pseudo-variables for the construction of the trace file name:
$(APPNAME)
The basename of the executable invoked to start the current process. For example, if run.exeis invoked, $(APPNAME) has the value "run".
$(EMITTER)
Always "BINFILE" for this emitter.
$(GEN)
The generation of the file, starting from 1.
$(PID)
The operating system identifier for the current process
$(APPNAME).$(EMITTER).$(PID).ctb, or $(APPNAME).$(EMITTER).$(PID).ctb_$(GEN) if the MAXGENERATION property has been specified. For example:
  • If the BINFILE emitter is being used to output trace events for run.exe executing as process-id 3456 and the MAXGENERATION property has not been specified, the trace file created will be called run.binfile.3456.ctb .
  • If the binfile emitter is being used to output trace events for myapp.exe executing as process-id 1975 and the MAXGENERATION property has been set to 3, the trace files created will be called myapp.binfile.1975.ctb_1, myapp.binfile.1975.ctb_2, and myapp.binfile.1975.ctb_3.
FLUSHEVERY | The number of trace records that will be output before the file is flushed. 0 indicates that the file will never be explicitly flushed. | 1
LOCATION The folder where the trace files are to be written. The folder specified by the MFTRACE_LOGS environment variable. If MFTRACE_LOGS is not set, the current folder is used.
Note: The Net Express command prompt, 32-bit, sets MFTRACE_LOGS to %PUBLIC%\Micro Focus\MFTRACE\Logs. The Net Express command prompt, 64-bit sets MFTRACE_LOGS to %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Base\MFTRACE\Logs.

If the folder specified by the LOCATION property does not exist, the Consolidated Tracing Facility tries to create it. If this fails, the Consolidated Tracing Facility uses the default location (as specified by the MFTRACE_LOGS environment variable). If this fails, the current folder is used.

MAXFILESIZE | The maximum amount of data (in Kb) that will be written to the trace file before the file is closed and the next trace file in the generation sequence is opened. The first trace file in a generation sequence results in the $(GEN) pseudo-variable (see the description of the FILE property, above) being set to 1, the second in the sequence results in it being set to 2, and so on until MAXGENERATION is exceeded. Once the MAXGENERATION number of files has been reached, the generation number reverts to 1 and the first trace file in the generation is overwritten. This is only used if MAXGENERATION > 1. | 0x00002800, indicating a maximum file size of 10 Mb.
MAXGENERATION | The maximum number of trace files that will be written to while tracing is enabled. Use this property in conjunction with the MAXFILESIZE property. | 1, indicating that only a single trace file will be created.
MultiProc | Controls whether trace events are written to the trace file by a single process or by multiple processes. If enabled for multiple processes, the File property must also be specified without the $(PID) pseudo-variable embedded in its name. | FALSE, indicating that the configured trace file includes only events from the current process
Parent topic: Emitter List
Related concepts
Example CTF Configuration Files
CTF Trace File Formats


IDEDBG Emitter Properties

Set the IDEDBG emitter properties to output trace information to a debugger that is attached to a running process.

The IDEDBG emitter is provided to allow trace records to be output by a debugger, such as your COBOL development system, Visual Studio, or Eclipse at the point which they occur in the application being debugged.

To enable the IDEDBG emitter, specify the following statement in the Consolidated Tracing Facility configuration file:

mftrace.dest = IDEDBG

To use this emitter with your COBOL development system IDE, you must set the MFTRACE_CONFIG environment variable on the Environment Variables tab of the Configure IDE Environment dialog box. Trace events appear in the Debug messages tab when the application is debugged.

To use this emitter with a third-party debugger such as Visual Studio, you must set the MFTRACE_CONFIG environment variable in the environment before the debugger process is started. Trace events appear in the debugger‘s window where other system debug events would normally be displayed. For example, under Visual Studio 6, debug messages are displayed in the Debug tab.

The following list shows the properties you can set to control the behavior of the IDEDBG emitter:

DELIMCHAR
The character used in the output file to delimit trace data parts for a trace event.
Default = Space
FORMAT
The format to be used for each trace data record written to the file. You can use the following pseudo-variables in the format specification:
$(COMPONENT) | The name of the component outputting the trace event.
$(DATA) | The trace data specified by the component to be output for the trace event. Each trace part will be delimited by the character specified by the DELIMCHAR property.
$(DATE) | The current date, output as yyyy/mm/dd.
$(EVENT) | The event identifier as specified by the component outputting the trace event.
$(LEVEL) The tracing level:
  • 0 = debug
  • 1 = info
  • 2 = warning
  • 3 = error
  • 4 = fatal
$(THREAD) | The current operating system thread identifier.
$(TIME) | The current time, output as hh:mm:ss.nnn.
Default = $(TIME) $(COMPONENT) $(EVENT) $(LEVEL)$(DATA)
LEVEL
The trace level below which this emitter will not output trace records:
  • 0 = debug
  • 1 = info
  • 2 = warning
  • 3 = error
  • 4 = fatal
  • >4 = no trace records are output
Default = 3
HEXBLOCKSIZE
The number of hexadecimal bytes to be output in each block when outputting binary trace data. Each block of hexadecimal characters will be separated by a '-' character. For example, if HEXBLOCKSIZE is set to 4, and some binary trace data with the value 3132333435363738393A3B3C3D3E3F is specified for output, it would be formatted as follows:
31323334-35363738-393A3B3C-3D3E3F
Default = 8
QUOTESTRING
Whether or not string trace data is to be output enclosed in double-quote characters.
Default = TRUE
Parent topic: Emitter List
Related information
Emitter List


TEXTFILE Emitter Properties

Set the TEXTFILE emitter properties to control the behavior and appearance of the text trace file.

A text trace file is the default format when a trace is run.

To control the behavior and the appearance of the file, set the following TEXTFILE emitter properties in the Consolidated Tracing Facility configuration file:

DELIMCHAR
The character used in the output file to delimit trace data parts for a trace event.
Default = space.
FILE
The name of the trace file to be written. You can use the following pseudo-variables for the construction of the trace file name:
$(APPNAME)
The basename of the executable invoked to start the current process. For example, if run.exe is invoked, $(APPNAME) has the value "run".
$(EMITTER)
Always "TEXTFILE" for this emitter.
$(GEN)
The generation of the file, starting from 1.
$(PID)
The operating system identifier for the current process.
Default = $(APPNAME).$(EMITTER).$(PID).log, or $(APPNAME).$(EMITTER).$(PID).log_$(GEN) if the MAXGENERATION property has been specified. For example:
  • If the TEXTFILE emitter is being used to output trace events for run.exe executing as process-id 3456 and the MAXGENERATION property has not been specified, the trace file created will be called run.textfile.3456.log .
  • If the TEXTFILE emitter is being used to output trace events for myapp.exe executing as process-id 1975 and the MAXGENERATION property has been set to 3, the trace files created will be called myapp.textfile.1975.log_1, myapp.textfile.1975.log_2, and myapp.textfile.1975.log_3.
FLUSHEVERY
The number of trace records that will be output before the file is flushed. 0 indicates that the file will never be explicitly flushed.
Default = 1
FORMAT
The format to be used for each trace data record written to the file. You can use the following pseudo-variables in the format specification:
$(COMPONENT)
The name of the component outputting the trace event.
$(DATA)
The trace data specified by the component to be output for the trace event. Each trace part will be delimited by the character specified by the DELIMCHAR property.
$(DATE)
The current date, output as yyyy/mm /dd
$(EVENT)
The event identifier as specified by the component outputting the trace event.
$(LEVEL)
The tracing level:
  • 0: debug
  • 1: info
  • 2: warning
  • 3: error
  • 4: fatal
$(PID)
The current process identifier. Same as $(PROCESS).
$(PROCESS)
The current process identifier. Same as $(PID).
$(THREAD)
The current operating system thread identifier.
$(TIME)
The current time, output as hh:mm:ss
Default = $(TIME) $(COMPONENT) $(EVENT) $(LEVEL) $(DATA)
HEXBLOCKSIZE
The number of hexadecimal bytes to be output in each block when outputting binary trace data. Each block of hexadecimal characters will be separated by a '-' character. For example, if HEXBLOCKSIZE is set to 4, and some binary trace data with the value 3132333435363738393A3B3C3D3E3F is specified for output, it would be formatted as follows:
31323334-35363738-393A3B3C-3D3E3F
LOCATION
The folder where the trace files are to be written. On Windows platforms, this is specified by the MFTRACE_LOGS environment variable. If MFTRACE_LOGS is not set, the current folder is used .
Note: The Net Express command prompt, 32-bit, sets MFTRACE_LOGS to %PUBLIC%\Micro Focus\MFTRACE\Logs. The Net Express command prompt, 64-bit sets MFTRACE_LOGS to %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Base\MFTRACE\Logs.

If the folder specified by the LOCATION property does not exist, the Consolidated Tracing Facility tries to create it. If this fails, the Consolidated Tracing Facility uses the default location (as specified by the MFTRACE_LOGS environment variable). If this fails, the current folder is used.

Default = 8
MAXFILESIZE
The maximum amount of data (in Kb) that will be written to the trace file before the file is closed and the next trace file in the generation sequence is opened. The first trace file in a generation sequence results in the $(GEN) pseudo-variable (see the description of the FILE property, above) being set to 1, the second in the sequence results in it being set to 2, and so on until MAXGENERATION is exceeded. Once the MAXGENERATION number of files has been reached, the generation number reverts to 1 and the first trace file in the generation is overwritten. This is only used if MAXGENERATION > 1.
Default = 0x00002800, indicating a maximum file size of 10 Mb.
MAXGENERATION
The maximum number of trace files that will be written to while tracing is enabled. Use this property in conjunction with the MAXFILESIZE property.
Default = 1, indicating that only a single trace file will be created.
MultiProc
Controls whether trace events are written to the trace file by a single process or multiple processes. If enabled for multiple processes, the File property must also be specified without the $(PID) pseudo-variable embedded in its name.

Default=FALSE, indicating that the configured trace file includes only events from the current process.
QUOTESTRING
Whether or not string trace data is to be output enclosed in double-quote characters.
Default = TRUE
Parent topic: Emitter List
Related concepts
Example CTF Configuration Files
CTF Trace File Formats


WINEVENT Emitter Properties

Set the WINEVENT emitter properties to output trace information to the Windows log file.

The WINEVENT emitter is provided to allow trace records to be output to the Windows event log. By default, to prevent the event log from being filled with unnecessary information, this emitter only outputs trace records with a trace level of error or above.

To enable the WINEVENT emitter, specify the following statement in the Consolidated Tracing Facility configuration file:

mftrace.dest = WINEVENT

The following list shows the properties you can set to control the behavior of the WINEVENT emitter:

DELIMCHAR
The character used in the output file to delimit trace data parts for a trace event. The default is space.
FORMAT
The format to be used for each trace data record written to the file. You can use the following pseudo-variables in the format specification:
$(COMPONENT) | The name of the component outputting the trace event.
$(DATA) | The trace data specified by the component to be output for the trace event. Each trace part will be delimited by the character specified by the DELIMCHAR property.
$(DATE) | The current date, output as yyyy/mm/dd.
$(EVENT) | The event identifier as specified by the component outputting the trace event.
$(LEVEL) The tracing level:
  • 0: debug
  • 1: information
  • 2: warning
  • 3: error
  • 4: fatal
$(THREAD) | The current operating system thread identifier.
$(TIME) | The current time, output as hh:mm:ss.nnn.
The default is $(DATA).
HEXBLOCKSIZE
The number of hexadecimal bytes to be output in each block when outputting binary trace data. Each block of hexadecimal characters will be separated by a '-' character. For example, if HEXBLOCKSIZE is set to 4, and some binary trace data with the value 3132333435363738393A3B3C3D3E3F is specified for output, it would be formatted as follows:
31323334-35363738-393A3B3C-3D3E3F
The default is 8.
LEVEL
The trace level below which this emitter will not output trace records. The default is 3.
QUOTESTRING
Whether or not string trace data is to be output enclosed in double-quote characters. The default is TRUE.
Parent topic: Emitter List


Demonstration Programs

There are two demonstration programs that illustrate how to use Consolidated Tracing Facility's library routines. Each demonstration program is installed in a folder of its own and includes a readme file describing how to use it.

The table below lists the demonstration programs that are available and gives an overview of each one. The location specified assumes that you have installed using the default folder structure.

Program Name | Location | Description
ctfdemo.c | Examples\Net Express IDE\ctf\c | C version that runs unchanged on Windows, Unix and Linux. This version uses the Consolidated Tracing Facility library routines that are exposed by the COBOL run-time system so has a dependency on the COBOL run-time system.
ctfdemo.cbl | Examples\Net Express IDE\ctf\cobol | COBOL version that runs unchanged on Windows, Unix and Linux.
Parent topic: Introduction to the Consolidated Tracing Facility


Tracing Examples

By default, tracing is disabled for all components, so the absolute minimum you need to do to enable run-time system tracing is to specify an mftrace.level or mftrace.level.mf.rts entry in the configuration file. For example, if you have set the MFTRACE_CONFIG environment variable set as follows:

set MFTRACE_CONFIG=e:\mydir\ctf.cfg

and e:\mydir\ctf.cfg contains only the following entry:

mftrace.level=error

a trace file with an entry for event id 255 would be created by any process that generated a run-time system error. Note that you do not have to specify any properties for the mf.rts component for this event to be emitted; having the trace level set to error is enough.

In the examples that follow, the application mymain is used. This application comprises two programs: mymain.cbl and mysub.cbl that include the following code:

mymain.cbl:

 identification division.
 program-id. mymain.
 environment division.
 data division.
 working-storage section.
 01 my-var pic 9(9) external.
 procedure division.
     move 1 to my-var

     perform 5 times
         call 'mysub'
         add 1 to my-var
     end-perform

     cancel 'mysub'

     call 'myprog'
     goback.

mysub.cbl:

 identification division.
 program-id. mysub.
 environment division.
 data division.
 working-storage section.
 01 my-var pic 9(9) external.
 procedure division.
     display my-var
     goback.

When mymain is executed, run-time system error 173 (“Called program file not found in drive/directory”) occurs because of the call to myprog. The contents of a trace file generated using the configuration above look similar to the following:

1>   # -MFTRACE Text Emitter-
2>   # CommandLine      = mymain
3>   # ProcessId        = 2404
4>   # Date             = 2004/12/14
5>   # Time             = 11:54:42.875
6>   # Operating System = Windows XP Service Pack 1 (Build 2600)
7>   # Computer Name    = PC-NAME
8>   # Format           = $(TIME) $(COMPONENT) $(EVENT) $(LEVEL)$(DATA)
9>   11:54:42.875 MF.RTS 255 3 173 1 "myprog"
The entries marked 1> through 8> are header records output by the TEXTFILE emitter giving information about the application being traced. 8> indicates the format of the subsequent trace entries (this example is using the default trace entry format), so the fields in entry 9> can be interpreted as follows:
Information in Trace File | Pseudo-variable | Description
11:54:42.875 | $(TIME) | The time the trace entry was output.
MF.RTS | $(COMPONENT) | The name of the component outputting the trace entry. MF.RTS indicates the run-time system.
255 | $(EVENT) | The event identifier. Event identifier 255 for the mf.rts component indicates a run-time system error.
3 $(LEVEL) The level of the error, based on the following values:
  • 0 = debug
  • 1 = info
  • 2 = warning
  • 3 = error
  • 4 = fatal
173 1 "myprog" | $(DATA) | Event-specific data.

If you now rerun mymain after changing the statement in the configuration file to specify a trace level of INFO, as follows:

mftrace.level=info

the trace file created contains entries for the run-time system initialization and de-initialization events in addition to the run-time system error event. The trace file looks similar to the following:

    # -MFTRACE Text Emitter-
    # CommandLine      = mymain
    # ProcessId        = 2820
    # Date             = 2004/12/14
    # Time             = 12:27:04.317
    # Operating System = Windows XP Service Pack 1 (Build 2600)
    # Computer Name    = PC-NAME
    # Format           = $(TIME) $(COMPONENT) $(EVENT) $(LEVEL)$(DATA)
    12:27:04.317 MF.RTS 128 1
    12:27:04.327 MF.RTS 129 1
    12:27:04.337 MF.RTS 255 3 173 1 "myprog"
    12:27:04.367 MF.RTS 130 1
    12:27:04.367 MF.RTS 131 1

To see which programs the application has invoked before the run-time system error occurred you need to set the PGM property. If you want to see where the programs have been loaded from and when they are canceled, you also need to set the PGMLOAD property, as follows:

mftrace.level=info
mftrace.comp.mf.rts#pgm=true
mftrace.comp.mf.rts#pgmload=true

When you rerun mymain, the trace file created contains additional entries for program load, entry, exit, and cancel events. The trace file looks similar to the following:

    # -MFTRACE Text Emitter-
    # CommandLine      = mymain
    # ProcessId        = 4092
    # Date             = 2004/12/14
    # Time             = 13:44:30.868
    # Operating System = Windows XP Service Pack 1 (Build 2600)
    # Computer Name    = PC-NAME
    # Format           = $(TIME) $(COMPONENT) $(EVENT) $(LEVEL)$(DATA)
    13:44:30.868 MF.RTS 128 1
    13:44:30.888 MF.RTS 129 1
    13:44:30.888 MF.RTS 19 1 0 0 "mymain" "" ""
    13:44:30.888 MF.RTS 6 1 17 0 "mymain"
    13:44:31.008 MF.RTS 19 1 0 0 "mysub" "gnt" "E:\myprogs"
    13:44:31.008 MF.RTS 6 1 1 0 "MYSUB"
    13:44:31.008 MF.RTS 7 1
    13:44:31.008 MF.RTS 6 1 1 0 "MYSUB"
    13:44:31.008 MF.RTS 7 1
    13:44:31.008 MF.RTS 6 1 1 0 "MYSUB"
    13:44:31.008 MF.RTS 7 1
    13:44:31.008 MF.RTS 6 1 1 0 "MYSUB"
    13:44:31.008 MF.RTS 7 1
    13:44:31.008 MF.RTS 6 1 1 0 "MYSUB"
    13:44:31.008 MF.RTS 7 1
    13:44:31.008 MF.RTS 20 1 0 0 "mysub"
1>  13:44:31.008 MF.RTS 6 1 1 0 "MYSUB"
    13:44:31.008 MF.RTS 7 1
    13:44:31.139 MF.RTS 255 3 173 1 "myprog"
    13:44:31.199 MF.RTS 130 1
    13:44:31.199 MF.RTS 20 1 0 0 "mymain"
2>  13:44:31.199 MF.RTS 6 1 17 0 "mymain"
    13:44:31.199 MF.RTS 7 1
    13:44:31.199 MF.RTS 131 1

The entries marked 1> and 2> show event type 6 and 7 entries (program entry and exit) for a program immediately after an event type 20 entry (logical cancel) for the same program. This is because the Compiler embeds a cancel routine in all programs to close any files that the program may have opened. These cancel routines are implicitly invoked by the run-time system as part of a logical cancel operation.

To enable the tracing of all run-time system events with the exception of the memory management ones, you use the following configuration file entries:

mftrace.level = info
mftrace.comp.mf.rts#all=true
mftrace.comp.mf.rts#memory=false

When you rerun mymain, the trace file created contains additional entries for external data items. If you have compiled the programs with the AMODE directive, there would also be entries for each of the Mainframe Pointer Manager events. The trace file looks similar to the following:

    # -MFTRACE Text Emitter-
    # CommandLine      = mymain
    # ProcessId        = 2716
    # Date             = 2004/12/14
    # Time             = 14:33:22.704
    # Operating System = Windows XP Service Pack 1 (Build 2600)
    # Computer Name    = PC-NAME
    # Format           = $(TIME) $(COMPONENT) $(EVENT) $(LEVEL)$(DATA)
    14:33:22.704 MF.RTS 128 1
    14:33:22.714 MF.RTS 129 1
    14:33:22.714 MF.RTS 19 1 0 0 "mymain" "" ""
    14:33:22.714 MF.RTS 6 1 17 0 "mymain"
1>  14:33:22.714 MF.RTS 26 1 "MY_VAR" 9
    14:33:22.714 MF.RTS 19 1 0 0 "mysub" "gnt" "E:\myprogs"
    14:33:22.724 MF.RTS 6 1 1 0 "MYSUB"
    14:33:22.724 MF.RTS 7 1
    14:33:22.724 MF.RTS 6 1 1 0 "MYSUB"
    14:33:22.724 MF.RTS 7 1
    14:33:22.724 MF.RTS 6 1 1 0 "MYSUB"
    14:33:22.724 MF.RTS 7 1
    14:33:22.724 MF.RTS 6 1 1 0 "MYSUB"
    14:33:22.724 MF.RTS 7 1
    14:33:22.724 MF.RTS 6 1 1 0 "MYSUB"
    14:33:22.724 MF.RTS 7 1
    14:33:22.724 MF.RTS 20 1 0 0 "mysub"
    14:33:22.724 MF.RTS 6 1 1 0 "MYSUB"
    14:33:22.724 MF.RTS 7 1
    14:33:22.724 MF.RTS 255 3 173 1 "myprog"
    14:33:22.764 MF.RTS 130 1
    14:33:22.764 MF.RTS 20 1 0 0 "mymain"
    14:33:22.764 MF.RTS 6 1 17 0 "mymain"
    14:33:22.764 MF.RTS 7 1
2>  14:33:22.764 MF.RTS 27 1 "MY_VAR"
    14:33:22.764 MF.RTS 131 1

The entries marked 1> and 2> show the additional entries for external data items.

Parent topic: Introduction to the Consolidated Tracing Facility
Related information
To enable CTF tracing


Profiler

  • Introduction to Profiler
  • Running Profiler
  • Profiler Output
  • Time Spent in Called Programs
  • Directives for Profiler
Parent topic: Problem Determination and Diagnostic Tools


Introduction to Profiler

Note: This facility is supported in native COBOL only.

Profiler is a facility that enables you to obtain detailed statistics on the run-time performance of a COBOL program.

When you compile a program you can specify the PROFILE compiler directive. This causes the compiler to include code in your program that produces performance statistics about each paragraph of the program each time you run the compiled program. If your program contains no paragraphs, this report is not produced.

The performance statistics produced using the PROFILE compiler directive for that run of the program are contained in a file called program-name.ipf where program-name is the name of the program that was run. If an executable file is produced, then program-name is the first entry point name in the executable file.

These performance statistics are in compact form and first must be converted to a readable format, using Profiler.

By default, this file is created in the current working directory, but you can change this using the COBPRFDIR environment variable to specify an alternative directory. For example:

SET COBPRFDIR=C:\myipfdir
Parent topic: Profiler
Related information
PROFILE


Running Profiler

Note: This facility is supported in native COBOL only.

To start Profiler from the Studio Enterprise Edition command prompt, use the following command:

profiler filenames directives

where the parameters are:

filenames
One or more files containing compact Profiler output. Profiler always searches for a file with the filename extension .ipf; if you specify any other extension, it is ignored.
directives
One or more of the directives that control the operation of Profiler. To specify a directive to Profiler, you must precede it with a plus sign (+). You can precede each directive with a plus sign; alternatively, you can specify one at the start of a list of directives.

Directives must be separated by one or more spaces. Where a Profiler directive takes a parameter, you can enclose the parameter either in quotation marks or in parentheses. If you use either of these, however, you must escape them using the backslash character ( \).

Profiler creates a file with the extension .prf, with the same basename as the .ipf file. If you profile more than one program at one time, Profiler output for all programs is appended to the output file for the first program, that is filename1 .prf.

Parent topic: Profiler


Profiler Output

When you run Profiler, the following banner is displayed:

* Micro Focus COBOL Profiler Vv.r
* name-1
.
.
.
* name-n

where name is one of the files listed in filenames in the command line.

For example, if you compile the program prog1 with the PROFILE directive set, run the program, and then enter:

profiler prog1 +LIST

the following output is produced on the console:

* Micro Focus COBOL Profiler Vv.r
* prog1
 Total time: 172 milliseconds. Module called once.

%time   time    entries  ms/entry    paragraph
-----------------------------------------------------------------
64.53   111     21       5           TEST-ROUTINE
17.44   30      1        30          PARA1
16.28   28      15       2           NAME-ENTRY
1.74    3       1        3           END-SECTION
0.00    0       1        0           INITIAL(UNNAMED) PARAGRAPH

The Profiler output gives the total execution time (in milliseconds) for the program run and then breaks this down for each section and paragraph in the program:

Output | Description
%time | Total percentage of execution time spent in the named section or paragraph
time | Total time (in milliseconds) spent in the named section or paragraph
entries | Number of times the named section or paragraph was entered
ms/entry | Average time (in milliseconds) per entry to the section or paragraph
paragraph | Section or paragraph to which performance statistics apply. The initial (unnamed) paragraph listed is the initialization code executed before the user part of the program is entered.

The product of the ms/entry and the number of entries should equal the total time spent in the section or paragraph; however, because all three values are truncated, there can be a slight discrepancy.

Note: Profiler reports can include unnamed paragraphs that appear if a program has sections without subsequent paragraphs, or in-line PERFORM and EVALUATE statements.
Parent topic: Profiler


Time Spent in Called Programs

How the run-time system treats the time spent in a called COBOL program that has been compiled with the PROFILE directive (a profiled program) depends on the value of the profile_behavior run-time tunable. You specify this tunable when you run the program that you want to be profiled.

If the profile_behavior run-time tunable is set to 0 (the default), then time spent in a profiled called program is recorded both in the called program and in the calling program.

If the profile_behavior run-time tunable is set to1, then time spent in a profiled called program is recorded only in the called program.

For example, suppose program prog_a calls program prog_c. prog_a is a profiled COBOL program. Then:

  • If prog_c is not COBOL, time spent in prog_c is recorded in prog_a
  • If prog_c is COBOL but is not profiled, time spent in prog_c is recorded in prog_a
  • If prog_c is COBOL and profiled, time spent in prog_c is recorded in prog_c, and not in prog_a

If prog_a actually calls prog_b, which calls prog_c, and prog_b is not a profiled COBOL program, then time in prog_b is always recorded in prog_a, while time in prog_c is recorded as explained above.

Parent topic: Profiler


Directives for Profiler

You can use the following directives to control the behavior of the COBOL Profiler.

ALL
Outputs a full performance profile. If you do not set the ALL directive, no statistics are produced for sections or paragraphs that are not entered or PERFORMed
ALPHA
Outputs performance statistics in alphabetical order by paragraph name. If you do not specify ALPHA, statistics are output in descending order of the total percentage time spent in each paragraph.
FORM"integer"
Specifies the page size in lines for the listing file. The minimum value you should specify is 6. The default size is 60 lines.
LIST["destination"]
Specifies where the listing is to be produced.
If destination is specified, the output is written to that file.
If destination is not specified, then the output is sent to the console, with page headings and page throws omitted. The VERBOSE Profiler directive is also set automatically.
If you do not set the LIST Profiler directive, then by default the output is produced in a file called filename.prf, where filename is the first name in the files listed on the command line.
[NO]VERBOSE
Displays on the screen messages output by Profiler. The default setting is NOVERBOSE, unless the LIST directive is set without a specified parameter, in which case VERBOSE is set automatically.
WIDE
Allows lines in the Profiler output to be up to 131 characters wide. If the WIDE directive is not set, lines are truncated to 79 characters.
Parent topic: Profiler
Related information
PROFILE


Hints and Tips

  • Performance Programming
  • Programming Tips
Parent topic: Programming


Performance Programming

There are a range of techniques for maximizing the performance of your COBOL programs. As a general rule, the simpler the operation, the faster it executes and the smaller the compiled code. For the best performance it is often better to use a number of simple operations rather than one complex operation.

  • Optimizing Data Definitions
    Defining data items appropriately and aligning them to give the best performance.
  • Optimizing Arithmetic Statements
    Arithmetic statements, for which simple two-operand statements are the most efficient.
  • Optimizing COMPUTE Statements
    COMPUTE statements, which are for floating-point calculations.
  • Decimal Point Alignment
    Decimal point alignment. For operations on non-integer numbers, make the decimal point alignment of the operands match.
  • Optimizing Exponential Operations
    Exponential operations, some of which are optimized. For others, use MULTIPLY and DIVIDE.
  • Initializing Data Items
    Data item initialization. By default, COBOL initializes all data items in the Working-Storage Section to spaces if no VALUE clause is specified.
  • Optimizing Data Manipulation and Reference Modification
    Data manipulation and reference modification, and how to use the MOVE, INITIALIZE, STRING and UNSTRING statements.
  • Optimizing Table Handling
    Handling tables. For example, make each subscript a COMP-5 item of the smallest optimum size for the values involved, and use the BOUND directive only when debugging.
  • Optimizing Logical Operations
    Logical operations, such as AND, OR and XOR. These are, if possible, optimized to produce in-line code.
  • Optimizing PERFORM Statements
    PERFORM statements. These are generally very efficient, although you can increase their performance in a number of ways.
  • Optimizing CALL Statements
    CALL statements. For example, to use these efficiently, call the program using a literal rather than a data-name, limit the number of CALL statements, and so on.
  • Optimizing Parameter Handling
    Passing parameters. For example. avoid making many references to linkage items.
  • Optimizing File Sorting
    Sorting files.
  • Aligning Bit Data Items
    Aligning bit data.
  • Compiler Directives for Optimizing Code
  • Examples
Parent topic: Hints and Tips


Optimizing Data Definitions

Defining data items appropriately and aligning them to give the best performance.

The performance of your program is affected by the data type, size and alignment of the data items. Using the correct data type increases efficiency, particularly in arithmetic operations.

Use unsigned COMP-5 or COMP-X numeric data items; preferably COMP-5 (where possible).

COMP-5 usage is defined for binary storage with the value stored in the native byte sequence of the processor. This makes it ideal for arithmetic efficiency. However, it is not suitable for data stored in files or passed to other machines over a network as the data is not accessible by programs running in an environment in which COMP-5 is stored in a different sequence. In these cases use COMP-X.

In native code programs, it is more efficient to move integer data items that are not COMP-X or COMP-5 to COMP-5 data items before doing arithmetic operations on them.

The speed in which data items are processed varies according to the type of data item.

Addition and subtraction on non-integer data items is fastest if the items are COMP-5 and the decimal alignment is the same in both.

Mixing different data types in the same statement is less efficient than using the same data types throughout. The main exception to this is mixing COMP-5 and COMP-X items, where there is very little impact on performance.

Use only numeric items that occupy one, two, four or eight bytes of storage.

The fastest and smallest code is produced for operations on items that contain up to nine digits, or four bytes for binary items.

Operations on numeric items that contain more than nine digits, or more than four bytes for binary items, produce the slowest and largest code.

Align items on even-byte boundaries, in general.

Do not redefine COMP-5 items to access individual bytes. If access to individual bytes is required, use COMP-X.

Use edited items only when necessary and use only simple ones such as ZZ9. If possible, use them in a subroutine so that the total number of edited moves in your program is kept to a minimum.

  • Speed of Processing of Different Data Types
  • Aligning Data Items for Efficiency
Parent topic: Performance Programming


Speed of Processing of Different Data Types

The following list shows the order of speed of processing data of different types. This applies to any size of numeric data item. On this COBOL system this applies to integer data items. The list is ordered fastest to slowest.

  • COMP-5
  • COMP-X
  • COMP
  • COMP-3
  • DISPLAY

If the ON SIZE ERROR clause is used, or if the data item is non-integer, the above ordering does not apply. For example, arithmetic on such items uses packed decimal registers inside the In this non-optimized mode the order is:

  • COMP-3
  • DISPLAY
  • COMP
  • COMP-X
  • COMP-5

However, individual cases might behave differently.

  • COMP-5 Performance
  • COMP-X Performance
  • COMP Performance
  • COMP-3 Performance
  • DISPLAY Performance
Parent topic: Optimizing Data Definitions


COMP-5 Performance

Operations on COMP-5 data items are performed as true native binary operations. The fastest performance of COMP-5 is given using the Compiler directive COMP-5"2", the default. See the COBOL On-line Reference for details.

Parent topic: Speed of Processing of Different Data Types


COMP-X Performance

Operations on COMP-X data items are performed as binary operations. The data items are stored in COBOL order, which might not be the same as the native byte order.In this case, arithmetic on items longer than one byte involve operations to change the byte order before the arithmetic can be carried out. This results in slightly slower arithmetic than on COMP-5 items.

Parent topic: Speed of Processing of Different Data Types


COMP Performance

Operations on COMP data items, by default, work as defined in the ANSI standard. This results in truncation of the result of operations before it is stored in a COMP item. This generally results in slower arithmetic than on COMP-X data items. However, if the directives COMP and NOTRUNC are used when the program is compiled, operations on COMP items behave exactly like operations on COMP-X items.

Parent topic: Speed of Processing of Different Data Types


COMP-3 Performance

Arithmetic on COMP-3 data items is performed in packed decimal and is much slower than arithmetic on COMP items. It should be avoided. Arithmetic on COMP-3 data items is slower than DISPLAY items in intermediate code.

Parent topic: Speed of Processing of Different Data Types


DISPLAY Performance

Arithmetic on DISPLAY items is much slower than arithmetic on COMP items, and should be avoided.

  • Arithmetic on DISPLAY items in intermediate code is faster than on COMP-3 items.
  • In generated code, arithmetic on display items can be optimized if the numeric value can be stored in an eight byte COMP-5 item.
Parent topic: Speed of Processing of Different Data Types


Aligning Data Items for Efficiency

Align items on even-byte boundaries. Align numeric items greater than two bytes on four-byte boundaries. Use the ALIGN"4" Compiler directive to ensure that level-01 items are always aligned on such boundaries. Use ALIGN"8" for compatibility with 64-bit systems.

To ensure that all items in a table are correctly aligned, check that the size of an occurrence in the table (the of the table) is a multiple of two or four bytes as required. Pad the table as necessary. For example:

 01 a OCCURS 10.
     03 b PIC X(4) COMP-5
     03 c PIC X.
     03 filler PIC X(3).

A three-byte filler has been added to each occurrence in the table to ensure that the numeric data item is always aligned on a four-byte boundary.

You can use the REF Compiler directive to find out how data items are aligned.

Parent topic: Optimizing Data Definitions


Optimizing Arithmetic Statements

Arithmetic statements, for which simple two-operand statements are the most efficient.

For the best performance from arithmetic statements:

Use simple two-operand arithmetic statements wherever possible. The following operations are optimized for COMP-5 and COMP-X data items up to four bytes long:

 MOVE a TO b
 ADD a TO b
 SUBTRACT a FROM b
 MULTIPLY a BY b
 DIVIDE a INTO b
 IF a condition b

where:

a Is a numeric literal value or data item up to four bytes long

b Is a numeric data item up to four bytes long

On other data items, these simple operations result in faster code than more complex instructions, but the benefits are not as great as with COMP-5 or COMP-X items. More complex forms of these instructions, involving more than two operands, might not produce code which is as efficient as the simple form.

Do not use the GIVING form of the above verbs. If necessary, create temporary data items and code several simple statements to achieve the same result. For example, write:

 MOVE a TO c
 ADD b TO c

rather than:

 ADD a TO b GIVING c

Provided that the operands are all of the same type, statements that contain the GIVING phrase are optimized.

Do not use the REMAINDER, ON SIZE ERROR or CORRESPONDING phrases.

When using the simple operations described above on COMP-5 or COMP-X items, do not use the ROUNDED phrase. In other situations, although the ROUNDED phrase impacts performance, but it is generally faster to use ROUNDED than try to round the result using your own routine.

Do not mix items of different sizes in an arithmetic statement (for example, try to use all two-byte items or all four-byte items).

Parent topic: Performance Programming


Optimizing COMPUTE Statements

COMPUTE statements, which are for floating-point calculations.

Only use COMPUTE statements to perform calculations that involve floating-point data. For floating-point data, COMPUTE is the most efficient statement.

COMPUTE is defined to evaluate its result in a temporary field of the largest possible significance to hold the result. This temporary field might be of a larger significance than is actually required, causing the operations to be slower. The temporary field is stored in the target field with any necessary truncation. This also applies to IF statements involving expressions. For example:

 IF a + b < c

It is often better to define a temporary data item of the required size and use that to hold the result of the arithmetic, as follows:

 MOVE a TO temp
 ADD b TO temp
 IF temp < c
Parent topic: Performance Programming
Related information
Decimal Point Alignment
Exponential Operations
Initializing Data Items


Decimal Point Alignment

Decimal point alignment. For operations on non-integer numbers, make the decimal point alignment of the operands match.

Operations are fastest on integers. Operations on non-integer numbers are most efficient if operands have matching decimal point alignment (that is, the number of decimal positions to the right of the implied decimal point). For example:

  • ADD and SUBTRACT operations are fastest if the source and target have the same decimal alignment.
  • MULTIPLY operations are fastest if the decimal alignment of the target is the sum of the alignments of the sources.
  • DIVIDE operations are fastest if the divisor has no fractional part and if the dividend and the target have the same decimal alignment.
Parent topic: Performance Programming
Related information
COMPUTE Statements
Exponential Operations
Initializing Data Items


Optimizing Exponential Operations

Exponential operations, some of which are optimized. For others, use MULTIPLY and DIVIDE.

Exponential operations in which the exponent is 0.5 (square root), 2 (square) and 3 (cube) are optimized. Other exponential operations are relatively slow as no optimization is carried out for them. Where integer powers are involved, use MULTIPLY and DIVIDE operations instead.

Parent topic: Performance Programming
Related information
COMPUTE Statements
Decimal Point Alignment
Initializing Data Items


Initializing Data Items

Data item initialization. By default, COBOL initializes all data items in the Working-Storage Section to spaces if no VALUE clause is specified.

By default, COBOL initializes all data items in the Working-Storage Section to spaces if no VALUE clause is specified. This includes all numeric items. The effect of arithmetic operations on such an item depends on how the item is used:

Usage | Effect of arithmetic
DISPLAY and COMP-3 | Intermediate code reports run-time error 163 ("Illegal character in numeric field"). Generated code gives unpredictable results.
Any other | Results are unpredictable.

To avoid these problems, initialize all numeric items to numeric values before use.

Parent topic: Performance Programming
Related information
COMPUTE Statements
Decimal Point Alignment


Optimizing Data Manipulation and Reference Modification

Data manipulation and reference modification, and how to use the MOVE, INITIALIZE, STRING and UNSTRING statements.

Reference modified fields are optimized if coded in one of the following forms:

item (literal:)
item (literal:literal)
item (literal:variable)
item (variable:variable)
item (variable + literal:literal)
item (variable - literal:literal)
item (variable + literal:variable)
item (variable - literal:variable)

Other forms of reference modification are inefficient.

If the offset or length of the reference modification is a data item, use a COMP-5 item of the smallest optimum size (one, two or four bytes) that accommodates the range of values involved. Define it in the Working-Storage Section. With this COBOL system, use a four-byte COMP-5 item.

In a MOVE statement, the source item should be the same size as, or larger than, the target. This prevents space-padding code from being generated.

If you try to implement a MOVE between two numeric-edited items, the result is undefined although no error status is returned.

Do not use the CORRESPONDING option of the MOVE verb.

Do not use the INITIALIZE verb.

The STRING or UNSTRING verbs can create a large amount of code. To manipulate filenames use the COBOL System Library Routines CBL_SPLIT_FILENAME and CBL_JOIN_FILENAME. For other purposes, create your own loops as they are almost always more efficient.

Parent topic: Performance Programming
Related information
The MOVE Statement
The INITIALIZE Statement
The USAGE Clause
The STRING Statement
The UNSTRING Statement
CBL_SPLIT_FILENAME
CBL_JOIN_FILENAME


Optimizing Table Handling

Handling tables. For example, make each subscript a COMP-5 item of the smallest optimum size for the values involved, and use the BOUND directive only when debugging.

A subscript should be a COMP-5 item of the smallest optimum size that accommodates the range of values involved. The optimal size for a subscript is four bytes.

Subscripts for items that have the samestride and which are used in consecutive statements are optimized so that they are only evaluated once.

When you compile a program for use in production, use the NOBOUND directive. Use BOUND only when debugging. It causes code to be generated, every time a subscript or index is used, to check that it is within the defined bounds of the table.

If you are using USAGE DISPLAY subscripts, the BOUNDOPT directive (also switched on by NOBOUND) can improve performance.

Access to tables defined with OCCURS ... DEPENDING is less efficient than access to tables of fixed size, and so should be avoided where high performance is needed.

Bound checking on a variable length table checks only if the subscript or index points outside the maximum length of the table. It does not take account of the table's current length (that is, the value of the item specified in the DEPENDING phrase).

Parent topic: Performance Programming
Related information
Example of Optimized Subscripts to Table Elements
Example of Optimizing USAGE DISPLAY Subscripts
BOUNDOPT
BOUND


Optimizing Conditional Statements

IF Statements

In IF statements, conditions within combined conditions are evaluated in the order in which they occur. Therefore, put the conditions that are most likely to produce a false result before others. Similarly, put those conditions that can be evaluated fastest before slower conditions.

Comparisons using EQUALS (=) or NOT EQUAL are faster than comparisons using GREATER (>) or LESS (<). In some systems, comparisons against binary zero are more efficient than against other literal values.

In both alphanumeric and numeric comparisons, make the source and target items the same size.

EVALUATE Statements

Do not use large EVALUATE statements. They are compiled into a series of IF ... ELSE IF ... statements where the value of the expression is derived separately for each WHEN clause.

Order an EVALUATE statement so that the most commonly satisfied condition is tried first. Do not use complex expressions or items defined in the Linkage Section as conditions in an EVALUATE statement; instead, include statements to calculate the value in an item defined in the Working-Storage Section and use that item in the EVALUATE statement.

GO TO Statements

Use a GO TO ... DEPENDING statement if the range of possible values is fairly close. Although this construct is not particularly suited to structured programming, it is efficient.

Related information
The IF Statement
The EVALUATE Statement
The GO TO Statement


Optimizing Logical Operations

Logical operations, such as AND, OR and XOR. These are, if possible, optimized to produce in-line code.

A number of COBOL System Library Routines (call-by-name) are available to perform bitwise logical operations on data items. They perform operations such as AND, OR and XOR.

The Compiler recognizes calls to these routines and, if possible, optimizes them to produce in-line code rather than calls to the run-time system. In-line code is native code which performs the function directly without making any calls. The alternative is a call to a generic run-time routine which must allow for many cases.

The calls are optimized if the length is specified as a literal value. Logical AND and logical OR operations can also be carried out using the VALUE clause.

Parent topic: Performance Programming
Related information
Logic Routines for Bit Manipulation


Optimizing PERFORM Statements

PERFORM statements. These are generally very efficient, although you can increase their performance in a number of ways.

Using PERFORM is generally very efficient, and is a very good way of keeping the size of your program down as well as giving it an easy-to-maintain structure. The following rules enable you to use PERFORM in the most efficient ways.

  • Put commonly used pieces of code in sections and perform them.

    Apart from being good coding practice, this saves space.

  • When you increment or decrement a counter, terminate it with a literal value rather than a value held in a data item. For example, to execute a loop n times, set the counter to n and then decrement the counter until it becomes zero, rather than incrementing the counter from zero to n.
  • Perform sections, not paragraphs. Put EXIT PROGRAM and STOP RUN statements at the end of the first (main) section.

    The range of an out-of-line PERFORM statement should not contain the end of another perform range. If it does, the program is said to trickle, that is execution is allowed to go past the end of a perform range. Applying the rule above ensures that this does not happen.

    If your program does not trickle, you can compile it with the directive NOTRICKLE which causes the Compiler to produce more efficient code since PERFORM is implemented as a machine code CALL instruction with a corresponding RET at the end of the perform range. If NOTRICKLE is used where two perform ranges overlap, results are unpredictable.

    For example, do not use code in the following form:

  • Only use GO TO for paragraphs in the same section.
  • Do not use PERFORM .. THRU statements.
  • Do not use ALTER statements. The presence of an ALTER statement in a program prevents optimization of PERFORM statements.
Parent topic: Performance Programming
Related information
Example of Inefficient Use of the PERFORM Statement
TRICKLE


Optimizing CALL Statements

CALL statements. For example, to use these efficiently, call the program using a literal rather than a data-name, limit the number of CALL statements, and so on.

You can optimise CALL statements in the following ways:

  • Use a literal in a CALL statement rather than a data-name, so that the statement can be optimized. For example:
    CALL "myprog" USING

    is faster than:

    CALL program-name USING

    where program-name is a data item containing the value myprog.

  • In unmanaged code, calling using a procedure pointer is efficient. However in .NET managed code, it is not.
  • Each CALL statement takes time, so try not to arbitrarily split a program into too many subprograms. On the other hand, small dynamically loadable programs make efficient use of memory, and may improve performance even though the calls themselves take time. In which case, use CALL and CANCEL to dynamically load the subprograms when they are needed. Note that cancelling a program does not, by default, free any memory.
  • CALL statements that do not alter the RETURN-CODE special register, or whose effect on RETURN-CODE are of no interest, should use a calling convention of 4. The Compiler directive DEFAULTCALLS can be used to set this globally.
  • Calls to the COBOL system library routines that carry out logical operations, such as CBL_AND, are optimized by the Compiler to actual machine logic operators, provided the parameters are eight bytes long or less and the length parameter is a literal value. These too should use a calling convention of 4.
  • Calls can be made faster by using call convention 256, which eliminates parameter-count checking on individual entry points.
Parent topic: Performance Programming
Related information
Parameter Handling
Call Conventions for Interfacing with Mixed Languages
Logical Operations
Logic Routines for Bit Manipulation
Overview - Mixed Language Programming
Overview - Calling COBOL Programs
DEFAULTCALLS


Optimizing Parameter Handling

Passing parameters. For example. avoid making many references to linkage items.

You can optimize the way parameters are handled as follows:

Put the parameters in the CALL statement in the same order as their descriptions in the called program's Linkage Section.

Ensure that any Linkage Section items that are not referred to in the Procedure Division header appear after those that do.

Avoid making many references to linkage items. These include items that are defined in the Linkage Section, items set to CBL_ALLOC_MEM allocated memory, and items defined as EXTERNAL.

It is always slower to access linkage items than Working-Storage Section items. If a Linkage Section item is used frequently, it is faster to move it into a Working-Storage Section when the program is entered and move it back to the Linkage Section if necessary before returning to the calling program. Instead of the Linkage Section item, the Working-Storage Section item should then be accessed throughout the program.

If a linkage parameter is optional, you can detect its presence using a statement such as:
IF address of linkage-item NOT = null

However, this statement works only if the NOPARAMCOUNTCHECK Compiler directive is specified. This construct is considered poor programming practice.

Parent topic: Performance Programming
Related information
CALL Statements
Linkage Section
CBL_ALLOC_MEM


Optimizing File Sorting

Sorting files.

If you use input and output procedures with a file sort in your program, it is important that you write them efficiently as they are executed once for each record that you are sorting. Inefficient input and output procedures can make the sort process appear to be very slow.

Parent topic: Performance Programming
Related information
The File Control Entry
The I-O-Control Paragraph
The SORT Statement


Aligning Bit Data Items

Aligning bit data.

Alignment of elementary bit data items and bit group items within a record, when an ALIGNED clause is not specified, is at the next bit position in storage when that item is:

  • an elementary bit data item immediately following an elementary bit data item or bit group item of the same level
  • bit group item immediately following a bit group item or elementary bit data item of the same level

Alignment of elementary bit data items of level 1 or level 77 and a level 1 bit group are at the first bit of a byte.

Implicit filler bit positions are generated:

  • Following a bit data item within an alphanumeric group item, within a strongly-typed group item, or within a bit group item, as needed to advance alignment to a required natural boundary for the next item within that group. The filler bit positions are implicitly described as a filler elementary bit data item of the necessary number of bits and of the same level number as the next item within that group.
  • Following a bit data item that is the last data item in a record that is an alphanumeric group or strongly-typed group item, as needed to increase the number of bits to fill an integral number of characters. The filler bit positions are implicitly described as a filler elementary bit data item of the necessary number of bits with a level number the same as the highest hierarchical level of any bit data item superordinate to the last item, or, if there is no such superordinate item, the same as the level number of the last data item in the record.
    Note: No filler is generated at the end of a record that is entirely a bit group, at the end of a level 77 item, or at the end of a level 1 elementary item.

The alignment of the start of a group item and the alignment of the first item within that group, when the first item is a bit data item, are at the same bit position in storage.

Note: Using the SYNCHRONIZED clause has no effect on the alignment of any type of bit data items.
Parent topic: Performance Programming


Compiler Directives for Optimizing Code

A number of Compiler directives can be used to optimize the native code for a program. Some of these directives must be used with care. Ensure that their expected behavior is acceptable for your application.

In general, always use the following directives when compiling your programs to native code:

  • NOALTER
  • ALIGN"4"
  • COMP
  • NOBOUND
  • NOCHECKDIV
  • NOODOSLIDE
  • NOQUALPROC
  • NOSEG
  • NOTRUNC

Use the REMOVE directive to remove the following reserved words:

  • REMOVE "UNSTRING"
  • REMOVE "STRING"
  • REMOVE "GIVING"
  • REMOVE "ROUNDED"
  • REMOVE "COMPUTE"
  • REMOVE "ERROR"
  • REMOVE "ALTER"
  • REMOVE "INITIALIZE"
  • REMOVE "CORRESPONDING"
  • REMOVE "TALLYING"
  • REMOVE "THRU"
  • REMOVE "THROUGH"

By removing these reserved words, you prevent code that uses these inefficient constructs from being added to the program.

You can use directives to optimize your program for speed.

  • Directives that Optimize for Speed
  • Directives that Optimize for Size
Parent topic: Performance Programming


Directives that Optimize for Speed

There are many Compiler directives that you can use to optimize for speed. In some cases, the defaults for directives are the ones that provide speed optimization. The following directives are those that need to be changed from their default values to provide for speed optimization.

  • ALTER
  • BOUND
  • BOUNDOPT
  • COMP
  • FASTLINK
  • LITLINK
  • OPT
  • SCHEDULER
  • TARGET
  • TRUNC
Parent topic: Compiler Directives for Optimizing Code
Related reference
ALTER
BOUND
BOUNDOPT
COMP
FASTLINK
LITLINK
OPT (Intel x86 platforms)
OPT (Non-Intel x86 platforms)
SCHEDULER
TRUNC


Directives that Optimize for Size

There are many Compiler directives that you can use to optimize for size. In some cases, the defaults for directives are the choices that provide size optimization. The following directives are ones that need to be changed from their default values to provide for size optimization.

  • ALIGN
  • OPT
Parent topic: Compiler Directives for Optimizing Code
Related reference
ALIGN
OPT (Intel x86 platforms)
OPT (Non-Intel x86 platforms)


Examples

  • Example of Inefficient Use of the PERFORM Statement
  • Example of Optimized Subscripts to Table Elements
  • Example of Optimizing USAGE DISPLAY Subscripts
Parent topic: Performance Programming


Example of Inefficient Use of the PERFORM Statement

An example of code that uses PERFORM in a way that might give unexpected results, becuase they depend on the setting of the “perform-type” directive. This is also poor programming style.

 procedure division.
     perform a thru c
     perform b thru d
     stop run.
 a.
     display "a".
 b.
     display "b".
 c.
     display "c".
 d.
     display "d".
Parent topic: Examples


Example of Optimized Subscripts to Table Elements

The following code shows the use of optimized subscripts:

 01 a pic xx occurs 10.
 01 b pic xx occurs 10.
 01 c pic xx occurs 10.
 01 d pic xx occurs 10.
  ...
     move a(i) to b(i)
     if c(i) = d(i)
         display "pass"
     end if

The result would be that the subscript i would be evaluated only once, although it is used four times in two statements. The stride of each of these tables is the same: two.

Parent topic: Examples


Example of Optimizing USAGE DISPLAY Subscripts

The following code shows the use of USAGE DISPLAY subscripts:

  ...
 01 array   pic x occurs 20.
 01 array-index pic 9(5) value 2.
  ...
     move "a" to array(array-index).
  ...

If the program is compiled without BOUNDOPT, all five digits of array-index are used to evaluate the subscript. If BOUNDOPT is specified, only the last two digits of array-index are used, as only two digits are needed to access all elements of a 20 element table. However, it is much more efficient to use comp-5 subscripts.

Parent topic: Examples


Programming Tips

There is a range of programming of techniques for designing and writing COBOL applications.

  • Accessing Data on the Command Line from COBOL
  • Accessing Environment Variables from COBOL
  • Manipulating Data with Reference Modification and STRING
  • Writing Recursive Routines
  • Coding an Intrinsic Function
  • Manipulating Bits
  • Examples
Parent topic: Hints and Tips
Related information
Overview - Mixed Language Programming
Overview - Performance Programming


Accessing Data on the Command Line from COBOL

You can use the following methods to enable a program to access and use data on the command line:

  • To move the complete contents of the command line to a data-name, use ACCEPT data-name FROM COMMAND-LINE. For example:
    …
working-storage section.
01 cmdline pic x(100).

procedure division.
accept cmdline from command-line
…
  • To access individual arguments on the command line, use one of the following:
    • DISPLAY ... UPON ARGUMENT-NUMBER
    • ACCEPT ... FROM ARGUMENT-NUMBER
In managed COBOL, you can use the following construct:
    program-id. Program1.
    data division.
    Procedure division using by value cmds as string occurs any.
    Perform varying s as string thru CMDS
            Display s
           End-perform

Comments:

Only in native COBOL can you use the command_line_linkage run-time system tunable to have parameters passed to your main program.

Parent topic: Programming Tips
Related reference
command line linkage
Related information
The ACCEPT Statement


Accessing Environment Variables from COBOL

Use the following construct to access environment variables from the your COBOL source code:

working-storage section.
01 val pic x(100).
Procedure division.

display "USERNAME" upon environment-name
accept val from environment-value
display val
goback.
...
Parent topic: Programming Tips
Related information
Accessing Data on the Command Line


Manipulating Data with Reference Modification and STRING

You can manipulate data items in detail in two ways:

  • The STRING statement. This statement concatenates the partial or complete contents of two or more data items and stores the result.

    In general, using STRING is easier to read and implement. However, it can be resource-intensive, particularly if used many times in a program. You can use STRING in programs that do not incur a lot of overhead for other reasons, such as significant file I/O.

  • Reference modification. This technique enables you to make references to (and change) parts of a data item by starting values, for a specified length.

    Reference modification is more efficient, but can lead to code that is more difficult to read and maintain. It is a way to improve performance in programs that use STRING heavily and are running slowly or growing too large.

For example, the following two statements are equivalent. In both examples, street-address is 25 bytes long:

STRING street-address DELIMITED BY SIZE INTO print-rec
    WITH POINTER num-char
MOVE street-address TO print-rec (num-char: 25)
Parent topic: Programming Tips


Writing Recursive Routines

A recursive routine is a routine that calls itself. Recursion is the most natural method of solving certain problems, such as:

  • Searching a tree
  • Calculating certain mathematical functions
  • Following paths through a network
  • Processing a bill of materials
  • Choosing the best solution from a set of possible solutions

Although you can write any recursive routine as a straight iterative routine, the use of a recursive routine can simplify the program's logic.

In this COBOL system, a program can be recursive provided it is not nested inside another program and it has a Local-Storage Section. A program can call itself via either its program-id or an entry point.

Each call of a recursive routine is called an instance. Each instance needs a different set of the data items used by the routine; so this COBOL system enables you to have a Local-Storage Section. A run-time error message is issued if you try to use recursion in a program that does not contain a Local-Storage Section.

See Related information for examples of recursion and recursive routines.

A more extensive illustration of recursive routines can be seen in the example program diophant.cbl. This program solves the linear equation Ax + By = 0 for integers x and y.

See Related information for the example program diophant.cbl.

Parent topic: Programming Tips


Coding an Intrinsic Function

A function is a temporary data item whose value is determined when the function is referenced during execution. Your COBOL system provides a library of intrinsic functions.

As an example of an intrinsic function, consider the following statement:

COMPUTE x = FUNCTION COS(y)

The intrinsic function cos computes a numeric value that approximates the cosine of an angle (expressed in y radians) and stores that value in x.

Parent topic: Programming Tips


Manipulating Bits

When you program in a COBOL environment, you deal with data that is composed of characters, fields, records, or files. However, there are occasions when you must deal with individual data bits. For example, bit manipulation is an important feature in applications that deal with:

  • Screen and graphics interfaces
  • Encryption techniques
  • System-level routines
  • Table lookup, that is, converting an incoming code to an expanded value
  • Packing and unpacking data

Manipulating Bits with Logic Routines

There is a set of library routines for bit manipulation. These routines are:

CBL_NOT | logical NOT
CBL_AND | logical AND
CBL_OR | logical OR
CBL_EQ | logical EQuivalence
CBL_XOR | logical eXclusive OR
CBL_IMP | logical IMPlies

These logical operations give the results shown in the following truth table.

A |  | 0 | 0 | 1 | 1
B |  | 0 | 1 | 0 | 1
CBL_NOT | (not A) | 1 | 1 | 0 | 0
CBL_AND | (A AND B) | 0 | 0 | 0 | 1
CBL_OR | (A OR B) | 0 | 1 | 1 | 1
CBL_EQ | (A EQ B) | 1 | 0 | 0 | 1
CBL_XOR | (A XOR B) | 0 | 1 | 1 | 0
CBL_IMO | (A IMP B) | 1 | 1 | 0 | 1

For example, when the CBL_EQ routine compares bits A and B, the resulting bit is set to 1 if both A and B are 0 or if both A and B are 1. Otherwise the resulting bit is set to 0.

Manipulating Bits as Boolean Data Items

You can also define data items as boolean using picture character 1, and use the boolean operators B-AND, B-OR, B-XOR, and B-NOT to perform "and", "or", "exclusive or", and "negate" operations. These operators are used in boolean expressions; for example:

 01 My-flag PIC 1111 USAGE BIT VALUE B"0000".
01 My-flag-2 PIC 1111 USAGE BIT.
...
MOVE B"0011" to My-flag-2 *> Initialize My-flag-2
...
COMPUTE My-flag = B-NOT My-flag-2 *> set the bits in My-flag to the
*> reverse of My-flag-2, 1100.
...
COMPUTE My-flag = My-flag B-AND B"0000" *> turn off all the bits in My-flag.
...
COMPUTE My-flag-2 = My-flag-2 B-OR B"1000" *> set bit 1 ON in My-flag-2, keeping
*> other bits unchanged.

Boolean items can be tested in two ways:

  • as a boolean condition, if the length of an item is 1 bit position or 1 character position; for example:
    01 Single-bit-item pic 1 usage bit.
01 Multiple-bit-item pic 1(7) usage bit.
...
IF Single-bit-item THEN CALL a-program *> calls if Single-bit-item is true (1)
  • as a relation condition, testing for equal or not equal; for example:
    IF My-flag-2 EQUAL B"1000" THEN CALL a-program

Converting boolean data items to integers

Boolean items can be converted to integer with the INTEGER-OF-BOOLEAN intrinsic function, and integer items can be converted to boolean with the BOOLEAN-OF-INTEGER intrinsic function. For example:

01 bit-item PIC 1(6) usage BIT.

01 integer-item PIC 9(5) VALUE 544. *>  1000100000 in binary
01 integer-item-2 PIC 9(3).
...
MOVE FUNCTION BOOLEAN-OF-INTEGER ( integer-item , 6) TO bit-item.
*> the function returns the low order 6 bits of the binary representation of the
*> integer value, and MOVE stores it in bit-item, padding on the right with 0’s
...
COMPUTE integer-item-2 = FUNCTION INTEGER-OF-BOOLEAN (bit-item).
*> the function returns the numeric value of the leading 6 bits (100000 in binary), 32, and
*> COMPUTE puts 032 in integer-item-2
Parent topic: Programming Tips


Examples

  • Example of Recursion
  • Example of Recursive Routines
  • Example of Intrinsic Functions
  • Example of Bit Manipulation
Parent topic: Programming Tips


Example of Recursion

In the following example, the table in the item family-tree contains an entry for each of Fred Smith's descendants. Assume the data has been put in the table by an earlier program. The first entry is Fred Smith's own. Each entry contains, as well as the person's name, a data item called eldest-pointer containing the position in the table of the entry for that person's eldest child. Someone with no children has 99 in this item. Similarly each entry has a data item sibling-pointer pointing to the entry for the person's next younger sibling. Someone with no younger siblings has 99 in this item.

An example that shows how to use recursion to search a family tree:

 identification division.
 program-id. family.
    . . .
 working-storage section.
 01  family-tree.
     03  individual    occurs 50.
         05  ind-name           pic x(30).
         05  eldest-pointer     pic 9(2).
         05  sibling-pointer    pic 9(2).

 local-storage section.
 01  tree-pointer      pic 9(2).

 linkage section.
 01  parent-pointer    pic 9(2).

 procedure division.
     move 1 to tree-pointer
     call "children" using tree-pointer
     stop run.

* If this person has no eldest child, routine "children"
* displays the person's name and does nothing more. Otherwise,
* this routine starts with the person's eldest child and calls
* itself for each sibling in turn.
 entry "children" using parent-pointer
     move eldest-pointer(parent-pointer) to tree-pointer
     if tree-pointer = 99
         display ind-name(parent-pointer)
     else
         perform until tree-pointer = 99
             call "children" using tree-pointer
             move sibling-pointer(tree-pointer)to tree-pointer
         end-perform
     end-if.
Parent topic: Examples


Example of Recursive Routines

The following sample code illustrates some of the features of a recursive routine. This routine, identified by the entry point factorl, computes the factorial of a number that you enter.

 1 working-storage section.
 2 01 n             pic x(4) comp-x.
 3 01 factorial     pic x(4) comp-x.
 4 01 m             pic x(4) comp-x.
 5
 6 local-storage section.
 7
 8 procedure division.
 9     accept n
10     move 1 to factorial
11     call 'factorl' using n
12     display 'factorial of ' n ' is ' factorial
13     stop run.
14
15 entry 'factorl' using m.
16     if m < 1
17         move 1 to factorial
18     else
19         if m > 1
20             multiply m by factorial
21             subtract 1 from m
22             call 'factorl' using m
23         end-if
24     end-if
25
26     exit program.
Note:
  • Line 6

    local-storage section

    Since the recursive routine can be called several times, the local data from one call must be protected from another call to the same code. This protection is done using a Local-Storage Section. Each time a new instance of the routine starts, an initialized copy of this section is created in memory. If you try to use recursion in a program that does not contain a Local-Storage Section, an RTS error message is issued.

    Notice that this routine does not have any local storage data items, but it still requires the local storage declaration.

  • Line 15

    entry 'factorl' using m

    This is the entry point of the recursive routine factorl. A program can call itself via its Program-ID or an entry point.

  • Lines 19-23

    if m > 1

    multiply m by factorial

    subtract 1 from m

    call 'factorl' using m

    end-if

    This loop contains the recursive call.

  • Line 22

    call 'factorl' using m

    The recursive call statement.

Parent topic: Examples


Example of Intrinsic Functions

This example program, intrins.cbl, shows some of the ways you can use intrinsic functions in your programs.

Note:

There are three types of intrinsic function: integer, numeric and alpha. The FACTORIAL function used in the sample below is a numeric function. The coding technique shown might not apply for the other function types.

  1$set mf noosvs ans85
  2
  3*************************************************************
  4* Copyright Micro Focus Limited 1991. All Rights Reserved.  *
  5* This demonstration program is provided for use by users   *
  6* of Micro Focus products and may be used, modified and     *
  7* distributed as part of your application provided that you *
  8* properly acknowledge the copyright of Micro Focus in this *
  9* material.                                                 *
 10*************************************************************
 11
 12*************************************************************
 13*                                                           *
 14*                     INTRINS.CBL                           *
 15*                                                           *
 16*    This program demonstrates some of the ways you can     *
 17*    use Intrinsic Functions in your COBOL application.     *
 18*    This program uses the FACTORIAL Intrinsic Function     *
 19*    to illustrate the following capabilities:              *
 20*                                                           *
 21*    1) Data item is assigned the value of a function       *
 22*    2) Function is used as a data item in an EVALUATE      *
 23*           statement                                       *
 24*    3) Function is used as a data item in an IF            *
 25*           statement                                       *
 26*    4) Function uses an array element (fixed index) as     *
 27*           an argument                                     *
 28*    5) Function uses an array element (variable index)     *
 29*           as an argument                                  *
 30*    6) Data item is assigned the value of a function of    *
 31*           a function                                      *
 32*    7) Data item, assigned the value of the function,      *
 33*           is used in a COMPUTE statement                  *
 34*    8) Data item is assigned the value of the sum of       *
 35*           two functions                                   *
 36*    9) Function is used in the UNTIL condition of a        *
 37*           PERFORM ... UNTIL statement                     *
 38*                                                           *
 39*                                                           *
 40*    To familiarize yourself with the Intrinsic function    *
 41*    syntax, try running INTRINS under Debugger.            *
 42*                                                           *
 43*    Compile the program using:                             *
 44*                                                           *
 45*           COBOL INTRINS ANIM;                             *
 46*                                                           *
 47*    then debug the program:                                *
 48*                                                           *
 49*           ANIMATE INTRINS                                 *
 50*                                                           *
 51*                                                           *
 52*                                                           *
 53*                                                           *
 54*                                                           *
 55*************************************************************
 56 working-storage section.
 57 78 fals value 0.
 58 78 tru  value 1.
 59
 60 01 true-or-false               pic 9(1).
 61
 62 01 factor                      pic s9(10).
 63
 64 01 val                         pic s9(10).
 65
 66 01 indx                        pic 9(5) comp-x.
 67
 68 01 arg                         pic 9(2) comp-x  value 5.
 69
 70 01 arr                                         value "40537".
 71     03 elem   occurs 5 times   pic 9.
 72
 73 procedure division.
 74
 75 main-section.
 76
 77************************************************************
 78* Form 1 - Data item is assigned the value of the function *
 79************************************************************
 80
 81     compute factor = function factorial(0)
 82
 83************************************************************
 84* Form 2 - Function is used as a data item in an EVALUATE  *
 85*          statement                                       *
 86************************************************************
 87
 88     evaluate function integer(6.5)
 89      when 6
 90         move tru to true-or-false
 91      when other
 92         move fals to true-or-false
 93     end-evaluate
 94
 95************************************************************
 96* Form 3 - Function is used as a data item in an IF        *
 97*          statement                                       *
 98************************************************************
 99
100     if function integer (function factorial(arg)) = 120 then
101         move tru to true-or-false
102     else
103         move fals to true-or-false
104     end-if
105
106  ************************************************************
107  * Form 4 - Function uses an array element (fixed index) as *
108  *          an argument                                     *
109  ************************************************************
110
111     compute factor = function factorial(elem(4))
112
113  ************************************************************
114  * Form 5 - Function uses an array element (variable index) *
115  *          as an argument                                  *
116  ************************************************************
117
118       move 4 to indx
119       compute factor = function factorial(elem(indx))
120
121  ************************************************************
122  * Form 6 - Data item is assigned the value of a function   *
123  *          of a function                                   *
124  ************************************************************
125
126     compute factor = function factorial(
127                        function factorial(3))
128
129  ************************************************************
130  * Form 7 - Data item, assigned the value of the function,  *
131  *          is used in a COMPUTE statement                  *
132  ************************************************************
133
134     compute val = function factorial(3) + 5
135
136  ************************************************************
137  * Form 8 - Data item is assigned the value of the sum of   *
138  *          two functions                                   *
139  ************************************************************
140
141     compute val = function factorial(3) +
142                   function factorial(5)
143
144  ************************************************************
145  * Form 9 - Function is used in the UNTIL condition of a    *
146  *          PERFORM ... UNTIL statement                     *
147  ************************************************************
148
149     move 1 to indx
150     perform para-1 until function integer (function
151           factorial(indx))  = 120
152     stop run.
153
154 para-1.
155     compute indx = indx + 1.
Note:
  • Line 81
     compute factor = function factorial(0)

    Data item is assigned the value of the function

  • Lines 88-93
     evaluate function integer(6.5)
  when 6
     move tru to true-or-false
  when other
     move fals to true-or-false
 end-evaluate

    Function is used as a data item in an EVALUATE statement

  • Lines 100-104
     if function integer (function factorial(arg)) = 120 then
     move tru to true-or-false
 else
     move fals to true-or-false
 end-if

    Function is used as a data item in an IF statement

    The result of a numeric function is in floating-point format, so it cannot be expected to hold an exact integer value. In this example, the integer function is used to obtain an exact integer value for the IF statement.

  • Line 111
     compute factor = function factorial(elem(4))

    Function uses an array element (fixed index) as an argument

  • Lines 118-119
     move 4 to indx
 compute factor = function factorial(elem(indx))

    Function uses an array element (variable index) as an argument

  • Lines 126-127
     compute factor = function factorial (function factorial(3))

    Data item is assigned the value of a function of a function

  • Line 134
     compute val = function factorial(3) + 5

    Data item, assigned the value of the function, is used in a COMPUTE statement

  • Lines 141-142
     compute val = function factorial(3) + function factorial(5)

    Data item is assigned the value of the sum of two functions

  • Lines 149-155
        move 1 to indx
    perform para-1 until function integer (function
       factorial(indx)) = 120
  stop run.

 para-1.
    compute indx = indx + 1.

    Function is used in the UNTIL condition of a PERFORM ... UNTIL statement

Parent topic: Examples


Example of Bit Manipulation

The sample program logoper.cbl, shown below, illustrates the use of bit manipulation routines. It uses three of the logical call-by-name routines, namely, CBL_OR, CBL_AND, and CBL_XOR.

working-storage section.
01  clr-char            pic x value space.
01  clr-attr            pic x value x"0f".

78  text-start          value 29.
78  text-len            value 23.
78  text-end            value 51.

01  text-scr-pos.
    03  text-row        pic 9(2) comp-x value 12.
    03  text-col        pic 9(2) comp-x value text-start.
01  text-char-buffer    pic x(text-len)
                        value "Text-in-various-colours".
01  text-attr-buffer.
    03  first-word      pic x(4) value all x"0f".
    03  second-word     pic x(4) value all x"2c".
    03  third-word      pic x(7) value all x"14".
    03  third-space     pic x value x"30".
    03  fourth-word     pic x(7) value all x"59".
01  text-length         pic 9(4) comp-x value text-len.

01  char-read           pic x.
01  char-length         pic 9(9) comp-5 value 1.

01  quit-flag           pic 9 comp-x.
    88 not-ready-to-quit    value 0.
    88 ready-to-quit        value 1.

01  csr-pos.
    03  csr-row         pic 9(2) comp-x value 12.
    03  csr-col         pic 9(2) comp-x value 39.
01  csr-attr            pic x.
01  csr-length          pic 9(4) comp-x value 1.

01  blink-mask          pic x value x"80".
01  steady-mask         pic x value x"7f".

01  invert-mask         pic x(text-len) value all x"7f".

78  instr-len           value 41.
01  instr-length        pic 9(4) comp-x value instr-len.
01  instr               pic x(instr-len)
        value "Press (L)eft, (R)ight, (I)nvert or (Q)uit".
01  instr-pos.
    03  instr-row       pic 9(2) comp-x value 8.
    03  instr-col       pic 9(2) comp-x value 19.

procedure division.

main section.
    perform init-screen
    set not-ready-to-quit to true
    perform until ready-to-quit
        perform read-keyboard
        evaluate char-read
            when "L"
                perform csr-move-left
            when "R"
                perform csr-move-right
            when "I"
                perform invert-text
            when "Q"
                set ready-to-quit to true
        end-evaluate
    end-perform
    stop run
    .

init-screen section.
    call "CBL_CLEAR_SCR" using clr-char
                               clr-attr
    call "CBL_WRITE_SCR_CHARS" using instr-pos
                                     instr
                                     instr-length
    call "CBL_WRITE_SCR_CHARS" using text-scr-pos
                                     text-char-buffer
                                     text-length
    perform put-attrs-on-screen
    perform blink-cursor
    .

read-keyboard section.
    call "CBL_READ_KBD_CHAR" using char-read
    call "CBL_TOUPPER" using char-read
                             by value char-length
    .

csr-move-left section.
    perform steady-cursor
    subtract 1 from csr-col
    if csr-col < text-start
        move text-end to csr-col
    end-if
    perform blink-cursor
    .

csr-move-right section.
    perform steady-cursor
    add 1 to csr-col
    if csr-col > text-end
        move text-start to csr-col
    end-if
    perform blink-cursor
    .

blink-cursor section.

*> Turn on the blink bit at the current attribute.

    call "CBL_READ_SCR_ATTRS" using csr-pos
                                    csr-attr
                                    csr-length
    call "CBL_OR" using blink-mask
                        csr-attr
                        by value 1
    call "CBL_WRITE_SCR_ATTRS" using csr-pos
                                     csr-attr
                                     csr-length
    .

steady-cursor section.

*> Turn off the blink bit at the current attribute.

    call "CBL_READ_SCR_ATTRS" using csr-pos
                                    csr-attr
                                    csr-length
    call "CBL_AND" using steady-mask
                         csr-attr
                         by value 1
    call "CBL_WRITE_SCR_ATTRS" using csr-pos
                                     csr-attr
                                     csr-length
    .

invert-text section.

*> invert the bits that set the foreground colour, the background
*> colour, and the intensity bits, but leave the blink bit alone.

    call "CBL_READ_SCR_ATTRS" using text-scr-pos
                                    text-attr-buffer
                                    text-length
    call "CBL_XOR" using invert-mask
                         text-attr-buffer
                         by value text-len
    perform put-attrs-on-screen
    .

put-attrs-on-screen section.
    call "CBL_WRITE_SCR_ATTRS" using text-scr-pos
                                     text-attr-buffer
                                     text-length
    .

In the sample program, the section blink-cursor makes the cursor character (the character the cursor is pointing to) blink by its attributes. To see how you would create code to make the cursor blink, first consider the form of the display attribute. The following table shows the structure of the attribute byte for a personal computer with a monochrome display.

Bit | Attribute
7 | Blink
6-4 | Turns off display or sets reverse video
3 | Intensity
2-0 | Normal or underline select

Thus, for example, setting bit 7 to 1 turns blinking on. In the Working-Storage Section of the program, the mask for the "blink" attribute is defined as:

01 blink-mask pic x value x"80".

This hex value translates to the following bit pattern:

1 0 0 0 0 0 0 0

The CBL_READ_SCR_ATTRS routine reads the current attributes of the screen into an attribute buffer that in this case is one character long.

     call "CBL_READ_SCR_ATTRS" using csr-pos
                                     csr-attr
                                     csr-length

The CBL_OR routine does a logical OR on the current attributes and the blinking mask. This in effect turns on the blinking attribute. Note that the length parameter is 1. This says the OR operation is for one byte.

     call "CBL_OR" using blink-mask csr-attr by value 1

The CBL_WRITE_SCR_ATTRS routine writes the updated attributes buffer to the screen causing the character to "blink".

     call "CBL_OR" using blink-mask
                         csr-attr
                         by value 1
Parent topic: Examples


General Reference

  • C Functions for Calling COBOL
  • COBOL Language Reference
  • Command Line Reference
  • Compiler Directives
  • Configuring CCI
    Configuring the Common Communications Interface used by many Micro Focus products for distributed applications.
  • Licensing
  • Configuring Environment Variables
  • Error Messages
  • File Handling Reference
  • Integrated Preprocessor Interface
  • Library Routines
  • Restrictions, Compiler Limits, and System Limits
  • Mainframe Reference
  • Managed COBOL
  • Open PL/I Language Reference Manual
  • Run-time System Configuration
Parent topic: Micro Focus Studio Enterprise Edition 6.0


C Functions for Calling COBOL

Restriction: These functions are supported for native COBOL only.

This section lists the functions that you can use from C programs to call COBOL. For more information about using these functions, see the topic Interfacing with C Programs.

  • cobcall
    Calls a COBOL program, subprogram or entry point from C.
  • cobcancel
    Cancels a program previously loaded by the COBOL run-time system.
  • cobcols
    Returns the number of columns on the screen.
  • cobcommandline
    Sets up the COBOL command line.
  • cobexit
    Closes down the global COBOL run-time environment.
  • cobfunc
    Calls a COBOL program, subprogram or entry point and then cancels it.
  • cobget
    Converts COBOL-based data to native C language types. There are a number of cobget functions, each for a different type of COBOL data.
  • cobgetenv
    Obtains the value of an environment variable.
  • cobgetfuncaddr
    Returns a function pointer to a COBOL program, subprogram or entry point.
  • cobinit
    Initializes the COBOL environment, so that a COBOL program can be called from a non-COBOL program.
  • coblines
    Returns the number of lines on the screen.
  • coblongjmp
    With the cobsetjmp function, provides the capability of a non-local GO TO, for use in error or exception handling.
  • cobpostsighandler
    Adds the specified handler to the list of handlers for the specified signal, at the specified priority.
  • cobput
    Converts data from native C language types to COBOL types. There are a number of cobput functions, each for a different type of COBOL data.
  • cobputenv
    Dynamically changes the value of an environment variable.
  • cobremovesighandler
    Removes a posted handler from the list of handlers for a signal.
  • cobrescanenv
    Causes the run-time system to rescan the environment for COBOL environment strings.
  • cobsetjmp
    With the coblongjmp function, provides the capability of a non-local GO TO, for use in error or exception handling.
  • cobthreadtidy
    Tidies up the thread-local COBOL run-time environment.
  • cobtidy
    Tidies up the global COBOL run-time environment.
Parent topic: General Reference
Related information
Interfacing with C Programs


cobcall

Calls a COBOL program, subprogram or entry point from C.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobcall.h"

cobrtncode_t cobcall (const cobchar_t *name, int argc,
                      cobchar_t **argv);

Parameters:

name | A null-terminated string that specifies the name of the COBOL program to be called
argc | The number of arguments passed in argv
argv | Arguments to be passed to the COBOL program

Comments:

This function is used to call the COBOL program of the specified name using the arguments passed in argv. Parameters are passed BY REFERENCE.

The result of a cobcall() is a COBOL type call as defined in the ANSI '74 standard and behaves in the same way as if the COBOL entry point had been called from COBOL.

Using this function is equivalent to calling a COBOL program directly from C code, using C syntax.

If the specified name is an entry point of an already loaded COBOL program, that program is called. Alternatively, if the specified name is a C function, then that is called. Otherwise, a program with a basename of the specified name is searched for on disk using the standard COBOL search order and paths. You can change the program search order using the program_search_order run-time tunable.

If no program of the specified name can be found a run-time error is produced.

If the COBOL entry point does not expect any arguments then argc should be 0 and argv should be NULL.

Equivalent COBOL Syntax:

call "name" [using ...] [returning ...]

Example:

To call a COBOL entry point cobep with two string arguments from a C function, use either:

cobchar_t *argv[2];
argv[0] = arg1;
argv[1] = arg2;
cobcall("cobep", 2, argv);

or:

cobep(arg1, arg2);
Parent topic: C Functions for Calling COBOL
Related reference
cobgetfuncaddr


cobcancel

Cancels a program previously loaded by the COBOL run-time system.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobcall.h"

void cobcancel (const cobchar_t *name);

Parameters:

name A null terminated string that specifies the name of the COBOL program to be canceled.

Comments:

If name is a COBOL program, the data contained in the program is returned to its initial state as defined for the COBOL CANCEL verb.

If name is a C function then its data is unchanged.

If name does not correspond to any loaded COBOL entry point or C function no action occurs and this function returns as normal.

Equivalent COBOL Syntax:

cancel "name"

Example:

To cancel the COBOL entry point cobep:

cobcancel("cobep");
Parent topic: C Functions for Calling COBOL
Related information
The CANCEL Statement


cobcols

Returns the number of columns on the screen.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobscreen.h"

int cobcols (void);

Parameters:

None.

Comments:

This function returns the width in columns of the screen.

Equivalent COBOL Syntax:

call "CBL_GET_SCR_SIZE" using ...

Example:

To find out and display the width of the screen use:

int width = cobcols();

printf("Width of screen = %d\n", width);
int width = cobcols();

cobprintf("Width of screen = %d\n", width);
Parent topic: C Functions for Calling COBOL


cobcommandline

Sets up the COBOL command line.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobcall.h"

cobchar_t *cobcommandline(int flags, int *argcp,
           cobchar_t ***argvp, cobchar_t ***envpp,
           cobchar_t **namep);

Parameters:

flags | Reserved for future use. Must be 0.
argcp | Address of the argc argument passed to the C main().
argvp | Address of the argv argument passed to the C main().
envpp | Address of the envp argument passed to the C main().
namep | Reserved for future use. Should be NULL.

Comments:

This routine sets up the COBOL run-time environment with the passed command line.

If your application has a C main() and the command line is accessed from COBOL, then this routine must be called.

Equivalent COBOL Syntax:

None.

Example:

The following example shows how to use this routine:

main(int argc, char **argv, char **envp)
{
    cobinit();
    cobcommandline(0, &argc, &argv, &envp, NULL);

    /* Rest of code here */

    cobexit(0);
}
Parent topic: C Functions for Calling COBOL


cobexit

Closes down the global COBOL run-time environment.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobmain.h"

void cobexit (cobrtncode_t exitstatus);

Parameters:

exitstatus The exit status returned to the calling process.

Comments:

This function terminates a running application in the same way as if a COBOL STOP RUN statement had been executed, emptying buffers, closing files and freeing any data areas allocated by the COBOL system.

You must use the cobexit() function to exit from non-COBOL applications rather than just using the C library function exit().

This function will ultimately call exit() and so will not return.

The specified exit status is returned to the calling process. Standard operating system practice is to use an exit status of 0 on success.

The COBOL run-time system returns values of -1 (255) and -2 (254) if it exits due to an error or signal.

Equivalent COBOL Syntax:

stop run

Example:

To exit an application that has used COBOL, returning an error value of +123 to the parent process, use

cobexit(123);.
Parent topic: C Functions for Calling COBOL


cobfunc

Calls a COBOL program, subprogram or entry point and then cancels it.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobcall.h"

cobrtncode_t cobfunc (const cobchar_t *name, int argc,
                     cobchar_t **argv);

Parameters:

name | A null-terminated string that specifies the name of the COBOL program or entry point to be called
argc | The number of arguments passed in argv
argv | Arguments to be passed to the COBOL program

Comments:

This function has the same effect as specifying cobcall() and then cobcancel(). That is, it calls the specified program and then cancels it, leaving the data contained in the program in its initial state. See the descriptions of cobcall() and cobcancel() for more details.

This function, unlike cobcall(), causes the program to behave as if it had been called using C function rules rather than COBOL call rules. cobfunc() returns the return code of the called program.

Equivalent COBOL Syntax:

call "name" [using ...] [returning ...]
cancel "name"

Example:

To call and then cancel a COBOL entry point cobep which takes no arguments use:

cobfunc("cobep", 0, NULL);
Parent topic: C Functions for Calling COBOL
Related reference
cobcall
cobcancel


cobget

Converts COBOL-based data to native C language types. There are a number of cobget functions, each for a different type of COBOL data.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cbltypes.h"    /* Includes cbltypes.h and cobgetput.h */

cobuns8_t   cobget_x1_compx(const cbl_x1_compx_t *cbldata);
cobuns16_t  cobget_x2_compx(const cbl_x2_compx_t *cbldata);
cobuns32_t  cobget_x4_compx(const cbl_x4_compx_t *cbldata);
cobuns64_t  cobget_x8_compx(const cbl_x8_compx_t *cbldata);

cobuns8_t   cobget_x1_comp5(const cbl_x1_comp5_t *cbldata);
cobuns16_t  cobget_x2_comp5(const cbl_x2_comp5_t *cbldata);
cobuns32_t  cobget_x4_comp5(const cbl_x4_comp5_t *cbldata);
cobuns64_t  cobget_x8_comp5(const cbl_x8_comp5_t *cbldata);

cobs8_t     cobget_sx1_comp5(const cbl_sx1_comp5_t *cbldata);
cobs16_t    cobget_sx2_comp5(const cbl_sx2_comp5_t *cbldata);
cobs32_t    cobget_sx4_comp5(const cbl_sx4_comp5_t *cbldata);
cobs64_t    cobget_sx8_comp5(const cbl_sx8_comp5_t *cbldata);

cobuns64_t  cobget_xn_comp5(const cbl_x1_t *cbldata, cobuns8_t n);
cobuns64_t  cobget_xn_compx(const cbl_x1_t *cbldata, cobuns8_t n);

cobs64_t    cobget_sxn_comp5(const cbl_x1_t *cbldata, cobuns8_t n);

void       *cobget_pointer(const cbl_pointer_t *cbldata);
PFR         cobget_ppointer(const cbl_ppointer_t *cbldata);

Parameters:

cbldata | Pointer to the COBOL data item and data description as indicated by the cobget function name.
n | For cobget_xn_ functions. Describes the number of COBOL character positions cbldata occupies.

Comments:

The cobget_xn_compx functions enable you to extract data from data items with descriptions such as PIC X(3).

Equivalent COBOL Syntax:

None.

Example:

COBOL program:

program-id.  mycblprog.

 copy "cbltypes.cpy".

 01  myrec.
      05 myrec-key   		cblt-x4-compx value 10.
 procedure division.
     call 'mycprog'  using myrec-key
     if  myrec-key = 20
         display "First call to 'mycblprog'"
     else
         display "Subsequent call to 'mycblprog'"
     end-if
     exit program
 end program mycblprog.

C program:

#include "cbltypes.h"
 void
 mycprog(cbl_x4_compx_t *cbldata)
 {
  cobput_x4_compx(cbldata, cobget_x4_compx(cbldata) + 10);
 }
Parent topic: C Functions for Calling COBOL
Related reference
cobput
Related information
Passing Data between C and COBOL
Interfacing with C Programs
Signal Handling Overview


cobgetenv

Obtains the value of an environment variable.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobenv.h"

cobchar_t *cobgetenv(const cobchar_t *name);

Parameters:

name A null-terminated string, specifying the environment variable name to be searched for.

Comments:

This function provides the same functionality as the C library call getenv(). The specified environment variable is searched for and returned. If the environment variable does not exist then NULL is returned.

Equivalent COBOL Syntax:

display name upon environment-name
accept ... from environment-value

Example:

The following code displays the value of $COBDIR:

cobchar_t *cobdir;

if ((cobdir = cobgetenv("COBDIR")) == NULL)
    cobdir = "<unset>";

cobprintf("COBDIR=%s\n", cobdir);

cobchar_t *cobdir;

if ((cobdir = cobgetenv("COBDIR")) == NULL)
    cobdir = "<unset>";

printf("COBDIR=%s\n", cobdir);
Parent topic: C Functions for Calling COBOL
Related reference
cobputenv


cobgetfuncaddr

Returns a function pointer to a COBOL program, subprogram or entry point.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobcall.h"

PFR cobgetfuncaddr(int type, const cobchar_t *name);

Parameters:

type
Indicates what is returned if the specified program is not found.
Bit | Description
0 Can be either 0 or 1, where
  • 0 means a null pointer is returned
  • 1 means the address of an error function is returned
1-31 | Reserved
name
A null terminated string that specifies the name of the COBOL program to be found.

Comments:

This function returns a function pointer to the COBOL program of the specified name.

If the specified name is an entry point of an already loaded COBOL program, that program is used. Alternatively, if the specified name is a C function, then that is used. Otherwise, a program with a basename of the specified name is searched for on disk using the standard COBOL search order and paths. To change the program search order use the program_search_order run-time tunable.

If an error function is returned (bit 0 set to 1) and it is subsequently called then a run-time error is produced, as for cobcall().

This function only loads the program of the specified name; it does not call it. This enables programs to be preloaded. This is especially useful if you want to call an entry point within the program, but not the main entry point of the program.

Equivalent COBOL Syntax:

set procedure-pointer to entry "name"

Example:

The following C code calls a COBOL program cobprog with two arguments, coping with any error condition:

PFR cobprog;

if ((cobprog = cobgetfuncaddr(0, "cobprog")) == NULL)
{
    /* Error case */
}
else
{
    /* Loaded */
    (*cobprog)(arg1, arg2);    /* Call it! */
}
Parent topic: C Functions for Calling COBOL


cobinit

Initializes the COBOL environment, so that a COBOL program can be called from a non-COBOL program.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobmain.h"

int cobinit (void);

Parameters:

None.

Comments:

You must call cobinit() before calling a COBOL program if the main program is not written in COBOL or the programs in the application are linked with the static COBOL run-time system .

If you do not, you might receive an initialization error when you enter your COBOL code.

On some platforms, the COBOL environment is initialized when the COBOL run-time system is loaded (for example, at process startup).

If the COBOL environment has already been initialized then cobinit() returns successfully.

This function returns 0 on success.

Equivalent COBOL Syntax:

None.

Example:

The following example shows how to initialize (and close down) the COBOL environment from a C main(), so that a COBOL program can be called:

main(int argv, char *argv)
{
    cobinit();             /* Initialize COBOL environment */

    cobcall("cobep", 0, NULL); /* Call a COBOL program */

    cobtidy();             /* Close down COBOL environment */

    return(0);
)
Parent topic: C Functions for Calling COBOL


coblines

Returns the number of lines on the screen.
Note: This function is supported for native COBOL only.

Syntax:

#include "cobscreen.h"

int coblines (void);

Parameters:

None.

Comments:

This function returns the depth in lines of the screen.

Equivalent COBOL Syntax:

call "CBL_GET_SCR_SIZE" using ...

Example:

To find out and display the depth of the screen use:

int depth = coblines();

printf("Depth of screen = %d\n", depth);
Parent topic: C Functions for Calling COBOL


coblongjmp

With the cobsetjmp function, provides the capability of a non-local GO TO, for use in error or exception handling.
Restriction:

This function is supported for native COBOL only.

Syntax:

#include "cobsetjmp.h"

void coblongjmp(struct cobjmp_buf *buf);

Parameters:

buf A buffer in which the current execution environment is saved.

Comments:

The cobsetjmp() function saves the environment of the current COBOL program and C function in the buffer pointed to by buf. It calls the C library function setjmp(), which immediately returns a value of 0.

A subsequent call to coblongjmp() either from elsewhere in the C function that called cobsetjmp(), or from one of its C or COBOL subprograms, causes execution to be resumed at the point immediately after the call to cobsetjmp().

After calling coblongjmp(), cobsetjmp() returns a non-zero value, thus enabling the value to be tested after the cobsetjmp() call.

The following restrictions apply when using the coblongjmp() and cobsetjmp() functions:

  • cobsetjmp() and coblongjmp can be called from a C program only; they cannot be called from COBOL.
  • coblongjmp() must be called from the same or from a lower level in the CALL/PERFORM hierarchy of control flow as cobsetjmp(). In the intervening time, control must not have been returned to a higher level. Specifically, control must not have been returned from the C function that called cobsetjmp().
  • If coblongjmp() returns control to a different call level than that used by cobsetjmp(), programs exited by this mechanism appear to have been exited normally and can be called again later in the program's run.
  • coblongjmp cannot be used if a CHAIN has been made since cobsetjmp was last called.
  • coblongjmp() cannot be used in an error procedure, exit procedure or signal handler.

Equivalent COBOL Syntax:

None.

Example:

The following shows how to use the coblongjmp() and cobsetjmp() functions:

void
some_c_func(void)
{
    struct cobjmp_buf buf;

    if (cobsetjmp(&buf) != 0)
    {
        cobprintf("Returned from coblongjmp\n");
        return;
    }

    /* Valid code here - for example can call COBOL */

    coblongjmp(&cobjmp_buf);
}
Parent topic: C Functions for Calling COBOL


cobpostsighandler

Adds the specified handler to the list of handlers for the specified signal, at the specified priority.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobsignal.h"

cobsigtype_t cobpostsighandler (int signal, int priority,
    PFI_SIG handler);

Parameters:

signal | Signal number, as defined in the <signal.h> include file.
priority | The priority of handler in the range 1 to 254, where 254 is the highest priority. Values 127 and 129 through 139 are reserved for our use.
handler | Address of your signal handler. This must be a C function that returns an integer value.

Comments:

  • This function adds the specified handler to the list of handles for the specified signal, at the specified priority.
  • This function returns a pointer that you can use to remove your signal handler later. If the return value is NULL, a signal handler was not posted for this signal. This could be due to lack of memory or the signal being disabled by the signal_regime run-time tunable.
  • Refer to cobsignal.h for the definition of PFI_SIG, which defines the additional information that is passed to your handler.

Equivalent COBOL Syntax:

None.

Parent topic: C Functions for Calling COBOL
Related reference
cobremovesighandler
signal_regime
Related information
Signal Handling Overview
Example of Posting a Signal Handler
Third Party Software that Uses Signals
cobremovesighandler
signal_regime


cobput

Converts data from native C language types to COBOL types. There are a number of cobput functions, each for a different type of COBOL data.
Restriction: This function is supported for native COBOL only.

Syntax:

include "cbltypes.h"    /* Includes cbltypes.h and cobgetput.h */

void        cobput_x1_compx(cbl_x1_compx_t *cbldata, cobuns8_t val);
void        cobput_x2_compx(cbl_x2_compx_t *cbldata, cobuns16_t val);
void        cobput_x4_compx(cbl_x4_compx_t *cbldata, cobuns32_t val);
void        cobput_x8_compx(cbl_x8_compx_t *cbldata, cobuns64_t val);

void        cobput_x1_comp5(cbl_x1_comp5_t *cbldata, cobuns8_t val);
void        cobput_x2_comp5(cbl_x2_comp5_t *cbldata, cobuns16_t val);
void        cobput_x4_comp5(cbl_x4_comp5_t *cbldata, cobuns32_t val);
void        cobput_x8_comp5(cbl_x8_comp5_t *cbldata, cobuns64_t val);

void        cobput_sx1_comp5(cbl_sx1_comp5_t *cbldata, cobs8_t val);
void        cobput_sx2_comp5(cbl_sx2_comp5_t *cbldata, cobs16_t val);
void        cobput_sx4_comp5(cbl_sx4_comp5_t *cbldata, cobs32_t val);
void        cobput_sx8_comp5(cbl_sx8_comp5_t *cbldata, cobs64_t val);

void        cobput_xn_comp5(cbl_x1_t *cbldata, cobuns8_t n, cobuns64_t vall);
void        cobput_xn_compx(cbl_x1_t *cbldata, cobuns8_t n, cobuns64_t val);

void        cobput_sxn_comp5(cbl_x1_t *cbldata, cobuns8_t n, cobs64_t val);

void        cobput_pointer(cbl_pointer_t *cbldata, void *val);
void        cobput_ppointer(cbl_ppointer_t *cbldata, PFR val);

Parameters:

cbldata | Pointer to the COBOL data item and data description as indicated by the cobget function name.
val | Value to be placed in the COBOL data item cbldata.

Comments:

The cobput_xn_compx functions enable you to put data into data items with descriptions such as PIC X(3).

Equivalent COBOL Syntax:

None.

Example:

COBOL program:

program-id.  mycblprog.

 copy "cbltypes.cpy".

 01  myrec.
      05 myrec-key   		cblt-x4-compx value 10.
 procedure division.
     call 'mycprog'  using myrec-key
     if  myrec-key = 20
         display "First call to 'mycblprog'"
     else
         display "Subsequent call to 'mycblprog'"
     end-if
     exit program
 end program mycblprog.

C program:

#include "cbltypes.h"
 void
 mycprog(cbl_x4_compx_t *cbldata)
 {
  cobput_x4_compx(cbldata, cobget_x4_compx(cbldata) + 10);
 }
Parent topic: C Functions for Calling COBOL
Related reference
cobget
Related information
Passing Data between C and COBOL
Interfacing with C Programs
Signal Handling Overview


cobputenv

Dynamically changes the value of an environment variable.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobenv.h"

int cobputenv (const cobchar_t *envstr);

Parameters:

envstr
The null terminated string to be placed into the environment.

Comments:

The environment string envstr is put into the environment. By convention, environment strings have the format:

NAME=VALUE

but the run-time system does not check that envstr is in this format.

This function ultimately passes envstr into the C library function putenv(), which puts envstr into the operating system environment.

This function returns a value of zero if the operation was successful; any other value indicates an unsuccessful operation. Illegal environment names lead to undefined results.

Equivalent COBOL Syntax:

display name upon environment-name
display value upon environment-value

Example:

The following code shows how to set $ABC to XYZ:

cobputenv("ABC=XYZ");
Parent topic: C Functions for Calling COBOL


cobremovesighandler

Removes a posted handler from the list of handlers for a signal.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobsignal.h"

void cobremovesighandler (cobsigtype_t sighandler);

Parameters:

sighandler Pointer returned when posting your signal handler using a previous cobpostsighandler() call.

Comments:

This function removes a previously posted signal handler.

There is no return value from this function.

Equivalent COBOL Syntax:

None.

Parent topic: C Functions for Calling COBOL
Related reference
cobpostsighandler
signal_regime
Related information
Signal Handling Overview
Example of Posting a Signal Handler
Third Party Software that Uses Signals


cobrescanenv

Causes the run-time system to rescan the environment for COBOL environment strings.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobenv.h"

int cobrescanenv(void);

Parameters:

None.

Comments:

This function causes the run-time system to rescan the environment for COBOL environment strings, such as file-name mapping entries (that is, dd_ entries). This can be useful if the environment has been changed without the knowledge of the run-time system.

A value of zero is returned on success; any other value indicates an unsuccessful call.

Equivalent COBOL Syntax:

None.

Example:

The following code shows how to set a dd_ environment variable so that an open of file abc will instead open xyz:

cobputenv("dd_abc=xyz");
cobrescanenv();
Parent topic: C Functions for Calling COBOL
Related information
Filename Mapping


cobsetjmp

With the coblongjmp function, provides the capability of a non-local GO TO, for use in error or exception handling.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobsetjmp.h"

int cobsetjmp(struct cobjmp_buf *buf);

Parameters:

buf A buffer in which the current execution environment is saved.

Comments:

The cobsetjmp() function saves the environment of the current COBOL program and C function in the buffer pointed to by buf. It calls the C library function setjmp(), which immediately returns a value of 0.

A subsequent call to coblongjmp() either from elsewhere in the C function that called cobsetjmp(), or from one of its C or COBOL subprograms, causes execution to be resumed at the point immediately after the call to cobsetjmp().

After calling coblongjmp(), cobsetjmp() returns a non-zero value, thus enabling the value to be tested after the cobsetjmp() call.

The following restrictions apply when using the coblongjmp() and cobsetjmp() functions:

  • cobsetjmp() and coblongjmp can be called from a C program only; they cannot be called from COBOL.
  • coblongjmp() must be called from the same or from a lower level in the CALL/PERFORM hierarchy of control flow as cobsetjmp(). In the intervening time, control must not have been returned to a higher level. Specifically, control must not have been returned from the C function that called cobsetjmp().
  • If coblongjmp() returns control to a different call level than that used by cobsetjmp(), programs exited by this mechanism appear to have been exited normally and can be called again later in the program's run.
  • coblongjmp cannot be used if a CHAIN has been made since cobsetjmp was last called.
  • coblongjmp() cannot be used in an error procedure, exit procedure or signal handler.

Equivalent COBOL Syntax:

None.

Example:

The following shows how to use the coblongjmp() and cobsetjmp() functions:

void
some_c_func(void)
{
    struct cobjmp_buf buf;

    if (cobsetjmp(&buf) != 0)
    {
        cobprintf("Returned from coblongjmp\n");
        return;
    }

    /* Valid code here - for example can call COBOL */

    coblongjmp(&cobjmp_buf);
}
Parent topic: C Functions for Calling COBOL


cobthreadtidy

Tidies up the thread-local COBOL run-time environment.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobmain.h"

int cobthreadtidy(void);

Parameters:

None.

Comments:

This function deinitializes the COBOL environment for the current thread, cleaning up any thread-state information and freeing any data allocated as thread-local. It returns 0 on success.

This function can be used only when the current thread was created by non-COBOL API calls; that is, if the thread was created by C library, operating system or third-party threading API calls. It must not be called if the thread was created by COBOL syntax or the CBL_THREAD_CREATE library routine. You cannot call cobthreadtidy() directly from a COBOL program.

You should call this function only when all COBOL modules have been exited in this thread and you do not intend to reenter them. If you do call any COBOL entry points or COBOL routines (such as cobinit()) after you have called cobthreadtidy(), the results are undefined.

Equivalent COBOL Syntax:

None.

Example:

When a C thread is created, you need to specify a C function that is the initial entry point for the thread. If this entry point is c_thread(), then the following shows how to:

  • Call a COBOL entry point cobep which takes no arguments
  • Call cobthreadtidy() before the thread dies
c_thread(void)
{
    cobinit();                  /* Only required if not   */
                                /* already called in this */
                                /* process                */
    cobcall("cobep", 0, NULL);  /* Call COBOL */
    cobthreadtidy();            /* Tidy up COBOL in this  */
                                /* thread */

    return 0;                   /* Exit thread */
}
Parent topic: C Functions for Calling COBOL


cobtidy

Tidies up the global COBOL run-time environment.
Restriction: This function is supported for native COBOL only.

Syntax:

#include "cobmain.h"

int cobtidy (void);

Parameters:

None.

Comments:

This function deinitializes the COBOL environment, emptying buffers, closing files and freeing any data areas allocated by the COBOL system.

Use this function if you want to close down the COBOL system, but are not yet ready to exit. It returns 0 on success.

Do not call cobtidy() directly from a COBOL program.

You can call this function only when all COBOL modules have been exited, and you do not intend to re-enter them. If you do call any COBOL entry points or COBOL routines (such as cobinit()) after you have called cobtidy(), the results are undefined.

Equivalent COBOL Syntax:

None.

Example:

The following example shows how to initialise and close down the COBOL environment from a C main(), so that a COBOL program can be called:

main(int argv, char *argv)
{
    cobinit();            /* Initialize COBOL environment */

    cobcall("cobep", 0, NULL); /* Call a COBOL program */

    cobtidy();            /* Close down COBOL environment */

    return(0);
}
Parent topic: C Functions for Calling COBOL


COBOL Language Reference

  • COBOL Language Supported and Copyrights
  • Notations
  • Part 1. Concepts
  • Part 2. Program Definition
  • Part 3. Additional Topics
  • Part 4: Appendices
Parent topic: General Reference
Related reference
Managed COBOL Reference


COBOL Language Supported and Copyrights

This describes the base COBOL language supported by this system: this COBOL language is based on the ANSI COBOL standards X3.23-1985, X3.23a-1989 and X3.23b-1993, and is supported by a number of COBOL systems. In addition, support has been added for some of the features from ISO/IEC 1989:2002, Programming language COBOL.

COBOL is an industry language and is not the property of any company or group of companies, or of any organization or group of organizations.

No warranty, expressed or implied, is made by any contributor or by the CODASYL Programming Language Committee as to the accuracy and functioning of the programming system and language. Moreover, no responsibility is assumed by any contributor, or by the committee, in connection herewith.

The authors and copyright holders of the copyrighted material used herein:

  • FLOW-MATIC Programming for the Univac I and II, Data Automation Systems copyrighted 1958,1959, by Sperry Rand Corporation; IBM Commercial Translator Form No. F28-8013, copyrighted 1959 by IBM; FACT, DSI27A5260-2760, copyrighted 1960 by Minneapolis-Honeywell

have specifically authorized the use of this material in whole or in part, in the COBOL specifications. Such authorization extends to the reproduction and use of COBOL specifications in programming manuals or similar publications.

Parent topic: COBOL Language Reference


Notations

Throughout this book, the following notation is used to describe the format of COBOL statements:

  1. Words printed in capital letters which are underlined must always be present when the functions of which they are a part are used. An error will be reported by your COBOL system if the underlined words are absent or incorrectly spelled. The underlining is not necessary when writing a COBOL source program.
  2. Words printed in capital letters which are not underlined are used in the COBOL source program for readability only. They may be written, or not, as the programmer wishes, but if written, must be correctly spelled.
  3. All words printed in small letters are generic terms representing names which will be devised by the programmer.
  4. When material is enclosed in braces { }, a choice must be made from the options within them.
  5. When material is enclosed in choice indicators { | | }, one or more of the unique options must be specified, but a single option may be specified only once.
  6. When material is enclosed in square brackets [ ] , it is an indication that the material is an option which may be included or omitted as required.
  7. When material is enclosed in boxed, square brackets:

    it is an indication that the material is mandatory for ANSI'74 COBOL (American National Standards Institute publication X3.23-1974) but may be optionally omitted as an extension to that language specification. The symbol adjacent to the box or appearing in the margin indicates the dialects of COBOL in which that material is optional. See rule 12 for further details on dialect features.

  8. In text, the ellipsis (...) shows the omission of a portion of a source program or a sequence. This meaning becomes apparent in context.

    In the General Formats, the ellipsis represents the position at which repetition may occur at the user's option. The portion of the format that may be repeated is determined as follows:

    Given ... in a clause or statement format, scanning right to left, determine the } or ] immediately to the left of the ...; continue scanning right to left and determine the logically matching { or [; the ... applies to the words between the determined pair of delimiters.

  9. Where the term "integer" appears in the general formats, integer must be a numeric literal which is an integer, and must be neither signed nor zero unless explicitly allowed by the rules of that format.
  10. This Reference presents the syntax of IBM SAA AD/Cycle COBOL370 (COBOL/370) statements and the rules for writing source programs that are to be compiled by the COBOL/370 compiler.

    The only distinction Micro Focus COBOL makes between COBOL/370 and IBM VS COBOL II is that for the procedure-pointer format, the default length is eight bytes rather than four bytes.

  11. This Reference presents the syntax of Multivendor Integration Architecture (MIA) - Technical Requirements for the programming language COBOL. No boxes or dialect symbols for MIA are used in this book.
  12. The COBOL language accepted by most COBOL compilers includes extensions to the COBOL language defined in American National Standard X3.23-1974. Different compilers allow different extensions to this standard which means that different versions, called `dialects', of COBOL exist. This COBOL product is designed for use in cross-development; it can be used for developing not only programs for use on your COBOL system itself but also programs for use with IBM OS/VS COBOL, IBM VS COBOL II, IBM COBOL/370 or IBM COBOL for OS/390 & V2R2, or programs that conform entirely to ANS X3.23-1974 or its successor ANS X3.23-1985. It allows most extensions that are in the IBM COBOLs, and all the features from ANS X3.23-1985 and X3.23a-1989.

    To help you keep to the appropriate dialect - that of your target system - this book shows the dialects in which each feature appears. In the text, features outside ANS X3.23-1974 are in separate paragraphs, with a symbol indicating the dialect at the start of the paragraph. Where a complete section is a separate dialect, the heading of the section is followed by a symbol in a paragraph by itself. A phrase which is part of a separate dialect is separated out into a paragraph on its own, marked as indicated above. In syntax diagrams, features outside ANS X3.23-1974 are enclosed in boxes, with symbols adjacent to the boxes or in the margin.

    The symbols used are as follows:

    OSVS | These features are extensions to ANS X3.23-1974 that appear in IBM OS/VS COBOL.
    VSC2 | These features are extensions to ANS X3.23-1985 that appear in IBM VS COBOL II.
    COB370 | These features are extensions to ANS X3.23-1985 that are supported in IBM SAA AD/Cycle COBOL/370, but not in IBM VS COBOL II.
    OS390 | These features are extensions to ANS X3.23-1985 that are supported in IBM COBOL for OS/390 & V2R2, but not in IBM SAA AD/Cycle COBOL/370.
    ENT | These features are extensions to ANS X3.23-1985 that are supported in Enterprise COBOL for z/OS, but not IBM COBOL for OS/390.
    ANS85 | These features are features defined in ANS X3.23-1985 which are not supported under ANS X3.23-1974.
    XOPEN | These features are extensions to ANS X3.23-1985 that appear in the X/Open CAE Specification, COBOL language (XPG-4).
    MF | These features are extensions to ANS X3.23-1985 that are specific to Micro Focus COBOL.
    ISO2002 | These features are features defined in ISO/IEC 1989:2002 which are not supported under ANS X3.23-1985.
    Note:
    • The Micro Focus, VS COBOL II, COBOL/370, OS/390 and X/Open dialects are all based on the ANS X3.23-1985 COBOL Standard. Therefore, any syntax (or rules) which are marked as valid for ANS85 are also valid for Micro Focus, VS COBOL II, COBOL/370, OS/390 and X/Open unless explicitly designated otherwise.
    • The COBOL/370 dialect includes all of the syntax included in VS COBOL II which is marked with a VSC2 bubble in this book. The only time that a COB370 bubble appears in this book are cases where COBOL370 (with the NOCMPR2 compiler option) includes additional or different text than that included with VS COBOL II (with the NOCMPR2 compiler option).
    • The OS390 dialect includes all of the syntax included in VS COBOL II that is marked with a VSC2 bubble. The only time that an OS390 bubble appears in this book are cases where OS390 (with the NOCMPR2 compiler option) includes additional or different text than that is included with VS COBOL II (with the NOCMPR2 compiler option).
    • The Enterprise Cobol dialect includes all of the syntax included in VS COBOL II which is marked with a VSC2 bubble. The only time that an ENT bubble appears in this book is in cases where Enterprise Cobol (with the NOCMPR2 compiler option) includes additional or different text than that included with VS COBOL II (with the NOCMPR2 compiler option).

    These bubbles reflect support only for a particular syntax and its semantics. You have to use Compiler directives to effect a set of reserved words associated with a particular dialect. See the appendix Reserved Words in this book and your Compatibility Guide, if your COBOL system has one, for a list of the reserved words for various dialects.

    Thus, for example, if you are developing a program for use on IBM OS/VS COBOL, you can use the unmarked features plus any marked OSVS; while if developing solely for your COBOL environment you can use any feature. If you supply the FLAG Compiler directive when you invoke the system software, your COBOL system software flags any features outside the given dialect. You can also use the FLAGAS Compiler directive to turn flagging messages into error messages.

  13. Some features have different effects in different dialects; you specify a dialect-control directive to select the dialect with which you want compatibility. The boxes around such features are double-ruled.

    Extra reserved words needed by features outside ANS X3.23-1985 are reserved only when the appropriate dialect-control directive is present; this means you can ensure that only the words reserved in the specified dialect are reserved on your target system. If you use only features that need no extra reserved words, and whose effects are the same in all dialects, you need not specify a dialect-control directive.

    The dialect-control directive specifying the ANS X3.23-1985 dialect also causes the few ANS 3.23-1974 features not allowed in ANS X3.23-1985 to be flagged with a warning message.

  14. The phrase "is documentary only" in the text of this book means that the associated coding is accepted syntactically by your COBOL system software, but is ignored when producing the object program.
  15. Hexadecimal values are enclosed in quotation marks and preceded by a lowercase x for nonnumeric values and by a lowercase h for numeric values; for example, x"9D".
Parent topic: COBOL Language Reference


Part 1. Concepts

  • Introduction to the COBOL Language
  • Concepts of the COBOL Language
  • Language Fundamentals
Parent topic: COBOL Language Reference


Introduction to the COBOL Language

This chapter introduces you to the COBOL language.

  • The COBOL Language
  • Source Format
Parent topic: Part 1. Concepts


The COBOL Language

COBOL (COmmon Business Oriented Language) is the programming language most widely and extensively used in commercial and administrative data processing.

This COBOL implementation is a superset of the ANSI and ISO COBOL standard as specified in ANSI X3.23-1974 (ISO 1989-1978), and of the current ANSI and ISO COBOL standard as specified in ANSI X3.23-1985 (IS 1989:1985), ANSI X3.23a-1989 (IS 1989:1985/AM1), and ANSI X3.23b-1993 (IS 1989:1985/AM2). Language extensions include:

  • Most of the more commonly used extensions of IBM OS/VS COBOL (Release 2.3 and later)
  • Most of the language constructs of IBM VS COBOL II (all releases), IBM DOS/VS COBOL and IBM SAA AD/Cycle COBOL/370
  • X/Open conforming extensions
  • Extensions specific to this system.

Combinations of these extensions are permissible in program source.

The ANSI COBOL 1974 and 1985 modules that are fully implemented are:

  • Nucleus
  • Table Handling (In the Nucleus as of the ANSI'85 Standard)
  • Record Sequential I/O
  • Relative I/O
  • Indexed I/O
  • Sort-Merge
  • Segmentation
  • Library/Source Text Manipulation
  • Inter-Program Communication
  • Debug
  • Report Writer
  • ANS85 Intrinsic Functions

This COBOL system meets the certification requirements for the above modules of the COBOL Compiler Validation System (CCVS) of the U.S. Department of Commerce, National Institute of Standards and Technology.

MF A number of additional enhancements to the COBOL language are present:

  • A screen-handling module, comprising a Screen Section and additional formats of ACCEPT and DISPLAY statements, which enable the user to specify exact location of fields on a screen, accept data entered at specified positions, display literal text at specified positions, define screen attributes, and control console features.
  • Enhanced file I/O with an additional organization to handle text files efficiently; optional definition of file-names either within a program source (data variable or literal) or at run time from operating system environment variables; multiuser file-sharing facilities.
  • Systems programming extension which enhances interlanguage calls and supports recursive COBOL programs.
Parent topic: Introduction to the COBOL Language


Source Format

Source code can be in

MF XOPEN free format,

fixed format, or variable format.

  • Fixed Format
  • Free Format
  • Variable Format
Parent topic: Introduction to the COBOL Language


Fixed Format

In fixed format, the COBOL source record is divided into the following areas:

Columns 1 - 6 | Sequence number
Column 7 | Indicator area
Column 8 - 11 | Area A
Columns 12 - 72 | Area B

MF A COBOL source record can extend up to a maximum of 80 columns in length. The contents of columns 73 to 80 are ignored by the COBOL system.

  • Sequence Number
  • Indicator Area
  • Areas A and B
  • Sample Program
Parent topic: Source Format


Sequence Number

A sequence number of six digits can be used to identify each source program line.

MF If the first character position of the sequence number field contains an asterisk, or any nonprinting control character (less than the character SPACE in the ASCII collating sequence), then the line is treated as comment and is not output to the listing file or device. This facility allows an output listing file to be used as a source file to a subsequent compilation.

MF This support is sensitive to the MFCOMMENT Compiler directive.

ANS85 The sequence number can contain any character in the computer's character set.

Parent topic: Fixed Format


Indicator Area

An asterisk (*) in the indicator area marks the line as documentary comment only. Such a comment line can appear anywhere in the program after the IDENTIFICATION DIVISION header. Any characters from the ASCII character set can be included in area A and area B of the line.

OSVS VSC2 MF A comment line can appear before the IDENTIFICATION DIVISION header.

A slash (/) in the indicator area acts as a comment line above but causes the page to eject before the comment is printed.

A "D" or "d" in the indicator area represents a debugging line. Areas A and B can contain any valid COBOL sentence.

A "–" in the indicator area represents a continuation of the previous line without spaces or the continuation of a nonnumeric literal (see the section Continuation of Lines in the chapter Language Fundamentals).

MF A "$" in the indicator area indicates a special line for setting directives or conditional compilation.

Parent topic: Fixed Format
Related information
Continuation of Lines


Areas A and B

Section names and paragraph names begin in area A and are followed by a period and a space. Level indicators FD, SD, CD and RD begin in area A and are followed in area B.

ANS85 or area A

by the appropriate description. Level numbers 01 and 77 begin in area A and are followed in area B

ANS85 or area A

by the data description. Level numbers 02 through 49, 66 and 88 begin in area B.

MF Level number 78 can begin in area A or area B.

MF No rules regarding area A and area B are enforced except in relation to comment-entries in the Identification Division.

MF XOPEN The concept of area A and area B is removed when free format source code is used. See the next section in this chapter for additional information on free format source code.

More than one sentence is permitted in each source record.

Parent topic: Fixed Format


Sample Program

Below is the source of a typical program in fixed format.

000010 identification division.
000020 program-id. stock-file-set-up.
000030 author. MicroFocus.
000040 environment division.
000050 configuration section.
000060 source-computer. mds-800.
000070 object-computer. mds-800.
000075 special-names. console is crt.
000080 input-output section.
000090 file-control.
000100  select stock-file assign "stock.it"
000110  organization indexed
000120  access dynamic
000130  record key stock-code.
000140 data division.
000150 file section.
000160 fd   stock-file record 32.
000170 01   stock-item.
000180  02  stock-code       pic x(4).
000190  02  product-desc     pic x(24).
000200  02  unit-size        pic 9(4).
000210 working-storage section.
000220 01   screen-headings.
000230  02  ask-code pic x(21) value "stock code    <    >".
000240  02  filler   pic x(59).
000250  02  ask-desc pic x(16) value "description   <".
000260  02  si-desc  pic x(25) value "                 >".
000270  02  filler   pic x(39).
000280  02  ask-size pic x(21) value "unit size <    >".
000290 01   enter-it redefines screen-headings.
000300  02      filler       pic x(12).
000310  02  crt-stock-code   pic x(4).
000320  02      filler       pic x(80).
000330  02  crt-prod-desc    pic x(24).
000340  02      filler       pic x(51).
000350  02  crt-unit-size    pic 9(4).
000360  02  filler           pic x.
000370 procedure division.
000380 sr1.
000390  display space.
000400  open i-o stock-file.
000410  display screen-headings.
000420 normal-input.
000430  move space to enter-it.
000440  display enter-it.
000450 correct-error.
000460  accept enter-it.
000470  if crt-stock-code = space go to end-it.
000480  if crt-unit-size not numeric go to correct-error.
000490  move crt-prod-desc to product-desc.
000500  move crt-unit-size to unit-size.
000510  move crt-stock-code to stock-code.
000520  write stock-item invalid key go to correct-error.
000530  go to normal-input. 000540 end-it.
000550  close stock-file.
000560  display space.
000570  display "end of program".
000580  stop run.
<---->|<--><----------------------------------------------------------->
  |   | |     |
  |   | |     +-- Columns 12-72 - Area B
  |   | +-- Columns 8-11 - Area A
  |   +-- Column 7 - Indicator Area
  +-- Columns 1-6 - Sequence Numbers
Parent topic: Fixed Format


Free Format

Free format COBOL is selected using the SOURCEFORMAT"FREE" directive.

The first six characters are considered part of the normal source line and may contain COBOL source code. Column 1 takes the role of the indicator area as follows:

* | comment line
/ | comment line starting on a new page in the listing file
D or d | followed by space, debugging line
$ | special line (for example, directive, conditional compilation)
any other character | normal source line

There are no continuation lines. Continuation of alphanumeric literals is achieved through concatenation (for example, "A" & "B").

There is no distinction between area A and area B.

There is no fixed right margin, though for practical purposes this implementation restricts the maximum length of a source line to 250 single-byte or 125 double-byte characters.

Comment-entries are only allowed on the same line as the paragraph header and must not continue onto another line.

Parent topic: Source Format


Variable Format

Variable format COBOL is selected using the SOURCEFORMAT"VARIABLE" directive.

The COBOL source record is divided into areas as in fixed format. The only difference from fixed format is that the B area has no fixed right margin, though for practical purposes this implementation restricts the maximum length of a source line to 250 single-byte or 125 double-byte characters.

Parent topic: Source Format


Concepts of the COBOL Language

This chapter explains the concepts of the COBOL language.

  • Character Set
  • Language Structure
  • Formats and Rules
  • Concept of Computer-independent Data Description
  • Concept of Levels
  • Class and Category of Data
Parent topic: Part 1. Concepts


Character Set

The most basic and indivisible unit of the language is the character. The set of characters used to form COBOL character-strings and separators includes the letters of the alphabet, digits and special characters, and is defined below:

Character | Meaning
0 to 9 | Digits
A to Z | Upper-case letters
a to z | Lower-case letters
 | Space
+ | Plus sign
- | Minus sign or hyphen
* | Asterisk
/ | Oblique stroke/slash
= | Equal sign
$ | Dollar sign
. | Period or decimal point
, | Comma or decimal point
; | Semicolon
" | Quotation mark
' | Apostrophe
( | Left parenthesis
) | Right parenthesis
> | Greater than symbol
< | Less than symbol
: | Colon
& | Ampersand
_ | Underscore

ANS85 Lower-case letters can be used in character strings and text words; except when used in nonnumeric literals and except for some picture symbols, each lower-case letter is equivalent to the corresponding upper-case letter.

This COBOL implementation is restricted to the above character set, but the content of nonnumeric literals, comment lines, comment entries and data can include any of the characters available under the character encoding scheme used for the COBOL compilation group. (See the topic Character Sets and Collating Sequences.)

Parent topic: Concepts of the COBOL Language
Related information
Character Sets and Collating Sequences


Language Structure

The individual characters of the language are concatenated to form character-strings and separators. A separator can be concatenated with another separator or with a character-string. A character-string can be concatenated only with a separator. The concatenation of character-strings and separators forms your source text.

  • Separators
  • Character-strings
  • Scope of Names
  • Literals
  • Nonnumeric Literals
  • Numeric Literals
    Numeric literals can be either fixed-point or floating-point numbers.
  • National Literals
    A national literal is a string of national characters represented in the storage of the computer as characters of a uniform size. See your COBOL system documentation on national data (Unicode) for further information.
  • Figurative Constant Values
    Figurative constant values are generated by your COBOL system and referenced through the use of the reserved words given below. These words must not be bounded by quotation marks when used as figurative constants. The singular and plural forms of figurative constants are equivalent and can be used interchangeably.
  • Constant-names
  • Concatenation Expressions
    A concatenation expression consists of two operands separated by the concatenation operator.
  • Special Registers
  • Predefined Object Identifiers
  • PICTURE Character-Strings
  • Comment-entries
Parent topic: Concepts of the COBOL Language


Separators

A separator is a string of one or more punctuation characters. The rules for formation of separators are:

  1. The punctuation character space is a separator. Wherever a space is used as a separator or as part of a separator, more than one space can be used. All spaces immediately following the separators comma, semicolon, or period are considered part of that separator and are not considered to be the separator space.
  2. Except when the comma is used in a PICTURE character-string, the punctuation characters comma and semicolon, immediately followed by a space, are separators that can be used anywhere the separator space is used.
  3. The punctuation character period, when followed by a space, is a separator. It must be used only to indicate the end of a sentence, or as shown in formats.
  4. The punctuation characters right and left parenthesis are separators. Except in pseudo-text, parentheses can appear only in balanced pairs of left and right parentheses delimiting subscripts,

    ANS85 a list of function arguments, reference modifiers,

    arithmetic expressions, or conditions.

  5. The opening delimiters and closing delimiters of literals are separators.

    ISO2002 OSVS VSC2 MF Either an apostrophe or a quotation mark may be used as the quotation symbol character in opening and closing delimiters.

    The opening delimiters of literals are:

    • A quotation mark symbol
    • MF Any of the following pairs of contiguous characters: G", G', H", H', N", N', X", X', Z", Z'

    The closing delimiters of literals are:

    • A quotation mark when the opening delimiter uses a quotation mark
    • An apostrophe when the opening delimiter uses an apostrophe

    The opening delimiter must be immediately preceded by a space, left parenthesis or opening pseudo-text delimiter. The closing delimiter must be immediately followed by one of the separators space, comma, semicolon, period, right parenthesis or closing pseudo-text delimiter. Separators immediately preceding the opening delimiter are not part of the opening delimiter. Separators immediately following the closing delimiter are not part of the closing delimiter.

  6. Pseudo-text delimiters are separators. An opening pseudo-text delimiter must be immediately preceded by a space; a closing pseudo-text delimiter must be immediately followed by one of the separators space, comma, semicolon, or period.

    MF The space immediately preceding the opening pseudo-text delimiter can be omitted.

    Pseudo-text delimiters can appear only in balanced pairs delimiting pseudo-text

    MF and verb-signatures

    . (See the topic Source Text Manipulation and the topic Method Interface Definition.)

  7. The COBOL character colon, except as part of the invocation operator, is a separator and is required when shown in the general formats.
  8. The separator space can immediately precede all separators except the following:
    1. As specified by reference format (see the section Reference Format in the chapter Language Fundamentals).
    2. The separator closing quotation mark. In this case, a preceding space is considered as part of the nonnumeric literal and not as a separator.
    3. The opening pseudo-text delimiter, where the preceding space is required.
  9. The separator space can optionally immediately follow any separator except the opening quotation mark. In this case, a following space is considered as part of the nonnumeric literal and not as a separator.

Any punctuation character which appears as part of the specification of a PICTURE character-string (see the topic The PICTURE Clause) or numeric literal is not considered to be a punctuation character, but rather a symbol. PICTURE character-strings are delimited only by the separators space, comma, semicolon, or period.

The rules established for the formation of separators do not apply to the characters which comprise the contents of nonnumeric literals, comment-entries, or comment lines.

Parent topic: Language Structure
Related reference
Reference Format
Related information
Source Text Manipulation
Method Interface Definition
Reference Format
The PICTURE Clause


Character-strings

A character-string is a character or a sequence of contiguous characters forming a COBOL word, a literal, a PICTURE character-string, or a comment-entry. A character-string is delimited by separators.

  • COBOL Words
Parent topic: Language Structure


COBOL Words

ANS85 A COBOL word is a character-string of not more than 30 characters which forms a compiler-directive word, a context-sensitive word, user-defined word, a system-name, a reserved word, or an intrinsic-function-name. Each character of a COBOL word that is not a special character word is selected from the set of letters, digits, the hyphen

ISO2002 and the underscore

.

The hyphen

ISO2002 or the underscore

may not appear as the first or last character in such words. Each lower-case letter is considered to be equivalent to its corresponding upper-case letter.

ISO2002 The character-string may contain 31 characters.

ANS85 Within a source element the following apply:

  1. ANS85 For all COBOL words excluding the words LENGTH, RANDOM, and SUM:
    1. Reserved words form disjoint sets with user-defined words, system-names and intrinsic-function-names.
    2. User-defined words, system-names and intrinsic-function-names form intersecting sets. The same COBOL word may be used as a user-defined word, a system-name and an intrinsic-function-name. The classification of a specific occurrence of such COBOL words is determined by the context of the clause or phrase in which it occurs.
  2. ANS85 For the COBOL words LENGTH, RANDOM, and SUM:
    1. The reserved words LENGTH, RANDOM and SUM form an identical set with the intrinsic-function-names LENGTH, RANDOM and SUM. The same COBOL word LENGTH, RANDOM, or SUM may be used as an intrinsic-function-name and as a reserved word. The classification of a specific occurrence of such COBOL words is determined by the context in which it occurs.
    2. The COBOL words LENGTH, RANDOM, and SUM form disjoint sets with user-defined words and system-names. They may not be used as a system-name or user-defined word regardless of context.

User-Defined Words

A user-defined word is a COBOL word that must be supplied by the user to satisfy the format of a clause or statement.

The types of user-defined words are:

  • alphabet-name
  • ISO2002 MF class-name for object orientation
  • ANS85 class-name for truth value proposition
  • condition-name
  • MF constant-name
  • data-name
  • NET delegate-name
  • NET JVM enum-name
  • file-name
  • ISO2002 function-prototype-name
  • index-name
  • ISO2002 MF interface-name
  • level-number
  • library-name
  • ISO2002 MF method-name
  • mnemonic-name
  • paragraph-name
  • ISO2002 parameter-name
  • program-name
  • ISO2002 program-prototype-name
  • ISO2002 property-name
  • record-name
  • report-name
  • MF routine-name
  • ISO2002 MF XOPEN screen-name
  • section-name
  • segment-number
  • ISO2002 MF split-key-name
  • ANS85 symbolic-character
  • text-name
  • MF typedef-name
  • ISO2002 user-function-name
  • NET JVM valuetype-name

Within a given source element the following user-defined words are grouped into the following disjoint sets:

  • alphabet-names
  • ISO2002 MF class-names for object orientation
  • ANS85 class-names for truth value proposition
  • condition-names,

    MF constant-names,

    data-names,

    ISO2002 property-names,

    record-names,

    ISO2002 MF split-key-names

    MF typedef-names

  • NET delegate-name
  • NET JVM enum-name
  • file-names
  • ISO2002 function-prototype-names
  • index-names
  • ISO2002 interface-names
  • library-names
  • ISO2002 MF method-names
  • mnemonic-names
  • paragraph-names
  • ISO2002 parameter-names
  • program-names
  • ISO2002 MF program-prototype-names
  • report-names
  • MF routine-names
  • ISO2002 MF XOPEN screen-names
  • section-names
  • ANS85 symbolic-characters
  • text-names.
  • ISO2002 user-function-names
  • NET JVM valuetype-name

All user-defined words, except segment-numbers and level-numbers, can belong to one and only one of these disjoint sets. Furthermore, all user-defined words within a given disjoint set must be unique, except as specified in the section Uniqueness Of Reference.

With the exception of paragraph-name, section-name, level-number and segment-number, all user-defined words must contain at least one alphabetic character

MF or one occurrence of the hyphen character

.

Segment-numbers and level-numbers need not be unique; a given specification of a segment-number or level-number can be identical to any other segment-number or level-number and can even be identical to a paragraph-name or section-name.

The following user-defined words are externalized to the operating environment:

  1. Program-names of programs that are not contained in other programs,

    ISO2002 MF class-names,

    ISO2002 function-prototype-names, interface-names,

    ISO2002 MF method-names,

    ISO2002 program-prototype-names, user-function-names

    .

  2. ANS85 Data-names, file-names, and record-names of items described with the EXTERNAL attribute.

If a literal is specified in place of or in addition to one of these names, the content of the literal is the name that is externalized to the operating environment in a case-sensitive manner. If no literal is specified, the externalized name is created by folding the name to upper case. The Compiler directive FOLD-CALL-NAME can be used to control the case of externalized class-names, interface-names and program-names. The F and U options of the Compiler directive OOCTRL can be used to control the case of externalized method-names. +F and -U cause method-names to be folded to lower case, which is the default.

Condition-name: A condition-name is a name which is assigned to a specific value, set of values, or range of values, within a complete set of values that a data item can assume. The data item itself is called a conditional variable. Condition-names can be defined in the Data Division or in the Special-Names paragraph within the Environment Division where a condition-name must be assigned to one or both of the ON STATUS or OFF STATUS of the run-time switches.

A condition-name is used only as follows:

  1. In the RERUN clause.
  2. In conditions as an abbreviation for a relation condition. This relation condition posits that the associated conditional variable is equal to one of the set of values to which that condition-name is assigned.
  3. In a SET statement indicating that the associated value is to be moved to the conditional variable.
Constant-name: A constant-name is a name which is assigned as the name of a fixed value.
Mnemonic-name: A mnemonic-name assigns a user-defined word to an implementor-name. These associations are established in the Special-Names paragraph of the Environment Division. (See the topic The Special-Names Paragraph.)
Paragraph-name: A paragraph-name is a word that names a paragraph in the Procedure Division. Paragraph-names are equivalent if, and only if, they are composed of the same sequence of the same number of characters.
Section-name: A section-name is a word that names a section in the Procedure Division. Section-names are equivalent if, and only if, they are composed of the same sequence of the same number of characters.
Other user-defined words: See the Glossary for definitions of all other types of user-defined words.

System-names

A system-name is a COBOL word that is used to communicate with the operating environment.

System-names must contain at least one alphabetic character

MF or one occurrence of the hyphen character

.

There are three types of system-names:

  • Computer-name
  • Implementor-name
  • Language-name.

Within a given implementation these three types of system-names form disjoint sets; a given system-name can belong to one and only one of them.

The system-names listed above are individually defined in the Glossary.

Intrinsic-function-names

ANS85 An intrinsic-function-name is a word that is one of a specified list of words which can be used in COBOL source elements. The same word, with the exception of LENGTH, RANDOM and SUM, in a different context, can appear in a source element as a user-defined word or a system-name. (See the topic Definitions of Functions.)

Reserved words

A reserved word is a COBOL word that is one of a specified list of words which can be used in COBOL compilation groups, but which must not appear in the compilation groups as user-defined words or system-names. Reserved words can be used only as specified in the general formats. (See the topic Reserved Words.)

The types of reserved words are:

  • Key words
  • Optional words
  • Special registers
  • Figurative constants
  • Special-character words
  • ISO2002 MF Predefined object identifiers.

Key words: A key word is a word whose presence is required when the format in which it appears is used in a compilation group. Within each format, such words are upper-case and underlined.

Key words are of three types:

  1. Verbs such as ADD, READ, and ENTER
  2. Required words, which appear in statement and entry formats
  3. Words which have a specific functional meaning, such as NEGATIVE, SECTION, and so on.
Optional words: Within each format, upper-case words that are not underlined are called optional words and can appear at the user's discretion. The presence or absence of an optional word does not alter the semantics of the COBOL source element in which it appears.
Special registers: Certain words are used to name and reference special registers: special registers are certain storage areas created by your COBOL system, whose primary use is to store information produced in conjunction with the use of specific COBOL features. They are specified in the section Special Registers.
Figurative constants: Certain reserved words are used to name and reference specific constant values. These reserved words are specified in the section Figurative Constant Values.
Special character words: The arithmetic operators and relation characters are reserved words.
Predefined object identifiers: Certain reserved words are used as predefined object identifiers. The predefined object identifiers are:
  • SELF
  • SUPER
  • MF SELFCLASS

Context-sensitive words

ISO2002 A context-sensitive word is a COBOL word that is reserved only in the general formats in which it is specified. The same word may also be used as an intrinsic-function-name, a user-defined word or a system-name. Context-sensitive words and the contexts in which they are reserved are specified in the section Context-sensitive Words Table in the appendix Reserved Words.

Parent topic: Character-strings
Related information
Uniqueness Of Reference
The Special-Names Paragraph
Glossary
Definitions of Functions
Reserved Words
Special Registers
Figurative Constant Values
Context-sensitive Words Table


Scope of Names

When source elements are directly or indirectly contained within other source elements, each source element can use identical user-defined words to name items independent of the use of these user-defined words by other elements. (See the discussion of user-defined words in the section COBOL Words.) When identically named items exist, a source elements's reference to such a name, even when it is a different type of user-defined word, is to the item which that source element describes rather than to the item possessing the same name, described in another source element.

Delegate-names, enum-names and valuetype-names are special cases of class-names for object orientation.

The following types of user-defined words can be referenced only by statements and entries in the source element in which the user-defined word is declared:

  • paragraph-name
  • section-name

The following types of user-defined words can be referenced throughout a compilation group:

  • library-name
  • text-name

The following types of names, when declared in a Configuration Section, can be referenced only by statements and entries either in the source element that contains that Configuration Section or in any source element contained within that source element:

  • alphabet-name
  • class-name (for truth value proposition)
  • condition-name
  • mnemonic-name
  • symbolic-character

Specific conventions, for declarations and references, apply to the following types of user-defined words when the conditions listed above do not apply:

  • ISO2002 MF class-name (for object orientation)
  • condition-name
  • data-name
  • file-name
  • ISO2002 MF function-prototype-name
  • index-name
  • ISO2002 interface-name
  • ISO2002 MF method-name
  • program-name
  • ISO2002 MF program-prototype-name
  • record-name
  • report-name
  • ISO2002 MF XOPEN screen-name
  • MF typedef-name
  • ISO2002 user-function-name
  • Conventions for Program-names
  • Conventions for Condition-names, Data-names, File-names, Record-names, Report-names and Typedef-names
  • Conventions for Index-names
  • Conventions for Class-names (for Object Orientation) and Interface-names
  • Conventions for Method-names
  • Conventions for Function-prototype-names
  • Conventions for Program-prototype-names
Parent topic: Language Structure
Related information
COBOL Words


Conventions for Program-names

The program-name of a program is declared in the Program-ID paragraph of the program's Identification Division. A program-name can be referenced only by the CALL statement,

MF the CHAIN statement,

the CANCEL statement,

MF the SET statement

and the END PROGRAM header. If two programs in a run unit are identically named, at least one of those two programs must be directly or indirectly contained within a separate program which does not contain the other of those two programs.

The following rules regulate the scope of a program-name:

  1. If the program-name is that of a program which does not possess the common attribute and which is directly contained within another program, that program-name can be referenced only by statements included in that containing program

    ISO2002 MF OS390 or, if the program possesses the recursive attribute, in the program itself

    .

  2. If the program-name is that of a program which does possess the common attribute and which is directly contained within another program, that program-name can be referenced only by statements included in that containing program and any programs directly or indirectly contained within that containing program

    ISO2002 MF OS390 , except that the program possessing the common attribute and any programs contained within it may reference the program-name only if the program possesses the recursive attribute.

  3. If the program-name is that of a program that is not contained in another program, it can be referenced by statements included in any source element in the run unit.

For example, suppose that ProgA contains ProgB and ProgC, ProgC contains ProgD and ProgF, and ProgD contains ProgE, as shown below.

Example of Scope of Program-Names

If ProgD does not possess the COMMON attribute, then ProgD can only be referenced by the program that directly contains ProgD, that is, ProgC.

If ProgD does possess the COMMON attribute, then ProgD can be referenced by ProgC since it contains ProgD and by any programs contained in ProgC except for programs contained in ProgD, that is, by ProgF but not by ProgE. Also it cannot be referenced by ProgA or ProgB.

Parent topic: Scope of Names


Conventions for Condition-names, Data-names, File-names, Record-names, Report-names and Typedef-names

Conventions for Condition-names, Data-names, File-names, Record-names, Report-names and MF Typedef-names

When condition-names, data-names, file-names, record-names and report-names

MF and typedef-names

are declared in a source element, they can be referenced only by that source element unless one or more of the names is global and the source element contains other source elements.

The requirements governing the uniqueness of the names declared by a single source element to be condition-names, data-names, file-names, record-names and report-names

MF and typedef-names

are explained in the discussion of user-defined words in the section COBOL Words.

A source element cannot reference any condition-name, data-name, file-name, record-name or report-name

MF or typedef-name

declared in any source element it contains.

A global name can be referenced in the source element in which it is declared or in any source elements which are directly or indirectly contained within that source element.

When a source element, source element B, is directly contained within another source element, source element A, both source elements can define a condition-name, a data-name, a file-name, a record-name or a report-name

MF or a typedef-name

using the same user-defined word. When such a duplicate-name is referenced in source element B, the following rules are used to determine the referenced item:

  1. The set of names to be used for determination of a referenced item consists of all names that are defined in source element B and all global names that are defined in source element A and in any source elements which directly or indirectly contain source element A. Using this set of names, the normal rules for qualification and any other rules for uniqueness of reference are applied until one or more item is identified.
  2. If only one item is identified, it is the referenced item.
  3. If more than one item is identified, no more than one of them can have a name local to source element B. If zero or one of the items has a name local to source element B, the following rules apply:
    1. If the name is declared in source element B, the item in source element B is the referenced item.
    2. Otherwise, if source element A is contained within another source, the referenced item is:
      1. The item in source element A if the name is declared in source element A.
      2. The item in the containing source element if the name is not declared in source element A and is declared in the source element containing source element A. This rule is applied to further containing source elements until a single valid name has been found.
Parent topic: Scope of Names
Related information
COBOL Words


Conventions for Index-names

If a data item possessing the global attribute includes a table described with an index-name, that index-name also possesses the global attribute. Therefore, the scope of an index-name is identical to that of the data-name which names the table whose index is named by that index-name and the scope of name rules for data-names apply.

Index-names cannot be qualified.

OSVS Index-names can be qualified.

Parent topic: Scope of Names


Conventions for Class-names (for Object Orientation) and Interface-names

The class-name of a class referenced within a source element must be either the name of the containing class definition or declared in the Repository paragraph

MF or the Class-Control paragraph

of that or a containing source element.

Within a compilation group, there must be at most one class definition for a given class-name.

The interface-name of an interface referenced within a source element must be either the name of the containing interface definition or declared in the Repository paragraph of that or a containing source element.

Within a compilation group, there must be at most one interface definition for a given interface-name.

A class-name or interface-name declared in the Repository paragraph of a source element may be used in that source element and any nested source element.

MF A class-name or interface-name declared in the Class-Control paragraph of a source element may be used in that source element and any nested source element.

Parent topic: Scope of Names


Conventions for Method-names

A method-name of a method is declared in the Method-ID paragraph. A method-name must be referenced only by the INVOKE statement, an inline method invocation and the end method header.

The methods declared in a class definition must have unique method-names within that class definition. The methods declared in a child class may have the same name as a method in the parent class, subject to the conditions for the Method-ID paragraph.

The methods declared in an interface definition must have unique method-names within that interface definition. The methods declared in an inheriting interface can have the same name as a method in the inherited interface, subject to the conditions stated for the Method-ID paragraph.

Parent topic: Scope of Names


Conventions for Function-prototype-names

Function-prototype-names referenced within a source element must be either the name of the containing function definition or declared in the Repository paragraph of that or a containing source element.

If a function prototype is specified in a Repository paragraph and the function prototype declaring the same function-prototype-name is also specified within the same compilation group, the function prototype specification is used and the information in the external repository for this prototype is ignored.

Parent topic: Scope of Names


Conventions for Program-prototype-names

Program-prototype-names referenced within a source element must be either the program-name of a containing program definition or a program-prototype-name declared in the Repository paragraph

If a program prototype is specified in a Repository paragraph and the program prototype declaring the same program-prototype-name is also specified within the same compilation group, the program prototype specification is used and the information in the external repository for this prototype is ignored.

Parent topic: Scope of Names


Literals

A literal is any of:

  • A character-string whose value is implied by the ordered set of characters of which it is composed
  • A reserved word which references a figurative constant
  • MF A user-defined word which references a constant value

Every literal belongs to one of three types; nonnumeric, numeric and national.

Parent topic: Language Structure


Nonnumeric Literals

A nonnumeric literal is a character-string delimited at both ends by quotation marks

ISO2002 OSVS VSC2 MF or apostrophes

and consisting of any allowable character in the computer's character set. Nonnumeric literals may be of 1 to 160 characters in length. Whether quotation marks

ISO2002 OSVS VSC2 MF or apostrophes

are used as delimiters, the presence of that delimiter within a nonnumeric literal can be represented by two contiguous occurrences. The presence of the character that is not serving as the delimiter is represented by a single occurrence. The value of a nonnumeric literal in the run-time element is the string of characters itself, except:

  • The delimiting quotation marks are excluded, and
  • Each embedded pair of contiguous delimiter characters represents a single character.

All other punctuation characters are part of the value of the nonnumeric literal rather than separators; all nonnumeric literals are category alphanumeric. (See the topic The PICTURE Clause.)

VSC2 MF In addition, hexadecimal binary values can be attributed to nonnumeric literals by expressing literals as: X"nn", where each n is a hexadecimal digit in the set 0 through 9, A through F; nn can be repeated up to 160 times, but the number of hexadecimal digits must be even.

MF The number of hexadecimal digits may be odd.

MF In addition, a nonnumeric literal can be null-terminated (i.e. have a null byte x"00" at the end of the lietral) by expressing it as: Z"string", where string is a non-numeric literal.

Parent topic: Language Structure
Related information
The PICTURE Clause


Numeric Literals

Numeric literals can be either fixed-point or floating-point numbers.

Fixed-Point Numeric Literals

A numeric literal is a character-string whose characters are selected from the digits 0 through 9, the plus sign, the minus sign, and the decimal point. This implementation allows for numeric literals of 1 to 18 digits in length. The rules for the formation of numeric literals are as follows:

  • A literal must contain at least one digit.
  • A literal must not contain more than one sign character. If a sign is used, it must appear as the leftmost character of the literal. If the literal is unsigned, the literal is positive.
  • A literal must not contain more than one decimal point. The decimal point is treated as an assumed decimal point, and can appear anywhere within the literal except as the rightmost character. If the literal contains no decimal point, the literal is an integer.
  • The value of a numeric literal is the algebraic quantity represented by the characters in the numeric literal. Every numeric literal is category numeric. (See the topic The PICTURE Clause.)

If a literal conforms to the rules for the formation of numeric literals, but is enclosed in quotation marks, it is a nonnumeric literal and is treated as such by your COBOL system.

The size of a numeric literal in standard data format characters is equal to the number of digits specified by the user.

MF In addition, hexadecimal binary values can be attributed to numeric literals by expressing literals as: H" nn ", where each n is a hexadecimal digit in the set 0-9 A-F; nn can be repeated up to 8 times, but the number of hexadecimal digits must be even.

Floating-Point Numeric Literals

A floating-point literal is written in the form:

If you omit a sign, the system assumes a positive number.

The significand can contain between 1 and 16 digits. A decimal point must be included in the significand.

The exponent is represented by an E followed by an optional sign and one or two digits.

The magnitude of a floating-point literal value must fall between 0.54E-78 and 0.72E+76. For values outside this range, an error message is produced and the value is replaced by 0 or 0.72E+76 respectively. You must not use a floating-point literal when an integer literal is required.

Parent topic: Language Structure
Related information
The PICTURE Clause


National Literals

A national literal is a string of national characters represented in the storage of the computer as characters of a uniform size. See your COBOL system documentation on national data (Unicode) for further information.

General Formats for Format 1

General Formats for Format 2

Syntax Rules for All Formats

  1. The length of a national literal, excluding the separators that delimit the literal, must be greater than zero and less than or equal to 160 national character positions.
  2. Character 1 can be any character in the alphanumeric coded character set such that a correspondence exists between that alphanumeric character and a national character.

Syntax Rules for Format 1

  3. Two contiguous quotation symbol characters matching the quotation symbol used in the opening delimiter represent a single occurrence of that quotation symbol character in the content of the literal. The two contiguous quotation symbol characters must be in the same coded character set representation as the opening quotation symbol.

Syntax Rules for Format 2

  4. Each hex-character-sequence-1 must consist of four hexadecimal digits (two bytes) coded with the high-order byte first

General Rules for All Formats

  1. The separators that delimit the national literal are not included in the value of the national literal.
  2. National literals are of the class and category national.

General Rules for Format 1

  3. The value of the literal at compile time is the string of occurrences of character-1 represented in the computer’s compile-time coded character set.

    The value of the literal at runtime is the string of national characters that results from converting the compile-time value of the literal to its runtime equivalent.

General Rules for Format 2

  4. The value of the literal at runtime is a string of national characters, each of which has the bit configuration specified by one occurrence of hex-character-sequence-1.
Parent topic: Language Structure


Figurative Constant Values

Figurative constant values are generated by your COBOL system and referenced through the use of the reserved words given below. These words must not be bounded by quotation marks when used as figurative constants. The singular and plural forms of figurative constants are equivalent and can be used interchangeably.

The figurative constant values and the reserved words used to reference them are shown in the table below.

Table 1. Figurative Constants and Their Reserved Words
Constant | Representation
ZERO ZEROS ZEROES | Represents the value "0", or one or more of the character "0" depending on the context.
SPACE SPACES | Represents one or more of the character space from the computer's character set.
HIGH-VALUE HIGH-VALUES | Represents one or more of the character that has the highest ordinal position in the program collating sequence. (x"FF" for the extended ASCII character set.)
LOW-VALUE LOW-VALUES | Represents one or more of the character that has the lowest ordinal position in the program collating sequence. (x"00" for the ASCII character set.)
QUOTE QUOTES | Represents one or more of the character """. The word QUOTE or QUOTES cannot be used in place of a quotation mark in a source program to bound a nonnumeric literal. Thus QUOTE ABD QUOTE is incorrect as a way of stating "ABD".
ALL literal | Represents one or more characters of the string of characters comprising the literal. The literal must be either a nonnumeric literal or ISO2002 MF a national literal or a figurative constant other than ALL literal. ISO2002 MF XOPEN This nonnumeric literal and this national literal may be concatenation expressions. When a figurative constant is used, the word ALL is redundant and is used for readability only.
NULL NULLS | Represents one or more unset pointer MF COB370 or procedure-pointer values. A data item with USAGE POINTER MF COB370 or PROCEDURE-POINTER and with a value of NULL is guaranteed not to represent the address of any data item MF COB370 or procedure . The NULL value varies between environments and is generally consistent with the equivalent value used in non-COBOL languages for each environment.

When a figurative constant represents a string of one or more characters, the length of the string is determined by your COBOL system from context by applying the following rules in order:

  1. ISO2002 MF XOPEN When a figurative constant is specified in a concatenation expression, the length of the string is one character.
  2. When a figurative constant is either specified in a VALUE clause, or associated with another data item, (for example, when the figurative constant is moved to or compared with another data item), the string of characters specified is repeated character by character on the right until the size of the resultant string is greater than or equal to the number of character positions in the associated data item. This resultant string is then truncated from the right until the number of character positions remaining is equal either to 1 or to the number of character positions in the associated data item, whichever is greater. This is done prior to and independent of the application of any JUSTIFIED clause that can be associated with the data item.
  3. When a figurative constant is other than ALL literal, the length of the string is one character.
  4. The length of the string is the length of the literal.

    MF Use of figurative constants in Format 3 DISPLAY statements has specific effects, described in the General Rules for that statement.

A figurative constant can be used wherever a literal appears in a format, except that whenever the literal is restricted to having only numeric characters in it, the only figurative constant permitted is ZERO (ZEROS, ZEROES).

When the figurative constants HIGH-VALUE(S) or LOW-VALUE(S) are used , the actual character associated with each figurative constant depends upon the program collating sequence specified. (See the topics The Object-Computer Paragraph and the The Special-Names Paragraph.)

Each reserved word that is used to reference a figurative constant value is a distinct character-string, with the exception of the construction "ALL literal" which is composed of two distinct character-strings.

OSVS VSC2 MF The value associated with the QUOTE/QUOTES figurative constant is sensitive to the APOST and QUOTE directives.

ANS85 The figurative constant ALL literal, when associated with a numeric or numeric edited item, and when its length is greater than one, is classed as an obsolete element in the ANSI'85 standard and is scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects within this COBOL implementation fully support this obsolete ALL literal syntax. The FLAGSTD directive can be used to detect all occurrences of this syntax.

XOPEN Although this obsolete ALL literal syntax is a part of the standard COBOL definition, this syntax is explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

Parent topic: Language Structure
Related information
The Object-Computer Paragraph
The Special-Names Paragraph


Constant-names

Constant-names are user-defined words described in the Data Division in level-78 data description entries. A constant-name may be used wherever a literal appears in a format. Its effect is as if the literal in the VALUE clause of its data description had been written instead. A constant-name with an integer value can also be used wherever a format requires an integer; for example, as a level number or segment number, or in a PICTURE character-string.

A constant-name can only be used after it has been described; that is, it cannot be the object of a forward reference.

Parent topic: Language Structure


Concatenation Expressions

A concatenation expression consists of two operands separated by the concatenation operator.

General Format

Syntax Rules

  1. Both operands must be of the same class, except that a figurative constant may be specified as one or both operands. Neither operand must be numeric. Neither literal-1 nor literal-2 must be a figurative constant that begins with the word ALL.
  2. ISO2002 The length of the value resulting from concatenation must be less than or equal to 160 character positions.

General Rules

  1. The class of the concatenation expression resulting from the concatenation operation must be:
    1. When one of the operands is a figurative constant, the class of the literal or concatenation expression that constitutes the other operand, or
    2. When both of the operands are figurative constants, the class alphanumeric, or
    3. The same class as the operands.
  2. The value of a concatenation expression must be the concatenation of values of the literals, figurative constants and concatenation expressions of which it is composed.
  3. A concatenation expression must be equivalent to a literal of the same class and value, and may be used anywhere a literal of that class may be used.
Parent topic: Language Structure


Special Registers

Special registers are data items or transient values generated by your COBOL system and referenced through the use of their associated names or expressions. These special registers are subject to special rules of reference and have implicit data descriptions (PICTUREs), as individually described.
Table 1. Special Registers
Special Register Name or Expression | Implicit Data Description Picture | Usage
VSC2 MF ADDRESS OF data-name-1 USAGE IS POINTER The expression generates a pointer value representing the address of data-name-1. The expression is explicitly shown in the general format for statements in which it can be used. Data-name-1 must be a data item declared in the Linkage Section with a level number or 01 or 77

MF or must be declared anywhere in the Data Division and with any level number

.

OSVS CURRENT-DATE 1 | X(8) | The CURRENT-DATE special register contains the value of the current date (as supplied by the COBOL execution environment), in the form: MM/DD/YY where MM is the month number, DD is the day of the month, and YY is the year number (from 1900). CURRENT-DATE is valid only as the sending area of a MOVE statement.
DEBUG-ITEM | A group item of variable size | The DEBUG-ITEM special register provides information about the conditions that caused the execution of a Debugging Section. For further information see the section Debug Module.
VSC2 MF LENGTH OF data-name-2 2 9(9) The expression generates a value representing the current number of bytes of storage used by data-name-2. The expression can be used wherever a numeric data item can be used except as a subscript or a reference modifier.

MF It can also be used to set the value of a level 78 item.

LINAGE-COUNTER | The LINAGE-COUNTER special register is generated by the presence of a LINAGE clause in a file description entry for a record sequential file. The implicit description is that of an unsigned integer whose size is equal to the size of integer-1 or the data item referenced by data-name-1 in the LINAGE clause.
OSVS VSC2 MF RETURN-CODE 3 S9(4) COMP

XOPEN S9(9) COMP

The RETURN-CODE special register can:
  • be set by a program, prior to the execution of a STOP RUN, EXIT PROGRAM or GOBACK statement, to pass a value to the calling run-time element (or the execution environment)
  • be read, subsequent to a CALL to another COBOL program, to obtain the value of the RETURN-CODE special register set by that CALLed program.

A program's RETURN-CODE special register is set to zero when that program is first entered. RETURN-CODE is valid as a data-name in a Procedure Division statement wherever an elementary data item can be referenced.

VSC2 SHIFT-IN | X(1) | Used to switch the character representation from double-byte characters (DBCS) back to single-byte characters (SBCS) in environments where this is applicable.
VSC2 SHIFT-OUT | X(1) | Used to switch the character representation from single-byte characters (SBCS) to double-byte characters (DBCS) in environments where this is applicable.
VSC2 SORT-CONTROL | X(8) | Used only during sort and merge operations. You can reference it in the Procedure Division but it will contain spaces.
OSVS VSC2 SORT-CORE-SIZE | S9(8) COMP | Used only during sort and merge operations. You can reference it in the Procedure Division but it will contain zeros.
OSVS VSC2 SORT-FILE-SIZE | S9(8) COMP | Used only during sort and merge operations. You can reference it in the Procedure Division but it will contain zeros.
OSVS VSC2 SORT-MESSAGE | X(8) | Used only during sort and merge operations. You can reference it in the Procedure Division but it will contain spaces.
OSVS VSC2 SORT-MODE-SIZE | S9(5) COMP | Used only during sort and merge operations. You can reference it in the Procedure Division but it will contain zeros.
OSVS VSC2 MF SORT-RETURN | S9(4) COMP | SORT-RETURN can be used to cause an abnormal termination of a SORT procedure. If a value of 16 is moved into this field, the SORT operation is terminated after the next RELEASE or RETURN.
OSVS VSC2 TALLY | 9(5) COMP | The TALLY special register contains information produced by the EXAMINE...TALLYING statement. It is valid as a data-name in a Procedure Division statement wherever an elementary data item can be referenced.
OSVS TIME-OF-DAY | 9(6) DISPLAY | The TIME-OF-DAY special register contains the value of the current time of day (24-hour clock) (as supplied by the COBOL execution environment), in the form: hhmmss where hh =hour, mm =minutes, and ss =seconds. TIME-OF-DAY is valid only as the sending area of a MOVE statement.
OSVS WHEN-COMPILED X(20) The WHEN-COMPILED special register contains the time and date that the COBOL compilation group was submitted to your COBOL system, in the form: hh.mm.ssMMM DD, YYYY where hh =hours (24-hour clock), mm =minutes, ss =seconds, MMM =month name (first 3 characters), DD =day of month, and YYYY =year.

WHEN-COMPILED is valid only as the sending area of a MOVE statement.

VSC2 WHEN-COMPILED X(20) The WHEN-COMPILED special register contains the time and date that the COBOL compilation group was submitted to your COBOL system, in the form: MM/DD/YYhh.mm.ss where DD, hh, mm and ss are as above. YY =year in century and MM =month in year.

WHEN-COMPILED is valid only as the sending area of a MOVE statement.

ENT MF XML-CODE 4 | S9(9) COMP | The XML-CODE special register is used to communicate status between the XML parser and the processing procedure identified in the XML PARSE statement. The XML parser sets XML-CODE for each event and at parser termination. You can reset XML-CODE in the processing procedure to -1 after a normal event, to indicate that the parser is to terminate with a user-initiated exception, which is not an EXCEPTION XML event, indicated by the returned XML-CODE value of -1.
ENT MF XML-EVENT 5 | X(30) | The XML-EVENT special register is used to communicate event information from the XML parser to the processing procedure that was identified in the XML PARSE statement. Before passing control to the processing procedure, the XML parser sets the XML-EVENT special register to the name of the XML event. XML-EVENT cannot be used as a receiving data item.
ENT MF XML-NTEXT The XML-NTEXT special register is defined during XML parsing to contain document fragments that are USAGE NATIONAL. XML-NTEXT is an elementary national data item of the length of the contained XML document fragment. The length of XML-NTEXT varies dynamically at run time.
The parser sets XML-NTEXT to the document fragment associated with an event before transferring control to the processing procedure in these cases:
  • When the operand of the XML PARSE statement is a data item of category national or the RETURNING NATIONAL phrase is specified in the XML PARSE statement
  • For the ATTRIBUTE-NATIONAL-CHARACTER event
  • For the CONTENT-NATIONAL-CHARACTER event

When XML-NTEXT is set, the XML-TEXT special register has a length of zero. At any given time, only one of the two special registers XML-NTEXT and XML-TEXT has a non-zero length.

Use the LENGTH function to determine the number of national characters that XML-NTEXT contains.

XML-NTEXT cannot be used as a receiving item.

ENT MF XML-TEXT The XML-TEXT special register is defined during XML parsing to contain document fragments that are of class alphanumeric. XML-TEXT is an elementary alphanumeric data item of the length of the contained XML document fragment. The length of XML-TEXT varies dynamically at run time.

The parser sets XML-TEXT to the document fragment associated with an event before transferring control to the processing procedure when the operand of the XML PARSE statement is an alphanumeric data item and the RETURNING NATIONAL phrase is not specified in the XML PARSE statement, except for the ATTRIBUTE-NATIONAL-CHARACTER event and the CONTENT-NATIONAL-CHARACTER event.

When XML-TEXT is set, the XML-NTEXT special register has a length of zero. At any given time, only one of the two special registers XML-NTEXT and XML-TEXT has a non-zero length.

Use the LENGTH function or the LENGTH OF special register for XML-TEXT to determine the number of bytes that XML-TEXT contains.

XML-TEXT cannot be used as a receiving item.

Table 2. Contents of XML events and associated special register contents
XML-EVENT6 | XMLPARSE(XMLSS) | XMLPARSE(COMPAT)
ATTRIBUTE-CHARACTER | N/A | XML-TEXT or XML-NTEXT contains the single character that corresponds with the predefined entity reference in the attribute value.
ATTRIBUTE-CHARACTERS | XML-TEXT or XML-NTEXT contains the value within quotation marks or apostrophes. This can be a substring of the attribute value. | XML-TEXT or XML-NTEXT contains the value within quotation marks or apostrophes. This can be a substring of the attribute value if the value includes a character reference or an entity reference.
ATTRIBUTE-NAME | For attribute names that are not in a namespace, XML-TEXT or XML-NTEXT contains the attribute name. For attributes with names in a nondefault namespace, attribute names are always prefixed and have the form: prefix: local-part = " AttValue ". XML-TEXT or XML-NTEXT contains the local-part , XML-NAMESPACE or XML-NNAMESPACE contains the namespace identifier, and XML-NAMESPACE-PREFIX or XML-NNAMESPACE-PREFIX contains the prefix . | XML-TEXT or XML-NTEXT contains the attribute name (the string to the left of the equal sign).
ATTRIBUTE-NATIONAL-CHARACTER | Regardless of the type of the XML document, XML-TEXT is empty with length zero and XML-NTEXT contains the single national character that correponds with the numeric character reference. | XML-TEXT or XML-NTEXT content is the same as for XMLPARSE(XMLSS).
COMMENT | XML-TEXT or XML-NTEXT contains the text of the comment between the opening character sequence "<!--" and the closing character sequence "-->". This can be a substring of the text. | XML-TEXT or XML-NTEXT always contains the complete text of the comment.
CONTENT-CHARACTER | N/A | XML-TEXT or XML-NTEXT contains the single character that corresponds with the predefined entity reference in the element content.
CONTENT-CHARACTERS | XML-TEXT or XML-NTEXT contains the character content of the element between start and end tags. This can be a substring of the content. | XML-TEXT or XML-NTEXT contains the character content of the element between start and end tags. This can be a substring of the character content if the content includes a character reference or an entity reference.
CONTENT-NATIONAL-CHARACTER | Regardless of the type of the XML document, XML-TEXT is empty with length zero and XML-NTEXT contains the single national character that corresponds with the numeric character reference. | XML-TEXT or XML-NTEXT content is the same as for XMLPARSE(XMLSS).
DOCUMENT-TYPE-DECLARATION | XML-TEXT or XML-NTEXT contains the name of the root element, as specified in the document type delcaration. | XML-TEXT or XML-NTEXT contains the entire document type declaration, including the opening and closing character sequences "<!DOCTYPE" and ">".
ENCODING-DECLARATION | XML-TEXT or XML-NTEXT contains the value, between quotation marks or apostrophes, of the encoding declaration in the XML declaration. | XML-TEXT or XML-NTEXT content is the same as for XMLPARSE(XMLSS).
END-OF-CDATA-SECTION | All XML special registers except XML-CODE and XML-EVENT are empty with length zero. | XML-TEXT or XML-NTEXT contains the string "]]>".
END-OF-DOCUMENT | All XML special registers except XML-CODE and XML-EVENT are empty with length zero. | XML-TEXT or XML-NTEXT content is the same as for XMLPARSE(XMLSS).
END-OF-ELEMENT | XML-TEXT or XML-NTEXT contains the local part of the end element tag or empty element tag name. If the element name is in a nondefault namespace, XML-NAMESPACE or XML-NNAMESPACE contains the namespace identifier. If the element name is in a namespace and is prefixed (of the form prefix: local-part ), XML-NAMESPACE-PREFIX or XML-NNAMESPACE-PREFIX contains the prefix. | XML-TEXT or XML-NTEXT contains the name of the end element tag or empty element tag.
END-OF-INPUT | All XML special registers except XML-CODE and XML-EVENT are empty with length zero. To parse an additional segment of an XML document, move the next segment to identifier-1 and set XML-CODE to 1. | N/A
EXCEPTION | XML-CODE contains the unique return code and reason code that identifies the exception. XML-TEXT or XML-NTEXT contains the document fragment up to the point of the error or anomaly that caused the exception. All other XML special registers are empty with length zero. | XML-CODE contains the unique error code that identifies the exception. XML-TEXT or XML-NTEXT contains the part of the document that was successfully scanned, up to and including the point at which the exception was detected.
NAMESPACE-DECLARATION | XML-TEXT and XML-NTEXT are both empty with length zero. XML-NAMESPACE or XML-NNAMESPACE contains the declared namespace identifier. If the namespace is "undeclared" by specifying the empty string, XML-NAMESPACE and XML-NNAMESPACE are empty with length zero. XML-NAMESPACE-PREFIX or XML-NNAMESPACE-PREFIX contains the prefix if the namespace declaration is of the form xmlns: prefix = " namespace-identifier "; otherwise, if the declaration is for the default namespace and thus the attribute name is xmlns , XML-NAMESPACE-PREFIX and XML-NNAMESPACE-PREFIX are both empty with length zero. | N/A (ATTRIBUTE-NAME and ATTRIBUTE-CHARACTERS events are signaled instead.)
PROCESSING-INSTRUCTION-DATA | XML-TEXT or XML-NTEXT contains the rest of the processing instruction (after the target name), not including the closing sequence "?>", but including trailing, and not leading, white space characters. This can be a substring of the processing instruction data. | XML-TEXT or XML-NTEXT always contains the complete processing instruction data.
PROCESSING-INSTRUCTION-TARGET | XML-TEXT or XML-NTEXT contains the processing instruction target name, which occurs immediately after the processing instruction opening sequence, "<?". This event can occur multiple times for a given processing instruction: one occurrence preceding each substring of the data. | XML-TEXT or XML-NTEXT content is the same as for XMLPARSE(XMLSS). This event occurs only once for a given processing instruction.
STANDALONE-DECLARATION | XML-TEXT or XML-NTEXT contains the value, between quotation marks or apostrophes ("yes" or "no"), of the stand-alone declaration in the XML declaration. | XML-TEXT or XML-NTEXT content is the same as for XMLPARSE(XMLSS).
START-OF-CDATA-SECTION | All XML special registers except XML-CODE and XML-EVENT are empty with length zero. | XML-TEXT or XML-NTEXT contains the string "<![CDATA[".
START-OF-DOCUMENT | All XML special registers except XML-CODE and XML-EVENT are empty with length zero. | XML-TEXT or XML-NTEXT contains the entire document.
START-OF-ELEMENT | XML-TEXT or XML-NTEXT contains the local part of the start element tag name or the local part of the empty element tag name. If the element name is in a namespace, XML-NAMESPACE or XML-NNAMESPACE contains the namespace identifier. If the element name is in a namespace and is prefixed (of the form prefix: local-part , XML-NAMESPACE-PREFIX or XML-NNAMESPACE-PREFIX contains the prefix. | XML-TEXT or XML-NTEXT contains the name of the start element tag or empty element tag, also known as the element type.
UNKNOWN-REFERENCE-IN-ATTRIBUTE | For XMLPARSE(XMLSS), the parser always signals EXCEPTION. | XML-TEXT or XML-NTEXT contains the entity reference name, not including the "&" and ";" delimiters.
UNKNOWN-REFERENCE-IN-CONTENT | For XMLPARSE(XMLSS), the parser signals UNRESOLVED-REFERENCE or EXCEPTION instead. | XML-TEXT or XML-NTEXT contains the entity reference name, not including the "&" and ";" delimiters.
UNRESOLVED-REFERENCE | XML-TEXT or XML-NTEXT contains the entity name from XML content, not including the "&" and ";" delimiters. | N/A (The parser signals UNKNOWN-REFERENCE-IN-CONTENT instead.)
VERSION-INFORMATION | XML-TEXT or XML-NTEXT contains the value, between quotation marks or apostrophes, of the version information in the XML declaration. | XML-TEXT or XML-NTEXT content is the same as for XMLPARSE(XMLSS).
Parent topic: Language Structure
1 The format of the contents of the CURRENT-DATE special register is sensitive to the CURRENT-DATE directive.
2 The LENGTH OF special register may be followed by an alphanumeric literal when using the Micro Focus dialect.
3 The size of the RETURN-CODE special register is sensitive to the XOPEN and RTNCODE-SIZE directives.
4 For a list of supported exception codes, see the topic XML-CODE Exception Codes.
5 The contents of XML-TEXT and XML-NTEXT vary depending on the contents of XML-EVENT. See Table 2 for additional information.
6 For all events except EXCEPTION, XML-CODE contains zero. Unless stated otherwise, the namespace XML registers (XML-NAMESPACE, XML-NNAMESPACE, XML-NAMESPACE-PREFIX, and XML-NNAMESPACE-PREFIX) are empty and have length zero.


Predefined Object Identifiers

The predefined object identifiers are:

Predefined Object Identifier | Usage
SELF | References the object on which the current method is executing. May be used in the Procedure Division of a method. References the object that was used to invoke the method in which SELF appears. If SELF is specified for a method invocation, the search for the method includes all methods declared for the object.
SELFCLASS | References the object that is the class object of the current object (SELF). If SELF is itself a class object, SELFCLASS is the system class BEHAVIOR. The class object BEHAVIOR terminates this self-reference. (i.e., If SELF is the BEHAVIOR of class, so is SELFCLASS.)
SUPER | References the object on which the current method is executing. May be used in the Procedure Division of a method. May be the object used to invoke a method with the INVOKE statement or inline invocation. References the object that was used to invoke the method in which SELF appears. If SUPER is specified for a method invocation, the search for the method ignores all the methods defined in the same class as the executing method.
NULL | References the null object reference value, which is a unique value that is guaranteed to never reference an object. NULL is implicitly described as class object and category object reference, and is not a universal object reference. NULL must not be specified as a receiving operand.
Parent topic: Language Structure


PICTURE Character-Strings

A PICTURE character-string consists of certain combinations of characters in the COBOL character set, used as symbols. See the topic The PICTURE Clause for the PICTURE character-string and for the rules that govern its use.

Any punctuation character that appears as part of the specification of a PICTURE character-string is not considered to be a punctuation character, but a symbol used in the specification of that PICTURE character-string.

Parent topic: Language Structure
Related information
The PICTURE Clause


Comment-entries

A comment-entry is an entry in the Identification Division that can be any combination of characters from the computer's character set. A comment-entry is for documentary purposes only, may extend over more than one line and is terminated upon encountering a division, section or paragraph name that is a reserved word

OSVS or encountering any character

in area A of a line. The continuation of a comment-entry by the use of the hyphen in the indicator area is not permitted.

Parent topic: Language Structure


Formats and Rules

  • General Format
  • Syntax Rules
  • General Rules
  • Elements
Parent topic: Concepts of the COBOL Language


General Format

A general format is the specific arrangement of the elements of a clause or a statement. Throughout this document a format is shown adjacent to information defining the clause or statement. When more than one specific arrangement is permitted, the general format is separated into numbered formats. Clauses must be written in the sequence given in the general formats. (Clauses that are optional must appear in the sequence shown if they are used.) In certain cases, stated explicitly in the rules associated with a given format, the clauses can appear in sequences other than that shown. Applications, requirements or restrictions are shown as rules.

Parent topic: Formats and Rules


Syntax Rules

Syntax rules are those rules that define or clarify the order in which words or elements are arranged to form larger elements, such as phrases, clauses, or statements. Syntax rules also impose restrictions on individual words or elements.

These rules are used to define or clarify how the statement must be written; that is, the order of the elements of the statement and restrictions on what each element may represent.

Parent topic: Formats and Rules


General Rules

General rules are those rules that define or clarify the meaning or relationship of meanings of an element or set of elements. They are used to define or clarify the semantics of the statement and the effect that it has on either execution or on the way intermediate code is produced.

Parent topic: Formats and Rules


Elements

Elements which make up a clause or a statement consist of upper-case words, lower-case words, level-numbers, brackets, braces, connectives and special characters.

Parent topic: Formats and Rules


Concept of Computer-independent Data Description

To make data as computer-independent as possible, the characteristics or properties of the data are described in relation to a standard data format rather than to an equipment-oriented format. This standard data format is oriented to general data processing applications and uses the decimal system to represent numbers (regardless of the radix used by the computer) and the remaining characters in the COBOL character set to describe nonnumeric data items.

Parent topic: Concepts of the COBOL Language


Concept of Levels

A level concept or hierarchy is inherent in the structure of a logical data record. This concept arises from the need to specify subdivisions of a record for the purpose of data reference. Once a subdivision has been specified, it can be further subdivided to permit more detailed data referral.

The most basic subdivisions of a record, that is, those not further subdivided, are called elementary items; consequently, a record is said to consist of a sequence of elementary items, or the record itself can be an elementary item.

In order to refer to a set of elementary items, the elementary items are combined into groups. Each group consists of a named sequence of one or more elementary items. Groups, in turn, can be combined into groups of two or more groups, and so on. Thus, an elementary item can belong to more than one group.

  • Level-Numbers
Parent topic: Concepts of the COBOL Language


Level-Numbers

A system of level-numbers shows the organization of elementary items and group items. Since records are the most inclusive data items, level-numbers for records start at 01. Less inclusive data items are assigned higher (not necessarily successive) level-numbers not greater in value than 49. A maximum of 49 levels in a record is allowed. There are special level-numbers, 66, 77

MF , 78

and 88 which are exceptions to this rule (see below). Separate entries are written for each level-number used.

A group includes all group and elementary items following it until a level-number less than or equal to the level-number of that group is encountered. All items which are immediately subordinate to a given group item should be described using identical level-numbers greater than the level-number used to describe that group item

OSVS VSC2 ; this rule is not insisted upon

.

Example

Correct OSVS VSC2 MF Incorrect but Permitted
01 A.
  05 C-1.
    10 D PICTURE X.
    10 E PICTURE X.
  05 C-2.

01  A.
  05 C-1.
    10 D PICTURE X.
    10 E PICTURE X.
 04 C-2.

Four types of entries exist for which there is no true concept of level. These are:

  1. Entries that specify elementary items or groups introduced by a RENAMES clause.
  2. Entries that specify noncontiguous working storage and linkage data items.
  3. Entries that specify condition-names.
  4. MF Entries that specify constant-names.

Entries describing items by means of RENAMES clauses for the purpose of regrouping data items have been assigned the special level-number 66.

Entries that specify noncontiguous data items, which are not subdivisions of other items, and are not themselves subdivided, have been assigned the special level-number 77.

Entries that specify condition-names, to be associated with particular values of a conditional variable, have been assigned the special level-number 88.

MF Entries that specify constant-names, to be associated with the value of a particular literal, have been assigned the special level-number 78.

Figure 1. Example of Level-numbers Representing a Data Hierarchy
Example of Level-numbers Representing a Data Hierarchy

Note that indentation of COBOL source code is a readability convention only and is not part of the language.

Elementary items are by definition those items without any subordinate entries (entries without numerically greater level-numbers) following, and must have a storage definition associated with them (see the topics The PICTURE Clause and the The USAGE Clause).

Note that only elementary items (marked with an asterisk, "*", above) and FILLER items (marked with a "#" sign above) have storage explicitly reserved for them (in accordance with the associated PICTURE clause); non-elementary items have implicit storage associated with them of size determined by their subordinate items plus any FILLER bytes needed for synchronization (see the topic The SYNCHRONIZED Clause).

Level-numbers need not be consecutively ascending or descending as shown above for clarity; thus, the next subordinate level after 01 could be 05, and the next level 10, and so on.

The above data descriptions would produce storage allocation in the following manner:

Data Record Storage Allocation

where:

R-E-I | is Record-Entry-Item
M-G-I | is Major-Group-Item
R-G-I | is Regular-Group-Item
S-G | is Sub-Group
EI | is Elementary-Item
NEI | is Noncontiguous Elementary-Item
Parent topic: Concept of Levels
Related information
The PICTURE Clause
The USAGE Clause
The SYNCHRONIZED Clause


Class and Category of Data

Every elementary data item, every literal, and every function has a class and a category. The class and category of a data item are defined by its picture character string, by the BLANK WHEN ZERO clause, or by its usage; the class and category of a literal are defined in the section Literals.

ANS85 and the class and category of an intrinsic function are specified by the definition of that intrinsic function (see the topic Intrinsic Functions).

The category of a group item is alphanumeric.

The following table depicts the relationship of categories to classes of data for elementary items.

Table 1. Category and class relationships for elementary items
Class Category
Alphabetic
  • Alphabetic
Alphanumeric
  • Numeric edited
  • Alphanumeric edited
  • Alphanumeric
  • VSC2 MF DBCS
Index
  • Index
National
  • National
Numeric
  • Numeric
  • OSVS VSC2 MF Internal floating-point
  • OSVS VSC2 MF External floating-point
Object
  • ISO2002 MF Object-reference
Pointer
  • ISO2002 VSC2 MF Pointer
  • MF COB370 Procedure-pointer
  • Algebraic Signs
  • Standard Alignment Rules
  • Item Alignment for Increased Object-code Efficiency
  • Selection of Character Representation and Radix
  • Uniqueness of Reference
  • Explicit and Implicit Specifications
Parent topic: Concepts of the COBOL Language
Related information
Literals
Intrinsic Functions


Algebraic Signs

Algebraic signs fall into two categories:

  1. Operational signs, which are associated with signed numeric data items and signed numeric literals to indicate their algebraic properties.
  2. Editing signs, which appear on edited reports to identify the sign of the item.

The SIGN clause permits you to state explicitly the location of the operational sign. The clause is optional; if it is not used, operational signs are represented as described in the section Selection Of Character Representation And Radix.

Editing signs are inserted into a data item through the use of the sign control symbols of the PICTURE clause.

Parent topic: Class and Category of Data
Related information
Selection Of Character Representation And Radix


Standard Alignment Rules

The standard rules for positioning data within an elementary item depend on the category of the receiving item. These rules are:

  1. If the receiving data item is described as numeric:
    1. The data is aligned by decimal point and is moved to the receiving character positions with zero fill or truncation on either end as required
    2. When an assumed decimal point is not explicitly specified, the data item is treated as if it had an assumed decimal point immediately following its rightmost character and is aligned as in paragraph a. above.
  2. If the receiving data item is a numeric edited data item, the data moved to the edited item is aligned by decimal point with zero fill or truncation at either end as required within the receiving character positions of the data item, except where editing requirements cause replacement of the leading zeros.
  3. If the receiving data item is alphanumeric (other than a numeric edited data item), alphanumeric edited or alphabetic, the sending data is moved to the receiving character position and aligned at the leftmost character position in the data item with space fill or truncation to the right, as required.
  4. OSVS VSC2 MF If the receiving data item is external floating-point, the leftmost non-zero digit, if one exists, is aligned on the leftmost digit position: the exponent is adjusted accordingly.

If the JUSTIFIED clause is specified for the receiving item, these standard rules are modified as described in the section The JUSTIFIED Clause in the chapter Data Division - File and Data Description.

Parent topic: Class and Category of Data
Related information
The JUSTIFIED Clause


Item Alignment for Increased Object-code Efficiency

Some computer memories are organized so that natural addressing boundaries exist in the computer memory (for example, word boundaries, half-word boundaries, byte boundaries). The way in which data is stored need not respect these natural boundaries.

However, certain uses of data (for example, in arithmetic operations or in subscripting) can be facilitated if the data is stored so as to be aligned on these boundaries. Specifically, additional machine operations in the run-time element can be repeated for the accessing and storage of data if portions of two or more data items appear between adjacent natural boundaries, or if certain natural boundaries divide a single data item.

Data items which are aligned on these natural boundaries in such a way as to avoid additional machine operations are defined to be synchronized. A synchronized item is assumed to be introduced and carried in that form; conversion to synchronized form occurs only during the execution of a statement (other than READ or WRITE) which stores data in the item.

Synchronization can be accomplished in two ways:

  1. By use of the SYNCHRONIZED clause
  2. By organizing the data suitably on the appropriate natural boundaries without the use of the SYNCHRONIZED clause.

By use of the SYNCHRONIZED clause, the use of special types of alignment within a group can affect the results of statements in which the group is used as an operand. The effect of the implicit FILLER and the semantics of any statement referencing these groups is described later in this chapter.

Parent topic: Class and Category of Data


Selection of Character Representation and Radix

The value of a numeric item (defined as numeric by its PICTURE, see the topic The PICTURE Clause) can be represented in the computer's storage in either binary or decimal form depending on the USAGE clause of the declaration (see the topic The USAGE Clause). These numeric formats are:

  • DISPLAY
  • COMPUTATIONAL, COMP,

    ANS85 BINARY,

    OSVS VSC2 MF COMPUTATIONAL-4 or COMP-4

  • OSVS VSC2 MF XOPEN COMPUTATIONAL-3, COMP-3 or

    ANS85 PACKED-DECIMAL

  • MF XOPEN OS390 COMPUTATIONAL-5, COMP-5,
  • MF COMPUTATIONAL-X or COMP-X

  • OSVS VSC2 MF COMPUTATIONAL-1, COMPUTATIONAL-2

    ,

    ISO2002 FLOAT-SHORT or FLOAT-LONG

  • VSC2 MF POINTER
  • MF COB370 PROCEDURE-POINTER

ANS85 An alphanumeric function is always represented in the standard data format. Its size is determined by the definition of the function.

The representation of integer and numeric functions is as follows:

  • COMP-2 if the function is trigonometric or if one or more function arguments are COMP-2 and the function is not defined as returning an integer.
  • Otherwise, as PIC SV9(39)ES9(4). The exponent is S9(4) COMP and so has a range of approximately +/-32k.

Integer and numeric functions can be used only in arithmetic expressions, and represent the value resulting from the evaluation of the function without the restriction on composite of operands and/or receiving data items.

When a computer provides more than one means of representing data, the standard data format must be used for data items

ANS85 other than integer and numeric functions,

if not otherwise specified by the data description.

  • DISPLAY Format
  • COMPUTATIONAL, BINARY, or COMPUTATIONAL-4 Format
  • COMPUTATIONAL-1, COMPUTATIONAL-2,FLOAT-SHORT and FLOAT-LONG Formats
  • COMPUTATIONAL-3 or PACKED-DECIMAL Format
  • COMPUTATIONAL-X and COMPUTATIONAL-5 Formats
  • POINTER Format
  • PROCEDURE-POINTER Format
Parent topic: Class and Category of Data
Related information
The PICTURE Clause
The USAGE Clause


DISPLAY Format

The COBOL digit characters from 0 through 9 that represent the number value are held in radix 10, one digit character per byte of computer storage. This is the standard data format of the COBOL language.

If the data item is signed and the sign is not specified as SEPARATE (see the topic The SIGN Clause and the rules for the NUMERIC SIGN clause in the topic The Special-Names Paragraph) the numeric sign is incorporated into either the leading or trailing digit, according to the LEADING or TRAILING phrase in the SIGN clause. Signed data is incorporated into the requisite digit as shown in Table 4 below. (Effectively, bit 6 (hexadecimal value "40" ) of the character is set from 0 to 1 if the number has a negative value.)

If the data item is signed and the sign is specified as SEPARATE, then the sign is held as a separate single COBOL character, additional to the digits, either plus (+) or minus (-) as necessary.

If the data item is signed and no SIGN clause applies, the numeric sign is incorporated into the trailing digit, unless the NUMERIC SIGN clause is specified in the Special-Names paragraph. If the SIGN clause is specified in a data description entry, the NUMERIC SIGN clause, if specified, is ignored for that entry.

In the following table, the numbers in brackets represent the hexadecimal encoding for the COBOL character. On some systems, the encoding can be varied by the CHARSET and SIGN Compiler directives.

Table 1. DISPLAY Non-SEPARATE Sign-Digit Characters
Leading or trailing value digit before sign incorporation | Sign Digit Character for:
 | Positively-signed values |  |  | Negatively-signed values
 | Charset (ASCII) |  | Charset (EBCDIC) | Charset (ASCII) |  | Charset (EBCDIC)
 | Sign (ASCII) | Sign (EBCDIC) | Sign (EBCDIC) | Sign (ASCII) | Sign (EBCDIC) | Sign (EBCDIC)
0 | 0(30) | {(7B) | {(C0) | p(70) | }(7D) | }(D0)
1 | 1(31) | A(41) | A(C1) | q(71) | J(4A) | J(D1)
2 | 2(32) | B(42) | B(C2) | r(72) | K(4B) | K(D2)
3 | 3(33) | C(43) | C(C3) | s(73) | L(4C) | L(D3)
4 | 4(34) | D(44) | D(C4) | t(74) | M(4D) | M(D4)
5 | 5(35) | E(45) | E(C5) | u(75) | N(4E) | N(D5)
6 | 6(36) | F(46) | F(C6) | v(76) | O(4F) | O(D6)
7 | 7(37) | G(47) | G(C7) | w(77) | P(50) | P(D7)
8 | 8(38) | H(48) | H(C8) | x(78) | Q(51) | Q(D8)
9 | 9(39) | I(49) | I(C9) | y(79) | R(52) | R(D9)

Storage character position requirements for DISPLAY data items are thus equal to the number of "9"s in the PICTURE clause plus one if the sign is specified as SEPARATE. The SYNCHRONIZED clause has no effect on DISPLAY format data declarations.

Parent topic: Selection of Character Representation and Radix
Related information
The SIGN Clause
The Special-Names Paragraph


COMPUTATIONAL, BINARY, or COMPUTATIONAL-4 Format

COMPUTATIONAL, ANS85 BINARY, or OSVS VSC2 MF COMPUTATIONAL-4 Format

This format holds numeric data items in computer storage in pure binary two's complement representation. In this format, number values are held in radix of 2 where each computer bit in the representation starting from the right (least-significant) end represents the presence or absence of an increasingly significant power of 2 in that value. Negative numbers are represented by complementing (inverting all the bit values of) their positive counterpart, and then adding one to the whole. Storage requirements depend on the number of "9"s in the PICTURE clause, and whether the numeric data item is signed or unsigned (see the topics The PICTURE Clause, The SIGN Clause and The USAGE Clause); also your COBOL system assigns storage for COMPUTATIONAL items in one of two modes; byte-storage and word-storage. Byte-storage is the default storage-assignment mode for this COBOL implementation.

  • Computer Memory Natural Boundaries
  • Synchronization
  • Implicit Synchronization
  • Example of Implicit FILLER Assignments
  • Truncation
Parent topic: Selection of Character Representation and Radix
Related information
The PICTURE Clause
The SIGN Clause
The USAGE Clause


Computer Memory Natural Boundaries

The fundamental natural boundaries of a modern computer's memory are usually based on an eight-bit character, known as a byte. Within this fundamental framework, machines fall into two broad categories; those with no other natural boundaries, called here byte-storage computers, and those with other natural boundaries based upon multiples of the fundamental boundary of the byte, called here word-storage computers.

In byte-storage mode, COBOL assigns numeric storage so that each numeric item occupies the minimum number of bytes (see the section Selection Of Character Representation And Radix); the SYNCHRONIZED clause has no meaning in the context and hence has no effect.

Within word-storage computers, natural boundaries can occur at 2-byte, 4-byte and/or 8-byte boundaries. The COBOL language can provide such data item storage-assignment and synchronization when the COMPUTATIONAL clause and possibly the SYNCHRONIZED clause are used. This word-storage assignment of COMPUTATIONAL format data is controlled by the Compiler directive IBMCOMP.

Table 1. COMP(UTATIONAL) Format Data Item Character-Position (Byte) Storage Assignment
Number of Digits (9s) in PICTURE Representation |  | Number of Characters (Bytes) of Storage Assigned
Signed | Unsigned | Byte-Storage Mode | Word-Storage Mode
1-2 | 1-2 | 1 | 2
3-4 | 3-4 | 2 | 2
5-6 | 5-7 | 3 | 4
7-9 | 8-9 | 4 | 4
10-11 | 10-12 | 5 | 8
12-14 | 13-14 | 6 | 8
15-16 | 15-16 | 7 | 8
17-18 | 17-19 | 8 | 8
19-21 | 20-21 | 9 | 16
22-23 | 22-24 | 10 | 16
24-26 | 25-26 | 11 | 16
27-28 | 27-28 | 12 | 16
29-31 | 29-31 | 13 | 16
32-33 | 23-33 | 14 | 16
34-35 | 34-36 | 15 | 16
36-38 | 37-38 | 16 | 16
Parent topic: COMPUTATIONAL, BINARY, or COMPUTATIONAL-4 Format
Related information
Selection Of Character Representation And Radix


Synchronization

If a data item description contains the SYNCHRONIZED clause, and word-storage mode is enabled, the position of that item within the computer storage is aligned so that the right-hand (least-significant) end is on a natural boundary of the computer's storage. Extra character positions (bytes) of computer storage are reserved adjacent to synchronized items to achieve this alignment; these bytes, known as padding bytes or implicit FILLER bytes, are normally inaccessible to the computer program except as part of a group item.

Each elementary data item that is described as SYNCHRONIZED is aligned to the natural storage boundary that corresponds to its data item storage assignment (according to Table 5 in the topic Computer Memory Natural Boundaries above). Thus, in word-storage mode, a numeric data item with a PICTURE description of S9(5) would be assigned 4 bytes of storage (being 1 padding byte and 3 data bytes). If SYNCHRONIZED was specified, it would be aligned to the next nearest 4-byte boundary (that is, with the total (4-byte) storage assignment aligned such that the number of bytes from the beginning of the record containing that item to the left-hand (most-significant) end of that item was a multiple of four). If the previous item does not end on a 4-byte boundary, implicit FILLER assignments are necessary to achieve this.

Other such implicit FILLER bytes can be generated by the use of SYNCHRONIZED items in non-elementary data descriptions containing an OCCURS clause (see the topic The OCCURS Clause). This is because further bytes may need to be reserved for each group item occurrence in order that the second or subsequent occurrences have the same alignment to the natural boundaries of the computer storage as did the first occurrence.

Parent topic: COMPUTATIONAL, BINARY, or COMPUTATIONAL-4 Format
Related information
Computer Memory Natural Boundaries
The OCCURS Clause


Implicit Synchronization

With word-storage mode enabled, all record-level data descriptions are automatically synchronized to a full 8-byte boundary.

MF Where automatic alignment is enabled, it is sensitive to the ALIGN directive.

Parent topic: COMPUTATIONAL, BINARY, or COMPUTATIONAL-4 Format


Example of Implicit FILLER Assignments

The following COBOL data description produces the computer storage allocation shown in the figure below. An explanation of the symbols used is given below the figure.

01 UNSYNCHRONIZED-RECORD.
    02 UNSYNCHRONIZED-DATA-1        PIC 9(3) DISPLAY.
    02 UNSYNCHRONIZED-DATA-2        PIC X(2).
01 COMPOUND-REPEATED-RECORD.
    02 ELEMENTARY-ITEM-1            PIC X(2).
    02 GROUP-ITEM OCCURS 3 TIMES.
 03 ELEMENTARY-ITEM-2        PIC X.
 03 ELEMENTARY-ITEM-3        PIC S9(2) COMP SYNC.
 03 ELEMENTARY-ITEM-4        PIC S9(4)V9(2) COMP SYNC.
 03 ELEMENTARY-ITEM-5        PIC X(5).
Figure 1. Sample Computer Storage Allocation
Sample Computer Storage Allocation

where:

@ | indicates implicit FILLER bytes allocated due to automatic synchronization of a record (01-level) description.
# | indicates implicit FILLER bytes allocated when following data item is explicitly synchronized.
$ | indicates implicit FILLER bytes allocated when a non-elementary item is subject to an OCCURS clause.
9 | indicates bytes allocated for a numeric DISPLAY character.
A | indicates bytes allocated for an alphanumeric DISPLAY character.
C | indicates bytes allocated for a COMPUTATIONAL data storage.
Parent topic: COMPUTATIONAL, BINARY, or COMPUTATIONAL-4 Format


Truncation

In data items of USAGE COMP, data is held in binary format as described in the previous sections. The storage allocated for an item can have space for larger numbers than specified by the PICTURE clause. For example, an item described as PIC 99 COMP is normally assigned one byte, which can hold numbers up to 255.

To conform with the rules of ANSI COBOL, numbers behave as decimal numbers, regardless of their format. If, in an arithmetic statement, the result is bigger than the PICTURE clause of a receiving item allows, a size error occurs, and if the ON SIZE ERROR phrase is specified the result is not stored in the receiving item. In a non-arithmetic statement, if this situation occurs, the decimal value is truncated on the left, to the number of digits specified in the PICTURE clause.

OSVS VSC2 MF However, data in USAGE COMP items can be forced to behave as binary data, that is, truncation occurs only if it is necessary in order for the data to fit the space allocated. The behavior of USAGE COMP items is controlled by the setting of the COBOL Compiler directive TRUNC. This directive selects whether the decimal value is truncated to the picture size, or the binary value is truncated to the space available. It distinguishes between results of arithmetic statements, and data being moved by non-arithmetic statements.

Regardless of the setting of any directive, an arithmetic statement gives the size error condition if the result has more decimal digits than specified in the PICTURE clause of a receiving item.

  • Example of Truncation
Parent topic: COMPUTATIONAL, BINARY, or COMPUTATIONAL-4 Format


Example of Truncation

The TRUNC Compiler directive can change the results of some operations, as demonstrated in the following examples in which item A is described as PIC 99 COMP.

Operation | Result
 | TRUNC | NOTRUNC | TRUNC"ANSI"
MOVE 163 TO A | 63 | 163 | 63
MOVE 263 TO A | 63 | 7 | 63
MOVE 13 TO A, ADD 150 TO A | 63 | 163 | undefined results
MOVE 13 TO A, ADD 250 TO A | 63 | undefined results | undefined results
Note:
  1. This directive has no effect on the truncation of low-order digits in non-integer data. This always conforms with the behavior specified in ANSI COBOL.
  2. If the IBMCOMP Compiler directive is set, extra upper bytes may be allocated to a COMP item. These are counted in the space allocated. When IBMCOMP is on, padding bytes may be generated before a COMP item with a SYNC clause; these are not part of the item, and are never affected by data stored in the item.
  3. When a value being stored into a signed item is limited to the number of digits by the PICTURE clause, it can never be big enough to overwrite the sign bit. When the NOTRUNC directive is set this is not true, and the value, if large enough, overwrites the sign bit.
Parent topic: Truncation


COMPUTATIONAL-1, COMPUTATIONAL-2,FLOAT-SHORT and FLOAT-LONG Formats

OSVS VSC2 MF COMPUTATIONAL-1, COMPUTATIONAL-2, ISO2002 FLOAT-SHORT and FLOAT-LONG Formats

These formats are used for internal floating-point data items. Such data items can be used in all syntax where a numeric data item can be used and where the syntax is a part of the ANSI'74, ANSI'85, ISO2000, OSVS, or VSC2 COBOL language definition. Such data items cannot be used where integer data items are required unless explicitly allowed by the rules for a specific COBOL verb. An internal floating-point data item cannot be used in other syntax unless a specific rule allows it.

The internal storage format can differ from operating system to operating system. In all storage formats, four pieces of information are encoded:

  1. The exponent - the power of 10 to which the specific numeric value is multiplied.
  2. The exponent sign - an indication of whether the specific numeric value (significand) is multiplied by a "whole" number in the series, 1, 10, 100, and so on, or by a fractional number in the series 1/10, 1/100, 1/1000, and so on.
  3. The significand - the specific value, which when multiplied by a power of 10 provides the numeric value of the data item.
  4. The significand sign - an indication of whether the resultant value of the data item is negative or positive.

ISO2002 USAGE FLOAT-SHORT is equivalent to USAGE COMPUTATIONAL-1. USAGE FLOAT-LONG is equivalent to USAGE COMPUTATIONAL-2.

Items that are USAGE COMPUTATIONAL-1 (COMP-1) are usually referred to as single precision floating-point items while items that are USAGE COMPUTATIONAL-2 (COMP-2) are usually referred to as double precision floating-point items. Depending on the operating system or mathematical support libraries available to this COBOL system, different constraints can exist for single and double precision floating-point items. There can be constraints on the maximum exponent sizes, on the maximum significand sizes, or both. See your operating system or mathematical library floating-point support documentation for additional information.

COMPUTATIONAL-1 and COMPUTATIONAL-2 are equivalent to Single Format and Double Format, respectively, for operating systems that conform to ANSI/IEEE Std 754-1985, IEEE Standard for Binary Floating-Point Arithmetic.

It is important to understand that internal floating-point representation is not a continuous numeric spectrum. Internal floating-point representations are not standard from operating system to operating system. For example, in one representation of internal floating-point values, the following shows internal to decimal equivalence:

Internal (Hexadecimal) Storage | Decimal Value (Scientific Notation)
x"AD17E148" | -0.12345673E-23
x"AD17E149" | -0.12345810E-23

Therefore, any application which tested for or expected an internal floating-point item with an exact decimal value of -0.12345678E-23, would never find it, while in some other system of internal floating-point storage, that value might be found while the values listed above would never exist. Therefore, any application which tests for exact equivalence between internal floating-point items and other numeric values (including external floating-point items and floating-point literals) cannot be portable and may result in different logic flow even when using the same input data.

For internal floating-point items, the size of the item in storage is determined by its USAGE clause. USAGE COMPUTATIONAL-1 reserves 4 bytes of storage for the item; USAGE COMPUTATIONAL-2 reserves 8 bytes of storage.

When the IBMCOMP Compiler directive is on, padding bytes can be generated before an internal floating-point item with a SYNC clause; these bytes are not part of the item, and are never affected by data stored in the item.

Within the COBOL system, COMP-1 items are accurate to 7 decimal digits and COMP-2 items to 16 decimal digits. However, for mainframe compatibility the DISPLAY statement shows 8 decimal places for COMP-1 and 18 for COMP-2. Any operations using floating-point items should take the limits of accuracy into account, and should disregard decimal places beyond the limits of accuracy.

Parent topic: Selection of Character Representation and Radix
Related reference
COMPUTATIONAL-1 Data Items with a PICTURE other than S9(4)


COMPUTATIONAL-3 or PACKED-DECIMAL Format

COMPUTATIONAL-3 ANS85 or PACKED-DECIMAL Format

This format, commonly called binary-coded decimal format, represents numeric data items in radix 10, but with each digit of the value held in only one half of one computer character, as described in the table below. The sign is held in a separate trailing digit (half-character) position; that is, at the right-hand or least significant end of the item.

MF Any unused half bytes are set to zero.

Table 1. COMPUTATIONAL-3 Digit Representation
Digit Value | Digit Representation in Hexadecimal
 | Left Half-Character (odd digit) | Right Half-Character (even digit)
0 | x"00" | x"00"
1 | x"10" | x"01"
2 | x"20" | x"02"
3 | x"30" | x"03"
4 | x"40" | x"04"
5 | x"50" | x"05"
6 | x"60" | x"06"
7 | x"70" | x"07"
8 | x"80" | x"08"
9 | x"90" | x"09"
OSVS VSC2 MF XOPEN Note: Count even and odd starting from the right.

The table immediately below shows the sign digit used for COMPUTATIONAL-3. Storage requirements for this format depend only on the number of "9s" in the PICTURE clause of the data item as shown in the second table.

Table 2. COMPUTATIONAL-3 Sign Digit Representation
Sign Convention in the PICTURE Clause | Sign of Data Item Value | Sign Half-character, in Hexadecimal
Unsigned | n/a | x"0F"
Signed | + | x"0C"
Signed | - | x"0D"
Table 3. Numeric Data Storage for the COMP(UTATIONAL)-3 ANS85 or PACKED-DECIMAL PICTURE Clause.
Bytes Required | Number of Digits (Signed or Unsigned)
1 | 1
2 | 2-3
3 | 4-5
4 | 6-7
5 | 8-9
6 | 10-11
7 | 12-13
8 | 14-15
9 | 16-17
10 | 18-19
11 | 20-21
12 | 22-23
13 | 24-25
14 | 26-27
15 | 28-29
16 | 30-31
17 | 32-33
18 | 34-35
19 | 36-37
20 | 38

Example:

  1. For COMPUTATIONAL-3 and PICTURE 9999, the number +1234 would be stored as follows:

    where F represents the non-printing plus sign.

  2. For COMPUTATIONAL-3 and PICTURE S9999, the number + 1234 would be stored as follows:

    where C represents the plus sign.

  3. For COMPUTATIONAL-3 and PICTURE S9999, the number -1234 would be stored as follows:

    where D represents the minus sign.

The SYNCHRONIZED clause (with or without the LEFT or RIGHT phrase) has no effect on COMPUTATIONAL-3 data declarations.

Parent topic: Selection of Character Representation and Radix
Related information
COMP-3/COMPUTATIONAL-3 Data


COMPUTATIONAL-X and COMPUTATIONAL-5 Formats

MF COMPUTATIONAL-X and COMPUTATIONAL-5 Formats

These formats are as for COMPUTATIONAL format except for the differences given below. See the section COMPUTATIONAL, BINARY, or COMPUTATIONAL-4 Format.

They both differ in the following ways from the COMPUTATIONAL format:

  • The PICTURE character-string can consist of all "x"s. If it does, the number of "x"s gives the length of the item in bytes.
  • Whether the PICTURE character-string consists of "x" s or "9"s, the value that can be stored is limited to the largest binary number for which the allocated storage has space. The item is not affected by the TRUNC, COMP, and ALIGN Compiler directives. However, there is still a maximum of 18 digits which can be specified (either up to eighteen "9"s or up to eight "x"s in the PICTURE clause). If the compiler directive INTLEVEL(4) is specified, the maximum is 38 digits (either thirty-eight "9"s or sixteen "x"s).
  • The number of "9"s in the PICTURE character string affect the run-time element if the item is a destination field in an arithmetic operation including an ON SIZE ERROR or NOT ON SIZE ERROR clause: the number of "9"s determines whether or not a size error condition is deemed to have arisen due to a decimal digit overflow. When either clause is present, only arithmetic results falling within this range, that is, not causing a size error, are stored.
  • The following are the only differences between COMPUTATIONAL-X and COMPUTATIONAL-5 formats:
    • A COMPUTATIONAL-5 data item can be signed; a COMPUTATIONAL-X data item must not be signed. When "x"s are used in the PICTURE clause for a COMP-5 data item, it is treated as unsigned, not signed.
    • A COMPUTATIONAL-X item is always stored using the same storage scheme as BINARY items, that is with the high-order bytes stored at the lowest addresses and successively lower-order bytes at successively higher addresses.

      The storage of COMPUTATIONAL-5 items is operating system-specific. In some operating systems COMPUTATIONAL-5 items are stored in the same format as COMPUTATIONAL-X items and in others they are stored with the low-order bytes stored at the lowest addresses and successively higher-order bytes stored at successively higher addresses. For example, under operating systems which store numeric items in reverse order, a PIC X(5) COMPUTATIONAL-5 item with a numeric internal value of:

      h "12 34 56 78 9A"

      would be stored as:

      9A 78 56 34 12

      while a COMPUTATIONAL-X item (or a COMPUTATIONAL-5 item on an operating system without reverse numeric storage) would be stored as:

      12 34 56 78 9A

    • A COMPUTATIONAL-5 item is affected by the IBMCOMP Compiler directive and possibly the SYNCHRONIZED clause; a COMPUTATIONAL-X item is not.
  • If a non-arithmetic statement attempts to store a negative value in a COMPUTATIONAL-X or unsigned COMPUTATIONAL-5 item, the value is stored in two's complement, as if the item had been signed.

    The result of a statement attempting to store a negative value in an unsigned COMPUTATIONAL-5 item is sensitive to the COMP-5 Compiler directive.

Parent topic: Selection of Character Representation and Radix
Related information
COMPUTATIONAL, BINARY, or COMPUTATIONAL-4 Format


POINTER Format

The POINTER format holds a value that represents the memory address of an available data item. If the data item becomes unavailable (for example, because it is in a program that has been canceled) then the POINTER format is considered to hold a value that is incompatible with the format.

The default amount of storage allocated for the POINTER format may vary depending on the operating environment but is at least four bytes. The method of representation of the memory address varies between environments and is in general consistent with the representation used in non-COBOL languages.

When the IBMCOMP system directive is on, padding bytes can be generated before a pointer data item with a SYNC clause; these bytes are not part of the data item and are never affected by data stored in the item.

Parent topic: Selection of Character Representation and Radix


PROCEDURE-POINTER Format

The PROCEDURE-POINTER format holds a value that represents the memory address of an available procedure. If the procedure becomes unavailable (for example, because it is in a program that has been canceled) then the PROCEDURE-POINTER format is considered to hold a value that is incompatible with the format.

The default amount of storage allocated for the PROCEDURE-POINTER format may vary depending on the operating environment but is at least four bytes. If the COBOL370 directive is specified, then eight bytes of storage are allocated. The method of representation of the memory address varies between environments and is in general consistent with the representation used in non-COBOL languages.

When the IBMCOMP system directive is on, padding bytes can be generated before a procedure-pointer data item with a SYNC clause; these bytes are not part of the data item and are never affected by data stored in the item.

Parent topic: Selection of Character Representation and Radix


Uniqueness of Reference

  • Qualification
  • Subscripting
  • Indexing
  • Function-identifier
    A function-identifier references the unique data item that results from the evaluation of a function.
  • Reference Modification
    Reference modification defines a unique data item by specifying an identifier, a leftmost position and a length.
  • Identifier
    An identifier is a sequence of character-strings and separators used to reference data uniquely.
  • Condition-name
    Each condition-name must be unique, or be made unique through qualification and/or indexing, or subscripting. If qualification is used to make a condition-name unique, the associated conditional variable can be used as the first qualifier. The hierarchy of names associated with the conditional variable or the conditional variable itself must be used to make the condition-name unique.
  • Object property
    Object properties provide a special syntax to get information out of and pass information back into an object. The mechanisms for accessing object properties are get property methods and set property methods. A get property method is a method explicitly defined with the GET PROPERTY phrase or a method implicitly generated for a data item described with the PROPERTY clause; a set property method is a method explicitly defined with the SET PROPERTY phrase or a method implicitly generated for a data item described with the PROPERTY clause.
  • Inline method invocation
    Inline method invocation references a temporary data item returned from invocation of a method.
  • Object-view
    An object-view causes an object reference to be treated as though it had the specified description. A runtime conformance check for this description will be done on the object.
  • Data-address-identifier
    A data-address-identifer references the unique data item that contains the address of a data item.
  • Type of identifier
    The TYPE OF identifier obtains the System.Type object for a class, interface, delegate or enumeration.
  • Program-address-identifier
Parent topic: Class and Category of Data


Qualification

Every user-specified name that defines an element in a COBOL source element.

ANS85 and is referenced in that source element

must be unique, either because no other name has the identical spelling and hyphenation, or because the name exists within a hierarchy of names such that references to the name can be made unique by mentioning one or more of the higher levels of the hierarchy. The higher levels are called qualifiers and the process that specifies uniqueness is called qualification. Enough qualification must be mentioned to make the name unique; however, it may not be necessary to mention all levels of the hierarchy.

In the Data Division, all data-names used for qualification must be associated with a level indicator or a level-number. Therefore, two identical data-names must not appear as entries subordinate to a group item unless they are capable of being made unique through qualification

ANS85 or they are never referenced

. In the Procedure Division, two identical paragraph-names must not appear in the same section.

In the hierarchy of qualification, names associated with a level indicator are the most significant, followed by those names associated with level-number 01, followed by names associated with level-number 02 through 49. A section-name is the highest (and the only) qualifier available for a paragraph-name. Thus, the most significant name in the hierarchy must be unique and cannot be qualified. Subscripted or indexed data-names and conditional variables, as well as procedure-names and data-names, can be made unique by qualification. The name of a conditional variable can be used as a qualifier for any of its condition-names. Regardless of the available qualification, no name can be both a data-name and procedure-name.

Qualification is performed by following a data-name, a condition-name, a paragraph-name, or a text-name by one or more phrases composed of a qualifier preceded by IN or OF, which are logically equivalent.

ANS85 When the resource named is a function, the function definition may require the user to specify in the reference to the function a value or set of values for one or more parameters which determine the value of the function for that particular reference. This is accomplished through the specification of arguments as described in the section Function-identifier.

General Format: for Format 1

General Format: for Format 2

General Format: for Format 3

General Format: for Format 4

General Rules:

  1. Each qualifier must be of a successively higher level and within the same hierarchy as the name it qualifies.
  2. The same name must not appear at two levels in a hierarchy

    ANS85 if it is explicitly referenced within the source unit

    .

  3. If a data-name or a condition-name is assigned to more than one data item in a source element, the data-name or condition-name must be qualified each time it is referred to in the Procedure, Environment, and Data Divisions (except in the REDEFINES clause, where qualification must not be used).
  4. A paragraph-name must not be duplicated within a section. When a paragraph-name is qualified by a section-name, the word SECTION must not appear. A paragraph-name need not be qualified when referred to from within the same section.

    ANS85 Neither a paragraph-name nor a section-name need be unique, or capable of being made unique, unless explicitly referenced.

  5. A data-name cannot be subscripted when it is being used as a qualifier.
  6. A name can be qualified even when it does not need qualification; if there is more than one combination of qualifiers that ensures uniqueness, then any such set can be used. The complete set of qualifiers for a data-name must not be the same as any partial set of qualifiers for another data-name.

    Qualified data-names can have up to five qualifiers.

    ANS85 Up to fifty qualifiers are permitted.

  7. If more than one COBOL library is available to your COBOL system, text-name must be qualified each time it is referenced.

    OSVS VSC2 MF This restriction is not enforced.

Parent topic: Uniqueness of Reference
Related information
Function-identifier


Subscripting

Subscripts can be used only when reference is made to an individual element within a list or table of like elements that have not been assigned individual data-names (see the topic The OCCURS Clause).

The subscript can be represented either by a numeric literal that is an integer, by a data-name, or by a data-name followed by the operator "+" or "-" , followed by an unsigned integer numeric literal. The data-name must be a numeric elementary item that represents an integer, and the whole subscript must be delimited by the balanced pair of separators, left-parenthesis and right-parenthesis.

The subscript data-name can be signed and, if signed, must be positive. The lowest possible subscript value is 1. This value points to the first element of the table. The next sequential elements of the table are pointed to by subscripts whose values are 2, 3, ... . The highest permissible subscript value, in any particular case, is the maximum number of occurrences of the item as specified in the OCCURS clause.

The subscript, or set of subscripts, that identifies the table element is delimited by the balanced pair of separators, left parenthesis and right parenthesis following the table element data-name. The table element data-name appended with a subscript is called a subscripted data-name or an identifier. When more than one subscript is required, they are written in the order of successively less inclusive dimensions of the data organization. Up to 3 subscripts are permitted.

ANS85 Up to 7 subscripts are permitted.

MF Up to 16 subscripts are permitted.

General Format

Syntax Rules

  1. The data description entry containing data-name-1 or the data-name associated with condition-name-1 must contain an OCCURS clause or must be subordinate to a data description entry which contains an OCCURS clause.
  2. Except as defined in Syntax Rule 7, when a reference is made to a table element, the number of subscripts must equal the number of OCCURS clauses in the description of the table element being referenced. When more than one subscript is required, the subscripts are written in the order of successively less inclusive dimensions of the table.
  3. ANS85 The subscript ALL can be used only when the subscripted identifier is used as a function argument and cannot be used when condition-name-1 is specified. (See the topic Arguments.)
  4. Integer-1 can be signed, and if signed, must be positive.
  5. Data-name-2 can be qualified and must be a numeric elementary item representing an integer.
  6. Index-name-1 must correspond to a data description entry in the hierarchy of the table being referenced which contains an INDEXED BY phrase specifying that index-name.

    OSVS VSC2 MF An index described for some other table can be used instead, provided the two tables have elements of the same size.

  7. Each table element reference must be subscripted except when such reference appears:
    1. In a USE FOR DEBUGGING statement
    2. As the subject of a SEARCH or SORT statement
    3. In a REDEFINES clause
    4. In the KEY IS phrase of an OCCURS clause.
  8. OSVS The mixing of subscripts and indices in the same identifier is illegal.

    ANS85 The mixing of subscripts and indices in the same identifier is legal.

General Rules

  1. The value of the subscript must be a positive integer. The lowest possible occurrence number represented by a subscript is 1. The first element of any given dimension of a table is referenced by an occurrence number of 1. Each successive element within that dimension of the table is referenced by occurrence numbers of 2, 3, ... . The highest permissible occurrence number for any given dimension of the table is the maximum number of occurrences of the item specified in the associated OCCURS clause.

    MF If the subscript is a floating-point data item, the value is rounded to the nearest integer, otherwise any fractional part is truncated.

    If arithmetic-expression-1 is specified, and the final result of the arithmetic expression is not an integer, the final result is truncated. Intermediate results are not truncated.

    If arithmetic-expression-1 is specified, and if the final result or any intermediate result of the arithmetic expression is negative, the effect is unpredictable.

  2. The value of the index referenced by index-name-1 corresponds to the occurrence number of an element in the associated table.
  3. The value of the index referenced by index-name-1 must be initialized before it is used as a subscript. An index can be given an initial value by either a PERFORM statement with the VARYING phrase, a SEARCH statement with the ALL phrase, or a SET statement. An index can be modified only by the PERFORM, SEARCH, and SET statements.
  4. If

    ANS85 integer-2 or

    integer-3 is specified, the value of the subscript is determined by incrementing by the value of

    ANS85 integer-2 or

    integer-3 (when the operator "+" is used) or by decrementing by the value of

    ANS85 integer-2 or

    integer-3 (when the operator "-" is used),

    ANS85 either

    the occurrence number represented by the value of the index referenced by index-name-1

    ANS85 or the value of the data item referenced by data-name-2

    .

Comments:

MF If the NOBOUND Compiler directive is specified, the General Rules are not applicable at run time.

Parent topic: Uniqueness of Reference


Indexing

References can be made to individual elements within a table of like elements by specifying indexing for that reference. An index is assigned to that level of the table by using the INDEXED BY phrase in the definition of a table. A name given in the INDEXED BY phrase is known as an index-name and is used to refer to the assigned index. The value of an index corresponds to the occurrence number of an element in the associated table or any other table. An index-name must be initialized before it is used as a table reference. An index-name can be given an initial value by a SET statement.

Unlike a subscript, which is simply a numeric data item or literal, an index is a special type of item and holds a representation of an occurrence number. The form of this representation can vary; the contents of an index cannot be regarded as a numeric value.

Direct indexing is specified by using an index-name in the form of a subscript. Relative indexing is specified when the index-name is followed by the operator "+" or "-", followed by an unsigned integer numeric literal, all delimited by the balanced pair of separators left parenthesis and right parenthesis following the table element data-name. The occurrence number resulting from relative indexing is determined by incrementing (where the operator "+" is used) or decrementing (where the operator "-" is used), by the value of the literal, the occurrence number represented by the value of the index. When more than one index-name is required, they are written in the order of successively less inclusive dimensions of the data organization.

A table can be indexed only by the index described in its INDEXED BY phrase.

OSVS VSC2 MF An index described for some other table can be used instead provided the two tables have elements of the same size.

At the time of execution of a statement which refers to an indexed table element, the value contained in the index used to index it must neither correspond to a value less than one nor to a value greater than the highest permissible occurrence number of an element of the associated table. This restriction also applies to the value resulting from relative indexing.

MF If the NOBOUND Compiler directive is specified, this rule is not applicable at run time.

Up to 3 index-names can be used with a data-name.

ANS85 Up to 7 index-names can be used with a data-name.

MF Up to 16 index-names can be used with a data-name.

The general format for indexing is included in the general format for subscripting; see the section Subscripting.

Parent topic: Uniqueness of Reference
Related information
Subscripting


Function-identifier

A function-identifier references the unique data item that results from the evaluation of a function.

General Format

Syntax Rules

  1. A function-identifier must not be specified as a receiving operand.
  2. The word FUNCTION is required

    ISO2002 unless either of the following apply:

    ISO2002
    1. ISO2002 intrinsic-function-name-1 is specified in the Repository paragraph
    2. ISO2002 function-prototype-name-1 is specified.
  3. ISO2002 Function-prototype-name-1 must be a function prototype specified in the Repository paragraph.
  4. ISO2002 The word OMITTED must not be specified if intrinsic-function-name-1 is specified.
  5. Argument-1 must be an identifier, a literal, or an arithmetic expression. Specific rules governing the number, class, and category of argument-1 are given for intrinsic functions in the definition of that intrinsic function in the section Definitions of Functions in the chapter Procedure Division - Intrinsic Functions

    ISO2002 and for user-defined functions in the section Conformance for Parameters and Returning Items in the chapter Procedure Division

    .

  6. ISO2002 If the word OMITTED is specified, the OPTIONAL phrase must be specified for the corresponding formal parameter.
  7. ISO2002 If function-prototype-name-1 is specified and the formal parameter corresponding to argument-1 is specified with a BY VALUE phrase, argument-1 must be of class numeric, object or pointer.
  8. A numeric function must not be specified where an integer operand is required, even though a particular reference of the numeric function might yield an integer value.
  9. An integer function other than the integer form of the ABS function must not be specified where an unsigned integer is required.
  10. A function-identifier which references an integer or numeric function can only be used in an arithmetic expression.
  11. ISO2002 If function-prototype-name-1 is specified, the rules for conformance specified in the section Conformance for Parameters and Returning Items in the chapter Procedure Division apply.
  12. A reference modifier can be specified only for functions of the category alphanumeric

    ISO2002 MF or national

    .

  13. If a function's definition permits arguments and a left parenthesis immediately follows function-prototype-name-1 or intrinsic-function-name-1, the left parenthesis is always treated as the left parenthesis of that function's arguments.
    Note: For a function that may be referenced either with or without arguments, such as the RANDOM function, careful coding is necessary to ensure correct interpretation. For example, in the following:
     FUNCTION MAX (FUNCTION RANDOM (A) B)

    'A' is treated as an argument to the RANDOM function. If 'A' is instead meant to be a second argument to the MAX function, different coding is necessary - either:

     FUNCTION MAX (FUNCTION RANDOM () A B)

   or
     FUNCTION MAX ( (FUNCTION RANDOM) (A) B)

   or
     FUNCTION MAX (FUNCTION RANDOM A B)

General Rules

  1. A function-identifier references a temporary data item whose value is determined when the function is referenced at run time.

    If intrinsic-function-name-1 is specified, the temporary data item is an elementary data item whose description and category are specified by the definition of that intrinsic function in the section Definitions of Functions in the chapter Procedure Division - Intrinsic Functions.

    ISO2002 If function-prototype-name-1 is specified, the description, class, and category of the temporary data item is that specified by the description in the Linkage Section of the item specified in the RETURNING phrase of the PROCEDURE DIVISION header of the function prototype identified by function-prototype-name-1.

  2. At the time reference is made to a function, its arguments are evaluated individually in the order specified in the list of arguments, from left to right. An argument being evaluated may itself be a function-identifier or may be an expression containing function-identifiers. There is no restriction preventing the function referenced in evaluating an argument from being the same function as that for which the argument is specified. In other words, recursion is permitted. Additional rules for intrinsic functions are given in the section Intrinsic Functions.

    ISO2002 for user-defined functions in the sections The PROCEDURE DIVISION Header and Conformance for Parameters and Returning Items in the chapter Procedure Division

    MF If a function is expecting an integer argument, then if a floating-point argument is provided, the value is rounded to the nearest integer, otherwise any fractional part is truncated.

  3. ISO2002 If function-prototype-name-1 is specified, the function to be activated is identified by function-prototype-name-1 in accordance with the rules specified in the section The Repository Paragraph in the chapter Environment Division, and function-prototype-name-1 is used to determine the characteristics of the activated function.
  4. ISO2002 If function-prototype-name-1 is specified, the manner used for passing each argument is determined as follows:
    1. BY REFERENCE is assumed when the BY REFERENCE phrase is specified or implied for the corresponding formal parameter and argument-1 is an identifier that is permitted as a receiving operand, other than an object property, object data item or factory object data item.
    2. BY CONTENT is assumed when the BY REFERENCE phrase is specified or implied for the corresponding formal parameter and argument-1 is a literal, an arithmetic expression, an object property, object data item, factory object data item or any identifier that is not permitted as a receiving operand.
    3. BY VALUE is assumed when the BY VALUE phrase is specified for the corresponding formal parameter.
  5. Evaluation of the function-identifier proceeds as follows:
    1. Each argument-1 is evaluated at the beginning of the evaluation of the function-identifier. The values of argument-1 are made available to the activated function at the time control is transferred to that function.
    2. The run-time system attempts to locate the function being activated.

      ISO2002 If function-prototype-name-1 is specified, the rules are specified in the section Conventions for Function-prototype-names. Additional rules are given in the section The Repository Paragraph in the chapter Environment Division.

    3. If the function is located but the resources necessary to execute the function are not available, the function is not activated. The run-time resources that are checked in order to determine the availability of the function for execution are defined by the implementor.
    4. The function specified by the function-identifier is made available for execution and control is transferred to the activated function in a manner consistent with the call convention specified for the function.

      ISO2002 If function-prototype- name-1 is specified and the function to be activated is a COBOL function, its execution is as described in the section The PROCEDURE DIVISION Header in the chapter Procedure Division.

      If intrinsic-function-name-1 is specified, its execution is as described in the chapter Procedure Division - Intrinsic Functions.

      ISO2002 If function-prototype-name-1 is specified and the function to be activated is not a COBOL function, the execution is as defined in your COBOL system documentation on interfacing.

  6. If the word OMITTED is specified or a trailing argument is omitted, the omitted-argument condition for that parameter evaluates to TRUE in the activated function. (See the topic The Omitted-Argument Condition.)
  7. If a parameter for which the omitted-argument condition is true is referenced in an activated function, except as an argument or in the omitted-argument condition, you will get runtime error 203.
Parent topic: Uniqueness of Reference
Related information
Definitions of Functions
Conformance for Parameters and Returning Items
Intrinsic Functions
The PROCEDURE DIVISION Header
The Repository Paragraph
Conventions for Function-prototype-names
Procedure Division - Intrinsic Functions
The Omitted-Argument Condition


Reference Modification

Reference modification defines a unique data item by specifying an identifier, a leftmost position and a length.

General Format

identifier-1 ( leftmost-position : [length] )

Syntax Rules

  1. Identifier-1 must reference a data item that is one of the following:
    • An elementary item of class alphanumeric or national
    • A numeric item of usage display
    • A group item
    Note: Identifier-1 must not be an individual boolean data item or a group item defined by the GROUP-USAGE BIT clause.
  2. Leftmost-position and length must be arithmetic expressions.
  3. Unless otherwise specified, reference modification is allowed anywhere an identifier referencing a data item of the class alphanumeric or national is permitted.
  4. Identifier-1 must not include reference-modification.
  5. If identifier-1 is a function-identifier, it must reference an alphanumeric or national function.

General Rules

  1. Leftmost-position represents an alphanumeric position or national position when identifier-1 references an alphanumeric or national data item, respectively.
  2. Each position of the data item referenced identifier-1 is assigned an ordinal number incrementing by one from the leftmost position to the rightmost position. The leftmost position is assigned the ordinal number one. If the data description entry for identifier-1 contains a SIGN IS SEPARATE clause, the sign position is assigned an ordinal number within that data item.
  3. If the data item referenced by identifier-1 is explicitly or implicitly described as usage DISPLAY and the category is numeric,

    OSVS VSC2 MF external floating-point,

    numeric edited, alphabetic, or alphanumeric edited, it is operated upon for purposes of reference modification as if it were redefined as an alphanumeric data item of the same size as the data item referenced by identiifer-1.

  4. Reference modification for an operand is evaluated as follows:
    1. If subscripting is specified for the operand, the reference modification is evaluated immediately after evaluation of the subscripts. If an ALL subscript is specified for an operand, the reference-modifier is applied to each of the implicitly specified elements of the table.
    2. If subscripting is not specified for the operand, the reference modification is evaluated at the time subscripting would have been evaluated if subscripts had been specified.
    3. If reference modification is specified in a function reference, the reference modification is evaluated immediately after evaluation of the function.
    4. If reference modification is specified in an object property reference, the reference modification is evaluated immediately after evaluation of the object property.
  5. Reference modification creates a unique data item that is a subset of the data item referenced by identifier-1. This unique data item is defined as follows:
    1. The evaluation of leftmost-position specifies the ordinal position of the leftmost character of the unique data item in relation to the leftmost character of the data item referenced by identifier-1. Evaluation of leftmost-position must result in a positive nonzero integer less than or equal to the number of positions in the data item referenced by identifier-1.

      VSC2 MF The results are rounded if the expression is in floating-point, and truncated if the expression is in fixed-point.

    2. The evaluation of length specifies the size in characters of the data item to be used in the operation. The evaluation of length must result in a positive nonzero integer. The sum of leftmost-position and length minus the value one, must be less than, or equal to, the number of characters in the data item referenced by identifier-1. If length is not specified, the unique data item extends from and includes the character identified by leftmost-position, up to and including the rightmost character of the data item referenced by identifier-1.

      VSC2 MF The results are rounded if the expression is in floating-point, and truncated if the expression is in fixed-point.

      Note: There is no check that the evaluation of leftmost-position and length produce valid values. If these evaluations do not conform to the restrictions stated in this rule, the result is undefined and other data items may be corrupted.
  6. The unique data item is considered an elementary data item without the JUSTIFIED clause. The unique data item has the same class, category and usage as that defined for the data item referenced by identifier-1, except that:
    • The categories numeric, numeric edited, alphanumeric edited

      OSVS VSC2 MF and external floating-point

      are considered class and category alphanumeric

    • ISO2002 MF The category national-edited is considered class and category national.
  7. OSVS If the OSVS Compiler directive is set, reference modification cannot be used in conditional expressions (see the topic Conditional Expressions).
Parent topic: Uniqueness of Reference
Related information
Conditional Expressions


Identifier

An identifier is a sequence of character-strings and separators used to reference data uniquely.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

   object-property-1

General Formats for Format 4

   inline-invocation-1

General Formats for Format 5

   identifier-2 object-view-1

General Formats for Format 6

General Formats for Format 7

   type-of-identifier-1

Syntax Rules:

  1. Subscript-1 represents either subscripting (see the section Subscripting) or indexing (see the section Indexing).

General Rules: for Format 2

  1. The words IN and OF are equivalent.
  2. A data-name must neither be subscripted nor indexed when it is being used as an index, or subscript.
  3. Indexing is not permitted where subscripting is not permitted.
  4. An index can be modified only by the SET, SEARCH, and PERFORM statements. Data items described by the USAGE IS INDEX clause permit storage of the values associated with index-names as data. Such data items are called index data items.
  5. Literals used as subscripts must be positive numeric integers. Literals used for relative subscripting and indexing must be unsigned numeric integers.

General Rules: for Format 3

  6. ISO2002 MF NET JVM Object-property-1 is defined by the section Object property

General Rules: for Format 4

  7. ISO2002 MF Inline-invocation-1 is defined by the section Inline Method Invocation

General Rules: for Format 5

  8. ISO2002 MF Object-view-1 is defined by the section Object-view

General Rules: for Format 6

  9. ISO2002 MF Address-identifiers are defined by the section Data-address-identifier and the section Program-address-identifier.

General Rules: for Format 7

  10. NET JVM Type-of-1 is defined by the section Type of identifier.
Parent topic: Uniqueness of Reference
Related information
Subscripting
Indexing
Object property
Inline Method Invocation
Object-view
Data-address-identifier
Program-address-identifier
Type of identifier


Condition-name

Each condition-name must be unique, or be made unique through qualification and/or indexing, or subscripting. If qualification is used to make a condition-name unique, the associated conditional variable can be used as the first qualifier. The hierarchy of names associated with the conditional variable or the conditional variable itself must be used to make the condition-name unique.

If references to a conditional variable require indexing or subscripting, references to any of its condition-names require the same combination of indexing or subscripting.

The format and restrictions on the combined use of qualification, subscripting, and indexing of condition-names are exactly those of "identifier" except that data-name-1 is replaced by condition-name-1.

In the general formats, "condition-name" refers to a condition-name qualified, indexed or subscripted, as necessary.

Parent topic: Uniqueness of Reference


Object property

Object properties provide a special syntax to get information out of and pass information back into an object. The mechanisms for accessing object properties are get property methods and set property methods. A get property method is a method explicitly defined with the GET PROPERTY phrase or a method implicitly generated for a data item described with the PROPERTY clause; a set property method is a method explicitly defined with the SET PROPERTY phrase or a method implicitly generated for a data item described with the PROPERTY clause.

General Format for Format 1

   property-name-1 OF identifier-1

General Format for Format 2

  identifier-1::literal-1

Syntax Rules

  1. ISO2002 Property-name-1 must be an object property specified in the Repository paragraph.
  2. ISO2002 Identifier-1 must be an object reference; neither a universal object reference, nor the predefined object reference NULL can be specified.
  3. ISO2002 If the object property is used as a sending item, a get property method must exist for property-name-1 in the object referenced by identifier-1.
  4. ISO2002 If the object property is used as a receiving item, a set property method must exist for property-name-1 in the object referenced by identifier-1.
  5. ISO2002 The description of an object property used as a sending item is the same as the description of the returning item of the get property method. This object property can be specified wherever a data item with that description would be valid as a sending item.
  6. ISO2002 The description of an object property used as a receiving item is the same as the description of the using parameter of the set property method. This object property may be specified wherever a data item with that description would be valid as a receiving item.
  7. ISO2002 The data description of the item specified in the RETURNING phrase of the get property method must be the same as the data description of the item specified as the USING parameter of the set property method.
  8. NET JVM Literal-1 must specify the name of a property of the object referenced by identifier-1.

General Rules

  1. ISO2002 When an object property is used only as a sending item, a conceptual temporary data item, temp-1 is used in its place. The value of the property is determined as though the associated get property method were invoked, in accordance with the rules of the INVOKE statement, and the returned value placed in temp-1. The data description of temp-1 is the same as the data description of the item specified in the RETURNING phrase of the get property method.
  2. ISO2002 When an object property is used only as a receiving item, a conceptual temporary data item, temp-2, is used in its place. The value of the property is assigned as though the associated set property method were invoked, in accordance with the rules of the INVOKE statement, passing the content of temp-2 as the parameter. The data description of temp-2 is the same as the data description of the item specified as the USING parameter of the set property method.
  3. ISO2002 When an object property is used as both a sending item and a receiving item, conceptual temporary data items temp-1 and temp-2 are used in its place; temp-1 and temp-2 are the same temporary data item, where temp-2 redefines temp-1. For sending operations, the value of the property is determined in the same manner as for sending items in general rule 1; for receiving operations, the value of the property is assigned in the same manner as for receiving items in general rule 2. The data descriptions of temp-1 and temp-2 are the same as the data description of the item specified in the RETURNING phrase of the get property method.
Parent topic: Uniqueness of Reference


Inline method invocation

Inline method invocation references a temporary data item returned from invocation of a method.

General Format

Syntax Rules

  1. Inline method invocation must not be specified as a receiving operand.
  2. Identifier-1 must be of class object; neither the predefined object reference NULL nor a universal object reference may be specified.
  3. One of the INVOKE statements specified in general rule 1 must be valid according to syntax rules for the INVOKE statement.
  4. The data item referenced in the RETURNING phrase of the invoked method's PROCEDURE DIVISION header must not be described with the ANY LENGTH clause.

General Rules

  1. An inline method invocation references a temporary data item with the same class, category, and content as the temp-identifier that would be returned from the execution of the applicable form of INVOKE statement, as follows:
    INVOKE identifier-1 literal-1 USING arguments RETURNING temp-identifier INVOKE identifier-1 literal-1 RETURNING temp-identifier INVOKE class-name-1 literal-1 USING arguments RETURNING temp-identifier INVOKE class-name-1 literal-1 RETURNING temp-identifier
    where:
    1. arguments are the operands specified within parentheses in the inline method invocation, if any
    2. temp-identifier has the same description, class, and category as the RETURNING parameter in the specification of the method identified by literal-1 and either identifier-1 or class-name-1
    3. temp-identifier is a temporary item that exists for the purpose of effecting the inline invocation in this way and for no other purpose
Parent topic: Uniqueness of Reference


Object-view

An object-view causes an object reference to be treated as though it had the specified description. A runtime conformance check for this description will be done on the object.

General Format

Syntax Rules

  1. Identifier-1 must be of class object; the predefined object references SUPER and NULL must not be specified.
  2. An object-view must not be specified as a receiving operand.

General Rules

  1. This reference of identifier-1 is treated at compile-time as though it had the description specified by the AS phrase.
  2. If class-name-1 is specified without either of the optional phrases, identifier-1 is treated as though it were described as USAGE IS OBJECT REFERENCE class-name-1. If the object referenced by identifier-1 is not an object of class-name-1 or an object of a subclass of class-name-1, the EC-OO-CONFORMANCE exception condition is set to exist.
  3. If the FACTORY phrase is specified and the ONLY phrase is not specified, identifier-1 is treated as though it were described as USAGE OBJECT REFERENCE FACTORY OF class-name-1. If the object referenced by identifier-1 is not the factory object of class-name-1 or the factory object of a subclass of class-name-1, the EC-OO-CONFORMANCE exception condition is set to exist.
  4. If the ONLY phrase is specified and the FACTORY phrase is not specified, identifier-1 is treated as though it were described as USAGE OBJECT REFERENCE class-name-1 ONLY. If the object referenced by identifier-1 is not an object of class-name-1, the EC-OO-CONFORMANCE exception condition is set to exist.
  5. If both the FACTORY phrase and the ONLY phrase are specified, identifier-1 is treated as though it were described as USAGE OBJECT REFERENCE FACTORY OF class-name-1 ONLY. If the object referenced by identifier-1 is not the factory object of class-name-1, the EC-OO-CONFORMANCE exception condition is set to exist.
  6. If interface-name-1 is specified, identifier-1 is treated as though it were described as USAGE OBJECT REFERENCE interface-name-1. If the object referenced by identifier-1 does not implement interface-name-1, the EC-OO-CONFORMANCE exception condition is set to exist.
  7. If UNIVERSAL is specified, identifier-1 is treated as though it were described as USAGE OBJECT REFERENCE without any of the optional phrases to indicate the class or interface for objects referenced by identifier-1. The EC-OO-CONFORMANCE exception condition is not set to exist.
Parent topic: Uniqueness of Reference


Data-address-identifier

A data-address-identifer references the unique data item that contains the address of a data item.

General Format

ADDRESS of identifier-1

Syntax Rules

  1. Identifier-1 must reference a data item defined in the File Section, Working-Storage Section, Local-Storage Section or Linkage Section. Identifier-1 must not be defined in the Working-Storage or the File Section of an instance object or a factory object.
  2. Identifier-1 must not reference an object reference.
  3. This identifier format must not be specified as a receiving opernad.

General Rules

  1. Data-address-identifier creates a unique data item of class pointer and category data-pointer that contains the address of identifier-1.
Parent topic: Uniqueness of Reference


Type of identifier

The TYPE OF identifier obtains the System.Type object for a class, interface, delegate or enumeration.

General Format

TYPE OF identifier-1

Syntax Rules

  1. NET JVM Identifier-1 must reference a class, an interface, a delegate or an enumeration.

General Rules

  1. NET JVM Type-of-identifier creates a unique data item that contains the System.Type object for identifier-1.
Parent topic: Uniqueness of Reference


Program-address-identifier

General Format

Syntax Rules

  1. Identifier-1 must of of category alphanumeric or national.
  2. Literal-1 must be an alphanumeric or national literal.
  3. Program-prototype-name-1 must be a program prototype specified in the Repository paragraph.
  4. This identifier format must not be specified as a receiving operand.

General Rules

  1. Program-address-identifier creates a unique data item of class pointer and category program-pointer that contains the address of a program identified by one of the following:
    1. the content of the data item referenced by identifier-1
    2. the value of literal-1
    3. program-prototype-name-1.

    If identifier-1 or literal-1 is specified, COBOL Words in the chapter Concepts of the COBOL Language describes how this value is used to identify the referenced program.

  2. The program may be written in COBOL or in another language. For a COBOL program, the address is that of the outermost program identified by the externalized program-name in its Program-ID paragraph.
  3. When program-prototype-name-1 is specified, the program-address-identifier has the characteristics of a program-pointer restricted to program-prototype-name-1.
  4. If the runtime system cannot locate the program, the value of the address-identifier is the predefined address NULL.
Parent topic: Uniqueness of Reference
Related information
COBOL Words


Explicit and Implicit Specifications

There are four types of explicit and implicit specifications that occur in COBOL source elements:

  1. Explicit and implicit Procedure Division references.
  2. Explicit and implicit transfers of control.
  3. Explicit and implicit attributes.
  4. ANS85 Explicit and implicit scope terminators.
  • Explicit and Implicit Procedure Division References
  • Explicit and Implicit Transfers of Control
  • Explicit and Implicit Attributes
  • Explicit and Implicit Scope Terminators
Parent topic: Class and Category of Data


Explicit and Implicit Procedure Division References

A COBOL source element can reference data items either explicitly or implicitly in Procedure Division statements. An explicit reference occurs when the name of the referenced item is written in a Procedure Division statement or when the name of the referenced item is copied into the Procedure Division by the processing of a COPY statement

ANS85 , a REPLACE statement

OSVS VSC2 , an -INC statement, or ++INCLUDE statement

. An implicit reference occurs when the item is referenced by a Procedure Division statement without the name of the referenced item being written in the source statement.

An implicit reference also occurs during the execution of a PERFORM statement, when the index or data item referenced by the index-name or identifier specified in the VARYING, AFTER or UNTIL phrase is initialized, modified, or evaluated by the control mechanism associated with that PERFORM statement. Such an implicit reference occurs if and only if the data item contributes to the execution of the statement.

Parent topic: Explicit and Implicit Specifications


Explicit and Implicit Transfers of Control

The flow of control mechanism transfers control from statement to statement in the sequence in which they were written unless an explicit transfer of control overrides this sequence or there is no next executable statement to which control may be passed. The transfer of control from statement to statement occurs without the writing of an explicit Procedure Division statement, and, therefore, is an implicit transfer of control.

COBOL provides both an explicit and an implicit means of altering the implicit control transfer mechanism.

In addition to the implicit transfer of control between consecutive statements, implicit transfer of control occurs when the normal flow is altered without the execution of a procedure branching statement. COBOL provides the following types of implicit control flow alterations which override the statement-to-statement transfers of control:

  1. If a paragraph is being executed under control of another COBOL statement (for example, PERFORM, USE, SORT and MERGE) and the paragraph is the last paragraph in the range of the controling statement, then an implied transfer of control occurs from the last statement in the paragraph to the control mechanism of the last executed controling statement. Further, if a paragraph is being executed under the control of a PERFORM statement which causes iterative execution and that paragraph is the first paragraph in the range of that PERFORM statement, an implicit transfer of control occurs between the control mechanism associated with that PERFORM statement and the first statement in that paragraph for each iterative execution of the paragraph.
  2. When a SORT or MERGE statement is executed, an implicit transfer of control occurs to any associated input or output procedures.
  3. When any COBOL statement is executed that results in the execution of a declarative section, an implicit transfer of control to the declarative section occurs.
    Note: Another implicit transfer of control occurs after execution of the declarative section, as described in item 1. above.
  4. MF In any file operation (including OPEN and CLOSE), if a file does not have a FILE STATUS data item declared for it and the file is not explicitly covered by a USE statement, then it is covered by an implicit USE statement. The implied USE procedure is equivalent to:
    USE AFTER ERROR PROCEDURE ON file-name.
IF status-key-1 >= 3
  DISPLAY error-message UPON CONSOLE
  STOP RUN.

    See your COBOL system documentation for descriptions of error messages.

An explicit transfer of control consists of an alteration of the implicit control transfer mechanism by the execution of a procedure branching, ending or conditional statement. An explicit transfer of control between statements can be caused only by the execution of a procedure branching or conditional statement. An explicit transfer of control between sentences can be caused only by the execution of the NEXT SENTENCE phrase of an IF or SEARCH statement.

The execution of the procedure branching statement ALTER does not in itself constitute an explicit transfer of control, but affects the explicit transfer of control that occurs when the associated GO TO statement is executed. The procedure branching statement EXIT PROGRAM causes an explicit transfer of control only when the statement is executed in a called program.

The term "next executable sentence" is used to refer to the next COBOL sentence to which control is either implicitly transferred according to the rules above, or explicitly transferred as a result of execution of the NEXT SENTENCE phrase. The next executable sentence is the first sentence following the separator period that terminates the current sentence. There is no next executable sentence when there is no next executable statement as described below.

The term "next executable statement" is used to refer to the next COBOL statement to which control is transferred according to the rules above and the rules associated with each language element in the Procedure Division.

There is no next executable statement following:

  • The last statement in a declarative section when the paragraph in which it appears is not being executed under the control of some other COBOL statement
  • The last statement in a source element when the paragraph in which it appears is not being executed under the control of some other COBOL statement in that source element
  • The last statement in a declarative section, when the statement is in the range of an active PERFORM statement executed in a different section, and this last statement of the declarative section is not also the last statement of the procedure that is the exit of the active PERFORM statement
  • A STOP RUN statement

    ISO2002 OSVS VSC2 MF , GOBACK statement

    ISO2002 MF , EXIT METHOD

    ISO2002 , EXIT FUNCTION

    or EXIT PROGRAM statement that transfers control outside the COBOL source element

  • The end marker.
Parent topic: Explicit and Implicit Specifications


Explicit and Implicit Attributes

Attributes can be implicitly or explicitly specified. Any attribute which has been explicitly specified is called an explicit attribute. If an attribute has not been specified explicitly, then the attribute takes on the default specification. Such an attribute is known as an implicit attribute.

For example, the usage of a data item need not be specified, in which case a data item's usage is DISPLAY

OSVS VSC2 MF , unless the PICTURE character-string contains a "G" or an "N", in which case a data item's usage is DISPLAY-1

.

Parent topic: Explicit and Implicit Specifications


Explicit and Implicit Scope Terminators

Scope terminators delimit the scope of certain Procedure Division statements (delimited scope statements), and are of two types: explicit and implicit.

The explicit scope terminators are listed below:

  • END-ADD
  • END-PERFORM
  • MF XOPEN END-ACCEPT
  • END-CALL
  • MF END-CHAIN
  • END-COMPUTE
  • END-DELETE
  • MF XOPEN END-DISPLAY
  • END-DIVIDE
  • END-EVALUATE
  • END-IF
  • END-MULTIPLY
  • END-READ
  • END-RETURN
  • END-REWRITE
  • END-SEARCH
  • END-START
  • END-STRING
  • END-SUBTRACT
  • END-UNSTRING
  • END-WRITE
Note: In some cases the delimited scope statement with which an explicit scope delimiter is paired is determined differently for different COBOL language specifications.

Implicit scope termination occurs:

  • At the end of any sentence, where the separator period terminates the scope of all previous statements not yet terminated
  • Within any statement containing another statement. The next phrase of the containing statement (for example, ELSE, WHEN, AT END, and so on) following the contained statement terminates the scope of any unterminated contained statement.
Parent topic: Explicit and Implicit Specifications
Related information
The EVALUATE Statement
The STRING Statement


Language Fundamentals

  • Optional Division, Section and Paragraph Headings
  • Reserved Words
  • External Repository
  • Call Prototypes
  • Files
  • Object-oriented COBOL Concepts
  • Managed Code Concepts
  • Run Unit Communication
  • Data Division
  • Procedure Division
  • Reference Format
Parent topic: Part 1. Concepts


Optional Division, Section and Paragraph Headings

Some of the "red-tape" statements required by the ANSI Standard COBOL specifications are optional when using this COBOL system. It is, however, possible to have your COBOL system output warning messages when such statements are found to be missing by use of the FLAG directive. Such statements are identified as optional in this manual by enclosing them between brackets which have boxes around them. The symbols next to these boxes indicate the dialect in which these features are optional.

Parent topic: Language Fundamentals


Reserved Words

A full list of reserved words is given in the appendix Reserved Words.

Parent topic: Language Fundamentals
Related information
Reserved Words


External Repository

The external repository stores information specified in function prototypes, program definitions, class definitions and interface definitions.

The information stored about these source units must consist of all information required for activation and checking conformance. This information includes

  • The externalized name of the source unit
  • The type of the source unit - program, function, class or interface
  • The parameters of the source unit, if any
  • The returning item of the source unit, if any
  • The object properties of the source unit, if any
  • The methods contained in the source unit, if any, and details about the method's externalized name, parameters and returning item
  • Whether the DECIMAL-POINT IS COMMA clause is specified in the source unit; for a class, this detail must be stored for both its factory and object
  • Whether the CURRENCY clause is specified in the source unit; for a class, this detail must be stored for both its factory and object

This information about a source unit, excluding the externalized name of the source unit, is called its signature.

If a REPOSITORY directive is specified with the ON phrase, the compiler puts this information into the external repository as it compiles each compilation unit.

If a REPOSITORY directive is specified with the CHECKING phrase, either explicitly or by default, the compiler issues a warning when these characteristics of definitions and prototypes do not exactly match the information, if any, in the external repository for the associated definition.

The details on the association of the name of a source unit with information in the external repository are specified in the section The Repository Paragraph in the chapter Environment Division.

Parent topic: Language Fundamentals
Related information
The Repository Paragraph


Call Prototypes

A call prototype is a program declaration or skeleton program which serves to define the characteristics of a called subprogram. These characteristics include the number of parameters required, the type of these parameters and the calling convention. If a source element contains a CALL statement referring to a subprogram for which a prototype exists, the CALL statement is checked against the prototype. If there is an explicit mismatch, an error is given. If the CALL statement leaves some characteristics (such as the call convention) undefined, this is derived from the prototype.

The call prototype is defined as a complete program in which the EXTERNAL clause is specified in the Program-ID paragraph. The program structure should consist only of an Identification Division with a Program-ID paragraph, a Data Division with a Linkage Section, a PROCEDURE DIVISION header, and optional ENTRY statements. These call prototypes are placed before the other types of compilation units in a similar way to multi-program source files.

Note that you must include a copy of the call prototype for every subprogram to which you want your CALL statements checked before the IDENTIFICATION DIVISION header of your compilation unit containing the CALL statements.

Parent topic: Language Fundamentals


Files

  • File Connector
  • Sequential Input/Output
  • Relative Input/Output
  • Indexed Input/Output
  • Sharing Mode
Parent topic: Language Fundamentals


File Connector

A file connector is a storage area which contains information about a file and is used as the linkage between a file-name and a physical file and between a file-name and its associated record area.

Parent topic: Files


Sequential Input/Output

If the words sequential file or sequential organization are used in this chapter without specifying LINE or RECORD, then the sentence applies to both forms. The default behavior for sequential files is sensitive to the SEQUENTIAL Compiler directive.

  • Record Sequential Input/Output
  • Line Sequential Input/Output
  • Organization of Line and Record Sequential Files
  • Access Mode
Parent topic: Files


Record Sequential Input/Output

Record sequential I/O allows you to access records of a file in an established sequence. The sequence is established as a result of writing the records to the file.

Parent topic: Sequential Input/Output


Line Sequential Input/Output

Line sequential I/O allows you to access records of a text file in an established sequence. The records are stored with trailing spaces removed.

If the records are written to a line sequential file using unqualified WRITE commands, the file will be identical in format to those files produced by your operating system editor.

If the records are written to a line sequential file using qualified WRITE commands (for example using WRITE AFTER or WRITE BEFORE commands), the file will not be identical in format to those files produced by your operating system editor.

Parent topic: Sequential Input/Output
Related information
WRITE


Organization of Line and Record Sequential Files

Organization of MF Line and Record Sequential Files

Sequential files are organized such that each record in the file except the first has a unique predecessor record, and each record except the last has a unique successor record. These predecessor-successor relationships are established by the order of WRITE statements when the file is created. Once established, the predecessor-successor relationships do not change except in the case where records are added to the end of the file.

Parent topic: Sequential Input/Output


Access Mode

The only access available for sequential files is sequential access mode; the sequence in which records are accessed is the order in which the records were originally written.

If the record size in a line sequential file is greater than the record length, the data fills the record length and on the next READ it returns more data from that record. i.e. it uses the record length and the record delimiter.

Parent topic: Sequential Input/Output


Relative Input/Output

Relative I/O allows you to access records within a mass storage file in either a random or sequential manner. Each record in a relative file is identified by an integer value greater than zero which specifies the record's ordinal position in the file.

  • Organization of Relative Files
  • Access Mode
Parent topic: Files


Organization of Relative Files

Relative file organization is permitted only on disk devices. A relative file consists of records which are identified by relative record numbers. The file can be thought of as being composed of a serial string of areas, each capable of holding a logical record. Each of these areas has a relative record number. Records are stored and retrieved via this number. For example, ten denotes the tenth record area.

Parent topic: Relative Input/Output


Access Mode

In sequential access mode, records are accessed in the ascending order of the relative record numbers of those records which currently exist within the file.

In random access mode, you control the sequence in which records are accessed. The desired record is accessed by placing its relative record number in a relative key data item.

In dynamic access mode, you can change at will between sequential access and random access, using the appropriate forms of input/output statements.

Parent topic: Relative Input/Output


Indexed Input/Output

Indexed I/O allows you to access records within a mass storage file in either a random or sequential manner. Each record in an indexed file is identified by the value of one or more keys within that record.

  • Organization of Indexed Files
  • Access Mode
Parent topic: Files


Organization of Indexed Files

An indexed file is a mass storage file in which data records can be accessed by the value of a key. A record description can include one or more key data items, each of which is associated with an index. Each index provides a logical path to the data records, according to the contents of a data item within each record which is the record key for that index.

The data item named in the RECORD KEY clause of the file control entry for a file is the prime record key for that file. For purposes of inserting, updating and deleting records in a file, each record is identified solely by the value of its prime record key. This value should, therefore, be unique and must not be changed when updating the record.

The data item named in the ALTERNATE RECORD KEY clause of the file control entry for a file is an alternative record key for that file. The value of an alternative record key can be non-unique if the DUPLICATES phrase is specified. These keys provide alternative access paths for retrieval of records from the file.

MF Your COBOL system provides an extension which allows the key field to be a split key. A split key is a key comprising two or more data items, which may or may not be contiguous, in the record description.

Parent topic: Indexed Input/Output


Access Mode

In sequential access mode, records are accessed in the ascending order of the record key values. Records within a set of records that have duplicate alternate record key values are retrieved in the order in which the records were written into the set.

In random access mode, you control the sequence in which records are accessed. The desired record is accessed by placing the value of its record key in the record key data item.

In dynamic access mode, you can change at will between sequential access and random access, using appropriate forms of input/output statements.

Parent topic: Indexed Input/Output


Sharing Mode

The sharing mode indicates whether a file is to participate in file sharing and record locking, and specifies the degree of file sharing (or non-sharing) to be permitted for the file. The sharing mode specifies the types of operations that may be performed on the shared file through other file connectors while this file connector is open.

The SHARING phrase on an OPEN statement overrides the SHARING clause in the file control entry for establishing the sharing mode. If there is no SHARING phrase on the OPEN statement, the sharing mode is completely determined by the SHARING clause in the file control entry. If no specification is made in either location, the sharing mode is determined by the first of the following conditions that is satisfied:

  • If you specify the WITH LOCK phrase on the OPEN statement, the sharing mode is SHARING WITH NO OTHER.
  • If you specify the LOCK MODE IS EXCLUSIVE phrase in the SELECT clause, the sharing mode is SHARING WITH NO OTHER.
  • If you specify either the LOCK MODE IS MANUAL phrase or the LOCK MODE IS AUTOMATIC phrase in the SELECT clause, the sharing mode is SHARING WITH ALL OTHER.
  • If the open mode is OUTPUT, I-O, or EXTEND, the sharing mode is SHARING WITH NO OTHER.
  • If the open mode is INPUT, the sharing mode depends on the setting of the configuration option OPENINPUTSHARED. If you set this option to ON, the sharing mode is SHARING WITH ALL OTHER. Otherwise the sharing mode is SHARING WITH READ ONLY.

The rules are the same for a given standard sharing mode whether the sharing mode is specified on the OPEN statement, specified in the file control entry, or determined from the list above.

COBOL file sharing does not interoperate with other file sharing facilities in the environment.

A shared file must reside on disk.

Before access to a shared file is allowed through an OPEN statement, the sharing mode and the open mode must be allowed by all other file connectors that are currently associated with the file. Additionally, the sharing mode for the current OPEN statement shall permit all of the sharing modes and open modes that exist for all other file connectors that are currently associated with the file. (See the topic The OPEN Statement, particularly the table Opening available shared files that are currently open by another file connector.)

The sharing mode controls access to a file as follows:

  1. The SHARING WITH NO OTHER mode specifies exclusive access to a file. Associating this file connector with the file will be unsuccessful if the file is currently open through other file connectors. If the OPEN statement is successful, subsequent requests to open the file through other file connectors before this file connector is closed will be unsuccessful. Record locks are ignored.
  2. The SHARING WITH READ ONLY mode restricts concurrent access to a file through file connectors other than this one, to input mode. Associating this file connector with the file will be unsuccessful if the file is currently open in a mode other than input. If the OPEN statement is successful, subsequent requests to open the file through other file connectors in a mode other than input before this file connector is closed will be unsuccessful. Record locks are in effect.
  3. The SHARING WITH ALL OTHER mode allows concurrent access to a file through other file connectors specifying input, I-O, or extend mode, subject to any further restrictions that apply. Record locks are in effect.

Multiple paths of access may exist in the same runtime element, contained elements, separate runtime modules within the same run unit, or different run units. The file sharing conflict condition can exist regardless of the location of the file connector that holds the file lock of the file to be opened.

The setting of a file lock is part of the atomic operation of an I/O statement.

The file lock and all record locks established for a file connector are removed by an explicit or implicit CLOSE statement executed for that file connector.

Parent topic: Files
Related information
The OPEN Statement


Object-oriented COBOL Concepts

  • Objects and Classes
  • Object References
  • Predefined Object References
  • Methods
  • Method Invocation
  • Conformance and Interfaces
  • Polymorphism
  • Class Inheritance
  • Interface Inheritance
  • Interface Implementation
  • Parameterized Classes
  • Parameterized Interfaces
Parent topic: Language Fundamentals


Objects and Classes

An object is a runtime element that consists of its own data and shares the methods defined in its class definition. An object is defined by a class. The class definition describes the characteristics of the data and the methods that may be invoked on each of the objects of the class.

Every class also has a single factory object with its own unique set of data and methods. The factory object is typically used to create object instances, and to maintain data common to all instances of the class.

Parent topic: Object-oriented COBOL Concepts


Object References

An object reference is an implicitly- or explicitly-defined data item containing a value - an object reference value - that uniquely references an object for the lifetime of the object. Implicitly-defined object references are the predefined object references and object references returned from an object property, an object-view, an inline method invocation or a function. Explicitly-defined object references are data items defined by a data description entry specifying a USAGE OBJECT REFERENCE clause.

No two distinct objects have the same object reference value and every object has at least one object reference.

Parent topic: Object-oriented COBOL Concepts


Predefined Object References

A predefined object reference is an implicitly-generated data item referenced by one of the identifiers NULL, SELF,

MF SELFCLASS,

and SUPER. Each predefined object reference has a specific meaning, as described in the section Predefined Object Identifiers in the chapter Concepts of the COBOL Language.

Parent topic: Object-oriented COBOL Concepts
Related information
Predefined Object Identifiers


Methods

The procedural code in an object is placed in methods. Each method has its own method-name and its own Data Division and Procedure Division. When a method is invoked, the procedural code it contains is executed. A method is invoked by specifying an identifier that references the object and the name of the method. A method may specify parameters and a returning item.

Parent topic: Object-oriented COBOL Concepts


Method Invocation

The procedural code in a method is executed by invoking the method with an INVOKE statement, an inline method invocation or

MF referencing a verb-signature, or

referencing an object property. The method implementation that is bound to the invocation depends on the class, at runtime, of the object on which the method is invoked. In particular, it is not necessarily the class specified statically in the definition of the object reference; it is the class of the actual object referenced at runtime that is used in resolving a method invocation to a particular method implementation.

If an invocation specifies the object using an object reference, then:

  1. If the identified object is a factory object, the method invocation will resolve to a factory method
  2. Otherwise, the resolution will be to an object method.

If an invocation specifies the object using a class name, the factory object of the specified class is used as the object on which the method is invoked, and the method invocation will resolve to a factory method.

Method resolution proceeds by applying the first one of the following rules that is applicable:

  1. If a method with the method-name specified in the invocation is defined in the class of the object, that method is bound.
  2. If a method with the method-name specified in the invocation is defined in the class that is inherited by the class of the object, that method is bound, including any classes inherited from higher levels of the class hierarchy.
  3. If the method is not found, a runtime error will result.
Parent topic: Object-oriented COBOL Concepts


Conformance and Interfaces

The term "conformance" is used in this document with several different meanings. In the context of object orientation, the term "conformance" is used to describe a relationship between object interfaces, and it is the basis of such fundamental features as inheritance, interface definitions, and conformance checking.

Note: Conformance checking is done at compile time only, except when using an object modifier and when invoking a method using a universal object reference.
  • Conformance for Object Orientation
Parent topic: Object-oriented COBOL Concepts


Conformance for Object Orientation

Conformance for objects allows an object to be used according to an interface other than the interface of its own class. Conformance is a unidirectional relation from one interface to another interface and from an object to an interface.

  • Interfaces
  • Conformance between Interfaces
  • Conformance for Parameterized Classes and Parameterized Interfaces
Parent topic: Conformance and Interfaces


Interfaces

Every object has an interface consisting of the names and parameter specifications for each method supported by the object, including inherited methods. Each class has two interfaces: an interface for the factory object and an interface for the objects.

Interfaces may also be defined independently from a specific class by specifying method prototypes in an interface definition.

Parent topic: Conformance for Object Orientation


Conformance between Interfaces

An interface interface-1 conforms to an interface interface-2 if and only if:

  1. For every method in interface-2 there is a method in interface-1 with the same name taking the same number of parameters, with consistent BY REFERENCE and BY VALUE specifications.
  2. If the formal parameter of a given method in interface-2 is an object reference, the corresponding parameter in interface-1 is an object reference following these rules:
    1. If the parameter in interface-2 is a universal object reference, the corresponding parameter in interface-1 is a universal object reference.
    2. If the parameter in interface-2 is described with an interface-name, the corresponding parameter in interface-1 is described with the same interface- name.
    3. If the parameter in interface-2 is described with a class-name, the corresponding parameter in interface-1 is described with the same class-name, and the presence or absence of the FACTORY and ONLY phrases is the same in both interfaces.
    4. If the parameter in interface-2 is described with the ACTIVE-CLASS phrase, the corresponding parameter in interface-1 is described with the ACTIVE-CLASS phrase, and the presence or absence of the FACTORY phrase is the same in both interfaces.
  3. If the formal parameter of a given method in interface-2 is not an object reference, the corresponding formal parameter in interface-1 has the same ANY LENGTH, PICTURE, USAGE, SIGN, SYNCHRONIZED, JUSTIFIED, and BLANK WHEN ZERO clauses, with the following exceptions:
    1. Currency symbols match if and only if the corresponding currency strings are the same.
    2. Period picture symbols match if and only if the DECIMAL-POINT IS COMMA clause is in effect for both or for neither of these interfaces. Comma picture symbols match if and only if the DECIMAL-POINT IS COMMA clause is in effect for both or for neither of these interfaces.
  4. The presence or absence of the Procedure Division RETURNING phrase is the same in the corresponding methods.
  5. If the returning item in a given method of interface-2 is an object reference, the corresponding returning item in interface-1 is an object reference following these rules:
    1. If the returning item in interface-2 is a universal object reference, the corresponding returning item in interface-1 is an object reference.
    2. If the returning item in interface-2 is described with an interface-name that identifies the interface int-r, the corresponding returning item in interface-1 is either of the following:
      1. an object reference described with an interface-name that identifies int-r or an interface described with an INHERITS clause that references int-r,
      2. an object reference described with a class-name, subject to the following rules:
        1. if described with the FACTORY phrase, the factory object of the specified class must be described with an IMPLEMENTS clause that references int-r
        2. if described without the FACTORY phrase, the instance objects of the specified class must be described with an IMPLEMENTS clause that references int-r.
    3. If the returning item in interface-2 is described with a class-name, the corresponding returning item in interface-1 is an object reference, subject to the following rules:
      1. If the returning item in interface-2 is described with the ONLY phrase, the returning item in interface-1 is described with the ONLY phrase and the same class-name.
      2. If the returning item in interface-2 is described without the ONLY phrase, the returning item in interface-1 is described with the same class-name or a subclass of that class-name.
      3. The presence or absence of the FACTORY phrase is the same.
    4. If the returning item in interface-2 is described with the ACTIVE-CLASS phrase, the corresponding returning item in interface-1 is described with the ACTIVE-CLASS phrase, and the presence or absence of the FACTORY phrase is the same.

    If the description of the returning item of a method in interface-1 directly or indirectly references interface-2, the description of the returning item of the corresponding method in interface-2 does not directly or indirectly reference interface-1.

  6. If the returning item in a given method of interface-2 is not an object reference, the corresponding returning item has the same ANY LENGTH,PICTURE, USAGE, SIGN, SYNCHRONIZED, JUSTIFIED, and BLANK WHEN ZERO clauses, with the following exceptions:
    1. Currency symbols match if and only if the corresponding currency strings are the same.
    2. Period picture symbols match if and only if the DECIMAL-POINT IS COMMA clause is in effect for both or for neither of these interfaces. Comma picture symbols match if and only if the DECIMAL-POINT IS COMMA clause is in effect for both or for neither of these interfaces.
  7. A group item is, for the purpose of conformance checking, considered to be equivalent to an elementary alphanumeric data item of the same length.
  8. The presence or absence of the OPTIONAL phrase is the same for corresponding parameters.
Parent topic: Conformance for Object Orientation


Conformance for Parameterized Classes and Parameterized Interfaces

When using a parameterized class or interface, the class or interface is treated as if the actual parameter classes or interfaces were substituted for the parameters throughout the class definition or interface definition.

Parent topic: Conformance for Object Orientation


Polymorphism

Polymorphism is a feature that allows a given statement to do different things. In COBOL, the ability for a data item to contain various objects of different classes means that a method invocation on that data item can be bound to one of many possible methods. Sometimes the method can be identified before execution, but in general, the method cannot be identified until run time.

A data item can be declared to contain objects of a given class or any sub-class of that class; it can also be declared to contain objects that conform to a given interface. When a given interface is used, the classes of the objects may be completely unrelated.

Parent topic: Object-oriented COBOL Concepts


Class Inheritance

Class inheritance is a mechanism for using the interface and implementation of one or more classes as the basis for another class. The inheriting class, also known as a subclass, inherits from one or more classes, known as superclasses. The subclass has all the methods defined for the inherited class definition or definitions, including any methods that the inherited definition inherited. The subclass has all the data definitions defined for the inherited class or classes, including any data definitions that the inherited class or classes inherited.

ISO2002 MF Note: This does not mean that the actual source code that describes the data is accessible or that the data items described in that source code can be directly referenced in the subclass. It means that the subclasses are treated as if their source code had a copy of the superclass definitions; in other words, the inherited data items are considered to be defined in the subclass.

The inherited data definitions define data for every instance object of the subclass and for its factory object. Each instance object has its own copy of inherited data, distinct from the copy belonging to an instance object of an inherited class. Each factory object has its own copy of inherited data, distinct from the copy belonging to a factory object of an inherited class. Names and attributes of inherited data items are not visible in the inheriting class. The inherited object data is initialized when an object is created. The inherited factory data is allocated independently from the factory data of the inherited class or classes and is initialized when the factory of the subclass is created. The inherited factory data is accessible only via methods and properties specified in the factory definition of the class that describes the data. The inherited object data is accessible only via methods and properties specified in the object definition of the class that describes the data. The subclass inherits all the file definitions in the same way as the data definitions, subject to the same provisions as data definitions. The subclass may define methods in addition to or in place of the inherited methods and may specify data definitions and file definitions in addition to, but not in place of, the inherited data definitions and file definitions.

The interface of a subclass must always conform to the interface of the inherited class, although the subclass may override some of the methods of the inherited class to provide different implementations.

User-defined words in an inherited class are not inherited in the subclass, and may be used in the subclass definition as if they were not defined in the inherited class.

Parent topic: Object-oriented COBOL Concepts


Interface Inheritance

Interface inheritance is a mechanism for using one or more interface definitions as the basis for another interface. The inheriting interface has all the method specifications defined for the inherited interface definition or definitions, including any method specifications that the inherited definition or definitions inherited. The inheriting interface may define new methods augmenting the set of inherited method specifications. The inheriting interface must always conform to each of the inherited interfaces.

Parent topic: Object-oriented COBOL Concepts


Interface Implementation

Interface implementation is a mechanism for using one or more interface definitions as the basis for a class. The implementing class must implement all the method specifications defined for the implemented interface definition or definitions, including any method specifications that the implemented definition or definitions inherited. The interface of the factory object of the implementing class must conform to the interfaces to be implemented by the factory object, and the interface of the instance objects of the implementing class must conform to the interfaces to be implemented by the instance object.

Parent topic: Object-oriented COBOL Concepts


Parameterized Classes

A parameterized class is a generic or skeleton class, which has formal parameters that will be replaced by one or more class-names or interface-names. When it is expanded by substituting specific class-names or interface-names as actual parameters, a class is created that functions as a non-parameterized class. See the ACTUAL-PARAMS Compiler directive for details of this expansion.

The life cycle for a parameterized class is defined in the section Life Cycle of Parameterized Classes.

Parent topic: Object-oriented COBOL Concepts
Related information
Life Cycle of Parameterized Classes


Parameterized Interfaces

A parameterized interface is a generic or skeleton interface, which has formal parameters that will be replaced by one or more class-names or interface-names. When it is expanded by substituting specific class-names or interface-names as actual parameters, an interface is created that functions as a non-parameterized interface. See the ACTUAL-PARAMS Compiler directive for details of this expansion.

The life cycle for a parameterized interface is defined in the section Life Cycle of Parameterized Interfaces.

  • Object Life Cycle
  • Life Cycle of Factory Objects
  • Life Cycle of Objects
  • Life Cycle of Parameterized Classes
  • Life Cycle of Parameterized Interfaces
Parent topic: Object-oriented COBOL Concepts
Related information
Life Cycle of Parameterized Interfaces


Object Life Cycle

The life cycle for an object begins when it is created and ends when it is destroyed.

Parent topic: Parameterized Interfaces


Life Cycle of Factory Objects

A factory object is created before it is first referenced by a run unit.

A factory object is destroyed after it is last referenced by a run unit.

Parent topic: Parameterized Interfaces


Life Cycle of Objects

An object is created as the result of the NEW method being invoked on a factory object.

An object is destroyed when the run unit terminates.

MF An object is also destroyed as the result of the FINALIZE method being invoked on an object, if that occurs before the run unit terminates.

Parent topic: Parameterized Interfaces


Life Cycle of Parameterized Classes

An expansion of a parameterized class is treated in all respects the same as if it were a class that is not a parameterized class.

When a parameterized class is specified in the Repository paragraph, a new class (an instance of a parameterized class) is created based on the specification of the parameterized class. This class has its own factory object and is completely separate from any other instance of the same parameterized class.

Within a run unit, two classes with the same externalized class-name that are created by expanding the same parameterized class with the same actual parameters are the same class instance. If two classes expand a parameterized class with different actual parameters, they are not the same class instance and shall not have the same externalized class-name.

Parent topic: Parameterized Interfaces


Life Cycle of Parameterized Interfaces

An expansion of a parameterized interface is treated in all respects as if it were an interface that is not parameterized.

When a parameterized interface is specified in the Repository paragraph, a new interface (an instance of a parameterized interface) is created based on the specification of the parameterized interface.

Within a run unit, two interfaces with the same externalized interface-name that are created by expanding the same parameterized interface with the same actual parameters are the same interface instance. If two interfaces expand a parameterized interface with different actual parameters, they are not the same interface instance and shall not have the same externalized interface-name.

Parent topic: Parameterized Interfaces


Managed Code Concepts

  • Custom Attributes
  • Delegates and Events
    The delegate system is the object-oriented equivalent of the procedure pointer and is a type safe solution. The use of procedure or function pointers is a common enough occurrence in many languages, and in .NET they are generally used as a mechanism for one software component to notify another about an event which has occurred.
  • Enumerations and Enum types
  • Data Types in Managed COBOL
  • Specifying Type Names
  • Simplified Class Layout
Parent topic: Language Fundamentals


Custom Attributes

Custom attributes are used to provide additional information about elements within your program. Much of the syntax used in a COBOL program describes program elements, such as the visibility of methods and fields (PUBLIC, PRIVATE, PROTECTED, etc.). All these descriptions are embedded as ‘Metadata’ into the dll or exe file output by the Compiler, and can be interrogated by other programs using Reflection. Custom attributes are a way of adding additional metadata to program elements in a way that is open ended and unlimited. Custom attributes are attached to COBOL items using the CUSTOM-ATTRIBUTE reserved word.

Custom attributes may be used to describe methods, data items, properties, events, delegates, method parameters, assemblies, classes and method return values.

The arguments you specify for the attribute are of two types:

  • Ordinary parameters - the arguments to the constructor for that attribute
  • Named parameters - correspond to properties defined on the custom attribute class

For example:

 01 a binary-long attribute xml("UpperB").

The ordinary parameters used in the attribute specification must match a constructor defined by the attribute. In the example above, the constructor expects a single parameter of type string.

As another example:

custom-attribute is webservice("Description"="My service")

The named parameters must match properties defined by the attribute. In this example, Description is a property of type string defined for the custom attribute class webservice.

The attributes supported in COBOL are broadly similar to annotations supported in other languages for JVM.

Parent topic: Managed Code Concepts
Related information
The CUSTOM-ATTRIBUTE Clause


Delegates and Events

The delegate system is the object-oriented equivalent of the procedure pointer and is a type safe solution. The use of procedure or function pointers is a common enough occurrence in many languages, and in .NET they are generally used as a mechanism for one software component to notify another about an event which has occurred.

Delegates

A delegate is a class that can hold a reference to a method and, in the case of an instance method, an object on which that method can be invoked.

Once an instance of a delegate class has been created, it can be invoked, at which point the referenced method is invoked on the stored instance.

A delegate type can only hold references to methods of a particular signature, so creating and invoking delegates is type safe.

To define a delegate in COBOL, you use the DELEGATE-ID keyword, and the PROCEDURE DIVISION header to specify the signature. For example, to declare a delegate that has a string parameter and returns a binary-long:

delegate-id del.
procedure division using by value s1 as string returning n1 as binary-long.
end delegate.
Method Groups

A method group is a method invocation expression preceded by the keyword METHOD, and without any parameters. When a method group is specified, it denotes one of the set of methods with the specified name in the specified class.

An implicit conversion exists between a method group and a specific delegate type, if one of the methods identified by the method group has a signature which is compatible with that delegate type.

For example, to create an instance of the delegate MyDelegate you declared above, that points to a suitable method:

01 d type MyDelegate.
01 c type Class1.
...
set d to method c::m

class-id Class1.
method-id m.
procedure division using by value s1 as string returning n1 as binary-long.
end method.

method-id m.
procedure division using by value s1 as string s2 as string returning n1 as binary-long.
end method.

end class.

In the example above, the SET statement automatically selects the first overload of the method m as it has a signature which is compatible with that of the delegate type MyDelegate.

A method group can also be used as a parameter to a method, when that method has an argument of a compatible delegate type. Again, an implicit conversion from the method group to the delegate type will take place, and that delegate will be passed as the parameter to the target method.

Anonymous methods

You can set a delegate to point to a piece of code, without formally setting that code up as a specific method. Such a piece of code is called an Anonymous Method, and you use the keywords DELEGATE and END-DELEGATE to specify it.

You specify any parameters and return values with the words USING and RETURNING attached to the word DELEGATE.

The following shows how you can attach an anonymous method to the delegate MyDelegate you created in the previous examples:

01 d type MyDelegate.
set d to delegate using s1 as string
                                returning n1 as binary-long
                  set n1 to s1::Length
              end-delegate.
Invoking delegates

To invoke a delegate after it has been created, you use the keyword RUN followed by the delegate name, and any parameters enclosed in parentheses. For example, to run the delegate d created above and displaying the results, type:

display run d(“Hello”)

This statement causes the anonymous method to be invoked and return a value of 5. This value is then displayed.

Example of creating and invoking delegates
       delegate-id del.
       procedure division using by value s1 as string returning n1 as binary-long.
       end delegate.

       class-id a.
       method-id main static.
       01 d type del.
       01 c type Class1 value new Class1.

       set d to method c::m
       display run d("ABC")

       set d to delegate using s1 as string
                         returning n1 as binary-long
                    set n1 to s1::Length
                end-delegate
       display run d("XYZ")
       end method.
       end class.

       class-id Class1.
       method-id m.
       procedure division using by value s1 as string returning n1 as binary-long.
           set n1 to size of s1 + 3
       end method.
       method-id m.
       procedure division using by value s1 as string s2 as string returning n1 as binary-long.
       end method.
       end class.
Combining delegates

A single delegate can hold references to more than one object/method pairs. In such cases, at the time when the delegate is invoked, each one of the methods will be invoked in the order in which they were added to the delegate.

  • You use the operator '+' to add a method group, anonymous method or another delegate to a delegate.
  • You use the operator '-' to remove methods from a delegate.
Note: At least one side of such an expression must be an instance of a delegate type.

For example:

       class-id DelegateCombining.
       method-id main static.
       01 cd1 type D.
       01 cd2 type D.
       01 cd3 type D.
       01 cd4 type D.
       01 c type C value new C.
           set cd1 to method type C::M1
           invoke cd1(-1)
           set cd2 to method type C::M2
           invoke cd2(-2)
           set cd3 to cd 2 + method type C::M1
           invoke cd3(10)
           set cd3 to method type C::M1 + cd3
           invoke cd3(20)

           set cd4 to method c::M3
           set cd3 to cd3 + method c::M3
           invoke cd3(30)

           set cd3 to cd3 - method type C::M1
           invoke cd3(40)
           set cd3 to cd3 - method c::M3
           invoke cd3(50)
           set cd3 to cd3 - method type C::M2
           invoke cd3(60)
           set cd3 to cd3 - cd2
           invoke cd3(60)
           set cd3 to cd3 - cd1
           try
               invoke cd3(70)
           catch
               display "null reference exception caught"
           end-try
           set cd3 to cd3 - cd1
           display "Hello"

           set cd1 to method type C::M1
           set cd2 to method type C::M2
           set cd3 to cd1 + cd2 + cd2 + cd1
           invoke cd3(80)
           set cd3 to cd3 - cd1
           invoke cd3(90)
           set cd3 to cd1 + cd2 + cd2 + cd1
           set cd3 to cd3 - (cd1 + cd2)
           invoke cd3(100)
           set cd3 to cd1 + cd2 + cd2 + cd1
           set cd3 to cd3 - (cd2 + cd2)
           invoke cd3(110)
           set cd3 to cd1 + cd2 + cd2 + cd1
           set cd3 to cd3 - (cd2 + cd1)
           invoke cd3(120)
           set cd3 to cd1 + cd2 + cd2 + cd1
           set cd3 to cd3 - (cd1 + cd1)
           invoke cd3(130)

       end method.
       end class.

       delegate-id D.
       procedure division using by value i as binary-long.
       end delegate.

       class-id C.
       method-id M1 static.
       procedure division using by value i as binary-long.
           display "C::M1 --> " i
       end method.
       method-id M2 static.
       procedure division using by value i as binary-long.
           display "C::M2 --> " i
       end method.
       method-id M3.
       procedure division using by value i as binary-long.
           display "C::M3 --> " i
       end method.
       end class.

Events

An event is a way in which a class can provide notifications when something of interest happens, such as a key being pressed in a GUI environment.

To define an event, you add the keyword EVENT to a delegate field. For example:

       01 ChangeEvent type ChangeDelegate event public.

Delegates of the same type, or compatible method groups or anonymous methods can be attached to the event, and will be invoked at the time when the owning class of the event invokes the backing delegate.

The relationship between an event and its backing delegate is very similar to the relationship between a property and its backing storage.

Attaching a method or a delegate to an event

You use the ATTACH statement to attach a delegate, method group or an anonymous method to an event:

ATTACH {delegate-instance}    TO event-expression
                {method-group}
                {anonymous-method}

For example:

       01 names type myList.
       01 del type ChangeDelegate.
       procedure division.
           set names to new myList
           attach method self::ListChanged to names::ChangeEvent
           set del to method self::ListChanged
           attach del to names::ChangeEvent
To detach a method or a delegate from an event

To detach a delegate or method group from an event use the DETACH statement:

DETACH {delegate-instance}    FROM  event-expression
                {method-group}

For example:

           detach del from names::ChangeEvent
           detach method self::ListChanged from names::ChangeEvent
Parent topic: Managed Code Concepts
Related information
The Delegate-ID Paragraph


Enumerations and Enum types

An enumeration represents a list of constant values, such as values for the days of the week. You can declare an enum type that defines the values and symbolic names for them. You can then refer to the values by name.

For example, you could declare an enum type for the days of the week, as follows:

enum-id DaysOfWeek as "DaysOfWeek".
       01 binary-long.
          78 Sunday value 0. *> optional, as 0 is the default
          78 Monday.         *> by default, this is value 1
          78 Tuesday.        *> by default, this is value 2 and so on
          78 Wednesday.
          78 Thursday.
          78 Friday.
          78 Saturday.
       end enum.

You can then refer to the enum type in your code, as follows:

set today to type DaysOfWeek::Monday

Where DaysOfWeek::Monday represents the binary-long value 1.

The Compiler adds a static method called 'values' that returns an array containing the values of the enum. You can use this method together with the PERFORM THROUGH construct to iterate over the values of an enum type.

You declare an enum using the ENUM-ID paragraph. This is followed by a working-storage section consisting of:

  • A single numeric field of one of the predefined types. By default, this is binary-long corresponding to the .NET type Int32 or the Java type int.
  • Any number of level 78 items defining the values for the enum. The default value of the first item is 0 and the values of subsequent items are incremented by default.

In .NET, but not JVM, you need to set the attribute System.FlagsAttribute. This attribute applied to an enum means that the distinct values are to be regarded as bit settings, and can therefore be combined. For example:

enum-id DaysOfWeek attribute System.FlagsAttribute.
Note:

In COBOL for JVM, as in Java, the enum declaration defines an enum class, which is a class that derives from java.lang.Enum. In Java, this enum class can include methods and other fields explicitly declared by the user, whereas this is not allowed in COBOL.

Parent topic: Managed Code Concepts
Related information
The Enum-ID Paragraph


Data Types in Managed COBOL

COBOL provides predefined usages corresponding to many of the most commonly used managed code types. These names can be used when declaring a data item, and anywhere that a class name is expected. For example:

    01 anInteger binary-long.

Predefined Managed Types

Managed COBOL | .NET class | JVM type | C# type | Description
Integer types:
binary-char | System.SByte | byte | sbyte | An 8-bit signed integer Not CLS-compliant
binary-char unsigned | System.Byte |  | byte | An 8-bit unsigned integer
binary-short | System.Int16 | short | short | A 16-bit unsigned integer Not CLS-compliant
binary-short unsigned | System.UInt16 |  | ushort | A 16-bit signed integer
binary-long | System.Int32 | int | int | A 32-bit signed integer
binary-long unsigned | System.UInt32 |  | uint | A 32-bit unsigned integer Not CLS-compliant.
binary-double | System.Int64 | long | long | A 64-bit signed integer
binary-double unsigned | System.UInt64 |  | ulong | A 64-bit unsigned integer Not CLS-compliant
Floating point types:
float-short | System.Single | float | float | A single-precision (32-bit) floating-point number
float-long | System.Double | double | double | A double-precision (64-bit) floating-point number
Logical Types:
condition-value | System.Boolean | boolean | bool | A boolean value (true or false)
Other types:
pic n usage national | System.Char | char | char | A unicode (16-bit) character
object reference sys-Decimal * | System.Decimal |  | decimal | A 96-bit decimal value
object reference sys-IntPtr * | System.IntPtr |  |  | A signed integer whose size depends on the underlying platform (a 32-bit value on a 32-bit platform and a 64-bit value on a 64-bit platform)
object reference sys-UIntPtr * | System.UIntPtr |  |  | An unsigned integer whose size depends on the underlying platform (a 32- bit value on a 32-bit platform and a 64-bit value on a 64-bit platform) Not CLS-compliant
Class objects:
object reference | System.Object | java.lang.Object | object | The root of the object hierarchy
object reference sys-String * | System.String | java.lang.String | string | An immutable, fixed-length string of Unicode characters

Defining Types with the TYPE Keyword

Further managed types can be specified in COBOL using the syntax TYPE classname in the data item definition. For example:

    01 objMyType type MyType.

All the COBOL data types in the table above and any further managed types that you define are mapped onto the corresponding native type (.NET or JVM), but they must conform to the following rules. They:

  • Must be declared at 01 (or 77) level
  • Must have no REDEFINES or RENAMES
  • Must never be the subject of reference modification
  • Must never be the subject of the ADDRESS OF clause
  • May use format 3 of the OCCURS clause to declare an array

Any COBOL data item that does not follow these rules, or is of any other category, is not considered to be a native type (.NET or JVM) and is allocated by the Compiler within an internally managed byte array. COBOL pointer data items always point into one of these byte arrays.

Resolving Types

If your code references a type without specifying the namespace it belongs to, the Compiler first attempts to resolve this to a type formed by adding the namespace of the current class to the type name. For example:

$set ilusing"System"
type-id MyNamespace.EventHandler.
01 o type EventHandler.
end type.

In the example above 01 o type EventHandler. resolves to MyNamespace.EventHandler and not to System.EventHandler.

If no such type exists then the Compiler tries to resolve the unspecified type in the order listed below:

  1. if the current compilation includes a single type with this name and with no namespace, the Compiler resolves it to this type.
  2. if a referenced assembly includes a single type with the same name and with no namespace, the Compiler resolves to this type.
  3. if among the namespaces specified with the ILUSING directives a single type with the same name, the Compiler resolves to this type.
  4. if among the namespaces specified with the ILUSING directives there are more than one namespaces that include the same type, the Compiler emits an error.

Value Types, Reference Types and Boxing

Managed COBOL distinguishes between:

  • Value types (such as binary-long and System.DateTime in .NET). Value type data items contain the actual data. For example, a COBOL binary-long data item contains a 32 bit integer.
  • Reference types, which are allocated on the object heap. Reference type data items hold a reference into the object heap. Reference types are under the management of the garbage collector.

All value types can be turned into reference types by a process known as boxing. For example, you can set an object reference to a value type, such as a binary-long.

Boxing happens automatically when needed, for example when a value type is passed as a parameter to a method that expects an object as a parameter.

You can box explicitly by assigning a value type to a generic object (such as System.Object in .NET COBOL or java.lang.Object in JVM COBOL).

You can unbox value types to restore the original value type.

When you specify TYPE classname in the data item definition:

  • If classname represents a reference type, you get a reference type object.
  • If classname represents a value type, you get a value type object.

During boxing, the system copies the value into the object heap and returns a reference to it. When the reference is no longer active (because nothing in the program is holding on to it), the space in the object heap will eventually be regained by the garbage collector.

See the ValueTypes sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET.

Parent topic: Managed Code Concepts
Related information
Type Compatibility of Managed COBOL with Other Managed Languages
Specifying Type Names


Specifying Type Names

You can refer to class and interface names in managed COBOL by using a type-specifier, which can be defined by using:

  • Managed COBOL data types that correspond to types in other managed languages, such as binary-long, which corresponds to System.Int32 in .NET COBOL and int in JVM COBOL. For example:
        01 anInteger binary-long
    01 aFloatingPointItem float-short
    01 aString string
  • The TYPE keyword followed by the class name, which can be quoted or quoteless. For example:

    Where:

    • objMyType is defined as an object of type myType
    • objDateTime is defined as an object of type DateTime in .NET COBOL or java.util.Date in JVM COBOL
  • The class defined in a repository entry (for backward compatibility only)

To define a namespace to represent long class names so that you need to type a short name only, use the ILUSING directive.

In .NET COBOL, to refer to a generic type using the TYPE literal syntax, you enumerate the generic parameters within square brackets. The following example declares myNames as an item of type Dictionary with both generic parameters set to string (System.String):

myNames type "System.Collections.Generic.Dictionary"[string, string].

The equivalent syntax using the traditional repository is:

Repository.
    Class dictionary is "System.Collections.Generic.Dictionary"
    Class dictionary-string-string expands dictionary using string, string.
01 d1 dictionary-string-string.
Parent topic: Managed Code Concepts
Related information
Data Types in Managed COBOL
ILUSING
Type Compatibility of Managed COBOL with Other Managed Languages


Simplified Class Layout

We recommend that you use the simplified class layout when writing managed COBOL. In this layout, you put data and methods directly under the CLASS-ID header.

In this case, both method and data are instance by default. To define methods and data as static, you use the STATIC keyword. For example:

Class-id. a.
01 str string.
01 static-str string static.
Method-id. m1.
End method m1.
Method-id. m2 static.
End method m2.
End class a.

The previous layout is still supported for backward compatibility. Previously, you had to embed methods and data within the STATIC/END STATIC and OBJECT/END OBJECT markers.

Parent topic: Managed Code Concepts


Run Unit Communication

  • Common, Initial and Recursive Attributes
  • Sharing Data
  • Sharing File Connectors
Parent topic: Language Fundamentals


Common, Initial and Recursive Attributes

A program can be described with attributes that affect its initial state or that define the manner in which it can be called.

ANS85 A common program is one that is directly contained within another program and that can be called by programs directly or indirectly contained in that other program, as described in the section Scope of Names in the chapter Concepts of the COBOL Language. The common attribute is attained by specifying the COMMON clause in a program's Identification Division. When the COMMON clause is not specified, a contained program that is not recursive can be called only from the directly-containing program. The COMMON clause facilitates the writing of subprograms that can be used by all the programs contained within a program.

ANS85 An initial program is one whose program state is initialized when the program is called. During the process of initializing an initial program, that program's internal data is initialized as described in the section State of a Function, Method, Object or Program. The initial attribute is attained by specifying the INITIAL clause in the program's Identification Division.

ISO2002 MF OS390 A recursive program may call itself directly or indirectly. The program's internal data is initialized as described in the section State of a Function, Method, Object or Program. The recursive attribute is attained as specified in the section The Program-ID Paragraph in the chapter Identification Division.

ISO2002 MF OS390 Methods are always recursive. Their data is initialized in the same way as recursive programs.

ISO2002 MF OS390 If a program is neither initial nor recursive, the program's data is in the last-used state on other than the first activation of the program as described in the section State of a Function, Method, Object or Program. The program cannot be activated while it is active unless it has the recursive attribute.

Parent topic: Run Unit Communication
Related information
Scope of Names
State of a Function, Method, Object or Program
The Program-ID Paragraph


Sharing Data

Two runtime elements in a run unit can reference common data in the following circumstances:

  • The data content of an external data record can be referenced from any runtime element provided that element has described that data record.
  • If a program is contained in another program, both programs can refer to data possessing the global attribute either in the containing program or in any program which directly or indirectly contains the containing program.
  • The mechanism whereby a parameter value is passed by reference from an activating runtime element to an activated runtime element establishes a common data item; the activated runtime element, which can use a different identifier, can refer to a data item in the activating runtime element.
Parent topic: Run Unit Communication


Sharing File Connectors

Two runtime elements in a run unit can reference common file connectors in the following circumstances:

  • An external file connector can be referenced from any runtime element which describes that file connector.
  • If a program is contained in another program, both programs can refer to a common file connector by referring to an associated global file-name either in the containing program or in any program which directly or indirectly contains the containing program.
Parent topic: Run Unit Communication


Data Division

  • Overview
  • Automatic, Initial and Static
  • State of a Function, Method, Object or Program
  • Global Names and Local Names
  • External and Internal Items
Parent topic: Language Fundamentals


Overview

The Data Division is subdivided into the following sections:

  1. File Section
  2. Working-Storage Section
  3. MF Thread-Local-Storage Section
  4. MF Object-Storage Section
  5. ISO2002 MF Local-Storage Section
  6. Linkage Section
  7. Report Section
  8. ISO2002 MF XOPEN Screen Section.

The File Section defines the structure of data files. Each file is defined by a file description entry and one or more record descriptions. Record descriptions are written immediately following the file description entry.

The Working-Storage Section describes records and noncontiguous data items which are not part of external data files but are developed and processed internally. It also describes data items whose values are assigned in the source text and do not change during execution.

MF The Thread-Local-Storage Section describes data which is unique to each thread, and is persistent across calls. Thread-local-storage can be viewed as thread-specific working-storage. This is useful for resolving contention problems in most reentrant programs. In many cases, a non-file-handling program can be made completely reentrant by simply changing the WORKING-STORAGE SECTION header to a THREAD-LOCAL-STORAGE SECTION header.

MF The Object-Storage Section describes class object data and instance object data. Its structure is the same as the Linkage and Working-Storage Sections.

ISO2002 MF The Local-Storage Section identifies a program as eligible for recursion. The Local-Storage Section can also be specified in a method, which is also eligible for recursion. A separate copy of the Local-Storage Section is created each time the runtime element is activated and exists only during the lifetime of that runtime element.

The Linkage Section appears in a source element that can be activated by another source element. It describes data items that are to be referred to by both the activating and the activated elements. Its structure is the same as the Working-Storage Section.

The Report Section contains one or more report description entries (RD entries), each of which forms the complete description of a report.

ISO2002 MF XOPEN The Screen Section defines the attributes of the screens. It offers the facility to specify the exact location of fields when they are displayed on the screen as well as to control certain console features during an ACCEPT or DISPLAY operation.

MF Data records and items that are described in the same way have the same type. The descriptions of such items can be conveniently manipulated by declaring a type definition. A type definition can appear in the Working-Storage and Linkage Sections. A type definition in a call prototype may be referenced in a program definition.

Parent topic: Data Division


Automatic, Initial and Static

There are three kinds of internal data items and file connectors: automatic, initial, and static. The designation of automatic, initial, and static items relates to their persistence and the persistence of their contents during the execution of a run unit.

Data items and file connectors have an initial and last-used state. The initial state of a data item depends on the presence or absence of a VALUE clause in its data description entry, the section in which the data item is described, and the description of the data item. The initial state of a file connector is that it is not in an open mode.

Last-used state means that the content of the data item or file connector is that of the last time it was modified.

Automatic items are set to their initial state any time a function, method or program is activated, and each instance of the function, method or program has its own copy of the item. An automatic item is an item described in the Local-Storage Section.

Initial items are set to their initial state any time an initial program is activated. All data items and file connectors in an initial program are initial items. Also, an attribute of a screen item in an initial program is treated as an initial item.

Static items are set to their initial state any time a function, method, object, or program is set to its initial state. (See the section State of a Function, Method, Object or Program.) A static item is an item described in the File or Working-Storage Section of a source element that is not an initial program. Also, an attribute of a screen item in a source element that is not an initial program is treated as a static item.

Parent topic: Data Division
Related information
State of a Function, Method, Object or Program


State of a Function, Method, Object or Program

  • State of a Function, Method or Program
  • Initial State of an Object
Parent topic: Data Division


State of a Function, Method or Program

The state of a function, method or program at any point in time in a run unit may be active or inactive. When a function, method or program is activated, its state may also be initial or last-used.

  • Active State
  • Initial and Last-used States of Data
Parent topic: State of a Function, Method, Object or Program


Active State

A function, method or program may be activated recursively. Therefore, several instances of a function, method or program may be active at once.

An instance of a function is placed in an active state when it is successfully activated and remains active until the execution of a STOP statement or an implicit or explicit function format of the EXIT statement with this instance of this function.

An instance of a method is placed in an active state when it is successfully activated and remains active until the execution of a STOP statement or an implicit or explicit EXIT METHOD statement within this instance of this method.

An instance of a program is placed in an active state when it is successfully activated by the operating system or successfully called from a runtime element. An instance of a program remains active until the execution of one of the following:

  • A STOP statement
  • In a called program, an implicit or explicit EXIT PROGRAM statement within that program
  • A GOBACK statement within either that same called program or a program that is not under the control of a calling runtime element.

Whenever an instance of a function, method or program is activated, the control mechanisms for PERFORM statements contained in that instance of the function, method or program are set to their initial states and the GO TO statements referred to by ALTER statements are set to their initial states.

Parent topic: State of a Function, Method or Program


Initial and Last-used States of Data

When a function, method or program is activated, the data within is in either the initial state or the last-used state.

  • Initial State
  • Last-used State
Parent topic: State of a Function, Method or Program


Initial State

Automatic data and initial data is placed in the initial state every time the function, method or program in which it is described is activated.

Static data is placed in the initial state:

  1. The first time the function, method or program in which it is described is activated in a run unit.
  2. The first time the program in which it is described is activated after the execution of an activating statement referencing a program that possesses the initial attribute and directly or indirectly contains the program.
  3. The first time the program in which it is described is activated after the execution of a CANCEL statement referencing the program or CANCEL statement referencing a program that directly or indirectly contains the program.

When data in a function, method or program is placed in the initial state, the following occurs:

  1. Internal data items in the Working-Storage Section

    ISO2002 MF OS390 and Local-Storage Section

    that are subject to VALUE clauses are initialized as described in the section The VALUE Clause in the chapter Data Division - File and Data Description.

  2. Internal data items in the Working-Storage Section that are not subject to VALUE clauses and internal data items in the File Section are initialized in accordance with the setting of the DEFAULTBYTE Compiler directive.
  3. Internal data items in the Linkage Section

    ISO2002 MF OS390 and Local-Storage Section

    that are not subject to VALUE clauses and are undefined.

  4. MF Internal data items in the Thread-Local Section and the Object Section are treated in the same way as internal data items in the Working-Storage Section.
  5. The function, method or program's internal file connectors are initialized by setting them to not be in any open mode.
  6. The attributes of screen items are set as specified in the screen description entry.
Parent topic: Initial and Last-used States of Data
Related information
The VALUE Clause


Last-used State

MF , 78

Static and external data are the only data that are in the last-used state. External data is always in the last-used state except when the run unit is activated. Static data is in the last-used state except when it is in the initial state as defined above.

Parent topic: Initial and Last-used States of Data


Initial State of an Object

The initial state of an object is the state of the object immediately after it is created. Internal data, internal file connectors, and the attributes of screen items are initialized in the same manner as when data in a method or program is placed in the initial state, in accordance with the section Initial State.

Parent topic: State of a Function, Method, Object or Program
Related information
Initial State


Global Names and Local Names

A data-name names a data item. A file-name names a file connector. These names are classified as either global or local.

A global name can be used to refer to the item with which it is associated either from within the source element in which the global name is declared, or from within any other source element which is contained in the source element which declares the global name.

A local name, however, can be used only to refer to the item with which it is associated from within the source element in which the local name is declared. Some names are always global; other names are always local; some other names are either local or global depending upon specifications in the source element in which the names are declared.

A record-name is global if the GLOBAL clause is specified in the record description entry by which the record-name is declared or, in the case of record description entries in the File Section, if the GLOBAL clause is specified in the file description entry for the file-name associated with the record description entry.

A data-name is global if the GLOBAL clause is specified either in the data description entry by which the data-name is declared or in another entry to which that data description entry is subordinate.

A condition-name declared in a data description entry is global if that entry is subordinate to another entry in which the GLOBAL clause is specified. However, specific rules sometimes prohibit specification of the GLOBAL clause for certain data description, file description, or record description entries.

A file-name is global if the GLOBAL clause is specified in the file description entry for that file-name.

If a data-name, a file-name, or a condition-name declared in a data description entry is not global, the name is local.

Global names are transitive across source elements contained within other source elements.

Parent topic: Data Division


External and Internal Items

Accessible data items usually require that certain representations of data be stored. File connectors require that certain information concerning files be stored. The storage associated with a data item or a file connector can be external or internal.

External and internal items can have either global or local names.

A data record described in the Working-Storage Section is given the external attribute by the presence of the EXTERNAL clause in its data description entry. Any data item described by a data description entry subordinate to an entry describing an external record also attains the external attribute. If a record or data item does not have the external attribute, it is internal.

A file connector is given the external attribute by the presence of the EXTERNAL clause in the associated file description entry. If the file connector does not have the external attribute, it is internal.

The data records described subordinate to a file description entry which does not contain the EXTERNAL clause or a sort-merge file description entry, as well as any data items described subordinate to the data description entries for such records, are always internal. If the EXTERNAL clause is included in the file description entry, the data records and the data items attain the external attribute.

Data records, subordinate data items, and various associated control information described in the Local-Storage, Linkage, Report and Screen Sections are always internal. Special considerations apply to data described in the Linkage Section whereby an association is made between the data records described and other data items accessible to other runtime elements.

If a data item or file connector is external, the storage associated with that item is associated with the run unit rather than with any particular runtime module within the run unit. An external item can be referenced by any runtime module in the run unit that describes it. References to external items from different runtime modules using separate descriptions of the data item or file connector are always to the same item. In a run unit, there is only one representation of an external item.

If a data item or file connector is internal, the storage associated with it is associated only with the runtime module that describes it.

Parent topic: Data Division


Procedure Division

  • Execution
  • Statements and Sentences
Parent topic: Language Fundamentals


Execution

Execution begins with the first statement of the Procedure Division, excluding declaratives. Statements are then executed in the order in which they occur in the source element, except where the rules indicate some other order.

Parent topic: Procedure Division


Statements and Sentences

A statement is a syntactically valid combination of words and symbols beginning with a COBOL verb.

A sentence consists of one or more statements and is terminated by a period followed by a space.

Statements are of the following types:

  1. Conditional statements.
  2. COBOL system-directing statements.
  3. Imperative statements.
  4. ANS85 Delimited scope statements.

There are three types of sentences:

  1. Conditional sentences.
  2. COBOL system-directing sentences.
  3. Imperative sentences.
  • Conditional Statement
  • Conditional Sentence
  • COBOL System-Directing Statement
  • COBOL System-Directing Sentence
  • Compiler Directives
  • Imperative Statement
  • Imperative Sentence
  • Delimited Scope Statements
  • Categories of Statements
Parent topic: Procedure Division


Conditional Statement

A conditional statement specifies that the truth value of a condition is to be determined and that the subsequent flow of control is dependent on this truth value.

A conditional statement is one of the following:

  • An

    ANS85 EVALUATE,

    IF, SEARCH or RETURN statement

  • A READ statement that specifies the AT END or INVALID KEY phrase
  • OSVS An ON statement
  • A WRITE statement that specifies the INVALID KEY or END-OF-PAGE phrase
  • A START, REWRITE or DELETE statement that specifies the INVALID KEY phrase
  • An arithmetic statement (ADD, COMPUTE, DIVIDE, MULTIPLY, SUBTRACT) that specifies the SIZE ERROR phrase
  • A STRING or UNSTRING statement that specifies the ON OVERFLOW phrase
  • A CALL statement that specifies the ON OVERFLOW

    ANS85 or ON EXCEPTION

    phrase

  • MF XOPEN An ACCEPT or DISPLAY statement that specifies the ON EXCEPTION phrase.
Parent topic: Statements and Sentences


Conditional Sentence

A conditional sentence is a conditional statement, optionally preceded by an imperative statement, terminated by a separator period followed by a space.

Parent topic: Statements and Sentences


COBOL System-Directing Statement

A COBOL system-directing statement consists of a directing verb and its operands. The directing verbs are described in the chapter Compiler-directing Statements.

A COBOL system-directing statement causes your COBOL system to take a specified action during creation of the object code.

Parent topic: Statements and Sentences
Related information
Compiler-directing Statements


COBOL System-Directing Sentence

A COBOL system-directing sentence is a single system-directing statement terminated by a period followed by a space.

Parent topic: Statements and Sentences


Compiler Directives

Compiler directives give you options to control the actions of the Compiler. They allow you to enable language features, choose run-time behavior, choose compile-time options, create debugging information, control the format of data files, optimize the object code, and choose SQL options.

ISO2002 The compiler directives provided by the standard are described in the topic Compiler Directives.

MF The syntax of the directives and a description of each directive provided by this implementation are given in your COBOL system documentation.

Parent topic: Statements and Sentences
Related information
Compiler Directives


Imperative Statement

An imperative statement indicates a specific unconditional action to be taken . An imperative statement is any statement that is neither a conditional statement nor a COBOL system-directing statement. An imperative statement can consist of a sequence of imperative statements, each possibly separated from the next by a separator.

The imperative verbs are:

  • ACCEPT (1)
  • ADD (2)
  • ALTER
  • CALL (4)
  • CANCEL
  • CLOSE
  • COMPUTE (2)
  • DELETE (3)
  • DISPLAY (1)
  • DIVIDE (2)
  • EXIT
  • GO TO
  • INSPECT
  • MERGE
  • MOVE
  • MULTIPLY (2)
  • OPEN
  • PERFORM
  • READ (5)
  • RELEASE
  • REWRITE (3)
  • SET
  • SORT
  • START (3)
  • STOP
  • STRING (4)
  • SUBTRACT (2)
  • UNSTRING (4)
  • WRITE (6)

1 | Without the optional ON EXCEPTION phrase.
2 | Without the optional SIZE ERROR phrase.
3 | Without the optional INVALID KEY phrase.
4 | Without the optional ON OVERFLOW or ON EXCEPTION phrase.
5 | Without the optional AT END phrase or INVALID KEY phrase.
6 | Without the optional INVALID KEY phrase or END-OF-PAGE phrase.

ANS85 The additional ANSI'85 imperative verbs are:

  • CONTINUE
  • INITIALIZE

ISO2002 The additional ISO 2002 imperative verb is:

  • ISO2002 MF INVOKE

The additional OS/VS COBOL imperative verbs are:

  • EXAMINE
  • EXHIBIT
  • GOBACK
  • TRANSFORM

VSC2 The additional VS COBOL II imperative verb is:

  • VSC2 GOBACK

MF The additional imperative verbs available to this COBOL system are:

  • CHAIN
  • EXHIBIT
  • GOBACK
  • NEXT SENTENCE

When "imperative-statement" appears in the general format of statements, "imperative-statement" refers to that sequence of consecutive imperative statements that must be ended by a period or by any phrase associated with a statement containing that "imperative-statement".

OSVS Either the connective word "THEN" or the connective word "AND" can optionally be placed between any two imperative statements which appear in a single sequence of imperative statements.

Parent topic: Statements and Sentences


Imperative Sentence

An imperative sentence is an imperative statement terminated by a period followed by a space.

Parent topic: Statements and Sentences


Delimited Scope Statements

A delimited scope statement is a statement (for example, an IF statement) which is terminated by (that is, has its end-point determined by) a matching explicit scope terminator (in this case END-IF). Thus, all the statements between a delimited scope statement and its paired explicit scope terminator are deemed to be contained within that delimited scope statement.

Delimited scope statements can be nested, in which case each explicit scope terminator encountered is considered to pair with the nearest preceding unpaired matching delimited scope statement.

Scope delimited statements can also be implicitly terminated, either at the end of a procedural sentence (where all unterminated statements are terminated by the separator period), or by the termination of any containing delimited scope statement.

Note: Not all statements are scope delimitable in this fashion; those statements that are scope delimitable are termed delimited scope statements only if they are explicitly terminated by an explicit scope delimiter.

See the section Explicit And Implicit Scope Terminators in the chapter Concepts of the COBOL Language for further information.

Parent topic: Statements and Sentences
Related information
Explicit And Implicit Scope Terminators


Categories of Statements

Category Verbs
Arithmetic
  • ADD
  • COMPUTE
  • DIVIDE
  • INSPECT (TALLYING)
  • MULTIPLY
  • SUBTRACT
  • OSVS EXAMINE (TALLYING)
Conditional
  • ADD (SIZE ERROR)
  • CALL (OVERFLOW)
  • COMPUTE (SIZE ERROR)
  • DELETE (INVALID KEY)
  • DIVIDE (SIZE ERROR)
  • GO TO (DEPENDING)
  • IF
  • MULTIPLY (SIZE ERROR)
  • READ (END or INVALID KEY)
  • RETURN (END)
  • REWRITE (INVALID KEY)
  • SEARCH
  • START (INVALID KEY)
  • STRING (OVERFLOW)
  • UNSTRING (OVERFLOW)
  • WRITE (INVALID KEY or END-OF-PAGE)
  • ANS85 EVALUATE
  • OSVS ON
Data movement
  • ACCEPT (DATE, DAY or TIME)
  • INSPECT (REPLACING)
  • MOVE
  • STRING
  • UNSTRING
  • OSVS EXAMINE
  • OSVS TRANSFORM
  • ANS85 INITIALIZE
  • ANS85 INSPECT (CONVERTING)
  • ANS85 SET (TO TRUE)
  • MF SET (TO FALSE)
  • VSC2 MF SET (ADDRESS OF)
  • VSC2 MF SET (POINTER)
  • MF SET (object reference)
Ending
  • MF EXIT METHOD
  • EXIT PROGRAM
  • OSVS VSC2 MF GOBACK
  • STOP
Input/Output
  • ACCEPT (identifier)
  • CLOSE
  • MF COMMIT
  • DELETE
  • DISPLAY
  • OPEN
  • READ
  • RECEIVE
  • REWRITE ]
  • ROLLBACK
  • START
  • STOP (literal)
  • MF UNLOCK
  • WRITE
  • OSVS MF EXHIBIT
  • SET (TO ON or TO OFF)
Inter-program
  • CALL
  • CANCEL
  • MF CHAIN
  • OSVS VSC2 MF ENTRY
  • MF EXEC
  • ISO2002 MF INVOKE
  • OSVS VSC2 SERVICE
Null operation
  • EXIT
  • CONTINUE
Ordering
  • MERGE
  • RELEASE
  • RETURN
  • SORT
Procedure branching
  • ALTER
  • CALL
  • MF EXIT PERFORM/EXIT PARAGRAPH/EXIT SECTION
  • GO TO
  • MF NEXT SENTENCE
  • PERFORM
Scope delimiting
  • MF XOPEN END-ACCEPT
  • END-ADD
  • END-CALL
  • END-DELETE
  • MF XOPEN END-DISPLAY
  • END-DIVIDE
  • END-EVALUATE
  • END-IF
  • MF END-INVOKE
  • END-MULTIPLY
  • END-PERFORM
  • END-READ
  • END-RETURN
  • END-REWRITE
  • END-SEARCH
  • END-START
  • END-STRING
  • END-SUBTRACT
  • END-UNSTRING
  • END-WRITE
COBOL system-directing
  • OSVS VSC2 BASIS
  • OSVS VSC2 DELETE
  • OSVS VSC2 INSERT
  • MF $DISPLAY
  • MF $ELSE
  • MF $END
  • MF $IF
  • COPY
  • ENTER
  • USE
  • ANS85 REPLACE
  • OSVS VSC2 MF ENTRY
  • OSVS VSC2 MF EJECT
  • OSVS VSC2 MF SKIP1
  • OSVS VSC2 MF SKIP2
  • OSVS VSC2 MF SKIP3
  • VSC2 MF TITLE
  • OSVS NOTE
  • OSVS VSC2 ++INCLUDE
  • OSVS VSC2 -INC
Table handling
  • SEARCH
  • SET

IF and ON are verbs in the COBOL sense; it is recognized that they are not verbs in English.

Parent topic: Statements and Sentences


Reference Format

This entire section refers to fixed format only. Your COBOL system also accepts compilation groups written in free format.

The reference format, which provides a standard method for describing COBOL source text, is described in terms of character positions in a line on an input/output medium. Your COBOL system accepts source text written in reference format and produces an output listing using reference format.

The rules for spacing given in the discussion of the reference format take precedence over all other rules for spacing.

  • Reference Format Representation
  • Division, Section and Paragraph Formats
  • Data Division Entries
  • Declaratives
  • Comment Lines
Parent topic: Language Fundamentals
Related information
Free Format
Sample Program


Reference Format Representation

The reference format for a line is represented as shown below:

Reference Format for a COBOL Source Line

  • Margin L is immediately to the left of the leftmost character position of a line.
  • Margin C is between the 6th and 7th character positions of a line.
  • Margin A is between the 7th and 8th character positions of a line.
  • Margin B is between the 11th and 12th character positions of a line.
  • MF Margin R is immediately to the right of the 72nd character position of a line. A line can extend up to the 80th character position, but any characters occupying positions 73 to 80 are ignored by your COBOL system.

The sequence number area occupies six character positions (1-6), and is between margin L and margin C.

The indicator area is the 7th character position of a line.

Area A occupies character positions 8, 9, 10 and 11, and is between margin A and margin B.

Area B occupies character positions 12 through 72 inclusive; it begins immediately to the right of margin B and terminates immediately to the left of margin R.

ISO2002 The program text area consists of both area A and area B. Text-words can begin anywhere in the program text area.

  • Sequence Numbers
  • Continuation of Lines
  • Blank Lines
  • Pseudo-text
Parent topic: Reference Format


Sequence Numbers

A sequence number, normally consisting of six digits, can be placed in the sequence area and can be used to label a source line. This sequence number is usually in ascending numeric order on each successive source line.

OSVS VSC2 This sequence number is the one used by the BASIS mechanism for line editing, in which case it must be both numeric and in ascending order through the program (see the topic The BASIS Mechanism).

The ascending order of sequence numbers can be optionally verified by your COBOL system by using the SEQCHK Compiler directive.

ANS85 There is no requirement for the content of this area to be numeric, or even unique.

MF If the first character position of the sequence number field contains an asterisk, or any non-printing control character (less than the character SPACE in the ASCII collating sequence), then the line is treated as comment, and is not output to the listing file or device. This facility allows an output listing file to be used as a source file to a subsequent compile. This support is sensitive to the MFCOMMENT Compiler directive.

Parent topic: Reference Format Representation
Related information
The BASIS Mechanism


Continuation of Lines

Whenever a sentence, entry, phrase, or clause requires more than one line, it can be continued by starting subsequent line(s) in area B. These subsequent lines are called the continuation line(s). Any word, literal

ANS85 or PICTURE character-string

can be broken in such a way that part of it appears on a continuation line.

A hyphen in the indicator area of a line indicates that the first nonblank character in area B of the current line is the successor of the last nonblank character of the preceding line

ANS85 excluding intervening comment or blank lines

without any intervening space. However, if the continued line contains a nonnumeric literal without closing quotation mark, the first nonblank character in area B on the continuation line must be a quotation mark, and the continuation starts with the character immediately after that quotation mark. All spaces at the end of the continued line are considered part of the literal. Area A of a continuation line must be blank.

If there is no hyphen in the indicator area of a line, it is assumed that the last character in the preceding line is followed by a space. Both characters composing the separator "==" must be on the same line.

VSC2 MF Characters X" and G" must be on the same line.

MF Characters H" must be on the same line.

MF COB370 Characters N" must be on the same line.

MF XOPEN Characters *> must be on the same line.

ISO2002 Characters >> must be on the same line.

Parent topic: Reference Format Representation


Blank Lines

A blank line is one that is blank from margin C to margin R, inclusive. A blank line can appear anywhere in the source text.

Parent topic: Reference Format Representation


Pseudo-text

The text words and the separator space comprising pseudo-text can start in either area A or area B. If, however, there is a hyphen in the indicator area of a line which follows the opening pseudo-text delimiter, area A of the line must be blank; and the normal rules for continuation of lines apply to the formation of text words. (For an explanation of pseudo-text see the section Compiler-directing Statements.)

Parent topic: Reference Format Representation
Related information
Compiler-directing Statements


Division, Section and Paragraph Formats

  • Division Header
  • Section Header
  • Paragraph Header, Paragraph-name and Paragraph
Parent topic: Reference Format


Division Header

The division header must start in area A. (See Figure 1 in the topic Reference Format Representation.)

ISO2002 MF It may start in area B.

Parent topic: Division, Section and Paragraph Formats
Related information
Reference Format Representation


Section Header

The section header must start in area A. (See the figure in the topic Reference Format Representation.)

ISO2002 MF It may start in area B.

A section consists of zero, one, or more paragraphs in the Environment Division or Procedure Division or zero, one or more entries in the Data Division.

Parent topic: Division, Section and Paragraph Formats
Related information
Reference Format Representation


Paragraph Header, Paragraph-name and Paragraph

A paragraph consists of a paragraph-name followed by a period and a space, and by zero, one or more sentences, or a paragraph header followed by one or more entries. Comment entries can be included within a paragraph. The paragraph header or paragraph-name starts in area A of any line following the first line of a division or a section.

ISO2002 MF It may start in area B.

The first sentence or entry in a paragraph begins either on the same line as the paragraph header or paragraph-name, or in area B of the next nonblank line that is not a comment line. Successive sentences or entries begin either in area B of the same line as the preceding sentence or entry, or in area B of the next nonblank line that is not a comment line.

ISO2002 MF Sentences can begin anywhere in area A or area B unless the AREACHECK directive is specified.

When the sentences or entries of a paragraph require more than one line, they can be continued as described in the section Continuation of Lines.

Parent topic: Division, Section and Paragraph Formats
Related information
Continuation of Lines


Data Division Entries

Each Data Division entry begins with a level indicator or a level-number, followed by a space, followed by its associated name

ANS85 if any

, followed by a sequence of independent descriptive clauses. The last clause is always terminated by a period followed by a space.

There are two types of Data Division entry; those which begin with a level indicator and those which begin with a level-number.

A level indicator is any of the following:

  • FD (see the topic File Description Entry Skeleton),
  • SD (see the topic File Description Entry Skeleton),
  • RD (see the section The Report Description Entry.

In those Data Division entries that begin with a level indicator, the level indicator begins in area A followed by a space and followed in area B

ANS85 or area A

with its associated name and appropriate descriptive information.

Those Data Division entries that begin with level-numbers are called data description entries.

A level-number has a value taken from the set of values 1 through 49, 66, 77

MF , 78

and 88. Level-numbers in the range 1 through 9 can be written either as a single digit or as a zero followed by a significant digit. At least one space must separate a level-number from the word following the level-number.

In those data description entries that begin with level-number 01 or 77, the level-number begins in area A followed by a space and followed in area B

ANS85 or area A

by its associated record-name or item-name and appropriate descriptive information.

Successive data description entries can have the same format as the first and are indented according to level-number. Indentation does not affect the magnitude of a level-number.

When level-numbers are to be indented, each new level-number can begin any number of spaces to the right of margin A. The extent of indentation to the right is determined only by the width of the physical medium.

ISO2002 MF Data descriptions and level numbers other than 01 and 77 can also begin in area A.

Parent topic: Reference Format
Related information
File Description Entry Skeleton
The Report Description Entry


Declaratives

The key word DECLARATIVES and the key words END DECLARATIVES that precede and follow, respectively, the declaratives portion of the Procedure Division must each appear on a line by themselves. Each must begin in area A and be followed by a separator period (see the diagram in the topic Reference Format Representation).

Parent topic: Reference Format
Related information
Reference Format Representation


Comment Lines

A comment line is any line with an asterisk (*) in the continuation indicator area of the line. A comment line can appear as any line in a source element after the IDENTIFICATION DIVISION header. Any combination of characters from the computer's character set can be included in area A and area B of that line (see the diagram in the topic Reference Format Representation). The asterisk and the characters in area A and area B will be produced on the listing but serve as documentation only.

OSVS VSC2 MF A comment line can appear before the Identification Division header.

A second form of comment line represented as above but with a slash (/) (instead of an asterisk) in the indicator area of the line causes page ejection prior to printing the comment.

Successive comment lines are allowed. Continuation of comment lines is permitted, except that each continuation line must contain an asterisk in the indicator area.

  • In-line Comment
Parent topic: Reference Format
Related information
Reference Format Representation


In-line Comment

An in-line comment begins with the two contiguous characters "*>" preceded by a separator space, and ends with the last character position of the line. It allows free-form commentary to appear on the same line as character-strings and/or separators. An in-line comment can appear anywhere a separator space can appear in a COBOL compilation group or in a library text of a COBOL library. For the purpose of evaluating library text, pseudo-text and source text, an in-line comment has the value of a single space character. An in-line comment cannot be continued onto another line.

Parent topic: Comment Lines


Part 2. Program Definition

  • Compilation Group
  • Identification Division
  • Environment Division
  • Data Division
  • Procedure Division
  • Compiler-directing Statements
  • Examples
Parent topic: COBOL Language Reference


Compilation Group

  • Compilation Groups
    A compilation group is the entire source file that is submitted to the compiler.
  • End Markers
    End markers indicate the end of a definition
Parent topic: Part 2. Program Definition


Compilation Groups

A compilation group is the entire source file that is submitted to the compiler.

ANS85 A compilation group may contain zero, one, or more source units. A compilation group consists of a series of source units. A source unit may contain other source units and these contained source units may reference some of the resources of the source units within which they are contained.

A source unit begins with an Identification Division.

ANS85 A source unit includes any contained source units.

With the exception of source text manipulation statements

ANS85 and end markers

ISO2002 MF and compiler directives

, the statements, entries, paragraphs, and sections of a source unit are grouped into four divisions that are sequenced in the following order:

  1. Identification Division
  2. Environment Division
  3. Data Division
  4. Procedure Division

The beginning of a division in a source unit is indicated by the appropriate division header.

ISO2002 MF The beginning of the Identification Division may also be indicated by one of the paragraph headers permitted in the Identification Division.

The end of a division in a source unit is indicated by one of the following:

  1. The beginning of a succeeding division in that source unit
  2. ANS85 The end marker for that source unit
  3. That physical position after which no more source lines occur.

The end of a source unit is indicated by the absence of additional source lines in the compilation group.

ANS85 The end of a source unit can also be indicated by an end marker.

ANS85 When a source unit, B, is contained in another source unit, A, it may be directly or indirectly contained. Source unit B is directly contained in source unit A if there is no source unit contained in A that also contains B. Source unit B is indirectly contained in source unit A if there exists a source unit contained in A that also contains B.

A source unit that is directly or indirectly contained within another source unit is considered in these specifications as a separate source unit that may additionally reference certain resources defined in the containing source unit.

The object code resulting from compiling a source unit contained within another source unit is considered in these specifications to be inseparable from the object code resulting from compiling the containing source unit.

ANS85 A compilation unit is a source unit that is not contained within another source unit. It may be preceded or followed by other compilation units in a compilation group.

A source element is a source unit excluding any nested source units.

A runtime element is the result of compiling a source element.

A runtime module is the result of compiling a compilation unit.

ANS85 A compilation group may contain zero, one, or more source units. A compilation group consists of a series of source units. A source unit may contain other source units and these contained source units may reference some of the resources of the source units within which they are contained.

A source unit begins with an Identification Division.

ANS85 A source unit includes any contained source units.

With the exception of source text manipulation statements

ANS85 and end markers

ISO2002 MF and compiler directives

, the statements, entries, paragraphs, and sections of a source unit are grouped into four divisions that are sequenced in the following order:

  1. Identification Division
  2. Environment Division
  3. Data Division
  4. Procedure Division

The beginning of a division in a source unit is indicated by the appropriate division header.

ISO2002 MF The beginning of the Identification Division may also be indicated by one of the paragraph headers permitted in the Identification Division.

The end of a division in a source unit is indicated by one of the following:

  1. The beginning of a succeeding division in that source unit
  2. ANS85 The end marker for that source unit
  3. That physical position after which no more source lines occur.

The end of a source unit is indicated by the absence of additional source lines in the compilation group.

ANS85 The end of a source unit can also be indicated by an end marker.

ANS85 When a source unit, B, is contained in another source unit, A, it may be directly or indirectly contained. Source unit B is directly contained in source unit A if there is no source unit contained in A that also contains B. Source unit B is indirectly contained in source unit A if there exists a source unit contained in A that also contains B.

A source unit that is directly or indirectly contained within another source unit is considered in these specifications as a separate source unit that may additionally reference certain resources defined in the containing source unit.

The object code resulting from compiling a source unit contained within another source unit is considered in these specifications to be inseparable from the object code resulting from compiling the containing source unit.

ANS85 A compilation unit is a source unit that is not contained within another source unit. It may be preceded or followed by other compilation units in a compilation group.

A source element is a source unit excluding any nested source units.

A runtime element is the result of compiling a source element.

A runtime module is the result of compiling a compilation unit.

General Format

Syntax Rules

  1. Within a compilation group,

    MF call-prototypes and

    ISO2002 MF function-prototypes and program-prototypes

    must precede all other types of source units.

  2. ISO2002 MF If a compilation group contains both a function definition and a function prototype definition with the same externalized name, the signatures of these two compilation units must be the same.
  3. ISO2002 MF The Data Division of a method in an interface definition can contain only a Linkage Section.
  4. ISO2002 MF The Procedure Division of a method in an interface definition must contain only a PROCEDURE DIVISION header.
  5. MF In a call prototype, the PROCEDURE DIVISION header must conform to the rules for a format 2 PROCEDURE DIVISION header and any ENTRY statements must conform to the rules for a format 2 ENTRY statement.

General Rules:

  1. MF In a call prototype, all sections of the Data Division are ignored except for the Linkage Section, and the Procedure Division is ignored except for the PROCEDURE DIVISION header and ENTRY statements.
  2. ISO2002 MF In a function prototype and a program prototype, all sections of the Data Division are ignored except for the Linkage Section, and the Procedure Division is ignored except for thePROCEDURE DIVISION header.
Parent topic: Compilation Group


End Markers

End markers indicate the end of a definition

General Format

Syntax Rules

  1. An end marker must be present in every source unit that contains, is contained in, or precedes another source unit.
  2. Program-name-1 must be identical to the program-name declared in a preceding Program-ID paragraph.
  3. If a Program-ID paragraph declaring a specific program-name is stated between the Program-ID paragraph and the END PROGRAM marker for program-name-1, then an END PROGRAM marker referencing program-name must precede the END PROGRAM marker referencing program-name-1.
  4. ISO2002 MF Function-prototype-name-1 must be identical to the function-prototype-name declared in the corresponding Function-ID paragraph.
  5. ISO2002 MF User-function-name-1 must be identical to the user-function-name declared in the corresponding Function-ID paragraph.
  6. ISO2002 MF Program-prototype-name-1 must be identical to the program-prototype-name declared in the corresponding Program-ID paragraph.
  7. ISO2002 MF Class-name-1 must be identical to the class-name declared in the corresponding Class-ID paragraph.
  8. ISO2002 MF Method-name-1 must be identical to the method-name declared in the corresponding Method-ID paragraph.

    If the PROPERTY phrase is specified in the Method-ID paragraph, method-name-1 must be omitted.

  9. ISO2002 MF Interface-name-1 must be identical to the interface-name declared in the corresponding Interface-ID paragraph.
  10. If the source unit terminated by the end marker is contained within another source unit, the next statement must be either the first statement of a source unit or another end marker that terminates the containing source unit.
  11. If the source unit terminated by an end marker is not contained within another source unit, the next statement must be the first statement of a compilation unit.

General Rules

  1. An end marker indicates the end of the specified source unit.
Parent topic: Compilation Group


Identification Division

  • Identification Division - General Description
    The Identification Division identifies the program
  • The Program-ID Paragraph
    The Program-ID paragraph gives the name by which a program is identified and assigns selected program attributes to that program.
  • The Class-ID Paragraph
    The Class-ID paragraph indicates that this Identification Division is introducing a class definition and specifies the name that identifies the class and assigns class attributes to the class.
  • The Factory Paragraph
    The Factory paragraph indicates that this Identification Division is introducing a factory definition.
  • The Object Paragraph
    The Object paragraph indicates that this Identification Division is introducing an object definition.
  • The Method-ID Paragraph
    The Method-ID paragraph indicates that this Identification Division introduces a method definition, specifies the name that identifies the method or method prototype, and assigns method attributes to the method.
  • The Interface-ID Paragraph
    The Interface-ID paragraph indicates that this Identification Division is introducing an interface definition, specifies the name that identifies the interface and assigns interface attributes to the interface.
  • The Function-ID Paragraph
    The Function-ID paragraph specifies the name by which a function is identified and assigns selected attributes to that function.
  • The Date-Compiled Paragraph
    The Date-Compiled paragraph provides the date the intermediate code was produced in the Identification Division source program listing.
  • The Delegate-ID Paragraph
    The Delegate-ID paragraph indicates that this Identification Division introduces a delegate definition and specifies the name that identifies the delegate.
  • The Enum-ID Paragraph
    The Enum-ID paragraph indicates that this Identification Division introduces a enumeration definition and specifies the name that identifies the enumeration.
  • The Iterator-ID Paragraph
    The Iterator-ID paragraph indicates that this Identification Division introduces an iterator definition and specifies the name that identifies the iterator. Iterator-id can be specified wherever Method-ID can be specified, and can be used to define either static or instance iterators.
  • The Operator-ID Paragraph
    The Operator-ID paragraph indicates that this Identification Division introduces an operator definition and specifies the symbol or keyword that identifies the operator.
  • The Valuetype-ID Paragraph
    The Valuetype-ID paragraph indicates that this Identification Division introduces a valuetype definition and specifies the name that identifies the valuetype.
Parent topic: Part 2. Program Definition


Identification Division - General Description

The Identification Division identifies the program

ISO2002 MF , class, factory object, object, method,

NET delegate,

NET JVM enum, operator, valuetype,

ISO2002 function or interface.

MF This entire division (including the division header) is optional in a program definition.

MF Another way to identify the first source element defined in a file is with the basename, which is derived from the filename of the file containing the source element.

The Identification Division consists of a number of paragraphs. The paragraph header identifies the type of information contained in the paragraph.

ANS85 The Author, Installation, Date-Written, Date-Compiled, and Security paragraphs are classed as obsolete elements in the ANSI'85 standard and may be deleted from the next full revision of the ANSI Standard.

MF All dialects in this COBOL implementation except ISO2000 fully support these obsolete paragraphs. The FLAGSTD Compiler directive can be used to detect all occurrences of this syntax.

XOPEN Although they are a part of the standard COBOL definition, the obsolete paragraphs are explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open source program.

General Format

Syntax Rules

  1. OSVS VSC2 MF The paragraphs can appear in any order.
  2. OSVS VSC2 The periods following the paragraph-names in the Identification Division are optional as is the period following the program-name.
  3. The comment-entry can be any combination of the characters from the computer's character set. The continuation of the comment-entry by the use of a hyphen in the continuation area is not permitted. If the Compiler directive SOURCEFORMAT is specified as or defaulted to FIXED, the comment-entry can be contained on one or more lines but is restricted to area B of those lines; the next line commencing in area A begins the next non-comment entry.

    MF If the Compiler directive SOURCEFORMAT is specified as FREE, the comment-entry cannot be continued; the next line begins the next non-comment entry.

    VSC2 The comment-entry can contain the SKIP1, SKIP2, SKIP3, EJECT or TITLE statements anywhere on the line. These statements are actioned if they are alone on a line in the comment-entry, and do not terminate the comment-entry.

    OSVS The comment-entry can contain the SKIP1, SKIP2, SKIP3, or EJECT statements anywhere in the B margin. These statements are actioned if they are alone on a line in the comment-entry, and do not terminate the comment-entry.

    OSVS The comment-entry can be contained in either area A or area B of the comment-entry lines. However, the next occurrence in area A of any one of the following COBOL words or phrases terminates the comment-entry and begin the next paragraph or division:

    OSVS
    • OSVS PROGRAM-ID
    • OSVS AUTHOR
    • OSVS INSTALLATION
    • OSVS DATE-WRITTEN
    • OSVS DATE-COMPILED
    • OSVS SECURITY
    • OSVS ENVIRONMENT
    • OSVS DATA
    • OSVS PROCEDURE
Parent topic: Identification Division


The Program-ID Paragraph

The Program-ID paragraph gives the name by which a program is identified and assigns selected program attributes to that program.

ISO2002 MF The Program-ID paragraph specifies the name by which a program prototype is identified.

MF The Program-ID paragraph specifies the name by which a call prototype is identified.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

General Formats for Format 4

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • CASE - determines whether upper-case and lower-case letters are considered equivalent.
    • DEFAULT-BYTE - sets the value for data items defined in Working-Storage Section without a VALUE clause.
    • MAPNAME - impacts the handling of non-alphabetic characters in the program-name.
    • PROGID-COMMENT - causes Format 1 to be assumed rather than Format 2.

Syntax Rules for All Formats

  1. OSVS VSC2 MF Program-name-1 can be a nonnumeric literal specified with or without enclosing quotation marks. The content of the literal must follow the rules for formation of program-names, but may also contain the characters @, #, and $.
  2. Program-name-1 must not be the same as another user-defined word.

    OSVS MF Program-name-1 can be the same as another user-defined word.

Syntax Rules for Formats1 and 2

  3. OSVS VSC2 The first 8 characters of program-name-1 of a program that is not contained in another program should be unique in the system. The first character must be alphabetic; otherwise it is converted as follows:
    • 1 through 9 are changed to A through I respectively.
    • Anything else is changed to J.

    If a hyphen is used in characters 2 through 8 of program-name-1 in a program that is not contained in another program, it is changed to zero (0).

    The MAPNAME Compiler directive controls this behavior.

    VSC2 For programs that are contained in another program, program-name-1 can be any valid user-defined COBOL word, up to 30 characters long. The first eight characters need not be unique, and they will not be converted as described above. Lower-case letters are valid, but such program-names will be handled in a case-insensitive manner.

  4. ANS85 A program contained within another program must not be assigned the same name as that of any other program contained within the compilation unit that contains this program.

Syntax Rules for Format 2

  5. ANS85 The optional COMMON clause can be used only if the program is contained within another program.
  6. ANS85 If the IS PROGRAM phrase is present, at least one of COMMON or INITIAL

    ISO2002 MF OS390 or RECURSIVE

    must be specified.

  7. ISO2002 Literal-1 must be an alphanumeric literal and must not be a figurative constant.
  8. ISO2002 Literal-1 must not be specified in a program that is contained within another program.
  9. ISO2002 MF The RECURSIVE clause must not be specified if any program that directly or indirectly contains this program is an initial program.
  10. OS390 The RECURSIVE clause must not be specified in a program that is contained within another program.
  11. OS390 The RECURSIVE clause must not be specified in a program that contains another program.

Syntax Rules for Format 4

  12. ISO2002 MF Program-prototype-name-1 identifies the program prototoype. However, literal-1, if specified, is the name of the program prototype that is externalized to the operating environment.

General Rules for Formats 1 and 2

  1. Program-name-1 names the program declared by this program definition and is associated with the object code file pertaining to this program. Literal-1, if specified, is the name of the program that is externalized to the operating environment.

General Rules for Format 2

  2. ANS85 The COMMON clause specifies that the program is common. A common program is contained within another program but can be called from programs other than that containing it.
  3. ANS85 The INITIAL clause specifies that the program is initial. When an initial program is called, it and any programs contained within it are placed in their initial state. See the topic Initial State in the chapter Language Fundamentals.
  4. ISO2002 MF OS390 The RECURSIVE clause specifies that the program is recursive.

    ISO2002 MF Any programs contained within a recursive program are recursive.

    ISO2002 MF OS390 A program in which the Local-Storage Section is specified is recursive.

    A recursive program may be called while it is active and may call itself.

  5. ISO2002 MF OS390 If the RECURSIVE clause is not specified in a program or implied for a program, the program must not be called while it is active.
  6. ISO2002 MF OS390 Additional rules concerning common, initial and recursive programs are given in the topic Common, Initial and Recursive Attributes in the chapter Language Fundamentals

General Rules for Format 3

  7. MF Program-name-1 names the call prototype that will be used during syntax checking to determine the validity and nature of CALL literal statements.
Parent topic: Identification Division
Related reference
Program Identification and Data Names
Related information
Initial State
Common, Initial and Recursive Attributes


The Class-ID Paragraph

The Class-ID paragraph indicates that this Identification Division is introducing a class definition and specifies the name that identifies the class and assigns class attributes to the class.

General Format

Directives

  1. In addition to the Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • ACTUAL-PARAMS - specifies the parameters to be used in the creation of a class from a parameterized class or interface.
    • ILSOURCE - specifies a file that contains another program to form part of the current .NET assembly. This may include further components of a partial class .

Syntax Rules

  1. Literal-1 must be an alphanumeric literal and must not be a figurative constant.
  2. Type-specifier-1 must not be the name of the class declared by this class definition.
  3. Type-specifier-1 must not inherit from class-name-1 directly or indirectly.
  4. Type-specifier-1 must not be the name of a class defined with the FINAL clause.
  5. Type-specifier-1 cannot be repeated when you compile a program for .NET. In other words, multiple inheritance is not allowed.
  6. Type-specifier-2 must not refer to the interface.
  7. A given class name must not appear more than once in an INHERITS clause.
  8. If two or more different methods with the same name are inherited, none of them may be specified with the FINAL clause. If the same method is inherited from one superclass through two or more intermediate superclasses, it may be specified with the FINAL clause.
  9. If a given method-name is inherited from more than one inherited class, then, if the prototypes for these methods are such that to define a method with the same interface as any one of them in this class would prevent this class from conforming to all the inherited classes, then a method with the same method-name must be declared in this class. This method must satisfy syntax rule 9 in the topic The Method-ID Paragraph.
    Note: If class A inherits method M from two classes, B and C, and the method interface for M is not identical in classes B and C (say M in B returns an object of class X, and M in C returns an object of an unrelated class Y), then the inheritance is invalid, unless a valid method override of M is defined in class A that resolves the method interface conformance problem. It is not always possible to do so (in which case the inheritance is not valid), but there are some cases in which it can be done. For example, if it is possible to define Z as a class that inherits X and Y, then a method override for M could be specified in class A, returning an object of class Z.
  10. Parameter-name-1 must be a name specified in a class-specifier or an interface-specifier in the Repository paragraph of this class definition.
  11. NET JVM Attribute-clause is defined in the topic on the Custom-Attribute Clause.

General Rules

  1. Class-name-1 names the class declared by this class definition. However, literal-1, if specified, is the name of the class that is externalized to the operating environment.
  2. The INHERITS clause specifies the name of the class that is inherited by class-name-1 according to Class inheritance.
  3. If the FINAL clause is specified, the class must not be the superclass for any other class.
  4. NET JVM The PARTIAL phrase specifies that this is a partial class that may be combined with one or more other partial classes with the same externalized name to form a single combined class. This may be combined using the ILSOURCE directive.
  5. NET JVM The USING phrase specifies that this is a parameterized class. Parameter-name-1 is the name given to the formal parameter. See the topic Parameterized Classes in the chapter Language Fundamentals for details of the behavior of a parameterized class.

    When USING is specified for a class that is being compiled for .NET, the resulting class is known as a generic class. Constraints for the parameters may be specified in the Constraints paragraph.

  6. Parameter-name-1 must be specified within this class definition only where a class-name or an interface-name is permitted.
  7. If the same class is inherited more than once, then only one copy of the data for that class is added to class-name-1.
    Note: While the same class cannot be directly inherited more than once, a class may be indirectly inherited multiple times. For example, suppose class D inherits from classes B and C, and classes B and C both inherit from class A. In this example, class D indirectly inherits class A twice, once as a superclass of B, and once as a superclass of C.
  8. NET JVM If STATIC is specified, all methods in a class are static.
Parent topic: Identification Division
Related reference
Simplified Class Layout
Related information
The CUSTOM-ATTRIBUTE Clause
Specifying Type Names
Parameterized Classes


The Factory Paragraph

The Factory paragraph indicates that this Identification Division is introducing a factory definition.

General Format

Syntax Rules

  1. Interface-name-1 must be the name of an interface specified in the Repository paragraph of the containing class definition.
  2. Each method prototype in each implemented interface must be such that the factory interface of this class conforms to all implemented interfaces.
  3. FACTORY and STATIC are synonymous.

General Rules

  1. The IMPLEMENTS clause specifies the names of the interfaces that are implemented by the factory object of the containing class according to section Interface Implementation in the chapter Language Fundamentals.
  2. A factory object implements an interface int-1 in the following cases:
    1. The factory object is defined with an IMPLEMENTS clause specifying int-1,
    2. The factory object implements an interface that inherits int-1,
    3. The class containing the factory object inherits a class whose factory object implements int-1.
Parent topic: Identification Division
Related information
Interface Implementation


The Object Paragraph

The Object paragraph indicates that this Identification Division is introducing an object definition.

General Format

Syntax Rules

  1. Interface-name-1 must be the name of an interface specified in the Repository paragraph of the containing class definition.
  2. Each method prototype in each implemented interface must be such that the object interface of this class conforms to all implemented interfaces.

General Rules

  1. The IMPLEMENTS clause specifies the names of the interfaces that are implemented by the instance object of the containing class according to section Interface Implementation in the chapter Language Fundamentals.
  2. An instance object implements an interface int-1 in the following cases:
    1. The instance object is defined with an IMPLEMENTS clause specifying int-1.
    2. The instance object implements an interface that inherits int-1.
    3. The class containg the instance object inherits a class whose instance object implements int-1.
Parent topic: Identification Division
Related information
Interface Implementation


The Method-ID Paragraph

The Method-ID paragraph indicates that this Identification Division introduces a method definition, specifies the name that identifies the method or method prototype, and assigns method attributes to the method.

General Format

Syntax Rules

  1. Literal-1 must be an alphanumeric literal and must not be a figurative constant.
  2. If property-name-1 is specified as a data-name in the Working-Storage Section of the containing object or factory definition, the PROPERTY clause must not be specified in the data description entry of that data-name.
  3. If the GET phrase is specified, then the method must have no USING phrase parameters specified in the PROCEDURE DIVISION header and must have a single RETURNING phrase.
  4. If the SET phrase is specified, then the method must have a single USING parameter specified in the PROCEDURE DIVISION header and no RETURNING phrase.
  5. If STATIC is specified, the method is a static method. In other words, it is accessed through the class rather than an instance of the class.
  6. The OVERRIDE phrase must not be specified in a method prototype.
  7. If the OVERRIDE phrase is specified, there must be a method with the same name as the method declared by this method definition defined in a superclass. The method in the superclass must not be defined with the FINAL clause.
  8. If the OVERRIDE phrase is not specified:
    1. If this method definition is contained in a class definition, no inherited method may have the same name as the method declared by this method definition
    2. If this method definition is contained in an interface definition, no inherited method prototype may have the same name as the method prototype declared by this method definition.
  9. NET JVM If the REDEFINE phrase is specified, there must be a method with the same name as the method declared by this method definition defined in a superclass.
  10. The FINAL clause must not be specified in a method prototype.
  11. If method-name-1 or literal-1 is the same as a method-name inherited by the containing definition, the parameter declarations and returning item in the PROCEDURE DIVISION header must obey the rules of conformance to ensure that the definition that contains this method definition conforms to every inherited definition according to the section Conformance for Parameters and Returning Items in the chapter Procedure Division.
  12. NET JVM If the ABSTRACT phrase is specified, the ABSTRACT phrase must also be specified in the CLASS-ID paragraph of the containing class.
  13. NET JVM If the ABSTRACT phrase is specified, the Procedure Division of this method must be empty.
  14. NET JVM The ABSTRACT phrase must not be specified in a static method.
  15. NET JVM If the PROTECTED phrase is specified, the ABSTRACT phrase must not be specified.
  16. NET JVM The FOR clause may only be specified for instance methods.
  17. NET JVM Interface-name-1 must be the name of an interface, which is implemented by the current class.
  18. NET JVM This interface must include a method with the same signature as the current method.
  19. NET JVM Attribute-clause is defined in the topic on the Custom-Attribute Clause.

General Rules

  1. The name of the method declared by this method definition is determined as follows:
    1. If the PROPERTY clause is specified, the name is formed as follows:
      1. If the GET phrase is specified, the characters "GET" are concatenated to property-name-1 folded to upper case.
      2. If the SET phrase is specified, the characters "SET" are concatenated to property-name-1 folded to upper case.
    2. If the PROPERTY clause is not specified, the name is method-name-1. However, literal-1, if specified, is the name of the method that is externalized to the operating environment.
  2. The OVERRIDE phrase indicates that this method overrides the inherited method.
  3. NET JVM The REDEFINE phrase indicates that this method creates a new method with the same name that hides the parent method. Hiding is the same as overriding the inherited method when an object is described as being of an inherited class, however, when an object is described as being of a particular class, but actually contains an instance of a derived class, the method in the class referenced in the description of the object is executed.
  4. The FINAL clause indicates that this method must not be overridden in any subclasses

    NET JVM , but it can be redefined

    .
  5. The name of this method can be referenced in the invocation of a method for an object of the class in which this method is defined.
  6. If a given user-defined word is defined in the Data Division of this method definition and in the Data Division of the containing factory definition or object definition, the use of that word in this method refers to the declaration in this method. The declaration in the containing factory object or object definition is inaccessible to this method.
  7. If the GET phrase is specified, this method is a get property method for property-name-1.
  8. If the SET phrase is specified, this method is a set property method for property-name-1.
  9. NET JVM If the PUBLIC phrase is specified or implied, this method may be invoked from any runtime element.
  10. NET JVM If the PRIVATE phrase is specified, this method may be invoked only from within the containing class.
  11. NET JVM If the PROTECTED phrase is specified without the INTERNAL phrase, this method may be invoked only from within the containing class or a class that inherits from the containing class.
  12. NET JVM If the PROTECTED phrase is specified with the INTERNAL phrase, this method may be invoked only from within the containing class, a class that inherits from the containing class, or from within the current compilation unit.
  13. NET JVM If the INTERNAL phrase is specified without the PROTECTED phrase, this method may be invoked only from within the current compilation unit.
  14. NET JVM If the ABSTRACT phrase is specified, this method must be overridden in every derived class that is not itself ABSTRACT.
  15. NET JVM The CUSTOM-ATTRIBUTE phrase associates the specified custom attributes with this method.
  16. NET JVM If the FOR clause is specified, this method is an Explicit Interface Member Implementation. The method may not be invoked explicitly. It will be invoked implicitly when the corresponding method is invoked on an instance of this class which has been cast to the interface type.
Parent topic: Identification Division
Related information
Conformance for Parameters and Returning Items
The CUSTOM-ATTRIBUTE Clause
Specifying Type Names
The SYNC Statement


The Interface-ID Paragraph

The Interface-ID paragraph indicates that this Identification Division is introducing an interface definition, specifies the name that identifies the interface and assigns interface attributes to the interface.

General Format

Directives

  1. In addition to the Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • ACTUAL-PARAMS - specifies the parameters to be used in the creation of an interface from a parameterized class or interface

Syntax Rules

  1. Literal-1 must be an alphanumeric literal and must not be a figurative constant.
  2. Type-specifier must not inherit directly or indirectly from interface-name-1.
  3. Type-specifier cannot be repeated when you compile a program for .NET. In other words, multiple inheritance is not allowed.
  4. Parameter-name-1 must be a name specified in a class-specifier or an interface-specifier in the Repository paragraph of this interface definition.
  5. If a given method-name is inherited from more than one interface, the method prototype in each inherited interface must be such that this interface conforms to all inherited interfaces.
  6. NET JVM Attribute-clause is defined in the topic on the Custom-Attribute Clause.

General Rules

  1. Interface-name-1 names the interface declared by this interface definition. However, literal-1, if specified, is the name of the interface that is externalized to the operating environment.
  2. The INHERITS phrase specifies the name of the interface that is inherited by interface-name-1 as described in the topic Interface Inheritance in the chapter Language Fundamentals.
  3. NET JVM The USING phrase specifies that this is a parameterized interface. Parameter-name-1 is the name given to the formal parameter.
  4. Parameter-name-1 must be specified within this interface definition only where a class-name or an interface-name is permitted.
Parent topic: Identification Division
Related information
Interface Inheritance
The CUSTOM-ATTRIBUTE Clause
Specifying Type Names


The Function-ID Paragraph

The Function-ID paragraph specifies the name by which a function is identified and assigns selected attributes to that function.

General Format for Format 1 (definition):

General Format for Format 2 (prototype):

Syntax Rules

  1. Literal-1 must be an alphanumeric literal and must not be a figurative constant.

General Rules for Format 1

  1. User-function-name-1 names the function declared by this function definition. However, literal-1, if specified, is the name of the function that is externalized to the operating environment.

General Rules for Format 2

  2. Function-prototype-name-1 names the function prototype declared by this definition. However, literal-1, if specified, is the name of the function prototype that is externalized to the operating environment.
Parent topic: Identification Division


The Date-Compiled Paragraph

The Date-Compiled paragraph provides the date the intermediate code was produced in the Identification Division source program listing.

General Format

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or semantics described in this section.
    • DATE - impacts the format in which the date is printed in this paragraph.

Syntax Rules

  1. The comment-entry can be any combination of the characters from the computer's character set. The continuation of the comment entry by use of the hyphen is not permitted; however, the comment entry can be contained on one or more lines. The comment-entry lines must be contained in area B. The next line commencing in area A will begin the next non-comment paragraph.

General Rules

  1. The paragraph-name DATE-COMPILED causes your COBOL system to insert a date comment-entry as the executable code is created. If a Date-Compiled paragraph is present (with or without a comment-entry), the paragraph is replaced in the program listing with one of the form:
     DATE-COMPILED. current-date-and-time .

    where the date and time format is DD-MMM-YY hh:mm .

    The DATE Compiler directive can impact the comment-entry replacement string for your COBOL implementation.

    ANS85 The value inserted in the Date-Compiled paragraph is also the value used in the WHEN-COMPILED intrinsic function. However, the format can differ.

Parent topic: Identification Division


The Delegate-ID Paragraph

The Delegate-ID paragraph indicates that this Identification Division introduces a delegate definition and specifies the name that identifies the delegate.

General Format

Syntax Rules

  1. Attribute-clause is defined in the topic on the Custom-Attribute Clause.

General Rules

  1. A delegate is the .NET equivalent of a function pointer, however, a delegate has a well-defined signature.
  2. For a discussion of delegates, see the Delegates section in the .NET Concepts section of the Language Fundamentals chapter.
Parent topic: Identification Division
Related reference
Managed Code Concepts
Delegates and Events
Related information
The CUSTOM-ATTRIBUTE Clause


The Enum-ID Paragraph

The Enum-ID paragraph indicates that this Identification Division introduces a enumeration definition and specifies the name that identifies the enumeration.

General Format

Syntax Rules

  1. An enum program consists only of an optional environment division and a data division.
  2. The environment division, if specified, must include only a repository paragraph and a class-attributes paragraph
  3. The data division must include only a working-storage section which has:
    • an optional 01 level item of type, e.g. BINARY-LONG or BINARY-DOUBLE. The type of this item determines the underlying type of the enum. If no such 01 level item is specified, the underlying type is BINARY-LONG.
    • any number of level 78 items, for which the VALUE clause may be omitted. If the VALUE clause is present, it must specify an integer literal. If omitted, the value is assumed to be 1 if this is the first item, and for subsequent items 1 more than the previous value.
  4. The enum definition may be terminated with END ENUM enumeration-name.
  5. Attribute-clause is defined in the topic on the Custom-Attribute Clause.

General Rules

  1. The attributes clause is used to assign any custom attributes to the enum (for instance the Flags attribute, which indicates that the enum is to be regarded as a set of bit settings).
  2. If a 01 level item is specified, the type of this item determines the underlying type of the enum. If no 01 level item is specified, the underlying type is BINARY-LONG.
  3. Each level 78 item specifies an enum member with the same name and value
  4. In .NET, but not JVM, you need to set the attribute System.FlagsAttribute. This attribute applied to an enum means that the distinct values are to be regarded as bit settings, and can therefore be combined.
Parent topic: Identification Division
Related reference
Enumerations and Enum types
Related information
The CUSTOM-ATTRIBUTE Clause


The Iterator-ID Paragraph

The Iterator-ID paragraph indicates that this Identification Division introduces an iterator definition and specifies the name that identifies the iterator. Iterator-id can be specified wherever Method-ID can be specified, and can be used to define either static or instance iterators.

General Format

Syntax Rules:

  1. The procedure division header of an Iterator must include a Yielding phrase. The type of the item specified in the Yielding phrase determines the type of the iterators.
  2. Attribute-clause is defined in the topic on the Custom-Attribute Clause.

General Rules

  1. For an iterators of type T, the system will automatically generate a nested class which implements both IEnumerable[T] and IEnumerator[T].
  2. The system also generates a method with the name specified in the Iterator-ID paragraph. This method returns an item of the nested type defined in GR 1.
  3. Code outside the context of the iterators may invoke this method to return the iteration object, and iterate through it using the PERFORM THROUGH collection class syntax (see PERFORM statement format 5).
  4. The order in which iteration proceeds is determined by the successive RETURNING values when each EXIT ITERATOR statement is executed.
Parent topic: Identification Division
Related information
The CUSTOM-ATTRIBUTE Clause


The Operator-ID Paragraph

The Operator-ID paragraph indicates that this Identification Division introduces an operator definition and specifies the symbol or keyword that identifies the operator.

General Format

Syntax Rules

  1. The Operator-ID paragraph may be specified only within a factory definition.
  2. An implicit conversion should only be used when the target type is able to represent all possible values of the source type.
  3. An explicit conversion, which is specified using casting syntax (object-name AS type-name), can be used when there is a possibility of failure.
  4. If a comparison operator is specified, a boolean data item must be specified in the RETURNING phrase of the Procedure Division header.
  5. Except for unary +, unary –, IMPLICIT and EXPLICIT, there must be two formal parameters specified in the USING phrase of the Procedure Division header, at least one of which must be of the class in which this operator is defined.
  6. If IMPLICIT or EXPLICIT is specified, there must be one formal parameter specified in the USING phrase of the Procedure Division header and one data item specified in the RETURNING phrase of that header. Either the formal parameter or the return value must be of the class in which this operator is defined.

General Rules

  1. The new meaning for the operator can be anything, but it is a good idea if it is consistent with the normal understanding of the operator.
  2. Overloaded arithmetic expressions can be specified anywhere that a normal arithmetic expression can be specified.
  3. Implicit and explicit conversions give a way of assigning an item of one type to another type, even when neither type inherits, directly or indirectly, from the other.
  4. You can tell if an operator is overloaded by using a class browser such as Reflector, look for factory (static) methods whose names begin with the prefix op_.
Parent topic: Identification Division
Related information
The CUSTOM-ATTRIBUTE Clause


The Valuetype-ID Paragraph

The Valuetype-ID paragraph indicates that this Identification Division introduces a valuetype definition and specifies the name that identifies the valuetype.

General Format

Syntax Rules

  1. Within a valuetype definition, the object data must consist only of .NET native types.
  2. The valuetype definition must not include a parameter-less constructor.
  3. Attribute-clause is defined in the topic on the Custom-Attribute Clause.
Parent topic: Identification Division
Related information
The CUSTOM-ATTRIBUTE Clause


Environment Division

  • Configuration Section
    The Configuration Section is located in the Environment Division. The Configuration Section specifies aspects of the data processing system that are dependent on the specific system as well as special control techniques and a means of associating a local name with an external resource.
  • Input-Output Section
    The Input-Output Section deals with the information needed to control transmission and handling of data between external media and a runtime element.
Parent topic: Part 2. Program Definition


General Description

The Environment Division specifies a standard method of expressing those aspects of a data processing problem that are dependent upon the physical characteristics of a specific computer. This division allows specification of the configuration of the compiling computer and the object computer. In addition, information relative to input-output control, special hardware characteristics and control techniques may be given.

ANS85 The Environment Division is optional in a COBOL source element.

General Format

    ENVIRONMENT DIVISION. [configuration-section][input-output-section]

Syntax Rules

  1. MF If the program includes an Environment Division, the Environment Division header is optional only if it is the first division in the program.


Configuration Section

The Configuration Section is located in the Environment Division. The Configuration Section specifies aspects of the data processing system that are dependent on the specific system as well as special control techniques and a means of associating a local name with an external resource.

ANS85 OSVS The Configuration Section is optional .

This section is divided into paragraphs: the Source-Computer paragraph, which describes the computer configuration on which the source element is compiled; the Object-Computer paragraph, which describes the computer configuration on which the runtime module produced by the compiler is to be run; the Special-Names paragraph, which provides a means for specifying the currency symbol and the currency string, choosing the decimal point, specifying symbolic-characters, relating implementor-names to user-specified mnemonic-names, relating alphabet-names to character sets or collating sequences, and relating class-names to sets of characters; the Repository paragraph, which provides a means for associating a local name with an external resource and specifying which intrinsic function names become reserved words for this source unit; and the Constraints paragraph, which provides a means for specifying properties of generic parameters, and therefore allows the use of methods or properties on data items whose type is that generic parameter.

General Format

Syntax Rules

  1. MF The CONFIGURATION SECTION header is optional only if it is the first statement in the program.
  2. ANS85 The Configuration Section must not be stated in a program that is contained within another program.
  3. ISO2002 The Configuration Section must not be stated in a method definition.
  4. ISO2002 The Source-Computer, Object-Computer and Repository paragraphs must not be stated in a factory definition or an object definition.
  5. NET JVM The Constraints paragraph must not be stated in a factory defintion or an object definition.

General Rules

  1. ANS85 The entries explicitly or implicitly stated in the Configuration Section of a source unit that contains other source units apply to each directly or indirectly contained source unit.
Parent topic: Environment Division


The Source-Computer Paragraph

The Source-Computer paragraph identifies the computer on which the compilation unit is to be compiled.

General Format

General Rules

  1. The source-computer-name is documentary only.
  2. The WITH DEBUGGING MODE clause is used to enable debugging code, in accordance with the Standard ANSI COBOL Debug Module. (See the topic The WITH DEBUGGING MODE Clause.)
  3. ISO2002 All clauses of the Source-Computer paragraph apply to the source unit in which they are explicitly or implicitly specified and to any source unit contained within that source unit.
Related information
The WITH DEBUGGING MODE Clause


The Object-Computer Paragraph

The Object-Computer paragraph provides a means of describing the computer on which the runtime module created by the compiler is to be executed.

ANS85 OSVS It is optional.

ANS85 The MEMORY SIZE clause and SEGMENT-LIMIT clause are classed as obsolete elements in the ANSI'85 standard and are scheduled to be deleted from the next full revision of the ANSI standard.

MF All dialects within this COBOL implementation support the MEMORY SIZE clause and SEGMENT-LIMIT clause for documentary purposes only. The FLAGSTD Compiler directive can be used to detect occurrences of this syntax.

XOPEN Although they are part of the standard COBOL definition, the MEMORY SIZE clause and SEGMENT-LIMIT clause are explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

General Format

Syntax Rules

  1. Object-computer-name must be one user-defined COBOL word.
  2. ANS85 OSVS The Object-Computer paragraph can consist of only the OBJECT-COMPUTER header.

General Rules

  1. The computer-name provides a means for identifying equipment configuration. The configuration definition contains specific information concerning the memory size. The computer-name and the MEMORY SIZE clause are documentary only.
  2. If the PROGRAM COLLATING SEQUENCE clause is not specified, the native collating sequence is used. The appendix Character Sets and Collating Sequences lists both the full ASCII and EBCDIC collating sequences. Either can be chosen as the native collating sequence by use of the NATIVE Compiler directive.
  3. If the PROGRAM COLLATING SEQUENCE clause is specified, the program collating sequence is the collating sequence associated with the alphabet-name specified in that clause.
  4. The program collating sequence established in the Object-Computer paragraph is used to determine the truth value of any nonnumeric comparisons:
    1. Explicitly specified in relation conditions (see the topic Relation Condition in the chapter Procedure Division).
    2. Explicitly specified in condition-name conditions; see the topic Condition-Name Condition (Conditional Variable) in the chapter Procedure Division.
  5. The PROGRAM COLLATING SEQUENCE clause is also applied to any nonnumeric merge or sort keys unless the COLLATING SEQUENCE phrase of the respective SORT or MERGE statement is specified.
  6. The PROGRAM COLLATING SEQUENCE clause has no effect on the ordering of indexed files.
  7. The PROGRAM COLLATING SEQUENCE clause applies only to the source element in which it is specified

    ANS85 and source elements contained within it

  8. The SEGMENT-LIMIT clause is documentary only. (See the topic Segmentation.)
Related information
Character Sets and Collating Sequences
Relation Condition
Condition-Name Condition (Conditional Variable)
Segmentation


The Special-Names Paragraph

The Special-Names paragraph provides a means for specifying the currency string and the currency symbol, choosing the decimal point,

ANS85 specifying symbolic-characters,

relating implementor-names to user-specified mnemonic-names, relating alphabet-names to character sets or collating sequences, and relating class-names to sets of characters.

MF You can select one of several pre-defined parameter passing conventions. Enhancements to the CALL statement and the PROCEDURE DIVISION header allow these parameter passing conventions to be used in inter-program communication.

General Format

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • ALPHASTART - determines whether valid numeric literals used in the ALPHABET clause can begin with 0 or with 1.
    • CHARSET - impacts which alphabet is considered the native character set. This directive is ignored in some environments.
    • NATIVE - impacts which alphabet is considered the native character set.
    • SYMBSTART - determines whether valid numeric literals used in the SYMBOLIC CHARACTERS clause can begin with 0 or with 1.

Syntax Rules

  1. OSVS VSC2 MF The clauses in the Special-Names paragraph may appear in any order.
  2. ISO2002 At the outer level of a source unit that defines a class, the CURSOR and CRT STATUS clauses must not be specified.
  3. ISO2002 In the factory or object of a class definition, the only clauses that can be specified are the CURSOR and CRT STATUS clauses.
  4. ISO2002 If the Special-Names paragraph is specified in an interface definition, the ALPHABET, CURRENCY and DECIMAL-POINT clauses are the only permitted clauses.
  5. Mnemonic-names can be any COBOL user-defined word. At least one constituent character must be alphabetic.
  6. Function-name refers to a system device or function used by your COBOL system.

    OSVS VSC2 MF Function-name refers to an external switch if its name is one of UPSI-0 through UPSI-7.

  7. If function-name references an external switch

    MF XOPEN or the SWITCH-n is used,

    the associated mnemonic-name cannot be specified anywhere

    MF XOPEN except in the SET statement

    . At least one condition-name should be associated with it.

    ANS85 No condition-name is required.

  8. If function-name does not reference an external switch, the associated mnemonic-name can be specified only in the ACCEPT, DISPLAY, SEND or WRITE statements. A condition-name cannot be associated with such an implementor-name.
  9. The literals specified in the literal phrase of the alphabet-name-1 clause:
    1. If numeric, must be unsigned integers and must have a value within the range of one (1) through the maximum number of characters in the native character set.

      The lowest valid values for numeric literals in the ALPHABET clause are sensitive to the ALPHASTART Compiler directive.

    2. If nonnumeric and associated with a THROUGH or ALSO phrase, must each be one character in length.
    3. VSC2 MF Cannot be specified as floating-point literals or DBCS literals.
  10. If the literal phrase of the alphabet-name-1 clause is specified, a given character must not be specified more than once in an alphabet-name clause.
  11. The words THRU and THROUGH are equivalent.
  12. MF The words STANDARD-1 and ASCII are equivalent.
  13. ANS85 The reserved word IS is never required in the Special-Names paragraph.
  14. ANS85 The literals specified in the literal-4 phrase:
    1. If numeric, must be unsigned integers and must have a value within the range of one (1) through the maximum number of characters in the native character set.
    2. If nonnumeric and associated with a THROUGH phrase, must each be one character in length.
    3. VSC2 MF Cannot be specified as floating-point or DBCS literals.
  15. ANS85 literal-1, ... literal-5 must not specify a symbolic-character figurative constant.
  16. ANS85 The same symbolic-character-1 must appear only once in a SYMBOLIC CHARACTERS clause.
  17. ANS85 The relationship between each symbolic-character-1 and the corresponding integer-1 is by position in the SYMBOLIC CHARACTERS clause. The first symbolic-character-1 is paired with the first integer-1, the second symbolic- character-1 is paired with the second integer-1; and so on throughout the SYMBOLIC CHARACTERS clause; the division into IS or ARE phrases is documentary only.

    The lowest valid value for integer-1 is sensitive to the SYMBSTART Compiler directive.

  18. ANS85 There must be a one-to-one correspondence between occurrences of symbolic-character-1 and occurrences of integer-1, both within each IS or ARE phrase and within the entire SYMBOLIC CHARACTERS clause.
  19. ANS85 The ordinal position specified by integer-1 must exist in the native character set. If the IN phrase is specified, the ordinal position must exist in the character set named by alphabet-name-2; alphabet-name-2 must be described in an ALPHABET clause.
  20. literal-6 must be an alpnanumeric literal

    MF COB370 or national literal.

  21. literal-6 must not be a figurative constant.
  22. If the PICTURE SYMBOL phrase is not specified, literal-6 must consist of a single character that is not one of the following:
    • digits 0 through 9;
    • alphabetic characters A, B, C, D, L, P, R, S, V, X, Z, or their lower-case equivalents; or the space;
      • MF C and R can be used.
      • ANS85 L can be used.
      • OSVS VSC2 MF E cannot be used.
      • MF COB370 N cannot be used.
      • VSC2 MF G cannot be used.
      • ANS85 no lower-case alphabetic characters can be used.
      • MF lower-case alphabetic characters can be used except for those explicitly prohibited by this rule.
    • characters '+' '-' ',' '.' '*' '/' ';' '(' ')' '"' '='.
  23. ISO2002 MF OS390 If the PICTURE SYMBOL phrase is specified, literal-6 may have any length and:
    1. must contain at least one nonspace character and
    2. may consist of any characters from the computer's coded character set except for the digits 0 through 9 and the characters '+' '-' ',' '.' '*'.
  24. ISO2002 MF OS390 Literal-7 must be an alphanumeric literal consisting of a single character. It must not be a figurative constant. No two occurrences of literal-7 may be the same value.
  25. ISO2002 MF OS390 Literal-7 may be any character from the computer's coded character set except for the following:
    • digits 0 through 9;
    • alphabetic characters A, B, C, D, E, N, P, R, S, V, X, Z, or their lower-case equivalents; or the space;
      • MF C and R can be used.
      • MF G cannot be used.
    • characters '+' '-' ',' '.' '*' '/' ';' '(' ')' '"' '='.
  26. If literal-6 is of class alphanumeric, the associated currency symbol may be used only to define a numeric-edited item with usage display.

    ISO2002 MF OS390 If literal-6 is of class national, the associated currency symbol may be used only to define a numeric-edited item with usage national.

  27. MF Integer-2 must be an unsigned integer in the range 0 to 65535.
  28. MF XOPEN Data-name-1 of the CURSOR IS clause must be declared in the Working-Storage Section .
  29. MF XOPEN The CRT STATUS clause specifies a data item into which a status value is moved after each Format 4

    MF or Format 5

    ACCEPT statement. In some environments, it can be defined only in the first 64K of working storage.

  30. MF XOPEN Data-name-2 must be described in the Working-Storage Section and must be three bytes long.
  31. MF XOPEN The CURSOR IS clause specifies the data item to contain the cursor address as used by the ACCEPT statement.

General Rules

  1. External switches are set at run time by the operator, and the setting can be determined by testing the associated condition-names.
  2. If mnemonic-name is associated with an external switch, the status of that switch can be altered by execution of a Format 1 SET statement (see the topic The SET Statement).
  3. The alphabet-name-1 clause provides a means for relating a name to a specified character code set and/or collating sequence. When alphabet-name-1 is referenced in the PROGRAM COLLATING SEQUENCE clause (see the topic The Object-Computer Paragraph) or the COLLATING SEQUENCE phrase of a SORT or MERGE statement (see the topic The SORT Statement or The MERGE Statement), the alphabet-name-1 clause specifies a collating sequence. When alphabet-name-1 is referenced in a CODE-SET clause in a file description entry (see the topic File Description Entry Skeleton), the alphabet-name clause specifies a character code set.
    1. If the STANDARD-1

      MF or ASCII

      phrase is specified, the character code set or collating sequence identified is the American Standard Code for Information Interchange, as defined in American National Standard X3.4-1968.

      ANS85 If the STANDARD-2 phrase is specified, the character code set identified is the International Reference Version of the ISO 7-bit code, as defined in International Standard 646, 7-bit Coded Character Set for Information Processing Interchange.

      VSC2 MF XOPEN If the EBCDIC phrase is specified, the character code set or collating sequence identified is EBCDIC.

      If the NATIVE phrase is specified, the native character code set or native collating sequence is used. The native collating sequence is either ASCII or EBCDIC, as specified by the NATIVE Compiler directive.)

      See the appendix Character Sets and Collating Sequences for details of the ASCII code set and the ASCII and EBCDIC collating sequences and their correspondence.

    2. If the literal phrase is specified, alphabet-name-1 cannot be referenced in a CODE-SET clause (see the topic The CODE-SET Clause). The character code set and/or collating sequence identified is that defined according to the following rules:
      1. The value of each literal specifies:
        1. The ordinal number of a character within the native character set, if the literal is numeric. This value must not exceed the value which represents the number of characters in the native character set.
        2. The actual character within the native character set, if the literal is nonnumeric. If the value of the nonnumeric literal contains multiple characters, each character in the literal, starting with the leftmost character, is assigned successive ascending positions in the collating sequence being specified.
      2. The order in which the literals appear in the ALPHABET clause specifies, in ascending sequence, the ordinal number of the character within the collating sequence being specified.
      3. Any characters within the native collating sequence which are not explicitly specified in the literal phrase, assume a position, in the collating sequence being specified, greater than any of the explicitly specified characters. The relative order within the set of these unspecified characters is unchanged from the native collating sequence.
      4. If a character code set is being specified, for each character within the native character set that is not specified by the literal-1 phrase, the implementor defines the ordinal number within the character code set being specified.
      5. If the THROUGH phrase is specified, the set of contiguous characters in the native character set, beginning with the character specified by the value of literal-1, and ending with the character specified by the value of literal-2, is assigned a successive ascending position in the collating sequence being specified. In addition, the set of contiguous characters specified by a given THROUGH phrase can specify characters of the native character set in either ascending or descending sequence.
      6. If the ALSO phrase is specified, the characters of the native character set specified by the value of literal-1, and literal-3 are assigned to the same position in the collating sequence being specified

        ANS85 , or in the character code set that is used to represent the data

  4. The character that has the highest ordinal position in the program collating sequence is associated with the figurative constant HIGH-VALUE

    ANS85 except when this figurative constant is specified as a literal in the Special-Names paragraph

    .

    If more than one character has the highest position in the program collating sequence, the last character specified is associated with the figurative constant HIGH-VALUE.

  5. The character that has the lowest ordinal position in the program collating sequence is associated with the figurative constant LOW-VALUE

    ANS85 except when this figurative constant is specified as a literal in the Special-Names paragraph

    .

    If more than one character has the lowest position in the program collating sequence, the first character specified is associated with the figurative constant LOW-VALUE.

  6. OSVS VSC2 MF Floating-point literals cannot be used in a user-specified collating sequence.
  7. ANS85 When specified as literals in the Special-Names paragraph, the figurative constants HIGH-VALUE and LOW-VALUE are associated with those characters having the highest and lowest positions, respectively, in the native collating sequence.
  8. ANS85 The SYMBOLIC CHARACTERS clause is used to define user-defined words that can be used like figurative constants. If the IN phrase is not specified, symbolic-character-1 represents the character whose ordinal position in the native character set is specified by integer-1. If the IN phrase is specified, integer-1 specifies the ordinal position of the character that is represented in the character set named by alphabet-name-2.
  9. ANS85 The internal representation of symbolic-character-1 is the internal representation of the character that is represented in the native character set.
  10. The CURRENCY SIGN clause is used to specify a currency string that is placed into numeric-edited data items when they are used as receiving items and de-edited from the data item when it is used as a sending item that has a numeric or numeric-edited receiving item. In addition, it is used to determine which symbol is used in a character-string of a basic format PICTURE clause to specify the presence of this currency string. This symbol is referred to as the currency symbol.

    Literal-6 represents the value of the currency string.

    ISO2002 MF OS390 If the CURRENCY SIGN clause is specified with the PICTURE SYMBOL phrase, literal-7 is used as the currency symbol.

    If the CURRENCY SIGN clause is specified without the PICTURE SYMBOL phrase, literal-6 is used as the currency symbol.

    If the currency symbol is a lower-case letter, it is treated as its upper-case equivalent.

    If this clause is not present, only the currency sign defined in the COBOL character set is used in the PICTURE clause. See the section Character Set in the chapter Concepts of the COBOL Language.

  11. The DECIMAL-POINT IS COMMA clause means that the function of comma and period are exchanged in the character-string of the PICTURE clause and in numeric literals.
  12. MF If the NUMERIC SIGN clause is specified, the default for signed numeric items is for the sign to be stored as a trailing separate character.
  13. OSVS VSC2 MF Wherever a mnemonic-name is allowed, you can use a function-name.
  14. If function-name does not reference an external switch, it can be selected from the following list:
    TAB | Skip to vertical tabulation position (inserts ASCII X"0B" in the output record as appropriate) | WRITE ADVANCING statement
    PRINTER | Printer | DISPLAY statement
    FORMFEED | Skip to new page (inserts ASCII X"0C" in the output record as appropriate) | WRITE ADVANCING statement
    COMMAND-LINE | Command transfer | ACCEPT and DISPLAY statements
    ARGUMENT-NUMBER | Command-line argument number | ACCEPT and DISPLAY statements
    ARGUMENT-VALUE | Command-line argument value | ACCEPT statement
    ENVIRONMENT-NAME | Environment variable name | DISPLAY statement
    ENVIRONMENT-VALUE | Environment variable value | ACCEPT and DISPLAY statements
    SYSERR | Standard error device | DISPLAY statement

    OSVS VSC2 The following table reflects the support for function names offered by OS/VS COBOL, VS COBOL II and SAA in this COBOL system.

    Table 1. FunctionNames Support
    OSVS | VSC2 Rel (2) | COBOL/370 or VSC2 Rel (3)/(4) | SAA L1
    SYSIN | y | y | y | y
    SYSIPT | U | U | y
    SYSOUT | y | y | y | y
    SYSLIST | y
    SYSLST | U | U | y
    SYSPCH | U | U | y
    SYSPUNCH | U | y | y
    CONSOLE | y | y | y | y
    C01 | y | y | y | y
    C02 | y | y | y
    C03 | y | y | y
    C04 | y | y | y
    C05 | y | y | y
    C06 | y | y | y
    C07 | y | y | y
    C08 | y | y | y
    C09 | y | y | y
    C10 | y | y | y
    C11 | y | y | y
    C12 | y | y | y
    S01 | y | y | y
    S02 | y | y | y
    S03 | U | y
    S04 | U | y
    S05 | U | y
    CSP | y | y | y | y
    1 char rw literal | y
    AFP-5A | y
    Key:
    y
    Documented and accepted by mainframe compilers and the COBOL system.
    U
    Undocumented but accepted by mainframe compiler.
  15. ANS85 The CLASS clause provides a means for relating a name to the specified set of characters listed in that clause. Class-name-1 can be referenced only in a class condition. The characters specified by the values of the literals in this clause define the exclusive set of characters which constitute class-name-1. The value of each literal specifies:
    1. The ordinal number of a character within the native character set, if the literal is numeric. This value must not exceed the value which represents the number of characters in the native character set.
    2. The actual character within the native character set, if the literal is nonnumeric. If the value of the nonnumeric literal contains multiple characters, each character in the literal is included in the set of characters identified by class-name-1.

    If the THROUGH phrase is specified, the contiguous characters in the native character set beginning with the character specified by the value of literal-4, and ending with the character specified by the value of literal-5, are included in the set of characters identified by class-name-1. Additionally, the contiguous characters specified by a given THROUGH phrase can specify characters of the native character set in ascending or descending sequence.

  16. All clauses specified in the Special-Names paragraph for a source element also apply to source elements contained within that source element. The condition-names, mnemonic-names, class-names, currency symbols, alphabet-names and symbolic-characters specified in the containing source element's Special-Names paragraph can be referenced from any contained source element.
  17. MF The CALL-CONVENTION clause allows you to select one of several pre-defined parameter-passing conventions which allow you to CALL subprograms written in languages other than COBOL, and which use different parameter passing conventions.
  18. MF The CONSOLE IS CRT clause causes any ACCEPT or DISPLAY statement whose operand is not a screen-name, and that has no phrases specific to a particular format, to be treated as Format 5. If the CONSOLE IS CRT clause is not present, these statements are treated as the standard ANSI ACCEPT or DISPLAY.
  19. MF XOPEN The CURSOR IS clause specifies the data item to contain the cursor address used by the ACCEPT statement.
    1. At the start of an ACCEPT statement, if data-name-1 contains a value that is a valid character position on the screen, that position is used as the initial position for the cursor. Otherwise, data-name-1 is ignored, and the initial position for the cursor is the start of the first input field on the screen. At the end of an ACCEPT statement, if the position in data-name-1 has been used in that statement, data-name-1 is updated to show the position of the cursor at the termination of the ACCEPT statement.
    2. CURSOR IS has no effect on the positioning of fields on the screen.
    3. Data-name-1 must be 4 or 6 characters in length. If data-name-1 is 4 characters in length, the first two characters are interpreted as line number, and the second two as column number. If data-name-1 is 6 characters in length, the first three characters are interpreted as line number, and the second three as column number.
    4. The clause has no effect if data-name-1 contains an illegal position (for example, zeros, a nonnumeric value, or a value that is beyond the bottom of the screen).
    5. If data-name-1 contains a valid position that does not correspond to an input field being accepted by the current ACCEPT statement, the cursor is positioned to the next such field or, if there is none, to the first such field. The ordering of the fields is the order in which their descriptions appear in the Data Division.
  20. MF XOPEN The CRT STATUS clause specifies a 3-byte data item, into which a status value is moved after each Format 4 or Format 5 ACCEPT statement.

    If the CRT STATUS clause is specified in the Special-Names paragraph, every Format 4 or 5 ACCEPT statement (as described later in this chapter) places a value into data-name-2 to indicate the outcome of the ACCEPT operation. Data-name-2 consists of status keys which are set to indicate possible conditions resulting from the completion of the operation. They are described below.

CRT status key CRT Status Keys

CRT Status Key 1: The first byte of data-name-1 is CRT Status Key 1. It should be described as PICTURE 9 USAGE DISPLAY. It indicates the condition that caused the termination of the ACCEPT operation. The possible values are:

"0" | indicates a terminator key or auto-skip out of the final field
"1" | indicates a user-defined function key
"2" | indicates a COBOL system-defined function key
"9" | indicates an error

A terminator key is a key whose purpose is terminating ACCEPT operations (for example, Enter). A particular configuration option causes the field-tab key, when used in the final field of an ACCEPT, to act as a terminator key. Defining function keys is also a configuration option.

A termination that returns a value of "0" is called a normal termination.

If the ACCEPT statement contains an ON EXCEPTION phrase, any value in CRT Status Key 1, except " 0", causes the execution of the imperative statement in that phrase.

CRT Status Key 2: The second byte of data-name-1 is CRT Status Key 2 and contains a code giving further details of the condition that terminated the ACCEPT operation. Its format and possible values depend on the value in CRT Status Key 1, as shown in the following table.

Table 2. Valid Combinationsof CRT Status Keys 1 and 2
Key 1 | Key 2 | Meaning
0 | Format: PIC 9 DISPLAY Value: 0 | The operator pressed a terminator key
0 | Format: PIC 9 DISPLAY Value: 1 | Auto-skip out of the last field
1 | Format: PIC 99 COMP Values: 0-127 | The function key number
2 | Format: PIC 99 COMP Values: 0-26 | The function key number
9 | Format: PIC 99 COMP Value: 0 | No items fall within the screen

See your COBOL system documentation on screen handling and user interfaces for an explanation of function key numbers.

CRT Status Key 3: The third byte of data-name-1 is CRT Status Key 3 and should be described as PICTURE 99 COMP-X or as PICTURE 99 COMP (with the NOIBMCOMP directive specified). If CRT Status Key 1 and CRT Status Key 2 are zero, then CRT Status Key 3 contains the raw keyboard code for the key that terminated the ACCEPT operation. Otherwise, the contents of CRT Status Key 3 are undefined.

Where a sequence of keystrokes rather than a single key has been configured to perform a single function, only the code for the first keystroke is returned.

Examples:

  1. An example of using the CRT status key fields is provided in the topic CRT STATUS Clause of the Special-Names Paragraph.
Related concepts
Character Set


The Repository Paragraph

The Repository paragraph allows specification of program-prototypes-names, function-prototype-names, class-names, delegate-names, enum-names, interface-names and property-names that may be used within the scope of this Environment Division. It also allows declaration of intrinsic-function-names that may be used without specifying the word FUNCTION.

General Format

Directives

  1. In addition to the Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • RDFPATH - specifies the location of the library for the repository files.
    • ACTUAL-PARAMS - specifies the parameters to be used in the creation of a class or interface from a parameterized class or interface

Syntax Rules

  1. If any class-name-1, delegate-name-1, enum-name-1, interface-name-2, function-prototype-name-2, intrinsic-function-name-1, property-name-1 or program-prototype-name-1 is specified more than once in the Repository paragraph, all the specifications for that name must be identical.
  2. Literal-1, literal-2, literal-3, literal-4, literal-5, literal-6 and literal-7 must be nonnumeric literals and must not be figurative constants.
  3. If the CLASS clause is specified, class-name-2, class-name-3, and interface-name-1 must be:
    1. Parameters of a containing class definition or interface definition; or
    2. Defined in the same Repository paragraph where class-name-1 is defined.
  4. If class-name-1 is specified in the USING phrase of the Class-ID paragraph of a class definition containing this Repository paragraph or in the USING phrase of the Interface-ID paragraph of an interface definition containing this Repository paragraph, the EXPANDS phrase must not be specified.
  5. If the INTERFACE clause is specified, class-name-4, interface-name-3 and interface-name-4 must be:
    1. Parameters of a containing class definition or interface definition; or
    2. Defined in the same repository paragraph where interface-name-2 is defined.
  6. If interface-name-2 is specified in the USING phrase of the Class-ID paragraph of a class definition containing this Repository paragraph or in the USING phrase of the Interface-ID paragraph of an interface definition containing this Repository paragraph, the EXPANDS phrase must not be specified.
  7. Either program-prototype-name-1 must be the name of a program prototype or a program definition specified previously in this compilation group or:
    1. If literal-3 is not specified, there must be information in the external repository for the program program-prototype-name-1,
    2. If literal-3 is specified, there must be information in the external repository for the program literal-3.
  8. Either function-prototype-name-1 must be the name of a function prototype or a function definition specified previously in this compilation group or:
    1. If literal-5 is not specified, there must be information in the external repository for the function function-prototype-name-1,
    2. If literal-5 is specified, there must be information in the external repository for the function literal-5.
  9. Intrinsic-function-name-1 must not be specified as a user-defined word within the scope of this Repository paragraph.
  10. If ALL is specified in the intrinsic format of the function-specifier, none of the names of the intrinsic functions can be specified as a user-defined word within the scope of the Repository paragraph.
  11. If the specified class-name-1 is the name of the class definition in which this Repository paragraph is specified, references to class-name-1 are to that class definition and this class-specifier is ignored.
  12. If the specified interface-name-2 is the name of the interface definition in which this Repository paragraph is specified, references to interface-name-2 are to that interface definition and this interface-specifier is ignored.
  13. If the specified program-prototype-name-1 is the name of the program definition in which this Repository paragraph is specified or the name of a containing program, references to program-prototype-name-1 are to the named program definition and this program-specifier is ignored.
  14. If the specified function-prototype-name-1 is the name of the function definition in which this Repository paragraph is specified, references to function-prototype-name-1 are to that function definition and this function-specifier is ignored.
  15. NET If the specified delegate-name-1 is the name of the delegate definition in which this Repository paragraph is specified, references to delegate-name-1 are to that delegate definition and this delegate-specifier is ignored.
  16. NET JVM If the specified enum-name-1 is the name of the enumeration definition in which this Repository paragraph is specified, references to enum-name-1 are to that enumeration definition and this enum-specifier is ignored.
  17. If the CLASS clause is specified:
    1. If literal-1 is specified, there must be information in the external repository for the class literal-1.
    2. If literal-1 is not specified, there must be information in the external repository for the class class-name-1.
  18. If the INTERFACE clause is specified:
    1. If literal-2 is specified, there must be information in the external repository for the interface literal-2.
    2. If literal-2 is not specified, there must be information in the external repository for the interface interface-name-2.
  19. If the PROPERTY clause is specified:
    1. If literal-4 is specified, there must be information in the external repository for the property literal-4 that is part of one of the classes or interfaces that are declared in this Repository paragraph.
    2. If literal-4 is not specified, there must be information in the external repository for the property property-name-1 that is part of one of the classes or interfaces that are declared in this Repository paragraph.
  20. NET If the DELEGATE clause is specified:
    1. If literal-6 is specified, there must be information in the external repository for the delegate definition literal-6.
    2. If literal-6 is not specified, there must be information in the external repository for the delegate definition literal-6.
  21. NET JVM If the ENUM clause is specified:
    1. If literal-7 is specified, there must be information in the external repository for the enumeration definition literal-7.
    2. If literal-7 is not specified, there must be information in the external repository for the enumeration definition literal-7.

General Rules

  1. Class-name-1 is the name of a class that may be used throughout the scope of the containing Environment Division.
  2. If the AS phrase is specified, literal-1, literal-2, literal-3, literal-5 or literal-6 is the name by which the class, interface, program, function or delegate respectively, is known to the operating environment. Literal-4 is the name known to the operating environment for a method that implements the named property. The AS phrase is required when the name of a class, interface, property, function or delegate does not follow the rules for formation of a user-defined word or when the name is case specific.
  3. Class-name-3 and interface-name-1 are actual parameters for the parameterized class referenced by class-name-2.
  4. Class-name-4 and interface-name-4 are actual parameters for the parameterized interface referenced by interface-name-3.
  5. If the EXPANDS phrase is specified in a class-specifier, a class class-name-1 is created from the parameterized class class-name-2. The number of parameters in the USING phrase of the EXPANDS phrase of the class-specifier must be the same as the number of parameters in the USING phrase of the CLASS-ID paragraph of class-name-2. The interface for class-name-1 is the interface specified for class-name-2 with the parameters of class-name-2 replaced by the parameters specified in the class-specifier.

    The class class-name-1 is created from the parameterized class class-name-2 by replacing each specification of the formal parameter by the corresponding actual parameter. This replacement is done after the processing of COPY and REPLACE statements.

  6. The compiler uses the information specified for class-name-1 together with the external repository to determine the details of the class that is to be used. The repository information for the class must be in a file whose name is the externalized name of the class with the extension rdf. If the RDFPATH directive is specified, the file must be in the specified directory; otherwise, the file must be in the local directory where the .idy files will be created.
  7. Interface-name-2 is the name of an interface that may be used throughout the scope of the containing Environment Division.
  8. If the EXPANDS phrase is specified in an interface-specifier, an interface interface-name-2 is created from the parameterized interface interface-name-3. The number of parameters in the USING phrase of the EXPANDS phrase of the interface-specifier must be the same as the number of parameters in the USING phrase of the INTERFACE-ID paragraph of interface-name-3. The interface for interface-name-2 is the interface specified for interface-name-3 with the parameters of interface-name-3 replaced by the parameters specified in the interface-specifier.

    The interface interface-name-2 is created from the parameterized interface interface-name-3 by replacing each specification of the formal parameter by the corresponding actual parameter. This replacement is done after the processing of COPY and REPLACE statements.

  9. The compiler uses the information specified for interface-name-2 together with the external repository to determine the details of the interface that is to be used. The repository information for the interface must be in a file whose name is the externalized name of the interface with the extension rdf. If the RDFPATH directive is specified, the file must be in the specified directory; otherwise, the file must be in the local directory where the .idy files will be created.
  10. Property-name-1 is the name of an object property that may be used throughout the scope of the containing Environment Division.
  11. Program-prototype-name-1 is the name of a program prototype that may be used throughout the scope of the containing Environment Division.
  12. NET Delegate-name-1 is the name of a delegate definition that may be used throughout the scope of the containing Environment Division.
  13. NET JVM Enum-name-1 is the name of an enumeration definition that may be used throughout the scope of the containing Environment Division.
  14. If a prototype definition or a program definition for program-prototype-name-1 is specified previously in this compilation group, that definition is used to determine the details for activating the program identified by program-prototoype-name-1. Otherwise, the external repository is used to determine the details for activating the program with the externalized name program-prototype-name-1 and that program is activated when program-prototype-name-1 is referenced.
  15. Function-prototype-name-1 is the name of a function prototype that may be used throughout the scope of the containing Environment Division.
  16. If a prototype definition or a function definition for function-prototype-name-1 is specified previously in this compilation group, that definition is used to determine the details for activating the function identified by function-prototoype-name-1. Otherwise, the external repository is used to determine the details for activating the function with the externalized name function-prototype-name-1 and that function is activated when function-prototype-name-1 is referenced.
  17. Intrinsic-function-name-1 may be specified in a function-identifier without being preceded by the word FUNCTION.
  18. If ALL is specified in the intrinsic format of the function-specifier, it is as if each of the intrinsic-function-names defined in the topic Intrinsic Functions were specified.
Related information
Intrinsic Functions


The Constraints Paragraph

The Constraints paragraph allows specification of properties of parameters of a parameterized class, and therefore allows the use of methods or properties on data items whose type is specified as that parameter.

General Format

Syntax Rules

  1. Parameter-name-1 must be a parameter of the class in which this Constraints paragraph is specified.

General Rules

  1. If the IMPLEMENTS phrase is specified, parameter-name-1 must be of a class that implements the interface interface-name-1.
  2. If the INHERITS phrase is specified, parameter-name-1 must inherit directly or indirectly from class-name-1.
  3. If the NEWABLE phrase is specified, the class of parameter-name-1 must include a constructor with no parameters.
  4. If VALUE TYPE or VALUETYPE is specified, the type of parameter-name-1 must be a value type. If REFERENCE TYPE is specified, the type of parameter-name-1 must be a reference type.
  5. Items whose type is specified as parameter-name-1 may be specified where an item of class class-name-1 or interface-name-1 is required.
  6. Items whose type is specified as parameter-name-1 have all the methods and properties of a class-name-1 and interface-name-1


The Class-Attributes Paragraph

The Class-Attributes paragraph allows specification of attributes on a class, delegate, enum, interface or valuetype.

General Format

    CLASS-ATTRIBUTES. [ Attribute-Clause ] ... .

Syntax Rules

  1. The Attribute-Clause is described in the topic The Custom-Attribute Clause.

General Rules

  1. The attribute specified becomes part of the metadata describing the source element in which this clause appears and is visible to a reflector.
Related information
The CUSTOM-ATTRIBUTE Clause


The Assembly-Attributes Paragraph

The Assembly-Attributes paragraph allows specification of custom-attributes for the entire compilation unit.

General Format

    ASSEMBLY-ATTRIBUTES. [ Attribute-Clause ] ... .

Syntax Rules

  1. The Attribute-Clause is described in the topic The CUSTOM-ATTRIBUTE Clause.

General Rules

  1. The attribute specified becomes part of the metadata describing the compilation unit in which this clause appears and is visible to a reflector.
Related information
The CUSTOM-ATTRIBUTE Clause


Input-Output Section

The Input-Output Section deals with the information needed to control transmission and handling of data between external media and a runtime element.

General Format

   INPUT-OUTPUT SECTION.[ file-control-paragraph ][ i-o-control-paragraph ]

Syntax Rules

  1. ISO2002 The Input-Output Section can be specified in a program definition or a function definition. Within a class definition, the Input-Output Section can be specified only in a factory definition or an object definition, but not in a method definition. The Input-Output Section must not be specified within an interface definition.
Parent topic: Environment Division


The File-Control Paragraph

The File-Control paragraph names each file and allows specification of other file-related information.

General Format


The File Control Entry

The file control entry names a file and can specify other file-related information.

XOPEN Although they are a part of the standard COBOL definition, the RECORD DELIMITER and RESERVE phrases and ellipses in the ASSIGN clause are explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

General Formats for Format 1 (Record Sequential Files)

General Formats for Format 2 (Line Sequential Files)

General Formats for Format 3 (Relative Files)

General Formats for Format 4 (Indexed Files)

General Formats for Format 5 (Sort-Merge Files)

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • ASSIGN - determines how the literal, data-name, or external-file-reference is evaluated.
    • SEQUENTIAL - determines whether files defined as ORGANIZATION IS SEQUENTIAL are considered LINE SEQUENTIAL or RECORD SEQUENTIAL.

Syntax Rules for All Formats (All Files)

  1. The SELECT clause must be specified first in the file control entry. The clauses which follow the SELECT clause can appear in any order.
  2. Each file described in the Data Division must be named once, and only once, as file-name in the File-Control paragraph. Each file specified in the file control entry must have a file description entry in the Data Division of the same factory, method, object, function or program.
  3. If the ACCESS MODE clause is not specified, the ACCESS MODE IS SEQUENTIAL clause is implied.
  4. MF Data-name-1 can be declared in the Data Division as an alphanumeric or group data item long enough to hold the external name of the file. If it is not explicitly declared within the source element, your COBOL system declares it implicitly as an alphanumeric data item long enough to hold the maximum permissible size of file-name. If data-name-1 occurs in the FROM phrase, the data item must be explicitly declared in the Data Division.
  5. MF The NOT OPTIONAL phrase has effect only when the file is opened input-output.
  6. MF External-file-reference, data-name-1, or literal-1 specifies the external name of the file. If the EXTERNAL or DYNAMIC option is used, literal-1 must not be specified. If the DYNAMIC option is used, the word specified for the external file-name is interpreted as external-file-reference.
  7. Data-name-2 must be defined in the Data Division as a two-character, alphanumeric data item

    OSVS VSC2 MF or a two-character numeric data item with USAGE DISPLAY

    and must not be defined in the File Section

    MF or Local-Storage Section

    of the Data Division.

  8. VSC2 Data-name-3 must be defined as a group item of 6 bytes in the Working-Storage or Linkage Section of the Data Division.
  9. OSVS VSC2 Data-name-4 must be defined in the Working-Storage Section as an alphanumeric data item.
  10. All data-names can be qualified.

Syntax Rules for Format 1 (Record Sequential Files only)

  11. ANS85 Literal-2 must be a one-character nonnumeric literal.
  12. ANS85 Data-name-5 can be qualified. It must be defined in the Data Division as a one-character data item of category alphanumeric. It cannot be defined in the File or Report Sections of the Data Division.
  13. ANS85 Character-string must not be a reserved word, a user-defined word that is defined elsewhere, or a literal.

Syntax Rules for Formats 1 and 2 (Record and Line SequentialFiles)

  14. When the ORGANIZATION clause is not specified, sequential organization is assumed.
  15. MF KEYBOARD means console input.
  16. MF DISPLAY means console output.
  17. MF PRINTER specifies the system's main printer.
  18. MF PRINTER-1 specifies the system's second printer.

Syntax Rules for Format 3 (Relative Files)

  19. If a relative file is to be referenced by a START statement, the RELATIVE KEY phrase must be specified for that file.
  20. Data-name-5 must not be defined in a record description entry associated with that file-name.
  21. The data item referenced by data-name-5 must be defined as an unsigned integer.

Syntax Rules for Format 4 (Indexed Files)

  22. ISO2002 MF Split-key-name is a concatenation of one or more data items within a record associated with that file-name. It can be referenced only in START and READ statements.
  23. The data items referenced by data-name-5 and data-name-8

    MF and any data-names referenced by split-key-name-1 and split-key-name-2

    must be defined within a record description entry associated with the file-name.

    OSVS VSC2 MF Any of these data items can be defined as any supported data category. However, the key is still treated as an alphanumeric item for the input and output statements against the file named in the SELECT clause.

  24. Data-name-5 and data-name-8

    MF and any data-names referenced by split-key-name-1 and split-key-name-2

    cannot describe an item whose size is variable. See the topic The OCCURS Clause.

  25. Data-name-8 cannot reference an item whose leftmost character position corresponds to the leftmost character position of the item referenced by data-name-5 or by another data-name-8 specified for the same file.
  26. If the indexed file contains variable-length records, data-name-5 and data-name-8

    and any data-names referenced by split-key-name-1 and split-key-name-2

    shallbe contained within the first x bytes of the record, where x equals theminimum record size specified for the file. See the topic The RECORD Clause.
  27. OSVS VSC2 If the PASSWORD clause is specified, it must immediately follow its associated RECORD KEY or ALTERNATE RECORD KEY clause.

Syntax Rules for Format 5 (Sort-Merge Files)

  28. Each sort or merge file described in the Data Division must be named once and once only as file-name in the File-Control paragraph. Each sort or merge file specified in the file control entry must have a sort-merge file description entry in the Data Division.
  29. Since file-name represents a sort or merge file, only the ASSIGN clause is permitted to follow file-name in the File-Control paragraph.

General Rules for All Formats (All Files)

  1. The ASSIGN clause specifies the association of the file referenced by file-name-1 to a storage medium. The first assignment takes effect.

    OSVS VSC2 MF Subsequent assignments within any one ASSIGN clause are documentary only.

  2. The RESERVE clause allows you to specify the required number of input-output areas.

    ANS85 The RESERVE clause is documentary only, unless the COBOL system documentation specific to your operating system indicates otherwise.

  3. The ORGANIZATION clause specifies the logical structure of a file. The file organization is established at the time a file is created and cannot subsequently be changed.
  4. When the FILE STATUS clause is specified, a value is moved by the run-time system into the data item specified by data-name-2 after the execution of every statement that references that file either explicitly or implicitly. This value indicates the status of execution of the statement. (See the topic I-O Status in the chapter Procedure Division.)

    MF Data-name-3, if specified, is documentary only.

  5. MF The PASSWORD clause is documentary only.
  6. MF Use of the reserved word DYNAMIC in an ASSIGN clause indicates that the value of literal-1 or data-name-1 in that ASSIGN clause is the specified file's name in the external file-storage environment.
  7. MF Use of the reserved word EXTERNAL in an ASSIGN clause indicates that external-file-reference identifies the specified file to the external environment for possible further mapping to an external file-storage environment-name. (See your COBOL system documentation on file handling for details on setting up external-file-name for your particular operating environment.)

    If external-file-reference contains the character "-", then only that part of the name following the last "-" is used to identify the file to the external environment.

  8. MF The DISK option without external-file-reference, data-name-1 or literal-1 and without the FROM option, specifies a disk file whose name is given in a VALUE OF FILE-ID clause in the file description for the file. If that file description contains no VALUE OF FILE-ID clause, the name of the disk file is assumed to be the same as file-name-1 (known as the internal file-name).
  9. MF If any of the keywords DISK, KEYBOARD, DISPLAY, PRINTER or PRINTER-1 are followed by external-file-reference, data-name-1 or literal-1, that keyword is ignored.
  10. MF The DISK option with the FROM option specifies a disk file whose name on the disk is the value of data-name-1. However, if when an OPEN statement is executed for that file, data-name-1 contains all spaces, the name of the disk file is assumed to be the same as file-name-1 (known as the internal-file-name).
  11. The OPTIONAL phrase applies only to files opened in the INPUT, I-O or EXTEND mode. Its specification is required for files that are not necessarily present each time the runtime element is executed.
  12. ISO2002 MF The SHARING clause specifies the sharing mode to be used for the file unless it is overridden by the SHARING phrase of the OPEN statement. This clause also specifies whether record locks have an effect. Additional details are specified in the topic Sharing Mode in the chapter Language Fundamentals.

General Rules for Formats 1, 3 and 4 (Record Sequential, Relative and Indexed files)

  13. MF The LOCK MODE clause is an optional clause in the file control entry and is used to specify the locking technique used for the file.

    If this clause is omitted, opening the file causes it to become exclusive, with the exception of OPEN INPUT.

    When LOCK MODE IS EXCLUSIVE is specified, the run unit acquires a lock on the whole file when it opens the file.

    When LOCK MODE IS AUTOMATIC or LOCK MODE IS MANUAL is specified, the file that the run unit opens is shareable. Files opened OUTPUT, and indexed and relative files opened EXTEND are, however, always exclusive.

  14. MF The ROLLBACK clause requests transaction logging for a file under those COBOL systems that support that feature. See your COBOL system documentation on file handling for details of how it is implemented in your system.

    If the ROLLBACK clause is specified then WITH LOCK ON MULTIPLE RECORDS is automatically in effect.

  15. MF The WITH LOCK ON RECORD clause specifies single record locking for the file.

    The WITH LOCK ON MULTIPLE RECORDS clause specifies multiple record locking for the file. This clause must be present if multiple record locking is required.

  16. MF If LOCK MODE IS AUTOMATIC WITH LOCK ON RECORD is specified for a file, a record lock is acquired by the execution of the READ statement and is released upon execution of a subsequent I/O operation on this file, with the exception of a START statement.

    If LOCK MODE IS AUTOMATIC WITH LOCK ON MULTIPLE RECORD is specified for a file, a record lock is acquired by the execution of the READ statement and is not released until a CLOSE, COMMIT, ROLLBACK or UNLOCK statement is executed, or until an individual lock is released by a DELETE statement.

  17. MF If LOCK MODE IS MANUAL WITH LOCK ON RECORD is specified, a lock is acquired by a READ statement only if it includes the WITH LOCK phrase, and is released upon execution of a subsequent I/O operation on this file, with the exception of a START statement.

    If LOCK MODE IS MANUAL WITH LOCK ON MULTIPLE RECORDS is specified, a record lock is acquired by the READ WITH KEPT LOCK statement and is not released until a CLOSE, COMMIT, ROLLBACK or UNLOCK statement is executed.

  18. MF When the lock mode is MANUAL or AUTOMATIC, single record locking is assumed unless the WITH LOCK ON MULTIPLE RECORDS phrase is included.
  19. MF If a file is defined as EXTERNAL and the operating system file-name is assigned by means of a file-name, for example, by use of the ASSIGN directive or keyword, using data-name-1 in the SELECT/ ASSIGN statement, or using Format 2 of the VALUE OF phrase of an FD, then the following rules should be followed:
    1. An identifier with the same name should be used to contain the physical file-name in all source elements which reference the file.
    2. The definition of the identifier which contains the physical file-name should also contain the EXTERNAL attribute.

    No violation of these rules is detected at compile time, but, if any runtime element in the run unit violates these rules, the results at run time are undefined.

    For further details of the effects of record locking, see your COBOL system documentation on file handling.

General Rules for Format 1 (Record Sequential Files)

  20. The MULTIPLE REEL or MULTIPLE UNIT phrase must be specified if it is possible or intended that the file can be closed by use of the CLOSE REEL or CLOSE UNIT statement.
  21. Records in the file are accessed in the sequence specified by predecessor-successor record relationships which are established by the execution of WRITE statements when the file is created or extended.
  22. MF Using the LINE ADVANCING FILE phrase causes a file suitable for a printer to be produced. This file has an initial carriage-return character, and each record is written with AFTER ADVANCING 1 LINE as the default advancing phrase. See your COBOL system documentation on file handling for further details of the format.
  23. ANS85 MF The PADDING CHARACTER clause is documentary only.

    ANS85 If the associated file connector is an external file connector, all PADDING CHARACTER clauses in a run unit which are associated with that file connector must have the same specification. If data-name-5 is external, it must reference an external data item.

  24. ANS85 MF The RECORD DELIMITER clause is documentary only.

General Rules for Format 2 (Line SequentialFiles)

  25. MF XOPEN When LINE SEQUENTIAL ORGANIZATION is specified either implicitly or explicitly, the file is treated as consisting of fixed-length records, each containing one line of data. The records are stored with trailing spaces removed. The definition of a line of data varies among different operating systems. Some terminate line records with one or both of the carriage-return and line-feed characters, and some pad out as fixed length records. Your COBOL system, therefore, always produces files which are compatible in this respect with the editor software in any operating system.
  26. MF XOPEN The LOCK MODE IS clause is documentary only.

General Rules for Format 3 (Relative Files)

  27. When access mode is sequential, records in the file are accessed in order of ascending relative record numbers of existing records in the file.
  28. When access mode is random, the value of the RELATIVE KEY data item indicates the record to be accessed.
  29. All records stored in a relative file are uniquely identified by relative record numbers, which also specify the record's logical ordinal position in the file. The first logical record has a relative record number of 1, and subsequent logical records have relative record numbers of 2, 3, 4, ... .
  30. The data item specified by data-name-5 is used to communicate a relative record number between the run-time elementand the operating system.

General Rules for Format4 (Indexed Files)

  31. When access mode is sequential, records in the file are accessed in order of ascending record key values within a given key of reference.
  32. When access mode is random, the value of the record key data item indicates the record to be accessed.
  33. The RECORD KEY clause specifies the record key that is the prime record key for the file. The values of the prime record key must be unique among records of the file. This prime record key provides an access path to records in an indexed file.
  34. If the file has more than one record description entry, data-name-5

    ISO2002 MF and any data-names referenced by split-key-name-1

    need be describedonly in one of these record description entries. The identical character positionsreferenced by data-name-5

    ISO2002 MF and any data-names referenced by split-key-name-1

    in any one record descriptionentry are implicitly referenced as keys for all other record description entriesof that file.
  35. ANS85 If the associated file connector is an external file connector, all file description entries in the run unit which are associated with that file connector must specify the same data description entry for data-name-1 with the same relative location in the associated record.
  36. The ALTERNATE RECORD KEY clause specifies a record key that is an alternative record key for the file. This alternate record key provides an alternative access path to records in an indexed file.
  37. The data description of data-name-5

    MF or split-key-name-1

    and data-name-8

    MF or split-key-name-2,

    as well as of relative locations within a record, must be the same as that used when the file was created. The number of alternate keys for the file must also be the same as that used when the file was created. This checking is configurable in some environments. (Look up the KEYCHECK parameter in your COBOL system documentation.)

  38. The DUPLICATES phrase specifies that the value of the associated record key can be duplicated within any of the records in the file. If the DUPLICATES phrase is not specified, the value of the associated record key must not be duplicated among any of the records in the file.
  39. For duplicate values, the correct duplicate entry must be located using sequential reads from the first duplicate entry.
  40. MF The SUPPRESS phrase requests the use of a sparse key for an alternate index. Sparse keys are available only through the File Handler and are not available on all systems (see your COBOL system documentation on file handling for details).
  41. ISO2002 MF Split-key-name-1 defines a record key consisting of the concatenation of data-name-6 and all occurrences of data-name-7 in the order specified. Split-key-name-2 defines a record key consisting of the concatenation of data-name-9 and all occurrences of data-name-10 in the order specified.

General Rules for Format 5 (Sort-MergeFiles)

  42. The file-control entry names a sort or merge file and specifies the association of the file to a storage medium.
  43. MF When the SORT STATUS clause is specified, a value is placed into the two-character data item specified by data-name-2 after the execution of each sort or merge operation. This value indicates the status at completion of the operation. The following combinations of status keys are possible. Status key 1=0 and status key 2=0 indicates successful completion. Status key 1=3 and status key 2=0 indicates a permanent error. If status key 1=9, status key 2 contains an operating system error message number. For explanations of status keys 1 and 2 and definitions of status, see the topic I-O Status in the chapter Procedure Division. The FILE STATUS clause can be used instead of a SORT STATUS clause, but is treated as a synonym for it, when specified for a sort or merge file.
  44. The ASSIGN clause is documentary only.
Related information
The OCCURS Clause
The RECORD Clause
I-O Status
Sharing Mode


The I-O-Control Paragraph

The I-O-Control paragraph specifies the points at which rerun is to be established, the memory area which is to be shared by different files, and for files with sequential organization the location of files on a multiple file reel.

ANS85 The RERUN and MULTIPLE FILE TAPE clauses of the I-O-Control paragraph are classed as obsolete elements in the ANSI'85 standard and are scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects within this COBOL implementation fully support this syntax. The FLAGSTD Compiler directive can be used to detect all occurrences of this syntax.

XOPEN Although they are a part of the standard COBOL definition, the RERUN and MULTIPLE FILE TAPE clauses are explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

General Format

Syntax Rules

  1. The I-O-Control paragraph is optional.
  2. When either the integer-1 RECORDS clause or the integer-2 CLOCK-UNITS clause is specified, character-string must be given in the RERUN clause.
  3. In the SAME AREA clause, SORT and SORT-MERGE are equivalent.
  4. If the SAME SORT AREA or SAME SORT-MERGE AREA clause is used, at least one of the file-names must represent a sort or merge file. Files that do not represent sort or merge files can also be named in the clause.
  5. The two forms of the SAME clause (SAME AREA, SAME RECORD AREA) are considered separately in the following:

    More than one SAME clause can be included in a source element, subject to the following restrictions:

    1. A file-name must not appear in more than one SAME AREA clause.
    2. A file-name must not appear in more than one SAME RECORD AREA clause.
    3. If one or more file-names of a SAME AREA clause appear in a SAME RECORD AREA clause, all of the file-names in that SAME AREA clause must appear in the SAME RECORD AREA clause. However, additional file-names not appearing in that SAME AREA clause can also appear in that SAME RECORD AREA clause. The rule that only one of the files mentioned in a SAME AREA clause can be open at any one time takes precedence over the rule that all files mentioned in a SAME RECORD AREA clause can be open at any one time.
    4. A file-name that represents a sort or merge file must not appear in a SAME AREA clause.
    5. A file-name that represents a sort or merge file must not appear in more than one SAME SORT AREA or SAME SORT-MERGE AREA clause.
    6. If a file-name that does not represent a sort or merge file appears in a SAME AREA clause and one or more SAME SORT AREA or SAME SORT-MERGE AREA clauses, all of the files named in that SAME AREA clause must be named in that SAME SORT AREA or SAME SORT-MERGE AREA clause(s).
  6. The files referenced in the SAME AREA, SAME SORT AREA, SAME SORT-MERGE AREA, or SAME RECORD AREA clause need not all have the same organization or access.
  7. MF Character-string must not be a reserved word, a literal or a user-name.
  8. The END OF REEL/UNIT clause can only be used if file-name-2 is a sequential file.
  9. More than one RERUN clause can be specified for a given file-name-2, subject to the following restrictions:
    1. When multiple integer-1 RECORD clauses are specified, no two of them can specify the same file-name-2.
    2. When multiple END OF REEL or END OF UNIT clauses are specified, no two of them can specify the same file-name-2.
  10. Only one RERUN clause containing the CLOCK-UNITS clause can be specified.
  11. OSVS VSC2 Each clause in the I-O-Control paragraph may optionally be followed by a period.

General Rules

  1. ANS85 The RERUN clause is documentary only.
  2. The SAME AREA clause specifies that two or more files that do not represent sort or merge files are to use the same memory area during processing. The area being shared includes all storage areas assigned to the files specified. It is not, therefore, valid to have more than one of the files open at the same time. (See Syntax Rule 5c.)
  3. The SAME RECORD AREA clause specifies that two or more files are to use the same memory area for processing the current logical record. All of the files can be open at the same time. A logical record in the SAME RECORD AREA is considered as a logical record of each opened output file whose file-name appears in this SAME RECORD AREA clause and of the most recently read input file whose file-name appears in this SAME RECORD AREA clause. This is equivalent to an implicit redefinition of the area; that is, records are aligned on the leftmost character position.
  4. MF The APPLY clause is documentary only.
  5. MF The MULTIPLE FILE clause is documentary only.
  6. If the SAME SORT AREA or SAME SORT-MERGE AREA clause is used, at least one of the file-names must represent a sort or merge file. Files that do not represent sort or merge files can also be named in the clause. This clause specifies that storage is shared as follows:
    1. The SAME SORT AREA or SAME SORT-MERGE AREA clause specifies a memory area which is made available for use in sorting or merging each sort or merge file named. Thus any memory area allocated for the sorting or merging of a sort or merge file is available for reuse in sorting or merging any of the other sort or merge files.
    2. In addition, storage areas assigned to files that do not represent sort or merge files can be allocated as needed for sorting or merging the sort or merge files named in the SAME SORT AREA or SAME SORT-MERGE AREA clause.
    3. Files other than sort or merge files do not share a storage area. If you wish these files to share a storage area, you must also include in the source element a SAME AREA or SAME RECORD AREA clause naming these files.
    4. During the execution of a SORT or MERGE statement that refers to a sort or merge file named in this clause, any non-sort-merge files named in this clause must not be open.


Data Division

  • General Description
    The Data Division describes the data that the runtime module is to accept as input, to manipulate, to create, or to produce as output.
  • File Section
    The file description entry (FD) represents the highest level of organization in the File Section. The FILE SECTION header is followed by a file description entry consisting of a level indicator (FD), a file-name and a series of independent clauses. The clauses in the file description entry specify the size of the logical and physical records, the external name of the file, and the names of the data records which comprise the file. The entry itself is terminated by a period.
  • Working-Storage Section
    The Working-Storage Section is composed of the section header, followed by data description entries for noncontiguous data items and/or record description entries. The syntax of data description entries is defined in the topic File Description Entry Skeleton
  • Thread-Local-Storage Section
    The Thread-Local-Storage Section describes data which is unique to each thread, and is persistent across calls. The VALUE clause can be used to provide initial values for this data. The syntax of data description entries is defined in the topic File Description Entry Skeleton.
  • Object-Storage Section
    The Object-Storage Section is an optional section of the Data Division that enables you to declare class object data and instance object data.
  • Local-Storage Section
    A separate copy of the Local-Storage Section is created each time the runtime element is activated and exists only during the lifetime of that activation. The Local-Storage Section is provided specifically for use in functions, methods and recursive calls.
  • Linkage Section
    All references to PROCEDURE DIVISION USING in the following discussion also apply to ENTRY USING.
  • Screen Section
    The Screen Section provides screen handling facilities for use with ACCEPT and DISPLAY statements.
  • File and Data Description
  • Screen Section
Parent topic: Part 2. Program Definition


General Description

The Data Division describes the data that the runtime module is to accept as input, to manipulate, to create, or to produce as output.

The following is the General Format of the sections in the Data Division, and defines the order of presentation in the source element.

General Format

The Report Section is described in the section Report Writer. The other sections are described in individual subtopics within this section.

Parent topic: Data Division
Related information
Report Writer
Input-Output Section
The File-Control Paragraph
The I-O-Control Paragraph
The File Description Entry (Report Writer)
The REPORT Clause
Report Section
The Report Description Entry
PAGE-COUNTER Rules
LINE-COUNTER Rules
The CODE Clause
The CONTROL Clause
The PAGE Clause
The Report Group Description Entry
Presentation Rules Tables
The COLUMN NUMBER Clause (Report Writer)
Data-name (Report Writer)
The GROUP INDICATE Clause
Level-Number (Report Writer)
The LINE NUMBER Clause (Report Writer)
The NEXT GROUP Clause
The SIGN Clause (Report Writer)
The SOURCE Clause (Report Writer)
The SUM Clause (Report Writer)
The TYPE Clause
The USAGE Clause
The VALUE Clause (Report Writer)
General Description
The CLOSE Statement
The GENERATE Statement
The INITIATE Statement
The OPEN Statement (Report Writer)
The SUPPRESS Statement
The TERMINATE Statement
The USE BEFORE REPORTING Statement


File Section

The file description entry (FD) represents the highest level of organization in the File Section. The FILE SECTION header is followed by a file description entry consisting of a level indicator (FD), a file-name and a series of independent clauses. The clauses in the file description entry specify the size of the logical and physical records, the external name of the file, and the names of the data records which comprise the file. The entry itself is terminated by a period.

An SD file description gives information about the size and the names of the data records associated with a file to be sorted or merged. There are no label procedures which the user can control, and the rules for blocking and internal storage are peculiar to the SORT and MERGE statements.

The elements allowed in a file description entry and sort-merge file description entry are defined in the topic File Description Entry Skeleton.

Relationship with Sort-Merge

The sort-merge module provides the capability to sort elements of a table in the Data Division. The files specified in the USING and GIVING phrases of the SORT and MERGE statements must be described implicitly or explicitly in the FILE-CONTROL paragraph as having sequential organization and sequential access mode. No I/O statement can be executed for the file named in the sort-merge file description.

ANS85 The files specified in the USING and GIVING phrases of the SORT and MERGE statements can be described explicitly in the FILE-CONTROL paragraph as having either indexed or relative organization and can have either sequential or dynamic access mode.

Record Description Structure

A record description consists of a set of data description entries which describe the characteristics of a particular record. Each data description entry consists of a level-number, a data-name if required and a series of independent clauses as required. A record description has a hierarchical structure and, therefore, the clauses used with an entry can vary considerably, depending upon whether or not it is followed by subordinate entries. The structure of a record description is defined in the topic Concept Of Levels in the chapter Concepts of the COBOL Language, while the elements allowed in a record description are defined in the topic File Description Entry Skeleton.

Parent topic: Data Division
Related information
File Description Entry Skeleton
Concept Of Levels


Working-Storage Section

The Working-Storage Section is composed of the section header, followed by data description entries for noncontiguous data items and/or record description entries. The syntax of data description entries is defined in the topic File Description Entry Skeleton

Each Working-Storage Section record-name and noncontiguous item-name should be unique since it cannot be qualified. Subordinate data-names need not be unique if they can be made unique by qualification.

ANS85 Provided no reference is made to a given data-name or record-name, it need not be unique by qualification.

General Format

Syntax Rules

  1. The Working-Storage Section may be specified in a function definition or a program definition. Within a class definition, the Working-Storage Section must be specified only in a factory definition or an instance definition, but not in a method definition. The Working-Storage Section must not be specified within an interface definition.

Comments:

Noncontiguous Working-Storage (77-level-description-entry)

Items and constants in the Working-Storage Section which bear no hierarchical relationship to one another need not be grouped into records, provided they do not need to be further subdivided. Instead, they are classified as noncontiguous elementary items and are defined in a separate data description entry which begins with the special level-number, 77. The syntax of data description entries is defined in the chapter File Description Entry Skeleton.

The following data clauses are required in each data description entry:

  • Level-number 77
  • Data-name
  • Either:
    • The PICTURE clause or
    • The USAGE clause specifying USAGE INDEX,

      VSC2 MF USAGE COMPUTATIONAL-1, USAGE COMPUTATIONAL-2, USAGE POINTER, or

      MF COB370 USAGE PROCEDURE-POINTER

      ISO2002 MF USAGE OBJECT-REFERENCE

      MF USAGE EVENT-POINTER, MONITOR-POINTER, MUTEX-POINTER, SEMAPHORE-POINTER or THREAD-POINTER

      .

Other data description clauses are optional and can be used to complete the description of the item if necessary.

Working-Storage Records (record-description-entry)

Data elements in the Working-Storage Section which bear a definite hierarchical relationship to one another must be grouped into records according to the rules for formation of record descriptions. All clauses which are used in record descriptions in the File Section can be used in record descriptions in the Working-Storage Section.

Record Description Structure

A record description consists of a set of data description entries which describe the characteristics of a particular record. Each data description entry consists of a level-number

ANS85 optionally

followed by the data-name or FILLER clause, followed by a series of independent clauses as required. A record description can have a hierarchical structure and therefore the clauses used within an entry can vary considerably, depending upon whether or not it is followed by subordinate entries. The structure of a record description is defined in the topic Concept Of Levels in the chapter Concepts of the COBOL Language, while the elements allowed in a record description are defined in the topic File Description Entry Skeleton.

Parent topic: Data Division
Related information
File Description Entry Skeleton
Concept Of Levels


Thread-Local-Storage Section

The Thread-Local-Storage Section describes data which is unique to each thread, and is persistent across calls. The VALUE clause can be used to provide initial values for this data. The syntax of data description entries is defined in the topic File Description Entry Skeleton.

Thread-local storage can be viewed as thread-specific working storage. This is useful for resolving contention problems in most reentrant programs. In many cases, a non file-handling program can be made completely reentrant by simply changing the WORKING-STORAGE SECTION header to a THREAD-LOCAL-STORAGE SECTION header.

General Format

Syntax Rules

  1. The EXTERNAL clause is not allowed.

General Rules

  1. A separate copy of each data item in thread-local storage is created and set to its initial state for each new thread of execution that enters the program. The data item is only visible to the thread causing its execution. The data item is destroyed when the creating thread's execution terminates, or when a CANCEL statement on the program is executed; otherwise, on subsequent calls to the program within that thread, the data item is in its last used state.
  2. In a single-threaded environment, thread-local storage behaves exactly as working storage.
Parent topic: Data Division
Related information
File Description Entry Skeleton


Object-Storage Section

The Object-Storage Section is an optional section of the Data Division that enables you to declare class object data and instance object data.

Format

Syntax Rules

  1. Data declared in the Object-Storage Section of the class object may only be accessed in class methods.
  2. Data declared in the Object-Storage Section of an object-program may only be accessed in instance methods.
  3. If DATA IS RESTRICTED or DATA IS PROTECTED is specified in the CLASS-ID paragraph, data declared in the Object-Storage Section may be directly accessed in a subclass. Otherwise, this data may only be accessed by invoking methods.
  4. The syntax rules for data declared in the Object-Storage Section are the same as those for the Linkage Section except you must not specify the DEPENDING ON phrase on an OCCURS clause when the ODOSLIDE Compiler directive is specified.

General Rules

  1. Data declared in the Object-Storage Section can be inherited by subclasses.
  2. Each new instance object is allocated its own unique storage for data items declared in the Object-Storage Section.
  3. When the Compiler directive OOCTRL(+W) is specified, the Working-Storage Section is treated as the Object-Storage Section.
Parent topic: Data Division


Local-Storage Section

A separate copy of the Local-Storage Section is created each time the runtime element is activated and exists only during the lifetime of that activation. The Local-Storage Section is provided specifically for use in functions, methods and recursive calls.

The Local-Storage Section is composed of the section header, followed by data description entries for noncontiguous data items and/or record description entries. Each Local-Storage Section record-name and noncontiguous item-name should be unique since it cannot be qualified. Subordinate data-names need not be unique if they can be made unique by qualification. The syntax of data description entries is defined in the topic File Description Entry Skeleton.

Provided no reference is made to a given data-name or record-name, it need not be unique by qualification.

General Format

Syntax Rules

  1. The EXTERNAL clause is not allowed.
  2. The GLOBAL clause is not allowed.
  3. The syntax CALL ... USING local-data-item is permitted.
  4. The syntax ENTRY ... USING local-data-item is not permitted.
  5. The syntax PROCEDURE DIVISION ... USING local-data-item is not permitted.
  6. The LOCAL-STORAGE SECTION header is not permitted in nested programs.
  7. The presence of a Local-Storage Section in a program implicitly sets the recursive attribute, even if the section does not have any records. For more information, see the section Common, Initial, and Recursive Attributes in the chapter Language Fundamentals.

General Rules

  1. The DEFAULTBYTE compiler directive does not apply to items declared within the Local-Storage Section.
  2. The VALUE clause initializes data items as described in the topic The VALUE clause.
Parent topic: Data Division
Related information
File Description Entry Skeleton
Common, Initial, and Recursive Attributes
The VALUE clause


Linkage Section

All references to PROCEDURE DIVISION USING in the following discussion also apply to ENTRY USING.

VSC2 MF Except as described in the topic The SET Statement in the chapter Procedure Division - SEARCH - WRITE,

the Linkage Section in a program definition is meaningful if, and only if, the object program is to function under the control of a CALL statement, and the CALL statement in the calling program contains a USING phrase.

ISO2002 MF The Linkage Section is always meaningful in a function or method.

Formal parameters and returning items described in the Linkage Section of a source element are referred to both by that source element, when it is activated, and by the activating source element.

MF Such data can also be described in the File and Working-Storage Sections .

No storage is allocated for data items defined in the Linkage Section. Procedure Division references to these data items are resolved at run time by equating the reference in the activated runtime element to the location used in the activating runtime element. In the case of index-names, no such correspondence is established. Index-names in the activated and activating runtime element always refer to separate indices.

Data items defined in the Linkage Section of a program can be referenced within the Procedure Division of that program only if they are specified as operands of the USING phrase of the PROCEDURE DIVISION header or are subordinate to such operands, and the object program is under the control of a CALL statement which specifies a USING phrase.

The structure of the Linkage Section is the same as that previously described for the Working-Storage Section, beginning with a section header, followed by data description entries for noncontiguous data items and/or record description entries. The syntax of data description entries is defined in the chapter File Description Entry Skeleton.

Each Linkage Section record-name and noncontiguous item-name must be unique within the source element.

ANS85 These names need not be unique if they are not referenced in the Procedure Division.

The description of the parameters and the returning items that appear in a Linkage Section must follow the rules specified in the topic Conformance for Parameters and Returning Items in the chapter Procedure Division.

Comments:

Noncontiguous Linkage Storage

Items in the Linkage Section that bear no hierarchic relationship to one another need not be grouped into records and are classified and defined as noncontiguous elementary items. Each of these data items is defined in a separate data description entry which begins with the special level-number 77.

The following data clauses are required in each data description entry:

  • Level-number 77
  • Data-name
  • Either
    • The PICTURE clause or
    • the USAGE clause specifying USAGE INDEX ,

      VSC2 MF USAGE COMPUTATIONAL-1, USAGE COMPUTATIONAL-2, USAGE POINTER,

      MF COB370 USAGE PROCEDURE-POINTER,

      ISO2002 MF USAGE OBJECT-REFERENCE,

      MF USAGE EVENT-POINTER, MONITOR-POINTER, MUTEX-POINTER, SEMAPHORE-POINTER , THREAD-POINTER

      .

Other data description clauses are optional and can be used to complete the description of the item if necessary.

Linkage Records

Data elements in the Linkage Section which bear a definite hierarchic relationship to one another must be grouped into records according to the rules for formation of record descriptions. Any clause which is used in an input or output record description can be used in a Linkage Section.

Parent topic: Data Division
Related reference
Linkage Section in Main Program
Related information
The SET Statement
File Description Entry Skeleton
Conformance for Parameters and Returning Items


Screen Section

The Screen Section provides screen handling facilities for use with ACCEPT and DISPLAY statements.
Note: This functionality is not supported in COBOL for JVM.

The Screen Section provides screen handling facilities for use with ACCEPT and DISPLAY statements. It allows the following:

  • The display of non-scrolling forms consisting of areas of the screen as defined in the Screen Section. A Screen Section entry is called a screen description. It is similar in appearance to a data description but defines a screen item or area of the screen rather than an area in memory.
  • MF The display of data items which constitute non-scrolling forms. The details of the areas of the screen to be used are provided in the associated ACCEPT and DISPLAY operations.

The Screen Section contains a description of each field on the screen which is accessed in a Format 4 ACCEPT or Format 2 DISPLAY operation. Such a field is called a screen item. Many screen items describe only the layout of fields within a field on the screen and are never referenced explicitly.

The Screen Section contains syntax which enables you to:

  • Specify the exact location of fields
  • Accept data typed at specified positions
  • Display literal text at specified positions
  • Define screen attributes
  • Control console features.

This syntax is defined in the topic Screen Section Entry Skeleton.

Data entry is made to numeric and numeric-edited screen fields in two ways; fixed-format mode and free-format mode. Refer to your COBOL system documentation about user interfaces for further details.

Fixed-format mode is the default manner in which data entry is made to numeric and numeric edited screen fields. This mode formats and echoes the entered data and also moves the cursor in accordance with the requirements of the field's picture specification, as each keystroke is received. Characters other than digits, "+", "-" , and the decimal point character, are rejected; insertion characters in edited fields are skipped over as the cursor moves backwards and forwards; any sign indicator is modified in accordance with its normal specification; floating symbols move left and right in the field, and insertion symbols appear and disappear as digits are inserted or deleted. When the cursor reaches the last character position in a field, any further character entered replaces the last character.

Free-format mode is an alternative manner in which data entry can be made to numeric and numeric-edited screen fields. The default mode is fixed-format mode. Free-format mode allows data to be keyed into a PIC X field of appropriate length, and only when the operator leaves the field is the data reformatted to comply with the picture specification. Once the operator moves the cursor from the field, your COBOL system disregards all characters other than digits and the sign and decimal point symbols. It then extracts, stores, or reformats the numeric value in accordance with the normal COBOL rules for a MOVE to an item with the same picture as the screen item or working storage item. The numeric value is then usually echoed to the screen. See your COBOL system documentation about user interfaces for details on configuration options available to you.

The Screen Section provides screen handling facilities for use with Format 4 ACCEPT and Format 2 DISPLAY statements.

General Format

Syntax Rules

  1. The Screen Section must be the last section in the Data Division.
  2. A screen-description-entry contains screen description clauses. Data description clauses allowed in the Screen Section are restricted to those shown in the General Format.

General Rule

  1. The Screen Section contains a description of each field on the screen which is accessed in a Format 4 ACCEPT or Format 2 DISPLAY operation. Such a field is called a screen item. Many screen items describe only the layout of fields within a field on the screen and are never referenced explicitly.
Parent topic: Data Division
Related information
Screen Section Entry Skeleton


File and Data Description

  • File Description Entry Skeleton
    The file description comprises information concerning the physical structure, identification, and record-names pertaining to a given file.
  • Data Description Entry Skeleton
    A data description entry specifies the characteristics of a particular item of data.
Parent topic: Data Division


File Description Entry Skeleton

The file description comprises information concerning the physical structure, identification, and record-names pertaining to a given file.

ANS85 It determines the internal or external attributes of a file connector, of the associated data records, and of the associated data items. The file description entry also determines whether a file-name is a local name or a global name.

General Formats for Format 1 (Record Sequential Files)

General Formats for Format 2 (Line Sequential Files)

General Formats for Format 3 (Relative and Indexed Files)

General Formats for Format 4 (Sort-Merge Files)

Syntax Rules for All Formats (All Files)

  1. The clauses which follow file-name-1 may appear in any order.
  2. MF If the VALUE OF FILE-ID clause is specified, literal-1 must be a nonnumeric literal and cannot be a figurative constant.

Syntax Rules for Formats 1, 2 and 3 (RecordSequential, MF Line Sequential, Relative and Indexed Files)

  3. The level indicator FD identifies the beginning of a file description and must precede the file-name.
  4. One or more record description entries must follow the file description entry.
  5. MF The EXTERNAL clause and the THREAD-LOCAL clause must not be specified in the same file description entry.

Syntax Rules for Format 4 (Sort-Merge Files)

  6. The level indicator SD identifies the beginning of the sort-merge file description and must precede the file-name.
  7. The clauses which follow the name of the file are optional and may appear in any order.
  8. One or more record description entries must follow the sort-merge file description entry. However, no input-output statements can be executed for this file.

General Rules for Format 1 (Record Sequential Files)

  1. If the file description entry for a sequential file contains the LINAGE clause and the EXTERNAL clause, the LINAGE-COUNTER data item is an external data item. If the file description entry for a sequential file contains the LINAGE clause and the GLOBAL clause, the special register LINAGE-COUNTER is a global name.
  • The BLOCK CONTAINS Clause
    The BLOCK CONTAINS clause specifies the size of a physical record.
  • The CODE-SET Clause
    The CODE-SET clause specifies the character code set used to represent data on the external media.
  • The DATA RECORDS Clause
    The DATA RECORDS clause serves only as documentation for the names of data records with their associated file.
  • The EXTERNAL Clause
    The EXTERNAL clause specifies that a data item or a file connector is external. The constituent data items and group items of an external data record are available to every runtime element in the run unit that describes that record.
  • The GLOBAL Clause
    The GLOBAL clause specifies that a data-name, a file-name, or a report-name is a global name. A global name is available to every program contained within the program which declares it.
  • The LABEL RECORDS Clause
    The LABEL RECORDS clause specifies whether labels are present.
  • The LINAGE Clause
    The LINAGE clause allows the user to specify the depth of a logical page in terms of number of lines. The user can also specify the size of the top and bottom margins on the logical page, and the line number, within the page body, at which the footing area begins.
  • The RECORD Clause
  • The THREAD-LOCAL Clause
    The THREAD-LOCAL clause specifies that there is a distinct copy of a data item or file connector for each thread entering a program.
  • The VALUE OF Clause
    The VALUE OF clause specifies the description of an item in the label records associated with a file.
  • The RECORDING MODE Clause
    The RECORDING MODE clause specifies the format of the logical records in the file.
Parent topic: File and Data Description


The BLOCK CONTAINS Clause

The BLOCK CONTAINS clause specifies the size of a physical record.

XOPEN Although it is a part of the standard COBOL definition, this feature is explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

General Format

General Rules

  1. MF This clause is documentary only.
Parent topic: File Description Entry Skeleton


The CODE-SET Clause

The CODE-SET clause specifies the character code set used to represent data on the external media.

It can be specified only for files with record sequential

MF and line sequential

organization.

XOPEN Although it is a part of the standard COBOL definition, this feature is explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

General Format

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directive may impact either the syntax or the semantics described in this section.
    • CHARSET – determines what is considered the native code set.

Syntax Rules

  1. When the CODE-SET clause is specified for a file, all data in that file must be described as USAGE IS DISPLAY and any signed numeric data must be described with the SIGN IS SEPARATE clause.

    MF These restrictions do not apply.

  2. The alphabet-name clause referenced by the CODE-SET clause must not specify the literal phrase.

    MF These restrictions do not apply.

  3. MF Identifier-1 can be qualified, but must not be subscripted.
  4. MF Each identifier-1 must be a data item described in the same record description for the file, and must not itself be a record description.
  5. MF If the optional FOR phrase is specified, the CODE-SET clause specifies the character code to be used for the data items named. If the FOR phrase is not specified, the CODE-SET clause specifies the character code to be used for the whole file.
  6. The native character set is used for any file, or data item in a file, to which no CODE-SET clause applies.

General Rules

  1. MF The data in the record area is always in ASCII. If alphabet-name has been equated in the Special-Names paragraph to EBCDIC, then data affected by the CODE-SET clause is translated from ASCII to EDCDIC as it is written to the file; or from EBCDIC to ASCII as it is read from the file. If alphabet-name has been equated in the Special-Names paragraph to STANDARD-1, STANDARD-2, NATIVE, or ASCII, no translation is necessary.
  2. MF For the purposes of this translation, any data item to which a CODE-SET clause applies is treated as alphanumeric. No account is taken of the class and category of the item as described in its data description.
  3. MF If identifier-1 has an OCCURS clause, the CODE-SET clause applies to only the first occurrence of it. If identifier-1 has a subordinate item with an OCCURS clause, the CODE-SET clause applies to the whole of identifier-1.
Parent topic: File Description Entry Skeleton


The DATA RECORDS Clause

The DATA RECORDS clause serves only as documentation for the names of data records with their associated file.

ANS85 The DATA RECORDS clause of the file description entry is classed as an obsolete element in the ANSI'85 standard and is scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects in this COBOL implementation fully support this syntax. The FLAGSTD Compiler directive can be used to detect all occurrences of this syntax.

XOPEN Although part of the standard COBOL definition, this feature is explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

General Format

Syntax Rules

  1. Data-name-1 and data-name-2 are the names of data records and should have 01 level-number record descriptions, with the same names, associated with them.

    OSVS VSC2 These data-names do not have to be associated with any data description entry in the program.

General Rules

  1. The presence of more than one data-name indicates that the file contains more than one type of data record. These records can be of differing sizes, different formats, and so on. The order in which they are listed is not significant.
    Note: When using multiple 01 level items within an FD, if the SELECT statement contains key definitions, the key sizes must be contained within the minimum record length of that FD.
  2. Conceptually, all data records within a file share the same area. This is in no way altered by the presence of more than one type of data record within the file.
Parent topic: File Description Entry Skeleton


The EXTERNAL Clause

The EXTERNAL clause specifies that a data item or a file connector is external. The constituent data items and group items of an external data record are available to every runtime element in the run unit that describes that record.

General Format

Syntax Rules

  1. The EXTERNAL clause can be specified only in file description entries, or in record description entries in the Working-Storage Section.
  2. In the same source element, the externalized name of the subject of the entry that includes the EXTERNAL clause must not be the same as the externalized name of any other entry that includes the EXTERNAL clause.
  3. The VALUE clause must not be used in any data description entry that includes, or is subordinate to an entry that includes, the EXTERNAL clause. The VALUE clause can be specified for condition-name entries associated with such data description entries.
  4. MF Literal-1 must be a nonnumeric or a national literal and must not be a figurative constant.
  5. ISO2002 The EXTERNAL clause must not be specified for a data item of class object.
  6. MF The EXTERNAL clause must not be specified in the data division of a method, or as instance data.

General Rules

  1. The data contained in the record named by the data-name clause is external and can be accessed and processed by any runtime element in the run unit which describes and, optionally, redefines it subject to the following general rules.
  2. Within a run unit, if two or more source elements describe the same external data record, each record-name of the associated record description entries must be the same and the records must define the same number of standard data format characters. However, a source element which describes an external record can contain a data description entry including the REDEFINES clause which redefines the complete external record, and this complete redefinition need not occur identically in other source elements in the run unit, unless the storage area required for the redefinition is larger than the storage area required for the external data record. See the topic The REDEFINES Clause.
  3. Use of the EXTERNAL clause does not imply that the associated file-name or data-name is a global name. See the topic The GLOBAL Clause.
  4. The file connector associated with this description entry is an external file connector.

    MF See your COBOL system documentation on file handling for further information on files with the EXTERNAL attribute.

  5. MF Literal-1 identifies the external name of an external data item or file connector. The same external name must be used by all source elements that reference the same external data item or file connector.
Parent topic: File Description Entry Skeleton
Related information
The REDEFINES Clause
The GLOBAL Clause


The GLOBAL Clause

The GLOBAL clause specifies that a data-name, a file-name, or a report-name is a global name. A global name is available to every program contained within the program which declares it.

General Format

Syntax Rules

  1. The GLOBAL clause can be specified only in data description entries whose level-number is 01 in the File Section or the Working-Storage Section, file description entries, or report description entries.

    MF COB370 The GLOBAL clause can also be specified in the Linkage Section.

  2. In the same Data Division, the data description entries for any two data items for which the same data-name is specified must not include the GLOBAL clause.
  3. If the SAME RECORD AREA clause is specified for several files, the record description entries or the file description entries for these files must not include the GLOBAL clause.

General Rules

  1. A data-name, file-name or report-name described using a GLOBAL clause is a global name. All data-names subordinate to a global name are global names. All condition-names associated with a global name are global names.
  2. A statement in a program contained directly or indirectly within a program which describes a global name can reference that name without describing it again. See the topic Scope of Names in the chapter Concepts of the COBOL Language.
  3. If the GLOBAL clause is used in a data description entry which contains the REDEFINES clause, it is only the subject of that REDEFINES clause which possesses the global attribute.
Parent topic: File Description Entry Skeleton
Related information
Scope of Names


The LABEL RECORDS Clause

The LABEL RECORDS clause specifies whether labels are present.

ANS85 The LABEL RECORDS clause is classed as an obsolete element in the ANSI'85 standard and is scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects in this COBOL implementation fully support this syntax. The FLAGSTD Compiler directive can be used to detect all occurrences of this syntax.

XOPEN Although it is a part of the standard COBOL definition, this feature is explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

General Format

Syntax Rules

  1. This clause should be present in every file description entry.

    ANS85 It is not required.

  2. OSVS VSC2 Data-name-1 is the name of a label record and should have a 01 level-number record description, with the same name, associated with it.
  3. OSVS VSC2 Data-name-1 must not appear in the DATA RECORDS clause for the file.
  4. OSVS VSC2 Both LABEL RECORDS IS and LABEL RECORD ARE are accepted as valid syntax.

General Rule

  1. MF This clause is documentary only.
Parent topic: File Description Entry Skeleton


The LINAGE Clause

The LINAGE clause allows the user to specify the depth of a logical page in terms of number of lines. The user can also specify the size of the top and bottom margins on the logical page, and the line number, within the page body, at which the footing area begins.

It can be specified only for files with sequential organization.

General Format

Syntax Rules

  1. Data-name-1, data-name-2, data-name-3 and data-name-4 must reference elementary unsigned integer data items.
  2. The value of integer-1 must be greater than zero.
  3. The value of integer-2 must not be greater than integer-1.
  4. The value of integer-3 and integer-4 can be zero.

General Rules

  1. The LINAGE clause allows the user to specify the size of a logical page in terms of number of lines. The logical page size is the sum of the values referenced by each phrase except the FOOTING phrase. If the FOOTING phrase is not specified, the values for these functions are zero and no end-of-page condition independent of the page overflow condition exists.

    There is not necessarily any relationship between the size of the logical page and the size of a physical page.

  2. The value of integer-1 or the data item referenced by data-name-1 specifies the number of lines that can be written and/or spaced on the logical page. The value must be greater than zero. That part of the logical page in which these lines can be written and/or spaced is called the page body.
  3. The value of integer-2 or the data item referenced by data-name-2 specifies the line number within the page body at which the footing area begins. The value must be greater than zero and not greater than the value of integer-1 or the data item referenced by data-name-1.

    The footing area comprises the area of the logical page between the line represented by the value of integer-2 of the data item referenced by data-name-2, and the line represented by the value of integer-1 or the data item referenced by data-name-1, inclusive.

  4. The value of integer-3 or the data item referenced by data-name-3 specifies the number of lines that comprise the top margin on the logical page. The value can be zero.

    The value of integer-4 or the data item referenced by data-name-4 specifies the number of lines that comprise the bottom margin on the logical page. The value can be zero.

  5. The value of integer-1, integer-3, and integer-4, if specified, will be used at the time the file is opened by the execution of an OPEN statement with the OUTPUT phrase, to specify the number of lines that comprise each of the indicated sections of a logical page. The value of integer-2, if specified, will be used at that time to define the footing area. These values are used for all logical pages written for the file during a given execution of the runtime element.
  6. The values of the data items referenced by data-name-1, data-name-3, and data-name-4, if specified at the time an open statement with the OUTPUT phrase is executed for the file, will be used to specify the number of lines that are to comprise each of the indicated sections for the first logical page.

    The value of the data item referenced by data-name-2, if specified, will be used at the time an OPEN statement with the OUTPUT phrase is executed for the file to define the footing area for the first logical page.

  7. A LINAGE-COUNTER special register is generated by the presence of a LINAGE clause. The value in the LINAGE-COUNTER special register at any one time represents the line number at which the device is positioned within the current page body. The rules governing the LINAGE-COUNTER special register are as follows:
    1. A separate LINAGE-COUNTER special register is supplied for each file described in the File Section whose file description entry contains a LINAGE clause.
    2. The LINAGE-COUNTER special register can be referenced, but cannot be modified, by Procedure Division statements. Since more than one LINAGE-COUNTER special register can exist in a source element, the user must qualify LINAGE-COUNTER by file-name when necessary.
  8. Each logical page is contiguous to the next with no additional spacing provided.
  9. The values of the data items, at the time a WRITE statement with the ADVANCING PAGE phrase is executed or page overflow condition occurs (see the topic The WRITE Statement), will be used to specify the number of lines that are to comprise each of the indicated sections for the next logical page.
  10. The value of the data item referenced by data-name-2, if specified, will be used at the time a WRITE statement with the ADVANCING PAGE phrase is executed or a page overflow condition occurs, to define the footing area for the next logical page.
  11. The LINAGE-COUNTER special register is automatically modified, according to the following rules, during the execution of a WRITE statement to an associated file:
    • When the ADVANCING PAGE phrase of the WRITE statement is specified, the LINAGE-COUNTER special register is automatically reset to one.
    • When the ADVANCING identifier-2 or integer phrase of the WRITE statement is specified, the LINAGE-COUNTER special register is incremented by integer or the value of the data item referenced by identifier-2.
    • When the ADVANCING phrase of the WRITE statement is not specified, the LINAGE-COUNTER special register is incremented by the value one. (See the topic The WRITE Statement.)
    • The value of the LINAGE-COUNTER special register is automatically reset to one when the device is repositioned to the first line that can be written on for each of the succeeding logical pages. (See the topic The WRITE Statement.)
  12. The value of the LINAGE-COUNTER special register is automatically set to one when an OPEN statement is executed for the associated file.
Parent topic: File Description Entry Skeleton
Related information
The WRITE Statement


The RECORD Clause

ANS85 The RECORD clause specifies either the number of character positions in a fixed-length record or the range of character positions in a variable-length record. If the number of character positions varies, the clause specifies the minimum and maximum number of character positions.

MF The concepts of fixed and variable format files used throughout this section do not directly apply to line sequential files. See your COBOL system documentation on file handling for details on the implications of using line sequential files in your COBOL implementation.

XOPEN Although it is a part of the standard COBOL definition, the RECORD CONTAINS clause is explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

Syntax Rules for Format 1

  1. No record description entry for the file can specify a number of character positions different from integer-1.

Syntax Rules for Format 2

  2. ANS85 Record descriptions for the file must not describe records which contain fewer character positions than specified by integer-2, nor records which contain a greater number of character positions than that specified by integer-3.
  3. ANS85 Integer-3 must be greater than integer-2.
  4. ANS85 Data-name-1 must describe an elementary unsigned integer in the Working-Storage or Linkage Section.

General Rules for All Formats

  1. If the RECORD clause is not specified, the size of each data record is completely defined in the record description entry.
  2. ANS85 If the associated file connector is an external file connector, all file description entries in the run unit which are associated with that file connector must specify the same values for integer-1 or integer-2 and integer-3. If the RECORD clause is not specified, all record description entries associated with this file connector must be the same length.
  3. MF XOPEN Line sequential files are neither truly fixed nor truly variable format files: the presence or absence of any RECORDING MODE, RECORD CONTAINS or RECORD VARYING IN SIZE clause does not, therefore, impact their performance.

General Rules for Format1

  4. Format 1 is used to specify fixed-length records. Integer-1 specifies the number of character positions contained in each record in the file.

General Rules for Format2

  5. ANS85 Format 2 is used to specify variable-length records. Integer-2 specifies the minimum number of character positions to be contained in any record of the file. Integer-3 specifies the maximum number of character positions in any record of the file.
  6. ANS85 The number of character positions associated with a record description is determined by the sum of the number of character positions in all elementary data items excluding redefinitions and renamings, plus any implicit FILLER items due to synchronization. If a table is specified:
    1. The minimum number of table elements described in the record is used in the summation above to determine the minimum number of character positions associated with the record description.
    2. The maximum number of table elements described in the record is used in the summation above to determine the maximum number of character positions associated with the record description.
  7. ANS85 If integer-2 is not specified, the minimum number of character positions to be contained in any record of the file is equal to the least number of character positions described for a record in that file.
  8. ANS85 If integer-3 is not specified, the maximum number of character positions to be contained in any record of the file is equal to the greatest number of character positions described for a record in that file.
  9. ANS85 If data-name-1 is specified, the number of character positions in the record must be placed into the data item referenced by data-name-1 before any RELEASE, REWRITE, or WRITE statement is executed for the file.
  10. ANS85 If data-name-1 is specified, the execution of a DELETE, RELEASE, REWRITE, START, or WRITE statement or the unsuccessful execution of a READ or RETURN statement does not alter the content of the data item referenced by data-name-1.
  11. ANS85 During the execution of a RELEASE, REWRITE, or WRITE statement, the number of character positions in the record is determined by the following conditions:
    1. If data-name-1 is specified, by the content of the data item referenced by data-name-1.
    2. If data-name-1 is not specified and the record does not contain a variable occurrence data item, by the number of character positions in the record.
    3. If data-name-1 is not specified and the record does contain a variable occurrence data item, by the sum of the fixed portion and that portion of the table described by the number of occurrences at the time of execution of the output statement.

    If the number of character positions in the logical record which is to be written is less than integer-2 or greater than integer-3, the output statement is unsuccessful and, except during execution of a RELEASE statement, the associated I/O status is set to a value indicating the cause of the condition.

  12. ANS85 If data-name-1 is specified, after the successful execution of a READ or RETURN statement for the file, the contents of the data item referenced by data-name-1 indicates the number of character positions in the record just read.
  13. ANS85 If the INTO phrase is specified in the READ or RETURN statement, the number of character positions in the current record that participate as the sending data items in the implicit MOVE statement is determined by the following conditions:
    1. If data-name-1 is specified, by the content of the data item referenced by data-name-1.
    2. If data-name-1 is not specified, by the value that would have been moved into the data item referenced by data-name-1 had data-name-1 been specified.

General Rules for Format 3

  14. When format 3 of the RECORD clause is used, integer-4 and integer-5 refer to the minimum number of characters in the smallest size data record and the maximum number of characters in the largest size data record respectively. However, in this case, the size of each data record is completely defined in the record description entry.
  15. The size of each data record is specified in terms of the number of character positions required to store the logical record, regardless of the types of characters used to represent the items within the logical record. The size of a record is determined by the sum of the number of characters in all fixed-length elementary items plus the sum of the maximum number of characters in any variable-length item subordinate to the record. This sum can be different from the actual size of the record. See the topic Selection Of Character Representation And Radix in the chapter Concepts of the COBOL Language, and the sections The SYNCHRONIZED Clause and The USAGE Clause.
Parent topic: File Description Entry Skeleton
Related information
Selection Of Character Representation And Radix
The SYNCHRONIZED Clause
The USAGE Clause


The THREAD-LOCAL Clause

The THREAD-LOCAL clause specifies that there is a distinct copy of a data item or file connector for each thread entering a program.

General Format

IS THREAD-LOCAL

Syntax Rules

  1. The THREAD-LOCAL clause can be specified only in file description entries or in record description entries in the Working-Storage Section.

General Rules

  1. If the THREAD-LOCAL clause is specified, a separate copy of the file connector or data item is created and set to its initial state for each new thread of execution that enters the program. The file connector or data item is only visible to the thread causing its creation. The file connector or data item is destroyed when the creating thread's execution terminates or when a CANCEL statement on the program is executed; otherwise, on subsequent calls to the program within that thread, the data item or file connector is in its last used state.
  2. If the THREAD-LOCAL clause is not specified, the file connector or data item is shared by all threads entering the program.
  3. In a single-threaded environment, the clause is ignored and the program behaves exactly as if the THREAD-LOCAL clause had not been specified.
Parent topic: File Description Entry Skeleton


The VALUE OF Clause

The VALUE OF clause specifies the description of an item in the label records associated with a file.

ANS85 The VALUE OF clause of the file description entry is classed as an obsolete element in the ANSI'85 standard and is scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects in this COBOL implementation fully support this syntax. The FLAGSTD Compiler directive can be used to detect all occurrences of this syntax.

XOPEN Although it is a part of the standard COBOL definition, this feature is explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

General Formats for Format 1 (All Files)

General Formats for Format 2 (All Files)

Syntax Rules for Format 1 (All Files)

  1. Data-name-1 should be qualified when necessary but cannot be subscripted or indexed, nor can it be an item described with the USAGE IS INDEX clause.

Syntax Rules for Format 2 (All Files)

  2. MF Data-name-2 must be in the Working-Storage Section.
  3. MF Literal-2 must be a nonnumeric literal and cannot be a figurative constant.
  4. MF The VALUE OF FILE-ID clause cannot be used if external-file-reference, data-name-1 or literal-1 has been specified in the ASSIGN clause in the file control entry (see the topic The File Control Entry in the chapter Environment Division).

General Rules for Format 1 (All Files)

  1. MF This clause is documentary only.

General Rules for Format 2 (All Files)

  2. MF The character-string specified in literal-2 or data-name-2 is taken as the external file-name.
Parent topic: File Description Entry Skeleton
Related information
The File Control Entry


The RECORDING MODE Clause

The RECORDING MODE clause specifies the format of the logical records in the file.

General Formats for Format 1 (Record Sequential Files)

General Formats for Format 2 (Line Sequential Files)

General Formats for Format 3 (Relative and Indexed Files)

Syntax Rules

  1. MF F and FIXED are synonyms.
  2. MF V and VARIABLE are synonyms.

General Rules for All Formats (All Files)

  1. Specifying RECORDING MODE IS F causes all the records in the file to be the same length.

General Rules for Format 1 (Record Sequential Files)

  2. MF The "U" option is documentary only.

General Rules for Formats 1 and 3 (Record Sequential,Relative and Indexed Files)

  3. When RECORDING MODE IS V is specified, the records in the file can be either fixed or variable in length. Each data record includes a record length field. These fields are not part of the record description.

General Rules for Format 2 (Line SequentialFiles)

  4. MF Line sequential files are neither truly fixed nor truly variable format files: the presence or absence of any RECORDING MODE, RECORD CONTAINS or RECORD VARYING IN SIZE clause does not, therefore, impact their performance.
Parent topic: File Description Entry Skeleton


Data Description Entry Skeleton

A data description entry specifies the characteristics of a particular item of data.

MF or the characteristics of a programmer-defined type of data which can then be used to specify the description of one or more particular items of data

.

ANS85 A level 01 data description entry within the Working-Storage Section or File Section determines whether the data record and its subordinate data items have local names or global names.

ANS85 A level 01 data description in the Working-Storage Section determines the internal or external attribute of the data record and its subordinate data items.

General Formats for Format 1

General Formats for 66 level item Format 2

General Formats for 88 level item Format 3

General Formats for 78 level item Format 4

Syntax Rules

  1. The level-number in Format 1 can be any number from 01 through 49 or 77.
  2. The clauses can be written in any order with two exceptions: the data-name-1 or FILLER clause

    ANS85 , if specified,

    must immediately follow the level-number; the REDEFINES clause, when used, must immediately follow the data-name-1 or FILLER clause

    ANS85 if either is specified; otherwise it must immediately follow the level number

    .

  3. The PICTURE clause must not be specified for the subject of a RENAMES clause or for an item whose usage is
    • INDEX,
    • ISO2002 MF OBJECT-REFERENCE,
    • PROCEDURE-POINTER,
    • ISO2002 MF PROGRAM-POINTER,
    • POINTER,
    • OSVS VSC2 MF COMPUTATIONAL-1, COMPUTATIONAL-2,
    • ISO2002 MF BINARY-CHAR, BINARY-SHORT, BINARY-LONG, BINARY-DOUBLE,
    • ISO2002 MF FLOAT-SHORT, FLOAT-LONG,
    • MF EVENT-POINTER, MONITOR-POINTER, MUTEX-POINTER, SEMAPHORE-POINTER or THREAD-POINTER.

    For any other entry describing an elementary item, a PICTURE clause must be specified except as indicated in the rule that immediately follows.

  4. The PICTURE clause may be omitted for an elementary item when an alphanumeric or national literal is specified in a format 1 VALUE clause. A PICTURE clause is implied as follows:
    1. if the literal is alphanumeric, 'PICTURE X(length)'
    2. if the literal is national, 'PICTURE N(length)'.

    where length is the length of the literal as specified in the topic Literals in the chapter Concepts of the COBOL Language.

  5. The words THRU and THROUGH are equivalent.
  6. ANS85 The EXTERNAL clause can be specified only in data description entries in the Working-Storage Section whose level-number is 01.
  7. ANS85 The EXTERNAL clause and the REDEFINES clause must not be specified in the same data description entry.
  8. MF The EXTERNAL clause and the THREAD-LOCAL clause must not be specified in the same data description entry.
  9. ANS85 The GLOBAL clause can be specified only in data description entries whose level-number is 01.
  10. ANS85 Data-name-1 must be specified for any entry containing the GLOBAL or EXTERNAL clause, or for record descriptions associated with a file description entry which contains the EXTERNAL or GLOBAL clause.
  11. MF The TYPEDEF clause can only be specified in data description entries whose level-number is 01.
  12. MF The TYPEDEF clause can only be used when data-name-1 is also specified. In other words, it cannot be used in the same data description with either an explicit or implicit FILLER clause.

    Note that if the TYPEDEF clause is specified for a group item, subordinate data descriptions can be defined with either an implicit or explicit FILLER clause.

  13. The clauses SYNCHRONIZED, PICTURE, JUSTIFIED, and BLANK WHEN ZERO must not be specified except for an elementary data item.

    OSVS VSC2 The SYNCHRONIZED clause can be specified for a group item.

  14. MF Literal-6 and integer-1 must not be floating-point values, must not be negative values and must not be more than 18 digits.
  15. If literal-6 is used as part of an expression, it must be an integer.
  16. OSVS VSC2 Data-name-2 and data-name-3 can be implicitly qualified.
  17. ISO2002 The VALUE clause must not be specified for data items of class index, object, or pointer.
  18. ISO2002 MF If the ANY LENGTH clause is specified, the only other clauses permitted are level-number, entry-name, PICTURE, and USAGE.

General Rules

  1. Format 3 is used for each condition-name. Each condition-name requires a separate entry with level-number 88. Format 3 contains the name of the condition and the value, values, or range of values associated with the condition-name. The condition-name entries for a particular conditional variable must immediately follow the entry describing the item with which the condition-name is associated. A condition-name can be associated with any data description entry which contains a level-number except the following:
    1. Another condition-name.
    2. A level 66 item.
    3. A group containing items with descriptions including JUSTIFIED, SYNCHRONIZED or USAGE (other than USAGE IS DISPLAY).
    4. An index

      VSC2 MF or pointer

      data item (see the topic The USAGE Clause).

    5. MF A constant-name.
  2. VSC2 MF Condition-names can be associated with internal floating-point items.

    MF Condition-names can be associated with external floating-point items.

  3. MF Format 4 defines a constant-name, which is a symbolic name representing a constant value assigned to it when the source code is passed through your COBOL system. Your COBOL system replaces each reference to a constant-name by its value.
  4. MF The TYPEDEF clause allows you to declare a group or elementary data description as a type definition, which allows instances of that data description to be declared as data items using data-name-1 as typedef-name-1 in the USAGE clause. The type definition itself is not a data item with allocated storage.
  5. MF If the TYPEDEF clause is specified at a group level, the components of the type definition are implicitly declared for any data item of that type and are referenced using the usual COBOL rules of qualification for the data item.
  • The ANY LENGTH Clause
    The ANY LENGTH clause specifies that the length of a linkage section item may vary at runtime and is determined by the length of the argument.
  • The BLANK WHEN ZERO Clause
    The BLANK WHEN ZERO clause permits the blanking of an item when its value is zero.
  • The CUSTOM-ATTRIBUTE Clause
    The CUSTOM-ATTRIBUTE clause specifies an attribute that provides metadata (information) about a managed code native data item or a property that will be visible using reflection.
  • The Data-name or FILLER Clause
    A data-name specifies the name of the data being described. The word FILLER can be used to specify an elementary item of the logical record that cannot be referred to explicitly.
  • The GROUP-USAGE Clause
    A GROUP-USAGE clause with a BIT phrase specifies that the group item defined by the subject of the entry is to be treated as an elementary item of usage bit and category boolean, unless specified otherwise.
  • The JUSTIFIED Clause
    The JUSTIFIED clause specifies non-standard positioning of data within a receiving data item.
  • Level Number
    The level-number shows the hierarchy of data within a logical record.
  • The OCCURS Clause
    The OCCURS clause eliminates the need for separate entries for repeated data items and supplies information required for the application of subscripts or indices.
  • The PICTURE Clause
    The PICTURE clause describes the general characteristics and editing requirements of an elementary item.
  • The PROPERTY Clause
    The PROPERTY clause indicates that this data item is a property of the object in which this data description is contained and that GET and/or SET methods are to be generated accordingly.
  • The REDEFINES Clause
    The REDEFINES clause allows the same computer storage area to be described by different data description entries.
  • The RENAMES Clause
    The RENAMES clause permits alternative, possibly overlapping, groupings of elementary items.
  • The SIGN Clause
    The SIGN clause specifies the position and the mode of representation of the operational sign when it is necessary to describe these properties explicitly.
  • The SYNCHRONIZED Clause
    The SYNCHRONIZED clause specifies the alignment of an elementary item on the natural boundaries of the computer memory.
  • The TYPEDEF Clause
    The TYPEDEF clause defines a record as a programmer-defined type definition.
  • The USAGE Clause
    The USAGE clause specifies the format of a data item in the computer storage.
  • The VALUE Clause
    The VALUE clause defines the value of constants, the initial value of working storage and local storage items, and the values associated with a condition name.
Parent topic: File and Data Description
Related information
Literals
The USAGE Clause


The ANY LENGTH Clause

The ANY LENGTH clause specifies that the length of a linkage section item may vary at runtime and is determined by the length of the argument.

General Format

  ANY LENGTH

Syntax Rules

  1. The ANY LENGTH clause must be specified only in an elementary level 1 entry in the Linkage Section of a function, of a contained program, or of a method that is not a property method.
  2. If the source element containing the ANY LENGTH clause is a contained program or is a method, the subject of the entry must be referenced in its PROCEDURE DIVISION header as either
    1. A formal parameter with the BY REFERENCE phrase, or
    2. The returning item.
  3. If the source element containing the ANY LENGTH clause is a function, the subject of the entry must be referenced in its PROCEDURE DIVISION header as a formal parameter with the BY REFERENCE phrase.
  4. A PICTURE clause must be specified for the subject of the entry, and the character-string specified in the PICTURE clause must be one instance of the picture symbols 'N' or 'X'.

General Rules

  1. The ANY LENGTH clause specifies that the subject of the entry must be:
    1. A zero-length item when the corresponding argument or returning item of the activating runtime element is a zero-length item, or
    2. Treated as though there were n repetitions of the picture symbol in the character-string in its PICTURE clause, where n is the length of the corresponding argument or returning item of the activating runtime element.
Parent topic: Data Description Entry Skeleton


The BLANK WHEN ZERO Clause

The BLANK WHEN ZERO clause permits the blanking of an item when its value is zero.

General Format

Syntax Rules

  1. The BLANK WHEN ZERO clause can be used only for an elementary item whose PICTURE is specified as numeric (with implicit or explicit USAGE IS DISPLAY) or numeric edited. (See the topic The PICTURE Clause.)
  2. The asterisk, when used as the zero suppression symbol, and the clause BLANK WHEN ZERO should not appear in the same entry.

    OSVS This construct is, however, permitted in which case, zero suppression overrides the BLANK WHEN ZERO clause.

General Rules

  1. When the BLANK WHEN ZERO clause is used, the item will contain nothing but spaces if the value of the item is zero.
  2. When the BLANK WHEN ZERO clause is used for an item whose PICTURE is numeric, the category of the item is considered to be numeric edited.
Parent topic: Data Description Entry Skeleton
Related information
The PICTURE Clause


The CUSTOM-ATTRIBUTE Clause

The CUSTOM-ATTRIBUTE clause specifies an attribute that provides metadata (information) about a managed code native data item or a property that will be visible using reflection.

Format 1

{ CUSTOM-ATTRIBUTE IS  class-name-1 [ ( {parameter-1} . . . ) ] }...

Syntax Rules for Format 1

  1. This list of parameters must match a constructor defined for class-name-1. Each parameter-1 must be one of the following:
    • An ordinary parameter that is the argument to the constructor for that attribute. For example:

      custom-attribute is Marshal-Attribute(3)

    • A named parameter that corresponds to a property defined on the custom attribute class. For example:

      custom-attribute is webservice("Description"="My service")

General Rules

  1. The custom attribute specified becomes part of the metadata describing the subject of the entry and is visible to a reflector.
  2. Languages for JVM support annotations, which are similar broadly to attributes in COBOL.
Parent topic: Data Description Entry Skeleton


The Data-name or FILLER Clause

A data-name specifies the name of the data being described. The word FILLER can be used to specify an elementary item of the logical record that cannot be referred to explicitly.

General Format

Syntax Rules

  1. The data-name or FILLER clause

    ANS85 , if specified,

    must be the first word following the level-number in a data description entry.

General Rules

  1. The key word FILLER can be used to name an elementary item or group in a record. Under no circumstances can a FILLER item be referred to explicitly. However, a data item defined with the key word FILLER can be used as a conditional variable because such use does not require explicit reference to the FILLER item but only to the value contained therein.
  2. ANS85 If this clause is omitted, the data item being described is treated as though FILLER had been specified.
Parent topic: Data Description Entry Skeleton


The GROUP-USAGE Clause

A GROUP-USAGE clause with a BIT phrase specifies that the group item defined by the subject of the entry is to be treated as an elementary item of usage bit and category boolean, unless specified otherwise.

A GROUP-USAGE clause with a NATIONAL phrase specifies that the group item defined by the subject of the entry is to be treated as an elementary item of usage national and category national, unless otherwise specified.

General Format

GROUP-USAGE syntax diagram

Syntax Rules

  1. The GROUP-USAGE clause may be specified only if the subject of the entry is a group item that is not strongly typed.
  2. When the BIT phrase is specified, USAGE BIT is implied for the subject of the entry. A USAGE clause shall not be specified for the subject of the entry. All elementary items subordinate to the subject of the entry shall be explicitly or implicitly described as usage bit, class and category boolean. All subordinate group items shall be explicitly or implicitly described as GROUP-USAGE BIT.

    The maximum number of characters allowed in the group is 64.

  3. When the NATIONAL phrase is specified, USAGE NATIONAL is implied for the subject of the entry. A USAGE clause shall not be specified for the subject of the entry. All elementary items subordinate to the subject of the entry shall be explicitly or implicitly described as usage national. Any signed numeric data items shall be described with the SIGN IS SEPARATE clause. All subordinate group items shall be explicitly or implicitly described as GROUP-USAGE NATIONAL.

General Rules

  1. When the BIT phrase is specified:
    • The subject of the entry is a bit group and also a bit data item; its class and category are boolean.
    • Unless stated otherwise, a bit group is treated as though it were an elementary data item of usage bit and class and category boolean described with PICTURE 1(m), where m is the bit length of the group.
    • Data items contained within a bit group are allocated in storage in accordance with the rules specified in the topic Aligning Bit Data Items.
  2. When the NATIONAL phrase is specified:
    • The subject of the entry is a national group; its class and category are national.
    • Unless stated otherwise, a national group is treated as though it were an elementary data item of usage national and class and category national described with PICTURE N(m), where m is the length of the group.
      Note: The GROUP-USAGE NATIONAL clause is needed so that groups containing only national characters can be properly truncated and padded with national characters and can be correctly processed for operations such as INSPECT. Without the GROUP-USAGE NATIONAL clause, the content of such a group item would be treated as category alphanumeric, possibly leading to corruption or invalid handling of data.
  3. If a GROUP-USAGE clause is not specified or implied for a group item that is not strongly typed, that group item is an alphanumeric group item.
Parent topic: Data Description Entry Skeleton
Related information
The USAGE Clause
The PICTURE Clause


The JUSTIFIED Clause

The JUSTIFIED clause specifies non-standard positioning of data within a receiving data item.

General Format

Syntax Rules

  1. The JUSTIFIED clause can be specified only at the elementary item level.
  2. JUST is an abbreviation for JUSTIFIED.
  3. The JUSTIFIED clause cannot be specified for any data item described as numeric or for which editing is specified.
  4. The JUSTIFIED clause cannot be specified for an index data item (see the section The USAGE Clause)

    VSC2 MF , or for a pointer data item

    .

  5. OSVS VSC2 MF The JUSTIFIED clause cannot be specified for external or internal floating-point data items.

General Rules

  1. When a receiving data item is described with the JUSTIFIED clause and the sending data item is larger than the receiving data item, the leftmost characters are truncated. When the receiving data item is described with the JUSTIFIED clause and it is larger than the sending data item, the data is aligned at the rightmost character position in the data item with space fill for the leftmost character positions.

    The contents of the sending data item are not taken into account, that is, trailing spaces within the sending data item are not suppressed.

    For example, if a data item PIC X(4) whose value is "A   " (that is, A followed by three spaces) is moved into a data item PIC X(6) JUSTIFIED the result is "  A   ". If the same data item is moved to one with PIC X(3) JUSTIFIED the result is "   " that is, the leftmost character is truncated.

  2. When the JUSTIFIED clause is omitted, the standard rules for aligning data within an elementary item apply. (See the topic Standard Alignment Rules in the chapter Concepts of the COBOL Language.)
Parent topic: Data Description Entry Skeleton
Related information
The USAGE Clause
Standard Alignment Rules


Level Number

The level-number shows the hierarchy of data within a logical record.

In addition, it is used to identify entries for working-storage items, linkage items, condition-names

MF , constant-names

and the RENAMES clause.

General Format

Syntax Rules

  1. A level-number is required as the first element in each data description entry.
  2. Data description entries subordinate to an FD or SD entry must have level-numbers with the values 01 through 49, 66

    MF ,78

    or 88. (See the topic File Description Entry Skeleton.)

  3. Data description entries in the Report Section and Screen Section must have level-numbers with the values 01 through 49

    MF , or 78

  4. Data description entries in the Working-Storage Section

    MF , Local-Storage Section

    and Linkage Section must have level-numbers with the values 01 through 49, 66, 77

    MF , 78

    or 88.

  5. A level-number can be a one- or two-digit number.

General Rules

  1. The level-number 01 identifies the first entry in each record description.
  2. Special level numbers have been assigned to certain entries where there is no real concept of level hierarchy:
    1. The level-number 77 is assigned to identify noncontiguous working-storage data items and noncontiguous linkage data items. It can be used only as described by Format 1 of the data description skeleton earlier in this chapter.
    2. Level number 66 is assigned to identify RENAMES entries and can be used only as described in Format 2 of the data description skeleton earlier in this chapter.
    3. Level number 88 is assigned to entries which define condition-names associated with a conditional variable and can be used only as described in Format 3 of the data description skeleton earlier in this chapter.
    4. MF Level number 78 is assigned to entries which define constant-names. It can be used only as described in Format 4 of the data description skeleton earlier in this chapter.
  3. Multiple level 01 entries subordinate to an FD or SD entry represent implicit redefinitions of the same area.
Parent topic: Data Description Entry Skeleton
Related information
File Description Entry Skeleton


The OCCURS Clause

The OCCURS clause eliminates the need for separate entries for repeated data items and supplies information required for the application of subscripts or indices.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • ODOOSVS – requests OS/VS COBOL compatible processing of the OCCURS DEPENDING ON clause.
    • ODOSLIDE – controls the processing of nested OCCURS DEPENDING ON clauses and fixed data following an OCCURS DEPENDING ON clause.
    • REENTRANT – allows a program to be used in a multi-threaded environment.

Syntax Rules

  1. Where both integer-1 and integer-2 are used, integer-1 must be greater than

    ANS85 OSVS or equal to

    zero and integer-2 must be greater than

    OSVS VSC2 or equal to

    integer-1.

    OSVS VSC2 MF In Format 2, if "integer-1 TO" is omitted, the default value one is assumed.

  2. The data description of data-name-1 must describe an integer.
  3. Data-name-1, data-name-2, data-name-3, ... can be qualified.
  4. Data-name-2 must be either the name of the entry containing the OCCURS clause or the name of an entry subordinate to the entry containing the OCCURS clause.

    OSVS This restriction is removed.

  5. Data-name-3, and so on, must be the name of an entry subordinate to the group item which is the subject of this entry.

    OSVS This restriction is removed.

  6. An INDEXED BY phrase is required if the subject of this entry, or an entry subordinate to this entry, is to be referred to by indexing,

    OSVS VSC2 MF unless it is to be indexed by an index defined for another table (see the section Indexing in the chapter Concepts of the COBOL Language)

    .

    The index-name identified by this clause is not defined elsewhere, and not being data, cannot be associated with any data hierarchy.

  7. A data description entry that contains Format 2 of the OCCURS clause should only be followed, within that record description, by data description entries which are subordinate to it.

    OSVS VSC2 MF A data description entry that contains Format 2 of the OCCURS clause can be followed, within that record description, by data description entries which are not subordinate to it. When the value of the data item referenced by data-name-1 is changed, the position of data items following, but not subordinate to, the table is changed. The data these items contain can be lost.

    MF If the NOODOSLIDE Compiler directive is set, all group items containing the table are considered as always having the maximum number of occurrences, irrespective of the value of data-name-1 and therefore the position of the data items following the table is not changed.

  8. The OCCURS clause cannot be specified in a data description entry that:
    1. Has a 66 or 88 level-number
    2. Describes an item whose size is variable. The size of an item is variable if the data description of any subordinate item contains Format 2 of the OCCURS clause.

      OSVS VSC2 An OCCURS clause can be specified for a data description subordinate to another item with a Format 2 OCCURS clause.

  9. The OCCURS clause should not be specified in a data description entry at the 01 level or as a 77 level-number.

    MF This restriction is removed.

  10. In Format 2, the data item defined by data-name-1 must not occupy a character position within the range of the first character position defined by the data description entry containing the OCCURS clause and the last character position defined by the record description entry containing that OCCURS clause.

    OSVS VSC2 If the ODOSLIDE Compiler directive is set, data-name-1 must have a fixed location.

  11. If data-name-2 is not the subject of this entry, then:
    1. All of the items identified by the data-names in the KEY IS phrase must be within the group item which is the subject of this entry
    2. Items identified by the data-name in the KEY IS phrase must not contain an OCCURS clause
    3. There must not be any entry that contains an OCCURS clause between the items identified by the data-names in the KEY IS phrase and the subject of this entry.
  12. Index-name-1, index-name-2, ... must be unique words within the source element.

    OSVS Index-name-1, index-name-2, ... need not be unique and can be qualified by the data-name which is the subject of this entry

    .

  13. OSVS VSC2 MF The OCCURS clause can be specified for external or internal floating-point data items.
  14. ISO2002 The KEY clause must not be specified for a data item of class object.
  15. NET JVM The Format 3 OCCURS clause must be specified in a data description entry at the 01 level.
  16. NET JVM If the ANY phrase is specifed, it must be specified for all dimensions, whether or not OCCURS is repeated.
  17. NET JVM The subject of the entry for a Format 3 OCCURS clause must be a .NET native type as specified in the topic .NET Native Types in the section .NET Concepts in the Language Fundamentals chapter.

General Rules

  1. The OCCURS clause is used in defining tables and other homogenous sets of repeated data items. Whenever the OCCURS clause is used, the data-name which is the subject of this entry must be either subscripted or indexed whenever it is referred to in a statement other than SEARCH

    MF , SORT

    or USE FOR DEBUGGING. Further, if the subject of this entry is the name of a group item, then all data-names belonging to the group must be subscripted or indexed whenever they are used as operands, except as the object of a REDEFINES clause. (See the topics Subscripting, Indexing and Identifier in the chapter Concepts of the COBOL Language.)

  2. Except for the OCCURS clause itself, all data description clauses associated with an item whose description includes an OCCURS clause apply to each occurrence of the item described.
  3. Data-name-1 must have a fixed location, and must not follow an item that contains an OCCURS DEPENDING ON clause.
  4. The number of occurrences of the subject entry is defined as follows:
    1. In Format 1, the value of integer-2 represents the exact number of occurrences.
    2. In Format 2, the current value of the data item referenced by data-name-1 represents the number of occurrences.

      This format specifies that the subject of this entry has a variable number of occurrences. The value of integer-2 represents the maximum number of occurrences and the value of integer-1 represents the minimum number of occurrences. This does not imply that the length of the subject of the entry is variable, but that the number of occurrences is variable.

      The value of the data item referenced by data-name-1 must fall within the range of integer-1 through integer-2. Reducing the value of this data item makes the contents of data items, whose occurrence numbers now exceed the value of the data item referenced by data-name-1, unpredictable.

  5. ANS85 When a group item, having subordinate to it an entry that specifies Format 2 of the OCCURS clause, is referenced, the part of the table area used in the operation is determined as follows:
    1. If the data item referenced by data-name-1 is outside the group, only that part of the table area that is specified by the value of the data item referenced by data-name-1 at the start of the operation is used.
    2. If the data item referenced by data-name-1 is included in the same group and the group data item is referenced as a sending item, only that part of the table area that is specified by the value of the data item referenced by data-name-1 at the start of the operation is used in the operation. If the group is a receiving item, the maximum length of the group is used.
  6. The KEY IS phrase is used to indicate that the repeated data is arranged in ascending or descending order according to the values contained in data-name-2, data-name-3, and so on. The ascending or descending order is determined according to the rules for comparison of operands (see the topics Comparison of Numeric Operands and Comparison of Nonnumeric Operands in the topic Relation Condition in the chapter Procedure Division). The data-names are listed in their descending order of significance.
  7. The type of storage allocated for index-name-1, index-name-2... depends on whether or not the program is recursive (that is, has a Local-Storage Section defined) and whether the REENTRANT Complier directive has been specified.

    The first of the tables below specifies how storage is allocated for non-recursive programs. The second table specifies how storage is allocated for recursive programs.

    Table 1. Storage Allocated for Index-name in Non-Recursive Program
    Index-name Defined in | Index-name Allocated in
    NOREENTRANT | REENTRANT (1) | REENTRANT (2)
    working storage | working storage | working storage | thread-local
    thread-local | thread-local | thread-local | thread-local
    linkage | working storage | local storage | local storage
    Table 2. Storage Allocated for Index-name in Recursive Program
    Index-name Defined in | Index-name Allocated in
    NOREENTRANT | REENTRANT (1) | REENTRANT (2)
    working storage | working storage | working storage | thread-local
    thread-local | thread-local | thread-local | thread-local
    local storage | local storage | local storage | local storage
    linkage | local storage | local storage | local storage
  8. NET JVM An entry with a Format 3 OCCURS clause defines an array that is mapped directly to a .NET native array. In COBOL, the first array element has the subscript one.
  9. NET JVM If the ANY phrase is specified, a SET statement with either the SIZE phrase or the CONTENT phrase must be executed on the array before an element of the array can be referenced.
  10. NET JVM A Format 3 OCCURS clause that repeats the option containing ANY and integer-2 defines a rectangular array, one in which all rows and columns have the same size.
  11. NET JVM Repetition of the Format 3 OCCURS clause defines a jagged array, or an array of arrays in which the various sub-arrays can have different lengths.
Parent topic: Data Description Entry Skeleton
Related concepts
Nested OCCURS DEPENDING Clauses
Numeric Fields Containing Illegal Characters When Using a DEPENDING ON Phrase of an OCCURS Clause
Related information
Subscripting
Indexing
Identifier
Relation Condition


The PICTURE Clause

The PICTURE clause describes the general characteristics and editing requirements of an elementary item.

General Format

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directive may impact either the syntax or the semantics described in this section.
    • INTLEVEL

Syntax Rules

  1. A PICTURE clause can be specified only at the elementary item level.
  2. A character-string consists of certain allowable combinations of characters in the COBOL character set used as symbols. The allowable combinations determine the category of the elementary item.
  3. The maximum number of characters allowed in the character-string is 30.

    ISO2002 MF OS390 The maximum number of characters allowed in the character-string is 50.

  4. The PICTURE clause must not be specified for the subject of a RENAMES clause.
  5. PIC is an abbreviation for PICTURE.
  6. The asterisk when used as the zero suppression symbol and the clause BLANK WHEN ZERO should not appear in the same entry.

    OSVS This construct is, however, permitted, in which case zero suppression overrides the BLANK WHEN ZERO clause.

  7. An integer in parentheses following a character indicates that the character is repeated the number of times shown by the integer.

General Rules

The categories of data that can be described with a PICTURE clause are: alphabetic, numeric, alphanumeric, alphanumeric edited, numeric edited,

OSVS VSC2 MF external floating-point,

ISO2002 MF and boolean.

General rules within these categories are given below:

Alphabetic Data Rules

  1. The PICTURE character-string can contain only the symbols "A" and "B".

    ANS85 The PICTURE character-string can contain only the symbol "A".

  2. The contents when represented in standard data format must be one or more alphabetic characters.

Numeric Data Rules

  3. The PICTURE character-string can contain only the symbols "9", "P", "S", and "V". The number of digit positions that can be described by the PICTURE character-string must range from 1 through 18.

    ISO2002 OS390 The PICTURE character-string can contain up to 31 digit positions.

    MF The PICTURE character-string can contain up to 18 digit positions by default or if you set INTLEVEL"2", and up to 38 digit positions if you set INTLEVEL"4".

  4. If unsigned, the data in standard data format must be a combination of the Arabic numerals "0", "1", "2", " 3", "4", "5", "6", "7", "8", and "9"; if signed, the item can also contain a "+", "-", or other representation of an operational sign. (See the topic The SIGN Clause.)

Alphanumeric Data Rules

  5. The PICTURE character-string is restricted to certain combinations of the symbols " A", "X", "9", and the item is treated as if the character-string contained all X"s. A PICTURE character-string which contains all A"s or all 9"s does not define an alphanumeric item.
  6. The contents when represented in standard data format can consist of any characters in the computer's character set.

Alphanumeric Edited Data Rules

  7. The PICTURE character-string is restricted to certain combinations of the following symbols: "A", "X", " 9", "B", "0", and "/" as follows:
    1. The character-string must contain at least one "B" and at least one "X" or at least one "0" (zero) and at least one "X" or at least one "/" (slash) and at least one "X", or:
    2. The character-string must contain at least one "0" (zero) and at least one "A" or at least one "/" (slash) and at least one "A".
  8. The contents when represented in standard data format can consist of any characters in the computer's character set.

Numeric Edited Data Rules

  9. The PICTURE character-string is restricted to certain combinations of the symbols "B", "/", "P", "V" , "Z", "0", "9", ",", ".", "*", "+", "-", "CR", "DB", and the currency symbol. The allowable combinations are determined from the order of precedence of symbols and the editing rules as follows:
    1. The number of digit positions that can be represented in the PICTURE character-string must range from 1 through 18.

      ISO2002 OS390 The PICTURE character-string can contain up to 31 digit positions.

      MF The PICTURE character-string can contain up to 18 digit positions by default or if you set INTLEVEL"2", and up to 38 digit positions if you set INTLEVEL"4".

    2. The character-string must contain at least one "0" , "B", "/", "Z", "*", "+", ",", ".", "-", "CR" , "DB", or currency symbol.
  10. The contents of the character positions that represent a digit must be one of the numerals.
  11. If all character positions in the PICTURE character-string are represented by an insertion character, at least one of the insertion characters must be positioned to the left of the decimal point.

External Floating-point Data Items

  12. The PICTURE string must have the following form:

    A sign character must immediately precede both the significand and the exponent.

    A "+" sign indicates that a positive sign will be used in the output to represent positive values and that a negative sign will represent negative values.

    A "-"sign indicates that a blank will be used in the output to represent positive values and that a negative sign will represent negative values.

    Each sign position occupies one byte of storage.

    significand

    The significand can contain the symbols:

    9 . V

    An actual decimal point can be represented with a period while an assumed decimal point is represented by a V. Either an actual or an assumed decimal point must be present in the significand; the decimal point can be leading, embedded or trailing. The significand can contain from 1 to 16 numeric characters.

    E

    Indicates the exponent.

    exponent

    The exponent must be a PIC "99".

  13. The OCCURS, REDEFINES and RENAMES clauses can be associated with external floating-point items.
  14. The SIGN clause is documentary only and has no effect on the representation of the sign.
  15. The SYNCHRONIZED clause is documentary only.
  16. The following clauses are invalid with external floating-point items:

    BLANK WHEN ZERO JUSTIFIED VALUE

Boolean Data Rules

  17. The PICTURE character-string can contain only the symbol "1".
  18. The PICTURE character-string can contain up to 64 digit positions.
  19. Values can be specified in literals with an opening separator B", for example B"1110", where the value is expressed as bits.

Comments:

The size of an elementary item, where size means the number of character positions occupied by the elementary item in standard data format, is determined by the number of allowable symbols that represent character positions. An integer which is enclosed in parentheses following the symbols "A", ",", "X" , "9", "P", "Z", "*", "B", "/", "0", "+", "-", or the currency symbol indicates the number of replications of the symbol. Note that the following symbols can appear only once in a given PICTURE: "S" , "V", ".", "CR", and "DB",

OSVS VSC2 MF "E".

The functions of the symbols used to describe an elementary item are explained as follows:

A | Each "A" in the character-string represents a character position which can contain only a letter of the alphabet or a space.
B | Each "B" in the character-string represents a character position into which the space character will be inserted.
OSVS VSC2 MF E | Marks the start of the exponent in an external floating-point item. The exponent occupies 1 byte of storage at run time.
P Each "P" indicates an assumed decimal scaling position and is used to specify the location of an assumed decimal point when the point is not within the number that appears in the data item. The scaling position character "P" is not counted in the size of the data item. Scaling position characters are counted in determining the maximum number of digit positions (18) in numeric edited items or numeric items. The scaling position character "P" can appear only to the left or right as a continuous string of "P"s within a PICTURE description; since the scaling position character "P" implies an assumed decimal point (to the left of "P" s if "P"s are leftmost PICTURE characters and to the right if "P"s are rightmost PICTURE characters), the assumed decimal point symbol "V" is redundant as either the leftmost or rightmost character within such a PICTURE description.

The character "P" and the insertion character "." (period) cannot both occur in the same PICTURE character-string. If, in any operation involving conversion of data from one form of internal representation to another, the data item being converted is described with the PICTURE character "P", each digit position described by a "P" is considered to contain the value zero, and the size of the data item is considered to include the digit positions so described.

ANS85 In certain operations that reference a data item whose PICTURE character-string contains the symbol "P", the algebraic value of the data item is used rather than the actual character representation of the data item. This algebraic value assumes the decimal point in the prescribed location and zero in place of the digit position specified by the symbol "P". The size of the value is the number of digit positions represented by the PICTURE character-string. These operations are any of the following:

  1. Any operation requiring a numeric sending operand.
  2. An elementary MOVE statement where the sending operand is numeric and its PICTURE character-string contains the symbol "P".
  3. A MOVE statement where the sending operand is numeric edited and its PICTURE character-string contains the symbol "P" and the receiving operand is numeric or numeric edited.
  4. A comparison operation where both operands are numeric.

ANS85 In all other operations the digit positions specified with the symbol "P" are ignored and are not counted in the size of the operand.

S | The letter "S" is used in a character-string to indicate the presence, but neither the representation nor, necessarily, the position of an operational sign; it must be written as the leftmost character in the PICTURE. The "S" is not counted in determining the size (in terms of standard data format characters) of the elementary item unless the entry is subject to a SIGN clause which specifies the optional SEPARATE CHARACTER phrase. (See the topic The SIGN Clause.)
V | The letter "V" is used in a character-string to indicate the location of the assumed decimal point and can only appear once in a character-string. The "V" does not represent a character position and therefore is not counted in the size of the elementary item. When the assumed decimal point is to the right of the rightmost symbol in the string the "V" is redundant.
X | Each "X" in the character-string is used to represent a character position which contains any allowable character from the computer's character set.
Z | Each "Z" in a character-string can only be used to represent the leftmost numeric character positions which will be replaced by a space character when the contents of that character position is zero. Each "Z" is counted in the size of the item.
9 | Each "9" in the character-string represents a character position which contains a numeral and is counted in the size of the item.
0 | Each "0" (zero) in the character-string represents a character position into which the numeral zero will be inserted. The "0" is counted in the size of the item.
/ Each "/" (slash) in the character-string represents a character position into which the slash character will be inserted. The "/" is counted in the size of the item.
, Each "," (comma) in the character-string represents a character position into which the character "," will be inserted. This character position is counted in the size of the item. The insertion character "," must not be the last character in the PICTURE character-string.

ANS85 The insertion character "," can be the last character in the PICTURE character-string.

. When the character "." (period) appears in the character-string it is an editing symbol which represents the decimal point for alignment purposes and, in addition, represents a character position into which the character "." will be inserted. The character "." is counted in the size of the item. For a given source unit the functions of the period and comma are exchanged if the clause DECIMAL-POINT IS COMMA is stated in the Special-Names paragraph. In this exchange the rules for the period apply to the comma and the rules for the comma apply to the period wherever they appear in a PICTURE clause. The insertion character " ." must not be the last character in the PICTURE character-string.

ANS85 The insertion character "." can be the last character in the PICTURE character-string.

+, -, CR, DB | These symbols are used as editing sign control symbols. When used, they represent the character position into which the editing sign control symbol will be placed. The symbols are mutually exclusive in any one character-string and each character used in the symbol is counted in determining the size of the data item.
* Each "*" (asterisk) in the character-string represents a leading numeric character position into which an asterisk will be placed when the contents of that position is zero. Each "*" is counted in the size of the item.
cs A currency symbol represents character positions into which the currency string will be placed during editing. A currency symbol is represented in character-string-1 either by the currency sign or by the currency symbol specified in a CURRENCY SIGN clause in the Special-Names paragraph.

The first occurrence of the currency symbol adds the number of characters in the currency string to the size of the item. Each subsequent occurrence of the currency symbol adds one to the size of the item.

The CURRENCY Compiler directive also affects the currency symbol used.

Two general methods of performing editing in the PICTURE clause are available: insertion or suppression and replacement. Four types of insertion editing are available:

  1. Simple insertion
  2. Special insertion
  3. Fixed insertion
  4. Floating insertion

Two types of suppression and replacement editing are available:

  1. Zero suppression and replacement with spaces
  2. Zero suppression and replacement with asterisks

The type of editing which can be performed upon an item is dependent upon the category to which the item belongs. The table below specifies which type of editing can be performed upon a given category.

Table 1. EditingTypes For Data Categories
Category | Type of Editing
Alphabetic | Simple insertion "B" only 1
Numeric | None
Alphanumeric | None
Alphanumeric edited | Simple insertion "0", "B" and "/"
Numeric edited | All 2
DBCS | Simple insertion
External floating-point | Special insertion
Note:
  1. ANS85 In the ANSI'74 standard, PICTURE clauses containing both "A" and "B" are treated as simple insertion in category Alphabetic. As the ANSI'85 standard does not support "B" in the Alphabetic category, the ANSI'85 standard considers this PICTURE as simple insertion in the Alphanumeric Edited category.
  2. Floating insertion editing and editing by zero suppression and replacement are mutually exclusive in a PICTURE clause. Only one type of replacement can be used with zero suppression in a PICTURE clause.

The "," (comma), "B" (space), "0" (zero), and " /" (slash) are used as the insertion characters. The insertion characters are counted in the size of the item and represent the position in the item into which the character will be inserted.

OSVS VSC2 MF This type of editing is valid for either numeric edited items or external floating-point items.

The "." (period) is used as the insertion character. In addition to being an insertion character it represents the decimal point for alignment purposes. The insertion character used for the actual decimal point is counted in the size of the item. The use of the assumed decimal point, represented by the symbol "V" and the actual decimal point, represented by the insertion character, in the same PICTURE character-string is disallowed. The result of special insertion editing is the appearance of the insertion character in the item in the same position as shown in the character-string.

The currency string and the editing sign control symbols "+" , "-", "CR", "DB" are the insertion characters. Only one currency symbol and only one of the editing sign control symbols can be used in a given PICTURE character-string. When the symbols "CR" or "DB" are used, they represent two character positions in determining the size of the item and they must represent the rightmost character positions that are counted in the size of the item. The symbol "+" or "-", when used, must be either the leftmost or rightmost character position to be counted in the size of the item. The currency symbol must be the leftmost character.

Table 2. Editing Symbols in PICTURE Character-Strings
Editing Symbol in Picture Character-string | Result
 | Data Item Positive or Zero | Data Item Negative
+ | + | -
- | space | -
CR | 2 spaces | CR
DB | 2 spaces | DB

The currency symbol and the editing sign control symbols "+" and "-" are the floating insertion symbols and as such are mutually exclusive in a given PICTURE character-string.

Floating insertion editing is indicated in a PICTURE character-string by using a string of at least two of the floating insertion symbols. This string of floating insertion characters can contain any of the simple insertion characters or have simple insertion characters immediately to the right of this string. These simple insertion characters are part of the floating string.

When the floating insertion character is the currency symbol, this string of floating insertion characters can have one of the editing sign control symbols "+", "-", "CR" or " DB" immediately to the right of this string.

The leftmost character of the floating insertion string represents the leftmost limit of the floating symbol in the data item. The rightmost character of the floating string represents the rightmost limit of the floating symbols in the data item.

The second floating character from the left represents the leftmost limit of the numeric data that can be stored in the data item. Non-zero numeric data can replace all the characters at or to the right of this limit.

Floating insertion editing can be represented in a PICTURE character-string in only two ways. One way is to represent any or all of the leading numeric character positions on the left of the decimal point by the insertion character. The other way is to represent all of the numeric character positions in the PICTURE character-string by the insertion character.

If the insertion characters are only to the left of the decimal point in the PICTURE character-string, the result is that a single floating insertion character will be placed into the character position immediately preceding either the decimal point or the first non-zero digit in the data represented by the insertion symbol string, whichever is farther to the left in the PICTURE character-string. The character positions preceding the insertion character are replaced with spaces.

If all numeric character positions in the PICTURE character-string are represented by the insertion character, the result depends upon the value of the data. If the value is zero, the entire data item will contain spaces. If the value is not zero, the result is the same as when the insertion character is only to the left of the decimal point.

ANS85 If all numeric positions in the PICTURE character string are represented by the insertion character, at least one numeric position must be to the left of the assumed or actual decimal point.

To avoid truncation, the minimum size of the PICTURE character-string for the receiving data item must be the number of characters in the sending data item, plus the number of non-floating insertion characters being edited into the receiving data item, plus one for the floating insertion character.

The suppression of leading zeros in numeric character positions is indicated by the use of the alphabetic character "Z" or the character "*" (asterisk) as suppression symbols in a PICTURE character-string. These symbols are mutually exclusive in a given PICTURE character-string. Each suppression symbol is counted in determining the size of the item. If "Z" is used, the replacement character will be the space and if the asterisk is used, the replacement character will be "*".

Zero suppression and replacement is indicated in a PICTURE character-string by using a string of one or more of the allowable symbols to represent leading numeric character positions which are to be replaced when the associated character position in the data contains a zero. Any of the simple insertion characters embedded in the string of symbols or to the immediate right of this string are part of the string.

Zero suppression can be represented in a PICTURE character-string in only two ways. One way is to represent any or all of the leading numeric character positions to the left of the decimal point by suppression symbols. The other way is to represent all of the numeric character positions in the PICTURE character-string by suppression symbols.

If the suppression symbols appear only to the left of the decimal point, any leading zero in the data which corresponds to a symbol in the string is replaced by the replacement character. Suppression terminates at the first non-zero digit in the data represented by the suppression symbol string or at the decimal point, whichever is encountered first.

If all numeric character positions in the PICTURE character-string are represented by suppression symbols and the value of the data is not zero, the result is the same as if the suppression characters were only to the left of the decimal point. If the value is zero and the suppression symbol is "Z", the entire data item will be spaces. If the value is zero and the suppression symbol is "*", the data item will be all "*" except for the actual decimal point.

The symbols "+", "-", "*", " Z" and the currency symbol, when used as floating replacement characters, are mutually exclusive within a given character-string.

The table below shows the order of precedence when using characters as symbols in a character-string. An "X" at an intersection indicates that the symbol(s) at the top of the column can precede, in a given character-string, the symbol(s) at the left of the row. Arguments appearing in braces indicate that the symbols are mutually exclusive. The currency symbol is indicated by the symbol "cs". At least one of the symbols "A " , "X", "Z", " 9" or "*", or at least two of the symbols "+" , "-" or "cs" must be present in a PICTURE string.

In this table, non-floating insertion symbols "+" and "-" , floating insertion symbols "Z", "*", " +", "-", and "cs", and other symbol "P" appear twice in the PICTURE character precedence chart. The leftmost column and uppermost row for each symbol represents its use to the left of the decimal point position. The second appearance of symbol in the row and column represents its use to the right of the decimal point position.

Table 3. PICTURE Character Precedence Chart
First Symbol |  | Non-Floating Insertion Symbols |  |  |  |  |  |  |  |  |  | Floating Insertion Symbols |  |  |  |  |  | Other Symbols
Second Symbol |  | B | 0 | / | , | . | + - | + - | CR DB | C S | E | Z * | Z * | + - | + - | C S | C S | 9 | A X | S | V | P | P | G | 1
Non-Floating Insertion Symbols | B | X | X | X | X | X |  |  |  | X |  | X | X | X | X | X | X | X | X |  | X |  | X | X |
 | 0 | X | X | X | X | X |  |  |  | X |  | X | X | X | X | X | X | X | X |  | X |  | X |  |
 | / | X | X | X | X | X |  |  |  | X |  | X | X | X | X | X | X | X | X |  | X |  | X |  |
 | , | X | X | X | X | X |  |  |  | X |  | X | X | X | X | X | X | X |  |  | X |  | X |  |
 | . | X | X | X | X | X |  |  |  | X |  | X |  | X |  | X |  | X |  |  |  |  |  |  |
 | + - |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | + - | X | X | X | X | X |  |  |  | X | X | X | X |  |  | X | X | X |  |  | X | X | X |  |
 | CR DB | X | X | X | X | X |  |  |  | X |  | X | X |  |  | X | X | X |  |  | X | X | X |  |
 | CC S |  |  |  |  |  | X |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | E |  |  |  | X | X |  |  |  |  |  |  |  |  |  |  |  | X |  |  | X |  |  |  |
Floating Insertion Symbols | Z * | X | X | X | X |  | X |  |  | X |  | X |  |  |  |  |  |  |  |  |  |  |  |  |
 | Z * | X | X | X | X | X | X |  |  | X |  | X | X |  |  |  |  |  |  |  | X |  | X |  |
 | + - | X | X | X | X |  |  |  |  | X |  |  |  | X |  |  |  |  |  |  |  |  |  |  |
 | + - | X | X | X | X | X |  |  |  | X |  |  |  | X | X |  |  |  |  |  | X |  |  |  |
 | C S | X | X | X | X |  | X |  |  |  |  |  |  |  |  | X |  |  |  |  |  |  |  |  |
 | C S | X | X | X | X | X | X |  |  |  |  |  |  |  |  | X | X |  |  |  | X |  |  |  |
Other Symbols | 9 | X | X | X | X | X | X |  |  | X | X | X |  | X |  | X |  | X | X | X | X |  | X |  |
 | A X | X | X | X |  |  |  |  |  |  |  |  |  |  |  |  |  | X | X |  |  |  |  |  |
 | S |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
 | V | X | X | X | X |  | X |  |  | X |  | X |  | X |  |  |  | X |  | X |  | X |  |  |
 | P | X | X | X | X |  | X |  |  | X |  | X |  | X |  |  |  | X |  | X |  | X |  |  |
 | P |  |  |  |  |  | X |  |  | X |  |  |  |  |  |  |  |  |  | X | X |  | X |  |
 | G | X |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  | X |
 | 1 |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  | X
Parent topic: Data Description Entry Skeleton
Related information
PICTURE Character-strings
The SIGN Clause
The USAGE Clause
Selection of Character Representation And Radix


The PROPERTY Clause

The PROPERTY clause indicates that this data item is a property of the object in which this data description is contained and that GET and/or SET methods are to be generated accordingly.

General Format

Syntax Rules

  1. The PROPERTY clause can be specified only in the Working-Storage Section of a factory definition or an object definition.
  2. The PROPERTY clause must not be specified for data items subordinate to an OCCURS clause.
  3. The PROPERTY clause can be specified only for an elementary item whose name does not require qualification for uniqueness of reference.
  4. The data-name for the subject of the entry must not be the same as a property-name defined in a superclass.
    Note: A property-name may be defined in a superclass either by defining a method or a pair of methods with the PROPERTY phrase or by describing a data description entry with the PROPERTY clause.

General Rules

  1. If the GET phrase is not specified, the PROPERTY clause causes a method to be defined for the containing factory or object.

    If the subject of this entry is of class index, object, or pointer, the implicit definition of this method is as follows:

     METHOD-ID. GET PROPERTY data-name.
 DATA DIVISION.
 LINKAGE SECTION.
 01 LS-data-name data-description.
 PROCEDURE DIVISION RETURNING LS-data-name.
 par-name.
     SET LS-data-name TO data-name
     EXIT METHOD.
 END METHOD.

    If the subject of this entry is of category alphanumeric-edited, national-edited, or numeric-edited, the implicit definition of this method is as follows:

     METHOD-ID. GET PROPERTY data-name.
 DATA DIVISION.
 LINKAGE SECTION.
 01 LS-data-name data-description.
 PROCEDURE DIVISION RETURNING LS-data-name.
 par-name.
     MOVE data-name TO LS-data-name (1:).
     EXIT METHOD.
 END METHOD.
    Note: If the subject of the entry is edited, reference modification of the receiving item as the whole of itself prevents the editing rules from being reapplied to the data.

    Otherwise, the implicit definition of this method is as follows:

     METHOD-ID. GET PROPERTY data-name.
 DATA DIVISION.
 LINKAGE SECTION.
 01 LS-data-name data-description.
 PROCEDURE DIVISION RETURNING LS-data-name.
 par-name.
     MOVE data-name TO LS-data-name
     EXIT METHOD.
 END METHOD.

    where LS-data-name has the data description of the subject of the entry, including its subordinate items, with the exception of:

    • INDEXED BY phrases
    • PROPERTY clauses
    • VALUE clauses
    • a REDEFINES clause in the description of the subject of the entry.
  2. If the SET phrase is not specified, the PROPERTY clause causes a method to be defined for the containing factory or object.

    If the subject of this entry is of class index, object, or pointer, the implicit definition of this method is as follows:

     METHOD-ID. SET PROPERTY data-name.
 DATA DIVISION.
 LINKAGE SECTION.
 01 LS-data-name data-description.
 PROCEDURE DIVISION USING LS-data-name.
 par-name.
     SET data-name TO LS-data-name
     EXIT METHOD.
 END METHOD.

    If the subject of this entry is of category alphanumeric-edited, national-edited, or numeric-edited, the implicit definition of this method is as follows:

     METHOD-ID. SET PROPERTY data-name.
 DATA DIVISION.
 LINKAGE SECTION.
 01 LS-data-name data-description.
 PROCEDURE DIVISION USING LS-data-name.
 par-name.
     MOVE LS-data-name TO data-name (1:).
     EXIT METHOD.
 END METHOD.
    Note: If the subject of the entry is edited, reference modification of the receiving item as the whole of itself prevents the editing rules from being reapplied to the data.

    Otherwise, the implicit definition of this method is as follows:

     METHOD-ID. SET PROPERTY data-name.
 DATA DIVISION.
 LINKAGE SECTION.
 01 LS-data-name data-description.
 PROCEDURE DIVISION USING LS-data-name.
 par-name.
     MOVE LS-data-name TO data-name
     EXIT METHOD.
 END METHOD.

    where LS-data-name has the data description of the subject of the entry, including its subordinate items, with the exception of:

    • INDEXED BY phrases
    • PROPERTY clauses
    • VALUE clauses
    • A REDEFINES clause in the description of the subject of the entry.
Parent topic: Data Description Entry Skeleton


The REDEFINES Clause

The REDEFINES clause allows the same computer storage area to be described by different data description entries.

General Format

Note that level-number and data-name-1

ANS85 or FILLER

are shown in the above format to improve clarity. Level-number, and data-name-1

ANS85 and FILLER

are not part of the REDEFINES clause.

Syntax Rules

  1. The REDEFINES clause, when specified, must immediately follow data-name-1

    ANS85 or FILLER,

    MF or it can follow the PICTURE or USAGE clause

    .

  2. The level-numbers of data-name-1 and data-name-2 must be identical but must not be 66,

    MF 78

    or 88.

  3. This clause must not be used in level 01 entries in the File Section, since multiple level 01 entries subordinate to an FD or SD indicator represent implicit redefinitions of the same areas. (See General Rule 2 in the topic The DATA RECORDS Clause.)

    MF This clause can be used on level 01 entries in the File Section.

  4. OSVS VSC2 The data description for data-name-2 can contain a REDEFINES clause and

    data-name-2 can be subordinate to an entry which contains a REDEFINES clause. Its data description cannot contain an OCCURS clause. However, data-name-2 can be subordinate to an item whose data description entry contains an OCCURS clause. In this case, the reference to data-name-2 in the REDEFINES clause cannot be subscripted or indexed. Neither the original definition nor the redefinition can include an item whose size is variable as defined in the OCCURS clause. (See the topic The OCCURS Clause.)

    OSVS MF The data description for data-name-2 can contain an OCCURS clause.

    MF If the level number is 01, either or both of the original definition and the redefinition can include an item whose size is variable as defined in the OCCURS clause.

  5. No entry having a level-number numerically lower than the level-number of data-name-2 and data-name-1 can occur between the data description entries of data-name-2 and data-name-1.
  6. OSVS VSC2 MF An external or internal floating-point data item can be the subject or object of a REDEFINES clause.
  7. ANS85 Data-name-2 must not be qualified even if it is not unique since no ambiguity of reference exists in this case because of the required placement of the REDEFINES clause .

    OSVS Data-name-2 may be qualified but any qualification specified is ignored.

  8. The entries giving the new description of the character positions must not contain any VALUE clauses except in condition-name entries.
  9. ISO2002 The REDEFINES clause must not be specified for a data item of class object.

    MF The REDEFINES clause may be specified for a data item of class object.

  10. ISO2002 Data-name-2 must not be of class object.

    MF Data-name-2 may be of class object.

  11. ISO2002 MF Data-name-2 must not be described with the ANY LENGTH clause.

General Rules

  1. Redefinition starts at data-name-2 and ends when a level-number less than or equal to that of data-name-2 is encountered.
  2. When the level-number of data-name-1 is other than 01, it must specify the same number of character positions that the data item referenced by data-name-2 contains

    ANS85 OSVS except that the data-name-1 area can be either smaller than the data-name-2 area

    MF or be larger than the data-name-2 area. In this case, extra storage is reserved to provide sufficient storage for the number of character positions in the largest of the redefining or redefined items.

    It is important to observe that the REDEFINES clause specifies the redefinition of a storage area, not of the data items occupying the area.

  3. Multiple redefinitions of the same character positions are permitted. The entries giving the new descriptions of the character positions must follow the entries defining the area being redefined, without intervening entries that define new character positions. Multiple redefinitions of the same character positions must all use the data-name of the entry that originally defined the area

    OSVS VSC2 MF or the data-name of any other preceding redefinition of that entry

    .

  4. Multiple level 01 entries subordinate to any given level indicator (FD or SD) represent implicit redefinitions of the same area.
Parent topic: Data Description Entry Skeleton
Related information
The DATA RECORDS Clause
The OCCURS Clause


The RENAMES Clause

The RENAMES clause permits alternative, possibly overlapping, groupings of elementary items.

General Format

Level-number 66 and data-name-1 are shown in the above format to improve clarity. Level-number and data-name-1 are not part of the RENAMES clause.

Syntax Rules

  1. Any number of RENAMES entries can be written for a logical record.
  2. All RENAMES entries referring to data items within a given logical record must immediately follow the last data description entry of the associated record description entry.
  3. Data-name-2 and data-name-3 must be names of elementary items or groups of elementary items in the same logical record, and cannot be the same data-name. A 66 level entry cannot rename another 66 level entry, nor can it rename a 77,

    MF 78,

    88, or 01 entry.

    MF A 66 level entry may rename another 66 level entry or a level 77 or level 01 entry.

  4. Data-name-1 cannot be used as a qualifier, and can be qualified only by the names of the associated level 01, FD or SD entries. Neither data-name-2 nor data-name-3 can have an OCCURS clause in its data description entry, nor be subordinate to an item that has an OCCURS clause in its data description entry. (See the topic The OCCURS Clause.)
  5. The beginning of the area described by data-name-3 must not be to the left of the beginning of the area described by data-name-2. The end of the area described by data-name-3 must be to the right of the end of the area described by data-name-2. Data-name-3, therefore, cannot be subordinate to data-name-2.
  6. Data-name-2 and data-name-3 can be qualified.
  7. The words THRU and THROUGH are equivalent.
  8. None of the items within the range, including data-name-2 and data-name-3, if specified, can be an item whose size is variable as defined in the topic The OCCURS Clause.

General Rules

  1. When data-name-3 is specified, data-name-1 is a group item which includes all elementary items starting with data-name-2 (if data-name-2 is an elementary item) or the first elementary item in data-name-2 (if data-name-2 is a group item), and concluding with data-name-3 (if data-name-3 is an elementary item) or the last elementary item in data-name-3 (if data-name-3 is a group item).
  2. When data-name-3 is not specified, all of the attributes of data-name-2 become the data attributes for data-name-1.
  3. OSVS When data-name-2 and data-name-3 are not explicitly qualified and when no ambiguity of reference exists, implied qualification of the 01 level item is used.
Parent topic: Data Description Entry Skeleton
Related information
The OCCURS Clause


The SIGN Clause

The SIGN clause specifies the position and the mode of representation of the operational sign when it is necessary to describe these properties explicitly.

General Format

Syntax Rules

  1. The SIGN clause can be specified only for a numeric data description entry whose PICTURE contains the character "S" , or a group item containing at least one such numeric data description entry.
  2. The numeric data description entries to which the SIGN clause applies must be described, implicitly or explicitly, as USAGE IS DISPLAY.
  3. At most one SIGN clause can apply to any given numeric data description entry.

    ANS85 This rule is removed.

  4. If the CODE-SET clause is specified, any signed numeric data description entries associated with that file description entry must be described with the SIGN IS SEPARATE clause.

    MF This restriction is not enforced. See the topic The CODE-SET Clause.

General Rules

  1. The optional SIGN clause, if present, specifies the position and the mode of representation of the operational sign for the numeric data description entry to which it applies, or for each numeric data description entry subordinate to the group to which it applies. The SIGN clause applies only to numeric data description entries whose PICTURE contains the character "S"; the "S" indicates the presence of, but neither the representation nor, necessarily, the position of the operational sign.
  2. A numeric data description entry whose PICTURE contains the character "S", but to which no optional SIGN clause applies, has an operational sign, but neither the representation nor, necessarily, the position of the operational sign is specified by the character "S". In this (default) case, General Rules 3 through 5 do not apply to such signed numeric data items. The representation of the default operational sign is defined in the topic Selection of Character Representation and Radix in the chapter Concepts of the COBOL Language.
  3. If the optional SEPARATE CHARACTER phrase is not present, then:
    1. The operational sign is presumed to be associated with the leading (or, respectively, trailing) digit position of the elementary numeric data item in a manner defined in the topic Selection of Character Representation and Radix in the chapter Concepts of the COBOL Language.
    2. The letter "S" in a PICTURE character-string is not counted in determining the size of the item (in terms of standard data format characters).
  4. If the optional SEPARATE CHARACTER phrase is present, then:
    1. The operational sign is presumed to be the leading (or, respectively, trailing) character position of the elementary numeric data item; this character position is not a digit position.
    2. The letter "S" in a PICTURE character-string is counted in determining the size of the item (in terms of standard data format characters).
    3. The operational signs for positive and negative are the standard data format characters "+" and "-", respectively.
  5. Every numeric data description entry whose PICTURE contains the character "S" is a signed numeric data description entry. If a SIGN clause applies to such an entry and conversion is necessary for purposes of computation or comparisons, conversion takes place automatically.
  6. ANS85 If a SIGN clause is specified for an item (either an elementary numeric data description entry or a group item) which is subordinate to a group item for which a SIGN clause is also specified, then the SIGN clause specified in the subordinate item takes precedence.
  7. OSVS VSC2 MF The SIGN clause is treated as documentary for external floating-point items. For internal floating-point items, the SIGN clause is invalid and will result in a diagnostic message.
Parent topic: Data Description Entry Skeleton
Related information
The CODE-SET Clause
Selection of Character Representation and Radix


The SYNCHRONIZED Clause

The SYNCHRONIZED clause specifies the alignment of an elementary item on the natural boundaries of the computer memory.

XOPEN Although it is a part of the standard COBOL definition, this feature is explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

General Format

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directive may impact either the syntax or the semantics described in this section.
    • IBMCOMP - When NOIBMCOMP is specified, the SYNCHRONIZED clause is treated as documentary only.

Syntax Rules

  1. This clause should appear only with an elementary item.

    OSVS VSC2 The SYNCHRONIZED clause can appear with a non-elementary item.

  2. SYNC is an abbreviation for SYNCHRONIZED.

General Rules

  1. SYNCHRONIZED RIGHT specifies that the elementary item is to be positioned so that it terminates on the right character position of the natural boundary in which the elementary item is placed.

    It takes effect only if the IBMCOMP Compiler directive is set.

  2. Specification of the LEFT phrase in the SYNCHRONIZED clause has no effect.
  3. The effect of the SYNCHRONIZED clause is, by definition, implementation-dependent.
  4. This clause specifies that the subject data item is to be aligned in the computer so that no other data item occupies any of the character positions between the leftmost and rightmost natural boundaries of the computer memory which delimits this data item.

    If the number of character positions required to store this data item is less than the number of character positions between those natural boundaries, the unused character positions (or portions thereof) must not be used for any other data item. Such unused character positions are, however, included in:

    1. The size of any group item(s) to which the elementary item belongs, and:
    2. The character positions redefined when this data item is the object of a REDEFINES clause.

    Thus the size of an elementary item is unchanged by the SYNCHRONIZED clause, but extra character positions are assigned by the use of the clause.

  5. SYNCHRONIZED not followed by either RIGHT or LEFT specifies that the elementary item is to be positioned between natural boundaries so that it uses the elementary data item efficiently.
  6. Whenever a SYNCHRONIZED item is referenced , the original size of the item, as shown in the PICTURE clause, is used in determining any action that depends on size, such as justification, truncation or overflow.
  7. If the data description of an item contains the SYNCHRONIZED clause and an operational sign, the sign of the item appears in the normal operational sign position, regardless of whether the item is SYNCHRONIZED LEFT or SYNCHRONIZED RIGHT.
  8. When the SYNCHRONIZED clause is specified in a data description entry of a data item that also contains an OCCURS clause, or in a data description entry of a data item subordinate to a data description entry that contains an OCCURS clause, then:
    1. Each occurrence of the data item is SYNCHRONIZED.
    2. Any implicit FILLER generated for other data items within that same table is generated for each occurrence of those data items.
  9. OSVS VSC2 If the SYNCHRONIZED clause is specified with a non-elementary item, then the clause applies to all the items subordinate to that non-elementary item.
  10. The effect of using the SYNCHRONIZED clause is discussed in the topic Selection of Character Representation and Radix in the chapter Concepts of the COBOL Language.
Parent topic: Data Description Entry Skeleton
Related information
Selection of Character Representation and Radix


The TYPEDEF Clause

The TYPEDEF clause defines a record as a programmer-defined type definition.

General Format

Syntax Rules

  1. The TYPEDEF clause can be specified only in data description entries whose level-number is 01.
  2. If TYPEDEF is specified, the following clauses cannot be specified:
    • EXTERNAL
    • GLOBAL
    • OCCURS
    • REDEFINES
    • VALUE

    If the TYPEDEF clause is specified for a group item, then subordinate items can be specified with OCCURS or REDEFINES clauses.

    The VALUE clause cannot be specified either in the data descriptions specifying the TYPEDEF clause or in any subordinate item except for condition-names (88 level entries) within the TYPEDEF structure.

  3. If the TYPEDEF clause is specified for a data description, then that same data description must include a data-name, that is, it must not be specified with either an implicit or explicit FILLER clause.
  4. If a TYPEDEF clause is specified in a call prototype (a program with the EXTERNAL clause in its Program-ID paragraph) then that TYPEDEF can be referenced in any subsequent source line of the compilation group.

General Rules

  1. The purpose of using the TYPEDEF clause is to create a programmer-defined usage or structure that can subsequently be referenced in the USAGE clause.
  2. A record declared with the TYPEDEF clause does not allocate any storage, but declares that data-name-1 can be specified in a subsequent data description entry as typedef-name-1.
Parent topic: Data Description Entry Skeleton
Related concepts
SAME AS Clause Not Available When Defining Data Structures


The USAGE Clause

The USAGE clause specifies the format of a data item in the computer storage.

General Format

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • COBOL370 – controls whether four or eight bytes of storage are allocated to USAGE PROCEDURE-POINTER data items.
    • COMP-5 – controls the handling of the operational sign when storing into a USAGE COMP-5 data item.
    • IBMCOMP – controls the storage allocated for USAGE COMP and USAGE COMP-5 data items.

Syntax Rules

  1. The USAGE clause may be written in any data description entry with a level number other than 66 or 88.
  2. If the USAGE clause is written in the data description entry for a group item, it may also be written in the data description entry for any subordinate elementary item or group item, but the same usage must be specified in both entries.
  3. An elementary data item whose declaration contains, or an elementary data item subordinate to a group item whose declaration contains, a USAGE clause specifying COMPUTATIONAL

    ANS85 , BINARY, PACKED-DECIMAL

    OSVS VSC2 MF XOPEN , COMPUTATIONAL-3

    OSVS VSC2 MF , COMPUTATIONAL-4

    MF XOPEN OS390 , or COMPUTATIONAL-5

    must be declared with a PICTURE character-string that describes a numeric item (i.e. a PICTURE character-string that contains only the symbols "P", "S", "V", and "9"). See the topic The PICTURE Clause.

    MF An elementary data item whose declaration contains no USAGE clause and that is subordinate to a group item whose declaration contains a USAGE clause specifying a format from the list may be declared with a PICTURE character-string that describes an alphabetic, alphanumeric, alphanumeric-edited or numeric-edited data item.

  4. MF XOPEN OS390 An elementary data item whose declaration contains, or an elementary data item subordinate to a group item whose declaration contains, a USAGE clause specifying COMPUTATIONAL-5

    MF or COMPUTATIONAL-X

    must be declared with a picture character-string that describes a numeric item

    MF or describes an alphanumeric item with a size of between one and eight bytes inclusive. If it describes an alphanumeric item of size 1, 2, 3, 4, 5, 6, 7, or 8 bytes, then this is equivalent to specifying an integer item with 2, 4, 7, 9, 12, 14, 16 or 18 decimal digit positions respectively

    .

    MF When COMPUTATIONAL-X is specified and the PICTURE character-string describes a numeric item, then that item must be unsigned.

  5. The BLANK WHEN ZERO, JUSTIFIED and SIGN clauses must not be specified for data items whose usage is not explicitly or implicitly DISPLAY.
  6. The SYNCHRONIZED and VALUE clauses must not be specified for data items whose usage is INDEX.

    OSVS VSC2 MF The SYNCHRONIZED clause can be specified for data items whose usage is INDEX.

  7. COMP is an abbreviation for COMPUTATIONAL.

    OSVS VSC2 MF COMP-1 is an abbreviation for COMPUTATIONAL-1.

    OSVS VSC2 MF COMP-2 is an abbreviation for COMPUTATIONAL-2.

    OSVS VSC2 MF XOPEN COMP-3 is an abbreviation for COMPUTATIONAL-3.

    OSVS VSC2 MF COMP-4 is an abbreviation for COMPUTATIONAL-4.

    MF XOPEN OS390 COMP-5 is an abbreviation for COMPUTATIONAL-5.

    MF COMP-X is an abbreviation for COMPUTATIONAL-X.

  8. An index item can be referenced explicitly only in a SEARCH or SET statement, a relation condition, the USING phrase of a Procedure Division,

    OSVS VSC2 MF the USING statement of an ENTRY statement,

    ANS85 an intrinsic function argument

    ISO2002 MF the USING phrase of an INVOKE statement, an inline method invocation argument

    ANS85 an INITIALIZE statement

    or the USING phrase of a CALL statement.

  9. ISO2002 VSC2 MF COB370 ISO2002 VSC2 MF A pointer

    MF COB370 or procedure-pointer

    VSC2 MF item can be referenced explicitly only in a SET statement, a relation condition, a CALL statement, the USING phrase of a Procedure Division, the USING statement of an ENTRY statement

    ISO2002 an INVOKE statement, the argument list of an inline invocation of a method, the argument list of a function,

  10. An elementary data item described with usage INDEX,

    ISO2002 OBJECT,

    VSC2 MF POINTER,

    MF COB370 or PROCEDURE-POINTER

    MF EVENT-POINTER, MONITOR-POINTER, MUTEX-POINTER, PROCEDURE-POINTER, SEMAPHORE-POINTER or THREAD-POINTER

    clause must not be a conditional variable.

  11. MF Typedef-name-1 must be previously defined in the same source file as a record with the TYPEDEF clause.
  12. MF If USAGE typedef-name-1 is specified, the following clauses cannot also be specified:
    • BLANK
    • JUSTIFIED
    • PICTURE
    • SIGN
    • SYNCHRONIZED
    • VALUE
  13. MF It is an error to specify USAGE typedef-name-1 if there is an explicit USAGE clause at a higher level in the same hierarchy.
  14. MF It is an error to specify any subordinate items (items with a higher level number other than 78) immediately following an item defined with USAGE typedef-name-1.
  15. ISO2002 The USAGE OBJECT REFERENCE clause must not be specified in the data description entry for a group item, but may be specified on subordinate elementary data items.
  16. ISO2002 The USAGE OBJECT REFERENCE clause must not be specified in the File Section.

    MF The USAGE OBJECT REFERENCE clause can be specified in the File Section.

    Note: Whether the object reference still references an active object depends on the application logic.
  17. ISO2002 The ACTIVE-CLASS phrase can be specified only in a factory definition, object definition, or method definition.
  18. MF A data item whose usage is EVENT-POINTER can be referenced explicitly only in a CLOSE statement, an OPEN statement, a SET statement, a WAIT statement or a USING phrase.
  19. MF A data item whose usage is MONITOR-POINTER, MUTEX-POINTER, or SEMAPHORE-POINTER can be referenced explicitly only in a CLOSE statement, an OPEN statement, a SET statement or a USING phrase.
  20. MF A data item whose usage is THREAD-POINTER can be referenced explicitly only in a START statement, a WAIT statement or a USING phrase.
  21. MF An elementary data item whose description contains, or an elementary data item subordinate to a group item whose description contains, a USAGE NATIONAL clause must be declared with a picture character-string that describes a national or national-edited data item.
  22. MF When a USAGE clause is not specified for an elementary data item or for any group to which the data item belongs:
    1. if the explicit or implicit picture character-string contains the symbol 'N', a USAGE NATIONAL clause is implied;
    2. otherwise, a USAGE DISPLAY clause is implied.
  23. MF A USAGE clause with the OBJECT REFERENCE, POINTER, or PROGRAM-POINTER phrase must be specified only for an elementary data item with level 1.

    This restriction is not enforced.

  24. MF If program-prototype-name-1 is specified, the TYPEDEF clause must be specified for the subject of the entry.

    This restriction is not enforced.

  25. MF The NATIONAL phrase must be specified in a USAGE clause associated with an elementary data item whose explicit or implicit picture character-string contains the symbol 'N'.
  26. NET JVM A USAGE clause with the CONDITION-VALUE phrase must be specified only for an elementary data item with level 1.
  27. NET JVM If the EVENT phrase is specified, then class-name-1 shall reference a delegate definition and the FACTORY phrase shall not be specified.

General Rules

  1. If the USAGE clause is written at the group level, it applies to each elementary item in the group

    MF except when there is a PICTURE clause and the data item described is non-numeric

  2. The USAGE clause specifies the manner in which a data item is represented in the storage of the computer. It does not affect the use of the data item, although the specifications for some statements in the Procedure Division may restrict the USAGE clause of the operands referred to. The USAGE clause may affect the radix or type of character representation of the item. See the section Selection of Character Representation and Radix in the chapter Concepts of the COBOL Language for more details of the format of each usage.
  3. The USAGE IS BINARY clause specifies that a radix of 2 is used to represent a numeric item in the storage of the computer. This clause is equivalent to specifying USAGE IS COMPUTATIONAL.
  4. The USAGE IS PACKED-DECIMAL clause specifies that a radix of 10 is used to represent a numeric item in the storage of the computer. Furthermore, this clause specifies that each digit position must occupy the minimum possible configuration in computer storage.

    OSVS VSC2 MF XOPEN This clause is equivalent to specifying USAGE IS COMPUTATIONAL-3.

  5. The USAGE IS DISPLAY clause (whether specified explicitly or implicitly) specifies that a standard data format is used to represent a data item in the storage of the computer, and that the data item is aligned on a character boundary.
  6. OSVS VSC2 MF The USAGE IS DISPLAY clause is valid for the following types of items:
    • Alphabetic
    • Alphanumeric
    • Alphanumeric edited
    • Numeric edited
    • External floating-point
    • External decimal (numeric)
  7. The USAGE IS INDEX clause specifies that a data item is an index data item and contains a value which must correspond to an occurrence number of a table element.
  8. When a MOVE statement or an input-output statement that references a group item that contains an index,

    VSC2 MF or pointer,

    MF COB370 or procedure-pointer

    data item is executed, no conversion of the index,

    VSC2 MF or pointer

    MF COB370 or procedure-pointer

    data item takes place.

  9. OSVS VSC2 MF The USAGE IS COMPUTATIONAL-4 clause is equivalent to specifying USAGE IS COMPUTATIONAL.
  10. VSC2 MF The USAGE IS POINTER clause identifies a data item in which you can store the address of a data item (see the topic The SET Statement).
  11. MF COB370 The USAGE IS PROCEDURE-POINTER clause specifies that a data item is a procedure pointer data item in which you can store the address of a procedure. (See the topic The SET Statement.) The procedure can be written in any language: if COBOL, it represents the Procedure Division of a program that is not nested and identified by either:
    • The program-name of the Program-ID paragraph; or
    • The entry-name of an ENTRY statement.
  12. MF If typedef-name-1 was specified as an elementary item, then the USAGE typedef-name-1 clause specifies an elementary item with the same attributes as the programmer-defined usage referenced by typedef-name-1.
  13. MF If typedef-name-1 was specified as a group item, then the USAGE typedef-name-1 clause specifies a group item with an identical structure. The effect is as if the data declarations subordinate to the data description entry identified by typedef-name-1 had been specified identically, subordinate to the item declared with the USAGE typedef-name-1 clause. Data-names of the subordinate data items are identical to those declared within the programmer-defined structure referenced by typedef-name-1 and can be uniquely referenced using qualification.
  14. ISO2002 MF A data item described with a USAGE OBJECT REFERENCE clause is called an object reference. An object reference is a data item of class object and category object-reference. It must contain either null or a reference to an object, subject to the following rules:
    1. The amount of storage allocated for an object reference data item is four bytes.
    2. If none of the optional phrases is specified, this data item is called a universal object reference. Its content may be a reference to any object.
    3. If interface-name-1 is specified, the object referenced by this data item must implement interface-name-1.
    4. If class-name-1 is specified, the object referenced by this data item must be an object of class-name-1 or of a subclass of class-name-1, subject to the following rules:
      1. If the ONLY phrase is not specified:
        1. If the FACTORY phrase is specified, the object referenced by this data item must be the factory object of the specified class or of a subclass of the specified class.
        2. If the FACTORY phrase is not specified, the object referenced by this data item must be an object of the specified class or of a subclass of the specified class.
      2. If the ONLY phrase is specified:
        1. If the FACTORY phrase is specified, the object referenced by this data item must be the factory object of the specified class.
        2. If the FACTORY phrase is not specified, the object referenced by this data item must be an object of the specified class.
    5. If ACTIVE-CLASS is specified, the object referenced by this data item must be an object of the class of the object that was used to invoke the method in which the object referenced is specified, subject to the following rules:
      1. If the FACTORY phrase is specified, the object referenced by this data item must be the factory object of that class.
      2. If the FACTORY phrase is not specified, the object referenced by this data item must be an object of that class.
  15. MF The USAGE IS EVENT-POINTER clause identifies an synchronization data item that flags an occurrence of a software event. An event data item has a value of either TRUE or FALSE.
  16. MF The USAGE IS MONITOR-POINTER clause identifies a synchronization data item, known as a monitor, on which one can request read locks, browse locks, and write locks.
    Note: A monitor is typically used to protect a data structure that different threads might want to read from or read from and write to.
  17. MF The USAGE IS MUTEX-POINTER clause identifies a synchronization data item, known as a mutex, that can be used to protect critical sections in a multi-threaded application. A mutex data item has a value of either ON or OFF. Only one thread can have a mutex data item in the ON state at a time.
  18. MF The USAGE IS SEMAPHORE-POINTER clause identifies a counting synchronization data item that cannot go below zero.
  19. MF The USAGE IS THREAD-POINTER clause identifies a data item in which you can store the handle for a thread.
  20. ISO2002 MF The implicit or explicit USAGE IS NATIONAL clause identifies a data item that is stored in the computer in national-coded characters and aligned on a character boundary. National characters are represented in the storage of the computer as characters of a uniform size. See your COBOL system documentation on national data (UNICODE) for further information.
  21. ISO2002 MF The USAGE IS BINARY-CHAR, USAGE IS BINARY-SHORT, USAGE IS BINARY-LONG and USAGE IS BINARY-DOUBLE clauses identify a numeric data item that has a radix of 2 in the storage of the computer. These usages are equivalent to specifying USAGE IS COMP-5 with the picture character-strings as shown below. An S is included in the equivalent picture character-string unless the UNSIGNED phrase is specified in the USAGE clause.
    USAGE | Equivalent PICTURE character-string
    BINARY-CHAR | [S]9(2)
    BINARY-SHORT | [S]9(4)
    BINARY-LONG | [S]9(9)
    BINARY-DOUBLE | [S] 9(18)
  22. ISO2002 MF The USAGE IS FLOAT-SHORT clause is equivalent to specifying USAGE IS COMPUTATIONAL-1.
  23. ISO2002 MF The USAGE IS FLOAT-LONG clause is equivalent to specifying USAGE IS COMPUTATIONAL-2.
  24. ISO2002 MF A data description entry that specifies the USAGE PROGRAM-POINTER clause specifies a procedure-pointer data item, also called a program-pointer and a procedure-pointer, that may contain the address of a program. (See the topic The SET Statement.) The procedure can be written in any language: if COBOL, it represents the Procedure Division of a program that is not nested and identified by one of :
    • The program-name of the Program-ID paragraph
    • The entry-name of an ENTRY statement.
  25. ISO2002 MF If program-prototype-name-1 is specified, this data item is a restricted program-pointer. A restricted programpointer must contain only the predefined address NULL or the address of a program with the same signature as that identified by the specified program-prototype-name.
  26. NET JVM The USAGE IS CONDITION-VALUE clause specifies a boolean data item that can have the value TRUE or FALSE. A CONDITION-VALUE boolean data item maps onto the .NET framework System.Boolean type, so data items with this usage can be passed to methods that accept System.Boolean parameters.
  27. NET JVM If the class-name specified in the USAGE IS OBJECT REFERENCE class-name clause is a value type, a compiler warning is produced. The item will be treated as a value type, i.e. no reference is produced.
  28. NET JVM The USAGE IS class-name clause phrase specifies:
    • If class-name references a reference type, this is exactly equivalent to USAGE OBJECT REFERENCE class-name-1. The data item represents a reference to an object allocated on the heap, or the value NULL.
    • If class-name references a value type, this clause specifies a data item that is a value type.
  29. NET JVM If the EVENT phrase is specified, the two methods add_ChangeEvent and remove_ChangeEvent are automatically created. These methods can be used, respectively, to hook a new method into the delegate, and subsequently to remove it.
  30. ISO2002 MF The USAGE BIT clause specifies that bits are used to represent a boolean data item. A data item described with USAGE BIT is a bit data item. See the topic Aligning Bit Data Items for information on how boolean data items are aligned.
Parent topic: Data Description Entry Skeleton
Related concepts
SAME AS Clause Not Available When Defining Data Structures
Related information
The PICTURE Clause
Selection of Character Representation and Radix
The SET Statement
Aligning Bit Data Items


The VALUE Clause

The VALUE clause defines the value of constants, the initial value of working storage and local storage items, and the values associated with a condition name.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

General Formats for Format 4

General Formats for Format 5

Syntax Rules for All Formats

  1. If a signed numeric literal is specified, the subject of the entry must be a signed numeric data item.
  2. If the category of the subject of the entry is numeric, all literals in the VALUE clause must be numeric and have a value that is within the range of values indicated by the PICTURE clause or the USAGE clause. If the usage is other than float-short or float-long this value must not require truncation of non-zero digits. This value must have the digit zero in each position that corresponds to a picture character symbol 'P'.
  3. If the item is of class alphabetic or alphanumeric, literals in the VALUE clause must be alphanumeric literals. Alphanumeric literals in the VALUE clause of an elementary item must not exceed the size indicated by an explicit PICTURE clause. Alphanumeric literals in the VALUE clause of an alphanumeric group item must not exceed the size of the group item.
  4. If the item is of class national, literals in the VALUE clause must be national literals. National literals in the VALUE clause of an elementary item must not exceed the size indicated by an explicit PICTURE clause. National literals in the VALUE clause of a national group item must not exceed the size of the group item.

Syntax Rules for Formats 1 and 4

  5. The VALUE clause must not be specified in a data description entry that contains a REDEFINES clause or in an entry that is subordinate to an entry containing a REDEFINES clause.
  6. If the VALUE clause is specified at the group level, the literal must be of the same category as the group item or must be a figurative constant that is permitted in a MOVE statement to a receiving item of that category. The VALUE clause cannot be specified at subordinate levels within this group.
  7. If a VALUE clause is specified at the group level, subordinate items within that group must not be described with a JUSTIFIED or SYNCHRONIZED clause, and all data items subordinate to an alphanumeric group item must be explicitly or implicitly described with USAGE DISPLAY.

Syntax Rules for Format 1

  8. OSVS VALUES ARE can be used with Format 1.
  9. OSVS VSC2 MF The VALUE clause may not be used with external floating-point data items.

    MF The VALUE clause may be used with external floating-point data items.

  10. OSVS VSC2 MF The VALUE clause may be used for an internal floating-point data item, that is an item defined with USAGE COMP-1 or USAGE COMP-2. In this case literal-1 must either be a floating-point literal, the figurative constant ZERO, or a numeric literal representing the value zero.

Syntax Rules for Format 2

  11. The words THRU and THROUGH are equivalent.
  12. Any number of Format 2 entries can be written for a data item.
  13. Format 2 must be used only in connection with a condition-name.
  14. In a condition-name entry, the VALUE clause is required. The VALUE clause and the condition-name itself are the only two clauses permitted in the entry.
  15. Literal-2 must be less than literal-3.
  16. OSVS VSC2 MF Format 2 may be used to define a conditional-variable associated with an internal floating-point data item, but not an external floating-point data item. In this case, literal-2 and literal-3 must be floating-point literals, the figurative constant ZERO, or numeric literals representing the value zero.

    MF Format 2 may be used to define a condition-variable associated with an external floating-point data item.

  17. ISO2002 MF Literal-4 must not be equal to any literal-2, and in any literal-2 THROUGH literal-3 pair, literal-4 cannot be greater than or equal to literal-2 and less than or equal to literal-3.

Syntax Rules for Format 3

  18. MF All identifiers must have been defined before the declaration of the level 78 item. If either identifier-1 or identifier-3 (LENGTH parameters) is a group item, the definition of that group must have been completed before the level 78 declaration, by the appearance of another data item at the same or lower level number.

Syntax Rules for Format 4

  19. ISO2002 MF In Format 4 (level 78) the VALUE clause may be omitted if the item is specified in an ENUM definition.
  20. ISO2002 MF A data description entry that contains the VALUE clause must contain an OCCURS clause or be subordinate to a data description entry that contains an OCCURS clause.
  21. ISO2002 MF Subscript-1 and subscript-2 must be integer numeric literals.
  22. ISO2002 MF In one FROM phrase, there must be one subscript-1 specified for each OCCURS clause for the subject of the entry or superordinate to that entry, specified in the same order as a subscripted reference to the subject of the entry would be specified. Each instance of subscript-1 must not exceed the maximum number of occurrences specified in the OCCURS clause associated with that instance.
  23. ISO2002 MF If the TO phrase is specified, there must be one subscript-2 specified for each OCCURS clause for the subject of the entry or superordinate to that entry, specified in the same order as a subscripted reference to the subject of the entry would be specified. Each instance of subscript-2 must not exceed the maximum number of occurrences specified in the OCCURS clause associated with that instance. The specification of subscript-2 in one TO phrase must be such that the table element associated with subscript-2 is the same occurrence or a successive occurrence of the table element associated with the corresponding subscript-1.

Syntax Rules for Format 5

  24. NET JVM Format 5 must be used only in conjunction with USAGE CONDITION-VALUE.

General Rules for Formats 1, 2 and 4

  1. The VALUE clause must not conflict with other clauses in the data description of the item or in the data description within the hierarchy of the item. The following rules apply:
    1. If the literal defines the value of a data item, the literal is aligned in the data item according to the standard alignment rules. (See the topic Standard Alignment Rules in the chapter Concepts of the COBOL Language.)
    2. If the category of the item is alphabetic, alphanumeric, alphanumeric edited or numeric edited all literals in the VALUE clause must be nonnumeric. The literal is aligned in the data item as if the data item had been described as alphanumeric. (See the topic Standard Alignment Rules in the chapter Concepts of the COBOL Language.) Editing characters in the PICTURE clause are included in determining the size of the data item (see the topic The PICTURE Clause) but have no effect on initialization of the data item. Therefore, the programmer is responsible for specifying the value of a literal associated with an edited data item in edited form.

      MF If the item is numeric edited, the value can be a numeric literal or a nonnumeric literal. If the value is a numeric literal, the value contained in the item will be the same as if the numeric literal were moved to the numeric edited item.

    3. Initialization takes place independent of any BLANK WHEN ZERO or JUSTIFIED clause that can be specified.

General Rules for Data-Item (Format 1)

  2. Rules governing the use of the VALUE clause in data item entries differ with the respective sections of the Data Division:
    1. In the Working-Storage Section

      ISO2002 MF and Local-Storage Section,

      the VALUE clause can be used to specify the initial value of a data item, in which case the clause causes the item to assume the specified value at the time the runtime element is placed into its initial state. If the VALUE clause is not used in an item's description, the initial value of that data item is undefined.

    2. In the File Section and the Linkage Section,

      OS390 and Local-Storage Section,

      the VALUE clause can be used in data item entries, but it takes effect only when an INITIALIZE statement that applies to the entries is executed.

  4. If the VALUE clause is specified in an entry at the group level the group area is initialized without consideration for the individual elementary or group items contained within this group.
  5. VSC2 MF The figurative constant NULL can be specified in the VALUE clause only if the data item is defined with USAGE POINTER or USAGE PROCEDURE-POINTER. This is the only value you can specify in the VALUE clause for such an item. The effect is to set the pointer in such a way that it is guaranteed not to point to any data item.
  6. ANS85 A VALUE clause specified in a data description entry that contains an OCCURS clause, or in an entry that is subordinate to an OCCURS clause, causes every occurrence of the associated data item to be assigned the specified value.
  7. ANS85 If a VALUE clause is specified in a data description entry of a data item which is associated with a variable occurrence data item, the initialization of the data item behaves as if the value of the data item referenced by the DEPENDING ON phrase in the OCCURS clause specified for the variable occurrence data item is set to the maximum number of occurrences as specified by that OCCURS clause. A data item is associated with a variable occurrence data item in any of the following cases:
    1. It is a group data item which contains a variable occurrence data item.
    2. It is a variable occurrence data item.
    3. It is a data item that is subordinate to a variable occurrence data item.

    If a VALUE clause is associated with the data item referenced by a DEPENDING ON phrase, that value is considered to be placed in the data item after the variable occurrence data item is initialized.

  8. ISO2002 A data item of class object is initialized to null. The initial value takes effect when VALUE clauses take effect and when storage for the data item is allocated.
  9. ISO2002 A data item of class pointer is initialized to null. The initial value takes effect when VALUE clauses take effect and when storage for the data item is allocated.

Condition-name Rules (Format 2)

  10. In a condition-name entry, the VALUE clause is required. The VALUE clause and the condition-name itself are the only two clauses permitted in the entry. The characteristics of a condition-name are implicitly those of its conditional variable.
  11. Format 2 can be used only in connection with condition-names. Wherever the THRU phrase is used, literal-2 must be less than literal-3.
  12. The FALSE phrase is meaningful only if the associated condition-name is referenced in a SET condition-name TO FALSE statement. (See the topic The SET Statement.)

Constant-Name Rules (Format 3)

  13. MF Format 3 can be used only in a constant-name entry.
  14. MF If literal-5 is specified and not followed by an operator, the characteristic of the constant-name is that of literal-5. Otherwise, the characteristic of the constant-name is that of an integer.
  15. MF Any number of arithmetic or logical operators can be used. The result is evaluated using integer arithmetic in strict left to right order. No parentheses can be used. If any intermediate result is less than zero, the final value is undefined. A constant-name may be used in place of integer-1.
  16. MF The logical operations AND and OR act on the binary representation in a bit-wise manner.
  17. MF LENGTH of identifier-1 or identifier-3 is the size of the storage allocated for identifier-1 or identifier-3, respectively. If the identifier is a group item, the length includes all subordinate data items.
  18. MF The value returned by NEXT is the offset at which the next byte of storage occurs after the previous data declaration. (It is not the offset of the start of the next data declaration.) If that data declaration was of a table defined with an OCCURS clause, the value returned by NEXT is the offset at which the next byte of storage occurs after the first element of the table.
  19. MF START of identifier-2 or identifier-4 is the offset at which identifier-2 or identifier-4, respectively, begins.
  20. MF For rules 18 and 19, the offset is defined as follows:
    • If the identifier is part of an EXTERNAL record or a LINKAGE record, the offset is calculated from the start of the associated 01-level;
    • If the identifier is defined in the Local-Storage Section, the offset is calculated from the start of the Local-Storage Section;
    • Otherwise the offset is calculated from the start of the Data Division.
  21. MF Offsets are not portable across different COBOL implementations and no reliance should be placed on particular values outside this compilation unit.

Table Rules (Format 4)

  22. ISO2002 MF A format 2 VALUE clause initializes a table element to the value of literal-6. The table element initialized is identified by subscript-1. Consecutive table elements are initialized, in turn, to the value of successive occurrences of literal-6. Consecutive table elements are referenced by incrementing by 1 the subscript that represents the least inclusive dimension of the table. When any reference to a subscript, prior to incrementing it, is equal to the maximum number of occurrences specified by its corresponding OCCURS clause, that subscript is set to 1 and the subscript for the next most inclusive dimension of the table is incremented by 1.
  23. ISO2002 MF If the TO phrase is specified, all occurrences of literal-6 are reused, in the order specified, as a source during the initialization described in the immediately preceding rule. This repetition is done until the table element identified by subscript-2 is initialized.
  24. ISO2002 MF If the TO phrase is not specified, it is as if the TO phrase were specified with each subscript-2 as the maximum number of occurrences of the table associated with each corresponding subscript-1.
  25. ISO2002 MF If multiple specifications of the FROM phrase reference the same table element, the value defined by the last specified FROM phrase in the VALUE clause is assigned to the table element.

Format 5

  26. NET JVM If the TRUE phrase is specified, the associated condition-value data item is set to true. If the FALSE phrase is specified, the associated condition-value data item is set to false.

Examples

  1. An example of using the NEXT phrase of the VALUE clause is provided in the section NEXT Phrase of CONSTANT-NAMES.
Parent topic: Data Description Entry Skeleton
Related reference
Initialization of Working Storage
Related information
Standard Alignment Rules
The SET Statement
The PICTURE Clause
NEXT Phrase of CONSTANT-NAMES


Screen Section

Note: This functionality is not supported in COBOL for JVM.
  • Screen Section Entry Skeleton
    A Screen Description entry specifies the attributes, behavior, size and location for a referenced screen item which is accepted or displayed at run time.
  • The AUTO Clause
    The AUTO clause automatically terminates an ACCEPT operation of the screen item when the last character position is keyed. No explicit terminator key is necessary.
  • The BACKGROUND-COLOR Clause
    The BACKGROUND-COLOR clause specifies the background color of the screen item.
  • The BELL Clause
    The BELL clause causes an audible alarm to occur each time the item containing the clause is displayed.
  • The BLANK Clause
    The BLANK clause clears a line of a screen or the whole screen before a screen item is displayed.
  • The BLANK WHEN ZERO Clause in the Screen Section
    The BLANK WHEN ZERO clause causes the blanking of a screen item when its value is zero.
  • The BLINK Clause
    The BLINK clause causes the screen item to blink when it appears on the screen.
  • The COLUMN Clause
    The COLUMN clause specifies the column at which the screen item starts on the screen.
  • The CONTROL Clause
    The CONTROL clause allows attributes associated with a Screen Section item to be defined at run time.
  • The ERASE Clause
    The ERASE clause clears part of the line or the screen starting at the cursor position.
  • The FOREGROUND-COLOR Clause
    The FOREGROUND-COLOR clause specifies the foreground color of the screen item.
  • The FROM Clause
    The FROM clause identifies the source of data for display.
  • The FULL Clause
    The FULL clause specifies that the operator must either leave the screen item completely empty or fill it entirely with data.
  • The GRID Clause
    The GRID clause causes each character of the screen item to have a vertical line on its left-hand side when the item appears on the screen. Each line is within the character-position.
  • The HIGHLIGHT Clause
    The HIGHLIGHT clause causes the screen item to appear in high intensity mode when it appears on the screen.
  • The JUSTIFIED Clause in the Screen Section
    The JUSTIFIED clause specifies non-standard positioning of data within a screen item when data is either moved to it or entered into it.
  • The LEFTLINE Clause
    The LEFTLINE clause causes the leftmost character of the screen item to have a vertical line on its left-hand side when the item appears on the screen. The line is within the character-position.
  • The LINE Clause
    The LINE clause specifies the line at which the screen item starts on the screen.
  • The LOWLIGHT Clause
    The LOWLIGHT clause specifies that the field is to appear on the screen with the lowest intensity.
  • The OCCURS Clause in the Screen Section
    The OCCURS clause eliminates the need for separate entries for repeated screen items and supplies information required for the application of subscripts or indices.
  • The OVERLINE Clause
    The OVERLINE clause causes every character of the screen item to have a horizontal line above it when the item appears on the screen. The line is within the character-position.
  • The PICTURE Clause in the Screen Section
    The PICTURE clause describes the length, general characteristics and editing requirements of a screen item.
  • The PROMPT Clause
    The PROMPT clause causes the empty character positions in the screen item to be marked on the screen during an ACCEPT operation while the system is ready to accept operator-keyed data into that item.
  • The REQUIRED Clause
    The REQUIRED clause specifies that the operator must not leave the screen item empty.
  • The REVERSE-VIDEO Clause
    The REVERSE-VIDEO clause causes the screen item to be displayed in reverse-video.
  • The SECURE Clause
    The SECURE clause prevents operator-keyed data from appearing on the screen.
  • The SIGN Clause in the Screen Section
    The SIGN clause specifies the position and representation of the operational sign.
  • The SIZE Clause
    The SIZE clause specifies the current size of the screen item.
  • The TO Clause
    The TO clause identifies the destination of data accepted.
  • The UNDERLINE Clause
    The UNDERLINE clause causes the screen item to be underlined when it appears on the screen.
  • The USAGE Clause in the Screen Section
    The USAGE clause specifies the format of a data item in the computer storage.
  • The USING Clause
    The USING clause identifies the source of data for display.
  • The VALUE Clause in the Screen Section
    The VALUE clause specifies literal information for display on the screen.
  • The ZERO-FILL Clause
    The ZERO-FILL clause causes trailing prompt characters to be replaced by zeros instead of spaces.
Parent topic: Data Division


Screen Section Entry Skeleton

A Screen Description entry specifies the attributes, behavior, size and location for a referenced screen item which is accepted or displayed at run time.
Note: This functionality is not supported in COBOL for JVM.

The availability of screen attributes is dependent on your terminal hardware and operating system and COBOL run-time support.

MF The following are not a part of X/Open screen handling:

  • ACCEPT (Formats 3 and 5)
  • AUTO-SKIP (synonym for AUTO)
  • BEEP (synonym for BELL)
  • COL (synonym for COLUMN)
  • CONTROL
  • DISPLAY (Format 3)
  • EMPTY-CHECK (synonym for REQUIRED)
  • GRID
  • LEFTLINE
  • LENGTH-CHECK (synonym for FULL)
  • NO-ECHO (synonym for SECURE)
  • OCCURS
  • OVERLINE
  • PROMPT
  • SIZE
  • ZERO-FILL

General Format

Syntax Rules

  1. Each Screen Description entry must start with a level number from 01 through 49.
  2. Each level 01 item must have a screen-name.
  3. Screen-name must immediately follow level number and conform to the rules for user-defined names.
  4. A screen item can be referenced only in a Format 4 ACCEPT or Format 2 DISPLAY statement.
  5. Each elementary screen item must contain at least one of the following clauses: BELL, BLANK LINE, BLANK SCREEN, COLUMN, LINE, PICTURE, VALUE.
  6. The data items in the FROM, TO and USING phrases are associated with the screen item. The USING phrase is equivalent to the combination of a FROM and TO phrase, each specifying the same field.
  7. An ACCEPT can be executed on a group screen item containing screen items with FROM or VALUE phrases only if that group also contains screen items with TO or USING phrases.
  8. The clauses following screen-name can be specified in any order.
  9. A clause that appears in the description of a group screen item applies to all the elementary subordinate items in that group in whose descriptions it would be allowed.
  10. Any non-01 level screen item can have a data name, FILLER, or no name. If no name is used, then FILLER is assumed (and the item can never be explicitly referenced).
  11. If the same clause is specified more than once for the same screen item, the clause which appears at the lowest level within the hierarchy is the one which takes effect.

  12. Table 1 summarizes the screen description entry clauses available in the Screen Section for use with different types of screen fields

    MF and the WITH phrase options for use with the ACCEPT and DISPLAY statements.

    Table 1. Permitted Use of Options
    Screen Description Entry Clauses/ WITH Phrases | Screen Section | MF WITH Phrase
    Input Field | Output Field | Update Field | Literal Field | ACCEPT | DISPLAY
    AUTO | X | X | X
    BACKGROUND-COLOR | X | X | X | X | X | X
    BELL | X | X | X | X | X | X
    BLANK | X | X | X | X | X
    BLANK WHEN ZERO | X | X | X
    BLINK | X | X | X | X | X | X
    COLUMN | X | X | X | X
    ERASE | X | X | X | X | X
    FOREGROUND-COLOR | X | X | X | X | X | X
    FULL | X | X | X
    GRID | X | X | X | X | X | X
    HIGHLIGHT | X | X | X | X | X | X
    JUSTIFIED | X | X | X
    LEFT-JUSTIFY | X
    LEFTLINE | X | X | X | X | X | X
    LINE | X | X | X | X
    LOWLIGHT | X | X | X | X | X | X
    OCCURS | X | X | X
    OVERLINE | X | X | X | X | X | X
    PROMPT | X | X | X
    REQUIRED | X | X | X
    REVERSE-VIDEO | X | X | X | X | X | X
    RIGHT-JUSTIFY | X
    SECURE | X | X | X
    SIGN | X | X | X
    SIZE | X | X | X | X | X | X
    SPACE-FILL | X
    TRAILING-SIGN | X
    UNDERLINE | X | X | X | X | X | X
    UPDATE | X

    Key:

    X | Clause or option allowed
    Input field | Screen item whose description contains a TO phrase
    Output field | Screen item whose description contains a FROM phrase
    Update field | Screen item whose description contains a USING phrase
    Literal field | Elementary screen item whose description contains no PICTURE clause.

General Rules

  1. Screen-name assigns a name to the screen item described in the screen description.
  2. Screen descriptions define areas on the screen. Each entry consists of a level number, an optional screen-name, and various optional clauses relating to the positioning of fields as well as to console functions.
  3. When the screen item is displayed, data is taken from the literal or data item named in the associated FROM or USING phrase. Items with the TO phrase only are treated as though FROM SPACE or FROM ZERO were specified, depending on the type of screen item.
  4. When the screen item is accepted, the data entered is moved from the screen to the data item named in the TO or USING phrase. Depending on the category of the item, conversion and de-editing are done if necessary.
  5. An input field is a screen item whose description contains a TO phrase.
  6. An output field is a screen item whose description contains a FROM phrase.
  7. An update field is a screen item whose description contains a USING phrase.
  8. A literal field is an elementary screen item whose description contains no PICTURE clause.
  9. An ACCEPT of a group screen item consists of accepting those elementary subordinate items that are input or update fields. They are accepted in the order their descriptions appear in the Screen Section at the screen positions indicated by the screen descriptions. Unless otherwise specified in the CURSOR IS clause (see the topic The Special-Names Paragraph in the chapter Environment Division), the cursor is initially positioned at the start of the first item. As the ACCEPT operation into each item is terminated, the cursor moves to the start of the next item.
  10. A DISPLAY of a group screen item consists of displaying those elementary subordinate items that are output, update or literal fields. They are displayed simultaneously at the screen positions indicated by the screen descriptions.
  11. If the length of an ACCEPT or DISPLAY screen item exceeds the length of the current line, wraparound is to the next line.
  12. If a screen item is too large to fit within the physical screen, truncation occurs at the first character that is off-screen for output fields and alphanumeric input and update fields, and at the first field that is off-screen for numeric and numeric edited input and update fields.
Parent topic: Screen Section
Related information
The Special-Names Paragraph


The AUTO Clause

The AUTO clause automatically terminates an ACCEPT operation of the screen item when the last character position is keyed. No explicit terminator key is necessary.

General Format

Syntax Rules

  1. The AUTO clause is allowed only with input and update fields.
  2. If this clause is specified at group level, it applies to all elementary subordinate items.
  3. MF AUTO and AUTO-SKIP are equivalent.

General Rules

  1. Provided any REQUIRED or FULL clause is satisfied, the cursor is positioned to the next screen item. Alternatively, if the screen item is the last one in the ACCEPT operation, the entire ACCEPT is terminated.
  2. This clause overrides any existing configuration options for automatic skipping and for the automatic termination of an ACCEPT statement. (See your COBOL system documentation about user interfaces for details of configuration options.)
  3. In a fixed-format numeric-edited screen item, the AUTO clause causes the decimal point position to be skipped automatically once all of the integer places have been filled. Selection of fixed format mode is a configuration option. (See your COBOL system documentation about user interfaces for details of configuration options.)
Parent topic: Screen Section


The BACKGROUND-COLOR Clause

The BACKGROUND-COLOR clause specifies the background color of the screen item.

General Format

Syntax Rules

  1. MF BACKGROUND-COLOR and BACKGROUND-COLOUR are equivalent.
  2. This clause is allowed with any screen item.
  3. If this clause is specified at group level, it applies to all elementary subordinate items.
  4. Integer-1 must be a value from 0 to 15.

General Rules

  1. This clause is available for use only with a color screen.
  2. Integer-1 or identifier-1 specifies the background color of the screen item. The colors and their corresponding values are:
    0 | black | 8 | grey
    1 | blue | 9 | light blue
    2 | green | 10 | light green
    3 | cyan | 11 | light cyan
    4 | red | 12 | light red
    5 | magenta | 13 | light magenta
    6 | brown or yellow | 14 | yellow
    7 | white | 15 | high intensity white

    On a color screen, if the value is from 8 to 15, this is equivalent to specifying an integer from 0 to 7 and specifying the BLINK clause. On a monochrome screen, this is equivalent to simply specifying the BLINK clause.

  3. If this clause is not specified, the background color defaults to black.
  4. If a screen description contains a BLANK SCREEN clause, and either contains a BACKGROUND-COLOR clause or is subordinate to one that does, when the screen item is displayed by a DISPLAY statement the specified color becomes the default background color. It remains the default background color until either another screen item with this combination of options is displayed (whether in the same DISPLAY statement or another), or a Format 3 DISPLAY statement with both options is executed.
  5. Identifier-1 must be an unsigned numeric integer and should contain a value between 0 and 7. Any value higher than 7 is divided by 8 and the remainder used as the color value.
  6. Identifier-1 must not be subject to OCCURS clauses.
  7. Whether a value of 6 in integer-1 or identifier-1 produces brown or yellow color depends on the terminal hardware.
Parent topic: Screen Section


The BELL Clause

The BELL clause causes an audible alarm to occur each time the item containing the clause is displayed.

General Format

Syntax Rules

  1. This clause is allowed only with elementary items.
  2. MF BELL and BEEP are equivalent.

General Rules

  1. The BELL clause causes an alarm to occur each time the item containing the clause is accepted or displayed.
  2. In order to cause the audible alarm to sound when the subject of this entry is accepted, you must specify the BELL clause in General Format 5 of the ACCEPT statement: the alarm does not sound if you specify the BELL clause in the Screen Description Entry and then use General Format 4 of the ACCEPT statement.
Parent topic: Screen Section


The BLANK Clause

The BLANK clause clears a line of a screen or the whole screen before a screen item is displayed.

General Format

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directive may impact either the syntax or semantics described in this section.
    • OLDBLANKLINE - specifies that the BLANK LINE clause has the same effect as ERASE EOL; that is, all characters to the right of the cursor are deleted.

Syntax Rules

  1. The BLANK SCREEN clause can be specified in any screen description entry.
  2. The BLANK LINE clause can be specified only for elementary items.

General Rules

  1. The BLANK SCREEN clause is executed before DISPLAY of a screen data item, no matter where it appears. If the clause is specified, all the screen is cleared and the cursor is placed at line 1, column 1.
  2. When BLANK LINE is specified, blanking begins at column 1 of the line specified for the screen data element in whose description it is included and continues through the end of the line. The cursor remains in the same position as before the BLANK LINE was actioned.
  3. If neither the BLANK nor the ERASE clause is specified, only the particular character positions corresponding to the screen data element are modified when the element is displayed. The rest of the screen content remains the same.
  4. The BLANK SCREEN clause causes the screen to return to its default foreground and background colors. For additional effects, if the screen item is subject to a FOREGROUND-COLOR or BACKGROUND-COLOR clause, see the topics on those clauses.
  5. The BLANK clause is ignored in an ACCEPT statement.
  6. When the BLANK SCREEN clause is used, only color options (foreground-color and background-color) should be used on the same screen. Other attributes are accepted but ignored.
Parent topic: Screen Section


The BLANK WHEN ZERO Clause in the Screen Section

The BLANK WHEN ZERO clause causes the blanking of a screen item when its value is zero.

General Format

Syntax Rules

  1. This clause is allowed only with input, output and update fields that are numeric or numeric-edited.

General Rules

  1. The BLANK WHEN ZERO clause causes the blanking of a screen item when its value is zero.
  2. This clause has no effect when the cursor is in the field. That is, the contents of the field are always displayed, even if zero, if this is the current input field.
Parent topic: Screen Section


The BLINK Clause

The BLINK clause causes the screen item to blink when it appears on the screen.

General Format

Syntax Rules

  1. The BLINK clause is allowed with any screen item.
  2. If the BLINK clause is specified at group level, it applies to all suitable subordinate elementary items.

General Rules

  1. The BLINK clause causes the screen item to blink when it appears on the screen.
Parent topic: Screen Section


The COLUMN Clause

The COLUMN clause specifies the column at which the screen item starts on the screen.

General Format

Syntax Rules

  1. Identifier-1 must be an unsigned numeric integer and must contain a value greater than zero and less than 256.
  2. Integer-1 must be unsigned, greater than zero and less than 256.
  3. MF PLUS and "+" are equivalent.
  4. Omitting the NUMBER phrase results in a default value of +1.
  5. COLUMN 1 is assumed for screen descriptions which specify the LINE clause but omit the COLUMN clause.
  6. The COLUMN clause can be specified with any elementary item.
  7. MF COL is an abbreviation for COLUMN.
  8. MF When the COLUMN clause is specified anywhere within the hierarchy of a Screen Section group item, then at least one of the following clauses must also be specified within the same group definition:

    BEEP, BELL, BLANK LINE, BLANK SCREEN, ERASE EOL, ERASE EOS, FROM, TO, USING, or VALUE.

General Rules

  1. The COLUMN clause specifies the column in which the screen item is to appear on the screen in an ACCEPT or DISPLAY operation.
  2. If the COLUMN clause has an identifier or an integer but does not specify PLUS,

    MF "+" or "-",

    the clause gives an absolute column number within the screen record. Each 01 level represents a screen record. The AT phrase of the ACCEPT and DISPLAY statements specifies the positioning of the screen record relative to the start of the display screen. If the AT phrase is not specified, then column 1 is the first column on the screen.

  3. If PLUS,

    MF "+" or "-"

    is specified in the COLUMN clause, then the column number within the screen record is relative to that at which the preceding screen item ends, regardless of whether or not the statement displays the preceding item on the screen. This depends on the current effective length of that item at run time, derived from its PICTURE, VALUE and SIZE clauses. The counting of column numbers restarts at a level 01 item at column 1.

  4. If a screen description contains neither a LINE or COLUMN clause, and the item is not a level 01 item, COLUMN+1 is assumed. The item then starts immediately following the preceding item in the Screen Section.
  5. If a COLUMN position that is specified is off the screen, wraparound is to the next (or previous) line.
Parent topic: Screen Section


The CONTROL Clause

The CONTROL clause allows attributes associated with a Screen Section item to be defined at run time.

General Format

Syntax Rules

  1. This clause is allowed with any screen item.
  2. If this clause is specified at group level, it applies to all elementary subordinate items.
  3. Identifier-1 must be an alphanumeric data item. The maximum permitted size of the item is PIC X(65535).
  4. Attributes specified in identifier-1 override any statically defined attributes.
  5. CONTROL statements must not be nested.
  6. The PROTECT attribute may be specified only for an elementary screen description entry.

General Rules

  1. When an ACCEPT or DISPLAY statement is executed that implicitly or explicitly references the subject of this entry, the contents of the data item referenced by identifier-1 must conform to the following subset of the screen attributes which can be specified elsewhere:

  2. If identifier-1 contains spaces, the statically defined attributes are used for any accept or display of the item.
  3. The meaning of each of the attributes that can be specified within the CONTROL identifier-1 is defined in the following parts of this reference:
    1. Within the Data Division as an individual Screen Section clause
      • AUTO-SKIP/AUTO
      • BACKGROUND-COLOR/BACKGROUND-COLOUR
      • BELL/BEEP
      • BLANK LINE/SCREEN
      • BLINK
      • FOREGROUND-COLOR/FOREGROUND-COLOUR
      • FULL/LENGTH-CHECK
      • GRID
      • HIGHLIGHT
      • JUSTIFY/JUST
      • LEFTLINE
      • LOWLIGHT
      • OVERLINE
      • PROMPT
      • REQUIRED/EMPTY-CHECK
      • REVERSE-VIDEO
      • SECURE/NO-ECH0
      • UNDERLINE
      • ZERO-FILL
    2. Within the Procedure Division in the ACCEPT statement General Rules:
      • RIGHT-JUSTIFY
      • TRAILING-SIGN
      • TRAILING
    3. Within this CONTROL clause discussion:
      • PROTECT
  4. The PROTECT attribute specifies that input to an ACCEPT item is to be prevented.
Parent topic: Screen Section


The ERASE Clause

The ERASE clause clears part of the line or the screen starting at the cursor position.

General Format

Syntax Rules

  1. The ERASE clause can be specified only for elementary items.

General Rules

  1. When ERASE EOL is specified, blanking begins at the line and column coordinates specified for the screen data element in whose description it is included and continues through the end of the line.
  2. When ERASE EOS is specified, blanking begins at the line and column coordinates specified for the screen data element in whose description it is included and continues through the end of the screen.
  3. If neither the BLANK nor the ERASE clause is specified, only the particular character positions corresponding to the screen data element are modified when the element is displayed.
  4. The clause is ignored in an ACCEPT operation.
Parent topic: Screen Section


The FOREGROUND-COLOR Clause

The FOREGROUND-COLOR clause specifies the foreground color of the screen item.

General Format

Syntax Rules

  1. FOREGROUND-COLOR and FOREGROUND-COLOUR are equivalent.
  2. This clause is allowed with any screen item.
  3. If this clause is specified at group level, it applies to all elementary subordinate items.
  4. Integer-1 must be a value from 0 to 15.

General Rules

  1. This clause is available for use only with a color screen.
  2. Integer-1 or identifier-1 specifies the foreground color of the screen item. The colors and their corresponding values are:
    0 | black | 8 | grey
    1 | blue | 9 | light blue
    2 | green | 10 | light green
    3 | cyan | 11 | light cyan
    4 | red | 12 | light red
    5 | magenta | 13 | light magenta
    6 | brown or yellow | 14 | yellow
    7 | white | 15 | high intensity white

    On a color screen, if the value is from 8 to 15, this is equivalent to specifying an integer from 0 to 7 and specifying the HIGHLIGHT clause. On a monochrome screen, this is equivalent to simply specifying the HIGHLIGHT clause.

  3. If this clause is not specified, the foreground color defaults to white.
  4. If a screen description contains a BLANK SCREEN clause, and either contains a FOREGROUND-COLOR clause or is subordinate to one that does, then when the screen item is displayed by a DISPLAY statement the specified color becomes the default foreground color. It remains the default foreground color until either another screen item with this combination of options is displayed (whether in the same DISPLAY statement or another), or a Format 3 DISPLAY statement with both options is executed.
  5. If the HIGHLIGHT clause is also specified, foreground colors are brightened and lightened; for example on some hardware, black can become grey and brown can become yellow. However, this does not apply to the BLANK SCREEN clause.
  6. Identifier-1 must be an unsigned numeric integer and should contain a value between 0 and 7. Any value higher than 7 is divided by 8 and the remainder used as the color value.
  7. Identifier-1 must not be subject to OCCURS clauses.
  8. Whether a value of 6 in integer-1 or identifier-1 produces brown or yellow depends on the terminal hardware.
Parent topic: Screen Section


The FROM Clause

The FROM clause identifies the source of data for display.

General Format

Syntax Rules

  1. The FROM clause, when used with the TO clause, is equivalent to the USING clause, both specifying the same identifier. It must not be used with the USING clause.
  2. The identifier in the FROM clause can be qualified. If no OCCURS clause applies to the screen item, this identifier can be subscripted or indexed. It must be defined in the File, Working-Storage,

    MF Local-Storage,

    or Linkage Section of the program.

General Rules

  1. Executing a DISPLAY statement on a screen item whose description includes a FROM clause moves data from the associated data item to the screen item, and then displays the screen item on the screen.
Parent topic: Screen Section


The FULL Clause

The FULL clause specifies that the operator must either leave the screen item completely empty or fill it entirely with data.

General Format

Syntax Rules

  1. The FULL clause is valid only in input and update fields and group items.
  2. If this clause is specified at group level, it applies to all suitable subordinate elementary items.
  3. MF FULL and LENGTH-CHECK are equivalent.

General Rules

  1. The FULL clause is effective during the execution of any ACCEPT statement that causes the screen item to be accepted provided the cursor enters the screen item at some time during the ACCEPT operation. Until this clause is satisfied, terminator keystrokes are rejected. If the item is fixed format numeric edited, the cursor is repositioned to the decimal point position.
  2. If the screen item is alphanumeric, in order to satisfy this clause either the entire item must contain only spaces or prompt characters, or both the first and last character positions must contain non-space, non-prompt characters.
  3. If the screen item is free-format numeric or free-format numeric-edited, then to satisfy the clause, either the resultant value must be zero, or both the first and last character positions must contain non-space, non-prompt characters.
  4. If the screen item is fixed-format numeric-edited, then to satisfy the clause either the value must be zero or there must be no digit positions in which zero-suppression has taken effect.
  5. The FULL clause has no effect on fixed-format numeric or on numeric-edited screen items that have no zero-suppression positions.
  6. For update fields, the FULL clause can be satisfied by initial data as well as operator-keyed data.
  7. The FULL clause cannot be effective if a function key is used to terminate the ACCEPT operation. (See your COBOL system documentation about user interfaces for details of configuration options.)
  8. An error message can be configured for display on the screen if the FULL clause is not satisfied. (See your COBOL system documentation about user interfaces for details of configuration options.)
Parent topic: Screen Section


The GRID Clause

The GRID clause causes each character of the screen item to have a vertical line on its left-hand side when the item appears on the screen. Each line is within the character-position.

General Format

Syntax Rules

  1. The GRID clause can be used with any screen item.
  2. If the GRID clause is specified at group level, it applies to all suitable subordinate elementary items.
  3. If this clause is used on a system that does not support characters with vertical left-hand lines it has no effect.

General Rules

  1. The GRID clause causes each character of the screen item to have a vertical line on its left-hand side when the item appears on the screen. Each line is within the character-position.
Parent topic: Screen Section


The HIGHLIGHT Clause

The HIGHLIGHT clause causes the screen item to appear in high intensity mode when it appears on the screen.

General Format

Syntax Rules

  1. This clause is valid for input, output, update and literal fields.
  2. If the HIGHLIGHT clause is specified at group level, it applies to all suitable subordinate elementary items.

General Rules

  1. If the FOREGROUND-COLOR clause is also specified, the HIGHLIGHT clause causes the foreground colors to become brighter and lighter; for example on some hardware, black can become grey and brown can become yellow. However, this does not apply to the BLANK SCREEN clause.
Parent topic: Screen Section


The JUSTIFIED Clause in the Screen Section

The JUSTIFIED clause specifies non-standard positioning of data within a screen item when data is either moved to it or entered into it.

General Format

Syntax Rules

  1. JUST is an abbreviation for JUSTIFIED.
  2. The JUSTIFIED clause is allowed only with input, output and update fields.

General Rules

  1. If the screen item is an output or update field, when data is moved to it from the sending item, the JUSTIFIED clause is applied according to the normal rules for MOVE.
  2. If the screen item is an input or update field, when the accepting of data into it has terminated, the JUSTIFIED clause causes the data entered to be moved right by the number of character positions occupied by prompt characters, and the left of the field to be padded with spaces. This is done before the data is moved to the receiving item. This does not occur if data is not entered.
  3. If the screen item has a SECURE clause, the effect on the data is the same as it would be without the SECURE clause, but this effect does not appear on the screen.
Parent topic: Screen Section


The LEFTLINE Clause

The LEFTLINE clause causes the leftmost character of the screen item to have a vertical line on its left-hand side when the item appears on the screen. The line is within the character-position.

General Format

Syntax Rules

  1. The LEFTLINE clause can be used with any screen item.
  2. If the LEFTLINE clause is specified at group level, it applies to all suitable subordinate elementary items.
  3. If this clause is used on a system that does not support characters with vertical left-hand lines it has no effect.

General Rules

  1. The LEFTLINE clause causes the leftmost character of the screen item to have a vertical line on its left-hand side when the item appears on the screen. The line is within the character-position.
Parent topic: Screen Section


The LINE Clause

The LINE clause specifies the line at which the screen item starts on the screen.

General Format

Syntax Rules

  1. Identifier-1 must be an unsigned numeric integer and must contain a value greater than zero and less than 256.
  2. Integer-1 must be unsigned, greater than zero and less than 256.
  3. MF PLUS and "+" are equivalent.
  4. Omitting the NUMBER phrase results in a default value of PLUS 1.
  5. The current line is assumed for screen descriptions which omit the LINE clause.
  6. The LINE clause can be specified with any elementary item.
  7. MF When the LINE clause is specified anywhere within the hierarchy of a Screen Section group item, then at least one of the following clauses must also be specified within the same group definition: BEEP, BELL, BLANK LINE, BLANK SCREEN, ERASE EOL, ERASE EOS, FROM, TO, USING, or VALUE.

General Rules

  1. The LINE clause specifies the line on which the screen item is to appear on the screen in an ACCEPT or DISPLAY operation.
  2. If the LINE clause has identifier-1 or integer-1 but does not specify PLUS,

    MF "+" or "-",

    the clause gives an absolute line number within the screen record. Each 01 level represents a screen record. The AT phrase of the ACCEPT and DISPLAY statements specifies the positioning of the start of the screen record relative to the start of the display screen. If the AT phrase is not specified, then line 1 is the first line on the screen.

  3. If PLUS,

    MF "+" or "-",

    is specified in the LINE clause, then the line number is relative to that at which the preceding screen item ends, regardless of whether or not the statement displays the preceding item on the screen. This depends on the current effective length of that item at run time, derived from its PICTURE, VALUE and SIZE clauses. The counting of line numbers restarts at a level 01 item at line 1.

  4. If a Screen Description contains neither a LINE or COLUMN clause, and the item is not a level 01 item, COLUMN PLUS 1 is assumed. The item then starts immediately following the preceding item in the Screen Section.
  5. If a LINE position that is specified is off the screen, the ACCEPT or DISPLAY is truncated.
  6. If PLUS

    MF "+" or "-",

    is specified in the LINE clause, and an ACCEPT or DISPLAY statement referencing the Screen Section item includes the AT LINE NUMBER phrase, the line number at which this item is presented is the sum or difference of the two numbers.

Parent topic: Screen Section


The LOWLIGHT Clause

The LOWLIGHT clause specifies that the field is to appear on the screen with the lowest intensity.

General Format

Syntax Rules

  1. If the LOWLIGHT clause is specified at group level, it applies to all suitable subordinate elementary items.

General Rules

  1. The LOWLIGHT clause specifies that the field is to appear on the screen with the lowest intensity.
Parent topic: Screen Section


The OCCURS Clause in the Screen Section

The OCCURS clause eliminates the need for separate entries for repeated screen items and supplies information required for the application of subscripts or indices.

General Format

Syntax Rules

  1. The OCCURS clause is not allowed at 01 level.
  2. If USING or TO clauses apply to the item, or to any item subsidiary to the item, then the same number of OCCURS clauses, specifying the same number of occurrences, must apply to the receiving item. These OCCURS clauses must not include the DEPENDING phrase.
  3. If a FROM clause applies to the item, or to any item subsidiary to the item, either the same number of OCCURS clauses, specifying the same number of occurrences, or no OCCURS clauses at all, must apply to the sending item. These OCCURS clauses must not include the DEPENDING phrase.

General Rules

  1. In a screen description which is subject to an OCCURS clause, the LINE and COLUMN clauses apply to each individual table entry. Thus either the LINE or the COLUMN clause should specify relative positioning, because if they both specify an absolute position every entry will appear in the same place.
  2. If the screen item is an output field, and no OCCURS clauses apply to the sending item, in a DISPLAY operation the contents of the sending item are moved to every occurrence of the screen item. An elementary item that is fully subscripted is deemed to have no OCCURS clauses applying to it.
  3. If the screen item is an update field, or it is an output field with OCCURS clauses applying to the sending item, then in a DISPLAY operation the contents of each occurrence of the sending item are moved to the corresponding occurrence of the screen item.
  4. If the screen item is an update or input field, then in an ACCEPT operation the data entered into each occurrence of the screen item is moved to the corresponding occurrence of the receiving item.
Parent topic: Screen Section


The OVERLINE Clause

The OVERLINE clause causes every character of the screen item to have a horizontal line above it when the item appears on the screen. The line is within the character-position.

General Format

Syntax Rules

  1. The OVERLINE clause can be used with a screen item.
  2. If the OVERLINE clause is specified at group level, it applies to all suitable subordinate elementary items.
  3. If this clause is used on a system that does not support overlining it has no effect.

General Rules

  1. The OVERLINE clause causes every character of the screen item to have a horizontal line above it when the item appears on the screen.
Parent topic: Screen Section


The PICTURE Clause in the Screen Section

The PICTURE clause describes the length, general characteristics and editing requirements of a screen item.

General Format

Syntax Rules

  1. The PICTURE clause can include any standard editing characters.
  2. The PICTURE clause must be used in conjunction with one or more of the FROM, TO or USING clauses. The USING clause must not be used with either the FROM or TO clause.
  3. PIC is an abbreviation for PICTURE.
  4. The PICTURE clause is allowed only with elementary items.
  5. The PICTURE clause need not be the same as the PICTURE clause of the data item referenced in the FROM, TO or USING clause but it must be such that the implied MOVE is legal.

General Rules

  1. The character-string describes the length and category of the screen item. It is used in the same way as the character-string in the PICTURE clause for a data item.
  2. We recommend that every numeric screen item either be a numeric edited item or contain only 9's in its PICTURE clause. Editing and de-editing are applied as necessary when data is moved to or from the associated data item.
Parent topic: Screen Section


The PROMPT Clause

The PROMPT clause causes the empty character positions in the screen item to be marked on the screen during an ACCEPT operation while the system is ready to accept operator-keyed data into that item.

General Format

Syntax Rules

  1. This clause is allowed only with input and update fields and with group items.
  2. If this clause is specified at group level, it applies to all subordinate elementary items.
  3. Identifier-1 must be a single-character alphabetic or alphanumeric data item.
  4. Identifier-1 must not be subject to an OCCURS clause.
  5. Literal-1 must be a one-character nonnumeric literal or a figurative constant.

General Rules

  1. For items in the Screen Section :
    1. PROMPT is always on.
    2. If the PROMPT clause is not specified, or is specified without the CHARACTER phrase, the default prompt character is used.
  2. For other data items referenced in an ACCEPT statement,
    1. PROMPT is on if and only if the PROMPT clause is specified on the ACCEPT statement.
    2. If the PROMPT clause is specified without the CHARACTER phrase, the default prompt character is used.
  3. The CHARACTER phrase specifies a prompt character to be used for marking empty character positions. The prompt character overrides the configured option. (See your COBOL system documentation about user interfaces for details on configuration options.)
  4. The PROMPT clause causes the prompt character to replace trailing spaces in alphanumeric or free format numeric screen items. It also causes the prompt character to replace leading suppressed digit positions in fixed format numeric edited screen items.
  5. The PROMPT clause has no effect on fixed format, nonedited numeric screen items or numeric edited screen items that have no zero-suppression positions.
  6. If PROMPT is on for a field, you cannot move the cursor past the end of the field, which is marked by prompt characters. An attempt to do so moves the cursor to the next field .
  7. If PROMPT is not on for a field, the cursor can be moved to the spaces following the end of the field.
  8. This clause has no effect if the SECURE clause is specified.
  9. The prompt characters appearing in the screen item are changed to spaces upon termination of the ACCEPT operation.
Parent topic: Screen Section


The REQUIRED Clause

The REQUIRED clause specifies that the operator must not leave the screen item empty.

General Format

Syntax Rules

  1. The REQUIRED clause is allowed only with input and update fields and with group items.
  2. This clause can be specified on a group screen item, in which case it applies to all suitable elementary items which are subordinate to that item.
  3. MF REQUIRED and EMPTY-CHECK are equivalent.

General Rules

  1. The REQUIRED clause takes effect during the execution of any ACCEPT statement that causes the screen item to be accepted provided the cursor enters the screen item at some time during the ACCEPT. Unless this clause is satisfied, terminator keystrokes are rejected and the cursor is repositioned to the beginning of the item.
  2. To satisfy this clause, alphanumeric screen items must contain at least one non-space, non-prompt character; numeric screen items must have a non-zero value.
  3. For update fields, the REQUIRED clause can be satisfied by initial data as well as by operator-keyed data.
  4. The REQUIRED clause cannot be effective if a function key is used to terminate an ACCEPT operation. (See your COBOL system documentation about user interfaces for details on configuration options.)
  5. An error message can be configured for display on the screen if the REQUIRED clause is not satisfied. (See your COBOL system documentation about user interfaces for details on configuration options.)
Parent topic: Screen Section


The REVERSE-VIDEO Clause

The REVERSE-VIDEO clause causes the screen item to be displayed in reverse-video.

General Format

Syntax Rules

  1. The REVERSE-VIDEO clause is allowed with any screen item.
  2. If the REVERSE-VIDEO clause is specified at group level, it applies to all suitable subordinate elementary items.

General Rules

  1. The REVERSE-VIDEO clause causes the screen item to be displayed in reverse-video.
Parent topic: Screen Section


The SECURE Clause

The SECURE clause prevents operator-keyed data from appearing on the screen.

General Format

Syntax Rules

  1. The SECURE clause is allowed only with input and update fields.
  2. This clause can be specified on a group screen item, in which case it applies to all suitable elementary items which are subordinate to that item.

    MF SECURE and NO-ECHO are equivalent.

General Rules

  1. When the SECURE clause is specified for input fields, only spaces and the cursor appear in the screen item. For update fields, the original contents of the field are displayed, but cannot be altered.
Parent topic: Screen Section


The SIGN Clause in the Screen Section

The SIGN clause specifies the position and representation of the operational sign.

General Format

Syntax Rules

  1. The SIGN clause is allowed only with input, output and update fields whose pictures contain the character "S".
  2. This clause is allowed only with elementary items.

General Rules

  1. It is recommended that the SEPARATE option be used when the SIGN clause is specified in a screen description. If the SEPARATE option is not specified, a sign denoted by "S" in a PICTURE clause appears as an overpunch.
Parent topic: Screen Section


The SIZE Clause

The SIZE clause specifies the current size of the screen item.

General Format

Syntax Rules

  1. The SIZE clause is allowed only with elementary screen items.
  2. Identifier-1 must be an unsigned numeric integer and must not be subject to an OCCURS clause.
  3. Integer-1 must be unsigned.

General Rules

  1. The SIZE clause has no effect if the size specified is zero.
  2. If the SIZE clause is specified for a numeric or numeric edited screen item and the size specified is not zero, the screen item is treated as though it were free format. This overrides the setting of the configuration option.
  3. If the size specified in the SIZE clause is less than that implied by the associated PICTURE or VALUE clause, only the left-hand portion of the screen item appears on the screen. If the JUSTIFIED clause is present in an ACCEPT statement, only the right-hand portion of the screen item appears. The remainder of the screen item can be considered to contain spaces or zeros, as appropriate.
  4. If the size specified in the SIZE clause is greater than that implied by the PICTURE or VALUE clause for output or literal fields, the screen item is padded on the right with spaces.
  5. Changing the value in identifier-1 alters the effective size of the screen item at run time. This can alter the screen positions of items whose descriptions follow it in the Screen Section. (See the topics The LINE Clause and The COLUMN Clause.)
Parent topic: Screen Section
Related information
The LINE Clause
The COLUMN Clause


The TO Clause

The TO clause identifies the destination of data accepted.

General Format

Syntax Rules

  1. The TO clause, when used with the FROM clause, is equivalent to the USING clause, both specifying the same identifier. It must not be used with the USING clause.
  2. The identifier in the TO clause can be qualified. If no OCCURS clause applies to the screen item, this identifier can be subscripted or indexed. It must be defined in the File, Working-Storage,

    MF Local-Storage,

    or Linkage Section of the program.

General Rules

  1. Executing an ACCEPT statement on a screen item whose description includes a TO clause accepts operator-keyed data into the screen item, and then moves that data to the associated data item.
Parent topic: Screen Section


The UNDERLINE Clause

The UNDERLINE clause causes the screen item to be underlined when it appears on the screen.

General Format

Syntax Rules

  1. The UNDERLINE clause is allowed with any screen item.
  2. If the UNDERLINE clause is specified at group level, it applies to all suitable subordinate elementary items.

General Rules

  1. The UNDERLINE clause causes the screen item to be underlined when it appears on the screen.
  2. This clause has no effect if your screen hardware does not support underline.
Parent topic: Screen Section


The USAGE Clause in the Screen Section

The USAGE clause specifies the format of a data item in the computer storage.

General Format

Syntax Rules

  1. The USAGE of a Screen Section data item must be either explicitly or implicitly defined as USAGE DISPLAY or USAGE DISPLAY-1.
Parent topic: Screen Section


The USING Clause

The USING clause identifies the source of data for display.

General Format

Syntax Rules

  1. The USING clause is equivalent to the TO and FROM clauses, both specifying the same identifier. It must not be used with either the TO or FROM clause.
  2. The identifier in the USING clause can be qualified. If no OCCURS clause applies to the screen item, this identifier can be subscripted or indexed. It must be defined in the File, Working-Storage, Local-Storage, or Linkage Section of the program.

General Rules

  1. Executing a DISPLAY statement on a screen item whose description includes a USING clause moves data from the associated data item to the screen item, and then displays the screen item on the screen.
  2. Executing an ACCEPT statement on a screen item whose description includes a USING clause accepts operator-keyed data into the screen item, and then moves that data to the associated data item.
Parent topic: Screen Section


The VALUE Clause in the Screen Section

The VALUE clause specifies literal information for display on the screen.

General Format

Syntax Rules

  1. The literal associated with the VALUE clause must be nonnumeric. It cannot be a figurative constant.
  2. The VALUE clause is allowed only with elementary items that have no PICTURE clauses.

General Rules

  1. The VALUE clause specifies literal information for display on the screen.
Parent topic: Screen Section


The ZERO-FILL Clause

The ZERO-FILL clause causes trailing prompt characters to be replaced by zeros instead of spaces.

General Format

Syntax Rules

  1. This clause is allowed only with input and update fields that are alphabetic or alphanumeric.

General Rules

  1. The ZERO-FILL clause causes trailing prompt characters to be replaced by zeros instead of spaces when data is moved from the screen item to the receiving item. This occurs only if the operator enters data into the screen item.
  2. If the receiving item has a JUSTIFIED clause, the ZERO-FILL clause causes leading positions left vacant by justification to be zero-filled.
Parent topic: Screen Section


Procedure Division

  • Procedure Division General Description
  • The PROCEDURE DIVISION Header
    The Procedure Division is identified by and must begin with a header in one of the following formats:
  • Arithmetic Expressions
  • Conditional Expressions
  • Common Phrases
  • File I/O Concepts
  • Conformance for Parameters and Returning Items
  • Intrinsic Functions
  • Statements
Parent topic: Part 2. Program Definition


Procedure Division General Description

ANS85 The Procedure Division is optional.

The Procedure Division in a program definition

ISO2002 MF , function definition

or method definition contains procedures to be executed. These procedures can be declarative and/or nondeclarative.

ISO2002 MF The Procedure Division for an object definition and a factory definition contains the methods that may be invoked on the object or factory object.

MF The Procedure Division in a call prototype contains no procedures, except that it may contain the ENTRY statement.

ISO2002 MF The Procedure Division in a function prototype, method prototype or program prototype specifies the parameters and returning item, if any.

General Formats for Format 1 (with-sections)

General Formats for Format 2 (without-sections)

General Formats for Format 3 (interface-object-or-factory)

Comments:

The generic term procedure-division-header is described in the topic The PROCEDURE DIVISION Header.

Formats 1 and 2 can be used only in a program definition,

ISO2002 MF a program prototype definition, a function definition, a function prototype definition

ISO2002 MF a method definition, or a

MF call prototype.

ISO2002 MF Format 3 can be used only in a factory definition or an interface definition

ISO2002 MF or an object definition.

The declarative sentence shown above is a USE statement (see the topics The USE Statement, The USE FOR DEBUGGING Statement, and The USE BEFORE REPORTING Statement ). It specifies when the section is to be executed.

A procedure is composed of a paragraph or group of paragraphs, or a section or group of sections in the Procedure Division. A procedure-name is a word used to refer to a paragraph or section in the source element in which it occurs. It consists of a paragraph-name (that may be qualified) or a section-name.

If one paragraph is in a section, all must be.

OSVS VSC2 MF This rule is not enforced.

A paragraph comprises a paragraph-name followed by a period and a space, and any number of sentences or, if the paragraph-name is omitted, one or more successive sentences following the PROCEDURE DIVISION header or a section header. It is terminated either immediately before the next paragraph-name or section-name or at the end of the Procedure Division, or, in the declaratives portion, with END DECLARATIVES.

A section comprises a section header followed by any number of paragraphs. It is terminated either immediately before the next section or at the end of the Procedure Division, or, in the declaratives portion, with END DECLARATIVES.

VSC2 MF However, a section in the declaratives need not have a declarative-sentence; it can be invoked by a PERFORM statement. (See the topic The PERFORM Statement for details of the PERFORM statement.)

VSC2 MF Sentences that are not explicitly contained within a named paragraph as described above are considered to be contained within an unnamed implicit paragraph. Paragraphs that are not explicitly contained within a section are considered to be contained within an implicit, unnamed section.

In a program definition

ISO2002 MF or method definition,

execution begins with the first statement in the Procedure Division, excluding declaratives. Statements are then executed in the order in which they are written, except where the rules indicate some other order.

MF In a call prototype the Procedure Division is never executed.

ISO2002 MF In an object definition, declaratives behave in the same way as if they had been specified in every contained method definition

ISO2002 In a factory definition, declaratives behave in the same way as if they had been specified in every contained method definition.

This segment of the chapter deals with arithmetic and conditional expressions, common and input/output phrases, intrinsic functions and COBOL verbs.

MF The procedure-division-header is optional in Format 2 of the Procedure Division. However, it is only optional if there are no divisions coded before this and if the Procedure Division begins with a COBOL sentence (not a section header, paragraph header, or Declarative Section).

Parent topic: Procedure Division
Related information
The PROCEDURE DIVISION Header
The USE Statement
The USE FOR DEBUGGING Statement
The USE BEFORE REPORTING Statement
The PERFORM Statement


The PROCEDURE DIVISION Header

The Procedure Division is identified by and must begin with a header in one of the following formats:

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • DEFAULTCALLS - sets the default calling convention if none is explicitly coded in the Procedure Division header.
    • STICKY-LINKAGE - controls whether addressability to Linkage Section items is maintained between calls to different entry points in the same program.

Syntax Rules for All Formats

  1. MF Mnemonic-name is necessary only if the runtime element is being invoked by another runtime element and that runtime element is using a calling convention other than that used as default by your COBOL system. Typically, the default COBOL calling convention is consistent with that used by a significant implementation of a non-COBOL language for the run-time environment.

    Mnemonic-name must be defined in the Special-Names paragraph. See the topic The Special-Names Paragraph in the chapter Environment Division for details of how to do this and your COBOL system documentation on interfacing for details of which calling conventions are supported in your run time environment.

  2. MF CHAINING and USING are equivalent.
  3. ISO2002 MF If data-name-1 or data-name-2 is defined with the USAGE OBJECT REFERENCE clause, the ACTIVE-CLASS phrase must not be specified.
  4. ISO2002 MF Data-name-3 must be defined as a level 01 or level 77 entry in the Linkage Section. The data description entry for data-name-3 must not contain a REDEFINES clause. A data item elsewhere in the Linkage Section may specify REDEFINES data-name-3.
  5. ISO2002 MF Data-name-3 must not be the same as data-name-1 or data-name-2.

Syntax Rules for Format 1

  6. Data-name-1 must be defined as a level 01 or a level 77 entry in the Linkage Section

    MF , File Section or Working-Storage Section

    . A particular user-defined word must not appear more than once as data-name-1.

    OSVS VSC2 MF It may appear more than once.

    The data description entry for data-name-1 must not contain a REDEFINES clause.

    OSVS VSC2 MF It may contain a REDEFINES clause.

    Data-name-1 may, however, be the object of a REDEFINES clause elsewhere in the Linkage Section.

  7. ISO2002 MF Data-name-2 must be defined as a level 01 or a level 77 entry in the Linkage Section

    MF , File Section or Working-Storage Section , unless the source unit is a method definition or method prototype definition

    . Data-name-2 must be defined as a data item of class numeric, object or pointer.

    MF Data-name-2 can be of any class, but the length must be no greater than 8 bytes.

Syntax Rules for Formats 1 and 3

  8. ISO2002 MF NET JVM The RETURNING phrase must be specified in a function definition and in a function prototype definition.
  9. ISO2002 MF NET JVM The RETURNING phrase may be specified in a method definition, a program definition or a program prototype.

Syntax Rules for Format 2

  10. MF Format 2 can only be used in a program in which the EXTERNAL clause is specified in the Program-ID paragraph, that is a call prototype.
  11. MF Data-name-1 and data-name-2 must be defined as 01 level records in the Linkage Section.
  12. MF Typedef-name-1, typedef-name-2, and typedef-name-3 must be previously defined in the same source file as a programmer-defined usage by means of a TYPEDEF clause.

Syntax Rules for Format 3

  13. NET JVM Data-name-1, data-name-2, data-name-4 and data-name-5 must either be defined as 01 level records in the Linkage Section or be followed by the AS phrase.
  14. NET JVM Type-name-1 must be a .NET native type.
  15. NET JVM Custom-attribute-clause is as decribed in the section The CUSTOM-ATTRIBUTE clause in the Data Division chapter.
  16. NET JVM YIELDING may be specified only in the context of an Iterator. See Iterator-ID.
  17. NET JVM The type of the item specified in the YIELDING phrase determines the type of the iterator.

General Rules for All Formats

  1. Up to five data-names are permitted in the USING phrase.

    ISO2002 MF XOPEN Up to sixty-two data-names are permitted in the USING phrase.

  2. The BY REFERENCE, the BY VALUE and the BY OUTPUT phrases are transitive across the parameters that follow them until another BY REFERENCE, BY VALUE or BY OUTPUT phrase is encountered. If neither the BY REFERENCE, the BY VALUE nor the BY OUTPUT phrase is specified prior to the first parameter, the BY REFERENCE phrase is assumed.

General Rules for Format 1

  3. MF Mnemonic-name identifies the calling convention that this program assumes has been adopted by the calling program that invokes it. This calling convention is also used for subsequent entry points unless those entry points specify a calling convention explicitly. If the calling convention actually used is different to that implied by mnemonic-name, then the COBOL system may become corrupt.
  4. MF If data-name-1 is defined as a level 01 or a level 77 entry in the File Section or Working-Storage Section then the activated runtime element operates as if a data item had been declared in the Linkage Section with the same data declaration as data-name-1 and the contents of that data item were moved to data-name-1 prior to executing the first statement in the activated runtime element. In an initial program, these values are overwritten by the initialization of the program's working storage data and are therefore not available to the called program.
  5. ENT OSVS OS390 If the activating runtime element is COBOL the following rules apply. If the activating runtime element is not COBOL, see your COBOL system documentation on interfacing for details of when you need to use the BY REFERENCE or BY VALUE clauses.
  6. ENT OSVS OS390 At all times in the activated element, references to data-name-1

    ISO2002 MF , data-name-2 and data-name-3

    are resolved in accordance with their description in the Linkage Section. If this description defines a greater number of character positions than the corresponding data item in the activating element, unpredictable results can occur. Failure to comply with this rule or exceeding the maximum allowed size of the system area for a particular run time environment may result in the system becoming catastrophically corrupt.

  7. MF When a program is called and a BY REFERENCE operand in the USING phrase corresponds to a parameter in the calling program, a referential connection is established and endures until control is returned to the calling program. If the program is called a second time, without any intervening cancel of the program, and that same BY REFERENCE operand does not correspond to a parameter in the calling program, then you must not reference that operand unless the STICKY-LINKAGE Compiler directive is specified.
  8. ENT OSVS OS390 data-name 4 must be defined in the Linkage Section.

General Rules for Formats 1 and 3

  9. The USING phrase identifies the names of the formal parameters used by the program,

    ISO2002 , function

    ISO2002 MF or method for any arguments passed to it

    . The arguments passed to it are identified in the activating source element by one of the following:

    • The USING phrase of a CALL statement
    • ISO2002 The arguments in a function-identifier
    • ISO2002 MF The USING phrase of an INVOKE statement
    • ISO2002 MF The arguments specified in an inline invocation of a method
    • ISO2002 MF The arguments defined by the rules of an object-property for invocation of an implicit SET property method.

    The correspondence between the two lists of names is established on a positional basis

  10. If the argument is passed by content, the activated runtime element operates as if the record in the Linkage Section were allocated by the activating runtime element during the process of initiating the activation and as if this record does not occupy the same storage area as the argument in the activating runtime element.

    ISO2002 MF If the activated runtime element is a program for which there is no program-specifier in the Repository paragraph of the activating runtime element, the allocated record is handled as follows.

    The allocated record is of the same length as the argument, where the maximum length is used if the argument is described as a variable-occurrence data item. That argument is moved to this allocated record without conversion. This record is then treated by the activated runtime element as if it were the argument and as if it were passed by reference.

    ISO2002 MF If the activated runtime element is one of the following:

    ISO2002 MF
    • ISO2002 MF A program for which there is a program-specifier in the Repository paragraph of the activating runtime element
    • ISO2002 MF A method
    • ISO2002 MF A function

    ISO2002 MF then this allocated record is one of:

    ISO2002 MF
    • ISO2002 MF A data item of the same category, usage, and length as the argument, if the formal parameter is described with the ANY LENGTH clause
    • ISO2002 MF A data item with the same description and the same number of bytes as the formal parameter, where the maximum length is used if the formal parameter is described as a variable-occurrence data item.

    ISO2002 MF The argument is used as the sending operand and the allocated record as the receiving operand in one of the following:

    ISO2002 MF
    • ISO2002 MF If the formal parameter is numeric, a COMPUTE statement without the ROUNDED phrase
    • ISO2002 MF If the formal parameter is of class index, object, or pointer, a SET statement
    • ISO2002 MF A MOVE statement.

    ISO2002 MF The allocated record is then treated as if it were the argument and it were passed by reference.

  11. If the argument is passed by reference, the activated runtime element operates as if the formal parameter occupies the same storage area as the argument.
  12. ISO2002 MF If the argument is passed by value, the activated runtime element operates as if the record in the Linkage Section were allocated by the activating runtime element during the process of initiating the activation and as if this record does not occupy the same storage area as the argument in the activating runtime element. This allocated record is exactly the same number of alphanumeric character positions in length as the argument. That argument is moved to this allocated record without conversion. This record is then treated by the activated runtime element as if it were the argument and as if it were passed by reference.
  13. If the OPTIONAL phrase is specified for data-name-1, the OMITTED phrase may be specified as the corresponding argument; otherwise, the OMITTED phrase must not be specified as the corresponding argument.

    Note that, in COBOL, the storage for the returning item is allocated in the activating source unit. The activated element contains only a formal description in its linkage section.

General Rules for Format 2

  14. MF If a call prototype (program with the EXTERNAL clause in the Program-ID paragraph) contains a format 2 PROCEDURE DIVISION header and another program in the same source file includes a CALL literal statement referencing the program-name of this call prototype, then the following rules apply:
    1. If a call convention is specified in the CALL statement, it must match that specified (implicitly or explicitly) in the prototype. If no call convention is specified in the CALL statement, the call convention specified (implicitly or explicitly) in the prototype is used.
    2. The number of parameters specified in the CALL statement must equal the number of parameters specified in the prototype, except as allowed by the REPEATED phrase.
    3. For each parameter specified in the CALL statement, the following rules apply:
      1. If there is a BY REFERENCE or a BY CONTENT phrase associated with the parameter, the corresponding parameter in the prototype must be specified BY REFERENCE.
      2. If there is a BY VALUE phrase associated with the parameter, the corresponding parameter in the prototype must be specified BY VALUE.
      3. If the parameter in the CALL statement has no BY REFERENCE, BY CONTENT or BY VALUE phrase, the phrase specified (implicitly or explicitly) in the prototype is used.
      4. This rule overrides the rules that apply when no matching call prototype is found. In other words, when no call prototype is used, all parameters up to the first BY phrase are treated as if BY REFERENCE were specified and all parameters after any BY phrase, that do not themselves have an explicit BY phrase, use the last one in effect. However, when a matching call prototype is found, its definitions for the BY phrases take precedence.
      5. If the parameter in the prototype is of class numeric, or it is a pointer or index data-item, then the parameter in the CALL must have the same data definition.
      6. If the parameter in the prototype is of class alphanumeric, the parameter in the CALL must also be of class alphanumeric and be at least as long as the parameter in the prototype.
      7. If ANY is specified in the prototype, the parameter in the CALL statement can be of any class.
    4. If the CALL statement includes the GIVING or RETURNING clause, the prototype must also include the clause, and vice versa. The data definition of the data item specified in the CALL must be the same as that of the data item specified in the prototype.
    5. The DELIMITED BY SIZE phrase in the prototype can be used only for alphanumeric parameters. In this case, the corresponding parameter in the CALL statement is moved to an implicitly allocated data area, and a binary 0 (x"00") character is placed immediately following this copy of the data. If the BY SIZE phrase is omitted, the corresponding parameter in the CALL statement is moved to an implicitly allocated data area, and a binary 0 (x"00") character is placed immediately following the last non-space character in the copy data. The intention is to help in interfacing to languages such as C, which use null terminated text strings.
    6. The REPEATED phrase indicates that there must be at least integer-1 and no more than integer-2 repetitions of the final parameter. If integer-1 TO integer-2 is not specified, integer-1 is taken as 0 and integer-2 as infinite.

General Rules for Format 3

  15. NET JVM The data item referenced by data-name-5 has no value when the runtime element is activated. An attempt to access the value of the data item referenced by data-name-5 prior to that item being a receiving item will result in a runtime exception..
  16. NET JVM At all times in the activated element, references to data-name-1, data-name-2, data-name-4 and data-name-5 are resolved in accordance with their description in the Linkage Section or the AS phrase. If this description defines a greater number of character positions than the corresponding data item in the activating element, unpredictable results can occur. Failure to comply with this rule or exceeding the maximum allowed size of the system area for a particular run time environment may result in the system becoming catastrophically corrupt.
  17. NET JVM If the CUSTOM-ATTRIBUTE clause is specified, the custom attribute information is included in the generated code..
Parent topic: Procedure Division
Related information
The Iterator-ID Paragraph
The Special-Names Paragraph


Arithmetic Expressions

An arithmetic expression can be an identifier of a numeric elementary item, a numeric literal, such identifiers and literals separated by arithmetic operators or bitwise operators (or both), two arithmetic expressions separated by an arithmetic or bitwise operator, or an arithmetic expression enclosed in parentheses. Any arithmetic expression can be preceded by a unary arithemetic or bitwise operator.

OSVS VSC2 MF In the following discussion:

  • OSVS VSC2 MF The term "numeric data item" encompasses floating-point data items in addition to fixed-point data items
  • OSVS VSC2 MF The term "numeric literal" encompasses floating-point literals in addition to fixed-point literals

Those identifiers and literals appearing in an arithmetic expression must represent either numeric elementary items or numeric literals on which arithmetic can be performed.

  • Arithmetic Operators
  • Bitwise Operators
  • Permissible Combinations of Symbols
  • Formation and Evaluation Rules
  • Intermediate Results
Parent topic: Procedure Division


Arithmetic Operators

Five binary arithmetic operators and two unary arithmetic operators can be used in arithmetic expressions. They are represented by specific characters that must be preceded by a space and followed by a space.

Binary Arithmetic Operators | Meaning
+ | Addition
- | Subtraction
* | Multiplication
/ | Division
** | Exponentiation
Unary Arithmetic Operators | Meaning
+ | The effect of multiplication by numeric literal +1
- | The effect of multiplication by numeric literal -1
Parent topic: Arithmetic Expressions
Related reference
Undefined Results of MOVE and Arithmetic Operations


Bitwise Operators

Four binary bitwise operators and one unary bitwise operator can be used in arithmetic expressions. They are represented by reserved words that must be preceded by a space and followed by a space.

Binary Bitwise Operators | Meaning
B-AND | The effect of performing a logical AND between the two data items
B-OR | The effect of performing a logical OR between the two data items
B-XOR | The effect of performing a logical XOR (exclusive OR) between the two data items
B-EXOR | The effect of performing a logical XOR (exclusive OR) between the two data items
Unary Bitwise Operator | Meaning
B-NOT | The effect of performing a logical NOT on the data item

B-XOR and B-EXOR are equivalent.

These operators can only be used in any arithmetic expressions with COMP-5, COMP-X or numeric literal operands. B-NOT takes one operand. The rest take two operands. The result is as if the equivalent logical operator library routine were used on the operands and the result returned in a temporary data item the size of the largest item used. If the items differ in size then the smaller item is moved to a temporary data item of the same size as the larger item. If the operands are of mixed type (COMP-5, COMP-X) then the smaller operand is moved to a temporary item of the same type as the larger. For best performance use consistent data types.

Here is an example program:

data division.
working-storage section.
01 n1 pic 9(9).
 01 n2 pic xx comp-5.
 01 n3 pic xxxx comp-5.
 procedure division.
     move 2 to n2
     move 4 to n3
     compute n1 = n2 b-or n3        *> n1 = 6
     if n2 b-and n3 = n2
         display 'true'
     end-if
     compute n1 = b-not n2          *> n1 = 65533
     compute n1 = n2 b-xor n3 + 1   *> n1 = 7
     compute n1 = n2 b-and 2        *> n1 = 2
Parent topic: Arithmetic Expressions


Permissible Combinations of Symbols

The permissible combinations of variables, numeric literals, arithmetic operator and parentheses are given in Table 1.

Table 1. Combination Of Symbols In Arithmetic Expressions
First Symbol | Second Symbol
 | Variable | * / ** + - B-AND B-OR B-XOR B-EXOR | Unary + - B-NOT | ( | )
Variable | - | P | - | - | P
* / ** + - B-AND B-OR B-XOR B-EXOR | P | - | P | P | -
Unary + - B-NOT | P | - | - | P | -
( | P | - | P | P | -
) | - | P | - | - | P
P | indicates a permissible pair of symbols
- | indicates an invalid pair
Variable | indicates an identifier or literal
Parent topic: Arithmetic Expressions


Formation and Evaluation Rules

The following formation and evaluation rules aplly to arithmetic expressions:

  1. Parentheses can be used in arithmetic expressions to specify the order in which elements are to be evaluated. Expressions within parentheses are evaluated first, and within nested parentheses, evaluation proceeds from the least inclusive set to the most inclusive set. When parentheses are not used, or parenthesized expressions are at the same level of inclusiveness, the following hierarchical order of execution is implied:
    1st | Unary plus and minus, B-NOT
    2nd | Exponentiation
    3rd | Multiplication and division
    4th | Addition and subtraction
    5th | B-AND
    6th | B-XOR and B-EXOR
    7th | B-OR

    Thus, in the expression:

     1 + 2 * 3

    the order of evaluation is:

    1. 2 * 3

      yielding an intermediate result of 6

    2. 1 + 6

      giving a result of 7.

  2. Parentheses are used either to eliminate ambiguities in logic where consecutive operations of the same hierarchical level appear or to modify the normal hierarchical sequence of execution in expressions where it is necessary to have some deviation from the normal precedence. When the sequence of execution is not specified by parentheses, the order of execution of consecutive operations of the same hierarchical level is from left to right.
  3. An arithmetic expression can only begin with the symbol "(", "+", "-", the bitwise operator B-NOT, or a variable, and can only end with a ")" or a variable. There must be a one-to-one correspondence between left and right parenthesis of an arithmetic expression such that each left parenthesis is to the left of its corresponding right parenthesis.
  4. Arithmetic expressions allow you to combine arithmetic operations without the restrictions on composite of operands and/or receiving data items. See, for example, Syntax Rule 3 of The ADD Statement in this chapter.
Parent topic: Arithmetic Expressions


Intermediate Results

As the expression is evaluated, one or more intermediate results is derived. Conceptually, each intermediate result is stored in a temporary data item, the value of which is determined by the parameter you select in the ARITHMETIC Compiler directive.

If you select the ARITHMETIC"MF" Compiler directive, the Micro Focus COBOL system evaluates each intermediate result using an internal floating-point register of 40 decimal digits. The most significant nonzero digit of each nonzero intermediate result is stored in the first digit of the register. The decimal point location depends on the value. Intermediate results are truncated to 40 digits.

If you select the ARITHMETIC"TRUNC20" Compiler directive, the Micro Focus COBOL system evaluates each intermediate result in the same manner as when ARITHMETIC"MF" is selected, except that the number of digits to the right of the decimal point is truncated to 20 at each step in the evaluation of the expression. You should use this directive only when you require truncation similar to that provided in COBOL WorkBench. If you use this directive, you must not change the setting of the INTLEVEL compiler directive from its default value of "2". This means that you cannot use some of the newer features, such as numeric pictures with more than 18 total digits, with the TRUNC20 parameter.

The OS/VS COBOL, VS COBOL II, DOS/VS COBOL, COBOL/370 and OS/390 systems compute intermediate results to an accuracy determined by the pictures of the operands in the expressions. The rules, which are slightly different for each version of COBOL, are documented in appendices of the IBM VS COBOL for OS/VS manual, the VS COBOL II Application Programming Guide, and the COBOL for OS/390 & VM V2R2 Programming Guide. Each intermediate result has a picture of 9(n)V9(m). The maximum value of n+m is either 30 or 31 depending on the system and the chosen arithmetic option.

If you specify the OSVS or VSC2 options for intermediate results, this COBOL system emulates the selected mainframe behavior by truncating its results accordingly, with the following limitations:

  • The maximum number of integer and decimal places allowed by this COBOL system is 18 for each. Truncation of intermediate results ceases at the point in the expression where this limit is reached. A warning message is issued at compile time if this occurs.
  • The rules apply to fixed-point numerical expressions only. If the expression contains any floating-point operands or any operation which causes it to be evaluated in floating point (see the topic Intrinsic Functions), all truncation of intermediate results ceases.
  • Floating-point results are, by their nature, inexact and may vary across platforms by a small degree.
Parent topic: Arithmetic Expressions
Related information
Intrinsic Functions


Conditional Expressions

Conditional expressions identify conditions that are tested to enable selection between alternate paths of control depending upon the truth value of the condition. Conditional expressions are specified in the

ANS85 EVALUATE,

IF, PERFORM and SEARCH statements. Two categories of conditions are associated with conditional expressions: simple conditions and complex conditions. Each can be enclosed within any number of paired parentheses, in which case its category is not changed.

OSVS If the OSVS Compiler directive is set, reference modification cannot be used within a conditional expression.

  • Simple Conditions
  • Complex Condition
  • Abbreviated Combined Relation Conditions
Parent topic: Procedure Division


Simple Conditions

The simple conditions are the relation, class, condition-name, switch-status, sign and omitted-argument conditions. A simple condition has a truth value of "true" or "false". The inclusion in parentheses of simple conditions does not change the simple truth value.

See also Complex Condition.

  • Relation Condition
  • Class Condition
    The class condition determines whether the operand is numeric, or alphabetic
  • Condition-name Condition (Conditional Variable)
    In a condition-name condition, a conditional variable is tested to determine whether or not its value is equal to one of the values associated with a condition-name.
  • Switch-Status Condition
    A switch-status condition determines the "on" or "off" status of one of the
  • Sign Condition
    The sign condition determines whether or not the algebraic value of an arithmetic expression is less than, greater than, or equal to zero. The general format for a sign condition is as follows:
  • Omitted-argument Condition
    The omitted-argument condition determines whether an argument was provided to a function, method, or program.
  • Instance-of Condition
    The instance-of condition determines whether an object reference is an instance of a particular class or interface.
Parent topic: Conditional Expressions
Related information
Complex Condition


Relation Condition

A relation condition causes a comparison of two operands, each of which can be the data item referenced by an identifier, a literal or the value resulting from an arithmetic expression. A relation condition has a truth value of "true" if the relation exists between the operands. Comparison of two numeric operands is permitted regardless of the formats specified in their respective USAGE clauses. However, for all other comparisons the operands must have the same usage. If either of the operands is a group item, the nonnumeric comparison rules apply.

OSVS VSC2 A nonnumeric literal can be enclosed in parentheses.

OSVS Note that " = TO", "> THAN" and "< THAN" are accepted.

The first operand (identifier-1, literal-1 or arithmetic-expression-1) is called the subject of the condition; the second operand (identifier-2 or literal-2 or arithmetic-expression-2) is called the object of the condition. The relation condition must contain at least one reference to a variable.

The relational operator specifies the type of comparison to be made in a relation condition. A space must precede and follow each reserved word comprising the relational operator. When used, "NOT" and the next key word or relation character are one relational operator that defines the comparison to be executed for truth value; for example, "NOT EQUAL" is a truth test for an "unequal" comparison; " NOT GREATER" is a truth test for an "equal" or "less" comparison. The meaning of the relational operators is shown in the Relational Operators table below.

The following relational operators are equivalent:

IS EQUAL TO | and | EQUALS;
IS NOT EQUAL TO | and | IS UNEQUAL TO;
IS GREATER THAN | and | EXCEEDS;
IS NOT GREATER THAN | and | IS LESS THAN OR EQUAL TO;
IS NOT LESS THAN | and | IS GREATER THAN OR EQUAL TO.
Table 1. Relational Operators
Meaning | Relational Operator
Greater than or not greater than | {short description of image}
Less than or not less than | {short description of image}
Equal or not equal to | {short description of image}
Greater than or equal to | {short description of image}
Less than or equal to | {short description of image}
Equal to | {short description of image}
Not equal to | {short description of image}
Greater than | {short description of image}

The required relational characters '<', '>', and '=' are not underlined to avoid confusion with other symbols such as '>' (greater than or equal to).

  • Comparison of Numeric Operands (Relation Condition)
  • Comparison of Nonnumeric Operands (Relation Condition)
  • Comparisons Involving Index-Names and/or Index Data Items (Relation Condition)
  • Comparisons Involving Data Items with USAGE POINTER (Relation Condition)
    Two items whose USAGE is either implicitly or explicitly POINTER can be compared. Only the relational operators which test for exact equality or inequality are permitted in pointer comparisons.
  • Comparisons Involving Data Items with USAGE PROCEDURE-POINTER (Relation Condition)
    Two items whose USAGE is PROCEDURE-POINTER can be compared.
  • Comparisons Involving Data Items with USAGE OBJECT (Relation Condition)
    You can compare two object references to see if they refer to the same object.
Parent topic: Simple Conditions


Comparison of Numeric Operands (Relation Condition)

General Format:

Note that the required relational characters "<" , ">", and "=" are not underlined, to avoid confusion with other symbols such as " ? ".

General Rules:

  1. For operands whose class is numeric a comparison is made with respect to the algebraic value of the operands. The length of the literal or arithmetic expression operands in terms of number of digits represented, is not significant. Zero is considered a unique value regardless of the sign.
  2. Comparison of these operands is permitted regardless of the manner in which their usage is described. Unsigned numeric operands are considered positive for purposes of comparison.
  3. Numeric-edited items are of class alphanumeric, and comparisons involving them follow the rules for comparison of nonnumeric operands, as below.
Parent topic: Relation Condition


Comparison of Nonnumeric Operands (Relation Condition)

General Format:

Note that the required relational characters "<" , ">", and "=" are not underlined, to avoid confusion with other symbols such as " ? ".

General Rules:

  1. For nonnumeric operands, or one numeric and one nonnumeric operand, a comparison is made with respect to a specified collating sequence of characters (see the topic The Object-Computer Paragraph). If one of the operands is specified as numeric, it must be an integer data item or an integer literal and:
    1. If the nonnumeric operand is an elementary data item or a nonnumeric literal, the numeric operand is treated as though it were moved to an elementary alphanumeric data item of the same size as the numeric data item (in terms of standard data format characters), and the contents of this alphanumeric data item were then compared to the nonnumeric operand. (See the topic The MOVE Statement.)
    2. If the nonnumeric operand is a group item, the numeric operand is treated as though it were moved to a group item of the same size as the numeric data item (in terms of standard data format characters), and the contents of this group item were then compared to the nonnumeric operand. (See the topic The MOVE Statement.)
    3. A non-integer numeric operand cannot be compared to a nonnumeric operand.

    The size of an operand is the total number of standard data format characters in the operand.

  2. OSVS Comparison of a numeric-edited data item with figurative constants is allowed and is treated as an alphanumeric comparison.
  3. MF Numeric and nonnumeric operands can be compared when their usage is not the same. The numeric operand is treated as if it were moved to a USAGE DISPLAY item of the same size (in terms of standard data format characters), and the contents of this were then compared to the nonnumeric operand.

    There are two cases to consider:

    1. Operands of equal size - if the operands are of equal size, comparison effectively proceeds by comparing characters in corresponding character positions starting from the high order end and continuing until either a pair of unequal characters is encountered or the low order end of the operand is reached, whichever comes first. The operands are determined to be equal if all pairs of characters compare equally through the last pair, when the low order end is reached.

      The first encountered pair of unequal characters is compared to determine their relative position in the collating sequence. The operand that contains the character that is positioned higher in the collating sequence is considered to be the greater operand.

    2. Operands of unequal size - if the operands are of unequal size, comparison proceeds as though the shorter operand were extended on the right by sufficient spaces to make the operands of equal size.
Parent topic: Relation Condition
Related information
The Object-Computer Paragraph
The MOVE Statement


Comparisons Involving Index-Names and/or Index Data Items (Relation Condition)

General Format:

Note that the required relational characters "<" , ">", and "=" are not underlined, to avoid confusion with other symbols such as " ? ".

General Rules:

  1. Relation tests can be made only between:

    1. Two index-names. The result is the same as if the corresponding occurrence numbers were compared.
    2. An index-name and a numeric data item or numeric literal. The occurrence number that corresponds to the value of the index-name is compared to the data item or literal.
    3. An index data item and an index-name or another index data item. The actual values are compared without conversion.
    4. OSVS VSC2 An index-name can be compared with an arithmetic expression. The occurrence number that corresponds to the value of the index-name is compared to the computed value of the expression.
    5. The result of the comparison of an index data item with any data item or literal not specified above is undefined.
Parent topic: Relation Condition


Comparisons Involving Data Items with USAGE POINTER (Relation Condition)

Two items whose USAGE is either implicitly or explicitly POINTER can be compared. Only the relational operators which test for exact equality or inequality are permitted in pointer comparisons.

General Format

Syntax Rules

  1. Identifier-1 and identifier-3 refer to an 01 or 77 level items in the Linkage Section.
  2. MF Identifier-1 and identifier-3 can refer to any data items defined in the Data Division.
  3. Identifier-2 and identifier-4 refer to items with USAGE IS POINTER.
  4. Only one operand in the comparison can be the figurative constant NULL.

General Rules

  1. The operands are equal if the two addresses are the same, otherwise they are unequal.
  2. This type of relation condition is allowed in IF, PERFORM, EVALUATE and SEARCH (Format 1) statements. It is not allowed in SEARCH (Format 2) statements (SEARCH ALL) because no meaningful ordering can be applied to pointer data items.
Parent topic: Relation Condition


Comparisons Involving Data Items with USAGE PROCEDURE-POINTER (Relation Condition)

Two items whose USAGE is PROCEDURE-POINTER can be compared.

General Format

Syntax Rules

  1. Identifier-1 and identifier-2 refer to items with USAGE IS PROCEDURE-POINTER.
  2. Only one operand in the comparison can be the figurative constant NULL.

General Rules

  1. The operands are equal if the two addresses are the same, otherwise they are unequal.
  2. This type of relation condition is allowed in IF, PERFORM, EVALUATE and SEARCH (Format 1) statements. It is not allowed in SEARCH (Format 2) statements (SEARCH ALL) because no meaningful ordering can be applied to pointer data items.
Parent topic: Relation Condition


Comparisons Involving Data Items with USAGE OBJECT (Relation Condition)

You can compare two object references to see if they refer to the same object.

General Format

Syntax Rules

  1. Only one operand in the comparison can be the figurative constant NULL.

General Rules

  1. The operands are equal if they identify the same object, otherwise they are unequal.
Parent topic: Relation Condition


Class Condition

The class condition determines whether the operand is numeric, or alphabetic

ANS85 or alphabetic-lower, or alphabetic-upper, or contains only the characters in the set of characters specified by the CLASS clause as defined in the Special-Names paragraph of the Environment Division.

General Format

Syntax Rules

  1. The class of an operand is determined as follows:
    1. An operand is numeric if it consists entirely of the characters 0,1, 2, 3, ... , 9, with or without an operational sign.
    2. An operand is alphabetic if it consists entirely of the upper-case letters A, B, C, ... , Z, space,

      ANS85 or the lower-case letters a, b, c, ... , z, space,

      or any combination of the upper-case

      ANS85 and lower-case

      letters and spaces.

    3. ANS85 An operand is alphabetic-lower if it consists entirely of the lower-case letters a, b, c, ... , z, and space.
    4. ANS85 An operand is alphabetic-upper if it consists entirely of the upper-case letters A, B, C, ... , Z, and space.
    5. ANS85 An operand conforms to class-name-1 if it consists entirely of the characters listed in the definition of class-name-1 in the Special-Names paragraph.
  2. Identifier-1 must reference a data item whose usage is explicitly or implicitly DISPLAY, or in the case of the NUMERIC test, is one of: DISPLAY,

    MF COMPUTATIONAL, COMPUTATIONAL-X,

    OSVS VSC2 MF XOPEN COMPUTATIONAL-3

    MF XOPEN COMPUTATIONAL-5

    ANS85 or PACKED-DECIMAL.

  3. ANS85 If identifier-1 is a function-identifier, it must reference an alphanumeric

    MF or national

    function.

General Rules

  1. When the class condition does not include the word NOT and identifier-1 is a zero-length group item, the result of the class test is always false.

    When used, NOT and the next key word specify one class condition that defines the class test to be executed for truth value; e.g. NOT NUMERIC is a truth test for determining that an operand is nonnumeric. When the class condition includes the word NOT and identifier-1 is a zero-length group item, the result of the class test is always true.

    MF The truth value of a class test involving a zero-length group item is reversed by the ZEROLENGTHFALSE Compiler directive.

  2. The NUMERIC test cannot be used with an item whose data description describes the item as alphabetic or as a group item composed of elementary items whose data description indicates the presence of operational sign(s). If the data description of the item being tested does not indicate the presence of an operational sign, the item being tested is determined to be numeric only if the contents are numeric and an operational sign is not present. If the data description of an elementary item being tested does indicate the presence of an operational sign, the item being tested is determined to be numeric only if the contents are numeric and a valid operational sign is present. Valid operational signs for data items described with the SIGN IS SEPARATE clause are the standard data format characters, "+" and "-"; valid operational signs for data items not described with the SIGN IS SEPARATE clause are described in the section Selection of Character Representation and Radix in the chapter Concepts of the COBOL Language.

    OSVS MF The NUMERIC test can be used with an item defined as a group item composed of elementary items whose data description indicates the presence of operational sign(s).

  3. The ALPHABETIC test cannot be used with an item whose data description describes the item as numeric. The item being tested is determined to be alphabetic only if the contents consist of any combination of the upper-case alphabetic characters "A" through "Z" and the space

    ANS85 and any combination of the lower-case alphabetic characters "a" through "z"

    and the space.

    OSVS VSC2 MF The class condition cannot be used for external floating-point (USAGE DISPLAY) or internal floating-point (USAGE COMP-1 and USAGE COMP-2) items.

  4. ANS85 The ALPHABETIC-LOWER test cannot be used with an item whose data description describes the item as numeric. The result of the test is true if the content of the data item referenced by identifier-1 consists entirely of the lower-case alphabetic characters "a" through "z" and space.
  5. ANS85 The ALPHABETIC-UPPER test cannot be used with an item whose data description describes the item as numeric. The result of the test is true if the content of the data item referenced by identifier-1 consists entirely of the upper-case alphabetic characters "A" through "Z" and space.
  6. MF The class-name-1 test must not be used with an item whose data description describes the item as numeric.
Parent topic: Simple Conditions
Related information
Selection of Character Representation and Radix


Condition-name Condition (Conditional Variable)

In a condition-name condition, a conditional variable is tested to determine whether or not its value is equal to one of the values associated with a condition-name.

General Format

Syntax Rules

  1. OSVS VSC2 MF Condition-names with DBCS and internal floating-point items are allowed.
  2. MF Condition-names with external floating-point items are allowed.

General Rules

  1. If the condition-name is associated with a value or range of values, then the conditional variable is tested to determine whether or not its value falls in this range, including the end values.
  2. The rules for comparing a conditional variable with a condition-name value are the same as those specified for relation conditions.
  3. The result of the test is true if one of the values corresponding to the condition-name equals the value of its associated conditional variable.
Parent topic: Simple Conditions


Switch-Status Condition

A switch-status condition determines the "on" or "off" status of one of the

MF nine

COBOL switches

MF named respectively SWITCH-0 through SWITCH-8.

The value of each of these switches ("on" or "off" ) is set by the operator at the start of execution of the COBOL run unit. (See the discussion of RTS switches in your COBOL system documentation for details.) The switch and the "on" or "off" value associated with the condition must be named in the Special-Names paragraph of the Environment Division described earlier in this chapter; see the topic The Special-Names Paragraph.

General Format

Comments:

The result of the test is true if the switch is set to the specified position corresponding to the condition-name.

If the compiler directive SWITCH-TYPE is set to 1, which is the default, it is only possible to use the Switch-Status Condition to test if a COBOL switch is set from within the runtime element that set the switch.

If the compiler directive SWITCH-TYPE is set to 2, which is set by the compiler when the compiler directive DIALECT is set to ISO2000, it is possible to use the Switch-Status Condition to test if a COBOL switch is set from within any runtime element of the run unit.

Parent topic: Simple Conditions
Related information
The Special-Names Paragraph


Sign Condition

The sign condition determines whether or not the algebraic value of an arithmetic expression is less than, greater than, or equal to zero. The general format for a sign condition is as follows:

General Format:

General Rules:

  1. When used, "NOT" and the next keyword specify one sign condition that defines that algebraic test to be executed for truth value; for example, "NOT ZERO" is a truth test for a nonzero (positive or negative) value. An operand is positive if its value is greater than zero, negative if its value is less than zero, and zero if its value is equal to zero. The arithmetic expression must contain at least one reference to a variable.
  2. OSVS ZEROS or ZEROES can be used instead of ZERO in a sign test.
Parent topic: Simple Conditions


Omitted-argument Condition

The omitted-argument condition determines whether an argument was provided to a function, method, or program.

General Format

data-name-1 IS [ NOT ] OMITTED

Syntax Rules

  1. Data-name-1 must be a formal parameter defined in the source element in which this condition is specified.

General Rules

  1. The result of the OMITTED test is true if one of the following conditions applies:
    1. If the OMITTED phrase, rather than an identifier or literal, is specified as the argument corresponding to data-name-1 in the statement that activated this program, function, or method
    2. The argument corresponding to data-name-1 was a trailing argument that was omitted from the activating statement
    3. If the argument corresponding to data-name-1 is itself a formal parameter for which the omitted-argument condition is true.
  2. When used, NOT and the keyword OMITTED specify one condition to be executed for truth values.
Parent topic: Simple Conditions


Instance-of Condition

The instance-of condition determines whether an object reference is an instance of a particular class or interface.

General Format

Syntax Rules

  1. Object-identifier-1 must be an object reference.
  2. Class-name-1 must be the name of a class specified in the Repository paragraph or the Class-Control paragraph of this source element.
  3. Interface-name-1 must be the name of an interface specified in the Repository paragraph or the Class-Control paragraph of this source element.

General Rules

  1. If none of the optional phrases is specified, the result of the instance-of test is true if the object named by object-identifier-1 is an instance of the class named by class-name-1 or one of its subclasses, or the interface named by interface-name-1 or one of its subinterfaces.
  2. If the FACTORY phrase is specified and the ONLY phrase is not specified, the result of the instance-of test is true if the object named by object-identifier-1 is the factory of the class named by class-name-1.
  3. If the ONLY phrase is specified and the FACTORY phrase is not specified, the result of the instance-of test is true if the object named by object-identifier-1 is an instance of the class named by class-name-1, and not one of its subclasses.
  4. If both the FACTORY phrase and the ONLY phrase are specified, the result of the instance-of test is true if the object named by object-identifier-1 is the factory of the class named by class-name-1, and not one of its subclasses
Parent topic: Simple Conditions


Complex Condition

A complex condition is formed by combining simple conditions, combined conditions and/or complex conditions with logical connectors (logical operators "AND" and "OR" ) or negating these conditions with logical negation (the logical operator "NOT"). The truth value of a complex condition, whether parenthesized or not, is that truth value which results from the interaction of all the stated logical operators on the individual truth values of simple conditions, or the intermediate truth values of conditions logically connected or logically negated.

The logical operators and their meanings are:

Operator | Meaning
AND | Logical conjunction; the truth value is "true" if both of the conjoined conditions are true; "false" if one or both of the conjoined conditions is false.
OR | Logical inclusive OR; the truth value is "true" if one or both of the included conditions is true; "false" if both included conditions are false.
NOT | Logical negation or reversal of truth value; the truth value is "true" if the condition is false; "false" if the condition is true.

The logical operators must be preceded by a space and followed by a space.

  • Negated Simple Condition
    A simple condition is negated through the use of the logical operator "NOT". The negated simple condition effects the opposite truth value for a simple condition. Thus the truth value of a negated simple condition is "true" if and only if the truth value of the simple condition is "false" ; the truth value of a negated simple condition is "false" if and only if the truth value of the simple condition is "true". The inclusion in parentheses of a negated simple condition does not change the truth value.
  • Combined and Negated Combined Condition
    A combined condition results from connecting conditions with one of the logical operators "AND" or "OR".
Parent topic: Conditional Expressions
Related information
Simple Conditions


Negated Simple Condition

A simple condition is negated through the use of the logical operator "NOT". The negated simple condition effects the opposite truth value for a simple condition. Thus the truth value of a negated simple condition is "true" if and only if the truth value of the simple condition is "false" ; the truth value of a negated simple condition is "false" if and only if the truth value of the simple condition is "true". The inclusion in parentheses of a negated simple condition does not change the truth value.

General Format

Parent topic: Complex Condition


Combined and Negated Combined Condition

A combined condition results from connecting conditions with one of the logical operators "AND" or "OR".

General Format

Syntax Rules

  1. Condition may be:
    • A simple condition
    • A negated simple condition
    • A combined condition
    • A negated combined condition; that is, the "NOT" logical operator followed by a combined condition enclosed within parentheses
    • Combinations of the above, specified according to the rules summarized in the table in the Comments section below.
  2. Although parentheses need never be used when either "AND" or "OR" (but not both) is used exclusively in a combined condition, parentheses can be used to effect a final truth value when a mixture of "AND", "OR" and "NOT" is used.

General Rules

  1. In the absence of the relevant parentheses in a complex condition, the precedence (that is, binding power) of the logical operators determines the conditions to which the specified logical operators apply and implies the equivalent parentheses. The order of precedence is "NOT", "AND" , "OR". Thus, specifying "condition-1 OR NOT condition-2 AND condition-3" implies and is equivalent to specifying "condition-1 OR ((NOT condition-2) AND condition-3)".
  2. Where parentheses are used in a complex condition, precedence is used to determine the binding of conditions to logical operator. Parentheses can, therefore, be used to depart from the normal precedence of logical operators as specified above. Thus, the example complex condition above can be given a different meaning by specifying it as a "(condition-1 OR (NOT condition-2)) AND condition-3". (See the topic Condition Evaluation Rules.)

Comments:

The table below indicates the ways in which conditions and logical operators can be combined and parenthesized. There must be a one-to-one correspondence between left and right parentheses such that each left parenthesis is to the left of its corresponding right parenthesis.

Table 1. Combinations of Conditions, Logical Operators, and Parentheses
Element | Permitted location in conditional expression | Element can be preceded by only: | Element can be followed by only:
simple-condition | Any | OR, NOT, AND, ( | OR, AND, )
OR or AND | Not first or last | simple-condition, ) | simple-condition, NOT, (
NOT | Not last | OR, AND, ( | simple-condition, (
( | Not last | OR, NOT, AND, ( | simple-condition, NOT, (
) | Not first | simple-condition, ) | OR, AND, )

Thus, the element pair "OR NOT" is permissible while the pair "NOT OR" is not permissible; "NOT ( " is permissible while "NOT NOT" is not permissible.

Parent topic: Complex Condition
Related information
Condition Evaluation Rules


Abbreviated Combined Relation Conditions

When simple or negated simple relation conditions are combined with logical connectives in a consecutive sequence such that a succeeding relation condition contains a subject or subject and relational operator that is common with the preceding relation condition, and no parentheses are used within such a consecutive sequence, any relation condition except the first can be abbreviated by either of the following means:

  • The omission of the subject of the relation condition
  • The omission of the subject and relational operator of the relation condition.

General Format

Comments:

Within a sequence of relation conditions both of the above forms of abbreviation can be used. The effect of using such abbreviations is as if the last preceding stated subject were inserted in place of the omitted subject, and the last stated relational operator were inserted in place of the omitted relational operator. The result of such implied insertion must comply with the rules of the table Relational Operators. This insertion of an omitted subject and/or relational operator terminates once a complete simple condition is encountered within a complex condition.

OSVS The order of evaluation of the conditions can be prioritized by the use of parentheses (see example below).

The interpretation applied to the use of the word "NOT" in an abbreviated combined relation condition is as follows:

  1. ANS85 If NOT is immediately followed by the word GREATER, >, LESS, <, EQUAL, or =, excluding the relational operators GREATER THAN OR EQUAL TO, >=, LESS THAN OR EQUAL TO, and <=, then the word NOT is interpreted as part of the relational operator, otherwise:
  2. The "NOT" is interpreted as a logical operator and, therefore, the implied insertion of subject or relational operator results in a negated relation condition.

Some examples of abbreviated combined and negated combined relation conditions and expanded equivalents follow.

Abbreviated Combined Relation Condition | Expanded Equivalent
a > b AND NOT < c OR d | ((a > b) AND (a NOT < c)) OR (a NOT < d)
a NOT EQUAL b OR c | (a NOT EQUAL b) OR (a NOT EQUAL c)
NOT a = b OR c | (NOT (a = b)) OR (a = c)
NOT (a GREATER b OR < c) | NOT ((a GREATER b) OR (a < c))
NOT (a NOT > b AND c AND NOT d | NOT ((((a NOT > b) AND (a NOT > c)) AND (NOT (a NOT > d))))
x > a OR y AND z | x > a OR (x > y AND x > z)
x > a OR (y AND z) | x > a OR (x > y AND x > z)
x > (a OR y) AND z | (x > a OR x > y) AND x > z
x ( = a OR > b) | x = a OR x > b
x = a AND ( > b OR < z ) | x = a AND ( x > b OR x < z )
a EQUAL b OR NOT GREATER OR EQUAL c OR d | (a EQUAL b) OR (NOT (a GREATER OR EQUAL c)) OR (a GREATER OR EQUAL d)
a EQUAL b OR NOT >=c OR d | (a EQUAL b) OR (NOT (a >= c)) OR (a >= d)
  • Condition Evaluation Rules
Parent topic: Conditional Expressions
Related information
Relational Operators


Condition Evaluation Rules

Parentheses can be used to specify the order in which individual conditions of complex conditions are to be evaluated when it is necessary to depart from the implied evaluation precedence.

Conditions within parentheses are evaluated first, and, within nested parentheses, evaluation proceeds from the least inclusive condition to the most inclusive condition. When parentheses are not used, or parenthesized conditions are at the same level of inclusiveness, the following hierarchical order of logical evaluation is implied until the final truth value is determined:

  1. ANS85 Values are established for arithmetic expressions and functions if and when the conditions containing them are evaluated. Similarly, negated conditions are evaluated if and when it is necessary to evaluate the complex condition that they represent. (See the section Formation and Evaluation Rules.)
  2. Truth values for simple conditions are established in the following order:

    relation (following the expansion of any abbreviated relation condition) class condition-name switch-status sign

  3. Truth values for negated conditions are established.
  4. Truth values for combined conditions are established: "AND" logical operators, followed by "OR" logical operators.
  5. Truth values for negated combined conditions are established.
  6. When the sequence of evaluation is not completely specified by parentheses, the order of evaluation of consecutive operations of the same hierarchical level is from left to right.
Parent topic: Abbreviated Combined Relation Conditions
Related information
Formation and Evaluation Rules


Common Phrases

In the statement descriptions several phrases appear frequently.

In these phrases, the term "resultant-identifier" refers to that identifier associated with the result of an arithmetic operation.

  • Arithmetic Statements
  • Overlapping Operands
  • Multiple Results in Arithmetic Statements
  • Incompatible Data
  • Signed Receiving Items
  • The ROUNDED Phrase
  • The ON SIZE ERROR Phrase and NOT ON SIZE ERROR Phrase
  • The CORRESPONDING Phrase
Parent topic: Procedure Division


Arithmetic Statements

The arithmetic statements are the ADD, COMPUTE, DIVIDE, MULTIPLY and SUBTRACT statements. Common features are as follows:

  1. The data descriptions of the operands need not be the same; any necessary conversion and decimal point alignment are supplied throughout the calculation.

  2. The composite of operands is a hypothetical data item resulting from the superimposition of specified operands in a statement aligned on their decimal points.

    ANS85 The composite of operands for ADD, DIVIDE, MULTIPLY and SUBTRACT statements must not contain more than 18 decimal digits.

    MF There is no limit on the composite of operands.

Parent topic: Common Phrases


Overlapping Operands

When a sending and a receiving item in a statement share a part of their storage areas,

ANS85 yet are not defined by the same data description entry,

the result of the execution of such a statement is undefined.

MF Overlapping moves are detected at compile time only when the MOVE verb is used and neither operand uses reference modification or subscripting. Forward overlapping moves result in a warning message, if you set the Compiler directive WARNING"3". Any other types result in flagging messages, if you set the Compiler directive FLAG"dialect", where "dialect" is anything but OSVS. Other operations resulting in sending and receiving items sharing the same memory are not detected.

MF Although portability of COBOL source code is only guaranteed when there are no overlapping MOVE statements, this COBOL system does allow such statements. The behavior of such statements is sensitive to the BYTE-MODE-MOVE Compiler directive.

Parent topic: Common Phrases


Multiple Results in Arithmetic Statements

The ADD, COMPUTE, DIVIDE, MULTIPLY and SUBTRACT statements can have multiple results. Such statements behave as though they had been written in the following way:

  1. A statement which accesses all data items that are part of the initial evaluation of the statement, performs all arithmetic necessary to arrive at the result to be stored in the receiving items, and stores that result in a temporary storage location.
  2. A sequence of statements transferring or combining the value of this temporary location with each single resultant data item. These statements are considered to be written in the same left-to-right sequence in which the multiple results are listed.

    The result of the statement:

    ADD a, b, c TO c, d (c), e

    is equivalent to:

    ADD a, b,
c GIVING temp ADD temp TO c ADD temp TO d (c) ADD temp TO e

    and the result of the statement:

    MULTIPLY a(i) BY i, a(i)

    is equivalent to:

    MOVE a(i) to temp MULTIPLY temp by i MULTIPLY temp BY
a(i)

    where temp is an intermediate result item provided by your COBOL system.

Parent topic: Common Phrases


Incompatible Data

Except for the class condition (see the topic Class Condition), when the contents of a data item are referenced in the Procedure Division and the contents of that data item are not compatible with the class specified for that data item by its PICTURE clause

ANS85 or function definition

then the result of such a reference is undefined.

MF The results of referencing a numeric field that contains nonnumeric, or otherwise invalid data, are undefined. Such conditions may be detected, and give an error at run-time. This behavior is affected by the F RTS switch.

MF When an alphabetic field which contains non-alphabetic data is referenced, execution continues, but results may be undefined.

Parent topic: Common Phrases
Related information
Class Condition


Signed Receiving Items

When the receiving item in an arithmetic statement or a MOVE statement is a signed numeric or a signed numeric-edited item, the sign is moved into the receiving item independently of any truncation of the absolute numeric data. It is possible, therefore, for the numeric value to be zero but for the sign to be negative.

Parent topic: Common Phrases


The ROUNDED Phrase

If, after decimal point alignment, the number of places in the fraction of the result of an arithmetic operation is greater than the number of places provided for the fraction of the resultant-identifier, truncation is relative to the size provided for the resultant-identifier. When rounding is requested, the absolute value of the resultant-identifier is increased by one whenever the most significant digit of the excess is greater than or equal to five.

When the low-order integer positions in a resultant-identifier are represented by the character "P" in the PICTURE for the resultant-identifier, rounding or truncation occurs relative to the rightmost integer position for which storage is allocated.

OSVS VSC2 MF In a floating-point arithmetic operation, the ROUNDED phrase is treated as documentary; the result of a floating-point operation is always rounded.

Parent topic: Common Phrases


The ON SIZE ERROR Phrase and NOT ON SIZE ERROR Phrase

If, after decimal point alignment, the absolute value of a result of an arithmetic operation exceeds the largest value that can be contained in the associated resultant-identifier, a size error condition exists. Division by zero always causes a size error condition. Note that the results of division by zero when no ON SIZE ERROR phrase is specified are unpredictable. The size error condition applies only to the final results, except in MULTIPLY and DIVIDE statements, in which case the size error condition applies to the intermediate results as well.

ANS85 Violation of the rules for the evaluation of exponentiation always terminates the arithmetic operation and always causes a size error condition.

If the ROUNDED phrase is specified, rounding takes place before checking for size error. When such a size error condition occurs, the subsequent action depends on whether or not the SIZE ERROR phrase is specified, as follows:

  • ON SIZE ERROR Phrase Not Specified
  • ON SIZE ERROR Phrase Specified
  • The NOT ON SIZE ERROR Phrase
Parent topic: Common Phrases
Related reference
ON SIZE ERROR Phrase


ON SIZE ERROR Phrase Not Specified

When a size error condition occurs, the value of those resultant- identifier(s) affected is undefined. Any subsequent use of the resultant-identifier(s) affected is also unpredictable in effect. Values of resultant-identifier(s) for which no size error condition occurs are unaffected by size errors that occur for other resultant-identifier(s) during execution of this operation.

ANS85 After completion of the arithmetic operation, control is transferred to the end of the arithmetic statement and the NOT ON SIZE phrase, if specified, is ignored.

Results of division by zero, when no ON SIZE ERROR is specified, are unpredictable. You can avoid this by using the CHECKDIV Compiler directive and O RTS switch.

Parent topic: The ON SIZE ERROR Phrase and NOT ON SIZE ERROR Phrase


ON SIZE ERROR Phrase Specified

When a size error condition occurs, then the values of resultant- identifier(s) affected by the size errors are not altered. Values of resultant-identifier(s) for which no size error condition occurs are unaffected by size errors that occur for other resultant-identifier(s) during execution of this operation. After completion of the execution of this operation, the imperative statement in the SIZE ERROR phrase is executed.

For the ADD statement with the CORRESPONDING phrase and the SUBTRACT statement with the CORRESPONDING phrase, if any of the individual operations produces a size error condition, the imperative statement in the ON SIZE ERROR phrase is not executed until all of the individual additions or subtractions are completed.

ANS85 If a size error condition occurs, any NOT ON SIZE ERROR phrase is ignored whether or not an ON SIZE ERROR phrase is specified.

ANS85 When both ON SIZE ERROR and NOT ON SIZE ERROR phrases are specified, and the statement in the phrase that is executed does not contain any explicit transfer of control, then, if necessary, an implicit transfer of control is made after execution of the phrase to the end of the arithmetic statement.

Parent topic: The ON SIZE ERROR Phrase and NOT ON SIZE ERROR Phrase


The NOT ON SIZE ERROR Phrase

If the NOT ON SIZE ERROR phrase is specified for an arithmetic operation statement, and after execution of that statement a size error condition (as defined above) does not exist, then the NOT ON SIZE ERROR phrase is executed. The ON SIZE ERROR phrase, if specified, is ignored, and the imperative statement associated with it is not executed.

Parent topic: The ON SIZE ERROR Phrase and NOT ON SIZE ERROR Phrase


The CORRESPONDING Phrase

In the text that follows, d1 and d2 must each be identifiers that refer to group items. A pair of data items, one from d1 and one from d2 correspond if the following conditions exist:

  1. A data item in d1 and a data item in d2 are not designated by the key word FILLER and have the same data-name and the same qualifiers up to, but not including, d1 and d2.
  2. At least one of the data items is an elementary data item and the resulting move is legal according to the move rules in the case of a MOVE statement with the CORRESPONDING phrase, and both of the data items are elementary numeric data items in the case of the ADD statement with the CORRESPONDING phrase or the SUBTRACT statement with the CORRESPONDING phrase.
  3. The description of d1 and d2 must not contain level-number 66, 77,

    MF 78

    or 88, the USAGE IS INDEX clause

    MF or the USAGE IS OBJECT clause

  4. A data item that is subordinate to d1 or d2 and contains a REDEFINES, RENAMES, OCCURS, USAGE IS INDEX

    MF , USAGE IS PROCEDURE-POINTER

    VSC2 MF , USAGE IS POINTER

    MF , or USAGE IS OBJECT

    clause is ignored, as well as those data items subordinate to the data item that contains the REDEFINES, RENAMES, OCCURS, USAGE IS INDEX

    MF , USAGE IS PROCEDURE-POINTER

    VSC2 MF , USAGE IS POINTER

    MF , or USAGE IS OBJECT

    clause. However, d1 and d2 can have REDEFINES or OCCURS clauses or be subordinate to data items with REDEFINES or OCCURS clauses.

    ANS85 Neither d1 or d2 can be reference modified.

  5. The name of each data item which satisfies the above conditions must be unique after application of the implied qualifiers.
Parent topic: Common Phrases


File I/O Concepts

  • File Position Indicator
  • I-O Status
  • The AT END Condition
  • The INVALID KEY Condition
  • Sharing Files on Multi-user Systems
Parent topic: Procedure Division


File Position Indicator

The file position indicator identifies the next record to be accessed within a given file during certain input-output sequences. The setting of the file position indicator is affected only by CLOSE, OPEN, START and READ statements. The file position indicator has no effect on files opened in the output or extend mode.

Parent topic: File I/O Concepts


I-O Status

If the FILE STATUS clause is specified in a file control entry, a value is placed into the specified two-character data item during the execution of an OPEN, CLOSE, READ, WRITE, REWRITE, DELETE, UNLOCK or START statement before any applicable USE procedure is executed, to indicate the status of that input-output operation.

The file status keys described in the following pages are for those files which conform fully to the ANSI standard and which use none of the extensions available with this COBOL system.

MF Use of extensions, for example, specifying a file as LINE SEQUENTIAL, affects the status keys returned. Additional information is provided under the relevant verbs.

  • Status Key 1
  • Successful Completion
  • Valid Combinations of Status Keys 1 And 2
Parent topic: File I/O Concepts


Status Key 1

The leftmost character position of the FILE STATUS data item is known as status key 1 and is set to indicate one of the following conditions upon completion of the input-output operation on a file of any organization.

"0" | - Successful completion
"1" | - At end
"2" | - Invalid key
"3" | - Permanent error
"4" | - Logic error
"9" | - Run-time system error message

The meaning of the above conditions is as follows:

"0" | Successful completion. The input-output statement was successfully executed.
"1" | At end. The sequential READ statement was unsuccessfully executed either because of an attempt to read a record when no next logical record exists in the file or because the first READ statement was executed for a file described with the OPTIONAL clause when that file was not available at the time its associated OPEN statement was executed.
"2" | Invalid key. The input-output statement on a non-sequential file was unsuccessfully executed because of one of the following: Sequence error Duplicate key No record found Boundary violation
"3" | Permanent error. The input-output statement was unsuccessfully executed because of a boundary violation for a sequential file or because of an input-output error, such as a data check parity error or transmission error.
"4" | Logic error. The input-output statement was unsuccessfully executed, either because an improper sequence of input-output operations was performed on the file, or because a limit you defined was violated.
"9" | Run-time system error message. The input-output statement was unsuccessfully executed because of a condition that is specified by the run-time system error message number. This value is used only to indicate a condition not indicated by other defined values of status key 1, or by specified combinations of the values of status key 1 and status key 2.
Parent topic: I-O Status


Successful Completion

If status key 1 contains "0" to indicate the successful completion of the input-output operation, status key 2 can contain one of the following values:

"0" | (all files) No further information is available
"2" (indexed files only) Indicates one of two possibilities:
  • For a READ statement, the key value for the current key of reference is equal to the value of the same key in the next record within the current key of reference.
  • For a WRITE or REWRITE statement, the record just written created a duplicate key value for at least one alternate record key for which duplicates are allowed.
"4" | (all files) Indicates that the length of the record being processed does not conform to the fixed file attributes for that file.
"5" | (all files) Indicates that the referenced optional file was not present at the time the OPEN statement was executed.
"7" | (record sequential files only) Indicates that for a CLOSE statement with the NO REWIND, REEL/UNIT or FOR REWIND phrase, or an OPEN statement with the NO REWIND phrase, the referenced file is a non-reel/unit medium.
  • Successful Completion
  • AT END Condition with Unsuccessful Completion
  • INVALID KEY Condition with Unsuccessful Completion
  • Permanent Error Condition with Unsuccessful Completion
  • Logic Error Condition with Unsuccessful Completion
  • Run-Time System Error Message
Parent topic: I-O Status


Successful Completion

If status key 1 contains "0" to indicate the successful completion of the input-output operation, status key 2 can contain one of the following values:

"0" | (all files) No further information is available
"2" (indexed files only) Indicates one of two possibilities:
  • For a READ statement, the key value for the current key of reference is equal to the value of the same key in the next record within the current key of reference.
  • For a WRITE or REWRITE statement, the record just written created a duplicate key value for at least one alternate record key for which duplicates are allowed.
"4" | (all files) Indicates that the length of the record being processed does not conform to the fixed file attributes for that file.
"5" | (all files) Indicates that the referenced optional file was not present at the time the OPEN statement was executed.
"7" | (record sequential files only) Indicates that for a CLOSE statement with the NO REWIND, REEL/UNIT or FOR REWIND phrase, or an OPEN statement with the NO REWIND phrase, the referenced file is a non-reel/unit medium.
Parent topic: Successful Completion


AT END Condition with Unsuccessful Completion

If status key 1 contains "1" to indicate the AT END condition, status key 2 can contain one of the following values:

"0" (all files) Indicates that there is no next logical record. This can be caused by two conditions:
  • The end of the file has been reached.
  • A sequential READ statement has been attempted for the first time on an optional input file that is not present.
"4" (relative files only) Indicates that the number of significant digits in the relative record number is larger than the size of the relative key data item described for that file.
Parent topic: Successful Completion


INVALID KEY Condition with Unsuccessful Completion

If status key 1 contains "2" to indicate INVALID KEY condition, status key 2 indicates the cause of the condition by one of the values:

"1" | (sequentially accessed indexed files) Indicates a sequence error. The ascending sequence requirements of successive record key values have been violated (see the topic The WRITE Statement), or the prime record key value has been changed by the COBOL runtime element between the successful execution of a READ statement and the execution of the next REWRITE statement for that file.
"2" | (relative and indexed files only) Indicates a duplicate key value. An attempt has been made either to write a record that would create a duplicate prime record key or to write or rewrite a record that would create a duplicate alternate record key when the DUPLICATES phrase is not specified for that alternate record key.
"3" | (relative and indexed files only) Indicates no record found. An attempt has been made to access a record, identified by a key, and that record does not exist in the file, or a START or READ statement has been attempted on an optional input file that is not present.
"4" (relative and indexed files only) Indicates a boundary violation arising from one of the following conditions:
  • An attempt has been made to write beyond the externally defined boundaries of a file.
  • A sequential WRITE statement has been attempted for a relative file, but the number of significant digits in the relative record number is larger than the size of the relative key data item described for the file.
Parent topic: Successful Completion
Related information
The WRITE Statement


Permanent Error Condition with Unsuccessful Completion

If status key 1 contains "3" to indicate a permanent error condition, status key 2 can contain one of the following values to indicate the cause of that error:

"0" | (all files) Indicates that no further information is available concerning the cause of the error.
"4" | (sequential files only) Indicates a boundary violation. An attempt has been made to write beyond the externally defined boundaries of a file.
"5" | (all files) Indicates that an OPEN statement with the INPUT, I-O, or EXTEND phrase has been attempted on a non-optional file that is not present.
"7" (all files) Indicates that an OPEN statement has been attempted on a file which does not support the open mode specified in the OPEN statement. The possible violations are:
  • The EXTEND or OUTPUT phrase has been specified but the file does not support write operations.
  • The I-O phrase has been specified but the file doesl not support the input and output operations that are permitted for a relative file when opened in the I-O mode.
  • The INPUT phrase has been specified but the file does not support read operations.
"8" | (all files) Indicates that an OPEN statement has been attempted on a file previously closed with lock.
"9" | (record sequential, relative and indexed files) Indicates that a conflict has been detected between the fixed file attributes and the attributes specified for that file in the source element.
Parent topic: Successful Completion


Logic Error Condition with Unsuccessful Completion

If status key 1 contains "4" to indicate a logic error condition, status key 2 can contain one of the following values to indicate the cause of that error:

"1" | (all files) Indicates that an OPEN statement has been attempted for a file already in open mode.
"2" | (all files) Indicates that a CLOSE statement has been attempted for a file not in open mode.
"3" | (all files, sequential access mode only) Indicates that the last input-output statement executed for the associated file, prior to the execution of a DELETE or REWRITE statement, was not a successfully executed READ statement.
"4" | (record sequential files only) Indicates that a boundary violation exists. A possible violation is that an attempt has been made to WRITE or REWRITE a record that is larger than the largest, or smaller than the smallest, record allowed by the RECORD IS VARYING clause of the associated file.
"5" (all files ) An attempt has been made to REWRITE a record to a file, and the record is not the same size as the record being replaced.

MF For line sequential files this refers to the physical size of the record, that is after space removal, tab compression and null insertion. In this case, the physical size of the new record is allowed to be smaller than that of the record being replaced.
"6" (all files) Indicates that a sequential READ statement has been attempted on a file open in input or I-O mode, but no valid next record has been established. This can be caused by the following conditions:
  • The preceding START statement was unsuccessful.
  • The preceding READ statement was unsuccessful but did not cause an at end condition.
  • The preceding READ statement caused an at end condition.
"7" | (all files) Indicates that the execution of a READ or START statement has been attempted on a file not open in input or I-O mode.
"8" | (all files) Indicates that the execution of a WRITE statement has been attempted on a file not open in I-O, output or extend mode, or on a file open I-O in sequential access mode.
"9" | (all files) Indicates that the execution of a DELETE or REWRITE statement has been attempted on a file not open in I-O mode.
Parent topic: Successful Completion


Run-Time System Error Message

If status key 1 contains " 9" to indicate a run-time system error message, status key 2 contains the run-time system error message number in binary. These are described in full in your COBOL system documentation.

Parent topic: Successful Completion


Valid Combinations of Status Keys 1 And 2

In the following table: "S" indicates a Record Sequential file,

MF "L " indicates a Line Sequential file,

"R" indicates a Relative file and "I" indicates an Indexed file.

A particular combination of status key 1 and status key 2 is valid for a given file organization if the letter for that organization is found at the corresponding intersection in the table below.

Table 1. Valid Combinations of Status Keys 1 and 2
Status Key 1 |  | Status Key 2
 |  | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
Successful Completion | 0 | SRIL |  | I |  | SRIL | SRIL |  | S |  |
At End | 1 | SRIL |  |  |  | R |  |  |  |  |
Invalid Key | 2 |  | I | RI | RI | RI |  |  |  |  |
Permanent Error | 3 | SRIL |  |  |  | SL | SRIL |  | SRIL | SRIL | SRIL
Logic Error | 4 |  | SRIL | SRIL | SRIL | SRIL |  | SRIL | SRIL | SRIL | SRIL
Implementor Defined | 9 | Run-Time System Error Message (SRIL)
Parent topic: I-O Status


The AT END Condition

The AT END condition can occur as a result of the execution of a READ statement. For details of the causes of the condition, see the topic The READ Statement.

Parent topic: File I/O Concepts
Related information
The READ Statement


The INVALID KEY Condition

The INVALID KEY condition can occur as a result of the execution of a START, READ, WRITE, REWRITE or DELETE statement. For details of the causes of the condition, see the topics The READ Statement and The REWRITE Statement and the sections The START Statement and The WRITE Statement.

If the INVALID KEY condition exists after the execution of the input-output operation specified in an input-output statement, the following actions occur in the order shown:

  1. A value is placed in the FILE STATUS data item, if specified for this file, to indicate an INVALID KEY condition. (See the section earlier in this chapter.)
  2. If the INVALID KEY phrase is specified in the statement causing the condition, control is passed to the INVALID KEY imperative statement. Any USE procedure specified for this file is not executed.
  3. If the INVALID KEY phrase is not specified, but a USE procedure is specified, either explicitly or implicitly, for this file, that procedure is executed.

When the INVALID KEY condition occurs, execution of the input-output statement which recognized the condition is unsuccessful, and the file is not affected.

Note that INVALID KEY does not trap errors when status key 1 is set to "9". Such errors must be trapped either by explicitly testing the status key or by using declaratives instead of the INVALID KEY clause.

Parent topic: File I/O Concepts
Related information
The READ Statement
The REWRITE Statement
The START Statement
The WRITE Statement


Sharing Files on Multi-user Systems

The run-time system supports this COBOL system's multi-user facilities which allow files to be shared between users in a multi-user environment, and allow runtime elements accessing those files to lock records or entire files in order to prevent access to them while data is being updated.

In single-user environments the multi-user syntax has no effect at run time, but runtime elements can be developed for use in both single- and multi-user environments.

Files are either active or inactive. An active file is open to one or more run units. An inactive file is one that is not open to any run unit.

Active files can be open in one of two modes: exclusive or shareable:

  • MF XOPEN Exclusive

    A file which is in exclusive mode is open to one run unit only; any other run unit which attempts to access it receives a "File locked" error and is denied access. Exclusive mode implies that a file lock is held by the one run unit which is able to access the file; the file lock is released by that run unit closing the file.

  • Shareable

    A file which is in shareable mode is available to any number of run units, each of which can protect data while using the file by locking one or more records at a time in the file. This prevents other run units from acquiring a lock on the individual records that are locked, but does not prevent access to the file otherwise. The organization of the file affects the way the file can be shared.

The organization of the file affects the way the file can be shared:

  • Record sequential

    Record sequential files opened for INPUT can be shared between run units but records cannot be locked in the file. Files opened for I-O or EXTEND can also be made shareable and each run unit can maintain a record lock for the file. Files opened for OUTPUT always have an exclusive file lock.

  • MF Line sequential

    Line sequential files that are opened INPUT or EXTEND can be made shareable but records cannot be locked in the file. Files that are opened OUTPUT always have an exclusive file lock.

  • Relative and indexed

    Files that are opened in INPUT mode are shareable, but records cannot be locked in the file. Files that are opened I-O can be shareable but files that are opened OUTPUT or EXTEND are exclusive.

Each run unit that is sharing access to a file can be locking either a single record or multiple records in that file. A run unit cannot select single record locking and multiple record locking for the same file.

  • Single Record Locking
  • Multiple Record Locking
  • Default Record Locking
Parent topic: File I/O Concepts


Single Record Locking

A run unit that has specified single record locking for a file (either explicitly or implicitly) can hold only one record lock in that file at any one time. A run unit can acquire a record lock in two ways: manually or automatically:

  • Manual record lock

    The run unit acquires a lock only if it accesses a record with a READ WITH LOCK statement.

  • Automatic record lock

    The run unit acquires a lock whenever it reads a record in the file, unless you specify the READ WITH NO LOCK statement.

The lock is released by the same run unit doing any of the following:

  • Accessing any record in the file with any file operation (except START for relative and indexed files)
  • Executing an UNLOCK statement on that file
  • Executing a COMMIT statement
  • Executing a ROLLBACK statement
  • Closing the file.
Parent topic: Sharing Files on Multi-user Systems


Multiple Record Locking

Locking of multiple records in a file is available only when the organization of that file is relative, indexed or record sequential.

A run unit that has specified multiple record locking for a file can hold a number of record locks in one file simultaneously. This prevents other run units from updating or acquiring a lock on those locked records, but does not deny them access to any records that are not locked. Record locks can be acquired in two ways: manually or automatically:

  • Manual record lock

    The run unit acquires a lock only if it accesses a record with a READ WITH LOCK or READ WITH KEPT LOCK statement.

  • Automatic record lock

    The run unit acquires a lock whenever it reads a record in the file unless you explicitly specify that it should not. If the WRITELOCK Compiler directive has been specified at the time the compilation group was submitted to your COBOL system, then a lock is acquired if the run unit accesses the file with a WRITE or REWRITE statement.

The locks are released by the same run unit doing any of the following:

  • Executing a DELETE statement referencing a record for which a lock is held. In this case, only the lock on that record is released
  • Executing an UNLOCK statement for that file
  • Executing a COMMIT statement
  • Executing a ROLLBACK statement
  • Closing the file.
Parent topic: Sharing Files on Multi-user Systems


Default Record Locking

Tables 2, 3 and 4 show the default type of locking which is used when files are opened in a particular open mode. The default locking can be modified if the AUTOLOCK Compiler directive was specified at the time the compilation group was submitted to your COBOL system. The tables also indicate whether the default type of locking can be overridden for individual files. This is done by inserting a suitable clause in the SELECT clause for the file. (See the topic The File Control Entry.)

XOPEN X/Open restricts those X/Open conforming source programs that use locking to either single record locks with automatic locking, or multiple record locks with manual locking.

Table 1. Default Locking For Record Sequential Files
OPEN Mode | No Directive | AUTOLOCK Compiler Directive | Override in SELECT Statement
INPUT | No lock | No lock | Yes, but only to Exclusive
I-O | Exclusive | Lock on single record | Yes
OUTPUT | Exclusive | Exclusive | No
EXTEND | Exclusive | No lock | Yes, the file can be made shareable but no records are locked
Table 2. Default Locking For Line Sequential Files
OPEN Mode | No Directive | AUTOLOCK Compiler Directive | Override in SELECT Statement
INPUT | No lock | No lock | No
I-O | Exclusive | No lock | No
OUTPUT | Exclusive | Exclusive | No
EXTEND | Exclusive | No lock | No
Table 3. Default Locking For Relative And Indexed Files
OPEN Mode | No Directive | AUTOLOCK Compiler Directive | Override in SELECT Statement
INPUT | No lock | No lock | Yes, but only to Exclusive
I-O | Exclusive | Automatic lock on single record | Yes
OUTPUT | Exclusive | Exclusive | No
EXTEND | Exclusive | Exclusive | No
Note:
  1. A file opened for OUTPUT causes the file to become exclusive, regardless of the specified lock mode.
  2. You can select the type of locking for individual files by accepting the default locking (see Tables 1, 2 and 3) or by including a LOCK MODE clause in the file control entry (see the section The File Control Entry).
Parent topic: Sharing Files on Multi-user Systems
Related information
The File Control Entry


Conformance for Parameters and Returning Items

The conformance rules for parameters and returning items apply at compile time when an explicit reference is made to them from a syntax rule.

Note: Conformance rules for parameters and returning items are checked at compile time for:
  • An INVOKE statement on an object reference that is not a universal object reference,
  • A reference to a user-defined function,
  • A program-prototype format of the CALL statement.
  • Parameters
  • Returning Items
Parent topic: Procedure Division


Parameters

The number of arguments in the activating element must be equal to the number of formal parameters in the activated element,

ISO2002 MF with the exception of trailing formal parameters that are specified with an OPTIONAL phrase in the PROCEDURE DIVISION header of the activated element and are omitted from the list of arguments of the activating element.

MF If the numbers of operands are different, then if there are more operands in the activating statement, they are ignored and if there are more operands in the PROCEDURE DIVISION header, they must not be referenced within the activated runtime element. The positional correspondence may vary depending on the non-COBOL calling conventions implied by mnemonic-name. Any mismatch in the number of the operands will only be apparent at run time and so the directive FLAG does not cause this extension to be flagged.

The rules for conformance between arguments and formal parameters depend on whether either the formal parameter or its corresponding argument is a group item or both are elementary items.

  • Group Items
  • Elementary Items
Parent topic: Conformance for Parameters and Returning Items


Group Items

If either the formal parameter or the argument is a group item, the corresponding argument or formal parameter must be a group item or an elementary item of category alphanumeric, and the formal parameter must be described with the same number or a smaller number of character positions as the corresponding argument.

Parent topic: Parameters


Elementary Items

The conformance rules for elementary items depend on whether the argument is passed by reference, by content, or by value.

  • Elementary Items Passed by Reference
  • Elementary Items Passed by Content or by Value
Parent topic: Parameters


Elementary Items Passed by Reference

If either the formal parameter or the corresponding argument is an object reference, the corresponding argument or formal parameter must be an object reference following these rules:

  1. If either the argument or the formal parameter is a universal object reference, the corresponding formal parameter or argument must be a universal object reference.
  2. If either the argument or the formal parameter is described with an interface-name, the corresponding formal parameter or argument must be described with the same interface-name.
  3. If either the argument or the formal parameter is described with a class-name, the corresponding formal parameter or argument must be described with the same class-name, and the FACTORY and ONLY phrases must be the same.
  4. If the formal parameter is described with the ACTIVE-CLASS phrase, one of the following conditions must be true:
    1. The argument must be an object reference described with the ACTIVE-CLASS phrase, where the presence or absence of the FACTORY phrase is the same as in the formal parameter, and the method to be activated must be invoked with the predefined object references SELF or SUPER, or with an object reference described with the ACTIVE-CLASS phrase.
    2. The argument must be an object reference described with a class-name and the ONLY phrase, where the presence or absence of the FACTORY phrase is the same as in the formal parameter, and the method to be activated must be invoked with that class-name or with an object reference described with that classname and the ONLY phrase.

If either the argument or the formal parameter is of class pointer, the corresponding formal parameter or argument must be of class pointer and the corresponding items must be of the same category. If either is a restricted pointer, both must be restricted and of the same type. The ADDRESS special register is considered to be of class pointer and category data-pointer.

If neither the formal parameter nor the argument is of class object or pointer, the conformance rules are the following:

  1. If the activated element is a program for which there is no program-specifier in the Repository paragraph of the activating element and there is no NESTED phrase specified on the CALL statement, the formal parameter must be of the same length as the corresponding argument.
  2. If the activated element is one of the following:
    • A program for which there is a program-specifier in the Repository paragraph of the activating element
    • A program that was called with a CALL statement in which the NESTED phrase is specified
    • A method
    • A function

    then the definition of the formal parameter and the definition of the argument must have the same PICTURE, USAGE, SIGN, JUSTIFIED, and BLANK clauses, with the following exceptions:

    1. Currency symbols match if and only if the corresponding currency strings are the same.
    2. Period picture symbols match if and only if the DECIMAL-POINT IS COMMA clause is in effect for both the activating and the activated runtime elements or for neither of them. Comma picture symbols match if and only if the DECIMAL-POINT IS COMMA clause is in effect for both the activating and the activated runtime elements or for neither of them.

    Additionally:

    1. If the formal parameter is described with the ANY LENGTH clause, its length is considered to match the length of the corresponding argument.
    2. If the argument is described with the ANY LENGTH clause, the corresponding formal parameter shall be described with the ANY LENGTH clause.
Parent topic: Elementary Items


Elementary Items Passed by Content or by Value

If the formal parameter is an object reference described with the ACTIVE-CLASS phrase, one of the following conditions must be true:

  1. The method to be activated must be invoked with the predefined object references SELF or SUPER, or with an object reference described with the ACTIVE-CLASS phrase, and a SET statement must be valid in the activating unit with the argument as the sending operand and an object reference described with the ACTIVE-CLASS phrase as the receiving operand, where the presence or absence of the FACTORY phrase is the same as in the formal parameter.
  2. The method to be activated must be invoked with a class-name or with an object reference described with a class-name and the ONLY phrase, and a SET statement must be valid in the activating unit with the argument as the sending operand and an object reference described with that class-name and the ONLY phrase as the receiving operand, where the presence or absence of the FACTORY phrase is the same as in the formal parameter.

If the formal parameter is of class pointer or an object reference descrited without the ACTIVE-CLASS phrase, the conformance rules are the same as if a SET statement were performed in the activating runtime element with the argument as the sending operand and the corresponding formal parameter as the receiving operand.

If the formal parameter is not of class object or pointer, the conformance rules are the following:

  1. If the activated element is a program for which there is no program-specifier in the Repository paragraph of the activating element and there is no NESTED phrase specified on the CALL statement, the formal parameter must be described with the same number of character positions as the corresponding argument.
  2. If the activated unit is one of the following:
    • A program for which there is a program-specifier in the Repository paragraph of the activating element
    • A program that was called with a CALL statement in which the NESTED phrase is specified
    • A method
    • A function

    then the conformance rules depend on the type of the formal parameter as specified in the following rules:

    1. If the formal parameter is numeric, the conformance rules are the same as for a COMPUTE statement with the argument as the sending operand and the corresponding formal parameter as the receiving operand.
    2. If the formal parameter is an index or pointer data item, the conformance rules are the same as for a SET statement with the argument as the sending operand and the corresponding formal parameter as the receiving operand.
    3. If the formal parameter is described with the ANY LENGTH clause, its length is considered to match the length of the corresponding argument.
    4. Otherwise, the conformance rules are the same as for a MOVE statement with the argument as the sending operand and the corresponding formal parameter as the receiving operand.
Parent topic: Elementary Items


Returning Items

A returning item must be specified in the activating statement, if and only if a returning item is specified in the PROCEDURE DIVISION header

MF or ENTRY statement

of the activated source element. A returning item is implicitly specified in the activating element when a function or inline method invocation is referenced.

The returning item in the activated source element is the sending operand, the corresponding returning item in the activating source element is the receiving operand.

The rules for conformance between the sending operand and the receiving operand depend on whether at least one of the operands is an alphanumeric group item or both operands are elementary items.

  • Group Items
  • Elementary Items
Parent topic: Conformance for Parameters and Returning Items


Group Items

If either the sending or the receiving operand is a group item, the corresponding returning item must be a group item or an elementary item of category alphanumeric, and the receiving operand must be described with the same number of character positions as the sending operand.

Note: If a returning item in an activating element is a group with a level number other than 1 and its subordinate items are described such that the implementation inserts slack bits or bytes, the alignment of the subordinate elementary items might not correspond between the returning item in the activating runtime element and the returning item in the activated runtime element.

For an operand that is described as a variable-occurrence data item, the maximum length is used.

Parent topic: Returning Items


Elementary Items

If either of the operands is an object reference, the corresponding item must be an object reference, and the following rules apply:

  1. If the returning item in the activated source element is not described with an ACTIVE-CLASS phrase, the conformance rules are be the same as if a SET statement were performed in the activated runtime element with the returning item in the activated source element as the sending operand and the corresponding returning item in the activating source element as the receiving operand.
  2. If the returning item in the activated source element is described with an ACTIVE-CLASS phrase, the conformance rules are the same as if a SET statement were performed in the activating runtime element with the returning item in the activating source element as the receiving operand, and a sending operand described with USAGE OBJECT REFERENCE as determined by the following rules:
    1. If the activated method is invoked with a class-name, the sending operand is described with the same class-name and an ONLY phrase.
    2. If the activated method is invoked with the predefined object references SELF or SUPER

      MF or SELFCLASS

      , the sending operand is described with an ACTIVE-CLASS phrase.

    3. If the activated method is invoked with an object reference described with an interface-name, the sending operand is a universal object reference.
    4. If the activated method is invoked with any other object reference, this identifier is used as the sending operand, including the ONLY phrase if specified.
    5. If the sending operand selected by applying the above rules is described with a class-name or an ACTIVE-CLASS phrase, the presence or absence of the FACTORY phrase is the same as in the returning item of the activated source element.

If the sending operand is not an object reference, the receiving operand must have the same PICTURE, USAGE, SIGN, SYNCHRONIZED, JUSTIFIED, and BLANK clauses, with the following exceptions:

  1. Currency symbols match if and only if the corresponding currency strings are the same.
  2. Period picture symbols match if and only if the DECIMAL-POINT IS COMMA clause is in effect for both the activating and the activated runtime elements or for neither of them.
  3. Comma picture symbols match if and only if the DECIMAL-POINT IS COMMA clause is in effect for both the activating and the activated runtime elements or for neither of them.

Additionally:

  1. If the receiving operand is described with the ANY LENGTH clause, the sending operand must also be described with the ANY LENGTH clause.
  2. If the sending operand is described with the ANY LENGTH clause, the length of the sending operand is considered to match the length of the receiving operand.
Parent topic: Returning Items


Intrinsic Functions

General Description

An intrinsic function is a temporary data item whose value is determined at the time the function is referenced during the execution of a statement. An intrinsic-function-name is a COBOL word that is one of a specified list of COBOL words which can be used in COBOL source programs. (For a list of all the available functions, see the topic Definitions of Functions .)

Function Definition and Returned Value

The definition of each function specifies:

  • For alphanumeric

    MF and national

    functions, the size of the returned value

  • For numeric and integer functions, the sign of the returned value and whether the function is integer
  • For some other cases, the value returned.

Function Identifier

A function identifier is used to reference a function in the Procedure Division of a COBOL source program.

The value returned by a function is considered to be a data value. A mechanism is provided at run time to assign a data value to a function when it is referenced. In order to determine the function's value, the evaluation mechanism requires access to data values provided by the referencing program. These data values are provided by specifying parameters, known as arguments, when referencing the function. Specific functions can place constraints on these arguments, such as range, and so on. If, at the time a function is referenced, the arguments specified for that reference do not have values that comply with the specified constraints, then the returned value for the function is undefined.

  • Arguments
  • Function Types
  • Definitions of Functions
Parent topic: Procedure Division


Arguments

Arguments specify values used in the evaluation of a function. Arguments are specified in the function-identifier. These arguments can be specified as identifiers, as arithmetic expressions, or as literals. The definition of a function specifies the number of arguments required, which can be zero, one, or more. For some functions, the number of arguments which can be specified is variable. The order in which arguments are specified in a function-identifier determines the interpretation given to each value in arriving at the function value. Arguments may be required to have a certain class or a subset of a certain class. The types of argument are:

  1. Numeric. An arithmetic expression must be specified. The value of the arithmetic expression, including operational sign, is used in determining the value of the function.
  2. Alphabetic. An elementary data item of the class alphabetic or a nonnumeric literal containing only alphabetic characters must be specified. The size associated with the argument can be used in determining the value of the function.
  3. Alphanumeric. A data item of the class alphabetic or alphanumeric or a nonnumeric literal must be specified. The size associated with the argument can be used in determining the value of the function.
  4. MF National. An elementary data item of class national or a national literal must be specified. The size associated with the argument can be used in determining the value of the function.
  5. Integer. An arithmetic expression which will always result in an integer value must be specified. The value of the arithmetic expression, including operational sign, is used in determining the value of the function.

The rules for a function can place constraints on the permissible values for arguments, in order to accurately determine the function's value. If, at the time a function is referenced, the arguments specified for that reference do not have values within the permissible range, the returned value for the function is undefined.

When the definition of a function permits an argument to be repeated a variable number of times, a table can be referenced by specifying the data-name and any qualifiers that identify the table, followed immediately by subscripting where one or more of the subscripts is the word ALL.

When ALL is specified as a subscript, the effect is as if each table element associated with that subscript position were specified. The order of the implicit specification of each occurrence is from left to right, with the first (or leftmost) specification being the identifier with each subscript specified by the word ALL replaced by one, the next specification being the same identifier with the rightmost subscript specified by the word ALL incremented by one.

This process continues with the rightmost ALL subscript being incremented by one for each implicit specification until the rightmost ALL subscript has been incremented through its range of values. If any additional ALL subscripts exist, the subscript immediately to the left of the rightmost ALL subscript is incremented by one, the rightmost ALL subscript is reset to one and the process of varying the rightmost ALL subscript is repeated. The ALL subscript to the left of the rightmost ALL subscript is incremented through its range of values. For each additional ALL subscript this process is repeated in turn until the leftmost ALL subscript has been incremented by one through its range of values.

If the ALL subscript is associated with an OCCURS DEPENDING ON clause, the range of values is determined by the object of the OCCURS DEPENDING ON clause. The evaluation of an ALL subscript must result in at least one argument, otherwise the result of the reference to the function-identifier is undefined.

Example

 01 Test-Fields.
     10 OT-Elem                  PIC 9(02).
     10 Arr.
         15 Ind occurs 5 times        PIC 9(02).
     compute OT-Elem = function sum (IND(ALL)).

is equivalent to specifying

     compute OT-Elem = function sum (IND(1), IND(2), IND(3),
                                            IND(4), IND(5)).

The ALL subscript can also be used with a table that has a variable number of elements as in the following example:

 01 Test-Group.
     03 OT-Elem               pic 9(15) binary.
     03 table-length          pic s9(9) binary.
     03 array.
         05 Ind pic 9(2) occurs 1 to 200 times depending on
                              table length
      ...
     move 100 to table-length.
     compute OT-Elem = function sum (Ind(ALL))

These statements will sum the first 100 elements of the table. At the time the function is referenced, the number of elements specified by table-length determines that number of elements that are added.

Parent topic: Intrinsic Functions
Related information
Intrinsic Functions
Data Item Functions
Date Conversion Functions
Trigonometric Functions
Definitions of Functions


Function Types

  • Data Item Functions
  • Date Conversion Functions
  • Trigonometric Functions
Parent topic: Intrinsic Functions


Data Item Functions

Data item functions are elementary data items and return alphanumeric,

MF national,

numeric or integer values. Data item functions are treated as elementary data items and cannot be receiving operands. The types of data item functions are:

  1. Alphanumeric functions. These are of the class and category alphanumeric. The number of character positions in this data item is specified in the function definition. Alphanumeric functions have an implicit usage of DISPLAY.
  2. Numeric functions. These are of the class and category numeric. A numeric function is always considered to have an operational sign.
    • A numeric function can be used only in an arithmetic expression

      MF or as the source of a MOVE statement

    • A numeric function cannot be referenced where an integer operand is required, even though a particular reference can yield an integer value.
  3. Integer functions. These are of the class and category numeric. An integer function is always considered to have an operational sign.
    • An integer function can be used only in an arithmetic expression

      MF or as the source of a MOVE statement

      ISO2002 or anywhere an integer data item is not used as a receiving data item.

    • An integer function can be referenced where an integer operand is required and where a signed operand is allowed.
  4. MF National functions. These are of the class and category national. The number of character positions in this data item is specified in the function definition. National functions have an implicit usage of NATIONAL.
Parent topic: Function Types
Related information
Intrinsic Functions
Arguments
Date Conversion Functions
Trigonometric Functions
Definitions of Functions


Date Conversion Functions

Date conversion functions are of type integer. The Gregorian calendar is used in the date conversion functions. The starting date of Monday, January 1, 1601, was chosen to establish a simple relationship between the date and DAY-OF-WEEK; that is, the integer date 1 was a Monday, DAY-OF-WEEK 1.

For example, the statement:

compute DoW =
     function rem (function integer-of-date (date-field) , 7)

returns the day of week for a given date, where 0 is Sunday, 1 is Monday, and so on.

Parent topic: Function Types
Related information
Intrinsic Functions
Arguments
Data Item Functions
Trigonometric Functions
Definitions of Functions


Trigonometric Functions

Trigonometric functions are of type numeric. Trigonometry deals with the relationships among the sides of a triangle and its angles. An angle can be measured in degrees, radians or Gon (grad). Since a computer usually generates trigonometric values by series approximation, the angle is specified in radians when used as the argument to the SIN, COS, and TAN functions or as the returned value from the ASIN, ACOS, and ATAN functions.

A radian is an arc of a circle whose length is equal to the circle's radius. Since the relationship between a circle's radius and circumference is C = 2 * P * r, and there are 360 degrees in a circle, we can derive from 360 = 2 * P * r, that the values for conversion are:

1 radian = 180/P = 57.295780 degrees 1 degree = P/180 = 0.01745329 radians.

Another scale that is sometimes used to measure angles is Gon, also known as grad. The values for conversion are:

1 radian = 200/P = 63.661977 Gon (grad) 1 Gon (grad) = P/200 = 0.01570796 radians.

Parent topic: Function Types
Related information
Intrinsic Functions
Arguments
Data Item Functions
Date Conversion Functions
Definitions of Functions


Definitions of Functions

The table below summarizes the intrinsic functions that are available.

The "arguments" column defines argument type and the "type" column defines the type of the function, as follows:

Alph | means alphabetic
Anum | means alphanumeric
Int | means integer
Nat | means national
Num | means numeric
Table 1. Summary of Functions
Function-Name | Arguments | Type | Value Returned
The ABS Function | Int1 or Num1 | Depends upon arguments | The absolute value of argument
The ACOS Function | Num1 | Num | Arccosine of Num1
The ANNUITY Function | Num1, Int2 | Num | Ratio of annuity paid for Int2 periods at interest of Num1 to initial investment of one
The ASIN Function | Num1 | Num | Arcsine of Num1
The ATAN Function | Num1 | Num | Arctangent of Num1
The CHAR Function | Int1 | Anum | Character in position Int1 of the alphanumeric program collating sequence
The CHAR-NATIONAL Function | Int1 | Nat | Character in position Int1 of the national program collating sequence
The COS Function | Num1 | Num | Cosine of Num1
The CURRENT-DATE Function | None | Anum | Current date and time and difference from Greenwich Mean Time
The DATE-OF-INTEGER Function | Int1 | Int | Standard date equivalent (YYYYMMDD) of integer date
The DATE-TO-YYYYMMDD Function | Int1, Int2 | Int | Argument-1 converted from YYMMDD to YYYYMMDD based on the value of argument-2
The DAY-OF-INTEGER Function | Int1 | Int | Julian date equivalent (YYYYDDD) of integer date
The DAY-TO-YYYYDDD Function | Int1, Int2 | Int | Argument-1 converted from YYDDD to YYYYDDD based on the value of argument-2
The DISPLAY-OF Function | Nat1, ENT MF Anum1 ENT Num1 | Anum | Usage display representation of argument Nat1
The E Function | None | Num | The value of e, the natural base
The EXP Function | Num1 | Num | e raised to the power Num1
The EXP10 Function | Num1 | Num | 10 raised to the power Num1
The FACTORIAL Function | Int1 | Int | Factorial of Int1
The FRACTION-PART Function | Num1 | Num | Fraction part of Num1
The INTEGER Function | Num1 | Int | The greatest integer not greater than Num1
The INTEGER-OF-DATE Function | Int1 | Int | The integer date equivalent of standard date (YYYYMMDD)
The INTEGER-OF-DAY Function | Int1 | Int | The integer date equivalent of Julian date (YYYYDDD)
The INTEGER-PART Function | Num1 | Int | Integer part of Num1
The LENGTH Function | Alph1 or Anum1 MF or Nat1 or Num1 | Int | Length of argument in number of character positions
The LENGTH-AN Function | Alph1 or Anum1 or Int1 or Nat1 or Num1 | Int | Length of argument in number of alphanumeric character positions
The LOG Function | Num1 | Num | Natural logarithm of Num1
The LOG10 Function | Num1 | Num | Logarithm to base 10 of Num1
The LOWER-CASE Function | Alph1 or Anum1 MF or Nat1 | Depends upon argument* | All letters in the argument are set to lowercase
The MAX Function | Alph1 ... or Anum1 ... or Int1 ... or MF Nat1 ... or Num1 ... | Depends upon arguments* | Value of maximum argument
The MEAN Function | Num1 ... | Num | Arithmetic mean of arguments
The MEDIAN Function | Num1 ... | Num | Median of arguments
The MIDRANGE Function | Num1 ... | Num | Mean of minimum and maximum arguments
The MIN Function | Alph1 ... or Anum1 ... or Int1 ... or MF Nat1 ... or Num1 ... | Depends upon arguments* | Value of minimum argument
The MOD Function | Int1, Int2 | Int | Int1 modulo Int2
The NATIONAL-OF Function | Anum1 MF or Nat1 Num1 | Nat | Usage national representation of argument Anum1
The NUMVAL Function | Anum1 or MF or Nat1 | Num | Numeric value of simple numeric string
The NUMVAL-C Function | Anum1 or Anum2 MF or Nat1 or Nat2 | Num | Numeric value of numeric string with optional commas and currency string
The ORD Function | Alph1 or Anum1 MF or Nat1 | Int | Ordinal position of the argument in collating sequence
The ORD-MAX Function | Alph1 ... or Anum1 ... or MF Nat1 ... or Num1 | Int | Ordinal position of maximum argument
The ORD-MIN Function | Alph1 ... or Anum1 ... or MF Nat1 ... or Num1 | Int | Ordinal position of minimum argument
The PI Function | None | Num | Value of
The PRESENT-VALUE Function | Num1, Num2 ... | Num | Present value of a series of future period-end amounts, Num2, at a discount rate of Num1
The RANDOM Function | Int1 | Num | Random number
The RANGE Function | Int1 ... or Num1 | Depends upon arguments* | Value of maximum argument minus value of minimum arguments
The REM Function | Num1, Num2 | Num | Remainder of Num1/Num2
The REVERSE Function | Alph1 or Anum1 MF or Nat1 | Depends upon argument* | Reverse order of the characters of the argument
The SIGN Function | Num1 | Int | The sign of Num1
The SIN Function | Num1 | Num | Sine of Num1
The SQRT Function | Num1 | Num | Square root of Num1
The STANDARD-DEVIATION Function | Num1 ... | Num | Standard deviation of arguments
The SUM Function | Int1 ... or Num1 ... | Depends upon arguments | Sum of arguments
The TAN Function | Num1 | Num | Tangent of Num1
The UPPER-CASE Function | Alph1 or Anum1 MF or Nat1 | Depends upon argument* | All letters in the argument are set to uppercase
The VARIANCE Function | Num1 ... | Num | Variance of argument
The WHEN-COMPILED Function | None | Anum | Date and time program was compiled
The YEAR-TO-YYYY Function | Int1, Int2 | Int | Argument-1 converted from YY to YYYY based on the value of argument-2

* A function that has only alphabetic arguments is type alphanumeric.

  • The ABS Function
    The ABS function returns the absolute value of the argument.
  • The ACOS Function
    The ACOS function returns a numeric value in radians that approximates the arccosine of argument-1. The type of this function is numeric.
  • The ANNUITY Function
    The ANNUITY function (annuity immediate) returns a numeric value that approximates the ratio of an annuity paid at the end of each period for the number of periods specified by argument-2 to an initial investment of one. Interest is earned at the rate specified by argument-1 and is applied at the end of the period, before the payment. The type of this function is numeric.
  • The ASIN Function
    The ASIN function returns a numeric value in radians that approximates the arcsine of argument-1. The type of this function is numeric.
  • The ATAN Function
    The ATAN function returns a numeric value in radians that approximates the arctangent of argument-1. The type of this function is numeric.
  • The BOOLEAN-OF-INTEGER Statement
    The BOOLEAN-OF-INTEGER function returns a boolean item of usage bit representing the binary value of argument-1. Argument-2 specifies the length of the boolean data item that is returned.
  • The CHAR Function
    The CHAR function returns a one-character alphanumeric value that is a character in the program collating sequence having the ordinal position equal to the value of argument-1. The type of this function is alphanumeric.
  • The CHAR-NATIONAL Function
    The CHAR-NATIONAL (national character) function returns a one-character value that is a character in the national program collating sequence having the ordinal position equal to the value of the argument.
  • The COS Function
    The COS function returns a numeric value that approximates the cosine of an angle or arc, expressed in radians, that is specified by argument-1. The type of this function is numeric.
  • The CURRENT-DATE Function
    The CURRENT-DATE function returns a 21-character alphanumeric value that represents the calendar date, time of day, and local time differential factor provided by the system on which the function is evaluated. The type of this function is alphanumeric.
  • The DATE-OF-INTEGER Function
    The DATE-OF-INTEGER function converts a date in the Gregorian calendar from integer date form to standard date form (YYYYMMDD). The type of this function is integer.
  • The DATE-TO-YYYYMMDD Function
    The DATE-TO-YYYYMMDD function converts argument-1 from the form YYmmdd to the form YYYYmmdd. Argument-2, when added to the year at the time of execution, defines the ending year of a 100-year interval, or sliding window, into which the year of argument-1 falls. The type of this function is integer.
  • The DAY-OF-INTEGER Function
    The DAY-OF-INTEGER function converts a date in the Gregorian calendar from integer date form to Julian date form (YYYYDDD). The type of this function is integer.
  • The DAY-TO-YYYYDDD Function
    The DAY-TO-YYYYDDD function converts argument-1 from the form YYnnn to the form YYYYnnn. Argument-2, when added to the year at the time of execution, defines the ending year of a 100-year interval, or sliding window, into which the year of argument-1 falls. The type of this function is integer.
  • The DISPLAY-OF Function
    The DISPLAY-OF function returns a character string containing the alphanumeric character representation - the external format representation - of the national characters in the argument.
  • The E Function
    The E function returns an approximation of e, the base of natural logarithms.
  • The EXP Function
    The EXP function returns an approximation of the value of e raised to the power of the argument.
  • The EXP10 Function
    The EXP10 function returns an approximation of the value of 10 raised to the power of the argument.
  • The FACTORIAL Function
    The FACTORIAL function returns an integer that is the factorial of argument-1. The type of this function is integer.
  • The FRACTION-PART Function
    The FRACTION-PART function returns a numeric value that is the fraction portion of the argument.
  • The INTEGER Function
    The INTEGER function returns the greatest integer value that is less than or equal to the argument. The type of this function is integer.
  • The INTEGER-OF-BOOLEAN Statement
    The INTEGER-OF-BOOLEAN function returns the numeric value of the boolean string in argument-1.
  • The INTEGER-OF-DATE Function
    The INTEGER-OF-DATE function converts a date in the Gregorian calendar from standard date form (YYYYMMDD) to integer date form. The type of this function is integer.
  • The INTEGER-OF-DAY Function
    The INTEGER-OF-DAY function converts a date in the Gregorian calendar from Julian date form (YYYYDDD) to integer date form. The type of this function is integer.
  • The INTEGER-PART Function
    The INTEGER-PART function returns an integer that is the integer portion of argument-1. The type of this function is integer.
  • The LENGTH Function
    The LENGTH function returns an integer equal to the length of the argument in alphanumeric character positions
  • The LENGTH-AN Function
    The LENGTH-AN function returns an integer equal to the length of the argument in number of alphnumeric character positions.
  • The LOG Function
    The LOG function returns a numeric value that approximates the logarithm to the base e (natural log) of argument-1. The type of this function is numeric.
  • The LOG10 Function
    The LOG10 function returns a numeric value that approximates the logarithm to the base 10 of argument-1. The type of this function is numeric.
  • The LOWER-CASE Function
    The LOWER-CASE function returns a character string that is the same length as argument-1 with each upper-case letter replaced by the corresponding lower-case letter. The type of this function depends on the argument as follows:
  • The MAX Function
    The MAX function returns the content of the argument-1 that contains the maximum value. The type of this function depends upon the argument types as follows:
  • The MEAN Function
    The MEAN function returns a numeric value that is the arithmetic mean (average) of its arguments. The type of this function is numeric.
  • The MEDIAN Function
    The MEDIAN function returns the content of the argument whose value is the middle value in the list formed by arranging the arguments in sorted order. The type of this function is numeric.
  • The MIDRANGE Function
    The MIDRANGE (middle range) function returns a numeric value that is the arithmetic mean (average) of the values of the minimum argument and the maximum argument. The type of this function is numeric.
  • The MIN Function
    The MIN function returns the content of the argument-1 that contains the minimum value. The type of this function depends upon the argument types as follows:
  • The MOD Function
    The MOD function returns an integer value that is argument-1 modulo argument-2. The type of this function is integer.
  • The NATIONAL-OF Function
    The NATIONAL-OF function returns a character string containing the national character internal representation of the characters in the argument.
  • The NUMVAL Function
    The NUMVAL function returns the numeric value represented by the character string specified by argument-1. Leading and trailing spaces are ignored. The type of this function is numeric.
  • The NUMVAL-C Function
    The NUMVAL-C function returns the numeric value represented by the character string specified by argument-1. Any optional currency string specified by argument-2 and any optional commas preceding the decimal point are ignored. The type of this function is numeric.
  • The ORD Function
    The ORD function returns an integer value that is the ordinal position of argument-1 in the collating sequence for the program. The lowest ordinal position is 1. The type of this function is integer.
  • The ORD-MAX Function
    The ORD-MAX function returns a value that is the ordinal number of the argument-1 that contains the maximum value. The type of this function is integer.
  • The ORD-MIN Function
    The ORD-MIN function returns a value that is the ordinal number of the argument-1 that contains the minimum value. The type of this function is integer.
  • The PI Function
    The PI function returns a value that is an approximation of the ratio of the circumference of a circle to its diameter.
  • The PRESENT-VALUE Function
    The PRESENT-VALUE function returns a value that approximates the present value of a series of future period-end amounts specified by argument-2 at a discount rate specified by argument-1. The type of this function is numeric.
  • The RANDOM Function
    The RANDOM function returns a numeric value that is a pseudo-random number from a rectangular distribution. The type of this function is numeric.
  • The RANGE Function
    The RANGE function returns a value that is equal to the value of the maximum argument minus the value of the minimum argument. The type of this function depends upon the argument types as follows:
  • The REM Function
    The REM function returns a numeric value that is the remainder of argument-1 divided by argument-2. The type of this function is numeric.
  • The REVERSE Function
    The REVERSE function returns a character string whose length and characters are exactly the same as argument-1, except that the characters are in reverse order. The type of this function depends on the argument type as follows:
  • The SIGN Function
    The SIGN function returns +1, 0, or -1 depending on the sign of the argument.
  • The SIN Function
    The SIN function returns a numeric value that approximates the sine of an angle or arc, expressed in radians, that is specified by argument-1. The type of this function is numeric.
  • The SQRT Function
    The SQRT function returns a numeric value that approximates the square root of argument-1. The type of this function is numeric.
  • The STANDARD-DEVIATION Function
    The STANDARD-DEVIATION function returns a numeric value that approximates the standard deviation of its arguments. The type of this function is numeric.
  • The SUM Function
    The SUM function returns a value that is the sum of the arguments. The type of this function depends upon the argument types as follows:
  • The TAN Function
    The TAN function returns a value that approximates the tangent of an angle or arc, expressed in radians, that is specified by argument-1. The type of this function is numeric.
  • The UPPER-CASE Function
    The UPPER-CASE function returns a character string that is the same length as argument-1 with each lower-case letter replaced by the corresponding upper-case letter. The type of this function depends on the argument as follows:
  • The VARIANCE Function
    The VARIANCE function returns a numeric value that approximates the variance of its arguments. The type of this function is numeric.
  • The WHEN-COMPILED Function
    The WHEN-COMPILED function returns the date and time the program was compiled. The type of this function is alphanumeric.
  • The YEAR-TO-YYYY Function
    The YEAR-TO-YYYY function converts argument-1, the two low-order digits of a year, to a four-digit year. Argument-2, when added to the year at the time of execution, defines the ending year of a 100-year interval, or sliding window, into which the year of argument-1 falls. The type of this function is integer.
Parent topic: Intrinsic Functions
Related information
Date Conversion Functions
Intrinsic Functions
Data Item Functions
Arguments
Trigonometric Functions


The ABS Function

The ABS function returns the absolute value of the argument.

The type of this function is according to the argument type as follows:

Argument Type | Function Type
Integer | Integer
Numeric | Numeric

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is as follows:
    1. When the value of argument-1 is zero or positive, (argument-1)
    2. When the value of argument-1 is negative, (-argument-1)
Parent topic: Definitions of Functions


The ACOS Function

The ACOS function returns a numeric value in radians that approximates the arccosine of argument-1. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.
  2. The value of argument-1 must be greater than or equal to -1 and less than or equal to +1.

Returned Values

  1. The returned value is the approximation of the arccosine of argument-1 and is greater than or equal to zero and less than or equal to pi.
    Note: Conversion factors from radians to degrees and Gon (grad) are specified in the section Trigonometric Functions.
  2. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions
Related information
Trigonometric Functions


The ANNUITY Function

The ANNUITY function (annuity immediate) returns a numeric value that approximates the ratio of an annuity paid at the end of each period for the number of periods specified by argument-2 to an initial investment of one. Interest is earned at the rate specified by argument-1 and is applied at the end of the period, before the payment. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.
  2. The value of argument-1 must be greater than or equal to zero.
  3. Argument-2 must be a positive integer.

Returned Values

  1. When the value of argument-1 is zero, the value of the function is the approximation of:

    1 / argument-2

  2. When the value of argument-1 is not zero, the value of the function is the approximation of:

    argument-1 / (1 - (1 + argument-1) ** (- argument-2))

  3. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The ASIN Function

The ASIN function returns a numeric value in radians that approximates the arcsine of argument-1. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.
  2. The value of argument-1 must be greater than or equal to -1 and less than or equal to +1.

Returned Values

  1. The returned value is the approximation of the arcsine of argument-1 and is greater than or equal to -pi/2 and less than or equal to +pi/2.
    Note: Conversion factors from radians to degrees and Gon (grad) are specified in the section Trigonometric Functions.
  2. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions
Related information
Trigonometric Functions


The ATAN Function

The ATAN function returns a numeric value in radians that approximates the arctangent of argument-1. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is the approximation of the arctangent of argument-1 and is greater than -pi/2 and less than +pi/2.
    Note: Conversion factors from radians to degrees and Gon (grad) are specified in the section Trigonometric Functions.
  2. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions
Related information
Trigonometric Functions


The BOOLEAN-OF-INTEGER Statement

The BOOLEAN-OF-INTEGER function returns a boolean item of usage bit representing the binary value of argument-1. Argument-2 specifies the length of the boolean data item that is returned.

The function type is boolean.

The returned value is a boolean item of usage bit that has the same bit configuration as the binary representation of the value of argument-1, where the rightmost boolean position is the low-order binary digit. The boolean value is zero-filled or truncated on the left, if necessary, in order to return a boolean item whose length is specified by argument-2 in terms of boolean positions.

General Format

FUNCTION BOOLEAN-OF-INTEGER (argument-1 argument-2)

Syntax Rules

  1. Argument-1 must be a positive integer.
  2. Argument-2 must be a positive nonzero integer.
  3. Argument-2 must be a numeric constant when the function is used
    • in an expression with B-NOT
    • as part of a boolean expression which is used as an argument in INTEGER-OF-BOOLEAN
Parent topic: Definitions of Functions


The CHAR Function

The CHAR function returns a one-character alphanumeric value that is a character in the program collating sequence having the ordinal position equal to the value of argument-1. The type of this function is alphanumeric.

General Format

Arguments

  1. Argument-1 must be an integer.
  2. The value of argument-1 must be greater than zero and less than or equal to the number of positions in the collating sequence.

Returned Values

  1. If more than one character has the same position in the program collating sequence, the character returned as the function value is that of the first literal specified for that character position in the ALPHABET clause.
  2. If the current program collating sequence was not specified by an ALPHABET clause, the native collating sequence is used.
Parent topic: Definitions of Functions


The CHAR-NATIONAL Function

The CHAR-NATIONAL (national character) function returns a one-character value that is a character in the national program collating sequence having the ordinal position equal to the value of the argument.
Restriction: This function is supported for native COBOL only.

The type of the function is national.

General Format

Arguments

  1. Argument-1 must be an integer.
  2. The value of argument-1 must be greater than zero and less than or equal to the number of positions in the national program collating sequence.

Returned Values

  1. The returned value is the character in the national program collating sequence having the ordinal position specifed by argument-1.
  2. If more than one character has the same ordinal positon in the current national program collating sequence, the returned value is the first character defined for that position.
Parent topic: Definitions of Functions


The COS Function

The COS function returns a numeric value that approximates the cosine of an angle or arc, expressed in radians, that is specified by argument-1. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.
    Note: Conversion factors from degrees and Gon (grad) to radians are specified in the section Trigonometric Functions.

Returned Values

  1. The returned value is the approximation of the cosine of argument-1 and is greater than or equal to -1 and less than or equal to +1.
  2. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions
Related information
Trigonometric Functions


The CURRENT-DATE Function

The CURRENT-DATE function returns a 21-character alphanumeric value that represents the calendar date, time of day, and local time differential factor provided by the system on which the function is evaluated. The type of this function is alphanumeric.

General Format

Returned Values

  1. The character positions returned, numbered from left to right, are:
    Character Positions | Contents
    1-4 | Four numeric digits of the year in the Gregorian calendar.
    5-6 | Two numeric digits of the month of the year, in the range 01 through 12.
    7-8 | Two numeric digits of the day of the month, in the range 01 through 31.
    9-10 | Two numeric digits of the hours past midnight, in the range 00 through 23.
    11-12 | Two numeric digits of the minutes past the hour, in the range 00 through 59.
    13-14 | Two numeric digits of the seconds past the minute, in the range 00 through 59.
    15-16 Two numeric digits of the hundredths of a second past the second, in the range 00 through 99.

    If the system does not have the facility to provide fractional parts of a second, the value 00 is returned.

    17 Either the character "-", the character " +", or the character "0". The character "-" is returned if the local time indicated in the previous character positions is behind Greenwich Mean Time. The character "+" is returned if the local time indicated is the same or ahead of Greenwich Mean Time. The character "0" is returned if the system on which this function is evaluated does not have the facility to provide the local time differential factor.

    If the system does not have the facility to provide the local time differential factor, the value 00000 is returned in character positions 17 through 21.

    18-19 | If character position 17 is "-", two numeric digits are returned in the range 00 through 12 indicating the number of hours that the reported time is behind Greenwich Mean Time. If character position 17 is "+", two numeric digits are returned in the range 00 through 13 indicating the number of hours that the reported time is ahead of Greenwich Mean Time. If character position 17 is "0", the value 00 is returned.
    20-21 | Two numeric digits are returned in the range 00 through 59 indicating the number of additional minutes that the reported time is ahead of or behind Greenwich Mean Time, depending on whether character position 17 is "+" or "-" , respectively. If character position 17 is "0", the value 00 is returned.
Parent topic: Definitions of Functions


The DATE-OF-INTEGER Function

The DATE-OF-INTEGER function converts a date in the Gregorian calendar from integer date form to standard date form (YYYYMMDD). The type of this function is integer.

General Format

Arguments

  1. Argument-1 is a positive integer that represents a number of days succeeding December 31, 1600, in the Gregorian calendar.

Returned Values

  1. The returned value represents the ISO Standard date equivalent of the integer specified in argument-1.
  2. The returned value is in the form (YYYYMMDD) where YYYY represents a year in the Gregorian calendar; MM represents the month of that year; and DD represents the day of that month.
Parent topic: Definitions of Functions


The DATE-TO-YYYYMMDD Function

The DATE-TO-YYYYMMDD function converts argument-1 from the form YYmmdd to the form YYYYmmdd. Argument-2, when added to the year at the time of execution, defines the ending year of a 100-year interval, or sliding window, into which the year of argument-1 falls. The type of this function is integer.

General Format

    FUNCTION DATE-TO-YYYYMMDD ( argument-1 [argument-2] )

Arguments

  1. Argument-1 must be a positive integer less than 1,000,000.
  2. Argument-2 must be an integer.
  3. If argument-2 is omitted, the function is evaluated as though 50 were specified.
  4. The sum of the year at the time of execution and the value of argument-2 must be less than 10,000 and greater than 1699.

Returned Values

  1. The equivalent arithmetic expression is:

    (FUNCTION YEAR-TO-YYYY (YY, argument-2) * 10000 + nnnn) where:

    YY = FUNCTION INTEGER (argument-1/10000) nnnn = FUNCTION MOD (argument-1, 10000)

    and where argument-1 of the INTEGER and MOD functions and argument-2 of the YEAR-TO-YYYY function are the same as argument-1 and argument-2 of the DATE-TO-YYYYMMDD function itself.

Notes

  1. In the year 2002 the returned value for FUNCTION DATE-TO-YYYYMMDD (851003, 10) is 19851003. In the year 1994 the returned value for FUNCTION DATE-TO-YYYYMMDD (981002, (-10)) is 18981002.
  2. This function supports a sliding window algorithm. See the notes for the YEAR-TO-YYYY function for a discussion of how to specify a fixed window.
Parent topic: Definitions of Functions


The DAY-OF-INTEGER Function

The DAY-OF-INTEGER function converts a date in the Gregorian calendar from integer date form to Julian date form (YYYYDDD). The type of this function is integer.

General Format

Arguments

  1. Argument-1 is a positive integer that represents a number of days succeeding December 31, 1600, in the Gregorian calendar.

Returned Values

  1. The returned value represents the Julian equivalent of the integer specified in argument-1.
  2. The returned value is an integer of the form (YYYYDDD) where YYYY represents a year in the Gregorian calendar and DDD represents the day of that year.
Parent topic: Definitions of Functions


The DAY-TO-YYYYDDD Function

The DAY-TO-YYYYDDD function converts argument-1 from the form YYnnn to the form YYYYnnn. Argument-2, when added to the year at the time of execution, defines the ending year of a 100-year interval, or sliding window, into which the year of argument-1 falls. The type of this function is integer.

General Format

    FUNCTION DAY-TO-YYYYDDD ( argument-1 [argument-2] )

Arguments

  1. Argument-1 must be a positive integer less than 100,000.
  2. Argument-2 must be an integer.
  3. If argument-2 is omitted, the function is evaluated as though 50 were specified.
  4. The sum of the year at the time of execution and the value of argument-2 must be less than 10,000 and greater than 1699.

Returned Values

  1. The equivalent arithmetic expression is:

    (FUNCTION YEAR-TO-YYYY (YY, argument-2) * 1000 + nnn)

    where:

    YY = FUNCTION INTEGER (argument-1/1000) nnn = FUNCTION MOD (argument-1, 1000)

    and where argument-1 of the INTEGER and MOD functions and argument-2 of the YEAR-TO-YYYY functions are the same as argument-1 and argument-2 of the DAY-TO-YYYYDDD function itself.

Notes

  1. In the year 2002 the returned value for FUNCTION DAY-TO-YYYYDDD (10004,20) is 2010004. In the year 1994 the returned value for FUNCTION DAY-TO-YYYYDDD (95005, (-10)) is 1895005.
  2. This function supports a sliding window algorithm. See the notes for the YEAR-TO-YYYY function for a discussion of how to specify a fixed window.
Parent topic: Definitions of Functions


The DISPLAY-OF Function

The DISPLAY-OF function returns a character string containing the alphanumeric character representation - the external format representation - of the national characters in the argument.

The type of the function is alphanumeric.

General Format

Arguments

  1. Argument-1 must be of class national.
  2. ISO2002 MF Argument-2 must be of class alphabetic or alphanumeric and must be one character position in length. Argument-2 specifies an alphanumeric substitution character for use in conversion of national characters for which there is no corresponding alphanumeric character.

    ENT Must be an integer. Argument-2 identifies the source code page for the conversion. Currently beyond the default codepage only 1208 is supported.

Returned Values

  1. A character string is returned with each national character of argument-1 converted to its corresponding alphanumeric character representation, if any. The correspondence of characters between the alphanumeric character set and the national character set depends on the native environment.
  2. ISO2002 MF If argument-2 is specified, the alphanumeric substitution character is returned for each national character in argument-1 that has no corresponding alphanumeric character representation.
  3. ISO2002 MF If argument-2 is unspecified, each national character in argument-1 that has no corresponding alphanumeric character representation is returned in national external format, with the minimum of control functions necessary for interpretation of the external format characters.
  4. The length of the returned value is the number of character positions of usage display required to hold the returned value; it is dependent on the characters in the argument and on the attributes of the national character set.
Parent topic: Definitions of Functions


The E Function

The E function returns an approximation of e, the base of natural logarithms.

The type of the function is numeric.

General Format

Returned Values

  1. The returned value is:

    2.718281828459045235

Parent topic: Definitions of Functions


The EXP Function

The EXP function returns an approximation of the value of e raised to the power of the argument.

The type of the function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is:

    FUNCTION E ** argument-1

Parent topic: Definitions of Functions


The EXP10 Function

The EXP10 function returns an approximation of the value of 10 raised to the power of the argument.

The type of the function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is:

    10 ** argument-1

Parent topic: Definitions of Functions


The FACTORIAL Function

The FACTORIAL function returns an integer that is the factorial of argument-1. The type of this function is integer.

General Format

Arguments

  1. Argument-1 must be an integer greater than or equal to zero.

Returned Values

  1. If the value of argument-1 is zero, the value 1 is returned.
  2. If the value of argument-1 is positive, its factorial is returned.
  3. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The FRACTION-PART Function

The FRACTION-PART function returns a numeric value that is the fraction portion of the argument.

The type of the function is numeric.

General Format

Arguments

  1. Argument-1 must be of the class numeric.

Returned Values

  1. The returned value is:

    (argument-1 - FUNCTION INTEGER-PART (argument-1))

    where the argument for the INTEGER-PART function is the same as for the FRACTION-PART function itself.

    Note: If the value of argument-1 is +1.5, +0.5 is returned. If the value of argument-1 is -1.5, -0.5 is returned.
Parent topic: Definitions of Functions


The INTEGER Function

The INTEGER function returns the greatest integer value that is less than or equal to the argument. The type of this function is integer.

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is the greatest integer less than or equal to the value of argument-1. For example, if the value of argument-1 is -1.5, -2 is returned. If the value of argument-1 is +1.5, +1 is returned.
Parent topic: Definitions of Functions


The INTEGER-OF-BOOLEAN Statement

The INTEGER-OF-BOOLEAN function returns the numeric value of the boolean string in argument-1.

The function type is integer.

General Format

FUNCTION INTEGER-OF-BOOLEAN (argument-1)

Syntax Rules

  1. Argument-1 must be a boolean data item.
Parent topic: Definitions of Functions


The INTEGER-OF-DATE Function

The INTEGER-OF-DATE function converts a date in the Gregorian calendar from standard date form (YYYYMMDD) to integer date form. The type of this function is integer.

General Format

Arguments

  1. Argument-1 must be an integer of the form YYYYMMDD, whose value is obtained from the calculation:

    (YYYY * 10,000) + (MM * 100) + DD.

    1. YYYY represents the year in the Gregorian calendar. It must be an integer greater than 1600.
    2. MM represents a month and must be a positive integer less than 13.
    3. DD represents a day and must be a positive integer less than 32 provided that it is valid for the specified month and year combination.

Returned Values

  1. The returned value is an integer that is the number of days by which the date represented by argument-1 succeeds December 31, 1600, in the Gregorian calendar.
Parent topic: Definitions of Functions


The INTEGER-OF-DAY Function

The INTEGER-OF-DAY function converts a date in the Gregorian calendar from Julian date form (YYYYDDD) to integer date form. The type of this function is integer.

General Format

Arguments

  1. Argument-1 must be an integer of the form YYYYDDD, whose value is obtained from the calculation:

    (YYYY * 1000) + DDD.

    1. YYYY represents the year in the Gregorian calendar. It must be an integer greater than 1600.
    2. DDD represents the day of the year. It must be a positive integer less than 367 provided that it is valid for the year specified.

Returned Values

  1. The returned value is an integer that is the number of days by which the date represented by argument-1 succeeds December 31, 1600, in the Gregorian calendar.
Parent topic: Definitions of Functions


The INTEGER-PART Function

The INTEGER-PART function returns an integer that is the integer portion of argument-1. The type of this function is integer.

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. If the value of argument-1 is zero, the returned value is zero.
  2. If the value of argument-1 is positive, the returned value is the greatest integer less than or equal to the value of argument-1. For example, if the value of argument-1 is +1.5, +1 is returned.
  3. If the value of argument-1 is negative, the returned value is the least integer greater than or equal to the value of argument-1. For example, if the value of argument-1 is -1.5, -1 is returned.
Parent topic: Definitions of Functions


The LENGTH Function

The LENGTH function returns an integer equal to the length of the argument in alphanumeric character positions

MF or national character positions, depending on the class of the argument.

The type of this function is integer.

General Format

Arguments

  1. Argument-1 can be a nonnumeric literal or a data item of any class or category.
  2. If argument-1 or any data item subordinate to argument-1 is described with the DEPENDING phrase of the OCCURS clause, the contents of the data item referenced by the data-name specified in the DEPENDING phrase are used at the time the LENGTH function is evaluated.

Returned Values

  1. If argument-1 is an alphanumeric literal or is an elementary data item of class other than national or is a group data item that does not contain a variable occurrence data item, the value returned is an integer equal to the length of argument-1 in alphanumeric character positions.

    MF If argument-1 is an elementary data item of the class national or is a national literal, the returned value is an integer equal to the length of argument-1 in national character positions.

  2. If argument-1 is a group data item containing a variable occurrence data item, the returned value is an integer determined by evaluation of the data item specified in the DEPENDING phrase of the OCCURS clause for that variable occurrence data item. This evaluation is accomplished according to the rules in the OCCURS clause dealing with the data item as a sending data item. See the section The OCCURS Clause in the chapter Data Division - File and Data Description.
  3. The returned value includes implicit FILLER characters, if any.
Parent topic: Definitions of Functions
Related information
The OCCURS Clause


The LENGTH-AN Function

The LENGTH-AN function returns an integer equal to the length of the argument in number of alphnumeric character positions.

The type of the function is integer.

General Format

Arguments

  1. Argument-1 may be a literal or data item of any class or category.
  2. If argument-1 or any data item subordinate to argument-1 is described with the DEPENDING phrase of the OCCURS clause, the contents of the data item referenced by the data-name specified in the DEPENDING phrase is used at the time the LENGTH-AN function is evaluated.

Returned Values

  1. If argument-1 is an elementary data item, the returned value is an integer equal to the length of argument-1 in alphanumeric character positions.
  2. If argument-1 is a group data item:
    1. If argument-1 or any data item subordinate to argument-1 is decribed with the DEPENDING phrase of the OCCURS clause, the returned value is an integer equal to the length of argument-1 in alphanumeric character positions, as a sending data item, determined by evaluation of the data item specified in the DEPENDING phrase in accordance with the rules of the OCCURS clause.
    2. Otherwise the value returned is an integer equal to the lengthof argument-1 in alphanumeric character positions.
    3. The returned length includes the number of implicit FILLER positions, if any, in argument-1.
Parent topic: Definitions of Functions


The LOG Function

The LOG function returns a numeric value that approximates the logarithm to the base e (natural log) of argument-1. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.
  2. The value of argument-1 must be greater than zero.

Returned Values

  1. The returned value is the approximation of the logarithm to the base e of argument-1.
  2. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The LOG10 Function

The LOG10 function returns a numeric value that approximates the logarithm to the base 10 of argument-1. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.
  2. The value of argument-1 must be greater than zero.

Returned Values

  1. The returned value is the approximation of the logarithm to the base 10 of argument-1.
  2. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The LOWER-CASE Function

The LOWER-CASE function returns a character string that is the same length as argument-1 with each upper-case letter replaced by the corresponding lower-case letter. The type of this function depends on the argument as follows:
Argument Type | Function Type
Alphabetic | Alphanumeric
Alphanumeric | Alphanumeric
National | National

General Format

Arguments

  1. Argument-1 must be class alphabetic or alphanumeric

    MF or national

    and must be at least one character in length.

Returned Values

  1. The same character string as argument-1 is returned, except that each upper-case letter is replaced by the corresponding lower-case letter.
  2. The character string returned has the same length as argument-1.
  3. If the computer character set does not include lower-case letters, no changes take place in the character string.
Parent topic: Definitions of Functions


The MAX Function

The MAX function returns the content of the argument-1 that contains the maximum value. The type of this function depends upon the argument types as follows:
Argument Type | Function Type
Alphabetic | Alphanumeric
Alphanumeric | Alphanumeric
National | National
All arguments integer | Integer
Numeric | Numeric
(some arguments can be integer) |

General Format

Arguments

  1. If more than one argument-1 is specified, all arguments must be of the same class except alphabetic and alphanumeric arguments which can be mixed.

Returned Values

  1. The returned value is the content of the argument-1 having the greatest value. The comparisons used to determine the greatest value are made according to the rules for relation conditions. See the topic Relation Condition in the chapter Procedure Division.
  2. If more than one argument-1 has the same greatest value, the content of the argument-1 returned is the leftmost argument-1 having that value.
  3. If the type of the function is alphanumeric

    MF or national

    the size of the returned value is the same as the size of the selected argument-1.

  4. If the value of argument-1 is numeric non-integer, results are returned in floating-point format.
Parent topic: Definitions of Functions
Related information
Relation Condition


The MEAN Function

The MEAN function returns a numeric value that is the arithmetic mean (average) of its arguments. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is the arithmetic mean of the argument-1 series.
  2. The returned value is defined as the sum of the argument-1 series divided by the number of occurrences referenced by argument-1.
  3. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The MEDIAN Function

The MEDIAN function returns the content of the argument whose value is the middle value in the list formed by arranging the arguments in sorted order. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is the content of the argument-1 having the middle value in the list formed by arranging all the argument-1 values in sorted order.
  2. If the number of occurrences referenced by argument-1 is odd, the returned value is such that at least half of the occurrences referenced by argument-1 are greater than or equal to the returned value and at least half are less than or equal. If the number of occurrences referenced by argument-1 is even, the returned value is the arithmetic mean of the values referenced by the two middle occurrences.
  3. The comparisons used to arrange the argument-1 values in sorted order are made according to the rules for relation conditions. See the topic Relation Condition in the chapter Procedure Division.
  4. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions
Related information
Relation Condition


The MIDRANGE Function

The MIDRANGE (middle range) function returns a numeric value that is the arithmetic mean (average) of the values of the minimum argument and the maximum argument. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is the arithmetic mean of the greatest argument-1 value and the least argument-1 value.
  2. The comparisons used to determine the greatest and least values are made according to the rules for relation conditions. See the topic Relation Condition in the chapter Procedure Division.
  3. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions
Related information
Relation Condition


The MIN Function

The MIN function returns the content of the argument-1 that contains the minimum value. The type of this function depends upon the argument types as follows:
Argument Type | Function Type
Alphabetic | Alphanumeric
Alphanumeric | Alphanumeric
National | National
All arguments integer | Integer
Numeric | Numeric
(some arguments can be integer) |

General Format

Arguments

  1. If more than one argument-1 is specified, all arguments must be of the same class except alphabetic and alphanumeric arguments which can be mixed.

Returned Values

  1. The returned value is the content of the argument-1 having the least value. The comparisons used to determine the least value are made according to the rules for relation conditions. See the topic Relation Condition in the chapter Procedure Division.
  2. If more than one argument-1 has the same least value, the content of the argument-1 returned is the leftmost argument-1 having that value.
  3. If the type of the function is alphanumeric

    MF or national,

    the size of the returned value is the same as the size of the selected argument-1.

  4. If the value of argument-1 is numeric non-integer, results are returned in floating-point format.
Parent topic: Definitions of Functions
Related information
Relation Condition


The MOD Function

The MOD function returns an integer value that is argument-1 modulo argument-2. The type of this function is integer.

General Format

Arguments

  1. Argument-1 and argument-2 must be integers.
  2. The value of argument-2 must not be zero.

Returned Values

  1. The returned value is argument-1 modulo argument-2. The returned value is defined as:

    argument-1 - (argument-2 * FUNCTION INTEGER (argument-1 / argument-2))

  2. The expected results for some values of argument-1 and argument-2 are as follows:
    Argument-1 | Argument-2 | Return
    11 | 5 | 1
    -11 | 5 | 4
    11 | -5 | -4
    -11 | -5 | -1
Parent topic: Definitions of Functions


The NATIONAL-OF Function

The NATIONAL-OF function returns a character string containing the national character internal representation of the characters in the argument.

The type of the function is national.

General Format

Arguments

  1. Argument-1 must be of class alphabetic or class alphnumeric. If alphanumeric, it may contain alphanumeric characters or national characters in external format, or both.
  2. ISO2002 MF Argument-2 must be of category national and must be one character in length. Argument-2 specifes a national substitution character for use in conversion of alphanumeric characters for which there is no corresponding national character.

    ENT Must be an integer. Argument-2 identifies the source code page for the conversion. Currently beyond the default codepage only 1208 is supported.

Returned Values

  1. A character string is returned with each alphanumeric character and each national character in argument-1 converted to its corresponding national internal format. Any control functions used for external format representation in argument-1 are recognised only for purposes of distinguishing characters, and are not be considered as separate characters of argument-1.
  2. ISO2002 MF If argument-2 is specified, each character in argument-1 that has no corresponding internal national representation is converted to the substitution character specified by argument-2.

  3. ISO2002 MF If argument-2 is unspecified, each character that has no corresponding internal national representation is converted to a national space.

    .
  4. The length of the returned value is the number of character positions of usage national required to hold the converted argument and depends on the number of characters contained in argument-1.
Parent topic: Definitions of Functions


The NUMVAL Function

The NUMVAL function returns the numeric value represented by the character string specified by argument-1. Leading and trailing spaces are ignored. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be an alphanumeric

    MF or national

    literal or an alphanumeric

    MF or national

    data item whose content has one of the following two formats:

    or

    where space is a string of zero or more spaces and digit is a string of one to 18 digits.

  2. The total number of digits in argument-1 must not exceed 18.
  3. If the DECIMAL POINT IS COMMA clause is specified in the Special-Names paragraph, a comma must be used in argument-1 rather than a decimal point.

Returned Values

  1. The returned value is the numeric value represented by argument-1.
  2. The number of digits returned is 18.
  3. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The NUMVAL-C Function

The NUMVAL-C function returns the numeric value represented by the character string specified by argument-1. Any optional currency string specified by argument-2 and any optional commas preceding the decimal point are ignored. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be an alphanumeric

    MF or national

    literal or an alphanumeric

    MF or national

    data item whose content has one of the following two formats:

    or

    where space is a string of zero or more spaces, cs is the string of one or more characters specified by argument-2 and digit is a string of one or more digits.

  2. If the DECIMAL POINT IS COMMA clause is specified in the Special-Names paragraph, the functions of the comma and decimal point in argument-1 are reversed.
  3. The total number of digits in argument-1 must not exceed 18.
  4. Argument-2, if specified, must be of the same class as argument-1.

    It cannot be a digit, comma, space, plus sign(+), minus sign (-) or decimal point.

  5. If argument-2 is not specified, the character used for cs is the currency string specified for the program when argument-1 is of class alphanumeric

    MF ; or if argument-1 is of class national, the national representation of the currency string specified for the program. The national representation of cs is the value returned from FUNCTION NATIONAL-OF (cs).

Returned Values

  1. The returned value is the numeric value represented by argument-1.
  2. The number of digits returned is 18.
  3. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The ORD Function

The ORD function returns an integer value that is the ordinal position of argument-1 in the collating sequence for the program. The lowest ordinal position is 1. The type of this function is integer.

General Format

Arguments

  1. Argument-1 must be one character in length and must be class alphabetic, alphanumeric

    MF or national.

Returned Values

  1. If the class of argument-1 is alphabetic or alphanumeric, the returned value is the ordinal position of argument-1 in the current alphanumeric collating sequence for the program.
  2. MF If the class of argument-1 is national, the returned value is the ordinal position of argument-1 in the current national program collating sequence.
Parent topic: Definitions of Functions


The ORD-MAX Function

The ORD-MAX function returns a value that is the ordinal number of the argument-1 that contains the maximum value. The type of this function is integer.

General Format

Arguments

  1. If more than one argument-1 is specified, all arguments must be of the same class, except alphabetic and alphanumeric arguments which can be mixed.

Returned Values

  1. The returned value is the ordinal number that corresponds to the position of the argument-1 having the greatest value in the argument-1 series.
  2. The comparisons used to determine the greatest valued argument are made according to the rules for relation conditions. See the topic Relation Condition in the chapter Procedure Division.
  3. If more than one argument-1 has the same greatest value, the number returned corresponds to the position of the leftmost argument-1 having that value.
Parent topic: Definitions of Functions
Related information
Relation Condition


The ORD-MIN Function

The ORD-MIN function returns a value that is the ordinal number of the argument-1 that contains the minimum value. The type of this function is integer.

General Format

Arguments

  1. If more than one argument-1 is specified, all arguments must be of the same class, except alphabetic and alphanumeric arguments which may be mixed.

Returned Values

  1. The returned value is the ordinal number that corresponds to the position of the argument-1 having the lowest value in the argument-1 series.
  2. The comparisons used to determine the lowest valued argument are made according to the rules for relation conditions. See the topic Relation Condition in the chapter Procedure Division.
  3. If more than one argument-1 has the same lowest value, the number returned corresponds to the position of the leftmost argument-1 having that value.
Parent topic: Definitions of Functions
Related information
Relation Condition


The PI Function

The PI function returns a value that is an approximation of the ratio of the circumference of a circle to its diameter.

The type of the function is numeric.

General Format

Returned Values

  1. The returned value is:

    3.141592653589793238

Parent topic: Definitions of Functions


The PRESENT-VALUE Function

The PRESENT-VALUE function returns a value that approximates the present value of a series of future period-end amounts specified by argument-2 at a discount rate specified by argument-1. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 and argument-2 must be of the class numeric.
  2. The value of argument-1 must be greater than -1.

Returned Values

  1. The returned value is an approximation of the summation of a series of calculations with each term in the following form:

    argument-2 / (1+argument-1) ** n

    There is one term for each occurrence of argument-2. The exponent, n, is incremented from one by one for each term in the series.

  2. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The RANDOM Function

The RANDOM function returns a numeric value that is a pseudo-random number from a rectangular distribution. The type of this function is numeric.

General Format

Arguments

  1. If argument-1 is specified, it must be zero or a positive integer. It is used as the seed value to generate a sequence of pseudo-random numbers.
  2. If a subsequent reference specifies argument-1, a new sequence of pseudo-random numbers is started.
  3. MF If the first reference to this function in the run unit does not specify argument-1, the seed value of zero is used.
  4. In each case, subsequent references without specifying argument-1 return the next number in the current sequence.

Returned Values

  1. The returned value is greater than or equal to zero and less than one.
  2. For a given seed value on a given implementation, the sequence of pseudo-random numbers will always be the same.
  3. The domain of argument-1 values will yield distinct sequences of pseudo-random numbers. This subset includes the values from 0 through at least 32767.
  4. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The RANGE Function

The RANGE function returns a value that is equal to the value of the maximum argument minus the value of the minimum argument. The type of this function depends upon the argument types as follows:
Argument Type | Function Type
All arguments integer | Integer
Numeric | Numeric
(some arguments can be integer) |

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is equal to the greatest value of argument-1 minus the least value of argument-1.
  2. The comparisons used to determine the greatest and least values are made according to the rules for relation conditions. See the topic Relation Condition in the chapter Procedure Division.
  3. If the value of argument-1 is numeric non-integer, results are returned in floating-point format.
Parent topic: Definitions of Functions
Related information
Relation Condition


The REM Function

The REM function returns a numeric value that is the remainder of argument-1 divided by argument-2. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 and argument-2 must be class numeric.
  2. The value of argument-2 must not be zero.

Returned Values

  1. The returned value is the remainder of argument-1 / argument-2. It is defined as the expression:

    argument-1 - (argument-2 * FUNCTION INTEGER-PART (argument-1 / argument-2))

  2. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The REVERSE Function

The REVERSE function returns a character string whose length and characters are exactly the same as argument-1, except that the characters are in reverse order. The type of this function depends on the argument type as follows:
Argument Type | Function Type
Alphabetic | Alphanumeric
Alphanumeric | Alphanumeric
National | National

General Format

Arguments

  1. Argument-1 must be class alphabetic, alphanumeric

    MF or national

    and must be at least one character in length.

Returned Values

  1. If argument-1 is a character string of length n, the returned value is a character string of length n such that for 1 <j < n, the character in position j of the returned value is the character from position n-j+1 of argument-1.
Parent topic: Definitions of Functions


The SIGN Function

The SIGN function returns +1, 0, or -1 depending on the sign of the argument.

The type of the function is integer.

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is:
    1. When the value of argument-1 is positive, 1
    2. When the value of argument-1 is zero, 0
    3. When the value of argument-1 is negative, -1
Parent topic: Definitions of Functions


The SIN Function

The SIN function returns a numeric value that approximates the sine of an angle or arc, expressed in radians, that is specified by argument-1. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.
    Note: Conversion factors from degrees and Gon (grad) to radians are specified in the section Trigonometric Functions.

Returned Values

  1. The returned value is the approximation of the sine of argument-1 and is greater than or equal to -1 and less than or equal to +1.
  2. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions
Related information
Trigonometric Functions


The SQRT Function

The SQRT function returns a numeric value that approximates the square root of argument-1. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.
  2. The value of argument-1 must be zero or positive.

Returned Values

  1. The returned value is the absolute value of the approximation of the square root of argument-1.
  2. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The STANDARD-DEVIATION Function

The STANDARD-DEVIATION function returns a numeric value that approximates the standard deviation of its arguments. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is the approximation of the standard deviation of the argument-1 series.
  2. The returned value is calculated as follows:
    1. The difference between each argument-1 value and the arithmetic mean of the argument-1 series is calculated and squared.
    2. The values obtained are added. This quantity is divided by the number of values in the argument-1 series.
    3. The square root of the quotient obtained is calculated. The returned value is the absolute value of this square root.
  3. If the argument-1 series consists of only one value, or if the argument-1 series consists of all variable occurrence data items and the total number of occurrences for all of them is one, the returned value is zero.
  4. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions


The SUM Function

The SUM function returns a value that is the sum of the arguments. The type of this function depends upon the argument types as follows:
Argument Type | Function Type
All arguments integer | Integer
Numeric | Numeric
(some arguments may be integer) |

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is the sum of the arguments.
  2. If the argument-1 series are all integers, the value returned is an integer.
  3. If the argument-1 series are not all integers, a numeric value is returned in floating-point format.
Parent topic: Definitions of Functions


The TAN Function

The TAN function returns a value that approximates the tangent of an angle or arc, expressed in radians, that is specified by argument-1. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.
    Note: Conversion factors from degrees and Gon (grad) to radians are specified in the section Trigonometric Functions.

Returned Values

  1. The returned value is the approximation of the tangent of argument-1.
  2. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions
Related information
Trigonometric Functions


The UPPER-CASE Function

The UPPER-CASE function returns a character string that is the same length as argument-1 with each lower-case letter replaced by the corresponding upper-case letter. The type of this function depends on the argument as follows:
Argument Type | Function Type
Alphabetic | Alphanumeric
Alphanumeric | Alphanumeric
National | National

General Format

Arguments

  1. Argument-1 must be class alphabetic, alphanumeric

    MF or national

    and must be at least one character in length.

Returned Values

  1. The same character string as argument-1 is returned, except that each lower-case letter is replaced by the corresponding upper-case letter.
  2. The character string returned has the same length as argument-1.
Parent topic: Definitions of Functions


The VARIANCE Function

The VARIANCE function returns a numeric value that approximates the variance of its arguments. The type of this function is numeric.

General Format

Arguments

  1. Argument-1 must be class numeric.

Returned Values

  1. The returned value is the approximation of the variance of the argument-1 series.
  2. The returned value is defined as the square of the standard deviation of the argument-1 series. (See the topic The STANDARD-DEVIATION Function.)
  3. If the argument-1 series consists of only one value, or if the argument-1 series consists of all variable occurrence data items and the total number of occurrences for all of them is one, the returned value is zero.
  4. Floating-point format is used for numeric non-integer results.
Parent topic: Definitions of Functions
Related information
The STANDARD-DEVIATION Function


The WHEN-COMPILED Function

The WHEN-COMPILED function returns the date and time the program was compiled. The type of this function is alphanumeric.

General Format

Returned Values

  1. The character positions returned, numbered from left to right, are:
    Character Positions | Contents
    1-4 | Four numeric digits of the year in the Gregorian calendar.
    5-6 | Two numeric digits of the month of the year, in the range 01 through 12.
    7-8 | Two numeric digits of the day of the month, in the range 01 through 31.
    9-10 | Two numeric digits of the hours past midnight, in the range 00 through 23.
    11-12 | Two numeric digits of the minutes past the hour, in the range 00 through 59.
    13-14 | Two numeric digits of the seconds past the minute, in the range 00 through 59.
    15-16 Two numeric digits of the hundredths of a second past the second, in the range 00 through 99.

    If the system does not have the facility to provide fractional parts of a second, the value 00 is returned.

    17 Either the character "-", the character " +", or the character "0". The character "-" is returned if the local time indicated in the previous character positions is behind Greenwich Mean Time. The character "+" is returned if the local time indicated is the same or ahead of Greenwich Mean Time. The character "0" is returned if the system on which this function is evaluated does not have the facility to provide the local time differential factor.

    If the system does not have the facility to provide the local time differential factor, the value 00000 is returned in character positions 17 through 21.

    18-19 | If character position 17 is "-", two numeric digits are returned in the range 00 through 12, indicating the number of hours that the reported time is behind Greenwich Mean Time. If character position 17 is "+", two numeric digits are returned in the range 00 through 13 indicating the number of hours that the reported time is ahead of Greenwich Mean Time. If character position 17 is "0", the value 00 is returned.
    20-21 Two numeric digits are returned in the range 00 through 59 indicating the number of additional minutes that the reported time is ahead of or behind Greenwich Mean Time, depending on whether character position 17 is "+" or "-" , respectively.

    If character position 17 is "0", the value 00 is returned.

  2. The returned value is the date and time of compilation of the source program that contains this function. If the program is a contained program, the returned value is the compilation date and time associated with the separately compiled program in which it is contained.
  3. The returned value denotes the same time as the compilation date and time if provided in the listing of the source program and in the generated object code for the source program, although their representations and precisions may differ.
Parent topic: Definitions of Functions


The YEAR-TO-YYYY Function

The YEAR-TO-YYYY function converts argument-1, the two low-order digits of a year, to a four-digit year. Argument-2, when added to the year at the time of execution, defines the ending year of a 100-year interval, or sliding window, into which the year of argument-1 falls. The type of this function is integer.

General Format

    FUNCTION YEAR-TO-YYYY ( argument-1 [argument-2] )

Arguments

  1. Argument-1 must be a nonnegative integer less than 100.
  2. Argument-2 must be an integer.
  3. If argument-2 is omitted, the function is evaluated as though 50 were specified.
  4. The sum of the year at the time of execution and the value of argument-2 must be less than 10,000 and greater than 1699.

Returned Values

  1. Maximum-year is calculated as follows:

    (FUNCTION NUMVAL (FUNCTION CURRENT-DATE (1:4)) + argument-2)

    where argument-2 of the NUMVAL function is the same as argument-2 of the YEAR-TO-YYYY function itself.

  2. The equivalent arithmetic expression is:
    1. When the following condition is true:

      FUNCTION MOD (maximum-year, 100) > = argument-1

      The equivalent arithmetic expression is:

      (argument-1 + 100 * (FUNCTION INTEGER (maximum-year/100)))

    2. Otherwise, the equivalent arithmetic expression is:

      (argument-1 + 100 * (FUNCTION INTEGER (maximum-year/100) - 1))

Notes

  1. In the year 1995, the returned value for FUNCTION YEAR-TO-YYYY (4, 23) is 2004. In the year 2008 the returned value for FUNCTION YEAR-TO-YYYY (98, (-15)) is 1898.
  2. The YEAR-TO-YYYY function implements a sliding window algorithm. To use it for a fixed window, argument-2 can be specified as follows, where fixed-maximum-year is the maximum year in the fixed 100-year interval:

    (fixed-maximum-year - FUNCTION NUMVAL (FUNCTION CURRENT-DATE (1:4)))

    If the fixed window is 1973 through 2072, then in 2009 argument-2 has the value 63 and in 2019, the value 53.

Parent topic: Definitions of Functions


Statements

  • The ACCEPT Statement
    The ACCEPT statement causes data keyed at the console or supplied by the operating system to be made available to the program in a specified data item.
  • The ADD Statement
    The ADD statement causes two or more numeric operands to be summed and the result to be stored.
  • The ALTER Statement
    The ALTER statement modifies a predetermined sequence of operations.
  • The CALL Statement
    The CALL statement causes control to be transferred to a specific program within the run unit.
  • The CANCEL Statement
    The CANCEL statement ensures that the next time the referenced program is called it is in its initial state.
  • The CHAIN Statement
    The CHAIN statement transfers control from one object program to another in the run unit with no subsequent return of control. The effect is as though the chained program is the main program in the new run unit.
  • The CLOSE Statement
    The CLOSE statement terminates the processing of reels/units and files, with optional rewind, lock or removal where applicable.
  • The COMMIT Statement
    The COMMIT statement releases all record locks in all files held by this run unit. For COBOL systems that support the WITH...ROLLBACK clause of the SELECT statement as other than documentary, COMMIT indicates the end of the current transaction and makes the effects of that transaction permanent.
  • The COMPUTE Statement
    The COMPUTE statement assigns to one or more data items the value of an arithmetic expression.
  • The CONTINUE Statement
    The CONTINUE statement is a no operation statement, indicating that no executable statement is present.
  • The DELETE Statement
    The DELETE statement logically removes a record from a mass storage file. It can be specified only for files with relative or indexed organization.
  • The DELETE FILE Statement
    The DELETE FILE statement physically removes the specified files from the physical devices on which they reside.
  • The DISPLAY Statement
    The DISPLAY statement causes data to be transferred from specified data items to the appropriate hardware device, such as the CRT screen.
  • The DIVIDE Statement
    The DIVIDE statement divides one numeric data item into others and sets the values of data items equal to the quotient and remainder.
  • The ENTER Statement
    The ENTER statement provides a means of allowing the use of more than one language in the same program.
  • The ENTRY Statement
    The ENTRY statement establishes an alternate entry point into a called COBOL program.
  • The EVALUATE Statement
    The EVALUATE statement describes a multi-branch, multi-join structure. It can cause multiple conditions to be evaluated. The subsequent action of the runtime element depends on the results of these evaluations.
  • The EXAMINE Statement
    The EXAMINE statement replaces or counts the number of occurrences of a given character in a data item.
  • The EXEC(UTE) Statement
    The EXEC(UTE) statement is provided as a linkage mechanism to allow control to be passed to non-COBOL subsystems.
  • The EXHIBIT Statement
    The EXHIBIT statement causes an (optionally conditional) display of the literals, and/or identifiers (optionally preceded by the identifier name) specified in the statement.
  • The EXIT Statement
    The EXIT statement provides a common end point for a series of procedures.
  • The GOBACK Statement
    The GOBACK statement marks the logical end of a called program.
  • The GO TO Statement
    The GO TO statement causes control to be transferred from one part of the Procedure Division to another.
  • The IF Statement
    The IF statement causes a condition to be evaluated (see the topic Conditional Expressions in the chapter Procedure Division). The subsequent action of the runtime element depends on whether the value of the condition is true or false.
  • The INITIALIZE Statement
    The INITIALIZE statement provides the ability to set selected data items to specified values.
  • The INSPECT Statement
    The INSPECT statement provides the ability to tally (Format 1), replace (Format 2), tally and replace (Format 3) , convert (Format 4) and tally trailing (Format 5).
  • The INVOKE Statement
    The INVOKE statement causes a method to be invoked.
  • The MERGE Statement
    The MERGE statement combines two or more identically sequenced files on a set of specified keys, and during the process makes records available, in merged order, to an output procedure or to an output file.
  • The MOVE Statement
    The MOVE statement transfers data, in accordance with the rules of editing, to one or more data areas.
  • The MULTIPLY Statement
    The MULTIPLY statement causes numeric data items to be multiplied and sets the values of data items equal to the results.
  • The NEXT SENTENCE Statement
    The NEXT SENTENCE statement transfers control to the next COBOL sentence, that is, following the next period. It does not transfer control to the logically next COBOL verb as occurs with the CONTINUE verb.
  • The NOTE Statement
    The NOTE statement introduces a sentence or paragraph that will be treated as comments.
  • The ON Statement
    The ON statement allows selective execution of procedural statements on a periodic basis.
  • The OPEN Statement
    The OPEN statement initiates the processing of files. It also performs checking and/or writing of labels and other input-output operations.
  • The PERFORM Statement
    The PERFORM statement is used to transfer control explicitly to one or more procedures and to return control implicitly whenever execution of the specified procedure is complete.
  • The RAISE Statement
    The RAISE statement raises an exception.
  • The READ Statement
  • The RELEASE Statement
    The RELEASE statement transfers records to the initial phase of a SORT operation.
  • The RETURN Statement
    The RETURN statement obtains either sorted records from the final phase of a SORT operation or merged records during a MERGE operation.
  • The REWRITE Statement
    The REWRITE statement logically replaces a record existing in a disk file.
  • The ROLLBACK Statement
    The ROLLBACK statement releases all record locks in all files held by this run unit.
  • The SEARCH Statement
    The SEARCH statement is used to search a table for a table element that satisfies the specified condition and to adjust the associated index-name to indicate that table element.
  • The SERVICE Statement
    The SERVICE statement is used to establish addressability to Linkage Section items usually in a CICS program.
  • The SET Statement
    The SET statement is used to alter the status of external switches.
  • The SORT Statement
    The SORT statement creates a sort file by executing input procedures or by transferring records from another file, sorts the records in the sort file on a set of specified keys, and in the final phase of the sort operation, makes available each record from the sort file, in sorted order to some output procedures or to an output file.
  • The START Statement
    The START statement provides a basis for logical positioning within a relative or indexed file for subsequent retrieval of records. This statement is not available for files with sequential organization.
  • The STOP Statement
    The STOP statement causes a permanent or temporary suspension of the execution of the run unit.
  • The STRING Statement
    The STRING statement provides concatenation of the partial or complete contents of two or more data items into a single data item.
  • The SUBTRACT Statement
    The SUBTRACT statement is used to subtract one, or the sum of two or more, numeric data items from one or more items, and set the values of one or more items equal to the results.
  • The SYNC Statement
    The SYNC statement marks a statement block as a critical section by obtaining the mutual-exclusion lock for a given object, executing a block of statements, and then releasing the lock.
  • The TRANSFORM Statement
    The TRANSFORM statement is used to alter characters according to a transformation rule.
  • The TRY Statement
    The TRY...CATCH...FINALLY...END-TRY structure is the basis for structured exception handling. The TRY block allows you to test a section of code for exceptions that may occur during its execution. The CATCH block must specify the type of exception you wish to handle if one should occur during the execution of the TRY block. The FINALLY block allows you to execute a section of code following the TRY block, whether or not an exception occurred.
  • The UNLOCK Statement
    The UNLOCK statement releases all record locks held by the run unit on a named file.
  • The UNSTRING Statement
    The UNSTRING statement causes contiguous data in a sending field to be separated and placed into multiple receiving fields.
  • The USE Statement
    The USE statement specifies procedures for input-output error handling, that are in addition to the standard procedures provided by the input-output control system.
  • The WAIT Statement
    The WAIT statement suspends the current thread's execution until the targeted thread's execution terminates and optionally retrieves the value returned from the targeted thread's execution.
  • The WRITE Statement
    The WRITE statement releases a logical record for an output or input-output file. For sequential files it can also be used for vertical positioning of lines within a logical page.
  • The XML GENERATE Statement
    The XML GENERATE statement converts data to XML format.
  • The XML PARSE Statement
    The XML PARSE statement is used to interface with an XML parser that is part of the COBOL run-time system. The XML PARSE statement parses an XML document into its individual pieces and passes each piece, one at a time, to a user-written processing procedure.
Parent topic: Procedure Division


The ACCEPT Statement

The ACCEPT statement causes data keyed at the console or supplied by the operating system to be made available to the program in a specified data item.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

General Formats for Format 4

General Formats for Format 5

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • ACCEPTREFRESH - specifies whether the data areas associated with Screen Section data are updated from their corresponding Working-Storage Section items before an ACCEPT statement.
    • XOPEN - specifies whether the data areas associated with the Screen Section data are updated from their corresponding Working-Storage Section items before an ACCEPT statement.

Syntax Rules for Format 1

  1. The mnemonic-name in Format 1 must be associated with a function-name in the Special-Names paragraph in the Environment Division. See General Rule 14 in the topic The Special-Names Paragraph for a list of valid function-names.
  2. OSVS VSC2 MF Alternatively, function-name can itself be used instead of an associated mnemonic-name.
  3. MF XOPEN When mnemonic-name is associated with ARGUMENT-NUMBER in the Special-Names paragraph, then identifier must be an unsigned integer.
  4. MF XOPEN When mnemonic-name is associated with ARGUMENT-VALUE or ENVIRONMENT-VALUE in the Special-Names paragraph, then identifier must be an alphanumeric data item.
  5. VSC2 MF Identifier can be a USAGE DISPLAY-1 (DBCS) item or an external floating-point data item.

    ISO2002 MF Identifier can be an internal floating-point data item.

  6. MF XOPEN The EXCEPTION phrase may be specified only if FROM is specified with either ENVIRONMENT-NAME or ARGUMENT-VALUE, or with the mnemonic-names associated with them.

Syntax Rules for Format 2

  7. OSVS VSC2 MF Identifier can be of any class, category or usage, including an internal floating-point or external floating-point item.

Syntax Rules for Format 3

  8. MF No restrictions apply to the class, category or usage of the identifier. However, the actual value placed into the identifier and the validity of moving such values to the identifier are dependent on the FROM clause. See the Format 3 General Rules for more information.

Syntax Rules for Format 4

  9. MF Screen-name cannot be an item with an OCCURS clause.

Syntax Rules for Formats 4 and 5

  10. MF The LINE and COLUMN phrases can appear in any order.
  11. MF EXCEPTION and ESCAPE are equivalent.
  12. MF Identifier-4 must be a PIC 9(4) or a PIC 9(6) data item.

Syntax Rules for Format 5

  13. MF Identifier-8 must be an integer. It can be signed.
  14. MF Integer-7 can be signed.
  15. MF An ACCEPT statement whose operand is not a screen-name is treated as a Format 5 ACCEPT statement if it has an AT phrase, a FROM phrase with the CRT option, a WITH phrase, a MODE IS BLOCK phrase, or an EXCEPTION phrase; or if it has no FROM phrase but the CONSOLE option clause is specified in the Special-Names paragraph. If it has the FROM phrase with the CONSOLE option, or if it has no FROM phrase and the CONSOLE IS CRT clause is not specified in the Special-Names paragraph, it is treated as a Format 1 ACCEPT statement.
  16. MF The phrases following the identifier can be in any order.
  17. MF The SPACE-FILL, ZERO-FILL, LEFT-JUSTIFY, RIGHT-JUSTIFY, PROMPT and TRAILING-SIGN options are allowed only if the operand is an elementary item.
  18. MF Elementary data items in identifier-1 must be of USAGE DISPLAY.
  19. MF No elementary item in identifier-1 may be longer than 8191 bytes. If the MODE IS BLOCK phrase is used, the whole of identifier-1 must be no longer than 8191 bytes.

General Rules for All Formats

  1. The END-ACCEPT phrase delimits the scope of the ACCEPT statement. (See the section Explicit and Implicit Scope Terminators in the chapter Concepts of the COBOL Language.) END-ACCEPT is treated as a reserved word only if the MF(4) Compiler directive is set.

General Rules for Format 1

  2. The ACCEPT statement causes the transfer of data from the logical or physical device. This data replaces the content of the data item referenced by identifier. If the data item referenced by identifier has an explicit or implicit usage of DISPLAY then replacement is direct and without conversion, otherwise conversion into the correct format takes place.

    The size of a data transfer is determined by the device and the run-time environment (see the topic The Special-Names Paragraph for a list of function-names that can be used and your COBOL system documentation for details of devices and the limits of data transfer sizes).

    If the device is capable of transferring data of the same size as the receiving data item, the transferred data is stored in the receiving data item. If otherwise, then:

    1. If the size of the receiving data item (or the portion not yet currently occupied by transferred data) exceeds the size of the transferred data, the transferred data is stored aligned to the left in the receiving data item (or the portion not yet occupied) and additional data is requested.
    2. If the size of the transferred data exceeds the size of the receiving data item (or portion not yet occupied by transferred data), only the leftmost characters of the transferred data are stored in the receiving data item (or in the portion remaining). The remaining characters of the transferred data which do not fit into the receiving data item are ignored.

    If the FROM option is not given, it is equivalent to specifying FROM CONSOLE.

  3. MF XOPEN If the function-name COMMAND-LINE, or a mnemonic-name associated with the function-name COMMAND-LINE, is specified, the contents of a system-dependent command-line buffer are transferred to the receiving data item.
  4. MF XOPEN If the mnemonic-name associated with the function-name ARGUMENT-NUMBER is used, identifier receives the number of arguments contained in the command line. (This includes all arguments, those before the program-name, the program-name itself, and any arguments following the program-name. Hence no portability from types of program invocation is expected.)
  5. MF XOPEN When mnemonic-name is associated with ARGUMENT-VALUE, the current command-line argument is placed into identifier. The determination of which command-line argument is current is as follows:
    1. Initially, the first command-line argument is current.
    2. A DISPLAY upon a mnemonic-name associated with ARGUMENT-NUMBER sets the current command-line argument number to the value of the identifier or literal specified in the DISPLAY statement.
    3. When an ACCEPT statement from a mnemonic-name associated with ARGUMENT-NUMBER has been executed since the last execution of a DISPLAY statement upon a mnemonic-name associated with ARGUMENT-NUMBER, the current command-line argument number is incremented prior to its use in this ACCEPT statement.

    If the current command-line argument number is 0, it is intended that the program-name of the main program of the run unit will be returned. However, the effects of variations on program invocation can impact these results so that a utility or calling program can be returned instead.

    If the current command-line argument number

    XOPEN is not in the range 0 to 99 inclusive or

    exceeds the number of arguments on the command line when this ACCEPT statement is executed, imperative-statement-1, if specified, is executed.

  6. MF XOPEN If the mnemonic-name associated with the function-name ENVIRONMENT-VALUE is used then,
    1. If a previous DISPLAY with a mnemonic-name associated with an ENVIRONMENT-NAME has been performed, the value of the designated environment variable is placed into identifier.
    2. If no previous DISPLAY with a mnemonic-name associated with an ENVIRONMENT-NAME has been performed, or if the specified environment variable does not exist, the imperative statement associated with an ON EXCEPTION phrase is executed. The value in identifier is undefined in this case.
  7. MF XOPEN The effect of retrieving command-line arguments and the number of arguments in a program that is called by another program is defined as the same as if they were retrieved by the first program in the run unit.

General Rules for Format 2

  8. The ACCEPT statement causes the information requested to be transferred to the data item specified by identifier according to the rules of the MOVE statement. DATE, DAY,

    ANS85 DAY-OF-WEEK,

    and TIME are conceptual data items and, therefore, are not described in the COBOL program.

  9. DATE, without the phrase YYYYMMDD, is composed of the data elements year of the current century, month of the year, and day of the month. DATE, without the phrase YYYYMMDD, when accessed by a COBOL program, behaves as if it had been described as an unsigned elementary integer data item of usage display six digits in length, the character positions of which, numbered from left to right, are:
    Char | Contents
    1-2 | The two right-most numeric characters of the year in the Gregorian calendar.
    3-4 | Two numeric characters of the month of the year in the range 01 through 12.
    5-6 | Two numeric characters of the day of the month in the range 01 through 31.
  10. DATE, with the phrase YYYYMMDD, is composed of the data elements year in the Gregorian calendar, month of the year, and day of the month. DATE, with the phrase YYYYMMDD, when accessed by a COBOL program, behaves as if it had been described as an unsigned elementary integer data item of usage display eight digits in length, the character positions of which, numbered from left to right, are:
    Char | Contents
    1-4 | Four numeric characters of the year in the Gregorian calendar.
    5-6 | Two numeric characters of the month of the year in the range 01 through 12.
    7-8 | Two numeric characters of the day of the month in the range 01 through 31.
  11. DAY, without the phrase YYYYDDD, is composed of the data elements year of the current century and day of the year. DAY, without the phrase YYYYDDD, when accessed by a COBOL program, behaves as if it had been described as an unsigned elementary integer data item of usage display five digits in length, the character positions of which, numbered from left to right, are:
    Char | Contents
    1-2 | The two right-most numeric characters of the year in the Gregorian calendar.
    3-5 | Three numeric characters of the day of the year in the range 01 through 366.
  12. DAY, with the phrase YYYYDDD, is composed of the data elements year in the Gregorian calendar and day of the year. DAY, with the phrase YYYYDDD, when accessed by a COBOL program, behaves as if it had been described as an unsigned elementary integer data item of usage display seven digits in length, the character positions of which, numbered from left to right, are:
    Char | Contents
    1-4 | Four numeric characters of the year in the Gregorian calendar.
    5-7 | Three numeric characters of the day of the year in the range 01 through 366.
  13. ANS85 DAY-OF-WEEK is composed of a single data element whose content represents the day of the week. DAY-OF-WEEK, when accessed by a COBOL program, behaves as if it had been described in a COBOL program as an unsigned elementary numeric integer data item one digit in length. In DAY-OF-WEEK, the value 1 represents Monday, 2 represents Tuesday, ... , 7 represents Sunday.
  14. TIME is composed of the data elements: hours, minutes, seconds and hundredths of a second. TIME is based on elapsed time after midnight on a 24-hour clock basis - thus, 2:41 P.M. would be expressed as 14410000. TIME, when accessed by a COBOL program behaves as if it had been described in a COBOL program as an unsigned elementary numeric integer data item eight digits in length. The minimum value of TIME is 00000000; the maximum value of TIME is 23595999. If the hardware does not have the facility to provide fractional parts of TIME, the value is converted to the closest decimal approximation.

General Rules for Format 3

  15. MF The value returned from the ACCEPT FROM LINE NUMBER phrase is always numeric. The value is implementation-dependent.
  16. MF The FROM USER NAME option returns a user-id number on UNIX systems, or spaces on systems where such a concept is meaningless.
  17. MF The FROM ESCAPE KEY option returns the two-digit code generated by a termination key.
  18. MF The EXCEPTION STATUS item contains a three-digit numeric value that identifies the type of exception condition that has occurred during the execution of a CALL statement.

    If EXCEPTION STATUS is to be examined this should be done immediately following the CALL statement. There must be nothing between the CALL and ACCEPT FROM EXCEPTION STATUS. File I/O operations will alter the exception status value making it unpredictable.

General Rules for Format 4

  19. MF This format of the ACCEPT statement accepts screen items,which are defined in the Screen Section of the program, and allows full access to the enhanced screen handling facilities.

General Rules for Formats 4 and 5

  20. MF The order of execution of an ACCEPT statement is always:
    1. The AT phrase
    2. The BLANK phrase
    3. If either of the Compiler directives ACCEPTREFRESH or XOPEN are specified, the current contents of screen items with the USING phrase are displayed
    4. The BELL phrase
    5. The ACCEPT operation.
  21. MF The AT phrase gives the absolute address on the screen where the ACCEPT operation is to start.
  22. MF If integer-3 or identifier-4 is 4 digits long, the first two digits specify the line, the second two the column. If 6 digits long, the first three digits specify the line, while the second three specify the column.
  23. MF Certain combinations of line and column numbers have special meanings, as follows:
    1. Until the column comes within range, out of range column values are reduced by the line length and the line value is incremented.
    2. Out of range line values cause the screen to scroll up one line. The effect is the same as if the line number of the bottom line had been specified.
    3. If the line and column numbers given are both zero, the ACCEPT starts at the position following that where the preceding Format 4 or Format 5 ACCEPT operation finished. Column 1 of each line is considered to follow the last column of the previous line.
    4. If the line number is zero, but a non-zero column number is specified, the ACCEPT starts at the specified column, on the line following that where the preceding Format 4 or Format 5 ACCEPT operation finished.
    5. If the column number is zero, but a non-zero line number is specified, the ACCEPT starts on the specified line, at the column following that where the preceding Format 4 or Format 5 ACCEPT operation finished.
  24. MF Prior to the execution of this ACCEPT statement, a DISPLAY statement which specifies the same screen-name or identifier-1 as is specified in this ACCEPT statement must have been executed. There must not have been any ACCEPT or DISPLAY statement executed since then.
  25. MF If the ON EXCEPTION phrase is specified, imperative-statement-1 is executed if the ACCEPT operation finishes with anything other than a normal termination. If the NOT ON EXCEPTION phrase is specified, imperative-statement-2 is executed if the ACCEPT operation terminates normally. (See the rules for the CRT STATUS clause in the topic The Special-Names Paragraph for possible types of termination.)

General Rules for Format 5

  26. MF The ACCEPT operation starts at line 1, column 1 if no AT phrase is specified.
  27. MF If identifier is a group item and no MODE IS BLOCK phrase exists, then those elementary subordinate items which have names other than FILLER are accepted. They are positioned on the screen in the order their descriptions appear in the Data Division and are separated by the lengths of the FILLER items in the group. For this purpose, the first position on a line is regarded as immediately following the last position on the previous line. The items are accepted in the same order.

    Unless otherwise specified in the CURSOR IS clause (see the rules for the CURSOR IS clause clause in the topic The Special-Names Paragraph), the cursor is initially positioned at the start of the first item. As the ACCEPT operation into each item is terminated, the cursor moves to the start of the next item.

  28. MF If identifier-1 is a group item that has a variable-occurrence data item subordinate to it, the ACCEPT statement acts as if the MODE IS BLOCK clause were specified.
  29. MF If identifier-1 is a group item that has a variable-occurrence data item subordinate to it, the ACCEPT statement acts as if the MODE IS BLOCK clause were specified.
  30. MF The MODE IS BLOCK phrase indicates that the identifier is to be treated as an elementary item. Thus, even if it is a group item it is displayed as one item.
  31. MF The effect of specifying the PROMPT option is as described in the topic The PROMPT Clause.
  32. MF If the PROMPT option is not specified, no character is output to the screen to mark empty character-positions; those character-positions into which the operator does not enter data produce spaces in the data item.
  33. MF The WITH phrase allows you to specify certain options available during the operation. (See the topic Screen Section Entry Skeleton for descriptions of these options.)

    In addition to the options available as screen description clauses, the following options can be used in the WITH phrase; SPACE-FILL, ZERO-FILL, LEFT-JUSTIFY, RIGHT-JUSTIFY TRAILING-SIGN and UPDATE. ZERO-FILL appears in this list and as a screen description clause because it has two different uses. Its second use is documented later in this chapter.

    A configuration option is available which allows the entry of data into numeric and numeric edited screen fields in free format mode. In COBOL, nonedited numeric data items are intended for holding data in an internal form; however, this format enables such data items to appear on the screen. See your COBOL system documentation on user interfaces for more details. If free format mode is in effect, the data appears automatically reformatted as follows:

    • With the virtual decimal point represented by a period
    • With the sign represented by a sign character ("-" for minus; space for plus) which appears immediately before the leftmost digit
    • With zero suppression in all integer character positions, except the least significant
    • With left justification.

    The SPACE-FILL, ZERO-FILL, LEFT-JUSTIFY, RIGHT-JUSTIFY and TRAILING-SIGN options amend this format.

  34. MF The SPACE-FILL option causes data in free format nonedited numeric data items to appear on the screen with zero-suppression in all integer character positions. This option affects only free format, nonedited numeric data items. This takes effect when initial data in the data item is displayed and again when the ACCEPT operation into the data item is terminated. Any leading sign is displayed in the rightmost space.
  35. MF The ZERO-FILL option causes data in free format nonedited numeric data items to appear on the screen with no zero-suppression. This takes effect when initial data in the data item is displayed and again when the ACCEPT operation into the data item is terminated. (See the topic The ZERO-FILL Clause for this option's effect when used with alphabetic or alphanumeric data items.)
  36. MF The LEFT-JUSTIFY option is documentary only.
  37. MF The RIGHT-JUSTIFY option causes operator-keyed characters to be moved on the screen to the rightmost character positions of the field. This option affects only free format nonedited numeric data items. This takes effect upon display of the initial data (the current contents displayed) in the data item and also upon termination of the ACCEPT operation.
  38. MF The TRAILING-SIGN option causes the operational sign to appear in the rightmost character position of the field. This takes effect upon display of initial data in the data item and also upon termination of the ACCEPT operation. This option affects only signed, nonedited numeric data items which are in free format mode.
  39. MF The UPDATE option causes the current contents (initial data) of the data item to be displayed before the operator is prompted to key in new input. If the operator does not key in any new data, the initial data is then treated as though it were operator-keyed. If the UPDATE option is not specified, the display of initial data is a configuration option. (See your COBOL system documentation on user interfaces for details of configuration options.)
  40. MF The UPPER option forces input into upper case.
  41. MF The LOWER option forces input into lower case.
  42. MF If REDEFINES is used with identifier-1, the first description of the redefined data area is used and subsequent descriptions are ignored. If OCCURS or nested OCCURS are used the repeated data item is expanded into the full number of times it occurs, so that one definition is repeated for many fields.
  43. MF If identifier-8 or integer-7 has a negative value, this represents a request that no time-out "exception" should occur no matter how long there is between/before key-strokes.
  44. MF If identifier-8 or integer-7 is zero, no timeout occurs if characters are waiting (when the ACCEPT is processed). However, if no characters are waiting, then a timeout occurs immediately.
  45. MF The ON EXCEPTION clause, if present, will be executed when a timeout occurs and a TIMEOUT clause is specified. The NOT ON EXCEPTION clause, if present, will be executed when a TIMEOUT clause is specified but no timeout (or other exception) occurs.
  46. MF If a timeout exception occurs, then the contents of any ACCEPT resultant-field are defined as follows:
    1. Any field which has been partially modified contains any information which has already been received.
    2. Fields which have "FULL" or "REQUIRED" attributes or any other attribute which would normally impact partial field input, are not required to meet those attributes when a partial field entry has occurred when a timeout exception occurs.
    3. The rules listed above apply whether or not the timeout clock is reset upon each keystroke.
  47. MF If at run time a positive timeout interval greater than 2,147,483,647 hundredths of a second is detected the timeout value is reset to 2,147,483,647 hundredths of a second (which is approximately eight months).
  48. MF The TIMEOUT value specifies the number of seconds (or tenths of a second) after the ACCEPT statement begins processing until a timeout exception occurs. An ADISCF configuration option controls whether or not the timeout clock is reset each time a new keyboard action is detected. An application which wants some ACCEPT statements to be handled with a RESET and some without, can make specific calls to the ADIS run-time interface before or after the ACCEPT statements that need changes from the default. For example when ADIS was configured not to do resets, if a program had:
     ACCEPT INPUT-FIELD TIME-OUT AFTER +10

    a timeout would occur after 10 seconds had elapsed from the beginning of the ACCEPT, even if some characters were entered after 5 seconds into the ACCEPT processing.

    If, on the other hand, ADIS were configured to do resets, if a program had the same code given above, then each time a new character were entered, the TIMEOUT clock would be reset to zero.

  49. MF If a timeout exception occurs and no ON EXCEPTION phrase is specified, the CRT Status keys (if specified) are updated, the application continues to the next logical phrase, and the contents of the ACCEPT receiving field are as defined above. (The above is true whether or not a NOT ON EXCEPTION phrase is specified.)
  50. MF All references to (NOT) ON EXCEPTION phrases also apply to (NOT) ON ESCAPE phrases.

General Rules for Formats 1 and 5

  51. MF For alphanumeric data items, the size of the field that is accepted from the screen during an ACCEPT statement is exactly the same size as the target field. Therefore, if you want data to appear at the right hand side of a field, you must enter it there.
Parent topic: Statements
Related concepts
ACCEPT FROM CENTURY-DATE and FROM CENTURY-DAY
Related reference
ACCEPT Fields at the Edge of the Screen
Display of Input Data in Concealed ACCEPT Fields
ACCEPT Statement
Related information
The Special-Names Paragraph
Explicit and Implicit Scope Terminators
The PROMPT Clause
Screen Section Entry Skeleton
The ZERO-FILL Clause


The ADD Statement

The ADD statement causes two or more numeric operands to be summed and the result to be stored.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

Syntax Rules for All Formats

  1. In Formats 1 and 2, each identifier must refer to an elementary numeric item, except that in Format 2 each identifier following the word GIVING must refer to either an elementary numeric item or an elementary numeric edited item. In Format 3, each identifier must refer to a group item.
  2. Each literal must be a numeric literal.
  3. The composite of operands is determined as follows (see the topic Arithmetic Statements in the chapter Procedure Division):
    1. In Format 1, by using all of the operands in a given statement.
    2. In Format 2, by using all of the operands in a given statement excluding the data items that follow the word GIVING.
    3. In Format 3, separately for each corresponding pair of data items.
  4. In Format 3, CORR is an abbreviation for CORRESPONDING.
  5. OSVS VSC2 MF Floating-point literals and floating-point data items can be used anywhere a numeric data item or literal can be specified.

General Rules for All Formats

  1. See the topics The ROUNDED Phrase, The ON SIZE ERROR Phrase, The CORRESPONDING Phrase, Arithmetic Statements, Overlapping Operands and Multiple Results in Arithmetic Statements in the chapter Procedure Division; the section Explicit and Implicit Scope Terminators in the chapter Concepts of the COBOL Language, and the section Delimited Scope Statements in the chapter Language Fundamentals.
  2. If Format 1 is used, the values of the operands preceding the word TO are added together, then this sum is added to the current value of identifier-2 storing the result immediately into identifier-2, and repeating this process respectively for each successive operand following the word TO in left-to-right order.
  3. If Format 2 is used, the value of the operands preceding the word GIVING are added together, then the sum is stored as the new value of each data item referenced by identifier-3, the resultant identifier.
  4. If Format 3 is used, data items in identifier-1 are added to and stored in corresponding data items in identifier-2.
  5. MF Your COBOL system ensures that enough places are carried so as not to lose any significant digits during execution.
Parent topic: Statements
Related information
Arithmetic Statements
The ON SIZE ERROR Phrase
The CORRESPONDING Phrase
The ROUNDED Phrase
Overlapping Operands
Multiple Results in Arithmetic Statements
Explicit and Implicit Scope Terminators
Delimited Scope Statements


The ALTER Statement

The ALTER statement modifies a predetermined sequence of operations.

ANS85 The ALTER statement is classed as an obsolete element in the ANSI'85 standard and is scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects in this COBOL implementation fully support this syntax. The FLAGSTD Compiler directive can be used to detect all occurrences of this syntax.

XOPEN Although it is a part of the standard COBOL definition, this verb is explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

General Format

Syntax Rules

  1. Each procedure-name-1, procedure-name-3, ..., is the name of a paragraph that contains a single sentence consisting of a GO TO statement without the DEPENDING phrase.
  2. Each procedure-name-2, procedure-name-4, ..., is the name of a paragraph or section in the Procedure Division.
  3. The ALTER statement is not supported in class programs when compiling to managed code.

General Rules

  1. Execution of the ALTER statement modifies the GO TO statement in the paragraph named procedure-name-1, procedure-name-3, ..., so that subsequent executions of the modified GO TO statements cause transfer of control to procedure-name-2, procedure-name-4, ..., respectively. Modified GO TO statements in independent segments can, under some circumstances, be returned to their initial states (see the section Independent Segments in the topic Segmentation.
  2. A GO TO statement in a section whose segment-number is greater than or equal to 50 must not be referred to by an ALTER statement in a section with a different segment-number.

    All other uses of the ALTER statement are valid and are performed even if procedure-name-1, procedure-name-3 is in an overlayable fixed segment.

Parent topic: Statements
Related information
Independent Segments


The CALL Statement

The CALL statement causes control to be transferred to a specific program within the run unit.

ISO2002 MF You can call the program indirectly, by address. Data, pointers to data, and pointers to procedures can be passed as parameters to the called program, and returned by it. Parameter passing conventions can be controlled in order to allow the called program to be written in languages other than COBOL, using different conventions.

ISO2002 MF OS390 A called COBOL program can recursively call itself when it has the recursive attribute.

General Formats for Format 1

General Formats for Format 2 (program-prototype)

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • ALIGN - specifies the memory boundaries on which data items of 01-level or 77-level are aligned.
    • CASE - determines whether upper-case and lower-case letters are considered equivalent.
    • DEFAULTCALLS - controls which calling convention is the default.
    • FOLD-CALL-NAME - determines whether you are guaranteed to find a called subprogram when the calling and called programs do not use the same upper-case and lower-case letters for the program-name.
    • IBMCOMP - turns on word-storage mode.
    • MAPNAME - impacts the handling of non-alphabetic characters in the program-name.

Syntax Rules for All Formats

  1. * Identifier-1 must be defined as an alphanumeric

    ISO2002 MF or national

    data item.

  2. * Literal-1

    MF , literal-2

    VSC2 MF , and literal-3

    cannot be a figurative constant and must be an alphanumeric literal

    ISO2002 MF or a national literal.

  3. * Identifier-2 and identifier-4 must be defined as data items in the File Section, Working-Storage Section,

    ISO2002 MF Local-Storage Section

    or Linkage Section, and must be a level 01 data item, or a level 77 data item

    ANS85 , or an elementary item

    ISO2002 MF , or any group item.

    MF Identifier-2 must not be defined in the Working-Storage or File Section of a factory or an instance object.

  4. MF * Neither identifier-5, identifier-6, identifier-7, nor identifier-8 can be a function-identifier.
  5. MF * GIVING and RETURNING are equivalent.
  6. MF Identifier-9 must be defined as a data item in the Linkage Section with a level number of 01 or 77.
  7. MF *Identifier-2, identifier-4, identifier-6 and identifier-8 must not be described with the ANY LENGTH clause.

Syntax Rules for Format 1

  8. MF Mnemonic-name is necessary only if the object program that is to be invoked expects a calling convention other than that used as the default by your COBOL system. Typically, the default COBOL calling convention is consistent with that used by a significant implementation of a non-COBOL language for the run-time environment.

    Mnemonic-name must be defined in the Special-Names paragraph. See the topic The Special-Names Paragraph for details of how to do this and your COBOL system documentation on interfacing for details of which calling conventions are supported in your run-time environment.

  9. MF * Integer-1 may be signed.
  10. VSC2 MF * Identifier-3 must be defined as a data item in the Linkage Section

    MF , Local-Storage Section or Working-Storage Section,

    and must be a level 01 data item, a level 77 data item

    MF , or other level data item.

  11. MF If the CALL statement specifies literal-1 (but not if it specifies identifier-1 or procedure-pointer-1), and if a call prototype (a program with the EXTERNAL clause in its Program-ID paragraph) has been included in the current compilation unit with a name that matches literal-1, then the following items are validated during syntax checking:
    • The number of parameters required
    • The type of parameters
    • The call convention
  12. ISO2002 * Identifier-2 must not be a data item of class object or pointer.

Syntax Rules for Format 2

  13. ISO2002 MF The NESTED phrase must be specified only in a program definition.
  14. ISO2002 MF If the NESTED phrase is specified, literal-1 must be specified. Literal-1 must be the same as the program-name specified in the Program-ID paragraph of a common program as specified in the topic Conventions for Program-names in the chapter Concepts of the COBOL Language or of a program that is directly contained in the calling program.
  15. ISO2002 MF Program-prototype-name-1 must be specified in a program-specifier in the Repository paragraph.
  16. ISO2002 MF If the BY CONTENT or BY REFERENCE phrase is specified or implied for an argument, the BY REFERENCE phrase must be specified for the corresponding formal parameter in the PROCEDURE DIVISION header.
  17. ISO2002 MF BY CONTENT must not be omitted when identifier-4 is an identifier that is permitted as a receiving operand, except that BY CONTENT may be omitted when identifier-4 is an object property.
  18. ISO2002 MF If the BY VALUE phrase is specified for an argument, the BY VALUE phrase must be specified for the corresponding formal parameter in the PROCEDURE DIVISION header.
  19. ISO2002 MF Identifier-6 must be of class numeric, object, or pointer.
  20. ISO2002 MF Literal-4 must be a numeric literal.
  21. ISO2002 MF If the OMITTED phrase is specified, the OPTIONAL phrase must be specified for the corresponding formal parameter in the PROCEDURE DIVISION header.
  22. ISO2002 MF The rules for conformance specified in the topic Conformance for Parameters and Returning Items in the chapter Procedure Division apply.

General Rules for All Formats

General rules marked with an asterisk (*) are common to the CALL statement and to the CHAIN statement. In these rules, where "CALL or CHAIN statement" are specified, you should read "CALL statement" or "CHAIN statement" when applying the rules to the CALL statement or the CHAIN statement respectively.

  1. Literal-1 or the content of the data item referenced by identifier-1 is the name of the called program

    MF or called procedure.

    The program in which the CALL statement appears is the calling program. If the program being called is a COBOL program, literal-1 or the content of the data item referenced by identifier-1 must contain the program-name contained in the Program-ID paragraph of the called program (see the topic The Program-ID Paragraph, particularly in regard to case sensitivity),

    MF or the entry-name contained in the ENTRY statement of a called program that must have been called previously and not canceled since. Alternatively, the name of the called program may be a name which identifies a file that contains executable program code for the called program. The result of specifying different names that identify the same file in two CALL statements or a CALL and a CANCEL statement are operating-system specific. See your COBOL system documentation for details of how your system matches the given name to previously called programs, program filenames or programs held in library files.

    MF If the program being called is not a COBOL program, the rules for the formation of the program or procedure name are given in the COBOL system documentation on interfacing.

  2. MF The content of the data item referenced by procedure-pointer-1 is the address of the called program that must be already resident in memory. If the program being called is a COBOL program, the address of the called program must originally have been derived from a SET statement with an ENTRY phrase and no CANCEL statement for that program must have been subsequently executed. If the program being called is not a COBOL program then the address of the called program must originally have been derived from a CALL to a non-COBOL program or procedure. It is an error to attempt to CALL a program with an address that is equal to NULL.
  3. If, when a CALL statement is executed, the program specified by the CALL statement is made available for execution, control is transferred to the called program. After control is returned from the called program, the ON OVERFLOW

    ANS85 or ON EXCEPTION

    phrase is ignored and control is passed to the end of the CALL statement

    ANS85 or, if the NOT ON EXCEPTION phrase is specified control is passed to imperative-statement-2. If control is passed to imperative-statement-2, execution continues according to the rules for each statement specified in imperative-statement-2. If a procedure branching or conditional statement which causes explicit transfer of control is executed, control is transferred in accordance with the rules for that statement; otherwise, upon completion of the execution of imperative-statement-2, control is transferred to the end of the CALL statement.

  4. When a CALL statement is executed, the program specified by the CALL statement is made available if it is already resident in memory. If it is not already resident in memory then an attempt may be made to dynamically load the program (see your COBOL system documentation on interfacing). If a program with the specified name can be dynamically located and a sufficient, contiguous area of free memory is available, then the program is dynamically loaded and made available for execution.

    If the program specified by the CALL is not resident in memory, is not available for dynamic loading or is available but is too large for the available memory, then the program cannot be made available at that time and one of the following two actions occurs:

    1. If the ON OVERFLOW

      ANS85 or ON EXCEPTION

      phrase is specified in the CALL statement, control is transferred to imperative-statement-1. Execution then continues according to the rules for each statement specified in imperative-statement-1. If a procedure branching or conditional statement which causes explicit transfer of control is executed, control is transferred in accordance with the rules for that statement; otherwise, upon completion of execution of imperative-statement-1, control is transferred to the end of the CALL statement

      ANS85 and the NOT ON EXCEPTION phrase, if specified, is ignored.

    2. ANS85 If the ON OVERFLOW or ON EXCEPTION phrase is not specified in the CALL statement, the NOT ON EXCEPTION phrase, if specified, is ignored.

      MF Program execution stops, without an implicit CLOSE statement for any file that is in open mode in the run unit, and a run time error is displayed.

  5. ANS85 Two or more COBOL programs in the run unit can have the same program-name, and the reference in a CALL statement to such a program-name is resolved by using the scope-of-names conventions for program-names. See the topic Conventions for Program-names in the chapter Concepts of the COBOL Language. For example, when two programs in the run unit have the same name as that specified in a CALL statement:
    1. One of those two programs must also be contained directly or indirectly either within the separate program which includes the CALL statement or within the separate program which itself directly or indirectly contains the program which includes that CALL statement, and
    2. The other one of those two programs must be a different separate program.

    The mechanism used in this example is as follows:

    1. If one of the two programs having the same name as that specified in the CALL statement is directly contained within the program which includes that CALL statement, that program is called.
    2. If one of the two programs having the same name as that specified in the CALL statement possesses the common attribute and is directly contained within another program which directly or indirectly contains the program which includes the CALL statement, that common program is called unless the calling program is contained in that common program.
    3. Otherwise, the separate program is called.
  6. If the called program is a COBOL program and does not possess the initial attribute, it and each COBOL program directly or indirectly contained within it, is in its initial state the first time it is called within a run unit and the first time it is called after a CANCEL of the called program.

    If the called program is not COBOL, it is only in its initial state the first time it is called within a run unit. A CANCEL of such a program has no effect.

    On all other entries into the called program, the state of the program and each program directly or indirectly contained within it remains unchanged from its state when last exited. Some implementations of languages other than COBOL may provide alternative semantics and, if available, these are detailed in your COBOL system documentation on interfacing.

  7. ANS85 If the called program possesses the intial attribute, it and each program directly or indirectly contained within it, is placed into its initial state every time the called program is called in a run unit. Whether a called program is in the initial state or last-used state is sensitive to the DYNAM Compiler directive.
  8. ANS85 Files associated with a called program's internal file connectors are not in the open mode when the program is in an initial state. See the topicIntial State Of A Program earlier in this chapter. On all other entries into the called program, the states and positioning of all such files are the same as when the called program was last exited.
  9. ANS85 The process of calling a program or exiting from a called program does not alter the status or positioning of a file associated with any external file connector.
  10. If the program being called is a COBOL program, the USING phrase is included in the CALL statement only if there is a USING phrase in the PROCEDURE DIVISION header

    OSVS VSC2 MF or ENTRY statement

    of the called program, in which case the number of operands in each USING phrase must be identical.

    MF The number of operands need not be identical.

  11. MF If the program being called is not a COBOL program, the USING phrase is included in the CALL statement only if one or more parameters are declared for the called program, in which case the number of operands in the USING phrase must be identical to the number of parameters in the called program. (Some implementations of languages other than COBOL may allow the number of operands to be other than identical.) The COBOL language places no restrictions on the alignment of the addresses of data items, whereas non-COBOL languages typically do make assumptions about addresses and will fail in some way if a misaligned data item is referenced. Alignment can be achieved by one or more of the following actions:
    • Modifying group items to include additional filler items
    • Ensuring operands in the USING phrase are level 01 or level 77 data items in conjunction with the ALIGN Compiler directive or
    • Use of the SYNCHRONIZED clause in conjunction with the IBMCOMP Compiler directive.
  12. * The sequence of appearance of the operands in the USING phrase of the CALL

    MF or CHAIN

    statement and in the corresponding USING phrase in the called program's PROCEDURE DIVISION header

    MF or ENTRY statement or parameter list if the called program is not COBOL

    determines the correspondence between the data names used by the calling and called programs. This correspondence is positional and not by name equivalence; the first operand in the CALL

    MF or CHAIN

    statement's USING phrase corresponds to the first operand in the called program's USING phrase or parameter list, the second to the second, etc.

    MF If the correspondence cannot be completed because the numbers of operands are different, then if the remaining unmatched operands are in the CALL or CHAIN statement they are ignored and if they are in the PROCEDURE DIVISION header or ENTRY statement or parameter list then they must not be referenced within the called program. The positional correspondence may vary depending on the calling conventions implied by mnemonic-name.

    In the case of index-name, no such correspondence is established. Index-names in the called and calling programs always refer to separate indices.

  13. ANS85 * The values of the parameters referenced in the USING phrase of the CALL statement are made available to the called program at the time the CALL statement is executed.
  14. * If the BY REFERENCE identifier-2 phrase is

    ANS85 either specified or

    implied for a parameter, the program operates as if the corresponding data item in the called program occupies the same storage area as the data item in the calling program. The description of the data item in the called program must describe the same number of character positions as described by the description of the corresponding data item in the calling program.

    VSC2 MF If the BY REFERENCE ADDRESS OF phrase is specified or implied then the program operates as if an additional data item had been declared with USAGE POINTER and that data item passed BY REFERENCE with a value acquired by a SET data item TO ADDRESS OF identifier-3 statement.

    VSC2 MF If identifier-3 is in the Linkage Section and has a level number other than 01 or 77 or is in the Working-Storage Section, this is equivalent to passing the item BY CONTENT; the address of identifier-3 cannot be modified by the called subprogram.

    MF If the BY REFERENCE literal-2 phrase is specified or implied then the object program processes literal-2 as described for literal-3.

  15. MF XOPEN * If the BY CONTENT phrase is specified or implied for a parameter, the called program cannot change the value of this parameter as referenced in the CALL statement's USING phrase, though the called program can change the value of the data item referenced by the corresponding data-name in the called program's PROCEDURE DIVISION header. The data description of each parameter in the BY CONTENT phrase of the CALL statement must be the same, meaning no conversion or extension or truncation, as the data description of the corresponding parameter in the USING phrase of the PROCEDURE DIVISION header.

    MF If the BY CONTENT phrase is specified or implied for a parameter, the object program operates as if an additional data item had been declared and this additional data item used as the parameter in a BY REFERENCE phrase. If identifier-4 is specified, then both the implied data description of the additional data item and its contents are identical to that of identifier-4. If literal-3 is specified, then the implied data description of the additional item is equivalent to an alphanumeric data item with the same size as literal-3 and with its contents set to the value of literal-3. If LENGTH OF identifier-5 is specified, then the data description of the additional item is equivalent to PIC S9(n) USAGE BINARY, where the value of n is at least 9 and defines a data item that is large enough to hold the maximum length of a data item in the COBOL system. The contents of the additional data item are set to the number of bytes of storage allocated to identifier-5.

  16. MF COB370 *If the BY VALUE phrase is specified or implied for a parameter, the called program cannot change the value of this parameter as referenced in the CALL statement's USING phrase, though the called program can change the value of the data item referenced by the corresponding data-name in the called program's PROCEDURE DIVISION header. The object program operates, conceptually, as if an additional data item had been declared in a system area (typically the stack), available to non-COBOL languages for passing parameters and that this additional data item occupies the same storage area as the data item in the called program.

    If identifier-6 is specified and is BINARY, COMP-4, COMP-5 or COMP-X, then the data description of the additional data item is identical to that of identifier-6, except its usage is COMP-5. The contents of the additional data item are identical to the COMP-5 representation of the contents of identifier-6. This conversion and representation facilitates calling non-COBOL programs.

    Otherwise, if identifier-6 is specified then the implied data description of the additional data item and its contents are identical to that of identifier-6.

    If integer-1 is specified, then the data description of the additional item is equivalent to a signed numeric item USAGE COMP-5 that occupies the number of bytes of storage indicated by the value of integer-2, if specified, or the size of the system area otherwise (typically the size of a POINTER on the system).

    If LENGTH OF identifier-7 is specified, then the data description of the additional item is equivalent to PIC S9(n) USAGE COMP-5, where the value of n is at least 9 and defines a data item that is large enough to hold the maximum length of a data item in the COBOL system. The contents of the additional data item are set to the number of bytes of storage allocated to identifier-7.

    If the program being called is a COBOL program, each parameter in the BY VALUE phrase of the CALL statement must have a corresponding parameter declared in the USING phrase of the PROCEDURE DIVISION header that also has the BY VALUE phrase specified or implied.

    The additional data item generated as a result of the CALL statement, described above, is related to this corresponding parameter in the called program, as follows.

    If the additional data item was subject to conversion from BINARY, COMP-4, COMP-5 or COMP-X to COMP-5, then the data description of the corresponding parameter in the called program must be identical to that of the data description of the additional data item with the exception that the corresponding parameter's USAGE can be any of BINARY, COMP-4, COMP-5 or COMP-X. On entry to the called COBOL program, a conversion from the USAGE COMP-5 of the additional data item to the USAGE of the corresponding parameter in the called program is performed.

    If the additional data item was not subject to conversion to COMP-5, the data description of each parameter in the called program must be the same as the corresponding additional data item. This means there is no conversion or extension or truncation, of the additional data item to match the corresponding parameter in the called program.

    If the program being called is not COBOL, the size of the additional data item should not exceed the maximum size of the system area (typically the size of a POINTER on the system); otherwise the system might become catastrophically corrupt.

  17. MF A called program can pass data to the calling program either by using a parameter declared in the USING phrase of the calling program or by means of a returned value. A called program returns a value by means of an EXIT GIVING or GOBACK GIVING statement. As control is returned from the called program to the calling program, the returned value is held in a system area generally available for non-COBOL programs to return a value.

    The size of the system area (typically the size of a POINTER on the system) is determined outside the COBOL system and limits the maximum value the return value can take, but the return value might not utilize the full size of the system area. The returned value is available to the calling program after control is returned, either implicitly in the special register RETURN-CODE or explicitly in the data item specified in the GIVING phrase.

  18. MF If the GIVING phrase is not specified and the calling convention specifies updating the RETURN-CODE special register (see the topic The Special-Names Paragraph) then the object program operates as if the system area were declared as a COBOL numeric data item with USAGE COMP-5 and the same size as the system area and as if a MOVE statement had been executed with the system area as the sending item and the RETURN-CODE special register as the receiving item.
  19. MF If the GIVING INTO phrase is specified in the calling program, identifier-8 must describe the same number of character positions as is required to hold the return value in the system area and must be of the type and usage that is implied for the returned value by the manner in which the value was returned from the called program. When control returns to the calling program, identifier-8 contains the return value.
  20. MF If the GIVING ADDRESS OF phrase is specified in the calling program, the called program must return a value with explicit or implicit USAGE POINTER. The object program operates as if the system area were declared as a COBOL data item with USAGE POINTER and as if a SET statement had been executed with the system area as the first operand and TO ADDRESS OF identifier-9 as the second operand.
  21. MF It is an error to specify the GIVING phrase for a called program that does not return a value.
  22. Called programs can contain CALL statements. However, a called program may not execute a CALL that directly or indirectly calls the calling program,

    ISO2002 MF OS390 unless that calling program has the recursive attribute.

  23. If a CALL statement is executed within the range of a declarative, that CALL statement cannot directly or indirectly reference any called program to which control has been transferred and which has not completed execution.
  24. ANS85 The END-CALL phrase delimits the scope of the CALL statement.
  25. VSC2 MF Any values with implicit or explicit USAGE POINTER

    MF or USAGE PROCEDURE-POINTER

    that were originally derived from the address of a data item

    MF or procedure

    that is contained within a called program become invalid and must not be used after a CANCEL statement that references that called program is executed.

  26. MF The OMITTED phrase is used to pass unused parameters to a subprogram without having to declare a dummy data item.
  27. MF The OMITTED parameter is a BY REFERENCE parameter, equivalent to passing a null address to the calling subprogram. It is identical to BY VALUE 0 but is subject to the type checking of call prototypes as a BY REFERENCE parameter.
  28. MF If BY REFERENCE does not immediately precede OMITTED, subsequent parameters are passed by the convention previously in force and the omitted parameter is treated as if the program had specified BY VALUE 0.

General Rules for Format 1

  29. MF Mnemonic-name identifies the calling convention that this program uses when invoking the called program. If the calling convention assumed by the called program is different to that implied by mnemonic-name, then the COBOL system may become corrupt.
  30. MF The run unit remains unaware of whether a called program is a COBOL program or a non-COBOL program or procedure until the called program has been located, prior to being made available for execution. The form of the program-name cannot be used, in general, to determine whether the program is a COBOL program or not. It is an error for a COBOL program and a non-COBOL program or for two non-COBOL programs to have the same program-name.
  31. ANS85 * The BY CONTENT, BY REFERENCE

    MF COB370 and BY VALUE

    phrases are transitive across the parameters which follow them until another BY CONTENT, BY REFERENCE

    MF COB370 or BY VALUE

    phrase is encountered.

    If no BY CONTENT, BY REFERENCE

    MF COB370 or BY VALUE

    phrase is specified prior to the first parameter, the BY REFERENCE phrase is assumed.

General Rules for Format 2

  32. ISO2002 MF If none of identifier-1, literal-1 or procedure-pointer-1 is specified, program-prototype-name-1 determines the externalized program-name of the program being called, according to the rules specified in the topic The Repository Paragraph.
  33. ISO2002 MF If the NESTED phrase is specified, the common or contained program that has literal-1 specified in the Program-ID paragraph is used to determine the characteristics of the called program.
  34. ISO2002 MF If the NESTED phrase is not specified, program-prototype-name-1 is used to determine the characteristics of the called program.
  35. An argument that consists merely of a single identifier or literal is regarded as an identifier or literal rather than an arithmetic expression.
  36. ISO2002 MF If an argument is specified without any of the keywords BY REFERENCE, BY CONTENT, or BY VALUE, the manner used for passing this argument is determined as follows:
    1. When the BY REFERENCE phrase is specified or implied for the corresponding formal parameter:
      1. If the argument meets the requirements of syntax rule 3, BY REFERENCE is assumed.
      2. If the argument does not meet the requirements of syntax rule 3, BY CONTENT is assumed.
    2. When the BY VALUE phrase is specified or implied for the corresponding formal parameter, BY VALUE is assumed.
  37. ISO2002 MF Control is transferred to the called program in a manner consistent with the entry convention specified for the program.
  38. ISO2002 MF If an OMITTED phrase is specified or a trailing argument is omitted, the omitted-argument condition for that parameter evaluates to true in the called program. (See the topic The Omitted-argument Condition in the chapter Procedure Division.)
  39. ISO2002 MF If a parameter for which the omitted-argument condition is true is referenced in a called program, except as an argument or in the omitted-argument condition, you will get runtime error 203.

Example

  1. An example of using procedure-pointer in a CALL statement is provided in section Calling and Setting a Procedure-Pointer.
Parent topic: Statements
Related concepts
C$DARG
C$NARG
Related information
The Special-Names Paragraph
Conventions for Program-names
Conformance for Parameters and Returning Items
The Program-ID Paragraph
The Repository Paragraph
The Omitted-argument Condition
Calling and Setting a Procedure-Pointer


The CANCEL Statement

The CANCEL statement ensures that the next time the referenced program is called it is in its initial state.

General Format

Directives:

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • DYNAM - NODYNAM causes CANCEL statements to be ignored.

Syntax Rules

  1. Literal-1 must be a nonnumeric literal.
  2. Identifier-1 must reference an alphanumeric data item.

General Rules

  1. Literal-1 or the content of the data item referenced by identifier-1 identifies the name of the program to be canceled. The name must contain the program-name contained in the Program-ID paragraph of the program to be canceled (see the section The Program-ID Paragraph in the chapter Identification Division, particularly in regard to case sensitivity). Alternatively, the name may identify a file that contains executable program code for the program to be canceled. The results of specifying different names that identify the same file in a CANCEL statement are operating-system specific. See your COBOL system documentation for details of how your system matches the given name to previously called programs, program filenames or programs held in library files.

    If the name contains the entry-name contained in an ENTRY statement, the results are undefined.

  2. Subsequent to the execution of an explicit or implicit CANCEL statement, the program referred to therein ceases to have any logical relationship to the run unit in which the CANCEL statement appears. If the program referenced by a successfully executed explicit or implicit CANCEL statement in a run unit is subsequently called in that run unit, that program is in its initial state. See the topic State of a Function, Method or Program in the chapter Language Fundamentals.
  3. A program named in a CANCEL statement in another program must be callable by that other program. See the topic Scope of Names in the chapter Concepts of the COBOL Language and the section The CALL Statement.
  4. ANS85 When an explicit or implicit CANCEL statement is executed, all programs contained in the program referenced by the CANCEL statement are also canceled. The result is the same as if a valid CANCEL statement were executed for each contained program in the reverse order in which the programs appear in the separate program.
  5. A program named in the CANCEL statement must not refer directly or indirectly to any program that has been called and has not yet executed an EXIT PROGRAM

    OSVS VSC2 MF or GOBACK

    statement.

  6. A logical relationship to a canceled program is established only by execution of a subsequent CALL statement naming that program.
  7. A called program is canceled either by being referred to as the operand of a CANCEL statement, by the termination of the run unit of which the program is a member,

    ANS85 or by execution of an EXIT PROGRAM statement in a called program that possesses the initial attribute.

  8. No action is taken when an explicit or implicit CANCEL statement is executed naming a program that has not been called in this run unit, has been called and is at present canceled or is a non-COBOL program. Control is transferred to the next executable statement following the CANCEL statement.
  9. ANS85 The contents of data items in external data records described by a program are not changed when that program is canceled.
  10. ANS85 During execution of an explicit or implicit CANCEL statement, an implicit CLOSE statement without any optional phrases is executed for each file in the open mode that is associated with an internal file connector in the program named in the CANCEL statement. Any USE procedures associated with any of these files are not executed.
  11. The CANCEL statement determines whether or not a subprogram is re-entered in initial or last-used state. It does not necessarily free any memory used by the subprogram. However, in many operating systems, if the subprogram has been dynamically loaded, this statement also frees the memory originally used by the subprogram. EXTERNAL files and data areas of the subprogram are never freed by a CANCEL statement.
Parent topic: Statements
Related information
The Program-ID Paragraph
State of a Function, Method or Program
Scope of Names
The CALL Statement


The CHAIN Statement

The CHAIN statement transfers control from one object program to another in the run unit with no subsequent return of control. The effect is as though the chained program is the main program in the new run unit.

General Format

Syntax Rules

  1. The syntax of the CHAIN statement is similar to the syntax of the CALL statement and the two are subject to common syntax rules as indicated in the topic The CALL Statement. All the identifiers, literals and integers in the general format of the CHAIN statement correspond to the identifiers, literals and integers of the CALL statement.

General Rules

  1. Literal-1 or the content of the data item referenced by identifier-1 is the name of the chained program. The program in which the CHAIN statement appears is the chaining program.

    The chained program must be a COBOL program that is not a nested program. The name of the chained program must contain the name contained in the Program-ID paragraph of the chained program (seethe section The Program-ID Paragraph, particularly in regard to case sensitivity). Alternatively, the name of the chained program may contain a name which identifies a file that contains executable program code for the chained program. See your COBOL system documentation for details of how your system matches the given name to previously chained programs, program filenames or programs held in library files.

  2. If, when a CHAIN statement is executed, the program specified by the CHAIN statement is made available for execution, control is transferred to the chained program, and the chaining program, and any COBOL programs called by the chaining program, are canceled. The chained program is not under the control of a chaining program and so any EXIT PROGRAM executed within the chained program has no effect.
  3. If, when a CHAIN statement is executed, the program specified by the CHAIN statement is not made available for execution, then a fatal run-time error is given.
  4. Chained programs can contain CHAIN statements. A CHAIN statement within a chained program may reference any program except itself.
  5. The form of the CHAIN statement is similar to the form of the CALL statement and the two are subject to common general rules as indicated in the topic The CALL Statement. All the identifiers, literals and integers in the general format of the CHAIN statement correspond to the identifiers, literals and integers of the CALL statement. Also, where the expressions calling program and called program are used, these can be considered equivalent to the expressions chaining program and chained program.
  6. The chain operation moves the value from each data item referenced in the USING phrase of the CHAIN statement to the data item referenced by the corresponding data-name in the USING phrase of the PROCEDURE DIVISION header of the chained program.
  7. The value of any data item with USAGE POINTER or USAGE PROCEDURE-POINTER that is passed as an operand in the USING phrase must not represent the address that was originally derived from a COBOL data item.
  8. The END-CHAIN phrase delimits the scope of the CHAIN statement.
  9. The USING phrase must not be used if you have specified the Compiler directive INTLEVEL"1".
Parent topic: Statements
Related information
The CALL Statement
The Program-ID Paragraph


The CLOSE Statement

The CLOSE statement terminates the processing of reels/units and files, with optional rewind, lock or removal where applicable.

General Formats for Format 1 (Record Sequential Files)

General Formats for Format 2 ( MF Line Sequential, Relative and Indexed Files)

Syntax Rules for All Formats (All Files)

  1. The files referenced in the CLOSE statement need not all have the same organization or access.

Syntax Rules for Format 1 (Record Sequential Files)

  2. MF The REEL and UNIT phrases should be specified only for files which have had MULTIPLE REEL or MULTIPLE UNIT specified in their SELECT clause. If your run-time system does not recognize multi-unit files, the statements CLOSE REEL and CLOSE UNIT are "null" statements; that is, they are documentary only. It is important that no other files are open on the device(s) closed by a CLOSE REEL or CLOSE UNIT statement.

    OSVS The statements CLOSE REEL WITH LOCK and CLOSE UNIT WITH LOCK are treated as equivalent to CLOSE REEL FOR REMOVAL.

  3. OSVS The DISP option is applicable only to tape files.

    It is documentary only.

General Rules for All Formats (All Files)

  1. A CLOSE statement can be executed only for a file in an open mode.
  2. Following the successful execution of a CLOSE statement the record area associated with file-name-1 is no longer available. The unsuccessful execution of such a CLOSE statement leaves the availability of the record area undefined.
  3. ANS85 If a file is in the open mode when a STOP RUN statement is executed, the fileis closed. If a file has been opened in a called program and not closed in that program prior to the execution of a CANCEL statement for the program, that file is closed.
  4. MF Following the successful execution of a CLOSE statement, all record or file locks held by the run unit on the closed file are released.
  5. The execution of the CLOSE statement causes the value of the I/O status associated with file-name-1 to be updated. (See the topic I-O Status in the chapter Procedure Division.)
  6. The results of executing each type of CLOSE statement for each category of file are summarized in the table below.
    Table 1. Relationship of Categories of Files and the Formats of the CLOSE Statement
    CLOSE Statement Format | File Category
    Non-Reel/Unit | Record Sequential Single-Reel/Unit | Record Sequential Multi-Reel/Unit | Non-record Sequential Single/ Multi-Reel/Unit
    CLOSE | C | C, G | A, C, G | C
    CLOSE WITH LOCK | C, E | C, E, G | A, C, E, G | C, E
    CLOSE WITH NO REWIND record sequential only | ANS85 C, H | B, C | A, B, C | X
    CLOSE REEL/UNIT record sequential only | ANS85 F | ANS85 F, G | F, G | X
    CLOSE REEL/UNIT FOR REMOVAL record sequential only | ANS85 F | ANS85 D, F, G | D, F , G | X
    CLOSE REEL/UNIT WITH NO REWIND record sequential only | X | X | F, B | X

    The definitions of the symbols in the table are given below. Where the definition depends on whether the file is an input, output or input-output file, alternate definitions are given; otherwise, a definition applies to input, output, and input-output files.

    A. Previous Reels/Units Unaffected
    • Input Files and Input-output Files:

      All reels/units in the file prior to the current reel/unit are processed except those reels/units controlled by a prior CLOSE REEL/UNIT statement. If the current reel/unit is not the last in the file, the reels/units in the file following the current one are not processed.

    • Output Files:

      All reels/units in the file prior to the current reel/unit are processed except those reels/units controlled by a prior CLOSE REEL/UNIT statement.

    B. No Rewind of Current Reel

    The current reel/unit is left in its current position.

    C. Close File
    • Input Files and Input-output Files (Sequential Access Mode):

      If the file is at the end and label records are specified for the file, the labels are processed according to the operating system label convention. The behavior of the CLOSE statement when label records are specified but not present, or when label records are not specified but are present, is undefined. If the file is at the end and label records are not specified for the file, label processing does not take place, but other closing operations dependent on the run-time system are executed. If the file is not at the end, the closing operations dependent on the run-time system are executed, but there is no ending label processing.

    • Input Files and Input-output Files (Random or Dynamic Access Mode); Output Files (Random, Dynamic or Sequential Access Mode):

      If label records are specified for the file, the labels are processed according to the operating system standard label convention. The behavior of the CLOSE statement when label records are specified but not present, or when label records are not specified but are present, is undefined. If label records are not specified for the file, label processing does not take place, but other closing operations dependent on the run-time system are executed.

    D. Reel/Unit Removal

    The reel or unit can be accessed again, in the proper order of reels or units in the file, if a CLOSE statement without the REEL or UNIT phrase has previously been executed for this file followed by the execution of an OPEN statement for the file.

    E. File Lock

    This file cannot be opened again during this execution of this run unit.

    F. Close Reel/Unit
    • Input Files and Input-output Files (Reel/Unit Media):
      1. ANS85 If the current reel/unit is the last or only reel/unit for the file, no reel/unit swap takes place; the current volume pointer remains unchanged, and the file position indicator is set to indicate that no next reel/unit exists.
      2. If another reel/unit exists for the file, a reel/unit swap occurs, the current volume pointer is updated to point to the next reel/unit existing in the file, the standard beginning reel/unit label procedure is executed, and the file position indicator is set to one less than the number of the first record existing on the new current volume. If no data records exist for the current volume, another reel/unit swap occurs.
    • Output Files (Reel/Unit Media):

      The following operations take place:

      1. Execution of the standard ending reel/unit label procedure.
      2. A reel/unit swap.
      3. Execution of the standard beginning reel/unit label procedure.
      4. The next executed WRITE statement that references that file directs the next logical data record to the next reel/unit of the file.
    • Input Files, Input-output Files, and Output Files (Non-Reel/Unit Media):

      ANS85 Execution of this statement is considered successful. The file remains in the open mode, the file position indicator remains unchanged, and no action takes place except as specified in General Rule 4.

    G. Rewind

    The current reel or analogous device is positioned at its physical beginning.

    H. Optional Phrases Ignored

    ANS85 The CLOSE statement is executed as if none of the optional phrases is present.

    X. Illegal

    This is an illegal combination of a CLOSE option and a file category. The results at object time are undefined.

General Rules for Format 1 (Record SequentialFiles)

Note: Except where otherwise stated in the general rules below, the terms "reel" and "unit" are equivalent and completely interchangeable in the CLOSE statement. Treatment of sequential mass storage files is logically equivalent to the treatment of a file on tape or analogous sequential media.

General Rules for All Formats (All Files)

  7. In order to show the effect of various types of CLOSE statements as applied to various storage media, all files are divided into the following categories:
    1. Non-reel/unit. A file whose input or output medium is such that the concepts of rewind and reels/units have no meaning.
    2. Sequential single-reel/unit. A sequential file that is entirely contained on one reel/unit.
    3. Sequential multi-reel/unit. A sequential file that is contained on more than one reel/unit.
  8. If the OPTIONAL phrase has been specified for the file in the File-Control paragraph of the Environment Division and the file is not present, the standard end-of-file processing is not performed for that file.
  9. If a CLOSE statement without the REEL or UNIT phrase has been executed for a file, no other statement (except the SORT or MERGE statements with the USING or GIVING phrases) can be executed that references that file, either explicitly or implicitly, unless an intervening OPEN statement for that file is executed.
  10. The WITH NO REWIND and FOR REMOVAL phrases have no effect at object time if they do not apply to the storage media on which the file resides.
  11. If WITH LOCK is specified, the file cannot be reopened during the current execution of the run unit. Otherwise a normal CLOSE takes effect.

    MF (This option has no connection with the record or file locking used when sharing files.)

General Rules for All Formats (All Files)

  12. If a CLOSE statement has been executed for a file, no statement

    MF other than a DELETE FILE statement

    can be executed that references that file, either explicitly or implicitly, unless an intervening OPEN statement for that file is executed.

  13. If WITH LOCK is specified, the file cannot be reopened during the current execution of the run unit.
Parent topic: Statements
Related information
I-O Status


The COMMIT Statement

The COMMIT statement releases all record locks in all files held by this run unit. For COBOL systems that support the WITH...ROLLBACK clause of the SELECT statement as other than documentary, COMMIT indicates the end of the current transaction and makes the effects of that transaction permanent.

General Format

General Rules

  1. Execution of the COMMIT statement causes all record locks in all files held by the run unit to be released.
  2. The file lock on an exclusive file is not affected by the COMMIT statement.
  3. If your COBOL system supports the WITH ... ROLLBACK clause of the SELECT statement as other than documentary, then the COMMIT verb:
    1. Indicates completion of the current transaction
    2. Makes all changes applied during the transaction permanent.
Parent topic: Statements


The COMPUTE Statement

The COMPUTE statement assigns to one or more data items the value of an arithmetic expression.

General Format for Format 1 (arithmetic compute)

Format 2 (boolean compute)

COMPUTE {identifier-2} ... = boolean-expression-1 [END-COMPUTE]

Syntax Rules for Format 1

  1. Identifiers that appear only to the left of "=" must refer to either an elementary numeric item or an elementary numeric edited item

    OSVS VSC2 MF or a floating-point item.

  2. OSVS VSC2 MF "Equal" and "=" are synonymous.

Syntax Rules for Format 2

  3. Identifier-2 must reference an elementary boolean data item.
  4. Boolean-expression-1 must not consist solely of the figurative constant ALL literal.

General Rules

  1. See the topics Arithmetic Expressions, The ROUNDED Phrase, The ON SIZE ERROR Phrase, Arithmetic Statements, Overlapping Operands and Multiple Results in Arithmetic Statements in the chapter Procedure Division; the section Explicit and Implicit Scope Terminators in the chapter Concepts of the COBOL Language, and the section Delimited Scope Statements in the chapter Language Fundamentals.
  2. An arithmetic expression consisting of a single identifier or literal provides a method of setting the values of identifier-1 equal to the value of the single identifier or literal.
  3. The COMPUTE statement allows you to combine arithmetic operations without the need to explicitly store intermediate results in temporary data items, as would be necessary using the arithmetic statements ADD, SUBTRACT, MULTIPLY and DIVIDE. The expression is evaluated to as many digits as possible, and truncated or rounded to fit into identifier-1.

    OSVS VSC2 The intermediate results obtained during the expression evaluation are truncated as if they were moved to data items whose PICTURE is determined by the COBOL system. This behavior is selected using the ARITHMETIC Compiler directive.

    ISO2002 MF The number of boolean positions in the value resulting from the evaluation of boolean-expression-1 is the number of boolean positions in the largest boolean item referenced in the expression. The resulting value is moved to the data item referenced by identifier-2 according to the rules of the MOVE statement.

  4. If more than one identifier is specified for the result of the operation, that is preceding "=", the value of the arithmetic expression is computed, and then this value is stored as the new value of each occurrence of identifier-1 in turn.
Parent topic: Statements
Related information
Arithmetic Expressions
The ON SIZE ERROR Phrase
The ROUNDED Phrase
Arithmetic Statements
Overlapping Operands
Multiple Results in Arithmetic Statements
Explicit and Implicit Scope Terminators
Delimited Scope Statements


The CONTINUE Statement

The CONTINUE statement is a no operation statement, indicating that no executable statement is present.

General Format

Syntax Rules

  1. The CONTINUE statement can be used anywhere a conditional statement or an imperative-statement can be used.

General Rules

  1. The CONTINUE statement has no effect on the execution of the program.
Parent topic: Statements


The DELETE Statement

The DELETE statement logically removes a record from a mass storage file. It can be specified only for files with relative or indexed organization.

General Format

Syntax Rules

  1. The INVALID KEY phrase must not be specified for a DELETE statement which references a file in sequential access mode.
  2. The INVALID KEY phrase must be specified for a DELETE statement which references any file not in sequential access mode for which an applicable USE AFTER STANDARD EXCEPTION PROCEDURE is not specified.

    OSVS VSC2 MF This rule is not enforced.

General Rules

  1. The associated file must be open in the I-O mode at the time of execution of this statement. (See the topic The OPEN Statement.)
  2. For files in sequential access mode, the last input-output statement executed for file-name-1 prior to the execution of the DELETE statement must have been a successfully executed READ statement. The operating system logically removes from the file the record that was accessed by that READ statement.
  3. For a file in random or dynamic access mode, the operating system logically removes from the file that record identified by the contents of a key data item associated with file-name. For a relative file, this key data item is the relative key and for an indexed file, it is the prime record key. If the file does not contain the record specified by the key, an INVALID KEY condition exists. (See the section The INVALID KEY Condition in the chapter Procedure Division.)
  4. After the successful execution of a DELETE statement, the identified record is logically removed from the file and can no longer be accessed.
  5. The execution of a DELETE statement does not affect the contents of the record area associated with file-name-1.
  6. The file position indicator is not affected by the execution of a DELETE statement.
  7. Execution of the DELETE statement causes the value of the specified FILE STATUS data item, if any, associated with the file-name to be updated. (See the topic I-O Status in the chapter Procedure Division.)
  8. Transfer of control following the successful or unsuccessful execution of the DELETE operation depends on the presence or absence of the optional INVALID KEY phrase

    ANS85 and NOT INVALID KEY phrase

    in the DELETE statement. (See the topic The INVALID KEY Condition in the chapter Procedure Division.)

  9. ANS85 The END-DELETE phrase delimits the scope of the DELETE statement. (See the section Explicit and Implicit Scope Terminators in the chapter Concepts of the COBOL Language.)
  10. MF When using DELETE, the record to be deleted must not be locked by another run unit.
  11. MF Following the successful execution of a DELETE statement, any record lock held by the run unit on the deleted record is released.
Parent topic: Statements
Related information
The OPEN Statement
The INVALID KEY Condition
I-O Status
Explicit and Implicit Scope Terminators


The DELETE FILE Statement

The DELETE FILE statement physically removes the specified files from the physical devices on which they reside.

General Format

General Rules

  1. The DELETE FILE statement physically removes the specified files from the physical devices on which they reside.
  2. The specified files must be closed when the statement is executed, but not CLOSED WITH LOCK.
Parent topic: Statements


The DISPLAY Statement

The DISPLAY statement causes data to be transferred from specified data items to the appropriate hardware device, such as the CRT screen.

MF The DISPLAY statement also transfers data from your program to the CRT or video terminal screen: non-scrolling forms, into which you can enter data, are displayed.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

Syntax Rules for Format 1

  1. The mnemonic-name must be associated with a function-name in the Special-Names paragraph in the Environment Division. See General Rule 9 in the topic The Special-Names Paragraph for a list of valid function-names.
  2. OSVS VSC2 MF Alternatively, function-name can itself be used instead of an associated mnemonic-name.
  3. Each literal can be any figurative constant, except ALL.
  4. If the literal is numeric, it must be an unsigned integer.

    OSVS VSC2 MF This restriction can be ignored.

  5. MF XOPEN When mnemonic-name is associated with ARGUMENT-NUMBER, then identifier-1 or literal-1 must each, if used, reference a data item defined as an unsigned integer or an unsigned integer literal respectively. Only a single identifier-1 or literal-1 can be used and the WITH NO ADVANCING phrase cannot be used.
  6. MF XOPEN When mnemonic-name is associated with ENVIRONMENT-NAME or ENVIRONMENT-VALUE, then identifier-1, if used, must reference an alphanumeric data item. Literal-1, if used, must reference a nonnumeric literal. Only a single identifier-1 or literal-1 can be used and the WITH NO ADVANCING phrase cannot be used.
  7. The ON EXCEPTION and NOT ON EXCEPTION phrases can only be specified when mnemonic-name is associated with ENVIRONMENT-NAME or ENVIRONMENT-VALUE.

Syntax Rules for Format 2

  8. MF XOPEN Screen-name cannot be an item with an OCCURS clause.

Syntax Rules for Format 2 and 3

  9. MF The LINE and COLUMN phrases can appear in any order.
  10. MF Integer-3 and identifier-4 must be 4 or 6 digits long.

Syntax Rules for Format 3

  11. MF A DISPLAY statement with an operand that is not a screen-name is treated as a Format 3 DISPLAY statement if it has an AT phrase, an UPON phrase with the CRT or CRT-UNDER option, a WITH phrase, or a MODE IS BLOCK phrase; or if it has no UPON phrase but the CONSOLE IS CRT clause is specified in the Special-Names paragraph. If it has the UPON phrase with the CONSOLE option, or if it has no UPON phrase and the CONSOLE IS CRT clause is not specified in the Special-Names paragraph, it is treated as a Format 1 DISPLAY statement.
  12. MF The phrases following the identifier can be in any order.
  13. MF Elementary data items in identifier-1 must be of USAGE DISPLAY.
  14. MF No elementary item in identifier-1 may be longer than 8191 bytes. If the MODE IS BLOCK phrase is used, the whole of identifier-1 must be no longer than 8191 bytes.
  15. MF If a DISPLAY verb is followed by more than one identifier-1, any WITH clause applies only to the operand immediately preceding it.

General Rules for Format 1

  1. When operands in a DISPLAY statement have USAGE other than DISPLAY, or have included signs, they are converted to USAGE DISPLAY with separate sign. The size of the operand is taken as the size after conversion.
  2. If a figurative constant is specified as one of the operands, only a single occurrence of the figurative constant is displayed.
  3. MF If the function-name COMMAND-LINE, or a mnemonic-name associated with the function-name COMMAND LINE, is specified, data overwrites the contents of a system-dependent command-line buffer from where it can be retrieved by subsequent use of ACCEPT FROM COMMAND-LINE. Only one operand is allowed in this case.

    All permissible function-names other than those specifically mentioned in the general rules for Format 1 of the DISPLAY statement are treated as equivalent to CONSOLE and each operand is transferred to the console device in the order listed. The total size of data displayed is equal to the sum of the sizes of each operand. The display starts from the current cursor position, overflowing onto the following line(s) if necessary.

    On earlier releases, trailing spaces after the last operand were not displayed.

  4. ANS85 If the NO ADVANCING phrase is specified, the cursor is then left at the space following the last character displayed; otherwise it is positioned at the start of the next line. Scrolling can take place whenever the cursor is moved to a new line.
  5. MF XOPEN If the mnemonic-name associated with the function-name ARGUMENT-NUMBER is used, then the position for any subsequent ACCEPT with a mnemonic associated with ARGUMENT-VALUE is set to retrieve the designated command-line argument. If the value associated with identifier-1 or literal-1 is less than 0, greater than 99, or greater than the total number of arguments on the command-line, then results are explicitly undefined.
  6. MF XOPEN If the mnemonic-name associated with the function-name ENVIRONMENT-NAME is used then the variable to be read or set in any subsequent ACCEPT or DISPLAY with a mnemonic associated with ENVIRONMENT-VALUE is set to the designated variable-name specified in literal-1 or as the contents of identifier-1. The ON EXCEPTION phrase is ignored. If any problem occurs while trying to set an ENVIRONMENT-NAME for a subsequent ACCEPT or DISPLAY associated with ENVIRONMENT-VALUE, then it is only the subsequent ACCEPT or DISPLAY that must detect the ON EXCEPTION condition.
  7. MF XOPEN If the mnemonic-name associated with the function-name ENVIRONMENT-VALUE is used then
    1. If a previous DISPLAY with a mnemonic-name associated with an ENVIRONMENT-NAME has been done, then the value of the identifier is placed into the designated environment variable.
    2. If no previous DISPLAY with a mnemonic-name associated with an ENVIRONMENT-NAME has been performed, or, for ACCEPT, if the specified environment variable does not exist, or, for DISPLAY, not enough space can be allocated to store the environment variable, the imperative statement associated with an ON EXCEPTION phrase is executed. The value in identifier is undefined in this case.
  8. MF XOPEN If the mnemonic-name associated with the function-name SYSERR is used, then a DISPLAY is performed as if to the CONSOLE except that all output is directed to the system's standard Error Device.
  9. MF XOPEN When using DISPLAY UPON ENVIRONMENT-VALUE, trailing spaces are included in the value. You should use INSPECT REPLACING ALL SPACE BY LOW-VALUES to avoid this.
  10. OSVS VSC2 MF Within identifier-1, internal floating-point numbers are converted to external floating-point numbers for display, so that:
    1. A COMP-1 item is displayed as if it has an external floating-point PICTURE clause of -.9(8)E-99.
    2. A COMP-2 item is displayed as if it has an external floating-point PICTURE clause of -.9(18)E-99 (even though this picture string is illegal if explicitly specified).
  11. OSVS VSC2 MF Literal-1 may be a floating-point literal.

General Rules for Format 2

  12. MF XOPEN This format of the DISPLAY statement displays screen items, which are defined in the Screen Section of the program, and allows full access to the enhanced screen handling facilities.

General Rules for Format 2 and 3

  13. MF The AT phrase gives the absolute address on the screen where the DISPLAY operation is to start.
  14. MF The order of execution of a DISPLAY statement is always:
    1. The AT phrase
    2. The BLANK phrase
    3. The BELL phrase
    4. The DISPLAY operation
  15. MF If integer-3 or identifier-4 is 4 digits long, the first two digits specify the line, the second two the column. If 6 digits long, the first three digits specify the line, while the second three specify the column.
  16. MF Certain combinations of line and column numbers have special meanings, as follows:
    1. Until the column comes within range, out of range column values are reduced by the line length and the line value is incremented.
    2. Out of range line values cause the screen to scroll up one line. The effect is the same as if the line number of the bottom line had been specified.
    3. If the line and column numbers given are both zero, the DISPLAY starts at the position following that where the preceding Format 2 or Format 3 DISPLAY operation finished. Column 1 of each line is considered to follow the last column of the previous line.
    4. If the line number is zero, but a non-zero column number is specified, the DISPLAY starts at the specified column, on the line following that where the preceding Format 2 or 3 DISPLAY operation finished.
    5. If the column number is zero, but a non-zero line number is specified, the DISPLAY starts on the specified line, at the column following that where the preceding Format 2 or 3 DISPLAY operation finished.

General Rules for Format 3

  17. MF Part of this statement can be repeated to allow the display of several data items. If the first item has no AT phrase, it begins at line 1, column 1. Each subsequent item begins at the current cursor position as left after the previous item.
  18. MF If identifier-1 is a group item and no MODE IS BLOCK phrase exists, those elementary subordinate items which have names other than FILLER are displayed. They are displayed simultaneously, positioned on the screen in the order their descriptions appear in the Data Division, and separated by the lengths of the FILLER items in the group. For this purpose, the first position on a line is regarded as immediately following the last position on the previous line.
  19. MF The MODE IS BLOCK phrase indicates that the identifier is to be treated as an elementary item. Thus, even if it is a group item it is displayed as one item.
  20. MF The WITH phrase allows you to specify certain options available during the operation. (See the chapter Screen Section Entry Skeleton for descriptions of these options.)

    In addition to the options available as screen description clauses, the following options can be used in the WITH phrase; SPACE-FILL, ZERO-FILL, LEFT-JUSTIFY, RIGHT-JUSTIFY, TRAILING-SIGN and UPDATE. ZERO-FILL appears in this list and as a screen description clause because it has two different uses. Its second use is documented later in this chapter.

    A configuration option is available which allows the entry of data into numeric and numeric edited screen fields in free format mode. In COBOL, nonedited numeric data items are intended for holding data in an internal form; however, this format enables such data items to appear on the screen. See your COBOL system documentation on user interfaces for more details. If free format mode is in effect, the data appears automatically reformatted as follows:

    • With the virtual decimal point represented by a period
    • With the sign represented by a sign character ("-" for minus; space for plus) which appears immediately before the leftmost digit
    • With zero suppression in all integer character positions, except the least significant
    • With left justification

    The SPACE-FILL, ZERO-FILL, LEFT-JUSTIFY, RIGHT-JUSTIFY and TRAILING-SIGN options amend this format.

  21. MF If the literal-1 is one of the following figurative constants it has a special effect as follows: SPACE clears from the specified cursor position to the end of the screen; LOW-VALUE moves the cursor to the specified position; ALL X"01" clears from the specified cursor position to the end of the line; ALL X"02" clears the whole screen; ALL X"07" sounds the bell. If the literal is a figurative constant that is not listed above and the SIZE option is not specified, one occurrence of its value is displayed.
  22. MF If the SIZE option is specified for a figurative constant that has no special effect, then that figurative constant is displayed as many times as necessary to reach the length specified in the SIZE option. However, if the display wraps around to a new line, it starts again at the beginning of the figurative constant.
  23. MF If the FOREGROUND-COLOR option is specified, then the specified color becomes the default foreground color if and only if the entire screen is cleared by this display. The entire screen is cleared either when the BLANK SCREEN option is specified or when literal-1 is SPACES and the DISPLAY starts at line 1 column 1.
  24. MF If the BACKGROUND-COLOR option is specified, then the specified color becomes the default background color if and only if the entire screen is cleared by this display.
  25. MF If REDEFINES is used within identifier-1, the first description of the redefined data area is used and subsequent descriptions are ignored. If OCCURS or nested OCCURS are used the repeated data item is expanded into the full number of times it occurs, so that one definition is repeated for many fields.
Parent topic: Statements
Related reference
DISPLAY Statement
Related information
The Special-Names Paragraph
Screen Section Entry Skeleton


The DIVIDE Statement

The DIVIDE statement divides one numeric data item into others and sets the values of data items equal to the quotient and remainder.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

General Formats for Format 4

General Formats for Format 5

Syntax Rules for All Formats

  1. Each identifier must refer to an elementary numeric item, except that any identifier associated with the GIVING or REMAINDER phrase must refer to either an elementary numeric item or an elementary numeric edited item.
  2. Each literal must be a numeric literal.
  3. The composite of operands is determined by using all receiving data items except the REMAINDER data item. See the topic Arithmetic Statements in the chapter Procedure Division.
  4. OSVS VSC2 MF When Format 1, 2, or 3 is used, floating-point data items and literals can be used anywhere a numeric data item or literal can be specified. When Format 4 or 5 is used, no floating-point data items or literals may be specified.

General Rules for All Formats

  1. See the topics The ROUNDED Phrase, The ON SIZE ERROR Phrase, Arithmetic Statements, Overlapping Operands and Multiple Results in Arithmetic Statements in the chapter Procedure Division; the section Explicit and Implicit Scope Terminators in the chapter Concepts of the COBOL Language, and the section Delimited Scope Statements in the chapter Language Fundamentals. .

General Rules for Format 1

  2. When Format 1 is used, literal-1 or the value of the data item referenced by identifier-1 is stored in a temporary data item. The value in this temporary data item is then divided into the value of identifier-2. The value of the dividend (the value of the data item referenced by identifier-2) is replaced by this quotient; similarly, the temporary data item is divided into each successive occurrence of identifier-2 in the left-to-right order in which identifier-2 is specified.

General Rules for Format 2

  3. When Format 2 is used, the value of identifier-1 or literal-1 is divided into identifier-2 or literal-2 and the result is stored in each data item referenced by identifier-3.

General Rules for Format 3

  4. When Format 3 is used, the value of identifier-1 or literal-1 is divided by the value of identifier-2 or literal-2 and the result is stored in each data item referenced by identifier-3.

General Rules for Formats 4 and 5

  5. Formats 4 and 5 are used when a remainder from the division operation is desired, namely identifier-4. The remainder in COBOL is defined as the result of subtracting the product of the quotient (identifier-3) and the divisor from the dividend. If identifier-3 is defined as a numeric edited item, the quotient used to calculate the remainder is an intermediate field which contains the unedited quotient. If ROUNDED is used, the quotient used to calculate the remainder is an intermediate field which contains the quotient of the DIVIDE statement, truncated rather than rounded.
  6. In Formats 4 and 5, the accuracy of the REMAINDER data item (identifier-4) is defined by the calculation described above. Appropriate decimal alignment truncation (not rounding) is performed for the content of the data item referenced by identifier-4, as needed.
  7. When the ON SIZE ERROR phrase is used in Formats 4 and 5, the following rules pertain:
    1. If the size error condition occurs on the quotient, no remainder calculation is meaningful. Thus, the contents of the data items referenced by both identifier-3 and identifier-4 ill remain unchanged.
    2. If the size error condition occurs on the remainder, the contents of the data item referenced by identifier-4 remains unchanged.

    However, as with other instances of multiple results of arithmetic statements, you will have to do your own analysis to recognize which situation has actually occurred.

Parent topic: Statements
Related information
Arithmetic Expressions
The ON SIZE ERROR Phrase
The ROUNDED Phrase
Arithmetic Statements
Overlapping Operands
Multiple Results in Arithmetic Statements
Explicit and Implicit Scope Terminators
Delimited Scope Statements


The ENTER Statement

The ENTER statement provides a means of allowing the use of more than one language in the same program.

ANS85 The ENTER statement is classed as an obsolete element in the ANSI'85 standard and is scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects in this COBOL implementation support this syntax for documentation purposes only. The FLAGSTD Compiler directive can be used to detect all occurrences of this syntax.

XOPEN Although it is a part of the standard COBOL definition, this feature is explicitly excluded from the X/Open COBOL language definitions and should not be used in an X/Open COBOL conforming source program.

General Format

Syntax Rules

  1. Language-name and routine-name can be any user-defined word or alphanumeric literal.

General Rules

  1. This statement is treated as for documentation purposes only. Access to other languages can be achieved by means of the CALL statement.
Parent topic: Statements


The ENTRY Statement

The ENTRY statement establishes an alternate entry point into a called COBOL program.

General Formats for Format 1

General Formats for Format 2

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the STICKY-LINKAGE directive controls whether addressability to Linkage Section items is maintained between calls to different entry points in the same program.

Syntax Rules for All Formats

  1. The ENTRY statement cannot be used in a program that is nested within another program.
  2. Literal-1 must be non-numeric and must not be a figurative constant. In some environments, only the first 8 characters are significant.
  3. Mnemonic-name is necessary only if the object program that is to be invoked expects a calling convention other than that used as the default by your COBOL system. Typically, the default COBOL calling convention is consistent with that used by a significant implementation of a non-COBOL language for the run-time environment.

    Mnemonic-name must be defined in the Special-Names paragraph. See the topic The Special-Names Paragraph for details of how to do this and your COBOL system documentation on interfacing for details of which calling conventions are supported in your run-time environment.

Syntax Rules for Format 1

  4. Format 1 must be specified only within program definitions.
  5. Data-name-1 must be defined as a level 01 or a level 77 entry in the Linkage Section

    MF , File Section or Working-Storage Section.

  6. MF Data-name-2 must be defined as a level 01 or a level 77 entry in the Linkage Section, File Section or Working-Storage Section. Data-name-2 can be of any class, but the length must be no greater than 8 bytes.

Syntax Rules for Format 2

  7. MF Format 2 can only be used in a program in which the EXTERNAL clause is specified in the Program-ID paragraph, that is a call prototype.
  8. MF Data-name-1 and data-name-2 must be defined as 01 level records in the Linkage Section.
  9. MF Typedef-name-1, typedef-name-2, and typedef-name-3 must be previously defined in the same source file as a programmer-defined usage by means of a TYPEDEF clause.

General Rules for All Formats

  1. The content of literal-1 gives the entry-name, a name which identifies an entry point into the program that is an alternative to the default COBOL entry point at the start of the Procedure Division that is identified by the program-name given in the Program-ID paragraph.

    Note that program files containing executable COBOL code typically have names that are essentially the same as the program-name. When a CALL is made and the program-name or entry-name is not already loaded into memory, program files are located by filename but can appear to be located by program-name. In such circumstances, a CALL that references a program-name may succeed but a CALL that references an entry-name may fail.

    The entry-name is largely equivalent to a program-name and the two are subject to common rules for formation of the name as indicated in the topic The Program-ID Paragraph. Literal-1 corresponds to literal-1 of the general format for the Program-ID paragraph.

  2. When the calling program invokes the called program by a CALL statement naming the entry-name given by literal-1, control is transferred to the next executable statement following the ENTRY statement.
  3. Data items that are declared in the Linkage Section but are not declared in the USING phrase of the ENTRY statement can only be referenced if they have been linked to a data item by executing a SET statement or if the STICKY-LINKAGE Compiler directive is used.
  4. Up to sixty-two data-names are permitted in the USING phrase.
  5. Both the BY REFERENCE and the BY VALUE phrases are transitive across the parameters that follow them until another BY REFERENCE or BY VALUE phrase is encountered. If neither the BY REFERENCE nor the BY VALUE phrase is specified prior to the first parameter, the BY REFERENCE phrase is assumed.

General Rules for Format 1

  6. MF If data-name-1 is defined as a level 01 or a level 77 entry in the File Section or Working-Storage Section then the object program operates as if a data item had been declared in the Linkage Section with the same data declaration as data-name-1 and the contents of that data item were moved to data-name-1 prior to executing the first statement in the called program. In an initial program, these values are overwritten by the initialization of the program's Working-Storage data and are therefore not available to the called program.
  7. If the activating runtime element is COBOL the following rules apply. If the activating runtime element is not COBOL, see your COBOL system documentation on interfacing for details of when you need to use the BY REFERENCE or BY VALUE clauses.
  8. The USING phrase identifies the names of the formal parameters used by the program or for any arguments passed to it. The arguments passed to it are identified in the activating source element by the USING phrase of a CALL statement. The correspondence between the two lists of names is established on a positional basis.
  9. If the argument is passed by content, the called program operates as if the record in the Linkage Section were allocated by the calling runtime element during the process of initiating the call and as if this record does not occupy the same storage area as the argument in the calling runtime element. This allocated record is exactly the same number of alphanumeric character positions in length as the argument. That argument is moved to this allocated record without conversion. This record is then treated by the called program as if it were the argument and as if it were passed by reference.
  10. If the argument is passed by reference, the called program operates as if the formal parameter occupies the same storage area as the argument.
  11. MF If the argument is passed by value, the called program operates as if the record in the Linkage Section were allocated by the calling runtime element during the process of initiating the call and as if this record does not occupy the same storage area as the argument in the calling runtime element. This allocated record is exactly the same number of alphanumeric character positions in length as the argument. That argument is moved to this allocated record without conversion. This record is then treated by the called program as if it were the argument and as if it were passed by reference.
  12. At all times in the activated element, references to data-name-1

    MF , data-name-2 and data-name-3

    are resolved in accordance with their description in the Linkage Section. If this description defines a greater number of character positions than the corresponding data item in the activating element, unpredictable results can occur. Failure to comply with this rule or exceeding the maximum allowed size of the system area for a particular run time environment may result in the system becoming catastrophically corrupt.

  13. MF When a program is called and a BY REFERENCE operand in the USING phrase corresponds to a parameter in the calling program, a referential connection is established and endures until control is returned to the calling program. If the program is called a second time, without any intervening cancel of the program, and that same BY REFERENCE operand does not correspond to a parameter in the calling program, then you must not reference that operand unless the STICKY-LINKAGE Compiler directive is specified.
Parent topic: Statements
Related information
The Special-Names Paragraph
The Program-ID Paragraph


The EVALUATE Statement

The EVALUATE statement describes a multi-branch, multi-join structure. It can cause multiple conditions to be evaluated. The subsequent action of the runtime element depends on the results of these evaluations.

General Format

Syntax Rules

  1. The operands or the words TRUE and FALSE which appear before the first WHEN phrase of the EVALUATE statement are referred to individually as selection subjects and collectively, for all those specified, as the set of selection subjects.
  2. The operands or the words TRUE, FALSE, and ANY which appear in a WHEN phrase of an EVALUATE statement are referred to individually as selection objects and collectively, for all those specified in a single WHEN phrase, as the set of selection objects.
  3. The words THROUGH and THRU are equivalent.
  4. Two operands connected by a THROUGH phrase must be of the same class. The two operands thus connected constitute a single selection object.
  5. The number of selection objects in each set of selection objects must be equal to the number of selection subjects.
  6. Each selection object in a set of selection objects must correspond to the selection subject having the same ordinal position in the set of selection subjects according to the following rules:
    1. Identifiers, literals, or arithmetic expressions appearing in a selection object must be valid operands for comparison to the corresponding operand in the set of selection subjects. (See the topic Relation Condition in the chapter Procedure Division.)
    2. Condition-1, condition-2, or the words TRUE or FALSE appearing as a selection object must correspond to a conditional expression or the words TRUE or FALSE in the set of selection subjects.
    3. The word ANY can correspond to a selection subject of any type.
    4. VSC2 MF Where identifiers are permitted, they can reference floating-point data items.
    5. VSC2 MF Where numeric literals are permitted, floating-point literals are permitted.
    6. VSC2 MF Where identifiers are permitted, they can reference pointer data items.
  7. A selection object is a partial-expression if the leftmost portion of the selection object is a relational operator, a class condition without the identifier, a sign condition without the identifier, or a sign condition without the arithmetic expression.
  8. ISO2002 MF If partial-expression-1 or partial-expression-2 is specified as a selection object, it must correspond to a selection subject that is an identifier, a literal or an arithmetic expression. Partial-expression-1 and partial-expression-2 must be a sequence of COBOL words which, when following the corresponding selection subject, make the resultant text a valid conditional expression.

General Rules

  1. The execution of the EVALUATE statement operates as if each selection subject and selection object were evaluated and assigned a numeric or nonnumeric value, a range of numeric or nonnumeric values, or a truth value. These values are determined as follows:
    1. Any selection subject specified by identifier-1, identifier-2, and any selection object specified by identifier-3, identifier-5, without either the NOT or the THROUGH phrases, are assigned the value and class of the data item referenced by the identifier.
    2. Any selection subject specified by literal-1, literal-2, and any selection object specified by literal-3, literal-5, without either the NOT or the THROUGH phrases, are assigned the value and class of the specified literal. If literal-3, literal-5, is the figurative constant ZERO, it is assigned the class of the corresponding selection subject.
    3. Any selection subject in which expression-1, expression-2, is specified as an arithmetic expression and any selection object, without either the NOT or the THROUGH phrases, in which arithmetic-expression-1, arithmetic-expression-3, is specified are assigned a numeric value according to the rules for evaluating an arithmetic expression. (See the topic Arithmetic Expressions in the chapter Procedure Division.)
    4. Any selection subject in which expression-1, expression-2 is specified as a conditional expression and any selection object in which condition-1, condition-2, is specified are assigned a truth value according to the rules for evaluating conditional expressions. (See the topic Conditional Expressions in the chapter Procedure Division.)
    5. Any selection subject or any selection object specified by the words TRUE or FALSE is assigned a truth value. The truth value "true" is assigned to those items specified with the word TRUE, and the truth value "false" is assigned to those items specified with the word FALSE.
    6. Any selection object specified by the word ANY is not further evaluated.
    7. If the THROUGH phrase is specified for a selection object, without the NOT phrase, the range of values is all values which, when compared to the selection subject, are greater than or equal to the first operand and less than or equal to the second operand according to the rules for comparison. (See the topic Relation Condition in the chapter Procedure Division.
    8. If the NOT phrase is specified for a selection object, the values assigned to that item are all values not equal to the value, or range of values, which would have been assigned to the item had the NOT phrase not been specified.
  2. The execution of the EVALUATE statement then proceeds as if the values assigned to the selection subjects and selection objects were compared to determine if any WHEN phrase satisfies the set of selection subjects. This comparison proceeds as follows:
    1. Each selection object in the set of selection objects for the first WHEN phrase is compared to the selection subject having the same ordinal position in the set of selection subjects.
      1. If the items being compared are assigned numeric or nonnumeric values, or a range of numeric or nonnumeric values, the comparison is satisfied if the value, or one of the range of values, assigned to the selection object is equal to the value assigned to the selection subject according to the rules for comparison. (See the topic Relation Condition in the chapter Procedure Division.)
      2. If the items being compared are assigned truth values, the comparison is satisfied if the items are assigned the identical truth value.
      3. If the selection object being compared is specified by the word ANY, the comparison is always satisfied regardless of the value of the selection subject.
    2. If the above comparison is satisfied for every selection object in the set of selection objects being compared, the WHEN phrase containing that set of selection objects is selected as the one satisfying the set of selection subjects.
    3. If the above comparison is not satisfied for one or more selection objects in the set of selection objects being compared, that set of selection objects does not satisfy the set of selection subjects.
    4. This procedure is repeated for subsequent sets of selection objects, in the order of their appearance in the source element, until either a WHEN phrase satisfying the set of selection subjects is selected or until all sets of selection objects are exhausted.
  3. After the comparison operation is completed, execution of the EVALUATE statement proceeds as follows:
    1. If a WHEN phrase is selected, execution continues with the first imperative-statement-1 following the selected WHEN phrase.
    2. If no WHEN phrase is selected and a WHEN OTHER phrase is specified, execution continues with imperative-statement-2.
    3. The scope of execution of the EVALUATE statement is terminated when execution reaches the end of the scope of the selected WHEN phrase or WHEN OTHER phrase or when no WHEN phrase is selected and no WHEN OTHER phrase is specified.
  4. ISO2002 MF If the selection object is specified by partial-expression-1 or partial-expression-2, the corresponding selection subject is considered to be the word TRUE. The selection object is considered to be condition-1 or condition-2 respectively, where condition-1 or condition-2 is the conditional expression resulting from partial expression-1 or partial-expression-2 following the original corresponding selection-subject-1 or selection-subject-2 respectively.
Parent topic: Statements
Related concepts
Explicit and Implicit Scope Terminators


The EXAMINE Statement

The EXAMINE statement replaces or counts the number of occurrences of a given character in a data item.

General Formats for Format 1

General Formats for Format 2

Syntax Rules for All Formats

  1. The identifier must be described, explicitly or implicitly, as USAGE IS DISPLAY.
  2. Each literal must consist of a single character. If identifier is a numeric item, the literals must be numeric literals, nonnumeric literals whose value is a single numeric digit, or the figurative constant ZERO. If identifier belongs to any other class, then the literals can be numeric or nonnumeric, or any figurative constant without the word ALL.

General Rules for All Formats

  1. Examination proceeds as follows:
    1. For nonnumeric data items, examination starts at the leftmost character and proceeds to the right. Each character in the data item specified by the identifier is examined in turn.
    2. If a data item referred to by the EXAMINE statement is numeric, it must consist of numeric characters and can possess an operational sign. Examination starts at the leftmost character (excluding the sign) and proceeds to the right. Each character except the sign is examined in turn. Regardless of where the sign is physically located, it is completely ignored by the EXAMINE statement.
  2. The TALLYING option creates an integral count which replaces the value of a spe cial register called TALLY. The count represents the number of:
    1. Characters not equal to literal-1 encountered before the first occurrence of literal-1 when the UNTIL FIRST option is used.
    2. Occurrences of literal-1 when the ALL option is used.
    3. Occurrences of literal-1 prior to encountering a character other than literal-1 when the LEADING option is used.
  3. When either of the REPLACING options is used, the replacement rules are as follows:
    1. When the ALL option is used, then literal-2 is substituted for each occurrence of literal-1.
    2. When the LEADING option is used, the substitution of literal-2 terminates as soon as a character other than literal-1 or when the right-hand boundary of the data item is encountered.
    3. When the FIRST option is used, the first occurrence of literal-1 is replaced by literal-2.
    4. When the UNTIL FIRST option is used, the substitution of literal-2 terminates as soon as literal-1 or the right-hand boundary of the data item is encountered.
Parent topic: Statements


The EXEC(UTE) Statement

The EXEC(UTE) statement is provided as a linkage mechanism to allow control to be passed to non-COBOL subsystems.

General Formats for Format 1

General Formats for Format 2

Syntax Rules

  1. Text-data can be any textual data not containing the string END-EXEC.

General Rules for Format 1

  1. The formats EXEC(UTE) CICS, EXEC(UTE) SQL, and EXEC(UTE) DLI cause the appropriate system component (variously known as preprocessors, co-processors and external compiler modules) to be called to process text-data if the corresponding Compiler directive is specified that invokes that system component. If the corresponding Compiler directive has not been specified, the EXEC(UTE) statement is treated as a format 1 EXEC(UTE) statement For further information on the use of these formats see the information on using CICS and accessing databases in your COBOL system documentation.

General Rules for Format 2

  2. The statement is compiled as a CALL "text-name" USING text-data-buffer statement (see the topic The CALL Statement), where text-data-buffer contains all the text-data from the EXEC statement (space compressed) for further parsing by the called program text-name.

    This means that the called subprogram (text-name) is passed a text string which includes the entire COBOL statement beginning with the EXEC(UTE) verb and ending with the END-EXEC phrase. The called program must parse and then process all of the included information.

    If an identifier-name is included in text-data, then it is the name of the identifier, not the value of the data in the identifier, that is passed to the subprogram.

Parent topic: Statements
Related information
The CALL Statement


The EXHIBIT Statement

The EXHIBIT statement causes an (optionally conditional) display of the literals, and/or identifiers (optionally preceded by the identifier name) specified in the statement.

General Format

Syntax Rules

  1. Each identifier specified in the EXHIBIT statement can be any class of data. TALLY and RETURN-CODE are the only special registers that can be used as identifiers.
  2. CHANGED and NAMED can both be omitted.
  3. The EXHIBIT CHANGED statement is not supported in class programs when compiling to managed code.

General Rules

  1. Literals and identifiers displayed by the EXHIBIT statement are separated by a space on the displayed line.
  2. Each literal can be any figurative constant other than ALL.
  3. If the literal is numeric, it must be an unsigned integer.
  4. Each execution of an EXHIBIT NAMED statement displays each identifier or literal specified, with each identifier (including any qualifiers and subscripts) followed by an "=" (equal sign) and its current value. They all appear on a single line in the order in which they appear in the statement.
  5. Each execution of an EXHIBIT CHANGED NAMED statement displays each identifier or literal specified, with each identifier (including any qualifiers and subscripts) followed by an "=" (equal sign) and its current value. They all appear on a single line in the order in which they appear in the statement. However, the display for each identifier (name and value) is conditional on the value of that identifier having changed since the last execution of the current EXHIBIT statement. If one or more of the identifier values have not changed, neither the name nor the value is printed for those identifiers. If none of the identifier values has changed, and no literals are specified, no display takes place (display of a blank line is suppressed).
  6. Each execution of an EXHIBIT CHANGED statement displays the current value of each identifier or literal specified. They all appear on a single line in the order in which they appear in the statement. However, the value display for each identifier is conditional on the value of that identifier having changed since the last execution of the current EXHIBIT statement. If one or more of the identifier values have not changed, the value for those identifiers is not printed; spaces are inserted instead. If none of the identifier values has changed, and no literals are specified, a blank line is displayed (display of a blank line is not suppressed).
  7. Each execution of an EXHIBIT statement with neither the CHANGED nor the NAMED option displays each identifier or literal specified. They all appear on a single line in the order in which they appear in the statement.
Parent topic: Statements


The EXIT Statement

The EXIT statement provides a common end point for a series of procedures.

MF The EXIT statement can also exit an inline PERFORM, a paragraph or a section.

The EXIT PROGRAM statement marks the logical end of a called program.

MF You can also return values to activating runtime elements written in any language.

ISO2002 MF The EXIT METHOD statement marks the logical end of an invoked method.

ISO2002 The EXIT FUNCTION statement marks the logical end of the execution of a function.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

General Formats for Format 4

General Formats for Format 5

General Formats for Format 6

General Formats for Format 7

Syntax Rules for Format 1

  1. The EXIT statement should appear in a sentence by itself.

    VSC2 MF This rule is not enforced.

  2. The EXIT sentence should be the only sentence in the paragraph.

    VSC2 MF This rule is not enforced.

Syntax Rules for Format 2

  3. MF A Format 2 EXIT statement can be used only within an inline PERFORM.

Syntax Rules for Format4

  4. If an EXIT PROGRAM statement appears in a consecutive sequence of imperative statements within a sentence, it must appear as the last statement in that sequence.

    VSC2 MF This rule is not enforced.

  5. There must be no sentence other than the EXIT PROGRAM sentence in the paragraph.

    ANS85 This rule is not enforced.

  6. MF Integer-1 may be signed.
  7. MF GIVING and RETURNING are equivalent.
  8. MF If the ADDRESS OF clause is not specified, identifier-1 must be no larger than 8 bytes in size.

Syntax Rules for Format 5

  9. ISO2002 MF An EXIT METHOD statement may be specified only in a method Procedure Division.

Syntax Rules for Format 6

  10. ISO2002 An EXIT FUNCTION statement must be specified only in a function Procedure Division.

Syntax Rules for Formats 4, 5 and 6

  11. The EXIT statement must not be specified in a declarative procedure for which the GLOBAL phrase is specified in the associated USE statement.

Syntax Rules for Format 7

  12. NET JVM EXIT ITERATOR may only be specified in the context of an Iterator. See Iterator-ID.

General Rules for Format 1

  1. An EXIT statement serves only to enable you to assign a procedure-name to a given point in a Procedure Division. Such an EXIT statement has no other effect on the compilation or execution .

General Rules for Format 2

  2. MF The execution of an EXIT PERFORM statement without a CYCLE phrase causes control to be passed to an implicit CONTINUE statement, immediately following the END-PERFORM associated with the nearest inline PERFORM statement.
  3. MF The execution of an EXIT PERFORM statement with a CYCLE phrase causes control to be passed to an implicit CONTINUE statement, immediately preceding the END-PERFORM associated with the nearest inline PERFORM statement.

General Rules for Format3

  4. MF The execution of a Format 3 EXIT statement with the PARAGRAPH phrase causes control to pass to an implicit CONTINUE statement immediately following the last statement in the paragraph.
  5. MF The execution of an EXIT SECTION statement causes control to be passed to an unnamed empty paragraph immediately following the last paragraph of the current section, preceding any return mechanisms for that section.

General Rules for Format 4

  6. ANS85 If the EXIT PROGRAM statement is executed in a program which is not under the control of a calling runtime element, the EXIT PROGRAM statement causes execution of the program to continue with the next executable statement.
  7. ANS85 The execution of an EXIT PROGRAM statement in a called program which does not possess the initial attribute causes execution to continue with the next executable statement following the CALL statement in the calling runtime element. The state of the calling runtime element is not altered and is identical to that which existed at the time it executed the CALL statement except that the contents of data items and the contents of data files shared between the calling and called runtime elements may have been changed. The program state of the called program is not altered except that the ends of the ranges of all PERFORM statements executed by that called program are considered to have been reached.
  8. ANS85 Besides the actions specified in General Rule 7, the execution of an EXIT PROGRAM statement in a called program which possesses the initial attribute is equivalent to also executing a CANCEL statement referencing that program except that the statement does not free any memory. See the topic The CANCEL Statement in the chapter Procedure Division - ACCEPT - DIVIDE.
  9. ANS85 An EXIT PROGRAM statement must not be executed while executing a declarative procedure in which the GLOBAL phrase is specified except in a program called while executing that declarative procedure.
  10. MF Execution of an EXIT PROGRAM statement in a program that is under the control of a calling runtime element, causes a return value to be set in the system area generally available for non-COBOL programs to return a value. This system area is never smaller than 4 bytes in size but may be larger in some environments.

    If the GIVING phrase is not specified and the calling convention specifies updating the RETURN-CODE special-register (see the rules for the CALL-CONVENTION clause in the topic The Special-Names Paragraph) then the object program operates as if the system area were declared as a COBOL numeric data item with USAGE COMP-5 and with a size determined by the operating environment external to the COBOL system and as if a MOVE statement had been executed with the RETURN-CODE as the sending item and the system area as the receiving item. (See the topic Special Registers in the chapter Concepts of the COBOL Language for details of RETURN-CODE.)

    If the GIVING ADDRESS OF phrase is specified, the object program operates as if the system area were declared as a COBOL data item with USAGE POINTER and as if a SET statement had been executed with TO ADDRESS OF identifier-1 as the first operand and the system area as the second operand. The ADDRESS OF phrase may be used to indirectly pass a value that is larger than the system area.

    If the GIVING identifier-1 phrase is specified, identifier-1 must describe the same number of character positions as is required to hold the return value in the system area and must be of the type and usage that is expected by the calling runtime element. The object program operates as if a MOVE statement had been executed with identifier-1 as the sending item and the system area as the receiving item.

    If the GIVING integer-1 phrase is specified, integer-1 must not be larger than the value that can be held in the system area. The object program operates as if the system area were declared as a COBOL numeric data item with USAGE COMP-5 and with a size determined by the operating environment external to the COBOL system and as if a MOVE statement had been executed with integer-1 as the sending item and the system area as the receiving item.

    When compiling procedural COBOL code to managed COBOL, if there is no RETURNING phrase on the PROCEDURE DIVISION header, the Compiler generates a method that returns a 32 or 64-bit integer depending on the setting of the RTNCODE-SIZE directive. Statements of the form EXIT PROGRAM RETURNING identifier-1 attempt to convert identier-1 into the correct integer type, according to the rules of the MOVE statement, before returning the value to the calling program.

General Rules for Format 5

  11. ISO2002 MF The execution of an EXIT METHOD statement causes the executing method to terminate, and control to return to the invoking statement. If a RETURNING phrase is present in the containing method definition, the value in the data item referenced by the RETURNING phrase becomes the result of the method invocation.

General Rules for Format 6

  12. ISO2002 The execution of an EXIT FUNCTION causes the executing function to terminate, and control to return to the activating statement. The value in the data item referenced by the RETURNING phrase in the containing function definition becomes the result of the function activation.
Parent topic: Statements
Related reference
EXIT Statement
Related information
The Iterator-ID Paragraph
The CANCEL Statement
The Special-Names Paragraph
Special Registers


The GOBACK Statement

The GOBACK statement marks the logical end of a called program.

MF You can also return values to calling runtime elements written in any language or to the operating system environment.

General Format

Syntax Rules

  1. If a GOBACK statement appears in a consecutive sequence of imperative statements within a sentence, it must appear as the last statement in that sequence.

    This rule is not enforced, although any statements in the sentence that follow the GOBACK statement are not executed.

  2. MF GIVING and RETURNING are equivalent.
  3. MF If the ADDRESS OF clause is not specified, the data item referenced by identifier-1 must be no larger than 8 bytes in size.
  4. Integer-1 may be signed.

General Rules

  1. If a GOBACK statement is executed in a program which is under the control of a calling runtime element, the object program operates as if executing an EXIT PROGRAM statement that has the same clauses as the GOBACK statement. See the topic The EXIT Statement.
  2. If a GOBACK statement without the ADDRESS OF clause is executed in a program which is not under the control of a calling runtime element, the object program operates as if executing a STOP RUN statement that has the same clauses as the GOBACK statement.
  3. If a GOBACK statement with the ADDRESS OF clause is executed in a program which is not under the control of a calling runtime element, the object program operates as if executing a STOP RUN statement except that an arbitrary returned value is set in the system area. The GOBACK statement may result in more compact code than the equivalent EXIT PROGRAM and STOP RUN statement.
  4. A GOBACK statement must not be executed while executing a declarative procedure in which the GLOBAL phrase is specified except in a program called while executing that declarative procedure.
  5. ISO2002 If a GOBACK statement is executed in a function, the function operates as if executing an EXIT FUNCTION statement.
  6. ISO2002 MF If a GOBACK statement is executed in a method, the method operates as if executing an EXIT METHOD statement.
  7. NET JVM If a GOBACK statement is executed in an iterator, the iterator operates as if executing an EXIT ITERATOR statement.
Parent topic: Statements
Related reference
GOBACK Statement
Related information
The EXIT Statement


The GO TO Statement

The GO TO statement causes control to be transferred from one part of the Procedure Division to another.

ANS85 The option of omitting procedure-name-1 in a Format 1 GO TO statement is classed as an obsolete element in the ANSI'85 standard and is scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects in this COBOL implementation fully support this syntax. The FLAGSTD Compiler directive can be used to detect all occurrences of this syntax.

XOPEN Although it is a part of the standard COBOL definition, omitting the procedure-name in Format 1 is explicitly excluded from the X/Open COBOL language definitions and should not be used in an X/Open COBOL conforming source program.

General Formats for Format 1

General Formats for Format 2

Syntax Rules for All Formats

  1. Identifier is the name of a numeric elementary item which is an integer.
  2. When a paragraph is referenced by an ALTER statement, that paragraph can consist only of a paragraph header followed by a Format 1 GO TO statement.

Syntax Rules for Format 1

  3. A Format 1 GO TO statement, without procedure-name-1, can only appear in a single statement paragraph.

    MF This restriction is not enforced.

  4. If a Format 1 GO TO statement appears in a consecutive sequence of imperative statements within a sentence, it must appear as the last statement in that sequence.

Syntax Rules for Format 2

  5. In Format 2, at least two procedure-names should be specified.

    ANS85 A Format 2 statement can be written with only one procedure name.

General Rules for All Formats

  1. If procedure-name-1 is not specified in Format 1, an ALTER statement, referring to this GO TO statement, must be executed prior to the execution of this GO TO statement.

    VSC2 MF If an ALTER statement referring to the paragraph containing this GO TO statement has not been executed before this GO TO statement is executed, this GO TO statement is treated like a CONTINUE statement.

General Rules for Format 1

  2. When a GO TO statement represented by Format 1 is executed, control is transferred to procedure-name-1 or to another procedure-name if the GO TO statement has been modified by an ALTER statement.

General Rules for Format 2

  3. When a GO TO statement represented by Format 2 is executed, control is transferred to procedure-name-1, procedure-name-2, and so on, depending on the value of the identifier being 1, 2, ..., n. If the value of the identifier is anything other than the positive or unsigned integers 1, 2, ..., n, then no transfer occurs and control passes to the next statement in the normal sequence for execution.
Parent topic: Statements


The IF Statement

The IF statement causes a condition to be evaluated (see the topic Conditional Expressions in the chapter Procedure Division). The subsequent action of the runtime element depends on whether the value of the condition is true or false.

General Format

Syntax Rules

  1. Statement-1 and statement-2 represent either an imperative statement or a conditional statement optionally preceded by an imperative statement.
  2. ANS85 If the END-IF phrase is specified, the NEXT SENTENCE phrase must not be specified.

    VSC2 MF NEXT SENTENCE can be specified with END-IF.

    If the NEXT SENTENCE phrase is executed, control does not pass to the next statement following the END-IF, but instead passes to the statement after the closest following period.

General Rules

  1. The scope of an IF statement can be terminated by any of the following:
    1. ANS85 An END-IF phrase at the same level of nesting.
    2. A separator period.
    3. If nested, by an ELSE phrase associated with an IF statement at a higher level of nesting.
  2. When an IF statement is executed, the following transfers of control occur:
    1. If the condition is true, statement-1 is executed if specified. If statement-1 contains a procedure branching or conditional statement, control is explicitly transferred in accordance with the rules of that statement. If statement-1 does not contain a procedure branching or conditional statement, the ELSE phrase, if specified, is ignored and control passes to the end of the IF statement.
    2. If the condition is true and the NEXT SENTENCE phrase is specified instead of statement-1, the ELSE phrase, if specified, is ignored and control passes to the next executable sentence.
    3. If the condition is false, statement-1 or its surrogate NEXT SENTENCE is ignored, and statement-2, if specified, is executed. If statement-2 contains a procedure branching or conditional statement, control is explicitly transferred in accordance with the rules of that statement. If statement-2 does not contain a procedure branching or conditional statement, control passes to the end of the IF statement. If the ELSE statement-2 phrase is not specified, statement-1 is ignored and control passes to the end of the IF statement.
    4. If the condition is false, and the ELSE NEXT SENTENCE phrase is specified, statement-1 is ignored, if specified, and control passes to the next executable sentence.
  3. Statement-1 and/or statement-2 can contain an IF statement. In this case the IF statement is said to be nested.

    ANS85 IF statements within IF statements are considered matched IF, ELSE, and END-IF ordered combinations, proceeding from left to right. Thus, any ELSE encountered is matched with the nearest preceding IF that has not been already matched with an ELSE or has not been implicitly or explicitly terminated. Any END-IF encountered is matched with the nearest preceding IF that has not been implicitly or explicitly terminated.

Parent topic: Statements
Related information
Conditional Expressions


The INITIALIZE Statement

The INITIALIZE statement provides the ability to set selected data items to specified values.

General Format

Syntax Rules

  1. Identifier-1 must be of class alphabetic or alphanumeric or numeric

    ISO2002 MF or national or object or pointer.

  2. ISO2002 MF For each DATA-POINTER, OBJECT-REFERENCE or PROGRAM-POINTER phrase specified as the category-name in the REPLACING phrase, identifier-2 must be specified.
  3. ISO2002 MF For each of the categories data-pointer, object-reference and program-pointer specified in the REPLACING phrase, a SET statement with identifer-2 as the sending operand and an item of the specified category as the receiving operand must be valid. (See the topic The SET Statement.)

    For each of the categories other than data-pointer, object-reference or program-pointer stated in the REPLACING phrase, a MOVE statement with identifier-2 or literal-1 as the sending item and an item of the specified category as the receiving operand must be valid. (See the topic The MOVE Statement.)

  4. If the REPLACING phrase is specified, literal-1 or the data item referenced by identifier-2 is the sending operand.

    ISO2002 MF If the REPLACING phrase is not specified, the sending operand is determined according to the general rules of the INITIALIZE statement.

  5. The data item referenced by identifier-1 is the receiving area.
  6. The same category cannot be repeated in a REPLACING phrase.
  7. The description of the data item referenced by identifier-1 or any items subordinate to identifier-1 cannot contain the DEPENDING phrase of the OCCURS clause.

    VSC2 The data item referenced by identifier-1 cannot be variably located, that is, it cannot follow in the same record description an item containing the DEPENDING phrase of the OCCURS clause unless identifier-1 is subordinate to that item with the OCCURS clause.

    MF The data item referenced by identifier-1 can be variably located.

  8. The data description entry for the data item referenced by identifier-1 must not contain a RENAMES clause.
  9. VSC2 MF A floating-point data item or literal can be used anywhere a numeric identifier or literal can be specified.

General Rules

  1. The key words in category-name correspond to a category of data as defined elsewhere in this document. (See the topic Class and Category of Data in the chapter Concepts of the COBOL Language.)

    ISO2002 MF If ALL is specified in the VALUE phrase it is as if all of the categories listed in category-name were specified.

  2. Whether identifier-1 references an elementary item or a group item, the effect of the execution of the INITIALIZE statement is as though a series of implicit MOVE or SET statements, each of which has an elementary data item as its receiving operand, were executed. The sending-operands of these implicit statements are defined in general rule 4 and the receiving-operands are defined in general rule 3.

    If the category of a receiving-operand is data-pointer, object-reference, or program-pointer, the implicit statement is: SET receiving-operand TO sending-operand

    Otherwise, the implicit statement is: MOVE sending-operand TO receiving-operand.

  3. The receiving-operand in each implicit MOVE or SET statement is determined by applying the following steps in order:
    1. First, the following data items are excluded as receiving-operands:
      1. ISO2002 MF Any identifiers that are not valid receiving operands of a MOVE statement - except data items of category data-pointer, object-reference or program-pointer when dialect specified is MF15 or ISO2002.
      2. If the FILLER phrase is not specified, elementary data items with an explicit or implicit FILLER clause.
      3. Any elementary data item subordinate to identifier-1 whose data description entry contains a REDEFINES or RENAMES clause or is subordinate to a data item whose data description entry contains a REDEFINES clause. However, identifier-1 may itself have a REDEFINES clause or be subordinate to a data item with a REDEFINES clause.
    2. Second, an elementary data item is a posible receiving item if either of the following apply:
      1. It is explicitly referenced by identifier-1
      2. It is contained within the group dtat item referenced by identifier-1. If the elementary data items is a table element, each occurrence of the elementary data items is a possible receiving operand
    3. Finally, each possible receiving operand is a receiving operand if at least one of the following is true:
      1. The VALUE phrase is specified, the category of the elementary data item is one of the categories specified or implied in the VALUE phrase, and one of the following is true:
        1. Either the category of the elementary data item is data-pointer, object-reference, or program-pointer.
        2. A data-item format or table format VALUE clause is specified in the data description entry of the elementary data item.
      2. The REPLACING phrase is specified and the category of the elementary data item is one of the categories specified in the REPLACING phrase.
      3. The DEFAULT phrase is specified.
      4. Neither the REPLACING phrase nor the VALUE phrase is specified.
  4. The sending-operand in each implicit MOVE and SET statement is determined as follows:
    1. If the data item qualifies as a receiving-operand because of the VALUE phrase:
      1. ISO2002 MF If the category of the receiving-operand is data-pointer or program-pointer, the sending-operand is the predefined address NULL. This requires the INITPTR compiler directive to be set.
      2. ISO2002 MF If the category of the receiving-operand is object-reference, the sending-operand is the predefined object reference NULL. This requires the INITPTR compiler directive to be set.
      3. Otherwise, the sending-operand is determined by the literal in the VALUE clause specified in the data description entry of the data item. If the data item is a table element, the literal in the VALUE clause that corresponds to the occurrence being initialized determines the sending-operand. The actual sending-operand is a literal that, when moved to the receiving-operand with a MOVE statement, produces the same result as the initial value of the data item as produced by the application of the VALUE clause.
    2. If the data item does not qualify as a receiving-operand because of the VALUE phrase, but does qualify because of the REPLACING phrase, the sending-operand is the literal-1 or identifier-2 associated with the category specified in the REPLACING phrase.
    3. If the data item does not qualify in accordance with general rules 4a and 4b, the sending-operand used depends on the category of the receiving-operand as follows:
      Receiving operand | Figurative constant
      Alphabetic | Figurative constant alphanumeric SPACES
      Alphanumeric | Figurative constant alphanumeric SPACES
      Alphanumeric-edited | Figurative constant alphanumeric SPACES
      Data-pointer | Predefined address NULL
      National | Figurative constant national SPACES
      National-edited | Figurative constant national SPACES
      Numeric | Figurative constant ZEROES
      Numeric-edited | Figurative constant ZEROES
      Object-reference | Predefined object reference NULL
      Program-pointer | Predefined address NULL
  5. In all cases, the content of the data item referenced by identifier-1 is set to the indicated value in the order (left to right) of the appearance of identifier-1 in the INITIALIZE statement. Within this sequence, where identifier-1 references a group item, affected elementary items are initialized in the sequence of their definition in the group. For a variable-occurrence data item, the number of occurrences initialized is determined by the rules of the OCCURS clause for a receiving data item.
  6. If identifier-1 occupies the same storage area as identifier-2, the result of the execution of this statement is undefined, even if they are defined by the same data description entry. (See the topic Overlapping Operands in the chapter Procedure Division.)
Parent topic: Statements
Related information
The SET Statement
The MOVE Statement
Class and Category of Data
Overlapping Operands


The INSPECT Statement

The INSPECT statement provides the ability to tally (Format 1), replace (Format 2), tally and replace (Format 3) , convert (Format 4) and tally trailing (Format 5).

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

General Formats for Format 4

General Formats for Format 5

Syntax Rules for All Formats

  1. Identifier-1 must reference either a group item or any category of elementary item, described (either implicitly or explicitly) as USAGE IS DISPLAY.
  2. Identifier-3 ... identifier-n must reference

    MF either a group item or

    an elementary alphabetic, alphanumeric,

    ANS85 alphanumeric edited, numeric edited

    or numeric item described (either implicitly or explicitly) as USAGE IS DISPLAY.

  3. Each literal must be nonnumeric and can be any figurative constant, except ALL. If literal-1, literal-2 or literal-4 is a figurative constant, it refers to an implicit one-character data item.
  4. No more than one BEFORE phrase

    ANS85 and /;

    or one AFTER phrase can be specified for any one ALL, LEADING, CHARACTERS, FIRST

    ANS85 or CONVERTING

    phrase.

  5. Literal-1, literal-2, literal-3, literal-4, and literal-5, and the data items referenced by identifier-3, identifier-4, identifier-5, identifier-6, and identifier-7 can be any number of characters in length up to the limit allowed for literals or data items.
  6. MF All identifiers, except identifier-2 (the TALLYING field), can be external floating-point items. External floating-point items are treated as if redefined as alphanumeric with the INSPECT statement referring to the alphanumeric item.

Syntax Rules for Formats 1 and 3

  7. Identifier-2 must reference an elementary numeric data item.

Syntax Rules for Formats 2 and 3

  8. The size of the data referenced by literal-3 or identifier-5 must be equal to the size of the data referenced by literal-1 or identifier-3. When a figurative constant is used as literal-3, the size of the figurative constant is equal to the size of literal-1 or the size of the data item referenced by identifier-3.
  9. When the CHARACTERS phrase is used, literal-3 or the size of the data item referenced by identifier-5 must be one character in length.

    ANS85 This restriction does not apply to literal-2 or identifier-4.

Syntax Rules for Format 4

  10. ANS85 The size of literal-5 or the data item referenced by identifier-7 must be equal to the size of literal-4 or the data item referenced by identifier-6. When a figurative constant is used as literal-5, the size of the figurative constant is equal to the size of literal-4 or the size of the data item referenced by identifier-6.
  11. ANS85 The same character must not appear more than once either in literal-4 or in the data item referenced by identifier-6.

General Rules for All Formats

  1. ANS85 For the purpose of determining its length, identifier-1 is treated as if it were a sending data item. (See the topic The OCCURS Clause.)
  2. Inspection (which includes the comparison cycle, the establishment of boundaries for the BEFORE or AFTER phrase, and the mechanism for tallying and/or replacing) begins at the leftmost character position of the data item referenced by identifier-1, regardless of its class, and proceeds from left to right to the rightmost character position as described in General Rules 11, 12 and 13.
  3. For use in the INSPECT statement, the contents of the data item referenced by identifier-1, identifier-3, identifier-4, identifier-5, identifier-6 or identifier-7 is treated as follows:
    1. If any of identifier-1, identifier-3, identifier-4, identifier-5, identifier-6 or identifier-7 is described as alphanumeric, the INSPECT statement treats the contents of each such identifier as a character-string.
    2. If any of identifier-1, identifier-3, identifier-4, identifier-5, identifier-6 or identifier-7 is described as alphanumeric edited, numeric edited or unsigned numeric, the data item is inspected as though it had been redefined as alphanumeric (see General Rule 3a.) and the INSPECT statement had been written to reference the redefined data item.
    3. If any of identifier-1, identifier-3, identifier-4, identifier-5, identifier-6 or identifier-7 is described as signed numeric, the data item is inspected as though it had been moved to an unsigned numeric data item with length equal to the length of the signed item excluding any separate sign position and then the rules in General Rule 3b had been applied. (See the topic The MOVE Statement.)
  4. In General Rules 6 through 19, all references to literal-1, literal-2, literal-3, literal-4, and literal-5 apply equally to the contents of the data item referenced by identifier-3, identifier-4, identifier-5, identifier-6, and identifier-7, respectively.
  5. If any identifier is subscripted

    ANS85 or is a function-identifier

    , the subscript

    ANS85 or function-identifier

    is evaluated only once as the first operation in the execution of the INSPECT statement.

General Rules for Format 1

  6. ANS85 Identifier-1 is a sending data item.
  7. The required words ALL and LEADING are adjectives that apply to each succeeding literal-1 until the next adjective appears.
  8. The contents of the data item referenced by identifier-2 are not initialized by the execution of the INSPECT statement.
  9. The rules for tallying are as follows:
    1. If the ALL phrase is specified, the contents of the data item referenced by identifier-2 are incremented by one for each occurrence of literal-1 matched in the contents of the data item referenced by identifier-1.
    2. If the LEADING phrase is specified, the contents of the data item referenced by identifier-2 are incremented by one for the first and each subsequent contiguous occurrence of literal-1 matched in the contents of the data item referenced by identifier-1, provided that the leftmost such occurrence is at the point where comparison began in the first comparison cycle in which literal-1 was eligible to participate.
    3. If the CHARACTERS phrase is specified, the contents of the data item referenced by identifier-2 are incremented by one for each character matched, in the sense of Format 1 and 2, General Rule 12e, in the contents of the data item referenced by identifier-1.
  10. If identifier-1, identifier-3 or identifier-4 occupies the same storage area as identifier-2, the result of the execution of this statement is undefined, even if they are defined by the same data description entry. (See the topic Overlapping Operands.)

General Rules for Formats 1 and 2

  11. During inspection of the contents of the data item referenced by identifier-1, each properly matched occurrence of literal-1 is tallied (Format 1) or replaced by literal-3 (Format 2).
  12. The comparison operation to determine the occurrences of literal-1 to be tallied or to be replaced, occurs as follows:
    1. The operands of the TALLYING or REPLACING phrases are considered in the order they are specified in the INSPECT statement from left to right. The first literal-1 is compared to an equal number of contiguous characters, starting with the leftmost character position in the data item referenced by identifier-1. Literal-1 matches that portion of the contents of the data item referenced by identifier-1 if, and only if, they are equal, character for character, and if one of the following is true:
      1. If neither LEADING nor FIRST is specified:
      2. If the LEADING adjective applies to literal-1 and literal-1 is a leading occurrence as defined in General Rules 9 and 15:
      3. If the FIRST adjective applies to literal-1 and literal-1 is the first occurrence as defined in General Rule 9.
    2. If no match occurs in the comparison of the first literal-1, the comparison is repeated with each successive literal-1, if any, until either a match is found or there is no next successive literal-1. When there is no next successive literal-1, the character position in the data item referenced by identifier-1 immediately to the right of the leftmost character position considered in the last comparison cycle is considered as the leftmost character position, and the comparison cycle begins again with the first literal-1.
    3. Whenever a match occurs, tallying and/or replacing takes place as described in General Rules 9 and 15. The character position in the data item referenced by identifier-1 immediately to the right of the rightmost character position that participated in the match is now considered to be the leftmost character position of the data item referenced by identifier-1, and the comparison cycle starts again with the first literal-1.
    4. The comparison operation continues until the rightmost character position of the data item referenced by identifier-1 has participated in a match or has been considered as the leftmost character position. When this occurs, inspection is terminated.
    5. If the CHARACTERS phrase is specified, an implied one-character operand participates in the cycle described in paragraphs 12a through 12d above, except that no comparison to the contents of the data item referenced by identifier-1 takes place. This implied character is considered always to match the leftmost character of the contents of the data item referenced by identifier-1 participating in the current comparison cycle.
  13. The comparison operation defined in General Rule 12 is affected by the BEFORE and AFTER phrases as follows:
    1. If neither the BEFORE nor the AFTER phrase is specified, literal-1 or the implied operand of the CHARACTERS phrase is first eligible to participate in matching at the leftmost character position of identifier-1.
    2. If the BEFORE phrase is specified, the associated literal-1, or the implied operand of the CHARACTERS phrase participates only in those comparison cycles which involve that portion of the contents of the data item referenced by identifier-1 from its leftmost character position up to, but not including, the first occurrence of literal-2, in the contents of the data item referenced by identifier-1.

      The position of this first occurrence is determined before the first cycle of the comparison operation described in General Rule 12 is begun. If, on any comparison cycle, literal-1, or the implied operand of the CHARACTERS phrase is not eligible to participate, it is considered not to match the contents of the data item referenced by identifier-1. If there is no occurrence of literal-2, in the contents of the data item referenced by identifier-1, its associated literal-1, or the implied operand of the CHARACTERS phrase participates in the comparison operation as though the BEFORE phrase had not been specified.

    3. If the AFTER phrase is specified, the associated literal-1, or the implied operand of the CHARACTERS phrase can participate only in those comparison cycles which involve that portion of the contents of the data item referenced by identifier-1 from the character position immediately to the right of the rightmost character position of the first occurrence of literal-2, in the contents of the data item referenced by identifier-1 to the rightmost character position of the data item referenced by identifier-1.

      The position of this first occurrence is determined before the first cycle of the comparison operation described in General Rule 12 is begun. If, on any comparison cycle, literal-1, or the implied operand of the CHARACTERS phrase is not eligible to participate, it is considered not to match the contents of the data item referenced by identifier-1. If there is no occurrence of literal-2, in the contents of the data item referenced by identifier-1, its associated literal-1, or the implied operand of the CHARACTERS phrase is never eligible to participate in the comparison operation.

General Rules for Format 2

  14. The required words ALL, LEADING and FIRST are adjectives that apply to each succeeding BY phrase until the next adjective appears.
  15. The rules for replacement are as follows:
    1. When the CHARACTERS phrase is specified, each character matched in the sense of Format 1 and 2, General Rule 12e in the contents of the data item referenced by identifier-1, is replaced by literal-3.
    2. When the adjective ALL is specified, each occurrence of literal-1 matched in the contents of the data item referenced by identifier-1 is replaced by literal-3.
    3. When the adjective LEADING is specified, the first and each subsequent contiguous occurrence of literal-1 matched in the contents of the data item referenced by identifier-1 is replaced by literal-3, provided that the leftmost occurrence is at the point where comparison began in the first comparison cycle in which literal-1 was eligible to participate.
    4. When the adjective FIRST is specified, the leftmost occurrence of literal-1 matched in the contents of the data item referenced by identifier-1 is replaced by literal-3.
  16. If identifier-3, identifier-4 or identifier-5 occupies the same storage area as identifier-1, the result of the execution of this statement is undefined, even if they are defined by the same data description entry. (See the topic Overlapping Operands.)

General Rules for Format 3

  17. A Format 3 INSPECT statement is interpreted and executed as though two successive INSPECT statements specifying the same identifier-1 had been written with one statement being a Format 1 statement with TALLYING phrases identical to those specified in the Format 3 statement, and the other statement being a Format 2 statement with REPLACING phrases identical to those specified in the Format 3 statement. The General Rules given for matching and counting apply to the Format 1 statement and the General Rules given for matching and replacing apply to the Format 2 statement.

General Rules for Format 4

  18. ANS85 A Format 4 INSPECT statement is interpreted and executed as though a Format 2 INSPECT statement specifying the same identifier-1 had been written with a series of ALL phrases, one for each character of literal-4. The effect is as if each of these ALL phrases referenced, as literal-1, a single character of literal-4 and referenced, as literal-3, the corresponding single character of literal-5. Correspondence between the characters of literal-4 and the characters of literal-5 is by ordinal position within the data item.
  19. ANS85 If identifier-4, identifier-6 or identifier-7 occupies the same storage area as identifier-1, the result of the execution of this statement is undefined, even if they are defined by the same data description entry.

General Rules for Format 5

  1. TRAILING is an MF extension, used to find the rightmost occurrence or set of contiguous occurrences in a source data item.

  2. If a TRAILING occurrence is found, a right to left scan of the source data item is made to find contiguous occurrences.

  3. The REPLACING option enables you to replace all contiguous occurrences.

  4. The following items must be single-character items: identifier-3, identifier-4, identifier-5, literal-1, literal-2 and literal-3.

Examples

  1. Examples of using INSPECT TALLYING, REPLACING, and CONVERTING are provided in the topic INSPECT Statement (Tallying, Replacing, and Converting).
Parent topic: Statements
Related information
The OCCURS Clause
The MOVE Statement
INSPECT Statement (Tallying, Replacing, and Converting)
Overlapping Operands


The INVOKE Statement

The INVOKE statement causes a method to be invoked.

General Format

Syntax Rules

  1. Object-identifier-1 must be an object reference or a class-name.
  2. MF Identifier-1 must be a four-byte data item.
  3. Literal-1 must be an alphanumeric literal.
  4. Neither literal-1 nor literal-2 may be a figurative constant.
  5. ISO2002 If object-identifier-1 references a universal object reference, neither the BY CONTENT nor BY VALUE phrase can be specified and the BY REFERENCE phrase, if not specified explicitly, is assumed implicitly.

    MF The BY CONTENT and BY VALUE phrases can be specified.

  6. Identifier-2 must be defined as an alphanumeric data item.
  7. ISO2002 If identifier-2 is specified, object-identifier-1 must be a universal object reference.

    MF Object-identifier-1 is not required to be a universal object reference.

  8. If the data item referenced by identifier-1 is not a universal object reference, the rules for conformance as specified in the topic Conformance for Parameters and Returning Items in the chapter Procedure Division apply.
  9. If the data item referenced by identifier-1 is not a universal object reference and a BY CONTENT or BY REFERENCE phrase is specified for an argument, a BY REFERENCE phrase must be specified for the corresponding formal parameter in the PROCEDURE DIVISION header.
  10. Identifier-3 must reference a data item defined in the File, Working-Storage,

    MF Object-Storage,

    Local-Storage, or Linkage Section.

  11. MF Neither identifier-4, identifier-5, identifier-6, identifier-7, nor identifier-8 can be a function-identifier.
  12. If a BY VALUE phrase is specified for an argument, a BY VALUE phrase must be specified for the corresponding formal parameter in the PROCEDURE DIVISION header.
  13. MF Integer-1 may be signed or zero.
  14. MF GIVING and RETURNING are equivalent.
  15. MF Identifier-9 must be a data item no more than 8 bytes in size that is defined in the File, Working-Storage,

    MF Object-Storage,

    Local-Storage, or Linkage Section.

  16. MF Identifier-10 must be defined as a data item in the Linkage Section with a level number of 01 or 77.
  17. Identifier-3 is both a sending and receiving operand.
  18. Identifier-1, identifier-2, identifier-4, identifier-5, identifier-6, identifier-7, identifier-8 and any identifier specified in arithmetic-expression-1 are sending operands.
  19. Identifier-9 and identifier-10 are receiving operands.
  20. If an OMITTED phrase is specified, an OPTIONAL phrase must be specified for the corresponding formal parameter in the PROCEDURE DIVISION header.

General Rules

  1. The instance of the program, function or method that executes the INVOKE statement is the activating runtime element.
  2. Object-identifier-1

    MF or identifier-1

    identifies an object instance. If object-identifier-1 is specified as a class-name, object-identifier-1 identifies the factory object of that class-name. Literal-1 or the content of the data item referenced by identifier-2 identifies a method of that object that will act upon that object instance:

    1. If the method to be invoked is a COBOL method, literal-1 or the content of the data item referenced by identifier-2 is the name of the method to be invoked as specified in its Method-ID paragraph.

      If the object instance is identified by a universal object reference, neither a formal parameter nor the returning item in the invoked method may be described with the ANY LENGTH clause

    2. If the method to be invoked is not a COBOL method, the rules for the formation of the method-name are dependent upon the domain involved.
  3. MF The AS phrase enables you to invoke methods on a COBOL data item. If template-1 is specified, it is used as a class template. Creation of templates is a function provided by objects in the supplied Class Library. (See your COBOL system documentation for details.)
  4. When an INVOKE statement is executed, the method specified is made available for execution and control is transferred to the invoked method. If the invoked method is a COBOL method, its execution is as described in the topic General Rules in the topic The PROCEDURE DIVISION Header; otherwise, the execution is defined by the implementor of the language in which the method is written. After control is returned from the method, control is transferred to the end of the INVOKE statement.
  5. The run unit is not aware of whether an invoked method is a COBOL method or a non-COBOL method until the invoked method has been located, prior to being made available for execution. The form of the method-name cannot be used to determine whether the method is a COBOL method or not.
  6. The process of invoking a method or exiting from an invoked method does not alter the status or positioning of a file associated with any external file connector.
  7. This implementation does not maintain any synchronization between the arguments and the Linkage Section data items. That is your responsibility.
    Note: The COBOL language places no restrictions on the alignment of the addresses of data items, whereas non-COBOL languages typically do make assumptions about addresses and will fail in some way if a misaligned data item is referenced. Alignment can be achieved by one or more of the following actions:
    • Modifying group items to include additional filler items
    • Ensuring operands in the USING phrase are level 01 or level 77 data items in conjunction with the ALIGN Compiler directive or
    • Use of the SYNCHRONIZED clause in conjunction with the IBMCOMP Compiler directive

    If a RETURNING phrase is specified on the INVOKE statement, a non-COBOL method must return a result in the appropriate format.

  8. The sequence of arguments in the USING phrase of the INVOKE statement and the corresponding formal parameters in the USING phrase of the invoked method's PROCEDURE DIVISION header determines the correspondence between arguments and formal parameters. This correspondence is positional and not by name equivalence; the first argument corresponds to the first formal parameter, the second to the second, etc.

    If a parameter is an index-name, no such correspondence is established. Index-names in the invoked method and the invoking runtime element always refer to separate indices.

    The effect of the USING phrase on the activated runtime element is described in as described in the topic General Rules in the topic The PROCEDURE DIVISION Header

  9. An argument that consists merely of a single identifier or literal is regarded as an identifier or literal rather than an arithmetic expression.
  10. The values of the parameters referenced in the USING phrase of the INVOKE statement are made available to the invoked method at the time the INVOKE statement is executed.
  11. The BY CONTENT, BY REFERENCE and BY VALUE phrases are transitive across the parameters that follow them until another BY CONTENT, BY REFERENCE or BY VALUE phrase is encountered.

    If no BY CONTENT, BY REFERENCE or BY VALUE phrase is specified prior to the first parameter, the BY REFERENCE phrase is assumed.

  12. If the BY REFERENCE ADDRESS OF phrase is specified or implied then the method operates as if a data item had been declared with USAGE POINTER and that data item passed BY REFERENCE with a value acquired by a SET data item TO ADDRESS OF identifier-4 statement.
  13. If the BY CONTENT phrase is specified or implied for a parameter, the invoked method cannot change the value of this parameter as referenced in the INVOKE statement's USING phrase, although the invoked method can change the value of the data item referenced by the corresponding data-name in the invoked method's PROCEDURE DIVISION header. The data description of each parameter in the BY CONTENT phrase of the INVOKE statement must be the same, meaning no conversion or extension or truncation, as the data description of the corresponding parameter in the USING phrase of the PROCEDURE DIVISION header.

    If the BY CONTENT phrase is specified or implied for a parameter, the object program operates as if an additional data item had been declared and this additional data item used as the parameter in a BY REFERENCE phrase. If identifier-5 is specified then both the implied data description of the additional data item and its contents are identical to that of identifier-5. If literal-3 is specified then the implied data description of the additional item is equivalent to an alphanumeric data item with the same size as literal-3 and with its contents set to the value of literal-3. If LENGTH OF identifier-6 is specified, then the data description of the additional item is equivalent to PIC S9(n) USAGE COMP-5, where the value of n is at least 9 and defines a data item that is large enough to hold the maximum length of a data item in the COBOL system. The contents of the additional data item are set to the number of bytes of storage allocated to identifier-6.

  14. If the BY VALUE phrase is specified or implied for a parameter, the invoked method cannot change the value of this parameter as referenced in the INVOKE statement's USING phrase, though the invoked method can change the value of the data item referenced by the corresponding data-name in the invoked method's PROCEDURE DIVISION header. The method operates, conceptually, as if an additional data item had been declared in a system area (typically the stack), available to non-COBOL languages for passing parameters and this additional data item occupies the same storage area as the data item in the invoked method.

    If identifier-7 is specified and is BINARY, COMP-4, COMP-5 or COMP-X, then the data description of the additional data item is identical to that of identifier-7, except its usage is COMP-5. The contents of the additional data item are identical to the COMP-5 representation of the contents of identifier-7. This conversion and representation facilitates calling non-COBOL programs.

    Otherwise, if identifier-7 is specified then the implied data description of the additional data item and its contents are identical to that of identifier-7.

    If integer-1 is specified, then the data description of the additional item is equivalent to a signed numeric item USAGE COMP-5 that occupies the number of bytes of storage indicated by the value of integer-2, if specified, or the size of the system area otherwise (typically the size of a POINTER on the system).

    If LENGTH OF identifier-8 is specified, then the data description of the additional item is equivalent to PIC S9(n) USAGE COMP-5, where the value of n is at least 9 and defines a data item that is large enough to hold the maximum length of a data item in the COBOL system. The contents of the additional data item are set to the number of bytes of storage allocated to identifier-8.

    If the method being invoked is a COBOL method, each parameter in the BY VALUE phrase of the INVOKE statement must have a corresponding parameter declared in the USING phrase of the PROCEDURE DIVISION header that also has the BY VALUE phrase specified or implied.

    The additional data item generated as a result of the INVOKE statement, described above, is related to this corresponding parameter in the invoked method, as follows.

    • If the additional data item was subject to conversion from BINARY, COMP-4, COMP-5 or COMP-X to COMP-5, then the data description of the corresponding parameter in the invoked method must be identical to that of the data description of the additional data item with the exception that the corresponding parameter's usage can be any of BINARY, COMP-4, COMP-5 or COMP-X. On entry to the invoked COBOL method, a conversion from the USAGE COMP-5 of the additional data item to the USAGE of the corresponding parameter in the invoked method is performed.
    • If the additional data item was not subject to conversion to COMP-5, the data description of each parameter in the invoked method must be the same as the corresponding additional data item. This means there is no conversion or extension or truncation, of the additional data item to match the corresponding parameter in the invoked method.

    If the method being invoked is non-COBOL, the details of when you need to use the BY VALUE phrase are dependent on the domain involved.

  15. MF If identifier-4 is in the Linkage Section and has a level number other than 01 or 77 or is in the Working-Storage Section, the item is passed as if BY CONTENT had been specified and the address of identifier-4 cannot be modified by the invoked method.
  16. MF If the BY REFERENCE literal-2 phrase is specified or implied then the method processes literal-2 as described for literal-3.
  17. MF If LENGTH OF identifier-6 is specified then the data description of the argument is PIC S9(9) USAGE BINARY and its content is set to the number of bytes of storage allocated to identifier-6.
  18. MF If integer-1 is specified then the implied data description of the argument is a signed numeric item USAGE COMP-5 that occupies the number of bytes of storage specified by the value of integer-2, if specified, or 4 bytes otherwise.
  19. MF If LENGTH OF identifier-8 is specified then the data description of the argument is PIC S9(9) USAGE BINARY and its content is set to the number of bytes of storage allocated to identifier-8.
  20. MF If identifier-10 is specified, the invoked method must return a value with explicit or implicit USAGE POINTER. The result of the method is assigned to identifier-10 using the rules for the SET statement.
  21. Invoked methods may contain INVOKE statements. An invoked method may execute an INVOKE statement that directly or indirectly invokes the invoking method.
  22. If an OMITTED phrase is specified or a trailing argument is omitted, the omitted-argument condition for that parameter is true in the invoked method.
  23. If a parameter for which the omitted-argument condition is true is referenced in an invoked method, except as an argument or in the omitted-argument condition, you will get RTS error message 203.
Parent topic: Statements
Related information
Conformance for Parameters and Returning Items
The PROCEDURE DIVISION Header


The MERGE Statement

The MERGE statement combines two or more identically sequenced files on a set of specified keys, and during the process makes records available, in merged order, to an output procedure or to an output file.

General Format

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • CALLSORT"EXTSM" - enables you to specify up to 128 files in the USING or GIVING clause. Without this directive the limit is 10 file-names.

Syntax Rules

  1. File-name-1 must be described in a sort-merge file description entry in the Data Division.
  2. Procedure-name-1 represents the name of an output procedure.
  3. Procedure-name-1 and procedure-name-2 must be section-names.

    ANS85 OSVS This restriction is removed.

  4. ANS85 If the file referenced by file-name-1 contains variable length records, the size of the records contained in the files referenced by file-name-2 and file-name-3 must not be less than the smallest record, nor greater than the largest record described for file-name-1. If the file referenced by file-name-1 contains fixed length records, the size of the records contained in the files referenced by file-name-2 and file-name-3 must not be greater than the largest record described for file-name-1.
  5. File-name-2, file-name-3, and file-name-4 must be described in file description entries, not in sort-merge file description entries, in the Data Division.
  6. The words THRU and THROUGH are equivalent.
  7. Data-name-1 is a KEY data-name and is subject to the following rules:
    1. The data items identified by KEY data-names must be described in records associated with file-name-1.
    2. KEY data-names can be qualified.
    3. The data items identified by KEY data-names must not be variable length items.
    4. If file-name-1 has more than one record description, then the data items identified by KEY data-names need be described in only one of the record descriptions. The same character positions referenced by a key data-name in one record description entry are taken as the key in all records of the file.
    5. None of the data items identified by KEY data-names can be described by an entry which either contains an OCCURS clause or is subordinate to an entry which contains an OCCURS clause.
    6. OSVS VSC2 MF KEY data items can be floating-point items.
    7. OSVS VSC2 MF If the KEY is an external floating-point item, the key is treated as alphanumeric. The sequence in which the records are merged depends on the collating sequence used.
    8. OSVS VSC2 MF If the KEY is an internal floating-point item, the records are merged in numeric order.
  8. No more than one file-name from a multiple file reel can appear in the MERGE statement.
  9. File-names must not be repeated in the MERGE statement.
  10. MERGE statements can appear anywhere except in the declaratives portion of the Procedure Division.
  11. ANS85 If file-name-4 references an indexed file, the first specification of data-name-1 must be associated with an ASCENDING phrase, and the data item referenced by that data-name-1 must occupy the same character positions in its record as the data item associated with the prime record key for that file.
  12. ANS85 If the GIVING phrase is specified and the file referenced by file-name-4 contains variable length records, the size of the records contained in the file referenced by file-name-1 must not be less than the smallest record nor greater than the largest record described for file-name-4. If the file referenced by file-name-4 contains fixed length records, the size of the records contained in the file referenced by file-name-1 must not be greater than the largest record described for file-name-4.

General Rules

  1. The MERGE statement merges all records contained on the files referenced by file-name-2 and file-name-3.
  2. If the file referenced by file-name-1 contains only fixed length records, any record in the file referenced by file-name-2 or file-name-3 containing fewer character positions than that fixed length is space filled on the right, beginning with the first character position after the last character in the record, when that record is released to the file referenced by file-name-1.
  3. The data-names following the word KEY are listed from left to right in the MERGE statement in order of decreasing significance without regard to how they are divided into KEY phrases. The leftmost data-name is the major key, the next data-name is the next most significant key, and so on.
    1. When the ASCENDING phrase is specified, the merged sequence is from the lowest value of the contents of the data items identified by the key data-names to the highest value, according to the rules for comparison of operands in a relation condition.
    2. When the DESCENDING phrase is specified, the merged sequence is from the highest value of the contents of the data items identified by the key data-names to the lowest value, according to the rules for comparison of operands in a relation condition.
  4. When, according to the rules for comparison of operands in relation condition, the contents of all the key data items of one data record are equal to the corresponding key data items of one or more other data records, the order of return of these records:
    1. Follows the order of the associated input files as specified in the MERGE statement
    2. Is such that all records associated with one input file are returned prior to the return of records from another input file.
  5. The collating sequence that applies to the comparison of the nonnumeric key data items specified is determined at the beginning of the execution of the MERGE statement in the following order of precedence:
    1. First, the collating sequence established by the COLLATING SEQUENCE phrase, if specified, in that MERGE statement.
    2. Second, the collating sequence established as the program collating sequence.
  6. The results of the merge operation are undefined unless the records in the files referenced by file-name-2 and file-name-3 are ordered as described in the ASCENDING or DESCENDING KEY phrases associated with the MERGE statement.
  7. All the records in the files referenced by file-name-2 and file-name-3 are transferred to the file referenced by file-name-1. At the start of execution of the MERGE statement, the files referenced by file-name-2 and file-name-3 must not be in the open mode. For each of the files referenced by file-name-2 and file-name-3 the execution of the MERGE statement causes the following actions to be taken:
    1. The processing of the file is initiated. The initiation is performed as if an OPEN statement with the INPUT phrase had been executed. If an output procedure is specified, this initiation is performed before control passes to the output procedure.
    2. The logical records are obtained and released to the merge operation. Each record is obtained as if a READ statement with the NEXT and the AT END phrases had been executed.

      If the file referenced by file-name-1 is described with variable length records, the size of any record written to file-name-1 is the size of that record when it was read from file-name-2 or file-name-3, regardless of the content of the data item referenced in the DEPENDING ON phrase of either a RECORD IS VARYING clause or an OCCURS clause specified in the sort-merge file description entry for file-name-1.

      For a relative file, the content of the relative data key item is undefined after the execution of the MERGE statement.

    3. The processing of the file is terminated. The termination is performed as if a CLOSE statement without optional phrases had been executed. If an output procedure is specified, this termination is not performed until after control passes the last statement in the output procedure.

      These implicit functions are performed such that any associated USE AFTER EXCEPTION/ERROR procedures are executed.

      The value of the data item referenced by the DEPENDING ON phrase of a RECORD IS VARYING clause specified in the file description entry for file-name-2 or file-name-3 is undefined upon completion of the MERGE statement.

  8. The output procedure can consist of any procedure needed to select, modify or copy the records that are made available one at a time by the RETURN statement in merged order from the file referenced by file-name-1. The range includes all statements that are executed as the result of a transfer of control by CALL, EXIT, GO TO, and PERFORM statements in the range of the output procedure, as well as all statements in declarative procedures that are executed as a result of the execution of statements in the range of the output procedure. The range of the output procedure must not cause the execution of any MERGE, RELEASE, or SORT statement. (See the topic Explicit and Implicit Transfers of Control in the chapter Concepts of the COBOL Language.)
  9. If an output procedure is specified, control passes to it during execution of the MERGE statement. The compiler inserts a return mechanism at the end of the last statement in the output procedure. When control passes the last statement in the output procedure, the return statement provides for termination of the merge, and then passes control to the next executable statement after the MERGE statement. Before entering the output procedure, the merge procedure reaches a point at which it can select the next record in merged order when requested. The RETURN statements in the output procedure are the requests for the next record.
  10. During the execution of the output procedure, no statement can be executed manipulating the file referenced by, or accessing the record area associated with, file-name-2, file-name-3, or file-name-4.
  11. If the GIVING phrase is specified, all the merged records are written on the file referenced by file-name-4 as the implied output procedure for the MERGE statement. At the start of execution of the MERGE statement, the file referenced by file-name-4 must not be in the open mode. For each of the files referenced by file-name-4, the execution of the MERGE statement causes the following actions to be taken:
    1. The processing of the file is initiated. The initiation is performed as if an OPEN statement with the OUTPUT phrase had been executed.
    2. The merged logical records are returned and written onto the file. Each record is written as if a WRITE statement without any optional phrases had been executed.

      If the file referenced by file-name-4 is described with variable length records, the size of any record written to file-name-4 is the size of that record when it was read from file-name-1, regardless of the content of the data item referenced in the DEPENDING ON phrase of either a RECORD IS VARYING clause or an OCCURS clause specified in the file description entry for file-name-4.

      For a relative file, the relative key data item for the first record returned has the value 1; for the second record returned, the value 2, and so on. The content of the relative key data item is undefined after execution of the MERGE statement.

    3. The processing of the file is terminated. The termination is performed as if a CLOSE statement without optional phrases had been executed.

    These implicit functions are performed such that any associated USE AFTER EXCEPTION/ERROR procedures are executed; however, the execution of such a USE procedure must not cause the execution of any statement manipulating the file referenced by, or accessing the record area associated with, file-name-4. On the first attempt to write beyond the externally defined boundaries of the file, any USE AFTER EXCEPTION/ERROR procedure specified for the file is executed; if control is returned from the USE procedure or if no such USE procedure is specified, the processing of the file is terminated as in paragraph 11c above.

    The value of the data item referenced by the DEPENDING ON phrase of a RECORD IS VARYING clause specified in the file description entry for file-name-1 is undefined upon completion of the MERGE statement for which the GIVING phrase is specified.

  12. If the file referenced by file-name-4 contains only fixed length records, any record in the file referenced by file-name-1 containing fewer character positions than that fixed length is space filled on the right, beginning with the first character position after the last character in the record, when that record is returned to the file referenced by file-name-4.
  13. Segmentation, as defined in the topic Segmentation, can be applied to programs containing the MERGE statement. However, the following restrictions apply:
    1. If the MERGE statement appears in a section that is not in an independent segment, then any output procedure referenced by that MERGE statement must appear:
      1. Totally within non-independent segments, or
      2. Wholly contained in a single independent segment.
    2. If a MERGE statement appears in an independent segment, then any output procedure referenced by that MERGE statement must be contained:
      1. Totally within non-independent segments, or
      2. Wholly within the same independent segment as that MERGE statement.
  14. OSVS VSC2 MF The SORT-RETURN special register is available to source elements with a MERGE statement. It contains a return code of 0 (successful) or 16 (unsuccessful) at the completion of the merge operation. You can set the special register to 16 in the output procedure to terminate a merge operation before all records are processed. The operation is terminated on the next RETURN statement.
Parent topic: Statements
Related information
Segmentation
Explicit and Implicit Transfers of Control


The MOVE Statement

The MOVE statement transfers data, in accordance with the rules of editing, to one or more data areas.

General Formats for Format 1

General Formats for Format 2

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • BYTE-MODE-MOVE - impacts the behavior of MOVE statements in which the sending and receiving items share a part of their storage (that is, overlapping moves).
    • DBCS (DBSPACE) - impacts what characters are used for space-filling DBCS receiving items.
    • DE-EDIT - controls whether the value of numeric-edited sending fields is determined by their PICTURE clause or not.
    • TRUNC - determines whether truncation occurs based on the storage available or the PICTURE clause, when the sending item includes a value larger than a binary receiving value's size.

Syntax Rules for All Formats

  1. Identifier-1 and literal represent the sending area; identifier-2 represents the receiving area.
  2. An index-name or an index data item may not be specified as an operand of a MOVE statement.
  3. MF If the sending or receiving item is a pointer data item or an ADDRESS OF operand, then the other operands of the MOVE statement must also be pointer data items or ADDRESS OF operands or, in the case of the sending item, NULL.
  4. MF If the sending or receiving item is an object reference, a program-pointer, an entry-pointer, a monitor-pointer, a mutex-pointer, a semaphore-pointer or a thread-pointer, then all other operands of the MOVE statement must be of the same type or, in the case of the sending item, NULL.
  5. VSC2 MF If either the sending or receiving item is a DBCS (USAGE DISPLAY-1) item, then both must be DBCS items. The figurative constant SPACE can be the DBCS sending item.

Syntax Rules for Format 1

  6. OSVS VSC2 MF When Format 1 is specified, all identifiers can be either group or elementary items. The data in the sending area is moved into the data item referenced by each identifier-2 in the order in which it is specified.
  7. MF Identifier-1 may be a numeric function-identifier.
  8. If identifier-1 is a data item described with USAGE BINARY-CHAR, USAGE BINARY-SHORT, USAGE BINARY-LONG or USAGE BINARY-DOUBLE, identifier-2 must be a numeric or numeric-edited item; otherwise, Table 14-1, MOVE Statement Data Categories, specifies the validity of the move.

Syntax Rules for Format 2

  9. CORR is an abbreviation for CORRESPONDING.
  10. When the CORRESPONDING phrase is used, all identifiers must be group items.
  11. The following items can be part of a group that is referenced in a MOVE CORRESPONDING statement; however, no movement of this item takes place:
    • VSC2 MF POINTER, PROCEDURE-POINTER
    • ISO2002 MF OBJECT-REFERENCE, PROGRAM-POINTER
    • MF EVENT-POINTER, MONITOR-POINTER, MUTEX-POINTER, SEMAPHORE-POINTER, THREAD-POINTER.

General Rules for All Formats

  1. MF If identifier-1 is a numeric function-identifier, then identifier-2 must be either a numeric or numeric-edited item.
  2. The data designated by the literal or identifier-1 is moved to the data item referenced by each identifier-2, in the order in which it is specified. The rules referring to identifier-2 also apply to the other receiving areas. Any subscripting or indexing associated with identifier-2, is evaluated immediately before the data is moved to the respective data item.

    ANS85 If identifier-1 is reference modified, subscripted, or is a function-identifier, the reference modifier, subscript, or function-identifier is evaluated only once, immediately before data is moved to the first of the receiving operands.

    ANS85 The result of the statement:

    ANS85
     MOVE a(b) TO b, c(b)

    ANS85 is equivalent to:

    ANS85
     MOVE a(b) TO temp MOVE temp TO b MOVE temp TO c(b)

    ANS85 where temp is an intermediate result item provided by your COBOL system.

  3. Any MOVE in which the sending and receiving items are both elementary items is an elementary move. Every elementary item belongs to one of the following categories: numeric, alphabetic, alphanumeric, numeric-edited, alphanumeric-edited

    ISO2002 MF national, national-edited, boolean

    OSVS VSC2 MF or floating-point.

    These categories are described in the PICTURE clause. Numeric literals belong to the category numeric, and nonnumeric literals belong to the category alphanumeric. The figurative constant ZERO belongs to the category numeric when moved to a numeric or numeric-edited item. The figurative constant ZERO belongs to the category alphanumeric in all other cases. The figurative constant SPACE belongs to the category alphabetic. All other figurative constants belong to the category alphanumeric.

    The following rules apply to an elementary move between these categories:

    1. The figurative constant SPACE, or an alphanumeric-edited, or alphabetic data item must not be moved to a numeric or numeric-edited data item.
    2. A numeric-edited data item must not be moved to a numeric or numeric-edited data item

      ISO2002 MF , or boolean

      .

      ANS85 This restriction is removed.

    3. A numeric literal, the figurative constant ZERO, a numeric data item or a numeric-edited data item

      ISO2002 MF , or a boolean data item

      must not be moved to an alphabetic data item.
    4. A non-integer numeric literal or a non-integer numeric data item must not be moved to an alphanumeric or alphanumeric-edited data item

      ISO2002 MF , or boolean data item

      .
    5. ISO2002 MF If identifier-2 is a boolean data item, it can only receive figurative constants whose associated characters are boolean characters.
    6. ISO2002 MF An alphabetic, alphanumeric-edited, numeric, or national data item must not be moved to a boolean data item.
    7. ISO2002 MF A boolean data item must not be moved to a national data item.
    8. All other elementary moves are legal and are performed according to the rules given in General Rule 5.
  4. Any necessary conversion of data from one form of internal representation to another takes place during legal elementary moves, along with any editing specified for

    ANS85 , or de-editing implied by,

    the receiving data item:
    1. When an alphanumeric-edited or alphanumeric item is a receiving item, alignment and any necessary space-filling takes place as defined in the topic Standard Alignment Rules in the chapter Concepts of the COBOL Language. If the size of the sending item is greater than the size of the receiving item, the excess characters are truncated on the right after the receiving item is filled. If the sending item is described as being signed numeric, the operational sign is not moved; if the operational sign occupies a separate character position (see the topic The SIGN Clause), that character is not moved and the size of the sending item is considered to be one less than its actual size (in terms of standard data format characters).
    2. When a numeric or numeric-edited item is the receiving item, alignment by decimal point and any necessary zero-filling takes place as defined in the section Standard Alignment Rules in the chapter Concepts of the COBOL Language, except where zeros are replaced because of editing requirements.

      ANS85 When the sending operand is numeric-edited, de-editing is implied to establish the operand's unedited numeric value, which can be signed; then the unedited numeric value is moved to the receiving field. The effect of de-editing depends on the setting of the DE-EDIT Compiler directive

      When a signed numeric item is the receiving item, the sign of the sending item is placed in the receiving item. (See the topic The SIGN Clause.) Conversion of the representation of the sign takes place as necessary. If the sending item is unsigned, a positive sign is generated for the receiving item.

      When an unsigned numeric item is the receiving item, the absolute value of the sending item is moved and no operational sign is generated for the receiving item.

      When a data item described as alphanumeric is the sending item, data is moved as if the sending item were described as an unsigned numeric integer.

      When the receiving item is numeric or numeric-edited and the sending item is defined as alphanumeric, if the content of the sending item is not an integer, the results of the move are undefined. If the alphanumeric sending item is a literal whose contents do not represent an integer, an error is reported, and zero moved to the target. (See the topic Incompatible Data in the chapter Procedure Division.)

      ANS85 When the numeric data item is the sending item the action of the move is such that a reverse of the move would cause the same value to appear in the numeric-edited field (except for truncation). If the data item contains data which does not conform to the edited picture, zero is moved to the target.

    3. When a receiving field is described as alphabetic, justification and any necessary space-filling takes place as defined in the topic Standard Alignment Rules in the chapter Concepts of the COBOL Language. If the size of the sending item is greater than the size of the receiving item, the excess characters are truncated on the right after the receiving item is filled.
    4. OSVS VSC2 MF When the receiving field is floating-point, the sending item is converted first to internal floating-point and then moved. When data is moved to or from an external floating-point item, the data is converted first to or from its equivalent internal floating-point value.
    5. VSC2 MF When the receiving field is DBCS the sending item must be DBCS or national; no conversion takes place. If the sending and receiving items are not the same size the data item is either truncated or padded with DBCS spaces on the right.

      ISO2002 MF When the receiving field is national the sending item must be DBCS or national; no conversion takes place. If the sending and receiving items are not the same size the data item is either truncated or padded with national spaces on the right.

  5. Any move that is not an elementary move is treated exactly as if it were an alphanumeric to alphanumeric elementary move, except that no conversion of data from one form of internal representation to another takes place. In such a move, the receiving area is filled without consideration for the individual elementary or group items contained in either the sending or receiving area, except as noted in the General Rules of the OCCURS clause.
  6. The table below summarizes the legality of the various types of MOVE statements. The general rule reference indicates the rule that prohibits the move or the behavior of a legal move.
  7. ISO2002 MF When the receiving field is boolean, the boolean value of the sending item is moved, with conversion of data representation if necessary, and any necessary alignment and zero filling as defined in the topic Standard Alignment Rules in the sectionConcepts of the COBOL Language. If the sending field is not boolean, it is treated as if it were a boolean data item with the same usage and number of character positions as the sending field. If the content of the sending field would result in a false value in a boolean class condition, an error is reported (see the topic Incompatible Data in the section Procedure Division.)

General Rules for Format 2

  8. If the CORRESPONDING phrase is used, selected items in identifier-1 are moved to selected items in identifier-2, according to the rules given in The CORRESPONDING Phrase in the chapter Procedure Division. The results are the same as if you had referred to each pair of corresponding identifiers in separate MOVE statements.

    OSVS VSC2 The process is repeated for each destination group.

    Table 1. MOVE Statement Data Categories
    Category of Sending Item | Category of Receiving Data Items (the relevant rule number is quoted in these columns)
    Alphabetic | Alphanumeric-Edited/ Alpha-numeric | Numeric Integer/Non-Integer | Numeric-Edited External/Internal Floating Point | DBCS, national or national-edited | Boolean
    Alphabetic | Yes/4c | Yes/4a | No/3a | No/3a | No/4e | No/3f
    Alphanumeric | Yes/4c | Yes/4a | Yes/4b2 | Yes/4b | No/4e | Yes/3e
    Alphanumeric-Edited | Yes/4c | Yes/4a | No/3a | No/3a | No/4e | No/3f
    Numeric Integer | No/3b | Yes/4a | Yes/4b | Yes/4b | No/4e | No/3f
    Numeric Non-Integer | No/3b | No/3c | Yes/4b | Yes/4b | No/4e | No/3f
    Numeric-Edited | No/3b | Yes/4a | Yes/4b | Yes/4b | No/4e | No/3f
    DBCS national or national-edited | No/4e | No/4e | No/4e | No/4e | Yes/4e | No/3f
    Boolean | No/3c | Yes/4a | No/3b | No/3b | No/3g | Yes/4f
    Note: An error is reported if a non-integer alphanumeric literal sending item is used
Parent topic: Statements
Related reference
Undefined Results of MOVE and Arithmetic Operations
MOVE Statement
Related information
Standard Alignment Rules
The SIGN Clause
Incompatible Data
The CORRESPONDING Phrase


The MULTIPLY Statement

The MULTIPLY statement causes numeric data items to be multiplied and sets the values of data items equal to the results.

General Formats for Format 1

General Formats for Format 2

Syntax Rules for All Formats

  1. Each identifier must refer to a numeric elementary item, except that in Format 2 each identifier following the word GIVING must refer to either an elementary numeric item or an elementary numeric-edited item.
  2. Each literal must be a numeric literal.
  3. The composite of operands is determined by using all receiving data items. See the topic Arithmetic Statements in the chapter Procedure Division.
  4. OSVS VSC2 MF Floating-point data items and literals can be used anywhere a numeric data item or literal can be specified.

General Rules for All Formats

  1. See the topics The ROUNDED Phrase, The ON SIZE ERROR Phrase, Arithmetic Statements, Overlapping Operands and Multiple Results In Arithmetic Statements in the chapter Procedure Division.

General Rules for Format 1

  2. When Format 1 is used, the value of identifier-1 or literal-1 is multiplied by the value of identifier-2. The value of the multiplier (identifier-2) is replaced by this product; similarly for each successive occurrence of identifier-2 in the left-to-right order in which identifier-2 is specified.

General Rules for Format 2

  3. When Format 2 is used, the value of identifier-1 or literal-1 is multiplied by identifier-2 or literal-2 and the result is stored in the data item referenced by each identifier-3.
Parent topic: Statements
Related information
Arithmetic Statements
The ON SIZE ERROR Phrase
The ROUNDED Phrase
Overlapping Operands
Multiple Results in Arithmetic Statements


The NEXT SENTENCE Statement

The NEXT SENTENCE statement transfers control to the next COBOL sentence, that is, following the next period. It does not transfer control to the logically next COBOL verb as occurs with the CONTINUE verb.

General Format

Syntax Rules

  1. The NEXT SENTENCE statement can be used anywhere a conditional statement or an imperative-statement can be used.

General Rules

  1. The NEXT SENTENCE statement redirects the flow of execution to the logically next COBOL verb following the next period.
Parent topic: Statements


The NOTE Statement

The NOTE statement introduces a sentence or paragraph that will be treated as comments.

General Format

Syntax Rules

  1. The character-string can be any combination of characters from the computer character set.

General Rules

  1. If a NOTE statement is the first sentence of a paragraph, the entire paragraph is treated as comment.
  2. If a NOTE statement appears as other than the first sentence of a paragraph, text up to the next separator period is treated as comment.
Parent topic: Statements


The ON Statement

The ON statement allows selective execution of procedural statements on a periodic basis.

General Format

Syntax Rules

  1. Identifier-1, identifier-2 and identifier-3 must describe unsigned integer numeric elementary items.
  2. Literal-1, literal-2 and literal-3 must be unsigned numeric literals.
  3. The ON statement is not supported in class programs when compiling to managed code.

General Rules

  1. Prior to the first execution of each ON statement , a counter, implicitly defined for that ON statement (the implicit-ON-counter), is initialized to be zero.
  2. Identifier-1, identifier-2 and identifier-3 should, if specified, contain positive integer values at the time of execution of the ON statement. Varying these values between executions of the ON statement will affect subsequent executions of the ON statements.
  3. The implicit ON counter cannot be affected in any way other than by transfer of execution flow to that ON statement. (The ON counter of a called program can only be reset by the canceling of that program; execution of the EXIT PROGRAM statement and subsequent CALL of the program without intervening CANCEL has no effect upon the implicit ON counter value.)
  4. The following value-list is then evaluated:
    1. The current value of identifier-1 or literal-1,
    2. A sequence of values being the results of repeatedly adding the current value of identifier-2 or literal-2 to the current value of identifier-1 or literal-1 until the value of identifier-3 or literal-3 is reached.

    The implicit-ON-counter is then compared with each of this list of values. If an equality is found, then imperative-statement-1 is executed. If no equality is found, then imperative-statement-2, if specified, is executed.

Parent topic: Statements


The OPEN Statement

The OPEN statement initiates the processing of files. It also performs checking and/or writing of labels and other input-output operations.

ANS85 The REVERSED phrase of the OPEN statement is classed as an obsolete element in the ANSI'85 standard and is scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects in this COBOL implementation fully support this syntax. The FLAGSTD Compiler directive can be used to detect all occurrences of this syntax.

XOPEN Although it is a part of the standard COBOL definition, the REVERSED phrase of the OPEN statement is explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

MF The OPEN statement allocates system resources for a synchronization data item and initializes the data item.

General Formats for Format 1 (Record Sequential Files)

General Formats for Format 2 ( MF Line Sequential, Relative and Indexed Files)

General Formats for Format 3 (Synchronization Data Items)

Syntax Rules for All Formats (All Files)

  1. The files referenced in the OPEN statement need not all have the same organization or access.
  2. ISO2002 MF If SHARING ALL is specified and the INPUT phrase is not specified, the LOCK MODE clause must be specified in the file control entry for file-name-1.

Syntax Rules for Format 1 (Record Sequential Files)

  3. MF NO REWIND is documentary only.
  4. The I-O phrase can be used only for disk files.
  5. The EXTEND phrase must be used only for files for which the LINAGE clause has not been specified.
  6. The EXTEND phrase must not be specified with multiple file reels.
  7. The REVERSED phrase can be used only for fixed-length record sequential files.

Syntax Rules for Format 2 ( MF Line Sequential, Relative and Indexed Files)

  8. ANS85 The EXTEND phrase can be used for files in sequential access mode.
  9. ISO2002 MF The SHARING phrase must not be specified for files with line sequential organization.

Syntax Rules for Format 3 (Synchronization Data Items)

  10. MF Identifier-1 must reference an elementary data item with a USAGE of EVENT-POINTER, MONITOR-POINTER, MUTEX-POINTER or SEMAPHORE-POINTER.

General Rules for Formats 1 and 2 (All Files)

  1. Prior to the successful execution of an OPEN statement for a given file, no statement (except for a SORT or MERGE statement with the USING or GIVING phrases) can be executed that references that file, either explicitly or implicitly.
  2. ISO2002 MF The successful execution of an OPEN statement determines the availability of the file and results in the file connector referenced by the file-name being in an open mode. The successful execution of an OPEN statement associates the file with the file-name through a file connector.

    The key words INPUT, OUTPUT, I-O, and EXTEND specify the type of input-output operations intended for the file through the file connector and establish the open mode. (See table 14-4, Permissible Combinations of Statements and OPEN Modes.)

    A file is available if it is physically present and is recognized by the file handling system. Table 1, Opening Available and Unavailable Files (file not currently open), shows the results of opening available and unavailable files that are not currently open. Table 2, Opening Available Shared Files that are Currently Open by Another File Connector, shows the results of opening available and unavailable files that are currently open by another file connector.

    Table 1. Opening Available and UnavailableFiles (File not Currently Open)
    Open Mode | File is Available | File is Unavailable
    INPUT | Normal open | Open is unsuccessful
    INPUT (optional file) | Normal open | Normal open; the first read causes the at end condition or invalid key condition
    I-O | Normal open | Open is unsuccessful
    I-O (optional file) | Normal open | Open causes the file to be created
    OUTPUT | Normal open; the file contains no records | Open causes the file to be created
    EXTEND | Normal open | Open is unsuccessful
    EXTEND (optional file) | Normal open | Open causes the file to be created
    Table 2. Opening Available SharedFiles that are Currently Open by Another File Connector
    Open request | Most Restrictive Existing Sharing Mode and Open Mode
    Sharing with no Other | Sharing with Read Only | Sharing with All Other
    extend/ I-O/ input/ output | extend/ I-O/ output | input | extend/ I-O/ output | input
    SHARING WITH NO OTHER | EXTEND/ I-O/ INPUT/ OUTPUT/ | Unsuccessful open | Unsuccessful open | Unsuccessful open | Unsuccessful open | Unsuccessful open
    SHARING WITH READ ONLY | EXTEND/ I-O | Unsuccessful open | Unsuccessful open | Unsuccessful open | Unsuccessful open | Normal open
    INPUT | Unsuccessful open | Unsuccessful open | Normal open | Unsuccessful open | Normal open
    OUTPUT | Unsuccessful open | Unsuccessful open | Unsuccessful open | Unsuccessful open | Unsuccessful open
    SHARING WITH ALL OTHER | EXTEND/ I-O | Unsuccessful open | Unsuccessful open | Unsuccessful open | Normal open | Normal open
    INPUT | Unsuccessful open | Normal open | Normal open | Normal open | Normal open
    OUTPUT | Unsuccessful open | Unsuccessful open | Unsuccessful open | Unsuccessful open | Unsuccessful open
  3. The successful execution of an OPEN statement makes the associated record area available .
  4. In Table 3, "X" at an intersection indicates that the specified statement, used in the access mode given for that row, can be used with the open mode given at the top of the column.
    File Access Mode | OPEN Mode
    Statement | Input | Output | Input-Output | Extend
    Sequential | READ | X | X
    WRITE | X | X
    REWRITE | X
    Random (Non-Sequential Files) | READ | X | X
    WRITE | X | X
    REWRITE | X
    START
    DELETE | X
    Dynamic (Non-Sequential Files) | READ | X | X
    WRITE | X | X
    REWRITE | X
    START | X | X
    DELETE | X
    Note: The START and DELETE statements cannot be used with record

    MF or line

    sequential files.
  5. MF If the WITH LOCK phrase is specified, the OPEN statement acquires a lock on the whole file. (This is equivalent to specifying LOCK MODE IS EXCLUSIVE in the SELECT statement for the file. See the topic The File Control Entry in the chapter Environment Division.)
  6. ANS85 If, during the execution of an OPEN statement, a file attribute conflict occurs, the execution of the OPEN statement is unsuccessful. Your COBOL system defines which of the fixed file attributes are validated during the execution of the OPEN statement. See your file handling documentation for more details. The validation of fixed file attributes can vary depending on the organization and/or storage medium of the file.
  7. ANS85 A file can be opened with the INPUT, OUTPUT, EXTEND and I-O phrases in the same run unit. Following the initial execution of an OPEN statement for a file connector, each subsequent OPEN statement execution for that same file connector must be preceded by the execution of a CLOSE statement for that file connector, even if the file is optional.
  8. Execution of the OPEN statement does not obtain or release the first data record.
  9. The external name of the file specified in the SELECT clause for a file is processed as follows:
    1. When the INPUT phrase is specified, execution of the OPEN statement causes the name to be checked in accordance with the operating system conventions for opening files for input.
    2. When the OUTPUT phrase is specified, execution of the OPEN statement causes the name to be checked in accordance with the operating system conventions for opening files for output.
  10. The file description entry for file-name-1, file-name-2, file-name-3, and file-name-4 must be equivalent to that used when this file was created.
  11. For files being opened with the INPUT or I-O phrase, the OPEN statement sets the file position indicator to the first record currently existing in the file for indexed and sequential files, and record position one for relative files. If no records exist in the file, the file position indicator is set such that the next executed READ statement for an indexed or sequential file will result in an AT END condition. If the file does not exist, OPEN INPUT causes an error status, unless the file is optional.
  12. When the I-O phrase is specified and the LABEL RECORDS clause indicates label records are present, the execution of the OPEN statement includes the following steps:
    1. The labels are checked in accordance with the operating system-specified conventions for input-output label checking.
    2. The new labels are written in accordance with the operating system-specified conventions for input-output label writing.
  13. Upon successful execution of an OPEN statement with the OUTPUT phrase specified, a file is created. At that time the associated file contains no data records. If a file of the same name exists it is deleted. If the file is write-protected an error occurs.
  14. ANS85 When the EXTEND phrase is specified, the OPEN statement positions the file immediately after the last logical record for that file. The last logical record for a sequential file is the last record written in the file. In a relative file it is the currently existing record with the highest relative record number, and in an indexed file it is the currently existing record with the highest prime key value.
  15. Execution of the OPEN statement causes the value of the FILE STATUS data item to be updated (see the topic I-O Status in the chapter Procedure Division).
  16. MF When LOCK MODE IS EXCLUSIVE is specified in the SELECT/ ASSIGN statement of a file, successful execution of an OPEN statement of that file locks the file exclusively to that run unit.
  17. MF When LOCK MODE IS AUTOMATIC or LOCK MODE IS MANUAL is specified in the SELECT/ASSIGN statement of a file, the file that is referred to is shareable. More than one run unit can successfully open such a file.
  18. MF A file opened for OUTPUT, and relative and indexed files opened EXTEND, are implicitly defined as files with an exclusive lock, that is, they are not shareable.
  19. MF Only shareable files opened for I-O can acquire record locks.
  20. If execution of the OPEN statement is unsuccessful, the physical file is not affected and the following actions take place in this order:
    1. A value is placed in the I-O status associated with file-name to indicate the condition that caused the OPEN statement to be unsuccessful.
    2. Any applicable USE AFTER EXCEPTION procedure is executed. (See the topic The USE Statement.)
  21. The I-O phrase permits the opening of a file for both input and output operations. If the file does not exist, the following rules apply:
    1. If the OPTIONAL phrase is specified in the SELECT clause for the file, the file is created
    2. If the NOT OPTIONAL phrase is specified in the SELECT clause for the file, an error occurs
    3. If neither phrase is specified, and the directive OPTIONAL-FILE was specified when the source element was compiled, the file is created.
    4. If neither phrase is specified, and the directive NOOPTIONAL-FILE was specified when the source element was compiled, an error occurs.
  22. If an input file is designated with the OPTIONAL phrase in its SELECT clause, when the file is opened there is an interrogation for the presence or absence of this file. If the file is not present, the first READ statement for this file causes the AT END condition to occur.
  23. When the EXTEND phrase is specified, the OPEN statement positions the file immediately following the last logical record of that file. Subsequent WRITE statements referencing the file will add records to the file as though the file had been opened with the OUTPUT phrase. If the file does not exist it is created.
  24. ANS85 When the EXTEND phrase is specified and the LABEL RECORDS clause in this file's FD indicates label records are present, the execution of the OPEN statement includes the following steps:
    1. The beginning file labels are processed only in the case of a single reel/unit file.
    2. The beginning reel/unit labels on the last existing reel/unit are processed as though the file was being opened with the INPUT phrase.
    3. The existing ending file labels are processed as though the file is being opened with the INPUT phrase. These labels are then deleted.
    4. Processing then proceeds as though the file had been opened with the OUTPUT phrase.
  25. The I-O phrase permits the opening of a file for both input and output operations,

    MF except files with ORGANIZATION LINE SEQUENTIAL.

    If the file does not exist, it is created and used as an empty file for input

    MF unless NOT OPTIONAL was specified in the SELECT statement.

    An attempt to READ from the newly created file causes an error.

  26. ISO2002 MF The SHARING phrase can be specified only for shared files. (See the topic Sharing Mode in the chapter Language Fundamentals.)
  27. ISO2002 MF The SHARING phrase specifies what operations may be performed on the file through other file connectors sharing the file. (See the topic Sharing Mode in the chapter Language Fundamentals.)
  28. ISO2002 MF The SHARING phrase overrides any SHARING clause in the file control entry of the file connector associated with the file-name. If there is no SHARING phrase on the OPEN statement, then file sharing is completely specified in the file control entry. If neither a SHARING phrase on the OPEN statement nor a SHARING clause in the file control entry is specified, the sharing mode is established for the file connector in accordance with the rules specified in the topic Language Fundamentals in the chapter Language Fundamentals.

General Rules for Format1 (Record Sequential Files)

  29. If the storage medium for the file permits rewinding, the following rules apply:
    1. Execution of the OPEN statement causes the file to be positioned at its beginning.
    2. When the REVERSED phrase is specified, the file is positioned at its end by execution of the OPEN statement.
  30. When the REVERSED phrase is specified, the subsequent READ statements for the file make the data available in reversed order; that is, starting with the last record.

General Rules for Format 2 ( Line Sequential Files)

  31. MF I-O mode is not allowed for line sequential files unless the REWRITE-LS Compiler directive is set.

General Rules for Format 3 (Synchronization Data Items)

  32. MF Prior to the successful execution of an OPEN statement for a given synchronization data item, no statement can be executed that references that data item.
  33. MF The successful execution of an OPEN statement determines the availability of the synchronization data item.
  34. MF Execution of the OPEN statement causes the RETURN-CODE special register to be updated with one of the values specified for the synchronization item library routines.
  35. MF Following the initial execution of an OPEN statement for a synchronization data item, each subsequent OPEN statement execution for that same data item must be preceded by the execution of a CLOSE statement for that data item.
  36. MF If identifier-1 references an event data item, the execution of the OPEN statement initializes the data item to FALSE.
  37. MF If identifier-1 references a monitor data item, the execution of the OPEN statement initializes the monitor to NOT BROWSING, NOT READING, and NOT WRITING.
  38. MF If identifier-1 references a mutex data item, the execution of the OPEN statement initializes the data item to OFF.
  39. MF If identifier-1 references a semaphore data item, the execution of the OPEN statement initializes the data item to zero.
Parent topic: Statements
Related reference
File and Record Locking
Related information
The File Control Entry
I-O Status
The USE Statement
Sharing Mode


The PERFORM Statement

The PERFORM statement is used to transfer control explicitly to one or more procedures and to return control implicitly whenever execution of the specified procedure is complete.

ANS85 The PERFORM statement is used to control execution of one or more imperative statements which are in the scope of that PERFORM statement.

NET JVM The PERFORM statement is used to process each element of an array.

See also the section The EXIT Statement.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

General Formats for Format 4

General Formats for Format 5

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directive may impact either the syntax or the semantics described in this section.
    • PERFORM-TYPE - controls the handling of overlapping PERFORM ranges.

Syntax Rules for All Formats

  1. ANS85 If procedure-name-1 is omitted, imperative-statement-1 and the END-PERFORM phrase must be specified; if procedure-name-1 is specified, imperative-statement-1 and the END-PERFORM phrase must not be specified.

    MF When imperative-statement-1 is specified, the END-PERFORM phrase is optional.

    COB370 Procedure-name-1 and imperative-statement-1 may both be omitted.

  2. The words THROUGH and THRU are equivalent.
  3. Where procedure-name-1 and procedure-name-2 are both specified and either is the name of a procedure in the declaratives portion of the Procedure Division, both must be procedure-names in the same declarative section.

Syntax Rules for Formats 2 and 4

  4. Each identifier represents a numeric elementary item described in the Data Division. In Format 2, identifier-1 must be described as a numeric integer.
  5. OSVS VSC2 MF Floating-point data items and literals can be used anywhere a numeric data item or literal can be specified. They cannot be used where an integer is required.

Syntax Rules for Format 3

  6. If the TEST phrase is specified, the EXIT phrase must not be specified.

Syntax Rules for Formats 3 and 4

  7. ANS85 If neither the TEST BEFORE nor the TEST AFTER phrase is specified, the TEST BEFORE phrase is assumed.
  8. Condition-1, condition-2, ... , can be any conditional expression. (See the section Conditional Expressions in the chapter Procedure Division)

Syntax Rules for Format 4

  9. ANS85 In Format 4, if procedure-name-1 is omitted, the AFTER phrase must not be specified.

    ISO2002 MF This restriction does not apply.

  10. Each literal represents a numeric literal.
  11. If an index-name is specified in the VARYING or AFTER phrase, then:
    1. The identifier in the associated FROM and BY phrases must reference an integer data item.
    2. The literal in the associated FROM phrase must be a positive integer.
    3. The literal in the associated BY phrase must be a nonzero integer.
  12. If an index-name is specified in the FROM phrase, then:
    1. The identifier in the associated VARYING or AFTER phrase must reference an integer data item.
    2. The identifier in the associated BY phrase must reference an integer data item.
    3. The literal in the associated BY phrase must be an integer.
  13. The literal in the BY phrase must not be zero.
  14. Two AFTER phrases are permitted in Format 4 of the PERFORM statement.

    ANS85 Six AFTER phrases are permitted in Format 4 of the PERFORM statement.

    MF This limit is raised to fifteen.

Syntax Rules for Format 5

  15. NET JVM Identifier-9 must be an instance of a collection class, i.e. a class that has a GetEnumerator method returning a type that:
    1. contains a public instance method called MoveNext with no parameters;
    2. contains a public instance get property called Current. The type of this property is known as the element type of identifier-9.
    Any class that implements the System.Collections.IEnumerable interface satisfies the above rules and is therefore a collection class. All .NET arrays are such collection classes, as are the various Dictionary and List classes defined in the .NET framework.
  16. NET JVM It must be possible to perform a casting operation from the element type of identifier-9 to the type of identifier-8.

General Rules for All Formats

  1. When procedure-name-1 is specified, the PERFORM statement is referred to as an out-of-line PERFORM statement;

    ANS85 when procedure-name-1 is omitted, the PERFORM statement is referred to as an in-line PERFORM statement.

  2. The statements contained within the range of procedure-name-1 (through procedure-name-2 if specified) for an out-of-line PERFORM statement

    ANS85 or contained in the PERFORM statement itself for an in-line PERFORM statement

    are referred to as the specified set of statements.

  3. ANS85 The END-PERFORM phrase delimits the scope of the in-line PERFORM statement. (See the topic Explicit and Implicit Scope Terminators in the chapter Concepts of the COBOL Language.)
  4. ANS85 An in-line PERFORM statement functions according to the following general rules for an otherwise identical out-of-line PERFORM statement, with the exception that the statements contained within the in-line PERFORM statement are executed in place of the statements contained within the range of procedure-name-1 (through procedure-name-2 if specified). Unless specifically qualified by the word in-line or out-of-line, all the general rules which apply to the out-of-line PERFORM statement also apply to the in-line PERFORM statement.
  5. When the PERFORM statement is executed, control is transferred to the first statement of the specified set of statements (except as indicated in General Rules 8b, 8c, 8d and 8e). This transfer of control occurs only once for each execution of a PERFORM statement. For those cases where a transfer of control to the specified set of statements does take place, an implicit transfer of control to the end of the PERFORM statement is established as follows:
    1. If procedure-name-1 is a paragraph-name and procedure-name-2 is not specified, the return is after the last statement of procedure-name-1.
    2. If procedure-name-1 is a section-name and procedure-name-2 is not specified, the return is after the last statement of the last paragraph in procedure-name-1.
    3. If procedure-name-2 is specified and it is a paragraph-name, the return is after the last statement of the paragraph.
    4. If procedure-name-2 is specified and it is a section-name, the return is after the last statement of the last paragraph in the topic.
    5. ANS85 If an in-line PERFORM statement is specified, an execution of the PERFORM statement is completed after the last statement contained within it has been executed.
    6. MF An EXIT PERFORM statement can be used to exit an in-line perform before executing all statements within the in-line perform.
  6. There is no necessary relationship between procedure-name-1 and procedure-name-2 except that a consecutive sequence of operations is to be executed beginning at the procedure named procedure-name-1 and ending with the execution of the procedure named procedure-name-2. In particular, GO and PERFORM statements can occur between procedure-name-1 and the end of procedure-name-2. If there are two or more logical paths to the return point, then procedure-name-2 can be the name of a paragraph consisting of the EXIT statement, to which all of these paths must lead.
  7. If control passes to the specified set of statements by means other than a PERFORM statement, control passes through the last statement of the set to the next executable statement as if no PERFORM statement referenced the set.
  8. The PERFORM statements operate as follows:
    1. Format 1 is the basic PERFORM statement. The specified set of statements referenced by this type of PERFORM statement is executed once and then control passes to the end of the PERFORM statement.
    2. Format 2 is the PERFORM ... TIMES. The specified set of statements is performed the number of times specified by integer-1 or by the initial value of the data item referenced by identifier-1 for that execution. If at the time of the execution of a PERFORM statement, the value of the data item referenced by identifier-1 is equal to zero or is negative, control passes to the end of the PERFORM statement. Following the execution of the specified set of statements the specified number of times, control is transferred to the end of the PERFORM statement.

      During execution of the PERFORM statement, reference to identifier-1 cannot alter the number of times the specified set of statements is to be executed from that which was indicated by the initial value of the data item referenced by identifier-1.

      Integer-1 must be zero or positive, but it may be signed.

    3. Format 3 is the PERFORM ... UNTIL. The specified set of statements is performed until the condition specified by the UNTIL phrase is true. When the condition is true, control is transferred to the end of the PERFORM statement. If the condition is true when the PERFORM statement is entered,

      ANS85 and the TEST BEFORE phrase is specified or implied,

      no transfer to procedure-name-1 takes place, and control is passed to the end of the PERFORM statement.

      ANS85 If the TEST AFTER phrase is specified, the PERFORM statement functions as if the TEST BEFORE phrase were specified except that the condition is tested after the specified set of statements has been executed. Any subscripting or reference modification associated with the operands specified in condition-1 is evaluated each time the condition is tested.

      MF When UNTIL EXIT is specified, the specified set of statements is performed repeatedly until some statement in the set causes this repetition to end. In the case of an out-of-line PERFORM, the only statements that will cause this termination are statements such as EXIT PROGRAM and STOP RUN. In the case of an in-line PERFORM, the repetition can also be terminated by the EXIT PERFORM statement and the GO TO statement.

    4. Format 4 is the PERFORM ... VARYING. This variation of the PERFORM statement is used to augment the values referenced by one or more identifiers or index-names in an orderly fashion during the execution of a PERFORM statement. In the following discussion, every reference to identifier as the object of the VARYING, AFTER, and FROM (current value) phrases also refers to index-names.

      If index-name-1 is specified, the value of identifier-3, index-name- 2, or literal-1 at the beginning of the execution of the PERFORM statement must correspond to an occurrence number of an element in the table associated with index-name-1. If index-name-3 is specified, the value of identifier-6, index-name-4, or literal-3 at the beginning of the execution of the PERFORM statement must correspond to an occurrence number of an element in the table associated with index-name-3.

      Subsequent augmentation, as described below, of index-name-1 or index-name-3 must not result in the associated index being set to a value outside the range of the table associated with index-name-1 or index-name-3; except that, at the completion of the PERFORM statement, the index associated with index-name-1 can contain a value that is outside the range of the associated table by one increment or decrement value.

      If identifier-2 or identifier-5 is subscripted, the subscripts are evaluated each time the content of the data item referenced by the identifier is set or augmented. If identifier-3, identifier-4, identifier-6, or identifier-7 is subscripted, the subscripts are evaluated each time the content of the data item referenced by the identifier is used in a setting or augmenting operation. Any subscripting or reference modification associated with the operands specified in condition-1 or condition-2 is evaluated each time the condition is tested.

      Representations of the actions of several types of Format 4 PERFORM statements are given on the following pages.

      1. If the TEST BEFORE phrase is specified or implied:

        When the data item referenced by one identifier is varied, the content of the data item referenced by identifier-2 is set to literal-1 or the current value of the data item referenced by identifier-3 at the point of initial execution of the PERFORM statement; then, if the condition of the UNTIL phrase is false, the specified set of statements is executed once. The value of the data item referenced by identifier-2 is augmented by the specified increment or decrement value (literal-2 or the value of the data item referenced by identifier-4) and condition-1 is evaluated again. The cycle continues until this condition is true, at which point control is transferred to the end of the PERFORM statement. If condition-1 is true at the beginning of execution of the PERFORM statement, control is transferred to the end of the PERFORM statement. See the diagram below.

        The VARYING Option of a PERFORM Statement with the TEST BEFORE Phrase Having One Condition

        When the data items referenced by two identifiers are varied, the content of the data item referenced by identifier-2 is set to literal-1 or the current value of the data item referenced by identifier-3 and then the content of the data item referenced by identifier-5 is set to literal-3 or the current value of the data item referenced by identifier-6. See the diagram of The VARYING Option of a PERFORM Statement with the TEST BEFORE Phrase Having Two Conditions below.

        After the contents of the data items referenced by the identifiers have been set, condition-1 is evaluated; if true, control is transferred to the end of the PERFORM statement; if false, condition-2 is evaluated. If condition-2 is false, the specified set of statements is executed once, then the content of the data item referenced by identifier-5 is augmented by literal-4 or the content of the data item referenced by identifier-7 and condition-2 is evaluated again.

        This cycle of evaluation and augmentation continues until this condition is true. When condition-2 is true, the content of the data item referenced by identifier-2 is augmented by literal-2 or the content of the data item referenced by identifier-4, the content of the data item referenced by identifier-5 is set to literal-3 or the current value of the data item referenced by identifier-6, and condition-1 is reevaluated. The PERFORM statement is completed if condition-1 is true; if not, the cycle continues until condition-1 is true.

        At the termination of the PERFORM statement, the data item referenced by identifier-5 contains literal-3 or the current value of the data item referenced by identifier-6. The data item referenced by identifier-2 contains a value that exceeds the last used setting by one increment or decrement value, unless condition-1 was true when the PERFORM statement was entered, in which case the data item referenced by identifier-2 contains literal-1 or the current value of the data item referenced by identifier-3.

        Figure 1. The VARYING Option of a PERFORM Statement with the TEST BEFORE Phrase Having Two Conditions
        The VARYING Option of a PERFORM Statement with the TEST BEFORE Phrase Having Two Conditions
      2. ANS85 If the TEST AFTER phrase is specified:

        When the data item referenced by one identifier is varied, the content of the data item referenced by identifier-2 is set to literal-1 or the current value of the data item referenced by identifier-3 at the point of execution of the PERFORM statement; then the specified set of statements is executed once and condition-1 of the UNTIL phrase is tested. If the condition is false, the value of the data item referenced by identifier-2 is augmented by the specified increment or decrement value (literal-2 or the value of the data item referenced by identifier-4) and the specified set of statements is executed again. The cycle continues until condition-1 is tested and found to be true, at which point control is transferred to the end of the PERFORM statement. See the diagram below.

        The VARYING Option of a PERFORM Statement with the TEST AFTER Phrase Having One Condition

        When the data items referenced by two identifiers are varied, the content of the data item referenced by identifier-2 is set to literal-1 or the current value of the data item referenced by identifier-3; then the current value of the data item referenced by identifier-5 is set to literal-3 or the current value of the data item referenced by identifier-6; and the specified set of statements is then executed. Condition-2 is then evaluated; if false, the content of the data item referenced by identifier-5 is augmented by literal-4 or the content of the data item referenced by identifier-7 and the specified set of statements is again executed. The cycle continues until condition-2 is again evaluated and found to be true, at which time condition-1 is evaluated. If false, the content of the data item referenced by identifier-2 is augmented by literal-2 or the content of data item referenced by identifier-4, the content of the data item referenced by identifier-5 is set to literal-3 or the current value of the data item referenced by identifier-6 and the specified set of statements is again executed. This cycle continues until condition-1 is again evaluated and found to be true, at which time control is transferred to the end of the PERFORM statement. See the diagram The VARYING Option of a PERFORM Statement with a TEST AFTER Phrase Having Two Conditions below.

        After completion of the PERFORM statement, each data item varied by an AFTER or VARYING phrase contains the same value it contained at the end of the most recent execution of the specified set of statements.

        Figure 2. The VARYING Option of a PERFORM Statement with a TEST AFTER Phrase Having Two Conditions
        The VARYING Option of a PERFORM Statement with a TEST AFTER Phrase Having Two Conditions

        During the execution of the specified set of statements associated with the PERFORM statement, any change to the VARYING variable (the data item referenced by identifier-2 and index-name-1), the BY variable (the data item referenced by identifier-4), the AFTER variable (the data item referenced by identifier-5 and index-name-3), or the FROM variable (the data item referenced by identifier-3 and index-name-2) is taken into consideration and affects the operation of the PERFORM statement.

        When the data items referenced by two identifiers are varied, the data item referenced by identifier-5 goes through a complete cycle (FROM, BY, UNTIL) each time the content of the data item referenced by identifier-2 is varied. When the contents of three or more data items referenced by identifiers are varied, the mechanism is the same as for two identifiers except that the data item being varied by each AFTER phrase goes through a complete cycle each time the data item being varied by the preceding AFTER phrase is augmented.

    5. NET JVM Format 5 is the PERFORM VARYING ... THROUGH. This variation of the PERFORM statement is used to set the values referenced by identifier-8 to access every element of collection during the execution of a PERFORM statement. The specified set of statements is performed once for each element of the collection referenced by identifier-9. Following the execution of the specified set of statements for each element of the collection, control is transferred to the end of the PERFORM statement. During execution of the PERFORM statement, reference to identifier-8 or identifier-9 cannot alter the number of times the specified set of statements is to be executed from that which was indicated by the initial size of the collection referenced by identifier-9.
  9. The range of a PERFORM statement consists logically of all those statements that are executed as a result of executing the PERFORM statement through execution of the explicit transfer of control to the end of the PERFORM statement. The range includes all statements that are executed as the result of a transfer of control by CALL, EXIT, GO TO and PERFORM statements in the range of the PERFORM statement, as well as all statements in declarative procedures that are executed as a result of the execution of statements in the range of the PERFORM statement. The statements in the range of a PERFORM statement need not appear consecutively in the source element.
  10. Statements executed as the result of a transfer of control caused by executing an EXIT PROGRAM statement are not considered to be part of the range of the PERFORM statement when both of the following conditions apply:
    1. The EXIT PROGRAM statement is specified in the same program in which the PERFORM statement is specified
    2. The EXIT PROGRAM statement is within the range of the PERFORM statement.
  11. If the range of a PERFORM statement includes another PERFORM statement, the sequence of procedures associated with the included PERFORM should itself either be totally included in, or totally excluded from, the logical sequence referred to by the first PERFORM. Thus, an active PERFORM statement, whose execution point begins within the range of another active PERFORM statement should not allow control to pass to the exit of the other active PERFORM statement; furthermore, two or more such active PERFORM statements should not have a common exit.

    MF These restrictions are not enforced. PERFORM statements can be freely nested, and recursion (a PERFORM statement performing a procedure containing it) is allowed. Only the exit point of the innermost PERFORM statement currently being executed is recognized. These rules can be changed by use of the PERFORM-TYPE Compiler directive.

    See the following illustrations for examples of legal PERFORM constructs.

  12. A PERFORM statement that appears in a section that is not in an independent segment can have within its range, in addition to any declarative sections whose execution is caused within that range, one of the following:
    1. Sections and/or paragraphs wholly contained in one or more non-independent segments.
    2. Sections and/or paragraphs wholly contained in a single independent segment.

    OSVS VSC2 These restrictions do not apply.

  13. A PERFORM statement that appears in an independent segment can have within its range, in addition to any declarative sections whose execution is caused within that range, only one of the following:
    1. Sections and/or paragraphs wholly contained in one or more non-independent segments.
    2. Sections and/or paragraphs wholly contained in the same independent segment as that PERFORM statement.

    OSVS VSC2 These restrictions do not apply.

General Rules for Format 4

  14. The data items referenced by identifier-4 and identifier-7 must not have a zero value.
  15. If an index-name is specified in the VARYING or AFTER phrase, and an identifier is specified in the associated FROM phrase, the data item referenced by the identifier must have a positive value.
Parent topic: Statements
Related reference
PERFORM Statement
Related information
The EXIT Statement
Conditional Expressions
Explicit and Implicit Scope Terminators


The RAISE Statement

The RAISE statement raises an exception.

General Formats

Syntax Rules

  1. Identifier-1 must be an object reference of class System.Exception or a subclass of System.Exception.

General Rules

  1. If identifier-1 is specified, it is raised as an exception.
  2. If identifier-1 is not specified, the current exception is re-raised.
Parent topic: Statements


The READ Statement

For sequential access, the READ statement makes available the next

MF or previous

logical record from a file. For random access, the READ statement makes available a specified record from a mass storage file.

General Formats for Format 1 (Record Sequential Files)

General Formats for Format 2 (Line Sequential Files)

General Formats for Format 3 (Relative and Indexed Files)

General Formats for Format 4 (Relative Files)

General Formats for Format 5 (Indexed Files)

Directives and RTS switches

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directive may impact either the syntax or the semantics described in this section.
    • RETRYLOCK - causes the COBOL system to retry to read a locked record.
  2. The following RTS switches may impact the semantics described in this section.
    • B, B1 - causes the record pointer to be updated past any locked record encountered when executing a READ NEXT statement.
    • N - controls the interpretation of null characters before control characters when reading line sequential records.
    • T - controls the interpretation of tab characters when writing line sequential records.

Syntax Rules for All Formats (All Files)

  1. The INTO phrase must not be used when the input file contains logical records of various sizes as indicated by their record descriptions.

    ANS85 This restriction is removed.

    The storage area associated with identifier and the storage area which is the record area associated with file-name must not be the same storage area.

  2. OSVS VSC2 MF Identifier can be a floating-point data item.
  3. The INVALID KEY phrase or the AT END phrase must be specified if no applicable USE procedure is specified for file-name.

    OSVS VSC2 MF This rule is not enforced.

Syntax Rules for Formats 1, 3, 4 and 5 (Record Sequential,Relative and Indexed Files)

  4. MF The WITH LOCK phrase can be included only when single records are being locked manually in a shareable file.
  5. MF The WITH NO LOCK phrase is only allowed when records are being locked manually or automatically in a shareable file.

Syntax Rules for Format 3 (Relative and Indexed Files)

  6. The NEXT

    MF or PREVIOUS

    phrases must be specified for files in dynamic access mode when records are to be retrieved sequentially.

Syntax Rules for Formats 3, 4 and 5 (Relative and IndexedFiles)

  7. MF The WITH KEPT LOCK phrase can be included only when multiple records are being locked manually in a shareable file.

Syntax Rules for Formats 4 and 5 (Relative andIndexed Files)

  8. Format 4 or 5 is used for files in random access mode or for files in dynamic access mode when records are to be retrieved randomly.

Syntax Rules for Format 5 (IndexedFiles)

  9. Data-name

    ISO2002 MF or split-key-name

    must be the name of a data item specified as a record key associated with file-name.

    OSVS MF Data-name may also be a redefinition of a data-item specified as a record key associated with a file-name, provided the data-name has the same length as that data-item.

    OSVS The redefinition may have a different length from the record key.

  10. Data-name

    ISO2002 MF or split-key-name

    can be qualified.
  11. MF Split-key-name is a concatenation of one or more data items specified as a record key associated with file-name.

General Rules for All Formats (All Files)

  1. The associated file must be open in the INPUT or I-O mode at the time the statement is executed. (See the topic The OPEN Statement.)
  2. The execution of the READ statement causes the value of the FILE STATUS data item, if any, associated with file-name to be updated. (See the topic I-O Status in the chapter Procedure Division.)
  3. When the logical records of a file are described by more than one record description, these records automatically share the same storage area; this is equivalent to an implicit redefinition of the area. The contents of any data items which lie beyond the range of the current data record are undefined at the completion of the execution of the READ statement.
  4. If the INTO phrase is specified, the record being read is moved from the record area to the area specified by identifier according to the rules specified for the MOVE statement without the CORRESPONDING phrase. The implied MOVE does not occur if execution of the READ statement was unsuccessful. Any subscripting or indexing associated with identifier is evaluated after the record has been read and immediately before it is moved to the data item.
  5. When the INTO phrase is used, the record being read is available in both the input record area and data area associated with identifier.
  6. If the file position indicator indicates that no next logical record exists, or that an optional input file is not present, the following occurs in the order specified:
    1. A value, derived from the setting of the file position indicator, is placed into the FILE STATUS data item associated with file-name-1 to indicate the at end condition. (See the topic I-O Status in the chapter Procedure Division.)
    2. If the AT END phrase is specified in the statement causing the condition, control is transferred to AT END imperative-statement-1. Any USE AFTER EXCEPTION procedure associated with the file connector referenced by file-name-1 is not executed. Execution then continues according to the rules for each statement specifed in imperative-statement-1. If a procedure branching or conditional statement that causes explicit transfer of control is executed, control is transferred in accordance with the rules of that statement; otherwise, upon completion of the execution of imperative-statement-1, control is transferred to the end of the READ statement and the NOT AT END phrase, if specified, is ignored.
    3. If the AT END phrase is not specified, a USE AFTER STANDARD EXCEPTION procedure must be associated with this file-name-1, and that procedure is executed. Return from that procedure is to the next executable statement following the end of the READ statement.

      ANS85 When the AT END condition occurs, the execution of the READ statement is unsuccessful.

  7. Following the unsuccessful execution of any READ statement, the contents of the associated record area are undefined and the file position indicator is set to indicate that no next record has been established.

General Rules for Format 1 (Record Sequential Files)

  8. The record to be made available by the READ statement is determined as follows:
    1. ANS85 If the file position indicator was positioned by the execution of the OPEN statement, the record pointed to by the file position indicator is made available.
    2. ANS85 If the file position indicator was positioned by the execution of a previous READ statement, the file position indicator is updated to point to the next existing record in the file, and that record is made available.

      MF However if the previous statement was a READ, and if that READ returned a locked record status, the file position indicator is left unchanged. The record pointed to by the file position indicator is made available.

  9. If the end of a reel or unit is recognized during the execution of a READ statement, and end-of-file has not been reached, the following procedures are executed:
    1. The standard ending reel/unit label procedure.
    2. A reel/unit swap.
    3. The standard beginning reel/unit label procedure.
    4. The first data record of the new reel/unit is made available.
  10. If a file described with the OPTIONAL clause is not present at the time the file is opened, then at the time of execution of the first READ statement for the file, the AT END condition occurs and execution of the READ statement is unsuccessful. The standard end of file procedures are not performed. (See the topic The File-Control Paragraph, the topic The OPEN Statement and the topic The USE Statement.) Execution then proceeds as in General Rule 13.
  11. MF For files opened for INPUT, the READ, READ WITH LOCK or READ WITH KEPT LOCK statements do not acquire a record lock.
  12. MF Two or more run units can share a sequential output file by opening it EXTEND with AUTOMATIC or MANUAL record locking. Records that are appended to the file are in unspecified order.
  13. MF For files opened for I/O:
    1. With LOCK MODE AUTOMATIC, unless the WITH NO LOCK phrase is specified, each record is locked as it is read.
    2. With LOCK MODE MANUAL, a simple READ statement does not acquire a lock on the record - the READ WITH LOCK statement must be used to acquire a record lock. The WITH NO LOCK phrase, if specified, is documentary.
    3. The use of multiple or single record locking determines when the record lock is released. (See the topic The File Control Entry.)
  14. MF If an end-of-file status occurs on a READ statement in a file opened for I/O or INPUT by one run unit and opened EXTEND by another run unit, the run unit that attempted the READ must close the file. This run unit has no access to the appended records because the status remains end-of-file.

General Rules for Formats 1, 2 and 3 (Sequential, Relative and Indexed Files)

  15. If an AT END condition does not occur during the execution of a READ statement, the AT END phrase, if specified, is ignored and the following actions occur:
    1. The file position indicator is set and the I/O status associated with file-name-1 is updated.
    2. If an exception condition which is not an AT END condition exists, control is transferred according to the rules of the USE statement following the execution of any USE AFTER EXCEPTION procedure applicable to file-name-1. (See the topic The USE Statement.)
    3. If no exception condition exists, the record is made available in the record area and any implicit move resulting from the presence of an INTO phrase is executed. Control is transferred to the end of the READ statement or to imperative-statement-2, if specified. In the latter case, execution continues according to the rules for each statement specified in imperative-statement-2. If a control branching or conditional statement which causes explicit transfer of control is executed, control is transferred in accordance with the rules for that statement; otherwise, upon completion of the execution of imperative-statement-2, control is transferred to the end of the READ statement.
  16. If when a READ statement with the NEXT option is executed, no next logical record exists in the file, the AT END condition occurs, and the execution of the READ statement is considered unsuccessful. See the topic I-O Status in the chapter Procedure Division.
  17. For

    ANS85 sequential files or

    files in sequential access mode, the NEXT phrase is optional and has no effect on the execution of the READ statement.

General Rules for Format 3 (Relative and IndexedFiles)

  18. MF Following a READ which encounters a locked record status, the file position indicator points at the locked record. A subsequent READ NEXT or READ PREVIOUS will retrieve the same record again.

    The NOT AT END phrase is only executed following successful completion of the operation.

  19. MF If when a READ statement with the PREVIOUS option is executed no previous logical record exists in the file, the AT END condition occurs, and the execution of the READ statement is considered unsuccessful.
  20. When the AT END condition has been recognized,

    MF the next Format 3 READ statement, if any, executed for that file must be a READ NEXT statement, if AT END occurred because no previous logical record existed. Otherwise

    the AT END condition must be followed by:

    1. A successful CLOSE statement followed by the execution of a successful OPEN statement for that file.
    2. A successful START statement for that file.
    3. A successful Format 4 (or Format 5 for indexed files) READ statement for that file.
  21. For a file for which dynamic access mode is specified, a READ statement with the NEXT phrase specified causes the next logical record to be retrieved from the file

    MF as described in General Rule 8.

  22. The record to be made available by the READ statement is determined as follows:
    1. MF If the file position indicator was positioned by the execution of an OPEN statement, and the PREVIOUS option is specified, the AT END condition occurs. Otherwise

      if the file position indicator was positioned by the execution of the START or OPEN statement and the record is still accessible through the path indicated by the file position indicator, the record pointed to by the file position indicator is made available. If the record is no longer accessible, which can have been caused for a relative file by deletion of the record, or for an indexed file by a change in an alternate key, the file position indicator is updated to point to the next

      MF or, if the PREVIOUS option is specified, the previous

      existing record within the established key of reference, and that record is then made available.

    2. If the file position indicator was positioned by the execution of a previous READ statement, the file position indicator is updated to point to the next

      MF or, if the PREVIOUS option is specified, the previous

      existing record in the file.

      MF However, if the previous statement was a READ, and if that READ returned a locked record status, the file position indicator is left unchanged. The record pointed to by the file position indicator is made available.

General Rules for Formats 1, 3, 4 and 5 (Sequential, Relative and Indexed Files)

  23. MF If the lock mode is MANUAL with single record locking and the referenced file is opened I/O, the run unit acquires a record lock on the record only if the WITH LOCK phrase is specified. A simple READ statement does not acquire a record lock. To read past a locked record the file position indicator should be updated using the START statement. This, however, cannot be used on alternate keys which allow duplicates.
  24. MF If the lock mode is MANUAL with multiple record locking and the referenced file is opened I/O, the run unit acquires a lock on the record only if the WITH KEPT LOCK phrase is specified. A simple READ statement does not acquire a record lock. To read past a locked record the file position indicator should be updated using the START statement. This, however, cannot be used on alternate keys which allow duplicates.
  25. MF The WITH WAIT phrase ensures that a lock is acquired on the record, waiting if necessary.

General Rules for Format 3 (Relative Files)

  26. If the RELATIVE KEY phrase is specified for the file, the execution of a READ statement updates the contents of the RELATIVE KEY data item so that it contains the relative record number of the record made available.

General Rules for Format4 (Relative Files)

  27. The execution of a READ statement sets the file position indicator to, and makes available, the record whose relative record number is contained in the data item named in the RELATIVE KEY phrase for the file. If the file does not contain such a record, the INVALID KEY condition exists and execution of the READ statement is unsuccessful. (See the topic The INVALID KEY Condition in the chapter Procedure Division.)

General Rules for Formats 3 and 5 (Relative and IndexedFiles)

  28. MF The IGNORE LOCK phrase causes the READ to proceed as if the record were not locked.

General Rules for Format 3 (Indexed Files)

  29. For an indexed file being sequentially accessed, records having the same duplicate value in an alternate record key which is the key of reference are made available in the same order in which they are released by execution of WRITE statements, or by execution of REWRITE statements which create such duplicate values.

General Rules for Format 5 (Indexed Files)

  30. If the KEY phrase is not specified the prime record key is established as the key of reference for this retrieval. If dynamic access mode is specified, this key of reference is also used for retrievals by any subsequent executions of Format 3 READ statements for the file.
  31. If the KEY phrase is specified, data-name-1

    ISO2002 MF or split-key-name

    is established as the key of reference for this retrieval. If dynamic access mode is specified, this key of reference is also used for retrievals by any subsequent executions of Format 3 READ statements for the file until a different key of reference is established for the file.

  32. Execution of a Format 5 READ statement causes the value of the key of reference to be compared with the value contained in the corresponding data item of the stored records in the file, until the first record having an equal value is found. The file position indicator is positioned to this record which is then made available. If no record can be so identified, the INVALID KEY condition exists and execution of the READ statement is unsuccessful. (See the topic The INVALID KEY Condition in the chapter Procedure Division.)
Parent topic: Statements
Related reference
End of File Notification
Related information
The OPEN Statement
I-O Status
The File-Control Paragraph
The USE Statement
The File Control Entry
The INVALID KEY Condition


The RELEASE Statement

The RELEASE statement transfers records to the initial phase of a SORT operation.

General Format

Syntax Rules

  1. A RELEASE statement can only be used within the range of an input procedure associated with a SORT statement for a file whose sort-merge file description entry contains record-name. (See the topic The SORT Statement.)
  2. Record-name must be the name of a logical record in the associated sort-merge file description entry and can be qualified.
  3. ANS85 If identifier is a function-identifier, it must reference an alphanumeric function. When identifier is not a function-identifier,

    record-name and identifier must not reference the same storage area.

  4. OSVS VSC2 MF Record-name can be defined as a floating-point item.
  5. OSVS VSC2 MF Identifier can be a floating-point item.

General Rules

  1. The execution of a RELEASE statement causes the record named by record-name to be released to the initial phase of a sort operation.
  2. If the FROM phrase is used, the contents of the identifier data area are moved to record-name, then the contents of record-name are released to the sort file. Moving records takes place according to the rules specified for the MOVE statement without the CORRESPONDING phrase. The information in the record area is no longer available, but the information in the data area associated with identifier is available.
  3. After the execution of the RELEASE statement, the logical record is no longer available in the record area unless the associated sort-merge file is named in a SAME RECORD AREA clause. The logical record is also available as a record of other files referenced in the same SAME RECORD AREA clause as the associated sort-merge file, as well as the file associated with record-name. When control passes from the input procedure, the file consists of all those records which were placed in it by the execution of RELEASE statements.
Parent topic: Statements
Related information
The SORT Statement


The RETURN Statement

The RETURN statement obtains either sorted records from the final phase of a SORT operation or merged records during a MERGE operation.

General Format

Syntax Rules

  1. File-name must be described by a sort-merge file description entry in the Data Division.
  2. A RETURN statement can only be used within the range of an output procedure associated with a SORT or MERGE statement for file-name.
  3. The INTO phrase must not be used when the input file contains logical records of various sizes as indicated by their record descriptions. The storage area associated with identifier and the record area associated with file-name must not be the same storage area.
  4. OSVS VSC2 MF Identifier-1 can be a floating-point item.

General Rules

  1. When the logical records of a file are described with more than one record description, these records automatically share the same storage area; this is equivalent to an implicit redefinition of the area. The contents of any data items which lie beyond the range of the current data record are undefined at the completion of the execution of the RETURN statement.
  2. The execution of the RETURN statement causes the next existing record in the file referenced by file-name, as determined by the keys listed in the SORT or MERGE statement, to be made available in the record area associated with file-name. If no next logical record exists in the file referenced by file-name, the AT END condition exists and control is transferred to imperative-statement-1 of the AT END phrase. Execution continues according to the rules for each statement specified in imperative-statement-1. If a procedure branching or conditional statement which causes explicit transfer of control is executed, control is transferred according to the rules for that statement. Otherwise, upon completion of the execution of imperative-statement-1, control is transferred to the end of the RETURN statement

    ANS85 and the NOT AT END phrase if specified is ignored.

    When the AT END condition occurs, execution of the RETURN statement is unsuccessful and the contents of the record area associated with file-name are undefined. After the execution of imperative-statement-1 in the AT END phrase, no RETURN statement can be executed as part of the current output procedure.

  3. ANS85 If an AT END condition does not occur during the execution of a RETURN statement, then after the record is made available and after executing any implicit move resulting from the presence of an INTO phrase, control is transferred to imperative-statement-2, if specified. Otherwise, control is transferred to the end of the RETURN statement.
  4. ANS85 The END-RETURN phrase delimits the scope of the RETURN statement.
  5. The INTO phrase can be specified in a RETURN statement if one of the following conditions apply:
    • If only one record description is subordinate to the sort-merge file description entry:
    • If all record-names associated with file-name and the data item referenced by identifier describe groups item or elementary alphanumeric items.
  6. The result of the execution of a RETURN statement with the INTO phrase is equivalent to the application of the following rules in the order specified:
    1. The same RETURN statement without the INTO phrase is executed.
    2. The current record is moved from the record area to the area specified by identifier according to the rules for the MOVE statement without the CORRESPONDING phrase. The size of the current record is determined by rules specified for the RECORD clause. If the file description entry contains a RECORD IS VARYING clause, the implied move is a group move. The implied MOVE statement does not occur if the execution of the RETURN statement was unsuccessful. Any subscripting associated with identifier-1 is evaluated after the record has been read and immediately before it is moved to the data item. The record is available in both the record area and the data item referenced by identifier-1.
Parent topic: Statements


The REWRITE Statement

The REWRITE statement logically replaces a record existing in a disk file.

General Formats for Format 1 (Line Sequential Files)

General Formats for Format 2 (Record Sequential Files)

General Formats for Format 2 (Relative and Indexed Files)

Directives and RTS switches

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • WRITE-LOCK - acquires a record lock for a REWRITE statement when multiple recording locking is used.
  2. The following RTS switches may impact the semantics described in this section.
    • N - controls the insertion of null characters before control characters when writing line sequential records.
    • T - controls the insertion of tab characters when writing line sequential records.

Syntax Rules for All Formats (All Files)

  1. ANS85 If identifier is a function-identifier, it must reference an alphanumeric function. When identifier is not a function-identifier,

    record-name and identifier must not reference the same storage area.

  2. Record-name is the name of a logical record in the File Section of the Data Division and can be qualified.
  3. OSVS VSC2 MF Record-name can define a floating point or DBCS item.
  4. OSVS VSC2 MF Identifier can be a USAGE DISPLAY-1 (DBCS) item or a floating- point item.

Syntax Rules for Format 3 (Relative and Indexed Files)

  5. The INVALID KEY phrase must not be specified for a REWRITE statement which references a file in sequential access mode.

    OSVS VSC2 However, it can be specified for an indexed file in sequential access mode.

  6. The INVALID KEY phrase must be specified in the REWRITE statement for files in the random or dynamic access mode for which an appropriate USE procedure is not specified.

General Rules for All Formats (All Files)

  1. The file associated with record-name must be a disk file and must be open in the I-O mode at the time of execution of this statement. (See the section The OPEN Statement.)
  2. For files in the sequential access mode the last input-output statement executed for the associated file prior to the execution of the REWRITE statement must have been a successfully executed READ statement. The operating system logically replaces the record that was accessed by the READ statement.
  3. The execution of a REWRITE statement with the FROM phrase is equivalent to the execution of:
     MOVE identifier TO record-name

    followed by the execution of the same REWRITE statement without the FROM phrase. The contents of the record area prior to the execution of the implicit MOVE statement have no effect on the execution of the REWRITE statement.

  4. The file position indicator is not affected by the execution of a REWRITE statement.
  5. The execution of the REWRITE statement causes the value of the FILE STATUS data item, if any, associated with the file to be updated. (See the topic I-O Status in the chapter Procedure Division.)
  6. ANS85 The END-REWRITE phrase delimits the scope of the REWRITE statement.
  7. MF A REWRITE is unsuccessful if any other run unit holds a lock on the record to be rewritten.

General Rules for Formats 1 and 2 (Sequential Files)

  8. The number of character positions in the record referenced by record-name must be equal to the number of character positions in the record being replaced.
    Note: We recommend that you do not use the REWRITE statement on compressed sequential files because a REWRITE operation will only succeed if the length of the compressed new record is the same as the length of the compressed old record.
  9. The logical record released by a successful execution of the REWRITE statement is no longer available in the record area unless the associated file is named in a SAME RECORD AREA clause. In this case, the record is still available in the record area, not only as a record of this file, but also as a record of other files named in the SAME RECORD AREA clause.

General Rules for Format 1 (Line SequentialFiles)

  10. MF The REWRITE statement can be used and is considered successful whenever the record being written (after compacting by removing trailing spaces, tab compression and null insertion) is less than or equal to the length of the original compacted record. When a record is read, nulls and tab characters in the record can be expanded and this makes the record longer.

General Rules for Format 3 (Relative and IndexedFiles)

  11. The logical record released by a successful execution of the REWRITE statement is no longer available in the record area unless the associated file is named in a SAME RECORD AREA clause, in which case the logical record is available both as a record of other files appearing in the same SAME RECORD AREA clause as the associated I/O file, as well as the file associated with record-name.

General Rules for Format 3 (Relative Files)

  12. For a file accessed in either random or dynamic access mode, the operating system logically replaces the record specified by the contents of the RELATIVE KEY data item associated with the file. If the file does not contain the record specified by the key, the INVALID KEY condition exists (see the topic The INVALID KEY Condition in the chapter Procedure Division), the updating operation does not take place and the data in the record area is unaffected.

General Rules for Format 3 (Indexed Files)

  13. For a file in sequential access mode, the record to be replaced is specified by the value contained in the prime record key. When the REWRITE statement is executed, the value contained in the prime record data item of the record to be replaced must be equal to the value of the prime record key of the last record read from this file.
  14. For a file in random or dynamic access mode, the record to be replaced is specified by the prime record key data item.
  15. The contents of alternate record key data items of the record being rewritten can differ from those in the record being replaced. The operating system uses the contents of the record key data items during execution of the REWRITE statement so that the record can subsequently be accessed via any of those specified record keys.
  16. The INVALID KEY condition exists when any of the following is true:
    1. Access mode is sequential and the value contained in the prime record key data item of the record to be replaced is not equal to the value of the prime record key of the last record read from this file:
    2. The value contained in the prime record key data item does not equal that of any record stored in the file:
    3. The value contained in an alternate record key data item for which a DUPLICATES clause has not been specified is equal to that of a record already stored in the file.

    The updating operation does not take place and the data in the record area is unaffected. (See the topic The INVALID KEY Condition in the chapter Procedure Division.)

Parent topic: Statements
Related information
The OPEN Statement
I-O Status
The INVALID KEY Condition


The ROLLBACK Statement

The ROLLBACK statement releases all record locks in all files held by this run unit.

General Format

General Rules

  1. Execution of the ROLLBACK statement causes all record locks in all files held by the run unit to be released.
  2. The file lock on an exclusive file is not affected by the ROLLBACK statement.
  3. If your COBOL system supports the WITH ROLLBACK clause of the SELECT statement as other than documentary, then the ROLLBACK verb:
    1. Indicates completion of the current transaction
    2. Ensures all changes applied during the transaction are canceled.
Parent topic: Statements


The SEARCH Statement

The SEARCH statement is used to search a table for a table element that satisfies the specified condition and to adjust the associated index-name to indicate that table element.

General Format for Format 1

General Format for Format 2

Syntax Rules for All Formats (All Files)

  1. Identifier-1 must not be subscripted or indexed, but its description must contain an OCCURS clause and an INDEXED BY clause. The description of identifier-1 in Format 2 must also contain the KEY IS phrase in its OCCURS clause.
  2. Identifier-2, when specified, must be described as USAGE IS INDEX or as a numeric elementary item without any positions to the right of the assumed decimal point.
  3. ANS85 If the END-SEARCH phrase is specified, the NEXT SENTENCE phrase must not be specified.

    VSC2 MF END-SEARCH can be specified with NEXT SENTENCE. If the NEXT SENTENCE phrase is executed, control does not pass to the next statement following the END-SEARCH, but instead passes to the statement after the closest following period.

  4. MF Both imperative-statement-1 and imperative-statement-2 can be replaced by a conditional statement.

Syntax Rules for Format 1

  5. Condition-1, condition-2, and so on, can be any condition as described in the section Conditional Expressions in the chapter Procedure Division.
  6. OSVS VSC2 MF Identifier-1, the table element being searched, can be an internal or external floating-point item.

Syntax Rules for Format 2

  7. All referenced condition-names must be defined as having only a single value. The data-name associated with a condition-name must appear in the KEY clause of identifier-1. Each data-name-1, data-name-2 can be qualified. Each data-name-1, data-name-2 must be indexed by the first index-name associated with identifier-1 along with other indices or literals as required, and must be referenced in the KEY clause of identifier-1. Identifier-3, identifier-4, or identifiers specified in arithmetic-expression-1, arithmetic-expression-2 must not be referenced in the KEY clause of identifier-1 or be indexed by the first index-name associated with identifier-1.

    When a data-name in the KEY clause of identifier-1 is referenced, or when a condition-name associated with a data-name in the KEY clause of identifier-1 is referenced, all preceding data-names in the KEY clause of identifier-1 or their associated condition-names must also be referenced.

  8. OSVS VSC2 MF Identifier-1, the table element being searched, cannot be a floating-point item.
  9. OSVS VSC2 MF Neither data-name-1 nor data-name-2, the key data items, can be floating-point items. However, identifier-3, identifier-4, literal-1, or literal-2, the items against which the key is compared, can be floating-point items.

General Rules for All Formats

  1. The scope of a SEARCH statement can be terminated by any of the following:
    • ANS85 An END-SEARCH phrase at the same level of nesting.
    • Separator period.
    • An ELSE

      ANS85 or END-IF

      associated with a previous IF statement.

  2. After execution of imperative-statement-1 or imperative-statement-2 that does not terminate with a GO TO statement, control passes to the next executable sentence.
  3. If identifier-1 is a data item subordinate to a data item that contains an OCCURS clause (providing for a two- or three-dimensional table), an index-name must be associated with each dimension of the table through the INDEXED BY phrase of the OCCURS clause. Only the setting of the index-name associated with identifier-1 (and the data item identifier-2 or index-name-1, if present) is modified by the execution of the SEARCH statement. To search an entire two- or three-dimensional table it is necessary to execute a SEARCH statement several times. Prior to each execution of a SEARCH statement, SET statements must be executed whenever index-names must be adjusted to appropriate settings.

General Rules for Serial search Format 1

  4. If Format 1 of the SEARCH statement is used, a serial type of search operation takes place, starting with the current index setting.
    1. If, at the start of execution of the SEARCH statement, the index-name associated with identifier-1 contains a value that corresponds to an occurrence number that is greater than the highest permissible occurrence number for identifier-1, the SEARCH is terminated immediately. The number of occurrences of identifier-1, the last of which is the highest permissible, is discussed in the topic The OCCURS Clause in the chapter Data Division - File and Data Description.) Then, if the AT END phrase is specified, imperative-statement-1 is executed; if the AT END phrase is not specified, control passes to the next executable sentence.
    2. If, at the start of execution of the SEARCH statement, the index-name associated with identifier-1 contains a value that corresponds to an occurrence number that is not greater than the highest permissible occurrence number for identifier-1 (the number of occurrences of identifier-1, the last of which is the highest permissible is discussed in the topic The OCCURS Clause), the SEARCH statement operates by evaluating the conditions in the order that they are written, making use of the index settings, wherever specified, to determine the occurrence of those items to be tested. If none of the conditions is satisfied, the index name for identifier-1 is incremented to obtain reference to the next occurrence. The process is then repeated using the new index-name settings unless the new value of the index-name settings for identifier-1 corresponds to a table element outside the permissible range of occurrence values, in which case the search terminates as indicated in General Rule 4a above. If one of the conditions is satisfied upon its evaluation, the search terminates immediately and the imperative statement associated with that condition is executed; the index-name remains set at the occurrence which caused the condition to be satisfied.
  5. If the VARYING phrase is not used, the index-name that is used for the search operation is the first (or only) index-name that appears in the INDEXED BY phrase of identifier-1. Any other index-names for identifier-1 remain unchanged.
  6. If the VARYING index-name-1 phrase is specified, and if index-name-1 appears in the INDEXED BY phrase of identifier-1, that index-name is used for this search. If this is not the case, or if the VARYING identifier-2 phrase is specified, the first (or only) index-name given in the INDEXED BY phrase of identifier-1 is used for the search. In addition, the following operations occur:
    1. If the VARYING index-name-1 phrase is used, and if index-name-1 appears in the INDEXED BY phrase of another table entry, the occurrence number represented by index-name-1 is incremented by the same amount as the index-name associated with identifier-1, and at the same time.
    2. If the VARYING identifier-2 phrase is specified, and identifier-2 is an index data item, then the data item referenced by identifier-2 is incremented by the same amount as the index-name associated with identifier-1, and at the same time. If identifier-2 is not an index data item, the data item referenced by identifier-2 is incremented by the value (1) at the same time as the index referenced by the index-name associated with identifier-1 is incremented.

General Rules for Non-serial search Format 2

  7. The results of the SEARCH ALL operation are predictable only when:
    1. The data in the table is ordered in the same manner as described in the ASCENDING/DESCENDING KEY clause associated with the description of identifier-1, and:
    2. The contents of the key(s) referenced in the WHEN clause are sufficient to identify a unique table element.
  8. If Format 2 of the SEARCH statement is used, a non-serial type of search operation can take place; the initial setting of the index-name for identifier-1 is ignored and its setting is varied during the search operation with the restriction that at no time is it set to a value that exceeds the value which corresponds to the last element of the table, or that is less than the value that corresponds to the first element of the table. The length of the table is discussed in the topic The OCCURS Clause). If any of the conditions specified in the WHEN clause cannot be satisfied for any setting of the index within the permitted range, control is passed to imperative-statement-1 of the AT END phrase, when specified, or to the next executable sentence when this phrase is not specified; in either case the final setting of the index is not predictable. If all conditions can be satisfied, the index indicates an occurrence that allows the conditions to be satisfied, and control passes to imperative-statement-2.
  9. The index-name that is used for the search operation is the first (or only) index-name that appears in the INDEXED BY phrase of identifier-1. Any other index-names for identifier-1 remain unchanged.
  10. OSVS VSC2 MF Neither imperative-statement-2 nor NEXT SENTENCE is required. Without them, the SEARCH statement sets the index to the value in the table that matched the condition.

Comments:

Figure 1 shows a flowchart of a Format 1 SEARCH operation containing two WHEN phrases.

Figure 1. Flowchart of SEARCH Operation Showing Two WHEN Phrases
Flowchart of SEARCH Operation Showing Two WHEN Phrases
1 | These operations are options included only when specified in the SEARCH statement
2 | Each of these control transfers is to the next executable sentence unless the imperative-statement ends with a GO TO statement.
Parent topic: Statements
Related information
Conditional Expressions
The OCCURS Clause


The SERVICE Statement

The SERVICE statement is used to establish addressability to Linkage Section items usually in a CICS program.

General Format

Syntax Rules

  1. SERVICE LABEL is generated by the mainframe CICS preprocessor to indicate control flow. It is not intended for general use.
  2. The SERVICE LABEL statement can appear only in the Procedure Division, not in the Declaratives Section.
  3. Identifier should be either the first 01-level item representing the BLL-cell block in the Linkage Section, or another Linkage Section 01-level item for which addressability needs to be re-established following an EXEC CICS statement.

General Rules

  1. At the statement following the SERVICE LABEL statement, all registers that can no longer be valid are reloaded.
  2. If the OS/VS COBOL BLL mechanism is used in a CICS program, addressability to the parameter list must be established at the start of the Procedure Division. This is done by adding a SERVICE RELOAD identifier statement at the start of the Procedure Division where the identifier is the first item in the Linkage Section and it includes pointers to all other entries in the Linkage Section.
  3. If a locate-mode EXEC CICS statement is included in a program compiled with the OSVS Compiler directive, then a SERVICE RELOAD statement must follow each such CICS command and the identifier must be the same pointer (BLL-cell reference) used in the CICS command.
  4. In a CICS program compiled with the OSVS Compiler directive, any time a reference is made to a Linkage Section which is greater than 4096 bytes long, a SERVICE RELOAD statement should be made to re-establish addressability to that portion of the data item greater than 4096 bytes.
  5. The SERVICE RELOAD statement is documentary only in a program compiled with the VSC2 Compiler directive.
Parent topic: Statements


The SET Statement

The SET statement is used to alter the status of external switches.

ANS85 The SET statement is used to alter the value of conditional variables.

VSC2 MF The SET statement is used to assign the address of a data item to a pointer data item. It is also used to adjust the contents of a pointer data item.

The SET statement establishes reference points for table handling operations by setting indices associated with table elements.

MF The SET statement is used to assign the address of a program or an entry-point in a program to a procedure-pointer data item.

ISO2002 MF The SET statement is used to assign the address of a pointer to a program-pointer data item.

ISO2002 MF The SET statement is used to assign object references.

MF The SET statement is used to alter the value of a synchronization data item.

MF The SET statement is used to assign the address of a synchronization data item to another synchronization data item.

NET JVM The SET statement is used to alter the size of a native array.

NET JVM The SET statement is used to initialize the contents of a native array and to set the array size based on those contents.

NET JVM The SET statement is used to alter the value of a boolean data item with usage CONDITION-VALUE.

NET JVM The SET statement is used to alter the value of a data item with a native type.

General Formats for Format 1 (Switch-setting)

General Formats for Format 2 (Condition-setting)

General Formats for Format 3 (Data-pointer-assignment)

General Formats for Format 4 (Data-pointer-assignment)

General Formats for Format 5 (Data-pointer-arithmetic)

General Formats for Format 6 (Index-assignment)

General Formats for Format 7 (Index-arithmetic)

General Formats for Format 8 (Procedure-pointer-assignment)

General Formats for Format 9 (Object-reference-assignment)

General Formats for Format 10 (Value-of-Event-pointer)

General Formats for Format 11 (Address-of-Event-pointer)

General Formats for Format 12 (Value-of-Monitor-pointer)

General Formats for Format 13 (Address-of-Monitor-pointer)

General Formats for Format 14 (Value-of-Mutex-pointer)

General Formats for Format 15 (Address-of-Mutex-pointer)

General Formats for Format 16 (Value-of-Semaphore-pointer)

General Formats for Format 17 (Address-of-Semaphore-pointer)

General Formats for Format 18 (Size-of-array)

General Formats for Format 19 (Content-of-array)

General Formats for Format 20 (Boolean-setting)

General Formats for Format 21 (data-setting)

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • STICKY-LINKAGE - determines whether addresses of data items placed in pointer data items by the SET statement are retained between invocations of a subprogram.

Syntax Rules for All Formats

  1. The figurative constant NULL or NULLS or the data item referenced by pointer-name-2 or procedure-pointer-name-2 represents the sending area. ADDRESS OF identifier-2, ENTRY identifier-8, ENTRY literal-1 or the value held in the sending area, represents the sending value.

    The data item referenced by pointer-name-1, pointer-name-3 or procedure-pointer-name-1 or the COBOL system area implied by ADDRESS OF identifier-1 represents the receiving area.

    Identifier-3, integer-1 or LENGTH OF identifier-4 represents the increment value.

Syntax Rules for Format 1

  2. ANS85 Mnemonic-name-1 must be associated with an external switch, the status of which can be altered.

    MF See the topic The Special-Names Paragraph for details of which external switches can be referenced in the SET statement.

Syntax Rules for Format 2

  3. ANS85 Condition-name-1 must be associated with a conditional variable.
  4. MF If the FALSE phrase is specified, the FALSE phrase must be specified in the VALUE clause of the Data Description entry for condition-name-1.
  5. MF Each FALSE or TRUE phrase applies to the occurrences of condition-name-1 that precede that phrase and follow a previous FALSE or TRUE phrase, if any.

Syntax Rules for Format 3 and 4

  6. VSC2 MF Identifier-1 must reference a level 01 or level 77 data item that is declared in the Linkage Section.

    OS390 Identifier-1 must be declared in the Linkage Section, the Local-Storage Section or the Working-Storage Section

  7. ISO2002 VSC2 MF OS390 Identifier-2 must reference a data item with a level of 77 or between 01 and 49 inclusive.

    ISO2002 VSC2 Identifier-2 must be declared in the Linkage Section.

  8. VSC2 MF Pointer-name-1, pointer-name-2 must each be an identifier that references an elementary data item with USAGE IS POINTER.

Syntax Rules for Format 5

  9. MF Pointer-name-3 must be an identifier that references an elementary data item with USAGE IS POINTER.
  10. MF Identifier-3 must be an elementary numeric integer.
  11. MF Integer-1 may be signed.

Syntax Rules for Format 6

  12. Identifier-5 and identifier-6 must each reference an index data item or an elementary item described as an integer. If both are specified, they must not both reference an elementary item.

Syntax Rules for Formats 6 and 7

  13. Integer-2 and integer-3 may be signed. Integer-2 must be positive.

Syntax Rules for Format 6

  14. Identifier-7 must reference an elementary numeric integer.

Syntax Rules for Format 8

  15. MF Procedure-pointer-name-1 and procedure-pointer-name-2 must each be an identifier that references an elementary data item with USAGE IS PROCEDURE-POINTER.
  16. MF Identifier-8 must be defined as an alphanumeric data item such that its value can be a COBOL or a non-COBOL program name.
  17. MF Literal-1 must be a nonnumeric literal.

Syntax Rules for Format 9

  18. ISO2002 MF Identifier-9 must be any item of class object that is permitted as a receiving item.
  19. ISO2002 MF Identifier-10 must be a class-name or an object reference; the predefined object reference SUPER must not be specified.
  20. ISO2002 MF If the data item referenced by identifier-9 is a universal object reference, the only predefined object references that may be specified for identifier-10 are SELF and NULL.
  21. ISO2002 MF If the data item referenced by identifier-9 is described with an interface-name that identifies the interface int-1, the data item referenced by identifier-10 must be one of the following:
    1. An object reference described with an interface-name that identifies int-1 or an interface inheriting from int-1.
    2. An object reference described with a class-name, subject to the following rules:
      1. If described with a FACTORY phrase, the factory object of the specified class must implement int-1
      2. If described without a FACTORY phrase, the instance objects of the specified class must implement int-1.
    3. An object reference described with an ACTIVE-CLASS phrase, subject to the following rules:
      1. If described with a FACTORY phrase, the factory object of the class containing the data item referenced by identifier-10 must implement int-1.
      2. If described without a FACTORY phrase, the instance objects of the class containing the data item referenced by identifier-10 must implement int-1.
    4. A class-name whose factory object implements int-1.
    5. The predefined object reference SELF, subject to the following rules:
      1. If the SET statement is contained in a method within the factory definition of the class, that factory definition must be described with an IMPLEMENTS clause that references int-1.
      2. If the SET statement is contained in a method within the instance definition of the class, that instance definition must be described with an IMPLEMENTS clause that references int-1.
    6. The predefined object reference NULL
  22. ISO2002 MF If the data item referenced by identifier-9 is described with a class-name, the data item referenced by identifier-10 must be one of the following:
    1. An object reference described with a class-name, subject to the following rules:
      1. If the data item referenced by identifier-9 is described with an ONLY phrase, the data item referenced by identifier-10 must be described with the ONLY phrase, and the class-name specified in the description of the data item referenced by identifier-10 must be the same as the class-name specified in the description of the data item referenced by identifier-9
      2. If the data item referenced by identifier-9 is described without an ONLY phrase, the class-name specified in the description of the data item referenced by identifier-10 must reference the same class or a subclass of the class specified in the description of the data item referenced by identifier-9
      3. The presence or absence of the FACTORY phrase must be the same as in the description of the data item referenced by identifier-9
    2. An object reference described with an ACTIVE-CLASS phrase, subject to the following rules:
      1. The data item referenced by identifier-9 must not be described with the ONLY phrase
      2. The class containing the data item referenced by identifier-10 must be the same class or a subclass of the class specified in the description of the data item referenced by identifier-9
      3. The presence or absence of the FACTORY phrase must be the same as in the description of the data item referenced by identifier-9
    3. The predefined object reference SELF, subject to the following rules:
      1. The data item referenced by identifier-9 must not be described with the ONLY phrase
      2. The class of the object containing the SET statement must be the same class or a subclass of the class specified in the description of the data item referenced by identifier-9
      3. If the data item referenced by identifier-9 is described without a FACTORY phrase, the object containing the SET statement must be an instance object
      4. If the data item referenced by identifier-9 is described with a FACTORY phrase, the object containing the SET statement must be a factory object
    4. A class-name, provided the data item referenced by identifier-9 is described with the FACTORY phrase, and class-name references the same class or a subclass of the class specified in the description of the data item referenced by identifier-9
    5. The predefined object reference NULL
  23. ISO2002 MF If the data item referenced by identifier-9 is described with an ACTIVE-CLASS phrase, the data item referenced by identifier-10 must be one of the following:
    1. An object reference described with the ACTIVE-CLASS phrase, where the presence or absence of the FACTORY phrase is the same as in the data item referenced by identifier-9
    2. The predefined object reference SELF, subject to the following rules:
      1. If the data item referenced by identifier-9 is described without a FACTORY phrase, the object containing the SET statement must be an instance object
      2. If the data item referenced by identifier-9 is described with a FACTORY phrase, the object containing the SET statement must be a factory object
    3. The predefined object reference NULL

Syntax Rules for Format 10 (Value of Event-pointer)

  24. MF Event-pointer-1 must be defined as a data item with USAGE EVENT-POINTER.

Syntax Rules for Format 11 (Address of Event-pointer)

  25. MF Event-pointer-1 and event-pointer-2 must be defined as data items with USAGE EVENT-POINTER.

Syntax Rules for Format 12 (Value of Monitor-pointer)

  26. MF Monitor-pointer-1 must be defined as a data item with USAGE MONITOR-POINTER.
  27. MF If the NOT phrase is specified, then the CONVERTING phrase must not be specified.

Syntax Rules for Format 13 (Address of Monitor-pointer)

  28. MF Monitor-pointer-1 and monitor-pointer-2 must be defined as data items with USAGE MONITOR-POINTER.

Syntax Rules for Format 14 (Value of Mutex-pointer)

  29. MF Mutex-pointer-1 must be defined as a data item with USAGE MUTEX-POINTER.

Syntax Rules for Format 15 (Address of Mutex-pointer)

  30. MF Mutex-pointer-1 and mutex-pointer-2 must be defined as data items with USAGE MUTEX-POINTER.

Syntax Rules for Format 16 (Value of Semaphore-pointer)

  31. MF Semaphore-pointer-1 must be defined as a data item with USAGE SEMAPHORE-POINTER.
  32. MF Identifier-11 must reference an integer.

Syntax Rules for Format 17 (Address of Semaphore-pointer)

  33. MF Semaphore-pointer-1 and semaphore-pointer-2 must be defined as data items with USAGE SEMAPHORE-POINTER.

Syntax Rules for Format 18 (Size-of-Array)

  34. NET JVM Identifier-12 must be described with a format 3 OCCURS clause.
  35. NET JVM Identifier-13 must describe an integer.
  36. NET JVM The number of operands after the TO phrase must not exceed the number of dimensions specified for identifier-12.

Syntax Rules for Format 19 (Content-of-Array)

  37. NET JVM Identifier-14 must be described with a format 3 OCCURS clause as either a one-dimensional array or a rectangular array.
  38. NET JVM Literal-2 must be a valid literal for a VALUE clause describing the subject of the entry.
  39. NET JVM Parentheses may be used within the repetitions of literal-2 to separate the values into subarrays.

Syntax Rules for Format 20 (Boolean setting)

  40. NET JVM Identifier-15 and identifier-16 must have usage CONDITION-VALUE.
  41. NET JVM Condition-name-2 and condition-name-3 must be associated with conditional variables.
  42. NET JVM If condition-name-2 is specified and the TRUE phrase is not specified, the FALSE phrase must be specified in the VALUE clause of the Data Description entry for condition-name-2.

Syntax Rules for Format 21 (.NET-data-setting)

  43. NET JVM Identifier-17 is the receiving item.
  44. NET JVM Identifier-18, literal-3 or arithmetic-expression-1 is the sending item.
  45. NET JVM The SET statement is legal if any of the following are true:
    • Both the sending item and the receiving item are numeric
    • Identifier-17 and identifier-18 are objects of the same class.
    • The class of identifier-18 inherits directly or indirectly from the class of identifier-17.
    • Identifier-17 conforms to an interface and identifier-18 implements that interface.
    • There is an implicit conversion operator for an item with the class of identifier-18 to the class of identifier-17.
    • Identifier-17 is alphanumeric or national.

General Rules for Format 1

  1. ANS85 The status of each external switch associated with the specified mnemonic-name-1 is modified such that the truth value resulting from evaluation of a condition-name associated with that switch reflects an on status if the ON phrase is specified, or an off status if the OFF phrase is specified. (See the topic Switch-Status Condition in the chapter Procedure Division.)

General Rules for Format 2

  2. ANS85 The literal in the VALUE clause associated with condition-name-1 is placed in the conditional variable according to the rules of the VALUE clause (see the section The VALUE Clause.) If more than one literal is specified in the VALUE clause, the conditional variable is set to the value of the first literal that appears in the VALUE clause.
  3. ANS85 If multiple condition-names are specified, the results are the same as if a separate SET statement had been written for each condition-name-1 in the same order as specified in the SET statement.
  4. MF If the FALSE phrase is specified, the literal in the FALSE phrase of the VALUE clause associated with condition-name-1 is placed in the conditional variable according to the rules for the VALUE clause. (See the topic The VALUE Clause.)

General Rules for Format 3 and 4

  5. VSC2 MF The sending value represents the address of a data item. If pointer-name-2 is specified, the sending value is the value contained with the data item referenced by pointer-name-2. If ADDRESS OF identifier-2 is specified, the sending value represents the address of identifier-2.
  6. VSC2 MF If pointer-name-1 is specified, the sending value is moved to the data name referenced by pointer-name-1.
  7. VSC2 MF If ADDRESS OF identifier-1 is specified, the sending value is moved to a COBOL system area and the runtime element subsequently operates such that the area of storage referenced by identifier-1 is located at the address represented by the sending value.

    MF Whether or not the link is retained between invocations of a subprogram is dependent on the STICKY-LINKAGE Compiler directive.

General Rules for Format 5

  8. MF Before execution of the SET statement, the value of the data item referenced by pointer-name-3 must represent the address of a data item within a logical record, the original address. After execution of the SET statement, the value of the data item referenced by pointer-name-3 represents the new address. If the original address and the new address do not both lie within the same logical record, (or, for environments in which address space is segmented, within the same segment) then the results of using the value of the data item referenced by pointer-name-3 are undefined.
  9. MF If the UP clause is specified, the new address is formed by adding the number of bytes given by the increment value to the original address.
  10. MF If the DOWN clause is specified, the new address is formed by subtracting the number of bytes given by the increment value from the original address.

General Rules for Format 5

  11. The following steps are repeated for each recurrence of index-name-1 or identifier-5. Each time, the value of index-name-2 or identifier-6 is used as it was at the beginning of the execution of the statement. Any subscripting or indexing associated with identifier-5 is evaluated immediately before the value of that data item is changed.
    1. If index-name-1 is specified, index-name-1 is set to a value causing it to refer to the table element that corresponds in occurrence number to the table element referenced by index-name-2, identifier-6, or integer-2. If identifier-6 references an index data item, or if index-name-2 is related to the same table as index-name-1, no conversion takes place.
    2. If identifier-5 references an index data item, it can be set equal to either the contents of index-name-2 or identifier-6 where identifier-6 also references an index item; no conversion takes place in either case.
    3. If identifier-5 does not reference an index data item, it can be set only to an occurrence number that corresponds to the value of index-name-2. Neither identifier-6 nor integer-2 can be used in this case.
  12. The following table represents the validity of various operand combinations in the SET statement. The general rule reference indicates the applicable general rule.
    Table 1. SET Index Statement Valid Operand Combinations
    Sending Item | Receiving Item
    Integer Data Item | Index-Name | Index Data Item
    Integer Literal | No/11c | Valid/11a | No/11b
    Integer Data Item | No/11c | Valid/11a | No/11b
    Index-Name | Valid/11c | Valid/11a | Valid/11b1
    Index Data Item | No/11c | Valid/11a1 | Valid/11b1

    1 = No conversion takes place.

General Rules for Formats 6 and 7

  13. Index-names are associated with a given table by being specified in the INDEXED BY phrase of the OCCURS clause for that table.
  14. If index-name-1 is specified, the value of the index after the execution of the SET statement must correspond to an occurrence number of an element in the table associated with index-name-1. The value of the index associated with an index-name after the execution of a PERFORM or SEARCH statement may be set to an occurrence number that is outside the range of its associated table. (See the topic The PERFORM Statement and the topic The SEARCH Statement.)

    If index-name-2 is specified, the value of the index before the execution of the SET statement must correspond to an occurrence number of an element in the table associated with index-name-1.

    If index-name-3 is specified, the value of the index both before and after the execution of the SET statement must correspond to an occurrence number of an element in the table associated with index-name-3.

General Rules for Format 7

  15. The contents of index-name-3 are incremented (UP BY) or decremented (DOWN BY) by a value that corresponds to the number of occurrences represented by the value of integer-3 or the data item referenced by identifier-7; thereafter, the process is repeated for each recurrence of index-name-3. For each repetition, the value of the data item referenced by identifier-7 is used as it was at the beginning of the execution of the statement.

General Rules for Format 8

  16. MF The sending value represents the address of the start of a procedure within a COBOL or non-COBOL program.
  17. MF The sending value is moved to the data item referenced by procedure-pointer-name-1.
  18. MF If procedure-pointer-name-2 is specified, the sending value is the value contained within the data item referenced by procedure-pointer-name-2.
  19. MF Literal-1 or the content of the data item referenced by identifier-8 is the name of the referenced procedure. If the referenced procedure is a COBOL procedure, the name of the referenced procedure must contain the program-name contained in the Program-ID paragraph of the referenced program or the entry-name contained in the ENTRY statement of the referenced procedure.

    If the program being called is not a COBOL program, the rules for the formation of the program or procedure name are given in your COBOL system documentation on interfacing.

    If the referenced procedure has been previously made available and remains available at the time of execution of the SET statement, then the sending value represents the address of the referenced procedure.

    If the referenced procedure is not available at the time of execution of the SET statement, then the sending value represents the address of a COBOL system error procedure.

General Rules for Format 9

  20. ISO2002 MF If identifer-10 is an object reference, a reference to the object identified by identifier-10 is placed into each data item referenced by identifier-9 in the order specified.
  21. ISO2002 MF If identifier-10 is a class-name, a reference to the factory object of the class identified by identifier-10 is placed into each data item referenced by identifier-9 in the order specified.

General Rules for Formats 10 and 11

  22. MF If more than one event-pointer-1 is specified, the results are the same as if a separate SET statement had been written for each event-pointer-1 in the same order as specified in the SET statement.

General Rules for Format 10 (Value of Event-pointer)

  23. MF The execution of the SET statement sets the value of the event referenced by event-pointer-1 to TRUE or FALSE.
    Note: When an event is set to FALSE, the execution of any thread which executes a WAIT statement which references that event suspends until the event is set to TRUE in another thread.

General Rules for Format 11 (Address of Event-pointer)

  24. MF Event-pointer-1 is set to reference the same event data item that event-pointer-2 references.

General Rules for Formats 12 and 13

  25. MF If more than one monitor-pointer-1 is specified, the results are the same as if a separate SET statement had been written for each monitor-pointer-1 in the same order as specified in the SET statement.

General Rules for Format 12 (Value of Monitor-pointer)

  26. MF If the NOT phrase is not specified, the value of the monitor referenced by monitor-pointer-1 is set to one of BROWSING, READING, or WRITING, thus establishing the corresponding form of lock. This specific lock type for this specific monitor must be eventually released by a SET statement either with a matching NOT phrase or a matching CONVERTING FROM phrase.

    For example, the lock established by

     SET mon-1 TO READING

    can be cleared by

     SET mon-1 TO NOT READING
  27. MF The CONVERTING phrase is used to change the current type of lock established on a monitor. The lock type specified in the FROM phrase must be currently established by that thread and upon successful execution of the statement, that lock will have been changed, in one atomic operation, to the lock type specified in the TO phrase.
  28. MF Nested locks can be obtained by the execution of successive SET monitor statements with no intervening SET statement that releases the lock. Once a READING lock is established, no BROWSING or WRITING lock is allowed to nest within that thread. Once a BROWSING lock or a WRITING lock is established, any other level of lock is allowed to nest within that thread.

General Rules for Format 13 (Address of Monitor-pointer)

  29. MF Monitor-pointer-1 is set to reference the same monitor data item that monitor-pointer-2 references.

General Rules for Formats 14 and 15

  30. MF If more than one mutex-pointer-1 is specified, the results are the same as if a separate SET statement had been written for each mutex-pointer-1 in the same order as specified in the SET statement.

General Rules for Format 14 (Value of Mutex-pointer)

  31. MF The execution of the SET statement sets the value of the mutex referenced by mutex-pointer-1 to ON or OFF.
  32. MF When a mutex is set to ON, the execution of any thread that attempts to set that mutex to ON suspends until the mutex is set to OFF in the thread that set it ON.

General Rules for Format 15 (Address of Mutex-pointer)

  33. MF Mutex-pointer-1 is set to reference the same mutex data item that mutex-pointer-2 references.

General Rules for Formats 16 and 17

  34. MF If more than one semaphore-pointer-1 is specified, the results are the same as if a separate SET statement had been written for each semaphore-pointer-1 in the same order as specified in the SET statement.

General Rules for Format 16 (Value of Semaphore-pointer)

  35. MF The contents of the semaphore data item referenced by semaphore-pointer-1 are incremented (UP BY) or decremented (DOWN BY) by a value that corresponds to the value of integer-4 or the data item referenced by identifier-11; thereafter, the process is repeated for each recurrence of semaphore-pointer-1. For each repetition, the value of the data item referenced by identifier-11 is used as it was at the beginning of the execution of the statement.
  36. MF If a semaphore is set DOWN BY n and the semaphore is less than n, the thread is suspended until another thread raises the semaphore to above n.

General Rules for Format 17 (Address of Semaphore-pointer)

  37. MF Semaphore-pointer-1 is set to reference the same semaphore data item that semaphore-pointer-2 references.

General Rules for Format 18 (Size-of-Array)

  38. NET JVM The SET statement sets the size of the .NET array described by identifier-12 to the contents of the data item referenced by identifier-13 or the value of integer-5.

General Rules for Format 19 (Content-of-Array)

  39. NET JVM The SET statement creates an a .NET array of the size required to contain the values specified by the repetitions of literal-2 and initializes the array to the specfied values..

General Rules for Format 20 (Boolean setting)

  40. NET JVM The contents of the data-item referenced by identifier-15 or condition-item-2 is set to the contents of the data item referencesby identifier-16 or condition-name-3 or to TRUE or FALSE.

General Rules for Format 21 (.NET-data-setting)

  41. NET JVM If identifier-17 is alphanumeric or national, the ToString method is automatically invoked on the sending item and the resulting string moved to the data item referenced by identifier-17. Note that the ToString method exists for any class since it is implemented in System.Object.
  42. NET JVM The sending item is moved to the receiving item.
Parent topic: Statements
Related reference
SET Statement
Related information
The Special-Names Paragraph
Switch-Status Condition
The VALUE Clause
The PERFORM Statement
The SEARCH Statement


The SORT Statement

The SORT statement creates a sort file by executing input procedures or by transferring records from another file, sorts the records in the sort file on a set of specified keys, and in the final phase of the sort operation, makes available each record from the sort file, in sorted order to some output procedures or to an output file.

MF The SORT statement can also be used to sort the elements of a table.

General Formats for Format 1

General Formats for Format 2

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • CALLSORT - specifies the program to be used to handle SORT and MERGE operations.

Syntax Rules for All Formats

  1. A Format 1 SORT statement cannot appear in the declaratives portion of the Procedure Division, or in an input or output procedure associated with a SORT or MERGE statement.

    MF A Format 2 SORT can appear in the declaratives portion.

  2. Data-name-1 is a KEY data-name and is subject to the following rules:
    1. KEY data-names can be qualified.
    2. The data items identified by KEY data-names must not be variable length items.
    3. KEY data items can be floating-point items.
    4. OSVS VSC2 MF If the KEY is an external floating-point item, the Compiler treats the data item as character data, rather than numeric data. The sequence in which the records are sorted depends on the collating sequence used.
    5. OSVS VSC2 MF If the KEY data item is internal floating-point, the records are sorted in numeric order of key values.

Syntax Rules for Format 1

  3. File-name-1 must be described in a Sort-Merge File Description entry in the Data Division.
  4. Data-name-1 is a KEY data-name and is subject to the following rules:
    1. The data items identified by KEY data-names must be described in records associated with file-name-1.
    2. If file-name-1 has more than one record description, then the data items identified by KEY data-names need be described in only one of the record descriptions.
    3. None of the data items identified by KEY data-names can be described by an entry which either contains an OCCURS clause or is subordinate to an entry which contains an OCCURS clause.
    4. If the file referenced by file-name-1 contains variable-length records, all the data items identified by key data-names must be contained within the first x character positions of the record, where x equals the minimum record size specified for the file referenced by file-name-1.
  5. The words THRU and THROUGH are equivalent.
  6. File-name-2 and file-name-3 must be described in file description entries, not in sort-merge file description entries, in the Data Division.
  7. ANS85 The files referenced by file-name-2 and file-name-3 can reside on the same multiple file reel.
  8. ANS85 If file-name-3 references an indexed file, the first specification of data-name-1 must be associated with an ASCENDING phrase and the data item referenced by that data-name-1 must occupy the same character positions in its record as the data item associated with the prime record key for that file.
  9. No pair of file-names in the same SORT statement can be specified in the SAME SORT AREA or SAME SORT-MERGE AREA clause. File-names associated with the GIVING phrase cannot be specified in the same SAME clause.
  10. ANS85 If the GIVING phrase is specified and the file referenced by file-name-3 contains variable-length records, the size of the records contained in the file referenced by file-name-1 must not be less than the smallest record nor larger than the largest record described for file-name-3. If the file referenced by file-name-3 contains fixed-length records, the size of the records contained in the file referenced by file-name-1 must not be larger than the largest record described for the file referenced by file-name-3.

    If the data descriptions of the elementary items that make up these records are not identical, it is the programmer's responsibility to describe the corresponding records in such a manner as to cause equal amounts of character positions to be allocated for the corresponding records.

  11. ANS85 If the USING phrase is specified and the file referenced by file-name-1 contains variable-length records, the size of the records contained in the file referenced by file-name-2 must not be less than the smallest record nor larger than the largest record described for file-name-1. If the file referenced by file-name-1 contains fixed-length records, the size of the records contained in the file referenced by file-name-2 must not be larger than the largest record described for the file referenced by file-name-1.
  12. Procedure-name-1 represents the name of an input procedure. Procedure-name-3 represents the name of an output procedure.
  13. Procedure-name-1, procedure-name-2, procedure-name-3 and procedure-name-4 must be section-names.

    ANS85 OSVS This restriction is removed.

  14. If you want to specify more than 10 file-names in the USING or GIVING clause, you must use the Compiler directive CALLSORT"EXTSM"; this allows you to specify up to 255 files.

Syntax Rules for Format 2

  15. MF Data-name-2 can be qualified and must have an OCCURS clause in the data description entry.
  16. MF The data item referenced by data-name-1 must be the same as the data item referenced by data-name-2, or an entry subordinate to the data item referenced by data-name-2.
  17. MF Unless data-name-1 and data-name-2 are the same, the data item referenced by data-name-1 must not be described by an entry containing an OCCURS clause. The data item referenced by data-name-1 must not be subordinate to an entry containing an OCCURS clause that is also subordinate to data-name-2.
  18. MF The KEY phrase can be omitted only if the description of the table referenced by data-name-2 contains a KEY phrase.
  19. MF If data-name-2 references a data item subordinate to a data item that contains an OCCURS clause, an index-name must be associated with each data item containing an OCCURS clause to which the data item referenced by data-name-2 is subordinate.

General Rules for All Formats

  1. The words ASCENDING and DESCENDING are transitive across all occurrences of data-name-1 until another word ASCENDING or DESCENDING is encountered.
  2. The data items referenced by the specifications of data-name-1 are the key data items which determine the order in which records are returned from the file referenced by file-name-1 or the order in which the table elements are stored after sorting takes place. The order of significance of the keys is the order in which they are specified in the SORT statement, without regard to their association with ASCENDING or DESCENDING phrases.
  3. If the DUPLICATES phrase is specified and the contents of all the key data items associated with one data record or table element are equal to the contents of the corresponding key data items associated with one or more other data records or table elements, the order of return of these records is:
    1. The order of the associated input files as specified in the SORT statement, or by means of an RTS switch. Within a given input file the order is that in which the records are accessed from that file.
    2. The order in which these records are released by an input procedure, when an input procedure is specified.
    3. The relative order of the contents of these table elements before sorting takes place.
  4. If the DUPLICATES phrase is not specified and the contents of all the key data items associated with one data record or table element are equal to the contents of the corresponding key data items associated with one or more other data records or table elements, the order of return of these records or the relative order of the contents of these table elements is undefined.
  5. The collating sequence that applies to the comparison of the nonnumeric key data items specified is determined at the beginning of the execution of the SORT statement in the following order of precedence:
    1. First, the collating sequence established by the COLLATING SEQUENCE phrase, if specified, in the SORT statement.
    2. Second, the collating sequence established as the program collating sequence.

General Rules for Format 1

  6. The SORT statement releases all the records in the file referenced by file-name-2 or released by an input procedure to the file referenced by file-name-1, and returns them to an output procedure, or to the file referenced by file-name-3, in an order determined by the ASCENDING and DESCENDING phrases and the values of the data items referenced by the specifications of data-name-1.
  7. To determine the relative order in which two records are returned from the file referenced by file-name-1, the contents of corresponding key data items are compared according to the rules for comparison of operands in a relation condition, starting with the most significant key data item:
    1. If the contents of the corresponding key data items are not equal and the key is associated with the ASCENDING phrase, the record containing the key data item with the lower value is returned first.
    2. If the contents of the corresponding key data items are not equal and the key is associated with the DESCENDING phrase, the record containing the key data item with the higher value is returned first.
    3. If the contents of the corresponding key data items are equal, the determination is made on the contents of the next most significant key data item.
  8. The execution of the SORT statement consists of three distinct phases as follows:
    1. Records are made available to the file referenced by file-name-1. This is achieved either by the execution of RELEASE statements in the input procedure or by the implicit execution of READ statements for file-name-2. When this phase commences, the file referenced by file-name-2 must not be in the open mode. When this phase terminates, the file referenced by file-name-2 is not in the open mode.
    2. The file referenced by file-name-1 is sequenced. No processing of the files referenced by file-name-2 and file-name-3 takes place during this phase.
    3. The records of the file referenced by file-name-1 are made available in sorted order. The sorted records are either written to the file referenced by file-name-3, or, by the execution of a RETURN statement, are made available for processing by the output procedure. When this phase commences, the file referenced by file-name-3 must not be in the open mode. When this phase terminates, the file referenced by file-name-3 is not in the open mode.
  9. The input procedure can consist of any procedure needed to select, modify or copy the records that are made available one at a time by the RELEASE statement to the file referenced by file-name-1. The range includes all statements that are executed as a result of a transfer of control by CALL, EXIT without the optional PROGRAM or METHOD phrase, GO TO and PERFORM statements in the range of the input procedure. The range of the input procedure must not cause the execution of any MERGE, RETURN or SORT statement.
  10. If an input procedure is specified, control is passed to the input procedure before the file referenced by file-name-1 is sequenced by the SORT statement. The compiler inserts a return mechanism at the end of the last statement in the input procedure and when control passes the last statement in the input procedure, the records that have been released to the file referenced by file-name-1 are sorted.
  11. If the USING phrase is specified, all the records in the file(s) referenced by file-name-2 are transferred to the file referenced by file-name-1. For each of the files referenced by file-name-2 the execution of the SORT statement causes the following actions to be taken:
    1. The processing of the file is initiated. The initiation is performed as if an OPEN statement with the INPUT and the WITH LOCK phrases had been executed .
    2. The logical records are obtained and released to the sort operation. Each record is obtained as if a READ statement with the NEXT and AT END phrases had been executed. If the file referenced by file-name-1 contains fixed-length records, any record in the file referenced by file-name-2 containing fewer character positions than that specified for file-name-1 is space-filled on the right, beginning with the first character position after the last character in the record, when that record is released to the file referenced by file-name-1. If the file referenced by file-name-1 is described with variable-length records, the size of any record written to file-name-1 is the size of that record when it was read from file-name-2 or file-name-3, regardless of the contents of the data item referenced by a RECORD VARYING DEPENDING ON or OCCURS DEPENDING ON clause specified in the File Description entry for file-name-1.
    3. The processing of the file is terminated. The termination is performed as if a CLOSE statement without optional phrases had been executed. This termination is performed before the file referenced by file-name-1 is sequenced by the SORT statement.

      For a relative file, the content of the relative key data item is undefined after the execution of a SORT statement if file-name-2 is not referenced in the GIVING phrase.

      These implicit functions are performed such that any associated USE AFTER EXCEPTION procedures are executed; however, the execution of such a USE procedure must not cause the execution of any statement manipulating the file referenced by file-name-2 or accessing the record area associated with file-name-2.

      The value of the data item referenced by a RECORD VARYING DEPENDING ON clause specified in the File Description entry for file-name-2 is undefined upon completion of the SORT statement.

  12. The output procedure can consist of any procedure needed to select, modify or copy the records that are made available one at a time by the RETURN statement in sorted order from the file referenced by file-name-1. The range includes all statements that are executed as a result of a transfer of control by CALL, EXIT without the optional PROGRAM or METHOD phrase, GO TO and PERFORM statements in the range of the output procedure, as well as all statements in the declarative procedures that are executed as a result of the execution of statements in the range of the output procedure. The range of the output procedure must not cause the execution of any MERGE, RELEASE or SORT statement.
  13. If an output procedure is specified, control passes to it after the file referenced by file-name-1 has been sequenced by the SORT statement. The compiler inserts a return mechanism at the end of the last statement in the output procedure and when control passes the last statement in the output procedure, the return mechanism provides for termination of the sort and then passes control to the next executable statement after the SORT statement. Before entering the output procedure, the sort procedure reaches a point at which it can select the next record in sorted order when requested. The RETURN statements in the output procedure are the requests for the next record.
  14. If the GIVING phrase is specified, all the sorted records are written to the file referenced by file-name-3 as the implied output procedure for the SORT statement. For each of the files referenced by file-name-3, the execution of the SORT statement causes the following actions to be taken:
    1. The processing of the file is initiated. The initiation is performed as if an OPEN statement with the OUTPUT phrase had been executed. This initiation is performed after the execution of any input procedure.
    2. The logical records are returned and written to the file. The records are written as if a WRITE statement without any optional phrases had been executed. If the file referenced by file-name-3 is described with fixed-length records, any record in the file referenced by file-name-1 containing fewer character positions than that specified for file-name-3 is space-filled on the right, beginning with the first character position after the last character in the record, when that record is returned to the file referenced by file-name-3. If the file referenced by file-name-3 is described with variable-length records, the size of any record written to file-name-3 is the size of that record when it was read from file-name-1, regardless of the contents of the data item referenced by a RECORD VARYING DEPENDING ON or OCCURS DEPENDING ON clause specified in the File Description entry for file-name-3.

      For a relative file, the relative key data item for the first record returned has the value 1; for the second record returned, the value 2, and so on. The content of the relative key data item is undefined after execution of a SORT statement.

    3. The processing of the file is terminated. The termination is performed as if a CLOSE statement without optional phrases had been executed.

      These implicit functions are performed such that any associated USE AFTER EXCEPTION procedures are executed; however, the execution of such a USE procedure must not cause the execution of any statement manipulating the file referenced by file-name-3 or accessing the record area associated with file-name-3. On the first attempt to write beyond the externally-defined boundaries of a file, the USE AFTER EXCEPTION procedure, if any, associated with the file is executed; if control is returned as specified by the rules of the USE statement, no additional implicit write operations are executed for that file and the processing of the file is terminated as specified in this part.

    The value of the data item referenced by a RECORDING VARYING DEPENDING ON clause specified in the File Description entry for file-name-1 is undefined upon completion of the SORT statement for which the GIVING phrase is specified.

  15. Segmentation, as defined in the topic Segmentation, can be applied to programs containing the SORT statement. However, the following restrictions apply:
    1. If a SORT statement appears in a section that is not in an independent segment, then any input procedures or output procedures referenced by that SORT statement must be contained either:
      • Totally within non-independent segments
      • Wholly contained in a single independent segment.
    2. If a SORT statement appears in an independent segment, then any input procedures or output procedures referenced by that SORT statement must be contained either:
      • Totally within non-independent segments
      • Wholly within the same independent segment as that SORT statement.
  16. OSVS VSC2 MF The SORT-RETURN special register is available to SORT runtime elements. It contains a return code of 0 (successful) or 16 (unsuccessful) at the completion of a sort operation. You can set the SORT-RETURN special register to 16 in an error declarative or input/output procedure to terminate a sort operation before all records are processed. The operation is terminated on the next RETURN or RELEASE statement.

General Rules for Format 2

  17. MF The SORT statement sorts the table referenced by data-name-2 and presents the sorted table in data-name-2 either in the order determined by the ASCENDING or DESCENDING phrases, if specified, or in the order determined by the KEY phrase associated with data-name-2.
  18. MF To determine the relative order in which the table elements are stored after sorting, the contents of the corresponding key data items are compared according to the rules for comparison of operands in a relation condition, starting with the most significant key data item.
    1. If the contents of the corresponding key data items are not equal and the key is associated with the ASCENDING phrase, the table element containing the key data item with the lower value has the lowest occurrence number.
    2. If the contents of the corresponding key data items are not equal and the key is associated with the DESCENDING phrase, the table element containing the key data item with the higher value has the lowest occurrence number.
    3. If the contents of the corresponding key data items are equal, the determination is based on the contents of the next most significant key data item.
  19. MF The number of occurrences of table elements referenced by data-name-2 is determined by the rules in the OCCURS clause.
  20. MF If data-name-2 references a data item which is subordinate to a data item which contains an OCCURS clause, the first or only index-name associated with each such superordinate table must be set to the desired occurrence number before the SORT statement is executed.
  21. MF If the KEY phrase is not specified, the sequence is determined by the KEY phrase in the Data Description entry of the table referenced by data-name-2.
  22. MF If the KEY phrase is specified, it overrides any KEY phrase specified in the Data Description entry of the table referenced by data-name-2.
  23. MF If the key phrase is specified but data-name-1 is omitted, the data item referenced by data-name-2 is the KEY data item.
  24. MF The sorted table elements of the table referenced by data-name-2 are placed in the table referenced by data-name-2.
  25. MF The COLLATING SEQUENCE phrase is treated as documentary only.
  26. SORT procedures should not be invoked by multiple threads simultaneously.

Examples

Examples of using the SORT verb are provided in the topics SORT a File Using Input and Output Procedures and SORT Table Entries.

Parent topic: Statements
Related reference
SORT Statement
Related information
Segmentation
SORT a File Using Input and Output Procedures
SORT Table Entries


The START Statement

The START statement provides a basis for logical positioning within a relative or indexed file for subsequent retrieval of records. This statement is not available for files with sequential organization.

MF The START statement initiates execution of a thread, either synchronously or asynchronously.

General Formats for Format 1 (Relative Files)

General Formats for Format 2 (Indexed Files)

General Formats for Format 3 (Threads)

Syntax Rules for All Formats (Relative and Indexed Files)

  1. File-name-1 must be the name of a relative or indexed file.
  2. File-name-1 must be the name of a file with sequential or dynamic access.
  3. Data-name-1 can be qualified.
  4. The INVALID KEY phrase must be specified if no applicable USE procedure is specified for file-name-1.

    OSVS VSC2 MF This rule is not enforced.

Syntax Rules for Format 1 (Relative Files)

  5. If the KEY phrase is specified, data-name-1 must be the data item specified in the RELATIVE KEY phrase of the associated file control entry.

Syntax Rules for Format2 (Indexed Files)

  6. If the KEY phrase is specified, data-name-1 can reference a data item specified as a record key associated with file-name-1. It can also reference any data item of category alphanumeric, subordinate to the data item specified as a record key associated with file-name-1, whose leftmost character position corresponds to the leftmost character position of that record key data item.
  7. MF Split-key-name-1 can reference one or more data items, and is specified as a record key associated with file-name-1.
  8. MF WITH SIZE specifies the number of characters in the key to be used in the positioning process.
  9. MF Identifier-1 must be the name of an elementary integer data item when used with the WITH SIZE phrase.

Syntax Rules for Format 3 (Threads)

  10. MF Literal-1 must be a nonnumeric literal and cannot be a figurative constant.
  11. MF Identifier-1 must be defined as an alphanumeric data item such that its value can be a COBOL or non-COBOL program-name.
  12. MF Identifier-3 must be defined as either USAGE POINTER or a data item that is four bytes in size. The definition depends on the definition of the GIVING/RETURNING item within the EXIT PROGRAM / STOP RUN statement for the new thread. If identifier-3 is defined as a USAGE POINTER item, it must not be a function-identifier.
  13. MF Thread-pointer-1 must be defined as USAGE THREAD-POINTER.
  14. MF Identifier-4 must be defined as an integer data item that has a length of at least four digits.

General Rules for All Formats (All Files)

  1. File-name-1 must be open in the INPUT or I/O mode at the time that the START statement is executed. (See the topic The OPEN Statement.)
  2. If the KEY phrase is not specified, the relational operation IS EQUAL TO is implied.
  3. Execution of the START statement causes the value of the FILE STATUS data item, if any, associated with file-name-1 to be updated. (See the topic I-O Status in the chapter Procedure Division.)
  4. MF The START statement never acquires, detects or releases record locks.

General Rules for Format 1 (Relative Files)

  5. The type of comparison specified by the relational operator in the KEY phrase occurs between a key associated with a record in the file referenced by file-name-1 and a data item as specified in General Rule 6.
    1. ANS85 If the relational operator specifies that the key must be equal to, greater than, or greater than or equal to the data item, then

      the file position indicator is positioned to the first logical record currently existing in the file whose key satisfies the comparison.

    2. MF If the relational operator specifies that the key must be less than, or less than or equal to the data item, then the file position indicator is positioned to the last logical record currently existing in the file whose key satisfies the comparison.
    3. If the comparison is not satisfied by any record in the file, an INVALID KEY condition exists. The execution of the START statement is unsuccessful, and the position of the file position indicator is undefined. (See the topic The INVALID KEY Condition in the chapter Procedure Division.)
  6. The comparison described in General Rule 5 uses the data item referenced by the RELATIVE KEY clause associated with file-name-1. A RELATIVE KEY clause must be associated with file-name-1.

General Rules for Format 2 (Indexed Files)

  7. The type of comparison specified by the relational operator in the KEY phrase occurs between a key associated with a record in the file referenced by file-name-1 and a data item as specified in General Rule 8. If file-name-1 references an indexed file and the operands are of unequal size, the comparison proceeds as though the longer one were truncated on the right so that its length is equal to that of the shorter. All other nonnumeric comparison rules apply except that the presence of the PROGRAM COLLATING SEQUENCE clause has no effect on the comparison. (See the topic Comparison of Nonnumeric Operands in the section Relation Condition in the chapter Procedure Division.)
    1. ANS85 If the relational operator specifies that the key must be equal to, greater than, or greater than or equal to the data item, then

      the file position indicator is positioned to the first logical record currently existing in the file whose key satisfies the comparison.

    2. MF If the relational operator specifies that the key must be less than, or less than or equal to the data item, then the file position indicator is positioned to the last logical record currently existing in the file whose key satisfies the comparison. If this key has duplicate entries, the file position indicator is positioned to the last of these entries.
    3. If the comparison is not satisfied by any record in the file, an INVALID KEY condition exists, the execution of the START statement is unsuccessful, and the position of the file position indicator is undefined. (See the topic The INVALID KEY Condition in the chapter Procedure Division.)
  8. If the KEY phrase is specified, the comparison described in General Rule 7 uses the data item referenced by data-name.
  9. If the KEY phrase is not specified, the comparison described in General Rule 7 uses the data item referenced in the RECORD KEY clause associated with file-name-1.
  10. After successful execution of the START statement, a key of reference is established and used in subsequent Format 3 READ statements as follows (see the topic The READ Statement):
    1. If the KEY phrase is not specified, the prime record key specified for file-name-1 becomes the key of reference.
    2. If the KEY phrase is specified, and data-name-1

      MF or split-key-name-1

      is specified as a record key for file-name-1, that record key becomes the key of reference.

    3. If the KEY phrase is specified, and data-name-1

      MF or split-key-name-1

      is not specified as a record key for file-name-1, the record key whose leftmost character position corresponds to the leftmost character position of the data item specified by data-name-1

      MF or split-key-name-1

      becomes the key of reference.

  11. If execution of the START statement is not successful, the key of reference is undefined.

General Rules for Format 3 (Threads)

  12. MF Literal-1, identifier-1, or procedure-pointer-1 must reference a program-id which is either the outermost program-id in a compilation unit, an ENTRY point in a program or a label in another language. This is the starting point of the newly created thread's execution.
  13. MF If identifier-2 is specified, the starting point of the newly created thread must be defined in such a way that it accepts a single parameter that is passed by reference.
  14. MF If the BY CONTENT phrase is specified, the contents of identifier-2 are copied to a system-allocated, thread-safe work area and a reference to this work area is passed to the starting point of the newly created thread. This work area remains valid during the entire execution of the created thread, irrespective of the lifetime of the creating program's data areas.
  15. MF If the BY CONTENT phrase is not specified, a direct reference to identifier-2 is passed to the starting point of the newly created thread. It is left to you to ensure that this data area remains valid while the newly created thread references it.
  16. MF If the RETURNING phrase is specified, the newly created thread executes to completion, returns a value in identifier-3 and returns control to the START statement.
  17. MF If the IDENTIFIED BY phrase is specified, execution of the newly created thread is initiated, a handle to reference the newly created thread is placed into thread-pointer-1 and control is returned to the START statement. The handle can be used in a WAIT statement to retrieve a returned value, synchronize execution and free the thread's resources. This handle is a valid thread handle as used by the CBL_THREAD_ library routines.
  18. MF If neither the RETURNING phrase nor the IDENTIFIED phrase is specified, the newly created thread is initiated and control is returned to the START statement. All resources of the thread are automatically freed when the thread terminates.
  19. MF If the STATUS phrase is specified, the execution of the START statement places into identifier-4 one of the return codes specified for the CBL_THREAD_ library routines.
  20. MF If the START statement fails, one of the return codes specified for the CBL_THREAD_ library routines is placed into identifier-4, if specified, and then one of the following occurs:
    1. If the ON EXCEPTION phrase is specified, control is transferred to imperative-statement-1. Execution then continues according to the rules for each statement specified in imperative-statement-1. If a procedure-branching or conditional statement that causes explicit transfer of control is executed, control is transferred in accordance with the rules of that statement; otherwise, upon completion of the execution of imperative-statement-1, control is transferred to the end of the START statement and the NOT ON EXCEPTION phrase, if specified, is ignored.
    2. Otherwise, if the NOT ON EXCEPTION phrase or the STATUS phrase is specified, control is transferred to the end of the START statement and the NOT ON EXCEPTION phrase, if specified, is ignored.
    3. Otherwise, the run-unit terminates with a run-time system error.
  21. MF If the START statement is successful, the following occurs in the order specified:
    1. If the STATUS phrase is specified, ZERO is moved to identifier-4.
    2. If the NOT ON EXCEPTION phrase is specified, control is transferred to imperative-statement-2. Execution then continues according to the rules for each statement specified in imperative-statement-2. If a procedure-branching or conditional statement that causes explicit transfer of control is executed, control is transferred in accordance with the rules of that statement; otherwise, upon completion of the execution of imperative-statement-2, control is transferred to the end of the START statement and the ON EXCEPTION phrase, if specified, is ignored.
Parent topic: Statements
Related information
The OPEN Statement
I-O Status
The INVALID KEY Condition
Relation Condition
The READ Statement


The STOP Statement

The STOP statement causes a permanent or temporary suspension of the execution of the run unit.

ANS85 The STOP literal statement is classed as an obsolete element in the ANSI'85 Standard and is scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects within this COBOL implementation fully support this syntax. The FLAGSTD Compiler directive can be used to detect all occurrences of this syntax.

XOPEN Although it is a part of the standard COBOL definition, the Stop literal format is explicitly excluded from the X/Open COBOL language definitions and should not be used in an X/Open COBOL conforming source program.

General Format for Format 1

General Format for Format 2

General Format for Format 3

Syntax Rules

  1. Literal-1 must not be a figurative constant that begins with the word ALL.
  2. If literal-1 is numeric, then it must be an unsigned integer.

    OSVS VSC2 A signed integer is allowed.

  3. MF Integer-1 may be signed.
  4. If a STOP RUN statement appears in a consecutive sequence of imperative statements within a sentence, it must appear as the last statement in that sequence.

    OSVS VSC2 MF This rule is not enforced, although any statements in the sentence that follow the STOP RUN statement will not be executed.

  5. MF GIVING and RETURNING are equivalent.
  6. MF Identifier-1 must be no larger than 8 bytes in size.
  7. MF If a STOP RUN GIVING statement is executed within a thread created with the START statement (format 3 threads) and if the ADDRESS OF clause is not specified, identifier-1 must be defined as either USAGE POINTER or a data item that is four bytes in size. The definition depends on the definition of the RETURNING item within the START statement. If identifier-1 is defined as a USAGE POINTER item, it must not be a function-identifier.
  8. NET JVM STOP ITERATOR may only be specified in the context of an Iterator. See Iterator-ID.

General Rules

  1. If the RUN phrase is specified, execution of the run unit ceases and control is transferred to the operating system.
  2. During the execution of a STOP RUN statement, an implicit CLOSE statement without any optional phrases is executed for each file that is in the open mode in the run unit. Any USE procedures associated with any of these files are not executed.
  3. MF Execution of a STOP RUN statement causes a return value to be set in the system area generally available for non-COBOL runtime elements to return a value. If the operating system supports the facility of returning a value from a program that is run to the operating system environment then it returns the value from the system area.

    If the GIVING phrase is not specified then the run unit operates as if the system area were declared as a COBOL numeric data item with USAGE COMP-5 and with a size determined by the operating environment external to the COBOL system and as if a MOVE statement had been executed with the RETURN-CODE as the sending item and the system area as the receiving item. (See the topic Special Registers in the chapter Concepts of the COBOL Language for details of RETURN-CODE.)

    If the GIVING identifier-1 phrase is specified, identifier-1 must describe the same number of character positions as is required to hold the return value in the system area and must be of the type and usage that is expected by the operating system. Typically identifier-1 needs to be declared explicitly or implicitly as PIC S9 (9) USAGE COMP-5. The run unit operates as if a MOVE statement had been executed with identifier-1 as the sending item and the system area as the receiving item.

    If the GIVING integer-1 phrase is specified, integer-1 must not be larger than the value that can be held in the system area. The run unit operates as if a MOVE statement had been executed with integer-1 as the sending item and the system area as the receiving item.

  4. If STOP literal-1 is specified, the execution of the run unit is suspended and literal-1 is communicated to the operator. Continuation of the execution of the run unit begins with the next executable statement when the operator presses the ENTER key or its equivalent.
  5. When executed within a thread created with a START statement or the CBL_CREATE_THREAD library routine, a STOP RUN GIVING statement does not end the run-unit; it simply provides a return value and terminates the thread. It is equivalent to:
    CALL 'CBL_THREAD_EXIT' USING BY VALUE ADDRESS OF thread-parm
  6. MF STOP RUN in threads not created by the START statement or CBL_THREAD_CREATE library routine (that is, the main thread, or a thread created by a program written in another programming language) waits for all active CBL_THREAD_CREATE threads to finish and then terminates the run unit.
  7. NET JVM The STOP ITERATOR statement has the effect of terminating the iterator.
Parent topic: Statements
Related information
The Iterator-ID Paragraph
Special Registers


The STRING Statement

The STRING statement provides concatenation of the partial or complete contents of two or more data items into a single data item.

General Format

Syntax Rules

  1. Each literal can be any figurative constant without the optional word ALL.
  2. All literals must be described as nonnumeric literals, and all identifiers, except identifier-4, must be described implicitly or explicitly as USAGE IS DISPLAY.
  3. Identifier-3 must represent an elementary alphanumeric data item without editing symbols or the JUSTIFIED clause.
  4. Identifier-4 must represent an elementary numeric integer data item of sufficient size to contain a value equal to the size plus 1 of the area referenced by identifier-3. The symbol "P" cannot be used in the PICTURE character-string of identifier-4.
  5. Where identifier-1 or identifier-2 is an elementary numeric data item, it must be described as an integer without the symbol "P" in its PICTURE character-string.
  6. ANS85 Identifier-3 must not be reference modified.
  7. MF OS390 Identifier-3 can be reference modified.

General Rules

  1. Identifier-1, or literal-1, represents the sending item. Identifier-3 represents the receiving item.
  2. Literal-2, identifier-2, indicate the character(s) delimiting the move. If the SIZE phrase is used, the complete data item defined by identifier-1, or literal-1, is moved. When a figurative constant is used as the delimiter, it stands for a single-character nonnumeric literal.
  3. When a figurative constant is specified as literal-1, or literal-2, it refers to an implicit one-character data item whose usage is DISPLAY.
  4. When the STRING statement is executed, the transfer of data is governed by the following rules:
    1. Those characters from literal-1, or from the contents of the data item referenced by identifier-1, are transferred to the contents of identifier-3 in accordance with the rules for alphanumeric to alphanumeric moves, except that no space filling is provided. (See the topic The MOVE Statement.)
    2. If the DELIMITED phrase is specified without the SIZE phrase, the contents of the data item referenced by identifier-1, or the value of literal-1, is transferred to the receiving data item in the sequence specified in the STRING statement beginning with the leftmost character and continuing from left to right until the end of the data item is reached, or until the character(s) specified by literal-2, or by the contents of identifier-2 are encountered. The character(s) specified by literal-2, or by the data item referenced by identifier-2, are not transferred.
    3. If the DELIMITED phrase is specified with the SIZE phrase, the entire contents of literal-1, or the contents of the data item referenced by identifier-1, are transferred, in the sequence specified in the STRING statement, to the data item referenced by identifier-3 until all data has been transferred or the end of the data item referenced by identifier-3 has been reached.
  5. If the POINTER phrase is specified, identifier-4 is explicitly available to you, and you are then responsible for setting its initial value. The initial value must not be less than one.
  6. If the POINTER phrase is not specified, the following General Rules apply as if you had specified identifier-4 with an initial value of 1.
  7. When characters are transferred to the data item referenced by identifier-3, the moves behave as though the characters were moved one at a time from the source into the character position of the data item referenced by identifier-3 designated by the value associated with identifier-4, and then identifier-4 was increased by one prior to the move of the next character. The value associated with identifier-4 is changed during execution of the STRING statement only by the behavior specified above.
  8. At the end of execution of the STRING statement, only the portion of the data item referenced by identifier-3 that was referenced during the execution of the STRING statement is changed. All other portions of the data item referenced by identifier-3 contains data that was present before this execution of the STRING statement.
  9. Before each move of a character to the data item referenced by identifier-3, if the value associated with the data item referenced by identifier-4 is either less than one or exceeds the number of character positions in the data item referenced by identifier-3, no (further) data is transferred to the data item referenced by identifier-3,

    ANS85 the NOT ON OVERFLOW phrase, if specified, is ignored

    and control is transferred to the end of the STRING statement or, if the ON OVERFLOW phrase is specified, to imperative-statement-1. If control is transferred to imperative-statement-1, execution continues according to the rules for each statement specified in imperative-statement-1. If a procedure branching or conditional statement which causes explicit transfer of control is executed, control is transferred in accordance with the rules for that statement; otherwise, upon completion of the execution of imperative-statement-1, control is transferred to the end of the STRING statement.

  10. ANS85 If, at the time of execution of a STRING statement with the NOT ON OVERFLOW phrase, the conditions described in General Rule 9 are not encountered, after completion of the transfer of data according to the other general rules, the ON OVERFLOW phrase, if specified, is ignored and control is transferred to the end of the STRING statement or, if the NOT ON OVERFLOW phrase is specified, to imperative- statement-2. If control is transferred to imperative-statement-2, execution continues according to the rules for each statement specified in imperative-statement-2. If a procedure-branching or conditional statement which causes explicit transfer of control is executed, control is transferred in accordance with the rules for that statement; otherwise, upon completion of the execution of imperative-statement-2, control is transferred to the end of the STRING statement.
  11. ANS85 The END-STRING phrase delimits the scope of the STRING statement. (
Parent topic: Statements
Related concepts
Explicit and Implicit Scope Terminators


The SUBTRACT Statement

The SUBTRACT statement is used to subtract one, or the sum of two or more, numeric data items from one or more items, and set the values of one or more items equal to the results.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

Syntax Rules for All Formats

  1. Each identifier must refer to a numeric elementary item, except that in Format 2 each identifier following the word GIVING must refer to either an elementary numeric item or an elementary numeric edited item, and in Format 3 each identifier must refer to a group item.
  2. The composite of operands is determined as follows (see the topic Arithmetic Statements in the chapter Procedure Division):
    1. In Format 1, by using all of the operands in a given statement.
    2. In Format 2, by using all of the operands in a given statement excluding the data items that follow the word GIVING.
    3. In Format 3, separately for each pair of corresponding data items.

Syntax Rules for Formats1 and 2

  3. Each literal must be a numeric literal.
  4. OSVS VSC2 MF Floating-point data items and literals can be used anywhere numeric data items and literals can be specified.

Syntax Rules for Format 3

  5. CORR is an abbreviation for CORRESPONDING.

General Rules for All Formats

  1. See the topics The ROUNDED Phrase, The ON SIZE ERROR Phrase, Arithmetic Statements, Overlapping Operands and Multiple Results In Arithmetic Statements in the chapter Procedure Division.
  2. VSC2 MF The COBOL system ensures enough places are carried so as not to lose significant digits during execution.

General Rules for Format 1

  3. All literals or identifiers preceding the word FROM are added together and this total is subtracted from the current value of identifier-2 storing the result immediately into identifier-2, and repeating this process respectively for each operand following the word FROM.

General Rules for Format 2

  4. In Format 2, all literals or identifiers preceding the word FROM are added together, the sum is subtracted from literal-2 or identifier-2 and the result of the subtraction is stored as the new value of each data item referenced by identifier-3.

General Rules for Format 3

  5. If Format 3 is used, data items in identifier-1 are subtracted from and stored into corresponding data items in identifier-2.
Parent topic: Statements
Related information
Arithmetic Statements
The ON SIZE ERROR Phrase
The ROUNDED Phrase
Overlapping Operands
Multiple Results In Arithmetic Statements


The SYNC Statement

The SYNC statement marks a statement block as a critical section by obtaining the mutual-exclusion lock for a given object, executing a block of statements, and then releasing the lock.

General Format

Syntax Rules

  1. identifier-1 must be a reference type.

General Rules

  1. identifier-1 specifies the object that you want to lock on. Typically, identifier-1 is the SELF keyword if you want to protect an instance variable, or a type if you want to protect a static variable (or if the critical section occurs in a static method in the given class).
  2. statement- block-1 represents the statements of the critical section.
  3. When the object is locked, code executing in the same execution thread can also obtain and release the lock. However, code executing in other threads cannot. It is blocked until the lock is released.

Example

In the following example, the SYNC statement locks a set of critical statements.

method-id Withdraw.
procedure division using by value amount as binary-long
                   returning ret as binary-long.
           sync on self
               if balance >= amount
                   display "In critical section"
                   compute balance = balance - amount
                   set ret to amount
               else
                   display "In critical section"
                   set ret to 0
               end-if
           end-sync
end method.
Parent topic: Statements


The TRANSFORM Statement

The TRANSFORM statement is used to alter characters according to a transformation rule.

General Format

Syntax Rules

  1. Identifier-3 can be any elementary item except a numeric item with USAGE other than DISPLAY, or a group item.
  2. Identifier-1 and identifier-2 must be elementary alphabetic or alphanumeric items.
  3. Nonnumeric-literal-2 or identifier-2 must be either one character long or the same length as nonnumeric-literal-1 or identifier-1.

General Rules

  1. The use of figurative-constant-1 and/or figurative-constant-2 is equivalent to the use of a single-character nonnumeric literal with the same value.
  2. If either identifier-1 or identifier-2 references the same computer storage area as identifier-3, the result of the TRANSFORM is undefined. (See the topic The REDEFINES Clause .)
  3. If characters are repeated in nonnumeric-literal-1 or identifier-1, then the result of the TRANSFORM operation is undefined.
  4. The TRANSFORM statement scans identifier-3 for occurrences of individual characters from identifier-1 or nonnumeric-literal-1. When a match is found, the corresponding character (or the single character of a one-character field) from identifier-2 or nonnumeric-literal-2 is substituted into that character position in identifier-3. The correspondence between identifier-1 or nonnumeric- literal-1 and identifier-2 or nonnumeric-literal-2 is by occurrence number of the character within the data item (starting from the left).
Parent topic: Statements
Related information
The REDEFINES Clause


The TRY Statement

The TRY...CATCH...FINALLY...END-TRY structure is the basis for structured exception handling. The TRY block allows you to test a section of code for exceptions that may occur during its execution. The CATCH block must specify the type of exception you wish to handle if one should occur during the execution of the TRY block. The FINALLY block allows you to execute a section of code following the TRY block, whether or not an exception occurred.

General Formats

Syntax Rules

  1. Identifier-1 must be an object reference of class System.Exception or a subclass of System.Exception.

General Rules

  1. If identifier-1 is omitted, it is equivalent to specifying the special register EXCEPTION-OBJECT as identifier-1. EXCEPTION-OBJECT has class System.Exception.
  2. If an exception is raised during the execution of imperative-statement-1, each CATCH phrase is examined in the order specified until one is found for which the class of the exception that was thrown is equal to, or derives from, the class of identifier-1. If such an identifier-1 is found, identifier-1 is set to contain the value of the thrown exception, and the associated imperative-statement-2 is executed. Execution continues according to the rules for each statement specified in imperative-statement-2. If a control branching or conditional statement that causes explicit transfer of control is executed, control is transferred in accordance with the rules for that statement; otherwise, upon completion of the execution of imperative-statement-2, control is transferred to imperative-statement 3, if specified, or to the end of the TRY statement.
  3. If no exception is raised during the execution of imperative-statement-1, execution continues according to the rules for each statement specified in imperative-statement-1. If a control branching or conditional statement that causes explicit transfer of control is executed, control is transferred in accordance with the rules for that statement; otherwise, upon completion of the execution of imperative-statement-1, control is transferred to imperative-statement 3, if specified, or to the end of the TRY statement.
  4. Execution of imperative-statement-3 continues according to the rules for each statement specified in imperative-statement-3. If a control branching or conditional statement that causes explicit transfer of control is executed, control is transferred in accordance with the rules for that statement; otherwise, upon completion of the execution of imperative-statement-3, control is transferred to the end of the TRY statement

Example

The following is an example of specifying the EXCEPTION-OBJECT register:

           try
               set str to "some string"
           catch
               display exception-object::ToString()
           finally
           end-try
Parent topic: Statements


The UNLOCK Statement

The UNLOCK statement releases all record locks held by the run unit on a named file.

General Format

Syntax Rule

  1. File-name must occur in the SELECT statement of the file control entry.

General Rules

  1. The file referenced by file-name must already be opened with the OPEN statement.
  2. The UNLOCK statement releases all record locks held by the run unit on a named file.
Parent topic: Statements


The UNSTRING Statement

The UNSTRING statement causes contiguous data in a sending field to be separated and placed into multiple receiving fields.

General Format

Syntax Rules

  1. Each literal must be a nonnumeric literal. In addition, each literal can be any figurative constant without the optional word ALL.
  2. Identifier-1, identifier-2, identifier-3, and identifier-5 must be described, implicitly or explicitly, as alphanumeric data items.
  3. Identifier-4 can be described as either alphabetic (except that the symbol "B" cannot be used in the PICTURE character-string), alphanumeric, or numeric (except that the symbol "P" cannot be used in the PICTURE character-string), and must be described as USAGE IS DISPLAY.
  4. MF Syntax Rules 2 and 3 do not apply. Instead, the following rules apply:
    1. Identifier-1 must be alphanumeric
    2. Identifier-2 and identifier-3 must be USAGE DISPLAY and must not be edited
    3. Identifier-5 must be USAGE DISPLAY
    4. Identifier-4 can be USAGE DISPLAY
    5. Identifier-4 can have any USAGE that defines a numeric data item as long as the data results in a valid MOVE operation.
  5. OSVS VSC2 MF Identifier-4 must not be defined as a floating-point item.
  6. Identifier-6 and identifier-8 must reference integer data items (except that the symbol " P" cannot be used in the PICTURE character-string).
  7. Identifier-7 must be described as an elementary numeric integer data item of sufficient size to contain a value equal to 1 plus the size of the data item referenced by identifier-1. The symbol "P" cannot be used in the PICTURE character string of identifier-7.
  8. No identifier can name a level 88 entry.
  9. The DELIMITER IN phrase and the COUNT IN phrase can be specified only if the DELIMITED BY phrase is specified.
  10. MF Identifier-1 must not be reference modified.
  11. ISO2002 MF OS390 Identifier-1 can be reference modified.

General Rules

  1. All references to identifier-2, literal-1, apply equally to identifier-3, literal-2, respectively and all recursions thereof.
  2. Identifier-1 represents the sending area.
  3. Identifier-4 represents the data receiving area. Identifier-5 represents the receiving area for delimiters.
  4. Literal-1 or the data item referenced by identifier-2 specifies a delimiter.
  5. The data item referenced by identifier-6 represents the count of the number of characters within the data item referenced by identifier-1 isolated by the delimiters for the move to the data item referenced by identifier-4. This value does not include a count of the delimiter character(s).
  6. The data item referenced by identifier-7 contains a value that indicates a relative character position within the area defined by identifier-1.
  7. The data item referenced by identifier-8 is a counter that records the number of data items acted upon during the execution of an UNSTRING statement.
  8. When a figurative constant is used as the delimiter, it stands for a single character nonnumeric literal.

    When the ALL phrase is specified, one occurrence or two or more contiguous occurrences of literal-1 (figurative constant or not) or the contents of the data item referenced by identifier-2 are treated as if it were only one occurrence, and this occurrence is moved to the receiving data item according to the rules in General Rule 13d.

  9. When any examination encounters two contiguous delimiters, the current receiving area is either space- or zero-filled according to the description of the receiving area.
  10. Literal-1 or the contents of the data item referenced by identifier-2 can contain any character in the computer's character set.
  11. Each literal-1 or the data item referenced by identifier-2 represents one delimiter. When a delimiter contains two or more characters, all of the characters must be present in contiguous positions of the sending item and in the order given, to be recognized as a delimiter.
  12. When two or more delimiters are specified in the DELIMITED BY phrase, an "OR" condition exists between them. Each delimiter is compared to the sending field. If a match occurs, the character(s) in the sending field is considered to be a single delimiter. No character(s) in the sending field can be considered a part of more than one delimiter.

    Each delimiter is applied to the sending field in the sequence specified in the UNSTRING statement.

  13. When the UNSTRING statement is initiated, the current receiving area is the data item referenced by identifier-4. Data is transferred from the data item referenced by identifier-1 to the data item referenced by identifier-4 according to the following rules:
    1. If the POINTER phrase is specified, the string of characters referenced by identifier-1 is examined beginning with the relative character position indicated by the contents of the data item referenced by identifier-7. If the POINTER phrase is not specified, the string of characters is examined beginning with the leftmost character position.
    2. If the DELIMITED BY phrase is specified, the examination proceeds left to right until either a delimiter specified by the value of literal-1 or the data item referenced by identifier-2 is encountered. (See General Rule 11.) If the DELIMITED BY phrase is not specified, the number of characters examined is equal to the size of the current receiving area. However, if the sign of the receiving item is defined as occupying a separate character position, the number of characters examined is one less than the size of the current receiving area.

      If the end of the data item referenced by identifier-1 is encountered before the delimiting condition is met, the examination terminates with the last character examined.

    3. The characters thus examined (excluding the delimiting character(s), if any) are treated as an elementary alphanumeric data item, and are moved into the current receiving area according to the rules for the MOVE statement. (See the section The MOVE Statement.)
    4. If the DELIMITER IN phrase is specified, the delimiting character(s) are treated as an elementary alphanumeric data item and are moved into the data item referenced by identifier-5 according to the rules for the MOVE statement. (See the topic The MOVE Statement.) If the delimiting condition is the end of the data item referenced by identifier-1, then the data item referenced by identifier-5 is space-filled.
    5. If the COUNT IN phrase is specified, a value equal to the number of characters thus examined (excluding the delimiter character(s) if any) is moved into the area referenced by identifier-6 according to the rules for an elementary move.
    6. If the DELIMITED BY phrase is specified, the string of characters is further examined beginning with the first character to the right of the delimiter. If the DELIMITED BY phrase is not specified, the string of characters is further examined beginning with the character to the right of the last character transferred.
    7. After data is transferred to the data item referenced by identifier-4, the current receiving area is the data item referenced by the next recurrence of identifier-4. The behavior described in paragraphs 13b through 13f is repeated until either all the characters are exhausted in the data item referenced by identifier-1, or until there are no more receiving areas.
  14. The initialization of the contents of the data items associated with the POINTER phrase or the TALLYING phrase is your responsibility.
  15. The contents of the data item referenced by identifier-7 is incremented by one for each character examined in the data item referenced by identifier-1. When the execution of an UNSTRING statement with a POINTER phrase is complete, the data item referenced by identifier-7 contains a value equal to the initial value plus the number of characters examined in the data item referenced by identifier-1.
  16. When the execution of an UNSTRING statement with a TALLYING phrase is completed, the contents of the data item referenced by identifier-8 contains a value equal to its initial value plus the number of data receiving items acted upon.
  17. Either of the following situations causes an overflow condition:
    1. An UNSTRING is initiated, and the value in the data item referenced by identifier-7 is less than 1 or greater than the size of the data item referenced by identifier-1.
    2. During execution of an UNSTRING statement, all data receiving areas have been acted upon, and the data item referenced by identifier-1 contains characters that have not been examined.
  18. When an overflow condition exists, the UNSTRING operation is terminated,

    ANS85 the NOT ON OVERFLOW phrase, if specified, is ignored,

    and control is transferred to the end of the UNSTRING statement or, if the ON OVERFLOW phrase is specified, to imperative-statement-1. If control is transferred to imperative-statement-1, execution continues according to the rules for each statement specified in imperative-statement-1. If a procedure branching or conditional statement which causes explicit transfer of control is executed, control is transferred in accordance with the rules for that statement; otherwise, upon completion of the execution of imperative-statement-1, control is transferred to the end of the UNSTRING statement.

  19. ANS85 The END-UNSTRING phrase delimits the scope of the UNSTRING statement. (See the section Explicit and Implicit Scope Terminators in the chapter Concepts of the COBOL Language.)
  20. If, at the time of execution of an UNSTRING statement, the conditions described in General Rule 17 are not encountered, after completion of the transfer of data according to the other general rules, the ON OVERFLOW phrase, if specified, is ignored and control is transferred to the end of the UNSTRING statement

    ANS85 or, if the NOT ON OVERFLOW phrase is specified, to imperative-statement-2. If control is transferred to imperative- statement-2, execution continues according to the rules for each statement specified in imperative-statement-2. If a procedure branching or conditional statement which causes explicit transfer of control is executed, control is transferred in accordance with the rules for that statement; otherwise, upon completion of the execution of imperative-statement-2, control is transferred to the end of the UNSTRING statement.

  21. The evaluation of subscripting and indexing for the identifiers is as follows:
    1. Any subscripting or indexing associated with identifier-1, identifier-7, or identifier-8 is evaluated only once, immediately before any data is transferred as the result of the execution of the UNSTRING statement.
    2. Any subscripting or indexing associated with identifier-2, -3, -4, -5, or -6 is evaluated immediately before the transfer of data into the respective data item.
    3. ANS85 22..Any subscripting associated with the DELIMITED BY identifier, the INTO identifier, the DELIMITER IN identifier, or the COUNT IN identifier is evaluated once, immediately before the examination of the sending fields for the delimiter.
  22. If identifier-1, -2 or -3 occupies the same storage area as identifier-4, -5, -6, -7 or -8, or if identifier-4, -5 or -6 occupies the same storage area as identifier-7 or -8, or if identifier-7 and identifier-8 occupy the same storage area, the result of the execution of this statement is undefined, even if they are defined by the same data description entry.
Parent topic: Statements
Related information
The MOVE Statement
Explicit and Implicit Scope Terminators


The USE Statement

The USE statement specifies procedures for input-output error handling, that are in addition to the standard procedures provided by the input-output control system.

General Formats for Format 1 (Sequential , Relative and Indexed Files)

General Formats for Format 2 (Record Sequential Files)

General Formats for Format 3 (Relative and Indexed Files)

Syntax Rules for All Formats (All Files)

  1. Format 1 is the ERROR declarative.

    OSVS VSC2 Formats 2 and 3 are the LABEL declarative.

  2. A USE statement, when present, must immediately follow a section header in the Declaratives Section and must be followed by a period followed by a space.
  3. The USE statement itself is never executed; it merely defines the conditions calling for the execution of the USE procedures.
  4. The files implicitly or explicitly referenced in a USE statement need not all have the same organization or access.

Syntax Rules for Format 1 (Sequential, Relativeand Indexed Files)

  5. The same file-name can appear in a different specific arrangement of the format. Appearance of a file-name in a USE statement must not cause the simultaneous request for execution of more than one USE procedure.

    ANS85 The same file-name must not appear in more than one USE AFTER EXCEPTION statement within the same Procedure Division.

  6. The words ERROR and EXCEPTION are equivalent and can be used interchangeably.

Syntax Rules for Formats 2 and 3 (Record Sequential,Relative and Indexed Files)

  7. OSVS VSC2 If both BEGINNING and ENDING are omitted, the effect is as though both BEGINNING and ENDING had been specified.

Syntax Rules for Format 2 (Record Sequential Files)

  8. OSVS VSC2 REEL and UNIT are treated as equivalent.
  9. OSVS VSC2 If both FILE and REEL/UNIT are omitted, the effect is as though both REEL or UNIT and FILE had been specified.
  10. OSVS VSC2 Any one file-name and any one OPEN mode can appear in only one declarative for each of the possible combinations of BEGINNING/ENDING and FILE/REEL as shown below:
    • BEGINNING FILE
    • BEGINNING REEL/UNIT
    • ENDING FILE
    • ENDING REEL/UNIT

General Rules for All Formats (All Files)

  1. After execution of a USE procedure, control is returned to the invoking routine. Note that control is not returned if an exception is trapped.
  2. Within a USE procedure, there must not be any reference to any non-declarative procedures. Conversely, in the non-declarative portion there must be no reference to procedure-names that appear in the declarative portion, except that PERFORM statements can refer to a USE statement.

    OSVS VSC2 MF This restriction can be ignored.

  3. Within a USE procedure, there must be no execution of any statement that would cause the execution of a USE procedure that has previously been invoked and has not yet returned control to the invoking routine.

General Rules for Format 1 (Sequential,Relative and Indexed Files)

  4. The designated procedures are executed by the input-output system after completing the standard input-output error routine, or upon recognition of the AT END condition, when the AT END phrase has not been specified in the input-output statement.
  5. ANS85 When file-name-1 is specified explicitly, no other USE statement applies to file-name-1.
  6. The GIVING phrase is documentary only.

General Rules for Formats 2 and 3 (Record Sequential,Relative and Indexed Files)

  7. OSVS VSC2 If the BEGINNING phrase is specified explicitly or implicitly, the following actions are taken during the execution of an applicable OPEN statement:
    Open Mode Action
    INPUT
    1. Read header labels
    2. Execute beginning declarative
    OUTPUT
    1. Execute beginning declarative
    2. Write header labels
    I/O
    1. Read header labels
    2. Execute beginning declarative
    3. Write header labels
    EXTEND
    1. Read header labels
    2. Execute beginning declaratives (trailer labels treated as header)
    3. Write header labels
  8. OSVS VSC2 If the ENDING phrase is specified explicitly or implicitly, the following actions are taken during the execution of an applicable CLOSE statement:
    Open Mode Action
    INPUT
    1. Read trailer labels
    2. Execute ending declarative
    OUTPUT
    1. Execute ending declarative
    2. Write trailer labels
    I/O
    1. Read trailer labels
    2. Execute ending declarative
    3. Write trailer labels
    EXTEND
    1. Execute ending declaratives
    2. Write trailer labels
  9. OSVS VSC2 The statement GO TO MORE-LABELS appearing in a declarative procedure is treated as a simple jump to the start of the declarative procedure in which it appears.
Parent topic: Statements


The WAIT Statement

The WAIT statement suspends the current thread's execution until the targeted thread's execution terminates and optionally retrieves the value returned from the targeted thread's execution.

The WAIT statement suspends execution until an event is TRUE.

General Formats for Format 1 (Thread)

General Formats for Format 2 (Event)

Syntax Rules for Format 1 (Thread)

  1. Thread-pointer-1 must be defined as USAGE THREAD-POINTER.
  2. Identifier-1 must be defined either as USAGE POINTER or must be four bytes in size. It must not be a function-identifier.
  3. Identifier-2 must be defined as an integer data item that has a length of at least four digits.

Syntax Rules for Format 2 (Event)

  4. Event-pointer-1 must be defined as USAGE EVENT-POINTER.

General Rules for Format 1 (Thread)

  1. Thread-pointer-1 must contain a thread handle as returned from the START statement with the IDENTIFIED BY phrase or from a CBL_THREAD_ library routine.
  2. A successful WAIT statement suspends the current thread's execution until the termination of the thread referenced by the thread handle contained in thread-pointer-1.
  3. If the RETURNING phrase is specified, a successful WAIT statement returns a value in identifier-1.
  4. After the successful execution of a WAIT statement, the thread handle contained in thread-pointer-1 is invalid.
  5. If the STATUS phrase is specified, the execution of the WAIT statement places into identifier-4 one of the return codes specified for the CBL_THREAD_ library routines.
  6. If the WAIT statement fails, one of the return codes specified for the CBL_THREAD_ library routines is placed into identifier-2, if specified, and then one of the following occurs:
    1. If the ON EXCEPTION phrase is specified, control is transferred to imperative-statement-1. Execution then continues according to the rules for each statement specified in imperative-statement-1. If a procedure-branching or conditional statement that causes explicit transfer of control is executed, control is transferred in accordance with the rules of that statement; otherwise, upon completion of the execution of imperative-statement-1, control is transferred to the end of the WAIT statement and the NOT ON EXCEPTION phrase, if specified, is ignored.
    2. Otherwise, if the NOT ON EXCEPTION phrase or the STATUS phrase is specified, control is transferred to the end of the WAIT statement and the NOT ON EXCEPTION phrase, if specified, is ignored.
    3. Otherwise, the run unit terminates with a run-time system error.
  7. If the WAIT verb is successful, the following occurs in the order specified:
    1. If the STATUS phrase, is specified, ZERO is moved to identifier-2.
    2. If the NOT ON EXCEPTION phrase is specified, control is transferred to imperative-statement-2. Execution then continues according to the rules for each statement specified in imperative-statement-2. If a procedure-branching or conditional statement that causes explicit transfer of control is executed, control is transferred in accordance with the rules of that statement; otherwise, upon completion of the execution of imperative-statement-2, control is transferred to the end of the WAIT statement and the ON EXCEPTION phrase, if specified, is ignored.

General Rules for Format 2 (Event)

  8. A successful WAIT statement suspends execution until the event referenced by event-pointer-1 is TRUE.
    Note: Execution resumes immediately if the event referenced by event-pointer-1 is TRUE when the statement is executed.
  9. If the WAIT statement fails, the run unit terminates with a run-time system error.
Parent topic: Statements


The WRITE Statement

The WRITE statement releases a logical record for an output or input-output file. For sequential files it can also be used for vertical positioning of lines within a logical page.

XOPEN Although they are a part of the standard COBOL definition, mnemonic names in the ADVANCING phrase are explicitly excluded from the X/Open COBOL language definitions and should not be used in X/Open COBOL source programs.

General Formats for Format 1 (Record MF and Line Sequential Files)

General Formats for Format 2 (Record Sequential Files)

General Formats for Format 3 (Record Sequential Files)

General Formats for Format 4 (Relative and Indexed Files)

Directives and RTS switches

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • WRITE-LOCK - causes a WRITE statement to acquire a record lock when multiple recording locking is used.
    • FDCLEAR - causes the contents of the record area to be predictable after a WRITE statement.
  2. The following RTS switches may impact the semantics described in this section.
    • N - controls the insertion of null characters before control characters when writing line sequential records.
    • T - controls the insertion of tab characters when writing line sequential records.

Syntax Rules for All Formats (All Files)

  1. ANS85 If identifier-1 is a function-identifier, it must reference an alphanumeric function. When identifier-1 is not a function-identifier, record-name and identifier-1 must not reference the same storage area.
  2. Record-name is the name of a logical record in the File Section of the Data Division and can be qualified.
  3. OSVS VSC2 MF Record-name can define a floating-point item.
  4. OSVS VSC2 MF Identifier-1 can be defined as a floating-point item.

Syntax Rules for Format 1 (RecordSequential Files)

  5. MF A user-defined mnemonic-name can be used instead of TAB if they are associated in the Special-Names paragraph. (See the topic The Special-Names Paragraph.)
  6. When identifier-2 is used in the ADVANCING phrase, it must be the name of an elementary integer data item.
  7. Integer, or the value of the data item referenced by identifier-2, can be zero.
  8. VSC2 Integer can be signed.
  9. If the END-OF-PAGE phrase is specified, the LINAGE clause must be specified in the file description entry for the associated file.
  10. The words END-OF-PAGE and EOP are equivalent.
  11. The ADVANCING mnemonic-name phrase cannot be specified when writing a record to a file whose file description entry contains the LINAGE clause.
  12. ANS85 The phrases ADVANCING PAGE and END-OF-PAGE must not both be specified in a single WRITE statement.

    MF This restriction can be ignored.

    OSVS VSC2 MF Alternatively, function-name can itself be used instead of an associated mnemonic-name.

Syntax Rules for Format 2 (Record Sequential Files)

  13. OSVS This format cannot be specified when writing a record to a file whose file description entry contains the LINAGE clause.
  14. OSVS If this format of the WRITE statement is used for writing to a given file, then every WRITE statement used for that file should be in this format.
  15. OSVS In the AFTER POSITIONING phrase, identifier-2 must be defined as a single-character alphanumeric item. See General Rule 18 for its possible values.

Syntax Rules for Format4 (Relative and Indexed Files)

  16. The INVALID KEY phrase must be specified if an applicable USE procedure is not specified for the associated file.

    OSVS VSC2 MF This rule is not enforced.

General Rules for All Formats (All Files)

  1. The results of the execution of the WRITE statement with the FROM phrase is equivalent to the execution of:
    1. The statement:
       MOVE identifier-1 TO record-name

      according to the rules specified for the MOVE statement:

    2. The same WRITE statement without the FROM phrase.

    The contents of the record area prior to the execution of the implicit MOVE statement have no effect on the execution of this WRITE statement.

    After execution of the WRITE statement is complete, the information in the area referenced by identifier-1 is available, even though the information in the area referenced by record-name is not. (See General Rule 13.)

  2. The file position indicator is unaffected by the execution of a WRITE statement.
  3. The execution of the WRITE statement causes the value of the FILE STATUS data item, if any, associated with the file to be updated. (See the topic I-O Status in the chapter Procedure Division.)
  4. The maximum record size for a file is established at the time the file is created and must not subsequently be changed.
  5. The number of character positions on a mass storage device to store a logical record in a file may or may not be equal to the number of character positions defined by the logical description of that record .
  6. The execution of the WRITE statement releases a logical record to the operating system.
  7. ANS85 If the execution of the WRITE statement is unsuccessful, the I/O status of the file-name associated with record-name is updated and control is transferred according to the rules of the USE statement following the execution of any USE AFTER EXCEPTION procedure applicable to the file-name associated with record-name. (See the topic The USE Statement.)

General Rules for Format 1 (Record SequentialFiles)

  8. MF When the mnemonic-name associated with TAB is specified the result is to cause the paper to throw to the standard vertical tabulation position.
  9. If the logical end of the representation of the printed page is reached during the execution of a WRITE statement with the END-OF-PAGE phrase, the imperative-statement specified in the END-OF-PAGE phrase is executed. The logical end is specified in the LINAGE clause associated with record-name.
  10. An end-of-page condition is reached whenever the execution of a given WRITE statement with the END-OF-PAGE phrase occurs, when the execution of such a WRITE statement causes the LINAGE-COUNTER to equal or exceed the value specified by integer-2 or the data item referenced by data-name-2 of the LINAGE clause, if specified. In this case, the WRITE statement is executed and then the imperative statement in the END-OF-PAGE phrase is executed.

    An automatic page overflow condition is reached whenever the execution of a given WRITE statement (with or without an END-OF-PAGE phrase) cannot be fully accommodated within the current page body.

    This occurs when a WRITE statement, if executed, would cause the LINAGE-COUNTER to exceed the value specified by integer-1 or the data item referenced by data-name-1 of the LINAGE clause. In this case, the record is presented on the logical page before or after (depending on the phrase used) the device is repositioned to the first line that can be written on the next logical page as specified in the LINAGE clause. The imperative statement in the END-OF-PAGE clause, if specified, is executed after the record is written and the device has been repositioned.

    If integer-2 or data-name-2 of the LINAGE clause is not specified, no end-of-page condition distinct from the page overflow condition is detected. In this case, the end-of-page condition and page overflow condition occur simultaneously.

    If integer-2 or data-name-2 of the LINAGE clause is specified, but the execution of a given WRITE statement would cause LINAGE-COUNTER to simultaneously exceed the value of both integer-2 or the data item referenced by data-name-2 and integer-1 or the data item referenced by data-name-1, then the operation proceeds as if integer-2 or data-name-2 had not been specified.

General Rules for Format 1 (LineSequential Files)

  11. MF If the ADVANCING phrase is not used, automatic advancing of one line is provided to act in accordance with the convention of your operating system text editor (usually as if you had specified BEFORE ADVANCING 1 LINE).
  12. MF MF When an attempt is made to write beyond the externally defined boundaries of a sequential file, an exception condition exists and the contents of the record area are unaffected. The following actions take place:
    1. The value of the FILE STATUS data item, if any, of the associated file is set to a value indicating a boundary violation. (See the topic I-O Status in the chapter Procedure Division.)
    2. If a USE AFTER STANDARD EXCEPTION declarative is explicitly or implicitly specified for the file, that declarative procedure is executed.
    3. If a USE AFTER STANDARD EXCEPTION declarative is not explicitly or implicitly specified for the file, the result is undefined.
  13. MF MF After the recognition of an end-of-unit of an output file that is contained on more than one physical reel/unit, the WRITE statement performs the following operations:
    1. The standard ending reel/unit procedure.
    2. The reel/unit swap.
    3. The standard beginning of reel/unit label procedure.
  14. XOPEN When the file contains fixed-length records, the entire record area is written to the file. If the record area is redefined with records of varying sizes, records that are shorter than the maximum size may need to be spaced-filled so that they do not contain meaningless data.
  15. ANS85 If, during the successful execution of a WRITE statement with the NOT END-OF-PAGE phrase, the end-of-page condition does not occur, control is transferred to imperative-statement-2 after execution of the input-ouput operation.

General Rules for Format1 (Record and Line Sequential Files)

  16. Both the ADVANCING phrase and the END-OF-PAGE phrase allow control of the vertical positioning of each line on a representation of a printed page.

    If the ADVANCING phrase is not used, automatic advancing is provided when output is directed to a list device (PRINTER or PRINTER-1), to act as if you had specified AFTER ADVANCING 1 LINE. If the ADVANCING phrase is used, advancing is provided as follows:

    1. If identifier-2 is specified, the representation of the printed page is advanced the number of lines equal to the current value associated with identifier-2.
    2. If integer is specified, the representation of the printed page is advanced the number of lines equal to the value of integer.
    3. If mnemonic-name is specified, the representation of the printed page is advanced as specified in the topic The Special-Names Paragraph.
    4. If the BEFORE phrase is used, the line is presented before the representation of the printed page is advanced according to rules a, b, and c above.
    5. If the AFTER phrase is used, the line is presented after the representation of the printed page is advanced according to rules a, b, and c above.
    6. If PAGE is specified, the record is presented on the logical page before or after (depending on the phrase used) the device is repositioned to the next logical page. If the record to be written is associated with a record sequential file whose file description entry contains a LINAGE clause, the device is repositioned to the first line that can be written on the next logical page as specified in the LINAGE clause.
  17. The phrases ADVANCING PAGE and END-OF-PAGE must not both be specified in a single WRITE statement.

General Rules for Formats 1, 2, and 3 (Sequential Files)

  18. The associated file must be open in the OUTPUT or EXTEND mode at the time of the execution of this statement. (See the topic The OPEN Statement.)
  19. The logical record released by the execution of the WRITE statement is no longer available in the record area unless the associated file is named in a SAME RECORD AREA clause or the execution of the WRITE statement was unsuccessful due to a boundary violation.

    The logical record is also available as a record of other files referenced in the SAME RECORD AREA clause as the associated output file, as well as the file associated with record-name.

General Rules for Format 2 (Record Sequential Files)

  20. OSVS When the AFTER POSITIONING phrase is used in a WRITE statement, the system moves a suitable character into the first position of the record before it is written to the file. This first character position must be reserved for this purpose. If the identifier-2 option is used, then the character moved into the output record is simply the value held by identifier-2 and should be one of the following:
    Identifier-2 | Interpretation
    (space) | Single-spacing
    0 | Double-spacing
    - Triple-spacing
    + Suppress spacing
    1-9 | Skip to channel 1 through 9, respectively
    A, B, C | Skip to channel 10, 11, 12, respectively
    V, W | Pocket select 1 or 2

    If the integer-1 option is used, then the character placed in the output record is determined as follows:

    Integer | Output Character | Interpretation
    0 | 1 | Skip to channel 1
    1 | (space) | Single-space
    2 | 0 | Double-spacing
    3 - Triple-spacing
  21. OSVS The END-OF-PAGE phrase, if specified, is documentary.

General Rules for Format 3 (RecordSequential Files)

  22. OSVS VSC2 MF When an attempt is made to write beyond the externally defined boundaries of a sequential file, an INVALID KEY condition occurs. When the INVALID KEY condition occurs, the execution of the WRITE statement is unsuccessful; the contents of the record area are unaffected, and the FILE STATUS data item, if any, of the associated file is set to a value indicating the cause of the condition. Execution proceeds according to the rules stated in The INVALID KEY Condition in this chapter (see also the section I-O Status in the chapter Procedure Division).

General Rules for Format 4 (Relative and Indexed Files)

  23. The associated file must be open in the OUTPUT, I/O or EXTEND mode at the time of execution of this statement; an indexed file must not be open in the I/O mode with sequential access mode. (See the topic The File Control Entry and the section The OPEN Statement.)
  24. The logical record released by the execution of the WRITE statement is available in the record area only if the associated file is named in a SAME RECORD AREA clause, or the execution of the WRITE statement is unsuccessful due to an INVALID KEY condition.

    The logical record is also available as a record of other files referenced in the same SAME RECORD AREA clause as the associated output file, as well as the file associated with record-name.

  25. When the INVALID KEY condition is recognized, the execution of the WRITE statement is unsuccessful; the contents of the record area are unaffected, and the FILE STATUS data item, if any, of the associated file is set to a value indicating the cause of the condition. Execution proceeds according to the rules stated in The INVALID KEY Condition in this chapter (see also the section I-O Status in the chapter Procedure Division).

General Rules for Format4 (Relative Files)

  26. When a file is opened in the OUTPUT mode, the WRITE statement proceeds as follows:
    1. If access mode is sequential, the WRITE statement causes a record to be released to the operating system. The first record has a relative record number of one and subsequent records releasedhave relative record numbers of 2, 3, 4, ... . If the RELATIVE KEY data item has been specified in the file control entry for the associated file, the relative record number of the record just released is placed into the RELATIVE KEY data item by the operating system during execution of the WRITE statement.
    2. If access mode is random or dynamic, the value of the RELATIVE KEY data item must be initialized in the runtime element, prior to the execution of the WRITE statement, with the relative record number, or be associated with the record in the record area. That record is then released to the operating system by execution of the WRITE statement.
  27. When a file is opened in I/O mode and access mode is random or dynamic, the value of the RELATIVE KEY data item must be initialized by the runtime element with the relative record number to be associated with the record in the record area. Execution of a WRITE statement then causes the contents of the record area to be released to the operating system.
  28. The INVALID KEY condition exists under either of the following circumstances:
    1. When access mode is random or dynamic, and the RELATIVE KEY data item specifies a record which already exists in the file:
    2. When an attempt is made to write beyond the externally defined boundaries of the file.

General Rules for Format 4 (Indexed Files)

  29. Execution of the WRITE statement causes the contents of the record area to be released. The operating system uses the contents of the record keys so that subsequent access of the record can be made via any of those specified record keys.
  30. The value of the prime record key should be unique within the records in the file.
  31. The data item specified as the prime record key must be set by the runtime element to the desired value prior to the execution of the WRITE statement.
  32. If sequential access mode is specified for the file, records must be released to the operating system in ascending order of prime record key values.
  33. If random or dynamic access mode is specified, records can be released to the operating system in any program-specified order.
  34. When the ALTERNATE RECORD KEY clause is specified in the file control entry for an indexed file, the value of the alternate record key can be non-unique only if the DUPLICATES phrase is specified for that record key data item. In this case, the operating system provides storage of records so that when records are accessed sequentially, records with duplicate alternate record keys are retrieved in the order in which they are released to the operating system.
  35. The INVALID KEY condition exists under the following circumstances:
    1. When sequential access mode is specified for a file opened in OUTPUT mode, and the value of the prime record key is not greater than the value of the prime record key of the previous record, or:
    2. When the file is opened in OUTPUT or I/O mode, and the value of the prime record key is equal to the value of a prime record key of a record already existing in the file, or:
    3. When the file is opened in OUTPUT or I/O mode, and the value of an alternate record key for which duplicates are not allowed equals the corresponding data item of a record already existing in the file, or:
    4. When an attempt is made to write beyond the externally defined boundaries of the file.
  36. ANS85 Transfer of control following the successful or unsuccessful execution of the WRITE operation depends on the presence or absence of the INVALID KEY and NOT INVALID KEY phrases. (See the topic The INVALID KEY Condition.)
Parent topic: Statements
Related information
The Special-Names Paragraph
I-O Status
The USE Statement
The OPEN Statement
The File Control Entry
The INVALID KEY Condition


The XML GENERATE Statement

The XML GENERATE statement converts data to XML format.

General Format

Syntax Rules

  1. Identifier-1 must be an alphanumeric or national data item. It must not be described with the JUSTIFIED clause, and cannot be a function identifier.
  2. Identifier-1 can be subscripted or reference modified.
  3. Identifier-1 must not overlap identifier-2 or identifier-3.
  4. Identifier-1 must be a national data item if the generated XML includes data from identifier-2 for:
    1. Any national data item or DBCS data item
    2. Any data item with a DBCS name (that is, a data item whose name contains DBCS characters)
    3. An alphanumeric data item that contains DBCS characters
  5. Identifier-2 cannot be a function identifier or be reference modified.
  6. Identifier-2 can be subscripted.
  7. Identifier-2 must not overlap with identifier-1 or identifier-3.
  8. Identifier-2 must not specify the RENAMES clause.
  9. All data items specified by identifier-2 that are not ignored according to General Rule 5 must satisfy the following conditions:
    1. Each elementary data item must either have class alphabetic, alphanumeric, numeric, or national, or be an index data item. That is, no elementary data item can be described with the USAGE POINTER, USAGE FUNCTION-POINTER, USAGE PROCEDURE-POINTER, or USAGE OBJECT REFERENCE phrase.
    2. There must be at least one such elementary data item.
    3. Each non-FILLER data-name must be unique within any immediately superordinate group data item.
  10. Identifier-3 must be an integer data item defined without the symbol P in its picture string.
  11. Identifier-3 must not overlap identifier-1 or identifier-2.

General Rules

  1. Identifier-1 is the receiving area for a generated XML document.
  2. If identifier-1 is a national data item, the generated XML document is encoded in UTF-16.
  3. Identifier-1 must be large enough to contain the generated XML document. Typically, it should be from five to eight times the size of identifier-2, depending on the length of the data name or data names within identifier-2. If identifier-1 is not large enough, an error condition occurs at the end of the XML GENERATE statement.
  4. Identifier-2 is the group or elementary data item to be converted to XML format.
  5. The following data items specified by identifier-2 are ignored by the XML GENERATE statement:
    1. Unnamed elementary data items or elementary FILLER data items
    2. Slack bytes inserted for SYNCHRONIZED items
    3. Data items subordinate to identifier-2 that are described with the REDEFINES clause or that are subordinate to such a redefining item
    4. Data items subordinate to identifier-2 that are described with the RENAMES clause
    5. Group data items all of whose subordinate data items are ignored
  6. The content of each eligible elementary data item within identifier-2 is converted to character format as described below. The converted content is then inserted as element character content in XML markup. The XML element names are derived from the data names within identifier-2. The names of group items that contain the selected elementary items are retained as parent elements. No extra white space (new lines, indentation, etc.) is inserted to make the generated XML more readable. The exact mixed-case spelling of data names from the data description entry is retained and data names that start with a digit are prefixed by an underscore.
    Note: The exact mixed-case spelling of data names from the data description entry is retained only if you specify the PRESERVECASE directive.
  7. Elementary data items are converted to character format depending on the type of the data item:
    1. Alphabetic, alphanumeric, alphanumeric-edited, DBCS, external floating-point, national, and numeric-edited items are not converted.
    2. Fixed-point numeric data items other than COMPUTATIONAL-5 (COMP-5) binary data items are converted as if they were moved to a numeric-edited item that has:
      • As many integer positions as the numeric item has, but with at least one integer position
      • An explicit decimal point, if the numeric item has at least one decimal position
      • The same number of decimal positions as the numeric item
      • A leading '-' picture symbol if the data item is signed
    3. COMPUTATIONAL-5 (COMP-5) binary data items are converted in the same way as the other fixed-point numeric items except for the number of integer positions. The number of integer positions is computed depending on the number of '9' symbols in the picture character string as follows:
      • 5 minus the number of decimal places, if the data item has one to four '9' picture symbols
      • 10 minus the number of decimal places, if the data item has five to nine '9' picture symbols
      • 20 minus the number of decimal places, if the data item has 10 to 18 '9' picture symbols
    4. Internal floating-point data items are converted as if they were moved to a data item as follows:
      • For COMP-1: an external floating-point data item with PICTURE -9.9(8)E+99
      • For COMP-2: an external floating-point data item with PICTURE -9.9(17)E+99
    5. Index data items are converted as if they were declared USAGE COMP-5 PICTURE S9(9).
    6. If identifier-1 is a national data item, any non-national values are converted to national format.
  8. After any conversion to character format, leading and trailing spaces and leading zeroes are eliminated as follows:
    1. For values converted from signed numeric values, the leading space is removed if the value is positive.
    2. For values converted from numeric items, leading zeroes (after any initial minus sign) up to but not including the digit immediately before the actual or implied decimal point are eliminated. Trailing zeroes after a decimal point are retained. For example:
      • -012.340 becomes -12.340
      • 0000.45 becomes 0.45
      • 0013 becomes 13
      • 0000 becomes 0
    3. Character values from alphabetic, alphanumeric, DBCS, and national data items have either trailing or leading spaces removed, depending on whether the corresponding data items have left (default) or right justification, respectively. That is, trailing spaces are removed from values whose corresponding data items do not specify the JUSTIFIED clause. Leading spaces are removed from values whose data items do specify the JUSTIFIED clause. If a character value consists only of spaces, one space remains as the value after trimming is finished.
  9. If a data item after any conversion contains any characters that are illegal in XML content, the original data value - the value in the data item before any conversion or trimming - is represented in hexadecimal, and an element tag name with the prefix hex. is substituted for the regular tag name. For example, if data item My-Name is found at run time to contain LOW-VALUES, the XML element tag name hex.My-Name is used instead, and the content is represented as a string of pairs of zero digits.
  10. If a data item after any conversion contains instances of any of the following the five symbols:
    • & (ampersand)
    • ' (apostrophe)
    • > (greater-than sign)
    • < (less-than sign)
    • " (quotation mark)

    the symbols are converted into the equivalent XML references &amp;, &apos;, &gt;, &lt;, and &quot;, respectively.

  11. If identifier-1 is longer than the generated XML document, only that part of identifier-1 in which XML is generated is changed. The rest of identifier-1 contains the data that was present before this execution of the XML GENERATE statement. To avoid referring to that data, either initialize identifier-1 to spaces before the XML GENERATE statement or specify the COUNT IN phrase.
  12. If the COUNT IN phrase is specified, identifier-3 contains (after execution of the XML GENERATE statement) the count of generated XML character positions. If identifier-1 (the receiver) is a national data item, the count is in national character positions (UTF-16 character encoding units). Otherwise, the count is in bytes.
  13. If an exception condition does not occur during generation of the XML document, control is passed to imperative-statement-2, if specified. Otherwise, it is passed to the end of the XML GENERATE statement. The ON EXCEPTION phrase, if specified, is ignored. Special register XML-CODE contains zero after execution of the XML GENERATE statement.
Parent topic: Statements


The XML PARSE Statement

The XML PARSE statement is used to interface with an XML parser that is part of the COBOL run-time system. The XML PARSE statement parses an XML document into its individual pieces and passes each piece, one at a time, to a user-written processing procedure.

General Format

Syntax Rules

  1. Identifier-1 must be an alphanumeric or national data item, cannot be a function-identifier, and should contain the XML document character stream. If identifier-1 is a national data item, its contents must be encoded using CCSID 1200 (Unicode UTF-16). It must not contain any character entities that are represented using multiple encoding units. Use a character reference, for example "" or "", to represent any such characters.
  2. Procedure-name-1 specifies the first or only section or paragraph in the processing procedure
  3. Procedure-name-2 specifies the last section or paragraph in the processing procedure.

General Rules

  1. The PROCESSING PROCEDURE phrase specifies the name of a procedure to handle the various events that the XML parser generates. The processing procedure consists of the statements that handle XML events. The range of the processing procedure also includes all statements executed by CALL, EXIT, GO TO, GOBACK, INVOKE, and PERFORM statements in the processing procedure. The Compiler inserts a return mechanism after the last statement in the processing procedure. The processing procedure can terminate the run unit with a STOP RUN statement. It must not attempt to return to the parser with a GOBACK or EXIT PROGRAM statement.
  2. The ON EXCEPTION phrase specifies imperative statements that are executed when the XML PARSE statement raises an exception condition. An exception condition occurs when the XML parser detects an error in processing the XML document. The parser first signals an exception XML event by passing control to the processing procedure with special register XML-EVENT set to contain "EXCEPTION". The parser provides a numeric error code in special register XML-CODE.

    An exception condition also occurs if the processing procedure deliberately terminates parsing by setting XML-CODE to -1 before returning to the parser from any normal XML event. In this case, the parser does not signal an EXCEPTION XML event. The following applies:

    1. If the ON EXCEPTION phrase is specified, the parser then transfers control to imperative-statement-1.
    2. If the ON EXCEPTION phrase is not specified, the NOT ON EXCEPTION phrase, if any, is ignored, and control is transferred to the end of the XML PARSE statement.
    3. If the XML processing procedure handles the exception XML event and sets XML-CODE to zero before returning control to the parser, the exception condition no longer exists.
    4. If no other unhandled exceptions occur before the termination of the parser, control is transferred to imperative-statement-2 of the NOT ON EXCEPTION phrase, if specified.
  3. The NOT ON EXCEPTION phrase specifies imperative statements that are executed when no exception condition exists at the termination of XML PARSE processing. The following applies:
    1. If an exception condition does not exist at termination of XML PARSE processing, control is transferred to imperative-statement-2 of the NOT ON EXCEPTION phrase, if specified.
    2. If the NOT ON EXCEPTION phrase is not specified, control is transferred to the end of the XML PARSE statement. In this case, ON EXCEPTION, if specified, is ignored. Special register XML-CODE contains zero after execution of the XML PARSE statement.
Parent topic: Statements
Related information
XML PARSE


Compiler-directing Statements

  • Source Text Manipulation
  • The BASIS Mechanism
  • The ++INCLUDE and -INC Mechanisms
  • Conditional Compilation
  • The Listing Control Statements
  • Compiler Directives Specific to Your COBOL System
Parent topic: Part 2. Program Definition


Source Text Manipulation

Source text manipulation allows you to include text from one or more COBOL source libraries in your program. COBOL source libraries are collections of source text that programmers can use in many different programs, reducing effort and promoting consistency between programs. Any suitable source text editor can be used to create the source text.

You use the COPY statement to include source text from a library in your program. The effect of the COPY statement is to insert text into the compilation group, where it is treated by the COBOL system as part of the compilation group. All occurrences of a given literal, identifier, word or group of words in the library text can be replaced with alternative text during the copy process.

ANS85 Source text manipulation also allows you to replace source text in your program. You use the REPLACE statement to replace source text. The effect of the REPLACE statement is to replace source text in your program by new text supplied in the REPLACE statement; the COBOL system treats the new text as part of the compilation group.

  • The COPY Statement
    The COPY statement incorporates text into a COBOL compilation group.
  • The REPLACE Statement
    The REPLACE statement modifies source text in a compilation group.
Parent topic: Compiler-directing Statements


The COPY Statement

The COPY statement incorporates text into a COBOL compilation group.

General Format

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.
    • COPYEXT - specifies the filename extension to be used for locating copy files.
    • COPYLBR - specifies that library-names are equivalent to .lbr files.
    • COPYLIST - causes the result of a COPY statement to be included in the listing file.
    • FOLD-COPY-NAME - allows the Compiler to find a copy library member when the library name on disk and the text-name in the COPY statement do not use the same upper-case and lower-case letters for the library member name.
    • OLDCOPY - changes the handling of COPY statements to match the ANS'68 and OS/VS COBOL LANGLVL(1) rules.

Syntax Rules

  1. If more than one COBOL library is available while the source is passed through the COBOL system, text-name must be qualified by the library-name identifying the COBOL library in which the text associated with text-name resides. See your COBOL system documentation for details of libraries.

    OSVS VSC2 MF This restriction is removed.

  2. The COPY statement must be preceded by a space and terminated by the separator period.
  3. Pseudo-text-1 must not be null, nor can it consist solely of either the character space(s) or comment lines.
  4. Pseudo-text-2 can be null.
  5. Character-strings within pseudo-text-1 and pseudo-text-2 can be continued. However, both characters of a pseudo-text delimiter must be on the same line. (See the topic Continuation of Lines in the chapter Language Fundamentals.)
  6. Word-1 or word-2 can be any single COBOL word.
  7. A COPY statement can occur in the compilation group anywhere a character-string or a separator can occur except that a COPY statement must not occur within another COPY statement.
  8. Text-name defines a unique external file-name which conforms to the rules for user-defined words.

    OSVS VSC2 MF COB370 External-file-name-literal is an alphanumeric literal that conforms to the operating system rules for file-names. It can be specified with or without enclosing quotation marks.

    Text-names and unquoted external-file-name-literals are always converted to upper case.

  9. MF Library-name-literal is an alphanumeric literal that conforms either to the operating system rules for file-names or to the operating system rules for device identifiers. It can be specified with or without enclosing quotation marks.

    Library-name-literals not inside quotation marks are always converted to upper case.

  10. OSVS VSC2 MF The SUPPRESS phrase is used to suppress the printing of the contents of the copy member on the source listing.
  11. ANS85 If the word COPY appears in a comment-entry or in the place where a comment entry can appear, it is considered part of the comment-entry.

    OSVS A COPY statement that appears in a comment-entry is processed.

  12. OSVS MF External-file-name-literal and library-name-literal, when enclosed in quotation marks, may contain the $, #, and @ characters.
  13. ISO2002 MF Partial-word-1 must consist of one text-word.
  14. ISO2002 MF Partial-word-2 must consist of zero or one text-word.
  15. ISO2002 MF Neither a nonnumeric literal nor a national literal can be specified as partial-word-1 or partial-word-2.
  16. Library text must conform to the rules for COBOL reference format.
  17. ISO2002 MF XOPEN A concatenation expression must not be specified for external-file-name-literal, library-name-literal, literal-1 or literal-2.

General Rules

  1. The compilation of a compilation group containing COPY statements is logically equivalent to the processing of all COPY statements before the processing of the resultant compilation group.
  2. The effect of processing a COPY statement is that the library text associated with text-name is copied into the source text, logically replacing the entire COPY statement, beginning with the reserved word COPY and ending with the punctuation character period, inclusive.
  3. If the REPLACING phrase is not specified, the library text is copied unchanged.

    If the REPLACING phrase is specified, the library text is copied and each properly matched occurrence of pseudo-text-1, identifier-1, literal-1, word-1 and partial-word-1 in the library text is replaced by the corresponding pseudo-text-2, identifier-2, literal-2, word-2 or partial-word-2.

  4. For purposes of matching, identifier-1, literal-1 and word-1 are treated as pseudo-text containing only identifier-1, literal-1 or word-1, respectively.
  5. The comparison operation to determine text replacement occurs in the following manner:
    1. The leftmost library text-word which is not a separator comma or a separator semicolon is the first text-word used for comparison. Any text-word or space preceding this text-word is copied into the source text. Starting with the first text-word for comparison and first pseudo-text-1, identifier-1, word-1, literal-1 or partial-word-1 that was specified in the REPLACING phrase, the entire REPLACING phrase operand that precedes the reserved word BY is compared to an equivalent number of contiguous library text-words.
    2. Pseudo-text-1, identifier-1, word-1, or literal-1 match the library text if, and only if, the ordered sequence of text-words that forms pseudo-text-1, identifier-1, word-1, or literal-1 is equal, character for character, to the ordered sequence of library text-words.
    3. ISO2002 MF When the LEADING phrase is specified, partial-word-1 matches the library text only if the contiguous sequence of characters that forms partial-word-1 is equal, character for character, to an equal number of contiguous characters starting with the leftmost character position of a library text-word. When the TRAILING phrase is specified, partial-word-1 matches the library text only if the contiguous sequence of characters that forms partial-word-1 is equal, character for character, to an equal number of contiguous characters, ending with the rightmost character position of a library text-word.
    4. The following rules apply for the purpose of matching:
      1. Each occurrence of a separator comma, semicolon, or space in pseudo-text-1 or in the library text is considered to be a single space. Each sequence of one or more space separators is considered to be a single space.
      2. Except when used in nonnumeric or national literals, each lower-case letter is equivalent to the corresponding upper-case letter as specified for the COBOL character set.
      3. Text-words within a debugging line participate in the matching as if the "D" did not appear in the indicator area.
      4. ISO2002 MF XOPEN Each operand and operator of a concatenation expression is a separate text-word.
    5. If no match occurs, the comparison is repeated with each next successive pseudo-text-1, identifier-1, word-1, literal-1, or pseudo-text-1, if any, in the REPLACING phrase until either a match is found or there is no next successive REPLACING operand.
    6. When all the REPLACING phrase operands have been compared and no match has occurred, the leftmost library text-word is copied into the source text. The next successive library text-word is then considered as the leftmost library text-word, and the comparison cycle starts again with the first pseudo-text-1, identifier-1, word-1, literal-1, or partial-word-1 specified in the REPLACING phrase.
    7. Whenever a match occurs between pseudo-text-1, identifier-1, word-1, or literal-1 and the library text, the corresponding pseudo-text-2, identifier-2, word-2, or literal-2 is placed into the source text.

      ISO2002 MF When a match occurs between partial-word-1 and the library text-word, the library text-word is placed into the resultant text with the matched characters either replaced by partial-word-1 or deleted when partial-word-2 consists of zero text-words.

      The library text-word immediately following the rightmost text-word that participated in the match is then considered as the leftmost text-word. The comparison cycle starts again with the first pseudo-text-1, identifier-1, word-1, literal-1 or partial-word-1 specified in the REPLACING phrase.

    8. The comparison operation continues until the rightmost text-word in the library text has either participated in a match or been considered as a leftmost library text-word and participated in a complete comparison cycle.
  6. A comment line occurring in either the library text or pseudo-text-1 is interpreted, for purposes of matching, as a single space. Comment lines appearing in either pseudo-text-2 or library text are copied into the source text unchanged.
  7. The text produced as a result of the complete processing of a COPY statement must not contain a COPY statement.

    VSC2 This text can contain a COPY statement provided neither this contained COPY nor the already expanded COPY includes the REPLACING phrase. However, recursive COPY statements (where a library-text is referred to by a COPY statement within it) are not allowed.

    MF COPY statements may be nested in this way to any level. One of the COPY statements in this structure may include the REPLACING phrase, and the replacements specified are in effect for all subsidiary COPY statements.

  8. The syntactic correctness of the library text cannot be independently determined.

    ANS85 Except for COPY statements,

    the syntactic correctness of the entire COBOL compilation group cannot be determined until all COPY statements have been completely processed.

  9. MF If the REPLACING phrase is specified, the library text must not contain an EXEC HTML statement. Violation of this rule may result in unexpected behavior and syntax errors.
  10. Each text-word copied from the library but not replaced, or only partially replaced, is copied so as to start in the same area of the line in the resultant source text as it begins in the line within the library. However, if a text-word copied from the library begins in area A but follows another text-word, which also begins in area A of the same line, and if replacement of a preceding text-word in the line by replacement text of greater length occurs, the following text-word begins in area B if it cannot begin in area A. Each text-word in pseudo-text-2 that is to be placed into the resultant source text begins in the same area of the resultant source text as it appears in pseudo-text-2. Each identifier-2, literal-2, and word-2 that is to be placed into the resultant source text begins in the same area of the resultant source text as the leftmost library text-word that participated in the match would appear if it had not been replaced.

    If additional lines are introduced into the source text as a result of a COPY statement, each text-word introduced appears on a debugging line if the copy statement begins on a debugging line, or if the text-word being introduced appears on a debugging line in library text. When a text-word specified in the BY phrase is introduced, it appears on a debugging line if the first library text-word being replaced is specified on a debugging line. Except in the preceding cases, only those text-words that are specified on debugging lines where the debugging line is within pseudo-text-2 appear on debugging lines in the resultant source text. If any literal specified as literal-2 or within pseudo-text-2 or library text is of too great a length to be accommodated on a single line without continuation to another line in the resultant source text and the literal is not being placed on a debugging line, additional continuation lines are introduced which contain the remainder of the literal. If replacement requires that the continued literal be continued on a debugging line, the compilation group is in error.

  11. For purposes of compilation, text-words after replacement are placed in the source text according to the rules for reference format as described in the section Reference Format in the chapter Language Fundamentals.
  12. If the unit identifier is not explicitly specified, the default drive is used. (The default is operating system-dependent.)
  13. OSVS The OLDCOPY Compiler directive causes the entire entry to be replaced by the information identified by text-name, except that the data-name preceding the COPY statement replaces the corresponding data-name in the text-name.
  14. ANS85 If certain conventions are followed in library text, parts of names, for example the prefix portion of data-names, can be changed with the REPLACING phrase. To use this type of "partial word replacement" the portion of the words to be modified must be enclosed in one of the following ways:
    1. In pairs of left and right parentheses. For example, (ABC)
    2. Within colons. For example :XYZ:
    Note: The LEADING and TRAILING phrases can also be used for partial word replacement. The LEADING and TRAILING phrases are supported by the MF dialect and the next COBOL standard, however, they are not included in the ANSI '85 COBOL standard.

Examples

Examples of the following are provided in the chapter Examples in your Language Reference - Additional Topics:

  • Using the OLDCOPY Compiler directive to achieve ANSI'68 or LANGLVL(1) behavior. See the topic COPY (ANSI'68 or LANGLVL(1) Variation)
  • Using the COPY statement with partial word replacement supported by ANSI'85 rules. See the topic Example Using ANSI'85 with Special Characters
  • Using the COPY statement with partial word replacement supported by ISO2000 rules. See the topic Example Using ISO2000 and MF Dialects
Parent topic: Source Text Manipulation
Related concepts
Preprocessor Response Codes
Related information
COPY (ANSI'68 or LANGLVL(1) Variation)
COPY (Partial Word Replacement)
Continuation of Lines
Reference Format


The REPLACE Statement

The REPLACE statement modifies source text in a compilation group.

General Formats for Format 1

General Formats for Format 2

Syntax Rules

  1. A REPLACE statement can be specified anywhere in source text or in library text that a character-string or a separator, other than the closing delimiter of a literal, can appear. It must be preceded by a separator space except when it is the first statement in a compilation group.
  2. A REPLACE statement must be terminated by a separator period.
  3. Pseudo-text-1 must contain one or more text-words.
  4. Pseudo-text-2 can contain zero, one, or more text-words.
  5. Character-strings within pseudo-text-1 and pseudo-text-2 can be continued.
  6. A text-word within pseudo-text must be between 1 and 322 characters long.
  7. Pseudo-text-1 must not consist entirely of a separator comma or a separator semicolon.
  8. If the word REPLACE appears in a comment-entry or in the place where a comment-entry can appear, it is considered part of the comment-entry.
  9. ISO2002 MF Partial-word-1 must consist of one text-word.
  10. ISO2002 MF Partial-word-2 must consist of zero or one text-word.
  11. ISO2002 MF Neither a nonnumeric literal nor a national literal can be specified as partial-word-1 or partial-word-2.

General Rules

  1. Pseudo-text-1 specifies the source text to be replaced by pseudo-text-2.
  2. ISO2002 MF Partial-word-1 specifies the text to be replaced by partial-word-2.
  3. The Format 2 REPLACE statement specifies that any text replacement currently in effect is discontinued.
  4. A given occurrence of the REPLACE statement is in effect from the point at which it is specified until the next occurrence of the REPLACE statement or the end of the compilation unit, respectively.
  5. Any REPLACE statements contained in a source unit are processed after the processing of any COPY statements contained in that source unit.
  6. The text produced as a result of the processing of a REPLACE statement must contain neither a COPY statement nor a REPLACE statement.
  7. The comparison operation to determine text replacement begins with the text immediately following the REPLACE statement and occurs in the following manner:
    1. Starting with the leftmost source text-word and the first pseudo-text-1 or partial-word-1, pseudo-text-1 or partial-word-1 is compared to an equivalent number of contiguous source text-words.
    2. Pseudo-text-1 matches the source text if, and only if, the order sequence of text-words that forms pseudo-text-1 is equal, character for character, to the ordered sequence of source text-words.

      ISO2002 MF When the LEADING phrase is specified, partial-word-1 matches the source text-word only if the contiguous sequence of characters that forms partial-word-1 is equal, character for character, to an equal number of contiguous characters starting with the leftmost character position of that source text-word. When the TRAILING phrase is specified, partial-word-1 matches the source text-word only if the contiguous sequence of characters that forms partial-word-1 is equal, character for character, to an equal number of contiguous characters, ending with the rightmost character position of that source text-word.

    3. The following rules apply for the purpose of matching:
      1. Each occurrence of a separator comma, semicolon, or space in pseudo-text-1 or in the source text is considered to be a single space. Each sequence of one or more space separators is considered to be a single space.
      2. Except when used in nonnumeric or national literals, each lower-case letter is equivalent to the corresponding upper-case letter as specified for the COBOL character set.
      3. text-words within a debugging line participate in the matching as if the "D" did not appear in the indicator area.
      4. ISO2002 MF XOPEN Each operand and operator of a concatenation expression is a separate text-word.
    4. If no match occurs, the comparison is repeated with each next successive occurrence of pseudo-text-1 or partial-word-1, until either a match is found or there is no next successive occurrence of pseudo-text-1 or partial-word-1.
    5. When all occurrences of pseudo-text-1 or partial-word-1 have been compared and no match has occurred, the next successive source text-word is then considered as the leftmost source text-word, and the comparison cycle starts again with the first occurrence of pseudo-text-1 or partial-word-1.
    6. Whenever a match occurs between pseudo-text-1 and the source text, the corresponding pseudo-text-2 replaces the matched text in the source text.

      ISO2002 MF When a match occurs between partial-word-1 and the source text-word, the matched characters of that source text-word are either replaced by partial-word-2 or deleted when partial-word-2 consists of zero text-words.

      The source text-word immediately following the rightmost text-word that participated in the match is then considered as the leftmost source text-word. The comparison cycle starts again with the first occurrence of pseudo-text-1 or partial-word-1.

    7. The comparison operation continues until the rightmost text-word in the source text which is within the scope of the REPLACE statement has either participated in a match or been considered as a leftmost source text-word and participated in a complete comparison cycle.
  8. Comment lines or blank lines occurring in either the source text or pseudo-text-1 are ignored for purposes of matching; and the sequence of text-words in the source text and in pseudo-text-1 is determined by the rules for reference format. See the topic Reference Format Representation in the chapter Language Fundamentals. Comment lines or blank lines in pseudo-text-2 are placed into the resultant source text unchanged whenever pseudo-text-2 is placed into the source text as a result of text replacement. A comment line or blank line in source text is not placed into the resultant source text if that comment line or blank line appears within the sequence of text-words that match pseudo-text-1.
  9. Only after all COPY and REPLACE statements have been completely processed, can the syntactical correctness of the rest of the source code be determined.
  10. text-words inserted into the source text as a result of processing a REPLACE statement are placed in the source text according to the rules for reference format. See the topic Reference Format in the chapter Language Fundamentals. When inserting text-words of pseudo-text-2 into the source text, additional spaces can be introduced only between text-words where a space (including the assumed space between source lines) already exists.
  11. If additional lines are introduced into the source text as a result of the processing of REPLACE statements, the indicator area of the introduced lines contains the same character as the line on which the text being replaced begins, unless that line contains a hyphen, in which case the introduced line contains a space.

    If any literal within pseudo-text-2 is of a length too great to be accommodated on a single line without continuation to another line in the resultant source text and the literal is not being placed on a debugging line, additional continuation lines are introduced to contain the remainder of the literal. If replacement requires the continued literal to be continued on a debugging line, the compilation unit is in error.

  12. MF The source text for which a REPLACE statement is in effect must not contain an EXEC HTML statement. Violation of this rule may result in unexpected behavior and syntax errors.
Parent topic: Source Text Manipulation
Related concepts
Preprocessor Response Codes
Related information
Reference Format Representation
Reference Format


The BASIS Mechanism

The BASIS mechanism provides support to allow an entire COBOL source file to be non-interactively edited, temporarily, and the result of this edit to be submitted to your COBOL system. The COBOL source file referenced as the source of the temporary edit (the "subject program") remains unchanged, and there is no record of the result of the edit other than the files output by your COBOL system (listing, and so on). The resulting code file cannot be animated since there is no source file for reference.

The BASIS mechanism is valid for fixed-format source only.

The program submitted to your COBOL system consists of two files: an edit control file (containing the BASIS statement and editing information) and the COBOL source file (the subject program as described above).

Three special statements are associated with the BASIS mechanism:

  1. BASIS
  2. INSERT
  3. DELETE.

These special statements are not part of the COBOL language. Each one must, in its entirety, be contained on a single line and must be in upper case.

If you use INSERT or DELETE statements to modify a COBOL source program specified in a BASIS statement, the sequence field of the COBOL source program must contain numeric sequence numbers in ascending order.

General Rules

  1. A DELETE statement wholly within area B of the source-program line, not followed by a valid subject-sequence or subject-sequence-range, is treated as a COBOL DELETE statement by your COBOL system.
  2. Within the BASIS mechanism DELETE statement, all subject-sequence and subject-sequence-range numbers must be in ascending numeric order.
  3. Within the edit control file, all subject-sequence and subject-sequence-range numbers must be in ascending numeric order.
Parent topic: Compiler-directing Statements


The BASIS Statement

The BASIS statement identifies that the program (the edit control file and the COBOL source file) is to be submitted to your COBOL system under the BASIS mechanism rules.

General Format

Syntax Rules

  1. The BASIS statement must be the first line of the edit control file.
  2. The BASIS reserved word can commence anywhere between columns 1 and 66 of the statement line.
  3. Sequence numbers can be included anywhere in columns 1 through 6 of the statement and must be followed by a space.
  4. Text-name defines a unique external file-name which conforms to the rules for user-defined words. Lower case is translated into upper case. External-file-name-literal is an alphanumeric literal enclosed in quotation marks, which conforms to the operating system rules for file-names.

General Rules

  1. Text-name or external-file-name-literal determines the COBOL source file to be edited by the control file.
  2. The editing of the COBOL source file is determined by the INSERT and DELETE statements in the edit control file.


The DELETE Statement - BASIS Control

The DELETE statement (under the BASIS mechanism) identifies lines of the COBOL source file to be ignored by your COBOL system. Any COBOL statements that follow the DELETE statement (up to the next BASIS mechanism INSERT or DELETE statement in the edit control file) are included.

General Format

Syntax Rules

  1. The DELETE reserved word can commence anywhere between columns 1 and 66 of the statement line.
  2. Sequence numbers can be included anywhere in columns 1 through 6 of the statement and must be followed by a space.
  3. Subject-sequence-1, subject-sequence-2, and so on, must be 6-digit positive integers (following the rules for integer numeric-literals).
  4. Subject-sequence-range-1, subject-sequence-range-2, and so on, must consist of two subject-sequence numbers (as above) separated by a hyphen (-).
  5. The comma between subject-sequences and/or subject-sequence ranges is mandatory.

General Rules

  1. Subject-sequence-1, subject-sequence-2, and so on, refer to sequence numbers of those statements within the COBOL source file which are to be ignored by your COBOL system.
  2. Subject-sequence-range-1, subject-sequence-range-2, and so on, refer to inclusive ranges of statement sequence numbers within the COBOL source file, all of which statements are to be ignored when the intermediate code is produced.
  3. Any COBOL statements following the DELETE statement in the edit control file up to the next BASIS mechanism DELETE or INSERT statement are included in the source submitted to your COBOL system. These COBOL source statements are inserted in place of the last statement omitted by this BASIS mechanism DELETE statement.


The INSERT Statement - BASIS Control

The INSERT statement (under the BASIS mechanism) lists lines of COBOL source to be included in the program submitted to your COBOL system.

General Format

Syntax Rules

  1. The INSERT reserved word can commence anywhere between columns 1 and 66 of the statement line.
  2. Subject-sequence must be a positive numeric integer (following the rules for integer numeric literals).

General Rules

  1. Subject-sequence refers to that statement within the COBOL source file after which the COBOL statement(s) is to be included.
  2. All the COBOL statements following the INSERT statement in the edit control file up to the next BASIS mechanism DELETE or INSERT statement are included in the source submitted to your COBOL system. At least one COBOL statement must immediately follow the BASIS mechanism INSERT statement.


The ++INCLUDE and -INC Mechanisms

The ++INCLUDE and -INC mechanisms provide an IBM-mainframe compatible means whereby a COBOL program source file or portion of source code can be included in a file to be compiled.

  • The -INC Statement
    The -INC statement is used to include all of the data records of one source file in another source file at compilation time.
  • The ++INCLUDE Statement
    The ++INCLUDE statement is used to include all of the data records of one source file in another source file at compilation time.
Parent topic: Compiler-directing Statements


The -INC Statement

The -INC statement is used to include all of the data records of one source file in another source file at compilation time.

General Format

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directive may impact either the syntax or the semantics described in this section.
    • LIBRARIAN - enables the use of -INC syntax.

Syntax Rules

  1. -INC must begin in column 1 and be followed by one or more spaces.
  2. Text-name defines a unique external file-name which conforms to the rules for user-defined words.
  3. This special statement is not part of the COBOL language. It must, in its entirety, be contained on a single line and must be in upper case.

General Rules

  1. Text-name determines the COBOL source file to be included at this specific place in the source code.
  2. Any other text appearing on the line is treated as a comment.
Parent topic: The ++INCLUDE and -INC Mechanisms


The ++INCLUDE Statement

The ++INCLUDE statement is used to include all of the data records of one source file in another source file at compilation time.

General Format

Directives

  1. In addition to Compiler directives which provide flagging and modify the reserved word list, the following directive may impact either the syntax or the semantics described in this section.
    • PANVALET - enables the use of ++INCLUDE syntax.

Syntax Rules

  1. ++INCLUDE must begin in column 8, must be in upper case and must be followed by one or more spaces.
  2. Text-name defines a unique external file-name which conforms to the rules for user-defined words.
  3. This special statement is not part of the COBOL language. It must, in its entirety, be contained on a single line and must be in upper case.

General Rules

  1. Text-name determines the COBOL source file to be included at this place in the source code.
  2. Any other text appearing on the line is treated as a comment.
Parent topic: The ++INCLUDE and -INC Mechanisms


Conditional Compilation

The COBOL system provides a mechanism for selectively compiling part or all of the COBOL source. To benefit fully from the advantages of conditional compilation the use of level 78 (see the topic Level Number) and the CONSTANT Compiler directive is recommended. Conditional compilation is controlled by $IF, $ELSE, $END constructs, which behave in a similar way to the COBOL IF construct. Conditional compilation also supplies the $DISPLAY statement, which can be used to display a message during compilation or include a version number in the object file.

Syntax Rules

  1. Conditional compilation statements are indicated by a dollar ($) in column 7 in fixed-format source, or column 1 in free-format source of the COBOL source line followed by one of the key words IF, DISPLAY, ELSE, END.
  2. Conditional compilation should not be used to split a COBOL character string; that is, continuation lines should not be split by conditional compilation controls.
  3. You cannot use include boolean data items in conditional compilation statements.
  • $DISPLAY Statement
    The $DISPLAY statement displays a message on the standard output device during compilation or includes a version number in the object file.
  • $ELSE Statement
    The $ELSE statement is used in conjunction with the $IF statement to control conditional compilation.
  • $END Statement
    The $END statement is used in conjunction with the $IF statement to control conditional compilation.
  • $IF Statement
    A $IF statement provides the means whereby selected parts of the source text are not included in the compilation.
Parent topic: Compiler-directing Statements
Related information
Level Number


$DISPLAY Statement

The $DISPLAY statement displays a message on the standard output device during compilation or includes a version number in the object file.

General Format for Format 1

General Format for Format 2

Syntax Rules

  1. The whole $DISPLAY statement must appear on a single line.

General Rules for Format 1

  1. Text-data is displayed on the standard output device during compilation.

General Rules for Format 2

  2. Version-number is the content of the entire source line following the "=", excluding leading and trailing spaces.
  3. The character string formed by concatenating "@(#)", version-number and a null character (binary zero) is included in the object file, no matter which type of object file is created. If version-number begins with the characters "@(#)", the system does not concatenate these characters when forming the character string.
    Note:
    • Version-number can be any text string, however, it is intended to contain a version number for which a pattern matching tool, such as the UNIX sccs "what" utility, can search the object file.
    • Unreachable procedural code is eliminated by the Compiler during the optimization phase and the literals used only in that code are discarded. The practice of including version numbers in Procedure Division statements by using the following technique does not work:
       filename-what section. move "@(#)filename %I%>" to what-string perform filename-what
    • Since the $DISPLAY statement can be specified anywhere in the source code, each text-name (copybook) can have its own version number.
    • Older compilers treat a format 2 $DISPLAY statement as a format 1 $DISPLAY statement.
Parent topic: Conditional Compilation


$ELSE Statement

The $ELSE statement is used in conjunction with the $IF statement to control conditional compilation.

General Format

Syntax Rules

  1. The whole statement must appear on a single line.

General Rules

  1. The most recent $IF condition is reversed. If the now active $IF condition is true, the source lines following the $ELSE statement are processed. If the $IF condition is false, COBOL source lines are ignored until the next conditional compilation line is encountered. .
Parent topic: Conditional Compilation


$END Statement

The $END statement is used in conjunction with the $IF statement to control conditional compilation.

General Format

Syntax Rules

  1. The whole statement must appear on a single line.

General Rules

  1. The innermost $IF statement is terminated. The now active $IF condition is considered. If the active condition is true the source lines following the $END are processed. If the condition is false, COBOL source lines are ignored until the next conditional compilation line is encountered.
Parent topic: Conditional Compilation


$IF Statement

A $IF statement provides the means whereby selected parts of the source text are not included in the compilation.

General Formats for Format 1

General Formats for Format 2

General Formats for Format 3

Syntax Rules

  1. Constant-name-1 is defined by a level 78 entry or a CONSTANT Compiler directive.
  2. If literal-1 is numeric, it must be zero or a positive integer.
  3. Directive-setting is specified in the same format as it is given in a $SET statement and may be preceded by NO. However, the format used in the $IF statement differs from the format used in the $SET statement as follows:
    1. No spaces are permitted between the NO and directive name
    2. Hyphens in the directive must be specified exactly
    3. If the directive has a parameter it may be omitted
  4. Only directives used in the syntax-check phase and produced in the directive settings list (see compiler directive SETTINGS) may be specified for directive-setting
  5. The whole statement must appear on a single line.
  6. $IF can be nested within another $IF.

General Rules

  1. Constant-name-2 is DEFINED if it is the subject of a level 78 entry or a CONSTANT Compiler directive, otherwise it is NOT DEFINED.
  2. Directive-setting SET evaluates true if the given setting matches the actual directive setting. If a parameter is specified then it must also match.
  3. The comparison between Directive-setting and the actual directive setting is not case sensitive.
  4. If the condition evaluates true the source lines following the $IF statement are processed. If the condition evaluates false, COBOL source lines are ignored until the next conditional compilation line is encountered.

Examples

  1. An example of using conditional compilation is provided in the topic $IF Statement (Conditional Compilation).
Parent topic: Conditional Compilation
Related information
$IF Statement (Conditional Compilation)


The Listing Control Statements

The listing control statements provide a control for producing output file listings during the compile process.

Three statements are associated with the listing control statements:

  1. EJECT
  2. SKIP1, SKIP2 AND SKIP3
  3. VSC2 MF TITLE.
  • The EJECT Statement
    The EJECT statement tells your COBOL system to print the next line of source code at the top of the next page.
  • The SKIP1, SKIP2 and SKIP3 Statements
    The SKIP1, SKIP2 and SKIP3 statements control the vertical spacing of the source code listing produced by your COBOL system. They specify the lines to be skipped in the source code listing.
  • The TITLE Statement
    The TITLE statement tells your COBOL system what title to print on the first line of all subsequent pages of the listing.
Parent topic: Compiler-directing Statements


The EJECT Statement

The EJECT statement tells your COBOL system to print the next line of source code at the top of the next page.

General Format

Syntax Rules

  1. EJECT may begin either in area A or in area B, must be the only statement on the line and may optionally be followed by a period.

General Rules

  1. The EJECT statement itself is not printed.
Parent topic: The Listing Control Statements


The SKIP1, SKIP2 and SKIP3 Statements

The SKIP1, SKIP2 and SKIP3 statements control the vertical spacing of the source code listing produced by your COBOL system. They specify the lines to be skipped in the source code listing.

General Format

Syntax Rules

  1. The statement can begin in area A or in area B, must be the only statement on the line

    VSC2 MF and can optionally be followed by a period.

General Rules

  1. SKIP1 tells your COBOL system to skip one line (double spacing). SKIP2 tells your COBOL system to skip two lines (triple spacing). SKIP3 tells your COBOL system to skip three lines (quadruple spacing).
  2. The SKIP statement itself is not printed.
Parent topic: The Listing Control Statements


The TITLE Statement

The TITLE statement tells your COBOL system what title to print on the first line of all subsequent pages of the listing.

General Format

Syntax Rules

  1. Literal-1 must be nonnumeric and can be followed by a period. It cannot be a figurative constant.
  2. The word TITLE can begin either in Area A or Area B and must be the only statement on the line.
  3. The TITLE statement can appear anywhere in the compilation group.

General Rules

  1. Literal-1 is used as a title on all subsequent pages of the listing. The default title, which is used until a TITLE directive is encountered, identifies your COBOL system and its current release level.
  2. The chosen or default title occupies the left-hand side of the first line of each page. The remainder of the line gives the date and time the intermediate code is produced and a page number.
  3. A second title line is also output containing the name of the main source file and of the current text-name (copybook).
  4. The TITLE statement causes an immediate new page.
  5. The TITLE statement itself is not printed.
Parent topic: The Listing Control Statements


Compiler Directives Specific to Your COBOL System

Your COBOL system provides a large number of Compiler directives. For details of these, see your COBOL system documentation.

Parent topic: Compiler-directing Statements


Examples

This chapter provides annotated examples of some of the source code clauses and statements explained in detail elswhere in the COBOL Language Reference. For the complete syntax and general rules for any item included in this chapter, please see the appropriate reference manual entry.

The sample code extracts provided within this chapter are not intended to be complete COBOL programs but rather sufficient excerpts to illustrate specific coding tasks. A number of complete COBOL source programs are provided with your COBOL system in machine readable format. If you look in the on-disk document, Products Contents Checklist and search for the word "sample", you will see which sample programs are provided with your COBOL system.

Note: No boxes, bubbles or other dialect designations are included in this chapter. See relevant reference entries and your COBOL system documentation for information on what syntax and semantic differences may exist for the COBOL options used in this chapter.

The examples in this chapter are presented in alphabetic order according to the phrase, clause, or statement which they are primarily demonstrating. Of course, within most of these examples other COBOL syntax may also appear. These examples are not divided according to the division or module in which they appear.

  • Call Prototypes
  • Calling and Setting a Procedure-Pointer
  • Call Returning a Dynamically Allocated Data Area from a Subprogram
  • Compilation Group
  • COPY (ANSI'68 or LANGLVL(1) Variation)
  • COPY (Partial Word Replacement)
  • CRT STATUS Clause of the SPECIAL-NAMES Paragraph
  • $IF Statement (Conditional Compilation)
  • INSPECT Statement (Tallying, Replacing, and Converting)
  • NEXT Phrase of CONSTANT-NAMES
  • SEARCH statement
  • SORT a File Using Input and Output Procedures
  • SORT Table Entries
  • Split Key
  • Typedef - User Defined USAGE or Structure
Parent topic: Part 2. Program Definition


Call Prototypes

The following program demonstrates the use of call prototypes. Assume that you have defined the following call prototype:

 identification division.
 program-id.  callsub is external.
 environment division.
 configuration section.
 special-names.
     call-convention 3 is some-language.
 data division.
 linkage section.
 01  x1     pic 9(4) comp-5.
 01  x2     pic xx.
 01  x3     pic 9(8).
 01  x7     pic x.
 procedure division some-language using by value     x1
                                        by reference x2
                                        by reference x3.
 entry "callsub2" using x2 delimited
                        any
                        x1.
 entry "printf" using x7 delimited
                       any repeated.
 end program callsub.

If you had the following "real" source coded in the same source file as the previous call prototype:

 identification division.
 program-id.  prog-1.
 data division.
 working-storage section.
 01  x1      pic 9(4) comp-5.
 01  x2.
     05      pic 9(4) comp-5.
     05      pic x(20).
 01  x3      pic 9(8).
 01  x4      pic 9(9) comp-5.
 01  x5      pic x.
 01  x6      pic x(20).
 procedure division.
 mainline.
     call "callsub" using x1 x2 x3

the preceding CALL statement would be equivalent to using:

                          by value x1
                          by reference x2
                          by reference x3

The following examples show the results of different call statements:

Example 1

     call "callsub" using x1 x2

The preceding CALL statement would generate an error since the number of parameters is wrong.

Example 2

     call other-language "callsub" using x1 x2 x3

The preceding CALL statement would generate an error since the call-convention is wrong.

Example 3

     call "callsub" using by reference x1 x2 x3

The preceding CALL statement would generate an error since x1 should be passed by value.

Example 4

     call "callsub" using 99 x2 x3

The preceding CALL statement would be equivalent to a call using:

                          by value 99 size 2
                          by reference x2
                          by reference x3

Example 5

     call "callsub" using x4 x2 x3

The preceding CALL statement would generate an error since x4 has the wrong length.

Example 6

     call "callsub" using x1 x5 x3

The preceding CALL statement would generate an error since x5 is too small.

Example 7

     call "printf" using "A long %1\n" x4

In the preceding CALL statement x4 is a parameter covered by ANY REPEATED.

Example 8

     call "callsub2" using "Hello" x2 x1

The preceding CALL statement is equivalent to:

     move "Hello" & x"00" to temp
     call "callsub2" using temp x2 x1

Example 9

     call "callsub2" using x6 x2 x1

The preceding CALL statement is equivalent to:

     move x6 to temp
     move x"00" to temp (21:1)
     call "callsub2" using temp x2 x1

Example 10

     call "callsub2" using x6 x2 x1 x4

The preceding CALL statement would generate an error as there are too many parameters being passed.

Example of Call Prototype Usage

If a COBOL application programmer wants to call a C function from within his COBOL application the following need to be done:

  • The C function parameters need to be defined within the COBOL application. This means the mapping of C data types to COBOL data types.
  • The actual call to the C function must contain the correct number of parameters and each parameter must be of the correct type.
  • Any strings of text that need to passed to a C function will need to be converted into a null terminated C string.

The use of COBOL typedefs and COBOL call prototypes may be used to automate the above process. This includes the automatic conversion of text strings into null terminated C strings. The following is an example of how all this may be done.

Suppose I have a C function that I want to call. Let us call it my_C_function. The following is a segment of C code that shows this function:

sample.c
-------------------------------------------------------------

/*** start of source module sample.c ***/

/*------------------------*/
/*  Include Header Files  */
/*------------------------*/
#include <stdio.h>
#include "sample.h"

/*-------------------*/
/*  Sample Function  */
/*-------------------*/
int my_C_function (parm_1, parm_2, parm_3)
num_type parm_1;
unsigned char *parm_2;
complex_type *parm_3;
{
    int rtn_code = 0;

    printf("  my-C_function: invoked\n");

    printf("  my-C_function: parm_1 = %d\n", parm_1);

    if (parm_2 == NULL) {
        printf("  my_C_function: parm_2 = IS NULL\n", parm_2);
        rtn_code = -1;
    } else {
        printf("  my_C_function: parm_2 = %s\n", parm_2);
    }

    if (parm_3 == NULL ) {
        printf("  my_C_function: parm_3 = IS NULL\n", parm_3);
        rtn_code = -1;
    } else {
        printf("  my_C_function: parm_3\n");
        printf("                (num1) = %d\n", parm_3->num1);
        printf("                (num2) = %d\n", parm_3->num2);
    }

    printf("    my_C_function: completed\n");
    return(rtn_code);
}

/*** end of source module sample.c ***/
-------------------------------------------------------------

In this example we have three parameters for the C function:

  • A typdef'ed value
  • A C string
  • A constructed data type

There is a header file that contains the C typedef definitions and also the C function prototype. It is as follows:

sample.h

-------------------------------------------------------------

/*** start of source module sample.h ***/

#ifndef     SAMPLE
#define     SAMPLE

/*------------*/
/*  Typedefs  */
/*------------*/
typedef int num_type;
typedef struct {
        int num1;
        long num2;
} complex_type;

/*----------------------*/
/*  Function Prototype  */
/*----------------------*/
extern int my_C_function (
        num_type parm_1,
        unsigned char *parm_2,
        complex_type *parm_3
);
#endif      /* SAMPLE */
/*** end of source module sample.h ***/
-------------------------------------------------------------

The first step is to convert the C typedefs and function prototypes into COBOL typedefs and COBOL call prototypes.

sample.cpy
-------------------------------------------------------------
 program-id. "c_typedefs" is external.
 77  char                   pic s9(2)  comp-5 is typedef.
 77  uns-char               pic  9(2)  comp-5 is typedef.
 77  short                  pic s9(4)  comp-5 is typedef.
 77  uns-short              pic  9(4)  comp-5 is typedef.
 77  int                    pic s9(9)  comp-5 is typedef.
 77  uns-int                pic  9(9)  comp-5 is typedef.
 77  long                   pic s9(9)  comp-5 is typedef.
 77  uns-long               pic  9(9)  comp-5 is typedef.
 77  d-l-float                         comp-2 is typedef.
 77  d-float                           comp-2 is typedef.
 77  float                             comp-1 is typedef.
 77  proc-pointer           procedure-pointer is typedef.
 77  data-pointer                     pointer is typedef.
 77  void                   pic  9(2)  comp-5 is typedef.
 01  num-type          is typedef       usage int.
 01 complex-type       is typedef.
     02 num1              usage int.
     02 num2              usage long.
 entry "my_C_function" using
         by value      int
         by reference  uns-char
         by reference  complex-type
     returning         int
     .
 end program "c-typedefs".
-------------------------------------------------------------

In the above we have:

  • Level 77's that map all the basic C data types to COBOL typedefs.
  • Level 01's that are typedefs that match the C typedefs in the header file
  • An entry statement that acts as a COBOL call prototype for the C function

The following changes should be made to this file with a text editor.

  • Remove the level 77 data items that are not needed
  • Change the uns-char mapping to map to "pic x" instead of a numeric field. If this is not done then an attempt to pass a PIC X field as a parameter would be rejected as not conforming to the prototype parameter specification.
  • Add the keyword delimited beside uns-char in the call prototype. This has the result of converting the TEXT string passed as a parameter into a null terminated C string at run time for the caller.

The result of the above editing is the following:

sample.cpy
-------------------------------------------------------------
 program-id. "c_typedefs" is external.

 77  uns-char               pic x             is typedef.
 77  int                    pic s9(9)  comp-5 is typedef.
 77  long                   pic s9(9)  comp-5 is typedef.
 77  data-pointer                     pointer is typedef.

 01 num-type           is typedef       usage int.
 01 complex-type       is typedef.
     02 num1              usage int.
     02 num2              usage long.

 entry "my_C_function" using
         by value      int
         by reference  uns-char delimited
         by reference  complex-type
     returning         int
     .

 end program "c_typedefs".
-------------------------------------------------------------

The following is an example of the COBOL application that makes a call to the my_C_function function.

-------------------------------------------------------------
 copy 'sample.cpy'.

 identification division.
 program-id.  prog.
 working-storage section.
 01  ws-parm-1                       usage num-type.
 01  ws-parm-2                       pic x(50)
      value "This is a PIC X string from COBOL".
 01  ws-parm-3                       usage complex-type.
 01  ws-return-code                  usage int.

 procedure division.
 main-code section.
     display "prog: started"

     move 123     to ws-parm-1
     move 1       to num1 IN ws-parm-3
     move 2       to num2 IN ws-parm -3

     display " "
     display "prog: call 'my_C_function' with ALL parameters"
     call "my_C_function" using ws-parm-1
                                ws-parm-2
                                ws-parm-3
                          returning ws-return-code
     end-call
     display "prog: 'my_C_function' return code = "
             ws-return-code

     display " "
     display "prog: call 'my_C_function' with NULL parameters"
     call "my_C_function" using 0
                                OMITTED
                                OMITTED
                          returning ws-return-code
     end-call
     display "prog: 'my_C_function' return code = "
             ws-return-code

     display " "
     display "prog: completed"
     exit program
     stop run.
-------------------------------------------------------------

In the above example the following has been coded:

  • The copybook sample.cpy has been included as the first statement in the source. This is the copybook that contains the COBOL typedefs and COBOL call prototypes.

    Typedefs and prototypes are defined as complete external programs. They are placed before real source programs in a similar way to multi-program source files.

  • The parameters for the C function have been defined in the Working-Storage Section using the COBOL typedefs.
  • In this example two calls are made to the C function. The following should be noted from this:
    • BY REFERENCE/VALUE has not been specified. The correct default is picked up from the prototype.
    • The prototype will ensure that the correct number of parameters of the correct type has been specified. If not, then the checker will flag an error at compile time.
    • In the second call the special word OMITTED has been specified to pass a BY REFERENCE parameter as a NULL instead of a parameter value.

      This is required because it is not possible to just go BY VALUE 0 which would be flagged as invalid because BY REFERENCE is mandatory for that parameter. OMITTED will pass a NULL instead of a pointer to the parameter being passed to the C function.

The following is the output that results when the specific example above is run:

-------------------------------------------------------------
%prog
prog: started

prog: call 'my_C_function' with ALL parameters
      my_C_function: invoked
      my_C_function: parm_1 = 123
      my_C_function: parm_2 = This is a COBOL PIC X string
      my_C_function: parm_3
                     (num1) = 1
                     (num2) = 2
      my_C_function: completed
prog: 'my_C_function' return code = +0000000000

prog: call 'my_C_function' with NULL parameters
      my_C_function: invoked
      my_C_function: parm_1 = 0
      my_C_function: parm_2 = IS NULL
      my_C_function: parm_3 = IS NULL
      my_C_function: completed

prog: 'my_C_function' return code = -0000000001

prog: completed
%
-------------------------------------------------------------
Parent topic: Examples
Related information
Examples


Calling and Setting a Procedure-Pointer

*> Calling program:

 program-id. startup.
 working-storage section.
 01 start-point  usage procedure-pointer.
 procedure division.
     set start-point to entry "menu"
     call "controller" using start-point
     display "End of run"
     stop run.

 entry "illegal"
*> Recursive calls invalid without local-storage section.
     stop run.
 end program startup.

*> Called program:

 program-id. controller.
 working-storage section.
 01 next-option  pic x.
 linkage section.
 01 current-proc usage procedure-pointer.
 procedure division using current-proc.
     perform until current-proc = NULL
         call current-proc returning next-option
*>       Note program-id must be called before any entry point
         evaluate next-option
          when "a"    set current-proc to entry "sub1"
          when other  set current-proc to NULL
         end-evaluate
     end-perform.
     exit program.
 end program controller.

 program-id. menu.
 working-storage section.
 01 exit-option  pic x.
 procedure division.
     display "In menu"
     move "a" to exit-option
     exit program returning exit-option.
*>    Note that the maximum size of returned value is 4 bytes

 entry "sub1"
     display "In sub1"
     exit program returning 1.
Parent topic: Examples
Related information
Examples


Call Returning a Dynamically Allocated Data Area from a Subprogram

* Calling program:

 program-id. calling.
 working-storage section.
 01 call-size   pic x(4) comp-5 value 64.
 linkage section.
 01 call-area   pic x.
 procedure division.
     call "sub2" using call-size
              returning address of call-area
     if address of call-area not = null
         display "Contents of new area: " call-area(1:call-size)
     end-if
     stop run.
end program calling.

* Called program:

 program-id. sub2.
 working-storage section.
 01 sub-pointer usage pointer.
 linkage section.
 01 link-size   pic x(4) comp-5.
 01 link-area   pic x.
 procedure division using link-size.
     call "CBL_ALLOC_MEM" using sub-pointer
                                by value link-size
                                         0 size is 4
     if return-code = 0
         set address of link-area to sub-pointer
         move "Hello!" to link-area(1:call-size)
     else
         set sub-pointer to null
     end-if
     exit program returning sub-pointer.
Parent topic: Examples
Related information
Examples


Compilation Group

A compilation group is everything that is submitted to a compiler at one time. A compilation group contains a series of source units. A source element is a term used to refer to a source unit excluding any nested source units. For more information on compilation groups and source units, see the topic Compilation Groups.

The following compilation group is an example of some of these concepts.

  FUNCTION-ID. factorial.
  DATA DIVISION.
  LINKAGE SECTION.
  01  parm1 BINARY-LONG.
  01  fact  BINARY-LONG.
  PROCEDURE DIVISION USING parm1 RETURNING fact.
     IF parm1 = 0
        COMPUTE fact = 1
     ELSE
        COMPUTE fact = parm1 * factorial (parm1 - 1)
     END-IF
     EXIT FUNCTION.
  END FUNCTION factorial.
  PROGRAM-ID. program-1.
  ENVIRONMENT DIVISION.
  CONFIGURATION SECTION.
  REPOSITORY.
      FUNCTION factorial.
  DATA DIVISION.
  WORKING-STORAGE SECTION.
  01  i  BINARY-LONG.
  PROCEDURE DIVISION.
      COMPUTE i = factorial (10)
  ...
  END PROGRAM program-1.
  PROGRAM-ID. program-2.
  ENVIRONMENT DIVISION.
  CONFIGURATION SECTION.
  REPOSITORY.
      FUNCTION-ID. factorial.
  DATA DIVISION.
  WORKING-STORAGE SECTION.
  01  i  BINARY-LONG.
  01  global-item PIC X(30) GLOBAL VALUE "The factorial is: "
  PROCEDURE DIVISION.
      COMPUTE i = factorial (11)
      CALL display-it USING i
      ...

      PROGRAM-ID. display-it.
      LINKAGE SECTION.
      01 n BINARY-LONG.
      PROCEDURE DIVISION USING n.
          DISPLAY global-item, n
      END PROGRAM display-it.

  END PROGRAM program-2.

This compilation group consists of three compilation units: the function factorial, the program program-1, and the program program-2. Each compilation unit is also a source unit. The source unit program-2 contains another source unit, the program display-it. Each of the four source units is also a source element. The difference between the source elements and the source units is that the source element program-2 does not include the nested program.

From each of the 3 compilation units, a separate runtime module is created by the compiler. Typically, a linkage editor is used to combine runtime modules, from one or multiple compilations, into a run unit.

The runtime module for the function factorial contains one runtime element, the function factorial. The runtime module for the program program-1 contains one runtime element. The runtime module for program-2 contains two runtime elements, one for program-2 and one for display-it.

This example illustrates how the user-defined function factorial can override the intrinsic function factorial. The compiler would use the factorial intrinsic function if FUNCTION factorial INTRINSIC were specified in the REPOSITORY paragraph. However, since the INTRINSIC phrase is not specified in the example, the user-defined function is the function that is activated.

To compile these programs, use the REPOSITORY directive. For example, use:

cobol program-1.cbl nognt repository(update on)
Parent topic: Examples
Related information
Compilation Groups
Examples


COPY (ANSI'68 or LANGLVL(1) Variation)

The COPY statement's behavior is slightly modified when the OLDCOPY Compiler directive is set. This modification changes it from acting as defined by the ANSI'74 and ANSI'85 standards to behaving as the old ANSI'68 standard defined. This modified behavior is also consistent with how OS/VS COBOL and DOS/VS COBOL behave when the LANGLVL(1) compiler option is used on an IBM mainframe.

When the OLDCOPY Compiler directive is set and a copy member is intended to include an entire 01 level data description, both the COPY statement and the copied description should be defined with an 01 level item. However, only the data name from the copying statement will be available to the rest of the COBOL program. For example:

Source file Code.

 01   PRODUCT-CODE COPY COPYPROD.

Copybook Code "COPYPROD":

 01   PROD-CD.
     05   ITEM-NAME      PIC X(30).
     05   ITEM-NUMBER    PIC X(5).

Resulting COBOL Code:

 01   PRODUCT-CODE.
     05   ITEM-NAME      PIC X(30).
     05   ITEM-NUMBER    PIC X(5).
Parent topic: Examples
Related information
Examples


COPY (Partial Word Replacement)

Example Using ANSI'85 with Special Characters

The COPY statement in an ANSI'85 conforming compiler can be used to modify parts of words in the copy member source. It should be carefully noted that this syntax only works when certain conventions (and special characters) are used. When using this technique, the programmer must set up their copy members with the modifiable sections pre-established. In fact, once this technique is used, the copy members will NOT compile cleanly when not replaced. For example:

Source file Code:

     copy Payroll
          replacing ==(TAG)== by ==Payroll==.

Copybook Code:

 01  (TAG).
     05 (TAG)-Week      pic s99.
     05 (TAG)-Gross-Pay pic s9(5)v99.
     05 (TAG)-Hours     pic s9(3)
                          occurs 1 to 52 times
                           depending on (TAG)-Week of (TAG).

Is treated as if it were coded as:

 01  Payroll.
     05 Payroll-Week      pic s99.
     05 Payroll-Gross-Pay pic s9(5)v99.
     05 Payroll-Hours     pic s9(3)
                            occurs 1 to 52 times
                              depending on Payroll-Week of Payroll.

Example Using ISO 2002 and Micro Focus Dialects

Both the ISO 2002 and the Micro Focus dialects support partial word replacement as specified in the ISO 2002 COBOL standard. As above, the modifiable sections must be pre-established, however, the use of special characters is not required and the copy members will compile cleanly even when no replacement is done to them.

The above example could equivalently be coded as follows:

     copy Payroll
          replacing leading ==TAG== by ==Payroll==.

Copybook Code:

 01  TAG.
     05 TAG-Week      pic s99.
     05 TAG-Gross-Pay pic s9(5)v99.
     05 TAG-Hours     pic s9(3)
                          occurs 1 to 52 times
                           depending on TAG-Week of TAG.

Is treated exactly as the code is treated in the ANSI'85 example.

Parent topic: Examples
Related information
Examples


CRT STATUS Clause of the SPECIAL-NAMES Paragraph

The CRT STATUS clause of the SPECIAL-NAMES paragraph provides a data item composed as follows:

  • Status Key 1 - indicates the conditon that caused the termination of the ACCEPT operation
  • Status Key 2 - further distinguishes between ACCEPT termination actions
  • Status Key 3 - contains the raw keyboard code for the key that terminated the ACCEPT operation.

The following examples show how the CRT status key should be coded and referenced.

************************************************************
*                                                          *
*   The following shows how the special-names paragraph    *
*   sets up both a cursor position field and a CRT status  *
*   key field.                                             *
*                                                          *
************************************************************

 special names.
     cursor is cursor-position
     crt status is crt-status.
       ...

 working-storage section.
 01 cursor-position                    pic 9(4).

************************************************************
*   The following group item defines the CRT status key    *
*   field and establishes certain 78-level condition-names *
*   associated with key fields.                            *
*                                                          *
*   Programs using these definitions should be compiled    *
*   with NOIBMCOMP and MF to function as expected.         *
*                                                          *
************************************************************

 01  crt-status.
     05 crt-status-1                   pic 9.
        88  terminate-key                  value 0.
        88  function-key                   value 1.
        88  adis-key                       value 2.
        88  status-1-error                 value 9.
    05  crt-status-2                   pic 99 comp-x.
        88  esc-key                        value 0.
        88  f1-key                         value 1.
        88  enter-key                      value 1.
        88  fun-key-num-user               values 0 thru 127.
        88  fun-key-num-system             values 0 thru 26.
    05  crt-status-3                   pic 99 comp-x.
        88 raw-key-code                    values 0 thru 255.
       ...
 procedure-division.
      ...
************************************************************
*                                                          *
*   The following shows the procedural code that would     *
*   evaluate the CRT status keys and direct processing     *
*   accordingly.                                           *
*                                                          *
************************************************************

     evaluate terminate-key also function-key also adis-key
      when true  also any  also any
         if esc-key
             evaluate crt-status-3
              when 0  perform raw-key-0
              when 1  perform raw-key-1
              when 2  perform raw-key-2
              when 3  perform raw-key-3
               ...
             end-evaluate
        else
            perform logic-for-terminator-key
        end-if

      when any  also true  also any
         evaluate crt-status-2
          when 1  perform user-function-1
          when 2  perform user-function-2
          when 3  perform user-function-3
          when 4  perform user-function-4
          when 5  perform user-function-5
           ...
         end-evaluate

      when any  also any  also true
         evaluate crt-status-2
          when 1 perform sys-function-1
          when 2 perform sys-function-2
          when 3 perform sys-function-3
          when 4 perform sys-function-4
          when 5 perform sys-function-5
           ...
         end-evaluate
     end-evaluate
Parent topic: Examples
Related information
Examples


$IF Statement (Conditional Compilation)

The $IF statement can be used to "conditionally compile" portions of your source code. In the following example, if the program is compiled with the directives:

/MF /CONSTANT WHERE "PC"

then at compile time, the word "NO" will be displayed and the object code will include an EVALUATE rather than a GO TO statement. If the MF directive were not set, "Not MF dialect" would also be displayed.

$if WHERE = "PC"
     evaluate test-field
       when 5  perform test-a
     end-evaluate
$if OTHER-CONSTANT defined
$display Program compiled with other-constant set
$else
$display NO
$end
$else
     go to test-a test-b depending on test-field
$end
$if NOMF set
$display Not MF dialect
$end
Parent topic: Examples
Related information
Examples


INSPECT Statement (Tallying, Replacing, and Converting)

The INSPECT statement can be used to tally the number of occurrences of specific character strings, to replace characters by other characters, or to convert from one set of characters to another. Setting the conditons for these inspections can be quite complex. The following examples demonstrate some of the variations and uses of this verb.

In each of the following examples of the INSPECT statement, COUNT-n is assumed to be zero immediately prior to execution of the statement. The results shown for each example, except the last, are the result of executing the two successive INSPECT statements shown above them.

Example 1:

     inspect item tallying
         count-0 for all "AB", all "D"
         count-1 for all "BC"
         count-2 for leading "EF"
         count-3 for leading "B"
         count-4 for characters;

     inspect item replacing
         all "AB" by "XY", "D" by "X"
         all "BC" by "VW"
         leading "EF" by "TU"
         leading "B" by "S"
         first "G" by "R"
         first "G" by "P"
         characters by "Z"
Initial Value of ITEM | COUNT-0 | COUNT-1 | COUNT-2 | COUNT-3 | COUNT-4 | Final Value of ITEM
EFABDBCGABEFGG | 3 | 1 | 1 | 0 | 5 | TUXYXVWRXYZZPZ
BABABC | 2 | 0 | 0 | 1 | 1 | SXYXYZ
BBBC | 0 | 1 | 0 | 2 | 0 | SSVW

Example 2:

     inspect item tallying
         count-0 for characters
         count-1 for all "A";

     inspect item replacing
         characters by "Z"
         all "A" by "X"
Intial Value of ITEM | COUNT-0 | COUNT-1 | Final Value of ITEM
BBB | 3 | 0 | ZZZ
ABA | 3 | 0 | ZZZ

Example 3:

     inspect item tallying
         count-0 for all "AB" before "BC"
         count-1 for leading "B" after "D"
         count-2 for characters after "A" before "C"

     inspect item replacing
         all "AB" by "XY" before "BC"
         leading "B" by "W" after "D"
         first "E" by "V" after "D"
         characters by "Z" after "A" before "C"
Initial Value of ITEM | COUNT-0 | COUNT-1 | COUNT-2 | Final Value of ITEM
BBEABDABABBCABEE | 3 | 0 | 2 | BBEXYZXYXYZCABVE
ADDDDC | 0 | 0 | 4 | AZZZZC
ADDDDA | 0 | 0 | 5 | AZZZZZ
CDDDDC | 0 | 0 | 0 | CDDDDC
BDBBBDB | 0 | 3 | 0 | BDWWWDB

Example 4:

     inspect item tallying
         count-0 for all "AB" after "BA" before "BC";

     inspect item replacing
         all "AB" by "XY" after "BA" before "BC"
Initial Value of Item | COUNT-0 | Final Value of Item
ABABABABC | 1 | ABABXYABC

Example 5:

     inspect item converting
  "ABCD" to "XYZX" after quote before "#".

The above INSPECT is equivalent to the following INSPECT:

     inspect item replacing
         all "A" by "X" after quote before "#"
         all "B" by "Y" after quote before "#"
         all "C" by "Z" after quote before "#"
         all "D" by "X" after quote before "#".
Initial Value of ITEM | Final Value of ITEM
AC"AEBDFBCD#AB"D | AC"XEYXFYZX#AB"D
Parent topic: Examples
Related information
Examples


NEXT Phrase of CONSTANT-NAMES

The NEXT phrase of the constant-name format of a VALUE clause always points to the offset at which the next byte of storage occurs after the previous data declaration. For example, given the following:

 01  x1             pic x(10).
 01  x2 redefines x1    pic x.
     78  next-offset    value next.
 01  x3             pic xx.

the value in next-offset will be the location of the second byte of x1 and not the starting location of x3.

This also can cause confusion with OCCURS clauses. For example, given the following:

 01  group-item.
     05  tabl occurs 10 times.
             78  offset-a   value next.
         10 elem            pic x.
             78  offset-b   value next.
     05  after-tabl     pic x(02).

offset-a will point to the offset at the start of the first occurrence of elem while offset-b will point to the starting location of the second occurrence of table element elem and not to the starting location of after-tabl. If you wanted to get the starting location of after-tabl, you should recode your source as follows:

 01  group-item.
     05  dummy-item     pic x(10).
          78 offset-c            value next.
     05  tabl redefines dummy-item
               occurs 10 times.
          78 offset-a     value next.
         10 elem            pic x.
             78 offset-b     value next.
     05  after-tabl     pic x (02).

In this example, offset-c will point to the starting offset of after-tabl.

Parent topic: Examples
Related information
Examples


SEARCH statement

There are two types of SEARCH statements.

The first type, a serial search, starts with an element determined by the setting of the associated index. To search the entire table, the index must be set to one.

The second type is a binary search. It ignores the initial setting of the associated index and searches the entire table.

In both formats

  • the programmer specifies the conditions that a table element must satisfy to terminate the search successfully
  • the WHEN phrase can be used to specify an action to be taken when an element is found that does satisfy these conditions
  • the AT END phrase can be used to specify an action to be taken if no element satisfies these conditions

The following data description is used in both examples of the SEARCH statement. The binary search requires that the KEY phrase be specified in the OCCURS clause, the serial search does not require this, but does allow it.

 working-storage section.
 01 states.
   03 state-abbr pic x(2) occurs 50 ascending key state-abbr indexed by i.
 01 state-code pic x(2).

The two coding examples are equivalent. They illustrate the difference between the serial and the binary search. In both examples, the user enters a two-character state abbreviation and the SEARCH statement is used to determine whether the entered abbreviation matches any of the valid abbreviations listed in the table. If the abbreviation is invalid, another one must be entered. A CONTINUE statement is coded at the location where you would process a valid state abbreviation, if additional processing beyond the validation were desired.

Serial Search

 enter-state.
     accept state-code
     set i to 1
     search state-abbr
      at end display "invalid state code, please reenter"
         go to enter-state
      when state-code = state-abbr (i)
         continue
     end-search
     stop run.

Binary Search

 enter-state.
     accept state-code
     search all state-abbr
      at end display "invalid state code, please reenter"
             go to enter-state
      when state-code = state-abbr (i)
         continue
     end-search
     stop run.

The differences in these two examples of the SEARCH statement are

  • the keyword ALL in the second example indicates that a binary search is to be used
  • the example of the serial search initializes the associated index with a SET statement
  • before a binary search is executed, the elements of the table must be ordered according to the specified keys. (The section SORT Table Entries shows an example of this.)
Parent topic: Examples
Related information
Examples
SORT Table Entries


SORT a File Using Input and Output Procedures

The SORT statement can be used to sort the records in a file. Note that SORT procedures should not be invoked by multiple threads simultaneously. The following program takes the names of the input and output files from the command line. RELEASE and RETURN statements are used in the input and output procedures which input records, sort the records, and output a sorted file.

$SET ANS85
 select ifile assign to ipf
     organization is line sequential
     file status is ipstat.

 select sfile assign to "temp.dat".

 select ofile assign to opf
     organization is line sequential.

 fd ifile.
 01 irec     pic x(80).
 fd ofile.
 01 orec     pic x(80).
 sd sfile.
 01 srec     pic x(80).

 working-storage section.
 01 ipstat.
   03 iskey1 pic x.
   03 iskey2 pic x.
 01 ipf  pic x(20).
 01 opf  pic x(20).
 01 ext  pic x(20).
 01 clin     pic x(132).
 01 len  pic 9(2) comp-x.
 01 a    pic 9(2) comp-x value 0.
 procedure division.
     accept clin from command-line
     unstring clin delimited by space into ipf, opf, ext
     if ext not = space
         display "too many arguements
     end if
     sort sfile on ascending srec
      input procedure sortin
      output procedure sortout

     stop run.

 sortin section.
     open input ifile
     read ifile
     perform until ipstat not = "00"
         move irec to srec
         release srec
         read ifile
     end-perform
     close ifile.
 sortout section.
     return sfile at end go to sortout-exit
     display srec
     go to sortout.
 sortout-exit.
     display "Done".
Parent topic: Examples
Related information
Examples


SORT Table Entries

A table sort using KEYS in OCCURS clause for sequencing:

 working-storage section.
 01 group-item.
     05   tabl   occurs 10 times
                     ascending elem-item2
                     descending elem-item1.
          10 elem-item1 pic x.
          10 elem-item2 pic x.
     . . .
 procedure division.
     . . .
     sort tabl.
     if tabl (1) . . .

This is a simple sort in which the table is sorted in ascending order using the key definitions in the OCCURS clause of data item Tabl to determine the sequence, that is Elem-Item2 would be the major key (ascending) and Elem-Item1 would be the secondary key (descending).

A table sort using the entire element for sequencing:

 working-storage section.
 01 group-item.
     05 tabl occurs 10 times
         10 elem-item1 pic x.
         10 elem-item2 pic x.
     . . .
 procedure division.
     . . .
     sort tabl ascending.
     if tabl (1) ...

This is a simple sort in which the table is sorted in ascending order using each entire element of the table to determine the sequence.

A table sort with specified items for sequencing:

 working-storage section.
 01 group-item.
     05  tabl    occurs 10 times
                      ascending elem-item3
                      descending elem-item1.
         10 elem-item1 pic x.
         10 elem-item2 pic x.
         10 elem-item3 pic x.
     . . .
 procedure division.
     . . .
     sort tabl descending elem-item2 elem-item3
     if tabl (1) ...

This is a sort in which the table is sorted based on specified key data items. The major key would be Elem-Item2, even though it was not specified as a KEY in the OCCURS clause. The secondary key would be Elem-Item3. It would be treated as a DESCENDING key for this sort because the DESCENDING (which is transitive across KEY data items) specified in the SORT statement would take precedence over the ASCENDING specified in the OCCURS clause.

A table sort for a nested table:

 working-storage section.
 01 group-item.
     05  tabl1   occurs 10 times
                     indexed by t1-ind t2-ind.
         10  tabl2 occur 5 times.
             15 group1.
                 20 elem-item1 pic x.
             15 group2.
                 20 elem-item1 pic 9.
     . . .
 procedure division.
     . . .
     set t1-ind to 3
     sort tabl2 descending elem-item1 of group2
     if group1 (3 1) ...

This sorts only the third instance of Tabl2, that is Tabl2(3). It uses the qualified data-item, Elem-Item1 of Group2 as its key. In normal Procedure Division references, Elem-Item1 of Group2 would require two levels of subscripting/indexing while in this reference it has none. (Similarly, Tabl2 normally requires one level of subscripting, but cannot be subscripted as data-name-2 in the SORT statement. Instead it uses the value of T1-Ind for determining which instance is to be sorted.)

Parent topic: Examples
Related information
Examples


Split Key

If a program contained the following definition:

 01 rec.
     03 forename     pic X(10).
     03 personnel-no pic X(4).
     03 surname      pic X(15).

the syntax:

     record key is fullname =
  surname forename

would cause the COBOL system to treat fullname as though it were an explicitly defined group item consisting of:

     03 surname      pic X(15).
     03 forename     pic X(10).
Parent topic: Examples
Related information
Examples


Typedef - User Defined USAGE or Structure

The Compiler supports the following data descriptions:

 01 struct-1        TYPEDEF.
    05  part-1  pic x (20).
    05  part-2  pic x(10).
 01 USHORT  pic 9 (4)   comp-5 typedef.

which defines struct-1 and USHORT to be new usages that can be used as in the following:

 01  a.
     05  b  struct-1.
     05  x  USHORT.

which would be interpreted as if it had been coded as:

 01  a.
     05  b.
         10  part-1 pic x(20).
         10  part-2     pic x(10).
     05  x              pic 9(4) comp-5.
Parent topic: Examples
Related information
Examples


Part 3. Additional Topics

  • XML Syntax Extensions
  • Report Writer
  • Debug Module
  • Segmentation
  • Double-Byte Character Set Support
  • Micro Focus Extensions for Double-Byte Character Support
  • Micro Focus OO COBOL Extensions
  • Additional Dialect Support
Parent topic: COBOL Language Reference


XML Syntax Extensions

Your COBOL development system supports the creation of relationships between COBOL data structures and element definitions in XML schemas. Do this using COBOL XML syntax extensions, which allow you to code references to XML structures right into your COBOL definitions. These XML structures are used to input and output information in an XML format.

  • XML File Status Codes
  • XML Preprocessor Restrictions
  • XML Syntax - CLOSE Statement
    The CLOSE statement in XML syntax closes the XML stream and prevents further operation on it unless the file is subsequently reopened using the OPEN statement.
  • XML Syntax - COUNT IN Clause
  • XML Syntax - DELETE Statement
    The DELETE statement in XML syntax deletes an XML element and all sub-elements from the in-memory representation of an XML document.
  • XML Syntax - IDENTIFIED BY Clause
    The IDENTIFIED BY clause enables you to map an XML data name (tag) to a COBOL data name.
  • XML Syntax - NAMESPACE clause
    The NAMESPACE clause sets or identifies the namespaces that are contained in an XML document.
  • XML Syntax - PROCESSING-INSTRUCTION Clause
    The PROCESSING-INSTRUCTION clause enables you to embed a processing instruction directly into the data associated with an XML tag.
  • XML Syntax - OPEN Statement
    The OPEN statement in XML syntax opens the I/O stream which contains or will contain XML data.
  • XML Syntax - READ Statement
    The READ statement in XML syntax reads an XML document from an I/O stream or retrieves an XML element from the in-memory representation of an XML document.
  • XML Syntax - REWRITE Statement
    The REWRITE statement in XML syntax modifies an XML element in the in-memory representation of the XML document.
  • XML Syntax - SELECT Clause
    This extended version of the SELECT clause assigns a filename to an XML stream.
  • XML Syntax - START Statement
    The START statement in XML syntax resets the position of a key.
  • XML Syntax - WRITE Statement
    The WRITE statement in XML syntax writes an XML document to an I/O stream or add an XML element to the in-memory representation of the XML document.
  • XML Syntax - XD File Description
    The XD file description defines a set of record definitions to receive data in an XML stream. COBOL programs that use XML must specify ORGANIZATION IS XML.
Parent topic: Part 3. Additional Topics
Related information
XML Syntax Extensions


XML File Status Codes

The following table shows return codes for the file status of the last I/O operation.

Return Code | Meaning
> 0 | After a successful READ action, the ordinal number of the record read is returned as the status code.
0 | Success. The XML I/O action is performed without problem.
-1 | The XML I/O action is trying to access an XML stream that is not opened.
-2 | This is an invalid XML I/O action.
-3 | Invalid mode is specified in the OPEN statement.
-4 | The XML stream cannot be opened.
-5 | The XML I/O action is attempting to access an internal DOM (Document Object Model) representation which is not present. DOM enables you to create and modify HTML pages and XML documents as full-fledged program objects.
-6 | An invalid KEY is specified in the XML I/O action.
-7 | The end of the XML stream has been reached.
-8 | This is an invalid position to insert the specified XML item.
-9 | The current record read is not a well-formed XML document.
-10 | The internal DOM representation is not written out to any XML stream and has been cleared after a READ statement or a CLOSE statement.
-11 | There is a problem reading an XML stream that is a URL.
-12 | There is a problem writing to an XML stream that is a URL.
-13 | There is a problem reading an XML stream that is not a URL.
-14 | There is a problem writing to an XML stream that is not a URL.
-15 | There is a problem closing an XML stream.
Parent topic: XML Syntax Extensions


XML Preprocessor Restrictions

The following restrictions apply to applications using the XML Preprocessor:

  • Any level-78s used in an XD must be defined within the scope of the XD. Any references to these level 78s are only valid in the scope of that XD and in the procedure division. Do not use them in other Data Division sections.
  • There is no support for AT END or INVALID KEY phrases of the READ or WRITE verbs. Use the XML FILE status variable instead.
  • All variable names with the prefix 'PREXML--' are reserved for use by the Preprocessor.
  • In the Debugger, you cannot position the cursor in a data field when using "locate data" for an XML field definition.
Parent topic: XML Syntax Extensions


XML Syntax - CLOSE Statement

The CLOSE statement in XML syntax closes the XML stream and prevents further operation on it unless the file is subsequently reopened using the OPEN statement.

Format

XML Syntax - CLOSE statement

Syntax Rules:

  1. File-name-1 is the filename as declared in the SELECT statement as ORGANIZATION IS XML.
Parent topic: XML Syntax Extensions


XML Syntax - COUNT IN Clause

Format

XML Syntax - COUNT IN clause

Syntax Rules:

  1. Data-name-1 is an implicitly defined numeric data item with a picture clause of PIC S9(9) USAGE COMP-5.

General Rules:

The COUNT IN clause enables the program to determine the number of occurrences just read, or to specify the number of element occurrences to be output.

  1. If COUNT IN appears on a data description entry with an OCCURS clause, the dimension of data-name-1 is one less than the dimension of the associated data item.
  2. If COUNT IN appears on a data description without an OCCURS clause, the dimension of data-name-1 is the same as the dimension of the associated data item.
Parent topic: XML Syntax Extensions
Related information
COUNT IN Clause


XML Syntax - DELETE Statement

The DELETE statement in XML syntax deletes an XML element and all sub-elements from the in-memory representation of an XML document.

Format

XML Syntax - DELETE statement

Syntax Rules:

  1. File-name-1 is the filename as declared in the SELECT statement with ORGANIZATION IS XML.
  2. Data-name-1 can be qualified, and references a data item whose declaration includes an IDENTIFIED BY clause and is included in the XD record declarations for file-name-1.

General Rules:

  1. When you specify DELETE KEY IS, this deletes the internal representation of the elements and child elements associated with data-name-1. All other elements represented in the record remain unchanged.
  2. No stream I/O is actually performed by the DELETE statement.
  3. If the internal representation of the XML document is modified through the use of WRITE KEY, REWRITE KEY, or DELETE KEY, and the internal representation is cleared with either a CLOSE or READ (no key) statement, then the CLOSE or READ statement will return a status of -10, indicating the operation succeeded but no write was done.
Parent topic: XML Syntax Extensions


XML Syntax - IDENTIFIED BY Clause

The IDENTIFIED BY clause enables you to map an XML data name (tag) to a COBOL data name.

General Format

XML Syntax - IDENTIFIED BY clause

Syntax Rules:

  1. Data-name-1 is a COBOL data name.
  2. Literal-1 is an XML tag or attribute name.
  3. If data-name-1 is specified, this clause must appear on a group item and data-name-1 must be defined directly within that group item.
  4. The IS ATTRIBUTE clause is mandatory when literal-1 or data-name-1 defines an attribute.

General Rules:

  1. If a group item has an IDENTIFIED BY clause for it, any non-IDENTIFIED data items within it receive the data contained within the tag identified for the group item.
Parent topic: XML Syntax Extensions
Related information
IDENTIFIED BY and IS ATTRIBUTE Clauses


XML Syntax - NAMESPACE clause

The NAMESPACE clause sets or identifies the namespaces that are contained in an XML document.

Format

XML Syntax - NAMESPACE clause

Syntax Rules:

  1. Data-name-1 is an alphanumeric data item which contains the namespace URI (Uniform Resource Identifier).
  2. Literal-1 is a fixed namespace URI.
  3. If the NAMESPACE clause appears on a group item's declaration, then data-item-1 must be defined directly within that group item.
Parent topic: XML Syntax Extensions
Related information
NAMESPACE Clause


XML Syntax - PROCESSING-INSTRUCTION Clause

The PROCESSING-INSTRUCTION clause enables you to embed a processing instruction directly into the data associated with an XML tag.

Format

XML Syntax - PROCESSING INSTRUCTION clause

Syntax Rules:

  1. If the PROCESSING-INSTRUCTION clause is specified on a data item, the IDENTIFIED BY clause must not be.
Parent topic: XML Syntax Extensions
Related information
PROCESSING-INSTRUCTION Clause


XML Syntax - OPEN Statement

The OPEN statement in XML syntax opens the I/O stream which contains or will contain XML data.

Format

XML Syntax - OPEN statement

Syntax Rules:

  1. File-name-1 is the filename as declared in the SELECT statement as ORGANIZATION IS XML.

General Rules:

  1. Any OPEN request establishes an internal tree-based representation of an XML stream:
    • The various I/O verbs with the KEY IS clause allow traversal, update, deletion or insertion of tree nodes within that internal representation; however this does not cause any disk or other I/O operation.
    • When used with the READ verb in its basic form, I/O is performed and populates the internal representation, deleting the previous internal representation.
    • The WRITE verb in its basic form performs I/O and commits the current internal representation to the I/O stream.
  2. OPEN INPUT opens a multi-document XML input stream that contains multiple root elements.
  3. OPEN OUTPUT opens a multi-document XML output stream that can write multiple root elements.
  4. OPEN EXTEND opens a multi-document XML output stream that can write multiple root elements. The previous contents of the file are left intact and output begins at the previous end of file. OPEN EXTEND works on physical files only.
  5. OPEN I-O implicitly defines handshaking, based on the program execution flow, for streams such as pipes to another process, consoles, or Web-based streams.
  6. OPEN I-O performed on a stream which does not easily support handshaking causes all input and output operations to be based at file offset 0. In this case, multiple successive READs (not READ NEXTs) read the same record based on a file offset of 0. Multiple successive WRITEs (without the KEY IS clause) successively overwrite the entire file from a file offset of 0.
Parent topic: XML Syntax Extensions


XML Syntax - READ Statement

The READ statement in XML syntax reads an XML document from an I/O stream or retrieves an XML element from the in-memory representation of an XML document.

Format

XML Syntax - READ statement

Syntax Rules:

  1. File-name-1 is the filename as declared in the SELECT statement as ORGANIZATION IS XML.
  2. Data-name-1 can be qualified, and references a data item whose declaration includes an IDENTIFIED BY clause and is included in the XD record declarations for file-name-1.

General Rules:

  1. The READ statement without NEXT KEY specified reads an XML document and creates an internal tree-based representation of that document. In addition, it populates the appropriate record definition from the XD with as much data as possible, based on the record elements and occurrence limitations of the associated XML tags. The populated elements are associated with their in-memory counterparts to allow DELETE, REWRITE, and WRITE to modify the internal representation.
  2. READ NEXT finds the associated internal counterpart of the indicated key and either populates the key and all subordinate items with the next occurrence of that internal counterpart, or returns end-of-file if there is no next occurrence.
  3. No stream I/O is actually performed by the READ NEXT KEY IS statement.
  4. The READ statement cannot read PROCESSING-INSTRUCTIONs that are outside the body of the XML record. If you need this flexibility, use the XML PARSE verb.
Parent topic: XML Syntax Extensions


XML Syntax - REWRITE Statement

The REWRITE statement in XML syntax modifies an XML element in the in-memory representation of the XML document.

Format

XML Syntax - REWRITE statement

Syntax Rules:

  1. Record-name-1 is the name of an 01 level group item defined in an XD record declaration within the Data Division.
  2. Data-name-1 can be qualified, and references a data item whose declaration includes an IDENTIFIED BY clause and is included in the XD record declarations for file-name-1.

General Rules:

  1. No stream I/O is performed by the REWRITE verb.
  2. REWRITE KEY IS updates the in-memory representation of the elements and child elements associated with data-name-1. All other elements in the in-memory representation remain unchanged.
  3. If the internal representation of the XML document is modified through the use of WRITE KEY, REWRITE KEY, or DELETE KEY, and the internal representation is cleared with either a CLOSE or READ (no key) statement, then the CLOSE or READ statement returns a status of -10, indicating the operation succeeded but no write was done.
Parent topic: XML Syntax Extensions


XML Syntax - SELECT Clause

This extended version of the SELECT clause assigns a filename to an XML stream.

Format

XML Syntax - SELECT clause

Syntax Rules:

  1. File-name-1 is the name of the file that contains the XML stream.
  2. LINE ADVANCING specifies that line feeds are included in the output.
  3. NOT LINE ADVANCING specifies that no line feeds are included in the output.
  4. Literal-1 must be an alphanumeric literal.
  5. Literal-1 or data-name-1 must be a COBOL file specifier.
  6. Data-name-2 is an alphanumeric data item that contains XML data at run time.
  7. Pointer-name-1 is the address a memory buffer containing XML data.
  8. Data-name-3 is the length of the buffer pointed to by pointer-name-1.
  9. EXTERNAL indicates that the schema this XML stream conforms to is external. This is for documentation purposes alone and does not affect input or output.
  10. OMITTED specifies that no schema is associated with the XML file.
  11. Literal-2 or data-name-4 is a generated or external name of the schema the record conforms to. For example, for an external schema, this could be an entire URL to the file such as "http://www.microfocus.com/nx40/cobol/v2.0/foo.xsd"
  12. Data-name-5 must be declared in the data division as a PIC S9(9) (any usage) and holds the file status for the last I/O operation.

General Rules:

  1. When neither LINE ADVANCING nor NOT LINE ADVANCING is specified, line feeds are included in the output.
  2. Literal-1 or data-name-1 in an application that is not Web-based can be a COBOL file specifier as follows:
    • stdin, use ":CI:"
    • stout, use ":CO:"
    • file, use ".myxmlfile"

      where myxmlfile is the name of the file. Generally, XML files use the file extension .xml.

    • pipe, use "<myprog, ">myprog" or "|myprog"

      where myprog is the name of a program that uses stdin and/or stdout to communicate through the pipe.

  3. Literal-1 or data-name-1, in a client-side Web-based application, can be:
    • A CGI program hosted on a Web site, such as "http://www.bookdb.com:80/cgibin/xmlprog.exe"
    • An XML file, such as or "http://localhost/xmlfile.xml"
  4. Literal-1 or data-name-1, in a CGI, server-side Web application can be ":CGI:", which causes the environment variable CONTENT_LENGTH to be considered when reading the standard input stream (stdin). ":CGI:" can only be opened INPUT or OUTPUT, never I-O or EXTEND.
  5. When DOCUMENT-TYPE is not specified, no schema is associated with the XML file. For example:

    The following code:

    SELECT xml-addressdb
    ASSIGN 'address.xml'
    ORGANIZATION IS XML
    DOCUMENT-TYPE IS OMITTED

    FILE STATUS xml-status.

    Is equivalent to:

    SELECT xml-addressdb
    ASSIGN 'address.xml'
    ORGANIZATION IS XML
    FILE STATUS xml-status.
  6. The CHECK clause can be repeated multiple times. For example:
    SELECT foobar
    ASSIGN TO "foobar.xml"
    ORGANIZATION IS XML
    DOCUMENT TYPE IS "foobar.xsd"
    CHECK VALIDITY ON INPUT
    CHECK OUTPUT.
Parent topic: XML Syntax Extensions
Related information
SELECT Paragraph


XML Syntax - START Statement

The START statement in XML syntax resets the position of a key.

Format

XML Syntax - START statement

Syntax Rules:

  1. File-name-1 is the file name as declared in the SELECT statement as ORGANIZATION IS XML.
  2. Data-name-1 is a data item whose declaration includes an IDENTIFIED BY clause, and is included in the XD record declarations for file-name-1.
  3. Identifier-1 or literal-1 is a numeric value indicating which occurence of the tag name referenced by xml_file_record_node is returned by the next READ NEXT statement.

General Rules:

  1. The KEY IS clause resets the current internal counterpart so that a subsequent READ NEXT reads the occurrence of that key specified by data-name-1.
  2. If the INDEX clause is omitted, the index is assumed to be 1.
  3. Once a START request is performed, the indicated key and all sub-keys are associated with a position, and not with any data in the internal representation.
  4. If a START is followed immediately by WRITE KEY, that key is placed immediately before the node that would have been read if a START had been followed with READ NEXT. To add a node after this node, use a READ NEXT statement specifying the same key specified on the START.
  5. Do not immediately follow START with REWRITE KEY.
Parent topic: XML Syntax Extensions


XML Syntax - WRITE Statement

The WRITE statement in XML syntax writes an XML document to an I/O stream or add an XML element to the in-memory representation of the XML document.

Format

XML Syntax - WRITE statement

Syntax Rules:

  1. Record-name-1 is the name of an 01 level group item defined in an XD record declaration within the Data Division .
  2. Data-name-1 can be qualified, and references a data item whose declaration includes an IDENTIFIED BY clause and is included in the XD record declarations for file-name-1.

General Rules:

  1. WRITE without KEY IS takes the record specified, creates a new internal representation (if one does not exist already) and then writes that internal representation to the stream.
  2. If the following conditions are met when an XML file is opened I-O:
    • an internal representation is created by a READ statement
    • the internal representation is modified by any combination of WRITE, REWRITE, or DELETE KEY statements
    • WRITE without the KEY IS clause is performed
    The current contents of the record specified are ignored; instead, the internal representation as established by the READ and modified by the WRITE, REWRITE, or DELETE KEY statements, is written to the stream.
  3. WRITE KEY IS PLAIN-TEXT, data-name-2 or literal-1 is a string value which contains plain text to be output to the XML stream.
  4. WRITE KEY IS PLAIN-TEXT can be decoration such as "Content-type: text/xml."
  5. No stream I/O is actually performed by the WRITE KEY IS statement.
  6. AT END and INVALID KEY are not supported. Use the XML file status variable instead.
  7. WRITE KEY IS adds the node specified to the internal representation of the XML document immediately after the current position. If any containing nodes are required for the node specified, these are also created in the internal representation.
  8. If ALL is specified, any contained nodes are also added to the internal representation of the XML document. Otherwise only the specific node and its attributes and data are added. No stream I/O is performed.
  9. WRITE KEY IS PROCESSING-INSTRUCTION causes an XML processing-instruction node to be added immediately after the current position. When using sequential I/O, where your other WRITE statements have no usage of the KEY clause, a processing instruction is either written before or after the entire XML record, depending on order of execution. When using random I/O, you can write a processing instruction immediately before or after any pre-existing node, using the following sequence:
    START  xml_file_record KEY IS xml_file_node
    IF write-after
       READ xml_file_record NEXT KEY IS xml_file_node
    END-IF
    WRITE  xml_file_record KEY IS PROCESSING-INSTRUCTION 'processing-id processing-data'

    For example, this technique is useful when dealing with the root node and the processing instruction 'xml version="1.0"'.

  10. When using WRITE KEY IS PROCESSING-INSTRUCTION:
    • Data-name-2 is a defined level 78 or a simple data name.
    • Literal-1 is a string value which contains an XML-specific processing instruction. Upon output, this string is decorated with the XML delimiters '<? 'and '?>'.
  11. WRITE KEY IS PLAIN-TEXT adds a plain text node immediately after the current position. When using sequential I/O, where your other WRITE statements have no usage of the KEY clause, plain text will either be written before or after the entire XML record, depending on order of execution. When using random I/O, you can write plain text immediately before or after any pre-existing node, using the following sequence:
    START  xml_file_record KEY IS xml_file_node
    IF write-after
       READ xml_file_record NEXT KEY IS xml_file_node
    END-IF
    WRITE  xml_file_record KEY IS PLAIN-TEXT  'processing-id processing-data'

    This technique is useful when your XML program needs to 'decorate' an XML record with plain text data, for example, specifying "Content-type: text/xml" when operating in a CGI context.

  12. If the internal representation of the XML document is modified through the use of WRITE KEY, REWRITE KEY, or DELETE KEY, and the internal representation is cleared with either a CLOSE or READ (no key) statement, then the CLOSE or READ statement returns a status of -10, indicating the operation succeeded but no write was done.
Parent topic: XML Syntax Extensions


XML Syntax - XD File Description

The XD file description defines a set of record definitions to receive data in an XML stream. COBOL programs that use XML must specify ORGANIZATION IS XML.

Format

XML Syntax - XD file description

Syntax Rules:

  1. File-name-1 is the filename as declared in the SELECT statement as ORGANIZATION IS XML.
  2. Record-description-entry is the COBOL record definition that uses XML syntax extensions.

General Rules:

  1. Do not code an OCCURS DEPENDING ON clause into the XD record of a program that is compiled with the ODOSLIDE directive.
Parent topic: XML Syntax Extensions
Related information
XML Description Paragraph (XD)


Report Writer

The Report Writer is a special purpose feature which places its emphasis on the organization, format, and contents of an output report. Although a report can be produced using the standard COBOL language, the Report Writer language features provide a more concise facility for report structuring and report production. Much of the Procedure Division programming which would normally be supplied by the programmer is instead provided automatically by the Report Writer Control System (RWCS). Thus the programmer is relieved of writing procedures for moving data, constructing print lines, counting lines on a page, numbering pages, producing heading and footing lines, recognizing the end of logical data subdivisions, updating sum counters, and so on. All these operations are accomplished by the RWCS as a consequence of source language statements that appear primarily in the report section of the data division of the source program.

XOPEN Although it is a part of the standard COBOL definition, this module is explicity excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

OSVS The OS/VS COBOL compiler provides support for Report Writer that is based on the ANSI'68 Standard (even when the mainframe LANGLVL(2) compiler option is used - which normally requests ANSI'74 support). However, there are many cases in which that compiler actually supports a cross between the two COBOL Standards. Therefore, you should not attempt to use your COBOL system with OS/VS COBOL emulation along with any other dialect.

OSVS Within this chapter, many of these OS/VS COBOL extensions are indicated by an OSVS bubble. However, for the exact rules for the OS/VS COBOL Report Writer syntax, you should refer to your IBM OS/VS COBOL Language Reference.

  • Report Section
  • Report Structure
  • Report Subdivisions
  • Language Concepts
  • Environment Division
  • Data Division
  • Procedure Division
Parent topic: Part 3. Additional Topics


Report Section

The Report Section of a COBOL Data Division contains one or more Report Description entries (RD entries), each of which forms the complete description of a report.

The report named in the RD entry is not assigned directly to an output file. Instead, it is associated with a file-name in the File Section and that file-name is associated with a file when an OPEN statement specifying the file-name is executed. More than one report can be associated with the same file-name and the CODE clause is used to differentiate among the reports. For an external file connector referenced by a file-name, separately compiled programs can specify different reports for the same file-name. This file description entry must specify the name of a report description entry for each report associated with that file-name in this program.

The RD entry contains a set of clauses that names the report and supplies specific information about the format of the printed page and the organization of the subdivisions of the report. An identification code can be given in the RD entry so that each report can be identified separately in an intermediate output file.

Following each RD entry are one or more 01 level-number entries, each followed by a hierarchical structure similar to COBOL record descriptions. Each 01 level-number entry and its subordinate entries describes a report group. Each report group consists of one or more print lines that are regarded as a unit. A report group that is to be printed is printed entirely on one logical page; it is never split across pages.

Parent topic: Report Writer


Report Structure

When structuring a report, major consideration must be given to vertical and horizontal spacing requirements, manipulation of data, and the physical and logical subdivisions of a report.

  • Vertical Spacing
  • Horizontal Spacing
  • Data Manipulation
Parent topic: Report Writer


Vertical Spacing

The Report Writer feature allows the user to describe report groups containing multiple lines. The vert ical positioning of the lines on a page is specified by the LINE NUMBER clause that is associated with each line. The NEXT GROUP clause indicates how many lines to space after presenting the last line of the group. The first LINE NUMBER clause of the next group indicates additional spacing information to be used in positioning of that group.

Parent topic: Report Structure


Horizontal Spacing

The Report Writer allows the user to position the fields of data on a report line by means of the COLUMN NUMBER clause. The RWCS supplies space fill between all defined fields.

Parent topic: Report Structure


Data Manipulation

When the Report Writer feature is used, data movement to a report group is directed by report section clauses rather than Procedure Division statements. The report section clauses that affect the manipulation of data are the SOURCE, SUM, and VALUE clauses.

The SOURCE clause specifies the sending data item of an implicit MOVE statement. The receiving printable item is defined by the description of the report group item in which the SOURCE clause appears.

The SUM clause automatically causes the establishment of a sum counter. The object of the SUM clause names the data item(s) which are added to the sum counter when a GENERATE statement is executed. The moving of the sum counter contents to the receiving printable item, defined by the description of the report group item in which the SUM clause appears, is accomplished automatically when that report group is presented.

The VALUE clause defines a literal that appears in the printable item of a report group each time that report group is to be presented.

In summary, a data item in a report group is presented only if it has a COLUMN NUMBER clause specifying where it is to be presented. The value that is placed in a printable item is determined by the SOURCE, SUM, or VALUE clause stated in the report group description. Under no circumstances can a report group printable item receive a value directly via a Procedure Division statement.

Note: Report Writer does not support boolean data items.
Parent topic: Report Structure


Report Subdivisions

The physical and logical organization of a report interact to determine what is presented on a page.

  • Physical Subdivision of a Report
  • Logical Subdivisions of a Report
  • Procedure Division Report Writer Statements
Parent topic: Report Writer


Physical Subdivision of a Report

The PAGE clause specifies the length of the page, the size of the heading and footing areas, and the size of the area in which the detail lines will appear. The RWCS uses the LINE NUMBER and NEXT GROUP clauses to position these report groups, and when necessary, to advance to a new page with automatic production of PAGE HEADING and PAGE FOOTING report groups.

Parent topic: Report Subdivisions


Logical Subdivisions of a Report

DETAIL report groups can be structured into a nested set of control groups. Each control group can begin with a CONTROL HEADING report group and end with a CONTROL FOOTING report group.

When nested control groups are defined, the recognition of a change in value of a control data item in a control hierarchy is called a control break and the heading and footing lines associated with the control data-name are called CONTROL HEADING and CONTROL FOOTING report groups.

During the execution of a GENERATE statement, the RWCS uses the control hierarchy to check automatically for control breaks. If a control break has occurred, all controls that are minor to it are considered to have changed, even though they may not in fact have changed. The occurrence of a control break causes the following sequence of events to take place:

  1. ALL CONTROL FOOTING report groups are presented up to and including the one at the level at which the control break occurred.
  2. ALL CONTROL HEADING report groups are presented from the control break level down to the most minor control.
  3. The DETAIL report group named in the GENERATE statement is presented.
Parent topic: Report Subdivisions


Procedure Division Report Writer Statements

The Report Writer statements that appear in the Procedure Division are: INITIATE, GENERATE, TERMINATE, SUPPRESS, and USE BEFORE REPORTING.

The INITIATE statement causes the RWCS to perform automatically a number of initialization functions. A report must be initiated before any detail processing can take place.

The GENERATE statement which specifies a data-name causes the named DETAIL report group to be formatted and written to the output device. In addition, it triggers the RWCS to perform the many implicit actions described in the preceding section.

The GENERATE statement which specifies a report-name provides a means of summary reporting. A report produced by this type of statement has all detail print lines suppressed automatically and consists of only the summary totals accumulated during the processing of the DETAIL report group. The RWCS processing for a GENERATE report-name statement is identical to that which occurs for a GENERATE data-name statement, except that the former results in the suppression of detail print lines.

The TERMINATE statement causes the RWCS to perform all of the automatic functions associated with the termination of a report. The TERMINATE statement must be executed before the file containing the report is closed.

The SUPPRESS statement provides the object time facility to suppress the printing of an entire report group.

The BEFORE REPORTING phrase of the USE statement provides a mechanism whereby Procedure Division statement can be executed at specific instances in the automatic procedures performed by the RWCS. The statements in the USE BEFORE REPORTING procedure can alter the contents of the data items that are referenced by SOURCE clauses. Thus control is possible over the contents of data items referenced in report groups that are produced automatically.

Parent topic: Report Subdivisions


Language Concepts

  • Report File
  • Special Register PAGE-COUNTER
  • Special Register LINE-COUNTER
  • Special Register PRINT-SWITCH
  • Subscripting
Parent topic: Report Writer


Report File

A report file is an output file having sequential organization. A report file has a file description entry containing a REPORT clause. The content of a report file consists of records that are written under control of the RWCS.

A report file is named by a file control entry and is described by a file description entry containing a REPORT clause. A report file is referred to and accessed by the OPEN, GENERATE, INITIATE, SUPPRESS, TERMINATE, USE BEFORE REPORTING, and CLOSE statements.

Parent topic: Language Concepts


Special Register PAGE-COUNTER

The reserved word PAGE-COUNTER is a name for a page counter that is generated for each RD entry in the report section of the Data Division. The implicit description is PIC 9(6) BINARY. The value in PAGE-COUNTER is maintained by the RWCS and is used by the program to number the pages of a report. PAGE-COUNTER can be referenced only in the SOURCE clause of the Report Section and in Procedure Division statements. (See the section PAGE-COUNTER Rules.)

Parent topic: Language Concepts
Related information
PAGE-COUNTER Rules


Special Register LINE-COUNTER

The reserved word LINE-COUNTER is a name for a line counter that is generated for each RD entry in the report section of the data division. The implicit description is PIC 9(6) BINARY. The value in LINE-COUNTER is maintained by the RWCS, and is used to determine the vertical positioning of a report. LINE-COUNTER can be referenced only in the SOURCE clause of the report section and in Procedure Division statements; however, only the RWCS can change the value of LINE-COUNTER. (See the section LINE-COUNTER Rules.)

Parent topic: Language Concepts
Related information
LINE-COUNTER Rules


Special Register PRINT-SWITCH

The reserved word PRINT-SWITCH is a name for a register whose value may be set to non-zero in the course of a USE BEFORE REPORTING declarative procedure. This has the effect of suppressing printing of the corresponding report group.

Parent topic: Language Concepts


Subscripting

In the Report Section, neither a sum counter nor the special registers LINE-COUNTER and PAGE-COUNTER can be used as a subscript.

Parent topic: Language Concepts


Environment Division

  • Input-Output Section
  • The File-Control Paragraph
  • The I-O-Control Paragraph
Parent topic: Report Writer


Input-Output Section

Information concerning the Input-Output Section is located in the section Input-Output Section.

Parent topic: Environment Division
Related information
Input-Output Section


The File-Control Paragraph

Information concerning the File-Control paragraph is located in the section The File-Control Paragraph.

Function

The file-control entry declares the relevant physical attributes of a report file.

Additional Syntax Rules

  1. The OPTIONAL phrase applies only to a report opened in the extend mode. Its specification is required for a report file that is not necessarily present each time the object program is executed.
  2. A report file must have sequential organization. Each report file specified in the SELECT clause must have a file description entry containing a REPORT clause in the Data Division of the same program.
Parent topic: Environment Division
Related information
The File-Control Paragraph


The I-O-Control Paragraph

Information concerning the I-O-Control paragraph is located in the section The I-O-Control Paragraph.

Additional Syntax Rules

  1. A report file can not appear in a SAME clause for which the RECORD phrase is specified.
Parent topic: Environment Division
Related information
The I-O-Control Paragraph


Data Division

  • The File Description Entry (Report Writer)
    The file description entry furnishes information concerning the physical structure, identification, and record-names pertaining to a given file.
  • The REPORT Clause
    The REPORT clause specifies the names of reports that comprise a report file.
  • Report Section
    The Report Section is located in the Data Division of a source program. The Report Section describes the reports to be written onto report files. The description of each report must begin with a RD entry and be followed by one or more report group description entries.
  • The Report Description Entry
    The RD entry names a report, specifies any identifying characters to be appended to each print line in the report and describes the physical structure and organization of that report.
  • The Report Group Description Entry
    The report group description entry specifies the characteristics of a report group and of the individual items in a report group.
Parent topic: Report Writer


The File Description Entry (Report Writer)

The file description entry furnishes information concerning the physical structure, identification, and record-names pertaining to a given file.

ANS85 It determines the internal or external attributes of a file connector, of the associated data records, and of the associated data items. The file description entry also determines whether a file-name is a local name or a global name.

General Format

Syntax Rules

  1. The level indicator FD identifies the beginning of the file description entry for a report file and must precede the file-name of the report file.
  2. The clauses which follow file-name-1 can appear in any order.
  3. File-name-1 can only reference a sequential file.
  4. No record description entries can follow the file description entry for a report file.

    OSVS MF Record description entries are permitted.

  5. The subject of a file description entry that specifies a REPORT clause can be referenced in the procedure division only by the USE statement, the CLOSE statement, or the OPEN statement with the OUTPUT or EXTEND phrase.

General Rules

  1. With the exception of the REPORT clause, all clauses in the file description entry for a report file are presented in the sequential I-O module.
  2. Details on the REPORT clause are presented below.
Parent topic: Data Division


The REPORT Clause

The REPORT clause specifies the names of reports that comprise a report file.

General Format

Syntax Rules

  1. Each report-name specified in a REPORT clause must be the subject of a RD entry in the report section of the same program. The order of appearance of the report-names is not significant.
  2. A report-name must appear in only one REPORT clause.

    OSVS A report-name can appear in two REPORT clauses.

  3. The subject of a file description entry that specifies a REPORT clause can be referenced in the procedure division only by the USE statement, the CLOSE statement, or the OPEN statement with the OUTPUT or EXTEND phrase.

General Rules

  1. The presence of more than one report-name in a REPORT clause indicates that the file contains more than one report.
  2. After execution of an INITIATE statement and before the execution of a TERMINATE statement for the same report file, the report file is under the control of the RWCS. While a report file is under the control of the RWCS, no input-output statement can be executed which references that report file.
  3. ANS85 If the associated file connector is an external file connector, every file description entry in the run unit which is associated with that file connector must describe it as a report file.
Parent topic: Data Division


Report Section

The Report Section is located in the Data Division of a source program. The Report Section describes the reports to be written onto report files. The description of each report must begin with a RD entry and be followed by one or more report group description entries.

General Format

Comments

In addition to naming the report, the RD entry defines the format of each page of the report by specifying the vertical boundaries of the region within which each type of report group can be printed. The RD entry also specifies the control data items. When the report is produced, changes in the values of the control data items cause the detail information of the report to be processed in groups called control groups.

Each report named in the REPORT clause of a file description entry in the file section must be the subject of a RD entry in the report section. Furthermore, each report in the report section must be named in one and only one file description entry.

The report groups that will comprise the report are described following the RD entry. The description of each report group begins with a report group description entry; that is an entry that has a 01 level-number and a TYPE clause. Subordinate to the report group description entry, there can appear group and elementary entries that further describe the characteristics of the report group.

Parent topic: Data Division


The Report Description Entry

The RD entry names a report, specifies any identifying characters to be appended to each print line in the report and describes the physical structure and organization of that report.

ANS85 It also determines whether a report-name is a local name or a global name.

General Format

Syntax Rules

  1. Report-name-1 must appear in one and only one REPORT clause.
  2. The order of appearance of the clauses following report-name-1 is immaterial.
  3. Report-name-1 is the highest permissible qualifier that can be specified for LINE-COUNTER, PAGE-COUNTER, and all data-names defined in the report section.

General Rules

  1. The CODE clause, the CONTROL clause, and the PAGE clause are resented in alphabetical order below.
  2. ANS85 If the RD entry contains the GLOBAL clause, the special registers LINE-COUNTER and PAGE-COUNTER are global names.
  • PAGE-COUNTER Rules
  • LINE-COUNTER Rules
  • The CODE Clause
    The CODE clause specifies a two-character literal that identifies each print line as belonging to a specific report.
  • The CONTROL Clause
    The CONTROL clause establishes the levels of the control hierarchy for the report.
  • The PAGE Clause
    The PAGE clause defines the length of a page and the vertical subdivisions within which report groups are presented.
Parent topic: Data Division


PAGE-COUNTER Rules

  1. PAGE-COUNTER is the reserved word used to reference a special register that is automatically created for each report specified in the report section. (See the section Special Register PAGE-COUNTER.)
  2. In the report section, a reference to PAGE-COUNTER can appear only in a SOURCE clause. In the Procedure Division, PAGE-COUNTER can be used in any context in which a data item with an integer value can appear.
  3. If more than one PAGE-COUNTER exists in a program, PAGE-COUNTER must be qualified by a report-name whenever it is referenced in the Procedure Division.

    In the report section an unqualified reference to PAGE-COUNTER is qualified implicitly by the name of the report in whose RD entry the reference is made. Whenever the PAGE-COUNTER of a different report is referenced, PAGE-COUNTER must be explicitly qualified by the report-name associated with the different report.

  4. Execution of the INITIATE statement causes the RWCS to set the PAGE-COUNTER of the referenced report to one.
  5. PAGE-COUNTER is automatically incremented by one each time the RWCS executes a page advance.
  6. PAGE-COUNTER can be altered by Procedure Division statements.
Parent topic: The Report Description Entry
Related information
Special Register PAGE-COUNTER


LINE-COUNTER Rules

  1. LINE-COUNTER is the reserved word used to reference a special register that is automatically created for each report specified in the Report Section. (See the section Special Register LINE-COUNTER.)
  2. In the report section a reference to LINE-COUNTER can appear only in a SOURCE clause. In the Procedure Division, LINE-COUNTER can be used in any context in which a data item with an integral value can appear. However, only the RWCS can change the content of LINE-COUNTER.
  3. If more than one LINE-COUNTER exists in a program, LINE-COUNTER must be qualified by a report-name whenever it is referenced in the Procedure Division.

    In the Report Section an unqualified reference to LINE-COUNTER is qualified implicitly by the name of the report in whose description entry the reference is made. Whenever the LINE-COUNTER of a different report is referenced, LINE-COUNTER must be explicitly qualified by the report-name associated with the different report.

  4. Execution of an INITIATE statement causes the RWCS to set the LINE-COUNTER of the referenced report to zero. The RWCS also automatically resets LINE-COUNTER to zero each time it executes a page advance.
  5. The value of LINE-COUNTER is not affected by the processing of nonprintable report groups nor by the processing of a printable report group whose printing is suppressed by means of the SUPPRESS statement.
  6. At the time each print line is presented, the value of LINE-COUNTER represents the line number on which the print line is presented. The value of LINE-COUNTER after the presentation of a report group is governed by the presentation rules for the report group. (See the section Presentation Rules Tables.)
Parent topic: The Report Description Entry
Related information
Special Register LINE-COUNTER
Presentation Rules Tables


The CODE Clause

The CODE clause specifies a two-character literal that identifies each print line as belonging to a specific report.

General Format

Syntax Rules

  1. Literal-1 must be a two-character nonnumeric literal.

    OSVS Literal-1 may be replaced by a mnemonic-name specified in the special-names paragraph. See the OS/VS COBOL Language Reference for additional details.

  2. If the CODE clause is specified for any report in a file, it must be specified for all reports in that file.

General Rules

  1. When the CODE clause is specified, literal-1 is automatically placed in the first two character positions of each report writer logical record.
  2. The positions occupied by literal-1 are not included in the description of the print line, but are included in the logical record size.
Parent topic: The Report Description Entry


The CONTROL Clause

The CONTROL clause establishes the levels of the control hierarchy for the report.

General Format

Syntax Rules

  1. Data-name-1 must not be defined in the Report Section. Data-name-1 can be qualified.
  2. Each recurrence of data-name-1 must identify a different data item.
  3. Data-name-1 must not have subordinate to it a variable occurrence data item.

General Rules

  1. Data-name-1 and the word FINAL specify the levels of the control hierarchy. FINAL, if specified, is the highest control, data-name-1 is the major control, the next recurrence of data-name-1 is an intermediate control, and so on. The last recurrence of data-name-1 is the minor control.
  2. The execution of the chronologically first GENERATE statement for a given report causes the RWCS to save the values of all control data items associated with that report. On subsequent executions of all GENERATE statements for that report, control data items are tested by the RWCS for a change of value. A change of value in any control data item causes a control break to occur. This control break is associated with the highest level for which a change of value is noted. (See the section The GENERATE Statement.)
  3. The RWCS tests for a control break by comparing the content of each control data item with the prior content of each control data item that was saved when the previous GENERATE statement for the same report was executed. The RWCS applies the inequality relation test as follows:
    1. If the control data item is a numeric data item, the relation test is for the comparison of two numeric operands.
    2. If the control data item is an index data item, the relation test is for the comparison of two index data items.
    3. If the control data item is a data item other than as described in 3a and 3b above, the relation test is for the comparison of two nonnumeric operands.

    The relation test is further explained in the appropriate paragraph. (See the topic Relation Condition.)

  4. FINAL is used when the most inclusive control group in the report is not associated with a control data-name.
Parent topic: The Report Description Entry
Related information
The GENERATE Statement
Relation Condition


The PAGE Clause

The PAGE clause defines the length of a page and the vertical subdivisions within which report groups are presented.

General Format

Syntax Rules

  1. The HEADING, FIRST DETAIL, LAST DETAIL, and FOOTING phrases can be written in any order.
  2. Integer-1 must not exceed three significant digits in length.
  3. Integer-2 must be greater than or equal to one.
  4. Integer-3 must be greater than or equal to integer-2.
  5. Integer-4 must be greater than or equal to integer-3.
  6. Integer-5 must be greater than or equal to integer-4.
  7. Integer-1 must be greater than or equal to integer-5.
  8. The following rules indicate the vertical subdivision of the page in which each type of report group can appear when the PAGE clause is specified. (See the section Page Regions.)
    1. A report heading report group that is to be presented on a page by itself, if defined, must be defined such that it can be presented in the vertical subdivision of the page that extends from the line number specified by integer-2 to the line number specified by integer-1, inclusive.

      A report heading report group that is not to be presented on a page by itself, if defined, must be defined such that it can be presented in the vertical subdivision of the page that extends from the line number specified by integer-2 to the line number specified by integer-3 minus 1, inclusive.

    2. A page heading report group, if defined, must be defined such that it can be presented in the vertical subdivision of the page that extends from the line number specified by integer-2 to the line number specified by integer-3 minus 1, inclusive.
    3. A control heading or detail report group, if defined, must be defined such that it can be presented in the vertical subdivision of the page that extends from the line number specified by integer-3 to the line number specified by integer-4, inclusive.
    4. A control footing report group, if defined, must be defined such that it can be presented in the vertical subdivision of the page that extends from the line number specified by integer-3 to the line number specified by integer-5, inclusive.
    5. A page footing report group, if defined, must be defined such that it can be presented in the vertical subdivision of the page that extends from the line number specified by integer-5 plus 1 to the line number specified by integer-1, inclusive.
    6. A report footing report group that is to be presented on a page by itself, if defined, must be defined such that it can be presented in the vertical subdivision of the page that extends from the line number specified by integer-2 to the line number specified by integer-1, inclusive.

      A report footing report group that is not to be presented on a page by itself, if defined, must be defined such that it can be presented in the vertical subdivision of the page that extends from the line number specified by integer-5 plus 1 to the line number specified by integer-1, inclusive.

  9. All report groups must be described such that they can be presented on one page. The RWCS never splits a multi-line report group across page boundaries.

General Rules

  1. The vertical format of a report page is established using the integer values specified in the PAGE clause.
    1. Integer-1 defines the size of a report page by specifying the number of lines available on each page.
    2. HEADING integer-2 defines the first line number on which a report heading or page heading report group can be presented.
    3. FIRST DETAIL integer-3 defines the first line number on which a body group can be presented. Report heading and page heading report groups cannot be presented on or beyond the line number specified by integer-3.
    4. LAST DETAIL integer-4 defines the last line number on which a control heading or detail report group can be presented.
    5. FOOTING integer-5 defines the last line number on which a control footing report group can be presented. Page footing and report footing report groups must follow the line number specified by integer-5.
  2. If the PAGE clause is specified the following implicit values are assumed for any omitted phrases:
    1. If the HEADING phrase is omitted, a value of one is assumed for integer-2.
    2. If the FIRST DETAIL phrase is omitted, a value equal to integer-2 is given to integer-3.
    3. If the LAST DETAIL and the FOOTING phrases are both omitted, the value of integer-1 is given to both integer-4 and integer-5.
    4. If the FOOTING phrase is specified and the LAST DETAIL phrase is omitted, the value of integer-5 is given to integer-4.
    5. If the LAST DETAIL phrase is specified and the FOOTING phrase is omitted, the value of integer-4 is given to integer-5.
  3. If the PAGE clause is omitted, the report consists of a single page of indefinite length.
  4. The presentation rules for each type of report group are specified in the appropriate paragraph. (See the section Presentation Rules Tables.)

Pageregion Page Regions

Page regions that are established by the PAGE clause are described in the table below.

Table 1. Page Regions
Report Groups that can be represented in the Region | First line no. of the Region | Last line no. of the Region
Report heading described with NEXT GROUP NEXT PAGE Report footing described with LINE integer-1 NEXT PAGE | integer-2 | integer-1
Report heading not described with NEXT GROUP NEXT PAGE Page heading | integer-2 | integer-3 minus 1
Control footing Detail | integer-3 | integer-4
Control footing | integer-3 | integer-5
Page footing Report footing not described with LINE integer-1 NEXT PAGE | integer-5 plus 1 | integer-1
Parent topic: The Report Description Entry
Related information
Presentation Rules Tables


The Report Group Description Entry

The report group description entry specifies the characteristics of a report group and of the individual items in a report group.

General Formats for Format 1

General Formats for Format 2

General Formats for GROUP INDICATE clause Format 3

Syntax Rules for All Formats

  1. The report group description entry can appear only in the Report Section.
  2. Except for the data-name clause, which when present must immediately follow the level-number, the clauses can be written in any sequence.
  3. A description of a report group can consist of one, two, three or four hierarchic levels:
    1. The first entry that describes a report group must be a Format 1 entry.
    2. Both Format 2 and Format 3 entries can be immediately subordinate to a Format 1 entry.
    3. At least one Format 3 entry must be immediately subordinate to a Format 2 entry.
    4. Format 3 entries must define elementary data items.
  4. In the Report Section, the USAGE clause is used only to declare the usage of printable items.
    1. If the USAGE clause appears in a Format 3 entry, that entry must define a printable item.
    2. If the USAGE clause appears in a Format 1 or Format 2 entry, at least one subordinate entry must define a printable item.
  5. An entry that contains a LINE NUMBER clause must not have a subordinate entry that also contains a LINE NUMBER clause.

    OSVS However an entry containing the LINE NUMBER NEXT PAGE clause can have a subordinate entry containing a LINE NUMBER clause but without the NEXT PAGE option.

Syntax Rules for Format 1

  6. Data-name-1 is required only when:
    1. A detail report group is referenced by a GENERATE statement.
    2. A detail report group is referenced by the UPON phrase of a SUM clause.
    3. A report group is referenced in a USE BEFORE REPORTING sentence.
    4. The name of a control footing report group is used to qualify a reference to a sum counter.

    If specified, data-name-1 can be referenced only by a GENERATE statement, the UPON phrase of a SUM clause, a USE BEFORE REPORTING sentence, or as a sum counter qualifier.

Syntax Rules for Format 2

  7. The level-number can be any integer from 02 to 48 inclusive.
  8. An entry must contain at least one optional clause.
  9. Data-name-1 is optional. If present it can be used only to qualify a sum counter reference.

Syntax Rules for Format 3

  10. The level-number can be any integer from 02 to 49 inclusive.
  11. In Format 3:
    1. A GROUP INDICATE clause can appear only in a type detail report group.
    2. A SUM clause can appear only in a type control footing report group.
    3. An entry that contains a COLUMN NUMBER clause but no LINE NUMBER clause must be subordinate to an entry that contains a LINE NUMBER clause.
    4. Data-name-1 is optional but can be specified in any entry. Data-name-1 can be referenced only if the entry defines a sum counter.
    5. An entry that contains a VALUE clause must also have a COLUMN NUMBER clause.
  12. The table below shows all permissible clause combinations for a Format 3 entry. The table is read from left to right along the selected row.

    An "M" indicates that the presence of the clause is mandatory.

    A "P" indicates that the presence of the clause is permitted, but not required.

    A blank indicates that the clause is not permitted.

    Table 1. Permissible Clause Combinations in Format 3 Entries
    PIC | COLUMN | SOURCE | SUM | VALUE | JUST | BLANK WHEN ZERO | GROUP INDICATE | USAGE | SIGN | LINE
    M | M | P | P
    M | M | M | P | P | P | P
    M | P | M | P | P | P | P | P
    M | P | M | P | P | P | P | P
    M | M | M | P | P | P | P | P

General Rules

  1. Format 1 is the report group entry. The report is defined by the contents of this entry and all of its subordinate entries.
  2. The BLANK WHEN ZERO clause, the JUSTIFIED clause, and the PICTURE clause for the Report Writer module are the same as The BLANK WHEN ZERO Clause, The JUSTIFIED Clause, and The PICTURE Clause in the nucleus. The other clauses of the report group description entry are presented in alphabetical order later in this chapter.
  • Presentation Rules Tables
  • The COLUMN NUMBER Clause (Report Writer)
    The COLUMN NUMBER clause identifies a printable item and specifies the position of the item on a print line.
  • Data-name (Report Writer)
    A data-name specifies the name of the data item being described.
  • The GROUP INDICATE Clause
    The GROUP INDICATE clause specifies that the associated printable item is presented only on the first occurrence of its report group after a control break or page advance.
  • Level-Number (Report Writer)
    The level-number indicates the position of a data item in the hierarchical structure of a report group.
  • The LINE NUMBER Clause (Report Writer)
    The LINE NUMBER clause specifies vertical positioning information for its report group.
  • The NEXT GROUP Clause
    The NEXT GROUP clause specifies information for vertical positioning of a page following the presentation of the last line of a report group.
  • The SIGN Clause (Report Writer)
    The SIGN clause specifies the position and the mode of representation of the operational sign when it is necessary to describe these properties explicitly.
  • The SOURCE Clause (Report Writer)
    The SOURCE clause identifies the sending data item that is moved to an associated printable item defined in a report group description entry.
  • The SUM Clause (Report Writer)
    The SUM clause establishes a sum counter and names the data items to be summed.
  • The TYPE Clause
    The TYPE clause specifies the particular type of report group that is described by this entry and indicates the time at which the report group is to be processed by the RWCS.
  • The USAGE Clause
    The USAGE clause specifies the format of a data item in the computer storage.
  • The VALUE Clause (Report Writer)
    The VALUE clause defines the value of Report Section printable items.
Parent topic: Data Division
Related information
The BLANK WHEN ZERO Clause
The JUSTIFIED Clause
The PICTURE Clause


Presentation Rules Tables

The tables and rules on the following pages specify:

  1. The permissible combinations of LINE NUMBER and NEXT GROUP clauses for each type of report group.
  2. The requirements that are placed on the use of these clauses, and
  3. The interpretation that the RWCS gives to these clauses.
  • Organization
  • Line Number Clause Notation
  • Line Number Clause Sequence Substitutions
  • Saved Next Group Integer Description
  • Report Heading Group Presentation Rules
  • Page Heading Group Presentation Rules
  • Body Group Presentation Rules
  • Page Footing Presentation Rules
  • Report Footing Presentation Rules
Parent topic: The Report Group Description Entry


Organization

There is an individual presentation rules table for each of the following types of report groups: report heading, page heading, page footing, report footing. In addition, detail report groups, control heading report groups, or control footing report groups are treated jointly in the body group presentation rules table. (See the section Body Group Presentation Rules.)

Columns 1 and 2 of a presentation rules table list all of the permissible combinations of LINE NUMBER and NEXT GROUP clauses for the designated report group type. Consequently, for the purpose of identifying the set of presentation rules that apply to a particular combination of LINE NUMBER and NEXT GROUP clauses, a presentation rules table is read from left to right, along the selected row.

The applicable rules columns of a presentation rules table are partitioned into two parts. The first part specifies the rules that apply if the report description contains a PAGE clause, and the second part specifies the rules that apply if the PAGE clause is omitted. The purpose of the rules named in the applicable rules columns is discussed below:

  1. Upper limit rules and lower limit rules.

    These rules specify the vertical subdivisions of the page within which the specified report group can be represented.

    In the absence of a PAGE clause the printed report is not considered to be partitioned into vertical subdivisions. Consequently, in the tables no upper limit rule or lower limit rule is specified for a report description in which the PAGE clause is omitted

  2. Fit test rules.

    The fit test rules are applicable only to body groups, and hence fit test rules are specified only in the body group presentation rules table. At object time the RWCS applies the fit test rules to determine whether the designated body group can be presented on the page to which the report is currently positioned.

    However, even for body groups there are no fit test rules when the PAGE clause is omitted from the report description entry.

  3. First print line position rules.

    The first print line position rules specify where on the report medium the RWCS shall present the first print line of the given report group.

    The presentation rules tables do not specify where on the report medium the RWCS shall present the second and subsequent print lines (if any) of a report group. Certain general rules determine where the second and subsequent print lines of a report group shall be presented. Refer to the LINE NUMBER clause general rules for this information.

  4. Next group rules.

    The next group rules relate to the proper use of the NEXT GROUP clause.

  5. Final LINE-COUNTER setting rules.

    The terminal values that the RWCS places in LINE-COUNTER after presenting report groups are specified by the final LINE-COUNTER setting rules.

Parent topic: Presentation Rules Tables
Related information
Body Group Presentation Rules


Line Number Clause Notation

Column 1 of the presentation rules table uses a shorthand notation to describe the sequence of LINE NUMBER clauses that can appear in the description of a report group. The meaning of the abbreviations used in column 1 is as follows.

  1. The letter "A" represents one or more absolute LINE NUMBER clauses, none of which has the NEXT PAGE phrase, that appear in consecutive order in the sequence of LINE NUMBER clauses in the report group description entry.
  2. The letter "R" represents one or more relative LINE NUMBER clauses that appear in consecutive order in the sequence of LINE NUMBER clauses in the report group description entry.
  3. The letters "NP" represent one or more absolute LINE NUMBER clauses that appear in consecutive order in the sequence of LINE NUMBER clauses in the report group description entry with the phrase NEXT PAGE appearing in the first and only in the first LINE NUMBER clause.

    OSVS This entry can appear without a line number.

When two abbreviations appear together, they refer to a sequence of LINE NUMBER clauses that consists of the two specified consecutive sequences. For example "A R" refers to a report group description entry within which the "A" sequence (defined in rule 1 above) is immediately followed by the "R" sequence (defined in rule 2 above).

Parent topic: Presentation Rules Tables


Line Number Clause Sequence Substitutions

Where "A R" is shown to be a permissible sequence in the presentation rules table, "A" is also permissible and the same presentation rules are applicable.

Where "NP R" is shown to be a permissible sequence in the presentation rules table, "NP" is also permissible and the same presentation rules are applicable.

Parent topic: Presentation Rules Tables


Saved Next Group Integer Description

Saved next group integer is a data item that is addressable only by the RWCS. When an absolute NEXT GROUP clause specifies a vertical positioning value which cannot be accommodated on the current page, the RWCS stores that value in saved next group integer. After page advance processing, the RWCS positions the next body group using the value stored in saved next group integer.

Parent topic: Presentation Rules Tables


Report Heading Group Presentation Rules

The Report Heading Group Presentation Rulestable below points to the appropriate presentation rules for all permissible combinations of LINE NUMBER and NEXT GROUP clauses in a report heading report group. The report heading group presentation rules are as follows:

  1. Upper limit rule.

    The first line number on which the report heading report group can be presented is the line number specified by the HEADING phrase of the PAGE clause.

  2. Lower limit rules.
    1. The last line number on which the report heading report group can be presented is the line number that is obtained by subtracting 1 from the value of integer-3 of the FIRST DETAIL phrase of the PAGE clause.
    2. The last line number on which the report heading report group can be presented is the line number specified by integer-1 of the PAGE clause.
  3. First print line position rules.
    1. The first print line of the report heading report group is presented on the line number specified by the integer of its LINE NUMBER clause.
    2. The first print line of the report heading report group is presented on the line number obtained by adding the integer of the first LINE NUMBER clause and the value obtained by subtracting 1 from the value of integer-2 of the HEADING phrase of the PAGE clause.
    3. The report heading report group is not presented.
    4. The first print line of the report heading report group is presented on the line number obtained by adding the content of its LINE-COUNTER (in this case, zero) to the integer of the first LINE NUMBER clause.
  4. Next group rules.
    1. The NEXT GROUP integer must be greater than the line number on which the final print line of the report heading report group is presented. In addition, the NEXT GROUP integer must be less than the line number specified by the value of integer-3 of the FIRST DETAIL phrase of the PAGE clause.
    2. The sum of the NEXT GROUP integer and the line number on which the final print line of the report heading report group is presented must be less than the value of integer-3 of the FIRST DETAIL phrase of the PAGE clause.
    3. NEXT GROUP PAGE signifies that the report heading report group is to be presented entirely by itself on the first page of the report. The RWCS processes no other report group while positioned to the first page of the report.
  5. Final LINE-COUNTER setting rules.
    1. After the report heading report group is presented, the RWCS places the NEXT GROUP integer into LINE-COUNTER as the final LINE-COUNTER setting.
    2. After the report heading report group is presented, the RWCS places the sum of the NEXT GROUP integer and the line number on which the final print line of the report heading report group was presented into LINE-COUNTER as the final LINE-COUNTER setting.
    3. After the report heading report group is presented, the RWCS places zero into LINE-COUNTER as the final LINE-COUNTER setting.
    4. After the report heading report group is presented, the final LINE-COUNTER setting is the line number on which the final print line of the report heading report group was presented.
    5. LINE-COUNTER is unaffected by the processing of a non-printable report group.
Table 1. Report Heading Group Presentation Rules
1 |  | Applicable Rules2
 |  | If the PAGE Clause is specified |  |  |  |  | If the PAGE Clause is omitted
Sequence of LINE NUMBER Clauses3 | NEXT GROUP Clause | Upper Limit | Lower Limit | First Print Line Position | Next Group | Final LINE COUNTER Setting | First Print Line Position | Final LINE COUNTER Setting
AR | Absolute | 1 | 2a | 3a | 4a | 5a | Illegal Combination
AR | Relative | 1 | 2a | 3a | 4b | 5b | Illegal Combination HRLHLHWRI0RU906.html#FN4
AR | NEXT PAGE | 1 | 2b | 3a | 4c | 5c | Illegal Combination HRLHLHWRI0RU906.html#FN4
AR |  | 1 | 2a | 3a |  | 5d | Illegal Combination HRLHLHWRI0RU906.html#FN4
R | Absolute | 1 | 2a | 3b | 4a | 5a | Illegal Combination
R | Relative | 1 | 2a | 3b | 4b | 5b | 3b | 5b
R | NEXT PAGE | 1 | 2b | 3b | 4c | 5c | Illegal Combination HRLHLHWRI0RU906.html#FN5
R |  | 1 | 2a | 3b |  | 5d | 3d | 5d
 |  |  |  | 3c |  | 5e | 3c | 5e
Parent topic: Presentation Rules Tables
Related information
The NEXT GROUP Clause
Line Number Clause Notation
1 A blank entry in column 1 or column 2 indicates that the named clause is totally absent from the report group description entry.
2 A blank entry in an applicable rules column indicates the absence of the named rule for the given combination of LINE NUMBER and NEXT GROUP clauses.
3 See the section Line Number Clause Notation for a description of the abbreviations used in column 1.
4 See the section Line Number Clause Notation.
5 See the section The NEXT GROUP Clause.


Page Heading Group Presentation Rules

The table below points to the appropriate presentation rules for all permissible combinations of LINE NUMBER and NEXT GROUP clauses in a page heading report group.

Table 1. Page Heading Group Presentation Rules
1 |  | Applicable Rules2
 |  | If the PAGE Clause is specified3
Sequence of LINE NUMBER Clauses4 | NEXT GROUP Clause | Upper Limit | Lower Limit | First Print Line Position | Next Group | Final LINE COUNTER Setting
AR | Absolute | 1 | 2 | 3a |  | 4a
R | Relative | 1 | 2 | 3b |  | 4a
 |  |  |  | 3c |  | 4b

The page heading group presentation rules are as follows:

  1. Upper limit rule.

    If a report heading report group has been presented on the page on which the page heading report group is to be presented, then the first line number on which the page heading report group can be presented is one greater than the final LINE-COUNTER setting established by the REPORT HEADING.

    Otherwise the first line number on which the page heading report group can be presented is the line number specified by the HEADING phrase of the PAGE clause.

  2. Lower limit rule.

    The last line number on which the page heading report group can be presented is the line number that is obtained by subtracting one from the value of integer-3 of the FIRST DETAIL phrase of the PAGE clause.

  3. First print line position rules.
    1. The first print line of the page heading report group is presented on the line number specified by the integer of its LINE NUMBER clause.
    2. If a report heading report group has been presented on the page on which the page heading report group is to be present, then the sum of the final LINE-COUNTER setting established by the report heading report group and the integer of the first LINE NUMBER clause of the page heading report group defines the line number on which the first print line of the page heading report group is presented.

      Otherwise the sum of the integer of the first LINE NUMBER clause of the page heading report group and the value obtained by subtracting one from the value of integer-2 of the HEADING phrase of the PAGE clause defines the line number on which the first print line of the page heading report group is presented.

    3. The page heading report group is not presented.
  4. Final LINE-COUNTER setting rules.
    1. The final LINE-COUNTER setting is the line number on which the final print line of the page heading report group was presented.
    2. LINE-COUNTER is unaffected by the processing of a nonprintable report group.
Parent topic: Presentation Rules Tables
Related information
The TYPE Clause
LINE NUMBER Clause Notation
1 A blank entry in column 1 or column 2 indicates that the named clause is totally absent from the report group description entry.
2 A blank entry in an applicable rules column indicates the absence of the named rule for the given combination of LINE NUMBER and NEXT GROUP clauses.
3 If the PAGE clause is omitted from the report description entry, then a page heading report group can not be defined. (See the section The TYPE Clause.)
4 See the section LINE NUMBER Clause Notation for a description of the abbreviations used in column 1.


Body Group Presentation Rules

The Body Group Presentation Rules table below points to the appropriate presentation rules for all permissible combinations of LINE NUMBER and NEXT GROUP clauses in control heading, detail, and control footing report groups. The body group presentation rules are as follows:

  1. Upper limit rule.

    The first line number on which a body group can be presented is the line number specified by the FIRST DETAIL phrase of the PAGE clause.

  2. Lower limit rules.

    The last line number on which a control heading report group or detail report group can be presented is the line number specified by the LAST DETAIL phrase of the PAGE clause.

    The last line number on which a control footing report group can be presented is the line number specified by the FOOTING phrase of the PAGE clause.

  3. Fit test rules.
    1. If the value in LINE-COUNTER is less than the integer of the first absolute LINE NUMBER clause, then the body group is presented on the page to which the report is currently positioned.

      If the value in LINE-COUNTER is not less than the integer of the first absolute LINE NUMBER clause, the RWCS executes page advance processing. After the page heading report group (if defined) has been processed, the RWCS determines whether the saved next group integer location was set when the final body group was presented on the preceding page. (See final LINE-COUNTER setting rule 6a.)

      If saved next group integer was not set, the body group shall be presented on the page to which the report is currently positioned. If saved next group integer was set, the RWCS moves the saved next group integer into LINE-COUNTER, resets saved next group integer to zero, and reapplies this rule.

    2. If a body group has been presented on the page to which the report is currently positioned, the RWCS computes a trial sum in a work location. The trial sum is computed by adding the content of LINE-COUNTER to the integers of all LINE NUMBER clauses of the report group. If the trial sum is not greater than the body group's lower limit integer, then the report group is presented on the current page. If the trial sum exceeds the body group's lower limit integer, then the RWCS executes page advance processing. After the page heading report group (if defined) has been processed, the RWCS reapplies this rule.

      If no body group has yet been presented on the page to which the report is currently positioned, the RWCS determines whether the saved next group integer location was set when the final body group was presented on the preceding page. (See final LINE-COUNTER setting rule 6a.)

      If saved next group integer was not so set, the body group shall be presented on the page to which the report is currently positioned.

      If saved next group integer was so set, the RWCS moves the saved next group integer into LINE-COUNTER, resets saved next group integer to zero, and computes a trial sum in a work location.

      The trial sum is computed by adding the content of LINE-COUNTER to the integer one and the integers of all but the first LINE NUMBER clause of the body group. If the trial sum is not greater than the body group's lower limit integer, then the body group is presented on the current page. If the trial sum exceeds the body group's lower limit integer, the RWCS executes page advance processing. After the page heading report group (if defined) has been processed, the RWCS presents the body group on that page.

    3. If a body group has been presented on the page to which the report is currently positioned, the RWCS executes page advance processing. After the page heading report group (if defined) has been processed, the RWCS reapplies this rule.

      If no body group has yet been presented on the page to which the report is currently positioned, the RWCS determines whether the saved next group integer location was set when the final body group was presented on the preceding page. (See final LINE-COUNTER setting rule 6a.)

      If saved next group integer was not so set, the body group shall be presented on the page to which the report is currently positioned. If saved next group integer was so set, the RWCS moves the saved next group integer into LINE-COUNTER and resets saved next group integer to zero.

      If then the value in LINE-COUNTER is less than the integer of the first absolute LINE NUMBER clause, the body group shall be presented on the page to which the report is currently positioned. Otherwise the RWCS executes page advance processing. After the page heading report group (if defined) has been processed, the RWCS presents the body group on that page.

  4. First print line position rules.
    1. The first print line of the body group is presented on the line number specified by the integer of its LINE NUMBER clause.
    2. If the value in LINE-COUNTER is equal to or greater than the line number specified by the FIRST DETAIL phrase of the PAGE clause, and if no body group has previously been presented on the page to which the report is currently positioned, then the first print line of the current body group is presented on the line immediately following the line indicated by the value contained on LINE-COUNTER.

      If the value in LINE-COUNTER is equal to or greater than the line number specified by the FIRST DETAIL phrase of the PAGE clause, and if a body group has previously been presented on the page to which the report is currently positioned, then the first print line of the current body group is presented on the line that is obtained by adding the content of LINE-COUNTER and the integer of the first LINE NUMBER clause of the current body group.

      If the value in LINE-COUNTER is less than the line number specified by the FIRST DETAIL phrase of the PAGE clause, then the first printer line of the body group is presented on the line specified by the FIRST DETAIL phrase.

    3. The body group is not presented.
    4. The sum of the content of LINE-COUNTER and the integer of the first LINE NUMBER clause defines the line number on which the first print line is presented.
  5. Next group rule.

    The integer of the absolute NEXT GROUP clause must specify a line number that is not less than that specified in the FIRST DETAIL phrase of the PAGE clause, and that is not greater than that specified in the FOOTING phrase of the PAGE clause.

  6. Final LINE-COUNTER setting rules.
    1. If the body group that has just been presented is a control footing report group and if the control footing report group is not associated with the highest level at which the RWCS detected a control break, then the final LINE-COUNTER setting is the line number on which the final print line of the control footing report group was presented.

      For all other cases, the RWCS makes a comparison of the line number on which the final print line of the body group was presented and the integer of the NEXT GROUP clause. If the former is less than the latter, then the RWCS places the NEXT GROUP integer into LINE-COUNTER as the final LINE-COUNTER setting. If the former is equal to or greater than the latter, then the RWCS places the line number specified by the FOOTING phrase of the PAGE clause into LINE-COUNTER as the final LINE-COUNTER setting; in addition the RWCS places the NEXT GROUP integer into the saved next group integer location.

    2. If the body group that has just been presented is a control footing report group, and if the control footing report group is not associated with the highest level at which the RWCS detected a control break, then the final LINE-COUNTER setting is the line number on which the final print line of the control footing report group was presented.

      For all other cases the RWCS computes a trial sum in a work location. The trial sum is computed by adding the integer of the NEXT GROUP clause to the line number on which the final print line of the body group was presented. If the sum is less than the line number specified by the FOOTING phrase of the PAGE clause, then the RWCS places that sum into LINE-COUNTER as the final LINE-COUNTER setting. If the sum is equal to or greater than the line number specified by the FOOTING phrase of the PAGE clause, then the RWCS places the line number specified by the FOOTING phrase of the PAGE clause into LINE-COUNTER as the final LINE-COUNTER setting.

    3. If the body group that has just been presented is a control footing report group, and if the control footing report group is not associated with the highest level at which the RWCS detected a control break, then the final LINE-COUNTER setting is the line number on which the final print line of the control footing report group was presented.

      For all other cases the RWCS places the line number specified by the FOOTING phrase of the PAGE clause into LINE-COUNTER as the final LINE-COUNTER setting.

    4. The final LINE-COUNTER setting is the line number on which the final print line of the body group was presented.
    5. LINE-COUNTER is unaffected by the processing of a nonprintable body group.
    6. If the body group that has just been presented is a control footing report group, and if the control footing report group is not associated with the highest level at which the RWCS detected a control break, then the final LINE-COUNTER setting is the line number on which the final print line of the control footing report group was presented.

      For all other cases the RWCS places the sum of the line number on which the final print line was presented and the NEXT GROUP integer into LINE-COUNTER as the final LINE-COUNTER setting.

Table 1. Body Group Presentation Rules
1 |  | Applicable Rules 2
 |  | If the PAGE Clause is specified |  |  |  |  | If the PAGE Clause is omitted
Sequence of LINE NUMBER Clauses 3 | NEXT GROUP Clause | Upper Limit | Lower Limit | First Print Line Position | Next Group | Final LINE COUNTER Setting | First Print Line Position | Final LINE COUNTER Setting
AR | Absolute | 1 | 2 | 3a | 4a | 5 | Illegal Combination HRLHLHWRI0RU043.html#FN4
AR | Relative | 1 | 2 | 3a | 4a |  | Illegal Combination HRLHLHWRI0RU043.html#FN4
AR | NEXT PAGE | 1 | 2 | 3a | 4a |  | Illegal Combination HRLHLHWRI0RU043.html#FN4
AR |  | 1 | 2 | 3a | 4a |  | Illegal Combination HRLHLHWRI0RU043.html#FN4
R | Absolute | 1 | 2 | 3b | 4b | 5 | Illegal Combination HRLHLHWRI0RU043.html#FN4
R | Relative | 1 | 2 | 3b | 4b |  | 4d | 6f
R | NEXT PAGE | 1 | 2 | 3b | 4b |  | Illegal Combination HRLHLHWRI0RU043.html#FN4
R |  | 1 | 2 | 3b | 4b |  | 4d | 6f
NP R | Absolute | 1 | 2 | 3c | 4a | 5 | Illegal Combination HRLHLHWRI0RU043.html#FN4
NP R | Relative | 1 | 2 | 3c | 4a |  | Illegal Combination HRLHLHWRI0RU043.html#FN4
NP R | NEXT PAGE | 1 | 2 | 3c | 4a |  | Illegal Combination HRLHLHWRI0RU043.html#FN4
NP R |  | 1 | 2 | 3c | 4a |  | Illegal Combination HRLHLHWRI0RU043.html#FN4
 |  |  |  |  | 4c |  | 4c | 6e
Parent topic: Presentation Rules Tables
Related information
The LINE NUMBER Clause (Report Writer)
The NEXT GROUP Clause
1 A blank entry in column 1 or column 2 indicates that the named clause is totally absent from the report group description entry.
2 A blank entry in an applicable rules column indicates the absence of the named rule for the given combination of LINE NUMBER and NEXT GROUP clauses.
3 See the section LINE NUMBER Clause Notation for a description of the abbreviations used in column 1.
4 See the section The LINE NUMBER Clause.


Page Footing Presentation Rules

The table below points to the appropriate presentation rules for all permissible combinations of LINE NUMBER and NEXT GROUP clauses in a PAGE FOOTING report group.

Table 1. Page Footing Presentation Rules
1 |  | Applicable Rules 2
 |  | If the PAGE Clause is specified 3
Sequence of LINE NUMBER Clauses 4 | NEXT GROUP Clause | Upper Limit | Lower Limit | First Print Line Position | Next Group | Final LINE COUNTER Setting
AR | Absolute | 1 | 2 | 3a | 4a | 5a
AR | Relative | 1 | 2 | 3a | 4b | 5b
AR |  | 1 | 2 | 3a |  | 5c
 |  |  |  | 3b |  | 5d

The page footing presentation rules are as follows:

  1. Upper limit rule.

    The first line number on which the page footing report group can be presented is the line number obtained by adding one to the value of integer-5 of the FOOTING phrase of the PAGE clause.

  2. Lower limit rule.

    The last line number on which the page footing report group can be presented is the line number specified by integer-1 of the PAGE clause.

  3. First print line position rules.
    1. The first print line of the page footing report group is presented on the line specified by the integer of its LINE NUMBER clause.
    2. The page footing report group is not presented.
  4. Next group rules.
    1. The NEXT GROUP integer must be greater than the line number on which the final print line of the page footing report group is presented. In addition, the NEXT GROUP integer must not be greater than the line number specified by integer-1 of the PAGE clause.
    2. The sum of the NEXT GROUP integer and the line number on which the final print line of the page footing report group is presented must not be greater than the line number specified by integer-1 of the PAGE clause.
  5. Final LINE-COUNTER setting rules.
    1. After the page footing report group is presented, the RWCS places the NEXT GROUP integer into LINE-COUNTER as the final LINE-COUNTER setting.
    2. After the page footing report group is presented, the RWCS places the sum of the NEXT GROUP integer and the line number on which the final print line of the PAGE FOOTING report group was presented into LINE-COUNTER as the final LINE-COUNTER setting.
    3. After the PAGE FOOTING report group is presented the final LINE-COUNTER setting is the line number on which the final print line of the PAGE FOOTING report group was presented.
    4. LINE-COUNTER is unaffected by the processing of a nonprintable report group.
Parent topic: Presentation Rules Tables
Related information
The TYPE Clause
The LINE NUMBER Clause (Report Writer)
1 A blank entry in column 1 or column 2 indicates that the named clause is totally absent from the report group description entry.
2 A blank entry in an applicable rules column indicates the absence of the named rule for the given combination of LINE NUMBER and NEXT GROUP clauses.
3 If the PAGE clause is omitted from the report description entry, then a page footing report group can not be defined. (See the section The TYPE Clause.)
4 See the section LINE NUMBER Clause Notation for a description of the abbreviations used in column 1


Report Footing Presentation Rules

The Report Heading Group Presentation Rules table points to the appropriate presentation rules for all permissible combinations of LINE NUMBER and NEXT GROUP clauses in a report footing report group. The report footing presentation rules are as follows:

  1. Upper limit rules.
    1. If a page footing report group has been presented on the page to which the report is currently positioned, then the first line number on which the report footing report group can be presented is one greater than the final LINE- COUNTER setting established by the page footing report group.

      Otherwise the first line number on which the report footing report group can be presented is the line number obtained by adding one and the value of integer-5 of the PAGE clause.

    2. The first line number on which the report footing report group can be presented, is the line number specified by the HEADING phrase of the PAGE clause.
  2. Lower limit rule:

    The last line number on which the report footing report group can be presented is the line number specified by integer-1 of the PAGE clause.

  3. First print line position rules:
    1. The first print line of the report footing report group is presented on the line specified by the integer of its LINE NUMBER clause.
    2. If a page footing report group has been presented on the page to which the report is currently positioned, then the sum of the final LINE-COUNTER setting established by the page footing report group and the integer of the first LINE NUMBER clause of the report footing report group defines the line number on which the first print line of the report footing report group is presented. Otherwise the sum of the integer of the first LINE NUMBER clause of the report footing report group, and the line number specified by the value of integer-5 of the FOOTING phrase of the PAGE clause defines the line number on which the first print line of the report footing report group is presented.
    3. The NEXT PAGE phrase in the first absolute LINE NUMBER clause directs that the report footing report group is presented on a page on which no other report group has been presented. The first print line of the report footing report group is presented on the line number specified by the integer of its LINE NUMBER clause.
    4. If LINE IS NEXT PAGE is the only LINE clause in this report group, the first line of the report heading report group is presented on line HEADING integer-2.
    5. The sum of the content of LINE-COUNTER and the integer of the first LINE NUMBER clause defines the line number on which the first print line is presented.
    6. The report footing report group is not presented.
  4. Final LINE-COUNTER setting rules.
    1. The final LINE-COUNTER setting is the line number on which the final print line of the report footing report group is presented.
    2. LINE-COUNTER is unaffected by the processing of a nonprintable report group.
Table 1. Report Heading Group Presentation Rules
1 |  | Applicable Rules 2
 |  | If the PAGE Clause is specified |  |  |  |  | If the PAGE Clause is omitted
Sequence of LINE NUMBER Clauses 3 | NEXT GROUP Clause | Upper Limit | Lower Limit | First Print Line Position | Next Group | Final LINE COUNTER Setting | First Print Line Position | Final LINE COUNTER Setting
AR |  | 1a | 2 | 3a |  | 4a | Illegal CombinationHRLHLHWRI0RU910.html#FN4
R |  | 1b | 2 | 3b |  | 4a | 3b | 4a
NP R |  | 1c | 2 | 3c |  | 4a | Illegal Combination HRLHLHWRI0RU910.html#FN4
 |  |  |  | 3e |  | 4b | 3e | 4b
Parent topic: Presentation Rules Tables
Related information
The LINE NUMBER Clause (Report Writer)
1 A blank entry in column 1 or column 2 indicates that the named clause is totally absent from the report group description entry.
2 A blank entry in an applicable rules column indicates the absence of the named rule for the given combination of LINE NUMBER and NEXT GROUP clauses.
3 See the section LINE NUMBER Clause Notation for a description of the abbreviations used in column 1.
4 See the section The LINE NUMBER Clause.


The COLUMN NUMBER Clause (Report Writer)

The COLUMN NUMBER clause identifies a printable item and specifies the position of the item on a print line.

General Format

Syntax Rules

  1. The COLUMN NUMBER clause can be specified only at the elementary level in a report group. The COLUMN NUMBER clause, if present, must appear in or be subordinate to an entry that contains a LINE NUMBER clause.
  2. Within a given print line, the printable items should be defined in ascending column number order such that each printable item defined occupies a unique sequence of contiguous character positions.

    OSVS No restrictions on the sequence of COLUMN NUMBER clauses are enforced.

General Rules

  1. The COLUMN NUMBER clause indicates that the object of a SOURCE clause or the object of a VALUE clause or the sum counter defined by a SUM clause is to be presented on the print line. The absence of a COLUMN NUMBER clause indicates that the entry is not to be presented on a print line.
  2. Integer-1 specifies the column number of the leftmost character position of the printable item.
  3. The RWCS supplies space characters for all positions of a print line that are not occupied by printable items.
  4. The leftmost position of the print line is considered to be column number 1.
Parent topic: The Report Group Description Entry


Data-name (Report Writer)

A data-name specifies the name of the data item being described.

General Format

Syntax Rules

  1. In the report section data-name-1 need not appear in a data description entry.

General Rules

  1. In the Report Section, data-name-1 must be given in the following cases:
    1. When data-name-1 represents a report group to be referred to by a GENERATE or a USE statement in the procedure division.
    2. When reference is to be made to the sum counter in the procedure division or report section.
    3. When a DETAIL report group is referenced in the UPON phrase of the SUM clause.
    4. When data-name-1 is required to provide sum counter qualification.
Parent topic: The Report Group Description Entry


The GROUP INDICATE Clause

The GROUP INDICATE clause specifies that the associated printable item is presented only on the first occurrence of its report group after a control break or page advance.

General Format

Syntax Rules

  1. The GROUP INDICATE clause must be specified only in a DETAIL report group entry that defines a printable item.

General Rules

  1. If a GROUP INDICATE clause is specified, it causes the SOURCE or VALUE clause to be ignored and spaces supplied, except:
    1. On the first presentation of the DETAIL report group in the report, or:
    2. On the first presentation of the DETAIL report group after every page advance, or:
    3. On the first presentation of the DETAIL report group after every control group.
  2. If the report description entry specifies neither a PAGE clause nor a CONTROL clause, then a GROUP INDICATE printable item is presented the first time its DETAIL is presented after the INITIATE statement is executed. Thereafter spaces are supplied for indicated items with SOURCE or VALUE clauses.
Parent topic: The Report Group Description Entry


Level-Number (Report Writer)

The level-number indicates the position of a data item in the hierarchical structure of a report group.

General Format

Syntax Rules

  1. A level-number is required as the first element in each data description entry.
  2. Data description entries subordinate to an RD entry must have level-numbers 01 through 49 only.

General Rules

  1. The level-number 01 identifies the first entry in a report group.
  2. Multiple level 01 entries subordinate to a report description entry having the level indicator RD do not represent implicit redefinitions of the same area.
Parent topic: The Report Group Description Entry


The LINE NUMBER Clause (Report Writer)

The LINE NUMBER clause specifies vertical positioning information for its report group.

General Format

Syntax Rules

  1. Integer-1 and integer-2 must not exceed three significant digits in length.

    Neither integer-1 nor integer-2 can be specified in such a way as to cause any line of a report group to be presented outside the vertical subdivision of the page designated for that report group type, as defined by the PAGE clause. (See the section The PAGE Clause.)

    Integer-2 can be zero.

  2. Within a given report group description entry, an entry that contains a LINE NUMBER clause must not contain a subordinate entry that also contains a LINE NUMBER clause.
  3. Within a given report group description entry, all absolute LINE NUMBER clauses must precede all relative LINE NUMBER clauses.
  4. Within a given report group description entry, successive absolute LINE NUMBER clauses must specify integers that are in ascending order. The integers need not be consecutive.
  5. If the PAGE clause is omitted from a given report description entry, only relative LINE NUMBER clauses can be specified in any report group description entry in that report.
  6. Within a given report group description entry a NEXT PAGE phrase can appear only once and, if present, must be in the first LINE NUMBER clause in that report group description entry.
  7. A LINE NUMBER clause with the NEXT PAGE phrase can appear only in the description of body groups and in a REPORT FOOTING report group.
  8. Every entry that defines a printable item (see the section The COLUMN NUMBER Clause) must either contain a LINE NUMBER clause, or be subordinate to an entry that contains a LINE NUMBER clause.
  9. The first LINE NUMBER clause specified in a PAGE FOOTING report group must be an absolute LINE NUMBER clause.

General Rules

  1. A LINE NUMBER clause must be specified to establish each print line of a report group.
  2. The RWCS affects the vertical positioning specified by a LINE NUMBER clause, before presenting the print line established by that LINE NUMBER clause.
  3. Integer-1 specifies an absolute line number. An absolute line number specifies the line number on which the print line is presented.
  4. Integer-2 specifies a relative line number. If a relative LINE NUMBER clause is not the first LINE NUMBER clause in the report group description entry, then the line number on which its print line is presented is determined by calculating the sum of the line number on which the previous print line of the report group was presented and integer-2 of the relative LINE NUMBER clause. If integer-2 is zero, the line will be printed on the same line as the previous print line.

    If a relative LINE NUMBER clause is the first LINE NUMBER clause in the report group description entry, then the line number on which its print line is presented is determined by specified rules. (See the section Presentation Rules Tables.)

  5. The NEXT PAGE phrase specifies that the report group is to be presented beginning on the indicated line number on a new page. (See the section Presentation Rules Tables.) You need not specify integer-1 for the NEXT PAGE phrase.
Parent topic: The Report Group Description Entry
Related information
The PAGE Clause
The COLUMN NUMBER Clause (Report Writer)
Presentation Rules Tables


The NEXT GROUP Clause

The NEXT GROUP clause specifies information for vertical positioning of a page following the presentation of the last line of a report group.

General Format

Syntax Rules

  1. A report group entry must not contain a NEXT GROUP clause unless the description of that report group contains at least one LINE NUMBER clause.
  2. Integer-1 and integer-2 must not exceed three significant digits in length.
  3. If the PAGE clause is omitted from the report description entry only a relative NEXT GROUP clause can be specified in any report group description entry in that report.
  4. The NEXT PAGE phrase of the NEXT GROUP clause must not be specified in a PAGE FOOTING report group.
  5. The NEXT GROUP clause must not be specified in a REPORT FOOTING report group or in a PAGE HEADING report group.

General Rules

  1. Any positioning of the page specified by the NEXT GROUP clause takes place after the presentation of the report group in which the clause appears. (See the section Presentation Rules Tables.)
  2. The RWCS uses the vertical positioning information supplied by the NEXT GROUP clause along with information from the TYPE and PAGE clauses, and the value in LINE-COUNTER, to determine a new value for LINE-COUNTER. (See the section Presentation Rules Tables.)
  3. The NEXT GROUP clause is ignored by the RWCS when it is specified on a CONTROL FOOTING report group that is at a level other than the highest level at which a control break is detected.
  4. The NEXT GROUP clause of a body group refers to the next body group to be presented, and therefore can affect the location at which the next body group is presented. The NEXT GROUP clause of a REPORT HEADING report group can affect the location at which the PAGE HEADING report group is presented. The NEXT GROUP clause of a PAGE FOOTING report group can affect the location at which the REPORT FOOTING report group is presented. (See the section Presentation Rules Tables.)
Parent topic: The Report Group Description Entry
Related information
Presentation Rules Tables


The SIGN Clause (Report Writer)

The SIGN clause specifies the position and the mode of representation of the operational sign when it is necessary to describe these properties explicitly.

General Format

Syntax Rules

  1. The SIGN clause can be specified only for a numeric data description entry whose PICTURE contains the character "S".
  2. The numeric data description entries to which the SIGN clause applies must be described, implicitly or explicitly, as USAGE IS DISPLAY.
  3. When the SIGN clause is included in a report group description entry, the SEPARATE CHARACTER phrase must be specified.

General Rules

  1. The optional SIGN clause, if present, specifies the position and the mode of representation of the operational sign for the numeric data description entry to which it applies. The SIGN clause applies only to numeric data description entries whose PICTURE contains the character "S"; The "S" indicates the presence of, but neither the representation nor, necessarily, the position of the operational sign.
  2. A numeric data description entry whose PICTURE contains the character "S", but to which no optional SIGN clause applies, has an operational sign, but neither the representation nor, necessarily, the position of the operational sign is specified by the character "S". In this (default) case, General Rule 3 does not apply to such signed numeric data items. The representation of the default operational sign is defined in the section Selection of Character Representation and Radix in the chapter Concepts of the COBOL Language.
  3. Since a SIGN clause in a report group description entry must specify the SEPARATE CHARACTER phrase, then:
    1. The operational sign will be presumed to be the leading (or, respectively, trailing) character position of the elementary numeric data item; this character position is not a digit position.
    2. The letter "S" in a PICTURE character-string is counted in determining the size of the item (in terms of standard data format characters).
    3. The operational signs for positive and negative are the standard data format characters "+" , and "–", respectively.
  4. Every numeric data description entry whose PICTURE contains the character "S" is a signed numeric data description entry. If a SIGN clause applies to such an entry and conversion is necessary for purposes of computation or comparisons, conversion takes place automatically.
Parent topic: The Report Group Description Entry
Related information
Selection of Character Representation and Radix


The SOURCE Clause (Report Writer)

The SOURCE clause identifies the sending data item that is moved to an associated printable item defined in a report group description entry.

General Format

Syntax Rules

  1. Identifier-1 can be defined in any section of the data division or be a function-identifier. If identifier-1 is a report section item it must be a:
    1. PAGE-COUNTER, or:
    2. LINE-COUNTER, or:
    3. Sum counter that is part of the report within which the SOURCE clause appears.
  2. Identifier-1 specifies the sending data item of the implicit MOVE statement that the RWCS executes to move the content of the data item referenced by identifier-1 to the printable item. Identifier-1 must be defined such that it conforms to the rules for sending items in the MOVE statement. (See the section The MOVE Statement.)

General Rules

  1. The RWCS formats the print lines of a report group just prior to presenting the report group. (See the section The TYPE Clause.) It is at this time that the implicit MOVE statements specified by SOURCE clauses are executed by the RWCS.
Parent topic: The Report Group Description Entry
Related information
The MOVE Statement
The TYPE Clause


The SUM Clause (Report Writer)

The SUM clause establishes a sum counter and names the data items to be summed.

General Format

Syntax Rules

  1. The data item that is the subject of the report group description entry in which the SUM clause appears must not be defined as alphabetic. Identifier-1 must reference a numeric data item. If identifier-1 is defined in the report section, identifier-1 must reference a sum counter.

    If the UPON phrase is omitted, any identifiers in the associated SUM clause which are themselves sum counters must be defined either in the same report group that contains this SUM clause or in a report group which is at a lower level in the control hierarchy of this report.

    If the UPON phrase is specified, any identifiers in the associated SUM clause must not be sum counters.

  2. Data-name-1 must be the name of a DETAIL report group described in the same report as the CONTROL FOOTING report group in which the SUM clause appears. Data-name-1 can be qualified by a report-name.
  3. A SUM clause can appear only in the description of a CONTROL FOOTING report group.
  4. Data-name-2 must be one of the data-names specified on the CONTROL clause for this report. Data-name-2 must not be a lower level control than the associated control for the report group in which the RESET phrase appears.

    FINAL, if specified in the RESET phrase, must also appear in the CONTROL clause for this report.

    OSVS This rule is not enforced.

  5. The highest permissible qualifier of a sum counter is the report-name.

General Rules

  1. The SUM clause establishes a sum counter. The sum counter is a numeric data item with an optional sign. At object time, the RWCS adds into the sum counter the value in each data item referenced by identifier-1. This addition is consistent with the rules for arithmetic statements. (See the sections Arithmetic Statements and Overlapping Operands.)
  2. The size of the sum counter is equal to the number of receiving character positions specified by the PICTURE clause that accompanies the SUM clause in the description of the elementary item.
  3. Only one sum counter exists for an elementary report entry regardless of the number of SUM clauses specified in the elementary report entry.
  4. If the elementary report entry for a printable item contains a SUM clause, the sum counter serves as a source data item. The RWCS moves the data contained in the sum counter, according to the rules of the MOVE statement, to the printable item for presentation.
  5. If a data-name appears as the subject of an elementary report entry that contains a SUM clause, the data-name is the name of the sum counter; the data-name is not the name of the printable item that the entry can also define.
  6. It is permissible for Procedure Division statements to alter the contents of sum counters.
  7. Addition of the values of the data items referenced by identifiers into sum counters is performed by the report writer control system during the execution of GENERATE and TERMINATE statements. There are three categories of sum counter incrementing called subtotalling, crossfooting, and rolling forward. Subtotalling is accomplished only during execution of GENERATE statements and after any control break processing but before processing of the DETAIL report group. (See the section The GENERATE Statement.) Crossfooting and rolling forward are accomplished during the processing of CONTROL FOOTING report groups. (See the section The TYPE Clause.)
  8. The UPON phrase provides the capability to accomplish selective subtotalling for the DETAIL report groups named in the phrase.
  9. The RWCS adds each individual addend into the sum counter at a time that depends upon the characteristics of the addend.
    1. When the addend is a sum counter defined in the same CONTROL FOOTING report group, then the accumulation of that addend into the sum counter is termed crossfooting.

      Crossfooting occurs when a control break takes place and at the time the CONTROL FOOTING report group is processed.

      Crossfooting is performed according to the sequence in which sum counters are defined in the CONTROL FOOTING report group. That is, all crossfooting into the first sum counter defined in the CONTROL FOOTING report group is completed, and then all crossfooting into the second sum counter defined in the CONTROL FOOTING report group is completed.

      When one of the addends is the sum counter defined by the data description entry in which that SUM clause appears, the initial value of that sum counter at the time of summation is used in the summing operation.

    2. When the addend is a sum counter defined in a lower level CONTROL FOOTING report group, then the accumulation of that addend into the sum counter is termed rolling forward. A sum counter in a lower level CONTROL FOOTING report group is rolled forward when a control break occurs and at the time that the lower level CONTROL FOOTING report group is processed.
    3. When the addend is not a sum counter the accumulation into a sum counter of such an addend is called subtotalling. If the SUM clause contains the UPON phrase, the addends are subtotalled when a GENERATE statement for the designated DETAIL report group is executed. If the SUM clause does not contain the UPON phrase, the addends which are not sum counters are subtotalled when any GENERATE data-name statement is executed for the report in which the SUM clause appears.
  10. If two or more of the identifiers specify the same addend, then the addend is added into the sum counter as many times as the addend is referenced in the SUM clause. It is permissible for two or more of the data-names to specify the same DETAIL report group. When a GENERATE data-name statement for such a DETAIL report group is given, the incrementing occurs repeatedly, as many times as data-name appears in the UPON phrase.
  11. The subtotalling that occurs when a GENERATE report-name statement is executed is discussed in the appropriate paragraph. (See the section The GENERATE Statement.)
  12. In the absence of an explicit RESET phrase, the report writer control system will set a sum counter to zero at the time that the report writer control system is processing the CONTROL FOOTING report group in which the sum counter is defined. If an explicit RESET phrase is specified, then the report writer control system will set the sum counter to zero at the time that the report writer control system is processing the designated level of the control hierarchy. (See the section The TYPE Clause.)

    Sum counters are initially set to zero by the report writer control system during the execution of the INITIATE statement for the report containing the sum counter.

Parent topic: The Report Group Description Entry
Related information
Arithmetic Statements
Overlapping Operands
The GENERATE Statement
The TYPE Clause


The TYPE Clause

The TYPE clause specifies the particular type of report group that is described by this entry and indicates the time at which the report group is to be processed by the RWCS.

General Format

Syntax Rules

  1. RH is an abbreviation for REPORT HEADING. PH is an abbreviation for PAGE HEADING. CH is an abbreviation for CONTROL HEADING. DE is an abbreviation for DETAIL. CF is an abbreviation for CONTROL FOOTING. PF is an abbreviation for PAGE FOOTING. RF is an abbreviation for REPORT FOOTING.
  2. REPORT HEADING, PAGE HEADING, CONTROL HEADING FINAL, CONTROL FOOTING FINAL, PAGE FOOTING, and REPORT FOOTING report groups can each appear no more than once in the description of a report.
  3. PAGE HEADING and PAGE FOOTING report groups can be specified only if a PAGE clause is specified in the corresponding report description entry.
  4. Data-name-1, data-name-2, and FINAL, if present, must be specified in the CONTROL clause of the corresponding report description entry.

    OSVS This rule is not enforced with regard to FINAL.

    At most, one CONTROL HEADING report group and one CONTROL FOOTING report group can be specified for each data-name or FINAL in the CONTROL clause of the report description entry. However, neither a CONTROL HEADING report group nor a CONTROL FOOTING report group is required for a data-name or FINAL specified in the CONTROL clause of the report description entry.

  5. In CONTROL FOOTING, PAGE HEADING, PAGE FOOTING, AND REPORT FOOTING report groups, SOURCE clauses and USE statements must not reference any of the following:
    1. Group data items containing a control data item.
    2. Data items subordinate to a control data item.
    3. A redefinition or renaming of any part of a control data item.

    In PAGE HEADING and PAGE FOOTING report groups, SOURCE clauses and USE statements must not reference control data-names.

  6. When a GENERATE report-name statement is specified in the Procedure Division, the corresponding report description entry must include no more than one DETAIL report group. If no GENERATE data-name statements are specified for such a report, a DETAIL report group is not required.
  7. The description of a report must include at least one body group.

General Rules

  1. DETAIL report groups are processed by the RWCS as a direct result of GENERATE statements. If a report group is other than TYPE DETAIL its processing is an automatic RWCS function.
  2. The REPORT HEADING phrase specifies a report group that is processed by the RWCS only once, per report, as the first report group of that report. The REPORT HEADING report group is processed during the execution of the chronologically first GENERATE statement for that report.
  3. The PAGE HEADING phrase specifies a report group that is processed by the RWCS as the first report group on each page of that report except under the following conditions:
    1. A PAGE HEADING report group is not processed on a page that is to contain only a REPORT HEADING report group or only a REPORT FOOTING report group.
    2. A PAGE HEADING report group is processed as the second report group on a page when it is preceded by a REPORT HEADING report group that is not to be presented on a page by itself.

    (See the section Presentation Rules Tables.)

  4. The CONTROL HEADING phrase specifies a report group that is processed by the RWCS at the beginning of a control group for a designated control data-name or, in the case of FINAL, is processed during the execution of the chronologically first GENERATE statement for that report. During the execution of any GENERATE statement at which the RWCS detects a control break, any CONTROL HEADING report groups associated with the highest control level of the break and lower levels are processed.
  5. The DETAIL phrase specifies a report group that is processed by the RWCS when a corresponding GENERATE statement is executed.
  6. The CONTROL FOOTING phrase specifies a report group that is processed by the RWCS at the end of a control group for a designated control data-name.

    In the case of FINAL, the CONTROL FOOTING report group is processed only once per report as the last body group of that report. During the execution of any GENERATE statement in which the RWCS detects a control break, any CONTROL FOOTING report group associated with the highest level of the control break or more minor levels is presented. All CONTROL FOOTING report groups are presented during the execution of the TERMINATE statement if there has been at least one GENERATE statement executed for the report. (See the section The TERMINATE Statement.)

  7. The PAGE FOOTING phrase specifies a report group that is processed by the RWCS as the last report group on each page except under the following conditions:
    1. A PAGE FOOTING report group is not processed on a page that is to contain only a REPORT HEADING report group or only a REPORT FOOTING report group.
    2. A PAGE FOOTING report group is processed as the second to last report group on a page when it is followed by a REPORT FOOTING report group that is not to be processed on a page by itself.

    (See the section Presentation Rules Tables.)

  8. The REPORT FOOTING phrase specifies a report group that is processed by the RWCS only once per report and as the last report group of that report. The REPORT FOOTING report group is processed during the execution of a corresponding TERMINATE statement, if there has been at least one GENERATE statement executed for the report. (See the section The TERMINATE Statement.)
  9. The sequence of steps that the RWCS executes when it processes a REPORT HEADING, PAGE HEADING, CONTROL HEADING, PAGE FOOTING, or REPORT FOOTING report group is described below.
    1. If a USE BEFORE REPORTING procedure references the data-name of the report group, the USE procedure is executed.
    2. If a SUPPRESS statement has been executed or if the report group is not printable, no further processing is done for the report group.
    3. If a SUPPRESS statement has not been executed and the report group is printable, the RWCS formats the print lines and presents the report group according to the presentation rules for that type of report group. (See the section Presentation Rules Tables.)
  10. The sequence of steps that the RWCS executes when it processes a CONTROL FOOTING report group is described below.

    The GENERATE rules specify that when a control break occurs, the RWCS produces the CONTROL FOOTING report groups beginning at the minor level, and proceeding upwards, through the level at which the highest control break was sensed. In this regard, it should be noted that even though no CONTROL FOOTING report group has been defined for a given control data-name, the RWCS will still have to execute the step described in rule 10f below if a RESET phrase in the report description specifies that control data-name.

    1. Sum counters are crossfooted; that is, all sum counters defined in this report group that are operands of SUM clauses in the same report group are added to their sum counters. (See the section The SUM Clause.)
    2. Sum counters are rolled forward; that is, all sum counters defined in the report group that are operands of SUM clauses in higher level CONTROL FOOTING report groups are added to the higher level sum counters. (See the section The SUM Clause.)
    3. If a USE BEFORE REPORTING procedure references the data-name of the report group the USE procedure is executed.
    4. If a SUPPRESS statement has been executed or if the report group is not printable, the RWCS next executes the step described in rule 10e below.
    5. If a SUPPRESS statement has not been executed and the report group is printable, the RWCS formats the print lines and presents the report group according to the presentation rules of CONTROL FOOTING report groups.
    6. Then the RWCS resets those sum counters that are to be reset when the RWCS processes this level in the control hierarchy. (See the section The SUM Clause.)
  11. The DETAIL report group processing that the RWCS system executes in response to a GENERATE data-name statement is described in rules 11a through 11e below.

    When the description of a report includes exactly one DETAIL report group, the detail-related processing that the RWCS executes in response to a GENERATE report-name statement is described in rules 11a through 11e below. These steps are performed as though a GENERATE data-name statement were being executed.

    When the description of a report includes no DETAIL report groups, the detail-related processing that the RWCS executes in response to a GENERATE report-name statement is described in rule 11a below. This step is performed as though the description of the report included exactly one DETAIL report group, and a GENERATE data-name statement were being executed.

    1. The RWCS performs any subtotalling that has been designated for the DETAIL report group. (See the section The SUM Statement.)
    2. If a USE BEFORE REPORTING procedure refers to the data-name of the report group, the USE procedure is executed.
    3. If a SUPPRESS statement has been executed or if the report group is not printable no further processing is done for the report group.
    4. If the DETAIL report group is being processed as a consequence of a GENERATE report-name statement, no further processing is done for the report group.
    5. If neither 11c nor 11d above applies, the RWCS formats the print lines and presents the report group according to the presentation rules for DETAIL report groups. (See the section Presentation Rules Tables.)
  12. When the RWCS is processing a CONTROL HEADING, CONTROL FOOTING, or DETAIL report group, as described in General Rules 9, 10, and 11, the RWCS may have to interrupt the processing of that body group after determining that the body group is to be presented, and execute a page advance ( and process PAGE FOOTING and PAGE HEADING report groups) before actually presenting the body group.
  13. During control break processing, the values of control data items that the RWCS used to detect a given control break are referred to as prior values.
    1. During control break processing of a CONTROL FOOTING report group, any references to control data items in a USE procedure or SOURCE clause associated with that CONTROL FOOTING report group are supplied with prior values.
    2. When a TERMINATE statement is executed, the RWCS makes the prior control data item values available to SOURCE clause or USE procedure references in CONTROL FOOTING and REPORT FOOTING report groups as though a control break had been detected in the highest control data-name.
    3. All other data item references in report groups and their USE procedures access the current values that are contained in the data items at the time the report group is processed.
Parent topic: The Report Group Description Entry
Related information
Presentation Rules Tables
The TERMINATE Statement
The SUM Clause (Report Writer)
The SUM Function


The USAGE Clause

The USAGE clause specifies the format of a data item in the computer storage.

General Format

Syntax Rules

  1. The USAGE clause can be written in any data description entry.
  2. If the USAGE clause is written in the data description entry for a group item, it can also be written in the data description entry for a subordinate elementary item or group item.
  3. The USAGE clause for a report group item can specify only USAGE IS DISPLAY.

General Rules

  1. If the USAGE clause is written at a group level, it applies to each elementary item in the group.
  2. The USAGE clause specifies the manner in which a data item is represented in the storage of a computer. It does not affect the use of the data item, although the specifications for some statements in the Procedure Division can restrict the USAGE clause of the operands referred to. The USAGE clause can affect the radix or type of character representation of the item.
  3. The USAGE IS DISPLAY clause indicates that the format of the data is a standard data format.
  4. If the USAGE clause is not specified for an elementary item, or for any group to which the item belongs, the usage is implicitly DISPLAY.
Parent topic: The Report Group Description Entry


The VALUE Clause (Report Writer)

The VALUE clause defines the value of Report Section printable items.

General Format

Syntax Rules

  1. A signed numeric literal must have associated with it a signed numeric PICTURE character-string.
  2. A numeric literal in a VALUE clause of an item must have a value which is within the range of values indicated by the PICTURE clause, and must not have a value which would require truncation of nonzero digits. A nonnumeric literal in a VALUE clause of an item must not exceed the size indicated by the PICTURE clause.

General Rules

  1. The VALUE clause must not conflict with other clauses in the data description of the item or in the data description in the hierarchy of the item. The following rules apply:
    1. If the category of the item is numeric, literal-1 in the VALUE clause must be numeric.
    2. If the category of the item is alphabetic, alphanumeric, alphanumeric edited, or numeric edited, literal-1 in the VALUE clause must be a nonnumeric literal. The literal is aligned in the data item as if the data item had been described as alphanumeric (See the section Standard Alignment Rules). Editing characters in the PICTURE clause are included in determining the size of the data item but have no effect on initialization of the data item (see the section The PICTURE Clause. Therefore, the value for an edited item must be specified in an edited form.
    3. Initialization is not affected by any BLANK WHEN ZERO or JUSTIFIED clause that can be specified.
  2. In the report section, if the elementary report entry containing the VALUE clause does not contain a GROUP INDICATE clause, then the printable item will assume the specified value each time its report group is printed. However, when the GROUP INDICATE clause is also present, the specified value will be presented only when certain object item conditions exist (see the section The GROUP INDICATE Clause).
Parent topic: The Report Group Description Entry
Related information
The PICTURE Clause
The GROUP INDICATE Clause
Standard Alignment Rules


Procedure Division

  • General Description
    The Procedure Division contains declarative procedures when the USE BEFORE REPORTING statement from the report writer module is present in a COBOL source program. Shown below is the general format of the Procedure Division when the USE BEFORE REPORTING statement is present.
  • The CLOSE Statement
    The CLOSE statement terminates the processing of reel/units and files with optional rewind and/or lock or removal where applicable.
  • The GENERATE Statement
    The GENERATE statement directs the RWCS to produce a report in accordance with the Report Description specified in the Report Section of the Data Division.
  • The INITIATE Statement
    The INITIATE statement causes the RWCS to begin the processing of a report.
  • The OPEN Statement (Report Writer)
    See the section The OPEN Statement.
  • The SUPPRESS Statement
    The SUPPRESS statement causes the RWCS to inhibit the presentation of a report group.
  • The TERMINATE Statement
    The TERMINATE statement causes the RWCS to complete the processing of the specified reports.
  • The USE BEFORE REPORTING Statement
    The USE BEFORE REPORTING statement specifies Procedure Division statements that are executed just before a report group named in the Report Section of the Data Division of this program, and optionally a contained program, is presented.
Parent topic: Report Writer


General Description

The Procedure Division contains declarative procedures when the USE BEFORE REPORTING statement from the report writer module is present in a COBOL source program. Shown below is the general format of the Procedure Division when the USE BEFORE REPORTING statement is present.

General Format:

Parent topic: Procedure Division


The CLOSE Statement

The CLOSE statement terminates the processing of reel/units and files with optional rewind and/or lock or removal where applicable.

General Format

Syntax Rules

  1. The files referenced in the CLOSE statement need not all have the same organization or access.

General Rules

Except where otherwise stated in the general rules below, the terms "reel" and "unit" are equivalent and completely interchangeable in the CLOSE statement. Treatment of sequential mass storage files is logically equivalent to the treatment of a file on tape or analogous sequential media. Treatment of a file contained in a multiple file tape environment is logically equivalent to the treatment of a sequential single-reel/unit file if the file is wholly contained on one reel.

  1. A CLOSE statement can only be executed for a file in an open mode.
  2. For the purpose of showing the effect of various types of CLOSE statements as applied to various storage media, all report files are divided into the following categories:
    1. Non-reel/unit. A file whose output medium is such that the concepts of rewind and reels/units have no meaning.
    2. Sequential single-reel/unit. A sequential file that is entirely contained on one reel/unit.
    3. Sequential multi-reel/unit. A sequential file that is contained on more than one reel/unit.
  3. The results of executing each type of CLOSE for each category of file are summarized in the table below.
    Table 1. Relationship of Categories of Files and the Formats of the CLOSE Statements
    CLOSE Statement Format | File Category
    Non-Reel/Unit | Sequential Single-Reel/Unit | Sequential Multi-Reel/Unit
    CLOSE | C | C,G | A,C,G
    CLOSE WITH LOCK | C,E | C,E,G | A,C,E,G
    CLOSE WITH NO REWIND | C,H | B,C | A,B,C
    CLOSE WITH REEL/UNIT | F | F,G | F,G
    CLOSE REEL/UNIT FOR REMOVAL | F | D,F,G | D,F,G

    The definitions of the symbols in the table are given below.

    • A. Effect on Previous Reels/Units for an Output Report File

      All reels/units in the report file prior to the current reel/unit are closed except those reels/units controlled by a prior CLOSE REEL/UNIT statement.

    • B. No Rewind of Current Reel

      The reel/unit is left in its current position.

    • C. Close Output Report File

      If label records are specified for the report file, the labels are processed according to the implementor's standard label convention. The behavior of the CLOSE statement when label records are specified but not present, or when records are not specified but are present, is undefined. Closing operations specified by the implementor are executed. If label records are not specified for the report file, label processing does not take place but other closing operations specified by the implementor are executed.

    • D. Reel/Unit Removal

      The current reel or unit is rewound, when applicable, and the reel or unit is logically removed from the run unit; however, the reel or unit can be accessed again, in its proper order of reels or units in the report file, if a CLOSE statement without the REEL or UNIT phrase is subsequently executed for this report file followed by the execution of an OPEN statement for the report file.

    • E. File Lock

      The report file is locked and cannot be opened again during this execution of this run unit.

    • F. Close Reel/Unit

      Output Report File (Reel/Unit Media):

      The following operations take place:

      1. The standard ending reel/unit label procedure is executed.
      2. A reel/unit swap. The current volume pointer is updated to point to the new reel/unit.
      3. The standard beginning reel/unit label procedure is executed.
      4. The next executed write operation that references that file directs the next logical data record to the next reel/unit of the file.

      Output Report File (Non-Reel/Unit Media):

      Execution of this statement is considered successful. The file remains in the open mode, and no action takes place except as specified in general rule 4.

    • G. Rewind

      The current reel or analogous device is positioned at its physical beginning.

    • H. Optional Phrases Ignored

      The CLOSE statement is executed as if none of the optional phrases is present.

  4. The execution of the CLOSE statement causes the value of the I/O status associated with file-name-1 to be updated.
  5. All reports associated with a report file that have been initiated must be ended with the execution of a TERMINATE statement before a CLOSE statement is executed for that report file.
  6. Following the successful execution of a CLOSE statement without the REEL or UNIT phrase, the report file is removed from the open mode, and the report file is no longer associated with the file connector.
  7. If more than one file-name-1 is specified in a CLOSE statement, the result of executing this CLOSE statement is the same as if a separate CLOSE statement had been written for each file-name-1 in the same order as specified in the CLOSE statement.
Parent topic: Procedure Division


The GENERATE Statement

The GENERATE statement directs the RWCS to produce a report in accordance with the Report Description specified in the Report Section of the Data Division.

General Format

Syntax Rules

  1. Data-name-1 must name a TYPE DETAIL report group and can be qualified by a report-name.
  2. Report-name-1 can be used only if the referenced report description contains:
    1. A CONTROL clause, and
    2. Not more than one DETAIL report group, and
    3. At least one body group.

General Rules

  1. In response to a GENERATE report-name-1 statement, the RWCS performs summary processing. If all of the GENERATE statements that are executed for a report are of the form GENERATE report-name-1, then the report that is produced is called a summary report.
  2. In response to a GENERATE data-name-1 statement, the RWCS performs detail processing that includes certain processing that is specific for the DETAIL report group designated by the GENERATE statement. Normally, the execution of a GENERATE data-name-1 statement causes the RWCS to present the designated DETAIL report group.
  3. During the execution of the chronologically first GENERATE statement for a given report, the RWCS saves the values in the control data items. During the execution of the second and subsequent GENERATE statements for the same report, and until a control break is detected, the RWCS utilizes this set of control values to determine whether a control break has occurred. When a control break occurs, the RWCS saves the new set of control values, which it thereafter uses to sense for a control break until another control break occurs.
  4. During the report presentation, an automatic function of the RWCS is to process PAGE HEADING and PAGE FOOTING report groups, if defined, when the RWCS must advance the report to a new page for the purpose of presenting a body group. (See the section Presentation Rules Tables)
  5. When the chronologically first GENERATE statement for a given report is executed, the RWCS processes, in order, the report groups that are named below, provided that such report groups are defined in the report description. The RWCS also processes PAGE HEADING and PAGE FOOTING report groups as described in General Rule 4. The actions taken by the RWCS when it processes each type of report group are explained under the appropriate paragraph. (See the section The TYPE Clause.)
    1. The REPORT HEADING report group is processed.
    2. The PAGE HEADING report group is processed.
    3. All CONTROL HEADING report groups are processed from major to minor.
    4. If a GENERATE data-name-1 statement is being executed, the processing for the designated DETAIL report group is performed. If a GENERATE report-name-1 statement is being executed, certain of the steps that are involved in the processing of a DETAIL report group are performed. (See the section The TYPE Clause.)
  6. When a GENERATE statement other than the chronologically first is executed for a given report, the RWCS performs the steps enumerated below, as applicable. The RWCS also processes PAGE HEADING and PAGE FOOTING report groups as described in General Rule 4. The actions taken by the RWCS when it processes each type of report group are explained under the appropriate paragraph. (See the section The TYPE Clause.)
    1. Sense for control break. The rules for determining the equality of control data items are the same as those specified for relation conditions. If a control break has occurred then:
      1. Enable the CONTROL FOOTING USE procedures and CONTROL FOOTING SOURCE clauses to access the control data item values that the RWCS used to detect a given control break. (See the section The TYPE Clause.)
      2. Process the CONTROL FOOTING report groups in the order minor to major. Only CONTROL FOOTING report groups that are not more major than the highest level at which a control break occurred are processed.
      3. Process the CONTROL HEADING report groups in the order major to minor. Only the CONTROL HEADING report groups that are not more major than the highest level at which a control break occurred are processed.
    2. If a GENERATE data-name-1 statement is being executed, the processing for the designated DETAIL report group is performed. If a GENERATE report-name-1 statement is being executed, certain of the steps that are involved in the processing of a DETAIL report group are performed. (See the section The TYPE Clause.)
  7. GENERATE statements for a report can be executed only after an INITIATE statement for the report has been executed and before a TERMINATE statement for the report has been executed.
Parent topic: Procedure Division
Related information
Presentation Rules Tables
The TYPE Clause


The INITIATE Statement

The INITIATE statement causes the RWCS to begin the processing of a report.

General Format

Syntax Rules

  1. Report-name-1 must be defined by a report description entry in the report section of the Data Division.

General Rules

  1. The INITIATE statement performs the following initialization functions for each named report:
    1. All sum counters are set to zero.
    2. LINE-COUNTER is set to zero.
    3. PAGE-COUNTER is set to one.
  2. The INITIATE statement does not place the file associated with the report in the open mode; therefore, an OPEN statement with either the OUTPUT phrase or the EXTEND phrase for the file must be executed prior to the execution of the INITIATE statement.
  3. A subsequent INITIATE statement for report-name-1 must not be executed unless an intervening TERMINATE statement has been executed for report-name-1.
  4. If more than one report-name is specified in an INITIATE statement, the result of executing this INITIATE statement is the same as if a separate INITIATE statement had been written for each report-name in the same order as specified in the INITIATE statement.
Parent topic: Procedure Division


The OPEN Statement (Report Writer)

See the section The OPEN Statement.

Additional Syntax Rules:

  1. A report file must have sequential organization.
  2. The OPEN statement for a report file must contain only the OUTPUT phrase or the EXTEND phrase.

Additional General Rules:

  1. The OPEN statement for a report file must be executed prior to the execution of an INITIATE statement for any reports contained in the file.
Parent topic: Procedure Division
Related information
The OPEN Statement


The SUPPRESS Statement

The SUPPRESS statement causes the RWCS to inhibit the presentation of a report group.

General Format

Syntax Rules

  1. The SUPPRESS statement can only appear in a USE BEFORE REPORTING procedure.

General Rules

  1. The SUPPRESS statement inhibits presentation only for the report group named in the USE procedure in which the SUPPRESS statement appears.
  2. The SUPPRESS statement must be executed each time the presentation of the report group is to be inhibited.
  3. When the SUPPRESS statement is executed, the RWCS is instructed to inhibit the processing of the following report group functions:
    1. The presentation of the print lines of the report group.
    2. The processing of all LINE clauses in the report group.
    3. The processing of the NEXT GROUP clause in the report group.
    4. The adjustment of LINE-COUNTER.
  4. OSVS The SUPPRESS PRINTING function can also be achieved by moving the value 1 to the special register PRINT- SWITCH.

    The statement

         MOVE 1 TO PRINT-SWITCH

    has exactly the same effect as the statement

         SUPPRESS PRINTING
Parent topic: Procedure Division


The TERMINATE Statement

The TERMINATE statement causes the RWCS to complete the processing of the specified reports.

General Format

Syntax Rules

  1. Report-name-1 must be defined by a report description entry in the Report Section of the Data Division.

General Rules

  1. The TERMINATE statement causes the RWCS to produce all the CONTROL FOOTING report groups beginning with the minor CONTROL FOOTING report group. Then the REPORT FOOTING report group is produced. The RWCS makes the prior set of control data item values available to the CONTROL FOOTING and REPORT FOOTING SOURCE clauses and USE procedures, as though a control break has been sensed in the most major control data-name.
  2. If no GENERATE statements have been executed for a report during the interval between the execution of an INITIATE statement and a TERMINATE statement, for that report, the TERMINATE statement does not cause the RWCS to produce any report groups or perform any of the related processing.
  3. During report presentation, an automatic function of the RWCS is to process PAGE HEADING and PAGE FOOTING report groups, if defined, when the RWCS must advance the report to a new page for the purpose of presenting a body group. (See the section Presentation Rules Tables.)
  4. The TERMINATE statement cannot be executed for a report unless the TERMINATE statement was chronologically preceded by an INITIATE statement for that report and for which no TERMINATE statement has yet been executed.
  5. If more than one report-name is specified in a TERMINATE statement, the result of executing this TERMINATE statement is the same as if a separate TERMINATE statement had been written for each report-name in the same order as specified in the TERMINATE statement.
  6. The TERMINATE statement does not close the file with which the report is associated; a CLOSE statement for the file must be executed. Every report that is in an initiated condition must be terminated before a CLOSE statement is executed for the associated file.
Parent topic: Procedure Division
Related information
Presentation Rules Tables


The USE BEFORE REPORTING Statement

The USE BEFORE REPORTING statement specifies Procedure Division statements that are executed just before a report group named in the Report Section of the Data Division of this program, and optionally a contained program, is presented.

General Format

Syntax Rules

  1. A USE BEFORE REPORTING statement, when present, must immediately follow a section header in the declaratives portion of the Procedure Division and must appear in a sentence by itself. The remainder of the section must consist of zero, one, or more procedural paragraphs that define the procedures to be used.
  2. Identifier-1 must reference a report group. The same identifier-1 must not appear in more than one USE BEFORE REPORTING statement in the same Procedure Division.
  3. The GENERATE, INITIATE, or TERMINATE statements must not appear in a paragraph in a USE BEFORE REPORTING procedure. A PERFORM statement in a USE BEFORE REPORTING procedure must not have GENERATE, INITIATE, or TERMINATE statements in its range.
  4. A USE BEFORE REPORTING procedure must not alter the value of any control data item.
  5. The USE BEFORE REPORTING statement itself is never executed; it merely defines the conditions calling for the execution of the USE procedures.

General Rules

  1. A declarative procedure is invoked just before the named report group is produced during the execution of the program. The report group is named by identifier-1 in the USE BEFORE REPORTING statement which prefaces the declarative.
  2. Within a declarative procedure, there must be no reference to any nondeclarative procedures.
  3. Procedure-names associated with a USE BEFORE REPORTING statement can be referenced in a different declarative section or in a nondeclarative procedure only with a PERFORM statement.
  4. In the USE BEFORE REPORTING statement, the designated procedures are executed by the RWCS just before the named report group is produced. (See the section The TYPE Clause.)
  5. Within a USE procedure, there must not be the execution of any statement that would cause the execution of a USE procedure that had previously been invoked and had not yet returned control to the invoking routine.
  6. Special precedence rules are followed when programs are contained within other programs. In applying these rules, only the first qualifying directive will be selected for execution. The declarative which is selected for execution must satisfy the rules for execution of that declarative. The order of precedence for selecting a declarative is:
    1. The declarative within the program that contains the statement which caused the qualifying condition.
    2. The declarative in which the GLOBAL phrase is specified and which is within the program directly containing the program which was last examined for a qualifying declarative.
    3. Any declarative selected by applying rule 6b to each more inclusive containing program until rule 6b is applied to the outermost program. If no qualifying directive is found, none is executed.
Parent topic: Procedure Division
Related information
The TYPE Clause


Debug Module

Debugging provides a means by which the user can describe the conditions under which procedures are to be monitored during the execution of the object program.

ANS85 The ANSI Debug Module is classed as an obsolete element in the ANSI'85 standard and is scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects in this COBOL implementation fully support this syntax. The FLAGSTD directive can be used to detect all occurrences of this syntax.

XOPEN Although it is a part of the standard COBOL definition, this module is explicitly excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

  • Standard ANSI COBOL Debug
  • Object-time Switch
  • COBOL Debug RTS Switch
  • Debugging Lines
  • Environment Division
  • Procedure Division
Parent topic: Part 3. Additional Topics


Standard ANSI COBOL Debug

The decisions of what to monitor and what information to display are explicitly in the domain of the user. The COBOL debug facility simply provides a convenient access to pertinent information.

The features of the language that support the COBOL debug module are:

  • a WITH DEBUGGING MODE Switch – used at object code creation time
  • an RTS switch
  • a USE FOR DEBUGGING statement
  • a special register – DEBUG-ITEM
  • debugging lines.

The reserved word DEBUG-ITEM is the name for a special register generated automatically by your COBOL system that supports the debugging facility. Only one DEBUG-ITEM is allocated per program. The names of the subordinate data items in DEBUG-ITEM are also reserved words.

Parent topic: Debug Module


Object-time Switch

The DEBUGGING MODE clause is written as part of the SOURCE-COMPUTER paragraph in the Environment Division. It serves as an object-time switch over debugging statements written in the program.

When the WITH DEBUGGING MODE clause is specified in a program, all debugging sections and all debugging lines are handled as specified in this section of the document.

When the DEBUGGING MODE clause is not specified in a program, all the debugging sections and debugging lines are treated as if they were comment lines and their syntax is not checked.

Parent topic: Debug Module


COBOL Debug RTS Switch

An RTS switch dynamically activates the debugging code inserted by your COBOL system. This switch cannot be addressed in the program; it is controlled outside the COBOL environment. If the switch is on, the effects of any USE FOR DEBUGGING statements written in the source program are permitted. If the switch is off, all the effects described in the USE FOR DEBUGGING statement are inhibited. Re-creation of the object code is not required to provide or take away this facility.

The object time switch has no effect on the execution of the object program if the WITH DEBUGGING MODE clause was not specified in the source program.

Parent topic: Debug Module


Debugging Lines

A debugging line is any line with a "D" or "d" in the indicator area of the line. Any debugging line that consists solely of spaces from margin A to margin R is considered the same as a blank line.

The contents of a debugging line must be such that a syntactically correct program is formed with or without the debugging lines being considered as comment lines.

A debugging line will be considered to have all the characteristics of a comment line, if the WITH DEBUGGING MODE clause is not specified in the SOURCE-COMPUTER paragraph.

Successive debugging lines are allowed. Continuation of debugging lines is permitted, except that each continuation line must contain a "D" or "d" in the indicator area, and character-strings can not be broken across two lines.

A debugging line is permitted in the program only after theOBJECT-COMPUTER paragraph .

Note: Debugging lines are part of the ANSI Nucleus and not the ANSI Debug module. Therefore, they are not obsolete and are not scheduled to be deleted from the next full revision of the ANSI Standard.
Parent topic: Debug Module


Environment Division

  • The WITH DEBUGGING MODE Clause
    The WITH DEBUGGING MODE clause indicates that all debugging sections and all debugging lines are to be included in the object code. If this clause is not specified, all debugging lines and sections are treated as if they were comment lines.
Parent topic: Debug Module


The WITH DEBUGGING MODE Clause

The WITH DEBUGGING MODE clause indicates that all debugging sections and all debugging lines are to be included in the object code. If this clause is not specified, all debugging lines and sections are treated as if they were comment lines.

The WITH DEBUGGING MODE clause is not an obsolete feature in ANSI'85 as it can also be used in the Nucleus.

General Format

General Rules

Note: The WITH DEBUGGING MODE clause is part of the ANSI Nucleus as well as the ANSI Debug module. It is not obsolete and is not scheduled to be deleted from the next full revision of the ANSI Standard.
  1. If the WITH DEBUGGING MODE clause is specified in the SOURCE-COMPUTER paragraph of the Configuration Section of a program, all USE FOR DEBUGGING statements and all debugging lines are included in the object code.
  2. If the WITH DEBUGGING MODE clause is not specified in the SOURCE-COMPUTER paragraph of the Configuration Section of a program, any USE FOR DEBUGGING statements and all associated debugging sections, and any debugging lines are treated as if they were comment statements.
Parent topic: Environment Division


Procedure Division

  • The READY TRACE Statement
  • The RESET TRACE Statement
    The RESET TRACE statement disables the tracing of section and paragraph names on the screen.
  • The USE FOR DEBUGGING Statement
    The USE FOR DEBUGGING statement identifies the user items that are to be monitored by the associated debugging section.
Parent topic: Debug Module


The READY TRACE Statement

General Format

General Rules

  1. The COBOL Compiler directive TRACE must be set to on to allow execution of the statement. When the directive is not set, READY TRACE is documentary only.
  2. VSC2 READY TRACE is accepted, but is treated as documentary only.

Comments:

The READY TRACE statement is a debugging feature which causes each section and paragraph name subsequently reached to appear on the screen in order of execution.

Parent topic: Procedure Division


The RESET TRACE Statement

The RESET TRACE statement disables the tracing of section and paragraph names on the screen.

General Format

General Rules

  1. The COBOL Compiler directive TRACE must be set to on to allow execution of the statement. When the directive is not set or when no previous READY TRACE is in effect, RESET TRACE is documentary only.
  2. VSC2 RESET TRACE is accepted, but is treated as documentary only.
Parent topic: Procedure Division


The USE FOR DEBUGGING Statement

The USE FOR DEBUGGING statement identifies the user items that are to be monitored by the associated debugging section.

General Format

RTS switches

  1. The following RTS switch may impact either the syntax or semantics described in this section.
    • D – Activates ANSI Debug facilities

Syntax Rules

  1. Debugging section(s), if specified, must appear together immediately after the DECLARATIVES header.
  2. Except in the USE FOR DEBUGGING statement itself, there must be no reference to any non-declarative procedure in the debugging section.

    OSVS VSC2 MF This restriction is not enforced.

  3. Statements appearing outside of the set of debugging sections must not reference procedure-names defined in the set of debugging sections.
  4. Except for the USE FOR DEBUGGING statement itself, statements appearing in a given debugging section can reference procedure-names defined in a different USE procedure only with a PERFORM statement.
  5. Procedure-names defined in debugging sections must not appear in USE FOR DEBUGGING statements.
  6. Any given identifier, file-name, or procedure-name can appear in only one USE FOR DEBUGGING statement and can appear only once in that statement.
  7. The ALL PROCEDURES phrase can appear only once in a program.
  8. When the ALL PROCEDURES phrase is specified, procedure-name-1 must not be specified in any USE FOR DEBUGGING statement.
  9. If the data description entry of the data item referenced by identifier-1 contains an OCCURS clause or is subordinate to a data description entry that contains an OCCURS clause, identifier-1 must be specified without the subscripting or indexing normally required.
  10. References to the special register DEBUG-ITEM are restricted to references from within a debugging section.

General Rules

  1. Automatic execution of a debugging section is not caused by a statement appearing in a debugging section.
  2. When file-name-1 is specified in a USE FOR DEBUGGING statement , that debugging section is executed:
    1. After the execution of any OPEN or CLOSE statement that references file-name-1, and:
    2. After the execution of any READ statement (after any other specified USE procedure) not resulting in the execution of an associated AT END or INVALID KEY imperative statement, and:
    3. After the execution of any DELETE or START statement that references file-name-1.
  3. When procedure-name-1 is specified in a USE FOR DEBUGGING statement that debugging section is executed:
    1. Immediately before each execution of the named procedure.
    2. Immediately after the execution of an ALTER statement which references procedure-name-1.
  4. The ALL PROCEDURES phrase causes the effects described in General Rule 3 to occur for every procedure-name in the program, except those appearing in a debugging section.
  5. When the phrase, ALL REFERENCES OF identifier , is specified, that debugging section is executed for every statement that explicitly references identifier-1 at each of the following times:
    1. In the case of a WRITE or REWRITE statement immediately before the execution of that WRITE or REWRITE statement and after the execution of any implicit move resulting from the presence of the FROM phrase.
    2. In the case of a GO TO statement with a DEPENDING ON phrase, immediately before control is transferred and prior to the execution of any debugging section associated with the procedure-name to which control is to be transferred.
    3. In the case of a PERFORM statement in which a VARYING, AFTER, or UNTIL phrase references identifier-1, immediately after each initialization, modification or evaluation of the contents of the data item referenced by identifier-1.
    4. In the case of any other COBOL statement, immediately after execution of that statement.

    If identifier-1 is specified in a phrase that is not executed or evaluated, the associated debugging section is not executed.

  6. When identifier-1 is specified without the ALL REFERENCES OF phrase , that debugging section is executed at each of the following times:
    1. In the case of a WRITE or REWRITE statement that explicitly references identifier-1, immediately before the execution of that WRITE or REWRITE statement and after the execution of any implicit move resulting from the presence of the FROM phrase.
    2. In the case of a PERFORM statement in which a VARYING, AFTER or UNTIL phrase references identifier-1, immediately after each initialization, modification or evaluation of the contents of the data item referenced by identifier-1.
    3. Immediately after the execution of any other COBOL statement that explicitly references and causes the contents of the data item referenced by identifier-1 to be changed.

    If identifier-1 is specified in a phrase that is not executed or evaluated, the associated debugging section is not executed.

  7. The associated debugging section is not executed for a specific operand more than once as a result of the execution of a single statement, regardless of the number of times that operand is explicitly specified. In the case of a PERFORM statement which caused iterative execution of a referenced procedure, the associated debugging section is executed once for each iteration.

    Within an imperative statement, each individual occurrence of an imperative verb identifies a separate statement for the purpose of debugging.

  8. A reference to file-name-1, identifier-1, or procedure-name-1 as a qualifier does not constitute reference to that item for the debugging described in the General Rules above.
  9. Associated with each execution of a debugging section is the special register DEBUG-ITEM , which provides information about the conditions that caused the execution of a debugging section . DEBUG-ITEM has the following implicit description:
     01 debug-item.
     02 debug-line      pic x(6).
     02 filler          pic x value space.
     02 debug-name      pic x(30).
     02 filler          pic x value space.
     02 debug-sub-1     pic s9999 sign is leading separate character.
     02 filler          pic x value space
     02 debug-sub-2     pic s9999 sign is leading separate character.
     02 filler          pic x value space.
     02 debug-sub-3     pic s9999 sign is leading separate character.
     02 filler          pic x value space.
     02 debug-contents  pic x(n).
  10. Prior to each execution of a debugging section, the contents of the data item referenced by DEBUG-ITEM are space-filled. The contents of data items subordinate to DEBUG-ITEM are then updated, according to the following general rules, immediately before control is passed to that debugging section. The contents of any data item not specified in the following general rules remains spaces.

    Updating is accomplished in accordance with the rules for the MOVE statement, the sole exception being the move to DEBUG-CONTENTS when the move is treated exactly as if it was an alphanumeric to alphanumeric elementary move with no conversion of data from one form of internal representation to another.

  11. The contents of DEBUG-LINE is the relevant COBOL source line number. This provides the means of identifying a particular source statement.
  12. DEBUG-NAME contains the first 30 characters of the name that caused the debugging section to be executed.

    All qualifiers of the name are separated in DEBUG-NAME by the word IN or OF.

    Subscripts/indices, if any, are not entered into DEBUG-NAME.

  13. If the reference to a data item that causes the debugging section to be executed is subscripted or indexed, the occurrence number of each level is entered in DEBUG-SUB-1, DEBUG-SUB-2, DEBUG-SUB-3, respectively, as necessary.
  14. DEBUG-CONTENTS is a data item that is large enough to contain the data required by the following General Rules.
  15. If the first execution of the first nondeclarative procedure in the program causes the debugging section to be executed, the following conditions exist:
    1. DEBUG-LINE identifies the first statement of that procedure.
    2. DEBUG-NAME contains the name of that procedure.
    3. DEBUG-CONTENTS contains "START PROGRAM".
  16. If a reference to procedure-name-1 in an ALTER statement causes the debugging section to be executed, the following conditions exist:
    1. DEBUG-LINE identifies the ALTER statement that references procedure-name-1.
    2. DEBUG-NAME contains procedure-name-1.
    3. DEBUG-CONTENTS contains the applicable procedure-name associated with the TO phrase of the ALTER statement.
  17. If the transfer of control associated with the execution of a GO TO statement causes the debugging section to be executed, the following conditions exist:
    1. DEBUG-LINE identifies the GO TO statement whose execution transfers control to procedure-name-1.
    2. DEBUG-NAME contains procedure-name-1.
  18. If reference to procedure-name-1 in the INPUT or OUTPUT phrase of a SORT or MERGE statement causes the debugging section to be executed, the following conditions exist:
    1. DEBUG-LINE identifies the SORT or MERGE statement that references procedure-name-1.
    2. DEBUG-NAME contains procedure-name-1.
    3. DEBUG-CONTENTS contains:
      1. If the reference to procedure-name-1 is the INPUT phrase of a SORT statement, "SORT INPUT".
      2. If the reference to procedure-name-1 is in the OUTPUT phrase of a SORT statement, "SORT OUTPUT".
      3. If the reference to procedure-name-1 is in the OUTPUT phrase of a MERGE statement, "MERGE OUTPUT".
  19. If the transfer to control from the control mechanism associated with a PERFORM statement causes the debugging section associated with procedure-name-1 to be executed, the following conditions exist:
    1. DEBUG-LINE identifies the PERFORM statement that references procedure-name-1.
    2. DEBUG-NAME contains procedure-name-1.
    3. DEBUG-CONTENTS contains "PERFORM LOOP".
  20. If procedure-name-1 is a USE procedure that is to be executed, the following conditions exist:
    1. DEBUG-LINE identifies the statement that causes execution of the USE procedure.
    2. DEBUG-NAME contains procedure-name-1.
    3. DEBUG-CONTENTS contains "USE PROCEDURE".
  21. If an implicit transfer of control from the previous sequential paragraph to procedure-name-1 causes the debugging section to be executed, the following conditions exist:
    1. DEBUG-LINE identifies the previous statement.
    2. DEBUG-NAME contains procedure-name-1.
    3. DEBUG-CONTENTS contains "FALL THROUGH".
  22. If references to file-name-1 cause the debugging section to be executed, then:
    1. DEBUG-LINE identifies the source statement that references file-name-1 .
    2. DEBUG-NAME contains the name of file-name-1 .
    3. For READ, DEBUG-CONTENTS contains the entire record read.
    4. For all other references to file-name-1, DEBUG-CONTENTS contains spaces.
  23. If a reference to identifier-1 causes the debugging section to be executed, then:
    1. DEBUG-LINE identifies the source statement that references identifier-1,
    2. DEBUG-NAME contains the name of identifier-1, and:
    3. DEBUG-CONTENTS contains the contents of the data item referenced by identifier-1 at the time that control passes to the debugging section (see General Rules 5 and 6).
Parent topic: Procedure Division


Segmentation

The segmentation module provides a capability to specify object program overlay requirements.

Segmentation provides a facility for specifying permanent and independent segments. Segmentation also allows the intermixing of sections with different segment-numbers and allows the fixed portion of the source program to contain segments that can be overlaid.

ANS85 The Segmentation module is classed as an obsolete element in the ANSI'85 standard and is scheduled to be deleted from the next full revision of the ANSI Standard.

MF All dialects in this COBOL implementation fully support this syntax. The FLAGSTD directive can be used to detect all occurrences of this syntax.

XOPEN Although it is a part of the standard COBOL definition, this module is explicity excluded from the X/Open COBOL language definitions and should not be used in a conforming X/Open COBOL source program.

  • General Description of Segmentation
  • Organization
  • Segmentation Classification
  • Segmentation Control
  • Structure of Program Segments
  • Restrictions on Program Flow
  • The ALTER Statement
  • The PERFORM Statement
  • The MERGE Statement
  • The SORT Statement
Parent topic: Part 3. Additional Topics
Related reference
Program Identification and Data Names


General Description of Segmentation

COBOL segmentation is a facility that provides a means by which the user can communicate with your COBOL system to specify object program overlay requirements.

COBOL segmentation deals only with segmentation of procedures. As such, only the Procedure Division is considered in determining segmentation requirements for an object program.

Parent topic: Segmentation


Organization

  • Program Segments
  • Fixed Portion
  • Independent Segments
Parent topic: Segmentation


Program Segments

Although it is not mandatory, the Procedure Division for a source program is often written as a consecutive group of sections, each of which is composed of a series of closely related operations that are designed to collectively perform a particular function. However, when segmentation is used, the entire Procedure Division must be in sections. In addition, each section must be classified as belonging either to the fixed portion or to one of the independent segments of the object program. Segmentation in no way affects the need for qualification of procedure-names to ensure uniqueness.

Parent topic: Organization


Fixed Portion

The fixed portion is defined as that part of the object program which is logically treated as if it were always in memory. This portion of the program is composed of fixed permanent segments, and fixed overlayable segments.

A fixed permanent segment is a segment in the fixed portion which cannot be overlaid by any other part of the program.

A fixed overlayable segment is a segment in the fixed portion which, although logically treated as if it were always in memory, can be overlaid by another segment to optimize memory utilization.

Parent topic: Organization


Independent Segments

An independent segment is defined as part of the object program which can overlay, and can be overlaid by either a fixed overlayable segment or another independent segment. An independent segment is in its initial state whenever control is transferred (either implicitly or explicitly) to that segment for the first time during the execution of a program. On subsequent transfers of control to the segment, an independent segment is also in its initial state when:

  • control is transferred to that segment as a result of the implicit transfer of control between consecutive statements from a segment with a different segment-number
  • control is transferred to that segment as the result of the implicit transfer of control between a SORT or MERGE statement, in a segment with a different segment-number, and an associated input or output procedure in that independent segment
  • control is transferred explicitly to that segment from a segment with a different segment-number (with the exception noted in paragraph 2 below).

On subsequent transfer of control to the segment, an independent segment is in its last-used state when:

  • control is transferred implicitly to that segment from a segment with a different segment-number (except as noted in paragraph 1).
  • control is transferred explicitly to that segment as the result of the execution of an EXIT PROGRAM

    OSVS VSC2 MF or GOBACK

    statement.

Parent topic: Organization


Segmentation Classification

Sections which are to be segmented are classified, using a system of segment-numbers and the following criteria:

  • Logic Requirements.

    Sections which must be available for reference at all times, or which are referred to very frequently, are normally classified as belonging either to one of the overlayable fixed segments or to one of the permanent segments; sections which are used less frequently are normally classified as belonging to one of the independent segments, depending on logic requirements.

  • Frequency of Use.

    Generally, the more frequently a section is referred to, the lower its segment-number; the less frequently it is referred to, the higher its segment-number.

  • Relationship to Other Sections.

    Sections which frequently communicate with one another should be given the same segment-numbers.

Parent topic: Segmentation


Segmentation Control

The logical sequence of the program is the same as the physical sequence except for specific transfers of control. Control can be transferred in a source program to any paragraph in a section; that is, it is not mandatory to transfer control to the beginning of a section.

Parent topic: Segmentation


Structure of Program Segments

  • Segment-Numbers
    Section classification is accomplished by means of a system of segment-numbers. The segment-number is included in the section header.
  • The SEGMENT-LIMIT Clause
Parent topic: Segmentation


Segment-Numbers

Section classification is accomplished by means of a system of segment-numbers. The segment-number is included in the section header.

General Format

Syntax Rules

  1. The segment-number must be an integer ranging in value from 0 through 99.
  2. If the segment-number is omitted from the section header, the segment-number is assumed to be 0.
  3. Sections in the declaratives must contain segment-numbers less than 50.
  4. OSVS VSC2 The segment-number must be a signed integer, but must not be a floating-point literal.

General Rules

  1. All sections which have the same segment-number constitute a program segment. All sections which have the same segment-number need not be physically contiguous in the source program.
  2. Segments with segment-number 0 through 49 belong to the fixed portion of the object program.
  3. Segments with segment-number 50 through 99 are independent segments.
Parent topic: Structure of Program Segments


The SEGMENT-LIMIT Clause

General Format

The SEGMENT-LIMIT clause appears in the OBJECT-COMPUTER paragraph and has the following format:

The SEGMENT-LIMIT clause appears in the OBJECT-COMPUTER paragraph and has the following format:

Syntax Rules

  1. Segment-number must be an integer ranging in value from 1 thru 49.

General Rules

  1. MF The SEGMENT-LIMIT clause is treated as documentary.
Parent topic: Structure of Program Segments


Restrictions on Program Flow

When segmentation is used, the following restrictions are placed on the ALTER, PERFORM, MERGE and SORT statements.

Parent topic: Segmentation


The ALTER Statement

A GO TO statement in a section whose segment-number is greater than or equal to 50 must not be referred to by an ALTER statement in a section with a different segment-number.

All other uses of the ALTER statement are valid and performed even if the GO TO to which the ALTER refers is in a fixed overlayable segment.

Parent topic: Segmentation


The PERFORM Statement

A PERFORM statement that appears in a section that is not in an independent segment can have within its range, in addition to any declarative sections whose execution is caused within that range, only one of the following:

  • Sections and/or paragraphs wholly contained in one or more non-independent segments.
  • Sections and/or paragraphs wholly contained in a single independent segment.

A PERFORM statement that appears in an independent segment can have within its range, in addition to any declarative sections whose execution is caused within that range, only one of the following:

  • Sections and/or paragraphs wholly contained in one or more non-independent segments.
  • Sections and/or paragraphs wholly contained in the same independent segment as that PERFORM statement.
Parent topic: Segmentation


The MERGE Statement

If the MERGE statement appears in a section that is not in an independent segment, then any output procedure referenced by that MERGE statement must appear:

  • totally within non-independent segments, or
  • wholly contained in a single independent segment.

If a MERGE statement appears in an independent segment, then any output procedure referenced by that MERGE statement must be contained:

  • totally within non-independent segments, or
  • wholly within the same independent segment as that MERGE statement.
Parent topic: Segmentation


The SORT Statement

If a SORT statement appears in a section that is not an independent segment, then any input procedures or output procedures referenced by that SORT statement must appear:

  • totally within non-independent segments, or
  • wholly contained in a single independent segment.

If a SORT statement appears in an independent segment, then any input procedures or output procedures referenced by that SORT statement must be contained:

  • totally within non-independent segments, or
  • wholly within the same independent segment as that SORT statement.

SORT procedures should not be invoked by multiple threads simultaneously.

Parent topic: Segmentation


Double-Byte Character Set Support

Many of the world's languages use sets of characters that run into the thousands. Most computers use 8-bit bytes, and assign a different 8-bit code to represent each character; this scheme can represent no more than 256 different characters.

Ideally a COBOL programmer should not need to be aware of the internal code used to represent characters. However, in practice some features of the internal code can affect the source programmer, and this limitation to 256 different characters is one of the most restricting of these.

For this reason the Double-Byte Character Set (DBCS) is provided. In this scheme each character is represented by a 16-bit code, each character occupying a pair of adjacent bytes. This scheme can represent thousands of different characters.

The assignment of DBCS character codes to characters varies from country to country.

The 8-bit code used by your COBOL system is the American Standard Code for Information Interchange (ASCII). In this chapter this will be referred to as the Single-Byte Character Set (SBCS).

MF Double-Byte Character set support is sensitive to the DBCS Compiler directive.

See also the chapter Micro Focus Extensions for Double-Byte Character Support, primarily for Japanese language support.

  • DBCS Data
  • Roman Script in DBCS
  • Multivendor Integration Architecture Support
  • Source Programs
  • Language Extensions
  • Comments and Comment-entries
  • User-defined Words
  • Spaces
  • Data Items
  • Literals
  • Program Structure
  • Identification Division
  • Environment Division
  • Data Division
  • Procedure Division
Parent topic: Part 3. Additional Topics
Related information
Micro Focus Extensions for Double-Byte Character Support


DBCS Data

The DBCS Compiler directive makes your COBOL compiler recognize two data categories in which data is stored in DBCS. It does not prevent the use of other data categories; thus you can still use those data categories in which data is stored in SBCS.

Provided you have the necessary hardware support, DBCS data items used in input and output will be recognized and their data displayed and accepted correctly on such devices as screens, keyboard, printers, et cetera.

Parent topic: Double-Byte Character Set Support


Roman Script in DBCS

The character set that can be represented by SBCS is based on the Roman alphabet plus some other characters. In some countries the DBCS character codes also include codes for many of these characters.

On some hardware the character displayed is visibly different according to whether the character is stored in SBCS or DBCS; for example on some screens the DBCS code for a letter causes it to be printed larger than does its SBCS code.

Parent topic: Double-Byte Character Set Support


Multivendor Integration Architecture Support

Programs written to the NTT Multivendor Integration Architecture (MIA) Support are accepted by the COBOL compiler, using the DBCS and CURRENCY-SIGN"92" directives.

Parent topic: Double-Byte Character Set Support


Source Programs

DBCS characters can be used in literals, in comments and comment-entries, and in user-defined words. Otherwise the NCHAR or JAPANESE directives do not change the range of characters that can be used in source programs - the program is still written using the COBOL character set (see the chapter Concepts of the COBOL Language).

Parent topic: Double-Byte Character Set Support
Related information
Concepts of the COBOL Language


Language Extensions

There are extensions to the PICTURE and USAGE clauses to define items that are to contain DBCS data. A new format of literal is required for DBCS data.

There are additional rules for various options, clauses and statements to define the behavior of DBCS data.

Except where otherwise stated, all the rules and features of COBOL remain applicable when DBCS is in use. The following sections give only the additional rules and formats pertaining to DBCS.

Parent topic: Double-Byte Character Set Support


Comments and Comment-entries

SBCS and DBCS characters can be mixed freely in comments and comment-entries.

Parent topic: Double-Byte Character Set Support


User-defined Words

Either SBCS or DBCS characters can be used in user-defined words for: Alphabet-name, Class-name, Condition-name, Data-name/Identifier, Record-name, File-name, Index-name, Mnemonic-name, Paragraph-name, Section-name, and Symbolic-character.

MF SBCS and DBCS characters can be freely mixed in user-defined words. Where a character exists in both the DBCS and SBCS character sets, its DBCS and SBCS representations will not be regarded as equivalent. See the section Roman Script in DBCS.

Parent topic: Double-Byte Character Set Support
Related information
Roman Script in DBCS


Spaces

Spaces in data of class DBCS will be represented by the DBCS code for space. A space character represented by a 2-byte code is referred to as a DBCS space.

MF The values assigned to a DBCS space are sensitive to the DBCS and DBSPACE Compiler directives.

Parent topic: Double-Byte Character Set Support


Data Items

  • DBCS Data Items
  • Mixed Data Items
Parent topic: Double-Byte Character Set Support


DBCS Data Items

There is a class of data additional to the classes described in the section Class and Category of Data: it is called DBCS. It includes two data categories: DBCS and DBCS edited.

A data item of class DBCS is described by using the USAGE DISPLAY-1 clause. An item with this clause can have only the characters "G" and "B" in its PICTURE character-string. A " G" represents a DBCS character position; "B" is an editing character, and indicates a position that will always have a DBCS space inserted in editing. An item whose PICTURE character-string is all "G"s is of category DBCS; an item whose PICTURE character-string contains both "G" s and "B"s is of category DBCS edited.

Note that each "G" or "B" represents one 2-byte character position. Except where otherwise stated, the length of the data item for all purposes is the number of "G" s and "B"s in its PICTURE character-string.

For reference modification, the leftmost-character-position and length specify the number of DBCS characters, not bytes.

Data items of class DBCS can be used wherever data items of class alphanumeric can be used, subject to rules and exceptions given in the appropriate places in this chapter.

Parent topic: Data Items
Related information
Class and Category of Data


Mixed Data Items

DBCS characters can be included in data stored in data items of category alphanumeric. In such data, SBCS characters are represented by SBCS codes and DBCS characters by DBCS codes. Each space character is represented by the SBCS code for space.

On input and output both the SBCS and the DBCS codes will be recognized. The first byte of a DBCS code is never a valid SBCS code; hence the two can be used together without confusion. But in operations within the program the data will be treated as ordinary alphanumeric data. It is the programmer's responsibility to ensure that the two halves of a DBCS code do not get separated.

The length of the data item for all purposes is its length in bytes.

Parent topic: Data Items


Literals

  • DBCS Literals
  • Mixed Literals
  • Figurative Constants
  • The "N" literal
Parent topic: Double-Byte Character Set Support


DBCS Literals

There is a fourth type of literal in addition to the nonnumeric, numeric and national literals described in the section Literals, the DBCS literal.

A DBCS literal is a character-string delimited at both ends by quotation marks or apostrophes, with the beginning delimiter preceded by a "G". It can consist of any characters in the computer's DBCS character set. It can be up to 28 DBCS characters in length. It cannot be continued across lines.

Whether quotation marks or apostrophes are used, the presence of that delimiter within a DBCS literal can be represented by two contiguous occurrences. The presence of the character that is not serving as the delimiter is represented by a single occurrence. The value of a DBCS literal in the object program is the string of characters itself, except:

  1. The initial G and the delimiters are excluded, and
  2. Each embedded pair of contiguous delimiter characters represents a single character.
  • Category of DBCS Literals
Parent topic: Literals
Related information
Literals


Category of DBCS Literals

All DBCS literals can be used wherever nonnumeric literals can be used, subject to rules and exceptions given in the appropriate places in this chapter.

Parent topic: DBCS Literals


Mixed Literals

DBCS characters can be included in nonnumeric literals. A nonnumeric literal that includes DBCS characters is called a mixed literal. In such a literal, SBCS characters are represented by SBCS codes and DBCS characters by DBCS codes. Each space character is represented by the SBCS code for space.

On output both the SBCS and the DBCS codes will be recognized. The first byte of a DBCS code is never a valid SBCS code; hence the two can be used together without confusion. But in operations within the program the literal will be treated as an ordinary nonnumeric literal. It is the programmer's responsibility to ensure that the two halves of a DBCS code do not get separated.

A nonnumeric literal is of category alphanumeric, not DBCS, regardless of whether it includes DBCS characters.

A mixed literal cannot be continued across lines.

MF This restriction has been removed.

Parent topic: Literals


Figurative Constants

If a figurative constant is used where only a DBCS literal is allowed (according to the rules concerning classes and categories given in the appropriate places in this chapter), it is a DBCS literal. Each space in this literal is a DBCS space.

Only the figurative constant SPACE(S) can be a DBCS literal.

Parent topic: Literals


The "N" literal

Another format of literal, equivalent to the DBCS literal, is used in COBOL/370 and the MIA COBOL specification.

General Format

Syntax Rules

  1. An N-literal can contain no more than 18 DBCS-characters, and can not be split over two lines.
  2. An N-literal can contain only double-byte characters for your computer's Double Byte Character Set.
  3. Any double-byte quotation marks used in the literal should be written twice. For example, in order to express a double-byte quotation mark in the literal, you should write:

    N"ABC""DEF"

  4. N-literal specification and behavior can be modified in exactly the same way as G-literals using the APOST Compiler directive to replace a quotation (double-line) by an apostrophe (single-line) character.

General Rules

  1. The N-literal can be used in conjunction with ALL to make a figurative constant (see the section Figurative Constants.
  2. All characters must be double-byte characters.
Parent topic: Literals
Related information
Figurative Constants


Program Structure

  • The END PROGRAM Header (DBCS)
Parent topic: Double-Byte Character Set Support


The END PROGRAM Header (DBCS)

Syntax Rules

  1. Program-name must not contain DBCS characters.

    MF This restriction is removed.

Parent topic: Program Structure


Identification Division

  • The PROGRAM-ID Paragraph (DBCS)
Parent topic: Double-Byte Character Set Support


The PROGRAM-ID Paragraph (DBCS)

Syntax Rules

  1. Program-name must not contain DBCS characters.

    MF This restriction is removed.

  2. Comment-entries can contain DBCS characters.
Parent topic: Identification Division


Environment Division

  • The SOURCE-COMPUTER Paragraph (DBCS)
  • The OBJECT-COMPUTER Paragraph (DBCS)
  • The SPECIAL-NAMES Paragraph (DBCS)
  • The FILE-CONTROL Paragraph (DBCS)
Parent topic: Double-Byte Character Set Support


The SOURCE-COMPUTER Paragraph (DBCS)

Syntax Rules

  1. Source-computer-name can contain DBCS characters.
Parent topic: Environment Division


The OBJECT-COMPUTER Paragraph (DBCS)

Syntax Rules

  1. Object-computer-name can contain DBCS characters.
Parent topic: Environment Division


The SPECIAL-NAMES Paragraph (DBCS)

Syntax Rules

  1. In the CURRENCY SIGN clause, literal-6 must not be a DBCS literal and must not be "G"

    MF COB370 or "N".

  2. In the ALPHABET clause, literal-1, -2, and -3 must not be DBCS literals.
  3. In the CLASS clause, literal-4 and -5 must not be DBCS literals.
Parent topic: Environment Division


The FILE-CONTROL Paragraph (DBCS)

Syntax Rules

  1. In the ASSIGN clause, literal-1 must not be a DBCS literal and external-file-reference must not contain DBCS characters.

    MF This restriction is removed.

Parent topic: Environment Division


Data Division

  • The JUSTIFIED Clause (DBCS)
  • The PICTURE Clause (DBCS)
  • The REDEFINES Clause (DBCS)
  • The RENAMES Clause (DBCS)
  • The USAGE Clause (DBCS)
  • The VALUE Clause (DBCS)
Parent topic: Double-Byte Character Set Support


The JUSTIFIED Clause (DBCS)

General Rules

  1. The JUSTIFIED clause can be used with DBCS data items.
Parent topic: Data Division


The PICTURE Clause (DBCS)

General Rules for All Formats

  1. There are two additional categories of data that can be described with a PICTURE clause: DBCS and DBCS edited. Both these categories must be described as USAGE IS DISPLAY-1.

    MF These categories need not be described as USAGE DISPLAY-1.

    COB370 DISPLAY-1 is optional for PIC N, but not for PIC G items.

General Rules for DBCS Data

  2. Its PICTURE character-string can contain only the symbol "G"

    MF COB370 or "N".

  3. Its contents can be any characters in the DBCS character set.

General Rules for DBCS Edited Data

  4. Its PICTURE character string can contain any combination of the symbols "G" and "B".

General Rules for Editing

  5. The type of editing that can be performed on an item depends on the category to which the item belongs. The table Editing Types for Data Categories in the topic The PICTURE Clause is extended with the information shown in the table below:
    Table 1. Editing Types for Data Categories
    Category | Type of Editing
    DBCS | None
    DBCS Edited | Simple insertion "B" only

General Rules for Fixed Insertion Editing

  6. When used in an SBCS item, "B" (space) represents an SBCS space. When used in a DBCS item it represents a DBCS space.

Symbols Used

The functions of these symbols are as follows:

G - | Each "G" represents a character position which can contain only a DBCS character or a DBCS space.
B - | Each "B" represents a character position into which the DBCS space character will be inserted.
MF COB370 N - | Each "N" represents a character position which can contain only a DBCS character or a DBCS space.

Note that each "G" or "B"

ANS85 or "N"

represents a single double-byte character position.

Parent topic: Data Division
Related information
The PICTURE Clause


The REDEFINES Clause (DBCS)

Syntax Rules

  1. If either data-name-1 or data-name-2 is of class DBCS, then both must be of class DBCS.

    MF This restriction is removed.

Parent topic: Data Division


The RENAMES Clause (DBCS)

Syntax Rules

  1. If either data-name-1 or data-name-2 is of class DBCS, then both must be of class DBCS. No THROUGH clause is allowed.
Parent topic: Data Division


The USAGE Clause (DBCS)

General Format

The General Format is extended by the addition of the following:

The General Format is extended by the addition of the following:

Syntax Rules

  1. The PICTURE character-string of a DISPLAY-1 item can contain only "G"s and "B" s. An item whose PICTURE character-string contains "G"s must have a USAGE IS DISPLAY-1 clause.

    Note that therefore the USAGE IS DISPLAY-1 clause makes an item's class DBCS.

    MF COB370 USAGE IS DISPLAY-1 is not required for items whose PICTURE clause contains

    MF "G"s or

    MF COB370 "N"s.

    MF Whenever a PICTURE clause contains a "G" the associated item is considered to be of class DBCS.

  2. The BLANK WHEN ZERO clause cannot be used with group or elementary items described as USAGE IS DISPLAY-1. The SYNCHRONIZED clause is ignored.
  3. The usage of a Screen Section data item may be implicitly or explicitly defined as USAGE DISPLAY-1.

General Rules

  1. The USAGE IS DISPLAY-1 clause indicates that the format of the data is DBCS.
Parent topic: Data Division


The VALUE Clause (DBCS)

Syntax Rules for All Formats

  1. In a data description entry, if the category of the item is DBCS the literal in the VALUE clause must be of category DBCS. A DBCS literal is allowed only if the category of the item is DBCS or if the category of the item is DBCS edited.
  2. A DBCS literal in the VALUE clause must not exceed the size given by the PICTURE character-string.

Syntax Rules for Condition-name Rules

  3. In a condition-name entry, if the associated data item is of category DBCS, all literals in the VALUE clause must be of category DBCS. DBCS literals are allowed only if the category of the associated data item is DBCS.
Parent topic: Data Division


Procedure Division

  • Conditional Expressions (DBCS)
  • Statements that Involve Moving Data
  • The ACCEPT Statement (DBCS)
  • The CALL Statement (DBCS)
  • The CANCEL Statement (DBCS)
  • The INITIALIZE Statement (DBCS)
  • The INSPECT Statement (DBCS)
  • The MOVE Statement (DBCS)
  • The SEARCH Statement (DBCS)
  • The STOP Statement (DBCS)
  • The STRING Statement (DBCS)
  • The UNSTRING Statement (DBCS)
Parent topic: Double-Byte Character Set Support


Conditional Expressions (DBCS)

  • Relation Conditions
  • Class Condition
Parent topic: Procedure Division


Relation Conditions

Data items and literals of class DBCS can be used in a relation condition with any relational operator. Each operand must be either a group item or of class DBCS. No conversion, editing, or de-editing is done; no distinction is made between items of category DBCS and items of category DBCS edited.

The operation performed is a nonnumeric comparison. Since there is in general no collating sequence between the characters in a DBCS character set, the collating sequence used is based on the numeric values of the bit patterns representing the characters, interpreted as if they were binary numbers.

Note that if the DBCS character codes include codes for characters in the SBCS character set, there is no guarantee that this collating sequence will order them the same as in SBCS.

MF Where a character exists in both the DBCS and SBCS character sets, its DBCS and SBCS representations will not be regarded as equivalent. See the section Roman Script in DBCS.

The PROGRAM COLLATING SEQUENCE clause has no effect on comparisons involving data items of class DBCS or DBCS literals.

If the operands are of unequal size, comparison proceeds as though the shorter operand were extended on the right by enough DBCS spaces to make them the same size.

Parent topic: Conditional Expressions (DBCS)
Related information
Roman Script in DBCS


Class Condition

The class tests for DBCS items are DBCS and KANJI.

MF DBCS and KANJI class tests are not supported.

Parent topic: Conditional Expressions (DBCS)


Statements that Involve Moving Data

All statements that involve moving data between items and/or literals of class DBCS obey the rules given for such moves under the General Rules for The MOVE Statement; see the section The MOVE Statement.

Parent topic: Procedure Division
Related information
The MOVE Statement


The ACCEPT Statement (DBCS)

Syntax Rules

  1. In Format 2, identifier must not be of class DBCS.

General Rules

  1. In Format 1, DBCS data can be entered only if identifier is of class DBCS.
Parent topic: Procedure Division


The CALL Statement (DBCS)

Syntax Rules

  1. Identifier-1 must not be a data item of class DBCS; literal-1 must not be a DBCS literal.

    MF This restriction is removed.

  2. The program-name given by identifier-1 or literal-1 must not contain DBCS characters.

    MF This restriction is removed.

General Rules

  1. Each item of class DBCS referenced in the USING clause must correspond to an item of class DBCS in the USING clause of the Procedure Division header of the called program.
Parent topic: Procedure Division


The CANCEL Statement (DBCS)

Syntax Rules

  1. Identifier-1 must not be a data item of class DBCS; literal-1 must not be a DBCS literal.

    MF This restriction is removed.

  2. The program-name given by identifier-1 or literal-1 must not contain DBCS characters.

    MF This restriction is removed.

Parent topic: Procedure Division


The INITIALIZE Statement (DBCS)

General Format

The General Format is extended by the options DBCS,

MF NATIONAL or NATIONAL-EDITED

as additional alternatives to ALPHABETIC, ALPHANUMERIC, et cetera.

General Rules

  1. Specifying the DBCS,

    MF NATIONAL or NATIONAL-EDITED option causes

    data items of categories DBCS and DBCS-EDITED to be initialized.

Parent topic: Procedure Division


The INSPECT Statement (DBCS)

Syntax Rules

  1. All the identifiers and literals except identifier-2 must be of class DBCS if any one of them is of class DBCS.

General Rules

  1. The count maintained in identifier-2 is of DBCS characters, not bytes.
Parent topic: Procedure Division


The MOVE Statement (DBCS)

Syntax Rules

  1. All the identifiers and literals must be of class DBCS if any one of them is.

    MF Items of class DBCS, category alphanumeric, and category alphabetic can be mixed freely.

  2. In Format 2, the MOVE CORRESPONDING format, if either of a pair of matching items is of class DBCS then they both must be.

General Rules

  1. If the sending field is of class DBCS and a receiving field is of category DBCS Edited, editing is carried out on that receiving field. For any other combination of fields of class DBCS, no conversion, editing, or de-editing is done.

    MF This rule is relaxed as follows. If a receiving field is of category DBCS edited, it is edited. For any other combination that includes a field of class DBCS, no conversion, editing, or de-editing is done.

  2. If a receiving field is a different size from the sending field, the data is stored in that receiving item and truncated or padded on the right with DBCS spaces.
Parent topic: Procedure Division


The SEARCH Statement (DBCS)

Syntax Rules

  1. In Format 2, if identifier-1 is of class DBCS, then the ASCENDING/DESCENDING KEY item defined in its OCCURS clause must be of class DBCS also.
Parent topic: Procedure Division


The STOP Statement (DBCS)

Syntax Rules

  1. Literal must not be a DBCS literal.

    MF This restriction is removed.

Parent topic: Procedure Division


The STRING Statement (DBCS)

Syntax Rules

  1. All the identifiers and literals except identifier-4 must be of class DBCS if any one of them is of class DBCS.

General Rules

  1. The relative position indicated by identifier-4 gives the position in DBCS characters.
Parent topic: Procedure Division


The UNSTRING Statement (DBCS)

Syntax Rules

  1. All of identifier-1, -2, -3, literal-1, and -2 must be of class DBCS if any one of them is of class DBCS.

General Rules

  1. The relative position indicated by identifier-7 gives the position in DBCS characters.
  2. The count maintained in identifier-6 is of DBCS characters.
Parent topic: Procedure Division


Micro Focus Extensions for Double-Byte Character Support

The Micro Focus Extensions for Double-Byte Character Support is the additional facility we provide as the programming solution for environments using 16-bit coding schemes (DBCS). This facility incorporates every implementation of Japanese language support from earlier Micro Focus products.

(MIA) If you wish your program to comply with the Multivendor Integration Architecture Standard or to be compatible with IBM VS COBOL II, COBOL/370 or IBM SAA you should use the DBCS Support defined earlier in the topic Double-Byte Character Set Support.

8-bit codes used by your COBOL system are referred to as the Single-Byte Character Set (SBCS). 16-bit codes, each character occupying a pair of adjacent bytes are referred as the Double-Byte Character Set (DBCS).

Micro Focus Extensions for Double-Byte Character Support is enabled by the NCHAR or JAPANESE Compiler directives.

When the Micro Focus Extensions for Double-Byte Character Support is enabled, the support defined in the topic Double-Byte Character Set Support is modified. In particular, in this chapter MOVE operations from SBCS to DBCS data items perform SBCS to DBCS conversion.

The classes NCHAR and JAPANESE, and NCHAR-EDITED and JAPANESE-EDITED are synonyms and interchangeable. In this chapter, reference to the class or category NCHAR or the category NCHAR-EDITED is equivalent to the class or category JAPANESE or the category JAPANESE-EDITED respectively.

  • Environment Division
  • Data Division
  • Procedure Division
Parent topic: Part 3. Additional Topics


Environment Division

  • The OBJECT-COMPUTER Paragraph
  • The SPECIAL-NAMES Paragraph
  • The FILE-CONTROL Paragraph
Parent topic: Micro Focus Extensions for Double-Byte Character Support


The OBJECT-COMPUTER Paragraph

General Rule

The compiler is designed to allow only 8-bit characters to be used in the PROGRAM COLLATING SEQUENCE IS phrase.

It is meaningless to define a collating sequence using an ALPHABET clause in which the literals contain double-byte characters. This is because double-byte appears as two separate 8-bit characters. If you attempt to use double-byte in this way, double-byte characters are collated as two single bytes – any double-byte meaning is ignored.

You can, however, use non-ASCII characters in the ALPHABET clause literals when you define the program collating sequence. For example, in a Japanese environment single-byte Katakana can be used in a Shift-JIS environment as they are stored and displayed as one byte. If you are using EUC you cannot use single-byte characters in the ALPHABET IS phrase, because such characters are hybrid two-byte characters.

Parent topic: Environment Division


The SPECIAL-NAMES Paragraph

Syntax Rules

  1. In the CURRENCY SIGN clause, literal-6 must not be an NCHAR literal and must not be "N".
  2. In the ALPHABET clause, literal-1, -2, and -3 must not be NCHAR literals.
  3. In the CLASS clause, literal-4 and -5 must not be NCHAR literals.
Parent topic: Environment Division


The FILE-CONTROL Paragraph

Syntax Rules

  1. In the ASSIGN clause, literal-1 can be an NCHAR literal and external-file-reference can contain DBCS characters.
Parent topic: Environment Division


Data Division

  • The JUSTIFIED Clause
  • The PICTURE Clause (DBCS)
  • The USAGE Clause
  • The VALUE Clause
Parent topic: Micro Focus Extensions for Double-Byte Character Support


The JUSTIFIED Clause

General Rules

  1. The JUSTIFIED clause can be used with NCHAR data items.
Parent topic: Data Division


The PICTURE Clause (DBCS)

General Rules for NCHAR data itemrules Rules for NCHAR Data

  1. Its PICTURE character-string can contain only the symbol "N".
  2. Its contents can be any characters in the DBCS character set.

General Rules for NCHAR-EDITED data rule Rules for NCHAR-EDITED Data

  3. Its PICTURE character string can contain any combination of the symbols "N", "B", "/" and "0". Refer to the section The PICTURE Clause for edited-data rules.

Symbols Used

The functions of these symbols are as follows:

Symbol | Representation | Example NCHAR Japanese Values
 |  | Shift-JIS | EUC
N | Each "N" represents a character position which can contain only a DBCS character or a DBCS space. |  |
B | Each "B" represents a character position into which the DBCS space character is inserted. | x"8140" | x"A1A1"
/ | Each "/" represents a character position into which the DBCS forward slash is inserted. | x"851E" | x"A1BF"
0 | Each "0" represents a character position into which the DBCS Zero is inserted. | x"824F" | x"A3B0"
Note: Each "N", "B", "/", "0" represents a single double-byte character position.

DBCS Characters Editing Rules

The type of editing that can be performed on an item depends on the category to which the item belongs. The table Editing Types for Data Categories in the section The PICTURE Clause is extended with the information shown in the table below:

Category | Type of Editing
NCHAR | None
NCHAR-EDITED | Simple insertion "B", "/", "0" only

Fixed Insertion Editing

When used in an SBCS item, "B" (space) represents an SBCS space. When used in an NCHAR item it represents a DBCS space.

When used in an SBCS item, "/" (forward slash) represents an SBCS forward slash. When used in an NCHAR item it represents a DBCS forward slash.

When used in an SBCS item, "0" (zero) represents an SBCS zero. When used in an NCHAR item it represents a DBCS zero.

Parent topic: Data Division
Related information
The PICTURE Clause


The USAGE Clause

General Format

The General Format is extended by the addition of the following:

The General Format is extended by the addition of the following:

Syntax Rules

  1. The PICTURE character-string can contain only "N"s, "B"s, "/"s, and "0"s.

    Whenever a PICTURE clause contains an "N" the associated item is considered to be of class NCHAR, Japanese.

  2. The BLANK WHEN ZERO clause cannot be used with group or elementary items described as USAGE IS NCHAR or USAGE IS JAPANESE. The SYNCHRONIZED clause is ignored.

General Rules

  1. The USAGE IS NCHAR or USAGE IS JAPANESE clause indicates that the format of the data is NCHAR.
Parent topic: Data Division


The VALUE Clause

Syntax Rules

  1. In a data description entry, if the category of the item is NCHAR, the literal in the VALUE clause must be of category NCHAR. An NCHAR literal is allowed only if the category of the item is NCHAR or NCHAR-EDITED.

    An NCHAR literal in the VALUE clause must not exceed the size given by the PICTURE character-string.

Parent topic: Data Division


Procedure Division

  • Conditional Expressions
  • The ACCEPT Statement
  • The INITIALIZE Statement
  • The INSPECT Statement
  • The MOVE Statement
    All statements that involve moving data between items and/or literals of class NCHAR obey the rules given for such moves under the General Rules below.
  • The SEARCH Statement
  • The STRING Statement
  • The UNSTRING Statement
Parent topic: Micro Focus Extensions for Double-Byte Character Support


Conditional Expressions

  • Condition-name
  • Relation Conditions
  • Class Condition
Parent topic: Procedure Division


Condition-name

If a condition-name with a literal of class NCHAR is associated with an elementary item which is not of class NCHAR, the literal is treated as an SBCS alphanumeric literal.

Parent topic: Conditional Expressions


Relation Conditions

Data items and literals of class NCHAR can be used in a relation condition with any relational operator. No conversion, editing or de-editing is done and no distinction is made between items of category NCHAR and items of category NCHAR-EDITED.

The operation performed is a nonnumeric comparison. Since there is in general no collating sequence between the characters in a DBCS character set, the collating sequence used is based on the numeric values of the bit patterns representing the characters, interpreted as if they were binary numbers.

Note that if the DBCS character codes include codes for characters in the SBCS character set, there is no guarantee that this collating sequence orders them the same as in SBCS.

Where a character exists in both the DBCS and SBCS character sets, its DBCS and SBCS representations are not regarded as equivalent.

The PROGRAM COLLATING SEQUENCE clause has no effect on comparisons involving data items of class NCHAR or NCHAR literals.

If the operands are of unequal size, comparison proceeds as though the shorter operand were extended on the right by enough DBCS spaces to make them the same size.

Parent topic: Conditional Expressions


Class Condition

An additional class test, JAPANESE, is available. This class test is true if all characters in the data item being tested are valid single-byte Katakana or double-byte characters, or if the data item contains all spaces.

Parent topic: Conditional Expressions


The ACCEPT Statement

General Rules

Note: In some environments, such as a Japanese EUC environment, special actions or behavior may occur.
  1. In Format 1, both SBCS and DBCS data can be entered. SBCS data is not converted to DBCS data.

    In a Format 1 ACCEPT of an NCHAR-EDITED data item, there is no validation, conversion or character alignment of the data that you enter. As a result, the data might be corrupted. Therefore, we recommend that you do not use this method, or use it with caution.

    In Formats 4 and 5, both single-byte and double-byte characters are valid characters to be entered into an NCHAR data item. However single-byte characters are converted to their double-byte equivalent.

    All normal editing features are supported for the ACCEPT of NCHAR data items (backspace, retype, delete, restore, overtype and insert) on a character by character basis.

Parent topic: Procedure Division


The INITIALIZE Statement

General Format

The General Format is extended by the options NCHAR and JAPANESE as additional alternatives to options such as ALPHABETIC or ALPHANUMERIC.

Syntax Rules

  1. NCHAR and JAPANESE may not be specified together or in conjunction with DBCS or NATIONAL.

General Rules

  1. Specifying the NCHAR or JAPANESE option causes data items of category NCHAR to be initialized.
Parent topic: Procedure Division


The INSPECT Statement

Syntax Rules

  1. All the identifiers and literals except identifier-2 must be of class NCHAR if any one of them is of class NCHAR.

General Rules

  1. If identifier-1 is of class NCHAR, the count maintained in identifier-2 is of DBCS characters, not bytes.
Parent topic: Procedure Division


The MOVE Statement

All statements that involve moving data between items and/or literals of class NCHAR obey the rules given for such moves under the General Rules below.
Category of Sending Item | Category of Receiving Data Item
 | Alpha-numeric | NCHAR | NCHAR-EDITED | NCHAR with JUSTIFIED
Alpha-numeric | See Note | Yes/G1 | Yes/G4 | No/S2
NCHAR | Yes/G2 | Yes/G3 | Yes/G4 | Yes/G5
NCHAR-EDITED | No/S1 | No/S1 | No/S1 | No/S1
NCHAR with JUSTIFIED | Yes/G2 | Yes/G3 | Yes/G4 | Yes/G5
Note: Class Alphanumeric is specified in this table as an illustration of the usage of single-byte or group data items. For details of MOVE operations involving only single-byte data items refer to the topic The MOVE Statement. For details of MOVE operations mixing single- and double-byte data item, refer to the following information and the table above.

Syntax Rules

  1. The sending data item must not be of category NCHAR-EDITED.
  2. If the receiving data item is of class NCHAR and the JUSTIFIED clause is specified, the sending data item must be of class NCHAR.

General Rules

  1. If the sending data item is of class alphanumeric or alphabetic and the receiving data item is of class NCHAR then the single-byte characters in the source are converted into the equivalent double-byte characters in the target. DBCS characters in the source are moved unchanged into the target.

    If a receiving data item is a different size from the sending data item, the data that is stored in the receiving item is truncated or padded on the right with DBCS spaces.

  2. If the sending data item is of class NCHAR and the receiving data item is of class alphanumeric, then the hexadecimal values in the source are moved, unchanged, to the target data item on a byte by byte basis.

    If a receiving data item is a different size from the sending data item, the data that is stored in the receiving item is truncated or padded on the right with SBCS spaces.

  3. If the sending data item is of class NCHAR and the receiving data item is also of class NCHAR, then the values in the source are moved, unchanged, to the target data item on a byte by byte basis.

    If a receiving data item is a different size from the sending data item, the data that is stored in the receiving item is truncated or padded on the right with DBCS spaces.

  4. If the sending data item is of class alphanumeric, alphabetic or NCHAR and a receiving data item is of category NCHAR-EDITED, editing is carried out on that receiving data item.

    If a receiving data item is a different size from the sending data item, the data is stored in that receiving item and truncated or padded on the right with DBCS spaces.

    If the sending data item is of class alphanumeric or alphabetic, the hexadecimal values of the single-byte characters in the source are converted to the equivalent double-byte characters in the target. DBCS characters in the source are moved unchanged into the target.

  5. If the sending data item is of class NCHAR and the receiving data item is class NCHAR with the JUSTIFIED clause specified, then the values in the source data item are moved, unchanged, to the target data item on a byte by byte basis.

    When a receiving data item is described with JUSTIFIED clause and the sending data item is larger than the receiving data item, the leftmost characters are truncated. When the receiving data item is described with the JUSTIFIED clause and it is larger than the sending data item, data is aligned at the rightmost character position in the data item with DBCS spaces padding from the leftmost character positions.

Parent topic: Procedure Division
Related information
The MOVE Statement


The SEARCH Statement

General Rules

  1. If identifier-1 is of class NCHAR then in Format 1 the value maintained in identifier-2 consists of DBCS characters.
Parent topic: Procedure Division


The STRING Statement

Syntax Rules

  1. All the identifiers and literals except identifier-4 must be of class NCHAR if any one of them is of class NCHAR.

General Rules

  1. If identifier-3 is of class NCHAR then the relative position indicated by identifier-4 gives the position in DBCS characters.
Parent topic: Procedure Division


The UNSTRING Statement

Syntax Rules

  1. All of identifier-1, identifier-2, identifier-3, literal-1 and literal-2 must be of class NCHAR if any one of them is of class NCHAR.

General Rules

  1. If identifier-1 is of class NCHAR then the relative position indicated by identifier-7 gives the position in DBCS characters and the count maintained in identifier-6 is of DBCS characters.
Parent topic: Procedure Division


Micro Focus OO COBOL Extensions

  • Directives
  • Class Definition
    A Class describes an Object COBOL Class object and its instance objects. It contains nested programs for class methods and instance methods.
  • Class Extension
    A class extension enables you to add extra functionality to an object COBOL class without changing the original source code.
  • Class-body
    The class body contains all the code that defines class data and class methods.
  • Class-object
    The class object is an object that acts as a creator of objects.
  • Object-program
    The object program contains the definition of data and methods for all instances of the class.
  • Method
  • Method Interface Definition
    A method interface definition defines the parameters for the method, how they are passed, and any alternate syntax that can be used to invoke the method.
Parent topic: Part 3. Additional Topics


Directives

In addition to the Compiler directives which provide flagging and modify the reserved word list, the following directives may impact either the syntax or the semantics described in this section.

  • ALIGN - specifies the memory boundaries on which data items of 01-level or 77-level are aligned.
  • IBMCOMP - turns on word-storage mode.
  • MAPNAME - impacts the handling of non-alphabetic characters in the method-name.
  • REPOSITORY - tells the Compiler whether to create a repository entry for a class, ignore the repository entry for a class, or check against the repository entry for a class.
  • OOCTRL - provides specific switches for OO options. The settings can be enabled or disabled by use of the + and - signs, respectively, preceding the option character. The default is OOCTRL(+F-G-P+Q-W). The meaning of the options is:
    +F Folds method names invoked by the program being compiled to lower case. Use -F if your program calls Java methods, since Java method names are case-sensitive. See your COBOL system documentation for information on using Java and COBOL together.
    +G Makes class data global for instances.
    Note: The use of this option is not recommended. It is provided for compatibility with earlier releases.
    +P Makes parameter type information available to the Object COBOL runtime system.
    Note: Needed for messages sent to OLE and SOM.
    +Q Disables the use of IN and OF any place that could possibly follow a data name in the verb-signature of a Method Interface Definition.

    Disables the use of any verb in the verb-signature of a Method Interface Definition (see the topic Categories of Statements in the chapter Language Fundamentals).

    -Q Enables the use of IN and OF in the verb-signature of a Method Interface Definition. Disables the use of qualification in a verb-signature that invokes a method.

    Enables the use of verbs in the verb-signature of a Method Interface Definition (see the topic Categories of Statements in the chapter Language Fundamentals).

    +W Uses working storage in the object and factory (class) object to mean object storage.
    Note: Provides compatibility with the ISO 2002 COBOL standard.
Parent topic: Micro Focus OO COBOL Extensions
Related information
Categories of Statements


Class Definition

A Class describes an Object COBOL Class object and its instance objects. It contains nested programs for class methods and instance methods.

General Format

Syntax Rules

  1. The words PROTECTED and RESTRICTED are equivalent.
  2. If the EXTERNAL clause is specified, neither the DATA nor the INHERITS clause may be specified.
  3. If the ABSTRACT clause is specified, the FINAL clause must not be specified.
  4. If the WITH DATA phrase is specified in the INHERITS clause, the DATA IS PRIVATE clause must not be specified explicitly or implicitly in the source code for class-name-2.
  5. Class-name-2 must not be the same as class-name-1.
  6. Class-name-2 must not inherit from class-name-1 directly or indirectly.
  7. Class-name-1 in the END CLASS header must be identical to the class-name-1 specified in the preceding Class-ID paragraph.

General Rules

  1. Class-name-1 identifies the class being declared.
  2. The ABSTRACT clause indicates that class-name-1 is an abstract class. You cannot create an instance of an abstract class.
  3. The EXTERNAL phrase indicates that class-name-1 is an external class. No code is produced.
  4. The RESTRICTED phrase enables subclasses to directly access data inherited from class-name-1.
  5. The PRIVATE phrase prevents subclasses from directly accessing data inherited from class-name-1.
  6. The INHERITS phrase specifies that class-name-2 is a parent class of class-name-1.
  7. If the INHERITS phrase is not specified, class-name-1 forms a new root in the classification scheme. There can be one or more roots in a classification scheme.
  8. The WITH DATA phrase specifies that class-name-1 is able to access directly data inherited from class-name-2.
Parent topic: Micro Focus OO COBOL Extensions


Class Extension

A class extension enables you to add extra functionality to an object COBOL class without changing the original source code.

The difference between extending a class with a class extension as opposed to using inheritance is that the class extensions are inherited by all existing subclasses. For example, if class A has a subclass, class B (B INHERITS FROM A), you can add methods to class A by subclassing it to create subclass C. However, class B does not inherit the methods of class C, because it is a subclass of A. If you extend class A with a class extension, X, the effect at run time is the same as if you had changed and recompiled class A: class B inherits all the extra methods in class X.

General Format

Syntax Rules

  1. Extension-name-1 must not be the same as class-name-1.
  2. Extension-name-1 in the END CLASS header must be identical to the extension-name-1 specified in the preceding Class-ID paragraph.
  3. Class-name-1 must be the name of a class specified in the Class-Control paragraph.
  4. The Data Division of the class-body may contain an empty Object-Storage Section. The only other sections that may be specified in the Data Division of a Class Extension are the Working-Storage Section and the Linkage Section.
  5. Statements in the class extension may reference data declared in class-name-1 only when both the following cocnditions are true:
    • The DATA IS PROTECTED or DATA IS RESTRICTED phrase is specified in the Class-ID paragraph of class-name-1
    • The WITH DATA phrase is specified in the Class-ID paragraph of the class extension.

General Rules

  1. The EXTEND clause specifies a class extension. A class extension adds methods to an object class. The methods specified in extension-name-1 are inherited by all subclasses, existing and new, of class-name-1.
  2. During the execution of a run unit, a COBOL call statement to extension-name-1 must be executed before any of the methods in the class extension are invoked. This registers the methods in the class extension with the OO runtime system.
Parent topic: Micro Focus OO COBOL Extensions


Class-body

The class body contains all the code that defines class data and class methods.

General Format for Format 1

Used when the Compiler directive OOCTRL(+N) is specified.

Note: This is the preferred syntax.

General Format for Format 2

Used when the Compiler directive OOCTRL(-N) is specified.

Syntax Rules for All Formats

  1. Class-name-3 must not be specified more than once in the Class-Control paragraph.
  2. Class-name-3 may be the same as the class-name specified in the Class-ID paragraph.
  3. The Data Division may not contain a Linkage Section.

Syntax Rules for Format 1

  4. The Data Division may not contain an Object-Storage Section.
  5. Data items declared in the Data Division may be referenced from instance methods and class methods.

Syntax Rules for Format 2

  6. Data items declared in the Local-Storage Section, Report Section, and Screen Section may be referenced only from the statements in the Procedure Division of this class, not from any methods.
  7. Data items declared in the File Section or Working-Storage Section can be referenced from instance methods and class methods and from the Procedure Division of this class.
  8. Data items declared in the Object-Storage Section may be referenced from class methods.

General Rules for All Formats

  1. Class-name-3 is implicitly defined as USAGE IS OBJECT REFERENCE.
  2. Class-name-3 is the name of a class that may be used throughout the scope of the containing Environment Division.
  3. External-name-1 specifies the external name of the file containing the class.
  4. Method-1 is a class method.
  5. Only data items in the Object-Storage Section are inherited by subclasses.

General Rules for Format 1

  6. Data items are in their initial state at the start of the run unit and remain in their last used state between method invocations.

General Rules for Format 2

  7. The statements in the class Procedure Division are executed before the first time any class method or instance method of this class is executed in the run unit.
  8. When execution of the class Procedure Division begins, the contents of the data items in the Local-Storage Section are undefined. This storage is deallocated immediately after execution of the class Procedure Division.
  9. Data items declared in the File Section and Working-Storage Section remain in their last used state between invocations of class and instance methods.
    Note: Working storage data is useful for class or instance initialization data.
  10. Data items declared in the Object-Storage Section remain in their last used state between invocations of class methods.
Parent topic: Micro Focus OO COBOL Extensions


Class-object

The class object is an object that acts as a creator of objects.

General Format

General Rules

  1. If a data-item is declared in the Object-Storage Section of a class object, it is class data. Class data may be referenced only in class methods. Class data can be inherited by subclasses.
  2. Data is in its initial state at the start of the run unit and remains in its last used state between method invocations.
  3. Method-1 is a class method.
Parent topic: Micro Focus OO COBOL Extensions


Object-program

The object program contains the definition of data and methods for all instances of the class.

General Format

General Rules

  1. If a data-item is declared in the Object-Storage Section of an object program, it is instance data. Instance data may be referenced only in instance methods.
  2. Data items are in their initial state at the start of the run unit and remain in their last used state between method invocations.
  3. Method-1 is an instance method.
Parent topic: Micro Focus OO COBOL Extensions


Method

Genral Format:

Syntax Rules

  1. Method-name-1 in the END METHOD header must be identical to the method-name-1 declared in the preceding Method-ID paragraph.
  2. Data declared in the Data Division of a method is accessible only within that method.
  3. Quotation marks around method-name-1 are optional.
    Note: Quotation marks enable you to use reserved words as method-names and to use non-COBOL characters.
  4. A method definition must be contained in a Class Definition.
  5. The format of the PROCEDURE DIVISION header for a method is the same as the format 1 PROCEDURE DIVISION header for a program. The GIVING or RETURNING data-name clause shown in the format 2 header may also be specified. (See the section The PROCEDURE DIVISION Header for details.)

General Rules

  1. Method-name-1 names the method declared by this method definition.
  2. Data declared in the Local-Storage Section of a method is allocated separate storage for each invocation of the method and deallocated upon return from the method. This data is in an undefined state each time the method is invoked.
    Note: If you declare your data in the Local-Storage Section, separate invocations of the method do not interfere with each other's data.
  3. Data and files declared in a method in sections other than the Local-Storage Section or the Linkage Section are shared among all invocations of the method and are in their last used state when the method is invoked.
  4. Method-name-1 may be used in a method invocation with an object identifier that references an object containing this method.
  5. If a RETURNING or GIVING phrase is specified in the PROCEDURE DIVISION header of a method, the contents of the data item specified in that phrase when the method terminates become the result of the method. This result is placed in the identifier specified in the RETURNING or GIVING phrase of the INVOKE statement.
Parent topic: Micro Focus OO COBOL Extensions
Related information
The PROCEDURE DIVISION Header


Method Interface Definition

A method interface definition defines the parameters for the method, how they are passed, and any alternate syntax that can be used to invoke the method.

General Format:

where verb-signature is:

Syntax Rules

  1. A method interface definition must be nested within an external class.
  2. Procedure-division-header is a format 2 procedure-division-header as specified for a program, except that neither mnemonic-name nor the REPEATED phrase may be specified. The INVOKED phrase, shown in the format above, may optionally be included in the header just before the terminating period. (See the topic The PROCEDURE DIVISION Header for details.)
  3. When the FUNCTION phrase is specified in the verb-signature, the RETURNING phrase must be specified in the PROCEDURE DIVISION header.
  4. Verb-1 must be a COBOL word that is neither a reserved word nor a procedure-name.
  5. The words <OBJECT>, <SELF> and <THIS> are equivalent. One of them must be present once and only once in each verb-signature.
  6. Data-name-3 must be preceded by "<" and followed by ">".
  7. Compulsory-word must be a COBOL word.
  8. Noise-word must be a COBOL word and must be preceded by "[" and followed by "]".
  9. Open-parenthesis and close-parenthesis are "(" and ")" respectively.
    Note: Open-parenthesis and close-parenthesis enable you to define functions that look like intrinsic functions, with parameters enclosed in parentheses.
  10. A verb-signature must not be a subset of another verb-signature.

General Rules

  1. When method-name-1 is invoked using verb-signature, <SELF> is replaced with the object reference to the receiving object.
  2. Noise-words are for readability and are optional when the syntax is used to invoke a method.
  3. If verb-1 is also declared as a data-name in a program, then any reference to that word in that program is to the data-name.
Parent topic: Micro Focus OO COBOL Extensions
Related information
The PROCEDURE DIVISION Header


Summary of Obsolete Language Elements

The elements of the COBOL language listed here are marked as obsolete in the ANSI X3.23-1985 COBOL specification.

  • They are to be deleted at the next revision of the standard COBOL specification.
  • They will not be enhanced, modified or maintained.
  • They should not be used in a conforming X/Open source program.

List of Obsolete Language Elements

  • Associating the figurative constant ALL literal where literal is longer than one character with a data item that is numeric or numeric edited.
  • The paragraphs AUTHOR, INSTALLATION, DATE-WRITTEN, DATE-COMPILED, and SECURITY within the Identification Division.
  • The MEMORY SIZE clause of the OBJECT-COMPUTER paragraph.
  • The RERUN clause of the I-O-CONTROL paragraph.
  • The MULTIPLE FILE TAPE clause of the I-O-CONTROL paragraph.
  • The LABEL RECORDS clause in the file description entry.
  • The VALUE OF clause in the file description entry.
  • The DATA RECORDS clause in the file description entry.
  • The ALTER statement.
  • The KEY phrase within the DISABLE statement.
  • The KEY phrase within the ENABLE statement.
  • The ENTER statement.
  • The option to exclude procedure-name in the GO TO statement.
  • The REVERSED phrase within the OPEN statement.
  • The STOP literal statement.
  • The segmentation module.
  • The debug module.


Additional Dialect Support

  • ACUCOBOL-GT Syntax Extensions
    Use the abbreviated ACUCOBOL-GT language reference for details of ACUCOBOL-GT's syntax extensions to ANSI 85 COBOL.
  • Data General Interactive COBOL V1.3 Syntax Support
  • DOS/VS COBOL Support
  • Microsoft COBOL V1.0 and V2.0 Syntax Support
  • RM/COBOL Syntax Support
  • Siemens BS2000 COBOL Syntax Support
  • VS COBOL II Compatibility
Parent topic: Part 3. Additional Topics


ACUCOBOL-GT Syntax Extensions

Use the abbreviated ACUCOBOL-GT language reference for details of ACUCOBOL-GT's syntax extensions to ANSI 85 COBOL.

ACUCOBOL-GT (Acu) is an implementation of the ANSI 85 COBOL programming language (ANSI X3.23-1985 and the ANSI X3.23a-1989 supplement). This section contains an abbreviated ACUCOBOL-GT language reference, which provides descriptions of Acu's language extensions when programs are compiled in Acu compatibility mode. For details on all other syntax supported by this COBOL system, see the COBOL Language Reference.

Since Micro Focus COBOL is also an implementation of ANSI 85 COBOL, Acu's ANSI 85 elements and behaviors are identical (or compatible) to Micro Focus COBOL.

You can obtain a complete ACUCOBOL-GT reference manual from the ACUCOBOL-GT product documentation set, which is available from the Micro Focus Product Documentation Page.

  • Program Structure
    Supported ACUCOBOL-GT program structures and elements when compiling for Acu compatibility.
  • Identification Division
    Supported elements when compiling for Acu compatibility.
  • Environment Division
    Supported ACUCOBOL-GT Environment Division elements when compiling for ACU compatibility.
  • Data Division
    Supported ACUCOBOL-GT Data Division elements and types when compiling for Acu compatibility.
  • Procedure Division
    Supported ACUCOBOL-GT extensions to Procedure Division statements and elements when compiling for Acu compatibility.
Parent topic: Additional Dialect Support


Program Structure

Supported ACUCOBOL-GT program structures and elements when compiling for Acu compatibility.
  • Identifiers
  • Numeric Literals
  • Nonnumeric Literals
  • Source Formats
Parent topic: ACUCOBOL-GT Syntax Extensions


Identifiers

  • Identifiers can be up to 62 characters long.
  • Underscore "_" is treated as a dash "-" in identifiers.
  • Data names can have the same name as procedure names.
Parent topic: Program Structure


Numeric Literals

A numeric literal is a character string selected from the digits, the plus sign, the minus sign, and the decimal point.

The following rules govern the formation of numeric literals:

  • A literal must contain at least one digit
  • A literal must contain no more than one sign character and, if one is used, it must be the leftmost character of the string
  • A literal must not contain more than one decimal point. The decimal point is treated as an assumed decimal point and may appear anywhere within the literal except as the rightmost character

If a literal conforms to the rules for formation of a numeric literal, but is enclosed in quotation marks, it is a nonnumeric literal.

Numeric literals may also be specified using binary, octal, or hexadecimal notation. To specify a numeric literal in one of these forms, preface the number with one of the following prefixes:

Binary | "B#"
Octal | "O#"
Hexadecimal | “X#” or “H#”

For example:

Number | Binary | Octal | Hexadecimal
3 | B#11 | O#3 | X#3 or H#3
8 | B#1000 | O#10 | X#8 or H#8
12 | B#1100 | O#14 | X#C or H#C
128 | B#10000000 | O#200 | X#80 or H#80
255 | B#11111111 | O#377 | X#FF or H#FF

Leading zeroes after the # are ignored. For example, X#00FF and X#FF are equivalent.

The Compiler converts each numeric literal specified in this way to an unsigned long integer. In most cases, this is a 32-bit unsigned number, so the maximum value of a numeric literal that can specified with this notation is 4294967295, or (2**32) -1.

LENGTH OF expression

The LENGTH OF expression can be used anywhere you would use a numeric literal, except as a subscript or reference modifier. The Compiler treats this expression as if you have coded a numeric literal. The LENGTH OF expression is written as follows:

LENGTH OF data-name

data-name can be a numeric or nonnumeric literal or the name of a data item of any type. Data-name may include subscripts if it refers to a table item. The Compiler calculates the value of the LENGTH OF expression and replaces it with a numeric literal equivalent to the current number of bytes of storage used by the data item or literal referenced in LENGTH OF. For example:

77 my-item PIC x(10).
78 my-item-length value LENGTH OF my-item.

becomes:

77 my-item PIC x(10).
78 my-item-length value 10.

The LENGTH OF expression can also be used in the procedure division as demonstrated in this example:

01 my-data.
   03 my-table occurs 20 times.
      05 my-element-1 pic x(10).
   05 my-element-2 pic 99.

MOVE LENGTH OF my-element-1 TO data-size.
MOVE LENGTH OF my-table TO data-size.
MOVE LENGTH OF my-table(1) TO data-size.

In this example the Compiler treats the first MOVE as MOVE 10 TO data-size, the second MOVE as MOVE 240 TO data-size, and the third MOVE as MOVE 12 TO data-size.

Note: This expression (when used on a table) works differently in ACUCOBOL-GT than in other COBOL Compilers, such as IBM Enterprise COBOL. ACUCOBOL-GT returns the size of the entire table, while IBM returns the size of a single element of the table. You can use the IBM method by compiling the program with -Cv, which turns on the Compiler’s IBM compatibility mode. Refer to ACUCOBOL-GT User’s Guide, section Compatibility Options for details on the -Cv Compiler option.

Floating-Point Literals

  1. A floating-point literal has the following format:
    [ + ] k.m { E } [ + ] n
[ - ]     { e } [ - ]

    In the above:

    • k.m represents a number with at least one digit.
    • n represents one or more digits.
    • If the functions of the decimal point and comma are switched with DECIMAL IS COMMA, then k.m will be k,m.

    Here are a few examples of floating-point numbers:

    -12.345e12
.0123E-6
123.E1
  2. Floating-point literals in the Procedure Division are stored internally as USAGE DOUBLE.
  3. The legal range of floating-point values is determined by the target machine. If you express a literal that is out of range for a particular machine, the runtime reports a warning message and substitutes the closest boundary value--either zero or the maximum floating-point value for the machine.
  4. On some computers, floating-point computations may give imprecise results. This is a hardware limitation; some floating point numbers cannot be precisely represented on some machines.
Parent topic: Program Structure


Nonnumeric Literals

A nonnumeric literal (sometimes called an alphanumeric literal) is a character string delimited at the beginning and at the end by quotation marks or apostrophes. The beginning and ending delimiters must be the same (that is, either both quotes or both apostrophes).

Nonnumeric literals may be up to 4096 characters in length. The characters contained in the delimiters may be selected from all characters available on the host computer.

To place the delimiter character in a nonnumeric literal, use two contiguous delimiter characters (either two quotes or two apostrophes). These two characters represent a single occurrence of that character.

You can also specify nonnumeric literals by supplying the hexadecimal value of the characters desired using the native character set. This can be used, for example, to encode device control codes. Any of the following formats are recognized:

X"hex-values"
X'hex-values'
H"hex-values"
H'hex-values'

The initial H or X may be either upper- or lower-case. The hex-values consist of one or more hexadecimal digits. These digits are drawn from the set of characters '0' – '9' and 'A' – 'F'. Every two hexadecimal digits represent one character position, with the first digit encoding the high-order 4 bits of the character, and the second digit encoding the low-order 4 bits. If an odd number of hexadecimal digits is specified, the low-order 4 bits of the last character are treated as zeros.

Note: In ACUCOBOL-GT h"123" is a nonnumeric literal and not numeric literal for all other dialects.

Example:

The following pairs of nonnumeric literals are equivalent (when the native character set is ASCII):

X"414243" | "ABC"
h'32313' | "210"
H"6E" | "n"
x"22" | """"
Parent topic: Program Structure


Source Formats

ACUCOBOL-GT supports two different source formats:

  • ANSI format
  • Terminal format

ANSI format has the following characteristics:

  • Columns 1 - 6 are used for sequence numbers. This area is ignored by the compiler.
  • Column 7 is the indicator area.
  • Columns 8 - 11 are area A.
  • Columns 12 - 72 are area B.
  • Columns 73 - 80 are the identification area. This area is ignored by the Compiler (but see Source Code Control below).
  • Lines are 80 characters long. Lines shorter than 80 characters are padded with spaces, and longer lines are truncated.

Terminal format is convenient for developing programs interactively. This format has the following characteristics:

  • The sequence number area is eliminated.
  • The indicator area is in column 1. All of the usual COBOL indicators are accepted here except for the conditional debugging line indicator D. This indicator must be preceded by a backslash (\) in column 1 (placing the D in column 2).
  • Area A also starts in column 1 unless an indicator is present, in which case it starts immediately after the indicator character.
  • Area B starts in column 5 and extends to the end of the line.
  • The identification area starts when a | or *> is encountered, provided it is not part of a literal. The Identification Area extends to the end of the line. This can be used to introduce in-line comments.
  • The line ends when a carriage-return or new-line is found. Lines may be longer or shorter than 80 characters.

ACUCOBOL-GT Terminal format is compatible with the VAX COBOL terminal source format, except for the introduction of the identification area, which VAX COBOL does not support. ACUCOBOL-GT Terminal mode is also compatible with ICOBOL terminal source format except that area A must start in column 1 (in ICOBOL area A may start in column 2).

Both formats expand tab characters to every eight spaces. Both formats also translate lower-case characters to upper-case except in literals. Finally, both formats translate the underscore character to a hyphen when it is found in identifiers.

Normally, the Compiler determines the source format automatically by examining the first character of the first non-blank line. If this character is blank or a digit, the file is assumed to be an ANSI file; otherwise it is assumed to be in terminal format. This is done independently for the main source file and all COPY libraries. This allows mixing of formats among a source file and its COPY libraries. If desired, the format to use for the entire input source can be set to either mode via the -Sa or -St compile flags.

Parent topic: Program Structure


Identification Division

Supported elements when compiling for Acu compatibility.
  • PROGRAM-ID Paragraph
Parent topic: ACUCOBOL-GT Syntax Extensions


PROGRAM-ID Paragraph

General Format

[ PROGRAM-ID. program-name [ IS {INITIAL } PROGRAM ] . ]
                                {RESIDENT}

General Rules

  1. The RESIDENT clause is an ACUCOBOL-GT extension.
  2. The RESIDENT clause specifies that the program is to remain resident in memory after its first execution. A program with the RESIDENT clause cannot be affected by a CANCEL statement. Note that the RESIDENT clause shields selected programs from the effects of a CANCEL Statement.
Note: The NOCANCEL Compiler directive has the the same effect as the RESIDENT clause.
Parent topic: Identification Division


Environment Division

Supported ACUCOBOL-GT Environment Division elements when compiling for ACU compatibility.
  • The File-Control Paragraph
Parent topic: ACUCOBOL-GT Syntax Extensions


The File-Control Paragraph

The File-Control paragraph contains descriptions of the physical aspects of files used in a program.

Format 3 - Indexed Files

SELECT [OPTIONAL] file-name

 ASSIGN TO [DYNAMIC] [device] [file-spec]
           [EXTERNAL]

   [WITH {COMPRESSION} ... ]
         {ENCRYPTION}

     [ORGANIZATION IS] INDEXED.

General Rules

  1. The WITH ENCRYPTION phrase specifies that record encryption is required on the file. Encryption is currently available with the Vision indexed file system only. Encryption takes effect only when the file is initially created or re-created via the OPEN statement.

  2. The WITH COMPRESSION phrase specifies that record compression is required on the file. This phrase must be specified before the ORGANIZATION IS INDEXED phrase. Compression is currently available with the Vision indexed file system only. The WITH COMPRESSION phrase takes effect only when the file is initially created or re-created via the OPEN statement.

Parent topic: Environment Division


Data Division

Supported ACUCOBOL-GT Data Division elements and types when compiling for Acu compatibility.
  • SYNCHRONIZED Clause
  • USAGE Clause
Parent topic: ACUCOBOL-GT Syntax Extensions


SYNCHRONIZED Clause

The SYNCHRONIZED clause specifies elementary item alignment on word boundaries of the computer's memory.

General Format

{SYNCHRONIZED}  [LEFT ]
{SYNC        }  [RIGHT]

Syntax Rules

  1. SYNC is an abbreviation of SYNCHRONIZED.
  2. The SYNCHRONIZED clause can be used for elementary items only.
  3. A SYNCHRONIZED clause may not be used with an external floating-point data item.

General Rules

  1. The SYNCHRONIZED clause is used to specify that word boundary alignment should be performed for the data item. Normally, data contained in records is aligned on byte boundaries. Only data items whose underlying representation is binary are affected by the SYNCHRONIZED clause.
  2. The SYNCHRONIZED clause causes the data item to be placed on a boundary that is an even multiple of the natural size of the data item. The following table lists the boundary used for each size of data item:
    Data Size | Boundary Multiple
    1-2 | 2
    3-4 | 4
    5-8 | 8
  3. A group item that contains a synchronized data item is also synchronized on the same boundary. Regardless of the effects of synchronization, a group item always begins at the same location as its first elementary data item.
  4. Synchronization may result in the creation of filler bytes. These bytes count in the size of any group item that contains them. For this reason, a group item that contains synchronized data may be larger than the total size of its elementary items.
  5. Level 01 and level 77 data items that are not otherwise synchronized are placed on a boundary that can be selected at compile time. By default, these items are placed at word boundaries that are divisible by two.
  6. Level 01 and level 77 data items that are POINTER or COMP-5 items are automatically synchronized to an appropriate machine boundary, regardless of any compile-time settings. All C-style data types are automatically synchronized regardless of their level. This allows you to pass these items safely to C subroutines without having to concern yourself with alignment.
  7. A compile-time (-Dl) option can be used to cut back the maximum boundary multiple. For example, -Dl4 would cause items of size 1 or 2 to be synchronized on 2-byte boundaries, and all other items synchronized on 4-byte boundaries. If this option is not specified, then the maximum boundary multiple depends on the compatibility mode being used:
    Mode | Boundary Limit
    VAX COBOL | 8
    RM/COBOL | 2
    ICOBOL | 1

    A limit of 1 effectively inhibits synchronization.

  8. The LEFT and RIGHT options are treated as commentary. They have the same effect as a SYNCHRONIZED clause without either option.
Parent topic: Data Division


USAGE Clause

The USAGE clause specifies the format of a data item in computer memory or in a file record.

In some circumstances, a data item's file-record format may differ from its computer-memory format as specified by the USAGE clause. This can occur when non-COBOL file systems with different data storage formats are being accessed through an interface. For example, Acu4GL uses SQL to access non-COBOL file systems, and in the process a translation occurs on the data.

Note: There are numerous compiler options for affecting data storage behavior. See Data Storage Options in the ACUCOBOL-GT Compatibility section.

General Format

[ USAGE IS ] {COMPUTATIONAL                                 }
             {COMP                                          }
             {COMPUTATIONAL-1                               }
             {COMP-1                                        }
             {COMPUTATIONAL-2                               }
             {COMP-2                                        }
             {COMPUTATIONAL-3                               }
             {COMP-3                                        }
             {COMPUTATIONAL-4                               }
             {COMP-4                                        }
             {COMPUTATIONAL-5                               }
             {COMP-5                                        }
             {COMPUTATIONAL-6                               }
             {COMP-6                                        }
             {COMPUTATIONAL-X                               }
             {COMP-X                                        }
             {COMPUTATIONAL-N                               }
             {COMP-N                                        }
             {BINARY                                        }
             {PACKED-DECIMAL                                }
             {DISPLAY                                       }
             {INDEX                                         }
             {POINTER                                       }
             {FLOAT                                         }
             {DOUBLE                                        }
             {SIGNED-SHORT                                  }
             {UNSIGNED-SHORT                                }
             {SIGNED-INT                                    }
             {UNSIGNED-INT                                  }
             {SIGNED-LONG                                   }
             {UNSIGNED-LONG                                 }
             {HANDLE [ OF {WINDOW                       } ] }
                          {SUBWINDOW                    }
                          {FONT [font-name]             }
                          {control-type                 }
                          {THREAD                       }
                          {MENU                         }
                          {VARIANT                      }
                          {LAYOUT-MANAGER [layout-name] }

Syntax Rules

  1. The column on the left shows the accepted abbreviations for the terms on the right:
    COMP      COMPUTATIONAL

COMP-1    COMPUTATIONAL-1

COMP-2    COMPUTATIONAL-2

COMP-3    COMPUTATIONAL-3

COMP-4    COMPUTATIONAL-4

COMP-5    COMPUTATIONAL-5

COMP-6    COMPUTATIONAL-6

COMP-X    COMPUTATIONAL-X

COMP-N    COMPUTATIONAL-N
  2. A USAGE clause may be used in any data description entry except those with level-numbers 66, 78, and 88.
  3. A USAGE clause may not be used with an external floating-point data item.
  4. If a USAGE clause is in the data description entry for a group item, then any USAGE clauses that appear for subordinate entries must be of the same type.
  5. The PICTURE string of a COMP, COMP-1, COMP-2, COMP-3, COMP-4, COMP-5, COMP-6, BINARY, or PACKED-DECIMAL item can contain only the symbols "9", "S", "V", and "P". COMP-6 items may not use the "S" symbol.
  6. The PICTURE string of a COMP-X or COMP-N item may contain only all "9" symbols or all "X" symbols.
  7. The data description entry for a USAGE IS INDEX data item cannot contain any of the following clauses: BLANK WHEN ZERO, JUSTIFIED, PICTURE, and VALUE IS.
  8. Level 88 items may not be specified for a USAGE IS INDEX data item.
  9. The data description entry for a USAGE IS POINTER data item cannot contain any of the following clauses: BLANK WHEN ZERO, JUSTIFIED, or PICTURE. A POINTER data item may have a value clause specified for it, but the value must be the word NULL.
  10. The data description entry for a USAGE IS FLOAT or a USAGE IS DOUBLE data item cannot contain any of the following clauses: BLANK WHEN ZERO, JUSTIFIED, or PICTURE. FLOAT or DOUBLE data items may have a value clause. The value may be a floating point literal, a numeric literal, or the word ZERO. Here is an example of a Working-Storage Section data item:
    01  F-DATA-1  USAGE IS FLOAT
              VALUE IS 3.97E+24.
  11. The following are collectively called the "C-style" data types: SIGNED-INT, UNSIGNED-INT, SIGNED-SHORT, UNSIGNED-SHORT, SIGNED-LONG, UNSIGNED-LONG. These data types are similar to the data types found in the C programming language.

    The data description entry for a C-style data type cannot contain any of the following clauses: BLANK WHEN ZERO, JUSTIFIED, or PICTURE.

  12. Control-type is one of the graphical control type names known to the compiler, such as LABEL or ENTRY-FIELD, or the name of an ActiveX, COM, or .NET control.
  13. The data description entry for USAGE HANDLE data items may not contain any of the following clauses: BLANK WHEN ZERO, JUSTIFIED, or PICTURE. If it contains a VALUE clause, the value specified must be the word NULL.
  14. Font-name is one of the following identifiers: DEFAULT-FONT, FIXED-FONT, TRADITIONAL-FONT, SMALL-FONT, MEDIUM-FONT, LARGE-FONT.
  15. It should be noted that either the "-Df" option or the "-Cv" option will cause the compiler to treat COMP-1 and COMP-2 as FLOAT and DOUBLE, respectively. For more information, see section 5.4 in Transitioning to ACUCOBOL-GT.
  16. Layout-name is the name of one of the system's standard layout managers. Currently, this can only be LM-RESIZE.

General Rules

  1. A USAGE clause written at a group level applies to every elementary item subordinate to that group item.
  2. If no USAGE clause is specified, then USAGE IS DISPLAY is implied.
  3. The internal format of a USAGE IS DISPLAY item is ASCII.
  4. The format of an index item is 32-bit signed binary. Its size is always four, and it holds a range of values from -2147483647 to 2147483647. When using a compile switch for compatibility with versions prior to 6.0.0 (-Z52 for example) an index item is 16-bit unsigned binary, size is always two, and it holds values from 0 to 65535.
  5. The format of a COMP-1 data item is 16-bit signed binary. The legal values range from -32767 to 32767. The size of the data item is always two bytes, and the high-order half of the data is stored in the leftmost byte. The PICTURE string that describes the item is irrelevant. Unlike other numeric data types, a size error will occur on a COMP-1, COMP-X, or COMP-N data item only when the value exceeds the physical storage of the item (in other words, the number of "9"s in the item's PICTURE is ignored when size error is determined).
  6. For COMP-2 (decimal storage), each digit is stored in one byte in decimal format. If the value is signed, then an additional trailing byte is allocated for the sign. The storage of COMP-2 is identical with USAGE DISPLAY with the high-order four bits stripped from each byte.
  7. For COMP-3 (packed-decimal storage), two digits are stored in each byte. An additional half byte is allocated for the sign, even if the value is unsigned. The sign is placed in the rightmost position, and its value is 0x0D for negative; all other values are treated as positive (but see rule 18 below). The size of an item (including one for the implied sign) is divided by two to arrive at its actual size (rounding fractions up).
  8. The format of a COMP-4 item is two's-complement binary (the value without its decimal point). COMP-4 values are stored in a machine-independent format. This format places the highest-order part of the value in the leftmost position and follows down to the low-order part in the rightmost position. The number of bytes a data item occupies depends on the number of "9"s in its PICTURE and on the presence of various compile-time options. For example, you may include more than eighteen "9"s only if your program has been compiled for 31-digit support. This is summarized in the following table:
    # of "9"s | Default | -D1 | -Dm | -D7
    1-2 | 2 | 1 | 1 | 1
    3-4 | 2 | 2 | 2 | 2
    5-6 | 4 | 4 | 3 | 3
    7 | 4 | 4 | 4 | 3
    8-9 | 4 | 4 | 4 | 4
    10-11 | 8 | 8 | 5 | 5
    12 | 8 | 8 | 6 | 5
    13-14 | 8 | 8 | 6 | 6
    15-16 | 8 | 8 | 7 | 7
    17-18 | 8 | 8 | 8 | 8
    19 | 12 | 12 | 9 | 8,9
    20 | 12 | 12 | 9 | 9
    21 | 12 | 12 | 9 | 9
    22 | 12 | 12 | 10 | 10
    23 | 12 | 12 | 10 | 10
    24 | 12 | 12 | 11 | 10,11
    25 | 12 | 12 | 11 | 11
    26 | 12 | 12 | 11 | 11
    27 | 12 | 12 | 12 | 12
    28 | 12 | 12 | 12 | 12
    29 | 16 | 16 | 13 | 13
    30 | 16 | 16 | 13 | 13
    31 | 16 | 16 | 13 | 13
    Note: Where two values are given, the smaller value applies to unsigned data items, and the larger value applies to signed data items.
  9. COMP-5 is primarily used to communicate with external programs that expect native data storage.

    The format of a COMP-5 data item is identical to a COMP-4 data item, except that the data is stored in a machine-dependent format. It is stored in an order that is natural to the host machine. For example, a PIC S9(9) COMP-5 data item is equivalent to a 32-bit binary word on the host machine, and a PIC S9(20) COMP-5 item is equivalent to a 64-bit word.

    Note: Data stored in a COMP-5 field may not be transportable to other machines because different machines have different natural byte-orderings. On many machines (68000, most RISC), COMP-5 is identical to COMP-4. On others (80x86, VAX), it is the same with the bytes in the reverse order.

    A VALUE clause for a COMP-5 data item is stored in a machine-independent format and is adjusted when it is loaded into the data item. This ensures that the value is the same from machine to machine.

    On arithmetic and non-arithmetic stores into COMP-5 items, if truncation is required, by default ACUCOBOL-GT truncates in decimal to the number of digits given in the PICTURE clause. You can use the "--TruncANSI" compiler option to force truncation in binary to the capacity of the allocated storage of COMP-5 items. The "-Dz" and "--noTrunc"options also effects truncation. See Book 1, section 2.1.9, "Data Storage Options," for more information.

    Level 01 and level 77 data items that are COMP-5 are automatically synchronized to an appropriate machine boundary, regardless of any compile-time settings. This allows you to pass these items safely to C subroutines without having to concern yourself with alignment.

    If COMP-5 is used with a PIC X(n) data item and assigned an alphanumeric value, the results are undefined. For example, the following code fragment causes NUM to have an undefined number and the resulting value for the last line will be "100":

    NUM PIC X(5) COMP-5.
ALPHANUM PIC X(9).
MOVE "ABC" TO NUM.
MOVE "1,000" TO NUM.
MOVE ALPHANUM TO NUM.
MOVE "100" TO NUM.

    A PIC X(n) data item used with COMP-5 cannot be signed.

  10. The format of a COMP-6 item is identical to a COMP-3 item except that it is unsigned and no space is allocated for the sign. If the number of digits is odd, a zero is added to the left end of the number before it is packed. Thus there are two decimal digits per byte, and the actual size of the item is determined by dividing its PICTURE size by two and rounding up.
  11. A COMP-X data item must be described with a picture string consisting of only "9" or only "X" symbols. In either case, the data item is treated as an unsigned binary integer, with internal storage similar to that of a COMP-4 data item. If "X" symbols are used to describe the item, then the number of bytes allocated to the item is the same as the number of "X" symbols in the picture string. If "9" symbols are used instead, then the number of bytes allocated is the least number of bytes required to hold a number of that size. For example, a "PIC 99" data item will be allocated 1 byte; a "PIC 9(9)" data item will be allocated 4 bytes.

    Regardless of the number of "9" symbols in the item's picture string, the maximum value that can be stored in a COMP-X item is determined by the number of bytes allocated to it (to a maximum of 18 digits, or a maximum of 31 digits if 31-digit support is in effect). For example, a COMP-X item consisting of 1 byte can hold a range of numbers from 0 to 255. A 2-byte COMP-X number can hold from 0 to 65535. A size error occurs on a COMP-X item only when the value is larger than the data item can physically hold. When COMP-X is used with a PIC(X) data item, the maximum is PIC X(8). (This maximum is increased to PIC X(16) when 31-digit support is in effect.)

  12. A COMP-N data item is identical to a COMP-X data item, except that the data is stored in the host machine's native format, instead of machine-independent format.
  13. Data items described as PACKED-DECIMAL are identical to COMP-3. You can cause unsigned PACKED-DECIMAL to be treated as COMP-6 by using a compile-time option.
  14. By default, a BINARY data item is identical to a COMP-4 data item. The compile-time option "-D5" treats BINARY data items as COMP-5 items instead.
  15. In VAX/COBOL compatibility mode, a COMP data item is the same as COMP-4 and is treated as binary data. In RM/COBOL compatibility mode, COMP is the same as COMP-2. You can use compile-time options to change the default behavior.
  16. A pointer data item is treated as an unsigned numeric data item. The internal format differs for each machine. Pointer data items are intended to hold addresses of other data items (see the SET Statement.) A pointer data item may have a VALUE clause specified for it, but the specified value must be the word NULL. This indicates that the pointer does not currently point to any item. If a pointer is not explicitly given an initial value, then its initial value is arbitrary.

    Pointer data items occupy 8 bytes. This provides enough space to hold an address on a 64-bit machine. If you are on a smaller machine, the runtime uses only the first 4 bytes of pointer data items (the trailing 4 bytes remain in memory, they are just left unused). You can use the "-Dw" compile-time option to adjust the space allocated to pointer data items. You can do this to conserve storage if you know you will not be running on a 64-bit machine.

    Pointers may be used in conditional expressions, where they can be compared to each other or to the value NULL. A comparison involving a pointer must be either "equals" or "not equals" ("greater" and "less than" comparisons are not allowed).

    Level 01 and level 77 data items that are POINTER items are automatically synchronized to an appropriate machine boundary, regardless of any compile-time settings. This allows you to pass these items safely to C subroutines without having to concern yourself with alignment.

    Except for the automatic synchronization, USAGE POINTER data items are treated in all respects like USAGE UNSIGNED-LONG data items. This handles all current machines correctly. This behavior may change to meet the requirements of some future machine.

  17. Floating-point data items are stored in a machine-dependent format. USAGE FLOAT items have 4 bytes allocated to them. USAGE DOUBLE items occupy 8 bytes.

    Level 01 and level 77 data items that are USAGE FLOAT or DOUBLE are automatically synchronized to appropriate machine boundaries, regardless of any compile-time settings. This allows you to pass these items safely to C subroutines without having to concern yourself with alignment.

  18. The ANSI definition of COBOL does not state how signs should be stored in numeric fields (except for the case of SIGN IS SEPARATE). ACUCOBOL-GT lets you select alternate sign-storage conventions by using the compile-time options "-Dca", '-Dcb", "-Dci", "-Dcm", "-Dcn", "-Dcr", and "-Dcv". Specifying a sign-storage convention is sometimes useful when you are exporting and importing data. For additional information, see the User's Guide, section 2.2.10, "Data Storage Options."

    The storage convention affects how data appears in USAGE DISPLAY, COMP-2, and COMP-3 data types. In USAGE DISPLAY, standard ASCII storage, if the sign is incorporated into a digit position, the digit is encoded according to the following table:

    USAGE DISPLAY

    DIGIT VALUE -Dca,

    -Dcb,

    -Dcm,

    -Dcr

    Positive

            -Dci,

    -Dcn

    Positive

            -Dca,

    -Dci,

    -Dcn

    Negative

            -Dcb

    Negative

            -Dcm

    Negative

            -Dcr

    Negative

    0 '0' '{' '}' '@' 'p' ' ' (space)
    1 '1' 'A' 'J' 'A' 'q' '!'
    2 '2' 'B' 'K' 'B' 'r' '"' (double-quote)
    3 '3' 'C' 'L' 'C' 's' '#'
    4 '4' 'D' 'M' 'D' 't' '$'
    5 '5' 'E' 'N' 'E' 'u' '%'
    6 '6' 'F' 'O' 'F' 'v' '&'
    7 '7' 'G' 'P' 'G' 'w' ''' (single-

    quote)

    8 '8' 'H' 'Q' 'H' 'x' '('
    9 '9' 'I' 'R' 'I' 'y' ')'
    Note:

    For import compatibility with some systems that do not have the symbols "{" and "}", the symbols "[" and "?" are considered equivalent to "{", and the symbols "]", ":", and "!" are considered equivalent to "}", when an item with USAGE DISPLAY is read.

    The next two tables show sign representation for COMP-2 and COMP-3 items, when you are using the "-Dca", "-Dcb", "-Dci", "-Dcm", "-Dcn", "-Dcr", and "-Dcv" storage conventions. For COMP-2, the trailing byte is reserved for the sign. For COMP-3, the trailing half-byte is reserved for the sign.

    USAGE COMP-2

    -Dca Positive | x'0B'
    -Dcb/-Dci/-Dcm/-Dcn/-Dcr Positive | x'0C'
    -Dca/-Dcb/-Dci/-Dcm/-Dcn/-Dcr Negative | x'0D'

    USAGE COMP-3

    -Dca Positive | x'0F'
    -Dcb/-Dci/-Dcm/-Dcr Positive | x'0C'
    -Dca/-Dcb/-Dci/-Dcm/-Dcr Negative | x'0D
    -Dca/-Dcb/-Dci/-Dcm/-Dcr Unsigned | x'0F'
    -Dcv Unsigned | x'0C'
  19. There are six USAGE types for integer data that simplify communications with other programming languages such as C. These types are designed to provide a portable method for handling machine-dependent data. The six USAGE types handle three classes of machine data: "short words," "words," and "long words." These three correspond to the C data types: "short", "int", and "long". There are signed and unsigned versions of each of these data types.

    These USAGE types are specified without a PICTURE clause (like USAGE INDEX and POINTER).

    The names of the types are:

    SIGNED-SHORT | UNSIGNED-SHORT
    SIGNED-INT | UNSIGNED-INT
    SIGNED-LONG | UNSIGNED-LONG

    Each of these represents a binary value that is stored using the machine's native byte ordering. Since there is no PICTURE phrase, size checking for these items is performed only on byte boundaries. These data types are automatically SYNCHRONIZED.

    The unusual characteristic of these data types is that their size is not necessarily set at compile time. Instead, the size of these items is determined at execution time. This allows them to match the working characteristics of the host machine. For example, a SIGNED-LONG data item will contain 64 bits when run on a DEC Alpha machine, but it will have 32 bits when run on an Intel 80486-based machine. This lets you write one program that can communicate effectively with an external routine written in another language (such as C), regardless of the target environment.

    In order to lay out memory, the compiler assigns a maximum size to each of these data types. This is the number of bytes that the item will occupy. At run time, these items may be reduced in size to match the host machine's characteristics. Any remaining bytes are then treated as FILLER. The "-Dw" compile option (see the User's Guide section 2.2.10, "Data Storage Options.") determines the maximum size of these types:

    USAGE -Dw32 -Dw64
    SIGNED-SHORT

    UNSIGNED-SHORT

            2* 2*
    SIGNED-INT

    UNSIGNED-INT

            4 4
    SIGNED-LONG

    UNSIGNED-LONG

            4* 8

    Table entries marked with an asterisk indicate fixed-size items. A fixed-size item is the same size regardless of the target machine. Entries without an asterisk are variable in size. These items will occupy space up to the number of bytes listed in the table.

    Note: The sizes listed in the table above cover all current and anticipated machines that run ACUCOBOL-GT. Future architectures may require changes to the maximum size assigned to these items.

    In the execution environment, these items act in all ways as if they were fixed-size data items of the appropriate size.

    For example, the following code fragment:

       77  LONG-1         SIGNED-LONG.
   77  SIZE-1         PIC 9.

   SET SIZE-1 TO SIZE OF LONG-1.
   DISPLAY SIZE-1.

    will print "4" when run on a 32-bit machine, but it will print "8" when run on a 64-bit machine.

    Examples

    In the following examples, each byte is represented by two hexadecimal digits or by a single quoted character. Each value is shown in the various formats. Also shown is USAGE DISPLAY using the various SIGN options. The following examples use the default ACUCOBOL-GT sign-storage conventions.

    PIC 9(3) VALUE 123.
TRAILING            '1'   '2'   '3'
TRAILING SEPARATE   '1'   '2'   '3'
LEADING             '1'   '2'   '3'
LEADING SEPARATE    '1'   '2'   '3'
COMP-1                    00    7B
COMP-2              01    02    03
COMP-3                    12    3F
COMP-4                    00    7B
COMP-5(68000)             00    7B
COMP-5(8086)              7B    00
COMP-6                    01    23

PIC S9(3) VALUE -123.
TRAILING                 '1'   '2'   'L'
TRAILING SEPARATE  '1'   '2'   '3'   '-'
LEADING                  'J'   '2'   '3'
LEADING SEPARATE   '-'   '1'   '2'   '3'
COMP-1                         FF    85
COMP-2             01    02    03    0D
COMP-3                         12    3D
COMP-4                         FF    85
COMP-5(68000)                  FF    85
COMP-5(8086)                   85    FF
COMP-6             illegal

PIC 9(5)V9 VALUE 12345.6.
TRAILING             '1'   '2'   '3'   '4'   '5'   '6'
TRAILING SEPARATE    '1'   '2'   '3'   '4'   '5'   '6'
LEADING              '1'   '2'   '3'   '4'   '5'   '6'
LEADING SEPARATE     '1'   '2'   '3'   '4'   '5'   '6'
COMP-1               illegal
COMP-2               01    02    03    04    05    06
COMP-3                           01    23    45    6F
COMP-4                           00    01    E2    40
COMP-5(68000)                    00    01    E2    40
COMP-5(8086)                     40    E2    01    00
COMP-6                                 12    34    56

PIC S9(5)V9 VALUE -12345.6.
TRAILING                '1'  '2'  '3'  '4'  '5'  '0'
TRAILING SEPARATE  '1'  '2'  '3'  '4'  '5'  '6'  '-'
LEADING                 'J'  '2'  '3'  '4'  '5'  '6'
LEADING SEPARATE   '-'  '1'  '2'  '3'  '4'  '5'  '6'
COMP-1             illegal
COMP-2             01   02   03   04   05   06   0D
COMP-3                            01   23   45   6D
COMP-4                            FF   FE   1D   C0
COMP-5(68000)                     FF   FE   1D   C0
COMP-5(8086)                      C0   1D   FE   FF
COMP-6             illegal
  20. HANDLE data items make up their own data class and category in COBOL. Internally they are stored as integer values, and behave like numbers when used. A HANDLE data item is normally used to store the handle of a dynamically created object such as a floating window or a graphical control.

    HANDLE data items come in two forms: typed and generic. You create a generic handle when you omit the OF phrase. You create a typed handle when you include the OF phrase.

  21. You may use HANDLE data items only when explicitly allowed, or as part of a MOVE statement, a CALL statement (as a parameter), or in a Boolean expression.
  22. Generic handles may be used in any situation where handles are allowed. When you use a generic handle as the source of a MODIFY statement, you will not be able to use any control-specific property or style names in that statement. This is because the generic handle could be associated with any type of control. In this case, the compiler cannot determine which set of style and property names is valid.
  23. Typed handles may be used in statements where any handle is allowed, or when you are referring to an object of a matching type. For example, a HANDLE OF WINDOW cannot be used as the handle in a DISPLAY LABEL statement. Instead, you must use either a generic handle or a HANDLE OF LABEL. Typed handles allow the compiler to recognize associated style and property names when appropriate. Typed handles also improve the readability of your program by providing additional information about the intended use of the handle, in addition to providing compile-time checking to ensure that you are using the handles in appropriate situations.
  24. Handles may be used in comparisons. There are only two meaningful comparisons: checking for equality or inequality to NULL, and comparison to another handle data item. A handle value of NULL always indicates an invalid handle.
  25. Handles are stored internally as 4-byte binary integers. This information can be useful when you are debugging a program (you can examine the values of handles in the debugger). You should not rely on this definition in your program, however, because it is subject to change in the future.
  26. Handle data items are automatically SYNCHRONIZED on a 4-byte boundary. Note that this occurs regardless of the setting of the "-Dl" compile-time option (which limits the amount of synchronization). The runtime system requires this level of alignment to avoid generating bus errors on some machines.
  27. If font-name is specified, then the data item described by the USAGE clause is initialized at program startup with the corresponding font handle. This acts identically to placing the statement:
    ACCEPT data-item FROM STANDARD OBJECT "font-name"

    at the beginning of your program, where data-item is the data item described by the USAGE clause and font-name is the same as font-name in the USAGE clause.

Parent topic: Data Division
Related tasks
Data Storage Options


Procedure Division

Supported ACUCOBOL-GT extensions to Procedure Division statements and elements when compiling for Acu compatibility.
  • Procedure Division Statements
    Supported ACUCOBOL-GT extensions to Procedure Division statements and elements when compiling for Acu compatibility.
Parent topic: ACUCOBOL-GT Syntax Extensions


Procedure Division Statements

Supported ACUCOBOL-GT extensions to Procedure Division statements and elements when compiling for Acu compatibility.
  • ACCEPT FROM
    ACUCOBOL-GT ACCEPT 3 format, which returns selected data from the operating environment.
  • ACCEPT FROM ENVIRONMENT
    ACUCOBOL-GT format 5 ACCEPT extension.
  • INSPECT
    ACUCOBOL-GT extension to the INSPECT statement.
  • SET ENVIRONMENT
    ACUCOBOL-GT format 6 SET extension.
Parent topic: Procedure Division


ACCEPT FROM

ACUCOBOL-GT ACCEPT 3 format, which returns selected data from the operating environment.

Syntax

ACCEPT dest-item FROM {CENTURY-DATE}
                                            {CENTURY-DAY }

General Rules

  1. The Format 3 ACCEPT statement causes information to be transferred to dest-item according to the rules for the MOVE statement.
  2. ACCEPT FROM CENTURY-DATE returns the current date in the format YYYYMMDD (year/month/day). ACCEPT FROM DATE YYYYMMDD is equivalent to ACCEPT FROM CENTURY-DATE. ACCEPT FROM CENTURY-DAY returns the current date in the format YYYYDDD (year/day-of-year). ACCEPT FROM DAY YYYYDDD is equivalent to ACCEPT FROM CENTURY-DAY. These are the same as ACCEPT FROM DATE and ACCEPT FROM DAY, except that the year field is 4 digits instead of 2 digits.

    The compiler option -Zy lets you treat ACCEPT FROM DATE as ACCEPT FROM CENTURY-DATE, and ACCEPT FROM DAY as ACCEPT FROM CENTURY-DAY. For details, see the ACUCOBOL-GT User's Guide documentation.

Parent topic: Procedure Division Statements


ACCEPT FROM ENVIRONMENT

ACUCOBOL-GT format 5 ACCEPT extension.

Format 5

ACCEPT dest-item FROM {ENVIRONMENT} env-name

      [ ON EXCEPTION statement-1 ]

      [ NOT ON EXCEPTION statement-2 ]

      [ END-ACCEPT ]

Syntax Rules

  1. dest-item is a data item that receives the accepted data. It must be USAGE DISPLAY unless the WITH CONVERSION phrase is also used.
  2. EXCEPTION and ESCAPE are equivalent.
  3. A NOT AT END phrase may not be paired with an ON EXCEPTION phrase, nor may a NOT ON EXCEPTION phrase be paired with an AT END phrase.
Note: ACCEPT FROM CONFIGURATION is not supported.

General Rules

  1. A Format 5 ACCEPT statement returns values from the user's environment. Env-name is the name of the environment setting whose value is to be returned. The value returned from this item is moved to dest-item.
    Note: ACUCOBOL-GT allows you to specify an ACUCOBOL-GT runtime configuration variable for Env-name. This COBOL system does not support specifying runtime configuration variables.
Parent topic: Procedure Division Statements


INSPECT

ACUCOBOL-GT extension to the INSPECT statement.

Formats 1 and 2

Formats 1 and 2 are identical to MF COBOL. Refer to the Micro Focus COBOL Language Reference section or the ACUCOBOL-GT Reference manual.

Format 3

INSPECT source

    [ TALLYING counter FOR TRAILING comp-value ]
    [ REPLACING TRAILING target BY replace ]

TRAILING is an ACUCOBOL-GT extension. It is used to find the rightmost occurrence, or set of contiguous occurrences, in the source data item. If a TRAILING occurrence is found, a right to left scan of the source data item is made to find contiguous occurrences.

If the TRAILING phrase is present, the REPLACING option causes all contiguous occurrences of target to be replaced by replace, provided that these occurrences end in the rightmost character position of source.

Comp-value and Target must be single character items.

Parent topic: Procedure Division Statements
Related information
The INSPECT Statement


SET ENVIRONMENT

ACUCOBOL-GT format 6 SET extension.

FORMAT 6

SET { env-name TO env-value } ...
    {ENVIRONMENT  }
Note: The CONFIGURATION option that is supported in ACUCOBOL-GT is not supported in Studio Enterprise Edition.

Syntax Rules

  1. env-name is a nonnumeric literal or data item.
  2. env-value is a USAGE DISPLAY numeric or nonnumeric literal or data item. If numeric, it must be an integer.

General Rules

  1. A format 6 SET statement is used to set environment variables. ACUCOBOL-GT maintains a set of configuration variables that can affect various aspects of the runtime system. These variables can be initially set in the ACUCOBOL-GT runtime configuration file described in Appendix H of the ACUCOBOL-GT Appendices Manual. The Format 6 SET statement can be used to modify these values at runtime.
    Note: ACUCOBOL-GT allows you to set runtime configuration variables and to change their values. This COBOL system does not support this functionality.
Parent topic: Procedure Division Statements


Data General Interactive COBOL V1.3 Syntax Support

The syntax listed here is accepted by your COBOL system purely for compatibility with version 1.3 of Data General Interactive COBOL. Many features found in Data General Interactive COBOL exist already in this COBOL implementation. These are documented in your COBOL Language Reference. Some of the compatibility syntax listed in this chapter is identical to standard COBOL syntax, but behaves differently if you set the DG Compiler directive when you submit your source code to your COBOL system. See the Data General Interactive Programmer's Reference Manual for a full description of the Data General syntax.

Note: Setting the DG Compiler directive does not affect the reserved words at all.
  • Environment Division
  • Data Division
  • Procedure Division
Parent topic: Additional Dialect Support
Related concepts
The DG Directive
Related reference
DG
Related information
COBOL Language Reference


Environment Division

  • Switch-Names
  • File-Name on Disk
  • The DATA SIZE Clause
  • The INDEX SIZE Clause
  • Duplicate Alternate Keys
  • Alternate Keys
  • I-O-Control Paragraph
Parent topic: Data General Interactive COBOL V1.3 Syntax Support


Switch-Names

In addition to the switches 0 to 8 supported by COBOL, another form of switch-name can be used. It is an upper-case letter in the range A to Z.

These letters are mapped to switches 0 to 25, so at run time you should use the appropriate digit on your command line and not the letter itself.

For example, to turn on switch J you would put:

+9 filename

after the run command. You cannot, however, specify a run-time switch in a CALL statement, as in:

CALL "PROG.INT/A"

because this is not supported.

Parent topic: Environment Division


File-Name on Disk

When you assign a file to disk, the file on disk is named in upper case letters, regardless of whether the name you specify is in upper- or lowercase letters.

Parent topic: Environment Division


The DATA SIZE Clause

You can use the following clause in a SELECT statement:

It is treated as documentary.

Parent topic: Environment Division


The INDEX SIZE Clause

You can use the following clause in a SELECT statement for a relative or indexed file:

It is treated as documentary.

Parent topic: Environment Division


Duplicate Alternate Keys

If you specify the DG Compiler directive when you submit your source files to your COBOL system, you can have duplicate alternate keys in an indexed file regardless of whether or not you have specified the DUPLICATES phrase.

Parent topic: Environment Division


Alternate Keys

If you specify the DG Compiler directive when you submit your source files to your COBOL system, alternate keys can occupy the same area as primary keys.
Note: Note , however, that under UNIX, if you issue START and/or READ statements, you will receive an error message. This will not stop your program running, but is merely to inform you that you might ncounter problems with that coding.
Parent topic: Environment Division


I-O-Control Paragraph

If you specify the DG Compiler directive when you submit your source files to your COBOL system, the SAME AREA phrase is treated as equivalent to the SAME RECORD AREA phrase.

Parent topic: Environment Division


Data Division

  • VALUE Clause
  • The Screen Section
Parent topic: Data General Interactive COBOL V1.3 Syntax Support


VALUE Clause

A numeric literal can be used in a VALUE clause in the data description of a nonnumeric data item.

Parent topic: Data Division


The Screen Section

If you specify the DG Compiler directive when you submit your source files to your COBOL system, the HIGHLIGHT option when used with TO or USING items highlights all the non-protected areas of the screen.

Parent topic: Data Division


Procedure Division

  • The CALL Statement
  • The COPY INDEXED Statement
  • The DISPLAY Statement
  • File Sharing Syntax
  • The OPEN Statement
  • The READ Statement
Parent topic: Data General Interactive COBOL V1.3 Syntax Support


The CALL Statement

General Format

The following format of the CALL statement is supported:

General Rules

  1. This format is treated as equivalent to a CHAIN statement.
Parent topic: Procedure Division


The COPY INDEXED Statement

If you specify the DG Compiler directive when you submit your source files to your COBOL system, the COPY verb can be followed by the word INDEXED. The word INDEXED is treated as documentary.

Parent topic: Procedure Division


The DISPLAY Statement

If you specify the DG Compiler directive when you submit your source files to your COBOL system, the behavior of the DISPLAY statement with the WITH NO ADVANCING option is changed to be as in Data General Interactive COBOL.

Parent topic: Procedure Division


File Sharing Syntax

If you specify the DG Compiler directive when you submit your source files to your COBOL system, the default lock mode for both ISAM and relative files is MANUAL WITH LOCK ON MULTIPLE RECORDS.

Parent topic: Procedure Division


The OPEN Statement

The OPEN verb can be followed by the keyword EXCLUSIVE. It is treated as equivalent to the WITH LOCK phrase.

Parent topic: Procedure Division


The READ Statement

The file-name and the optional word RECORD can be followed by the keyword LOCK. It causes the READ statement to acquire a lock on the record read.

This does not apply to line sequential files.

Parent topic: Procedure Division


DOS/VS COBOL Support

This Micro Focus COBOL system provides limited support for DOS/VS COBOL syntax. This COBOL system provides no distinction for the VS COBOL II dialect as it is implemented on VSE/ESA as opposed to MVS and CMS.

A directive, DOSVS, is supplied to enable all DOS/VS COBOL reserved words. The Compiler directive FLAG"DOSVS" will flag any syntax that is not part of DOS/VS COBOL.

DOS/VS COBOL is identical to OS/VS COBOL, apart from the differences below:

If the ASSIGN (EXTERNAL) Compiler directive has been set, the variable to be defined in the SET command is either:

  1. all of the text following the last hyphen, if it is not one of P, R, S, SR or AS, or;
  2. that part of the name preceding the first hyphen.

In the Special Registers table (see the section Special Registers), an entry should be made for DOS/VS COBOL as follows:

Special Register:

COM-REG

Implicit Data Description Picture:

PIC X(11)

Usage:

In DOS/VS COBOL, this field corresponds to bytes 12 through 22 of the DOS Communication Region. In the Micro Focus COBOL system, however, the data area is simply allocated, is initialized, and has no special meaning attached to any data that is placed in it by the program.

Parent topic: Additional Dialect Support
Related information
Special Registers


Microsoft COBOL V1.0 and V2.0 Syntax Support

The Microsoft syntax listed in this chapter is accepted by your COBOL system purely for compatibility with IBM 1.0 syntax and Microsoft V2.0 syntax. Many features found in Microsoft COBOL exist already in COBOL. Some of the compatibility syntax listed in this chapter is identical to standard COBOL syntax, but behaves differently if you set the MS Compiler directive when you submit your source code to your COBOL system. Other Microsoft syntax is available only if this directive is set. See your IBM COBOL 1.0 manual and the Microsoft COBOL V2.0 manual for further information on the Microsoft syntax. This manual covers IBM COBOL V1.0; where syntax is a Microsoft V2.0 extension it is explicitly indicated.

  • Special Registers LIN and COL
  • Environment Division
  • Data Division
  • Procedure Division
  • Microsoft V2.0 Additional Syntax Support
Parent topic: Additional Dialect Support


Special Registers LIN and COL

LIN and COL are intended to be used for specifying the line number and column number, respectively, of the current cursor position on the screen. Together they form part of the position-spec phrase which is supported in the ACCEPT, DISPLAY and EXHIBIT statements documented later in this chapter. You must set the MS Compiler directive when you submit your source code to your COBOL system if it contains these registers.

The format of both LIN and COL is PIC S9(4) COMP. They are used like ordinary data items, except that they must not be declared; they are automatically declared by the system. You must set them to the desired values before using them in the position-spec phrase.

Note that COL, the abbreviation for COLUMN, is not available as a COBOL reserved word if the MS Compiler directive is set.

Parent topic: Microsoft COBOL V1.0 and V2.0 Syntax Support


Environment Division

  • The Special-Names Paragraph
Parent topic: Microsoft COBOL V1.0 and V2.0 Syntax Support


The Special-Names Paragraph

The following two clauses are supported:

where: n is an integer in the range 0 to 8. The default setting is OFF.

Parent topic: Environment Division


Data Division

  • The USAGE Clause
Parent topic: Microsoft COBOL V1.0 and V2.0 Syntax Support


The USAGE Clause

General Format

The following format of the USAGE clause is supported:

Syntax Rules

  1. COMP and COMPUTATIONAL are synonymous.
  2. COMP-0 and COMPUTATIONAL-0 are synonymous.

General Rules

  1. USAGE IS COMPUTATIONAL means the same as USAGE IS DISPLAY, if you set the MS Compiler directive when you submit your source code to your COBOL system.
  2. USAGE IS COMP-0 is allowed only with numeric items. If an item is described with a PICTURE no larger than S9(4), the effect is a data item whose description is PIC S9(4) USAGE COMP; that is, a 2-byte signed binary item. Otherwise, the effect is a data item with the PICTURE clause actually specified and with USAGE DISPLAY.
Parent topic: Data Division


Procedure Division

  • The Position-Specification Phrase
  • The ACCEPT Statement
  • The DISPLAY Statement
  • The EXHIBIT Statement
Parent topic: Microsoft COBOL V1.0 and V2.0 Syntax Support


The Position-Specification Phrase

The position-specification phrase specifies the screen position in the ACCEPT, DISPLAY and EXHIBIT statements described in this chapter. You must set the MS Compiler directive when you submit your source code to your COBOL system if it contains this phrase.

General Format

Syntax Rules

  1. The comma shown in the above format is mandatory.
Parent topic: Procedure Division


The ACCEPT Statement

The following format of the ACCEPT statement is supported:

General Format

General Rules

  1. The ACCEPT operation treats a group item as an elementary item, if you set the MS Compiler directive when you submit your source code to your COBOL system: it accepts the item itself and not its subordinate elementary items.
  2. If the screen position at which the first operand is to appear is not specified, the default is the current cursor position, if you set the MS Compiler directive when you submit your source code to your COBOL system.
  3. Rules 1 and 2 above also apply to Format 5 of the ACCEPT statement as described in the topic The ACCEPT Statement.
  4. The WITH phrase options and their equivalents are:

    AUTO/AUTO-SKIP BACKGROUND-COLOR BELL/BEEP BLINK FOREGROUND-COLOR LENGTH-CHECK REVERSE-VIDEO RIGHT-JUSTIFY SECURE/NO-ECHO SIZE SPACE-FILL TRAILING-SIGN UNDERLINE UPDATE ZERO-FILL

    These options also apply to Format 5 of the ACCEPT statement as described in the topic The ACCEPT Statement.

    The options listed below differ from standard COBOL, as follows:

    1. UPDATE. If the UPDATE option is not specified, a data item for data entry is displayed initially as spaces, if you set the MS Compiler directive when you submit your source code to your COBOL system. (If the MS directive is not set, the display of initial data is a configuration option.)

      If the UPDATE option is specified, initial data of the data item for data entry is displayed.

    2. PROMPT. This option need not be specified to display prompt characters, if you set the MS Compiler directive when you submit your source code to your COBOL system.
    3. LENGTH-CHECK. If this option is specified, it causes an implicit EMPTY-CHECK option, so that the operator must enter something. You set the MS Compiler directive when you submit your source code to your COBOL system, if you have specified this option.
  5. FOREGROUND-COLOR and BACKGROUND-COLOR. Integer-1 in these options specifies the foreground color and background color of the screen item respectively, and can be defined by a value from 0 to 15, as follows:
    0 | black | 8 | grey
    1 | blue | 9 | light blue
    2 | green | 10 | light green
    3 | cyan | 11 | light cyan
    4 | red | 12 | light red
    5 | magenta | 13 | light magenta
    6 | brown | 14 | yellow
    7 | white | 15 | high intensity white

    On a color screen, if the FOREGROUND-COLOR option specifies an integer whose value is from 8 to 15, this is equivalent to specifying an integer from 0 to 7 and specifying the HIGHLIGHT option. On a monochrome screen, this is equivalent to simply specifying the HIGHLIGHT option.

    On a color screen, if the BACKGROUND-COLOR option specifies an integer whose value is from 8 to 15, this is equivalent to specifying an integer from 0 to 7 and specifying the BLINK option. On a monochrome screen, this is equivalent to simply specifying the BLINK option.

Parent topic: Procedure Division
Related information
The ACCEPT Statement


The DISPLAY Statement

General Format

The following format of the DISPLAY statement is supported:

General Rules

  1. The DISPLAY operation treats a group item as an elementary item, if you set the MS Compiler directive when you submit your source code to your COBOL system: it displays the item itself and not its subordinate elementary items.
  2. If the screen position at which the first operand is to appear is not specified, the default is the current cursor position, if you set the MS Compiler directive when you submit your source code to your COBOL system.
  3. Rules 1 and 2 above also apply to Format 3 of the DISPLAY statement as described in the topic The DISPLAY Statement.
  4. If ERASE is specified, the screen is cleared from the current cursor position onwards.

The following two rules are additional rules which apply to Format 3 of the DISPLAY statements described in the topic The DISPLAY Statement.

  1. The WITH phrase options and their synonyms are:

    BACKGROUND-COLOR BELL/BEEP BLANK BLINK FOREGROUND-COLOR HIGHLIGHT REVERSE-VIDEO SIZE UNDERLINE

  2. FOREGROUND-COLOR and BACKGROUND-COLOR. Integer-1 in these clauses specifies the foreground color and background color of the screen item respectively, and can be defined by a value from 0 to 15, as follows:
    0 | black | 8 | grey
    1 | blue | 9 | light blue
    2 | green | 10 | light green
    3 | cyan | 11 | light cyan
    4 | red | 12 | light red
    5 | magenta | 13 | light magenta
    6 | brown | 14 | yellow
    7 | white | 15 | high intensity white

    On a color screen, if the FOREGROUND-COLOR option specifies an integer whose value is from 8 to 15, this is equivalent to specifying an integer from 0 to 7 and specifying the HIGHLIGHT option. On a monochrome screen, this is equivalent to simply specifying the HIGHLIGHT option.

    On a color screen, if the BACKGROUND-COLOR option specifies an integer whose value is from 8 to 15, this is equivalent to specifying an integer from 0 to 7 and specifying the BLINK option. On a monochrome screen, this is equivalent to simply specifying the BLINK option.

Parent topic: Procedure Division
Related information
The DISPLAY Statement


The EXHIBIT Statement

An EXHIBIT statement with neither the CHANGED nor the NAMED option behaves as if the NAMED option were specified.

General Format

The following format of the EXHIBIT statement is supported:

Syntax Rules

  1. Mnemonic-name should be associated with sysout, syslist, syslst, syspunch, syspch, console or printer.

General Rules

  1. ERASE clears the screen from the current cursor position onwards.
Parent topic: Procedure Division


Microsoft V2.0 Additional Syntax Support

  • Record LOCKING
  • OPEN LOCKING Statement
  • READ Statement (in Manual Mode)
  • START Statement
Parent topic: Microsoft COBOL V1.0 and V2.0 Syntax Support


Record LOCKING

If you set the MS Compiler directive, the LOCKING clause in the SELECT statement is supported.

General Format

General Rules

  1. For SEQUENTIAL and LINE SEQUENTIAL files only EXCLUSIVE locking is allowed.
  2. If MANUAL is specified multiple locks can be applied to the file.
  3. If AUTOMATIC is specified a single lock is applied automatically to the current record.
  4. For SEQUENTIAL and LINE SEQUENTIAL files the default LOCKING mode is EXCLUSIVE.
  5. For RELATIVE and INDEXED files the default LOCKING mode is AUTOMATIC.
  6. If the MANUAL option is specified the UNLOCK statement will release all locks.
Parent topic: Microsoft V2.0 Additional Syntax Support


OPEN LOCKING Statement

If you set the MS Compiler directive the LOCKING clause in the OPEN statement is supported.

General Format

General Rules

  1. For SEQUENTIAL and LINE SEQUENTIAL files only EXCLUSIVE is allowed.
  2. If the NO LOCKING phase is specified EXCLUSIVE is implied.
Parent topic: Microsoft V2.0 Additional Syntax Support


READ Statement (in Manual Mode)

General Format

General Rules

  1. If you set the MS Compiler directive, the WAIT clause in the READ statement is allowed and treated as documentary.
Parent topic: Microsoft V2.0 Additional Syntax Support


START Statement

General Format

General Rules

  1. If you set the MS Compiler directive the LOCK and WAIT clauses in the START statement are allowed and treated as documentary.
Parent topic: Microsoft V2.0 Additional Syntax Support


RM/COBOL Syntax Support

The syntax listed in this chapter is accepted by your COBOL system purely for compatibility with version 12 of RM/COBOL. Many features found in RM/COBOL exist already in this COBOL implementation. Some of the compatibility syntax listed in this chapter is identical to standard COBOL syntax, but behaves differently if you set the RM Compiler directive when you submit your source code to your COBOL system. See the RM/COBOL Language Reference Manual for a full description of the RM/COBOL syntax.

  • Environment Division
  • Data Division
  • Procedure Division
Parent topic: Additional Dialect Support
Related concepts
Converting RM/COBOL Applications


Environment Division

  • The ASSIGN Clause
  • The ORGANIZATION Clause
Parent topic: RM/COBOL Syntax Support


The ASSIGN Clause

General Format

The following format of the ASSIGN clause is supported:

General Rules

  1. The words INPUT, OUTPUT, INPUT-OUTPUT, PRINT and RANDOM are treated as documentary.
Parent topic: Environment Division


The ORGANIZATION Clause

General Format

The following format of the ORGANIZATION clause is supported:

General Rules

  1. This clause is treated as equivalent to ORGANIZATION IS SEQUENTIAL.

    However, if you specify the RM"ANSI" Compiler directive when you submit your source code to your COBOL system, this clause is treated as equivalent to ORGANIZATION IS LINE SEQUENTIAL.

  2. If you do not specify an ORGANIZATION clause for a file then ORGANIZATION IS LINE SEQUENTIAL is assumed, providing you set the RM Compiler directive when you submit your source code to your COBOL system.

    However, if you specify the RM"ANSI" Compiler directive when you submit your source code to your COBOL system, then ORGANIZATION IS SEQUENTIAL is assumed.

Parent topic: Environment Division


Data Division

  • The VALUE OF LABEL Clause
  • Length of Nonnumeric Literals
  • Default Sign Representation
  • The USAGE Clause
Parent topic: RM/COBOL Syntax Support


The VALUE OF LABEL Clause

General Format

The following clause is accepted in an FD entry:

General Rules

  1. This clause is treated as documentary.
Parent topic: Data Division


Length of Nonnumeric Literals

In the Data Division, nonnumeric literals up to 2047 characters long are allowed if you set the RM Compiler directive when you submit your source code to your COBOL system.

Parent topic: Data Division


Default Sign Representation

The syntax:

is assumed in the SPECIAL-NAMES paragraph if you set the RM Compiler directive when you submit your source code to your COBOL system. However, if you specify the RM"ANSI" Compiler directive when you submit your source code to your COBOL system, this phrase is not assumed.

Parent topic: Data Division


The USAGE Clause

General Format

The following format of the USAGE clause is supported:

Syntax Rules

  1. COMP and COMPUTATIONAL are synonymous.
  2. COMP-1 and COMPUTATIONAL-1 are synonymous.
  3. COMP-6 and COMPUTATIONAL-6 are synonymous.

General Rules

  1. The COBOL system allocates a 2-byte signed binary data item, capable of holding values in the range –32k to +32k, for each data item declared as USAGE COMP-1 in the source program, regardless of its picture string. That is, each USAGE COMP-1 data item is treated as though it had a standard COBOL picture-string of S9(4) COMP.
  2. COMP-6 data items are converted to COBOL COMP format. If, as a result of this, less data space is allocated to each item than would be under the RM/COBOL system, the space is padded with null bytes (that is, bytes containing X"00")..
  3. USAGE IS COMPUTATIONAL is treated the same as USAGE IS DISPLAY.
Parent topic: Data Division


Procedure Division

  • Literals as CALL Parameters
  • The EXIT PROGRAM Statement
  • Bound Checking
  • Size Allocation for Index Data Items
  • The ACCEPT Statement
  • The DISPLAY Statement
  • Non-Standard Operations on Alphanumeric Data Items
  • OPEN and CLOSE on SEQUENTIAL Files
  • The PERFORM Statement
  • Procedure Names
  • REWRITE on LINE SEQUENTIAL Files
  • The STOP RUN Statement
  • I-O Status Codes
  • Locked Records
Parent topic: RM/COBOL Syntax Support


Literals as CALL Parameters

Literals can be used as parameters to CALL statements.

Parent topic: Procedure Division


The EXIT PROGRAM Statement

The EXIT PROGRAM statement closes all files that the subprogram being exited has open, if you set the RM Compiler directive when you submit your source code to your COBOL system.

However, if you specify the RM"ANSI" Compiler directive, the EXIT PROGRAM statement does not do this.

Parent topic: Procedure Division


Bound Checking

If you set the RM Compiler directive when you submit your source code to your COBOL system, table subscripts are not bound checked.

Parent topic: Procedure Division


Size Allocation for Index Data Items

Two bytes are allocated to index data items, instead of the normal four, if you set the RM Compiler directive when you submit your source code to your COBOL system.

Parent topic: Procedure Division


The ACCEPT Statement

General Format

The following format of the ACCEPT statement is supported:

Syntax Rules

  1. Identifier-3, identifier-4 and identifier-5, if specified, must be integer identifiers. Literal-2, literal-3 and literal-5, if specified, must be integer literals.
  2. Literal-5 must be a single character.

General Rules

  1. This format is treated as equivalent to Format 5 of the ACCEPT statement as described in the section The ACCEPT Statement, but multiple operands are allowed.
Parent topic: Procedure Division
Related information
The ACCEPT Statement


The DISPLAY Statement

General Format

The following format of the DISPLAY statement is supported:

Syntax Rules

  1. Identifier-3, identifier-4 and identifier-5, if specified, must be integer identifiers. Literal-2, literal-3 and literal-5, if specified, must be integer literals.
  2. Literal-5 must be a single character.

General Rules

  1. This format is treated as equivalent to Format 3 of the DISPLAY statement as described in the section The DISPLAY Statement.
Parent topic: Procedure Division
Related information
The DISPLAY Statement


Non-Standard Operations on Alphanumeric Data Items

Alphanumeric values can be stored in numeric data items, but will be right justified (as is normal with a numeric receiving item) and space-filled on the left. For example, if "AB" is moved to an item decribed as PIC 9(5), the value stored will be "     AB".

Parent topic: Procedure Division


OPEN and CLOSE on SEQUENTIAL Files

The RM/COBOL language permits OPEN and CLOSE statements to be specified with NO REWIND on a sequential file. In the standard COBOL language, such statements are treated as documentary only.

Parent topic: Procedure Division


The PERFORM Statement

Your COBOL system normally uses a stack for handling PERFORM statements, while the RM/COBOL system associates a return address with a specific procedure name. As a result, under the RM/COBOL system all end-points of PERFORM statements are active until they are used, whereas under your COBOL system only the end-point of the innermost current PERFORM statement is active at any one time.

However, if the PERFORM-TYPE"RM" Compiler directive is set, your COBOL system will handle PERFORM statements in the way RM/COBOL does.

Parent topic: Procedure Division


Procedure Names

Programs can contain procedure-names that are the same as data-names.

Parent topic: Procedure Division


REWRITE on LINE SEQUENTIAL Files

The REWRITE statement can be used on sequential files, providing the new record is the same length as the original.

Parent topic: Procedure Division


The STOP RUN Statement

General Format

The following format of the STOP RUN statement is supported:

Syntax Rules

  1. identifier must be a numeric integer data item.
  2. literal must be a numeric integer.

General Rules

  1. The value held in the numeric integer data item or the value of the literal is placed in a special register RETURN-CODE.
Parent topic: Procedure Division


I-O Status Codes

COBOL I-O status codes are mapped onto their RM equivalents if you specify the RM Compiler directive when you submit your source files to your COBOL system.

Parent topic: Procedure Division


Locked Records

If you specify the RM Compiler directive when you submit your source files to your COBOL system and a record is found to be locked, the following happens:

  • If the file has an applicable Declaratives Section and it has a file status value associated with it:
    • processing is transferred to the Declaratives Section
    • the record area contains the correct record from the read
    • the I-O status code indicates the "record locked" condition
  • If the file has no applicable Declaratives Section or file status value associated with it, the locked record is continually retried until its lock is released.
Parent topic: Procedure Division


Siemens BS2000 COBOL Syntax Support

When the DIALECT Compiler directive is set to BS2000 or BS2000-OFFLOAD, the syntax listed in this chapter is accepted by your COBOL system for compatibility with Siemens BS2000 COBOL. Many features found in Siemens BS2000 COBOL exist already in this COBOL implementation, marked as ANS85. Some of the compatibility syntax listed in this chapter is identical to standard COBOL syntax, but behaves differently if you set the DIALECT Compiler directive to BS2000 or BS2000-OFFLOAD when you submit your source code to your COBOL system. See the COBOL85 (BS2000) COBOL Compiler Reference Manual for a full description of the Siemens BS2000 COBOL syntax.

  • Concepts
  • Identification Division
  • Environment Division
  • Data Division
  • Procedure Division
  • Compiler Directing Statements
Parent topic: Additional Dialect Support


Concepts

  • Indicator Area
  • Areas A and B
  • Special Registers
  • Nonnumeric Literals
  • Floating-point Literals
  • Function-Identifier
  • Representation of Numeric Items
  • File Concepts
  • Subscripts
  • Object Views
Parent topic: Siemens BS2000 COBOL Syntax Support


Indicator Area

A comment line may appear anywhere in the compilation group.

Parent topic: Concepts


Areas A and B

The level number 01 may begin in either area A or area B.

Parent topic: Concepts


Special Registers

The special registers SORT-CORE-SIZE, SORT-FILE-SIZE, SORT-MODE-SIZE, SORT-RETURN and TALLY are supported as described in the section Special Registers. The special register RETURN-CODE is also supported, but it has the description PIC S9(8) COMP-5 SYNC.

Parent topic: Concepts
Related information
Special Registers


Nonnumeric Literals

Nonnumeric literals may be from 1 to 180 characters in length.

Parent topic: Concepts


Floating-point Literals

Floating-point literals are supported as described in the section Floating-point Numeric Literals.

Parent topic: Concepts
Related information
Floating-point Numeric Literals


Function-Identifier

A function-identifier that references an integer or numeric function can be used as the source of a MOVE statement, as well as in an arithmetic expression.

Parent topic: Concepts


Representation of Numeric Items

  • The BINARY, COMPUTATIONAL and COMPUTATIONAL-5 phrases
Parent topic: Concepts


The BINARY, COMPUTATIONAL and COMPUTATIONAL-5 phrases

Syntax Rules

  1. These phrases specify binary data items.
  2. The PICTURE clause of a binary data item must contain only 9s, the operational sign S, the assumed decimal point V, and one or more Ps (see the topic The PICTURE Clause).
  3. The data items are stored in a halfword, fullword, or doubleword, and are aligned only if the SYNCHRONIZED clause is specified.
  4. If a data item described with USAGE IS BINARY is used as a receiving data item, a check is made to determine whether the value to be transferred to this data item exceeds the maximum possible value indicated by the PICTURE character-string. If this is the case, the value is made to conform by truncation. If a receiving data item is described with USAGE IS COMPUTATIONAL or COMPUTATIONAL- 5, this check and any subsequent truncation which may be required is not performed.

General Rules

  1. The storage requirements for binary items vary depending on the number of decimal digits specified in the PICTURE clause, as follows:
    Decimal digits in the PICTURE clause | Bytes required in computer storage | Alignment
    1-4 5-9 10-18 | 2 4 8 | halfword fullword fullword
  2. The leftmost bit of a binary data item is the operational sign. The remaining bits represent the value.
Parent topic: Representation of Numeric Items
Related information
The PICTURE Clause


File Concepts

The line sequential file organization is supported as described in the section Line Sequential Input/Output. This support is consistent with the X/Open Portability Guide.

Parent topic: Concepts
Related information
Line Sequential Input/Output


Subscripts

A subscript may be an arithmetic expression that has the value of a positive integer.

As specified in the standard, the value of an index should correspond to a valid occurrence number of the associated table. This compiler also permits corresponding occurrence numbers for 0, negative numbers, and values beyond the maximum permissible occurrence number, but the binary value of the index must remain within the range that is representable in 4 bytes, i.e. -2 ** 31 to 2 ** 31 -1. In these cases, the index must be set to a valid occurrence number before it is used (e.g. with SET UP or SET DOWN), or relative indexing must be used to ensure that only valid table elements are addressed.

Parent topic: Concepts


Object Views

Object views are supported as described in the section Object-view

Parent topic: Concepts
Related information
Object-view


Identification Division

  • Identification Division Header
  • Identification Division Structure
  • The Class-ID Paragraph
  • The Factory Paragraph
  • The Interface-ID Paragraph
  • The Method-ID Paragraph (Siemens BS2000 COBOL)
  • The Object Paragraph
Parent topic: Siemens BS2000 COBOL Syntax Support


Identification Division Header

The following additional format of the Identification Division header is supported:

 ID DIVISION.
Parent topic: Identification Division


Identification Division Structure

The paragraphs of the Identification Division can be written in any order.

Parent topic: Identification Division


The Class-ID Paragraph

The Class-ID paragraph may be specified as documented in the topic The Class-ID Paragraph. Neither the AS phrase nor the USING phrase is permitted.

Parent topic: Identification Division
Related information
The Class-ID Paragraph


The Factory Paragraph

The Factory paragraph may be specified as documented in the topic The Factory Paragraph. The IMPLEMENTS clause is not permitted.

Parent topic: Identification Division
Related information
The Factory Paragraph


The Interface-ID Paragraph

The Interface-ID paragraph may be specified as documented in the topic The Interface-ID Paragraph. Neither the AS phrase nor the USING phrase is permitted.

Parent topic: Identification Division
Related information
The Interface-ID Paragraph


The Method-ID Paragraph (Siemens BS2000 COBOL)

The Method-ID paragraph may be specified as documented in the topic The Method-ID Paragraph. Neither the AS phrase nor the PROPERTY phrase is permitted.

Parent topic: Identification Division
Related information
The Method-ID Paragraph


The Object Paragraph

The Object paragraph may be specified as documented in the topic The Object Paragraph. The IMPLEMENTS clause is not permitted.

Parent topic: Identification Division
Related information
The Object Paragraph


Environment Division

  • The Special-Names Paragraph
  • The File Control Entry
  • The Repository Paragraph
Parent topic: Siemens BS2000 COBOL Syntax Support


The Special-Names Paragraph

ARGUMENT-NAME, ARGUMENT-VALUE, ENVIRONMENT-NAME and ENVIRONMENT-VALUE may be specified in the Special-Names paragraph for use in ACCEPT and DISPLAY statements. Their use is consistent with the X/Open Portability Guide and the Micro Focus implementation.

An implementor-name is a system-name and must be a name from the left column of the following table. The implementor-names and their meanings are:

Implementor-name | Meaning
COMPILER-INFO | used in ACCEPT statement
CONSOLE | System or main console or subconsole; used in ACCEPT and DISPLAY statements
CPU-TIME | used in ACCEPT statement
DATE-ISO4 | used in ACCEPT statement
JV_jobvariable-name | used in ACCEPT and DISPLAY statements
PRINTER | System logical printer; used in DISPLAY statement
PRINTER01 ... PRINTER99 | treated as PRINTER-1
PROCESS-INFO | used in ACCEPT statement
SYSIPT SYSOPT | treated as comment
TERMINAL | used in ACCEPT and DISPLAY statements; same as CONSOLE
TERMINAL-INFO | used in ACCEPT statement
TSW-0 ... TSW-31 | task switches, used in SET statement and in compares
USW-0 ... USW-31 | user switches, used in SET statement and in compares

The mnemonic-name can be the same as the implementor-name. For example:

 TERMINAL IS TERMINAL

JV_jobvariable-name, TSW-n, and USW-n only work when the BS/2000 add-on is present to provide the necessary run-time support.

Parent topic: Environment Division


The File Control Entry

For all file organizations, the data-name-1 phrase in the ASSIGN clause is supported as described in the topic File Control Entry.

For all file organizations, a second data-name may be specified in the FILE STATUS clause, but it is treated as commentary only.

Parent topic: Environment Division
Related information
The File Control Entry


The Repository Paragraph

The Repository paragraph may be specified as documented in the topic The Repository Paragraph. The program-specifier is not permitted.

Parent topic: Environment Division
Related information
The Repository Paragraph


Data Division

  • The File Description Entry
  • The Sort-Merge File Description Entry
  • The Working-Storage Section
  • The DYNAMIC Clause
  • The OCCURS Clause
  • The PICTURE Clause
  • The REDEFINES Clause
  • The SYNCHRONIZED Clause
  • The USAGE Clause
  • The VALUE Clause
Parent topic: Siemens BS2000 COBOL Syntax Support


The File Description Entry

The RECORDING MODE clause may be specified as documented in the topic The RECORDING MODE Clause. The S phrase is not permitted.

Data-name-1 may be specified in the LABEL RECORDS clause as documented in the topic The LABEL RECORDS Clause.

Parent topic: Data Division
Related information
The RECORDING MODE Clause
The LABEL RECORDS Clause


The Sort-Merge File Description Entry

The RECORDING MODE clause is permitted, however, there is no need for it since the compiler can determine the information from the associated record descriptions.

The LABEL RECORDS clause may be specified.

Parent topic: Data Division


The Working-Storage Section

The Working-Storage Section may be specified in method definitions. The data in these sections is static.

Parent topic: Data Division


The DYNAMIC Clause

General Format

The following clause is accepted in level-01 entries in the Working-Storage Section:

  IS DYNAMIC

General Rules

  1. This clause is treated as documentary.
Parent topic: Data Division


The OCCURS Clause

In an OCCURS clause with the DEPENDING phrase, the lower bound (integer-1) may be omitted.

Parent topic: Data Division


The PICTURE Clause

External floating-point data items are supported as described in the section The PICTURE Clause.

Parent topic: Data Division
Related information
The PICTURE Clause


The REDEFINES Clause

Data-name-2 may qualified, however, the qualification is ignored since the required placement of the REDEFINES clause determines the item that is redefined.

Parent topic: Data Division


The SYNCHRONIZED Clause

The SYNCHRONIZED clause may be specified on a group item. The clause applies to the items subordinate to that group.

The SYNCHRONIZED clause may be specified for a data item whose usage is index, in addition to the usages allowed by the standard.

Parent topic: Data Division


The USAGE Clause

The additional usages COMPUTATIONAL-1 (COMP-1), COMPUTATIONAL-2 (COMP-2) and COMPUTATIONAL-3 (COMP-3) are supported as described in the section The USAGE Clause.

The additional usage COMPUTATIONAL-5 (COMP-5) is described in the section Representation of Numeric Items.

The additional usage OBJECT REFERENCE is supported with all its optional phrases.

Parent topic: Data Division
Related information
The USAGE Clause
Representation of Numeric Items


The VALUE Clause

Format 1 - Additional Syntax Rules

  1. The VALUE clause is prohibited for external floating-point data items.

Format 2

The WHEN SET TO FALSE phrase is supported, as described in the section The VALUE Clause.

Format 3

The VALUE clause may be used to initialize the elements of a table.

Format 4

Syntax Rules

Format 4

  1. Format 3 of the VALUE clause must be used only in the Working-Storage section.
  2. All numeric literals in a VALUE clause of an item must have a value which is within the range of values indicated by the associated PICTURE clause, and must not have a value which would require truncation of non-zero digits.
  3. Nonnumeric literals in a VALUE clause of an item must not exceed the size indicated by the associated PICTURE clause.
  4. If the VALUE clause is used in an entry at the group level, the literal must be a figurative constant or a nonnumeric literal, and the group area is initialized without consideration for the individual elementary or group items contained within this group. The VALUE clause must not be stated at the subordinate levels within this group.
  5. The VALUE clause must not be specified for a group item containing items subordinate to it with descriptions including JUSTIFIED or USAGE (other than USAGE IS DISPLAY).
  6. When format 3 is specified, the data description entry must contain an OCCURS clause or be subordinate to a data description entry that contains an OCCURS clause.
  7. Subscript-1 must be a numeric literal that is an integer. If all subscripts have the value 1, no subscripts need be specified; otherwise, all subscripts required to reference an individual element in a table must be specified.
  8. The number of table elements to be initialized is determined as follows:
    1. If integer-1 is not specified, it is the number of repetitions of literal-2.
    2. If integer-1 is specified, it is the number of repetitions of literal-2 times integer-1.

    The number of table elements to be initialized must not exceed the maximum number of occurrences in the table from the point of reference to the end of the table.

  9. If multiple format 3 VALUE clauses are specified in an entry, the TO END phrase may be specified only once.

General Rules

Format 4

  1. All formats of the VALUE clause can be used in one table.
  2. Within the same data description entry, if more than one VALUE clause references the same table element, the value defined by the last specified VALUE clause in the data description entry is assigned to the table element.
  3. A format 3 VALUE clause initializes a table element to the value of literal-2. The table element initialized is identified by subscript-1. Consecutive table elements are initialized, in turn, to the successive occurrences of the value of literal-2. Consecutive table elements are referenced by augmenting by 1 the subscript that represents the least inclusive dimension of the table. When any reference to a subscript, prior to augmenting it, is equal to the maximum number of occurrences specified by its corresponding OCCURS clause, that subscript is set to 1 and the subscript for the next most inclusive dimension of the table is augmented by 1.
  4. If the REPEATED phrase is specified, all occurrences of literal-2 are reused, in the order specified.

    If the TO END phrase is specified, this reuse occurs until the end of the table is reached.

    If the integer-1 TIMES phrase is specified, the occurrences of literal-2 are reused, in the order specified, integer-1 times.

    If the REPEATED phrase is not specified, the occurrences of literal-2 are used, in the order specified, only once.

  5. If a VALUE clause is specified in a data description entry of a data item which is associated with a variable-occurrence data item, the initialization of the data item behaves as if the value of the data item referenced by the DEPENDING ON phrase in the OCCURS clause specified for the variable-occurrence data item is set to the maximum number of occurrences as specified by that OCCURS clause. A data item is associated with a variable-occurrence data item in any of the following cases:
    1. It is a group data item which contains a variable-occurrence data item.
    2. It is a variable-occurrence data item.
    3. It is a data item that is subordinate to a variable-occurrence data item.
  6. The VALUE clause must not conflict with other clauses in the data description of the item or in the data description within the hierarchy of the item. The following rules apply:

    If the category of the item is numeric, all literals in the VALUE clause must be numeric. The literal is aligned in the data item according to the standard alignment rules.

    If the category of the item is alphabetic or alphanumeric, all literals in the VALUE clause must be nonnumeric literals. The literal is aligned in the data item as if the data item had been described as alphanumeric.

    Initialization is not affected by any BLANK WHEN ZERO or JUSTIFIED clause that was specified.

Parent topic: Data Division
Related information
The VALUE Clause


Procedure Division

  • Class Condition
  • Intrinsic Functions
  • The ACCEPT Statement
  • The CALL Statement
  • The CLOSE Statement
  • The DISPLAY Statement
  • The ENTRY Statement
  • The EVALUATE Statement
  • The EXIT PERFORM Statement
  • The GOBACK Statement
  • The INSPECT Statement
  • The INVOKE Statement
  • The MERGE Statement
  • The MOVE Statement
  • The OPEN Statement
  • The READ Statement
  • The REWRITE Statement
  • The SEARCH Statement
  • The SET Statement
  • The SORT Statement
  • The START Statement
  • The STRING Statement
  • The USE Statement
  • The WRITE Statement
Parent topic: Siemens BS2000 COBOL Syntax Support


Class Condition

The identifier in the class condition can be of usage COMPUTATIONAL-3, as well as the usages DISPLAY and PACKED-DECIMAL that are allowed by the standard.

Parent topic: Procedure Division


Intrinsic Functions

In addition to the intrinsic functions specified in the standard, the following intrinsic functions are supported: ADDR, DATE-TO-YYYYMMDD, DAY-TO-YYYYDDD, and YEAR-TO-YYYY. The ADDR function is described below. The other intrinsic functions are described in the topic Intrinsic Functions.

  • The ADDR Function
Parent topic: Procedure Division
Related information
Intrinsic Functions
Arguments
Data Item Functions
Date Conversion Functions
Trigonometric Functions
Definitions of Functions


The ADDR Function

Description

The ADDR function returns an integer representing the address of argument-1. The type of this function is integer

General Format

FUNCTION ADDR (argument-1)

Arguments

  1. Argument-1 can be a literal or a data-item of any class or category.

Returned Values

  1. The returned value is an integer representing the address of argument-1 at run time.
Parent topic: Intrinsic Functions


The ACCEPT Statement

Mnemonic-names associated with the implementor-names ARGUMENT-NUMBER, ARGUMENT-VALUE, ENVIRONMENT-NAME and ENVIRONMENT-VALUE are supported as described in the section The Special-Names Paragraph.

Mnemonic-name may be associated with one of the following implementor-names: COMPILER-INFO, CONSOLE, CPU-TIME, DATE-ISO4, job-variable-name (BS2000 job variable), PROCESS-INFO, SYSIPT, TERMINAL or TERMINAL-INFO.

Job-variable-names only work when the BS/2000 add-on is present to provide the necessary run-time support.

SYSIPT, TERMINAL, or CONSOLE specifies the system file from which data is to be read. SYSIPT refers to the system file of that name. TERMINAL refers to the system file SYSDTA (normally assigned to the data terminal). CONSOLE refers to the system console.

When a mnemonic-name is associated with a job-variable-name, it references the associated operating system job variable which is to be read in. If the job variable cannot be read in for some reason, the runtime system issues an error message, and the program is then either continued or aborted, as determined by a compiler directive. In the former case, /* is assumed as the value of identifier.

When mnemonic-name is associated with COMPILER-INFO, CPU-TIME, PROCESS-INFO, or TERMINAL-INFO, it specifies the information which is to be requested. COMPILER-INFO refers to information provided by the compiler. CPU-TIME, PROCESS-INFO, TERMINAL-INFO and DATE-ISO4 refer to information provided by the operating system.

CPU-TIME is moved in accordance with the rules of the MOVE statement from a field with the description PIC 9(6)V9(4).

Parent topic: Procedure Division
Related information
The Special-Names Paragraph


The CALL Statement

Identifiers in the USING phrase may be groups or elementary items and may have any level number except 88.

BY VALUE identifier may be specified in the USING phrase. BY CONTENT literal may be specified in the USING phrase. Additional details are specified in the section The CALL Statement.

Parent topic: Procedure Division
Related information
The CALL Statement


The CLOSE Statement

  • Record Sequential Files
  • Line Sequential Files
Parent topic: Procedure Division


Record Sequential Files

The REEL and UNIT phrases are treated as commentary.

Parent topic: The CLOSE Statement


Line Sequential Files

The only optional phrase permitted for a line sequential file is the WITH LOCK phrase.

Parent topic: The CLOSE Statement


The DISPLAY Statement

Mnemonic-names associated with the implementor-names ARGUMENT-NUMBER, ENVIRONMENT-NAME and ENVIRONMENT-VALUE are supported as described in the section The Special-Names Paragraph.

Mnemonic-name may be associated with one of the following implementor-names: CONSOLE, PRINTER, PRINTER01 - PRINTER99, SYSOPT, TERMINAL, job-variable-name (BS2000 job variable).

Job-variable-names only work when the BS/2000 add-on is present to provide the necessary run-time support.

A mnemonic-name associated with CONSOLE, SYSOPT or TERMINAL specifies that the data is to be written to the system operator console.

A mnemonic-name associated with PRINTER or PRINTER01 - PRINTER99 specifies that the data is to be written to the printer.

A mnemonic-name associated with a job-variable-name references a job variable which has a maximum record length of 256 characters. If the total number of characters in the sending operands exceeds the maximum record length, the record will be truncated to the maximum length.

Parent topic: Procedure Division
Related information
The Special-Names Paragraph


The ENTRY Statement

The ENTRY statement is supported as documented in the section The ENTRY Statement.

Parent topic: Procedure Division
Related information
The ENTRY Statement


The EVALUATE Statement

Partial expressions are supported in the WHEN and ALSO phrases of the EVALUATE statement as described in the section The EVALUATE Statement.

Parent topic: Procedure Division
Related information
The EVALUATE Statement


The EXIT PERFORM Statement

The EXIT PERFORM statement makes it possible to branch to the end of the PERFORM statement or to a repetition of the loop from an in-line PERFORM statement.

General Formats

 EXIT [TO TEST OF] PERFORM

Syntax Rules

  1. An EXIT [TO TEST OF] PERFORM statement can only be specified within an in-line PERFORM.
  2. An EXIT TO TEST OF PERFORM statement can only refer to format 2, 3, or 4 PERFORM statements (see the section The PERFORM Statement).

General Rules

  1. The associated in-line PERFORM statement is exited by the execution of an EXIT PERFORM.
  2. Depending on the format of the PERFORM statement, different branches are made as the result of EXIT TO TEST OF PERFORM:
    1. In a format 2 PERFORM, control passes to the test of "end of loop".
    2. In a format 3 PERFORM, control passes to the test of "UNTIL condition".
    3. When TEST AFTER is specified in format 4, control passes to the test of "UNTIL condition". If the condition is satisfied, the PERFORM statement is terminated. If the condition is not satisfied, augmentation is carried out.
    4. When TEST BEFORE is specified in format 4, control is passed to the increment counter. The test of "UNTIL condition" then follows.
Parent topic: Procedure Division
Related information
The PERFORM Statement


The GOBACK Statement

The GOBACK statement is supported as documented in the section The GOBACK Statement.

Parent topic: Procedure Division
Related information
The GOBACK Statement


The INSPECT Statement

Identifier-3 ... identifier-n may reference a group item, as well as the elementary items allowed by the standard.

Parent topic: Procedure Division


The INVOKE Statement

The INVOKE statement is supported as documented in the section The INVOKE Statement. The Micro Focus extensions are not permitted.

Parent topic: Procedure Division
Related information
The INVOKE Statement


The MERGE Statement

The optional word KEY in the ASCENDING or DESCENDING phrase may be replaced by the word KEY-YY. When KEY-YY is specified, the behavior of the MERGE statement is not changed.

Parent topic: Procedure Division


The MOVE Statement

Multiple receiving identifiers may be specified in a MOVE statement with the CORRESPONDING phrase.

Parent topic: Procedure Division


The OPEN Statement

For line sequential files, the only permissible open modes are INPUT and OUTPUT; and the REVERSED and NO REWIND phrases must not be specified.

Parent topic: Procedure Division


The READ Statement

  • Relative and Indexed Files
Parent topic: Procedure Division


Relative and Indexed Files

The NO LOCK phrase may be specified in both formats of the READ statement. The effect of the NO LOCK phrase is described in the section The READ Statement. The placement of the phrase differs from the placement in the MF dialect, here the NO LOCK phrase immediately follows the file-name.

In a format 1 READ statement in which the AT END phrase or the NOT AT END phrase is specified, the NEXT phrase is implied and may be omitted.

Parent topic: The READ Statement
Related information
The READ Statement


The REWRITE Statement

The REWRITE statement is not permitted for line sequential files.

Parent topic: Procedure Division


The SEARCH Statement

The key (data-name-1 or data-name-2) in a format 2 SEARCH statement (SEARCH ALL) may be specified on either the right hand side or the left hand side of the equality operator in the WHEN phrase. This is shown in the general format of the section The SEARCH Statement as an OSVS extension.

Parent topic: Procedure Division
Related information
The SEARCH Statement


The SET Statement

The FALSE phrase is supported in a format 2 SET statement, as specified in the section The SET Statement.

The value of an index-name after the execution of a format 5 or format 6 SET statement need not be a valid occurrence number in the corresponding table, but must be within the range of permissible values for the index as specified in the section Subscripts.

The format 8 SET statement (object references) is permitted.

Parent topic: Procedure Division
Related information
The SET Statement
Subscripts


The SORT Statement

  • Sorting of Tables
  • Sorting Two-digit Years with a Century Window
Parent topic: Procedure Division


Sorting of Tables

Format 2 of the SORT statement (table sort) is supported. Most of the details are given in the section The SORT Statement. Additional details are contained in this section.

General format

Syntax Rules

  1. For data-name-3, the same rules apply as for data-name-2.
  2. If the USING phrase is used, data-name-2 and data-name-3 must be described as alphanumeric data items.

General Rules

  1. Data-name-3, if specified, is the table to be sorted; otherwise, the table specified by data-name-2 is sorted.
  2. By specifying USING data-name-3, a second table is used for sort processing. In this case, the elements of the table specified by data-name-3 are transferred to the table specified by data-name-2 and then sorted in the table specified by data-name-2. The individual table elements are transferred in accordance with the rules for the MOVE statement:
    • If the "sending" element is shorter than the "receiving" element, it is padded with blanks;
    • if it is longer, it is truncated.
  3. Transfer of the data-name-3 table elements to the data-name-2 table ends with the last table element of data-name-3 or on reaching the number of table elements for data-name-2. This means that if the data-name-3 table contains more elements than the data-name-2 table, the excess elements are not transferred. If it contains fewer elements, the excess elements of the data-name-2 table are retained unchanged.
  4. Sort processing does not change the contents of the data-name-3 table.
Parent topic: The SORT Statement
Related information
The SORT Statement


Sorting Two-digit Years with a Century Window

In both formats 1 and 2 of the SORT statement, the optional word KEY in the ASCENDING or DESCENDING phrase may be replaced by the word KEY-YY. When KEY-YY is specified, the behavior of the SORT statement is not changed.

Parent topic: The SORT Statement


The START Statement

  • Relative and Indexed Files
Parent topic: Procedure Division


Relative and Indexed Files

The NO LOCK phrase may be specified immediatly after START file-name, but is treated as a comment.

The relational operators LESS, LESS OR EQUAL, NOT GREATER and their equivalents are supported as specified in the section The START Statement.

Parent topic: The START Statement
Related information
The START Statement


The STRING Statement

As in the Micro Focus dialect, the following extension is supported:

The DELIMITED phrase may be omitted only immediately preceding the INTO phrase. If it is omitted, DELIMITED BY SIZE is implied.

Parent topic: Procedure Division


The USE Statement

A PERFORM statement within a declarative procedure (USE statement) may reference a nondeclarative procedure, as well as a declarative procedure.

Formats 2 and 3 are supported as specified in the section The USE Statement.

Parent topic: Procedure Division
Related information
The USE Statement


The WRITE Statement

  • Sequential Files
Parent topic: Procedure Division


Sequential Files

The identifier in the ADVANCING phrase of the WRITE statement may be an elementary one-character nonnumeric item, as well as an elementary integer data item. If a nonnumeric item is specified, the ADVANCING phrase is treated as a comment.

Parent topic: The WRITE Statement


Compiler Directing Statements

  • The COPY Statement
Parent topic: Siemens BS2000 COBOL Syntax Support


The COPY Statement

The SUPPRESS phrase of the COPY statement is supported as described in the section The COPY Statement.

COPY statements may be nested as described in the section The COPY Statement.

Parent topic: Compiler Directing Statements
Related information
The COPY Statement


VS COBOL II Compatibility

The VS COBOL II compatibility features available in this COBOL system are controlled by the two Compiler directives:

FLAG "VSC2" VSC2 "integer"

where integer provides compatibility as follows:

VSC2 (1) VS COBOL II release 1.x VSC2 (2) VS COBOL II release 2 VSC2 (3) VS COBOL II release 3.x VSC2 (4) VS COBOL II release 4.x

Most differences are reflected as flagging differences when the FLAG "VSC2" Compiler directive is specified. COBOL will not report any differences in the four levels of support. Indication is always given in the form of a flag.

Element | VSC2(1) | VSC2(2) | VSC2(3) | VSC2(4)
ADD..TO..GIVING | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
ALPHABET alphabetic class test | Keyword is prohibited in SPECIAL-NAMES | Keyword is prohibited in SPECIAL-NAMES | Keyword is required in SPECIAL-NAMES | Keyword is required in SPECIAL-NAMES
Alpha-numeric literal 160 chars. | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
BINARY usage | Rejected | Rejected | Supported | Supported
CALL BY CONTENT | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
CALL ON EXCEPTION | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
Class Name | User defined class names are rejected Only upper case accepted | User defined class names are rejected Only upper case is accepted | Additional user class names can be defined in the SPECIAL-NAMES paragraph Both upper and lower case are accepted | Additional user class names can be defined in the SPECIAL-NAMES paragraph Both upper and lower case are accepted
COMMON | Rejected | Rejected | Supported | Supported
Data - name following level number allowed in margin A | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
DAY - OF - WEEK | Rejected | Rejected | Supported | Supported
DISPLAY WITH NO ADVANCING | Flagged as ANSI'85 extension | Flagged as ANSI'85 extension | Supported | Supported
END PROGRAM | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
EVALUATE omitted ALSO | Supported | Flagged as MF extension | Flagged as MF extension | Flagged as MF extension
EXIT PROGRAM not alone in paragraph | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
EXTERNAL | Rejected | Rejected | Supported | Supported
File Status Code | ANSI 74 codes | ANSI 74 codes | ANSI'85 codes | ANSI'85 codes
GLOBAL clause | Rejected | Rejected | Supported | Supported
OCCURS nest depth seven | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
OPEN EXTEND for relative and indexed organizations | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
Optional FILLER or data name | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
INITIAL program-id | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
INITIALIZE Replacing DBCS | Rejected | Rejected | Supported | Supported
INSPECT CONVERTING | Rejected | Rejected | Supported | Supported
LESS OR EQUAL, GREATER OR EQUAL, <=, >= | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
Lower case letters | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
MERGE GIVING Multiple files | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
NOT scope delimiter | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
OPTIONAL RELATIVE files | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
PACKED - DECIMAL | Rejected | Rejected | Supported | Supported
PADDING CHARACTER | Rejected | Rejected | Supported | Supported
PIC continuation | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
Program-name can be the same as a user-defined word | Rejected | Rejected | Rejected | Rejected
RECORD DELIMITER | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
RECORD IS VARYING | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
Reference modification | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
REPLACE | Rejected | Rejected | Supported | Supported
SET TO ON/OFF | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
SIGN nested | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
SORT DUPLICATES phrase | Rejected if ORDER used | Rejected if ORDER used | Supported | Supported
STANDARD -2 | Rejected | Rejected | Supported | Supported
Symbolic chars. | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
VALUE with OCCURS | Flagged as ANSI'85 | Flagged as ANSI'85 | Supported | Supported
Parent topic: Additional Dialect Support


Part 4: Appendices

  • Character Sets and Collating Sequences
  • ANSI File Status Summary
  • Reserved Words
  • XML-CODE Exception Codes
  • Glossary
    The terms in this glossary are defined in accordance with their meaning as used in this document. These definitions are, in most instances, brief and do not include detailed syntactic rules, or dialect bubbles. Therefore, parts of the information may or may not be relevant based on the dialect selected.
Parent topic: COBOL Language Reference


Character Sets and Collating Sequences

The Character Set Encoding and Collating Sequence table, below, lists the ASCII and EBCDIC character sets and collating sequences, and show, the hexadecimal equivalent of the characters. For each ASCII and EBCDIC character, a further column contains an X if the character is not available as part of the recognized COBOL character set.

See your COBOL system documentation for details of the ALPHASTART and SYMBSTART Compiler directives, which set the number from which the compiler counts positions in the collating sequence.

The EBCDIC column shows the IBM standard U.S. bit pattern assignments. Some characters have a different bit pattern in different languages, and these are boxed within the table.

Table 1. Character Set Encoding and Collating Sequence
 | ASCII |  | EBCDIC
Hex | Character | COBOL | Character | COBOL
00 | NUL | X | NUL | X
01 | SOH | X | SOH | X
02 | STX | X | STX | X
03 | ETX | X | ETX | X
04 | EOT | X | SEL | X
05 | ENQ | X | HT | X
06 | ACK | X | RNL | X
07 | BEL | X | DEL | X
08 | BS | X | GE | X
09 | HT | X | SPS | X
0A | LF | X | RPT | X
0B | VT | X | VT | X
0C | FF | X | FF | X
0D | CR | X | CR | X
0E | SO | X | SO | X
0F | SI | X | SI | X
10 | DLE | X | DLE | X
11 | DCI | X | DC1 | X
12 | DC2 | X | DC2 | X
13 | DC3 | X | DC3 | X
14 | DC4 | X | RES/ENP | X
15 | NAK | X | NL | X
16 | SYN | X | BS | X
17 | ETB | X | POC | X
18 | CAN | X | CAN | X
19 | EM | X | EM | X
1A | SUB | X | UBS | X
1B | ESC | X | CU1 | X
1C | FS | X | IFS | X
1D | GS | X | IGS | X
1E | RS | X | IRS | X
1F | US | X | ITB/IUS | X
20 | SPACE |  | DS | X
21 | ! | X | SOS | X
22 | " |  | FS | X
23 | # | X | WUS | X
24 | $ |  | BYP/INP | X
25 | % | X | LF | X
26 | & |  | ETB | X
27 | ' |  | ESC | X
28 | ( |  | SA | X
29 | ) |  | SFE | X
2A | * |  | SM/SW | X
2B | + |  | CSP | X
2C | , |  | MFA | X
2D | – |  | ENQ | X
2E | . |  | ACK | X
2F | / |  | BEL | X
30 | 0 |  |  | X
31 | 1 |  |  | X
32 | 2 |  | SYN | X
33 | 3 |  | IR | X
34 | 4 |  | PP | X
35 | 5 |  | TRN | X
36 | 6 |  | NBS | X
37 | 7 |  | EOT | X
38 | 8 |  | SBS | X
39 | 9 |  | IT | X
3A | : |  | RFF | X
3B | ; |  | CU3 | X
3C | < |  | DC4 | X
3D | = |  | NAK | X
3E | > |  |  | X
3F | ? | X | SUB | X
40 | @ | X | SP | X
41 | A |  | RSP | X
42 | B |  |  | X
43 | C |  |  | X
44 | D |  |  | X
45 | E |  |  | X
46 | F |  |  | X
47 | G |  |  | X
48 | H |  |  | X
49 | I |  |  | X
4A | J |  | c (cent) | X
4B | K |  | . | X
4C | L |  | < | X
4D | M |  | ( | X
4E | N |  | + | X
4F | O |  | | | X
50 | P |  | & |
51 | Q |  |  | X
52 | R |  |  | X
53 | S |  |  | X
54 | T |  |  | X
55 | U |  |  | X
56 | V |  |  | X
57 | W |  |  | X
58 | X |  |  | X
59 | Y |  |  | X
5A | Z |  | ! | X
5B |  | X | $ |
5C |  | X | * |
5D |  | X | ) |
5E |  | X | ; |
5F | _ |  | ¬ | X
60 |  | X | – |
61 | a |  | / |
62 | b |  |  | X
63 | c |  |  | X
64 | d |  |  | X
65 | e |  |  | X
66 | f |  |  | X
67 | g |  |  | X
68 | h |  |  | X
69 | i |  |  | X
6A | j |  | | | X
6B | k |  | , |
6C | l |  | % | X
6D | m |  | _ |
6E | n |  | > |
6F | o |  | ? | X
70 | p |  | . | X
71 | q |  |  | X
72 | r |  |  | X
73 | s |  |  | X
74 | t |  |  | X
75 | u |  |  | X
76 | v |  |  | X
77 | w |  |  | X
78 | x |  |  | X
79 | y |  | ` | X
7A | z |  | : |
7B |  | X | # | X
7C |  | X | @ | X
7D |  | X | ' |
7E |  | X | = |
7F | DEL | X | " |
80 |  |  |  | X
81 |  |  | a |
82 |  |  | b |
83 |  |  | c |
84 |  |  | d |
85 |  |  | e |
86 |  |  | f |
87 |  |  | g |
88 |  |  | h |
89 |  |  | i |
8A |  |  |  | X
8B |  |  |  | X
8C |  |  |  | X
8D |  |  |  | X
8E |  |  |  | X
8F |  |  |  | X
90 |  |  |  | X
91 |  |  | j |
92 |  |  | k |
93 |  |  | l |
94 |  |  | m |
95 |  |  | n |
96 |  |  | o |
97 |  |  | p |
98 |  |  | q |
99 |  |  | r |
9A |  |  |  | X
9B |  |  |  | X
9C |  |  |  | X
9D |  |  |  | X
9E |  |  |  | X
9F |  |  |  | X
A0 |  |  |  | X
A1 |  |  | ~ | X
A2 |  |  | s |
A3 |  |  | t |
A4 |  |  | u |
A5 |  |  | v |
A6 |  |  | w |
A7 |  |  | x |
A8 |  |  | y |
A9 |  |  | z |
AA |  |  |  | X
AB |  |  |  | X
AC |  |  |  | X
AD |  |  |  | X
AE |  |  |  | X
AF |  |  |  | X
B0 |  |  |  | X
B1 |  |  |  | X
B2 |  |  |  | X
B3 |  |  |  | X
B4 |  |  |  | X
B5 |  |  |  | X
B6 |  |  |  | X
B7 |  |  |  | X
B8 |  |  |  | X
B9 |  |  |  | X
BA |  |  |  | X
BB |  |  |  | X
BC |  |  |  | X
BD |  |  |  | X
BE |  |  |  | X
BF |  |  |  | X
C0 |  |  | ( | X
C1 |  |  | A |
C2 |  |  | B |
C3 |  |  | C |
C4 |  |  | D |
C5 |  |  | E |
C6 |  |  | F |
C7 |  |  | G |
C8 |  |  | H |
C9 |  |  | I |
CA |  |  | SHY | X
CB |  |  |  | X
CC |  |  |  | X
CD |  |  |  | X
CE |  |  |  | X
CF |  |  |  | X
D0 |  |  | ) | X
D1 |  |  | J |
D2 |  |  | K |
D3 |  |  | L |
D4 |  |  | M |
D5 |  |  | N |
D6 |  |  | O |
D7 |  |  | P |
D8 |  |  | Q |
D9 |  |  | R |
DA |  |  |  | X
DB |  |  |  | X
DC |  |  |  | X
DD |  |  |  | X
DE |  |  |  | X
DF |  |  |  | X
E0 |  |  | \ | X
E1 |  |  | NSP | X
E2 |  |  | S |
E3 |  |  | T |
E4 |  |  | U |
E5 |  |  | V |
E6 |  |  | W |
E7 |  |  | X |
E8 |  |  | Y |
E9 |  |  | Z |
EA |  |  |  | X
EB |  |  |  | X
EC |  |  |  | X
ED |  |  |  | X
EE |  |  |  | X
EF |  |  |  | X
F0 |  |  | 0 |
F1 |  |  | 1 |
F2 |  |  | 2 |
F3 |  |  | 3 |
F4 |  |  | 4 |
F5 |  |  | 5 |
F6 |  |  | 6 |
F7 |  |  | 7 |
F8 |  |  | 8 |
F9 |  |  | 9 |
FA |  |  | | | X
FB |  |  |  | X
FC |  |  |  | X
FD |  |  |  | X
FE |  |  |  | X
FF |  |  | E0 | X
Parent topic: Part 4: Appendices


ANSI File Status Summary

This provides a summary of the ANSI file status codes. See the topic The File Control Entry, the topic I-O Status and your COBOL system documentation for more details.

  • ANSI'74 File Status Codes
  • ANSI'85 File Status Codes
Parent topic: Part 4: Appendices
Related information
The File Control Entry
I-O Status


ANSI'74 File Status Codes

The ANSI'74 file status codes are as follows:

Status key 1 | Status key 2 | Description
0 | 0 | Successful completion
2 Indexed files only. One of two possibilities:
  1. For a READ statement, the key value for the current key is equal to the value of that same key in the next record within the current key of reference.
  2. For a WRITE or REWRITE statement, the record just written created a duplicate key value for at least one alternate record key for which duplicates are allowed.
1 | 0 | There is no next logical record. You have reached the end of the file.
2 | 1 | Sequentially accessed files only. Indicates a sequence error. The ascending key requirement of successive record key values has been violated, or the prime record key value has been changed by a COBOL program between successful execution of a READ statement and the execution of the next REWRITE statement for that file.
2 | Relative and indexed files only. Indicates a duplicate key value. An attempt has been made to write or rewrite a record that would create a duplicate key in a relative or indexed file.
3 | Indicates no record found. An attempt has been made to access a record identified by a key, and that record does not exist in the file.
3 | 0 | There was either a boundary violation for a sequential file or an I/O error, such as a data check parity error, or a transmission error.
4 | The I/O statement failed because of a boundary violation. This condition indicates that an attempt has been made to write beyond the externally defined boundaries of a sequential file.
9 | Extended file status code
Parent topic: ANSI File Status Summary


ANSI'85 File Status Codes

ANSI'85 file status codes include all ANSI'74 status codes together with the following status codes:

Status key 1 | Status key 2 | Description
0 | 4 | The length of the record being processed does not conform to the record length specified in the fixed file attributes for that file.
5 | The referenced optional file is not present at the time the OPEN statement is executed.
7 | Sequential files only. For a CLOSE statement with the REEL/UNIT phrase the referenced file is a non-reel/unit medium.
1 | 4 | Relative files only. The number of significant digits in the relative record number is larger than the number of significant digits in the relative key data item described for that file.
2 | 2 | Indexed and relative files only. Indicates a duplicate key condition. An attempt has been made to store a record that would create a duplicate key in the indexed or relative file or a duplicate alternate record key for a file that does not allow duplicates.
3 | The conditions listed under ANSI'74 code "23". In addition, a START or READ statement has been attempted on an optional input file that is not present.
4 Relative and indexed files only. Indicates a boundary violation arising from one of the following conditions:
  1. An atttempt has been made to write beyond the externally defined boundaries of a file.
  2. A sequential WRITE statement has been attempted for a relative file, but the number of significant digits in the relative record number was larger than the size of the relative key data item described for the file.
3 | 5 | An OPEN statement with the I-O, INPUT, or EXTEND phrases has been attempted on a non-OPTIONAL file that is not present.
7 | An OPEN statement has been attempted on a file which does not support the open mode specified in the OPEN statement.
8 | An OPEN statement has been attempted on a file previously closed with a lock.
9 | A conflict has been detected between the fixed file attributes specified for that file in the program.
4 | 1 | An OPEN has been attempted on a file already opened.
2 | A CLOSE has been attempted on a file already closed.
3 | Sequentially accessed files only. The last I/O statement executed for the file, prior to the execution of a DELETE or REWRITE statement, was not a READ statement.
4 | A boundary violation exists.
6 | A sequential READ statement has been attempted on a file open in the INPUT or I-O mode but no valid next record has been established.
7 | A READ or START statement has been attempted on a file not opened INPUT or I-O.
8 | A WRITE statement has been attempted: on a file not open in the OUTPUT, I-O or EXTEND mode; or on a file open in the I-O and sequential access modes.
9 | A DELETE or REWRITE statement has been attempted on a file that is not opened I-O.
Parent topic: ANSI File Status Summary


Reserved Words

This appendix details all of the words which are reserved words in the COBOL language.

  • Reserved Words Table
  • Context-sensitive Words Table
Parent topic: Part 4: Appendices


Reserved Words Table

The following table indicates which reserved words are enabled when a particular dialect is in use, as specified by the use of the appropriate Compiler directive.

If you use any of these words as identifiers in your COBOL sources, you have the following choices:
  • Change the source
  • Set an appropriate Micro Focus reserved word level using the MF or MFLEVEL Compiler directive
  • Remove the word explicitly (as a reserved word) by using the REMOVE Compiler directive, for example REMOVE(ENCODING)
# |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
3-D | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
A |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
ABSENT | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
ABSTRACT | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
ACCEPT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ACCESS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ACQUIRE | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
ACTION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ACTIVE-CLASS | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ACU
ACTIVE-X | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ACTUAL | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
ADD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ADDRESS | MF3 | ... | ... | I2 | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
ADDRESS-ARRAY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
ADDRESS-OFFSET | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
ADJUSTABLE-COLUMNS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ADVANCING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
AFP-5A | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
AFTER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ALIGNED | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
ALIGNMENT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ALL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ALLOCATE | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
ALLOW | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
ALLOWING | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ALPHABET | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
ALPHABETIC | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ALPHABETIC-LOWER | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
ALPHABETIC-UPPER | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
ALPHANUMERIC | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
ALPHANUMERIC-EDITED | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
ALSO | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ALTER | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ALTERNATE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
AND | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ANY | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
APPLY | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ACU
ARE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
AREA | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
AREAS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ARITHMETIC | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
AS | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ACU
ASCENDING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ASSEMBLY-ATTRIBUTES | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
ASSIGN | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
AT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ATTRIBUTE | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ACU
AUTHOR | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
AUTO | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ACU
AUTO-DECIMAL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
AUTO-HYPHEN-SKIP | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
AUTO-MINIMIZE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
AUTO-RESIZE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
AUTO-SKIP | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ACU
AUTO-SPIN | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
AUTOMATIC | MF1 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ACU
AUTOTERMINATE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
AX-EVENT-LIST | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
B |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
B-AND | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
B-EXOR | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
B-LEFT | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
B-NOT | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
B-OR | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
B-RIGHT | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
B-XOR | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
BACKGROUND-COLOR | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ACU
BACKGROUND-COLOUR | MF3 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BACKGROUND-HIGH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BACKGROUND-LOW | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BACKGROUND-STANDARD | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BACKWARD | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BAR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BASED | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
BASIS | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
BEEP | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | MS(1,2) | ... | ... | ... | ... | ... | ACU
BEFORE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
BEGINNING | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
BELL | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ACU
BINARY | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
BINARY | MF7 | ... | 85 | I2 | ... | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | RM | ... | ... | BS | OS390 | ENT | ... | ...
BINARY-CHAR | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
BINARY-DOUBLE | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
BINARY-LONG | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
BINARY-SHORT | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
BIND | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BIT | MF14 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
BITMAP | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BITMAP-END | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BITMAP-HANDLE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BITMAP-NUMBER | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BITMAP-RAW-HEIGHT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BITMAP-RAW-WIDTH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BITMAP-SCALE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BITMAP-START | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BITMAP-TIMER | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BITMAP-TRAILING | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BITMAP-WIDTH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BLANK | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
BLINK | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | RM | MS(1,2) | ... | ... | ... | ... | ... | ACU
BLINKING | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BLOB | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
BLOB-FILE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
BLOB-LOCATOR | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
BLOCK | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
BOLD | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BOOLEAN | MF14 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
BOTTOM | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
BOX | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BOXED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BROWSING | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
BUSY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BUTTONS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
BY | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
C |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
C01 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
C02 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
C03 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
C04 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
C05 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
C06 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
C07 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
C08 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
C09 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
C10 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
C11 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
C12 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CALENDAR-FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CALL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CALLED | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CANCEL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CANCEL-BUTTON | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CATCH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
CBL | ... | ... | ... | ... | ... | ... | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
CBL-CTR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
CCOL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CELL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CELL-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CELL-DATA | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CELL-FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CELL-PROTECTION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CELLS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CENTER | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CENTERED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CENTERED-HEADINGS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CENTURY-DATE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CENTURY-DAY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CF | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CH | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CHAIN | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
CHAINING | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
CHANGED | MF3 | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CHAR | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CHAR-VARYING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CHARACTER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CHARACTERS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CHART | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CHECK-BOX | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CHECKING | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
CLASS | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
CLASS-ATTRIBUTES | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
CLASS-CONTROL | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CLASS-ID | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
CLASS-OBJECT | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CLEAR-SELECTION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CLINE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CLINES | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CLOB | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CLOB-FILE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CLOB-LOCATOR | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CLOCK-UNITS | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CLOSE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
COBOL | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CODE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CODE-SET | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
COERCION | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
COL | MF3 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
COLLATING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
COLORS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
COLOUR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
COLOURS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
COLS | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
COLUMN | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
COLUMN-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
COLUMN-DIVIDERS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
COLUMN-FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
COLUMN-HEADINGS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
COLUMN-PROTECTION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
COLUMNS | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
COM-REG | ... | ... | ... | ... | ... | ... | ... | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
COMBO-BOX | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
COMMA | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
COMMIT | MF1 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
COMMITMENT | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
COMMON | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
COMMUNICATION | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
COMP | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
COMP-0 | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
COMP-1 | MF7 | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | ... | ... | BS | OS390 | ENT | ... | ...
COMP-2 | MF7 | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
COMP-3 | MF1 | ... | ... | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | ... | BS | OS390 | ENT | ... | ...
COMP-4 | MF7 | ... | ... | ... | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | MS(2) | ... | ... | ... | ... | ... | ...
COMP-5 | MF3 | ... | ... | ... | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | OS390 | ENT | ... | ...
COMP-6 | MF10 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ...
COMP-X | MF2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
COMPRESSION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
COMPUTATIONAL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
COMPUTATIONAL-0 | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
COMPUTATIONAL-1 | MF7 | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | ... | ... | BS | OS390 | ENT | ... | ...
COMPUTATIONAL-2 | MF7 | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
COMPUTATIONAL-3 | MF1 | ... | ... | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | ... | BS | OS390 | ENT | ... | ...
COMPUTATIONAL-4 | MF7 | ... | ... | ... | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | MS(2) | ... | ... | OS390 | ENT | ... | ...
COMPUTATIONAL-5 | MF3 | ... | ... | ... | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | OS390 | ENT | ... | ...
COMPUTATIONAL-6 | MF10 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ...
COMPUTATIONAL-X | MF2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
COMPUTE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CONDITION-VALUE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
CONFIGURATION | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CONSOLE | MF1 | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
CONSTANT | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CONSTRAIN | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
CONSTRAINTS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
CONTAINS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CONTENT | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
CONTINUE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
CONTROL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CONTROL-AREA | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CONTROLS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CONTROLS-UNCROPPED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CONVERSION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CONVERT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ...
CONVERTING | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
COPY | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
COPY-SELECTION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CORE-INDEX | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CORR | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CORRESPONDING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
COUNT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CREATE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
CREATING | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
CRT | MF1 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CRT-UNDER | MF1 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CSIZE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CSP | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
CURRENCY | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
CURRENT-DATE | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CURSOR | MF1 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CURSOR-COL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CURSOR-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CURSOR-FRAME-WIDTH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CURSOR-ROW | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CURSOR-X | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CURSOR-Y | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CUSTOM-ATTRIBUTE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
CUSTOM-PRINT-TEMPLATE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
CYCLE | MF7 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CYL-INDEX | ... | ... | ... | ... | ... | ... | ... | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
CYL-OVERFLOW | ... | ... | ... | ... | ... | ... | ... | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
D |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
DASHED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DATA | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DATA-COLUMNS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DATA-POINTER | MF15 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
DATA-TYPES | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DATABASE-KEY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
DATABASE-KEY-LONG | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
DATE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DATE-COMPILED | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DATE-ENTRY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DATE-RECORD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DATE-WRITTEN | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DAY | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DAY-OF-WEEK | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
DBCLOB | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DBCLOB-FILE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DBCLOB-LOCATOR | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DBCS | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | VS( 3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
DE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DEBUG | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
DEBUG-CONTENTS | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DEBUG-ITEM | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DEBUG-LINE | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DEBUG-NAME | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DEBUG-SUB-1 | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DEBUG-SUB-2 | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DEBUG-SUB-3 | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DEBUGGING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DECIMAL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
DECIMAL-POINT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DECLARATIVES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DECLARE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
DEFAULT | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
DEFAULT-BUTTON | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DEFAULT-FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DEFINITION | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
DELEGATE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
DELEGATE-ID | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
DELETE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DELIMITED | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DELIMITER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DEPENDING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DESCENDING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DESTINATION | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DESTROY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DETAIL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DICTIONARY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
DISABLE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DISC | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
DISJOINING | MF13 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
DISK | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
DISP | ... | ... | ... | ... | ... | ... | OS | ... | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
DISPLAY | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DISPLAY-1 | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
DISPLAY-COLUMNS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DISPLAY-FORMAT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DISPLAY-ST | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
DIVIDE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DIVIDER-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DIVIDERS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DIVISION | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DOT-DASH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DOTTED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DOWN | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DRAG-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DRAW | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DROP | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
DROP-DOWN | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DROP-LIST | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
DUPLICATES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
DYNAMIC | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
E |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
EBCDIC | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
ECHO | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ...
EGCS | ... | ... | ... | ... | ... | ... | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
EGI | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
EJECT | MF7 | ... | ... | ... | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | MS(2) | ... | BS | OS390 | ENT | ... | ...
ELEMENTARY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
ELSE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
EMI | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
EMPTY-CHECK | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
ENABLE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ENABLED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
END | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
END-ACCEPT | MF4 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
END-ADD | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-CALL | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-CHAIN | MF5 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
END-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
END-COMPUTE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-DELEGATE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
END-DELETE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-DISPLAY | MF7 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
END-DIVIDE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-EVALUATE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-IF | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-INVOKE | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-MODIFY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
END-MOVE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
END-MULTIPLY | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-OF-PAGE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
END-PERFORM | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-READ | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-RECEIVE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-RETURN | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-REWRITE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-SEARCH | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-START | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-STRING | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-SUBTRACT | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-SYNC | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
END-TRY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
END-UNSTRING | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-WAIT | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
END-WRITE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
END-XML | MF12 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ENT | ... | ...
ENDING | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
ENGRAVED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ENSURE-VISIBLE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ENTER | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ENTRY | MF5 | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
ENTRY-FIELD | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ENTRY-REASON | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ENUM | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
ENUM-ID | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
ENVIRONMENT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
EOL | MF7 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ...
EOP | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
EOS | MF7 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ...
EQUAL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
EQUALS | MF7 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
ERASE | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | RM | MS(1,2) | ... | ... | ... | ... | ... | ...
ERROR | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ESCAPE | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
ESCAPE-BUTTON | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ESI | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
EVALUATE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
EVENT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ACU
EVENT-LIST | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
EVENT-POINTER | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
EVERY | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
EXAMINE | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
EXCEEDS | MF7 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
EXCEPTION | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
EXCEPTION-OBJECT | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
EXCEPTION-VALUE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
EXCESS-3 | MF1 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
EXCLUDE-EVENT-LIST | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
EXCLUSIVE | MF1 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
EXEC | MF2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
EXECUTE | MF2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
EXHIBIT | MF3 | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
EXIT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
EXPAND | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
EXPANDS | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
EXTEND | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
EXTENDED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
EXTENDED-SEARCH | ... | ... | ... | ... | ... | ... | ... | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
EXTENSION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
EXTERNAL | MF2 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
EXTERNAL-FORM | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
EXTERNALLY-DESCRIBED-KEY | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
F |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
FACTORY | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
FALSE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
FD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
FH--FCD | MF5 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
FH--KEYDEF | MF5 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
FILE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
FILE-CONTROL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
FILE-ID | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
FILE-LIMIT | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
FILE-LIMITS | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
FILE-NAME | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FILE-POS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FILL-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FILL-COLOR2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FILL-PERCENT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FILLER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
FINAL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
FINALLY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
FINISH-REASON | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FIRST | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
FIXED | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
FIXED-FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FIXED-WIDTH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FLAT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FLAT-BUTTONS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FLOAT-EXTENDED | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
FLOAT-LONG | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
FLOAT-SHORT | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
FLOATING | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FOOTING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
FOR | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
FOREGROUND-COLOR | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ACU
FOREGROUND-COLOUR | MF3 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FOREVER | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
FORMAT | ... | ... | ... | I2 | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
FRAME | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FRAMED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FREE | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
FROM | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
FULL | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
FULL-HEIGHT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
FUNCTION | MF7 | ... | 85 | I2 | XO(1,2) | SAA(2) | ... | ... | ... | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
FUNCTION-ID | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
FUNCTION-POINTER | MF12 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ENT | ... | ...
G |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
GENERATE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
GET | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
GETTER | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
GIVING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
GLOBAL | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
GO | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
GO-BACK | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
GO-FORWARD | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
GO-HOME | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
GO-SEARCH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
GOBACK | MF5 | ... | ... | I2 | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
GRAPHICAL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
GREATER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
GRID | MF4 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
GRIP | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
GROUP | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
GROUP-USAGE | MF14 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ENT | ... | ...
GROUP-VALUE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
H |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
HANDLE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HAS-CHILDREN | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HEADING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
HEADING-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HEADING-DIVIDER-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HEADING-FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HEAVY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HEIGHT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HEIGHT-IN-CELLS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HELP-ID | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HIDDEN-DATA | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HIGH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ...
HIGH-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HIGH-VALUE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
HIGH-VALUES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
HIGHLIGHT | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
HORIZONTAL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HOT-TRACK | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HSCROLL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
HSCROLL-POS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
I |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
I-O | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
I-O-CONTROL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ICON | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ID | MF7 | ... | ... | ... | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
IDENTIFICATION | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
IDENTIFIED | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
IF | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
IGNORE | MF8 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
IGNORING | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
IMPLEMENTS | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
IN | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INDEPENDENT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
INDEX | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INDEXED | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INDEXER | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
INDEXER-ID | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
INDIC | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
INDICATE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INDICATOR | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
INDICATORS | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
INHERITING | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
INHERITS | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
INITIAL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INITIALIZE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
INITIALIZED | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
INITIATE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INPUT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INPUT-OUTPUT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INQUIRE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
INSERT | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
INSERT-ROWS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
INSERTION-INDEX | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
INSPECT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INSTALLATION | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INSTANCE | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
INTERFACE | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
INTERFACE-ID | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
INTERNAL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
INTO | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INTRINSIC | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
INVALID | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
INVOKE | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
INVOKED | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
IS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ITEM | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ITEM-BOLD | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ITEM-ID | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ITEM-TEXT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ITEM-TO-ADD | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ITEM-TO-DELETE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ITEM-TO-EMPTY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ITEM-VALUE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ITERATOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
ITERATOR-ID | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
J |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
JAPANESE | MF1 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
JOINED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
JOINING | MF13 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
JUST | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
JUSTIFIED | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
K |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
KANJI | MF8 | ... | ... | ... | ... | ... | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
KEPT | MF1 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
KEY | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
KEY-YY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
KEYBOARD | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
L |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
LABEL | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LABEL-OFFSET | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LARGE-FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LAST | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LAST-ROW | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LAYOUT-DATA | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LAYOUT-MANAGER | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LC_ALL | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LC_COLLATE | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LC_CTYPE | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LC_CURRENCY | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LC_MESSAGES | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LC_MONETARY | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LC_NUMERIC | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LC_TIME | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LEADING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LEADING-SHIFT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LEAVE | ... | ... | ... | ... | ... | ... | OS | ... | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LEFT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LEFT-JUSTIFY | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
LEFT-TEXT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LEFTLINE | MF4 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LENGTH | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LENGTH-CHECK | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
LESS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LIMIT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LIMITS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LIN | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
LINAGE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LINAGE-COUNTER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LINE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LINE-COUNTER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LINES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LINES-AT-ROOT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LINK | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LINKAGE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LIST | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
LIST-BOX | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LM-RESIZE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LOCAL-STORAGE | MF5 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
LOCALE | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LOCK | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LOCKING | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
LONG-DATE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LONG-VARBINARY | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LONG-VARCHAR | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LOW | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ...
LOW-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LOW-VALUE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LOW-VALUES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
LOWER | MF8 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
LOWERED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
LOWLIGHT | MF7 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
M |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
MANUAL | MF1 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
MASS-UPDATE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MASTER-INDEX | ... | ... | ... | ... | ... | ... | ... | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
MAX-HEIGHT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MAX-LINES | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MAX-PROGRESS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MAX-SIZE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MAX-TEXT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MAX-VAL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MAX-WIDTH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MDI-CHILD | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MDI-FRAME | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MEDIUM-FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MEMORY | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
MENU | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MERGE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
MESSAGE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
MESSAGES | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
METACLASS | ... | ... | ... | ... | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
METHOD | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
METHOD-ID | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
MIN-HEIGHT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MIN-LINES | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MIN-SIZE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MIN-VAL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MIN-WIDTH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MODAL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MODE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
MODELESS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MODIFIED | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
MODIFY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MODULES | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
MONITOR-POINTER | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
MORE-LABELS | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
MOVE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
MULTILINE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
MULTIPLE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
MULTIPLY | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
MUTEX-POINTER | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
N |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
NAME | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
NAMED | MF3 | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
NATIONAL | MF8 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ENT | ... | ...
NATIONAL-EDITED | MF8 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
NATIVE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
NAVIGATE-URL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NCHAR | MF5 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
NEGATIVE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
NESTED | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
NET-EVENT-LIST | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NEW | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
NEWABLE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
NEXT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
NEXT-ITEM | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
NO-AUTO-DEFAULT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-AUTOSEL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-BOX | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-CELL-DRAG | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-CLOSE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-DIVIDERS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-ECHO | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
NO-F4 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-FOCUS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-GROUP-TAB | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-KEY-LETTER | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-SEARCH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-TAB | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NO-UPDOWN | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NOMINAL | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
NONE | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
NORMAL | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
NOT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
NOTE | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
NOTIFY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NOTIFY-CHANGE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NOTIFY-DBLCLICK | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NOTIFY-SELCHANGE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NSTD-REELS | ... | ... | ... | ... | ... | ... | ... | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
NULL | MF6 | ... | ... | I2 | ... | ... | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
NULLS | MF6 | ... | ... | ... | ... | ... | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
NUM-COL-HEADINGS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NUM-ROW-HEADINGS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NUM-ROWS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
NUMBER | MF3 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
NUMBERS | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
NUMERIC | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
NUMERIC-EDITED | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
NUMERIC-FILL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
O |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
O-FILL | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
OBJECT | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
OBJECT-COMPUTER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
OBJECT-ID | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
OBJECT-REFERENCE | MF15 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
OBJECT-STORAGE | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
OCCURS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
OF | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
OFF | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
OK-BUTTON | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
OMITTED | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ON | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ONLY | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
OOSTACKPTR | MF10 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
OPEN | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
OPERATOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
OPERATOR-ID | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
OPTIONAL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
OPTIONS | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
OR | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ORDER | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
ORGANIZATION | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
OTHER | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
OTHERWISE | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
OUTPUT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
OVERFLOW | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
OVERLAP-LEFT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
OVERLAP-TOP | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
OVERLAPPED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
OVERLINE | MF4 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
OVERRIDE | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
P |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
PACKED-DECIMAL | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
PADDING | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
PAGE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PAGE-COUNTER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PAGE-SETUP | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PAGE-SIZE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PAGED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PANEL-INDEX | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PANEL-STYLE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PANEL-TEXT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PANEL-WIDTHS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PARAGRAPH | MF7 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PARAMS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
PARENT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ACU
PARSE | MF12 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ENT | ... | ...
PARTIAL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
PASSWORD | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
PERFORM | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PERMANENT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PF | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PH | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PIC | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PICTURE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PIXEL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PIXELS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PLACEMENT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PLUS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
POINTER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
POP-UP | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
POSITION | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
POSITION-SHIFT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
POSITIONING | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
POSITIVE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PREFIXING | MF13 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PRESENT | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PREVIOUS | MF3 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PRINT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ...
PRINT-CONTROL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PRINT-NO-PROMPT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PRINT-PREVIEW | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PRINT-SWITCH | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
PRINTER | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
PRINTER-1 | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PRINTING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PRIOR | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PRIORITY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PRIVATE | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PROCEDURE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PROCEDURE-POINTER | MF5 | ... | ... | ... | ... | ... | ... | ... | ... | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
PROCEDURES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PROCEED | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PROCESS | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PROCESSING | MF12 | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
PROGRAM | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PROGRAM-ID | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
PROGRAM-POINTER | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PROGRESS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PROMPT | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | MS(1,2) | ... | ... | ... | ... | ... | ...
PROPERTIES | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
PROPERTY | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
PROPERTY-ID | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
PROPERTY-VALUE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
PROTECTED | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PROTOTYPE | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PUBLIC | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
PURGE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
PUSH-BUTTON | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
Q |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
QUERY-INDEX | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
QUEUE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
QUOTE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
QUOTES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
R |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
RADIO-BUTTON | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
RAISE | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
RAISED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
RAISING | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
RANDOM | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RANGE | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
RD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
READ | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
READ-ONLY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
READING | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
READY | MF3 | ... | ... | ... | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | MS(2) | ... | ... | OS390 | ENT | ... | ...
RECEIVE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RECORD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RECORD-DATA | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
RECORD-OVERFLOW | ... | ... | ... | ... | ... | ... | OS | ... | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
RECORD-TO-ADD | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
RECORD-TO-DELETE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
RECORDING | MF3 | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
RECORDS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RECURSIVE | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
REDEFINE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
REDEFINES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
REDEFINITION | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
REEL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
REFERENCE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
REFERENCES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
REFRESH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
REGION-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
RELATION | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
RELATIVE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RELEASE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RELOAD | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
REMAINDER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
REMARKS | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ACU
REMOVAL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RENAMES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
REORG-CRITERIA | ... | ... | ... | ... | ... | ... | OS | ... | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
REPEATED | MF10 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
REPLACE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
REPLACING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
REPORT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
REPORTING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
REPORTS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
REPOSITORY | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
REQUIRED | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
REREAD | ... | ... | ... | ... | ... | ... | OS | ... | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
RERUN | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RESERVE | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RESET | MF3 | ... | ... | I2 | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | MS(2) | ... | BS | OS390 | ENT | ... | ...
RESET-GRID | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
RESET-LIST | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
RESET-TABS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
RESIZABLE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
RESTRICTED | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
RESULT-SET-LOCATOR | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RESUME | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
RETRY | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
RETURN | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RETURN-CODE | MF5 | ... | ... | ... | XO(1,2) | SAA(2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
RETURNING | MF5 | ... | ... | I2 | ... | ... | ... | ... | ... | C370,(2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
REVERSE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ...
REVERSE-VIDEO | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
REVERSED | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
REWIND | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
REWRITE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RF | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RH | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RIGHT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RIGHT-ALIGN | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
RIGHT-JUSTIFY | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
RIMMED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ROLLBACK | MF1 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
ROLLING | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
ROUNDED | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ROW-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ROW-COLOR-PATTERN | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ROW-DIVIDERS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ROW-FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ROW-HEADINGS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ROW-PROTECTION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
ROWID | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
RUN | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
S |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
S01 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
S02 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
S03 | ... | ... | ... | ... | ... | ... | ... | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
S04 | ... | ... | ... | ... | ... | ... | ... | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
S05 | ... | ... | ... | ... | ... | ... | ... | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SAME | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SAVE-AS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SAVE-AS-NO-PROMPT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SCREEN | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
SCROLL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SCROLL-BAR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SEARCH | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SEARCH-OPTIONS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SEARCH-TEXT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SECONDS | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SECTION | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SECURE | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
SECURITY | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SEEK | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SEGMENT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SEGMENT-LIMIT | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SELECT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SELECT-ALL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SELECTION-INDEX | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SELECTION-TEXT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SELECTIVE | ... | ... | ... | ... | ... | ... | OS | ... | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SELF | MF10 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
SELF-ACT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SELFCLASS | MF10 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SEMAPHORE-POINTER | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SEND | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SENTENCE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SEPARATE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SEPARATION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SEQUENCE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SEQUENTIAL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SERVICE | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
SET | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SETTER | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
SHADING | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SHADOW | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SHARING | MF11 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SHIFT-IN | ... | ... | ... | ... | ... | ... | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
SHIFT-OUT | ... | ... | ... | ... | ... | ... | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
SHORT-DATE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SHOW-LINES | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SHOW-NONE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SHOW-SEL-ALWAYS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SIGN | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SIGNED | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SIZE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SKIP1 | MF7 | ... | ... | ... | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
SKIP2 | MF7 | ... | ... | ... | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
SKIP3 | MF7 | ... | ... | ... | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
SMALL-FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SORT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SORT-CONTROL | ... | ... | ... | ... | ... | ... | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
SORT-CORE-SIZE | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
SORT-FILE-SIZE | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
SORT-MERGE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SORT-MESSAGE | ... | ... | ... | ... | ... | ... | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
SORT-MODE-SIZE | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
SORT-OPTION | ... | ... | ... | ... | ... | ... | ... | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SORT-ORDER | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SORT-RETURN | MF7 | ... | ... | ... | ... | SAA(2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
SORT-TAPE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
SORT-TAPES | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
SOURCE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SOURCE-COMPUTER | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SOURCES | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SPACE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SPACE-FILL | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
SPACES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SPECIAL-NAMES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SPINNER | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SQL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SQUARE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
STANDARD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
STANDARD-1 | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
STANDARD-2 | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
STANDARD-3 | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
START | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
START-X | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
START-Y | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
STARTING | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
STATIC | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
STATIC-LIST | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
STATUS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
STATUS-BAR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
STATUS-TEXT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
STEP | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
STOP | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
STOP-BROWSER | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
STRING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
STRONG | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
STYLE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SUB-QUEUE-1 | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SUB-QUEUE-2 | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SUB-QUEUE-3 | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SUBFILE | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SUBTRACT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SUBWINDOW | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SUFFIXING | MF13 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SUM | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SUPER | MF10 | ... | ... | I2 | ... | ... | ... | ... | ... | C370(2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
SUPPRESS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SYMBOL | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | OS390 | ENT | ... | ...
SYMBOLIC | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SYNC | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SYNCHRONIZED | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
SYSIN | ... | ... | ... | ... | ... | ... | OS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SYSIPT | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SYSLST | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SYSOUT | ... | ... | ... | ... | ... | ... | OS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SYSPCH | ... | ... | ... | ... | ... | ... | ... | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SYSPUNCH | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SYSTEM | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
SYSTEM-DEFAULT | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
SYSTEM-INFO | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
T |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
TAB | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | ... | ... | ... | ... | ... | ... | ...
TAB-CONTROL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TAB-TO-ADD | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TAB-TO-DELETE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TABLE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TALLY | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
TALLYING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TAPE | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TAPES | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
TEMPORARY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TERMINAL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TERMINAL-INFO | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TERMINATE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TERMINATION-VALUE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TEST | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
TEXT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | ... | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
THAN | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
THEN | MF1 | ... | 85 | I2 | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
THREAD | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
THREAD-LOCAL | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
THREAD-LOCAL-STORAGE | MF10 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
THREAD-POINTER | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
THROUGH | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
THRU | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
THUMB-POSITION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TILED-HEADINGS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TIME | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TIME-OF-DAY | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
TIME-OUT | MF7 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
TIME-RECORD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TIMEOUT | MF7 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
TIMES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TIMESTAMP | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TIMESTAMP-OFFSET | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TIMESTAMP-OFFSET-RECORD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TIMESTAMP-RECORD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TITLE | MF7 | ... | ... | ... | ... | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
TITLE-BAR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TITLE-POSITION | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TO | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TOOL-BAR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TOP | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TOTALED | ... | ... | ... | ... | ... | ... | OS | ... | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
TOTALING | ... | ... | ... | ... | ... | ... | OS | ... | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
TRACE | MF3 | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | MS(2) | ... | ... | OS390 | ENT | ... | ...
TRACK-AREA | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
TRACK-LIMIT | ... | ... | ... | ... | ... | ... | OS | ... | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
TRACK-THUMB | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TRACKS | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
TRADITIONAL-FONT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TRAILING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TRAILING-SHIFT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TRAILING-SIGN | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
TRANSACTION | ... | ... | ... | ... | ... | SAA(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
TRANSFORM | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2) | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
TRANSPARENT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TRANSPARENT-COLOR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TREE-VIEW | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
TRUE | MF7 | ... | 85 | I2 | XO(1,2) | SAA(1,2) | ... | ... | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | BS | OS390 | ENT | ... | ...
TRY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
TYPE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
TYPEDEF | MF10 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
U |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
UCS-4 | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UNDERLINE | MF3 | ... | ... | I2 | XO(1,2) | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
UNDERLINED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
UNEQUAL | MF7 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UNFRAMED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
UNIT | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
UNITS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
UNIVERSAL | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | BS | ... | ... | ... | ...
UNLOCK | MF1 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | RM | MS(1,2) | ... | ... | ... | ... | ... | ...
UNSIGNED | MF12 | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UNSORTED | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
UNSTRING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
UNTIL | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
UP | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
UPDATE | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | RM | MS(1,2) | ... | ... | ... | ... | ... | ...
UPON | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
UPPER | MF8 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UPSI-0 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UPSI-1 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UPSI-2 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UPSI-3 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UPSI-4 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UPSI-5 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UPSI-6 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UPSI-7 | ... | ... | ... | ... | ... | ... | OS | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
USAGE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
USE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
USE-ALT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
USE-RETURN | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
USE-TAB | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
USER | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
USER-COLORS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
USER-DEFAULT | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
USER-GRAY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
USER-WHITE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
USING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
UTF-16 | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
UTF-8 | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
V |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
VALID | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
VALIDATE | ... | ... | ... | I2 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
VALUE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
VALUE-FORMAT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
VALUES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
VALUETYPE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
VALUETYPE-ID | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
VARBINARY | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
VARIABLE | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
VARIANT | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
VARYING | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
VERTICAL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
VERY-HEAVY | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
VIRTUAL-WIDTH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
VISIBLE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
VPADDING | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
VSCROLL | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
VSCROLL-BAR | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
VSCROLL-POS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
VTOP | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
W |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
WAIT | MF8 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
WEB-BROWSER | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
WHEN | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
WHEN-COMPILED | MF7 | ... | ... | ... | ... | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
WHERE | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
WIDTH | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
WIDTH-IN-CELLS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
WINDOW | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
WITH | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
WORDS | MF1 | 74 | 85 | ... | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
WORKING-STORAGE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
WRAP | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
WRITE | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
WRITE-ONLY | ... | ... | ... | ... | ... | ... | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | ... | ... | ... | ... | OS390 | ENT | ... | ...
WRITE-VERIFY | ... | ... | ... | ... | ... | ... | ... | DVS | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
WRITING | MF11 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ...
X |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
X | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
XML | MF12 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
XML-CODE | MF12 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ENT | ... | ...
XML-EVENT | MF12 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ENT | ... | ...
XML-NTEXT | MF12 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ENT | ... | ...
XML-TEXT | MF12 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ENT | ... | ...
Y |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
Y | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ACU
YIELDING | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MGD | ...
YYYYDDD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
YYYYMMDD | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
Z |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |
ZERO | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ZERO-FILL | MF3 | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | ... | MS(2) | ... | ... | ... | ... | ... | ...
ZEROES | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...
ZEROS | MF1 | 74 | 85 | I2 | XO(1,2) | SAA(1,2) | OS | DVS | VS(1,2,3,4) | C370(1,2) | MVS | RM | MS(1,2) | DG | BS | OS390 | ENT | ... | ...

Key

The definitions of the dialect codes in the table are given below.

Dialect Code | Compiler Directive | Meaning
74 | None | Word reserved in ANSI 74 standard
85 | ANS85 | Word reserved in ANSI 85 standard
I2 | ISO2002 | Word reserved in ISO 2002 standard
OS | OSVS | Word reserved in OSVS COBOL
VS(2) | VSC2"2" | Word reserved in VS COBOL II revision 2
VS(3) | VSC2"3" | Word reserved in VS COBOL II revision 3, IBM LE COBOL/370 and IBM COBOL for MVS and VM unless indicated otherwise
VS(4) | VSC2"4" | Word reserved in VS COBOL II revision 4, IBM LE COBOL/370 and IBM COBOL for MVS and VM unless indicated otherwise
C370 | COBOL370"2" | Word reserved in IBM LE COBOL/370 revision 2 and IBM COBOL for MVS and VM, but not in VS COBOL II
OS390 | OS390 | Word reserved in COBOL for OS/390 and VM V2R2, but not in IBM LE COBOL/370 revision 2 and IBM COBOL for MVS and VM
ENT | ENTCOBOL | Word reserved in IBM Enterprise COBOL for z/OS and OS/390
XO | XOPEN | Word reserved as part of X/Open definition
MF1 | MF"1" | Word reserved in Micro Focus LEVEL II COBOL, LEVEL II COBOL/ET and Professional COBOL
MF2 | MF"2" | As MF1 plus additional features in Micro Focus VS COBOL Workbench V1.2
MF3 | MF"3" | As MF2 plus additional features in Micro Focus VS COBOL Workbench V1.3 and V2.0, Professional COBOL V2.0 and Micro Focus V1.5
MF4 | MF"4" | As MF3 plus additional features in Micro Focus COBOL/2 V1.1, Microsoft COBOL" V3.0 and IBM COBOL V2
MF5 | MF"5" | As MF4 plus additional features in Micro Focus COBOL/2 V1.2 and Micro Focus COBOL/2 Workbench V2.3
MF6 | MF"6" | As MF5 plus additional features in Micro Focus COBOL/2 V2.4 and Micro Focus COBOL/2 Workbench V2.4
MF7 | MF"7" | As MF6 plus additional features in Micro Focus COBOL/2 V2.5 and Micro Focus COBOL/2 Workbench V2.5
MF8 | MF"8" | As MF7 plus additional features in Micro Focus COBOL V3.0 and Micro Focus COBOL Workbench V3.0
MF9 | MF"9" | As MF8 plus additional features in Micro Focus COBOL V3.1 and Micro Focus COBOL Workbench V3.1
MF10 | MF"10" | As MF9 plus additional features in Micro Focus COBOL V3.2 and Micro Focus COBOL Workbench V3.2
MF11 | MF"11" | As MF10 plus additional features in Micro Focus Net Express 3.0
MF12 | MF"12" | As MF11 plus additional features in Micro Focus Mainframe Express 3.0 and 3.1; Net Express 4.0, 5.0, and 5.1; and Server Express 4.0, 5.0, and 5.1
MF13 | MF"13" | As MF12 plus additional features in Micro Focus Net Express 5.1 WS2 and Server Express 5.1 WS2
MF14 | MF"14" | As MF13 plus additional features in Micro Focus Net Express 6.0 and Server Express 6.0
MF15 | MF"15" | As MF14 plus additional features in Micro Focus Net Express 5.1 WS5 and 6.0 WS2, and Server Express 5.1 WS5 and 6.0 WS2
MS1 | MS"1" | Word reserved in Microsoft COBOL Version 1
MS2 | MS"2" | Word reserved in Microsoft COBOL Version 2
RM | RM | Word reserved in RM/COBOL
DVS | DOSVS | Word reserved in DOSVS COBOL
BS | BS2000 | Word reserved in Siemens BS2000 COBOL
MGD | ILGEN or DOTNET | Word reserved in managed COBOL.
Parent topic: Reserved Words


Context-sensitive Words Table

The following table lists context-sensitive words, which are words that are reserved in the specified language construct when the specified dialect is chosen. If a context-sensitive word is used where a context-sensitive word is permitted in the general format, the word is treated as a keyword; otherwise, it is treated as a user-defined word. The dialect codes have the same meanings as in the section Reserved Words Table.

Context-sensitive Word | Language Context or Construct | Dialect Code
ARITHMETIC | OPTIONS paragraph | I2
ATTRIBUTE | SET statement | I2
AUTO | screen description entry | I2, XO, MF3, MS2
BACKGROUND-COLOR | screen description entry | I2, XO, MF3, MS2
BACKGROUND-COLOUR | screen description entry | I2, MF3
BELL | screen description entry and SET attribute statement | I2, XO, MF3, MS2
BLINK | screen description entry and SET attribute statement | I2, XO, MF3, RM, MS2
CENTER | COLUMN clause | I2
CYCLE | EXIT statement | I2, MF7
DATA-POINTER |  | I2, MF15
EOL | ERASE phrase in screen description entry | I2, XO, MF7, RM
EOS | ERASE phrase in screen description entry | I2, XO, MF7, RM
ERASE | screen description entry | I2, XO, MF3, RM, MS2
EXPANDS | CLASS phrase and INTERFACE phrase of the REPOSITORY paragraph | I2, MF12
FOREGROUND-COLOR | screen description entry | I2, XO, MF3, MS2
FOREGROUND-COLOUR | screen description entry | I2, MF3
FOREVER | RETRY phrase | I2
FULL | screen description entry | I2, XO, MF3, MS2
HIGH | ACCEPT statement and DISPLAY statement | RM
HIGHLIGHT | screen description entry and SET attribute statement | I2, XO, MF3, MS2
IGNORING | READ statement | I2
INITIALIZED | ALLOCATE statement | I2
INTRINSIC | function-specifier of the REPOSITORY paragraph | I2
LC_ALL | SET statement | I2
LC_COLLATE | SET statement | I2
LC_CTYPE | SET statement | I2
LC_MESSAGES | SET statement | I2
LC_MONETARY | SET statement | I2
LC_NUMERIC | SET statement | I2
LC_TIME | SET statement | I2
LOW | ACCEPT statement and DISPLAY statement | RM
LOWLIGHT | screen description entry and SET attribute statement | I2, XO, MF7
MANUAL | LOCK MODE clause | I2, MF1, MS2
MULTIPLE | LOCK ON clause | all dialects
NONE | DEFAULT clause | I2
NORMAL | STOP statement | I2
NUMBERS | COLUMN clause and LINE clause | I2
ONLY | Object-view, SHARING clause, SHARING phrase and USAGE clause | I2, MF11, BS
PARAGRAPH | EXIT statement | I2, MF7
PREVIOUS | READ statement | I2, MF3
RECURSIVE | PROGRAM-ID paragraph | I2, MF12, C370
RELATION | VALIDATE-STATUS clause | I2
REQUIRED | screen description entry | I2, XO, MF3, MS2
REVERSE | ACCEPT statement and DISPLAY statement | RM
REVERSE-VIDEO | screen description entry and SET attribute statement | I2, XO, MF3, MS2
SECONDS | RETRY phrase | I2
SECURE | screen description entry | I2, XO, MF3, MS2
SIGNED | USAGE clause | I2, MF12
STEP | OCCURS clause | I2
STRONG | TYPEDEF clause | I2
SYMBOL | CURRENCY clause | I2, MF12, OS390
UCS-4 | ALPHABET clause | I2
UNDERLINE | screen description entry and SET attribute statement | I2, XO, MF3, MS2
UNSIGNED | USAGE clause | I2, MF12
UTF-8 | ALPHABET clause | I2
UTF-16 | ALPHABET clause | I2
YYYYDDD | ACCEPT statement | all dialects
YYYYMMDD | ACCEPT statement | all dialects
Parent topic: Reserved Words
Related information
Reserved Words Table


XML-CODE Exception Codes

Your COBOL system supports a subset of the exception codes that are available on the mainframe for the XML-CODE special register. Support is provided for the following exception codes.

Code | Description
1 | The parser found an invalid character while scanning white space outside element content.
2 | The parser found an invalid start of a processing instruction, element, comment or document type declaration outside element content.
3 | The parser found a duplicate attribute name.
4 | The parser found the markup character '<' in an attribute value.
5 | The start and end tag names of an element did not match.
6 | The parser found an invalid character in element content.
8 | The parser found in element content the CDATA closing character sequence '' without the matching opening character sequence ''.
9 | The parser found an invalid character in a comment.
10 | The parser found in a comment the character sequence '--' (dashdash) not followed by '>'.
11 | The parser found an invalid character in a processing instruction data segment.
12 | A processing instruction target name was 'xml' in lower-case, upper-case or mixed-case.
13 | The parser found an invalid digit in a hexadecimal character reference (of the form &#xdddd;).
14 | The parser found an invalid digit in a decimal character reference (of the form &#dddd;).
15 | The encoding declaration value in the XML declaration did not begin with lower- or upper-case A through Z
16 | A character reference did not refer to a legal XML character.
17 | The parser found an invalid character in an entity reference name.
18 | The parser found an invalid character in an attribute value.
100 | The parser reached the end of the document while scanning the start of the XML declaration.
101 | The parser reached the end of the document while looking for the end of the XML declaration.
102 | The parser reached the end of the document while looking for the root element.
103 | The parser reached the end of the document while looking for the version information in the XML declaration.
104 | The parser reached the end of the document while looking for the version information value in the XML declaration.
106 | The parser reached the end of the document while looking for the encoding declaration value in the XML declaration.
108 | The parser reached the end of the document while looking for the standalone declaration value in the XML declaration.
109 | The parser reached the end of the document while scanning an attribute name.
110 | The parser reached the end of the document while scanning an attribute value.
111 | The parser reached the end of the document while scanning a character reference or entity reference in an attribute value.
112 | The parser reached the end of the document while scanning an empty element tag.
113 | The parser reached the end of the document while scanning the root element name.
114 | The parser reached the end of the document while scanning an element name.
115 | The parser reached the end of the document while scanning character data in element content.
116 | The parser reached the end of the document while scanning a processing instruction in element content.
117 | The parser reached the end of the document while scanning a comment or CDATA section in element content.
118 | The parser reached the end of the document while scanning a comment in element content.
119 | The parser reached the end of the document while scanning a CDATA section in element content.
120 | The parser reached the end of the document while scanning a character reference or entity reference in element content.
122 | The parser found a possible invalid start of a document type declaration.
123 | The parser found a second document type declaration.
124 | The first character of the root element name was not a letter, '_' or ':'.
125 | The first character of the first attribute name of an element was not a letter, '_' or ':'.
126 | The parser found an invalid character either in or following an element name.
127 | The parser found a character other than '=' following an attribute name.
128 | The parser found an invalid attribute value delimiter.
130 | The first character of an attribute name was not a letter, '_' or ':'.
131 | The parser found an invalid character either in or following an attribute name.
132 | An empty element tag was not terminated by a '>' following the '/'.
133 | The first character of an element end tag name was not a letter, '_' or ':'.
134 | An element end tag name was not terminated by a '>'.
135 | The first character of an element name was not a letter, '_' or ':'.
138 | The first character of a processing instruction target name was not a letter, '_' or ':'.
139 | The parser found an invalid character in or following a processing instruction target name.
140 | A processing instruction was not terminated by the closing character sequence '?>'.
141 | The parser found an invalid character following '&' in a character reference or entity reference.
142 | The version information was not present in the XML declaration.
143 | 'version' in the XML declaration was not followed by a '='.
144 | The version declaration value in the XML declaration is either missing or improperly delimited.
145 | The version information value in the XML declaration specified a bad character, or the start and end delimiters did not match.
146 | The parser found an invalid character following the version information value closing delimiter in the XML declaration.
147 | The parser found an invalid attribute instead of the optional encoding declaration in the XML declaration.
148 | 'encoding' in the XML declaration was not followed by a '='.
149 | The encoding declaration value in the XML declaration is either missing or improperly delimited.
150 | The encoding declaration value in the XML declaration specified a bad character, or the start and end delimiters did not match.
151 | The parser found an invalid character following the encoding declaration value closing delimiter in the XML declaration.
152 | The parser found an invalid attribute instead of the optional standalone declaration in the XML declaration.
153 | 'standalone' in the XML declaration was not followed by a '='.
154 | The standalone declaration value in the XML declaration is either missing or improperly delimited.
155 | The standalone declaration value was neither 'yes' nor 'no' only.
156 | The standalone declaration value in the XML declaration specified a bad character, or the start and end delimiters did not match.
157 | The parser found an invalid character following the standalone declaration value closing delimiter in the XML declaration.
158 | The XML declaration was not terminated by the proper character sequence '?>', or contained an invalid attribute.
159 | The parser found the start of a document type declaration after the end of the root element.
160 | The parser found the start of an element after the end of the root element.
201 | Miscellaneous XML document parsing errors.
300 | The document was encoded in EBCDIC, but the CODEPAGE compiler option specified a supported ASCII code page.
306 | The document was encoded in ASCII, but the CODEPAGE compiler option specified a supported EBCDIC code page.
310 | The CODEPAGE compiler option specified a supported EBCDIC code page, but the document was encoded in Unicode.
Parent topic: Part 4: Appendices


Glossary

!

77 level-description-entry

A data description entry that describes a noncontiguous data item with the level-number 77.

78 level-description-entry

A data description entry that describes a constant-name with the level-number 78.

88 level-description-entry

A data description entry that describes a condition-name with the level-number 88.

A

abbreviated combined relation condition

The combined condition that results from the omission of a common subject or a common subject and common relational operator in a consecutive sequence of relation conditions.

abstract class

A class which does not act as a creator of instance objects. Abstract classes implement behavior for their subclasses.

access mode

The manner in which records are to be operated upon within a file.

activated runtime element

A function, method or program placed into the active state by a statement.

activating runtime element

A function, method or program that contains the activating statement.

activating statement

A statement that causes the execution of a function, method or program.

active state

The state of a function, method or program that has been activated but has not yet returned to the activating runtime element.

actual decimal point

The physical representation, using either of the decimal point characters "." (period) or "," (comma), of the decimal point position in a data item.

alphabet-name

A user-defined word in the Special-Names paragraph of the Environment Division that assigns a name to a specific character set and/or collating sequence.

alphabetic character

A character that belongs to the following set of letters: A, B, C, D, E, F, G, H, I, J, K, L, M, N, O, P, Q, R, S, T, U, V, W, X, Y, Z, a, b, c, d, e, f, g, h, i, j, k, l, m, n, o, p, q, r, s, t, u, v, w, x, y and z and the space.

alphanumeric character

Any letter or number in the computer's character set.

alphanumeric function

A function whose value is composed of a string of one or more characters from the computer's character set.

alternate record key

A key, other than the prime record key, whose contents identify a record within an indexed file.

argument

An operand specified in the activating statement of a function, a method or a program that specifies the data to be passed upon activation of the intrinsic function or runtime element.

arithmetic expression

An identifier or a numeric elementary item, a numeric literal, such identifiers and literals separated by arithmetic operators, two arithmetic expressions separated by an arithmetic operator, or an arithmetic expression enclosed in parentheses.

arithmetic operator

A single character, or a fixed two-character combination, that belongs to the following set:

Character Meaning
+ Addition
- Subtraction
* Multiplication
/ Division
** Exponentiation
ascending key

A key upon the values of which data is ordered starting with the lowest value of key up to the highest value of key in accordance with the rules for comparison of data items.

assumed decimal point

A decimal point position which does not involve the existence of an actual character in a data item. The assumed decimal point has logical meaning but no physical representation.

at end condition

A condition caused in one of three circumstances:

  1. During the execution of a READ statement for a sequentially accessed file.
  2. During the execution of a RETURN statement when no next logical record exists for the associated sort or merge file.
  3. During the execution of a SEARCH statement, when the search operation terminates without satisfying the condition specified in any of the associated WHEN phrases.
automatic data

The data described in the Local-Storage Section.

automatic data item

A data item that is described as part of an automatic data record.

automatic data record

A logical record that is described in the Local-Storage Section.

B

block

A physical unit of data that is normally composed of one or more logical records. For mass storage files, a block can contain a portion of a logical record. The size of a block has no direct relationship to the size of the file within which the block is contained or to the size of the logical record(s) that are either continued within the block or that overlap the block. The term is equivalent to physical record.

C

call prototype

A program with the EXTERNAL clause in the Program-ID paragraph. A call prototype is a program declaration that is not executed but is used by the compiler system to validate CALL statements in program definitions that appear in the same source file.

called program

A program that receives control as the result of the execution of a CALL statement.

calling runtime element

A function, method or program that transfers control to a program by execution of a CALL statement.

chained program

A program which is the object of a CHAIN statement.

chaining program

A program which executes a CHAIN to another program.

character

The basic indivisible unit of the language.

character boundary

The leftmost bit of an addressing boundary in the storage of the computer.

character position

The amount of physical storage required to store a single standard data format character described as USAGE IS DISPLAY.

character set

The complete COBOL language character set consists of all the characters listed below:

Character | Meaning
0,1,...,9 | Numeric digit
A,B,...,Z | Upper-case alphabetic
a,b,...,z | Lower-case alphabetic
Space (blank)
+ Plus sign
- Minus sign
* Asterisk
/ Stroke (virgule, slant or slash)
= Equal sign
$ Currency sign
, Comma
; Semicolon
. Period (decimal point, full stop)
" Quotation mark
( Left parenthesis
) Right parenthesis
> Greater than symbol
< Less than symbol
: Colon
' Apostrophe
& Ampersand
Note: If the computer character set includes lower-case letters, they can be used in character strings and text words. Except when used in nonnumeric literals, each lower-case letter is equivalent to the corresponding upper-case letter.
character-string

A sequence of contiguous characters which form a COBOL word, a literal, a PICTURE character-string or a comment-entry.

class

The entity that defines common behavior and implementation for zero, one or more objects. Objects that share the same implementation are considered to be objects of the same class.

class condition

The proposition, for which a truth value can be determined, that an operand is wholly alphabetic or is wholly numeric, or alphabetic-lower, or alphabetic-upper, or contains only the characters in the set of characters specified by the CLASS clause as defined in the Special-Names paragraph of the Environment Division.

class definition

The source unit that defines a class.

class method

A method for a class object.

class-name (for object orientation)

A user-defined word that identifies a class.

class-name (for truth value proposition)

A user-defined word defined in the Special-Names paragraph of the Environment Division that assigns a name to the proposition for which a truth value can be determined, that the content of a data item consists exclusively of those characters listed in the definition of the class-name.

clause

An ordered set of consecutive COBOL character-strings whose purpose is to specify an attribute of an entry.

COBOL word

See word.

collating sequence

The sequence in which the characters that are acceptable in a computer are ordered for purposes of sorting, merging, comparing and for processing indexed files sequentially.

column

A character position within a print line or a screen line. The columns are numbered from one, by one, starting at the leftmost character position of the line and extending to the rightmost character position of the line.

combined condition

A condition that is the result of connecting two or more conditions with the "AND" or the "OR" logical operator.

comment entry

An entry in the Identification Division that can be any combination of characters from the computer's character set. A comment entry is for documentary purposes only, may extend over more than one line and is terminated upon encountering a division, section or paragraph name or encountering any character in area A of a line.

comment indicator

The two contiguous COBOL characters '*>', which indicate a comment line or an in-line comment.

comment line

A source line represented by an asterisk in the indicator area of the line and any characters from the computer's character set in area A and area B of that line. The comment line serves only for documentation . A special form of comment line is represented by a slash (/) in the indicator area of the line and any characters from the computer's character set in area A and area B of that line causes page ejection before the comment is printed.

common program

A program that is directly contained within another program, and can be called from any program directly or indirectly contained in that other program.

compilation group

A sequence of source units submitted for compilation together.

compilation unit

A source unit that is not nested within another source unit.

compile time

The time at which a compilation group is translated to a runtime module consisting of one or more executable runtime elements.

compiler-directing statement

A compiler directive or a source text manipulation statement.

compiler directive

An instruction to the COBOL Compiler to take specific action when compiling a compilation group.

compiler directive line

A line of source text beginning with the two contiguous COBOL characters >> followed by a compiler-directive word.

compiler-directive word

A COBOL word that is used in the syntax of a compiler directive.

complex condition

A condition in which one or more logical operators act upon one or more conditions. See negated simple condition, combined condition, negated combined condition.

computer-name

A system-name that identifies the computer upon which the compilation group is to be converted to object code, or the object code run.

condition

A status for which a truth value can be determined at execution time. Where the term "condition" (condition-1, condition-2, ...) appears in a general format or in rules that reference a general format, it is a conditional expression consisting of either a simple condition optionally parenthesized, or a combined condition consisting of a syntactically correct combination of simple conditions, logical operators, and parentheses for which a truth value can be determined.

condition-name

A user-defined word assigned to a specific value, set of values, or range of values, within the complete set of values that a conditional variable can possess; or the user-defined word assigned to a status of an implementor-defined switch or device.

condition-name condition

The proposition, for which a truth value can be determined, that the value of a conditional variable is a member of the set of values attributed to a condition-name associated with the conditional variable.

conditional expression

A simple condition or a complex condition specified in an IF, PERFORM, EVALUATE or SEARCH statement. See simple condition and complex condition.

conditional statement

A statement for which the truth value of a specified condition is evaluated and used to determine subsequent flow of control.

conditional variable

A data item, one or more values of which has a condition-name assigned to it.

Configuration Section

A section of the Environment Division that describes overall specifications of source and run computers.

conformance (for object orientation)

The property that allows an object with a given interface to be used where an object with a different interface is expected. Conformance ensures that any operation specified for the conformed interface is supported by the conforming interface.

constant-name

A user-defined word assigned as the name of a fixed value.

context-sensitive words

COBOL words that are specified in formats but are reserved only in the context in which they are specified.

contiguous items

Items that are described by consecutive entries in the Data Division and that bear a definite hierarchic relationship to one another.

counter

A data item used for storing numbers or number representations in a manner that permits these numbers to be increased or decreased by the value of another number, or to be changed or reset to zero or to an arbitrary positive or negative value.

CRT status

A conceptual entity whose value is set to indicate the status of a terminal input-output operation during the execution of an ACCEPT screen statement.

currency sign

The COBOL character '$', used as the default currency symbol in a picture character-string and as the default currency string that appears in the edited format of data items.

Note: Features exist for selection of other currency strings and currency symbols.
currency string

The set of characters to be placed into numeric-edited data items as a result of editing operations when the item includes a currency symbol in its picture character-string. See the topic The Special-Names Paragraph.

currency symbol

The character used in a picture character-string to represent the presence of a currency string. See the section The Special-Names Paragraph.

current record

In file processing, the record that is available in the record area associated with a file.

current volume pointer

A conceptual entity that points to the current volume of a sequential file.

cursor

A visible indicator on a character-addressable terminal screen that shows the position on the screen at which the next data character input at the keyboard will be displayed.

cursor control keys

Keys on the keyboard of a character-addressable terminal that control the positioning of the cursor on the screen. Typically these include keys that move the cursor up, down, left, right, to the next screen item, to the previous screen item.

D

data description entry

An entry in the Data Division that is composed of a level-number followed by a data-name, if required, and then followed by a set of data clauses as required.

data item

A unit of data defined by a data description entry or resulting from the evaluation of an identifier.

data keys

Keys on the keyboard of a character-addressable terminal that represent individual printable data characters.

data-name

A user-defined word that names a data item described in a data description entry in the Data Division. When used in the general formats, "data-name" represents a word which can neither be subscripted nor indexed unless specifically permitted by the rules for that format.

DBCS

See double-byte character set.

debugging Line

Any line with "D" or "d" in the indicator area of the line for fixed format source, or any line with "D" or "d" as the first character and space as the second character of the line for free format source.

Debugging Section

A section that contains a USE FOR DEBUGGING statement.

declaratives

A set of one or more special purpose sections written at the beginning of the Procedure Division, the first of which is preceded by the key word DECLARATIVES and the last of which is followed by the key words END DECLARATIVES. A declarative is composed of a section header, followed by a USE COBOL system-directing-sentence, followed by a set of associated paragraphs (zero or more).

declarative-sentence

A COBOL system-directing sentence consisting of a single USE statement terminated by the separator period (. ).

de-edit

The logical removal of all editing characters from a numeric-edited data item in order to determine that item's unedited numeric value.

delimited scope statement

Any statement that includes its explicit scope terminator.

delimiter

A character (or sequence of contiguous characters) that identifies the end of a string of characters, and separates that string of characters from the following string of characters. A delimiter is not part of the string of characters that it delimits.

descending key

A key upon the values of which data is ordered starting with the highest value of key down to the lowest value of key, in accordance with the rules for comparing data items.

digit position

The amount of physical storage required to store a single digit. This amount varies depending on the usage of the data item describing the digit position.

division

There are four divisions in a COBOL source element: Identification, Environment, Data and Procedure. Each division consists of zero or more sections or paragraphs.

division header

A combination of words followed by a period and a space that indicate the beginning of a division. The division headers are:

double-byte character set

A character set in which two bytes are used for each character.

dynamic access

An access mode in which specific logical records can be obtained from or placed into a disk file in a non-sequential manner (see random access) and obtained from a file in a sequential manner (see sequential access) during the scope of the same OPEN statement.

E

editing character

A single character or two-character combination that is specified in the PICTURE character-string and inserted into the data item when it is edited.

elementary item

A data item that is not logically subdivided.

end marker

A marker for the end of a source unit.

end of Procedure Division

The physical position in a COBOL source element after which no further procedures appear.

end program marker
A combination of words, followed by a separator period, that indicates the end of a COBOL source program. The end program header is:
 END PROGRAM program-name.
Enter key

A key on the keyboard of a character-addressable terminal that signals that the input of the screen item or the screen record is complete.

entry

Any descriptive set of consecutive clauses terminated by a separator period (. ) (except for a comment entry) and written in the Identification Division, Environment Division or Data Division.

entry-name

A user-defined word that identifies an alternative point at which to start executing a program from the default point which is the first non-declarative procedural statement in the source program.

execution time

The time at which a function, method or program is executed.

explicit attribute

Any attribute which has been explicitly defined.

explicit interface member implementation

An explicit interface member implementation is a method that may not be invoked explicitly. The method may be invoked implicitly when the corresponding method is invoked on an instance of this class which has been cast to the interface type.

explicit scope terminator

A reserved word that terminates the scope of a particular Procedure Division statement.

exponent

In floating-point representation, that power to which the radix of the representation is to be raised.

expression

An arithmetic or conditional expression.

extend mode

The state of a file connector after execution of an OPEN statement, with the EXTEND phrase specified, for that file connector and before the execution of a CLOSE statement without the REEL or UNIT phrase for that file connector.

external data

Data described as external data items and external file connectors.

external file connector

A file connector which is accessible to one or more runtime elements in the run unit.

external repository

See repository.

external switch

A hardware or software device, defined and named by the implementor, that is used to indicate that one of two alternate states exists.

F

factory definition

The source unit that defines a factory object.

factory method

A method for a factory object.

factory object

The single object of a class, defined by the factory definition of a class. There is one factory object for each class. The factory object is the creator of objects of the class.

factory (object) data

The data for a factory object, declared in the Data Division of a factory definition and common for all objects of the class.

field (of a screen)

A contiguous area of a terminal screen that represents an elementary screen item.

figurative constant

A value generated by your COBOL system which is referenced through the use of certain reserved words.

file

A physical collection of logical records.

file connector

A storage area which contains information about a file and is used as the linkage between a file-name and a physical file and between a file-name and its associated record area.

file control entry

A SELECT clause and subordinate clauses that declare the relevant physical attributes of a file.

file description entry

An entry in the File Section of the Data Division that is composed of the level indicator FD, followed by a file-name, and then followed by a set of file clauses as required.

file-name

A user-defined word that names a file connector described in a file description entry or a sort-merge file description entry within the File Section of the Data Division.

file organization

The permanent logical file structure established at the time that a file is created.

file position indicator

A conceptual entity that contains the value of the current key within the key of reference for an indexed file, or the record number of the current record for a sequential file, or the relative record number of the current record for a relative file, or indicates that no next logical record exists, or that the number of significant digits in the relative record number is larger than the size of the relative key data item, or that an optional input file is not present, or that the at end condition already exists, or that no valid next record has been established.

File Section

The section of the Data Division that contains file description entries and sort-merge file description entries together with their associated record descriptions.

file status

A conceptual entity that contains a two-character value indicting the status of an input-output operation.

file sharing

A cooperative environment that controls concurrent access to the same physical file.

fixed file attributes

Information about a file which is established when a file is created and cannot subsequently be changed during the existence of the file. These attributes include the organization of the file (sequential, relative, or indexed), the prime record key, the alternate record keys, the code set, the minimum and maximum record size, the record type (fixed or variable), the collating sequence of the keys for indexed files, the maximum and minimum physical record size, the padding character, and the record delimiter.

fixed format mode

The default manner in which data entry is made to numeric and numeric-edited screen fields. This mode formats and echoes the entered data and also moves the cursor in accordance with the requirements of the field's picture specification, as each keystroke is received. Characters other than " +", "-", and the decimal point character, are rejected; insertion characters in edited fields are skipped over as the cursor moves backwards and forwards; any sign indicator is modified in accordance with its normal specification; floating symbols move left and right in the field, and insertion symbols appear and disappear as digits are inserted or deleted.

fixed format source

A source format in which each COBOL source line consists of 80 characters which are divided into various fixed areas. There are restrictions on the syntax that can appear in each area. The alternative is free format source.

fixed-length record

A record associated with a file whose file description or sort-merge description entry requires that all records contain the same number of character positions.

fixed-point numeric item

A numeric data item using fixed-point representation.

fixed-point numeric literal

A quantity, in fixed-point representation, that has a radix of ten and is expressed as a literal composed of one or more numeric characters and optionally either a decimal point or an algebraic sign, or both.

fixed-point representation

A positional representation in which each number is represented by a single sequence of digits, the position of the radix point being fixed with respect to the rightmost end of the set according to the position of the implicit or explicit radix point.

floating-point literal

A quantity, in floating-point representation, that has a base of ten and is written as a signed fixed-point numeric literal that must have a decimal point in any character position (the significand), immediately followed by the letter "E", which is, in turn, immediately followed by a signed fixed-point numeric literal that does not contain a decimal point (the exponent).

floating-point representation

A number representation in which a number is represented by two sequences of digits, the significand and the exponent.

footing area

The position of the page body adjacent to the bottom margin of the printed page.

format

A specific arrangement of a set of data.

format parameter

A data-name specified in the USING phrase of the PROCEDURE DIVISION header or ENTRY statement that gives the name used in the function, method or program for a parameter.

free format mode

An alternative manner in which data entry can be made to numeric and numeric-edited screen fields. The default mode is fixed format mode. This configurable mode allows data to be keyed into a PIC X field of appropriate length, and it is only when the operator leaves the field that the data is reformatted to comply with the picture specification. Once the operator moves the cursor from the field, your COBOL system disregards all characters other than digits and the sign and decimal point symbols. It then extracts, stores, or reformats the numeric value in accordance with the normal COBOL rules for a MOVE to an item with the same picture as the screen or working-storage item. The numeric value is then usually echoed to the screen.

free format source

A source format in which each COBOL source line can consist of up to 250 bytes of characters. There is no restriction on where syntax may appear on the line. The alternative is fixed format source.

function

A temporary data item whose value is determined at the time an intrinsic or a user-defined function is referenced during the execution of a statement.

function-identifier

An identifier that references an intrinsic-function-name, a user-defined-name, or a function-prototype-name. The data item represented by a function is uniquely identified by a function-name with its arguments, if any. A function-identifier can include a reference-modifier. A function-identifier that references an alphanumeric function can be specified anywhere in the general formats that an identifier can be specified, subject to certain restrictions. A function-identifier that references an integer or numeric function can be referenced anywhere in the general formats that an arithmetic expression can be specified.

function key

A key on the keyboard of a character addressable terminal that, when enabled and pressed, signals that input of the screen record is complete and a function is requested.

function-name

A word that names a mechanism provided by the implementor to determine the value of a function.

function prototype definition

A definition that specifies the rules governing the arguments needed for the evaluation of a particular function, the data item resulting from the evaluation of the function, and all other requirements needed for the evaluation of that function.

G

global name

A name declared in only one program that may be referenced from that program and from any program contained within that program.

group item

A named contiguous set of elementary items.

H

high order end

The leftmost character of a string of characters.

I

I-O-Control

The name of an Environment Division paragraph in which requirements for specific input/output techniques, rerun points, sharing of same areas by several data files, and multiple file storage on a single input/output device are specified.

I-O mode

The state of a file connector after execution of an OPEN statement with the I-O phrase specified, for that file connector and before the execution of a CLOSE statement without the REEL or UNIT phrase for that file connector.

identifier

A sequence of character-strings and separators that uniquely references a unit of data.

imperative statement

A statement that specifies an unconditional action to be taken or a conditional statement that is delimited by its explicit scope terminator (delimited scope statement). An imperative statement can consist of a sequence of imperative statements.

implicit attribute

Any attribute which has not been explicitly specified.

implicit scope terminator

A separator period that terminates the scope of any preceding unterminated statement, or a phrase of a statement which by its occurrence indicates the end of the scope of any statement contained within the preceding phrase.

implicit segment

A segment created by your COBOL system to control the size of code segments.

index

A computer storage area or register, the contents of which represent the identification of a particular element in a table.

index data item

A data item in which the value associated with an index-name can be stored.

index-name

A user-defined word that names an index associated with a specific table.

indexed data-name

An identifier that is composed of a data-name, followed by one or more index-names enclosed in parentheses.

indexed file

A file with indexed organization.

indexed organization

The permanent logical file structure in which each record is identified by the value of one or more keys within that record.

indicator area

The leftmost position of a COBOL source record that indicates the use of the record.

inheritance (for classes)

A mechanism for using the interface and implementation of one or more classes as the basis for another class. A subclass inherits from one or more superclasses. The interface of an inheriting class conforms to the interface of the inherited classes.

inheritance (for interfaces)

A mechanism for using the specification of one or more interfaces as the basis for another interface. An inheriting interface conforms to the inherited interface.

initial data

The data described in the Working-Storage or File Section of an initial program.

initial data item

A data item that is described as part of an initial data record.

initial data record

A logical record that is described in the Working-Storage or File Section of an initial program and is initialized on every call to the program.

initial file connector

A file connector that is described in an initial program and is not in an open mode on any call to the program.

initial program

A program that is placed into an initial state every time the program is called in a run unit.

initial state

The state of a function, method or program when it is first activated in a run unit.

in-line comment

A comment preceded on a source line by one or more COBOL words or character-strings.

input field

A screen item whose description contains a TO phrase.

input file

A file that is opened in the input mode.

input mode

The state of a file connector after execution of an OPEN statement with the INPUT phrase specified, for that file connector and before the execution of a CLOSE statement without the REEL or UNIT phrase for that file connector.

input-output control system (IOCS)

A system provided by the implementor that directs, or controls, the processing of files.

input-output file

A file that is opened in the I-O mode.

Input-Output Section

The section of the Environment Division that names the files and the external media used and which provides information required for transmission and handling of data during execution .

input-output statement

A statement that causes files to be processed by performing operations upon individual records or upon the file as a unit. The input-output statements are: CLOSE, DELETE, OPEN, READ, REWRITE, START and WRITE.

input procedure

A set of statements to which control is given during the execution of a SORT statement, for the purpose of controlling the release of specified records to be sorted..

instance method

A method of an instance object (as opposed to a class method).

instance-of condition

The proposition, for which a truth value can be determined, that an object reference is an instance of a particular class or interface.

integer

A numeric literal or a numeric data item that does not include any digit positions to the right of the decimal point.

integer function

A function whose category is numeric and whose definition provides that all digits to the right of the decimal point are zero in the returned value for any possible evaluation of the function.

interface (for a method)

The information needed to invoke a method correctly.

interface (the language construct)

A grouping of method prototypes.

interface definition

The source unit that defines an interface.

internal data

The data described in a source unit excluding all external data items and external file connectors. Items described in the Linkage Section are treated as internal data.

internal file connector

A file connector which is accessible to only one runtime module in a run unit.

intrinsic-function-name

A word that names a mechanism provided by the implementor to determine the value of a function.

invalid key condition

A condition occurring at execution time when a specific value of the key associated with an indexed or relative file is determined to be invalid.

invocation

See method invocation.

IOCS

See input-output control system.

K

key

A data item which identifies the location of a record, or a set of data items which serve to identify the ordering of data.

key of reference

The key, either prime or alternate, currently being used by a file connector to access records within an indexed file.

key word

A reserved word or intrinsic-function-name whose presence is required when the general format in which the word appears is used.

L

language-name

A system-name that specifies a particular programming language.

level indicator

Two alphabetic characters that identify a specific type of file. The level indicators in the Data Division are: FD, RD and SD.

level-number

A user-defined word which indicates the position of a data item in the hierarchical structure of a logical record or which indicates special properties of a data description entry. A level-number is expressed as a one- or two-digit number.

Level-numbers in the range 1 through 49 indicate the position of a data item in the hierarchical structure of a logical record. Level-numbers in the range 1 through 9 can be written either as a single digit or as a zero followed by a significant digit.

Level-numbers 66, 77, 78 and 88 identify special properties of a data description entry.

library-name

A user-defined word that names a COBOL library source file that is to be used by your COBOL system during creation of the object code.

library-text

Text that resides in a COBOL library for the purpose of being introduced into the source text at compile time by a COPY statement.

line sequential file organization

A type of sequential file containing variable length records in the format of text files produced by the host operating system.

Linkage Section

The section in the Data Division of the activated element that describes data items available from the activating element. These data items can be referenced by both the activating and the activated elements.

literal

A character-string whose value is derived from the ordered set of characters in the string.

literal field

An elementary screen item whose description contains no PICTURE clause.

lock mode

The state of an open file connector when record locking is in effect that indicates whether record locking is manual or automatic.

logical operator

One of the reserved words AND, OR and NOT. In the formation of a condition, both or either of AND and OR can be used as logical connections. NOT can be used for logical negation.

logical page

A conceptual entity consisting of the top margin, the page body and the bottom margin.

logical record

The most inclusive data item. The level-number for a record is 01.

low order end

The rightmost character of a string of characters.

M

mass storage

A storage medium in which data may be organized and maintained in both a sequential and nonsequential manner.

mass storage file

A collection of records that is assigned to mass storage.

merge file

A collection of records to be merged by a MERGE statement. The merge file is created and can be used only by the merge function.

method

Procedural code that is declared in the Procedure Division of a method definition and is executed by a method invocation on that object.

method definition

The source unit that defines a method.

method invocation

The request to execute a named method on a given object. A method invocation identifies an object, a method name, and the parameters required by the method definition.

method-name

A user-defined word that identifiers a method.

method prototype

The method-name and parameter types (including a returning item if specified) for a method. It is specified by a method definition in an interface.

mixed literal

A nonnumeric literal that includes DBCS characters.

mnemonic-name

A user-defined word that is associated in the Environment Division with a specified implementor-name.

N

native character set

The implementor-defined character set associated with the computer specified in the Object-Computer paragraph.

native collating sequence

The default collating sequence associated with the computer specified in the Object-Computer paragraph.

negated combined condition

The "NOT" logical operator immediately followed by a parenthesized combined condition.

negated simple condition

The "NOT" logical operator immediately followed by a simple condition.

next executable sentence

The next sentence to which control will be transferred after execution of the current statement is complete.

next executable statement

The next statement to which control will be transferred after execution of the current statement is complete.

next record

The record which logically follows the current record of a file.

noncontiguous items

Elementary data items, in the Working-Storage, Local-Storage and Linkage Sections, which bear no hierarchic relationship to other data items.

nonnumeric item (alphanumeric item)

A data item whose description permits its contents to be composed of any combination of characters taken from the computer's character set. Certain categories of nonnumeric items can be formed from more restricted character sets.

nonnumeric literal (alphanumeric literal)

A character-string bounded by quotation marks. The string of characters can include any character in the computer's character set. To represent a single quotation mark character within a nonnumeric literal, two contiguous quotation marks must be used.

null
  1. The state of a pointer that guarantees no storage is addressed by that data item - indicated by the predefined null data address value.
  2. The state of a procedure-pointer that guarantees no program is addressed by that data item - indicated by the predefined null program address value.
  3. The state of an object reference that guarantees no object is referenced by that data item - indicated by the value of the predefined object reference NULL.
numeric character

A character that belongs to the following set of digits: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9.

numeric function

A function whose class and category are numeric but which for some possible evaluation does not satisfy the requirements of an integer function.

numeric item

A data item whose description restricts its contents to a value represented by characters chosen from the digits 0 through 9; if signed, the item can also contain a "+", "-" , or other representation of an operational sign.

numeric literal

See fixed-point numeric literal and floating-point numeric literal.

O

object (instance)

A unit consisting of data and the methods that can act upon that data.

object data

Data described in the Data Division of an object definition, excluding data described in its methods.

object definition

The source unit that defines an object.

object method

A method of an object (as opposed to a factory method, which is a method of factory object).

object property

A name that may be used to qualify an object reference to get a value from or pass a value to an object.

object reference

An explicitly or implicitly defined data item that contains a reference to an object.

object view

Syntax that causes an object reference to be treated at complie time as though it had the specified description. At run time a conformance check for this description is performed on the object.

obsolete element

A language element in Standard COBOL that is to be deleted from the next edition of Standard COBOL.

open mode

The state of a file after execution of an OPEN statement for that file and before the execution of a CLOSE statement without the REEL or UNIT phrase for that file. The particular open mode is specified in the OPEN statement as either INPUT, OUTPUT, I-O or EXTEND.

operand

Any lower-case word (or words) that appears in a statement or entry format can be considered to be an operand and, as such, is an implied reference to the data indicated by the operand.

operational sign

An algebraic sign, associated with a numeric data item or a numeric literal, that indicates whether its value is positive or negative.

optional file

A file declared as being not necessarily present each time the runtime module is executed.

optional word

A reserved word that is included in a specific format only to improve the readability of the language.

output field

A screen item whose description contains a FROM phrase.

output file

A file that is opened in either the output mode or extend mode.

output mode

The state of a file connector after execution of an OPEN statement with the OUTPUT phrase specified, for that file connector and before the execution of a CLOSE statement without the REEL or UNIT phrase for that file connector.

output procedure

A set of statements to which control is given during execution of a SORT statement after the sort function is completed, or during execution of a MERGE statement after the merge function reaches a point at which it can select the next record in merged order when requested.

P

paragraph

In the Identification and Environment Divisions, a paragraph header followed by zero, one, or more entries. In the Procedure Division, a paragraph-name followed by a period and a space and optionally by one or more sentences.

paragraph header

A reserved word, followed by a period and a space that indicates the beginning of a paragraph in the Identification and Environment Divisions.

paragraph-name

A user-defined word that identifies and begins a paragraph in the Procedure Division.

parameterized class

A class where the full details of one or more dependent classes or interfaces are not specified in the class definition. The full details of these dependent classes or interfaces are specified by parameters before the parameterized class is used.

parameterized interface

An interface where the full details of one or more dependent classes or interfaces are not specified in the interface definition. The full details of these dependent classes or interfaces are specified by parameters before the parameterized interface is used.

phrase

An ordered set of COBOL character-strings that specifies an attribute of an entry or a statement and is a subset of a clause or paragraph in all divisions except the Procedure Division, and a subset of a statement in the Procedure Division.

physical page

A device-dependent concept defined by the implementor.

physical record

See block.

pointer data item

A data item in which the address of a data item may be stored.

predefined object reference

An implicitly generated data item referenced by one of the identifiers NULL, SELF, SELFCLASS or SUPER.

prime record key

A key whose contents uniquely identify a record within an indexed file.

procedure

A paragraph or group of logically successive paragraphs, or a section or group of logically successive sections, within the Procedure Division.

procedure branching statement

A statement that causes the explicit transfer of control to a statement other than the next executable statement in the sequence in which the statements are written. The procedure branching statements are: CALL, EXIT, EXIT METHOD, EXIT PROGRAM, GO TO, GOBACK, INVOKE, MERGE (with the OUTPUT PROCEDURE phrase), PERFORM, and SORT (with the INPUT PROCEDURE or OUTPUT PROCEDURE phrase).

procedure-name

A user-defined word that names a paragraph or section in the Procedure Division.

procedure-pointer data item

A data item in which the address of a program may be stored.

program declaration

A source program that merely declares how the program is to be called, a call prototype. Unlike a program definition, it does not include any executable procedures. See call prototype.

program definition

A source program that defines how a program is to execute by procedures specified in a Procedure Division. A traditional COBOL program, as distinct from a program declaration.

program-name

A user-defined word that identifies a COBOL source program.

program prototype definition

A definition that specifies the rules governing the class of the parameters expected to be received by a particular subprogram, and any other requirements needed to transfer control to and get control and return information from that subprogram.

prompt character

The character used to mark empty character positions in a screen item.

property

See object property.

pseudo-text

A sequence of text-words, comment lines, or the separator space in a source text or a COBOL library bounded by, but not including, pseudo-text delimiters.

pseudo-text delimiter

Two contiguous equal sign (=) characters used to delimit pseudo-text.

punctuation character

A character that belongs to the following set:

Character Meaning
, Comma
; Semicolon
. Period
" Quotation mark
( Left parenthesis
) Right parenthesis
Space
= Equal sign in pseudo-text delimiters
' Apostrophe
: Colon
& Ampersand

Q

qualified data-name

An identifier that is composed of a data-name followed by one or more sets of either of the connectives OF and IN, followed by a data-name qualifier.

qualifier
  1. A data-name or name associated with a level indicator that is used in a reference either together with a data-name of an item that is subordinate to the qualifier or together with a condition-name.
  2. A section-name which is used in a reference together with a paragraph-name specified in that section.
  3. A library-name which is used in a reference together with a text-name associated with that library.

R

radix

In positional representation of numeric values, that positive integer by which the significance of a digit place must be multiplied to give the significance of the next higher digit position.

random access

An access mode in which the programmer-specified value of a key data item identifies the logical record that is obtained from, deleted from or placed into a relative or indexed file.

receiving item

A data item referenced in a TO or USING phrase in a PICTURE clause in the Screen Section.

record

See logical record.

record area

A storage area allocated for the purpose of processing the record described in a record description entry in the File Section.

record description entry

The total set of data description entries associated with a particular record.

record key

A key, either the prime record key or an alternate record key, whose contents identify a record within an indexed file.

record lock

An indicator that is associated with a specific record in a file and is set and released by the locking facility. It is used to determine whether multiple file connectors may access the record concurrently.

record locking

The controlling of record access for shared files in which a record lock prevents access to the associated record from other file connectors.

record-name

A user-defined word that names a record described in a record description entry in the Data Division.

record number

The ordinal number of a record in a file whose organization is sequential.

reel (unit, volume)

A discrete portion of a storage medium that contains part of a file, all of a file, or any number of files.

reference-format

A format that provides a standard method for describing source text and library text.

reference modification

A definition of a data item by specifying a leftmost character and length for the data item.

reference-modifier

An identifier that references a unique data item created by specifying an identifier, a starting position and a length.

relation

See relational operator.

relation character

A character that belongs to the following set:

Character Meaning
> Greater than
< Less than
= Equal to
>= Greater than or equal to
<= Less than or equal to
< > Unequal to
relation condition

A proposition, for which a truth value can be determined, that the value of an arithmetic expression, data item, literal or index has a specific relationship to the value of another arithmetic expression, data item, literal or index.

relational operator

A reserved word, a relation character, a group of consecutive reserved words, or a group of consecutive reserved words and relation characters used in the construction of a relation condition. The permissible operators and their meanings are:

Relational Operator | Meaning
IS [NOT] GREATER THAN IS [NOT] > | Greater than or not greater than
IS [NOT] LESS THAN IS [NOT] < | Less than or not less than
IS [NOT] EQUAL TO IS [NOT] = | Equal to or not equal to
IS GREATER THAN OR EQUAL TO IS >= | Greater than or equal to
IS LESS THAN OR EQUAL TO IS <= | Less than or equal to
IS UNEQUAL TO IS < > | Not equal to
EQUALS | Equal to
EXCEEDS | Greater than
relative file

A file with relative organization.

relative key

A key whose contents identify a logical record in a relative file.

relative organization

The permanent logical file structure in which each record is uniquely identified by an integer value greater than zero, which specifies the record's logical ordinal position in the file.

relative record number

The ordinal number of a record in a file whose organization is relative.

repository

Implementor-provided storage for information relating to class names, method names, method parameters, and any other information that the implementor requires.

Repository paragraph

A paragraph in the Configuration Section of the Environment Divisison that allows specification of program prototype names, function prototype names, property-names, class names, and interface names that may be used within the scope of that Environment Division. It also allows declaration of intrinsic-function-names that may be used without specifying the word FUNCTION.

reserved word

A COBOL word specified in the list of words which can be used in COBOL, but which must not appear as a user-defined word or a system-name.

resultant identifier

A user-defined data item that is to contain the result of an arithmetic operation.

root class

A class with no superclass.

routine-name

A user-defined word that identifies a procedure written in a language other than COBOL.

run time

The time at which the code produced by your COBOL system is executed.

runtime system (RTS)

The software that interprets the code produced by your COBOL system and enables it to be executed by providing interfaces to the operating system.

run unit

One or more runtime modules that interact with one another and that function, at execution time, as an entity to provide problem solutions.

runtime element

The executable unit resulting from compiling a source element, which may be a function, method or a program.

runtime module

The result of compiling a compilation unit.

S

screen description entry

An entry in the Screen Section of the Data Division that is composed of a level number, followed by an optional screen-name, and then by a set of screen clauses as required. This entry is very similar in structure to a data description entry, but while a data description entry declares areas in memory, a screen description entry declares areas on the screen.

screen item

A field on the screen to which the screen description entry assigns properties.

screen-name

A user-defined word that names a screen item described in a screen description entry.

screen record

A screen description entry with a level-number of 1.

Screen Section

A section in the Data Division in which the layouts of the screen areas accessed in Format 4 of the ACCEPT and Format 2 of the DISPLAY statements are defined.

section

A set of zero, one, or more paragraphs or entries, called a section body, the first of which is preceded by a section header. Each section consists of the section header and the related section body.

section header

A combination of words followed by a period and a space that indicates the beginning of a section in the Environment, Data and Procedure Divisions.

section-name

A user-defined word which names a section in the Procedure Division.

segment-number

A user-defined word which classifies sections in the Procedure Division for purposes of segmentation. Segment-numbers can contain only the characters "0" through "9". A segment-number can be expressed either as a one- or two-digit number.

sending item

A data item referenced in a FROM or USING phrase in a PICTURE clause in the Screen Section.

sentence

A sequence of one or more statements, the last of which is terminated by a period followed by a space.

separate program

A program, together with its contained programs, that is not contained in another program.

separator

A character or two contiguous characters used to delimit character-strings.

sequential access

An access mode in which logical records are obtained from or placed into a file in a consecutive predecessor-to-successor logical record sequence determined by the order of records in the file.

sequential file

A file with sequential organization.

sequential organization

The permanent logical file structure in which a record is identified by a predecessor-successor relationship established when the record is placed into the file.

shared file

A file for which file sharing has been specified.

sharing mode

The state of an open file connector that indicates the mode of file sharing. The sharing modes are: sharing with all other, sharing with no other, and sharing with read only.

sign condition

The proposition, for which a truth value can be determined, that the algebraic value of a data item or an arithmetic expression is less than, greater than, or equal to zero.

signature

The information stored about a source unit in the external repository.

significand

In floating-point representation, the fixed-point numeral that represents the significant digits of the number.

simple condition

Any of the following:

relation condition class condition switch-status condition condition-name condition sign condition (simple-condition)

sort file

A collection of records to be sorted by a SORT statement. The sort file is created and can be used by the sort function only.

sort-merge file description entry

A Data Division entry that specifies the characteristics of a sort or merge file.

source element

A source unit excluding any nested source units.

source text manipulation statement

A statement beginning with the word COPY or the word REPLACE that provides the capability to insert and replace source text during compilation.

source unit

A sequence of statements beginning with an Identification Division and finishing with an end marker or the end of the compilation group, including any contained source units.

special character

A character that belongs to the following set:

Character Meaning
+ Plus sign
- Minus sign
* Asterisk
/ Slash (virgule, stroke)
= Equal sign
$ Currency sign
, Comma (decimal point)
; Semicolon
. Period (decimal point)
' Quotation mark
( Left parenthesis
) Right parenthesis
> Greater than symbol
< Less than symbol
' Apostrophe
: Colon
& Ampersand
special-character word

A reserved word that is composed entirely of special characters.

Special-Names

The name of an Environment Division paragraph in which implementor-names are related to user-specified mnemonic-names.

special registers

Storage areas created by your COBOL system whose primary use is to store information produced in conjunction with the use of specific COBOL features.

split key

A concatenation of one or more data items within a record associated with that file-name. It can be referenced only in START and READ statements. See the chapter Examples for an example of Split Key.

standard data format

A concept used to describe data in a COBOL Data Division whereby the characteristics or properties of the data are expressed in terms of the appearance of graphic characters on a printed page, rather than the manner in which the data is stored internally in the computer or on a particular external medium.

statement

A syntactically valid combination of words and symbols written in the Procedure Division beginning with a verb.

static data

The data described in the File or Working-Storage Section of a source element that is not an initial program.

static data item

A data item that is described as part of a static data record.

static data record

A logical record described in the File or Working-Storage Section of a source element that is not an initial program.

subclass

A class that inherits from another class. When two classes in an inheritance relationship are considered together, the subclass is the inheritor or inheriting class; the superclass is the inheritee or inherited class.

In the industry literature, the term derived class is also often used as an alternative to the term subclass. These terms are equivalent

subject of entry

The data item that is being defined by a data description entry.

subprogram

See called program.

subscript

An occurrence number represented by either an integer, a data-name optionally followed by an integer with the operator + or -, or an index-name optionally followed by an integer with the operator + or -, that identifies a particular element in a table. A subscript can be the word ALL when the subscripted identifier is used as a function argument.

subscripted data-name

An identifier that is composed of a data-name followed by one or more subscripts enclosed in parentheses.

superclass

A class that is inherited by another class. See also subclass.

switch-status condition

The proposition, for which a truth value can be determined, that an implementor-defined switch, capable of being set to an "on" or "off" status, has been set to a specified status.

symbolic-character

A user-defined word that specifies a user-defined figurative constant.

syntax

The order in which elements must be put together to form a compilation group.

system-directing statement

A statement, beginning with a directing verb, that causes your COBOL system to take a specific action during creation of the intermediate code.

system-name

A COBOL word which is used to communicate with the operating environment.

T

table

A set of logically consecutive items of data that are defined in the Data Division by means of the OCCURS clause.

table element

A data item that belongs to the set of items in a table.

terminal

A character-addressable device that includes a display and a keyboard.

termination key

Any function key or the enter key of a terminal.

text-name

A user-defined word which identifies library text.

text-word

A character or a sequence of contiguous characters between margin A and margin R in a COBOL library, source text, or in pseudo-text which is:

  1. A separator, except for: space; a pseudo text delimiter; and the opening and closing delimiters for nonnumeric literals. The right-parenthesis and left-parenthesis characters, regardless of context within the library, source text, or pseudo-text, are always considered text-words.
  2. A literal including, in the case of nonnumeric literals, the opening quotation mark and the closing quotation mark which bound the literal.
  3. Any other sequence of contiguous COBOL characters except comment lines and the word "COPY", bounded by separators, which is neither a separator nor a literal. One or both of the bounding separators can be a pseudo-text delimiter.
truth value

The representation of the result of the evaluation of a condition in terms of one of two values:

true false

typedef-name

A user-defined word which identifies a type definition.

type definition

A programmer-defined type or USAGE that may be used to define data items of that type. A type definition is defined in a data description entry that includes the TYPEDEF clause. The type contains all the characteristics of a data item and its subordinates.

U

unit

See reel.

universal object reference

An object reference that is not restricted to a specific class or interface.

unsuccessful execution

The attempted execution of a statement that does not result in the execution of all the operations specified by that statement.

update field

A screen item whose description contains a USING phrase.

user-defined word

A COBOL word supplied by the user to satisfy the format of a clause or statement.

V

variable

A data item whose value can be changed at run time.

variable-length record

A record associated with a file whose file description or sort-merge description entry permits records to contain a varying number of character positions.

variable-occurrence data item

A table element that is repeated a variable number of times. Such an item contains an OCCURS clause with the DEPENDING phrase in its data description entry or is subordinate to such an item.

verb

A word that expresses an action to be taken during creation of native code or at run time.

volume

See reel..

W

word

A character-string of not more than 30 characters which forms a user-defined word, a system-name, a reserved word, or an intrinsic-function-name.

Working-Storage Section

The section of the Data Division that describes working storage data items, composed either of noncontiguous items or of working storage records, or of both.

Z

zero-length group item

An item whose minimum length is zero and whose length at execution time is zero. A zero-length group item can result from one of the following:

  • A group data item containing only a variable-occurrence data item in which the minimum number of occurrences is zero.
  • A group data item containing only a subordinate zero-length group item.
  • A record that has been specified using format 2 or format 3 of the RECORD clause in which the minimum number of character positions is zero.
  • A function that returns a zero-length item.
Parent topic: Part 4: Appendices


Command Line Reference

A range of command line utilities and interfaces are available for creating, building, debugging and running COBOL applications.

  • Example - Setting COBCPY
  • Effect of COBCPY
  • Setting Directives Outside the IDE
  • Compiling from the Command Line
  • Linking from the Command Line
  • Service Interfaces
  • Running an Application from the Command Line
  • Configuring Enhanced ACCEPT and DISPLAY
  • Test Coverage
Parent topic: General Reference


Example - Setting COBCPY

If you specify the following in your autoexec.bat file:

set cobcpy=d:\myapp\copyfils;.;e:\common\copyfils

the Compiler searches for a copyfile first in the same directory as the source file, then in d:\myapp\copyfils, then in the current directory and finally in e:\common\copyfils.

If you would like to choose from different settings for COBCPY at the time you start Net Express, create a batch file for each variation, containing a line to set COBCPY, and a line to start Net Express:

set cobcpy=d:\myapp\copyfils;.;e:\common\copyfils
mfnetx

You can ensure that other environment variables are set correctly by running the batch files from the command prompt in the Net Express group on the Start menu.

Parent topic: Command Line Reference


Effect of COBCPY

The following table shows how setting the COBCPY environment variable effects the search order for files specified on COPY statements.

COPY Statement Contents of COBCPY Files Searched For (includes path)
copy f1
  • f1.cbl
  • f1.cpy
  • f1
copy "f1.cop"
  • f1.cop
copy "f1.cop" dir1
  • f1.cop
  • dir1\f1.cop
copy "dir1\f1" didr2
  • dir1\f1.cbl
  • dir1\f1.cpy
  • dir1\f1
copy f1 of dir1
  • dir1\f1.cbl
  • dir1\f1.cpy
  • dir1\f1
copy f1 d:\ (selects root directory on d:)
  • f1.cbl
  • f1.cpy
  • f1
  • d:\f1.cbl
  • d:\f1.cpy
  • d:\f1
copy f1 d: (selects current directory on d:)
  • f1.cbl
  • f1.cpy
  • f1
  • d:f1.cbl
  • d:f1.cpy
  • d:f1
copy f1 dir1\
  • f1.cbl
  • f1.cpy
  • f1
  • dir1\f1.cbl
  • dir1\f1.cpy
  • dir1\f1
copy f1 in dir1 \dir2
  • dir1\f1.cbl
  • dir1\f1.cpy
  • dir1\f1
  • \dir2\f1.cbl
  • \dir2\f1.cpy
  • \dir2\f1
Parent topic: Command Line Reference


Setting Directives Outside the IDE

You use directives to control the way the Compiler behaves: what output it produces, what code is compiled and how the compiled code behaves when it runs.

You can specify Compiler directives within the IDE. However, you can specify them in a number of other ways too, such as on the command line, or in a directives file.

  • Order in which Compiler Directives Are Processed
    Choose the appropriate way to set the Compiler directives to ensure that they are processed in the order you require.
  • System-wide Directives File, cobol.dir
    Use this file if you want to permanently override the default value of a directive.
  • $SET Statements in the Source Code
    Use $SET statements if your program is affected by particular circumstances that none of the other programs in an application needs.
  • User Directives File
    Use this file when you have a set of directives that you always want to use together.
Parent topic: Command Line Reference


Order in which Compiler Directives Are Processed

Choose the appropriate way to set the Compiler directives to ensure that they are processed in the order you require.

The Compiler processes directives specified on the command line from left to right. If a directive appears more than once, the Compiler uses the setting that it processed last for that directive.

The Compiler processes the directives according to the way you set them. It processes them in the following order:

  1. Project or file properties, set from within the IDE
  2. System-wide directives file cobol.dir
  3. $SET statements in the source code

In addition, you can set directives in a user directives file, which you specify with the USE directive. These directives are then processed when they are encountered.

For example, the above order means that a directive set in a $SET statement would override the setting for that directive in the IDE.

Parent topic: Setting Directives Outside the IDE


System-wide Directives File, cobol.dir

Use this file if you want to permanently override the default value of a directive.

To override one or more directives, create a flat system-wide directives file named cobol.dir, and list the directives in the file. Place cobol.dir in the directory specified by the COBDIR environment variable.

The Compiler automatically process the directives in the system-wide directives file. It looks for a cobol.dir file first in the current directory, and then in the %COBDIR%\etc directory.

Compilation terminates if the Compiler rejects a directive, if that directive is on the command line or in a directives file specified on the command line. Therefore, whenever you create or change a cobol.dir file, run a trial compilation and watch for "Rejected" messages at the beginning when the directives are processed.

Parent topic: Setting Directives Outside the IDE


$SET Statements in the Source Code

Use $SET statements if your program is affected by particular circumstances that none of the other programs in an application needs.

Syntax

$SET directive["parameter"] ...

where the parameters are:

directive
A Compiler directive whose phase is identified as "syntax check". It cannot be a generate phase directive. Multiple directives must be separated by spaces.
parameter
A qualifier to directive. It must appear in one of the following forms:
  • "parameter" - can contain spaces
  • (parameter) - cannot contain spaces

parameter must not be preceded with an equals sign (=)

Rules:

  • The $ character must be in column 7.
  • $SET statements must not be terminated with a period (.).
  • $SET statements cannot be continued onto a new line, but it can be followed by additional $SET statements.
  • Some directives must be set at the start of the program; these are known as initial $SET statements. They can precede or follow other $SET statements, but must come before any other statements.
  • When a directive is specified on a statement after the initial $SET statements, the directive affects compilation from that point onwards.
  • Dialect-controlling directives must be on an initial $SET statement. Once you have set a dialect, you cannot unset it later in the program.

Example

If your program requires a specific currency symbol that none of your other programs need, start the program with the line:

$set currency-sign"157"
Parent topic: Setting Directives Outside the IDE


User Directives File

Use this file when you have a set of directives that you always want to use together.

The user directives file is an ASCII text file, which defines a set of directives to pass to the Compiler altogether at the same time. You use either the DIRECTIVES or USE directive to pass this user directives file to the Compiler.

For example, to migrate some programs from a different dialect, put the directives you need to get compatibility with this dialect into a directives file, which you could call myDialectDirectives.dir. To use this file when compiling, use the USE or DIRECTIVES directive either in the project's properties in the IDE or in a $SET statement in your program. For example

USE"myDialectDirectives.dir"

The Compiler processes the directives in the file as if they replace the USE or DIRECTIVES directive. Consequently, the restrictions applying to a directive at that time also apply to the directives read from the file at that time. Also any directives set later override the directives in your directives file

You can specify another directives file within the original directives file. The Compiler switches to the new directives file for processing and then returns to the original directives file. When the Compiler finishes processing the directives file, it then processes subsequent directives on the command line or in $SET statements.

Parent topic: Setting Directives Outside the IDE


Compiling from the Command Line

You control the way your program is compiled by specifying Compiler directives. For example, you use a Compiler directive to specify that you want the Compiler to produce a file in generated code format. You can also direct the Compiler to produce a source code listing file and an object code listing file.

You can compile (without linking) using the cobol command, and compile and link your program in one step using the cbllink utility.

You can also instruct the Compiler to automatically invoke the Linker to create an executable file.

You can either specify all the information required on the command line, or use the Compiler prompts.

  • The cobol Command
  • cobol Command Examples
  • Compiling Using Response Files Example
  • Compiler Prompts
  • Compiler Prompts Example
  • Filenames
  • Response Files
  • Error Codes Returned by the Compiler
Parent topic: Command Line Reference
Related information
cbllink


The cobol Command

You can use cobol.exe to compile COBOL source and generate managed code assemblies as well as native code objects.

Command Line Syntax:

To invoke the compiler prompts:

>>--cobol---><

To invoke the compiler from the command line:

>>--cobol--s-file-,-.--------.-,-.--------.-,-.--------.-.--------.-.---.-><
                    +-o-file-+   +-s-list+-   -+o-list-+ +--dirs-.+ +-;-+
                                                          ^      |
                                                          +------+

Where the parameters are:

s-file
The name of the file containing your source code. By default, the system looks for s-file.cbl. You can override this default by either typing an extension of your choice or using the OSEXT directive.
o-file
The name of the file to contain the compiled object code. By default, the file is named s-file.obj.

If a filename with an extension of .exe or .dll is specified, the Compiler automatically invokes the Linker, once compilation is complete, to create the specified executable using the default run-time libraries as specified by the LINKLIB directive.

s-list
The name of the file to contain the source code listing. If the command line is terminated by a semicolon before the comma preceding this field, this option is set to NUL (indicating that no list file is produced). If the preceding comma is specified, but no filename is entered, the default is s-file.lst.

If you specify s-list without an extension or trailing period, the system adds the extension .lst to create the filename s-list.lst.

l-list
The name of the file to contain the object code listing. If the command line is terminated by a semicolon before the comma preceding this field, this option is set to NUL (indicating that no list file is produced). If the preceding comma is specified, but no filename is entered, the default is s-file.grp.

If you specify o-list without an extension or trailing period, the system adds the file extension .grp to create the filename o-list.grp.

dirs
A sequence of one or more Compiler directives. Directives can appear after any filename. Each directive must be separated by a space and must not be broken across two lines.
In order to compile for managed code you must include either the -ILGEN or -ILGEN(SUB) directives in this sequence.
;
Terminates the command line, causing the Compiler to use the default setting for any unspecified options. The semicolon can be entered any time after s-file.

When you invoke the Compiler without prompts:

  • You specify the parameters you require and terminate the line with a semicolon
  • The Compiler uses the default settings for any unspecified options
  • If you omit the semicolon, the Compiler prompts you for any options that you did not specify
  • Filenames specified in the command can be either a disk file or a system device
Parent topic: Compiling from the Command Line
Related concepts
Compiler Directives
Compiling COBOL code


cobol Command Examples

The following examples illustrate how you could compile a program, myprog, using a number of options from the command line.

To create myprog.obj but first receive prompts for the listing files, enter:

cobol myprog,,

To create myprog.obj but no listing files, terminate the command line with a semicolon instead of a comma:

cobol myprog;

To create myprog.obj and an object code listing in myprog.grp, enter:

cobol myprog,,nul,,

To create the object file myprog.obj in the myobjdir directory, enter:

cobol myprog,\myobjdir\;
Parent topic: Compiling from the Command Line


Compiling Using Response Files Example

The following example illustrates how you could compile a program, Myprog, using response files. The example assumes that Enter is pressed at the end of each line.

The file myprog.rsp contains the lines:

myprog.obj
temp.lst, temp.grp
warning"3" ans85 errlist

If you compile myprog.cbl using this response file:

cobol myprog, @myprog.rsp;

the program is compiled with the directives:

warning"3" ans85 errlist

producing myprog.obj, source listing in temp.lst, and an object listing in temp.grp.

Parent topic: Compiling from the Command Line


Compiler Prompts

You display the Compiler prompts by typing:

cobol

Do not enter any parameters. The system prompts you for each option as follows:

Native code only:

Source filename [.CBL] :
Object filename [source-filename.OBJ] :
Source listing [NUL] :
Object listing [NUL]:

Managed code only:

Source filename [.CBL] :

After you enter the source filename, you can accept the defaults for subsequent options by pressing Enter after each prompt or by entering a semicolon at any prompt.

You can override the defaults by entering a filename of your choice after the appropriate prompt. You do not need to enter an extension and trailing period with your filename; the Compiler assigns a default extension according to the type of file being produced. However, if you do not want to use the default extension, you can enter one of your own.

If you do not want to create a particular type of file, you enter NUL in response to the prompt.

After you type any of the responses, before you press Enter, you can continue the response without waiting for the next prompt by typing a comma and the answer to the next prompt.

You can enter a semicolon at any point after entering the source filename to terminate the command line and accept the default settings for any unspecified options. Processing then begins immediately.

You can terminate the compilation at any point by pressing Ctrl+Break.

Parent topic: Compiling from the Command Line


Compiler Prompts Example

The following example illustrates how you could compile a program, Myprog, using the prompts. The example assumes that Enter is pressed at the end of each line.

At the first prompt, enter the name of your source file, which causes the Compiler to read from myprog.cbl:

Source filename [.CBL] : myprog

At the next prompt, press Enter to create the file myprog.obj.

Object filename [MYPROG.OBJ]:

At the next prompt, enter the name of your source listing file, which creates a file listing your source file, myprog.lst.

Source listing [NUL]:  myprog

At the final prompt, enter specify the name of the listing file of the object code, myprog.grp.

Object listing [NUL]:  myprog
Parent topic: Compiling from the Command Line


Filenames

Each specified filename can identify either a disk file or a system device. File descriptions must have the following format:

>>----.---------.-.--------------------------------------.-----><
      +-device:-+ +--.-----------.---filename--.------.--+
                     +-pathname\-+             +-.ext-+

Each filename or directory name can consist of up to 254 characters and contain any number of periods (.).

This COBOL system regards any text following the final period as an extension (or a trailing period as a space extension) and removes it when creating its own names. Therefore, if you do use multiple periods for a source filename, you must specify an extension.

Parent topic: Compiling from the Command Line


Response Files

You can supply all or part of the command line as a response file, which is an ASCII text file containing options for the command. You give the name of the response file on the command line, preceded by an at character (@). This name is replaced in the command by the contents of the file. Within the response file, the end of a line is equivalent to a comma separating filenames or a space between directives beyond the last comma.

The maximum length of a line in a response file is 256 characters.

Response files must not refer to other response files.

Parent topic: Compiling from the Command Line


Error Codes Returned by the Compiler

The error messages issued by the Compiler are classed according to their severity as follows:

Severity | Return Value | Description
Unrecoverable | 16 | Indicates a fatal error
Severe | 12 | Indicates an error that the Compiler was unable to correct. Compilation continues, but the statement at fault is not compiled
Error | 8 | Indicates an error which the Compiler has attempted to correct
Warning | 4 | Flags a statement that although is syntactically correct may contain a possible error
Informational | See INFORETURN | Draws your attention to something in your source code of which you should be aware

The Compiler returns a value to the operating system to show the most severe type of message it issued.

If you invoked the Compiler from within a batch file, you can test this value using the Windows IF ERRORLEVEL n command. This executes a specified command if the return value is n or higher. For example, if your batch file contains:

cobol myprog;
if errorlevel 8 goto abortjob

then control jumps to ABORTJOB if the Compiler issues any message of severity Unrecoverable, Severe, or Error.

Parent topic: Compiling from the Command Line
Related reference
Key to Syntax Checking Error Messages
INFORETURN


Linking from the Command Line

You use cbllink to compile and link at the command line.

  • cbllink
  • cbllink Options
  • cbllink Examples
Parent topic: Command Line Reference


cbllink

Restriction: You can use cbllink to compile native COBOL code only.

The cbllink utility is a combined compiler and linker. To use this utility, the Cblnames utility, and the Linker and Library Manager utilities, must be located in the directories indicated by the PATH environment variable.

By default, any run-time support modules required by a COBOL program, for example Adis or Mffh, is automatically linked in to the executable module by this utility. You can instruct Cbllink to link the run-time support modules separately if required.

To invoke cbllink from the command line:

                                       +-sep-+
             +-----,-----+           +-.-----.--+
             v           |           V          |
>>-cbllink----.---------.----------------file----><
              +-option--+

The cbllink options affect the link process. Separate options with a comma or spaces.

Parent topic: Linking from the Command Line
Related reference
cbllink Options
cbllink Examples
Compiling from the Command Line


cbllink Options

The cbllink options affect the link process.

Separate options with a comma or spaces.

  • -b[options]
    Links your program with the static linked run-time system.
  • -d
    Creates a .dll file. A .def file is also created and used when creating the .dll file.
  • -f[option]
    Links your program with the shared run-time system using an import library.
  • -g
    Specifies that the application is graphical.
  • -isymbol
    Specifies that the function or entry-point symbol should be included in the executable file.
  • -k
    Prevents temporary files created by cbllink from being deleted.
  • -l
    Create a linker .map output file.
  • -mname
    Specifies the main program. name specifies which entry point should be treated as the main entry point. This option should not be used when creating dynamic link libraries.
  • -oname
    Specifies an output filename. name specifies the name of the executable module or dynamic link library to be created.
  • -roption[v]
    Links your program with the shared run-time system using dynamic binding.
  • -s
    Prevents system modules, such as Adis, Adisinit, Adiskey, Adisdyna, and Mffh from being linked into the executable.
  • -udir_file
    Specifies that the Compiler directives contained in the file dir_file be used during compilation.
  • -v
    Enables verbose details to be displayed.
  • -xsymbol
    Specifies that the function or entry-point symbol should be excluded from the executable file.
Parent topic: Linking from the Command Line
Related information
cbllink


-b[options]

Links your program with the static linked run-time system.

Standalone executables created with the static linked run-time system require the run-time system support modules to be available to the executable.

In a standalone executable, all of the support required by a program is copied into the program.

You can link with a version of the run-time system that suits your requirements for size and functionality. Lite is the smallest version of the run-time system, while Full is the largest.

options specifies the run-time system to use:

l | Lite
b | Base
f | Full
d | Include debugging functionality
s | Single-threaded
m | Multi-threaded

For details on these versions of the static linked run-time system, see the topic Run-time Systems and Choosing Which to Link.

For example, the option:

-bfm

specifies the full multi-threading run-time system, while:

-blds

specifies the lite, single-threaded run-time system with debugging functionality.

You can enter the options in any order. You should only enter one of the l,b or f options, and one of the s or m options. If you enter more than one, only the last will be actioned. For example, -bbfsm is equivalent to entering -bfm.

If -b is specified without options, the default is -bbs.

Parent topic: cbllink Options
Related information
-s


-d

Creates a .dll file. A .def file is also created and used when creating the .dll file.
Parent topic: cbllink Options


-f[option]

Links your program with the shared run-time system using an import library.

Where option can be:

s
Single-threaded shared run-time system. This is the default.
m
Multi-threaded shared run-time system.
Parent topic: cbllink Options


-g

Specifies that the application is graphical.
Parent topic: cbllink Options


-isymbol

Specifies that the function or entry-point symbol should be included in the executable file.
Parent topic: cbllink Options


-k

Prevents temporary files created by cbllink from being deleted.
Parent topic: cbllink Options


-l

Create a linker .map output file.
Parent topic: cbllink Options


-mname

Specifies the main program. name specifies which entry point should be treated as the main entry point. This option should not be used when creating dynamic link libraries.
Parent topic: cbllink Options


-oname

Specifies an output filename. name specifies the name of the executable module or dynamic link library to be created.

This overrides the default name of file1.exe or file1.dll.

Parent topic: cbllink Options


-roption[v]

Links your program with the shared run-time system using dynamic binding.

Where:

option

Indicates the run-time system to bind to and is one of:

  • E - to bind either a single or multi-threaded run-time system
  • S - to bind the single-threaded run-time system
  • M - to bind the multi-threaded run-time system
v

Limits dynamic binding to the current release of the run-time system. If you do not specify this parameter the executable can bind with current and future versions of your COBOL run-time system.

The actual run-time system chosen is determined by the version specified in the registry.

This form of linking should be used on any application that is deployed using Server Enterprise Edition.

Parent topic: cbllink Options


-s

Prevents system modules, such as Adis, Adisinit, Adiskey, Adisdyna, and Mffh from being linked into the executable.

Do not use the -s option with the -b option.

Parent topic: cbllink Options
Related reference
-b[options]


-udir_file

Specifies that the Compiler directives contained in the file dir_file be used during compilation.
Parent topic: cbllink Options


-v

Enables verbose details to be displayed.

The options passed to the Cblnames utility and to the Linker are displayed.

Parent topic: cbllink Options


-xsymbol

Specifies that the function or entry-point symbol should be excluded from the executable file.
Parent topic: cbllink Options


cbllink Examples

Use the cbllink command to link .obj files, or to compile and link source code files in one step.

To Produce a System Executable File

To compile and link the file myprog.cbl to produce an .exe file, myprog.exe, use the command:

cbllink myprog.cbl
To Produce a Dynamic Link Library File

To compile and link the file mydll.cbl to produce a .dll file, mydll.dll, use the command:

cbllink -d mydll.cbl
To Create a Standalone Executable File

The following command compiles and the files main.cbl, module1.cbl, module2.cbl and any run-time support modules that are needed to create the graphical main.exe:

cbllink -g -b main.cbl module1.cbl module2.cbl

The following command compiles and statically links the files main.cbl, module1.cbl, and any run-time support modules that are needed to create the character-based standalone executable myapp.exe:

cbllink -b -omyapp.exe main.cbl module1.cbl
To Create a Modular Application

The following commands:

  • Compile and statically link the files main.cbl and unique1.cbl, to create the root module of the graphical application main.exe.
  • Llink the run-time support module Mffh to create a dynamic link library, mffh.dll.
cbllink -g -s main.cbl unique1.cbl
cbllink -d mffh

The following commands:

  • Compile and statically link the files main.cbl and unique1.cbl, to create the root module of the character-based application myapp.exe.
  • Link the run-time support modules Adis, Adisinit and Adiskey to create a dynamic link library, adis.dll.
cbllink -s -omyapp.exe main.cbl unique1.cbl
cbllink -d adis adisinit adiskey
To Create a Dynamically Linked Application

To create an application in which the files main.cbl and fast1.cbl are compiled and linked to create the root module of the graphical application myapp.exe, use the command:

cbllink -g -s -omyapp.exe main.cbl fast1.cbl

To create an application in which the files subprog1.cbl and subprog2.cbl are compiled and linked to create a dynamic link library, subprogs.dll, use the command:

cbllink -d -s -osubprogs.dll subprog2.cbl subprog3.cbl
To Create a Dynamically Bound Application

To create a .dll file that can bind to the run-time system, and any version later than or including that supplied with this COBOL development system, use the command:

cbllink -d -r mydll.obj

To create a .dll file that must bind to the version of the run-time system supplied with this COBOL development system, use the command:

cbllink -d -rv mydll.obj
Parent topic: Linking from the Command Line
Related information
cbllink


Service Interfaces

  • imtkmake command
    Enables you to create and deploy a COBOL program-based service interface, and generate a client to access the deloyed service running on an enterprise server.
  • mfdepinst command
    Deploys the service interface contained in a COBOL archive file (.car file) to an enterprise server.
  • COBOL to Service Interface Data Type Matches
    Describes which COBOL data types correspond to available Service Interface data types, including Web Service, Java, and .NET service interfaces.
Parent topic: Command Line Reference


Running an Application from the Command Line

Runnable programs can be linked system executable files, which can be run directly from the command line, or dynamically loadable programs, which can be run without being linked into a system executable file.

  • Command to Run a Linked System Executable Program
Parent topic: Command Line Reference


Command to Run a Linked System Executable Program

To run a linked system executable program, enter the following command:

program-name [parameters]

where:

program-name
The name of a system executable file. If the program-name does not contain an explicit path then the directories specified by the PATH environment variable are searched.
parameters
Parameters that are required by the program. Each parameter is a string, separated from adjoining parameters by one or more spaces.
Parent topic: Running an Application from the Command Line


Configuring Enhanced ACCEPT and DISPLAY

Use the Adis Configuration utility to configure enhanced ACCEPT and DISPLAY statements.

  • Overview
  • Invoking the Adis Configuration Utility
  • Menus
  • Adiscf Functions
Parent topic: Command Line Reference


Overview

The Adis Configuration utility enables you to alter the default behavior of the enhanced ACCEPT and DISPLAY statements as described in your Language Reference

The Adis module can be configured to change behavior in many areas. Full details on Adis are provided in the chapter Adis. Adis contains an internal set of defaults which it uses unless the file ADISCTRL is present. Configuration changes ADISCTRL, not the defaults internal to Adis.

ADISCTRL is the configuration database for the Adis module. It can hold up to a maximum of 16 configurations, any of which are available to you. An entry at the start of ADISCTRL determines which configuration Adis uses.

ADISCTRL contains all of the machine-independent information required by Adis. This includes:

  • How ACCEPT and DISPLAY statements are to be executed.
  • The messages output by Adis in response to errors.
  • Which keys are enabled or disabled.

You can alter any of the configurations held in ADISCTRL using the the Adis Configuration utility. This utility is designed around a hierarchy of menus. These menus appear at the bottom of your screen and list the options available to you at any time.

The ADISCTRL file that is supplied with your COBOL system contains a number of configurations that are set up to emulate different dialects of COBOL. Most of the time you do not need to do anything other than use the Adis Configuration utility to select which one of these configurations you wish to use (use the Choose option on the main menu of the Adis Configuration utility).

The configurations supplied with your COBOL system include:

  • Default Configuration.

    This is exactly the same as the configuration built into Adis that is used at run time if no ADISCTRL file is found. This provides the standard mode of operation during execution of ACCEPT and DISPLAY statements.

  • RM Compatibility.

    This configuration should be selected if your program was originally written in RM/COBOL V2.0. This configuration provides a very close emulation of the action of ACCEPT and DISPLAY statements in RM COBOL.

  • DG ICOBOL Compatibility.

    This is provided to emulate the action of ACCEPT and DISPLAY statements under Data General's ICOBOL.

  • IBM V1.0 Compatibility.

    This is provided to emulate IBM COBOL V1.0. It is not a close emulation, especially in the action of ACCEPT operations into numeric and numeric-edited fields.

  • Microsoft V2 Compatibility.

    This is provided to emulate Microsoft COBOL V2.2. It is not a close emulation, especially in the action of ACCEPT operations into numeric and numeric-edited fields.

See the Compatibility Guide for full details on RM, DG ICOBOL, IBM and Microsoft compatibility.

If you do want to create your own configuration, we recommend that you do not change any of the supplied configurations directly. Instead, you should save the configuration you want to change under a different name and make changes to that.

If you create a custom ADISCTRL file, it must be accessible to your program (in the current directory or the directory specified by the COBDIR environment variable) at run time. If it is not, defaults are used.

Parent topic: Configuring Enhanced ACCEPT and DISPLAY


Invoking the Adis Configuration Utility

To invoke the Adis Configuration utility, enter the command line:

adiscf

The utility searches for ADISCTRL, first in the current directory and then in the directory specified by COBDIR. If one exists, the Adis Configuration utility reads in the configuration currently selected for use by Adis. If ADISCTRL does not exist, the following message is displayed on your screen:

adisctrl does not exist - Defaults used

The Adis Configuration utility has a set of default values built into it. These are used if ADISCTRL does not exist.

If the message:

Old style adisctrl found. Converting to new format.

is displayed, the Adis Configuration utility has located an ADISCTRL file from an earlier product. This file is of a different format. However, the Adis Configuration utility can read the old format and convert it. Once files have been converted to the new format, versions of Adis supplied with previous versions of the COBOL system can no longer read them.

Parent topic: Configuring Enhanced ACCEPT and DISPLAY


Menus

The Adis Configuration utility menus are organized to provide rapid access to its most commonly used functions.

You can access a help menu from any menu by pressing F1=Help. This calls the help screen for the option from which it is called.

The menus described in this section appear in alphabetical order according to the menu-name. The name of a menu is displayed on the left-hand side of the information line.

The information line lists information concerning which menu you are on or, if you are on the main menu, which configuration is currently loaded. Each menu contains a similar information line as you will discover while using the Adis Configuration utility.

  • The Adis Configuration Utility Main Menu
  • The Adis Key Control Menu
  • The Alter Accept/Display Options Menu
  • The Alter All Messages Menu
  • The Alter All ACCEPT/DISPLAY Options Menu
  • The Alter Configuration Menu
  • The Alter Crt-Under Highlighting Menu
  • The Alter Function Mappings Menu
  • The Alter Indicators Menu
  • The Alter Individual Messages Menu
  • The Alter Individual Options Menu
  • The Alter Message/Indicator Positions Menu
  • The Alter Messages Menu
  • The Alter Tab Stops Menu
  • The Choose Configuration Menu
  • The Delete Configuration Menu
  • The Enable/Disable Adis Keys Menu
  • The Load Configuration Menu
  • The Save Menu
Parent topic: Configuring Enhanced ACCEPT and DISPLAY


The Adis Configuration Utility Main Menu

Once you have invoked the Adis Configuration utility it displays its main menu and the information line.

The main menu provides access to a number of submenus, enabling you to perform the following actions:

  • Alter any aspect of a configuration.
  • Load a configuration.
  • Save a configuration.
  • Delete a configuration.
  • Choose a configuration for Adis to use when running your programs.
Parent topic: Menus


The Adis Key Control Menu

Pressing F8=Key Control from the Alter Configuration menu displays the Adis Key Control menu.

This menu enables you to perform the following actions:

  • Alter the function performed by a specific key
  • Make a key act as an Adis function key
  • Disable a key completely

where an Adis function key is a key which is used during an ACCEPT operation to perform an editing function; for example, to move the cursor.

Parent topic: Menus


The Alter Accept/Display Options Menu

Pressing F3=Accept/Display Options from the Alter Configuration menu displays the Alter Accept/Display Options menu.

This menu enables you to specify how you want the cursor to behave, and what you want the fields to look like, during an ACCEPT operation. You can choose to alter all the available options or individual ones.

Parent topic: Menus


The Alter All Messages Menu

Pressing F2=All Messages or A from the Alter Messages menu displays the Alter All Messages menu.

This menu enables you to change the messages Adis displays when certain conditions (such as the cursor being at the end of a field) occur.

Parent topic: Menus


The Alter All ACCEPT/DISPLAY Options Menu

Pressing F2=All Options or A from the Alter Accept/Display Options menu displays the Alter All Options menu.

This menu enables you to change a set of options (such as the range of data keys allowed during an ACCEPT operation) that determine the behavior of the ACCEPT and DISPLAY operations.

Parent topic: Menus


The Alter Configuration Menu

Selecting the Alter menu by pressing F2=Alter from the main menu enables you to alter all or part of a configuration.

Parent topic: Menus


The Alter Crt-Under Highlighting Menu

Pressing F2=Crt-Under Highlighting from the Alter Configuration menu displays the Alter Crt-Under Highlighting menu.

This menu enables you to alter the type of highlighting that is used with the DISPLAY ... UPON CRT-UNDER statement, the DISPLAY ... WITH UNDERLINE statement, or when the UNDERLINE clause is used in the Screen Section of your programs.

Parent topic: Menus


The Alter Function Mappings Menu

Pressing F3=Function Mappings from the Adis Key Control menu displays the Alter Function Mappings menu.

This menu enables you to map Adis keys so that they perform different functions to those originally associated with those keys.

Parent topic: Menus


The Alter Indicators Menu

Pressing F5=Indicators from the Alter Configuration menu displays the Alter Indicators menu.

This menu enables you to alter the text displayed by Adis during an ACCEPT operation to indicate various conditions. The text for each message can be up to 32 characters long. Once you have typed your own message press Enter to make that change.

Parent topic: Menus


The Alter Individual Messages Menu

Pressing F3=Individual Messages or I from the Alter Messages menu displays the Alter Individual Messages menu.

This menu displays a list of the currently defined messages with a number by the side of each. Press F2=Next Page to see the next screen of available messages, then press F2 again to see the original screen of messages.

Parent topic: Menus


The Alter Individual Options Menu

Pressing F3=Individual Options or I from the Alter Accept/Display Options menu displays the Alter Individual Options menu.

This menu enables you to change one of the options controlling the use of the ACCEPT and DISPLAY operations (such as the range of data keys enabled during an ACCEPT operation).

Parent topic: Menus


The Alter Message/Indicator Positions Menu

Pressing F7=Positions on the Alter Configuration menu displays the Alter Message/Indicator Positions menu.

This menu enables you to control whether or not the messages and indicators normally displayed by Adis during an ACCEPT operation are displayed. If you choose to display them, this menu also enables you to alter the position on the screen at which they are displayed.

Parent topic: Menus


The Alter Messages Menu

Pressing F6=Messages from the Alter Configuration menu displays the Alter Messages menu.

This menu enables you to alter the text of messages displayed by Adis during an ACCEPT operation, to indicate various error conditions. You can choose to alter all the available messages or individual ones.

Parent topic: Menus


The Alter Tab Stops Menu

Pressing F4=Tab Stops from the Alter Configuration menu displays the Alter Tab Stops menu.

This menu enables you to set up to 96 tab stops to be used at run time. The Tab Stops screen shows a ruler at the top of the screen on which the current positions of tab stops are shown by the letter T. Use the cursor keys <left-arrow> and <right-arrow> to move the cursor along the ruler.

Parent topic: Menus


The Choose Configuration Menu

Pressing F6=Choose from the main menu displays the Choose Configuration menu.

This menu enables you to choose the configuration to be used by Adis when you run your programs.

Parent topic: Menus


The Delete Configuration Menu

Pressing F5=Delete or D from the main menu displays the Delete Configuration menu.

This menu enables you to delete an existing configuration from the ADISCTRL file.

Parent topic: Menus


The Enable/Disable Adis Keys Menu

Pressing F2=Enable/Disable Adis Keys or D from the Adis Key Control menu displays the Enable/Disable Adis Keys menu.

This menu enables you to control which of the functions performed by the Adis keys are enabled.

Parent topic: Menus


The Load Configuration Menu

Pressing F3=Load or L from the main menu displays the Load Configuration menu.

This menu enables you to load an existing configuration into memory. You must load a configuration into memory before you can make any changes to that particular configuration.

Parent topic: Menus


The Save Menu

Pressing F4=Save from the main menu displays the Save menu.

Once you have altered a configuration, using the Alter menu, this menu enables you to save your changes.You must do this if you wish to use the new version of your configuration. If you attempt to leave the Adis Configuration utility without first saving any changes you have made to a configuration, you are asked to confirm that this is what you wish to do.

Parent topic: Menus


Adiscf Functions

Adiscf functions are accessed from menus. The following table lists the available functions in alphabetical order, describes them in detail, and indicates the keys you must press to access them.

Add New Tab Stop
Access keys: F2>F4>F2
Sets a tab stop at the current cursor position. A "T" is displayed to show the position of the new tab stop. During an ACCEPT operation,Tab only moves to the next tab stop if it is mapped to the "Move to next tab stop" function.
Alter ACCEPT/DISPLAY Options
Access keys: F2>F3
Displays the Alter ACCEPT/DISPLAY Options menu.
Alter All ACCEPT/DISPLAY Options
Access keys: F2>F3>F2
Displays a description of each option and its current value in turn, one option per screen.

Press Enter to move from one screen to the next or Escape to return to the Alter Accept/Display Options menu. To alter the value of an option, type the number of the choice you require at the relevant prompt. You can alter as few or as many options as you wish.

Alter All Messages
Access keys: F2>F6>F2
Displays in turn the current text of each message and the conditions under which it is output; one message per screen. Press Enter to cycle from one screen to the next.

To alter a message, type the text of the new message at the prompt on the relevant screen, then press Enter to save the new message and return you to the Alter Messages menu. You can alter as few or as many messages as you wish. Pressing Escape returns you to the Alter Messages menu, abandoning any change made to the current message.

Alter Auto Clear Indicator
Access keys: F2>F5>F4
Displays the current text for the auto clear and clear auto clear indicators. The auto clear indicator is displayed during an ACCEPT operation if the first character entered into a field would cause the field to be cleared before the character is placed into it. The clear auto clear indicator is displayed at the end of an ACCEPT operation to remove the auto clear indicator if it is currently displayed.

Use the cursor keys (cursor-up and cursor-down) to move between the two fields. Press Enter to save your changes, or Escape to leave the Alter Auto Clear Indicator menu without altering either of the indicators.

Alter Configuration
Access key: F2
Displays the Alter Configuration menu.
Alter CRT-UNDER Hightlighting
Access keys: F2>F2
Displays the Alter CRT-UNDER Highlighting menu.
Alter Indicators
Access keys: F2>F5
Displays the Alter Indicators menu.
Alter Individual ACCEPT/DISPLAY Option
Access keys: F2>F3>F3
Displays a screen of ACCEPT/DISPLAY options you can change. The currently selected option is highlighted. Press F2=Next Page to see a page of further options, then press F2 again to return to the page of original options.

Type the number of the option you want to change or position the cursor on the relevant line using the cursor keys ( and ). Press Enter to select that option.

A description of that option and its current value is then displayed. To alter the value of an option, type the number of the choice you require at the relevant prompt and press Enter. Press Escape to return to the Alter Individual Options menu.

Alter Individual Messages
Access keys: F2>F6>F3
Displays a screen of messages you can change. The currently selected message is highlighted. Press F2=Next Page to see a page of further options, then press F2 again to return to the page of original messages.

Type the number of the message you want to change, or position the cursor on the relevant line, using the cursor keys (cursor-up and cursor-down). Press Enter to select that message. The message currently configured for that error condition is displayed. Type the new message at the prompt on the screen. Press Enter to save the message you have typed and return to the list of messages, or press Escape to abandon any change you have made and return to the list of messages.

Alter Insert/Replace Indicator
Access keys: F2>F5>F2
Displays the current text for the insert, replace and clear insert/replace indicators. The insert indicator is displayed when insert mode is active during an ACCEPT operation. The replace indicator is displayed if replace mode is active during an ACCEPT operation. The clear insert/replace indicator is displayed at the end of an ACCEPT operation to remove whichever of the two other indicators is currently displayed.

Use the cursor keys (cursor-up and cursor-down) to move between the three fields. Press Enter to save your changes, or Escape to leave the Alter Insert/Replace Indicator menu without altering any of the indicators.

Alter Key Control
Access keys: F2>F8
Displays the Enhanced ACCEPT/DISPLAY Syntax Key Control menu.
Alter Messages
Access keys: F2>F6
Displays the Alter Messages menu.
Alter Off End of Field Indicator
Access keys: F2>F5>F3
Displays the current text for the off end of field and clear off end of field indicators. The off end of field indicator is displayed during an ACCEPT operation if the next character entered would be beyond the end of the field. The clear off end of field indicator is displayed at the end of an ACCEPT operation to remove the indicator that is currently displayed.

Use the cursor keys (cursor-up and cursor-down) to move between the two fields. Press Enter to save your changes, or Escape to leave the Alter Insert/Replace Indicator menu without altering any of the indicators.

Alter Position of Messages and Indicators
Access keys: F2>F7
Displays the four categories of messages and indicators whose positioning you can alter, along with input fields for you to enter the relevant positioning for each category.

Use the cursor keys (cursor-left, cursor-right, cursor-up and cursor-down) to move around the screen from field to field. If you want error messages or a specific indicator to be displayed during an ACCEPT operation enter Y in the relevant field. Enter N if you do not want them to be displayed. Even if you choose not to display error messages, the abort confirmation message is always displayed when the Abort key is pressed during an ACCEPT operation, unless you use the Alter Messages Menu to specifically alter the text associated with this message.

If you choose to display the messages or any specific indicators, you can alter the default positions at which they are displayed on your screen during an ACCEPT operation. Use the cursor keys to position the cursor in the relevant fields and type the new line and column at which you wish the messages or indicator to be displayed.

Line 1 column 1 is the top left-hand corner of your screen.

If you configure more than one indicator to be displayed at the same position, and more than one needs to be displayed at the same time, the off end of field and auto clear indicators take priority over the insert/replace indicator.

Selecting line 255 for any indicator causes the indicator to be displayed on the bottom line of the screen, regardless of the actual length of the screen.

Press Enter once you have made your entries, to return to the Alter Configuration menu and save your changes. Press Escape to return to the Alter Configuration menu, abandoning any changes you have made.

Alter Tab Stops
Access keys: F2>F4
Displays the Alter Tab Stops menu.
Choose Configuration
Access key: F6
Displays the available configurations, with the one currently active appearing highlighted.

Choose the configuration you require either by entering its number at the prompt, or by positioning the cursor on the relevant configuration name using the cursor keys (cursor-up and cursor-down). This line now appears highlighted.

When you have highlighted the configuration you want to choose, press Enter. The highlighted configuration becomes the active configuration and you are returned to the Adiscf main menu. When you next run a program using your COBOL system, the enhanced ACCEPT/DISPLAY syntax automatically uses the configuration you have just chosen. Alternatively, you can press Escape to return to the Adiscf main menu without choosing a new configuration.

Delete Configuration
Access key: F5
Displays the existing configurations, with the current configuration appearing highlighted. Highlight the configuration you wish to delete by entering its number to the prompt, or by using the cursor keys (cursor-up and cursor-down).

When you have highlighted the configuration you want to delete, press Enter. The configuration is deleted from adisctrl and you are returned to the Adiscf main menu. Alternatively you can press Escape to return to the Adiscf main menu without deleting a configuration.

Important: You cannot delete the configuration which is currently selected. If you wish to delete this you must first use the Choose menu to choose an alternative configuration.
Delete Tab Stop
Access key: F2>F4>F3
Deletes the tab stop (represented by T) at the current cursor position. You should first have used the cursor keys (cursor-left and cursor-right) to position the cursor over the tab stop to be deleted.
Enable/Disable Enhanced ACCEPT/DISPLAY Syntax Keys
Access keys: F2>F8>F2
Displays a list of all functions provided by the enhanced ACCEPT/DISPLAY syntax keys, together with the current status of each key.

You can alter the status of any key to be one of the following:

Status | Description
d | Disabled - the key does not perform its associated function during an ACCEPT operation.
E | Enabled - the key performs its associated function during an ACCEPT operation.
F | Function key - the key acts as a function key during an ACCEPT operation.

Use the cursor keys (cursor-left, cursor-right, cursor-up and cursor-down) to move from field to field on the screen and enter the required letter in the field(s) you wish to alter.

Press Enter once you have made your entries, to return to the Enhanced ACCEPT/DISPLAY Syntax Key Control menu and save your changes. Press Escape to return to the Enhanced ACCEPT/DISPLAY Syntax Key Control menu, abandoning any changes you have made.

Escape
Access key: Esc
Returns to the higher level menu or exits from Adiscf altogether if you are at the Adiscf main menu. Where both Escape and Enter are available options, Escape exits without making the update you have keyed in, whereas Enter makes the update and then exits.
Load Configuration
Access key: F3
Displays a list of available configurations.

The configurations may vary according to the version of the software.

The configuration currently loaded appears highlighted on your screen. To select a configuration, either enter its number at the prompt or use the cursor keys (cursor-up and cursor-down) to position the cursor on the line specifying the required configuration. When you move the cursor to another configuration, that configuration appears highlighted on the screen, and its number appears at the prompt position at the bottom of your screen.

Once you have highlighted the configuration you require, press Enter. Adiscf loads the configuration you have selected into memory from adisctrl.

You are then returned to the Adiscf main menu. The configuration you have just selected appears on the information line. You can now alter this configuration by selecting the Alter menu.

If you do not want to select a configuration to load, pressing Escape returns you to the Adiscf main menu.

Map Adis Keys
Access keys: F2>F8>F3
Displays a page of supported enhanced ACCEPT/DISPLAY syntax functions. Press F2=Next Page to see a page of further functions, then press F2 again to return to the page of original functions.

This function enables you to alter the function normally associated with a key. You can map any function to any key. Each function key has three fields associated with it which you can alter:

Field | Description
Validate | If you set this field to Y, all validation criteria must be satisfied before the cursor can leave a field during an ACCEPT operation. If you enter N, validation criteria are not checked during an ACCEPT operation.
Align | By default this field is set to N. If set to Y, a field is cleared from the current cursor position to the end of the field during an ACCEPT operation. Numeric fields are aligned to the decimal point, if it is to the right of the current cursor position.
Mapped Number | This field contains the number of the function to which the associated key is currently mapped. Enter the number of the required function if you want to alter this.

Press F2=Next Page to display a page of further function mappings.

Move between the fields using the cursor keys (cursor-left, cursor-right, cursor-up and cursor-down). When you have made your changes, press Enter to return to the Enhanced ACCEPT/DISPLAY Syntax Key Control menu and save your changes. Press Escape to return to the Enhanced ACCEPT/DISPLAY Syntax Key Control menu if you do not wish to save your changes, or you have made none.

Overwrite Existing Configuration
Access keys: F4>F3
Saves your configuration in adisctrl with the same name as an existing configuration. Use this option with care as it overwrites the existing configuration with that name. Adiscf displays a numbered list of the existing configurations. Type the number of the configuration you want to overwrite, or position the cursor on the relevant line, using the cursor up and down keys. Press Enter to save the configuration to the name you have specified and to return to the Adiscf main menu. Alternatively, press Escape to return to the Adiscf main menu without saving.

You can store up to 16 configurations in adisctrl. If you try to save more than this number you receive the message:

The configuration file is full - No new entries allowed

If you receive this message you must either delete or overwrite an existing configuration before you can save any others.

Save
Access key: F4
Displays the Save menu.
Save New Configuration
Access Keys: F4>F2
Saves your configuration as a new configuration within adisctrl. You are prompted to type the name of this configuration. Press Enter to save the configuration to the name you have entered and to return to the Adiscf main menu. Alternatively, press Escape to return to the Adiscf main menu without saving.
Save New Tab Stop Settings
Access Keys: F2>F4>F4
Saves the changes you have made to the positions of the tab stops, and returns to the Alter Configuration menu.
Set CRT-UNDER Attribute to Blink
Access Keys: F2>F2>F5
Specifies that the attribute to be used when a DISPLAY ... UPON CRT-UNDER statement is executed is blinking. The word BLINK appears on the information line.
Set CRT-UNDER Attribute to Bold
Access Keys: F2>F2>F2
Specifies that the attribute to be used when a DISPLAY ... UPON CRT-UNDER statement is executed is bold. The word INTENSITY appears on the information line.
Set CRT-UNDER Attribute to Reverse Video
Access Keys: F2>F2>F4
Specifies that the attribute to be used when a DISPLAY ... UPON CRT-UNDER statement is executed is reverse video. The words REVERSE VIDEO appear on the information line in reverse video.
Set CRT-UNDER Attribute to Underscore
Access Keys: F2>F2>F3
Specifies that the attribute to be used when a DISPLAY ... UPON CRT-UNDER statement is executed is underscore. The word UNDERSCORE appears on the information line.
Parent topic: Configuring Enhanced ACCEPT and DISPLAY


Test Coverage

Information regarding test coverage is provided on the Micro Focus Web site.

See Test Coverage

Parent topic: Command Line Reference


Compiler Directives

Restriction: Some compiler directives can be used only if you have certain features installed, or if you are using them with a particular platform or interface.
  • Language Features
  • Compiler Control
  • Compiling for Debugging and Analysis
  • File Handling
  • Managed COBOL Command Line Compiler Directives
  • Object Code, Size, and Optimization
  • Report Writer
  • Reserved Directives
  • Run-time Behavior
  • Key to Compiler Directives
  • Compiler Directives - Alphabetical List
Parent topic: General Reference
Related information
CBL2XML Utility
To set project-wide build properties and compiler directives


Language Features

These directives change which language features your Compiler accepts.

  • Language Features - Dialect
  • Language Features - Mainframe Compatibility
  • Language Features - Multi-threading
  • Language Features - Reserved Word Control
  • Language Features - Speed
  • Language Features - Additional Features
Parent topic: Compiler Directives


Language Features - Dialect

  • ACTUAL-PARAMS
    Specifies actual parameters that are substituted for formal parameters in a parameterized class or interface.
  • ACU
    Enables compatibility with ACUCOBOL-GT COBOL.
  • ACU-COMMENT
    Treats lines of code starting with a pipe (|) as comment lines.
  • ACUOPT
    Enables you to set various options specifically for compilation of ACUCOBOL-GT applications.
  • ACUSYNC
    Changes the effect of the SYNC clause so that it matches that used in ACU programs.
  • ANS85
    Specifies that words reserved in the ANSI'85 COBOL Standard are to be treated as reserved words in this COBOL system, and changes the behavior of certain features to be compatible with that Standard.
  • BS2000
    Ensures that words reserved under the Siemens BS2000 COBOL dialect are reserved words in this COBOL system, and changes the behavior of certain features to be compatible with that COBOL dialect.
  • COMS85
    Allows your program to contain syntax introduced in the Communications Module of the ANSI'85 COBOL Standard.
  • DBCHECK
    Makes the Compiler check that any Double-byte Character Set (DBCS) literals only contain valid 16-bit DBCS characters.
  • DBCS
    Makes the Compiler accept characters of the Double-byte Character Set (DBCS) for use in ideographic languages such as Japanese, Chinese and Korean.
  • DBCSSOSI
    Defines the two characters used as the shift-out and shift-in delimiters in DBCS literals.
  • DG
    Changes the behavior of certain features to be compatible with Data General Interactive COBOL rev 1.30.
  • DIALECT
    Enables check-time and run-time behavior consistent with the specified dialect.
  • ENTCOBOL
    Specifies that words reserved in IBM Enterprise COBOL for z/OS and OS/390 are to be treated as reserved words..
  • FLAG
    Makes the Compiler produce language-level certification flags when it finds syntax that is not part of a specified dialect of COBOL.
  • FLAGCD
    When used in conjunction with the FLAG directive, FLAGCD flags any directive settings that would cause incompatibility with the specified dialect of COBOL.
  • FLAGSTD
    Makes the Compiler produce language-level certification flags when it finds syntax that is not part of a specified level of the ANSI'85 Standard.
  • IBM-MS
    Specifies that words reserved in IBM COBOL V1.00 are to be regarded as reserved words, and changes the behavior of certain features to be compatible with that COBOL system.
  • ISO2002
    Specifies that words reserved in the ISO2002 COBOL Standard are to be treated as reserved words, and changes the behavior of certain features to be compatible with that standard.
  • JAPANESE
    Enables the use of Micro Focus Japanese Language Extension (PIC N, Japanese data-names and Japanese procedure-names).
  • MF, MFLEVEL
    Facilitates forward compatibility with Micro Focus COBOL systems by selectively enabling Micro Focus-specific reserved words and changing the behavior of certain features to be compatible with particular versions.
  • MS
    Facilitates forward compatibility with Microsoft COBOL systems by selectively enabling Microsoft-specific reserved words and changing the behavior of certain features to be compatible with particular versions.
  • NCHAR
    Enables the use of Micro Focus Double-byte Language Extension (PIC N, Japanese data-names and Japanese procedure-names).
  • NSYMBOL
    Defines the default USAGE for PIC N clauses and controls the interpretation of national literals.
  • OOCTRL
    Enables you to change language options when compiling OO COBOL classes and interfaces.
  • OSVS
    Specifies that words reserved in IBM OS/VS COBOL are to be treated as reserved words.
  • PC1
    Specifies that words reserved in IBM COBOL V1.00 are to be regarded as reserved words, and changes the behavior of certain features to be compatible with that COBOL system.
  • RM
    Specifies that words reserved in RM/COBOL are to be regarded as reserved words, and changes the behavior of certain features to be compatible with that COBOL system.
  • VSC2
    Specifies that words reserved in IBM VS COBOL II are to be treated as reserved words, and enables selected features for compatibility with a given level of that COBOL system.
  • XOPEN
    Specifies that words reserved under the X/Open definition of COBOL are to be treated as reserved words.
Parent topic: Language Features


ACTUAL-PARAMS

Specifies actual parameters that are substituted for formal parameters in a parameterized class or interface.

Syntax:

>>-.---.-.----ACTUAL-PARAMS--"parameters"--.-------><
   +-/-+ +-NO-ACTUAL-PARAMS----------------+

Parameters:

parameters A maximum of 32 space-separated parameters. At least one parameter must be specified.

Properties:

Default: | NOACTUAL-PARAMS
Phase: | Syntax check
$SET: | Initial
Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


ACU

Enables compatibility with ACUCOBOL-GT COBOL.

Syntax:

>>--.---.--.----.--ACU------><
    +-/-+--+-NO-+

Parameters:

None

Properties:

Default: | NOACU
Phase: | Syntax check
$SET: | Initial

Dependencies:

ACU sets ACU-SYNC, ACU-COMMENT, LOCAL-SOURCEFORMAT, MFSYNC(8), ALIGN(8), COMP-5(1), COMP-6(3), IDENTIFIERLEN(62), NOMFCOMMENT, NORESEQ, SIGN(ACU), TRUNC(ACU)

ACU is set by ACUOPT.

Comments:

Setting ACU enables some ACU extensions to the language and implements changes of behavior for compatibility with ACUCOBOL-GT COBOL. Refer to ACUCOBOL-GT Syntax Extensions for more information.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


ACU-COMMENT

Treats lines of code starting with a pipe (|) as comment lines.

Syntax:

 >>-.---.-.----.--ACU-COMMENT---><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOACUCOMMENT (Dialect)
Phase: | Syntax check
$SET: | Any
Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


ACUOPT

Enables you to set various options specifically for compilation of ACUCOBOL-GT applications.

Syntax:

>>--.---.-----ACUOPT--(option)----><
    +-/-+

Parameters:

option
The ACU compiler option in the form -Xx or --option.
Refer to Supported ACUCOBOL-GT Compiler Options for details on the options you can set.

Properties:

Default: | None
Phase: | Syntax check
$SET: | Initial

Comments:

Setting any option using ACUOPT automatically sets the ACU compiler directive.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List
Related information
Supported ACUCOBOL-GT Compiler Options


ACUSYNC

Changes the effect of the SYNC clause so that it matches that used in ACU programs.

Syntax:

>>--.---.---ACUSYNC------><
    +-/-+

Parameters:

None

Properties:

Default: | Standard SYNC clause behavior
Phase: | Syntax check
$SET: | Initial

Comments:

A synchronized elementary item always causes any containing group item to be aligned on the boundary of the most restrictive synchronized elementary item, and that group to be padded at the end to a multiple of that size. e.g. a group containing an elementary data item that was "DOUBLE SYNC" will always be aligned on an 8 byte boundary and will be padded to be a multiple of 8 bytes long.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


ANS85

Specifies that words reserved in the ANSI'85 COBOL Standard are to be treated as reserved words in this COBOL system, and changes the behavior of certain features to be compatible with that Standard.

Syntax:

>>-.----.-.-------ANS85---"SYNTAX"--.--------><
   +-/--+ +.----.-ANS85-------------+
           +-NO-+

Parameters:

SYNTAX Makes the directive affect syntax only and not behavior.

Properties:

Default: | ANS85 (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to ANS85 at end by COBOL370, ENTCOBOL, MVS, OS390, SAA"2", VSC2"3" or VSC2"4".

Comments:

This directive causes the following behavior changes:

  • The I/O status values are those defined in ANSI'85.
  • The ALPHABETIC class test regards lower case as alphabetic.
  • Control variables in PERFORM operations are initialized in the order specified by ANSI'85.
  • Move operations to a variable-length group item use the maximum length of the target if the DEPENDING ON item is in the group.
Parent topic: Language Features - Dialect
Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List


BS2000

Ensures that words reserved under the Siemens BS2000 COBOL dialect are reserved words in this COBOL system, and changes the behavior of certain features to be compatible with that COBOL dialect.

Syntax:

>>-.---.-.----.--BS2000---------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOBS2000
Phase: | Syntax check
$SET: | Initial
Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


COMS85

Allows your program to contain syntax introduced in the Communications Module of the ANSI'85 COBOL Standard.

Syntax:

>>-.---.-.----.--COMS85--------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOCOMS85 (Dialect)
Phase: | Syntax check
$SET: | Initial
Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


DBCHECK

Makes the Compiler check that any Double-byte Character Set (DBCS) literals only contain valid 16-bit DBCS characters.

Syntax:

>>-.---.-.----.--DBCHECK-------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | DBCHECK (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

If you specify DBCHECK in environments that support validation of DBCS data, any literal that does not contain only valid 16-bit DBCS characters results in syntax error 1048 (DBCS literal includes invalid data).

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


DBCS

Makes the Compiler accept characters of the Double-byte Character Set (DBCS) for use in ideographic languages such as Japanese, Chinese and Korean.

Syntax:

>>-.---.-.-------DBCS-"integer"-.---------><
   A-/-+ +.----.-DBCS-----------+
          +-NO-+

Parameters:

integer
One of:
1
Behavior as in earlier versions of this Compiler.
2
Provides full System Application Architecture (SAA) DBCS support. This directive sets DBSPACE.
3
Includes DBCS support as in IBM COBOL/370. This includes the use of PIC N, PIC G, and DBCS literals specified with "delimiter N".

Properties:

Default: | DBCS"3"
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to DBCS"2" immediately by SAA, VSC2"2", VSC2"3" or MF"7".

Set to DBCS"3" immediately by COBOL370 or MF"integer" where integer > 7.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


DBCSSOSI

Defines the two characters used as the shift-out and shift-in delimiters in DBCS literals.

Syntax:

 >>-.---.-.----DBCSSOSI-"integer-1"-"integer-2"-.--><
    +-/-+ +-NO-DBCSSOSI-------------------------+

Parameters:

integer-1 | ASCII code of the shift-out character, in decimal.
integer-2 | ASCII code of the shift-in character, in decimal.

Properties:

Default: | NODBCSSOSI (Dialect)
Phase: | Syntax check
$SET: | IAny

Comments:

When shift-out and shift-in characters are specified by this directive, every DBCS literal must have the shift-out character immediately after the opening quotation mark and the shift-in character immediately before the closing quotation mark. They act as additional delimiters to the literal, and are not part of its value. With NODBCSSOSI, no shift-out and shift-in characters are needed or recognized.

Parent topic: Language Features - Dialect
Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Language Features - Mainframe Compatibility
Key to Compiler Directives


DIALECT

Enables check-time and run-time behavior consistent with the specified dialect.

Syntax:

>>--.---.----DIALECT--"dialect"-----------><
    +-/-+

Parameters:

dialect
The dialect to use. Other compiler directives are set depending on the value. Valid values are listed in the Comments section below.

Properties:

Default: | DIALECT"MF"
Phase: | Check
$SET: | Initial

Dependencies:

Depending on the setting of dialect, various other Compiler directives are set by default.

Comments:

The settings SAA1 and SAA2 are also available; use these for backward compatibility purposes only.

Note: Under your COBOL development system, the DIALECT directive does not set the AMODE directive. To provide compatibility with mainframe style pointers, you will need to set AMODE to the appropriate storage format.

Valid dialect values are listed below. Click on a value to see the other compiler directives that are set for each dialect.

Examples

DIALECT"ANS85"
This sets the dialect to emulate the ANS85 COBOL.

Some directives set by DIALECT are the same as those set by default by the Compiler. However, you need to know the setting of a dialect-specific directive as it might overwrite the setting you expect. For example:

ALIGN"2" DIALECT"ANS85"
This sets ALIGN to ALIGN"8", since this is the value set by the DIALECT"ANS85".
ALIGN"2" DIALECT"MF"
This also sets ALIGN to ALIGN"8", since the MF dialect sets the directives to their default values. For ALIGN, the defualt is ALIGN"8".
  • ACU DIALECT setting
  • ANS85 DIALECT setting
  • BS2000 DIALECT setting
  • BS2000-OFFLOAD DIALECT setting
  • COB370, COB371 and COB372 DIALECT settings
  • ENTCOBOL DIALECT setting
  • ISO2002 DIALECT setting
  • MF DIALECT setting
  • MVS DIALECT setting
  • OS390 DIALECT setting
  • OSVS DIALECT setting
  • RM DIALECT setting
  • VSC21 and VSC22 DIALECT settings
  • VSC23 and VSC24 DIALECT settings
Parent topic: Language Features - Dialect
Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Control - Directives Control
Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
AMODE
Language Features - Dialect


ACU DIALECT setting

If you set DIALECT"ACU", the following Compiler directives are set:

ACU

ACU-COMMENT

ACU-SYNC

ALIGN(8)

COMP-5(1)

COMP-6(3)

IDENTIFIERLEN(62)

LOCAL-SOURCEFORMAT

NOMFCOMMENT

MFSYNC(8)

NORESEQ

SIGN(ACU)

TRUNC(ACU)

Parent topic: DIALECT


ANS85 DIALECT setting

If you set DIALECT"ANS85", the following Compiler directives are set:

NOADV

ALIGN"8"

ALPHASTART"1"

ALTER

ANS85

ARITHMETIC"MF"

NOBS2000

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"ASCII"

CHECKDIV"ANSI"

COMS85

COPYEXT"cbl,CPY,"

COPYLBR

CURRENT-DATE"MMDDYY"

NODBCHECK

NODBCS

NODBCSSOSI

NODBSPACE

DE-EDIT"2"

DEFAULTBYTE"32"

NODG

DPC-IN-SUBSCRIPT

DYNAM

ECHO

NOENTCOBOL

NOEXTINDEX

NOFDCLEAR

NOFLAG

NOFLAGAS

FLAGCD"W"

NOFLAGMIG

FLAGSTD"H C2 D2 S2 R O"

FOLDCALLNAME"UPPER"

FOLDCOPYNAME"UPPER"

NOHOSTNUMCOMPARE

NOHOSTNUMMOVE

NOIBM-MS

INFORETURN"U"

INTLEVEL"2"

IOCONV

NOISO2002

NOLIBRARIAN

NOMAPNAME

NOMF

NOMFCOMMENT

NOMS

NOODOSLIDE

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOLDREADINTO

NOOLDSTRSUB

NOOPTIONAL-FILE

NOPC1

PERFORM-TYPE"MF"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

QUOTE

NORDW

RECMODE"F"

REMAINDER"1"

NORESEQ

NORM

NOSEQCHK

SOURCEFORMAT"FIXED"

NOSPZERO

NOSTICKY-LINKAGE

NOSTICKY-PERFORM

SYMBSTART"1"

TRUNC"ANSI"

TRUNCCALLNAME"8"

NOTRUNCCOPY

WARNING"3"

NOXOPEN

ZEROLENGTHFALSE

NOZEROSEQ

NOZWB

Parent topic: DIALECT


BS2000 DIALECT setting

If you set DIALECT"BS2000", the following Compiler directives are set:

ALIGN"8"

ALPHASTART"1"

ALTER

NOANS85

ARITHMETIC"MF"

ASSIGN"EXTERNAL"

BS2000

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"EBCDIC"

CHECKDIV"ANSI"

NOCOMS85

COMP5-BYTE-ORDER"NATIVE"

COPYEXT"cbl,CPY,"

NOCOPYLBR

CURRENT-DATE"MMDDYY"

NODBCHECK

NODBCS

NODBCSSOSI

NODBSPACE

DE-EDIT"2"

DEFAULTBYTE"00"

NODG

DPC-IN-SUBSCRIPT

DYNAM

ECHO

NOENTCOBOL

NOEXTINDEX

FCDCAT

NOFDCLEAR

FLAG"BS2000"

FLAGAS"S"

FLAGCD"W"

NOFLAGMIG

NOFLAGSTD

FOLDCALLNAME"UPPER"

FOLDCOPYNAME"UPPER"

NOHOSTNUMCOMPARE

NOHOSTNUMMOVE

NOIBM-MS

INFORETURN"U"

INTLEVEL"4"

IOCONV

ISO2002

NOLIBRARIAN

NOMAPNAME

NOMF

NOMFCOMMENT

NOMS

ODOSLIDE

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOLDREADINTO

NOOLDSTRSUB

NOOPTIONAL-FILE

NOPC1

PERFORM-TYPE"MF"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

QUOTE

NORDW

RECMODE"F"

REMAINDER"1"

NORESEQ

NORM

RTNCODESIZE"4"

NOSEQCHK

SOURCEFORMAT"FIXED"

NOSPZERO

NOSTICKY-LINKAGE

NOSTICKY-PERFORM

SWITCH-TYPE"3"

SYMBSTART"1"

TRUNC

NOTRUNCCOPY

WARNING"3"

NOXOPEN

ZEROLENGTHFALSE

NOZEROSEQ

NOZWB

Parent topic: DIALECT


BS2000-OFFLOAD DIALECT setting

If you set DIALECT"BS2000-OFFLOAD", the following Compiler directives are set:

ALIGN"8"

ALPHASTART"1"

ALTER

NOANS85

ARITHMETIC"MF"

ASSIGN"EXTERNAL"

BS2000-OFFLOAD

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"ASCII"

CHECKDIV"ANSI"

NOCOMS85

COMP5-BYTE-ORDER"NATIVE"

COPYEXT"cbl,CPY,"

NOCOPYLBR

CURRENT-DATE"MMDDYY"

NODBCHECK

NODBCS

NODBCSSOSI

NODBSPACE

DE-EDIT"2"

DEFAULTBYTE"00"

DPC-IN-SUBSCRIPT

NODG

DYNAM

ECHO

NOENTCOBOL

NOEXTINDEX

FCDCAT

NOFDCLEAR

FLAG"BS2000"

FLAGAS"S"

FLAGCD"W"

NOFLAGMIG

NOFLAGSTD

FOLDCALLNAME"UPPER"

FOLDCOPYNAME"UPPER"

NOHOSTNUMCOMPARE

NOHOSTNUMMOVE

NOIBM-MS

INFORETURN"U"

INTLEVEL"4"

IOCONV

ISO2002

NOLIBRARIAN

NOMAPNAME

NOMF

NOMFCOMMENT

NOMS

ODOSLIDE

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOLDREADINTO

NOOLDSTRSUB

NOOPTIONAL-FILE

NOPC1

PERFORM-TYPE"MF"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

QUOTE

NORDW

RECMODE"F"

REMAINDER"1"

NORESEQ

NORM

RTNCODESIZE"4"

NOSEQCHK

SOURCEFORMAT"FIXED"

NOSPZERO

NOSTICKY-LINKAGE

NOSTICKY-PERFORM

SWITCH-TYPE"2"

SYMBSTART"1"

TRUNC

NOTRUNCCOPY

WARNING"3"

NOXOPEN

ZEROLENGTHFALSE

NOZEROSEQ

NOZWB

Parent topic: DIALECT


COB370, COB371 and COB372 DIALECT settings

If you set DIALECT"COB370", DIALECT"COB371" or DIALECT"COB372", the following Compiler directives are set:

ADV

ALIGN"8"

ALPHASTART"1"

ALTER

ANS85

APOST

AREACHECK

ARITHMETIC"VSC2"

ASSIGN"EXTERNAL"

NOBOUND

BYTEMODEMOVE

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"EBCDIC"

CHECKDIV"COBOL370"

COBOL370"2" (for DIALECT"COB370")

COBOL370"2" (for DIALECT"COB372")

COBOL370"1" (for DIALECT"COB371")

COBSTATCONV

COMS85

COPYEXT"CPY,CBL"

COPYLBR

CURRENT-DATE"MMDDYY"

DBCHECK

DBCS"3"

DBCSSOSI"14""15"

DBSPACE

DE-EDIT"2"

DEFAULTBYTE"00"

NODG

NODOSVS

DPC-IN-SUBSCRIPT

NODYNAM

ECHO

NOENTCOBOL

NOEXTINDEX

FCDCAT

FDCLEAR

FLAG"COBOL370"

FLAGAS"S"

FLAGCD"W"

NOFLAGMIG

NOFLAGSTD

FOLDCALLNAME"UPPER"

FOLDCOPYNAME"UPPER"

HOSTNUMCOMPARE"2"

HOSTNUMMOVE"2"

NOIBM-MS

IBMCOMP

INDD

INFORETURN"0"

NOLIBRARIAN

LISTWIDTH"80"

MAPNAME

NOMF

NOMFCOMMENT

NOMS

NOODOOSVS

ODOSLIDE

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOPTIONAL-FILE

NOOS390

NOOSVS

OUTDD

NOPANVALET

NOPC1

PERFORM-TYPE"COB370"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

QUOTE

RDW

RECMODE"COB370"

REMAINDER"2"

RESEQ

NORM

RTNCODESIZE"2"

NOSEQCHK

SEQUENTIAL"RECORD"

SETTINGS"COL"

SOURCEFORMAT"FIXED"

NOSPZERO

STICKY-LINKAGE

NOSTICKY-PERFORM

SYMBSTART"1"

NOTRACE

NOTRUNC

TRUNCCALLNAME"8"

TRUNCCOPY"8"

WARNING"3"

NOXOPEN

NOXREF

ZEROLENGTHFALSE

NOZEROSEQ

ZWB

Parent topic: DIALECT


ENTCOBOL DIALECT setting

If you set DIALECT"ENTCOBOL" the following Compiler directives are set:

ADV

ALIGN"4"

ALPHASTART"1"

ALTER

ANS85

APOST

AREACHECK

ARITHMETIC"ENTCOBOL"

ASSIGN"EXTERNAL"

NOBOUND

BYTEMODEMOVE

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"EBCDIC"

CHECKDIV"ENTCOBOL"

COBSTATCONV

NOCOBOL370

COMS85

COMP5-BYTE-ORDER"NATIVE"

COPYEXT"CPY,CBL"

COPYLBR

COPYLIST

CURRENT-DATE"MMDDYY"

DBCHECK

DBCS"3"

DBCSSOSI"14""15"

DBSPACE

DE-EDIT"2"

DEFAULTBYTE"00"

NODG

NODOSVS

DPC-IN-SUBSCRIPT

NODYNAM

ECHO

ENTCOBOL

NOEXTINDEX

FCDCAT

FDCLEAR

FLAG"ENTCOBOL"

FLAGAS"S"

FLAGCD"W"

NOFLAGMIG

NOFLAGSTD

FOLDCALLNAME"UPPER"

FOLDCOPYNAME"UPPER"

FORM"60"

FP-ROUNDING"ENTCOBOL"

HOSTNUMCOMPARE"2"

HOSTNUMMOVE"2"

NOIBM-MS

IBMCOMP

INDD

INFORETURN"0"

NOLIBRARIAN

LISTWIDTH"80"

MAPNAME

NOMF

NOMFCOMMENT

NOMS

NOMVS

ODOSLIDE

NOODOOSVS

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOPTIONAL-FILE

NOOS390

NOOSVS

OUTDD

NOPANVALET

NOPC1

PERFORM-TYPE"ENTCOBOL"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

RDW

RECMODE"ENTCOBOL"

REMAINDER"2"

RESEQ

NORM

RTNCODESIZE"2"

NOSAA

NOSEQCHK

SEQUENTIAL"RECORD"

SETTINGS"COL"

SOURCEFORMAT"FIXED"

NOSPZERO

STICKY-LINKAGE"2"

NOSTICKY-PERFORM

SYMBSTART"1"

NOTRACE

NOTRUNC

TRUNCCALLNAME"8"

TRUNCCOPY"8"

NOVSC2

WARNING"3"

NOXOPEN

NOXREF

ZEROLENGTHFALSE

NOZEROSEQ

ZWB

Parent topic: DIALECT


ISO2002 DIALECT setting

If you set DIALECT"ISO2002" the following Compiler directives are set:

ALIGN"8"

ALPHASTART"1"

ALTER

NOANS85

ARITHMETIC"MF"

NOBS2000

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"ASCII"

CHECKDIV"ANSI"

NOCOMS85

COPYEXT"cbl,CPY,"

COPYLBR

CURRENT-DATE"MMDDYY"

NODBCHECK

NODBCS

NODBCSSOSI

NODBSPACE

DE-EDIT"2"

DEFAULTBYTE"32"

NODG

DPC-IN-SUBSCRIPT

DYNAM

ECHO

NOENTCOBOL

NOEXTINDEX

NOFDCLEAR

FLAG"ISO2002"

NOFLAGAS

FLAGCD"W"

NOFLAGMIG

NOFLAGSTD

FOLDCALLNAME"UPPER"

FOLDCOPYNAME"UPPER"

NOHOSTNUMCOMPARE

NOHOSTNUMMOVE

NOIBM-MS

INFORETURN"U"

INTLEVEL"4"

IOCONV

ISO2002

NOLIBRARIAN

NOMAPNAME

NOMF

NOMFCOMMENT

NOMS

NOODOSLIDE

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOLDREADINTO

NOOLDSTRSUB

NOOPTIONAL-FILE

NOPC1

PERFORM-TYPE"MF"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

QUOTE

NORDW

RECMODE"F"

REMAINDER"1"

NORESEQ

NORM

NOSEQCHK

SOURCEFORMAT"FIXED"

NOSPZERO

NOSTICKY-LINKAGE

NOSTICKY-PERFORM

SYMBSTART"1"

TRUNC"ANSI"

NOTRUNCCOPY

WARNING"3"

NOXOPEN

ZEROLENGTHFALSE

NOZEROSEQ

NOZWB

Parent topic: DIALECT


MF DIALECT setting

If you set DIALECT"MF" the following Compiler directives are set:

NOADV

ALIGN"8"

ALPHASTART"1"

ALTER

ANS85

APOST

NOAREACHECK

ARITHMETIC"MF"

ASSIGN"DYNAMIC"

BOUND

NOBYTEMODEMOVE

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"ASCII"

CHECKDIV"ANSI"

NOCOBOL370

NOCOBSTATCONV

COMP5-BYTE-ORDER"NATIVE"

NOCOMS85

COPYEXT"cbl,CPY,"

NOCOPYLBR

COPYLIST

CURRENT-DATE"MMDDYY"

DATE

DBCHECK

DBCS"3"

NODBCSSOSI

DBSPACE

DE-EDIT"2"

DEFAULTBYTE"32"

NODG

NODOSVS

DYNAM

ECHO

NOENTCOBOL

NOEXTINDEX

NOFDCLEAR

NOFLAG

NOFLAGAS

NOFLAGCD

NOFLAGMIG

NOFLAGSTD

NOFOLDCALLNAME

NOFOLDCOPYNAME

FORM"60"

NOFP-ROUNDING

NOHOSTNUMCOMPARE

NOHOSTNUMMOVE

NOIBM-MS

NOIBMCOMP

NOINDD

INFORETURN"0"

NOLIBRARIAN

LISTWIDTH"80"

NOMAPNAME

MF

MFCOMMENT

NOMS

NOODOOSVS

NOODOSLIDE

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOLDREADINTO

NOOLDSTRSUB

OPTIONAL-FILE

NOOS390

NOOSVS

NOOUTDD

NOPANVALET

NOPC1

PERFORM-TYPE"MF"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

QUOTE

NORDW

RECMODE"F"

REMAINDER"1"

REPORTLINE"256"

RESEQ

NORM

RTNCODESIZE"4"

NOSAA

NOSEQCHK

SEQUENTIAL"RECORD"

SETTINGS

SOURCEFORMAT"FIXED"

NOSPZERO

NOSTICKY-LINKAGE

NOSTICKY-PERFORM

SYMBSTART"1"

NOTRACE

TRUNC"ANSI"

NOTRUNCCOPY

NOVSC2

WARNING"1"

NOXOPEN

NOXREF

NOZEROLENGTHFALSE

NOZEROSEQ

NOZWB
Parent topic: DIALECT


MVS DIALECT setting

If you set DIALECT"MVS" the following Compiler directives are set:

ADV

ALIGN"4"

ALPHASTART"1"

ALTER

ANS85

APOST

AREACHECK

ARITHMETIC"VSC2"

ASSIGN"EXTERNAL"

NOBOUND

BYTEMODEMOVE

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"EBCDIC"

CHECKDIV"COBOL370"

NOCOBOL370

COBSTATCONV

COMS85

COPYEXT"CPY,CBL"

COPYLBR

COPYLIST

CURRENT-DATE"MMDDYY"

DBCHECK

DBCS"3"

DBCSOSSI"14""15"

DBSPACE

DE-EDIT"2"

DEFAULTBYTE"00"

NODG

NODOSVS

DPC-IN-SUBSCRIPT

NODYNAM

ECHO

NOENTCOBOL

NOEXTINDEX

FCDCAT

FDCLEAR

FLAG"MVS"

FLAGAS"S"

FLAGCD"W"

NOFLAGMIG

NOFLAGSTD

FOLDCALLNAME"UPPER"

FOLDCOPYNAME"UPPER"

FORM"60"

FP-ROUNDING"VSC2"

HOSTNUMCOMPARE"2"

HOSTNUMMOVE"2"

IBMCOMP

NOIBM-MS

INDD

INFORETURN"0"

NOLIBRARIAN

LISTWIDTH"80"

MAPNAME

MVS

NOMF

NOMFCOMMENT

NOMS

NOODOOSVS

ODOSLIDE

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOPTIONAL-FILE

NOOS390

NOOSVS

OUTDD

NOPANVALET

NOPC1

PERFORM-TYPE"MVS"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

RDW

RECMODE"COB370"

REMAINDER"2"

RESEQ

NORM

RTNCODESIZE"2"

NOSAA

NOSEQCHK

SEQUENTIAL"RECORD"

SETTINGS"COL"

NOSTICKY-PERFORM

SOURCEFORMAT"FIXED"

NOSPZERO

STICKY-LINKAGE"2"

SYMBSTART"1"

NOTRACE

NOTRUNC

TRUNCCALLNAME"8"

TRUNCCOPY"8"

WARNING"3"

NOXOPEN

NOXREF

NOZEROSEQ

ZEROLENGTHFALSE

ZWB

Parent topic: DIALECT


OS390 DIALECT setting

If you set DIALECT"OS390" the following Compiler directives are set:

ADV

ALIGN"4"

ALPHASTART"1"

ALTER

ANS85

APOST

AREACHECK

ARITHMETIC"OS390"

ASSIGN"EXTERNAL"

NOBOUND

BYTEMODEMOVE

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"EBCDIC"

CHECKDIV"OS390"

NOCOBOL370

COBSTATCONV

COMS85

COMP5-BYTE-ORDER"NATIVE"

COPYEXT"CPY,CBL"

COPYLBR

COPYLIST

CURRENT-DATE"MMDDYY"

DBCHECK

DBCS"3"

DBCSOSSI"14""15"

DBSPACE

DE-EDIT"2"

DEFAULTBYTE"00"

NODG

NODOSVS

DPC-IN-SUBSCRIPT

ECHO

NOENTCOBOL

NOEXTINDEX

FCDCAT

FDCLEAR

FLAG"OS390"

FLAGAS"S"

FLAGCD"W"

NOFLAGMIG

NOFLAGSTD

FOLDCALLNAME"UPPER"

FOLDCOPYNAME"UPPER"

FORM"60"

FP-ROUNDING"OS390"

HOSTFD

HOSTNUMCOMPARE"2"

HOSTNUMMOVE"2"

IBMCOMP

NOIBM-MS

INDD

INFORETURN"0"

NOLIBRARIAN

LISTWIDTH"80"

MAPNAME

NODYNAM

NOMF

NOMFCOMMENT

NOMS

NOMVS

NOODOOSVS

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOPTIONAL-FILE

NOOSVS

ODOSLIDE

OUTDD

OS390

NOPANVALET

NOPC1

PERFORM-TYPE"OS390"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

RDW

RECMODE"OS390"

REMAINDER"2"

RESEQ

NORM

RTNCODESIZE"2"

NOSAA

NOSEQCHK

SEQUENTIAL"RECORD"

SETTINGS"COL"

SOURCEFORMAT"FIXED"

NOSPZERO

STICKY-LINKAGE"2"

NOSTICKY-PERFORM

SYMBSTART"1"

NOTRACE

NOTRUNC

TRUNCCALLNAME"8"

TRUNCCOPY"8"

NOVSC2

WARNING"3"

NOXOPEN

NOXREF

NOZEROSEQ

ZEROLENGTHFALSE

ZWB

Parent topic: DIALECT


OSVS DIALECT setting

If you set DIALECT"OSVS" the following Compiler directives are set:

NOADV

ALIGN"8"

ALPHASTART"1"

ALTER

NOANS85

APOST

AREACHECK

ARITHMETIC"OSVS"

ASSIGN"EXTERNAL"

NOBOUND

BYTEMODEMOVE

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"EBCDIC"

CHECKDIV"OSVS"

NOCOBOL370

NOCOMS85

COBSTATCONV

COPYEXT"CPY,CBL"

COPYLBR

COPYLIST

CURRENT-DATE"MMDDYY"

NODBCHECK

NODBCS

NODBCSSOSI

NODBSPACE

DE-EDIT"2"

DEFAULTBYTE"00"

NODG

NODOSVS

DPC-IN-SUBSCRIPT

NODYNAM

ECHO

NOENTCOBOL

NOEXTINDEX

FCDCAT

FDCLEAR

FLAG"OSVS"

FLAGAS"S"

FLAGCD"W"

NOFLAGMIG

NOFLAGSTD

FOLDCALLNAME"UPPER"

FOLDCOPYNAME"UPPER"

FORM"60"

FP-ROUNDING"OSVS"

HOSTNUMCOMPARE"2"

HOSTNUMMOVE"2"

IBMCOMP

NOIBM-MS

INDD

INFORETURN"0"

NOLIBRARIAN

LISTWIDTH"80"

MAPNAME

NOMF

NOMFCOMMENT

NOMS

NOMVS

ODOOSVS

ODOSLIDE

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOPTIONAL-FILE

NOOS390

OSVS

OUTDD

NOPANVALET

NOPC1

PERFORM-TYPE"OSVS"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

RDW

RECMODE"OSVS"

REMAINDER"2"

REPORTLINE"132"

RESEQ

NORM

RTNCODESIZE"2"

NOSAA

NOSEQCHK

SEQUENTIAL"RECORD"

SETTINGS"LINE"

SOURCEFORMAT"FIXED"

NOSPZERO

STICKY-LINKAGE

STICKY-PERFORM

SYMBSTART"1"

TRACE

NOTRUNC

TRUNCCALLNAME"8"

TRUNCCOPY"8"

NOVSC2

WARNING"3"

NOXOPEN

NOXREF

NOZEROLENGTHFALSE

NOZEROSEQ

ZWB

Parent topic: DIALECT


RM DIALECT setting

If you set DIALECT"RM", the following Compiler directives are set:

ALIGN(2)

COMP-6(1)

COPYSEARCH(RM)

PARAMCOUNTCHECK

OLDINDEX

NOOPTIONAL-FILE

RETRYLOCK

RM

SEQUENTIAL"LINE"

NOTRUNC

The following settings are also enabled:
  • The LOCKING clause of the SELECT statement is set to LOCK MODE IS AUTOMATIC for all file types.
  • Numeric data items are defined as SIGN TRAILING SEPARATE.
Parent topic: DIALECT


VSC21 and VSC22 DIALECT settings

If you set DIALECT"VSC21" or DIALECT"VSC22" the following Compiler directives are set:

NOADV

ALIGN"8"

ALPHASTART"1"

ALTER

NOANS85

APOST

AREACHECK

ARITHMETIC"VSC2"

ASSIGN"EXTERNAL"

NOBOUND

BYTEMODEMOVE

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"EBCDIC"

CHECKDIV"VSC2"

NOCOBOL370

COBSTATCONV

NOCOMS85

COPYEXT"CPY,CBL"

COPYLBR

COPYLIST

CURRENT-DATE"MMDDYY"

DBCHECK

DBCS"2"

DBCSSOSI"14""15"

DBSPACE

DE-EDIT"2"

DEFAULTBYTE"00"

NODG

NODOSVS

DPC-IN-SUBSCRIPT

NODYNAM

ECHO

NOENTCOBOL

NOEXTINDEX

FCDCAT

FDCLEAR

FLAG"VSC2"

FLAGAS"S"

FLAGCD"W"

NOFLAGMIG

NOFLAGSTD

FOLDCALLNAME"UPPER"

FOLDCOPYNAME"UPPER"

FORM"60"

FP-ROUNDING"VSC2"

HOSTNUMCOMPARE"2"

HOSTNUMMOVE"2"

IBMCOMP

NOIBM-MS

INDD

INFORETURN"0"

NOLIBRARIAN

LISTWIDTH"80"

MAPNAME

NOMF

NOMFCOMMENT

NOMS

NOMVS

ODOSLIDE

NOODOOSVS

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOPTIONAL-FILE

NOOS390

NOOSVS

OUTDD

NOPANVALET

NOPC1

PERFORM-TYPE"VSC2"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

RDW

RECMODE"OSVS"

REMAINDER"2"

RESEQ

NORM

RTNCODESIZE"2"

NOSAA

NOSEQCHK

SEQUENTIAL"RECORD"

SETTINGS"COL"

SOURCEFORMAT"FIXED"

NOSPZERO

STICKY-LINKAGE

STICKY-PERFORM

SYMBSTART"1"

NOTRACE

NOTRUNC

TRUNCCALLNAME"8"

TRUNCCOPY"8"

VSC2"1" (for VSC21), VSC2"2" (for VSC22)

WARNING"3"

NOXOPEN

NOXREF

ZEROLENGTHFALSE

NOZEROSEQ

ZWB

Parent topic: DIALECT


VSC23 and VSC24 DIALECT settings

If you set DIALECT"VSC23" or DIALECT"VSC24" the following Compiler directives are set:

NOADV

ALIGN"8"

ALPHASTART"1"

ALTER

ANS85

APOST

AREACHECK

ARITHMETIC"VSC2"

ASSIGN"EXTERNAL"

NOBOUND

BYTEMODEMOVE

CALLFH

CALLSORT"EXTSM"

CANCELLBR

CHARSET"EBCDIC"

CHECKDIV"VSC2"

NOCOBOL370

COBSTATCONV

COMS85

COPYEXT"CPY,CBL"

COPYLBR

COPYLIST

CURRENT-DATE"MMDDYY"

DBCHECK

DBCS"2"

DBCSSOSI"14""15"

DBSPACE

DE-EDIT"2"

DEFAULTBYTE"00"

NODG

NODOSVS

DPC-IN-SUBSCRIPT

NODYNAM

ECHO

NOENTCOBOL

NOEXTINDEX

FCDCAT

FDCLEAR

FLAG"VSC2"

FLAGAS"S"

FLAGCD"W"

NOFLAGMIG

NOFLAGSTD

FOLDCALLNAME"UPPER"

FOLDCOPYNAME"UPPER"

FORM"60"

FP-ROUNDING"VSC2"

HOSTNUMCOMPARE"2"

HOSTNUMMOVE"2"

NOIBM-MS

IBMCOMP

INDD

INFORETURN"0"

NOLIBRARIAN

LISTWIDTH"80"

MAPNAME

NOMF

NOMFCOMMENT

NOMS

NOMVS

NOODOOSVS

ODOSLIDE

NOOLDCOPY

NOOLDINDEX

NOOLDNEXTSENTENCE

NOOPTIONAL-FILE

NOOS390

NOOSVS

OUTDD

NOPANVALET

NOPC1

PERFORM-TYPE"VSC2"

NOPROGID-COMMENT

NOPROTECT-LINKAGE

QUAL

QUALPROC

RDW

RECMODE"VSC23"

REMAINDER"2"

RESEQ

NORM

RTNCODESIZE"2"

NOSAA

NOSEQCHK

SEQUENTIAL"RECORD"

SETTINGS"COL"

SOURCEFORMAT"FIXED"

NOSPZERO

STICKY-LINKAGE

NOSTICKY-PERFORM

SYMBSTART"1"

NOTRACE

NOTRUNC

TRUNCCOPY"8"

VSC2"3" (for VSC23)

VSC2"4" (for VSC24)

WARNING"3"

NOXOPEN

NOXREF

ZEROLENGTHFALSE

NOZEROSEQ

ZWB

Parent topic: DIALECT


ENTCOBOL

Specifies that words reserved in IBM Enterprise COBOL for z/OS and OS/390 are to be treated as reserved words..

Syntax:

 >>-.---.-.----.--ENTCOBOL-------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOENTCOBOL(Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

ENTCOBOL sets DBSPACE and DBCS"3" immediately.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Language Features - Dialect
Key to Compiler Directives


FLAG

Makes the Compiler produce language-level certification flags when it finds syntax that is not part of a specified dialect of COBOL.

Syntax:

>>-.---.-.-----FLAG-----"dialect"-.--------><
   +-/-+ +-NO--FLAG---------------+

Parameters:

dialect
A literal identifying the dialect.
ANS74 | ANSI COBOL standard X3.23, 1974
ANS85 | ANSI COBOL standard X3.23, 1985
BS2000 | Siemens BS2000 COBOL
COBOL370 | IBM COBOL/370
DOSVS | IBM DOS/VS COBOL
ENTCOBOL | IBM Enterprise COBOL
ISO2002 | ISO2002 COBOL standard
MVS | IBM MVS COBOL
MF | Micro Focus
OS390 | IBM OS390 COBOL
OSVS | IBM OS/VS COBOL
SAA | Full implementation of IBM's System Application Architecture definition of COBOL
VSC2 | IBM VS COBOL II

Properties:

Default: | NOFLAG (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

You cannot use DG, RM or MS as a dialect.

When creating a program that is to be fully ANSI'85 or ISO2002 conforming, use:

ANS85 FLAG"ANS85"

or

ISO2002 FLAG"ISO2002"

and correct anything that causes a flagging message to be produced.

Parent topic: Language Features - Dialect
Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List
Related concepts
Preprocessor Response Codes


FLAGCD

When used in conjunction with the FLAG directive, FLAGCD flags any directive settings that would cause incompatibility with the specified dialect of COBOL.

Syntax:

>>-.---.-.--------FLAGCD--"severity"-.-----><
   +-/-+ +.----.--FLAGCD-------------+
          +-NO-+

Parameters:

severity
A literal showing the severity to assign to flag messages arising from conflicting directives.
S
Severe error
E
Error
W
Warning
I
Informational

Properties:

Default: | NOFLAGCD (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

If FLAGCD is specified with no parameters, the messages are assigned the severity given by the FLAGAS directive, if specified; if FLAGAS is not specified, they are produced as flagging messages.

Parent topic: Language Features - Dialect
Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Compiler Control - Error & Flag Messages
Language Features - Dialect
FLAG
FLAGAS
Key to Compiler Directives


FLAGSTD

Makes the Compiler produce language-level certification flags when it finds syntax that is not part of a specified level of the ANSI'85 Standard.

Syntax:

>>-.---.-.-----FLAGSTD--"string"-.---------><
   +-/-+ +-NO--FLAGSTD-----------+

Parameters:

string List of language levels

Properties:

Default: | NOFLAGSTD (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

string contains a list of parameters, each defining a language level or optional module of the ANSI Standard. A feature is not flagged if it is in one of the specified levels or below, or in one of the specified optional modules. A feature is flagged if it is an extension, in a higher level of the Standard, or in an optional module not specified. In addition, it is possible to flag elements identified as Obsolete by the ANSI Standard.

string consists of a combination of the following parameters:

M | ANSI'85 defined Minimum COBOL subset
I | ANSI'85 defined Intermediate COBOL subset
H | ANSI'85 defined High COBOL subset
C1 | Communications optional module level 1
C2 | Communications optional module level 2
D1 | Debug optional module level 1
D2 | Debug optional module level 2
S1 | Segmentation optional module level 1
S2 | Segmentation optional module level 2
R | Report writer optional module
O | Obsolete language elements

They can appear in any order but must be separated by at least one space. The following combination of flags can be specified:

  • You must choose one of the following: M, I, H
  • You can choose as many of the following as desired: C1 or C2, D1 or D2, S1 or S2, R
  • You can also choose the following flag: O

FLAG and FLAGSTD provide similar functionality and thus only one can be used.

The ANS85 directive must be on.

Parent topic: Language Features - Dialect
Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


IBM-MS

Specifies that words reserved in IBM COBOL V1.00 are to be regarded as reserved words, and changes the behavior of certain features to be compatible with that COBOL system.

Syntax:

>>-.---.-.----.--IBM-MS--------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOIBM-MS (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

IBM-MS sets DEFAULTBYTE"0" and ACCEPTREFRESH immediately.

Comments:

This directive is synonymous with the PC1 and MS"1" directives.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


ISO2002

Specifies that words reserved in the ISO2002 COBOL Standard are to be treated as reserved words, and changes the behavior of certain features to be compatible with that standard.

Syntax:

>>-.----.-.----.---ISO2002-----------><
   +-/--+ +-NO-+

Parameters:

None

Properties:

Default: | NOISO2002 (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

For maximum compatibility with the ISO2002 standard, you should also set the DIALECT"ISO2002" directive.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


JAPANESE

Enables the use of Micro Focus Japanese Language Extension (PIC N, Japanese data-names and Japanese procedure-names).

Syntax:

>>-.---.-.---------JAPANESE--"integer"-.-----><
   +-/-+ +-.----.--JAPANESE------------+
           +-NO-+

Parameters:

integer
The level of support required.
1
Compatibility with previous versions of Nihongo Micro Focus products.
2
Enhanced PIC N support. This setting enables the DBSPACE directive.

Properties:

Default: | NOJAPANESE
Phase: | Syntax check
$SET: | Initial

Comments:

Specifying JAPANESE with no parameter is the same as specifying JAPANESE"2".

This directive is provided for compatibility purposes only. It has been replaced by the NCHAR directive. JAPANESE and NCHAR are synonymous. The JAPANESE and DBCS directives are mutually exclusive.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


MF, MFLEVEL

Facilitates forward compatibility with Micro Focus COBOL systems by selectively enabling Micro Focus-specific reserved words and changing the behavior of certain features to be compatible with particular versions.

Syntax:

>>-.---.-.-------.-MF------.-"integer"-.---><
   +-/-+ |       +-MFLEVEL-+           |
         +.----.-.-MF------.-----------+
          +-NO-+ +-MFLEVEL-+

Parameters:

integer
The level of Micro Focus COBOL to be compatible with:
1
  • Professional COBOL V1.0, V1.1, and V1.2
  • Level II COBOL V2.5 and V2.6
  • Level II COBOL/ET V1.1
2
  • VS COBOL Workbench V1.2
  • VS COBOL V1.2
3
  • VS COBOL Workbench V1.3
  • VS COBOL Workbench V2.0
  • Professional COBOL V2.0
  • VS COBOL V1.5
4
  • COBOL/2 V1.1
  • Professional COBOL/2
  • COBOL/2 Workbench V2.2
  • Microsoft COBOL V3.0
5
  • COBOL/2 V1.2
  • COBOL/2 Workbench V2.3
6
  • COBOL/2 V2.4
  • COBOL/2 Workbench V2.4
  • Microsoft COBOL V4.0
7
  • COBOL/2 V2.5
  • COBOL/2 Workbench V2.5
  • Microsoft COBOL V4.5
8
  • COBOL V3.0
  • COBOL Workbench V3.0
  • Microsoft COBOL V5.0
9
  • COBOL V3.1
  • COBOL Workbench V3.1
10
  • COBOL V3.1 with Early Release syntax enabled
  • COBOL Workbench V3.1 with Early Release syntax enabled
  • COBOL V3.2 and V3.3
  • COBOL Workbench V3.2 and V3.3
  • Object COBOL V3.2 and V3.3
  • COBOL V4.0 (UNIX)
11
  • Visual Object COBOL 1.0
  • COBOL V3.4 and V4.0 with Early Release syntax enabled
  • COBOL Workbench V3.4 and V4.0 with Early Release syntax enabled
12
  • Mainframe Express 3.0 and 3.1; Net Express 4.0, 5.0, and 5.1; and Server Express 4.0, 5.0, and 5.1
13
  • Net Express 5.1 WS2
14
  • Net Express 6.0
15
  • Net Express 6.0 SP1; Net Express 5.1 WS5
  • Visual COBOL R1
16
  • Visual COBOL R3 or later; Enterprise Developer 2.0

Properties:

Default: | MF"16" (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

MF"7" sets DBCS"2" immediately.

If integer > 7, sets DBCS"3" and DBSPACE immediately.

Comments:

Behavior of the BLANK LINE phrase in previous versions of this COBOL system can be implemented using the OLDBLANKLINE directive. Behavior of the NEXT SENTENCE phrase in previous versions of this COBOL system can be implemented using the OLDNEXTSENTENCE directive.

If MF"10" or lower is specified, data names are truncated to 30 characters, for compatibility with earlier versions.

MF"11" contains all reserved words that were enabled by the V3.2 and V3.3 MF-OO directive.

MF"12" contains all reserved words in MF"11" together with additional reserved words added at Mainframe Express 3.0, Net Express 4.0 and Server Express 4.0.

Parent topic: Language Features - Dialect
Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List
Related concepts
Preprocessor Response Codes
Related reference
Reserved Words
Related information
DIALECT
OLDBLANKLINE
OLDNEXTSENTENCE
Language Features - Dialect
Key to Compiler Directives


MS

Facilitates forward compatibility with Microsoft COBOL systems by selectively enabling Microsoft-specific reserved words and changing the behavior of certain features to be compatible with particular versions.

Syntax:

>>-.---.-.-------MS--"version"-.-----------><
   +-/-+ +.----.-MS------------+
          +-NO-+

Parameters:

version
The version:
1
Microsoft COBOL Version 1.
2
Microsoft COBOL Version 2.

Properties:

Default: | NOMS (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

MS sets DEFAULTBYTE"0" and ACCEPTREFRESH immediately.

Comments:

Specifying MS with no parameters is the same as specifying MS"2". MS"1" is identical to IBM-MS and PC1.

This directive is for compatibility with Microsoft COBOL before version 3.0. For compatibility with V3.0 and later, use:NOMS MF"integer"

The value of integer to use is shown in the description of the MF directive.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


NCHAR

Enables the use of Micro Focus Double-byte Language Extension (PIC N, Japanese data-names and Japanese procedure-names).

Syntax:

>>-.---.-.-------NCHAR--"integer"-.--------><
   +-/-+ +.----.-NCHAR------------+
          +-NO-+

Parameters:

integer
The level of support required.
1
Compatibility with previous versions of Nihongo Micro Focus products
2
Enhanced PIC N support. This setting enables the DBSPACE directive.

Properties:

Default: | NONCHAR
Phase: | Syntax check
$SET: | Initial

Comments:

Specifying NCHAR with no parameter is the same as specifying NCHAR"2".

This directive is synonymous with, and should be used in preference to, the JAPANESE directive.

The NCHAR and DBCS directives are mutually exclusive.

When a PIC X is moved to a PIC N, with NCHAR"2", a space (x"20") is expanded to one double-byte space, and so x"2020" is expanded to two double-byte spaces. With NCHAR"1", x"2020" is expanded to one double-byte space.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


NSYMBOL

Defines the default USAGE for PIC N clauses and controls the interpretation of national literals.

Syntax:

>>-.---.--NSYMBOL--"nsymbol-type"---------><
   +-/-+

Parameters:

nsymbol-type
The meaning of the N symbol. Possible values are:
DBCS
In a PIC N clause with no USAGE clause specified, the USAGE clause is DISPLAY-1, that is, the characters are DBCS characters

An N symbol prefixing a literal identifies a DBCS literal

NATIONAL
In a PIC N clause with no USAGE clause specified, the USAGE clause is NATIONAL, that is, the characters are Unicode characters

An N symbol prefixing a literal identifies a Unicode literal

Properties:

Default: | NSYMBOL"DBCS"
Phase: | Syntax check
$SET: | Yes
Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


OOCTRL

Enables you to change language options when compiling OO COBOL classes and interfaces.

Syntax:

                  +--------+
                  V        |
>>-.---.--OOCTRL--.-option-.-------------><
   +-/-+

Parameters:

+
Turns on an option.
-
Turns off an option.
option
Determines how syntax in OO programs is to be treated:
F | Specifies whether or not to fold method names invoked by the program being compiled to lower case. Use -F if your program calls Java methods, since Java method names are case-sensitive. See your Java and COBOL book for information on using Java and COBOL together.
G | Specifies whether to make class data global for instances. The use of this option is not recommended. It is provided for compatibility with earlier releases.
P | Specifies whether to make parameter type information available to the run-time system. This is needed for messages sent to COM. The number of parameters in any method called or declared is limited to 31, plus an optional return value.
Q Specifies whether to disable the use of:
  • IN and OF any place that could possibly follow a data name in the verb-signature of a method interface definition.
  • Any verb in the verb-signature of a method interface definition.
W | Specifies whether to use working storage to mean object storage in instances and factory (class) objects.

Properties:

Default: | OOCTRL(+F-G-P+Q+W)
Phase: | Syntax check
$SET: | Any

Comments:

When working storage is used to mean object storage, an Object-Storage Section must not be specified.

The +W setting provides compatibility with the ISO 2002 COBOL standard.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


OSVS

Specifies that words reserved in IBM OS/VS COBOL are to be treated as reserved words.

Syntax:

>>-.---.-.----.--OSVS------------------------><
   +-/-+ +-NO-+

Properties:

Default: | NOOSVS(Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

Set to OSVS immediately by DOSVS.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Language Features - Dialect
Key to Compiler Directives


PC1

Specifies that words reserved in IBM COBOL V1.00 are to be regarded as reserved words, and changes the behavior of certain features to be compatible with that COBOL system.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--PC1-----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOPC1 (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

PC1 sets DEFAULTBYTE"0" and ACCEPTREFRESH immediately.

Comments:

This directive is synonymous with the IBM-MS and MS"1" directives.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List


RM

Specifies that words reserved in RM/COBOL are to be regarded as reserved words, and changes the behavior of certain features to be compatible with that COBOL system.

Syntax:

>>-.---.-.-------RM--"parameter"-.--------------><
   +-/-+ +.----.-RM---------+
          +-NO-+

Parameters:

ANSI
Provides behavior as if you compile your RM/COBOL programs with the ANSI switch set.
BEEP
Stops the beep from sounding when the RM"ANSI" directive is set and you use the ACCEPT statement.

Properties:

Default: | NORM (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

RM sets COMP-6"1", SEQUENTIAL"LINE", NOTRUNC, OLDINDEX, NOOPTIONAL-FILE, RETRYLOCK and ALIGN"2" immediately.

RM also behaves as if the following syntax is set:

sign trailing separate

for signed numeric data items, and:

lock mode is automatic

for each file in the program which has no explicit locking syntax declared.

RM"ANSI" sets COMP-6"1", SEQUENTIAL"RECORD", NOTRUNC, OLDINDEX, NOOPTIONAL-FILE, RETRYLOCK and ALIGN"2" immediately.

RM"ANSI" also behaves as if the following syntax is set:

sign trailing included

for signed numeric data items, and:

lock mode is automatic

for each file in the program which has no explicit locking syntax declared.

NORM sets COMP-6"2", SEQUENTIAL"RECORD", TRUNC"ANSI", NOOLDINDEX, OPTIONAL-FILE, NORETRYLOCK and ALIGN"8" immediately.

Comments:

For the fullest RM/COBOL behavior available, set DIALECT"RM", which also sets this directive.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
COBOL Language Reference
Language Features - Dialect
Key to Compiler Directives


VSC2

Specifies that words reserved in IBM VS COBOL II are to be treated as reserved words, and enables selected features for compatibility with a given level of that COBOL system.

Syntax:

 >>-.---.-.-------VSC2--"integer"-.---------><
    +-/-+ +.----.-VSC2------------+
           +-NO-+

Parameters:

integer
The level of IBM VS COBOL II to be compatible with:
1
VS COBOL II release 1.0
2
  • VS COBOL II release 2.0
  • VS COBOL II release 3.x (when compiled with its CMPR2 directive)
  • VS COBOL II release 4.x (when compiled with its CMPR2 directive)
  • COBOL/370 V1R1 (when compiled with its CMPR2 directive)
3
VS COBOL II release 3.x (when compiled with its NOCMPR2 directive).
4
Synonymous with VS COBOL II release 4.x.

Properties:

Default: | NOVSC2 (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

If integer > 1, VSC2"integer" sets DBSPACE and DBCS"2" immediately. VSC2"3" sets ANS85 at end.

Comments:

1 VS COBOL II release 1.0 (Replaces the directives OLDVSC2 VSC2.)

No explicit scope delimiter is allowed in a statement without a conditional phrase (for example, AT END or ON SIZE ERROR).

The word ALSO in an EVALUATE statement must be omitted.

The CLASS and SYMBOLIC CHARACTERS clauses are not allowed.

Conditional phrases with NOT (for example NOT AT END, NOT ON SIZE ERROR) are not allowed.

2
  • VS COBOL II release 2.0
  • VS COBOL II release 3.x (when compiled with its CMPR2 directive)
  • VS COBOL II release 4.x (when compiled with its CMPR2 directive)
  • COBOL/370 V1R1 (when compiled with its CMPR2 directive)

The CLASS and SYMBOLIC CHARACTERS clauses are not allowed.

Conditional phrases with NOT (for example, NOT AT END, NOT ON SIZE ERROR) are not allowed.

When used with FLAG"VSC2" it provides similar functionality to VS COBOL II release 2.

3 VS COBOL II release 3.x (when compiled with its NOCMPR2 directive).

For complete compatibility in this instance, the directive REMOVE"FUNCTION" also should be specified. However, for upward compatibility, we recommend that you do not use FUNCTION as a user-defined word.

When used with FLAG"VSC2" it provides similar functionality to VS COBOL II release 3.

4 Synonymous with VS COBOL II release 4.x.

When VSC2 is specified without integer, VSC2"4" is assumed.

ANSI'85 status codes are used when VSC2"3" is selected.

Do not use the NOANS85 directive after VSC2"3"; it turns off some of the ANSI'85 behavior turned on by VSC2"3".

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Language Features - Dialect
Key to Compiler Directives


XOPEN

Specifies that words reserved under the X/Open definition of COBOL are to be treated as reserved words.

Syntax:

>>-.---.-.-------XOPEN--"level"-.----------><
   +-/-+ +.----.-XOPEN----------+
          +-NO-+

Parameters:

level
The level of X/Open definition COBOL to be compatible with:
3
Compatible with X/Open Portability Guide 1988 (XPG-3)
4
Compatible with X/Open CAE Specification (XPG-4)

Properties:

Default: | NOXOPEN (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

XOPEN sets RTNCODE-SIZE"4" immediately.

Comments:

Specifying XOPEN with no parameter is the same as specifying XOPEN"4". If you specify XOPEN"4", National Character Support is enabled using the DBCS"3" directive.

Parent topic: Language Features - Dialect
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
DBCS
RTNCODE-SIZE
Language Features - Dialect
Key to Compiler Directives


Language Features - Mainframe Compatibility

  • AREACHECK
    Causes the Compiler to treat any token which starts in area A in the Procedure Division as a paragraph or section label, regardless of the preceding tokens.
  • CMPR2
    Provides compatibility with the mainframe compiler option of the same name, which returns behavior of the COBOL 370, VS COBOL II version 3 and VS COBOL II version 4 compilers to that of the VS COBOL II version 2 compiler.
  • DBCSSOSI
    Defines the two characters used as the shift-out and shift-in delimiters in DBCS literals.
  • DIALECT
    Enables check-time and run-time behavior consistent with the specified dialect.
  • DPC-IN-SUBSCRIPT
    Turns on or off DECIMAL-POINT IS COMMA when processing subscripts.
  • IDENTIFIERLEN
    Specifies the portion of an identifier name that the compiler will consider to be significant.
  • LIBRARIAN
    Allows -INC statements in your program.
  • MAPNAME
    Makes the Compiler alter program-names and entry-point names to make them compatible with OS/VS COBOL, DOS/VS COBOL, VS COBOL II and COBOL/370.
  • PANVALET
    Allows ++INCLUDE statements in your program.
  • PROGID-COMMENT
    Allows comments following the PROGRAM-ID header in the Program-Id paragraph.
  • RDW
    Enables you to find out the length of a record that has just been read from a variable-length sequential file.
  • TRUNCCALLNAME
    Truncates subprogram names to a specified length.
  • TRUNCCOPY
    Specifies whether to truncate the names of copybooks.
  • TRUNCINC
    Specifies whether to truncate the names of ++INCLUDE files.
Parent topic: Language Features


AREACHECK

Causes the Compiler to treat any token which starts in area A in the Procedure Division as a paragraph or section label, regardless of the preceding tokens.

Syntax:

>>-.---.-.----.---AREACHECK------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOAREACHECK
Phase: | Syntax check
$SET: | Any

Comments:

If AREACHECK is not specified, only tokens which follow a period are treated as possible labels. This directive provides closer compatibility with mainframe error handling, where omitting a period before the label produces a less serious message. We recommend that such erroneous source code is corrected.

Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
Language Features - Mainframe Compatibility
Key to Compiler Directives


CMPR2

Provides compatibility with the mainframe compiler option of the same name, which returns behavior of the COBOL 370, VS COBOL II version 3 and VS COBOL II version 4 compilers to that of the VS COBOL II version 2 compiler.

Syntax:

 >>-.---.-.----.--CMPR2---------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOCMPR2
Phase: | Syntax check
$SET: | Initial

Dependencies:

Requires VSC2"3", VSC2"4" or COBOL370 flagging to be selected.

Comments:

A conflicting directives message is issued (with FLAGCD only) if one of the required flagging levels is not selected.

Setting this directive is not the same as setting VSC2"2". It emulates the mainframe behavior quite closely, and also causes different run-time behavior in some cases. If you use the CMPR2 directive on the mainframe with one of the specified compilers, use this directive instead of VSC2"2".

The FLAGMIG directive flags the items that give different run-time behavior.

Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


DPC-IN-SUBSCRIPT

Turns on or off DECIMAL-POINT IS COMMA when processing subscripts.

Syntax:

 >>-.---.-.----.--.-DPC-IN-SUBSCRIPT-.------------><
    +-/-+ +-NO-+  +--DPCINSUBSCRIPT--+

Parameters:

None

Properties:

Default: | NODPC-IN-SUBSCRIPT (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

This directive only has an effect if the DECIMAL-POINT IS COMMA clause is used.

Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


IDENTIFIERLEN

Specifies the portion of an identifier name that the compiler will consider to be significant.

Syntax:

>>-----IDENTIFIERLEN--"integer"------><

Parameters:

integer
The number of characters or bytes of an identifier name to use as a unique identifier. Valid values are:
30
Use the first 30 characters
31
Use the first 31 characters
62
Use the first 62 bytes
128
Use the first 128 bytes

Properties:

Default: | IDENTIFIERLEN"128"
Phase: | Syntax check
$SET: | Initial

Comments:

The internal space constraints of some multi-byte character sets mean that some integers are expressed in bytes, not characters. A character is considered to be an ASCII, UTF-16, or SHIFT-JIS/EUC character. If the identifiers are UTF-8 encoded, then integer indicates number of bytes.

Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


LIBRARIAN

Allows -INC statements in your program.

Syntax:

>>-.---.-.---------LIBRARIAN--"integer"-.-----><
   +-/-+ +-.----.--LIBRARIAN------------+
           +-NO-+

Parameters:

integer
The level of support required.
1
-INC statements are ignored; that is, no error message is generated.
2
-INC statements are processed.

Properties:

Default: | NOLIBRARIAN
Phase: | Syntax check
$SET: | Any

Comments:

The -INC statement specifies a file for inclusion in the source program. The string -INC must be written as a contiguous sequence of upper case characters starting in column 1, followed by one or more spaces, and then, on the same line, by the name of a file containing COBOL source. This file is included in the program at the point where the -INC statement appears.

If you set NOLIBRARIAN, -INC statements are not recognized; in this case, an error message is generated.

If you set LIBRARIAN without specifying integer, LIBRARIAN"2" is set.

Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


MAPNAME

Makes the Compiler alter program-names and entry-point names to make them compatible with OS/VS COBOL, DOS/VS COBOL, VS COBOL II and COBOL/370.

Syntax:

 >>-.---.-.----.--MAPNAME-------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOMAPNAME
Phase: | Syntax check
$SET: | Initial

Comments:

Specifying MAPNAME affects program-names and entry-point names defined in the compilation and those referenced by the program as follows:

  • ENTRY statements only in the outermost program
  • CALL literal, but not CALL identifier, statements
  • PROGRAM-ID entries in the outermost program, but not in nested programs

When a name is found to be incompatible a warning message is given and a modified name is used in the object program. The rules enforced and the modifications made are:

  • The first eight characters must be unique among program-names. The name is truncated to the first eight characters.
  • The first character must be alphabetic. If it is numeric it is changed as follows:
    0       becomes    J
1 - 9   become     A - I
  • Hyphen (-) is not allowed. If one appears it is changed to zero (0).
Parent topic: Language Features - Mainframe Compatibility
Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
Language Features - Mainframe Compatibility
Key to Compiler Directives


PANVALET

Allows ++INCLUDE statements in your program.

Syntax:

 >>-.---.------.----PANVALET--.-------------.-.--><
    +-/-+      |              +--"integer"--+ +
               +--NOPANVALET------------------+

Parameters:

integer
Must be either:
1
++INCLUDE statements are ignored; that is, no error message is generated.
2
++INCLUDE statements are processed.

Properties:

Default: | NOPANVALET.
Phase: | Syntax check
$SET: | Any

Comments:

The ++INCLUDE statement specifies a file for inclusion in the source program. The string ++INCLUDE must be written as a contiguous sequence of upper-case characters starting in Area A or Area B, followed by one or more spaces, and then, on the same line, by the name of a file containing COBOL source. This file is included in the program at the point where the ++INCLUDE statement appears.

If you set NOPANVALET, ++INCLUDE statements are not recognized; in this case, an error message is generated.

f you set PANVALET without specifying integer, PANVALET"2" is set.

If you specify PANVALET and LIBRARIAN together, a warning message is given advising that the compiled program might not be mainframe compatible.

Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
Language Features - Mainframe Compatibility
Key to Compiler Directives


PROGID-COMMENT

Allows comments following the PROGRAM-ID header in the Program-Id paragraph.

Syntax:

 >>-.---.-.----.--PROGID-COMMENT------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOPROGID-COMMENT
Phase: | Syntax check
$SET: | Initial

Comments:

This directive is provided for compatibility with earlier versions of this COBOL system.

Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


RDW

Enables you to find out the length of a record that has just been read from a variable-length sequential file.

Syntax:

 >>-.---.-.----.--RDW-----------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NORDW (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

If you specify the RDW directive, a four-byte record-length field is allocated immediately before the record area for the file. After a READ, the length (in binary) of the record just read is put in the first two bytes of this record area. The length returned includes the record-length field itself, so is four bytes longer than the actual record length.

You can access this field by defining the record area as a table, and using negative or zero subscripts

The RDW directive is intended only for mainframe compatibility; for new programs you should use the RECORD IS VARYING DEPENDING ON phrase of the FD statement.

Example:

 fd  file-1.
 01  rec-1           pic x(100).
 01  rec-2.
     03  rdw-table   pic x(4) occurs 25.
 Working-storage section.
 01  rdw-area.
     03  rec-length  pic 9(4) comp.
     03  filler      pic 9(4) comp.
 procedure division.
     ...
     read file-1
     move rdw-table (0) to rdw-area
     ...
Parent topic: Language Features - Mainframe Compatibility
Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Language Features - Mainframe Compatibility
Key to Compiler Directives


TRUNCCALLNAME

Truncates subprogram names to a specified length.

Syntax:

>>-.---.-.------TRUNCCALLNAME--"integer"--.------><
   +-/-+ +-NO---TRUNCCALLNAME-------------+

Parameters:

integer The length to which to truncate the name

Properties:

Default: | NOTRUNCCALLNAME
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to TRUNCCALLNAME"8" by DIALECT"ANS85", DIALECT"COB370", DIALECT"ENTCOBOL", DIALECT"MVS", DIALECT"OS390", DIALECT"OSVS", and DIALECT"VSC21".

Comments:

This directive truncates the name of a called subprogram to integer characters. Only literal or data names are truncated.

Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


TRUNCCOPY

Specifies whether to truncate the names of copybooks.

Syntax:

 >>-.---.-.----TRUNCCOPY--"integer"-.-------><
    +-/-+ +-NO-TRUNCCOPY------------+

Parameters:

integer
The number of characters to truncate the name of the copybook to. Value between 8 and 255 inclusive.

Properties:

Default: | NOTRUNCCOPY
Phase: | Syntax check
$SET: | Initial
Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
Language Features - Mainframe Compatibility
Key to Compiler Directives
TRUNCINC


TRUNCINC

Specifies whether to truncate the names of ++INCLUDE files.

Syntax:

 >>-.---.-.----TRUNCINC--"integer"-.-------><
    +-/-+ +-NO-TRUNCINC------------+

Parameters:

integer The number of characters to truncate the name of the ++INCLUDE to. Value between 8 and 255 inclusive.

Properties:

Default: | TRUNCINC"10"
Phase: | Syntax check
$SET: | Initial
Parent topic: Language Features - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


Language Features - Multi-threading

  • REENTRANT
    Controls reentrancy of a multithreading program. Any program that is to be reentrant in a multi-threaded application must be compiled with this directive. If REENTRANT is specified, many program areas are dynamically allocated, so that it is safe to have multiple copies of the program running.
  • SERIAL
    Specifies that the program is to be a serial program.
Parent topic: Language Features


REENTRANT

Controls reentrancy of a multithreading program. Any program that is to be reentrant in a multi-threaded application must be compiled with this directive. If REENTRANT is specified, many program areas are dynamically allocated, so that it is safe to have multiple copies of the program running.

Syntax:

>>-.---.-.-----REENTRANT---"n"--.-------><
   +-/-+ +-NO--REENTRANT--------+

Parameters:

n
One of:
1
All compiler-generated temporary work areas are allocated on a per thread basis. All user data and FD file areas allocated in the Environment and Data Divisions will be shared by all threads. It is the responsibility of the programmer to ensure serialization to the program's data by use of the CBL_ synchronization calls.
2
All user data and FD file areas allocated in the Environment and Data Divisions are allocated on a per thread basis. EXTERNAL data and files will always be shareable by all threads.

Properties:

Default: | NOREENTRANT
Phase: | Syntax check
$SET: | Initial

Comments:

Use REENTRANT"1" wherever possible for any program you wish to be reentrant. Use REENTRANT"2" only as the first step towards converting an existing program to be reentrant.

Note:
  • The Compiler rejects the REENTRANT directive if you use it with programs that use:
    • ALTER statements
    • Debug facility (SOURCE-COMPUTER... WITH DEBUGGING)
    • ON statements
    • Segmentation
    • Any of the following directives:
      • PROTECT-LINKAGE
      • STICKY-LINKAGE
      • STICKY-PERFORM
  • If you are using the PROGRAM-ID. … IS INITIAL statement, you cannot use REENTRANT”1”, and can only use REENTRANT “2” if the program does not contain nested programs.
  • Do not use the REENTRANT directive in a ThreadPool environment such as that used by ASP.NET. You must use the multiple run units model instead.
Parent topic: Language Features - Multi-threading
Parent topic: Compiler Directives - Alphabetical List
Related information
SERIAL
Language Features - Multi-threading
Key to Compiler Directives
Multiple User COBOL Applications in .NET
RunUnit Class


SERIAL

Specifies that the program is to be a serial program.

Syntax:

>>-.---.-.----.--SERIAL-----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOSERIAL
Phase: | Syntax check
$SET: | Initial

Comments:

If you specify this directive the run-time system determines whether the program is active in a thread and prevents any other thread entering the active program. This directive should be used on the first COBOL program to be executed on any given thread.

Note that the code to determine this takes time and is called on every program entry. Programs should be compiled with this directive only if they are going to run in a multi-threaded environment.

Parent topic: Language Features - Multi-threading
Parent topic: Compiler Directives - Alphabetical List


Language Features - Reserved Word Control

  • ADDRSV
    Adds one or more specific reserved words to the reserved word list so that they are recognized as reserved words in your program. The specified reserved words are added, whatever dialect directives are in force.
  • ADDSYN
    Defines a user-defined reserved word to be synonymous with an existing reserved word.
  • COBOL370
    Specifies that words reserved in IBM COBOL/370 are to be treated as reserved words, and allows features selectively for compatibility with a given level of that product.
  • DOSVS
    Specifies that words reserved in IBM DOS/VS COBOL are to be treated as reserved words.
  • MAKESYN
    Makes one reserved word synonymous with another.
  • MVS
    Specifies that words reserved in IBM COBOL for MVS are to be treated as reserved words.
  • OS390
    Specifies that words reserved in IBM COBOL for OS/390 R2V2 are to be treated as reserved words.
  • OVERRIDE
    Replaces a reserved word by a new one.
  • REMOVE
    Removes words from the reserved word list, so that they can be used as user-defined words.
  • SAA
    Specifies that words reserved under the Systems Application Architecture (SAA) definition of COBOL are to be treated as reserved words.
Parent topic: Language Features


ADDRSV

Adds one or more specific reserved words to the reserved word list so that they are recognized as reserved words in your program. The specified reserved words are added, whatever dialect directives are in force.

Syntax:

                   +------------+
                   V            |
>>--.---.--ADDRSV--.-"rsv-word"-.-----><
    +-/-+

Parameters:

rsv-word A reserved word in some dialects of COBOL, but not necessarily in a dialect specified for this compilation

Properties:

Default: | No additional reserved words are created.
Phase: | Syntax check
$SET: | Initial

Comments:

The specified reserved words are added, whatever dialect directives are in force.

This directive does not appear in the list created with the SETTING directive.

Parent topic: Language Features - Reserved Word Control
Parent topic: Compiler Directives - Alphabetical List


ADDSYN

Defines a user-defined reserved word to be synonymous with an existing reserved word.

Syntax:

>>-.---.--ADDSYN--"rsv-word" = "user-word"-><
   +-/-+

Parameters:

rsv-word
Existing reserved word.
user-word
Any COBOL word not the same as an existing reserved word.

Properties:

Default: | No reserved word synonyms are created.
Phase: | Syntax check
$SET: | Initial

Comments:

This directive does not appear in the list created with the SETTING directive.

The equals sign must be surrounded by spaces.

Parent topic: Language Features - Reserved Word Control
Parent topic: Compiler Directives - Alphabetical List


COBOL370

Specifies that words reserved in IBM COBOL/370 are to be treated as reserved words, and allows features selectively for compatibility with a given level of that product.

Syntax:

 >>-.---.-.-------COBOL370--"integer"-.-----><
    +-/-+ ++----+-COBOL370------------+
           +-NO-+

Parameters:

integer
The level of IBM COBOL/370 to be compatible with:
1
Specifies compatibility with Version 1 Release 1 of IBM COBOL/370
2
Specifies compatibility with Version 1 Release 2 of IBM COBOL for MVS and VM

Properties:

Default: | NOCOBOL370
Phase: | Syntax check
$SET: | Initial

Dependencies:

COBOL370 sets DBSPACE and DBCS"3" immediately.

Comments:

Specifying COBOL370 without a parameter is the same as specifying COBOL370"2".

Parent topic: Language Features - Reserved Word Control
Parent topic: Compiler Directives - Alphabetical List
Related information
Language Features - Dialect
Key to Compiler Directives


DOSVS

Specifies that words reserved in IBM DOS/VS COBOL are to be treated as reserved words.

Syntax:

 >>-.---.-.----.--DOSVS----------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NODOSVS (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to NODOSVS immediately by OSVS.

Parent topic: Language Features - Reserved Word Control
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Language Features - Dialect
Key to Compiler Directives


MAKESYN

Makes one reserved word synonymous with another.

Syntax:

>>-.---.-MAKESYN-"rsv-word-1" = "rsv-word-2"---><
   +-/-+

Parameters:

rsv-word-1
A reserved word.
rsv-word-2
The reserved word whose meaning is to be changed.

Properties:

Default: | No reserved word synonyms are created.
Phase: | Syntax check
$SET: | Initial

Comments:

The equals sign must be surrounded by spaces.

This directive does not appear in the list created with the SETTING directive.

Parent topic: Language Features - Reserved Word Control
Parent topic: Compiler Directives - Alphabetical List


MVS

Specifies that words reserved in IBM COBOL for MVS are to be treated as reserved words.

Syntax:

 >>-.---.-.----.--MVS-----><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOMVS(Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

MVS sets DBSPACE and DBCS"3" immediately.

Parent topic: Language Features - Reserved Word Control
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Language Features - Dialect
Key to Compiler Directives


OS390

Specifies that words reserved in IBM COBOL for OS/390 R2V2 are to be treated as reserved words.

Syntax:

 >>-.---.-.----.--OS390----><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOOS390(Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

OS390 sets DBSPACE and DBCS"3" immediately.

Parent topic: Language Features - Reserved Word Control
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Language Features - Dialect
Key to Compiler Directives


OVERRIDE

Replaces a reserved word by a new one.

Syntax:

                  +--------------------------+
                  V                          |
>>-.---.-OVERRIDE-.-"rsv-word" = "user-word"-.--><
   +-/-+

Parameters:

rsv-word
Existing reserved word.
user-word
Any COBOL word not the same as an existing reserved word.

Properties:

Default: | No change of reserved words takes place.
Phase: | Syntax check
$SET: | Initial

Comments:

This directive equates an existing reserved word to the specified user-defined word, so that, in the program, user-word is treated as a reserved word, and rsv-word can be used as a user-defined word.

The equals signs must be surrounded by spaces. If the parameters are repeated they must be separated by spaces.

This directive does not appear in the list created with the SETTING directive.

Parent topic: Language Features - Reserved Word Control
Parent topic: Compiler Directives - Alphabetical List


REMOVE

Removes words from the reserved word list, so that they can be used as user-defined words.

Syntax:

                 +-----------+
                 V           |
>>-.---.--REMOVE-.-"rsv-word".--------------><
   +-/-+

Parameters:

rsv-word A reserved word.

Properties:

Default: | No reserved words are removed.
Phase: | Syntax check
$SET: | Initial

Comments:

This directive does not appear in the list created with the SETTING directive.

Parent topic: Language Features - Reserved Word Control
Parent topic: Compiler Directives - Alphabetical List
Related reference
Reserved Words


SAA

Specifies that words reserved under the Systems Application Architecture (SAA) definition of COBOL are to be treated as reserved words.

Syntax:

 >>-.---.-.-------SAA--"level"-.------------><
    +-/-+ +.----.-SAA----------+
           +-NO-+

Parameters:

level
Must be one of:
1
SAA level 1 supported
2
SAA level 2 supported

Properties:

Default: | NOSAA
Phase: | Syntax check
$SET: | Any

Dependencies:

SAA sets DBSPACE and DBCS"2" immediately.

SAA"2" sets ANS85 at end.

Comments:

Specifying SAA with no parameters is the same as specifying SAA"2".

Parent topic: Language Features - Reserved Word Control
Parent topic: Compiler Directives - Alphabetical List


Language Features - Speed

  • ALTER
    Allows ALTER statements in your program.
  • FASTCALL
    Controls the behavior of a called program. If FASTCALL is specified, the program does not set up information to allow it to determine whether it is a main program. The program always assumes that it is not a main program, and EXIT PROGRAM will always cause an exit to the calling program.
  • FASTLINK
    Tells the Compiler that the parameters in the USING clauses of the Procedure Division statement and each ENTRY statement conform to certain restrictions. This enables it to produce faster code.
  • FIXOPT
    Changes the way in which generated code accesses the Data Division in object (.obj) code.
  • QUAL
    Allows qualified data-names and procedure-names in your program.
  • QUALPROC
    Allows qualified procedure-names in your program.
  • SEG
    Turns on COBOL segmentation.
  • TRICKLE
    Tells the Compiler that the program contains legal but unstructured perform-ranges, and that certain optimizations cannot, therefore, be made.
Parent topic: Language Features


ALTER

Allows ALTER statements in your program.

Syntax:

>>-.---.-.----.--ALTER---------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | ALTER (Dialect)
Phase: | Both
$SET: | Initial

Comments:

If you know there are no ALTER statements in your program, specifying NOALTER enables the Compiler to produce slightly more efficient code.

Parent topic: Language Features - Speed
Parent topic: Compiler Directives - Alphabetical List


FASTCALL

Controls the behavior of a called program. If FASTCALL is specified, the program does not set up information to allow it to determine whether it is a main program. The program always assumes that it is not a main program, and EXIT PROGRAM will always cause an exit to the calling program.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--FASTCALL------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOFASTCALL
Phase: | Generator
$SET: | Initial

Comments:

Programs compiled with FASTCALL do not set up the information that allows further called programs to determine whether they are main programs. Thus, any program called by a program compiled with FASTCALL should itself be compiled with FASTCALL.

Parent topic: Language Features - Speed
Parent topic: Object Code - Size and Speed
Parent topic: Compiler Directives - Alphabetical List


FASTLINK

Tells the Compiler that the parameters in the USING clauses of the Procedure Division statement and each ENTRY statement conform to certain restrictions. This enables it to produce faster code.
Restriction:

This directive is supported in native COBOL only.

This directive can be used with 32-bit x86 platforms only.

Syntax:

>>-.---.-.----.--FASTLINK------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOFASTLINK
Phase: | Generate
$SET: | Initial

Comments:

  • The parameters must be in the same order on every entry point. This order does not have to be the same order as the order in which they appear as 01-level items in the Linkage Section.
  • The program must be compiled with the NOFIXOPT and NOTYPECHECK Compiler directives
Parent topic: Language Features - Speed
Parent topic: Compiler Directives - Alphabetical List
Related information
Language Features - Speed
FIXOPT
Screen Section Entry Skeleton
The USING Clause
Procedure Division General Description
The PROCEDURE DIVISION Header
The CALL Statement
The CHAIN Statement
The ENTRY Statement
The INVOKE Statement
The MERGE Statement
The SORT Statement
The START Statement
The Class-ID Paragraph
The Interface-ID Paragraph
The SET Statement
ENTRY Statement Restrictions


FIXOPT

Changes the way in which generated code accesses the Data Division in object (.obj) code.
Restriction:

This directive is supported for native COBOL only.

This directive is supported for 32-bit x86 platforms only.

Syntax:

>>-.---.-.----.--FIXOPT-----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOFIXOPT
Phase: | Generate
$SET: | Initial

Comments:

FIXOPT is supported only on Intel x86 processors.

If you receive code generation error 78 ("Too many code relocations (limit=limit, actual=actual-relocations)") when creating object code, you must recompile specifying FIXOPT.

Parent topic: Language Features - Speed
Parent topic: Object Code - Size and Speed
Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List


QUAL

Allows qualified data-names and procedure-names in your program.

Syntax:

>>-.---.-.----.--QUAL----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | QUAL (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

If you have no qualified data-names or procedure-names in your source code, you can specify NOQUAL. This improves compilation speed.

Parent topic: Language Features - Speed
Parent topic: Compiler Directives - Alphabetical List


QUALPROC

Allows qualified procedure-names in your program.

Syntax:

>>-.---.-.----.--QUALPROC------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | QUALPROC (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

If you have no qualified procedure-names in your source code, you can specify NOQUALPROC. This improves compilation speed. If you have qualified data-names but no qualified procedure-names, you should specify QUAL and NOQUALPROC.

Parent topic: Language Features - Speed
Parent topic: Compiler Directives - Alphabetical List


SEG

Turns on COBOL segmentation.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--SEG-----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | SEG
Phase: | Syntax check
$SET: | Initial

Comments:

With NOSEG, the Compiler treats all section numbers in the code as if they were zero. This means that the Compiler ignores segmentation and creates one program with no overlays.

Parent topic: Language Features - Speed
Parent topic: Object Code - Size and Speed
Parent topic: Compiler Directives - Alphabetical List
Related information
Object Code - Size and Speed
Language Features - Speed
Key to Compiler Directives


TRICKLE

Tells the Compiler that the program contains legal but unstructured perform-ranges, and that certain optimizations cannot, therefore, be made.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--TRICKLE-------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | TRICKLE
Phase: | Generate
$SET: | Initial

Comments:

NOTRICKLE tells the Compiler that nowhere in the program could control "trickle" from one perform-range into another. Such a program has structured flow of control: it contains no paragraph or section that is entered both by being performed and by control falling into it from the preceding code, and none that is at the end of the range of one PERFORM and in the middle of the range of another PERFORM.

With NOTRICKLE, the Compiler can generate more efficient code for PERFORM statements.

Parent topic: Language Features - Speed
Parent topic: Compiler Directives - Alphabetical List


Language Features - Additional Features

  • CICSECM
    Causes EXEC CICS statements in your program to be replaced by CICS API run-time calls.
  • CONSTANT
    Declares a constant for use in the program.
  • DB2
    Causes EXEC SQL statements in your program to be replaced with DB2 LUW API calls.
  • FCDREG
    Makes the Compiler define special registers giving access to File Control Descriptions (FCD) and Key Definition Blocks.
  • PREPROCESS, P
    Makes the Compiler take the source program from a preprocessor instead of a source file.
  • REWRITE-LS
    Allows REWRITE statements on line sequential files.
  • SEQCHK
    Makes the Compiler check the sequence numbers in columns 1 through 6 and identify source lines that are out of sequence.
  • SOURCEFORMAT
    Selects free, fixed, variable, or terminal format for COBOL source.
  • LOCALSOURCEFORMAT
    Specifies that any setting of the SOURCEFORMAT directive in a source file is maintained for that file. This means that if a file with a different SOURCEFORMAT setting is copied into the source file, when processing exits the copied code, the SOURCEFORMAT setting returns to that originally specified in the source file.
  • SQL
    Causes EXEC SQL statements in your program to be replaced by ODBC or OCI run-time calls, depending on the options you specify.
  • XDB
    Causes EXEC SQL statements in your program to be replaced by XDB calls, depending on the options you specify.
Parent topic: Language Features


CICSECM

Causes EXEC CICS statements in your program to be replaced by CICS API run-time calls.
Restriction: This directive is supported in native COBOL only.

Syntax:

>>-.---.-.----CICSECM-.----------------------.-.><
   +-/-+ |            |   +-----.---.-----+  | |
         |            |   |     +-,-+     |  | |
         |            |   V               |  | |
         |            +-(.-option=setting-.)-+ |
         |                                     |
         +-NO-CICSECM--------------------------+

Parameters:

option
One of the CICSECM options (see below)
setting
The setting for the option

Properties:

Default: | NOCICSECM
Phase: | Syntax check
$SET: | No

Comments:

You normally set this directive by checking EXEC CICS in the Build Settings dialect box.

For more information on the CICS ECM directive options, see the help topic CICS Preprocessor Options.

Parent topic: Language Features - Additional Features
Parent topic: Compiler Directives - Alphabetical List
Related information
CICS Preprocessor Options
Language Features - Additional Features
Key to Compiler Directives


CONSTANT

Declares a constant for use in the program.

Syntax:

>>-.---.-CONSTANT-const-name-.-(numeric-lit)--.-><
   +-/-+                     +-"alphanum-lit"-+

Parameters:

const-name | Data-name. The constant's name.
numeric-lit | Numeric literal. The constant's value. Must be zero or a positive integer.
alphanum-lit | Alphanumeric literal. The constant's value.

Properties:

Default: | Not set
Phase: | Syntax check
$SET: | Any

Comments:

The effect is as if the constant const-name had been defined in the program in a level-78. Its value is that given in the parentheses or quotation marks. If parentheses are used, the constant is of category numeric; if quotation marks are used it is of category alphanumeric.

To declare several figurative constants using this feature, use the CONSTANT directive repeatedly.

Parent topic: Language Features - Additional Features
Parent topic: Compiler Directives - Alphabetical List
Related information
Conversion Tool


DB2

Causes EXEC SQL statements in your program to be replaced with DB2 LUW API calls.
Note: This directive is supported for native COBOL only.

Syntax:

 >>-.---.-.----DB2-.----------------------.-.--><
    +-/-+ |        |   +-----.---.-----.  | |
          |        |   |     +-,-+     |  | |
          |        |   v               |  | |
          |        +-(.-option=setting-.)-+ |
          |           |                |    |
          |           +-NO-option------+    |
          +-NO-DB2--------------------------+

Parameters:

option | One of the DB2 options.
setting | The setting for the option

Comment:

To avoid a compiler error with the DB2 directive you must have DB2 LUW Data Server Client installed.

Properties:

Default: | NODB2
Phase: | Syntax check
$SET: | Initial
Parent topic: Language Features - Additional Features
Parent topic: Compiler Directives - Alphabetical List
Related information
DB2 Compiler Directive Options
Language Features - Additional Features
Key to Compiler Directives


FCDREG

Makes the Compiler define special registers giving access to File Control Descriptions (FCD) and Key Definition Blocks.

Syntax:

>>-.---.-.----.--FCDREG--------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOFCDREG
Phase: | Syntax check
$SET: | Initial

Comments:

FCDREG causes a special register, FH--FCD, to be created for each File Definition (FD) in the program. This register points to the File Control Description (FCD) for the file. Thus the program can read or change information in the FCD.

For each indexed file, an additional special register, FH--KEYDEF, is created. This register points to the Key Definitions Block for the file.

Parent topic: Language Features - Additional Features
Parent topic: Compiler Directives - Alphabetical List
Related information
File Description Entry Skeleton
The File Control Entry
The I-O-Control Paragraph
The DELETE FILE Statement
The USE Statement
XML Syntax - SELECT Clause


PREPROCESS, P

Makes the Compiler take the source program from a preprocessor instead of a source file.

Syntax:

>>-.---.-.----.-PREPROCESS-.-"name".----------------..------..><
   +-/-+ |    +-P----------+       +-preproc-params-++-ENDP-+|
         +-NO-.-PREPROCESS-.---------------------------------+
              +-P----------+

Parameters:

name
The preprocessor to use.
preproc-params
Parameters to be passed directly to the preprocessor.

Properties:

Default: | NOPREPROCESS
Phase: | Syntax check
$SET: | On very first source line only
 | No (with NOPREPROCESS)

Comments:

This directive informs the Compiler that an integrated preprocessor is to be used.

A $SET statement is processed by both the Compiler and the preprocessor. Furthermore, if the PREPROCESS directive is set in a $SET statement, the directive only takes effect after the entire $SET statement has been processed. If the $SET statement contains other directives there might be incompatibilities when the preprocessor parses the source a second time. In particular, the SOURCEFORMAT directive might cause the Compiler to interpret the source as fixed format while the preprocessor might view it as free format, or vice-versa. If you specify the PREPROCESS Compiler directive in a $SET statement, you should, therefore, ensure that the $SET statement only contains the PREPROCESS directive. If you want to set other directives, use separate $SET statements on following lines.

You are advised to use the ENDP COBOL directive to terminate the directives to pass to the preprocessor. Directives placed after ENDP pass to the COBOL Compiler. Therefore, without the ENDP directive, Compiler directives might continue to pass to the preprocessor rather than to the COBOL compiler.

If you are sending directives to the COBSQL preprocessor, use END-C to distinguish the directives to pass to COBSQL and the directives to pass to the precompiler. For example, in the command line below directives placed before END-C pass to COBSQL while directives placed between END-C and ENDP pass via COBSQL to the precompiler:

preprocess(cobsql) cobsqltype=oracle end-c comp5=yes endp;
Parent topic: Language Features - Additional Features
Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List
Related information
Compiler Control - Compile/Link Files
Language Features - Additional Features
Key to Compiler Directives


REWRITE-LS

Allows REWRITE statements on line sequential files.

Syntax:

>>-.---.-.----.--REWRITE-LS----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | REWRITE-LS
Phase: | Syntax check
$SET: | No

Comments:

You must make sure that the record you write is the same size as the one it replaces.

Parent topic: Language Features - Additional Features
Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List


SEQCHK

Makes the Compiler check the sequence numbers in columns 1 through 6 and identify source lines that are out of sequence.

Syntax:

>>-.---.-.----.--SEQCHK--------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOSEQCHK (Dialect)
Phase: | Syntax check
$SET: | Any

Dependencies:

SEQCHK sets NORESEQ immediately.

Set to NOSEQCHK at end by SOURCEFORMAT"FREE".

Parent topic: Language Features - Additional Features
Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


SOURCEFORMAT

Selects free, fixed, variable, or terminal format for COBOL source.

Syntax:

>>-.---.--SOURCEFORMAT--"format-type"------><
   +-/-+

Parameters:

format-type
The format of COBOL source. One of:
  • FIXED
  • FREE
  • VARIABLE
  • TERMINAL

Properties:

Default: | SOURCEFORMAT"VARIABLE" (Dialect) for managed code and SOURCEFORMAT"FIXED" (Dialect) for native code
Phase: | Syntax check
$SET: | Any

Dependencies:

SOURCEFORMAT"FREE" sets NOMFCOMMENT, NORESEQ and NOSEQCHK at end.

SOURCEFORMAT"VARIABLE" is set by DIALECT(ENTCOBOL).

Comments:

The COBSQL preprocessor supports SOURCEFORMAT(FIXED) only.

Parent topic: Language Features - Additional Features
Parent topic: Compiler Directives - Alphabetical List
Related concepts
COBSQL
Related reference
Source Format
Related information
DIALECT
MFCOMMENT
RESEQ
SEQCHK
Key to Compiler Directives


LOCALSOURCEFORMAT

Specifies that any setting of the SOURCEFORMAT directive in a source file is maintained for that file. This means that if a file with a different SOURCEFORMAT setting is copied into the source file, when processing exits the copied code, the SOURCEFORMAT setting returns to that originally specified in the source file.

Syntax:

>>-.---.-.----.--LOCALSOURCEFORMAT-------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOLOCALSOURCEFORMAT
Phase: | Check
$SET: | Any
Parent topic: Language Features - Additional Features
Parent topic: Compiler Directives - Alphabetical List
Related information
Key to Compiler Directives
SOURCEFORMAT


SQL

Causes EXEC SQL statements in your program to be replaced by ODBC or OCI run-time calls, depending on the options you specify.

Syntax:

>>-.---.-.----SQL-.----------------------.-.><
   +-/-+ |        |   +-----.---.-----+  | |
         |        |   |     +-,-+     |  | |
         |        |   V               |  | |
         |        +-(.-option=setting-.)-+ |
         |           |                |    |
         |           +-NO-option------+    |
         +-NO-SQL--------------------------+

Parameters:

option
One of the SQL options listed in the topic SQL Compiler Directive Options
setting
The setting for the option

Properties:

Default: | NOSQL
Phase: | Syntax check
$SET: | Initial
Parent topic: Language Features - Additional Features
Parent topic: Compiler Directives - Alphabetical List
Related reference
Embedded SQL Statements
Related information
Language Features - Additional Features
Key to Compiler Directives


XDB

Causes EXEC SQL statements in your program to be replaced by XDB calls, depending on the options you specify.
Restriction:

This directive is supported in native COBOL only.

Syntax:

 >>-.---.-.----XDB-.----------------------.-.--><
    +-/-+ |        |   +-----.---.-----.  | |
          |        |   |     +-,-+     |  | |
          |        |   v               |  | |
          |        +-(.-option=setting-.)-+ |
          |           |                |    |
          |           +-NO-option------+    |
          +-NO-XDB--------------------------+

Parameters:

option | One of the XDB options listed in the topic XDB Directive Options.
setting | The setting for the option

Properties:

Default: | NOXDB
Phase: | Syntax check
$SET: | Initial
Parent topic: Language Features - Additional Features
Parent topic: Compiler Directives - Alphabetical List


Compiler Control

  • Compiler Control - Compile/Link Files
  • Compiler Control - Directives Control
  • Compiler Control - Error and Flag Messages
  • Compiler Control - Listing
  • Compiler Control - Screen
Parent topic: Compiler Directives


Compiler Control - Compile/Link Files

  • CANCELLBR
    Makes the Compiler close an .lbr file used as a library in a COPY statement once that copy operation is complete.
  • CONVSPACE
    Converts double-byte space characters in COBOL source files to single-byte spaces on input.
  • COPYLBR
    Makes the Compiler treat the library specified in a COPY statement as an .lbr file.
  • COPYPATH
    Specifies a list of directories for the Compiler to search for copy files.
  • DATA-CONTEXT
    Enables you to specify how a program's Data Division is to be maintained between CICS link levels.
  • IDYSRCPATH
    Controls the paths stored in .idy files for main source files.
  • IGNOREEXEC
    Specifies that procedural EXEC statements are to be treated as documentary only.
  • INT
    Specifies the name of the intermediate code file.
  • INTLEVEL
    When intermediate code is being created by the Compiler, this directive controls the level of portability of the code created to different versions of Micro Focus COBOL systems in other environments.
  • JVMGEN
    Generates Java bytecode.
  • KEYCHECK
    Specifies whether the File Handler checks that all the keys belonging to the indexed file you are opening are defined in your application.
  • OBJ
    Specifies the name and format of the object code file and generated code file.
  • OSEXT
    Tells the Compiler what extension to expect by default on the names of source files.
  • P64
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • PCOMP
    Enables you to specify a user program as a precompiler for COBOL files.
  • PREPROCESS, P
    Makes the Compiler take the source program from a preprocessor instead of a source file.
  • PROGID-INT-NAME
    Causes the name of the intermediate code file to be taken from the PROGRAM-ID clause, rather than the name of the source file.
  • PROTOTYPE
    Enables relaxed or strict checking of call prototypes for COMP, BINARY, COMP-4, COMP-5 and COMP-X data items when used in the BY VALUE or RETURNING clauses of a CALL statement. It also inhibits or enables the implicit copying of parameter types from the prototype.
  • RDFPATH
    Specifies a location for a repository file.
  • REPOSITORY
    Creates a repository file or requests that the program being compiled is checked against the repository file.
  • SOURCETABSTOP
    Sets the number of space characters by which to expand tab characters in the source code when it is parsed by the checker.
  • UNICODE
    Specifies the encoding to be used for Unicode characters.
Parent topic: Compiler Control


CANCELLBR

Makes the Compiler close an .lbr file used as a library in a COPY statement once that copy operation is complete.
Note: This Compiler directive is not intended for your use, and its setting should not be changed. It is included here for completeness, because it might appear in the list of settings.

Syntax:

>>-.---.-.----.--CANCELLBR-----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | CANCELLBR (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

NOCANCELLBR causes such .lbr files to be left open until the end of the compilation. Subsequent COPY statements that do not specify a library, search for the copybook in all open .lbr libraries (last one opened is searched first) before the current directory.

This directive is only relevant if COPYLBR is on.

[NO]CANCELLBR can be used on any $SET statement. Only .lbr libraries referenced in COPY statements after the $SET statement are affected. Any left open from previous COPY statements are only closed if specified again on a COPY statement following a CANCELLBR directive.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


CONVSPACE

Converts double-byte space characters in COBOL source files to single-byte spaces on input.

Syntax:

>>-.---.-.----.--CONVSPACE-----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | CONVSPACE
Phase: | Syntax check
$SET: | Initial

Comments:

CONVSPACE only has an effect when the DBSPACE Compiler directive is off.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


COPYLBR

Makes the Compiler treat the library specified in a COPY statement as an .lbr file.
Note: This Compiler directive is not intended for your use, and its setting should not be changed. It is included here for completeness, because it might appear in the list of settings.

Syntax:

>>-.---.-.----.--COPYLBR-------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOCOPYLBR (Dialect)
Phase: | Syntax check
$SET: | No

Comments:

With NOCOPYLBR, the Compiler assumes that the library is a path-name.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Compiler Control - Compile/Link Files
The COPY Statement
Key to Compiler Directives


COPYPATH

Specifies a list of directories for the Compiler to search for copy files.

Syntax:

>>----.--COPYPATH---"list-of-directories"--.--><
      +-----NOCOPYPATH---------------------+

Parameters:

list-of-directories The directories to search. Use semicolons to separate the directories. Use quotes to surround the path if it contains spaces.

Properties:

Default: | COPYPATH($COBCPY), which means use the COBCPY environment variable to search for copy files
IDE equivalent: | Click Project > Properties > Build and fill in Configuration Copybook Paths
Phase | Syntax check
$SET | None

Comments:

You should only use the COPYPATH directive when compiling using the cobol command line utility, and not when building programs from within the IDE.

When you use this directive, the Compiler does not search the COBCPY environment variable. Note that some of your COBOL development system's components rely on COBCPY being set to find copy files.

You cannot specify environment variables as a parameter for this directive.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


DATA-CONTEXT

Enables you to specify how a program's Data Division is to be maintained between CICS link levels.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.---------DATA-CONTEXT------><
   +-/-+ +-NO-+

Parameters:

None.

Properties:

Default: | NODATA-CONTEXT
Phase: | Syntax check
$SET: | Any

Comments:

If a program is compiled with DATA-CONTEXT and is invoked in link level 1 then invoked again in link level 2, its Data Division contents in link level 2 will be in an initial state. On return to link level 1, the program's Data Division contents will be the same as they were before link level 2 was invoked.

If a program is compiled with NODATA-CONTEXT and is invoked in link level 1 then invoked again in link level 2, its Data Division contents in link level 2 will be whatever the link level 1 invocation had set them to. On return to link level 1, the program's Data Division contents will be in whatever state link level 2 had left them.

You might need this directive when compiling programs for running in:

  • Mainframe Subsystem Support, available with your COBOL development system
  • IBM's TX Series on WebSphere
Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


IDYSRCPATH

Controls the paths stored in .idy files for main source files.
Note: This directive has been deprecated. It is provided for backward compatibility only and may be removed in later releases.

Syntax:

>>-.---.-.----IDYSRCPATH-(-.----------.-)---.-.><
   +-/-+ |                 +-src-path-+       |
         |                                    |
         +----NOIDYSRCPATH--------------------+

Parameters:

src-path The path to insert into .idy files to override the actual paths of main source files.

Properties:

Default: | NOIDYSRCPATH
Phase: | Syntax check
$SET: | No

Comments:

NOIDYSRCPATH causes the names of main source files to be stored in .idy files with their actual paths.

IDYSRCPATH(src-path) causes the names of main source files to be stored in .idy files with their actual paths replaced by src-path.

IDYSRCPATH() causes the names of main source files to be stored in .idy files with no paths.

Changing the main source file paths stored in .idy files enables you to compile files on one machine then move them to another machine and still have the debugger find all the files it needs. To do this you would also need to set the COBIDY directive.

Note: IDYSRCPATH only affects the paths used for main source files; it does not affect the paths used for copy books.
Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


IGNOREEXEC

Specifies that procedural EXEC statements are to be treated as documentary only.

Syntax:

>>-.---.-.----.--IGNOREEXEC------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOIGNOREEXEC
Phase: | Check
$SET: | Any
Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


INT

Specifies the name of the intermediate code file.
Note: This Compiler directive is not intended for your use, and its setting should not be changed. It is included here for completeness, because it might appear in the list of settings.

Syntax:

>>-.---.-.-----INT-.-"path-name\filename"--.-.--><
   +-/-+ |         +-"path-name/filename"--+ |
         |         +-"path-name\"----------+ |
         |         +-"path-name/"----------+ |
         |         +-"filename"------------+ |
         |         +-()--------------------+ |
         +-NO--INT---------------------------+

Parameters:

path-name | Path or environment variable specifying the path.
filename | A full file specification.

Properties:

Default: | INT"source-name.int"
Phase: | Syntax check
$SET: | No

Dependencies:

NOINT sets NOANIM immediately.

Comments:

When the INT() directive is implied because it is set by default, its behavior is to produce a temporary intermediate code file during the . This file is deleted when an .obj or .gnt file is successfully created. If you want to keep the .int file after the Compiler has produced the .obj or .gnt file, you need to explicitly set the INT() directive, and not rely on its being set by default.

Specifying NOINT prevents the intermediate code file being produced.

If you specify an existing file, it is overwritten.

If filename is not specified, the Compiler uses source-name.int, where source-name is the basename of the source filename. If you specify path-name but no filename, the Compiler uses the path-name, with the filename source-name.int attached.

INT() causes intermediate code to be put in the standard file source-name.int. With this format you must use parentheses not quotation marks. So, INT"" does not give this result.

Use the INT directive with caution. Incorrect use can abort the compilation process.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


INTLEVEL

When intermediate code is being created by the Compiler, this directive controls the level of portability of the code created to different versions of Micro Focus COBOL systems in other environments.
Note: This Compiler directive is not intended for your use, and its setting should not be changed. It is included here for completeness, because it might appear in the list of settings.

Syntax:

>>-.---.-.-------INTLEVEL--"integer"-.-----><
   +-/-+ +-----NOINTLEVEL------------+

Parameters:

integer
The level of portability. Can be 2, 4, 5, 6 or 7 where:
2
Base INTLEVEL support.
4
Enables long numeric support, that is, PIC clauses greater than PIC 9(18).
5
Reserved.
6
Reserved. Enables UNICODE support.
7
Reserved.

Properties:

Default: | INTLEVEL"2"
Phase: | Syntax check
$SET: | No

Dependencies:

Set to INTLEVEL"5" immediately by the Compiler directive P64.

Comments:

Full details of intermediate code portability are included with the relevant COBOL systems.

NOINTLEVEL causes intermediate code to be created that is suitable for execution only in this environment.

INTLEVEL"integer" creates intermediate code that can be executed by some versions of Micro Focus products in other environments. For portability between environments, the value of integer used for compilation must be supported by the Micro Focus COBOL system on each environment on which you want to execute the intermediate code.

INTLEVEL"integer" can limit the syntax that can be used in your program.

Use INTLEVEL"4" if you are compiling a program that is using syntax defined in the ISO2002 standard. INTLEVEL"4" is set by default if you set DIALECT"ISO2002".

If you are using the COBOL for OS/390 dialect and want to emulate the mainframe's ARITH"EXTEND" behavior (to enable the use of PIC 9 data items longer than 18 bytes, for example), you must set INTLEVEL"4".

You must explicitly set INTLEVEL"2" (and not rely on the default value) if you are creating an .int file that you want to port to COBOL for Workbench V3.4.

We recommend that you use only INTLEVEL"2" and INTLEVEL"4".

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


JVMGEN

Generates Java bytecode.
Restriction: This directive is supported for JVM COBOL only.

Syntax:

>>-.--JVMGEN-.-----.--.---><
   |         +-SUB-+  |
   +----NOJVMGEN------+

Parameters:

SUB
Indicates that a library is being compiled which doesn't require a main program entry point

Properties:

Default: | NOJVMGEN
IDE equivalent: | None. This directive is always used from the IDE.

Comments:

Instructs the compiler to generate Java bytecode. If a program doesn't require a main program entry point, use the SUB parameter.

This directive is not allowed in the $SET statement. You must specify JVMGEN on the command line.

Parent topic: Compiler Control - Compile/Link Files


KEYCHECK

Specifies whether the File Handler checks that all the keys belonging to the indexed file you are opening are defined in your application.

Syntax:

>>-.---.-.----.--KEYCHECK-------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | KEYCHECK
Phase: | Syntax check
$SET: | Any

Comments:

If you specify KEYCHECK, all key definitions must be specified and must match, otherwise a 3/9 error is returned. If you specify NOKEYCHECK, the File Handler opens the file without any checks on key definitions. If the file is opened with NOKEYCHECK set, and if one or more of the keys does not match, then any I/O operation that explicitly references a non-matching key (for example, a READ or START with the KEY phrase) will result in a 3/9 error.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List


OBJ

Specifies the name and format of the object code file and generated code file.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.-----OBJ-.-------------..--------><
   +-/-+ |         +-"filename"--+|
         +-NO--OBJ----------------+

Parameters:

filename A full file specification.

Properties:

Default: | OBJ"source-name.obj"
Phase: | Generate
$SET: | Any

Comments:

This directive creates a file in the format specified, with the name specified. For example, if you specify OBJ"myprog.obj", then a file myprog.obj is produced that contains object code.

With NOOBJ, no object code file is produced. If this directive is not specified, the name of the object code file is the basename of the source code file with an extension of .obj.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


OSEXT

Tells the Compiler what extension to expect by default on the names of source files.

Syntax:

>>-.---.--OSEXT--"ext"---------------------><
   +-/-+

Parameters:

ext The extension.

Properties:

Default: | OSEXT"cbl"
Phase: | Syntax check
$SET: | Any

Comments:

If the source filename used in the command or prompt does not have an extension or a trailing period the value in this directive is added.

Specifying a null extension (OSEXT"") indicates that the filename has no extension.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List
Related concepts
Compiler Directives
Compiling COBOL code


P64

This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.

Compiles a program for execution in a 64-bit run-time environment.

Syntax:

 >>-.---.-.----.--P64--------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOP64 on 32-bit systems or P64 if the 64-bit check box in the Build Settings dialog box is set.
IDE equivalent: | Click Project > Properties > COBOL > Platform Target .
Phase: | Syntax check
$SET: | Any

Dependencies:

P64 immediately sets: RTNCODE-SIZE"8", INTLEVEL"5" and FCD3

Comments:

If you set the P64 directive, your program is compiled to run under a 64-bit development environment, and to manipulate 64-bit pointers.

If you set the P64 directive, your program is compiled to use 64-bit pointers and has access to a 64-bit address space if you are executing on a 64-bit machine with an appropriate setting of the ILTARGET directive.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Reserved Directives
Parent topic: Compiler Directives - Alphabetical List


PCOMP

Enables you to specify a user program as a precompiler for COBOL files.

Syntax:

>>-.---.--PCOMP--"userprog"------><
   +-/-+

Parameters:

userprog The user program to be used as a precompiler..

Properties:

Default: None

Comments:

The user program should return an external filename.

If userprog is not found, the compilation fails.

The user program can use CBL_EXIT_PROC to perform some post-build processing.

Example:

working-storage section.
       01.
           05 install-flag       pic x comp-x.
           05 install-params.
               10 exit-proc-ptr  usage procedure-pointer.
               10                pic x.

       01 p-exit-block.
           03 p-block-size       pic x(4) comp-5 value 16.
           03 p-return-code      pic x(4) comp-5.
           03 p-rts-error        pic x(4) comp-5.
           03 p-exit-flags       pic x(4) comp-5.

       linkage section.
       01 source-file            pic x(256).

       procedure division using source-file.
           display source-file
      * On exit the file specified in source-file is the one
      * the compiler will actually compile
           move "EMPLOY.BMS" to source-file

           set exit-proc-ptr to entry "exitproc"
           move 0 to install-flag
           call "CBL_EXIT_PROC" using install-flag
                                       install-params
           end-call

      * Zero means continue, non-zero abort
    move 0 to return-code
           exit program
           .

       exitproc section.
       entry "exitproc".
           display "in exit proc"

           call "CBL_GET_EXIT_INFO" using     p-exit-block

           exit program
           .
Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


PROGID-INT-NAME

Causes the name of the intermediate code file to be taken from the PROGRAM-ID clause, rather than the name of the source file.
Note: This Compiler directive is not intended for your use, and its setting should not be changed. It is included here for completeness, because it might appear in the list of settings.

Syntax:

>>-.---.-.----.--PROGID-INT-NAME------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOPROGID-INT-NAME
Phase: | Syntax check
$SET: | Any
Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


PROTOTYPE

Enables relaxed or strict checking of call prototypes for COMP, BINARY, COMP-4, COMP-5 and COMP-X data items when used in the BY VALUE or RETURNING clauses of a CALL statement. It also inhibits or enables the implicit copying of parameter types from the prototype.

Syntax:

>>----.---.-----PROTOTYPE----"level"---------------------><
      +-/-+

Parameters:

level
One of:
RELAXED
Data items and parameter attributes are loosely checked against the prototype
NORMAL
Data items are strictly checked against the protoype, while parameter attributes are loosely checked
STRICT
Data items and parameter attributes are strictly checked against the proto

Properties:

Default: | PROTOTYPE"RELAXED
Phase: | Syntax check
$SET: | Any

Comments:

The PROTOTYPE directive gives you control over how calls to call prototypes are handled.

PROTOTYPE"RELAXED" can be particularly useful when you compile programs written on 32-bit systems that use call prototypes written on 64-bit systems.

By default, BY VALUE binary data-items are loosely type-checked (that is PROTOTYPE"RELAXED" is set). For example, a CALL statement can provide a PIC X(2) COMP data-item in its USING list, and that item can correspond to a PIC X(n) COMP data-item in a call prototype, where n can be from 1 to 4 on a 32-bit system, and 1 to 8 on a 64-bit system. If the value passed was larger than that specified for the receiving data item, truncation occurs. If you want to avoid truncation due to this loose type-checking, set PROTOTYPE"NORMAL"or PROTOTYPE"STRICT" when compiling your program.

If you set PROTOYPE"NORMAL" or PROTOTYPE"RELAXED", the attributes for the parameters of a call are copied from the prototype. If you set PROTOYPE"STRICT", this does not happen. For example, suppose you have the program:

program-id. prog1 is external.
entry call-conv "my_api" by value x1
                         by reference x2
end program prog1.

program-id. prog2.
call "my_api" by x1 x2

If you set PROTOYPE"NORMAL", the call to my_api is converted by the Compiler to:

call call-conv "my_api" by value x1
                        by reference x2

If you set PROTOTYPE"STRICT", the call to my_api is treated as if the parameters followed the normal rules. The call is therefore is converted to:

call "my_api" by reference x1
              by reference x2

and the Compiler issues appropriate error messages. Similarly, if the call convention does not match that specified in the prototype, or is not specified to the CALL statement, error messages are issued.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


RDFPATH

Specifies a location for a repository file.

Syntax:

>>-.---.--.----RDFPATH-"path"---.--------><
   +-/-+  +-NO-RDFPATH----------+

Parameters:

path The pathname in which the repository file is stored.

Properties:

Default: | NORDFPATH
Phase: | Syntax check
$SET: | Initial

Comments:

Repository files are searched for in the order:

  1. Source folder if NORDFPATH, or the path specified by RDFPATH
  2. The location specified by the COBCPY environment variable

Repository files are stored in the source folder if you specify NORDFPATH.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


REPOSITORY

Creates a repository file or requests that the program being compiled is checked against the repository file.

Syntax:

>>-.---.-------REPOSITORY--"option"------><
   +-/-+

Parameters:

option
One of:
UPDATE ON
A repository file is created for the class, program, function or interface being compiled.
UPDATE OFF
No repository file is created
CHECKING ON
A repository is used for conformance checking of parameters in CALL and INVOKE statements.
CHECKING OFF
No conformance checking takes place

Properties:

Default: | REPOSITORY "UPDATE OFF CHECKING OFF"
Phase: | Syntax check
$SET: | Initial

Comments:

The repository file is created in the directory specified by the RDFPATH directive.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


SOURCETABSTOP

Sets the number of space characters by which to expand tab characters in the source code when it is parsed by the checker.

Syntax:

>>-.---.--SOURCETABSTOP--"number"------><
   +-/-+

Parameters:

number A number between 1-255

Properties:

Default: | SOURCETABSTOP"8" (Dialect)
Phase: | Syntax check
$SET: | Initial

Visual Studio inserts tab characters when the tab key is pressed.

Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


UNICODE

Specifies the encoding to be used for Unicode characters.

Syntax:

>>-.---.--UNICODE--"unicode-type"---------><
   +-/-+

Parameters:

unicode-type
The encoding of Unicode characters. Possible values are:
NATIVE
A Unicode character is represented as the native UTF-16 encoding on the platform on which the program is being executed
PORTABLE
A Unicode character is represented as a big-endian UTF-16 encoding irrespective of the platform on which the program is being run

Properties:

Default: | UNICODE"NATIVE"
Phase: | Syntax check
$SET: | Yes
Parent topic: Compiler Control - Compile/Link Files
Parent topic: Compiler Directives - Alphabetical List


Compiler Control - Directives Control

  • COBOLDIR
    Specifies whether the Compiler should process the directives in a cobol.dir file or ignore it.
  • CONFIRM
    Makes the Compiler echo all subsequent directives to the screen.
  • DIALECT
    Enables check-time and run-time behavior consistent with the specified dialect.
  • DIRECTIVES, DIR
    Makes the Compiler read directives from a file.
  • DIRECTIVES-IN-COMMENTS
    Makes the Compiler process $SET statements held in comment lines.
  • SETTING, SETTINGS
    Makes the Compiler include in the source listing a list of the settings of directives.
  • SHOW-DIR
    Makes the Compiler show the contents of directives files in the source listing.
  • USE
    Makes the Compiler read directives from a file.
Parent topic: Compiler Control


COBOLDIR

Specifies whether the Compiler should process the directives in a cobol.dir file or ignore it.

Syntax:

>>-.---.-.----.--COBOLDIR------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOCOBOLDIR
Phase: | Syntax check
$SET: | No
Parent topic: Compiler Control - Directives Control
Parent topic: Compiler Directives - Alphabetical List


CONFIRM

Makes the Compiler echo all subsequent directives to the screen.

Syntax:

>>-.---.-.----.--CONFIRM-------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOCONFIRM
Phase: | Both
$SET: | No

Dependencies:

Set to CONFIRM immediately by VERBOSE.

Parent topic: Compiler Control - Directives Control
Parent topic: Compiler Control - Screen
Parent topic: Compiler Directives - Alphabetical List


DIRECTIVES, DIR

Makes the Compiler read directives from a file.

Syntax:

>>-.---.-.-DIRECTIVES-.-"filename"---------><
   +-/-+ +-DIR--------+

Parameters:

filename A full file specification of the directives file. This can be any valid filename except cobol.dir .

Properties:

Default: | None
Phase: | Syntax check
$SET: | Any

Comments:

A directives file is a text file containing directives. Directives are separated by a space or the end of line. A directive cannot be broken across two lines.

You can include a comment in the file by placing an ampersand (in column 1 of the comment line, followed by a space. If you omit the space the comment is treated as a directive, and the syntax check on that file fails.

The directives are read from the file until the end of file is reached or another DIRECTIVES directive is encountered. The maximum length of a line is 128 characters.

You can specify more than one directives file in a program by specifying DIRECTIVES"filename" several times. If you specify the DIRECTIVES directive in a directives file, the Compiler switches to the new directives file, reads all the directives in it, returns to the original directives file, and continues to read the directives specified after the DIRECTIVES directive. You can nest directives files to any depth.

The directives file is searched for in the current and COBOL system directories. If no extension is specified, a file extension of .dir is added before the search is made. If no file is found, the search is repeated with no extension.

Parent topic: Compiler Control - Directives Control
Parent topic: Compiler Directives - Alphabetical List


DIRECTIVES-IN-COMMENTS

Makes the Compiler process $SET statements held in comment lines.

Syntax:

>>-.---.-.----.--DIRECTIVES-IN-COMMENTS----><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NODIRECTIVES-IN-COMMENTS
Phase: | Syntax check
$SET: | Any

Comments:

This directive enables sources to contain directives used when compiling with the Micro Focus Compiler, but ignored (as comment lines) by any other compiler.

$SET can appear anywhere on a line, provided it is the first thing on the line. However, if this directive is set, the $SET statement is processed even if the line is a comment line (asterisk in column 7).

Parent topic: Compiler Control - Directives Control
Parent topic: Compiler Directives - Alphabetical List


SETTING, SETTINGS

Makes the Compiler include in the source listing a list of the settings of directives.

Syntax:

>>-.---.-.-------.-SETTING--.-.----------.-.-><
   +-/-+ |       +-SETTINGS-+ +-"format"-+ |
         +.----.-.-SETTING--.--------------+
          +-NO-+ +-SETTINGS-+

Parameters:

format
The layout of the listing. Only affects the listing given during the syntax check phase. One of:
LINE
Lines of directives, each separated from the next by a space.
COL
One directive per line.
COL3
Three directives per line in columns.

Properties:

Default: | NOSETTING (Dialect)
Phase: | Syntax check
$SET: | Any

Dependencies:

Set to NOSETTING by NOLIST at end.

Comments:

If format is not specified, LINE is assumed.

A few directives provided only for compatibility with other COBOL systems are not shown. Also not shown are directives that control code generation, make specific changes to the reserved word list, or are synonymous with other directives.

If the directive is specified other than on a $SET statement, the directives list is produced before processing the program source. If the directive is specified on a $SET statement, the list is produced once all the directives on that statement have been processed. In each case, the list contains the state of each directive at that point.

Parent topic: Compiler Control - Directives Control
Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
LIST
Compiler Control - Directives Control
Compiler Control - Listing
Key to Compiler Directives


SHOW-DIR

Makes the Compiler show the contents of directives files in the source listing.

Syntax:

>>-.---.-.----.--SHOW-DIR------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOSHOW-DIR
Phase: | Syntax check
$SET: | Any

Comments:

A directives file means a file that appears in a DIRECTIVES or USE directive.

You can use SHOW-DIR and NOSHOW-DIR selectively so that only parts of the directives file are output to the listing.

Parent topic: Compiler Control - Directives Control
Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


USE

Makes the Compiler read directives from a file.

Syntax:

>>-.---.--USE--"filename"------------------><
   +-/-+

Parameters:

filename A full file specification of the directives file. This can be any valid filename except cobol.dir .

Properties:

Default: | Not set
Phase: | Syntax check
$SET: | Any

Comments:

USE is synonymous with DIRECTIVES. All rules that apply to DIRECTIVES also apply to USE.

Parent topic: Compiler Control - Directives Control
Parent topic: Compiler Directives - Alphabetical List


Compiler Control - Error and Flag Messages

  • BRIEF
    Enables the Compiler to produce only error numbers, and no message texts.
  • CHANGE-MESSAGE
    Changes the severity of errors/messages. Messages can also be suppressed or returned to their original severity.
  • EDITOR
    Enables the Compiler to send error messages to a file in a format compatible with a specified editor.
  • ERRFORMAT
    Specifies the type of error message format to be used for command-line compilations and to appear in the list file.
  • ERRLIST
    Specifies the format of error messages in a list file.
  • ERRQ
    Enables the Compiler to prompt you to stop compiling each time it gives an error message.
  • FLAG
    Makes the Compiler produce language-level certification flags when it finds syntax that is not part of a specified dialect of COBOL.
  • FLAGAS
    Makes the Compiler output flagging messages as error messages, warning messages or informational messages.
  • FLAGCD
    When used in conjunction with the FLAG directive, FLAGCD flags any directive settings that would cause incompatibility with the specified dialect of COBOL.
  • FLAGEUC
    Flags occurences of SBCS (8-bit codes) and certain occurences of DBCS (16-bit codes) in the source code.
  • FLAGMIG
    Causes the Compiler to flag any syntax that behaves differently at run time depending on the setting of CMPR2.
  • FLAGQ
    Enables the Compiler prompt you to stop compiling each time it gives a flagging message.
  • FLAGSINEDIT
    Specifies whether flagging messages are to be included in an error file.
  • FLAGSTD
    Makes the Compiler produce language-level certification flags when it finds syntax that is not part of a specified level of the ANSI'85 Standard.
  • HIDE-MESSAGE
    Registers the number of a syntax check error message to "hide" so that if the error is encountered it is ignored.
  • IMPLICITSCOPE
    Enables the syntax checker to produce warning messages for cases where scope has been implicitly ended. This usually occurs where the scope terminator (END-VERB) could have been used.
  • INFORETURN
    Specifies the return-code value returned by the Compiler when it produces only informational messages.
  • MAX-ERROR
    Causes the Compiler to abort when the specified number of errors have been produced.
  • MOVE-LEN-CHECK
    Causes the Compiler to check source and target lengths for alphanumeric MOVE operations.
  • QUERY
    Each time the Compiler is unable to find a copybook, it prompts you for an action.
  • RESTRICT-GOTO
    Generates a syntax error for GO TO statements that transfer control to outside of the current section.
  • STDERR
    Causes error messages to be echoed to STDERR rather than to the console (STDOUT).
  • WARNING, WARNINGS
    Specifies the lowest severity level of errors to report.
Parent topic: Compiler Control


BRIEF

Enables the Compiler to produce only error numbers, and no message texts.

Syntax:

>>-.---.-.----.--BRIEF---------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOBRIEF
Phase: | Syntax check
$SET: | Any
Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


CHANGE-MESSAGE

Changes the severity of errors/messages. Messages can also be suppressed or returned to their original severity.

Syntax:

                              +---------------+
                              V               |
>>-.---.-.-----CHANGE-MESSAGE--"error svrty"--.-><
   +-/-+ +-NO--CHANGE-MESSAGE-----------------+

Parameters:

error Number of message to be changed or ALL meaning all messages.
svrty New severity:
S
Serious
E
Error
W
Warning
I
Informational
N
Do not produce this message
R
Reset to normal severity

Properties:

Default: | NOCHANGE-MESSAGE
Phase: | Syntax check
$SET: | Any

Dependencies:

CHANGE-MESSAGE overrides the general settings of directives such as FLAGAS.

Comments:

CHANGE-MESSAGE can take as many parameter pairs as required. If CHANGE-MESSAGE is specified multiple times the effects are cumulative.

CHANGE-MESSAGE replaces the HIDE-MESSAGE Compiler directive. However, if you use HIDE-MESSAGE in conjunction with CHANGE-MESSAGE the effects are also cumulative.

Serious errors cannot have their severity reduced unless they were changed to serious (from a lower severity) by another CHANGE-MESSAGE directive or the FLAGAS or FLAGCD directive.

Example:

CHANGE-MESSAGE"ALL R"
CHANGE-MESSAGE"10 S 135 E 100 N"
Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List
Related information
FLAGAS
FLAGCD
HIDE-MESSAGE
Compiler Control - Error & Flag Messages
Key to Compiler Directives


EDITOR

Enables the Compiler to send error messages to a file in a format compatible with a specified editor.

Syntax:

>>-.---.-.-----EDITOR--"editor-id"-.-------><
   +-/-+ +-NO--EDITOR--------------+

Parameters:

editor-id
One of:
MF
Micro Focus Editor
MF2
Micro Focus Animator V2
MS
Microsoft Programmer's Workbench

Properties:

Default: | NOEDITOR
Phase: | Syntax check
$SET: | No

Dependencies:

EDITOR"MS" sets NOENSUITE immediately.

EDITOR"MF" sets ENSUITE"1" immediately.

Comments:

You are recommended to use the NOECHO and NOQUERY directives in addition to the EDITOR directive.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


ERRFORMAT

Specifies the type of error message format to be used for command-line compilations and to appear in the list file.

Syntax:

>>---ERRFORMAT(integer)------><

Parameters:

integer
Can be one of two values:
1
Traditional format, which has been used for previous products
2
New 'COBCH' format, which is used for compilations from the IDEs

Properties:

Default: | ERRFORMAT(1)
Phase: | Syntax Check
$SET: | Any
Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List
Related information
ERRLIST
ERRQ


ERRLIST

Specifies the format of error messages in a list file.

Syntax:

>>-.---.-.------ERRLIST-------"option"----.-------><
   +-/-+ +----NOERRLIST-------------------+

Parameters:

option
A literal specifying the option required, as follows:
TERSE
Only lines containing errors are shown in the list file. Both source line and error are shown.
EMBED
The list file contains a source listing that has error messages embedded within it at the point they occur.
END
The list file contains a source listing, followed by a list of error messages. In a batch compile, no error messages are echoed to screen unless a screen listing is selected.
VERBOSE
The list file contains a source listing that has error messages embedded within it at the point they occur, followed by a separate listing of the error messages.

Properties:

Default: | ERRLIST"EMBED"
Phase: | Syntax check
$SET: | No

Dependencies:

If FLAGQ or ERRQ is set, ERRLIST"END" is switched to ERRLIST"VERBOSE".

Comments:

Mainframe compatible listings are obtained by using ERRLIST"END" for the majority of mainframe compilers. Particularly with a batch compile generating a list file, use of this directive has the following effects:

  • If the program contains errors, the only indication of this will be the message on screen:
    Compilation completed with errors
  • The list file will contain these errors in a block at the end. For each error the line and column will be shown along with the error number and description, and the description might be reformatted and split over several lines if it does not fit into the line as controlled by the LISTWIDTH directive.

Fatal errors cause the format to revert to ERRLIST(EMBED). These errors cause the syntax-check phase of the Compiler to terminate immediately. If ERRLIST(END) were still in force the errors would not be shown, as the end of the listing would not be reached.

If either the ERRQ or FLAGQ directives are set, then, to ensure these are actioned correctly, the Compiler will set ERRLIST(END) to ERRLIST(EMBED).

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


ERRQ

Enables the Compiler to prompt you to stop compiling each time it gives an error message.

Syntax:

>>-.---.-.----.--ERRQ----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOERRQ
Phase: | Syntax check
$SET: | Any

Comments:

This directive should not be used within the IDE.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


FLAGAS

Makes the Compiler output flagging messages as error messages, warning messages or informational messages.

Syntax:

>>-.---.-.-----FLAGAS--"severity"-.--------><
   +-/-+ +-NO--FLAGAS-------------+

Parameters:

severity
A literal showing the severity to assign to flag messages.
S
Severe error
E
Error
W
Warning
I
Informational

Properties:

Default: | NOFLAGAS (Dialect)
Phase: | Syntax check
$SET: | Any
Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Compiler Control - Error & Flag Messages
Key to Compiler Directives


FLAGEUC

Flags occurences of SBCS (8-bit codes) and certain occurences of DBCS (16-bit codes) in the source code.

Syntax:

>>-.---.-.----.-FLAGEUC----><
   +-/-+ +-NO-+

Parameters:

None.

Properties:

Default: | NOFLAGEUC
Phase: | Syntax check
$SET: | Any

Comments:

This directive adds 3 new flag messages.

  • 1090 Literal contains SBCS Katakana characters.

    Alphanumeric literals contain 8-bit Shift-JIS Hankaku Katakana characters which will expand into 16-bit codes on EUC.

  • 1091 Literal contains DBCS or SBCS Katakana characters.

    Hexadecimal literals contain either or both DBCS Shift-JIS or EUC characters.

  • 1092 SBCS Katakana character usage in source is not portable.

    Source code contains SHIFT-JIS Katakana characters which will not compile on the target machine due to codes expanding to two bytes and moving source code.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


FLAGMIG

Causes the Compiler to flag any syntax that behaves differently at run time depending on the setting of CMPR2.

Syntax:

 >>-.---.-.----.--FLAGMIG----------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOFLAGMIG
Phase: | Syntax check
$SET: | Any

Comments:

Such syntax receives W-level messages, with the additional text "MIGR" appearing in the message line to indicate that the warning results from specifying the FLAGMIG directive.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


FLAGQ

Enables the Compiler prompt you to stop compiling each time it gives a flagging message.

Syntax:

>>-.---.-.----.--FLAGQ---------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOFLAGQ
Phase: | Syntax check
$SET: | Any

Comments:

This directive should not be used within the IDE.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


FLAGSINEDIT

Specifies whether flagging messages are to be included in an error file.

Syntax:

>>-.---.-.----.--FLAGSINEDIT---------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | FLAGSINEDIT
Phase: | Both
$SET: | No

Comments:

This directive has no effect if NOEDITOR is specified. If EDITOR and FLAGSINEDIT are specified, the error file produced contains all flagging messages produced by the Compiler.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiling for Debugging and Analysis
Parent topic: Compiler Directives - Alphabetical List


HIDE-MESSAGE

Registers the number of a syntax check error message to "hide" so that if the error is encountered it is ignored.
Note: This directive has been replaced by the directive CHANGE-MESSAGE. It remains for compatibility only, and will be removed in a future release.

Syntax:

>>-.---.-.-----HIDE-MESSAGE--"integer"-----.----><
   +-/-+ |                                 |
         +-NO--HIDE-MESSAGE--.-----------.-+
                             +-"integer"-+

Parameters:

integer The number of the syntax check error message to hide.

Properties:

Default: | NOHIDE-MESSAGE
Phase: | Syntax check
$SET: | Any

Comments:

The Compiler also accepts the directive-name without a hyphen; that is HIDEMESSAGE.

HIDE-MESSAGE"integer" adds integer to a list of syntax check error message numbers. To hide several error message numbers using this feature, you must use the HIDE-MESSAGE directive repeatedly.

When the program is being syntax checked, any message with severity E, W, I, or flag with its number in the list is not shown in any listing. It is not included in the error summary at the end of the compilation.

Messages with severity S can be hidden only if they were made severity S by the CHANGE-MESSAGE, FLAGCD or FLAGAS directives. Normally, they are always shown, even if their number appears in this list.

NOHIDE-MESSAGE clears the list of numbers so no messages are hidden.

NOHIDE-MESSAGE"integer" removes only the specified message number from the list.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


IMPLICITSCOPE

Enables the syntax checker to produce warning messages for cases where scope has been implicitly ended. This usually occurs where the scope terminator (END-VERB) could have been used.

Certain syntax conditions end the scope of verbs automatically. This might not be what was intended. NOIMPLICITSCOPE causes the syntax checker to produce warning messages for cases where scope has been implicitly ended. This usually occurs where the scope terminator (END-VERB) could have been used.

Syntax:

>>-.---.--IMPLICITSCOPE------------><
   +-/-+

Parameters:

None

Properties:

Default: | IMPLICITSCOPE
Phase: | Syntax check
$SET: | Any

Dependencies:

None

Comments:

You will need to set WARNINGS(3) to make the messages appear.

Example:

IF ITEM-1 > 10
    MOVE 10 TO ITEM-2
    PERFORM ITEM-3 TIMES
        ADD 1 TO ITEM-3
ELSE
    IF ITEM-1 > 20
        MOVE 20 TO ITEM-2
    ELSE
        MOVE 0 TO ITEM-2.
    MOVE 4 TO ITEM-3

The ELSE ends the scope of the inline PERFORM, and the period ends the scope of all statements, which in this case is the two IF statements.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List
Related information
Concepts of the COBOL Language


INFORETURN

Specifies the return-code value returned by the Compiler when it produces only informational messages.

Syntax:

>>-.---.--INFORETURN--"integer"------------><
   +-/-+

Parameters:

integer Must be between 0 and 4.

Properties:

Default: | INFORETURN"0" (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

When the Compiler terminates it returns a value that can be tested by an operating system command to determine the success or otherwise of the compilation. This directive enables you to set the value to be returned if the Compiler only outputs informational messages.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List
Related reference
DIALECT
Related information
Compiler Control - Error & Flag Messages
Key to Compiler Directives


MAX-ERROR

Causes the Compiler to abort when the specified number of errors have been produced.

Syntax:

>>-.---.-.-----MAX-ERROR--"err-cnt -.-------.-"-.-><
   +-/-+ |                          +-svrty-+   |
         +-NOMAX-ERROR--------------------------+

Parameters:

err-cnt
The maximum number of errors
svrty
The minimum level of severity to be counted. Only messages of the severity specified and greater are counted. One of:
F
Flag
I
Informational
W
Warning
E
Error
S
Severe
If omitted, assumes F.

Properties:

Default: | NOMAX-ERROR
Phase: | Syntax check
$SET: | Any

Comments:

The Compiler also accepts the directive-name without a hyphen; that is MAXERROR.

If the maximum number of messages of at least the specified severity is reached then the compilation stops. The messages are only counted if produced and after any modification to the severity of the message.

Example:

Specifying the directive:

MAX-ERROR"100 E"

causes the compilation to terminate when 101 messages of severity E or S have been produced.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


MOVE-LEN-CHECK

Causes the Compiler to check source and target lengths for alphanumeric MOVE operations.

Syntax:

>>-.---.------.-MOVE-LEN-CHECK--.---------------.--.---><
   +-/-+      |                 +--"parameter"--+  |
              +-NOMOVE-LEN-CHECK-------------------+

Parameters:

parameter ALL or TRUNC

Properties:

Default: | NOMOVE-LEN-CHECK
Phase: | Syntax check
$SET: | Any

Comments:

This directive causes the compiler to check source and target lengths for alphanumeric MOVE operations and issues a warning message (166) if they are different.

If you do not specify a parameter, or if you set parameter to ALL, a warning message (166) is issued if the source and target lengths are different.

If you set parameter to TRUNC, a warning message (1247) is issued when the source length is greater than the target length.

Any warning messages produced by enabling this directive are only visible if WARNINGS"2" or WARNINGS"3" is selected.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


QUERY

Each time the Compiler is unable to find a copybook, it prompts you for an action.

Syntax:

>>-.---.-.----.--QUERY---------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | QUERY
Phase: | Syntax check
$SET: | Any

Comments:

With QUERY, if the Compiler cannot find a copybook, it asks you whether to terminate the compilation, try the search again, produce an error message and continue, or try again with an alternative path specified by you.

With NOQUERY, the Compiler simply produces an error message and continues.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


RESTRICT-GOTO

Generates a syntax error for GO TO statements that transfer control to outside of the current section.

Syntax:

 >>-.---.-.----.--RESTRICT-GOTO------><
    +-/-+ +-NO-+

Parameters:

None.

Properties:

Default: | NORESTRICT-GOTO
Phase: | Syntax check
$SET: | Any
Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List
Related reference
COBCH1259 GO TO target outside current section


STDERR

Causes error messages to be echoed to STDERR rather than to the console (STDOUT).

Syntax:

>>-.---.-.----.--STDERR--------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOSTDERR
Phase: | Syntax check
$SET: | Any

Comments:

This directive should only be used if you are compiling from the command line.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List


WARNING, WARNINGS

Specifies the lowest severity level of errors to report.

Syntax:

>>-.---.-.----.-WARNING--.-"integer"-.-----><
   +-/-+ |    +-WARNINGS-+           |
         +-NO-.-WARNING--.-----------+
              +-WARNINGS-+

Parameters:

integer
One of:
1
Only those of level U, S, or E.
2
Only those of level U, S, E, or W.
3
All levels, that is, levels U, S, E, W, and I.

Properties:

Default: | WARNING"1" (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

With NOWARNING only those of level U or S are reported.

Parent topic: Compiler Control - Error and Flag Messages
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
FLAGAS
FLAGCD
Compiler Control - Error & Flag Messages
Key to Compiler Directives


Compiler Control - Listing

  • COPYEXT
    Specifies the filename extension of the copybook that the Compiler is to look for if a filename in a COPY statement is specified without an extension.
  • COPYLIST
    Makes the Compiler list the contents of files named in COPY statements.
  • COPYLISTCOMMENT
    Specifies the type of comment to be used on COPY statements in .lst files when the COPYLIST directive is specified.
  • DATAMAP
    Causes the Compiler to output information on data items.
  • DATE
    Puts the date in the Date-Compiled paragraph and at the top of each page of the listing.
  • ERRLIST
    Specifies the format of error messages in a list file.
  • FORM
    Specifies the number of lines on each page of the listing.
  • LINE-COUNT
    Controls the detail of information displayed at the end of a source listing.
  • LIST
    Specifies the destination of the source listing file.
  • LISTPATH
    Specifies a path on which the list file is to be written. The name of the list file is source-name.lst.
  • LISTWIDTH, LW
    Sets the width of the listing.
  • MFCOMMENT
    Treats lines with an asterisk (*) in column 1 the same as comment lines but does not show them in the source listing.
  • PREPLIST
    Causes the list file produced during a compilation to show both the original and modified source created by the preprocessor as well as to show all data passed to the Compiler by a preprocessor.
  • PRINT
    Specifies the destination of the source listing file.
  • RAWLIST
    Prevents changeable information, such as page headers, date, time, Compiler release level, from being included in any listing file produced.
  • REF
    Makes the Compiler include in the source listing the intermediate code address of each Procedure Division statement.
  • REFNO
    Makes the Compiler display its internal reference number at the start of a compilation as well as at the bottom of every listing.
  • RESEQ
    Makes the Compiler produce line numbers.
  • SEQCHK
    Makes the Compiler check the sequence numbers in columns 1 through 6 and identify source lines that are out of sequence.
  • SETTING, SETTINGS
    Makes the Compiler include in the source listing a list of the settings of directives.
  • SHOW-DIR
    Makes the Compiler show the contents of directives files in the source listing.
  • SOURCEASM
    Makes the Compiler include source code statements in the assembler listing.
  • TIME
    Puts the time at the top of each page of the listing.
  • VERBOSE
    Sends messages from the Compiler to the screen.
  • XREF
    Makes the Compiler produce a cross-reference listing.
  • ZEROSEQ
    Causes leading zeros to appear in the sequence numbers in columns 1 through 6.
Parent topic: Compiler Control


COPYEXT

Specifies the filename extension of the copybook that the Compiler is to look for if a filename in a COPY statement is specified without an extension.

Syntax:

                             +---------------+
                             V               |
>>-.---.--COPYEXT-"extension--.-------------.--"--><
   +-/-+                      +-,-extension-+

Parameters:

extension A filename extension.

Properties:

Default: | COPYEXT"cbl,CPY"
Phase: | Syntax check
$SET: | Initial

Comments:

Up to eight extensions can be specified, each extension being up to 10 characters long. A null extension is used to represent an extension of spaces; for example:

COPYEXT"src,,txt"
COPYEXT"cpy,cbl,cob,abc,"

If the filename specified in a COPY statement has no extension or trailing period then the list of possible extensions is tried in turn until a file is sucessfully found or the list is exhausted (and an error reported).

If you have many COPY statements that do not specify an extension, using COPYEXT can improve the compilation speed of your program. For example, if all of your copybooks have the filename extension .cpy, specifying COPYEXT"CPY,CBL" would avoid unnecessary file access attempts.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


COPYLIST

Makes the Compiler list the contents of files named in COPY statements.

Syntax:

>>-.---.-.----.--COPYLIST-.-----------.----><
   +-/-+ +-NO-+           +-"integer"-+
                          +---"ALL"---+

Parameters:

integer Must be 0 or between 50 and 99.

Properties:

Default: | COPYLIST
Phase: | Syntax check
$SET: | Any

Comments:

integer is the number of a COBOL segment. It must be 0 or in the range 50 through 99. If it is not specified, the contents of all copybooks are listed. If it is specified, the contents of all copybooks in the first three divisions (that is, the Identification, Environment and Data Divisions), the root, and the given segment are listed. An integer of 0 refers to the first three divisions and all root segments.

COPYLIST "ALL" causes all copybook contents to be listed, including those that have the SUPPRESS clause on the COPY statement in the source.

NOCOPYLIST prevents the listing of the contents of any copybooks. If a segment-number is specified with NOCOPYLIST, only copybooks in that segment are listed. For example:

COPYLIST"53" | List all copybooks in the first three divisions, the root segment, and segment 53.
NOCOPYLIST"53" | List only copybooks that are in segment 53.

Whatever the state of this directive, the name of any copybook open when a page heading is output is given in that heading.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


COPYLISTCOMMENT

Specifies the type of comment to be used on COPY statements in .lst files when the COPYLIST directive is specified.

Syntax:

>>-----COPYLISTCOMMENT-"integer"---><

Parameters:

integer
The type of comment used. The possible values are:
1
Specifies an MFCOMMENT with the asterisk in column 1
7
Specifies a standard comment with the asterisk in column 7

Properties:

Default: | COPYLISTCOMMENT(1)
Phase: | Syntax check
$SET: | Any

Dependencies:

This directive has no effect unless the COPYLIST directive is on.

Comments:

This directive controls whether the MFCOMMENT directive is required when recompiling the .lst file.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


DATAMAP

Causes the Compiler to output information on data items.

Syntax:

>>-.---.-.----.---DATAMAP------><
   +-/-+ +-NO-+

Parameters:

None.

Properties:

Default: | NODATAMAP
Phase: | Syntax check
$SET: | Initial

Dependencies:

None.

Comments:

This directive causes the check phase of the Compiler to output information on the data items; both those that you have specified, and those automatically generated by the Compiler, such as the data area for the RETURN-CODE special register.

The information is output at the end of the list file. The information on the data items is output in the same order as the items are encountered in your program by the Compiler. The first line is the program-id of the program to which the data items belong. For each data item, the following information is listed:

  • The line number
  • The data name
  • The address of the data item, that is the offset from the beginning of the program's data area
  • The size of the data item in bytes
  • The attributes of the data item. This consists of a string in the following format:

    ss xxxx cccccccccc R E G

    where the variables are:

    ss
    Location of data item. This can be:
    IO | Input-Output Section
    FD | File Description
    WS | Working-Storage Section
    TL | Thread-Local-Storage Section
    OS | Object-Storage Section
    LC | Local-Storage Section
    LS | Linkage Section
    RD | Report Section
    SS | Screen Section
    PG | Variables, such as special registers, generated by the Compiler check phase
    PD | Temporary variables, such as those used in search statements, generated by the Procedure Division
    xxxx
    Can be:
    G | Group item
    GO | Group occurs item
    GSO | Group sub occurs item
    E | Elementary item
    EO | Elementary occurs item
    ESO | Elementary sub occurs item
    ESOO | Elementary sub occurs occurs item
    cccccccccc
    A description of the data type; for example, Display, Comp, Comp-3, Numeric E (for Numeric Edited), AlphNum J (for AlphaNumeric Justified), and so on
    R
    The item is a Redefinition of some other data item
    E
    The data item is an External data item
    G
    The data item is a Global data item
Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


DATE

Puts the date in the Date-Compiled paragraph and at the top of each page of the listing.

Syntax:

>>-.---.-.-------DATE--"string"-.----------><
   +-/-+ +.----.-DATE-----------+
          +-NO-+

Parameters:

string An alphanumeric literal.

Properties:

Default: | DATE
Phase: | Syntax check
$SET: | No

Comments:

The date and time, available from the operating system, are automatically inserted when you specify DATE. You can, however, enter the date yourself as the parameter. With NODATE, the paragraph is left unaltered.

With DATE, the operating system date or the string you enter appears at the top of each page of the listing. With NODATE, spaces are used instead.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


FORM

Specifies the number of lines on each page of the listing.

Syntax:

>>-.---.-.-----FORM--"integer"-.-----------><
   +-/-+ +-NO--FORM------------+

Parameters:

integer Must be greater than 3.

Properties:

Default: | FORM"60"
Phase: | Syntax check
$SET: | Any

Dependencies:

Set to NOFORM at end by NOLIST.

Set to FORM"60" immediately by LIST.

Comments:

With FORM"integer", a form-feed character is always produced at the head of the listing file. With NOFORM, no form-feed characters or page headings are produced anywhere in the listing.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


LINE-COUNT

Controls the detail of information displayed at the end of a source listing.

Syntax:

>>-.---.-.-------LINE-COUNT--"integer"-.----><
   +-/-+ +.----.-LINE-COUNT------------+
          +-NO-+

Parameters:

integer
Controls the detail displayed:
1
The number of source lines checked, excluding blank lines and comments, is displayed at the end of the source listing.
2
As well as number of source lines checked, many additional details are displayed at the end of the source listing. These include the number of calls, number of sections and number of conditions in the program.

Properties:

Default: | NOLINE-COUNT
Phase: | Syntax check
$SET: | Initial

Dependencies:

LINE-COUNT"2" sets ANIM immediately.

Comments:

Specifying LINE-COUNT with no integer is the same as specifying LINE-COUNT"2".

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


LIST

Specifies the destination of the source listing file.

Syntax:

>>-.---.-.-------LIST-.-"Destination"-..---><
   +-/-+ |            +-()------------+|
         +.----.-LIST------------------+
          +-NO-+

Parameters:

destination
A full file specification or a device-name.

Properties:

Default: | NOLIST
Phase: | Syntax check
$SET: | Any (for LIST and NOLIST)
 | None (for LIST"filename" and LIST())

Dependencies:

NOLIST sets NOFORM, NOSETTING and NOXREF at end.

LIST sets FORM"60" immediately.

Comments:

If you specify an existing file, it is overwritten.

When NOLIST is specified, no source listing is produced. If you specify LIST with no destination, the source listing is sent to the screen. If you specify either destination or (), you cannot use this directive in a $SET statement.

destination can be the name of any suitable device. Use CON: for the screen.

NOLIST and LIST with no parameter can be used in $SET statements in a program to list selected parts of the program. The destination of the listing cannot be changed in this way.

LIST() causes the source listing to be put in the file source-name.lst, where source-name is the basename of the filename of the program being compiled.

If you want to list the source to a file for every compilation you do, place the LIST() directive in the cobol.dir file. This overrides the default NOLIST.

Alternatively, if you already have a LIST directive in your cobol.dir, making every listing go to the screen, you can override it by using LIST() on the command line.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List
Related information
Compiler Control - Listing
FORM
SETTING, SETTINGS
XREF
Key to Compiler Directives


LISTPATH

Specifies a path on which the list file is to be written. The name of the list file is source-name.lst.

Syntax:

>>-.---.---.--LISTPATH--"list-path"--.--><
   +-/-+   +---NOLISTPATH------------+

Parameters:

list-path Path to which the list file is written, or an environment variable specifying the path to which the list file is written.

Properties:

Default: | NOLISTPATH
Phase: | Syntax check
$SET: | Initial

Comments:

In order to point list-path to an environment variable, suffix it with a $ (dollar) sign (for example, listpath"$listdir") to indicate that the value is not a directory name.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


LISTWIDTH, LW

Sets the width of the listing.

Syntax:

>>-.---.--.-LISTWIDTH-.-"width"------------><
   +-/-+  +-LW--------+

Parameters:

width Width in characters. It must be between 72 and 132.

Properties:

Default: | LISTWIDTH"80"
Phase: | Syntax check
$SET: | Any

Comments:

LISTWIDTH"132" causes additional information to be displayed for each line listed. This includes the first eight characters of the current copybook-name (spaces for the main file) together with the number of the line relative to the start of that file.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


MFCOMMENT

Treats lines with an asterisk (*) in column 1 the same as comment lines but does not show them in the source listing.

Syntax:

>>-.---.-.----.--MFCOMMENT-----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | MFCOMMENT (Dialect)
Phase: | Syntax check
$SET: | Any

Dependencies:

Set to NOMFCOMMENT at end by SOURCEFORMAT"FREE".

Comments:

With MFCOMMENT, lines with an asterisk in column 1 are ignored by the Compiler and do not appear in the source listing (though they do appear in the debugger ). With NOMFCOMMENT, the asterisk forms part of the sequence number and has no special significance.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


PREPLIST

Causes the list file produced during a compilation to show both the original and modified source created by the preprocessor as well as to show all data passed to the Compiler by a preprocessor.

Syntax:

>>-.---.-.----.--PREPLIST------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOPREPLIST
Phase: | Syntax check
$SET: | No

Comments:

This directive is provided as a debugging aid to preprocessor writers.

This directive only affects what the listing file, if produced, contains. It does not determine if a listing file is produced, or the name of the file.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


PRINT

Specifies the destination of the source listing file.

Syntax:

>>-.---.-.-------PRINT-.-"destination"-..--><
   +-/-+ |             +-()------------+|
         +.----.-PRINT------------------+
          +-NO-+

Parameters:

destination A full file specification, or a device-name.

Properties:

Default: | NOPRINT
Phase: | Syntax check
$SET: | Any

Comments:

PRINT is synonymous with LIST.

If you specify an existing file, it is overwritten.

When NOPRINT is specified, no source listing is produced. If you specify PRINT with no destination, the source listing is sent to the screen. If you specify either destination or (), you cannot use this directive in a $SET statement.

destination can be the name of any suitable device. Use CON: for the screen.

NOPRINT and PRINT with no parameter can be used in $SET statements in a program to list selected parts of the program. The destination of the listing cannot be changed in this way.

PRINT() causes the source listing to be put in the file source-name.lst, where source-name is the basename of the filename of the program being compiled.

If you want to list the source to a file for every compilation you do, place the PRINT() directive in the cobol.dir file. This overrides the default NOPRINT.

Alternatively, if you already have a PRINT directive in your cobol.dir, making every listing go to the screen, you can override it by using PRINT() on the command line.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


RAWLIST

Prevents changeable information, such as page headers, date, time, Compiler release level, from being included in any listing file produced.

Syntax:

>>-.---.-.----.--RAWLIST-------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NORAWLIST
Phase: | Syntax check
$SET: | Any

Comments:

Specifying this directive does not affect whether a listing is produced or the name of the listing file.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


REF

Makes the Compiler include in the source listing the intermediate code address of each Procedure Division statement.
Note: This Compiler directive is not intended for your use, and its setting should not be changed. It is included here for completeness, because it might appear in the list of settings.

Syntax:

>>-.---.-.----.--REF---------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOREF
Phase: | Both
$SET: | Any

Dependencies:

None.

Comments:

A table is placed at the end of the listing, in the format:

Address | Line No | Address | Line No | Address | Line No | Address | Line No
000000FD | 16161 | 00000101 | 16162 | 00000109 | 16163 | 00000121 | 16165
0000012A | 16166 | 00000133 | 16169 | 00000138 | 16170 | 0000013C | ...
Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


REFNO

Makes the Compiler display its internal reference number at the start of a compilation as well as at the bottom of every listing.

Syntax:

>>-.---.-.----.--REFNO---------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOREFNO
Phase: | Syntax check
$SET: | No
Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


RESEQ

Makes the Compiler produce line numbers.

Syntax:

>>-.---.-.----.--RESEQ---------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | RESEQ (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to RESEQ immediately by XREF.

Set to NORESEQ immediately by SEQCHK.

Set to NORESEQ at end by SOURCEFORMAT"FREE".

Comments:

These are COBOL line sequence numbers, starting at 1 and increasing in increments of 1.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


SOURCEASM

Makes the Compiler include source code statements in the assembler listing.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--SOURCEASM-----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOSOURCEASM
Phase: | Generate
$SET: | No

Dependencies:

Set to NOSOURCEASM by NOLIST at end.

SOURCEASM sets ANIM at end.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


TIME

Puts the time at the top of each page of the listing.

Syntax:

>>-.---.-.----.--TIME----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | TIME
Phase: | Syntax check
$SET: | No

Comments:

This directive has no effect if NODATE is specified.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


VERBOSE

Sends messages from the Compiler to the screen.

Syntax:

>>-.---.-.----.--VERBOSE-------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | VERBOSE
Phase: | Syntax check
$SET: | No

Dependencies:

VERBOSE sets CONFIRM immediately.

Comments:

When VERBOSE is specified, messages concerning accepted directives and the size of code and data areas are displayed on the screen.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List


XREF

Makes the Compiler produce a cross-reference listing.

Syntax:

>>-.---.-.----.--XREF----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOXREF
Phase: | Syntax check
$SET: | Initial

Dependencies:

XREF sets RESEQ immediately.

Set to NOXREF at end by NOLIST.

Comments:

This directive has no effect if the LIST directive is not specified.

To produce the cross-reference listing the Compiler needs extra work space on the disk. The space needed depends on the number of data items and procedure-names and the number of times they are referenced.

On UNIX, to produce the message "*End of cross reference listing" in the cross reference listing you must also specify the verbose compiler option, -v.

When the XREF directive is specified, extra information is added to the end of the .lst file produced:

  • Name of the data item
  • Type of the data item
  • Line number where the data item was defined, shown as n#
  • Line numbers where the data item was updated, shown as n*
  • Line numbers where the data item was tested, shown as n?
  • Number of times the data item appeared in the cross-reference listing, shown as (X n)
  • Procedure-name
  • Type of procedure

Example:

The following is an extract from a .lst file for a simple program:

     1 working-storage section.
     2 01 a  pic 9(2).
     3
     4 procedure division.
     5 main section.
     6     move 1 to a
     7     if a = 1 display "HELLO" end-if
     8     stop run.
     ...
* A                              Numeric DISPLAY
*          2#      6*      7?                           (X    3)
*
*               1 data-names
*
* MAIN                           Section
*          5#                                           (X    1)
*
*
*               1 procedure-names
* End of cross reference listing

The cross-referencing information shows that there is one data item, a, of type numeric display, which is defined on line 2, updated on line 6, and tested on line 7. The (X 3) at the end of the line refers to the number of times the data item appears in the cross-reference listing. The procedure-name main also appears in the listing, as a section which is referenced only once.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List
Related information
RESEQ
Compiler Control - Listing
LIST
Key to Compiler Directives


ZEROSEQ

Causes leading zeros to appear in the sequence numbers in columns 1 through 6.

Syntax:

>>-.---.-.----.--ZEROSEQ-------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOZEROSEQ (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

NOZEROSEQ suppresses these leading zeros.

Parent topic: Compiler Control - Listing
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Compiler Control - Listing
Key to Compiler Directives


Compiler Control - Screen

  • BELL
    Makes the bell sound at points such as when compilation stops, either because of an error or because it has finished.
  • CONFIRM
    Makes the Compiler echo all subsequent directives to the screen.
  • ECHO
    Makes the Compiler display error lines and error messages on the screen.
  • ECHOALL
    Sends a full listing to the screen as well as to a printer or other device specified with the LIST or PRINT directive.
  • SUPFF
    Suppresses form-feed characters on the compilation listing if it is sent to the screen.
Parent topic: Compiler Control


BELL

Makes the bell sound at points such as when compilation stops, either because of an error or because it has finished.

Syntax:

>>-.---.-.----.--BELL----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOBELL
Phase: | Generate
$SET: | Initial
Parent topic: Compiler Control - Screen
Parent topic: Compiler Directives - Alphabetical List


ECHO

Makes the Compiler display error lines and error messages on the screen.

Syntax:

>>-.---.-.----.--ECHO----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | ECHO (Dialect)
Phase: | Syntax check
$SET: | Any

Dependencies:

Set to NOECHO immediately by ECHOALL.

Comments:

For each error, the source line is displayed together with an error number and (unless BRIEF is set) an explanatory message.

Parent topic: Compiler Control - Screen
Parent topic: Compiler Directives - Alphabetical List


ECHOALL

Sends a full listing to the screen as well as to a printer or other device specified with the LIST or PRINT directive.

Syntax:

>>-.---.-.----.--ECHOALL-------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOECHOALL
Phase: | Syntax check
$SET: | No

Dependencies:

ECHOALL sets NOECHO immediately.

Parent topic: Compiler Control - Screen
Parent topic: Compiler Directives - Alphabetical List


SUPFF

Suppresses form-feed characters on the compilation listing if it is sent to the screen.

Syntax:

>>-.---.-.----.--SUPFF---------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | SUPFF
Phase: | Syntax check
$SET: | Any
Parent topic: Compiler Control - Screen
Parent topic: Compiler Directives - Alphabetical List


Compiling for Debugging and Analysis

These directives make the Compiler create files containing extra information about the program, for input to software used for debugging and analysis.

  • ANIM
    Makes the Compiler produce extra information so that you can debug your program.
  • COBIDY
    Specifies the path where the .idy file is to be written.
  • FAULTFIND
    Enables file input and output to be logged by FaultFinder.
  • FLAGSINEDIT
    Specifies whether flagging messages are to be included in an error file.
  • PROFILE
    Includes code in your program to produce detailed performance statistics each time you run the program.
  • TESTCOVER
    Enables you to use the test coverage tool, which creates a statistical execution profile of a program.
  • TRACE
    Enables READY TRACE and RESET TRACE statements.
Parent topic: Compiler Directives


ANIM

Makes the Compiler produce extra information so that you can debug your program.

Syntax:

>>-.---.-.----.--ANIM----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOANIM
Phase: | Both
$SET: | Initial

Comments:

The ANIM directive causes a file with extension .idy to be created. This contains the additional information needed to debug the program. The location of the .idy file is controlled by the COBIDY directive.

Parent topic: Compiling for Debugging and Analysis
Parent topic: Compiler Directives - Alphabetical List


COBIDY

Specifies the path where the .idy file is to be written.

Syntax:

>>-.---.-.-------COBIDY-"path-name"-.-----><
   +-/-+ +.----.-COBIDY-------------+
          +-NO-+

Parameters:

path-name Path specification.

Properties:

Default: | NOCOBIDY
Phase: | Syntax check
$SET: | No

Comments:

If you do not specify path-name, the path-name in the COBIDY environment variable is used; if the environment variable contains multiple path-names the first of them is used. With NOCOBIDY, the .idy is written to the same path as the .obj file.

Parent topic: Compiling for Debugging and Analysis
Parent topic: Compiler Directives - Alphabetical List


FAULTFIND

Enables file input and output to be logged by FaultFinder.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--FAULTFIND------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOFAULTFIND
Phase: | Syntax check
$SET: | Any
Parent topic: Compiling for Debugging and Analysis
Parent topic: Compiler Directives - Alphabetical List


PROFILE

Includes code in your program to produce detailed performance statistics each time you run the program.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--PROFILE-----------><
   +-/-+ +-NO-+

Parameters:

None.

Properties:

Default: | NOPROFILE
Phase: | Syntax check
$SET: | No

Comments:

You need to use the Profiler utility to look at the statistics.

Parent topic: Compiling for Debugging and Analysis
Parent topic: Compiler Directives - Alphabetical List


TESTCOVER

Enables you to use the test coverage tool, which creates a statistical execution profile of a program.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--TESTCOVER------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOTESTCOVER
Phase: | Syntax check
$SET: | Any

Comments:

In order to create a program profile, you need to specify this directive and run your programs under test coverage mode.

Parent topic: Compiling for Debugging and Analysis
Parent topic: Compiler Directives - Alphabetical List
Related information
To use test coverage from the command line for native COBOL
Run-time Behavior - General
Key to Compiler Directives


TRACE

Enables READY TRACE and RESET TRACE statements.

Syntax:

>>-.---.-.----.--TRACE----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOTRACE(Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

When TRACE is set, the READY TRACE statement turns on the trace facility at run time. With this facility on, the name of each paragraph or section heading is displayed as it is executed. RESET TRACE turns this facility off. With NOTRACE, the READY TRACE and RESET TRACE statements have no effect.

Parent topic: Compiling for Debugging and Analysis
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - General
Compiling for Debugging and Analysis
Key to Compiler Directives


File Handling

These directives affect the way files are handled.

  • ANS85
    Specifies that words reserved in the ANSI'85 COBOL Standard are to be treated as reserved words in this COBOL system, and changes the behavior of certain features to be compatible with that Standard.
  • ASSIGN-PRINTER
    Specifies how to assign the output from an ASSIGN TO PRINTER clause when the clause does not specify a filename.
  • ASSIGN
    Specifies how to assign a filename when neither EXTERNAL nor DYNAMIC appear in the SELECT statement.
  • AUTOLOCK
    Makes the default locking AUTOMATIC rather than EXCLUSIVE for files opened I-O or EXTEND in a multi-user environment.
  • CALLFH
    Makes the Compiler generate direct calls for all file I/O operations, using the Callable File Handler interface.
  • CALL-RECOVERY
    Specifies the behavior when control is returned to a program.
  • CALLSORT
    Defines the program to be called to handle all SORT and MERGE operations.
  • COBFSTATCONV
    Causes the Callable File Handler to use the user-supplied module specified in the COBFSTATCONV environment variable to convert the file status codes if an I/O error is encountered on a file.
  • DATACOMPRESS
    Specifies the type of data compression to be done on sequential and indexed files.
  • DETECT-LOCK
    Makes READ statements detect when a record is locked by another program.
  • FCDCAT
    Specifies whether the catalogued file information for a file is used when accessing that file.
  • FDCLEAR
    Specifies that the record buffer for a file should be cleared after every write operation.
  • FILESHARE
    Causes the default locking to become AUTOMATIC rather than EXCLUSIVE for files in a multi-user environment, and automatically locks records on a WRITE or REWRITE statement when the program is locking multiple records.
  • FILETYPE
    Specifies the file format to use when creating files.
  • HOSTCONTZERO
    For files defined with the RECORD CONTAINS"0" clause, this directive instructs the File Handler to take the record length from the catalog rather than the file description entry.
  • HOSTFD
    Specifies that the record area associated with a file should only be allocated at the time of an OPEN statement and not before.
  • IDXFORMAT
    Specifies the format to use when creating indexed files.
  • IXNLSKEY
    Specifies that the File Handler should sort index file keys according to the local collating sequence rather than the ASCII collating sequence.
  • IXNUMKEY
    Enables true numeric sorting on index keys.
  • KEYCHECK
    Specifies whether the File Handler checks that all the keys belonging to the indexed file you are opening are defined in your application.
  • KEYCOMPRESS
    Specifies the type of key compression to be done on indexed files.
  • LOCKTYPE
    Specifies the type of record locking.
  • OLDREADINTO
    Changes the behavior of the READ ... INTO statement.
  • OPTIONAL-FILE
    Makes the Compiler treat all files opened for I-O or EXTEND as optional.
  • PRESERVECASE
    Ensures that COBOL items declared in the current program retain their case and are not converted to uppercase as is usual in COBOL. This enables the items to be found from outside the program.
  • PRINT-EXT
    Specifies the extension to be added to the filename associated with the ASSIGN TO PRINTER clause.
  • RDW
    Enables you to find out the length of a record that has just been read from a variable-length sequential file.
  • RECMODE
    Specifies the default format of files.
  • RETRYLOCK
    Specifies that when a READ statement finds that a record is locked the read operation is to be retried repeatedly until the record is available.
  • REWRITE-LS
    Allows REWRITE statements on line sequential files.
  • SEQUENTIAL
    Specifies the default file type for files defined (implicitly or explicitly) as ORGANIZATION SEQUENTIAL.
  • SORTTYPE
    Selects which mainframe SORT module to emulate.
  • WRITELOCK, WRITE-LOCK
    Makes the WRITE and REWRITE statements acquire a record lock when the program is locking multiple records in a shared data file in a multi-user environment.
  • WRITETHROUGH, WRITETHRU
    Specifies that disk writes are not to be buffered.
Parent topic: Compiler Directives


ASSIGN-PRINTER

Specifies how to assign the output from an ASSIGN TO PRINTER clause when the clause does not specify a filename.

Syntax:

>>-.---.-.----ASSIGN-PRINTER.-"filename"-.-.-><
   +-/-+ |                  +-()---------+ |
         +--NOASSIGN-PRINTER---------------+

Parameters:

filename
The file to be associated with the ASSIGN TO PRINTER clause.

Properties:

Default: | NOASSIGN-PRINTER
Phase: | Syntax check
$SET: | Any

Comments:

This directive has no effect if you specify a filename as part of the ASSIGN TO PRINTER clause.

NOASSIGN-PRINTER causes the output to be sent to the device LST:.

ASSIGN-PRINTER"filename" causes the output to be directed to the filename specified. The filename can be fully specified, including a path-name, base-name, and extension.

ASSIGN-PRINTER() results in the same behavior as including the following COBOL statement:

 select filename-1 assign to printer filename-1

That is, the filename used in your COBOL program is also used as the filename for your output. If the internal filename is too long for your operating system to handle, it is truncated to the maximum length the operating system allows.

By default, the filename does not include an extension, but you can specify an extension by using the PRINT-EXT directive.

Parent topic: File Handling
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


ASSIGN

Specifies how to assign a filename when neither EXTERNAL nor DYNAMIC appear in the SELECT statement.

Syntax:

>>-.---.--ASSIGN--"assign-type"------------><
   +-/-+

Parameters:

assign-type
EXTERNAL | The ASSIGN clause contains a data name or literal that specifies the file's name in the external file-storage environment.
DYNAMIC | the ASSIGN clause contains an external-file-reference that specifies the file to the external environment for possible further mapping to an external file-storage environment-name.

Properties:

Default: | ASSIGN"DYNAMIC" (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

For any indexed files or for all files if the program is compiled using the CALLFH directive, filename mapping overrides any syntax definition or use of the ASSIGN directive.

Parent topic: File Handling
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - General
CALLFH
Key to Compiler Directives
Assigning Filenames


AUTOLOCK

Makes the default locking AUTOMATIC rather than EXCLUSIVE for files opened I-O or EXTEND in a multi-user environment.

Syntax:

>>-.---.-.----.--AUTOLOCK------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOAUTOLOCK
Phase: | Syntax check
$SET: | Initial

Comments:

This directive does not appear in the SETTING list if its state is the same as WRITELOCK. In this case, the state of the two directives is indicated by the FILESHARE directive.

This directive is included for compatibility with earlier file-sharing products. When writing new programs you should use the locking syntax rather than this directive.

Parent topic: File Handling
Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


CALLFH

Makes the Compiler generate direct calls for all file I/O operations, using the Callable File Handler interface.

Syntax:

>>-.---.--.------CALLFH--"handler-name"--.--><
   +-/-+  +------CALLFH------------------+

Parameters:

handler-name
Root-name of a program to be called to act as the file handler. One of:
EXTFH
The file handler supplied with this COBOL system
ACUFH
Offers limited access to RM, Vision and database files (see Comments)
FHREDIR
For use with Fileshare Version 2
fhname
Name of your own file handler

Properties:

Default: | CALLFH"EXTFH" (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

When CALLFH is specified, all file I/O statements are converted to calls to the file handler specified by the parameter.

If handler-name is not specified, the module EXTFH is assumed.

This directive is also used to direct all file handling calls through converter modules, to make use of non-COBOL file handlers.

Parent topic: File Handling
Parent topic: Object Code - External Handlers
Parent topic: Compiler Directives - Alphabetical List
Related concepts
Environment Variables Used to Resolve File Names


CALL-RECOVERY

Specifies the behavior when control is returned to a program.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.-------CALL-RECOVERY--"integer"--.-----><
   +-/-+ +.----.-CALL-RECOVERY-------------+
          +-NO-+

Parameters:

integer
Must be one of:
1
Makes the program check the current call recovery state every time control is returned to it following a call; if there is a controlled exit in force the program performs a GOBACK, that is, passes control back up the COBOL call chain rather than continuing with the next statement.

You should use CALL-RECOVERY "1" when compiling a mixture of CICS and non-CICS programs for running in Mainframe Subsystem Support. When compiling only CICS programs , CALL-RECOVERY "1" is not required.

2
As for 1, but also catches exceptions on CALL dataname statements and sets the call recovery state before performing a GOBACK to pass control back up the COBOL call chain.

You should use CALL-RECOVERY "2" when compiling a mixture of CICS and non-CICS programs for running in IBM's TX Series on WebSphere.

Properties:

Default: | NOCALL-RECOVERY
Phase: | Syntax check
$SET: | Initial

Comments:

Specifying CALL-RECOVERY with no parameter has the same effect as specifying CALL-RECOVERY "2".

Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List
Related information
Run-time Behavior - General
Key to Compiler Directives


CALLSORT

Defines the program to be called to handle all SORT and MERGE operations.

Syntax:

>>-.---.--CALLSORT-"sort-name"--------------><
   +-/-+

Parameters:

sort-name Root-name of a program to be called to process sorts and merges.

Properties:

Default: | CALLSORT"EXTSM" (Dialect)
Phase: | Syntax check
$SET: | Initial
Parent topic: File Handling
Parent topic: Object Code - External Handlers
Parent topic: Compiler Directives - Alphabetical List


COBFSTATCONV

Causes the Callable File Handler to use the user-supplied module specified in the COBFSTATCONV environment variable to convert the file status codes if an I/O error is encountered on a file.

Syntax:

>>-.---.-.----.--COBFSTATCONV--------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOCOBFSTATCONV .
Phase: | Syntax check
$SET: | Initial

Comments:

This directive is provided for compatibility with previous versions of Micro Focus COBOL only.

Parent topic: File Handling
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related information
Run-time Behavior - General
Key to Compiler Directives


DATACOMPRESS

Specifies the type of data compression to be done on sequential and indexed files.

Syntax:

>>-.---.-.-----DATACOMPRESS--"integer"-.---><
   +-/-+ +-NO--DATACOMPRESS------------+

Parameters:

integer
Must be one of:
0
Equivalent to NODATACOMPRESS
1
Specifies run-length encoding.
3
Specifies run-length encoding for double-byte (DBCS) characters
128 through 255
User-defined compression routines

Properties:

Default: | NODATACOMPRESS
Phase: | Syntax check
$SET: | Any

Comments:

The only values that can be specified for data compression supported by this system are 0, 1 and 3. Values in the range 128 through 255 indicate user-defined compression routines.

You need to specify data compression only when creating the file. Subsequently, the data compression is detected when the file is opened.

To get data compression on an individual file, use $SET statements in your source so that this directive is in effect only for the part of the source containing the file's SELECT statement.

Data compression is supported only by the Callable File Handler. All indexed files are processed by the Callable File Handler. However, if you want to use data compression with sequential files, every program referencing those files must be compiled with the directive CALLFH"EXTFH".

Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List
Related information
CALLFH
File Handling
Key to Compiler Directives


DETECT-LOCK

Makes READ statements detect when a record is locked by another program.

Syntax:

>>-.---.-.----.--DETECT-LOCK---------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | DETECT-LOCK
Phase: | Syntax check
$SET: | Initial

Comments:

The Compiler also accepts the name without a hyphen; that is, DETECTLOCK.

With DETECT-LOCK, if a READ statement reads a record locked by another program, it returns an I/O status of 9/068. With NODETECT-LOCK, it returns 0/000. In both cases it reads the record successfully.

If a READ statement attempts to lock a record (that is, if the statement LOCK MODE IS AUTOMATIC has been specified, or a WITH LOCK phrase is used on the READ statement), and the record is locked by another program, an I/O status of 9/068 is returned. If NODETECT-LOCK is specified, and the READ statement is not attempting to lock a record an I/O status of 0/000 is returned.

When DETECT-LOCK is specified, individual READ statements can be made to ignore locks by using the READ ... IGNORE LOCK syntax.

Parent topic: File Handling
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


FCDCAT

Specifies whether the catalogued file information for a file is used when accessing that file.

Syntax:

>>-.---.--.----.-FCDCAT-----><
   +-/-+  +-NO-+

Parameters:

None

Properties:

Default: | FCDCAT for mainframe dialects; NOFCDCAT for non-mainframe dialects
Phase: | Syntax check
$SET: | Any

Comments:

To enable this behavior for an individual file, use a $SET statement in your source code before the file's SELECT statement.

Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List


FDCLEAR

Specifies that the record buffer for a file should be cleared after every write operation.

Syntax:

>>-.---.-.-------FDCLEAR--"integer"--.-----><
   +-/-+ +.----.-FDCLEAR-------------+
          +-NO-+

Parameters:

integer
Must be one of:
1
Specifies that the record buffer for a file should be cleared after every write operation. The buffer is cleared to the value specified by the DEFAULTBYTE directive.
2
As for 1, but the record buffer is also cleared after the initial OPEN statement.

Properties:

Default: | NOFDCLEAR (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

The FDCLEAR directive is effective while the SELECT clauses are being processed. Use $SET statements before and after each SELECT clause to apply this feature to selected files. Alternatively, use it once before processing any SELECT statements to apply it to all files in a program.

The FDCLEAR directive is ignored for files subject to a SAME RECORD AREA clause in the I-O-Control paragraph.

Specifying FDCLEAR with no parameter has the same effect as specifying FDCLEAR "1".

Example:

In the following code, FDCLEAR is applied only to file-2:

 file-control.
     select file-1 ...
$set fdclear
     select file-2 ...
$set nofdclear
     select file-3 ...
Parent topic: File Handling
Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List


FILESHARE

Causes the default locking to become AUTOMATIC rather than EXCLUSIVE for files in a multi-user environment, and automatically locks records on a WRITE or REWRITE statement when the program is locking multiple records.

This directive is not related in any way to Fileshare Version 2. You must not use this directive when using Fileshare V2.

Syntax:

>>-.---.-.----.--FILESHARE-----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOFILESHARE
Phase: | Syntax check
$SET: | Initial

Comments:

This directive is included for compatibility with earlier file-sharing products. When writing new programs you should use the locking syntax rather than this directive.

FILESHARE is equivalent to WRITELOCK and AUTOLOCK together. NOFILESHARE is equivalent to NOAUTOLOCK and NOWRITELOCK together.

Parent topic: File Handling
Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


FILETYPE

Specifies the file format to use when creating files.

Syntax:

>>-.---.--FILETYPE--"integer"--------------><
   +-/-+

Parameters:

integer
An integer representing the type to use.
0 | System-specific default (for this COBOL system, same as 3).
1 | C-ISAM format.
2 | Micro Focus Level II format.
3 | Micro Focus COBOL format.
4 | An optimized form of the format used by this COBOL system, for fast duplicate key handling.
5 | Reserved
6 | Reserved
7 | Reserved.
8 | Large indexed files.
9-10 | Reserved.
11 | Mainframe print file format.
12-255 | Reserved.

Properties:

Default: | FILETYPE"0"
Phase: | Syntax check
$SET: | Any

Dependencies:

FILETYPE"integer" sets IDXFORMAT"integer" immediately.

Comments:

This directive only works on files processed by the Micro Focus File Handler. Use the CALLFH directive if you are processing files other than indexed files.

To produce print files in the style of an IBM mainframe using FILETYPE"11", you must also:

  • Set the directive OSVS or VCS2
  • Use WRITE AFTER ADVANCING syntax
  • Set the CALLFH directive (so your program uses the Micro Focus File Handler)
  • Use a SELECT statement in the form:
    select printfile assign "print" organization is sequential.

    (Print files in the style of an IBM mainframe have a print control character in the first column.)

Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List


HOSTCONTZERO

For files defined with the RECORD CONTAINS"0" clause, this directive instructs the File Handler to take the record length from the catalog rather than the file description entry.

Syntax:

>>-.---.-.----.-------HOSTCONTZERO-------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | HOSTCONTZERO for mainframe dialects; NOHOSTCONTZERO for Micro Focus and non-mainframe dialects
Phase: | Syntax Check
$SET: | Initial
Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List


HOSTFD

Specifies that the record area associated with a file should only be allocated at the time of an OPEN statement and not before.

Syntax:

 >>-.---.-.----.--HOSTFD-------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOHOSTFD
Phase: | Syntax check
$SET: | Initial

Comments:

If you specify this directive, operations on the record area associated with a file are only possible while the file is open. HOSTFD does not affect EXTERNAL or SORT files. Nor does it affect files defined in a SAME RECORD AREA clause in the I-O CONTROL paragraph.

Specify NOHOSTFD if you need to access a file's record area after a FILE CLOSE has been performed on it.

This directive is for mainframe compatibility.

Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List
Related information
Run-time Behavior - Mainframe Compatibility
Key to Compiler Directives


IDXFORMAT

Specifies the format to use when creating indexed files.

Syntax:

>>-.---.--IDXFORMAT--"integer"-------------><
   +-/-+

Parameters:

0
Default format for the operating system (identical to 8.)
1
C-ISAM.
3
Micro Focus default indexed file format.
4
Optimized format for fast duplicate key handling.
5
Btrieve with ANSI
6
Btrieve without ANSI
8
Large indexed file format.
9
Indexed with single key, non-duplicate, key ordered records.
10
Reserved.
11
Mainframe print file format.
12-13
Reserved.
14
Heap file.
15
ESDS
16
ESDS-Big
17-255
Reserved.

Properties:

Default: | IDXFORMAT"3"
Phase: | Syntax check
$SET: | Any

Dependencies:

Set to IDXFORMAT"integer" immediately by FILETYPE"integer".

Comments:

Existing files in any of the given formats are processed correctly without the need for this directive. This directive controls the format used when creating new files.

Setting the IDXFORMAT using this Compiler directive overrides the index format setting specified in the file handler configuration file.

Specifying 4 might make the files larger than their IDXFORMAT"3" equivalents.

Micro Focus Level II format files are compatible with Micro Focus products such as Level II COBOL, Professional COBOL V1.2, and VS COBOL Workbench versions up to and including V1.3.

You must not use the ANS85 directive to enable ANSI'85 behavior when using IDXFORMAT"2". However, you can use ANS85"SYNTAX" to enable ANSI'85 syntax.

Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List


IXNLSKEY

Specifies that the File Handler should sort index file keys according to the local collating sequence rather than the ASCII collating sequence.

Syntax:

>>-.---.-.----.----IXNLSKEY---------------><
   +-/-+ +-NO-+

Parameters:

None.

Properties:

Default: | NOIXNLSKEY
Phase: | Syntax check
$SET: | Any

Comments:

If you set IXNLSKEY, then move the index file to a different locale, the index keys will no longer be found.

Parent topic: File Handling
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


IXNUMKEY

Enables true numeric sorting on index keys.

Syntax:

>>-.---.-.----.-IXNUMKEY-------------------><
   +-/-+ +-NO-+

Parameters:

None.

Properties:

Default: | NOIXNUMKEY
Phase: | Syntax check
$SET: | Any

Comments:

Index keys are are normally treated as alphanumeric even if they contain numeric data. Therefore, the results of READ NEXT operations might be unexpected. This directive should be used when the true numeric order is required. In general it will only have an effect for keys defined as signed numeric, but some kinds of unsigned data (for instance COMP-5) may also be affected.

For example, say you have a key defined as pic s9(5), and you had four records for which the key values were 1, -2, 3, -4, stored as:

  • 00001+
  • 00002-
  • 00003+
  • 00004-

If these keys are treated as alphanumeric, they will be retrieved in the above order. However if they are treated as numeric (which is the case when IXNUMKEY is specified), they will be stored (and therefore retrieved when using READ NEXT) in numeric order:

  • 00004-
  • 00002-
  • 00001+
  • 00003+
Parent topic: File Handling
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


KEYCOMPRESS

Specifies the type of key compression to be done on indexed files.

Syntax:

>>-.---.-.-----KEYCOMPRESS--"integer"-.----><
   +-/-+ +-NO--KEYCOMPRESS------------+

Parameters:

integer
Must be between 0 and 7, combining the following values
1
Suppress repetitions of duplicate keys.
2
Suppress leading characters that are the same as in the previous key.
4
Suppress trailing spaces.

You can specify any combination of these numbers by adding these values together.

Properties:

Default: | NOKEYCOMPRESS
Phase: | Syntax check
$SET: | Any

Comments:

KEYCOMPRESS"0" is equivalent to NOKEYCOMPRESS.

You need specify key compression only when creating the file. Subsequently, key compression is detected when the file is opened.

To get key compression on an individual file, use $SET statements in your source code so that this directive is in effect only for the part of the source containing the relevant KEY clause in the file's SELECT statement.

Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List
Related information
File Handling
The File Control Entry
Data Description Entry Skeleton
The OCCURS Clause
The INVALID KEY Condition
The ACCEPT Statement
The DELETE Statement
The MERGE Statement
The READ Statement
The REWRITE Statement
The SORT Statement
The START Statement
The WRITE Statement
XML Syntax - DELETE Statement
XML Syntax - READ Statement
XML Syntax - REWRITE Statement
XML Syntax - START Statement
XML Syntax - WRITE Statement
XML Syntax - SELECT Clause
Index Files - Overview
Key to Compiler Directives


LOCKTYPE

Specifies the type of record locking.

Syntax:

>>-.---.--LOCKTYPE--"integer"--------------><
   +-/-+

Parameters:

integer
The type of locking.
0 | Programs can read locked records, but not access them in other ways. This is the standard method with this COBOL system.
1 | Programs cannot access locked records at all. This is as in languages other than COBOL.
2 | Creates a new file with the same basename as the file being opened but with a .lck extension. Any record locks are recorded in this file. This enables the File Handler to read and write to files up to 4 gigabytes in size regardless of whether the file is shared or locked. You cannot set this value for striped files.

Properties:

Default: | LOCKTYPE"0"
Phase: | Syntax check
$SET: | Initial

Comments:

This directive only has an effect if the CALLFH directive is used.

Parent topic: File Handling
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


OLDREADINTO

Changes the behavior of the READ ... INTO statement.

Syntax:

>>-.---.-.----.--OLDREADINTO---------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOOLDREADINTO (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

When OLDREADINTO is specified, the implicit move from the file's record area to the data item specified in the INTO phrase is executed even when the READ is not successful. If NOOLDREADINTO is specified, the MOVE only happens if the READ is successful.

Parent topic: File Handling
Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


OPTIONAL-FILE

Makes the Compiler treat all files opened for I-O or EXTEND as optional.

Syntax:

>>-.---.-.----.--OPTIONAL-FILE-------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | OPTIONAL-FILE (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to OPTIONAL-FILE immediately by NORM. Set to NOOPTIONAL-FILE immediately by RM or RM"ANSI".

Comments:

Under ANSI'85 Standard COBOL, a file is treated as optional only if it has the OPTIONAL phrase in its SELECT statement. For compatibility with the ANSI'85 Standard you must specify the NOOPTIONAL-FILE directive.

Parent topic: File Handling
Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List
Related reference
Open EXTEND of Nonexistent File
Related information
DIALECT
Run-time Behavior - Compatibility with Other COBOL Dialects
The File Control Entry
XML Syntax - OPEN Statement
XML Syntax - SELECT Clause
RM
The OPEN Statement
The USE Statement
Key to Compiler Directives


PRESERVECASE

Ensures that COBOL items declared in the current program retain their case and are not converted to uppercase as is usual in COBOL. This enables the items to be found from outside the program.

Syntax:

>>-.----.--PRESERVECASE---------><
   +-NO-+

Parameters:

None

Properties:

Default: | PRESERVECASE for managed code or if the DIALECT"ENTCOBOL" compiler directive is set, and NOPRESERVECASE for native code or managed code compiled from the command line.
Phase: | Syntax check
$SET: | Any

Comments:

PRESERVECASE preserves the case of those items for which the COBOL name determines a name that is visible externally (such as PROPERTY names specified without the AS clause). The exact case of the COBOL name used in the declaration is the case used for the external name. References to the item from within the same COBOL program can still use any case combination.

The directive also preserves the case of data-names in output from the XML GENERATE statement.

Example:

$set preservecase
01 Fred property binary-long.
*> Sets up a property with external name "Fred"

procedure division.
    Move 999 to fred
*> fred is a normal COBOL data name and can therefore be accessed using any case
Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List


PRINT-EXT

Specifies the extension to be added to the filename associated with the ASSIGN TO PRINTER clause.

Syntax:

>>-.---.-.----PRINT-EXT--"extension"---.-------><
   +-/-+ +-------NOPRINT-EXT-----------+

Parameters:

extension The extension to be added.

Properties:

Default: | No extension is added
Phase: | Syntax check
$SET: | Any

Comments:

This directive is ignored unless ASSIGN-PRINTER() is specified with no filename.

Parent topic: File Handling
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


RECMODE

Specifies the default format of files.

Syntax:

>>-.---.--RECMODE--"format"----------------><
   +-/-+

Parameters:

format
One of:
F
Fixed-length record format.
V
Variable-length record format.
OSVS, VSC21, VSC22
Fixed or variable depending on a file's record definitions. If all record definitions for the file have the same length and are fixed length, the file is fixed-length record format. Otherwise it is variable-length record format.
COB370, ENTCOBOL, MVS, OS390, VSC23, VSC24
Fixed or variable length depending on the file's record definitions. If all record definitions for the file are the same length, and are fixed length and/or the FD entry has a RECORD CONTAINS x CHARACTERS clause, the file is fixed-length record format. Otherwise it is variable-length record format.

Properties:

Default: | RECMODE"F" (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

RECMODE"VSC22" set at end by CMPR2.

Comments:

For an individual file this directive is overridden if the FD contains either a RECORD IS VARYING phrase (which specifies variable format) or a RECORDING MODE clause.

Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
File Handling
File Description Entry Skeleton
The RECORDING MODE Clause
The RECORD Clause
The PERFORM Statement
The SEARCH Statement
File Organizations
Key to Compiler Directives


RETRYLOCK

Specifies that when a READ statement finds that a record is locked the read operation is to be retried repeatedly until the record is available.

Syntax:

>>-.---.-.----.--RETRYLOCK-----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NORETRYLOCK
Phase: | Syntax check
$SET: | Any

Dependencies:

Set to NORETRYLOCK immediately by NORM.

Comments:

This directive affects a file only if the file has a FILE STATUS item but there is no declarative specifically for that file.

Parent topic: File Handling
Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List


SEQUENTIAL

Specifies the default file type for files defined (implicitly or explicitly) as ORGANIZATION SEQUENTIAL.

Syntax:

>>-.---.--SEQUENTIAL--"type"---------------><
   +-/-+

Parameters:

type
One of:
ADVANCING
RECORD SEQUENTIAL with LINE ADVANCING.
ANSI
ANSI-conforming RECORD SEQUENTIAL.
LINE
LINE SEQUENTIAL.
RECORD
RECORD SEQUENTIAL (a standard SEQUENTIAL file).

Properties:

Default: | SEQUENTIAL"RECORD" (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to SEQUENTIAL"RECORD" immediately by NORM or RM"ANSI".

Set to SEQUENTIAL"LINE" immediately by RM.

Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List


SORTTYPE

Selects which mainframe SORT module to emulate.

Syntax:

>>-.---.-.----.--SORTTYPE--"module-type"----------><
   +-/-+

Parameters:

module-type
DFSORT
Compatibility with DFSORT
SYNCSORT
Compatibility with SYNCSORT

Properties:

Default: | SORTTYPE(DFSORT)
Phase: | Check
$SET: | Initial
Parent topic: File Handling
Parent topic: Compiler Directives - Alphabetical List
Related information
Key to Compiler Directives
Mfsort Utility


WRITELOCK, WRITE-LOCK

Makes the WRITE and REWRITE statements acquire a record lock when the program is locking multiple records in a shared data file in a multi-user environment.

Syntax:

>>-.---.-.----.-.-WRITELOCK--.-------------><
   +-/-+ +-NO-+ +-WRITE-LOCK-+

Parameters:

None

Properties:

Default: | NOWRITELOCK
Phase: | Syntax check
$SET: | Initial

Comments:

This directive is included for compatibility with earlier file-sharing products. When writing new programs you should use the relevant locking syntax rather than this directive.

Parent topic: File Handling
Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


WRITETHROUGH, WRITETHRU

Specifies that disk writes are not to be buffered.

Syntax:

>>-.---.-.----.-.-WRITETHROUGH-.-----------><
   +-/-+ +-NO-+ +-WRITETHRU----+

Parameters:

None

Properties:

Default: | NOWRITETHROUGH
Phase: | Syntax check
$SET: | Any

Dependencies:

Requires CALLFH to be set.

Comments:

When WRITETHROUGH is specified, the system does not buffer disk writes.

To specify this directive for an individual file, use $SET statements in your source so that the directive is in effect only for the part of the source containing the file's SELECT statement.

Using WRITETHROUGH helps improve the integrity of data files by ensuring that every write operation goes to the disk file straight away, reducing the possibility of losing data if your computer crashes. However, it also bypasses all cacheing and blocking methods, resulting in poorer performance.

Parent topic: File Handling
Parent topic: Object Code - File Handling
Parent topic: Compiler Directives - Alphabetical List


Managed COBOL Command Line Compiler Directives

When you build a project, the Compiler directives for managed COBOL are generated according to the project structure and properties. We recommend that you compile programs using the IDE, so that the directives are automatically set.

If you want to compile at the command line, the following directives are available:

  • Application Directives
  • Code Generation Directives
  • Reference, Resource and Namespace Directives
  • Strong Naming Directives
  • Identity, Information and Manifest Directives
Parent topic: Compiler Directives


Application Directives

  • DOTNET
    Sets the reserved words needed for the .NET COBOL language.
  • ILASSEMBLY
    Specifies the name of the assembly created.
  • ILGEN
    Generates the IL for a program with a main program entry point or for a library without one.
  • ILMAIN
    Specifies the entry method for the executable program being compiled.
  • ILNAMESPACE
    Specifies the default namespace for items such as classes when building a project.
  • ILOUTPUT
    Sets the path of the output assembly file or Java class file.
Parent topic: Managed COBOL Command Line Compiler Directives


DOTNET

Sets the reserved words needed for the .NET COBOL language.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-.----.--DOTNET------------><
   |    |
   +-NO-+

Parameters:

None

Properties:

Default: | NODOTNET
IDE equivalent: | None.

Dependencies:

ILGEN sets DOTNET.

Comments:

This directive is not allowed in the $SET statement. You must specify DOTNET on the command line.

Parent topic: Application Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
ILASSEMBLY
ILMAIN
Key to Compiler Directives
ILGEN


ILASSEMBLY

Specifies the name of the assembly created.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.----ILASSEMBLY"assembly-name"--.------------><
       +--NOILASSEMBLY-----------------+

Parameters:

assembly-name
The name of the assembly created. The default name is the same as the name of the file being compiled. The output file has this name with the extension .dll if the directive ILGEN(SUB) is specified, or the extension .exe if ILGEN is specified.

Properties:

Default: | ILASSEMBLY"assembly-name" (IDE default) or NOILASSEMBLY (command line default)
IDE equivalent: | Click Project > Properties > Application > Assembly Name

Comments:

If you need to specify the path of the output assembly file, you do this using the ILOUTPUT directive.

Parent topic: Application Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
ILGEN
ILOUTPUT
ILMAIN
Key to Compiler Directives


ILGEN

Generates the IL for a program with a main program entry point or for a library without one.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>------.--ILGEN-.-MAIN--.-----><
        |        +-SUB---+
        +--NOILGEN-------+

Parameters:

MAIN
Indicates that a program with a main entry point is being compiled
SUB
Indicates that a library is being compiled, which doesn't require a main program entry point

Properties:

Default: | ILGEN"MAIN"
IDE equivalent: | Click Project> Properties> Application and then fill in Output Type.

Dependencies:

ILGEN sets DOTNET.

Comments:

This directive is always used when you build a project from the IDE. If a program doesn't require a main program entry point, use the SUB parameter.

This directive is comparable to the ILMAIN directive: ILGEN"SUB" is equivalent to NOILMAIN.

This directive is not allowed in the $SET statement. You must specify ILGEN on the command line.

Parent topic: Application Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
ILASSEMBLY
ILMAIN
Key to Compiler Directives


ILMAIN

Specifies the entry method for the executable program being compiled.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILMAIN--"entry-program"--.---><
       +-NOILMAIN------------------+

Parameters:

entry-program
The name of the program containing the main entry point, which is the first static method within that program. For procedural COBOL, the main entry point is denoted by the Procedure Division Using clause.

Properties:

Default: | NOILMAIN
IDE equivalent: | Click Project > Properties > Application and fill in Startup object

Comments:

This directive is comparable to the ILGEN directive: NOILMAIN is equivalent to ILGEN"SUB".

Parent topic: Application Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
ILASSEMBLY
ILGEN
Key to Compiler Directives


ILNAMESPACE

Specifies the default namespace for items such as classes when building a project.
Restriction: This directive is supported for managed COBOL only.

Syntax:

>>-----.---ILNAMESPACE--"namespace"---.--><
       +-NOILNAMESPACE----------------+

Parameters:

namespace The default namespace

Properties:

Default: | NOILNAMESPACE
IDE equivalent: | Click Project > Properties > COBOL > Additional Directives or Project > Properties > Application > Default Namespace
Parent topic: Application Directives
Parent topic: Compiler Directives - Alphabetical List
Related reference
ILSOURCE
Related information
Managed COBOL Command Line Compiler Directives
ILASSEMBLY
ILGEN
Key to Compiler Directives


ILOUTPUT

Sets the path of the output assembly file or Java class file.
Restriction: This directive is supported for managed COBOL only.

Syntax:

>>-----.---ILOUTPUT -"output-path"----.----><
       +-NOILOUTPUT-------------------+

Parameters:

output-path
The path of the output assembly file or Java class file.

Properties:

Default: | ILOUTPUT"output-path"
IDE equivalent: | Click Project > Properties > COBOL > Output Path

Comments:

If you need to set the filename of the output assembly file, use the ILASSEMBLY directive.

Parent topic: Application Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
ILASSEMBLY
ILGEN
ILMAIN
Key to Compiler Directives


Code Generation Directives

  • ILARRAYPROPERTY
    Controls the way in which the Compiler generates code for data items that include the PROPERTY phrase, and which either include the OCCURS phrase or are subsidiary to a group item with the OCCURS clause.
  • ILCLR
    Allows a managed program to be compiled for Microsoft's Common Language Runtime (CLR) version 2.0 or 4.0.
  • ILDOC
    Generates documentation in xml format using comments in the code, and puts the documentation in the specified file.
  • ILDYNCALL
    Specifies that CALL literal statements are resolved at run time rather than being resolved at compile time.
  • ILNATIVE
    Exposes COBOL 01 level data items as managed primitives where possible.
  • ILOBJECTIFY
    Deprecated functionality. Supported for backward compatibility only.
  • ILSTATIC
    Exposes the entry points of a COBOL program as static methods for compatibility with previous releases.
  • ILTARGET
    Enables an application to target a specified CPU type.
  • ILVERIFY
    Ensures that the compiled IL code is verifiable.
Parent topic: Managed COBOL Command Line Compiler Directives


ILARRAYPROPERTY

Controls the way in which the Compiler generates code for data items that include the PROPERTY phrase, and which either include the OCCURS phrase or are subsidiary to a group item with the OCCURS clause.
Restriction: This directive is supported for managed COBOL only.

Syntax:

>>----ILARRAYPROPERTY(integer)-----------><

Parameters:

integer
0

The property is generated with a type determined by that of the data element. The property will have a number of parameters equal to the dimensionality of the data item. You can only access these properties using COBOL. Other languages such as C# and Visual Basic will not permit access to such properties with parameters. Use this setting to produce the code generated by earlier versions of this product.

1
01 level arrays of native managed types will be generated as simple properties whose type is that of the array type (not the element type). You can access these properties using other languages. Other data items with OCCURS, or subsidiary to OCCURS, will be generated as for ILARRAYPROPERTY(0).
2
As ILARRAYPROPERTY(1), except that non-native array properties will cause the GET and SET accessors to be generated for the property, but not the property itself. This enables Visual Basic programs to access the property (via the accessor methods).

Properties:

Default: ILARRAYPROPERTY(1)

Example:

Consider the following data structures:
data division.
working-storage section.
01 n1 string OCCURS 10 PROPERTY.
01 group1.
    03 n2 PIC X(9) OCCURS 10 PROPERTY.
  • With ILARRAYPROPERTY(0), n1 and n2 are both exposed as properties of type string, with an int parameter to indicate the occurrence required.
  • With ILARRAYPROPERTY(1), n2 is exposed, as above, but n1 is exposed as a property of type string[ ] (in C# notation).
  • With ILARRAYPROPERTY(2), n1 is exposed, as for ILARRAYPROPERTY(1), but for n2, the Compiler will generate accessor methods get_n2(int) (returning string) and set_n2(string, int), but no actual property.
Parent topic: Code Generation Directives
Parent topic: Compiler Directives - Alphabetical List


ILCLR

Allows a managed program to be compiled for Microsoft's Common Language Runtime (CLR) version 2.0 or 4.0.

Using 2.0 allows the application to be deployed to an environment where only CLR 2.0 is present.

Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-------ILCLR-"number"-----><

Parameters:

number
The version of CLR that can support the compiled program.
2 | Compiles the program for CLR 2.0. Use ILCRL(2) for .NET Framework 3.5 or earlier.
4 | Compiles the program for CLR 4.0. Use ILCLR(4) for .NET Framework 4.

Properties:

Default: | 4
$SET | INITIAL
IDE equivalent: | Click Project > Properties > Application > Target Framework
Parent topic: Code Generation Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILDOC

Generates documentation in xml format using comments in the code, and puts the documentation in the specified file.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.--ILDOC--"filename"--.---><
       +-NOILDOC-------------+

Parameters:

filename The name of the file to contain the documentation comments

Properties:

Default: | ILDOC
IDE equivalent: | Click Project > Properties > COBOL > XML documentation file, and then type the filename
Parent topic: Code Generation Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILDYNCALL

Specifies that CALL literal statements are resolved at run time rather than being resolved at compile time.
Restriction: This directive is supported for managed COBOL only.

Syntax:

>>-.----.---ILDYNCALL---------><
   |    |
   +-NO-+

Parameters:

None

Properties:

Default: | NOILDYNCALL
IDE equivalent: | None. You can specify ILDYNCALL as an additional Compiler directive under Project > Properties > COBOL

Comments:

When ILDYNCALL is specified, all calls in the assembly are resolved at run time. This enables you to use an alias for an entry point in a call, using the entry point mapper.

If you do not need to map any entry points to aliases, avoid using this directive.

Parent topic: Code Generation Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILNATIVE

Exposes COBOL 01 level data items as managed primitives where possible.
Restriction: This directive is supported for managed COBOL only.

When ILNATIVE is specified:

  • Any COBOL level-01 data item that is equivalent to a managed COBOL data type is handled internally as that native type, where possible (see COBOL Type Compatibility)
  • COBOL data items other than level-01 items are stored within byte arrays
  • If a parameter of a PROCEDURE DIVISION USING or ENTRY … USING statement corresponds to a .NET native type, the parameter is exposed as a data item of that type in the method signature for the entry point
  • BY REFERENCE parameters that don't correspond to a managed COBOL data type are exposed as internal type-neutral objects representing the byte array/offset pair of the data item

When ILNATIVE is specified, the Compiler usually converts parameters in the calling program to the appropriate type, by examining the target method signature. This signature is available if the method is in the same source module as the calling program or in a module identified by the ILSOURCE directive or in an assembly identified by an ILREF directive.

Where the called program is not known at compile time or not available until run time, the calling program sets up parameter types based on only the data items in the CALL statement. At run time the types of the parameters might not match those in the target method and this causes the .NET CLR or JVM to raise an exception because it can't convert the data. You can avoid this by specifying the NOILNATIVE directive for both the calling and the called program.

Syntax:

>>-.----.---ILNATIVE----------><
   |    |
   +-NO-+

Parameters:

None

Properties:

Default: | ILNATIVE
IDE equivalent: | None. You can specify ILNATIVE as an additional Compiler directive under Project > Properties > COBOL

Comments:

A COBOL data item that is represented as a managed primative performs significantly better than one that isn't. However, there are some situations where using IL native types is not suitable, such as when the call arguments do not match in dynamic call, or when your program relies on the DEFAULTBYTE Compiler directive initializing an item that will be exposed as an IL native type.

You can avoid these problems by specifying the NOILNATIVE directive when compiling your program.

Example:

The following programs demonstrate a case for compiling with NOILNATIVE:

cmain.cbl

      01 ws-data pic 9(4) comp-5.
       procedure division.
       call “csub” using ws-data.

csub.cbl

       linkage section.
       01 ls-data.
          03 ls-value pic 9(4) comp-5.

       procedure division using ls-data.
          move 100 to ls-value.
          exit program.

Compile the two programs independently, with the default setting of ILNATIVE, using commands such as:

cobol cmain ilgen;
cobol csub ilgen(sub);

When you run the program cmain, an exception is raised at run time due to the different types of the ws-data and ls-data data items.

However, if you specify NOILNATIVE directive for both programs, as follows, both data items will be represented with the same type and so the argument will be successfully passed to the subprogram.

cobol cmain ilgen noilnative;
cobol csub ilgen(sub) noilnative;
Parent topic: Code Generation Directives
Parent topic: Compiler Directives - Alphabetical List
Related reference
DEFAULTBYTE
Related information
Managed COBOL Command Line Compiler Directives
ILGEN
Key to Compiler Directives


ILOBJECTIFY

Deprecated functionality. Supported for backward compatibility only.
Restriction: This directive is supported for .NET COBOL only.
Parent topic: Code Generation Directives
Parent topic: Compiler Directives - Alphabetical List
Related reference
ILSTATIC
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILSTATIC

Exposes the entry points of a COBOL program as static methods for compatibility with previous releases.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-.----.---ILSTATIC----------><
   |    |
   +-NO-+

Parameters:

None

Properties:

Default: | NOILSTATIC
IDE equivalent: | None. You can specify ILSTATIC as an additional Compiler directive under Project > Properties > COBOL

Comments:

When NOILSTATIC is specified, the compiled program is represented as a class with instance methods and instance data. The run-time system maintains a singleton instance of the program in a run unit. A program written in a non-COBOL .NET language can fetch this instance using the CobLoad method in the Interop class of the MicroFocus.COBOL.RuntimeServices assembly and can then invoke methods on the instance directly.

When ILSTATIC is specified, the compiled program is represented as a class with static methods and static data. A program written in a non-COBOL .NET language can call COBOL by invoking the static methods directly. ILSTATIC provides compatibility with a previous release of this product, and should be used only on COBOL programs that are called using static method calls from an existing program written in a non-COBOL .NET language.

Parent topic: Code Generation Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILTARGET

Enables an application to target a specified CPU type.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILTARGET--"CPU-type"--.---><
       +-NOILTARGET--------------+

Parameters:

CPU-type
Indicates the type of CPU and can be:
  • ANYCPU
  • Itanium
  • X64
  • X86

Properties:

Default: | ILTARGET"ANYCPU"
IDE equivalent: | Click Project > Properties > COBOL > Platform Target

Comments:

The main uses of this directive are for performance and for integrating with components that use native platform invokes to access unmanaged code.

Applications compiled with SQL(DBMAN=ODBC) for .NET must be compiled with ILTARGET directive specifying the appropriate platform. You cannot specify ILTARGET(ANYCPU) in this case.

Parent topic: Code Generation Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILVERIFY

Ensures that the compiled IL code is verifiable.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILVERIFY--"check"---.--><
       +-NOILVERIFY------------+

Parameters:

check
Indicates that the resultant assembly is to be checked as verifiable, by running the Microsoft tool PEVERIFY.

Properties:

Default: | NOILVERIFY
IDE equivalent: | None

Comments:

When NOILVERIFY is specified, the IL code produced by the Compiler is not guaranteed to be verifiable. Non-verifiable code is produced for certain COBOL statements where significant performance benefits can be gained by doing so. In particular, this covers some statements involving non-01 level COMP-5 data items, alphanumeric moves, and the setting and use of COBOL POINTERs.

When ILVERIFY is specified, the IL code produced by the Compiler is verifiable. If the “check” option is also specified, the Microsoft tool PEVERIFY.EXE is automatically run on the resultant assembly to confirm the code is verifiable.

If PEVERIFY.EXE is not installed, a COBCH1585 Could not find peverify.exe, required for ILVERIFY(CHECK) error is produced. You can download and install this tool as part of the .NET Framework Tools package.

Verifiable code is a requirement for certain kinds of .NET applications, such as SQL stored procedures.

Parent topic: Code Generation Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


Reference, Resource and Namespace Directives

  • ILICON
    Adds the specified icon to the output program.
  • ILNATIVERESOURCE
    The resource file you specify will be included in the resulting output file.
  • ILPINVOKE
    Makes the specified unmanaged code available, so that the entry points in the unmanaged code are available to the program being compiled. See the Visual Studio Help topic Calling Native Functions from Managed Code.
  • ILREF
    This directive makes the Visual Studio Framework classes in the specified assembly available to the program being compiled.
  • ILRESOURCE
    Specifies a resource file to embed in the assembly file when it is culture neutral.
  • ILSOURCE
    Specifies an additional COBOL source file to be compiled together with the current program into a single .NET assembly or Java class file.
  • ILSTACKSIZE
    Sets the size of the stack when the program is run.
  • ILSUBSYSTEM
    Specifies the subsystem directive to the MSIL Assembler (ilasm.exe). See the Visual Studio Help topic MSIL Assembler (ilasm.exe).
  • ILUSING
    Specifies the namespace for a class to be imported. This directive enables you to write just the class name in the program code, without its namespace, potentially making the code shorter and simpler.
Parent topic: Managed COBOL Command Line Compiler Directives


ILICON

Adds the specified icon to the output program.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILICON---"icon-filename"--.---><
       +-NOILICON--------------------+

Parameters:

icon filename
Name of the icon file with the extension .ico.

Properties:

Default: | NOILICON
IDE equivalent: | Click Project > Properties > Resources > Add Resource, and then either select an existing file or create a new icon.

Comments:

The icon represents the output file in Windows Explorer.

Parent topic: Reference, Resource and Namespace Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILNATIVERESOURCE

The resource file you specify will be included in the resulting output file.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILNATIVERESOURCE---"resource-file"----.--><
       +-NOILNATIVERESOURCE----------------------+

Parameters:

resource-file Name of the native resource file, with file extension .res, to be used as part of the compilation process.

Properties:

Default | NOILNATIVERESOURCE
IDE equivalent | Click Project > Properties > Application > Resource File and enter the name of the resource file.

Comments:

You can specify only one resource file.

Parent topic: Reference, Resource and Namespace Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILPINVOKE

Makes the specified unmanaged code available, so that the entry points in the unmanaged code are available to the program being compiled. See the Visual Studio Help topic Calling Native Functions from Managed Code.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>------.----ILPINVOKE--"unmanaged-dll"--.---><
        +--NOILPINVOKE-------------------+

Parameters:

unmanaged-dll
The name of the .dll containing the unmanaged code that is required

Properties:

Default: | NOILPINVOKE
IDE equivalent: | Add a reference to the unmanaged .dll to the References folder of the solution
Parent topic: Reference, Resource and Namespace Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
ILREF
ILRESOURCE
Key to Compiler Directives


ILREF

This directive makes the Visual Studio Framework classes in the specified assembly available to the program being compiled.
Restriction: This directive is supported for managed COBOL only.

Syntax:

>>-----.---ILREF--"parameter"---.--><
       +-NOILREF----------------+

Parameters:

assembly-name
The name of the assembly that contains the required classes

Properties:

Default: | ILREF"assembly-name" (IDE default) or NOILREF (command line default)NOILREF
IDE equivalent: | Add a reference in the References folder of the solution
Parent topic: Reference, Resource and Namespace Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
ILPINVOKE
ILRESOURCE
Key to Compiler Directives


ILRESOURCE

Specifies a resource file to embed in the assembly file when it is culture neutral.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILRESOURCE--"resource-file"---.--><
       +-NOILRESOURCE-------------------+

Parameters:

resource-file
The filename of the resource file to embed in the assembly

Properties:

Default: | NOILRESOURCE
IDE equivalent: | Add a reference to the resources file in the References folder of the solution

Comments:

You can use resource files in culture neutral assemblies to contain such data as graphics (icons and cursors) or text strings.

Parent topic: Reference, Resource and Namespace Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
ILREF
ILPINVOKE
Key to Compiler Directives


ILSOURCE

Specifies an additional COBOL source file to be compiled together with the current program into a single .NET assembly or Java class file.
Restriction: This directive is supported for managed COBOL only.

Syntax:

>>-----.---ILSOURCE---"cobolsourcefile"---.--><
       +-NOILSOURCE-----------------------+

Parameters:

cobolsourcefile
The filename of the additional COBOL source file to be compiled

Properties:

Default: | NOILSOURCE
IDE equivalent: | Add the additional source file to the solution

Comments:

Each program specified in an ILSOURCE directive is treated as a separate COBOL program, but the compilation results in a single .exe or .dll file.

Parent topic: Reference, Resource and Namespace Directives
Parent topic: Compiler Directives - Alphabetical List
Related reference
ILNAMESPACE
Related information
Managed COBOL Command Line Compiler Directives
ILASSEMBLY
ILREF
ILRESOURCE
Key to Compiler Directives


ILSTACKSIZE

Sets the size of the stack when the program is run.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>----.---ILSTACKSIZE"size"---.------><
      +-NOILSTACKSIZE---------+

Parameters:

size
The size, in bytes, allocated to the stack.

Properties:

Default: | NOILSTACKSIZE
IDE equivalent: | None

Comments:

If no size is set using this directive, the default stack size under the .NET framework is 1MB.

Parent topic: Reference, Resource and Namespace Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILSUBSYSTEM

Specifies the subsystem directive to the MSIL Assembler (ilasm.exe). See the Visual Studio Help topic MSIL Assembler (ilasm.exe).
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.--ILSUBSYSTEM--"value"-.----><
       +-NOILSUBSYSTEM---------+

Parameters:

value
Indicates the output type of the assembly. 2 (Windows application) is the only valid value.

Properties:

Default: | NOILSUBSYSTEM
IDE equivalent: | Click Project > Properties > Application and fill in Output Type
Parent topic: Reference, Resource and Namespace Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
ILREF
ILPINVOKE
ILRESOURCE
Key to Compiler Directives


ILUSING

Specifies the namespace for a class to be imported. This directive enables you to write just the class name in the program code, without its namespace, potentially making the code shorter and simpler.
Restriction: This directive is supported for managed COBOL only.

Syntax:

>>---.---ILUSING---"namespace"--.---><
     +-NOILUSING----------------+

Parameters:

namespace
The name of a namespace to be imported into the program.

Properties:

Default: | For the IDE default, see the selected namespaces in the project's properties. Click Project > Properties > ReferencesThe command line default is NOILUSING . Note: Specifying NOILUSING clears any settings that are in effect as a result of previous ILUSING directives.
IDE equivalent: | Click Project > Properties > References and use Add Namespace in the Imported Namespaces section.
$SET: | Initial.

Examples:

When referring to a class whose name begins with the specified namespace (or one of the specified namespaces if there are multiple ILUSING directives), the namespace may be omitted. For example:

01 d1 type System.DateTime.

Is equivalent to:

$set ilusing"System"
01 d1 type DateTime.

Note that the complete namespace must be specified in an ILUSING directive for it to be effective.

For example:

$set ilusing"System"
01 f1 type System.Windows.Forms.Form.   *> this is OK
01 f2 type Windows.Forms.Form.          *> this does not work

However, this does work:

$set ilusing"System.Windows.Forms"

01 f1 type Form.

Comments:

You can add this directive more than once, to add multiple namespaces to your programs.

Parent topic: Reference, Resource and Namespace Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


Strong Naming Directives

  • ILDELAYSIGN
    Indicates whether to reserve space in the assembly for the strong name signature, or to defer the actual signing until later.
  • ILKEYFILE
    Specifies a key file, which contains a key or public/private key pair for strong naming an assembly.
  • ILKEYNAME
    Specifies the container of a key or key pair that has been installed in the Crypto Service Provider (CSP).
Parent topic: Managed COBOL Command Line Compiler Directives


ILDELAYSIGN

Indicates whether to reserve space in the assembly for the strong name signature, or to defer the actual signing until later.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-.----.--ILDELAYSIGN--------><
   +-NO-+

Parameters:

None

Properties:

Default: | NOILDELAYSIGN
IDE equivalent: | Click Project > Properties > Application > Assembly Information and check Delay Sign
Assembly manifest attribute: | System.Reflection.AssemblyDelaySign

Comments:

When signing is delayed, only the public key is set. See the Visual Studio Help topic Delay Signing for more information.

You can specify the keys for signing the assembly using the ILKEYFILE or ILKEYNAME directive.

Parent topic: Strong Naming Directives
Parent topic: Compiler Directives - Alphabetical List


ILKEYFILE

Specifies a key file, which contains a key or public/private key pair for strong naming an assembly.

Syntax:

Restriction: This directive is supported for .NET COBOL only.
>>-----.---ILKEYFILE--"keyfile"--.---><
       +-NOILKEYFILE-------------+

Parameters:

keyfile
The name of the key file

Properties:

Default: | NOILKEYFILE
IDE equivalent: | Click Project > Properties > Application > Assembly Information and fill in Key File
Assembly manifest attribute: | System.Reflection.AssemblyKeyFile

Comments:

The Compiler sets the public key in the assembly manifest and signs the final assembly with the private key. See the Visual Studio Help topic Strong-Name Assemblies (Assembly Signing) for more information.

To generate the key file, use the .NET sn.exe utility.

You can alternatively specify the keys using the ILKEYNAME directive. You can also partially sign the assembly using the ILDELAYSIGN directive.

Parent topic: Strong Naming Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
ILDELAYSIGN
ILKEYNAME
ILMAIN
Key to Compiler Directives


ILKEYNAME

Specifies the container of a key or key pair that has been installed in the Crypto Service Provider (CSP).
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>------.---ILKEYNAME--"keycontainer"--.---><
        +-NOILKEYNAME------------------+

Parameters:

keycontainer
The name of the container that contains the key

Properties:

Default: | NOILKEYNAME
IDE equivalent: | Click Project > Properties > Application > Assembly Information and fill in Key Name
Assembly manifest attribute | System.Reflection.AssemblyKeyName

Comments:

The key or key pair in the key container is used for strong naming an assembly. The Compiler sets the public key in the assembly manifest and signs the final assembly with the private key. See the Visual Studio Help topic Strong-Name Assemblies (Assembly Signing) for more information.

You can alternatively specify the keys using the ILKEYFILE directive. You can also partially sign the assembly using the ILDELAYSIGN directive.

Parent topic: Strong Naming Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
ILKEYFILE
ILDELAYSIGN
ILMAIN
Key to Compiler Directives


Identity, Information and Manifest Directives

  • ILCOMPANY
    Defines the company name custom attribute in the assembly manifest.
  • ILCOPYRIGHT
    Defines the copyright custom attribute in the assembly manifest.
  • ILCULTURE
    Defines the culture custom attribute in the assembly manifest.
  • ILDESCRIPTION
    Defines the description attribute in the assembly manifest.
  • ILFILEVERSION
    Instructs the compiler to use a specific version number for the Win32 file version.
  • ILMANIFEST
    Selects a manifest generation option when the application runs on Windows Vista under User Account Control (UAC).
  • ILPRODUCT
    Defines the product name custom attribute in the assembly manifest.
  • ILPRODUCTVERSION
    Instructs the compiler to use a specific version number for the Win32 product file version.
  • ILTITLE
    Defines the title custom attribute in the assembly manifest.
  • ILTRADEMARK
    Defines the trademark custom attribute in the assembly manifest.
  • ILVERSION
    Specifies the version of the assembly.
Parent topic: Managed COBOL Command Line Compiler Directives


ILCOMPANY

Defines the company name custom attribute in the assembly manifest.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>------.---ILCOMPANY--"companyname"--.---><
        +-NOILCOMPANY-----------------+

Parameters:

companyname The name of your company for the assembly

Properties:

Default: | NOILCOMPANY
IDE equivalent: | Click Project > Properties > Application > Assembly Information and fill in Company
Assembly manifest attribute: | System.Reflection.AssemblyCompany
Parent topic: Identity, Information and Manifest Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILCOPYRIGHT

Defines the copyright custom attribute in the assembly manifest.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.-----ILCOPYRIGHT--"copyright"--.---><
       +---NOILCOPYRIGHT---------------+

Parameters:

copyright The copyright statement for the assembly

Properties:

Default: | NOILCOPYRIGHT
IDE equivalent: | Click Project > Properties > Application > Assembly Information and fill in Copyright
Assembly manifest attribute: | System.Reflection.AssemblyCopyright
Parent topic: Identity, Information and Manifest Directives
Parent topic: Compiler Directives - Alphabetical List


ILCULTURE

Defines the culture custom attribute in the assembly manifest.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.----ILCULTURE--"culture"--.---><
       +--NOILCULTURE-------------+

Parameters:

culture The culture statement for the assembly

Properties:

Default: | NOILCULTURE
IDE equivalent: | Click Project > Properties > Application > Assembly Information and fill in Culture
Assembly manifest attribute: | System.Reflection.AssemblyCulture
Parent topic: Identity, Information and Manifest Directives
Parent topic: Compiler Directives - Alphabetical List


ILDESCRIPTION

Defines the description attribute in the assembly manifest.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILDESCRIPTION--"descriptiontext"--.---><
       +-NOILDESCRIPTION---------------------+

Parameters:

descriptiontext The text of the description for the assembly

Properties:

Default: | NOILDESCRIPTION
IDE equivalent: | Click Project > Properties > Application > Assembly Information and under Assembly Manifest Attributes, fill in Description
Assembly manifest attribute: | System.Reflection.AssemblyDescription
Parent topic: Identity, Information and Manifest Directives
Parent topic: Compiler Directives - Alphabetical List


ILFILEVERSION

Instructs the compiler to use a specific version number for the Win32 file version.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILFILEVERSION---"version"--.---><
       +-NOILFILEVERSION--------------+

Parameters:

version
The version number to be assigned to the output file.

Properties:

Default | NOILFILEVERSION
IDE equivalent | Click Project > Properties > Application > Assembly Information and fill in the File Version.

Comments:

The version number should be expressed as four integers separated by . (periods). For example:

 2.0.0.0.

This directive instructs the compiler to use a specific version number for the Win32 file version. The file version is not required to be the same as the assembly version number, which is set by the ILVERSION directive.

This directive also has the effect of setting up the assembly attribute System.Reflection.AssemblyFileVersionAttribute with the given value.

Parent topic: Identity, Information and Manifest Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives
ILVERSION


ILMANIFEST

Selects a manifest generation option when the application runs on Windows Vista under User Account Control (UAC).
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.--ILMANIFEST--"filename"--.---><
       +-NOILMANIFEST-------------+

Parameters:

filename
The name of a manifest file with extension .manifest.

Properties:

Default: | ILMANIFEST
IDE equivalent: | Click Project > Properties >Application and under Resources, select the Manifest.

Comments:

The default option is to use ILMANIFEST without a file name to support the typical manner in which an application operates on Windows Vista. This will embed security information in the application’s executable file, specifying that requestedExecutionLevel be AsInvoker.

Use NOILMANIFEST for compatibility with earlier applications. Use ILMANFEST”filename” if you want to specify your own application manifest.

Parent topic: Identity, Information and Manifest Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILPRODUCT

Defines the product name custom attribute in the assembly manifest.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILPRODUCT--"product-text"--.---><
       +-NOILPRODUCT------------------+

Parameters:

producttext
The name of the product

Properties:

Default: | NOILPRODUCT
IDE equivalent: | Click Project > Properties > Application > Assembly Information and fill in Product
Assembly manifest attribute: | System.Reflection.AssemblyProduct
Parent topic: Identity, Information and Manifest Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILPRODUCTVERSION

Instructs the compiler to use a specific version number for the Win32 product file version.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILPRODUCTVERSION---"version"--.---><
       +-NOILPRODUCTVERSION--------------+

Parameters:

version
The product version number to be assigned to the output file.

Properties:

Default | NOILPRODUCTVERSION
IDE equivalent | None

Comments:

The version number should be expressed as four integers separated by .(periods). For example:

 2.0.0.0.

If ILPRODUCTVERSION is not specified, the product file version will be the same as the file version (see ILFILEVERSION directive).

This directive has the effect of setting up the assembly attribute System.Reflection.InformationalVersionAttribute with the given value.

This directive also has the effect of:

  1. setting the product file version string
  2. setting the binary product file version
Parent topic: Identity, Information and Manifest Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives
ILFILEVERSION


ILTITLE

Defines the title custom attribute in the assembly manifest.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-.----.----ILTITLE--"titletext"--.---><
        +--NOILTITLE---------------+

Parameters:

titletext
The title of the assembly

Properties:

Default: | NOILTITLE
IDE equivalent: | Click Project > Properties > Application > Assembly Information and fill in Title
Assembly manifest attribute: | System.Reflection.AssemblyTitle
Parent topic: Identity, Information and Manifest Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILTRADEMARK

Defines the trademark custom attribute in the assembly manifest.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILTRADEMARK--"trademarktext"---.--><
       +-NOILTRADEMARK--------------------+

Parameters:

trademarktext
Text of the trademark information for the assembly.

Properties:

Default: | NOILTRADEMARK
IDE equivalent: | Click Project > Properties > Application > Assembly Information and fill in Trademark
Assembly manifest attribute: | System.Reflection.AssemblyTrademark
Parent topic: Identity, Information and Manifest Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


ILVERSION

Specifies the version of the assembly.
Restriction: This directive is supported for .NET COBOL only.

Syntax:

>>-----.---ILVERSION--"version"---.--><
       +-NOILVERSION--------------+

Parameters:

version
The version of the assembly.

Properties:

Default: | ILVERSION"version"
IDE equivalent: | Click Project > Properties > Application > Assembly Information and fill in Assembly Version

Comments:

The version numbers should be expressed as four integers separated by . (periods) for example:

2.0.0.0

You can use wildcards for the third and fourth component of the version number.

Parent topic: Identity, Information and Manifest Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Managed COBOL Command Line Compiler Directives
Key to Compiler Directives


Object Code, Size, and Optimization

These directives change the object code produced without changing the logic of your program.

  • Object Code - External Handlers
  • Object Code - File Handling
  • Object Code - Interprogram Communication
  • Object Code - Size and Speed
Parent topic: Compiler Directives


Object Code - External Handlers

  • CALLFH
    Makes the Compiler generate direct calls for all file I/O operations, using the Callable File Handler interface.
  • CALLMCS
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • CALLSORT
    Defines the program to be called to handle all SORT and MERGE operations.
Parent topic: Object Code, Size, and Optimization


CALLMCS

This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.

Causes all Message Control System operations to be routed through the specified handler.

Syntax:

>>-.---.-.-------CALLMCS--"mcs-name"--.-----><
   +-/-+ +.----.-CALLMCS--------------+
          +-NO-+

Parameters:

mcs-name Root-name of a program to be called to process message control system (MCS) operations.

Properties:

Default: | NOCALLMCS
Phase: | Syntax check
$SET: | Initial

Comments:

If mcs-name is not specified, EXTMCS is assumed.

Parent topic: Object Code - External Handlers
Parent topic: Compiler Directives - Alphabetical List


Object Code - File Handling

  • WRITETHROUGH, WRITETHRU
    Specifies that disk writes are not to be buffered.
Parent topic: Object Code, Size, and Optimization


Object Code - Interprogram Communication

  • LITLINK
    Makes the Compiler declare the literals in CALL literal statements as public symbols, so they are resolved at link time rather than run time. (Calls generated in this way are referred to as litlinked.)
  • LITVAL-SIZE
    Specifies the number of bytes to pass if the SIZE clause is omitted when passing numeric literals BY VALUE.
  • RTNCODE-SIZE
    Specifies the size of the RETURN-CODE special register and its alignment in memory.
  • PPLITLINK
    Makes the Compiler declare literals as public symbols, in a SET statement using a data item defined as USAGE IS PROCEDURE-POINTER. This means literals are resolved at link time rather than run time. (Symbol references defined in this way are referred to as litlinked.)
Parent topic: Object Code, Size, and Optimization


LITLINK

Makes the Compiler declare the literals in CALL literal statements as public symbols, so they are resolved at link time rather than run time. (Calls generated in this way are referred to as litlinked.)
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.-----LITLINK-.-----------.-.-----><
   +-/-+ |             +-"integer"-+ |
         +-NOLITLINK-----------------+

Parameters:

integer
Must be 1 or 2.

Properties:

Default: | NOLITLINK
Phase: | Generate
$SET: | Initial

Comments:

This directive only affects object code files.

With LITLINK"2", if the name in a CALL literal statement starts with a single underscore - "_name" - a litlinked call to entry-name _name is generated. If it starts with a double underscore - "__name", a litlinked call to entry-name name is generated. (That is the entry-names are declared as public symbols.)

With LITLINK or LITLINK"1", all CALL literal statements generate litlinked calls, regardless of the inclusion of underscores at the start of the literal.

With NOLITLINK, no CALL literal statements generate litlinked calls, regardless of the inclusion of underscores at the start of the literal.

LITLINK"2" is only intended to provide backward compatibility with code written for the 16-bit COBOL system. You should use call-convention 8 for new programs.

Parent topic: Object Code - Interprogram Communication
Parent topic: Compiler Directives - Alphabetical List


LITVAL-SIZE

Specifies the number of bytes to pass if the SIZE clause is omitted when passing numeric literals BY VALUE.

Syntax:

>>-.---.--LITVAL-SIZE--"integer"-----------><
   +-/-+

Parameters:

integer A number up to 4. The number of bytes to pass.

Properties:

Default: | LITVAL-SIZE"4"
Phase: | Syntax check
$SET: | Any
Parent topic: Object Code - Interprogram Communication
Parent topic: Compiler Directives - Alphabetical List
Related information
Object Code - Interprogram Communication
The Object-Computer Paragraph
File Description Entry Skeleton
The RECORD Clause
Screen Section Entry Skeleton
The SIZE Clause
The ACCEPT Statement
The ADD Statement
The CALL Statement
The CHAIN Statement
The COMPUTE Statement
The DISPLAY Statement
The DIVIDE Statement
The ENTRY Statement
The INVOKE Statement
The MULTIPLY Statement
The SET Statement
The START Statement
The STOP Statement
The STRING Statement
The SUBTRACT Statement
The COPY Statement
The REPLACE Statement
Data Description Entry Skeleton
The EXTERNAL Clause
The OCCURS Clause
The PROCEDURE DIVISION Header
The EXAMINE Statement
The INITIALIZE Statement
The INSPECT Statement
The PERFORM Statement
The UNSTRING Statement
XML Syntax - IDENTIFIED BY Clause
The VALUE Clause
The VALUE OF Clause
The VALUE Clause in the Screen Section
The VALUE Clause (Report Writer)
Key to Compiler Directives


RTNCODE-SIZE

Specifies the size of the RETURN-CODE special register and its alignment in memory.

Syntax:

>>-.---.--RTNCODE-SIZE--"integer"----------><
   +-/-+

Parameters:

integer
One of:
2
PIC S9(4) COMP: size 2 bytes, aligned on a two-byte boundary.
4
PIC S9(9) COMP: size 4 bytes, aligned on a four-byte boundary.
8
PIC S9(18) COMP: size 8 bytes, aligned on an eight-byte boundary.

Properties:

Default: | RTNCODE-SIZE"4"
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to RTNCODE-SIZE"4" immediately by XOPEN.

If a program with a four-byte RETURN-CODE calls a program with a two-byte RETURN-CODE, on return the value from the called program is in the lower two bytes of the four-byte RETURN-CODE. The content of the upper two bytes is undefined.

If a program with an eight-byte RETURN-CODE calls a program with a four-byte RETURN-CODE, on return the value from the called program is in the lower four bytes of the eight-byte RETURN-CODE. The content of the upper four bytes is undefined.

When one program calls another, it is not necessary that the size of their RETURN-CODE registers match. If the calling program's RETURN-CODE register is larger than the called program's RETURN-CODE register, then any remaining bytes the calling program's register are undefined. For example, if a program with a two-byte RETURN-CODE calls a program with a four-byte RETURN-CODE, on return the lower two bytes of the value from the called program are in the two-byte RETURN-CODE. The content of the upper two bytes is lost.

If the calling program's RETURN-CODE register is smaller than the called program's RETURN-CODE register, then any bytes that cannot fit into the calling program's register are lost. For example, if a program with a four-byte RETURN-CODE calls a program with a eight-byte RETURN-CODE, on return the lower four bytes of the value from the called program are in the four-byte RETURN-CODE. The content of the upper four bytes is lost.

Parent topic: Object Code - Interprogram Communication
Parent topic: Compiler Directives - Alphabetical List


PPLITLINK

Makes the Compiler declare literals as public symbols, in a SET statement using a data item defined as USAGE IS PROCEDURE-POINTER. This means literals are resolved at link time rather than run time. (Symbol references defined in this way are referred to as litlinked.)
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.------PPLITLINK-------.-----><
   +-/-+ +-----NOPPLITLINK------+

Parameters:

None.

Properties:

Default: | Current PPLITLINK setting
Phase: | Generate
$SET: | Initial

Comments:

This directive only affects object code files.

With NOPPLITLINK, literals are not declared as public symbols for SET statements that use a data item defined as USAGE IS PROCEDURE-POINTER.

Parent topic: Object Code - Interprogram Communication
Parent topic: Compiler Directives - Alphabetical List


Object Code - Size and Speed

  • CHECK
    Turns on all run-time checks in generated code.
  • FASTCALL
    Controls the behavior of a called program. If FASTCALL is specified, the program does not set up information to allow it to determine whether it is a main program. The program always assumes that it is not a main program, and EXIT PROGRAM will always cause an exit to the calling program.
  • FASTINIT
    Turns on fast INITIALIZE of tables. FASTINIT renders as undefined any table contents that a normal INITIALIZE statement would not change.
  • FIXOPT
    Changes the way in which generated code accesses the Data Division in object (.obj) code.
  • HOSTSIGNS
    Allows arithmetic and moves with COMP-3 items with illegal sign nibbles (such as those produced by a redefinition of the item) to produce the desired result.
  • LINKCHECK
    Specifies that each time a Linkage Section item is referenced a check is to be made that it exists.
  • LNKALIGN
    Indicates that level-01 and level-77 Linkage Section items are always aligned on a machine-dependent favorable boundary.
  • OPT (Intel x86 platforms)
    Specifies the level of optimization of the code produced by the compiler.
  • OPT (Non-Intel x86 platforms)
    Specifies the level of optimization of the code produced in the object code file. Use this version of the OPT directive on operating systems that use chips other than the Intel x86 chip, for example, AIX, Solaris Sparc, HP-UX, IA64 (this list is not exhaustive).
  • PARAMCOUNTCHECK
    Enables the program to be called with fewer parameters than are specified in the relevant entry point's USING clause.
  • RECURSECHECK
    Turns on checking for recursion in generated code.
  • SCHEDULER
    Controls the invocation of the Intel COBOL Optimizer.
  • SEG
    Turns on COBOL segmentation.
Parent topic: Object Code, Size, and Optimization


CHECK

Turns on all run-time checks in generated code.
Note: This directive is supported for native COBOL only.

Syntax:

>>--.----.---CHECK------------------><
    +-NO-+

Parameters:

None

Properties:

Default: | None
Phase: | Generator
$SET: | Initial

Dependencies:

CHECK sets BOUND, LINKCHECK, PARAMCOUNTCHECK and RECURSECHECK immediately. NOCHECK sets NOBOUND, NOLINKCHECK, NOPARAMCOUNTCHECK and NORECURSECHECK immediately.

Comments:

CHECK turns on all run-time checks in generated code. The run-time checks include checks for:

  • Divide-by-zero
  • Calling invalid (that is NULL) procedure-pointers
  • Recursion of non-recursive programs

NOCHECK turns off all run-time checks in generated code.

Parent topic: Object Code - Size and Speed
Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List


FASTINIT

Turns on fast INITIALIZE of tables. FASTINIT renders as undefined any table contents that a normal INITIALIZE statement would not change.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--FASTINIT------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOFASTINIT
Phase: | Check
$SET: | Initial
Parent topic: Object Code - Size and Speed
Parent topic: Compiler Directives - Alphabetical List
Related information
Key to Compiler Directives
INITIALIZE Statement


HOSTSIGNS

Allows arithmetic and moves with COMP-3 items with illegal sign nibbles (such as those produced by a redefinition of the item) to produce the desired result.
Note: This directive is supported for native COBOL only.
Note:

This directive is deprecated and may be removed in a future product. Use the checker options SIGN-FIXUP, HOST-NUMMOVE, and HOST-NUMCOMPARE instead.

Syntax:

>>-.---.-.----.---HOSTSIGNS------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOHOSTSIGNS
Phase: | Generate
$SET: | Initial

Comments:

Specifying HOSTSIGNS causes COMP-3 arithmetic to be performed by a non-optimized route, reducing the efficiency of your programs.

For smaller, faster code you should not specify HOSTSIGNS.

Parent topic: Object Code - Size and Speed
Parent topic: Compiler Directives - Alphabetical List


LINKCHECK

Specifies that each time a Linkage Section item is referenced a check is to be made that it exists.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--LINKCHECK-----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOLINKCHECK
Phase: | Generate
$SET: | Initial

Dependencies:

Set to LINKCHECK by CHECK.

Comments:

If you set this directive, then for any reference to a Linkage Section item that does not exist a run-time error 203 (CALL parameter not supplied) is generated.

Parent topic: Object Code - Size and Speed
Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List


LNKALIGN

Indicates that level-01 and level-77 Linkage Section items are always aligned on a machine-dependent favorable boundary.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--LNKALIGN------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOLNKALIGN
Phase: | Generate
$SET: | No

Comments:

Using LNKALIGN can reduce the time needed to access a linkage item at run time. However, take care when using it. You must use the correct ALIGN directive setting when compiling your program. No checks are made to ensure that the items are aligned.

The results of using this directive are machine-dependent, and you should not use it if you are in any doubt as to its effect. Unpredictable results might occur if you pass linkage items that are not aligned.

Parent topic: Object Code - Size and Speed
Parent topic: Compiler Directives - Alphabetical List


OPT (Intel x86 platforms)

Specifies the level of optimization of the code produced by the compiler.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.--OPT--"integer"-------------------><
   +-/-+

Parameters:

integer
The level of optimization; one of:
1
Minimal optimization.
2
Default optimization.
3
Additional optimization - particularly of STRING, UNSTRING and INSPECT. This option increases the time taken to generate a program in comparison to the default optimization.
4
Optimized as for option 3, but in addition the code is scheduled. This option increases the time taken to generate a program in comparison to option 3.

Properties:

Default: | OPT"2"
Phase: | Generate
$SET: | Any

Dependencies:

If no other OPT level is specified, set to OPT"1" at end by ANIM.

Comments:

OPT is the equivalent of OPT"3".

Debugging code compiled with an OPT level greater than 1 can be difficult, as compiler optimizations reorganize instructions derived from your source in such a way that, for example, Step might appear to jump statements or execute statements out of order, and Query and Modify might not work as expected.

Parent topic: Object Code - Size and Speed
Parent topic: Compiler Directives - Alphabetical List
Related information
ANIM
Object Code - Size and Speed
Key to Compiler Directives


OPT (Non-Intel x86 platforms)

Specifies the level of optimization of the code produced in the object code file. Use this version of the OPT directive on operating systems that use chips other than the Intel x86 chip, for example, AIX, Solaris Sparc, HP-UX, IA64 (this list is not exhaustive).

Syntax:

>>-.---.--OPT--"integer"-------------------><
   +-/-+

Parameters:

integer
The level of optimization; one of:
1 | Minimal optimization.
2 | Default optimization.
3 | Additional optimization - particularly of STRING, UNSTRING and INSPECT. This option increases the time taken to generate a program in comparison to the default optimization.

Properties:

Default: | OPT"2"
Phase: | Generate
$SET: | Any

Dependencies:

Set to OPT"1" at end by ANIM.

Comments:

OPT"3" provides global optimisation; this means that the entire program is examined as a whole during optimisation, rather than successive small portions of it.

Compiling with OPT"3" can take considerably longer than with OPT"2".

If you request optimization of a large program, compilation might fail because there is insufficient memory. If this happens, repeat the compilation with OPT"2" specified.

OPT is the equivalent of OPT"3".

Parent topic: Object Code - Size and Speed
Parent topic: Compiler Directives - Alphabetical List
Related information
ANIM
Object Code - Size and Speed
Key to Compiler Directives


PARAMCOUNTCHECK

Enables the program to be called with fewer parameters than are specified in the relevant entry point's USING clause.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--PARAMCOUNTCHECK-----------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | PARAMCOUNTCHECK
Phase: | Generate
$SET: | Initial

Comments:

You must use this directive if any of the following apply:

  • The program is called with a variable number of parameters.
  • The program contains a Linkage Section, and is to be used both as a main program run from the command line and as a subprogram called from another program.
  • The program is compiled with STICKY-LINKAGE"2" specified.

Otherwise the program can be compiled with NOPARAMCOUNTCHECK for efficiency. A program to be called from a language other than COBOL must be compiled with NOPARAMCOUNTCHECK.

Parent topic: Object Code - Size and Speed
Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List
Related information
LINKCHECK
STICKY-LINKAGE
Run-time Behavior - Speed or Size
The ENTRY Statement
The SET Statement
ENTRY Statement Restrictions
The INVOKE Statement
The PROCEDURE DIVISION Header
The MERGE Statement
The SORT Statement
The USE Statement
The XML PARSE Statement
The CALL Statement
The CHAIN Statement
General Description
Linkage Section


RECURSECHECK

Turns on checking for recursion in generated code.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--RECURSECHECK------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NORECURSECHECK
Phase: | Generate
$SET: | Initial
Parent topic: Object Code - Size and Speed
Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List


SCHEDULER

Controls the invocation of the Intel COBOL Optimizer.
Restriction:

This directive is supported for native COBOL only.

This directive is supported for 32-bit x86 platforms only.

Syntax:

>>-.---.-.----.--SCHEDULER-----------------><
   +-/-+ +-NO-+

Parameters:

None.

Properties:

Default: | NOSCHEDULER
Phase: | Generate
$SET: | Initial

Dependencies:

Set to NOSCHEDULER immediately by ANIM.

Comments:

This directive controls the invocation of the Intel COBOL Optimizer (Copyright Intel 1994-1996) which applies further optimizations to the generated code produced by the Micro Focus compiler. Use this directive if you want to further improve the performance of your applications.

The use of the SCHEDULER directive produces code that cannot be debugged using the debugger. As a result, selecting the ANIM directive during code generation results in SCHEDULER being switched off.

Parent topic: Object Code - Size and Speed
Parent topic: Compiler Directives - Alphabetical List


Report Writer

This directive affects the way the Report Writer control module behaves:

  • REPORT-LINE
    Specifies the maximum length of a Report Writer line.
  • RWHARDPAGE
    Causes the Report Writer control module to execute a form feed after the last item has been printed on a page, instead of the usual multiple blank lines. This ensures that the paper is positioned correctly ready for a new page.
Parent topic: Compiler Directives


REPORT-LINE

Specifies the maximum length of a Report Writer line.

Syntax:

>>-.---.-.-----REPORT-LINE--"integer"-.----><
   +-/-+ +-NO--REPORT-LINE------------+

Parameters:

integer The maximum length, in characters.

Properties:

Default: | REPORT-LINE"256"(Dialect)
Phase: | Syntax check
$SET: | Initial
Parent topic: Report Writer
Parent topic: Compiler Directives - Alphabetical List


RWHARDPAGE

Causes the Report Writer control module to execute a form feed after the last item has been printed on a page, instead of the usual multiple blank lines. This ensures that the paper is positioned correctly ready for a new page.

Syntax:

>>-.---.-.----.--RWHARDPAGE-----------------><
   +-/-+ +-NO-+

Parameters:

None.

Properties:

Default: | NORWHARDPAGE
Phase: | Syntax check
$SET: | Initial

Comments:

If you use the CODE IS clause with this directive, the 2-character code does not extend all the way to the end of the page.

Parent topic: Report Writer
Parent topic: Compiler Directives - Alphabetical List


Reserved Directives

These directives are reserved or are maintained for compatibility with earlier products and have no effect. Do not use them.

  • CANCEL
    This directive may appear in source code supplied by Micro Focus. NOCANCEL stops sub-programs being canceled by the RTS for CANCEL and CHAIN statements and other circumstances when the main user application is canceled.
  • CSI
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • ENSUITE
    Reserved for internal use only.
  • FASTSORT
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • FCD3
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • LOCALCOUNT
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • P64
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • WB
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • WB2
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • WB3
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
Parent topic: Compiler Directives


CANCEL

This directive may appear in source code supplied by Micro Focus. NOCANCEL stops sub-programs being canceled by the RTS for CANCEL and CHAIN statements and other circumstances when the main user application is canceled.

Syntax:

>>-.---.-.----.--CANCEL-----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | CANCEL
Phase: | Syntax check
$SET: | Any

Comments:

NOCANCEL stops programs being canceled.

This directive is reserved for Micro Focus internal use.

Parent topic: Reserved Directives
Parent topic: Compiler Directives - Alphabetical List
Related information
Creating Your Own File Handler
Dynamic Redirection to a Custom File Handler


CSI

This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.

Syntax:

>>-.---.-.----.--CSI-----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | CSI
Phase: | Syntax check
$SET: | Initial

Dependencies:

CSI sets ANIM at end.

Parent topic: Reserved Directives
Parent topic: Compiler Directives - Alphabetical List


ENSUITE

Reserved for internal use only.

Parent topic: Reserved Directives
Parent topic: Compiler Directives - Alphabetical List


FASTSORT

This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.

Syntax:

>>-.---.-.----.--FASTSORT------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | FASTSORT
Phase: | Syntax check
$SET: | Initial
Parent topic: Reserved Directives
Parent topic: Compiler Directives - Alphabetical List


FCD3

This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.

Syntax:

 >>-.---.-.----.--FCD3----------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | FCD3 on 64-bit development systems. NOFCD3 on 32-bit development systems
Phase: | Syntax check
$SET: | No

Dependencies:

Set to FCD3 immediately by the Compiler directive P64.

Parent topic: Reserved Directives
Parent topic: Compiler Directives - Alphabetical List


LOCALCOUNT

This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.

Syntax:

>>-.---.--LOCALCOUNT--"integer"------------><
   +-/-+

Parameters:

integer Must be in the range 0 to 65536

Properties:

Default: | LOCALCOUNT"0"
Phase: | Syntax check
$SET: | Initial
Parent topic: Reserved Directives
Parent topic: Compiler Directives - Alphabetical List


WB

This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.

Syntax:

>>-.---.-.----.--WB------------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOWB
Phase: | Syntax check
$SET: | No

Dependencies:

WB sets ANIM immediately.

Parent topic: Reserved Directives
Parent topic: Compiler Directives - Alphabetical List


WB2

This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.

Syntax:

>>-.---.-.----.--WB2-----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOWB2
Phase: | Syntax check
$SET: | No
Parent topic: Reserved Directives
Parent topic: Compiler Directives - Alphabetical List


WB3

This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.

Syntax:

>>-.---.-.----.--WB3-----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOWB3
Phase: | Syntax check
$SET: | No
Parent topic: Reserved Directives
Parent topic: Compiler Directives - Alphabetical List


Run-time Behavior

These directives change the definition of language features and so change the logic of your program.

Some directives listed underLanguage features - dialect also affect behavior.

  • Run-time Behavior - General
  • Run-time Behavior - Arithmetic
  • Run-time Behavior - Mainframe Compatibility
  • Run-time Behavior - Compatibility with Older Micro Focus Products
  • Run-time Behavior - Compatibility with Other COBOL Dialects
  • Run-time Behavior - Speed or Size
Parent topic: Compiler Directives


Run-time Behavior - General

  • ACCEPTREFRESH
    Specifies whether the data areas associated with Screen Section data are updated from their corresponding Working-Storage Section items before an ACCEPT statement.
  • ASSIGN-PRINTER
    Specifies how to assign the output from an ASSIGN TO PRINTER clause when the clause does not specify a filename.
  • ASSIGN
    Specifies how to assign a filename when neither EXTERNAL nor DYNAMIC appear in the SELECT statement.
  • BWZSTAR
    Determines whether the BLANK WHEN ZERO clause is allowed in the Data Division for those fields defined with the "*" PICTURE symbol.
  • CHARSET
    Defines the character set of the environment.
  • CHECKDIV
    Controls the behavior of your program if it tries to divide by zero in a statement that has no ON SIZE ERROR phrase.
  • CHECKNUM
    Checks whether numeric fields contain valid data before performing operations on them.
  • COBFSTATCONV
    Causes the Callable File Handler to use the user-supplied module specified in the COBFSTATCONV environment variable to convert the file status codes if an I/O error is encountered on a file.
  • CONVERTRET
    Causes COMP and COMP-X items specified in CALL ... RETURNING and EXIT PROGRAM ... RETURNING phrases to be converted to COMP-5.
  • CURRENCY-SIGN
    Specifies the currency sign to be recognized in the PICTURE clause.
  • CURRENT-DATE
    Specifies the format of the date stored in the CURRENT-DATE special register.
  • DATA
    Enables AMODE"24" programs to access pointers to Data Division items passed to them by AMODE"31" programs.
  • DEFAULTBYTE
    Initializes each otherwise undefined byte of the Working-Storage Section to the character given.
  • DEFAULTCALLS
    Specifies the default calling convention.
  • DETECT-LOCK
    Makes READ statements detect when a record is locked by another program.
  • FOLD-CALL-NAME
    Folds the identifier/literal associated with CALL, CANCEL, ENTRY, and CHAIN statements and the program-name in the PROGRAM-ID paragraph to upper or lower case.
  • FOLD-COPY-NAME
    Determines whether copybook names should be converted to upper case or lower case.
  • HOSTARITHMETIC
    Controls whether or not decimal truncation of arithmetic results occurs following a size error condition.
  • INDD
    Causes ACCEPT statements to be read from a specified file.
  • INITCALL
    Specifies modules to be called immediately before the first statement of the program is executed.
  • INITPTR
    Enables the INITIALIZE statement to initialize DATA-POINTER, OBJECT-REFERENCE, and PROGRAM-POINTER data types.
  • INTDATE
    Selects the starting date for integer format dates used with date intrinsic functions.
  • IXNLSKEY
    Specifies that the File Handler should sort index file keys according to the local collating sequence rather than the ASCII collating sequence.
  • IXNUMKEY
    Enables true numeric sorting on index keys.
  • LOCKTYPE
    Specifies the type of record locking.
  • METHODDEFAULT
    Specifies the default parameter passing type for methods.
  • NATIVE
    Specifies the default collating sequence for comparisons.
  • NLS
    Enables the National Locale Support facility.
  • OUTDD
    Causes DISPLAY and EXHIBIT statements to be written to a specified output file..
  • PRINT-EXT
    Specifies the extension to be added to the filename associated with the ASSIGN TO PRINTER clause.
  • PROTECT-LINKAGE
    Extends the standard COBOL semantics so that the lengths of parameters can differ between the calling and the called program.
  • SHARE-OUTDD
    When set, multiple threads can write to the same SYSOUT or OUTDD file. When not set, a file locking error occurs in this situation.
  • STICKY-LINKAGE
    Makes parameters to the program remain linked during subsequent calls of the program.
  • TERMPAGE
    Determines whether the last page of a report file is to be padded with blank lines until it is a full page in length.
  • ZEROLENGTHFALSE
    Changes the way that class tests involving zero-length items are carried out.
  • ZWB
    Affects the operation of comparisons between integer numeric data items of USAGE DISPLAY and alphanumeric literals or figurative constants.
Parent topic: Run-time Behavior


ACCEPTREFRESH

Specifies whether the data areas associated with Screen Section data are updated from their corresponding Working-Storage Section items before an ACCEPT statement.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--ACCEPTREFRESH-------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOACCEPTREFRESH
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to ACCEPTREFRESH immediately by MS, IBM-MS or PC1.

Comments:

With ACCEPTREFRESH specified, before an ACCEPT statement that references a Screen Section data item, all data areas associated with Screen Section items subsidiary to the item being accepted are modified as follows:

  • If the Screen Section item includes the USING phrase, an implicit MOVE is generated from the corresponding Working-Storage Section item
  • If the Screen Section item includes the TO phrase the data area is initialized to spaces.

With NOACCEPTREFRESH specified, the Screen Section data area is left as it was following the last ACCEPT or DISPLAY.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


BWZSTAR

Determines whether the BLANK WHEN ZERO clause is allowed in the Data Division for those fields defined with the "*" PICTURE symbol.

Syntax:

>>-.---.-.----.--BWZSTAR-------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | BWZSTAR
Phase: | Syntax check
$SET: | Any

Comments:

If BWZSTAR is specified, the BLANK WHEN ZERO clause is allowed with fields defined using the "*" PICTURE symbol, and BLANK WHEN ZERO is effective when the field is the target of an editing operation and the result is zero. If NOBWZSTAR is specified, a BLANK WHEN ZERO clause associated with a PIC * field is rejected.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


CHARSET

Defines the character set of the environment.

Syntax:

>>-.---.--CHARSET--"char-set"--------------><
   +-/-+

Parameters:

char-set
ASCII or EBCDIC.

Properties:

Default: | CHARSET"ASCII" (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

CHARSET"ASCII" sets DEFAULTBYTE"32", SIGN"ASCII" and NATIVE"ASCII" immediately.

CHARSET"EBCDIC" sets DEFAULTBYTE"0" immediately and SIGN"EBCDIC" and NATIVE"EBCDIC" at end.

Comments:

All literals and collating sequences are handled in the character set specified.

With CHARSET"EBCDIC" set, COBOL system library routines that receive or return alphanumeric data in any parameters do not work. The alphanumeric data must be in ASCII.

With CHARSET"EBCDIC" set, if you want the application to run on a machine where only Server Enterprise Edition is installed, you must link in the object associated with your codepage (by default cs0437.obj).

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - General
DEFAULTBYTE
SIGN
NATIVE
Key to Compiler Directives


CHECKDIV

Controls the behavior of your program if it tries to divide by zero in a statement that has no ON SIZE ERROR phrase.

Syntax:

>>-.---.-.-------CHECKDIV-"dialect"-.-----><
   +-/-+ +.----.-CHECKDIV-----------+
          +-NO-+

Parameters:

dialect
One of ANSI, ISO2002, COBOL370, ENTCOBOL, MVS, OS390, OSVS, VSC2 .

Properties:

Default: | CHECKDIV"ANSI" (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

With CHECKDIV, CHECKDIV"ANSI" or CHECKDIV"ISO2002" specified, the program continues with an undefined result if it tries to divide by zero. With NOCHECKDIV set, the behavior is undefined.

Specifying CHECKDIV"COBOL370", CHECKDIV"ENTCOBOL", CHECKDIV"MVS", CHECKDIV"OS390", CHECKDIV"OSVS" or CHECKDIV"VSC2" has the same effect; trying to divide by zero produces run-time error 048 (Attempt to divide by zero). This error can be disabled using the -O run-time system switch.

Setting NOCHECKDIV results in optimal code for divides.

This directive has no effect on arithmetic statements that use the ON SIZE ERROR phrase.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - General
Key to Compiler Directives


CHECKNUM

Checks whether numeric fields contain valid data before performing operations on them.

Syntax:

>>-.---.-.----.--CHECKNUM------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOCHECKNUM
Phase: | Generate
$SET: | Initial

Comments:

Specifying this directive causes extra code to be generated to ensure that numeric fields contain valid data before any operations are performed on them. With CHECKNUM set, run-time error message 163 (Illegal character in numeric field (fatal)) is displayed if any numeric field is found to contain nonnumeric data. This error can be disabled using the -F RTS switch.

The extra code produced when you specify CHECKNUM reduces the efficiency of your programs. For smaller, faster code you should not specify CHECKNUM.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


CONVERTRET

Causes COMP and COMP-X items specified in CALL ... RETURNING and EXIT PROGRAM ... RETURNING phrases to be converted to COMP-5.

Syntax:

>>-.---.-.----.--CONVERTRET----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOCONVERTRET
Phase: | Syntax check
$SET: | Initial
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


CURRENCY-SIGN

Specifies the currency sign to be recognized in the PICTURE clause.

Syntax:

>>-.---.--CURRENCY-SIGN--"integer"---------><
   +-/-+

Parameters:

integer
The ANSI code of the character, in decimal.

Properties:

Default: | CURRENCY-SIGN"36" (that is, "$")
Phase: | Syntax check
$SET: | Initial

Comments:

You cannot specify a valid PICTURE clause symbol.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


CURRENT-DATE

Specifies the format of the date stored in the CURRENT-DATE special register.

Syntax:

>>-.---.--CURRENT-DATE--"date-format"------><
   +-/-+

Parameters:

date-format Either DDMMYY or MMDDYY.

Properties:

Default: | CURRENT-DATE"MMDDYY"
Phase: | Syntax check
$SET: | Any

Comments:

The DDMMYY parameter causes CURRENT-DATE to be stored in European format. The parameter can be specified in either upper case or lower case.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related information
Run-time Behavior - General
Concepts of the COBOL Language
The CURRENT-DATE Function


DATA

Enables AMODE"24" programs to access pointers to Data Division items passed to them by AMODE"31" programs.
Note: This directive is supported for native COBOL only.

Syntax:

 >>-.---.--------DATA--"format"-------------><
    +-/-+

Parameters:

format
The method of loading of the Data Division:
24
Forces the Data Division to be loaded "below-the-line"
31
Forces the Data Division to be loaded "above-the-line"

Properties:

Default: | DATA"31" if AMODE"31" is set(Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

AMODE"31" sets DATA"31" immediately.

Comments:

The DATA directive enables you to control where the Data Division of a program compiled using AMODE(31) program is loaded.

When the COBOL run-time system loads a program compiled with the AMODE directive, it registers the program's Data Division with the Mainframe Pointer Manager (MFPM) as "above-the-line" or "below-the-line". If you specified AMODE"31", the program is registered as "above-the-line"; if you specified AMODE"24", the program is registered as "below-the-line". All POINTER variable operations subsequently performed by AMODE programs use mainframe addresses assigned by MFPM.

As long as POINTER variables that address items in the Data Division of a program compiled with AMODE"31" are not passed to an AMODE"24" program, programs compiled with AMODE"31" and AMODE"24" can safely coexist in the same run-unit. However, if such POINTERs are passed, an error 114 (at best), or unexpected execution behavior (at worst), will occur.

On the mainframe, the VS COBOL II and COBOL MVS compilers provide the DATA compiler option that controls the location of the Data Division for AMODE"31" programs. By default DATA"31" is set, which causes the Data Division to be allocated above the 16Mb line. However, if you need a program compiled using AMODE"31" to pass data to an AMODE"24" program, you can specify DATA"24" to force the Data Division to be allocated below the 16Mb line. See your VS COBOL II Application Programming Guide and COBOL MVS & VM V1R2 Programming Guide for further details of the DATA(24|31) compiler option and mixed AMODE applications.

You can specify DATA"24" with AMODE"31" to force the Data Division to be loaded below the 16 Mb line.

You cannot use the DATA directive with AMODE"24".

The DATA directive cannot be used for programs that need to call a Micro Focus library routine or an external API that expects pointer items to be in the native machine format.

Parent topic: Run-time Behavior - General
Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Language Features - Mainframe Compatibility
AMODE
Key to Compiler Directives


DEFAULTBYTE

Initializes each otherwise undefined byte of the Working-Storage Section to the character given.

Syntax:

>>-.---.--DEFAULTBYTE--"integer"-----------><
   +-/-+

Parameters:

integer Decimal ASCII code between 0-254.

Properties:

Default: | DEFAULTBYTE"32" (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to DEFAULTBYTE"32" immediately by CHARSET"ASCII".

Set to DEFAULTBYTE"00" immediately by CHARSET"EBCDIC", DIALECT"SAA1", DIALECT"SAA2", DIALECT"OSVS", DIALECT"DOSVS", DIALECT"VSC2", DIALECT"COBOL37[012]", DIALECT"BS2000", DIALECT"SNI", MS, IBM-MS or PC1.

Comments:

integer is a decimal value. For example, if you want to specify an EBCDIC space use DEFAULTBYTE"64"; to specify an ASCII space use DEFAULTBYTE"32".

Decimal value 255 is not permitted.

If you compile with the ILNATIVE Compiler directive, items that will be exposed as IL native types are not initialized according to DEFAULTBYTE. Compile with the NOILNATIVE directive to ensure appropriate items are initialized according to DEFAULTBYTE.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related reference
ILNATIVE
Related information
DIALECT
Run-time Behavior - General
MS
IBM-MS
PC1
CHARSET
Language Fundamentals


DEFAULTCALLS

Specifies the default calling convention.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.-------DEFAULTCALLS--"integer"-.-><
   +-/-+ +.----.-DEFAULTCALLS------------+
          +-NO-+

Parameters:

integer Default calling convention

Properties:

Default: | NODEFAULTCALLS
Phase: | Syntax check
$SET: | Any

Comments:

DEFAULTCALLS without the optional parameter specifies that the calling convention specified in the PROCEDURE DIVISION USING statement is to be used as the default calling convention.

DEFAULTCALLS"integer" specifies that the calling convention indicated by integer is to be used as the default calling convention.

NODEFAULTCALLS is equivalent to DEFAULTCALLS"0".

Individual CALL statements can override these defaults.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


FOLD-CALL-NAME

Folds the identifier/literal associated with CALL, CANCEL, ENTRY, and CHAIN statements and the program-name in the PROGRAM-ID paragraph to upper or lower case.

Syntax:

>>-.---.-.-----FOLD-CALL-NAME--"case"-.----><
   +-/-+ +---NOFOLD-CALL-NAME---------+

Parameters:

case
UPPER or LOWER

Properties:

Default: | NOFOLD-CALL-NAME (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

The Compiler also accepts the directive name without hyphens; that is FOLDCALLNAME.

In a CALL identifier statement, the name called is given the case specified by this directive, but the actual contents of identifier are not changed.

The FOLD-CALL-NAME directive can help in the transfer of COBOL code from an environment with filenames which are not case specific to one which is.

It also makes the Compiler conform with the ANSI'85 standard interprogram communications module, in which the case of a program-name in a CALL statement does not matter.

With NOFOLD-CALL-NAME, by normal COBOL convention the program-name is folded to upper case unless enclosed in quotes. This also applies to the root program of a nested program. All the subprogram-names are folded to upper case even when in quotes. (Enclosing program-names in quotes is a Micro Focus extension.)

The program-name is also accessible as an entry point in a fully linked executable.

You need to specify the CASE directive if you are going to compile .obj code.

FOLD-CALL-NAME does not affect SET statements in the format SET procedure-pointer-name-1 TO ENTRY procedure-pointer-name-1.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - General
CASE
The CALL Statement
Key to Compiler Directives


FOLD-COPY-NAME

Determines whether copybook names should be converted to upper case or lower case.

Syntax:

>>-.---.-.-----FOLD-COPY-NAME--"case"-.----><
   +-/-+ +---NOFOLD-COPY-NAME---------+

Parameters:

case
"UPPER" or "LOWER".

Properties:

Default: | NOFOLD-COPY-NAME (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

The Compiler also accepts the directive-name without hyphens; that is FOLDCOPYNAME.

The FOLD-COPY-NAME directive affects both text and library-names regardless of whether they are specified as user-defined words or literals.

Example:

Specifying FOLD-COPY-NAME"UPPER" converts copybook names to upper case (also known as folding to upper case).

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related reference
DIALECT
Related information
Run-time Behavior - General
Key to Compiler Directives


HOSTARITHMETIC

Controls whether or not decimal truncation of arithmetic results occurs following a size error condition.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--HOSTARITHMETIC----------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOHOSTARITHMETIC
Phase: | Syntax check
$SET: | Yes

Comments:

The effect of specifying HOSTARITHMETIC is as follows:

  • If the result of an arithmetic operation (ADD, SUBTRACT, MULTIPLY, DIVIDE, COMPUTE) with no ON SIZE ERROR clause exceeds the maximum value that the target item can hold, decimal truncation will be performed on the result, provided that:
    • The target item is a decimal type, that is DISPLAY, COMP-3 or COMP-6
    • None of the source items are floating-point items
    • No exponentiation or intrinsic functions are used in the calculation
    • Neither the composite of operands nor any intermediate result has more than 31 decimal digits
  • If the result of an arithmetic operation (ADD, SUBTRACT, MULTIPLY, DIVIDE, COMPUTE) with an ON SIZE ERROR clause exceeds the maximum value that the target item can hold, the ON SIZE ERROR clause will be executed as normal, and the value of the target item will not be altered.

If you specify this directive in a $SET statement it will affect the run-time behavior of the whole program regardless of where it is placed.

Important: This directive can adversely affect the performance of generated code.
Parent topic: Run-time Behavior - General
Parent topic: Run-time Behavior - Arithmetic
Parent topic: Compiler Directives - Alphabetical List


INDD

Causes ACCEPT statements to be read from a specified file.

Syntax:

>>-.---.--.----.--INDD--"fname"------------.><
   +-/-+  +----+--INDD---------------------+
          +-NO-+

Parameters:

fname
Name of file to be read for the specified ACCEPT statements. When this parameter is not specified the name used is SYSIN.

Properties:

Default: | NOINDD
Phase: | Syntax check
$SET: | Initial

Comments:

When INDD is specified, all format 1 ACCEPT statements which either have no FROM option or specify FROM SYSIN (or the mnemonic-name associated with SYSIN) are transformed into READ statements, reading from a file with the specified external filename.

The filename can be mapped onto physical filenames in the same way as other files with external filenames; that is, by using environment variables or the External File Mapper.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related information
The ACCEPT Statement
ALTER and ACCEPT Statement Restrictions
The File Control Entry
The OPEN Statement
The READ Statement
XML Syntax - READ Statement
OUTDD
Run-time Behavior - General
Key to Compiler Directives


INITCALL

Specifies modules to be called immediately before the first statement of the program is executed.

Syntax:

>>-.---..-----INITCALL--"module"-.------------..><
   +-/-+|                        +-"priority"-+|
        +-NO--INITCALL-------------------------+

Parameters:

module
The module to be called.
priority
The priority to assign to the execution of the module.
H
High priority (the default if no priority is specified)
L
Low priority

Properties:

Default: | NOINITCALL
Phase: | Syntax check
$SET: | Initial

Comments:

Specifying INITCALL causes the Compiler to insert a call to the named module. At run time, the module specified is called before any procedural code is executed. You cannot pass parameters to the called module.

To call several modules using this feature, you must use the INITCALL directive repeatedly. NOINITCALL clears the list of modules to be called.

Calls specified with a high priority are placed before all calls with a low priority, as well as other calls made by the Compiler. Low priority calls are placed after other calls made by the Compiler. Calls with the same priority are executed in the order they are specified.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


INITPTR

Enables the INITIALIZE statement to initialize DATA-POINTER, OBJECT-REFERENCE, and PROGRAM-POINTER data types.

Syntax:

>>-.---.-.----.--INITPTR---------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | INITPTR
Phase: | Syntax check
$SET: | Initial

Comments:

When INITPTR is set, an INITIALIZE statement will move specified values to DATA-POINTER, OBJECT-REFERENCE, and PROGRAM-POINTER data types.

If NOINITPTR is set, an INITIALIZE statement will not change the values of these data types.

INITPTR is on by default for MF15 and ISO2002 and off by default for mainframe dialects

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


INTDATE

Selects the starting date for integer format dates used with date intrinsic functions.

Syntax:

>>-.---.-----INTDATE--"type"-------------><
   +-/-+

Parameters:

type
The type of starting-date:
ANSI
Instructs the compiler to use the ANSI COBOL Standard starting date (where Day 1 = Jan 1, 1601).
LILIAN
Instructs the compiler to use the Lilian starting date (where Day 1 = Oct 15, 1582).

Properties:

Default: | INTDATE"ANSI"
Phase: | Syntax check
$SET: | Any

Comments:

This directive selects the starting date for integer format dates used with date intrinsic functions (that is, DATE-OF-INTEGER, DAY-OF-INTEGER, INTEGER-OF-DATE, INTEGER-OF-DAY)

For more details on the date intrinsic functions, see your Language Reference.

Parent topic: Run-time Behavior - General
Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List


METHODDEFAULT

Specifies the default parameter passing type for methods.

Syntax:

>>-.---.-.----.--METHODDEFAULT--"pass-type"------><
   +-/-+

Parameters:

pass-type
REFERENCE
By default parameters are by reference.
VALUE
By default parameters are by value.

Properties:

Default: | METHODDEFAULT(REFERENCE)
Phase: | Check
$SET: | Initial
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related information
Key to Compiler Directives


NATIVE

Specifies the default collating sequence for comparisons.

Syntax:

>>-.---.--NATIVE--"coll-seq"---------------><
   +-/-+

Parameters:

coll-seq Either "ASCII" or "EBCDIC".

Properties:

Default: | NATIVE"ASCII"
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to NATIVE"ASCII" immediately by CHARSET"ASCII".

Set to NATIVE"EBCDIC" at end by CHARSET"EBCDIC".

Comments:

The keys in an indexed file are always ordered by the ASCII collating sequence.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


NLS

Enables the National Locale Support facility.

Syntax:

>>-.---.-.----.--NLS-----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NONLS
Phase: | Syntax check
$SET: | Initial

Comments:

NLS enables your program to adapt itself automatically at run time to the character set, currency symbol and editing symbols appropriate to your user's country.

If you want to sort index files according to the local collating sequence rather than the ASCII collating sequence, you must specify the IXNLSKEY directive.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


OUTDD

Causes DISPLAY and EXHIBIT statements to be written to a specified output file..

Syntax:

>>-.---.-.-------OUTDD--"fname rsize rtype"----.---><
   +-/-+ +-------OUTDD--"fname rsize"----------+
         +-------OUTDD--"fname"----------------+
         +.----.-OUTDD-------------------------+
          +-NO-+

Parameters:

fname
Name of file to be written for the specified DISPLAY statements and EXHIBIT statements and for the TRACE output. When this parameter is not specified the name used is SYSOUT.
rsize
Size of the data records in the file. When this parameter is not specified the size used is 132 for Micro Focus dialects (rtype = L), or 121 for mainframe dialects (rtype = R).
rtype
Either L for Line Sequential (Micro Focus dialect) or R for Record Sequential (mainframe dialects). When this parameter is not specified, L is used.

Properties:

Default: | NOOUTDD
Phase: | Syntax check
$SET: | Initial

Comments:

When OUTDD is specified, all format 1 DISPLAY statements which either have no UPON option or specify UPON SYSOUT, and all EXHIBIT statements and the output from TRACE are transformed into WRITE statements, writing to a file with the specified external filename.

The filename can be mapped onto physical filenames in the same way as other files with external filenames; that is, by using environment variables or the External File Mapper.

If you compile with OUTDD and are producing an executable, you need to link in outddfh.obj.

Note: JCL user exit programs should not be compiled with this directive.
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


PROTECT-LINKAGE

Extends the standard COBOL semantics so that the lengths of parameters can differ between the calling and the called program.
Note:

This directive is not supported under UNIX.

Normally, the result of ignoring the constraints would give undefined results, possibly including severe errors such as protection violations or memory access faults.

Syntax:

>>-.---.-.----.--PROTECT-LINKAGE-----------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOPROTECT-LINKAGE (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

The ANSI COBOL standard states in the general rules for each parameter passed by the CALL statement that "The description of the data item in the called program must describe the same number of character positions as described by the description of the corresponding data item in the calling program.". This restriction must be observed when using this COBOL system unless the program is compiled with the PROTECT-LINKAGE directive.

The restriction is lifted when the PROTECT-LINKAGE directive is set, for all items except when they are used in STRING statements. The called program only uses mismatched parameters as sending items in a statement and does not use them as receiving items.

Any character positions in a parameter for which there is no correspondence in the called and calling programs is a mismatched character. The contents of any mismatched character is undefined for a parameter used as a sending item in a called program.

Don’t set PROTECT-LINKAGE and use CBL_ALLOC_MEM to allocate memory for linkage items at the same time.

Attention: This directive can adversely affect the performance of generated code.

Example:

Calling program:

     ...
     03 x1  pic x.
     03 x2  pic x(100).
 procedure division.
      ...
     call subprog using x1
      ...

Subprogram:

 working-storage section.
 01  y1       pic x(1000).

 linkage section.
 01  z1       pic x(1000).

 procedure division using z1.

     move z1 to y1
* This operation works, and transfers the contents of x1. It
* also transfers any data following x1 in the calling program,
* up to 1000 bytes or the end of allocated memory, whichever
* occurs first. If less than 1000 bytes is transferred, the
* remainder of y1 is space filled.

     move y1 to z1.
* This operation is not protected and fails, either by
* corrupting data beyond x1 in the calling program, or
* trying to write beyond allocated memory, which might
* result in a protection violation.
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - General
Key to Compiler Directives
CBL_ALLOC_MEM


SHARE-OUTDD

When set, multiple threads can write to the same SYSOUT or OUTDD file. When not set, a file locking error occurs in this situation.

Syntax:

 >>-.---.-.----.--SHARE-OUTDD-------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOSHARE-OUTDD
Phase: | Syntax check
$SET: | Initial
Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


STICKY-LINKAGE

Makes parameters to the program remain linked during subsequent calls of the program.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.------STICKY-LINKAGE--"integer"-.-><
   +-/-+ +----NO-STICKY-LINKAGE-----------+

Parameters:

integer Either 1 or 2

Properties:

Default: | NOSTICKY-LINKAGE (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

The purpose of the COBOL Linkage Section is to provide a linkage between a level 01 or level 77 data item declared in the Linkage Section (a linkage item) and some dynamically specified data item so that they appear to share the same storage area. The linkage is established by one of three means: a CALL program-name USING statement, a CALL entry-name USING statement, or a SET statement. The first mechanism is the standard one specified by ANSI. The other two are COBOL language extensions that are supported by this COBOL system.

In ANSI COBOL, the Linkage Section enables a called program to access the parameters passed to it by a CALL statement. The number of parameters in the USING phrase of the CALL statement must equal the number of parameters in the USING phrase of the PROCEDURE DIVISION header. Any level 01 or level 77 data item in the Linkage Section that does not appear in the USING phrase of the PROCEDURE DIVISION header must not be referenced.

The ENTRY statement is a COBOL language extension that provides an alternative entry point into a program. The ENTRY statement takes a USING phrase in the same way as the PROCEDURE DIVISION header, and, in a similar fashion, linkage items must not be referenced if they do not appear in the USING phrase associated with the entry-name by which the program was invoked.

The SET statement enables a POINTER value that identifies a storage location to be used to link a linkage item. Such a linkage item can then be referenced in order to reference the data held at that storage location.

The following details explain in conceptual terms when linkage items are linked and unlinked.

This COBOL system checks at run time when a linkage item is referenced, to ensure it is linked to a data item. It gives a run-time error if it is not linked to any storage location. To facilitate this check, on each invocation immediately before executing the first statement in the program, all linkage items are first unlinked and then linkage items that have corresponding parameters passed by the calling program are linked. This means that a linkage item in a called program that is linked to a data item by the SET statement does not remain linked on subsequent invocations of the program; the SET statement needs to be executed in each invocation.

Many other COBOL implementations are less rigorous in enforcing the ANSI rules and the STICKY-LINKAGE directive takes a parameter to specify two alternative and less rigorous regimes.

STICKY-LINKAGE"1" specifies that only the linkage items that appear in the USING phrase of the called program are unlinked; other linkage items retain any previous linkage. If the program was called using the program-name this is the USING phrase of the PROCEDURE DIVISION header. Otherwise, this is the USING phrase associated with the entry-point by which the program was invoked.

Under this regime, if the calling program provides insufficient parameters and a reference is made to a linkage item that appears in the USING phrase but has no corresponding parameter in the USING phrase of the CALL statement, a run-time error is still given.

STICKY-LINKAGE"2" specifies that, except when the program is in its initial state at startup or after it is referenced in a CANCEL statement, no linkage items are unlinked when the program is called. All linkage items retain any linkage established during previous invocations unless the calling program provides a parameter or a SET statement is used to change the linkage.

No particular implementation method is implied by this and indeed, on this COBOL system, emulating the non-ANSI conformant behavior using this directive can have a detrimental effect on program size and execution speed.

Example:

If the following program is compiled without the STICKY-LINKAGE directive and run, a run-time error 203, CALL parameter not supplied, is given after the second CALL statement passes control to "ent" and the DISPLAY statement references two linkage items that do not appear in the USING phrase of ENTRY "ent".

If the program is then compiled with STICKY-LINKAGE"1" and run, execution progresses until it fails again after the third CALL statement passes control to "sub" and the DISPLAY statement references a linkage item that does appear in the USING phrase of the PROCEDURE DIVISION header but has no corresponding parameter passed by the CALL statement.

If the program is compiled with STICKY-LINKAGE"2" and run, the program successfully executes to completion.

 program-id. main.
 working-storage section.
 01 param pic x value "a".
 procedure division.
     call "sub" using param
     call "ent"
     call "sub"
     stop run.
 end program main.

 program-id. sub.
 linkage section.
 01 link-1 pic x.
 01 link-2 pic x.
 procedure division using link-1.
     set address of link-2 to address of link-1
     display link-1 link-2
     exit program.

   entry "ent"
     display link-1 link-2
     exit program.

If STICKY-LINKAGE"2" is used for a called program, it can be called only by a COBOL program.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
PARAMCOUNTCHECK
Run-time Behavior - General
Configuration Section
Input-Output Section
General Description
Working-Storage Section
Thread-Local-Storage Section
Object-Storage Section
Local-Storage Section
Linkage Section
Screen Section
Procedure Division General Description
The EXIT Statement
Input-Output Section
Report Section
The ENTRY Statement
The SET Statement
ENTRY Statement Restrictions
The Repository Paragraph
Screen Section Entry Skeleton
The USING Clause
The PROCEDURE DIVISION Header
The CALL Statement
The CHAIN Statement
The INVOKE Statement
The MERGE Statement
The SORT Statement
The START Statement
The Class-ID Paragraph
The Interface-ID Paragraph
The File Control Entry
Data Description Entry Skeleton
The USAGE Clause
The USAGE Clause in the Screen Section
The DISPLAY Statement
The CANCEL Statement
$IF Statement
The PROPERTY Clause
The VALUE Clause
The Method-ID Paragraph
Key to Compiler Directives


TERMPAGE

Determines whether the last page of a report file is to be padded with blank lines until it is a full page in length.

Syntax:

>>-.---.-.----.--TERMPAGE------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | TERMPAGE
Phase: | Syntax check
$SET: | Initial

Comments:

Specifying TERMPAGE causes the last page of a report to be padded with blank lines until it is a full page in length.

This directive affects any report file for which the PAGE phrase is specified in its Report Description (RD) entry.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


ZEROLENGTHFALSE

Changes the way that class tests involving zero-length items are carried out.

Syntax:

>>-.---.-.----.--ZEROLENGTHFALSE-----------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOZEROLENGTHFALSE (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

When ZEROLENGTHFALSE is set, all comparisons between zero-length group items, and between zero-length items and figurative constants, return false; when it is not set, they all return true.

For conformance to ANSI you must set ZEROLENGTHFALSE.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - General
Key to Compiler Directives


ZWB

Affects the operation of comparisons between integer numeric data items of USAGE DISPLAY and alphanumeric literals or figurative constants.

Syntax:

 >>-.---.-.----.--ZWB-----------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOZWB
Phase: | Syntax check
$SET: | Any

Comments:

The ZWB directive affects the range of comparisons that HOST-NUMCOMPARE"1" applies to. With ZWB on, only unsigned comparisons are affected. Otherwise, all comparisons are affected.

Parent topic: Run-time Behavior - General
Parent topic: Compiler Directives - Alphabetical List


Run-time Behavior - Arithmetic

  • ARITHMETIC
    Specifies how arithmetic expressions are to be evaluated.
  • BINLIT
    Controls whether binary b"" literals are interpreted as numeric values, or Boolean values for use with PIC 1 data items.
  • COMP-5
    Specifies whether the sign is to be dropped when a value is stored in an unsigned COMP-5 data item.
  • COMP-6
    Specifies whether COMP-6 data is to be held in binary or packed decimal format.
  • HOSTARITHMETIC
    Controls whether or not decimal truncation of arithmetic results occurs following a size error condition.
  • NATIVE-FLOATING-POINT
    Determines whether a program's floating point data items are to use IBM hexadecimal format.
  • SIGNDISCARD
    Specifies that a MOVE of a signed numeric DISPLAY field to a group item should discard the sign, and treat the group as an elementary alphanumeric field.
  • TRUNC
    Specifies whether data being stored into a USAGE COMP, USAGE BINARY or USAGE COMP-4 item is to be truncated to the size given by the item's PICTURE clause or to the maximum size the item can hold.
Parent topic: Run-time Behavior


ARITHMETIC

Specifies how arithmetic expressions are to be evaluated.

Syntax:

>>-.---.--ARITHMETIC--"arith-type"---------><
   +-/-+

Parameters:

arith-type
The behavior to adopt:
ENTCOBOL
Truncate according to the rules of Enterprise COBOL for z/OS and OS/390.
MF, ISO2002 or ANSI
Do not truncate intermediate results. With ARITHMETIC"MF", ARITHMETIC"ISO2002" or ARITHMETIC"ANSI" specified, expressions are calculated as accurately as possible because no truncation takes place.
OS390
Truncate according to the rules of COBOL for OS/390.
OSVS
Truncate according to the rules of OS/VS COBOL.
TRUNC20
Truncate the number of digits to the right of the decimal point to 20 at each step of the evaluation of the expression. This provides similar results to the truncation provided in COBOL Workbench. You should only use this directive if you need to obtain evaluation results similar to those provided in COBOL Workbench.
If you specify TRUNC20, you must not change the setting of the INTLEVEL Compiler directive from its default value of 2. This means that you cannot use some of the newer features, such as numeric pictures with more than 18 total digits, with the TRUNC20 parameter.
VSC2
Truncate according to the rules of VS COBOL II and COBOL/370.

Properties:

Default: | ARITHMETIC"MF" (Dialect)
Phase: | Syntax check
$SET: | No
Parent topic: Run-time Behavior - Arithmetic
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - General
Key to Compiler Directives


BINLIT

Controls whether binary b"" literals are interpreted as numeric values, or Boolean values for use with PIC 1 data items.

Syntax:

 >>-.---.-.----.--BINLIT--"literal-type"-------------><
    +-/-+

Parameters:

literal-type
NUMERIC
Treat binary literals as numeric values
BOOLEAN
Treat binary literals as Boolean values.

Properties:

Default: | BINLIT(NUMERIC)
Phase: | Check
$SET: | Any

Comments:

A program containing a PIC 1 data item will automatically have BINLIT(BOOLEAN) set at that point.

Parent topic: Run-time Behavior - Arithmetic
Parent topic: Compiler Directives - Alphabetical List
Related information
Key to Compiler Directives
The PICTURE Clause


COMP-5

Specifies whether the sign is to be dropped when a value is stored in an unsigned COMP-5 data item.

Syntax:

>>-.---.--COMP-5--"integer"----------------><
   +-/-+

Parameters:

integer
Must be one of:
1
Behavior as in earlier versions of this Compiler. The sign is dropped.
2
The sign is not dropped. Negative numbers are stored in two's complement form, so that, except for their byte-order being machine dependent, unsigned COMP-5 items behave like COMP-X. This results in highly efficient arithmetic on unsigned COMP-5 items.

Properties:

Default: | COMP-5"2"
Phase: | Syntax check
$SET: | Initial
Parent topic: Run-time Behavior - Arithmetic
Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


COMP-6

Specifies whether COMP-6 data is to be held in binary or packed decimal format.

Syntax:

>>-.---.--COMP-6--"integer"----------------><
   +-/-+

Parameters:

integer
Must be one of the following:
1
A binary format is used for COMP-6 data
2
Packed decimal format is used. If the item is signed, the format is identical to COMP-3. If the item is unsigned, no sign field is present.

Properties:

Default: | COMP-6"2"
Phase: | Syntax check
$SET: | Initial

Dependencies:

ADDRSV"COMP-6" must be set.

Comments:

The binary format used when you set COMP-6"1" is as described in the chapter RM/COBOL Syntax Support in your Language Reference .

Even if you specify the COMP-6 directive, the reserved word COMP-6 is recognized only if it belongs to the chosen dialect or the directive ADDRSV"COMP-6" is specified.

Example:

With COMP-6"2" specified:

PIC 99 COMP-6 VALUE 87

is stored in one byte as x"87"

PIC S99 COMP-6 VALUE 87

is stored in two bytes as x"087C"

Parent topic: Run-time Behavior - Arithmetic
Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List


NATIVE-FLOATING-POINT

Determines whether a program's floating point data items are to use IBM hexadecimal format.
Note: This directive is supported for native COBOL only.

Syntax:

 >>-.---.-.----.--NATIVE-FLOATING-POINT-----><
    .-/-+ .-NO-+

Parameters:

None

Properties:

Default: | NONATIVE-FLOATING-POINT
Phase: | Syntax check
$SET: | Initial

Comments:

Specifying NATIVE-FLOATING-POINT causes all floating point data items to use IEEE. Specifying NONATIVE-FLOATING-POINT causes the format used to be determined by the MAINFRAME_FLOATING_POINT environment variable.

Parent topic: Run-time Behavior - Arithmetic
Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
Run-time Behavior - Mainframe Compatibility
Compiler Directives - Alphabetical List
IBM Hexadecimal Format Floating Point Data
Key to Compiler Directives
mainframe_floating_point


SIGNDISCARD

Specifies that a MOVE of a signed numeric DISPLAY field to a group item should discard the sign, and treat the group as an elementary alphanumeric field.

Restriction: This directive is supported in native COBOL only.

Syntax:

>>-.---.-.----.--SIGNDISCARD------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOSIGNDISCARD
Phase: | Check
$SET: | Initial
Parent topic: Run-time Behavior - Arithmetic
Parent topic: Compiler Directives - Alphabetical List
Related information
Key to Compiler Directives
The MOVE Statement


TRUNC

Specifies whether data being stored into a USAGE COMP, USAGE BINARY or USAGE COMP-4 item is to be truncated to the size given by the item's PICTURE clause or to the maximum size the item can hold.

Syntax:

>>-.---.-.-------TRUNC--"method"-.---------><
   +-/-+ +.----.-TRUNC-----------+
          +-NO-+

Parameters:

method
One of:
TRUNC
Truncate in decimal to the number of digits given by the PICTURE clause, on all stores into COMP, BINARY and COMP-4 items.
NOTRUNC
Truncate in binary to the capacity of the allocated storage, on all nonarithmetic stores into COMP, BINARY and COMP-4 items.
TRUNC"ANSI"
Truncate in decimal to the number of digits given by the PICTURE clause, on nonarithmetic stores into COMP, BINARY and COMP-4 items. On arithmetic statements that cause the size error condition and that have no ON SIZE ERROR phrase, the result is undefined.

Properties:

Default: | TRUNC"ANSI" (Dialect) (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to TRUNC"ANSI" immediately by NORM.

Set to NOTRUNC immediately by RM or RM"ANSI".

Parent topic: Run-time Behavior - Arithmetic
Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - Compatibility with Other COBOL Dialects
Key to Compiler Directives


Run-time Behavior - Mainframe Compatibility

  • ADV
    Causes a control character to be inserted at the start of each line in a print file. This is for compatibility with mainframe operation.
  • AMODE
    Provides compatibility with mainframe-style pointers.
  • APOST
    Makes the Compiler interpret the figurative constant QUOTE as the single-quote character (').
  • BYTE-MODE-MOVE
    Controls behavior for alphanumeric moves between overlapping data items.
  • COMP5-BYTE-ORDER
    Specifies the byte ordering to be used for COMP-5 data.
  • DATA
    Enables AMODE"24" programs to access pointers to Data Division items passed to them by AMODE"31" programs.
  • DIALECT
    Enables check-time and run-time behavior consistent with the specified dialect.
  • DYNAM
    Specifies that CANCEL statements are not to be ignored.
  • FP-ROUNDING
    Determines whether one floating-point receiving item can affect the results of other, nonfloating-point receiving items.
  • HOST-NUMCOMPARE
    Controls the operation of comparisons between integer numeric data items of USAGE DISPLAY and alphanumeric literals, figurative constants, or numeric operands.
  • HOST-NUMMOVE
    Ensures that run-time error 163 (illegal characters in numeric fields) does not occur when certain MOVE statements are executed on numeric display data items or numeric operands.
  • HOSTRW
    Determines whether report files are written using WRITE AFTER ADVANCING for better mainframe emulation when the MAINFRAMEPRINT=ON option is set.
  • IBMCOMP
    Turns on word-storage mode.
  • MAPNAME
    Makes the Compiler alter program-names and entry-point names to make them compatible with OS/VS COBOL, DOS/VS COBOL, VS COBOL II and COBOL/370.
  • NATIVE-FLOATING-POINT
    Determines whether a program's floating point data items are to use IBM hexadecimal format.
  • ODOOSVS
    Makes the evaluation of OCCURS DEPENDING ON items more compatible with the OS/VS COBOL compiler.
  • OLDCOPY
    Makes COPY statements follow the ANSI'68 standard.
  • PERFORM-TYPE
    Specifies the behavior of return jumps from nested PERFORM statements.
  • QUOTE
    Makes the Compiler interpret the figurative constant QUOTE as the double-quote character (").
  • REMAINDER
    Enables you to select how the remainder is calculated in a DIVIDE statement.
  • SIGN-FIXUP
    Provides limited emulation of mainframe compiler options NUMPROC(NOPFD) and NUMPROC(PFD) for MOVE and COMPARE statements.
  • SYSPUNCH
    Specifies the SYSPUNCH record length to be used.
Parent topic: Run-time Behavior


ADV

Causes a control character to be inserted at the start of each line in a print file. This is for compatibility with mainframe operation.

Syntax:

>>-.---.-.----.--ADV---------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOADV
Phase: | Syntax check
$SET: | Any

Dependencies:

ADV has no effect unless FILETYPE"11" is set.

Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
FILETYPE
Key to Compiler Directives


AMODE

Provides compatibility with mainframe-style pointers.
Note: This directive is supported for native COBOL only.

Syntax:

 >>-.---.-.-------AMODE--"format"---.---------><
    +-/-+ +---NO--AMODE-------------+

Parameters:

format
The storage format of pointers:
24
All pointers are stored in a 24-bit format. This format is compatible with "below-the-line" storage on the mainframe. The top 8 bits of the pointer are masked off when the address of a linkage item is set from the pointer. This means that, as on the mainframe, the top 8 bits can be manipulated directly by the user's code.
31
All pointers are stored in a 31-bit format. This format is compatible with "above-the-line" storage on the mainframe. The top bit of the pointer is masked off when the address of a linkage item is set from the pointer. This means that, as on the mainframe, the top bit can be manipulated directly by the user's code.

Properties:

Default: | NOAMODE
Phase: | Syntax check
$SET: | Initial

Dependencies:

AMODE"31" sets DATA"31" immediately.

Comments:

The AMODE directive must be used with any program module which:

  • Must create mainframe-style pointer items (using SET pointer-item TO ADDRESS OF data-item syntax)
  • Uses mainframe-style pointer items (using SET ADDRESS OF linkage-item TO pointer-item syntax)
  • Contains a working-storage item that will be passed to a subprogram that creates a mainframe-style pointer item to point to that working-storage item

In general, to eliminate potential problems that might occur when trying to be selective about which programs are compiled with this directive, we strongly recommended that you use the AMODE directive on all programs in the application, and that you use the same value for format for each subprogram.

The AMODE directive cannot be used for programs that need to call a Micro Focus library routine or an external API that expects pointer items to be in the native machine format.

AMODE is required when compiling applications that call assembler programs.

Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
Language Features - Mainframe Compatibility
DATA
Key to Compiler Directives


APOST

Makes the Compiler interpret the figurative constant QUOTE as the single-quote character (').

Syntax:

>>------APOST-----><

Parameters:

None

Properties:

Default: | QUOTE
Phase: | Syntax check
$SET: | Any

Comments:

The opposite of this directive is the directive QUOTE which causes the double-quote character (") to be used.

Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List
Related information
QUOTE
Key to Compiler Directives


BYTE-MODE-MOVE

Controls behavior for alphanumeric moves between overlapping data items.

Syntax:

>>-.---.-.----.---BYTE-MODE-MOVE------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOBYTE-MODE-MOVE
Phase: | Syntax check
$SET: | Initial

Comments:

The Compiler also accepts the directive-name without hyphens; that is BYTEMODEMOVE.

This directive is provided for compatibility with IBM mainframe compilers in the handling of forward overlapping alphanumeric moves - that is, where the start of the target data item overlaps the end of the source data item.

If BYTE-MODE-MOVE is specified, data is moved one byte at a time from the source to the target.

If NOBYTE-MODE-MOVE is specified, the data is moved in granules of two, four or more bytes at a time (depending on environment) from the source to the target. Consequently, if the overlap is less than the size of the granule, each granule moved overwrites part of the next granule to be moved.

NO-BYTE-MODE-MOVE gives better performance.

Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


COMP5-BYTE-ORDER

Specifies the byte ordering to be used for COMP-5 data.

Syntax:

>>-.--------.-COMP5-BYTE-ORDER-.--"ordering"----><
   +-/-+    +--COMP5BYTEORDER--+

Parameters:

ordering
One of:
NATIVE
The byte ordering of COMP-5 data items varies depending on the platform on which they are compiled.
PORTABLE
The byte ordering of COMP-5 data items is always the same as the byte ordering used on the mainframe.

Properties:

Default: | COMP5-BYTE-ORDER"NATIVE"
Phase: | Syntax check
$SET: | Initial

Comments:

You must not set COMP5-BYTE-ORDER"PORTABLE" if you are compiling SQL programs.

You might need to set COMP5-BYTE-ORDER"PORTABLE" if you are compiling mainframe CICS programs.

COMP-5 data is only available for use with the following dialects:

  • BS2000
  • BS2000-OFFLOAD
  • ENTCOBOL
  • MF
  • OS390

Setting COMP5-BYTE-ORDER for any other dialect has no effect.

Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


DYNAM

Specifies that CANCEL statements are not to be ignored.

Syntax:

 >>-.---.-.----.--DYNAM---------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | DYNAM(Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

With NODYNAM, CANCEL statements in the program are ignored.

Note: The mainframe DYNAM option only affects the CANCEL statements for programs invoked by CALL literal statements; CANCEL statements for programs invoked by CALL identifier statements are not affected. In this COBOL system, the DYNAM Compiler directive affects CANCEL statements for programs invoked by both CALL literal and CALL identifier statements.
Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Language Features - Mainframe Compatibility
Key to Compiler Directives


FP-ROUNDING

Determines whether one floating-point receiving item can affect the results of other, nonfloating-point receiving items.

Syntax:

 >>-.---.-.---FP-ROUNDING--"dialect"----.--------><
    +-/-+ +-NOFP-ROUNDING---------------+

Parameters:

dialect COB370, ISO2002, ENTCOBOL, MVS, OS390, OSVS or VSC2 .

Properties:

Default: | NOFP-ROUNDING (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

FP-ROUNDING"ISO2002" is the equivalent of NOFP-ROUNDING.

With all possible values of dialect except ISO2002, if any of the sending data items of an arithmetic statement are floating-point, all receiving fields are rounded, regardless of the presence or absence of the ROUNDED phrase and regardless of whether or not the receiving fields are floating-point.

With all possible values of dialect except ISO2002 and OSVS, if any receiving data item is defined as floating-point, rounding takes place for all receiving data items regardless of the presence or absence of the ROUNDED phrase, of whether or not the receiving field is floating-point, and of whether or not there are any sending items which are floating-point.

With NOFP-ROUNDING or FP-ROUNDING"ISO2002", no rounding takes place for fixed-point targets in calculations involving floating-point operands unless the ROUNDED phrase is explicitly used in the source.

Example:

If two data items are defined as follows:

     05 numeric-field    pic 999.
     05 floating-field   comp-1.

and the following statement is executed:

     compute numeric-field floating-field = 7.7 + 1

specifying FP-ROUNDING"VSC2" or FP-ROUNDING"COB370" results in numeric-field containing 9 (rounded), whereas specifying NOFP-ROUNDING, FP-ROUNDING"ISO2002" or FP-ROUNDING"OSVS" would result in numeric-field containing 8 (truncated).

If, using the same two data items, the following statement is executed:

compute numeric-field = +7.6E0

specifying FP-ROUNDING"VSC2", FP-ROUNDING"COB370" or FP-ROUNDING"OSVS" results in numeric-field containing 8 (rounded), whereas specifying NOFP-ROUNDING or FP-ROUNDING"ISO2002" results in numeric-field containing 7 (truncated).

Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - Compatibility with Other COBOL Dialects
Run-time Behavior - Mainframe Compatibility
Key to Compiler Directives


HOST-NUMCOMPARE

Controls the operation of comparisons between integer numeric data items of USAGE DISPLAY and alphanumeric literals, figurative constants, or numeric operands.
CAUTION:
This directive can adversely affect the performance of generated code.

Syntax:

>>--.---.--.----.--HOST-NUMCOMPARE------><
    +-/-+  +-NO-+

Parameters:

None

Properties:

Default: | NOHOST-NUMCOMPARE
Phase: | Syntax check
$SET: | Any

Comments:

This directive is provided to improve compatibility with IBM mainframe compilers, resulting in a run-time error 163 ("Illegal character in numeric field") in cases where a S0C7 would have occurred on the mainframe.

Setting HOST-NUMCOMPARE improves compatibility with IBM mainframe compilers for a subset of IF statements when comparing numeric data items with numeric data items or numeric literals.

It is not possible to guarantee 100% compatibility with the IBM mainframe behavior, but setting HOST-NUMCOMPARE does provide emulation for the most common cases.

HOST-NUMCOMPARE is only supported for SIGN settings of ASCII, MF, EBCDIC, and IBM.

Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


HOST-NUMMOVE

Ensures that run-time error 163 (illegal characters in numeric fields) does not occur when certain MOVE statements are executed on numeric display data items or numeric operands.

Syntax:

>>--.---.--.----.--HOST-NUMMOVE------><
    +-/-+  +-NO-+

Parameters:

None

Properties:

Default: | NOHOST-NUMMOVE
Phase: | Syntax check
$SET: | Any

Comments:

This directive is provided to improve compatibility with IBM mainframe compilers, resulting in a run-time error 163 ("Illegal character in numeric field") in cases where a S0C7 would have occurred on the mainframe.

Setting HOST-NUMMOVE improves compatibility with IBM mainframe compilers for a subset of MOVE statements involving numeric/alphanumeric data types and numeric/numeric data types.

It is not possible to guarantee 100% compatibility with the IBM mainframe behavior, but setting HOST-NUMMOVE does provide emulation for the most common cases.

HOST-NUMMOVE is only supported for SIGN settings of ASCII, MF, EBCDIC, and IBM.

CAUTION:
This directive can adversely affect the performance of generated code.
Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


HOSTRW

Determines whether report files are written using WRITE AFTER ADVANCING for better mainframe emulation when the MAINFRAMEPRINT=ON option is set.

Syntax:

>>-.---.-.----.--HOSTRW------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOHOSTRW
Phase: | Check
$SET: | Initial
Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related reference
The WRITE Statement
Related information
Key to Compiler Directives
MAINFRAMEPRINT


IBMCOMP

Turns on word-storage mode.

Syntax:

>>-.---.-.----.--IBMCOMP-------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOIBMCOMP (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

IBMCOMP sets ALIGN"8" immediately.

Comments:

In word-storage mode every data item of USAGE COMP or COMP-5 occupies either two bytes or a multiple of four bytes. If you specify IBMCOMP and you use the SYNCHRONIZED clause on any items defined as USAGE COMP or COMP-5 in your program, do not specify ALIGN"1".

If you are calling any Micro Focus systems routines directly, use IBMCOMP with great care. It might cause the parameters you specify to these routines to be incorrectly aligned and sized, causing the routines to give incorrect results. This includes parameters for the CBL_ library routines, calls to Adis and direct calls to the Callable File Handler, Extfh.

Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List
Related reference
DIALECT
ALIGN
Related information
Run-time Behavior - Mainframe Compatibility
Data Description Entry Skeleton
The USAGE Clause
Screen Section Entry Skeleton
The USAGE Clause in the Screen Section
The USAGE Clause
The SYNCHRONIZED Clause
Key to Compiler Directives


ODOOSVS

Makes the evaluation of OCCURS DEPENDING ON items more compatible with the OS/VS COBOL compiler.
Note: This directive is supported for native COBOL only.

Syntax:

 >>-.---.-.----.--ODOOSVS-------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOODOSVS(Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

ODOOSVS sets the ODOSLIDE Compiler directive at the end.

Comments:

When ODOOSVS is specified, the length of variable-length groups and the address of items following variable-length tables is evaluated at the time when the OCCURS DEPENDING ON item is modified, rather than at the time when the variable-length group or sliding data item is referenced.

Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - Mainframe Compatibility
Key to Compiler Directives


OLDCOPY

Makes COPY statements follow the ANSI'68 standard.

Syntax:

 >>-.---.-.----.--OLDCOPY-------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOOLDCOPYDialect)
Phase: | Syntax check
$SET: | Any
Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - Mainframe Compatibility
Key to Compiler Directives


PERFORM-TYPE

Specifies the behavior of return jumps from nested PERFORM statements.

Syntax:

>>-.---.--PERFORM-TYPE--"dialect"----------><
   +-/-+

Parameters:

dialect
One of:
MF
Only the exit point of the innermost PERFORM currently being executed is recognized and its return jump taken.
RM
The exit point of any PERFORM statement currently being executed is recognized if reached; the return jump taken is the first reached. PERFORM statements with the same exit point cannot be nested; if they are they do not return correctly. The end of a section is regarded as a separate point from the end of its last paragraph.
COB370, ENTCOBOL, OS390, OSVS, VSC2
The exit point of any PERFORM statement currently being executed is recognized if reached; the return jump taken is the first reached. PERFORM statements with the same exit point can be nested to a depth of two (one inner and one outer). If they are nested deeper, they do not return correctly. The end of a section is regarded as a separate point from the end of its last paragraph.
  • PERFORM-TYPE"COB370" provides compatibility with the mainframe behavior of COBOL/370.
  • PERFORM-TYPE"ENTCOBOL" provides compatibility with the mainframe behavior of Enterprise COBOL.
  • PERFORM-TYPE"OS390" provides compatibility with the mainframe behavior of OS/390 COBOL.
  • PERFORM-TYPE"OSVS" provides compatibility with the mainframe behavior of OS/VS COBOL and DOS/VS COBOL.
  • PERFORM-TYPE"VSC2" provides compatibility with the mainframe behavior of VS COBOL II.

Properties:

Default: | PERFORM-TYPE"MF" (All mainframe dialects)
Phase: | Syntax check
$SET: | Initial

Dependencies:

PERFORM-TYPE"OSVS" sets TRICKLE at end.

Comments:

Note: PERFORM-TYPE "OSVS", PERFORM-TYPE "VSC2" and PERFORM-TYPE "COB370" are supported in native COBOL only.
Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
Perform Statements
STICKY-PERFORM
Run-time Behavior - Compatibility with Other COBOL Dialects
Key to Compiler Directives


QUOTE

Makes the Compiler interpret the figurative constant QUOTE as the double-quote character (").

Syntax:

>>-.---.--QUOTE----------------------------><
   +-/-+

Parameters:

None

Properties:

Default: | QUOTE (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

The opposite of this directive is the directive APOST which causes the single-quote character to be used.

Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List


REMAINDER

Enables you to select how the remainder is calculated in a DIVIDE statement.

Syntax:

 >>------REMAINDER---"integer"-----------><

Parameters:

integer
Must be one of:
1
The Compiler uses the ANSI 85 algorithm.
2
The Compiler uses an algorithm employing a subsidiary quotient. This subsidiary quotient is signed and is of sufficient size to hold any valid value. All current IBM mainframe compilers use this non-standard algorithm.

Properties:

Default: | REMAINDER"1" (Dialect)
Phase: | Syntax check
$SET: | Any
Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - Mainframe Compatibility
Key to Compiler Directives


SIGN-FIXUP

Provides limited emulation of mainframe compiler options NUMPROC(NOPFD) and NUMPROC(PFD) for MOVE and COMPARE statements.
Attention: This directive can adversely affect the performance of generated code.

Syntax:

 >>-.---.-.----.--SIGN-FIXUP------------------><
    +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOSIGN-FIXUP
Phase: | Syntax check
$SET: | Initial

Comments:

The effect of this directive is as follows:

  • SIGN-FIXUP provides a limited emulation of the mainframe compiler option NUMPROC(NOPFD) when using the HOST-NUMCOMPARE and HOST-NUMMOVE directives. It is not possible to provide a complete emulation of NUMPROC(NOPFD) behavior.
  • NOSIGN-FIXUP provides emulation of the mainframe compiler option NUMPROC(PFD) when using the HOST-NUMCOMPARE and HOST-NUMMOVE directives.

SIGN-FIXUP is only supported for SIGN settings of ASCII, MF, EBCDIC, and IBM.

Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List


SYSPUNCH

Specifies the SYSPUNCH record length to be used.

Syntax:

>>-.---.--SYSPUNCH--"integer"-------------><
   +-/-+

Parameters:

integer
The record length to be used.

Properties:

Default: | SYSPUNCH"132" (Dialect)
Phase: | Syntax check
$SET: | Any
Parent topic: Run-time Behavior - Mainframe Compatibility
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - Mainframe Compatibility
Key to Compiler Directives


Run-time Behavior - Compatibility with Older Micro Focus Products

  • AUTOLOCK
    Makes the default locking AUTOMATIC rather than EXCLUSIVE for files opened I-O or EXTEND in a multi-user environment.
  • COMP-5
    Specifies whether the sign is to be dropped when a value is stored in an unsigned COMP-5 data item.
  • COMP
    Makes the Compiler produce very compact and efficient code for some statements involving COMP data items, by treating COMP items as COMP-X.
  • DE-EDIT
    Specifies the behavior of de-editing moves from numeric-edited items to other numeric-edited items or to numeric items.
  • FILESHARE
    Causes the default locking to become AUTOMATIC rather than EXCLUSIVE for files in a multi-user environment, and automatically locks records on a WRITE or REWRITE statement when the program is locking multiple records.
  • IOCONV
    Selects between a straight group move and conversion of elementary record descriptions (ANSI behavior) when processing READ ... INTO and WRITE ... FROM statements.
  • MF, MFLEVEL
    Facilitates forward compatibility with Micro Focus COBOL systems by selectively enabling Micro Focus-specific reserved words and changing the behavior of certain features to be compatible with particular versions.
  • OLDBLANKLINE
    Changes the behavior of the BLANK LINE clause in the Screen Section.
  • OLDINDEX
    Causes indexes to be compiled as subscripts.
  • OLDNEXTSENTENCE
    Changes the behavior of the NEXT SENTENCE statement.
  • OLDREADINTO
    Changes the behavior of the READ ... INTO statement.
  • OLDSTRMIX
    Allows PIC X and PIC N fields to be specified in the same STRING, UNSTRING or INSPECT statement
  • SPZERO
    Causes space characters in numeric data items of USAGE DISPLAY to be treated as zeros.
  • WRITELOCK, WRITE-LOCK
    Makes the WRITE and REWRITE statements acquire a record lock when the program is locking multiple records in a shared data file in a multi-user environment.
Parent topic: Run-time Behavior


COMP

Makes the Compiler produce very compact and efficient code for some statements involving COMP data items, by treating COMP items as COMP-X.

Syntax:

>>-.---.-.----.--COMP----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOCOMP
Phase: | Syntax check
$SET: | Initial

Comments:

This COMP code produced by the Compiler behaves in a way that is not the ANSI standard in cases of numeric overflow. You should use this directive only if you know that your program does not lead to numeric overflow, or if you want to use the defined (but nonstandard) behavior on overflow.

Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


DE-EDIT

Specifies the behavior of de-editing moves from numeric-edited items to other numeric-edited items or to numeric items.

Syntax:

>>-.---.--DE-EDIT--"integer"---------------><
   +-/-+

Parameters:

integer
Indicates which compatibility required.
1
Behavior as in earlier versions of this Compiler. Ignores the PICTURE clause of the sending field.
2
De-edits according to the PICTURE clause of the sending field. This provides ANSI'85 conformance.

Properties:

Default: | DE-EDIT"2" (Dialect)
Phase: | Syntax check
$SET: | Any

Example:

 01 a  pic 909V99 value "30456".
 01 b  pic 9(5).
        ...
     move a to b

With DE-EDIT"1", b contains 30456. With DE-EDIT"2", b contains 00034; the 0 after the 3 is dropped because it corresponds to the insertion character 0 in the picture-string of a, and the .56 is dropped because B has no decimal places.

Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List
Related reference
DIALECT
Related information
Run-time Behavior - Compatibility with Older Micro Focus Products
The Special-Names Paragraph
The INITIALIZE Statement
Key to Compiler Directives


IOCONV

Selects between a straight group move and conversion of elementary record descriptions (ANSI behavior) when processing READ ... INTO and WRITE ... FROM statements.

Syntax:

>>-.---.-.----.--IOCONV--------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | IOCONV (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

NOIOCONV causes a straight group move for READ ... INTO and WRITE ... FROM operations. This is for backward compatibility.

IOCONV causes conversion of elementary record descriptions when required. This is normal ANSI behavior, and the default.

Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


OLDBLANKLINE

Changes the behavior of the BLANK LINE clause in the Screen Section.

Syntax:

>>-.---.-.----.--OLDBLANKLINE--------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOOLDBLANKLINE
Phase: | Syntax check
$SET: | Any

Comments:

When OLDBLANKLINE is specified, the BLANK LINE clause behaves exactly the same as ERASE EOL; that is all characters to the right of the cursor are deleted.

With NOOLDBLANKLINE specified, the BLANK LINE clause causes the whole line to be deleted.

Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


OLDINDEX

Causes indexes to be compiled as subscripts.

Syntax:

>>-.---.-.----.--OLDINDEX------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOOLDINDEX (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to NOOLDINDEX immediately by NORM. Set to OLDINDEX immediately by RM and RM"ANSI".

Comments:

This directive is for compatibility with earlier products.

Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


OLDNEXTSENTENCE

Changes the behavior of the NEXT SENTENCE statement.

Syntax:

>>-.---.-.----.--OLDNEXTSENTENCE-----------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOOLDNEXTSENTENCE (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

When OLDNEXTSENTENCE is specified, the NEXT SENTENCE statement behaves like a CONTINUE statement.

Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


OLDSTRMIX

Allows PIC X and PIC N fields to be specified in the same STRING, UNSTRING or INSPECT statement

Syntax:

>>-.---.-.----.--OLDSTRMIX---------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOOLDSTRMIX (Dialect)
Phase: | Syntax check
$SET: | Any

Comments:

This directive is provided for backward compatibility only.

We recommend that you do not use it as it can lead to unexpected results and the corruption of double-byte data.

Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


SPZERO

Causes space characters in numeric data items of USAGE DISPLAY to be treated as zeros.
Note:
  • This directive has been deprecated; it is provided for backward compatibility only. You should instead use SIGN-FIXUP.
  • This directive can adversely affect the performance of generated code.
  • The .NET Framework does not support SPZERO or SIGN-FIXUP.

Syntax:

>>-.---.-.----.--SPZERO--------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOSPZERO (Dialect)
Phase: | Both
$SET: | Any

Comments:

With NOSPZERO, space characters in numeric data items give unpredictable results.

Parent topic: Run-time Behavior - Compatibility with Older Micro Focus Products
Parent topic: Compiler Directives - Alphabetical List


Run-time Behavior - Compatibility with Other COBOL Dialects

  • ALPHASTART
    Sets the number from which the Compiler counts positions in the collating sequence when compiling the ALPHABET clause.
  • APOST
    Makes the Compiler interpret the figurative constant QUOTE as the single-quote character (').
  • CASE
    Prevents external symbols (such as Program-ID and names of called programs) being converted to upper case.
  • COMP-6
    Specifies whether COMP-6 data is to be held in binary or packed decimal format.
  • DBSPACE
    Makes the Compiler interpret the figurative constant SPACE, when used as a DBCS figurative constant, as the double-byte space character supplied by the system.
  • FDCLEAR
    Specifies that the record buffer for a file should be cleared after every write operation.
  • IBMCOMP
    Turns on word-storage mode.
  • INTDATE
    Selects the starting date for integer format dates used with date intrinsic functions.
  • ODOSLIDE
    Moves data items that follow a variable-length table in the same record as the table's length changes.
  • OPTIONAL-FILE
    Makes the Compiler treat all files opened for I-O or EXTEND as optional.
  • QUOTE
    Makes the Compiler interpret the figurative constant QUOTE as the double-quote character (").
  • RETRYLOCK
    Specifies that when a READ statement finds that a record is locked the read operation is to be retried repeatedly until the record is available.
  • SIGN
    Specifies which convention numeric DISPLAY items with included signs should use.
  • SSRANGE
    Turns on bounds checking for reference modifications, subscripting and indexes.
  • STICKY-PERFORM
    Specifies the behavior of PERFORM statements when a program is reentered.
  • SWITCH-TYPE
    Makes programmable switches behave in the same way as in the ISO 2002 standard.
  • SYMBSTART
    Sets the number from which the Compiler counts positions in the collating sequence when compiling the SYMBOLIC CHARACTERS clause.
  • TRUNC
    Specifies whether data being stored into a USAGE COMP, USAGE BINARY or USAGE COMP-4 item is to be truncated to the size given by the item's PICTURE clause or to the maximum size the item can hold.
Parent topic: Run-time Behavior


ALPHASTART

Sets the number from which the Compiler counts positions in the collating sequence when compiling the ALPHABET clause.

Syntax:

>>-.---.--ALPHASTART--"integer"------------><
   +-/-+

Parameters:

integer The number to be used.

Properties:

Default: | ALPHASTART"1" (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

For ANSI conformance use ALPHASTART"1".

Example:

With ALPHASTART"1", the COBOL statement:

alphabet myalpha is 66,  67

declares an alphabet consisting of "A" and "B" since, counting from 1, these are the 66th and 67th characters in the ASCII collating sequence. With ALPHASTART"0", MYALPHA consists of "B" and "C".

Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List


CASE

Prevents external symbols (such as Program-ID and names of called programs) being converted to upper case.

Syntax:

>>-.---.-.----.--CASE----------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOCASE
Phase: | Generate
$SET: | Any

Comments:

CASE leaves the case of external symbols as is. This is useful if you are calling a program written in C, where names are case dependent.

NOCASE folds external symbols to upper case.

Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List


DBSPACE

Makes the Compiler interpret the figurative constant SPACE, when used as a DBCS figurative constant, as the double-byte space character supplied by the system.

Syntax:

>>-.---.-.----.--DBSPACE-------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | Depends on the setting of MF"integer". If integer is greater than 7, the default is DBSPACE. Otherwise, it is NODBSPACE. (Dialect)
Phase: | Syntax check
$SET: | Any

Dependencies:

DBSPACE set immediately by COBOL370, NCHAR"2", SAA, VSC2"2" or VSC2"3".

DBSPACE set immediately by MF"integer". If integer is greater than 7

Comments:

With DBSPACE, the Compiler uses the system-supplied double-byte space character. NODBSPACE provides compatibility with previous versions of this Compiler, where the double-byte space character was two ASCII space characters (x"2020").

Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List


ODOSLIDE

Moves data items that follow a variable-length table in the same record as the table's length changes.

Syntax:

>>-.---.-.----.--ODOSLIDE------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOODOSLIDE
Phase: | Syntax check
$SET: | Initial

Dependencies:

The ODOSLIDE directive is set at the end by the ODOOSVS Compiler directive.

Comments:

This affects data items that appear after a variable-length table in the same record; that is, after an item with an OCCURS DEPENDING clause, but not subordinate to it.

With ODOSLIDE, these items always immediately follow the table, whatever its current size; this means their addresses change as the table's size changes. With NOODOSLIDE, these items have fixed addresses, and begin after the end of the space allocated for the table at its maximum length.

Note: You cannot have boolean data items following a variable-length table in the same record. Also, you cannot have boolean data items after a variable-length table in the same record.
Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List
Related concepts
Nested OCCURS DEPENDING Clauses
Related information
Run-time Behavior - Compatibility with Other COBOL Dialects
File Description Entry Skeleton
Data Description Entry Skeleton
The OCCURS Clause
The RECORD Clause
The GO TO Statement
Key to Compiler Directives


SIGN

Specifies which convention numeric DISPLAY items with included signs should use.

Syntax:

>>-.---.--SIGN--"convention"---------------><
   +-/-+

Parameters:

convention The sign storage convention. Must be one of
  • ASCII
  • MF (identical to ASCII)
  • EBCDIC
  • IBM (identical to EBCDIC)
  • acu
  • mbp
  • ncr
  • realia
  • vax

Properties:

Default: | SIGN"ASCII"
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to SIGN"ASCII" immediately by CHARSET"ASCII".

Set to SIGN"EBCDIC" at end by CHARSET"EBCDIC".

Comments:

If you specify CHARSET"ASCII" and SIGN"EBCDIC", and either HOSTNUMMOVE or HOSTNUMCOMPARE are already on, SIGN"EBCDIC" is ignored.

The convention parameter options have the following meanings:

ASCII, MF
The Micro Focus storage convention.
EBCDIC, IBM
The IBM storage convention. It is compatible with IBM COBOL, RM/COBOL-85, and the X/Open COBOL standard.
acu
The ACUCOBOL-GT storage convention. This convention is also compatible with data produced by RM/COBOL (not RM/COBOL-85) and previous versions of ACUCOBOL-GT.
mbp
The MBP COBOL sign storage convention.
Important: The MBP COBOL sign storage convention for USAGE DISPLAY directly conflicts with that used by IBM COBOL and some other COBOLs. As a result, signed USAGE DISPLAY items in the MBP format are correctly understood only when the program is compiled the mbp option. This is unlike the other sign conventions in which the runtime can usually extract the correct value even when a mismatched sign convention is specified at compile time.
Restriction: MBP COBOL does not have the COMP-2 storage type.
ncr
This causes a different numeric format to be used. The format is the same as the one used when the EBCDIC or IBM option is used, except that positive COMP-3 items use x0B as the positive sign value instead of x0C. This option is compatible with NCR COBOL.
realia
The Realia sign storage convention. Sign information for S9(n) variables is stored using the conventions for Realia COBOL, and their conversion to binary decimal is the same as that performed by the Realia compiler.
vax
This creates numeric sign formats that are compatible with VAX COBOL. These are identical to the IBM formats, except that unsigned COMP-3 fields place x0C in the sign position instead of x0F.
Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List


SSRANGE

Turns on bounds checking for reference modifications, subscripting and indexes.

Syntax:

>>-.---.-.-SSRANGE-.----------.--.-------><
   +-/-+ |         +-"integer"+  |
         +-NOSSRANGE-------------+

Parameter:

integer
The level of SSRANGE support required. The possible values are:
1
At run time, subscripts and indexes are checked to ensure they are not referencing an area outside the table, and reference modified items are checked for negative or zero value.
2
At both compile time and run time, subscripts, reference modified items, and indexes are checked to ensure they are not referencing an area outside the table.

Properties:

Default: | NOSSRANGE
Phase: | Syntax check
$SET: | Initial

Dependencies:

Sets BOUND immediately

Comments:

If you set SSRANGE without an integer, the behavior is the same as SSRANGE(2).

Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List
Related information
BOUND
Run-time Behavior - Compatibility with Other COBOL Dialects
Key to Compiler Directives


STICKY-PERFORM

Specifies the behavior of PERFORM statements when a program is reentered.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--STICKY-PERFORM------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOSTICKY-PERFORM (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

This directive has an effect only if your program was compiled with either PERFORM-TYPE"OSVS" or PERFORM-TYPE"RM" specified.

If you specified PERFORM-TYPE"OSVS" or PERFORM-TYPE"RM" when compiling, PERFORM statements are implemented by having a storage area, or bucket, associated with each place in the program that can be the end of a PERFORM statement's range. When a PERFORM statement is executed the return address is stored in the bucket, and at the end of the PERFORM statement's range the bucket is read to determine where control should return to and then cleared.

By default, an EXIT PROGRAM statement clears these buckets, so that if the program is reentered, none of the return addresses of the previously executed PERFORM statements remains. Specifying STICKY-PERFORM stops the buckets from being cleared by an EXIT PROGRAM statement. This means that on reentry, the return addresses of all previously executed PERFORM statements remain.

A STOP RUN or CANCEL statement clears the buckets regardless of the setting of this directive.

Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List


SWITCH-TYPE

Makes programmable switches behave in the same way as in the ISO 2002 standard.

Syntax:

>>-.---.-.----.--SWITCH-TYPE--"integer"-------------------><
   +-/-+ +-NO-+

Parameters:

integer
One of:
1
Behavior of this COBOL system
2
ISO 2002 behavior
3
Siemens BS2000 COBOL behavior

Properties:

Default: | SWITCH-TYPE"1"
Phase: | Syntax check
$SET: | Any

Comments:

In the ISO 2002 standard, and the Siemens BS2000 COBOL dialect, switches persist and are visible throughout a run unit. For example, if program A calls program B then any changes to the switches in A are visible when B is called, and any changes made in B are visible in A when control returns to A. If, however, A terminates and B is called, then the changes made by A are lost. The space in which the switches are stored can be regarded as common to all programs in a run unit; hence changes to the switches are visible to all programs.

In this COBOL system, and older versions of Micro Focus COBOL, any called subprogram (in this case B) has its own set of COBOL switches independent of any other program. If program A calls program B, program B's switches are set to the same values as A's were at program start - ignoring any changes A might have made to the switches. When control returns to program A, A's switches are exactly the same as they were before program control changed - ignoring any changes B might have made to the switches. B's switches are preserved (unless it is canceled), so that if invoked again its own switches are set as when it called A. In this case, the space in which switches are stored can be regarded as unique to each program.

SWITCH-TYPE"3" supports the Siemens BS2000 COBOL TSW-n and USW-n switches.

You should only use SWITCH-TYPE"3" when the BS/2000 add-on is present to provide the necessary run-time support.

Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List
Related information
Run-time Behavior - Compatibility with Other COBOL Dialects
DIALECT
BS2000
Key to Compiler Directives


SYMBSTART

Sets the number from which the Compiler counts positions in the collating sequence when compiling the SYMBOLIC CHARACTERS clause.

Syntax:

>>-.---.--SYMBSTART--"integer"-------------><
   +-/-+

Parameters:

integer The number to be used.

Properties:

Default: | SYMBSTART"1" (Dialect)
Phase: | Syntax check
$SET: | Initial

Comments:

For ANSI conformance use SYMBSTART"1"; for compatibility with previous products use SYMBSTART"0".

Example:

With SYMBSTART"1", the COBOL statement:

symbolic characters bee is 67

declares a symbolic character bee representing "B" since, counting from 1, "B" is the 67th character in the ASCII collating sequence. With SYMBSTART"0", bee represents "C".

Parent topic: Run-time Behavior - Compatibility with Other COBOL Dialects
Parent topic: Compiler Directives - Alphabetical List


Run-time Behavior - Speed or Size

  • ALIGN
    Specifies the memory boundaries on which data items of level-01 or level-77 are aligned.
  • BOUND
    Specifies that subscript or index values are to be checked to ensure they are within the limits defined by their OCCURS clause.
  • BOUNDOPT
    Optimizes the code generated for subscripts.
  • CHECK
    Turns on all run-time checks in generated code.
  • CHECKREFMOD
    Turns on bounds checking for reference modification.
  • FCDALIGN
    Ensures the memory boundaries of the file control descriptions (FCDs) associated with SYSIN, SYSOUT and SYSPUNCH files are aligned in the same way as other FCDs and internal structures.
  • FIXOPT
    Changes the way in which generated code accesses the Data Division in object (.obj) code.
  • LINKALIAS
    Lets the user provide assurances to the compiler about how linkage items will be used, to aid optimization.
  • LINKCHECK
    Specifies that each time a Linkage Section item is referenced a check is to be made that it exists.
  • MFSYNC
    Synchronizes items based on their size.
  • PARAMCOUNTCHECK
    Enables the program to be called with fewer parameters than are specified in the relevant entry point's USING clause.
  • PERFORMOPT
    Determines if the Compiler should optimize out code to PERFORM empty paragraphs in generated native code.
  • RECURSECHECK
    Turns on checking for recursion in generated code.
Parent topic: Run-time Behavior


ALIGN

Specifies the memory boundaries on which data items of level-01 or level-77 are aligned.

Syntax:

>>-.---.--ALIGN--"integer"-----------------><
   +-/-+

Parameters:

integer The distance from the start of one level-01 to the start of the next is a multiple of this. Can take any value from 1 to 255.

Properties:

Default: | ALIGN"8" (Dialect)
Phase: | Syntax check
$SET: | Initial

Dependencies:

Set to ALIGN"8" immediately by IBMCOMPor NORM. Set to ALIGN"2" immediately by RM or RM"ANSI".

Comments:

Data items of level-01 are aligned on byte boundaries that are multiples of the value given.

This can help produce more efficient execution results but does mean more memory might be used.

Setting integer to a number that is not a multiple of four could impair the efficiency of the generated code.

Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List
Related information
DIALECT
Run-time Behavior - Speed or Size
Key to Compiler Directives


BOUND

Specifies that subscript or index values are to be checked to ensure they are within the limits defined by their OCCURS clause.

Syntax:

>>-.---.-.----.--BOUND---------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | BOUND (Dialect)
Phase: | Both
$SET: | Initial

Dependencies:

BOUND sets NOBOUNDOPT at end.

Set to BOUND by CHECK.

Comments:

For multi-dimensional tables, only the composite subscript is checked. If any of the individual subscripts or indices is beyond its limit, but the reference remains within the table, no error is produced.

Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List
Related information
Table Bound Checking
DIALECT
Run-time Behavior - Speed or Size
BOUNDOPT
Data Description Entry Skeleton
The OCCURS Clause
Screen Section Entry Skeleton
The OCCURS Clause in the Screen Section
Key to Compiler Directives


BOUNDOPT

Optimizes the code generated for subscripts.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--BOUNDOPT------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | BOUNDOPT
Phase: | Generate
$SET: | Initial

Dependencies:

Set to NOBOUNDOPT at end by BOUND.

Comments:

If BOUNDOPT is used, subscripts can be optimized on the assumption that they do not exceed the bounds of the table. In particular, any digits in a subscript above the size of the table may be ignored.

Can only be used when NOBOUND is specified. NOBOUNDOPT must be specified if a program references beyond the end of a table.

Example:

For a table with 50 entries, a PIC 9(3) subscript is treated as PIC 9(2), with the most significant digit ignored.

Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List
Related information
Table Bound Checking


CHECKREFMOD

Turns on bounds checking for reference modification.

Syntax:

>>-.---.-.----.--CHECKREFMOD-------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | NOCHECKREFMOD
Phase: | Check
$SET: | Initial
Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List
Related reference
Related information
Key to Compiler Directives


FCDALIGN

Ensures the memory boundaries of the file control descriptions (FCDs) associated with SYSIN, SYSOUT and SYSPUNCH files are aligned in the same way as other FCDs and internal structures.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.-.----.--FCDALIGN------------------><
   +-/-+ +-NO-+

Parameters:

None

Properties:

Default: | FCDALIGN
Phase: | Check
$SET: | Any
Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List
Related information
Key to Compiler Directives
File Control Description (FCD)
ALIGN


LINKALIAS

Lets the user provide assurances to the compiler about how linkage items will be used, to aid optimization.

Syntax:

>>-.---.-.----.--LINKALIAS "type"-----------------><
   +-/-+ +-NO-+

Parameters:

type One of:
all
no assurances
paramdisjoint
parameters are assumed to be disjoint
none
linkage items will not be used to reference local-, thread-local- or working-storage, and incoming parameters are disjoint

Properties:

Default: | LINKALIAS(ALL)
Phase: | Generate
$SET: | Initial
Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List
Related information
Run-time Behavior - Speed or Size
Configuration Section
Input-Output Section
General Description
Working-Storage Section
Thread-Local-Storage Section
Object-Storage Section
Local-Storage Section
Linkage Section
Screen Section
Procedure Division General Description
The EXIT Statement
Input-Output Section
Report Section
Key to Compiler Directives


MFSYNC

Synchronizes items based on their size.

Syntax:

>>-.---.-.----.--MFSYNC-"integer"---------><
   +-/-+ +-NO-+

Parameters:

integer
The synchronization value defines the maximum synchronization boundary on which items will by synchronized (based on their size):
2 will synchronize:
2 byte comp/comp-x/comp-5 sync
pic x(4) comp/comp-x/comp-5 sync
pic x(8) comp/comp-x/comp-5 sync
 on boundary:
 2
 2
 2
4 will synchronize:
2 byte comp/comp-x/comp-5 sync
pic x(4) comp/comp-x/comp-5 sync
pic x(8) comp/comp-x/comp-5 sync
 on boundary:
 2
 4
 4
8 will synchronize:
2 byte comp/comp-x/comp-5 sync
pic x(4) comp/comp-x/comp-5 sync
pic x(8) comp/comp-x/comp-5 sync
 on boundary:
 2
 4
 8

Properties:

Default: | NOMFSYNC
Phase: | Syntax check
$SET: | Initial

Dependencies:

If MFSYNC is specified alone (that is, without a qualifier) the effect will be as if MFSYNC"4" was specified.

Comments:

Applying the MFSYNC directive on a compilation unit can improve code generation and execution speed considerably. However, applying MFSYNC to a program that was developed without consideration for the MFSYNC effect on Data Division and record layout could have a detrimental effect on the program’s semantics.

Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List


PERFORMOPT

Determines if the Compiler should optimize out code to PERFORM empty paragraphs in generated native code.
Note: This directive is supported for native COBOL only.

Syntax:

>>-.---.--PERFORMOPT---------------------><
   +-/-+

Parameters:

None

Properties:

Default: | PERFORMOPT
Phase: | Generate
$SET: | Initial

Comments:

For greatest efficiency the Compiler normally does not generate code for a PERFORM statement that references an empty paragraph. If you require the code to be left in, for example for timing purposes, specify NOPERFORMOPT.

Parent topic: Run-time Behavior - Speed or Size
Parent topic: Compiler Directives - Alphabetical List


Key to Compiler Directives

Descriptions for all of the Compiler directives appear alphabetically. Each description contains the following entries.

DIRECTIVE-NAME
A brief description of the function of DIRECTIVE-NAME.
Syntax
Syntax in the form:
                                +--------------+
                                V              |
>>-.---.-.-------DIRECTIVE-NAME--"parameter(s)"-.-><
   +-/-+ +.----.-DIRECTIVE-NAME-----------------+
          +-NO-+

The syntax of the directives is shown using diagrams called "railroad tracks", in which a directive and its parameters are shown joined by lines indicating the order in which they should be written. You read these diagrams from left-to-right. Each diagram starts with >> and ends with ><. Sometimes the track forks to show alternatives and then joins up again. The length of a track has no significance.

The loop over the parameter in the above example indicates that it can be repeated one or more times.

Parameters for directives are shown in quotation marks (" "), although you can use parentheses instead unless otherwise stated.

If a parameter is specified after a comma, but the filename is omitted, the directive must be preceded by a slash (/). Otherwise, the directive is incorrectly assumed to be a filename.

When writing the names of Compiler directives, you can use hyphens to improve their readability. A directive that contains hyphens is handled in exactly the same way as a directive that does not; for example, DPC-IN-SUBSCRIPT is the same as DPCINSUBSCRIPT.

Parameters
Lists and describes valid parameter(s), if any, for the directive.
Properties
Default: Indicates the directive's default setting. If you set the DIALECT directive to a particular value, some other directives are set to a value that overrides either the default, or any value to which you have the directives. Directives that are set by DIALECT are indicated by (DIALECT ). Click the link to display the DIALECT page to check the dialect-specific setting. For more information on using the DIALECT directive to set directives, see The DIALECT Directive.
Phase: Shows the phase controlled by this directive. One of:
  • Syntax check
  • Generate
  • Both
$SET: Shows whether you can put the directive on a $SET statement in your source program; "Initial" in this entry means it is only allowed on a $SET statement before the first line of COBOL code. The directives specified by a $SET statement in the source code must not exceed column 72.
IDE equivalent | Specifies how to apply the directive using the IDE
Assembly Manifest Attribute | Defines the attribute that is set in the assembly manifest
Dependencies
Shows if the setting of this directive changes the setting of any other directives, or if any other directives affect the setting of this directive.
There are a number of different cases, identified under this heading by the following keywords:
immediately | The change specified is done immediately, as a part of the processing of this directive. This enables you to reset the value by specifying the second directive after the first. Don't do this unless you know what you are doing.
at end | The change specified takes place when all the directives have been processed. This prevents you from overriding the new value.
Comments
Contains any additional information about the directive.
Parent topic: Compiler Directives


Compiler Directives - Alphabetical List

  • ACCEPTREFRESH
    Specifies whether the data areas associated with Screen Section data are updated from their corresponding Working-Storage Section items before an ACCEPT statement.
  • ACTUAL-PARAMS
    Specifies actual parameters that are substituted for formal parameters in a parameterized class or interface.
  • ACU
    Enables compatibility with ACUCOBOL-GT COBOL.
  • ACUOPT
    Enables you to set various options specifically for compilation of ACUCOBOL-GT applications.
  • ACU-COMMENT
    Treats lines of code starting with a pipe (|) as comment lines.
  • ACUSYNC
    Changes the effect of the SYNC clause so that it matches that used in ACU programs.
  • ADDRSV
    Adds one or more specific reserved words to the reserved word list so that they are recognized as reserved words in your program. The specified reserved words are added, whatever dialect directives are in force.
  • ADDSYN
    Defines a user-defined reserved word to be synonymous with an existing reserved word.
  • ADV
    Causes a control character to be inserted at the start of each line in a print file. This is for compatibility with mainframe operation.
  • ALIGN
    Specifies the memory boundaries on which data items of level-01 or level-77 are aligned.
  • ALPHASTART
    Sets the number from which the Compiler counts positions in the collating sequence when compiling the ALPHABET clause.
  • ALTER
    Allows ALTER statements in your program.
  • AMODE
    Provides compatibility with mainframe-style pointers.
  • ANIM
    Makes the Compiler produce extra information so that you can debug your program.
  • ANS85
    Specifies that words reserved in the ANSI'85 COBOL Standard are to be treated as reserved words in this COBOL system, and changes the behavior of certain features to be compatible with that Standard.
  • APOST
    Makes the Compiler interpret the figurative constant QUOTE as the single-quote character (').
  • AREACHECK
    Causes the Compiler to treat any token which starts in area A in the Procedure Division as a paragraph or section label, regardless of the preceding tokens.
  • ARITHMETIC
    Specifies how arithmetic expressions are to be evaluated.
  • ASSIGN
    Specifies how to assign a filename when neither EXTERNAL nor DYNAMIC appear in the SELECT statement.
  • ASSIGN-PRINTER
    Specifies how to assign the output from an ASSIGN TO PRINTER clause when the clause does not specify a filename.
  • AUTOLOCK
    Makes the default locking AUTOMATIC rather than EXCLUSIVE for files opened I-O or EXTEND in a multi-user environment.
  • BELL
    Makes the bell sound at points such as when compilation stops, either because of an error or because it has finished.
  • BINLIT
    Controls whether binary b"" literals are interpreted as numeric values, or Boolean values for use with PIC 1 data items.
  • BOUND
    Specifies that subscript or index values are to be checked to ensure they are within the limits defined by their OCCURS clause.
  • BOUNDOPT
    Optimizes the code generated for subscripts.
  • BRIEF
    Enables the Compiler to produce only error numbers, and no message texts.
  • BS2000
    Ensures that words reserved under the Siemens BS2000 COBOL dialect are reserved words in this COBOL system, and changes the behavior of certain features to be compatible with that COBOL dialect.
  • BWZSTAR
    Determines whether the BLANK WHEN ZERO clause is allowed in the Data Division for those fields defined with the "*" PICTURE symbol.
  • BYTE-MODE-MOVE
    Controls behavior for alphanumeric moves between overlapping data items.
  • CALL-RECOVERY
    Specifies the behavior when control is returned to a program.
  • CALLFH
    Makes the Compiler generate direct calls for all file I/O operations, using the Callable File Handler interface.
  • CALLMCS
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • CALLSORT
    Defines the program to be called to handle all SORT and MERGE operations.
  • CANCEL
    This directive may appear in source code supplied by Micro Focus. NOCANCEL stops sub-programs being canceled by the RTS for CANCEL and CHAIN statements and other circumstances when the main user application is canceled.
  • CANCELLBR
    Makes the Compiler close an .lbr file used as a library in a COPY statement once that copy operation is complete.
  • CASE
    Prevents external symbols (such as Program-ID and names of called programs) being converted to upper case.
  • CHANGE-MESSAGE
    Changes the severity of errors/messages. Messages can also be suppressed or returned to their original severity.
  • CHARSET
    Defines the character set of the environment.
  • CHECK
    Turns on all run-time checks in generated code.
  • CHECKDIV
    Controls the behavior of your program if it tries to divide by zero in a statement that has no ON SIZE ERROR phrase.
  • CHECKNUM
    Checks whether numeric fields contain valid data before performing operations on them.
  • CHECKREFMOD
    Turns on bounds checking for reference modification.
  • CICSECM
    Causes EXEC CICS statements in your program to be replaced by CICS API run-time calls.
  • CMPR2
    Provides compatibility with the mainframe compiler option of the same name, which returns behavior of the COBOL 370, VS COBOL II version 3 and VS COBOL II version 4 compilers to that of the VS COBOL II version 2 compiler.
  • COBFSTATCONV
    Causes the Callable File Handler to use the user-supplied module specified in the COBFSTATCONV environment variable to convert the file status codes if an I/O error is encountered on a file.
  • COBIDY
    Specifies the path where the .idy file is to be written.
  • COBOL370
    Specifies that words reserved in IBM COBOL/370 are to be treated as reserved words, and allows features selectively for compatibility with a given level of that product.
  • COBOLDIR
    Specifies whether the Compiler should process the directives in a cobol.dir file or ignore it.
  • COMP
    Makes the Compiler produce very compact and efficient code for some statements involving COMP data items, by treating COMP items as COMP-X.
  • COMP5-BYTE-ORDER
    Specifies the byte ordering to be used for COMP-5 data.
  • COMP-5
    Specifies whether the sign is to be dropped when a value is stored in an unsigned COMP-5 data item.
  • COMP-6
    Specifies whether COMP-6 data is to be held in binary or packed decimal format.
  • COMS85
    Allows your program to contain syntax introduced in the Communications Module of the ANSI'85 COBOL Standard.
  • CONFIRM
    Makes the Compiler echo all subsequent directives to the screen.
  • CONSTANT
    Declares a constant for use in the program.
  • CONVERTRET
    Causes COMP and COMP-X items specified in CALL ... RETURNING and EXIT PROGRAM ... RETURNING phrases to be converted to COMP-5.
  • CONVSPACE
    Converts double-byte space characters in COBOL source files to single-byte spaces on input.
  • COPYEXT
    Specifies the filename extension of the copybook that the Compiler is to look for if a filename in a COPY statement is specified without an extension.
  • COPYLBR
    Makes the Compiler treat the library specified in a COPY statement as an .lbr file.
  • COPYLIST
    Makes the Compiler list the contents of files named in COPY statements.
  • COPYLISTCOMMENT
    Specifies the type of comment to be used on COPY statements in .lst files when the COPYLIST directive is specified.
  • COPYPATH
    Specifies a list of directories for the Compiler to search for copy files.
  • CSI
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • CURRENCY-SIGN
    Specifies the currency sign to be recognized in the PICTURE clause.
  • CURRENT-DATE
    Specifies the format of the date stored in the CURRENT-DATE special register.
  • DATA
    Enables AMODE"24" programs to access pointers to Data Division items passed to them by AMODE"31" programs.
  • DATACOMPRESS
    Specifies the type of data compression to be done on sequential and indexed files.
  • DATA-CONTEXT
    Enables you to specify how a program's Data Division is to be maintained between CICS link levels.
  • DATAMAP
    Causes the Compiler to output information on data items.
  • DATE
    Puts the date in the Date-Compiled paragraph and at the top of each page of the listing.
  • DB2
    Causes EXEC SQL statements in your program to be replaced with DB2 LUW API calls.
  • DBCHECK
    Makes the Compiler check that any Double-byte Character Set (DBCS) literals only contain valid 16-bit DBCS characters.
  • DBCS
    Makes the Compiler accept characters of the Double-byte Character Set (DBCS) for use in ideographic languages such as Japanese, Chinese and Korean.
  • DBCSSOSI
    Defines the two characters used as the shift-out and shift-in delimiters in DBCS literals.
  • DBSPACE
    Makes the Compiler interpret the figurative constant SPACE, when used as a DBCS figurative constant, as the double-byte space character supplied by the system.
  • DE-EDIT
    Specifies the behavior of de-editing moves from numeric-edited items to other numeric-edited items or to numeric items.
  • DEFAULTBYTE
    Initializes each otherwise undefined byte of the Working-Storage Section to the character given.
  • DEFAULTCALLS
    Specifies the default calling convention.
  • DETECT-LOCK
    Makes READ statements detect when a record is locked by another program.
  • DG
    Changes the behavior of certain features to be compatible with Data General Interactive COBOL rev 1.30.
  • DIALECT
    Enables check-time and run-time behavior consistent with the specified dialect.
  • DIRECTIVES, DIR
    Makes the Compiler read directives from a file.
  • DIRECTIVES-IN-COMMENTS
    Makes the Compiler process $SET statements held in comment lines.
  • DOSVS
    Specifies that words reserved in IBM DOS/VS COBOL are to be treated as reserved words.
  • DOTNET
    Sets the reserved words needed for the .NET COBOL language.
  • DPC-IN-SUBSCRIPT
    Turns on or off DECIMAL-POINT IS COMMA when processing subscripts.
  • DYNAM
    Specifies that CANCEL statements are not to be ignored.
  • ECHO
    Makes the Compiler display error lines and error messages on the screen.
  • ECHOALL
    Sends a full listing to the screen as well as to a printer or other device specified with the LIST or PRINT directive.
  • EDITOR
    Enables the Compiler to send error messages to a file in a format compatible with a specified editor.
  • ENSUITE
    Reserved for internal use only.
  • ENTCOBOL
    Specifies that words reserved in IBM Enterprise COBOL for z/OS and OS/390 are to be treated as reserved words..
  • ERRFORMAT
    Specifies the type of error message format to be used for command-line compilations and to appear in the list file.
  • ERRLIST
    Specifies the format of error messages in a list file.
  • ERRQ
    Enables the Compiler to prompt you to stop compiling each time it gives an error message.
  • FASTCALL
    Controls the behavior of a called program. If FASTCALL is specified, the program does not set up information to allow it to determine whether it is a main program. The program always assumes that it is not a main program, and EXIT PROGRAM will always cause an exit to the calling program.
  • FASTINIT
    Turns on fast INITIALIZE of tables. FASTINIT renders as undefined any table contents that a normal INITIALIZE statement would not change.
  • FASTLINK
    Tells the Compiler that the parameters in the USING clauses of the Procedure Division statement and each ENTRY statement conform to certain restrictions. This enables it to produce faster code.
  • FASTSORT
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • FAULTFIND
    Enables file input and output to be logged by FaultFinder.
  • FCD3
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • FCDALIGN
    Ensures the memory boundaries of the file control descriptions (FCDs) associated with SYSIN, SYSOUT and SYSPUNCH files are aligned in the same way as other FCDs and internal structures.
  • FCDCAT
    Specifies whether the catalogued file information for a file is used when accessing that file.
  • FDCLEAR
    Specifies that the record buffer for a file should be cleared after every write operation.
  • FCDREG
    Makes the Compiler define special registers giving access to File Control Descriptions (FCD) and Key Definition Blocks.
  • FILESHARE
    Causes the default locking to become AUTOMATIC rather than EXCLUSIVE for files in a multi-user environment, and automatically locks records on a WRITE or REWRITE statement when the program is locking multiple records.
  • FILETYPE
    Specifies the file format to use when creating files.
  • FIXOPT
    Changes the way in which generated code accesses the Data Division in object (.obj) code.
  • FLAG
    Makes the Compiler produce language-level certification flags when it finds syntax that is not part of a specified dialect of COBOL.
  • FLAGAS
    Makes the Compiler output flagging messages as error messages, warning messages or informational messages.
  • FLAGCD
    When used in conjunction with the FLAG directive, FLAGCD flags any directive settings that would cause incompatibility with the specified dialect of COBOL.
  • FLAGEUC
    Flags occurences of SBCS (8-bit codes) and certain occurences of DBCS (16-bit codes) in the source code.
  • FLAGMIG
    Causes the Compiler to flag any syntax that behaves differently at run time depending on the setting of CMPR2.
  • FLAGQ
    Enables the Compiler prompt you to stop compiling each time it gives a flagging message.
  • FLAGSINEDIT
    Specifies whether flagging messages are to be included in an error file.
  • FLAGSTD
    Makes the Compiler produce language-level certification flags when it finds syntax that is not part of a specified level of the ANSI'85 Standard.
  • FOLD-CALL-NAME
    Folds the identifier/literal associated with CALL, CANCEL, ENTRY, and CHAIN statements and the program-name in the PROGRAM-ID paragraph to upper or lower case.
  • FOLD-COPY-NAME
    Determines whether copybook names should be converted to upper case or lower case.
  • FORM
    Specifies the number of lines on each page of the listing.
  • FP-ROUNDING
    Determines whether one floating-point receiving item can affect the results of other, nonfloating-point receiving items.
  • HIDE-MESSAGE
    Registers the number of a syntax check error message to "hide" so that if the error is encountered it is ignored.
  • HOSTARITHMETIC
    Controls whether or not decimal truncation of arithmetic results occurs following a size error condition.
  • HOSTCONTZERO
    For files defined with the RECORD CONTAINS"0" clause, this directive instructs the File Handler to take the record length from the catalog rather than the file description entry.
  • HOSTFD
    Specifies that the record area associated with a file should only be allocated at the time of an OPEN statement and not before.
  • HOST-NUMCOMPARE
    Controls the operation of comparisons between integer numeric data items of USAGE DISPLAY and alphanumeric literals, figurative constants, or numeric operands.
  • HOST-NUMMOVE
    Ensures that run-time error 163 (illegal characters in numeric fields) does not occur when certain MOVE statements are executed on numeric display data items or numeric operands.
  • HOSTRW
    Determines whether report files are written using WRITE AFTER ADVANCING for better mainframe emulation when the MAINFRAMEPRINT=ON option is set.
  • HOSTSIGNS
    Allows arithmetic and moves with COMP-3 items with illegal sign nibbles (such as those produced by a redefinition of the item) to produce the desired result.
  • IBM-MS
    Specifies that words reserved in IBM COBOL V1.00 are to be regarded as reserved words, and changes the behavior of certain features to be compatible with that COBOL system.
  • IBMCOMP
    Turns on word-storage mode.
  • IDENTIFIERLEN
    Specifies the portion of an identifier name that the compiler will consider to be significant.
  • IDXFORMAT
    Specifies the format to use when creating indexed files.
  • IDYSRCPATH
    Controls the paths stored in .idy files for main source files.
  • IGNOREEXEC
    Specifies that procedural EXEC statements are to be treated as documentary only.
  • ILARRAYPROPERTY
    Controls the way in which the Compiler generates code for data items that include the PROPERTY phrase, and which either include the OCCURS phrase or are subsidiary to a group item with the OCCURS clause.
  • ILASSEMBLY
    Specifies the name of the assembly created.
  • ILCLR
    Allows a managed program to be compiled for Microsoft's Common Language Runtime (CLR) version 2.0 or 4.0.
  • ILCOMPANY
    Defines the company name custom attribute in the assembly manifest.
  • ILCOPYRIGHT
    Defines the copyright custom attribute in the assembly manifest.
  • ILCULTURE
    Defines the culture custom attribute in the assembly manifest.
  • ILDELAYSIGN
    Indicates whether to reserve space in the assembly for the strong name signature, or to defer the actual signing until later.
  • ILDESCRIPTION
    Defines the description attribute in the assembly manifest.
  • ILDOC
    Generates documentation in xml format using comments in the code, and puts the documentation in the specified file.
  • ILDYNCALL
    Specifies that CALL literal statements are resolved at run time rather than being resolved at compile time.
  • ILFILEVERSION
    Instructs the compiler to use a specific version number for the Win32 file version.
  • ILGEN
    Generates the IL for a program with a main program entry point or for a library without one.
  • ILICON
    Adds the specified icon to the output program.
  • ILKEYFILE
    Specifies a key file, which contains a key or public/private key pair for strong naming an assembly.
  • ILKEYNAME
    Specifies the container of a key or key pair that has been installed in the Crypto Service Provider (CSP).
  • ILMAIN
    Specifies the entry method for the executable program being compiled.
  • ILMANIFEST
    Selects a manifest generation option when the application runs on Windows Vista under User Account Control (UAC).
  • ILNAMESPACE
    Specifies the default namespace for items such as classes when building a project.
  • ILNATIVE
    Exposes COBOL 01 level data items as managed primitives where possible.
  • ILNATIVERESOURCE
    The resource file you specify will be included in the resulting output file.
  • ILOBJECTIFY
    Deprecated functionality. Supported for backward compatibility only.
  • ILOUTPUT
    Sets the path of the output assembly file or Java class file.
  • ILPINVOKE
    Makes the specified unmanaged code available, so that the entry points in the unmanaged code are available to the program being compiled. See the Visual Studio Help topic Calling Native Functions from Managed Code.
  • ILPRODUCT
    Defines the product name custom attribute in the assembly manifest.
  • ILPRODUCTVERSION
    Instructs the compiler to use a specific version number for the Win32 product file version.
  • ILREF
    This directive makes the Visual Studio Framework classes in the specified assembly available to the program being compiled.
  • ILRESOURCE
    Specifies a resource file to embed in the assembly file when it is culture neutral.
  • ILSOURCE
    Specifies an additional COBOL source file to be compiled together with the current program into a single .NET assembly or Java class file.
  • ILSTACKSIZE
    Sets the size of the stack when the program is run.
  • ILSTATIC
    Exposes the entry points of a COBOL program as static methods for compatibility with previous releases.
  • ILSUBSYSTEM
    Specifies the subsystem directive to the MSIL Assembler (ilasm.exe). See the Visual Studio Help topic MSIL Assembler (ilasm.exe).
  • ILTARGET
    Enables an application to target a specified CPU type.
  • ILTITLE
    Defines the title custom attribute in the assembly manifest.
  • ILTRADEMARK
    Defines the trademark custom attribute in the assembly manifest.
  • ILUSING
    Specifies the namespace for a class to be imported. This directive enables you to write just the class name in the program code, without its namespace, potentially making the code shorter and simpler.
  • ILVERIFY
    Ensures that the compiled IL code is verifiable.
  • ILVERSION
    Specifies the version of the assembly.
  • IMPLICITSCOPE
    Enables the syntax checker to produce warning messages for cases where scope has been implicitly ended. This usually occurs where the scope terminator (END-VERB) could have been used.
  • INDD
    Causes ACCEPT statements to be read from a specified file.
  • INFORETURN
    Specifies the return-code value returned by the Compiler when it produces only informational messages.
  • INITCALL
    Specifies modules to be called immediately before the first statement of the program is executed.
  • INITPTR
    Enables the INITIALIZE statement to initialize DATA-POINTER, OBJECT-REFERENCE, and PROGRAM-POINTER data types.
  • INT
    Specifies the name of the intermediate code file.
  • INTDATE
    Selects the starting date for integer format dates used with date intrinsic functions.
  • INTLEVEL
    When intermediate code is being created by the Compiler, this directive controls the level of portability of the code created to different versions of Micro Focus COBOL systems in other environments.
  • IOCONV
    Selects between a straight group move and conversion of elementary record descriptions (ANSI behavior) when processing READ ... INTO and WRITE ... FROM statements.
  • ISO2002
    Specifies that words reserved in the ISO2002 COBOL Standard are to be treated as reserved words, and changes the behavior of certain features to be compatible with that standard.
  • IXNLSKEY
    Specifies that the File Handler should sort index file keys according to the local collating sequence rather than the ASCII collating sequence.
  • IXNUMKEY
    Enables true numeric sorting on index keys.
  • JAPANESE
    Enables the use of Micro Focus Japanese Language Extension (PIC N, Japanese data-names and Japanese procedure-names).
  • KEYCHECK
    Specifies whether the File Handler checks that all the keys belonging to the indexed file you are opening are defined in your application.
  • KEYCOMPRESS
    Specifies the type of key compression to be done on indexed files.
  • LIBRARIAN
    Allows -INC statements in your program.
  • LINE-COUNT
    Controls the detail of information displayed at the end of a source listing.
  • LINKALIAS
    Lets the user provide assurances to the compiler about how linkage items will be used, to aid optimization.
  • LINKCHECK
    Specifies that each time a Linkage Section item is referenced a check is to be made that it exists.
  • LIST
    Specifies the destination of the source listing file.
  • LISTPATH
    Specifies a path on which the list file is to be written. The name of the list file is source-name.lst.
  • LISTWIDTH, LW
    Sets the width of the listing.
  • LITLINK
    Makes the Compiler declare the literals in CALL literal statements as public symbols, so they are resolved at link time rather than run time. (Calls generated in this way are referred to as litlinked.)
  • LITVAL-SIZE
    Specifies the number of bytes to pass if the SIZE clause is omitted when passing numeric literals BY VALUE.
  • LNKALIGN
    Indicates that level-01 and level-77 Linkage Section items are always aligned on a machine-dependent favorable boundary.
  • LOCALCOUNT
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • LOCALSOURCEFORMAT
    Specifies that any setting of the SOURCEFORMAT directive in a source file is maintained for that file. This means that if a file with a different SOURCEFORMAT setting is copied into the source file, when processing exits the copied code, the SOURCEFORMAT setting returns to that originally specified in the source file.
  • LOCKTYPE
    Specifies the type of record locking.
  • MAKESYN
    Makes one reserved word synonymous with another.
  • MAPNAME
    Makes the Compiler alter program-names and entry-point names to make them compatible with OS/VS COBOL, DOS/VS COBOL, VS COBOL II and COBOL/370.
  • MAX-ERROR
    Causes the Compiler to abort when the specified number of errors have been produced.
  • METHODDEFAULT
    Specifies the default parameter passing type for methods.
  • MF, MFLEVEL
    Facilitates forward compatibility with Micro Focus COBOL systems by selectively enabling Micro Focus-specific reserved words and changing the behavior of certain features to be compatible with particular versions.
  • MFCOMMENT
    Treats lines with an asterisk (*) in column 1 the same as comment lines but does not show them in the source listing.
  • MFSYNC
    Synchronizes items based on their size.
  • MOVE-LEN-CHECK
    Causes the Compiler to check source and target lengths for alphanumeric MOVE operations.
  • MS
    Facilitates forward compatibility with Microsoft COBOL systems by selectively enabling Microsoft-specific reserved words and changing the behavior of certain features to be compatible with particular versions.
  • MVS
    Specifies that words reserved in IBM COBOL for MVS are to be treated as reserved words.
  • NATIVE
    Specifies the default collating sequence for comparisons.
  • NATIVE-FLOATING-POINT
    Determines whether a program's floating point data items are to use IBM hexadecimal format.
  • NCHAR
    Enables the use of Micro Focus Double-byte Language Extension (PIC N, Japanese data-names and Japanese procedure-names).
  • NLS
    Enables the National Locale Support facility.
  • NSYMBOL
    Defines the default USAGE for PIC N clauses and controls the interpretation of national literals.
  • OBJ
    Specifies the name and format of the object code file and generated code file.
  • ODOOSVS
    Makes the evaluation of OCCURS DEPENDING ON items more compatible with the OS/VS COBOL compiler.
  • ODOSLIDE
    Moves data items that follow a variable-length table in the same record as the table's length changes.
  • OLDBLANKLINE
    Changes the behavior of the BLANK LINE clause in the Screen Section.
  • OLDCOPY
    Makes COPY statements follow the ANSI'68 standard.
  • OLDINDEX
    Causes indexes to be compiled as subscripts.
  • OLDNEXTSENTENCE
    Changes the behavior of the NEXT SENTENCE statement.
  • OLDREADINTO
    Changes the behavior of the READ ... INTO statement.
  • OLDSTRMIX
    Allows PIC X and PIC N fields to be specified in the same STRING, UNSTRING or INSPECT statement
  • OOCTRL
    Enables you to change language options when compiling OO COBOL classes and interfaces.
  • OPT (Intel x86 platforms)
    Specifies the level of optimization of the code produced by the compiler.
  • OPT (Non-Intel x86 platforms)
    Specifies the level of optimization of the code produced in the object code file. Use this version of the OPT directive on operating systems that use chips other than the Intel x86 chip, for example, AIX, Solaris Sparc, HP-UX, IA64 (this list is not exhaustive).
  • OPTIONAL-FILE
    Makes the Compiler treat all files opened for I-O or EXTEND as optional.
  • OS390
    Specifies that words reserved in IBM COBOL for OS/390 R2V2 are to be treated as reserved words.
  • OSEXT
    Tells the Compiler what extension to expect by default on the names of source files.
  • OSVS
    Specifies that words reserved in IBM OS/VS COBOL are to be treated as reserved words.
  • OUTDD
    Causes DISPLAY and EXHIBIT statements to be written to a specified output file..
  • OVERRIDE
    Replaces a reserved word by a new one.
  • P64
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • PANVALET
    Allows ++INCLUDE statements in your program.
  • PARAMCOUNTCHECK
    Enables the program to be called with fewer parameters than are specified in the relevant entry point's USING clause.
  • PC1
    Specifies that words reserved in IBM COBOL V1.00 are to be regarded as reserved words, and changes the behavior of certain features to be compatible with that COBOL system.
  • PCOMP
    Enables you to specify a user program as a precompiler for COBOL files.
  • PERFORM-TYPE
    Specifies the behavior of return jumps from nested PERFORM statements.
  • PERFORMOPT
    Determines if the Compiler should optimize out code to PERFORM empty paragraphs in generated native code.
  • PPLITLINK
    Makes the Compiler declare literals as public symbols, in a SET statement using a data item defined as USAGE IS PROCEDURE-POINTER. This means literals are resolved at link time rather than run time. (Symbol references defined in this way are referred to as litlinked.)
  • PREPLIST
    Causes the list file produced during a compilation to show both the original and modified source created by the preprocessor as well as to show all data passed to the Compiler by a preprocessor.
  • PREPROCESS, P
    Makes the Compiler take the source program from a preprocessor instead of a source file.
  • PRESERVECASE
    Ensures that COBOL items declared in the current program retain their case and are not converted to uppercase as is usual in COBOL. This enables the items to be found from outside the program.
  • PRINT
    Specifies the destination of the source listing file.
  • PRINT-EXT
    Specifies the extension to be added to the filename associated with the ASSIGN TO PRINTER clause.
  • PROFILE
    Includes code in your program to produce detailed performance statistics each time you run the program.
  • PROGID-COMMENT
    Allows comments following the PROGRAM-ID header in the Program-Id paragraph.
  • PROGID-INT-NAME
    Causes the name of the intermediate code file to be taken from the PROGRAM-ID clause, rather than the name of the source file.
  • PROTECT-LINKAGE
    Extends the standard COBOL semantics so that the lengths of parameters can differ between the calling and the called program.
  • PROTOTYPE
    Enables relaxed or strict checking of call prototypes for COMP, BINARY, COMP-4, COMP-5 and COMP-X data items when used in the BY VALUE or RETURNING clauses of a CALL statement. It also inhibits or enables the implicit copying of parameter types from the prototype.
  • QUAL
    Allows qualified data-names and procedure-names in your program.
  • QUALPROC
    Allows qualified procedure-names in your program.
  • QUERY
    Each time the Compiler is unable to find a copybook, it prompts you for an action.
  • QUOTE
    Makes the Compiler interpret the figurative constant QUOTE as the double-quote character (").
  • RAWLIST
    Prevents changeable information, such as page headers, date, time, Compiler release level, from being included in any listing file produced.
  • RDFPATH
    Specifies a location for a repository file.
  • RDW
    Enables you to find out the length of a record that has just been read from a variable-length sequential file.
  • RECMODE
    Specifies the default format of files.
  • RECURSECHECK
    Turns on checking for recursion in generated code.
  • REENTRANT
    Controls reentrancy of a multithreading program. Any program that is to be reentrant in a multi-threaded application must be compiled with this directive. If REENTRANT is specified, many program areas are dynamically allocated, so that it is safe to have multiple copies of the program running.
  • REF
    Makes the Compiler include in the source listing the intermediate code address of each Procedure Division statement.
  • REFNO
    Makes the Compiler display its internal reference number at the start of a compilation as well as at the bottom of every listing.
  • REMAINDER
    Enables you to select how the remainder is calculated in a DIVIDE statement.
  • REMOVE
    Removes words from the reserved word list, so that they can be used as user-defined words.
  • REPORT-LINE
    Specifies the maximum length of a Report Writer line.
  • REPOSITORY
    Creates a repository file or requests that the program being compiled is checked against the repository file.
  • RESEQ
    Makes the Compiler produce line numbers.
  • RESTRICT-GOTO
    Generates a syntax error for GO TO statements that transfer control to outside of the current section.
  • RETRYLOCK
    Specifies that when a READ statement finds that a record is locked the read operation is to be retried repeatedly until the record is available.
  • REWRITE-LS
    Allows REWRITE statements on line sequential files.
  • RM
    Specifies that words reserved in RM/COBOL are to be regarded as reserved words, and changes the behavior of certain features to be compatible with that COBOL system.
  • RTNCODE-SIZE
    Specifies the size of the RETURN-CODE special register and its alignment in memory.
  • RWHARDPAGE
    Causes the Report Writer control module to execute a form feed after the last item has been printed on a page, instead of the usual multiple blank lines. This ensures that the paper is positioned correctly ready for a new page.
  • SAA
    Specifies that words reserved under the Systems Application Architecture (SAA) definition of COBOL are to be treated as reserved words.
  • SCHEDULER
    Controls the invocation of the Intel COBOL Optimizer.
  • SEG
    Turns on COBOL segmentation.
  • SEQCHK
    Makes the Compiler check the sequence numbers in columns 1 through 6 and identify source lines that are out of sequence.
  • SEQUENTIAL
    Specifies the default file type for files defined (implicitly or explicitly) as ORGANIZATION SEQUENTIAL.
  • SERIAL
    Specifies that the program is to be a serial program.
  • SETTING, SETTINGS
    Makes the Compiler include in the source listing a list of the settings of directives.
  • SHARE-OUTDD
    When set, multiple threads can write to the same SYSOUT or OUTDD file. When not set, a file locking error occurs in this situation.
  • SHOW-DIR
    Makes the Compiler show the contents of directives files in the source listing.
  • SIGN
    Specifies which convention numeric DISPLAY items with included signs should use.
  • SIGNDISCARD
    Specifies that a MOVE of a signed numeric DISPLAY field to a group item should discard the sign, and treat the group as an elementary alphanumeric field.
  • SIGN-FIXUP
    Provides limited emulation of mainframe compiler options NUMPROC(NOPFD) and NUMPROC(PFD) for MOVE and COMPARE statements.
  • SORTTYPE
    Selects which mainframe SORT module to emulate.
  • SOURCEASM
    Makes the Compiler include source code statements in the assembler listing.
  • SOURCEFORMAT
    Selects free, fixed, variable, or terminal format for COBOL source.
  • SOURCETABSTOP
    Sets the number of space characters by which to expand tab characters in the source code when it is parsed by the checker.
  • SPZERO
    Causes space characters in numeric data items of USAGE DISPLAY to be treated as zeros.
  • SQL
    Causes EXEC SQL statements in your program to be replaced by ODBC or OCI run-time calls, depending on the options you specify.
  • SSRANGE
    Turns on bounds checking for reference modifications, subscripting and indexes.
  • STDERR
    Causes error messages to be echoed to STDERR rather than to the console (STDOUT).
  • STICKY-LINKAGE
    Makes parameters to the program remain linked during subsequent calls of the program.
  • STICKY-PERFORM
    Specifies the behavior of PERFORM statements when a program is reentered.
  • SUPFF
    Suppresses form-feed characters on the compilation listing if it is sent to the screen.
  • SWITCH-TYPE
    Makes programmable switches behave in the same way as in the ISO 2002 standard.
  • SYMBSTART
    Sets the number from which the Compiler counts positions in the collating sequence when compiling the SYMBOLIC CHARACTERS clause.
  • SYSPUNCH
    Specifies the SYSPUNCH record length to be used.
  • TERMPAGE
    Determines whether the last page of a report file is to be padded with blank lines until it is a full page in length.
  • TESTCOVER
    Enables you to use the test coverage tool, which creates a statistical execution profile of a program.
  • TIME
    Puts the time at the top of each page of the listing.
  • TRACE
    Enables READY TRACE and RESET TRACE statements.
  • TRICKLE
    Tells the Compiler that the program contains legal but unstructured perform-ranges, and that certain optimizations cannot, therefore, be made.
  • TRUNC
    Specifies whether data being stored into a USAGE COMP, USAGE BINARY or USAGE COMP-4 item is to be truncated to the size given by the item's PICTURE clause or to the maximum size the item can hold.
  • TRUNCCALLNAME
    Truncates subprogram names to a specified length.
  • TRUNCCOPY
    Specifies whether to truncate the names of copybooks.
  • TRUNCINC
    Specifies whether to truncate the names of ++INCLUDE files.
  • UNICODE
    Specifies the encoding to be used for Unicode characters.
  • USE
    Makes the Compiler read directives from a file.
  • VERBOSE
    Sends messages from the Compiler to the screen.
  • VSC2
    Specifies that words reserved in IBM VS COBOL II are to be treated as reserved words, and enables selected features for compatibility with a given level of that COBOL system.
  • WARNING, WARNINGS
    Specifies the lowest severity level of errors to report.
  • WB
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • WB2
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • WB3
    This directive is reserved for internal use by this COBOL system. Because it might appear in the list of settings, it is included for completeness. It is not intended for your use, and its setting should not be changed.
  • WRITELOCK, WRITE-LOCK
    Makes the WRITE and REWRITE statements acquire a record lock when the program is locking multiple records in a shared data file in a multi-user environment.
  • WRITETHROUGH, WRITETHRU
    Specifies that disk writes are not to be buffered.
  • XDB
    Causes EXEC SQL statements in your program to be replaced by XDB calls, depending on the options you specify.
  • XOPEN
    Specifies that words reserved under the X/Open definition of COBOL are to be treated as reserved words.
  • XREF
    Makes the Compiler produce a cross-reference listing.
  • ZEROLENGTHFALSE
    Changes the way that class tests involving zero-length items are carried out.
  • ZEROSEQ
    Causes leading zeros to appear in the sequence numbers in columns 1 through 6.
  • ZWB
    Affects the operation of comparisons between integer numeric data items of USAGE DISPLAY and alphanumeric literals or figurative constants.
Parent topic: Compiler Directives


Configuring CCI

  • Configuring CCI Introduction
  • CCI Support for APPC
  • APPC Configuration
  • Application Configuration
  • CCIIPX Configuration
    CCIIPX is supported on Windows 95, Windows 98 and Windows NT systems only.
  • CCINETB Configuration
    CCINETB is supported on Windows 95, Windows 98 and Windows NT systems only.
  • CCITCP Configuration
    CCITCP is supported on Windows 95, Windows 98 and Windows NT and UNIX systems.
  • CCINAMPU Configuration
    CCINAMPU is supported on UNIX systems only.
  • Application Configuration
    CCI is used by a variety of Micro Focus applications. This chapter describes how each of these applications is configured to use CCI for each supported network protocol.
  • CCI Trace
    CCI Trace enables you to trace any CCI function calls made by applications. The information obtained from the trace is sent to a log file. By default this is called ccitrc1.trc, which a matching index file ccitrc1.idx. In addition to the trace information, data flow information can be sent to a separate set of log files with the default names ccitrc1d.trc and ccitrc1d.idx, depending on the trace options specified.Although the trace log file is not generally in a readable format, any data output from the CCI data buffers will not be encrypted when written to a trace file. Applications that use CCI can be coded to block data tracing for security reasons.
  • CCI.INI - The CCI Configuration File
  • CCI Status Messages
  • Attachmate Personal Client v6.3
    This document provides views of a sample installation for Attachmate Personal Client v6.3 for 95/NT over an 802.2 DLC connection. We have validated the CCIAPPC component against Attachmate Personal Client version 6.1, 6.2 and 6.3. This document is arranged in a logical sequence for an new installation of the Attachmate product. Please note that screen snapshots are copyright Attachmate Corporation.
  • Attachmate Personal Client v6.1 and v6.2
    This document provides views of a sample installation for Attachmate Personal Client 6.2 for Windows 95/NT over an 802.2 DLC connection. The configuration for Attachmate Personal Client 6.1 is very similar and this document can be used as a guide for both versions. We have validated the CCIAPPC component against Attachmate Personal Client version 6.1 and 6.2. This document is arranged in a logical sequence for an new installation of the Attachmate product. Please note that screen snapshots are copyright Attachmate Corporation.
  • IBM Communications Server v5.01 for Windows NT
    This document provides sample views of an 802.2 DLC connection for IBM Communications Server Version for NT. We have validated the CCIAPPC component against IBM Communications Server version 5.01. This document is arranged in a logical sequence for a new installation of the Communications Server product. Please note that screen snapshots are copyright IBM Corporation.
  • IBM Personal Communications v4.2 for Windows 95 and Windows NT
    This document provides sample views of an 802.2 DLC connection for IBM Personal Communications for Windows 95 and Windows NT. We have validated the CCIAPPC component against IBM Personal Communications version 4.2. This document is arranged in a logical sequence for a new installation of the Personal Communications product. Please note that screen snapshots are copyright IBM Corporation.
  • Microsoft SNA Server v3.0
    This document provides sample views of an 802.2 DLC connection for Microsoft SNA Server Version 3.0 for Windows 95/NT. We have validated the CCIAPPC component against Microsoft SNA Server version 3.0. This document is arranged in a logical sequence for a new installation of the SNA Server product. Please note that screen snapshots are copyright Microsoft Corporation.
  • Microsoft SNA Server v2.11
    This document provides sample views of an 802.2 DLC connection for Microsoft SNA Server for Windows 95/NT. We have validated the CCIAPPC component against Microsoft SNA Server version 2.11. This document is arranged in a logical sequence for a new installation of the SNA Server product. Please note that screen snapshots are copyright Microsoft Corporation.
  • Rumba Office 95/NT
    This document provides sample views of an 802.2 DLC connection for Rumba Office 95/NT. We have validated the CCIAPPC component against Rumba Office 95/NT version 5.0. This document is arranged in a logical sequence for an new installation of the Rumba product.
  • Support for Attachmate EXTRA! Personal Client
  • Configuring DLC over 802.2 on Windows 95
    This document provides sample views of DLC over an 802.2 Token-Ring / Ethernet connection for Windows '95. Please note that screen snapshots are copyright Microsoft Corporation.
  • Configuring DLC over 802.2 on Windows NT
    This document provides sample views of DLC over an 802.2 Token-Ring / Ethernet connection for Windows NT. Please note that screen snapshots are copyright Microsoft Corporation.
Parent topic: General Reference


Configuring CCI Introduction

CCI is the acronym for Common Communications Interface. CCI is the technology used by Micro Focus products such as Mainframe Access, Fileshare and CICS, to enable communications applications. CCI allows a common approach to configuration and diagnosis of errors for users of Micro Focus distributed applications.

This book provides a wide range of examples for configuring the various Micro Focus products that use CCI. All of this information is applicable to all products that make use of CCI technology. The information is divided into several categories:

  • Specific information regarding each communications protocol supported
  • Application configuration information
  • Tracing and CCI.INI file entry specifics used to customize your communications application
  • Error messages and their possible resolution.

UNIX: If you are using CCI on UNIX, you can ignore the chapters about CCIAPPC, CCIIPX, CCINETB and CCI Trace, and all of the appendices.

Windows: If you are using CCI on Windows, you can ignore the chapter on CCINAMPU.

Parent topic: Configuring CCI
Related information
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


CCI Support for APPC

  • CCI Support Modules for APPC
  • Pre-requisite SNA Support for CCIAPPC
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


CCI Support Modules for APPC

In order to enable CCI support for APPC one executable module is provided:

  • CCIAP32.DLL - which enables the CCI interface routines necessary for CCI equipped machines to communicate with each other. Micro Focus products use this (and other protocol-specific CCI modules) so that they do not need to worry about the complexities of the underlying network protocol.
Parent topic: CCI Support for APPC


Pre-requisite SNA Support for CCIAPPC

CCI support for APPC prerequisites the APPC support provided by a third-party SNA product. CCI uses the Windows Common Programming Interface for Communications (Windows CPI-C) to communicate with other systems using APPC. The SNA products supported by CCI on 32-bit Windows platforms are listed in the APPC Configuration section.

Parent topic: CCI Support for APPC
Related information
APPC Configuration


APPC Configuration

  • APPC Product Configuration Guides
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


APPC Product Configuration Guides

The following configuration guides describe configuration of the SNA products supported for use with CCIAPPC on 32-bit Windows platforms.

These SNA products require that a network adapter and device driver have been installed which will be used to communicate with other systems using SNA protocols. In a Local Area Network (LAN) environment you will need to have installed a LAN adapter and 802.2 Data Link Control device driver.

These guides describe how to install a DLC device driver and configure APPC for CCI communication in a LAN environment using 802.2 Data Link Control (DLC). However, you may want to use another network configuration, such as SDLC, X25 or Channel attachment, for example. Please refer to the documentation provided with the SNA product for information on configuring the SNA product in network configurations other than a LAN. In such cases, although the SNA Connection configuration will differ, the APPC configuration will be identical to that described for a LAN environment.

Parent topic: APPC Configuration
Related information
Attachmate EXTRA! Personal Client v6.3
Attachmate EXTRA! Personal Client v6.1,v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows NT/95
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
RUMBA Office 95/NT v5.0


Application Configuration

CCIAPPC Client/Server applications use the CCI Server Name and Machine Name parameters to enable the CCI Client to specify the CCI Server with which to communicate.

The CCI Server identifies itself using the Server Name parameter. The CCI Client specifies the partner CCI Server using the Server Name and Machine Name parameters.

  • CCIAPPC Server Name
  • CCIAPPC Machine Name
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


CCIAPPC Server Name

  • CCI Server

    The Server Name parameter specifies the APPC Local LU Name and Transaction Program Name (TP Name) to be used by the CCI Server.

    The format of the Server Name is as follows:

     Local-LU-Name.TP-Name

    For example, CCISERV.CCITPN01. The TP Name is optional and if absent the Local LU Name is also used as the TP Name.

  • CCI Client

    The Server Name parameter specifies the APPC Partner LU Name (also known as the APPLID on a host system) and TP Name of the partner CCI Server. The Partner LU Name (or APPLID) must match the Local LU Name (or APPLID) and TP Name as specified by the CCI Server (see above).

    The format of the Server Name is as follows:

     Partner-LU-Name.TP-Name
Parent topic: Application Configuration


CCIAPPC Machine Name

  • CCI Client

    The Machine Name parameter specifies the APPC Local LU Name for the CCI Client and and APPC Mode Name to be used by the Client to communicate with the Server.

    The format of the Machine Name is as follows:

     Local-LU-Name.Mode-Name

    For example, CCICLI.CCIMODE

    The Mode Name is optional and if absent the default APPC Mode #INTER is used.

Note:

APPC LU Names, TP Names and Mode Names can be up to 8 characters in length.

Parent topic: Application Configuration


Troubleshooting

  • CCI error message "CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined" obtained

    This occurs when the Local LU has not been properly specified for the CCIAPPC Client. Refer to the section entitled Enabling CCIAPPC To Find The Local LU in the appropriate configuration guide in the APPC Product Configuration Guides section for the SNA product in use.

For other problems refer to the section entitled Error Reporting and Diagnostics in the appropriate configuration guide in the APPC Product Configuration Guides section for the SNA product in use.

Related information
APPC Product Configuration Guides


CCIIPX Configuration

  • CCI Support for Novell NetWare IPX
  • Configuring CCIIPX Parameters
  • Available CCI.INI Options for CCIIPX
  • Application Configuration
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


CCI Support for Novell NetWare IPX

  • CCI Support Modules for IPX
  • Novell NetWare IPX Configuration
Parent topic: CCIIPX Configuration


CCI Support Modules for IPX

In order to enable CCI support for the Novell NetWare IPX transport, one executable module is provided:

  • CCIIX32.DLL - which enables the CCI interface routines necessary for CCI equipped machines to communicate with each other. Micro Focus products use this (and other protocol-specific CCI modules) so that they do not need to worry about the complexities of the underlying network protocol.
Parent topic: CCI Support for Novell NetWare IPX


Novell NetWare IPX Configuration

There is no specific configuration of the Novell NetWare or operating system environment required to run CCIIPX, however there are restrictions on the supported IPX protocol providers which can operate with CCIIPX, these differ between operating systems.

Microsoft Windows 95

  • CCIIPX v3 requires Novell's Client32(tm) NetWare Requester support as shipped by Novell. Use of Client32 version 2.20 or later is recommended.

Microsoft Windows NT

  • CCIIPX v3 requires Novell IntraNetWare Client for Windows NT(tm) v4.0a or v4.10 as shipped by Novell.

CCIIPX cannot use the Microsoft IPX compatible transport as shipped with Windows 95 or Windows NT, these IPX transports do not provide the interface support level required for CCIIPX.

Parent topic: CCI Support for Novell NetWare IPX


Configuring CCIIPX Parameters

  • CCI.INI File Options for CCIIPX
  • Why would I need to use any CCI.INI options?
  • What form do CCIIPX CCI.INI options take?
Parent topic: CCIIPX Configuration


CCI.INI File Options for CCIIPX

You can tune CCIIPX using the tuning options described below. You set the ones you want to change in the file CCI.INI.

Parent topic: Configuring CCIIPX Parameters


Why would I need to use any CCI.INI options?

The CCIIPX module has been developed to be a reliable and easy to configure protocol option in the CCI suite. In almost all circumstances CCIIPX will work correctly straight out of the box with no need to configure anything. If however some system tuning is required the following options are available under a heading of [cciipx-base] in the CCI.INI file.

CCI.INI can be located in a number of locations for testing and deployment. On Windows systems of all types the Windows root directory is a good location as it is visible from all applications. There may be configuration sections for more than one CCI protocol module in any CCI.INI file.

If you only want to affect the behavior of a single application, rather than affecting every application on the system, put the CCI.INI file (containing the CCIIPX entries for this application) in the current directory - the directory from where the application is being run.

Parent topic: Configuring CCIIPX Parameters


What form do CCIIPX CCI.INI options take?

A sample CCIIPX section of a CCI.INI file could look like:-

[cciipx-base]
 REPORT_CONNTYPES=n
 CRC_SEND=n
 CRC_FORCE_RECV=n
 CRC_REPORT_FAILS=n
 CRC_RETRY=y
 MAX_PKT_SIZE=17872

Acceptable entries for yes/no options are, "Y","y","YES" or "yes", and "N","n","NO", or "no". Mixed case words such as "Yes" are NOT accepted and default settings will be used if their use is attempted. Numeric values must always be entered in decimal format, use of HEX and OCTAL values is not supported and will lead to unpredictable results. Any unwanted entries in the CCI.INI file can be commented out using ";" as the first character of the line.

Parent topic: Configuring CCIIPX Parameters


Available CCI.INI Options for CCIIPX

  • Basic CCI.INI Options for CCIIPX
  • Advanced CCI.INI Options for CCIIPX
Parent topic: CCIIPX Configuration


Basic CCI.INI Options for CCIIPX

  • REPORT_CONNTYPES, default setting "n".

    If the application calling CCIIPX is a Console type application running on Windows 95 or Windows NT, a display will appear on the screen at the connection of a client to a server giving details of the type of connection that was established. These details include the protocol revision number (200, 201 or 202) and the maximum packet size that can be used to transmit data on the new session. If the application calling CCIIPX is not a Console type application running on one of the systems listed above, the output is lost. An example of output for an Ethernet based connection which doesn't use CRC checks is:

    "Con_Accepted: CRC_NO_SEND - v201 client, max pkt 1394 bytes"
  • CRC_SEND, default setting "n"

    Create a Cyclic Redundancy Check checksum and include this in outgoing packets, this process slows down data transmission but ensures greater data integrity on links where corruption is suspected. Connections with CRC checking switched on appear as protocol versions 200 and 202.

  • CRC_FORCE_RECV, default setting "n".

    Some servers will automatically discard CRC information from clients to save time, use of this flag will force the receiving servers to create a session which always uses the CRC information when sent from this client machine. Links with this flag set are seen as protocol type 202. NetWare Client v4.0 for NT has a inherent data integrity problem, when this client is installed CCIIPX will detect this and will always include CRC data in sessions created from these machines, CCIIPX clients on these machines will always force any server accepting their connections to use this CRC information, hence these clients will always be of protocol type 202.

  • CRC_REPORT_FAILS, default setting "n".

    This is a debugging setting, which can be used to display a notification message whenever a CRC check fails. This setting is obviously redundant in the default installations which do not utilize CRC checking at all.

  • CRC_RETRY, default setting "y".

    This is a debugging setting, which allows a system setup to use CRC checking to behave as if no CRC checking were being performed. Used in conjunction with "CRC_REPORT_FAILS=y" it can confirm a data integrity error on a link and appropriate action can be taken on the client and server systems to enable CRC checking to always preserve data, at the expense of speed on the links.

  • MAX_PKT_SIZE, default setting "17872".

    This option defines in bytes the maximum size of a data packet that can be used by CCIIPX. It will not always be possible to connect two machines at this size of packet, but negotiation to determine the largest possible packet to transmit and receive takes place at the initialization of a new session, so the largest possible packet that can be carried on the intervening link between two machines, up to this limit, will be used whenever possible.

Parent topic: Available CCI.INI Options for CCIIPX


Advanced CCI.INI Options for CCIIPX

  • SAP_OBJECT_TYPE, default setting "2088".

    We have registered service type 0x828 for CCI use, if users wish to utilize another service type in the SAP registrations they may alter this setting to do this. Users MUST remember to always use the new setting on ALL systems which require access to these re-assigned services. Since no other service type setting is registered with Novell for Micro Focus CCI, we cannot be responsible for any clashes with other installed services which my also be SAPing with the newly associated service type.

  • KA_PERIOD, default setting "27".

    This is the time period, in whole seconds, between attempts to confirm the continued existence of the remote end of a quiescent connection. See KA_RETRIES for more details.

  • KA_RETRIES, default setting "3".

    This is the number of retried attempts to confirm the continued existence of the remote end of a quiescent connection that are allowed to be missed before the remote end of the connection is declared lost. See KA_PERIOD for details as to the inter-attempt time period. Users may alter this setting to adjust the time-out of a connection and hence alter the time of detection of a dead connection. On WAN and dial-up links this period may be lengthened to accommodate the delays imposed in these architectures.

  • MAX_ASYNC_SEND_PAUSE, default setting "400".

    Maximum time in milliseconds between successive sends if no ACK has been received from the receiving end during an attempt to send a buffer. After this time another attempt will be made to send a reminder packet to the receiver. This is a very advanced setting which should only be used upon advisement from tech support, it is used to tune the system to avoid retries on already congested networks.

Parent topic: Available CCI.INI Options for CCIIPX


Application Configuration

CCIIPX Client/Server applications use the CCI Server Name and Machine Name parameters to enable the CCI Client to specify the CCI Server with which to communicate.

The CCI Server identifies itself on the network by using the Server Name parameter. The CCI Client specifies the CCI Server using the Server Name. Additionally, if it only wants to find this Server running on a particular machine in the network, it needs to specify the Machine Name parameter.

  • CCIIPX Server Name
  • CCIIPX Machine Name
Parent topic: CCIIPX Configuration


CCIIPX Server Name

Both CCI server and CCI client applications need to have a Server Name specified: server applications need to register themselves as available under this name (or what fixed port to use); and clients need to specify which server they wish to contact.

This can be any valid alphanumeric string (up to 47 characters in length). Strings must be terminated with either a space (" ") or a NULL (binary zero) byte. Names presented with a length greater than this limit will be rejected with a bad parameter message, to avoid the possibility of a truncated name allowing connection of a client to an unwanted service.

Parent topic: Application Configuration


CCIIPX Machine Name

This is a parameter that only needs to be specified by CCI client applications.

There are two aspects to the use of Machine Name

  • Clients for later versions of the old 16-bit broadcast based CCIIPX and the new CCIIPX for 32-bit Windows installations support the use of a 'Machine Name' parameter when calling CCI Client initialization functions.

    The broadcast based CCIIPX modules support the string format:

    • '<network>.<node>.<port>' - where the service port address is known.
    • '<network>.<node>' - where the service port address is unknown.

    For example, "33c251.1" for a NetWare Server based CCIIX32.NLM hosted service, where the NetWare Servers internal network number is "33c251" and the logical "node" address for the server is "1".

    The new 32-bit Windows hosted CCIIPX modules support the use of 'machinename' in exactly the same manner as the older broadcast based CCIIPX modules, however the SAP based module also support the use of ',' as the name element separators

    For example, "33c251,1" for the NetWare Server in the example above.

  • The 32-bit Windows hosted CCIIPX modules use the Novell NetWare Service Advertising Protocol (SAP) to detect the presence of CCIIPX services, without the direct need for 'machinename' information.

    The Service location detection is done by querying the contents of the NetWare Server which the client is attached to at the time. However if a large number of connections/disconnections are to be made with the same service, this SAP look-up can take up an appreciable amount of the overall time spent in using a connection.

    If the application using CCI supports this style of access, one such application is AAI, it is possible to avoid the requirement to search the SAP information on the connected NetWare Server and make the connection directly and thus speed up the connection time.

    This is done as follows:

    Set 'Machine Name' to "FFFFFFFF,FFFFFFFFFFFF,FFFF"

    The contents of the data area which holds this set of values will be over-written with the correct location of the server on the first successful connection attempt. If the same information is then passed back to the CCI Client connection call on the next connection/disconnection loop by the application, the CCI Client connection call will attempt to connect directly to this location, and avoid using the NetWare Servers SAP table completely.

    If three attempts to connect using this method are ignored (this takes 12 seconds during CCI Client connection execution time), the client will then use the NetWare Server's SAP tables and attempt to locate the service in the usual fashion. This technique provides a backup connection path, should the location information in the 'Machine Name' area become stale.

    Please note: the use of "FFFFFFFF" parameters in any other format or combination with other groups of numbers is invalid, and will result in a parameter rejection message being returned by CCI.

Parent topic: Application Configuration


CCINETB Configuration

  • CCI Support for NetBIOS
  • Configuring CCINETB Parameters
  • Application Configuration
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


CCI Support for NetBIOS

  • CCI Support Modules for NetBIOS
  • Configuring the Environment for Using CCINETB
  • Which Protocol will CCINETB Use?
Parent topic: CCINETB Configuration


CCI Support Modules for NetBIOS

In order to enable CCI support for the NetBIOS transport API, one executable module is provided:

  • CCINB32.DLL - which enables the CCI interface routines necessary for CCI equipped machines to communicate with each other. Micro Focus products use this (and other protocol-specific CCI modules) so that they do not need to worry about the complexities of the underlying network protocol.
Parent topic: CCI Support for NetBIOS


Configuring the Environment for Using CCINETB

The CCINETB module uses a NetBIOS interface to communicate over NetBEUI. Although Windows 95 and Windows NT offer NetBIOS interfaces running over other protocols such as TCP/IP, it is recommended that you use CCINETB with NetBEUI only. If communication over any other protocol is required, you should use the associated CCI module for that protocol.

Parent topic: CCI Support for NetBIOS


Which Protocol will CCINETB Use?

On Windows NT, CCINETB will, by default, interrogate the Registry and use the LAN Adapter number of the NetBEUI protocol. If, for some reason, this fails, CCINETB attempts to use LANA 0 (LAN Adapter Zero).

Parent topic: CCI Support for NetBIOS


Using CCINETB on Windows 95

Unlike Windows NT, CCINETB cannot discover the location of the NetBEUI logical Lan Adaptor (LANA) automatically, only the default LANA is defined on Windows 95, that is always LANA 0. So in Windows 95 some manual configuration may be required if NetBEUI is installed as well as other protocols.


Multiple Protocols on Windows 95

On Windows 95, it may be necessary to configure the default protocol to ensure that the NetBIOS interface is being used over the NetBEUI protocol. CCINETB will, by default, attempt to use the LAN Adapter number of the default protocol and the default protocol always uses LANA 0 (LAN Adapter Zero).


Setting the Default Protocol on Windows 95

You can set the adapter that CCINETB will use by following the directions for setting the AdapterLoc parameter below or you can ensure that CCINETB uses the NetBEUI protocol by setting NetBEUI to be the default protocol under Windows 95 as follows:
  1. Select the Network option in the Control Panel.

  2. Click on the Configuration tab.

  3. Double click on the NETBEUI network adapter protocol binding that you want CCINETB to use.

  4. Click on the Advanced tab.

  5. Ensure that the check box Set This Protocol To Be The Default Protocol is selected.

  6. Click OK.
  7. Restart Windows 95 for changes to take effect.


Using Multiple Adapters on Windows 95

On Windows 95, if you have configured more than one adapter, you must ensure that the NetBEUI protocol is only bound to a single adapter, the one that will be used by CCINETB. To do this:

  1. Select the Network option in the Control Panel

  2. Click on the Configuration tab.

  3. If there are multiple entries for NetBEUI, select, in turn, those that will not be used by CCINETB and then click on Remove.

  4. Click OK.
  5. Restart Windows 95 so that the changes take effect.


Configuring CCINETB Parameters

  • CCI.INI File Options for CCINETB
  • Available CCI.INI Options for CCINETB
Parent topic: CCINETB Configuration


CCI.INI File Options for CCINETB

You can tune CCINETB using the tuning options described below. You set the ones you want to change in the file CCI.INI.

  • Why would I need to use any CCI.INI options?
  • What form do CCI.INI options take?
Parent topic: Configuring CCINETB Parameters


Why would I need to use any CCI.INI options?

CCINETB can be used without any additional configuration by following the instructions above. It is possible, however, to configure some of the default parameters that CCINETB uses via the CCI.INI file.

You can create the CCI.INI file using any text editor. The CCI.INI configuration file must be placed in a directory defined on the system PATH.

Parent topic: CCI.INI File Options for CCINETB


What form do CCI.INI options take?

A sample CCINETB section of a CCI.INI file could look like:-

[ccinetb-base]

  AdapterLoc=0
  DefaultBuffLen=4096
  Commands=20
  Sessions=10
  Names=2
Parent topic: CCI.INI File Options for CCINETB


Available CCI.INI Options for CCINETB

The CCINETB parameters which are listed below must be specified in the [ccinetb-base] section of the CCI.INI file:

  • AdapterLoc, default setting "0"

    This parameter specifies the adapter and protocol binding over which CCINETB should be used.

  • DefaultBuffLen, default setting "4096"

    This parameter specifies, in bytes, the default size of the receive buffer used internally by CCI. The default value for this parameter on Windows NT and Windows 95 is 4096 bytes.

    If the data to be received is larger than the buffer, CCINETB performs multiple receive operations automatically until all the data has been received. Hence this parameter can be used to tune CCINETB to perform the minimum number of network receives whilst optimizing memory usage. For example, if you know that your CCI application will transmit data in buffers larger than 4096 bytes then increase this parameter. The maximum buffer size allowable is 65535 bytes.

  • Commands, default setting "20"

    This parameter specifies the maximum number of NetBIOS commands which can be outstanding at any one time. This parameter is used by CCINETB to allow it to communicate using NetBEUI. By default, CCINETB sets this parameter to 20 on Windows NT and Windows 95.

    On Windows 95 the default system value for the number of commands available is actually 12 . This means that the default for the maximum number of NetBIOS commands is overridden by Windows 95.

    If you are running client applications under Windows 95 this value may be sufficient. However, if you are running a server application or testing between Windows 95 sessions you may want to increase this value.

    CCINETB leaves one command outstanding for each end of a CCI session between a client and a server. It also uses two additional commands for listening for incoming connections and additional commands for canceling sessions. So, a CCI installation running a CCI server which services up to 10 connections needs to increase this parameter by at least 15 (i.e. to 27), ensuring that enough commands remain for other NetBIOS applications.

    To increase this system defined maximum:

    1. Select the Network option in Control Panel and click the Configuration tab.
    2. Double click on the NetBEUI network adapter protocol binding that you want CCINETB to use.
    3. Click on the Advanced tab, select NCBS and alter the value.
    4. Click on OK.
    5. Shutdown and restart Windows 95 so that the changes take effect.
  • Sessions, default setting "10"

    This parameter specifies the maximum number of NetBIOS sessions which can be active at any one time. By default, CCINETB sets this parameter to 10 on Windows NT and Windows 95.

    On Windows 95 the default system value for the number of sessions available is also 10. To increase the number of sessions available you must modify the system value for Windows 95. You may want to increase this value depending on how many other applications on your system require NetBIOS.

    CCINETB uses a NetBIOS session for each CCI session between a client and a server. So, a CCI installation running a CCI server which services up to 10 connections needs to increase this parameter by at least 10 (i.e. to 20), ensuring that enough sessions remain for other NetBIOS applications.

    To increase the system defined maximum:

    1. Select the Network option from the Control Panel and click on the Configuration tab.
    2. Double click on the NetBEUI network adapter protocol binding that you want CCINETB to use.
    3. Click on the Advanced tab, select Maximum Sessions and alter the setting of Value.
    4. Click on OK.
    5. Shutdown and restart Windows 95 so that the changes take effect.
  • Names, default setting "4096"

    This parameter is used to specify the maximum number of NetBIOS names which can exist in the NetBIOS name table at any one time. For Token Ring this includes the universally administered address.

    The default value for this parameter on Windows NT and Windows 95 is 2.

    The value of this parameter determines the maximum number of CCI servers which can exist at any one time.

Parent topic: Configuring CCINETB Parameters


Application Configuration

CCI Client/Server applications use the CCI Server Name and Machine Name parameters to enable the CCI Client to specify the CCI Server with which to communicate.

The CCI Server identifies itself on the network by using the Server Name parameter. The CCI Client specifies the CCI Server using the Server Name. Additionally, if it only wants to find this Server running on a particular machine in the network, it needs to specify the Machine Name parameter.

  • CCINETB Server Name
  • CCINETB Machine Name
Parent topic: CCINETB Configuration


CCINETB Server Name

Both CCI server and CCI client applications need to have a Server Name specified: server applications need to register themselves as available under this name (or what fixed port to use); and clients need to specify which server they wish to contact. This can be any valid alphanumeric string (up to 14 characters in length). Strings must be terminated with either a space (" ") or a NULL (binary zero) byte. Names presented with a length greater than this limit will be rejected with a bad parameter message, to avoid the possibility of a truncated name allowing connection of a client to an unwanted service.

Parent topic: Application Configuration


CCINETB Machine Name

No Machine Name configuration is available for CCINETB, any configuration options detected will be ignored.

Parent topic: Application Configuration


CCITCP Configuration

  • CCI Support For TCP/IP
  • Advanced Features
  • Application Configuration
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


CCI Support For TCP/IP

CCI over TCP/IP (CCITCP) allows an application to connect to another application (on another machine, usually, although it can be another process on the same machine) in two ways: directly, by specifying the TCP/IP address and port being used by the application you want to connect to (this is described in the Advanced Features section); or indirectly, by specifying a logical "Server Name" of the service you wish to connect to.

This second method allows the most flexibility: the applications can be moved from machine to machine without being altered; and the details of the machine they are running on are unimportant (as long as they support CCI and TCP/IP, of course). This flexibility is achieved by having an intermediate program which CCI can query when a connection request is made. This program contains or can obtain the necessary details to allow an application to establish a connection with another application of a given Server Name. This program is called the CCITCP2 registration daemon.

Before using CCI over TCP/IP (with or without using CCITCP2) there is some configuration that is necessary, described in the sections below.

  • CCI Support Modules for TCP/IP
  • TCP/IP Configuration
  • Running the CCI Configuration Utility
  • CCI Configuration for UNIX Users
  • Using CCITCP2
Parent topic: CCITCP Configuration
Related information
Advanced Features


CCI Support Modules for TCP/IP

In order to enable CCI support for TCP/IP three executable modules are provided:

  • CCITC32.DLL(cobtcp.so on UNIX systems) - which enables the CCI interface routines necessary for CCI equipped machines to communicate with each other. The module, its interface, and its associated functionality and other support modules, is generically referred to as CCITCP. Micro Focus products use this (and other protocol-specific CCI modules) so that they do not need to worry about the complexities of the underlying network protocol.
  • CCITCP2.EXE(ccitcp2 on UNIX systems) - a server registration module, which is used to register and advertise CCI server processes that are available for CCI clients to call. It is designed to be run as a background application, and so is sometimes referred to as a "daemon" process.
  • CCIINST.EXE(not supplied on UNIX systems) - adds necessary entries to the TCP/IP services file automatically and registers the name of the machine which CCI clients will use to connect to a CCITCP2 process. It generally needs to be run only once on a machine.
Parent topic: CCI Support For TCP/IP


TCP/IP Configuration

Before the CCI modules can work effectively the appropriate TCP/IP network hardware and software drivers must be already installed, fully configured, and working. Once the TCP/IP software is installed and configured, the network connections should be fully checked out using suitable utilities, such as the TCP/IP standard commands "ping" and "ftp", before attempting to use CCI over TCP/IP. Ensure that if hostnames are going to be used (as opposed to only dotted decimal IP addresses) that the Domain Name Server (DNS) configuration is correct and that the service is working.

Where a network is connected to other networks, ensure that TCP/IP is aware of the gateway(s) to these networks by running "route add" or a similar command. Please see your TCP/IP vendor's installation and configuration guides for details of these steps.

Once you are certain that TCP/IP is fully configured and functional and that the machines which you wish to communicate with are similarly set up and reachable, then the only other configuration issue that needs to be resolved is where (and whether) a CCITCP2 daemon will be run to enable these machines to contact each other.

Parent topic: CCI Support For TCP/IP


Running the CCI Configuration Utility

This section does not apply to UNIX installations. Please refer to CCI Configuration for UNIX users

If a CCITCP2 daemon is used to allow CCITCP clients and servers to establish contact then the "CCI Configuration" utility needs to be run first. It can be started by going to the "Configuration" group under the product Start menu item and selecting "CCI Configuration". Alternatively just run CCIINST from any Micro Focus Command Prompt.

The CCI Configuration Utility asks for the address of the machine in the reachable network which is running a CCITCP2 daemon. You can enter either a hostname or a dotted decimal format address. If you do not know the TCP/IP hostname or address of the system that the CCITCP2 daemon is running on, contact your system/network administrator.

The CCI Configuration Utility also updates the TCP/IP services file with values necessary for CCI to work over TCP/IP.

If you leave the hostname field empty, CCI assumes that the CCITCP2 daemon will be running on the local machine, and the changes to the services file are still made.

If the machine running the CCITCP2 daemon changes, you must rerun the CCI Installation Utility and change the hostname to the new value. If there are any Micro Focus processes running which were started before the value was changed (e.g. Command Prompt, Integrated Development Environment, etc.) then these will need to be re-started before they pick up the new value.

Parent topic: CCI Support For TCP/IP
Related information
CCI Configuration for UNIX users


CCI Configuration for UNIX Users

Prior to using CCITCP with CCITCP2, an entry must be made in the /bin/services file as follows:-

mfcobol 86/udp

Without this entry in the /bin/services file, CCITCP2 cannot function.

On UNIX systems the user is required to set an environment variable "CCITCP2" to select the location of the machine hosting CCITCP2 executable in the network that is being used.

An example of the setting of a CCITCP2 environment variable for korn shell users is

export CCITCP2=myhostmachinename

or

export CCITCP2=192.77.293.1

The method for setting environment variables in other UNIX shells differs slightly from the examples given here, please use the appropriate method for the user shell of your choice.

Please refer to the section Environment Variables and the CCI.INI File for more details of the advanced configuration of CCITCP.

Parent topic: CCI Support For TCP/IP
Related information
Environment Variables and the CCI.INI File


Using CCITCP2

There only needs to be one CCITCP2 process active on a network in order for CCI over TCP/IP to work, as long as all machines have been configured (using the CCI Configuration Utility) to use it. Alternatively, multiple CCITCP2 processes running in the network can coexist and can communicate between each other so that a machine configured to use one daemon can find an application registered with a different daemon in the network. For instance, it is possible for every machine on the network to be running a copy of CCITCP2 and be configured to use their own local copy to search for connections. This would, however, generate a lot more network broadcast traffic compared to having just one daemon which all machines are configured to use.

The CCI Configuration Utility needs to be run on a machine before CCITCP2 can be successfully started on it (enter a blank hostname if the daemon is run locally). Once started, the daemon will accept service registrations until the effective RAM available to the process is exhausted, or until it is shut down.

CCITCP2 can be started manually at any time (as long as it is not already running) by entering:

ccitcp2

at a Micro Focus command prompt, or it can be started automatically at system start-up by including it in the startup folder. Alternatively, on NT, it can be installed as a service (see CCITCP2 as an NT Service).

On UNIX systems CCITCP2 can only be started by a superuser (root).

  • Using Directory Server Instead of CCITCP2
  • CCITCP2 Search Order
  • CCITCP2 Troubleshooting
Parent topic: CCI Support For TCP/IP
Related information
CCI Configuration Utility
CCITCP2 as an NT Service


Using Directory Server Instead of CCITCP2

If you have installed Server Enterprise Edition, available with Studio Enterprise Edition and standalone, then the CCITCP2 program will have been replaced by a trigger program that calls the Micro Focus Directory Server program. As far as CCI users are concerned, the Directory Server serves the same purpose as CCITCP2 and behaves in exactly the same way. Each machine that runs Server Enterprise Edition must have the Directory Server program running on it, and for Windows machines it is automatically installed and started as a service. For more information about the Directory Server see your Enterprise Server Configuration and Administration book.

Parent topic: Using CCITCP2


CCITCP2 Search Order

If both the Server Name and Machine Name (see Application Configuration for a definition of these terms) are specified by the client application, the CCITCP2 process returns the machine and port address of the service specified to the client so that it can establish a connection with the named service. If the service is not found, an error is returned.

However, if the Server Name is specified but the Machine Name is not, the CCITCP2 process searches all the registered Server Names in the reachable network in the following order until either the named service is found or an error is returned:

  1. The CCITCP2 process returns the address and port of any occurrence of the Server Name that is registered with it and is running on the same machine as the CCITCP2 process.
  2. The CCITCP2 process returns the address and port of any occurrence of the named service that is registered with it but is running on another machine.
  3. The CCITCP2 process returns the address and port of the first occurrence of the named service that is registered with any other addressable CCITCP2 process. Note that there is no guarantee which particular service this will be.
  4. The CCITCP2 process returns an error to the calling program if the named service still cannot be found. At this point the client will probably keep re-trying for a fixed amount of time, in case the service has been started after the client first began searching for it.

You can avoid the potential problem of producing an undesired connection from the third level search by closely observing the rules followed at the first two search levels or by using a unique name for each server process on the network.

Parent topic: Using CCITCP2
Related information
Application Configuration


CCITCP2 Troubleshooting

This section provides information that may be useful if you experience problems when using CCI over TCP/IP with CCITCP2.

  • "mfcobol port entry not found in services file" error

    Run the CCI Configuration Utility on the machine receiving this error: this should automatically update the TCP/IP services file with the necessary entries.

  • "Cannot find CCITCP2" error

    Run the CCI Configuration Utility on the machine receiving this error. Make sure that the hostname or TCP address value matches that of the machine running the CCITCP2 process you expect to use, and that the CCITCP2 process is running on that machine. Use "ping" and "ftp" to make sure that the machine is reachable using the address you have specified. Check that there are no CCITCP environment variables or CCI.INI file entries over-riding the value specified by the Configuration Utility. If the value has been changed recently, make sure that the failing process has been subsequently re-started.

  • "Registered service found but could not make a connection" error

    There are two main possible causes of this message:

    • This error can occur if the CCI server the client is trying to connect to has abnormally terminated, but still remains registered with the CCITCP daemon that both the client and server are pointed at. (Where possible, CCITCP attempts to detect this sort of abnormal termination and tries to remove the Server Name entry which is no longer valid, however this cannot be guaranteed.) The client then connects to the CCITCP2 daemon, which tells it where to look for the CCI server, but when it then tries to connect to the terminated server and fails it will give the above error.

      To check to see if this is what is happening close and re-start the CCITCP2 daemon that the client is pointed at. This will clear it of all registered Server Names, including any "orphan" servers. (If CCITCP2 is running in debug console mode then you can press F2 and it will list what CCI servers are registered with it.) Check to see that the CCI service is not abnormally terminating.

    • Another reason you may get this error is if both the CCI server and client can see the CCITCP2 daemon, but they cannot contact each other directly (because of the network topology: packets from the client are not reaching the server because a bridge or router is not allowing them through). Check that the client can "ftp" from the machine running the CCI server and visa versa. If they cannot, then notify the system administrator.
  • "A CCITCP call has timed out" error

    This most commonly occurs if the server application that the client is attempting to contact is not running at the time the client is started. However, it can also a be produced in a network topology which includes routers or bridges which have not been configured to allow CCITCP2 daemons to communicate with each other. For example, if a client fails to connect with a registered service as follows:

    • Server A registers itself with the CCITCP2 process running on machine A
    • Client B looks for server A using the CCITCP2 process running on machine B
    • Client B fails to connect to server A.

    The CCITCP2 modules are designed to communicate with each other using the TCP/IP broadcast address mechanism. If this is not correctly configured, CCITCP2 cannot locate services registered with other CCITCP2 modules. If this happens, you should advise your system administrator.

    System administrators should be aware of the following:

    • Bridges and gateways that are not configured to pass broadcast addressed packets will have a blocking effect on CCITCP connectivity. These items must be re-configured to pass broadcast packets if the registration of processes is performed on a leg of a network other than that of the requesting client. The actual configuration operations for these are specific to each device. In this situation, the use of a CCITCP2 module on the same leg of the network for both client and server applications will avoid the problem.
    • Most bridges and routers can be configured to only pass broadcast packets using certain TCP/IP port numbers; that is, a filter is applied. To allow CCITCP2 to communicate across bridged networks, your router or bridge should allow broadcasts using port number 86 in the UDP domain to pass unhindered through the filter.

    For CCITCP2 modules to communicate correctly, your network must be configured to pass broadcast packets to all areas that want to use CCITCP.

Parent topic: Using CCITCP2
Related information
CCI Configuration Utility


Advanced Features

  • Running CCITCP2 as an NT Service
  • Using CCI Over TCP/IP Without CCITCP2
Parent topic: CCITCP Configuration


Running CCITCP2 as an NT Service

On Windows NT you can run the CCITCP2 daemon as an NT service by entering:

ccitcp2 -i

at the Micro Focus command prompt. (You must be logged on as a user with Administrator privilege to do this.)

Once installed as an NT service, CCITCP2 can be started and stopped via the Control Panel in the usual way.

You can use the -c option to install CCITCP2 as a service and run it in debug mode so that a console shows services being registered and connections being made:

ccitcp2 -c

Note that if CCITCP has already been installed as a non-console service it will need to be uninstalled first. To uninstall CCITCP2 as a service, use the -u option:

ccitcp2 -u

The -? option lists the available CCITCP2 startup modes.

Note:

If CCITCP2 is installed as an NT service, it will be started automatically when the NT system is re-started. If a non-service CCITCP2 has previously been added to the Windows Startup group, it should be removed; otherwise, Windows will try to start a second instance of CCITCP2.

If CCITCP2 is started from a command line with the -d (debug) option or installed as a service with the -c option, then pressing the F2 key will list the CCI services that are registered with the daemon. F4 toggles the echoing of the console output to the ccitcp2.log file in the current directory of the daemon.

Note:

If you have installed Micro Focus Enterprise Server for Windows, available with Net Express and also standalone, then the Micro Focus Directory Server (MFDS) will have been installed as a service, so there is no need to manually install CCITCP2 as a service. (If you have already installed CCITCP2 as a service, stop it and uninstall it before installing Micro Focus Enterprise Server for Windows.) For more information see the section Using Directory Server Instead of CCITCP2.

Parent topic: Advanced Features
Related information
Using Directory Server Instead of CCITCP2


Using CCI Over TCP/IP Without CCITCP2

  • Direct Connection and Starting Servers on Fixed Ports
  • Environment Variables and the CCI.INI File
Parent topic: Advanced Features


Direct Connection and Starting Servers on Fixed Ports

A CCITCP2 registration daemon is not necessary if the CCI client application and the CCI server application establish a connection directly between each other. This can only be done when the server application starts up on a specific TCP port, and the client knows which address and port the server is using.

In a relatively static application enterprise environment where the server application location is well-defined and persistent, then using direct connection can have advantages over using a CCITCP2 registration process to help establish a connection.

Allowing a server application to listen on a known, fixed port means that clients can contact the server through a security firewall if a gap has been configured for that port and address.

A CCI server can support both direct connection and normal connection via a CCITCP2 daemon simultaneously. If a server starts on a fixed port, and a CCITCP2 daemon is present, then it will register a Server Name with it as normal, but in addition clients will be able to connect to it directly because the port it is using is known. If the CCITCP2 daemon is not present or reachable then a fixed port server will still start successfully, but only clients who attempt to connect directly will be able to contact it.

Parent topic: Using CCI Over TCP/IP Without CCITCP2


Environment Variables and the CCI.INI File

A variety of environment variables and CCI.INI file entries can be used to customize CCI behavior either on a machine-wide or per-process basis. Most users should not need to use either of these methods, but they are provided in case a greater degree of application control is required.

If more than one of the above methods is used for the same purpose or feature, the order of precedence that determines the behavior is:

  1. environment variable
  2. CCI.INI option
  3. the original or default behavior
  • CCITCP Environment Variables
  • CCITCP Options in the CCI.INI File
Parent topic: Using CCI Over TCP/IP Without CCITCP2


CCITCP Environment Variables

In the following sections UNIX users should use the appropriate method of setting environment variables for the user shell which is being used. The examples given are guides using the manner of setting environment variables found on the PC.

  • CCITCP2 Environment Variable

    Instead of using the CCI Configuration Utility to set the TCP address of the machine running the CCITCP2 registration daemon the environment variable "CCITCP2" can be used instead. This may be useful if you need different processes on the same machine to contact different registration daemons. The value can be set from the command prompt by typing:

    set CCITCP2=hostname

    where hostname is the TCP hostname or dotted decimal IP address of the machine running the CCITCP2 daemon you wish to contact from that session.

    The environment variable value will always take precedence over any value set using the Configuration Utility. To restore a process to using the value set by the Configuration Utility simply set the environment variable to an empty string e.g.

    set CCITCP2=

    Alternatively, if this environment variable is set system-wide (by creating a system variable in the system environment settings, or by using a CONFIG.SYS file) then this value will always take precedence over any value set using the Configuration Utility.

  • CCITCPS_ Environment Variable

    If you want to start a CCI server on a fixed port, then you can associate the Server Name with the port value by using the CCITCPS_ environment variable (instead of appending the information on the Server Name itself, as described in the CCITCP Server Name section). If the Server Name is server_name, and you want it to use the fixed TCP port 3000, this can be specified by typing:

    set CCITCPS_server_name=MFPORT:3000

    Note that this will only work if the server application process is started in the same session or process that has this environment variable set.

  • CCITCPT_ Environment Variable

    If a client is known to be trying to connect to a server with Server Name server_name, and the TCP address (server_hostname) and port (e.g. 3000) that the server is using is known, then the client can be made to connect directly to it by setting an environment variable as follows:

    CCITCPT_server_name=MFNODE:server_hostname,MFPORT:3000

    Note that this can be used instead of setting the client Machine Name value (see section CCITCP Machine Name). This is useful if the Machine Name value the client specifies cannot be altered by an application defined method.

Parent topic: Environment Variables and the CCI.INI File
Related information
CCITCP Server Name
CCITCP Machine Name


CCITCP Options in the CCI.INI File

The CCI.INI file is only used by CCITCP if direct connection or a fixed port server is required. In addition, this configuration method is only recommended when the Server Name or Machine Name cannot be modified by the application that is using CCI, and the environment variable method described in the section above is also not considered suitable.

There are two possible sections in the CCI.INI file which are specifically used by CCITCP:

[ccitcp-servers]

which can have entries of the following form:

server_name=MFPORT:xxxxx

This is used exclusively to match a given Server Name server_name (see CCITCP Server Name for a description of valid values) with a fixed TCP port value xxxxxx.

The other CCI.INI section used is:

[ccitcp-targets]

which expects entries of the following form:

server_name=MFNODE:server_hostname,MFPORT:xxxxx

This is used exclusively by clients to associate a target Server Name server_name with a Machine Name value to the right of the "=" character (see CCITCP Machine Name for valid values and uses).

Parent topic: Environment Variables and the CCI.INI File
Related information
CCITCP Server Name
CCITCP Machine Name


Application Configuration

CCITCP Client/Server applications use the CCI Server Name and Machine Name parameters to enable the CCI Client to specify the CCI Server with which to communicate.

The CCI Server identifies itself on the network by using the Server Name parameter. The CCI Client specifies the CCI Server using the Server Name. Additionally, if it only wants to find this Server running on a particular machine in the network, it needs to specify the Machine Name parameter.

  • CCITCP Server Name
  • CCITCP Machine Name
Parent topic: CCITCP Configuration


CCITCP Server Name

Both CCI server and CCI client applications need to have a Server Name specified: server applications need to register themselves as available under this name (or what fixed port to use); and clients need to specify which server they wish to contact. The Server Name is not the same as the TCP host name of the machine the application is running on, but a name chosen by the server application to identify itself on the network so that client applications can find it whichever machine it is running on.

Server Name can be any valid alphanumeric string (up to 127 characters in length). Names beginning with a ',' character, or including the consecutive characters ",MF" are reserved for Micro Focus use.

If you wish to have the server start on a fixed or known TCP port (see Direct Connection and Starting Servers on Fixed Ports), then this can be achieved by appending the string ",MFPORT:xxxxx" to the Server Name, where xxxxx is the decimal value of the port. This string is not used as part of the Server Name, but is interpreted by CCI so that the server uses the specified port for listening for incoming clients. If you do not wish the server to have any name (that is, clients cannot use CCITCP2 to contact the server, but can only specify it directly by using the Machine Name parameter) then the Server Name need only consist of this string.

Note:

It is recommended that you do not use port numbers below 2000 as these may already be in use by standard TCP services. The maximum port value normally supported is 65535. Care should be taken not to use a port value that is already in use by other standard applications: check with the system or network administrator on valid port value ranges that should be used.

Parent topic: Application Configuration
Related information
Direct Connection and Starting Servers on Fixed Ports


CCITCP Machine Name

This is a parameter that only needs to be specified by CCI client applications.

This should be the TCP address (either the hostname if DNS is enabled, or the dotted decimal address if not) of the machine you wish to restrict the client to contacting. If you know that the Server Name of the application the client is trying to contact is unique in the reachable network, or you do not care which server of this same name it connects to, then this parameter is optional.

If you do not wish to use a CCITCP2 daemon to resolve the TCP address and port that the server is using (see Using CCI over TCP/IP without CCITCP2), but want the client to contact the server directly, then the Machine Name must have the following form:

MFNODE:server_hostname,MFPORT:xxxxx

where server_hostname is the hostname or dotted decimal address which the server application is using, and xxxxxx is the decimal port value.

Parent topic: Application Configuration
Related information
Using CCI over TCP/IP without CCITCP2


CCINAMPU Configuration

  • CCI Support for UNIX Named Pipes (FIFOs)
  • Application Configuration
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


CCI Support for UNIX Named Pipes (FIFOs)

  • CCI Support Module for UNIX Named Pipes
  • Transport Speed
  • CCI.INI File Options for CCINAMPU
Parent topic: CCINAMPU Configuration


CCI Support Module for UNIX Named Pipes

In order to enable CCI support for UNIX Named Pipes, one shared object executable module is supplied

  • cobnampu.so - which enables the CCI interface routines in CCI enabled processes to communicate with each other.

The CCINAMPU module is used to connect processes on single UNIX machines using UNIX named pipes (FIFO pipes). Any process running on a machine which has CCINAMPU installed can access any service on that same machine. CCINAMPU cannot communicate with CCINAMP for OS/2.

Parent topic: CCI Support for UNIX Named Pipes (FIFOs)


Transport Speed

For a given machine CCINAMPU may perform faster than using CCITCP in loopback mode (communicating on a single machine). This is entirely dependant upon the priorities given to each method of communication by the UNIX kernel design on any given system, it is recommended that users try both CCITCP and CCINAMPU and select whichever performs quicker in their own system.

Parent topic: CCI Support for UNIX Named Pipes (FIFOs)


CCI.INI File Options for CCINAMPU

Unlike many other CCI protocol modules, there are no CCI.INI configuration options available when using CCINAMPU.

Parent topic: CCI Support for UNIX Named Pipes (FIFOs)


Application Configuration

CCI Client/Server applications use the CCI Server Name and Machine Name parameters to enable the CCI Client to specify the CCI Server with which to communicate.

The CCI Server identifies itself on the network by using the Server Name parameter. The CCI Client also specifies the CCI Server using the Server Name. Additionally, if it only wants to find this Server running on a particular location within the UNIX machine, it needs to specify the Machine Name parameter.

In other protocols Machine Name is used to specify the individual machine hosting a service, with CCINAMPU Machine Name is used to denote the directory location of the service's listening Named Pipe, as such within a single UNIX system there may be several Services using the same Server Name but residing in different areas of the system.

  • CCINAMPU Server Name
  • CCINAMPU Machine Name
  • Default Service Location
  • Common Error Status
Parent topic: CCINAMPU Configuration


CCINAMPU Server Name

The Server Name specified in the creation of a CCINAMPU server can be one of the following:

  • A relative pipe-name (default)
  • An absolute pipe-name

A relative pipe-name is equivalent to an absolute pipe-name composed of a concatenation of the path /usr/spool/uucppublic/.CCI/ together with a period and the given server name. A relative pipe-name must be at least one character less than the maximum allowed length of a filename for the operating system.

For example, a Server Name consisting of

mainsrvr

would generate a named-pipe with the name /usr/spool/uucppublic/.CCI/.mainsrvr which would be unique on the machine in use.

The only restriction for using an absolute pipe-name is that the pipe name must be of a file layout supported by the host machine's file system.

An example of an absolute pipe-name is:

/u/work/pipespace/mainsrvr

This creates a pipe at the exact location specified. If the user attempting to create the pipe does not have permissions to use the requested directory, CCINAMPU issues an error.

All absolute pipe-names must start with a leading slash (/).

Parent topic: Application Configuration


CCINAMPU Machine Name

The CCINAMPU client initialization function always assumes that a Server Name is a relative pipe-name when it is passed an empty Machine Name parameter. When CCI-Initclient is passed a non-empty Machine Name parameter, the pipe-name searched for is composed of the absolute Server Name with the Machine Name preceding it to form the complete absolute path.

Thus if Server Name is passed as:

mainsrvr

and Machine Name is passed as:

/u/work/pipespace

the resultant pipe that is searched for would be /u/work/pipespace/mainsrvr

and would connect with the example of an absolute servername used in the description for starting a CCINAMPU server given above.

An absolute pipe-name must be consistent with any limitations of the file system in use on the host machine at all times. You should be aware that file permissions apply to named-pipes as well as to files.

Absolute pipe-names cannot be used across network file systems (NFS) successfully. Therefore, we recommend that relative pipe-names are used for simplicity in the majority of applications.

Parent topic: Application Configuration


Default Service Location

Unlike CCITCP, there is no central registration module for CCINAMPU. Any Server Name given to CCINAMPU as a relative pipe name, for example, "SRVS" appears as a pipe-file in the directory /usr/spool/uucppublic/.cci/.SRVS.

These are not normal files but they are affected by access permissions. So, if a server doesn't respond to a client's request, the first check should be made on access permissions. All files, and the directory itself, should have READ and WRITE permissions for all processes.

Parent topic: Application Configuration


Common Error Status

When running an application which uses CCINAMPU, if an error occurs when starting either the client or the server components, and the error status indicates that the system was too busy to create a new pipe, then it is most likely that the access permission set in the service location directory - for default service locations /usr/spool/uucppublic - is incorrect. The permission must be set to 777 for CCINAMPU to function correctly for all users at all times.

Parent topic: Application Configuration


Application Configuration

  • CCI Configuration for the Mainframe Access Product Suite
  • CCI Configuration for Fileshare
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


CCI Configuration for the Mainframe Access Product Suite

The section CCI Configuration in the protocol specific CCI configuration for Applications section below, describes the prerequisite CCI configuration for each protocol, which must be completed prior to its successful use with any application, including the Mainframe Access product suite.

Once the system has been configured correctly for use with CCI the following CCI parameters in Mainframe Access must be configured as described below:

  • CCI communication type

    Select the CCI protocol to use.

  • Standard Server Name

    Specify the standard server name of the Fileshare Server, which is Server Name as described in the section Server Name guide for the CCI Configuration being used.

  • Standard Server Machine Parameters

    Specify the Standard server machine parms, which is Machine Name as described in the section Machine Name guide for the CCI Configuration being used.

  • An example of using APPC with Mainframe Access
  • An example of using TCP/IP with Mainframe Access
Parent topic: Application Configuration
Related information
CCI configuration for Applications


An example of using APPC with Mainframe Access

The Partner LU Name portion of the Standard Server Name (before the period) for Mainframe Access must match the Partner LU Name, also known as the APPLID, of the Fileshare task running on the host system. The Transaction Program Name portion of the Standard Server Name for Mainframe Access (following the period) should be four characters long with 'F' as the fourth character.

In the example below the mainframe Server Name used is FILESHR2.BETF.

Parent topic: CCI Configuration for the Mainframe Access Product Suite


An example of using TCP/IP with Mainframe Access

In the example below the mainframe Server Name used is FILESHR2.MYSERVER.

If the mainframe connection supports direct connection, then the Standard Server Machine Parameter needs to be filled out. In this example the TCP hostname of the mainframe is server_hostname, and the fixed listening port is 3000. If the connection is direct then the Standard Server Name is optional.

Parent topic: CCI Configuration for the Mainframe Access Product Suite


CCI Configuration for Fileshare

  • Generic Fileshare Configuration
  • CCI Configuration for Applications
Parent topic: Application Configuration


Generic Fileshare Configuration

This may also be described as Record Level I/O especially when the Fileshare Server is running on a mainframe system.

The section CCI Configuration in the protocol specific CCI Configuration for Applications section below, describes the prerequisite CCI configuration for each protocol, which must be completed prior to its successful use with Fileshare.

Once the underlying protocol support has been configured correctly for use with CCI the following CCI parameters in Fileshare must be configured as described below:

  • Communication Module Parameter

    This is specified using the FSCOMMS environment variable or the Fileshare Server /CM parameter or the /CM parameter in the FHREDIR.CFG Fileshare Client configuration file.

  • Server Name Parameter

    This is specified using the FSSERVER environment variable or the Fileshare Server /S parameter or the /S parameter in the FHREDIR.CFG Fileshare Client configuration file.

    Specify the Server Name of the Fileshare Server as described in the section Server Name guide for the CCI Configuration being used.

    For example,

    SET FSCOMMS=Server-Name

    or in FHREDIR.CFG:

    /S
                Server-Name
  • Machine Name Parameter

    This is specified using the /MA parameter in the FHREDIR.CFG Fileshare Client configuration file. Note that the /MA parameter must be on the same FHREDIR.CFG text line as a matching /S parameter.

    Specify the Machine Name as described in the section Machine Name guide for the CCI Configuration being used.

For example, in FHREDIR.CFG:

/MA Machine-Name /S Server-Name

Note that Fileshare has a limit of 64 characters for the /MA parameter.

  • Example FHREDIR.CFG Configuration File for Use with APPC
  • Example FHREDIR.CFG Configuration File for Use with Multiple CCI Modules
  • Example FHREDIR.CFG Configuration File for Use with Default CCI Modules
Parent topic: CCI Configuration for Fileshare
Related information
CCI Configuration for Applications


Example FHREDIR.CFG Configuration File for Use with APPC

/MA CCILLU01.#INTER /S FILESHR2.BETF
/CM CCIAPPC /S FILESHR2.BETF
/F SYSOUT* /S FILESHR2.BETF

Fileshare can be used with multiple CCI protocols simultaneously, by specifying different CCI communications modules for each Fileshare Server, and by specifying which files reside on which server.

Parent topic: Generic Fileshare Configuration


Example FHREDIR.CFG Configuration File for Use with Multiple CCI Modules

/MA CCILLU01.#INTER /S FILESHR2.BETF
/CM CCIAPPC /S FILESHR2.BETF
/F SYSOUT* /S FILESHR2.BETF
/CM CCINETB /S FILESHR1
/F MYFILE /S FILESHR1

Fileshare also has the capability to specify a default protocol to be used whenever a file location is not specified directly in the configuration file.

Parent topic: Generic Fileshare Configuration


Example FHREDIR.CFG Configuration File for Use with Default CCI Modules

/CM CCITCP
/MA 32CC461,1 /S FILESHR2
/CM CCIIPX /S FILESHR2
/F FileName /S FILESHR2

This configuration file works in the following manner:

  • /CM CCITCP

    specifies the use of CCITCP as the default protocol to be used whenever no other specific configurations apply.

  • /MA 32CC461,1 /S FILESHR2

    specifies a Machine Name location to be used whenever the Fileshare server called "FILESHR2" is accessed.

  • /CM CCIIPX /S FILESHR2

    specifies that CCIIPX be used to contact the Fileshare server called FILESHR2.

  • /F FileName /S FILESHR2

    specifies that any access to a specific file called "FileName" is always made to Fileshare Server called "FILESHR2".

Parent topic: Generic Fileshare Configuration


CCI Configuration for Applications

Each application which uses CCI has different configuration mechanism, however the details of the CCI communications requirements are the same for all applications calling the same CCI module. These CCI configuration requirements are detailed in the sections in the table below. For details on the Protocol specific CCI Configuration, Server Name and Machine Name guidelines, please click on the appropriate item in the CCI configuration table below.

  • CCI Configuration Information by Protocol
  • Advanced Use of CCITCP Without Using CCITCP2
Parent topic: CCI Configuration for Fileshare


CCI Configuration Information by Protocol

For normal use of CCI protocol modules, including CCITCP using the CCITCP2 service registration daemon, please use the links in the following table to help configuration of the relevant environments. For details of using CCITCP without using CCITCP2, please see the section below.

All of the protocol modules listed in the table below are available on Windows 32-bit operating systems except CCINAMPU. CCITCP and CCINAMPU are available on the UNIX operating system.

CCIAPPC | CCI Configuration | Server Name guide | Machine Name guide
CCIIPX | CCI Configuration | Server Name guide | Machine Name guide
CCINETB | CCI Configuration | Server Name guide | Machine Name guide
CCITCP | CCI Configuration | Server Name guide | Machine Name guide
CCINAMPU | CCI Configuration | Server Name guide | Machine Name guide
Parent topic: CCI Configuration for Applications
Related information
CCIAPPC Configuration
Server Name guide
Machine Name guide
CCI Configuration
Server Name guide
Machine Name guide
CCI Configuration
Server Name guide
Machine Name guide
CCI Configuration
Server Name guide
Machine Name guide
CCI Configuration
Server Name guide
Machine Name guide


Advanced Use of CCITCP Without Using CCITCP2

It is possible to use CCITCP without having a CCITCP2 daemon present (see Direct Connection and Starting Servers on Fixed Ports on why you may want to do this). This method may be used for all applications which use CCITCP.

Example:

To start a Fileshare Server using a fixed TCP port, on the machine whose TCP hostname is server_hostname, enter the following command:

fs /s server_name,MFPORT:3000 /cm CCITCP

where:

server_name | is the name of the Fileshare Server
,MFPORT:3000 | is used by CCITCP to ensure that the server listens for incoming calls on port 3000

Once you have configured the Fileshare Server to use a specific port, you can get a Fileshare Client to connect to the server on this port number using the /MA parameter in the FHREDIR.CFG file to specify a Machine Name of the form:

/MA MFNODE:server_hostname,MFPORT:3000 /S server_name

The FHREDIR.CFG will look like this:

/S server_name
/CM ccitcp
/MA MFNODE:server_hostname,MFPORT:3000 /S server_name
Parent topic: CCI Configuration for Applications
Related information
Direct Connection and Starting Servers on Fixed Ports


CCI Trace

  • Activating CCI Trace
  • CCI Trace Options
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


Activating CCI Trace

To activate CCI Trace add the following /tr parameter setting to the Fileshare Server configuration file.

/tr cci

To prevent unauthorized access to the CCI Trace information you are prompted for the supervisor password when you invoke a Fileshare Server with CCI Trace enabled (the supervisor password is that specified for the user-ID FSVIEW in the password file so you must specify this password when you start the Fileshare Server). If the password is accepted CCI Trace is enabled and a second prompt asks if CCI Trace should be activated immediately or not.

CCI Trace can be toggled on and off using the F3 key.

Parent topic: CCI Trace


CCI Trace Options

  • CCITRACE Environment Variable
  • CCI.INI Trace Options
Parent topic: CCI Trace


CCITRACE Environment Variable

CCI trace can be enabled for any application by setting the CCITRACE environment variable as follows:

CCITRACE=filename [options]

where:

filename
The name of the log file you want the trace output to go to. If you do not specify this parameter, the log file ccitrc1.trc is created in the current directory with all options set to their default states. A matching filename.idx will also be generated.
options
Any, or all, of the following:
/F or -F | logs the details of CCI API calls to the trace file. The default condition for this option is OFF, unless a filename or any other trace option are specified, in which case it is always ON.
/P or -P | logs the details of protocol level calls to the trace file. If this flag is not ON, then only the details of the CCI user level API will be traced. If this flag is ON, the level of function tracing may be greatly increased. The default condition for this option is OFF.
/D or -D | logs the contents of all buffers passed to and from the CCI functions. The default condition for this option is OFF. Data tracing may not be allowed if the application has been coded to prohibit data tracing for security reasons.

So to create a CCI trace file with the default name of ccitrc1.trc (with matching ccitrc1.idx file) which traces CCI API function flow, along with the underlying protocol function flow, but with no tracing of the user data passed to these calls, the value of the CCITRACE environment variable would be /P.

The CCI.INI file can also be used to control trace options, but any values specified by the CCITRACE environment variable will take precedence.

Parent topic: CCI Trace Options


CCI.INI Trace Options

CCI trace options can be specified via the CCI.INI file. These options are listed under the [ccitrace-base] section.

Option | Value | Meaning
force_trace_on | yes or no | If yes, logs the details of CCI API calls to the trace file. The default condition for this option is no. Unless this option is specified, no tracing will be generated, even if the other options are specified to yes.
protocol_trace | yes or no | If yes, logs the details of protocol level calls to the trace file. If this option is yes, the level of function tracing may be greatly increased. The default condition for this option is no.
data_trace | yes or no | If yes, logs the contents of all buffers passed to and from the CCI functions. The default condition for this option is no. Data tracing may not be allowed if the application has been coded to prohibit data tracing for security reasons.

For example, to turn on CCI API tracing and data tracing, but not protocol level tracing, the CCI.INI file would need to contain the following

[ccitrace-base]
force_trace_on=yes
protocol_trace=no
data_trace=yes

Note that if trace options have been specified via a CCITRACE environment variable they will take precedence over any trace options specified in the CCI.INI file.

Parent topic: CCI Trace Options


CCI.INI - The CCI Configuration File

  • What is the CCI.INI File?
  • Where to Locate CCI.INI
  • The Format of CCI.INI
  • Specific Contents of CCI.INI for Each CCI Module
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


What is the CCI.INI File?

The CCI.INI file is used to specify selective configuration options for all or some CCI modules installed on a system. The contents of the CCI.INI file will vary from system to system in a network, depending upon the requirements for tuning each individual system.

Parent topic: CCI.INI - The CCI Configuration File


Where to Locate CCI.INI

CCI.INI may be located in a number of locations for testing and deployment. The Windows root directory is a good location as it is visible from all applications, on Windows systems of all types. On UNIX systems, the COBOL cobdir/bin installation directory or the applications current directory are good logical locations. There may be configuration sections for more than one CCI protocol module in any CCI.INI file so care is required when choosing the location for a CCI.INI file. If you only want to affect the behavior of a single application, rather than affecting every application on the system, put the CCI.INI file (containing the CCIIPX entries) in the current directory, from where the application is being run.

Parent topic: CCI.INI - The CCI Configuration File


The Format of CCI.INI

CCI.INI is a plain text file, which may be edited or created by any text editor. A CCI.INI file may look like this:-

[cciipx-base]
  REPORT_CONNTYPES=n
  CRC_SEND=n
  CRC_FORCE_RECV=n
  CRC_REPORT_FAILS=n
  CRC_RETRY=y
  MAX_PKT_SIZE=17872

[ccinetb-base]
  AdapterLoc=0
  DefaultBuffLen=4096
  Commands=20
  Sessions=10
  Names=2

[ccitcp-servers]
  myserver=MFPORT:3000
Parent topic: CCI.INI - The CCI Configuration File


Specific Contents of CCI.INI for Each CCI Module

The following sections describe the usage of CCI.INI file for all the available CCI modules.

  1. There are no CCI.INI tuning options for CCIAPPC
  2. CCI.INI usage for CCIIPX
  3. CCI.INI usage for CCINETB
  4. CCI.INI usage for CCITCP
  5. There are no CCI.INI tuning options for CCINAMPU
  6. CCI.INI usage for CCI Trace
Parent topic: CCI.INI - The CCI Configuration File
Related information
CCI.INI usage for CCITCP
CCI.INI usage for CCI Trace


CCI Status Messages

  • CCI Status Messages
  • CCI Message Table
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


CCI Status Messages

All CCI modules produce text based error messages describing the status of the completion of the last CCI operation. Some errors are critical and require remedial action before use of the affected CCI module can continue. Others are warnings and, in most cases, do not require you to take any action.

When an error occurs in the communications layer the CCI status codes returned to calling applications will change to reflect the underlying problem that has occurred. All CCI enabled applications can then make a call to CCI to obtain a text message describing the problem.

The manner in which these messages is returned to the application user is specific to each application, however the actual text returned from CCI is the same in all cases. The sections below indicate what the status messages mean, and what steps can be taken by the user to correct the situation which created the error status in the first place.

The text format used for all CCI messages is as follows:-

"CCINETB-0001I A CCINETB call has timed-out."

This is broken down in to the following sections:

  • Protocol issuing the message - "CCINETB"
  • Message number - "0001"
  • Severity level - "I"
  • Message text.- "A CCINETB call has timed-out."

Not all the available messages are produced by all the protocol modules, there are also messages which are specific to individual aspects of configuration on specific protocol environments. Some status are intended for use only during the development of CCI enabled applications, where these status are seen by the end user they should contact our technical support staff and report the situation and applications which generated the status condition.

Parent topic: CCI Status Messages


CCI Message Table

The following is a list of status numbers returned which may be produced from CCI modules, along with a brief explanation of their meaning, and, if applicable, a suggestion as to how to resolve the issue being reported. Status numbers which are produced to aid coding of CCI applications have been included in this list.

Message Number | Severity | Reason | Suggestion
0000 | Information | The last operation completed successfully | No action to take
0001 | Information | The last operation Timed-out prior to completion. | Increase time-out periods if the application allows, or check the status of the remote application to ensure that its host system is still functioning.
0002 | Information | A buffer given to a CCI receiving operation was too small to contain the incoming data stream. | This is a warning intended for applications designers. Contact us if you suspect that this is actually causing a problem.
0003 | Error | A bad parameter was given to a CCI function. | This is a application coding problem. Contact our technical support department and report any of these errors that appear.
0004 | Warning | This is only generated from a Service initiation. This status indicates that a Service with the same name was previously registered at the same network address. | No action required, the current Service is now registered with the network, connecting clients will connect to this Service.
0005 | Error | This is only generated from a Service initiation. This status indicates that a Service with the same name was previously registered at the same network. | Two services cannot exist on some networks with the same Service name, choose another name to start this Service with.
0006 | Error | A name parameter passed being used to start a client or a Service was invalid. | The range of valid names differs for underlying protocols, please see the sections for the relevant CCI module for the protocol in use for this information.
0007 | Error | An attempt was made to use a connection which has already been terminated. | This is a application coding error, contact our technical support department and report any occurrence of this error.
0008 | Error | A broken connection was detected on this link. | Check the status of the network supporting this link and determine whether the problem lies at the network or at the machine at the far end of the link.
0010 | Warning | The CCI module in use was too busy to complete the request. | Allow some of the outstanding CCI actions to complete before trying again.
0011 | Warning | The CCI module discovered that the system was too low on memory to complete an action. | Close any unwanted applications, and free up some memory to allow the application to continue.
0012 | Error | No service was found, the client could not complete a connection request. | Check the address passed as a location to the client and try again.
0013 | Error | The address specified in the direct addressing modes would not accept a client connection. | Check the address passed as a location to the client and try again. The service listening at the far end may not be compatible with a CCI client.
0014 | Error | An error occurred when creating a network endpoint. | The local network service provider was incapable of creating a new connection point, this usually means that a resource limit has been reached, or that the network itself is disabled. Check the system status and raise network resources as appropriate.
0015 | Error | A transport error has occurred | CCI full network transport failure has been reported to CCI from the transport provider. Check the network status, correct any problems that are found and try again.
0016 | Error | A CCI support module was not found on the network. | Some CCI protocols and configurations require network support modules, such as CCITCP2, please check to ensure that you have configured your network correctly to use CCI, and that the required support modules are running before starting CCI, then try again.
0017 | Error | A transport connection error has occurred | Where possible CCI will distinguish between this message and message 0016. This message indicates that an individual connection has failed, rather than a general network failure occurring. Check the application at the far end of the link to ensure that it is still functioning.
0018 | Information | An asynchronous call has not completed yet. | This status is intended for application programmers to monitor the status of an ongoing operation, it may be ignored by end users.
0019 | Information | An asynchronous call has completed correctly. | This status is intended for application programmers to monitor the status of an ongoing operation, it may be ignored by end users. It is functionally equivalent to status "0000".
0020 | Information | An asynchronous call has completed part one of a two part operation.. | This status is intended for application programmers to monitor the status of an ongoing operation, it may be ignored by end users.
0021 | Error | An error occurred when closing a session. | This could be a network or operating system failure, however a failure at this time may not affect the overall running of an application. Contact our technical support department if you suspect that this is actually causing a problem.
0022 | Error | This is only generated from a Service termination. Could not de-register a service | There was a problem when terminating a service that prevented it being de-registered from the CCI support modules such as CCITCP2, or from the network provider itself. Subsequent attempts to start a Service with the same name will generate messages 0004 or 0005 depending upon the network which is being used.
0023 | Error | This is only generated from a Service application. A client connection could not be completed due to a network level error condition. | The network service provider reported a failure to allow a full connection of an incoming client. Check the connecting clients to determine which of them is failing to connect, then check the network provider on the client and server machines for version compatibility.
0024 | Error | A call to HANGUP a server session could not complete as data was still queued. | This is an application coding error. Contact our technical support department.
0025 | Error | Transport initialization failure, INITCLIENT could not find CCITCP2, | The UDP support in the TCP/IP service provider configuration may be switched off, or may have run out of available resources. Ensure that UDP is enabled and that sufficient sockets are available, then try again.
0026 | Error | Transport initialization failure during INITCLIENT. | Check the version details of the network service provider to ensure that CCI is compatible with this level of network provider.
0027 | Error | A call to CCI-Query was made with an invalid session handle. | This is an application coding error. Contact our technical support department.
0028 | Error | A call to CCI-Wait was made with an invalid session handle. | This is an application coding error. Contact our technical support department.
0029 | Error | Parameters were incorrectly passed to the call named in the text. | This is an application coding error. Contact our technical support department.
0030 | Error | A listen call failed as the machine was too busy to receive any more incoming client connections. | The system configuration is too small to support the connection load being used, either increase the system capacity for the protocol in use, or reduce the load on this specific system by examining other possible alternative to using this system.
0031 | Error | A CCI function detected a transport failure during an attempt to receive a data buffer. | The network, or the machine at the far end of the connection, experienced an error condition, correct the network error and try again.
0032 | Error | CCI-Transact function detected a transport failure during an attempt to send a data buffer. | The network, or the machine at the far end of the connection, experienced an error condition, correct the network error and try again.
0033 | Error | CCI-Transact function detected a transport failure during an attempt to receive a data buffer. | The network, or the machine at the far end of the connection, experienced an error condition, correct the network error and try again.
0034 | Error | CCITCP could not find an entry for "mfcobol" in the "services" TCP/IP configuration file. | An entry such as : 'mfcobol <TAB> 86/udp' must be included in the file for CCI to establish a registration ,or make a registration enquiry with a CCITCP2 module.
0035 | Error | The far end of a connection has been reset. | Check this status of the remote end of a connection as it appears to have dropped off the network.
0036 | Information | CCITCP2 could not be found, a CCI Service could not de-register correctly from CCITCP2. | The Service registration module, CCITCP2, may have been closed or the network link to the machine hosting CCITCP2 may have died. If CCITCP2 is still running any requests for this Service will find a registration which is not responding to Client connection attempts. Any further requests to register the Service by the same name will get a status "0004" returned as it was already registered. See the CCITCP configuration guide for further details about using CCITCP2.
0037 | Error | An invalid service handle was passed to the CCI function named in the text. | This is an application coding error. Contact our technical support department.
0038 | Error | An invalid async' request handle was passed to CCI-Query or CCI-Wait. | This message has been superseded by "0027" and "0028" and should only be found on older CCI installations. See "0027" and "0028" for the correct action to take.
0039 | Warning | A data buffer and length combination given to CCI crossed a segment boundary in memory. Data was truncated at this boundary. | This is an application coding error. Contact our technical support department.
0040 | Error | A call to CCI-Suspend was made prior to a call to CCI-Resume. | This is an application coding error. Contact our technical support department.
0041 | Error | A call to initialize a network service provider has failed | Check the network support for the system and correct any problems found, then try again.
0042 | Error | Could not attach to a Network Server | This CCIIPX message indicates that no NetWare server has been found on your network. CCIIPX cannot operate with a NetWare server on its network and so cannot continue.
0043 | Error | Cannot connect to an incompatible version of CCI | A connection has been requested between dissimilar CCI installations, this has been detected and to prevent possible data flow problems a connection cannot be completed. please check the revisions in use and update the CCI installations as required before trying again.
0044 | Error | Could not register a service | This could be a configuration error, see CCITCP2, or the underlying network could have failed to allow the registration due to insufficient capacity of available resources, see message 0025 and CCINETB configuration.
0045 | Error | A bad address was passed to a CCI initialization call. | Check that the addresses used in the configuration are of the correct style and content for the CCI module being used, then try again.
0046 | Error | CCIAPPC failed to locate an APPC session | Ensure that the local LU is defined for this session.
0047 | Error | A call to CCI failed as CCI has already been terminated. | This is an application coding error. Contact our technical support department.
0048 | Error | A bad data buffer location was passed to CCI for use in sending or receiving data. | This is an application coding error. Contact our technical support department.
0049 | Error | CCI-Trace was unable to create trace output files for the CCI module named in the text. | There may be insufficient space left on the fixed disk to hold the data trace file. Please clear some space and try again.
0050 | Error | The requested CCI-TRACE output file could not be opened | Check that write permissions are available for the user of the application being traced, and that there is sufficient disk space remaining to store the trace file before trying again.
0051 | Error | An unexpected CCI error has occurred. | This is an internal CCI error. Contact our technical support department.
0052 | Information | This status is reserved for future use. |
0053 | Information | This status is reserved for future use. |
0054 | Information | This status is reserved for future use. |
0055 | Warning | Cannot send or receive data on a suspended session. | This is an application coding error. Contact our technical support department.
Parent topic: CCI Status Messages
Related information
CCITCP2
CCINETB configuration


Attachmate Personal Client v6.3

  1. Installing DLC for Windows 95
  2. Installing Attachmate Personal Client
  3. Configuring Attachmate Personal Client
  4. Step 1: Creating a New Configuration
  5. Step 2: Local Node Definition
  6. Step 3: Data Link Control Definition
  7. Step 4: Port Definition
  8. Step 5: Configuring the 802.2 Template (Port Definition)
  9. Step 6: Link Definition
  10. Step 7: Configuring the 802.2 Template (Link Definition)
  11. Step 8: Configuring a 3270 LU for Terminal Emulation
  12. Step 9: Configuring LU's for APPC
  13. Step 10: Configuring the Local LU
  14. Step 11: Configuring the Remote LU
  15. Step 12: Adjacent Link Definition
  16. Step 13: Configuring Session Limits - Defining a Mode
  17. Step 14: Enabling CCIAPPC to Find the Local LU
  18. Step 15: Updating the System Path
  19. Step 16: Activating the Configuration
  20. Error Reporting and Diagnostics
  21. Known Problems
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT
Important Bulletin Regarding Support For Attachmate EXTRA! Personal Client


Installing DLC for Windows 95

The Rumba product requires the Microsoft 32-bit DLC protocol to provide support for a connection over 802.2. You should already have installed the 32-bit DLC driver for Windows 95 or Windows NT. If you have not yet done this, please follow the instructions for installing this driver in Configuring DLC over 802.2 on Windows 95 or Configuring DLC over 802.2 on Windows NT.

Parent topic: Attachmate Personal Client v6.3
Next topic: Installing Attachmate Personal Client
Parent topic: Attachmate Personal Client v6.1 and v6.2
Next topic: Installing Attachmate Personal Client
Parent topic: Rumba Office 95/NT
Related information
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


Installing Attachmate Personal Client

You should have already installed Attachmate Personal Client. We suggest that you confirm that the CPI-C interface is installed before continuing, the 3270 display portion of this product will be fully functional without CPI-C, but CCIAPPC will not be able to access APPC.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Installing DLC for Windows 95
Next topic: Configuring Attachmate Personal Client


Configuring Attachmate Personal Client

After successfully installing the Attachmate Personal Client product, you can start to configure your APPC connection. You should have a VTAM definition of the connection you are attempting to configure available to you during the configuration. Select Start from the Taskbar, then Programs, then EXTRA! Personal Client 32-bit, then APPN Configurator. The APPN Configurator window will be displayed. A sample window with a full configuration is displayed below for reference.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Installing Attachmate Personal Client
Next topic: Step 1: Creating a New Configuration


Step 1: Creating a New Configuration

The first screen presented in the configuration tool allows you to enter a new configuration by choosing File from the action bar and selecting New to create a new configuration.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Configuring Attachmate Personal Client
Next topic: Step 2: Local Node Definition


Step 2: Local Node Definition

Select Node Definition from the Sections window and then click the Add button. The Local Node Configuration window will appear.

  1. Enter the Network ID for this SNA network. This should be obtained from the network administrator of the host system.
  2. Enter the Control Point (CP) name assigned to this machine. This should be obtained from the network administrator of the host system. The CP Name should match the Physical Unit (PU) name assigned to this machine as specified in the PU definition in VTAM for this machine.
  3. Enter the CP Alias, This should duplicate the CP Name.
  4. Enter the Default Node ID (Block ID, PU ID) This is the 8 digit hexadecimal number which is used to identify this local system on the SNA network. The first 3 digits is the block (IDBLK) number followed by the last 5 digits of the node (IDNUM) number. These numbers usually correspond with the IDBLK and IDNUM fields of the PU definition for this machine as defined in VTAM on the host system, however EXTRA requires that the PU ID be set to FFFFF.
  5. The Maximum locates and Locate timeout parameters can be left to the default values.
  6. The Default Protocol can be left to default to APPN then MPTN.
  7. HPR support level should be set to None.
  8. Support DLUR can be left to default to selected. This allows a Dependent LU Requester connection which allows you to route 3270 LU information through APPN traffic.
  9. The Start attach manager check box should be unselected. This does not need to be selected if only running CCIAPPC clients (e.g. Fileshare clients). The attach manager is only needed for incoming APPC requests, for example if running CCIAPPC servers.
  10. The Request discontact check box can be left unselected.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 1: Creating a New Configuration
Next topic: Step 3: Data Link Control Definition


Step 3: Data Link Control Definition

Select Data Link Control from the Sections window and then click the Add button. The Add Data Link Control dialog box will appear. Select DLC type Network (802.2) and press OK. The 802.2 definition template will then be displayed.

  1. Enter the DLC Name, a name to describe the DLC definition which will be unique within this node. For example, LANDLC since this is going to be a LAN connection.
  2. Leave the Negotiable links checkbox to default to unselected.
  3. The Activate on startup checkbox, we suggest initially be left unselected so that the DLC is tested by starting manually. Once this is tested this option can then be selected.
  4. For Board number specify the adapter number which will be used for this connection. If there is only one network adapter configured in this machine then select 0. To determine the network adapters installed double-click the Network icon in the Control Panel. The adapters are listed in ascending adapter number starting at zero.
  5. Select the appropriate Adapter type for the LAN network adapter, either Tokenring or Ethernet.
  6. You may allow the Buffer size in kilobytes to default to 64.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 2: Local Node Definition
Next topic: Step 4: Port Definition


Step 4: Port Definition

Select Port from the Sections window and then click the Add button. The Add Port definition dialog box will appear. Select DLC type Network (802.2) and press OK. The Port definition template will then be displayed.

  1. Enter the Port Name to describe the Port definition which will be unique within this node. For example, LANPORT since this is going to be a LAN connection.
  2. Select the Port Type, select SATF (shared access transport facility), the appropriate choice for a LAN connection. Note: select Switched for SDLC over a dialup line, Nonswitched for leased line SLDC or DFT.
  3. Enter the BTU size, select the maximum size of packet that the port can receive without segmentation. You must specify a value that is less than or equal to the value of the MAXDATA parameter of the PU definition in VTAM for this machine. For a 4 Mbs Token Ring specify a BTU value of 4195 or less. For a 16 Mbs Token Ring specify a value of 16393 or less. For an Ethernet LAN specify a BTU value of 1493 or less.
  4. Select the DLC section name, the definition to associate with this port, that is, the DLC definition configured above.
  5. Select Link station role, choose the default, Negotiable.
  6. Select Transmit/receive capability, choose the default, Half.
  7. Enter Target pacing count, allow this field to default to 7.
  8. Enter Maximum I-frames received, allow this field to default to 7.
  9. You may leave the TG characteristics section name blank.
  10. Enter Active Links. These parameters define the maximum number of connections or links which can be active using this port. This will define the maximum number of SNA connections to other nodes using this port, i.e. how many mainframes or peer systems you want to connect to using this port. We suggest you set both the Inbound and Outbound parameters to 2.
  11. The Implicit limited resource check box should be unselected.
  12. The Implicit CP-CP session check box should default to selected.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 3: Data Link Control Definition
Next topic: Step 5: Configuring the 802.2 Template (Port Definition)


Step 5: Configuring the 802.2 Template (Port Definition)

Select the 802.2 template by clicking on the tab labelled 802.2.

  1. Enter the Local SAP, allow this field to default to 4.
  2. Uncheck the HPR support checkbox to disable HPR.
  3. Enter Test Timeout and Retry, these values determine the time waited (in milliseconds) for the remote node to respond to a test frame and the number of times a test frame is transmitted if no response is received. A test frame is sent when you attempt to establish the SNA connection with the host. If you find that the connection fails to activate or fails to activate on an intermittent basis increase these values (defaults are 6 and 6).
  4. Enter the XID Timeout and Retry, these values determine the time waited (in milliseconds) for the remote node to respond to an XID frame and the number of times an XID frame is transmitted if no response is received. A NULL XID frame is sent following the response to a test frame when you attempt to establish the SNA connection with the host. If you find that the connection fails to activate or fails to activate on an intermittent basis increase these values (defaults are 6 and 6).

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 4: Port Definition
Next topic: Step 6: Link Definition


Step 6: Link Definition

Select Link from the Sections window and then click the Add button. The Add Link definition dialog box will appear. Select DLC type Network (802.2) and press OK. The Link definition template will then be displayed.

  1. Enter the Link Name, enter a name to describe the Link definition which will be unique within this node. For example, use a name which will describe the remote node, i.e. the host system, which this Link is used to communicate with.
  2. Select Adjacent CP type, select Learn.
  3. Select Port section name, select the Port definition to associate with this Link, that is, the Port definition configured above.
  4. Enter PU Name, enter a name which will act as an internal PU name which will be uniquely associated with this Link. For example duplicate the Link Name for the PU Name.
  5. Enter Adjacent net ID, leave this field blank.
  6. Enter Adjacent CP name, leave blank.
  7. Enter the Block ID, PU ID, this is the 8 digit hexadecimal number which is used to identify this local system on the SNA network.. The first 3 digits is the block (IDBLK) number followed by the last 5 digits of the node (IDNUM) number. These numbers correspond with the IDBLK and IDNUM fields of the PU definition for this machine as defined in VTAM on the host system.
  8. Select Back level XID, choose the default, No.
  9. Enter Target pacing count, allow this field to default to 7.
  10. Enter Maximum send BTU size, select the maximum size of packet that the Link can send without segmentation. You must specify a value that is less than or equal to the value of the MAXDATA parameter of the PU definition in VTAM for this machine. For a 4 Mbs Token Ring specify a BTU value of 4195 or less. For a 16 Mbs Token Ring specify a value of 16393 or less. For an Ethernet LAN specify a BTU value of 1493 or less.
  11. Select Default TG chars check box.
  12. TG characteristics, leave blank.
  13. Activate on startup check box, we suggest that initially this be left unselected so that the Link is tested by starting manually. Once this is tested this option can then be selected.
  14. Limited resource check box, do not select.
  15. Select Host connection check box.
  16. CP-CP session check box, do not select.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 5: Configuring the 802.2 Template (Port Definition)
Next topic: Step 7: Configuring the 802.2 Template (Link Definition)


Step 7: Configuring the 802.2 Template (Link Definition)

Select the 802.2 template by clicking on the tab labeled 802.2.

  1. Enter the Remote MAC Address, the 12 digit hexadecimal adapter address of the network controller attached to the remote host system. This should be obtained from the network administrator of the host system.
  2. Select the Remote SAP, allow this field to default to 4.
  3. Select the Address format, select the format which corresponds to type of adapter installed in the network controller attached to the remote host system. This is likely to be Tokenring but could be Ethernet.
  4. Enter the Test Timeout and Retry, these values determine the time waited (in seconds) for the remote node to respond to a test frame and the number of times a test frame is transmitted if no response is received. A test frame is sent when you attempt to establish the SNA connection with the host. If you find that the connection fails to activate or fails to activate on an intermittent basis increase these values (defaults are 6 and 6).
  5. Enter the XID Timeout and Retry, these values determine the time waited (in seconds) for the remote node to respond to an XID frame and the number of times an XID frame is transmitted if no response is received. A NULL XID frame is sent following the response to a test frame when you attempt to establish the SNA connection with the host. If you find that the connection fails to activate or fails to activate on an intermittent basis increase these values (defaults are 6 and 6).
  6. The configuration of the SNA LAN connection to the remote host is now complete. In the File menu select Save As and specify the name DEFAULT as the configuration file name.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 6: Link Definition
Next topic: Step 8: Configuring a 3270 LU for Terminal Emulation


Step 8: Configuring a 3270 LU for Terminal Emulation

Select 3270 from the Sections window and then click the Add button.

  1. Select the PU name, select the PU name associated with the Link to be used.
  2. Enter the LU name, this should match a dependent LU definition name for this PU as defined in VTAM. Dependent LUs are recognizable by the fact that the LOCADDR parameter of the LU definition is non-zero (LUs with a LOCADDR value of zero are Independent LUs used for APPC.
  3. Specify the NAU address, this should match the value of the LOCADDR parameter of the dependent LU as defined in VTAM.
  4. Leave the Pool Name blank.
  5. Select Priority, Allow this field to default to High.
  6. Select LU Type, allow this field to default to Unknown.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 7: Configuring the 802.2 Template (Link Definition)
Next topic: Step 9: Configuring LU's for APPC


Step 9: Configuring LU's for APPC

Before attempting to communicate using CCIAPPC you must define the local and remote LUs which will be used to communicate over the SNA connection you have configured. In this section we will describe the configuration of Independent LUs to be used to communicate over the host connection configured in section 1. When communicating with Host systems running VTAM (or NCP) the Remote LU is known as the APPLID (pronounced 'apple-id').

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 8: Configuring a 3270 LU for Terminal Emulation
Next topic: Step 10: Configuring the Local LU


Step 10: Configuring the Local LU

Select Local LU (LU 6.2) from the Sections window and then click the Add button.

  1. Enter the Local LU Name as defined in the list of LUs defined for this PU in VTAM on the host system.
  2. Enter the LU Alias, duplicate the LU name.
  3. Enter the NAU address, this value should correspond to the value of the LOCADDR parameter of this LU definition in VTAM on the host system. For independent LUs this value should be zero, whereas dependent LUs have a non-zero address.
  4. Select the PU Name, choose the PU Name associated with the Link to be used.
  5. Session limit For independent LUs specify the maximum number of parallel sessions which will be supported. Set the Session limit according to the number of CCIAPPC clients which are to communicate using this Local LU name. If the clients all specify the same LU Name in the machinename parameter of CCI-INITCLIENT (or the /MA parameter in FHREDIR.CFG for Fileshare clients) then the session limit should reflect this number of clients. If a different Local LU name is specified for each client, meaning that multiple Local LUs will need to be defined the session limit can remain at 1. Hence, a value of 8 is recommended for flexibility. Dependent LUs must have a maximum session limit of 1, that is, they are single session only.
  6. Repeat this section until all required Local LUs have been added.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 9: Configuring LU's for APPC
Next topic: Step 11: Configuring the Remote LU


Step 11: Configuring the Remote LU

Select Partner LU (LU 6.2) from the Sections window and then click the Add button.

  1. Enter the Network ID, the network name for SNA network which includes the host system as defined in VTAM on the host system. This should be obtained from the network administrator of the host system.
  2. Enter the LU Name, the name of the VTAM APPL ID on the host system which is specified by the CCIAPPC server in the publicname parameter (or in the /S parameter of the Fileshare Server).
  3. Enter the PLU Alias, duplicate the LU Name.
  4. Enter the Maximum logical record size, allow this field to default to 32767.
  5. PLU unqualified name, leave blank.
  6. You do not need to enter any information in the MPTN area or the Owning control point area.
  7. Leave Protocol preference to default to Use Node Default.
  8. Leave Domain Name or IP address blank.
  9. Leave Owning Control Point parameters, Network ID and CP name blank.
  10. Conversion security verification check box, leave unselected.
  11. Parallel session support check box, leave selected.
  12. Repeat this section until all required Partner LUs have been added.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 10: Configuring the Local LU
Next topic: Step 12: Adjacent Link Definition


Step 12: Adjacent Link Definition

Select Adjacent Link from the Sections window and then click the Add button.

  1. Enter the Network ID, enter the network name for SNA network which includes the host system as defined in VTAM on the host system. This should be obtained from the network administrator of the host system.
  2. Enter the CP name, enter the PU name of the host system as defined in VTAM on the host system. This should be obtained from the network administrator of the host system.
  3. Enter the Partner LU names to be associated with the host system (up to 8 names, separated by commas). Specify the Partner LUs, also known as APPLIDs defined in VTAM on the host system, which will be used by Fileshare servers running on the host system.
  4. Use as a wildcard check box, leave this unselected.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 11: Configuring the Remote LU
Next topic: Step 13: Configuring Session Limits - Defining a Mode


Step 13: Configuring Session Limits - Defining a Mode

A Mode is used to define the attributes of sessions used between a Local LU and a Remote LU.

If the default mode #INTER is not appropriate (because its settings are incompatible with the modes defined on the host system for the Remote LU, or perhaps because a larger number of sessions is required) then a new mode can be defined.

CCIAPPC uses a single APPC session for each CCI session between the client and the server (e.g. between the MFA client and Fileshare running on a mainframe). When CCIAPPC establishes a connection between the client and server the attributes of the Mode determine, amongst other things, the number of CCI sessions available between the Local LU and the Remote LU (APPLID in VTAM). Hence the Mode determines how many client sessions can be established using the same Local LU - Remote LU pairing.

The Maximum Session Limit and the Minimum Contention Winners values together determine how many sessions can be established by the Local LU (see below).

For example: if 10 client sessions are required, all using the same Local LU then the Mode session attributes might be:

Session Limits:
Maximum = 20
Minimum contention winners = 15

Alternatively the same number of client sessions could be attained by using multiple Local LUs with the client sessions divided between these LUs.

Important:

When a connection is established between a Local LU and a Remote LU the Mode characteristics are negotiated. This means that it is possible that the partner system (e.g. mainframe) will reduce the session limits to values which it can support. This may mean that fewer client sessions than expected will be supported. Hence it is important that the Mode characteristics, as defined for both the Local and Remote LUs, are compatible.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 12: Adjacent Link Definition
Next topic: Step 14: Enabling CCIAPPC to Find the Local LU


Step 14: Enabling CCIAPPC to Find the Local LU

This is a very important topic and without following the instructions below you will fail to establish a CCI session with CCIAPPC. If the CCI-INITCLIENT call returns CCI error 9 and CCI_GETERROR returns the message "Transport failure, the client could not make a connection" it is likely that these instructions have not been implemented. When CCIAPPC attempts to allocate an LU 6.2 session with the remote system it must specify the Remote LU name which it requires a session with. This is the Remote LU name specified in the CCI Servername parameter (e.g. the /S parameter in FHREDIR.CFG). However, APPC needs to know the Local LU name as well as the Remote LU name when attempting to establish a session between the LUs. To enable APPC to retrieve the Local LU name to use when attempting to allocate APPC sessions set the APPCLLU environment variable to the Local LU Name prior to starting the CCAPPC client.

For Example:

SET APPCLLU=NBTRN1L0;

This can be done in the Cobol MFENV environment file.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 13: Configuring Session Limits - Defining a Mode
Next topic: Step 15: Updating the System Path


Step 15: Updating the System Path

Before EXTRA can be used with CCIAPPC the system path must be updated so that the required EXTRA runtime DLLs can be found by CCIAPPC. CCIAPPC on 32 Bit Windows uses the WCPIC32.DLL from the EXTRA product to provide CPI-C APPC support.

Use one of the following methods to update the path:

  • Add the EXTRA directory to the path in the Environment section of the System settings in the Windows NT Control Panel.

This takes effect immediately, applications subsequently started will have the correct path setting.

  • Add the EXTRA directory to the path in the autoexec.bat in Windows 95.

Restart Windows 95 to adopt the new path setting.

  • Add the EXTRA directory to the path setting in the COBOL MFENV environment file.

The new path will now be set when MFENV is used to set the environment for Cobol.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 14: Enabling CCIAPPC to Find the Local LU
Next topic: Step 16: Activating the Configuration


Step 16: Activating the Configuration

Once the settings described above have been made the configuration must be saved before starting the EXTRA APPN Node. In the File menu, click Save and then exit the APPN Configurator. From the EXTRA! Personal Client 32 Bit program folder start the Start APPN Node program. This should start successfully without generating any error messages.

Once the Node has successfully started without generating any error messages start the Node Manager from the EXTRA! Personal Client 32 Bit program folder.

  1. Select the DLC icon in the toolbar (green adapter card) and select Start to start the Data Link Control (DLC). Once the DLC has started successfully the DLC Status should display active.
  2. Select the Link icon in the toolbar (linked circles), select the link name to start and select Start to start the link. Once the link has started successfully the Status should display Active.

Once the Link is active CCIAPPC can be used with this connection to the host system.

If an error message is generated at any stage see the section Error Reporting and Diagnostics for information on determining how to correct the error.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 15: Updating the System Path
Next topic: Error Reporting and Diagnostics


Error Reporting and Diagnostics

  • APPN Node activation errors

    Configuration errors are detected when the APPN Node is started and error messages are displayed in the Node Events window of the APPN Node Information dialog box. These configuration errors must be corrected before attempting to use CCIAPPC with EXTRA! Personal Client.

  • Fileshare Error Reporting

    Fileshare clients log messages returned from CCI in both the fhredir.msg and fhneterr.log files in the current directory. For Example:e.g. an entry from fhredir.cfg CCI: 970116 15183855 0009 07 CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined Column 2 and 3 gives the date and time stamp of the error. Column 4 (in this case 0009) gives the CCI error code Column 6 gives the CCI error message returned by CCI-GETERROR.

  • Attachmate EXTRA! Status App

    The Audit Log function of the Status App displays information on significant events and error messages and should be checked if problems are experienced.

    The API Trace function of the Status App can be used to provide tracing of CPI-C api calls made by CCIAPPC.

    • When in the API Trace window select Settings from the Options menu item.
    • In the API Trace Options dialog box select the CPI-C checkbox.
    • Select Record from the Options menu to start tracing.
    • Select Stop from the Options menu to stop tracing.

    Trace entries can be selected and expanded by double-clicking. This then displays parameters and return codes, etc. Trace files can be saved by selecting the Save/Save as options from the File menu.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Step 16: Activating the Configuration
Next topic: Known Problems


Known Problems

  • Mainframe Access (MFA) hangs when communicating with the host system using Attachmate EXTRA! Personal Client

    Problems have been experienced whereby MFA hangs when drag-and-drop or Record Level IO (RLIO) operations are attempted to the host system using Extra! Personal Client. In these circumstances MFA must be terminated and restarted. This issue has been raised with Attachmate and the cause of the problem has been diagnosed. Watch this space for news on the availability of a patch from Attachmate for this problem.

  • CCIAPPC reports response errors due to connection failures

    If CCIAPPC is used over a LAN (802.2) connection which uses routers to reach the host system intermittent connection failures may be experienced. If packet sizes of the APPC traffic are larger than the maximum packet size allowed by the router then the larger APPC packets will be discarded resulting in a connection failure. This could also cause problems in activating a connection with the host system.

    The solution to this problem is to reduce the Basic Transmission Unit (BTU) size of the APPC traffic so that it is less than or equal to the maximum packet size allowed by the router. This is achieved by reducing the BTU parameter on the Link definition using the APPN Configurator.

    You should check with the Network Administrator to determine the maximum packet size allowed by the router. If in doubt, we suggest that the BTU be reduced to 521 bytes which is usually well below the limit imposed by the router.

Parent topic: Attachmate Personal Client v6.3
Previous topic: Error Reporting and Diagnostics


Attachmate Personal Client v6.1 and v6.2

  1. Installing DLC for Windows 95
  2. Installing Attachmate Personal Client
  3. Configuring Attachmate Personal Client
  4. Step 1: Creating a New Configuration
  5. Step 2: Local Node Definition
  6. Step 3: Data Link Control Definition
  7. Step 4: Configuring the NCIA Template (Data Link Control)
  8. Step 5: Port Definition
  9. Step 6: Configuring the 802.2/NCIA Template (Port Definition)
  10. Step 7: Link Definition
  11. Step 8: Configuring the 802.2/NCIA Template (Link Definition)
  12. Step 9: Configuring a 3270 LU Pool
  13. Step 10: Configuring LU's for APPC
  14. Step 11: Configuring the Local LU
  15. Step 12: Configuring the Remote LU
  16. Step 13: Adjacent Link Definition
  17. Step 14: Enabling CCIAPPC to Find the Local LU
  18. Step 15: Updating the System Path
  19. Step 16: Activating the Configuration
  20. Error Reporting and Diagnostics
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT
Important Bulletin Regarding Support For Attachmate EXTRA! Personal Client


Installing Attachmate Personal Client

You should have already installed Attachmate Personal Client. We suggest that you confirm that the CPI-C interface is installed before continuing, the 3270 display portion of this product will be fully functional without CPI-C, but CCIAPPC will not be able to access APPC.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Installing DLC for Windows 95
Next topic: Configuring Attachmate Personal Client


Configuring Attachmate Personal Client

After successfully installing the Attachmate Personal Client product, you can start to configure your APPC connection. You should have a VTAM definition of the connection you are attempting to configure available to you during the configuration. Select Start from the Taskbar, then Programs, then EXTRA! Personal Client 32-bit, then APPN Configurator. The APPN Configurator window will be displayed. A sample window with a full configuration is displayed below for reference.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Installing Attachmate Personal Client
Next topic: Step 1: Creating a New Configuration


Step 1: Creating a New Configuration

The first screen presented in the configuration tool allows you to enter a new configuration by choosing File from the action bar and selecting New to create a new configuration.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Configuring Attachmate Personal Client
Next topic: Step 2: Local Node Definition


Step 2: Local Node Definition

Select Node Definition from the Sections window and then click the Add button. The Local Node Configuration window will appear.

  1. Enter the Network ID for this SNA network. This should be obtained from the network administrator of the host system.
  2. Enter the Control Point (CP) name assigned to this machine. This should be obtained from the network administrator of the host system. The CP Name should match the Physical Unit (PU) name assigned to this machine as specified in the PU definition in VTAM for this machine.
  3. Enter the CP Alias, This should duplicate the CP Name.
  4. Enter the Default Node ID (Block ID, PU ID) This is the 8 digit hexadecimal number which is used to identify this local system on the SNA network.. The first 3 digits is the block (IDBLK) number followed by the last 5 digits of the node (IDNUM) number. These numbers usually correspond with the IDBLK and IDNUM fields of the PU definition for this machine as defined in VTAM on the host system, however EXTRA requires that the PU ID be set to FFFFF.
  5. The Maximum locates and Locate timeout parameters can be left to the default values.
  6. The Start attach manager check box should be unselected. This does not need to be selected if only running CCIAPPC clients (e.g. Fileshare clients). The attach manager is only needed for incoming APPC requests, for example if running CCIAPPC servers.
  7. The Request discontact check box can be left unselected.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 1: Creating a New Configuration
Next topic: Step 3: Data Link Control Definition


Step 3: Data Link Control Definition

Select Data Link Control from the Sections window and then click the Add button. The Data Link Control Window will appear.

  1. Enter the DLC Name, a name to describe the DLC definition which will be unique within this node. For example, LANDLC since this is going to be a LAN connection.
  2. Enter the DLC Type, select Network (802.2) for a LAN connection. If an SDLC or COAX connection is required the corresponding option would be selected here.
  3. You may skip over the SDLC specific entry fields.
  4. In the 802.2 and NCIA specific entry fields enter the adapter number which will be used for this connection in Board number. If there is only one network adapter configured in this machine then select 0. To determine the network adapters installed double-click the Network icon in the Control Panel. The adapters are listed in ascending adapter number starting at zero.
  5. Select the appropriate Adapter type for the LAN network adapter, either Tokenring or Ethernet.
  6. You may allow the Buffer size in kilobytes to default to 64.
  7. You may skip over the Twinax specific fields.
  8. The Negotiable links check box should already be selected by default.
  9. The Activate on startup checkbox, we suggest initially be left unselected so that the DLC is tested by starting manually. Once this is tested this option can then be selected.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 2: Local Node Definition
Next topic: Step 4: Configuring the NCIA Template (Data Link Control)


Step 4: Configuring the NCIA Template (Data Link Control)

Select the NCIA template by clicking on the tab labeled NCIA.

  1. Enter the Workstation MAC Address as 00000000000. It is not necessary to provide the MAC address in most installations.
  2. Allow Ring to default to 0.
  3. Allow Bridge to default to 0.
  4. It is not necessary to enter any information under MPTN for this configuration.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 3: Data Link Control Definition
Next topic: Step 5: Port Definition


Step 5: Port Definition

Select Port from the Sections window and then click the Add button. The Port Window will appear.

  1. Enter the Port Name to describe the Port definition which will be unique within this node. For example, LANPORT since this is going to be a LAN connection.
  2. Select the Port Type, select SATF (shared access transport facility), the appropriate choice for a LAN connection. Note: select Switched for SDLC over a dialup line, Nonswitched for leased line SLDC or DFT.
  3. Enter the BTU size, select the maximum size of packet that the port can receive without segmentation. You must specify a value that is less than or equal to the value of the MAXDATA parameter of the PU definition in VTAM for this machine. For a 4 Mbs Token Ring specify a BTU value of 4195 or less. For a 16 Mbs Token Ring specify a value of 16393 or less. For an Ethernet LAN specify a BTU value of 1493 or less.
  4. Select the DLC section name, the definition to associate with this port, that is, the DLC definition configured above.
  5. Select Link station role, choose the default, Negotiable.
  6. Select Transmit/receive capability, choose the default, Half.
  7. Enter Target pacing count, allow this field to default to 7.
  8. Enter Maximum I-frames received, allow this field to default to 7.
  9. You may leave the TG characteristics section name blank.
  10. Enter Active Links. These parameters define the maximum number of connections or links which can be active using this port. This will define the maximum number of SNA connections to other nodes using this port, i.e. how many mainframes or peer systems you want to connect to using this port. We suggest you set both the Inbound and Outbound parameters to 2.
  11. The Implicit limited resource check box should be unselected.
  12. The Implicit CP-CP session check box should default to selected.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 4: Configuring the NCIA Template (Data Link Control)
Next topic: Step 6: Configuring the 802.2/NCIA Template (Port Definition)


Step 6: Configuring the 802.2/NCIA Template (Port Definition)

Select the 802.2/NCIA template by clicking on the tab labeled 802.2/NCIA.

  1. Enter the Local SAP, allow this field to default to 4.
  2. Enter Test Timeout and Retry, these values determine the time waited (in milliseconds) for the remote node to respond to a test frame and the number of times a test frame is transmitted if no response is received. A test frame is sent when you attempt to establish the SNA connection with the host. If you find that the connection fails to activate or fails to activate on an intermittent basis increase these values (defaults are 10 and 6).
  3. Enter the XID Timeout and Retry, these values determine the time waited (in milliseconds) for the remote node to respond to an XID frame and the number of times an XID frame is transmitted if no response is received. A NULL XID frame is sent following the response to a test frame when you attempt to establish the SNA connection with the host. If you find that the connection fails to activate or fails to activate on an intermittent basis increase these values (defaults are 10 and 6).
  4. It is not necessary to enter any information under SDLC or DFT for this configuration.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 5: Port Definition
Next topic: Step 7: Link Definition


Step 7: Link Definition

Select Link from the Sections window and then click the Add button.

  1. Enter the Link Name, enter a name to describe the Link definition which will be unique within this node. For example, use a name which will describe the remote node, i.e. the host system, which this Link is used to communicate with.
  2. Select Adjacent CP type, select Learn.
  3. Select Port section name, select the Port definition to associate with this Link, that is, the Port definition configured above.
  4. Enter PU Name, enter a name which will act as an internal PU name which will be uniquely associated with this Link. For example duplicate the Link Name for the PU Name.
  5. Enter Adjacent net ID, leave this field blank.
  6. Enter Adjacent CP name, leave blank.
  7. Enter the Block ID, PU ID, this is the 8 digit hexadecimal number which is used to identify this local system on the SNA network.. The first 3 digits is the block (IDBLK) number followed by the last 5 digits of the node (IDNUM) number. These numbers correspond with the IDBLK and IDNUM fields of the PU definition for this machine as defined in VTAM on the host system.
  8. Select Back level XID, choose the default, No.
  9. Enter Target pacing count, allow this field to default to 7.
  10. Enter Maximum send BTU size, select the maximum size of packet than the Link can send without segmentation. You must specify a value that is less than or equal to the value of the MAXDATA parameter of the PU definition in VTAM for this machine. For a 4 Mbs Token Ring specify a BTU value of 4195 or less. For a 16 Mbs Token Ring specify a value of 16393 or less. For an Ethernet LAN specify a BTU value of 1493 or less.
  11. Select Default TG chars check box.
  12. TG characteristics, leave blank.
  13. Activate on startup check box, we suggest that initially this be left unselected so that the Link is tested by starting manually. Once this is tested this option can then be selected.
  14. Limited resource check box, do not select.
  15. Select Host connection check box.
  16. CP-CP session check box, do not select.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 6: Configuring the 802.2/NCIA Template (Port Definition)
Next topic: Step 8: Configuring the 802.2/NCIA Template (Link Definition)


Step 8: Configuring the 802.2/NCIA Template (Link Definition)

Select the 802.2/NCIA template by clicking on the tab labeled 802.2/NCIA.

  1. Enter the Remote Network Address, the 12 digit hexadecimal adapter address of the network controller attached to the remote host system. This should be obtained from the network administrator of the host system.
  2. Select the Remote SAP, allow this field to default to 4.
  3. Select the Address format, select the format which corresponds to type of adapter installed in the network controller attached to the remote host system. This is likely to be Tokenring but could be Ethernet.
  4. Enter the Test Timeout and Retry, these values determine the time waited (in milliseconds) for the remote node to respond to a test frame and the number of times a test frame is transmitted if no response is received. A test frame is sent when you attempt to establish the SNA connection with the host. If you find that the connection fails to activate or fails to activate on an intermittent basis increase these values (defaults are 1000 and 1).
  5. Enter the XID Timeout and Retry, these values determine the time waited (in milliseconds) for the remote node to respond to an XID frame and the number of times an XID frame is transmitted if no response is received. A NULL XID frame is sent following the response to a test frame when you attempt to establish the SNA connection with the host. If you find that the connection fails to activate or fails to activate on an intermittent basis increase these values (defaults are 1000 and 1).
  6. Router's TCP/IP Address, leave blank.
  7. Virtual Ring, leave blank.
  8. Local Ack leave unselected.
  9. It is not necessary to enter any information under SDLC for this configuration.
  10. The configuration of the SNA LAN connection to the remote host is now complete. In the File menu select Save As and specify the name DEFAULT as the configuration file name.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 7: Link Definition
Next topic: Step 9: Configuring a 3270 LU Pool


Step 9: Configuring a 3270 LU Pool

Select 3270 LU Pool from the Sections window and then click the Add button.

  1. Select the PU name, select the PU name associated with the Link to be used.
  2. Enter the Base name, enter a name to describe the Base terminal name which will be unique within this node. For example, use a name such as, TERM.
  3. Enter a Pool name, enter a name to describe the 3270 LU Pool which will be unique within this node. For example, use a name such as, POOL1.
  4. Select Priority, Allow this field to default to High.
  5. Select LU Type, allow this field to default to Unknown.
  6. The Network address units may be left at their default values.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 8: Configuring the 802.2/NCIA Template (Link Definition)
Next topic: Step 10: Configuring LU's for APPC


Step 10: Configuring LU's for APPC

Before attempting to communicate using CCIAPPC you must define the local and remote LUs which will be used to communicate over the SNA connection you have configured. In this section we will describe the configuration of Independent LUs to be used to communicate over the host connection configured in section 1. When communicating with Host systems running VTAM (or NCP) the Remote LU is known as the APPLID (pronounced 'apple-id').

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 9: Configuring a 3270 LU Pool
Next topic: Step 11: Configuring the Local LU


Step 11: Configuring the Local LU

Select Local LU (LU 6.2) from the Sections window and then click the Add button.

  1. Enter the Local LU Name as defined in the list of LUs defined for this PU in VTAM on the host system.
  2. Enter the LU Alias, duplicate the LU name.
  3. Enter the NAU Address, this value should correspond to the value of the LOCADDR parameter of this LU definition in VTAM on the host system. For independent LUs this value should be zero, whereas dependent LUs have a non-zero address.
  4. Select the PU Name, choose the PU Name associated with the Link to be used.
  5. Session limit For independent LUs specify the maximum number of parallel sessions which will be supported. Set the Session limit according to the number of CCIAPPC clients which are to communicate using this Local LU name. If the clients all specify the same LU Name in the machinename parameter of CCI-INITCLIENT (or the /MA parameter in FHREDIR.CFG for Fileshare clients) then the session limit should reflect this number of clients. If a different Local LU name is specified for each client, meaning that multiple Local LUs will need to be defined the session limit can remain at 1. Hence, a value of 8 is recommended for flexibility. Dependent LUs must have a maximum session limit of 1, that is, they are single session only.
  6. Repeat this section until all required Local LUs have been added.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 10: Configuring LU's for APPC
Next topic: Step 12: Configuring the Remote LU


Step 12: Configuring the Remote LU

Select Partner LU (LU 6.2) from the Sections window and then click the Add button.

  1. Enter the Network ID, the network name for SNA network which includes the host system as defined in VTAM on the host system. This should be obtained from the network administrator of the host system.
  2. Enter the LU Name, the name of the VTAM APPL ID on the host system which is specified by the CCIAPPC server in the publicname parameter (or in the /S parameter of the Fileshare Server).
  3. Enter the PLU Alias, duplicate the LU Name.
  4. Enter the Maximum logical record size, allow this field to default to 32767.
  5. PLU unqualified name, leave blank.
  6. You do not need to enter any information in the MPTN area or the Owning control point area.
  7. Conversion security verification check box, leave unselected.
  8. Parallel session support check box, leave default selected.
  9. Repeat this section until all required Partner LUs have been added.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 11: Configuring the Local LU
Next topic: Step 13: Adjacent Link Definition


Step 13: Adjacent Link Definition

Select Adjacent Link from the Sections window and then click the Add button.

  1. Enter the Network ID, enter the network name for SNA network which includes the host system as defined in VTAM on the host system. This should be obtained from the network administrator of the host system.
  2. Enter the CP name, enter the PU name of the host system as defined in VTAM on the host system. This should be obtained from the network administrator of the host system.
  3. Enter the Partner LU names to be associated with the host system (up to 8 names, separated by commas). Specify the Partner LUs, also known as APPLIDs defined in VTAM on the host system, which will be used by Fileshare servers running on the host system.
  4. Use as a wildcard check box, leave this unselected.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 12: Configuring the Remote LU
Next topic: Step 14: Enabling CCIAPPC to Find the Local LU


Step 14: Enabling CCIAPPC to Find the Local LU

This is a very important topic and without following the instructions below you will fail to establish a CCI session with CCIAPPC. If the CCI-INITCLIENT call returns CCI error 9 and CCI_GETERROR returns the message "Transport failure, the client could not make a connection" it is likely that these instructions have not been implemented. When CCIAPPC attempts to allocate an LU 6.2 session with the remote system it must specify the Remote LU name which it requires a session with. This is the Remote LU name specified in the CCI Servername parameter (e.g. the /S parameter in FHREDIR.CFG). However, APPC needs to know the Local LU name as well as the Remote LU name when attempting to establish a session between the LUs. To enable APPC to retrieve the Local LU name to use when attempting to allocate APPC sessions set the APPCLLU environment variable to the Local LU Name prior to starting the CCAPPC client.

For Example:

SET APPCLLU=CCILLU01;
Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 13: Adjacent Link Definition
Next topic: Step 15: Updating the System Path


Step 15: Updating the System Path

Before EXTRA can be used with CCIAPPC the system path must be updated so that the required EXTRA runtime DLLs can be found by CCIAPPC. CCIAPPC on 32 Bit Windows uses the WCPIC32.DLL from the EXTRA product to provide CPI-C APPC support.

Use one of the following methods to update the path:

  • Add the EXTRA directory to the path in the Environment section of the System settings in the Windows NT Control Panel.

This takes effect immediately, applications subsequently started will have the correct path setting.

  • Add the EXTRA directory to the path in the autoexec.bat in Windows 95.

Restart Windows 95 to adopt the new path setting.

  • Add the EXTRA directory to the path setting in the Cobol MFENV environment file.

The new path will now be set when MFENV is used to set the environment for Cobol.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 14: Enabling CCIAPPC to Find the Local LU
Next topic: Step 16: Activating the Configuration


Step 16: Activating the Configuration

Once the settings described above have been made the configuration must be saved before starting the EXTRA APPN Node. In the File menu select Save and then exit the APPN Configurator. From the EXTRA! Personal Client 32 Bit program folder start the Start APPN Node program. This should start successfully without generating any error messages.

Once the Node has successfully started without generating any error messages start the Node Manager from the EXTRA! Personal Client 32 Bit program folder.

  1. Select the DLC icon in the toolbar (green adapter card) and select Start to start the Data Link Control (DLC). Once the DLC has started successfully the DLC Status should display active.
  2. Select the Link icon in the toolbar (linked circles), select the link name to start and select Start to start the link. Once the link has started successfully the Status should display Active.

Once the Link is active CCIAPPC can be used with this connection to the host system.

If an error message is generated at any stage see the section Error Reporting and Diagnostics for information on determining how to correct the error.

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 15: Updating the System Path
Next topic: Error Reporting and Diagnostics


Error Reporting and Diagnostics

Fileshare Error Reporting - Fileshare clients log messages returned from CCI in both the fhredir.msg and fhneterr.log files in the current directory. For example, an entry from fhredir.cfg CCI: 970116 15183855 0009 07 CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined Column 2 and 3 gives the date and time stamp of the error. Column 4 (in this case 0009) gives the CCI error code Column 6 gives the CCI error message returned by CCI-GETERROR

Parent topic: Attachmate Personal Client v6.1 and v6.2
Previous topic: Step 16: Activating the Configuration


IBM Communications Server v5.01 for Windows NT

  • Installing IBM Communications Server
  • Installing IBM LLC2 Protocol for Windows NT
  • Configuring IBM Communications Server
  • Configuring the Node
  • Step 1: Node Setup
  • Step 2: Device Configuration
  • Step 3: Connection Configuration
  • Step 4: Enable API Client Support (Configure the Gateway)
  • Step 5: Local LU Configuration
  • Step 6: Partner LU 6.2 Configuration
  • Step 7: Configuring Modes (Optional)
  • Configuring the IBM Communications Server SNA Client
  • Enabling CCIAPPC to Find the Local LU
  • Activating the Configuration
  • Testing the Configuration
  • Error Reporting and Diagnostics
  • Known Problems
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


Installing IBM Communications Server

This documentation assumes that you have already installed IBM Communications Server. In addition you should have opted to install the IBM LLC2 protocol during the installation of IBM Communications Server.

Parent topic: IBM Communications Server v5.01 for Windows NT


Installing IBM LLC2 Protocol for Windows NT

IBM Communications Server requires the IBM LLC2 protocol to provide support for a connection over 802.2. Towards the end of the installation of IBM Communications Server you will be prompted to choose whether to automatically install the IBM LLC2 protocol for use with IBM Communications Server over a LAN. Unless you have installed LLC2 previously you must opt to install LLC2 if you intend to configure connections over 802.2.

Parent topic: IBM Communications Server v5.01 for Windows NT


Configuring IBM Communications Server

After successfully installing the Communications Server product, you can start to configure your APPC connection. You should have a VTAM definition of the connection you are attempting to configure available to you during the configuration.

From the IBM Communications Server program folder, start the SNA Node Configuration program.

Parent topic: IBM Communications Server v5.01 for Windows NT


Configuring the Node

  1. In the File menu select New to create a new Node configuration.
  2. In the Scenarios menu select SNA API Clients running APPC applications.

The Configuration Steps window describes the configuration steps you will complete. Note that for CCIAPPC configuration step 7. Configure Modes is optional and that step 8. Transaction program configuration is not required.

Parent topic: IBM Communications Server v5.01 for Windows NT


Step 1: Node Setup

From the Configuration options listbox select Configure Node and then select New.

  • Basic Settings
  • Advanced Settings
  • DLU Requester Settings
Parent topic: IBM Communications Server v5.01 for Windows NT


Basic Settings

  1. In the Fully Qualified CP name enter the Network Name for this SNA network in the first box. This should be obtained from the network administrator of the host system. In the second box following the period enter the Control Point (CP) name assigned to this machine. This should be obtained from the network administrator of the host system. The CP Name should match the Physical Unit (PU) name assigned to this machine as specified in the PU definition in VTAM for this machine.
  2. Enter the 8 digit hexadecimal Local Node ID which is used to identify this local system on the SNA network. The first 3 digits is the Block ID (IDBLK) number followed by the last 5 digits of the Physical Unit ID (IDNUM) (also known as the Node number). These numbers must correspond with the IDBLK and IDNUM fields of the PU definition for this machine as defined in VTAM on the host system.
  3. Set the Node Type to End Node.

Parent topic: Step 1: Node Setup


Advanced Settings

These can be left to their default settings

Parent topic: Step 1: Node Setup


DLU Requester Settings

These can be left to their default settings

Select OK to complete the Node configuration.

Parent topic: Step 1: Node Setup


Step 2: Device Configuration

From the Configuration options listbox select Configure Devices. Then from the DLCs list box select LAN and then select New.

  • Basic Settings
  • Advanced Settings
  • Performance Settings
Parent topic: IBM Communications Server v5.01 for Windows NT


Basic Settings

  1. From the Adapter number pulldown select the LAN adapter which will be used for the SNA connection to the host system.
  2. Leave the Local SAP setting to default to 04.

Parent topic: Step 2: Device Configuration


Advanced Settings

These can be left to their default settings

Parent topic: Step 2: Device Configuration


Performance Settings

These can be left to their default settings

Select OK to complete the Device configuration.

Parent topic: Step 2: Device Configuration


Step 3: Connection Configuration

From the Configuration options listbox select Configure connections and then select New.

  • Basic Settings
  • Advanced Settings
  • Security Settings
Parent topic: IBM Communications Server v5.01 for Windows NT


Basic Settings

  1. Enter a name for the connection in the Link station name. This must be up to 8 characters long and will describe the connection, e.g. the destination of the connection.
  2. From the Device name pulldown select the LAN Device name configured previously in step 2.
  3. Enter the 12 digit hexadecimal Destination address of the network controller attached to the remote host system. This should be obtained from the network administrator of the host system.
  4. Unless directed otherwise, leave the Remote SAP to default to 04.

Parent topic: Step 3: Connection Configuration


Advanced Settings

  1. Select Activate link at start to automatically activate the connection when the Node is started.
  2. Select APPN support.
  3. Leave HPR Support, Auto-activate support, Link to preferred NN server and Solicit SSCP sessions unselected.
  4. Enter the 8 digit hexadecimal Local Node ID which is used to identify this local system on the SNA network. This should be the same as the Local Node ID specified when configuring the Node in step 1 previously.

Parent topic: Step 3: Connection Configuration


Security Settings

  1. Enter the fully qualified Control Point name of the Host system in the Adjacent CP name. Enter the Network Name for this SNA network in the first box. This should be obtained from the network administrator of the host system. In the second box following the period enter the Control Point (CP) name assigned to the remote Host machine. This should be obtained from the network administrator of the host system.
  2. From the Adjacent CP type pulldown select APPN Node.
  3. Leave the TG number to default to 0.

Select OK to complete the Connection configuration.

Parent topic: Step 3: Connection Configuration


Step 4: Enable API Client Support (Configure the Gateway)

From the Configuration options list box select Configure the Gateway and then select View/Change/Add.

  • SNA Clients Settings
Parent topic: IBM Communications Server v5.01 for Windows NT


SNA Clients Settings

  1. Ensure that the Enable SNA API Client Services checkbox is selected.
  2. The Default pool for SNA API Client Services can be left to default to None.

Select OK to complete the Gateway configuration.

Before attempting to communicate using CCIAPPC you must define the local and remote LUs which will be used to communicate over the SNA connection you have configured. In this section we will describe the configuration of Independent LUs to be used to communicate over the host connection. When communicating with Host systems running VTAM (or NCP) the Remote LU is known as the APPLID (pronounced 'apple-eye-dee').

Parent topic: Step 4: Enable API Client Support (Configure the Gateway)


Step 5: Local LU Configuration

From the Configuration options list box select Configure Local LU 6.2 and then select New.

  1. For the Local LU name specify the LU name as defined in the list of LUs defined for this PU in VTAM on the host system.
  2. Select SNA API client use.
  3. Leave Dependent LU unselected.
  4. For the Local LU alias enter the same Local LU name.
  5. Leave the LU session limit to default to 0.

Select OK to complete the Local LU configuration.

Parent topic: IBM Communications Server v5.01 for Windows NT


Step 6: Partner LU 6.2 Configuration

From the Configuration options list box select Configure Partner LU 6.2 and then select New.

Unlike Local LUs, Remote LUs are assigned to a connection which will be used to communicate with it.

  • Basic Settings
  • Advanced Settings
  • Configuring Session Limits: Defining a Mode
Parent topic: IBM Communications Server v5.01 for Windows NT


Basic Settings

  1. Enter the fully qualified Partner LU Name.

This LU Name should match the definition of the LU as it exists on the remote system, in this case in the form of a VTAM APPL definition on the host system.

Enter the Network Name for this SNA network in the first box. This should be obtained from the network administrator of the host system. In the second box following the period enter the name of the APPL on the remote Host machine. This should be obtained from the network administrator of the host system.

  • Leave Wildcard unselected.
  • For the Partner LU alias enter the Partner LU name (i.e. APPL name).
  • Enter the Fully qualified CP name of the Host system on which the partner LU resides.

This is the same as the fully qualified CP name entered in the Security settings of the Connection configured previously in step 3.

Setting this correctly will enable the Server to determine which connection to use to locate a partner LU when establishing a session with a Local LU.

Parent topic: Step 6: Partner LU 6.2 Configuration


Advanced Settings

  1. Leave the Maximum LL record sixe to default to 32767.
  2. Selecting Conversation security support will have no effect since this is not supported by CCIAPPC.
  3. Ensure that the Parallel session support is selected.

Select OK to complete the Partner LU configuration.

Parent topic: Step 6: Partner LU 6.2 Configuration


Configuring Session Limits: Defining a Mode

A Mode is used to define the attributes of sessions used between a Local LU and a Remote LU.

If the default mode #INTER is not appropriate (because its settings are incompatible with the modes defined on the host system for the Remote LU, or perhaps because a larger number of sessions is required) then a new mode can be defined.

CCIAPPC uses a single APPC session for each CCI session between the client and the server (e.g. between the MFA client and Fileshare running on a mainframe). When CCIAPPC establishes a connection between the client and server the attributes of the Mode determine, amongst other things, the number of CCI sessions available between the Local LU and the Remote LU (APPLID in VTAM). Hence the Mode determines how many client sessions can be established using the same Local LU - Remote LU pairing.

The PLU mode session limit and the Minimum contention winner sessions together determine how many sessions can be established by the Local LU (see below).

For example: if 10 client sessions are required, all using the same Local LU then the Mode session attributes might be:

PLU mode session limit = 20
Minimum contention winner sessions = 15

Alternatively the same number of client sessions could be attained by using multiple Local LUs with the client sessions divided between these LUs.

Important:

When a connection is established between a Local LU and a Remote LU the Mode characteristics are negotiated. This means that it is possible that the partner system (e.g. mainframe) will reduce the session limits to values which it can support. This may mean that fewer client sessions than expected will be supported. Hence it is important that the Mode characteristics, as defined for both the Local and Remote LUs, are compatible.

Parent topic: Step 6: Partner LU 6.2 Configuration


Step 7: Configuring Modes (Optional)

From the Configuration options list box select Configure Modes and then select New.

  • Basic Settings
  • Advanced Settings
Parent topic: IBM Communications Server v5.01 for Windows NT


Basic Settings

  1. Enter Mode Name, this should match the Mode Name as defined on the Host system in VTAM. This can be the default log mode specified by the DLOGMOD parameter of the VTAM Applid (APPL) definition.
  2. Enter the PLU mode session limit. This is the maximum number of sessions that can be established between the two LUs.
  3. Enter the number of Minimum contention winner sessions. This is the number of sessions that the Local LU can establish without needing the permission of the Remote LU.

This value cannot be greater than the PLU mode session limit.

Parent topic: Step 7: Configuring Modes (Optional)


Advanced Settings

  1. Leave Maximum negotiable session limit to default to 128.
  2. Leave Receive pacing window size to default to 1.
  3. Enter the number of Automatic activate sessions. This is the number of contention winner sessions to activate when the connection using this mode is started.
  4. From the Class of service name pulldown select #INTER. This is the default APPC class of service.
  5. Do not select Use cryptography or Use Compression support.
  6. Leave Use default RIU size selected.

If you are in doubt over these values check with the network administrator of the host system.

Select OK to complete the Mode configuration.

Parent topic: Step 7: Configuring Modes (Optional)


Configuring the IBM Communications Server SNA Client

The IBM Communications Server SNA Client (also known as the SNA API Client) runs on a client machine and communicates with the IBM Communications Server over the LAN using either TCP/IP or Novell SPX.

Having installed the IBM Communications Server SNA Client the following configuration is required.

  • Creating User IDs
  • Creating the SNA Client Configuration File
Parent topic: IBM Communications Server v5.01 for Windows NT


Creating User IDs

Clients are authorized to connect with the Communications Server by specifying a Windows NT Domain userid which is in the IBMCSAPI user group. You may want to define a unique userid for each client user or a single userid used by all users.

  1. On the NT Server, in the Administrative Tools program folder select User Manager.
  2. In the User menu select New User... and fill in the Username, Description, Password, etc. and select Add. Repeat this until all the required userids have been added.
  3. The group IBMCSAPI should have been created during the installation of IBM Communications Server. If is was not, select New Global Group... from the User menu. Enter Group Name IBMCSAPI and a description and select OK.
  4. In the Groups window double-click on IBMCSAPI and add the required userids from the Not Members window into the Members window. Select OK when all the required userids have been added to the group.
Parent topic: Configuring the IBM Communications Server SNA Client


Creating the SNA Client Configuration File

Start the Configuration program from the IBM Communications Server SNA Client program folder.

  1. In the Configuration Options window select Configure Global Data and then select New...
  2. Enter a a userid which is a member of the IBMCSAPI group.
  3. Enter and confirm the userid password.
  4. Select OK to complete the Global Data configuration.

  1. In the Configuration options window select Configure APPC Server List and then select New...
  2. In the first Servers edit box enter the name of the IBM Communications Server machine.

If the client will use TCP/IP to communicate with the Server the machine name should be the IP address of the Server machine or the TCP/IP hostname of the Server machine.

  • Select the Transport Type for this Server. This is either TCP (TCP/IP) or SPX (Novell Sequenced Packet Exchange).
  • Select OK to complete the APPC Server List configuration.

In the File menu select Save As... and save the configuration file as CSNTAPI.INI. Exit the SNA Client Configuration program.

Parent topic: Configuring the IBM Communications Server SNA Client


Enabling CCIAPPC to Find the Local LU

It is very important that the CCIAPPC module be able to determine the Local LU to use for communication with the Host application. You may have configured everything else correctly and all of your other APPC applications may work, but if you miss this final step you will fail to establish a CCI session with the host application. If the CCI-INITCLIENT call returns CCI error 9 and CCI_GETERROR returns the message "CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined" it is likely that you have failed to complete this final step. When CCIAPPC attempts to allocate an LU 6.2 session with the remote system it must specify the Remote LU name which it requires a session with. This is the Remote LU name specified in the CCI Servername parameter (e.g. the /S parameter in FHREDIR.CFG). However, APPC needs to know the Local LU name as well as the Remote LU name when attempting to establish a session between the LUs.

To enable APPC to retrieve the Local LU name to use when attempting to allocate APPC sessions set the APPCLLU environment variable to the Local LU Name prior to starting the CCIAPPC client. This must be done wherever the CCIAPPC client (e.g. MFA Drag and Drop) is run. If the CCIAPPC client communicates with the Server using the IBM Communications Server SNA Client then the APPCLLU environment variable must be set on each client machine. If the CCIAPPC client runs on the Server itself then the APPCLLU environment variable must be set on the Server machine.

For Example:

SET APPCLLU=CCILLU01
Parent topic: IBM Communications Server v5.01 for Windows NT


Activating the Configuration

Once the configuration has been verified as correct the Node can be started.

  1. In the IBM Communications Server program folder start the SNA Node Operations program.
  2. In the Operations menu select Start Node... or select the green Start Node icon in the task bar.
  3. Select the configuration to open and select Open.

Once the Node is active the underlying connections will activate if Activate link at start was defined for the connections.

Parent topic: IBM Communications Server v5.01 for Windows NT


Testing the Configuration

Once you have an active connection use the CNOS Initialize option in the Operations menu of the SNA Node Operations program to test the configuration. This will test the configuration by attempting to bind an LU 6.2 session between the Local LU and the Remote LU over the configured LAN connection.

  1. In the View menu of the SNA Node Operations program select LU 6.2 Sessions.
  2. In the Operations menu of the SNA Node Operations program select CNOS Initialize...
  3. Select the Local LU to be used from the Local LU 6.2 pulldown.
  4. Enter the fully qualified Partner LU name (as defined in step 6 previously). This is of the format:
     Network-Name.Partner-LU-Name
  5. Select the Mode to use. This may be a custom Mode you have defined or can be left to default to #INTER.
  6. Specify the characteristics of the Mode.
    • In Sessions specify the maximum number of sessions allowed by the Mode, this is PLU mode session limit defined for the Mode.
    • In Winners specify the number of Minimum Contention winners as defined for the mode.
    • Specify 0 in Losers for the number of Contention Losers.
    • Specify 1 in Activate to activate a single session as a test.
  7. Select OK to initiate the bind test.

    If the test is successful the session bound between the Local LU and Partner LU will appear in the LU 6.2 Sessions window of the SNA Node Operations program (in the View menu select Refresh to refresh the window). Sessions bound in this way can safely be terminated by selecting the Session Id, clicking the right mouse button and selecting Stop Abnormally.

    If the test fails an error will be reported in a dialog box. Use the IBM Communications Server Log File to help you diagnose the cause of failure (see the section Error Reporting and Diagnostics below).

Now you have tested the active connection it is ready for use with CCIAPPC.

Parent topic: IBM Communications Server v5.01 for Windows NT


Error Reporting and Diagnostics

  • Fileshare Error Reporting

    Fileshare clients log messages returned from CCI in both the fhredir.msg and fhneterr.log files in the current directory. For example an entry from fhredir.cfg CCI: 970116 15183855 0009 07 CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined Column 2 and 3 gives the date and time stamp of the error. Column 4 (in this case 0009) gives the CCI error code Column 6 gives the CCI error message returned by CCI-GETERROR.

  • Windows NT Event Log

    Events can be viewed using the Microsoft NT Event Viewer (in the Administrative Tools(Common) program folder). In the Event Viewer select Application from the Log menu. This will then display the Application Log. Events generated by the IBM Communications Server itself are prefixed with IBMCommServer. Events generated by interaction with clients use the prefix IBM SNA Client Services. Double-clicking on an event will show details of the event.

  • IBM Communications Server Log File (\IBMCS\PCWMSG.MLG)

    The Log file can be viewed by selecting Log Viewer from the Launch menu of the Node Operations program or by selecting Log Viewer from the IBM Communications Server program folder.

    Details of the selected message are shown at the bottom of the Log Viewer window. In addition, double-clicking on the message number will display an explanation of the message.

    Further useful diagnostic information can be obtained by interpreting the Sense Code returned with many errors using the Display SNA Sense Data utility in the IBM Communications Server program folder.

  • IBM Communications Server Trace Facility

    This can be used to provide tracing of CPI-C and APPC interface calls made by CCIAPPC.

    Start the Trace Facility program from the IBM Communications Server program folder or from the Launch menu of the SNA Node Operations program.

    1. Select Function Name APPN and APPC.
    2. Select Component Name CPI-C API and then select the desired Trace Options (Verb trace, Verb trace plus up to 128 bytes of data, or Verb trace plus full data).
    3. Select Component Name APPC API and then select the desired Trace Options (Verb trace, Verb trace plus up to 128 bytes of data, or Verb trace plus full data). CPI-C is built upon APPC and so it is sometimes useful to glean more information by tracing APPC as well as CPI-C.
    4. Adjust the Maximum Trace Data Length if required (default 16K).
    5. Select Start to start tracing.
    6. Having performed the required tracing select Stop to stop tracing.
    7. Select Save and opt to either overwrite or append to the unformatted trace file.
    8. Select Format and specify a name for the formatted trace file. The unformatted trace file will then be formatted and saved in this file.
    9. This file can be viewed using an editor or the Windows Notepad program.
Parent topic: IBM Communications Server v5.01 for Windows NT


Known Problems

None.

Parent topic: IBM Communications Server v5.01 for Windows NT


IBM Personal Communications v4.2 for Windows 95 and Windows NT

  • Installing IBM IEEE 802.2 LAN Interface
  • Configuring IBM Personal Communications
  • Configuring the Node
  • Step 1: Node Setup
  • Basic Settings
  • Basic Settings
  • Basic Settings
  • Step 5: Partner LU 6.2 Configuration
  • Basic Settings
  • Step 6: Configuring Modes (Optional)
  • Verifying the Configuration
  • Activating the Configuration
  • Testing the Configuration
  • Error Reporting and Diagnostics
  • Known Problems
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


Installing IBM IEEE 802.2 LAN Interface

IBM Personal Communications requires the IBM IEEE 802.2 Lan Interface to provide support for a connection over 802.2. Towards the end of the installation of IBM Personal Communications you will be prompted to choose whether to automatically install the IBM IEEE 802.2 Lan Interface for use with IBM Personal Communications over a LAN. Unless you have installed this interface previously you must opt to install the IBM IEEE 802.2 LAN Interface if you intend to configure connections over 802.2.

Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Configuring IBM Personal Communications

After successfully installing the Personal Communications product, you can start to configure your APPC connection. You should have a VTAM definition of the connection you are attempting to configure available to you during the configuration.

From the IBM Personal Communications program folder, start the SNA Node Configuration program.

Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Configuring the Node

In the File menu select New to create a new Node configuration.

Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Step 1: Node Setup

From the Configuration options listbox select Configure Node and then select New.

Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Basic Settings

  1. In the Fully Qualified CP name enter the Network Name for this SNA network in the first box. This should be obtained from the network administrator of the host system. In the second box following the period enter the Control Point (CP) name assigned to this machine. This should be obtained from the network administrator of the host system. The CP Name should match the Physical Unit (PU) name assigned to this machine as specified in the PU definition in VTAM for this machine.
  2. Duplicate the CP Name in CP alias.
  3. Enter the 8 digit hexadecimal Local Node ID which is used to identify this local system on the SNA network. The first 3 digits is the Block ID (IDBLK) number followed by the last 5 digits of the Physical Unit ID (IDNUM) (also known as the Node number). These numbers must correspond with the IDBLK and IDNUM fields of the PU definition for this machine as defined in VTAM on the host system.

  • Advanced Settings
  • DLU Requester Settings
  • Step 2: Device Configuration
Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Advanced Settings

These can be left to their default settings

Parent topic: Basic Settings


DLU Requester Settings

These can be left to their default settings

Select OK to complete the Node configuration.

Parent topic: Basic Settings


Step 2: Device Configuration

From the Configuration options list box select Configure Devices. Then from the DLCs list box select LAN and then select New.

Parent topic: Basic Settings


Basic Settings

  1. Specify LAN adapter.

    IBM Personal Communications will detect which LAN adapters are available for use (i.e. are not dialup adapters, etc.) and list them by number in the Adapter number pulldown list box. If you only have one LAN adapter installed you can select the Use first available LAN adapter checkbox. If you have more than one LAN adapter do not select this checkbox but select the appropriate LAN adapter number from the Adapter number pulldown listbox. The following information will help you to determine the adapter number of the LAN adapter.

    In Windows 95 and Windows NT LAN adapters are assigned an Adapter number in a range which starts with 0. However, you cannot assume that just because you have only one LAN adapter defined it will be assigned adapter number 0, for example a dial-up adapter will also be assigned a LAN adapter number and, in addition, removing adapters from the configuration does not cause the adapter numbers to be reassigned.

    • On Windows NT

      Select the adapter number assigned to the required LAN adapter listed in the Adapters panel of the network settings in Control Panel.

      Note:

      On Windows NT the adapter numbers displayed in the Adapter number pulldown list box of the Personal Communications Device configuration are inconsistent with the numbers assigned by Windows NT the Adapters panel of the Network settings in Control Panel. When only one LAN adapter is installed Windows NT assigns it number 1 in the Network settings whereas IBM Personal Communications displays it as 0 in the Adapter number pulldown list box of the Basic Settings of the Device configuration.

    • On Windows 95

      Start the Windows 95 Registry Editor (regedit). Select the key item HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Net. This key will contain a numbered key entry for each adapter. Select each numbered key (simply select with the mouse, do not double-click) and use the DriverDesc field to determine which adapter this describes. When you have found the required LAN adapter its adapter number is its numbered key value.

  2. Leave the Local SAP setting to default to 04.

  • Advanced Settings
  • Performance Settings
  • Step 3: Connection Configuration
Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Performance Settings

These can be left to their default settings

Select OK to complete the Device configuration.

Parent topic: Basic Settings


Step 3: Connection Configuration

From the Configuration options list box select Configure connections and then select New.

Parent topic: Basic Settings


Basic Settings

  1. Enter a name for the connection in the Link station name. This must be up to 8 characters long and will describe the connection, e.g. the destination of the connection.
  2. From the Device name pulldown select the LAN Device name configured previously in step 2.
  3. Enter the 12 digit hexadecimal Destination address of the network controller attached to the remote host system. This should be obtained from the network administrator of the host system.
  4. Unless directed otherwise, leave the Remote SAP to default to 04.
  5. Select the LAN adapter type of the network controller attached to the host system. This should be obtained from the network administrator of the host system.

  • Advanced Settings
  • Security Settings
  • Step 4: Local LU Configuration
Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Advanced Settings

  1. Select Activate link at start to automatically activate the connection when the Node is started.
  2. Select APPN support.
  3. Leave the HPR support, Auto-activate support, Link to preferred NN server and Solicit SSCP sessions options checkboxes unselected.
  4. Leave the Maximum PIU size to default to 32767.
  5. Enter the 8 digit hexadecimal Local Node ID which is used to identify this local system on the SNA network. This should be the same as the Local Node ID specified when configuring the Node in step 1 previously.

Parent topic: Basic Settings


Security Settings

  1. Enter the fully qualified Control Point name of the Host system in the Adjacent CP name. Enter the Network Name for this SNA network in the first box. This should be obtained from the network administrator of the host system. In the second box following the period enter the Control Point (CP) name assigned to the remote Host machine. This should be obtained from the network administrator of the host system.
  2. From the Adjacent CP type pulldown select APPN Node.
  3. Leave the TG number to default to 0.

Select OK to complete the Connection configuration.

Before attempting to communicate using CCIAPPC you must define the local and remote LUs which will be used to communicate over the SNA connection you have configured. In this section we will describe the configuration of Independent LUs to be used to communicate over the host connection. When communicating with Host systems running VTAM (or NCP) the Remote LU is known as the APPLID (pronounced 'apple-eye-dee').

Parent topic: Basic Settings


Step 4: Local LU Configuration

From the Configuration options listbox select Configure Local LU 6.2 and then select New.

  1. For the Local LU name specify the LU name as defined in the list of LUs defined for this PU in VTAM on the host system.
  2. Leave Dependent LU unselected.
  3. For the Local LU alias enter the same Local LU name.
  4. Leave the LU session limit to default to 0.

Select OK to complete the Local LU configuration.

Parent topic: Basic Settings


Step 5: Partner LU 6.2 Configuration

From the Configuration options list box select Configure Partner LU 6.2 and then select New.

Unlike Local LUs, Remote LUs are assigned to a connection which will be used to communicate with it.

Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Basic Settings

  1. Enter the fully qualified Partner LU Name.

This LU Name should match the definition of the LU as it exists on the remote system, in this case in the form of a VTAM APPL definition on the host system.

Enter the Network Name for this SNA network in the first box. This should be obtained from the network administrator of the host system. In the second box following the period enter the name of the APPL on the remote Host machine. This should be obtained from the network administrator of the host system.

  • For the Partner LU alias duplicate the Partner LU name (i.e. APPL name).
  • Enter the Fully qualified CP name of the Host system on which the partner LU resides.

This is the same as the fully qualified CP name entered in the Security settings of the Connection configured previously in step 3.

Setting this correctly will enable the Server to determine which connection to use to locate a partner LU when establishing a session with a Local LU.

  • Advanced Settings
  • Configuring Session Limits: Defining a Mode
Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Advanced Settings

  1. Leave the Maximum LL record size to default to 32767.
  2. Selecting Conversation security support will have no effect since this is not supported by CCIAPPC.
  3. Ensure that the Parallel session support is selected.

Select OK to complete the Partner LU configuration.

Parent topic: Basic Settings


Configuring Session Limits: Defining a Mode

A Mode is used to define the attributes of sessions used between a Local LU and a Remote LU.

If the default mode #INTER is not appropriate (because its settings are incompatible with the modes defined on the host system for the Remote LU, or perhaps because a larger number of sessions is required) then a new mode can be defined.

CCIAPPC uses a single APPC session for each CCI session between the client and the server (e.g. between the MFA client and Fileshare running on a mainframe). When CCIAPPC establishes a connection between the client and server the attributes of the Mode determine, amongst other things, the number of CCI sessions available between the Local LU and the Remote LU (APPLID in VTAM). Hence the Mode determines how many client sessions can be established using the same Local LU - Remote LU pairing.

The PLU mode session limit and the Minimum contention winner sessions together determine how many sessions can be established by the Local LU (see below).

For example: if 10 client sessions are required, all using the same Local LU then the Mode session attributes might be:

PLU mode session limit = 20
Minimum contention winner sessions = 15

Alternatively the same number of client sessions could be attained by using multiple Local LUs with the client sessions divided between these LUs.

Important:

When a connection is established between a Local LU and a Remote LU the Mode characteristics are negotiated. This means that it is possible that the partner system (e.g. mainframe) will reduce the session limits to values which it can support. This may mean that fewer client sessions than expected will be supported. Hence it is important that the Mode characteristics, as defined for both the Local and Remote LUs, are compatible.

Parent topic: Basic Settings


Step 6: Configuring Modes (Optional)

From the Configuration options list box select Configure Modes and then select New.

  • Basic Settings
  • Advanced Settings
  • Enabling CCIAPPC to Find the Local LU
Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Basic Settings

  1. Enter Mode Name, this should match the Mode Name as defined on the Host system in VTAM. This can be the default log mode specified by the DLOGMOD parameter of the VTAM Applid (APPL) definition.
  2. Enter the PLU mode session limit. This is the maximum number of sessions that can be established between the two LUs.
  3. Enter the number of Minimum contention winner sessions. This is the number of sessions that the Local LU can establish without needing the permission of the Remote LU.

This value cannot be greater than the PLU mode session limit.

Parent topic: Step 6: Configuring Modes (Optional)


Advanced Settings

  1. Leave the Maximum negotiable session limit to default to 128.
  2. Leave the Receive pacing window size to default to 1.
  3. From the Class of service name pulldown select #INTER. This is the default APPC class of service.
  4. Leave Use cryptography unselected.
  5. Leave Use compression unselected.
  6. Leave Use default RIU size selected.

If you are in doubt over these values check with the network administrator of the host system.

Select OK to complete the Mode configuration.

Select OK to complete the Mode configuration.

Parent topic: Step 6: Configuring Modes (Optional)


Enabling CCIAPPC to Find the Local LU

It is very important that the CCIAPPC module be able to determine the Local LU to use for communication with the Host application. You may have configured everything else correctly and all of your other APPC applications may work, but if you miss this final step you will fail to establish a CCI session with the host application. If the CCI-INITCLIENT call returns CCI error 9 and CCI_GETERROR returns the message "CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined" it is likely that you have failed to complete this final step. When CCIAPPC attempts to allocate an LU 6.2 session with the remote system it must specify the Remote LU name which it requires a session with. This is the Remote LU name specified in the CCI Servername parameter (e.g. the /S parameter in FHREDIR.CFG). However, APPC needs to know the Local LU name as well as the Remote LU name when attempting to establish a session between the LUs.

To enable APPC to retrieve the Local LU name to use when attempting to allocate APPC sessions set the APPCLLU environment variable to the Local LU Name prior to starting the CCIAPPC client.

For Example:

SET APPCLLU=CCILLU01
Parent topic: Step 6: Configuring Modes (Optional)


Verifying the Configuration

To save and verify the configuration:

  1. In the File menu select Save to save the configuration. If prompted, opt to make configuration the default configuration. Exit the SNA Node Configuration program.
  2. In the Administrative and PD Aids folder of the IBM Personal Communications program folder start the SNA Node Configuration Verification program.
  3. In the File menu select Open and select the configuration file. The file will be loaded and the configuration displayed.
  4. In the File menu select Verify. If the configuration is correct the Verify will complete with no errors. If there are errors correct these using the SNA Node Configuration program, save the configuration and run Verify again.
Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Activating the Configuration

Once the configuration has been verified as correct the Node can be started.

  1. In Administrative and PD Aids folder of the IBM Personal Communications program folder start the SNA Node Operations program.
  2. In the Operations menu select Start Node... or select the green Start Node icon in the task bar.
  3. Select the configuration to open and select Open.

Once the service is active the underlying connections will activate if Activate link at start was defined for the connections.

Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Testing the Configuration

Once you have an active connection use the CNOS Initialize option in the Operations menu of the SNA Node Operations program to test the configuration. This will test the configuration by attempting to bind an LU 6.2 session between the Local LU and the Remote LU over the configured LAN connection.

  1. In the View menu of the SNA Node Operations program select LU 6.2 Sessions.
  2. In the Operations menu of the Node Operations program select CNOS Initialize...
  3. Select the Local LU to be used from the Local LU 6.2 pulldown.
  4. Enter the fully qualified Partner LU name (as defined in step 6 previously). This is of the format:
     Network-Name.Partner-LU-Name
  5. Select the Mode to use. This may be a custom Mode you have defined or can be left to default to #INTER.
  6. Specify the characteristics of the Mode:
    • In Sessions specify the maximum number of sessions allowed by the Mode, this is PLU mode session limit defined for the Mode.
    • In Winners specify the number of Minimum Contention winners as defined for the mode.
    • Specify 0 in Losers for the number of Contention Losers.
    • Specify 1 in Activate to activate a single session as a test.
  7. Select OK to initiate the bind test.

    If the test is successful the session bound between the Local LU and Partner LU will appear in the LU 6.2 Sessions window of the Node Operations program (in the View menu select Refresh to refresh the window). Sessions bound in this way can safely be terminated by selecting the Session Id, clicking the right mouse button and selecting Stop Abnormally.

    If the test fails an error will be reported in a dialog box. Use the IBM Personal Communications Log Viewer to help you diagnose the cause of failure (see the section Error Reporting and Diagnostics below).

Now you have tested the active connection it is ready for use with CCIAPPC.

Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Error Reporting and Diagnostics

  • Fileshare Error Reporting

    Fileshare clients log messages returned from CCI in both the fhredir.msg and fhneterr.log files in the current directory. For example, an entry from fhredir.cfg CCI: 970116 15183855 0009 07 CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined Column 2 and 3 gives the date and time stamp of the error. Column 4 (in this case 0009) gives the CCI error code Column 6 gives the CCI error message returned by CCI-GETERROR.

  • IBM Personal Communications Log File (PCWMSG.MLG)

    The Log file can be viewed by selecting Log Viewer from the Launch menu of the SNA Node Operations program or by selecting Log Viewer from the Administrative and PD folder of the IBM Personal Communications program folder.

    Details of the selected message are shown at the bottom of the Log Viewer window. In addition, double-clicking on the message number will display an explanation of the message.

    Further useful diagnostic information can be obtained by interpreting the Sense Code returned with many errors using the Display SNA Sense Data utility in the the Administrative and PD folder of the IBM Personal Communications program folder.

  • IBM Personal Communications Trace Facility

    This can be used to provide tracing of CPI-C and APPC interface calls made by CCIAPPC.

    Start the Trace Facility program from the the Administrative and PD folder of the IBM Personal Communications program folder or from the Launch menu of the SNA Node Operations program.

    1. Select Function Name APPN and APPC.
    2. Select Component Name CPI-C API and then select the desired Trace Options (Verb trace, Verb trace plus up to 128 bytes of data, or Verb trace plus full data).
    3. Select Component Name APPC API and then select the desired Trace Options (Verb trace, Verb trace plus up to 128 bytes of data, or Verb trace plus full data). CPI-C is built upon APPC and so it is sometimes useful to glean more information by tracing APPC as well as CPI-C.
    4. Adjust the Maximum Trace Data Length if required (default 16K).
    5. Select Start to start tracing.
    6. Having performed the required tracing select Stop to stop tracing.
    7. Select Save and opt to either overwrite or append to the unformatted trace file.
    8. Select Format and specify a name for the formatted trace file. The unformatted trace file will then be formatted and saved in this file.
    9. This file can be viewed using an editor or the Windows Notepad program.
Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Known Problems

None.

Parent topic: IBM Personal Communications v4.2 for Windows 95 and Windows NT


Microsoft SNA Server v3.0

  • Installing DLC for Windows NT or 95
  • Installing Microsoft SNA Server
  • Configuring Microsoft SNA Server
  • Step 1: Configuring the Local Server
  • Step 2: Configuring the Link Service
  • Step 3: Configuring the Connection
  • Step 4: Configuring the Connection Address
  • Step 5: Configuring the System Identification
  • Step 6: Configuring 802.2 DLC Properties
  • Step 7: Configuring Local LUs
  • Step 8: Configuring Remote LUs
  • Configuring Session Limits: Defining a Mode
  • Step 9: Enabling CCIAPPC to Find the Local LU
  • Step 10: Configuring a 3270 LU for the 3270 Applet
  • Step 11: Associating a 3270 LU with a User
  • Step 12: Activating the Configuration
  • Error Reporting and Diagnostics
  • Known Problems
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


Installing DLC for Windows NT or 95

Microsoft SNA Server requires the Microsoft 32-bit DLC protocol to provide support for a connection over 802.2. You should already have installed the 32-bit DLC driver for Windows '95 or Windows NT. If you have not yet done this, please follow the instructions for installing this driver in Configuring DLC over 802.2 on Windows 95 or Configuring DLC over 802.2 on Windows NT.

Parent topic: Microsoft SNA Server v3.0
Parent topic: Microsoft SNA Server v2.11


Installing Microsoft SNA Server

This documentation assumes that you have already installed Microsoft SNA Server. In addition you should have specified the MS DLC in the SNA Server Setup program.

Parent topic: Microsoft SNA Server v3.0


Configuring Microsoft SNA Server

After successfully installing the SNA Server product, you can start to configure your APPC connection. You should have a VTAM definition of the connection you are attempting to configure available to you during the configuration.

From the Microsoft SNA Server(Common) program folder, start the Manager program.

Parent topic: Microsoft SNA Server v3.0


Step 1: Configuring the Local Server

During the SNA Server 3.0 installation (assuming that you are performing a new installation and not an upgrade) you will be prompted for information about the Local Server.

  1. Enter the Network Name for this SNA network. This should be obtained from the network administrator of the host system.
  2. Enter the Control Point (CP) name assigned to this machine. This should be obtained from the network administrator of the host system. The CP Name should match the Physical Unit (PU) name assigned to this machine as specified in the PU definition in VTAM for this machine.

Parent topic: Microsoft SNA Server v3.0


Step 2: Configuring the Link Service

Now configure the Link Service by selecting the Insert menu item then Link Service. This will display the Insert Link Service dialog box.

  1. Select DLC 802.2 Link Service which is the Microsoft 32 Bit DLC installed previously.
  2. Select Add... to add the Link Service.

This will display the DLC 802.2 Link Service Properties dialog box.

  1. Select the correct LAN adapter over which the Link Service will be used.
  2. Leave the Local Service Access Point (SAP) to default to 0x4.
  3. Leave the Allow Link Service To Be Distributed option unselected.
  4. Hit the OK button to complete the configuration of the Link Service.

Parent topic: Microsoft SNA Server v3.0


Step 3: Configuring the Connection

  1. Under the SNA Servers folder select the local Server which you have just configured in Steps 1 and 2 above.
  2. In the Insert menu choose Connection and then the connection type 802.2, at which point the Connection Properties dialog box will appear.
  3. Fill in the Connection Name with a name up to 8 characters long which will describe the connection, e.g. the destination of the connection.
  4. Select the Link Service SnaDlc1, this is the protocol which will be used to access the network adapter.
  5. For the Remote End select Host System.
  6. Set the Allowed Directions to both Incoming and Outgoing.
  7. Set the Activation to By Administrator initially. This can be changed to On Demand or At Server Startup later when we are sure that the connection is configured correctly.

Parent topic: Microsoft SNA Server v3.0


Step 4: Configuring the Connection Address

Now display the Address dialog box by clicking on the Address tag in the Connection Properties dialog box.

  • Enter the 12 digit hexadecimal Remote Network Address of the network controller attached to the remote host system. This should be obtained from the network administrator of the host system.

Parent topic: Microsoft SNA Server v3.0


Step 5: Configuring the System Identification

Now display the System Identification dialog box by clicking on the System Identification tag in the Connection Properties dialog box.

  1. Enter the 8 digit hexadecimal Local Node ID which is used to identify this local system on the SNA network. The first 3 digits is the block (IDBLK) number followed by the last 5 digits of the node (IDNUM) number. These numbers must correspond with the IDBLK and IDNUM fields of the PU definition for this machine as defined in VTAM on the host system.

The XID Type should reflect the type used by the host system. At this point you must check with the network administrator of the host system to see whether the host system uses Format 3 type XIDs. Format 0 only sends the local Node ID and is used only when hosts do not support the default Format 3 XID. Format 3 sends up to 100 bytes of identification data which includes the local Node ID and the Control Point name. Independent APPC LUs must use format 3 XIDs. The default is Format 3.

  • If the host system uses XID type Format 3 (which is usually the case) then select the XID Type of Format 3 and fill in the Network Name and Control Point name of the host system in the Remote Node Name fields. These names should be obtained from the network administrator of the host system.
  • If the host system does not use Format 3 XIDs then select the XID Type of Format 0 and leave the Remote Node Name fields blank.

Also check with the network administrator of the host system whether the Node Id of the host system should be configured.

  • If so, enter the 8 digit block number and node number given to you by the network administrator of the host system which is the Remote Node Id of the host system.

Parent topic: Microsoft SNA Server v3.0


Step 6: Configuring 802.2 DLC Properties

Now display the 802.2 DLC dialog box by clicking on the 802.2 DLC tag in the Connection Properties dialog box.

The 802.2 DLC settings contain parameters which in most cases can be left to their default values. Two which may need modification are the BTU Length and the Connection Retry Limits.

  1. Specify a value for the maximum BTU Length based on the following formula. BTU = MAXDATA - 9, where MAXDATA is the value of the MAXDATA parameter of the PU definition for this machine. NOTE: For a 4 Mbs Token Ring specify a BTU value of 4195 or less. For a 16 Mbs Token Ring specify a value of 16393 or less. For an Ethernet LAN specify a BTU value of 1493 or less.
  2. Set a value for the Maximum Retries which the SNA Server will make when attempting to establish the connection with the host system. The possible values range from 1 to Unlimited. We suggest a value of 2.
  3. Set a value for the Delay After Failure. This is a value in seconds between each attempt. The range is from 5 to 255 seconds, with a default of 10.

To complete the configuration of the connection click on the OK button.

Before attempting to communicate using CCIAPPC you must define the local and remote LUs which will be used to communicate over the SNA connection you have configured. In this section we will describe the configuration of Independent LUs to be used to communicate over the host connection. When communicating with Host systems running VTAM (or NCP) the Remote LU is known as the APPLID (pronounced 'apple-eye-dee').

Parent topic: Microsoft SNA Server v3.0


Step 7: Configuring Local LUs

  1. Under the SNA Servers folder select the local Server which you have just configured in Steps 1 and 2 above.
  2. In the Insert menu select APPC and then Local LU at which point the Local APPC LU Properties dialog box should appear.
  3. For the LU Alias specify the LU name as defined in the list of LUs defined for this PU in VTAM on the host system. This name is automatically duplicated for the LU Name.
  4. Select the Network Name field, this will cause the Network Name to be automatically set to the Network Name of the Local Server. The Network Name and LU Name together form the Fully Qualified LU Name.
  5. Leave the APPC SyncPoint Support box unselected.

Now select the Advanced tab in the Local APPC LU Properties dialog box.

  1. Select the check box marked Member of Default Outgoing Local APPC LU Pool.
  2. Select an LU 6.2 Type of Independent.

To complete the configuration of the Local LU click on the OK button.

Parent topic: Microsoft SNA Server v3.0


Step 8: Configuring Remote LUs

Unlike Local LUs, Remote LUs are assigned to a connection which will be used to communicate with it.

  1. Under the SNA Servers folder select the local Server which you have just configured in Steps 1 and 2 above.
  2. In the Insert menu select APPC and then Remote LU at which point the Remote APPC LU Properties dialog box should appear.
  3. Select the Connection over which this Remote LU will be used. This will be the Connection configured in Step 3.
  4. Enter the LU Alias, this name is automatically duplicated for the LU Name and Uninterpreted Name. This LU Name should match the definition of the LU as it exists on the remote system, in this case in the form of a VTAM APPL definition on the host system.
  5. Select the Network Name field, this will cause the Network Name to be automatically set to the Network Name of the Remote Node Name.

Now select the Options tab in the Remote APPC LU Properties dialog box.

  • Select the Supports Parallel Sessions check box.

To complete the configuration of the Remote LU click on the OK button.

Parent topic: Microsoft SNA Server v3.0


Configuring Session Limits: Defining a Mode

A Mode is used to define the attributes of sessions used between a Local LU and a Remote LU.

If the default mode #INTER is not appropriate (because its settings are incompatible with the modes defined on the host system for the Remote LU, or perhaps because a larger number of sessions is required) then a new mode can be defined.

CCIAPPC uses a single APPC session for each CCI session between the client and the server (e.g. between the MFA client and Fileshare running on a mainframe). When CCIAPPC establishes a connection between the client and server the attributes of the Mode determine, amongst other things, the number of CCI sessions available between the Local LU and the Remote LU (APPLID in VTAM). Hence the Mode determines how many client sessions can be established using the same Local LU - Remote LU pairing.

The Parallel Session Limit and the Minimum Contention Winner Limit together determine how many sessions can be established by the Local LU (see below).

For example: if 10 client sessions are required, all using the same Local LU then the Mode session attributes might be:

Parallel Session Limit = 20
Minimum Contention Winner Limit = 15
Partner Minimum Contention Winner Limit = 0

Alternatively the same number of client sessions could be attained by using multiple Local LUs with the client sessions divided between these LUs.

Important:

When a connection is established between a Local LU and a Remote LU the Mode characteristics are negotiated. This means that it is possible that the partner system (e.g. mainframe) will reduce the session limits to values which it can support. This may mean that fewer client sessions than expected will be supported. Hence it is important that the Mode characteristics, as defined for both the Local and Remote LUs, are compatible.

  • To Define a New Mode
Parent topic: Microsoft SNA Server v3.0


To Define a New Mode

  1. In the Insert menu select APPC then Mode Definition at which point the APPC Mode Properties dialog box should appear.
  2. Enter Mode Name, this should match the Mode Name as defined on the Host system in VTAM. This can be the default log mode specified by the DLOGMOD parameter of the VTAM Applid (APPL) definition.

Now select the Limits tab in the APPC Mode Properties dialog box.

  1. Enter the Parallel Session Limit. This is the maximum number of sessions that can be established between the two LUs.
  2. Enter the Minimum Contention Winner Limit. This is the number of sessions that the Local LU can establish without needing the permission of the Remote LU.
  3. Enter the Partner Min Contention Winner Limit. This is the number of sessions that the Remote LU can establish without needing the permission of the Local LU. Note that the sum of the Minimum and Partner Min Contention Winner Limits must be less than or equal to the Parallel Session Limit.
  4. Enter the Automatic Activation Limit. This is the number of contention winner sessions to activate when the connection using this mode is started.

If you are in doubt over these values check with the network administrator of the host system.

Now select the Characteristics tab in the APPC Mode Properties dialog box.

  1. Enter the Pacing Send Count and Pacing Receive Count. These values should be obtained from the system administrator of the host system.
  2. Enter the Max Send RU size and Max Receive RU size. These values should be obtained from the system administrator of the host system.
  3. Select High Priority Mode.

Select OK to complete the Mode definition. The new Mode should appear in the APPC Modes folder.

Repeat this section until all required Modes have been added.

Parent topic: Configuring Session Limits: Defining a Mode


Step 9: Enabling CCIAPPC to Find the Local LU

It is very important that the CCIAPPC module be able to determine the Local LU to use for communication with the Host application. You may have configured everything else correctly and all of your other APPC applications may work, but if you miss this final step you will fail to establish a CCI session with the host application. If the CCI-INITCLIENT call returns CCI error 9 and CCI_GETERROR returns the message "CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined" it is likely that you have failed to complete this final step. When CCIAPPC attempts to allocate an LU 6.2 session with the remote system it must specify the Remote LU name which it requires a session with. This is the Remote LU name specified in the CCI Servername parameter (e.g. the /S parameter in FHREDIR.CFG). However, APPC needs to know the Local LU name as well as the Remote LU name when attempting to establish a session between the LUs.

The manner in which it determines the Local LU name in SNA Server is by one of two mechanisms as described below:

  1. Configure the Local LU to be a member of the Default Outgoing Pool.

    When we configured the Local LU above, we selected the check box marked Member of Default Outgoing Local APPC LU Pool in the APPC LU Properties dialog box. This means that when CCIAPPC attempts to allocate a session with the Remote LU it will select a Local LU which is a member of the Default Outgoing Pool. However, if there are multiple Local LUs which are members of the Default Outgoing Pool then any of these Local LUs could be selected. If this side-effect is undesirable then implement the following method.

  2. Configure a default Local APPC LU Alias on per user or group basis.
    1. If the user or group has already been configured in SNA Server then skip to step number 6, otherwise perform steps 2 to 5 first.
    2. In the Insert menu select User at which point the Add Users and Groups dialog box should appear.
    3. Select the domain from which to add the users or groups or select the local server name.
    4. Select the user or group from the list in the Names list box (select the Members... button to list the users in a group) and then select Add.
    5. Click the OK button.
    6. In the Configured Users folder double-click on the user or group with which you want to associate a default Local APPC LU.
    7. In the users' properties dialog box select the APPC Defaults tag.
    8. Select the the required Local LU from the Local APPC LU popdown list.
    9. Click the OK button.

Now go to the File menu and select Save. It is not necessary to restart the SNA Server service to activate a new User configuration.

Parent topic: Microsoft SNA Server v3.0


Step 10: Configuring a 3270 LU for the 3270 Applet

In order to use the SNA Server 3270 Applet for 3270 terminal access to the host system a 3270 LU must be configured for use by each terminal session.

  1. In the Connections folder select the connection over which the 3270 session will be used.
  2. In the Insert menu select 3270 and then Display LU at which point the 3270 LU Properties dialog box should appear.
  3. Set the LU Number for this dependent LU. This must match the LOCADDR number as specified on the Dependent LU definition configured for use as a 3270 terminal. This is found under the PU definition for the SNA Server machine in VTAM.
  4. Enter the LU Name for the 3270 LU. This should match the name of the Dependent LU definition configured for use as a 3270 terminal. This is found under the PU definition for the SNA Server machine in VTAM.
  5. Now select the Display Model tab in the 3270 LU Properties dialog box.
  6. Set the Display Model attributes. These can usually be left to default to 2 (24x80) and Model can be overridden
  7. Click the OK button to complete the 3270 LU configuration

Repeat Step 10 until you have configured all the 3270 LUs which you require for 3270 terminal sessions.

Parent topic: Microsoft SNA Server v3.0


Step 11: Associating a 3270 LU with a User

When a user runs the SNA Server 3270 Applet a 3270 LU is required in order to establish a session with the host system. This 3270 LU may come from a pool of 3270 LUs or may be associated with the user. We will describe the latter case, associating a 3270 LU with a user.

  1. If the user has not yet been configured in SNA Server then see the second part of Step 9 above.
  2. In the Connections folder select the connection and then the 3270 LU which you wish to assign to a configured user.
  3. Whilst selecting the 3270 LU with the mouse pointer, click the right mouse button and select Assign To followed by User and then select the required user.
  4. In the Configured Users folder select the same user. The newly assigned 3270 LU should appear .

Now go to the File menu and select Save Configuration. It is not necessary to restart the SNA Server service to activate a new User configuration.

When the specified user starts the SNA Server 3270 Applet a session will be established using the 3270 LU associated with the user.

Parent topic: Microsoft SNA Server v3.0


Step 12: Activating the Configuration

Once the settings described above have been made the configuration must be saved before stopping and restarting the SNA Server service.

  1. In the File menu select Save to save the configuration.
  2. In the SNA Servers folder select the server and in the Service menu select Stop.
  3. Once the server status has gone to Inactive, in the Service menu select Start, the service should then go to Active status.

Once the service is active the underlying connections will activate if the Activation type was defined as On Server Startup or On Demand.

Connections configured for Incoming and Outgoing calls go to On Demand/Incoming status when successfully activated. The connection will go to active status when the first session is established or if activated manually by the administrator.

Parent topic: Microsoft SNA Server v3.0


Error Reporting and Diagnostics

  • Fileshare Error Reporting

    Fileshare clients log messages returned from CCI in both the fhredir.msg and fhneterr.log files in the current directory. For example, an entry from fhredir.cfg CCI: 970116 15183855 0009 07 CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined Column 2 and 3 gives the date and time stamp of the error. Column 4 (in this case 0009) gives the CCI error code Column 6 gives the CCI error message returned by CCI-GETERROR.

  • Microsoft SNA Server Event Log

    Events can be viewed using the Microsoft NT Event Viewer (in the Administrative Tools(Common) program folder). In the Event Viewer select Log menu and then menu item Application. This will then display the Application Log. MS SNA Server events are prefixed with SNA. SNA Base events originate from the SNA Base Service and describe events concerning the operation of SNA Server itself. SNA APPC Application events are generated by CCIAPPC calling the APPC interface using CPI-C (Common Programming Interface - Communications).

  • Microsoft SNA Server Trace

    This can be used to provide tracing of CPI-C and APPC interface calls made by CCIAPPC.

    Start the SNA Trace program from the Microsoft SNA Server(Common) program folder or the Microsoft SNA Server Client program folder.

    Select the SNA Applications trace item and then click the Properties button. Select the Messages tab and check the LU 6.2 Messages box. Then select the API Trace tab and check the CPI-C API box. Then click the OK button to return to the Trace Settings dialog box and OK again to activate the SNA Trace settings. To disable tracing select the Clear All Traces button and then OK at the prompt.

    Trace files are in binary format, have extension .ATF and are generated in the traces directory of the Microsoft SNA Server client installation. They must be viewed using the SNA Trace Viewer (sna\system\tracevwr.exe) which is found only in the Microsoft SNA Server(Common) program folder on the NT Server. However the tracevwr.exe can be copied and run on a Windows NT or Windows 95 client machine.

Parent topic: Microsoft SNA Server v3.0


Known Problems

  1. Running Microsoft SNA Server 3.0 with Novell Netware 32 Bit Client

    There is a problem running Microsoft SNA Server v3.0 on Windows NT Servers which are also running the Novell Netware 32 Bit Client. The SNA Server service can cause Windows NT to crash or the service itself may trap. Microsoft are aware of this problem and plan to address this with SNA Server v3.0 Service Pack 2 (SP2). This problem does not exist with the Microsoft Netware Client.

  2. Attempting to install Microsoft SNA Server 3.0 on an NT Server configured in a WorkGroup

    Microsoft SNA Server 3.0 MUST be installed on an NT Server which is EITHER a Domain Controller OR is configured in a Domain (where another Server is the Domain Controller). The NT Server must NOT be configured in a WorkGroup.

Parent topic: Microsoft SNA Server v3.0


Microsoft SNA Server v2.11

  • Installing DLC for Windows NT or 95
  • Installing Microsoft SNA Server
  • Configuring Microsoft SNA Server
  • Step 1: Configuring the Local Server
  • Step 2: Configuring the Adapter
  • Step 3: Configuring the Connection
  • Step 4: Configuring the Connection Setup
  • Step 5: Configuring Local LUs
  • Step 6: Configuring Remote LUs
  • Step 7: Partnering LUs
  • Step 8: Enabling CCIAPPC to Find the Local LU
  • Step 9: Configuring a 3270 LU for the 3270 Applet
  • Step 10: Associating a 3270 LU with a User
  • Step 11: Activating the Configuration
  • Error Reporting and Diagnostics
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


Installing Microsoft SNA Server

You should have already installed Microsoft SNA Server. In addition you should have specified the MS DLC in the SNA Server Setup program.

Parent topic: Microsoft SNA Server v2.11


Configuring Microsoft SNA Server

After successfully installing the SNA Server product, you can start to configure your APPC connection. You should have a VTAM definition of the connection you are attempting to configure available to you during the configuration.

From the Microsoft SNA Server(Common) program folder, start the SNA Admin program.

Parent topic: Microsoft SNA Server v2.11


Step 1: Configuring the Local Server

Select New Server from the Services menu. This will display the Server Properties dialog box.

  1. Enter a Server Name which will be used to identify this local MS SNA Server, for example, this could be the machine name.
  2. Enter the Network Name for this SNA network. This should be obtained from the network administrator of the host system.
  3. Enter the Control Point (CP) name assigned to this machine. This should be obtained from the network administrator of the host system. The CP Name should match the Physical Unit (PU) name assigned to this machine as specified in the PU definition in VTAM for this machine.

Parent topic: Microsoft SNA Server v2.11


Step 2: Configuring the Adapter

Now configure the Adapter by clicking on the Adapters button in the Server Properties dialog box. This will display the Adapter Properties dialog box.

  1. Select the Service Name SnaDlc1 which is the MS 32 Bit DLC installed previously.
  2. Select the correct adapter type (in this case Token Ring or Ethernet) which is being used by this machine. If the machine has more than one adapter then choose the adapter type which was configured for use with MS DLC.

Complete the Local Server configuration by clicking on the Close button.

Parent topic: Microsoft SNA Server v2.11


Step 3: Configuring the Connection

  1. Select the local Server in the Servers and Connections window which you have just configured in Steps 1 and 2 above.
  2. In the Services menu choose New Connection which then displays the Insert Connection dialog box.
  3. Select the type of connection, in this case 802.2.
  4. Choose OK at which point the Connection Properties dialog box will appear.
  5. Fill in the Connection Name with a name up to 8 characters long which will describe the connection, e.g. the destination of the connection.
  6. Select the Link Service SnaDlc1, this is the protocol which will be used to access the network adapter.
  7. For the Remote End select Host System.
  8. Set the Allowed Directions to both Incoming and Outgoing.
  9. Set the Activation to By Administrator initially. This can be changed to On Demand or At Server Startup later when we are sure that the connection is configured correctly.

Parent topic: Microsoft SNA Server v2.11


Step 4: Configuring the Connection Setup

Now display the 802.2 Setup dialog box by clicking on the Setup button in the Connection Properties dialog box.

  1. Enter the 12 digit hexadecimal Remote Network Address of the network controller attached to the remote host system. This should be obtained from the network administrator of the host system.
  2. Enter the 8 digit hexadecimal Local Node ID which is used to identify this local system on the SNA network. The first 3 digits is the block (IDBLK) number followed by the last 5 digits of the node (IDNUM) number. These numbers must correspond with the IDBLK and IDNUM fields of the PU definition for this machine as defined in VTAM on the host system.
  3. At this point you must check with the network administrator of the host system to see whether the host system uses Format 3 type XIDs.
    • If it does then you must fill in the Network Name and Control Point name of the host system.
    • If it does not use Format 3 XIDs (usually the case) then these fields can be left blank.
  4. Also check with the network administrator of the host system whether the Node Id of the host system should be configured. If so, enter the 8 digit block number and node number given to you by the network administrator of the host system which is the Remote Node Id of the host system.
  5. Now set the connection retry parameters by clicking on the Retry Timers button.
    1. Set a value for the Maximum Number of attempts that SNA Server will make to establish the connection with the host system. The possible values range from 1 to Unlimited. We suggest a value of 2.
    2. Set a value for the Delay after failed attempts. This is a value in seconds between each attempt. The range is from 5 to 255 seconds, with a default of 10.

  6. Now check the Advanced settings for the 802.2 connection by clicking the Advanced button.

    The Advanced settings contains parameters which in most cases can be left to their default values. Two which may need modification are the BTU Length and the XID Type.

    1. Specify a value for the maximum BTU Length based on the following formula. BTU = MAXDATA - 9, where MAXDATA is the value of the MAXDATA parameter of the PU definition for this machine. NOTE: For a 4 Mbs Token Ring specify a BTU value of 4195 or less. For a 16 Mbs Token Ring specify a value of 16393 or less. For an Ethernet LAN specify a BTU value of 1493 or less.
    2. The XID Type should reflect the type used by the host system. Format 0 only sends the local Node ID and is used only when hosts do not support the default Format 3 XID. Format 3 sends up to 100 bytes of identification data which includes the local Node ID and the Control Point name. Independent APPC LUs must use format 3 XIDs. The default is Format 3.
  7. To complete the configuration of the connection click on the OK button.

Before attempting to communicate using CCIAPPC you must define the local and remote LUs which will be used to communicate over the SNA connection you have configured. In this section we will describe the configuration of Independent LUs to be used to communicate over the host connection. When communicating with Host systems running VTAM (or NCP) the Remote LU is known as the APPLID (pronounced 'apple-id').

Parent topic: Microsoft SNA Server v2.11


Step 5: Configuring Local LUs

  1. In the Servers and Connections window, select the SNA Server name and then in the Services menu select Assign LUs and when the Insert LU dialog box appears select OK.
  2. For the LU Alias specify the LU name as defined in the list of LUs defined for this PU in VTAM on the host system. At this point this name is automatically duplicated for the LU Name.
  3. Enter the Network Name which should be the same as the Network Name field of the SNA Network Control Point in the Server Properties dialog box (activated by double-clicking on the SNA Server name in the Servers and Connections dialog box). The Network Name and LU Name together form the Fully Qualified LU Name.
  4. If you want to automatically associate this Local LU with every Remote LU configured in SNA Server then select the Enable Automatic Partnering check box.
  5. Select the check box marked Member of Default Outgoing Local APPC LU Pool.

To complete the configuration of the Local LU click on the OK button.

Parent topic: Microsoft SNA Server v2.11


Step 6: Configuring Remote LUs

Unlike Local LUs, Remote LUs are assigned to a connection which will be used to communicate with it.

  1. In the Servers and Connections windows, select the connection configured in Steps 3 and 4, then in the Services menu select Assign LUs. When the Insert LU dialog box appears select APPC (Remote) and then OK.
  2. Enter the LU Alias, at which point this name is automatically duplicated for the LU Name. Enter the Network Name. These should match the definition of the LU as it exists on the remote system, in this case in the form of a VTAM APPL definition on the host system.
  3. Select the Supports Parallel Sessions check box.

Parent topic: Microsoft SNA Server v2.11


Step 7: Partnering LUs

The partnering of a Local LU with a Remote LU forms a relationship between these LUs which will enable us to establish a session for CCIAPPC to communicate over.

  1. In the Servers and Connections windows, on the right hand side of the window, double-click on the Local LU which you have created.
  2. In the APPC LU Properties dialog box select the Partners button.
  3. In the LU 6.2 Partner LUs dialog box select the Add... button.
  4. In the Add APPC LU Partner dialog box select the partner LU (in this case it will be a previously defined Remote LU) and the mode for the LU-LU pair. A number of default modes are defined already, for example #INTER, which is adequate in most cases of LU 6.2 intercommunication. However if you need a customized mode see the section entitled Defining a Mode below.
  5. Click on the Close button.

  • Configuring Session Limits: Defining a Mode
  • To Define a New Mode
Parent topic: Microsoft SNA Server v2.11


Configuring Session Limits: Defining a Mode

A Mode is used to define the attributes of sessions used between a Local LU and a Remote LU.

If the default mode #INTER is not appropriate (because its settings are incompatible with the modes defined on the host system for the Remote LU, or perhaps because a larger number of sessions is required) then a new mode can be defined.

CCIAPPC uses a single APPC session for each CCI session between the client and the server (e.g. between the MFA client and Fileshare running on a mainframe). When CCIAPPC establishes a connection between the client and server the attributes of the Mode determine, amongst other things, the number of CCI sessions available between the Local LU and the Remote LU (APPLID in VTAM). Hence the Mode determines how many client sessions can be established using the same Local LU - Remote LU pairing.

The Parallel Session Limit and the Minimum Contention Winner Limit together determine how many sessions can be established by the Local LU (see below).

For example: if 10 client sessions are required, all using the same Local LU then the Mode session attributes might be:

Parallel Session Limit = 20
Minimum Contention Winner Limit = 15
Partner Minimum Contention Winner Limit = 0

Alternatively the same number of client sessions could be attained by using multiple Local LUs with the client sessions divided between these LUs.

Important:

When a connection is established between a Local LU and a Remote LU the Mode characteristics are negotiated. This means that it is possible that the partner system (e.g. mainframe) will reduce the session limits to values which it can support. This may mean that fewer client sessions than expected will be supported. Hence it is important that the Mode characteristics, as defined for both the Local and Remote LUs, are compatible.

Parent topic: Step 7: Partnering LUs


To Define a New Mode

  1. In the Servers and Connections windows, on the right hand side of the window, double-click on the Local LU which you have created.
  2. In the APPC LU Properties dialog box select the Partners button.
  3. In the LU 6.2 Partner LUs dialog box select the Modes... button.
  4. Enter Mode Name, this should match the Mode Name as defined on the Host system in VTAM. This can be the default log mode specified by the DLOGMOD parameter of the VTAM Applid (APPL) definition.
  5. Enter the Parallel Session Limit. This is the maximum number of sessions that can be established between the two LUs.
  6. Enter the Minimum Contention Winner Limit. This is the number of sessions that the Local LU can establish without needing the permission of the Remote LU.
  7. Enter the Partner Min Contention Winner Limit. This is the number of sessions that the Remote LU can establish without needing the permission of the Local LU. Note that the sum of the Minimum and Partner Min Contention Winner Limits must be less than or equal to the Parallel Session Limit. If you are in doubt over these values check with the network administrator of the host system.
  8. Do not select Enable Automatic Partnering.
  9. Select High Priority Mode.
  10. Enter the Pacing Send Count and Pacing Receive Count. These values should be obtained from the system administrator of the host system.
  11. Enter the Max Send RU size and Max Receive RU size. These values should be obtained from the system administrator of the host system.
  12. Select Close to complete the Mode definition. The new Mode should appear in the Modes pull-down window when choosing a mode for a Local LU - Remote LU partnership.

Repeat this section until all required Modes have been added.

Refer to the section entitled Configuring Modes for LU-LU Pairs in chapter 6, Configuring LUs for APPC of Part 2 of the Microsoft SNA Server Administration Guide for more information.

Parent topic: Step 7: Partnering LUs


Step 8: Enabling CCIAPPC to Find the Local LU

It is very important that the CCIAPPC module be able to determine the Local LU to use for communication with the Host application. You may have configured everything else correctly and all of your other APPC applications may work, but if you miss this final step you will fail to establish a CCI session with the host application. If the CCI-INITCLIENT call returns CCI error 9 and CCI_GETERROR returns the message "CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined" it is likely that you have failed to complete this final step. When CCIAPPC attempts to allocate an LU 6.2 session with the remote system it must specify the Remote LU name which it requires a session with. This is the Remote LU name specified in the CCI Servername parameter (e.g. the /S parameter in FHREDIR.CFG). However, APPC needs to know the Local LU name as well as the Remote LU name when attempting to establish a session between the LUs.

The manner in which it determines the Local LU name in SNA Server is by one of two mechanisms as described below:

  1. Configure the Local LU to be a member of the Default Outgoing Pool.

    When we configured the Local LU above, we selected the check box marked Member of Default Outgoing Local APPC LU Pool in the APPC LU Properties dialog box. This means that when CCIAPPC attempts to allocate a session with the Remote LU it will examine the Local LU partners configured with the Remote LU and select one which is a member of the Default Outgoing Pool. However, if there are multiple Local LU partners configured with the Remote LU which are members of the Default Outgoing Pool then any of these Local LUs could be selected. If this side-effect is undesirable then implement the following method.

  2. Configure a default Local APPC LU Alias on per user or group basis.
    • In the Users and Groups window from the View menu select Configured Users. From the Users menu select New User.
    • Select the domain from which to add the users or groups or select the local server name.
    • Select the user or group from the list in the Names list box (select the Members... button to list the users in a group) and then select Add.
    • Click the OK button.
    • In the Users and Groups window select the user or group with which you want to associate a default Local APPC LU.
    • In the Users menu select the Properties menu item.
    • In the User Properties dialog box select the required Local LU from the Default Local APPC LU popdown list.
    • Click the OK button.

Now go to the File menu and select Save Configuration. It is not necessary to restart the SNA Server service to activate the new configuration. For further information concerning assigning default LUs to users and groups see the section entitled Assigning Default APPC LUs to Users or Groups in chapter 6, Configuring LUs for APPC, in the Microsoft SNA Server Administration Guide.

Parent topic: Microsoft SNA Server v2.11


Step 9: Configuring a 3270 LU for the 3270 Applet

In order to use the SNA Server 3270 Applet for 3270 terminal access to the host system a 3270 LU must be configured for use by each terminal session.

  1. In the Servers and Connections window select the host connection which is to be used for the 3270 terminal session
  2. In the Services menu select menu item Assign LUs...
  3. In the Insert LU dialog box select 3270 and then click on the OK button
  4. In the New 3270 LU Properties dialog box:
    • Set the LU Number for this dependent LU. This must match the LOCADDR number as specified on the Dependent LU definition configured for use as a 3270 terminal. This is found under the PU definition for the SNA Server machine in VTAM.
    • Set the LU Type to Display
    • Set the Display Model attributes. These can usually be left to default to 2 (24x80) and Model can be overridden
    • Click the OK button to complete the 3270 LU configuration

Repeat Step 9 until you have configured all the 3270 LUs which you require for 3270 terminal sessions.

Parent topic: Microsoft SNA Server v2.11


Step 10: Associating a 3270 LU with a User

When a user runs the SNA Server 3270 Applet a 3270 LU is required in order to establish a session with the host system. This 3270 LU may come from a pool of 3270 LUs or may be associated with the user. We will describe the latter case, associating a 3270 LU with a user.

  1. If the user has not yet been configured in SNA Server:
    • In the Users and Groups window from the View menu select Configured Users. From the Users menu select New User.
    • Select the domain from which to add the users or groups or select the local server name.
    • Select the user or group from the list in the Names list box (select the Members... button to list the users in a group) and then select Add.
    • Click the OK button.
  2. In the Users and Groups window select the user with whom you want to associate a 3270 LU.
  3. In the Users menu select the Assign LUs menu item.
  4. In the Assign User LU/Pool Sessions dialog box select the required 3270 LU (configured in Step 9 above) from the list of Available LUs and Pools.
  5. Click the OK button.

Now go to the File menu and select Save Configuration. It is not necessary to restart the SNA Server service to activate the new configuration.

When the specified user starts the SNA Server 3270 Applet a session will be established using the 3270 LU associated with the user.

Parent topic: Microsoft SNA Server v2.11


Step 11: Activating the Configuration

Once the settings described above have been made the configuration must be saved before stopping and restarting the SNA Server service.

  1. In the File menu and select Save Configuration.
  2. In the Servers and Connections window select the server and in the Services menu select Stop Service.
  3. Once the server status has gone to Inactive, in the Services menu select Start Service, the service should then go to Active status.

Once the service is active the underlying connections will activate if the Activation type was defined as On Server Startup or On Demand.

Connections configured for Incoming and Outgoing calls go to On Demand/Incoming status when successfully activated. The connection will go to active status when the first session is established or if activated manually by the administrator.

Parent topic: Microsoft SNA Server v2.11


Error Reporting and Diagnostics

  • Fileshare Error Reporting

    Fileshare clients log messages returned from CCI in both the fhredir.msg and fhneterr.log files in the current directory. For example, an entry from fhredir.cfg CCI: 970116 15183855 0009 07 CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined Column 2 and 3 gives the date and time stamp of the error. Column 4 (in this case 0009) gives the CCI error code Column 6 gives the CCI error message returned by CCI-GETERROR

  • Microsoft SNA Server Event Log

    Events can be viewed using the Microsoft NT Event Viewer (in the Administrative Tools(Common) program folder). In the Event Viewer select Log menu and then menu item Application. This will then display the Application Log. MS SNA Server events are prefixed with SNA. SNA Base events originate from the SNA Base Service and describe events concerning the operation of SNA Server itself. SNA APPC Application events are generated by CCIAPPC calling the APPC interface using CPI-C (Common Programming Interface - Communications).

  • Microsoft SNA Server Trace

    provides tracing of CPI-C and APPC interface calls made by CCIAPPC. Start the SNA Server Trace program from the Microsoft SNA Server(Common) program folder. Select the SNA Applications Service Name . Select APPC API and CPI-C API for Client API Tracing. Select OK to activate the trace settings. To disable tracing select Clear at which point the trace file buffers are stored on disk. Trace files are plain text, have extension .TRC and are generated in the traces directory of the MS SNA Server client installation.

Parent topic: Microsoft SNA Server v2.11


Rumba Office 95/NT

  • Installing DLC for Windows 95
  • Installing Rumba Office 95/NT
  • Configuring Rumba Office 95/NT
  • Step 1: Enter Network Name and Control Point Name
  • Step 2: Configuring the Connection
  • Step 3: 802.2 DLC Configuration
  • Step 4: Configuring the Advanced Options
  • Step 5: Configuring Local LU's
  • Step 6: Configuring Local LU's Advanced Options
  • Step 7: Configuring a Dependent LU to be Used for a 3270 Terminal Session
  • Step 8: Configuring Dependent Local LU's Advanced Options
  • Step 9: Configuring Remote LU's
  • Step 10: Configuring Remote LU's Advanced Options
  • Step 11: Configuring Session Limits: Defining a Mode
  • Step 12: Enabling CCIAPPC to Locate the Local LU
  • Step 13: Saving your Configuration
  • Step 14: Updating the System Path
  • Step 15: Activating the Configuration
  • Error Reporting and Diagnostics
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


Installing Rumba Office 95/NT

You should have already installed Rumba Office 95/NT. We suggest that you install using the custom install options to insure that the APPC Client, the 802.2 DLC Interface, and the Rumba Communications Monitor is installed. The APPC Client must be selected and would not normally be installed if using the express installation.

Parent topic: Rumba Office 95/NT


Configuring Rumba Office 95/NT

After successfully installing the Rumba Office 95/NT product, you can start to configure your APPC connection. You should have a VTAM definition of the connection you are attempting to configure available to you during the configuration. Select Start from the Taskbar, then Programs, then Rumba 95 NT Folder, then Rumba Administrative Tools, then APPC Configuration. The APPC Configuration window will be displayed. A sample window with a full configuration is displayed below for reference. Your window will have some default values filled in, you can override these and configure your own connection using the instructions below.

Parent topic: Rumba Office 95/NT


Step 1: Enter Network Name and Control Point Name

The first screen presented in the configuration tool allows you to enter a Network Name and Control Point Name. Enter the network name for this SNA network. This should be obtained from the network administrator of the host system. Enter the Control Point (CP) name assigned to this machine. This should be obtained from the network administrator of the host system. The CP Name should match the Physical Unit (PU) name assigned to this machine as specified in the PU definition in VTAM for this machine.

Parent topic: Rumba Office 95/NT


Step 2: Configuring the Connection

Select Connections by clicking in the Connections portion of the configuration window, then click the Add button. The Select a Connection window will appear. Select the type of physical network connection which will be used, in this case 802.2 DLC (Token Ring and Ethernet) and select OK. If you are using an alternative network connection type, such as SDLC or DFT Coax for instance, ensure that you have already installed a device driver for the network adapter.

Parent topic: Rumba Office 95/NT


Step 3: 802.2 DLC Configuration

  1. Enter a name to describe the Link which will be unique within this node. For example, use a name which will describe the remote node, i.e. the host system, which this Link is used to communicate with.
  2. Enter the Block ID, Node ID, this is the 8 digit hexadecimal number which is used to identify this local system on the SNA network.. The first 3 digits is the block (IDBLK) number followed by the last 5 digits of the node (IDNUM) number. These numbers usually correspond with the IDBLK and IDNUM fields of the PU definition for this machine as defined in VTAM on the host system.
  3. Enter the Destination Address, this is a hexadecimal adapter address of the network controller attached to the remote host system. This should be obtained from the network administrator of the host system.
  4. Enter the Remote SAP Address and Local SAP Address. You may accept the default values of 4 in most cases.
  5. Finally select Mainframe for Link Options.

Parent topic: Rumba Office 95/NT


Step 4: Configuring the Advanced Options

In the 802.2 DLC Configuration dialog box, select the Advanced tab by clicking on it and enter the following parameter settings:

  1. Specify which local network adapter is to be used. If the local machine only has one adapter you may leave the default of Primary Adapter selected. If the machine has more than one adapter and you would like to use the secondary adapter select Secondary Adapter.
  2. Select Xid Type 3. In most SNA configurations this option should be selected. If the host system is running an older version of NCP/VTAM then Xid Type 0 may be required, in which case this checkbox should be left unselected. Check with the network administrator of the host system which Xid type is required
  3. Enter the Maximum Frame Size of a packet that can be transmitted without segmentation. You must specify a value that is less than or equal to the value of the MAXDATA parameter of the PU definition in VTAM for this machine. For a 4 Mbs Token Ring specify a value of 4195 or less. For a 16 Mbs Token Ring specify a value of 16393 or less. For an Ethernet LAN specify a value of 1493 or less.
  4. Enter the Max Out parameter. This parameter specifies the number of frames that the local machine can send on this link before waiting for an acknowledgment from the partner machine. Set this value to 7.
  5. You may leave the Connection Network Name blank.
  6. You may leave Auto Disconnect Link unselected.
  7. We suggest that the Auto Start Link selection initially be left unselected, so that the link is tested by starting manually. Once this is tested this option can then be activated.
  8. You should un-select End Node
  9. Enter 2 for the 3270 Session count.
  10. Enter 2 for the 3270 Start Address. This parameter should be obtained from the VTAM definition of the LU that you plan to use for 3270 Terminal sessions.
  11. Select OK to complete the definition of the connection. The new connection should appear in the Connections window of the RUMBA APPC Configuration window.

Parent topic: Rumba Office 95/NT


Step 5: Configuring Local LU's

Before attempting to communicate using CCIAPPC you must define the local and remote LUs which will be used to communicate over the SNA connection you have configured. In this section we will describe the configuration of Independent LUs to be used to communicate over the host connection. When communicating with Host systems running VTAM (or NCP) the Remote LU is known as the APPLID (pronounced 'apple-id').

  1. Select Local LU's by clicking in the Local LU's portion of the configuration window, then click the Add button. The Configure Local LU's window will appear.
  2. Enter the Local LU Name as defined in the list of LUs defined for this PU in VTAM on the host system.
  3. Enter the LU Alias in most cases this should duplicate the LU Name.

Parent topic: Rumba Office 95/NT


Step 6: Configuring Local LU's Advanced Options

  1. Select the Advanced settings panel by clicking on the Advanced tab.
  2. Enter the LU Address. This value should correspond to the value of the LOCADDR parameter of this LU definition in VTAM on the host system. For independent LUs this value should be zero, whereas dependent LUs have a non-zero address.
  3. Select Use As Default LU. You should click this option for the LU that you wish to use with CCIAPPC. This must be checked if you expect CCIAPPC to be able to determine which local LU to use for communications to the Host.
  4. Select OK to complete the Local LU definition. The new Local LU should appear in the Local LU's window of the RUMBA APPC Configuration window. Repeat this section until all required Local LUs have been added.

Parent topic: Rumba Office 95/NT


Step 7: Configuring a Dependent LU to be Used for a 3270 Terminal Session

In order to verify the connection to the Mainframe it is wise to configure an LU to be used as a 3270 Terminal Session. In this section we will describe the configuration of a Dependent LU.

  1. Select Local LU's by clicking in the Local LU's portion of the configuration window, then click the Add button. The Configure Local LU's window will appear.
  2. Enter the Local LU Name as defined in the list of LUs defined for this PU in VTAM on the host system. We will use the first dependant LU for our terminal session, the dependant LU's will have a LOCADDR that is not equal to zero. In our case we chose an LU with a LOCADDR of 02.
  3. Enter the LU Alias in most cases this should duplicate the LU Name.

Parent topic: Rumba Office 95/NT


Step 8: Configuring Dependent Local LU's Advanced Options

  1. Select the Advanced settings panel by clicking on the Advanced tab.
  2. Enter the LU Address. This value should correspond to the value of the LOCADDR parameter of this LU definition in VTAM on the host system. For independent LUs this value should be zero, whereas dependent LUs have a non-zero address.
  3. Select OK to complete the Local LU definition. The new Local LU should appear in the Local LU's window of the RUMBA APPC Configuration window. Repeat this section until all required Local LUs have been added.

Parent topic: Rumba Office 95/NT


Step 9: Configuring Remote LU's

Now we will configure the Remote LU that will be used to communicate with the Mainframe Fileshare process.

  1. Select Remote LU's by clicking in the Remote LU's portion of the configuration window, then click the Add button. The Configure Remote LU's window will appear.
  2. Enter the name of the VTAM APPL on the host system which is specified by the CCIAPPC server in the publicname parameter (or in the /S parameter of the Fileshare Server).
  3. Enter the LU Alias, this usually duplicates the LU Name.
  4. Connection Select the connection which will be used to communicate with this Remote LU. In this case, the Link Name defined for the connection definition in section 1, or BOSTON.

Parent topic: Rumba Office 95/NT


Step 10: Configuring Remote LU's Advanced Options

  1. Select the Advanced settings panel by clicking on the Advanced tab.
  2. Network Name Enter the network name for this SNA network. This should be obtained from the network administrator of the host system.
  3. Uninterpreted LU Name Duplicate the LU Name.
  4. Use As Default LU Leave to default to selected.
  5. Select OK to complete the Remote LU definition. The new Remote LU should appear in the Remote LU's window of the RUMBA APPC Configuration window. Repeat this section until all required Remote LUs have been added.

Parent topic: Rumba Office 95/NT


Step 11: Configuring Session Limits: Defining a Mode

A Mode is used to define the attributes of sessions used between a Local LU and a Remote LU.

If the default mode #INTER is not appropriate (because its settings are incompatible with the modes defined on the host system for the Remote LU, or perhaps because a larger number of sessions is required) then a new mode can be defined.

CCIAPPC uses a single APPC session for each CCI session between the client and the server (e.g. between the MFA client and Fileshare running on a mainframe). When CCIAPPC establishes a connection between the client and server the attributes of the Mode determine, amongst other things, the number of CCI sessions available between the Local LU and the Remote LU (APPLID in VTAM). Hence the Mode determines how many client sessions can be established using the same Local LU - Remote LU pairing.

The Session Limit and the Minimum Contention Winners values together determine how many sessions can be established by the Local LU (see below).

For example: if 10 client sessions are required, all using the same Local LU then the Mode session attributes might be:

Session Limit = 20
Minimum Contention Winners = 15

Alternatively the same number of client sessions could be attained by using multiple Local LUs with the client sessions divided between these LUs.

Note:

When a connection is established between a Local LU and a Remote LU the Mode characteristics are negotiated. This means that it is possible that the partner system (e.g. mainframe) will reduce the session limits to values which it can support. This may mean that fewer client sessions than expected will be supported. Hence it is important that the Mode characteristics, as defined for both the Local and Remote LUs, are compatible.

  • To Define a New Mode
Parent topic: Rumba Office 95/NT


To Define a New Mode

  1. Select Modes by clicking in the Modes portion of the configuration window, then click the Add button. The Configure Modes window will appear.
  2. Enter Mode Name, this should match the Mode Name as defined on the Host system in VTAM. This can be the default log mode specified by the DLOGMOD parameter of the VTAM Applid (APPL) definition.
  3. Select the Limits panel by clicking on the Limits tab.
  4. Enter the Session Limit, Automatic Activation Limit, and Minimum Contention Winners. These values should be obtained from the system administrator of the host system
  5. Select the Send panel by clicking on the Send tab.
  6. Enter the RU Length and Pacing Count. These values should be obtained from the system administrator of the host system.
  7. Select the Receive panel by clicking on the Receive tab.
  8. Enter the RU Length and Pacing Count. These values should be obtained from the system administrator of the host system.
  9. Select OK to complete the Mode definition. The new Mode should appear in the Modes window of the RUMBA APPC Configuration window. Repeat this section until all required Modes have been added.

Parent topic: Step 11: Configuring Session Limits: Defining a Mode


Step 12: Enabling CCIAPPC to Locate the Local LU

It is very important that the CCIAPPC module be able to determine the Local LU to use for communication with the Host application. You may have configured everything else correctly and all of your other APPC applications may work, but if you miss this final step you will fail to establish a CCI session with the host application. If the CCI-INITCLIENT call returns CCI error 9 and CCI_GETERROR returns the message "Transport failure, the client could not make a connection" it is likely that you have failed to complete this final step. When CCIAPPC attempts to allocate an LU 6.2 session with the remote system it must specify the Remote LU name which it requires a session with. This is the Remote LU name specified in the CCI Servername parameter (e.g. the /S parameter in FHREDIR.CFG). However, APPC needs to know the Local LU name as well as the Remote LU name when attempting to establish a session between the LUs. To enable APPC to retrieve the Local LU name to use when attempting to allocate APPC sessions set the Use As Default LU option in the Advanced window of the Configure Local LU's dialog box for the Local LU. This must be done prior to starting the CCIAPPC client.

Parent topic: Rumba Office 95/NT


Step 13: Saving your Configuration

Once the settings described above have been made the configuration must be saved before starting the RUMBA Engine. In the File menu select Save and then Exit the RUMBA APPC Configuration program.

Parent topic: Rumba Office 95/NT


Step 14: Updating the System Path

Before Rumba can be used with CCIAPPC the system path must be updated so that the required Rumba run-time DLLs can be found by CCIAPPC. CCIAPPC on 32 Bit Windows uses the WCPIC32.DLL from the Rumba product to provide CPI-C APPC support.

Use one of the following methods to update the path:

  • Add the \rumba\system directory to the path in the Environment section of the System settings in the Windows NT Control Panel.

    This takes effect immediately - applications subsequently started will have the correct path setting.

  • Add the \rumba\system directory to the path in the autoexec.bat in Windows 95.

    Restart Windows 95 to adopt the new path setting.

  • Add the \rumba\system directory to the path setting in the COBOL MFENV environment file.

    The new path will now be set when MFENV is used to set the environment for COBOL.

Parent topic: Rumba Office 95/NT


Step 15: Activating the Configuration

In order to activate the configuration follow the steps outlined below.

  1. From the RUMBA 95/NT Folder select the RUMBA Administration Tools folder and start the RUMBA Engine.
  2. Then from the same folder start the RUMBA Communication Monitor.
  3. Select the Link in the left hand window and select Start Link from the Control menu. If the Link activates successfully Active Link will be displayed in the right hand window. If the Link does not activate successfully and Inactive Link remains displayed in the right hand window (note that there is a delay between refreshes of the window) see the section Error Reporting and Diagnostics below for information on diagnosing the problem. Once the Link is active communication with CCIAPPC can be initiated.
Parent topic: Rumba Office 95/NT


Error Reporting and Diagnostics

Refer to the RUMBA Event Logger and Using the RUMBA Trace Console sections of the RUMBA Administrative Tools help topic in the RUMBA Help Desk. These sections will explain how to monitor error events and trace APPC within RUMBA.

Fileshare Error Reporting - Fileshare clients log messages returned from CCI in both the fhredir.msg and fhneterr.log files in the current directory. For Example: an entry from fhredir.cfg, "CCI: 970116 15183855 0009 07 CCIAPPC failed to allocate an APPC session, ensure that Local LU is defined". Column 2 and 3 gives the date and time stamp of the error. Column 4 (in this case 0009) gives the CCI error code Column 6 gives the CCI error message returned by CCI-GETERROR

Parent topic: Rumba Office 95/NT


Support for Attachmate EXTRA! Personal Client

  • Mainframe Access may hang with CCIAPPC and Attachmate EXTRA! Personal Client 32 Bit
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Configuring DLC over 802.2 on Windows 95
Configuring DLC over 802.2 on Windows NT


Mainframe Access may hang with CCIAPPC and Attachmate EXTRA! Personal Client 32 Bit

The initialization of the MFA CCIAPPC client can intermittently hang on some systems when APPC support is being provided by the Attachmate EXTRA! Personal Client 32 Bit product.

If the MFA CCIAPPC client hangs the only course of action is to terminate the client. Further attempts to run the client may be successful although the behavior is unpredictable. If you suspect that you are experiencing this problem you should contact Attachmate Support.

This problem only occurs when using Attachmate EXTRA! Personal Client, all other supported stacks have been tested and do not exhibit this problem.

Parent topic: Support for Attachmate EXTRA! Personal Client


Configuring DLC over 802.2 on Windows 95

  • Installing DLC for Windows 95
  • Step 1: Downloading MSDLC32.EXE
  • Step 2: Select Network from the Control Panel
  • Step 3: Adding a Protocol
  • Step 4: Select Component Type
  • Step 5: Select Have Disk
  • Step 6: Finishing up and Restarting Windows '95
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows NT


Installing DLC for Windows 95

The Rumba and Attachmate EXTRA! products requires the Microsoft 32-bit DLC protocol to provide support for an APPC connection over 802.2. There are other possible configuration options using other products acting as gateways to the APPC connection, but this is the most common configuration that will be found in the field at this time.

Parent topic: Configuring DLC over 802.2 on Windows 95


Step 1: Downloading MSDLC32.EXE

The DLC driver that was released with Windows '95 is a 16-bit driver. You will need to obtain the 32-bit DLC driver for Windows '95 from Microsoft. This can be done by accessing the Microsoft web site and searching for the file named MSDLC32.EXE. After downloading the file create a diskette and extract the contents by running MSDLC32.EXE. This file is a self-extracting zip file. This diskette can then be used to add a protocol. You will need to have your original Windows '95 CD or diskettes available during the installation as the DLC protocol will require additional operating system support files to be loaded.

Parent topic: Configuring DLC over 802.2 on Windows 95
Related information
Microsoft web site


Step 2: Select Network from the Control Panel

Select Start from the Taskbar, then Settings, then Control Panel. Once the Control Panel is displayed, select the Network Icon by double-clicking.

Parent topic: Configuring DLC over 802.2 on Windows 95


Step 3: Adding a Protocol

Select Add from the Network window by clicking on the Add button.

Parent topic: Configuring DLC over 802.2 on Windows 95


Step 4: Select Component Type

Select protocol from the Network Component Type Window and click the Add button.

Parent topic: Configuring DLC over 802.2 on Windows 95


Step 5: Select Have Disk

Select Have Disk by clicking on the Have Disk button, you should have the diskette that contains the unzipped contents of the MSDLC32.EXE file in the diskette drive of your computer. You will then see a selection that reads Microsoft 32-bit DLC. Select this protocol to be added and follow the prompts. Windows '95 will require that you have available the original Windows '95 CD or diskettes so that additional support drivers can be loaded. The screen below is from a system that has already had the driver loaded and is presented so that we can illustrate that fact that there will be a Microsoft DLC driver available without loading the MSDLC32.EXE file from diskette. THIS DRIVER WILL NOT WORK WITH ANY OF THE SUPPORTED APPC PRODUCTS AND IS NOT SUPPORTED BY MICRO FOCUS. As you can see below, the 32-bit DLC driver clearly states this in the Network Protocol window and you should verify that this is the DLC stack being used if a customer indicates that they have loaded the DLC drivers and they are still having problems.

Parent topic: Configuring DLC over 802.2 on Windows 95


Step 6: Finishing up and Restarting Windows '95

After following all of the prompts from Windows '95 and loading the additional support drivers from the Windows '95 distribution disks, you should be prompted to restart Windows '95. You should allow Windows '95 to restart, this allows the new DLC protocol stack that you have installed to become active. ALL ERROR MESSAGES ARE RELEVANT. YOU SHOULD NOT IGNORE ANY ERRORS YOU RECEIVE EITHER IN LOADING THE ADDITIONAL SUPPORT FILES FROM WINDOWS '95 OR WHEN RESTARTING THE MACHINE. IF YOU RECEIVE AN ERROR THEN THE STACK IS NOT INSTALLED PROPERLY OR THERE WAS A PROBLEM IN COPYING A FILE. YOU SHOULD TRY REMOVING THE STACK AND REINSTALLING.

Parent topic: Configuring DLC over 802.2 on Windows 95


Configuring DLC over 802.2 on Windows NT

  • Installing DLC for Windows NT
  • Step 1: The Microsoft 32-bit DLC Driver
  • Step 2: Select Network from the Control Panel
  • Step 3: Adding a Protocol
  • Step 4: Select Network Protocol
  • Step 5: Specify the Location of the Windows NT Files
  • Step 6: Finishing up and Restarting Windows NT
Parent topic: Configuring CCI
Related information
Configuring CCI Introduction
CCI Support for APPC
APPC Configuration
Application Configuration
CCIIPX Configuration
CCINETB Configuration
CCITCP Configuration
CCINAMPU Configuration
Application Configuration
CCI Trace
CCI.INI - The CCI Configuration File
CCI Status Messages
Attachmate Personal Client v6.3
Attachmate Personal Client v6.1 and v6.2
IBM Communications Server v5.01 for Windows NT
IBM Personal Communications v4.2 for Windows 95 and Windows NT
Microsoft SNA Server v3.0
Microsoft SNA Server v2.11
Rumba Office 95/NT
Support for Attachmate EXTRA! Personal Client
Configuring DLC over 802.2 on Windows 95


Installing DLC for Windows NT

The Rumba and Attachmate EXTRA! products require the Microsoft 32-bit DLC protocol to provide support for an APPC connection over 802.2. There are other possible configuration options using other products acting as gateways to the APPC connection, but this is the most common configuration that will be found in the field at this time.

Parent topic: Configuring DLC over 802.2 on Windows NT


Step 1: The Microsoft 32-bit DLC Driver

The DLC driver that was released with Windows NT is the required 32-bit driver. Unlike Windows '95 which requires you to download a specific driver to obtain 32-bit support, the driver that is supplied with Windows NT will work with all of the supported APPC providers products. You will notice that there is no special designation for 32-bit as there is under Windows '95.

Parent topic: Configuring DLC over 802.2 on Windows NT


Step 2: Select Network from the Control Panel

Select Start from the Taskbar, then Settings, then Control Panel. Once the Control Panel is displayed, select the Network Icon by double-clicking.

Parent topic: Configuring DLC over 802.2 on Windows NT


Step 3: Adding a Protocol

Select the Protocols tab from the Network window and click on the Add button.

Parent topic: Configuring DLC over 802.2 on Windows NT


Step 4: Select Network Protocol

Select DLC protocol from the Network Protocol Window and click the OK button.

Parent topic: Configuring DLC over 802.2 on Windows NT


Step 5: Specify the Location of the Windows NT Files

Windows NT will require that you have available the original Windows NT CD or diskettes so that additional support drivers can be loaded. Specify the drive and directory location of the Windows NT files (e.g. a:\i386, f:\i386, etc.) and click on the Continue button. The files for the DLC protocol will then be installed.

As you can see below, the 32-bit DLC driver is now present in the Protocol window. You should verify that this is the DLC stack being used if a customer indicates that they have loaded the DLC drivers and they are still having problems.

Parent topic: Configuring DLC over 802.2 on Windows NT


Step 6: Finishing up and Restarting Windows NT

After following all of the prompts from Windows NT and loading the additional support drivers from the Windows NT distribution disks, you should be prompted to restart Windows NT. You should allow Windows NT to restart, this allows the new DLC protocol stack that you have installed to become active. ALL ERROR MESSAGES ARE RELEVANT. YOU SHOULD NOT IGNORE ANY ERRORS YOU RECEIVE EITHER IN LOADING THE ADDITIONAL SUPPORT FILES FROM WINDOWS NT OR WHEN RESTARTING THE MACHINE. IF YOU RECEIVE AN ERROR THEN THE STACK IS NOT INSTALLED PROPERLY OR THERE WAS A PROBLEM IN COPYING A FILE. YOU SHOULD TRY REMOVING THE STACK AND REINSTALLING.

Parent topic: Configuring DLC over 802.2 on Windows NT


Configuring Environment Variables

You can use Enterprise Server environment variables to configure many server instance environment properties. This section contains information on setting environment variables, and on the environment variables that are available.

Tip: This section contains an alphabetical listing of environment variables, and environment variables listed by functional group. For variable values, check the alphabetical listing, and if this does not contain values, search the online help for the variable name.
  • How Enterprise Server uses Environment Variables
  • Setting Environment Variables
  • Environment Variables by Groups
  • Environment Variables: Alphabetical Order
  • How Enterprise Server uses Environment Variables
  • Setting Environment Variables
  • Environment Variables by Groups
  • Environment Variables: Alphabetical Order
Parent topic: General Reference
Parent topic: Configuring the Server Instance Environment


How Enterprise Server uses Environment Variables

An enterprise server instance's environment depends on the method you use to start the server instance:

  • When you start an enterprise server instance from the Enterprise Server Administration user interface, it inherits its environment from the Directory Server.
  • When you start an Enterprise Server instance from the command line using the casstart command, it inherits its environment from that command-line shell.

This means that all the environment variables that you need to run your servers' workload, including directory settings for third-party software, can be set in the session where you start the Directory Server. If Directory Server is running as a Windows service, it will have the system environment.

You can set environment variables for an enterprise server instance in Configuration Information on the Add Server or Edit Server page. These apply to all services that run in the server.

Any environment variables set at the service level when the service was created using the Interface Mapping Toolkit override the settings at the server level.

The format for environment variables is

[ES-Environment]
environment-variable-name=environment-variable-setting

Use a semi-colon to separate elements within the string on Windows platforms. For example:

  • For Windows:
    [ES-Environment]
COBPATH=c:\adirectory;c:\anotherdirectory
Note:

We recommend that you do not set the COBDIR environment variable for an enterprise server instance, especially on UNIX. This is because $COBDIR is used to point to the product location. The results of setting $COBDIR are undefined. Use the COBPATH environment variable if you want to specify the location of service programs at the enterprise server level. If you do set the COBPATH environment variable at enterprise server level, you also need to specify "$COBPATH" in Package Path in the Add Package or Edit Package page for services that should be located using COBPATH.

When you specify an environment variable, you can use the resolved value of another already-created variable as part of the environment variable value. To do this, prefix the environment variable you want to include with a dollar ($) sign, for example:

  • For Windows:
    FILEROOT=d:\data
FILEA=$FILEROOT\mydata.dat

    For Windows, this resolves to d:\data\mydata.dat

If you want to include a dollar sign in an environment variable value as part of the actual value, rather than as an indicator that another environment variable is being referred to, you can enable the dollar sign character to be escaped by inserting a backslash (\) character, for example:

FILEA=\$\$fsserver1\mydata.dat

For Windows, this resolves to $$fsserver1\mydata.dat

FILEA=\$\$fsserver1/mydata.dat

Because of the function of the backslash (\) character as an escape character, if you want the value of an environment variable to be a UNC path (e.g. \\server\volume\directory\filename), be sure that it starts with four backslash characters - \\\\server\volume\directory\filename - rather than two. Each pair of backslash characters resolves to a single character, yielding the correct two-character sequence as a final result.

Parent topic: Configuring Environment Variables
Parent topic: Configuring Environment Variables


Setting Environment Variables

You can use Enterprise Server environment variables to configure a wide range of settings to be used by enterprise server instances. You can set environment variables to apply to all server instances running on an installation, or to apply to specific server instances only. You can also use environment variables to allocate datasets.

  • Environment variables set at the Micro Focus Directory Server (MFDS) level apply to all Enterprise Server instances controlled by MFDS.
  • Environment variables set at the enterprise server instance level apply to the instance only.

You can set environment variables from the Enterprise Server Administration user interface, or from the command line.

  • Setting Environment Variables for Micro Focus Directory Server
  • To Set Environment Variables from the User Interface
  • To Set Environment Variables from the Command Line
  • To Specify Dataset Allocation Using Environment Variables
  • Setting Environment Variables for Micro Focus Directory Server
  • To Set Environment Variables from the User Interface
  • To Set Environment Variables from the Command Line
  • To Specify Dataset Allocation Using Environment Variables
Parent topic: Configuring Environment Variables
Parent topic: Configuring Environment Variables


Setting Environment Variables for Micro Focus Directory Server

When you set environment variables for a Micro Focus Directory Server (MFDS), the environment variables apply to all server instances that the MFDS controls.

Note: Environment variables set at the Enterprise Server instance level override any corresponding environment variables set at the MFDS level.

Under Windows, from a command shell you can use the net start command to start MFDS. However, environment variables set in the current command shell’s environment are inherited by the net.exe command, but they are NOT inherited by the MFDS service.

The net start command sends a message to the Windows service controller requesting that it start MFDS. The service controller starts the mfds.exe process, and MFDS inherits its environment.

To change the environment for the MFDS Windows service process, you need to change the system environment on the machine on which the service runs, for example using the System control panel, or by editing it in the Registry.

After you have made the changes, reboot the machine so that the Service Manager configures the new environment.

Parent topic: Setting Environment Variables
Parent topic: Setting Environment Variables


To Set Environment Variables from the User Interface

From the Enterprise Server Administration user interface, you can set environment variables to apply to each server instance that the interface displays.
  1. From the Enterprise Server Administration page, click the Edit button that corresponds to the enterprise server instance to configure.
  2. Select the Server > Properties > General tabs.
  3. In the Configuration Information text box, type: [ES-Environment]
  4. Enter the environment variable information to configure, using a separate line for each variable to configure.

    Enter the information in the form:

    <variable name>=<value>

  5. Click OK to apply the settings to the server instance.

For example, to configure that an enterprise server instance uses the EBCDIC character set, you would enter the following

[ES-Environment]
MF_CHARSET=EBCDIC
Parent topic: Setting Environment Variables
Parent topic: Setting Environment Variables


To Set Environment Variables from the Command Line

Before starting an Enterprise Server instance from the command line, you can set environment variables to apply to the Enterprise Server instance.
From the command line, set the environment variables:

For example, to set that the Enterprise Server instance uses the EBCDIC character set, use the following commands:

  • In the Windows environment:
    set MF_CHARSET=EBCDIC
Parent topic: Setting Environment Variables
Parent topic: Setting Environment Variables


To Specify Dataset Allocation Using Environment Variables

To configure datasets, you can specify the full path for each dataset accessed by Enterprise Server. However this is cumbersome and can make it difficult to move between test and production environments that have different directory structures.

To reduce the effort required when the system uses large numbers of data files, you can set environment variables to define the datasets that an Enterprise Server instance uses:

  1. From the Enterprise Server Administration page, click the Edit button that corresponds to the Enterprise Server instance to configure.
  2. Select the Server > Properties > General tabs.
  3. In the Configuration Information text box, type: [ES-Environment]
  4. Configure the datasets to use with the ENVIRONMENTVAR=path syntax where:
    • ENVIRONMENTVAR is the name of the environment variable you are creating
    • path is the full path, including the drive letter, to the dataset.

    You can create as many environment variables as you need to cover all of the paths you want to specify.

  5. When you have defined the datasets, click OK. The settings are applied to the Enterprise Server instance.
  6. In the catalog, when allocating datasets using the %PCDSN option to specify a physical file, you can substitute an environment variable that you defined to represent the path to the file. Prefix environment variable names with a dollar sign ($): $ENVIRONMENTVAR

    For example, you could create an environment variable named PRODDATA and set its value to d:\mydataset.

    Then, to allocate a dataset in the catalog for a file named MFIO1.SAMPLE.DATA, you would use this code:

     //*MFE:%PCDSN='$PRODDATA\MFI01.SAMPLE.DATA'
Parent topic: Setting Environment Variables
Parent topic: Setting Environment Variables


Environment Variables by Groups

The following sections list the environment variables by functional group.

Note: The Environment Variables: Alphabetical Order topic contains the values for most environment variables.
  • Assembler Environment Variables
  • CCI Environment Variables
  • CICS-Specific Environment Variables
  • Enterprise Server Communications Environment Variables
  • File Handling and Dataset Environment Variables
  • IMS-Specific Environment Variables
  • Input, Output and Display Environment Variables
  • JCL-Specific Environment Variables
  • Mainframe Access Environment Variables
  • PL/1-Specific Environment Variables
  • Security and Auditing Environment Variables
  • SORT Engine Environment Variables
  • Tracing and Debugging Environment Variables
  • Reserved Environment Variables
  • Assembler Environment Variables
  • CCI Environment Variables
  • CICS-Specific Environment Variables
  • Enterprise Server Communications Environment Variables
  • File Handling and Dataset Environment Variables
  • IMS-Specific Environment Variables
  • Input, Output and Display Environment Variables
  • JCL-Specific Environment Variables
  • Mainframe Access Environment Variables
  • PL/1-Specific Environment Variables
  • Security and Auditing Environment Variables
  • SORT Engine Environment Variables
  • Tracing and Debugging Environment Variables
  • Reserved Environment Variables
Parent topic: Configuring Environment Variables
Parent topic: Configuring Environment Variables


Assembler Environment Variables

These environment variables are used to configure the component locations for Assembler. You can use STEPLIB and SYSLIB to configure multiple paths. The rest can set a single path only.

Variable | Description
ES_MFASM_SUPPORT | Enables Assembler support when running CICS server regions.
STEPLIB | The paths for Loader input load-members .390 files (must contain SYSLMOD).
SYSIN | The path for macro input .MLC files.
SYSLIST | The path for Assemble and Link listing files: .MAT, .PRN, and .LST.
SYSWORK | The path for Assemble, Link and Animator/370 work files .BAL .IDF/.IDX .
SYSPUNCH | The path for Assemble output .PCH files for PUNCH statements .
SYSMPC | The path for Assemble input precompiled macros: .MPC .
SYSLIB | The paths for Assemble input macro and copy files .MAC .CPY .
SYSLIN | The path for Link input .LIN files and Assemble output .OBJ files .
SYSLMOD | The path for Link output load-member .390 files .
SYSPARM | The path for the Macro input SYSPARM value.
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


CCI Environment Variables

This topic lists environment variables that relate to CCI.

Generic environment variable | Description
CCITIMEOUT Allows the specification, in tenths of seconds, of the maximum time out period that will be used with any CCI based application, such as Drag and Drop, SourceConnect, FileShare or the Compare and Syncronisation Monitor. The default is 2 minutes (1200), and the maximum value that can be used is 2,147,483,647. For example to set this value to 4 minutes:

SET CCITIMEOUT=2400

CCIERRLOG | Specifies the output location and filename of ccierr.log content which tracks first-instance errors reported from the operating systems. CCIERRLOG overrides any entries found in CCI.INI, where the syntax and content is explained in detail.
CCITRACE Specifies the level of CCI tracing

Values

Filename for and trace output and the trace options. The trace options are as follows:

Note: In all options, / or - must prefix the option. That is, /OFF is the same as -OFF.
  • /OFF

    Switches all CCI tracing off regardless of CCI.INI settings.

  • /N

    Do not trace any user data in the output. Only trace system activity.

  • /D

    Logs the contents of all buffers passed to and from the CCI functions. The default condition for this option is OFF. Data tracing may not be allowed if the application has been coded to prohibit data tracing for security reasons.

  • /F

    Logs the details of CCI API calls to the trace file. The default condition for this option is OFF, unless a filename or any other trace option are specified, in which case it is always ON.

  • /P

    Logs the details of protocol level calls to the trace file. If this flag is not ON, then only the details of the CCI user level API will be traced. If this flag is ON, the level of function tracing may be greatly increased. The default condition for this option is OFF.

TCP/IP specific variables | Description
CCITCP2 | Locates the TCP/IP registration program. Values: The hostname or the IP address of the machine hosting the CCITCP2 registration program.
CCITCP2_PORT | The port that is being used for the registration process. Values: The port on which the CCITCP2 registration program operates.
Secure Connection (SSL) specific variables | Description
RANDOM | If using SSL connections, externally generated random data that is stored as a numeric value in the RANDOM variable will be inserted into the initial salt value used to generate temporary key pairs used in SSL hand-shaking. The RANDOM value will only form part of the initial salt value and is an aid to generating more randomness and not an essential requirement.
COBSSL | If using SSL connections specifies the location of the DemoCA directory. If not found, SSLDIR is inspected instead.
SSLDIR | If using SSL connections specifies the generic location of the system's OpenSSL directory.
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


CICS-Specific Environment Variables

These environment variables relate to configuring the CICS environment.

Note: The Environment Variables: Alphabetical Order topic contains the values for most environment variables.
Variable | Description
CICS_SIT | The name of the SIT used by the region
ES_CICS_SINGLE | Configures CICS so that a user can only log on once
ES_CLASS_XPCT | Overrides the default CICS PCT resource class
ES_CLASS_XCMD | Overrides the default CICS CMD resource class
ES_CLASS_XDCT | Overrides the default CICS DCT resource class
ES_CLASS_XFCT | Overrides the default CICS FCT resource class
ES_CLASS_XJCT | Overrides the default CICS JCT resource class
ES_CLASS_XPPT | Overrides the default CICS PPT resource class
ES_CLASS_XPSB | Overrides the default CICS PSB resource class
ES_CLASS_XRES | Overrides the default CICS DOCTEMPLATE resource class
ES_CLASS_XTST | Overrides the default CICS TST resource class
ES_CLASS_XTRAN | Overrides the default CICS TRAN resource class
ES_ESM_CMDSEC | Indicates whether CICS processing honors the CMDSEC option specified on a transaction's PLT definition
ES_ESM_PLTPIUSR | The user id under which PLT programs run during CICS initialization
ES_ESM_RESSEC | Indicates whether CICS processing honors the RESSEC option specified on a transaction's PLT definition
ES_ESM_SECPRFX | Indicates whether CICS processing prefixes the resource names when making security queries
ES_ESM_XUSER | Indicates whether CICS processing performs surrogate user checks
ES_EZASOKET_SUPPORT | Switches on EZASOKET support
ES_INQFILE_RETURN | Modifies EXEC CICS INQUIRE FILE behavior
ES_LE370_SUPPORT | Enables support for Language Environment (LE) in CICS applications
ES_MQ_1PC | Indicates whether the MQSeries switch module ESMQXA should operate in one-phase commit mode. Only set this when advised to do so by Micro Focus.
ES_MQ_LIB The full name including the path of the IBM MQ client or server library.
Important: In AIX environments the library is an object inside a shared object. For example
ES_MQ_LIB="/usr/mqm/lib64/libmqmxa64.a(libmqm64.o)"
ES_MQ_LIB_T | The full name including the path of the IBM MQ client or server library, for threaded environments
ES_MQ_LIB_XA The full name including the path of the IBM MQ XA library
Important: In AIX environments the library is an object inside a shared object. For example:
ES_MQ_LIB_XA="/usr/mqm/lib64/libmqmxa64.a(libmqmxa64.o)"
ES_MQ_LIB_XA_T | The full name including the path of the IBM MQ XA library, for threaded environments
ES_MQ_XA | Specifies whether the two-phase commit protocol uses a static or dynamic XA structure
ES_PLI_SUPPORT | Tells the CICS Emulation that it needs to load its subsystem support for PL/I user programs. The default value is "N".
ES_SSTM_CICS | Location of the JCL used to initialize the SSTM CICS environment
ES_SURROGATE_JOB_USER | Associates a user ID with a job when submitting the job for processing through the internal reader from CICS
ES_USR_DFLT_CICS | Allows you to override the default user when no user is logged on for CICS authentication
ES_XA_RECONNECT | If this environment variable is set, when an error occurs on a call to XA, the server recycles the SEP and attempts to reconnect to the Resource Manager.
ES_xxxxx_NB_RETRIES | Specifies the number of times a SEP attempts to reconnect to an XA resource following a connection error, where xxxxx is the ID of the associated resource. The default is 5. If no connection is made, the XA switch is disabled.
TXTRANP | The location of the CICS application object files.
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


Enterprise Server Communications Environment Variables

These environment variables relate to configuring the input and output and the display.

Note: The Environment Variables: Alphabetical Order topic contains the values for most environment variables.
Variable | Description
CCITCP2 | Locates the TCP/IP registration program
CCITCP2_PORT | The port that is being used for the registration process
CCITRACE | Specifies the level of CCI tracing
ES_CAS_API | Indicates whether casout or cassub has been executed by a call and not from the command line
ES_CONSOLE_LOG | Sends console messages to the Windows Event Log
ES_CSKL_NO_MSG_CONSOLE | Stops CSKL writing messages to console.log
ES_ESMAC_DISP_MAX_OVERRIDE | The number of items displayed in the ESMAC catalog view
ES_LEGACY_ECI | Indicates that Enterprise Server must use ES dfhtex32 instead of IBM CTG
ES_MAX_CATALOG_LINES | Restricts the number of entries displayed in ESMAC catalog view
ES_MEM_STRATEGY | Selects the types of memory processes supported
ES_OTMA_TIMEOUT | The time that an OTMA client should wait for an answer
ES_SEP_DORMANT_TIME | Allows override of Transient SEP dormant time
ES_SERVER | Server name (used if no -r switch is specified on casstart or casstop).
ES_SYSOUT_HOLD | Message classes to route to the Out Hold queue
ES_TN3270_FORCE_ALT | Enables you to use a screen size other than the default when using a TN3270 terminal emulator
ES_TN3270_MODEL_LOG | Writes the TN3270 emulator's model name to a temporary storage queue named TN32MODL that can be viewed using the CEBR transaction
ES_USR_DFLT_CICS | Allows you to override the default user when no user is logged on for CICS authentication
ES_USR_DFLT_ESMAC | Allows you to override the default user when no user is logged on for ESMAC authentication
ES_USR_DFLT_JES | Allows you to override the default user when no user is logged on for JES authentication
ES_WS_RUNAWAY_TIMEOUT | Time in seconds that the client will wait for a response from the web service. Only applies when using Net Express to deploy an application.
ISPPROF | The location of ISPF dialog profiles
JAVA_HOME | Locates the JDK
LANG | Specifies the language environment
LINES | Specifies screen depth
LD_LIBRARY_PATH | Locates shared libraries (applies to all operating systems except HP/UX PA-RISC 32 bit and AIX)
LIBPATH | Locates shared libraries (applies to AIX only)
MAINFRAME_FLOATING_POINT | Specifies the format to use for floating point data items
MF_AMODE31ONLY | Indicates that all programs are AMODE(31)
MF_CHARSET | Specifies the system character set (ASCII or EBCDIC)
MF_USESCA5 | Specifies that the server should use version 5 of the Open Service Component Architecture
MF_SPOOL_ARCHIVE_LOC | The location of the file where the contents of the MVS SPOOL spool file are copied prior to deletion
MF_USESCA7 | Specifies that the server should use version 7 of the Open Service Component Architecture
MFCODESET | Specifies which translation tables to use. See Environment Variables: Alphabetical Order for more details.
MFCSCFG | A configuration file to be used by the client/server binding client program
MFEXTMAP | Location of a mapper file
MFLOGDIR | Log file directory
MFLECONFIG | A configuration file for Language Environment (LE) run-time options
MFPRELOAD_USE | Calls MFPRELOAD to improve perfomance
MFSUB | Specifies whether to use SUBI or ASUBI
MFSCPY | The location of copybook files for MFSGEN utility
MFSYSCATDIR | The location of the system catalog directory
MFUSER | Default user ID
MFUSERCAT_LOC | The fully-qualified name of the SMS dataset
MQSERVER | The location of an MQSeries Server installation.
MULTMFENTMAP | Specifies whether special characters such as < and & are replaced with the equivalent HTML entities (for example &lt; and &amp;)
OOSW | OO run-time switches
PATH | Locates directories for all UNIX programs
PSBCPY | The location of copybook files for PSBGEN utility.
SHLIB_PATH | Locates shared libraries (applies to HP/UX only)
TERM | Specifies terminal type
TERMINFO | Locates the UNIX system terminfo database
TMPDIR | Locates the directory for temporary files
TX_TN3270_FORCE_ALT | Enables you to use a screen size other than the default when using a TN3270 terminal emulator
TXMAPP | The location of the BMS load module
TXRDTP | The location of MSS resource definition (RDO) files.
USER | Default user name
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


File Handling and Dataset Environment Variables

This topic lists environment variables that relate to configuring the file and dataset handling.

Note: The Environment Variables: Alphabetical Order topic contains the values for most environment variables.
Variable | Description
COBDATA | Specifies the directory or directories that the run-time system is to search for data files. Provides you with the facility to map data files globally, thus enabling you to put working data files in a directory whose name is not known until run time.
COBEXTFHBUF | Specifies that fixed-length sequential files are buffered.
DB2DBDFT | The default database for the DB2 SQL precompiler to process SQL statements against
ES_RLS_FILE_SUPPORT | Stops dirty records being returned when a record is locked by another process.
EXTFH | Specifies a configuration file for the Callable File Handler
FHREDIR | A configuration file to be used by the Fileshare Client
FS | A configuration file to be used by the Fileshare Server
FSCOMMS | Specifies that the Fileshare system is to run in single user mode
GDG.RECALL | Controls the recall of HSM archived datasets when accessing mainframe GDGs using MFA Data Access Services
HCOBND | A directory for DB2 bind files
LIB | The location of the DB2 LIB directory
MFALLOC_LOC | The location of the default allocated dataset
MFALLOC_PROP | Rules for generated PC dataset names on allocation (that is, the default catalog PC DSN format)
MF_NEWSPACE | Indicates whether SPACE is required for NEW datasets
MF_SYSLOGDSN | The Syslog Dataset name
MFLOCKING | Enables Locking Support
PROCLIB | Specifies PROCLIB datasets. This can be a concatenation of PDS names.
TXFILEP | The location of Micro Focus VSAM files
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


IMS-Specific Environment Variables

This topic lists environment variables relate to configuring the IMS environment.

Note: The Environment Variables: Alphabetical Order topic contains the values for most environment variables.
Variable | Description
DBDCPY | The location of copybook files used by the DBDGEN utility
ES_ACBLIB | The location of IMS ACB files
ES_ALLOC_OVERRIDE | The location of a file containing rules that determine where new datasets are created. This applies only to JES and batch files, and not CICS, IMS, or Web services files.
ES_DFS3650 | The default transaction to execute or MOD file to be displayed after successfully signing on to IMS. You specify these by setting environment variables prior to the start of the region: ES_DFS3650 - set to MOD if a MOD file is to be sent, or TRX if a TRANSACTION is to be executed. If you set to MOD, ES_MOD3650 needs to be set to the name of the MOD you want to display. If you set to TRX, ES_TRX3650 needs to be set to the name of the transaction.
ES_IMS_CONFIG | The IMS TM parameters
ES_IMS_DIAGNOSE | Marks IMS TM as diagnose mode only for IMSMSGQ
ES_IMS_DOSVS_PCB | Emulates DOS/VSE PCB address alignment for EXEC DLI programs.
ES_IMS_EXITPATH | The location of compiled code that contains segment and/or field exits
ES_IMS_FORCE_SIGNON | Enables a user to force a sign-on to IMS on the current terminal and sign off from other terminals
ES_IMS_IMSID | Allows the user to specify the IMS System ID returned to the AIBTDLI INQY ENVIRON call
ES_IMS_RCLASS

Creates a set of newly-named IMS security resource classes, appending the variable's value (maximum of seven characters) to each resource class' default character.

Create theses custom-named classes if you are using the same ESM active directory with two Enterprise Server systems and your security needs differ for each.

See Resource Classes for IMS Security for the names of the resource classes created if this variable is not set.

ES_IMS_RELEASE | Allows the user to specify the IMS Release returned to the AIBTDLI INQY ENVIRON call
ES_IMS_REGION | Allows the user to specify the IMS Region returned to the AIBTDLI INQY ENVIRON call
ES_IMS_SUPPORT | Enables IMS support
ES_IMS_TLOG_FILES | Maximum number of IMS DB transaction log files that can be created before they start to be overwritten
ES_IMS_TLOG_MAXSIZE | Maximum size of the IMS DB transaction logging file
ES_IMS_TLOG_PATH | The location of IMS DB transaction logging files
ES_IMS_TLOG_THRESHOLD | Threshold size of the IMS DB transaction logging file
ES_IMSCFG | The location of the IMS configuraton files IMSCONFIG.DAT/.idx
ES_IMSDAT | The location of IMS DB data files
ES_IMSDB_LOCK_RETRY_DELAY | The IMS DB lock retry delay in milliseconds
ES_IMSLIB | The location of DBDGEN2.DAT, DBDGEN2F.DAT and PSBGEN3.DAT files
ES_MFSLIB | The location of the control blocks generated by the MFS generation program
ES_MOD3650 | The default MOD file to be displayed after a successful sign-on to IMS. See ES_DFS3650.
ES_SSTM_IMS | Location of the JCL used to initialize the SSTM IMS environment
ES_TRX3650 | The default transaction to run after a successful sign-on to IMS. See ES_DFS3650.
ES_USR_DFLT_IMS | Allows you to override the default user when no user is logged on for IMS authentication
ICONN1 | Controls the client TCP connection status of an IMS Connect emulator
IMSCFG | Defines the location of IMS configuration files IMSCONFIG.DAT/.idx
IMSCPY | The location of copybook files for DBDGEN, PSBGEN and MFSGEN utilities
IMSDAT | The location of IMS DB data files
IMSLIB | The location of DBDGEN2.DAT, DBDGEN2F.DAT and PSBGEN3.DAT files
IMSNET | The location of network read-only IMS DB data files
IMSWRK | The location of the work directory for temporary files
MFIMS_ACBDUMP_TIMESTAMP | Suppresses date/time stamp display in ACB report
MFIMS_BMPCHKP | Returns a QC to a checkpoint call when it the call includes an IO area
MFIMS_DIBSTAT_CODES | Specifies additional DIBSTAT return codes to be returned to EXEC DLI program
MFIMS_DLI_OPT | Specifies DL/I call optimization flags
MFIMS_DIAG | Enables IMS BTS format diagnostic tracing
MFIMS_FLUSHTRACE | Flushes BTS trace file to disk after every write
MFIMS_FP_DA | Bypasses keycheck on IMS Fastpath DB delete
MFIMS_LOADMVS | Disables load of MVS support for IMS application programs
MFIMS_PCBCALL | Allows a standalone EXEC DLI program to issue a PCB call
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


Input, Output and Display Environment Variables

These environment variables relate to configuring the input and output and the display.

Note: The Environment Variables: Alphabetical Order topic contains the values for most environment variables.
Variable | Description
CCITCP2 | Locates the TCP/IP registration program
CCITCP2_PORT | The port that is being used for the registration process
CCITRACE | Specifies the level of CCI tracing
COBAIF | Locates .aif files
COBAIFNAME | The basename of .aif files
COBATTR | Specifies non-standard behavior for HIGHLIGHT and LOWLIGHT clauses used with ACCEPT and DISPLAY statements. It provides compatibility with earlier COBOL products.
COBCONFIG | Specifies a run-time configuration file that tailors the run-time configurable options in some way.
COBCONFIGJVM | Specifies a Java properties file that tailors the run-time configurable options for Java Virtual Machine applications.
COBCONFIG.BLOCK | The location of the application configuration file
COBDIR | Specifies the directory where the required Micro Focus COBOL system is installed. Many of the COBOL system components and utilities require and use this information. If the COBDIR environment variable is not set then the COBOL system acts as if it had been set to the default COBOL system directory.
COBKEYTIMEOUT | Maximum elapsed time, in tenths of a second, for the connected terminal to transmit any valid escape sequence to the run-time system.
COBLANG | The language environment in which your COBOL program runs
COBLPFORM | Logical printer channels
COBMAINSTACK | The size of the main stack
COBMODE | Whether to start the server in 32-bit or 64-bit mode
COBOPT | User default Cob utility options
COBPATH | The location of programs for dynamic loading
COBPRINTER | Specifies the name of a print spooler that is to receive, via its standard input stream (stdin), output from any DISPLAY UPON PRINTER statement.
COBPRFDIR | Location of .ipf files created by programs compiled with the PROFILE compiler directive
COBSES | The UNIX Session Recorder functions to perform
COBSW | Run-time system switch settings for the run-time system to observe when running an application
COBTERMINFO | The directory or directories to be searched by the run-time system for a terminfo database of terminal information tailored to the needs of COBOL applications. This enables COBOL applications to use different terminfo settings to those used by non-COBOL applications, such as vi, when using the same terminal.
COLUMNS | Specifies screen width
ES_CAS_API | Indicates whether casout or cassub has been executed by a call and not from the command line
ES_CONSOLE_LOG | Sends console messages to the Windows Event Log
ES_CSKL_NO_MSG_CONSOLE | Stops CSKL writing messages to console.log
ES_ESMAC_DISP_MAX_OVERRIDE | The number of items displayed in the ESMAC catalog view
ES_LEGACY_ECI | Indicates that Enterprise Server must use ES dfhtex32 instead of IBM CTG
ES_MAX_CATALOG_LINES | Restricts the number of entries displayed in ESMAC catalog view
ES_MEM_STRATEGY | Selects the types of memory processes supported
ES_OTMA_TIMEOUT | The time that an OTMA client should wait for an answer
ES_SEP_DORMANT_TIME | Allows override of Transient SEP dormant time
ES_SERVER | Server name (used if no -r switch is specified on casstart or casstop).
ES_SYSOUT_HOLD | Message classes to route to the Out Hold queue
ES_TN3270_FORCE_ALT | Enables you to use a screen size other than the default when using a TN3270 terminal emulator
ES_TN3270_MODEL_LOG | Writes the TN3270 emulator's model name to a temporary storage queue named TN32MODL that can be viewed using the CEBR transaction
ES_USR_DFLT_CICS | Allows you to override the default user when no user is logged on for CICS authentication
ES_USR_DFLT_ESMAC | Allows you to override the default user when no user is logged on for ESMAC authentication
ES_USR_DFLT_JES | Allows you to override the default user when no user is logged on for JES authentication
ISPPROF | The location of ISPF dialog profiles
JAVA_HOME | Locates the JDK
LANG | Specifies the language environment
LINES | Specifies screen depth
LD_LIBRARY_PATH | Locates shared libraries (applies to all operating systems except HP/UX PA-RISC 32 bit and AIX)
LIBPATH | Locates shared libraries (applies to AIX only)
MAINFRAME_FLOATING_POINT | Specifies the format to use for floating point data items
MF_AMODE31ONLY | Indicates that all programs are AMODE(31)
MF_CHARSET | Specifies the system character set (ASCII or EBCDIC)
MF_USESCA5 | Specifies that the server should use version 5 of the Open Service Component Architecture
MF_SPOOL_ARCHIVE_LOC | The location of the file where the contents of the MVS SPOOL spool file are copied prior to deletion
MF_USESCA7 | Specifies that the server should use version 7 of the Open Service Component Architecture
MFCODESET | Specifies which translation tables to use. See Environment Variables Alphabetical Order for more details.
MFCSCFG | A configuration file to be used by the client/server binding client program
MFEXTMAP | Location of a mapper file
MFLOGDIR | Log file directory
MFLECONFIG | A configuration file for Language Environment (LE) run-time options
MFPRELOAD_USE | Calls MFPRELOAD to improve perfomance
MFSUB | Specifies whether to use SUBI or ASUBI
MFSCPY | The location of copybook files for MFSGEN utility
MFSYSCATDIR | The location of the system catalog directory
MFUSER | Default user ID
MQSERVER | The location of an MQSeries Server installation.
MULTMFENTMAP | Specifies whether special characters such as < and & are replaced with the equivalent HTML entities (for example &lt; and &amp;)
OOSW | OO run-time switches
PATH | Directories to be searched for all UNIX programs
PSBCPY | The location of copybook files for PSBGEN utility.
SHLIB_PATH | Locates shared libraries (applies to HP/UX only)
TERM | Specifies terminal type
TERMINFO | Locates the UNIX system terminfo database
TMPDIR | Locates the directory for temporary files
TX_TN3270_FORCE_ALT | Enables you to use a screen size other than the default when using a TN3270 terminal emulator
TXMAPP | The location of the BMS load module
TXRDTP | The location of MSS resource definition (RDO) files.
USER | Default user name
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


JCL-Specific Environment Variables

This topic lists environment variables relate to configuring the JCL environment.

Note: The Environment Variables: Alphabetical Order topic contains the values for most environment variables.
Variable | Description
CASRDO44_NEWSUB | Enables access to JCL files held on the local machine on which the browser is running
CASSUB_JN_OVERWRITE | Enables job numbers to be reused without their job information being deleted manually or via automated spool housekeeping
ES_JES_BYTES | Maximum number of bytes to output in a job before taking the action specified (either cancelling the job, cancelling the job and dumping memory contents, or issuing a warning message)
ES_JES_CARDS | Maximum number of cards to output in a job before taking the action specified (either cancelling the job, cancelling the job and dumping memory contents, or issuing a warning message)
ES_JES_DISABLE_RESTART_FLUSH | Indicates whether a region's jobs are moved from the Active queue to the Output Hold queue when a region is restarted
ES_JES_LEVEL | Sets the default JCL type to JES2, JES3 or VSE
ES_JES_LINES | Maximum number of lines to output in a job before taking the action specified (either cancelling the job, cancelling the job and dumping memory contents, or issuing a warning message)
ES_JES_OUTLIM | Maximum number of lines to output to a particular dataset before calling the user exit, processing any global limits, and then cancelling the job
ES_JES_PAGES | Maximum number of pages to output in a job before taking the action specified (either cancelling the job, cancelling the job and dumping memory contents, or issuing a warning message)
ES_JES_RESTART | Enables JCL restart processing
ES_PL1_MFFH_JCL | Enables you to run Open PL/I programs that access JCL data definitions. The default value is "N".
ES_SSTM_CICS | Location of the JCL used to initialize the SSTM CICS environment
ES_SSTM_IMS | Location of the JCL used to initialize the SSTM IMS environment
ES_SYSOUT_HOLD | Sysout held classes
ES_USR_DFLT_JES | Allows you to override the default user when no user is logged on for JES authentication
MF_ALIAS | Specifies program aliases. Each set (pair) is 16 characters long - 8 characters for the program-name, and 8 characters for the alias.
MF_DUPJOBS | Enables jobs with identical names to run
MF_FALLTHRUCHECK | Specifies that MSS is to check that the main COBOL program ends by executing a GOBACK or STOP RUN.
MF_MFA Specifies what dataset catalogs are to be searched.
  • ALL - Search for datasets first in the local catalog, and if not found, on the mainframe (default)
  • RJSE - Search for datasets in the local catalog only. No mainframe is performed.
MF_MVSJOB | MVS job number rules
MF_NODD | Specifies what action MSS is to take at run time if a job step uses a file that has not been allocated.
MF_RCCF | Enables Remote Job Step Execution (RJSE)
MF_SMS | Enables SMS support
MF_SPOOL_HK_TESTDATE | Spool housekeeping testing date override
MF_UCC11 | Enables emulation of UCC11, a third party add-on to the mainframe that affects data set disposition processing. If UCC11 is enabled, a data set disposition of NEW is accepted even if the data set already exists.
MFREXX_LSEQ_RECSIZE_MAX | Specifies the record length for the REXX EXECIO command when reading or writing a line sequential file that has been cataloged with a record length of zero.
MFREXX_NOT | Specifies one or more characters to be used for the NOT operator in addition to REXX's default, which is "¬".
MFREXX_OR | One or more characters to be used for the OR operator in addition to REXX's default, which is "|".
MFSYSCAT | The location of the JES system catalog.
MFUSERCAT_LOC | User catalog location
VSE_STARTUP_CFG | The location of the VSE JCL configuration file
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups
Related reference
JOB Statement Extensions


Mainframe Access Environment Variables

These environment variables relate to the Mainframe Access functionality.

AUTOCAT_IMP
Name of an input file name for automated catalog import using MFA Data Access Services.
Values
  • An input file path and name.
CCITIMEOUT

Allows the specification, in tenths of seconds, of the maximum time out period that will be used with any LSC style application, such as Drag and Drop, SourceConnect, or the Monitor. The default is 2 minutes (1200), and the maximum value that can be used is 2,147,483,647.

Example for setting this value to 4 minutes:
SET CCITIMEOUT=2400
COBCPY
Specifies the directory or directories that the Compiler and Animator should search for copyfiles.
Values
  • A list of search directories, each item separated by a semicolon.
DBG_MVSPSKEL
The skeleton JCL for debugging
ENTRYNAMEMAP
Location of the mfentmap.dat entry name map file.
Values
  • File path and name of the mfentmap.dat entry name map file.
GDG.RECALL
Controls the recall of HSM archived datasets when accessing mainframe GDGs using MFA Data Access Services.
HELP
The location of IBM PL/I help files
HOST_DISP
Determines whether JCL DISP will be honored for DELETE on mainframe resident datasets.
HOST_NEW
Determines whether JCL looks on the host for new datasets that are not cataloged locally.
MF_SET_USERID
Sets the default user ID.
MAINFRAME_FLOATING_POINT
Specifies the format to use for floating point data items.
Values
  • true specifies that IBM hexadecimal format floating point data items are to be used.
  • false specifies that IEEE format floating point data items are to be used.
Note:
  • Setting MAINFRAME_FLOATING_POINT to anything other than true has the same effect as setting it to false.
  • The setting of this environment variable can be overridden by the NATIVE-FLOATING-POINT directive.
MFACLIENTINI
The complete path to the INI file containing mainframe logon credentials, which defaults to:

c:\users\USERNAME\appdata\roaming\micro focus\mfaclient.ini

MFAIMBEDDEDHEX
Indicates that you wish to have all source code embedded hex values handled in the same way as the MDECONV application, in that all translated hex values less than x'1f' will have a null character inserted before the hex value. The COBOL run-time system will properly handle these imbedded hex values. Example:
SET MFAIMBEDDEDHEX=COBOL
MFAMAXHOTLINKS
If using the hot-link software from Micro Focus, the LSC applications will route all communication request through this hot-link. The hot-link remains active to the mainframe until you shut down your workstation, or enter the command MFDAELSC CLOSE. The hot-link is able to allocate and load balance more than multiple simultaneous links and will start up an additional link if any request has to wait for more than 15 seconds for a time slice. The maximum number of simultaneous links can be specified, with a default of 4 and a maximum of 10, as follows:
SET MFAMAXHOTLINKS=4
MFAMAXSENDLENGTH
Sets the maximum length of data, in a single communication packet, that can be transmitted to or from the mainframe. This does not affect the size of the file that can be transmitted, but only the size of each of the numerous data chunks that are transmitted to make up the entire file. This is only useful, when there is a router that limits the transfer length of data to or from the mainframe, or there is a restriction in the length of data that can be transferred. Example:
SET MFAMAXSENDLENGTH=4000
MFASERV
Controls how mainframe access checks for a dataset name (DSN):
  • ON

    If a DSN is not found in the local catalog, then the catalog API calls MFA to check the mainframe for the DSN.

  • Not set

    The catalog API does not call MFA to check the mainframe for the DSN.

MFE.FALLTHRUCHECK
Enables messages to be issued if the user program does not return from a main program via GOBAK or STOP RUN.
MFUSERCAT_NODE
User catalog node
MVSCATIO_TIMEOUT
Time allowed for a catalog input/output operation to complete
NEWJCL
Controls ISPF skeleton JCL processing
SHOW_CATALOG_WAIT
Displays a message when the enterprise server is waiting for a response from the catalog server.
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


PL/1-Specific Environment Variables

This topic lists environment variables relate to configuring the PL-1 environment.

Note: The Environment Variables: Alphabetical Order topic contains the values for most environment variables.
Variable | Description
ES_PL1_MFFH | Enables Micro Focus File Handler to perform all Open PL/I I/O operations. The default value is "Y". If it is set to "N", then all I/O will be routed to old Liant file handlers.
ES_PL1_MFFH_JCL | Enables you to run Open PL/I programs that access JCL data definitions. The default value is "N".
ES_PLI_SUPPORT | Tells the CICS Emulation that it needs to load its subsystem support for PL/I user programs. The default value is "N".
IBM_DBG_LANG | The language the IBM PL/I debugger should use
MF_USE_JAVA_CW | Enables you to use Java CodeWatch for debugging Open PL/I programs.
MFPLI_PRODUCT_DIR | The location of the Open PL/I installation. It is used to find files needed for compiling and linking.
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


Security and Auditing Environment Variables

These environment variables relate to configuring the security and auditing environment.

Note: The Environment Variables: Alphabetical Order topic contains the values for most environment variables.
Variable | Description
ES_CESN_NO_OS390 | Use this variable to override the default behaviour CESN transaction response for invalid user credentials. Default behaviour reports "Your userid is invalid" or "Your password is invalid". Setting this variable to any value will cause CESN to produce an invalid credential message instead.
ES_ESM_PLTPISEC | The level of security checking for PLTPI processing
ES_ESM_RCF | Determines how RACF is used for command authorization
ES_OLD_SEC_TSTD | Prevents security being enforced for TS or TD queues that are not declared in the security repository.
ES_SURROGATE_JOB_USER | Associates a user ID with a job when submitting the job for processing through the internal reader from CICS.
MF_ROOT_CERT | Enables the MF Directory Server process and any client applications to pick up the value of the root certificate file
MFAUDIT_LOGS | The location of audit log files that the auditing sytem generates
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


SORT Engine Environment Variables

This topic lists environment variables that relate to the sorting functionality.

Note: The Environment Variables: Alphabetical Order topic contains the values for most environment variables.
Variable | Description
MFJSENGINE | Specifies which sort engine the utility MFJSORT is to emulate.
MFJSTATS | Specifies to create a report containing statistics for a SORT.
SORTCOMPRESS | Tells the system whether or not to execute a compression routine on each record to be sorted. SORTCOMPRESS=5 allows for run-length encoding of sort records, resulting in much better performance when records contain multiple repeated characters. Note that 5 is the only valid value for this environment variable.
SORTSCHEME | Use in conjunction with SORTSPACE for improved performance. This is activated by setting SORTSCHEME=1. This is the only valid value for the environment variable. See SORTSPACE below for more information.
SORTSPACE | The amount of memory to be allocated to internal workspace for SORT operations. This can be specified in different formats: for example, you could specify 64M, 2G, and 1000000 to give sort memory areas of 64 Megabytes, 2 Gigabytes and 1000000 bytes respectively.
SORTTEMPSPACE | The amount of temporary memory to be allocated to internal workspace for SORT operations. This can be specified in different formats much like the SORTSPACE environment variable. By using SORTTEMPSPACE, you can maximize available memory.
SORTTYPE | Setting SORTTYPE=2 forces SORT to use the file handler, so that format modifications are picked up from the extfh.cfg file. Not setting this means SORT will try to use CBL_ routines to read and write files to improve performance. Note that 2 is the only valid value for this environment variable.
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


Tracing and Debugging Environment Variables

This topic lists environment variables relate to the tracing and debugging functionality.

Note: The Environment Variables: Alphabetical Order topic contains the values for most environment variables.
Variable | Description
CCITRACE | Specifies the level of CCI tracing
COBANIMOPT | Directives to be used by Animator
COBANIMSRV | Attaches Animator to a running program
COBIDY | The location of Animator information (.idy) file for the program being animated if it is not found in the same directory as the intermediate code (.int) file.
CODEWATCH_SRCPATH | The location of source files for the debugger to use if none are found in directories specified when invoking CodeWatch
CODEWATCH_STBPATH | The location of STB files for the debugger to use if none are found in directories specified when invoking CodeWatch
DBG_MVSPSKEL | The skeleton JCL for debugging
ES_DDBG_PORT_RANGE | A range of ports to use for dynamic debugging
MFTRACE_ANNOTATIONS | The location of the Studio Enterprise Edition trace files
MFTRACE_CONFIG | The location of the CTF configuration file
MFTRACE_LOGS | The location of the CTF log files
MFTSO_DEBUG | Controls the display of debug message
TX_MQTRACE | Enables tracing in dfh0mqis for MQSeries calls
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


Reserved Environment Variables

CAUTION:
These variables are for Micro Focus use only and must not be set unless advised to do so by Micro Focus Support Line.
APPCLLU | ASLMFNET | BTRMAXREC
BTRPAGE | CCITCPS_servername | CCITCPT_servername
CHECKER | COBFSTATCONV | COBHNF
COMMIT_COUNT | CPDIR | DEBUGEXIT
DSQUERY | DYNDIR | ES_CESN_NO_OS388
ES_DB_APPLICATION_PLAN | ES_DB_PACKAGE_PATH | ES_DB_PACKAGESET
ES_EMP_EXIT_1(n) | ES_MNM_SUPPORT |
ES_IMS_TRACE | ES_HOME | ES_IDEBIN
ES_LOAD_SWITCH_PLUS | ES_LOG_PERF_EVENTS | ES_STAGING_FOLDER
ES_TSC_TRACE | ES_USR_DFLT_JCL | ES_WORKING_MODE
ES_XDBLIB | FSIDXINTEGRITY | FSSERVER
GCC_LIB | HELPFILES | IBM_DBG_IOCRESFILE
IBM_DBG_LANG | IPF_PATH30 |
MF_JOBDIAG | MF_MVSJOB | MF_ROOT_CERT
MF_SPPOOL_HK_TESTDATE | MFAUTOCTL_XREF_DSN | MFDS_PORT
MFE.AMODE31ONLY | MFEDATA | MFE-TRAP-IMS-AMP
MFIMS_DB_AUTOSTOP | MFJCLHF | MFJCOMPARE.FILE
MFJDEBUG | MFJSENGINE | MFJSTATS
MFJUXITLOG | MFMVSUSER | MFREXX_LSEQ_RECSIZE_MAX
MFREXX_NOT | MFREXX_OR | MFUCC12
NCG | NLS_TIMESTAMP_FORMAT |
 | SSLDIR | TMF
TX_UNICLI_SESSIONS | XFH2BTR | XFH2BTR
XFHNODE | LIBLIST |
Parent topic: Environment Variables by Groups
Parent topic: Environment Variables by Groups


Environment Variables: Alphabetical Order

C

CASRDO44_NEWSUB
Category: General
Enables access to JCL files held on the local machine on which the browser is running.
Values
  • ON

    Access JCL files on the local machine on which the browser is running.

  • OFF

    Access JCL files from the machine running the enterprise server.

CASSUB_JN_OVERWRITE
Enables job numbers to be reused without their job information being deleted manually or via automated spool housekeeping.
Values
  • ON

    Job numbers can be reused without their job information being deleted.

  • OFF

    You must delete job numbers in order to re-use them. This is the default.

CCITIMEOUT

Allows the specification, in tenths of seconds, of the maximum time out period that will be used with any LSC style application, such as Drag and Drop, SourceConnect, or the Monitor. The default is 2 minutes (1200), and the maximum value that can be used is 2,147,483,647.

Example for setting this value to 4 minutes:
SET CCITIMEOUT=2400
CCIERRLOG
Specifies the output location and filename of ccierr.log content which tracks first-instance errors reported from the operating systems. CCIERRLOG overrides any entries found in CCI.INI, where the syntax and content is explained in detail.
CCITCP2
Locates the TCP/IP registration program.
Values
  • The name or the IP address of the machine hosting the CCITCP2 registration program.
CCITCP2_PORT
The port that is being used for the registration process.
Values
  • The port on which the CCITCP2 registration program operates.
CCITRACE
Specifies the level of CCI tracing
Values

Filename for and trace output and the trace options. The trace options are as follows:

  • /F or -F

    Logs the details of CCI API calls to the trace file. The default condition for this option is OFF, unless a filename or any other trace option are specified, in which case it is always ON.

  • /P or -P

    logs the details of protocol level calls to the trace file. If this flag is not ON, then only the details of the CCI user level API will be traced. If this flag is ON, the level of function tracing may be greatly increased. The default condition for this option is OFF.

  • /D or -D

    Logs the contents of all buffers passed to and from the CCI functions. The default condition for this option is OFF. Data tracing may not be allowed if the application has been coded to prohibit data tracing for security reasons.

CICS_SIT
The name of the SIT used by the region.
Values
  • The name of the SIT that the region uses.
COBAIF
The path location of the .aif files.
Values
  • The path where the .aif files are located.
COBAIFNAME
The basename of animator session (.aif) files.
Values
  • The base animator session filename.
COBANIMOPT
Additional directives to be used by Animator.
Values
  • An Animator directive, or a list of directives. Must not be a filename.
COBANIMSRV
Attaches Animator to a running COBOL program.
Values
  • The progid identifier that is used to identify the program to which Animator will attach.
COBATTR

Specifies non-standard behavior for HIGHLIGHT and LOWLIGHT clauses used with ACCEPT and DISPLAY statements. It provides compatibility with earlier COBOL products. You should avoid using it wherever possible as support might be discontinued at some future date.

Values

A value in the range 0 through 7. It can be one of the following values, or a cumulative value; for example, specifying a value of 6 would result in the behavior described for values 4 and 2.

  • 0

    Provides standard, default behavior.

    When a COBOL program displays text subject to a HIGHLIGHT or LOWLIGHT clause, the run-time system uses respectively the bold or dim mode specified in the terminfo entry for the terminal. If the bold or dim mode is not specified, then the HIGHLIGHT or LOWLIGHT clause respectively has no effect.

  • 1

    When a COBOL program displays text subject to a HIGHLIGHT clause, the run-time system uses the bold mode. The run-time system uses the default mode for normal text. Specifying dim mode in the terminfo entry for the terminal has no affect. The LOWLIGHT clause has no effect.

  • 2

    High and low intensity space characters are not assumed to be the same as normal mode space characters.

  • 3

    As for 1 and 2 above

  • 4

    Provides compatibility with default behavior of products before COBOL version 3.2.

    When a COBOL program displays text subject to a HIGHLIGHT clause, the effect depends on whether the dim mode is specified in the terminfo entry for the terminal. If dim mode is specified, then the run-time system uses the default mode for highlighted text and the dim mode for normal text. If the dim mode is not specified, then the run-time system uses the bold mode for highlighted text and default mode for normal text. The LOWLIGHT clause has no effect, giving the same appearance as normal text.

COBCONFIG
Specifies a run-time configuration file that tailors the run-time configurable options in some way.
Values
  • The location of a COBOL runtime configuration file.
COBCONFIGJVM
Specifies a Java properties file that tailors the run-time configurable options for Java Virtual Machine applications.
Values
  • The location of a properties file.
COBCONFIG.BLOCK
The location of the application configuration file.
COBDATA
Specifies the directory or directories that the run-time system is to search for data files. Provides you with the facility to map data files globally, thus enabling you to put working data files in a directory whose name is not known until run time..
Values
  • A list of search directories, each item separated by a semicolon.
COBDIR
Specifies the directory where the required Micro Focus COBOL system is installed. Many of the COBOL system components and utilities require and use this information. If the COBDIR environment variable is not set then the COBOL system acts as if it had been set to the default COBOL system directory.
Values
  • A list of search directories, each item separated by a semicolon.
COBEXTFHBUF
Specifies that fixed-length sequential files are buffered.
Values
  • The buffer size in bytes.
COBIDY
The location of Animator information (.idy) file for the program being animated if it is not found in the same directory as the intermediate code (.int) file.
Values
  • A list of search directories, each item separated by a semicolon.
COBKEYTIMEOUT

Specifies the maximum elapsed time, in tenths of a second, for the connected terminal to transmit any valid escape sequence to the run-time system.

Values
  • Terminal timeout time in tenths of a second.
COBLANG
The language environment in which your COBOL program runs
Values
  • A COBOL language environment (LE) value.
COBLPFORM
Logical printer channels.
Values
  • A valid logical printer channel.
COBMAINSTACK
The size of the main stack.
Values
  • A number in the range 1 through nnn that represents the size of the main stack in bytes.
COBMODE
Whether to start the server in 32-bit or 64-bit mode.
Values
  • 32

    The system starts in 32-bit mode

  • 64

    The system starts in 64-bit mode

COBOPT
User default Cob utility options.
Values
  • environment-variable Any one of the environment variables supported by the COBOL system and listed in this appendix.
  • value The value to which you want to set the specified environment variable.
  • options One or more cob command line options. See the chapter COBOL System Interface (cob) for details on the format of cob options.
  • .ext A filename extension that, in addition to the standard ones of .cob, .CBL, or .cbl, denotes a file that Cob should treat as a COBOL source file. The extension must begin with a period, and if more than one is specified on one line then they must be separated by a space or tab character. You can use more than one cobextn line.
  • pathname The directory that the COBOL system is to search for an options file.
  • filename The name of a file containing cob options.
COBPATH
The path location of programs for dynamic loading.
Values
  • A list of search directories, each item separated by a semicolon.
COBPRINTER

Specifies the name of a print spooler that is to receive, via its standard input stream (stdin), output from any DISPLAY UPON PRINTER statement.

Values
  • A command line supported by your system and that can be executed by the system shell. Typically, it is simply the name of a print spooler or other executable, but if the shell is escaped when setting the value then any command-line arguments can be used.
COBPRFDIR
Location of .ipf files created by programs compiled with the PROFILE compiler directive.
Values
  • A list of search directories, each item separated by a semicolon.
COBSES
The UNIX Session Recorder functions to perform.
Values

COBSES={option[filename]}..., where option can be one or more of the following:

  • -a Include keystrokes made to and screen output from the Animator
  • -f filename Play back recording in fast forward mode
  • -p filename Play back recording in filename at normal speed
  • -r filename Record keystrokes
  • -s filename Record screen output
  • -t terminal number Indicate terminal number for multi-user screen recordings
COBSSL
If using SSL connections specifies the location of the DemoCA directory. If not found, SSLDIR is inspected instead.
COBSW
Run-time system switch settings for the run-time system to observe when running an application.
Values

A list of the runtime switches to set or unset.

  • + sets a switch.
  • - un-sets a switch.
COBTERMINFO
The directory or directories to be searched by the run-time system for a terminfo database of terminal information tailored to the needs of COBOL applications. This enables COBOL applications to use different terminfo settings to those used by non-COBOL applications, such as vi, when using the same terminal.
Values
  • A list of search directories, each item separated by a semicolon.
CODEWATCH_SRCPATH
The location of source files for the debugger to use if none are found in directories specified when invoking CodeWatch
Values
  • A list of search directories, each item separated by a semicolon.
CODEWATCH_STBPATH
The location of STB files for the debugger to use if none are found in directories specified when invoking CodeWatch.
Values
  • A list of search directories, each item separated by a semicolon.
COLUMNS
Sets the screen width.
Values
  • An integer number of columns.

D

DB2DBDFT
The default database for the DB2 SQL precompiler to process SQL statements against.
Values
  • The location and name of the default database.
DBDCPY
The location of copybook files used by the DBDGEN utility
Values
  • The copybook file location.

E

ES_ACBLIB
The location of IMS ACB files
Values
  • The path location of the IMS ACB files.
ES_ALLOC_OVERRIDE
The location of a file containing rules that determine where new datasets are created. This applies only to JES and batch files, and not CICS, IMS, or Web services files.
Values
  • File path and name of the dataset rules file.
ES_CAS_API
Indicates whether casout or cassub has been executed by a call and not from the command line
ES_CESN_NO_OS390
Overrides the default behaviour CESN transaction response for invalid user credentials. Default behaviour reports "Your userid is invalid" or "Your password is invalid".
Values
  • Setting this variable to any value causes CESN to produce an invalid credential message instead of a specific invalid user or invalid password message.
ES_CICS_SINGLE
Configures CICS so that a user can only log on once.
Values
  • Y A user can only log on once.
  • Not set: A user can log on multiple times. This is the default.
ES_CLASS_XPCT
Overrides the default CICS PCT resource class
Values
  • Yes
  • No
  • The overriding class. The default is: ACICSPCT
ES_CLASS_XCMD
Overrides the default CICS CMD resource class
Values
  • Yes
  • No
  • The overriding class. The default is: CCICSCMD
ES_CLASS_XDCT
Values
  • Yes
  • No
  • The overriding class. The default is: DCICSDCT
Overrides the default CICS DCT resource class
ES_CLASS_XFCT
Overrides the default CICS FCT resource class
Values
  • Yes
  • No
  • The overriding class. The default is: FCICSFCT
ES_CLASS_XJCT
Overrides the default CICS JCT resource class
Values
  • Yes
  • No
  • The overriding class. The default is: JCICSJCT
ES_CLASS_XPPT
Overrides the default CICS PPT resource class
Values
  • Yes
  • No
  • The overriding class. The default is: MCICSPPT
ES_CLASS_XPSB
Overrides the default CICS PSB resource class
Values
  • Yes
  • No
  • The overriding class. The default is: PCICSPSB
ES_CLASS_XRES
Overrides the default CICS DOCTEMPLATE resource class
Values
  • Yes
  • No
  • The overriding class.
ES_CLASS_XTST
Overrides the default CICS TST resource class
Values
  • Yes
  • No
  • The overriding class. The default is: SCICSTST
ES_CLASS_XTRAN
Overrides the default CICS TRAN resource class
Values
  • Yes
  • No
  • The overriding class. The default is: TCICSTRN
ES_CONSOLE_LOG
Sends console messages to the Windows Event Log
Values
  • Yes Console messages are sent to the Windows Event Log
ES_CSKL_NO_MSG_CONSOLE
Stops CSKL writing messages to console.log
Values
  • Yes CSKL messages are not written to the console log.
ES_DDBG_PORT_RANGE
A range of ports to use for dynamic debugging
ES_DFS3650
The default transaction to execute or MOD file to be displayed after successfully signing on to IMS. You specify these by setting environment variables prior to the start of the region: ES_DFS3650 - set to MOD if a MOD file is to be sent, or TRX if a TRANSACTION is to be executed. If you set to MOD, ES_MOD3650 needs to be set to the name of the MOD you want to display. If you set to TRX, ES_TRX3650 needs to be set to the name of the transaction.
ES_ESM_CMDSEC
Indicates whether CICS processing honors the CMDSEC option specified on a transaction's PLT definition.
Values
  • ASIS

    CICS honors the CMDSEC option defined in a transaction's resource definition. CICS calls its command security checking routine only when CMDSEC(YES) is specified in a transaction resource definition.

  • ALWAYS

    CICS overrides the CMDSEC option, and always calls its command security checking routine to issue the appropriate call to the SAF interface.

ES_ESM_PLTPISEC
The level of security checking for PLTPI processing.
Values
  • NONE

    You do not want any security checking on PLT initialization programs.

  • CMDSEC

    You want CICS to perform command security checking only.

  • RESSEC

    You want CICS to perform resource security checking only.

  • ALL

    You want CICS to perform both command and resource security checking.

ES_ESM_PLTPIUSR
The user id under which PLT programs run during CICS initialization.
Values
  • The userid that CICS is to use for security checking for PLT programs that run during CICS initialization.
ES_ESM_RCF
Determines how RACF is used for command authorization
Values:
  • A Includes options T, C, and S.
  • C Specifies that RACF is to be used for ETO terminal command authorization.
  • N Specifies that no sign-on, transaction, or command authorization is to be performed by RACF.
  • S Specifies that RACF is to be used for static and ETO terminal command authorization. Includes option C.
  • T Specifies that RACF is to be used for sign-on and transaction authorization.
  • Y Includes options T and C.
ES_ESM_RESSEC
Indicates whether CICS processing honors the RESSEC option specified on a transaction's PLT definition.
Values:
  • ASIS .

    The RESSEC option of a transaction's resource definition will be honored. That is, resource security checking is performed only when RESSEC is set to yes on the PLT definition.

  • ALWAYS

    CICS processing always performs resource security checking irrespective of the RLS security setting on the transaction definition.

ES_ESM_SECPRFX
Indicates whether CICS processing prefixes the resource names when making security queries.
Values
  • NO

    No prefixes are used

  • YES

    Resource names are prefixed with the CICS region user ID.

  • <prefix>

    A string to be used as the prefix for resource names. It can be 1 to 8 upper case alphanumeric characters and it must start with an alphabetic character.

ES_ESM_XUSER
Indicates whether CICS processing performs surrogate user checks.
Values
  • NO

    No surrogate user checking is performed.

  • YES

    Perform surrogate user checking wherever such checks are permitted.

ES_ESMAC_DISP_MAX_OVERRIDE
The number of items displayed in the ESMAC catalog view
Values
  • An integer number of the ESMAC catalog view items to display.
ES_IMS_CONFIG
The IMS TM parameters
ES_IMS_DIAGNOSE
Marks IMS TM as diagnose mode only for IMSMSGQ
ES_IMS_DOSVS_PCB
Emulates DOS/VSE PCB address alignment for EXEC DLI programs.
ES_IMS_EXITPATH
The location of compiled code that contains segment and/or field exits
ES_IMS_FORCE_SIGNON
Enables a user to force a sign-on to IMS on the current terminal and sign off from other terminals
ES_IMS_IMSID
Allows the user to specify the IMS System ID returned to the AIBTDLI INQY ENVIRON call
ES_IMS_RELEASE
Allows the user to specify the IMS Release returned to the AIBTDLI INQY ENVIRON call
ES_IMS_REGION
Allows the user to specify the IMS Region returned to the AIBTDLI INQY ENVIRON call
ES_IMS_SUPPORT
Enables IMS support
ES_IMS_TLOG_FILES
Maximum number of IMS DB transaction log files that can be created before they start to be overwritten
ES_IMS_TLOG_MAXSIZE
Maximum size of the IMS DB transaction logging file
ES_IMS_TLOG_PATH
The location of IMS DB transaction logging files
ES_IMS_TLOG_THRESHOLD
Threshold size of the IMS DB transaction logging file
ES_IMSCFG
The location of the IMS configuraton files IMSCONFIG.DAT/.idx
ES_IMSDAT
The location of IMS DB data files
ES_IMSDB_LOCK_RETRY_DELAY
The IMS DB lock retry delay in milliseconds
ES_IMSLIB
The location of DBDGEN2.DAT, DBDGEN2F.DAT and PSBGEN3.DAT files
ES_INQFILE_RETURN
Modifies EXEC CICS INQUIRE FILE behavior
ES_JES_BYTES
Maximum number of bytes to output in a job before taking the action specified (either cancelling the job, cancelling the job and dumping memory contents, or issuing a warning message)
ES_JES_CARDS
Maximum number of cards to output in a job before taking the action specified (either cancelling the job, cancelling the job and dumping memory contents, or issuing a warning message)
ES_JES_DISABLE_RESTART_FLUSH
Indicates whether a region's jobs are moved from the Active queue to the Output Hold queue when a region is restarted
ES_JES_LEVEL
Sets the default JCL type to JES2, JES3 or VSE
ES_JES_LINES
Maximum number of lines to output in a job before taking the action specified (either cancelling the job, cancelling the job and dumping memory contents, or issuing a warning message)
ES_JES_OUTLIM
Maximum number of lines to output to a particular dataset before calling the user exit, processing any global limits, and then cancelling the job
ES_JES_PAGES
Maximum number of pages to output in a job before taking the action specified (either cancelling the job, cancelling the job and dumping memory contents, or issuing a warning message)
ES_JES_RESTART
Enables JCL restart processing
ES_LE370_SUPPORT
Enables support for Language Environment (LE) in CICS applications
ES_LEGACY_ECI
Indicates that Enterprise Server must use ES dfhtex32 instead of IBM CTG
ES_MAX_CATALOG_LINES
Restricts the number of entries displayed in ESMAC catalog view
ES_MEM_STRATEGY
Selects the types of memory processes supported
ES_MFASM_SUPPORT
Enables Assembler support when running CICS server regions.
Values
  • N

    No Assembler supported for CICS server regions.

  • Y

    Assembler supported for CICS server regions.

ES_MFSLIB
The location of the control blocks generated by the MFS generation program
ES_MOD3650
The default MOD file to be displayed after a successful sign-on to IMS. See ES_DFS3650.
ES_MQ_1PC
Indicates whether the MQSeries switch module ESMQXA should operate in one-phase commit mode. Only set this when advised to do so by Micro Focus.
ES_MQ_LIB
The full name including the path of the IBM MQ client or server library
Important: In AIX environments the library is an object inside a shared object. For example
ES_MQ_LIB="/usr/mqm/lib64/libmqmxa64.a(libmqm64.o)"
ES_MQ_LIB_T
The full name including the path of the IBM MQ client or server library, for threaded environments
ES_MQ_LIB_XA
The full name including the path of the IBM MQ XA library
Important: In AIX environments the library is an object inside a shared object. For example:
ES_MQ_LIB_XA="/usr/mqm/lib64/libmqmxa64.a(libmqmxa64.o)"
ES_MQ_LIB_XA_T
The full name including the path of the IBM MQ XA library, for threaded environments
ES_MQ_XA
The type of XA structure to use for the two-phase commit XA switch module.
Values
  • D: use a dynamic XA structure
  • S: use a static XA structure
ES_OLD_SEC_TSTD
Prevents security being enforced for TS or TD queues that are not declared in the security repository.
ES_OTMA_TIMEOUT
The time that an OTMA client should wait for an answer
ES_PL1_MFFH
Enables Micro Focus File Handler to perform all Open PL/I I/O operations. The default value is "Y". If it is set to "N", then all I/O will be routed to old Liant file handlers.
ES_PL1_MFFH_JCL
Enables you to run Open PL/I programs that access JCL data definitions. The defaul value is "N".
ES_PLI_SUPPORT
Tells the CICS Emulation that it needs to load its subsystem support for PL/I user programs. The default value is "N".
ES_RLS_FILE_SUPPORT
Stops dirty records being returned when a record is locked by another process.
ES_SEP_DORMANT_TIME
Allows override of Transient SEP dormant time
ES_SERVER
Server name (used if no -r switch is specified on casstart or casstop).
ES_SSTM_CICS
Location of the JCL used to initialize the SSTM CICS environment
ES_SSTM_IMS
Location of the JCL used to initialize the SSTM IMS environment
ES_SURROGATE_JOB_USER
Associates a user ID with a job when submitting the job for processing through the internal reader from CICS.
Values
  • Any value

    The user ID that started the ES region is used in the job submission.

  • No Value

    The CICS default user CICSUSER, or as specified by ES_USR_DFLT_CICS, is used in the job submission.

ES_SYSOUT_HOLD
Sysout held classes
ES_TN3270_FORCE_ALT
Enables you to use a screen size other than the default when using a TN3270 terminal emulator
ES_TN3270_MODEL_LOG
Writes the TN3270 emulator's model name to a temporary storage queue named TN32MODL that can be viewed using the CEBR transWritesaction
ES_TRX3650
The default transaction to run after a successful sign-on to IMS. See ES_DFS3650.
ES_USR_DFLT_CICS
Allows you to override the default user when no user is logged on for CICS authentication
ES_USR_DFLT_ESMAC
Allows you to override the default user when no user is logged on for ESMAC authentication
ES_USR_DFLT_JES
Allows you to override the default user when no user is logged on for JES authentication
ES_USR_DFLT_IMS
Allows you to override the default user when no user is logged on for IMS authentication
ES_XA_????_NB_RETRIES
Operates in conjunction with ES_XA_CONNECT. Sets the number of connection re-tries when attempting to connect to a resource:

ES_XA_????_NB_RETRIES= nnnn where:

  • ???? is the XA ID defined in MFDS.
  • nnnn is the number of retries allowed.
ES_XA_RECONNECT

If this environment variable is set, when an error occurs on a call to XA, the server recycles the SEP and attempts to reconnect to the Resource Manager. The ES_XA_????_NB_RETRIES variable specifies the number of attempts to be made.

EXTFH
Specifies a configuration file for the Callable File Handler
ES_EZASOKET_SUPPORT
Switches on EZASOKET support

F

FHREDIR
A configuration file to be used by the Fileshare Client.
FS
A configuration file to be used by the Fileshare Server.
FSCOMMS
Specifies that the Fileshare system is to run in single user mode.
Values
  • "\$local" Run the Fileshare System in single user mode.

H

HCOBND
A directory for DB2 bind files.

I

ICONN1
Controls the client TCP connection status of an IMS Connect emulator
IMSCFG
Defines the location of IMS configuration files IMSCONFIG.DAT/.idx
IMSCPY
The location of copybook files for DBDGEN, PSBGEN and MFSGEN utilities
IMSDAT
The location of IMS DB data files
IMSLIB
The location of DBDGEN2.DAT, DBDGEN2F.DAT and PSBGEN3.DAT files
IMSNET
The location of network read-only IMS DB data files
IMSWRK
The location of the work directory for temporary files
ISPPROF
The location of ISPF dialog profiles.

J

JAVA_HOME
Locates the JDK.

L

LANG
Specifies the language environment.
Values
  • language The language in which your program is to run.
  • _ (underscore) The delimiter for language and territory, if territory is specified.
  • territory The country in which your program is to run.
  • . (period) The delimiter for territory and codepage, if codepage is specified.
  • codepage The character set to use for your program.

Example: LANG=fr_FR

LD_LIBRARY_PATH

Specifies the directory or directories for the UNIX system, Cob and the run-time system to search for shared libraries and callable shared objects. It must be set to include $COBDIR/lib on all platforms, except AIX and HP/UX, which use a different environment variable. It should also include any directories that contain callable shared objects used by your application.

Values
  • A path or a list of paths, each separated by a colon (:).
LIB
The location of the DB2 LIB directory
LIBPATH
Locates shared libraries (applies to AIX only).
Values
  • A path or a list of paths, each separated by a colon (:).
LINES
Specifies screen depth in lines.
Values
  • An integer that specifies the number of lines.

M

MF_ALIAS
Specifies program aliases. Each set (pair) is 16 characters long - 8 characters for the program-name, and 8 characters for the alias. You can specify up to 10 pairs. This list is searched first and thus can potentially override the built-in list. If not found, the built-in alias table is searched.
MF_AMODE31ONLY
Indicates that all programs are AMODE(31).
MF_CHARSET
Specifies the system character set (ASCII or EBCDIC).
MF_DUPJOBS
Enables jobs with identical names to run.
Values:
  • Y (Default)
  • N
MF_FALLTHRUCHECK
Specifies that MSS is to check that the main COBOL program ends by executing a GOBACK or STOP RUN.
Values:
  • y (default)
  • n
MF_MFA
Specifies what dataset catalogs are to be searched.
Values:
  • ALL - Search for datasets first in the local catalog, and if not found, on the mainframe (default)
  • RJSE - Search for datasets in the local catalog only. No mainframe is performed.
MF_MVSJOB
MVS job number rules.
MF_NEWSPACE
Indicates whether SPACE is required for NEW datasets.
MF_NODD
Specifies what action MSS is to take at run time if a job step uses a file that has not been allocated.
MF_RCCF
Enables Remote Job Step Execution (RJSE).
MF_ROOT_CERT
Enables the MF Directory Server process and any client applications to pick up the value of the root certificate file
MF_SMS
Enables SMS support
MF_SPOOL_ARCHIVE_LOC
The location of the file where the contents of the MVS SPOOL spool file are copied prior to deletion.
MF_SPOOL_HK_TESTDATE
Spool housekeeping testing date override.
MF_SYSLOGDSN
The Syslog Dataset name.
MF_UCC11
Enables emulation of UCC11, a third party add-on to the mainframe that affects data set disposition processing. If UCC11 is enabled, a data set disposition of NEW is accepted even if the data set already exists.
Values
  • y
  • n (Default)
MF_USESCA5
Specifies that the server should use version 5 of the Open Service Component Architecture
Values:
  • ON (Default)
  • OFF
MF_USESCA7
Specifies that MSS accepts CA7 Scheduler control statements as comments rather than diagnosing them as errors.
Values:
  • ON (Default)
  • OFF
MF_USE_JAVA_CW
Enables you to use Java CodeWatch for debugging Open PL/I programs.
MFALLOC_LOC
The location of the default allocated dataset.
MFALLOC_PROP
Rules for generated PC dataset names on allocation (that is, the default catalog PC DSN format).
MFAUDIT_LOGS
The location of audit files.
MFCODESET
Specifies which translation tables to use.
Values
  • A pre-defined country code:
    Country code | Language
    DEFAULT | English (US)
    AUTO or AUTOMATIC | Operating system default
    0031 | Dutch
    0033 | French
    0034 | Spanish
    0039 | Italian
    0043 | German (Austrian)
    0044 | English (UK)
    0045 | Danish
    0046 | Swedish
    0047 | Norwegian
    0049 | German
    0081 | Japanese Katakana Extended
    0082 | Korean
    0086 | Simplified Chinese
    0351 | Portuguese
    0358 | Finnish
    0437 | English (US)
    0500 | International (Latin 1)
    0886 | Traditional Chinese
    0939 | Japanese Latin Extended
    9122 | Japanese Katakana

  • A code between 2000 and 9999 (except 9122), which corresponds to a user-defined translation table. User-defined tables are created using the Codecomp utility.

On Windows platforms. to use the Euro symbol (€), prefix the country code for EURO codesets with "E".
MFCSCFG
A configuration file to be used by the client/server binding client program
MFE.SMS
Enables SMS support.
MFEXTMAP
Location of a mapper file.
MFIMS_ACBDUMP_TIMESTAMP
Suppresses date/time stamp display in ACB report
MFIMS_BMPCHKP
Returns a QC to a checkpoint call when it the call includes an IO area
MFIMS_DIBSTAT_CODES
Specifies additional DIBSTAT return codes to be returned to EXEC DLI program
MFIMS_DLI_OPT
Specifies DL/I call optimization flags
MFIMS_DIAG
Enables IMS BTS format diagnostic tracing
MFIMS_FLUSHTRACE
Flushes BTS trace file to disk after every write
MFIMS_FP_DA
Bypasses keycheck on IMS Fastpath DB delete
MFIMS_LOADMVS
Disables load of MVS support for IMS application programs
MFIMS_PCBCALL
Allows a standalone EXEC DLI program to issue a PCB call
MFJSENGINE
Specifies which sort engine the utility MFJSORT is to emulate.
Values:
  • DFSORT (Default)
  • SYNCSORT
MFJSTATS
Specifies to create a report containing statistics for a SORT.
MFLECONFIG
Path and filename for a configuration file for Language Environment (LE) run-time options
MFLOCKING
Enables Locking Support
MFLOGDIR
A directory that the client/server binding process is to use for log files.
MFPLI_PRODUCT_DIR
The location of the Open PL/I installation. Used to find files needed for compiling and linking.
MFPRELOAD_USE
Calls MFPRELOAD to improve perfomance.
MFREXX_LSEQ_RECSIZE_MAX

Specifies the record length for the REXX EXECIO command when reading or writing a line sequential file that has been cataloged with a record length of zero.

Values:
  • Record length to use (Default = 255)
MFREXX_NOT
Specifies one or more characters to be used for the NOT operator in addition to REXX's default, which is "¬".
Values
  • One or more characters for each operator; each character you specify is used in addition to the default operator. Each additional character must be defined within single or double quotes, or in hexadecimal. Separate multiple characters with a space or a comma.
MFREXX_OR
One or more characters to be used for the OR operator in addition to REXX's default, which is "|".
Values
  • One or more characters for each operator; each character you specify is used in addition to the default operator. Each additional character must be defined within single or double quotes, or in hexadecimal. Separate multiple characters with a space or a comma.
MFSUB
Specifies whether to use SUBI or ASUBI
Values
  • SUBI
  • ASUBI
MFSCPY
The location of copybook files for MFSGEN utility
MFSYSCAT
The location of the JES system catalog.
MFSYSCATDIR
The location of the system catalog directory
MFTRACE_ANNOTATIONS
The location of the Studio Enterprise Edition trace files
MFTRACE_CONFIG
The location of the CTF configuration file
MFTRACE_LOGS
The location of the CTF log files
MFTSO_DEBUG
Controls the display of debug message
MFUSERCAT_LOC
User catalog location
MQSERVER
The location of an MQSeries Server installation.
MULTMFENTMAP
Specifies whether special characters such as < and & are replaced with the equivalent HTML entities (for example &lt; and &amp;)

O

OOSW
OO run-time switches

P

PATH
Directories to be searched for all UNIX programs.
PROCLIB
Specifies PROCLIB datasets. This can be a concatenation of PDS names.
PSBCPY
The location of copybook files for PSBGEN utility.

R

RANDOM
If using SSL connections, externally generated random data that is stored as a numeric value in the RANDOM variable will be inserted into the initial salt value used to generate temporary key pairs used in SSL hand-shaking. The RANDOM value will only form part of the initial salt value and is an aid to generating more randomness and not an essential requirement.

S

SHLIB_PATH
Locates shared libraries (applies to HP/UX only).
SORTCOMPRESS
Tells the system whether or not to execute a compression routine on each record to be sorted.
Values
  • SORTCOMPRESS=5 allows for run-length encoding of sort records, resulting in much better performance when records contain multiple repeated characters.
    Note: 5 is the only valid value for this environment variable.
SORTSCHEME
Activates a sortscheme. Use in conjunction with SORTSPACE for improved performance.
Values
  • SORTSCHEME=1 - this is the only valid value for the environment variable. See SORTSPACE below for more information.
SORTSPACE
The amount of memory to be allocated to internal workspace for SORT operations. This can be specified in different formats: for example, you could specify 64M, 2G, and 1000000 to give sort memory areas of 64 Megabytes, 2 Gigabytes and 1000000 bytes respectively.
Values
  • n[K|k|M|m|G|g No letter indicates bytes. Defaults to 1 megabyte.
SORTTEMPSPACE
The amount of temporary memory to be allocated to internal workspace for SORT operations. This can be specified in different formats much like the SORTSPACE environment variable. By using SORTTEMPSPACE, you can maximize available memory.
SORTTYPE
Defines the sort type.
Values
  • SORTTYPE=2 Forces SORT to use the file handler, so that format modifications are picked up from the extfh.cfg file.
  • Not setting this means SORT will try to use CBL_ routines to read and write files to improve performance.
Note: "2 is the only valid value for this environment variable.
SSLDIR
If using SSL connections specifies the generic location of the system's OpenSSL directory.
STEPLIB
The paths for Loader input load-members .390 files (must contain SYSLMOD) .
Note: For this environment, you can specify multiple paths, each separated by a semi colon.
SYSIN
The path for macro input .MLC files.
SYSLIST
The path for Assemble and Link listing files: .MAT, .PRN, and .LST.
SYSWORK
The path for Assemble, Link and Animator/370 work files .BAL .IDF/.IDX.
SYSPUNCH
The path for Assemble output .PCH files for PUNCH statements.
SYSMPC
The path for Assemble input precompiled macros: .MPC.
SYSLIB
The paths for Assemble input macro and copy files .MAC .CPY.
Note: For this environment, you can specify multiple paths, each separated by a semi colon.
SYSLIN
The path for Link input .LIN files and Assemble output .OBJ files.
SYSLMOD
The path for Link output load-member .390 files.
SYSPARM
The path for the Macro input SYSPARM value.

T

TERM
Sets the terminal type.
Values
  • name The name of the terminal in the terminfo database.
TERMINFO
Locates the UNIX system terminfo database.
TMPDIR
Locates the directory for temporary files.
TX_MQTRACE
Enables tracing in dfh0mqis for MQSeries calls.
TX_TN3270_FORCE_ALT
Enables you to use a screen size other than the default when using a TN3270 terminal emulator.
TXFILEP
The location of Micro Focus VSAM files.
TXMAPP
The location of the BMS load module.
TXRDTP
The location of MSS resource definition (RDO) files.
TXTRANP
The location of the CICS application object files.

U

USER
Default user name.

V

VSE_STARTUP_CFG
The location of the VSE JCL configuration file
Parent topic: Configuring Environment Variables
Parent topic: Configuring Environment Variables


Error Messages

  • Syntax Checking Error Messages
  • Code Generation Error Messages
  • Run-time System Error Messages
  • COBOL Preprocessor Error Messages
  • Data File Converter Error Messages
  • Explanation of Error Codes
Parent topic: General Reference


Syntax Checking Error Messages

These messages are output when the compiler is checking your COBOL program for syntax and consistency. The Help topcs for the messages list the text of each message, and where necessary explains the error or problem that causes the message and gives advice on how to prevent it. The severity is not listed, as the same message can be output with a different severity depending on the setting of directives.

  • Key to Syntax Checking Error Messages
  • Messages COBCH0001 to COBCH0100
  • Messages COBCH0101 to COBCH0200
  • Messages COBCH0201 to COBCH0300
  • Messages COBCH0301 to COBCH400
  • Messages COBCH0401 to COBCH0500
  • Messages COBCH0501 to COBCH0600
  • Messages COBCH0601 to COBCH0700
  • Messages COBCH0701 to COBCH0800
  • Messages COBCH0801 to COBCH0900
  • Messages COBCH0901 to COBCH1000
  • Messages COBCH1001 to COBCH1100
  • Messages COBCH1101 to COBCH1200
  • Messages COBCH1201 to COBCH1300
  • Messages COBCH1301 to COBCH1400
  • Messages COBCH1401 to COBCH1500
  • Messages COBCH1501 to COBCH1600
  • Messages COBCH1601 - COBCH1700
  • Messages COBCH2000 and above
Parent topic: Error Messages


Key to Syntax Checking Error Messages

Syntax checking error messages have the following format:

ErrorCode Description : Location

where the parameters are:

ErrorCode A code containing the following information:
  • The component that the error occurred in.
  • The operation that was taking place when the error occurred.
  • The error message number.
  • The severity of the error.
For syntax errors, ErrorCode is generally of the form COBCHnnnns. See Explanation of Error Codes for more information on the possible values that ErrorCode can have.
Description | A description of the cause of the error.
Location | The approximate location of the error in the source code.

The severity returned in ErrorCode can take one of the following values:

U | Unrecoverable. An unrecoverable error stops the COBOL system. These messages are produced by the run-time system. See also Run-time System Error Messages
S | Severe. You must correct the syntax error or inconsistency in your program. Otherwise the compiler cannot generate code.
E | Error. The compiler will make an assumption about what you meant. You might want to correct your program in case the compiler's assumption is not what you intended.
W | Warning. This means there might be an error, although the program is syntactically correct.
I | Information. This draws your attention to something in the source code that you might need to be aware of. It does not mean there is an error.

You can disable reporting of errors of E-, W-, and I-level, using the WARNING directive.

When the Compiler has finished, the total number of errors in each category is also output.

You can disregard some levels of errors and continue working. You can:

  • Debug programs that have S-, E-, W-, and I-level errors regardless of the setting of the E .
  • Produce object code from intermediate code that has E-, W-, and I-level errors, but not S-level errors.
  • Run programs that have E-, W-, and I-level errors. If the E-level run-time switch is on, which overrides the default setting, you can also run programs with S-level errors.

The error messages can contain variable information. This information is indicated as an item in italics. For example:

COBCH0005 User-name user-name not unique

will have the name of the item that is not unique in place of the text user-name.

Parent topic: Syntax Checking Error Messages


Messages COBCH0001 to COBCH0100

  • COBCH0001 - COBCH0020
    Lists the Syntax Checking error messages from COBCH0001 through COBCH0020.
  • COBCH0021 - COBCH0040
    Lists the Syntax Checking error messages from COBCH0021 through COBCH0040.
  • COBCH0041 - COBCH0060
    Lists the Syntax Checking error messages from COBCH0041 through COBCH0060.
  • COBCH0061 - COBCH0080
    Lists the Syntax Checking error messages from COBCH0061 through COBCH0080.
  • COBCH0081 - COBCH0100
    Lists the Syntax Checking error messages from COBCH0081 through COBCH0100.
Parent topic: Syntax Checking Error Messages


COBCH0001 - COBCH0020

Lists the Syntax Checking error messages from COBCH0001 through COBCH0020.

  • COBCH0001 Undefined error. Inform Technical Support
    Your program contains an error which the COBOL system has failed to recognize.
  • COBCH0002 Unexpected SQL error. Inform Technical Support
    Your program contains an SQL error which the COBOL system has failed to recognize.
  • COBCH0003 Illegal format : Literal
    The sequence of characters forming a literal in your source code does not conform to the rules governing the construction of such names. A literal can be either nonnumeric or numeric.
  • COBCH0004 Illegal character
    Your program contains a character that is not part of the COBOL language set.
  • COBCH0005 User-name user-name not unique
    You have given the same user-name without qualification to more than one data item or procedure-name in your source code.
  • COBCH0007 $ specified in indicator area of otherwise blank line
    The indicator area, column 7, contains an illegal character.
  • COBCH0008 Unknown COPY file filename specified
    A file with the name filename, specified in conjunction with a COPY statement, cannot be found.
  • COBCH0009 '.' missing
    Your code does not contain a period in a place where one is expected by the rules of COBOL syntax.
  • COBCH0010 Word starts or is continued in wrong area of source line
    The word starts either in area A when it should have started in area B, or in area B when it should have started in area A.
  • COBCH0011 Reserved word missing or incorrectly used
    You have either used a reserved word in a place where a user defined word is expected or you have failed to use a reserved word where one is needed.
  • COBCH0012 Operand data-name is not declared
    You are trying to use a data-name which you have not declared, or which you have misspelled.
  • COBCH0013 User-name required
    You have not supplied a user-defined-name at the specified place in your program.
  • COBCH0014 Invalid operand
    The operand you have specified is in some way incorrect, and cannot be processed by your COBOL system. For example, you might have specified a negative integer where only positive integers are allowed.
  • COBCH0015 Procedure Division too large
    Your program's Procedure Division exceeds the maximum size allowed.
  • COBCH0016 Data space too large
    Your program's Data Division exceeds the maximum size allowed.
  • COBCH0017 Incorrect use of reserved word word
  • COBCH0018 Preprocessor error on initialization
    An integrated preprocessor invoked by the COBOL system detected an error during its initialization and was unable to continue.
  • COBCH0019 BASIS line number sequencing error
    You have made an error in the sequence of line numbers in one of the statements that implement the BASIS mechanism. For example, the statement DELETE 100-60 is incorrect. (BASIS requires numeric sequence values.)
  • COBCH0020 Numeric literal expected
    You must specify a numeric literal in this context.
Parent topic: Messages COBCH0001 to COBCH0100


COBCH0001 Undefined error. Inform Technical Support

Your program contains an error which the COBOL system has failed to recognize.

Resolution:

Send Technical Support a copy of your source code to enable them to find the cause of the error.

Parent topic: COBCH0001 - COBCH0020


COBCH0002 Unexpected SQL error. Inform Technical Support

Your program contains an SQL error which the COBOL system has failed to recognize.

Resolution:

Send Technical Support a copy of your source code to enable them to find the cause of the error.

Parent topic: COBCH0001 - COBCH0020


COBCH0003 Illegal format : Literal

The sequence of characters forming a literal in your source code does not conform to the rules governing the construction of such names. A literal can be either nonnumeric or numeric.

If numeric it can be up to 18 digits in length, but it must not contain more than one sign character or more than one decimal point.

A nonnumeric literal can consist of any allowable character in the computer's character set up to a maximum of 160 characters in the Procedure Division, or 2048 characters in the Data Division. A nonnumeric literal must be enclosed in quotation marks.

If you have used a figurative constant as the literal make sure that it is referenced by an allowable reserved word (such as ZERO) which you have spelled correctly. A figurative constant and a numeric literal must not be enclosed in quotation marks.

You might also have used the wrong class of literal for the context of the sentence.

Alternatively, if you have used the figurative constant ALL in your code, you have not coded it in accordance with the rules governing the use of this constant. ALL must be followed by a nonnumeric literal and not by a numeric one.

Resolution:

Revise your code to comply with the above rules.

Parent topic: COBCH0001 - COBCH0020


COBCH0004 Illegal character

Your program contains a character that is not part of the COBOL language set.

Resolution:

Replace the illegal character with a valid one.

Parent topic: COBCH0001 - COBCH0020


COBCH0005 User-name user-name not unique

You have given the same user-name without qualification to more than one data item or procedure-name in your source code.

Resolution:

You must rename or qualify the duplicated data items or procedure-names to ensure that uniqueness of reference is achieved.

Parent topic: COBCH0001 - COBCH0020


COBCH0007 $ specified in indicator area of otherwise blank line

The indicator area, column 7, contains an illegal character.

Resolution:

Legal characters are *, D, -, / or space.

Parent topic: COBCH0001 - COBCH0020


COBCH0008 Unknown COPY file filename specified

A file with the name filename, specified in conjunction with a COPY statement, cannot be found.

Resolution:

Change the filename, or make the file available to your COBOL system.

Parent topic: COBCH0001 - COBCH0020


COBCH0009 '.' missing

Your code does not contain a period in a place where one is expected by the rules of COBOL syntax.

Resolution:

Insert one at the relevant place.

Parent topic: COBCH0001 - COBCH0020


COBCH0010 Word starts or is continued in wrong area of source line

The word starts either in area A when it should have started in area B, or in area B when it should have started in area A.
Parent topic: COBCH0001 - COBCH0020


COBCH0011 Reserved word missing or incorrectly used

You have either used a reserved word in a place where a user defined word is expected or you have failed to use a reserved word where one is needed.

Resolution:

Alter the reserved word into a user defined one or insert a reserved word according to the context of this message.

Parent topic: COBCH0001 - COBCH0020


COBCH0012 Operand data-name is not declared

You are trying to use a data-name which you have not declared, or which you have misspelled.

Resolution:

This error might not always occur directly below the data item that is not declared. This is because your COBOL system continues processing through the source code to find out whether the data item is qualified. To find the item in error, work backward through the source to the most recent item.

Ensure that the data item is declared.

Parent topic: COBCH0001 - COBCH0020


COBCH0013 User-name required

You have not supplied a user-defined-name at the specified place in your program.

Resolution:

Insert a name ensuring that it conforms to the rules of COBOL syntax and that it is the correct type of name (for example a system-name or a condition-name).

Parent topic: COBCH0001 - COBCH0020


COBCH0014 Invalid operand

The operand you have specified is in some way incorrect, and cannot be processed by your COBOL system. For example, you might have specified a negative integer where only positive integers are allowed.

Resolution:

Check the operands allowed for this syntax (click Related Topics).

Parent topic: COBCH0001 - COBCH0020


COBCH0015 Procedure Division too large

Your program's Procedure Division exceeds the maximum size allowed.

Resolution:

Redesign your program as a set of smaller independent programs that call one another.

Parent topic: COBCH0001 - COBCH0020


COBCH0016 Data space too large

Your program's Data Division exceeds the maximum size allowed.

Resolution:

Redesign your program as a set of independent programs with smaller Data Divisions.

Parent topic: COBCH0001 - COBCH0020


COBCH0017 Incorrect use of reserved word word

Parent topic: COBCH0001 - COBCH0020


COBCH0018 Preprocessor error on initialization

An integrated preprocessor invoked by the COBOL system detected an error during its initialization and was unable to continue.

Resolution:

If the preprocessor displayed any further information correct the problem and resubmit the command

Parent topic: COBCH0001 - COBCH0020


COBCH0019 BASIS line number sequencing error

You have made an error in the sequence of line numbers in one of the statements that implement the BASIS mechanism. For example, the statement DELETE 100-60 is incorrect. (BASIS requires numeric sequence values.)

Resolution:

Correct the sequence error.

Parent topic: COBCH0001 - COBCH0020


COBCH0020 Numeric literal expected

You must specify a numeric literal in this context.

Resolution:

Ensure that your numeric literal complies with the syntax rules.

Parent topic: COBCH0001 - COBCH0020


COBCH0021 - COBCH0040

Lists the Syntax Checking error messages from COBCH0021 through COBCH0040.

  • COBCH0021 Too many qualifiers
    You have used too many qualifiers when referring to a qualified data-name, procedure-name or text-name.
  • COBCH0022 SKIP1/2/3, EJECT and TITLE must be alone on line
    Source program lines containing these words must not contain any other words.
  • COBCH0023 Nonnumeric literal expected
    You must specify a nonnumeric literal in this context.
  • COBCH0024 Illegal qualifier
    You have specified a qualified data-name, procedure-name, or text-name incorrectly.
  • COBCH0025 Qualification not permitted
    You cannot qualify a data-name, procedure-name, or text-name in this context.
  • COBCH0026 Literal too long
    The literal value you have specified is longer than the maximum literal length permitted.
  • COBCH0027 Number too large
    You have declared a numeric value that is too large.
  • COBCH0028 Data item too long
    You have declared a data item that is too long for the specified data-type.
  • COBCH0029 Not a data-name
    You have specified an operand that is not a data item where a valid data item is expected. For example, you might have specified an FD-name or a condition-name instead of a data-name.
  • COBCH0030 Should be a group
    You have specified an elementary item as the sending or receiving field in a MOVE CORRESPONDING statement.
  • COBCH0031 Should be elementary
    You have specified the name of a group data item in a context in which an elementary item must be used.
  • COBCH0032 Should be unitary
    You have specified a subscripted or indexed data item where one is not allowed.
  • COBCH0033 Should be procedure name
    A procedure-name (that is, a paragraph or section-name) is expected in this context. You have probably specified a data-name.
  • COBCH0034 Operand operand should be numeric
    A numeric value is required in this context, and you have specified a nonnumeric value.
  • COBCH0035 Integer required
    An integer value is required in this context, and you have specified a noninteger value.
  • COBCH0036 Should be alphanumeric
    An alphanumeric value is required in this context, and you have specified a numeric value.
  • COBCH0037 Should have USAGE DISPLAY
    The data item should have USAGE DISPLAY.
  • COBCH0038 Paragraph or phrase repeated illegally
    You have specified a paragraph or phrase more than once, when you might specify it only once.
  • COBCH0039 Too many COPY ... REPLACING statements
    The program contains more than 255 COPY...REPLACING statements.
  • COBCH0040 Missing or illegal file name
    The filename you have specified either does not conform to COBOL rules for filenames, or has not been declared in the FILE-CONTROL paragraph. This might be due to a misspelled valid filename.
Parent topic: Messages COBCH0001 to COBCH0100


COBCH0021 Too many qualifiers

You have used too many qualifiers when referring to a qualified data-name, procedure-name or text-name.

Resolution:

Change the reference in error so that it uses no more than the permitted number of qualifiers.

Parent topic: COBCH0021 - COBCH0040


COBCH0022 SKIP1/2/3, EJECT and TITLE must be alone on line

Source program lines containing these words must not contain any other words.

Resolution:

Edit your program so that these words are on a line of their own.

Parent topic: COBCH0021 - COBCH0040


COBCH0023 Nonnumeric literal expected

You must specify a nonnumeric literal in this context.

Resolution:

Ensure that the literal you have specified conforms to the rules for nonnumeric literals.

Parent topic: COBCH0021 - COBCH0040


COBCH0024 Illegal qualifier

You have specified a qualified data-name, procedure-name, or text-name incorrectly.

Resolution:

Correct the qualified reference.

Parent topic: COBCH0021 - COBCH0040


COBCH0025 Qualification not permitted

You cannot qualify a data-name, procedure-name, or text-name in this context.

Resolution:

Make the reference an unqualified reference.

Parent topic: COBCH0021 - COBCH0040


COBCH0026 Literal too long

The literal value you have specified is longer than the maximum literal length permitted.

Resolution:

If your literal is numeric, it can be up to 18 digits in length (or up to 38 digits if you specify INTLEVEL"4"). If it is nonnumeric, it can contain up to 160 characters in the Procedure Division, or 2048 characters in the Data Division. Ensure that the literal value you have specified in your program is not longer than the maximum length permitted.

Parent topic: COBCH0021 - COBCH0040


COBCH0027 Number too large

You have declared a numeric value that is too large.

Resolution:

Click Related Topics for information on the maximum value.

Parent topic: COBCH0021 - COBCH0040


COBCH0028 Data item too long

You have declared a data item that is too long for the specified data-type.

Resolution:

Click Related Topics for information on the maximum sizes of data items of various types.

Parent topic: COBCH0021 - COBCH0040


COBCH0029 Not a data-name

You have specified an operand that is not a data item where a valid data item is expected. For example, you might have specified an FD-name or a condition-name instead of a data-name.

Resolution:

Ensure that the item that is in error is a data-name, and that it is declared.

Parent topic: COBCH0021 - COBCH0040


COBCH0030 Should be a group

You have specified an elementary item as the sending or receiving field in a MOVE CORRESPONDING statement.

Resolution:

Ensure that both the sending and receiving fields are group items.

Parent topic: COBCH0021 - COBCH0040


COBCH0031 Should be elementary

You have specified the name of a group data item in a context in which an elementary item must be used.

Resolution:

Change the reference so that it is a reference to an elementary item.

Parent topic: COBCH0021 - COBCH0040


COBCH0032 Should be unitary

You have specified a subscripted or indexed data item where one is not allowed.

Resolution:

Change the reference so that it is a reference to a unitary (that is, nonsubscripted and nonindexed) data item.

Parent topic: COBCH0021 - COBCH0040


COBCH0033 Should be procedure name

A procedure-name (that is, a paragraph or section-name) is expected in this context. You have probably specified a data-name.

Resolution:

Ensure the procedure-name is correct.

Parent topic: COBCH0021 - COBCH0040


COBCH0034 Operand operand should be numeric

A numeric value is required in this context, and you have specified a nonnumeric value.

Resolution:

Make the value numeric.

Parent topic: COBCH0021 - COBCH0040


COBCH0035 Integer required

An integer value is required in this context, and you have specified a noninteger value.

Resolution:

Make the value an integer value.

Parent topic: COBCH0021 - COBCH0040


COBCH0036 Should be alphanumeric

An alphanumeric value is required in this context, and you have specified a numeric value.

Resolution:

Make the value an alphanumeric value.

Parent topic: COBCH0021 - COBCH0040


COBCH0037 Should have USAGE DISPLAY

The data item should have USAGE DISPLAY.

Resolution:

Change the data item's USAGE to DISPLAY.

Parent topic: COBCH0021 - COBCH0040


COBCH0038 Paragraph or phrase repeated illegally

You have specified a paragraph or phrase more than once, when you might specify it only once.

Resolution:

Delete the repeated paragraph or phrase.

Parent topic: COBCH0021 - COBCH0040


COBCH0039 Too many COPY ... REPLACING statements

The program contains more than 255 COPY...REPLACING statements.

Resolution:

Correct your program so that it contains fewer than 255 COPY...REPLACING statements.

Parent topic: COBCH0021 - COBCH0040


COBCH0040 Missing or illegal file name

The filename you have specified either does not conform to COBOL rules for filenames, or has not been declared in the FILE-CONTROL paragraph. This might be due to a misspelled valid filename.

Resolution:

Correct the filename (or, if necessary, add a file description entry to the FILE-CONTROL paragraph).

Parent topic: COBCH0021 - COBCH0040


COBCH0041 - COBCH0060

Lists the Syntax Checking error messages from COBCH0041 through COBCH0060.

  • COBCH0041 ZERO is an invalid value for an index-name
    You cannot enter a zero value here.
  • COBCH0042 Must be nonzero
    The numeric value you specify here must be nonzero.
  • COBCH0043 Literal or figurative constant expected
    You must specify a literal value or a figurative constant here.
  • COBCH0044 Literal expected
    You must specify a literal value here.
  • COBCH0045 Operand data-name has wrong size
    The operand in this statement is the wrong length (for example, you have specified a prompt character more than one character long).
  • COBCH0046 Alphabet name required
    You must specify the name of a user-defined collating sequence here.
  • COBCH0047 Numeric literal or ZERO expected
    You must specify a numeric literal or the figurative constant ZERO here.
  • COBCH0048 Missing or extra right parenthesis
    The number of left and right parentheses in an arithmetic expression is not the same.
  • COBCH0049 Illegal use of Index-name or Index Data item
    You have used an item with USAGE INDEX in a context where it is not allowed. Click Related Topics for details of where you can use such items.
  • COBCH0050 Illegal use of POINTER data item, ADDRESS OF or NULL
    You have tried to perform an illegal operation on a data item with USAGE POINTER. Alternatively, you have tried to apply the ADDRESS OF phrase to an item that is not an 01 or 77 level item in the Working-Storage or Linkage Section.
  • COBCH0051 Not a report name
    You must use a report-name in this context. You have probably misspelled a valid report-name.
  • COBCH0052 Only allowed with SEQUENTIAL files
    You have performed an operation that is permitted only if the file has SEQUENTIAL organization (for example, CLOSE REEL/UNIT).
  • COBCH0053 Directive directive invalid or not allowed here
    You have either specified a COBOL system directive in the wrong place or specified an invalid COBOL system directive in a $SET statement in your program.
  • COBCH0054 Class name required
    You have failed to define the class-name in the SPECIAL-NAMES paragraph, or you have misspelled a COBOL class-name.
  • COBCH0055 Index-name set to value greater than table size
    A SET index-name TO literal statement has been used to try to set an index name to a value greater than the number in the OCCURS clause for which that index name belongs.
  • COBCH0056 COPY is recursive
    One of the following:
  • COBCH0057 Not a report group
    You must use a report group in this context. You have probably misspelled a valid report group-name.
  • COBCH0058 Not a report name or a report group
    You have specified neither a valid report-name nor a valid report group in a GENERATE statement. You have probably misspelled the report-name or the report group.
  • COBCH0059 Cannot GENERATE this report name
    The report-name that you have specified should contain all of the following:
  • COBCH0060 Not a detail group
    You have specified a report group that is not of TYPE DETAIL.
Parent topic: Messages COBCH0001 to COBCH0100


COBCH0041 ZERO is an invalid value for an index-name

You cannot enter a zero value here.
Parent topic: COBCH0041 - COBCH0060


COBCH0042 Must be nonzero

The numeric value you specify here must be nonzero.

Resolution:

Specify a nonzero value.

Parent topic: COBCH0041 - COBCH0060


COBCH0043 Literal or figurative constant expected

You must specify a literal value or a figurative constant here.

Resolution:

Alter the value you have specified to be a literal or a figurative constant.

Parent topic: COBCH0041 - COBCH0060


COBCH0044 Literal expected

You must specify a literal value here.

Resolution:

Alter the value you have specified to be a literal value.

Parent topic: COBCH0041 - COBCH0060


COBCH0045 Operand data-name has wrong size

The operand in this statement is the wrong length (for example, you have specified a prompt character more than one character long).

Resolution:

Click Related Topics for information on the correct length of the operand.

Parent topic: COBCH0041 - COBCH0060


COBCH0046 Alphabet name required

You must specify the name of a user-defined collating sequence here.

Resolution:

The name of the alphabet that you have defined in the SPECIAL-NAMES paragraph should be specified.

Parent topic: COBCH0041 - COBCH0060


COBCH0047 Numeric literal or ZERO expected

You must specify a numeric literal or the figurative constant ZERO here.

Resolution:

Specify a numeric literal or ZERO.

Parent topic: COBCH0041 - COBCH0060


COBCH0048 Missing or extra right parenthesis

The number of left and right parentheses in an arithmetic expression is not the same.

Resolution:

Check the format of the arithmetic expression and ensure that you have a matching right parenthesis for each left parenthesis.

Parent topic: COBCH0041 - COBCH0060


COBCH0049 Illegal use of Index-name or Index Data item

You have used an item with USAGE INDEX in a context where it is not allowed. Click Related Topics for details of where you can use such items.

Resolution:

Change the USAGE of the item, or use an item that does not have USAGE INDEX.

Parent topic: COBCH0041 - COBCH0060


COBCH0050 Illegal use of POINTER data item, ADDRESS OF or NULL

You have tried to perform an illegal operation on a data item with USAGE POINTER. Alternatively, you have tried to apply the ADDRESS OF phrase to an item that is not an 01 or 77 level item in the Working-Storage or Linkage Section.

Resolution:

Click Related Topics for details of the operations you can perform on pointer items.

Parent topic: COBCH0041 - COBCH0060


COBCH0051 Not a report name

You must use a report-name in this context. You have probably misspelled a valid report-name.

Resolution:

Correct the reference.

Parent topic: COBCH0041 - COBCH0060


COBCH0052 Only allowed with SEQUENTIAL files

You have performed an operation that is permitted only if the file has SEQUENTIAL organization (for example, CLOSE REEL/UNIT).

Resolution:

Change the file organization to SEQUENTIAL.

Parent topic: COBCH0041 - COBCH0060


COBCH0053 Directive directive invalid or not allowed here

You have either specified a COBOL system directive in the wrong place or specified an invalid COBOL system directive in a $SET statement in your program.

Resolution:

For example, you can specify a $SET LIST anywhere, but a $SET PREPROCESS only on the first line.

Parent topic: COBCH0041 - COBCH0060


COBCH0054 Class name required

You have failed to define the class-name in the SPECIAL-NAMES paragraph, or you have misspelled a COBOL class-name.

Resolution:

Either define the class-name in the SPECIAL-NAMES paragraph, or make sure you have spelled the the COBOL class-name you want to use correctly.

Parent topic: COBCH0041 - COBCH0060


COBCH0055 Index-name set to value greater than table size

A SET index-name TO literal statement has been used to try to set an index name to a value greater than the number in the OCCURS clause for which that index name belongs.
Parent topic: COBCH0041 - COBCH0060


COBCH0056 COPY is recursive

One of the following:
  • You have tried to COPY a file that you have already started copying.
  • You have incorrectly spelled the name of either the file you have previously started to COPY, or the file you currently want to copy.

Resolution:

Revise your program so that the file you have already started to COPY is copied completely before you try to COPY the same file again.

Correct the spelling error.

Parent topic: COBCH0041 - COBCH0060


COBCH0057 Not a report group

You must use a report group in this context. You have probably misspelled a valid report group-name.

Resolution:

Correct the reference.

Parent topic: COBCH0041 - COBCH0060


COBCH0058 Not a report name or a report group

You have specified neither a valid report-name nor a valid report group in a GENERATE statement. You have probably misspelled the report-name or the report group.

Resolution:

Correct your reference to the report-name or to the report group.

Parent topic: COBCH0041 - COBCH0060


COBCH0059 Cannot GENERATE this report name

The report-name that you have specified should contain all of the following:
  • A CONTROL clause
  • Only one DETAIL report group
  • At least one body group.

Resolution:

Click related topics for details of the contents you require for a report-name when it is used in a GENERATE statement.

Parent topic: COBCH0041 - COBCH0060


COBCH0060 Not a detail group

You have specified a report group that is not of TYPE DETAIL.

Resolution:

Revise your program so that the report group is of TYPE DETAIL.

Parent topic: COBCH0041 - COBCH0060


COBCH0061 - COBCH0080

Lists the Syntax Checking error messages from COBCH0061 through COBCH0080.

  • COBCH0061 Pseudo text incorrectly specified
    A two-character delimiter for pseudotext is missing from either a REPLACE or COPY REPLACING statement.
  • COBCH0062 Nested COPY replacement not supported
    You cannot specify text replacement in a COPY statement when text replacement is already active in a containing COPY statement.
  • COBCH0063 Cannot be used in nested program
    Your program contains a statement or clause that is not valid in a nested program.
  • COBCH0064 If file is EXTERNAL, then PADDING CHARACTER must be also
    If a file is defined as EXTERNAL then the data item specified in the associated PADDING CHARACTER clause must also be defined as EXTERNAL.
  • COBCH0065 Unsigned integer required
    An unsigned integer was expected but not supplied.
  • COBCH0066 Data item must have fixed location
    An item which is part of an OCCURS ... DEPENDING ON (ODO) table entry is being used as a subscript to the table, or to another ODO table earlier in the group. This is not allowed.
  • COBCH0068 SQL error
    The compiler detected the error shown on your screen in your SQL syntax.
  • COBCH0069 Error code code during SQL Remote Precompile. Cannot continue.
    The compiler detected the error code ruring the remote SQL precompile.
  • COBCH0070 Invalid argument
    You have either specified a COBOL system directive with an invalid argument in a $SET statement in your program or you have specified an incorrect argument type for an intrinsic function.
  • COBCH0071 PROCEDURE DIVISION missing or unknown statement
    You have omitted the PROCEDURE DIVISION header, and have then started without a verb.
  • COBCH0072 Invalid FUNCTION name
    The name specified after the word FUNCTION is not a recognized function-name. It is possible you are using the word "function" as a data-name. This word is a reserved word.
  • COBCH0073 Missing left parenthesis
    You have specified an intrinsic function which requires parameters, but have not preceded the parameter list with a left parenthesis.
  • COBCH0074 Numeric argument expected
    You have specified a nonnumeric argument with an intrinsic function which is expecting a numeric argument.
  • COBCH0075 Alphanumeric argument expected
    You have specified a numeric argument with an intrinsic function where an alphanumeric argument was expected.
  • COBCH0076 Illegal combination of argument types
    The set of arguments you have specified with an intrinsic function do not match the types required for that function.
  • COBCH0077 Unexpected end of source within EXEC
    The end of a program source was encountered in an EXEC statement. This probably indicates that an END-EXEC has been omitted earlier in the program.
  • COBCH0078 Numeric function not allowed
    You have specified an intrinsic function that returns a numeric value in a position where a numeric value is not allowed.
  • COBCH0079 Argument must have length 1
    The argument you have specified does not have a length of 1.
  • COBCH0080 Prompt character incompatible for ACCEPT
Parent topic: Messages COBCH0001 to COBCH0100


COBCH0061 Pseudo text incorrectly specified

A two-character delimiter for pseudotext is missing from either a REPLACE or COPY REPLACING statement.

Resolution:

Insert the missing pseudotext delimiter (that is, ==) at the appropriate point in your program.

Parent topic: COBCH0061 - COBCH0080


COBCH0062 Nested COPY replacement not supported

You cannot specify text replacement in a COPY statement when text replacement is already active in a containing COPY statement.
Parent topic: COBCH0061 - COBCH0080


COBCH0063 Cannot be used in nested program

Your program contains a statement or clause that is not valid in a nested program.

Resolution:

Click Related Topics for the valid structure of a nested program.

Parent topic: COBCH0061 - COBCH0080


COBCH0064 If file is EXTERNAL, then PADDING CHARACTER must be also

If a file is defined as EXTERNAL then the data item specified in the associated PADDING CHARACTER clause must also be defined as EXTERNAL.
Parent topic: COBCH0061 - COBCH0080


COBCH0065 Unsigned integer required

An unsigned integer was expected but not supplied.

Resolution:

Specify an unsigned integer.

Parent topic: COBCH0061 - COBCH0080


COBCH0066 Data item must have fixed location

An item which is part of an OCCURS ... DEPENDING ON (ODO) table entry is being used as a subscript to the table, or to another ODO table earlier in the group. This is not allowed.

Resolution:

Move the item to a location outside the ODO and use that item in this statement.

Parent topic: COBCH0061 - COBCH0080


COBCH0068 SQL error

The compiler detected the error shown on your screen in your SQL syntax.

Resolution:

Refer to your SQL documentation for details of valid SQL syntax.

Parent topic: COBCH0061 - COBCH0080


COBCH0069 Error code code during SQL Remote Precompile. Cannot continue.

The compiler detected the error code ruring the remote SQL precompile.

Resolution:

Refer to your SQL documentation for details of valid SQL syntax.

Parent topic: COBCH0061 - COBCH0080


COBCH0070 Invalid argument

You have either specified a COBOL system directive with an invalid argument in a $SET statement in your program or you have specified an incorrect argument type for an intrinsic function.

Resolution:

Correct the arguments.

Parent topic: COBCH0061 - COBCH0080


COBCH0071 PROCEDURE DIVISION missing or unknown statement

You have omitted the PROCEDURE DIVISION header, and have then started without a verb.
Parent topic: COBCH0061 - COBCH0080


COBCH0072 Invalid FUNCTION name

The name specified after the word FUNCTION is not a recognized function-name. It is possible you are using the word "function" as a data-name. This word is a reserved word.

Resolution:

If you require an intrinsic function, ensure the name you have used is correct. If you want to use function as a data-name, resubmit your program with the directive REMOVE"FUNCTION" to remove the word FUNCTION from the reserved word list.

Parent topic: COBCH0061 - COBCH0080


COBCH0073 Missing left parenthesis

You have specified an intrinsic function which requires parameters, but have not preceded the parameter list with a left parenthesis.

Resolution:

Check the format of the intrinsic function and ensure that you have a matching left parenthesis for each right parenthesis.

Parent topic: COBCH0061 - COBCH0080


COBCH0074 Numeric argument expected

You have specified a nonnumeric argument with an intrinsic function which is expecting a numeric argument.

Resolution:

Make the argument numeric.

Parent topic: COBCH0061 - COBCH0080


COBCH0075 Alphanumeric argument expected

You have specified a numeric argument with an intrinsic function where an alphanumeric argument was expected.

Resolution:

Make the argument alphanumeric.

Parent topic: COBCH0061 - COBCH0080


COBCH0076 Illegal combination of argument types

The set of arguments you have specified with an intrinsic function do not match the types required for that function.

Resolution:

Revise your code to comply with the rules governing the construction of argument types.

Parent topic: COBCH0061 - COBCH0080


COBCH0077 Unexpected end of source within EXEC

The end of a program source was encountered in an EXEC statement. This probably indicates that an END-EXEC has been omitted earlier in the program.

Resolution:

Ensure that each EXEC has a matching END-EXEC.

Parent topic: COBCH0061 - COBCH0080


COBCH0078 Numeric function not allowed

You have specified an intrinsic function that returns a numeric value in a position where a numeric value is not allowed.

Resolution:

Make the intrinsic function nonnumeric.

Parent topic: COBCH0061 - COBCH0080


COBCH0079 Argument must have length 1

The argument you have specified does not have a length of 1.

Resolution:

Change your argument, specifying length 1.

Parent topic: COBCH0061 - COBCH0080


COBCH0080 Prompt character incompatible for ACCEPT

Parent topic: COBCH0061 - COBCH0080


COBCH0081 - COBCH0100

Lists the Syntax Checking error messages from COBCH0081 through COBCH0100.

  • COBCH0081 Please recompile using a larger value for LOCALCOUNT directive
    Related Topics
  • COBCH0082 COBOL Division or Section header encountered in incorrect order
    A COBOL Division or Section header was encountered in the wrong order in the source. For example, LINKAGE SECTION was encountered after SCREEN SECTION had already been read.
  • COBCH0083 Reserved word missing - word expected
    The reserved word word was expected but not found.
  • COBCH0084 SQL statement only allowed in the Procedure Division
  • COBCH0085 SQL statement only allowed in the Data Division
  • COBCH0086 Constant-name data-name same as reserved word
  • COBCH0087 SIZE must be a positive integer
    You have use the syntax CALL BY VALUE SIZE size with an invalid size.
  • COBCH0088 A SQL host variable name contains an underscore - illegal COBOL character.
    A host variable inside an SQL statement contained an underscore character and could not be processed.
  • COBCH0089 SQL statement contains more than one SQLDA.
    The COBOL system found more than one COBOL data items used as SQL Descriptor Areas in a single SQL statement, which is illegal.
  • COBCH0090 Too many errors
    The number of messages produced has reached the limit specified by the MAXERROR directive.
  • COBCH0091 Syntax not compatible with FILETYPE(11)
  • COBCH0092 Redefinition causes ambiguity in location of sliding data-item
  • COBCH0093 User-name not unique. Assumed qualified by current 01 level record
    The specified user-name is not unique, but has been qualified by the current 01 level item.
  • COBCH0094 Name is not a COBOL word
    The name you have specified is not a reserved word in COBOL.
  • COBCH0095 Literal used as COPY name
  • COBCH0096 Lower case used (future occurrences not flagged)
    You have used lower case where upper case was expected.
  • COBCH0097 Both single and double quotes used (future occurrences not flagged)
  • COBCH0098 Single quotes (apostrophe) used (future occurrences not flagged)
  • COBCH0099 Nested COPY file
  • COBCH0100 Sequence number out of order
    One or more numbers in your source code are out of sequence.
Parent topic: Messages COBCH0001 to COBCH0100


COBCH0081 Please recompile using a larger value for LOCALCOUNT directive

Related Topics
Parent topic: COBCH0081 - COBCH0100


COBCH0082 COBOL Division or Section header encountered in incorrect order

A COBOL Division or Section header was encountered in the wrong order in the source. For example, LINKAGE SECTION was encountered after SCREEN SECTION had already been read.
Parent topic: COBCH0081 - COBCH0100


COBCH0083 Reserved word missing - word expected

The reserved word word was expected but not found.
Parent topic: COBCH0081 - COBCH0100


COBCH0084 SQL statement only allowed in the Procedure Division

Parent topic: COBCH0081 - COBCH0100


COBCH0085 SQL statement only allowed in the Data Division

Parent topic: COBCH0081 - COBCH0100


COBCH0086 Constant-name data-name same as reserved word

Parent topic: COBCH0081 - COBCH0100


COBCH0087 SIZE must be a positive integer

You have use the syntax CALL BY VALUE SIZE size with an invalid size.

Resolution:

Recode with a valid positive integer.

Parent topic: COBCH0081 - COBCH0100


COBCH0088 A SQL host variable name contains an underscore - illegal COBOL character.

A host variable inside an SQL statement contained an underscore character and could not be processed.

Resolution:

Remove the underscore character. The message usually indicates that an underscore was used where a hyphen (-) was intended.

Parent topic: COBCH0081 - COBCH0100


COBCH0089 SQL statement contains more than one SQLDA.

The COBOL system found more than one COBOL data items used as SQL Descriptor Areas in a single SQL statement, which is illegal.

Resolution:

Ensure that the correct data items are used. The message is produced when the Compiler directive SQL(NODB2) is set and host variables are not declared inside the SQL DECLARE SECTION.

Parent topic: COBCH0081 - COBCH0100


COBCH0090 Too many errors

The number of messages produced has reached the limit specified by the MAXERROR directive.
Parent topic: COBCH0081 - COBCH0100


COBCH0091 Syntax not compatible with FILETYPE(11)

Parent topic: COBCH0081 - COBCH0100


COBCH0092 Redefinition causes ambiguity in location of sliding data-item

Parent topic: COBCH0081 - COBCH0100


COBCH0093 User-name not unique. Assumed qualified by current 01 level record

The specified user-name is not unique, but has been qualified by the current 01 level item.
Parent topic: COBCH0081 - COBCH0100


COBCH0094 Name is not a COBOL word

The name you have specified is not a reserved word in COBOL.

Resolution:

Change the name accordingly.

Parent topic: COBCH0081 - COBCH0100


COBCH0095 Literal used as COPY name

Parent topic: COBCH0081 - COBCH0100


COBCH0096 Lower case used (future occurrences not flagged)

You have used lower case where upper case was expected.
Parent topic: COBCH0081 - COBCH0100


COBCH0097 Both single and double quotes used (future occurrences not flagged)

Parent topic: COBCH0081 - COBCH0100


COBCH0098 Single quotes (apostrophe) used (future occurrences not flagged)

Parent topic: COBCH0081 - COBCH0100


COBCH0099 Nested COPY file

Parent topic: COBCH0081 - COBCH0100


COBCH0100 Sequence number out of order

One or more numbers in your source code are out of sequence.

Resolution:

Check that all sequence numbers are specified in correct numeric order.

Parent topic: COBCH0081 - COBCH0100


Messages COBCH0101 to COBCH0200

  • COBCH0101 - COBCH0120
    Lists the Syntax Checking error messages from COBCH0101 through COBCH0120.
  • COBCH0121 - COBCH0140
    Lists the Syntax Checking error messages from COBCH0121 through COBCH0140.
  • COBCH0141 - COBCH0160
    Lists the Syntax Checking error messages from COBCH0141 through COBCH0160.
  • COBCH0161 - COBCH0180
    Lists the Syntax Checking error messages from COBCH0161 through COBCH0180.
  • COBCH0181 - COBCH0200
    Lists the Syntax Checking error messages from COBCH0181 through COBCH0200.
Parent topic: Syntax Checking Error Messages


COBCH0101 - COBCH0120

Lists the Syntax Checking error messages from COBCH0101 through COBCH0120.

  • COBCH0101 Assignment-name is data-name
  • COBCH0102 RELATIVE KEY clause should immediately follow ACCESS clause
    Related Topics
  • COBCH0103 RECORD missing
    You have omitted the word RECORD.
  • COBCH0104 IDENTIFICATION missing
  • COBCH0105 PROGRAM-ID missing
    You have omitted the word PROGRAM-ID from the PROGRAM-ID paragraph.
  • COBCH0106 PROGRAM-ID has illegal format
    You have specified an invalid program-name in the PROGRAM-ID paragraph.
  • COBCH0107 Second status area
    You cannot have more than one identifier after the FILE STATUS clause.
  • COBCH0108 OPTIONAL not permitted on non-sequential file
  • COBCH0109 Paragraphs or phrases in non-standard order or repeated
    You have either specified paragraphs in the wrong order, or a paragraph twice, or SPECIAL-NAMES clauses in a nonstandard order.
  • COBCH0110 ENVIRONMENT missing
    You have omitted the word ENVIRONMENT.
  • COBCH0111 CONFIGURATION missing
    You have omitted the word CONFIGURATION.
  • COBCH0112 SOURCE-COMPUTER missing
    You have omitted the words SOURCE-COMPUTER.
  • COBCH0113 SPECIAL-NAMES clause error
    You have not specified the SPECIAL-NAMES paragraph correctly.
  • COBCH0114 OBJECT-COMPUTER missing
    You have omitted the words OBJECT-COMPUTER.
  • COBCH0115 OBJECT-COMPUTER clause not recognized
    You have specified the OBJECT-COMPUTER paragraph incorrectly.
  • COBCH0116 Character specified twice in alphabet
    You have specified at least one character twice in the ALPHABET clause. For example, you might have included a character in a range and also specified it as a literal.
  • COBCH0117 SWITCH clause error or system name/mnemonic name error
    An error exists in the coding of the SWITCH clause of the SPECIAL-NAMES paragraph in the Environment Division of your program.
  • COBCH0118 COMMA expected
    You have omitted the word COMMA from the DECIMAL-POINT clause.
  • COBCH0119 CRT expected
    You have used a COBOL word or user-defined word where your COBOL system expected the reserved word CRT.
  • COBCH0120 Illegal currency symbol
    The literal which you have specified in the CURRENCY SIGN IS clause in the SPECIAL-NAMES paragraph of your program is not one of those permitted under the rules of COBOL syntax, or if it is then you have failed to enclose it in quotation marks. The literal must be a single character, not a digit, and cannot be any of the following, A B C D L P S V X Z * + - , . ; ( ) " / = or space (except in ANS85 where L is valid).
Parent topic: Messages COBCH0101 to COBCH0200


COBCH0101 Assignment-name is data-name

Parent topic: COBCH0101 - COBCH0120


COBCH0102 RELATIVE KEY clause should immediately follow ACCESS clause

Related Topics
Parent topic: COBCH0101 - COBCH0120


COBCH0103 RECORD missing

You have omitted the word RECORD.

Resolution:

Add the word RECORD.

Parent topic: COBCH0101 - COBCH0120


COBCH0104 IDENTIFICATION missing

Parent topic: COBCH0101 - COBCH0120


COBCH0105 PROGRAM-ID missing

You have omitted the word PROGRAM-ID from the PROGRAM-ID paragraph.

Resolution:

Add the word PROGRAM-ID to the PROGRAM-ID paragraph.

Parent topic: COBCH0101 - COBCH0120


COBCH0106 PROGRAM-ID has illegal format

You have specified an invalid program-name in the PROGRAM-ID paragraph.

Resolution:

Correct the format of program-names.

Parent topic: COBCH0101 - COBCH0120


COBCH0107 Second status area

You cannot have more than one identifier after the FILE STATUS clause.
Parent topic: COBCH0101 - COBCH0120


COBCH0108 OPTIONAL not permitted on non-sequential file

Parent topic: COBCH0101 - COBCH0120


COBCH0109 Paragraphs or phrases in non-standard order or repeated

You have either specified paragraphs in the wrong order, or a paragraph twice, or SPECIAL-NAMES clauses in a nonstandard order.

Resolution:

If you have repeated any of these, delete the repetition.

Parent topic: COBCH0101 - COBCH0120


COBCH0110 ENVIRONMENT missing

You have omitted the word ENVIRONMENT.

Resolution:

Add the word ENVIRONMENT.

Parent topic: COBCH0101 - COBCH0120


COBCH0111 CONFIGURATION missing

You have omitted the word CONFIGURATION.

Resolution:

Add the word CONFIGURATION.

Parent topic: COBCH0101 - COBCH0120


COBCH0112 SOURCE-COMPUTER missing

You have omitted the words SOURCE-COMPUTER.

Resolution:

Add the words SOURCE-COMPUTER.

Parent topic: COBCH0101 - COBCH0120


COBCH0113 SPECIAL-NAMES clause error

You have not specified the SPECIAL-NAMES paragraph correctly.

Resolution:

Correct the format of the SPECIAL-NAMES paragraph.

Parent topic: COBCH0101 - COBCH0120


COBCH0114 OBJECT-COMPUTER missing

You have omitted the words OBJECT-COMPUTER.

Resolution:

Add the words OBJECT-COMPUTER.

Parent topic: COBCH0101 - COBCH0120


COBCH0115 OBJECT-COMPUTER clause not recognized

You have specified the OBJECT-COMPUTER paragraph incorrectly.

Resolution:

Correct the format of the OBJECT-COMPUTER paragraph.

Parent topic: COBCH0101 - COBCH0120


COBCH0116 Character specified twice in alphabet

You have specified at least one character twice in the ALPHABET clause. For example, you might have included a character in a range and also specified it as a literal.

Resolution:

Edit your source code so that the characters specified in the ALPHABET clause are referenced only once.

Parent topic: COBCH0101 - COBCH0120


COBCH0117 SWITCH clause error or system name/mnemonic name error

An error exists in the coding of the SWITCH clause of the SPECIAL-NAMES paragraph in the Environment Division of your program.

Resolution:

Revise your program accordingly. Ensure that each condition named in this clause is declared in the Data Division.

Parent topic: COBCH0101 - COBCH0120


COBCH0118 COMMA expected

You have omitted the word COMMA from the DECIMAL-POINT clause.

Resolution:

Add the word COMMA.

Parent topic: COBCH0101 - COBCH0120


COBCH0119 CRT expected

You have used a COBOL word or user-defined word where your COBOL system expected the reserved word CRT.

Resolution:

Edit your code so that the reserved word CRT is used.

Parent topic: COBCH0101 - COBCH0120


COBCH0120 Illegal currency symbol

The literal which you have specified in the CURRENCY SIGN IS clause in the SPECIAL-NAMES paragraph of your program is not one of those permitted under the rules of COBOL syntax, or if it is then you have failed to enclose it in quotation marks. The literal must be a single character, not a digit, and cannot be any of the following, A B C D L P S V X Z * + - , . ; ( ) " / = or space (except in ANS85 where L is valid).

Resolution:

Change the literal to a permitted character and ensure that it is enclosed in quotation marks.

Parent topic: COBCH0101 - COBCH0120


COBCH0121 - COBCH0140

Lists the Syntax Checking error messages from COBCH0121 through COBCH0140.

  • COBCH0121 Cannot specify DYNAMIC or EXTERNAL with literal file name
    You can specify DYNAMIC or EXTERNAL in the ASSIGN clause of a file description entry only if the filename is contained in a data item rather than given as a literal filename.
  • COBCH0122 Cannot use Double Byte characters in alphabet or class definition
    When defining an alphabet or class, you cannot use double-byte characters.
  • COBCH0123 I-O-CONTROL missing
    You have omitted the heading I-O-CONTROL.
  • COBCH0124 INPUT-OUTPUT missing
    You have omitted the heading INPUT-OUTPUT.
  • COBCH0125 FILE-CONTROL missing
    You have omitted the heading FILE-CONTROL.
  • COBCH0126 ASSIGN missing
    You have used a SELECT clause to give a file a filename which the program recognizes, but you have failed to use a corresponding ASSIGN clause to give the file an implementor-name (the name which the system recognizes).
  • COBCH0127 [LINE] SEQUENTIAL, RELATIVE or INDEXED missing
    In the ORGANIZATION IS clause of the FILE-CONTROL paragraph you have failed to specify the logical structure your file is to take.
  • COBCH0128 ACCESS missing on indexed/relative file
    The format of this clause depends on the organization of the data-file. If you have specified the ORGANIZATION clause for a file as either INDEXED or RELATIVE you must specify an ACCESS MODE clause for it, indicating which mode you will use to access that file. If no mode is specified, sequential access mode is assumed.
  • COBCH0129 Too many keys or key components
    The number of separate data items making up the record key and alternate key fields of one indexed file is too great.
  • COBCH0130 Illegal ORGANIZATION/ACCESS/KEY combination
    If you have specified these clauses in your program, they must be compatible, but in your program they are not.
  • COBCH0131 Unrecognized phrase in SELECT clause
    Your COBOL system has failed to accept part of your SELECT clause. This message could be given if the filename which you have given in the SELECT clause does not conform to the rules for the naming of COBOL files.
  • COBCH0132 Repeated "condition-name TO TRUE/FALSE" in SET statement
    You have specified a repeated "condition-name to TRUE/FALSE" phrase in a single SET statement. This does not conform to your selected flagging dialect.
  • COBCH0133 SAME AREA clause syntax error
    This optional clause, by which you allow two or more files to access the same central storage space, does not conform to the relevant syntax rules.
  • COBCH0134 FILE SECTION missing
    You have omitted the heading FILE SECTION.
  • COBCH0135 DATA DIVISION missing
    You have omitted the heading DATA DIVISION.
  • COBCH0136 Illegal use of phrase for National Locale operation
    You have included one or more of the following COBOL clauses in your program:
  • COBCH0137 Program collating sequence not defined
    You have included the PROGRAM COLLATING SEQUENCE clause in the OBJECT-COMPUTER paragraph of your code but have failed to code a corresponding ALPHABET-NAME in the SPECIAL-NAMES paragraph. Your code must contain an ALPHABET-NAME clause if it has a PROGRAM COLLATING SEQUENCE clause in it.
  • COBCH0138 "EXCLUSIVE", "AUTOMATIC" or "MANUAL" missing
    The LOCK MODE clause in the FILE-CONTROL paragraph of the Environment Division does not contain one of the words EXCLUSIVE, AUTOMATIC, or MANUAL, or if it does, your COBOL system has failed to recognize the word, perhaps owing to a spelling mistake. The LOCK MODE clause controls access to files shared between a number of users in a multi-user environment. Its form is determined by the filetype with which it is used.
  • COBCH0139 Illegal LOCK MODE/file type combination
    The format of the LOCK MODE clause depends on the file type. You have specified a LOCK MODE clause which is incompatible with the type of the specified file. Non-shareable files must have lock mode EXCLUSIVE while shareable files can have lock mode AUTOMATIC or MANUAL.
  • COBCH0140 For indexed file, PASSWORD phrase must follow KEY
    For an indexed sequential file description entry, any PASSWORD phrase must immediately follow the KEY phrase.
Parent topic: Messages COBCH0101 to COBCH0200


COBCH0121 Cannot specify DYNAMIC or EXTERNAL with literal file name

You can specify DYNAMIC or EXTERNAL in the ASSIGN clause of a file description entry only if the filename is contained in a data item rather than given as a literal filename.

Resolution:

Redesign your program so that the filename is contained in a data item.

Parent topic: COBCH0121 - COBCH0140


COBCH0122 Cannot use Double Byte characters in alphabet or class definition

When defining an alphabet or class, you cannot use double-byte characters.

Resolution:

Redesign your program so that your alphabet or class definition does not include any double-byte characters.

Parent topic: COBCH0121 - COBCH0140


COBCH0123 I-O-CONTROL missing

You have omitted the heading I-O-CONTROL.

Resolution:

Add the heading I-O-CONTROL.

Parent topic: COBCH0121 - COBCH0140


COBCH0124 INPUT-OUTPUT missing

You have omitted the heading INPUT-OUTPUT.

Resolution:

Add the heading INPUT-OUTPUT.

Parent topic: COBCH0121 - COBCH0140


COBCH0125 FILE-CONTROL missing

You have omitted the heading FILE-CONTROL.

Resolution:

Add the heading FILE-CONTROL.

Parent topic: COBCH0121 - COBCH0140


COBCH0126 ASSIGN missing

You have used a SELECT clause to give a file a filename which the program recognizes, but you have failed to use a corresponding ASSIGN clause to give the file an implementor-name (the name which the system recognizes).

Resolution:

Insert the relevant ASSIGN clause after the SELECT clause.

Parent topic: COBCH0121 - COBCH0140


COBCH0127 [LINE] SEQUENTIAL, RELATIVE or INDEXED missing

In the ORGANIZATION IS clause of the FILE-CONTROL paragraph you have failed to specify the logical structure your file is to take.

Resolution:

Insert [LINE] SEQUENTIAL, INDEXED, or RELATIVE into this clause depending on how you want your records to be stored and accessed in your file.

Parent topic: COBCH0121 - COBCH0140


COBCH0128 ACCESS missing on indexed/relative file

The format of this clause depends on the organization of the data-file. If you have specified the ORGANIZATION clause for a file as either INDEXED or RELATIVE you must specify an ACCESS MODE clause for it, indicating which mode you will use to access that file. If no mode is specified, sequential access mode is assumed.

Resolution:

Click Related Topics for information on the use of the ACCESS MODE clause.

Parent topic: COBCH0121 - COBCH0140


COBCH0129 Too many keys or key components

The number of separate data items making up the record key and alternate key fields of one indexed file is too great.

Resolution:

Simplify your program so you do not need so many keys, or components of keys, to the file.

Parent topic: COBCH0121 - COBCH0140


COBCH0130 Illegal ORGANIZATION/ACCESS/KEY combination

If you have specified these clauses in your program, they must be compatible, but in your program they are not.

Resolution:

Ensure that these clauses are compatible.

Parent topic: COBCH0121 - COBCH0140


COBCH0131 Unrecognized phrase in SELECT clause

Your COBOL system has failed to accept part of your SELECT clause. This message could be given if the filename which you have given in the SELECT clause does not conform to the rules for the naming of COBOL files.

Resolution:

Click Related Topics for more information.

Parent topic: COBCH0121 - COBCH0140


COBCH0132 Repeated "condition-name TO TRUE/FALSE" in SET statement

You have specified a repeated "condition-name to TRUE/FALSE" phrase in a single SET statement. This does not conform to your selected flagging dialect.

Resolution:

Split into two separate SET statements.

Parent topic: COBCH0121 - COBCH0140


COBCH0133 SAME AREA clause syntax error

This optional clause, by which you allow two or more files to access the same central storage space, does not conform to the relevant syntax rules.

Resolution:

Correct the format for this clause.

Parent topic: COBCH0121 - COBCH0140


COBCH0134 FILE SECTION missing

You have omitted the heading FILE SECTION.

Resolution:

Add the heading FILE SECTION.

Parent topic: COBCH0121 - COBCH0140


COBCH0135 DATA DIVISION missing

You have omitted the heading DATA DIVISION.

Resolution:

Add the heading DATA DIVISION.

Parent topic: COBCH0121 - COBCH0140


COBCH0136 Illegal use of phrase for National Locale operation

You have included one or more of the following COBOL clauses in your program:
PROGRAM COLLATING SEQUENCE IS
ALPHABET IS
CURRENCY SIGN IS
DECIMAL-POINT IS COMMA
and you have submitted the program with the NLS (National Locale Support) directive on, which is not allowed.

Resolution:

Either turn the NLS directive off, or edit your source code to ensure none of the above clauses appear in the program.

Parent topic: COBCH0121 - COBCH0140


COBCH0137 Program collating sequence not defined

You have included the PROGRAM COLLATING SEQUENCE clause in the OBJECT-COMPUTER paragraph of your code but have failed to code a corresponding ALPHABET-NAME in the SPECIAL-NAMES paragraph. Your code must contain an ALPHABET-NAME clause if it has a PROGRAM COLLATING SEQUENCE clause in it.

Resolution:

Insert the necessary ALPHABET-NAME clause ensuring it has the same user-defined-name as that used in the SEQUENCE entry. If you have specified both of these clauses in your code but have still received this message then ensure that you have used the same user-defined-name in each and that it is spelled the same in both. Correct any spelling error your code might contain.

Parent topic: COBCH0121 - COBCH0140


COBCH0138 "EXCLUSIVE", "AUTOMATIC" or "MANUAL" missing

The LOCK MODE clause in the FILE-CONTROL paragraph of the Environment Division does not contain one of the words EXCLUSIVE, AUTOMATIC, or MANUAL, or if it does, your COBOL system has failed to recognize the word, perhaps owing to a spelling mistake. The LOCK MODE clause controls access to files shared between a number of users in a multi-user environment. Its form is determined by the filetype with which it is used.

Resolution:

Correct the LOCK MODE clause.

Parent topic: COBCH0121 - COBCH0140


COBCH0139 Illegal LOCK MODE/file type combination

The format of the LOCK MODE clause depends on the file type. You have specified a LOCK MODE clause which is incompatible with the type of the specified file. Non-shareable files must have lock mode EXCLUSIVE while shareable files can have lock mode AUTOMATIC or MANUAL.

Resolution:

Correct the LOCK MODE clause.

Parent topic: COBCH0121 - COBCH0140


COBCH0140 For indexed file, PASSWORD phrase must follow KEY

For an indexed sequential file description entry, any PASSWORD phrase must immediately follow the KEY phrase.

Resolution:

Edit your program so that the PASSWORD phrase immediately follows the KEY phrase.

Parent topic: COBCH0121 - COBCH0140


COBCH0141 - COBCH0160

Lists the Syntax Checking error messages from COBCH0141 through COBCH0160.

  • COBCH0141 File name appears in more than one SAME clause of same type
    A file can appear in only one SAME AREA or SAME RECORD AREA clause.
  • COBCH0142 Can only be used in nested program
    A clause you have specified is allowed only in a nested program. For example, the COMMON clause, as defined by ANSI.
  • COBCH0143 Unknown Identification Division paragraph
    The paragraph header specified is not a legal paragraph of the Identification Division; at least, not in the selected COBOL dialect.
  • COBCH0144 OCCURS DEPENDING subsidiary to OCCURS only allowed with ODOSLIDE
    You have a record containing OCCURS DEPENDING ON as part of a record defined with OCCURS.
  • COBCH0145 "SET condition-name TO" syntax used
    The SET condition-name TO ... syntax is not a part of your chosen flagging dialect.
  • COBCH0146 Condition-name set to FALSE
    You have tried to SET a condition-name to FALSE. This is not a part of your chosen flagging dialect.
  • COBCH0147 Data item must be unsigned
    You have used the syntax RECORD VARYING IN SIZE DEPENDING ON signed-data-item which does not conform with your selected flagging dialect.
  • COBCH0148 Status condition missing
    You have failed to specify a status condition following a function-name IS mnemonic-name clause in the SPECIAL-NAMES paragraph. This is not conformant with your selected flagging dialect.
  • COBCH0149 No SQL directives have been set
    An EXEC SQL statement has been encountered but no SQL directive has been specified. The processing of the statement varies depending on whether the directive SQL is set or not; either SQL or NOSQL must be explicitly specified.
  • COBCH0154 COPY REPLACING nested within COPY
    A COPY REPLACING statement has been detected, nested under another COPY.
  • COBCH0155 Numeric item should be an integer and without a 'P' in its picture clause
    Where one of the identifiers in a STRING statement is an elementary numeric data item, it must be described as an integer without the 'P' symbol in its PICTURE clause.
  • COBCH0156 Period found in wrong area of source line
Parent topic: Messages COBCH0101 to COBCH0200


COBCH0141 File name appears in more than one SAME clause of same type

A file can appear in only one SAME AREA or SAME RECORD AREA clause.

Resolution:

Revise your program.

Parent topic: COBCH0141 - COBCH0160


COBCH0142 Can only be used in nested program

A clause you have specified is allowed only in a nested program. For example, the COMMON clause, as defined by ANSI.

Resolution:

Revise your program.

Parent topic: COBCH0141 - COBCH0160


COBCH0143 Unknown Identification Division paragraph

The paragraph header specified is not a legal paragraph of the Identification Division; at least, not in the selected COBOL dialect.

Resolution:

Revise your program or select another COBOL dialect.

Parent topic: COBCH0141 - COBCH0160


COBCH0144 OCCURS DEPENDING subsidiary to OCCURS only allowed with ODOSLIDE

You have a record containing OCCURS DEPENDING ON as part of a record defined with OCCURS.

Resolution:

Set the ODOSLIDE directive.

Parent topic: COBCH0141 - COBCH0160


COBCH0145 "SET condition-name TO" syntax used

The SET condition-name TO ... syntax is not a part of your chosen flagging dialect.
Parent topic: COBCH0141 - COBCH0160


COBCH0146 Condition-name set to FALSE

You have tried to SET a condition-name to FALSE. This is not a part of your chosen flagging dialect.
Parent topic: COBCH0141 - COBCH0160


COBCH0147 Data item must be unsigned

You have used the syntax RECORD VARYING IN SIZE DEPENDING ON signed-data-item which does not conform with your selected flagging dialect.

Resolution:

Recode with an unsigned data item.

Parent topic: COBCH0141 - COBCH0160


COBCH0148 Status condition missing

You have failed to specify a status condition following a function-name IS mnemonic-name clause in the SPECIAL-NAMES paragraph. This is not conformant with your selected flagging dialect.

Resolution:

Specify at least one status condition.

Parent topic: COBCH0141 - COBCH0160


COBCH0149 No SQL directives have been set

An EXEC SQL statement has been encountered but no SQL directive has been specified. The processing of the statement varies depending on whether the directive SQL is set or not; either SQL or NOSQL must be explicitly specified.
Parent topic: COBCH0141 - COBCH0160


COBCH0154 COPY REPLACING nested within COPY

A COPY REPLACING statement has been detected, nested under another COPY.
Parent topic: COBCH0141 - COBCH0160


COBCH0155 Numeric item should be an integer and without a 'P' in its picture clause

Where one of the identifiers in a STRING statement is an elementary numeric data item, it must be described as an integer without the 'P' symbol in its PICTURE clause.
Parent topic: COBCH0141 - COBCH0160


COBCH0156 Period found in wrong area of source line

Parent topic: COBCH0141 - COBCH0160


COBCH0161 - COBCH0180

Lists the Syntax Checking error messages from COBCH0161 through COBCH0180.

  • COBCH0161 Can only be used within a Paragraph
  • COBCH0162 Can only be used within a Section
  • COBCH0163 DISPLAY ... UPON SYSERR can only have one operand
  • COBCH0164 More than 250 USE statements
    Your program contains more than 250 USE statements. There is a system limit of 250 USE statements in a program.
  • COBCH0165 NEXT SENTENCE followed by non-executable imperative/conditional statements
  • COBCH0166 Source and target lengths do not match (integer1 <> integer2)
  • COBCH0167 WRITE ... ADVANCING and POSITIONING syntax used on same file
  • COBCH0168 DEPENDING ON item in RECORD VARYING clause not in WORKING-STORAGE/LINKAGE
  • COBCH0170 Invalid argument in directive
    An incorrect argument has been specified when setting a Compiler directive.
  • COBCH0172 Qualifying name name not unique. Discarded.
  • COBCH0173 Space invalid here.
  • COBCH0174 A RECORDING MODE of 'S' was assumed for the above file
  • COBCH0175 A VALUE clause was specified for a sliding item.
  • COBCH0176 'RENAMES' object object is an 01 level item
  • COBCH0177 'RENAMES' object object is not present in the preceeding record
  • COBCH0178 DEPENDING missing. Fixed length assumed.
  • COBCH0179 Number of subscripts in VALUE clause does not match table dimension
    FROM or TO in a VALUE clause does not contain the correct number of subscripts; there should be one subscript for each level of OCCURS for the data declaration.
  • COBCH0180 One or more subscripts in a VALUE clause is out of range
    A subscript value exceeds the maximum number of occurrences specified in the corresponding OCCURS clause.
Parent topic: Messages COBCH0101 to COBCH0200


COBCH0161 Can only be used within a Paragraph

Parent topic: COBCH0161 - COBCH0180


COBCH0162 Can only be used within a Section

Parent topic: COBCH0161 - COBCH0180


COBCH0163 DISPLAY ... UPON SYSERR can only have one operand

Parent topic: COBCH0161 - COBCH0180


COBCH0164 More than 250 USE statements

Your program contains more than 250 USE statements. There is a system limit of 250 USE statements in a program.
Parent topic: COBCH0161 - COBCH0180


COBCH0165 NEXT SENTENCE followed by non-executable imperative/conditional statements

Parent topic: COBCH0161 - COBCH0180


COBCH0166 Source and target lengths do not match (integer1 <> integer2)

Parent topic: COBCH0161 - COBCH0180


COBCH0167 WRITE ... ADVANCING and POSITIONING syntax used on same file

Parent topic: COBCH0161 - COBCH0180


COBCH0168 DEPENDING ON item in RECORD VARYING clause not in WORKING-STORAGE/LINKAGE

Parent topic: COBCH0161 - COBCH0180


COBCH0170 Invalid argument in directive

An incorrect argument has been specified when setting a Compiler directive.

Check the required syntax for the particular directive, as specified in Compiler Directives - Alphabetical List.

Example

When using the REMOVE directive to remove more than one reserved word, each word must be enclosed in separate parenthesis or quotation marks; otherwise the error will occur.
$set REMOVE(NATIVE NEXT)    *> this is incorrect

$set REMOVE(NATIVE) (NEXT)  *> this is correct

$set REMOVE"NATIVE" "NEXT"  *> this is correct
Parent topic: COBCH0161 - COBCH0180
Related reference
Compiler Directives - Alphabetical List


COBCH0172 Qualifying name name not unique. Discarded.

Parent topic: COBCH0161 - COBCH0180


COBCH0173 Space invalid here.

Parent topic: COBCH0161 - COBCH0180


COBCH0174 A RECORDING MODE of 'S' was assumed for the above file

Parent topic: COBCH0161 - COBCH0180


COBCH0175 A VALUE clause was specified for a sliding item.

Parent topic: COBCH0161 - COBCH0180


COBCH0176 'RENAMES' object object is an 01 level item

Parent topic: COBCH0161 - COBCH0180


COBCH0177 'RENAMES' object object is not present in the preceeding record

Parent topic: COBCH0161 - COBCH0180


COBCH0178 DEPENDING missing. Fixed length assumed.

Parent topic: COBCH0161 - COBCH0180


COBCH0179 Number of subscripts in VALUE clause does not match table dimension

FROM or TO in a VALUE clause does not contain the correct number of subscripts; there should be one subscript for each level of OCCURS for the data declaration.
Parent topic: COBCH0161 - COBCH0180


COBCH0180 One or more subscripts in a VALUE clause is out of range

A subscript value exceeds the maximum number of occurrences specified in the corresponding OCCURS clause.

Resolution:

Recode your program.

Parent topic: COBCH0161 - COBCH0180


COBCH0181 - COBCH0200

Lists the Syntax Checking error messages from COBCH0181 through COBCH0200.

  • COBCH0181 FROM subscript in VALUE clause must not be greater than TO subscript
    The table element specified by the TO subscript precedes that specified by the FROM subscript.
  • COBCH0182 Limit exceeded - too many literals in VALUE clause
    The VALUE clause is too complex for the compiler to process. Inform technical support.
  • COBCH0183 VALUE clause would result in initialisation of elements beyond end of table
    Not all of the specified values are contained within the table being declared.
  • COBCH0184 In-line comment
    Your program contains an in-line comment. In-line comments are permitted in the non-mainframe dialect, but your program was compiled using a different dialect.
  • COBCH0185 END-EXEC missing, or unexpected EXEC
    An EXEC was encountered before an END-EXEC closed the previous EXEC. The most common reason for this is that an END-EXEC intended to close the previous EXEC was missing or misspelled.
  • COBCH0186 EXEC too large or END-EXEC missing/misspelled
    An EXEC statement is larger than the maximum allowed. This is most likely because an END-EXEC has been omitted or misspelled.
  • COBCH0187 Program is nested in a program defined with the "RECURSIVE" attribute
    Mainframe compilers do not allow the RECURSIVE clause in a program that also has nested programs.
  • COBCH0188 Key file %1_s not found
  • COBCH0189 Directives file filename not found
  • COBCH0190 Zero is an invalid value for an index-name. 1 assumed.
  • COBCH0191 OCCURS DEPENDING ON phrase bisected by additional clause!
  • COBCH0192 CALL parameter is group at level other than 01.
    Your selected flagging dialect does not allow a CALL parameter to be a group at a level other than 01.
  • COBCH0193 Use of Z literals
    Your selected flagging dialect does not support Z literals.
  • COBCH0194 CALL procedure pointer
    Your selected flagging dialect does not support this.
  • COBCH0195 ASCENDING/DESCENDING KEY clause must appear before INDEXED BY clause
    Your selected flagging dialect does not support reversing the order of these clauses in the OCCURS phrase of a data item definition.
  • COBCH0196 Redefinition of item containing an 'OCCURS DEPENDING ON' clause
    Your selected flagging dialect does not support this.
  • COBCH0197 Qualification refers to invalid REDEFINES item - qualification ignored
    Related Topics
  • COBCH0199 LINE clause also specified in containing group
    The LINE clause cannot appear in an elementary item if the containing group already contains a LINE clause.
  • COBCH0200 Empty paragraph
    Your paragraph contains no statements.
Parent topic: Messages COBCH0101 to COBCH0200


COBCH0181 FROM subscript in VALUE clause must not be greater than TO subscript

The table element specified by the TO subscript precedes that specified by the FROM subscript.

Resolution:

Recode your program.

Parent topic: COBCH0181 - COBCH0200


COBCH0182 Limit exceeded - too many literals in VALUE clause

The VALUE clause is too complex for the compiler to process. Inform technical support.

Resolution:

Recode your program.

Parent topic: COBCH0181 - COBCH0200


COBCH0183 VALUE clause would result in initialisation of elements beyond end of table

Not all of the specified values are contained within the table being declared.

Resolution:

Recode your program.

Parent topic: COBCH0181 - COBCH0200


COBCH0184 In-line comment

Your program contains an in-line comment. In-line comments are permitted in the non-mainframe dialect, but your program was compiled using a different dialect.

Resolution:

Recode your program so that it does not use in-line comments, or recompile it using the non-mainframe dialect.

Parent topic: COBCH0181 - COBCH0200


COBCH0185 END-EXEC missing, or unexpected EXEC

An EXEC was encountered before an END-EXEC closed the previous EXEC. The most common reason for this is that an END-EXEC intended to close the previous EXEC was missing or misspelled.

Resolution:

Recode your program so that each EXEC has a closing END-EXEC before the next EXEC, then recompile.

Parent topic: COBCH0181 - COBCH0200


COBCH0186 EXEC too large or END-EXEC missing/misspelled

An EXEC statement is larger than the maximum allowed. This is most likely because an END-EXEC has been omitted or misspelled.

Resolution:

Recode your program so that each EXEC has a closing END-EXEC, then recompile.

Parent topic: COBCH0181 - COBCH0200


COBCH0187 Program is nested in a program defined with the "RECURSIVE" attribute

Mainframe compilers do not allow the RECURSIVE clause in a program that also has nested programs.

Resolution:

Recode your program so that it does not use this structure.

Parent topic: COBCH0181 - COBCH0200


COBCH0188 Key file %1_s not found

Parent topic: COBCH0181 - COBCH0200


COBCH0189 Directives file filename not found

Parent topic: COBCH0181 - COBCH0200


COBCH0190 Zero is an invalid value for an index-name. 1 assumed.

Parent topic: COBCH0181 - COBCH0200


COBCH0191 OCCURS DEPENDING ON phrase bisected by additional clause!

Parent topic: COBCH0181 - COBCH0200


COBCH0192 CALL parameter is group at level other than 01.

Your selected flagging dialect does not allow a CALL parameter to be a group at a level other than 01.

Resolution:

Recode your program so that the parameter is either an elementary item or a group at level 01.

Parent topic: COBCH0181 - COBCH0200


COBCH0193 Use of Z literals

Your selected flagging dialect does not support Z literals.

Resolution:

Recode your program.

Parent topic: COBCH0181 - COBCH0200


COBCH0194 CALL procedure pointer

Your selected flagging dialect does not support this.

Resolution:

Recode your program.

Parent topic: COBCH0181 - COBCH0200


COBCH0195 ASCENDING/DESCENDING KEY clause must appear before INDEXED BY clause

Your selected flagging dialect does not support reversing the order of these clauses in the OCCURS phrase of a data item definition.

Resolution:

Recode your program.

Parent topic: COBCH0181 - COBCH0200


COBCH0196 Redefinition of item containing an 'OCCURS DEPENDING ON' clause

Your selected flagging dialect does not support this.

Resolution:

Recode your program.

Parent topic: COBCH0181 - COBCH0200


COBCH0197 Qualification refers to invalid REDEFINES item - qualification ignored

Related Topics
Parent topic: COBCH0181 - COBCH0200


COBCH0199 LINE clause also specified in containing group

The LINE clause cannot appear in an elementary item if the containing group already contains a LINE clause.
Parent topic: COBCH0181 - COBCH0200


COBCH0200 Empty paragraph

Your paragraph contains no statements.
Parent topic: COBCH0181 - COBCH0200


Messages COBCH0201 to COBCH0300

  • COBCH0201 - COBCH0220
    Lists the Syntax Checking error messages from COBCH0201 through COBCH0220.
  • COBCH0221 - COBCH0240
    Lists the Syntax Checking error messages from COBCH0221 through COBCH0240.
  • COBCH0241 - COBCH0260
    Lists the Syntax Checking error messages from COBCH0241 through COBCH0260.
  • COBCH0261 - COBCH0280
    Lists the Syntax Checking error messages from COBCH0261 through COBCH0280.
  • COBCH0281 - COBCH0300
    Lists the Syntax Checking error messages from COBCH0281 through COBCH0300.
Parent topic: Syntax Checking Error Messages


COBCH0201 - COBCH0220

Lists the Syntax Checking error messages from COBCH0201 through COBCH0220.

  • COBCH0201 Sort file cannot have ACCESS or ORGANIZATION clauses
    An SD file control entry cannot have ACCESS or ORGANIZATION clauses, because the access mode and organization of such files are fixed.
  • COBCH0202 Too many levels of OCCURS
    You have specified more than the permitted number of OCCURS clauses in the definition of a table item.
  • COBCH0203 CODE must be specified for all reports or no report
    You have specified the CODE clause in the definition of a report. If you are defining more than one report for the specified file, you must specify the CODE clause either for all reports or for none of them for that file.
  • COBCH0204 REDEFINES on incorrect field
    A REDEFINES clause must have the same level number as the item it redefines.
  • COBCH0205 RECORD missing or has zero size
    You have declared a file using the SELECT statement in the Environment Division of your program, but have either failed to define it in a corresponding FD entry in the Data Division or have used a different filename in the FD entry, perhaps owing to a spelling mistake. If a mismatch of the two occurs then the record associated with the file does not exist although the necessary space has been created for it.
  • COBCH0206 01 or 77 level required
    The specified data item must have level number 01 or 77.
  • COBCH0207 FD, CD or SD qualification syntax error
    These source code entries describe the structure of a specified file and take the form FD or CD or SD followed by a filename and a description of the records in that file. The filename must be the name of a file defined in the FILE-CONTROL paragraph of your program.
  • COBCH0208 WORKING-STORAGE missing
    The words WORKING-STORAGE are missing from the relevant Section heading in the Data Division or, if present, have not been recognized by your COBOL system. This might be due to a spelling mistake or to their position in your code.
  • COBCH0209 PROCEDURE DIVISION missing or unknown statement
    The PROCEDURE DIVISION header is missing from your program or, if present, your COBOL system has failed to recognize it. This might be due to a spelling mistake or you could have placed the header at the wrong place in your code.
  • COBCH0210 Unrecognized data description qualifier or "." missing
    A qualifier (for example, JUST or COMP) is misspelled in the description of a data item.
  • COBCH0211 PICTURE clause not compatible with qualifiers
    Your code contains a PICTURE clause that is qualified by the wrong type of qualifier. For example, a data item cannot be defined as PIC XX USAGE COMP because it is an alphanumeric PICTURE clause but the qualifier is numeric.
  • COBCH0212 Illegal data item used with BLANK clause
    The BLANK WHEN ZERO clause can be used only as part of the data description entry for data items which are numeric (those which contain a 9 in the PICTURE clause) or numeric edited (ordinary edited data items with special characters added to allow the data items to be presented in a form which can be easily understood). You have used this clause with a nonnumeric data item in your source code or with a numeric data item that contains a "P", "S", or "V".
  • COBCH0213 Item is longer than USAGE allows or contains more than 18 numeric positions
    A PICTURE string defined in a PICTURE clause in your Data Division exceeds the maximum permitted by your COBOL system.
  • COBCH0214 VALUE too long for data item or has too many decimal positions
    The value you have specified in a VALUE clause is too big or has too many decimal places, to fit in the data item. For example, a declaration such as PIC 99 VALUE 123, where 123 is too large to fit into the receiving field without truncation.
  • COBCH0215 VALUE in error or illegal for PICTURE type
    You might have made a mistake in the coding of a VALUE clause in your program. For example, you have used a numeric data item with a nonnumeric VALUE clause. Alternatively, you have used a VALUE clause in an illegal place, for example in conjunction with a data item which has been redefined.
  • COBCH0216 Non-elementary item has JUSTIFIED or BLANK clause
    These clauses can be used in the data description entry of the Data Division but must be used only with elementary data items. Elementary data items are the most basic subdivisions of a record as they are not subdivided into higher level data items. You have used one of these clauses in conjunction with a non-elementary data item (that is, one which contains higher level data items).
  • COBCH0217 Preceding item at this level has zero length
    You have defined a data item but have failed to give it a size, either by not using a PICTURE clause in conjunction with it, or, if it is a group item, by failing to define any elementary items to go with it. If you enter something similar to the following:
  • COBCH0218 Illegal arithmetic operator
    You have specified an invalid operator in an arithmetic expression.
  • COBCH0219 Illegal level number
    You have specified an illegal level number in a data description entry.
  • COBCH0220 Literal type does not match data type
    You have specified a literal value that is incompatible with the PICTURE clause of the associated data item.
Parent topic: Messages COBCH0201 to COBCH0300


COBCH0201 Sort file cannot have ACCESS or ORGANIZATION clauses

An SD file control entry cannot have ACCESS or ORGANIZATION clauses, because the access mode and organization of such files are fixed.

Resolution:

Delete the clauses in error.

Parent topic: COBCH0201 - COBCH0220


COBCH0202 Too many levels of OCCURS

You have specified more than the permitted number of OCCURS clauses in the definition of a table item.

Resolution:

Delete the excess OCCURS clauses.

Parent topic: COBCH0201 - COBCH0220


COBCH0203 CODE must be specified for all reports or no report

You have specified the CODE clause in the definition of a report. If you are defining more than one report for the specified file, you must specify the CODE clause either for all reports or for none of them for that file.

Resolution:

Add CODE clauses to the other reports you have defined, or ensure that no report definition contains a CODE clause for that file.

Parent topic: COBCH0201 - COBCH0220


COBCH0204 REDEFINES on incorrect field

A REDEFINES clause must have the same level number as the item it redefines.

Resolution:

Change the level number in error.

Parent topic: COBCH0201 - COBCH0220


COBCH0205 RECORD missing or has zero size

You have declared a file using the SELECT statement in the Environment Division of your program, but have either failed to define it in a corresponding FD entry in the Data Division or have used a different filename in the FD entry, perhaps owing to a spelling mistake. If a mismatch of the two occurs then the record associated with the file does not exist although the necessary space has been created for it.

Resolution:

Add or revise the FD entry.

Parent topic: COBCH0201 - COBCH0220


COBCH0206 01 or 77 level required

The specified data item must have level number 01 or 77.

Resolution:

Change the level number of the item to 01 or 77.

Parent topic: COBCH0201 - COBCH0220


COBCH0207 FD, CD or SD qualification syntax error

These source code entries describe the structure of a specified file and take the form FD or CD or SD followed by a filename and a description of the records in that file. The filename must be the name of a file defined in the FILE-CONTROL paragraph of your program.

Resolution:

Correct the format of this syntax.

Parent topic: COBCH0201 - COBCH0220


COBCH0208 WORKING-STORAGE missing

The words WORKING-STORAGE are missing from the relevant Section heading in the Data Division or, if present, have not been recognized by your COBOL system. This might be due to a spelling mistake or to their position in your code.

Resolution:

Correct the errors.

Parent topic: COBCH0201 - COBCH0220


COBCH0209 PROCEDURE DIVISION missing or unknown statement

The PROCEDURE DIVISION header is missing from your program or, if present, your COBOL system has failed to recognize it. This might be due to a spelling mistake or you could have placed the header at the wrong place in your code.

Alternatively, your code might contain a statement in the Procedure Division that your COBOL system has failed to recognize. This is probably because you have used a reserved word but have spelled it incorrectly.

Resolution:

Insert the header immediately after the last entry in the Data Division.

Correct your spelling error.

Parent topic: COBCH0201 - COBCH0220


COBCH0210 Unrecognized data description qualifier or "." missing

A qualifier (for example, JUST or COMP) is misspelled in the description of a data item.

Alternatively you have not placed the necessary period at the end of a PICTURE clause.

Resolution:

A list of possible qualifiers can be found in the chapter Concepts of the COBOL Language in your Language Reference. Check the spelling of the qualifier in your code.

Add the period.

Parent topic: COBCH0201 - COBCH0220


COBCH0211 PICTURE clause not compatible with qualifiers

Your code contains a PICTURE clause that is qualified by the wrong type of qualifier. For example, a data item cannot be defined as PIC XX USAGE COMP because it is an alphanumeric PICTURE clause but the qualifier is numeric.

Resolution:

Revise your code so that the PICTURE clause and its qualifiers are of the same type.

Parent topic: COBCH0201 - COBCH0220


COBCH0212 Illegal data item used with BLANK clause

The BLANK WHEN ZERO clause can be used only as part of the data description entry for data items which are numeric (those which contain a 9 in the PICTURE clause) or numeric edited (ordinary edited data items with special characters added to allow the data items to be presented in a form which can be easily understood). You have used this clause with a nonnumeric data item in your source code or with a numeric data item that contains a "P", "S", or "V".

Resolution:

Delete this clause or redefine the data item to be either numeric or numeric edited, or remove the "P", "S", or "V" characters.

Parent topic: COBCH0201 - COBCH0220


COBCH0213 Item is longer than USAGE allows or contains more than 18 numeric positions

A PICTURE string defined in a PICTURE clause in your Data Division exceeds the maximum permitted by your COBOL system.

Resolution:

Numeric data items can be up to 18 characters in length, numeric edited up to 512 characters and alphanumeric up to 256 Mb.

Parent topic: COBCH0201 - COBCH0220


COBCH0214 VALUE too long for data item or has too many decimal positions

The value you have specified in a VALUE clause is too big or has too many decimal places, to fit in the data item. For example, a declaration such as PIC 99 VALUE 123, where 123 is too large to fit into the receiving field without truncation.

Resolution:

Alter your code so that the data item is large enough to receive the value that is to be placed in it.

Parent topic: COBCH0201 - COBCH0220


COBCH0215 VALUE in error or illegal for PICTURE type

You might have made a mistake in the coding of a VALUE clause in your program. For example, you have used a numeric data item with a nonnumeric VALUE clause. Alternatively, you have used a VALUE clause in an illegal place, for example in conjunction with a data item which has been redefined.

Resolution:

Click Related Topics for topics giving information on the rules governing the use of the VALUE clause.

Parent topic: COBCH0201 - COBCH0220


COBCH0216 Non-elementary item has JUSTIFIED or BLANK clause

These clauses can be used in the data description entry of the Data Division but must be used only with elementary data items. Elementary data items are the most basic subdivisions of a record as they are not subdivided into higher level data items. You have used one of these clauses in conjunction with a non-elementary data item (that is, one which contains higher level data items).

Resolution:

Revise your program to ensure that these clauses appear only with elementary data items.

Parent topic: COBCH0201 - COBCH0220


COBCH0217 Preceding item at this level has zero length

You have defined a data item but have failed to give it a size, either by not using a PICTURE clause in conjunction with it, or, if it is a group item, by failing to define any elementary items to go with it. If you enter something similar to the following:
 01 my-data-item. 01 prog-data-item pic x.

you receive this message after prog-data-item because, although it is my-data-item that is in error, the error is detected only when the next item at the same level as the data item in error is encountered.

Resolution

Add the necessary PICTURE clause or elementary items to the level hierarchy.

Parent topic: COBCH0201 - COBCH0220


COBCH0218 Illegal arithmetic operator

You have specified an invalid operator in an arithmetic expression.

Resolution:

Correct the expression.

Parent topic: COBCH0201 - COBCH0220


COBCH0219 Illegal level number

You have specified an illegal level number in a data description entry.

Resolution:

Correct the level number.

Parent topic: COBCH0201 - COBCH0220


COBCH0220 Literal type does not match data type

You have specified a literal value that is incompatible with the PICTURE clause of the associated data item.

Resolution:

Make the literal value compatible with the data item.

Parent topic: COBCH0201 - COBCH0220


COBCH0221 - COBCH0240

Lists the Syntax Checking error messages from COBCH0221 through COBCH0240.

  • COBCH0221 Data description qualifier inappropriate or repeated
    You have used a data description qualifier which is incompatible with the associated PICTURE clause. For example, you might have used a BLANK WHEN ZERO clause for a PIC XX data item. This is illegal as the data item is alphanumeric but the associated qualifier refers only to numeric items.
  • COBCH0222 REDEFINES data-name not declared
    You have not declared the data-name which you have used in conjunction with a REDEFINES clause.
  • COBCH0223 Unknown USAGE
    You have specified an invalid USAGE qualifier in a data description entry.
  • COBCH0224 SIGN must be LEADING or TRAILING
    This optional clause can be specified only for numeric description entries which contain the character S in their PICTURE clause. The key word SIGN must be followed by either LEADING or TRAILING depending on the position you want the operational sign to take.
  • COBCH0225 Level hierarchy wrong
    The structure of level numbers in a group data item is incorrect.
  • COBCH0226 Variable length group not unitary
    You cannot declare a variable-length group item in an OCCURS clause.
  • COBCH0227 ZERO missing
    The BLANK clause must be followed by the word ZERO, ZEROS or ZEROES.
  • COBCH0228 Group VALUE truncated
    The value you have specified for a group item exceeds its defined length.
  • COBCH0229 Incompatible qualifiers
    The qualifiers you have specified in the description of a data item are not compatible.
  • COBCH0230 PICTURE string has illegal precedence or illegal character
    You have used a character in a PICTURE clause that your COBOL system does not recognize, or which is illegal for that particular type of PICTURE string.
  • COBCH0231 INDEXED data-name missing or already declared
  • COBCH0232 Edited PICTURE string is too large
    A PICTURE string which you have defined for an edited or numeric edited (one which presents numeric data items in a more readable form, for example, with leading zeros removed or with currency signs inserted) data item exceeds the maximum permitted for your COBOL system.
  • COBCH0233 Unknown data description qualifier data-name
    You have either used a reserved word as a data-name, or used an invalid qualifier in a data description: this is probably a misspelling of a valid qualifier.
  • COBCH0234 DEPENDING missing
    You have defined a variable length table without specifying the DEPENDING phrase that, at run time, enables your COBOL system to determine the actual table size.
  • COBCH0235 Record size size1 < minimum size given in FD statement size2
    Related Topics
  • COBCH0236 Record > maximum size given in FD statement
    Related Topics
  • COBCH0237 Cannot have more than one initial CD
    Only one of the CD entries in the Communications Section can have the INITIAL clause specified.
  • COBCH0238 RENAMES missing
    You have omitted the word RENAMES in the definition of a level 66 data item.
  • COBCH0239 First data-name does not precede second
    You have included the syntax data-name-1 RENAMES data-name-2 THRU data-name-3 in your program, but the data item you have specified for data-name-2 is declared after the data item for data-name-3. This is not valid COBOL syntax, as data-name-2 in a THRU clause must be declared before data-name-3.
  • COBCH0240 Only allowed at 01 level
    You have used either the NEXT or TYPE clauses in a report description entry, or the GLOBAL or EXTERNAL clauses in a report file description entry, which is not an 01 level item.
Parent topic: Messages COBCH0201 to COBCH0300


COBCH0221 Data description qualifier inappropriate or repeated

You have used a data description qualifier which is incompatible with the associated PICTURE clause. For example, you might have used a BLANK WHEN ZERO clause for a PIC XX data item. This is illegal as the data item is alphanumeric but the associated qualifier refers only to numeric items.

Alternatively, you have used more than one PICTURE clause to define a single data item when each data item should have only one PICTURE clause associated with it.

Resolution:

Revise the qualifier or the data-type to ensure that they are compatible.

Delete any extra PICTURE clause to leave only one for that data item.

Parent topic: COBCH0221 - COBCH0240


COBCH0222 REDEFINES data-name not declared

You have not declared the data-name which you have used in conjunction with a REDEFINES clause.

Resolution:

Ensure that the data-name is declared in your Data Description entry and that the relevant REDEFINES clause is placed immediately after the data-name which it describes.

Parent topic: COBCH0221 - COBCH0240


COBCH0223 Unknown USAGE

You have specified an invalid USAGE qualifier in a data description entry.

Resolution:

Correct the USAGE qualifier.

Parent topic: COBCH0221 - COBCH0240


COBCH0224 SIGN must be LEADING or TRAILING

This optional clause can be specified only for numeric description entries which contain the character S in their PICTURE clause. The key word SIGN must be followed by either LEADING or TRAILING depending on the position you want the operational sign to take.

Resolution:

Add one of these words.

Parent topic: COBCH0221 - COBCH0240


COBCH0225 Level hierarchy wrong

The structure of level numbers in a group data item is incorrect.

Resolution:

Check the hierarchy of the level numbers and correct it.

Parent topic: COBCH0221 - COBCH0240


COBCH0226 Variable length group not unitary

You cannot declare a variable-length group item in an OCCURS clause.

Resolution:

Make the group item fixed length.

Parent topic: COBCH0221 - COBCH0240


COBCH0227 ZERO missing

The BLANK clause must be followed by the word ZERO, ZEROS or ZEROES.

Resolution:

Delete any other word that you might have used in place of ZERO and ensure that the clause contains no spelling errors.

Parent topic: COBCH0221 - COBCH0240


COBCH0228 Group VALUE truncated

The value you have specified for a group item exceeds its defined length.

Resolution:

Redefine the length of the group item or the value.

Parent topic: COBCH0221 - COBCH0240


COBCH0229 Incompatible qualifiers

The qualifiers you have specified in the description of a data item are not compatible.

Resolution:

Refer to the chapter Concepts of the COBOL Language in your Language Reference for the rules governing qualifiers in data descriptions. Revise the data description.

Parent topic: COBCH0221 - COBCH0240


COBCH0230 PICTURE string has illegal precedence or illegal character

You have used a character in a PICTURE clause that your COBOL system does not recognize, or which is illegal for that particular type of PICTURE string.

Resolution:

A full list of permitted characters can be found in the chapter Program Definition in your Language Reference. Alter the relevant PICTURE clause.

Parent topic: COBCH0221 - COBCH0240


COBCH0231 INDEXED data-name missing or already declared

Parent topic: COBCH0221 - COBCH0240


COBCH0232 Edited PICTURE string is too large

A PICTURE string which you have defined for an edited or numeric edited (one which presents numeric data items in a more readable form, for example, with leading zeros removed or with currency signs inserted) data item exceeds the maximum permitted for your COBOL system.

A string comprises 32 slots, each containing 16 characters. If no two consecutive characters in the string are the same, a new slot is allocated to each character. For example:

X(32)B(480)

works, but:

XBXBXBXBXBXBXBXBXBXBXBXBXBXBXBXBX

fails.

Resolution:

Alter the format of the string so that it contains no more than 32 groups of characters, each group holding up to 16 identical, contiguous edit characters.

Parent topic: COBCH0221 - COBCH0240


COBCH0233 Unknown data description qualifier data-name

You have either used a reserved word as a data-name, or used an invalid qualifier in a data description: this is probably a misspelling of a valid qualifier.

Resolution:

Correct the data description.

Parent topic: COBCH0221 - COBCH0240


COBCH0234 DEPENDING missing

You have defined a variable length table without specifying the DEPENDING phrase that, at run time, enables your COBOL system to determine the actual table size.

Resolution:

Specify the DEPENDING phrase.

Parent topic: COBCH0221 - COBCH0240


COBCH0235 Record size size1 < minimum size given in FD statement size2

Related Topics
Parent topic: COBCH0221 - COBCH0240


COBCH0236 Record > maximum size given in FD statement

Related Topics
Parent topic: COBCH0221 - COBCH0240


COBCH0237 Cannot have more than one initial CD

Only one of the CD entries in the Communications Section can have the INITIAL clause specified.

Resolution:

Delete the INITIAL clauses from all but one of the CD entries.

Parent topic: COBCH0221 - COBCH0240


COBCH0238 RENAMES missing

You have omitted the word RENAMES in the definition of a level 66 data item.

Resolution:

Add the word RENAMES.

Parent topic: COBCH0221 - COBCH0240


COBCH0239 First data-name does not precede second

You have included the syntax data-name-1 RENAMES data-name-2 THRU data-name-3 in your program, but the data item you have specified for data-name-2 is declared after the data item for data-name-3. This is not valid COBOL syntax, as data-name-2 in a THRU clause must be declared before data-name-3.

Resolution:

Check that you have specified the THRU phrase correctly.

Parent topic: COBCH0221 - COBCH0240


COBCH0240 Only allowed at 01 level

You have used either the NEXT or TYPE clauses in a report description entry, or the GLOBAL or EXTERNAL clauses in a report file description entry, which is not an 01 level item.

Resolution:

Edit your source code to ensure that where you have used NEXT, TYPE, GLOBAL or EXTERNAL the clause applies to an 01 level item.

Parent topic: COBCH0221 - COBCH0240


COBCH0241 - COBCH0260

Lists the Syntax Checking error messages from COBCH0241 through COBCH0260.

  • COBCH0241 Only allowed in Working-Storage Section
    The syntax indicated is allowed only in the Working-Storage Section.
  • COBCH0242 Only allowed in WORKING-STORAGE and FILE sections
    The syntax indicated is allowed only in the Working-Storage Section or the File Section.
  • COBCH0243 VALUE of group item must be nonnumeric or figurative constant
    If you specify a VALUE clause for a group item, the value in the clause must be either a nonnumeric literal or a figurative constant.
  • COBCH0244 FD missing for file filename
    You have not made an FD entry for all the files named in the FILE-CONTROL paragraph.
  • COBCH0245 DEPENDING ON item data-name missing or illegal
    You have not declared a data item named in the DEPENDING phrase of an OCCURS clause.
  • COBCH0246 KEY key-name missing or illegal
    You have not specified the RECORD KEY clause in the file description of an indexed sequential file.
  • COBCH0247 Index-name has been declared explicitly
    You have declared an index data item explicitly. The item is declared implicitly by its appearance in an INDEX phrase, so you have in effect declared the same item twice.
  • COBCH0248 ISAM key key-name too long
    A data item that is to be used as an indexed sequential file key is longer than the maximum length allowed for such keys.
  • COBCH0249 Alternate keys have same reference
    The two alternate keys you have defined for an indexed sequential file overlap. Alternate keys must be completely distinct from one another.
  • COBCH0250 STATUS field data-name missing or illegal
    You have either not declared the data item specified in the FILE STATUS clause of a file control entry, or you have declared it incorrectly.
  • COBCH0251 CURSOR field data-name missing or illegal
    You have either not declared the data item specified in the CURSOR IS clause in the SPECIAL-NAMES paragraph, or you have declared the item incorrectly.
  • COBCH0252 PASSWORD field data-name missing or illegal
    You have either not declared the data item specified in the PASSWORD clause in a file description entry, or you have declared the item incorrectly.
  • COBCH0253 LABEL RECORD or DATA RECORD record-name missing or illegal
    You have either not declared the record item specified in the LABEL RECORD or DATA RECORD clauses in a file description entry, or you have declared the item incorrectly.
  • COBCH0254 'VALUE OF' field data-name missing or illegal
    You have either not declared one or more of the data items named in the VALUE OF clause of an FD entry in the File Section, or you have declared such an item incorrectly.
  • COBCH0255 User name data-name same as special register
    You have declared a data item with the same name as one of the special registers, which are data items that are automatically declared by your COBOL system.
  • COBCH0256 Preceding record has zero length
    You have defined a file record with zero length. This is probably due to errors in all of the elementary item descriptions in the record definition.
  • COBCH0257 KEY data-name missing or already declared
    You have either not declared a data item specified in the KEY phrase of an OCCURS clause, or you have declared it twice.
  • COBCH0258 ASSIGN data-name data-name illegal
    You have specified an ASSIGN data-name in a SELECT ... ASSIGN clause that is not unitary, that is, the data definition contains an OCCURS clause.
  • COBCH0259 Illegal report-name or bad RD clause
    You have defined a report-name that is either not unique or which does not conform to the rules for user-defined words. Alternatively, you have specified a clause in an RD entry incorrectly.
  • COBCH0260 Inconsistent page specification
    The values you have specified in the PAGE LIMIT clause are not consistent; for example, the integer in the LAST DETAIL phrase is smaller than the integer in the FIRST DETAIL phrase.
Parent topic: Messages COBCH0201 to COBCH0300


COBCH0241 Only allowed in Working-Storage Section

The syntax indicated is allowed only in the Working-Storage Section.

Resolution:

Edit your source code to ensure that the syntax appears only in the Working-Storage Section.

Parent topic: COBCH0241 - COBCH0260


COBCH0242 Only allowed in WORKING-STORAGE and FILE sections

The syntax indicated is allowed only in the Working-Storage Section or the File Section.

Resolution:

Edit your source code to ensure that the syntax appears only in the Working-Storage or File Sections.

Parent topic: COBCH0241 - COBCH0260


COBCH0243 VALUE of group item must be nonnumeric or figurative constant

If you specify a VALUE clause for a group item, the value in the clause must be either a nonnumeric literal or a figurative constant.

Resolution:

Revise the value in the VALUE clause.

Parent topic: COBCH0241 - COBCH0260


COBCH0244 FD missing for file filename

You have not made an FD entry for all the files named in the FILE-CONTROL paragraph.

Resolution:

Ensure that you have an FD entry for each file named in a SELECT clause in the FILE-CONTROL paragraph.

Parent topic: COBCH0241 - COBCH0260


COBCH0245 DEPENDING ON item data-name missing or illegal

You have not declared a data item named in the DEPENDING phrase of an OCCURS clause.

Resolution:

Add a declaration of the missing data item.

Parent topic: COBCH0241 - COBCH0260


COBCH0246 KEY key-name missing or illegal

You have not specified the RECORD KEY clause in the file description of an indexed sequential file.

Resolution:

Add the RECORD KEY clause to the file description.

Parent topic: COBCH0241 - COBCH0260


COBCH0247 Index-name has been declared explicitly

You have declared an index data item explicitly. The item is declared implicitly by its appearance in an INDEX phrase, so you have in effect declared the same item twice.

Resolution:

Delete the explicit declaration of the index data item.

Parent topic: COBCH0241 - COBCH0260


COBCH0248 ISAM key key-name too long

A data item that is to be used as an indexed sequential file key is longer than the maximum length allowed for such keys.

Resolution:

Redefine the key accordingly.

Parent topic: COBCH0241 - COBCH0260


COBCH0249 Alternate keys have same reference

The two alternate keys you have defined for an indexed sequential file overlap. Alternate keys must be completely distinct from one another.

Resolution:

Redefine the alternate keys so that they do not overlap, or define them as split keys (which are allowed to overlap).

Parent topic: COBCH0241 - COBCH0260


COBCH0250 STATUS field data-name missing or illegal

You have either not declared the data item specified in the FILE STATUS clause of a file control entry, or you have declared it incorrectly.

Resolution:

Add or revise the definition of the FILE STATUS data item.

Parent topic: COBCH0241 - COBCH0260


COBCH0251 CURSOR field data-name missing or illegal

You have either not declared the data item specified in the CURSOR IS clause in the SPECIAL-NAMES paragraph, or you have declared the item incorrectly.

Resolution:

Refer to the chapter Program Definition in your Language Reference for the correct form of the cursor data item. Add or revise the declaration of the data item in the CURSOR IS clause.

Parent topic: COBCH0241 - COBCH0260


COBCH0252 PASSWORD field data-name missing or illegal

You have either not declared the data item specified in the PASSWORD clause in a file description entry, or you have declared the item incorrectly.

Resolution:

Add or correct the declaration of the data item in the PASSWORD clause.

Parent topic: COBCH0241 - COBCH0260


COBCH0253 LABEL RECORD or DATA RECORD record-name missing or illegal

You have either not declared the record item specified in the LABEL RECORD or DATA RECORD clauses in a file description entry, or you have declared the item incorrectly.

Resolution:

Add or correct the declaration of the record item in the LABEL RECORD or DATA RECORD clause.

Parent topic: COBCH0241 - COBCH0260


COBCH0254 'VALUE OF' field data-name missing or illegal

You have either not declared one or more of the data items named in the VALUE OF clause of an FD entry in the File Section, or you have declared such an item incorrectly.

Resolution:

Add or correct the declaration of the data item(s) in the VALUE OF clause.

Parent topic: COBCH0241 - COBCH0260


COBCH0255 User name data-name same as special register

You have declared a data item with the same name as one of the special registers, which are data items that are automatically declared by your COBOL system.

Resolution:

Alter the name of the data item in error.

Parent topic: COBCH0241 - COBCH0260


COBCH0256 Preceding record has zero length

You have defined a file record with zero length. This is probably due to errors in all of the elementary item descriptions in the record definition.

Resolution:

Correct the record description.

Parent topic: COBCH0241 - COBCH0260


COBCH0257 KEY data-name missing or already declared

You have either not declared a data item specified in the KEY phrase of an OCCURS clause, or you have declared it twice.

Resolution:

Declare the data item or remove the extra declaration.

Parent topic: COBCH0241 - COBCH0260


COBCH0258 ASSIGN data-name data-name illegal

You have specified an ASSIGN data-name in a SELECT ... ASSIGN clause that is not unitary, that is, the data definition contains an OCCURS clause.

Resolution:

Edit your source code to ensure that the ASSIGN data item does not include an OCCURS clause.

Parent topic: COBCH0241 - COBCH0260


COBCH0259 Illegal report-name or bad RD clause

You have defined a report-name that is either not unique or which does not conform to the rules for user-defined words. Alternatively, you have specified a clause in an RD entry incorrectly.

Resolution:

Correct your program accordingly.

Parent topic: COBCH0241 - COBCH0260


COBCH0260 Inconsistent page specification

The values you have specified in the PAGE LIMIT clause are not consistent; for example, the integer in the LAST DETAIL phrase is smaller than the integer in the FIRST DETAIL phrase.

Resolution:

Refer to the chapter Report Writer in your Language Reference - Additional Topics for the rules governing the PAGE LIMIT clause. Correct your program accordingly.

Parent topic: COBCH0241 - COBCH0260


COBCH0261 - COBCH0280

Lists the Syntax Checking error messages from COBCH0261 through COBCH0280.

  • COBCH0261 Only allowed in Report Section
    You have tried to specify syntax for a report outside the Report Section of the Data Division.
  • COBCH0262 Not a CONTROL for this report
    The data-name in a TYPE CH or TYPE CF clause must appear in the CONTROL clause of the associated RD entry. You might have misspelled the data-name.
  • COBCH0263 Not allowed when PAGE not specified in RD
    You have either specified a TYPE PH or TYPE PF clause without specifying a PAGE clause in the associated RD entry, or you have specified an absolute line number in the LINE NUMBER clause without specifying a PAGE clause in the associated RD entry.
  • COBCH0264 Only one report group with this TYPE allowed per RD
    You have specified a duplicate of one of the TYPE clauses (for example, you have specified two TYPE PF clauses); only one clause of each type is allowed in a particular RD entry.
  • COBCH0265 Not allowed with this TYPE
    You are using a qualifier in a statement that either does not allow any qualifiers, or that does not allow this particular qualifier.
  • COBCH0266 No TYPE specified
    All level 01 entries in the Report Section must have a TYPE clause.
  • COBCH0267 LINE specification missing or inconsistent
    This message has three possible causes:
  • COBCH0268 REPORT specified in more than one FD
    You have specified the same report-name in more than one FD.
  • COBCH0269 Duplicate CONTROL field
    You have specified the same CONTROL field value in more than one RD entry.
  • COBCH0270 COLUMN specification overlapping or not left to right
    Related Topics
  • COBCH0271 Only allowed with DETAIL groups
    You can specify a GROUP INDICATE clause only with DETAIL report groups.
  • COBCH0272 Only allowed with CONTROL FOOTING groups
    You can specify a SUM clause only in a control footing report group.
  • COBCH0273 Non-elementary item has invalid qualifier, or PICTURE missing
    You have specified in a group item a qualifier that can be used only in an elementary item. Possibly you intended the item to be elementary but omitted the PICTURE clause.
  • COBCH0274 GROUP INDICATE without COLUMN
    You have specified the GROUP INDICATE clause but no COLUMN clause in the same report group description.
  • COBCH0275 NEXT GROUP not allowed with this group TYPE
    You have specified NEXT GROUP in a group with TYPE RF or PH.
  • COBCH0276 NEXT GROUP NEXT PAGE not allowed with this group TYPE
    You have specified NEXT GROUP or NEXT PAGE in a group with TYPE PF.
  • COBCH0277 LINE NEXT PAGE not allowed with this group TYPE
    You can specify the LINE NEXT PAGE clause only with a group of TYPE CH, CF, or DE.
  • COBCH0278 RESET item is lower CONTROL level than group
    The control group on which a sum is reset must be at either the same level as or a lower level than the sum.
  • COBCH0279 Report line too long
    The syntax you have specified is trying to create a report line which is longer than the maximum allowed.
  • COBCH0280 THRU phrase not allowed with DBCS field
    DBCS is Double Byte Character Set.
Parent topic: Messages COBCH0201 to COBCH0300


COBCH0261 Only allowed in Report Section

You have tried to specify syntax for a report outside the Report Section of the Data Division.

Resolution:

Refer to the chapter Report Writer in your Language Reference - Additional Topics to see what syntax is allowed in the Report Section. Delete the syntax in error or relocate it in the Report Section.

Parent topic: COBCH0261 - COBCH0280


COBCH0262 Not a CONTROL for this report

The data-name in a TYPE CH or TYPE CF clause must appear in the CONTROL clause of the associated RD entry. You might have misspelled the data-name.

Resolution:

Ensure that the correct data-name appears in both the TYPE CF/CH and CONTROL clauses.

Parent topic: COBCH0261 - COBCH0280


COBCH0263 Not allowed when PAGE not specified in RD

You have either specified a TYPE PH or TYPE PF clause without specifying a PAGE clause in the associated RD entry, or you have specified an absolute line number in the LINE NUMBER clause without specifying a PAGE clause in the associated RD entry.

Resolution:

Add a PAGE clause to the RD entry.

Parent topic: COBCH0261 - COBCH0280


COBCH0264 Only one report group with this TYPE allowed per RD

You have specified a duplicate of one of the TYPE clauses (for example, you have specified two TYPE PF clauses); only one clause of each type is allowed in a particular RD entry.

Resolution:

Delete the duplicate TYPE clause.

Parent topic: COBCH0261 - COBCH0280


COBCH0265 Not allowed with this TYPE

You are using a qualifier in a statement that either does not allow any qualifiers, or that does not allow this particular qualifier.

Resolution:

Refer to the chapter Concepts of the COBOL Language in your Language Reference for details of the qualifiers allowed with this statement. Revise your program.

Parent topic: COBCH0261 - COBCH0280


COBCH0266 No TYPE specified

All level 01 entries in the Report Section must have a TYPE clause.

Resolution:

Add a TYPE clause.

Parent topic: COBCH0261 - COBCH0280


COBCH0267 LINE specification missing or inconsistent

This message has three possible causes:

You have specified a NEXT PAGE clause in a LINE clause other than the first of a report group description entry.

The absolute line numbers in the LINE clauses of a report group description entry are not in ascending order.

You have not specified a LINE clause in a particular report group description entry.

Resolution:

Depending on the cause of this message, you should:

Delete the NEXT PAGE clause from any but the first LINE clause.

Rearrange the LINE clauses so that absolute line numbers are in ascending order.

Add a LINE clause.

Parent topic: COBCH0261 - COBCH0280


COBCH0268 REPORT specified in more than one FD

You have specified the same report-name in more than one FD.

Resolution:

Delete the duplicate report-name.

Parent topic: COBCH0261 - COBCH0280


COBCH0269 Duplicate CONTROL field

You have specified the same CONTROL field value in more than one RD entry.

Resolution:

Delete the duplicate CONTROL field value.

Parent topic: COBCH0261 - COBCH0280


COBCH0270 COLUMN specification overlapping or not left to right

Related Topics
Parent topic: COBCH0261 - COBCH0280


COBCH0271 Only allowed with DETAIL groups

You can specify a GROUP INDICATE clause only with DETAIL report groups.

Resolution:

Delete the GROUP INDICATE clause.

Parent topic: COBCH0261 - COBCH0280


COBCH0272 Only allowed with CONTROL FOOTING groups

You can specify a SUM clause only in a control footing report group.

Resolution:

Delete the SUM clause.

Parent topic: COBCH0261 - COBCH0280


COBCH0273 Non-elementary item has invalid qualifier, or PICTURE missing

You have specified in a group item a qualifier that can be used only in an elementary item. Possibly you intended the item to be elementary but omitted the PICTURE clause.

Resolution:

Refer to the chapter Program Definition in your Language Reference for details of the correct syntax. Delete the clause in error, or insert the PICTURE clause.

Parent topic: COBCH0261 - COBCH0280


COBCH0274 GROUP INDICATE without COLUMN

You have specified the GROUP INDICATE clause but no COLUMN clause in the same report group description.

Resolution:

Include the COLUMN qualifier.

Parent topic: COBCH0261 - COBCH0280


COBCH0275 NEXT GROUP not allowed with this group TYPE

You have specified NEXT GROUP in a group with TYPE RF or PH.

Resolution:

Delete the NEXT GROUP clause.

Parent topic: COBCH0261 - COBCH0280


COBCH0276 NEXT GROUP NEXT PAGE not allowed with this group TYPE

You have specified NEXT GROUP or NEXT PAGE in a group with TYPE PF.

Resolution:

Delete the clause.

Parent topic: COBCH0261 - COBCH0280


COBCH0277 LINE NEXT PAGE not allowed with this group TYPE

You can specify the LINE NEXT PAGE clause only with a group of TYPE CH, CF, or DE.

Resolution:

Delete the LINE NEXT PAGE clause.

Parent topic: COBCH0261 - COBCH0280


COBCH0278 RESET item is lower CONTROL level than group

The control group on which a sum is reset must be at either the same level as or a lower level than the sum.

Resolution:

Refer to the chapter Report Writer in the Language Reference - Additional Topics for the rules governing the resetting of sums. Revise your code accordingly.

Parent topic: COBCH0261 - COBCH0280


COBCH0279 Report line too long

The syntax you have specified is trying to create a report line which is longer than the maximum allowed.

Resolution:

Ensure that any report lines are not longer than the permitted length.

Parent topic: COBCH0261 - COBCH0280


COBCH0280 THRU phrase not allowed with DBCS field

DBCS is Double Byte Character Set.

Resolution:

Refer to the chapter Micro Focus Extensions for Double-Byte Character Set Support in your Language Reference - Additional Topics for the rules governing the use of DBCS. Revise your code accordingly.

Parent topic: COBCH0261 - COBCH0280


COBCH0281 - COBCH0300

Lists the Syntax Checking error messages from COBCH0281 through COBCH0300.

  • COBCH0281 Illegal use of DBCS field
    DBCS is Double Byte Character Set.
  • COBCH0282 Number of BLL cells incorrect
  • COBCH0283 An EXTERNAL file cannot be subject of SAME RECORD AREA clause
    You have specified a file in a SAME RECORD AREA clause in your program that is specified as EXTERNAL in an FD entry.
  • COBCH0284 Not allowed in Report Section
    The syntax you have specified is not allowed in the Report Section.
  • COBCH0285 First LINE NUMBER clause in PAGE FOOTING group is relative
    Related Topics
  • COBCH0286 Not specified in CONTROL clause of RD
    Related Topics
  • COBCH0287 Data record specified for Report file
  • COBCH0288 SYNC with USAGE IS INDEX
    Related Topics
  • COBCH0289 SYNC at group level
    Related Topics
  • COBCH0290 Index key key-name not alphanumeric
    You have specified a key item that is not alphanumeric, in an index key clause where an alphanumeric key item is expected.
  • COBCH0291 Group FILLER
    Related Topics
  • COBCH0292 SIGN different from that at group level
    Related Topics
  • COBCH0293 SYNC on non-01 level group
    Related Topics
  • COBCH0295 VALUE clause in File or Linkage Section. Clause processed as comment
    You have specified a VALUE clause in either the File Section or the Linkage Section where you should not have specified one.
  • COBCH0296 BLANK WHEN ZERO with zero suppression
    Related Topics
  • COBCH0297 OCCURS .. DEPENDING clause without "integer TO". "1 TO" assumed
    Related Topics
  • COBCH0298 OCCURS at level 01 or 77
  • COBCH0299 FILLER omitted
    You have omitted the word FILLER.
  • COBCH0300 LABEL RECORDS clause omitted
    You have omitted the heading LABEL RECORDS.
Parent topic: Messages COBCH0201 to COBCH0300


COBCH0281 Illegal use of DBCS field

DBCS is Double Byte Character Set.

Resolution:

Refer to the chapter Report Writer in your Language Reference - Additional Topics for the rules governing the use of DBCS. Revise your code accordingly.

Parent topic: COBCH0281 - COBCH0300


COBCH0282 Number of BLL cells incorrect

Parent topic: COBCH0281 - COBCH0300


COBCH0283 An EXTERNAL file cannot be subject of SAME RECORD AREA clause

You have specified a file in a SAME RECORD AREA clause in your program that is specified as EXTERNAL in an FD entry.

Resolution:

Delete the EXTERNAL file in error from the SAME RECORD AREA clause in your program.

Parent topic: COBCH0281 - COBCH0300


COBCH0284 Not allowed in Report Section

The syntax you have specified is not allowed in the Report Section.

Resolution:

Delete the syntax from the Report Section.

Parent topic: COBCH0281 - COBCH0300


COBCH0285 First LINE NUMBER clause in PAGE FOOTING group is relative

Related Topics
Parent topic: COBCH0281 - COBCH0300


COBCH0286 Not specified in CONTROL clause of RD

Related Topics
Parent topic: COBCH0281 - COBCH0300


COBCH0287 Data record specified for Report file

Parent topic: COBCH0281 - COBCH0300


COBCH0288 SYNC with USAGE IS INDEX

Related Topics
Parent topic: COBCH0281 - COBCH0300


COBCH0289 SYNC at group level

Related Topics
Parent topic: COBCH0281 - COBCH0300


COBCH0290 Index key key-name not alphanumeric

You have specified a key item that is not alphanumeric, in an index key clause where an alphanumeric key item is expected.

Resolution:

Specify an alphanumeric key item.

Parent topic: COBCH0281 - COBCH0300


COBCH0291 Group FILLER

Related Topics
Parent topic: COBCH0281 - COBCH0300


COBCH0292 SIGN different from that at group level

Related Topics
Parent topic: COBCH0281 - COBCH0300


COBCH0293 SYNC on non-01 level group

Related Topics
Parent topic: COBCH0281 - COBCH0300


COBCH0295 VALUE clause in File or Linkage Section. Clause processed as comment

You have specified a VALUE clause in either the File Section or the Linkage Section where you should not have specified one.

Resolution:

You can delete the VALUE clause, although this has no effect on your program.

Parent topic: COBCH0281 - COBCH0300


COBCH0296 BLANK WHEN ZERO with zero suppression

Related Topics
Parent topic: COBCH0281 - COBCH0300


COBCH0297 OCCURS .. DEPENDING clause without "integer TO". "1 TO" assumed

Related Topics
Parent topic: COBCH0281 - COBCH0300


COBCH0298 OCCURS at level 01 or 77

Parent topic: COBCH0281 - COBCH0300


COBCH0299 FILLER omitted

You have omitted the word FILLER.

Resolution:

Add the word FILLER.

Parent topic: COBCH0281 - COBCH0300


COBCH0300 LABEL RECORDS clause omitted

You have omitted the heading LABEL RECORDS.

Resolution:

Add the LABEL RECORDS clause.

Parent topic: COBCH0281 - COBCH0300


Messages COBCH0301 to COBCH400

  • COBCH0301 - COBCH0320
    Lists the Syntax Checking error messages from COBCH0301 through COBCH0320.
  • COBCH0321 - COBCH0340
    Lists the Syntax Checking error messages from COBCH0321 through COBCH0340.
  • COBCH0341 - COBCH0360
    Lists the Syntax Checking error messages from COBCH0341 through COBCH0360.
  • COBCH0361 - COBCH0380
    Lists the Syntax Checking error messages from COBCH0361 through COBCH0380.
  • COBCH0381 - COBCH0400
    Lists the Syntax Checking error messages from COBCH0381 through COBCH0400.
Parent topic: Syntax Checking Error Messages


COBCH0301 - COBCH0320

Lists the Syntax Checking error messages from COBCH0301 through COBCH0320.

  • COBCH0301 Unrecognized verb
    You have either used a verb in the Procedure Division of your program that your COBOL system does not recognize as a valid COBOL verb, or have misspelled a COBOL verb.
  • COBCH0302 IF....ELSE or scope-delimiter mismatch
    An error exists in your coding of an IF statement in the Procedure Division of your program. The two halves of one IF statement do not match.
  • COBCH0303 Operand has wrong data-type
    You have used a data item with the wrong data-type in one of your statements. For example, you have used a filename instead of a record-name in a WRITE statement.
  • COBCH0304 Procedure name name not unique
    Two or more sections in the Procedure Division, or two or more paragraphs in a section, of your program have the same title.
  • COBCH0305 Procedure name name same as data-name
    A paragraph in the Procedure Division of your program has the same name as a data item declared in the Data Division.
  • COBCH0306 Entry name not unique
    You have used the same entry point-name more than once in your program. (This might be because the entry point name is the same as the Program-ID.)
  • COBCH0307 Wrong combination of data-types
    You are trying to manipulate data items which are not compatible.
  • COBCH0308 Conditional statement not allowed in this context
    You have used a conditional statement (one which specifies that the truth value of a condition is to be determined at run time) in the Procedure Division where an imperative statement is expected.
  • COBCH0309 Malformed subscript
    You have probably specified two subscripts for a one-dimensional table item.
  • COBCH0310 ACCEPT/DISPLAY syntax incorrect
    You have either used invalid syntax with an ACCEPT or DISPLAY statement, or have incorrectly coded that part of your code containing the communications syntax. The most likely cause of this message is a spelling mistake in your code.
  • COBCH0311 Illegal syntax used with I-O verb
    Code following an I/O verb (for example READ or WRITE) violates the rules of COBOL syntax.
  • COBCH0312 Invalid arithmetic statement
    An arithmetic statement which you have used in the Procedure Division does not conform to the rules of COBOL syntax. These statements must begin with an arithmetic verb (for example SUBTRACT or DIVIDE), followed by the relevant numeric literals or identifiers which the verb will act upon when the program is executed. The statement which you have specified is not a valid one.
  • COBCH0313 Invalid arithmetic expression
    An arithmetic expression which you have used in the Procedure Division is not a valid one.
  • COBCH0314 Illegal key
    The key value in a file operation or in a SEARCH statement is the wrong size.
  • COBCH0315 Invalid conditional expression
    A conditional expression which you have specified in the Procedure Division of your program does not conform to the rules of COBOL syntax. These expressions, an example of which is the statement immediately following an IF, enable one of two following statements to be executed at run time depending on the truth value.
  • COBCH0316 Too many AFTERs in PERFORM statement
    A PERFORM statement can be followed only by seven AFTER phrases. Your code exceeds this limit.
  • COBCH0317 Incorrect structure of Procedure Division
    You have made a mistake in the coding of the Procedure Division. For example, you might have forgotten one of the Section headers.
  • COBCH0318 File must have ACCESS SEQUENTIAL
    The file named in this statement must have sequential access mode. A file's access mode is derived from its SELECT statement; it is either implied by the file's organization or specified by its ACCESS MODE clause.
  • COBCH0319 Only index-names allowed with this format
    An index-name is required at this point in the operation you are trying.
  • COBCH0320 Too many operands in one statement
    A statement in the Procedure Division of your program contains too many operands or individual operands that are too long.
Parent topic: Messages COBCH0301 to COBCH400


COBCH0301 Unrecognized verb

You have either used a verb in the Procedure Division of your program that your COBOL system does not recognize as a valid COBOL verb, or have misspelled a COBOL verb.

Resolution:

Chech which verbs are permitted in the COBOL language, and ensure that you have spelled them correctly.

You might need to set a language-enabling directive if the verb you require is not part of your system's standard COBOL language.

Parent topic: COBCH0301 - COBCH0320


COBCH0302 IF....ELSE or scope-delimiter mismatch

An error exists in your coding of an IF statement in the Procedure Division of your program. The two halves of one IF statement do not match.

Alternatively, you have made an error in coding a construct that uses one of the scope delimiters (for example, END-ADD). There is a mismatch between the number of scope delimiters and the statements whose scope they delimit.

Resolution:

Ensure you do not have more ELSE phrases than IF phrases.

Revise your source code.

Parent topic: COBCH0301 - COBCH0320


COBCH0303 Operand has wrong data-type

You have used a data item with the wrong data-type in one of your statements. For example, you have used a filename instead of a record-name in a WRITE statement.

Resolution:

Revise the relevant item.

Parent topic: COBCH0301 - COBCH0320


COBCH0304 Procedure name name not unique

Two or more sections in the Procedure Division, or two or more paragraphs in a section, of your program have the same title.

Resolution:

Rename or qualify the sections or paragraphs in error to ensure uniqueness of reference.

Parent topic: COBCH0301 - COBCH0320


COBCH0305 Procedure name name same as data-name

A paragraph in the Procedure Division of your program has the same name as a data item declared in the Data Division.

Resolution:

Change the name of either the paragraph or the relevant data item to ensure uniqueness of reference.

Parent topic: COBCH0301 - COBCH0320


COBCH0306 Entry name not unique

You have used the same entry point-name more than once in your program. (This might be because the entry point name is the same as the Program-ID.)

Resolution:

Alter the entry-name in error or qualify it.

Parent topic: COBCH0301 - COBCH0320


COBCH0307 Wrong combination of data-types

You are trying to manipulate data items which are not compatible.

Resolution:

Ensure that the data items are of the same type.

Parent topic: COBCH0301 - COBCH0320


COBCH0308 Conditional statement not allowed in this context

You have used a conditional statement (one which specifies that the truth value of a condition is to be determined at run time) in the Procedure Division where an imperative statement is expected.

Resolution:

Replace the statement with one that begins with an imperative verb and is followed by a specification of an unconditional action to be taken at run time.

Parent topic: COBCH0301 - COBCH0320


COBCH0309 Malformed subscript

You have probably specified two subscripts for a one-dimensional table item.

Resolution:

Revise your code to ensure that you do not specify more than one subscript for a one-dimensional table item.

Parent topic: COBCH0301 - COBCH0320


COBCH0310 ACCEPT/DISPLAY syntax incorrect

You have either used invalid syntax with an ACCEPT or DISPLAY statement, or have incorrectly coded that part of your code containing the communications syntax. The most likely cause of this message is a spelling mistake in your code.

Resolution:

Correct the spelling mistake.

Parent topic: COBCH0301 - COBCH0320


COBCH0311 Illegal syntax used with I-O verb

Code following an I/O verb (for example READ or WRITE) violates the rules of COBOL syntax.

Resolution:

Revise your code accordingly.

Parent topic: COBCH0301 - COBCH0320


COBCH0312 Invalid arithmetic statement

An arithmetic statement which you have used in the Procedure Division does not conform to the rules of COBOL syntax. These statements must begin with an arithmetic verb (for example SUBTRACT or DIVIDE), followed by the relevant numeric literals or identifiers which the verb will act upon when the program is executed. The statement which you have specified is not a valid one.

Resolution:

Ensure that the arithmetic statement you want to use conforms to the relevant rules.

Parent topic: COBCH0301 - COBCH0320


COBCH0313 Invalid arithmetic expression

An arithmetic expression which you have used in the Procedure Division is not a valid one.

Resolution:

Click Related Topics for details of the COBOL syntax for complicated arithmetic tasks.

Parent topic: COBCH0301 - COBCH0320


COBCH0314 Illegal key

The key value in a file operation or in a SEARCH statement is the wrong size.

Resolution:

Check the key definition and correct the key value.

Parent topic: COBCH0301 - COBCH0320


COBCH0315 Invalid conditional expression

A conditional expression which you have specified in the Procedure Division of your program does not conform to the rules of COBOL syntax. These expressions, an example of which is the statement immediately following an IF, enable one of two following statements to be executed at run time depending on the truth value.

Resolution:

Refer to the chapter Program Definition in your Language Reference for details on the coding of the particular statement which you have used. Revise your code accordingly.

Parent topic: COBCH0301 - COBCH0320


COBCH0316 Too many AFTERs in PERFORM statement

A PERFORM statement can be followed only by seven AFTER phrases. Your code exceeds this limit.

Resolution:

Rewrite your code ensuring that no PERFORM statement has more than seven associated AFTER phrases.

Parent topic: COBCH0301 - COBCH0320


COBCH0317 Incorrect structure of Procedure Division

You have made a mistake in the coding of the Procedure Division. For example, you might have forgotten one of the Section headers.

Resolution:

Ensure that the Procedure Division follows a logical order and that each section in it has its own header.

Parent topic: COBCH0301 - COBCH0320


COBCH0318 File must have ACCESS SEQUENTIAL

The file named in this statement must have sequential access mode. A file's access mode is derived from its SELECT statement; it is either implied by the file's organization or specified by its ACCESS MODE clause.

Resolution:

Change the access mode of the file to sequential.

Parent topic: COBCH0301 - COBCH0320


COBCH0319 Only index-names allowed with this format

An index-name is required at this point in the operation you are trying.

Resolution:

Edit your source code to ensure that the name you have specified is an index-name.

Parent topic: COBCH0301 - COBCH0320


COBCH0320 Too many operands in one statement

A statement in the Procedure Division of your program contains too many operands or individual operands that are too long.

Resolution:

Reduce the number of operands, or shorten those operands that are too long.

Parent topic: COBCH0301 - COBCH0320


COBCH0321 - COBCH0340

Lists the Syntax Checking error messages from COBCH0321 through COBCH0340.

  • COBCH0321 Repeated INDEXED BY phrase
    You have used more than one INDEXED BY phrase on a table. This is not conformant with your selected flagging dialect.
  • COBCH0322 Cannot reference DEBUG-ITEM outside declaratives
    You have referred to your COBOL system-generated data item DEBUG-ITEM in a procedure that is not in the Declaratives Section of your program's Procedure Division. References to DEBUG-ITEM are permitted only in the Declaratives Section.
  • COBCH0323 More than one USE procedure on same file
    You have associated two or more USE procedures with the same file when you can associate only one.
  • COBCH0324 More than one USE procedure for same open mode
    You have associated two or more USE procedures with the same file open mode when you can associate only one.
  • COBCH0325 Illegal combination of debugging procedures
    You have specified an invalid combination of USE FOR DEBUGGING procedures in the Declaratives.
  • COBCH0326 Literal cannot be receiving field
    You have specified a literal value as the receiving field in an operation involving an implicit or explicit move. A receiving field must be a data item.
  • COBCH0327 Index item not permitted
    You have named an index data item as the sending or receiving field in a MOVE statement. This is not permitted.
  • COBCH0328 Not allowed with OPTIONAL file
  • COBCH0329 WHEN phrase missing from SEARCH statement
    You have specified a SEARCH statement with no WHEN phrase. You must specify at least one WHEN phrase in a SEARCH statement.
  • COBCH0330 Not a record name
    You must specify the name of a file record in this context (as defined in an FD entry in the File Section). You have probably misspelled a valid record-name.
  • COBCH0332 AFTER phrase not allowed with in-line perform
    You cannot specify an AFTER phrase in an inline PERFORM statement.
  • COBCH0333 Not an alterable paragraph
    The paragraph you have named in an ALTER statement is not a paragraph on which an ALTER statement can operate. Such a paragraph must consist of a single sentence containing only a single GO TO statement (without a DEPENDING phrase).
  • COBCH0334 Cannot follow WHEN OTHER
    The WHEN OTHER phrase, if specified, must be the last phrase in an EVALUATE statement.
  • COBCH0335 Selection object does not match selection subject
    A type mismatch has occurred between one of the selection subjects in an EVALUATE statement and the corresponding selection object.
  • COBCH0336 Variable length group not allowed
    You cannot INITIALIZE a variable-length item.
  • COBCH0337 Cannot repeat same category
    You have repeated the same data class in the REPLACING phrase of an INITIALIZE statement.
  • COBCH0338 REPORT not specified in an FD
    You have referred to a report for which no FD entry exists in the Report Section. You might have forgotten to specify the report entry, or you might have misspelled a correct report-name.
  • COBCH0339 Not allowed with SEQUENTIAL files
    You have specified an operation that cannot be performed on a file opened in sequential access mode.
  • COBCH0340 Not allowed with RANDOM ACCESS files
    You have specified an operation that cannot be performed on a file opened in random access mode.
Parent topic: Messages COBCH0301 to COBCH400


COBCH0321 Repeated INDEXED BY phrase

You have used more than one INDEXED BY phrase on a table. This is not conformant with your selected flagging dialect.
Parent topic: COBCH0321 - COBCH0340


COBCH0322 Cannot reference DEBUG-ITEM outside declaratives

You have referred to your COBOL system-generated data item DEBUG-ITEM in a procedure that is not in the Declaratives Section of your program's Procedure Division. References to DEBUG-ITEM are permitted only in the Declaratives Section.

Resolution:

Delete the reference to DEBUG-ITEM, or move it to the Declaratives Section.

Parent topic: COBCH0321 - COBCH0340


COBCH0323 More than one USE procedure on same file

You have associated two or more USE procedures with the same file when you can associate only one.

Resolution:

Delete the additional USE references.

Parent topic: COBCH0321 - COBCH0340


COBCH0324 More than one USE procedure for same open mode

You have associated two or more USE procedures with the same file open mode when you can associate only one.

Resolution:

Delete the additional USE references.

Parent topic: COBCH0321 - COBCH0340


COBCH0325 Illegal combination of debugging procedures

You have specified an invalid combination of USE FOR DEBUGGING procedures in the Declaratives.

Resolution:

Refer to the chapter Debug Module in your Language Reference - Additional Topics for details of debugging procedures. Correct the declaratives.

Parent topic: COBCH0321 - COBCH0340


COBCH0326 Literal cannot be receiving field

You have specified a literal value as the receiving field in an operation involving an implicit or explicit move. A receiving field must be a data item.

Resolution:

Change the literal value to a reference to a data item.

Parent topic: COBCH0321 - COBCH0340


COBCH0327 Index item not permitted

You have named an index data item as the sending or receiving field in a MOVE statement. This is not permitted.

Resolution:

Move the value into a nonindex data item and use this data item in the MOVE statement.

Parent topic: COBCH0321 - COBCH0340


COBCH0328 Not allowed with OPTIONAL file

Parent topic: COBCH0321 - COBCH0340


COBCH0329 WHEN phrase missing from SEARCH statement

You have specified a SEARCH statement with no WHEN phrase. You must specify at least one WHEN phrase in a SEARCH statement.

Resolution:

Add a WHEN phrase to the SEARCH statement.

Parent topic: COBCH0321 - COBCH0340


COBCH0330 Not a record name

You must specify the name of a file record in this context (as defined in an FD entry in the File Section). You have probably misspelled a valid record-name.

Resolution:

Correct the reference so that it is a reference to a file record.

Parent topic: COBCH0321 - COBCH0340


COBCH0332 AFTER phrase not allowed with in-line perform

You cannot specify an AFTER phrase in an inline PERFORM statement.

Resolution:

Delete the AFTER phrase.

Parent topic: COBCH0321 - COBCH0340


COBCH0333 Not an alterable paragraph

The paragraph you have named in an ALTER statement is not a paragraph on which an ALTER statement can operate. Such a paragraph must consist of a single sentence containing only a single GO TO statement (without a DEPENDING phrase).

Resolution:

Change the reference in the ALTER statement to refer to a paragraph that can be operated on by ALTER, or edit the named paragraph so that it can be operated on by ALTER

Parent topic: COBCH0321 - COBCH0340


COBCH0334 Cannot follow WHEN OTHER

The WHEN OTHER phrase, if specified, must be the last phrase in an EVALUATE statement.

Resolution:

Ensure any WHEN phrases precede the WHEN OTHER phrase.

Parent topic: COBCH0321 - COBCH0340


COBCH0335 Selection object does not match selection subject

A type mismatch has occurred between one of the selection subjects in an EVALUATE statement and the corresponding selection object.

Resolution:

Correct the EVALUATE statement.

Parent topic: COBCH0321 - COBCH0340


COBCH0336 Variable length group not allowed

You cannot INITIALIZE a variable-length item.

Resolution:

Delete the item-name from the INITIALIZE statement.

Parent topic: COBCH0321 - COBCH0340


COBCH0337 Cannot repeat same category

You have repeated the same data class in the REPLACING phrase of an INITIALIZE statement.

Resolution:

Delete the repeated class from the INITIALIZE statement.

Parent topic: COBCH0321 - COBCH0340


COBCH0338 REPORT not specified in an FD

You have referred to a report for which no FD entry exists in the Report Section. You might have forgotten to specify the report entry, or you might have misspelled a correct report-name.

Resolution:

Correct the report-name or add the necessary report definition to the Report Section.

Parent topic: COBCH0321 - COBCH0340


COBCH0339 Not allowed with SEQUENTIAL files

You have specified an operation that cannot be performed on a file opened in sequential access mode.
Parent topic: COBCH0321 - COBCH0340


COBCH0340 Not allowed with RANDOM ACCESS files

You have specified an operation that cannot be performed on a file opened in random access mode.
Parent topic: COBCH0321 - COBCH0340


COBCH0341 - COBCH0360

Lists the Syntax Checking error messages from COBCH0341 through COBCH0360.

  • COBCH0341 Not allowed with LINE SEQUENTIAL files
    You have specified an operation that cannot be performed on a line sequential file.
  • COBCH0342 Not allowed with LINAGE files
    You have performed an illegal operation on a file defined with a LINAGE clause (for example, WRITE AFTER CO1).
  • COBCH0343 Can only be used in inline PERFORM
    Related Topics
  • COBCH0344 Should be level 01 or 77
    You have specified a data item that is not a level 01 or level 77 data item where your COBOL system is expecting the data item to be either one of these levels.
  • COBCH0345 USING parameter used twice in parameter list
    You have specified the same data item-name twice in the USING phrase of the Procedure Division header. All the names in the USING phrase must be different.
  • COBCH0346 Only one WHEN phrase allowed with SEARCH ALL
    You have specified two WHEN phrases in a SEARCH statement using the ALL option. You can specify only one WHEN phrase in this context.
  • COBCH0347 MERGE needs at least two USING files
    You have specified fewer than two filenames in the USING phrase of a MERGE statement.
  • COBCH0348 Procedure name procedure-name undeclared, first used on line line-number
    You have referred to a nonexistent paragraph or section. You have probably misspelled a valid procedure-name.
  • COBCH0349 "LOCK" clause expected
    You have not specified the LOCK phrase with a READ statement.
  • COBCH0350 Illegal use of "NO LOCK"
    You have used a READ statement with the NO LOCK phrase on a file for which no record locking is required.
  • COBCH0351 "LOCK" clause specified for "EXCLUSIVE" file
    You have specified a LOCK clause in a READ statement for a file that you have already locked with an EXCLUSIVE lock (in the FILE-CONTROL paragraph of your code).
  • COBCH0352 "KEPT" specified for file with single record locking
    This message applies only to multi-user syntax. You have specified a WITH KEPT LOCK phrase in a READ statement which accesses a file that does not support multiple record locking.
  • COBCH0353 Cannot reference a Report Section item that is not a sum-counter
  • COBCH0354 Multiple receiving fields in MOVE CORRESPONDING
    Related Topics
  • COBCH0355 Only "=" and "NOT =" allowed for pointer data items
    You can use the operators = and NOT = only in comparisons involving pointer data items.
  • COBCH0356 Not allowed with REPORT files
    You have tried to perform a file operation (READ, WRITE, REWRITE) on a file whose FD entry indicates that it is a report.
  • COBCH0357 Screen is display-only
    You have named a screen in an ACCEPT statement that contains only display fields.
  • COBCH0358 Missing comma
    COBOL syntax expects a comma at this point.
  • COBCH0359 Mismatch of table dimensions
    A data item in an ACCEPT/DISPLAY statement has a different number of dimensions from the corresponding Screen Section item.
  • COBCH0360 File must have ACCESS DYNAMIC
    You have specified an operation on a file that can be performed only if the file has access mode DYNAMIC.
Parent topic: Messages COBCH0301 to COBCH400


COBCH0341 Not allowed with LINE SEQUENTIAL files

You have specified an operation that cannot be performed on a line sequential file.
Parent topic: COBCH0341 - COBCH0360


COBCH0342 Not allowed with LINAGE files

You have performed an illegal operation on a file defined with a LINAGE clause (for example, WRITE AFTER CO1).

Resolution:

Delete the illegal operation or redefine the file without a LINAGE clause.

Parent topic: COBCH0341 - COBCH0360


COBCH0343 Can only be used in inline PERFORM

Related Topics
Parent topic: COBCH0341 - COBCH0360


COBCH0344 Should be level 01 or 77

You have specified a data item that is not a level 01 or level 77 data item where your COBOL system is expecting the data item to be either one of these levels.

Resolution:

Redefine the data item to be level 01 or level 77.

Parent topic: COBCH0341 - COBCH0360


COBCH0345 USING parameter used twice in parameter list

You have specified the same data item-name twice in the USING phrase of the Procedure Division header. All the names in the USING phrase must be different.

Resolution:

Delete the extra reference.

Parent topic: COBCH0341 - COBCH0360


COBCH0346 Only one WHEN phrase allowed with SEARCH ALL

You have specified two WHEN phrases in a SEARCH statement using the ALL option. You can specify only one WHEN phrase in this context.

Resolution:

Delete the extra WHEN phrase.

Parent topic: COBCH0341 - COBCH0360


COBCH0347 MERGE needs at least two USING files

You have specified fewer than two filenames in the USING phrase of a MERGE statement.

Resolution:

Ensure that you specify at least two filenames in the USING phrase of the MERGE statement.

Parent topic: COBCH0341 - COBCH0360


COBCH0348 Procedure name procedure-name undeclared, first used on line line-number

You have referred to a nonexistent paragraph or section. You have probably misspelled a valid procedure-name.

Resolution:

Ensure that the procedure you have referred to exists and that you have spelled it correctly.

Parent topic: COBCH0341 - COBCH0360


COBCH0349 "LOCK" clause expected

You have not specified the LOCK phrase with a READ statement.

Resolution:

Insert a LOCK phrase in the READ statement.

Parent topic: COBCH0341 - COBCH0360


COBCH0350 Illegal use of "NO LOCK"

You have used a READ statement with the NO LOCK phrase on a file for which no record locking is required.

Resolution:

Delete the NO LOCK phrase.

Parent topic: COBCH0341 - COBCH0360


COBCH0351 "LOCK" clause specified for "EXCLUSIVE" file

You have specified a LOCK clause in a READ statement for a file that you have already locked with an EXCLUSIVE lock (in the FILE-CONTROL paragraph of your code).

Resolution:

Record locking is impossible on a file which your run unit has already locked with an EXCLUSIVE lock. To ensure that the two LOCK entries are compatible, you should either delete the LOCK entry in the relevant READ statement, or alter the LOCK MODE IS entry in the FILE-CONTROL paragraph.

Parent topic: COBCH0341 - COBCH0360


COBCH0352 "KEPT" specified for file with single record locking

This message applies only to multi-user syntax. You have specified a WITH KEPT LOCK phrase in a READ statement which accesses a file that does not support multiple record locking.

Resolution:

Either change the filetype or delete the WITH KEPT LOCK phrase to ensure compatibility between the two entries.

Parent topic: COBCH0341 - COBCH0360


COBCH0353 Cannot reference a Report Section item that is not a sum-counter

Parent topic: COBCH0341 - COBCH0360


COBCH0354 Multiple receiving fields in MOVE CORRESPONDING

Related Topics
Parent topic: COBCH0341 - COBCH0360


COBCH0355 Only "=" and "NOT =" allowed for pointer data items

You can use the operators = and NOT = only in comparisons involving pointer data items.

Resolution:

Correct the comparison.

Parent topic: COBCH0341 - COBCH0360


COBCH0356 Not allowed with REPORT files

You have tried to perform a file operation (READ, WRITE, REWRITE) on a file whose FD entry indicates that it is a report.

Resolution:

Delete the input-output statement.

Parent topic: COBCH0341 - COBCH0360


COBCH0357 Screen is display-only

You have named a screen in an ACCEPT statement that contains only display fields.

Resolution:

Make sure that you have named the correct screen.

Parent topic: COBCH0341 - COBCH0360


COBCH0358 Missing comma

COBOL syntax expects a comma at this point.

Resolution:

Add the missing comma.

Parent topic: COBCH0341 - COBCH0360


COBCH0359 Mismatch of table dimensions

A data item in an ACCEPT/DISPLAY statement has a different number of dimensions from the corresponding Screen Section item.

Alternatively, the Screen Section item has a different number of dimensions from the corresponding data item appearing in the USING or TO clause.

Resolution:

Make the two item definitions consistent.

Parent topic: COBCH0341 - COBCH0360


COBCH0360 File must have ACCESS DYNAMIC

You have specified an operation on a file that can be performed only if the file has access mode DYNAMIC.

Resolution:

Change the file control entry for the file so that it has access mode DYNAMIC.

Parent topic: COBCH0341 - COBCH0360


COBCH0361 - COBCH0380

Lists the Syntax Checking error messages from COBCH0361 through COBCH0380.

  • COBCH0361 Operation exceeds COMP subset
    Your program contains a statement that cannot be compiled to COMP subset instructions.
  • COBCH0362 data-name not declared for file or wrong type for CODE-SET
    The data-names you have specified in the CODE-SET clause do not belong to a record in the file.
  • COBCH0363 data-name not in same record as first item in CODE-SET clause
    You have specified data-names in the CODE-SET clause that belong to more than one record. All data-names specified in this clause must belong to a single record in the file.
  • COBCH0364 data-name overlaps another item in CODE-SET clause
    One or more of the data-names specified in the CODE-SET clause is redefined, or you might have specified the whole record, rather than individual data-names contained in that record, in the CODE-SET clause.
  • COBCH0365 Variable size table not last in group or subsidiary to OCCURS
    OCCURS DEPENDING ON item must be last item in a group.
  • COBCH0366 Variable length delimiter not allowed
    You cannot use a reference modified item or a group containing an OCCURS ... DEPENDING ON clause in this context.
  • COBCH0367 Description of operand does not contain the INDEXED BY clause
    A SEARCH is not possible as the description of the operand does not contain the INDEXED BY clause.
  • COBCH0368 Exception phrase inappropriate
    The specified exception is not appropriate with this statement in the specified access mode. For example an AT END has been specified with random access, or INVALID KEY with sequential access.
  • COBCH0369 OPEN EXTEND on file with LINAGE clause
    OPEN EXTEND is not allowed on a file defined with a LINAGE clause.
  • COBCH0370 Operand must be a table
    The operand used in this situation can only be a table.
  • COBCH0371 Data size is too large
    Your program's data size exceeds the maximum size permitted.
  • COBCH0372 Illegal use of SORT file
    You have specified a SORT file incorrectly.
  • COBCH0373 PICTURE string contains more than 18 numeric positions
    Your PICTURE string can contain a maximum of 18 numeric positions.
  • COBCH0374 Illegal use of floating-point item
    You have specified a floating-point item incorrectly.
  • COBCH0375 Literal includes repeated characters
    Related Topics
  • COBCH0376 Table superordinate to operand is not indexed
  • COBCH0377 SORT table does not support complex OCCURS DEPENDING ON tables
    Related Topics
  • COBCH0378 More than seven AFTER phrases
    You can include a maximum of seven AFTER phrases in a PERFORM statement.
  • COBCH0379 Non-DISPLAY numeric data cannot be compared with alphanumeric data
  • COBCH0380 Parameter count in CALL different from that in PROCEDURE DIVISION header
    Related Topics
Parent topic: Messages COBCH0301 to COBCH400


COBCH0361 Operation exceeds COMP subset

Your program contains a statement that cannot be compiled to COMP subset instructions.
Parent topic: COBCH0361 - COBCH0380


COBCH0362 data-name not declared for file or wrong type for CODE-SET

The data-names you have specified in the CODE-SET clause do not belong to a record in the file.

Resolution:

Edit your source code so that the data-names in the CODE-SET clause refer to a record in the file.

Parent topic: COBCH0361 - COBCH0380


COBCH0363 data-name not in same record as first item in CODE-SET clause

You have specified data-names in the CODE-SET clause that belong to more than one record. All data-names specified in this clause must belong to a single record in the file.

Resolution:

Edit your source code to delete one or more of the CODE-SET data-names to ensure that all data-names belong to only one record.

Parent topic: COBCH0361 - COBCH0380


COBCH0364 data-name overlaps another item in CODE-SET clause

One or more of the data-names specified in the CODE-SET clause is redefined, or you might have specified the whole record, rather than individual data-names contained in that record, in the CODE-SET clause.

Resolution:

Edit your source code so that the data-names in the record are specified only once.

Parent topic: COBCH0361 - COBCH0380


COBCH0365 Variable size table not last in group or subsidiary to OCCURS

OCCURS DEPENDING ON item must be last item in a group.

Resolution:

Restructure your data items so that the OCCURS DEPENDING ON item is the last item in the group.

Parent topic: COBCH0361 - COBCH0380


COBCH0366 Variable length delimiter not allowed

You cannot use a reference modified item or a group containing an OCCURS ... DEPENDING ON clause in this context.

Resolution:

Replace the reference modified item, or specify a valid item in the OCCURS DEPENDING ON clause.

Parent topic: COBCH0361 - COBCH0380


COBCH0367 Description of operand does not contain the INDEXED BY clause

A SEARCH is not possible as the description of the operand does not contain the INDEXED BY clause.

Resolution:

Include an INDEXED BY clause in your operand description.

Parent topic: COBCH0361 - COBCH0380


COBCH0368 Exception phrase inappropriate

The specified exception is not appropriate with this statement in the specified access mode. For example an AT END has been specified with random access, or INVALID KEY with sequential access.
Parent topic: COBCH0361 - COBCH0380


COBCH0369 OPEN EXTEND on file with LINAGE clause

OPEN EXTEND is not allowed on a file defined with a LINAGE clause.
Parent topic: COBCH0361 - COBCH0380


COBCH0370 Operand must be a table

The operand used in this situation can only be a table.

Resolution:

Revise your code so that the operand is a table.

Parent topic: COBCH0361 - COBCH0380


COBCH0371 Data size is too large

Your program's data size exceeds the maximum size permitted.

Resolution:

Redesign your program to include less data.

Parent topic: COBCH0361 - COBCH0380


COBCH0372 Illegal use of SORT file

You have specified a SORT file incorrectly.

Resolution:

Correct the syntax.

Parent topic: COBCH0361 - COBCH0380


COBCH0373 PICTURE string contains more than 18 numeric positions

Your PICTURE string can contain a maximum of 18 numeric positions.

Resolution:

Change your PICTURE string so that it contains no more than 18 numeric positions.

Parent topic: COBCH0361 - COBCH0380


COBCH0374 Illegal use of floating-point item

You have specified a floating-point item incorrectly.

Resolution:

Do not use a floating-point item in this context.

Parent topic: COBCH0361 - COBCH0380


COBCH0375 Literal includes repeated characters

Related Topics
Parent topic: COBCH0361 - COBCH0380


COBCH0376 Table superordinate to operand is not indexed

Parent topic: COBCH0361 - COBCH0380


COBCH0377 SORT table does not support complex OCCURS DEPENDING ON tables

Related Topics
Parent topic: COBCH0361 - COBCH0380


COBCH0378 More than seven AFTER phrases

You can include a maximum of seven AFTER phrases in a PERFORM statement.

Resolution:

Delete any extra AFTER phrases.

Parent topic: COBCH0361 - COBCH0380


COBCH0379 Non-DISPLAY numeric data cannot be compared with alphanumeric data

Parent topic: COBCH0361 - COBCH0380


COBCH0380 Parameter count in CALL different from that in PROCEDURE DIVISION header

Related Topics
Parent topic: COBCH0361 - COBCH0380


COBCH0381 - COBCH0400

Lists the Syntax Checking error messages from COBCH0381 through COBCH0400.

  • COBCH0381 TALLYING option has ALL etc. distributed over multiple identifiers
    Related Topics
  • COBCH0382 Only one Procedure-name in GO TO ... DEPENDING
    Related Topics
  • COBCH0383 Missing ALSO
    You have omitted the word ALSO.
  • COBCH0384 NEXT SENTENCE does not follow ON, IF, ELSE or SEARCH WHEN
    NEXT SENTENCE should be used only in either branch of an IF statement or the WHEN branch of a SEARCH statement.
  • COBCH0385 Order of initialization changed
  • COBCH0386 No section or paragraph at start of Procedure Division
  • COBCH0387 AFTER and BEFORE options used together
    Related Topics
  • COBCH0388 Key is right hand side of condition
  • COBCH0389 EXIT not in separate paragraph
    Related Topics
  • COBCH0390 OPEN EXTEND on non-sequential file
    Related Topics
  • COBCH0391 MF format Accept/Display
    Related Topics
  • COBCH0392 More than two AFTER phrases
    You have included more than the maximum of two AFTER phrases in your program.
  • COBCH0393 Inline PERFORM
    Related Topics
  • COBCH0394 No section header after END DECLARATIVES
    Related Topics
  • COBCH0395 FROM literal
    Related Topics
  • COBCH0396 No suitable conditional phrase and no applicable declarative
  • COBCH0397 No preceding section
  • COBCH0398 Offset only allowed with Index-names
  • COBCH0399 Index-name belongs to different table
  • COBCH0400 Cannot use index data item as subscript
    You have used an index data item as a subscript in your program.
Parent topic: Messages COBCH0301 to COBCH400


COBCH0381 TALLYING option has ALL etc. distributed over multiple identifiers

Related Topics
Parent topic: COBCH0381 - COBCH0400


COBCH0382 Only one Procedure-name in GO TO ... DEPENDING

Related Topics
Parent topic: COBCH0381 - COBCH0400


COBCH0383 Missing ALSO

You have omitted the word ALSO.

Resolution:

Add the word ALSO.

Parent topic: COBCH0381 - COBCH0400


COBCH0384 NEXT SENTENCE does not follow ON, IF, ELSE or SEARCH WHEN

NEXT SENTENCE should be used only in either branch of an IF statement or the WHEN branch of a SEARCH statement.

Resolution:

Revise your code to ensure that you have obeyed these rules.

Parent topic: COBCH0381 - COBCH0400


COBCH0385 Order of initialization changed

Parent topic: COBCH0381 - COBCH0400


COBCH0386 No section or paragraph at start of Procedure Division

Parent topic: COBCH0381 - COBCH0400


COBCH0387 AFTER and BEFORE options used together

Related Topics
Parent topic: COBCH0381 - COBCH0400


COBCH0388 Key is right hand side of condition

Parent topic: COBCH0381 - COBCH0400


COBCH0389 EXIT not in separate paragraph

Related Topics
Parent topic: COBCH0381 - COBCH0400


COBCH0390 OPEN EXTEND on non-sequential file

Related Topics
Parent topic: COBCH0381 - COBCH0400


COBCH0391 MF format Accept/Display

Related Topics
Parent topic: COBCH0381 - COBCH0400


COBCH0392 More than two AFTER phrases

You have included more than the maximum of two AFTER phrases in your program.

Resolution:

Delete any extra AFTER phrases.

Parent topic: COBCH0381 - COBCH0400


COBCH0393 Inline PERFORM

Related Topics
Parent topic: COBCH0381 - COBCH0400


COBCH0394 No section header after END DECLARATIVES

Related Topics
Parent topic: COBCH0381 - COBCH0400


COBCH0395 FROM literal

Related Topics
Parent topic: COBCH0381 - COBCH0400


COBCH0396 No suitable conditional phrase and no applicable declarative

Parent topic: COBCH0381 - COBCH0400


COBCH0397 No preceding section

Parent topic: COBCH0381 - COBCH0400


COBCH0398 Offset only allowed with Index-names

Parent topic: COBCH0381 - COBCH0400


COBCH0399 Index-name belongs to different table

Parent topic: COBCH0381 - COBCH0400


COBCH0400 Cannot use index data item as subscript

You have used an index data item as a subscript in your program.
Parent topic: COBCH0381 - COBCH0400


Messages COBCH0401 to COBCH0500

  • COBCH0401 - COBCH0420
    Lists the Syntax Checking error messages from COBCH0401 through COBCH0420.
  • COBCH0421 - COBCH0440
    Lists the Syntax Checking error messages from COBCH0421 through COBCH0440.
  • COBCH0441 - COBCH0460
    Lists the Syntax Checking error messages from COBCH0441 through COBCH0460.
  • COBCH0461 - COBCH0480
    Lists the Syntax Checking error messages from COBCH0461 through COBCH0480.
  • COBCH0481 - COBCH0500
    Lists the Syntax Checking error messages from COBCH0481 through COBCH0500.
Parent topic: Syntax Checking Error Messages


COBCH0401 - COBCH0420

Lists the Syntax Checking error messages from COBCH0401 through COBCH0420.

  • COBCH0401 Limit exceeded - number of source statements > limit
  • COBCH0402 Limit exceeded - number of files > limit
  • COBCH0404 Limit exceeded - number of pairs of REPLACING operands > limit
    Related Topics
  • COBCH0406 Limit exceeded - length of file/copy/library name > limit
  • COBCH0408 Limit exceeded - number of sections/paragraphs/labels > 64k
    The combined number of sections, paragraphs and labels in the Procedure Division is greater than 65535 (64K).
  • COBCH0409 Limit exceeded - number of SELECT filenames > limit
    Related Topics
  • COBCH0410 Limit exceeded - number of SAME RECORD AREA clauses > limit
    Related Topics
  • COBCH0411 Limit exceeded - number of MULTIPLE FILE filenames > limit
    Related Topics
  • COBCH0412 Limit exceeded - number of ALTERNATE RECORD KEY clauses in a file > limit
    Related Topics
  • COBCH0413 Limit exceeded - length of RECORD KEY > limit characters
    Related Topics
  • COBCH0414 Limit exceeded - length of Data Division > limit
  • COBCH0415 Limit exceeded - length of Data Section > limit
  • COBCH0419 Limit exceeded - BLOCK size > limit characters
    Related Topics
  • COBCH0420 Limit exceeded - RECORD length > limit characters
    Related Topics
Parent topic: Messages COBCH0401 to COBCH0500


COBCH0401 Limit exceeded - number of source statements > limit

Parent topic: COBCH0401 - COBCH0420


COBCH0402 Limit exceeded - number of files > limit

Parent topic: COBCH0401 - COBCH0420


COBCH0404 Limit exceeded - number of pairs of REPLACING operands > limit

Related Topics
Parent topic: COBCH0401 - COBCH0420


COBCH0406 Limit exceeded - length of file/copy/library name > limit

Parent topic: COBCH0401 - COBCH0420


COBCH0408 Limit exceeded - number of sections/paragraphs/labels > 64k

The combined number of sections, paragraphs and labels in the Procedure Division is greater than 65535 (64K).

You need to restructure your code to comply with this limit.

Parent topic: COBCH0401 - COBCH0420
Related concepts
Size of Programs Divisions and Sections


COBCH0409 Limit exceeded - number of SELECT filenames > limit

Related Topics
Parent topic: COBCH0401 - COBCH0420


COBCH0410 Limit exceeded - number of SAME RECORD AREA clauses > limit

Related Topics
Parent topic: COBCH0401 - COBCH0420


COBCH0411 Limit exceeded - number of MULTIPLE FILE filenames > limit

Related Topics
Parent topic: COBCH0401 - COBCH0420


COBCH0412 Limit exceeded - number of ALTERNATE RECORD KEY clauses in a file > limit

Related Topics
Parent topic: COBCH0401 - COBCH0420


COBCH0413 Limit exceeded - length of RECORD KEY > limit characters

Related Topics
Parent topic: COBCH0401 - COBCH0420


COBCH0414 Limit exceeded - length of Data Division > limit

Parent topic: COBCH0401 - COBCH0420


COBCH0415 Limit exceeded - length of Data Section > limit

Parent topic: COBCH0401 - COBCH0420


COBCH0419 Limit exceeded - BLOCK size > limit characters

Related Topics
Parent topic: COBCH0401 - COBCH0420


COBCH0420 Limit exceeded - RECORD length > limit characters

Related Topics
Parent topic: COBCH0401 - COBCH0420


COBCH0421 - COBCH0440

Lists the Syntax Checking error messages from COBCH0421 through COBCH0440.

  • COBCH0421 Limit exceeded - number of FD filenames > limit
    Related Topics
  • COBCH0422 Limit exceeded - number of SD filenames > limit
    Related Topics
  • COBCH0424 Limit exceeded - number of 01 &77 items in Linkage Section > limit
  • COBCH0425 Limit exceeded - length of File Section group item > limit characters
  • COBCH0426 Limit exceeded - length of group item > limit characters
  • COBCH0427 Limit exceeded - length of data item > limit characters
  • COBCH0428 Limit exceeded - length of edited item > limit characters
  • COBCH0429 Limit exceeded - length of variable length table > limit characters
  • COBCH0430 Total length of VALUE literals > integer - possible problem on mainframe
  • COBCH0431 Limit exceeded - length of PICTURE string > limit characters
    Related Topics
  • COBCH0432 Limit exceeded - length of PICTURE replication > limit
    Related Topics
  • COBCH0433 Limit exceeded - length of sort record > limit characters
  • COBCH0434 Limit exceeded - length of table > limit characters
  • COBCH0435 Limit exceeded - length of table element > limit characters
  • COBCH0436 Limit exceeded - number of ASC/DESC KEY clauses > limit
    Related Topics
  • COBCH0437 Limit exceeded at limit - length of ASC/DESC KEYs > limit characters
    Related Topics
  • COBCH0438 Limit exceeded - number of INDEXED BY clauses > limit
    Related Topics
  • COBCH0440 Limit exceeded - number of paragraph labels > limit
Parent topic: Messages COBCH0401 to COBCH0500


COBCH0421 Limit exceeded - number of FD filenames > limit

Related Topics
Parent topic: COBCH0421 - COBCH0440


COBCH0422 Limit exceeded - number of SD filenames > limit

Related Topics
Parent topic: COBCH0421 - COBCH0440


COBCH0424 Limit exceeded - number of 01 &77 items in Linkage Section > limit

Parent topic: COBCH0421 - COBCH0440


COBCH0425 Limit exceeded - length of File Section group item > limit characters

Parent topic: COBCH0421 - COBCH0440


COBCH0426 Limit exceeded - length of group item > limit characters

Parent topic: COBCH0421 - COBCH0440


COBCH0427 Limit exceeded - length of data item > limit characters

Parent topic: COBCH0421 - COBCH0440


COBCH0428 Limit exceeded - length of edited item > limit characters

Parent topic: COBCH0421 - COBCH0440


COBCH0429 Limit exceeded - length of variable length table > limit characters

Parent topic: COBCH0421 - COBCH0440


COBCH0430 Total length of VALUE literals > integer - possible problem on mainframe

Parent topic: COBCH0421 - COBCH0440


COBCH0431 Limit exceeded - length of PICTURE string > limit characters

Related Topics
Parent topic: COBCH0421 - COBCH0440


COBCH0432 Limit exceeded - length of PICTURE replication > limit

Related Topics
Parent topic: COBCH0421 - COBCH0440


COBCH0433 Limit exceeded - length of sort record > limit characters

Parent topic: COBCH0421 - COBCH0440


COBCH0434 Limit exceeded - length of table > limit characters

Parent topic: COBCH0421 - COBCH0440


COBCH0435 Limit exceeded - length of table element > limit characters

Parent topic: COBCH0421 - COBCH0440


COBCH0436 Limit exceeded - number of ASC/DESC KEY clauses > limit

Related Topics
Parent topic: COBCH0421 - COBCH0440


COBCH0437 Limit exceeded at limit - length of ASC/DESC KEYs > limit characters

Related Topics
Parent topic: COBCH0421 - COBCH0440


COBCH0438 Limit exceeded - number of INDEXED BY clauses > limit

Related Topics
Parent topic: COBCH0421 - COBCH0440


COBCH0440 Limit exceeded - number of paragraph labels > limit

Parent topic: COBCH0421 - COBCH0440


COBCH0441 - COBCH0460

Lists the Syntax Checking error messages from COBCH0441 through COBCH0460.

  • COBCH0441 Limit exceeded - number of PERFORMs > limit
    Related Topics
  • COBCH0442 Limit exceeded - OCCURS nesting > limit
    Related Topics
  • COBCH0443 Limit exceeded - number of GO TO DEPENDING ON names > limit
    Related Topics
  • COBCH0444 Limit exceeded - number of IF nesting levels > limit
    Related Topics
  • COBCH0445 Limit exceeded - number of CALL parameters > limit
    Related Topics
  • COBCH0446 Limit exceeded - number of SORT/MERGE input files > limit
    Related Topics
  • COBCH0447 Limit exceeded - number of SORT/MERGE keys > limit
    Related Topics
  • COBCH0448 Limit exceeded - number of conditions in a SEARCH ALL > limit
    Related Topics
  • COBCH0449 Limit exceeded - number of UNSTRING delimiters > limit
  • COBCH0450 Limit exceeded - number of operands in INSPECT TALLYING/REPLACING > limit
    Related Topics
  • COBCH0451 Limit exceeded - length of SORT/MERGE keys > limit characters
    Related Topics
  • COBCH0452 Limit exceeded - number of PROCEDURE DIVISION USING parameters > limit
    Related Topics
  • COBCH0453 Limit exceeded - number of ENTRY USING parameters > limit
    Related Topics
  • COBCH0460 Previous item crosses 64K boundary. Segment checking code produced
Parent topic: Messages COBCH0401 to COBCH0500


COBCH0441 Limit exceeded - number of PERFORMs > limit

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0442 Limit exceeded - OCCURS nesting > limit

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0443 Limit exceeded - number of GO TO DEPENDING ON names > limit

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0444 Limit exceeded - number of IF nesting levels > limit

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0445 Limit exceeded - number of CALL parameters > limit

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0446 Limit exceeded - number of SORT/MERGE input files > limit

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0447 Limit exceeded - number of SORT/MERGE keys > limit

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0448 Limit exceeded - number of conditions in a SEARCH ALL > limit

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0449 Limit exceeded - number of UNSTRING delimiters > limit

Parent topic: COBCH0441 - COBCH0460


COBCH0450 Limit exceeded - number of operands in INSPECT TALLYING/REPLACING > limit

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0451 Limit exceeded - length of SORT/MERGE keys > limit characters

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0452 Limit exceeded - number of PROCEDURE DIVISION USING parameters > limit

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0453 Limit exceeded - number of ENTRY USING parameters > limit

Related Topics
Parent topic: COBCH0441 - COBCH0460


COBCH0460 Previous item crosses 64K boundary. Segment checking code produced

Parent topic: COBCH0441 - COBCH0460


COBCH0461 - COBCH0480

Lists the Syntax Checking error messages from COBCH0461 through COBCH0480.

  • COBCH0461 Table crosses 64K boundary. Segment checking code produced
  • COBCH0463 Parameter to call-by-number routine not contained in first 64K of WS
  • COBCH0465 File Section exceeds 64K. Recompile with CALLFH directive
  • COBCH0466 KEY-YY not supported; assumed KEY
    The Siemens BS2000 SORT statement allows the use of KEY-YY. This compiler has accepted the syntax but will most likely produce invalid results.
  • COBCH0467 Overlapping data-items
  • COBCH0468 No valid data for xml generation
  • COBCH0469 %1_s must be a NATIONAL data-item
  • COBCH0470 No next sentence found for NEXT SENTENCE statement_
  • COBCH0471 ASSIGN name %1_s in THREAD-LOCAL, but no THREAD-LOCAL clause on FD
  • COBCH0472 No CICS directives have been set
  • COBCH0473 SORT key not within the first %1_s bytes of the file record_
  • COBCH0474 A duplicate "RECORD" clause was found in an "FD" or "SD" entry_
  • COBCH0475 A FUNCTION cannot be the subject of an INSPECT REPLACING statement
  • COBCH0476 No IMS directives have been set
    The source contains EXEC DLI statements, but the EXECDLI Compiler directive has not been specified.
Parent topic: Messages COBCH0401 to COBCH0500


COBCH0461 Table crosses 64K boundary. Segment checking code produced

Parent topic: COBCH0461 - COBCH0480


COBCH0463 Parameter to call-by-number routine not contained in first 64K of WS

Parent topic: COBCH0461 - COBCH0480


COBCH0465 File Section exceeds 64K. Recompile with CALLFH directive

Parent topic: COBCH0461 - COBCH0480


COBCH0466 KEY-YY not supported; assumed KEY

The Siemens BS2000 SORT statement allows the use of KEY-YY. This compiler has accepted the syntax but will most likely produce invalid results.
Parent topic: COBCH0461 - COBCH0480


COBCH0467 Overlapping data-items

Parent topic: COBCH0461 - COBCH0480


COBCH0468 No valid data for xml generation

Parent topic: COBCH0461 - COBCH0480


COBCH0469 %1_s must be a NATIONAL data-item

Parent topic: COBCH0461 - COBCH0480


COBCH0470 No next sentence found for NEXT SENTENCE statement_

Parent topic: COBCH0461 - COBCH0480


COBCH0471 ASSIGN name %1_s in THREAD-LOCAL, but no THREAD-LOCAL clause on FD

Parent topic: COBCH0461 - COBCH0480


COBCH0472 No CICS directives have been set

Parent topic: COBCH0461 - COBCH0480


COBCH0473 SORT key not within the first %1_s bytes of the file record_

Parent topic: COBCH0461 - COBCH0480


COBCH0474 A duplicate "RECORD" clause was found in an "FD" or "SD" entry_

Parent topic: COBCH0461 - COBCH0480


COBCH0475 A FUNCTION cannot be the subject of an INSPECT REPLACING statement

Parent topic: COBCH0461 - COBCH0480


COBCH0476 No IMS directives have been set

The source contains EXEC DLI statements, but the EXECDLI Compiler directive has not been specified.

Set the EXECDLI Compiler directive in your source code.

Parent topic: COBCH0461 - COBCH0480


COBCH0481 - COBCH0500

Lists the Syntax Checking error messages from COBCH0481 through COBCH0500.

  • COBCH0498 Procedure name %1_s undeclared, line %2_s
  • COBCH0499 DISPLAY ALL figurative constant syntax used
    You have used the syntax DISPLAY ALL figurative constant which is not conformant with your selected flagging dialect.
  • COBCH0500 DISPLAY ALL literal syntax used
    You have used the syntax DISPLAY ALL literal which is not conformant with your selected flagging dialect.
Parent topic: Messages COBCH0401 to COBCH0500


COBCH0498 Procedure name %1_s undeclared, line %2_s

Parent topic: COBCH0481 - COBCH0500


COBCH0499 DISPLAY ALL figurative constant syntax used

You have used the syntax DISPLAY ALL figurative constant which is not conformant with your selected flagging dialect.
Parent topic: COBCH0481 - COBCH0500


COBCH0500 DISPLAY ALL literal syntax used

You have used the syntax DISPLAY ALL literal which is not conformant with your selected flagging dialect.
Parent topic: COBCH0481 - COBCH0500


Messages COBCH0501 to COBCH0600

  • COBCH0501 - COBCH0520
    Lists the Syntax Checking error messages from COBCH0501 through COBCH0520.
  • COBCH0521 - COBCH0540
    Lists the Syntax Checking error messages from COBCH0521 through COBCH0540.
  • COBCH0541 - COBCH0560
    Lists the Syntax Checking error messages from COBCH0541 through COBCH0560.
  • COBCH0561 - COBCH0580
    Lists the Syntax Checking error messages from COBCH0561 through COBCH0580.
  • COBCH0581 - COBCH0600
    Lists the Syntax Checking error messages from COBCH0581 through COBCH0600.
Parent topic: Syntax Checking Error Messages


COBCH0501 - COBCH0520

Lists the Syntax Checking error messages from COBCH0501 through COBCH0520.

  • COBCH0501 Feature is part of an optional module - module-name
  • COBCH0502 This entire section is part of an optional module - module-name
  • COBCH0503 USAGE COMP used at other than 01 level
    Related Topics
  • COBCH0504 ORGANIZATION clause in SELECT statement of sort file
    Related Topics
  • COBCH0505 VALUE OF clause in SD or CD
    Related Topics
  • COBCH0506 REDEFINES does not immediately follow data-name
    The REDEFINES clause does not immediately follow data-name in your program.
  • COBCH0507 Numeric literal VALUE on edited item
    Related Topics
  • COBCH0508 NEXT used in READ of sequential file
    Related Topics
  • COBCH0509 SET operation on non-index data item
    Related Topics
  • COBCH0510 ZEROS or ZEROES in BLANK WHEN clause. Treated as ZERO
    Related Topics
  • COBCH0511 FILE STATUS data-name is not alphanumeric
    You have specified a nonalphanumeric data item in your FILE STATUS.
  • COBCH0512 Data-name is qualified
  • COBCH0513 Flag refers to entire section
  • COBCH0514 "CHANGED" and/or "NAMED" missing
    You have omitted at least one of CHANGED or NAMED.
  • COBCH0515 Phrases repeated
  • COBCH0516 Only 1 file specified in SAME AREA clause
    Related Topics
  • COBCH0517 Jump out of inline PERFORM
    Related Topics
  • COBCH0518 > or < followed by THAN or THEN, or = followed by TO
    You have included the noise words THAN and TO unnecessarily in your code.
  • COBCH0519 More than 5 levels of qualification
  • COBCH0520 "INVALID KEY" phrase used with sequential file
    Related Topics
Parent topic: Messages COBCH0501 to COBCH0600


COBCH0501 Feature is part of an optional module - module-name

Parent topic: COBCH0501 - COBCH0520


COBCH0502 This entire section is part of an optional module - module-name

Parent topic: COBCH0501 - COBCH0520


COBCH0503 USAGE COMP used at other than 01 level

Related Topics
Parent topic: COBCH0501 - COBCH0520


COBCH0504 ORGANIZATION clause in SELECT statement of sort file

Related Topics
Parent topic: COBCH0501 - COBCH0520


COBCH0505 VALUE OF clause in SD or CD

Related Topics
Parent topic: COBCH0501 - COBCH0520


COBCH0506 REDEFINES does not immediately follow data-name

The REDEFINES clause does not immediately follow data-name in your program.

Resolution:

Revise your program so that REDEFINES immediately follows data-name.

Parent topic: COBCH0501 - COBCH0520


COBCH0507 Numeric literal VALUE on edited item

Related Topics
Parent topic: COBCH0501 - COBCH0520


COBCH0508 NEXT used in READ of sequential file

Related Topics
Parent topic: COBCH0501 - COBCH0520


COBCH0509 SET operation on non-index data item

Related Topics
Parent topic: COBCH0501 - COBCH0520


COBCH0510 ZEROS or ZEROES in BLANK WHEN clause. Treated as ZERO

Related Topics
Parent topic: COBCH0501 - COBCH0520


COBCH0511 FILE STATUS data-name is not alphanumeric

You have specified a nonalphanumeric data item in your FILE STATUS.

Resolution:

Amend your code to make the data item alphanumeric.

Parent topic: COBCH0501 - COBCH0520


COBCH0512 Data-name is qualified

Parent topic: COBCH0501 - COBCH0520


COBCH0513 Flag refers to entire section

Parent topic: COBCH0501 - COBCH0520


COBCH0514 "CHANGED" and/or "NAMED" missing

You have omitted at least one of CHANGED or NAMED.

Resolution:

Add CHANGED and/or NAMED to your program.

Parent topic: COBCH0501 - COBCH0520


COBCH0515 Phrases repeated

Parent topic: COBCH0501 - COBCH0520


COBCH0516 Only 1 file specified in SAME AREA clause

Related Topics
Parent topic: COBCH0501 - COBCH0520


COBCH0517 Jump out of inline PERFORM

Related Topics
Parent topic: COBCH0501 - COBCH0520


COBCH0518 > or < followed by THAN or THEN, or = followed by TO

You have included the noise words THAN and TO unnecessarily in your code.

Resolution:

Delete these words.

Parent topic: COBCH0501 - COBCH0520


COBCH0519 More than 5 levels of qualification

Parent topic: COBCH0501 - COBCH0520


COBCH0520 "INVALID KEY" phrase used with sequential file

Related Topics
Parent topic: COBCH0501 - COBCH0520


COBCH0521 - COBCH0540

Lists the Syntax Checking error messages from COBCH0521 through COBCH0540.

  • COBCH0521 USING literal/LENGTH OF identifier. (BY CONTENT implied for this item)
    Related Topics
  • COBCH0522 BY CONTENT literal/LENGTH OF identifier
    Related Topics
  • COBCH0523 Declarative Section without USE statement
    Related Topics
  • COBCH0524 ALPHABET IS ASCII
    Related Topics
  • COBCH0525 EOP or END-OF-PAGE used on file which has no LINAGE
    You have specified EOP, which is invalid for a file which has no LINAGE.
  • COBCH0526 Phrases are not in the correct order
  • COBCH0527 REDEFINES at 01 in File Section
    Related Topics
  • COBCH0528 Data-name data-name in ASC/DESC key clause is not uniquely identified
    Related Topics
  • COBCH0529 Clause treated as documentary
  • COBCH0530 Data item used as index file key is not alphanumeric
    The data item you have specified as an index file key is not alphanumeric.
  • COBCH0531 Too many subscripts
  • COBCH0532 INTO data-name is group item
    Related Topics
  • COBCH0533 START ... LESS/NOT GREATER THAN ...
    Related Topics
  • COBCH0534 Entry treated as documentary
  • COBCH0535 ALPHABET is EBCDIC
  • COBCH0536 CICS LINKAGE items generated
  • COBCH0537 BASIS mechanism (BASIS, DELETE or INSERT)
    Related Topics
  • COBCH0538 Picture string is continued
    Related Topics
  • COBCH0539 This item is obsolete in 1985 standard
    The syntax you have used is not supported under ANSI'85.
  • COBCH0540 Source field is edited
Parent topic: Messages COBCH0501 to COBCH0600


COBCH0521 USING literal/LENGTH OF identifier. (BY CONTENT implied for this item)

Related Topics
Parent topic: COBCH0521 - COBCH0540


COBCH0522 BY CONTENT literal/LENGTH OF identifier

Related Topics
Parent topic: COBCH0521 - COBCH0540


COBCH0523 Declarative Section without USE statement

Related Topics
Parent topic: COBCH0521 - COBCH0540


COBCH0524 ALPHABET IS ASCII

Related Topics
Parent topic: COBCH0521 - COBCH0540


COBCH0525 EOP or END-OF-PAGE used on file which has no LINAGE

You have specified EOP, which is invalid for a file which has no LINAGE.

Resolution:

Delete EOP.

Parent topic: COBCH0521 - COBCH0540


COBCH0526 Phrases are not in the correct order

Parent topic: COBCH0521 - COBCH0540


COBCH0527 REDEFINES at 01 in File Section

Related Topics
Parent topic: COBCH0521 - COBCH0540


COBCH0528 Data-name data-name in ASC/DESC key clause is not uniquely identified

Related Topics
Parent topic: COBCH0521 - COBCH0540


COBCH0529 Clause treated as documentary

Parent topic: COBCH0521 - COBCH0540


COBCH0530 Data item used as index file key is not alphanumeric

The data item you have specified as an index file key is not alphanumeric.

Resolution:

Revise your code to make the data item alphanumeric.

Parent topic: COBCH0521 - COBCH0540


COBCH0531 Too many subscripts

Parent topic: COBCH0521 - COBCH0540


COBCH0532 INTO data-name is group item

Related Topics
Parent topic: COBCH0521 - COBCH0540


COBCH0533 START ... LESS/NOT GREATER THAN ...

Related Topics
Parent topic: COBCH0521 - COBCH0540


COBCH0534 Entry treated as documentary

Parent topic: COBCH0521 - COBCH0540


COBCH0535 ALPHABET is EBCDIC

Parent topic: COBCH0521 - COBCH0540


COBCH0536 CICS LINKAGE items generated

Parent topic: COBCH0521 - COBCH0540


COBCH0537 BASIS mechanism (BASIS, DELETE or INSERT)

Related Topics
Parent topic: COBCH0521 - COBCH0540


COBCH0538 Picture string is continued

Related Topics
Parent topic: COBCH0521 - COBCH0540


COBCH0539 This item is obsolete in 1985 standard

The syntax you have used is not supported under ANSI'85.

Resolution:

Delete this syntax.

Parent topic: COBCH0521 - COBCH0540


COBCH0540 Source field is edited

Parent topic: COBCH0521 - COBCH0540


COBCH0541 - COBCH0560

Lists the Syntax Checking error messages from COBCH0541 through COBCH0560.

  • COBCH0541 Comparison between edited field and COMP field
    Related Topics
  • COBCH0542 VALUE clause on group COMP
    Related Topics
  • COBCH0543 VALUE clause on variable length group
    Related Topics
  • COBCH0544 VALUE clause with OCCURS or subsidiary to group OCCURS
    Related Topics
  • COBCH0545 ALTERNATE RECORD KEY is not in SAA
    Related Topics
  • COBCH0546 PICTURE symbol P not allowed in RELATIVE KEY
    You have included the PICTURE symbol P in a Relative Key.
  • COBCH0547 END-IF used with NEXT SENTENCE
    Related Topics
  • COBCH0548 Program is nested
  • COBCH0549 USING identifier must not be a redefinition
    Related Topics
  • COBCH0550 Pseudo-text consists entirely of a separator comma or semicolon
  • COBCH0551 Second status field does not comply with VSC2_BS2000 specifications
  • COBCH0552 Comment lines precede IDENTIFICATION DIVISION
  • COBCH0553 syntax : non-conforming standard ANS85
    The language element is part of the ANSI'85 standard but above the flagging level selected.
  • COBCH0554 Syntax is non-conforming non-standard ANS85
    The language element is not part of the ANSI'85 standard. It is an OS/VS COBOL, VS COBOL II, Micro Focus, or other extension.
  • COBCH0555 syntax : marked as obsolete in the ANS85 standard
    The ANSI'85 standard has defined this language element as obsolete. It will be removed from the next ANSI standard.
  • COBCH0556 Multiple program source
    Source file contains more than one source program. In this situation, more than one separate, not nested, program exists.
  • COBCH0557 Multiple GIVING files
    A SORT or MERGE statement contains multiple files in the GIVING clause.
  • COBCH0558 Comparison between index-name and arithmetic expression
  • COBCH0559 Statement cannot be reached
  • COBCH0560 Alphabet declared without ALPHABET keyword
Parent topic: Messages COBCH0501 to COBCH0600


COBCH0541 Comparison between edited field and COMP field

Related Topics
Parent topic: COBCH0541 - COBCH0560


COBCH0542 VALUE clause on group COMP

Related Topics
Parent topic: COBCH0541 - COBCH0560


COBCH0543 VALUE clause on variable length group

Related Topics
Parent topic: COBCH0541 - COBCH0560


COBCH0544 VALUE clause with OCCURS or subsidiary to group OCCURS

Related Topics
Parent topic: COBCH0541 - COBCH0560


COBCH0545 ALTERNATE RECORD KEY is not in SAA

Related Topics
Parent topic: COBCH0541 - COBCH0560


COBCH0546 PICTURE symbol P not allowed in RELATIVE KEY

You have included the PICTURE symbol P in a Relative Key.

Resolution:

Delete P.

Parent topic: COBCH0541 - COBCH0560


COBCH0547 END-IF used with NEXT SENTENCE

Related Topics
Parent topic: COBCH0541 - COBCH0560


COBCH0548 Program is nested

Parent topic: COBCH0541 - COBCH0560


COBCH0549 USING identifier must not be a redefinition

Related Topics
Parent topic: COBCH0541 - COBCH0560


COBCH0550 Pseudo-text consists entirely of a separator comma or semicolon

Parent topic: COBCH0541 - COBCH0560


COBCH0551 Second status field does not comply with VSC2_BS2000 specifications

Parent topic: COBCH0541 - COBCH0560


COBCH0552 Comment lines precede IDENTIFICATION DIVISION

Parent topic: COBCH0541 - COBCH0560


COBCH0553 syntax : non-conforming standard ANS85

The language element is part of the ANSI'85 standard but above the flagging level selected.
Parent topic: COBCH0541 - COBCH0560


COBCH0554 Syntax is non-conforming non-standard ANS85

The language element is not part of the ANSI'85 standard. It is an OS/VS COBOL, VS COBOL II, Micro Focus, or other extension.
Parent topic: COBCH0541 - COBCH0560


COBCH0555 syntax : marked as obsolete in the ANS85 standard

The ANSI'85 standard has defined this language element as obsolete. It will be removed from the next ANSI standard.

Resolution:

Delete this syntax.

Parent topic: COBCH0541 - COBCH0560


COBCH0556 Multiple program source

Source file contains more than one source program. In this situation, more than one separate, not nested, program exists.
Parent topic: COBCH0541 - COBCH0560


COBCH0557 Multiple GIVING files

A SORT or MERGE statement contains multiple files in the GIVING clause.
Parent topic: COBCH0541 - COBCH0560


COBCH0558 Comparison between index-name and arithmetic expression

Parent topic: COBCH0541 - COBCH0560


COBCH0559 Statement cannot be reached

Parent topic: COBCH0541 - COBCH0560


COBCH0560 Alphabet declared without ALPHABET keyword

Parent topic: COBCH0541 - COBCH0560


COBCH0561 - COBCH0580

Lists the Syntax Checking error messages from COBCH0561 through COBCH0580.

  • COBCH0561 A "NOT" phrase did not have a matching verb and was discarded
    You declared a NOT phrase but failed to declare a matching verb.
  • COBCH0562 An "ELSE" phrase did not have a matching IF and was discarded
    You declared an ELSE phrase but failed to declare a matching IF.
  • COBCH0563 A "WHEN" phrase did not have a matching verb and was discarded
    You declared a WHEN phrase but failed to declare a matching verb.
  • COBCH0564 A scope-delimiter did not have a matching verb and was discarded
    You declared a scope-delimiter but failed to declare a matching verb.
  • COBCH0565 RECORDING MODE used with INDEXED or RELATIVE file
    Related Topics
  • COBCH0566 This release does not support floating point in this context
  • COBCH0567 USAGE DISPLAY-1 missing
    You have omitted the words USAGE DISPLAY-1.
  • COBCH0568 Sign condition in EVALUATE statement
    Related Topics
  • COBCH0569 Data item does not have fixed location
  • COBCH0570 Insufficient space in area B for SO/SI insertion
    You do not have sufficient space in area B for SO/SI characters to be inserted for the DBCS items. If the source program is ported to an environment requiring SO/SI characters the source line might become corrupted.
  • COBCH0571 Mixed literal is continued
    Related Topics
  • COBCH0572 INITIALIZE operand does not have fixed location
    Related Topics
  • COBCH0573 More than one REPLACING phrase
    Related Topics
  • COBCH0574 Conditional statement not terminated by its scope-delimiter
    Related Topics
  • COBCH0575 Zero suppression follows floating insertion
  • COBCH0576 Preceding statement is not imperative
  • COBCH0577 Group level USAGE does not match PICTURE type - USAGE ignored
    You have declared a PICTURE clause but the group USAGE does not match this type.
  • COBCH0578 PROGRAM-ID specified as literal
    Related Topics
  • COBCH0579 PROGRAM-ID is DBCS name
    Related Topics
  • COBCH0580 User-defined word as DBCS name
Parent topic: Messages COBCH0501 to COBCH0600


COBCH0561 A "NOT" phrase did not have a matching verb and was discarded

You declared a NOT phrase but failed to declare a matching verb.

Resolution:

Add the appropriate verb.

Parent topic: COBCH0561 - COBCH0580


COBCH0562 An "ELSE" phrase did not have a matching IF and was discarded

You declared an ELSE phrase but failed to declare a matching IF.

Resolution:

Resolve the mismatch between the conditional verbs.

Parent topic: COBCH0561 - COBCH0580


COBCH0563 A "WHEN" phrase did not have a matching verb and was discarded

You declared a WHEN phrase but failed to declare a matching verb.

Resolution:

Add the appropriate verb.

Parent topic: COBCH0561 - COBCH0580


COBCH0564 A scope-delimiter did not have a matching verb and was discarded

You declared a scope-delimiter but failed to declare a matching verb.

Resolution:

Resolve the mismatch between the conditional verbs.

Parent topic: COBCH0561 - COBCH0580


COBCH0565 RECORDING MODE used with INDEXED or RELATIVE file

Related Topics
Parent topic: COBCH0561 - COBCH0580


COBCH0566 This release does not support floating point in this context

Parent topic: COBCH0561 - COBCH0580


COBCH0567 USAGE DISPLAY-1 missing

You have omitted the words USAGE DISPLAY-1.

Resolution:

Add USAGE DISPLAY-1.

Parent topic: COBCH0561 - COBCH0580


COBCH0568 Sign condition in EVALUATE statement

Related Topics
Parent topic: COBCH0561 - COBCH0580


COBCH0569 Data item does not have fixed location

Parent topic: COBCH0561 - COBCH0580


COBCH0570 Insufficient space in area B for SO/SI insertion

You do not have sufficient space in area B for SO/SI characters to be inserted for the DBCS items. If the source program is ported to an environment requiring SO/SI characters the source line might become corrupted.
Parent topic: COBCH0561 - COBCH0580


COBCH0571 Mixed literal is continued

Related Topics
Parent topic: COBCH0561 - COBCH0580


COBCH0572 INITIALIZE operand does not have fixed location

Related Topics
Parent topic: COBCH0561 - COBCH0580


COBCH0573 More than one REPLACING phrase

Related Topics
Parent topic: COBCH0561 - COBCH0580


COBCH0574 Conditional statement not terminated by its scope-delimiter

Related Topics
Parent topic: COBCH0561 - COBCH0580


COBCH0575 Zero suppression follows floating insertion

Parent topic: COBCH0561 - COBCH0580


COBCH0576 Preceding statement is not imperative

Parent topic: COBCH0561 - COBCH0580


COBCH0577 Group level USAGE does not match PICTURE type - USAGE ignored

You have declared a PICTURE clause but the group USAGE does not match this type.

Resolution:

Either delete the USAGE clause or change the PICTURE clause.

Parent topic: COBCH0561 - COBCH0580


COBCH0578 PROGRAM-ID specified as literal

Related Topics
Parent topic: COBCH0561 - COBCH0580


COBCH0579 PROGRAM-ID is DBCS name

Related Topics
Parent topic: COBCH0561 - COBCH0580


COBCH0580 User-defined word as DBCS name

Parent topic: COBCH0561 - COBCH0580


COBCH0581 - COBCH0600

Lists the Syntax Checking error messages from COBCH0581 through COBCH0600.

  • COBCH0581 END-SEARCH used with NEXT SENTENCE
    Related Topics
  • COBCH0582 Redefined item has OCCURS phrase
    Related Topics
  • COBCH0583 EXIT PROGRAM in GLOBAL declarative
    Related Topics
  • COBCH0584 Inline PERFORM statement not terminated by END-PERFORM
    Related Topics
  • COBCH0585 Imperative statement missing
    You have failed to specify an imperative statement.
  • COBCH0586 Smallest record size size1 > minimum in RECORD clause size2
    You have specified a minimum size for your record definitions, but none of the records you have defined is that small.
  • COBCH0587 Largest record size size1 < maximum in RECORD clause size2
    You have specified a maximum size for your record definitions, but none of the records you have defined is that large.
  • COBCH0588 Operand does not have USAGE DISPLAY
    Related Topics
  • COBCH0589 Procedure Division does not finish with complete sentence
    Related Topics
  • COBCH0590 USING/GIVING file does not have ORGANIZATION SEQUENTIAL
    Related Topics
  • COBCH0591 USING/GIVING file has ACCESS RANDOM
    Related Topics
  • COBCH0592 USING/GIVING file has ACCESS DYNAMIC
    Related Topics
  • COBCH0593 Sequence number contains nonnumeric characters
  • COBCH0594 Variable length group is operand of INITIALIZE statement
    Related Topics
  • COBCH0595 SORT file has FILE STATUS clause
    Related Topics
  • COBCH0596 01 level record in Report Section is elementary
  • COBCH0597 Object of SUM clause belongs to different report
    Related Topics
  • COBCH0598 Assignment-name is alphanumeric literal
  • COBCH0599 Literal form of CODE phrase
    Related Topics
  • COBCH0600 Name is implicitly qualified
Parent topic: Messages COBCH0501 to COBCH0600


COBCH0581 END-SEARCH used with NEXT SENTENCE

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0582 Redefined item has OCCURS phrase

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0583 EXIT PROGRAM in GLOBAL declarative

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0584 Inline PERFORM statement not terminated by END-PERFORM

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0585 Imperative statement missing

You have failed to specify an imperative statement.

Resolution:

Include an imperative statement.

Parent topic: COBCH0581 - COBCH0600


COBCH0586 Smallest record size size1 > minimum in RECORD clause size2

You have specified a minimum size for your record definitions, but none of the records you have defined is that small.

Resolution:

Revise your code so that the minimum size specified is equal to your smallest data record.

Parent topic: COBCH0581 - COBCH0600


COBCH0587 Largest record size size1 < maximum in RECORD clause size2

You have specified a maximum size for your record definitions, but none of the records you have defined is that large.

Resolution:

Revise your code so that the maximum size specified is equal to your largest data record.

Parent topic: COBCH0581 - COBCH0600


COBCH0588 Operand does not have USAGE DISPLAY

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0589 Procedure Division does not finish with complete sentence

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0590 USING/GIVING file does not have ORGANIZATION SEQUENTIAL

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0591 USING/GIVING file has ACCESS RANDOM

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0592 USING/GIVING file has ACCESS DYNAMIC

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0593 Sequence number contains nonnumeric characters

Parent topic: COBCH0581 - COBCH0600


COBCH0594 Variable length group is operand of INITIALIZE statement

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0595 SORT file has FILE STATUS clause

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0596 01 level record in Report Section is elementary

Parent topic: COBCH0581 - COBCH0600


COBCH0597 Object of SUM clause belongs to different report

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0598 Assignment-name is alphanumeric literal

Parent topic: COBCH0581 - COBCH0600


COBCH0599 Literal form of CODE phrase

Related Topics
Parent topic: COBCH0581 - COBCH0600


COBCH0600 Name is implicitly qualified

Parent topic: COBCH0581 - COBCH0600


Messages COBCH0601 to COBCH0700

  • COBCH0601 - COBCH0620
    Lists the Syntax Checking error messages from COBCH0601 through COBCH0620.
  • COBCH0621 - COBCH0640
    Lists the Syntax Checking error messages from COBCH0621 through COBCH0640.
  • COBCH0641 - COBCH0660
    Lists the Syntax Checking error messages from COBCH0641 through COBCH0660.
  • COBCH0661 - COBCH0680
    Lists the Syntax Checking error messages from COBCH0661 through COBCH0680.
  • COBCH0681 - COBCH0700
    Lists the Syntax Checking error messages from COBCH0681 through COBCH0700.
Parent topic: Syntax Checking Error Messages


COBCH0601 - COBCH0620

Lists the Syntax Checking error messages from COBCH0601 through COBCH0620.

  • COBCH0601 USE BEFORE REPORTING on DETAIL group
    Related Topics
  • COBCH0602 Neither LINE nor LINES specified
    Related Topics
  • COBCH0603 SIGN phrase in Report Section
    Related Topics
  • COBCH0604 GLOBAL specified for entry without data-name
    Related Topics
  • COBCH0605 More than one SUM for single item
    Related Topics
  • COBCH0606 Program does not contain Procedure Division
    Related Topics
  • COBCH0607 PROCEDURE DIVISION header missing
    Related Topics
  • COBCH0608 Pseudo-text delimiter preceded / followed by illegal character
    The pseudo text delimiters used in COPY ... REPLACING and REPLACE must be preceded by a space and followed by a separator. The system assumes one was present.
  • COBCH0609 Apostrophe found with QUOTE directive (future occurrences not flagged)
    Related Topics
  • COBCH0610 Quote found with APOST directive (future occurrences not flagged)
  • COBCH0611 Line: line-no Column: column-no
  • COBCH0612 EXIT PROGRAM not in separate paragraph
    Related Topics
  • COBCH0613 Invalid program name
  • COBCH0614 Previous LINE clause specified same number
    Related Topics
  • COBCH0615 Floating point data item
  • COBCH0616 This EXIT statement format is an MF extension
  • COBCH0617 Data item is defined at level 66
  • COBCH0618 Data item is not declared in Linkage Section
  • COBCH0619 User-name mixes single-byte and double-byte characters
  • COBCH0620 DBCS user-name exceeds 14 characters in length
Parent topic: Messages COBCH0601 to COBCH0700


COBCH0601 USE BEFORE REPORTING on DETAIL group

Related Topics
Parent topic: COBCH0601 - COBCH0620


COBCH0602 Neither LINE nor LINES specified

Related Topics
Parent topic: COBCH0601 - COBCH0620


COBCH0603 SIGN phrase in Report Section

Related Topics
Parent topic: COBCH0601 - COBCH0620


COBCH0604 GLOBAL specified for entry without data-name

Related Topics
Parent topic: COBCH0601 - COBCH0620


COBCH0605 More than one SUM for single item

Related Topics
Parent topic: COBCH0601 - COBCH0620


COBCH0606 Program does not contain Procedure Division

Related Topics
Parent topic: COBCH0601 - COBCH0620


COBCH0607 PROCEDURE DIVISION header missing

Related Topics
Parent topic: COBCH0601 - COBCH0620


COBCH0608 Pseudo-text delimiter preceded / followed by illegal character

The pseudo text delimiters used in COPY ... REPLACING and REPLACE must be preceded by a space and followed by a separator. The system assumes one was present.
Parent topic: COBCH0601 - COBCH0620


COBCH0609 Apostrophe found with QUOTE directive (future occurrences not flagged)

Related Topics
Parent topic: COBCH0601 - COBCH0620


COBCH0610 Quote found with APOST directive (future occurrences not flagged)

Parent topic: COBCH0601 - COBCH0620


COBCH0611 Line: line-no Column: column-no

Parent topic: COBCH0601 - COBCH0620


COBCH0612 EXIT PROGRAM not in separate paragraph

Related Topics
Parent topic: COBCH0601 - COBCH0620


COBCH0613 Invalid program name

Parent topic: COBCH0601 - COBCH0620


COBCH0614 Previous LINE clause specified same number

Related Topics
Parent topic: COBCH0601 - COBCH0620


COBCH0615 Floating point data item

Parent topic: COBCH0601 - COBCH0620


COBCH0616 This EXIT statement format is an MF extension

Parent topic: COBCH0601 - COBCH0620


COBCH0617 Data item is defined at level 66

Parent topic: COBCH0601 - COBCH0620


COBCH0618 Data item is not declared in Linkage Section

Parent topic: COBCH0601 - COBCH0620


COBCH0619 User-name mixes single-byte and double-byte characters

Parent topic: COBCH0601 - COBCH0620


COBCH0620 DBCS user-name exceeds 14 characters in length

Parent topic: COBCH0601 - COBCH0620


COBCH0621 - COBCH0640

Lists the Syntax Checking error messages from COBCH0621 through COBCH0640.

  • COBCH0621 DBCS user-name begins with DBCS equivalent of SBCS "-" character
  • COBCH0622 DBCS name contains illegal character
  • COBCH0623 DBCS name contains only DBCS characters equivalent to SBCS characters
  • COBCH0624 Belongs to Linkage record not specified in PROCEDURE DIVISION header
    Related Topics
  • COBCH0625 Alphabetic edited item treated as alphabetic
  • COBCH0626 Edited field not allowed
  • COBCH0627 Section header not followed by paragraph name or other Section header
  • COBCH0628 Use of symbolic literal defined in level 78 or CONSTANT directive
    Related Topics
  • COBCH0629 Use of signed or non-integer numeric literal
  • COBCH0630 INTO not legal for this file
    Related Topics
  • COBCH0631 GLOBAL specified in Linkage Section
    Related Topics
  • COBCH0632 A FUNCTION cannot be a receiving item
    Related Topics
  • COBCH0633 REPORT HEADING extends beyond first detail_ NEXT GROUP NEXT PAGE assumed_
  • COBCH0634 Feature not supported in selected dialect
  • COBCH0635 VALUE specified for external floating point data item
    Related Topics
  • COBCH0636 Level 88 defined on external floating point data item
  • COBCH0637 ACCEPT references internal floating point data item
    Related Topics
  • COBCH0638 Floating point data illegal in DIVIDE with REMAINDER clause
    Related Topics
  • COBCH0639 Reserved word OR missing
    Related Topics
  • COBCH0640 Floating point data item used in SEARCH ALL statement
    Related Topics
Parent topic: Messages COBCH0601 to COBCH0700


COBCH0621 DBCS user-name begins with DBCS equivalent of SBCS "-" character

Parent topic: COBCH0621 - COBCH0640


COBCH0622 DBCS name contains illegal character

Parent topic: COBCH0621 - COBCH0640


COBCH0623 DBCS name contains only DBCS characters equivalent to SBCS characters

Parent topic: COBCH0621 - COBCH0640


COBCH0624 Belongs to Linkage record not specified in PROCEDURE DIVISION header

Related Topics
Parent topic: COBCH0621 - COBCH0640


COBCH0625 Alphabetic edited item treated as alphabetic

Parent topic: COBCH0621 - COBCH0640


COBCH0626 Edited field not allowed

Parent topic: COBCH0621 - COBCH0640


COBCH0627 Section header not followed by paragraph name or other Section header

Parent topic: COBCH0621 - COBCH0640


COBCH0628 Use of symbolic literal defined in level 78 or CONSTANT directive

Related Topics
Parent topic: COBCH0621 - COBCH0640


COBCH0629 Use of signed or non-integer numeric literal

Parent topic: COBCH0621 - COBCH0640


COBCH0630 INTO not legal for this file

Related Topics
Parent topic: COBCH0621 - COBCH0640


COBCH0631 GLOBAL specified in Linkage Section

Related Topics
Parent topic: COBCH0621 - COBCH0640


COBCH0632 A FUNCTION cannot be a receiving item

Related Topics
Parent topic: COBCH0621 - COBCH0640


COBCH0633 REPORT HEADING extends beyond first detail_ NEXT GROUP NEXT PAGE assumed_

Parent topic: COBCH0621 - COBCH0640


COBCH0634 Feature not supported in selected dialect

Parent topic: COBCH0621 - COBCH0640


COBCH0635 VALUE specified for external floating point data item

Related Topics
Parent topic: COBCH0621 - COBCH0640


COBCH0636 Level 88 defined on external floating point data item

Parent topic: COBCH0621 - COBCH0640


COBCH0637 ACCEPT references internal floating point data item

Related Topics
Parent topic: COBCH0621 - COBCH0640


COBCH0638 Floating point data illegal in DIVIDE with REMAINDER clause

Related Topics
Parent topic: COBCH0621 - COBCH0640


COBCH0639 Reserved word OR missing

Related Topics
Parent topic: COBCH0621 - COBCH0640


COBCH0640 Floating point data item used in SEARCH ALL statement

Related Topics
Parent topic: COBCH0621 - COBCH0640


COBCH0641 - COBCH0660

Lists the Syntax Checking error messages from COBCH0641 through COBCH0660.

  • COBCH0641 '_' missing following procedure name declaration, or unrecognized verb
  • COBCH0642 Source and target start at same location
  • COBCH0643 Source and target overlap, and source is at a higher address than target
    If the source and target items in a move overlap, the result of the move is undefined.
  • COBCH0644 Significand has more than 16 numeric positions
  • COBCH0645 Floating-point value out of range
  • COBCH0647 CURSOR/CRT STATUS data item may not be in LOCAL-STORAGE/LINKAGE
    Related Topics
  • COBCH0648 Illegal use of Local-Storage item
  • COBCH0649 Record length exceeds system limit
  • COBCH0650 No matching $IF - ignored
    A $END or $ELSE conditional compilation statement has been found without a preceding $IF. The line was ignored.
  • COBCH0651 SORT key cannot have, or be subsidiary to item with, OCCURS clause
    Related Topics
  • COBCH0652 BY CONTENT numeric literal
    You have specified a numeric literal as a BY CONTENT parameter on a CALL/ CHAIN/ INVOKE statement which is not supported under your selected dialect.
  • COBCH0654 NEXT GROUP specified for group with no LINE NUMBER clause
    Related Topics
  • COBCH0655 NEXT GROUP NEXT PAGE specified for report without PAGE description
  • COBCH0656 Source and target overlap, and source is at lower address than target
  • COBCH0657 Should be declared in Linkage Section
  • COBCH0658 NUMERIC class test on ALPHABETIC item
    Related Topics
  • COBCH0659 Screen name mandatory at 01 level in Screen Section
    Related Topics
  • COBCH0660 Positive signed integer used in relative subscripting
Parent topic: Messages COBCH0601 to COBCH0700


COBCH0641 '_' missing following procedure name declaration, or unrecognized verb

Parent topic: COBCH0641 - COBCH0660


COBCH0642 Source and target start at same location

Parent topic: COBCH0641 - COBCH0660


COBCH0643 Source and target overlap, and source is at a higher address than target

If the source and target items in a move overlap, the result of the move is undefined.
Parent topic: COBCH0641 - COBCH0660


COBCH0644 Significand has more than 16 numeric positions

Parent topic: COBCH0641 - COBCH0660


COBCH0645 Floating-point value out of range

Parent topic: COBCH0641 - COBCH0660


COBCH0647 CURSOR/CRT STATUS data item may not be in LOCAL-STORAGE/LINKAGE

Related Topics
Parent topic: COBCH0641 - COBCH0660


COBCH0648 Illegal use of Local-Storage item

Parent topic: COBCH0641 - COBCH0660


COBCH0649 Record length exceeds system limit

Parent topic: COBCH0641 - COBCH0660


COBCH0650 No matching $IF - ignored

A $END or $ELSE conditional compilation statement has been found without a preceding $IF. The line was ignored.
Parent topic: COBCH0641 - COBCH0660


COBCH0651 SORT key cannot have, or be subsidiary to item with, OCCURS clause

Related Topics
Parent topic: COBCH0641 - COBCH0660


COBCH0652 BY CONTENT numeric literal

You have specified a numeric literal as a BY CONTENT parameter on a CALL/ CHAIN/ INVOKE statement which is not supported under your selected dialect.

Resolution:

Change it to something that is not a numeric literal.

Parent topic: COBCH0641 - COBCH0660


COBCH0654 NEXT GROUP specified for group with no LINE NUMBER clause

Related Topics
Parent topic: COBCH0641 - COBCH0660


COBCH0655 NEXT GROUP NEXT PAGE specified for report without PAGE description

Parent topic: COBCH0641 - COBCH0660


COBCH0656 Source and target overlap, and source is at lower address than target

Parent topic: COBCH0641 - COBCH0660


COBCH0657 Should be declared in Linkage Section

Parent topic: COBCH0641 - COBCH0660


COBCH0658 NUMERIC class test on ALPHABETIC item

Related Topics
Parent topic: COBCH0641 - COBCH0660


COBCH0659 Screen name mandatory at 01 level in Screen Section

Related Topics
Parent topic: COBCH0641 - COBCH0660


COBCH0660 Positive signed integer used in relative subscripting

Parent topic: COBCH0641 - COBCH0660


COBCH0661 - COBCH0680

Lists the Syntax Checking error messages from COBCH0661 through COBCH0680.

  • COBCH0661 Superfluous TO found in MOVE statement. Ignored
    Related Topics
  • COBCH0662 Figurative constant or ALL not allowed here
    Related Topics
  • COBCH0663 LENGTH function in non-standard context
    Related Topics
  • COBCH0664 INPUT-OUTPUT SECTION precedes CONFIGURATION SECTION
  • COBCH0665 Communications syntax incorrect
  • COBCH0666 Reserved word used as data-name or unknown data description qualifier
  • COBCH0667 ODO object object must have fixed location
    Related Topics
  • COBCH0668 JUSTIFIED specified on edited field
    Related Topics
  • COBCH0669 EVALUATE statement using partial conditional expressions
    Related Topics
  • COBCH0670 Selection object does not correspond to selection subject
  • COBCH0671 PERFORM UNTIL EXIT
    Related Topics
  • COBCH0672 COPY nested in COPY REPLACING
    Related Topics
  • COBCH0673 Incompatible options specified
  • COBCH0674 Subscripting and indexing used for the same identifier
  • COBCH0675 Numeric FUNCTION used as source of MOVE statement
    Related Topics
  • COBCH0676 THEN used instead of THAN
    Related Topics
  • COBCH0677 Value of previous expression may not be the same under OSVS / VSC2
    The result of the arithmetic expression just evaluated under the OS/VS or VSC2 dialect could be different when evaluated on the mainframe. This warning is displayed when an intermediate result needs more than 19 digits on either side of the decimal point.
  • COBCH0678 Too many CONTROLS specified for report
  • COBCH0679 QUOTE character must be double in an N literal
    Related Topics
  • COBCH0680 N" format literal
Parent topic: Messages COBCH0601 to COBCH0700


COBCH0661 Superfluous TO found in MOVE statement. Ignored

Related Topics
Parent topic: COBCH0661 - COBCH0680


COBCH0662 Figurative constant or ALL not allowed here

Related Topics
Parent topic: COBCH0661 - COBCH0680


COBCH0663 LENGTH function in non-standard context

Related Topics
Parent topic: COBCH0661 - COBCH0680


COBCH0664 INPUT-OUTPUT SECTION precedes CONFIGURATION SECTION

Parent topic: COBCH0661 - COBCH0680


COBCH0665 Communications syntax incorrect

Parent topic: COBCH0661 - COBCH0680


COBCH0666 Reserved word used as data-name or unknown data description qualifier

Parent topic: COBCH0661 - COBCH0680


COBCH0667 ODO object object must have fixed location

Related Topics
Parent topic: COBCH0661 - COBCH0680


COBCH0668 JUSTIFIED specified on edited field

Related Topics
Parent topic: COBCH0661 - COBCH0680


COBCH0669 EVALUATE statement using partial conditional expressions

Related Topics
Parent topic: COBCH0661 - COBCH0680


COBCH0670 Selection object does not correspond to selection subject

Parent topic: COBCH0661 - COBCH0680


COBCH0671 PERFORM UNTIL EXIT

Related Topics
Parent topic: COBCH0661 - COBCH0680


COBCH0672 COPY nested in COPY REPLACING

Related Topics
Parent topic: COBCH0661 - COBCH0680


COBCH0673 Incompatible options specified

Parent topic: COBCH0661 - COBCH0680


COBCH0674 Subscripting and indexing used for the same identifier

Parent topic: COBCH0661 - COBCH0680


COBCH0675 Numeric FUNCTION used as source of MOVE statement

Related Topics
Parent topic: COBCH0661 - COBCH0680


COBCH0676 THEN used instead of THAN

Related Topics
Parent topic: COBCH0661 - COBCH0680


COBCH0677 Value of previous expression may not be the same under OSVS / VSC2

The result of the arithmetic expression just evaluated under the OS/VS or VSC2 dialect could be different when evaluated on the mainframe. This warning is displayed when an intermediate result needs more than 19 digits on either side of the decimal point.
Parent topic: COBCH0661 - COBCH0680


COBCH0678 Too many CONTROLS specified for report

Parent topic: COBCH0661 - COBCH0680


COBCH0679 QUOTE character must be double in an N literal

Related Topics
Parent topic: COBCH0661 - COBCH0680


COBCH0680 N" format literal

Parent topic: COBCH0661 - COBCH0680


COBCH0681 - COBCH0700

Lists the Syntax Checking error messages from COBCH0681 through COBCH0700.

  • COBCH0681 Function argument must be positive
  • COBCH0682 Function argument must be positive or zero
  • COBCH0683 Function argument must be nonzero
  • COBCH0684 Function argument must be between -1 and +1
  • COBCH0685 Function argument must be greater than -1
  • COBCH0686 Function argument must be between 1 and collating sequence length
  • COBCH0687 Use of PROCEDURE-POINTER data item
    Related Topics
  • COBCH0688 Use of "C" or "R" as currency sign
  • COBCH0689 Condition-name cannot be set to FALSE (no FALSE value specified)
    You have tried to set a level-88 item to FALSE without having specified the WHEN SET TO FALSE clause in the item's data description.
  • COBCH0690 Illegal use of floating-point literal
  • COBCH0691 Simple COPY and qualified COPY both used in the same program
    You have mixed two different copies of copylbr in the same program. You must not use COPY statements if some have qualification and some have not.
  • COBCH0692 REPORT specified in more than two FDs
  • COBCH0693 Cannot be an external item
  • COBCH0694 Identifier is reference modified
  • COBCH0695 EXTERNAL program
    Related Topics
  • COBCH0696 Data-name must be specified with TYPEDEF
    Related Topics
  • COBCH0697 Data item is redefinition of KEY, rather than the key itself
    Related Topics
  • COBCH0698 Use of positive literal in AFTER ADVANCING phrase
    Related Topics
  • COBCH0699 ADVANCING PAGE and END-OF-PAGE used in same WRITE statement
    Under ANS85, ADVANCING PAGE and END-OF-PAGE are not allowed in the same WRITE statement.
  • COBCH0700 Function argument is wrong format
    You have supplied an argument to an intrinsic function which is of the wrong format, for example INTEGER-OF-DAY requires a date of a certain format.
Parent topic: Messages COBCH0601 to COBCH0700


COBCH0681 Function argument must be positive

Parent topic: COBCH0681 - COBCH0700


COBCH0682 Function argument must be positive or zero

Parent topic: COBCH0681 - COBCH0700


COBCH0683 Function argument must be nonzero

Parent topic: COBCH0681 - COBCH0700


COBCH0684 Function argument must be between -1 and +1

Parent topic: COBCH0681 - COBCH0700


COBCH0685 Function argument must be greater than -1

Parent topic: COBCH0681 - COBCH0700


COBCH0686 Function argument must be between 1 and collating sequence length

Parent topic: COBCH0681 - COBCH0700


COBCH0687 Use of PROCEDURE-POINTER data item

Related Topics
Parent topic: COBCH0681 - COBCH0700


COBCH0688 Use of "C" or "R" as currency sign

Parent topic: COBCH0681 - COBCH0700


COBCH0689 Condition-name cannot be set to FALSE (no FALSE value specified)

You have tried to set a level-88 item to FALSE without having specified the WHEN SET TO FALSE clause in the item's data description.
Parent topic: COBCH0681 - COBCH0700


COBCH0690 Illegal use of floating-point literal

Parent topic: COBCH0681 - COBCH0700


COBCH0691 Simple COPY and qualified COPY both used in the same program

You have mixed two different copies of copylbr in the same program. You must not use COPY statements if some have qualification and some have not.
Parent topic: COBCH0681 - COBCH0700


COBCH0692 REPORT specified in more than two FDs

Parent topic: COBCH0681 - COBCH0700


COBCH0693 Cannot be an external item

Parent topic: COBCH0681 - COBCH0700


COBCH0694 Identifier is reference modified

Parent topic: COBCH0681 - COBCH0700


COBCH0695 EXTERNAL program

Related Topics
Parent topic: COBCH0681 - COBCH0700


COBCH0696 Data-name must be specified with TYPEDEF

Related Topics
Parent topic: COBCH0681 - COBCH0700


COBCH0697 Data item is redefinition of KEY, rather than the key itself

Related Topics
Parent topic: COBCH0681 - COBCH0700


COBCH0698 Use of positive literal in AFTER ADVANCING phrase

Related Topics
Parent topic: COBCH0681 - COBCH0700


COBCH0699 ADVANCING PAGE and END-OF-PAGE used in same WRITE statement

Under ANS85, ADVANCING PAGE and END-OF-PAGE are not allowed in the same WRITE statement.
Parent topic: COBCH0681 - COBCH0700


COBCH0700 Function argument is wrong format

You have supplied an argument to an intrinsic function which is of the wrong format, for example INTEGER-OF-DAY requires a date of a certain format.

Resolution:

Check the format of your argument against the documentation and recode.

Parent topic: COBCH0681 - COBCH0700


Messages COBCH0701 to COBCH0800

  • COBCH0701 - COBCH0720
    Lists the Syntax Checking error messages from COBCH0701 through COBCH0720.
  • COBCH0721 - COBCH0740
    Lists the Syntax Checking error messages from COBCH0721 through COBCH0740.
  • COBCH0741 - COBCH0760
    Lists the Syntax Checking error messages from COBCH0741 through COBCH0760.
  • COBCH0761 - COBCH0780
    Lists the Syntax Checking error messages from COBCH0761 through COBCH0780.
  • COBCH0781 - COBCH0800
    Lists the Syntax Checking error messages from COBCH0781 through COBCH0800.
Parent topic: Syntax Checking Error Messages


COBCH0701 - COBCH0720

Lists the Syntax Checking error messages from COBCH0701 through COBCH0720.

  • COBCH0701 Alphabet-name must be preceded by ALPHABET
    Related Topics
  • COBCH0702 Alphabetic class expanded to include lower-case letters
  • COBCH0703 ON OVERFLOW will execute under more conditions
    Related Topics
  • COBCH0704 Comparison between scaled integer and nonnumeric is different
    You are trying to compare a scaled integer with a numeric edited or alphanumeric item.
  • COBCH0705 ":" treated as a separator
  • COBCH0706 Non-COBOL character character found. Results might be different
    Your COBOL system has found non-COBOL characters when trying a COPY REPLACING BY operation. The results might be different on other environments.
  • COBCH0707 An implicit EXIT PROGRAM will be executed at end of program
    Related Topics
  • COBCH0708 PICTURE consists of A's and B's. Treated as alphanumeric-edited
    Related Topics
  • COBCH0709 Order of initialization different for PERFORM... VARYING.. . AFTER
    Related Topics
  • COBCH0710 The maximum length of receiver receiver will be used
  • COBCH0711 RECORD CONTAINS with one integer is supported differently
  • COBCH0712 The file status values are different
    The file status values for file operations differ between environments.
  • COBCH0713 Subscripting and ODO for UNSTRING evaluated at start of statement
    Related Topics
  • COBCH0714 Non-space characters following "." are ignored
  • COBCH0715 EXIT not followed by "."
    Related Topics
  • COBCH0716 EXIT PROGRAM not followed by "."
    Related Topics
  • COBCH0717 Shift out character not followed by valid DBCS character
  • COBCH0718 Shift out character not matched with shift in, or vice versa
  • COBCH0719 I-O CONTROL paragraph contains multiple sentences
    Related Topics
  • COBCH0720 SEQUENTIAL file used as CALL parameter
    Related Topics
Parent topic: Messages COBCH0701 to COBCH0800


COBCH0701 Alphabet-name must be preceded by ALPHABET

Related Topics
Parent topic: COBCH0701 - COBCH0720


COBCH0702 Alphabetic class expanded to include lower-case letters

Parent topic: COBCH0701 - COBCH0720


COBCH0703 ON OVERFLOW will execute under more conditions

Related Topics
Parent topic: COBCH0701 - COBCH0720


COBCH0704 Comparison between scaled integer and nonnumeric is different

You are trying to compare a scaled integer with a numeric edited or alphanumeric item.
Parent topic: COBCH0701 - COBCH0720


COBCH0705 ":" treated as a separator

Parent topic: COBCH0701 - COBCH0720


COBCH0706 Non-COBOL character character found. Results might be different

Your COBOL system has found non-COBOL characters when trying a COPY REPLACING BY operation. The results might be different on other environments.
Parent topic: COBCH0701 - COBCH0720


COBCH0707 An implicit EXIT PROGRAM will be executed at end of program

Related Topics
Parent topic: COBCH0701 - COBCH0720


COBCH0708 PICTURE consists of A's and B's. Treated as alphanumeric-edited

Related Topics
Parent topic: COBCH0701 - COBCH0720


COBCH0709 Order of initialization different for PERFORM... VARYING.. . AFTER

Related Topics
Parent topic: COBCH0701 - COBCH0720


COBCH0710 The maximum length of receiver receiver will be used

Parent topic: COBCH0701 - COBCH0720


COBCH0711 RECORD CONTAINS with one integer is supported differently

Parent topic: COBCH0701 - COBCH0720


COBCH0712 The file status values are different

The file status values for file operations differ between environments.
Parent topic: COBCH0701 - COBCH0720


COBCH0713 Subscripting and ODO for UNSTRING evaluated at start of statement

Related Topics
Parent topic: COBCH0701 - COBCH0720


COBCH0714 Non-space characters following "." are ignored

Parent topic: COBCH0701 - COBCH0720


COBCH0715 EXIT not followed by "."

Related Topics
Parent topic: COBCH0701 - COBCH0720


COBCH0716 EXIT PROGRAM not followed by "."

Related Topics
Parent topic: COBCH0701 - COBCH0720


COBCH0717 Shift out character not followed by valid DBCS character

Parent topic: COBCH0701 - COBCH0720


COBCH0718 Shift out character not matched with shift in, or vice versa

Parent topic: COBCH0701 - COBCH0720


COBCH0719 I-O CONTROL paragraph contains multiple sentences

Related Topics
Parent topic: COBCH0701 - COBCH0720


COBCH0720 SEQUENTIAL file used as CALL parameter

Related Topics
Parent topic: COBCH0701 - COBCH0720


COBCH0721 - COBCH0740

Lists the Syntax Checking error messages from COBCH0721 through COBCH0740.

  • COBCH0721 Non-SEQUENTIAL file used as CALL parameter
  • COBCH0722 Data item too small (must be at least 16 characters long)
  • COBCH0723 USE...GIVING option
  • COBCH0724 Period follows SKIP1/ 2/ 3 or EJECT
  • COBCH0725 Function argument invalid, year must be greater than 1600
  • COBCH0726 Function argument invalid, month must be an integer between 1 and 12
  • COBCH0727 Function argument invalid, day must be an integer between 1 and 31
  • COBCH0728 Function argument invalid, day must be an integer between 1 and 366
  • COBCH0729 OO: parameter-name not specified in USING
  • COBCH0730 OO: Definition too long
  • COBCH0731 OO: Syntax matches multiple signatures of signature - first assumed
  • COBCH0732 OO: Signature signature does not match or data name data-name not declared
  • COBCH0733 OO: FUNCTION not permitted - no RETURNING/GIVING phrase specified
  • COBCH0734 OO: FUNCTION cannot use RETURNING/GIVING parameter parameter-name
  • COBCH0735 OO: Invalid verb/function signature signature
  • COBCH0736 OO: CLASS class-name not declared
  • COBCH0737 OO: Object types do not conform (type-1,type-2)
  • COBCH0738 OO: Signature must contain <SELF> or <OBJECT> exactlyonce
  • COBCH0739 OO: Signature includes IN, OF or "(" after parameter. May be ambiguous.
  • COBCH0740 OO: Sorry, too many use signatures of signature to consider
Parent topic: Messages COBCH0701 to COBCH0800


COBCH0721 Non-SEQUENTIAL file used as CALL parameter

Parent topic: COBCH0721 - COBCH0740


COBCH0722 Data item too small (must be at least 16 characters long)

Parent topic: COBCH0721 - COBCH0740


COBCH0723 USE...GIVING option

Parent topic: COBCH0721 - COBCH0740


COBCH0724 Period follows SKIP1/ 2/ 3 or EJECT

Parent topic: COBCH0721 - COBCH0740


COBCH0725 Function argument invalid, year must be greater than 1600

Parent topic: COBCH0721 - COBCH0740


COBCH0726 Function argument invalid, month must be an integer between 1 and 12

Parent topic: COBCH0721 - COBCH0740


COBCH0727 Function argument invalid, day must be an integer between 1 and 31

Parent topic: COBCH0721 - COBCH0740


COBCH0728 Function argument invalid, day must be an integer between 1 and 366

Parent topic: COBCH0721 - COBCH0740


COBCH0729 OO: parameter-name not specified in USING

Parameters to user defined syntax must be listed in the PROCEDURE DIVISION USING clause of the program.

Parent topic: COBCH0721 - COBCH0740


COBCH0730 OO: Definition too long

The definitions of user defined syntax are restricted in size.

Resolution:

Shorten your syntax definition, for example, by omitting optional noise words.

Parent topic: COBCH0721 - COBCH0740


COBCH0731 OO: Syntax matches multiple signatures of signature - first assumed

The syntax defined in the program matches more than one user defined syntax definition. The code could be ambiguous. However, in many cases the definitions resolve to the same method. The Compiler uses the first matching definition.

Parent topic: COBCH0721 - COBCH0740


COBCH0732 OO: Signature signature does not match or data name data-name not declared

Parent topic: COBCH0721 - COBCH0740


COBCH0733 OO: FUNCTION not permitted - no RETURNING/GIVING phrase specified

User-defined syntax FUNCTIONs can only be defined for methods which have a RETURNING or GIVING phrase on the PROCEDURE DIVISION.

Parent topic: COBCH0721 - COBCH0740


COBCH0734 OO: FUNCTION cannot use RETURNING/GIVING parameter parameter-name

User-defined syntax FUNCTIONs cannot include the RETURNING/GIVING parameter as a parameter to the function.

Parent topic: COBCH0721 - COBCH0740


COBCH0735 OO: Invalid verb/function signature signature

You are trying to use a reserved word as the verb of user-defined syntax definition.

Resolution:

Choose a different verb.

Parent topic: COBCH0721 - COBCH0740


COBCH0736 OO: CLASS class-name not declared

class-name is not declared as a CLASS in the SPECIAL-NAMES paragraph of a program. It's definition might be required as a result of specified inheritance.

Resolution:

Include an appropriate CLASS statement in the SPECIAL-NAMES paragraph and resubmit.

Parent topic: COBCH0721 - COBCH0740


COBCH0737 OO: Object types do not conform (type-1,type-2)

You are trying an operation involving incompatible types of OBJECT REFERENCEs, as defined by the inheritance hierarchy. Such objects are said to be non-conforming.

Parent topic: COBCH0721 - COBCH0740


COBCH0738 OO: Signature must contain <SELF> or <OBJECT> exactlyonce

User defined syntax definitions must contain <SELF> or <OBJECT> exactly once.

Parent topic: COBCH0721 - COBCH0740


COBCH0739 OO: Signature includes IN, OF or "(" after parameter. May be ambiguous.

The use of OF or parentheses in user defined syntax definitions can lead to ambiguities in parsing which might give unexpected results. For example, parentheses following a parameter might be interpreted as subscripting.

Parent topic: COBCH0721 - COBCH0740


COBCH0740 OO: Sorry, too many use signatures of signature to consider

There is a limitation as to how many user defined syntax definitions with the same verb or function name can be considered at one time. For example, you have many definitions of the same verb.

Resolution:

Reduce the number of definitions of each verb, or shorten those definitions.

Parent topic: COBCH0721 - COBCH0740


COBCH0741 - COBCH0760

Lists the Syntax Checking error messages from COBCH0741 through COBCH0760.

  • COBCH0741 OO: Only allowed in an instance method
    You have tried to use syntax that is only permitted in an instance method.
  • COBCH0742 OO: Implicit use of SELF only allowed in a METHOD
    INVOKE statements might omit the initial object reference, and this implies an object reference of SELF. This can only be done in a METHOD, not a program.
  • COBCH0743 Expressions in SQL statements not affected by ARITHMETIC directive
    Arithmetical expressions in SQL statements are processed by the database engine and are therefore not affected by the ARITHMETIC directive.
  • COBCH0744 BY VALUE not allowed in nested programs
    You have tried to pass a parameter BY VALUE when calling a nested program.
  • COBCH0745 END DECLARATIVES missing
    Related Topics
  • COBCH0746 WHEN OTHER must follow other WHEN phrase
    Related Topics
  • COBCH0747 Object of SUM...UPON phrase is not a detail group for this report
    Related Topics
  • COBCH0748 Index name set to negative value
    You have set the value of an index to a negative number. Index values must be no less than 1.
  • COBCH0749 Index name set to +0
    You have set the value of an index to 0. Index values must be no less than 1.
  • COBCH0750 Index name set to 0
    You have set the value of an index to 0. Index values must be no less than 1.
  • COBCH0751 Index name augmented by 0
  • COBCH0752 Complex arithmetic expression used as subscript
    Related Topics
  • COBCH0753 OR phrase in INSPECT BEFORE/AFTER
    The INSPECT statement contains an OR operand after a BEFORE or AFTER phrase.
  • COBCH0754 Negative integer not allowed
    Related Topics
  • COBCH0755 Special register used with ACCEPT/DISPLAY/EXHIBIT or CALL statement
    Related Topics
  • COBCH0756 TYPEDEF name missing
    Related Topics
  • COBCH0757 POINTER name required
    Related Topics
  • COBCH0758 POINTER item has incorrect type
    Related Topics
  • COBCH0759 Illegal use of logical operator
    Related Topics
  • COBCH0760 INITIALIZE TO VALUE statement
    Related Topics
Parent topic: Messages COBCH0701 to COBCH0800


COBCH0741 OO: Only allowed in an instance method

You have tried to use syntax that is only permitted in an instance method.
Parent topic: COBCH0741 - COBCH0760


COBCH0742 OO: Implicit use of SELF only allowed in a METHOD

INVOKE statements might omit the initial object reference, and this implies an object reference of SELF. This can only be done in a METHOD, not a program.
Parent topic: COBCH0741 - COBCH0760


COBCH0743 Expressions in SQL statements not affected by ARITHMETIC directive

Arithmetical expressions in SQL statements are processed by the database engine and are therefore not affected by the ARITHMETIC directive.
Parent topic: COBCH0741 - COBCH0760


COBCH0744 BY VALUE not allowed in nested programs

You have tried to pass a parameter BY VALUE when calling a nested program.
Parent topic: COBCH0741 - COBCH0760


COBCH0745 END DECLARATIVES missing

Related Topics
Parent topic: COBCH0741 - COBCH0760


COBCH0746 WHEN OTHER must follow other WHEN phrase

Related Topics
Parent topic: COBCH0741 - COBCH0760


COBCH0747 Object of SUM...UPON phrase is not a detail group for this report

Related Topics
Parent topic: COBCH0741 - COBCH0760


COBCH0748 Index name set to negative value

You have set the value of an index to a negative number. Index values must be no less than 1.

Resolution:

Modify your code to specify a positive value for the index, then resubmit.

Parent topic: COBCH0741 - COBCH0760


COBCH0749 Index name set to +0

You have set the value of an index to 0. Index values must be no less than 1.

Resolution:

Modify your code to specify a positive value for the index, then resubmit.

Parent topic: COBCH0741 - COBCH0760


COBCH0750 Index name set to 0

You have set the value of an index to 0. Index values must be no less than 1.

Resolution:

Modify your code to specify a positive value for the index, then resubmit.

Parent topic: COBCH0741 - COBCH0760


COBCH0751 Index name augmented by 0

Parent topic: COBCH0741 - COBCH0760


COBCH0752 Complex arithmetic expression used as subscript

Related Topics
Parent topic: COBCH0741 - COBCH0760


COBCH0753 OR phrase in INSPECT BEFORE/AFTER

The INSPECT statement contains an OR operand after a BEFORE or AFTER phrase.
Parent topic: COBCH0741 - COBCH0760


COBCH0754 Negative integer not allowed

Related Topics
Parent topic: COBCH0741 - COBCH0760


COBCH0755 Special register used with ACCEPT/DISPLAY/EXHIBIT or CALL statement

Related Topics
Parent topic: COBCH0741 - COBCH0760


COBCH0756 TYPEDEF name missing

Related Topics
Parent topic: COBCH0741 - COBCH0760


COBCH0757 POINTER name required

Related Topics
Parent topic: COBCH0741 - COBCH0760


COBCH0758 POINTER item has incorrect type

Related Topics
Parent topic: COBCH0741 - COBCH0760


COBCH0759 Illegal use of logical operator

Related Topics
Parent topic: COBCH0741 - COBCH0760


COBCH0760 INITIALIZE TO VALUE statement

Related Topics
Parent topic: COBCH0741 - COBCH0760


COBCH0761 - COBCH0780

Lists the Syntax Checking error messages from COBCH0761 through COBCH0780.

  • COBCH0761 DELIMITED BY SIZE omitted
  • COBCH0762 Must be a typed pointer
  • COBCH0763 RETURNING phrase cannot be used on an ENTRY statement
  • COBCH0764 ENTRY statement in a program with a PROCEDURE DIVISION RETURNING phrase
  • COBCH0765 Failed to create directory %1_s
  • COBCH0766 Failed to create class file (%1_s) %2_s_
  • COBCH0770 OO: Signature includes IN, OF or "(" after parameter.
    The use of OF, IN or parentheses in user defined syntax definitions that follow or might possibly follow a parameter are not allowed.
  • COBCH0771 OO: Required or Optional word must not be a verb.
    The use of a COBOL verb is not allowed as a user defined required, or optionaly required, word in user defined syntax definitions.
  • COBCH0772 Illegal combination of ALLOW clauses
  • COBCH0773 CLASS clause cannot be used with numeric item
    Related Topics
  • COBCH0774 COBOL word contains 31 characters.
  • COBCH0775 Data item too small - must have at least 4 digits.
  • COBCH0776 Partial word replacement.
  • COBCH0777 Only one word allowed with partial word replacement.
  • COBCH0778 Additional messages suppressed
  • COBCH0779 The intermediate code may not be portable at the intlevel set
Parent topic: Messages COBCH0701 to COBCH0800


COBCH0761 DELIMITED BY SIZE omitted

Parent topic: COBCH0761 - COBCH0780


COBCH0762 Must be a typed pointer

Parent topic: COBCH0761 - COBCH0780


COBCH0763 RETURNING phrase cannot be used on an ENTRY statement

Parent topic: COBCH0761 - COBCH0780


COBCH0764 ENTRY statement in a program with a PROCEDURE DIVISION RETURNING phrase

Parent topic: COBCH0761 - COBCH0780


COBCH0765 Failed to create directory %1_s

Parent topic: COBCH0761 - COBCH0780


COBCH0766 Failed to create class file (%1_s) %2_s_

Parent topic: COBCH0761 - COBCH0780


COBCH0770 OO: Signature includes IN, OF or "(" after parameter.

The use of OF, IN or parentheses in user defined syntax definitions that follow or might possibly follow a parameter are not allowed.
Parent topic: COBCH0761 - COBCH0780


COBCH0771 OO: Required or Optional word must not be a verb.

The use of a COBOL verb is not allowed as a user defined required, or optionaly required, word in user defined syntax definitions.
Parent topic: COBCH0761 - COBCH0780


COBCH0772 Illegal combination of ALLOW clauses

Parent topic: COBCH0761 - COBCH0780


COBCH0773 CLASS clause cannot be used with numeric item

Related Topics
Parent topic: COBCH0761 - COBCH0780


COBCH0774 COBOL word contains 31 characters.

Parent topic: COBCH0761 - COBCH0780


COBCH0775 Data item too small - must have at least 4 digits.

Parent topic: COBCH0761 - COBCH0780


COBCH0776 Partial word replacement.

Parent topic: COBCH0761 - COBCH0780


COBCH0777 Only one word allowed with partial word replacement.

Parent topic: COBCH0761 - COBCH0780


COBCH0778 Additional messages suppressed

Parent topic: COBCH0761 - COBCH0780


COBCH0779 The intermediate code may not be portable at the intlevel set

If you have set INTLEVEL(or it has implicitly been set by language features) to a HIGHER level, it won't be portable if you take it to another platform with an older product that does not support the higher level.

Parent topic: COBCH0761 - COBCH0780


COBCH0781 - COBCH0800

Lists the Syntax Checking error messages from COBCH0781 through COBCH0800.

  • COBCH0781 01 Group item must have the EXTERNAL-FORM clause
  • COBCH0782 Call by number routine x"%1_s" does not exist_
  • COBCH0789 Pre-compiled header %1_s is incompatible with this compiler
  • COBCH0790 OO: Invalid method name.
  • COBCH0791 Pre-compiled header header not found.
  • COBCH0792 MOVE used with pointer item.
  • COBCH0793 No PICTURE specified for elementary alphanumeric item.
  • COBCH0794 KEY specification uses SOURCE syntax.
  • COBCH0795 END PROGRAM value missing.
  • COBCH0796 SYNC would cause re-alignment of redefined group - not allowed
  • COBCH0797 Non-COBOL character character found.
  • COBCH0799 COLUMN clause requires a SOURCE/SUM/VALUE clause also.
  • COBCH0800 Bad task request from External Compiler Module
Parent topic: Messages COBCH0701 to COBCH0800


COBCH0781 01 Group item must have the EXTERNAL-FORM clause

Parent topic: COBCH0781 - COBCH0800


COBCH0782 Call by number routine x"%1_s" does not exist_

Parent topic: COBCH0781 - COBCH0800


COBCH0789 Pre-compiled header %1_s is incompatible with this compiler

Parent topic: COBCH0781 - COBCH0800


COBCH0790 OO: Invalid method name.

Parent topic: COBCH0781 - COBCH0800


COBCH0791 Pre-compiled header header not found.

Parent topic: COBCH0781 - COBCH0800


COBCH0792 MOVE used with pointer item.

Parent topic: COBCH0781 - COBCH0800


COBCH0793 No PICTURE specified for elementary alphanumeric item.

Parent topic: COBCH0781 - COBCH0800


COBCH0794 KEY specification uses SOURCE syntax.

Parent topic: COBCH0781 - COBCH0800


COBCH0795 END PROGRAM value missing.

Parent topic: COBCH0781 - COBCH0800


COBCH0796 SYNC would cause re-alignment of redefined group - not allowed

Parent topic: COBCH0781 - COBCH0800


COBCH0797 Non-COBOL character character found.

Parent topic: COBCH0781 - COBCH0800


COBCH0799 COLUMN clause requires a SOURCE/SUM/VALUE clause also.

Parent topic: COBCH0781 - COBCH0800


COBCH0800 Bad task request from External Compiler Module

Parent topic: COBCH0781 - COBCH0800


Messages COBCH0801 to COBCH0900

  • COBCH0801 - COBCH0820
    Lists the Syntax Checking error messages from COBCH0801 through COBCH0820.
  • COBCH0821 - COBCH0840
    Lists the Syntax Checking error messages from COBCH0821 through COBCH0840.
  • COBCH0841 - COBCH0860
    Lists the Syntax Checking error messages from COBCH0841 through COBCH0860.
  • COBCH0861 - COBCH0880
    Lists the Syntax Checking error messages from COBCH0861 through COBCH0880.
  • COBCH0881 - COBCH0900
    Lists the Syntax Checking error messages from COBCH0881 through COBCH0900.
Parent topic: Syntax Checking Error Messages


COBCH0801 - COBCH0820

Lists the Syntax Checking error messages from COBCH0801 through COBCH0820.

  • COBCH0801 External Compiler Module message
  • COBCH0802 Data name defined using SQL syntax too long to modify
  • COBCH0803 Integrated preprocessor message
  • COBCH0804 Source limit of integer lines exceeded
  • COBCH0805 Bad directive or option in _IF
  • COBCH0806 Too many items in CODE-SET FOR clause
  • COBCH0807 VALUE clause requires a table declaration_
  • COBCH0808 Maximum number of data items exceeded
    The compiled program contains more than 64,000 data items.
  • COBCH0809 Pseudo-text delimiter missing_
  • COBCH0810 Reserved word missing - OF expected_
  • COBCH0811 Number of WHEN phrases _ %1_s
  • COBCH0812 USAGE NATIONAL - need to compile with NSYMBOL(NATIONAL) directive_
  • COBCH0813 Feature not yet supported when compiling for _NET
  • COBCH0814 Feature not supported
  • COBCH0815 Cannot have an abstract method in a non-abstract class
  • COBCH0816 CUSTOM-ATTRIBUTE must derive from System_Attribute class
  • COBCH0817 Exception-name must derive from System_Exception class
  • COBCH0818 '%1_s' not found or is not an interface
  • COBCH0819 Interface member '%1_s' or one of its overloads not implemented or not public
  • COBCH0820 Class '%1_s' not found or is not a delegate class
Parent topic: Messages COBCH0801 to COBCH0900


COBCH0801 External Compiler Module message

Parent topic: COBCH0801 - COBCH0820


COBCH0802 Data name defined using SQL syntax too long to modify

Parent topic: COBCH0801 - COBCH0820


COBCH0803 Integrated preprocessor message

Parent topic: COBCH0801 - COBCH0820


COBCH0804 Source limit of integer lines exceeded

Parent topic: COBCH0801 - COBCH0820


COBCH0805 Bad directive or option in _IF

Parent topic: COBCH0801 - COBCH0820


COBCH0806 Too many items in CODE-SET FOR clause

Parent topic: COBCH0801 - COBCH0820


COBCH0807 VALUE clause requires a table declaration_

Parent topic: COBCH0801 - COBCH0820


COBCH0808 Maximum number of data items exceeded

The compiled program contains more than 64,000 data items.

Resolution:

Reduce the number of data items then recompile your program.

Parent topic: COBCH0801 - COBCH0820


COBCH0809 Pseudo-text delimiter missing_

Parent topic: COBCH0801 - COBCH0820


COBCH0810 Reserved word missing - OF expected_

Parent topic: COBCH0801 - COBCH0820


COBCH0811 Number of WHEN phrases _ %1_s

Parent topic: COBCH0801 - COBCH0820


COBCH0812 USAGE NATIONAL - need to compile with NSYMBOL(NATIONAL) directive_

Parent topic: COBCH0801 - COBCH0820


COBCH0813 Feature not yet supported when compiling for _NET

Parent topic: COBCH0801 - COBCH0820


COBCH0814 Feature not supported

Parent topic: COBCH0801 - COBCH0820


COBCH0815 Cannot have an abstract method in a non-abstract class

Parent topic: COBCH0801 - COBCH0820


COBCH0816 CUSTOM-ATTRIBUTE must derive from System_Attribute class

Parent topic: COBCH0801 - COBCH0820


COBCH0817 Exception-name must derive from System_Exception class

Parent topic: COBCH0801 - COBCH0820


COBCH0818 '%1_s' not found or is not an interface

Parent topic: COBCH0801 - COBCH0820


COBCH0819 Interface member '%1_s' or one of its overloads not implemented or not public

Parent topic: COBCH0801 - COBCH0820


COBCH0820 Class '%1_s' not found or is not a delegate class

Parent topic: COBCH0801 - COBCH0820


COBCH0821 - COBCH0840

Lists the Syntax Checking error messages from COBCH0821 through COBCH0840.

  • COBCH0821 Not a valid iterator
  • COBCH0824 RAISE must specify exception object when not in CATCH block
  • COBCH0825 Cannot inherit from FINAL class '%1_s'
  • COBCH0826 Illegal parameter to delegate constructor
  • COBCH0827 Method has different signature from delegate
  • COBCH0828 Illegal cast or test - object types do not conform (%1_s, %2_s)
  • COBCH0829 Could not find method new with this signature
  • COBCH0830 Attribute class does not have constructor with this signature
  • COBCH0831 Illegal specification of named parameter
  • COBCH0832 Attribute class does not have property '%1_s'
  • COBCH0833 Invalid value for property '%1_s'
  • COBCH0834 Property can not be a sending item
  • COBCH0835 Property cannot be a receiving item
  • COBCH0836 Method in interface definition must be public
  • COBCH0837 Procedural code not allowed here
  • COBCH0838 System limit - Data Division too large _ 256Mbytes_
  • COBCH0839 System limit - Procedure Division too large_ _ 16Mbytes_
  • COBCH0840 RETURNING item is incompatible with method return type
Parent topic: Messages COBCH0801 to COBCH0900


COBCH0821 Not a valid iterator

Parent topic: COBCH0821 - COBCH0840


COBCH0824 RAISE must specify exception object when not in CATCH block

Parent topic: COBCH0821 - COBCH0840


COBCH0825 Cannot inherit from FINAL class '%1_s'

Parent topic: COBCH0821 - COBCH0840


COBCH0826 Illegal parameter to delegate constructor

Parent topic: COBCH0821 - COBCH0840


COBCH0827 Method has different signature from delegate

Parent topic: COBCH0821 - COBCH0840


COBCH0828 Illegal cast or test - object types do not conform (%1_s, %2_s)

Parent topic: COBCH0821 - COBCH0840


COBCH0829 Could not find method new with this signature

Parent topic: COBCH0821 - COBCH0840
Related information
Compiler


COBCH0830 Attribute class does not have constructor with this signature

Parent topic: COBCH0821 - COBCH0840


COBCH0831 Illegal specification of named parameter

Parent topic: COBCH0821 - COBCH0840


COBCH0832 Attribute class does not have property '%1_s'

Parent topic: COBCH0821 - COBCH0840


COBCH0833 Invalid value for property '%1_s'

Parent topic: COBCH0821 - COBCH0840


COBCH0834 Property can not be a sending item

Parent topic: COBCH0821 - COBCH0840


COBCH0835 Property cannot be a receiving item

Parent topic: COBCH0821 - COBCH0840


COBCH0836 Method in interface definition must be public

Parent topic: COBCH0821 - COBCH0840


COBCH0837 Procedural code not allowed here

Parent topic: COBCH0821 - COBCH0840


COBCH0838 System limit - Data Division too large _ 256Mbytes_

Parent topic: COBCH0821 - COBCH0840


COBCH0839 System limit - Procedure Division too large_ _ 16Mbytes_

Parent topic: COBCH0821 - COBCH0840


COBCH0840 RETURNING item is incompatible with method return type

Parent topic: COBCH0821 - COBCH0840


COBCH0841 - COBCH0860

Lists the Syntax Checking error messages from COBCH0841 through COBCH0860.

  • COBCH0841 RETURNING item requires implicit cast
  • COBCH0842 Method <method-name> has multiple definitions with same signature
    A method is defined more than once with the same signature. This isn't allowed as it would lead to ambiguity when the method was invoked.
  • COBCH0843 SET PROPERTY must have USING parameter and no RETURNING
  • COBCH0844 GET PROPERTY must have a RETURNING parameter
  • COBCH0845 Unknown class "class-name"
  • COBCH0846 Invalid use of ANY LENGTH clause
  • COBCH0847 OBJECT REFERENCE can only have OCCURS at 01 level
  • COBCH0848 Can only be used on native data item with OCCURS at 01 level
  • COBCH0849 Too many types specified for generic class
  • COBCH0850 Too many constraints specified for generic type
  • COBCH0851 Methods cannot be nested - END METHOD missing
  • COBCH0852 System error - unexpected error while generating IL code
  • COBCH0853 System error - evaluation stack mismatch
  • COBCH0854 System error - evaluation stack negative
  • COBCH0855 System error - evaluation stack exceeded limit
  • COBCH0856 System error - evaluation stack non-empty
  • COBCH0857 System error - failure during ILASM phase
  • COBCH0859 System error - peverify has determined that this program is not verifiable
  • COBCH0858 No static method found - cannot be a main program
  • COBCH0860 Object references must be specified at 01 level
Parent topic: Messages COBCH0801 to COBCH0900


COBCH0841 RETURNING item requires implicit cast

Parent topic: COBCH0841 - COBCH0860


COBCH0842 Method <method-name> has multiple definitions with same signature

A method is defined more than once with the same signature. This isn't allowed as it would lead to ambiguity when the method was invoked.

Resolution:

Change the method signature.

Parent topic: COBCH0841 - COBCH0860


COBCH0843 SET PROPERTY must have USING parameter and no RETURNING

Parent topic: COBCH0841 - COBCH0860


COBCH0844 GET PROPERTY must have a RETURNING parameter

Parent topic: COBCH0841 - COBCH0860


COBCH0845 Unknown class "class-name"

These are the possible causes for this problem:

  1. The class name might be misspelled.
  2. The class is included in the referenced assemblies, but its namespace is not imported in your project.
  3. The class is not included in the referenced assemblies.

Resolution:

  1. Ensure you are spelling the class name correctly.
Parent topic: COBCH0841 - COBCH0860


COBCH0846 Invalid use of ANY LENGTH clause

Parent topic: COBCH0841 - COBCH0860


COBCH0847 OBJECT REFERENCE can only have OCCURS at 01 level

Parent topic: COBCH0841 - COBCH0860


COBCH0848 Can only be used on native data item with OCCURS at 01 level

Parent topic: COBCH0841 - COBCH0860


COBCH0849 Too many types specified for generic class

Parent topic: COBCH0841 - COBCH0860


COBCH0850 Too many constraints specified for generic type

Parent topic: COBCH0841 - COBCH0860


COBCH0851 Methods cannot be nested - END METHOD missing

Parent topic: COBCH0841 - COBCH0860


COBCH0852 System error - unexpected error while generating IL code

Parent topic: COBCH0841 - COBCH0860


COBCH0853 System error - evaluation stack mismatch

Parent topic: COBCH0841 - COBCH0860


COBCH0854 System error - evaluation stack negative

Parent topic: COBCH0841 - COBCH0860


COBCH0855 System error - evaluation stack exceeded limit

Parent topic: COBCH0841 - COBCH0860


COBCH0856 System error - evaluation stack non-empty

Parent topic: COBCH0841 - COBCH0860


COBCH0857 System error - failure during ILASM phase

Parent topic: COBCH0841 - COBCH0860


COBCH0859 System error - peverify has determined that this program is not verifiable

Parent topic: COBCH0841 - COBCH0860


COBCH0858 No static method found - cannot be a main program

Restriction: This applies to .NET managed COBOL only.

The startup object for your project is specified incorrectly or the main program in the project does not contain a static method.

Resolution:

Do not use the Startup object in the Application properties page to set the main program. The startup object must be the first static method in a class specified using the ILMAIN directive.

Parent topic: COBCH0841 - COBCH0860


COBCH0860 Object references must be specified at 01 level

Parent topic: COBCH0841 - COBCH0860


COBCH0861 - COBCH0880

Lists the Syntax Checking error messages from COBCH0861 through COBCH0880.

  • COBCH0861 Object references must not be redefined
  • COBCH0862 Object references must not have REDEFINES clause
  • COBCH0863 Operand must be an ENUM
  • COBCH0864 All operands in an ENUM expression must be of the same type
  • COBCH0865 Failed to find system program '%1_s'
  • COBCH0866 Illegal combination of visibility attributes
  • COBCH0867 Cannot jump out of a FINALLY block
  • COBCH0868 Inherited class '%1_s' not found
  • COBCH0869 Cannot create an instance of abstract class '%1_s'
  • COBCH0870 ABSTRACT method cannot be PRIVATE
  • COBCH0871 ABSTRACT class or method cannot be FINAL
  • COBCH0872 ABSTRACT method cannot be static
  • COBCH0873 Program or method name missing
  • COBCH0874 Interface methods cannot be FINAL
  • COBCH0875 Property '%1_s' not implemented or not public
  • COBCH0876 Only one field may be declared in ENUM
  • COBCH0877 ENUM field must be a numeric field of native _NET type
  • COBCH0878 ENUM literal must a numeric integer
  • COBCH0879 ENUM literals must follow ENUM field
  • COBCH0880 VALUETYPE programs cannot inherit
Parent topic: Messages COBCH0801 to COBCH0900


COBCH0861 Object references must not be redefined

Parent topic: COBCH0861 - COBCH0880


COBCH0862 Object references must not have REDEFINES clause

Parent topic: COBCH0861 - COBCH0880


COBCH0863 Operand must be an ENUM

Parent topic: COBCH0861 - COBCH0880


COBCH0864 All operands in an ENUM expression must be of the same type

Parent topic: COBCH0861 - COBCH0880


COBCH0865 Failed to find system program '%1_s'

Parent topic: COBCH0861 - COBCH0880


COBCH0866 Illegal combination of visibility attributes

Parent topic: COBCH0861 - COBCH0880


COBCH0867 Cannot jump out of a FINALLY block

Parent topic: COBCH0861 - COBCH0880


COBCH0868 Inherited class '%1_s' not found

Parent topic: COBCH0861 - COBCH0880


COBCH0869 Cannot create an instance of abstract class '%1_s'

Parent topic: COBCH0861 - COBCH0880


COBCH0870 ABSTRACT method cannot be PRIVATE

Parent topic: COBCH0861 - COBCH0880


COBCH0871 ABSTRACT class or method cannot be FINAL

Parent topic: COBCH0861 - COBCH0880


COBCH0872 ABSTRACT method cannot be static

Parent topic: COBCH0861 - COBCH0880


COBCH0873 Program or method name missing

Parent topic: COBCH0861 - COBCH0880


COBCH0874 Interface methods cannot be FINAL

Parent topic: COBCH0861 - COBCH0880


COBCH0875 Property '%1_s' not implemented or not public

Parent topic: COBCH0861 - COBCH0880


COBCH0876 Only one field may be declared in ENUM

Parent topic: COBCH0861 - COBCH0880


COBCH0877 ENUM field must be a numeric field of native _NET type

Parent topic: COBCH0861 - COBCH0880


COBCH0878 ENUM literal must a numeric integer

Parent topic: COBCH0861 - COBCH0880


COBCH0879 ENUM literals must follow ENUM field

Parent topic: COBCH0861 - COBCH0880


COBCH0880 VALUETYPE programs cannot inherit

Parent topic: COBCH0861 - COBCH0880


COBCH0881 - COBCH0900

Lists the Syntax Checking error messages from COBCH0881 through COBCH0900.

  • COBCH0881 OCCURS format can only be used with native _NET types at 01 level
  • COBCH0882 Only one visibility attribute allowed
  • COBCH0883 Attribute repeated
  • COBCH0884 Cannot use ADDRESS OF operator on _NET native type
  • COBCH0885 Visibility attributes can only be used with native _NET types at 01 level
  • COBCH0886 EVENT can only be specified with objects of delegate type
  • COBCH0887 Class class-name has multiple definitions
    A class is defined more than once with the same name. This isn't allowed.
  • COBCH0888 Illegal comparison for this type
  • COBCH0889 Illegal operator
  • COBCH0890 Operator already defined
  • COBCH0891 '_' operator is defined without matching '__' operator
  • COBCH0892 '__' operator is defined without matching '_' operator
  • COBCH0893 '_' operator is defined without matching '_' operator
  • COBCH0894 '_' operator is defined without matching '_' operator
  • COBCH0895 '__' operator is defined without matching '__' operator
  • COBCH0896 '__' operator is defined without matching '__' operator
  • COBCH0897 Cannot specify reference modification on an object reference
  • COBCH0898 Ambiguous match for method '%1_s' with this signature
  • COBCH0899 Class constructors cannot have parameters
  • COBCH0900 Internal error - Stack overflow_ Inform Technical Support_
Parent topic: Messages COBCH0801 to COBCH0900


COBCH0881 OCCURS format can only be used with native _NET types at 01 level

Parent topic: COBCH0881 - COBCH0900


COBCH0882 Only one visibility attribute allowed

Parent topic: COBCH0881 - COBCH0900


COBCH0883 Attribute repeated

Parent topic: COBCH0881 - COBCH0900


COBCH0884 Cannot use ADDRESS OF operator on _NET native type

Parent topic: COBCH0881 - COBCH0900


COBCH0885 Visibility attributes can only be used with native _NET types at 01 level

Parent topic: COBCH0881 - COBCH0900


COBCH0886 EVENT can only be specified with objects of delegate type

Parent topic: COBCH0881 - COBCH0900


COBCH0887 Class class-name has multiple definitions

A class is defined more than once with the same name. This isn't allowed.

Parent topic: COBCH0881 - COBCH0900


COBCH0888 Illegal comparison for this type

Parent topic: COBCH0881 - COBCH0900


COBCH0889 Illegal operator

Parent topic: COBCH0881 - COBCH0900


COBCH0890 Operator already defined

Parent topic: COBCH0881 - COBCH0900


COBCH0891 '_' operator is defined without matching '__' operator

Parent topic: COBCH0881 - COBCH0900


COBCH0892 '__' operator is defined without matching '_' operator

Parent topic: COBCH0881 - COBCH0900


COBCH0893 '_' operator is defined without matching '_' operator

Parent topic: COBCH0881 - COBCH0900


COBCH0894 '_' operator is defined without matching '_' operator

Parent topic: COBCH0881 - COBCH0900


COBCH0895 '__' operator is defined without matching '__' operator

Parent topic: COBCH0881 - COBCH0900


COBCH0896 '__' operator is defined without matching '__' operator

Parent topic: COBCH0881 - COBCH0900


COBCH0897 Cannot specify reference modification on an object reference

Parent topic: COBCH0881 - COBCH0900


COBCH0898 Ambiguous match for method '%1_s' with this signature

Parent topic: COBCH0881 - COBCH0900


COBCH0899 Class constructors cannot have parameters

Parent topic: COBCH0881 - COBCH0900


COBCH0900 Internal error - Stack overflow_ Inform Technical Support_

Parent topic: COBCH0881 - COBCH0900


Messages COBCH0901 to COBCH1000

  • COBCH0901 - COBCH0920
    Lists the Syntax Checking error messages from COBCH0901 through COBCH0920.
  • COBCH0921 - COBCH0940
    Lists the Syntax Checking error messages from COBCH0921 through COBCH0940.
  • COBCH0941 - COBCH0960
    Lists the Syntax Checking error messages from COBCH0941 through COBCH0960.
  • COBCH0961 - COBCH0980
    Lists the Syntax Checking error messages from COBCH0961 through COBCH0980.
  • COBCH0981 - COBCH1000
    Lists the Syntax Checking error messages from COBCH0981 through COBCH1000.
Parent topic: Syntax Checking Error Messages


COBCH0901 - COBCH0920

Lists the Syntax Checking error messages from COBCH0901 through COBCH0920.

  • COBCH0901 Internal error - Enlarge Memory overflow_ Inform Technical Support_
  • COBCH0902 Internal error - Restore String invalid_ Inform Technical Support_
  • COBCH0903 Internal error - Dictionary corruption_ Inform Technical Support_
  • COBCH0904 Internal error - Stack underflow_ Inform Technical Support_
  • COBCH0905 Internal error - Invalid tree node_ Inform Technical Support_
  • COBCH0906 Internal error - Subscript count overflow_ Inform Technical Support_
  • COBCH0907 Internal error - Debug info buffer overflow_ Inform Technical Support_
  • COBCH0908 Internal error - Verb processing error_ Inform Technical Support_
  • COBCH0909 Internal error - Bad numeric descriptor_ Inform Technical Support_
  • COBCH0910 Internal error - Int code buffer overflow_ Inform Technical Support_
  • COBCH0911 Internal error - Dictionary heap failure %1_s Inform Technical Support_
  • COBCH0912 Internal error - Dictionary invalid r_w %1_s Inform Technical Support_
  • COBCH0913 Internal error - Dictionary open_close failure_ Inform Technical Support_
  • COBCH0914 Internal error - Dictionary literal size error_ Inform Technical Support_
  • COBCH0915 Internal error - Error during repository processing_ Inform Technical Support_
  • COBCH0916 Internal error - Error opening cdi2 handle_
  • COBCH0917 Internal error - CTF failed_
  • COBCH0918 Unknown attribute '%1_s'
  • COBCH0919 An AS expression cannot be used as a receiving item
  • COBCH0920 Can only INVOKE a method or a constructor
Parent topic: Messages COBCH0901 to COBCH1000


COBCH0901 Internal error - Enlarge Memory overflow_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0902 Internal error - Restore String invalid_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0903 Internal error - Dictionary corruption_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0904 Internal error - Stack underflow_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0905 Internal error - Invalid tree node_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0906 Internal error - Subscript count overflow_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0907 Internal error - Debug info buffer overflow_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0908 Internal error - Verb processing error_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0909 Internal error - Bad numeric descriptor_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0910 Internal error - Int code buffer overflow_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0911 Internal error - Dictionary heap failure %1_s Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0912 Internal error - Dictionary invalid r_w %1_s Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0913 Internal error - Dictionary open_close failure_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0914 Internal error - Dictionary literal size error_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0915 Internal error - Error during repository processing_ Inform Technical Support_

Parent topic: COBCH0901 - COBCH0920


COBCH0916 Internal error - Error opening cdi2 handle_

Parent topic: COBCH0901 - COBCH0920


COBCH0917 Internal error - CTF failed_

Parent topic: COBCH0901 - COBCH0920


COBCH0918 Unknown attribute '%1_s'

Parent topic: COBCH0901 - COBCH0920


COBCH0919 An AS expression cannot be used as a receiving item

Parent topic: COBCH0901 - COBCH0920


COBCH0920 Can only INVOKE a method or a constructor

Parent topic: COBCH0901 - COBCH0920


COBCH0921 - COBCH0940

Lists the Syntax Checking error messages from COBCH0921 through COBCH0940.

  • COBCH0921 Comparison operator must return a condition-value
  • COBCH0922 Comparison operator must have two parameters that belong to current class
  • COBCH0923 Conversion operator must have one parameter and one return type
  • COBCH0924 Either the parameter or the return type must belong to current class
  • COBCH0925 Referenced non-managed module '%1_s' not found
  • COBCH0926 Array initializer has non-uniform structure_
  • COBCH0927 Table dimensions are different from original declaration_
  • COBCH0928 Must be interface implemented by current class_
  • COBCH0929 Operator must have one parameters
  • COBCH0930 Operator must have two parameters
  • COBCH0931 Operator must have one or two parameters
  • COBCH0932 At least one parameter must be of current class
  • COBCH0933 Operator is not defined for operands of this type
  • COBCH0934 Only native _NET types are allowed in Valuetype instances
  • COBCH0935 Operator parameters must be passed BY VALUE
  • COBCH0936 Number of operands does not match dimensions of table
  • COBCH0937 CUSTOM-ATTRIBUTE %1_s not allowed in this context
  • COBCH0938 Only native _NET types are allowed to have custom attributes
  • COBCH0939 CUSTOM-ATTRIBUTE %1_s is only allowed once
  • COBCH0940 PROPERTY and EVENT must be specified before CUSTOM-ATTRIBUTE
Parent topic: Messages COBCH0901 to COBCH1000


COBCH0921 Comparison operator must return a condition-value

Parent topic: COBCH0921 - COBCH0940


COBCH0922 Comparison operator must have two parameters that belong to current class

Parent topic: COBCH0921 - COBCH0940


COBCH0923 Conversion operator must have one parameter and one return type

Parent topic: COBCH0921 - COBCH0940


COBCH0924 Either the parameter or the return type must belong to current class

Parent topic: COBCH0921 - COBCH0940


COBCH0925 Referenced non-managed module '%1_s' not found

Parent topic: COBCH0921 - COBCH0940


COBCH0926 Array initializer has non-uniform structure_

Parent topic: COBCH0921 - COBCH0940


COBCH0927 Table dimensions are different from original declaration_

Parent topic: COBCH0921 - COBCH0940


COBCH0928 Must be interface implemented by current class_

Parent topic: COBCH0921 - COBCH0940


COBCH0929 Operator must have one parameters

Parent topic: COBCH0921 - COBCH0940


COBCH0930 Operator must have two parameters

Parent topic: COBCH0921 - COBCH0940


COBCH0931 Operator must have one or two parameters

Parent topic: COBCH0921 - COBCH0940


COBCH0932 At least one parameter must be of current class

Parent topic: COBCH0921 - COBCH0940


COBCH0933 Operator is not defined for operands of this type

Parent topic: COBCH0921 - COBCH0940


COBCH0934 Only native _NET types are allowed in Valuetype instances

Parent topic: COBCH0921 - COBCH0940


COBCH0935 Operator parameters must be passed BY VALUE

Parent topic: COBCH0921 - COBCH0940


COBCH0936 Number of operands does not match dimensions of table

Parent topic: COBCH0921 - COBCH0940


COBCH0937 CUSTOM-ATTRIBUTE %1_s not allowed in this context

Parent topic: COBCH0921 - COBCH0940


COBCH0938 Only native _NET types are allowed to have custom attributes

Parent topic: COBCH0921 - COBCH0940


COBCH0939 CUSTOM-ATTRIBUTE %1_s is only allowed once

Parent topic: COBCH0921 - COBCH0940


COBCH0940 PROPERTY and EVENT must be specified before CUSTOM-ATTRIBUTE

Parent topic: COBCH0921 - COBCH0940


COBCH0941 - COBCH0960

Lists the Syntax Checking error messages from COBCH0941 through COBCH0960.

  • COBCH0941 Source file %1_s not found
  • COBCH0942 Could not load assembly '%1_s'
  • COBCH0943 %1_s is not the name of a generic parameter
  • COBCH0944 Generic class '%1_s' has wrong number of type arguments
  • COBCH0945 One or more of the type arguments for '%1_s' violates constraints
  • COBCH0946 Class, method, property or field is marked as obsolete
  • COBCH0947 ANY LENGTH item cannot be RETURNING item when compiling for _NET
  • COBCH0948 Invalid type name
  • COBCH0949 Cannot use PROPERTY on an item that is subject to an OCCURS clause
  • COBCH0950 Too many generic arguments
  • COBCH0951 System limit - number of multiple inheritance _ 10_
  • COBCH0952 Method '%1_s' must have the REDEFINE clause_
  • COBCH0953 Method '%1_s' must have the OVERRIDE or REDEFINE clause_
  • COBCH0954 Method '%1_s' cannot OVERRIDE a non-virtual method in inherited class_
  • COBCH0955 Method '%1_s' cannot OVERRIDE a FINAL method in inherited class_
  • COBCH0956 Method '%1_s' not found in inherited class - must not have the OVERRIDE or REDEFINE clause_
  • COBCH0957 Explicit interface implementations cannot have visibility attributes_
  • COBCH0958 Property '%1_s' has multiple definitions
  • COBCH0959 Invalid _line directive_
  • COBCH0960 Too many _line directives_
Parent topic: Messages COBCH0901 to COBCH1000


COBCH0941 Source file %1_s not found

Parent topic: COBCH0941 - COBCH0960


COBCH0942 Could not load assembly '%1_s'

Parent topic: COBCH0941 - COBCH0960


COBCH0943 %1_s is not the name of a generic parameter

Parent topic: COBCH0941 - COBCH0960


COBCH0944 Generic class '%1_s' has wrong number of type arguments

Parent topic: COBCH0941 - COBCH0960


COBCH0945 One or more of the type arguments for '%1_s' violates constraints

Parent topic: COBCH0941 - COBCH0960


COBCH0946 Class, method, property or field is marked as obsolete

Parent topic: COBCH0941 - COBCH0960


COBCH0947 ANY LENGTH item cannot be RETURNING item when compiling for _NET

Parent topic: COBCH0941 - COBCH0960


COBCH0948 Invalid type name

Parent topic: COBCH0941 - COBCH0960


COBCH0949 Cannot use PROPERTY on an item that is subject to an OCCURS clause

Parent topic: COBCH0941 - COBCH0960


COBCH0950 Too many generic arguments

Parent topic: COBCH0941 - COBCH0960


COBCH0951 System limit - number of multiple inheritance _ 10_

Parent topic: COBCH0941 - COBCH0960


COBCH0952 Method '%1_s' must have the REDEFINE clause_

Parent topic: COBCH0941 - COBCH0960


COBCH0953 Method '%1_s' must have the OVERRIDE or REDEFINE clause_

Parent topic: COBCH0941 - COBCH0960


COBCH0954 Method '%1_s' cannot OVERRIDE a non-virtual method in inherited class_

Parent topic: COBCH0941 - COBCH0960


COBCH0955 Method '%1_s' cannot OVERRIDE a FINAL method in inherited class_

Parent topic: COBCH0941 - COBCH0960


COBCH0956 Method '%1_s' not found in inherited class - must not have the OVERRIDE or REDEFINE clause_

Parent topic: COBCH0941 - COBCH0960


COBCH0957 Explicit interface implementations cannot have visibility attributes_

Parent topic: COBCH0941 - COBCH0960


COBCH0958 Property '%1_s' has multiple definitions

Parent topic: COBCH0941 - COBCH0960


COBCH0959 Invalid _line directive_

Parent topic: COBCH0941 - COBCH0960


COBCH0960 Too many _line directives_

Parent topic: COBCH0941 - COBCH0960


COBCH0961 - COBCH0980

Lists the Syntax Checking error messages from COBCH0961 through COBCH0980.

  • COBCH0961 Overriding method '%1_s' must have visibility 'PRIVATE'_
  • COBCH0962 Overriding method '%1_s' must have visibility 'INTERNAL'_
  • COBCH0963 Overriding method '%1_s' must have visibility 'PROTECTED'_
  • COBCH0964 Overriding method '%1_s' must have visibility 'PROTECTED INTERNAL'_
  • COBCH0965 Overriding method '%1_s' must have visibility 'PUBLIC'_
  • COBCH0966 Either all or no dimensions must be specified using ANY_
  • COBCH0967 Class '%1_s' inherits from itself (directly or indirectly)_
  • COBCH0968 Collection element has incompatible type
  • COBCH0969 Cannot access object data from a static method
  • COBCH0970 Class '%1_s' inherits from more than one base class
  • COBCH0971 EXTERNAL not allowed with instance data
  • COBCH0972 Linkage item '%1_s' is referenced but has no addressability_
  • COBCH0973 Must specify at least one CATCH or FINALLY clause_
  • COBCH0974 Inherited class does not have a default constructor_
  • COBCH0975 An anonymous method can only be used as a parameter to a delegate constructor_
  • COBCH0976 SET CONTENT syntax cannot be used with jagged arrays_
  • COBCH0977 Anonymous method signature does not match that of delegate_
  • COBCH0978 Anonymous method returning item does not match that of delegate_
  • COBCH0979 Anonymous method parameter must be new item specified with AS clause_
  • COBCH0980 YIELDING phrase can only be used in the context of an iterator_
Parent topic: Messages COBCH0901 to COBCH1000


COBCH0961 Overriding method '%1_s' must have visibility 'PRIVATE'_

Parent topic: COBCH0961 - COBCH0980


COBCH0962 Overriding method '%1_s' must have visibility 'INTERNAL'_

Parent topic: COBCH0961 - COBCH0980


COBCH0963 Overriding method '%1_s' must have visibility 'PROTECTED'_

Parent topic: COBCH0961 - COBCH0980


COBCH0964 Overriding method '%1_s' must have visibility 'PROTECTED INTERNAL'_

Parent topic: COBCH0961 - COBCH0980


COBCH0965 Overriding method '%1_s' must have visibility 'PUBLIC'_

Parent topic: COBCH0961 - COBCH0980


COBCH0966 Either all or no dimensions must be specified using ANY_

Parent topic: COBCH0961 - COBCH0980


COBCH0967 Class '%1_s' inherits from itself (directly or indirectly)_

Parent topic: COBCH0961 - COBCH0980


COBCH0968 Collection element has incompatible type

Parent topic: COBCH0961 - COBCH0980


COBCH0969 Cannot access object data from a static method

Parent topic: COBCH0961 - COBCH0980


COBCH0970 Class '%1_s' inherits from more than one base class

Parent topic: COBCH0961 - COBCH0980


COBCH0971 EXTERNAL not allowed with instance data

Parent topic: COBCH0961 - COBCH0980


COBCH0972 Linkage item '%1_s' is referenced but has no addressability_

Parent topic: COBCH0961 - COBCH0980


COBCH0973 Must specify at least one CATCH or FINALLY clause_

Parent topic: COBCH0961 - COBCH0980


COBCH0974 Inherited class does not have a default constructor_

Parent topic: COBCH0961 - COBCH0980


COBCH0975 An anonymous method can only be used as a parameter to a delegate constructor_

Parent topic: COBCH0961 - COBCH0980


COBCH0976 SET CONTENT syntax cannot be used with jagged arrays_

Parent topic: COBCH0961 - COBCH0980


COBCH0977 Anonymous method signature does not match that of delegate_

Parent topic: COBCH0961 - COBCH0980


COBCH0978 Anonymous method returning item does not match that of delegate_

Parent topic: COBCH0961 - COBCH0980


COBCH0979 Anonymous method parameter must be new item specified with AS clause_

Parent topic: COBCH0961 - COBCH0980


COBCH0980 YIELDING phrase can only be used in the context of an iterator_

Parent topic: COBCH0961 - COBCH0980


COBCH0981 - COBCH1000

Lists the Syntax Checking error messages from COBCH0981 through COBCH1000.

  • COBCH0981 YIELDING phrase must be used in the context of an iterator_
  • COBCH0982 Statement can only be used in the context of an iterator_
  • COBCH0983 Cannot initialize MicroFocus_COBOL_Compiler_dll_
  • COBCH0984 Could not find suitable '%1_s' method_
  • COBCH0985 Attribute class has multiple constructors with equally valid signature
  • COBCH0986 A method invoke cannot be a receiving item
  • COBCH0987 Could not find method '%1_s' with this signature - will generate dynamic call
  • COBCH0988 Operand must be Boolean
  • COBCH0989 GROUP-USAGE must be NATIONAL or BIT
  • COBCH0990 No period following EXEC SQL INCLUDE END-EXEC_ DB2 coprocessor will fail
  • COBCH0991 A readonly field cannot be a receiving item
  • COBCH0992 Program requires setting of INTLEVEL(4)
  • COBCH0993 Number of parameters in CALL (%1_s) different from number in target method (%2_s)
  • COBCH0994 Illegal function argument
  • COBCH0995 Iterator parameters must be passed BY VALUE
  • COBCH0996 A class can only be PUBLIC or INTERNAL
  • COBCH0997 Feature not yet supported when compiling for _NET - statement ignored
  • COBCH0998 Can only be PUBLIC or INTERNAL
  • COBCH0999 PROFILE directive ignored for nested programs
  • COBCH1000 Open fail _ %1_s
Parent topic: Messages COBCH0901 to COBCH1000


COBCH0981 YIELDING phrase must be used in the context of an iterator_

Parent topic: COBCH0981 - COBCH1000


COBCH0982 Statement can only be used in the context of an iterator_

Parent topic: COBCH0981 - COBCH1000


COBCH0983 Cannot initialize MicroFocus_COBOL_Compiler_dll_

Parent topic: COBCH0981 - COBCH1000


COBCH0984 Could not find suitable '%1_s' method_

Parent topic: COBCH0981 - COBCH1000


COBCH0985 Attribute class has multiple constructors with equally valid signature

Parent topic: COBCH0981 - COBCH1000


COBCH0986 A method invoke cannot be a receiving item

Parent topic: COBCH0981 - COBCH1000


COBCH0987 Could not find method '%1_s' with this signature - will generate dynamic call

Parent topic: COBCH0981 - COBCH1000


COBCH0988 Operand must be Boolean

Parent topic: COBCH0981 - COBCH1000


COBCH0989 GROUP-USAGE must be NATIONAL or BIT

Parent topic: COBCH0981 - COBCH1000


COBCH0990 No period following EXEC SQL INCLUDE END-EXEC_ DB2 coprocessor will fail

Parent topic: COBCH0981 - COBCH1000


COBCH0991 A readonly field cannot be a receiving item

Parent topic: COBCH0981 - COBCH1000


COBCH0992 Program requires setting of INTLEVEL(4)

Parent topic: COBCH0981 - COBCH1000


COBCH0993 Number of parameters in CALL (%1_s) different from number in target method (%2_s)

Parent topic: COBCH0981 - COBCH1000


COBCH0994 Illegal function argument

Parent topic: COBCH0981 - COBCH1000


COBCH0995 Iterator parameters must be passed BY VALUE

Parent topic: COBCH0981 - COBCH1000


COBCH0996 A class can only be PUBLIC or INTERNAL

Parent topic: COBCH0981 - COBCH1000


COBCH0997 Feature not yet supported when compiling for _NET - statement ignored

Parent topic: COBCH0981 - COBCH1000


COBCH0998 Can only be PUBLIC or INTERNAL

Parent topic: COBCH0981 - COBCH1000


COBCH0999 PROFILE directive ignored for nested programs

Parent topic: COBCH0981 - COBCH1000


COBCH1000 Open fail _ %1_s

Parent topic: COBCH0981 - COBCH1000


Messages COBCH1001 to COBCH1100

  • COBCH1001 - COBCH1020
    Lists the Syntax Checking error messages from COBCH1001 through COBCH1020.
  • COBCH1021 - COBCH1040
    Lists the Syntax Checking error messages from COBCH1021 through COBCH1040.
  • COBCH1041 - COBCH1060
    Lists the Syntax Checking error messages from COBCH1041 through COBCH1060.
  • COBCH1061 - COBCH1080
    Lists the Syntax Checking error messages from COBCH1061 through COBCH1080.
  • COBCH1081 - COBCH1100
    Lists the Syntax Checking error messages from COBCH1081 through COBCH1100.
Parent topic: Syntax Checking Error Messages


COBCH1001 - COBCH1020

Lists the Syntax Checking error messages from COBCH1001 through COBCH1020.

  • COBCH1001 Character other than *, D, /, -, or $ found in column 7. Blank assumed
    You might have mistyped one of the characters allowed in column 7. Your COBOL system cannot interpret the character in column 7, and has treated it as a space.
  • COBCH1002 Continuation character invalid at this point. Blank assumed
    You have placed a hyphen in column 7, though your COBOL system is not expecting the syntax to be continued at this point. The continuation character is ignored.
  • COBCH1003 First character of a continued literal not a quote. Quote assumed
    You have included a continuation character in column 7, but you have forgotten to start the continuation of the literal with a quotation mark. Your COBOL system assumes that the quotation mark is included.
  • COBCH1004 Continuation character expected. End of literal assumed
    The literal in the previous line of source code is not delimited by quotation marks, so your COBOL system is expecting a continuation character in column 7, and a continuation of the literal. Your COBOL system has assumed that you meant to end the literal on the previous line.
  • COBCH1005 Name ends in hyphen. Processed as written
    You have used a hyphen as the last character in a user-defined-name, which is against the rules of COBOL syntax. Your COBOL system has accepted this as a valid name, however, and has not changed the name in any way.
  • COBCH1006 COBOL word contains more than 31 characters. Word truncated
    The name that you have specified is longer than 31 characters. Your COBOL system treats this as a name consisting of the first 31 characters of your original name.
  • COBCH1007 VALUE literal size size1 > data item size size2. Literal truncated
    The literal you have specified in the VALUE clause is too long to fit into the data item. Your COBOL system inserts characters from the literal into the data item, until the data item is full.
  • COBCH1008 DBCS literal must contain an even number of characters. Literal truncated
    All Double Byte Character Set (DBCS) symbols are two bytes (two characters) long. You have specified a literal that consists of an odd number of characters. Your COBOL system ignores the last, single character of the literal.
  • COBCH1009 Closing delimiter for DBCS literal not found. Delimiter assumed
    You have not included the quotation mark to show the end of the Double Byte Character Set (DBCS) literal. Your COBOL system has assumed that you intended to end the literal at this point.
  • COBCH1010 Nonnumeric literal has length of zero. One SPACE assumed
    The alphabetic or alphanumeric literal you have defined in your source code is empty, that is, you have a pair of quotation marks with no character between them. Your COBOL system has assumed that the literal contains one space character.
  • COBCH1011 DBCS literal has length of zero. Length of one DBCS character assumed
    The Double Byte Character Set (DBCS) literal you have defined in your source code is empty, that is, you have a pair of quotation marks with no DBCS character between them. Your COBOL system has assumed that the literal is two characters long, and that it has a value of spaces.
  • COBCH1012 DIVISION missing or misspelled. DIVISION assumed
    You have omitted the word DIVISION from a Division header, or you have spelled it incorrectly. Your COBOL system has assumed that DIVISION is what was meant.
  • COBCH1013 SECTION missing or misspelled. SECTION assumed
    You have omitted the word SECTION from a Section header, or you have spelled it incorrectly. Your COBOL system has assumed that SECTION is what was meant.
  • COBCH1014 Period missing. Period assumed
    You have omitted a period in a place where one is expected by the rules of COBOL syntax. Your COBOL system has assumed the period is present.
  • COBCH1015 OCCURS integer-1 exceeds OCCURS integer-2. Zero is assumed for integer-1
    You have included the OCCURS integer-1 TO integer-2 DEPENDING clause in your source code, but the value given for integer-1 is greater than that for integer-2, which is against the rules of COBOL syntax. Your COBOL system has effectively changed the value of integer-1 to 0.
  • COBCH1016 Expected SEPARATE before CHARACTER in SIGN clause. SEPARATE assumed
    You have incorrectly coded the SIGN clause because you have included the word CHARACTER, which is not required, but you have omitted the required word SEPARATE. Your COBOL system has assumed that you intended the clause to be SIGN IS LEADING (or TRAILING) SEPARATE CHARACTER.
  • COBCH1017 REDEFINES ignored for 01 level item in File or Communication Section
    You have tried to REDEFINE a data item in the File or Communication Section but the data item is an 01 level item. Level 01 items for the same FD or CD automatically redefine one another.
  • COBCH1018 VALUE clause not allowed here. Clause processed as comment
    You have tried to assign a value to a data item defined in the File Section or the Linkage Section. The VALUE clause is ignored.
  • COBCH1019 Unsigned numeric literal expected. Sign ignored
    You have specified a sign where one is not expected, for example, you have used the AFTER ADVANCING +1 or BEFORE ADVANCING -2 clause to the WRITE statement. Your COBOL system ignores the sign, and treats the digits as a positive value.
  • COBCH1020 Unsigned numeric field. Sign in VALUE clause ignored
    You have defined a numeric data item (that is, PIC 9) and you have tried to assign a signed number as its value. Your COBOL system ignores the sign you have specified. Where you are trying to move a number with a negative sign into a numeric field, the result is not as expected.
Parent topic: Messages COBCH1001 to COBCH1100


COBCH1001 Character other than *, D, /, -, or $ found in column 7. Blank assumed

You might have mistyped one of the characters allowed in column 7. Your COBOL system cannot interpret the character in column 7, and has treated it as a space.
Parent topic: COBCH1001 - COBCH1020


COBCH1002 Continuation character invalid at this point. Blank assumed

You have placed a hyphen in column 7, though your COBOL system is not expecting the syntax to be continued at this point. The continuation character is ignored.
Parent topic: COBCH1001 - COBCH1020


COBCH1003 First character of a continued literal not a quote. Quote assumed

You have included a continuation character in column 7, but you have forgotten to start the continuation of the literal with a quotation mark. Your COBOL system assumes that the quotation mark is included.
Parent topic: COBCH1001 - COBCH1020


COBCH1004 Continuation character expected. End of literal assumed

The literal in the previous line of source code is not delimited by quotation marks, so your COBOL system is expecting a continuation character in column 7, and a continuation of the literal. Your COBOL system has assumed that you meant to end the literal on the previous line.
Parent topic: COBCH1001 - COBCH1020


COBCH1005 Name ends in hyphen. Processed as written

You have used a hyphen as the last character in a user-defined-name, which is against the rules of COBOL syntax. Your COBOL system has accepted this as a valid name, however, and has not changed the name in any way.
Parent topic: COBCH1001 - COBCH1020


COBCH1006 COBOL word contains more than 31 characters. Word truncated

The name that you have specified is longer than 31 characters. Your COBOL system treats this as a name consisting of the first 31 characters of your original name.
Parent topic: COBCH1001 - COBCH1020


COBCH1007 VALUE literal size size1 > data item size size2. Literal truncated

The literal you have specified in the VALUE clause is too long to fit into the data item. Your COBOL system inserts characters from the literal into the data item, until the data item is full.
Parent topic: COBCH1001 - COBCH1020


COBCH1008 DBCS literal must contain an even number of characters. Literal truncated

All Double Byte Character Set (DBCS) symbols are two bytes (two characters) long. You have specified a literal that consists of an odd number of characters. Your COBOL system ignores the last, single character of the literal.
Parent topic: COBCH1001 - COBCH1020


COBCH1009 Closing delimiter for DBCS literal not found. Delimiter assumed

You have not included the quotation mark to show the end of the Double Byte Character Set (DBCS) literal. Your COBOL system has assumed that you intended to end the literal at this point.
Parent topic: COBCH1001 - COBCH1020


COBCH1010 Nonnumeric literal has length of zero. One SPACE assumed

The alphabetic or alphanumeric literal you have defined in your source code is empty, that is, you have a pair of quotation marks with no character between them. Your COBOL system has assumed that the literal contains one space character.
Parent topic: COBCH1001 - COBCH1020


COBCH1011 DBCS literal has length of zero. Length of one DBCS character assumed

The Double Byte Character Set (DBCS) literal you have defined in your source code is empty, that is, you have a pair of quotation marks with no DBCS character between them. Your COBOL system has assumed that the literal is two characters long, and that it has a value of spaces.
Parent topic: COBCH1001 - COBCH1020


COBCH1012 DIVISION missing or misspelled. DIVISION assumed

You have omitted the word DIVISION from a Division header, or you have spelled it incorrectly. Your COBOL system has assumed that DIVISION is what was meant.
Parent topic: COBCH1001 - COBCH1020


COBCH1013 SECTION missing or misspelled. SECTION assumed

You have omitted the word SECTION from a Section header, or you have spelled it incorrectly. Your COBOL system has assumed that SECTION is what was meant.
Parent topic: COBCH1001 - COBCH1020


COBCH1014 Period missing. Period assumed

You have omitted a period in a place where one is expected by the rules of COBOL syntax. Your COBOL system has assumed the period is present.
Parent topic: COBCH1001 - COBCH1020


COBCH1015 OCCURS integer-1 exceeds OCCURS integer-2. Zero is assumed for integer-1

You have included the OCCURS integer-1 TO integer-2 DEPENDING clause in your source code, but the value given for integer-1 is greater than that for integer-2, which is against the rules of COBOL syntax. Your COBOL system has effectively changed the value of integer-1 to 0.
Parent topic: COBCH1001 - COBCH1020


COBCH1016 Expected SEPARATE before CHARACTER in SIGN clause. SEPARATE assumed

You have incorrectly coded the SIGN clause because you have included the word CHARACTER, which is not required, but you have omitted the required word SEPARATE. Your COBOL system has assumed that you intended the clause to be SIGN IS LEADING (or TRAILING) SEPARATE CHARACTER.
Parent topic: COBCH1001 - COBCH1020


COBCH1017 REDEFINES ignored for 01 level item in File or Communication Section

You have tried to REDEFINE a data item in the File or Communication Section but the data item is an 01 level item. Level 01 items for the same FD or CD automatically redefine one another.
Parent topic: COBCH1001 - COBCH1020


COBCH1018 VALUE clause not allowed here. Clause processed as comment

You have tried to assign a value to a data item defined in the File Section or the Linkage Section. The VALUE clause is ignored.
Parent topic: COBCH1001 - COBCH1020


COBCH1019 Unsigned numeric literal expected. Sign ignored

You have specified a sign where one is not expected, for example, you have used the AFTER ADVANCING +1 or BEFORE ADVANCING -2 clause to the WRITE statement. Your COBOL system ignores the sign, and treats the digits as a positive value.
Parent topic: COBCH1001 - COBCH1020


COBCH1020 Unsigned numeric field. Sign in VALUE clause ignored

You have defined a numeric data item (that is, PIC 9) and you have tried to assign a signed number as its value. Your COBOL system ignores the sign you have specified. Where you are trying to move a number with a negative sign into a numeric field, the result is not as expected.
Parent topic: COBCH1001 - COBCH1020


COBCH1021 - COBCH1040

Lists the Syntax Checking error messages from COBCH1021 through COBCH1040.

  • COBCH1021 Slack bytes added in conversion of COMP-6 to COMP
    You are using a program converted from RM/COBOL that contains a COMP-6 numeric data item which has been converted to a COMP numeric data item. As a result of this conversion, less data space might have been allocated to the numeric data item and, therefore, your COBOL system adds leading binary zeros to pad the space, if required.
  • COBCH1022 Table item not subscripted or indexed. First occurrence assumed
  • COBCH1023 WORKING-STORAGE SECTION expected. Start of Working-Storage assumed
    Your program begins with an 01 level entry. It is assumed that this is the first item of the Working-Storage Section.
  • COBCH1024 VALUE clause literal does not conform to PICTURE. Changed to blanks.
    A numeric value has been specified for a nonnumeric data item. The data item is filled with spaces.
  • COBCH1025 MOVE edited field to edited field - treated as alphanumeric move
    A move of one edited field to another is treated as an alphanumeric move.
  • COBCH1026 Source literal is nonnumeric - substituting zero
    A MOVE statement is trying to MOVE a nonnumeric literal to a numeric data item. This cannot be done. To avoid undefined results, ZERO is moved to the target data item.
  • COBCH1027 Literal is numeric - treated as nonnumeric
    A numeric literal is being used in relation to a nonnumeric data item; for example, as the VALUE of an 88 level entry attached to a nonnumeric data item. The literal is converted to an alphanumeric literal.
  • COBCH1028 Statement should not reference an alphabetic data item
    A statement would cause invalid data to be contained in an alphabetic data item. Your COBOL system executes the statement as written.
  • COBCH1029 A non-integer is being moved to an alphanumeric data item
    A MOVE statement is trying to move a noninteger item to an alphanumeric data item. The decimal point is ignored and all the digits moved as if they constituted an integer.
  • COBCH1030 Cannot SORT or MERGE USING or GIVING two files with SAME AREA
    Two files specified in a SORT or MERGE statement are defined as sharing the same area. The files are allocated different areas.
  • COBCH1031 SORT file appears in more than one SAME SORT (-MERGE) AREA clause
    A SORT file has been referenced in more than one SAME SORT (-MERGE) AREA clause. The files are allocated different areas.
  • COBCH1032 Filenames illegally specified in same SAME RECORD AREA clause
    Two files in a SORT or MERGE statement are defined as sharing the same record area. The files are allocated different record areas.
  • COBCH1033 Filenames illegally specified in same SAME SORT (-MERGE) AREA clause
    Two files in a SORT or MERGE statement are defined as sharing the same sort (-merge) area. The files are allocated different sort-merge areas.
  • COBCH1034 Source item is ALPHABETIC or ALPHANUMERIC-EDITED - treated as alphanumeric
    You have moved either an alphabetic, alphabetic justified, edited alphabetic or edited alphanumeric field to a numeric display field. The source field has been treated as though it were a numeric field.
  • COBCH1035 Key is not wholly contained within minimum record length
    The specified key is greater in length than the minimum size of the record.
  • COBCH1036 External name illegal
    An external name, such as program-id or an entry name does not conform to the syntax rules for that item.
  • COBCH1037 Data-name must be specified for an EXTERNAL record - EXTERNAL ignored
    Related Topics
  • COBCH1038 RECORD key or ALTERNATE key has same starting position as another key
    The specified key has the same starting position in the file's record as a previously defined key.
  • COBCH1039 Error in structure information. No structure diagram created
    You are trying to perform structure animation of a program in which a PERFORM THRU statement performs sections in the Declaratives.
  • COBCH1040 ALL not allowed here - ALL ignored
    Related Topics
Parent topic: Messages COBCH1001 to COBCH1100


COBCH1021 Slack bytes added in conversion of COMP-6 to COMP

You are using a program converted from RM/COBOL that contains a COMP-6 numeric data item which has been converted to a COMP numeric data item. As a result of this conversion, less data space might have been allocated to the numeric data item and, therefore, your COBOL system adds leading binary zeros to pad the space, if required.
Parent topic: COBCH1021 - COBCH1040


COBCH1022 Table item not subscripted or indexed. First occurrence assumed

Parent topic: COBCH1021 - COBCH1040


COBCH1023 WORKING-STORAGE SECTION expected. Start of Working-Storage assumed

Your program begins with an 01 level entry. It is assumed that this is the first item of the Working-Storage Section.
Parent topic: COBCH1021 - COBCH1040


COBCH1024 VALUE clause literal does not conform to PICTURE. Changed to blanks.

A numeric value has been specified for a nonnumeric data item. The data item is filled with spaces.
Parent topic: COBCH1021 - COBCH1040


COBCH1025 MOVE edited field to edited field - treated as alphanumeric move

A move of one edited field to another is treated as an alphanumeric move.
Parent topic: COBCH1021 - COBCH1040


COBCH1026 Source literal is nonnumeric - substituting zero

A MOVE statement is trying to MOVE a nonnumeric literal to a numeric data item. This cannot be done. To avoid undefined results, ZERO is moved to the target data item.
Parent topic: COBCH1021 - COBCH1040


COBCH1027 Literal is numeric - treated as nonnumeric

A numeric literal is being used in relation to a nonnumeric data item; for example, as the VALUE of an 88 level entry attached to a nonnumeric data item. The literal is converted to an alphanumeric literal.
Parent topic: COBCH1021 - COBCH1040


COBCH1028 Statement should not reference an alphabetic data item

A statement would cause invalid data to be contained in an alphabetic data item. Your COBOL system executes the statement as written.
Parent topic: COBCH1021 - COBCH1040


COBCH1029 A non-integer is being moved to an alphanumeric data item

A MOVE statement is trying to move a noninteger item to an alphanumeric data item. The decimal point is ignored and all the digits moved as if they constituted an integer.
Parent topic: COBCH1021 - COBCH1040


COBCH1030 Cannot SORT or MERGE USING or GIVING two files with SAME AREA

Two files specified in a SORT or MERGE statement are defined as sharing the same area. The files are allocated different areas.
Parent topic: COBCH1021 - COBCH1040


COBCH1031 SORT file appears in more than one SAME SORT (-MERGE) AREA clause

A SORT file has been referenced in more than one SAME SORT (-MERGE) AREA clause. The files are allocated different areas.
Parent topic: COBCH1021 - COBCH1040


COBCH1032 Filenames illegally specified in same SAME RECORD AREA clause

Two files in a SORT or MERGE statement are defined as sharing the same record area. The files are allocated different record areas.
Parent topic: COBCH1021 - COBCH1040


COBCH1033 Filenames illegally specified in same SAME SORT (-MERGE) AREA clause

Two files in a SORT or MERGE statement are defined as sharing the same sort (-merge) area. The files are allocated different sort-merge areas.
Parent topic: COBCH1021 - COBCH1040


COBCH1034 Source item is ALPHABETIC or ALPHANUMERIC-EDITED - treated as alphanumeric

You have moved either an alphabetic, alphabetic justified, edited alphabetic or edited alphanumeric field to a numeric display field. The source field has been treated as though it were a numeric field.
Parent topic: COBCH1021 - COBCH1040


COBCH1035 Key is not wholly contained within minimum record length

The specified key is greater in length than the minimum size of the record.
Parent topic: COBCH1021 - COBCH1040


COBCH1036 External name illegal

An external name, such as program-id or an entry name does not conform to the syntax rules for that item.

Correct the syntax and recompile the code.

See the section COBOL Language Reference for more details on the required syntax.

Parent topic: COBCH1021 - COBCH1040


COBCH1037 Data-name must be specified for an EXTERNAL record - EXTERNAL ignored

Related Topics
Parent topic: COBCH1021 - COBCH1040


COBCH1038 RECORD key or ALTERNATE key has same starting position as another key

The specified key has the same starting position in the file's record as a previously defined key.
Parent topic: COBCH1021 - COBCH1040


COBCH1039 Error in structure information. No structure diagram created

You are trying to perform structure animation of a program in which a PERFORM THRU statement performs sections in the Declaratives.

Resolution:

Normal animation can be performed, but not structure animation.

Parent topic: COBCH1021 - COBCH1040


COBCH1040 ALL not allowed here - ALL ignored

Related Topics
Parent topic: COBCH1021 - COBCH1040


COBCH1041 - COBCH1060

Lists the Syntax Checking error messages from COBCH1041 through COBCH1060.

  • COBCH1041 Data item has zero size, or group not yet completed. Value of 0 assumed
  • COBCH1042 A numeric item is being moved to an ALPHABETIC data item
    Related Topics
  • COBCH1043 PERFORM may be recursive
    Related Topics
  • COBCH1044 Load failure on SLOAD - STRUCT ignored
  • COBCH1045 Capacity of POINTER may be exceeded
    Related Topics
  • COBCH1046 Host variable name might cause problems
  • COBCH1047 Phrase ignored - unsuccessful chain will cause program termination
  • COBCH1048 DBCS literal includes invalid data
  • COBCH1049 KEY clause not allowed with sequential READ - clause ignored
    Related Topics
  • COBCH1050 Invalid condition in $IF
    Related Topics
  • COBCH1051 Value evaluated left to right, differs from normal arithmetic precedence
  • COBCH1052 ALL specified more than once - repeated occurrences ignored
    You have specified the word ALL more than once in an ALL literal.
  • COBCH1053 Multiple 01 level EXTERNAL records with same name - treated as same record
    Related Topics
  • COBCH1054 Variable length group redefines or is redefined
  • COBCH1055 Requested SQLSTDLVL incompatible with your version of DBM. Directive ignored
    You have specified a directive which has no meaning on your database manager
  • COBCH1056 CALL-CONVENTION does not match that specified in prototype
    Related Topics
  • COBCH1057 REFERENCE/ CONTENT/ VALUE phrase does not match that specified in prototype
    Related Topics
  • COBCH1058 Number of parameters is greater than in prototype
  • COBCH1059 Parameter is not consistent with that defined in prototype
  • COBCH1060 Can only use DELIMITED with alphanumeric items
    Related Topics
Parent topic: Messages COBCH1001 to COBCH1100


COBCH1041 Data item has zero size, or group not yet completed. Value of 0 assumed

Parent topic: COBCH1041 - COBCH1060


COBCH1042 A numeric item is being moved to an ALPHABETIC data item

Related Topics
Parent topic: COBCH1041 - COBCH1060


COBCH1043 PERFORM may be recursive

Related Topics
Parent topic: COBCH1041 - COBCH1060


COBCH1044 Load failure on SLOAD - STRUCT ignored

Parent topic: COBCH1041 - COBCH1060


COBCH1045 Capacity of POINTER may be exceeded

Related Topics
Parent topic: COBCH1041 - COBCH1060


COBCH1046 Host variable name might cause problems

Parent topic: COBCH1041 - COBCH1060


COBCH1047 Phrase ignored - unsuccessful chain will cause program termination

Parent topic: COBCH1041 - COBCH1060


COBCH1048 DBCS literal includes invalid data

Parent topic: COBCH1041 - COBCH1060


COBCH1049 KEY clause not allowed with sequential READ - clause ignored

Related Topics
Parent topic: COBCH1041 - COBCH1060


COBCH1050 Invalid condition in $IF

Related Topics
Parent topic: COBCH1041 - COBCH1060


COBCH1051 Value evaluated left to right, differs from normal arithmetic precedence

Parent topic: COBCH1041 - COBCH1060


COBCH1052 ALL specified more than once - repeated occurrences ignored

You have specified the word ALL more than once in an ALL literal.

Resolution:

We recommend that you remove any repetition of the word ALL, although any further occurrences are actually ignored.

Parent topic: COBCH1041 - COBCH1060


COBCH1053 Multiple 01 level EXTERNAL records with same name - treated as same record

Related Topics
Parent topic: COBCH1041 - COBCH1060


COBCH1054 Variable length group redefines or is redefined

Parent topic: COBCH1041 - COBCH1060


COBCH1055 Requested SQLSTDLVL incompatible with your version of DBM. Directive ignored

You have specified a directive which has no meaning on your database manager
Parent topic: COBCH1041 - COBCH1060


COBCH1056 CALL-CONVENTION does not match that specified in prototype

Related Topics
Parent topic: COBCH1041 - COBCH1060


COBCH1057 REFERENCE/ CONTENT/ VALUE phrase does not match that specified in prototype

Related Topics
Parent topic: COBCH1041 - COBCH1060


COBCH1058 Number of parameters is greater than in prototype

Parent topic: COBCH1041 - COBCH1060


COBCH1059 Parameter is not consistent with that defined in prototype

Parent topic: COBCH1041 - COBCH1060


COBCH1060 Can only use DELIMITED with alphanumeric items

Related Topics
Parent topic: COBCH1041 - COBCH1060


COBCH1061 - COBCH1080

Lists the Syntax Checking error messages from COBCH1061 through COBCH1080.

  • COBCH1061 Number of parameters is less than in prototype
    Related Topics
  • COBCH1062 Not allowed in EXTERNAL program
    Related Topics
  • COBCH1063 EXTERNAL not allowed with nested, INITIAL or COMMON programs - ignored
    Related Topics
  • COBCH1064 Illegal use of literal
    Related Topics
  • COBCH1065 OO: SELF only allowed in CLASS program
    Related Topics
  • COBCH1066 OO: SUPER not allowed - CLASS has no INHERITING phrase
    Related Topics
  • COBCH1067 OO: RETURNING phrase not allowed in METHOD
    Related Topics
  • COBCH1068 OO: Class name class-name missing in SPECIAL-NAMES - assumed
  • COBCH1069 Identifier in area A assumed procedure name. Period missing before it
  • COBCH1070 OO: Incorrect structure of CLASS program
    Related Topics
  • COBCH1071 OO: Missing OBJECT-STORAGE SECTION, required for inheritance
    Related Topics
  • COBCH1072 OO: Not allowed in PROGRAM-ID. OBJECT
    Related Topics
  • COBCH1073 LOCAL-STORAGE should be used with PERFORM-TYPE(MF).
    Related Topics
  • COBCH1074 OO: INVOKE data-item not yet supported by OOPS run-time
    Related Topics
  • COBCH1075 Invalid combination of RECORD and RECORDING MODE clauses
    Related Topics
  • COBCH1076 Reference modified length should not be > 8191 at run-time
  • COBCH1077 Host variable name longer than permitted by database engine - truncated
  • COBCH1078 Setting of directives inline / conditional compilation
    Inline directives ($SET statements) and conditional compilation conflict with the selected flagging dialect.
  • COBCH1079 Expected positive integer, positive integer assumed
    You have used a negative integer where a positive integer was expected. Your COBOL system has ignored the negative sign.
  • COBCH1080 Odd number of hexadecimal digits
    Hexadecimal constants should be specified in pairs. The constant contains an odd number of characters and a leading zero has been assumed.
Parent topic: Messages COBCH1001 to COBCH1100


COBCH1061 Number of parameters is less than in prototype

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1062 Not allowed in EXTERNAL program

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1063 EXTERNAL not allowed with nested, INITIAL or COMMON programs - ignored

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1064 Illegal use of literal

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1065 OO: SELF only allowed in CLASS program

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1066 OO: SUPER not allowed - CLASS has no INHERITING phrase

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1067 OO: RETURNING phrase not allowed in METHOD

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1068 OO: Class name class-name missing in SPECIAL-NAMES - assumed

A common cause of this error is the omission of the word "type" in an inherit statement.

Parent topic: COBCH1061 - COBCH1080


COBCH1069 Identifier in area A assumed procedure name. Period missing before it

Parent topic: COBCH1061 - COBCH1080


COBCH1070 OO: Incorrect structure of CLASS program

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1071 OO: Missing OBJECT-STORAGE SECTION, required for inheritance

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1072 OO: Not allowed in PROGRAM-ID. OBJECT

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1073 LOCAL-STORAGE should be used with PERFORM-TYPE(MF).

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1074 OO: INVOKE data-item not yet supported by OOPS run-time

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1075 Invalid combination of RECORD and RECORDING MODE clauses

Related Topics
Parent topic: COBCH1061 - COBCH1080


COBCH1076 Reference modified length should not be > 8191 at run-time

Parent topic: COBCH1061 - COBCH1080


COBCH1077 Host variable name longer than permitted by database engine - truncated

Parent topic: COBCH1061 - COBCH1080


COBCH1078 Setting of directives inline / conditional compilation

Inline directives ($SET statements) and conditional compilation conflict with the selected flagging dialect.

Resolution:

Embedded directives may be set within a comment so that the code is compatible with the selected flagging dialect. To use this feature you must set the DIRECTIVES-IN-COMMENTS compiler directive.

Parent topic: COBCH1061 - COBCH1080


COBCH1079 Expected positive integer, positive integer assumed

You have used a negative integer where a positive integer was expected. Your COBOL system has ignored the negative sign.
Parent topic: COBCH1061 - COBCH1080


COBCH1080 Odd number of hexadecimal digits

Hexadecimal constants should be specified in pairs. The constant contains an odd number of characters and a leading zero has been assumed.
Parent topic: COBCH1061 - COBCH1080


COBCH1081 - COBCH1100

Lists the Syntax Checking error messages from COBCH1081 through COBCH1100.

  • COBCH1081 More than 255 BLL Cells
  • COBCH1082 Source line is too long
    You have coded a source line greater than 80 characters. Your chosen flagging dialect does not support this.
  • COBCH1083 RECORDING MODE IS F specified for a variable length record structure
    Related Topics
  • COBCH1084 OO: Missing OBJECT-STORAGE SECTION, required for class extension
    Related Topics
  • COBCH1085 Created subordinate data item item
  • COBCH1090 Literal contains SBCS Katakana characters
  • COBCH1091 Literal contains DBCS or SBCS Katakana characters
  • COBCH1092 SBCS Katakana character usage in source is not portable
  • COBCH1094 NOPRESERVECASE not supported with ILGEN. Consider removing NOPRESERVECASE.
Parent topic: Messages COBCH1001 to COBCH1100


COBCH1081 More than 255 BLL Cells

Parent topic: COBCH1081 - COBCH1100


COBCH1082 Source line is too long

You have coded a source line greater than 80 characters. Your chosen flagging dialect does not support this.
Parent topic: COBCH1081 - COBCH1100


COBCH1083 RECORDING MODE IS F specified for a variable length record structure

Related Topics
Parent topic: COBCH1081 - COBCH1100


COBCH1084 OO: Missing OBJECT-STORAGE SECTION, required for class extension

Related Topics
Parent topic: COBCH1081 - COBCH1100


COBCH1085 Created subordinate data item item

Parent topic: COBCH1081 - COBCH1100


COBCH1090 Literal contains SBCS Katakana characters

Parent topic: COBCH1081 - COBCH1100


COBCH1091 Literal contains DBCS or SBCS Katakana characters

Parent topic: COBCH1081 - COBCH1100


COBCH1092 SBCS Katakana character usage in source is not portable

Parent topic: COBCH1081 - COBCH1100


COBCH1094 NOPRESERVECASE not supported with ILGEN. Consider removing NOPRESERVECASE.

Parent topic: COBCH1081 - COBCH1100


Messages COBCH1101 to COBCH1200

  • COBCH1101 - COBCH1120
    Lists the Syntax Checking error messages from COBCH1101 through COBCH1120.
  • COBCH1121 - COBCH1140
    Lists the Syntax Checking error messages from COBCH1121 through COBCH1140.
  • COBCH1141 - COBCH1160
    Lists the Syntax Checking error messages from COBCH1141 through COBCH1160.
  • COBCH1161 - COBCH1180
    Lists the Syntax Checking error messages from COBCH1161 through COBCH1180.
  • COBCH1181 - COBCH1200
    Lists the Syntax Checking error messages from COBCH1181 through COBCH1200.
Parent topic: Syntax Checking Error Messages


COBCH1101 - COBCH1120

Lists the Syntax Checking error messages from COBCH1101 through COBCH1120.

  • COBCH1101 No COBOL statement between periods
    You have placed one period immediately following another period. This is not against the rules of COBOL syntax, but it might indicate a fault in your program, for example, you might have wanted to include a line of source code here.
  • COBCH1102 Blank continuation source line. Line ignored
    You have placed a hyphen in column 7, but the rest of the line contains no other code. The next line should also contain a hyphen in column 7, to continue correctly.
  • COBCH1103 Sequence number out of order or missing
  • COBCH1104 77 level item in File Section. Processed as 01 level
    You have assigned a level of 77 to a data item in the File Section which is against the rules of COBOL syntax. Your COBOL system assumes that you had intended to code this as an 01 level item, and processes it as such.
  • COBCH1105 No CORRESPONDING items were found. Statement has no effect
    Your COBOL system found no matching data items for the CORRESPONDING clause, so no intermediate code is produced for this statement.
  • COBCH1106 ZERO value for BY operand. Statement processed as written
    You have used the BY operand with the verb PERFORM, but the value you have specified for the increment is zero. Your COBOL system produces code to execute this statement, but the value is never incremented.
  • COBCH1107 Statement exceeds COMP subset
    The COMP subset code you have written could be rewritten to execute more efficiently.
  • COBCH1108 Signed numeric compared with group. Processed as alphanumeric compare
    You have written your code so that a signed numeric field is compared with a group item. Your COBOL system has treated the signed numeric field as an alphanumeric field for the comparison. There are no problems with comparing a signed numeric field with an elementary item.
  • COBCH1109 WITH DEBUGGING MODE not specified. Section ignored
    Your program includes the USE FOR DEBUGGING statement in a section in the Declaratives of your Procedure Division, but you have not included the WITH DEBUGGING MODE clause in the Source-Computer paragraph. Your COBOL system ignores all code in this section.
  • COBCH1110 First literal is greater than second. Processed as written
    In the ALPHABET clause the first literal that is specified has a value greater than that of the second, for example, P THRU D. Your COBOL system accepts this as written, that is, the characters are processed in reverse order.
  • COBCH1111 Boundary violation. Processed as written
    You have tried to access an item beyond the end of a table. Your COBOL system generates code to access the appropriate line of code beyond the end of the table, but the result of this is undefined.
  • COBCH1112 Compatibility directive forcing non standard behaviour
  • COBCH1113 Imperative statement missing - CONTINUE assumed
    Your program contains a conditional statement which has not been followed by an imperative statement. Your COBOL system executes the code, but the result of this might be undefined.
  • COBCH1114 Clause treated as documentary
    You have assigned more than one external file reference to a SELECT ... ASSIGN clause. Your COBOL system accepts the first external file reference, but treats all remaining external file references in that clause as documentary.
  • COBCH1115 SAME AREA treated as SAME RECORD AREA
    You are using a program converted from DG Interactive COBOL to this COBOL that contains a SAME AREA clause. Your COBOL system has assumed that the SAME RECORD AREA clause is what was meant.
  • COBCH1116 ACCEPT qualifier used with display-only field - qualifier ignored
    The qualifier used with a DISPLAY only field, or in a DISPLAY statement, can be used only with an ACCEPT. It is ignored.
  • COBCH1117 Zero suppression follows floating insertion - treated as floating insertion
    As an example, PIC ++Z.ZZ is treated as PIC +++.++.
  • COBCH1118 Index-name belongs to different table
    The index used to subscript a table item is not one used in the INDEXED BY clause for this table. The results are unpredictable.
  • COBCH1119 Record size size1 < minimum size given in FD statement size2
    The definition of a record following an FD clause is smaller than the minimum size specified in the RECORD CONTAINS phrase of that FD clause.
  • COBCH1120 Record size size1 > maximum size given in FD statement size2
    The definition of a record following an FD clause is larger than the maximum size specified in the RECORD CONTAINS phrase of that FD clause.
Parent topic: Messages COBCH1101 to COBCH1200


COBCH1101 No COBOL statement between periods

You have placed one period immediately following another period. This is not against the rules of COBOL syntax, but it might indicate a fault in your program, for example, you might have wanted to include a line of source code here.
Parent topic: COBCH1101 - COBCH1120


COBCH1102 Blank continuation source line. Line ignored

You have placed a hyphen in column 7, but the rest of the line contains no other code. The next line should also contain a hyphen in column 7, to continue correctly.
Parent topic: COBCH1101 - COBCH1120


COBCH1103 Sequence number out of order or missing

Parent topic: COBCH1101 - COBCH1120


COBCH1104 77 level item in File Section. Processed as 01 level

You have assigned a level of 77 to a data item in the File Section which is against the rules of COBOL syntax. Your COBOL system assumes that you had intended to code this as an 01 level item, and processes it as such.
Parent topic: COBCH1101 - COBCH1120


COBCH1105 No CORRESPONDING items were found. Statement has no effect

Your COBOL system found no matching data items for the CORRESPONDING clause, so no intermediate code is produced for this statement.
Parent topic: COBCH1101 - COBCH1120


COBCH1106 ZERO value for BY operand. Statement processed as written

You have used the BY operand with the verb PERFORM, but the value you have specified for the increment is zero. Your COBOL system produces code to execute this statement, but the value is never incremented.
Parent topic: COBCH1101 - COBCH1120


COBCH1107 Statement exceeds COMP subset

The COMP subset code you have written could be rewritten to execute more efficiently.

Click below for information on writing efficient code.

Parent topic: COBCH1101 - COBCH1120


COBCH1108 Signed numeric compared with group. Processed as alphanumeric compare

You have written your code so that a signed numeric field is compared with a group item. Your COBOL system has treated the signed numeric field as an alphanumeric field for the comparison. There are no problems with comparing a signed numeric field with an elementary item.
Parent topic: COBCH1101 - COBCH1120


COBCH1109 WITH DEBUGGING MODE not specified. Section ignored

Your program includes the USE FOR DEBUGGING statement in a section in the Declaratives of your Procedure Division, but you have not included the WITH DEBUGGING MODE clause in the Source-Computer paragraph. Your COBOL system ignores all code in this section.
Parent topic: COBCH1101 - COBCH1120


COBCH1110 First literal is greater than second. Processed as written

In the ALPHABET clause the first literal that is specified has a value greater than that of the second, for example, P THRU D. Your COBOL system accepts this as written, that is, the characters are processed in reverse order.
Parent topic: COBCH1101 - COBCH1120


COBCH1111 Boundary violation. Processed as written

You have tried to access an item beyond the end of a table. Your COBOL system generates code to access the appropriate line of code beyond the end of the table, but the result of this is undefined.
Parent topic: COBCH1101 - COBCH1120


COBCH1112 Compatibility directive forcing non standard behaviour

Parent topic: COBCH1101 - COBCH1120


COBCH1113 Imperative statement missing - CONTINUE assumed

Your program contains a conditional statement which has not been followed by an imperative statement. Your COBOL system executes the code, but the result of this might be undefined.
Parent topic: COBCH1101 - COBCH1120


COBCH1114 Clause treated as documentary

You have assigned more than one external file reference to a SELECT ... ASSIGN clause. Your COBOL system accepts the first external file reference, but treats all remaining external file references in that clause as documentary.
Parent topic: COBCH1101 - COBCH1120


COBCH1115 SAME AREA treated as SAME RECORD AREA

You are using a program converted from DG Interactive COBOL to this COBOL that contains a SAME AREA clause. Your COBOL system has assumed that the SAME RECORD AREA clause is what was meant.
Parent topic: COBCH1101 - COBCH1120


COBCH1116 ACCEPT qualifier used with display-only field - qualifier ignored

The qualifier used with a DISPLAY only field, or in a DISPLAY statement, can be used only with an ACCEPT. It is ignored.
Parent topic: COBCH1101 - COBCH1120


COBCH1117 Zero suppression follows floating insertion - treated as floating insertion

As an example, PIC ++Z.ZZ is treated as PIC +++.++.
Parent topic: COBCH1101 - COBCH1120


COBCH1118 Index-name belongs to different table

The index used to subscript a table item is not one used in the INDEXED BY clause for this table. The results are unpredictable.
Parent topic: COBCH1101 - COBCH1120


COBCH1119 Record size size1 < minimum size given in FD statement size2

The definition of a record following an FD clause is smaller than the minimum size specified in the RECORD CONTAINS phrase of that FD clause.
Parent topic: COBCH1101 - COBCH1120


COBCH1120 Record size size1 > maximum size given in FD statement size2

The definition of a record following an FD clause is larger than the maximum size specified in the RECORD CONTAINS phrase of that FD clause.
Parent topic: COBCH1101 - COBCH1120


COBCH1121 - COBCH1140

Lists the Syntax Checking error messages from COBCH1121 through COBCH1140.

  • COBCH1121 VALUE in File, Linkage, or Local-Storage Section - processed as comment
    A data item in the File or Linkage Section cannot be given a value. The VALUE clause specified is ignored.
  • COBCH1122 Period must be followed by a space
    In all cases a period must be followed by a space.
  • COBCH1123 Neither NAMED nor CHANGED specified. Will be treated as formatted DISPLAY.
    An EXHIBIT statement has been used without the NAMED or CHANGED phrase. The resulting display is formatted by separating each item with a space.
  • COBCH1124 CALL parameter is literal (or LENGTH OF). BY CONTENT assumed
    You are using a program converted from RM/COBOL to this COBOL that contains a CALL ... USING literal statement. Your COBOL system has assumed that CALL ... USING BY CONTENT literal is what was meant.
  • COBCH1125 Punctuation character not followed by a space. Assume space
    A punctuation character should be followed by a space.
  • COBCH1126 Punctuation character not preceded by a space. Assume space
    In accordance with ANS85 specifications, the relational operator "=" is considered to be a COBOL reserved word; all reserved words must be both preceded and delimited by a space.
  • COBCH1127 Double-Byte character(s) might be corrupted by use of this move
    This MOVE statement might cause a double-byte data item to be corrupted by changing one byte of a double-byte pair.
  • COBCH1128 No STOP RUN, GOBACK, or EXIT PROGRAM statements encountered in source
    The source has no STOP RUN, GOBACK or EXIT PROGRAM statement. Your COBOL system automatically inserts an EXIT statement followed by a STOP RUN statement following the last line in the program. However, this might not have the effect you desire.
  • COBCH1129 Statement cannot be reached
    The program flow prevents the statement flagged from being executed.
  • COBCH1130 Prefix of filename treated as documentary
  • COBCH1131 Statement generated no executable code
    This error might be produced when, for example, an INITIALIZE statement does not cause any code to be created. It is an indication that the statement can be removed from the program. If the error is ignored the effect is as if the statement were removed.
  • COBCH1132 Unable to validate contents of DBCS literals
    Your COBOL system is unable to check that the contents of a DBCS literal are valid. If the contents are invalid the results are unpredictable.
  • COBCH1133 SQL warning/ recoverable error
    The SQL processor generated a warning. Check your SQL documentation for further details.
  • COBCH1134 Entry name has been converted following OS/VS COBOL and VS COBOL II rules
  • COBCH1135 No OPEN statement was found for file
    Related Topics
  • COBCH1136 No CLOSE statement was found for file
    Related Topics
  • COBCH1137 "KEPT" omitted for file with multiple record locking
    The KEPT phrase has not been included in your multiple record locked file.
  • COBCH1138 Name truncated to characters characters
  • COBCH1139 Operand operand does not have suitable data type
Parent topic: Messages COBCH1101 to COBCH1200


COBCH1121 VALUE in File, Linkage, or Local-Storage Section - processed as comment

A data item in the File or Linkage Section cannot be given a value. The VALUE clause specified is ignored.
Parent topic: COBCH1121 - COBCH1140


COBCH1122 Period must be followed by a space

In all cases a period must be followed by a space.
Parent topic: COBCH1121 - COBCH1140


COBCH1123 Neither NAMED nor CHANGED specified. Will be treated as formatted DISPLAY.

An EXHIBIT statement has been used without the NAMED or CHANGED phrase. The resulting display is formatted by separating each item with a space.
Parent topic: COBCH1121 - COBCH1140


COBCH1124 CALL parameter is literal (or LENGTH OF). BY CONTENT assumed

You are using a program converted from RM/COBOL to this COBOL that contains a CALL ... USING literal statement. Your COBOL system has assumed that CALL ... USING BY CONTENT literal is what was meant.
Parent topic: COBCH1121 - COBCH1140


COBCH1125 Punctuation character not followed by a space. Assume space

A punctuation character should be followed by a space.
Parent topic: COBCH1121 - COBCH1140


COBCH1126 Punctuation character not preceded by a space. Assume space

In accordance with ANS85 specifications, the relational operator "=" is considered to be a COBOL reserved word; all reserved words must be both preceded and delimited by a space.
Parent topic: COBCH1121 - COBCH1140


COBCH1127 Double-Byte character(s) might be corrupted by use of this move

This MOVE statement might cause a double-byte data item to be corrupted by changing one byte of a double-byte pair.
Parent topic: COBCH1121 - COBCH1140


COBCH1128 No STOP RUN, GOBACK, or EXIT PROGRAM statements encountered in source

The source has no STOP RUN, GOBACK or EXIT PROGRAM statement. Your COBOL system automatically inserts an EXIT statement followed by a STOP RUN statement following the last line in the program. However, this might not have the effect you desire.
Parent topic: COBCH1121 - COBCH1140


COBCH1129 Statement cannot be reached

The program flow prevents the statement flagged from being executed.
Parent topic: COBCH1121 - COBCH1140


COBCH1130 Prefix of filename treated as documentary

Parent topic: COBCH1121 - COBCH1140


COBCH1131 Statement generated no executable code

This error might be produced when, for example, an INITIALIZE statement does not cause any code to be created. It is an indication that the statement can be removed from the program. If the error is ignored the effect is as if the statement were removed.
Parent topic: COBCH1121 - COBCH1140


COBCH1132 Unable to validate contents of DBCS literals

Your COBOL system is unable to check that the contents of a DBCS literal are valid. If the contents are invalid the results are unpredictable.
Parent topic: COBCH1121 - COBCH1140


COBCH1133 SQL warning/ recoverable error

The SQL processor generated a warning. Check your SQL documentation for further details.
Parent topic: COBCH1121 - COBCH1140


COBCH1134 Entry name has been converted following OS/VS COBOL and VS COBOL II rules

Parent topic: COBCH1121 - COBCH1140


COBCH1135 No OPEN statement was found for file

Related Topics
Parent topic: COBCH1121 - COBCH1140


COBCH1136 No CLOSE statement was found for file

Related Topics
Parent topic: COBCH1121 - COBCH1140


COBCH1137 "KEPT" omitted for file with multiple record locking

The KEPT phrase has not been included in your multiple record locked file.
Parent topic: COBCH1121 - COBCH1140


COBCH1138 Name truncated to characters characters

Parent topic: COBCH1121 - COBCH1140


COBCH1139 Operand operand does not have suitable data type

Parent topic: COBCH1121 - COBCH1140


COBCH1141 - COBCH1160

Lists the Syntax Checking error messages from COBCH1141 through COBCH1160.

  • COBCH1141 Name longer than 8 characters
  • COBCH1142 Name includes characters that would be changed by OS/VS COBOL and VS COBOL II
  • COBCH1143 Name includes characters that would be illegal for OS/VS COBOL and VS COBOL II
  • COBCH1144 String will be null terminated when returned by SQL
  • COBCH1145 DUPLICATES phrase with keys generates slower sort; remove if possible
    Related Topics
  • COBCH1146 procedure-name lies in more than one PERFORM THRU range
    Related Topics
  • COBCH1147 End precedes start in PERFORM procedure-name THRU procedure-name
    The procedure-name after the THRU comes earlier in the source program than the one before the THRU.
  • COBCH1148 Segmentation specified in nested program.
  • COBCH1149 Operand data-name ambiguous in corresponding target
    In a MOVE, ADD or SUBTRACT CORRESPONDING, the sending group contains an item, data-name, which is ambiguous in the receiving group.
  • COBCH1150 Redefinition of internal floating-point item. Might not be portable
  • COBCH1151 Forward overlapping move might produce unpredictable results
    You have specified a MOVE to a target whose starting position is before the ending position of the source data item.
  • COBCH1152 Comparison involving floating point data might not be portable
  • COBCH1153 Some mainframe values for this data-type cannot be handled on PC
  • COBCH1154 PC allows values for this data-type that cannot be handled on mainframes
  • COBCH1155 Both PANVALET and LIBRARIAN specified - not mainframe compatible
  • COBCH1156 BLOCK or LABEL clause in SD not allowed. Ignored
    Related Topics
  • COBCH1157 JUSTIFIED specified on edited field
    Related Topics
  • COBCH1158 CBL PROCESS *CBL or *CONTROL record encountered. Directives ignored
  • COBCH1159 Portion of name following first "-" treated as documentary.
  • COBCH1160 Changes before first statement cannot be checked. Ignored
Parent topic: Messages COBCH1101 to COBCH1200


COBCH1141 Name longer than 8 characters

Parent topic: COBCH1141 - COBCH1160


COBCH1142 Name includes characters that would be changed by OS/VS COBOL and VS COBOL II

Parent topic: COBCH1141 - COBCH1160


COBCH1143 Name includes characters that would be illegal for OS/VS COBOL and VS COBOL II

Parent topic: COBCH1141 - COBCH1160


COBCH1144 String will be null terminated when returned by SQL

Parent topic: COBCH1141 - COBCH1160


COBCH1145 DUPLICATES phrase with keys generates slower sort; remove if possible

Related Topics
Parent topic: COBCH1141 - COBCH1160


COBCH1146 procedure-name lies in more than one PERFORM THRU range

Related Topics
Parent topic: COBCH1141 - COBCH1160


COBCH1147 End precedes start in PERFORM procedure-name THRU procedure-name

The procedure-name after the THRU comes earlier in the source program than the one before the THRU.
Parent topic: COBCH1141 - COBCH1160


COBCH1148 Segmentation specified in nested program.

Parent topic: COBCH1141 - COBCH1160


COBCH1149 Operand data-name ambiguous in corresponding target

In a MOVE, ADD or SUBTRACT CORRESPONDING, the sending group contains an item, data-name, which is ambiguous in the receiving group.

Resolution:

Although data-name occurs in both the sending and receiving groups, no relevant MOVE, ADD or SUBTRACT is generated: this is in accordance with ANSI defined behavior.

Parent topic: COBCH1141 - COBCH1160


COBCH1150 Redefinition of internal floating-point item. Might not be portable

Parent topic: COBCH1141 - COBCH1160


COBCH1151 Forward overlapping move might produce unpredictable results

You have specified a MOVE to a target whose starting position is before the ending position of the source data item.
Parent topic: COBCH1141 - COBCH1160


COBCH1152 Comparison involving floating point data might not be portable

Parent topic: COBCH1141 - COBCH1160


COBCH1153 Some mainframe values for this data-type cannot be handled on PC

Parent topic: COBCH1141 - COBCH1160


COBCH1154 PC allows values for this data-type that cannot be handled on mainframes

Parent topic: COBCH1141 - COBCH1160


COBCH1155 Both PANVALET and LIBRARIAN specified - not mainframe compatible

Parent topic: COBCH1141 - COBCH1160


COBCH1156 BLOCK or LABEL clause in SD not allowed. Ignored

Related Topics
Parent topic: COBCH1141 - COBCH1160


COBCH1157 JUSTIFIED specified on edited field

Related Topics
Parent topic: COBCH1141 - COBCH1160


COBCH1158 CBL PROCESS *CBL or *CONTROL record encountered. Directives ignored

Parent topic: COBCH1141 - COBCH1160


COBCH1159 Portion of name following first "-" treated as documentary.

Parent topic: COBCH1141 - COBCH1160


COBCH1160 Changes before first statement cannot be checked. Ignored

Parent topic: COBCH1141 - COBCH1160


COBCH1161 - COBCH1180

Lists the Syntax Checking error messages from COBCH1161 through COBCH1180.

  • COBCH1161 Paragraph/section definition has changed. Ignored
  • COBCH1162 Attempt to define item as procedure. Ignored
  • COBCH1163 Animator restriction - can't check this statement
  • COBCH1164 Too many basic blocks for GNTANLZ(COUNT) to work, recompile with GNTANLZ(TICK)
  • COBCH1165 GIVING option treated as documentary
    Related Topics
  • COBCH1166 BLANK WHEN ZERO phrase ignored
    Related Topics
  • COBCH1167 Use of COMP-5 data type
    Related Topics
  • COBCH1168 COMP-5 redefinition
    You have redefined a COMP-5 data item. Porting your code to other environments might produce inconsistent results.
  • COBCH1169 Reference modification on a COMP-5 item
    You have used reference modification on a COMP-5 data item. Porting your code to other environments might produce inconsistent results.
  • COBCH1170 A non-integer operand cannot be compared with a nonnumeric operand
    Related Topics
  • COBCH1171 Numeric class test on a group containing a signed numeric item
  • COBCH1172 Improper BLL Cell List item
  • COBCH1173 BLL Cell Addressability invalid
  • COBCH1174 Comparison of numeric literal with numeric literal
    Related Topics
  • COBCH1175 Synchronization non-optimal
  • COBCH1176 SLiteral is greater in length than data item
Parent topic: Messages COBCH1101 to COBCH1200


COBCH1161 Paragraph/section definition has changed. Ignored

Parent topic: COBCH1161 - COBCH1180


COBCH1162 Attempt to define item as procedure. Ignored

Parent topic: COBCH1161 - COBCH1180


COBCH1163 Animator restriction - can't check this statement

Parent topic: COBCH1161 - COBCH1180


COBCH1164 Too many basic blocks for GNTANLZ(COUNT) to work, recompile with GNTANLZ(TICK)

Parent topic: COBCH1161 - COBCH1180


COBCH1165 GIVING option treated as documentary

Related Topics
Parent topic: COBCH1161 - COBCH1180


COBCH1166 BLANK WHEN ZERO phrase ignored

Related Topics
Parent topic: COBCH1161 - COBCH1180


COBCH1167 Use of COMP-5 data type

Related Topics
Parent topic: COBCH1161 - COBCH1180


COBCH1168 COMP-5 redefinition

You have redefined a COMP-5 data item. Porting your code to other environments might produce inconsistent results.
Parent topic: COBCH1161 - COBCH1180


COBCH1169 Reference modification on a COMP-5 item

You have used reference modification on a COMP-5 data item. Porting your code to other environments might produce inconsistent results.
Parent topic: COBCH1161 - COBCH1180


COBCH1170 A non-integer operand cannot be compared with a nonnumeric operand

Related Topics
Parent topic: COBCH1161 - COBCH1180


COBCH1171 Numeric class test on a group containing a signed numeric item

Parent topic: COBCH1161 - COBCH1180


COBCH1172 Improper BLL Cell List item

Parent topic: COBCH1161 - COBCH1180


COBCH1173 BLL Cell Addressability invalid

Parent topic: COBCH1161 - COBCH1180


COBCH1174 Comparison of numeric literal with numeric literal

Related Topics
Parent topic: COBCH1161 - COBCH1180


COBCH1175 Synchronization non-optimal

Parent topic: COBCH1161 - COBCH1180


COBCH1176 SLiteral is greater in length than data item

Parent topic: COBCH1161 - COBCH1180


COBCH1181 - COBCH1200

Lists the Syntax Checking error messages from COBCH1181 through COBCH1200.

  • COBCH1181 Operand "%1_s" should be numeric
  • COBCH1182 Comparison between two ALL literals is not allowed
  • COBCH1183 EXAMINE TALLYING requires the TALLY special register_
Parent topic: Messages COBCH1101 to COBCH1200


COBCH1181 Operand "%1_s" should be numeric

Parent topic: COBCH1181 - COBCH1200


COBCH1182 Comparison between two ALL literals is not allowed

Parent topic: COBCH1181 - COBCH1200


COBCH1183 EXAMINE TALLYING requires the TALLY special register_

Parent topic: COBCH1181 - COBCH1200


Messages COBCH1201 to COBCH1300

  • COBCH1201 - COBCH1220
    Lists the Syntax Checking error messages from COBCH1201 through COBCH1220.
  • COBCH1221 - COBCH1240
    Lists the Syntax Checking error messages from COBCH1221 through COBCH1240.
  • COBCH1241 - COBCH1260
    Lists the Syntax Checking error messages from COBCH1241 through COBCH1260.
  • COBCH1261 - COBCH1280
    Lists the Syntax Checking error messages from COBCH1261 through COBCH1280.
Parent topic: Syntax Checking Error Messages


COBCH1201 - COBCH1220

Lists the Syntax Checking error messages from COBCH1201 through COBCH1220.

  • COBCH1201 Zero suppression PICTURE string overrides the BLANK WHEN ZERO clause
    Related Topics
  • COBCH1202 Original item is larger than redefinition (size1 > size2)
  • COBCH1203 LABEL clause processed as comment
    Related Topics
  • COBCH1204 BLOCK CONTAINS clause processed as comment
    Related Topics
  • COBCH1205 Previous paragraph or section contains no statements
  • COBCH1206 Procedure Division does not start with a section
    Related Topics
  • COBCH1207 Original item is smaller than redefinition (size1 < size2)
  • COBCH1208 USE clause omitted
    Related Topics
  • COBCH1209 COMP-5 is machine specific format. (Future occurrences not indicated)
    Related Topics
  • COBCH1210 COMP processed as DISPLAY (future occurrences not indicated)
    Related Topics
  • COBCH1211 COMP-6 processed as COMP (future occurrences not indicated)
    Related Topics
  • COBCH1212 COMP-1 processed as PIC S9(4) COMP (future occurrences not indicated)
    Related Topics
  • COBCH1213 COMP-0 field exceeds S9(5), converted to USAGE DISPLAY
    Related Topics
  • COBCH1214 COMP-0 processed as PIC S9(4) COMP (future occurrences not indicated)
    Related Topics
  • COBCH1215 UNIT phrase processed as comment
    Related Topics
  • COBCH1216 Literal exceeds 160 characters
    Related Topics
  • COBCH1217 procedure-name same as level 78 name
  • COBCH1218 RERUN clause processed as comment
    Related Topics
  • COBCH1219 No REPLACE currently in effect
  • COBCH1220 COMP-4 processed as PIC S9(9) COMP (future occurrences not indicated)
    Related Topics
Parent topic: Messages COBCH1201 to COBCH1300


COBCH1201 Zero suppression PICTURE string overrides the BLANK WHEN ZERO clause

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1202 Original item is larger than redefinition (size1 > size2)

Parent topic: COBCH1201 - COBCH1220


COBCH1203 LABEL clause processed as comment

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1204 BLOCK CONTAINS clause processed as comment

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1205 Previous paragraph or section contains no statements

Parent topic: COBCH1201 - COBCH1220


COBCH1206 Procedure Division does not start with a section

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1207 Original item is smaller than redefinition (size1 < size2)

Parent topic: COBCH1201 - COBCH1220


COBCH1208 USE clause omitted

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1209 COMP-5 is machine specific format. (Future occurrences not indicated)

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1210 COMP processed as DISPLAY (future occurrences not indicated)

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1211 COMP-6 processed as COMP (future occurrences not indicated)

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1212 COMP-1 processed as PIC S9(4) COMP (future occurrences not indicated)

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1213 COMP-0 field exceeds S9(5), converted to USAGE DISPLAY

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1214 COMP-0 processed as PIC S9(4) COMP (future occurrences not indicated)

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1215 UNIT phrase processed as comment

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1216 Literal exceeds 160 characters

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1217 procedure-name same as level 78 name

Parent topic: COBCH1201 - COBCH1220


COBCH1218 RERUN clause processed as comment

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1219 No REPLACE currently in effect

Parent topic: COBCH1201 - COBCH1220


COBCH1220 COMP-4 processed as PIC S9(9) COMP (future occurrences not indicated)

Related Topics
Parent topic: COBCH1201 - COBCH1220


COBCH1221 - COBCH1240

Lists the Syntax Checking error messages from COBCH1221 through COBCH1240.

  • COBCH1221 COMP-4 field exceeds S9(10), converted to USAGE DISPLAY
    Related Topics
  • COBCH1222 COMP-3 unsigned, converted to signed COMP-3
    Related Topics
  • COBCH1223 BLANK WHEN ZERO clause overrides the zero suppression PICTURE string
    Related Topics
  • COBCH1224 MEMORY SIZE clause processed as comment
    The MEMORY SIZE clause is treated as documentary.
  • COBCH1225 MULTIPLE FILE TAPE clause processed as comment
    The MULTIPLE FILE TAPE clause is treated as documentary.
  • COBCH1226 COMMON can only be used in nested program - processed as comment
    The program defined as COMMON is a main program, not a nested program.
  • COBCH1227 Scope terminator value generated implicitly
    Related Topics
  • COBCH1228 Word non-portable; reserved in OS/400
  • COBCH1229 Word non-portable; reserved in VSC2(3)
  • COBCH1230 Word non-portable; reserved in OS/2 COBOL
  • COBCH1231 Syntax is non-conforming SAA
  • COBCH1232 Use of early-release MF syntax
  • COBCH1233 item directive or parameter is early-release
  • COBCH1234 item is CORRESPONDING item in statement
    Related Topics
  • COBCH1235 Conflicting definition of level 78 item item
  • COBCH1236 Duplicate, equivalent definition of level 78 item
  • COBCH1237 File handling used with REENTRANT Directive
    Related Topics
  • COBCH1238 Conflict with REENTRANT Directive and user code or other Directives
    Related Topics
Parent topic: Messages COBCH1201 to COBCH1300


COBCH1221 COMP-4 field exceeds S9(10), converted to USAGE DISPLAY

Related Topics
Parent topic: COBCH1221 - COBCH1240


COBCH1222 COMP-3 unsigned, converted to signed COMP-3

Related Topics
Parent topic: COBCH1221 - COBCH1240


COBCH1223 BLANK WHEN ZERO clause overrides the zero suppression PICTURE string

Related Topics
Parent topic: COBCH1221 - COBCH1240


COBCH1224 MEMORY SIZE clause processed as comment

The MEMORY SIZE clause is treated as documentary.
Parent topic: COBCH1221 - COBCH1240


COBCH1225 MULTIPLE FILE TAPE clause processed as comment

The MULTIPLE FILE TAPE clause is treated as documentary.
Parent topic: COBCH1221 - COBCH1240


COBCH1226 COMMON can only be used in nested program - processed as comment

The program defined as COMMON is a main program, not a nested program.
Parent topic: COBCH1221 - COBCH1240


COBCH1227 Scope terminator value generated implicitly

Related Topics
Parent topic: COBCH1221 - COBCH1240


COBCH1228 Word non-portable; reserved in OS/400

Parent topic: COBCH1221 - COBCH1240


COBCH1229 Word non-portable; reserved in VSC2(3)

Parent topic: COBCH1221 - COBCH1240


COBCH1230 Word non-portable; reserved in OS/2 COBOL

Parent topic: COBCH1221 - COBCH1240


COBCH1231 Syntax is non-conforming SAA

Parent topic: COBCH1221 - COBCH1240


COBCH1232 Use of early-release MF syntax

Parent topic: COBCH1221 - COBCH1240


COBCH1233 item directive or parameter is early-release

Parent topic: COBCH1221 - COBCH1240


COBCH1234 item is CORRESPONDING item in statement

Related Topics
Parent topic: COBCH1221 - COBCH1240


COBCH1235 Conflicting definition of level 78 item item

Parent topic: COBCH1221 - COBCH1240


COBCH1236 Duplicate, equivalent definition of level 78 item

Parent topic: COBCH1221 - COBCH1240


COBCH1237 File handling used with REENTRANT Directive

Related Topics
Parent topic: COBCH1221 - COBCH1240


COBCH1238 Conflict with REENTRANT Directive and user code or other Directives

Related Topics
Parent topic: COBCH1221 - COBCH1240


COBCH1241 - COBCH1260

Lists the Syntax Checking error messages from COBCH1241 through COBCH1260.

  • COBCH1241 Results incompatible with BS2000 if src table length > dest table length
    A table SORT containing a USING phrase gives different run-time results to Siemens BS2000 when there are more elements in the source table than can be contained in the destination table.
  • COBCH1242 USAGE must be DISPLAY for entries in a group with VALUE clause
  • COBCH1243 Non-positive value changed to 1
  • COBCH1244 WITH NO ADVANCING phrase has no effect for CONSOLE device
  • COBCH1245 Should be in upper case
    A call to a COBOL run-time library routine (where the name begins CBL_) has been specified partly or all in lower case. This is not portable and will not work on operating systems where names are case-sensitive.
  • COBCH1246 One or more operands are missing and have taken a default value of 1
    A reference to a table item has fewer subscripts than dimensions. Additional subscripts are assumed, all taking the default value 1.
  • COBCH1247 Truncated MOVE. Source length (length) exceeds target length (length)
  • COBCH1248 Function argument invalid, date YYYYMMDD must be greater than 15821014
  • COBCH1249 Function argument invalid, date YYYYDDD must be greater than 1582287
  • COBCH1250 Use of intrinsic funtion module or function not in selected dialect.
  • COBCH1252 Requires an abstract machine level of 4 or greater
  • COBCH1253 THRU not allowed with boolean items
  • COBCH1254 Job variable name is too long
    Siemens BS2000 Job variable names are limited to 10 characters.
  • COBCH1255 Literal exceeds 180 characters
    Using the Siemens BS2000 dialect, the maximum allowable length of a literal is 180 characters.
  • COBCH1259 GO TO target outside current section
    A GO TO statement has attempted to change control to outside of the current section.
  • COBCH1300 Expected Interface name.
Parent topic: Messages COBCH1201 to COBCH1300


COBCH1241 Results incompatible with BS2000 if src table length > dest table length

A table SORT containing a USING phrase gives different run-time results to Siemens BS2000 when there are more elements in the source table than can be contained in the destination table.
Parent topic: COBCH1241 - COBCH1260


COBCH1242 USAGE must be DISPLAY for entries in a group with VALUE clause

Parent topic: COBCH1241 - COBCH1260


COBCH1243 Non-positive value changed to 1

Parent topic: COBCH1241 - COBCH1260


COBCH1244 WITH NO ADVANCING phrase has no effect for CONSOLE device

Parent topic: COBCH1241 - COBCH1260


COBCH1245 Should be in upper case

A call to a COBOL run-time library routine (where the name begins CBL_) has been specified partly or all in lower case. This is not portable and will not work on operating systems where names are case-sensitive.
Parent topic: COBCH1241 - COBCH1260


COBCH1246 One or more operands are missing and have taken a default value of 1

A reference to a table item has fewer subscripts than dimensions. Additional subscripts are assumed, all taking the default value 1.
Parent topic: COBCH1241 - COBCH1260


COBCH1247 Truncated MOVE. Source length (length) exceeds target length (length)

Parent topic: COBCH1241 - COBCH1260


COBCH1248 Function argument invalid, date YYYYMMDD must be greater than 15821014

Parent topic: COBCH1241 - COBCH1260


COBCH1249 Function argument invalid, date YYYYDDD must be greater than 1582287

Parent topic: COBCH1241 - COBCH1260


COBCH1250 Use of intrinsic funtion module or function not in selected dialect.

Parent topic: COBCH1241 - COBCH1260


COBCH1252 Requires an abstract machine level of 4 or greater

Parent topic: COBCH1241 - COBCH1260


COBCH1253 THRU not allowed with boolean items

Parent topic: COBCH1241 - COBCH1260


COBCH1254 Job variable name is too long

Siemens BS2000 Job variable names are limited to 10 characters.
Parent topic: COBCH1241 - COBCH1260


COBCH1255 Literal exceeds 180 characters

Using the Siemens BS2000 dialect, the maximum allowable length of a literal is 180 characters.
Parent topic: COBCH1241 - COBCH1260


COBCH1259 GO TO target outside current section

A GO TO statement has attempted to change control to outside of the current section.

The RESTRICT-GOTO Compiler directive switches on this behavior. To allow GO TO statements to transfer control to another section, remove the directive.

Parent topic: COBCH1241 - COBCH1260
Related concepts
RESTRICT-GOTO


COBCH1300 Expected Interface name.

Parent topic: COBCH1241 - COBCH1260


COBCH1261 - COBCH1280

Lists the Syntax Checking error messages from COBCH1261 through COBCH1280.

  • COBCH1261 Conversion operator must have mutually incompatible parameter and return type
  • COBCH1262 A method without a returning item cannot be a source operand
  • COBCH1263 PARAMS may only be specified for a single dimensional array as the last parameter
  • COBCH1264 Only '_' and 'NOT _' allowed for comparisons with NULL
  • COBCH1265 Cannot compare a value type with NULL
  • COBCH1266 Incompatible options specified, %1_s and %2_s
  • COBCH1267 Can only INVOKE self__new or super__new as first statement in constructor
  • COBCH1268 A static file cannot reference instance items
  • COBCH1269 Visibility attributes cannot be used with local data
  • COBCH1270 SIZE OF operator can only be used with native arrays
Parent topic: Messages COBCH1201 to COBCH1300


COBCH1261 Conversion operator must have mutually incompatible parameter and return type

Parent topic: COBCH1261 - COBCH1280


COBCH1262 A method without a returning item cannot be a source operand

Parent topic: COBCH1261 - COBCH1280


COBCH1263 PARAMS may only be specified for a single dimensional array as the last parameter

Parent topic: COBCH1261 - COBCH1280


COBCH1264 Only '_' and 'NOT _' allowed for comparisons with NULL

Parent topic: COBCH1261 - COBCH1280


COBCH1265 Cannot compare a value type with NULL

Parent topic: COBCH1261 - COBCH1280


COBCH1266 Incompatible options specified, %1_s and %2_s

Parent topic: COBCH1261 - COBCH1280


COBCH1267 Can only INVOKE self__new or super__new as first statement in constructor

Parent topic: COBCH1261 - COBCH1280


COBCH1268 A static file cannot reference instance items

Parent topic: COBCH1261 - COBCH1280


COBCH1269 Visibility attributes cannot be used with local data

Parent topic: COBCH1261 - COBCH1280


COBCH1270 SIZE OF operator can only be used with native arrays

Parent topic: COBCH1261 - COBCH1280


Messages COBCH1301 to COBCH1400

  • COBCH1301 - COBCH1320
    Lists the Syntax Checking error messages from COBCH1301 through COBCH1320.
  • COBCH1321 - COBCH1340
    Lists the Syntax Checking error messages from COBCH1321 through COBCH1340.
Parent topic: Syntax Checking Error Messages


COBCH1301 - COBCH1320

Lists the Syntax Checking error messages from COBCH1301 through COBCH1320.

  • COBCH1301 Expected Class name.
  • COBCH1302 Expected Class or Interface name.
  • COBCH1303 PROPERTY clause only allowed in Object or Factory.
  • COBCH1304 Method not found in the repository.
  • COBCH1305 Universal Object Reference is not allowed.
  • COBCH1306 Redefintion of an Object Reference is illegal.
  • COBCH1307 Object Reference with REDEFINES clause is illegal.
  • COBCH1308 VALUE clause is illegal with Object Reference or Pointer.
  • COBCH1309 INPUT-OUTPUT section not allowed.
  • COBCH1310 Not allowed in a FACTORY or OBJECT definition.
  • COBCH1311 Not allowed in a METHOD definition.
  • COBCH1312 Not allowed in the outer level of a Class Definition.
  • COBCH1313 Not allowed in an INTERFACE definition.
  • COBCH1314 LOCK MODE clause must be specified in the File Control Entry.
  • COBCH1315 Illegal use of floating-point item %1_s
  • COBCH1316 Non-integer moved to alphanumeric item %1_s
  • COBCH1317 Method '%1_s' not found in this class_
  • COBCH1318 Cannot resolve forward reference of method in an inline invoke_
  • COBCH1319 Clause from the REPOSITORY paragraph expected_
  • COBCH1320 HOSTNUMCOMPARE(1)_HOSTNUMMOVE(1) may be removed in future releases
Parent topic: Messages COBCH1301 to COBCH1400


COBCH1301 Expected Class name.

Parent topic: COBCH1301 - COBCH1320


COBCH1302 Expected Class or Interface name.

Parent topic: COBCH1301 - COBCH1320


COBCH1303 PROPERTY clause only allowed in Object or Factory.

Parent topic: COBCH1301 - COBCH1320


COBCH1304 Method not found in the repository.

Parent topic: COBCH1301 - COBCH1320


COBCH1305 Universal Object Reference is not allowed.

Parent topic: COBCH1301 - COBCH1320


COBCH1306 Redefintion of an Object Reference is illegal.

Parent topic: COBCH1301 - COBCH1320


COBCH1307 Object Reference with REDEFINES clause is illegal.

Parent topic: COBCH1301 - COBCH1320


COBCH1308 VALUE clause is illegal with Object Reference or Pointer.

Parent topic: COBCH1301 - COBCH1320


COBCH1309 INPUT-OUTPUT section not allowed.

Parent topic: COBCH1301 - COBCH1320


COBCH1310 Not allowed in a FACTORY or OBJECT definition.

Parent topic: COBCH1301 - COBCH1320


COBCH1311 Not allowed in a METHOD definition.

Parent topic: COBCH1301 - COBCH1320


COBCH1312 Not allowed in the outer level of a Class Definition.

Parent topic: COBCH1301 - COBCH1320


COBCH1313 Not allowed in an INTERFACE definition.

Parent topic: COBCH1301 - COBCH1320


COBCH1314 LOCK MODE clause must be specified in the File Control Entry.

Parent topic: COBCH1301 - COBCH1320


COBCH1315 Illegal use of floating-point item %1_s

Parent topic: COBCH1301 - COBCH1320


COBCH1316 Non-integer moved to alphanumeric item %1_s

Parent topic: COBCH1301 - COBCH1320


COBCH1317 Method '%1_s' not found in this class_

Parent topic: COBCH1301 - COBCH1320


COBCH1318 Cannot resolve forward reference of method in an inline invoke_

Parent topic: COBCH1301 - COBCH1320


COBCH1319 Clause from the REPOSITORY paragraph expected_

Parent topic: COBCH1301 - COBCH1320


COBCH1320 HOSTNUMCOMPARE(1)_HOSTNUMMOVE(1) may be removed in future releases

Parent topic: COBCH1301 - COBCH1320


COBCH1321 - COBCH1340

Lists the Syntax Checking error messages from COBCH1321 through COBCH1340.

  • COBCH1321 Cannot have REFERENCE to a value type - omit OBJECT REFERENCE_
  • COBCH1322 Cannot specify BEFORE or AFTER with TRAILING option_
  • COBCH1323 Cannot mix TRAILING option with other INSPECT phrases_
  • COBCH1324 Invalid HANDLE field_
  • COBCH1325 WHEN OTHER follows other WHEN clause_
  • COBCH1326 Level 78 literal too long_
  • COBCH1327 Cannot specify PROPERTY subsidiary to PROPERTY ALL_
Parent topic: Messages COBCH1301 to COBCH1400


COBCH1321 Cannot have REFERENCE to a value type - omit OBJECT REFERENCE_

Parent topic: COBCH1321 - COBCH1340


COBCH1322 Cannot specify BEFORE or AFTER with TRAILING option_

Parent topic: COBCH1321 - COBCH1340


COBCH1323 Cannot mix TRAILING option with other INSPECT phrases_

Parent topic: COBCH1321 - COBCH1340


COBCH1324 Invalid HANDLE field_

Parent topic: COBCH1321 - COBCH1340


COBCH1325 WHEN OTHER follows other WHEN clause_

Parent topic: COBCH1321 - COBCH1340


COBCH1326 Level 78 literal too long_

Parent topic: COBCH1321 - COBCH1340


COBCH1327 Cannot specify PROPERTY subsidiary to PROPERTY ALL_

Parent topic: COBCH1321 - COBCH1340


Messages COBCH1401 to COBCH1500

  • COBCH1401 - COBCH1420
    Lists the Syntax Checking error messages from COBCH1401 through COBCH1420.
  • COBCH1421 - COBCH1440
    Lists the Syntax Checking error messages from COBCH1421 through COBCH1440.
  • COBCH1441 - COBCH1460
    Lists the Syntax Checking error messages from COBCH1441 through COBCH1460.
  • COBCH1461 - COBCH1480
    Lists the Syntax Checking error messages from COBCH1461 through COBCH1480.
  • COBCH1481 - COBCH1500
    Lists the Syntax Checking error messages from COBCH1481 through COBCH1500.
Parent topic: Syntax Checking Error Messages


COBCH1401 - COBCH1420

Lists the Syntax Checking error messages from COBCH1401 through COBCH1420.

  • COBCH1401 OO_ Class '%1_s' can not inherit from itself_
  • COBCH1402 OO_ Class '%1_s' directly or indirectly inherits class '%2_s'_
  • COBCH1403 OO_ External name is illegal_
  • COBCH1404 OO_ Repository information for externalised class name '%1_s' not found_
  • COBCH1405 OO_ Externalised class name '%1_s' has FINAL clause and can not be inherited_
  • COBCH1406 OO_ Class name '%1_s' is not defined in the REPSOITORY paragraph_
  • COBCH1407 OO_ Interface name '%1_s' is not defined in the REPSOITORY paragraph_
  • COBCH1408 OO_ Class or Interface name '%1_s' is not defined in the REPSOITORY paragraph_
  • COBCH1409 OO_ EXPANDS phrase is illegal in a parameterised Class or Interface_
  • COBCH1410 OO_ The number of Actual parameters and Formal paramters is not the same_
  • COBCH1411 OO_ Expanded Class or Interface name '%1_s' is invalid_
  • COBCH1412 OO_ Expanded Class or Interface parameter name '%1_s' is invalid_
  • COBCH1413 OO_ Number of Expanded Class or Interface parameters do not match_
  • COBCH1414 OO_ Class or Interface name expected_
  • COBCH1415 OO_ Reserved word USING expected_
  • COBCH1416 OO_ There must be USING parameters_
  • COBCH1417 OO_ Method '%1_s' must not have the OVERRIDE clause_
  • COBCH1418 OO_ Method '%1_s' must have the OVERRIDE clause_
  • COBCH1419 OO_ Inherited method '%1_s' must not have the FINAL clause_
  • COBCH1420 OO_ Parameters of method '%1_s' do not conform _
Parent topic: Messages COBCH1401 to COBCH1500


COBCH1401 OO_ Class '%1_s' can not inherit from itself_

Parent topic: COBCH1401 - COBCH1420


COBCH1402 OO_ Class '%1_s' directly or indirectly inherits class '%2_s'_

Parent topic: COBCH1401 - COBCH1420


COBCH1403 OO_ External name is illegal_

Parent topic: COBCH1401 - COBCH1420


COBCH1404 OO_ Repository information for externalised class name '%1_s' not found_

Parent topic: COBCH1401 - COBCH1420


COBCH1405 OO_ Externalised class name '%1_s' has FINAL clause and can not be inherited_

Parent topic: COBCH1401 - COBCH1420


COBCH1406 OO_ Class name '%1_s' is not defined in the REPSOITORY paragraph_

Parent topic: COBCH1401 - COBCH1420


COBCH1407 OO_ Interface name '%1_s' is not defined in the REPSOITORY paragraph_

Parent topic: COBCH1401 - COBCH1420


COBCH1408 OO_ Class or Interface name '%1_s' is not defined in the REPSOITORY paragraph_

Parent topic: COBCH1401 - COBCH1420


COBCH1409 OO_ EXPANDS phrase is illegal in a parameterised Class or Interface_

Parent topic: COBCH1401 - COBCH1420


COBCH1410 OO_ The number of Actual parameters and Formal paramters is not the same_

Parent topic: COBCH1401 - COBCH1420


COBCH1411 OO_ Expanded Class or Interface name '%1_s' is invalid_

Parent topic: COBCH1401 - COBCH1420


COBCH1412 OO_ Expanded Class or Interface parameter name '%1_s' is invalid_

Parent topic: COBCH1401 - COBCH1420


COBCH1413 OO_ Number of Expanded Class or Interface parameters do not match_

Parent topic: COBCH1401 - COBCH1420


COBCH1414 OO_ Class or Interface name expected_

Parent topic: COBCH1401 - COBCH1420


COBCH1415 OO_ Reserved word USING expected_

Parent topic: COBCH1401 - COBCH1420


COBCH1416 OO_ There must be USING parameters_

Parent topic: COBCH1401 - COBCH1420


COBCH1417 OO_ Method '%1_s' must not have the OVERRIDE clause_

Parent topic: COBCH1401 - COBCH1420


COBCH1418 OO_ Method '%1_s' must have the OVERRIDE clause_

Parent topic: COBCH1401 - COBCH1420


COBCH1419 OO_ Inherited method '%1_s' must not have the FINAL clause_

Parent topic: COBCH1401 - COBCH1420


COBCH1420 OO_ Parameters of method '%1_s' do not conform _

Parent topic: COBCH1401 - COBCH1420


COBCH1421 - COBCH1440

Lists the Syntax Checking error messages from COBCH1421 through COBCH1440.

  • COBCH1421 OO_ Parameters of Method '%1_s' do not conform to Repository_
  • COBCH1422 OO_ Call Convention of '%1_s' does not match that in the Repository_
  • COBCH1423 OO_ Number of parameters of '%1_s' does not match Repository entry_
  • COBCH1424 OO_ The Prototype for Method '%1_s' was not found_
  • COBCH1425 OO_ Duplicated Internal Method name '%1_s'_
  • COBCH1426 OO_ Duplicated External Method name '%1_s'_
  • COBCH1427 OO_ Method_Function '%1_s" does not have a RETURNING clause defined_
  • COBCH1428 OO_ Method %1_s in interface %2_s not implemented_
  • COBCH1429 OO_ Method %1_s does not conform to that in class_interface %2_s
Parent topic: Messages COBCH1401 to COBCH1500


COBCH1421 OO_ Parameters of Method '%1_s' do not conform to Repository_

Parent topic: COBCH1421 - COBCH1440


COBCH1422 OO_ Call Convention of '%1_s' does not match that in the Repository_

Parent topic: COBCH1421 - COBCH1440


COBCH1423 OO_ Number of parameters of '%1_s' does not match Repository entry_

Parent topic: COBCH1421 - COBCH1440


COBCH1424 OO_ The Prototype for Method '%1_s' was not found_

Parent topic: COBCH1421 - COBCH1440


COBCH1425 OO_ Duplicated Internal Method name '%1_s'_

Parent topic: COBCH1421 - COBCH1440


COBCH1426 OO_ Duplicated External Method name '%1_s'_

Parent topic: COBCH1421 - COBCH1440


COBCH1427 OO_ Method_Function '%1_s" does not have a RETURNING clause defined_

Parent topic: COBCH1421 - COBCH1440


COBCH1428 OO_ Method %1_s in interface %2_s not implemented_

Parent topic: COBCH1421 - COBCH1440


COBCH1429 OO_ Method %1_s does not conform to that in class_interface %2_s

Parent topic: COBCH1421 - COBCH1440


COBCH1441 - COBCH1460

Lists the Syntax Checking error messages from COBCH1441 through COBCH1460.

  • COBCH1450 PIC 1 with CHARSET(EBCDIC) not supported
  • COBCH1451 Boolean with reference modification not supported
  • COBCH1452 MOVE of boolean to and from national not supported
  • COBCH1453 PIC 1 with VALUE FROM not supported
  • COBCH1454 PIC 1 with JUSTIFIED clause not supported
  • COBCH1455 Sliding items after PIC 1 table not supported
  • COBCH1456 Sliding PIC 1 items not supported
  • COBCH1457 PIC 1 fields > <num> not supported
  • COBCH1458 PIC 1 fields > <num> not supported. (Group-usage size: <num>)
  • COBCH1459 Only '=' and 'NOT =' allowed for boolean data items
  • COBCH1460 Arithmetic operator not allowed in boolean expression
Parent topic: Messages COBCH1401 to COBCH1500


COBCH1450 PIC 1 with CHARSET(EBCDIC) not supported

Boolean data items are only supported for ASCII environments.

Parent topic: COBCH1441 - COBCH1460


COBCH1451 Boolean with reference modification not supported

You cannot use reference modification on a boolean data item or a group item defined by the GROUP-USAGE BIT clause.

Parent topic: COBCH1441 - COBCH1460


COBCH1452 MOVE of boolean to and from national not supported

Boolean data items can only be moved to alphanumeric and alphanumeric-edited data items, and from alphanumeric data items.

Parent topic: COBCH1441 - COBCH1460


COBCH1453 PIC 1 with VALUE FROM not supported

You cannot define the values for the boolean elements of a table for a specified range of index values.

Parent topic: COBCH1441 - COBCH1460


COBCH1454 PIC 1 with JUSTIFIED clause not supported

The JUSTIFIED clause cannot be specified for boolean data items.

Parent topic: COBCH1441 - COBCH1460


COBCH1455 Sliding items after PIC 1 table not supported

If you use the ODOSLIDE directive, you cannot have boolean data items following a variable-length table in the same record; neither can you have data items following a variable-length table containing boolean data items.

Parent topic: COBCH1441 - COBCH1460


COBCH1456 Sliding PIC 1 items not supported

If you use the ODOSLIDE directive, you cannot have boolean data items following a variable-length table in the same record; neither can you have data items following a variable-length table containing boolean data items.

Parent topic: COBCH1441 - COBCH1460


COBCH1457 PIC 1 fields > <num> not supported

You have tried to define a boolean data item that is longer than the maximum allowed.

Parent topic: COBCH1441 - COBCH1460


COBCH1458 PIC 1 fields > <num> not supported. (Group-usage size: <num>)

You have tried to define a boolean data item that is longer than the maximum allowed.

Parent topic: COBCH1441 - COBCH1460


COBCH1459 Only '=' and 'NOT =' allowed for boolean data items

When comparing boolean items, you can only check whether the items are equal or unequal.

Parent topic: COBCH1441 - COBCH1460


COBCH1460 Arithmetic operator not allowed in boolean expression

Boolean expressions cannot contain the operators "+", "-", "/", "*", or "**".

Parent topic: COBCH1441 - COBCH1460


COBCH1461 - COBCH1480

Lists the Syntax Checking error messages from COBCH1461 through COBCH1480.

  • COBCH1461 To enable boolean literals BINLIT(BOOLEAN) must be specified
  • COBCH1462 KEY may not be of type boolean
  • COBCH1463 Boolean argument required
  • COBCH1464 Boolean argument not allowed
  • COBCH1465 Function BOOLEAN-OF-INTEGER, bit length needs to be an integer constant
  • COBCH1466 Boolean parameter must be aligned on a byte boundary
  • COBCH1467 Cannot pass boolean BY VALUE
  • COBCH1468 RETURNING boolean not supported
  • COBCH1480 Illegal use of condition name
Parent topic: Messages COBCH1401 to COBCH1500


COBCH1461 To enable boolean literals BINLIT(BOOLEAN) must be specified

Use the BINLIT directive to control whether binary b"" literals are interpreted as numeric values, or Boolean values for use with PIC 1 data items.

Parent topic: COBCH1461 - COBCH1480


COBCH1462 KEY may not be of type boolean

You cannot define a KEY to be a boolean data item.

Parent topic: COBCH1461 - COBCH1480


COBCH1463 Boolean argument required

This function must have a boolean argument.

Parent topic: COBCH1461 - COBCH1480


COBCH1464 Boolean argument not allowed

This function cannot have a boolean argument.

Parent topic: COBCH1461 - COBCH1480


COBCH1465 Function BOOLEAN-OF-INTEGER, bit length needs to be an integer constant

The BOOLEAN-OF-INTEGER function returns a boolean item of usage bit representing the binary equivalent of a value. The length of the returned value must be expressed as a positive nonzero integer or numeric constant.

Parent topic: COBCH1461 - COBCH1480


COBCH1466 Boolean parameter must be aligned on a byte boundary

Parent topic: COBCH1461 - COBCH1480


COBCH1467 Cannot pass boolean BY VALUE

Parent topic: COBCH1461 - COBCH1480


COBCH1468 RETURNING boolean not supported

Parent topic: COBCH1461 - COBCH1480


COBCH1480 Illegal use of condition name

Parent topic: COBCH1461 - COBCH1480


COBCH1481 - COBCH1500

Lists the Syntax Checking error messages from COBCH1481 through COBCH1500.

  • COBCH1481 Boundary violation_ Processed as maximum value (%1_s)
    A boundary violation has occurred because reference modification has referred to data beyond the boundaries of the base data item.
  • COBCH1492 Ambiguous type name '%1_s, could refer to either '%2_s' or '%3_s'
    An ambiguous reference has been made to a type name that is found in two or more namespaces referenced in ILUSING directives.
  • COBCH1498 Preprocessor file logic error
    A preprocessor has passed an incorrect or unexpected sequence of response codes.
  • COBCH1500 Memory allocation failure - module_ '%1_s'
Parent topic: Messages COBCH1401 to COBCH1500


COBCH1481 Boundary violation_ Processed as maximum value (%1_s)

A boundary violation has occurred because reference modification has referred to data beyond the boundaries of the base data item.

Example:

The following code will result in this error:

$SET VSC2(3)
 01 ITEM1 PIC X(256).
 01 ITEM2 PIC X(1).
      MOVE ITEM2(1:256) TO ITEM1.

Resolution:

Check your code for data items being manipulated with reference modification and ensure that either the data item being moved is of sufficient size or that the reference modification parameters are set correctly.

Parent topic: COBCH1481 - COBCH1500


COBCH1492 Ambiguous type name '%1_s, could refer to either '%2_s' or '%3_s'

An ambiguous reference has been made to a type name that is found in two or more namespaces referenced in ILUSING directives.

Resolution:

To resolve the error, you can either:

  • Specify the fully qualified type name in the code.
  • Modify the names of the imported usings/projects, to ensure their namespaces are unique.
Parent topic: COBCH1481 - COBCH1500


COBCH1498 Preprocessor file logic error

A preprocessor has passed an incorrect or unexpected sequence of response codes.

For example, there is no corresponding end of copybook code when the start of a copybook has been indicated.

Parent topic: COBCH1481 - COBCH1500


COBCH1500 Memory allocation failure - module_ '%1_s'

Parent topic: COBCH1481 - COBCH1500


Messages COBCH1501 to COBCH1600

  • COBCH1501 - COBCH1520
    Lists the Syntax Checking error messages from COBCH1501 through COBCH1520.
  • COBCH1521 - COBCH1540
    Lists the Syntax Checking error messages from COBCH1521 through COBCH1540.
  • COBCH1541 - COBCH1560
    Lists the Syntax Checking error messages from COBCH1541 through COBCH1560.
  • COBCH1561 - COBCH1580
    Lists the Syntax Checking error messages from COBCH1561 through COBCH1580.
  • COBCH1581 - COBCH1600
    Lists the Syntax Checking error messages from COBCH1581 through COBCH1600.
Parent topic: Syntax Checking Error Messages


COBCH1501 - COBCH1520

Lists the Syntax Checking error messages from COBCH1501 through COBCH1520.

  • COBCH1501 Insufficient memory
  • COBCH1502 Open fail _ '%1_s'
  • COBCH1503 Read error_ '%1_s'
  • COBCH1504 I-O error _ %1_s %2_s
  • COBCH1505 I-O error _ IDY file
  • COBCH1506 Checker _ pointer or index invalid - module_ '%1_s'
  • COBCH1507 Illegal command line
  • COBCH1508 Unknown XFD directive_ '%1_s'
  • COBCH1509 Missing '_' in XFD directive
  • COBCH1510 XFD value should be a name_ %1_s
  • COBCH1511 XFD value should be numeric_ %1_s
  • COBCH1512 XFD value should be a literal_ %1_s
  • COBCH1513 GROUP expected after USE
  • COBCH1514 Date format missing
  • COBCH1515 Missing field name after WHEN
  • COBCH1516 Condition value too long (%1_s max)
  • COBCH1517 Invalid date format
  • COBCH1518 Field %1_s causes duplicate data data
  • COBCH1519 Too many AND_OR conditions (50 max)
    Your source code has exceeded the number of AND or OR conditions in a single XFD WHEN directive, or has exceeded the number of XFD WHEN directives allowed.
  • COBCH1520 Error - duplicate file name
Parent topic: Messages COBCH1501 to COBCH1600


COBCH1501 Insufficient memory

Parent topic: COBCH1501 - COBCH1520


COBCH1502 Open fail _ '%1_s'

Parent topic: COBCH1501 - COBCH1520


COBCH1503 Read error_ '%1_s'

Parent topic: COBCH1501 - COBCH1520


COBCH1504 I-O error _ %1_s %2_s

Parent topic: COBCH1501 - COBCH1520


COBCH1505 I-O error _ IDY file

Parent topic: COBCH1501 - COBCH1520


COBCH1506 Checker _ pointer or index invalid - module_ '%1_s'

Parent topic: COBCH1501 - COBCH1520


COBCH1507 Illegal command line

Parent topic: COBCH1501 - COBCH1520


COBCH1508 Unknown XFD directive_ '%1_s'

Parent topic: COBCH1501 - COBCH1520


COBCH1509 Missing '_' in XFD directive

Parent topic: COBCH1501 - COBCH1520


COBCH1510 XFD value should be a name_ %1_s

Parent topic: COBCH1501 - COBCH1520


COBCH1511 XFD value should be numeric_ %1_s

Parent topic: COBCH1501 - COBCH1520


COBCH1512 XFD value should be a literal_ %1_s

Parent topic: COBCH1501 - COBCH1520


COBCH1513 GROUP expected after USE

Parent topic: COBCH1501 - COBCH1520


COBCH1514 Date format missing

Parent topic: COBCH1501 - COBCH1520


COBCH1515 Missing field name after WHEN

Parent topic: COBCH1501 - COBCH1520


COBCH1516 Condition value too long (%1_s max)

Parent topic: COBCH1501 - COBCH1520


COBCH1517 Invalid date format

Parent topic: COBCH1501 - COBCH1520


COBCH1518 Field %1_s causes duplicate data data

Parent topic: COBCH1501 - COBCH1520


COBCH1519 Too many AND_OR conditions (50 max)

Your source code has exceeded the number of AND or OR conditions in a single XFD WHEN directive, or has exceeded the number of XFD WHEN directives allowed.
Parent topic: COBCH1501 - COBCH1520


COBCH1520 Error - duplicate file name

Parent topic: COBCH1501 - COBCH1520


COBCH1521 - COBCH1540

Lists the Syntax Checking error messages from COBCH1521 through COBCH1540.

  • COBCH1521 Error - when field not found
  • COBCH1522 Error - internal XFD error 23
  • COBCH1523 Internal error - occurs inconsistency
  • COBCH1524 Error - invalid directive combination
  • COBCH1525 Error - XSL information too long
  • COBCH1526 Error - insufficient memory
  • COBCH1527 Internal error - not enough attributes (NO LONGER USED)
  • COBCH1528 File %1_s _ no matching field for condition %2_s
  • COBCH1529 Warning - directive word too long _ %1_s
  • COBCH1530 File %1_s _ variable filename requires "File" directive
  • COBCH1531 Warning - field %1_s causes duplicate database data
  • COBCH1532 Warning - field %1_s causes duplicate data
  • COBCH1533 Warning - %1_s not unique in first 30 characters
  • COBCH1534 File %1_s _ data missing from key segment %2_s
  • COBCH1535 File %1_s _ bad picture for date field %2_s
  • COBCH1536 XFD directive line continuation error - XFD directive ignored
  • COBCH1537 XFD WHEN directive mismatched parentheses
  • COBCH1538 XFD WHEN directive syntax error
  • COBCH1539 VALUE clause not allowed in conjunction with OCCURS ANY
  • COBCH1540 Only available with XMLPARSE(XMLSS) compiler option
Parent topic: Messages COBCH1501 to COBCH1600


COBCH1521 Error - when field not found

Parent topic: COBCH1521 - COBCH1540


COBCH1522 Error - internal XFD error 23

Parent topic: COBCH1521 - COBCH1540


COBCH1523 Internal error - occurs inconsistency

Parent topic: COBCH1521 - COBCH1540


COBCH1524 Error - invalid directive combination

Parent topic: COBCH1521 - COBCH1540


COBCH1525 Error - XSL information too long

Parent topic: COBCH1521 - COBCH1540


COBCH1526 Error - insufficient memory

Parent topic: COBCH1521 - COBCH1540


COBCH1527 Internal error - not enough attributes (NO LONGER USED)

Parent topic: COBCH1521 - COBCH1540


COBCH1528 File %1_s _ no matching field for condition %2_s

Parent topic: COBCH1521 - COBCH1540


COBCH1529 Warning - directive word too long _ %1_s

Parent topic: COBCH1521 - COBCH1540


COBCH1530 File %1_s _ variable filename requires "File" directive

Parent topic: COBCH1521 - COBCH1540


COBCH1531 Warning - field %1_s causes duplicate database data

Parent topic: COBCH1521 - COBCH1540


COBCH1532 Warning - field %1_s causes duplicate data

Parent topic: COBCH1521 - COBCH1540


COBCH1533 Warning - %1_s not unique in first 30 characters

Parent topic: COBCH1521 - COBCH1540


COBCH1534 File %1_s _ data missing from key segment %2_s

Parent topic: COBCH1521 - COBCH1540


COBCH1535 File %1_s _ bad picture for date field %2_s

Parent topic: COBCH1521 - COBCH1540


COBCH1536 XFD directive line continuation error - XFD directive ignored

Parent topic: COBCH1521 - COBCH1540


COBCH1537 XFD WHEN directive mismatched parentheses

Parent topic: COBCH1521 - COBCH1540


COBCH1538 XFD WHEN directive syntax error

Parent topic: COBCH1521 - COBCH1540


COBCH1539 VALUE clause not allowed in conjunction with OCCURS ANY

Parent topic: COBCH1521 - COBCH1540


COBCH1540 Only available with XMLPARSE(XMLSS) compiler option

Parent topic: COBCH1521 - COBCH1540


COBCH1541 - COBCH1560

Lists the Syntax Checking error messages from COBCH1541 through COBCH1560.

  • COBCH1541 XML-SCHEMA %1_s missing or illegal
  • COBCH1542 ACU threading syntax is not supported
  • COBCH1543 This ACU syntax is not supported
  • COBCH1544 ACU ACCEPT_DISPLAY extension is not supported
  • COBCH1545 Feature not yet supported when compiling for JVM
  • COBCH1546 Not allowed with DELEGATE programs
  • COBCH1547 Constructors cannot have a RETURNING item
  • COBCH1548 A concatenation expression cannot be used as a receiving item
  • COBCH1549 Concatenation expression has too many operands
  • COBCH1550 FOR interface not implemented by this class
  • COBCH1551 Recursive use of TYPEDEF name
  • COBCH1552 Perform range too large or complex
  • COBCH1553 Warning - JVM classpath %1_s is ignored
  • COBCH1554 Error - More than 65535 statements in a paragraph. Cannot produce debugging information
    A paragraph in the program contains too many statements to produce a .IDY file, and therefore cannot be debugged.
  • COBCH1555 Cannot access object data declared in a containing class
    An attempt to access object data in a containing class has been made from a nested class.
  • COBCH1556 Invalid JVM runtime: Possibly due to mixing 32 and 64 bit support
    The JVM runtime could not be loaded.
  • COBCH1557 Failed to find JVM type subsystem
  • COBCH1558 Failed to start JVM
    The JVM runtime could not be loaded.
  • COBCH1559 JVM type support failed: Unexpected failure of operation during operation of type support
  • COBCH1560 JVM support not loaded: the mfjvmlib library could not be loaded
    The mfjvmlib class library could not be located.
Parent topic: Messages COBCH1501 to COBCH1600


COBCH1541 XML-SCHEMA %1_s missing or illegal

Parent topic: COBCH1541 - COBCH1560


COBCH1542 ACU threading syntax is not supported

Parent topic: COBCH1541 - COBCH1560


COBCH1543 This ACU syntax is not supported

Parent topic: COBCH1541 - COBCH1560


COBCH1544 ACU ACCEPT_DISPLAY extension is not supported

Parent topic: COBCH1541 - COBCH1560


COBCH1545 Feature not yet supported when compiling for JVM

Parent topic: COBCH1541 - COBCH1560


COBCH1546 Not allowed with DELEGATE programs

Parent topic: COBCH1541 - COBCH1560


COBCH1547 Constructors cannot have a RETURNING item

Parent topic: COBCH1541 - COBCH1560


COBCH1548 A concatenation expression cannot be used as a receiving item

Parent topic: COBCH1541 - COBCH1560


COBCH1549 Concatenation expression has too many operands

Parent topic: COBCH1541 - COBCH1560


COBCH1550 FOR interface not implemented by this class

Parent topic: COBCH1541 - COBCH1560


COBCH1551 Recursive use of TYPEDEF name

Parent topic: COBCH1541 - COBCH1560


COBCH1552 Perform range too large or complex

Parent topic: COBCH1541 - COBCH1560


COBCH1553 Warning - JVM classpath %1_s is ignored

Parent topic: COBCH1541 - COBCH1560


COBCH1554 Error - More than 65535 statements in a paragraph. Cannot produce debugging information

A paragraph in the program contains too many statements to produce a .IDY file, and therefore cannot be debugged.

Restructure the program to reduce the number of statements in a single paragraph.

Parent topic: COBCH1541 - COBCH1560


COBCH1555 Cannot access object data declared in a containing class

An attempt to access object data in a containing class has been made from a nested class.

To access object data in a containing class, the nested class must specify the SHARING PARENT phrase.

class-id myContainingClass.
working-storage section.
01 i1 binary-long VALUE 1.
01 i2 string.

class-id myNestedClass1.
method-id myMethod1.
  set i2 to "abc".  *> this is incorrect
end method.
end class.

class-id myNestedClass2 sharing parent.
method-id myMethod2.
  set i1 to 123.  *> this is correct
end method.
end class.

end class.
Parent topic: COBCH1541 - COBCH1560


COBCH1556 Invalid JVM runtime: Possibly due to mixing 32 and 64 bit support

The JVM runtime could not be loaded.

Check that the JAVA_HOME environment variable is set to the appropriate runtime engine that your application is being compiled for.

Parent topic: COBCH1541 - COBCH1560


COBCH1557 Failed to find JVM type subsystem

Parent topic: COBCH1541 - COBCH1560


COBCH1558 Failed to start JVM

The JVM runtime could not be loaded.

Check that the JAVA_HOME environment variable is set to the appropriate runtime engine that your application is being compiled for.

Parent topic: COBCH1541 - COBCH1560


COBCH1559 JVM type support failed: Unexpected failure of operation during operation of type support

Parent topic: COBCH1541 - COBCH1560


COBCH1560 JVM support not loaded: the mfjvmlib library could not be loaded

The mfjvmlib class library could not be located.

Ensure the environment variable appropriate to your environment is set to locate mfjvmlib.dll correctly:

  • PATH on Windows
  • LD_LIBRARY_PATH on UNIX
  • LIBPATH on AIX and HP-UX
Parent topic: COBCH1541 - COBCH1560


COBCH1561 - COBCH1580

Lists the Syntax Checking error messages from COBCH1561 through COBCH1580.

  • COBCH1561 JVM support not found: possibly the type info helper classes were not on the classpath
  • COBCH1562 $ statement not recognized
    Incorrect syntax has been specified after $ in a declaration statement for a Compiler directive.
  • COBCH1563 Directive %1$s is deprecated and may be removed in future releases
    The specified Compiler directive has been deprecated and no longer has an effect on your source code.
  • COBCH1564 First parameter to an extension method must be passed BY VALUE
    The first parameter passed to an extension method must be a value parameter, not reference parameter.
  • COBCH1565 NULL value set on non-included field %1s
    The NULL XFD Compiler directive has been set on a field that does not exist in the database.
  • COBCH1566 NULL value set on key fields %1$s
    The NULL XFD Compiler directive has been set on a key field.
  • COBCH1567 VALUETYPE definition must have at least one instance field
    A valuetype must have at least one instance field in its construction.
  • COBCH1568 VALUETYPE instance field cannot have circular reference
    A field in a valuetype cannot specify a circular reference.
  • COBCH1569 Could not load ILPINVOKE file '%1$s'
    The .dll file specified by the ILPINVOKE Compiler directive does not exist or cannot be located.
  • COBCH1570 END name '%1$s' does not match corresponding header name
    The Program-ID marker and the End Program marker do not match.
  • COBCH1571 ILREF directive failed - file not found or access error
  • COBCH1572 ILREF directive has invalid type name
  • COBCH1573 ILREF directive failed - incorrect or corrupt class file format
  • COBCH1574 Reserved word missing - FROM or THROUGH expected
    An expected reserved word is missing from a statement.
  • COBCH1575 SELF and SUPER cannot be receiving items
    Incorrect syntax has been used.
  • COBCH1576 REFERENCE parameters not supported for functions in Managed COBOL
    An attempt to pass a parameter by reference into a function type has been made
  • COBCH1577 ILPINVOKE not supported with JVMGEN
    You cannot invoke a native COBOL .dll file when compiling to JVM COBOL.
  • COBCH1578 VALUETYPE instance field cannot have VALUE
    An instance field in a valuetype cannot have a VALUE clause defined.
  • COBCH1579 VALUETYPE cannot have an explicit parameter-less constructor
    Within a valuetype, you must pass a parameter into a constructor method.
  • COBCH1580 Too many END markers
    An END marker that has no corresponding definition has been found.
Parent topic: Messages COBCH1501 to COBCH1600


COBCH1561 JVM support not found: possibly the type info helper classes were not on the classpath

Parent topic: COBCH1561 - COBCH1580


COBCH1562 $ statement not recognized

Incorrect syntax has been specified after $ in a declaration statement for a Compiler directive.

Ensure that the statement syntax is as follows, also ensuring that $ appears in column 7:

$set directive-name{options}

For example:

$set sourceformat(free)
Parent topic: COBCH1561 - COBCH1580


COBCH1563 Directive %1$s is deprecated and may be removed in future releases

The specified Compiler directive has been deprecated and no longer has an effect on your source code.

You should plan to remove the directive from your source code.

Parent topic: COBCH1561 - COBCH1580


COBCH1564 First parameter to an extension method must be passed BY VALUE

The first parameter passed to an extension method must be a value parameter, not reference parameter.

To define an extension method:

  • Use the EXTENSION keyword in the method header.
  • The method must be in a static class that is not nested or generic. The method is implicitly static.
  • In the method body, the first parameter is the type to extend. It is always a value parameter.

Example:

The following extension method extends the string class, by adding a method to count the number of words in a string:

       class-id MyCount static.
       method-id CountWords extension. *> extension method is implicitly static
       procedure division using str as string
                          returning wordCount as binary-long.
            set wordCount to str::Split(' ')::Length
       end method.
       end class.
Parent topic: COBCH1561 - COBCH1580


COBCH1565 NULL value set on non-included field %1s

The NULL XFD Compiler directive has been set on a field that does not exist in the database.

Remove the directive from the file description of the field.

Parent topic: COBCH1561 - COBCH1580


COBCH1566 NULL value set on key fields %1$s

The NULL XFD Compiler directive has been set on a key field.

You cannot use this Compiler directive on any record or alternate key fields; remove the directive from the file description of the key field.

Parent topic: COBCH1561 - COBCH1580


COBCH1567 VALUETYPE definition must have at least one instance field

A valuetype must have at least one instance field in its construction.

The following valuetype has two instance fields.

valuetype-id StudentRecord.
 01 #name string public.   *> an instance field
 01 gpa float-short public. *> another instance field
 method-id new.
  procedure division using by value nam as string,
                                  gpa as float-short.
  set #name to nam
  set self::"gpa" to gpa
 end method.
end valuetype.
Parent topic: COBCH1561 - COBCH1580
Related reference
COBCH1579 VALUETYPE cannot have an explicit parameter-less constructor
COBCH1578 VALUETYPE instance field cannot have VALUE


COBCH1568 VALUETYPE instance field cannot have circular reference

A field in a valuetype cannot specify a circular reference.

The following example contains a circular reference, which causes the error. Change the specified field type.

valuetype-id myValuetype.
  01 field-1 type myValuetype  *> the field cannot be of type myValuetype
  method-id myMethod-1.
  ...
  end method.
end valuetype.
Parent topic: COBCH1561 - COBCH1580


COBCH1569 Could not load ILPINVOKE file '%1$s'

The .dll file specified by the ILPINVOKE Compiler directive does not exist or cannot be located.
Parent topic: COBCH1561 - COBCH1580


COBCH1570 END name '%1$s' does not match corresponding header name

The Program-ID marker and the End Program marker do not match.

Amend either of the markers so that they match, then recompile.

Parent topic: COBCH1561 - COBCH1580


COBCH1571 ILREF directive failed - file not found or access error

Parent topic: COBCH1561 - COBCH1580


COBCH1572 ILREF directive has invalid type name

Parent topic: COBCH1561 - COBCH1580


COBCH1573 ILREF directive failed - incorrect or corrupt class file format

Parent topic: COBCH1561 - COBCH1580


COBCH1574 Reserved word missing - FROM or THROUGH expected

An expected reserved word is missing from a statement.

Refer to Managed COBOL language reference for expected syntax.

Parent topic: COBCH1561 - COBCH1580
Related concepts
Structural Syntax Elements


COBCH1575 SELF and SUPER cannot be receiving items

Incorrect syntax has been used.

The following example shows correct and an incorrect usage of the self:: syntax:

class-id myClass.
  01 field-a string.
  method-id myMethod.
    set self to "Micro Focus"			*> this is incorrect
    set self::field-a to "Micro Focus"		*> this is correct
  end method.
end class.

Refer to Managed COBOL language reference for expected syntax.

Parent topic: COBCH1561 - COBCH1580
Related concepts
Structural Syntax Elements


COBCH1576 REFERENCE parameters not supported for functions in Managed COBOL

An attempt to pass a parameter by reference into a function type has been made

In managed COBOL, parameters can only be passed by value for function types.

function-id myFunction.
   procedure division using by reference myParam as binary-long. *> this causes the error
   ...
end function.
function-id myFunction.
 procedure division using by value myParam as binary-long. *> this is correct
 ...
end function.
function-id myFunction.
 procedure division using myParam as binary-long. *> this is correct - by  value assumed
 ...
end function.
Parent topic: COBCH1561 - COBCH1580


COBCH1577 ILPINVOKE not supported with JVMGEN

You cannot invoke a native COBOL .dll file when compiling to JVM COBOL.
Parent topic: COBCH1561 - COBCH1580


COBCH1578 VALUETYPE instance field cannot have VALUE

An instance field in a valuetype cannot have a VALUE clause defined.

Remove the clause from the definition and recompile.

The following example contains an illegal construction for the #name instance field:

valuetype-id StudentRecord.
 01 #name string public VALUE "Mike Focus". *> remove the VALUE clause
 01 gpa float-short public.
 method-id new.
  procedure division using by value nam as string,
                                  gpa as float-short.
  set #name to nam
  set self::"gpa" to gpa
 end method.
end valuetype.
Parent topic: COBCH1561 - COBCH1580
Related reference
COBCH1579 VALUETYPE cannot have an explicit parameter-less constructor
COBCH1567 VALUETYPE definition must have at least one instance field


COBCH1579 VALUETYPE cannot have an explicit parameter-less constructor

Within a valuetype, you must pass a parameter into a constructor method.

The following valuetype has two constructors. The first is parameter-less, and thus causes the error. The second example shows the correct syntax.

valuetype-id MyClassLibrary.MyValuetype1.
01 _powerlevel binary-long.
method-id new.
procedure division.  *> this is incorrect
  set _powerLevel to 0
end method.

method-id new.
procedure division using by value powerLevel as binary-long.  *> this is correct
  set _powerLevel to powerLevel
end method.
end valuetype.
Parent topic: COBCH1561 - COBCH1580
Related reference
COBCH1578 VALUETYPE instance field cannot have VALUE
COBCH1567 VALUETYPE definition must have at least one instance field


COBCH1580 Too many END markers

An END marker that has no corresponding definition has been found.

Delete the erroneous END marker and recompile.

Parent topic: COBCH1561 - COBCH1580


COBCH1581 - COBCH1600

Lists the Syntax Checking error messages from COBCH1581 through COBCH1600.
  • COBCH1581 Could not load dependent assembly '%1$s'
    An indirectly referenced assembly has failed to load.
  • COBCH1582 ACU DESTROY statement is not supported
    The DESTROY statement is not supported in this COBOL system.
  • COBCH1583 ACU INQUIRE statement is not supported
    The INQUIRE statement is not supported in this COBOL system.
  • COBCH1584 ACU MODIFY statement is not supported
    The MODIFY statement is not supported in this COBOL system.
  • COBCH1585 Could not find peverify.exe, required for ILVERIFY(CHECK)
    The utility peverify.exe, which is called if you compile using ILVERIFY(check), is missing from the local machine.
  • COBCH1600 Property must define at least one of GETTER or SETTER
    A property has not been defined correctly, because it is defined without a GETTER or a SETTER phrase.
Parent topic: Messages COBCH1501 to COBCH1600


COBCH1581 Could not load dependent assembly '%1$s'

An indirectly referenced assembly has failed to load.

An indirectly referenced assembly is one that is referenced from an assembly directly referenced from your project.

To help you diagnose further, use the Assembly Binding Log Viewer (fuslogvw.exe), available as part of the Visual Studio tools.

Parent topic: COBCH1581 - COBCH1600


COBCH1582 ACU DESTROY statement is not supported

The DESTROY statement is not supported in this COBOL system.

Remove the statement from your source code.

Parent topic: COBCH1581 - COBCH1600


COBCH1583 ACU INQUIRE statement is not supported

The INQUIRE statement is not supported in this COBOL system.

Remove the statement from your source code.

Parent topic: COBCH1581 - COBCH1600


COBCH1584 ACU MODIFY statement is not supported

The MODIFY statement is not supported in this COBOL system.

Remove the statement from your source code.

Parent topic: COBCH1581 - COBCH1600


COBCH1585 Could not find peverify.exe, required for ILVERIFY(CHECK)

The utility peverify.exe, which is called if you compile using ILVERIFY(check), is missing from the local machine.

Peverify.exe is installed as default with the full version of Microsoft Visual Studio 2010, but not with the Visual Studio 2010 Shell. It is also available as part of the .NET Framework Tools, which you can download and install.

Parent topic: COBCH1581 - COBCH1600


COBCH1600 Property must define at least one of GETTER or SETTER

A property has not been defined correctly, because it is defined without a GETTER or a SETTER phrase.

The following example shows the property myProperty with both the GETTER and SETTER phrases:

property-id myProperty string.
  getter.
  set property-value to field-1.
  setter.
  set field-2 to property-value.
end property.
Parent topic: COBCH1581 - COBCH1600


Messages COBCH1601 - COBCH1700

  • COBCH1601 - COBCH1620
    Lists the Syntax Checking error messages from COBCH1601 through COBCH1620.
  • COBCH1621 - COBCH1640
    Lists the Syntax Checking error messages from COBCH1621 through COBCH1640.
Parent topic: Syntax Checking Error Messages


COBCH1601 - COBCH1620

Lists the Syntax Checking error messages from COBCH1601 through COBCH1620.
  • COBCH1601 Property cannot have parameters
    The Procedure Division header within a property-id has parameters specified.
  • COBCH1602 Indexer must have at least one parameter
    The Procedure Division header within an indexer-id does not have a parameter specified.
  • COBCH1603 No indexer found for class '%1$s'
    An instance of a type that does not contain an indexer is being accessed as an array.
  • COBCH1604 Cannot inherit from interface '%1$s'
    The interface that you are trying to inherit does exist, but there is a problem with its construction.
  • COBCH1605 Entry name '%1$s' reserved for use by Micro Focus
    The specified entry point name is reserved for managed COBOL syntax.
  • COBCH1606 Syntax can only be used with LIST and DICTIONARY items
    Certain syntax can only be used on items of type LIST or DICTIONARY.
  • COBCH1607 Syntax can only be used with DICTIONARY items
    Certain syntax can only be used on items of type DICTIONARY.
  • COBCH1608 Illegal USAGE in this context
    The specified USAGE type has been used out of context.
  • COBCH1609 Property accessor visibility must be stricter than property visibility
    The visibility of a GETTER or SETTER phrase is not as strict as the visibility of its containing property.
  • COBCH1610 Cannot specify visibility on both GETTER and SETTER
    Both the GETTER and SETTER phrases of a property specify visibility.
  • COBCH1611 Can only specify accessor visibility if property has both GETTER and SETTER
    The property is missing a GETTER or SETTER phrase due to accessor visibility being specified.
  • COBCH1612 ACU picture string not supported
    You have specified an invalid picture string, for example, a mixture of symbols specified for zero suppression.
  • COBCH1613 Syntax error error not allowed
    A general syntax error has occurred.
  • COBCH1614 INSPECT TRAILING match item must be single character item
    You have specified an invalid TRAILING item in the INSPECT statement; you must specify a single character item.
  • COBCH1615 ACU statement COPY RESOURCE not supported; statement ignored
    The COPY RESOURCE statement is not supported in this COBOL system.
  • COBCH1616 Can only be used in nested class
    You have attempted to use nested-specific syntax in a class that is not nested.
  • COBCH1617 WITH COMPRESSION or WITH ENCRYPTION are only supported in ACU mode when DATACOMPRESS is off
    You have specified the WITH COMPRESSION or WITH ENCRYPTION phrase on a file in a program that also has the DATACOMPRESS Compiler directive set.
  • COBCH1618 WITH COMPRESSION or WITH ENCRYPTION are only valid for INDEX files
    You have specified the WITH COMPRESSION or WITH ENCRYPTION phrase on a file that is not an indexed file.
  • COBCH1619 Must specify one generic parameter
    The predefined LIST type must be specified with one generic parameter.
  • COBCH1620 Must specify two generic parameters
    The predefined DICTIONARY type must be specified with two generic parameters.
Parent topic: Messages COBCH1601 - COBCH1700


COBCH1601 Property cannot have parameters

The Procedure Division header within a property-id has parameters specified.

The Procedure Division header in a property-id must not have any parameters.

class-id myClass.
property-id myProp1 string.
procedure division using myField as string. *> this is incorrect
    getter.
    set property-value to "Micro Focus"
end property.

property-id myProp2 string.
procedure division.	*> this is correct
    getter.
    set property-value to "Studio Enterprise Edition"
end property.
end class.
Parent topic: COBCH1601 - COBCH1620


COBCH1602 Indexer must have at least one parameter

The Procedure Division header within an indexer-id does not have a parameter specified.

You must specify at least one parameter in the Procedure Division header:

class-id myClass1.
indexer-id string.
procedure division. *> this is incorrect - no parameter specified
    getter.
    set property-value to "abc"
end indexer.
end class.

class-id myClass2.
01 myField string value "abc".
indexer-id string.
procedure division using value myParam as binary-long. *> this is correct
    getter.
    set property-value to a
end indexer.
end class.
Parent topic: COBCH1601 - COBCH1620


COBCH1603 No indexer found for class '%1$s'

An instance of a type that does not contain an indexer is being accessed as an array.

A type must contain an indexer if an instance of that type is being accessed as an array, as shown in the following example:

class-id myClass1.
method-id main.
01 myField type myClass2.
    display myField[0]
end method.
end class.

class-id myClass2.
indexer-id string.		*> add an indexer to resolve the error
procedure division using value myParam as binary-long.
    getter.
    set property-value to myParam
end indexer.
end class.
Parent topic: COBCH1601 - COBCH1620


COBCH1604 Cannot inherit from interface '%1$s'

The interface that you are trying to inherit does exist, but there is a problem with its construction.

For example, the following example fails because the interface that is being inherited is empty.

class-id myClass inherits type myInterface.
...
end class.

interface-id myInterface.
end interface.

Add a method or some other valid construction to the interface to fix the error.

Parent topic: COBCH1601 - COBCH1620


COBCH1605 Entry name '%1$s' reserved for use by Micro Focus

The specified entry point name is reserved for managed COBOL syntax.

You must change the name of your entry point.

Parent topic: COBCH1601 - COBCH1620


COBCH1606 Syntax can only be used with LIST and DICTIONARY items

Certain syntax can only be used on items of type LIST or DICTIONARY.

Some syntax is specifically designed for collection types. To use this syntax, the item must be of LIST or DICTIONARY type.

Parent topic: COBCH1601 - COBCH1620
Related concepts
Structural Syntax Elements


COBCH1607 Syntax can only be used with DICTIONARY items

Certain syntax can only be used on items of type DICTIONARY.

In the following example, change the myField1 field to type DICTIONARY to be able to use the key keyword in the PERFORM statement:

class-id myClass.
01 myField1 list[string].
01 myField2 string.
method-id myMethod.
  perform varying key myField2 through myField1
  ...
  end-perform.
end method.
end class.
Parent topic: COBCH1601 - COBCH1620
Related concepts
Structural Syntax Elements


COBCH1608 Illegal USAGE in this context

The specified USAGE type has been used out of context.

Certain USAGE types cannot be used in the procedure division header. For example:

class-id myClass1.

indexer-id string.
procedure division using i1 as COMP-3. *> this is incorrect
    getter.
    set property-value to i1.
end indexer.
end class.

class-id myClass2.
indexer-id string.
procedure division using i2 as binary-double. *> this is correct
    getter.
    set property-value to i2
end indexer.
end class.
Parent topic: COBCH1601 - COBCH1620
Related concepts
Structural Syntax Elements


COBCH1609 Property accessor visibility must be stricter than property visibility

The visibility of a GETTER or SETTER phrase is not as strict as the visibility of its containing property.

The visibility of a GETTER or SETTER phrase must be stricter than the visibility of its containing property:

class-id myClass1.
property-id myProp1 string private.
    setter protected.  *> this is incorrect
    set property-value to "1234"
    getter.
end property.
end class.

class-id myClass2.
property-id myProp2 string public.
    setter protected.			*> this is correct
    set property-value to "5678"
    getter.
    declare myString as string.
    set myString to property-value
end property.
end class.
Parent topic: COBCH1601 - COBCH1620
Related concepts
Property Specification - syntax


COBCH1610 Cannot specify visibility on both GETTER and SETTER

Both the GETTER and SETTER phrases of a property specify visibility.

You can only set the visibility of one of either the GETTER or SETTER phrases of a property, as shown in the following example:

class-id myClass1.
property-id myProp1 string public.
    setter private.
    set property-value to "1234"
    getter.
    set myString to property-value
end property.
end class.
Parent topic: COBCH1601 - COBCH1620
Related concepts
Property Specification - syntax


COBCH1611 Can only specify accessor visibility if property has both GETTER and SETTER

The property is missing a GETTER or SETTER phrase due to accessor visibility being specified.

If you specify the visibility of either a GETTER or SETTER phrase, the property must contain both a GETTER and a SETTER phrase, but only one phrase can specify the visibility.

class-id myClass1.
property-id myProp1 string public.
    setter protected.			*> this is correct
    set property-value to "1234"
    getter.
    set myString to property-value
end property.
end class.
Parent topic: COBCH1601 - COBCH1620
Related concepts
Property Specification - syntax


COBCH1612 ACU picture string not supported

You have specified an invalid picture string, for example, a mixture of symbols specified for zero suppression.

This error message is displayed when an invalid symbol (or combination of symbols) has been specified in the picture string when you compile with either the DIALECT"ACU" or the ACU Compiler directive.

For example, in this COBOL system, the combination of numeric and numeric edited symbols in the same picture string must follow strict logical rules:
01 edit-acc-tot1 pic Z9.9Z.	*> this is incorrect
01 edit-acc-tot2 pic 99.ZZ.	*> this is incorrect
01 edit-acc-tot3 pic ZZ.99.	*> this is correct
01 edit-acc-tot4 pic Z9.99.	*> this is correct

You must correct any picture strings that produce this error. For more information on the symbol combinations allowed in this COBOL system, see The Picture Clause.

Parent topic: COBCH1601 - COBCH1620
Related concepts
The PICTURE Clause


COBCH1613 Syntax error error not allowed

A general syntax error has occurred.
Check your source code for errors, referring to the COBOL Language Reference, if required.
Parent topic: COBCH1601 - COBCH1620
Related concepts
Introduction to the COBOL Language


COBCH1614 INSPECT TRAILING match item must be single character item

You have specified an invalid TRAILING item in the INSPECT statement; you must specify a single character item.

For example:

INSPECT long-str TALLYING my-counter for TRAILING "**".  *> this is incorrect

INSPECT long-str TALLYING my-counter for TRAILING "*".	 *> this is correct
Parent topic: COBCH1601 - COBCH1620


COBCH1615 ACU statement COPY RESOURCE not supported; statement ignored

The COPY RESOURCE statement is not supported in this COBOL system.
Parent topic: COBCH1601 - COBCH1620


COBCH1616 Can only be used in nested class

You have attempted to use nested-specific syntax in a class that is not nested.
Certain syntax is only applicable to nested classes and must be removed from any other type of class. For example, the SHARING PARENT phrase is not permitted in containing classes.
...
end class.

class-id myContainingClass SHARING PARENT	*> this is incorrect usage
  01 myContainingStr string value "Hello Managed COBOL".
  ...
  class-id myNestedClass SHARING PARENT		*> this is correct usage
    display self::myContainingStr.
  end class.
...
end class.
Parent topic: COBCH1601 - COBCH1620


COBCH1617 WITH COMPRESSION or WITH ENCRYPTION are only supported in ACU mode when DATACOMPRESS is off

You have specified the WITH COMPRESSION or WITH ENCRYPTION phrase on a file in a program that also has the DATACOMPRESS Compiler directive set.
Remove the Compiler directive from your program.
Parent topic: COBCH1601 - COBCH1620
Related concepts
The File-Control Paragraph


COBCH1618 WITH COMPRESSION or WITH ENCRYPTION are only valid for INDEX files

You have specified the WITH COMPRESSION or WITH ENCRYPTION phrase on a file that is not an indexed file.
The WITH COMPRESSION and WITH ENCRYPTION phrases can only be specified in the SELECT statement for an indexed file.
Parent topic: COBCH1601 - COBCH1620
Related concepts
The File-Control Paragraph


COBCH1619 Must specify one generic parameter

The predefined LIST type must be specified with one generic parameter.
For example:
class-id myClass

01 myList1 LIST [string].      *> this is correct
01 myList2 LIST [float-short]. *> this is also correct
01 myList3 LIST [type myType]. *> this is also correct
01 myList4 LIST                *> this is incorrect - no param specified
01 myLIST5 LIST [string, float-short]  *>this also incorrect - too many params specified

...

end class.
Parent topic: COBCH1601 - COBCH1620


COBCH1620 Must specify two generic parameters

The predefined DICTIONARY type must be specified with two generic parameters.
For example:
class-id myClass

01 myDict1 DICTIONARY [string].		*> this is incorrect
01 myDict2 DICTIONARY [string string].  *> this is correct

...

end class.
Parent topic: COBCH1601 - COBCH1620


COBCH1621 - COBCH1640

Lists the Syntax Checking error messages from COBCH1621 through COBCH1640.
  • COBCH1621 Must specify a method invoke expression with no parameters
  • COBCH1622 A SIZE OF expression cannot be used as a receiving item
    You have attempted to use the SIZE OF expression as part of a receiving item.
  • COBCH1623 Anonymous method or method group cannot be cast to type1.
  • COBCH1624 Cannot implicitly convert type1 to type2.
    A SET statement cannot be completed, because you cannot convert to or from the specified type.
  • COBCH1625 Cannot convert type1 to type2.
    The casting expression cannot be completed, because you cannot convert to or from the specified type.
  • COBCH1626 Invalid test: type1 cannot be instance of type2.
    The INSTANCE OF phrase has encountered a type safety issue, and you cannot cast to or from the specified types.
  • COBCH1627 Preferred syntax uses pseudo-text delimiters (==) instead of quotes
    The REPLACING LEADING or REPLACING TRAILING phrase of the COPY statement has specified the wrong delimiters for text replacement.
  • COBCH1628 Cannot determine type of local variable
    The Compiler could not resolve the type for a DECLARE expression.
  • COBCH1629 REPLACING assumed
    A possible misspelling has been found in the REPLACING phrase of the COPY statement.
  • COBCH1631 ATTACH and DETACH statements can only be applied to events
  • COBCH1632 Cannot specify ALL numeric literal
    In this COBOL system, you cannot precede a numeric literal with the keyword ALL.
  • COBCH1633 Procedure division too large or complex - try using performtype(mf)
  • COBCH1634 Extended ACCEPT/DISPLAY not allowed with a Windows GUI executable (ILSUBSYSTEM"2")
    Your Windows application has specified an extended ACCEPT or DISPLAY statement.
  • COBCH1636 When compiling for managed code, this feature is supported only in procedural COBOL
    You have used syntax that is not supported in class programs. It is only supported in procedural programs.
  • COBCH1638 Start key ambiguous; using key key-name-1 (key key-name-2 has same offset)
    A START statement KEY phrase specifies the data-name of data item that has the same offset as two or more split keys of an indexed organization file.
Parent topic: Messages COBCH1601 - COBCH1700


COBCH1621 Must specify a method invoke expression with no parameters

Parent topic: COBCH1621 - COBCH1640


COBCH1622 A SIZE OF expression cannot be used as a receiving item

You have attempted to use the SIZE OF expression as part of a receiving item.
In this COBOL system, you can only use the SIZE OF expression as a sending item. For example:
01 firstName string
01 totalLen pic 9(3).
...
add 10 to SIZE OF firstName.                *> this is incorrect
add SIZE OF firstName to totalLen.	    *> this is correct
Note: You can only use the SIZE OF expression with single-dimensional managed arrays or strings.
Parent topic: COBCH1621 - COBCH1640


COBCH1623 Anonymous method or method group cannot be cast to type1.

Parent topic: COBCH1621 - COBCH1640


COBCH1624 Cannot implicitly convert type1 to type2.

A SET statement cannot be completed, because you cannot convert to or from the specified type.

For example:

class-id myClass1.

method-id myFirstMethod static.

 01 myFloat float-long.
 01 myString string.
 01 myInt binary-long.
 01 myObject object.
 01 myDecimal decimal.

 set myFloat to myString   *> this is incorrect
 set myFloat to myInt      *> this is correct
 set myObject to myString  *> this is correct - string derives from object
 set myDecimal to myString *> this is correct - In the .NET framwork, the System.Decimal class has an implicit conversion operator
                                                from type int (binary-long) to type System.Decimal

end method.

end class.
Parent topic: COBCH1621 - COBCH1640


COBCH1625 Cannot convert type1 to type2.

The casting expression cannot be completed, because you cannot convert to or from the specified type.
For example:
class-id myClass1.

method-id myFirstMethod static.

 01 myItem1 string.
 01 myItem2 type myClass2.
 01 myItem3 object.

 set myItem2 to myItem1 as string  *> this is incorrect unless type MyClass2 has an implicit\explicit conversion operator
                                   *> from type myClass2 to string
 set myItem1 to myItem3 as string  *> this is correct - note: this could produce an exception at runtime

end method.

end class.
Parent topic: COBCH1621 - COBCH1640


COBCH1626 Invalid test: type1 cannot be instance of type2.

The INSTANCE OF phrase has encountered a type safety issue, and you cannot cast to or from the specified types.
Parent topic: COBCH1621 - COBCH1640


COBCH1627 Preferred syntax uses pseudo-text delimiters (==) instead of quotes

The REPLACING LEADING or REPLACING TRAILING phrase of the COPY statement has specified the wrong delimiters for text replacement.
This error message is displayed when the " or ' quotation marks are used to delimit the text replacement and you have compiled with the DIALECT"ACU" or the ACU Compiler directive. Ensure you use the == delimiters when specifying the text replacement in this COBOL system, as shown below.
...
COPY "demo91.cpy" REPLACING LEADING "demo91" BY "acct".		*> this is incorrect
COPY "demo91.cpy" REPLACING LEADING ==demo91== BY ==acct==.	*> this is correct
...
Parent topic: COBCH1621 - COBCH1640


COBCH1628 Cannot determine type of local variable

The Compiler could not resolve the type for a DECLARE expression.

Declare the type explicitly.

Parent topic: COBCH1621 - COBCH1640


COBCH1629 REPLACING assumed

A possible misspelling has been found in the REPLACING phrase of the COPY statement.
Check and correct any spelling errors in your COPY statements. This error is only displayed if you are compiling with the DIALECT"ACU" or the ACU Compiler directive.
Parent topic: COBCH1621 - COBCH1640


COBCH1631 ATTACH and DETACH statements can only be applied to events

Parent topic: COBCH1621 - COBCH1640


COBCH1632 Cannot specify ALL numeric literal

In this COBOL system, you cannot precede a numeric literal with the keyword ALL.
In these circumstances, remove the keyword ALL from your source code.
Parent topic: COBCH1621 - COBCH1640


COBCH1633 Procedure division too large or complex - try using performtype(mf)

Parent topic: COBCH1621 - COBCH1640


COBCH1634 Extended ACCEPT/DISPLAY not allowed with a Windows GUI executable (ILSUBSYSTEM"2")

Your Windows application has specified an extended ACCEPT or DISPLAY statement.

If you are building a Windows application, you must remove any extended ACCEPT or DISPLAY statements, or change the output type of the application to Console Application.

Parent topic: COBCH1621 - COBCH1640


COBCH1636 When compiling for managed code, this feature is supported only in procedural COBOL

You have used syntax that is not supported in class programs. It is only supported in procedural programs.

To continue to use the syntax in managed code, move it to a procedural program and call it from within a class method.

Parent topic: COBCH1621 - COBCH1640


COBCH1638 Start key ambiguous; using key key-name-1 (key key-name-2 has same offset)

A START statement KEY phrase specifies the data-name of data item that has the same offset as two or more split keys of an indexed organization file.

Each of the keys has a total length that is greater than or equal to the length of the referenced data item. In this case, it is ambiguous which key should be used for the key of reference. The first key found that satisfies the length requirement is used as indicated by first key-name in the message; the second key found, as indicated by the key-name in the parenthetical of the message, is not used in establishing the key of reference. If the second key is the desired key for the key of reference, use its split-key-name and the WITH SIZE phrase to specify a partial key to avoid any ambiguity. This message is only produced for multi-component split keys that have the same starting offset and a compatible total length.

For single component keys, that is, ones specified without a split-key-name or those listing only one component following the split-key-name and equal sign, this message is not produced. The compiler uses the last single component key that has a matching offset with the specified data-name, regardless of its length. If the data-name references a data item with a length longer than the matched key, only the part of the data item up to the key length is compared to the key at run time. This last key found is used to establish the key of reference for subsequent sequential READ statements until another START statement or READ statement with the KEY phrase is executed.

Parent topic: COBCH1621 - COBCH1640


Messages COBCH2000 and above

  • COBCH2nnn directive incompatible with flagging dialect
    The directive setting causes behavior different from that of the dialect for which flagging was selected. It is processed as requested.
Parent topic: Syntax Checking Error Messages


COBCH2nnn directive incompatible with flagging dialect

The directive setting causes behavior different from that of the dialect for which flagging was selected. It is processed as requested.

Messages of this type occur if you have set the FLAGCD directive. Each directive that can be reported has a different error number between 2000 and 2199.

Parent topic: Messages COBCH2000 and above


Code Generation Error Messages

Code Generation messages are output when the compiler is producing generated code. Some are environment dependent, so your particular environment might not support them all. When you select an error message number, the text and severity of each message is described, the error or problem that causes the message is described, and advice is given on how to prevent it.

  • Key to Code Generation Error Messages
  • COBOP001 - COBOP080
    Lists all Code Generation error messages, including COBOP001 through COBOP080
Parent topic: Error Messages


Key to Code Generation Error Messages

Code generation messages have the following format:

NCG Error at INT Code Address - address
*ErrorCode message

where the variables are:

address | The address in the intermediate code at which the error occurred. Most errors of this type cause the code generator to display the source line in error, provided that the program was compiled with the ANIM directive, and the .idy and source files are available in the current directory. If it does not, you can relate it to your program source by compiling the program with the REF directive and referring to the source listing.
ErrorCode A code containing the following information:
  • The component that the error occurred in.
  • The operation that was taking place when the error occurred.
  • The error message number.
  • The severity of the error.
For code generation errors, ErrorCode is generally of the form COBOPnnn-s. See Explanation of Error Codes for more information on the possible values that ErrorCode can have.
message | A description of the cause of the error.

The severity returned in ErrorCode can take one of the following values:

F | Fatal. In the unlikely event that one of these errors occurs, contact Technical Support to solve the problem.
R | Recoverable. This ends code generation, as you must correct the error.
C | Cautionary. This tells you either that you have specified an invalid combination of directives or that PERFORM statements cannot be optimized. It does not end code generation or prevent the generated code being executed.
Parent topic: Code Generation Error Messages


COBOP001 - COBOP080

  • COBOP001 Internal error. Contact Technical Support. (Recoverable)
  • COBOP002 Attempted to redefine symbol name (Recoverable)
    The external data item or entry name name clashes with another external symbol of the same name.
  • COBOP003 Ran out of memory during optimization. Generate program using NOOPT. (Recoverable)
    The OPT Compiler directive was specified and the Compiler ran out of memory during the code generation phase.
  • COBOP006 Read failure on input file, not intermediate code or wrong version (Recoverable)
    One of the following has occurred:
  • COBOP012 Dictionary or dynamic paging error (Fatal)
    The disk is probably full.
  • COBOP013 Illegal intermediate code (at nnnnnn in seg mm) (Recoverable)
    You are trying to create generated code from intermediate code that has been corrupted.
  • COBOP014 Too many IF levels (Recoverable)
    You have nested IF statements beyond the maximum of 254 levels.
  • COBOP019 Program checked with non-optimal alignment. Optimal alignment is opt-align (Cautionary)
  • COBOP039 Errors detected during creation of intermediate code (Recoverable)
    You are trying to generate code from intermediate code that was found to contain severe errors when it was submitted to your COBOL system.
  • COBOP040 Bad program-id or entry name (Recoverable)
    The name you have given in the PROGRAM-ID clause or the ENTRY...USING phrase, or as the root of the input file-name, cannot be handled correctly by your system assembler.
  • COBOP054 Parameter type cannot be passed by value (Recoverable)
    Only those COMP-5 items that are 4 bytes or smaller can be passed by value.
  • COBOP055 Opcodes file corrupt or unknown machine type (Recoverable)
    Your $COBDIR/ncg.ops file has become corrupted.
  • COBOP056 Option not implemented: "option name" (Recoverable)
    This language option is not supported on your environment.
  • COBOP066 Write failure on .IDY file (Recoverable)
    Either the disk is full or the .idy file produced by the checker has been marked read-only.
  • COBOP068 IDY file not found - SOURCEASM ignored (Cautionary)
  • COBOP069 Source file not found - SOURCEASM ignored (Cautionary)
  • COBOP075 Call-convention not supported (Recoverable)
  • COBOP076 Inefficient code produced for this statement (Cautionary)
  • COBOP077 Generated code module too large (limit = limit bytes) (Recoverable)
  • COBOP078 Too many code relocations (limit = limit, actual = limit (Recoverable)
  • COBOP079 Too many data relocations (limit = limit, actual = limit (Recoverable)
  • COBOP080 Too many symbol table entries (limit = limit, actual = limit (Recoverable)
Parent topic: Code Generation Error Messages


COBOP001 Internal error. Contact Technical Support. (Recoverable)

Parent topic: COBOP001 - COBOP080


COBOP002 Attempted to redefine symbol name (Recoverable)

The external data item or entry name name clashes with another external symbol of the same name.

Resolution:

Change one of the names.

Parent topic: COBOP001 - COBOP080


COBOP003 Ran out of memory during optimization. Generate program using NOOPT. (Recoverable)

The OPT Compiler directive was specified and the Compiler ran out of memory during the code generation phase.

Resolution:

Re-compile your program using the NOOPT Compiler directive.

Parent topic: COBOP001 - COBOP080


COBOP006 Read failure on input file, not intermediate code or wrong version (Recoverable)

One of the following has occurred:
  • The input file you have specified is not an intermediate code file.
  • The intermediate code file was produced by a version of your COBOL system that is not compatible with your current version.
  • Your input file is corrupt.

Resolution:

Ensure that you specify an intermediate code file.

Parent topic: COBOP001 - COBOP080


COBOP012 Dictionary or dynamic paging error (Fatal)

The disk is probably full.

Resolution:

If the disk is full, make more space available. If you receive this message and your disk is not full, contact Technical Support.

Parent topic: COBOP001 - COBOP080


COBOP013 Illegal intermediate code (at nnnnnn in seg mm) (Recoverable)

You are trying to create generated code from intermediate code that has been corrupted.

nnnnnn is an intermediate code address; mm is an intermediate code segment number.

Resolution:

Resubmit your source code to your COBOL system to try to obtain valid intermediate code.

Parent topic: COBOP001 - COBOP080


COBOP014 Too many IF levels (Recoverable)

You have nested IF statements beyond the maximum of 254 levels.

Resolution:

Change your program so you do not have a nest of more than 254 conditions.

Parent topic: COBOP001 - COBOP080


COBOP019 Program checked with non-optimal alignment. Optimal alignment is opt-align (Cautionary)

Resolution:

No resolution is necessary as this message indicates that the code produced will still perform as expected but is not optimized. If you do not want to receive this message the next time you compile the program, ensure you set the ALIGN directive to its optimal setting.

Parent topic: COBOP001 - COBOP080


COBOP039 Errors detected during creation of intermediate code (Recoverable)

You are trying to generate code from intermediate code that was found to contain severe errors when it was submitted to your COBOL system.

Resolution:

Correct all the severe errors in your source code.

Parent topic: COBOP001 - COBOP080


COBOP040 Bad program-id or entry name (Recoverable)

The name you have given in the PROGRAM-ID clause or the ENTRY...USING phrase, or as the root of the input file-name, cannot be handled correctly by your system assembler.

Resolution:

Change the name to comply with your operating system's rules for a function-name.

Parent topic: COBOP001 - COBOP080


COBOP054 Parameter type cannot be passed by value (Recoverable)

Only those COMP-5 items that are 4 bytes or smaller can be passed by value.

Resolution:

Ensure that any COMP-5 items are no larger than 4 bytes.

Parent topic: COBOP001 - COBOP080


COBOP055 Opcodes file corrupt or unknown machine type (Recoverable)

Your $COBDIR/ncg.ops file has become corrupted.

Resolution:

Reinstall your ncg.ops file.

Parent topic: COBOP001 - COBOP080


COBOP056 Option not implemented: "option name" (Recoverable)

This language option is not supported on your environment.
Parent topic: COBOP001 - COBOP080


COBOP066 Write failure on .IDY file (Recoverable)

Either the disk is full or the .idy file produced by the checker has been marked read-only.

Resolution:

Delete any files you no longer need, or mark the .idy file read/write.

Parent topic: COBOP001 - COBOP080


COBOP068 IDY file not found - SOURCEASM ignored (Cautionary)

Parent topic: COBOP001 - COBOP080


COBOP069 Source file not found - SOURCEASM ignored (Cautionary)

Parent topic: COBOP001 - COBOP080


COBOP075 Call-convention not supported (Recoverable)

Parent topic: COBOP001 - COBOP080


COBOP076 Inefficient code produced for this statement (Cautionary)

Parent topic: COBOP001 - COBOP080


COBOP077 Generated code module too large (limit = limit bytes) (Recoverable)

Parent topic: COBOP001 - COBOP080


COBOP078 Too many code relocations (limit = limit, actual = limit (Recoverable)

Parent topic: COBOP001 - COBOP080


COBOP079 Too many data relocations (limit = limit, actual = limit (Recoverable)

Parent topic: COBOP001 - COBOP080


COBOP080 Too many symbol table entries (limit = limit, actual = limit (Recoverable)

Parent topic: COBOP001 - COBOP080


Run-time System Error Messages

These messages are output by the run-time system (RTS), and so can be produced while you are compiling, debugging, or running your program. When you select an error message number, its text and severity is listed, along with an explanation of the error or problem that caused the message, and advice on how to prevent the error.

  • Key to Run-time System Error Messages
  • COBRT001 - COBRT020
    Lists the Run-time System error messages from COBRT001 through COBRT020.
  • COBRT021 - COBRT040
    Lists the Run-time System error messages from COBRT021 through COBRT040.
  • COBRT041 - COBRT060
    Lists the Run-time System error messages from COBRT041 through COBRT060.
  • COBRT061 - COBRT080
    Lists the Run-time System error messages from COBRT061 through COBRT080.
  • COBRT101 - COBRT120
    Lists the Run-time System error messages from COBRT101 through COBRT120.
  • COBRT121 - COBRT140
    Lists the Run-time System error messages from COBRT121 through COBRT140.
  • COBRT141 - COBRT160
    Lists the Run-time System error messages from COBRT141 through COBRT160.
  • COBRT161 - COBRT180
    Lists the Run-time System error messages from COBRT161 through COBRT180.
  • COBRT181 - COBRT200
    Lists the Run-time System error messages from COBRT181 through COBRT200.
  • COBRT201 - COBRT220
    Lists the Run-time System error messages from COBRT201 through COBRT220.
  • COBRT221 - COBRT240
    Lists the Run-time System error messages from COBRT221 through COBRT240.
  • COBRT241 - COBRT260
    Lists the Run-time System error messages from COBRT241 through COBRT260.
Parent topic: Error Messages


Key to Run-time System Error Messages

These messages are output by the run-time system (RTS), and so can be produced while you are compiling, debugging, or running your program. When you select an error message number, its text and severity is listed, along with an explanation of the error or problem that caused the message, and advice on how to prevent the error.

Run-time system error messages have the following format:

ErrorCode Description

where the parameters are:

ErrorCode A code containing the following information:
  • The component that the error occurred in.
  • The operation that was taking place when the error occurred.
  • The error message number.
For run-time system errors, ErrorCode is generally of the form COBRTnnnn.
Description A description of the cause of the error.

There are two types of run-time error:

Fatal | A message is sent to the screen and the program terminates immediately.
Recoverable | The error is reported to the program. You can trap these errors in your program, but often they are the result of an error in your program's logic. If the program does not trap the error a message is sent to the screen and the program terminates immediately.
Parent topic: Run-time System Error Messages


COBRT001 - COBRT020

  • COBRT001 Insufficient buffer space (Recoverable)
    You have tried to open a file directly or indirectly and, although you have not exceeded your system's file limit, something in your system is unable to allocate enough memory space for this operation.
  • COBRT002 File not open when access attempted (Recoverable)
    You have tried to access a file without opening it first.
  • COBRT003 Serial mode error (Recoverable)
    You have tried to open a device as a relative or indexed file.
  • COBRT004 Illegal file name (Recoverable)
    A file-name contains an illegal character. This could be any character that is not part of the permitted character set or it could be the system-dependent delimiter, which on most systems is the space.
  • COBRT005 Illegal device specification (Recoverable)
    Devices to which your COBOL program can write are defined by the operating system. You have tried to write to a device that is not defined by your system.
  • COBRT006 Attempt to write to a file opened for INPUT (Recoverable)
    You have tried to WRITE to a file that is open for input only.
  • COBRT007 Disk space exhausted (Fatal)
    The disk is full.
  • COBRT008 Attempt to input from a file opened for OUTPUT (Recoverable)
    You have tried to read from a file that is open for output only.
  • COBRT009 Directory not found (Recoverable)
    The system cannot write to the specified directory for one of the following reasons:
  • COBRT010 File name not supplied (Recoverable)
    You have tried to open a file that you have declared as an external file, but have not named.
  • COBRT011 Process limit reached (Fatal)
    One of the following has occurred:
  • COBRT012 Attempt to open a file which is already open (Recoverable)
    You have tried to open a file which is already open and so cannot be opened again.
  • COBRT013 File not found (Recoverable)
    The operating system has been unable to find a file which you have tried to access in your program.
  • COBRT014 Too many files open simultaneously (Recoverable)
    You have tried to exceed the maximum number of files which you can have open at any one time. This can be a software or an operating system constraint, but you must not violate it.
  • COBRT015 Too many indexed files open (Recoverable)
    You have tried to exceed the maximum number of indexed files which you can have open at any one time. This can be a software or an operating system restraint, but you must not violate it.
  • COBRT016 Too many device files open (Recoverable)
    You have tried to exceed the maximum number of device files which you can have open at any one time. This can be a software or an operating system constraint, but you must not violate it.
  • COBRT017 Record error: probably zero length (Recoverable)
    You have probably tried to access a record that has had no value moved into it.
  • COBRT018 Read part record error: EOF before EOR or file open in wrong mode (Recoverable)
    A part record has been found at the end of a file. Consequently your run-time system treats the data file as a record, and not finding a full record, reports this error.
  • COBRT019 Rewrite error: open mode or access mode wrong (Recoverable)
    You are trying to do a REWRITE to a file that has not been opened with the correct access mode for this operation.
  • COBRT020 Device or resource busy (Recoverable)
    You have tried to open a file that is assigned to a device or resource (for example, a line printer) that is not available at this time.
Parent topic: Run-time System Error Messages


COBRT001 Insufficient buffer space (Recoverable)

You have tried to open a file directly or indirectly and, although you have not exceeded your system's file limit, something in your system is unable to allocate enough memory space for this operation.

Resolution:

Although you can trap this error you must do STOP RUN as soon as it is reported.

Parent topic: COBRT001 - COBRT020


COBRT002 File not open when access attempted (Recoverable)

You have tried to access a file without opening it first.

Resolution:

Open the file with the open mode that you need and try the operation again. As this error implies that your program logic contains a mistake, you might want to terminate the run and recode your program.

Parent topic: COBRT001 - COBRT020


COBRT003 Serial mode error (Recoverable)

You have tried to open a device as a relative or indexed file.

You are trying to execute a device, not a program.

Resolution:

Open the device in the correct mode or close any open files, do STOP RUN and recode your program.

The name of your program is recognized by the operating system as a valid device. Rename your program.

Parent topic: COBRT001 - COBRT020


COBRT004 Illegal file name (Recoverable)

A file-name contains an illegal character. This could be any character that is not part of the permitted character set or it could be the system-dependent delimiter, which on most systems is the space.

Resolution:

Try the file operation again using the correct file-name.

Parent topic: COBRT001 - COBRT020


COBRT005 Illegal device specification (Recoverable)

Devices to which your COBOL program can write are defined by the operating system. You have tried to write to a device that is not defined by your system.

Resolution:

Try the operation again using a device name that your system recognizes.

Parent topic: COBRT001 - COBRT020


COBRT006 Attempt to write to a file opened for INPUT (Recoverable)

You have tried to WRITE to a file that is open for input only.

Resolution:

Close the file and open it with a mode such as I-O, which allows you to write to the file. As this error implies that your program logic contains a mistake, you might want to terminate the run and recode your program.

Parent topic: COBRT001 - COBRT020


COBRT007 Disk space exhausted (Fatal)

The disk is full.

Resolution:

This error can be trapped, but once it has been reported you must do a STOP RUN immediately to terminate your program's run. When your program has terminated, delete any files that you no longer need. Alternatively, if your operating system supports this, put a new disk in a floppy disk drive and redirect your program's file operations to this.

Parent topic: COBRT001 - COBRT020


COBRT008 Attempt to input from a file opened for OUTPUT (Recoverable)

You have tried to read from a file that is open for output only.

Resolution:

Close the file and open it with a mode such as I-O, which allows you to read from the file. As this error implies that your program logic contains a mistake, you might want to terminate the run and recode your program.

Parent topic: COBRT001 - COBRT020


COBRT009 Directory not found (Recoverable)

The system cannot write to the specified directory for one of the following reasons:
  • The directory does not exist
  • The directory is full
  • Your program cannot find the directory

Resolution:

Create the directory if it doesn't exist. If the directory is full, either delete any files that you no longer need or, if your operating system supports this, put a new disk in a floppy disk drive and redirect your program's file operations to it. Alternatively, specify a different drive or directory for your file operations.

Parent topic: COBRT001 - COBRT020


COBRT010 File name not supplied (Recoverable)

You have tried to open a file that you have declared as an external file, but have not named.

Resolution:

Specify the external file-name.

Parent topic: COBRT001 - COBRT020


COBRT011 Process limit reached (Fatal)

One of the following has occurred:
  • The run-time system cannot create a new process as the operating system limit on the total number of processes per user or system-wide would be exceeded.
  • Insufficient memory is available to complete the operation.

Resolution:

Terminate any processes that you are no longer using, or make more memory available.

Your operating system might enable you to increase the maximum number of processes allowed. Refer to your operating system documentation for further information.

Parent topic: COBRT001 - COBRT020


COBRT012 Attempt to open a file which is already open (Recoverable)

You have tried to open a file which is already open and so cannot be opened again.

Resolution:

Cancel your second attempt to open the file. If the fact that the file is already open is acceptable to you, continue to run your program.

Parent topic: COBRT001 - COBRT020


COBRT013 File not found (Recoverable)

The operating system has been unable to find a file which you have tried to access in your program.

Resolution:

Ensure that you are in the correct directory or that a path to the file concerned exists. You can then try the file operation again. If the error is the result of a spelling mistake then ask for the correct file and try the file operation again.

Parent topic: COBRT001 - COBRT020


COBRT014 Too many files open simultaneously (Recoverable)

You have tried to exceed the maximum number of files which you can have open at any one time. This can be a software or an operating system constraint, but you must not violate it.

Resolution:

Close some of the open files which you are not currently accessing, and then try to open the relevant file again. You should then be able to continue to run your program.

Parent topic: COBRT001 - COBRT020


COBRT015 Too many indexed files open (Recoverable)

You have tried to exceed the maximum number of indexed files which you can have open at any one time. This can be a software or an operating system restraint, but you must not violate it.

Resolution:

Close some of the open indexed files which you are not currently accessing, and then try to open the relevant file again. You should then be able to continue to run your program. (Indexed files count as two files, one for data and one for the index.)

Parent topic: COBRT001 - COBRT020


COBRT016 Too many device files open (Recoverable)

You have tried to exceed the maximum number of device files which you can have open at any one time. This can be a software or an operating system constraint, but you must not violate it.

Resolution:

Close some of the open device files which you are not currently accessing, and then try to open the relevant file again. You should then be able to continue to run your program.

Parent topic: COBRT001 - COBRT020


COBRT017 Record error: probably zero length (Recoverable)

You have probably tried to access a record that has had no value moved into it.

Resolution:

Although this error is recoverable in the sense that it can be trapped, once it has been reported you must execute a STOP RUN statement immediately and then recode your program to ensure that the COBOL record length is not zero.

Parent topic: COBRT001 - COBRT020


COBRT018 Read part record error: EOF before EOR or file open in wrong mode (Recoverable)

A part record has been found at the end of a file. Consequently your run-time system treats the data file as a record, and not finding a full record, reports this error.

Resolution:

Ensure that the record size you give when you read from or WRITE to a file is consistent.

Parent topic: COBRT001 - COBRT020


COBRT019 Rewrite error: open mode or access mode wrong (Recoverable)

You are trying to do a REWRITE to a file that has not been opened with the correct access mode for this operation.

Resolution:

Close the file and reopen it in a mode such as I-O, which allows you to do REWRITE operations on that file. As this error implies that your program logic contains a mistake, you might want to close any open files and then execute a STOP RUN. You can then recode your program to eliminate the logic error.

Parent topic: COBRT001 - COBRT020


COBRT020 Device or resource busy (Recoverable)

You have tried to open a file that is assigned to a device or resource (for example, a line printer) that is not available at this time.

Resolution:

You can trap the error status returned by open and retry the open at regular intervals until it succeeds.

Parent topic: COBRT001 - COBRT020


COBRT021 - COBRT040

  • COBRT021 File is a directory (Fatal)
    You have tried to WRITE to a directory instead of to a file.
  • COBRT022 Illegal or impossible access mode for OPEN (Recoverable)
    The mode in which you are trying to open a file violates the General Rule of COBOL for that type of file; for example you might have opened a line sequential file in the I-O mode.
  • COBRT023 Illegal or impossible access mode for CLOSE (Recoverable)
    The mode in which you are trying to close a file is not possible for that type of file.
  • COBRT024 Disk input-output error (Recoverable)
    You might have performed a read after a WRITE, or there might be either a verification failure or a parity error.
  • COBRT025 Operating system data error (Fatal)
    You are trying to set up terminal characteristics for a device which is not a terminal.
  • COBRT026 Block I-O error (Fatal)
    An error has occurred while you are trying to access a disk. This could be the result of a corrupt disk.
  • COBRT027 Device not available (Recoverable)
    You are trying to access a device which either is not attached to your machine or if attached is not online.
  • COBRT028 No space on device (Fatal)
    You have tried a file operation such as WRITE for which insufficient space is available on your disk.
  • COBRT029 Attempt to delete open file (Recoverable)
    You have tried to perform a DELETE FD operation on an open file.
  • COBRT030 File system is read-only (Recoverable)
    The file system which you are using is read-only, which effectively means that it is write-protected. You have tried to change a file in some way, for example you might have tried to WRITE to a file or to DELETE information in it.
  • COBRT031 Not owner of file (Recoverable)
    You are trying an operation on a file but the file's owner has not given you the necessary permission for that operation. You could for example be trying to alter the access modes for a file, which only the file's owner can do.
  • COBRT032 Too many indexed files, or no such process (Recoverable)
    You have tried to open an indexed file but the number of files that you currently have open is the system limit.
  • COBRT033 Physical I-O error (Fatal)
    You have a hardware error of some type. Perhaps you have not put a disk in the relevant drive or you might have tried to WRITE to a disk but the processor detected hardware interface has failed.
  • COBRT034 Incorrect mode or file descriptor (Recoverable)
    You are either trying to write to a file which is open for read purposes only, or read a file which is open for write purposes only.
  • COBRT035 Attempt to access a file with incorrect permission (Recoverable)
    You are trying a file operation which you do not have sufficient permission to achieve. For example you could be trying to write data to a file which has been set up with the read attribute only.
  • COBRT036 File already exists (Recoverable)
    You are trying an inappropriate operation on an already existing file.
  • COBRT037 File access denied (Fatal)
    Your attempt to access a file has been denied by the operating system. You might have tried to write to a write-protected file or you could have tried to read from an output device.
  • COBRT038 Disk not compatible (Fatal)
    You have tried to access a disk that is incompatible with the current version of your operating system. This could be because it was created under a previous version of the system or it could have been created under a completely different operating system. You would also receive this error if you tried to load a disk with a name that clashed with a disk that was already loaded.
  • COBRT039 File not compatible (Fatal)
    You have tried to access a file that is not compatible with the structure of files under the current release of your software. This could be because the file was created either under a different operating system or under a previous version of your current system.
  • COBRT040 National Language initialization not set up correctly (Fatal)
    You have tried to use the additional language variants, but the environment or side file that is required to set up the language either has not been set up correctly, or does not exist, or is invalid.
Parent topic: Run-time System Error Messages


COBRT021 File is a directory (Fatal)

You have tried to WRITE to a directory instead of to a file.

Alternatively, the attributes are not set up correctly to allow you to access a file. That is, it is marked as read-only or you don't have sufficient rights to open it.

Resolution:

Recode your program so that it writes to a file and not to a directory.

You need to either change your file access attributes or recode your program so that it does not violate the existing attributes.

Parent topic: COBRT021 - COBRT040


COBRT022 Illegal or impossible access mode for OPEN (Recoverable)

The mode in which you are trying to open a file violates the General Rule of COBOL for that type of file; for example you might have opened a line sequential file in the I-O mode.

Resolution:

Open the file with a mode that is compatible with that type of file.

Parent topic: COBRT021 - COBRT040


COBRT023 Illegal or impossible access mode for CLOSE (Recoverable)

The mode in which you are trying to close a file is not possible for that type of file.

Resolution:

Close the file with a new access mode which is compatible with that type of file, or execute a STOP RUN statement and recode your program.

Parent topic: COBRT021 - COBRT040


COBRT024 Disk input-output error (Recoverable)

You might have performed a read after a WRITE, or there might be either a verification failure or a parity error.

Resolution:

In some circumstances this error is fatal, but if it occurs during a read you can trap it and then do a close on the file before executing a STOP RUN statement.

Parent topic: COBRT021 - COBRT040


COBRT025 Operating system data error (Fatal)

You are trying to set up terminal characteristics for a device which is not a terminal.

Resolution:

Recode your program.

Parent topic: COBRT021 - COBRT040


COBRT026 Block I-O error (Fatal)

An error has occurred while you are trying to access a disk. This could be the result of a corrupt disk.

Resolution:

If you have a corrupt disk try to run your program again using your backup copy.

Parent topic: COBRT021 - COBRT040


COBRT027 Device not available (Recoverable)

You are trying to access a device which either is not attached to your machine or if attached is not online.

Resolution:

Attach the device to your machine and ensure that it is online. Repeat the file operation.

Parent topic: COBRT021 - COBRT040


COBRT028 No space on device (Fatal)

You have tried a file operation such as WRITE for which insufficient space is available on your disk.

Resolution:

When your program has terminated you should delete some of the files or directories on your current logged in disk. Ensure that you delete sufficient files on your disk so that you have enough room to carry out successful file operations.

Parent topic: COBRT021 - COBRT040


COBRT029 Attempt to delete open file (Recoverable)

You have tried to perform a DELETE FD operation on an open file.

Resolution:

Close the file before performing the DELETE FD operation.

Parent topic: COBRT021 - COBRT040


COBRT030 File system is read-only (Recoverable)

The file system which you are using is read-only, which effectively means that it is write-protected. You have tried to change a file in some way, for example you might have tried to WRITE to a file or to DELETE information in it.

Resolution:

You should abandon your attempt to alter the file unless you can make your own personal copy of it. You should then be able to alter the contents of your copy, but not of the original source.

Parent topic: COBRT021 - COBRT040


COBRT031 Not owner of file (Recoverable)

You are trying an operation on a file but the file's owner has not given you the necessary permission for that operation. You could for example be trying to alter the access modes for a file, which only the file's owner can do.

Resolution:

You should abandon your tried file operation unless the file's owner gives you the permission necessary to do the operation you want to carry out.

Parent topic: COBRT021 - COBRT040


COBRT032 Too many indexed files, or no such process (Recoverable)

You have tried to open an indexed file but the number of files that you currently have open is the system limit.

Alternatively, you could be trying to use a process id which does not exist, or which your operating system no longer recognizes.

Resolution:

You should close some of the indexed files which you are no longer accessing, and you should then be able to open the file you require.

In this case you must rewrite your code so that it uses a process id which your system recognizes.

Parent topic: COBRT021 - COBRT040


COBRT033 Physical I-O error (Fatal)

You have a hardware error of some type. Perhaps you have not put a disk in the relevant drive or you might have tried to WRITE to a disk but the processor detected hardware interface has failed.

Resolution:

You should try to correct the fault in your hardware; for example put a disk in the necessary drive.

Parent topic: COBRT021 - COBRT040


COBRT034 Incorrect mode or file descriptor (Recoverable)

You are either trying to write to a file which is open for read purposes only, or read a file which is open for write purposes only.

Resolution:

You should close the file and reopen using the correct access mode. As this error implies that your program logic contains a mistake, you might want to close any open files, execute a STOP RUN statement and then recode your program to eliminate the logic error.

Shareable files opened INPUT (read-only) by the COBOL system still require write-permission (from the operating system) to enable temporary locking to take place.

Parent topic: COBRT021 - COBRT040


COBRT035 Attempt to access a file with incorrect permission (Recoverable)

You are trying a file operation which you do not have sufficient permission to achieve. For example you could be trying to write data to a file which has been set up with the read attribute only.

Resolution:

If you are the owner of the file you can alter the attributes of the file so that you have the permission needed to effect the particular file operation you were trying. If you are not the owner of the file you cannot to carry out that operation successfully unless you copy the file and make the changes to the copy only. You cannot alter the source file.

Parent topic: COBRT021 - COBRT040


COBRT036 File already exists (Recoverable)

You are trying an inappropriate operation on an already existing file.

Resolution:

Recode your program to eliminate this mistake.

Parent topic: COBRT021 - COBRT040


COBRT037 File access denied (Fatal)

Your attempt to access a file has been denied by the operating system. You might have tried to write to a write-protected file or you could have tried to read from an output device.

Resolution:

Alter the access permission on the relevant file. Access can be read-only, if you just want to read the contents of the file without making any changes, or it can be read and write in which case you can alter its contents.

Parent topic: COBRT021 - COBRT040


COBRT038 Disk not compatible (Fatal)

You have tried to access a disk that is incompatible with the current version of your operating system. This could be because it was created under a previous version of the system or it could have been created under a completely different operating system. You would also receive this error if you tried to load a disk with a name that clashed with a disk that was already loaded.

Resolution:

If the error is a result of a clash of names you can rename one of the disks and then you can load both disks together if this is what you want.

Parent topic: COBRT021 - COBRT040


COBRT039 File not compatible (Fatal)

You have tried to access a file that is not compatible with the structure of files under the current release of your software. This could be because the file was created either under a different operating system or under a previous version of your current system.

Resolution:

You should create a new copy of the file which has the correct structure.

Parent topic: COBRT021 - COBRT040


COBRT040 National Language initialization not set up correctly (Fatal)

You have tried to use the additional language variants, but the environment or side file that is required to set up the language either has not been set up correctly, or does not exist, or is invalid.

This might be because you have the LANG environment variable set for use by another system in a format not recognized by this COBOL system.

Resolution:

Set up the required environment or side file before you try to run the program again.

Parent topic: COBRT021 - COBRT040


COBRT041 - COBRT060

  • COBRT041 Corrupt index file (Recoverable)
    Your run-time system does not recognize the control information for an indexed file and as the index has been corrupted in some way the data in the file is no longer accessible by your system. This error is recoverable in the sense that it can be trapped but should you receive it, you can do little except to close any open files and stop your program's run.
  • COBRT042 Attempt to write on broken pipe (Recoverable)
    One of the following has occurred:
  • COBRT043 File information missing for indexed file (Fatal)
    The most likely reason for this error is that the names of either the data part or the index part of the file are not consistent with the setting of the IDXNAMETYPE FIle Handler configuration option.
  • COBRT044 Attempt to OPEN an NLS file in a non-NLS program (Fatal)
    The logical file-name is preceded by "%NLS%", but the program which OPENS the file has been compiled without the NLS directive set: the OPEN fails.
  • COBRT045 Attempt to OPEN an NLS file using incompatible language definition (Fatal)
    The NLS control information for a file in your program does not match the same NLS control information in the header of your index file. Alternatively, your index file has become corrupted.
  • COBRT047 Indexed structure overflow (Fatal)
    The structure of your indexed file contains a fault. You have probably tried to put another entry in the index when there is no room for it. This may be because you have reached the maximum number of duplicate keys.
  • COBRT048 Attempt to divide by zero (Fatal)
    You are executing a program that is trying to perform a divide by zero.
  • COBRT055 Routine table overflow (Fatal)
    You have tried to load too many programs simultaneously.
Parent topic: Run-time System Error Messages


COBRT041 Corrupt index file (Recoverable)

Your run-time system does not recognize the control information for an indexed file and as the index has been corrupted in some way the data in the file is no longer accessible by your system. This error is recoverable in the sense that it can be trapped but should you receive it, you can do little except to close any open files and stop your program's run.

Resolution:

You should identify the cause of the error. It might be something obvious such as a crash. You can run Rebuild using the /f option to find more about the nature of the corruption.

You should rerun your program using the backup copy of that file. If you have added a great deal of information to the file since you last took a backup you might like to rebuild the file using the Rebuild utility, which reads the data (if this has not been corrupted) and builds a new index for it.

Parent topic: COBRT041 - COBRT060


COBRT042 Attempt to write on broken pipe (Recoverable)

One of the following has occurred:
  • Your program has created a process as a result of a DD_ logical file-name mapping assignment (for example, the process might be a line printer spooler). The process was not created properly, or has ended prematurely. This error occurs when your program tries to write to the process.
  • Your application has terminated abnormally or prematurely, thus breaking the pipe.

Resolution:

You can trap the error status returned by the write operation, then open the file again.

Parent topic: COBRT041 - COBRT060


COBRT043 File information missing for indexed file (Fatal)

The most likely reason for this error is that the names of either the data part or the index part of the file are not consistent with the setting of the IDXNAMETYPE FIle Handler configuration option.

Other possibilities are that you have copied the indexed file from one disk to another but have copied either only the data part of the file or only the index, or that there was a system crash during your program's previous run, while the file was open.

Resolution:

Check that the setting of the IDXNAMETYPE FIle Handler configuration option is consistent with the naming of the index files used on your system.

If the error was the result of a faulty copy you should be able to restore the missing part of the file from the .dat or .idx file.

If the error is the result of a crash then whether you can access the necessary data or not is entirely system dependent.

Parent topic: COBRT041 - COBRT060


COBRT044 Attempt to OPEN an NLS file in a non-NLS program (Fatal)

The logical file-name is preceded by "%NLS%", but the program which OPENS the file has been compiled without the NLS directive set: the OPEN fails.
Parent topic: COBRT041 - COBRT060


COBRT045 Attempt to OPEN an NLS file using incompatible language definition (Fatal)

The NLS control information for a file in your program does not match the same NLS control information in the header of your index file. Alternatively, your index file has become corrupted.

Resolution:

Rebuild your index file, or rerun your program using the backup copy of that file. If you have added a great deal of information since you last took a backup, you might want to rebuild the file using a utility that is able to read the data, if it is not corrupt, and build a new index for it.

Parent topic: COBRT041 - COBRT060


COBRT047 Indexed structure overflow (Fatal)

The structure of your indexed file contains a fault. You have probably tried to put another entry in the index when there is no room for it. This may be because you have reached the maximum number of duplicate keys.

Alternatively, you have tried to access an old format indexed file, created perhaps using CIS COBOL.

Resolution:

If your index has no room for further entries you should either reorganize your file or convert it to IDXFORMAT"4" using Rebuild, to allow a greater number of duplicate keys.

If you have tried to access an old format indexed file, you can run the Rebuild utility to check the consistency of this indexed file, and to construct a new indexed file if the old one was found to be corrupt.

Parent topic: COBRT041 - COBRT060


COBRT048 Attempt to divide by zero (Fatal)

You are executing a program that is trying to perform a divide by zero.

Resolution:

Recode your program so that you can trap the error with an ON SIZE ERROR clause

Parent topic: COBRT041 - COBRT060


COBRT055 Routine table overflow (Fatal)

You have tried to load too many programs simultaneously.

Resolution:

Cancel any programs that you are no longer using, or use fewer separate programs.

Parent topic: COBRT041 - COBRT060


COBRT061 - COBRT080

  • COBRT065 File locked (Recoverable)
    You have tried to open a file which has already been locked, or opened for output by another user. Alternatively, you have tried to lock or open for output a file which another user already has open.
  • COBRT066 Attempt to add duplicate record key to indexed file (Fatal)
    You have tried to add a duplicate key for a key which you have not defined as being able to have duplicates.
  • COBRT067 Indexed file not open (Recoverable)
    You are trying to access an indexed file which you have not opened.
  • COBRT068 Record locked (Recoverable)
    You have tried to access a record which is currently locked by another user.
  • COBRT069 Illegal argument to isam module (Fatal)
    This is the result of an internal system error.
  • COBRT070 Too many indexed files open (Recoverable)
    You are trying to open an indexed file but you have already exhausted the system limit which specifies how many of these files can be opened at any one time.
  • COBRT071 Bad indexed file format (Fatal)
    You are either using a file which has been corrupted, or there is an internal system error.
  • COBRT072 End of indexed file (Fatal)
    This is the result of an internal system error.
  • COBRT073 No record found in indexed file (Fatal)
    This is the result of an internal system error.
  • COBRT074 No current record in indexed file (Fatal)
    This is the result of an internal system error.
  • COBRT075 Indexed data file name too long (Fatal)
    When creating indexed files, the extension .idx is added to the user-defined filename, so your filename must not exceed x-4 characters in length, where x is the maximum length of filename.
  • COBRT076 Can't create lock file in /isam directory (Fatal)
    For some reason your system is unable to create a lock file in the /isam directory. One reason for this could be that in its previous run your program terminated abnormally (perhaps due to a power failure) leaving some files locked.
  • COBRT077 Internal ISAM module error (Fatal)
    This is the result of an internal system error.
  • COBRT078 Illegal key description in indexed file (Fatal)
    This is the result of an internal system error.
  • COBRT079 COBCONFIG syntax error (Fatal)
    An error exists in the run-time configuration file accessed via the environment variable COBCONFIG_.
  • COBRT080 Can't convert to/from Unicode codeset (Fatal)
    You have tried to use the additional language variants but there are no mapping tables to convert to/from one of the codesets.
Parent topic: Run-time System Error Messages


COBRT065 File locked (Recoverable)

You have tried to open a file which has already been locked, or opened for output by another user. Alternatively, you have tried to lock or open for output a file which another user already has open.

Resolution:

Your program can inform the system operator (if there is one) that it is unable to access this file and should wait until the other user has finished using the file and closes it. You should then be able to continue to run your program.

Parent topic: COBRT061 - COBRT080


COBRT066 Attempt to add duplicate record key to indexed file (Fatal)

You have tried to add a duplicate key for a key which you have not defined as being able to have duplicates.

Resolution:

As this error implies that your program logic contains a mistake, you probably should recode.

Parent topic: COBRT061 - COBRT080


COBRT067 Indexed file not open (Recoverable)

You are trying to access an indexed file which you have not opened.

Resolution:

Open the file in the relevant access mode and then retry the unsuccessful file operation.

Parent topic: COBRT061 - COBRT080


COBRT068 Record locked (Recoverable)

You have tried to access a record which is currently locked by another user.

Resolution:

Your program can inform the system operator (if there is one) that the record is currently locked, and you should then wait until the other user has released the lock on that record. You should then be able to access the relevant record. You should not continually retry to gain access to the record without operator intervention, as this could result in your application hanging.

Parent topic: COBRT061 - COBRT080


COBRT069 Illegal argument to isam module (Fatal)

This is the result of an internal system error.

Resolution:

Contact Technical Support who will help you discover the cause of your error and how it can be rectified.

Parent topic: COBRT061 - COBRT080


COBRT070 Too many indexed files open (Recoverable)

You are trying to open an indexed file but you have already exhausted the system limit which specifies how many of these files can be opened at any one time.

Resolution:

Close some of the open indexed files which you are not currently accessing. You should then be able to open the indexed file which you require and to continue the program run.

Parent topic: COBRT061 - COBRT080


COBRT071 Bad indexed file format (Fatal)

You are either using a file which has been corrupted, or there is an internal system error.

Resolution:

If the disk you are using is corrupt, rerun your program using your backup copy of the disk. If this is not the cause of the error then you should contact Technical Support who will help you discover the cause of your error and how it can be rectified.

Parent topic: COBRT061 - COBRT080


COBRT072 End of indexed file (Fatal)

This is the result of an internal system error.

Resolution:

Contact Technical Support who will help you discover the cause of your error and how it can be rectified.

Parent topic: COBRT061 - COBRT080


COBRT073 No record found in indexed file (Fatal)

This is the result of an internal system error.

Resolution:

Contact Technical Support who will help you discover the cause of the error and how it can be rectified.

Parent topic: COBRT061 - COBRT080


COBRT074 No current record in indexed file (Fatal)

This is the result of an internal system error.

Resolution:

Contact Technical Support who will help you discover the cause of the error and how it can be rectified.

Parent topic: COBRT061 - COBRT080


COBRT075 Indexed data file name too long (Fatal)

When creating indexed files, the extension .idx is added to the user-defined filename, so your filename must not exceed x-4 characters in length, where x is the maximum length of filename.

Resolution:

Rename the file with a shorter filename, that is, one that is less than 10 characters in length.

Parent topic: COBRT061 - COBRT080


COBRT076 Can't create lock file in /isam directory (Fatal)

For some reason your system is unable to create a lock file in the /isam directory. One reason for this could be that in its previous run your program terminated abnormally (perhaps due to a power failure) leaving some files locked.

Resolution:

You should manually remove all of the files that are still locked from the /isam directory before you can successfully run your program.

Parent topic: COBRT061 - COBRT080


COBRT077 Internal ISAM module error (Fatal)

This is the result of an internal system error.

Resolution:

Contact Technical Support who will help you discover the cause of your error and how it can be rectified.

Parent topic: COBRT061 - COBRT080


COBRT078 Illegal key description in indexed file (Fatal)

This is the result of an internal system error.

Resolution:

Contact Technical Support who will help you discover the cause of your error and how it can be rectified.

Parent topic: COBRT061 - COBRT080


COBRT079 COBCONFIG syntax error (Fatal)

An error exists in the run-time configuration file accessed via the environment variable COBCONFIG_.

Resolution:

Check the syntax of the entries in the configuration file. You might have used incorrect syntax, or syntax that is not compatible with the type of run-time tunable you are configuring (this could include assigning an illegal value to the tunable).

Parent topic: COBRT061 - COBRT080


COBRT080 Can't convert to/from Unicode codeset (Fatal)

You have tried to use the additional language variants but there are no mapping tables to convert to/from one of the codesets.

Resolution:

Check that the operating system Unicode mapping tables have been installed on your machine. If converting to/from the current locale, ensure that operating system mapping tables exist for the corresponding codeset.

Parent topic: COBRT061 - COBRT080


COBRT101 - COBRT120

  • COBRT081 Key already exists in indexed file (Fatal)
    This is the result of an internal system error.
  • COBRT082 CALL convention not supported (Fatal)
    The CALL convention you have specified is not supported.
  • COBRT086 Remote file system failure (Fatal)
  • COBRT099 Illegal operation in SORT/MERGE module (Fatal)
    A SORT or MERGE module has received a RELEASE operation outside the Input procedure, or a RETURN operation either outside the Output procedure, or before the Input procedure has terminated correctly.
  • COBRT100 Invalid file operation (Fatal)
    You have tried a file operation which violates a general rule of COBOL in some way. The most likely cause of this error is that you have tried a rewrite on a sequential file opened I-O, or on a relative file with access mode sequential also opened I-O, without preceding it with a successful read NEXT.
  • COBRT101 Illegal operation on an indexed file (Fatal)
    This is the result of an internal system error.
  • COBRT102 Sequential file with non-integral number of records (Fatal)
    You have either specified an incorrect record length for a sequential file, or the sequential file you are trying to access is corrupt in some way, or the file which you have specified is not a sequential file.
  • COBRT103 Parameter cannot be passed BY VALUE (Fatal)
  • COBRT104 Null file name used in a file operation (Fatal)
    You specified a data-name for a file-name instead of a literal, and the data item contained only spaces when you tried to open the file.
  • COBRT105 Memory allocation error (Fatal)
    The run-time system is unable to allocate sufficient memory space to successfully carry out the tried operation, probably because of insufficient memory space on your system.
  • COBRT106 Dictionary error (Fatal)
    This could be the result of a read or write error to file or disk, but it is more likely to be the result of an internal system error.
  • COBRT107 Operation not implemented in this run-time system (Fatal)
    You are trying to perform a file operation which your run-time system does not support.
  • COBRT108 Failure to initialize data division (Fatal)
    The run-time system cannot load your program properly because the data needed to correctly initialize the Data Division has become corrupted.
  • COBRT109 Invalid checksum in run-time system (Recoverable)
    The internal information in the run-time system has been altered. The run-time system might have become corrupted, or you might have illegally tried to change the internal run-time system information.
  • COBRT110 Generated code not supported by this RTS (Fatal)
  • COBRT111 Incompatible Class Library and Run-Time Environment versions (Fatal)
    The version numbers for these components do not match.
  • COBRT112 Unable to locate/access the required security key (Recoverable)
    The run-time system cannot locate or cannot access the coded security key (dongle) that is required to execute this application.
  • COBRT114 Attempt to access item beyond bounds of memory (Fatal)
    Memory access violation has been detected by your operating system.
  • COBRT115 Unexpected signal (Fatal)
    A signal the run-time system was not expecting has been caught.
  • COBRT116 Cannot allocate memory (Fatal)
    For some reason a part of your run-time system is unable to allocate you sufficient memory to enable you to execute your code.
  • COBRT117 Bad collating sequence (Fatal)
    This is an internal system error.
  • COBRT118 Symbol not found (Fatal)
    You have attempted to reference a name that has not been defined.
  • COBRT119 Symbol redefined (Fatal)
    The run-time system has detected a symbol (for example, data item, entry point or module name) which is already defined.
  • COBRT120 Symbol string table of zero size (Fatal)
    You probably have a malformed object file.
Parent topic: Run-time System Error Messages


COBRT081 Key already exists in indexed file (Fatal)

This is the result of an internal system error.

Resolution:

Contact Technical Support who will help you discover the cause of your error and how it can be rectified.

Parent topic: COBRT101 - COBRT120


COBRT082 CALL convention not supported (Fatal)

The CALL convention you have specified is not supported.

Resolution:

Change the convention defined in the Special-Names paragraph to one of the supported CALL conventions.

Parent topic: COBRT101 - COBRT120


COBRT086 Remote file system failure (Fatal)

Parent topic: COBRT101 - COBRT120


COBRT099 Illegal operation in SORT/MERGE module (Fatal)

A SORT or MERGE module has received a RELEASE operation outside the Input procedure, or a RETURN operation either outside the Output procedure, or before the Input procedure has terminated correctly.

Resolution:

Recode your program so that RELEASE and RETURN operations are issued by the appropriate procedures.

Parent topic: COBRT101 - COBRT120


COBRT100 Invalid file operation (Fatal)

You have tried a file operation which violates a general rule of COBOL in some way. The most likely cause of this error is that you have tried a rewrite on a sequential file opened I-O, or on a relative file with access mode sequential also opened I-O, without preceding it with a successful read NEXT.

Resolution:

Recode your program to ensure that the REWRITE statement in error is preceded by a read NEXT.

Parent topic: COBRT101 - COBRT120


COBRT101 Illegal operation on an indexed file (Fatal)

This is the result of an internal system error.

Resolution:

Contact Technical Support who will help you discover the cause of your error and how it can be rectified.

Parent topic: COBRT101 - COBRT120


COBRT102 Sequential file with non-integral number of records (Fatal)

You have either specified an incorrect record length for a sequential file, or the sequential file you are trying to access is corrupt in some way, or the file which you have specified is not a sequential file.

Resolution:

Recode your program so that it specifies the correct type of file, or if the error is the result of a corrupt file, try to run the program again using a backup copy of that file.

Parent topic: COBRT101 - COBRT120


COBRT103 Parameter cannot be passed BY VALUE (Fatal)

Parent topic: COBRT101 - COBRT120


COBRT104 Null file name used in a file operation (Fatal)

You specified a data-name for a file-name instead of a literal, and the data item contained only spaces when you tried to open the file.

Alternatively, you have attempted to do a CALL dataname in which the dataname has at least one leading space character.

Resolution:

Recode your program specifying the correct file-name.

Ensure the target program name is space terminated.

Parent topic: COBRT101 - COBRT120


COBRT105 Memory allocation error (Fatal)

The run-time system is unable to allocate sufficient memory space to successfully carry out the tried operation, probably because of insufficient memory space on your system.

Resolution:

You should obtain more memory in which to run your program. Refer to your operating system documentation for details of how you can obtain more memory, if this is possible.

Parent topic: COBRT101 - COBRT120


COBRT106 Dictionary error (Fatal)

This could be the result of a read or write error to file or disk, but it is more likely to be the result of an internal system error.

Alternatively, your application might have called many programs without canceling them afterward, so that memory becomes exhausted during animation.

Resolution:

Contact Technical Support who will help you to discover the cause of your error and how it can be rectified.

Ensure that as much memory as possible is available during animation by CANCELing any program you do not currently need to access.

Parent topic: COBRT101 - COBRT120


COBRT107 Operation not implemented in this run-time system (Fatal)

You are trying to perform a file operation which your run-time system does not support.

Resolution:

You should recode your program so that it does not try such operations, or you should acquire a version of your system that does support this facility.

Parent topic: COBRT101 - COBRT120


COBRT108 Failure to initialize data division (Fatal)

The run-time system cannot load your program properly because the data needed to correctly initialize the Data Division has become corrupted.

Resolution:

You should compile your program again to try to obtain good intermediate code.

Parent topic: COBRT101 - COBRT120


COBRT109 Invalid checksum in run-time system (Recoverable)

The internal information in the run-time system has been altered. The run-time system might have become corrupted, or you might have illegally tried to change the internal run-time system information.

The internal information in the run-time system has been altered. The run-time system might have become corrupted, or you might have illegally tried to change the internal run-time system information.

Parent topic: COBRT101 - COBRT120


COBRT110 Generated code not supported by this RTS (Fatal)

Resolution:

Contact Technical Support who will help you to discover the cause of the error and how it can be rectified.

Parent topic: COBRT101 - COBRT120


COBRT111 Incompatible Class Library and Run-Time Environment versions (Fatal)

The version numbers for these components do not match.

Resolution:

Check that you have fully installed both the Class Library and the Run-Time Environment from the same version of your COBOL system. If you have more than one version installed, check that your PATH and COBDIR environment variables specify an appropriate path for the version you are using.

Parent topic: COBRT101 - COBRT120


COBRT112 Unable to locate/access the required security key (Recoverable)

The run-time system cannot locate or cannot access the coded security key (dongle) that is required to execute this application.

Resolution:

Connect the security key that was supplied with your COBOL system to the parallel port of your computer, then re-run the application.

Parent topic: COBRT101 - COBRT120


COBRT114 Attempt to access item beyond bounds of memory (Fatal)

Memory access violation has been detected by your operating system.

The file mfdebug.log is automatically generated in your current directory.

Parent topic: COBRT101 - COBRT120


COBRT115 Unexpected signal (Fatal)

A signal the run-time system was not expecting has been caught.

If you are running under Windows, the file mfdebug.log is automatically generated in your current directory.

Parent topic: COBRT101 - COBRT120


COBRT116 Cannot allocate memory (Fatal)

For some reason a part of your run-time system is unable to allocate you sufficient memory to enable you to execute your code.

Resolution:

You should try to reduce memory usage by canceling programs that are not in use, then try the operation that caused this message again.

Parent topic: COBRT101 - COBRT120


COBRT117 Bad collating sequence (Fatal)

This is an internal system error.

Resolution:

Contact Technical Support who will help you to discover the cause of the error and how it can be rectified.

Parent topic: COBRT101 - COBRT120


COBRT118 Symbol not found (Fatal)

You have attempted to reference a name that has not been defined.
Parent topic: COBRT101 - COBRT120


COBRT119 Symbol redefined (Fatal)

The run-time system has detected a symbol (for example, data item, entry point or module name) which is already defined.

OO programs can also cause this error for either of the following reasons:

  • You have defined the same method-name twice in a single object
  • You have defined the same class name with different filenames in different programs, in the Class-Control paragraph. Filename matching is case-sensitive; class filenames should always be coded in lower-case.

Resolution:

You can recode your application to remove the naming duplication.

Parent topic: COBRT101 - COBRT120


COBRT120 Symbol string table of zero size (Fatal)

You probably have a malformed object file.

Resolution:

Once the program has terminated you must correct your object file. If this does not work, contact Technical Support who will help you to discover the specific cause of the error.

Parent topic: COBRT101 - COBRT120


COBRT121 - COBRT140

  • COBRT121 Symbol is not in TEXT section (Fatal)
    You have tried to call a subprogram that is not an executable program.
  • COBRT122 Coblongjmp() called below level of cobsavenv() (Fatal)
    You might have returned control to a higher level in the CALL/PERFORM hierarchy than the level at which cobsetjmp was called. Coblongjmp must be called only from the same or from a lower level in the CALL/PERFORM hierarchy as cobsavenv was.
  • COBRT123 Unknown relocation type (Fatal)
    You are using incompatible versions of the object file and the COBOL run-time library.
  • COBRT124 Communication failure during I/O request to the central file handler
  • COBRT125 All locks/ current transactions canceled due to exceeding time limit
  • COBRT126 Record size exceeds system limit (Fatal)
    One of the following has occurred:
  • COBRT127 coblongjmp() called from a different thread to cobsetjmp() (Fatal)
    You have called coblongjmp() in a different thread from the corresponding call to cobsetjmp(). coblongjmp() must be called from the same thread as the corresponding call to cobsetjmp().
  • COBRT129 Attempt to access record zero of relative file (Recoverable)
    The value specified in the RELATIVE KEY data item contains the value zero.
  • COBRT135 File not found (Recoverable)
    The operating system has been unable to find a file which you have tried to access in your program.
  • COBRT136 Corrupt or invalid executable file (Fatal)
    An attempt was made to execute a .gnt file or a library file that is not valid. The file might be corrupted or truncated.
  • COBRT137 Illegal device specification - not mass storage
  • COBRT138 File closed with lock - cannot be opened (Recoverable)
    You are trying to open a file which you previously closed with lock, which violates one of the general rules of COBOL programming.
  • COBRT139 Record length or key data inconsistency (Recoverable)
    A discrepancy exists between the length of a record, or the keys which you have specified, in your current program and its definition in the program in which it was first opened.
Parent topic: Run-time System Error Messages


COBRT121 Symbol is not in TEXT section (Fatal)

You have tried to call a subprogram that is not an executable program.

Alternatively, you have used the same name for a called program as for a previously defined data item.

Resolution:

Check that the subprogram being called is an executable one. If required, correct the subprogram's name in the calling program and resubmit it to your COBOL system.

Once your program has terminated, recode it to remove the naming duplication. Resubmit your program to your COBOL system.

Parent topic: COBRT121 - COBRT140


COBRT122 Coblongjmp() called below level of cobsavenv() (Fatal)

You might have returned control to a higher level in the CALL/PERFORM hierarchy than the level at which cobsetjmp was called. Coblongjmp must be called only from the same or from a lower level in the CALL/PERFORM hierarchy as cobsavenv was.

Resolution:

Check and correct the logic of your program, and then resubmit your program to your COBOL system.

Parent topic: COBRT121 - COBRT140


COBRT123 Unknown relocation type (Fatal)

You are using incompatible versions of the object file and the COBOL run-time library.

Resolution:

Once the program has terminated, resubmit your object file to your COBOL system with the current version of your COBOL run-time library. If this does not work, contact Technical Support who will help you to discover the specific cause of the error.

Parent topic: COBRT121 - COBRT140


COBRT124 Communication failure during I/O request to the central file handler

Parent topic: COBRT121 - COBRT140


COBRT125 All locks/ current transactions canceled due to exceeding time limit

Parent topic: COBRT121 - COBRT140


COBRT126 Record size exceeds system limit (Fatal)

One of the following has occurred:
  • You have attempted to open for output a file whose record length is greater than the system limits. For C-ISAM format files, the limit is 32,767 bytes. For Micro Focus format files, the limit is 268,433,408 bytes.
  • You have attempted a REWRITE on a sequential file using data compression where the compressed length of the new record differs from that of the original.

Resolution:

Correct the record size.

Parent topic: COBRT121 - COBRT140


COBRT127 coblongjmp() called from a different thread to cobsetjmp() (Fatal)

You have called coblongjmp() in a different thread from the corresponding call to cobsetjmp(). coblongjmp() must be called from the same thread as the corresponding call to cobsetjmp().

Resolution:

Check and correct the logic of your program, then resubmit it to your COBOL system.

Parent topic: COBRT121 - COBRT140


COBRT129 Attempt to access record zero of relative file (Recoverable)

The value specified in the RELATIVE KEY data item contains the value zero.

Resolution:

You should ensure that the value in the RELATIVE KEY data item is greater than zero, then continue to run your program.

Parent topic: COBRT121 - COBRT140


COBRT135 File not found (Recoverable)

The operating system has been unable to find a file which you have tried to access in your program.

Resolution:

Ensure that you are in the correct directory or that a path to the file concerned exists. You can then try the file operation again. If the error is the result of a spelling mistake then ask for the correct file and try the file operation again.

Parent topic: COBRT121 - COBRT140


COBRT136 Corrupt or invalid executable file (Fatal)

An attempt was made to execute a .gnt file or a library file that is not valid. The file might be corrupted or truncated.

Resolution:

Recompile the source code or recreate the library file, ensuring that it is processed without errors.

Parent topic: COBRT121 - COBRT140


COBRT137 Illegal device specification - not mass storage

Parent topic: COBRT121 - COBRT140


COBRT138 File closed with lock - cannot be opened (Recoverable)

You are trying to open a file which you previously closed with lock, which violates one of the general rules of COBOL programming.

Resolution:

You cannot open the relevant file. As this error implies that your program logic contains a mistake, you might want to close any remaining open files, execute a STOP RUN statement and recode.

Parent topic: COBRT121 - COBRT140


COBRT139 Record length or key data inconsistency (Recoverable)

A discrepancy exists between the length of a record, or the keys which you have specified, in your current program and its definition in the program in which it was first opened.

Resolution:

Your program has a fault, so you probably should edit your code, then resubmit it to your COBOL system before running it again.

Parent topic: COBRT121 - COBRT140


COBRT141 - COBRT160

  • COBRT141 File already open - cannot be opened (Recoverable)
    You have tried to open a file which is already open and so cannot be opened again.
  • COBRT142 File not open - cannot be closed (Recoverable)
    You have tried to close a file which is not open which is impossible to achieve.
  • COBRT143 Rewrite/delete in sequential mode not preceded by successful read (Recoverable)
    You have failed to do a successful read on a sequentially accessed file trying a REWRITE or DELETE on some of the information contained in that file.
  • COBRT144 Boundary violation (Recoverable)
    You have tried to write a record to a variable length record file, the length of which is not within the defined range for that file.
  • COBRT146 No current record defined for sequential read (Recoverable)
    The file position indicator in your file is undefined owing to a failed read/START or INVALID KEY condition. You have tried to read another record in the file but as the current record is undefined the system cannot find the start of the record for which you have asked.
  • COBRT147 Wrong open mode or access mode for read/start (Recoverable)
    You have tried to carry out a read or START operation on a file which has not been opened for INPUT or I-O, or which is not open at all.
  • COBRT148 Wrong open mode or access mode for write (Recoverable)
    You have tried to write to a file in sequential access mode that you have not opened for OUTPUT or EXTEND, or you have tried to write to a file in random or dynamic access mode that has not been opened INPUT or I-O, or which is not open at all.
  • COBRT149 Wrong open mode or access mode for rewrite/delete (Recoverable)
    You are trying to do a REWRITE or a DELETE on a file that you have not opened for I-O, or which is not open at all.
  • COBRT151 Random read on sequential file (Recoverable)
    You are trying to do a random read on a file which has sequential organization.
  • COBRT152 REWRITE on file not opened I-O (Recoverable)
    You have tried a REWRITE on a file that is not open I-O.
  • COBRT153 Subscript out of range (Fatal)
    A subscript which you have used in your program is out of the defined range, that is, it is either less than one or it is greater than the number of occurrences of the item.
  • COBRT154 PERFORM nested too deeply (Fatal)
    This error usually results if you have used GO TO to jump out of the range of a PERFORM rather than to jump to an EXIT statement at the end of its range.
  • COBRT155 Illegal command line (Fatal)
    The run-time system does not recognize as valid the command line format you have specified.
  • COBRT156 Too many parentheses in compute statement (Fatal)
    You have coded a COMPUTE statement which is too complex for your system to handle successfully.
  • COBRT157 Not enough program memory: object file too large to load (Recoverable)
    Either your program is too large for the available memory space, or the stack is full.
  • COBRT158 Attempt to REWRITE to a line-sequential file (Recoverable)
    You have used the REWRITE statement in conjunction with a file whose organization is line sequential. The REWRITE statement cannot be used with line sequential files.
  • COBRT159 Malformed line-sequential file (Recoverable)
    A line-sequential file which you are trying to access is corrupt in some way.
  • COBRT160 Overlay loading error (Recoverable)
    An error has occurred while trying to load the intermediate code for an independent segment. The segment is either missing or corrupted in some way.
Parent topic: Run-time System Error Messages


COBRT141 File already open - cannot be opened (Recoverable)

You have tried to open a file which is already open and so cannot be opened again.

Resolution:

Cancel your second attempt to open the file and continue to run your program if the fact that the file is already open is acceptable to you. However as this error implies that your program logic contains a mistake, you might want to close any open files, execute a STOP RUN statement and then recode.

Parent topic: COBRT141 - COBRT160


COBRT142 File not open - cannot be closed (Recoverable)

You have tried to close a file which is not open which is impossible to achieve.

Resolution:

You can abandon your attempt to close the relevant file and continue to run your program. However, as this error implies that your program logic contains a mistake, you might want to close any open files, execute a STOP RUN statement and then recode.

Parent topic: COBRT141 - COBRT160


COBRT143 Rewrite/delete in sequential mode not preceded by successful read (Recoverable)

You have failed to do a successful read on a sequentially accessed file trying a REWRITE or DELETE on some of the information contained in that file.

Resolution:

If the previous read was successful then perform a read on the relevant file before you retry the unsuccessful REWRITE or DELETE operation. If the previous read was also unsuccessful close the file, execute a STOP RUN statement and then recode your program before you next run it.

Parent topic: COBRT141 - COBRT160


COBRT144 Boundary violation (Recoverable)

You have tried to write a record to a variable length record file, the length of which is not within the defined range for that file.

Resolution:

Recode your program.

Parent topic: COBRT141 - COBRT160


COBRT146 No current record defined for sequential read (Recoverable)

The file position indicator in your file is undefined owing to a failed read/START or INVALID KEY condition. You have tried to read another record in the file but as the current record is undefined the system cannot find the start of the record for which you have asked.

Resolution:

You should try a START operation, and continue to do so until the file position indicator is updated successfully.

Parent topic: COBRT141 - COBRT160


COBRT147 Wrong open mode or access mode for read/start (Recoverable)

You have tried to carry out a read or START operation on a file which has not been opened for INPUT or I-O, or which is not open at all.

Resolution:

Open the file for I-O or for INPUT and you should then be able to continue to run your program. However, as this error implies that your program logic contains a mistake, you might want to close any files which are open, execute a STOP RUN statement and then recode.

Parent topic: COBRT141 - COBRT160


COBRT148 Wrong open mode or access mode for write (Recoverable)

You have tried to write to a file in sequential access mode that you have not opened for OUTPUT or EXTEND, or you have tried to write to a file in random or dynamic access mode that has not been opened INPUT or I-O, or which is not open at all.

Resolution:

Close the file and reopen it with the correct open mode for the file type. However, as this error implies that your program logic contains a mistake, you might want to close any files that are open, execute a STOP RUN statement and then recode.

Parent topic: COBRT141 - COBRT160


COBRT149 Wrong open mode or access mode for rewrite/delete (Recoverable)

You are trying to do a REWRITE or a DELETE on a file that you have not opened for I-O, or which is not open at all.

Resolution:

Close the file and reopen for I-O. However, as this error implies that your program logic contains a mistake, you might want to close any open files, execute a STOP RUN statement and then recode.

Parent topic: COBRT141 - COBRT160


COBRT151 Random read on sequential file (Recoverable)

You are trying to do a random read on a file which has sequential organization.

Resolution:

Read the file with the correct access mode. As this error implies that your program logic contains a mistake, you might like to close any files which are open, execute a STOP RUN statement and recode.

Parent topic: COBRT141 - COBRT160


COBRT152 REWRITE on file not opened I-O (Recoverable)

You have tried a REWRITE on a file that is not open I-O.

Resolution:

Close the relevant file and open it for I-O operations. You should then be able to carry out the REWRITE operation successfully. However, as this error implies that your program logic contains a mistake, you might want to close any open files, execute a STOP RUN statement and then recode.

Parent topic: COBRT141 - COBRT160


COBRT153 Subscript out of range (Fatal)

A subscript which you have used in your program is out of the defined range, that is, it is either less than one or it is greater than the number of occurrences of the item.

Resolution:

You should recode your program.

Parent topic: COBRT141 - COBRT160


COBRT154 PERFORM nested too deeply (Fatal)

This error usually results if you have used GO TO to jump out of the range of a PERFORM rather than to jump to an EXIT statement at the end of its range.

Resolution:

When your program has terminated you should to recode your program to ensure that the GO TO in question jumps to an EXIT statement at the end of the PERFORM's range.

Parent topic: COBRT141 - COBRT160


COBRT155 Illegal command line (Fatal)

The run-time system does not recognize as valid the command line format you have specified.

Alternatively, the generic command-line interpreter, which must be present if your program is to be run successfully, is not found on your system.

Alternatively, you have set an invalid COBSW value.

Resolution:

Rerun your application with a valid command line.

Make sure that the interpreter is present to enable your system to pick up the commands correctly and then rerun your program.

Reset COBSW to a valid value.

Parent topic: COBRT141 - COBRT160


COBRT156 Too many parentheses in compute statement (Fatal)

You have coded a COMPUTE statement which is too complex for your system to handle successfully.

Resolution:

You should recode your program. We strongly advise you to break the relevant COMPUTE statement into a number of simpler statements.

Parent topic: COBRT141 - COBRT160


COBRT157 Not enough program memory: object file too large to load (Recoverable)

Either your program is too large for the available memory space, or the stack is full.

Resolution:

If you have specified the ON OVERFLOW/EXCEPTION clause in the relevant CALL statement, the error is recoverable. Any associated imperative statement is executed before the next instruction.

Parent topic: COBRT141 - COBRT160


COBRT158 Attempt to REWRITE to a line-sequential file (Recoverable)

You have used the REWRITE statement in conjunction with a file whose organization is line sequential. The REWRITE statement cannot be used with line sequential files.

Resolution:

Close the file in error before executing a STOP RUN statement to ensure that you do not lose any data from it. Recode your program to make the organization of the file to which you want to do a REWRITE either sequential, indexed sequential, or relative.

Parent topic: COBRT141 - COBRT160


COBRT159 Malformed line-sequential file (Recoverable)

A line-sequential file which you are trying to access is corrupt in some way.

Resolution:

Rerun your program using the backup copy of that file.

Parent topic: COBRT141 - COBRT160


COBRT160 Overlay loading error (Recoverable)

An error has occurred while trying to load the intermediate code for an independent segment. The segment is either missing or corrupted in some way.

Resolution:

If the segment is missing, locate it. If you cannot find it, or if it is present and corrupt, resubmit your program to your COBOL system.

Parent topic: COBRT141 - COBRT160


COBRT161 - COBRT180

  • COBRT161 Illegal intermediate code (Fatal)
    The intermediate code which is currently being processed is not valid code. You are probably trying to execute a corrupted file or one which has not been submitted to your COBOL system successfully.
  • COBRT162 Arithmetic overflow or underflow (Fatal)
    You are executing a program that is trying to perform a floating-point divide by zero.
  • COBRT163 Illegal character in numeric field (Fatal)
    The contents of a numeric or numeric edited field are inconsistent with the picture definition of that field.
  • COBRT164 Run-Time subprogram not found (Fatal)
    You have tried to call a subroutine whose entry address has not been set up in your run-time system.
  • COBRT165 Version number incompatibility (Fatal)
    You have tried to:
  • COBRT166 Recursive COBOL CALL is illegal (Fatal)
    You have tried to call a COBOL module that is already active.
  • COBRT167 Too many USING items (Fatal)
    The list of items which you have supplied in a CALL....USING statement is longer than the run-time system can handle.
  • COBRT168 Stack overflow (Fatal)
    You have nested a PERFORM statement or a series of CALL statements too deeply.
  • COBRT169 Illegal configuration information (Fatal)
    You have tried an operation for which your machine is not configured; the most likely cause of this is that Adis is not configured correctly.
  • COBRT170 System program not found (Fatal)
    A system program, for example Adis or Mffh, is not present.
  • COBRT171 Japanese operations illegal with this RTS (Fatal)
    You are trying to perform Japanese operations with a non-Japanese run-time system, or you have used a Japanese version of your COBOL system to produce code which you are now trying to run using a non-Japanese run-time system.
  • COBRT173 Called program file not found in drive/directory (Fatal)
    You have tried to call a program which is not present on your current logged-in drive or directory, or in a directory pointed to by the COBDIR environment variable, or to send a message to a class which cannot be loaded.
  • COBRT174 Imported file not found (Fatal)
    You have tried to load a .dll file which contains references to another .dll file which cannot be found by the operating system.
  • COBRT175 Attempt to run intermediate code program which had severe errors in it (Fatal)
    You are trying to run a program that produced severe faults when you submitted it to your COBOL system with the run-time switch E turned off.
  • COBRT176 Illegal intersegment reference (Fatal)
    You might have a corrupted file. Alternatively, your code contains a segment reference for the Forward Reference Table which is illegal.
  • COBRT177 Attempt to cancel program failed (Fatal)
    You have tried to remove a currently executing program or its parents or grandparents, from memory.
  • COBRT179 Error during chain (program not found) (Fatal)
    You have tried to chain to another program which your system is unable to find.
  • COBRT180 End-of-file marker error (Fatal)
    A file-marker used to indicate that the end-of-file has been reached is missing from one of your files.
Parent topic: Run-time System Error Messages


COBRT161 Illegal intermediate code (Fatal)

The intermediate code which is currently being processed is not valid code. You are probably trying to execute a corrupted file or one which has not been submitted to your COBOL system successfully.

Resolution:

You should resubmit your source program to your COBOL system, to try to obtain uncorrupted intermediate code.

or:

If your application is invoking the File Handler directly using calls to EXTFH or mFFH, you might encounter this error if the key definition block has been incorrectly defined. Please refer to the File Handler reference documentation for details about the correct format of the key definition block.

Parent topic: COBRT161 - COBRT180


COBRT162 Arithmetic overflow or underflow (Fatal)

You are executing a program that is trying to perform a floating-point divide by zero.

Resolution:

You should recode your program to avoid this illegal operation.

Parent topic: COBRT161 - COBRT180


COBRT163 Illegal character in numeric field (Fatal)

The contents of a numeric or numeric edited field are inconsistent with the picture definition of that field.

Resolution:

Adjust your code so that no invalid data is used, or set the –F run-time switch to suppress the checking of numeric items for valid data.

Parent topic: COBRT161 - COBRT180


COBRT164 Run-Time subprogram not found (Fatal)

You have tried to call a subroutine whose entry address has not been set up in your run-time system.

Resolution:

Check to see that you used a valid call number in the unsuccessful subroutine call. If not, revise your code to contain a call number which your system recognizes. If you did use a valid call number but still received this error you should contact Technical Support.

Parent topic: COBRT161 - COBRT180


COBRT165 Version number incompatibility (Fatal)

You have tried to:
  • Run a program that has:intermediate code which has been produced on a version of your COBOL system that is incompatible with the run-time system you are using. Your run-time system, therefore, cannot execute correctly any generated code you are producing or have already produced from this intermediate code.
  • Execute a file which is not in your COBOL system's intermediate or generated code.
  • Load a module whose format is not valid for the Win32 platform.
Parent topic: COBRT161 - COBRT180


COBRT166 Recursive COBOL CALL is illegal (Fatal)

You have tried to call a COBOL module that is already active.

Resolution:

You should recode your program.

Parent topic: COBRT161 - COBRT180


COBRT167 Too many USING items (Fatal)

The list of items which you have supplied in a CALL....USING statement is longer than the run-time system can handle.

Resolution:

Once your program has terminated recode it with group items rather than elementary items before rerunning it.

Parent topic: COBRT161 - COBRT180


COBRT168 Stack overflow (Fatal)

You have nested a PERFORM statement or a series of CALL statements too deeply.

Resolution:

Edit your program to reduce the number of levels in the nested PERFORM or CALL statement.

Parent topic: COBRT161 - COBRT180


COBRT169 Illegal configuration information (Fatal)

You have tried an operation for which your machine is not configured; the most likely cause of this is that Adis is not configured correctly.

Resolution:

Check that Adis is configured correctly.

Parent topic: COBRT161 - COBRT180


COBRT170 System program not found (Fatal)

A system program, for example Adis or Mffh, is not present.

Resolution:

Ensure that all the system programs are available and copy those which are not currently present using. Once all the necessary system programs are available you can run your program.

Parent topic: COBRT161 - COBRT180


COBRT171 Japanese operations illegal with this RTS (Fatal)

You are trying to perform Japanese operations with a non-Japanese run-time system, or you have used a Japanese version of your COBOL system to produce code which you are now trying to run using a non-Japanese run-time system.

Resolution:

You should resubmit your program using a non-Japanese run-time system, or if you still want your program to perform Japanese operations, you should acquire a Japanese run-time system.

Parent topic: COBRT161 - COBRT180


COBRT173 Called program file not found in drive/directory (Fatal)

You have tried to call a program which is not present on your current logged-in drive or directory, or in a directory pointed to by the COBDIR environment variable, or to send a message to a class which cannot be loaded.

Resolution:

Once your program has terminated you should copy the relevant file into your logged-in drive or directory. If insufficient space is available, you should set the COBDIR environment variable to search the directory or drive on which the file is present when your program calls it.

If the error was caused by a class which could not be loaded, find out whether or not the filename for the class (listed in the Class-Control paragraph) is a separate executable file, or contained in a .dll or .lbr file. If it is a separate executable file, the resolution is as above. If it is part of a .dll or .lbr file, ensure that the containing file has been loaded with a CALL statement before sending messages to any of the classes. If the program not found is P2emgr, you need to load the GUI Class Library, with a CALL "APIGUI" statement.

Parent topic: COBRT161 - COBRT180


COBRT174 Imported file not found (Fatal)

You have tried to load a .dll file which contains references to another .dll file which cannot be found by the operating system.

Resolution:

Locate the missing file and ensure it is located on the default search path for your operating system.

Parent topic: COBRT161 - COBRT180


COBRT175 Attempt to run intermediate code program which had severe errors in it (Fatal)

You are trying to run a program that produced severe faults when you submitted it to your COBOL system with the run-time switch E turned off.

Alternatively, you could try to run the program with the E run-time switch set, though this might not give the desired results.

Resolution:

You should edit your source code to correct all the severe faults, resubmit it to your COBOL system, then run the intermediate code that is produced.

When your program is being animated, the debugger reports this error and enables you to continue to run the program.

Parent topic: COBRT161 - COBRT180


COBRT176 Illegal intersegment reference (Fatal)

You might have a corrupted file. Alternatively, your code contains a segment reference for the Forward Reference Table which is illegal.

Resolution:

Resubmit your source code to your COBOL system. If you receive this error again, contact Technical Support who will help you to discover the specific cause of the error.

Parent topic: COBRT161 - COBRT180


COBRT177 Attempt to cancel program failed (Fatal)

You have tried to remove a currently executing program or its parents or grandparents, from memory.

Resolution:

Once your program has terminated you need to recode your program to ensure that you do not try to cancel a program (or its parents or grandparents) while it is still being executed.

Parent topic: COBRT161 - COBRT180


COBRT179 Error during chain (program not found) (Fatal)

You have tried to chain to another program which your system is unable to find.

Resolution:

Once your program has terminated you should copy the relevant file into your logged-in drive or directory. If insufficient space is available, you should set the COBDIR environment variable to include the directory or drive on which the file is present when your program calls it.

Parent topic: COBRT161 - COBRT180


COBRT180 End-of-file marker error (Fatal)

A file-marker used to indicate that the end-of-file has been reached is missing from one of your files.

Resolution:

You should resubmit your code to your COBOL system, or use a debugger to place the end-of-file marker at the end of the file. You can then rerun your program.

Parent topic: COBRT161 - COBRT180


COBRT181 - COBRT200

  • COBRT181 Invalid parameter error (Fatal)
    A parameter which you have used is not one which is recognized by your system.
  • COBRT182 Console input or console output open in wrong direction (Fatal)
    You are either trying to read input from the screen or write to the keyboard.
  • COBRT183 Attempt to open line sequential file for I-O (Fatal)
    You have tried to open a line-sequential file in the input-output open mode, but this mode is not supported for files with this organization.
  • COBRT184 ACCEPT/DISPLAY I-O error (Fatal)
    You have either tried to read input from the screen or write to the keyboard, or the ADIS module has not been able to open your terminal's channels for I-O.
  • COBRT185 File malformed (Recoverable)
  • COBRT186 Attempt to open stdin, stdout or stderr with incorrect mode (Recoverable)
    You have tried to open either a standard input file with output mode, or some other file in an incorrect mode.
  • COBRT187 Run-time system not found on $COBDIR path (Fatal)
    The run-time system cannot be found on the path you have set up in the COBDIR environment variable. Alternatively, you might not have installed your COBOL system correctly.
  • COBRT188 Filename too large (Fatal)
    A file-name which you have used has more characters than the maximum number allowed by your operating system.
  • COBRT189 Intermediate code load error (Fatal)
    You are unable to load your intermediate code. You might have tried to load intermediate code that either has not been successfully produced, or has been corrupted in some way.
  • COBRT190 Too many arguments to CALL (Fatal)
    A CALL statement in your program cannot be successfully executed because of the number of arguments which you have used with it.
  • COBRT191 Terminal type not defined (Fatal)
    Your terminal is not defined.
  • COBRT192 Required terminal capability description missing (Fatal)
    A compulsory entry, for example cursor movement or clear screen, is missing from your terminal configuration database.
  • COBRT193 Error in variable length count (Fatal)
    The intermediate code which is currently being processed is not a valid operation. You are probably trying to execute a corrupt file or one which has not been produced.
  • COBRT194 File size too large (Fatal)
    A file which your program is accessing is too large for successful execution to continue.
  • COBRT195 DELETE/REWRITE not preceded by a read (Fatal)
    Before a DELETE or a REWRITE statement can be successfully executed in sequential access mode the last input-output statement executed for the associated file must have been a successful read. In your code no read statement precedes your tried DELETE or REWRITE.
  • COBRT196 Record number too large in relative or indexed file (Fatal)
    The relative record key has exceeded the system limit, that is, the file is too large for the system to handle.
  • COBRT197 Screen handling system initialization error (Fatal)
    This error can be caused by one of the following:
  • COBRT198 Load failure (Fatal)
    The system cannot load a program module or, in a multi-threading program, start a new thread.
  • COBRT199 Operating System error code lies outside expected range (Fatal)
    A system call has returned an unexpected error number which is not documented.
  • COBRT200 Run-time system internal logic error (Fatal)
    The amount of memory available on your machine is so low that not even the run-time system can be fully loaded.
Parent topic: Run-time System Error Messages


COBRT181 Invalid parameter error (Fatal)

A parameter which you have used is not one which is recognized by your system.

Resolution:

Revise your code to contain a parameter which is known by your system.

Parent topic: COBRT181 - COBRT200


COBRT182 Console input or console output open in wrong direction (Fatal)

You are either trying to read input from the screen or write to the keyboard.

Resolution:

You should recode your program.

Parent topic: COBRT181 - COBRT200


COBRT183 Attempt to open line sequential file for I-O (Fatal)

You have tried to open a line-sequential file in the input-output open mode, but this mode is not supported for files with this organization.

Resolution:

When your program has terminated you should recode your program to ensure that the file with organization line sequential is opened for input, output, or extend. You can then rerun your code.

Parent topic: COBRT181 - COBRT200


COBRT184 ACCEPT/DISPLAY I-O error (Fatal)

You have either tried to read input from the screen or write to the keyboard, or the ADIS module has not been able to open your terminal's channels for I-O.

Resolution:

Your program logic contains a mistake, so you must recode.

Parent topic: COBRT181 - COBRT200


COBRT185 File malformed (Recoverable)

Parent topic: COBRT181 - COBRT200


COBRT186 Attempt to open stdin, stdout or stderr with incorrect mode (Recoverable)

You have tried to open either a standard input file with output mode, or some other file in an incorrect mode.
Parent topic: COBRT181 - COBRT200


COBRT187 Run-time system not found on $COBDIR path (Fatal)

The run-time system cannot be found on the path you have set up in the COBDIR environment variable. Alternatively, you might not have installed your COBOL system correctly.

Resolution:

Ensure that the run-time system is on the path you have set up in the COBDIR environment variable. Alternatively, ensure that your COBOL system has been installed correctly. If it has not, you must reinstall your COBOL system.

Parent topic: COBRT181 - COBRT200


COBRT188 Filename too large (Fatal)

A file-name which you have used has more characters than the maximum number allowed by your operating system.

Resolution:

You should recode your program to check the length of the file in error, and rename it with a shorter file-name. You can then run your program again.

Parent topic: COBRT181 - COBRT200


COBRT189 Intermediate code load error (Fatal)

You are unable to load your intermediate code. You might have tried to load intermediate code that either has not been successfully produced, or has been corrupted in some way.

Resolution:

Try to obtain good intermediate code, for example, by resubmitting (or submitting) your source code to your COBOL system. You should then be able to load your code and run the program successfully.

Parent topic: COBRT181 - COBRT200


COBRT190 Too many arguments to CALL (Fatal)

A CALL statement in your program cannot be successfully executed because of the number of arguments which you have used with it.

Resolution:

When your program has terminated you can recode it using group items rather than elementary ones. You should then be able to run your program successfully.

Parent topic: COBRT181 - COBRT200


COBRT191 Terminal type not defined (Fatal)

Your terminal is not defined.

Resolution:

Your terminal type is undefined, so your operating system is unable to drive your terminal. Set up the necessary environment for your terminal.

Parent topic: COBRT181 - COBRT200


COBRT192 Required terminal capability description missing (Fatal)

A compulsory entry, for example cursor movement or clear screen, is missing from your terminal configuration database.

Resolution:

Add the missing entry to your terminal configuration database.

Parent topic: COBRT181 - COBRT200


COBRT193 Error in variable length count (Fatal)

The intermediate code which is currently being processed is not a valid operation. You are probably trying to execute a corrupt file or one which has not been produced.

Resolution:

You should resubmit your source code to your COBOL system.

Parent topic: COBRT181 - COBRT200


COBRT194 File size too large (Fatal)

A file which your program is accessing is too large for successful execution to continue.

Resolution:

When your program has terminated you should recode your program spreading the data over more than one file to ensure that no file becomes too large for your operating system to handle. Having recoded your program you can then rerun it.

Parent topic: COBRT181 - COBRT200


COBRT195 DELETE/REWRITE not preceded by a read (Fatal)

Before a DELETE or a REWRITE statement can be successfully executed in sequential access mode the last input-output statement executed for the associated file must have been a successful read. In your code no read statement precedes your tried DELETE or REWRITE.

Resolution:

When your program has terminated, recode your program, making sure that the last input-output statement to be executed before the DELETE or REWRITE is a read statement.

Parent topic: COBRT181 - COBRT200


COBRT196 Record number too large in relative or indexed file (Fatal)

The relative record key has exceeded the system limit, that is, the file is too large for the system to handle.

Alternatively, the record key which you have specified is too large for the system to deal with successfully, or the pointer to the record has been corrupted in some way so that it is either too large or it is not a multiple of the record length.

Parent topic: COBRT181 - COBRT200


COBRT197 Screen handling system initialization error (Fatal)

This error can be caused by one of the following:
  • Your display adapter is in the wrong mode.
  • Your screen handling interface has not been correctly initialized because your terminal does not have the required capabilities.
  • Memory has been incorrectly allocated.

Resolution:

The monitor must be in alphanumeric display mode rather than graphics display mode.

Parent topic: COBRT181 - COBRT200


COBRT198 Load failure (Fatal)

The system cannot load a program module or, in a multi-threading program, start a new thread.

A CALL statement has failed because:

  • In the case of a DLL, the specified entry point does not exist in the file
  • In the case of an .int or .gnt file, the file has been corrupted
  • In the case of a call of the form $PROG, name mapping has failed
  • In the case of a call-by-number library routine (CALL data-name, where data-name is a pic x with value greater than x'80'), the routine does not exist

Any call or attempt to start a thread can fail where internal structures have been corrupted; for example, by a protection violation.

A statement of the form SET PROCEDURE POINTER TO ENTRY entry-point has failed because the entry point cannot be found on disk or in the current run-unit.

The Entry Point Mapping facility has found a program on disk with the same name as an alias definition. Whether or not this condition results in a COBRT198 error depends on the setting of the entry_point_mapper_alias_exists_error tunable.

Rarely, this error can be caused by a CALL statement failing because of insufficient available memory or because the run-time system version is too old.

Resolution:

Check that the target of your call exists and has not been corrupted.

Test that a procedure pointer is valid before using it by including code of the form:

set bad-pointer to entry 'just-not-there-ever'...set procedure-pointer to entry 'myentrypoint'if procedure-pointer = bad-pointer display errorend-if
Parent topic: COBRT181 - COBRT200


COBRT199 Operating System error code lies outside expected range (Fatal)

A system call has returned an unexpected error number which is not documented.

Resolution:

Contact Technical Support who will help you to discover the specific cause of this error.

This error generates a Consolidated Tracing Facility warning event. To capture the generated event you must configure the Consolidated Tracing Facility as follows:

  • Set the trace level for the mf.rts component to WARN, INFO or DEBUG.
  • Set the API or FSYS property of the mf.rts component to TRUE.

If you want the event to appear in the Windows Application Event log you can configure the Consolidated Tracing Facility to do this with configuration entries such as the following:

mftrace.dest = WINEVENT
mftrace.level = WARN

mftrace.emitter.winevent#level = 2
mftrace.comp.mf.rts#api = TRUE

The mftrace.emitter.winevent#level = 2 entry is required because by default the WINEVENT emitter does not output any events below level 3 (ERROR).

In previous versions of this COBOL system, the error returned by the system call was written to the Windows Application Event log. You can revert to this behavior by setting the os_error_log tunable to true. If you set os_error_log to true and configure the Consolidated Tracing Facility as described above, each COBRT199 error causes two entries to be written to the Windows Application Event log.

Parent topic: COBRT181 - COBRT200


COBRT200 Run-time system internal logic error (Fatal)

The amount of memory available on your machine is so low that not even the run-time system can be fully loaded.

Alternatively, your run-time system has stopped as a result of an internal logic error from which you cannot recover.

Resolution:

Free some memory and then you should be able to run your program successfully.

Contact Technical Support who will help you to discover the cause of the error.

Parent topic: COBRT181 - COBRT200


COBRT201 - COBRT220

  • COBRT201 I-O error in paging system (Fatal)
    No room is available in your current directory or on the floppy disk which you are using, for the paging file.
  • COBRT203 CALL parameter not supplied (Fatal)
    The item you are trying to access in the Linkage Section of the currently executing program has not been initialized.
  • COBRT205 Invalid mainframe pointer value (Fatal)
    You are trying to reference an invalid mainframe address.
  • COBRT206 Reading unwritten data from memory (Fatal)
    You are trying to read data which has not been written, from the core file.
  • COBRT207 Machine does not exist (Recoverable)
    You have tried to access a machine that is not connected to your network, or which is not on-line.
  • COBRT208 Error in multi-user system (Fatal)
    This is normally caused by an unexpected error occurring in the network or file-sharing facilities. A corrupted network message also causes this error to be returned.
  • COBRT209 Network communication error (Recoverable)
    This is normally given if an incorrect checksum has been received in a communications packet.
  • COBRT210 File is closed with lock (Fatal)
    You have tried to open a file which you have previously closed with lock.
  • COBRT211 Program not executable by Run-Time System (Fatal)
    An attempt was made to run a program that is incompatible with the currently-specified run-time system. For example, system executable, shared library, and callable shared object files that have been linked using older COBOL systems could be incompatible.
  • COBRT212 Run-Time System version incompatible with object-oriented program (Fatal)
    You attempted to run an OO program that was compiled using a version of your COBOL system that is incompatible with the OO support provided in the run-time system you are using.
  • COBRT213 Too many locks (Recoverable)
    You have either tried to exceed the maximum number of simultaneous record locks per file you can have, or you have exhausted an operating system or network resource; for example dynamic memory.
  • COBRT214 GO TO has not been ALTERed (Fatal)
    You have violated one of the general rules of COBOL programming.
  • COBRT215 Cannot DEBUG a program running COMMUNICATIONS (Fatal)
    You have tried to debug a program which makes use of the communications module. This cannot be done as both Debugger and the communications module need full use of the CRT.
  • COBRT216 Cannot initialize the named communications device (Fatal)
    A device driver is probably missing.
  • COBRT217 Incompatible host for native code file (Fatal)
    The .gnt file is not valid for the host processor.
  • COBRT218 Malformed MULTIPLE REEL/UNIT file (Fatal)
    Either your file header is not correctly formatted, or you are not using a MULTIPLE REEL/UNIT file.
  • COBRT219 Operating system shared file limit exceeded (Recoverable)
    You have tried to exceed your operating system's limit on the number of shared files that you can have open simultaneously. As this figure is operating system dependent, you should consult your Release Notes for details of how many shared files your system permits to be open at any one time.
  • COBRT220 Attempt to execute more than one SORT or MERGE simultaneously (Fatal)
    You have coded your program in such a way that it is trying to execute more than one SORT or MERGE operation at the same time. For example, you might have coded a SORT statement in the input or output procedure of another SORT statement, an operation that is specifically prohibited under the rules of ANSI COBOL.
Parent topic: Run-time System Error Messages


COBRT201 I-O error in paging system (Fatal)

No room is available in your current directory or on the floppy disk which you are using, for the paging file.

Resolution:

When your program has terminated, delete any files which you no longer need from your directory to make room for the paging file, or insert a new floppy disk.

Parent topic: COBRT201 - COBRT220


COBRT203 CALL parameter not supplied (Fatal)

The item you are trying to access in the Linkage Section of the currently executing program has not been initialized.

Resolution:

Recode your program to ensure that it contains all of the necessary parameters, or check that it is a valid caller.

Parent topic: COBRT201 - COBRT220


COBRT205 Invalid mainframe pointer value (Fatal)

You are trying to reference an invalid mainframe address.

Resolution:

Check the logic of your program, and recode the appropriate statements.

Parent topic: COBRT201 - COBRT220


COBRT206 Reading unwritten data from memory (Fatal)

You are trying to read data which has not been written, from the core file.
Parent topic: COBRT201 - COBRT220


COBRT207 Machine does not exist (Recoverable)

You have tried to access a machine that is not connected to your network, or which is not on-line.

Resolution:

Make sure the machine is connected to the network and is on-line, then try to access it again.

Parent topic: COBRT201 - COBRT220


COBRT208 Error in multi-user system (Fatal)

This is normally caused by an unexpected error occurring in the network or file-sharing facilities. A corrupted network message also causes this error to be returned.

Resolution:

Retry the unsuccessful operation. If the error persists, contact Technical Support who will help you to discover the specific cause of this error.

Parent topic: COBRT201 - COBRT220


COBRT209 Network communication error (Recoverable)

This is normally given if an incorrect checksum has been received in a communications packet.

Resolution:

Your program should continue to execute after you have received this error but results might be undefined.

Parent topic: COBRT201 - COBRT220


COBRT210 File is closed with lock (Fatal)

You have tried to open a file which you have previously closed with lock.

Resolution:

Recode your program to avoid opening a file which has previously been closed with lock.

Parent topic: COBRT201 - COBRT220


COBRT211 Program not executable by Run-Time System (Fatal)

An attempt was made to run a program that is incompatible with the currently-specified run-time system. For example, system executable, shared library, and callable shared object files that have been linked using older COBOL systems could be incompatible.

On dual 32-bit/64-bit COBOL systems, all code must be compiled and linked using the same word length. A 64-bit run-time system does not run programs compiled and/or linked on 32-bit platforms or in 32-bit mode. Similarly, a 32-bit run-time system does not run programs compiled and/or linked on 64-bit platforms in 64-bit mode.

Resolution:

Recompile and/or relink your program so that it is compatible with the current run-time system.

Parent topic: COBRT201 - COBRT220


COBRT212 Run-Time System version incompatible with object-oriented program (Fatal)

You attempted to run an OO program that was compiled using a version of your COBOL system that is incompatible with the OO support provided in the run-time system you are using.

Resolution:

Recompile and/or relink your program so that it is compatible with the current run-time system.

Parent topic: COBRT201 - COBRT220


COBRT213 Too many locks (Recoverable)

You have either tried to exceed the maximum number of simultaneous record locks per file you can have, or you have exhausted an operating system or network resource; for example dynamic memory.

Resolution:

Execute a COMMIT or an UNLOCK operation on the relevant file and you should then be able to continue to run your program. You should try not to retain a record lock for longer than is necessary.

Parent topic: COBRT201 - COBRT220


COBRT214 GO TO has not been ALTERed (Fatal)

You have violated one of the general rules of COBOL programming.

Resolution:

Close any files which might be open, execute a STOP RUN statement and then edit your program to avoid such illegal operations.

Parent topic: COBRT201 - COBRT220


COBRT215 Cannot DEBUG a program running COMMUNICATIONS (Fatal)

You have tried to debug a program which makes use of the communications module. This cannot be done as both Debugger and the communications module need full use of the CRT.

Resolution:

You should run your program without the aid of Debugger.

Parent topic: COBRT201 - COBRT220


COBRT216 Cannot initialize the named communications device (Fatal)

A device driver is probably missing.

Resolution:

Ensure that all communications drivers are loaded before you try to run Communications.

Parent topic: COBRT201 - COBRT220


COBRT217 Incompatible host for native code file (Fatal)

The .gnt file is not valid for the host processor.

Resolution:

You must resubmit your program to your COBOL system.

Parent topic: COBRT201 - COBRT220


COBRT218 Malformed MULTIPLE REEL/UNIT file (Fatal)

Either your file header is not correctly formatted, or you are not using a MULTIPLE REEL/UNIT file.

Resolution:

You should try to run your program again using a backup copy of the relevant file.

Parent topic: COBRT201 - COBRT220


COBRT219 Operating system shared file limit exceeded (Recoverable)

You have tried to exceed your operating system's limit on the number of shared files that you can have open simultaneously. As this figure is operating system dependent, you should consult your Release Notes for details of how many shared files your system permits to be open at any one time.

Resolution:

Close some of the open shared files you are no longer accessing and retry the file operation.

Parent topic: COBRT201 - COBRT220


COBRT220 Attempt to execute more than one SORT or MERGE simultaneously (Fatal)

You have coded your program in such a way that it is trying to execute more than one SORT or MERGE operation at the same time. For example, you might have coded a SORT statement in the input or output procedure of another SORT statement, an operation that is specifically prohibited under the rules of ANSI COBOL.

Alternatively you are trying to sort or merge a file that is not open with the correct permissions.

Alternatively you have set the TMP environment variable to point to a directory that does not exist.

Alternatively you are trying to run a SORT with a SORTSPACE too small to do so.

Alternatively the SORTSPACE you have set is too small for the SORT you are performing.

Resolution:

Recode your program to ensure that it does not execute more than one SORT or MERGE at any one time.

Check that the files are open with the correct permissions.

Set $TMP to point to a directory that does exist or unset $TMP.

Set SORTSPACE to something more appropriate.

Either increase SORTSPACE or set SORTSCHEME=0 if it is set.

Parent topic: COBRT201 - COBRT220


COBRT221 - COBRT240

  • COBRT222 Merge files out of sequence (Fatal)
    An attempt to merge two files has been unsuccessful. One or more of your files might be out of sequence.
  • COBRT223 NLS language expansion error (Fatal)
    You have used the SORT verb, but the output buffer is not large enough.
  • COBRT224 External Language Initialization failure
  • COBRT225 Dynamic load error - program component missing (Fatal)
    The run-time system cannot locate the root or overlay of a program that is currently loaded in memory.
  • COBRT226 EXTERNAL file definition inconsistent
    Two or more programs define the same external file but with different formats. For example, maximum and minimum record lengths might be different.
  • COBRT227 EXTERNAL data definition inconsistent (Fatal)
    Two or more programs are defining the same external data item, but the first loaded program has defined the size differently from the second or subsequent loaded program.
  • COBRT228 Could not allocate memory for EXTERNAL item (Fatal)
  • COBRT229 SORT/MERGE module does not support EXTERNAL using/giving files (Recoverable)
    You have tried a SORT or MERGE operation which has USING/ GIVING files which are defined as EXTERNAL. The SORT/ MERGE module does not support USING/ GIVING files defined as EXTERNAL.
  • COBRT231 GENERATE encountered before corresponding INITIATE in report (Fatal)
    A GENERATE (Report Writer syntax) statement has been executed before a corresponding INITIATE statement.
  • COBRT232 Reference modification out of bounds
    An error has occurred because reference modification has referred to data beyond the boundaries of the base data item.
  • COBRT235 Error in debugger communications channel (Fatal)
    The Debugger has encountered system limits or conflicts resulting in communications errors. Perhaps two logins on the same UNIX system are trying to cross-session debug the same program file.
  • COBRT236 Debugged program has terminated unexpectedly (Fatal)
    A program you are debugging has terminated without following the standard run-time system shut-down process. The termination was probably either initiated by the user or caused by a severe run-time error.
  • COBRT237 Unable to initialize debugged process (Fatal)
    The Debugger has encountered system limits in starting your program. The debugged program cannot start because of either insufficient memoryor too many processes running on the UNIX system .
  • COBRT238 STOP RUN encountered during GNT animation (Informational)
    The Debugger has encountered a STOP RUN statement while debugging your .gnt code program.
  • COBRT239 Shared run-time system initialization failure (Informational)
    You are calling a COBOL module from a non-COBOL program, and have not initialized the shared run-time system.
  • COBRT240 Object reference not valid (Fatal)
    You have tried to use an object reference that contains an incorrect or non-existent object handle.
Parent topic: Run-time System Error Messages


COBRT222 Merge files out of sequence (Fatal)

An attempt to merge two files has been unsuccessful. One or more of your files might be out of sequence.

Resolution:

Make sure that the files you are trying to merge are in sequence.

Parent topic: COBRT221 - COBRT240


COBRT223 NLS language expansion error (Fatal)

You have used the SORT verb, but the output buffer is not large enough.

Resolution:

Use either the SORTNLSEXPAND or SORTNLSOVERHEAD environment variable to control the values used by SORT when calling CBL_NLS_TRANSFORM.

SORTNLSEXPAND calculates the output buffer given the input buffer.

The value of SORTNLSOVERHEAD is added to the length of the output buffer after using SORTNLSEXPAND.

The default values for both is 6.

Parent topic: COBRT221 - COBRT240


COBRT224 External Language Initialization failure

Parent topic: COBRT221 - COBRT240


COBRT225 Dynamic load error - program component missing (Fatal)

The run-time system cannot locate the root or overlay of a program that is currently loaded in memory.

Alternatively, you have insufficient memory to load your program.

Alternatively, the run-time system could not find enough file handles to open and, therefore, load the code.

Resolution:

Either the library that contained the program has been canceled, or the program is no longer available on the program search path. Ensure that the program is available either on disk or on an open library.

Either free some memory or restructure your application so that it uses less memory.

Increase your operating system file handles limit.

Parent topic: COBRT221 - COBRT240


COBRT226 EXTERNAL file definition inconsistent

Two or more programs define the same external file but with different formats. For example, maximum and minimum record lengths might be different.

Resolution

Make sure that all of your programs define the external file with the same format so that they are consistent. It is useful to have the file definition in a COPY file.

Parent topic: COBRT221 - COBRT240


COBRT227 EXTERNAL data definition inconsistent (Fatal)

Two or more programs are defining the same external data item, but the first loaded program has defined the size differently from the second or subsequent loaded program.

Resolution:

Make sure that both or all of your programs define the size of the external data item as being the same.

Parent topic: COBRT221 - COBRT240


COBRT228 Could not allocate memory for EXTERNAL item (Fatal)

Parent topic: COBRT221 - COBRT240


COBRT229 SORT/MERGE module does not support EXTERNAL using/giving files (Recoverable)

You have tried a SORT or MERGE operation which has USING/ GIVING files which are defined as EXTERNAL. The SORT/ MERGE module does not support USING/ GIVING files defined as EXTERNAL.

Resolution:

Recompile your program to use the callable SORT module (EXTSM).

Parent topic: COBRT221 - COBRT240


COBRT231 GENERATE encountered before corresponding INITIATE in report (Fatal)

A GENERATE (Report Writer syntax) statement has been executed before a corresponding INITIATE statement.

Resolution:

Correct by revising your program execution flow.

Parent topic: COBRT221 - COBRT240


COBRT232 Reference modification out of bounds

An error has occurred because reference modification has referred to data beyond the boundaries of the base data item.
Note: This error is only reported if you are using the Compiler directive setting SSRANGE"2".

Resolution:

Check your code for data items being manipulated with reference modification and ensure that the reference modification parameters are set correctly.

Parent topic: COBRT221 - COBRT240


COBRT235 Error in debugger communications channel (Fatal)

The Debugger has encountered system limits or conflicts resulting in communications errors. Perhaps two logins on the same UNIX system are trying to cross-session debug the same program file.

Resolution:

Copy the debugged program file to a different directory and try debugging.

Parent topic: COBRT221 - COBRT240


COBRT236 Debugged program has terminated unexpectedly (Fatal)

A program you are debugging has terminated without following the standard run-time system shut-down process. The termination was probably either initiated by the user or caused by a severe run-time error.

Resolution:

Run your program without debugging to determine if it runs successfully; if so, debug the program without cross-session or intrasession debugging.

Parent topic: COBRT221 - COBRT240


COBRT237 Unable to initialize debugged process (Fatal)

The Debugger has encountered system limits in starting your program. The debugged program cannot start because of either insufficient memoryor too many processes running on the UNIX system .

Resolution:

Debug your program when the load on the system has reduced. Run the program without debugging to determine if it runs successfully; if so, debug the program without cross-session or intrasession debugging. Ask your system administrator to expand the number of process slots and virtual memory page maps.

Parent topic: COBRT221 - COBRT240


COBRT238 STOP RUN encountered during GNT animation (Informational)

The Debugger has encountered a STOP RUN statement while debugging your .gnt code program.

Resolution:

Step or Zoom the debugged program, and the Debugger will terminate the program and its current session.

Parent topic: COBRT221 - COBRT240


COBRT239 Shared run-time system initialization failure (Informational)

You are calling a COBOL module from a non-COBOL program, and have not initialized the shared run-time system.

Resolution:

Ensure that your application calls the cobinit() function before executing any COBOL modules. See your COBOL System Reference for UNIX for more information about the cobinit() function.

Parent topic: COBRT221 - COBRT240


COBRT240 Object reference not valid (Fatal)

You have tried to use an object reference that contains an incorrect or non-existent object handle.

Resolution:

Ensure that the object reference uses the correct object handle, and that your program has not previously destroyed the object by sending it a Finalize message.

Parent topic: COBRT221 - COBRT240


COBRT241 - COBRT260

  • COBRT221 Internal sort error (Fatal)
  • COBRT241 Cannot instantiate an abstract class (Fatal)
    You have tried to create an instance of a class that has been declared ABSTRACT. Such classes cannot be instantiated.
  • COBRT242 Could not resolve DoesNotUnderstand message (Fatal)
    The run-time system could not resolve the DoesNotUnderstand message. This is usually because you have defined a class in such a way that this method cannot be found.
  • COBRT243 Class could not be loaded (Fatal)
    An attempt to load an object class has failed because the class does not contain a valid Class-Control section, or because the class is not defined correctly.
  • COBRT244 Licensing initialization error (Fatal)
    An error occurred initializing the run-time license.
  • COBRT245 There are no valid product licenses (Fatal)
    There are no run-time licenses installed on either the local machine or license server, or all the licenses have expired.
  • COBRT246 Maximum number of product licenses exceeded (Fatal)
    All the run-time licenses installed on either the local machine or on the license server are in use.
  • COBRT247 Licensing error (Fatal)
    A error occurred whilst trying to get a run-time license.
  • COBRT249 Process killed (signal-number) (Fatal)
    The run-time system has passed a a SIGTERM signal to a service execution process (SEP) running on an enterprise server (SIGHUP and SIGINT as well on UNIX). This may occur for one of the following reasons:
  • COBRT250 Not enough mainframe address space to load or run the program (Fatal)
    This program has been compiled with one of the compiler directives AMODE(24) or AMODE(31), which request the program's data division be registered with the Mainframe Pointer Manager. However, there is not enough free mainframe address space to allow this. For example, if you have compiled with the AMODE(24) compiler directive, the total address space required for your program's data division should not exceed 16 megabytes.
  • COBRT251 Attempt to load AMODE(24) program when current setting is AMODE(31) only (Fatal)
    The settings for the current project indicate that only AMODE(31) programs can be invoked, but an attempt was made to invoke an AMODE(24) program.
  • COBRT252 Memory corruption detected (Fatal)
    The run-time system has detected a memory corruption in a block of memory that it had previously allocated.
  • COBRT253 Cannot load file - unsupported format (Fatal)
    The file specified is not recognized as a format that the run-time system can load and execute.
  • COBRT254 Keyboard interrupt to ANIMATOR during ACCEPT (Fatal)
    While using Animator you have terminated your program with a keyboard interrupt.
Parent topic: Run-time System Error Messages


COBRT221 Internal sort error (Fatal)

Resolution:

Contact Technical Support who will help you to discover the cause of the error and how it can be rectified.

Parent topic: COBRT241 - COBRT260


COBRT241 Cannot instantiate an abstract class (Fatal)

You have tried to create an instance of a class that has been declared ABSTRACT. Such classes cannot be instantiated.

Resolution:

Ensure that you have specified the correct class name. Check to see if there is a subclass that you should use instead.

Parent topic: COBRT241 - COBRT260


COBRT242 Could not resolve DoesNotUnderstand message (Fatal)

The run-time system could not resolve the DoesNotUnderstand message. This is usually because you have defined a class in such a way that this method cannot be found.

Resolution:

Check the logic in your program to ensure that it invokes only methods that are supported by the object, or ensure that the object supports the DoesNotUnderstand method.

Parent topic: COBRT241 - COBRT260


COBRT243 Class could not be loaded (Fatal)

An attempt to load an object class has failed because the class does not contain a valid Class-Control section, or because the class is not defined correctly.

Resolution:

Check the definition of the class.

Parent topic: COBRT241 - COBRT260


COBRT244 Licensing initialization error (Fatal)

An error occurred initializing the run-time license.

Additional information regarding this error is available in a CTF trace.

Resolution

Ensure that the license server installer is run on the local machine.

Parent topic: COBRT241 - COBRT260


COBRT245 There are no valid product licenses (Fatal)

There are no run-time licenses installed on either the local machine or license server, or all the licenses have expired.

Resolution

Run the License System Administration tool CESAdminTool and install run-time licenses.

Parent topic: COBRT241 - COBRT260


COBRT246 Maximum number of product licenses exceeded (Fatal)

All the run-time licenses installed on either the local machine or on the license server are in use.

Resolution

Run the License System Administration tool CESAdminTool and install additional run-time licenses.

Parent topic: COBRT241 - COBRT260


COBRT247 Licensing error (Fatal)

A error occurred whilst trying to get a run-time license.

Additional information is displayed after the error message and/or in a CTF trace.

Resolution

Either run the CESAdminTool on the local machine or resolve any issues on the license server or with the network.

Parent topic: COBRT241 - COBRT260


COBRT249 Process killed (signal-number) (Fatal)

The run-time system has passed a a SIGTERM signal to a service execution process (SEP) running on an enterprise server (SIGHUP and SIGINT as well on UNIX). This may occur for one of the following reasons:
  • Implicitly as part of MSS's runaway task processing when the server manager notices that a CICS transaction appears to be looping.
  • Explicitly on UNIX if you execute a kill -s TERM pid command (where pid is the process ID of the SEP). You might do this if you see a SEP consuming a lot of CPU.

Resolution:

Investigate the reason for the service or CICS transaction looping, for example, by analysing enterprise server dumps or traces, or by animating the service or transaction.

Parent topic: COBRT241 - COBRT260


COBRT250 Not enough mainframe address space to load or run the program (Fatal)

This program has been compiled with one of the compiler directives AMODE(24) or AMODE(31), which request the program's data division be registered with the Mainframe Pointer Manager. However, there is not enough free mainframe address space to allow this. For example, if you have compiled with the AMODE(24) compiler directive, the total address space required for your program's data division should not exceed 16 megabytes.

Resolution:

Reduce the amount of mainframe address space required by cancelling any other AMODE programs that are not currently in use.

Parent topic: COBRT241 - COBRT260


COBRT251 Attempt to load AMODE(24) program when current setting is AMODE(31) only (Fatal)

The settings for the current project indicate that only AMODE(31) programs can be invoked, but an attempt was made to invoke an AMODE(24) program.

Resolution:

Either change the current project settings to allow for the invocation of AMODE(24) programs, or recompile the program that was causing the error as AMODE(31).

Parent topic: COBRT241 - COBRT260


COBRT252 Memory corruption detected (Fatal)

The run-time system has detected a memory corruption in a block of memory that it had previously allocated.

Resolution:

You need to isolate the actual point in execution where the memory corruption occurs the investigate the cause. To do this you could:

  • Run with a memory strategy that indicates that memory is to be validated each time an allocation or free operation occurs (will have a major effect on performance)
  • Add calls to CBL_MEM_VALIDATE() at appropriate points in the application
Parent topic: COBRT241 - COBRT260


COBRT253 Cannot load file - unsupported format (Fatal)

The file specified is not recognized as a format that the run-time system can load and execute.
Parent topic: COBRT241 - COBRT260


COBRT254 Keyboard interrupt to ANIMATOR during ACCEPT (Fatal)

While using Animator you have terminated your program with a keyboard interrupt.
Parent topic: COBRT241 - COBRT260


COBOL Preprocessor Error Messages

Note:

The COBOL Preprocessor is supported for native COBOL only.

Click on a number below for a description of the error message and with causes of the error and action you can take.

  • COBCP001 Undefined internal error - contact Technical Support
    An internal processing error occurred.
  • COBCP101 Illegal command line
    One or more directive was rejected.
  • COBCP103 Open fail: filename
    CP was unable to find the source file.
  • COBCP104 Open fail: filename
    CP was unable to create a trace file.
  • COBCP105 Call to stacked preprocessor name failed
    The preprocessor specified using the CP directive PREPROCESS could not be found.
  • COBCP106 Stacked preprocessor returned an error
    The stacked preprocessor failed to initialise correctly
  • COBCP107 Unable to open a heap
    An internal error prevented a heap from being opened.
  • COBCP200 Internal stack full - contact your support representative
    An internal processing error occurred.
  • COBCP201 File error - contact Technical Support
    An internal processing error occurred.
  • COBCP202 Copybook filename not found
    A COPY statement referenced a file that could not be located.
  • COBCP203 Nested REPLACING is not allowed
    A COPY REPLACING statement was found while another was still being processed.
  • COBCP204 Statement begins in wrong area of source
    The statement starts either in area A when it should have started in area B, or in area B when it should have started in area A.
  • COBCP205 HTML splitter error err-code
    An internal processing error occurred on an EXEC HTML statement.
  • COBCP206 Bad format of COPY statement - COPY ignored
    A COPY statement was incorrectly constructed, for example, not followed by a period.
Parent topic: Error Messages
Parent topic: Integrated Preprocessor Interface


COBCP001 Undefined internal error - contact Technical Support

An internal processing error occurred.
Note:

The Integrated Preprocessor is supported for native COBOL only.

Resolution:

Inform Technical Support.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP101 Illegal command line

One or more directive was rejected.

Resolution:

If explicitly invoking CP, correct the command line and resubmit. If CP is invoked by another preprocessor, inform the appropriate vendor.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP103 Open fail: filename

CP was unable to find the source file.

Resolution:

Correct the filename and resubmit the command.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP104 Open fail: filename

CP was unable to create a trace file.

Resolution:

Ensure that the file is not already in use; there is sufficient disk space, the drive is not write protected.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP105 Call to stacked preprocessor name failed

The preprocessor specified using the CP directive PREPROCESS could not be found.

Resolution:

Ensure that the preprocessor exists and can be invoked. If the name is incorrect then either correct the command line if CP was explicitly invoked or see the appropriate product documentation if CP was invoked by another preprocessor.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP106 Stacked preprocessor returned an error

The stacked preprocessor failed to initialise correctly

Resolution:

For CP, none. Fix the error reported by the stacked preprocessor.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP107 Unable to open a heap

An internal error prevented a heap from being opened.

Resolution:

Inform Technical Support.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP200 Internal stack full - contact your support representative

An internal processing error occurred.

Resolution:

Inform Technical Support.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP201 File error - contact Technical Support

An internal processing error occurred.

Resolution:

Inform technical support.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP202 Copybook filename not found

A COPY statement referenced a file that could not be located.
Note:

The Integrated Preprocessor is supported for native COBOL only.

Resolution:

Correct the program source and resubmit.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP203 Nested REPLACING is not allowed

A COPY REPLACING statement was found while another was still being processed.
Note:

The Integrated Preprocessor is supported for native COBOL only.

Resolution:

Correct the program source and resubmit.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP204 Statement begins in wrong area of source

The statement starts either in area A when it should have started in area B, or in area B when it should have started in area A.
Note:

The Integrated Preprocessor is supported for native COBOL only.

Resolution:

Recode the statement to be in the correct area of source.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP205 HTML splitter error err-code

An internal processing error occurred on an EXEC HTML statement.

Resolution:

Inform Technical Support, specifying err-code.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


COBCP206 Bad format of COPY statement - COPY ignored

A COPY statement was incorrectly constructed, for example, not followed by a period.

Resolution:

Correct the program source and resubmit.

Parent topic: COBOL Preprocessor Error Messages
Parent topic: COBOL Preprocessor Error Messages


Data File Converter Error Messages

For numbers above 500, subtract 500 and then look for that number in the Run-time System Error Messages topic.

  • DFC1 - DFC11
    Lists the Data File Converter error messages from DFC1 through DFC11.
  • DFC100 - DFC139
    Lists the Data File Converter error messages from DFC100 through DFC139.
  • DFC143 - DFC169
    Lists the Data File Converter error messages from DFC143 through DFC169.
  • DFC173 - DFC188
    Lists the Data File Converter error messages from DFC173 through DFC188.
  • DFC190 - DFC196
    Lists the Data File Converter error messages from DFC190 through DFC196.
  • DFC451 - DFC469
    Lists the Data File Converter error messages from DFC451 through DFC469.
  • DFC470 - DFC491
    Lists the Data File Converter error messages from DFC470 through DFC491.
Parent topic: Error Messages


DFC1 - DFC11

  • DFC1 Error reading structure
    CONV was unable to correctly read the structure file.
  • DFC2 Error selecting structure
    CONV was unable to correctly select a structure for the current record.
  • DFC5 Error writing structure
    An error occurred when writing the adjusted structure for the current record.
  • DFC7 Error – no structure found on heap
    The structure file specified in the conversion details is empty.
  • DFC10 Error -- not enough memory
    Not enough free memory was available to continue the conversion.
  • DFC11 Error checking conditions
    An error occurred when testing the conditions on the current record.
Parent topic: Data File Converter Error Messages


DFC1 Error reading structure

CONV was unable to correctly read the structure file.

Resolution:

Ensure that the structure file is valid or that enough free memory is available.

Parent topic: DFC1 - DFC11


DFC2 Error selecting structure

CONV was unable to correctly select a structure for the current record.

Resolution:

Ensure that you correctly defined the structure file and that it contains a default structure.

Parent topic: DFC1 - DFC11


DFC5 Error writing structure

An error occurred when writing the adjusted structure for the current record.

Resolution:

Ensure that the data is not corrupted and that the structure file specified in the conversion details is correct.

Parent topic: DFC1 - DFC11


DFC7 Error – no structure found on heap

The structure file specified in the conversion details is empty.

Resolution:

Redefine a structure file and restart the conversion.

Parent topic: DFC1 - DFC11


DFC10 Error -- not enough memory

Not enough free memory was available to continue the conversion.

Resolution:

Either copy the necessary conversion files to another partition and restart the conversion ensuring that the path information has been updated, or free some space in the current directory.

Parent topic: DFC1 - DFC11


DFC11 Error checking conditions

An error occurred when testing the conditions on the current record.

Resolution:

Redefine a structure file, ensuring that the conditions are valid.

Parent topic: DFC1 - DFC11


DFC100 - DFC139

  • DFC100 Dialog System internal error
    An error occurred when reading or writing to the screen.
  • DFC101 Error reading structure file
  • DFC102 Error selecting correct structure
  • DFC105 Error resolving OCCURS DEPENDING ON in structure file
  • DFC107 Error – no structures found in structure file
  • DFC111 Input file error during rebuild
    An incompatibility was found when trying to rebuild the index of a file.
  • DFC119 Parameter specification error during rebuild
    Rebuilding could not proceed because of wrong parameters.
  • DFC128 No record layout matches record
  • DFC130 Invalid key in input file
    The key information specified for the input file is incompatible with the keys in the file.
  • DFC131 Error opening input file
    CONV was unable to successfully open the input file.
  • DFC132 Error reading input file
    CONV was unable to read the current record of the input file.
  • DFC133 Error opening output file
    CONV was unable to successfully open the output file.
  • DFC134 Error writing output file
    CONV was unable to successfully write the current record to the output file.
  • DFC136 Insufficient memory for loading data
    Not enough free memory was available to continue the conversion.
  • DFC137 Current record length > maximum
    The current record read from the input file has a length greater than the maximum record length specified for that file.
  • DFC138 Warning – Duplicate key, record overwritten
    A record with a duplicate key was found and the corresponding output was overwritten. Note that some data information has been lost.
  • DFC139 Input file not 'real' mainframe report format
    The file specified as the input file contains ANSI carriage control characters and was therefore not generated on the mainframe. Alternatively, you did not supply the correct parameters when you converted the file.
Parent topic: Data File Converter Error Messages


DFC100 Dialog System internal error

An error occurred when reading or writing to the screen.

Resolution:

Contact Technical Support.

Parent topic: DFC100 - DFC139


DFC101 Error reading structure file

Parent topic: DFC100 - DFC139


DFC102 Error selecting correct structure

Parent topic: DFC100 - DFC139


DFC105 Error resolving OCCURS DEPENDING ON in structure file

Parent topic: DFC100 - DFC139


DFC107 Error – no structures found in structure file

Parent topic: DFC100 - DFC139


DFC111 Input file error during rebuild

An incompatibility was found when trying to rebuild the index of a file.

Resolution:

Ensure that the file details specified, in particular the key information, are correct.

Parent topic: DFC100 - DFC139


DFC119 Parameter specification error during rebuild

Rebuilding could not proceed because of wrong parameters.

Resolution:

Ensure that the parameters specified and the file name are correct.

Parent topic: DFC100 - DFC139


DFC128 No record layout matches record

Resolution:

Ensure the record layout file contains a record description for all record types within the input file. A default record layout can be used if this provides an appropriate record description.

Parent topic: DFC100 - DFC139


DFC130 Invalid key in input file

The key information specified for the input file is incompatible with the keys in the file.

Resolution:

Ensure that the key information read from the file header corresponds to that specified in the conversion details or that the file has not been corrupted.

Parent topic: DFC100 - DFC139


DFC131 Error opening input file

CONV was unable to successfully open the input file.

Resolution:

Ensure that the file details given for the input file are correct.

Parent topic: DFC100 - DFC139


DFC132 Error reading input file

CONV was unable to read the current record of the input file.

Resolution:

Ensure that the file details given, in particular the record length information, are correct.

Parent topic: DFC100 - DFC139


DFC133 Error opening output file

CONV was unable to successfully open the output file.

Resolution:

Ensure that the file details given for the output file are correct and that a file with the same name is not used by another process.

Parent topic: DFC100 - DFC139


DFC134 Error writing output file

CONV was unable to successfully write the current record to the output file.

Resolution:

Ensure that the output file details are correct and that, in particular, the current record in the input file is shorter than the maximum record length of the output file.

Parent topic: DFC100 - DFC139


DFC136 Insufficient memory for loading data

Not enough free memory was available to continue the conversion.

Resolution:

Either copy the necessary conversion files to another partition and restart the conversion ensuring that the path information has been updated, or free some space in the current directory.

Parent topic: DFC100 - DFC139


DFC137 Current record length > maximum

The current record read from the input file has a length greater than the maximum record length specified for that file.

Resolution:

Either check that the file has not been corrupted or reset the maximum record length to the correct value. Remember to also adjust the maximum record length of the output file.

Parent topic: DFC100 - DFC139


DFC138 Warning – Duplicate key, record overwritten

A record with a duplicate key was found and the corresponding output was overwritten. Note that some data information has been lost.
Parent topic: DFC100 - DFC139


DFC139 Input file not 'real' mainframe report format

The file specified as the input file contains ANSI carriage control characters and was therefore not generated on the mainframe. Alternatively, you did not supply the correct parameters when you converted the file.

Resolution:

Either specify it as an EBCDIC line sequential file if that is correct, or use MFEXTMAP"PRINTER".

Reconvert the file, ensuring that you specify Mainframe Report Format in the Organization field, and EBCDIC in the Data Format field of the Convert - Input screen. In the Convert - Output screen, the Format field is automatically set to PC Print Format when you select Mainframe Report Format in the Convert - Input screen.

Parent topic: DFC100 - DFC139


DFC143 - DFC169

  • DFC143 Occurs Depending On value outside range
    During the conversion of a structure containing an OCCURS DEPENDING ON (ODO), the value of the ODO variable in the current record was outside the specified minimum and maximum values in the structure.
  • DFC150 Input record length cannot be zero or > 64K
    The input file maximum record length specified was either 0 or greater than 64K.
  • DFC151 Output record length cannot be zero or > 64K
    The output file maximum record length specified was either 0 or greater than 64K.
  • DFC152 Maximum record length cannot be < minimum length in input file
    The maximum record length specified was less than the minimum in the input file.
  • DFC153 Minimum record length must be > zero in input file
    An attempt was made to set the input file minimum record length to a negative value.
  • DFC154 Maximum record length must be > zero in input file
    An attempt was made to set the input file maximum record length to a negative value.
  • DFC159 Profile file not found
    An attempt was made to load a non-existent profile file.
  • DFC160 Error opening profile file
    CONV was unable to open the profile file specified.
  • DFC161 Invalid profile file format
    CONV was unable to read the profile file.
  • DFC162 Error on output file during conversion
    A file error was encountered when writing to the output file during conversion.
  • DFC163 Error on input file during conversion
    A file error was encountered when reading from the input file during conversion.
  • DFC168 No input file-name specified
    No input file name was specified.
  • DFC169 No output file-name specified
Parent topic: Data File Converter Error Messages


DFC143 Occurs Depending On value outside range

During the conversion of a structure containing an OCCURS DEPENDING ON (ODO), the value of the ODO variable in the current record was outside the specified minimum and maximum values in the structure.

Resolution:

Ensure that the data has been generated with the data structure used to create the .str file or check that the data has not been corrupted.

Parent topic: DFC143 - DFC169


DFC150 Input record length cannot be zero or > 64K

The input file maximum record length specified was either 0 or greater than 64K.

Resolution:

Set it to a valid non-zero value.

Parent topic: DFC143 - DFC169


DFC151 Output record length cannot be zero or > 64K

The output file maximum record length specified was either 0 or greater than 64K.

Resolution:

Set it to a valid non-zero value.

Parent topic: DFC143 - DFC169


DFC152 Maximum record length cannot be < minimum length in input file

The maximum record length specified was less than the minimum in the input file.

Resolution:

Reset the record length value(s) that are in error.

Parent topic: DFC143 - DFC169


DFC153 Minimum record length must be > zero in input file

An attempt was made to set the input file minimum record length to a negative value.

Resolution:

Set the input file minimum record length to a positive value.

Parent topic: DFC143 - DFC169


DFC154 Maximum record length must be > zero in input file

An attempt was made to set the input file maximum record length to a negative value.

Resolution:

Set the input file maximum record length to a positive value.

Parent topic: DFC143 - DFC169


DFC159 Profile file not found

An attempt was made to load a non-existent profile file.

Resolution:

Ensure that the correct location and name were given.

Parent topic: DFC143 - DFC169


DFC160 Error opening profile file

CONV was unable to open the profile file specified.

Resolution:

Ensure that the file is not being used by another process or has not been corrupted.

Parent topic: DFC143 - DFC169


DFC161 Invalid profile file format

CONV was unable to read the profile file.

Resolution:

Ensure that the file was correctly generated by CONV or WFL, and if necessary regenerate it.

Parent topic: DFC143 - DFC169


DFC162 Error on output file during conversion

A file error was encountered when writing to the output file during conversion.

Resolution:

Check the file details and the amount of memory available.

Parent topic: DFC143 - DFC169


DFC163 Error on input file during conversion

A file error was encountered when reading from the input file during conversion.

Resolution:

Check the file details and the amount of memory available.

Parent topic: DFC143 - DFC169


DFC168 No input file-name specified

No input file name was specified.

Resolution:

Ensure that a file name is passed either in the profile file or as a separate parameter.

Parent topic: DFC143 - DFC169


DFC169 No output file-name specified

Resolution:

Ensure that a file name is passed either in the profile file or as a separate parameter.

Parent topic: DFC143 - DFC169


DFC173 - DFC188

  • DFC173 Input file not found
  • DFC174 Structure file not found
  • DFC176 Invalid batch process type
  • DFC178 Maximum input record length allowed 133
  • DFC179 Must specify structure file
  • DFC180 Maximum input record length allowed 133
  • DFC182 Maximum record length cannot be < minimum length in output file
  • DFC183 Minimum record length must be > zero in output file
  • DFC184 Maximum record length must be > zero in output file
  • DFC185 Output file key must lie within record boundaries
  • DFC187 Output file key length cannot be zero or exceed 64K
  • DFC188 Output file key length cannot exceed record length
Parent topic: Data File Converter Error Messages


DFC173 Input file not found

Resolution:

Ensure that the location and name specified are correct or that the file is where you think it is.

Parent topic: DFC173 - DFC188


DFC174 Structure file not found

Resolution:

Ensure that a structure file has been generated, and that its location and name are correct.

Parent topic: DFC173 - DFC188


DFC176 Invalid batch process type

Parent topic: DFC173 - DFC188


DFC178 Maximum input record length allowed 133

Resolution:

Respecify a record length of 133 or less.

Parent topic: DFC173 - DFC188


DFC179 Must specify structure file

Resolution:

Call Structure Selector to define a structure file, load it into the conversion details, and restart the conversion.

Parent topic: DFC173 - DFC188


DFC180 Maximum input record length allowed 133

Resolution:

Respecify a record length of 133 or less.

Parent topic: DFC173 - DFC188


DFC182 Maximum record length cannot be < minimum length in output file

Resolution:

Reset the record length value(s) that are in error.

Parent topic: DFC173 - DFC188


DFC183 Minimum record length must be > zero in output file

Resolution:

Set the minimum record length to a positive value.

Parent topic: DFC173 - DFC188


DFC184 Maximum record length must be > zero in output file

Resolution:

Set the maximum record length to a positive value

Parent topic: DFC173 - DFC188


DFC185 Output file key must lie within record boundaries

Resolution:

Reset the key information or increase the minimum record length of the file.

Parent topic: DFC173 - DFC188


DFC187 Output file key length cannot be zero or exceed 64K

Resolution:

Set the key length to a valid non-zero value.

Parent topic: DFC173 - DFC188


DFC188 Output file key length cannot exceed record length

Resolution:

Reset the key information or increase the minimum record length of the file.

Parent topic: DFC173 - DFC188


DFC190 - DFC196

  • DFC190 Maximum output record length allowed 133
  • DFC191 Maximum output record length allowed 133
  • DFC194 BTRIEVE not found or accessible
  • DFC195 Rebuild only applies to ISAM files
  • DFC196 Output file-name cannot be same as input file-name
Parent topic: Data File Converter Error Messages


DFC190 Maximum output record length allowed 133

Resolution:

Respecify a record length of 133 or less.

Parent topic: DFC190 - DFC196


DFC191 Maximum output record length allowed 133

Resolution:

Respecify a record length of 133 or less.

Parent topic: DFC190 - DFC196


DFC194 BTRIEVE not found or accessible

Resolution:

Ensure that Btrieve is loaded and restart the conversion.

Parent topic: DFC190 - DFC196


DFC195 Rebuild only applies to ISAM files

Resolution:

Ensure that the file you are loading is the correct one.

Parent topic: DFC190 - DFC196


DFC196 Output file-name cannot be same as input file-name

Resolution:

Use a different output file-name.

Parent topic: DFC190 - DFC196


DFC451 - DFC469

  • DFC451 Profile file not found
  • DFC452 Invalid option for Batch process
  • DFC453 Invalid option for Edit mode
  • DFC454 Invalid profile details
  • DFC455 Cannot create profile file
  • DFC462 Invalid option for Input file - Format
  • DFC463 Invalid option for Input file - Organization
  • DFC464 Invalid option for Input file -- Record format
    The option defined for the input file Record-Format parameter is invalid
  • DFC465 Invalid option for Input file -- Character set
    The option defined for the input file Character-Set parameter is invalid
  • DFC466 Invalid option for Input file -- Floating point
    The option defined for the input file Floating-Point parameter is invalid.
  • DFC467 Invalid option for Input file – Minimum record length
  • DFC468 Invalid option for Input file – Maximum record length
  • DFC469 Invalid option for Input file -- Compression flag
    The option defined for the input file Data Compression parameter is invalid.
Parent topic: Data File Converter Error Messages


DFC451 Profile file not found

Resolution:

Correct the path or filename of the profile file.

Parent topic: DFC451 - DFC469


DFC452 Invalid option for Batch process

Resolution:

Correct the profile using one of the following options:

  • Convert-file
  • Rebuild-index
  • Rebuild-index-and-data
  • None
Parent topic: DFC451 - DFC469


DFC453 Invalid option for Edit mode

Resolution:

Correct the profile using one of the following options:

  • Quick
  • Full
Parent topic: DFC451 - DFC469


DFC454 Invalid profile details

Resolution:

Workbench File Loader profiles are fixed format, and as the profile has been edited, you need to verify details against a profile created by Workbench File Loader and correct the error. Alternatively, use File Converter to create a new profile with the required details.

Parent topic: DFC451 - DFC469


DFC455 Cannot create profile file

Resolution:

Ensure you have the correct file access permissions. If the file exists, check that it is not being used by any other process or user.

Parent topic: DFC451 - DFC469


DFC462 Invalid option for Input file - Format

Resolution:

Correct the profile using one of the following options:

  • Micro Focus
  • IDXFORMAT(4)
  • Btrieve
  • C-ISAM
  • LEVEL-II
Parent topic: DFC451 - DFC469


DFC463 Invalid option for Input file - Organization

Resolution:

Correct the profile using one of the following options:

  • Sequential
  • Line-sequential
  • Indexed
  • Mainframe-Report-ANSI
  • Relative
  • Mainframe-Report-mach
  • VRECGEN
  • PC-Print
Parent topic: DFC451 - DFC469


DFC464 Invalid option for Input file -- Record format

The option defined for the input file Record-Format parameter is invalid

Resolution:

Correct the profile using one of the following options:

  • Fixed
  • Variable
Parent topic: DFC451 - DFC469


DFC465 Invalid option for Input file -- Character set

The option defined for the input file Character-Set parameter is invalid

Resolution:

Correct the profile using one of the following options:

  • ASCII
  • EBCDIC
Parent topic: DFC451 - DFC469


DFC466 Invalid option for Input file -- Floating point

The option defined for the input file Floating-Point parameter is invalid.

Resolution:

Correct the profile using one of the following options:

  • IEEE
  • 370
Parent topic: DFC451 - DFC469


DFC467 Invalid option for Input file – Minimum record length

Resolution:

Correct the profile, ensuring that the minimum length is defined.

Parent topic: DFC451 - DFC469


DFC468 Invalid option for Input file – Maximum record length

Resolution:

Correct the profile, ensuring that the maximum length is defined.

Parent topic: DFC451 - DFC469


DFC469 Invalid option for Input file -- Compression flag

The option defined for the input file Data Compression parameter is invalid.

Resolution:

Correct the profile using one of the following options:

  • On
  • Off
Parent topic: DFC451 - DFC469


DFC470 - DFC491

  • DFC470 Invalid option for Input file -- Key field list
    The Prime-key or Alt-key key definition parameter format is invalid.
  • DFC471 Invalid option for Input file -- Key flag list
    The Prime-key or Alt-key key flags list contains invalid options.
  • DFC482 Invalid option for Output file - Format
  • DFC483 Invalid option for Output file - Organization
  • DFC484 Invalid option for Output file -- Record format
    The option defined for the output file Record-Format parameter is invalid
  • DFC485 Invalid option for Output file -- Character set
    The option defined for the output file Character-Set parameter is invalid
  • DFC486 Invalid option for Output file -- Floating point
    The option defined for the output file Floating-Point parameter is invalid.
  • DFC487 Invalid option for Output file -- Minimum record length
    The value defined for the output file Min-Rec-Length parameter is invalid or missing.
  • DFC488 Invalid option for Output file – Maximum record length
  • DFC489 Invalid option for Output file -- Compression flag
    The option defined for the output file Data Compression parameter is invalid.
  • DFC490 Invalid option for Output file -- Key field list
    The Prime-key or Alt-key key definition parameter format is invalid.
  • DFC491 Invalid option for Output file -- Key flag list
    The Prime-key or Alt-key key flags list contains invalid options.
Parent topic: Data File Converter Error Messages


DFC470 Invalid option for Input file -- Key field list

The Prime-key or Alt-key key definition parameter format is invalid.

Resolution:

Correct the profile, ensuring that the key definition parameters use the following format:

Prime-key | 1:5
Alt-key 1 | 10:5
Alt-key 2 | 30:10, 50:10, 70:10
Parent topic: DFC470 - DFC491


DFC471 Invalid option for Input file -- Key flag list

The Prime-key or Alt-key key flags list contains invalid options.

Resolution:

Correct the profile, ensuring the key flag list parameters are from the following list:

d | Allow duplicates
s | Sparse character set
cd | Compression on duplicates
cl | Compression on leading spaces
ct | Compression on trailing spaces

and use the following format:

Prime-key | 1:5
Alt-key 1 | 10:5
 | d, ct
Alt-key 2 | 30:10, 50:10, 70:10
 | s, cl
Parent topic: DFC470 - DFC491


DFC482 Invalid option for Output file - Format

Resolution:

Correct the profile using one of the following options:

  • Micro Focus
  • IDXFORMAT(4)
  • Btrieve
  • C-ISAM
  • LEVEL-II
Parent topic: DFC470 - DFC491


DFC483 Invalid option for Output file - Organization

Resolution:

Correct the profile using one of the following options:

  • Sequential
  • Line-sequential
  • Indexed
  • Mainframe-Report-ANSI
  • Relative
  • Mainframe-Report-mach
  • VRECGEN
  • PC-Print
Parent topic: DFC470 - DFC491


DFC484 Invalid option for Output file -- Record format

The option defined for the output file Record-Format parameter is invalid

Resolution:

Correct the profile using one of the following options:

  • Fixed
  • Variable
Parent topic: DFC470 - DFC491


DFC485 Invalid option for Output file -- Character set

The option defined for the output file Character-Set parameter is invalid

Resolution:

Correct the profile using one of the following options:

  • ASCII
  • EBCDIC
Parent topic: DFC470 - DFC491


DFC486 Invalid option for Output file -- Floating point

The option defined for the output file Floating-Point parameter is invalid.

Resolution:

Correct the profile using one of the following options:

  • IEEE
  • 370
Parent topic: DFC470 - DFC491


DFC487 Invalid option for Output file -- Minimum record length

The value defined for the output file Min-Rec-Length parameter is invalid or missing.

Resolution:

Correct the profile, ensuring that the minimum length is defined.

Parent topic: DFC470 - DFC491


DFC488 Invalid option for Output file – Maximum record length

Resolution:

Correct the profile, ensuring that the maximum length is defined.

Parent topic: DFC470 - DFC491


DFC489 Invalid option for Output file -- Compression flag

The option defined for the output file Data Compression parameter is invalid.

Resolution:

Correct the profile using one of the following options:

  • On
  • Off
Parent topic: DFC470 - DFC491


DFC490 Invalid option for Output file -- Key field list

The Prime-key or Alt-key key definition parameter format is invalid.

Resolution:

Correct the profile, ensuring that the key definition parameters use the following format:

Prime-key | 1:5
Alt-key 1 | 10:5
Alt-key 2 | 30:10, 50:10, 70:10
Parent topic: DFC470 - DFC491


DFC491 Invalid option for Output file -- Key flag list

The Prime-key or Alt-key key flags list contains invalid options.

Resolution:

Correct the profile, ensuring the key flag list parameters are from the following list:

d | Allow duplicates
s | Sparse character set
cd | Compression on duplicates
cl | Compression on leading spaces
ct | Compression on trailing spaces

and use the following format:

Prime-key | 1:5
Alt-key 1 | 10:5
 | d, ct
Alt-key 2 | 30:10, 50:10, 70:10
 | s, cl
Parent topic: DFC470 - DFC491


Explanation of Error Codes

The ErrorCode portion of an error message is made up as follows:

  • subproduct - three characters indicating the subproduct that found the error. Possible values for subproduct are:
    COB | COBOL Compiler
    IDE | Integrated Development Environment
    SQL | SQL preprocessor
  • function - two characters indicating the function that subproduct was performing when the error was found. function can be one of the following:
    AN | Debugging
    CH | Syntax checking
    CM | Compiling
    CP | Command processing
    DM | Dialog Manager
    EF | File handling
    ID | Interface handling
    IS | Installation
    LK | Linking
    OP | Optimization
    PR | Integrated preprocessor
    RT | Run-time emulation
    SQ | SQL pre-processing
    ST | Sorting
    YS | Internal system errors
    UT | Miscellaneous utility operations
  • message-no - the number of the error.
  • sev - one character indicating the severity of the error. This varies depending on the type of error.
Parent topic: Error Messages


File Handling Reference

  • Btrieve Error Codes
  • Compiler Directives - File Handling
    There are a number of Compiler directives that affect file handling.
  • File Handler
  • FSView
    View the available API calls and command line options that you can make with the FSView utility.
  • File Status
    View the full definitions of the two-digit file status codes.
  • File Structures
    View the structure of each available file format.
  • Library Routines
    There are a number of library routines that you can call to perform file handling functions.
  • Limits
    There are a number of limits that affect file handling operations in this COBOL system.
  • Rebuild Command Line Options
    Use a number of options available to configure and run Rebuild from the command line.
  • Rebuild Error, Information and Warning Messages
    Rebuild may output error, information or warning messages when rebuilding, converting or reorganizing an indexed file.
  • Run-time Switches
    There are a number of run-time switches that you can set that affect file handling operations.
  • Sorting Files
    Use the environment variables to affect the running of a sort operation, and use the FCD codes and error messages to help troubleshoot failed sort operations.
Parent topic: General Reference


Btrieve Error Codes

Click the number of the error that you require information about.

  • Btrieve Error/ COBOL File Status Mappings
  • 1 - 19
  • 20 - 39
  • 40 - 59
  • 60 - 79
  • 80 - 99
  • 100 - 119
  • 120-139
Parent topic: File Handling Reference


Btrieve Error/ COBOL File Status Mappings

If an error is returned by the Btrieve Record Manager, the Xfh2btr call conversion module maps the Btrieve error to a COBOL file status code which it returns to your program. The mappings are shown below. Any error returned by Btrieve that is not in the table below will be returned as a 9/025 error.

COBOL Status | Btrieve Status
10 | 9 (if READ sequential operation)
21 | 10
22 | 5
23 | 4, 9 (if START operation), 43
35 | 12
42 | 3 (if CLOSE operation)
43 | 8
47 | 3 (if START/READ operation)
48 | 3 (if WRITE operation), 46
49 | 3 (if REWRITE/DELETE operation)
9/004 | 11
9/007 | 2 (if WRITE operation), 18, 38
9/009 | 35
9/013 | 12
9/014 | 40, 47, 86, 87
9/025 | 101, 102, 103, 104, 105, 106, 107, 109, 130, 133
9/027 | 20
9/033 | 2 (if not WRITE or OPEN operation), 14, 15, 16, 17, 19, 33, 54, 66, 67, 68, 69, 71, 72, 73, 75, 76, 79, 100
9/036 | 59
9/037 | 51, 94
9/039 | 2 (if OPEN operation), 30
9/040 | 24, 36, 58, 90, 91, 92, 96
9/041 | 42, 56
9/047 | 6
9/053 | 53
9/065 | 25, 85 (if OPEN operation), 88
9/068 | 77, 80, 83, 84, 85 (if non-OPEN operation)
9/074 | 60, 61, 62, 63, 64, 65
9/077 | 13, 21, 23, 31, 32, 34, 37, 39, 45, 48, 49, 50, 55, 93
9/078 | 26, 29
9/100 | 41, 99
9/124 | 95
9/125 | 74, 78, 98
9/126 | 97
9/139 | 7, 22, 27, 28, 44
9/142 | 3 (if CLOSE operation)
9/143 | 8
9/146 | 82
9/147 | 3 (if START/READ operation)
9/148 | 3 (if WRITE operation), 46
9/149 | 3 (if REWRITE/DELETE operation)
9/161 | 1
9/213 | 81
Parent topic: Btrieve Error Codes


1 - 19

  • 1 The operation parameter is invalid.
    Returned as COBOL status: 9/161
  • 2 The application encountered an I/O error.
  • 3 The file is not open.
    This status should not be encountered if you are using the Xfh2btr module as it generates the appropriate status without calling the Btrieve run-time system.
  • 4 The key value cannot be found.
    Returned as COBOL status: 23
  • 5 The record has a key field containing a duplicate key value.
    Returned as COBOL status: 22
  • 6 The key number parameter is invalid.
    Returned as COBOL status: 9/047
  • 7 The key number has changed.
    Returned as COBOL status: 9/139
  • 8 The current positioning is invalid.
    This indicates that it is not possible to reposition the current record pointer after an operation and that the current positioning is invalid. The positioning needs to be re-established using a READ or START operation.
  • 9 The operation encountered an end-of-file mark.
  • 10 The key field is not modifiable.
    Returned as COBOL status: 21
  • 11 The specified filename is invalid.
    Returned as COBOL status: 9/004
  • 12 Btrieve cannot find the specified file.
    Note that if the file is on a server, you must have FILE SCAN access rights to the directory where the file resides.
  • 13 Extended file error.
    Returned as COBOL status: 9/077
  • 14 Btrieve cannot create or open the pre-image file.
    Returned as COBOL status: 9/033
  • 15 The application encountered an I/O error during pre-imaging.
    Returned as COBOL status: 9/033
  • 16 The application encountered an expansion error.
    Returned as COBOL status: 9/033
  • 17 The application encountered a close error.
    Returned as COBOL status: 9/033
  • 18 The disk is full.
    Returned as COBOL status: 9/007
  • 19 The application encountered an unrecoverable error.
    Returned as COBOL status: 9/033
Parent topic: Btrieve Error Codes


1 The operation parameter is invalid.

Returned as COBOL status: 9/161

This status should not be encountered if you are using the Xfh2btr module.

Parent topic: 1 - 19


2 The application encountered an I/O error.

Returned as COBOL status:

  • 9/039 if performing an OPEN operation
  • 9/007 if performing a WRITE operation
  • 9/033 if performing a different operation
Parent topic: 1 - 19


3 The file is not open.

This status should not be encountered if you are using the Xfh2btr module as it generates the appropriate status without calling the Btrieve run-time system.
Table 1. Returned as COBOL status
Operation | ansi 85 status | ansi 74 status
CLOSE | 42 | 9/142
WRITE | 48 | 9/148
REWRITE/DELETE | 49 | 9/149
START/READ | 47 | 9/147
Parent topic: 1 - 19


4 The key value cannot be found.

Returned as COBOL status: 23
Parent topic: 1 - 19


5 The record has a key field containing a duplicate key value.

Returned as COBOL status: 22
Parent topic: 1 - 19


6 The key number parameter is invalid.

Returned as COBOL status: 9/047

If calling Xfh2btr directly, this indicates that the key-id field in the FCD is incorrect

Parent topic: 1 - 19


7 The key number has changed.

Returned as COBOL status: 9/139

This error should not be encountered if using the Xfh2btr module.

Parent topic: 1 - 19


8 The current positioning is invalid.

This indicates that it is not possible to reposition the current record pointer after an operation and that the current positioning is invalid. The positioning needs to be re-established using a READ or START operation.
Returned as COBOL status:
  • ansi 85 status: 43
  • ansi 74 status: 9/143
Parent topic: 1 - 19


9 The operation encountered an end-of-file mark.

Returned as COBOL status:
  • 23 if performing a START operation
  • 10 if performing a READ (sequential) operation
Parent topic: 1 - 19


10 The key field is not modifiable.

Returned as COBOL status: 21

An attempt was made to perform a REWRITE operation where an attempt to change a key value was made although the key is defined as non-modifiable in the file.

The Xfh2btr module will create the primary key as non-modifiable and the alternate keys as modifiable.

This error implies that the Btrieve file was created outside of the COBOL system, and that an alternate key is defined as non-modifiable.

Parent topic: 1 - 19


11 The specified filename is invalid.

Returned as COBOL status: 9/004

Note that Btrieve filenames cannot have an extension ^^^.

Parent topic: 1 - 19


12 Btrieve cannot find the specified file.

Note that if the file is on a server, you must have FILE SCAN access rights to the directory where the file resides.
Returned as COBOL status:
  • ansi 85 status: 35
  • ansi 74 status: 9/013
Parent topic: 1 - 19


13 Extended file error.

Returned as COBOL status: 9/077

Btrieve v5.x or earlier could not find the extension file for an extended file that the application tried to open.

The Xfh2btr module does not extend files and so this error implies that the file was created outside of the COBOL system. Ensure that the required extended file is available (extension files must be loaded on the logical disk drive specified when the extension was created). In order to access an extended file, both the primary file and its extension file must be online.

Parent topic: 1 - 19


14 Btrieve cannot create or open the pre-image file.

Returned as COBOL status: 9/033

Note that pre-image files are only used of file versions prior to v6.0

Parent topic: 1 - 19


15 The application encountered an I/O error during pre-imaging.

Returned as COBOL status: 9/033

Note that pre-image files are only used of file versions prior to v6.0

Parent topic: 1 - 19


16 The application encountered an expansion error.

Returned as COBOL status: 9/033

The Xfh2btr module does not expand files and so this error should not be encountered.

Parent topic: 1 - 19


17 The application encountered a close error.

Returned as COBOL status: 9/033
Parent topic: 1 - 19


18 The disk is full.

Returned as COBOL status: 9/007
Parent topic: 1 - 19


19 The application encountered an unrecoverable error.

Returned as COBOL status: 9/033
Parent topic: 1 - 19


20 - 39

  • 20 The Btrieve Engine or Requester is inactive.
    Returned as COBOL status: 9/027
  • 21 The key buffer parameter is too short.
    Returned as COBOL status: 9/077
  • 22 The data buffer parameter is too short.
    Returned as COBOL status: 9/139
  • 23 The position block parameter is not 128 bytes long.
    Returned as COBOL status: 9/077
  • 24 The page size or date buffer size is invalid.
    Returned as COBOL status: 9/040
  • 25 The application cannot create the specified file.
    Returned as COBOL status: 9/065
  • 26 The number of keys is invalid.
    Returned as COBOL status: 9/078
  • 27 The key position is invalid.
    Returned as COBOL status: 9/139
  • 28 The record length is invalid.
    Returned as COBOL status: 9/139
  • 29 The key length is invalid.
    Returned as COBOL status: 9/078
  • 30 The file specified is not a Btrieve file.
    Returned as COBOL status: 9/039
  • 31 The file is already extended.
    Returned as COBOL status: 9/077
  • 32 The file cannot be extended.
    Returned as COBOL status: 9/077
  • 33 Btrieve cannot be unloaded.
    Returned as COBOL status: 9/033
  • 34 The specified extension name is invalid.
    Returned as COBOL status: 9/077
  • 35 The application encountered a directory error.
    Returned as COBOL status: 9/009
  • 36 The application encountered a transaction error.
    Returned as COBOL status: 9/040
  • 37 Another transaction is active.
    Returned as COBOL status: 9/077
  • 38 Btrieve enountered a transaction control file I/O error.
    Returned as COBOL status: 9/007
  • 39 A Begin Transaction operation must precede an End/Abort Transaction operation.
    Returned as COBOL status: 9/077
Parent topic: Btrieve Error Codes


20 The Btrieve Engine or Requester is inactive.

Returned as COBOL status: 9/027

You must start the Micro Kernel Database Engine (MKDE) before generating any requests.

Ensure that the MKDE executable is on your PATH or in the top level of your Windows directory.

Ensure that the Btrieve for Windows DLL, wbtrv32.dll, is on your PATH.

By default, in the Windows environment, the Setup utility turns on the Client Engine Usage option. If you want to access server-based Btrieve but do not want to access client-based Btrieve, turn the Local option off and turn the Server option on. If you want to access both client-based Btrieve and server-based Btrieve, turn the Server option on and leave the Local option on.

If the problem persists, ensure that the Btrieve run-time system is configured and running by performing a -STAT function on the file you are attempting to access. The -STAT operation is available with the BUTIL and BUTIL utilities supplied by Btrieve Technologies.

Parent topic: 20 - 39


21 The key buffer parameter is too short.

Returned as COBOL status: 9/077

This error should not be encountered if using Xfh2btr.

Parent topic: 20 - 39


22 The data buffer parameter is too short.

Returned as COBOL status: 9/139

This implies that the record area defined in the program is not large enough to hold the record that is being read from the Btrieve file. Ensure that the record area is large enough.

This status can also indicate a file corruption, especially in files with variable length records.

Parent topic: 20 - 39


23 The position block parameter is not 128 bytes long.

Returned as COBOL status: 9/077

This error should not be encountered if using Xfh2btr.

Parent topic: 20 - 39


24 The page size or date buffer size is invalid.

Returned as COBOL status: 9/040

Ensure that the setting of the BTRPAGE environment variable is correct. The page size must be a multiple of 512 bytes, with a maximum value of 4096. With Btrieve versions prior to 6.1, this status code can indicate that the page size of the file being opened is larger than that specified in the Largest Page Size configuration option. Configure Btrieve with the correct Largest Page Size option.

Parent topic: 20 - 39


25 The application cannot create the specified file.

Returned as COBOL status: 9/065
Parent topic: 20 - 39


26 The number of keys is invalid.

Returned as COBOL status: 9/078
The number of keys allowed for the page size is invalid. The number of key segments must be within the following limits (for Btrieve v6.x format files):
Page Size | Max. Number Key Components
512 | 8
1024 | 23
1536 | 24
2048 | 54
2560 | 54
3072 | 54
3584 | 54
4096 | 119
Parent topic: 20 - 39


27 The key position is invalid.

Returned as COBOL status: 9/139

The key field position specified is less than 1 or exceeds the defined (fixed) record length for the file. Either the key position is greater than the fixed record length, or the key position plus the key length exceeds the fixed record length.

Parent topic: 20 - 39


28 The record length is invalid.

Returned as COBOL status: 9/139

The record length specified (plus overhead for duplicates, record usage count, variable record pointer, key pointer and blank truncation information) must be less than or equal to the page size minus 8 bytes, and greater than or equal to 4 bytes.

Resolution:

Ensure that the page size is set correctly.

Parent topic: 20 - 39


29 The key length is invalid.

Returned as COBOL status: 9/078

The key length specified must be greater than 0 but less than 255 bytes. Btrieve requires that each key page in the file is large enough to hold at least 8 keys.

Resolution:

Ensure that the page size is set correctly.

Parent topic: 20 - 39


30 The file specified is not a Btrieve file.

Returned as COBOL status: 9/039
Parent topic: 20 - 39


31 The file is already extended.

Returned as COBOL status: 9/077

This status should not be encountered by Xfh2btr as files are never extended.

Parent topic: 20 - 39


32 The file cannot be extended.

Returned as COBOL status: 9/077

This status should not be encountered by Xfh2btr as files are never extended.

Parent topic: 20 - 39


33 Btrieve cannot be unloaded.

Returned as COBOL status: 9/033

This status should not be encountered by Xfh2btr.

Parent topic: 20 - 39


34 The specified extension name is invalid.

Returned as COBOL status: 9/077

This status should not be encountered by Xfh2btr as files are never extended.

Parent topic: 20 - 39


35 The application encountered a directory error.

Returned as COBOL status: 9/009

This status should not be encountered by Xfh2btr as directory operations are not used.

Parent topic: 20 - 39


36 The application encountered a transaction error.

Returned as COBOL status: 9/040

Btrieve tried to perform a Begin Transaction operation without configuring Btrieve to allow transactions. Ensure that the Btrieve Record Manager is configured to allow transactions.

Note that the Xfh2btr module will attempt to start a transaction on the first updating operation (REWRITE, WRITE, DELETE) after a file (with the WITH ROLLBACK clause specified in the SELECT statement) has been opened or after a COMMIT or ROLLBACK statement has been processed.

Parent topic: 20 - 39


37 Another transaction is active.

Returned as COBOL status: 9/077

This status should not be encountered by Xfh2btr.

Parent topic: 20 - 39


38 Btrieve enountered a transaction control file I/O error.

Returned as COBOL status: 9/007
Parent topic: 20 - 39


39 A Begin Transaction operation must precede an End/Abort Transaction operation.

Returned as COBOL status: 9/077

This status should not be encountered by Xfh2btr.

Parent topic: 20 - 39


40 - 59

  • 40 The file access request exceeds the maximum number of files allowed.
    Returned as COBOL status: 9/014
  • 41 Btrieve does not allow the attempted operation.
    Returned as COBOL status: 9/100
  • 42 A file previously opened in Accelerated mode was not closed.
    Returned as COBOL status: 9/041
  • 43 The specified record address is invalid.
    Returned as COBOL status: 23
  • 44 The specified key path is invalid.
    Returned as COBOL status: 9/139
  • 45 The specified key flags are invalid.
    Returned as COBOL status: 9/077
  • 46 Access to the requested file is denied.
    You attempted to perform an Insert, Update or Delete operation on a file that was opened in read-only mode by the application.
  • 47 The number of files opened exceeds the maximum allowed.
    Returned as COBOL status: 9/014
  • 48 The alternate collating sequence definition is invalid.
    Returned as COBOL status: 9/077
  • 49 The extended key type is invalid.
    Returned as COBOL status: 9/077
  • 50 The file owner is already set.
    Returned as COBOL status: 9/077
  • 51 The owner name is invalid.
    Returned as COBOL status: 9/037
  • 53 The language interface version is invalid.
    Returned as COBOL status: 9/053
  • 54 The variable-length portion of the record is corrupt.
    Returned as COBOL status: 9/033
  • 55 The application specified an invalid attribute for an auto-increment key.
    Returned as COBOL status: 9/077
  • 56 An index is incomplete.
    Returned as COBOL status: 9/041
  • 58 The compression buffer length is too short.
    Returned as COBOL status: 9/040
  • 59 The specified file already exists.
    Returned as COBOL status: 9/036
Parent topic: Btrieve Error Codes


40 The file access request exceeds the maximum number of files allowed.

Returned as COBOL status: 9/014
Parent topic: 40 - 59


41 Btrieve does not allow the attempted operation.

Returned as COBOL status: 9/100

This status should not be encountered by Xfh2btr.

Parent topic: 40 - 59


42 A file previously opened in Accelerated mode was not closed.

Returned as COBOL status: 9/041

The application tried to open a Btrieve v5.x file that was previously accessed in Accelerated mode by Btrieve v5.x and never successfully closed.

Another cause is that your application tried to open a v5.x format Btrieve file using a v5.x Btrieve engine, however that same file was previously accessed by a Btrieve v6.x engine, which failed to close the file successfully due to an unrecoverable error.

Parent topic: 40 - 59


43 The specified record address is invalid.

Returned as COBOL status: 23

The record address specified in a READ DIRECT (Get Direct) operation is invalid. This can occur if an invalid record address is specified when doing a READ DIRECT operation (calling Xfh2btr directly) is invalid.

Parent topic: 40 - 59


44 The specified key path is invalid.

Returned as COBOL status: 9/139

The application tried to use the Get Direct operation to establish an index path for a key whose value is null in the corresponding record. Btrieve cannot establish positioning based on a null key value.

Parent topic: 40 - 59


45 The specified key flags are invalid.

Returned as COBOL status: 9/077

This status should not be encountered if using Xfh2btr.

Parent topic: 40 - 59


46 Access to the requested file is denied.

You attempted to perform an Insert, Update or Delete operation on a file that was opened in read-only mode by the application.
Returned as COBOL status:
  • ansi 85 status: 48
  • ansi 74 status: 9/148

You attempted to perform an Insert, Update or Delete operation on a file that is flagged as read-only by the operating system.

Note that Xfh2btr attempts to perform an Update operation in order to detect record locks. Use the NODETECTLOCK directive if this error is returned and you are not performing a WRITE, DELETE or REWRITE operation.

The owner name required for updates was not specified correctly when the file was opened.

It is not possible to specify an owner name when using Xfh2btr to access Btrieve files.

Parent topic: 40 - 59


47 The number of files opened exceeds the maximum allowed.

Returned as COBOL status: 9/014

The number of files opened in Accelerated mode exceeded the number of buffers available in Btrieve's cache. In client-based versions of Btrieve prior to v6.0, you should reconfigure Btrieve both with a smaller page size configuration (to allocate more buffers) and a larger memory size option. You will not encounter this error either in v6.x client-based Btrieve, or in server-based Btrieve.

Parent topic: 40 - 59


48 The alternate collating sequence definition is invalid.

Returned as COBOL status: 9/077

This error should not be encountered as Xfh2btr does not use alternate collating sequences.

Parent topic: 40 - 59


49 The extended key type is invalid.

Returned as COBOL status: 9/077

This error should not be encountered as Xfh2btr does not use extended key types or alternate collating sequences.

Parent topic: 40 - 59


50 The file owner is already set.

Returned as COBOL status: 9/077

This error should not be encountered as Xfh2btr does not set ownership of files.

Parent topic: 40 - 59


51 The owner name is invalid.

Returned as COBOL status: 9/037

This error should not be encountered as Xfh2btr does not set ownership of files.

Parent topic: 40 - 59


53 The language interface version is invalid.

Returned as COBOL status: 9/053

This error should not be encountered as Xfh2btr uses the v5.1 language interface.

Parent topic: 40 - 59


54 The variable-length portion of the record is corrupt.

Returned as COBOL status: 9/033
Parent topic: 40 - 59


55 The application specified an invalid attribute for an auto-increment key.

Returned as COBOL status: 9/077

This error should not be encountered using Xfh2btr.

Parent topic: 40 - 59


56 An index is incomplete.

Returned as COBOL status: 9/041

An index can be damaged if a Create Index operation or a Drop Index operation is interrupted before it runs to completion. Perform a Drop Index operation to completely remove the damaged index from the file.

Parent topic: 40 - 59


58 The compression buffer length is too short.

Returned as COBOL status: 9/040

The application tried to read or write a record that is longer than the value specified for the size of the compression buffer. Reconfigure Btrieve, specifying a higher value for the Largest Compressed Record Size option.

Parent topic: 40 - 59


59 The specified file already exists.

Returned as COBOL status: 9/036

This error should not be returned using Xfh2btr.

Parent topic: 40 - 59


60 - 79

  • 60 The specified reject count has been reached.
    Returned as COBOL status: 9/074
  • 61 The work space is too small.
    Returned as COBOL status: 9/074
  • 62 The descriptor is incorrect.
    Returned as COBOL status: 9/074
  • 63 The data buffer parameter specified on an Insert Extended operation is invalid.
    Returned as COBOL status: 9/074
  • 64 The filter limit has been reached.
    Returned as COBOL status: 9/074
  • 65 The field offset is incorrect.
    Returned as COBOL status: 9/074
  • 66 The maximum number of open databases has been exceeded.
    Returned as COBOL status: 9/033
  • 67 Btrieve cannot open the SQL data dictionary files.
    Returned as COBOL status: 9/033
  • 68 Btrieve cannot perform the RI Delete Cascade operation.
    Returned as COBOL status: 9/033
  • 69 The Delete operation specified a file that is damaged.
    Returned as COBOL status: 9/033
  • 71 There is a violation of the RI definitions.
    Returned as COBOL status: 9/033
  • 72 Btrieve cannot open the RI-referenced file.
    Returned as COBOL status: 9/033
  • 73 The RI definition is out of sync.
    Returned as COBOL status: 9/033
  • 74 Btrieve aborted the transaction.
    Returned as COBOL status: 9/125
  • 75 Server routing list too small.
    Returned as COBOL status: 9/033
  • 76 There is a conflict on the referenced file.
    Returned as COBOL status: 9/033
  • 77 The application encountered a wait error.
    Returned as COBOL status: 9/068
  • 78 Btrieve detected a deadlock condition.
    Returned as COBOL status: 9/125
  • 79 A programming error occurred.
    Returned as COBOL status: 9/033
Parent topic: Btrieve Error Codes


60 The specified reject count has been reached.

Returned as COBOL status: 9/074

This error should not be returned using Xfh2btr as Extended operations are not used.

Parent topic: 60 - 79


61 The work space is too small.

Returned as COBOL status: 9/074

This error should not be returned using Xfh2btr as Extended operations are not used.

Parent topic: 60 - 79


62 The descriptor is incorrect.

Returned as COBOL status: 9/074

This error should not be returned using Xfh2btr as Extended operations are not used.

Parent topic: 60 - 79


63 The data buffer parameter specified on an Insert Extended operation is invalid.

Returned as COBOL status: 9/074

This error should not be encountered as Xfh2btr does not use the Insert Extended operation.

Parent topic: 60 - 79


64 The filter limit has been reached.

Returned as COBOL status: 9/074

This error should not be encountered as Xfh2btr does not use Extended operations.

Parent topic: 60 - 79


65 The field offset is incorrect.

Returned as COBOL status: 9/074

This error should not be encountered as Xfh2btr does not use Extended operations.

Parent topic: 60 - 79


66 The maximum number of open databases has been exceeded.

Returned as COBOL status: 9/033
Parent topic: 60 - 79


67 Btrieve cannot open the SQL data dictionary files.

Returned as COBOL status: 9/033
Parent topic: 60 - 79


68 Btrieve cannot perform the RI Delete Cascade operation.

Returned as COBOL status: 9/033
Parent topic: 60 - 79


69 The Delete operation specified a file that is damaged.

Returned as COBOL status: 9/033
Parent topic: 60 - 79


71 There is a violation of the RI definitions.

Returned as COBOL status: 9/033
Parent topic: 60 - 79


72 Btrieve cannot open the RI-referenced file.

Returned as COBOL status: 9/033
Parent topic: 60 - 79


73 The RI definition is out of sync.

Returned as COBOL status: 9/033
Parent topic: 60 - 79


74 Btrieve aborted the transaction.

Returned as COBOL status: 9/125
Parent topic: 60 - 79


75 Server routing list too small.

Returned as COBOL status: 9/033
Parent topic: 60 - 79


76 There is a conflict on the referenced file.

Returned as COBOL status: 9/033
Parent topic: 60 - 79


77 The application encountered a wait error.

Returned as COBOL status: 9/068
Parent topic: 60 - 79


78 Btrieve detected a deadlock condition.

Returned as COBOL status: 9/125
Parent topic: 60 - 79


79 A programming error occurred.

Returned as COBOL status: 9/033
Parent topic: 60 - 79


80 - 99

  • 80 Btrieve encountered a record-level conflict.
    Returned as COBOL status: 9/068
  • 81 Btrieve encountered a lock error.
    Returned as COBOL status: 9/213
  • 82 Btrieve lost positioning.
    Returned as COBOL status: 9/146
  • 83 Btrieve attempted to read a record outside the transaction.
    Returned as COBOL status: 9/068
  • 84 The record or page is locked.
    Returned as COBOL status: 9/068
  • 85 The file is locked.
  • 86 The file table is full.
    Returned as COBOL status: 9/014
  • 87 The handle table is full.
    Returned as COBOL status: 9/014
  • 88 The application encountered an incompatible mode error.
    Returned as COBOL status: 9/065
  • 90 Redirected device table full.
    Returned as COBOL status: 9/040
  • 91 The application encountered a server error.
    Returned as COBOL status: 9/040
  • 92 The transaction table is full.
    Returned as COBOL status: 9/040
  • 93 The record lock types are incompatible.
    Returned as COBOL status: 9/077
  • 94 The application encountered a permission error.
    Returned as COBOL status: 9/037
  • 95 The session is no longer valid.
    Returned as COBOL status: 9/124
  • 96 A communications environment error occurred.
    Returned as COBOL status: 9/040
  • 97 The data buffer is too small.
    Returned as COBOL status: 9/126
  • 98 Btrieve detected an internal transaction error.
    Returned as COBOL status: 9/125
  • 99 Btrieve requester unable to access NetWare Runtime server.
    Returned as COBOL status: 9/100
Parent topic: Btrieve Error Codes


80 Btrieve encountered a record-level conflict.

Returned as COBOL status: 9/068
Parent topic: 80 - 99


81 Btrieve encountered a lock error.

Returned as COBOL status: 9/213
Parent topic: 80 - 99


82 Btrieve lost positioning.

Returned as COBOL status: 9/146

The position of the current record pointer must be re-established using a START or READ (random) operation.

Parent topic: 80 - 99


83 Btrieve attempted to read a record outside the transaction.

Returned as COBOL status: 9/068
Parent topic: 80 - 99


84 The record or page is locked.

Returned as COBOL status: 9/068
Parent topic: 80 - 99


85 The file is locked.

Returned as COBOL status:
  • 9/065 if performing an OPEN operation
  • 9/068 if performing a different operation
Parent topic: 80 - 99


86 The file table is full.

Returned as COBOL status: 9/014
Parent topic: 80 - 99


87 The handle table is full.

Returned as COBOL status: 9/014
Parent topic: 80 - 99


88 The application encountered an incompatible mode error.

Returned as COBOL status: 9/065
Parent topic: 80 - 99


90 Redirected device table full.

Returned as COBOL status: 9/040

Resolution:

Reload the Requester, specifying a larger number for either the Number of File Servers (/S) option or the Number of Mapped Drives (/R) option.

Parent topic: 80 - 99


91 The application encountered a server error.

Returned as COBOL status: 9/040
Parent topic: 80 - 99


92 The transaction table is full.

Returned as COBOL status: 9/040

Resolution:

Reconfigure Btrieve specifying a higher value for the Number of Transactions configuration option.

Parent topic: 80 - 99


93 The record lock types are incompatible.

Returned as COBOL status: 9/077

This error should not be encountered if using Xfh2btr.

Parent topic: 80 - 99


94 The application encountered a permission error.

Returned as COBOL status: 9/037
Parent topic: 80 - 99


95 The session is no longer valid.

Returned as COBOL status: 9/124
Parent topic: 80 - 99


96 A communications environment error occurred.

Returned as COBOL status: 9/040
Parent topic: 80 - 99


97 The data buffer is too small.

Returned as COBOL status: 9/126

Resolution:

Perform one or both of the following:
  • Increase the size of the message buffer by configuring Btrieve with a higher value for the Largest Record Size.
  • Reload the Btrieve Requester and specify a higher value for the Message Buffer Size.
Parent topic: 80 - 99


98 Btrieve detected an internal transaction error.

Returned as COBOL status: 9/125
Parent topic: 80 - 99


99 Btrieve requester unable to access NetWare Runtime server.

Returned as COBOL status: 9/100
Parent topic: 80 - 99


100 - 119

  • 100 No cache buffers are available.
    Returned as COBOL status: 9/033
  • 101 Insufficient operating system memory is available.
    Returned as COBOL status: 9/025
  • 102 Insufficient stack space is available.
    Returned as COBOL status: 9/025
  • 103 The chunk offset is too big.
    Returned as COBOL status: 9/025
  • 104 Btrieve does not recognize the locale.
    Returned as COBOL status: 9/025
  • 105 The file cannot be created with Variable-tail Allocation Tables (VATs).
    Returned as COBOL status: 9/025
  • 106 Btrieve cannot perform a Get Next Chunk operation.
    Returned as COBOL status: 9/025
  • 107 The application attempted to perform a chunk operation on a pre-v6.0 file.
    Returned as COBOL status: 9/025
  • 109 The application's transaction has become too complex.
    Returned as COBOL status: 9/025
Parent topic: Btrieve Error Codes


100 No cache buffers are available.

Returned as COBOL status: 9/033

Resolution:

Reconfigure Btrieve with a higher value for the Cache Allocation option.

Parent topic: 100 - 119


101 Insufficient operating system memory is available.

Returned as COBOL status: 9/025
Parent topic: 100 - 119


102 Insufficient stack space is available.

Returned as COBOL status: 9/025
Parent topic: 100 - 119


103 The chunk offset is too big.

Returned as COBOL status: 9/025

This error should not be encountered as Xfh2btr does not use the Chunk operations.

Parent topic: 100 - 119


104 Btrieve does not recognize the locale.

Returned as COBOL status: 9/025
Parent topic: 100 - 119


105 The file cannot be created with Variable-tail Allocation Tables (VATs).

Returned as COBOL status: 9/025
Parent topic: 100 - 119


106 Btrieve cannot perform a Get Next Chunk operation.

Returned as COBOL status: 9/025

This error should not be encountered as Xfh2btr does not use the Chunk operations.

Parent topic: 100 - 119


107 The application attempted to perform a chunk operation on a pre-v6.0 file.

Returned as COBOL status: 9/025

This error should not be encountered as Xfh2btr does not use the Chunk operations.

Parent topic: 100 - 119


109 The application's transaction has become too complex.

Returned as COBOL status: 9/025
Parent topic: 100 - 119


120-139

  • 130 Btrieve ran out of system locks.
    Returned as COBOL status: 9/025
  • 133 More than 5 concurrent users attempted to access the same Btrieve file.
    Returned as COBOL status: 9/025
Parent topic: Btrieve Error Codes


130 Btrieve ran out of system locks.

Returned as COBOL status: 9/025
Parent topic: 120-139


133 More than 5 concurrent users attempted to access the same Btrieve file.

Returned as COBOL status: 9/025

This error only occurs on the Developer Kit version of client-based Btrieve, which limits the number of concurrent users of a file to five engines.

Parent topic: 120-139


Compiler Directives - File Handling

For information on the Compiler directives that affect file handling see the topic File Handling.

Parent topic: File Handling Reference
Related reference
File Handling


File Handler

  • Configuration File
    Certain aspects of the File Handler's behavior can be configured. You can alter these aspects by entering values in the File Handler configuration file.
  • Data Structures
    View the structure of data as it is stored in the FCD.
  • Operation Codes
    View the standard and special operation codes for all file organizations.
Parent topic: File Handling Reference


Configuration File

The default filename for the File Handler configuration file is extfh.cfg but you can use a different filename by setting the EXTFH environment variable. For example:

set EXTFH=c:\mydir\test.cfg
sets the filename to c:\mydir\test.cfg.
  • Format of the Configuration File
    The File Handler configuration file enables you to apply settings to individual or groups of files by adding options to different sections in the file.
  • Configuration File Options
    The File Handler configuration file can contain a number of options that affect file handling operations in this COBOL system.
Parent topic: File Handler


Format of the Configuration File

The File Handler configuration file enables you to apply settings to individual or groups of files by adding options to different sections in the file.

When a file handling action is performed, applicable settings are applied in the order that the sections are listed below:

  • XFH-DEFAULT
  • INTERNAL tag
  • Filename tag
  • Path and filename tag
  • Example
Parent topic: Configuration File


XFH-DEFAULT

Settings that apply to all files are listed under the tag:

[XFH-DEFAULT]

Two further tags are available to use within [XFH-DEFAULT] or instead of it. Settings that apply to all indexed files or all sequential files are listed under these tags:

[IDX-DEFAULT] and [SEQ-DEFAULT]
Parent topic: Format of the Configuration File


INTERNAL tag

The settings for an individual file override the global settings. If you just specify the filename, it must be the resolved filename, that is, the filename that the File Handler uses after it has completed its filename mapping process. Alternatively, you can prefix the filename with the keyword INTERNAL, to signify that the filename is the name that is used in the SELECT clause; the settings will then be applied to the file that is identified at the conclusion of the filename mapping process. For example, if the ASSIGN mode is dynamic, and you code:

[INTERNAL:$myfile\outfile.dat]
IDXFORMAT=8

where myfile is an environment variable holding the name of the directory where the folder is located, the settings will be applied to outfile.dat in that directory.

If the ASSIGN mode is external, and you had:

SELECT MYDATA ASSIGN TO EXTERNAL REALDATA

you could code:

[INTERNAL:REALDATA]

where any options which follow apply to the file to which the logical name "REALDATA" is mapped.

If, however, you have:

SELECT MYDATA ASSIGN TO '\directory\subdirectory\datadirectory\myfile'

you cannot use the INTERNAL option in the configuration file. The literal value in the SELECT statement must be replicated [inside square brackets] in the configuration file.

Filenames can use paths and DD_mappings but not wildcards or logic names. If you set the File Handler configuration option BASENAME=ON, you can specify filenames without paths. Note that the name of a file must match the mapped name in your program.

Parent topic: Format of the Configuration File


Filename tag

Settings that apply to a specific file are listed under the specific filename tag; for example:

[file1.dat]
IDXFORMAT=17
[file2.dat]
IDXFORMAT=21

sets file1.dat to IDXFORMAT 17 and file2.dat to IDXFORMAT 21.

Comments:

To enable the use of filenames (without a pathname), set BASENAME=ON in the [XFH-DEFAULT] section.

When you use the filename tag, the path to the current directory is assumed, and if a FOLDER tag exists for any folder along the path, settings for that tag are applied. For example, if you have the following file assignment:

SELECT myFile ASSIGN TO 'file1.dat'

and your application is run in the directory c:\files\mffiles, then if you have FOLDER tags for the following locations in your configuration file, the settings in them are applied:

  • c:\
  • c:\files
  • c:\files\mffiles
Parent topic: Format of the Configuration File


Path and filename tag

You can explicitly specifiy a file using the path and filename tag; for example:

[c:\\acufiles\\file1.dat]
IDXFORMAT=17
[c:\\rmfiles\\file1.dat]
IDXFORMAT=21
Important: If you include a path to a file in the tag, you must enter the "\" character twice in order for the configuration file to be parsed correctly. For example, instead of
[C:\SITETEST\EXTFH\TEST2.dat]

you would need to enter

[C:\\SITETEST\\EXTFH\\TEST2.dat]

sets file1.dat in c:\files\acufiles to IDXFORMAT 17 and file1.dat in c:\files\rmfiles to IDXFORMAT 21.

Note: To enable the use of filenames (without a pathname), set BASENAME=ON in the [XFH-DEFAULT] section.
Parent topic: Format of the Configuration File


Example

According to the order that the options are applied, the following excerpt of the File Handler configuration file:
[XFH-DEFAULT]
IDXFORMAT=2
[*.dat]
IDXFORMAT=8
[FOLDER:C:\\files\\acu]
IDXFORMAT=17
results in myfile.dat, located in c:\files\acu, being set to IDXFORMAT 17.
Parent topic: Format of the Configuration File


Configuration File Options

The following options can be set in the File Handler configuration file.

  • ASCIIMAINFRAMEPRINT
    The ASCIIMAINFRAMEPRINT option specifies whether to use ASCII printer control characters when CHARSET is set to ASCII and the FILETYPE is set to mainframe print format where “WRITE BEFORE ADVANCING SYNTAX” is used.
  • BASENAME
    The BASENAME option determines whether filenames specified in tags can be expressed without pathnames. By default, such filenames have to be expressed with full path information as passed to the File Handler by the calling program. By setting BASENAME=ON, it is possible to specify the filename without the path.
  • COMMITFLUSH
    In the context of a program that is not using Fileshare, the COMMITFLUSH option specifies whether the COMMIT and ROLLBACK statements cause all file updates to be flushed to disk, as well as record locks to be released.
  • CONCATNAME
    The CONCATNAME option determines whether filenames including the plus ('+') character are to be interpreted as normal filenames, or as file concatenations.
  • CONVERTDBSPACE
    The CONVERTDBSPACE option enables conversion of double-byte character set (DBCS) spaces to ASCII spaces when reading a line sequential file.
  • CONVERTEUCKATAKANA
    The CONVERTEUCKATAKANA option enables conversion of EUC single-width double-byte characters to their double-width Katakana equivalents when reading a line sequential file.
  • CONVERTSTATUS
    The CONVERTSTATUS option specifies the name of a program that is called after the File Handler has finished processing to map returned status values for emulation purposes.
  • DATACOMPRESS
    The DATACOMPRESS option specifies whether data compression is in effect and the type of compression. The directive only affects record sequential and indexed files.
  • DATAFILE
    The DATAFILE option maps the filename passed to an OPEN statement onto another name.
  • EXPANDPOSITIONING
    When using the WRITE AFTER POSITIONING statement (OS/VS COBOL compatibility), the first character of the record area can hold carriage control information. The EXPANDPOSITIONING option determines whether the written record includes this carriage control information.
  • EXPANDTAB
    The EXPANDTAB option determines whether to expand TAB characters encountered in line sequential or line advancing files during a READ operation into the equivalent number of spaces.
  • FASTREAD
    The FASTREAD option specifies whether or not the File Handler performs extra checking to ensure data integrity when reading an indexed file.
  • FHREDIR
    The FHREDIR option specifies whether a remote server using Fileshare can handle files.
  • FILEMAXSIZE
    The FILEMAXSIZE option specifies the number of bytes used internally to store file offsets.
  • FILEPOINTERSIZE
    For format 8 indexed files, the FILEPOINTERSIZE parameter specifies the length in bytes to use to store file pointers.
  • FSIDXINTEGRITY
    In the context of a Fileshare system, the FSIDXINTEGRITY option causes any changed nodes held within the File Handlers index cache (as configured with the INDEXCOUNT option) to be written to disk before Fileshare returns status information to the client program. This option improves the integrity of indexed files processed by Fileshare at the expense of a small amount of additional file I/O.
  • IDXDATBUF
    The IDXDATBUF option determines the size of buffer used when accessing the data portion of a file with organization INDEXED.
  • IDXFORMAT
    The IDXFORMAT option specifies the format to use when creating indexed files.
  • IDXNAMETYPE
    The IDXNAMETYPE option specifies the format of the filename type for both the data file and, if present, the index file.
  • IGNORELOCK
    The IGNORELOCK option specifies whether to ignore locks when reading files open for input.
  • INDEXCOUNT
    The INDEXCOUNT option specifies the number of index nodes to be cached for an indexed file.
  • INDEXFILE
    The INDEXFILE option maps the name of the index file (for those indexed file formats that have a separate index file). This name can include full path information.
  • INSERTNULL
    When performing WRITE or REWRITE operations on line sequential or line advancing files, the INSERTNULL option determines whether to insert NULL (x"00") characters before non-printable characters. The option also determines whether to strip out those NULL characters during READ operations.
  • INSERTTAB
    When performing WRITE or REWRITE operations on line sequential or line advancing files, the INSERTTAB option determines whether to replace sequences of spaces with TAB characters.
  • KEYCHECK
    The KEYCHECK option specifies whether the File Handler checks that the key definition defined in your application matches that of the indexed file you are opening.
  • KEYCOMPRESS
    The KEYCOMPRESS option specifies the type of key compression in use.
  • LOADONTOHEAP
    The LOADONTOHEAP option specifies whether the File Handler loads the file into memory before executing any I/O operations.
  • LOCKTYPE
    The LOCKTYPE option specifies the type of record locking in use.
  • LOG
    When LOG is set to ON, any unusual file-related situations, such as corrupted files, or automatic file recovery, are noted in a log file for later examination.
  • LOGFILENAME
    When the LOG option is active, the LOGFILENAME option specifies the name of the log file to produce.
  • LSFILETERM
    The option controls the behavior of the File Handler upon encountering the EOF character x"1a" when reading line sequential files.
  • LSRECDELIM
    The LSRECDELIM option specifies the characters to be used as the record delimiter in line sequential files.
  • MAINFRAMEPRINT
    For those files using WRITE AFTER ADVANCING or WRITE BEFORE ADVANCING, the MAINFRAMEPRINT option determines whether to use mainframe printer file format (filetype 11).
  • NAMEOPTIONS
    The NAMEOPTIONS option specifies whether the name you pass to the OPEN statement can contain File Handler options.
  • NFSFILELOCK
    The NFSFILELOCK option enables applications to detect record locks and file locks on UNIX NFS file systems.
  • NODESIZE
    The NODESIZE option specifies the size of the index nodes to use for an indexed file.
  • NOSEQCHECK
    The NOSEQCHECK option disables sequence-checking of keys in indexed files.
  • OPENINPUTSHARED
    The OPENINPUTSHARED option specifies whether files that you open for input, and for which you do not specify a LOCK MODE clause, can be shared by other users.
  • OSVSREWRITE
    The OSVSREWRITE option specifies whether to permit the WRITE statement for sequential files that are open for output. If so, these WRITE statements behave exactly like REWRITE statements.
  • READSEMA
    The READSEMA option specifies whether the system attempts to gain a semaphore for shared files when I/O operations are performed that do not modify the file.
  • READTODELIM
    The READTODELIM option specifies whether the file pointer is advanced to the next logical record in the file when reading in a record that is longer than the user data area. In these circumstances, the data record would effectively be truncated.
  • RELDATBUF
    The RELDATBUF option determines the size of buffer used when accessing a file with organization RELATIVE.
  • RELRECDELIM
    The RELRECDELIM option specifies the characters to be used as the record delimiter in fixed-length relative files.
  • RETRYLOCK
    The RETRYLOCK option indicates whether you wish to retry a READ operation that fails because the record is locked.
  • RETRYOPEN
    The RETRYOPEN option indicates whether you wish to retry an I/O operation that fails because the file is locked.
  • RETRYTIME
    The RETRYTIME option specifies whether the integer given in the RETRYLOCK and RETRYOPEN options specifies the number of attempts or the number of seconds.
  • RUNITLOCKDETECT
    The RUNITLOCKDETECT option specifies whether the File Handler checks whether a record has been locked by a separate OPEN statement issued from within the same run unit.
  • SEARCHONCREATE
    The SEARCHONCREATE parameter determines whether the File Handler searches each specified directory on a multi-directory path for a file with the same name as the one being created. This option applies only to files which are opened with OPEN OUTPUT.
  • SEQDATBUF
    The SEQDATBUF option determines the size of buffer to use when accessing a file with organization SEQUENTIAL.
  • SKIPLOCK
    The SKIPLOCK option specifies whether to advance the current record pointer when a locked record is encountered during a sequential READ.
  • SPACEFILL
    The SPACEFILL option determines whether to fill with spaces that part of the record area beyond the data that is read when performing READ operations on line sequential or line advancing files.
  • STARTUNLOCK
    The STARTUNLOCK option determines whether a START operation will remove existing locks for files specified with single record locking; that is, without the WITH LOCK ON MULTIPLE RECORDS phrase.
  • STRIPSPACE
    The STRIPSPACE parameter determines whether to remove trailing space characters when performing WRITE or REWRITE operations on line sequential or line advancing files.
  • SUPPRESSADV
    The SUPPRESSADV option determines whether to ignore the ADVANCING phrase of the WRITE statement for record sequential files.
  • TRACE
    The TRACE option specifies whether Xfhtrace, the File Handler trace module, is enabled. The Xfhtrace module traces File Handler operations and logs all activity to a trace file. It is supplied to help you diagnose any problems you may have with COBOL files.
  • TRACEFILEEXTEND
    The TRACEFILEEXTEND option determines whether to write trace information to the end of the current trace file, if the trace file already exists. This option has no effect if TRACE is OFF.
  • TRACEFILENAME
    The TRACEFILENAME option specifies the name of the trace file to produce when the TRACE option is active.
  • USEVSAMKEYDEFS
    Use the keys defined in the catalog via the JCL and IDCAMS instead of the keys defined in the executing program.
  • WRITELINE
    The WRITELINE parameter determines whether mainframe or PC behavior is used for WRITE record.
  • WRITETHRU
    The WRITETHRU option determines whether modifications to a file are written out to disk immediately or buffered internally, either by the COBOL system or by the operating system, and flushed to disk at a later stage.
Parent topic: Configuration File


ASCIIMAINFRAMEPRINT

The ASCIIMAINFRAMEPRINT option specifies whether to use ASCII printer control characters when CHARSET is set to ASCII and the FILETYPE is set to mainframe print format where “WRITE BEFORE ADVANCING SYNTAX” is used.

Syntax:

ASCIIMAINFRAMEPRINT = { ON } { OFF }

Parameters:

ON
Printer Control Characters are in ASCII when CHARSET is set to ASCII.
OFF
Printer Control Characters are in EBCDIC where CHARSET is set to ASCII.

Properties:

Default: OFF

Comments:

You use an entry in the File Handler Configuration File (EXTFH.cfg) to enable the printer control characters to be ASCII when the CHARSET is set to ASCII:

[xfh-default]
 ASCIIMAINFRAMEPRINT=ON

The default value is OFF.

This parameter can be set globally only; that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Parent topic: Configuration File Options


BASENAME

The BASENAME option determines whether filenames specified in tags can be expressed without pathnames. By default, such filenames have to be expressed with full path information as passed to the File Handler by the calling program. By setting BASENAME=ON, it is possible to specify the filename without the path.

Syntax:

BASENAME = { ON } { OFF }

Parameters:

ON
Filename tags can be expressed without path information.
OFF
All filename tags in the configuration file must be expressed with full path information.

Properties:

Default: OFF

Comments:

This parameter can be set globally only, that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Parent topic: Configuration File Options


COMMITFLUSH

In the context of a program that is not using Fileshare, the COMMITFLUSH option specifies whether the COMMIT and ROLLBACK statements cause all file updates to be flushed to disk, as well as record locks to be released.

Syntax:

COMMITFLUSH = { ON } { OFF }

Parameters:

ON
The COMMIT and ROLLBACK statements cause all file updates to be flushed to disk.
OFF
The COMMIT and ROLLBACK statements do not cause all file updates to be flushed to disk.

Properties:

Default: OFF

Comments:

This parameter can be set globally only; that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Parent topic: Configuration File Options


CONCATNAME

The CONCATNAME option determines whether filenames including the plus ('+') character are to be interpreted as normal filenames, or as file concatenations.

A concatenated file should be opened only for input and should have organization SEQUENTIAL or LINE SEQUENTIAL. It is made up of separate components whose names are separated by the '+' character. On reading sequentially through such a file, when the end of one component is reached and another component is available, the next read will automatically return the first record of that component. On reaching the end of the last component, the AT END status is returned.

Syntax:

CONCATNAME = { ON } { OFF }

Parameters:

ON
Names including the '+' character are treated as concatenated files; for example, the name file1+file2 is treated as the concatenation of files file1 and file2.
OFF
Names including the '+' character are created as normal filenames.

Properties:

Default: OFF

Comments:

This parameter can be set globally only, that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Parent topic: Configuration File Options


CONVERTDBSPACE

The CONVERTDBSPACE option enables conversion of double-byte character set (DBCS) spaces to ASCII spaces when reading a line sequential file.

Syntax:

CONVERTDBSPACE = { ON } { OFF }

Parameters:

ON
Convert DBCS spaces to ASCII when reading a line sequential file.
OFF
Do not convert DBCS spaces.

Properties:

Default: OFF
Parent topic: Configuration File Options


CONVERTEUCKATAKANA

The CONVERTEUCKATAKANA option enables conversion of EUC single-width double-byte characters to their double-width Katakana equivalents when reading a line sequential file.

Syntax:

CONVERTEUCKATAKANA = { ON } { OFF }

Parameters:

ON
Convert EUC single-width double-byte characters to their double-width Katakana equivalents.
OFF
Do not convert EUC characters.

Properties:

Default: OFF
Parent topic: Configuration File Options


CONVERTSTATUS

The CONVERTSTATUS option specifies the name of a program that is called after the File Handler has finished processing to map returned status values for emulation purposes.

Syntax:

CONVERTSTATUS = program

Parameters:

program
The name of the program to be called. Three such programs are built into the product:
rmstat
The rmstat program emulates status values returned by RM/COBOL.
hoststat
The hoststat program emulates status values returned by IBM Mainframe COBOL compilers.
msstat
The msstat program emulates status values returned by Microsoft COBOL V2.

Properties:

Default: none

Comments:

This parameter can be set globally only; that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Parent topic: Configuration File Options


DATACOMPRESS

The DATACOMPRESS option specifies whether data compression is in effect and the type of compression. The directive only affects record sequential and indexed files.

When set to 0, no data compression takes place. Otherwise, the number indicates the type of compression.

Syntax:

DATACOMPRESS = integer

Parameters:

integer
0
No data compression is performed.
1
Run-length encoding.
3
Run-length encoding for double-byte (DBCS) characters

Properties:

Default: 0
Parent topic: Configuration File Options
Related information
Data Compression


DATAFILE

The DATAFILE option maps the filename passed to an OPEN statement onto another name.

Syntax:

DATAFILE = name

Parameters:

name
Name to be mapped to filename; can include full path information.

Properties:

Default: none
Parent topic: Configuration File Options


EXPANDPOSITIONING

When using the WRITE AFTER POSITIONING statement (OS/VS COBOL compatibility), the first character of the record area can hold carriage control information. The EXPANDPOSITIONING option determines whether the written record includes this carriage control information.

Syntax:

EXPANDPOSITIONING = { ON } { OFF }

Parameters:

ON
Use the first character to determine carriage control before stripping the character from the output.
OFF
Write out the whole record, including the carriage control information.

Properties:

Default: OFF
Parent topic: Configuration File Options


EXPANDTAB

The EXPANDTAB option determines whether to expand TAB characters encountered in line sequential or line advancing files during a READ operation into the equivalent number of spaces.

Syntax:

EXPANDTAB = { ON } { OFF }

Parameters:

ON
Expand TAB characters into the equivalent number of spaces.
OFF
Leave TAB characters unchanged.

Properties:

Default: ON
Parent topic: Configuration File Options


FASTREAD

The FASTREAD option specifies whether or not the File Handler performs extra checking to ensure data integrity when reading an indexed file.

Syntax:

FASTREAD = { ON } { OFF }

Parameters:

ON
Do not perform extra checking.
OFF
Perform extra checking to ensure data integrity.

Properties:

Default: ON

Comments:

To increase the efficiency of reads on fixed length, non-compressed indexed files, set FASTREAD to ON.

Parent topic: Configuration File Options


FHREDIR

The FHREDIR option specifies whether a remote server using Fileshare can handle files.

Syntax:

FHREDIR = { ON } { OFF }

Parameters:

ON
Use Fileshare to access files on a remote server.
OFF
Do not use Fileshare.

Properties:

Default: OFF

Comments:

If FHREDIR is set to OFF, the File Handler examines the name at open time to determine whether the file is to be handled locally.

This parameter can be set globally only; that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Take care with this option. If it is in effect when Fileshare is running, Fileshare will attempt to redirect file I/O requests to itself, and this will cause a timeout failure.

Parent topic: Configuration File Options


FILEMAXSIZE

The FILEMAXSIZE option specifies the number of bytes used internally to store file offsets.

This also affects locking mechanisms: programs sharing the same file all need to use the same FILEMAXSIZE settings to ensure semaphores and record locks are handled correctly, thereby avoiding potential file corruption in shared files.

Syntax:

FILEMAXSIZE = { 4 } { 8 }

Parameters:

4
Limits file addressibility to 32-bit values, which is compatible with earlier versions of Micro Focus products.
8
Allows up to 64-bit values for file addressing on Windows platforms when accessing the NTFS file system, but changes the underlying record locking mechanism. Therefore, if you are sharing very large files (greater than 1Gb in size) all programs accessing the file must use FILEMAXSIZE set to 8 to avoid possible corruption problems.

Properties:

Default: 8

Comments:

Note: Do not set FILEMAXSIZE to 8 under any of the following circumstances:
  • You are running applications on an operating system which does not support a 64-bit file system.
  • You are running applications that access FAT file systems, since such file systems do not support file addressibility greater than 32-bit file addressing.
  • If any accessing program needs to access a shared file in a 32-bit file system.
  • You are sharing files with applications using earlier versions of the Micro Focus COBOL product that only supported 32-bit file access.

Set FILEMAXSIZE to 4 in these scenarios.

All applications accessing a file must run with the File Handler configured with the same value for FILEMAXSIZE.

If you are requesting 64-bit file access to an unknown remote file system, ensure you set the remote_64bit_access tunable.

Only 32-bit (4GB) support is provided for Novell systems.

Parent topic: Configuration File Options


FILEPOINTERSIZE

For format 8 indexed files, the FILEPOINTERSIZE parameter specifies the length in bytes to use to store file pointers.

Syntax:

FILEPOINTERSIZE = { 6 } { 8 }

Parameters:

6
Use 6 bytes, allowing for files up to 256 terabytes.
8
Use 8 bytes, allowing for files over 256 terabytes.

Properties:

Default: 6

Comments:

The FILEPOINTERSIZE=8 option uses up more space to store file pointers. Therefore, the resulting file size might increase slightly.

Parent topic: Configuration File Options


FSIDXINTEGRITY

In the context of a Fileshare system, the FSIDXINTEGRITY option causes any changed nodes held within the File Handlers index cache (as configured with the INDEXCOUNT option) to be written to disk before Fileshare returns status information to the client program. This option improves the integrity of indexed files processed by Fileshare at the expense of a small amount of additional file I/O.

Syntax:

FSIDXINTEGRITY = { ON } { OFF }

Parameters:

ON
Changes to the File Handler's index cache are written to disk before Fileshare returns control the client program.
OFF
Changes to the File Handler's index cache are written to disk when space is needed for other operations.

Properties:

Default: ON

Comments:

This parameter can be set globally only; that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Parent topic: Configuration File Options


IDXDATBUF

The IDXDATBUF option determines the size of buffer used when accessing the data portion of a file with organization INDEXED.

Syntax:

IXDATBUF = { integer } { 0 }

Parameters:

integer
Round up the value that you enter to the next power of 2 that is greater or equal.
0
Do not use buffering.

Properties:

Default: 0

Comments:

A non-zero value can be beneficial while the file is being created. Otherwise, you might not achieve a gain in performance; in fact, performance can be degraded.

For those files where index and data are held in the same physical file, this option has no effect.

Parent topic: Configuration File Options


IDXFORMAT

The IDXFORMAT option specifies the format to use when creating indexed files.

Syntax:

IDXFORMAT = integer

Parameters:

0
Default format for the operating system (identical to 8.)
1
C-ISAM.
3
Micro Focus default indexed file format.
4
Optimized format for fast duplicate key handling.
5
Btrieve with ANSI
6
Btrieve without ANSI
8
Large indexed file format.
9
Indexed with single key, non-duplicate, key ordered records.
10
Reserved.
11
Mainframe print file format.
12-13
Reserved.
14
Heap file.
15
ESDS
16
ESDS-Big
17-255
Reserved.

Properties:

Default: 3

Comments:

Rebuild will not take the setting of this configuration option into account when generating a new file. Refer to the Rebuild Options /t topic in the Reference section for further information.

You can also set the index format using the IDXFORMAT Compiler directive, which will override the setting specified in the file handler configuration file.

Parent topic: Configuration File Options


IDXNAMETYPE

The IDXNAMETYPE option specifies the format of the filename type for both the data file and, if present, the index file.

Syntax:

IDXNAMETYPE = { 0 } { 1 } { 2 }

Parameters:

0
Leave the filename of the data file the same. For the index file, discard any extension and add the extension .idx.
1
Leave the filename of the data file the same. For the index file, add the extension .idx.
2
For the data file, add the extension .dat. For the index file, add the extension .idx.

Properties:

Default: 0

Comments:

IDXNAMETYPE only affects the data file for Vision files.

The name of the index file (if present) is derived from that of the data file. For example, if the data file name presented to the File Handler is abc.def, the options shown above give the following data and index filenames:

0 | abc.def and abc.idx
1 | abc.def and abc.def.idx
2 | abc.def.dat and abc.def.idx
Parent topic: Configuration File Options


IGNORELOCK

The IGNORELOCK option specifies whether to ignore locks when reading files open for input.

Syntax:

IGNORELOCK = { ON } { OFF }

Parameters:

ON
Ignore locks when reading files open for input.
OFF
Do not ignore locks when reading files open for input.

Properties:

Default: OFF
Parent topic: Configuration File Options


INDEXCOUNT

The INDEXCOUNT option specifies the number of index nodes to be cached for an indexed file.

Syntax:

INDEXCOUNT = node-count

Parameters:

node-count
The number of nodes to be cached. Can be any value between 4 and 255.

Properties:

Default: 16
Parent topic: Configuration File Options


INDEXFILE

The INDEXFILE option maps the name of the index file (for those indexed file formats that have a separate index file). This name can include full path information.

Syntax:

INDEXFILE = name

Parameters:

name
The name of the index file.

Properties:

Default: The name of the index file is derived from the name of the data file by adding the extension .idx (see also IDXNAMETYPE).
Parent topic: Configuration File Options
Related information
IDXNAMETYPE


INSERTNULL

When performing WRITE or REWRITE operations on line sequential or line advancing files, the INSERTNULL option determines whether to insert NULL (x"00") characters before non-printable characters. The option also determines whether to strip out those NULL characters during READ operations.

Syntax:

INSERTNULL = { ON } { OFF }

Parameters:

ON
Insert NULL characters before non-printable characters. Strip out NULL characters during READ operations.
OFF
Do not insert NULL characters before non-printable characters. Do not strip out NULL characters during READ operations.

Properties

Default: ON

Comments:

INSERTNULL takes precedence over the N run-time switch.

If you do not set INSERTNULL, the setting of the N run-time switch determines whether or not NULL characters are inserted before non-printable characters.

Parent topic: Configuration File Options


INSERTTAB

When performing WRITE or REWRITE operations on line sequential or line advancing files, the INSERTTAB option determines whether to replace sequences of spaces with TAB characters.

Syntax:

INSERTTAB = { ON } { OFF }

Parameters:

ON
Replace sequences of spaces with TAB characters.
OFF
Do not replace sequences of spaces with TAB characters.

Properties:

Default: OFF

Comments:

The setting of the T switch can affect the default setting.

Parent topic: Configuration File Options
Related information
EXPANDTAB


KEYCHECK

The KEYCHECK option specifies whether the File Handler checks that the key definition defined in your application matches that of the indexed file you are opening.

Syntax:

KEYCHECK = { ON } { OFF }

Parameters:

ON
All key definitions must match; otherwise a 3/9 error is returned.
OFF
Open the file, regardless of whether key definitions match or not. Any explicit reference, in the program, to a key which does not match an actual key in the file,results in an error at the time of reference.

Properties:

Default: ON
Parent topic: Configuration File Options


KEYCOMPRESS

The KEYCOMPRESS option specifies the type of key compression in use.

Syntax:

KEYCOMPRESS = integer

Parameters:

0
Key compression is not in use.
1
Duplicater key compression is in use.
2
Leading character compression is in use.
4
Trailing space compression is in use.
8
Trailing null compression is in use.

Properties:

Default: 0

Comments:

To specify a combination of the various types of compression, add together the appropriate numbers. For example, 3 specifies duplicate key compression and leading character compression.

Note:
  • Trailing space compression and trailing null compression are mutually exclusive.
  • The KEYCOMPRESS parameter affects key compression for all indexes belonging to the file.
Parent topic: Configuration File Options
Related information
Key Compression


LOADONTOHEAP

The LOADONTOHEAP option specifies whether the File Handler loads the file into memory before executing any I/O operations.

Syntax:

LOADONTOHEAP = { ON } { OFF }

Parameters:

ON
The File Handler loads the entire file into memory when it opens the file, executes I/O operations on the file in memory, and writes the file back to disk when it is closed.
OFF
The File Handler leaves the file on disk and executes I/O operations on the file on disk.

Properties:

Default: 0FF

Comments:

  • You can set LOADONTOHEAP to ON only for non-shared files.
  • You should use the ON setting with care and only on small files.
Parent topic: Configuration File Options


LOCKTYPE

The LOCKTYPE option specifies the type of record locking in use.

Syntax:

LOCKTYPE = integer

Parameters:

0
Programs can read locked records, but cannot access them in other ways. This is the standard method with this COBOL system.
1
Programs cannot access locked records at all. This is as in languages other than COBOL.
2
Creates a new file with the same base name as the file being opened but with a .lck extension. Any record locks are recorded in this file.

Properties:

Default: 0
Parent topic: Configuration File Options


LOG

When LOG is set to ON, any unusual file-related situations, such as corrupted files, or automatic file recovery, are noted in a log file for later examination.

Syntax:

LOG = { ON } { OFF }

Parameters:

ON
Set logging on either for the individual file or, if specified under the [XFH-DEFAULT] tag, for all files.
OFF
Do not set logging on.

Properties:

Default: ON
Parent topic: Configuration File Options
Related information
LOGFILENAME


LOGFILENAME

When the LOG option is active, the LOGFILENAME option specifies the name of the log file to produce.

Syntax:

LOGFILENAME = name

The log file lists any unusual file-related situations, such as corrupted files, or automatic file recovery. Contact technical support if you need more information regarding the contents of the file.

Parameters:

name
Name of the log file.

Properties:

Default: XFHLOG

Comments:

This option can be set globally only, that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Use the program cobfhprint to create and display a text version of the log file:

cobfhprint filename
Parent topic: Configuration File Options


LSFILETERM

The option controls the behavior of the File Handler upon encountering the EOF character x"1a" when reading line sequential files.

Syntax:

LSFILETERM = { ON } OFF

Parameters:

ON
Interpret x"1a" characters as EOF markers.
OFF
Ignore EOF characters and continue reading until the physical end of file.

Properties:

Default: ON

Comments:

This option corresponds to bit h"10" of the fcd-flags-2 field in the File Control Description (FCD).

Parent topic: Configuration File Options


LSRECDELIM

The LSRECDELIM option specifies the characters to be used as the record delimiter in line sequential files.

Syntax:

LSRECDELIM = { 0A } { 0D0A }

Parameters:

0A
The hexadecimal character x"0A" is used as the record delimiter for line sequential files.
0D0A
The hexadecimal characters x"0D0A" are used as the record delimiter for line sequential files.

Properties:

Default: 0D0A.
Parent topic: Configuration File Options


MAINFRAMEPRINT

For those files using WRITE AFTER ADVANCING or WRITE BEFORE ADVANCING, the MAINFRAMEPRINT option determines whether to use mainframe printer file format (filetype 11).

Syntax:

MAINFRAMEPRINT = { ON } { OFF }

Parameters:

ON
Use mainframe printer file format.
OFF
Do not use mainframe printer file format.

Properties:

Default: OFF
Parent topic: Configuration File Options


NAMEOPTIONS

The NAMEOPTIONS option specifies whether the name you pass to the OPEN statement can contain File Handler options.

Syntax:

NAMEOPTIONS = { ON } { OFF }

Parameters:

ON
The name you pass to the OPEN statement can contain File Handler options enclosed in round or square brackets. For example:
fil1[PRINTER]
OFF
The name you pass to the OPEN statement cannot contain File Handler options.

Properties:

Default: OFF

Comments:

If set to OFF, the brackets and the characters they enclose are considered as part of the file name.

Note:
  • This parameter can be set globally only; that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.
  • This parameter is provided for compatibility with older products - you should use it only if you require compatibility with Micro Focus Workbench V4.0.
Parent topic: Configuration File Options


NFSFILELOCK

The NFSFILELOCK option enables applications to detect record locks and file locks on UNIX NFS file systems.

Syntax:

NSFILELOCK = { ON } { OFF } { HP }

Parameters:

ON
Enables programs to detect record and file locks on UNIX NFS file systems.
OFF
Windows applications cannot detect record and file locks on UNIX NFS systems.
HP
Specify HP if you are accessing Hewlett-Packard systems.

Properties:

Default: OFF
Parent topic: Configuration File Options


NODESIZE

The NODESIZE option specifies the size of the index nodes to use for an indexed file.

Syntax:

NODESIZE = size_of_node

Parameters:

size_of_node
Use the following minimum NODESIZE values depending on the length of your keys:
Key Length in Bytes | Minimum NODESIZE Value in Bytes
Less than 51 | 512
51 through 100 | 1024
101 through 512 | 4096
513 through 4080 | 16384

Properties:

Default: The minimum NODESIZE value for the key length, except that for key lengths less than 50 bytes, the default is 1024.

Comments:

In most circumstances you should allow the File Handler to work out the appropriate default node size. However, if file size is an issue, smaller node sizes do result in a smaller index file, but you should be aware that they also increase processing time as the tree depth is greater.

Parent topic: Configuration File Options


NOSEQCHECK

The NOSEQCHECK option disables sequence-checking of keys in indexed files.

Setting this option ON enables records to be written in any order to indexed files opened in sequential access mode. Otherwise records must be written in ascending order of prime key.

Syntax:

NOSEQCHECK = { ON } { OFF }

Parameters:

ON
Do not check the sequence of prime keys when writing to an indexed file with ACCESS SEQUENTIAL.
OFF
Return status 21 if prime keys are written out of sequence to an indexed file with ACCESS SEQUENTIAL.

Properties:

Default: OFF

Comments:

Note:

Micro Focus strongly suggest that you control the order in which records are written to indexed files within the program itself, by using the ACCESS SEQUENTIAL or ACCESS DYNAMIC syntax, and avoid using the NOSEQCHECK configuration option.

Parent topic: Configuration File Options


OPENINPUTSHARED

The OPENINPUTSHARED option specifies whether files that you open for input, and for which you do not specify a LOCK MODE clause, can be shared by other users.

Syntax:

OPENINPUTSHARED = { ON } { OFF }

Parameters:

ON
Other users can have the file open for INPUT only.
OFF
The system behaves as if you are specifying LOCK MODE IS MANUAL for the file. That is, other users can have the file open for I-O, provided they specify a LOCK MODE for the file.

Properties:

Default: OFF
Parent topic: Configuration File Options


OSVSREWRITE

The OSVSREWRITE option specifies whether to permit the WRITE statement for sequential files that are open for output. If so, these WRITE statements behave exactly like REWRITE statements.

Syntax:

OSVSREWRITE = { ON } { OFF }

Parameters:

ON
Permit the WRITE statement for sequential files that are open for output.
OFF
Do not permit the WRITE statement for sequential files that are open for output.

Properties:

Default: OFF

Comments:

This parameter can be set globally only; that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Parent topic: Configuration File Options


READSEMA

The READSEMA option specifies whether the system attempts to gain a semaphore for shared files when I/O operations are performed that do not modify the file.

Syntax:

READSEMA = { ON } { OFF }

Parameters:

ON
Attempt to gain a semaphore for every file operation, including READ and START operations.
OFF
Do not attempt to gain a semaphore for shared files during operations such as READ and START.

Properties:

Default: OFF

Comments:

Where a file is being read by multiple users, to improve throughput set this parameter to OFF.

Parent topic: Configuration File Options


READTODELIM

The READTODELIM option specifies whether the file pointer is advanced to the next logical record in the file when reading in a record that is longer than the user data area. In these circumstances, the data record would effectively be truncated.

The option affects only line sequential files.

Syntax:

READTODELIM = { ON } { OFF }

Parameters:

ON
Records are truncated to the length of the user record area if necessary.
OFF
The file pointer is not advanced to the next logical record so one logical record might require several READs to consume it.

Properties:

Default: OFF
Parent topic: Configuration File Options


RELDATBUF

The RELDATBUF option determines the size of buffer used when accessing a file with organization RELATIVE.

Syntax:

RELDATBUF = { integer } { 0 }

Parameters:

integer
Round up the value that you enter to the next power of 2 that is greater or equal.
0
Do not use buffering.

Properties:

Default: 4096

Comments:

A non-zero value can be beneficial in the following circumstances:

  • While you are creating the file.
  • When most of the access to the file is sequential.

However, in other cases there is likely to be no performance gain. In fact, performance may be degraded.

Parent topic: Configuration File Options


RELRECDELIM

The RELRECDELIM option specifies the characters to be used as the record delimiter in fixed-length relative files.

Syntax:

RELRECDELIM = { 0A } { 0D0A }

Parameters:

0A
The hexadecimal character x"0A" is used as the record delimiter for fixed-length relative files.
0D0A
The hexadecimal characters x"0D0A" are used as the record delimiter for fixed-length relative files.

Properties:

Default: 0D0A.
Parent topic: Configuration File Options


RETRYLOCK

The RETRYLOCK option indicates whether you wish to retry a READ operation that fails because the record is locked.

Syntax:

RETRYLOCK = { ON } { OFF } { NOSTATUS } { integer }

Parameters:

ON
Retry the operation until no lock is encountered.
OFF
Do not attempt a retry.
NOSTATUS
Retry the operation for those files for which no status field is defined.
integer
Specify the number of attempts or the number of seconds for which you wish to retry the operation before a locked record status is returned. The RETRYTIME option controls the meaning of integer; for more information see the topic RETRYTIME.

Properties:

Default: OFF
Parent topic: Configuration File Options
Related information
RETRYTIME


RETRYOPEN

The RETRYOPEN option indicates whether you wish to retry an I/O operation that fails because the file is locked.

Syntax:

RETRYOPEN = { ON } { ON } { integer }

Parameters:

ON
Retry the operation until no lock is encountered.
OFF
Do not attempt a retry.
integer
Specify the number of attempts or the number of seconds for which you wish to retry the operation before a locked record status is returned. The RETRYTIME option controls the meaning of integer; for more information see the topic RETRYTIME

Properties:

Default: OFF
Parent topic: Configuration File Options
Related information
RETRYTIME


RETRYTIME

The RETRYTIME option specifies whether the integer given in the RETRYLOCK and RETRYOPEN options specifies the number of attempts or the number of seconds.

Syntax:

RETRYTIME = { ON } { OFF }

Parameters:

ON
The integer specifies the number of seconds.
OFF
The integer specifies the number of attempts.

Properties:

Default: OFF
Parent topic: Configuration File Options
Related information
RETRYLOCK
RETRYOPEN


RUNITLOCKDETECT

The RUNITLOCKDETECT option specifies whether the File Handler checks whether a record has been locked by a separate OPEN statement issued from within the same run unit.

Syntax:

RUNITLOCKDETECT = { ON } { OFF }

Parameters:

ON
Detect record locks.
OFF
Do not detect record locks.

Properties:

Default: ON

Comments:

Locks set within a given run unit are detected, even if RUNITLOCKDETECT is on, if this is supported by the operating system.

Parent topic: Configuration File Options


SEARCHONCREATE

The SEARCHONCREATE parameter determines whether the File Handler searches each specified directory on a multi-directory path for a file with the same name as the one being created. This option applies only to files which are opened with OPEN OUTPUT.

Syntax:

SEARCHONCREATE = { ON } { OFF }

Parameters:

ON
The path will be searched for the file and, if found, the directory where it is found will be used for the creation of the new file.
OFF
The file will be created in the first directory on the search path.

Properties:

Default: OFF

Comments:

This parameter can be set globally only, that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Parent topic: Configuration File Options


SEQDATBUF

The SEQDATBUF option determines the size of buffer to use when accessing a file with organization SEQUENTIAL.

Syntax:

SEQDATBUF = integer

Parameters:

integer
Round up the value that you enter to the next power of 2. The minimum value is 4096.

Properties:

Default: 4096
Parent topic: Configuration File Options


SKIPLOCK

The SKIPLOCK option specifies whether to advance the current record pointer when a locked record is encountered during a sequential READ.

Syntax:

SKIPLOCK = { ON } { OFF }

Parameters:

ON
Advance the current record pointer when a locked record is encountered.
OFF
Do not advance the current record pointer.

Properties:

Default: OFF
Parent topic: Configuration File Options


SPACEFILL

The SPACEFILL option determines whether to fill with spaces that part of the record area beyond the data that is read when performing READ operations on line sequential or line advancing files.

Syntax:

SPACEFILL = { ON } { OFF }

Parameters:

ON
Fill the area with spaces.
OFF
Do not fill the area with spaces.

Properties:

Default: ON
Parent topic: Configuration File Options


STARTUNLOCK

The STARTUNLOCK option determines whether a START operation will remove existing locks for files specified with single record locking; that is, without the WITH LOCK ON MULTIPLE RECORDS phrase.

Syntax:

STARTUNLOCK = { ON } { OFF }

Parameters:

ON
A START operation will clear any existing lock for files specified with single record locking.
OFF
A START operation will not clear any existing lock for files specified with single record locking.

Properties:

Default: OFF

Comments:

This option is provided only for compatibility. Micro Focus recommend you do not change it.

Parent topic: Configuration File Options


STRIPSPACE

The STRIPSPACE parameter determines whether to remove trailing space characters when performing WRITE or REWRITE operations on line sequential or line advancing files.

Syntax:

STRIPSPACE = { ON } { OFF }

Parameters:

ON
Remove trailing space characters when performing WRITE or REWRITE operations on line sequential or line advancing files.
OFF
Do not remove trailing space characters when performing WRITE or REWRITE operations on line sequential or line advancing files.

Properties:

Default: ON
Parent topic: Configuration File Options


SUPPRESSADV

The SUPPRESSADV option determines whether to ignore the ADVANCING phrase of the WRITE statement for record sequential files.

Syntax:

SUPPRESSADV = { ON } { OFF }

Parameters:

ON
Ignore the ADVANCING phrase of the WRITE statement for record sequential files.
OFF
Do not ignore the ADVANCING phrase of the WRITE statement for record sequential files.

Properties:

Default: OFF
Parent topic: Configuration File Options


TRACE

The TRACE option specifies whether Xfhtrace, the File Handler trace module, is enabled. The Xfhtrace module traces File Handler operations and logs all activity to a trace file. It is supplied to help you diagnose any problems you may have with COBOL files.

Syntax:

TRACE = { ON } { OFF }

Parameters:

ON
Set tracing on either for the individual file or, if specified under the [XFH-DEFAULT] tag, for all files.
OFF
Do not produce a trace file.

Properties:

Default: OFF
Parent topic: Configuration File Options


TRACEFILEEXTEND

The TRACEFILEEXTEND option determines whether to write trace information to the end of the current trace file, if the trace file already exists. This option has no effect if TRACE is OFF.

Syntax:

TRACEFILEEXTEND = { ON } { OFF }

Parameters:

ON
Extend existing trace file when File Handler is first invoked.
OFF
Overwrite existing trace file when File Handler is first invoked.

Properties:

Default: OFF

Comments:

This parameter can be set globally only, that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Parent topic: Configuration File Options


TRACEFILENAME

The TRACEFILENAME option specifies the name of the trace file to produce when the TRACE option is active.

Syntax:

TRACEFILENAME = filename

Parameters:

filename
Name of the trace file.

Properties:

Default: XFHTRACE.XFH

Comments:

This parameter can be set globally only; that is under the tag [XFH-DEFAULT]. You cannot set the parameter for an individual file.

Parent topic: Configuration File Options


USEVSAMKEYDEFS

Use the keys defined in the catalog via the JCL and IDCAMS instead of the keys defined in the executing program.

Syntax:

USEVSAMKEYDEFS = { ON } { OFF }

Parameters:

ON
Use the catalog's key definitions.
OFF
Use executing program's key definitions.

Properties:

Default: ON
Parent topic: Configuration File Options


WRITELINE

The WRITELINE parameter determines whether mainframe or PC behavior is used for WRITE record.

Syntax:

WRITELINE = { ON } { OFF }

Parameters:

ON
Mainframe behavior is used for WRITE record.
OFF
PC behavior is used for WRITE record.

Properties:

Default: OFF

Comments:

Set WRITELINE=OFF if you want PC print behavior for WRITELINE when using mainframe dialects.

Parent topic: Configuration File Options


WRITETHRU

The WRITETHRU option determines whether modifications to a file are written out to disk immediately or buffered internally, either by the COBOL system or by the operating system, and flushed to disk at a later stage.

Syntax:

WRITETHRU = { ON } { OFF }

Parameters:

ON
Write out all modifications to disk immediately.
OFF
Flush modifications later.

Properties:

Default: OFF

Comments:

You can obtain greater security, at the cost of significantly reduced performance, by setting this parameter to ON.

Parent topic: Configuration File Options


Data Structures

  • File Control Description (FCD)
  • Global Information Area
  • Key Definition Area
  • Component Definition Area
Parent topic: File Handler


File Control Description (FCD)

The fields contained in the FCD are shown in the following table. The fields do not necessarily appear in this order; the order is defined in the copybook or xfhfcd3.cpy. For flags, the description refers to when the bit is set on. Bit 7 is the most significant (leftmost) bit. Unused bits are reserved for future use.

Refer to the Operation Codes section to display details of how each operation uses these fields.
fcd-file-status (fcd-status-key-1, fcd-status-key-2)
Type: pic x
User file status. After every operation except a COMMIT or ROLLBACK operation, this field is updated with a standard file status value telling you the status of the operation. See also fcd-access-mode and fcd-status-type.
fcd-length
Type: pic xx comp-x
Reserved. Must be set to binary zeros.
fcd-version
Type: pic x comp-x
Version number. Values can be:
0 | FCD2
1 | FCD3
fcd-organization
Type: pic x comp-x
File organization. Values can be:
0 | Line sequential
1 | Sequential
2 | Indexed
3 | Relative
fcd-access-mode
Type: pic x comp-x
User status and access mode indicators.

User status is indicated by bit 7. The bit is set if you have defined a file status. Defining a file status can affect how some operations (such as RETRYLOCK) are performed. When calling the File Handler directly, this bit should be set. However, file status is obtained directly from fcd-file-status.

Access mode is indicated by bits 6 through 0:

0 | Sequential access mode
4 | Random access mode
8 | Dynamic access mod
fcd-open-mode
Type: pic x comp-x
Open mode:
0 | INPUT
1 | OUTPUT
2 | I/O
3 | EXTEND
128 | File is closed

You must set this field to 128 before opening a file.

fcd-recording-mode
Type: pic x comp-x
Recording mode:
0 | Fixed
1 | Variable
fcd-file-format
Type: pic x comp-x
File format:
0 | Default format
1 | C-ISAM
2 | Level II V2.5 COBOL
3 | IDXFORMAT"3"
4 | IDXFORMAT"4"
5 | btrieve-ansi
6 | btrieve-non-ansi
8 | IDXFORMAT"8"
11 | Mainframe print file
14 | Heap file
15 | ESDS
fcd-device-flag
Type: pic x comp-x
Device flag:
0 | Normal
1 | Device
2 | Stdin
3 | Stdout
4 | stderr
5 | Badname
6 | Input pipe
7 | Output pipe
8 | I/O pipe
9 | Library
10 | Disk file
11 | Null
12 | Disk redir
13 | No map
fcd-lock-action
Type: pic x comp-x
Reserved.
fcd-data-compress
pic x comp-x
Data compression routine indicator:
0 | No compression
1-127 | Micro Focus data compression routine number (1= CBLDC001)
128 -255 | User-defined data compression routine number (128=USRDC128)
fcd-blocking
Type: pic x comp-x
Node length in bytes:
0 | Node length determined by system
1 | 512
2 | 1024
4 | 4096
6 | 16384
fcd-idxcache-size
Type: pic x comp-x
Number of index nodes held in cached memory. The number specified should be between 4 and 255. When set to 0, a default of 16 is used.
fcd-percent
Type: pic x comp-x
Percentage indicator
fcd-block size
Type: pic x comp-x
Block size for data records in bytes:
0 | No blocking
12 | 4096
13 | 8192
14 | 16384
15 | 32768
16 | 65536

For indexed and relative files, non-zero settings can degrade performance.

fcd-flags-1
Type: pic x comp-x
Bit 7 | Mainframe compatibility bit. When set, file characteristics are not required to match those specified in program.
Bit 5 | READ and START operations will return the key (only) in the record area
Bit 1 | TRACE=ON
Bit 0 | Reserved
fcd-flags-2
pic x comp-x
Bit 0 sets CONVERTDBSPACE=ON
fcd-mvs-flags
pic x comp-x
Mainframe emulation flags
Bit 2 | File is implicit file (ACCEPT or DISPLAY)
Bit 1 | AMODE(31) is on
Bit 0 | AMODE(24) is on
fcd-status-type
pic x comp-x
Status type:
Bit 7 | Set on for ANSI'85 COBOL file status by default, set off for ANSI'74 COBOL file status
Bit 6 | SPACEFILL=OFF
Bit 5 | STRIPSPACE=OFF
Bit 4 | EXPANDTAB=OFF
Bit 2 | INSERTTAB=ON
Bit 1 | INSERTNULL=ON
Bit 0 | Reserved

Bits 1 and 2 are set or unset by the File Handler at open time, depending on the settings of the N and T RTS switches. These bits can be set or unset after an OPEN operation to override the N and T RTS switches. Bit 3 means 'Use the other sort of line sequential record delimiter'.

fcd-other-flags
Type: pic x comp-x
Bit 7 | OPTIONAL file (OPEN INPUT)
Bit 6 | IGNORELOCK=ON
Bit 5 | Not OPTIONAL (OPEN I/O and EXTEND)
Bit 4 | Filename is EXTERNAL
Bit 3 | Reserved
Bit 2 | NODETECTLOCK directive enabled
Bit 1 | Multiple reel file (record sequential)
Bit 0 | Line advancing file (record sequential)
fcd-trans-log
Type: pic x comp-x
Bit 7 | OPENINPUTSHARED=ON
Bit 5 | READSEMA=OFF
Bit 4 | EXPANDPOSITIONING=ON
Bit 1 | FASTREAD=OFF
Bit 0 | SUPPRESSADV=ON
fcd-lock-types
Type: pic x comp-x
Bit 7 | Interlanguage locking (LOCKTYPE 1 or 2)
Bit 6 | SHARING WITH READ ONLY
Bit 5 | Separate lock file (LOCKTYPE 2)
Bit 4 | RUNITLOCKDETECT=OFF
Bit 3 | Use NFS file locking
Bit 2 | Use NFS file locking with HP compatibility
fcd-fs-flags
Type: pic x comp-x
Fileshare flags:
Bit 7 | Transaction logging
Bit 3 | Trace OPEN and CLOSE operations
fcd-config-flags
Type: pic x comp-x
Bit 7 | WRITETHRU
Bit 6 | Use relative byte address
Bit 5 | Update current record pointer
Bit 4 | For FCD2 use fcd-reladdr-big for relative byte address instead of fcd-reladdr-offset
Bit 1 | Call status conversion routine
Bit 0 | Set if IGNORELOCK required
fcd-misc-flags
Type: pic x comp-x
Miscellaneous flags:
Bit 7 | HOSTFD option (record areas allocated at OPEN time)
Bit 1 | File defined with EXTERNAL syntax
Bit 0 | File closed with lock
fcd-config-flags2
Type: pic x comp-x
Bit 7 | Use EBCDIC collating sequence
Bit 6 | Set if file is to have WRITE AFTER ADVANCING
Bit 5 | Set if file is to have WRITE BEFORE ADVANCING
Bit 4 | ADV specified
Bit 3 | Ignore minimum length checking on variable-length files
fcd-lock-mode
Type: pic x comp-x
Lock mode flags for shareable files:
Bit 7 | Lock on multiple records
Bit 6 | WRITELOCK directive enabled
Bit 5 | RETRYOPEN=ON
Bit 4 | SKIPLOCK =ON
Bit 3 | RETRYLOCK=ON
Bit 2 | Lock mode MANUAL
Bit 1 | Lock mode AUTOMATIC
Bit 0 | Lock mode EXCLUSIVE
fcd-shr2
Type: pic x comp-x
Miscellaneous flags:
Bit 1 | RETRYTIME=ON
Bit 0 | STARTUNLOCK=ON
fcd-nls-id
Type: pic xx comp-x
NLS identifier
fcd-fs-file-id
Type: pic xx comp-x
Reserved
fcd-retry-open-count
Type: pic xx comp-x
RETRYOPEN count field
fcd-name-length
Type: pic xx comp-x
Length of filename
fcd-idxname-length
Type: pic xx comp-x
Reserved
fcd-retry-count
Type: pic xx comp-x
Retry count (used when RETRYLOCK is on)
fcd-key-id
Type: pic xx comp-x
Key-of-reference (indexed files), used for random READ operations. To specify the prime key, set this field to zero. For example, to specify the first alternate key defined, use a value 1; the second alternate key defined use value 2.
fcd-line-count
Type: pic xx comp-x
Line count (sequential files): the number of lines to skip when writing a file. For example:

WRITE AFTER ADVANCING line-count LINES

fcd-use-give
Type: pic xx comp-x
Reserved
fcd-key-length
Type: pic xx comp-x
Effective key length. When using a START operation on indexed files, you can specify only the leading part of a key instead of the whole key. You should set this field to the number of bytes to be used in the comparison. It must be greater than zero, and no bigger than the key being used.
fcd-current-rec-len
Type: pic x(2) comp-x for FCD2; pic x(4) comp-x for FCD3
Current record length (in bytes)
fcd-min-rec-length
Type: pic x(4) comp-x
Minimum record length (in bytes)
fcd-max-rec-length
Type: pic x(4) comp-x
Maximum record length (in bytes)
fcd-session-id
Type: pic x(4) comp-x
Reserved
fcd-reladdr-offset
Type: pic x(4) comp-x for FCD2; pic x(8) comp-x for FCD3
Relative byte address. (See also fcd-config-flags, bit 4). The value of this field is undefined following the OPEN statement.
fcd-reladdr-big
Type: pic x(8) comp-x
An eight-byte relative byte address. For FCD2, this is a separate field. For FCD3, it redefines fcd-reladdr-offset. Provided for compatibility between FCD2 and FCD3.
fcd-max-rel-key
Type: pic x(8) comp-x
Maximum size of relative key
fcd-relative-key
Type: pic x(8) comp-x
Relative key.

This field is also used, for indexed files, to hold the number of records in the file. It is set following an OPEN.

fcd-handle
Type: pointer
File handle
fcd-record-address
Type: pointer
Pointer to the record area
fcd-filename-address
Type: pointer
Pointer to the filename area
fcd-idxname-address
Type: pointer
Reserved
fcd-key-def-address
Type: pointer
Pointer to key definition block
fcd-col-seq-address
Type: pointer
Pointer to a collating sequence (null if none is used)
fcd-fildef-address
Type: pointer
Reserved
fcd-dfsort-address
Type: pointer
Reserved
Parent topic: Data Structures
Related information
Operation Codes


Global Information Area

All unused or reserved areas must be initialized to binary zeros.

Offset | Type | Description of the Field
0 | pic xx comp-x | Length of the key definition block
2 | pic xxxx comp-x | Reserved
6 | pic xx comp-x | Number of keys
8 | pic xxxxxx comp-x | Reserved
Parent topic: Data Structures


Key Definition Area

All unused or reserved areas must be initialized to binary zeros.

Offset | Type | Description of the Field
0 | pic xx comp-x | Component count. For ordinary keys, the component count is 1. For split keys, the component count is the number of components making up the split key.
2 | pic xx comp-x | Offset to first component definition area for this key. This offset is relative to the start of the global information area, starting at 0.
4 pic x comp-x Key flags:
  • Bit 7 - Reserved
  • Bit 6 - Duplicates allowed
  • Bit 5 - Reserved
  • Bit 4 - Set to indicate that this is the prime key. If this is not set for any key, the File Handler assumes that the first key is the prime key.
  • Bit 3 - Reserved
  • Bit 2 - Reserved
  • Bit 1 - Sparse key. See offset 6.
  • Bit 0 - Reserved
5 pic x comp-x Compression flags:
  • Bits 7 - 4 Reserved
  • Bit 3 - Compression of trailing nulls
  • Bit 2 - Compression of trailing spaces
  • Bit 1 - Compression of leading characters
  • Bit 0 - Compression of duplicates
6 | pic x comp-x | Sparse character. If bit 1 of the key flags (offset 4) is set, the key is suppressed if it is entirely made up of this character.
7 | pic x(9) comp-x | Reserved
Parent topic: Data Structures


Component Definition Area

All unused or reserved areas must be initialized to binary zeros.

Offset | Type | Description
0 pic x comp-x
  • bit 7 (x"80") indicates duplicates to be returned in order
  • bit 6 (x"40") indicates DESCENDING key component
This byte is valid only if you compiled the program used to create the file with IXNUMKEY.
1 | pic x comp-x | bit 7 (x"80") indicates that the field is NUMERIC
If bit 7 is set (numeric):
  • bit 6 (x"40") indicates that the field is SIGNED NUMERIC
  • bit 6 (x"40") indicates that the field is SIGNED NUMERIC
  • bit 5 (x"20") indicates that the field is a non-display field.
If bit 7 is set and 5 is set (non-DISPLAY field), bits 0 and 1 are used as follows:
  • 0 - indicates that the field is BINARY
  • 1 - indicates that the field is PACKED-DECIMAL
  • 2 - indicates that the field is COMP-X format
  • 3 - indicates that the field is COMP-5 format
  • bit 2 (value x"04") indicates floating point
If bit 7 is set and bit 5 is not set, (DISPLAY field) but bit 6 is set (SIGNED), bits 0 and 1 are used as follows:
  • 0 - indicates SIGN TRAILING INCLUDED
  • 1 - indicates SIGN TRAILING SEPARATE
  • 2 - indicates SIGN LEADING INCLUDED
  • 3 - indicates SIGN LEADING SEPARATE
If bit 7 is not set (non-numeric):
  • Bit 1 is set if the collating sequence specified in the FCD is to be applied to this field.
2 | pic xxxx comp-x | Offset of component in the record (starting at 0).
6 | pic xxxx comp-x | Length of the component (in bytes).
Parent topic: Data Structures


Operation Codes

  • Standard Operation Codes
  • Special Operation Codes
Parent topic: File Handler


Standard Operation Codes

Not all operation codes are appropriate with all file organizations. Each operation code description includes a list of the file organizations for which it is valid.

  • Standard Operation Codes - Overview
  • CLOSE
  • COMMIT
  • DELETE
  • DELETE FILE
  • OPEN
  • READ
  • REWRITE
  • ROLLBACK
  • START
  • STEP
  • UNLOCK
  • WRITE
Parent topic: Operation Codes


Standard Operation Codes - Overview

Standard operation codes contain x"FA" in the most significant byte. The least significant byte indicates the specific operation.

CLOSE | Terminates the processing of a file.
COMMIT | Releases all record locks in all files held by a run unit.
DELETE | Logically removes a record from a file.
DELETE FILE | Physically removes the specified file from the physical devices on which it resides.
OPEN | Initiates the processing of files. It also performs checking and/or writing of labels and other I/O operations.
READ | For sequential access, makes available the next or previous logical record from a file. For random access, makes available a specified record from a disk file.
ROLLBACK | Releases all record locks in all files held by a run unit.
START | Provides a basis for logical positioning in a relative or indexed file, for subsequent retrieval of records.
STEP | Steps to the next physical record.
UNLOCK | Releases all record locks held by a run unit on a named file.
WRITE | Writes a new record to a file.
REWRITE | Replaces an existing record.

Not all operation codes are appropriate with all file organizations. Each operation code description includes a list of the file organizations for which it is valid, using the following key:

L | Line sequential
S | Record sequential (including vS)
R | Relative (including vR)
I | Indexed
vS | Record sequential variable format only
vR | Relative variable format only
Parent topic: Standard Operation Codes


CLOSE

Terminates the processing of files and reels/units with optional rewind and locking where appropriate. For record sequential files, the terms "reel" and "unit" are interchangeable; the treatment of sequential disk files is logically equivalent to the treatment of a file on tape or similar sequential media.

Opcode | Operation | File Type
80 | CLOSE | L S R I
81 | CLOSE WITH LOCK | L S R I
82 | CLOSE WITH NO REWIND | L S
84 | CLOSE REEL/UNIT | L S
85 | CLOSE REEL/UNIT FOR REMOVAL | L S
86 | CLOSE REEL/UNIT WITH NO REWIND | L S

Input Fields

None

Output Fields

fcd-file status File status
Parent topic: Standard Operation Codes


COMMIT

Releases all record locks in all files held by this run unit.

Opcode | Operation | File Types
DC | COMMIT (Unlock all files) | L S R I

Input Fields

None

Output Fields

None

Comments

This operation code requires an FCD for one of the files, but it can be completely empty.

Parent topic: Standard Operation Codes


DELETE

Logically removes a record from a disk file.

Opcode | Operation | File Types
F7 | DELETE | vS R I

Input Fields

fcd-relative-key | Relative key of record to remove (R)
fcd-record-address | Pointer to the record area of the record to remove (I)

Output Fields

fcd-file status File status
Parent topic: Standard Operation Codes


DELETE FILE

Physically removes the specified file from the physical devices on which it resides.

Opcode | Operation | File Types
F8 | DELETE FILE | L S R I

Input Fields

Filename area |
fcd-organization | File organization
fcd-name-length | Filename length
fcd-file-format | File format
fcd-filename-address | Pointer to the filename area

Output Fields

fcd-file status File status
Parent topic: Standard Operation Codes


OPEN

Initiates the processing of a file. It also performs checking and writing of labels and other I/O operations.

Opcode | Operation | File Types
00 | OPEN INPUT | L S R I
01 | OPEN OUTPUT | L S R I
02 | OPEN I-O | L S R I
03 | OPEN EXTEND | L S R I
04 | OPEN INPUT WITH NO REWIND | L S
05 | OPEN OUTPUT WITH NO REWIND | L S
08 | OPEN INPUT REVERSED | L S

Input Fields

Filename area |
Key definition block |
fcd-organization | File organization
fcd-access-mode | Access mode
fcd-open-mode | Open mode
fcd-name-length | Length of filename
fcd-lock-mode | Lock mode flags
fcd-other-flags | Other flags
fcd-file-format | File format
fcd-max-rec-length | Maximum record length
fcd-recording-mode | Recording mode
fcd-min-rec-length | Minimum record length
fcd-filename-address | Pointer to the filename area
fcd-key-def-address | Pointer to the key definition block (I)
fcd-data-compress | Data compression
fcd-locktypes | Type of file locks

Output Fields

fcd-file status | File status
fcd-open-mode | Open mode
fcd-handle | Pointer to the file; use for all subsequent accesses to this file

Comments

You must have set up a key definition block for this file if it is an indexed file.

You can assign several FCDs to the same physical file and have them all open at the same time. The operating system counts it as just one open file. The physical file is not closed until every logical file assigned to it has been closed.

Parent topic: Standard Operation Codes


READ

For sequential access, makes available the next or previous logical record from a file. For random access, makes available a specified record from a disk file.

Opcode | Operation | File Types
8D | READ(sequential) WITH NO LOCK | L S R I
D8 | READ (sequential) WITH LOCK | L S R I
D9 | READ (sequential) WITH KEPT LOCK | L S R I
F5 | READ (sequential) | L S R I
8C | READ PREVIOUS WITH NO LOCK | R I
DE | READ PREVIOUS WITH LOCK | R I
DF | READ PREVIOUS WITH KEPT LOCK | R I
F9 | READ PREVIOUS | R I
8E | READ (random) WITH NO LOCK | R I
DA | READ (random) WITH LOCK | R I
DB | READ (random) WITH KEPT LOCK | R I
F6 | READ (random) | R I
8F | READ (direct) WITH NO LOCK | L S R I
D6 | READ (direct) WITH LOCK | L S R I
D7 | READ (direct) WITH KEPT LOCK | L S R I
C9 | READ (direct) | L S R I
F1 | READ (position) | L S R I

Input Fields

fcd-relative-key | Relative record number (R) if READ random or direct
fcd-key-id | Key identifier (I)
fcd-record-address | Pointer to the record area

Output Fields

fcd-file status | File status
fcd-current-rec-len | Current record length
fcd-reladdr-offset or fcd-reladdr-big | Relative byte address
Parent topic: Standard Operation Codes


REWRITE

Replaces an existing record in a file.

Opcode | Operation | File Types
F4 | REWRITE | L S R I

Input Fields

cfd-relative-key | Relative record number (R)
fcd-current-rec-len | Current record length
fcd-record-address | Pointer to the record area

Output Fields

fcd-file-status | File status
fcd-reladdr-offset or fcd-reladdr-big | Relative byte address
Parent topic: Standard Operation Codes


ROLLBACK

Releases all record locks in all files held by this run unit.

Opcode | Operation | File Types
DD | ROLLBACK (unlocks all files) | L S R I

Input Fields

None

Output Fields

None

Comments

This operation code requires an FCD for one of the files, but it can be completely empty.

Parent topic: Standard Operation Codes


START

Provides a basis for logical positioning in a relative or indexed file, for subsequent retrieval of records.

Opcode | Operation | File Types
E8 | START equal to full length prime key | R I
E9 | START equal to (any key/record number) | R I
EA | START greater than (>) | R I
EB | START not less than (>=) | R I
FE | START less than (<) | R I
FF | START less than or equal to (<=) | R I

Input Fields

fcd-relative key | Relative record number (R)
fcd-key id | Key identifier (I)
fcd-key-length | Effective key length (I)
fcd-record-address | Pointer to the record area

Output Fields

fcd-file status File status
Parent topic: Standard Operation Codes


STEP

Steps to the next, previous, first or last physical record in the file . This operation enables very fast access to a record.

Opcode | Operation | File Types
90 | STEP NEXT WITH NO LOCK | L S R I
91 | STEP PREVIOUS WITH NO LOCK | L S R I
92 | STEP FIRST WITH NO LOCK | L S R I
93 | STEP LAST WITH NO LOCK | L S R I
CA | STEP NEXT | L S R I
CB | STEP PREVIOUS | L S R I
CC | STEP FIRST | L S R I
CD | STEP LAST | L S R I
CE | STEP LAST WITH LOCK | L S R I
CF | STEP LAST WITH KEPT LOCK | L S R I
D0 | STEP FIRST WITH LOCK | L S R I
D1 | STEP FIRST WITH KEPT LOCK | L S R I
D2 | STEP PREVIOUS WITH LOCK | L S R I
D3 | STEP PREVIOUS WITH KEPT LOCK | L S R I
D4 | STEP NEXT WITH LOCK | L S R I
D5 | STEP NEXT WITH KEPT LOCK | L S R I

Input Fields

fcd-record-address Pointer to the record area

Output Fields

fcd-file-status File status

Comments

STEP operations are a method of sequentially retrieving records in a relative or indexed file without having to read via a key or relative record number. Generally, this is a faster method of accessing data in the file.

A STEP NEXT operation returns the record that is physically stored immediately after the one that was last retrieved in the file (either by a STEP or READ operation).

A STEP PREVIOUS operation returns the record that is physically stored immediately before the one that was last retrieved in the file (either by a STEP or READ operation).

A STEP FIRST operation returns the record at the beginning of the file.

A STEP LAST operation returns the record at the end of the file.

If you are using relative byte addressing and you have specified that the current record pointer should be updated to the record you have just accessed, STEP operations are relative to this new position.

The relative byte address is returned on every STEP operation, so if you need to update the current record pointer to the record just retrieved, you can use the READ (direct) operation using the address returned.

Note:

The current record pointer is not affected by STEP operations.

Parent topic: Standard Operation Codes


UNLOCK

Releases all record locks held by the run unit on a named file.

Opcode | Operation | File Types
0E | UNLOCK | L S R I

Input Fields

None

Output Fields

fcd-file-status File status
Parent topic: Standard Operation Codes


WRITE

Writes a new record to a file.

For sequential files, it can also be used for vertical positioning of lines in a logical page.

Opcode | Operation | File Types
E1 | WRITE BEFORE | L S
E2 | WRITE AFTER | L S
E3 | WRITE BEFORE TAB | L S
E4 | WRITE AFTER TAB | L S
E5 | WRITE BEFORE PAGE | L S
E6 | WRITE AFTER PAGE | L S
EC | WRITE BEFORE mnemonic-name | S
ED | WRITE AFTER mnemonic-name | S
F3 | WRITE | L S R I

Input Fields

cfd-relative-key | Relative record number (R)
fcd-current-rec-len | Current record length
fcd-line-count | Line count (WRITE only) (S)
fcd-record-address | Pointer to the record area

Output Fields

fcd-file-status | File status
fcd-reladdr-offset or fcd-reladdr-big | Relative byte address
Parent topic: Standard Operation Codes


Special Operation Codes

Not all operation codes are appropriate with all file organizations. Each operation code description includes a list of the file organizations for which it is valid.

  • Special Operation Codes - Overview
  • File Information
  • Create Index File
  • Get Next Record
  • Add Key Value
  • Re-index File
  • Flush File
  • Unlock Record
Parent topic: Operation Codes


Special Operation Codes - Overview

Special operation codes contain x"00" in the most significant byte. The least significant byte indicates the specific operation.

File Information | Returns general file information for all file organizations with headers and, for indexed files, information on the file keys in the form of the Key Definition Block.
Get Next Record | Gets the next physical record from the data file part of an indexed file.
Add Key Value | Adds a key value to the index file part of an indexed file.
Re-index File | Re-indexes the file using a supplied key definition block.
Flush File | Flushes all data for a specific file to disk.
Unlock Record | Unlocks a specific record in a file.

Not all operation codes are appropriate with all file organizations. Each operation code description includes a list of the file organizations for which it is valid, using the following key:

L | Line sequential
S | Record sequential (including vS)
R | Relative (including vR)
I | Indexed
vS | Record sequential variable format only
vR | Relative variable format only
Parent topic: Special Operation Codes


File Information

Returns general file information for all file organizations with headers and, for indexed files, information on the file keys in the form of the key definition block.

Opcode | Operation | File Types
06 | Return file information | I vS vR

Input Fields

fcd-organization | File organization (can be x"FF")
fcd-name-length | Length of filename
fcd-filename-address | Pointer to the filename area
fcd-key-def-address | Pointer to the key definition block (I)

Output Fields

Key definition block (I) |
fcd-file-status | File status
fcd-organization | File organization
fcd-file-format | File format
fcd-max-rec-length | Maximum record length
fcd-recording-mode | Recording mode
fcd-min-rec-length | Minimum record length
fcd-reladdr-offset or fcd-reladdr-big | File size
fcd-data-compress | Data compression routine

It is your responsibility to ensure that you have enough space allocated for the key definition block to hold all the information returned. Failure to allocate enough space causes corruption of some data areas.

For variable-length sequential files and variable-length relative files, no key definition information exists.

If you can set the organization byte of the FCD to x"FF" before using this operation code, an attempt is made to determine the file type and return with the relevant information set. This mode of operation is not recommended if you use any fixed-length sequential files as it might be impossible to determine the difference between the first record of a fixed-length sequential file and the header of a variable-length sequential file. If the file type cannot be determined, the error code 9/161 is returned.

Parent topic: Special Operation Codes


Create Index File

Creates a new .idx file, containing only header information for the file to allow new indexes to be added.

Opcode | Operation | File Types
07 | Open new index | I

Input Fields

As OPEN.

Output Fields

As OPEN

Parent topic: Special Operation Codes


Get Next Record

Gets the next physical record from the data file part of an indexed file.

Opcode | Operation | File Types
08 | Get next record | I

Input Fields

fcd-record-address Pointer to the record area

Output Fields

fcd-file-status | File status
fcd-current-rec-len | Current record length
fcd-reladdr-offset or fcd-reladdr-big | Relative byte address
Parent topic: Special Operation Codes


Add Key Value

Adds a key value to the index file part of an indexed file.

Opcode | Operation | File Types
09 | Add key value | I

Input Fields

fcd-key-id | Key identifier
fcd-record-address | Pointer to the record area

Output Fields

fcd-file-status File status
Parent topic: Special Operation Codes


Re-index File

Re-indexes the file using a supplied key definition block.

Opcode | Operation | File Types
0B | Re-index file | I

Input Fields

Offset 64 Pointer to key definition block.

Output Fields

None
Parent topic: Special Operation Codes


Flush File

Flushes all data for a specific file to disk.

Opcode | Operation | File Types
0C | Flush File | L S R I

Input Fields

None

Output Fields

fcd-file-status File status
Parent topic: Special Operation Codes


Unlock Record

Unlocks a specific record in a file.

Opcode | Operation | File Types
0F | Unlock record | I

Input Fields

fcd-record-address Pointer to the record area

Output Fields

fcd-file-status File status
Parent topic: Special Operation Codes


FSView

  • FSVIEW API
  • FSVIEW Command Line
Parent topic: File Handling Reference


FSVIEW API

  • FSVIEW Datablock
  • FSV-C
    Initializes the FSVIEW module.
  • FSV-C-add-login-user
    This callback adds a temporary Fileshare user for the lifetime of the Fileshare process.
  • FSV-C-add-to-dbase-list
    This callback iteratively processes lists of database information.
  • FSV-C-add-to-user-list
    This callback iteratively processes lists of users.
  • FSV-C-add-to-file-list
    This callback iteratively processes lists of files.
  • FSV-C-auto-rename-logfile
    Automatically renames the log file.
  • FSV-C-shutdown-server
    Shuts down the currently accessed server.
  • FSV-C-change-server
    Changes the currently accessed server.
  • FSV-C-check-password
    Sets the FSVIEW password for a specific server.
  • FSV-C-close-file
    Closes a specific file for all users.
  • FSV-C-close-user-file
    Closes a file for a specific user.
  • FSV-C-get-comms-info
    Gets the communications information for the currently accessed server.
  • FSV-C-get-database-info
    Gets the database information for the currently accessed server.
  • FSV-C-get-files-users
    Gets the logged-on user information for a specific file.
  • FSV-C-get-log-file-info
    Gets the log file information for the currently accessed server.
  • FSV-C-get-open-files
    Gets the information about the files that are open for the server being currently accessed.
  • FSV-C-get-open-user-files
    Gets the open files for a specific user.
  • FSV-C-get-server-info
    Gets the server information for the currently accessed server.
  • FSV-C-get-user-info
    Gets the information about the logged-on users for the server being currently accessed.
  • FSV-C-logoff-user
    Logs off a specific user.
  • FSV-C-rename-logfile
    Renames the log file.
  • FSV-C-toggle-open-trace
    Toggles the XFH Open trace.
  • FSV-C-toggle-trace
    Toggles the FS trace.
  • FSV-C-toggle-XFH-trace
    Toggles the XFH trace.
  • FSVIEW-C-TERM
    Exits from FSVIEW.
Parent topic: FSView


FSVIEW Datablock

FSVIEW calls make extensive use of the FSVIEW datablock. Add the following data definitions to the datablock in your FSVIEW calls:

      *Server Information
          fsvw-server-name                  pic x(20).
          fsvw-server-startup               pic x(20).
          fsvw-server-usage                 pic x(4).
          fsvw-trace-on                     pic x comp-x.
      *Log file Information
          fsvw-log-filename                 pic x(255).
          fsvw-timings-table redefines fsvw-log-filename
             fsvw-timing-fs                 Reserved
             fsvw-timing-receiveall         Reserved
             fsvw-timing-query              Reserved
             fsvw-timing-comms-other        Reserved
             fsvw-timing-fh                 Reserved
             fsvw-timing-io-cnt             pic x(4) comp-x.

          fsvw-log-filename-size            pic x(2) comp-x.
          fsvw-log-filesize                 pic x(16).
          fsvw-disk-space                   pic x(16).
          fsvw-disk-size                    pic x(16).
      *Database Information
          fsvw-dbase-filename-size          pic x(2) comp-x.
          fsvw-dbase-filesize               pic x(16).
      *Various flags
          fsvw-exit-flg                     pic 9.
          fsvw-exit-flg-true                value 1.
          fsvw-function                     pic 9(2).
          fsvw-status-key-1                 pic x(2) comp-x.
          fsvw-status-key-2                 pic x(2) comp-x.
          fsvw-date-format                  pic x.
          fsvw-fsview-user-id               pic x(5).
      *Windows show flags
          fsvw-log-win-flg                  Reserved
             fsvw-log-win-flg-true          Reserved
          fsvw-dbase-win-flg                Reserved
             fsvw-dbase-win-flg-true        Reserved
          fsvw-user-win-flg                 Reserved
             fsvw-user-win-flg-true         Reserved
          fsvw-user-file-win-flg            Reserved
             fsvw-user-file-win-flg-true    Reserved
          fsvw-file-info-win-flg            Reserved
             fsvw-file-info-win-flg-true    Reserved
          fsvw-file-user-win-flg            Reserved
             fsvw-file-user-win-flg-true    Reserved
          fsvw-comms-win-flg                Reserved
             fsvw-comms-win-flg-true        Reserved
          fsvw-password-win-flg             Reserved
             fsvw-password-win-flg-true     Reserved
          fsvw-change-srvr-win-flg          Reserved
             fsvw-change-srvr-win-flg-true  Reserved
          fsvw-logid-needed-flg             Reserved
             fsvw-logid-needed-flg-true     Reserved
          fsvw-comms-too-small-flg          Reserved
             fsvw-comms-too-small-flg-true  Reserved
      *
          fsvw-insert-list-box
             fsvw-insert-list-box-item      occurs 10.
                fsvw-list-box-data          pic x(255).
      *User details
          fsvw-number-of-users              pic 9(5).
          fsvw-peak-number-of-users         pic 9(5).
          fsvw-logoff-id                    pic x(5).
          fsvw-file-list-user-id            pic x(5).
          fsvw-extracted-user-id            pic x(5).
      *
          fsvw-number-files-open            pic 9(10).
          fsvw-peak-files-open              pic 9(10).
      *Various fs state flags
          fsvw-user-not-found-flg           Reserved
             fsvw-user-not-found-flg-true   Reserved
          fsvw-invalid-password-flg         Reserved
             fsvw-invalid-password-flg-true Reserved
          fsvw-file-not-found-flg           Reserved
             fsvw-file-not-found-flg-true   Reserved
          fsvw-no-server-flg                Reserved
             fsvw-no-server-flg-true        Reserved
          fsvw-shutdown-already-flg         Reserved
             fsvw-shutdown-already-flg-true Reserved
          fsvw-rename-error-flg             Reserved
             fsvw-rename-error-flg-true     Reserved
          fsvw-rename-clash                 Reserved
             fsvw-rename-clash-true         Reserved
      *
          fsvw-comms-module-line2           pic x(42).
          fsvw-comms-module-line1           pic x(42).
          fsvw-send-failures                pic 9(10).
          fsvw-comms-busy                   pic 9(10).
          fsvw-comms-timeouts               pic 9(10).
      *Miscellaneous
          fsvw-filename                     Reserved
          fsvw-start-pt                     Reserved
          fsvw-user-tbl-z                   Reserved
          fsvw-server-error-flg             Reserved
             fsvw-server-error-flg-true     Reserved
      *Password check data
          fsvw-supervisor-mode              pic 9.
             fsvw-supervisor-mode-true      value 1.
          fsvw-password                     pic x(20).
          fsvw-title                        pic x(255).
          fsvw-help-topic                   pic 9(2).
          fsvw-user-id                      pic x(20).
          fsvw-user-password                pic x(20).
          fsvw-version                      pic x(8).
Parent topic: FSVIEW API


FSV-C

Initializes the FSVIEW module.

Syntax:

call FSV-C

Parameters:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSVIEW-C-TERM


FSV-C-add-login-user

This callback adds a temporary Fileshare user for the lifetime of the Fileshare process.

Syntax:

FSV-C-add-login-user  using      l-new-user-name
                                        l-new-password-name

Parameters:

l-new-user-name
pic x(20)
l-new-password
pic x(20)

On Entry:

l-new-user-name
The new user name
l-new-password
The password associated with the new user

On Exit:

None.

Comments:

Only applicable if you have security enabled. The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API


FSV-C-add-to-dbase-list

This callback iteratively processes lists of database information.

Syntax:

FSV-C-add-to-dbase-list list using      number-of-entries
                                        fsvw-data-block

Parameters:

number-of-entries | pic xx comp-x.
fsvw-data-block | A group item defined as:
fsvw-insert-list-box-item ( i ) | occurs 10.

See the topic FSVIEW Datablock for a complete definition of fsvw-data-block.

On Entry:

number-of-entries | The number of entries
fsvw-insert-list-box-item ( i ) | The user information for a specific user

On Exit:

None.

Comments:

RETURN-CODE must be set to 0 before returning.

Parent topic: FSVIEW API
Related reference
FSV-C-get-database-info


FSV-C-add-to-user-list

This callback iteratively processes lists of users.

Syntax:

FSV-C-add-to-user-list using      number-of-entries
                                  fsvw-data-block

Parameters:

number-of-entries | pic xx comp-x.
fsvw-data-block | A group item defined as:
fsvw-insert-list-box-item ( i ) | occurs 10.

See the topic FSVIEW Datablock for a complete definition of fsvw-data-block.

On Entry:

number-of-entries | The number of entries
fsvw-insert-list-box-item ( i ) | The user information for a specific user

On Exit:

None.

Comments:

RETURN-CODE must be set to 0 before returning.

Parent topic: FSVIEW API
Related reference
FSV-C-get-files-users


FSV-C-add-to-file-list

This callback iteratively processes lists of files.

Syntax:

FSV-C-add-to-file-list using      number-of-entries
                                  fsvw-data-block

Parameters:

number-of-entries | pic xx comp-x.
fsvw-data-block | A group item defined as:
fsvw-insert-list-box-item ( i ) | occurs 10

See the topic FSVIEW Datablock for a complete definition of fsvw-data-block.

On Entry:

number-of-entries | The number of entries
fsvw-insert-list-box-item ( i ) | The user information for a specific user

On Exit:

None.

Comments:

RETURN-CODE must be set to 0 before returning.

Parent topic: FSVIEW API
Related reference
FSV-C-get-open-user-files
FSV-C-get-open-files


FSV-C-auto-rename-logfile

Automatically renames the log file.

Syntax:

call FSV-C-auto-rename-logfile

Parameters:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-get-log-file-info
FSV-C-rename-logfile


FSV-C-shutdown-server

Shuts down the currently accessed server.

Syntax:

call FSV-C-shutdown-server

Parameters:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-change-server
FSV-C-get-server-info
FSV-C-get-database-info
FSV-C-check-password
FSV-C-get-comms-info


FSV-C-change-server

Changes the currently accessed server.

Syntax:

call FSV-C-change-server using      l-server-name
                                    l-user-name
                                    l-server-password

Parameters:

l-server-name | pic x(20).
l-user-name | pic x(20).
l-server-password | pic x(20).

On Entry:

l-server-name | The name of the server
l-user-name | The user ID
l-server-password | The password associated with the user ID

On Exit:

None.

Comments:

You need to set l-user-name and l-server-password only if you have Fileshare

security enabled.

The success of the call can be checked by examining RETURN-CODE. In the event

of a password error, the error message "Access Denied" is returned.

Parent topic: FSVIEW API
Related reference
FSV-C-get-server-info
FSV-C-get-database-info
FSV-C-check-password
FSV-C-get-comms-info
FSV-C-shutdown-server


FSV-C-check-password

Sets the FSVIEW password for a specific server.

Syntax:

call FSV-C-check-password using      l-server-password

Parameters:

l-server-password pic x(20)

On Entry:

l-server-password The FSVIEW password

On Exit:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-change-server
FSV-C-get-server-info
FSV-C-get-database-info
FSV-C-get-comms-info
FSV-C-shutdown-server


FSV-C-close-file

Closes a specific file for all users.

Syntax:

call FSV-C-close-file using      l-filename

Parameters:

l-filename pic x(260)

On Entry:

l-filename The name of a file. The name must contain the full path.

On Exit:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-logoff-user
FSV-C-get-open-user-files
FSV-C-close-user-file
FSV-C-get-files-users
FSV-C-get-user-info


FSV-C-close-user-file

Closes a file for a specific user.

Syntax:

call FSV-C-close-user-file using      l-user-id
                                      l-filename

Parameters:

l-user-id | pic 9(5)
l-filename | pic x(260)

On Entry:

l-user-id | A valid user ID
l-filename | The name of a file. The name must contain the full path.

On Exit:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-close-file
FSV-C-logoff-user
FSV-C-get-open-user-files
FSV-C-get-files-users
FSV-C-get-user-info


FSV-C-get-comms-info

Gets the communications information for the currently accessed server.

Syntax:

call FSV-C-get-comms-info using      fsvw-data-block

Parameters:

fsvw-data-block | A group item defined as:
fsvw-comms-module-line1 | pic x(42).
fsvw-comms-module-line2 | pic x(42).
fsvw-send-failures | pic 9(10).
fsvw-comms-busy | pic 9(10).
fsvw-comms-timeouts | pic 9(10).

See the topic FSVIEW Datablock for a complete definition of fsvw-data-block.

On Entry:

None.

On Exit:

fsvw-comms-module-line1 | A list of the communications modules in use
fsvw-comms-module-line2 | A list of the communications modules in use. fsvw-comms-module-line2 is an extension of fsvw-comms-module-line1
fsvw-send-failures | The number of send failures
fsvw-comms-busy | The number of times communications reported status busy
fsvw-comms-timeouts | The number of times communications reported timeouts

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-change-server
FSV-C-get-server-info
FSV-C-get-database-info
FSV-C-check-password
FSV-C-shutdown-server


FSV-C-get-database-info

Gets the database information for the currently accessed server.

Syntax:

call FSV-C-get-database-info using      fsvw-data-block

Parameters:

fsvw-data-block | A group item defined as:
fsvw-dbase-filename | pic x(255).
fsvw-dbase-filename-size | pic x(2) comp-x.
fsvw-dbase-filesize | pic x(16).

See the topic FSVIEW Datablock for a complete definition of fsvw-data-block.

On Entry:

None.

On Exit:

fsvw-dbase-filename | The database file name of the currently selected server.
fsvw-dbase-filename-size | Length of the name stored in fsvw-dbase-filename A value of 0 (zero) means that no database in use.
fsvw-dbase-filesize | The size of the database file

Comments:

This call does not directly return information to the calling program but makes repeated calls back to a user-defined call. Up to 10 entries at a time will be sent to the callback. You must provide the callback specified in the FSVIEW function FSV-C-add-to-dbase-list.

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-add-to-dbase-list
FSV-C-change-server
FSV-C-get-server-info
FSV-C-check-password
FSV-C-get-comms-info
FSV-C-shutdown-server


FSV-C-get-files-users

Gets the logged-on user information for a specific file.

Syntax:

call FSV-C-get-files-users using      l-filename

Parameters:

l-filename pic x(260)

On Entry:

l-filename The name of a file. The name must contain the full path.

On Exit:

None.

Comments:

This call does not directly return information to the calling program but makes repeated calls back to a user-defined call. Up to 10 entries at a time will be sent to the callback. You must provide the callback specified in the FSVIEW function FSV-C-add-to-user-list.

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-add-to-user-list
FSV-C-close-file
FSV-C-logoff-user
FSV-C-get-open-user-files
FSV-C-close-user-file
FSV-C-get-user-info


FSV-C-get-log-file-info

Gets the log file information for the currently accessed server.

Syntax:

call FSV-C-get-log-file-info using      fsvw-data-block

Parameters:

fsvw-data-block | A group item defined as:
fsvw-log-filename | pic x(255).
fsvw-filename-size | pic x(16).
fsvw-log-filesize | pic x(16).
fsvw-disk-space | pic x(16).
fsvw-disk-size | pic x(16).

See the topic FSVIEW Datablock for a complete definition of fsvw-data-block.

On Entry:

None.

On Exit:

fsvw-log-filename | The log file name of the server currently selected
fsvw-filename-size | Length of the name stored in fsvw-log-filename A value of 0 (zero) means that no log file is in use.
fsvw-log-filesize | The size of the log file
fsvw-disk-space | The amount of space remaining on the disk
fsvw-disk-size | The size of the disk

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-auto-rename-logfile
FSV-C-rename-logfile


FSV-C-get-open-files

Gets the information about the files that are open for the server being currently accessed.

Syntax:

call FSV-C-get-open-files using fsvw-data-block

Parameters:

fsvw-data-block | A group item defined as:
fsvw-log-filename | pic x(255).
fsvw-filename-size | pic x(16).
fsvw-log-filesize | pic x(16).
fsvw-disk-space | pic x(16).
fsvw-disk-size | pic x(16).

See the topic FSVIEW Datablock for a complete definition of fsvw-data-block.

On Entry:

fsvw-server-name The name of the currently selected server. This is the name that the Fileshare Server was started with in the /s option.

On Exit:

None

Comments:

This call does not directly return information to the calling program but makes repeated calls back to a user defined call. Up to 10 entries at a time will be sent to the callback. See the FSVIEW function FSV_C_add-to_file_list.

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-add-to-file-list
FSV-C-get-open-user-files


FSV-C-get-open-user-files

Gets the open files for a specific user.

Syntax:

call FSV-C-get-open-user-files using      l-user-id

Parameters:

l-user-id pic 9(5).

On Entry:

l-user-id A valid user ID

On Exit:

None.

Comments:

This call does not directly return information to the calling program but makes repeated calls back to a user defined call. Up to 10 entries at a time will be sent to the callback. You must provide the callback specified in the FSVIEW function FSV-C-add-to-file-list.

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-add-to-file-list
FSV-C-close-file
FSV-C-logoff-user
FSV-C-close-user-file
FSV-C-get-files-users
FSV-C-get-user-info
FSV-C-get-open-files


FSV-C-get-server-info

Gets the server information for the currently accessed server.

Syntax:

call FSV-C-get-server-info using      fsvw-data-block

Parameters:

fsvw-data-block | A group item defined as:
fsvw-server-name | pic x(20).
fsvw-server-startup | pic x(20).
fsvw-server-usage | pic x(4).
fsvw-timing-io-cnt | pic x(4) comp-x.
fsvw-trace-on | pic x comp-x.

See the topic FSVIEW Datablock for a complete definition of fsvw-data-block.

On Entry:

None.

On Exit:

fsvw-server-name | The name of the currently selected server. This is the name that the Fileshare Server was started with in the /s option.
fsvw-server-startup | The time and date when the server was started, in the format hh:mm:ss dd-mm-yy
fsvw-server-usage | The proportion of current execution time that the server is actually processing requests
fsvw-timing-io-cnt | The number of input and output operations per second
fsvw-trace-on | The trace modes that are currently on

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-change-server
FSV-C-get-database-info
FSV-C-check-password
FSV-C-get-comms-info
FSV-C-shutdown-server


FSV-C-get-user-info

Gets the information about the logged-on users for the server being currently accessed.

Syntax:

call FSV-C-get-user-info using      fsvw-data-block

Parameters:

fsvw-data-block | A group item defined as:
fsvw-log-filename | pic x(255).
fsvw-filename-size | pic x(16).
fsvw-log-filesize | pic x(16).
fsvw-disk-space | pic x(16).
fsvw-disk-size | pic x(16).

See the topic FSVIEW Datablock for a complete definition of fsvw-data-block.

On Entry:

fsvw-server-name The name of the currently selected server. This is the name that the Fileshare Server was started with in the /s option.

On Exit:

None.

Comments:

This call does not directly return information to the calling program but makes repeated calls back to a user-defined call. Up to 10 entries at a time will be sent to the call back. You must provide the callback specified in the FSVIEW function FSV_C_add-to_user_list.

You can check the success of the call by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-close-file
FSV-C-logoff-user
FSV-C-get-open-user-files
FSV-C-close-user-file
FSV-C-get-files-users


FSV-C-logoff-user

Logs off a specific user.

Syntax:

call FSV-C-logoff-user using      l-user-id

Parameters:

l-user-id pic 9(5).

On Entry:

l-user-id The user ID of the user to be logged off

On Exit:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-close-file
FSV-C-get-open-user-files
FSV-C-close-user-file
FSV-C-get-files-users
FSV-C-get-user-info


FSV-C-rename-logfile

Renames the log file.

Syntax:

call FSV-C-rename-logfile using      l-filename

Parameters:

l-filename pic x(260).

On Entry:

l-filename The log file name

On Exit:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-auto-rename-logfile
FSV-C-get-log-file-info


FSV-C-toggle-open-trace

Toggles the XFH Open trace.

Syntax:

call FSV-C-toggle-open-trace using      l-set-state

Parameters:

l-set-state pic x comp-x.

On Entry:

l-set-state Reserved for future use

On Exit:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-toggle-trace
FSV-C-toggle-XFH-trace


FSV-C-toggle-trace

Toggles the FS trace.

Syntax:

call FSV-C-toggle-trace using      l-set-state

Parameters:

l-set-state pic x comp-x.

On Entry:

l-set-state Reserved for future use

On Exit:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-toggle-open-trace
FSV-C-toggle-XFH-trace


FSV-C-toggle-XFH-trace

Toggles the XFH trace.

Syntax:

call FSV-C-toggle-XFH-trace using      l-set-state

Parameters:

l-set-state pic x comp-x.

On Entry:

l-set-state Reserved for future use

On Exit:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C-toggle-open-trace
FSV-C-toggle-trace


FSVIEW-C-TERM

Exits from FSVIEW.

Syntax:

call FSVIEW-C-TERM

Parameters:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: FSVIEW API
Related reference
FSV-C


FSVIEW Command Line

  • Admin logon
    Logs on a user to administer Fileshare.
  • Admin password
    Sets the password for secure commands.
  • Exit
    Exits FSVIEW.
  • File close
    Closes a specific file for all users.
  • File get-locks
    Gets the list of record locks held by Fileshare for a specific file.
  • File get-users
    Gets the list of users accessing a specific file.
  • Files get
    Gets the list of open files.
  • Help
    Displays the list of FSVIEW Command Line commands.
  • Logfile autorename
    Invokes the automatic log file rename on the server.
  • Logfile rename
    Renames the log file.
  • Opentrace toggle
    Toggles the XFH open trace.
  • Option echo
    Sets the echo command option on.
  • Option no-echo
    Sets the echo command option off.
  • Option no-upcase
    Sets the case of filenames to lower case.
  • Option upcase
    Sets the case of filenames to upper case.
  • Server get
    Gets the server information from the connected server.
  • Server set
    Connects to the named server.
  • Server shutdown
    Shuts down the server.
  • Trace toggle
    Toggles the Fileshare trace.
  • User-file close
    Terminates file access for a specific file and user.
  • User get-files
    Gets the list of open files for a specific user.
  • User logoff
    Logs off a user.
  • Users get
    Gets the list of logged-on users.
  • XFH trace toggle
    Toggles the XFH trace.
Parent topic: FSView


Admin logon

Logs on a user to administer Fileshare.

Syntax:

admin logon user-ID
            user-passwd

Parameters:

user-ID | A valid user ID
user-passwd | The password associated with user-ID

Comments:

This command is required if Fileshare security is enabled but the FSVIEW user ID is not going to be used.

Parent topic: FSVIEW Command Line
Related reference
Exit
Help
Admin password


Admin password

Sets the password for secure commands.

Syntax:

admin password supervisor-passwd

Parameters:

supervisor-passwd The supervisor password to be set

Comments:

This command is required if you want to access secure commands and Admin logon has not been used (Fileshare security is not enabled).

Parent topic: FSVIEW Command Line
Related reference
Admin logon
Exit
Help
Server get
Server set
Server shutdown


Exit

Exits FSVIEW.

Syntax:

exit

Parameters:

None.

Parent topic: FSVIEW Command Line
Related reference
Admin logon
Help
Admin password


File close

Closes a specific file for all users.

Syntax:

file close filename

Parameters:

filename The name of the file. The name must contain the full path.

Comments:

You must be logged on as FSVIEW to use this command.

Parent topic: FSVIEW Command Line
Related reference
Files get
File get-users


File get-locks

Gets the list of record locks held by Fileshare for a specific file.

Syntax:

file get-locks filename

Parameters:

filename The name of a file. The name must contain the full path.
Parent topic: FSVIEW Command Line


File get-users

Gets the list of users accessing a specific file.

Syntax:

file get-users filename

Parameters:

filename The name of a file. The name must contain the full path.
Parent topic: FSVIEW Command Line
Related reference
File close
Files get


Files get

Gets the list of open files.

Syntax:

files get

Parameters:

None.

Parent topic: FSVIEW Command Line
Related reference
File close
File get-users
User-file close
Users get
User get-files
User logoff


Help

Displays the list of FSVIEW Command Line commands.

Syntax:

help

Parameters:

None.

Parent topic: FSVIEW Command Line
Related reference
Admin logon
Exit
Admin password


Logfile autorename

Invokes the automatic log file rename on the server.

Syntax:

logfile autorename

Parameters:

None.

Parent topic: FSVIEW Command Line
Related reference
Logfile rename


Logfile rename

Renames the log file.

Syntax:

logfile rename log-file

Parameters:

log-file The log file to be renamed
Parent topic: FSVIEW Command Line
Related reference
Logfile autorename


Opentrace toggle

Toggles the XFH open trace.

Syntax:

opentrace toggle

Parameters:

None.

Parent topic: FSVIEW Command Line
Related reference
Trace toggle
XFH trace toggle


Option echo

Sets the echo command option on.

Syntax:

option echo

Parameters:

None.

Comments:

The default setting for FSVIEW is option no-echo.

Parent topic: FSVIEW Command Line
Related reference
Option no-echo


Option no-echo

Sets the echo command option off.

Syntax:

option no-echo

Parameters:

None.

Comments:

The default setting for FSVIEW is option no-echo.

Parent topic: FSVIEW Command Line
Related reference
Option echo


Option no-upcase

Sets the case of filenames to lower case.

Syntax:

option no-upcase

Parameters:

None.

Comments:

The default setting for FSVIEW is option no-upcase.

Parent topic: FSVIEW Command Line
Related reference
Option upcase


Option upcase

Sets the case of filenames to upper case.

Syntax:

option upcase

Parameters:

None.

Comments:

The default setting for FSVIEW is option no-upcase.

Parent topic: FSVIEW Command Line
Related reference
Option no-upcase


Server get

Gets the server information from the connected server.

Syntax:

server get

Parameters:

None.

Comments:

The information returned by this command includes activity statistics, log file information and database information.

Parent topic: FSVIEW Command Line
Related reference
Server set
Server shutdown
Admin password


Server set

Connects to the named server.

Syntax:

server set fileshare-name

Parameters:

fileshare-name The name of the Fileshare server to connect to
Parent topic: FSVIEW Command Line
Related reference
Server get
Server shutdown
Admin password


Server shutdown

Shuts down the server.

Syntax:

server shutdown

Comments:

You must be logged on as FSVIEW to use this command.

Parent topic: FSVIEW Command Line
Related reference
Server get
Server set
Admin password


Trace toggle

Toggles the Fileshare trace.

Syntax:

trace toggle

Parameters:

None.

Parent topic: FSVIEW Command Line
Related reference
Opentrace toggle
XFH trace toggle


User-file close

Terminates file access for a specific file and user.

Syntax:

user-file close user-ID
                filename

Parameters:

user-ID | A valid user ID associated with filename
filename | The name of a file. The name must contain the full path.

Comments:

You must be logged on as FSVIEW to use this command.

Parent topic: FSVIEW Command Line
Related reference
Users get
User get-files
Files get
User logoff


User get-files

Gets the list of open files for a specific user.

Syntax:

user get-file user-ID

Parameters:

user-ID A valid user ID
Parent topic: FSVIEW Command Line
Related reference
User-file close
Users get
Files get
User logoff


User logoff

Logs off a user.

Syntax:

user logoff user-ID

Parameters:

user-ID A valid user ID

Comments:

You must be logged on as FSVIEW to use this command.

Parent topic: FSVIEW Command Line
Related reference
User-file close
Users get
User get-files
Files get


Users get

Gets the list of logged-on users.

Syntax:

users get

Parameters:

None.

Parent topic: FSVIEW Command Line
Related reference
User-file close
User get-files
Files get
User logoff


XFH trace toggle

Toggles the XFH trace.

Syntax:

xfhtrace toggle

Parameters:

None.

Parent topic: FSVIEW Command Line
Related reference
Trace toggle
Opentrace toggle


File Status

  • File Status Codes
  • Extended File Status Codes
  • Microsoft COBOL V2 File Status Codes
Parent topic: File Handling Reference


File Status Codes

00
Successful completion.
02
Indexed files only. One of two possibilities: For a READ statement, the key value for the current key is equal to the value of that same key in the next record in the current key of reference. For a WRITE or REWRITE statement, the record just written created a duplicate key value for at least one alternate record key for which duplicates are allowed.
04
The length of the record being processed does not conform to the fixed file attributes for that file.
05
The referenced optional file is not present at the time the OPEN statement is executed.
07
Sequential files only. For an OPEN or CLOSE statement with the REEL/UNIT phrase the referenced file is a non-reel/unit medium.
10
No next logical record exists. You have reached the end of the file.
14
Relative files only. The number of significant digits in the relative record number is larger than the size of the relative key data item described for that file.
21
Sequentially accessed files only. Indicates a sequence error. The ascending key requirements of successive record key values has been violated, or, the prime record key value has been changed by a COBOL program between successful execution of a READ statement and execution of the next REWRITE statement for that file.
22
Indexed and relative files only. Indicates a duplicate key condition. Attempt has been made to store a record that would create a duplicate key in the indexed or relative file OR a duplicate alternate record key that does not allow duplicates.
23
Indicates no record found. An attempt has been made to access a record, identified by a key, and that record does not exist in the file. Alternatively a START or READ operation has been tried on an optional input file that is not present.
24
Relative and indexed files only. Indicates a boundary violation arising from one of the following conditions: an attempt is made to write beyond the externally defined boundaries of a file; a sequential WRITE operation has been tried on a relative file, but the number of significant digits in the relative record number is larger than the size of the relative key data item described for the file.
30
The I/O statement was unsuccessfully executed as the result of a boundary violation for a sequential file or as the result of an I/O error, such as a data check parity error, or a transmission error.
34
The I/O statement failed because of a boundary violation. This condition indicates that an attempt has been made to write beyond the externally defined boundaries of a sequential file.
35
An OPEN operation with the I-O, INPUT, or EXTEND phrases has been tried on a non-OPTIONAL file that is not present.
37
An OPEN operation has been tried on a file which does not support the open mode specified in the OPEN statement.
38
An OPEN operation has been tried on a file previously closed with a lock.
39
A conflict has been detected between the fixed file attributes and the attributes specified for that file in the program.
41
An OPEN operation has been tried on a file already opened.
42
A CLOSE operation has been tried on a file already clsoed.
43
Files in sequential access mode. The last I/O statement executed for the file, before the execution of a DELETE or REWRITE statement, was not a READ statement.
44
A boundary violation exists. Possible violations are:
  • An attempt has been made to WRITE or REWRITE a record that is larger than the largest, or smaller than the smallest record allowed by the RECORD IS VARYING clause of the associated file.
  • An attempt has been made to REWRITE a record to a file, and the record is not the same size as the record being replaced.
46
A sequential READ operation has been tried on a file open in the INPUT or I-O mode but no valid next record has been established.
47
A READ or START operation has been tried on a file not opened INPUT or I-O.
48
A WRITE operation has been tried on a file not opened in the OUTPUT, I-O, or EXTEND mode, or on a file open I-O in the sequential access mode.
49
A DELETE or REWRITE operation has been tried on a file that is not opened I-O.
Parent topic: File Status


Extended File Status Codes

When using ANSI'74 or ANSI'85 file status codes, run-time system returns extended file status codes if the extended file status is more specific.

Extended file status codes are of the form:

9/nnn

where nnn is a numeric value that is the same as the numeric value of the corresponding run-time system error. For example, if an extended file status code of 9/029 is returned, run-time system error COBRT029 (Attempt to delete open file) provides more information about the cause.

Parent topic: File Status


Microsoft COBOL V2 File Status Codes

Status Key 1 | Status Key 2 | Description
0 | 0 | Successful completion.
 | 2 | Duplicate key and duplicates are allowed.
1 | 0 | End of file.
2 | 1 | Sequence error in writing sequential access file.
 | 2 | Duplicate key and duplicates are not allowed.
 | 3 | Key not found.
 | 4 | Disk space full.
3 | 0 | Permanent error or file not found.
 | 4 | Disk space full.
9 | 1 | File structure error.
 | 4 | File or record locked.
 | 5 | Indexed file system not available.
Parent topic: File Status


File Structures

  • Files without Headers
  • Files with Headers
Parent topic: File Handling Reference


Files without Headers

  • Line Sequential File Structure
  • Printer Sequential File Structure
  • Fixed Format Record Sequential File
  • Fixed Format Relative File
Parent topic: File Structures


Line Sequential File Structure

Line sequential files are designed to enable you to read source or text files created with the system editor. As such, the structure is operating system dependent but typically contains variable length records with trailing spaces removed. In a line sequential file, each record in the file is separated from the next by a record delimiter.

Line Sequential File Structure

For files created on UNIX systems the default record delimiter is the line feed character specified by the single byte x"OA". For files created on DOS or Windows the default record delimiter is the carriage return/line feed character specified by the byte pair x"ODA". Files created using this COBOL system on UNIX can be read on DOS and Windows, and vice versa. If you set the INSERTNULL configuration option to OFF, you must make sure that any COMP or COMP-3 data does not contain bytes with a value of x"0A" (record delimiter), x"09" (tab) or x"0D" (carriage return).

Parent topic: Files without Headers
Related information
Data Compression


Printer Sequential File Structure

Printer sequential is the structure of files that are destined for a printer, either directly or by spooling to a disk file. The structure of these files reflects what is required to drive a printer and is independent of the operating system.

A printer sequential file consists of a sequence of print records with zero or more vertical positioning characters (such as line-feed) between print records.

A print record consists of zero or more printable characters and is terminated by a carriage return (x"0D").

Printer Sequential File Structure

Parent topic: Files without Headers
Related information
Data Compression


Fixed Format Record Sequential File

In a fixed format record sequential file, each record immediately follows the previous record in the file. Each record is the same length as the maximum length record.

Record Sequential File with Fixed Length Records

Parent topic: Files without Headers
Related information
Data Compression


Fixed Format Relative File

A relative file with fixed-length records is the same as a record sequential file with fixed-length records, except that each record is followed by a record marker which has the value x"0D0A" if the record is present and x"0D00" if the record has been deleted.

Relative File with Fixed Length Records

Parent topic: Files without Headers
Related information
Data Compression


Files with Headers

  • Standard File Header
  • Standard Record Header
  • Variable Format Record Sequential File
  • Variable Format Relative Structure
  • Indexed Files
Parent topic: File Structures


Standard File Header

The first record in every variable structure file is a system record called the file header. This is normally 128 bytes in length and takes the following form:

Offset | Size | Description
0 4 Length of the file header. The first 4 bits are always set to 3 (0011 in binary) indicating that this is a system record. The remaining bits contain the length of the file header record. If the maximum record length is less than 4095 bytes, the length is 126 and is held in the next 12 bits; otherwise it is 124 and is held in the next 28 bits. Hence, in a file where the maximum record length is less than 4095 bytes, this field contains x"30 7E 00 00". Otherwise, this field contains x"30 00 00 7C".

An exception to this is the header of C-ISAM files, for which the field contains "30 00 03 FC".

4 | 2 | Database sequence number, used by add-on products.
6 | 2 | Integrity flag. Indexed files only. If this is non-zero when the header is read, it indicates that the file is corrupt.
8 | 14 | Creation date and time in YYMMDDHHMMSSCC format. Indexed files only.
22 | 14 | Reserved.
36 | 2 | Reserved. Value 62 decimal; x"00 3E".
38 | 1 | Not used. Set to zeros.
39 1 Organization:
  1. Sequential
  2. Indexed
  3. Relative
40 | 1 | Not used. Set to zeros.
41 1 Data compression routine number:
0
No compression
1
CBLDC001
2-127
Reserved for internal use
128-255
User-defined compression routine number
42 | 1 | Not used. Set to zeros.
43 | 1 | Indexed files only - type of indexed file.
44 | 4 | Reserved.
48 1 Recording mode:
0
Fixed format
1
Variable format

For indexed files, the recording mode field of the .idx file takes precedence.

49 | 5 | Not used. Set to zeros.
54 | 4 | Maximum record length. Example: with a maximum record of length 80 characters, this field will contain x"00 00 00 50".
58 | 4 | Minimum record length. Example: with a minimum record length of 2 characters, this field will contain x"00 00 00 02".
62 | 46 | Not used. Set to zeros.
108 | 4 | Version and build data for the indexed file handler creating the file. Indexed files only.
112 | 16 | Not used. Set to zeros.
Parent topic: Files with Headers
Related reference
Types of Indexed File
Related information
Data Compression


Standard Record Header

Each record in a variable structure file is preceded by a two- or four-byte record header. The first four bits of this indicate the status of the record, for example, a value of 0100 means that this record is a normal user data record.

The remainder of the record header contains the length of the record. For all files where the maximum record size is less than 4095 bytes (excluding the record header), the record header is two bytes long. For all other files, the record header is four bytes long.

The record header for each record starts at an address which is an exact multiple of the data alignment value for the file type (see the topic Types of Indexed File for details of data alignment values). Consequently, a record may be followed by up to n padding characters, usually spaces. These padding characters are not included in the record length.

First four bits | Record type
1 (0001) | A system record. This indicates a duplicate occurrence record in the data file.
2 (0010) | Deleted record (available for reuse via the free space list).
3 (0011) | System record.
4 (0100) | Normal user data record.
5 (0101) | Reduced user data record (indexed files only). The area immediately following the data, as indicated by the length in the header, indicates length between the end of the data record plus any padding characters and the start of the next record header. This information is contained in either a 2-byte or 4-byte field (see the topic Types of Indexed File for details).
6 (0110) | Pointer record (indexed files only). The first n bytes following the record header contain the offset in the file to the location of the user data record, where n is the file pointer size for the indexed file type (see the topic Types of Indexed File for details).
7 (0111) | User data record referenced by a pointer record.
8 (1000) | Reduced user data record referenced by a pointer record.
9 (1001) | Reserved for future use
10 (1010) | Mid-transaction user data record (As 4 except the record is from a Fileshare transaction which has not yet been COMMITed)
11 (1011) | Mid-transaction reduced user data record (as 5 except the record is from a Fileshare transaction which has not yet been COMMITed)
12 (1100) | Mid-transaction user data record referenced by a pointer record (as 7 except the record is from a Fileshare transaction which has not yet been COMMITed)
13 (1101) | Mid-transaction reduced user data record referenced by a pointer record (as 8 except the record is from a Fileshare transaction which has not yet been COMMITed)
Parent topic: Files with Headers
Related reference
Types of Indexed File
Related information
Data Compression


Variable Format Record Sequential File

In a variable format record sequential file each record written is preceded by a record header containing the length of the record.

Padding characters can follow a record to ensure that the next record starts on a four-byte boundary.

The file contains a standard file header record.

Variable Format Record Sequential File Structure

Parent topic: Files with Headers
Related reference
Standard Record Header
Related information
Data Compression


Variable Format Relative Structure

A relative file with variable-length records follows the basic variable structure but each record is placed into a fixed-length slot, the length of the slot being the length of the longest record defined, plus the header and terminator characters.

The record header for each record contains the length of the logical record written, not the length of the physical fixed-length slot.

Relative File with Variable Length Records

Parent topic: Files with Headers
Related information
Data Compression


Indexed Files

  • Types of Indexed File
  • Index File
  • Data File
Parent topic: Files with Headers


Types of Indexed File

This COBOL system supports more than one type of indexed file. The tables below illustrate the different types available and the features that they support.

Table 1. Indexed Files - Features Supported
 | Supports Files Logically >4 Gb | Fast Updates on Files with Multiple Duplicate Keys | Maximum Occurrences of Duplicate Key Value | Support for Variable Length Records and Compression | Separate Index File
IDXFORMAT"1" | No | No | 65535 | No | Yes
IDXFORMAT"2" | No | No | 65535 | No | Yes
IDXFORMAT"3" | No | No | 65535 | Yes | Yes
IDXFORMAT"4" | No | Yes | 4 G | Yes | Yes
IDXFORMAT"8" | Yes | Yes | 4 G | Yes | No
Table 2. Indexed Files - Physical Characteristics
 | Duplicate Occurrence Records | Data Record Alignment | File Pointer Size (bytes) | Residue Length Field | Index Node Includes Record Header
IDXFORMAT"1" | No | 1 | 4 | n/a | No
IDXFORMAT"2" | No | 1 | 4 | n/a | No
IDXFORMAT"3" | No | 4 | 4 | 2 | No
IDXFORMAT"4" | Yes | 4 | 4 | 2 | No
IDXFORMAT"8" | Yes | 8 | 6 | 4 | Yes
Parent topic: Indexed Files
Related information
Data Compression


Index File

  • Index Files - Overview
  • Index File - File Header
  • Index File - Free Space Record
  • Index File - Key Information Record
  • Index File - Index Node Record
Parent topic: Indexed Files


Index Files - Overview

An index file comprises:

  • File header record

    The file header contains information about the file and points to the first free space record and the key information record.

  • Free space records

    Free space records are used to maintain a list of free records in the index file and the data file.

  • Key information record

    The key information record contains details of every key defined for the file, and, for each key, points to its root index node.

  • Index node record

    For each key defined, a complete and independent index is constructed. It consists of a tree of index node records which contain actual key values. Every key value in a node will point either to a subordinate index node record or to the actual data record associated with the key.

The records in an index file are always the same length, whether they are index nodes, file header or key information records. The size of the records is determined at the time the file is created and cannot be changed subsequently.

Parent topic: Index File
Related information
Data Compression


Index File - File Header

The file header is located at offset 0 within the index file. The first 128 bytes are the same as a standard variable structure file header, except for the fields below.

Offset | Size | Description
0 | 4 | Length of the file header.
39 | 1 | Always contains value 2 for indexed organization.
62 | 14 | Always contains zeros.
76 | 1 | Reserved. Set to 4.
120 | 8 | Offset of logical end of the index file.

The remainder of the file header contains the following fields:

Offset | Size | Description
128 | 8 | Offset of logical end of the data file.
136 | 1 | Value 2.
137 | 1 | Value 2.
138 | 1 | Value 4.
139 | 1 | Value 4.
140 | 2 | Contains the number of keys defined for the file.
142 | 1 | Value 0, or 1 if duplicate occurrence records are present. See the topic Types of Indexed File for details.
143 | 1 | Value 2 or 4. Number of bytes used for occurrence numbers in indices where duplicates are permitted.
144 | 8 | Offset of the first key information record.
152 | 8 | Offset of the free space record for the data file. For fixed format files, this is a record in the index file of the same format as the index free space record, but the addresses point to free records in the data file. For variable format files, this is the address in the data file of the data free space record. This record has a different structure to the index free space record.
160 | 8 | Offset of the first free space record in the index file.
168 | 4 | Value zeros.
172 | 4 | Index file record length (node size).
176 | 8 | Value zeros.
184 | 328 | Reserved. Value zeros. For node size 512.
 | 840 | Reserved. Value zeros. For node size 1024.
 | 3912 | Reserved. Value zeros. For node size 4096.
Parent topic: Index File
Related concepts
Types of Indexed File


Index File - Free Space Record

The free space record points to the location of free records in the index file or data file (fixed-length files only). Continuation records of the same size and structure are created as needed, each pointing to the next continuation record.

The first free space record is pointed to by the file header.

A free space record contains:

Size | Description
2 | Record header. Present only if index nodes have record header (see the topic Types of Indexed File).
2
Bit 15
Security Flag. Value should match value of trailing security flag.
Bits 14-0
Pointer to the end of the last free record address entry, relative to the start of this record.
file-pointer-size | Offset of free space continuation record. Zero if no further continuation records.
file-pointer-size | Offset of a free record in the index file.
...
file-pointer-size | Offset of a free record in the index file.
2
Bit 15
Security flag. Value should match value of leading security flag.
Bits 14-0
Reserved. Value x"7F".

The size of file-pointer-size varies according to the type of indexed file. See the topic Types of Indexed File for details.

Parent topic: Index File
Related concepts
Types of Indexed File


Index File - Key Information Record

The key information record describes the physical characteristics of all the keys used in the file, including the length of each key; where the key is defined within the data record; whether duplicates are permitted, and so on. Within the key information record structure is a sub-structure, the key block. A key block is created for each key defined. The first key block always describes the primary key. Subsequent key blocks define the alternate keys in the order specified when the file was created. If the key information record is not big enough to hold key blocks for all the keys defined, equal sized continuation records are created, each pointing to the next, until all the keys have been defined.

The key information record contains:

Size | Description of the field
2 | Record header. Present only if index nodes have record header. See the topic the topic Types of Indexed File for details.
2
Bit 15
Security flag. Value 0.
Bits 14-0
Pointer to the end of the last key block entry in this record, relative to the start of this record.
file-pointer-size | Address of continuation record. Zero if no further continuation records.
n | Key block for primary key
... ...one for each alternate key in the file
n | Key block
1 | Reserved. Value x"FF".
1 | Reserved. Value x"7E".

For all indexed file formats except IDXFORMAT"8", the key block contains:

Size | Description of the field
2 | Length of this entry in bytes.
4 | Address of the root index node record for this key.
1 Key compression:
Bit 2
Compression of trailing spaces.
Bit 1
Compression of leading characters.
Bit 0
Compression of duplicates.
5 | Key component block
... ...if the key is split, one block per component
5 | Key component block

For IDXFORMAT"8" files, the key block contains:

Size | Description of the field
2 | Length of this entry in bytes.
1 | Sparse key character.
13 | Reserved.
1 Key compression:
Bit 3
Compression of trailing nulls.
Bit 2
Compression of trailing spaces.
Bit 1
Compression of leading characters.
Bit 0
Compression of duplicates.
1 Key flags:
Bit 6
Duplicates permitted.
Bit 1
Sparse key.
6 | Key component block
... ...if the key is split, one block per component
6 | Key component block

For all indexed file formats except IDXFORMAT"8", the key component block contains:

Size | Description of the field
2
Bit 15
Duplicates permitted flag. If set, duplicates are permitted.
Bits 14-0
Length of component in bytes.
2 | Offset of component within data record, starting at 0.
1 | Component type. Value zeros.

For IDXFORMAT"8" files, the key component block contains:

Size | Description of the field
2 | Length of component in bytes.
2 | Offset of component within data record, starting at 0.
1 Component flags:
Bit 6
Descending
1 Component type:
Bit 7
Numeric.
Bit 6
Signed.
Bits 5-0
If not numeric:

0 – alphanumeric

If numeric:

h"00" – DISPLAY (SIGN TRAILING INCLUDED)

h"01" – DISPLAY (SIGN TRAILING SEPARATE)

h"02" – DISPLAY (SIGN LEADING INCLUDED)

h"03" – DISPLAY (SIGN LEADING SEPARATE)

h"20" – COMP

h"21" – COMP-3

h"22" – COMP-X

h"23" – COMP-5

h"24" – FLOAT

Parent topic: Index File
Related concepts
Types of Indexed File


Index File - Index Node Record

For each key defined, a complete and independent index is constructed which consists of a tree of index node records. Each index node record contains actual key values associated with data records written to the indexed file. Every key value in a node will point either to a subordinate index node record or, if it is a leaf node, to the data record associated with the key.

The top level node record is called the root.

The default node size is 1024 bytes, but can change depending on the largest key size defined for the file. If the largest key is greater than 238 bytes, the node size will be 4096 bytes.

Note: It is possible to change the default node size by setting the XFHNODE environment variable to one of 512, 1024 (the default) or 4096 bytes. However, if you set XFHNODE to 512 and the largest key value is greater than 120 bytes, the value of XFHNODE will be overwritten by 1024. Also, if you set XFHNODE to 512 or 1024 and the largest key value is greater than 248, the value of XFHNODE will be overwritten by 4096. The setting of XFHNODE is only effective at the time that the file is created - you cannot alter the node size of an existing file.

The index node record contains:

Size | Description of the field
2
Bit 15
Security flag. Value should match value of trailing security flag.
Bits 14-0
Pointer to the end of the last key value block in this record, relative to the start of this record.
n | Key value block
...
n | Key value block
1 Index number.

The value is the same for all nodes belonging to the same index tree. Contains zero if this is the primary key.

1
Bit 7
Security flag. Value should match value of leading security flag.
Bits 6-0
Level of this node. Leaf nodes are level 0.

The key value block contains:

Size | Description of the field
1 | Present only when compression of leading characters is enabled. Contains a count of leading characters identical to those in the previous key. It will always be 0 for the first key in a node.
1 | Present only when compression of trailing spaces is enabled. Contains a count of trailing spaces for this key value.
n | Key value.
duplicate-occurrence | Optional. Duplicate occurrence number. See the topic Types of Indexed File for details. This field is present only if duplicates are allowed for this key. It contains the duplicate occurrence count. The first key stored that is a duplicate has this field set to 1. Second duplicate has this field set to 2, and so on.
file-pointer-size
Most significant bit
Reserved if duplicate key compression is enabled. Set if the next Key-Value Block is a duplicate of this one.
Remainder
Address of the data record in the data file if this is a leaf node; otherwise, the address of the subordinate index node record in the index file.
Parent topic: Index File
Related concepts
Types of Indexed File


Data File

  • Indexed File - Data File Structure
Parent topic: Indexed Files


Indexed File - Data File Structure

The data file part of an indexed file contains all the data records.

Information about free records in the data file is maintained so that space created by deleting records can be re-used, preventing the file from growing too quickly.

In a fixed-format indexed file, this information is held in a free space record in the index file. This record has the same structure as the index free space record, but the addresses point to data file records.

In a variable-format indexed file, the information is held in a system record in the data file. All records are a multiple of the data record alignment size. For each slot length, a chain is maintained for all slots of that length that are free. The start of the chain for all lengths is maintained in the data free space record in the data file. This system record is always the same length as the maximum slot length or possible maximum compressed length (a record's length may increase when it is compressed) for the file. Each free slot pointed to contains, in the first n bytes after the record header, the address of the next free slot of the same length. For the last slot in the chain, this address contains zero.

The data free space record contains:

Offset | Size | Description of the field
0 | 2/4 | Record header.
2/4 | 4 | Offset of the first free data slot of length 8 bytes.
6/8 | 4 | Offset of the first free data slot of length 12 bytes.
... |  |
n | 4 | Offset of the first free data slot of maximum length.
Parent topic: Data File


Library Routines

For information on the library routines that perform file handling functions see the topic File and Filename Routines.

Parent topic: File Handling Reference
Related reference
File and Filename Routines


Limits

There are a number of limits that affect file handling operations in this COBOL system.

  • Limits - Overview
  • File Handling - COBOL Compiler Limits
  • File Handling - Run-time Limits
  • File Size Limits - General
  • Indexed File Size Limits
  • Sequential and Relative File Size Limits
  • File Handling - Operating System Limits
Parent topic: File Handling Reference


Limits - Overview

The following limits affect file handling:

  • COBOL run-time limits
  • File size limits
  • Indexed file size limits
  • Sequential and relative file size limits
  • Operating system limits

The limits associated with the COBOL Compiler cannot be exceeded. However, at run time, the operating system or hardware can affect the operation of the COBOL run-time, thereby imposing limits that are lower than those of the Compiler. In addition, the particular configuration of the operating system or hardware environment can directly impose limits that are lower than those of both the Compiler and the run-time.

Parent topic: Limits
Related information
File Handling - COBOL Compiler Limits
File Handling - Run-time Limits
File Size Limits - General
Indexed File Size Limits
Sequential and Relative File Size Limits
File Handling - Operating System Limits


File Handling - COBOL Compiler Limits

Remember that run-time limits and operating system limits may be lower than those of the COBOL Compiler.

Index key Limits

Per file (including split-key components) | 255 keys
Length of any one key, including split-key | 1016 bytes (performance best below 512)
Number of components in a split key | 62
Number of alternate keys: | 252

SORT/MERGE Operation Limits

Number of SORT input files: 128
Parent topic: Limits


File Handling - Run-time Limits

You should be aware that run-time limits may be lower than those imposed by the COBOL Compiler.

File sizes (number of records)

All file organizations No specifiable limit; depends on record size and file size

Index keys (numbers)

Records added with the same duplicate key value in:
 | IDXFORMAT 3 and C-ISAM | 65,535
 | With IDXFORMAT"4" or IDXFORMAT"8" directive | 4,294,967,297
Components in a split key: With IDXFORMAT"4" or IDXFORMAT"8" directive
 | (using Micro Focus format file) | 62
 | (using C-ISAM format file) | 8

Record sizes

All file types 62 KB
IDXFORMAT 9 | 4080 bytes
All other file types | 62 Kbytes
Note:

IDXFORMAT 9 files have a single primary key without duplicates.

Sort keys

Sort key size | 4096
Number of sort keys | 64
Parent topic: Limits


File Size Limits - General

The following limits affect file size in general:
  • 32-bit Windows platforms impose a file size limit of 4 Gbytes.
  • 64-bit Windows platforms allow for very large file sizes.
  • Some UNIX platforms impose a file size limit of 2 Gbytes.
Note: Even on UNIX platforms that support larger file sizes, the default kernel settings frequently impose a 2 Gbyte limit.
Parent topic: Limits


Indexed File Size Limits

The following file size limits affect indexed files. The default (where IDXFORMAT=0) is IDXFORMAT 8.

To create files of a different format, use the IDXFORMAT extfh.cfg or compiler directive setting. To convert existing files to other formats, use the Rebuild utility.

IDXFORMAT | Exclusive (#) | Exclusive with duplicate key compression on | Shared with default locking | FILEMAXSIZE set to
1 | 4 Gb | 2 Gb | 1 Gb | 4 or 8
2 | 4 Gb | 2 Gb | 1 Gb | 4 or 8
3 | 4 Gb | 2 Gb | 1 Gb | 4 or 8
4 | 4 Gb | 2 Gb | 1 Gb | 4 or 8
8 | 4 Gb | 2 Gb | 1 Gb | 4
8 | 256 Tb | 128 Tb | 256 Tb | 8

where:

  • (#) = either accessing files exclusively or accessing shared files with the extfh.cfg or compiler directive setting of LOCKTYPE 1 or 2. That is, file size is not affected when using LOCKTYPE 1 or 2.
  • FILEMAXSIZE is an extfh.cfg setting that defaults to 8
  • For IDXFORMAT 8 files only, if you increase the extfh.cfg setting FILEPOINTERSIZE to 8, you increase file size limits to:
    IDXFORMAT | Exclusive (#) | Exclusive with duplicate key compression on | Shared with default locking | FILEMAXSIZE set to
    8 | 16 Eb | 8 Eb | 4 Eb | 8
Note:
  • The above figures are determined by the pointer size used to address the file. For example:
    32 bits = 2^32 = 4,294,967,296 bytes = 4 Gb (Gigabytes)
    48 bits = 2^48 = 281,474,976,710,656 bytes = 256 Tb (Terabytes)
    64 bits = 2^64 = 18,446,744,073,709,551,616 bytes = 16 Eb (Exabytes or MegaTerabytes)
  • LOCKTYPE settings of 1 and 2 were specifically introduced in order to avoid the file size limit imposed by sharing files.
  • If you set FILEMAXSIZE to 8, IDXFORMAT 8 supports very large files with the default locking mechanism. Therefore, you are recommended to use IDXFORMAT 8 for large files rather than any of the other formats which also require LOCKTYPE 1 or 2 for large files. (LOCKTYPE=1 has the disadvantage of not allowing locked data to be read at all while LOCKTYPE=2 has the disadvantage of using up an extra file handle for the .LCK file that contains the locks).
Parent topic: Limits
Related reference
FILEMAXSIZE
IDXFORMAT
FILEPOINTERSIZE
LOCKTYPE


Sequential and Relative File Size Limits

The following file size limits affect sequential (including line sequential) and relative files:

Exclusive | Shared | FILEMAXSIZE set to
4 Gb | 1 Gb | 4
8 MTb | 4 MTb | 8

where FILEMAXSIZE is a File Handler configuration file setting that defaults to 8.

Parent topic: Limits
Related reference
FILEMAXSIZE


File Handling - Operating System Limits

The operating system and hardware configuration impose direct limits which can be lower than those imposed by either the COBOL Compiler or the COBOL run-time.

You must check your operating system and hardware to discover the actual values for any limits, but the following table lists items that you should consider:

  • Record locks
  • File locks
  • Length of contents of DD_ environment variables
  • File and record sizes
  • Files open simultaneously
  • Filename size and format

You should also be aware that the number and size of index keys can be limited if you are using a non-standard file handler and that the number and size of sort keys can be limited if you are using a non-standard SORT module.

Parent topic: Limits


Rebuild Command Line Options

The general format of the Rebuild command line is:

rebuild in-file [,out-file] [options]
CAUTION:
If you use Rebuild through Fileshare you can only use the options that are supported for such use. Otherwise you will obtain undefined results. See the topic Rebuild through Fileshare for more information.
  • Rebuild Options - Overview
  • Rebuild Options - /c
    Specifies file compression.
  • Rebuild Options - /d
    Specifies that Rebuild should reconstruct the index of an indexed file from the data area.
  • Rebuild Options - /e
    Specifies Rebuild's behavior when it encounters an illegal duplicate key while rebuilding a corrupt file or a file with a new key structure (using /k).
  • Rebuild Options - /f
    Validates an indexed file.
  • Rebuild Options - /i
    Displays information about the input and output files, including record lengths, file type and key structure.
  • Rebuild Options - /k
    Defines the key structure of an indexed file.
  • Rebuild Options - /l
    Specifies the loading and unloading of files.
  • Rebuild Options - /n
    Displays information about a file.
  • Rebuild Options - /o
    Specifies the organization of the input and output files.
  • Rebuild Options - /p
    Instructs Rebuild to rebuild an IDXFORMAT"8" file in place.
  • Rebuild Options - /r
    Defines the record structure of the input and output files.
  • Rebuild Options - /s
    Specifies the format of the input file.
  • Rebuild Options - /t
    Specifies the indexed format of the output file.
  • Rebuild Options - /u
    Instructs Rebuild to attempt to recover a file for which the last update operation was not completed.
  • Rebuild Options - /v
    Causes Rebuild to display progress information as it processes the file.
  • Rebuild Options - /x
    Defines the key-of-reference.
  • Rebuild Options - /y
    Instructs Rebuild to ignore any mismatch between the physical file size and the file size indicated in the file header.
  • Rebuild Options - /z
    Instructs Rebuild to use a Fileshare server for file access.
  • Rebuild Options - //q
    Suppresses the display of the Rebuild banner.
  • Rebuild Options - //v
    Displays the version number of Rebuild.
Parent topic: File Handling Reference


Rebuild Options - Overview

The general format of the Rebuild command line is:

rebuild in-file [,out-file] [options]

Both in-file and out-file must include the filename extension. The filename of out-file must not be the same as in-file. To implement filename mapping, you can use environment variables in place of in-file or out-file.

Note:

On UNIX systems, Rebuild options must be preceded by a hyphen (-) character rather than a slash (/) character (or two hyphen characters in the case of //q and //v.

Note:
  • The /m and //q options are not currently available.
  • If the /f or /v option is followed by parameters, use a colon (:) before the parameter(s). For other options, the colon is not required.
  • You can place options anywhere within the command, except that options beginning with two slashes must be placed before options beginning with one slash.
  • Options are free-format; spaces are required between options.
  • Do not insert spaces between the parameters of options.
CAUTION:
If you use Rebuild through Fileshare you can only use the options that are supported for such use. Otherwise you will obtain undefined results. See the topic Rebuild through Fileshare for more information.
Parent topic: Rebuild Command Line Options
Related reference
Rebuild through Fileshare


Rebuild Options - /c

Specifies file compression.

Data compression can only be specified for an output file. Key compression can be specified for an output file or the rebuild of an existing file.

The /c option operates in a similar manner to the Compiler directives DATACOMPRESS and KEYCOMPRESS.

Parameters

d n
Data compression. n must be in the range 0 through 255:
Value | Description
0 | No data compression.
1 through 127 | Reserved.
128 through 255 | User-defined compression routines.
i n
Key compression. n must be in the range 0 through 15:
Value | Description
0 | No key compression.
1 | Duplicates are compressed.
2 | Leading characters are compressed.
4 | Leading spaces are compressed.
8 | Trailing nulls are compressed.
You can specify any combination of these key compressions by adding together the appropriate values.
Note: You cannot compress the data in C-ISAM and Level 2 files.

Examples

-c:d1i6

specifies data compression routine 1, and index compression of leading characters and trailing spaces.

-c:i1

specifies key compression of duplicates only.

Parent topic: Rebuild Command Line Options
Related information
Overview of Rebuild command line options


Rebuild Options - /d

Specifies that Rebuild should reconstruct the index of an indexed file from the data area.

Any corrupt data records are skipped and logged to a file.

Parameters

c n Attempt to recover all valid records from the data file to the physical end of file, rather than the logical end of file. This option is valid for C-ISAM files only.

Default

If the /d option is not set, Rebuild returns file status error 9/041 when it encounters a corrupted record.

Parent topic: Rebuild Command Line Options


Rebuild Options - /e

Specifies Rebuild's behavior when it encounters an illegal duplicate key while rebuilding a corrupt file or a file with a new key structure (using /k).

When /e is set in such circumstances, Rebuild reports the duplicate, writes it to a duplicates file and continues to process the remaining records. The record with the duplicate key is not written to the file being rebuilt.

The duplicates file has the same file organization as the input file unless it is indexed, in which case the duplicates file is sequential. The duplicates file contains the same type of records, fixed-length or variable-length, as the input file. The name of the file is the input filename with .err appended, and it is written to the same directory as the input file.

Default

When /e is not set, Rebuild ends with an "Error on output file - status 22" error.

Parent topic: Rebuild Command Line Options


Rebuild Options - /f

Validates an indexed file.

If the file is corrupt, Rebuild returns a non-zero value.

Parameters

c
Specifies the validation to be performed. The default is 10.
Value | Description
2 | Checks the structure of the free space list (FSL).
8 | Checks the index file structure.
256 | Checks the data file structure with file open for sharing in another process. You cannot specify this check in combination with any other check.
0 | Nothing.
1 | Error messages only.
2 | Messages showing the options you have specified.
3 | Information about the file. This includes key definition, records lengths, data compression, and the version of the file handler that created and updated the file.
4 The different types of record present in the file:
  1. IDXFORMAT"4" information record.
  2. Deleted record.
  3. System record.
  4. Data record that has been reduced in size by a rewrite.
  5. Data record that has been increased in size by a rewrite, and therefore cannot fit into the original record area. Instead, this record points to another record area that contains the record.
  6. The record pointed to by a type 6 record.
  7. The record pointed to by a type 6 record.
  8. The record pointed to by a type 6 record.
5 | Statistics about each key structure. This includes information about how much space is being saved by key compression.
You can select a combination of checks 2 and 8 by adding the numbers together. The more checks you perform, the longer the validation takes.
d
Specifies the message level.
These values are cumulative, so if you specify level 4, you will also receive messages at levels 1, 2 and 3. The default is 5.
Value | Description
0 | Nothing.
1 | Error messages only.
2 | Messages showing the options you have specified.
3 | Information about the file. This includes key definition, records lengths, data compression, and the version of the file handler that created and updated the file.
4 The different types of record present in the file:
  1. IDXFORMAT"4" information record.
  2. Deleted record.
  3. System record.
  4. Data record that has been reduced in size by a rewrite.
  5. Data record that has been increased in size by a rewrite, and therefore cannot fit into the original record area. Instead, this record points to another record area that contains the record.
  6. The record pointed to by a type 6 record.
  7. The record pointed to by a type 6 record.
  8. The record pointed to by a type 6 record.
5 | Statistics about each key structure. This includes information about how much space is being saved by key compression.

Examples

rebuild test.dat -f:c8

checks the structure of the index file.

rebuild test.dat -f:d1

specifies error messages only.

rebuild test.dat -f:c2d1

checks the structure of the FSL and specifies error messages only.

rebuild test.dat -f

Performs a full integrity check on a file, displaying all possible information. This is the same as specifying -f:c10.

Note:

The display might end with one of the following messages:

File is corrupt

This means that the control information in the file is not consistent with the data. For example, a record may have been deleted but the list of deleted records does not include it. Such a file is reported as corrupt, even though the data itself is not corrupt.

File contains transaction data

This means that the control information may not be consistent with the data because the file contains records which were part of a Fileshare transaction which was not subject to a successful COMMIT or ROLLBACK.

For example, a record may have been written as part of a transaction, but a system failure caused Fileshare to stop processing before the transaction was COMMITed. If you are not using Fileshare Roll-Forward recovery, you can use rebuild to remove this transaction data by using the /d option and rebuilding to a new file. Note to quickly recover the file to a usable state that you can rebuild to the same file, this will recreate the index correctly (treating transaction data as deleted records) but the transaction record data will remain in the file, the space will not be reused and rebuild /f will continue to report that the “File contains transaction data”.

Parent topic: Rebuild Command Line Options
Related information
Overview of Rebuild command line options


Rebuild Options - /i

Displays information about the input and output files, including record lengths, file type and key structure.

If you want to display this information but do not want to perform any other processing, use the /n option instead.

Parent topic: Rebuild Command Line Options
Related reference
Rebuild Options - /n


Rebuild Options - /k

Defines the key structure of an indexed file.

The key structure is used to rebuild the index of an indexed file when the original index is missing or corrupt.

When converting non-indexed files to indexed files, this option is required to specify the key information for the new output file.

You can also use this option to

  • Replace the key structure of an existing indexed file with an alternative structure
  • Convert one indexed file to another with a different key structure.
  • Add a new key to an indexed file or remove an existing key without having to rebuild to a new file

Each key is defined by its starting character position within the record (the first character position in a record is 1) and its length in characters. The starting position and length must be separated by a plus sign (+) or the letter L.

The definition of one key is separated from the definition of the next key by a colon (:).

Each key can be defined as a number of parts (split key), each part being separated by a comma (,).

Alternate keys (those other than the first defined) can be terminated by the parameter d, indicating WITH DUPLICATES.

You can use the s parameter to specify a sparse key. The s parameter must be followed by the sparse character itself. If the sparse character is non-printable, or a lower or upper case 'd', the s parameter must be followed by d value, where value is the decimal value of the sparse character.

Different key compression values can be specified for each key by using the c parameter, indicating compression. The c parameter must be followed by a key compression value between 0 and 7.

You can add or remove a key without having to rebuild to a new file or specify all the keys again. To add a key you use the a parameter; to remove a key you use the r parameter. You can only add or remove one key at a time, and you can only rebuild in place. You cannot use any other functions when you are adding or removing a key

Examples

  • This example defines a single key, starting at character position 1 and 20 characters in length.
    -k:1+20
  • This example defines three keys. The first key, the primary key, starts at character position 5 and is 5 characters in length; the second key, an alternate key allowing duplicates, starts at character position 20 and is 1 character in length; the third key, a split alternate key, has two parts, the first starting at character position 40 and 2 characters in length and the second starting at character position 43 and 10 characters in length.
    -k:5+5:20+1d:40+2,43+10
  • This example defines two keys. The first key, the primary key, starts at character position 1 and is 5 characters in length; the second key, an alternate, sparse key allowing duplicates, starts at character position 20 and is 10 characters in length, the sparse character is Z.
    -k:1+5:20+10dsZ
  • This example defines two keys. The first key, the primary key, starts at character position 1 and is 5 characters in length. The second key, an alternate, sparse key allowing duplicates, starts at character position 20 and is 10 characters in length; the sparse character is the null character.
    -k:1+5:20+10dsh0
  • This example defines two keys. The first key, the primary, starts at character position 1 and is 10 characters in length. The second key, an alternate compressed key allowing duplicates, starts at character position 11 and is 20 characters in length. The types of key compression being used are compression of duplicates (1) and compression of leading characters (2).
    -k:1+10:11+20dc3
  • This example adds a new key which allows duplicates. The key starts at character position 1 and is 3 characters in length.
    -k:a:1+3d
  • This example removes the key that starts at character position 10 and is 5 characters in length.
    -k:r:10+5
  • This example shows how to correctly rebuild the index of an index file when the original index is missing. Use the s parameter to select an idxformat 4 index.
    Note: When the index is missing you should specify the key information exactly as the original key specification for idxformat 4 files, as the data file contains control information related to keys which allow duplicates. If the new key information does not exactly match, it can result in file corruptions or loss of data. We recommend you use the f parameter to validate the rebuild once the new key has been created.
    rebuild infile.dat, outfile.dat -k:1+5:6:10d -s:MF4
Parent topic: Rebuild Command Line Options


Rebuild Options - /l

Specifies the loading and unloading of files.

Use the /l option when you are loading to and unloading from IDXFORMAT 9 files.

For loading, you need to define the record size and key definition (one key only).

All records must be the key order of the target file and there must be no records which result in duplicate keys.

You do not need to define the record size and key definition for unloading.

Parameters

r9 | Load a record sequential file to an IDXFORMAT 9 file
9r | Unload an IDXFORMAT 9 file to a record sequential file

Examples

rebuild /l:r9 file1, file2 /k:1+10 /r:v20-30

This example loads a record sequential file to an IDXFORMAT 9 file, with the key structure specified by the /k option and the recording mode and record lengths specified with the /r option.

rebuild /l:9r file1, file2

This example unloads an IDXFORMAT 9 file to a record sequential file.

Parent topic: Rebuild Command Line Options


Rebuild Options - /n

Displays information about a file.

The /n option displays the same information as the /i option, plus the number of data records in the file, but without performing any other processing.

Parent topic: Rebuild Command Line Options
Related reference
Rebuild Options - /i


Rebuild Options - /o

Specifies the organization of the input and output files.

If the input file is line sequential and the record contains COMP or COMP-3 items, the file must have been created with the INSERTNULL configuration option set to ON. If the file has been created with INSERTNULL set to OFF, or has come from a third party and does not precede non-printable characters with null bytes, the file will not be correctly processed if the COMP/COMP-3 items contain bytes with the values x"00", x"09" (tab), x"0A" (newline) or x"0D" (carriage return).

Parameters

/o:infile-org[,outfile-org]

infile-org and outfile-org can be any of the following:

Value | Description
lseq | line sequential
seq | sequential
rel | relative
ind | indexed

This format enables you to convert from any one file organization to another.

If outfile-org is omitted, the output file will have the same organization as the input file.

Using this syntax, you can convert a line sequential file to an indexed file, or an indexed file to a variable sequential file, and so on.

Examples

rebuild in-file, out-file /o:lseq,ind /t:mf /k:1+10 /r:v20-30

converts a line sequential file to an indexed file with the key structure specified by the /k option, the file format specified by the /t option, and the recording mode and recording lengths specified by the /r option. The key information must be wholly contained within the minimum record length.

rebuild in-file, out-file /o:ind,seq /r:v20-30

converts an indexed file to a variable length sequential file with the recording mode and record lengths specified by the /r option.

Parent topic: Rebuild Command Line Options


Rebuild Options - /p

Instructs Rebuild to rebuild an IDXFORMAT"8" file in place.

The rebuild uses less disk space, but if it fails the file is lost. You must back up the file before you attempt a rebuild with this option.

Parent topic: Rebuild Command Line Options


Rebuild Options - /r

Defines the record structure of the input and output files.

You can specify a different record structure for the output file, and if the record length of the output file is greater than the record length of the input file, you can specify a padding character. You need to specify the record structure of the input file only where the file does not have a header. If you do not specify the record structure of the output file it will have the same structure as the input file. If you only specify one record structure, it is taken to be the record structure of the output file, unless the input file has no header, in which case it is taken to be the record structure of the input file.

If you convert to and from Btrieve format indexed files using the /s and /t options, you might need to supply the /r option, even where you are not changing the record structure. This is because some indexed file features are implemented differently by Btrieve. An example is that Btrieve does not store the maximum record length. Therefore, on conversion from a COBOL format file to a Btrieve file and back again, certain record length and recording mode information can be lost. This makes the file unreadable to a COBOL program using the original file description. Using the /r option, you can specify the record length and recording mode information on the command line to retain the correct record definitions during conversion. You can determine the correct options from the COBOL format file using the /n option.

Parameters

frecord-length | specifies a fixed-length record format with records of record-length
vmin-record-length-max-record-length | specifies a variable-length format where min-record-length is the minimum record length and max-record-length is the maximum record length. Separate the lengths with a hyphen
ppad-character|[ddecimal-value] | specifies the padding character where the output record length is greater than the input record length. The default is spaces for line sequential files and NULLs for all other file organizations. d indicates that the padding character is supplied as a decimal value in the range 0 through 255, indicating the ANSI character to be used

Examples

r:f100

(where the input file has no header) specifies that the input file has a fixed record length of 100 bytes and that the output file will have the same fixed record length.

-r:v100-200

(where the input file has a header) specifies that the output file will have a variable record length with a minimum record length of 100 bytes and a maximum record length of 200 bytes.

r:f20,f30pZ

specifies that the input file has a fixed record length of 20 bytes, and that the output file will have a fixed record length of 30 bytes with Z used as a padding character.

r:f40pd49

specifies that the output file will have a fixed record length of 40 bytes with the character "I" used as a padding character.

Parent topic: Rebuild Command Line Options


Rebuild Options - /s

Specifies the format of the input file.

Parameters

/s:btrv | Btrieve format
 | C-ISAM format
 | C-ISAM format
/s:lii | Level II V2.5 COBOL format
/s:l2 | Level II V2.5 COBOL format
/s:mf | IDXFORMAT"3" format
/s:mf4 | IDXFORMAT"4" format
/s:mf8 | IDXFORMAT"8" format
Note:
  • Since Rebuild automatically recognizes the file format, you do not need to specify this option.
Parent topic: Rebuild Command Line Options
Related reference
Rebuild Options - /t


Rebuild Options - /t

Specifies the indexed format of the output file.

If /t is not specified, the output file will have the same format as the input file, or the default format if the input file is not indexed.

Parameters

/t:btrv | Btrieve format
 | C-ISAM format
 | C-ISAM format
/t:lii | Level II V2.5 COBOL format
/t:l2 | Level II V2.5 COBOL format
/t:mf | IDXFORMAT"3" format
/t:mf4 | IDXFORMAT"4" format
/t:mf8 | IDXFORMAT"8" format
Parent topic: Rebuild Command Line Options
Related reference
Rebuild Options - /s


Rebuild Options - /u

Instructs Rebuild to attempt to recover a file for which the last update operation was not completed.

Use this option if a program failed or was terminated while updating a file. Rebuild may be able to recognise the specific problem with the file and fix it. This is quicker than doing a standard rebuild, so try this option first.

Parent topic: Rebuild Command Line Options


Rebuild Options - /v

Causes Rebuild to display progress information as it processes the file.

This is useful if you want to keep track of how Rebuild is progressing. We recommend that you don't use the -v option if you are redirecting the output to a file.

Parameters

n If you specify the /f option, Rebuild displays a '"." character every n records. If you do not specify the /f option, Rebuild displays a a record count every n records. If you do not specify the n parameter, Rebuild displays information about its processing phases.

Parent topic: Rebuild Command Line Options


Rebuild Options - /x

Defines the key-of-reference.

The key-of-reference defines the order in which data is read when an indexed file is specified as an input file.

Parameters

n The number of the key to be used where the primary key is 0 and the alternate keys are numbered, starting at 1, in the order they are specified in the SELECT statement in the creating program.

Default

If no /x option is specified, the primary key (key 0) is assumed.

Example

-x:2

Data is written in the order specified by the second alternate key for the file.

Parent topic: Rebuild Command Line Options
Related tasks
Example of reorganizing an indexed file


Rebuild Options - /y

Instructs Rebuild to ignore any mismatch between the physical file size and the file size indicated in the file header.

If no /y option is specified and Rebuild detects that the physical file size is less than that indicated in the file header, it stops. This is because a possible cause of the problem is that striping information has not been supplied to Rebuild. Under these circumstances continuing with the rebuild could cause loss of records.

Parent topic: Rebuild Command Line Options


Rebuild Options - /z

Instructs Rebuild to use a Fileshare server for file access.

Use this option for using Rebuild through Fileshare.

Parameters

/z:server-name
server-name The name of a Fileshare server.
Parent topic: Rebuild Command Line Options


Rebuild Options - //q

Suppresses the display of the Rebuild banner.
Parent topic: Rebuild Command Line Options


Rebuild Options - //v

Displays the version number of Rebuild.
Parent topic: Rebuild Command Line Options


Rebuild Error, Information and Warning Messages

Rebuild may output error, information or warning messages when rebuilding, converting or reorganizing an indexed file.

Also, when Rebuild encounters a problem, it searches for the next good record and writes it to a file called rebuild.1af.

  • Syntax Errors
    These occur when an error is encountered, the command line is displayed with a caret (^) symbol under the point at which the error was detected and error message is displayed.
  • Execution Errors
    These occur when the program sets the return code to a value other than zero to indicate the type of error that has occurred.
  • Information Messages
    These messages are displayed for information purposes only.
  • Warning Messages
    Depending on the operation selected, some command line options are unnecessary. In these cases, the incorrect usage will be indicated, but the option will be ignored and processing will continue. Note that the option may be correct, but omission of other information may have caused Rebuild to select the wrong process. If this is the case, correct the command line and rerun.
Parent topic: File Handling Reference


Syntax Errors

These occur when an error is encountered, the command line is displayed with a caret (^) symbol under the point at which the error was detected and error message is displayed.

If an error in the syntax of the command line occurs, the return code will be set to 9.

  • Key positions must be specified using /k option
    You did not supply a key definition for the index of the file being generated from a sequential or relative file, or from an indexed file with a missing .idx component
  • Data compression out of range
    The integer you specified for data compression is not within the allowable range.
  • Data compression specified more than once
    You have specified the option for data compression more than once; that is, /c:[dn][dn]
  • Input file same as output file
    You have given the output file the same name as the input file.
  • Index compression out of range
    The integer you specified for index compression is not within the allowed range.
  • Index compression specified more than once
    You have specified the option for index compression more than once; that is, /c[in][in].
  • Invalid command line
    The command line contains an error other than those described in more specific syntax error messages.
  • Invalid compression choice - must be 'd' or 'i'
    The specification of data or index compression was not correct.
  • Invalid format
    The value you specified for index file format is invalid.
  • Invalid key length - cannot be zero
    One of the keys you defined has a zero length, which is illegal. This may be due to incorrect use of separator characters.
  • Invalid key specification - key not contained in record
    One of the keys, as defined, is not wholly contained in the record. This is illegal.
  • Invalid key start - cannot be zero
    One of the keys defined has a start character position of zero, which is illegal. This may be due to incorrect use of separator characters.
  • Invalid key structure - '+' expected
    A key part parameter of the /k option is incorrect.
  • Invalid option
  • Invalid organization
    The syntax of the /o option is incorrect.
  • Invalid organization - must be indexed for index rebuild
    You have specified a non-indexed input file with no output file. If there is no output file Rebuild assumes that you want to rebuild an indexed file.
  • Invalid record length - cannot be zero
    You have specified that the length of a record is zero. This is invalid.
  • Invalid record lengths - maximum must not be less than minimum
    The integers you have used to specify the maximum and minimum lengths of a record indicate that the maximum length is less than the minimum length. This is invalid.
  • Invalid record parameter - '-' expected
    When specifying the record structure of a variable length file, you have not separated the minimum record length and the maximum record length with a hyphen (-).
  • Invalid record type - 'F' or 'V' expected
    You have entered record type other than fixed or variable. This is invalid.
  • Invalid format
    The format of the /s or /t option is incorrect.
  • No output file specified for /t option to refer to
    You did not specify a name for the output file which was referred to with the /t option.
  • No output file specified for data compression
    You did not specify an output filename for data compression.
  • Number expected
    You have specified another character where a number was expected.
  • Output organization was specified but not output file name
    You did not supply a filename although you specified an output organization.
  • Options file not found
    The options file specified on the command line cannot be found.
Parent topic: Rebuild Error, Information and Warning Messages


Key positions must be specified using /k option

You did not supply a key definition for the index of the file being generated from a sequential or relative file, or from an indexed file with a missing .idx component

Resolution:

Specify a key definition.

Parent topic: Syntax Errors


Data compression out of range

The integer you specified for data compression is not within the allowable range.

Resolution:

Data compression requires an integer in the range 0 through 255.

Parent topic: Syntax Errors


Data compression specified more than once

You have specified the option for data compression more than once; that is, /c:[dn][dn]

Resolution:

Use the correct format: /c:[dn][in]

Parent topic: Syntax Errors


Input file same as output file

You have given the output file the same name as the input file.

Resolution:

Use a different output filename.

Parent topic: Syntax Errors


Index compression out of range

The integer you specified for index compression is not within the allowed range.

Resolution:

Specify an integer in the range 0 through 15.

Parent topic: Syntax Errors


Index compression specified more than once

You have specified the option for index compression more than once; that is, /c[in][in].

Resolution:

Use the correct format: /c:[dn][in].

Parent topic: Syntax Errors


Invalid command line

The command line contains an error other than those described in more specific syntax error messages.

Resolution:

Check the syntax, spelling, and spacing in the command line you are trying to enter.

Parent topic: Syntax Errors


Invalid compression choice - must be 'd' or 'i'

The specification of data or index compression was not correct.

Resolution:

Specify the d or i parameter.

Parent topic: Syntax Errors


Invalid format

The value you specified for index file format is invalid.

Resolution

Specify a valid value: C-ISAM, CISAM, MF, MF4, MF8, BTRV, LII, L2.

Parent topic: Syntax Errors


Invalid key length - cannot be zero

One of the keys you defined has a zero length, which is illegal. This may be due to incorrect use of separator characters.

Resolution:

Make sure that any keys you define have a valid length.

Parent topic: Syntax Errors


Invalid key specification - key not contained in record

One of the keys, as defined, is not wholly contained in the record. This is illegal.

Resolution:

Ensure that the key is wholly contained in the record. For variable length records, the key must be wholly contained in the minimum length record.

Parent topic: Syntax Errors


Invalid key start - cannot be zero

One of the keys defined has a start character position of zero, which is illegal. This may be due to incorrect use of separator characters.

Resolution:

Make sure that any keys you define have a valid start character.

Parent topic: Syntax Errors


Invalid key structure - '+' expected

A key part parameter of the /k option is incorrect.

Resolution:

Make sure that you specify each key part as start character position and length separated by a plus (+) or L.

Parent topic: Syntax Errors


Invalid option

Parent topic: Syntax Errors


Invalid organization

The syntax of the /o option is incorrect.

Resolution:

Specify a valid organization, one of: lseq, seq, rel and ind. The forms s, r, i, si and ri are also permitted for compatibility with previous products.

Parent topic: Syntax Errors


Invalid organization - must be indexed for index rebuild

You have specified a non-indexed input file with no output file. If there is no output file Rebuild assumes that you want to rebuild an indexed file.

Resolution:

Make sure that you specify an output file if your input file is not an indexed file.

Parent topic: Syntax Errors


Invalid record length - cannot be zero

You have specified that the length of a record is zero. This is invalid.

Resolution

Specify a length greater than zero which falls within the limits for record lengths for this COBOL system.

Parent topic: Syntax Errors


Invalid record lengths - maximum must not be less than minimum

The integers you have used to specify the maximum and minimum lengths of a record indicate that the maximum length is less than the minimum length. This is invalid.

Resolution

Reenter the maximum or minimum record length, ensuring that the maximum length is greater than the minimum length.

Parent topic: Syntax Errors


Invalid record parameter - '-' expected

When specifying the record structure of a variable length file, you have not separated the minimum record length and the maximum record length with a hyphen (-).

Resolution:

Use the correct format: /r:vminreclen-maxreclen

Parent topic: Syntax Errors


Invalid record type - 'F' or 'V' expected

You have entered record type other than fixed or variable. This is invalid.

Resolution

Reenter the record type using either f (fixed) or v (variable).

Parent topic: Syntax Errors


Invalid format

The format of the /s or /t option is incorrect.

Resolution:

For details of the correct format see the help topic Rebuild Options - /s or the help topic Rebuild Options - /t.

Parent topic: Syntax Errors
Related information
Rebuild Options - /s
Rebuild Options - /t


No output file specified for /t option to refer to

You did not specify a name for the output file which was referred to with the /t option.

Resolution:

Specify the name of an output file for this option.

Parent topic: Syntax Errors


No output file specified for data compression

You did not specify an output filename for data compression.

Resolution:

Specify a valid output filename.

Parent topic: Syntax Errors


Number expected

You have specified another character where a number was expected.

Resolution:

Specify a numeric value for this parameter.

Parent topic: Syntax Errors


Output organization was specified but not output file name

You did not supply a filename although you specified an output organization.

Resolution:

Specify an output filename.

Parent topic: Syntax Errors


Options file not found

The options file specified on the command line cannot be found.

Resolution:

Check that the file exists, and the specification used on the command line is correct.

Parent topic: Syntax Errors


Execution Errors

These occur when the program sets the return code to a value other than zero to indicate the type of error that has occurred.
  • ***Error on input file - disk space exhausted
    File processing cannot continue because there is insufficient disk space to do so.
  • ***Error on input file - duplicate key - record not written:
    The record was not written to the output file as this would have created an invalid duplicate key.
  • ***Rebuild aborted - file is not as specified in s option (s option not required)
    The file specified by the /s option was not recognized.
  • ***Error on input file - File locked
    The file you specified as your input file is locked by another process.
  • ***Error on input file - file not found
    The input file cannot be found. The return code is set to 1.
  • ***Error on input file - illegal filename specified
    A filename does not conform to the standards imposed by the operating system or COBOL system.
  • ***Error on input file - invalid key of reference specified in x option
    The number specified in the key-of-reference option (/x) is greater than or equal to the number of keys for the given file. The return code is set to 1.
  • ***Error on input file - status xx, and ***Error on input file - status 9/yyy
    An error other than one of the above input file errors has occurred while processing the input file.
  • ***Error on output file - record length << min or >> max
    Rebuild attempted to write a record to the output file with a record length less than the minimum or greater than the maximum length for the file.
  • ***Error on output file - status xx, and ***Error on output file - status 9/yyy
    An error has occurred processing the output file.
Parent topic: Rebuild Error, Information and Warning Messages


***Error on input file - disk space exhausted

File processing cannot continue because there is insufficient disk space to do so.

Resolution:

Ensure that the input file is not corrupt. The output file is closed and should be usable, even if the rebuild is not complete.

Parent topic: Execution Errors


***Error on input file - duplicate key - record not written:

The record was not written to the output file as this would have created an invalid duplicate key.
Parent topic: Execution Errors


***Rebuild aborted - file is not as specified in s option (s option not required)

The file specified by the /s option was not recognized.

Resolution:

Either remove the /s option or correct it.

Parent topic: Execution Errors


***Error on input file - File locked

The file you specified as your input file is locked by another process.

Resolution:

Try again when the file is free to be accessed.

Parent topic: Execution Errors


***Error on input file - file not found

The input file cannot be found. The return code is set to 1.

Resolution:

Check that the filename you entered is correct, and the file does actually exist.

Parent topic: Execution Errors


***Error on input file - illegal filename specified

A filename does not conform to the standards imposed by the operating system or COBOL system.

Resolution:

Try the file operation again using a correct filename.

Parent topic: Execution Errors


***Error on input file - invalid key of reference specified in x option

The number specified in the key-of-reference option (/x) is greater than or equal to the number of keys for the given file. The return code is set to 1.

Resolution:

Check the key required, and try again.

Parent topic: Execution Errors


***Error on input file - status xx, and ***Error on input file - status 9/yyy

An error other than one of the above input file errors has occurred while processing the input file.

Possible causes are:

  • The file does not exist
  • A hardware error has occurred opening or reading the file
  • The file is corrupt

The status xx is a COBOL file status. If the first byte is a 9, then the status yyy is a COBOL run-time error number. The output file is closed, and should be usable, even if the rebuild is not complete. The return code is set to 1.

Resolution:

Investigate the error. For run-time system error messages see the help topic Run-time System Error Messages.

Parent topic: Execution Errors
Related reference
***Error on output file - status xx, and ***Error on output file - status 9/yyy
File Status Codes
Run-time System Error Messages


***Error on output file - record length << min or >> max

Rebuild attempted to write a record to the output file with a record length less than the minimum or greater than the maximum length for the file.

Resolution:

Change the record lengths specified in the /r option.

Parent topic: Execution Errors


***Error on output file - status xx, and ***Error on output file - status 9/yyy

An error has occurred processing the output file.
Possible causes are:
  • The file cannot be created
  • A hardware error has been encountered on opening or writing the file
  • The parameters specified are incorrect.

The status xx is a COBOL file status. If the first byte is a 9, then the status yyy is a COBOL run-time error number. The return code is set to 2.

Resolution:

Investigate the error. For run-time system error messages see the help topic Run-time System Error Messages.

Parent topic: Execution Errors
Related reference
***Error on input file - status xx, and ***Error on input file - status 9/yyy
File Status Codes
Run-time System Error Messages


Information Messages

These messages are displayed for information purposes only.
  • Rebuild successful
    The file you specified has been successfully rebuilt.
  • Records processed
    The indicated number of records were processed when the file was rebuilt or reorganized.
Parent topic: Rebuild Error, Information and Warning Messages


Rebuild successful

The file you specified has been successfully rebuilt.
Parent topic: Information Messages


Records processed

The indicated number of records were processed when the file was rebuilt or reorganized.
Parent topic: Information Messages


Warning Messages

Depending on the operation selected, some command line options are unnecessary. In these cases, the incorrect usage will be indicated, but the option will be ignored and processing will continue. Note that the option may be correct, but omission of other information may have caused Rebuild to select the wrong process. If this is the case, correct the command line and rerun.
  • Option ignored - k option not needed with n option
    A key definition option has been together with a request for file information. The k option is ignored.
  • Option ignored - x option not needed for index rebuild
    A key-of-reference option has been used when an action other than indexed file reorganization has been selected. The option is ignored.
Parent topic: Rebuild Error, Information and Warning Messages


Option ignored - k option not needed with n option

A key definition option has been together with a request for file information. The k option is ignored.
Parent topic: Warning Messages


Option ignored - x option not needed for index rebuild

A key-of-reference option has been used when an action other than indexed file reorganization has been selected. The option is ignored.
Parent topic: Warning Messages


Run-time Switches

The following run-time switches affect file handling:
L2 - Record Terminator Switch
The record terminator switch specifies the character to be used as a record terminator in line sequential files. When -L2 (the default) is used, x"0A" is treated as the record terminator. When +L2 is used, x"0D0A" is treated as the record terminator.

Use of the +L2 switch is in many respects unnecessary for the majority of applications. The File Handler is able to recognize line sequential delimiters for data files created on either Windows or UNIX systems, irrespective of the platform on which the files are processed. Using this method to change the delimiters will not result in the user record area ever containing x'0D' characters (unless escaped using the INSERTNULL option) because these are discarded as noise characters by the File Handler. This is in contrast to OCDS behavior.

N - Null Switch
When +N is used (which is the default), all characters less than x"1B" are preceded by a null byte (x"00"). If -N is used, characters less that x"1B" are treated as control characters; for example, x"1A" is treated as the end-of-file marker. If a file is created from an application running with -N, the file must be read back with an application running the same way; the same is true for files created from applications running with +N.
T - Tab Switch
The tab switch is set off (-T) by default. The tab switch compresses extra spaces to tab characters (x"09"), for line sequential files. This saves space in the file. If you write a file with +T set, you must use +T when reading the file and if you write a file with -T set, you must use -T when reading the file.
Parent topic: File Handling Reference
Related reference
L2 run-time switch
N run-time switch
T run-time switch


Sorting Files

  • Callable Sort Module
  • SORT Environment Variables
  • Mfsort Error Messages
Parent topic: File Handling Reference


Callable Sort Module

  • Sort Module Function Codes
  • Sort File Control Description
Parent topic: Sorting Files


Sort Module Function Codes

x"FA01" | Initiates the sort operation. If the number of USING files is other than zero, the sort starts immediately, using the specified files as input. If the number of GIVING files is other than zero, the sort operation processes the GIVING files before returning control to the calling program.
x"FA40" | Initiates the merge operation. For this operation the number of USING files must be other than zero. It is assumed that the records in each of the USING files are already sorted.
x"FAF3" | Releases a record to the sort operation. You should use this function only when the number of USING files is zero.
x"FA10" | Terminates the input stage of the sort operation. You should use this function only when the number of USING files is zero. It indicates that no more release operations are to be performed. If the number of GIVING files is other than zero, the sort operation writes the sorted data to the GIVING file and terminates.
x"FAF5" | Returns a record from the sort or merge operation. You should use this function only when the number of GIVING files is zero.
x"FA88" | Terminates the sort or merge operation, releasing all memory allocated for the operation and deleting any temporary files. You should use this function only when the number of GIVING files is zero. It indicates that no more return operations are to be performed.
Parent topic: Callable Sort Module


Sort File Control Description

The FCD used by the Callable Sort Module has the following fields in addition to, or overriding, the FCD used by the File Handler:
Field name | Size | Description of the field
fcd-use-files | 1 | Number of USING files involved in the sort operation (this can be zero)
fcd-give-files | 1 | Number of GIVING files involved in the sort operation (this can be zero)
fcd-col-seq-address | 4 | Pointer to the collating sequence (null if none used)
fcd-fildef-address | 4 | Pointer to the file definition block that defines the USING and GIVING files.

The key definition block is used to describe the structure of the key to be used in the sort operation. There is a pointer to this block in fcd-key-def-address in the Sort FCD.

For sort operations, only one key is allowed, although this key can have many components. Each of these components can be either ascending or descending and can have one of many different numeric formats. The first two bytes of the component definition area are used as follows:
Byte 0
Size: 1
bit 7 (x"80") | indicates duplicates to be returned in order
bit 6 (x"40") | indicates DESCENDING key
bit 1 (x"02") | indicates that SIGN is in EBCDIC format
bit 0 (x"01") | indicates that the data is in EBCDIC format
Byte 1
Size: 1
bit 7 (x"80")
indicates that the field is NUMERIC. If bit 7 is set:
bit 6 (x"40")
indicates that the field is SIGNED NUMERIC
bit 5 (x"20")
indicates that the field is a non-display field. If bit 5 is set:
bits 0 and 1
0 | indicates that the field is BINARY
1 | indicates that the field is PACKED-DECIMAL
2 | indicates that the field is COMP-X format
3 | indicates that the field is COMP-5 format
If bit 5 is not set (DISPLAY field) but bit 6 is set (SIGNED):
bits 0 and 1
0 | indicates SIGN TRAILING INCLUDED
1 | indicates SIGN TRAILING SEPARATE
2 | indicates SIGN LEADING INCLUDED
3 | indicates SIGN LEADING SEPARATE
bit 2 (value x"04")
indicates floating point
If bit 7 is not set:
Bit 1
set if the collating sequence specified in the FCD is to be applied to this field.

The file definition block is a table of pointers to the FCDs for each of the USING and GIVING files involved in the sort operation. The fcd-fildef-address field in the Sort FCD is a pointer to this area. The length of the file definition block is four times the total of the contents of the fields at offsets 52 and 53.

Parent topic: Callable Sort Module


SORT Environment Variables

The following environment variables can be used for configuring SORT:

  • MFJSENGINE
    Determines which sort engine the utility MFJSORT is to emulate.
  • MFJSERET
    Determines the response to an unsuccessful sort, copy or merge operation.
  • MFJSSTRICTSORT
    Enables strict mainframe emulation behavior during a sort.
  • MFJSTATS
    Produces a report for the SORT operation.
  • MFJSWINDOW
    Determines the sliding or fixed century window.
  • SORTCOMPRESS
    Determines whether to compress each record in a SORT operation.
  • SORTSCHEME
    To increase performance of a SORT operation, configure SORT to retain more of the record information in memory.
  • SORTSPACE
    Determines the amount of memory allocated to internal workspace for SORT operations.
  • SORTTEMPSPACE
    Determines the amount of temporary memory allocated for SORT operations.
  • SORTTYPE
    Determines the method for reading and writing files during SORT operations.
  • TEMPDIR/ TMP/ TEMP
    Determines where the run-time system of the directory stores paging files.
Parent topic: Sorting Files


MFJSENGINE

Determines which sort engine the utility MFJSORT is to emulate.

Use this variable with Enterprise Server only.

Parameters

DFSORT
Emulates DFSORT
SYNCSORT
Emulates SYNCSORT

The default is DFSORT.

Example

Parent topic: SORT Environment Variables
Related concepts
MFJSTATS
MFJSERET
MFJSSTRICTSORT
TEMPDIR/ TMP/ TEMP
SORTTYPE
SORTTEMPSPACE
SORTSPACE
SORTSCHEME
SORTCOMPRESS
Related reference
MFJSWINDOW


MFJSERET

Determines the response to an unsuccessful sort, copy or merge operation.

If this environment variable is not set, an unsuccessful operation and its program will terminate with an unrecoverable error (return code 16).

Parameters

ABEND
The operation will abend and its program will continue instead of terminating with an unrecoverable error (return code 16)

The default is that the variable is not set.

Example

MFJSERET=ABEND
Parent topic: SORT Environment Variables
Related concepts
MFJSENGINE
MFJSTATS
MFJSSTRICTSORT
TEMPDIR/ TMP/ TEMP
SORTTYPE
SORTTEMPSPACE
SORTSPACE
SORTSCHEME
SORTCOMPRESS
Related reference
MFJSWINDOW


MFJSSTRICTSORT

Enables strict mainframe emulation behavior during a sort.

Parameters

ON/OFF
Enables or disables the following mainframe behavior:
  • All JCL statements must contain a SYSOUT parameter, otherwise they will abend.
  • Modification of a ZD number with value 0 through INREC or OUTREC processing now keeps its sign value.
  • Records that are shorter than the output file's LRECL will be padded with low-values instead of spaces.

The default is OFF.

Example

MFJSSTRICTSORT=ON
Parent topic: SORT Environment Variables
Related concepts
MFJSENGINE
MFJSTATS
MFJSERET
TEMPDIR/ TMP/ TEMP
SORTTYPE
SORTTEMPSPACE
SORTSPACE
SORTSCHEME
SORTCOMPRESS
Related reference
MFJSWINDOW


MFJSTATS

Produces a report for the SORT operation.

Parameters

ON
The report is displayed to SYSOUT. If a report file already exists for a previous SORT operation, the new report is appended to it.
OFF
A report is not produced.

The default value is OFF.

Example

MFJSTATS=ON
Parent topic: SORT Environment Variables
Related concepts
MFJSENGINE
MFJSERET
MFJSSTRICTSORT
TEMPDIR/ TMP/ TEMP
SORTTYPE
SORTTEMPSPACE
SORTSPACE
SORTSCHEME
SORTCOMPRESS
Related reference
MFJSWINDOW


MFJSWINDOW

Determines the sliding or fixed century window.

Use this environment variable for Y2K compatibility, when two-digit year values are used.

Parameters

To set a sliding century window, set a value between 0 and 100. For example, a value of 80 would set a century window of 1931-2030 in 2011, 1932-2031 in 2012, and so on.

To set a fixed century window, set a value between 1000 and 3000. For example, a value of 1973 would set a century window of 1973-2072.

The default is a sliding value of 80 when emulating DFSORT, and a default value of 0 when emulating SYNCSORT. A value of 0 equates to a century window, starting in the current year.

Example

MFJSWINDOW=25

Comments

You can use this environment variable instead of the Y2PAST sort option.

Parent topic: SORT Environment Variables
Related concepts
MFJSENGINE
MFJSTATS
MFJSERET
MFJSSTRICTSORT
TEMPDIR/ TMP/ TEMP
SORTTYPE
SORTTEMPSPACE
SORTSPACE
SORTSCHEME
SORTCOMPRESS


SORTCOMPRESS

Determines whether to compress each record in a SORT operation.

When SORTCOMPRESS is set, run-length encoding of sort records results in much better performance when records contain multiple repeated characters.

Parameters

0
No compression.
Any number not equal to 0
Compression of records.

The default value is 0.

Example

SORTCOMPRESS=5
Parent topic: SORT Environment Variables
Related concepts
MFJSENGINE
MFJSTATS
MFJSERET
MFJSSTRICTSORT
TEMPDIR/ TMP/ TEMP
SORTTYPE
SORTTEMPSPACE
SORTSPACE
SORTSCHEME
Related reference
MFJSWINDOW


SORTSCHEME

To increase performance of a SORT operation, configure SORT to retain more of the record information in memory.

You should consider setting this environment variable if the total size of files in your SORT operation is over 1GB.

Parameters

0
During a SORT operation, temporary files are created to hold the non-key data portions of a record that are greater than 1024 bytes.
1

During a SORT operation, non-key data portions of a record are held in memory depending on the size of SORTSPACE:

Size of SORTSPACE | Maximum non-key data portion held in memory
1MB or greater | 5KB
4MB or greater | 12KB
8MB or greater | 28KB
16MB or greater | 62KB
Note: In general, the non-key data portion is the size of the record minus the size of the key data.

The default value is 0.

Example

SORTSCHEME=1
Parent topic: SORT Environment Variables
Related concepts
MFJSENGINE
MFJSTATS
MFJSERET
MFJSSTRICTSORT
TEMPDIR/ TMP/ TEMP
SORTTYPE
SORTTEMPSPACE
SORTSPACE
SORTCOMPRESS
Related reference
MFJSWINDOW


SORTSPACE

Determines the amount of memory allocated to internal workspace for SORT operations.

Typically, increasing SORTSPACE will improve the overall performance of SORT operations. This can be improved further by the use of SORTSCHEME when the files to be sorted are over 1GB.

Parameters

workspace size

Specify the amount of memory in one of the following formats:

Format | Workspace size
64M | 64 megabytes
2G | 2 gigabytes
1000000 | 1,000,000 bytes

The default value is 1,048,576 bytes (1MB).

The minimum value is 65,536 bytes (64KB).

The maximum value is 4,294,967,295 bytes (4GB - 1 byte).

Examples

SORTSPACE=64M
SORTSPACE=2G
SORTSPACE=1000000
Parent topic: SORT Environment Variables
Related concepts
MFJSENGINE
MFJSTATS
MFJSERET
MFJSSTRICTSORT
TEMPDIR/ TMP/ TEMP
SORTTYPE
SORTTEMPSPACE
SORTSCHEME
SORTCOMPRESS
Related reference
MFJSWINDOW


SORTTEMPSPACE

Determines the amount of temporary memory allocated for SORT operations.

If you cannot set SORTSPACE to allocate enough contiguous memory for a SORT operation, set SORTTEMPSPACE to the required amount, and then reduce the amount allocated by SORTSPACE. The memory required for the SORT operation can then be allocated in smaller chunks.

We recommend that you use SORTTEMPSPACE only if you are receiving COBRT105 Memory allocation error (Fatal) errors.

Parameters

workspace size

Specify the amount of memory in one of the following formats:

Format | Workspace size
64M | 64 megabytes
2G | 2 gigabytes
1000000 | 1,000,000 bytes

The default value is 1,048,576 bytes (1MB).

The minimum value is 65,536 bytes (64KB).

The maximum value is 4,294,967,295 bytes (4GB - 1 byte).

Example

SORTTEMPSPACE=64M
Parent topic: SORT Environment Variables
Related concepts
MFJSENGINE
MFJSTATS
MFJSERET
MFJSSTRICTSORT
TEMPDIR/ TMP/ TEMP
SORTTYPE
SORTSPACE
SORTSCHEME
SORTCOMPRESS
Related reference
MFJSWINDOW


SORTTYPE

Determines the method for reading and writing files during SORT operations.

Parameters

0 or 1
SORT operations use CBL_ routines, where possible, which improves performance.
2
SORT operations use the file handler, so that format modifications are picked up from the extfh.cfg file.

The default value is 0.

Example

SORTTYPE=2
Parent topic: SORT Environment Variables
Related concepts
MFJSENGINE
MFJSTATS
MFJSERET
MFJSSTRICTSORT
TEMPDIR/ TMP/ TEMP
SORTTEMPSPACE
SORTSPACE
SORTSCHEME
SORTCOMPRESS
Related reference
MFJSWINDOW


TEMPDIR/ TMP/ TEMP

Determines where the run-time system of the directory stores paging files.

By default, the paging files are stored in the current directory.

Parameters

pathname
Specify the pathname for the paging files, using the correct environment variable for your operating system:
Platform | Environment variable
UNIX | TMPDIR
Windows or other | TMP (or TEMP if TMP is not set)

Example

TMPDIR=/home/temp	*> UNIX
TMP=C:\temp		 *> WINDOWS
Parent topic: SORT Environment Variables
Related concepts
MFJSENGINE
MFJSTATS
MFJSERET
MFJSSTRICTSORT
SORTTYPE
SORTTEMPSPACE
SORTSPACE
SORTSCHEME
SORTCOMPRESS
Related reference
MFJSWINDOW


Mfsort Error Messages

Select the range containing your message number:

  • Messages 0001 to 0099
  • Messages 0100 to 0199
  • Messages 0200 to 0399
Parent topic: Sorting Files


Messages 0001 to 0099

Select the number of the message you require details about:

  • SORT011U SYSIN dataset value missing
  • SORT012U SYSIN dataset value missing
  • SORT013U I/O error on dataset value
  • SORT014U Status = value
  • SORT015U Command statement error(s) detected
    The sort will not execute because of errors found during the parsing of the command.
  • SORT019I Key length truncated to 4096 bytes
  • SORT020U SORT(EXTSM) failed - sort engine status = Value
    An unexpected failure occured after the sort had been initiated. This message indicates the returned sort file status value.
  • SORT032I Number records sorted
  • SORT033I Number records merged
  • SORT034I Number records copied
  • SORT035U SORTIN DSORG or RECFM missing
    At least one of the instructions RECORD and ORG was required and was not specified.
  • SORT036U SORTIN record length missing or invalid
    You did not specify a record length in the RECORD instruction, or else you specified an invalid length.
  • SORT037U SYSIN RECFM value invalid
  • SORT038U SORTIN RECFM value invalid
    The record format in the RECORD instruction for the input file is invalid.
  • SORT039U SORTOUT RECFM value invalid
    The record format in the RECORD instruction for the output file is invalid.
  • SORT040U SORT terminated by E15 Operator
    The user exit routine E15 has terminated the sort process.
  • SORT041U SORT terminated by E35 Operator
    The user exit routine E35 has terminated the sort process.
  • SORT042U Memory allocation failure
    The mfsort utility was unable to allocate the required memory.
  • SORT043U Too many OUTFIL files specified
    You have specified too many files in the OUTFIL option.
  • SORT044U Too many USE files specified
    You have specified too many files in the USE instruction.
  • SORT045U Too many GIVE files specified
    You have specified too many files in the GIVE instruction.
  • SORT050U ICETOOL input file not found
    The file that is to be sorted has not been found.
  • SORT051U ICETOOL output file not found
    The definition for the output file has not been found.
  • SORT090U SORT terminated - missing SYSOUT
    No catalog entry has been found for the SYSOUT file.
  • SORT091U SORT terminated - missing SYSIN
  • SORT092U SORT terminated - missing SORTOUT
  • SORT093U SORT terminated - missing SORTIN or SORTIN01
  • SORT094U SORT terminated - missing SORTOFvalue
  • SORT095U SORT terminated - Bad data in CHANGE field
    Please see the CHANGE and DFSORT documentation on the Micro Focus Web site.
  • SORT096U SORT terminated - missing FNAMES dataset value
    Please see the FNAMES and DFSORT documentation on the Micro Focus Web site.
Parent topic: Mfsort Error Messages


SORT011U SYSIN dataset value missing

Parent topic: Messages 0001 to 0099


SORT012U SYSIN dataset value missing

Parent topic: Messages 0001 to 0099


SORT013U I/O error on dataset value

Parent topic: Messages 0001 to 0099


SORT014U Status = value

Parent topic: Messages 0001 to 0099


SORT015U Command statement error(s) detected

The sort will not execute because of errors found during the parsing of the command.
Parent topic: Messages 0001 to 0099


SORT019I Key length truncated to 4096 bytes

Parent topic: Messages 0001 to 0099


SORT020U SORT(EXTSM) failed - sort engine status = Value

An unexpected failure occured after the sort had been initiated. This message indicates the returned sort file status value.

Resolution:

Investigate the file status. See the topic File Status.

Parent topic: Messages 0001 to 0099


SORT032I Number records sorted

Parent topic: Messages 0001 to 0099


SORT033I Number records merged

Parent topic: Messages 0001 to 0099


SORT034I Number records copied

Parent topic: Messages 0001 to 0099


SORT035U SORTIN DSORG or RECFM missing

At least one of the instructions RECORD and ORG was required and was not specified.

Resolution:

Provide the missing instruction and resubmit the sort.

Parent topic: Messages 0001 to 0099


SORT036U SORTIN record length missing or invalid

You did not specify a record length in the RECORD instruction, or else you specified an invalid length.

Resolution:

Provide or correct the record length and resubmit the sort.

Parent topic: Messages 0001 to 0099


SORT037U SYSIN RECFM value invalid

Parent topic: Messages 0001 to 0099


SORT038U SORTIN RECFM value invalid

The record format in the RECORD instruction for the input file is invalid.

Resolution:

Correct the record format and resusbmit the sort.

Parent topic: Messages 0001 to 0099


SORT039U SORTOUT RECFM value invalid

The record format in the RECORD instruction for the output file is invalid.

Resolution:

Correct the record format and resusbmit the sort.

Parent topic: Messages 0001 to 0099


SORT040U SORT terminated by E15 Operator

The user exit routine E15 has terminated the sort process.
Parent topic: Messages 0001 to 0099


SORT041U SORT terminated by E35 Operator

The user exit routine E35 has terminated the sort process.
Parent topic: Messages 0001 to 0099


SORT042U Memory allocation failure

The mfsort utility was unable to allocate the required memory.

Resolution:

Try reducing the value of the SORTSPACE environment variable.

Parent topic: Messages 0001 to 0099


SORT043U Too many OUTFIL files specified

You have specified too many files in the OUTFIL option.

Resolution:

Respecify your mfsort command with an OUTFIL instruction that names up to 100 files.

Parent topic: Messages 0001 to 0099


SORT044U Too many USE files specified

You have specified too many files in the USE instruction.

Resolution:

Respecify your mfsort command with a USE instruction that names up to 100 files.

Parent topic: Messages 0001 to 0099


SORT045U Too many GIVE files specified

You have specified too many files in the GIVE instruction.

Resolution:

Respecify your mfsort command with a GIVE instruction that names up to 100 files.

Parent topic: Messages 0001 to 0099


SORT050U ICETOOL input file not found

The file that is to be sorted has not been found.
Parent topic: Messages 0001 to 0099


SORT051U ICETOOL output file not found

The definition for the output file has not been found.
Parent topic: Messages 0001 to 0099


SORT090U SORT terminated - missing SYSOUT

No catalog entry has been found for the SYSOUT file.
Parent topic: Messages 0001 to 0099


SORT091U SORT terminated - missing SYSIN

Parent topic: Messages 0001 to 0099


SORT092U SORT terminated - missing SORTOUT

Parent topic: Messages 0001 to 0099


SORT093U SORT terminated - missing SORTIN or SORTIN01

Parent topic: Messages 0001 to 0099


SORT094U SORT terminated - missing SORTOFvalue

Parent topic: Messages 0001 to 0099


SORT095U SORT terminated - Bad data in CHANGE field

Please see the CHANGE and DFSORT documentation on the Micro Focus Web site.
Parent topic: Messages 0001 to 0099


SORT096U SORT terminated - missing FNAMES dataset value

Please see the FNAMES and DFSORT documentation on the Micro Focus Web site.
Parent topic: Messages 0001 to 0099


Messages 0100 to 0199

Select the number of the message you require details about:

  • SORT100E Missing operator
    An operator was expected but was not found. An operator identifies the type of operation to be performed, SORT or MERGE.
  • SORT101E Malformed operator
  • SORT102E Expected operand missing
  • SORT103E Invalid operator operator
    You have specified an unexpected operator in a command file.
  • SORT104E Invalid operand keyword keyword
    You have specified unexpected syntax in the middle of an instruction.
  • SORT105E Expected continuation not present
    The sort instruction is not complete and is not continued on the next line.
  • SORT106E Field formats improperly specified
    You specified an invalid data type in the FIELDS instruction.
  • SORT107E Field format field-format invalid
    You specified invalid data in the FIELDS instruction.
  • SORT108E Sequence sequence invalid
    You specified an invalid sort order in FIELDS instruction..
  • SORT109E Too many fields specified
    You specified too many fields. The maximum is 100.
  • SORT110E Non-numeric data detected
    Non-numeric data was read where numeric data was expected.
  • SORT111E operator operator already processed
    You have already specified this instruction or parameter to an instruction.
  • SORT112E exit exit not supported
    You tried to use a user exit that is not supported.
  • SORT114E Expected '(' not found
    You specified an instruction that takes multiple parameters inside parentheses, but the opening parenthesis was not found.
  • SORT115E Boolean operator operator invalid
    The combination of format and bit operator is invalid.
  • SORT118E SORT / MERGE conflict
    You have specified both SORT and MERGE.
  • SORT119E INCLUDE / OMIT conflict
    You have specified both INCLUDE and OMIT.
  • SORT120E SORT statement missing FIELDS operand
    You have omitted the FIELDS instruction.
  • SORT121E MERGE statement missing FIELDS operand
    You have omitted the FIELDS instruction.
  • SORT122E INCLUDE statement missing COND operand
    You have omitted the COND parameter from the INCLUDE instruction.
  • SORT123E OMIT statement missing COND operand
    You have omitted the COND parameter from the INCLUDE instruction.
  • SORT124E FIELD position field-position invalid
    The starting position of the field is greater than the record length.
  • SORT125E FIELD length field-length invalid
    The field length is invalid in the FIELDS instruction.
  • SORT126E RECORD length record-length invalid
  • SORT127E Missing SORT/MERGE/COPY command statement
    You have not specified a SORT or a MERGE or a COPY instruction.
  • SORT128E Expected ')' not found
    You specified an instruction that takes multiple parameters inside parentheses, but the closing parenthesis was not found.
  • SORT129E Expected '=' not found
    You specified an instruction that takes multiple parameters specified using keyword=value pairs. No = sign was found.
  • SORT130E Expected 'F' OR 'V' not found
    The format parameter in the RECORDS instruction was not followed by F (for fixed) or V(for variable).
  • SORT131E Expected 'IX', 'RL', 'SQ', or 'LS' not found
    You have specified an ORG instruction for the USE or GIVE instruction but have not specified one of the above options.
  • SORT132E Prime key must be specified first
    The primary key was not specified first in the KEY instruction.
  • SORT133E Expected 'P', 'AD', 'A', or 'C' not found
    You have specified a KEY instruction for an indexed file in the GIVE instruction but have not specified one of the above options.
  • SORT134E Keyword/value value invalid for DFSORT emulation
    You have specififed a keyword=value pair that is invalid in mfsort's emulation of DFSORT.
  • SORT135E Keyword/value value invalid for SYNCSORT emulation
    You have specififed a keyword=value pair that is invalid in mfsort's emulation of SYNCSORT.
  • SORT136E No GIVE file specified for OUTFIL group
    You have not specified a GIVE file for the OUTFIL option.
  • SORT137E No USE file specified
    You have not specified a USE file.
  • SORT138E Target literal literal too long in CHANGE
    The target literal for the parameter CHANGE is too long.
  • SORT139E Substring comparison must be with character literal
    In the substring comparison of an INCLUD or OMIT condition, you have not specified a character literal for the right-hand side of the comparison.
  • SORT140E Invalid binary digit detected
  • SORT141E Cannot specify SAVE with either INCLUDE or OMIT
    In an OUTFIL group, you have specified SAVE with both INCLUDE and OMIT.
  • SORT142E Repeated FILE= or FNAMES=
  • SORT191I Operator operator ignored
    You have specified syntax that is not supported.
  • SORT192I Operand operand ignored
    You have specified syntax that is not supported.
  • SORT193E Invalid hex digit detected
  • SORT194 I No ALTSEQ command specified for 'AQ' SORT field formats; 'CH' assumed
  • SORT196E SUM / COPY conflict
    You have specified SUM together with the COPY option.
  • SORT197E INREC / MERGE conflict
  • SORT198E Non-numeric data detected in 'ZD' SUM field
  • SORT199E Too many OUTFIL statements
Parent topic: Mfsort Error Messages


SORT100E Missing operator

An operator was expected but was not found. An operator identifies the type of operation to be performed, SORT or MERGE.

Resolution:

Ensure that your SORT or MERGE instruction appears between columns 2 and 71 on the command line.

Parent topic: Messages 0100 to 0199


SORT101E Malformed operator

Parent topic: Messages 0100 to 0199


SORT102E Expected operand missing

Parent topic: Messages 0100 to 0199


SORT103E Invalid operator operator

You have specified an unexpected operator in a command file.

Resolution:

Resubmit the command file after removing the invalid operator.

Parent topic: Messages 0100 to 0199


SORT104E Invalid operand keyword keyword

You have specified unexpected syntax in the middle of an instruction.

Resolution:

Respecify the command removing the invalid keyword.

Parent topic: Messages 0100 to 0199


SORT105E Expected continuation not present

The sort instruction is not complete and is not continued on the next line.

Resolution:

Provide a complete instruction, using a continuation line if necessary.

Parent topic: Messages 0100 to 0199


SORT106E Field formats improperly specified

You specified an invalid data type in the FIELDS instruction.
Parent topic: Messages 0100 to 0199


SORT107E Field format field-format invalid

You specified invalid data in the FIELDS instruction.
Parent topic: Messages 0100 to 0199


SORT108E Sequence sequence invalid

You specified an invalid sort order in FIELDS instruction..

Resolution:

Resubmit the sort specifying either A (ascending) or D (descending).

Parent topic: Messages 0100 to 0199


SORT109E Too many fields specified

You specified too many fields. The maximum is 100.
Parent topic: Messages 0100 to 0199


SORT110E Non-numeric data detected

Non-numeric data was read where numeric data was expected.
Parent topic: Messages 0100 to 0199


SORT111E operator operator already processed

You have already specified this instruction or parameter to an instruction.

Resolution:

Remove the duplication and resubmit.

Parent topic: Messages 0100 to 0199


SORT112E exit exit not supported

You tried to use a user exit that is not supported.

Resolution:

Only user exits E15 and E35 are supported.

Parent topic: Messages 0100 to 0199


SORT114E Expected '(' not found

You specified an instruction that takes multiple parameters inside parentheses, but the opening parenthesis was not found.
Parent topic: Messages 0100 to 0199


SORT115E Boolean operator operator invalid

The combination of format and bit operator is invalid.
Parent topic: Messages 0100 to 0199


SORT118E SORT / MERGE conflict

You have specified both SORT and MERGE.

Resolution:

Respecify the command using either SORT or MERGE.

Parent topic: Messages 0100 to 0199


SORT119E INCLUDE / OMIT conflict

You have specified both INCLUDE and OMIT.

Resolution:

Respecify the command using either INCLUDE or OMIT.

Parent topic: Messages 0100 to 0199


SORT120E SORT statement missing FIELDS operand

You have omitted the FIELDS instruction.
Parent topic: Messages 0100 to 0199


SORT121E MERGE statement missing FIELDS operand

You have omitted the FIELDS instruction.
Parent topic: Messages 0100 to 0199


SORT122E INCLUDE statement missing COND operand

You have omitted the COND parameter from the INCLUDE instruction.
Parent topic: Messages 0100 to 0199


SORT123E OMIT statement missing COND operand

You have omitted the COND parameter from the INCLUDE instruction.
Parent topic: Messages 0100 to 0199


SORT124E FIELD position field-position invalid

The starting position of the field is greater than the record length.
Parent topic: Messages 0100 to 0199


SORT125E FIELD length field-length invalid

The field length is invalid in the FIELDS instruction.
Parent topic: Messages 0100 to 0199


SORT126E RECORD length record-length invalid

Parent topic: Messages 0100 to 0199


SORT127E Missing SORT/MERGE/COPY command statement

You have not specified a SORT or a MERGE or a COPY instruction.

Resolution:

Respecify the mfsort command using one of these instructions.

Parent topic: Messages 0100 to 0199


SORT128E Expected ')' not found

You specified an instruction that takes multiple parameters inside parentheses, but the closing parenthesis was not found.
Parent topic: Messages 0100 to 0199


SORT129E Expected '=' not found

You specified an instruction that takes multiple parameters specified using keyword=value pairs. No = sign was found.
Parent topic: Messages 0100 to 0199


SORT130E Expected 'F' OR 'V' not found

The format parameter in the RECORDS instruction was not followed by F (for fixed) or V(for variable).
Parent topic: Messages 0100 to 0199


SORT131E Expected 'IX', 'RL', 'SQ', or 'LS' not found

You have specified an ORG instruction for the USE or GIVE instruction but have not specified one of the above options.

Resolution:

Respecify the ORG instruction for the USE or GIVE instruction using one of the options IX, RL, SQ, or LS.

Parent topic: Messages 0100 to 0199


SORT132E Prime key must be specified first

The primary key was not specified first in the KEY instruction.

Resolution:

Reorganise the key definition so that you specify the primary key first.

Parent topic: Messages 0100 to 0199


SORT133E Expected 'P', 'AD', 'A', or 'C' not found

You have specified a KEY instruction for an indexed file in the GIVE instruction but have not specified one of the above options.

Resolution:

Respecify the KEY for the GIVE instruction using one of P, AD, A, or C.

Parent topic: Messages 0100 to 0199


SORT134E Keyword/value value invalid for DFSORT emulation

You have specififed a keyword=value pair that is invalid in mfsort's emulation of DFSORT.
Parent topic: Messages 0100 to 0199


SORT135E Keyword/value value invalid for SYNCSORT emulation

You have specififed a keyword=value pair that is invalid in mfsort's emulation of SYNCSORT.
Parent topic: Messages 0100 to 0199


SORT136E No GIVE file specified for OUTFIL group

You have not specified a GIVE file for the OUTFIL option.

Resolution:

Specify the GIVE file.

Parent topic: Messages 0100 to 0199


SORT137E No USE file specified

You have not specified a USE file.

Resolution:

Specify one or more USE files.

Parent topic: Messages 0100 to 0199


SORT138E Target literal literal too long in CHANGE

The target literal for the parameter CHANGE is too long.
Parent topic: Messages 0100 to 0199


SORT139E Substring comparison must be with character literal

In the substring comparison of an INCLUD or OMIT condition, you have not specified a character literal for the right-hand side of the comparison.

Resolution:

Respecify the substring comparison, replacing its right-hand side with a character literal.

Parent topic: Messages 0100 to 0199


SORT140E Invalid binary digit detected

Parent topic: Messages 0100 to 0199


SORT141E Cannot specify SAVE with either INCLUDE or OMIT

In an OUTFIL group, you have specified SAVE with both INCLUDE and OMIT.

Resolution:

Respecify the SAVE instruction with either INCLUDE or OMIT.

Parent topic: Messages 0100 to 0199


SORT142E Repeated FILE= or FNAMES=

Parent topic: Messages 0100 to 0199


SORT191I Operator operator ignored

You have specified syntax that is not supported.
Parent topic: Messages 0100 to 0199


SORT192I Operand operand ignored

You have specified syntax that is not supported.
Parent topic: Messages 0100 to 0199


SORT193E Invalid hex digit detected

Parent topic: Messages 0100 to 0199


SORT194 I No ALTSEQ command specified for 'AQ' SORT field formats; 'CH' assumed

Parent topic: Messages 0100 to 0199


SORT196E SUM / COPY conflict

You have specified SUM together with the COPY option.

Resolution:

Respecify your mfsort command with either SUM or COPY.

Parent topic: Messages 0100 to 0199


SORT197E INREC / MERGE conflict

Parent topic: Messages 0100 to 0199


SORT198E Non-numeric data detected in 'ZD' SUM field

Parent topic: Messages 0100 to 0199


SORT199E Too many OUTFIL statements

Parent topic: Messages 0100 to 0199


Messages 0200 to 0399

Select the number of the message you require details about:

  • SORT200E Bad or unknown symbol
  • SORT201E No previous offset defined for symbols
  • SORT202E No previous length defined for symbols
  • SORT203E No previous format defined for symbols
  • SORT204I *********************Sort Statistics*********************
  • SORT205I INPUT file filename
  • SORT206I OUTPUT file filename
  • SORT207I OUTFIL file filename
  • SORT214I Format operand ignored
  • SORT215E Reformatting field error
  • SORT216I Record type is V - Data starts at position 5
    You specified variable organisation for a file and also a start position in the FIELDS instruction before position 5.
  • SORT217I Record length L1 or L3 overridden
  • SORT232E Field length exceeds maximum allowed
  • SORT399I End of Micro Focus MFJSORT Utility
Parent topic: Mfsort Error Messages


SORT200E Bad or unknown symbol

Parent topic: Messages 0200 to 0399


SORT201E No previous offset defined for symbols

Parent topic: Messages 0200 to 0399


SORT202E No previous length defined for symbols

Parent topic: Messages 0200 to 0399


SORT203E No previous format defined for symbols

Parent topic: Messages 0200 to 0399


SORT204I *********************Sort Statistics*********************

Parent topic: Messages 0200 to 0399


SORT205I INPUT file filename

Parent topic: Messages 0200 to 0399


SORT206I OUTPUT file filename

Parent topic: Messages 0200 to 0399


SORT207I OUTFIL file filename

Parent topic: Messages 0200 to 0399


SORT214I Format operand ignored

Parent topic: Messages 0200 to 0399


SORT215E Reformatting field error

Parent topic: Messages 0200 to 0399


SORT216I Record type is V - Data starts at position 5

You specified variable organisation for a file and also a start position in the FIELDS instruction before position 5.

This message is followed by message SORT217I Record length L1 or L3 overridden.

Parent topic: Messages 0200 to 0399


SORT217I Record length L1 or L3 overridden

Parent topic: Messages 0200 to 0399


SORT232E Field length exceeds maximum allowed

A sum field is longer than 18 digits. This is the maximum size of any numeric string used in MFJSORT.

Parent topic: Messages 0200 to 0399


SORT399I End of Micro Focus MFJSORT Utility

Parent topic: Messages 0200 to 0399


Integrated Preprocessor Interface

  • Overview - Integrated Preprocessor Interface
  • Invoking a Preprocessor
  • Writing a Preprocessor
  • CP Preprocessor
  • Example Integrated Preprocessor
  • COBOL Preprocessor Error Messages
Parent topic: General Reference


Overview - Integrated Preprocessor Interface

Note: The Integrated Preprocessor is supported for native COBOL only.

Language preprocessors (also known as precompilers) are used to convert non-standard COBOL, or non-COBOL code embedded in COBOL, into a form that the Compiler can process.

A non-integrated preprocessor takes as input a source file, reads and parses it, and produces a modified source file which is then passed as input to the COBOL compiler. This has the following disadvantages:

  • There are two steps involved in compiling a program
  • There can be no integration between the Compiler and editor; for example if an error occurs during compilation there is no possibility of the editor highlighting the original source line in error
  • Listing output and debugging tools do not show the original source program

These factors can significantly lengthen the development cycle.

The Integrated Preprocessor Interface overcomes these problems by enabling the preprocessor to mark the relationship between the original source code and the modified form. Although the Compiler will actually process the modified COBOL, it will only ever show the original code.

The Integrated Preprocessor Interface enables a preprocessor to read source files and pass modified source lines to the Compiler. This makes the interface completely general purpose. The disadvantage of this approach is that the preprocessor itself has to handle COBOL constructs such as continuation, copybook expansion and the effects of REPLACE and REPLACING. Micro Focus provides the CP preprocessor, which can handle REPLACE and REPLACING, although this does require that COPY statements conform to normal COBOL syntax rules. If, by comparison, the Compiler read source files and passed single tokens to the preprocessor, restrictions such as the format of a token and the syntax of a COPY (or equivalent) statement would be imposed.

The underlying code that is actually compiled might be significantly different from the original. You might therefore notice that:

  • The debugger cannot query a data item, as the data item does not exist in the underlying code.
  • The debugger does not reference lines that were modified by the preprocessor, as the compiler does not process these lines and is unaware of their contents.
  • An accurate cross reference listing is not produced by the XREF Compiler because information for code inserted by the preprocessor is not shown, even if the original source line referenced the same data items.
  • Certain directives, most notably FLAG and language switches such as MF, cause the Compiler to reject or flag code produced by a preprocessor, whether integrated or not. The Integrated Preprocessor Interface eases the task of preventing such problems by:
    • Never flagging lines inserted by a preprocessor
    • Enabling the preprocessor to query Compiler directive settings.

    A preprocessor can generate lines containing $SET statements to switch directive settings, but this might cause problems, especially if your code uses names for data items that conflict with reserved words in the language selected by the preprocessor.

A supplied preprocessor reads and expands source files (including copybooks), and returns additional information to other preprocessors in the stack about the effect of REPLACE and REPLACING.

If your project contains preprocessors and you are developing in the IDE, we recommend that you disable background parsing, as it can destabalize the IDE. You can disable background parse from Tools > Options > COBOL > Miscellaneous > Enable Background Syntax Checking.

Parent topic: Integrated Preprocessor Interface
Related reference
The COPY Statement
The REPLACE Statement
FLAG
MF, MFLEVEL
Invoking a Preprocessor
Writing a Preprocessor Overview
CP Preprocessor


Invoking a Preprocessor

Note: The Integrated Preprocessor is supported for native COBOL only.

The preprocessor is invoked by the Compiler, which is directed to do so by using the PREPROCESS directive. The general form of the directive is:

>>--.---.-.----.-PREPROCESS-.-"name".----------------.-.------.-.><
    +-/-+ |    +-P----------+       +-preproc-params-+ +-ENDP-+ |
          |                                                     |
          +-NO-.-PREPROCESS-.-----------------------------------+
               +-P----------+

where the parameters are:

name | The name of the preprocessor
preproc-params | One or more of the optional preprocessor parameters

You specify the directive when compiling a file you want preprocessed.

All parameters on the command line following the PREPROCESS directive and up to the end of the line, or the ENDP directive, are passed to the preprocessor without examination.

Note: It is advisable to use the ENDP COBOL directive to terminate the directives to pass to the preprocessor. Directives placed after ENDP pass to the COBOL compiler. Therefore, without the ENDP directive, compiler directives may continue to pass to the preprocessor rather than to the COBOL compiler.

In a similar manner to other Compiler directives, the PREPROCESS directive can be either placed in a directives file or included in a $SET statement within the source code. It should not be specified in more than one place. If it is in a $SET statement, it must be the first line in the source file.

Invoking Multiple Preprocessors

Multiple preprocessors are invoked by passing a preprocess directive to the preprocessor so that it calls the next preprocessor. It is the responsibility of the first preprocessor to call the second; this can then call a third, and so on. Preprocessors that are not written to allow this stack method can only be used as the last preprocessor in the stack.

To invoke several preprocessors, stack the directive:

   +---------------------------------------+
   V                                       |
>>----preprocess"name"-.----------------.--+---><
                       +-preproc-params-+

For information on writing preprocessors to be used in this way, see the topic Multiple Preprocessors.

Parent topic: Integrated Preprocessor Interface
Related reference
The COPY Statement
The REPLACE Statement
FLAG
MF, MFLEVEL
PREPROCESS, P
Multiple Preprocessors


Writing a Preprocessor

  • Writing a Preprocessor Overview
  • Definition of the Interface Between the Compiler and a Preprocessor
  • Preprocessor Response Codes
  • Source Modification
  • Multiple Preprocessors
  • Considerations When Writing a Preprocessor
Parent topic: Integrated Preprocessor Interface


Writing a Preprocessor Overview

Note:

The Integrated Preprocessor is supported for native COBOL only.

This topic explains how to write an integrated preprocessor and describes the interface used to pass information between a preprocessor and the Compiler.

Although a preprocessor could be written in a language other than COBOL, the following description assumes that it is written in COBOL.

The Integrated Preprocessor Interface works on the simple concept that preprocessing is a form of editing. The preprocessor marks each line of the source code as:

  • Unchanged
  • Inserted - that is, as new lines
  • Modified - that is, old lines that are not to be compiled

When compiling a COBOL program, the compiler calls the preprocessor instead of directly reading the source file and receives the code line by line from the preprocessor.

The operation of the debugger depends on a mapping of each line of object code onto each line of source code. The marking of source lines described above allows this mapping to be valid even though the object code does not match the source code.

Testing a Preprocessor

The preprocessor program should be compiled in the same manner as any other program you want to debug.

After compiling your preprocessor program for debugging, you use the debugger as though you want to debug the Compiler itself, that is debug COBOL. You will not see the Compiler debugged, since it is not compiled for debugging, but you will see any programs it calls that have been compiled for debugging, such as your preprocessor.

Parent topic: Writing a Preprocessor
Related information
FLAG
MF, MFLEVEL
The REPLACE Statement
The COPY Statement


Definition of the Interface Between the Compiler and a Preprocessor

Note: The Integrated Preprocessor is supported for native COBOL only.

Preprocessor Parameters

Three parameters are passed across the interface:

mode-flag | Used to pass control information
buffer | Used for text information (source lines and filenames)
response | Used to indicate the type of source line in the buffer

Use the following data structure to pass these parameters:

 01 mode-flag      pic 9(2) comp-x.
 01 buffer         pic x(n).
 01 response.
   03 response-status    pic 9(2) comp-x.
   03 response-code-1    pic 9(4) comp-x.
   03 filler redefines response-code-1.
     05 filler             pic x.
     05 resp-main          pic 9(2) comp-x.
   03 response-code-2    pic 9(4) comp-x.
   03 filler redefines response-code-2.
     05 filler             pic x.
     05 resp-more          pic 9(2) comp-x.

The Initial Call

The initial call is made to the preprocessor at the point where the Compiler would normally open the source file. The mode-flag parameter is set to 0 and the name of the source file is placed in buffer. If the Compiler was able to locate the source file, the filename contains the full path and file extension. If it was not able to do so, the name is as specified on the command line. The preprocessor preserves the contents of the buffer in this initial call.

In addition, the initial call initiates a handshaking process so that the Compiler and preprocessor can determine their respective levels of support. This enables new functionality to be built into the preprocessor interface while at the same time ensuring that this new functionality is not made use of unless both the Compiler and preprocessor support it. The Compiler does not pass any information to the preprocessor unless it has been told that the preprocessor is able to process it; similarly the preprocessor should not make any requests of the Compiler unless it has been told that it can do so. The process has been designed so that older Compilers and preprocessors continue to work even though they do not take account of the handshaking process.

When the Compiler calls the preprocessor, response-code-2 is used to inform the preprocessor of its support level. When the preprocessor returns to the Compiler, it uses the same parameter for its support level. As features are added the support levels are incremented; each level includes the support in the levels before it. To ensure that old Compilers are supported, the value 8224 is a special case - it indicates that the parameter was not initialized and represents the "base level". Similarly, an old preprocessor that does not set a support level does not change the parameter value, so all values of 32767 or lower are treated as the "base level".

Features in the base levels are explained in the following sections. Features not in the base level are highlighted with a warning. The following is a summary:

Compiler support levels

response-code-2 | Feature
8224 | Base level
0 | response-code-1 contains length of buffer
1 | resp-main of 14 supported
2 | Compiler understands preprocessor support level; andl tells the preprocessor to abort
3 | resp-main of 17 supported

Preprocessor support levels

response-code-2 | Feature
32767 or less | Base level
32768 | Compiler might tell the preprocessor to abort
32769 | Support for conditional compilation. Note: The preprocessor must accept and act on a MODE-FLAG value of 3 by returning source lines untouched and marked as original source lines. It must continue to do this while MODE-FLAG has this value.
Not base level: | The Compiler puts the length of buffer in response-code-1. The preprocessor can return source lines up to this length. If response-code-2 is 8224 then the preprocessor should assume the length is 80 bytes.

The preprocessor should open the file and return zero in response-status to indicate success, or 255 to indicate a failure.

The operating system command line contains any directives to the preprocessor, terminated by spaces. These directives are specified in the Compiler command line, directives files or $SET statements and follow the PREPROCESS directive itself.

The directives are used to pass information from the command line to the integrated preprocessor and are defined by the designer of the preprocessor. The preprocessor should not expect the directives it receives to be seperated by only one space character. The command line format matches that of the PREPROCESS directive and each preprocessor directive (including the first) can be preceded by one or more spaces.

Subsequent Calls

Subsequent calls request a line of source code until the preprocessor indicates that the last line has been reached.

In these calls, the Compiler sets mode-flag to 1 and response-status to 0, except as documented in the topic Handling COPY Statements. The preprocessor returns information in buffer, resp-main and resp-more as defined in the next section.

If there is an error, response-status should be set to a nonzero value (the remaining fields might be left undefined).

The first byte of response-code-1 and response-code-2 are reserved for future use and must always be set to zero on return.

The simplest way to achieve this is to set response-code-1 and response-code-2 to zero before setting resp-main and resp-more.

If you wish to modify the source code, you should note that the original source code lines should always be passed back before their replacement line(s). In addition, lines that are continued over several lines of source code must be treated as one block; it is not possible to modify part of the logical line.

Not base level: If the Compiler sets mode-flag to 2 then it is about to terminate before the preprocessor indicates that the end of the source has been reached. On this call the preprocessor should perform any clean-up operations it needs to do (such as deleting temporary work files). If the preprocessor is stacked, that is it invokes other preprocessors, it should also call the next preprocessor with the same parameter values and then CANCEL that preprocessor.
Parent topic: Writing a Preprocessor


Preprocessor Response Codes

Restriction: The Integrated Preprocessor is supported for native COBOL only.

After the initial call to the preprocessor, subsequent calls return with one of the following:

  • Source lines, which might be marked as:
    • Unchanged
    • Old (to be treated as commented out)
    • New
    • COPY statements
  • With other requests, such as:
    • Increment an error count
    • Return a directive setting

The value in resp-main is used to signify what is being returned; additional information might be placed in resp-more and/or buffer. The values of resp-main are:

Value | Description
0 | The source file has been completely processed and there is no further input. buffer and resp-more are ignored.
1 | buffer contains a new line that was added by the preprocessor and which was not in the original source code. resp-more optionally contains the position of the verb in the original source line that is being replaced. The line added by the preprocessor must not be a comment.
2 | buffer contains a line in the original source code which is to be ignored by the Compiler. resp-more is ignored.
3 | buffer contains a line in the original source code which contains the start of a COPY statement that is about to be expanded by the preprocessor. resp-more contains the position of the statement on the line.
4 | buffer contains a line in the original source code which contains the continuation of a COPY statement. resp-more is ignored.
5 | buffer contains a warning message inserted by the preprocessor. This must have the format of a comment line (that is, the value "*" in the indicator area of the source line). resp-more is ignored.
6 | An unrecoverable error has occurred; this forces the Compiler to abort and enter the COBOL Editor. In such a case, a message of up to 70 characters might be written to buffer and this is displayed on the bottom line of the Editor. resp-more is ignored.
7 | An error has occurred; this forces the Compiler to increment its internal error count. All error classes might be specified by using resp-more. The contents of buffer are ignored.
8 | This value is generated by the CP Preprocessor.
9 | This value is used when the CP Preprocessor is in use.
10 | Identical to 11, below.
11 | buffer contains a new line added by the preprocessor which contains the start of a COPY statement that is about to be expanded by the preprocessor. It is used when the COPY statement is not unique on a line or the original text was not a COBOL COPY statement. resp-more contains the position of the COPY statement on the line.
12 | buffer contains a new line added by the preprocessor which contains the continuation of a COPY statement. resp-more is ignored.
13 | Causes the Compiler to return information about its directive settings. The required directive might optionally be placed in buffer; resp-more is ignored.
Not base level:14 | This value is similar to 10 and 11 above, except that it indicates that the original source contained -INC or ++INCLUDE.
Not base level:17 | An error has been detected. buffer contains a message that the Checker outputs.
32 | buffer contains a line from the original source code which has not been modified by the preprocessor.
33 - 64 | These values are generated by the CP preprocessor.
128 | The end of a copybook has been reached. buffer must be empty.
  • Inserting Source Lines
  • Generating Preprocessor Error Messages
  • Querying Directive Settings
  • Handling COPY Statements
Parent topic: Writing a Preprocessor
Related reference
The COPY Statement
The REPLACE Statement
FLAG
MF, MFLEVEL
CP Preprocessor


Inserting Source Lines

Note:

The Integrated Preprocessor is supported for native COBOL only.

When resp-main contains the value 1, resp-more is used to indicate the position in the original source of the replaced non-COBOL verb as follows.

Value | Description
nn | The number of the column containing the first character of the non-COBOL verb being replaced by the current line. The line(s) containing the non-COBOL verb would have previously been marked by returning the value of 2 in resp-main; if there was more than one line, the verb is assumed to be on the first of them.
0 | No verb replacement is taking place.
For example, if the original source contains:
   exec abc
   do something useful
   end-exec

and these three lines are replaced by:

  call abc_something_useful

then the value of nn gives the position of the EXEC statement.
Parent topic: Preprocessor Response Codes


Generating Preprocessor Error Messages

Note: The Integrated Preprocessor is supported for native COBOL only.

Not base level

If the preprocessor encounters an error when processing the source code it can return the text of a message to be output.

This message is displayed in the same way as other Compiler messages according to the WARNING and ERRQ directives, and it is also highlighted in the source code.

To generate an error, a preprocessor must pass through the source line in error. The error message is passed with the following settings:

resp-main | 17
resp-more | Value indicating the severity:
1 | Informational
2 | Warning
3 | Error
4 | Severe error
Value | Severity
buffer | The text of the message. If the message text starts with the string OFFSETnnn (case is important) and a space, the error at the position specified by nnn is flagged. nnn is a three byte numeric number. The string is not displayed as part of the message.
1 | Unrecoverable error
2 | Severe error
3 | Error
4 | Warning
5 | Informational
6 | Flag count

The function resp-main=17 should only be used once one or more user source lines have been returned to the Checker by the preprocessor.

Note: in some circumstances using this feature highlights errors later than normal. This happens when the Compiler is reading ahead in the source to look for continuation and so on. If the Compiler receives and processes an error request from a preprocessor, and then determines that the error was on a line before the read-ahead, the line flagged by the prerocessor is highlighted.

All levels

An older technique for handling error conditions is still available. This requires the preprocessor to handle the actual display of the error message and so is less well integrated. We do not recommend this technique.

If the preprocessor encounters an error when processing the source code, it can communicate this to the Compiler so that the error is treated as a syntax error. There are two ways to do this:

  • Set resp-main to the value 5 and place a comment line in buffer; the comment is inserted in the list file.
  • Set resp-main to the value 6; the Compiler terminates.

The value in resp-more specifies the column number in which the error was found. It is used when positioning the cursor on return to the Editor.

It is also possible to force the Compiler to increment its internal error counts in conjunction with one of the two operations described above. This is done by setting resp-main to the value 7 and specifying which error count is to be increased in resp-more. Possible values for resp-more are:

Value | Severity
1 | Unrecoverable error
2 | Severe error
3 | Error
4 | Warning
5 | Informational
6 | Flag count

Increasing the unrecoverable error count causes the Compiler to abort immediately. The contents of buffer are ignored.

It is the responsibility of the preprocessor to output error messages to the user before forcing the Compiler to either abort or increment the error counts. This should not be confused with the message that can be inserted in the list file which is for informational purposes only.

Parent topic: Preprocessor Response Codes
Related reference
FLAG
MF, MFLEVEL
Handling COPY Statements


Querying Directive Settings

Note:

The Integrated Preprocessor is supported for native COBOL only.

When resp-main contains the value 13, buffer must contain either spaces or the name of a specific directive setting that is required. When the processor is next called, buffer contains the value of a directive setting. When the value 13 is first returned, the Compiler builds up a list of all of its directive settings and returns one value from it. Subsequent returns of this value return further values from this list. If a value other than 13 is returned at any point, further returns of value 13 cause the list to be generated again. The list of directives is generated in alphabetical order; once all directive settings have been returned, further calls yield spaces. If buffer contains spaces the first, or next, directive setting is returned; if buffer contains the name of a directive, the Compiler skips forward through its list to the specified directive. Only syntax-check phase directives are returned in this way.

Parent topic: Preprocessor Response Codes


Handling COPY Statements

Restriction: The Integrated Preprocessor is supported for native COBOL only.

If the preprocessor is not interested in the contents of a copybook, it can pass the COPY statement unmodified through to the Compiler, where it is expanded.

Only valid COBOL constructs can be passed in this way. Any non-COBOL constructs can be commented out and replaced by a valid COPY statement which the Compiler then expands.

In both of these cases, the preprocessor has no opportunity to read and process the copybook itself.

The Compiler expands all forms of COPY statement that it would expand with no preprocessor present, whether passed back as unchanged or modified lines. The following are supported:

  • Simple COPY statement
  • COPY ... REPLACING statements
  • COPY copy-filename OF/IN library-name
  • COPY statements spread over several lines
  • Nested COPY statements
  • ++INCLUDE
  • -INC

If the preprocessor does want to examine the copybook contents, it must either expand the copybook itself, or use the CP preprocessor. The contents of the copybook itself are returned to the Compiler in the same manner as the lines in the main source file; however, the COPY statement itself receives special handling.

In the simplest case, when the COPY statement is the only statement on one or more lines, and specifies the full filename (including the extension and path if necessary), the first of these lines is passed to the Compiler marked with resp-main set to 3 and resp-more set to the column number of the start of the COPY, and all subsequent lines are passed with resp-main set to 4.

If the location of the file specified in the COPY statement is resolved by adding a filename extension or path, or if the COPY is not unique on the line(s), or is not a regular COBOL COPY statement, it is necessary to comment out (mark with resp-main set to 2) all lines containing the COPY statement and then pass through all other lines as inserted. Inserted COPY statements that the preprocessor is expanding must conform to the normal syntax rules for COBOL, and be marked with:

  • resp-main set to 11 or 14
  • resp-more set to nn (where nn is the position of the start of the COPY statement) for the first line
  • resp-main set to 12 for all subsequent lines

For example, if the source contains:

01 item-a. copy "cpy-fil.cpy".

This is first returned with resp-main set to 2 to indicate that this is a line that is about to be replaced. On the next call, the preprocessor returns:

01 item-a.

with resp-main set to 1 to indicate that this is a replacement line. On the next call, the preprocessor returns:

copy "copy-fil.cpy".

This time, resp-main is set to 11 to indicate this is a replacement line containing the COPY statement alone. resp-more is set to 20, the position of the word COPY on the original source line.

Note that when a COPY statement is returned to the Compiler, whether to be expanded by the preprocessor or Compiler, the Compiler parses it and checks for REPLACING. This REPLACING affects all lines in this and nested copybooks. The name specified in this COPY statement is read and stored for use by the Debugger. It is strongly recommended that the name be enclosed in quotes so that no unwanted case folding occurs when reading the name as, on platforms where case is significant, the Debugger might not be able to locate the file.
Not base level: resp-main=14 is used when the original word was not a COBOL COPY statements, for example ++INCLUDE or -INC. Some Compiler directives can be specified in $SET statements before any COBOL source but not after. Such statements might follow ++INCLUDE but not COPY. Use of resp-main=14 allows a ++INCLUDE to be expanded whilst at the same time allowing such directives to be set subsequently.

Value 128 should only be used for resp-main when the preprocessor has finished expanding a copybook. If it is not, the Compiler aborts the compilation. The value 0 should be used at the end of the main source file.

COPY statements in Identification Division comment entries are not always expanded. If a preprocessor signals that it is about to expand a copybook (resp-main set to 3 or 11) at a point where this is not valid, the Compiler sets response-status to non-zero on the next call to the preprocessor. The preprocessor should abandon the copybook immediately and send the end-of-copybook marker (resp-main set to 128) as though the copybook were empty.

The CP preprocessor expands copybooks so that other preprocessors do not have to do so. It generates lines as documented above.

Parent topic: Preprocessor Response Codes
Related reference
The COPY Statement
The REPLACE Statement
FLAG
MF, MFLEVEL


Source Modification

Note:

The Integrated Preprocessor is supported for native COBOL only.

A number of COBOL commands exist to modify a source file. The REPLACE verb (ANSI'85 verb) is not supported by the Compiler when a preprocessor is active and must be handled by the preprocessor. The CP preprocessor returns information to other preprocessors about the effect of REPLACE.

Parent topic: Writing a Preprocessor
Related reference
The REPLACE Statement


Multiple Preprocessors

Note:

The Integrated Preprocessor is supported for native COBOL only.

Several preprocessors can be active simultaneously on the same source program. They are arranged in a stack so that the Compiler calls the top preprocessor in the stack, this preprocessor calls the next preprocessor and so on to the preprocessor at the bottom of the stack which actually reads the source code. Each line of source is then passed through every preprocessor in turn until it reaches the top of the stack and is passed to the Compiler. In order for this to work, the preprocessor must obey some additional rules.

The Compiler writes directives to the command line when it makes the initial call to a preprocessor. The preprocessor reads this command line and, if it finds a PREPROCESS directive, invokes the preprocessor named in it. It also passes any parameters following the directive to the invoked preprocessor by writing these in turn to the command line and continues the hand-shaking process described in this section.

As preprocessor directives to the Compiler are terminated by the ENDP directive or the end of the line, multiple PREPROCESS directives must all appear on the same line in a directives file.

The interface between two preprocessors is identical to that between the Compiler and preprocessor specified above, thus it is possible to use a stackable preprocessor in both stacked and unstacked situations. A preprocessor which has not been designed to be stackable must be stacked at the end of the stack where it is directly reading the source code.

If you are stacking another preprocessor on top of the CP preprocessor, to enable support for conditional compilation, it must support the following:

  • The preprocessor's handshaking support level needs to be increased to 32769.
  • The preprocessor must accept and act on a MODE-FLAG value of 3 by returning source lines untouched and marked as original source lines. It must continue to do this while MODE-FLAG has this value.

In most cases, preprocessors act on discrete sets of syntax and all produce valid COBOL syntax, so it is unlikely that more than one preprocessor will want to process a particular source line. However, it is possible that preprocessors in a stack represent language levels so that a source line is edited several times by the different preprocessors on its route through the stack to the Compiler. In this case, care must be taken to read the information in the response field so that the relationship between the source code and the code that finally reaches the Compiler is maintained. The order in which the stacking takes place should also be chosen carefully if code altered by one preprocessor is also to be successfully modified by a second preprocessor.

Parent topic: Writing a Preprocessor
Related reference
The COPY Statement
The REPLACE Statement
FLAG
MF, MFLEVEL


Considerations When Writing a Preprocessor

Note:

The Integrated Preprocessor is supported for native COBOL only.

Any change made to source code can conflict with either the user selected COBOL dialect or data names. With care, any potential problems can easily be avoided.

  • Conflicts with user selected COBOL dialect.

    If the user code conforms to a dialect that does not support features that the preprocessor needs to make use of, there are two issues to be overcome. Firstly, non-conforming code would be flagged; secondly the required reserved words might not be in the dictionary.

    In order to overcome the problem of flagging, no lines that are inserted by a preprocessor are ever flagged by the Compiler. To make all required reserved words available, a preprocessor could generate a $SET statement to specify, for example, the ANS85 directive.

    However, this would have some unwelcome side-effects: the behavior of some statements would be changed, and valid data names would be rejected as they would now be reserved words instead.

    A better technique would be to determine which words are actually needed and selectively add only these using the ADDRSV directive. For example, if only the reserved word FUNCTION is needed, it can be added using the ADDRSV(FUNCTION) directive. This, however, would still causes problems if the user code declared FUNCTION as a data name, and the best solution of all is to use the ADDSYN directive, and chose an alternative word to FUNCTION that is unlikely to be used by the user.

    For example, generate the directive ADDSYN "FUNCTION" = "PREPGEN--FUNCTION" and thereafter use PREPGEN--FUNCTION instead of FUNCTION when generating code.

    Note:

    Using the ADDSYN technique might confuse any preprocessors that subsequently process the source.

  • Conflicts with data names.

    If a preprocessor needs to create data for its own use, it should chose names that are unlikely to conflict with user chosen names. As in the case above, selecting a name like PREPGEN--USERID is unlikely to conflict with a user selected name, but USERID alone might well cause problems.

  • UNIX environments

    UNIX is case-sensitive. In your call statements, you need to use the correct case. For example, a CALL (XXX) statement results in a RTS173 error if the program is named xxx.cbl.

Parent topic: Writing a Preprocessor


CP Preprocessor

Note: The Integrated Preprocessor is supported for native COBOL only.

The CP preprocessor is designed to be used as a stacked preprocessor. It reads and expands source files (including copybooks), plus it returns additional information to the other preprocessors in the stack about the effect of REPLACE and REPLACING. It thus removes these quite complex functions from other preprocessors.

The CP preprocessor has the following restrictions:

  • It only recognizes normal COBOL tokens and COPY statements
  • It does not show the effect of BASIS
  • It is not designed to accept program source containing double-byte character set (DBCS) characters
  • Copybook Expansion
  • REPLACE Notification
  • CP Directives
Parent topic: Integrated Preprocessor Interface
Related concepts
Using the CP Preprocessor to Expand Copybooks
Preprocessor Response Codes
Related information
COBOL Preprocessor Error Messages
FLAG
MF, MFLEVEL
The REPLACE Statement
The COPY Statement


Copybook Expansion

Restriction: The Integrated Preprocessor is supported for native COBOL only.

When the CP preprocessor encounters a COPY statement it marks the source lines as documented in the topic Handling COPY Statements, and reads through the copybook. It locates the copybooks using the same pathnames and file extensions as the Compiler would.

If a copybook cannot be located, the CP preprocessor comments out the COPY statement and generates appropriate error messages. If there is an error in parsing the statement, the preprocessor ignores the statement and carries on parsing tokens from the point of the error. If other preprocessors receive an unmodified COPY statement they can assume that the CP preprocessor was unable to handle it; they should leave it and let the Compiler generate an error message.

Parent topic: CP Preprocessor
Related reference
FLAG
MF, MFLEVEL
Handling COPY Statements


REPLACE Notification

Note:

The Integrated Preprocessor is supported for native COBOL only.

So that other preprocessors are able to get a view of the source files as the Compiler would after the effect of REPLACE and REPLACING, the preprocessor returns additional lines as documented here. Note, however, that the Compiler still performs this REPLACING itself except as noted below. The additional lines are passed for information only.

If the preprocessor ever detects that a line will be modified, it will add 32 to the value of resp-main it returns. The line or lines thus marked will be followed by one or more lines marked with the value of 8 in resp-main, containing what would be in the line after it was modified. As these changes are for information only, other preprocessors receiving the lines should pass these values back out again for any other preprocessors in the stack; when the Compiler receives lines marked with values in the range 33 to 64 it subtracts 32, and it ignores lines marked with an 8.

If a preprocessor wishes to modify a line affected in this way, it should do so as normal, however it should mark the new line with a 9 rather than a 1 to inform the Compiler that this new, inserted, line does not need to be tested for the effect of REPLACE or REPLACING.

Parent topic: CP Preprocessor
Related reference
The COPY Statement
The REPLACE Statement
FLAG
MF, MFLEVEL


CP Directives

Note: The Integrated Preprocessor is supported for native COBOL only.

The CP preprocessor accepts a number of directives. In order to keep the command line short, these exist in an abbreviated form in addition to the full name. After looking at the command line in the usual way, CP also looks at the environment variable CPDIR for directives.

  • CONFIRM, C
    Specifies whether directives are to be shown on the screen if accepted.
  • LIMITED-SEARCH, LS
    Limits searches for copybooks to the directories specified by the COPCPY environment variable. By using this directive, and making a careful choice of both directories in the COBCPY environment variable and file extensions in the COPYEXT directive, the number of file searches can be greatly reduced.
  • PREPROCESS, P
    Stacks another preprocessor (that is, specifies that the source input to this preprocessor is to come from another preprocessor rather than the source file itself).
  • SQL, S
    Specifies whether EXEC SQL INCLUDE is to be treated as a COPY statement.
  • TRACE, T
    Specifies whether to create a trace file, and optionally specifies the name of the file to be used. If the filename is omitted, it is created as progname.cpt, where progname is the basename of the main source file.
  • WARNINGS, WARNING, W
    Specifies whether warnings about directive settings are to be shown on screen
  • SY
    Reserved for use with COBSQL; this directive should only be used as documented in the chapter COBSQL in your Database Access book.
Parent topic: CP Preprocessor
Related information
FLAG
MF, MFLEVEL
The COPY Statement
The REPLACE Statement
COBOL Preprocessor Error Messages


CONFIRM, C

Specifies whether directives are to be shown on the screen if accepted.

Syntax:

Note: The Integrated Preprocessor is supported for native COBOL only.
>>-----.----.--CONFIRM---------------><
       +-NO-+

Properties:

Default: NOCONFIRM
Parent topic: CP Directives
Related information
FLAG
MF, MFLEVEL
The COPY Statement
The REPLACE Statement
COBOL Preprocessor Error Messages


LIMITED-SEARCH, LS

Limits searches for copybooks to the directories specified by the COPCPY environment variable. By using this directive, and making a careful choice of both directories in the COBCPY environment variable and file extensions in the COPYEXT directive, the number of file searches can be greatly reduced.

Syntax:

Restriction: The Integrated Preprocessor is supported for native COBOL only.
>>------.----.--LIMITED-SEARCH-------><
        +-NO-+

Properties:

Default: NOLIMITED-SEARCH

Comments:

This directive limits searches for copybooks to the directories specified by the COPCPY environment variable.

This can reduce compilation time. If the directive is set:

  • Copybooks are searched for in the directories specified by COBCPY, omitting the directory where the source is located
  • The copybook extension specified by the OSEXT directive is not used in the search (any extensions specified by COPYEXT are used, however)
Parent topic: CP Directives
Related information
OSEXT
MF, MFLEVEL
COPYEXT
Copybook Location


PREPROCESS, P

Stacks another preprocessor (that is, specifies that the source input to this preprocessor is to come from another preprocessor rather than the source file itself).

Syntax:

Note:

The Integrated Preprocessor is supported for native COBOL only.

>>--.--PREPROCESS"name"-.----------------.--.--><
    |                   +-preproc-params-+  |
    +-NO-PREPROCESS-------------------------+

Parameters:

name | The name of the preprocessor
preproc-params | One or more of the optional preprocessor parameters

Properties:

Default: NOPREPROCESS
Parent topic: CP Directives
Related information
FLAG
MF, MFLEVEL
The COPY Statement
The REPLACE Statement
COBOL Preprocessor Error Messages


SQL, S

Specifies whether EXEC SQL INCLUDE is to be treated as a COPY statement.

Syntax:

Note:

The Integrated Preprocessor is supported for native COBOL only.

>>-----.----.--SQL-------------------><
       +-NO-+

Properties:

Default: SQL
Parent topic: CP Directives
Related information
FLAG
MF, MFLEVEL
The COPY Statement
The REPLACE Statement
COBOL Preprocessor Error Messages


TRACE, T

Specifies whether to create a trace file, and optionally specifies the name of the file to be used. If the filename is omitted, it is created as progname.cpt, where progname is the basename of the main source file.

Syntax:

Note:

The Integrated Preprocessor is supported for native COBOL only.

>>--.--TRACE----.-"filename"--.--.---><
    |           +-------------+  |
    +--NO--TRACE-----------------+

Properties:

Default: NOTRACE
Parent topic: CP Directives
Related information
FLAG
MF, MFLEVEL
The COPY Statement
The REPLACE Statement
COBOL Preprocessor Error Messages


WARNINGS, WARNING, W

Specifies whether warnings about directive settings are to be shown on screen

Syntax:

Note:

The Integrated Preprocessor is supported for native COBOL only.

>>-----.----.--WARNINGS--------------><
       +-NO-+

Properties:

Default: WARNING
Parent topic: CP Directives
Related information
FLAG
MF, MFLEVEL
The COPY Statement
The REPLACE Statement
COBOL Preprocessor Error Messages


SY

Reserved for use with COBSQL; this directive should only be used as documented in the chapter COBSQL in your Database Access book.
Note: The Integrated Preprocessor is supported for native COBOL only.
Parent topic: CP Directives


Example Integrated Preprocessor

Note: The Integrated Preprocessor is supported for native COBOL only.

There are two example integrated preprocessors for you to look at; these have been designed to be stacked. Also provided are an example source program and an example copybook for the preprocessors to process. By copying and pasting these, you could create projects to contain these files and see how they work, or you could create your own preprocessors based on these examples.

The example preprocessors can be used as a basis for other preprocessors. They demonstrate the following:

  • How the preprocessor is invoked and opens source input
  • How source is passed without editing to the Compiler
  • How source is edited and then passed to the Compiler
  • How lines containing more than one verb are expanded
  • How COPY statements are processed
  • How warnings and errors are produced
  • How preprocessors can be stacked

Specification of the Example Preprocessors

The example preprocessors recognize and process several verbs as follows:

  • MOV is converted to MOVE
  • DIS is converted to two lines, the first being DISPLAY SPACE UPON CRT and the second containing the original line with the word DIS replaced by DISPLAY
  • PRINT is converted to DISPLAY
  • CPY is converted to COPY, and thus expanded by the Compiler: COPY is expanded by the preprocessor
  • WARN causes a warning message to be placed in the listing file
  • ERROR causes a serious error message to be displayed. If you request that compilation should continue, the serious error count is increased.

In order to demonstrate stackable preprocessors, these functions are split into two separate programs. The two preprocessors are very similar, containing much common code.

The preprocessors include an example of a lexical analyzer for COBOL, which handles lexical tokens that do not continue across records.

Example Programs

The files asmcobol.cbl and working.cbl contain commands that can be interpreted by preprocessing the files using compiled versions of the Preproc or Preprox example preprocessors.

  • To build the demonstration preprocessor
  • To debug the demonstration preprocessor
Parent topic: Integrated Preprocessor Interface
Related tasks
To build the demonstration preprocessor
To debug the demonstration preprocessor
Related reference
FLAG
MF, MFLEVEL


To build the demonstration preprocessor

  1. From the Example Integrated Preprocessor topic, create the files preproc.cbl, working.cbl and asmcobol.cbl.
  2. Create a new project.
  3. Add preproc.cbl to this project.
  4. Ensure that the build settings for preproc.cbl use the MF dialect.
  5. Build the project.
  6. Create a second new project.
  7. Place the asmcobol.cbl and working.cbl files in the same folder as the new project file. Do not place them in a separate source folder.
  8. Add asmcobol.cbl to this project.
  9. Ensure that the build settings for asmcobol.cbl use the MF dialect.
  10. Specify the folder where asmcobol.cbl is as a Copybook folder. This enables the COBOL development system to find working.cbl.
  11. Edit asmcobol.cbl and comment out the $SET statement at the top of the program.
  12. In the build settings for asmcobol.cbl add the following directives:
    p (absolute_directory_path\preproc.int) endp

    For example:

    p (c:\mfuser\projects\preproc\loadlib\preproc.int) endp

    You specify the location of preproc.int in this way rather than in the $SET statement you deleted at step 10 because the preprocessor's parsing is quite basic and cannot handle the colon in the path-name.

  13. Build the project.

    You can now use the preprocessor.

Parent topic: Example Integrated Preprocessor
Related reference
FLAG
MF, MFLEVEL
Example Integrated Preprocessor


To debug the demonstration preprocessor

  1. From the Example Integrated Preprocessor topic, create the files preproc.cbl, working.cbl and asmcobol.cbl.
  2. Edit preproc.cbl to specify the following as the first statement in the START-PARA section:
    call "CBL_DEBUGBREAK" end-call

    This a call to the COBOL run-time system to invoke the COBOL debugger.

  3. Perform the relevant steps from the topic To build the demonstration preprocessor. If you have already created the projects, you will just need to rebuild the project containing preproc.cbl.

    When you debug the second project, the call to CBL_DEBUGBREAK that you inserted at step 2 invokes the debugger, enabling you to debug the preprocessor code.

Parent topic: Example Integrated Preprocessor
Related reference
FLAG
MF, MFLEVEL
Example Integrated Preprocessor


Library Routines

  • Library Routines - Key
  • Application Subsystem Routines
  • Bit-packing Routines
  • Byte-stream File Routines
  • Character Set Conversion Routines
  • Consolidated Tracing Facility Routines
  • Container-Managed Services Routines
  • Debugging Routines
  • Display Attribute Routines
  • Enhanced ACCEPT and DISPLAY Syntax Routines
  • Exit and Error Procedure Routines
  • File and Filename Routines
  • Keyboard Routines
  • Logical Operator Routines
  • Memory Allocation Routines
  • Mouse Routines
  • Multi-threading Routines
  • NLS Message-file Handling Routines
  • Operating System Information Routines
  • Portability Routines
  • Printer Routines
  • Program Canceling Routines
  • Program Information Routines
  • Run-unit Handling Routines
  • Screen Routines
  • State Maintenance Routines
  • Text Routines
  • Virtual Heap Routines
  • Windows Routines
  • Miscellaneous Routines
  • Alphabetical List of Library Routines
Parent topic: General Reference


Library Routines - Key

Descriptions for all of the call-by-name routines appear alphabetically. Each description contains the routine name and function and the following entries (as appropriate):

Syntax:

Shows the CALL statement you could use to call the routine.

The optional RETURNING clause is also shown. Every routine returns a value showing the result of the operation. Unless otherwise indicated, zero indicates success, nonzero indicates failure. This value is left in the data item specified in the RETURNING clause, in this reference, status-code. If this clause is omitted, the value is left in the special register RETURN-CODE. (If call-convention bit two is set, RETURN-CODE is not changed.)

status-code must be a numeric data item capable of holding positive values from 0 to 65535; for example, PIC X(2) COMP-5.

The name of the routine must be coded in upper case.

Parameters:

Describes any parameters shown in the RETURNING and USING clause. A parameter enclosed in brackets, for example, [parameter1] is optional and might not be needed for all forms of the routine.

If you want your parameters to be validated when your program is compiled, use the call prototye definition. (We recommend that you use the call prototype method.) Otherwise, use the PICTURE clause.

We provide the files cbltypes.cpy, which contains all types required by the system library routines, and cblproto.cpy, which contains all prototypes of the types used by the system library routines.

On Entry:

Indicates which of the parameters shown are passed on entry

On Exit:

Indicates which of the parameters shown are returned on exit

Where bits of one or more bytes are referenced, bit 0 is the least significant (rightmost) bit.

Comments:

Provides any additional information necessary for the successful use of the routine

Parent topic: Library Routines


Application Subsystem Routines

This routine enables you to logically group a number of programs. This enables you to cancel these programs, the subsystem, with a single statement.

  • CBL_SUBSYSTEM
    Declares or deallocates subsystems.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_SUBSYSTEM

Declares or deallocates subsystems.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_SUBSYSTEM" using     function-code
                               parameter
                     returning status-code

Parameters

function-code
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
Contains one of the following:

0: Declare subsystem

1: Cancel subsystem

2: Remove from subsystem

parameter
Group predefined as cblt-subsys-params containing:
01 cblt-subsys-params     typedef.
  03 cblte-ssp-handle     cblt-x2-compx. *> pic x(2) comp-x.
  03 cblte-ssp-name-len   cblt-x2-compx. *> pic x(2) comp-x.
  03 cblte-ssp-name       cblt-x1.       *> Occurs depending on
                                         *> cblte-ssp-name-len. pic x(n).
status-code
See Library Routines - Key.

On Entry:

function-code
The subfunction number.
With function-code = 0:
cblte-ssp-name-len
The length of subsystem program-name field.
cblte-ssp-name
The subsystem program-name (space-terminated).
cblte-ssp-handle
The subsystem handle returned by a function 0 call.
With function-code = 2:
dummy-param
Value 0.

On Exit:

With function-code = 0:
cblte-ssp-handle
The subsystem handle.

Comments:

A subsystem is defined to be a specified COBOL program in an application, plus any subprograms subsequently called by programs already in the subsystem that do not already belong to any other subsystems.

With function-code = 0:
This function declares a subsystem. The routine returns a subsystem handle. If the program is not already loaded, the function loads it. If an error occurs in finding or loading the program, a subsystem handle of zero is returned.
A program belonging to a subsystem is only deallocated (that is, deleted from memory), when either it is canceled by the CANCEL verb, or the program cancels the entire subsystem using function-code=1, or the application executes a STOP RUN or CHAIN statement. The main program of a subsystem should not be canceled with the CANCEL statement unless all other programs in the subsystem have already been canceled. Any imported .dll files are automatically removed from memory when the .dll file which imports them is cancelled.
If the program is a .dll file, it must have been called previously if it is to be used to declare a subsystem.
With function-code = 1:
This function cancels all programs in the specified subsystem. On Windows, the default cancel mode is physical cancel, which can be changed with the subsystem_cancel_mode runtime tunable.
If any program in the subsystem is still active, that program is released from the subsystem and is not canceled. Any imported .dll files are automatically removed from memory when the .dll file which imports them is cancelled.
With function-code = 2:
This function removes the program that called it from any subsystem the program is in. To ensure a program is never included in any subsystem, call this function at the start of each entry in to the program.
Parent topic: Application Subsystem Routines
Parent topic: Alphabetical List of Library Routines
Related reference
subsystem_cancel_mode


Bit-packing Routines

  • X"F4"
    Packs the least significant bits in eight bytes into a single byte.
  • X"F5"
    Unpacks the bits in a byte into eight bytes.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


X"F4"

Packs the least significant bits in eight bytes into a single byte.

Syntax:

call x"F4" using byte
                 array

Parameters:

 | Using call prototype (see Key) | Picture
byte | cblt-x1-compx | pic x comp-x.
array | cblt-x1-compx occurs 8 | pic x comp-x occurs 8

On Entry:

array The bits to be packed.

On Exit:

byte The packed byte.

Comments:

The routine takes the eight bytes from array and uses the least significant bit of each byte to form byte. The first occurrence in array becomes the most significant bit of byte (bit 7).

00000001 00000001 00000000 00000000 00000001 00000000 00000001 00000001
       |        |        |        |        |        |        |        |
       |        |        |        |+-------+        |        |        |
       |        |        +-------+||+---------------+        |        |
       |        +---------------+||||+-----------------------+        |
       +-----------------------+||||||+-------------------------------+
                               ||||||||
                               vvvvvvvv
                               11001011
Parent topic: Bit-packing Routines
Parent topic: Alphabetical List of Library Routines


X"F5"

Unpacks the bits in a byte into eight bytes.

Syntax:

call x"F5" using byte
                 array

Parameters:

 | Using call prototype (see Key) | Picture
byte | cblt-x1-compx | pic x comp-x.
array | cblt-x1-compx occurs 8 | pic x comp-x occurs 8

On Entry:

byte The byte to be unpacked

On Exit:

array The unpacked bits

Comments:

The routine takes the eight bits of byte and moves them to the corresponding occurrence within array

                               10110011
                               ||||||||
       +-----------------------+||||||+-------------------------------+
       |        +---------------+||||+-----------------------+        |
       |        |        +-------+||+---------------+        |        |
       |        |        |        |+-------+        |        |        |
       v        v        v        v        v        v        v        v
00000001 00000000 00000001 00000001 00000000 00000000 00000001 00000001
Parent topic: Bit-packing Routines
Parent topic: Alphabetical List of Library Routines


Byte-stream File Routines

The byte-stream file routines enable you to read and write data files without the need to adhere to COBOL record definitions.

For all these routines, if the routine is successful the RETURN-CODE register is set to zero. If the routine fails, the RETURN-CODE register contains a file status value indicating the failure. This file status is always the standard ANSI'74 file status value. If no ANSI'74 file status is defined for the error, an extended file status is returned (9/nnn where nnn is the run-time system error number).

For this to work you should use RETURN-CODE and not have a RETURNING clause. If RETURN-CODE is nonzero after calling a byte-stream routine, move it to a PIC XX COMP-X data item to process it as a file status. For example:

 01 file-stat      pic xx comp-x.
 01    redefines file-stat.
     03 fs-byte-1  pic x.
     03 fs-byte-2  pic x comp-x.
   . . .
     call "CBL_xxx_FILE" using <parameters>
     if return-code not = 0
        move return-code to file-stat
           . . .

At this point fs-byte-1 contains "9" and fs-byte-2 contains the run-time system error number.

  • CBL_CLOSE_FILE
    Closes a file opened for byte-stream operations.
  • CBL_CREATE_FILE
    Creates a new file and leaves it open for byte-stream operations.
  • CBL_FLUSH_FILE
    Ensures all file buffers for a file are written to disk. This includes both run-time system buffers and operating system buffers.
  • CBL_FREE_RECORD_LOCK
    Releases a record lock on a file.
  • CBL_GET_RECORD_LOCK
    Obtains a record lock on a file.
  • CBL_OPEN_FILE
    Opens an existing file for byte-stream operations.
  • CBL_READ_FILE
    Reads bytes from a file.
  • CBL_TEST_RECORD_LOCK
    Tests for an existing record lock on a file.
  • CBL_WRITE_FILE
    Writes bytes to a file.
  • Byte-stream File Handling Routines - Example
Parent topic: Library Routines
Related information
Byte-stream File Handling Routines - Example
Alphabetical List of Library Routines


CBL_CLOSE_FILE

Closes a file opened for byte-stream operations.

Syntax:

call "CBL_CLOSE_FILE" using  file-handle

Parameters:

 | Using call prototype (see Key) | Picture
file-handle | cblt-bytestream-handle | pic x(4) comp-5.

On Entry:

file-handle The file handle returned when the file was opened.

On Exit:

None.

Comments:

Any byte-stream file open when a STOP RUN is executed is automatically closed. Any record locks owned by the run-unit are released by a call to this routine.

The success of the call can be checked by examining RETURN-CODE.

Parent topic: Byte-stream File Routines
Parent topic: Alphabetical List of Library Routines


CBL_CREATE_FILE

Creates a new file and leaves it open for byte-stream operations.

Syntax:

call "CBL_CREATE_FILE" using filename
                             access-mode
                             deny-mode
                             device
                             file-handle

Parameters:

 | Using call prototype (see Key) | Picture
filename | pic x(n). | pic x(n).
access-mode | cblt-x1-compx | pic x comp-x.
deny-mode | cblt-x1-compx | pic x comp-x.
device | cblt-x1-compx | pic x comp-x.
file-handle | cblt-bytestream-handle | pic x(4) comp-5.

On Entry:

filename
Space- or null-terminated filename of the file to be opened. You can use embedded environment variables and library names in filename.
access-mode
Defines access mode:
1 | Read only
2 | Write only (deny-mode must be 0)
3 | Read/write
64 | Read/write files greater than 4Gb
deny-mode
Defines deny mode:
0 | Deny both read and write (exclusive)
1 | Deny write
2 | Deny read
3 | Deny neither read nor write
device
Reserved for future use (must be 0).

On Exit:

file-handle
Returns a file handle for a successful open.

Comments:

The success of the call can be checked by examining the RETURN-CODE special register.

You can use embedded environment variables and library names in filename.

If you are requesting 64-bit file access to an unknown remote file system, ensure you set the remote_64bit_access tunable.

Parent topic: Byte-stream File Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
Byte-stream File Routines
Special Registers
Filenames


CBL_FLUSH_FILE

Ensures all file buffers for a file are written to disk. This includes both run-time system buffers and operating system buffers.

Syntax:

call "CBL_FLUSH_FILE" using file-handle

Parameters:

file-handle
Call prototype: cblt-bytestream-handle
Picture: pic x(4) comp-5.

On Entry:

file-handle
The file handle returned when the file was opened (by CBL_OPEN_FILE).

On Exit:

RETURN-CODE
Indicates whether the routine was successful:
0 | Success
-1 | Buffers might not have been flushed
Other | Two-byte file status code indicating the error

Comments

On some operating systems it is not possible to flush the file buffers. In this case, the appropriate status code is returned.

The success of the call can be checked by examining RETURN-CODE.

Parent topic: Byte-stream File Routines
Parent topic: Alphabetical List of Library Routines


CBL_FREE_RECORD_LOCK

Releases a record lock on a file.

Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_FREE_RECORD_LOCK" using file-handle
                                 record-offset
                                 record-length
                                 reserved

Parameters

 | Using call prototype (see Key) | Picture
file-handle | cblt-bytestream-handle | pic x(4) comp-5.
record-offset | cblt-x4-compx | pic x(4) comp-x.
record-length | cblt-x4-compx | pic x(4) comp-x.
reserved | cblt-x2-compx | pic x(2) comp-x.
return-code | cblt-x2-compx | pic x(2) comp-x.

On Entry:

file-handle
The handle returned from a successful CBL_OPEN_FILE or CBL_CREATE_FILE call.
record-offset
The offset from the start of the file to the first byte to be unlocked.
record-length
The number of bytes to unlock, starting from record-offset.
reserved
Reserved - must be zero.

On Exit:

return-code
One of the following codes:
0 | Lock successfully released
9/nnn | File status code indicating an error condition
Parent topic: Byte-stream File Routines
Parent topic: Alphabetical List of Library Routines


CBL_GET_RECORD_LOCK

Obtains a record lock on a file.

Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_GET_RECORD_LOCK" using file-handle
                                 record-offset
                                 record-length
                                 reserved

Parameters

 | Using call prototype (see Key) | Picture
file-handle | cblt-bytestream-handle | pic x(4) comp-5.
record-offset | cblt-x4-compx | pic x(4) comp-x.
record-length | cblt-x4-compx | pic x(4) comp-x.
reserved | cblt-x2-compx | pic x(2) comp-x.
return-code | cblt-x2-compx | pic x(2) comp-x.

On Entry:

file-handle
The handle returned from a successful CBL_OPEN_FILE or CBL_CREATE_FILE call.
record-offset
The offset from the start of the file to the first byte to be locked.
record-length
The number of bytes to lock, starting from record-offset.
reserved
Reserved - must be zero.

On Exit:

return-code
One of the following codes:
0 | Successful lock
1 | Lock is already owned by this run-unit
9/nnn | File status code indicating an error condition
Parent topic: Byte-stream File Routines
Parent topic: Alphabetical List of Library Routines


CBL_OPEN_FILE

Opens an existing file for byte-stream operations.

Syntax:

call "CBL_OPEN_FILE" using filename
                           access-mode
                           deny-mode
                           device
                           file-handle

Parameters:

 | Using call prototype (see Key) | Picture
filename | pic x(n). | pic x(n).
access-mode | cblt-x1-compx. | pic x comp-x.
deny-mode | cblt-x1-compx. | pic x comp-x.
device | cblt-x1-compx. | pic x comp-x.
file-handle | cblt-bytestream-handle. | pic x(4) comp-5.

On Entry:

filename
Space- or null-terminated filename of the file to be opened. You can use spacey filenames if you put double quotation marks around them. You can use embedded environment variables and library names in filename; for more information see the chapter Filenames in yourFile Handling book.
access-mode
Defines access mode:
1 | Read only
2 | Write only (deny-mode must be 0)
3 | Read/write
64 | Read/write files greater than 4Gb
deny-mode
Defines deny mode:
0 | Deny both read and write (exclusive)
1 | Deny write
2 | Deny read
3 | Deny neither read nor write
device
Reserved for future use (must be 0).

On Exit:

file-handle
Returns a file handle for a successful open.

Comments:

The success of the call can be checked by examining RETURN-CODE.

If you are requesting 64-bit file access to an unknown remote file system, ensure you set the remote_64bit_access tunable.

Parent topic: Byte-stream File Routines
Parent topic: Alphabetical List of Library Routines


CBL_READ_FILE

Reads bytes from a file.

Syntax:

call "CBL_READ_FILE" using file-handle
                           file-offset
                           byte-count
                           flags
                           buffer

Parameters:

 | Using call prototype (see Key) | Picture
file-handle | cblt-bytestream-handle | pic x(4) comp-5.
file-offset | cblt-x8-compx | pic x(8) comp-x.
byte-count | cblt-x4-compx | pic x(4) comp-x.
flags | cblt-x1-compx | pic x comp-x.
buffer | pic x(n). | pic x(n).

On Entry:

file-handle
The file handle returned when the file was opened.
file-offset
The offset in the file at which to read. This field is limited to a maximum value of x"00FFFFFFFF" unless bit 4 of the access-mode flag is set when the file is opened using CBL_OPEN_FILE or CBL_CREATE_FILE.
byte-count
The number of bytes to read.
flags
This parameter can take the following values:
0 | Standard read
128 | Return the current file size in file-offset

On Exit:

file-offset
Contains the current file size on return if flags is set to 128 on entry.
buffer
The buffer into which the bytes are read. It is your responsibility to ensure that the buffer is large enough to hold the number of bytes to be read.

Comments:

The success of the call can be checked by examining RETURN-CODE.

When using this routine to read a file that is contained in a .lbr file, the end-of-file status is not returned. To ensure you only read the file you want, obtain the size of the file first (set flags to 128), and only read up to that size.

Parent topic: Byte-stream File Routines
Parent topic: Alphabetical List of Library Routines


CBL_TEST_RECORD_LOCK

Tests for an existing record lock on a file.

Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_TEST_RECORD_LOCK using file-handle
                                 record-offset
                                 record-length
                                 reserved

Parameters:

 | Using call prototype (see Key) | Picture
file-handle | cblt-bytestream-handle | pic x(4) comp-5.
record-offset | cblt-x4-compx | pic x(4) comp-x.
record-length | cblt-x4-compx | pic x(4) comp-x.
reserved | cblt-x2-compx | pic x(2) comp-x.
return-code | cblt-x2-compx | pic x(2) comp-x.

On Entry:

file-handle
The handle returned from a successful CBL_OPEN_FILE or CBL_CREATE_FILE call.
record-offset
The offset from the start of the file to the first byte to be tested for a lock.
record-length
The number of bytes to test for a lock, starting from record-offset.
reserved
Reserved - must be zero.

On Exit:

return-code
One of the following values:
0 | Record not locked
1 | Lock already owned by run-unit
9/nnn | File status code indicating an error condition
Parent topic: Byte-stream File Routines
Parent topic: Alphabetical List of Library Routines


CBL_WRITE_FILE

Writes bytes to a file.

Syntax:

call "CBL_WRITE_FILE" using  file-handle
                            file-offset
                            byte-count
                            flags
                            buffer

Parameters:

 | Using call prototype (see Key) | Picture
file-handle | cblt-bytestream-handle | pic x(4) comp-5.
file-offset | cblt-x8-compx | pic x(8) comp-x.
byte-count | cblt-x4-compx | pic x(4) comp-x.
flags | cblt-x1-compx | pic x comp-x.
buffer | pic x(n). | pic x(n).

On Entry:

file-handle
The file handle returned when the file was opened.
file-offset
The offset in the file at which to write. This field is limited to a maximum value of x"00FFFFFFFF" unless bit 4 of the access-mode flag is set when the file is opened using CBL_OPEN_FILE or CBL_CREATE_FILE.
byte-count
The number of bytes to write.

Putting a value of zero in this field causes the file to be truncated or extended to the size specified in the file-offset field.

flags
This parameter can take the following value:
0: standard write
buffer
The buffer from which the bytes are written. It is your responsibility to ensure that the buffer is large enough to hold the number of bytes to be written.

On Exit:

None

Comments:

The success of the call can be checked by examining RETURN-CODE.

Parent topic: Byte-stream File Routines
Parent topic: Alphabetical List of Library Routines


Byte-stream File Handling Routines - Example

The following example program contains routines to open and close files to be processed as byte-stream files, one for input, one for output and to read and write individual bytes using buffering.

Source Code

$SET ANS85
copy "cblproto.cpy".
program-id.
*==========================================================*

 working-storage section
 78 fals value 0
 78 tru  value 1.

*----------------------------------------------------------*
* WS for byte-stream handling

 78 in-buff-len      value 4096.

 01 in-buff          pic x(in-buff-len).

 01 infilename       pic x(64).
 01 infile-handle    cblt-bytestream-handle.
 01 infile-offset    cblt-x8-compx value 0.
 01 infile-len       cblt-x8-compx.

 01 in-buff-ptr      pic x(2) comp-x.
 01 in-buff-end      cblt-x4 comp-x value in-buff-len.

 78 out-buff-len     value 4096.

 01 out-buff         pic x(out-buff-len).

 01 outfilename      pic x(64).
 01 outfile-handle   cblt-bytestream-handle.
 01 outfile-offset   cblt-x8-compx value 0.
 01 outfile-len      cblt-x8-compx.

 01 out-buff-ptr     pic x(2) comp-x.
 01 out-buff-end     cblt-x4-compx value in-buff-len.

 01 bs-misc.
     03 eof-flag         pic x comp-x value fals.
         88 eof              value tru.
     03 last-block-flag  pic x comp-x value fals.
         88 last-block       value tru.
     03 display-put-flag pic x comp-x value fals.
         88 display-put      value tru false fals.

     03 next-byte.
         05 next-byte-n  cblt-x1-compx
     03 save-byte        pic x.

 01 k-0              cblt-x1-compx value 0.
 01 k-1              cblt-x1-compx value 1.
 01 k-2              cblt-x1-compx value 2.
 01 k-128            cblt-x1-compx value 128.

*----------------------------------------------------------*

*==========================================================*
 procedure division.
 aa-control section.
     perform ca-initial.
     perform cc-process.
     perform ce-final
     .

 aa-990-exit.
     exit program
     stop run
     .

 ca-initial section.
     move "inbyte.dat" to infilename
     move "outbyte.dat" to outfilename
     perform open-in-file
     perform open-out-file
     .

 cc-process section.

* Examine each byte, and process as required when the
* appropriate byte is found (as identified by the when
* clause)

     perform get-byte
     perform until eof
         evaluate next-byte
          when .......

          when other
             perform put-byte
             perform get-byte
         end-evaluate
     end-perform
     .

 ce-final section.
     perform close-in-file
     perform close-out-file
     .

*----------------------------------------------------------*
* Input byte-stream file code

 open-in-file section.
     call "CBL_OPEN_FILE" using infilename
                                k-1
                                k-0
                                k-0
                                infile-handle
     if return-code not = 0
         display "Open failed: "
                 infilename
         stop run
     end-if

* Find length of input file.
     call "CBL_READ_FILE" using infile-handle
                                infile-offset
                                in-buff-end
                                k-128
                                in-buff
     move infile-offset to infile-len
     move 0 to infile-offset
     move in-buff-len to in-buff-ptr
     add 1 to in-buff-ptr
     move fals to last-block-flag
     move fals to eof-flag
     .

 get-byte section.
     if in-buff-ptr = in-buff-end
         if last-block
             set eof to true
             move x"ff" to next-byte
         else
             perform get-next-block
             if in-buff-end = 0
                 set eof to true
                 move x"ff" to next-byte
             end-if
         end-if
     end-if

     if not eof
         move in-buff (in-buff-ptr : 1) to next-byte
         add 1 to in-buff-ptr
*        display next-byte
*            with no advancing
     end-if
     .

 get-previous-byte section.
     if in-buff-ptr = 2
         subtract 2 from in-buff-ptr
     else
         perform get-previous-block
     end-if
     perform get-byte
     .

 get-next-block section.
     call "CBL_READ_FILE" using infile-handle
                                infile-offset
                                in-buff-end
                                k-0
                                in-buff
     end-call
     move 1 to in-buff-ptr
     add in-buff-end to infile-offset
     if infile-offset = infile-len
         subtract infile-len from infile-offset
         subtract infile-offset from in-buff-end
         move tru to last-block-flag
     end-if
     .

 get-previous-block section.
     if last-block
         move fals to last-block-flag
         move in-buff-len to in-buff-end
         add infile-len to infile-offset
     end-if
     subtract in-buff-end from infile-offset
     call "CBL_READ_FILE" using infile-handle
                         infile-offset
                         in-buff-end
                         k-0
                         in-buff
     end-call
     move in-buff-len to in-buff-ptr
     .
 close-in-file section.
     call "CBL_CLOSE_FILE" using infile-handle
     .

*==========================================================*
* Output byte-stream file code

 open-out-file section.
     call "CBL_CREATE_FILE" using outfilename
                                k-2
                                k-0
                                k-0
                                outfile-handle

     if return-code not = 0
         display "Open failed: "
                 outfilename
         stop run
     end-if
     move 1 to out-buff-ptr
     .

 put-byte section.
     if display-put
         display next-byte
             with no advancing
     end-if
     move next-byte to out-buff (out-buff-ptr:1)
     add 1 to out-buff-ptr
     if out-buff-ptr = out-buff-len
         perform write-block
         move 1 to out-buff-ptr
     end-if
     .

 write-block section.
     call "CBL_WRITE_FILE" using outfile-handle
                                 outfile-offset
                                 out-buff-end
                                 k-0
                                 out-buff
     end-call
     add out-buff-end to outfile-offset
     .

 close-out-file section.
     if out-buff-ptr = 1
         move out-buff-ptr to out-buff-end
         subtract 1 from out-buff-end
         perform write-block
     end-if
     call "CBL_CLOSE_FILE" using outfile-handle
     .
Parent topic: Byte-stream File Routines


Character Set Conversion Routines

The character set conversion routines convert characters between the OEM and ANSI character sets..

  • PC_WIN_CHAR_TO_OEM
    Translates a buffer of ANSI characters into the OEM character set.
  • PC_WIN_OEM_TO_CHAR
    Translates a buffer of OEM characters into the ANSI character set.
  • PC_WIN_SET_CHARSET
    Specifies the character set to be used by the case conversion routines CBL_TOUPPER and CBL_TOLOWER.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


PC_WIN_CHAR_TO_OEM

Translates a buffer of ANSI characters into the OEM character set.

Syntax:

call "PC_WIN_CHAR_TO_OEM" using     srcbuff
                                    tgtbuff
                          by value  srclen
                                    tgtlen
                          returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
srcbuff | pic x(n). | pic x(n).
tgtbuff | pic x(n). | pic x(n).
srclen | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
tgtlen | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
status-code | See Library Routines - Key |

On Entry:

srcbuff | Buffer of ANSI characters to be converted.
srclen | Length of srcbuff. If this parameter is zero, then srcbuff is a null-terminated string all of which will be converted.
tgtlen | Length of tgtbuff.

On Exit:

tgtbuff Buffer of OEM characters converted from the ANSI input. This parameter must be at least as long as the number of characters in srcbuff. If srcbuff and tgtbuff are the same buffer, then the characters will be converted in place in the buffer.

Comments:

If status-code is non-zero, then the call failed due to the target buffer being of insufficient size.

Parent topic: Character Set Conversion Routines
Parent topic: Alphabetical List of Library Routines


PC_WIN_OEM_TO_CHAR

Translates a buffer of OEM characters into the ANSI character set.

Syntax:

call "PC_WIN_OEM_TO_CHAR" using     srcbuff
                                    tgtbuff
                          by value   srclen
                                    tgtlen
                          returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
srcbuff | pic x(n). | pic x(n).
tgtbuff | pic x(n). | pic x(n).
srclen | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
tgtlen | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
status-code | See Library Routines - Key |

On Entry:

srcbuff | Buffer of OEM characters to be converted.
srclen | Length of srcbuff. If this parameter is zero, then srcbuff is a null-terminated string all of which will be converted.
tgtlen | Length of tgtbuff.

On Exit:

tgtbuff Buffer of ANSI characters converted from the OEM input. This parameter must be at least as long as the number of characters in srcbuff. If srcbuff and tgtbuff are the same buffer, then the characters will be converted in place in the buffer.

Comments:

If status-code is non-zero, then the call failed due to the target buffer being of insufficient size.

Parent topic: Character Set Conversion Routines
Parent topic: Alphabetical List of Library Routines


PC_WIN_SET_CHARSET

Specifies the character set to be used by the case conversion routines CBL_TOUPPER and CBL_TOLOWER.

Syntax:

call "PC_WIN_SET_CHARSET" using
                          by value  charset
                          returning previous-charset

Parameters:

 | Using call prototype (see Key) | Picture
charset | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
previous-charset | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

charset The character set to use (0 - ANSI, 1 - OEM).

On Exit:

previous-charset The previous value of the character set.
Parent topic: Character Set Conversion Routines
Parent topic: Text Routines
Parent topic: Alphabetical List of Library Routines


Consolidated Tracing Facility Routines

These routines enable you to make use of the Consolidated Tracing Facility infrastructure in your applications.

  • CBL_CTF_COMP_PROPERTY_GET
    Returns a named property value for a component.
  • CBL_CTF_COMP_PROPERTY_SET
    Specifies a value for a component's property.
  • CBL_CTF_DEST
    Specifies an output destination by associating (or disassociating) an emitter with (or from) a component or the default emitter list.
  • CBL_CTF_EMITTER_PROPERTY_GET
    Returns a named property value for an emitter.
  • CBL_CTF_EMITTER_PROPERTY_SET
    Sets a named property value for an emitter.
  • CBL_CTF_LEVEL
    Specifies the trace level to be used for a specific component, or the default trace level if a component identifier is not specified.
  • CBL_CTF_TRACE
    Outputs an event to one or more output destinations.
  • CBL_CTF_TRACER_GET
    Returns a tracer handle that can be passed to other tracing routines to identify a component.
  • CBL_CTF_TRACER_LEVEL_GET
    Returns a tracer's current threshold trace level.
  • CBL_CTF_TRACER_NOTIFY
    Installs or uninstalls a tracer configuration callback function.
  • Consolidated Tracing Facility Return Codes
Parent topic: Library Routines
Related information
Introduction to the Consolidated Tracing Facility
Consolidated Tracing Facility Return Codes
Alphabetical List of Library Routines


CBL_CTF_COMP_PROPERTY_GET

Returns a named property value for a component.

Syntax:

call "CBL_CTF_COMP_PROPERTY_GET" using by value     flags
                                       by reference component-id
                                       by reference property-name
                                       by reference property-vallen
                                       by reference property-value
                                          returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
component-id | pic x(n) | pic x(n)
property-name | pic x(n) | pic x(n)
property-vallen | cblt-x4-comp5 | pic x(4) comp-5
property-value | pic x(n) | pic x(n)
status-code | See Library Routines - Key |

On Entry:

flags
Control flags:
Bit 0
Value | Meaning
0 | Return a string value. Use bit 1 to determine the string terminator.
1 | Return an integer value. Ignore bit 1.
Bit 1
Value | Meaning
0 | Return the value as a space-terminated string.
1 | Return the value as a null-terminated string.
Bits 2-28
Reserved for future use. Must be 0.
Bit 29
Value | Meaning
0 | property-name is space-terminated.
1 | property-name is null-terminated.
Bit 30
Value | Meaning
0 | component-id is space-terminated.
1 | component-id is null-terminated. This is ignored if bit 31 is unset.
Bit 31
Value | Meaning
0 | component-id is a pic x(4) comp-5 tracer handle returned from a call to CBL_CTF_TRACER_GET.
1 | component-id is a pic x(n) text string. The termination character for the string is defined by bit 30.
component-id
Component whose property value is to be returned. This is either a pic x(4) comp-5 tracer handle (from CBL_CTF_TRACER_GET) if bit 31 of flags is not set, or a pic x(n) text identifier if bit 31 of flags is set.
property-name
Space- or null-terminated (depending on the setting of bit 29) case-insensitive property whose value is to be returned.
property-vallen
Length of the property-value buffer in which the property's value is to be returned. The routine will fail if the buffer is too small for the value to be returned. property-vallen is ignored if the value is being returned as an integer.
property-value
If set to null, specifies that the routine is to return (in property-vallen) the length of the buffer required in to hold the property specified by property-name.

On Exit:

property-vallen
Length of returned string value in the property-value buffer, not including the termination character. If property-value is null, or if the specified buffer length is too small for the value to be returned, property-vallen is set to the required buffer length. property-vallen is not set if the value is being returned as an integer.
property-value
Buffer in which the property value is to be returned. This is either a pic x(n) field for a value being returned as a string, or a pic x(4) comp-5 field for a value being returned as an integer.
status-code
One of:
  • 78-CTF-RET-BUFFER-TOO-SMALL
  • 78-CTF-RET-INVALID-COMP-NAME
  • 78-CTF-RET-INVALID-PROP-NAME
  • 78-CTF-RET-INVALID-TRACE-HANDLE
  • 78-CTF-RET-NOT-ENOUGH-MEMORY
  • 78-CTF-RET-PROPERTY-NOT-FOUND
  • 78-CTF-RET-SUCCESS
  • 78-CTF-RET-VALUE-NOT-INTEGER

Example:

Acquire a tracer handle to trace "mycomp" component events, and get two "mycomp" property values; one a null-terminated string value, one an integer value:

copy "cbltypes.cpy".
copy "mfctf.cpy".

01 component-id    pic x(7) value "mycomp ".
01 flags           pic x(4) comp-5.
01 prop-integer    pic x(4) comp-5.
01 prop-len        pic x(4) comp-5.
01 prop-string     pic x(100).
01 tracer-handle   pic x(4) comp-5.
...
call "CBL_CTF_TRACER_GET" using by value 0
                                by reference component-id
                                by reference tracer-handle
...
compute flags = 78-CTF-FLAG-PROP-STRING-VALUE b-or
                78-CTF-FLAG-PROP-NAME-NULL-TERM
move length of prop-string to prop-len

call "CBL_CTF_COMP_PROPERTY_GET" using by value flags
                                       by reference tracer-handle
                                       by reference "prop1 "
                                       by reference prop-len
                                       by reference prop-string
...
compute flags = 78-CTF-FLAG-PROP-INT-VALUE

call "CBL_CTF_COMP_PROPERTY_GET" using by value flags
                                       by reference tracer-handle
                                       by reference "prop2 "
                                       by value 0
                                       by reference prop-integer
...
Parent topic: Consolidated Tracing Facility Routines
Parent topic: Alphabetical List of Library Routines


CBL_CTF_COMP_PROPERTY_SET

Specifies a value for a component's property.

Syntax:

call "CBL_CTF_COMP_PROPERTY_SET" using by value     flags
                                       by reference component-id
                                       by reference property-name
                                       by reference property-value
                                          returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
component-id | pic x(n) | pic x(n)
property-name | pic x(n) | pic x(n)
property-value | pic x(n) | pic x(n)
status-code | See Library Routines - Key |

On Entry:

flags
Control flags:
Bit 0
Value | Meaning
0 | Specify a string value. Use bit 1 to determine the string terminator.
1 | Specify an integer value. Ignore bit 1.
Bit 1
Value | Meaning
0 | String value is space-terminated.
1 | String value is null-terminated.
Bits 2-28
Reserved for future use. Must be 0.
Bit 29
Value | Meaning
0 | property-name is space-terminated.
1 | property-name is null-terminated.
Bit 30
Value | Meaning
0 | component-id is space-terminated.
1 | component-id is null-terminated. This is ignored if bit 31 is unset.
Bit 31
Value | Meaning
0 | component-id is a pic x(4) comp-5 tracer handle returned from a call to CBL_CTF_TRACER_GET if bit 31 of flags is not set, or a pic x(n) text identifier if bit 31 of flags is set.
1 | component-id is a pic x(n) text string. The termination character for the string is defined by bit 30.
component-id
Component identifier. This is either a pic x(4) comp-5 tracer handle (from CBL_CTF_TRACER_GET) if bit 31 of flags is not set, or a pic x(n) text identifier if bit 31 of flags is set.
property-name
Space- or null-terminated (depending on the setting of bit 29) case-insensitive property whose value is to be returned.
property-value
Buffer containing the property value to be set. This is either a pic x( n) field for a value being specified as a string, or a pic x(4) comp-5 field for a value being set as an integer.

On Exit:

status-code
One of:
  • 78-CTF-RET-INVALID-COMP-NAME
  • 78-CTF-RET-INVALID-TRACE-HANDLE
  • 78-CTF-RET-INVALID-PROP-NAME
  • 78-CTF-RET-NOT-ENOUGH-MEMORY
  • 78-CTF-RET-SUCCESS

Comments:

Use CBL_CTF_COMP_PROPERTY_SET to set a named property value for the component identified by component-id. If a property with the same name already exists for the component, its value is replaced with the new value. This routine provides equivalent functionality to the mftrace.comp.component-name#property configuration file entry.

Example:

To acquire a tracer handle to trace "mycomp" component events, and set two "mycomp" property values; one a null-terminated string value, the other an integer value:

copy "cbltypes.cpy".
copy "mfctf.cpy".

01 component-id    pic x(7) value "mycomp ".
01 flags           pic x(4) comp-5.
01 prop-integer    pic x(4) comp-5.
01 prop-string     pic x(100).
01 tracer-handle   pic x(4) comp-5.
...
call "CBL_CTF_TRACER_GET" using by value 0
                                by reference component-id
                                by reference tracer-handle
...
compute flags = 78-CTF-FLAG-PROP-STRING-VALUE b-or
                78-CTF-FLAG-PROP-NAME-NULL-TERM
move "xxxx" & x"00" to prop-string

call "CBL_CTF_COMP_PROPERTY_SET" using by value flags
                                       by reference tracer-handle
                                       by reference "prop1 "
                                       by reference prop-string
...
compute flags = 78-CTF-FLAG-PROP-INT-VALUE
move 100 to prop-integer

call "CBL_CTF_COMP_PROPERTY_SET" using by value flags
                                       by reference tracer-handle
                                       by reference "prop2 "
                                       by reference prop-integer
...
Parent topic: Consolidated Tracing Facility Routines
Parent topic: Alphabetical List of Library Routines


CBL_CTF_DEST

Specifies an output destination by associating (or disassociating) an emitter with (or from) a component or the default emitter list.

Syntax:

call "CBL_CTF_DEST" using by value     flags
                          by reference component-id
                          by reference emitter-name
                             returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
component-id | pic x(n) | pic x(n)
emitter-name | pic x(n) | pic x(n)
status-code | See Library Routines - Key |

On Entry:

flags
Control flags:
Bit 0
Value | Meaning
0 | Associate the emitter-name with component-id
1 | Disassociate the emitter-name with component-id
Bit 1
Value | Meaning
0 | Inherit emitters from parent.
1 | Do not inherit emitters from parent. This is ignored if bit 0 is set, or if the default emitter list is specified.
Bits 2-27
Reserved for future use. Must be 0.
Bit 28
Value | Meaning
0 | emitter-name is space-terminated.
1 | emitter-name is null-terminated.
Bit 29
Reserved for future use. Must be 0.
Bit 30
Value | Meaning
0 | component-id is space-terminated.
1 | component-id is null-terminated. This is ignored if bit 31 is unset.
Bit 31
Value | Meaning
0 | component-id is a pic x(4) comp-5 tracer handle returned from a call to CBL_CTF_TRACER_GET.
1 | component-id is a pic x(n) text string. The termination character for the string is defined by bit 30.
component-id
Component identifier. This is either a pic x(4) comp-5 tracer handle (from CBL_CTF_TRACER_GET) if bit 31 of flags is not set, or a pic x(n) text identifier if bit 31 of flags is set.
emitter-name
Space- or null-terminated (depending on the setting of bit 28) case-insensitive property whose value is to be returned.

On Exit:

status-code
One of:
  • 78-CTF-RET-EMITTER-NOT-FOUND
  • 78-CTF-RET-INVALID-COMP-NAME
  • 78-CTF-RET-INVALID-EMITTER-NAME
  • 78-CTF-RET-INVALID-TRACE-HANDLE
  • 78-CTF-RET-NOT-ENOUGH-MEMORY
  • 78-CTF-RET-SUCCESS

Comments:

CBL_CTF_DEST provides equivalent functionality to the mftrace.dest and mftrace.dest.component-name configuration file entries.

There is always at least one entry in the default emitter list. When the last entry is removed from the default list, the TextFile emitter is implicitly added to it. If a component's emitter list becomes empty, it implicitly inherits its parent's emitters even if bit 1 of flags is set indicating that it does not inherit.

Example:

 copy "cbltypes.cpy".
 copy "mfctf.cpy".

 01 component-name  pic x(4).
 01 emitter-name    pic x(10).
 01 flags           pic x(4) comp-5.

*> 1) Add TextFile to the default trace emitter list.

 ...
 move "TextFile" to emitter-name
 compute flags = 78-CTF-FLAG-DEST-ADD

 call "CBL_CTF_DEST" using by value flags
                          by value 0
                          by reference emitter-name
 ...

*> 2) Remove TextFile from the default trace emitter list.

 ...
 move "TextFile" to emitter-name
 compute flags = 78-CTF-FLAG-DEST-REMOVE

 call "CBL_CTF_DEST" using by value flags
                           by value 0
                           by reference emitter-name
 ...

*> 3) Associate the BinFile trace emitter with the RTS component.
*>    The RTS component will inherit the default trace emitters.

 ...
 move "RTS" to component-name
 move "ES" to emitter-name
 compute flags = 78-CTF-FLAG-DEST-ADD b-or
                 78-CTF-FLAG-COMPID-STRING

 call "CBL_CTF_DEST" using by value flags
                           by reference component-name
                           by reference emitter-name
 ...

*> 4) Make the BinFile trace emitter the only emitter the
*>    RTS component will use; that is, the RTS component will
*>    not inherit the default trace emitters.

 ...
 move "RTS" to component-name
 move "BinFile" to emitter-name
 compute flags = 78-CTF-FLAG-DEST-ADD b-or
                 78-CTF-FLAG-DEST-NOINHERIT
                 78-CTF-FLAG-COMPID-STRING

 call "CBL_CTF_DEST" using by value flags
                           by reference component-name
                           by reference emitter-name
 ...
Parent topic: Consolidated Tracing Facility Routines
Parent topic: Alphabetical List of Library Routines


CBL_CTF_EMITTER_PROPERTY_GET

Returns a named property value for an emitter.

Syntax:

call "CBL_CTF_EMITTER_PROPERTY_GET" using by value     flags
                                          by reference emitter-name
                                          by reference property-name
                                          by reference property-vallen
                                          by reference property-value
                                             returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
emitter-name | pic x(n) | pic x(n)
property-name | pic x(n) | pic x(n)
property-vallen | cblt-x4-comp5 | pic x(4) comp-5
property-value | pic x(n) | pic x(n)
status-code | See Library Routines - Key |

On Entry:

flags
Control flags:
Bit 0
Value | Meaning
0 | Return a string value. Use bit 1 to determine the string terminator.
1 | Return an integer value. Ignore bit 1.
Bit 1
Value | Meaning
0 | Return the value as a space-terminated string.
1 | Return the value as a null-terminated string.
Bits 2-27
Reserved for future use. Must be 0.
Bit 28
Value | Meaning
0 | emitter-name is space-terminated.
1 | emitter-name is null-terminated.
Bit 29
Value | Meaning
0 | property-name is space-terminated.
1 | property-name is null-terminated.
Bits 30-31
Reserved for future use. Must be 0.
emitter-name
Space- or null-terminated (depending on the setting of bit 28) case-insensitive emitter name.
property-name
Space- or null-terminated (depending on the setting of bit 29) case-insensitive property whose value is to be returned.
property-vallen
Length of the property-value buffer in which the property's value is to be returned. The routine will fail if the buffer is too small for the value to be returned. property-vallen is ignored if the value is being returned as an integer.
property-value
If set to null, specifies that the routine is to return (in property-vallen) the length of the buffer required in to hold the property specified by property-name.

On Exit:

property-vallen
Length of returned string value in the property-value buffer, not including the termination character. If property-value is null, or if the specified buffer length is too small for the value to be returned, property-vallen is set to the required buffer length. property-vallen is not set if the value is being returned as an integer.
property-value
Buffer in which the property value is to be returned. This is either a pic x(n) field for a value being returned as a string, or a pic x(4) comp-5 field for a value being returned as an integer.
status-code
One of:
  • 78-CTF-RET-BUFFER-TOO-SMALL
  • 78-CTF-RET-EMITTER-NOT-FOUND
  • 78-CTF-RET-NOT-ENOUGH-MEMORY
  • 78-CTF-RET-PROPERTY-NOT-FOUND
  • 78-CTF-RET-SUCCESS
  • 78-CTF-RET-VALUE-NOT-INTEGER

Example:

Get two property values associated with the "myemitter" emitter; one a null-terminated string value, one an integer value:

copy "cbltypes.cpy".
copy "mfctf.cpy".

01 emitter-name    pic x(10) value "myemitter".
01 flags           pic x(4) comp-5.
01 prop-integer    pic x(4) comp-5.
01 prop-len        pic x(4) comp-5.
01 prop-string     pic x(100).
...
compute flags = 78-CTF-FLAG-PROP-STRING-VALUE b-or
                78-CTF-FLAG-PROP-NULL-TERM
move length of prop-string to prop-len

call "CBL_CTF_EMITTER_PROPERTY_GET" using
                                    by value flags
                                    by reference emitter-name
                                    by reference "prop1 "
                                    by reference prop-len
                                    by reference prop-string
...
compute flags = 78-CTF-FLAG-PROP-INT-VALUE

call "CBL_CTF_EMITTER_PROPERTY_GET" using
                                    by value flags
                                    by reference emitter-name
                                    by reference "prop2 "
                                    by value 0
                                    by reference prop-integer
...
Parent topic: Consolidated Tracing Facility Routines
Parent topic: Alphabetical List of Library Routines


CBL_CTF_EMITTER_PROPERTY_SET

Sets a named property value for an emitter.

Syntax:

call "CBL_CTF_EMITTER_PROPERTY_SET" using by value     flags
                                          by reference emitter-name
                                          by reference property-name
                                          by reference property-value
                                             returning

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
emitter-name | pic x(n) | pic x(n)
property-name | pic x(n) | pic x(n)
property-value | pic x(n) | pic x(n)
status-code | See Library Routines - Key |

On Entry:

flags
Control flags:
Bit 0
Value | Meaning
0 | String value. Use bit 1 to determine the string terminator.
1 | Integer value. Ignore bit 1.
Bit 1
Value | Meaning
0 | String value is a space-terminated.
1 | String value is a null-terminated.
Bits 2-27
Reserved for future use. Must be 0.
Bit 28
Value | Meaning
0 | emitter-name is space-terminated.
1 | emitter-name is null-terminated.
Bit 29
Value | Meaning
0 | property-name is space-terminated.
1 | property-name is null-terminated.
Bits 30-31
Reserved for future use. Must be 0.
emitter-name
Space- or null-terminated (depending on the setting of bit 28) case-insensitive emitter name.
property-name
Space- or null-terminated (depending on the setting of bit 29) case-insensitive property whose value is to be returned.
property-value
Buffer containing the property value to be set. This is either a pic x(n) field for a value being specified as a string, or a pic x(4) comp-5 field for a value being set as an integer.

On Exit:

status-code
One of:
  • 78-CTF-RET-EMITTER-NOT-FOUND
  • 78-CTF-RET-INVALID-EMITTER-NAME
  • 78-CTF-RET-INVALID-PROPERTY-NAME
  • 78-CTF-RET-NOT-ENOUGH-MEMORY
  • 78-CTF-RET-SUCCESS

Comments:

If a property with the same name already exists for the specified emitter, its value is replaced by the new value.

Example:

To set two property values associated with the "myemitter" emitter; one a null-terminated string value, one an integer value:

copy "cbltypes.cpy".
copy "mfctf.cpy".
01 emitter-name pic x(10) value "myemitter".
01 flags        pic x(4) comp-5.
01 prop-integer pic x(4) comp-5.
01 prop-string  pic x(100).
...
compute flags = 78-CTF-FLAG-PROP-STRING-VALUE b-or
                78-CTF-FLAG-PROP-NULL-TERM
move "xxx" & x"00" to prop-string
call "CBL_CTF_EMITTER_PROPERTY_SET" using by value flags
                                          by reference emitter-name
                                          by reference "prop1 "
                                          by reference prop-string
...
compute prop-flags = 78-CTF-FLAG-PROP-INT-VALUE
move 100 to prop-integer
call "CBL_CTF_EMITTER_PROPERTY_GET" using by value flags
                                          by reference emitter-name
                                          by reference "prop2 "
                                          by reference prop-integer
...
Parent topic: Consolidated Tracing Facility Routines
Parent topic: Alphabetical List of Library Routines


CBL_CTF_LEVEL

Specifies the trace level to be used for a specific component, or the default trace level if a component identifier is not specified.

Syntax:

call "CBL_CTF_LEVEL" using by value     flags
                           by value     trace-level
                           by reference component-id
                              returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
trace-level | cblt-x4-comp5 | pic x(4) comp-5
component-id | pic x(n) | pic x(n)
status-code | See Library Routines - Key |

On Entry:

flags
Control flags:
Bits 0-29
Reserved for future use. Must be 0.
Bit 30
Value | Meaning
0 | component-id is space-terminated.
1 | component-id is null-terminated. This is ignored if bit 31 is unset.
Bit 31
Value | Meaning
0 | component-id is a pic x(4) comp-5 tracer handle returned from a call to CBL_CTF_TRACER_GET.
1 | component-id is a pic x(n) text string. The termination character for the string is defined by bit 30.
trace-level
Sets the default trace threshold level. One of:
  • 78-CTF-FLAG-LEVEL-DEBUG
  • 78-CTF-FLAG-LEVEL-INFO
  • 78-CTF-FLAG-LEVEL-WARN
  • 78-CTF-FLAG-LEVEL-ERROR
  • 78-CTF-FLAG-LEVEL-FATAL
component-id
Component whose property value is to be returned. This is either a pic x(4) comp-5 tracer handle (from CBL_CTF_TRACER_GET) if bit 31 of flags is not set, or a pic x(n) text identifier if bit 31 of flags is set.

On Exit:

status-code
One of:
  • 78-CTF-RET-INVALID-COMPONENT-NAME
  • 78-CTF-RET-INVALID-TRACE-HANDLE
  • 78-CTF-RET-INVALID-TRACE-LEVEL
  • 78-CTF-RET-NOT-ENOUGH-MEMORY
  • 78-CTF-RET-SUCCESS

Comments:

CBL_CTF_LEVEL provides equivalent functionality to the mftrace.level and mftrace.level.component-name configuration file entries.

Example:

 copy "cbltypes.cpy".
 copy "mfctf.cpy".

*> 1) Set the default trace threshold level to be DEBUG

 ...
 call "CBL_CTF_LEVEL" using by value 0
                            by value 78-CTF-FLAG-LEVEL-DEBUG
                            by reference " "
 ...

*> 2) Set the WARNING tracing threshold level for the MF.RTS component.
*>    Any component inheriting from the MF.RTS component (such as
*>    MF.RTS.ERR and MF.RTS.MEM) will also use the WARNING tracing
*>    threshold level. All other trace-enabled components will use the
*>    INFO tracing threshold level.

 ...
 call "CBL_CTF_LEVEL" using by value 0
                            by value 78-CTF-FLAG-LEVEL-INFO
                            by reference " "

 call "CBL_CTF_LEVEL" using by value 0
                            by value 78-CTF-FLAG-LEVEL-WARN
                            by reference "MF.RTS "
 ...
Parent topic: Consolidated Tracing Facility Routines
Parent topic: Alphabetical List of Library Routines


CBL_CTF_TRACE

Outputs an event to one or more output destinations.

Syntax:

call "CBL_CTF_TRACE" using by value     flags
                           by reference component-id
                           by reference trace-event
                              returning status-code

Parameters

flags
Call prototype:cblt-x4-comp5
Picture: pic x(4) comp-5.
component-id
Call prototype: pic x(n)
Picture: pic x(n).
trace-event
Group predefined as cblt-trc-event containing:
01 cblt-trc-event              typedef.
  03 cblte-trcevt-version      cblt-x4-comp5. *> pic x(4) comp-5.
  03 cblte-trcevt-flags        cblt-x4-comp5. *> pic x(4) comp-5.
  03 cblte-trcevt-event-id     cblt-x4-comp5. *> pic x(4) comp-5.
  03 cblte-trcevt-level        cblt-x4-comp5. *> pic x(4) comp-5.
  03 cblte-trcevt-data-count   cblt-x4-comp5. *> pic x(4) comp-5.
  03 cblte-trcevt-event-len    cblt-pointer.	 *> pointer
  03 cblte-trcevt-event-type   cblt-pointer.  *> pointer
  03 cblte-trcevt-event-data   cblt-pointer.  *> pointer
status-code
See Library Routines - Key.

On Entry:

flags
Control flags:
Bits 0-11
Reserved for future use. Must be 0.
Bit 12
Value | Meaning
0 | Output event data only if the component is enabled for tracing, and if the event level specified by cblte-trcevt-level is greater or equal to the tracing level configured for the component.
1 | Force the output of the event if the component is enabled for tracing. cblte-trcevt-level and the tracing level configured for the component are ignored.
Bit 13
Value | Meaning
0 | cblte-trcevt-event-data is an array of pointers to trace data of varying size and type. The corresponding elements of the cblte-trcevt-event-len and cblte-trcevt-event-type arrays need to be defined.
1 | cblte-trcevt-event-data is an array of pointers to trace data of the same size and type. Only the first element of cblte-trcevt-event-len and cblte-trcevt-event-type need to be defined.
Bits 14-29
Reserved for future use. Must be 0.
Bit 30
Value | Meaning
0 | component-id is space-terminated.
1 | component-id is null-terminated. This is ignored if bit 31 is unset.
Bit 31
Value | Meaning
0 | component-id is a pic x(4) comp-5 tracer handle returned from a call to CBL_CTF_TRACER_GET.
1 | component-id is a pic x(n) text string. The termination character for the string is defined by bit 30.
component-id
Component identifier. This is either a pic x(4) comp-5 tracer handle (from CBL_CTF_TRACER_GET) if bit 31 of flags is not set, or a pic x(n) text identifier if bit 31 of flags is set.
cblte-trcevt-version
Structure version. Must be 0.
cblte-trcevt-flags
Control flags. Must be 0.
cblte-trcevt-event-id
Component-specific event identifier used to identify the type of event being output.
cblte-trcevt-event-level
Tracing level of the event being output.
cblte-trcevt-data-count
Number of trace data items, indicating the number of elements in the cblte-trcevt-event-len, cblte-trcevt-event-type, and cblte-trcevt-event-data arrays. This can be 0.
cblte-trcevt-event-len
Pointer to an array of 4-byte comp-5 items. Each array element indicates the length of the corresponding trace data item in the cblte-trcevt-event-data array. This can be NULL if cblte-trcevt-data-count is 0.
cblte-trcevt-event-type
Pointer to an array of 4-byte comp-5 items. Each array element indicates the type of the corresponding trace data item in the cblte-trcevt-event-data array. This can be NULL if cblte-trcevt-data-count is 0.
Value | Type
0 | Binary
1 | Text (local encoding)
2 | Address
3 | COMP-5
4 | COMP-X
5 | UTF8
6 | Signed COMP-5
7 | Signed COMP-X
Any value other than the ones specified above is treated as type 0 (binary).
cblte-trcevt-event-data
Pointer to an array of pointer items. Each array element addresses a trace data item of the type and length indicated by the corresponding element in the cblte-trcevt-event-type and cblte-trcevt-event-len arrays respectively. This can be NULL if cblte-trcevt-data-count is 0.
For address type items, the array element is the address value; not a pointer to the address value.

On Exit:

status-code
One of:
  • 78-CTF-RET-INVALID-COMPONENT-NAME
  • 78-CTF-RET-INVALID-TRACE-HANDLE
  • 78-CTF-RET-INVALID-TRACE-LEVEL
  • 78-CTF-RET-NOT-ENOUGH-MEMORY
  • 78-CTF-RET-NOT-TRACE-ENABLED
  • 78-CTF-RET-NOT-TRACING-LEVEL
  • 78-CTF-RET-OUTPUT-ERROR
  • 78-CTF-RET-SUCCESS

Comments:

CBL_CTF_TRACE() outputs the specified event identified by cblte-trcevt-event-id to one or more output destinations provided that the event level specified in level is greater or equal to that configured for the component.

Example:

copy "cbltypes.cpy".
copy "mfctf.cpy".

78 78-EVENT-TYPE-A      value 1.
78 78-EVENT-TYPE-B      value 2.

01 component-id         pic x(7) value "mycomp ".
01 flags                pic x(4) comp-5.
01 trace-event          cblt-trc-event.
01 trace-event-lengths  pic x(4) comp-5 occurs 1.
01 trace-event-pointers pointer occurs 1.
01 trace-event-types    pic x(4) comp-5 occurs 1.
01 trace-info           pic x(10).
01 tracer-handle        pic x(4) comp-5.

...
move low-values to trace-event

set cblte-trcevt-event-len of trace-event to
    address of trace-event-lengths(1)
set cblte-trcevt-event-type of trace-event to
    address of trace-event-types(1)
set cblte-trcevt-event-data of trace-event
    to address of trace-event-pointers(1)

*> 1) Acquire a tracer handle to trace "mycomp" component events,
*>    then output two informational events; one with event data,
*>    one without.

call "CBL_CTF_TRACER_GET" using by value 0
                                by reference component-id
                                by reference tracer-handle
...
move 0 to flags
move 78-CTF-FLAG-LEVEL-INFO to cblte-trcevt-level of trace-event
move 78-EVENT-TYPE-A to cblte-trcevt-event-id of trace-event
move 1 to cblte-trcevt-data-count of trace-event
move length of trace-info to trace-event-lengths(1)
move 78-TRACE-EVENT-TYPE-TEXT to trace-event-types(1)
set trace-event-pointers(1) to address of trace-info

call "CBL_CTF_TRACE" using by value flags
                           by reference tracer-handle
                           by reference trace-event
...
move 78-EVENT-TYPE-B to cblte-trcevt-event-id of trace-event
move 0 to cblte-trcevt-data-count of trace-event

call "CBL_CTF_TRACE" using by value flags
                           by reference tracer-handle
                           by reference trace-event
...

*> 2) Output two informational events for the "mycomp" component
*>    without acquiring a tracer handle

...
move 78-CTF-FLAG-COMPID-STRING to flags
move 78-CTF-FLAG-LEVEL-INFO to cblte-trcevt-level of trace-event
move 78-EVENT-TYPE-A to cblte-trcevt-event-id of trace-event
move 1 to cblte-trcevt-data-count of trace-event
move length of trace-info to trace-event-lengths(1)
move 78-TRACE-EVENT-TYPE-TEXT to trace-event-types(1)
set trace-event-pointers(1) to address of trace-info

call "CBL_CTF_TRACE" using by value flags
                           by reference component-id
                           by reference trace-event
...
move 78-EVENT-TYPE-B to cblte-trcevt-event-id of trace-event
move 0 to cblte-trcevt-data-count of trace-event

call "CBL_CTF_TRACE" using by value flags
                           by reference component-id
                           by reference trace-event
...
Parent topic: Consolidated Tracing Facility Routines
Parent topic: Alphabetical List of Library Routines


CBL_CTF_TRACER_GET

Returns a tracer handle that can be passed to other tracing routines to identify a component.

Syntax:

call "CBL_CTF_TRACER_GET" using by value     flags
                                by reference component-name
                                by reference tracer-handle
                                   returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
component-name | pic x(n) | pic x(n)
tracer-handle | cblt-x4-comp5 | pic x(4) comp-5
status-code | See Library Routines - Key |

On Entry:

flags
Control flags:
Bits 0-29
Reserved for future use. Must be 0.
Bit 30
Value | Meaning
0 | component-name is space-terminated.
1 | component-name is null-terminated. This is ignored if bit 31 is unset.
Bit 31
Reserved for future use. Must be 0.
component-name
Space- or null-terminated (depending on the setting of bit 30) case-insensitive component identifier string.

On Exit:

tracer-handle
Tracer handle to be specified to the other tracing routines.
status-code
One of:
  • 78-CTF-RET-INVALID-COMPONENT-NAME
  • 78-CTF-RET-NOT-ENOUGH-MEMORY
  • 78-CTF-RET-SUCCESS

Comments:

Components should call this routine to acquire a tracer handle before performing any tracing operations. The handle acquired by a call to this routine can be used in calls to routines such as CBL_CTF_COMP_PROPERTY_GET, CBL_CTF_COMP_PROPERTY_SET, CBL_CTF_LEVEL, CBL_CTF_DEST, CBL_CTF_TRACER_LEVEL_GET and CBL_CTF_TRACER_NOTIFY.

Note: It is possible to trace events without first acquiring a tracer handle by specifying a component identifier string instead of a tracer handle. However, specifying a component identifier has an impact on performance because the component identifier is validated each time it is used, so we recommend that you use a tracer handle returned from a call to this routine instead.

Example:

To acquire a tracer handle to trace "mycomp" component events:

copy "cbltypes.cpy".
copy "mfctf.cpy".

01 component-name  pic x(7) value “mycomp”.
01 tracer-handle   pic x(4) comp-5.
...
call "CBL_CTF_TRACER_GET" using by value 0
                                by reference component-name
                                by reference tracer-handle
...
Parent topic: Consolidated Tracing Facility Routines
Parent topic: Alphabetical List of Library Routines


CBL_CTF_TRACER_LEVEL_GET

Returns a tracer's current threshold trace level.

Syntax:

call "CBL_CTF_TRACER_LEVEL_GET" using by value     flags
                                      by reference component-id
                                      by reference trace-level
                                         returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
component-id | pic x(n) | pic x(n)
trace-level | cblt-x4-comp5 | pic x(4) comp-5
status-code | See Library Routines - Key |

On Entry:

flags
Control flags:
Bits 0-29
Reserved for future use. Must be 0.
Bit 30
Value | Meaning
0 | component-id is space-terminated.
1 | component-id is null-terminated. This is ignored if bit 31 is unset.
Bit 31
Value | Meaning
0 | component-id is a pic x(4) comp-5 tracer handle returned from a call to CBL_CTF_TRACER_GET.
1 | component-id is a pic x(n) text string. The termination character for the string is defined by bit 30.
component-id
Component identifier. This is either a pic x(4) comp-5 tracer handle (from CBL_CTF_TRACER_GET) if bit 31 of flags is not set, or a pic x(n) text identifier if bit 31 of flags is set.
The default trace level is returned if a NULL or empty string is specified.

On Exit:

trace-level
Value indicating the tracer's threshold trace level:
Value | Level
0 | Debug
1 | Info
2 | Warn
3 | Error
4 | Fatal
0xFFFFFFFF | Not enabled for tracing
status-code
One of:
  • 78-CTF-RET-INVALID-COMPONENT-NAME
  • 78-CTF-RET-INVALID-TRACE-HANDLE
  • 78-CTF-RET-NOT-ENOUGH-MEMORY
  • 78-CTF-RET-SUCCESS

Comments:

You typically call this routine before performing any costly trace data formatting that CBL_CTF_TRACE might involve.

If you have used CBL_CTF_TRACER_NOTIFY to install a callback function to process any changes made to the tracer's configuration, you only need to call CBL_CTF_TRACER_LEVEL_GET during trace initialization and in the callback function when the threshold trace level changes.

When a component needs to check for the current threshold trace level it can check the variable into which CBL_CTF_TRACER_LEVEL_GET has previously returned the threshold value.

Example:

To acquire a tracer handle to trace "mycomp" component events, and then use CBL_CTF_TRACER_LEVEL_GET to determine whether the component is configured to trace information level events before performing the trace operation:

copy "cbltypes.cpy".
copy "mfctf.cpy".

78 78-EVENT-TYPE-A      value 1.

01 component-name       pic x(7) value "mycomp".
01 flags                pic x(4) comp-5.
01 trace-event          cblt-trc-event.
01 trace-level          pic x(4) comp-5.
01 tracer-handle        pic x(4) comp-5.
...
call "CBL_CTF_TRACER_GET" using by value 0
                                by reference component-name
                                by reference tracer-handle
...
call "CBL_CTF_TRACER_LEVEL_GET" using by value 0
                                      by reference component-name
                                      by reference trace-level

if 78-CTF-FLAG-LEVEL-INFO >= trace-level
      set up trace-info
      compute flags = 78-CTF-FLAG-LEVEL-INFO

      call “CBL_CTF_TRACE” using by value flags
                                 by reference tracer-handle
                                 by reference trace-event
end-if
...
Parent topic: Consolidated Tracing Facility Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
Tracing Examples
CBL_CTF_TRACER_NOTIFY
Consolidated Tracing Facility Routines
Consolidated Tracing Facility Return Codes


CBL_CTF_TRACER_NOTIFY

Installs or uninstalls a tracer configuration callback function.

Syntax:

call "CBL_CTF_TRACE_NOTIFY" using by value     install-function
                                  by reference notif-install
                                     returning status-code

Parameters

install-function
Call prototype (see Key):cblt-x4-comp5
Picture: pic x(4) comp-5.
notif-install
Group predefined as cblt-trc-notif-install containing:
01 cblt-trc-notif-install    typedef.
  03 cblte-tni-version       cblt-x4-comp5. *> pic x(4) comp-5.
  03 cblte-tni-handle        cblt-x4-comp5. *> pic x(4) comp-5.
  03 cblte-tni-callback      cblt-ppointer. *> procedure pointer
status-code
See Library Routines - Key.

On Entry:

install-function
The operation to be performed:
0 | Install a callback
1 | Uninstall a callback
cblte-tni-version
Parameter block version number. Must be 0.
cblte-tni-handle
Handle of component tracer (returned from a call to CBL_CTF_TRACER_GET) for which a callback is to be installed or uninstalled.
cblte-tni-callback
Callback function to install (if install-function is 0) or uninstall (if install-function is 1).

On Exit:

status-code
One of:
  • 78-CTF-RET-FAILURE
  • 78-CTF-RET-INVALID-TRACE-HANDLE
  • 78-CTF-RET-NOT-ENOUGH-MEMORY
  • 78-CTF-RET-SUCCESS

Comments:

A tracer configuration callback function is installed by a component to allow it to be notified when any configuration change to the associated tracer occurs, such as a threshold level change, or property value change.

The interface to the callback function is as follows:

entry "callback-func" using by value     tracer-handle
                            by value     notification-type
                            by reference notification-param

where tracer-handle and notification-type are pic x(4) comp-5 items, and notification-param is a pic x(n). All parameters are input only. The callback function should set return-code to 0 on completion.

Notification Type 0
A property value change has occurred. notification-param is the address of a cblt-trc-notif-prop-change item with the following structure:
Field | Picture | Call Prototype
cblte-tnpc-version | pic x(4) comp-5 | cblt-x4-comp5
cblte-tnpc-flags | pic x(4) comp-5 | cblt-x4-comp5
cblte-tnpc-namelen | pic x(4) comp-5 | cblt-x4-comp5
cblte-tnpc-vallen | pic x(4) comp-5 | cblt-x4-comp5
cblte-tnpc-valint | pic x(4) comp-5 | cblt-x4-comp5
cblte-tnpc-name | pointer | cblt-pointer
cblte-tnpc-value | pointer | cblt-pointer

Version types (cblte-tnpc-version): 0 = structure version

Control flags (cblte-tnpc-flags):
Bit 0
Value | Meaning
0 | Value is a character string.
1 | Value is a pic x(4) comp-5 integer.
Bits 1-31
Reserved for future use.
Notification Type 1
A trace level change has occurred. notification-param is the address of a pic x(4) comp-5 item indicating the new trace level.

Example:

To acquire a tracer handle to trace "mycomp" component events and install a callback to handle threshold level and property change notifications:

copy "cbltypes.cpy".
copy "mfctf.cpy".

01 component-id       pic x(7) value "mycomp".
01 install-params     cblt-trc-notif-install.

linkage section.
01 lk-tracer-handle            pic x(4) comp-5.
01 lk-notif-type               pic x(4) comp-5.
01 lk-notif-param              pic x.
01 lk-notif-param-level        redefines lk-notif-param
                               pic x(4) comp-5.
01 lk-notif-param-property     redefines lk-notif-param
                               cblt-trc-notif-prop-change
....
*>
*> Acquire tracer handle
*>
call "CBL_CTF_TRACER_GET" using by value 0
                                by reference component-id
                                by reference tracer-handle

...

*>
*> Install callback function
*>
move low-values to install-params
move tracer-handle to cblte-tni-handle of install-params
set cblte-tni-callback of install-params to entry "my-callback"

call "CBL_CTF_TRACER_NOTIFY" using by value 0
                                   by reference install-params
...
goback.
*>
*> The callback function to handle trace level and property
*> changes
*>
entry "my-callback" using by value lk-tracer-handle
                          by value lk-notif-type
                          by value lk-notif-param.
evaluate lk-notif-type
    when 78-TRC-NOTIF-TYPE-LEVEL-CHANGE
        ....

    when 78-TRC-NOTIF-TYPE-PROP-CHANGE
        ....
end-evaluate

move 0 to return-code
goback.
Parent topic: Consolidated Tracing Facility Routines
Parent topic: Alphabetical List of Library Routines
Related information
CBL_CTF_TRACER_GET
Consolidated Tracing Facility Routines
Consolidated Tracing Facility Return Codes


Consolidated Tracing Facility Return Codes

Calls to the Consolidated Tracing Facility library routines return one of the following return codes. These return codes are provided in the mftypes.cpy copybook for COBOL programs, and mftypes.h include file for C programs.

Value | Name (COBOL) | Name (C) | Description
-1 | 78-CTF-RET-FAILURE | CTF_RET_FAILURE | Unspecified failure
0 | 78-CTF-RET-SUCCESS | CTF_RET_SUCCESS | Success
1 | 78-CTF-RET-INVALID-TRACE-HANDLE | CTF_RET_INVALID_TRACE_HANDLE | Invalid trace handle specified
2 | 78-CTF-RET-INVALID-TRACE-LEVEL | CTF_RET_INVALID_TRACE_LEVEL | Invalid trace level specified
3 | 78-CTF-RET-NOT-TRACE-ENABLED | CTF_RET_NOT_TRACE_ENABLED | Component not enabled for tracing
4 | 78-CTF-RET-NOT-TRACING-LEVEL | CTF_RET_NOT_TRACING_LEVEL | Specified event level less than threshold level configured for the component
5 | 78-CTF-RET-NOT-ENOUGH-MEMORY | CTF_RET_NOT_ENOUGH_MEMORY | Memory allocation error
6 | 78-CTF-RET-OUTPUT-ERROR | CTF_RET_OUTPUT_ERROR | Error outputting to one or more output destinations
7 | 78-CTF-RET-PROPERTY-NOT-FOUND | CTF_RET_PROPERTY_NOT_FOUND | Property not found
8 | 78-CTF-RET-BUFFER-TOO-SMALL | CTF_RET_BUFFER_TOO_SMALL | Buffer length too small
9 | 78-CTF-RET-VALUE-NOT-INTEGER | CTF_RET_VALUE_NOT_INTEGER | Value is not an integer
10 | 78-CTF-RET-EMITTER-NOT-FOUND | CTF_RET_EMITTER_NOT_FOUND | Emitter not found
11 | 78-CTF-RET-INVALID-EVENT-HANDLE | CTF_RET_INVALID_EVENT_HANDLE | Invalid event handle specified
12 | 78-CTF-RET-ZERO-LENGTH-DATA | CTF_RET_ZERO_LENGTH_DATA | Zero length data specified
13 | 78-CTF-RET-INVALID-PROP-NAME | CTF_RET_INVALID_PROP_NAME | Invalid property name specified
14 | 78-CTF-RET-INVALID-COMP-NAME | CTF_RET_INVALID_COMP_NAME | Invalid component name specified
15 | 78-CTF-RET-INVALID-EMITTER-NAME | CTF_RET_INVALID_EMITTER_NAME | Invalid emitter name specified
16 | 78-CTF-RET-INVALID-PROGRAM-NAME | CTF_RET_INVALID_PROGRAM_NAME | Invalid program name specified
17 | 78-CTF-RET-CALLBACK-NOT-FOUND | CTF_RET_CALLBACK_NOT_FOUND | Callback doesn’t exist
18 | 78-CTF-RET-CALLBACK-EXISTS | CTF_RET_CALLBACK_EXISTS | Callback already exists
19 | 78-CTF-RET-INVALID-FUNCTION-CODE | CTF_RET_INVALID_FUNCTION_CODE | Invalid function code specified
20 | 78-CTF-RET-INVALID-SLOT-ID | CTF_RET_INVALID_SLOT_ID | Invalid slot identifier specified
Parent topic: Consolidated Tracing Facility Routines


Container-Managed Services Routines

  • CBL_SRV_SERVICE_FLAGS_GET
    Enables a program running within a COBOL container as part of a service to determine the service's execution characteristics.
  • CBL_SRV_SERVICE_FLAGS_SET
    Enables a program running within a COBOL container as part of a service to set one or more the service's execution characteristics.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_SRV_SERVICE_FLAGS_GET

Enables a program running within a COBOL container as part of a service to determine the service's execution characteristics.

Syntax:

call CBL_SRV_SERVICE_FLAGS_GET using by reference service-flags
                                        returning status-code

Parameters

service-flags
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
status-code
See Library Routines - Key.

On Entry:

None

On Exit:

service-flags
Service control flags:
Bit 0
Value | Meaning
0 | None
1 | Commit transactional resources during successful service termination
Bit 1
Value | Meaning
0 | None
1 | Rollback transactional resources during successful service termination.
Bits 0 and 1 are treated as a bit pair and only relate to container-managed services. If neither bit is set, at service termination the run-time system will commit transactional resources if the service completes successfully, otherwise it will rollback transactional resources. The API will never return with both bits 0 and 1 set.
Bits 2-30
Reserved for future use
Bit 31
Value | Meaning
0 | The service has not dirtied the COBOL container.
1 | The service has dirtied the COBOL container and will result in the SEP being terminated following service termination.
status-code
0 | Success
1015 | Not running within the COBOL container

Example

copy "cblproto.cpy".

...

78 78-SERVICE-FLAG-COMMIT            value h"00000001".
78 78-SERVICE-FLAG-ROLLBACK          value h"00000002".
78 78-SERVICE-FLAG-DIRTY-CONTAINER   value h"80000000".

01 service-flags   pic x(4) comp-5.

...

call "CBL_SRV_SERVICE_FLAGS_GET" using
                                 by reference service-flags

if return-code = 0
    display "Running as a service" upon console

    if service-flags b-and
       78-SERVICE-FLAG-COMMIT not = 0
        display "Service will commit"
    end-if

    if service-flags b-and
       78-SERVICE-FLAG-ROLLBACK not = 0
        display "Service will rollback"
    end-if

    if service-flags b-and
       78-SERVICE-FLAG-DIRTY-CONTAINER not = 0
        display "Service will dirty the container"
    end-if
else
    display "Not running as a service" upon console
end-if

...
Parent topic: Container-Managed Services Routines
Parent topic: Alphabetical List of Library Routines


CBL_SRV_SERVICE_FLAGS_SET

Enables a program running within a COBOL container as part of a service to set one or more the service's execution characteristics.

Syntax:

call CBL_SRV_SERVICE_FLAGS_SET using by value service-flags-mask
                                     by value service-flags
                                    returning status-code

Parameters

service-flags-mask
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
service-flags
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
status-code
See Library Routines - Key.

On Entry:

service-flags-mask
Mask that specifies the bit flags to be changed:
Bit 0
Value | Meaning
0 | None
1 | Commit transactional resources during successful service termination
Bit 1
Value | Meaning
0 | None
1 | Rollback transactional resources during successful service termination.
service-flags
Service control flags:
Bit 0
Value | Meaning
0 | None
1 | Commit transactional resources during successful service termination
Bit 1
Value | Meaning
0 | None
1 | Rollback transactional resources during successful service termination.

Bits 0 and 1 are treated as a bit pair and only relate to container-managed services. If neither bit is set, at service termination the run-time system will commit transactional resources if the service completes successfully, otherwise it will rollback transactional resources.

Attempting to set both bits 0 and 1 will be treated as an error; attempting to set either bit 0 or bit 1 by an application-managed service will also be treated as an error.

Bits 2-30
Reserved for future use
Bit 31
Value | Meaning
0 | The service has not dirtied the COBOL container.
1 | The service has dirtied the COBOL container and will result in the SEP being terminated following service termination.

On Exit:

status-code
0 | Success
1009 | Invalid parameter passed to the API
1015 | Not running within the COBOL container
1016 | Can only set commit/rollback flags when container managed

Example

copy "cblproto.cpy".

...

78 78-SERVICE-FLAG-COMMIT            value h"00000001".
78 78-SERVICE-FLAG-ROLLBACK          value h"00000002".
78 78-SERVICE-FLAG-DIRTY-CONTAINER   value h"80000000".

01 service-flags        pic x(4) comp-5.
01 service-flags-mask   pic x(4) comp-5.

...

*>
*> Clear the "rollback" flag.
*> Set the "commit" and "dirty container" flags
*>

compute service-flags-mask = 78-SERVICE-FLAG-COMMIT b-or
                             78-SERVICE-FLAG-ROLLBACK b-or
                             78-SERVICE-FLAG-DIRTY-CONTAINER
compute service-flags = 78-SERVICE-FLAG-COMMIT b-or
                        78-SERVICE-FLAG-DIRTY-CONTAINER

call "CBL_SRV_SERVICE_FLAGS_SET" using
                                 by value service-flags-mask
                                 by value service-flags

...
Parent topic: Container-Managed Services Routines
Parent topic: Alphabetical List of Library Routines


Debugging Routines

  • CBL_DEBUGBREAK
    Enables a COBOL program to invoke the debugger.
  • CBL_DEBUG_START
    Enables a COBOL program to initiate advanced remote debugging or cross-session debugging.
  • CBL_DEBUG_STOP
    Enables a COBOL program to stop or suspend animation.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_DEBUGBREAK

Enables a COBOL program to invoke the debugger.

Syntax:

call "CBL_DEBUGBREAK"

Parameters:

None.

Comments:

You can use this call to invoke the debugger. If the program is not being debugged when it calls CBL_DEBUGBREAK, it starts the debugger and then comes to a halt, as if you had been debugging it already and then pressed the Stop button on the toolbar.

If the program was already being debugged when it called CBL_DEBUGBREAK, then debugging comes to a halt in that debugger, as if you had pressed the Stop button.

The routine returns a value in RETURN-CODE of 0 if the call was successful, or non-zero if it tried to invoke a debugger but failed.

Parent topic: Debugging Routines
Parent topic: Alphabetical List of Library Routines


CBL_DEBUG_START

Enables a COBOL program to initiate advanced remote debugging or cross-session debugging.
Note: This routine is supported for native COBOL only.

Syntax:

CALL "CBL_DEBUG_START" using  by value      flags
                                            timeout
                              by reference  identifier
                              returning     status-code

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-os-flags | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
timeout | cblt-os-ssize | pic s9(9) comp-5 or pic s9(18) comp-5 (64-bit native programs only)
identifier |  | pic x(n)
status-code | See Library Routines - Key |

On Entry:

flags
Controls how animation starts. You can set the following bits:
Bit Meaning
0 Action if no cross-session or remote Animator process waiting and the specified timeout has elapsed.
0
Start local debugging.
1
Return an error status.
1 When debugging should start.
0
Start debugging immediately.
1
Start debugging when the next debuggable entry point is entered; this is the first statement in the next animatable COBOL program called, or the first statement in the next piece of animatable COBOL code called using an ENTRY statement.
timeout
Timeout, in milliseconds, to wait for a cross-session or remote Animator process to start. A timeout of 0 means do not wait; a timeout of -1 means wait indefinitely.
identifier
A unique string that identifies which waiting Animator process to attach to. The string must be space- or null-terminated.

Comments:

Use this call to initiate remote animation or cross-session animation. If the program is not being debugged when it calls CBL_DEBUG_START, the identifier string is used to work out which Animator process to attach to.

If you want to use advanced remote debugging, set the identifier string to the same value as the unique string provided to your COBOL development system command line that initiates remote debugging.

If you want to use cross session debugging, set the identifier string to the same value as the COBANIMSRV environment variable in the other Animator session.

If you leave the identifier string blank, then standard cross-session animation rules are used as follows:

  • If the COBANIMSRV environment variable is set its value is used as the identifier string.
  • If it is not set, the program attaches to any Animator process started in the same directory.

If there is a corresponding Animator process waiting then the program comes to halt and starts being debugged. The program halts immediately if bit 1 of flags is set. If it is not set, execution halts when the next debuggable entry point is reached.

If there is no corresponding Animator process waiting then the program suspends for the number of milliseconds specified in timeout or until an Animator process starts. A timeout of 0 means the call returns immediately, without suspending. A timeout of -1 causes the program to suspend, without timeout, until the Animator process starts.

If there is still no corresponding Animator process to attach to at the end of the timeout period, then the action depends on the setting of bit 0 of flags. If it is set, then the call returns an error status and execution continues. If it is unset, then a local Animator process is started.

If the program was already being debugged when it called CBL_DEBUG_START, then debugging comes to a halt in Animator, as if you had pressed the interrupt key.

The routine returns value 0 if the call was successful, or non-zero if it tried to invoke Animator but failed.

Parent topic: Debugging Routines
Parent topic: Alphabetical List of Library Routines


CBL_DEBUG_STOP

Enables a COBOL program to stop or suspend animation.
Note: This routine is supported for native COBOL only.

Syntax:

CALL "CBL_DEBUG_STOP" using  by value    flags
                               returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-os-flags | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
status-code | See Library Routines - Key |

On Entry:

flags
Controls how animation stops. You can set the following bits:
Bit | Meaning
0 | Animator detaches.
1 | Animator terminates.

Comments:

If the program is being debugged when it calls CBL_DEBUG_STOP, then animation stops. The effect on Animator and the program that called CBL_DEBUG_STOP depends on the settings of bits 0 and 1 of flags:

Bit 0 | Bit 1 | Meaning
0 | 0 | Execution of the calling program continues without animation until a subsequent event, such as a breakpoint, STOP RUN or CBL_DEBUG_START, is encountered. This is equivalent to pressing Z (for Zoom) in Animator.
0 | 1 | Animator and the calling program both exit. This is equivalent to exiting Animator using the Quit option.
1 | 0 | Animator detaches from the program and waits for a subsequent CBL_DEBUG_START with the same identifier string. Execution of the calling program continues without animation.
1 | 1 | Animator detaches from the program and exits. Execution of the calling program continues without animation. This is equivalent to exiting Animator using the Detach option.

If the program is not being debugged when it calls CBL_DEBUG_STOP, then execution continues as if the routine had not been called.

Parent topic: Debugging Routines
Parent topic: Alphabetical List of Library Routines


Display Attribute Routines

Restriction: These routines are not currently supported in the .NET environment.

These routines enable you to make use of generic attributes -- screen attributes which are portable across different environments and different types of terminals.

Screens displayed from a program using generic attributes are the same or as close as possible whether running on an IBM PC under Windows or a serial terminal under UNIX.

A generic attribute is a single byte which is an index into the generic attribute table. This table contains information about character attributes (for example, bold or underline), foreground color and background color for each of the indexes used. The two color items are in turn indexes into the colormap -- a table of red, green and blue (RGB) values specific to the screen hardware in use.

Colormaps can be read-only or read-write. Read-only colormaps do not allow dynamic changes of RGB values from one color to another; only the colors in the system supplied colormap can be used. Even for read-write colormaps, there is no guarantee that a requested color can be exactly produced by the hardware.

For routines which use a table parameter, you can either pass the first element in the table, or build up the table in dynamically allocated memory and pass its address.

The routines set RETURN-CODE as follows:

0 | Operation successful
1 | Named color not found in color database
2 | Colormap index out of range
3 | Attribute index out of range
4 | No exact match found
5 | Environment does not allow virtual colormap
6 | Could not allocate virtual colormap
7 | No virtual colormap in use

User Attribute Routines

The User attribute is initially off for each program. Once it is enabled, some of the various methods which you can use to display text upon the screen; for example, DISPLAY ... UPON CRT, screen I/O subprograms and the enhanced ACCEPT and DISPLAY syntax all use this attribute. The ANSI form of the DISPLAY and ACCEPT statements (using the UPON CONSOLE phrase) uses the User attribute only if one of the other DISPLAY or ACCEPT methods has been used previously.

The User attribute affects the results of enhanced DISPLAY and ACCEPT syntax operations only once Adis has been requested to set up the attribute. Such a request can be made by performing an enhanced ACCEPT or DISPLAY using an attribute. For example:

     display spaces upon crt with highlight

The User attribute, if turned on, is used when displaying text upon the screen and supersedes any Screen attribute set for the character positions being used in the display.

Use of the X"A7" routine can result in code that is not portable to other environments. You can provide generic color support by using the generic attribute routines.

When using WRITE to CON:, the output always goes directly to the default window.

If the User attribute is not enabled, the Screen attribute currently set for that character position is unaltered.

DISPLAY ... UPON CRT-UNDER forces highlighting if the User attribute is set on. DISPLAY SPACE UPON CRT clears the screen to the User attribute for each screen position.

  • CBL_SCR_ALLOCATE_COLOR
    Finds an entry in the colormap for each of one or more given RGB values.
  • CBL_SCR_ALLOCATE_VC_COLOR
    Sets one or more specified virtual colormap entries to the RGB values supplied.
  • CBL_SCR_CREATE_VC
    Creates a virtual colormap and copies the contents of the system colormap to it.
  • CBL_SCR_DESTROY_VC
    Destroys a virtual colormap, causing the run-time system to revert to using the system colormap.
  • CBL_SCR_GET_ATTR_INFO
    Returns information about the attribute system for the environment.
  • CBL_SCR_GET_ATTRIBUTES
    Gets the character attribute code, and foreground and background colormap indexes for one or more entries in the attribute table.
  • CBL_SCR_NAME_TO_RGB
    Converts a single named color into an RGB value.
  • CBL_SCR_QUERY_COLORMAP
    Returns the RGB value for one or more colormap entries.
  • CBL_SCR_RESTORE
    Restores an area of the character-mode screen previously saved with a call to the CBL_SCR_SAVE call-by-name routine.
  • CBL_SCR_RESTORE_ATTRIBUTES
    Restores the attribute table to the saved values that are associated with the specified buffer handle.
  • CBL_SCR_SAVE
    Saves away an area of the screen (text and attributes) for subsequent restoration.
  • CBL_SCR_SAVE_ATTRIBUTES
    Saves the current settings of the attribute table.
  • CBL_SCR_SET_ATTRIBUTES
    Defines the character attribute, and foreground and background colormap indexes associated with each of one or more COBOL attribute values (attribute table indexes).
  • X"A7" functions 6 and 7
    Reads and sets user attribute.
  • X"A7" function 16
    Turns the user attribute on or off.
  • X"A7" functions 20 and 21
    Reads and sets system attributes.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_SCR_ALLOCATE_COLOR

Finds an entry in the colormap for each of one or more given RGB values.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_ALLOCATE_COLOR" using     table-count
                                        RGB-values
                                        color-attribute
                                        non-exact-match
                              returning status-code

Parameters

table-count
Call prototype (see Key): cblt-x2-compx
Picture: pic x(2) comp-x.
RGB-values
Group predefined as cblt-generic-attr-rgb-values containing:
01 cblt-generic-attr-rgb-values  typedef.
  03 cblte-garv-red-value        cblt-x2-compx.	         *> pic x(2) comp-x.
  03 cblte-garv-green-value      cblt-x2-compx. 	        *> pic x(2) comp-x.
  03 cblte-garv-blue-value       cblt-x2-compx.          *> pic x(2) comp-x.
  03 cblte-garv-filler           cblt-x1-compx occurs 2. *> pic x(2).
color-attribute
Call prototype: cblt-x4-compx occurs ntimes
Picture: pic x4 occurs ntimes.
non-exact-match
Call prototype: cblt-x4-compx occurs ntimes
Picture: pic x occurs ntimes.
status-code
See Library Routines - Key.

On Entry:

table-count | The number of colors requested.
 | The table of color(s) to search for or add to the colormap.

On Exit:

color-attribute | The table of indexes to the colormap corresponding to the colors requested. This can be an existing colormap entry, or an unallocated read-write colormap entry set to the requested color.
non-exact-match | The table of flags indicating whether or not the corresponding occurrence of color-attribute represents an exact match. Zero if the match was exact, otherwise nonzero.
table-count | The number of colors successfully allocated. This is normally the number requested but is less if the call was not entirely successful.
RGB-values | The table of RGB values actually used during the search, truncated to suit the environment.
cblte-garv-filler | Unused.

Comments:

The RGB value can either be specified as a literal or be obtained using a call to the CBL_SCR_NAME_TO_RGB routine. The algorithm for determining the nearest match is environment-defined.

Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


CBL_SCR_ALLOCATE_VC_COLOR

Sets one or more specified virtual colormap entries to the RGB values supplied.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_ALLOCATE_VC_COLOR" using     table-count
                                           color-attribute
                                           RGB-values
                                 returning status-code

Parameters

table-count
Call prototype (see Key): cblt-x2-compx
Picture: pic x(2) comp-x.
color-attribute
Call prototype (see Key): cblt-x4-compx occurs ntimes
Picture: pic x4 occurs ntimes.
RGB-values
Group predefined as cblt-generic-attr-rgb-values containing:
01 cblt-generic-attr-rgb-values  typedef.
  03 cblte-garv-red-value        cblt-x2-compx.	         *> pic x(2) comp-x.
  03 cblte-garv-green-value      cblt-x2-compx. 	        *> pic x(2) comp-x.
  03 cblte-garv-blue-value       cblt-x2-compx.          *> pic x(2) comp-x.
  03 cblte-garv-filler           cblt-x1-compx occurs 2. *> pic x(2).
status-code
See Library Routines - Key.

On Entry:

table-count | The number of colors to allocate.
color-attribute | The table of indexes to the locations in the virtual colormap in which to store the specified RGB values.
RGB-values | The table of color(s) to add to the virtual colormap.

On Exit:

table-count | The number of colors successfully allocated. This is normally the number requested but is less if the call was not entirely successful.
RGB-values | The table of RGB values actually used during the search, truncated to suit the environment.
cblte-garv-filler | Unused.

Comments:

The RGB values can either be specified as a literal or be obtained using a call to the CBL_SCR_NAME_TO_RGB routine.

Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


CBL_SCR_CREATE_VC

Creates a virtual colormap and copies the contents of the system colormap to it.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_CREATE_VC" returning status-code

Parameters:

status-code See Library Routines - Key

On Entry:

None

On Exit:

None

Comments:

The run-time system can only have one virtual colormap, and it is used in preference to the system colormap as long as it exists.

Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


CBL_SCR_DESTROY_VC

Destroys a virtual colormap, causing the run-time system to revert to using the system colormap.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_DESTROY_VC" returning status-code

Parameters:

status-code See Library Routines - Key

On Entry:

None

On Exit:

None

Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


CBL_SCR_GET_ATTR_INFO

Returns information about the attribute system for the environment.
Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_GET_ATTR_INFO" using      attribute-info
                             returning status-code

Parameters

RGB-values
Group predefined as cblt-generic-attr-rgb-values containing:
01 cblt-generic-attr-information   typedef.
  03 cblte-gai-display-class       cblt-x1-compx.	 *> pic x comp-x.
  03 cblte-gai-colormap-size       cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-gai-colormap-flags      cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-gai-bits-per-gun        cblt-x1-compx. 	*> pic x comp-x.
status-code
See Library Routines - Key.

On Entry:

None

On Exit:

cblte-gai-display-class
The class of the environment:
1 | Monochrome
2 | Read-only colormap
3 | Read/write colormap
4 | Read-only decomposed colormap
5 | Read/write decomposed colormap
cblte-gai-colormap-size
Number of entries on the colormap.
cblte-gai-colormap-flags
Bits set as follows:
Bit 0
1 | The colormap is read-write.
0 | The colormap is read-only.
Bit 1
1 | Environment allows virtual colormaps to be created.
0 | Environment does not allow virtual colormaps to be created.
Bit 2
1 | Reading back attributes read back the values written
0 | Read back what is currently on the screen
cblte-gai-bits-per-gun
Number of significant bits of the RGB values that are actually used to drive the hardware. A value of zero indicates that the number of bits is unknown for the environment. If different guns have different numbers of significant bits the lowest number of bits is used.
Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines
Related information
Display Attribute Routines


CBL_SCR_GET_ATTRIBUTES

Gets the character attribute code, and foreground and background colormap indexes for one or more entries in the attribute table.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_GET_ATTRIBUTES" using     table-count
                                        attribute-index
                                        attribute-value
                              returning status-code

Parameters

table-count
Call prototype (see Key): cblt-x2-compx
Picture: pic x(2) comp-x.
attribute-index
Call prototype (see Key): cblt-x1-compx occurs n times.
Picture: pic x comp-x occurs n times.
attribute-value
Group predefined as cblt-generic-attr-value containing:
01 cblt-generic-attr-value           typedef.
  03 cblte-gav-foreground-color-attr cblt-x4-compx. 	        *> pic x(4) comp-x.
  03 cblte-gav-background-color-attr cblt-x4-compx. 	        *> pic x(4) comp-x.
  03 cblte-gav-character-attribute   cblt-x1-compx. 	        *> pic x  comp-x.
  03 cblte-gav-filler                cblt-x1-compx occurs 3. *> pic x(3).
status-code
See Library Routines - Key.

On Entry:

table-count | The number of attribute table entries to query.
attribute-index | The table of indexes of the entries to query.

On Exit:

table-count | The number of entries successfully queried. This is normally the number requested but is less if the call was not entirely successful.
attribute-value | The table of attribute values corresponding to the indexes supplied.
cblte-gav-filler | Unused.
Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


CBL_SCR_NAME_TO_RGB

Converts a single named color into an RGB value.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_NAME_TO_RGB" using     color-name
                                     RGB-values
                           returning status-code

Parameters

color-name
Call prototype (see Key): cblt-x2-compx
Picture: pic x(2) comp-x.
RGB-values
Group predefined as cblt-generic-attr-rgb-values containing:
01 cblt-generic-attr-rgb-values  typedef.
  03 cblte-garv-red-value        cblt-x2-compx.	         *> pic x(2) comp-x.
  03 cblte-garv-green-value      cblt-x2-compx. 	        *> pic x(2) comp-x.
  03 cblte-garv-blue-value       cblt-x2-compx.          *> pic x(2) comp-x.
  03 cblte-garv-filler           cblt-x1-compx occurs 2. *> pic x(2).
status-code
See Library Routines - Key.

On Entry:

color-name-len | The number of characters in the name.
color-name-buf | The color name to be converted.

On Exit:

RGB-values | The RGB value to which the named color is converted.
filler | Unused.
Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


CBL_SCR_QUERY_COLORMAP

Returns the RGB value for one or more colormap entries.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_QUERY_COLORMAP" using     table-count
                                        color-attribute
                                        RGB-values
                              returning status-code

Parameters

table-count
Call prototype (see Key): cblt-x2-compx
Picture: pic x(2) comp-x.
color-attribute
Call prototype (see Key): cblt-x4-compx occurs n times
Picture: pic x(4) comp-x occurs n times.
RGB-values
Group predefined as cblt-generic-attr-rgb-values containing:
01 cblt-generic-attr-rgb-values  typedef.
  03 cblte-garv-red-value        cblt-x2-compx.	         *> pic x(2) comp-x.
  03 cblte-garv-green-value      cblt-x2-compx. 	        *> pic x(2) comp-x.
  03 cblte-garv-blue-value       cblt-x2-compx.          *> pic x(2) comp-x.
  03 cblte-garv-filler           cblt-x1-compx occurs 2. *> pic x(2).
status-code
See Library Routines - Key.

On Entry:

table-count | The number of entries to query.
color-attribute | The table of one or more colormap indexes to query.

On Exit:

RGB-values | The table of RGB values corresponding to the table indexes.
table-count | The number of entries successfully queried. This is normally the number requested but is less if the call was not entirely successful.
Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


CBL_SCR_RESTORE

Restores an area of the character-mode screen previously saved with a call to the CBL_SCR_SAVE call-by-name routine.

Note: This routine is supported for native COBOL only.

Syntax:

call NoReturnCode "CBL_SCR_RESTORE" using by value     flags
                                                       handle

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5. | pic x(4) comp-5.
handle | cblt-pointer. | usage pointer.

On Entry:

flags | Currently, this must always be zero.
handle | A "save-handle" previously returned by a call to the CBL_SCR_SAVE call-by-name routine. This handle can be NULL, in which case the call does nothing.

On Exit:

handle Is untouched, but invalid. It must not be passed again to CBL_SCR_RESTORE unless it has subsequently been re-assigned a valid "save-handle" by a further call to the CBL_SCR_SAVE routine. We recommend that you set this pointer to NULL immediately on return from CBL_SCR_RESTORE. The area of the screen saved when the call to CBL_SCR_SAVE which returned handle was made is written, in the same position, to the screen.

Comments:

Because the flags parameter is passed BY VALUE, it may be specified as a numeric literal. For example, "BY VALUE 0 SIZE 4".

This call returns no status value. Therefore, it must be called using a suitable call-convention (as suggested in the syntax description) that you have defined in the special-names section. A suitable convention for this purpose is 4.

CBL_SCR_RESTORE has advantages over writing areas of the screen directly:

  • There is no need to have wasteful buffer space allocated in the working-storage section of your program.
  • Using any single-byte attribute method to write the screen (for example CBL_READ_SCR_ATTRS) requires indirection through the Generic Attributes system and thus a best-match guess has to be made for attributes not in the current palette. On certain systems (for example, UNIX, where the default palette is monochrome yet color displays through ADIS are possible) the result of writing the attributes back to the screen can yield very inaccurate results. This call attempts to minimize this effect by actually saving an internal representation of the screen contents and therefore removing the possibility of information loss.
  • This call is very fast.

It is valid to change the mode of the screen (for example, switch the screen to 132-column mode) after saving an area of the screen with CBL_SCR_SAVE providing that the mode is restored to the previous setting before calling CBL_SCR_RESTORE. Failure to do so will result in undefined results.

Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


CBL_SCR_RESTORE_ATTRIBUTES

Restores the attribute table to the saved values that are associated with the specified buffer handle.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_RESTORE_ATTRIBUTES" using     handle
                                  returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
handle | cblt-pointer | usage pointer.
status-code | See Library Routines - Key

On Entry:

handle The handle returned on the associated call to CBL_SCR_SAVE_ATTRIBUTES.

On Exit:

None

Comments:

This routine restores the COBOL attribute table to the saved values that are associated with handle. Resources that have been used to save the table are freed.

If the handle is null, the call is ignored. If the handle is invalid or is a handle to a table that has already been restored, results are undefined.

On return, handle is set to null in order to prevent multiple restores of the same attribute table settings.

Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


CBL_SCR_SAVE

Saves away an area of the screen (text and attributes) for subsequent restoration.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_SAVE" using by value       flags
                                         top-line
                                         bottom-line
                               returning handle.

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5. | pic x(4) comp-5.
top-line | cblt-x4-comp5. | pic x(4) comp-5.
bottom-line | cblt-x4-comp5. | pic x(4) comp-5.
handle | cblt-pointer. | usage pointer.

On Entry:

flags | Currently, this must always be zero.
top-line | The line nearest the top of the screen of the area to be saved. Line 1 is the top line.
bottom-line | The line nearest the bottom of the screen of the area to be saved. Line 1 is the top line.

The area between the top-line and bottom-line inclusive is saved. Therefore, if top-line and bottom-line are equivalent, a single line of the screen is saved.

Note that specifying zero as a top-line or bottom-line means that parameter will be considered to be the last line on the screen. This saves you from having to know the size of the screen if, for instance, you wished to save the whole screen.

The logical value of top-line must be equal or less than the logical value of bottom-line.

On Exit:

handle Contains either a "save handle", which can be subsequently passed to the CBL_SCR_RESTORE call-by-name routine, or the value NULL, meaning that the save operation could not be performed (because of bad parameters, or possibly lack of memory).

Comments:

Because the three parameters are passed BY VALUE, any or all of them may be specified with numeric literals. For example, "BY VALUE 12 SIZE 4".

CBL_SCR_SAVE has advantages over reading areas of the screen directly:

  • There is no need to have wasteful buffer space allocated in the working-storage section of your program.
  • Using any single-byte attribute method to write the screen (for example CBL_READ_SCR_ATTRS) requires indirection through the Generic Attributes system and thus a best-match guess has to be made for attributes not in the current palette.
  • This call is very fast.

If handle is not subsequently passed to the CBL_SCR_RESTORE routine, any core memory that may have been allocated to save the screen information in will be lost. Repeated failure to call CBL_SCR_RESTORE with handles returned will therefore result in a memory leak.

It is invalid to pass handle to any routine other than CBL_SCR_RESTORE.

Examples:

To save the screen in its entirety, whatever its size:

call "CBL_SCR_SAVE" using by value 0 size 4
                                   1 size 4
                                   0 size 4
                         returning handle.

To save just the last line of the screen:

call "CBL_SCR_SAVE" using by value 0 size 4
                                   0 size 4
                                   0 size 4
                         returning handle.

To save the top three lines of the screen:

call "CBL_SCR_SAVE" using by value 0 size 4
                                   1 size 4
                                   3 size 4
                         returning handle.
Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


CBL_SCR_SAVE_ATTRIBUTES

Saves the current settings of the attribute table.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_SAVE_ATTRIBUTES" using     handle
                               returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
handle | cblt-pointer | usage pointer.
status-code | See Library Routines - Key

On Entry:

None

On Exit:

handle The handle of the internal buffer used to save the attributes.

Comments:

This routine saves the current COBOL attribute table in an internal buffer. The handle is set to a value that identifies this buffer, and no meaning should be attached to the value of handle.

Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


CBL_SCR_SET_ATTRIBUTES

Defines the character attribute, and foreground and background colormap indexes associated with each of one or more COBOL attribute values (attribute table indexes).

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_SET_ATTRIBUTES" using      table-count
                                         attribute-index
                                         attribute-value
                               returning status-code

Parameters

table-count
Call prototype (see Key): cblt-x2-compx
Picture: pic x(2) comp-x.
attribute-index
Call prototype (see Key): cblt-x1-compx occurs n times.
Picture: pic x comp-x occurs n times.
attribute-value
Group predefined as cblt-generic-attr-value containing:
01 cblt-generic-attr-value           typedef.
  03 cblte-gav-foreground-color-attr cblt-x4-compx.         	*> pic x(4) comp-x.
  03 cblte-gav-background-color-attr cblt-x4-compx.         	*> pic x(4) comp-x.
  03 cblte-gav-character-attribute   cblt-x1-compx.         	*> pic x  comp-x.
  03 cblte-gav-filler                cblt-x1-compx occurs 3.	*> pic x(3).
status-code
See Library Routines - Key.

On Entry:

table-count | The number of attributes to set.
attribute-index | The table of indexes in the attribute table.
attribute-value | The table of attribute descriptions corresponding to the table of indexes.

On Exit:

table-count | The number of attributes successfully set. This is normally the number requested but is less if the call was not entirely successful.
cblte-gav-filler | Unused.
Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


X"A7" functions 6 and 7

Reads and sets user attribute.

Note: This routine is supported for native COBOL only.

Syntax:

call x"A7" using     function-code
                     user-attribute
           returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
function-code | cblt-x1-compx | pic x comp-x.
user-attribute | cblt-x1-compx | pic x comp-x.
status-code | See Library Routines - Key

On Entry:

function-code
Defines the action:
6 | Read user attribute
7 | Set user attribute
user-attribute
For function 7, the value to set the user attribute.

On Exit:

user-attribute
For function 6, the value of the current user attribute.

Comments:

You should use the same caution when using this routine as when using any other, using only regular COBOL syntax wherever possible.

Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


X"A7" function 16

Turns the user attribute on or off.

Note: This routine is supported for native COBOL only.

Syntax:

call x"A7" using function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
function-code | cblt-x1-compx | pic x comp-x.
parameter | cblt-x1-compx | pic x comp-x.

On Entry:

function-code
Value 16.
parameter
Indicates the action wanted:
0 | Turns the user attribute on
1 | Turns the user attribute off

On Exit:

None

Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


X"A7" functions 20 and 21

Reads and sets system attributes.

Note: This routine is supported for native COBOL only.

Syntax:

call X"A7" using     function-code
                     sys-attr-array
           returning status-code

Parameters:

function-code
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
sys-attr-array
Group containing:
01 sys-attr-array
  03 sys-attr   cblt-x1-compx occurs 16   *> pic x comp-x occurs 16 times.
status-code
See Library Routines - Key

On Entry:

function-code
Defines the action:
20 | Read system attributes
21 | Set system attributes
sys-attr-array
Contains the system attributes to set. The attributes are used for:
sys-attr-1 | Invisible
sys-attr-2 | Reverse video
sys-attr-3 | Normal
sys-attr-4 | Highlighted
sys-attr-5 | Normal underlined
sys-attr-6 | Highlighted underlined
sys-attr-7 | System normal
sys-attr-8 | Flashing highlighted
sys-attr-9 | Unused
sys-attr-10 | User reverse
sys-attr-11 | User normal
sys-attr-12 | User highlighted
sys-attr-13 | Unused
sys-attr-14 | Unused
sys-attr-15 | Unused
sys-attr-16 | Operating system normal

On Exit:

sys-attr-array
Contains the system attributes read.

Comments:

System attributes are used by some parts of the system to display screens in various colors or shades (depending on the type of screen). This means that by changing the system attributes, you can colorize displays to a particular choice. These calls can be used if you use components such as Panels which require attribute values as part of their parameters.

If you want to alter any of the attributes you should first read the current setting of the attributes, update the attribute array with any changes you want to make and then set the attributes. Doing things this way ensures that you do not affect the settings of any of the attributes which you are not interested in.

Parent topic: Display Attribute Routines
Parent topic: Alphabetical List of Library Routines


Enhanced ACCEPT and DISPLAY Syntax Routines

Restriction: These routines are supported for native COBOL only.

These routines affect the behavior of the enhanced ACCEPT and DISPLAY statements in a program. Enhanced ACCEPT and DISPLAY statements are handled by a run-time system module called Adis.

  • X"AF" function 1
    Sets various configurable features of Adis, including enabling or disabling individual user function, Adis or data keys, or a series of consecutive keys at run-time.
  • X"A7" function 18
    Makes console I/O redirectable.
  • X"AF" function 22
    Sounds the terminal alarm.
  • X"AF" function 26
    Gets a character from the keyboard.
  • X"AF" Function 81
    Enables SCREEN SECTION ACCEPT and DISPLAY statements to inherit Keisen attributes written by preceding CBL_ calls.
Parent topic: Library Routines


X"AF" function 1

Sets various configurable features of Adis, including enabling or disabling individual user function, Adis or data keys, or a series of consecutive keys at run-time.

Note: This routine is supported for native COBOL only.

Syntax:

call x"AF" using function-code
                 parameter-block

Parameters:

function-code
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
parameter-block
Group containing:
01 parameter-block
  03 key-setting    cblt-x1-compx   *> pic x comp-x.
  03 sub-fn-code    cblt-x1-compx   *> pic x comp-x.
  03 first-key-id   cblt-x1-compx   *> pic x comp-x.
  03 number-of-keys cblt-x1-compx   *> pic x comp-x.

On Entry:

function-code
Value 1.
sub-fn-code
One of:
1 | Enable/disable user function keys and compatibility keys
2 | Enable/disable Adis control keys and other configurables
3 | Enable/disable data keys
4 | Enable/disable shift keys
5 | Enable/disable lock keys

On Exit:

parameter
Bit settings indicating the type of screen as follows:

Comments:

Features are enabled or disabled until explicitly changed by another call to x"AF" or until the application terminates. The initial state of user function keys depends on the run-time operating system (see the chapter Adis for details). Calls to enable or disable functions keys are additive. For example, if you call x"AF" to enable function key F1 and then make another call to enable F10, both keys are enabled.

The chapter Adis describes the features and parameter in detail.

Parent topic: Enhanced ACCEPT and DISPLAY Syntax Routines
Parent topic: Alphabetical List of Library Routines


X"A7" function 18

Makes console I/O redirectable.

Note: This routine is supported for native COBOL only.

Syntax:

call X"A7" using function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
function-code | cblt-x1-compx | pic x comp-x.
parameter | cblt-x1-compx | pic x comp-x.

On Entry:

function-code
Value 18
parameter
Action to perform:
0 | Disable DOS-style console I/O
1 | Enable DOS-style console I/O

On Exit:

None

Comments:

Normally the run-time system uses the BIOS to read the keyboard, and writes direct to the video map for all displays. This routine makes the run-time system use operating system functions instead. This means the operator can use the operating system facilities for re-directing keyboard input and screen output.

Parent topic: Enhanced ACCEPT and DISPLAY Syntax Routines
Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


X"AF" function 22

Sounds the terminal alarm.

Note: This routine is supported for native COBOL only.

Syntax:

call x"AF" using function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
function-code | cblt-x1-compx | pic x comp-x.
parameter | pic x | pic x

On Entry:

function-code | Value 22.
parameter | Reserved

On Exit:

None

Parent topic: Enhanced ACCEPT and DISPLAY Syntax Routines
Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


X"AF" function 26

Gets a character from the keyboard.

Note: This routine is supported for native COBOL only.

Syntax:

call x"AF" using function-code
                 key-status

Parameters:

function-code
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
key-status
Group containing:
01 key-status
  03 key-type    pic x.         *> pic x.
  03 key-code-1  cblt-x1-compx  *> pic x comp-x.
  03 key-code-2  cblt-x1-compx  *> pic x comp-x.

On Entry:

function-code
Value 26.

On Exit:

key-type
The type of key read, as follows:
1 | User-defined function key
2 | Adis function key
3 | Data key
9 | Error
key-code-1
When key-type is 1 or 2, contains the number of the key; 0-127 for user-defined and 0-39 for Adis. See the chapter Adis Configuration Utility (AdisCF) in your Programmer's Guide to Creating User Interfaces for more details on function keys.

When key-type is 3, contains the ASCII code of the key pressed.

When key-type is 9, contains an error code:
8 | A disabled character has been keyed, and key-code-2 contains the character.
9 | An invalid keystroke (more than one byte) has occurred.

Comments:

This routine also causes the COBOL screen handling system to be invoked.

Parent topic: Enhanced ACCEPT and DISPLAY Syntax Routines
Parent topic: Alphabetical List of Library Routines


X"AF" Function 81

Enables SCREEN SECTION ACCEPT and DISPLAY statements to inherit Keisen attributes written by preceding CBL_ calls.

Note: This routine is supported for native COBOL only.

This function enables SCREEN SECTION ACCEPT and DISPLAY statements to inherit Keisen attributes written by preceding CBL_ calls.

Syntax:

call x"AF" using function-code
                 parameter

Parameters:

function-code
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
parameter
Call prototype: cblt-x1-compx
Picture: pic x comp-x.

On Entry:

function-code
Value 81
parameter
Action to perform:
0 | Prevent Keisen attributes being inherited
1 | Enable Keisen attributes to be inherited

On Exit:

None

Comments:

To use this function you must add the following code to your program.

In the Working Storage section:

78 Inherit-Keisen value 81.
01 adis-function  pic 99 comp-x.
01 adis-flag-on   pic 99 comp-x value 1.
01 adis-flag-off  pic 99 comp-x value 0.

In the Procedure division:

MOVE Inherit-Keisen TO adis-function
CALL X"AF" USING adis-function adis-flag-on
Parent topic: Enhanced ACCEPT and DISPLAY Syntax Routines
Parent topic: Alphabetical List of Library Routines


Exit and Error Procedure Routines

The exit and error procedure routines enable you to register your own routines which are executed by the run-time system when your application terminates, either normally or abnormally.

  • CBL_ERROR_PROC
    Installs or removes an error procedure to be invoked automatically when a run-time system error occurs.
  • CBL_EXIT_PROC
    Installs or removes a closedown procedure to be invoked automatically when the application terminates.
  • CBL_GET_EXIT_INFO
    Enables an application to determine under what circumstances an exit procedure has been invoked.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_ERROR_PROC

Installs or removes an error procedure to be invoked automatically when a run-time system error occurs.

Syntax:

call "CBL_ERROR_PROC" using     install-flag
                                install-addrs
                      returning status-code

Parameters:

install-flag
Call prototype (see Key): cblt-x1-compx
Picture: pic x comp-x.
install-addrs
Call prototype (see Key): cblt-ppointer
Picture: usage procedure-pointer.
status-code
See Library Routines - Key

On Entry:

install-flag
The operation to be performed:
0: Install error procedure
1: De-install error procedure
install-addrs
Address of error procedure to install or de-install.

On Exit:

None

Comments:

In the .NET environment, error procedures are only executed for an RTS exception that has not been handled by the application.

You can install several error procedures for an application by repeated calls of this routine.

Once an error procedure has been posted, subsequent attempts to install that error procedure are silently ignored until it is removed either implicitly (for example, during error processing) or explicitly (by calling CBL_ERROR_PROC with install-flag set to "1").

An error procedure can be written in any language. If it is in COBOL, install-addrs must be the address of an entry point. You can obtain this address using the statement:

  set install-addrs to entry entry-name

An error procedure in COBOL can include any legal COBOL, including CALL statements.

When an error occurs the installed procedures are executed, starting with the most recently installed and ending with the first one installed. When all have been processed, the RTS error handling procedure is then started.

If you don't want any other error procedures, including the run-time system error handling, to be executed after terminating your error procedure, set RETURN-CODE to zero.

If a program containing an error procedure is canceled, the error procedure is removed.

An error procedure installed in one program can be removed by another program.

An error procedure can install an error procedure.

If an error procedure is installed during error processing (either by itself, or by another error procedure) then it is executed when the error procedure that installed it returns, assuming that it doesn't return with a ZERO return code.

If an RTS error occurs in an error procedure, the procedure is terminated. The RTS then processes the new RTS error, starting with the next error procedure, if there is one.

You must ensure that the procedure-pointer you use to install the procedure is valid.

An error procedure belongs to the run-unit from which it was installed. So the error procedure is executed only by the run-unit that installed it.

Pressing interrupt does not cause any error procedures to be called.

If the error procedure is defined as an entry point in a program that itself could give an error, you must ensure that the program has a Local-Storage Section. This ensures that the program is reentrant and the run-time system will not give error 166 ("Recursive COBOL call is illegal") when trying to execute the error procedure.

Parameter Passed to the Error Procedure

When an installed error procedure is called, the characters containing the relevant RTS error message is passed as a parameter.

You should define this parameter in the Linkage Section as PIC X(325), and include it in the USING phrase of the entry to the error procedure. An example of the RTS error message string follows:
Load Error : file 'prog-name'\n
error code: 173, pc=0, call=-1, seg=0\n
173  Called program file not found in drive/directory\n\0
where \n is a new-line character and \0 is a null (x"00") terminator. This format is described in your Error Messages.
Example
The following is an example of installing an error procedure, and the skeleton of the error procedure that is called if an error occurs.
 working-storage section.
 01 install-flag     pic x comp-x value 0.
 01 install-address  usage procedure-pointer.
 01 status-code      pic 9(4) comp value zeros.

 local-storage section.

 linkage section.
 01 err-msg  pic x(325).

 procedure division.
     set install-address to entry "err-proc".
     call "CBL_ERROR_PROC" using  install-flag
                                  install-address
                                  returning status-code.

 ...
 ...

* Error procedure:
 entry "err-proc" using err-msg.

* Process err-msg to find out the error number.
* Act accordingly.
 ...

* Terminate, but allow other error procedures to be executed.
     move 1 to return-code
     exit program
     stop run.
Parent topic: Exit and Error Procedure Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
Exit and Error Procedure Routines


CBL_EXIT_PROC

Installs or removes a closedown procedure to be invoked automatically when the application terminates.

Syntax:

call "CBL_EXIT_PROC" using     install-flag
                               install-params
                     returning status-code

Parameters

install-flag
Call prototype (see Key): cblt-x1-compx
Picture: pic x comp-x.
install-params
Group predefined as cblt-exit-params containing:
01 cblt-exit-params            typedef.
  03 cblte-ep-install-addr     cblt-ppointer.	*> usage procedure-pointer.
  03 cblte-ep-install-priority cblt-x1-compx.	*> pic x comp-x
status-code
See Library Routines - Key.

On Entry:

install-flag
The operation to be performed:
0 | Install closedown procedure with default priority of 64
1 | De-install closedown procedure
2 | Query priority of installed closedown procedure
3 | Install closedown procedure with given priority
cblte-ep-install-addrs
Address of closedown procedure to install, de-install or query.
cblte-ep-install-priority
When install-flag is 3, contains the priority of the closedown procedure being installed, in range 0 to 127. Otherwise, ignored.

On Exit:

cblte-ep-install-priority
When install-flag is set to 2, returns the priority of the selected procedure.

Comments:

The installed closedown procedure is executed whether the application finishes normally (with a STOP RUN) or abnormally (for example, with a keyboard interrupt or RTS error). You can install several closedown procedures for an application by repeated calls of this routine.

A closedown procedure can be written in any language. If it is in COBOL, cblte-ep-install-addrs must be the address of an entry point. You can obtain this address using the statement:

  set install-addrs to entry "entry-name"

A closedown procedure in COBOL can include any legal COBOL, including call statements. The closedown procedure terminates when the main program in the procedure executes an EXIT PROGRAM or GOBACK or when a STOP RUN statement is executed.

A closedown procedure does not have any parameters passed to it when it is called.

Every closedown procedure installed has a priority. This priority determines the order in which the procedures are executed - procedures with the lowest values are processed first. If several procedures have the same priority, they are executed in reverse order of installation - that is the last one installed is executed first.

Procedures installed without a priority (install-flag = 0) are given the default priority of 64. To set your own priority, set install-flag = 3 and set the priority to a value in the range 0 to 127. Priorities 128 to 256 are reserved for use by the COBOL system. You must not set a priority higher than 127 unless your program is a user-written file handler, in which case it must be 200.

If a closedown procedure has already been installed, an attempt to install again fails. However, if the priority used on the second attempt is different to that used when it was installed, its priority is changed. RETURN-CODE is set to zero.

Use install-flag = 2 to find the priority of a previously installed procedure. This returns the priority in cblte-ep-install-priority if it is found The procedure is identified by its cblte-ep-install-addrs. If the procedure cannot be found, RETURN-CODE is set nonzero.

Parent topic: Exit and Error Procedure Routines
Parent topic: Alphabetical List of Library Routines


CBL_GET_EXIT_INFO

Enables an application to determine under what circumstances an exit procedure has been invoked.

Syntax:

call "CBL_GET_EXIT_INFO" using     param-block
                         returning status-code

Parameters

param-block
Group predefined as cblt-exit-info-params containing
01 cblt-exit-info-params    typedef.
  03 cblte-gei-size         cblt-x4-comp5. 	*> pic x(4) comp-5 value 16.
  03 cblte-gei-return-code  cblt-x4-comp5. 	*> pic x(4) comp-5.
  03 cblte-gei-rts-error    cblt-x4-comp5. 	*> pic x(4) comp-5.
  03 cblte-gei-exit-flags   cblt-x4-comp5. 	*> pic x(4) comp-5.
status-code
See Library Routines - Key.

On Entry:

cblte-gei-size
The size of parameter block including this field (must be set to 16).

On Exit:

cblte-gei-return-code
Current value of RETURN-CODE.
cblte-gei-rts-error
Error number of the run-time system error that caused termination (zero if none).
cblte-gei-exit-flags
A 32-bit word providing additional termination information:
Bit 0
0 | Not running under Debugger
1 | Running under Debugger
Bit 1
Escaped from Debugger
Bit 2
Terminated due to STOP RUN
Bit 3
0 | Terminated in COBOL
1 | Terminated in non-COBOL
Bit 4
Terminated due to the interrupt key being pressed (for example, CTRL+C), or some other similar mechanism for terminating a program
Bit 5
Exit procedure invoked during thread termination
Bits 6-31
Reserved for future use - set to 0
status-code
0 | Success.
1006 | API called from outside of exit procedure.
1009 | Invalid parameter passed to API.

Comments:

This routine must only be called from within an exit procedure that has been installed using CBL_EXIT_PROC.

A typical use of this routine would be in database applications which need to be able to determine under what circumstances an exit procedure has been invoked. Database applications would typically need to be able to determine whether the exit procedure had been invoked due to a normal or abnormal run-time system termination. This routine would enable them to decide whether to commit or rollback.

Parent topic: Exit and Error Procedure Routines
Parent topic: Alphabetical List of Library Routines


File and Filename Routines

The CBL_JOIN_FILENAME and CBL_SPLIT_FILENAME routines enable you to parse a filename into its component strings and to join strings together to form a filename. They can be used together to replace components of a filename, such as the extension. They can handle both null-terminated and space-terminated filenames.

A filename is split up into path, basename and extension. For example, in the filename d:\dir1\dir2\file.dat the path is "d:\dir1\dir2", the basename is "file", and the extension is "dat".

These two routines can work with filenames up to 65,535 characters long, but your environment or run-time system imposes a limit of 256 characters on the maximum length of basename.ext , and 261 characters on the maximum length of the entire filename.

  • CBL_CFGREAD_DYNFH
    The CBL_CFGREAD_DYNFH option determines whether the File Handler should reread its configuration file for configurable custom file handlers.
  • CBL_CFGREAD_EXTFH
    Forces the File Handler to reread its configuration file.
  • CBL_CHANGE_DIR
    Changes the current directory.
  • CBL_CHECK_FILE_EXIST
    Checks whether a file exists and if it does, returns details of when the file was last modified.
  • CBL_COPY_FILE
    Copies a file.
  • CBL_CREATE_DIR
    Creates a subdirectory.
  • CBL_DELETE_FILE
    Deletes a file.
  • CBL_DELETE_DIR
    Deletes a directory. The directory is deleted only if it is empty.
  • CBL_DIR_SCAN_END
    Terminates a search operation.
  • CBL_DIR_SCAN_READ
    Searches for the next entry in the file system using a search handle returned by a previous CBL_DIR_SCAN_START.
  • CBL_DIR_SCAN_START
    Initializes a search for a file or directory.
  • CBL_GET_CURRENT_DIR
    Returns the current directory.
  • CBL_FILENAME_CONVERT
    Converts a filename between space-terminated and null-terminated format.
  • CBL_FILENAME_MAX_LENGTH
    Returns the maximum size of a filename that the run-time system and the current operating system can handle. This size does not include any terminators (null or space).
  • CBL_JOIN_FILENAME
    Forms a filename by joining together its component parts; that is, the pathname, basename and extension.
  • CBL_LOCATE_FILE
    This routine has two uses. It can be used to expand an environment variable in a file specification, where the environment variable contains a list of several paths. It can also determine whether an OPEN INPUT statement using a particular file specification finds the file in a library file or as a separate disk file.
  • CBL_RENAME_FILE
    Changes the name of a file.
  • CBL_SPLIT_FILENAME
    Splits a filename into its component parts; that is, the pathname, basename and extension.
  • mFFH
    Initializes the File Handler.
  • MFFH_MODIFY_DISABLE
    Disables all File Handler trace modification set by previous MFFH_MODIFY_TRACE calls.
  • MFFH_MODIFY_TRACE
    Modifies some FCD fields, to save directly accessing the FCD. You can use this call whether you are issuing standard COBOL I/O statements or calling the File Handler explicitly using the API.
  • PC_FIND_DRIVES
    Returns all valid drives on a PC.
  • PC_READ_DRIVE
    Returns the current default drive letter.
  • PC_SET_DRIVE
    Sets the default drive letter.
  • X"91" function 46
    Enables insertion of a null character x"00" before data characters whose value is less than x"20" in line sequential files.
  • X"91" function 47
    Disables insertion of a null character x"00" before data characters whose value is less than x"20" in line sequential files.
  • X"91" function 48
    Enables insertion of tab characters in line sequential files.
  • X"91" function 49
    Disables insertion of tab characters in line sequential files.
  • Interpreting the return code as a file status code
  • Filename Routines - Example
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_CFGREAD_DYNFH

The CBL_CFGREAD_DYNFH option determines whether the File Handler should reread its configuration file for configurable custom file handlers.

By calling CBL_CFGREAD_DYNFH when the environment variable DYNREDIR is set to DYNCONFIG, the File Handler is forced to reread the configuration file.

Syntax:

call "CBL_CFGREAD_DYNFH"

On Exit:

The return code is set to a non-zero value if errors occurred.

Comments:

When the File Handler rereads the configuration file, it ignores any striping parameters in the file.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines
Related reference
Configuration File


CBL_CFGREAD_EXTFH

Forces the File Handler to reread its configuration file.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_CFGREAD_EXTFH" using     filename
                      returning status-code

Parameters:

filename | pic x(n).
status-code | See Library Routines - Key

On Entry:

filename The file to look for. The name can contain a path, and must be terminated by a space. If the filename is null (x"00"), the File Handler looks for the file using the standard search order (see the topic Searching Conventions Used for Calling Programs).

On Exit:

None.

Comments:

When the File Handler rereads the configuration file, it ignores any striping parameters in the file.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


CBL_CHANGE_DIR

Changes the current directory.

Syntax:

call "CBL_CHANGE_DIR" using     pathname
                      returning status-code

Parameters:

pathname | pic x(n).
status-code | See Library Routines - Key

On Entry:

pathname Relative or absolute pathname terminated by space or null (x"00"). This must be no longer than the number of characters allowed by your operating system and must be valid from the directory that is current when the routine is called.

On Exit:

None.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


CBL_CHECK_FILE_EXIST

Checks whether a file exists and if it does, returns details of when the file was last modified.

Syntax:

call "CBL_CHECK_FILE_EXIST"  using    filename
                                      file-details
                            returning status-code

Parameters

filename
Picture: pic x(n).
file-details
Group predefined as cblt-fileexist-buf containing
01 cblt-fileexist-buf        typedef.
  03 cblte-fe-filesize       cblt-x8-compx. *> pic x(8) comp-x.
  03 cblte-fe-date.
    05 cblte-fe-day          cblt-x1-compx. *> pic x comp-x.
    05 cblte-fe-month        cblt-x1-compx. *> pic x comp-x.
    05 cblte-fe-year         cblt-x2-compx. *> pic x(2) comp-x.
  03 cblte-fe-time.
    05 cblte-fe-hours        cblt-x1-compx. *> pic x comp-x.
    05 cblte-fe-minutes      cblt-x1-compx. *> pic x comp-x.
    05 cblte-fe-seconds      cblt-x1-compx. *> pic x comp-x.
    05 cblte-fe-hundredths   cblt-x1-compx. *> pic x comp-x.
status-code
See Library Routines - Key.

On Entry:

filename
The file to look for. The name can contain a path, and is terminated by a space. If no path is given, the current directory is assumed.

This routine does not work with filenames containing wildcard characters.

On Exit:

cblte-fe-filesize
The size of the file in bytes.
cblte-fe-filedate
The date the file was created.
cblte-fe-filetime
The time the file was created.

Comments:

CBL_CHECK_FILE_EXIST is not stripe-aware. If you use this routine on a file for which striping is enabled, the details returned refer to the first stripe only. Therefore, use this routine on an individual stripe only and refer to the stripe by the stripe name.

You can check the success of the call by examining RETURN-CODE.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines
Related information
Interpreting the return code as a file status code
File and Filename Routines


CBL_COPY_FILE

Copies a file.

Syntax:

call "CBL_COPY_FILE" using     filename1
                               filename2
                     returning status-code

Parameters:

filename1
pic x(n).
filename2
pic x(n).
status-code
See Library Routines - Key

On Entry:

filename1
The file to copy. The name can contain a path and is terminated by a space. If no path is given, the current directory is assumed.
filename2
The name of the new file. The name can contain a path and is terminated by a space. If no path is given, the current directory is assumed.

On Exit:

None.

Comments:

This routine does not work with filenames containing wildcard characters.

CBL_COPY_FILE is not stripe-aware. If you use this routine on a file for which striping is enabled, the details returned refer to the first stripe only. Therefore, use this routine on an individual stripe only and refer to the stripe by the stripe name.

You can check the success of the call by examining RETURN-CODE. See the topic Interpreting the Return Code as a File Status Code for more details.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
Interpreting the return code as a file status code
File and Filename Routines


CBL_CREATE_DIR

Creates a subdirectory.

Syntax:

All the directories in the given path, except the last, must already exist.

call "CBL_CREATE_DIR" using     pathname
                      returning status-code

Parameters:

pathname
pic x(n).
status-code
See Library Routines - Key

On Entry:

pathname
Relative or absolute pathname terminated by space or null (x"00").

On Exit:

None.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
File and Filename Routines


CBL_DELETE_FILE

Deletes a file.

Syntax:

call "CBL_DELETE_FILE" using     filename
                       returning status-code

Parameters:

filename | pic x(n).
status-code | See Library Routines - Key

On Entry:

filename The file to delete. The name can contain a pathname, and is terminated by a space. If no path is given, the current directory is assumed.

This routine does not work with filenames containing wildcard characters.

On Exit:

None.

Comments:

You cannot use wildcard characters in filenames.

CBL_DELETE_FILE is not stripe-aware. If you use this routine on a file for which striping is enabled, the details returned refer to the first stripe only. Therefore, use this routine on an individual stripe only and refer to the stripe by the stripe name. For more information on the use of striped files, please refer to the section File Striping in the chapter File Handler Configuration of your File Handling book..

You can check the success of the call by examining RETURN-CODE. See the topic Interpreting the Return Code as a File Status Code for more details.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


CBL_DELETE_DIR

Deletes a directory. The directory is deleted only if it is empty.

Syntax:

call "CBL_DELETE_DIR" using      pathname
                      returning status-code

Parameters:

pathname | pic x(n).
status-code | See Library Routines - Key

On Entry:

pathname Relative or absolute pathname terminated by space or null (x"00").

On Exit:

None.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


CBL_DIR_SCAN_END

Terminates a search operation.

Syntax:

CALL "CBL_DIR_SCAN_END" using  by reference   handle
                                  returning   search-status

Parameters:

handle
Usage pointer
search-status
See Library Routines - Key

On Entry:

handle
Set by CBL_DIR_SCAN_START. This field identifies the search operation that is to be terminated.

On Exit:

handle
Undefined
search-status
Return status:
0 | Success
1 | Unable to start search
2 | Invalid search handle
3 | Search finished
127 | Other error

Comments:

You must call CBL_DIR_SCAN_END to release system resources. You might be unable to start additional searches if you fail to release resources at the end of a scan operation.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
CBL_DIR_SCAN_START
CBL_DIR_SCAN_READ


CBL_DIR_SCAN_READ

Searches for the next entry in the file system using a search handle returned by a previous CBL_DIR_SCAN_START.

Syntax:

CALL "CBL_DIR_SCAN_READ" using  by reference   handle
                                               entry
                                   returning   search-status

Parameters:

handle
usage pointer.
entry
Group item containing the following subordinate items:
01 entry
   03 attribute        cblt-x4-comp5. *> pic x(4) comp-5
   03 date-stamp
      05 year          cblt-x4-comp5. *> pic x(4) comp-5
      05 month         cblt-x2-comp5. *> pic x(2) comp-5
      05 day           cblt-x2-comp5. *> pic x(2) comp-5
      05 hour          cblt-x2-comp5. *> pic x(2) comp-5
      05 minute        cblt-x2-comp5. *> pic x(2) comp-5
      05 second        cblt-x2-comp5. *> pic x(2) comp-5
      05 millisec      cblt-x2-comp5. *> pic x(2) comp-5
      05 dst           cblt-x1-comp5. *> pic x comp-5
      05 size          cblt-x8-comp5. *> pic x(8) comp-5
      05 name
         07 max-len    cblt-x2-comp5. *> pic x(2) comp-5
         07 entry-name pic x(max-len)
status-code
See Library Routines - Key.

On Entry:

handle
Set by CBL_DIR_SCAN_START. This field identifies the search operation. Search parameters cannot be changed for a given handle.
max-len
The length of the entry-name field.

On Exit:

attribute
Describes the properties of the entry found. Valid values are:
Value | Bit Set | Meaning
1 | 0 | File found
2 | 1 | Directory found
4 | 2 | The entry found is not a file or a directory
8 | 3 | The entry is readable
16 | 4 | The entry is writable
32 | 5 | The entry is hidden
If the entry found is a file, any of bits 3, 4 and 5 may be set, to indicate whether or not the file is readable and so on. These bits may be set if the entry found is not a file, but the meaning in this case is undefined.
Note that this is a return field. The flags in bits 0 to 2 reflect the entry's properties and may not be the same as the search attributes.
date-stamp
This group field holds the date and time that the entry was last written.
Attribute | Description
year | Current year minus 1900
month | Month, 0-11; January = 0
day | Day of month, 1-31
hour | Hour of day, 0-23
minute | Minute
second | Seconds
millisec | Milliseconds. On some systems millisec is set to zero
dst | Daylight saving time flag: 0 means that daylight saving was not in operation; 1 means that daylight saving was in operation when the entry was last written; 255 means that the daylight savings setting is unknown.
size
The size of the file in bytes.
entry-name
The name of the entry found. For native Windows projects this is the filename only, for JVM and UNIX projects it is the filename with relative path.
search-status
Return status:
0 | Success
1 | Unable to start search
2 | Invalid search handle
3 | Search finished
127 | Other error

Comments:

Errors associated with an entry-name field that is too small for the result will be ignored. If you do not supply a large enough field, the result will be truncated to fit. If you supply a field that is shorter than max-len you will corrupt memory.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


CBL_DIR_SCAN_START

Initializes a search for a file or directory.

Syntax:

CALL "CBL_DIR_SCAN_START" using  by reference   handle
                                                pattern
                                 by value       search-attribute
                                                flags
                                 returning      search-status

Parameters:

handle
usage pointer.
pattern
A group item containing the following subordinate items:
01 pattern
  03 pattern-length   cblt-x2-comp5. *> pic x(2) comp-5
  03 pattern-content  pic x(n)
search-attribute
Call prototype: cblt-x4-comp5
Picture: pic x(4) comp-5
search-status
See Library Routines - Key

On Entry:

pattern-length
Length of pattern string in the pattern-content field. It is associated with the handle and cannot be changed during a scan. A length of zero indicates a null-terminated pattern-content field. You can set pattern-length to less than the length of the pattern-content field, but not to more.
pattern-content
String for name searches. It is associated with the handle and cannot be changed during a scan. Can contain a full or partial directory path with or without a filename or just a filename. Elements in a path must be separated by "\". Null-terminated strings are recognised if the null is before the end of the string as provided in pattern-length, or if pattern-length is set to zero. If you set bit 1 of flags, the filename can contain wildcard characters: "*" means any arbitrary sequence of characters and "?" means any single character. If you set bit 0 flags the pling character "!" is available for use as an escape character. For more information about using wildcards and escape characters see the section Comments below.
search-attribute
Can be used to specify file properties to be searched for. It is associated with the handle and cannot be changed during a scan. Valid values are:
Value | Bit Set | Meaning
1 | 0 | Search for a file.
2 | 1 | Search for a directory.
4 | 2 | Search for any entry that is neither a file or a directory.
Bits above those specified are ignored. Bits 0 to 2 are always combined by OR, for example, to search for either a file or a directory set bits 0 and 1 (value 3). To search for all types of entry set bits 0, 1 and 2 (value 7).
flags
You can set one of the following values:
Value | Bit Set | Meaning
1 | 0 | Turns on processing of escape sequences in pattern-content. The default is no processing of escape sequences.
2 | 1 | Turns on the use of wildcards in the pattern-content field. Wildcards have significance as such only if this option is set.
Bits above those specified are ignored. To turn on both processing of escape characters and the use of wildcards set both bits 0 and 1 (value 3).

On Exit:

handle
Reference for this search. Once you have specified search parameters and obtained a handle, you cannot change the parameters.
search-status
Return status:
0 | Success
1 | Unable to start search
2 | Invalid search handle
3 | Search finished
127 | Other error

Comments:

You can use wildcards only in the filename part of the pattern to search against, for example:

main/rts/mf*.h

You cannot use them in the directory name or instead of a drive letter.

You can use escape sequences in patterns, to force the inclusion of any of the following characters:

"\", "/", "!", "*", "?".

To use an escape sequence, enter the escape sequence character, pling ("!"), followed by the character you wish to escape. For example:

"abc?" requests any files in the current folder beginning with "abc" and having only one more character in the name.

"abc!?" requests a file in the current folder with the name "abc?".

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


CBL_GET_CURRENT_DIR

Returns the current directory.

Syntax:

call "CBL_GET_CURRENT_DIR" using by value flags
                           by value       name-length
                           by reference   directory-name
                           returning      status-code

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-os-flags | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
name-length | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
directory-name | pic x(n). | pic x(n).
status-code | See Library Routines - Key.

On Entry:

flags
Reserved. Must be set to zero.
name-length
The size, in bytes, of the directory-name parameter. This parameter must be at least as big as the longest directory name that can be returned.

On Exit:

directory-name
Contains the current working directory in space-terminated format. If the directory name contains embedded spaces then it will be returned delimited by a pair of double quotes. This parameter must be large enough to also hold these quotes.
status-code
A return code:
0 | Success. directory-name contains the current working directory.
128 | The size of directory-name specified by name-length is not large enough to hold the name of the current working directory.
129 | The flags parameter is not set to zero.

Comments:

This routine ensures that name-length is at least as long as the current directory name that is to be returned. If it is not, the routine returns with status-code set to 128. If the flags parameter is not set to zero the routine returns with status-code set to 129.

The name-length parameter is not checked by this routine. It is the responsibility of the calling program to specify a valid name-length and directory-name combination (that is, to ensure that directory-name is at least name-length bytes long). Use the BY VALUE LENGTH OF directory-name SIZE 4" construct to pass the name-length parameter.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


CBL_FILENAME_CONVERT

Converts a filename between space-terminated and null-terminated format.

Syntax:

call 'CBL_FILENAME_CONVERT' using  fnc-func
                                   filename-in
                                   filename-out
                         by value  fnc-in-length
                         by value  fnc-out-length
                         returning fnc-ret

Parameters

fnc-func
Using call prototype (see Key): cblt-x1-compx
Picture: pic x comp-x.
filename-in
Using call prototype (see Key): pic x(n).
Picture: pic x(n).
filename-out
Using call prototype (see Key): pic x(n).
Picture: pic x(n).
fnc-in-length
Using call prototype (see Key): cblt-os-size
Picture: pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
fnc-out-length
Using call prototype (see Key): cblt-os-size
Picture: pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
fnc-ret
Using call prototype (see Key): cblt-rtncode

On Entry:

fnc-func
Defines how the conversion will proceed:
Bit 0
0 | Convert from space-terminated to null-terminated format.
1 | Convert from null-terminated to space-terminated format.
Bit 1
0 | If bit 0 is set to 0, the length of filename-in is determined using the space-termination character at the end of the filename.
1 | If bit 0 is set to 0, fnc-in-length exactly determines the length of filename-in. All characters are treated as part of the filename.
Bit 2
0 | Do not fold filename to upper case.
1 | Fold filename to upper case.
Bit 3
0 | Behavior determined by bits 0 to 2.
1 | Bits 0 to 2 are ignored, and the length of filename-in is determined by scanning the filename as a space-terminated filename. You can also specify a list of other termination characters; see below.
Bits 4-7
Reserved. Must be set to zero.
filename-in
Input filename.
filename-out
If bit 3 of fnc-func is set to 1, a list of characters that if encountered unquoted terminate the filename. If there are no additional characters, then a null pointer should be passed.
filename-in-length
Length of filename-in.
filename-out-length
If bit 3 of fnc-func is set to 0, the size of the buffer for the converted filename.

If bit 3 of fnc-func is set to 1, the number of characters in filename-out (if supplied).

On Exit:

filename-out
If bit 3 of fnc-func is set to 0, the converted filename. If filename-in is invalid, this parameter is set to an empty filename (a null if bit 0 was set to 0, else a space).
fnc-ret
If 0, an error occurred, otherwise, the length of the space terminated name that was either input or output.

Comments:

A space-terminated filename consists of a filename terminated by a space character. If the filename contains any embedded spaces then they should be escaped by including the whole filename between a pair of double quotes.

A null-terminated filename has any double quotes stripped out, but retains any embedded spaces.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


CBL_FILENAME_MAX_LENGTH

Returns the maximum size of a filename that the run-time system and the current operating system can handle. This size does not include any terminators (null or space).

Syntax:

call "CBL_FILENAME_MAX_LENGTH" returning max-length.

Parameters

 | Using call prototype (see Key) | Picture
max-length | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

None.

On Exit:

max-length Maximum size of filename that the run-time system and the current operating system can handle, not including a terminator (null or space).
Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


CBL_JOIN_FILENAME

Forms a filename by joining together its component parts; that is, the pathname, basename and extension.

Syntax:

call "CBL_JOIN_FILENAME" using     sj-param
                                   join-buffer
                                   path-buffer
                                   basename-buffer
                                   extension-buffer
                         returning status-code

Parameters

sj-param
Group predefined as cblt-splitjoin-buf containing:
01 cblt-splitjoin-buf                typedef.
  03 cblte-sj-param-length           cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-split-join-flag1       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-sj-split-join-flag2       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-sj-device-offset          cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-device-length          cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-basename-offset        cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-basename-length        cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-extension-offset       cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-extension-length       cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-total-length           cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-split-buf-len          cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-join-buf-len           cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-first-component-length cblt-x2-compx. 	*> pic x(2) comp-x.
join-buffer
Call prototype (see Key): pic x(n).
Picture: pic x(n).
path-buffer
Call prototype (see Key): pic x(n).
Picture: pic x(n).
basename-buffer
Call prototype (see Key): pic x(n).
Picture: pic x(n).
extension-buffer
Call prototype (see Key): pic x(n).
Picture: pic x(n).
status-code
See Library Routines - Key.

On Entry:

cblte-sj-param-length
Length of sj-param in bytes, including the two bytes for cblte-sj-param-length. The normal value for cblte-sj-param-length is 24.
cblte-sj-split-join-flag1
Can be set as follows:
Bit 1
1 | Strings are null-terminated
0 | Strings are space-terminated
Bit 0
1 | The new filename is folded to upper case
0 | The original case is preserved
cblte-sj-split-join-flag2
Can be set as follows:
Bit 2
1 | If bit 1 of cblte-sj-split-join-flag1 is set to 0, then this indicates that the length of each filename component is given exactly by cblte-sj-path-length, cblte-sj-basename-length and cblte-sj-extension-length. This flag can be used when there are known significant spaces in one of the filename components. If bit 1 of cblte-sj-split-join-flag1 is 1, then this is ignored,
0 | Length of filename components is determined by bit 1 of cblte-sj-split-join-flag1.
Bit 1
Reserved
Bit 0
Reserved
cblte-sj-device-offset
Offset of the start of the path in path-buffer, indexed from one.
cblte-sj-device length
Length of path if not space- or null-terminated.
cblte-sj-basename-offset
Offset of the start of the basename in basename-buffer, indexed from one.
cblte-sj-basename-length
Length of basename if not space- or null-terminated.
cblte-sj-extension-offset
Offset of the start of the extension in extension-buffer, indexed from one.
cblte-sj-extension-length
Length of extension if not space- or null-terminated.
path-buffer
Pathname.
basename-buffer
Basename.
extension-buffer
Extension.
cblte-sj-join-buf-len
Length of join-buffer.

On Exit:

cblte-sj-total-length
Total number of characters in the filename.
join-buffer
The joined-up filename.
status-code
Return status:
0 | Success
1 | Filename too big for join-buffer
4 | Illegal filename

Comments:

The new filename is formed by concatenating the following:

  • The first cblte-sj-device-length bytes (starting from cblte-sj-device-offset) of path-buffer
  • The first cblte-sj-basename-length bytes (starting from cblte-sj-basename-offset) of basename-buffer
  • The first cblte-sj-extension-length bytes (starting from cblte-sj-extension-offset) of extension-buffer

It is placed in join-buffer with length cblte-sj-total-length.

This routine can be made to fold to upper case by setting the least significant bit (bit 0) of cblte-sj-split-join-flag1. If this bit is not set, the case is preserved.

This routine can accept either null-terminated or space-terminated strings. Setting the second least significant bit (bit 1) of cblte-sj-split-join-flag1 results in the routine expecting null-terminated strings. If this bit is not set, space-terminated strings are expected.

The path, basename and extension fields can be shorter than the lengths specified by cblte-sj-path-length, cblte-sj-basename-length, and cblte-sj-extension-length respectively, if they are terminated with either a space or a null, depending on the setting bit 1 of cblte-sj-split-join-flag1.

path-buffer, basename-buffer, extension-buffer, and join-buffer do not have to be four distinct buffers. This means that this routine can be used with CBL_SPLIT_FILENAME to replace one component of a filename.

If path-buffer is not empty and does not have a trailing backslash (\) or slash (/) or colon (:) and basename-buffer is not empty, the routine inserts a backslash (\) between the path and basename in join-buffer.

If extension is ".", the string returned in join-buffer has an extension of spaces; that is, the filename has a trailing period (.).

If cblte-sj-total-length is less than cblte-sj-join-buf-len, the characters after the end of the filename are nulls or spaces depending on bit 1 of cblte-sj-split-join-flag1.

If path consists of a valid drive letter, but no colon (:), the routine adds one. It does not do this for a device (for example LPT1) that does not need one. You cannot join a device (as opposed to a drive letter) to a non-empty basename.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


CBL_LOCATE_FILE

This routine has two uses. It can be used to expand an environment variable in a file specification, where the environment variable contains a list of several paths. It can also determine whether an OPEN INPUT statement using a particular file specification finds the file in a library file or as a separate disk file.

Syntax:

call "CBL_LOCATE_FILE" using     user-file-spec
                                 user-mode
                                 actual-file-spec
                                 exist-flag
                                 path-flag
                       returning status-code

Parameters:

user-file-spec
Using call prototype (see Key): pic x(n)
Picture: pic x(n).
user-mode
Using call prototype (see Key): cblt-x1-compx
Picture: pic x comp-x.
actual-file-spec
Group item defined as
01 actual-file-spec
   03 buffer-len   cblt-x2-compx   pic x(2) comp-x.
   03 buffer       pic x(n).       pic x(n).
exist-flag
Using call prototype (see Key): cblt-x1-compx
Picture: pic x comp-x.
path-flag
Using call prototype (see Key): cblt-x1-compx
Picture: pic x comp-x.
status-code
See Library Routines - Key

On Entry:

user-file-spec
Contains the filename specification; this can include an embedded environment variable or library name.
user-mode
Specifies what to do with user-file-spec:
0 Check whether the file exists in a library or as a separate disk file.

.NET does not support embedded library names. If user-file-spec includes an embedded library-name, that library is opened (if it exists) and searched for the file. The library is left open afterward.

If user-file-spec includes an embedded environment variable, the file is searched for along each path specified in that variable.

If the file is found, actual-file-spec on exit contains the file specification with the environment variable expanded to the successful path. Otherwise, actual-file-spec on exit contains the file specification with the environment variable expanded to the first path it contained.

1 | If user-file-spec includes an environment variable, actual-file-spec on exit contains the file specification with the environment variable expanded to the first path it contained. The file is not searched for.
2 | If user-file-spec includes an environment variable, actual-file-spec on exit contains the file specification with the environment variable expanded to the next path it contained. The file is not searched for. This option should only be used after a successful call with user-mode = 1 or 2. See path-flag below.
path-flag
If user-mode = 2, this data item should contain the value that was returned in this item from the previous user-mode = 1 or 2 call.
buffer-len
Size of buffer.

On Exit:

buffer
Buffer to contain the resolved file specification, as described under user-mode. If the resolved file specification is larger than the size specified by buffer-len, the contents of buffer remain unchanged and status-code is set accordingly.
exist-flag
If user-mode = 0, this data item on exit shows whether the file specified in user-file-spec exists.
0 | File not found or not searched for
1 | File was found in a library that was already open
2 | File was found in a library specified in user-file-spec
3 | File was found as a separate disk file
If user-mode is not 0 this data item is always 0 on exit.
path-flag
Shows whether user-file-spec contained an embedded environment variable that has been expanded in actual-file-spec.
0 | actual-file-spec does not include an expanded environment variable
>0 | actual-file-spec contains an expanded environment variable
status-code
Return status:
0 | Success
1 | The environment variable does not exist
2 | There is no next path
3 | The resolved filename is too large for the buffer
4 | Resulting filename is illegal
255 | Other error

Comments:

CBL_LOCATE_FILE is not stripe-aware. If you use this routine on a striped file, the routine locates the first stripe only. Therefore, use this routine on an individual stripe only and refer to the stripe by the stripe name. For more information on the use of striped files, please refer to the section File Striping in the chapter File Handler Configuration of your File Handling book.

Example:

The user-file-spec can take the form:

Standard filename: | path \ filename.ext
Embedded environment variable: | $envname \ filename.ext
Embedded library name: | path \ lbr-name.lbr\filename.ext
Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


CBL_RENAME_FILE

Changes the name of a file.

Syntax:

call "CBL_RENAME_FILE" using     old-filename
                                 new-filename
                       returning status-code

Parameters:

old-filename
pic x(n).
new-filename
pic x(n).
status-code
See Library Routines - Key.

On Entry:

old-filename
The file to rename. The name can contain a pathname, and is terminated by a space. If no path is given, the current directory is assumed.

This routine does not work with filenames containing wildcard characters.

new-filename
The new name, terminated by a space. If old-filename contains a pathname, this must contain the same pathname. Some operating systems do not allow you to rename a file if a file of the name in new-filename already exists

On Exit:

None

Comments:

CBL_RENAME_FILE is not stripe-aware. If you use this routine on a striped file, the routine renames the first stripe only. Therefore, use this routine on an individual stripe only and refer to the stripe by the stripe name.

You can check the success of the call by examining RETURN-CODE. See the topic Interpreting the return code as a file status code for more details.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
Interpreting the return code as a file status code
File and Filename Routines


CBL_SPLIT_FILENAME

Splits a filename into its component parts; that is, the pathname, basename and extension.

Syntax:

call "CBL_SPLIT_FILENAME" using     sj-param
                                    split-buffer
                          returning status-code

Parameters

sj-param
Group defined as cblt-splitjoin-buf containing:
01 cblt-splitjoin-buf                typedef.
  03 cblte-sj-param-length           cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-split-join-flag1       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-sj-split-join-flag2       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-sj-device-offset          cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-device-length          cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-basename-offset        cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-basename-length        cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-extension-offset       cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-extension-length       cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-total-length           cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-split-buf-len          cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-join-buf-len           cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-sj-first-component-length cblt-x2-compx. 	*> pic x(2) comp-x.
split-buffer
Call prototype: pic x(n).
Picture: pic x(n).
status-code
See Library Routines - Key

On Entry:

param-length
Length of sj-param in bytes, including the two bytes for cblte-sj-param-length. The normal value for cblte-sj-param-length is 24.
splitjoin-flg1
Bit 1
1 | The strings are null-terminated
0 | The strings are space-terminated
Bit 0
1 | The new filename is folded to upper case
0 | The original case is preserved.
split-buf-len
Length of split-buffer
split-buffer
The string to split.

On Exit:

cblte-sj-splitjoin-flg2
Bit | Meaning
2 | Set if there is a significant space in the filename
1 | Set if there is a wildcard in the path
0 | Set if there is a wildcard in basename or extension
cblte-sj-path-strt
Start of pathname in split-buffer, from one.
cblte-sj-path-len
Length of pathname; zero if there is none. This includes any following colon (:).
cblte-sj-basename-strt
Start of basename in split-buffer, from one.
cblte-sj-basename-len
Length of basename; zero if there is none. This does not include the following period (.).
cblte-sj-extension-strt
Start of extension in split-buffer, from one.
cblte-sj-extension-len
Length of extension; zero if there is none. This does not include the preceding period (.).
cblte-sj-total-length
Total number of characters in the string.
cblte-sj-first-path-len
Number of characters up to and including the first backslash (\) or slash (/) or colon (:); if split-buffer contains none of these, this parameter = cblte-sj-path-len.
split-buffer
If bit 0 of cblte-sj-splitjoin-flg1 is set then this routine folds to upper case. If bit 1 of cblte-sj-splitjoin-flg1 is unset and split-buffer was a quoted name, possibly containing embedded spaces/quotes, then any unrequired quote characters are removed.
status-code
Return status:
0 | Success
4 | Illegal filename

Comments:

This routine can be made to fold to upper case by setting the least significant bit (bit 0) of cblte-sj-splitjoin-flg1. If this bit is not set, the case is preserved.

This routine can accept either null-terminated or space-terminated strings. Setting the second least significant bit (bit 1) of cblte-sj-splitjoin-flg1 results in the routine expecting null-terminated strings. If this bit is not set, space-terminated strings are expected.

If there are two or more periods (.) in the filename (not counting periods (.) in the pathname), the extension returned consists of the characters between the last period (.) and the end of the filename. The basename contains everything up to, but not including, the last period (.).

To make a distinction between filenames with no extension and filenames with spaces extension (that is, basenames whose last character is a period (.)), if the extension is spaces cblte-sj-extension-len is 1 and cblte-sj-extension-strt points to the last period (.).

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


mFFH

Initializes the File Handler.

Syntax:

call mFFH using      opcode

Parameters:

opcode pic x(2) comp-x

On Entry:

opcode | pic x(2) comp-x
opcode | h"0000" , the standard File Handler operation code that initializes the File Handler.

On Exit:

None.

Comments:

You need to use this call only if your program includes calls to MFFH_MODIFY_TRACE before any usage of COBOL I/O statements. You must use it before the first call to any MFFH_ routine.

The success of the call can be checked by examining RETURN-CODE.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines
Related information
MFFH_MODIFY_TRACE
MFFH_MODIFY_DISABLE
mFFH


MFFH_MODIFY_DISABLE

Disables all File Handler trace modification set by previous MFFH_MODIFY_TRACE calls.

Note: This routine is supported for native COBOL only.

Syntax:

call "MFFH_MODIFY_DISABLE"

Parameters:

None.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


MFFH_MODIFY_TRACE

Modifies some FCD fields, to save directly accessing the FCD. You can use this call whether you are issuing standard COBOL I/O statements or calling the File Handler explicitly using the API.
Note: This routine is supported for native COBOL only.

Syntax:

call "MFFH_MODIFY_TRACE" using      l-FCD-modifiers

Parameters:

l-FCD-modifiers.
Group item containing:
01 l-FCD-modifiers
   03 1-FCD-mod-enable  pic x comp-x.
   03 l-FCD-mod-flag    pic x(4) comp-x.
reserved pic x(8).

On Entry:

l-FCD-mod-enable
1 | Set modifier flag on
2 | Set modifier flag off
3 | Unset modifier - does not affect FCDs already modified
l-FCD-mod-flag
h"1102" | Modifies the trace bit in fcd-flags-1
h"1808" | Modifies the OPEN/CLOSE trace bit in fcd-fs-flags

On Exit:

None.

Comments:

The success of the call can be checked by examining RETURN-CODE.

Once a modification is set up, it is applied to every FCD passing into the File Hander until the modification is cleared.

Examples:

This example enables tracing for all files.

    move 1 to l-FCD-mod-enable
    move h"1102" to l-FCD-mod-flag
    call "MFFH_MODIFY_TRACE" using l-FCD-modifiers.

This example disables tracing for all files.

    move 2 to l-FCD-mod-enable
    move h"1102" to l-FCD-mod-flag
    call "MFFH_MODIFY_TRACE" using l-FCD-modifiers.

This example stops the tracing bit being modified from now on for all files. What was set, stays set.

    move 3 to l-FCD-mod-enable
    move h"1102" to l-FCD-mod-flag
    call "MFFH_MODIFY_TRACE" using l-FCD-modifiers.

This example enables OPEN/CLOSE tracing for all files.

    move 1 to l-FCD-mod-enable
    move h"1808" to l-FCD-mod-flag
    call "MFFH_MODIFY_TRACE" using l-FCD-modifiers.
Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


PC_FIND_DRIVES

Returns all valid drives on a PC.

Syntax:

call "PC_FIND_DRIVES" using      drive-info
                      returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
drive-info | cblt-x4-compx | pic x(4) comp-x.
status-code | See Library Routines - Key

On Entry:

None

On Exit:

drive-info | The 26 least-significant bits correspond to drives A: through Z:, with A: represented by bit 0 (the least significant bit) and Z: represented by bit 25. The corresponding bit is set for each drive that is present.
status-code | Status code.
Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


PC_READ_DRIVE

Returns the current default drive letter.

Syntax:

call "PC_READ_DRIVE" using     drive
                     returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
drive | cblt-x1-compx | pic x.
status-code | See Library Routines - Key

On Entry:

None

On Exit:

drive Drive letter, upper or lower case.
Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


PC_SET_DRIVE

Sets the default drive letter.

Syntax:

call "PC_SET_DRIVE" using     drive
                    returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
drive | cblt-x1-compx | pic x.
status-code | See Library Routines - Key

On Entry:

drive Drive letter, upper or lower case.

On Exit:

None

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


X"91" function 46

Enables insertion of a null character x"00" before data characters whose value is less than x"20" in line sequential files.

Note: This function is not supported in JVM COBOL.

Syntax:

call x"91" using result
                 function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
result | cblt-x1-compx | pic x comp-x.
function-code | cblt-x1-compx | pic x comp-x.
parameter | FD name of file

On Entry:

function-code | Value 46
parameter | The file-identifier specified in the File Description (FD). Must refer to a line sequential file which is currently open.

On Exit:

result Set to zero if the call was successful, nonzero otherwise.

Comments:

If you want to include non-ASCII data in a file then you must enable null insertion. This function lets you enable null insertion for individual files regardless of the setting of the run-time switch N.

Example:

 fd payroll-file
      ...
     call x"91" using result
                      function-code
                      payroll-file
Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


X"91" function 47

Disables insertion of a null character x"00" before data characters whose value is less than x"20" in line sequential files.

Note: This function is not supported in JVM COBOL.

Syntax:

call x"91" using result
                 function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
result | cblt-x1-compx | pic x comp-x.
function-code | cblt-x1-compx | pic x comp-x.
parameter | FD name of file

On Entry:

function-code | Value 47
parameter | The file-identifier specified in the File Description (FD). Must refer to a line sequential file which is currently open.

On Exit:

result Set to zero if the call was successful, nonzero otherwise.

Comments:

This function lets you disable null insertion for individual files regardless of the setting of the run-time switch N.

This function cannot be used if the file is declared as EXTERNAL.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


X"91" function 48

Enables insertion of tab characters in line sequential files.

Note: This function is not supported in JVM COBOL.

Syntax:

call x"91" using result
                 function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
result | cblt-x1-compx | pic x comp-x.
function-code | cblt-x1-compx | pic x comp-x.
parameter | FD name of file

On Entry:

function-code | Value 48
parameter | The file-identifier specified in the File Description (FD). Must refer to a line sequential file which is currently open.

On Exit:

result Set to zero if the call was successful, nonzero otherwise.

Comments:

On input all tab characters are expanded to the correct number of spaces, while on output to disk, multiple spaces before a tab stop position are contracted to a tab character. This function lets you enable tab insertion for individual files regardless of the setting of the run-time tab compression switch T.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


X"91" function 49

Disables insertion of tab characters in line sequential files.

Note: This function is not supported in JVM COBOL.

Syntax:

call x"91" using result
                 function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
result | cblt-x1-compx | pic x comp-x.
function-code | cblt-x1-compx | pic x comp-x.
parameter | FD name of file

On Entry:

function-code | Value 49
parameter | The file-identifier specified in the File Description (FD). Must refer to a line sequential file which is currently open.

On Exit:

result Set to zero if the call was successful, nonzero otherwise.

Comments:

On input all tab characters are expanded to the correct number of spaces, while on output to disk, multiple spaces before a tab stop position are contracted to a tab character. This function lets you disable tab insertion for individual files regardless of the setting of the run-time tab compression switch T.

Parent topic: File and Filename Routines
Parent topic: Alphabetical List of Library Routines


Interpreting the return code as a file status code

If any of the routines

  • CBL_CHECK_FILE_EXIST
  • CBL_COPY_FILE
  • CBL_CREATE_FILE
  • CBL_DELETE_FILE
  • CBL_OPEN_FILE
  • CBL_READ_FILE
  • CBL_RENAME_FILE
  • CBL_WRITE_FILE
  • CBL_CHANGE_DIR
  • CBL_CREATE_DIR
  • CBL_DELETE_DIR
  • CBL_READ_DIR

fails, the RETURN-CODE register contains a file status value indicating the failure. This file status is always the standard ANSI'74 file status value. If no ANSI'74 file status is defined for the error, an extended file status is returned (9/nnn where nnn is the run-time system error number).

You should, therefore, use RETURN-CODE and not a RETURNING clause. If RETURN-CODE is non-zero after calling one of these routines, you must process it as a file status, for example:

 01 file-status      pic xx comp-x.
 01 redefines file-status.
     03 fs-byte-1  pic x.
     03 fs-byte-2  cblt-x1-compx
   . . .
     call "CBL_xxx_xxx" using parameters
     if return-code not = 0
        move return-code to file-status
           . . .

At this point fs-byte-1 contains "9" and fs-byte-2 contains the run-time system error number.

Parent topic: File and Filename Routines


Filename Routines - Example

************************************************************
*                                                          *
*         (C) Micro Focus International Ltd 2000           *
*                                                          *
*                     SPLTJOIN.CBL                         *
*                                                          *
*  This program demonstrates the use of the routines that  *
*  enable you to separate a filename into its component    *
*  strings (CBL_SPLIT_FILENAME), and to join strings       *
*  together to form a filename (CBL_JOIN_FILENAME).        *
*                                                          *
************************************************************

 identification division.
 program-id. SPLTJOIN.
 environment division.
 data division.
 working-storage section.

 copy "cbltypes.cpy".

 78 environ          value "dos".

 01 split-buffer                     pic x(65).
 01 split-params                          cblt-splitjoin-buf.
*    03  cblte-sj-param-length            cblt-x2-compx value 24.
*    03  cblte-sj-split-join-flag1        cblt-x1-compx value 0.
*    03  cblte-sj-split-join-flag2        cblt-x1-compx.
*    03  cblte-sj-device-offset           cblt-x2-compx.
*    03  cblte-sj-device-length           cblt-x2-compx.
*    03  cblte-sj-basename-offset         cblt-x2-compx.
*    03  cblte-sj-basename-length         cblt-x2-compx.
*    03  cblte-sj-extension-offset        cblt-x2-compx.
*    03  cblte-sj-extension-length        cblt-x2-compx.
*    03  cblte-sj-total-length            cblt-x2-compx.
*    03  cblte-sj-split-buf-len           cblt-x2-compx value 65.
*    03  cblte-sj-join-buf-len            cblt-x2-compx value 65.
*    03  cblte-sj-first-component-length  cblt-x1-compx.

 01 join-buffer              pic x(65).
 01 path-buffer              pic x(65).
 01 basename-buffer          pic x(65).
 01 extension-buffer         pic x(3) value "cbl".

 procedure division.

* Set up lengths
     move 65 to cblte-sj-split-buf-len
                cblte-sj-join-buf-len

* Set flag for space-terminated, fold to upper
     move 1 to cblte-sj-split-join-flag1

$if environ = "unix"
     move "/dir/file.ext" to split-buffer
$else
     move "a:\dir\file.ext" to split-buffer

$end
     move 1 to cblte-sj-split-join-flag1
     move 24 to cblte-sj-param-length
     call "CBL_SPLIT_FILENAME" using split-params
                                     split-buffer

* This sets up most of the parameters you need for a join

* The join below replaces the original extension in
* split-buffer with the extension in extension-buffer, and
* puts the result in join-buffer.
     move 1 to cblte-sj-extension-offset
     move 3 to cblte-sj-extension-length
     call "CBL_JOIN_FILENAME" using split-params
                                    join-buffer
                                    split-buffer
                                    split-buffer
                                    extension-buffer

$if environ = "unix"
     if join-buffer = "/DIR/FILE.CBL" then
$else
     if join-buffer = "A:\DIR\FILE.CBL" then
$end
         display "first test passed"
     else
         display "first test failed"
     end-if

* It is harder to set up a join without doing a split first,
* but this is what you would need to do.

     move 1 to cblte-sj-device-offset
               cblte-sj-basename-offset
               cblte-sj-extension-offset

     move length of path-buffer to cblte-sj-device-length
     move length of basename-buffer
                                to cblte-sj-basename-length
     move length of extension-buffer
                                to cblte-sj-extension-length
     move length of join-buffer to cblte-sj-join-buf-len

     move 0 to cblte-sj-split-join-flag1
     move 24 to cblte-sj-param-length

$if environ = "unix"
     move "/path" to path-buffer
$else
     move "c:\path" to path-buffer
$end
     move "basename" to basename-buffer

     move "ext" to extension-buffer

     call "CBL_JOIN_FILENAME" using split-params
                                    join-buffer
                                    path-buffer
                                    basename-buffer
                                    extension-buffer

$if environ = "unix"
     if join-buffer = "/path/basename.ext" then
$else
     if join-buffer = "c:\path\basename.ext" then
$end
         display "second test passed"
     else

         display "second test failed"
     end-if
  stop run.
Parent topic: File and Filename Routines


Keyboard Routines

Restriction: These routines are supported for native COBOL only.
Note: The CBL_keyboard routines do not work with the x"AF" keyboard routines.
  • CBL_GET_KBD_STATUS
    Checks whether there is a character waiting to be read from the keyboard.
  • CBL_READ_KBD_CHAR
    Waits until a character is typed and then reads it with no echo.
  • X"B0" function 0
    Creates a function-key table.
  • X"B0" function 2
    Tests the status of the Shift, Alt, Ctrl and Lock keys.
  • X"B0" function 4
    Disables keyboard interrupts (Ctrl+Break).
  • Keyboard Routines - Example
Parent topic: Library Routines
Related information
Keyboard Routines - Example
Alphabetical List of Library Routines


CBL_GET_KBD_STATUS

Checks whether there is a character waiting to be read from the keyboard.

Syntax:

call "CBL_GET_KBD_STATUS" using     key-status
                          returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
key-status | cblt-x1-compx | pic x comp-x.
status-code | See Library Routines - Key

On Entry:

None

On Exit:

key-status
The status of the keyboard:
0 | No character available
1 | Character available

Comments:

Unpredictable results can occur if the user attempts to use both X"AF" and CBL_ keyboard routines. This is because X"AF" invokes ADIS to perform the required keyboard function and ADIS uses the CBL_ keyboard routines.

Parent topic: Keyboard Routines
Parent topic: Alphabetical List of Library Routines


CBL_READ_KBD_CHAR

Waits until a character is typed and then reads it with no echo.

Syntax:

call "CBL_READ_KBD_CHAR" using     char
                         returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
char | cblt-x1-compx. | pic x.
status-code | See Library Routines - Key.

On Entry:

None

On Exit:

char The character that was typed, in ASCII.
Parent topic: Keyboard Routines
Parent topic: Alphabetical List of Library Routines


X"B0" function 0

Creates a function-key table.

Note: This routine is supported for native COBOL only.

Syntax:

call X"B0" using function-code
                 key-table

Parameters:

function-code
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
key-table
Group containing:
01 key-table
  03 key-pressed     cblt-x1-compx   *> pic x comp-x.
  03 key-entry-list                  *> Group item defined as one iteration
                                     *> of the following for each key to be
                                     *> detected:
    05 key-entry-len cblt-x1-compx   *> pic x comp-x.
    05 key-entry     pic x(n)        *> pic x(n)
  03 key-list-end    cblt-x1-compx   *> pic x comp-x.

On Entry:

function-code | Contains 0.
key-entry-len | The length of key-entry in bytes (1 or 2).
key-entry | The code sequence produced by the required key.
key-list-end | Contains 0.

On Exit:

key-pressed The table entry matching the key used, or zero if no match is made.

Comments:

An ACCEPT statement normally recognizes as control keys only the keys used in data entry and is terminated by the Enter key; any other control key is rejected with a beep. Other control keys and function keys can be made available by calling this library routine.

This routine declares a table of key-code sequences, one for each additional key which is to be recognized. Details of the code sequences sent by each key are available in the IBM Personal Computer Technical Reference Manual.

After the routine has been called, an ACCEPT statement is terminated by the Enter key or by any one of the keys whose code sequence matches an entry in the table. The first byte of the table then contains a number indicating which entry in the table has been matched; zero indicates that the Enter key was used. If the Enter key has an entry in the table, the entry number of that key is returned rather than zero.

The routine can be called with different tables as often as you require. If the current table is changed (for example, if a key is changed or the length increased), then you don't need to call the routine again.

A table used by a particular program remains enabled for that program until it is superseded by another call to this routine, regardless of how many times this routine is called by other programs in your suite.

You must explicitly set up a table for each program in your suite of programs that uses this facility; passing the table in the Linkage Section is not sufficient.

As long as you know the key-code sent, you can define any key in the table. For example, a table entry with length of 1 and a key-code of pic X VALUE "C" causes the letter C to end an ACCEPT. You could, therefore, use such a key to "break-out" of an ACCEPT, perform your own processing, and return to the ACCEPT statement. The effect of this is that you have redefined the effect of that particular key.

The result byte is set both on termination of an ACCEPT and on each call to the routine when a key in the defined table has been pressed. When this occurs, the character code, x"0D" is returned to the CBL_READ_KBD_CHAR routine, and the result byte indicates which key in the table has been pressed. This means that, you can use CBL_READ_KBD_CHAR to read any single keystroke, including function keys.

For a complete list of code sequences sent by keys, see the technical reference manual for your personal computer.

Any keys defined by this call take precedence over those defined with AdisCF.

The function key table set up by AdisCF and used by call x"AF" is separate from the function key table used by call x"B0". Both can be enabled at the same time with all key sequences in the x"B0" table causing the carriage return x"0D" character to be returned to Adis.

Parent topic: Keyboard Routines
Parent topic: Alphabetical List of Library Routines


X"B0" function 2

Tests the status of the Shift, Alt, Ctrl and Lock keys.

Note: This routine is supported for native COBOL only.

Syntax:

call X"B0" using function-code
                 status-block

Parameters:

function-code
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
status-block
Group containing:
01  status-block
  03 status-inds  pic x           *> pic x
  03 status-id    cblt-x1-compx   *> pic x comp-x.
  03 status-res   pic x(6)        *> pic x(6)

On Entry:

function-code
Value 2.
status-id
Must be set to 2. It is overwritten by the call, so must be reset to 2 before each call.
status-res
Reserved.

On Exit:

status-inds
Contains bit settings indicating the status of the keys (1=key pressed, 0=key not pressed) in the following order:
bit 7 | Ins
bit 6 | Caps Lock
bit 5 | Num Lock
bit 4 | Scroll Lock
bit 3 | Alt
bit 2 | Ctrl
bit 1 | Shift (left key only)
bit 0 | Shift (right key only)

Comments:

For the Alt, Ctrl and Shift keys, the routine returns a 1 only if the key is actually pressed when the routine is called; for the other keys, the relevant bit is alternately set and unset each time the key is pressed.

Effective use of function 2 requires that the call is repeated at very frequent intervals.

Parent topic: Keyboard Routines
Parent topic: Alphabetical List of Library Routines


X"B0" function 4

Disables keyboard interrupts (Ctrl+Break).

Note: This routine is supported for native COBOL only.

Syntax:

call X"B0" using function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
function-code | cblt-x1-compx | pic x comp-x.
parameter | cblt-x1-compx | pic x comp-x.

On Entry:

function-code | Value 4.
parameter | Value 1.

On Exit:

None

Comments:

This routine disables keyboard interrupts for the rest of the application. It should be called before any subprograms are called.

Parent topic: Keyboard Routines
Parent topic: Alphabetical List of Library Routines


Keyboard Routines - Example

The following code is an example of how to use the function key call together with CBL_READ_KBD_CHAR:

 procedure division.
     ...
* Set up function key list
     call x"B0" using B0-function
                      B0-parameter-block
     ...
* Read a character from the keyboard
     call "CBL_READ_KBD_CHAR" using char
     if char = x"0D"

* A key defined in the function key table was pressed
         evaluate B0-return-byte
           when 1
            ...
           when 2
            ...
         end-evaluate
     else
         if char = x"00"
* A function key not defined in the table was pressed
             call "CBL_READ_KBD_CHAR" using char
* char contains the key's scan code
            ...
         else
* char contains a character
            ...
         end-if
     end-if.
Parent topic: Keyboard Routines


Logical Operator Routines

The logic routines carry out logic operations on bits. Apart from CBL_NOT, all these operations have two operands.

If the length is specified as a literal and there is no RETURNING clause then native code is optimized to generate inline code.

In the two-operand routines, interchanging the two operands, source and target, does not change the result except in CBL_IMP. However, the result is always stored in the second operand, target.

If length is longer than either data item, bytes following that data item are used, up to the length specified.

The parameter length can be replaced by the syntax:

        length of source

or:

        length of target

assuming all the bytes of the data item are to be used.

Logical AND and OR operations can also be carried out using the VALUE clause.

RETURN-CODE is not affected by these routines.

  • CBL_AND
    Does a logical AND between the bits of two data items.
  • CBL_EQ
    Does a logical EQUIVALENCE between the bits of two data items.
  • CBL_IMP
    Does a logical IMPLIES between the bits of two data items.
  • CBL_NOT
    Does a logical NOT on the bits of a data item.
  • CBL_OR
    Does a logical OR between the bits of two data items.
  • CBL_XOR
    Does a logical XOR between the bits of two data items.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_AND

Does a logical AND between the bits of two data items.

Syntax:

call "CBL_AND" using    source
                        target
               by value length

Parameters:

 | Using call prototype (see Key) | Picture
source | cblt-x1-compx | Any data item.
target | cblt-x1-compx | Any data item.
length | cblt-os-size | Numeric literal, pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

source | One of the data items to AND.
target | The other data item to AND.
length | The number of bytes of source and target to AND. Positions in target beyond this are unchanged.

On Exit:

target The result.

Comments:

The routine starts at the left-hand end of source and target and ANDs the bits together, storing the result in target. The truth table for this is:

source | target | result
0 | 0 | 0
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1
Parent topic: Logical Operator Routines
Parent topic: Alphabetical List of Library Routines


CBL_EQ

Does a logical EQUIVALENCE between the bits of two data items.

Syntax:

call "CBL_EQ" using    source
                       target
              by value length

Parameters:

 | Using call prototype (see Key) | Picture
source | cblt-x1-compx | Any data item.
target | cblt-x1-compx | Any data item.
length | cblt-os-size | Numeric literal pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

source | One of the data items to EQUIVALENCE.
target | The other data item to EQUIVALENCE.
length | The number of bytes of source and target to EQUIVALENCE. Positions in target beyond this length are unchanged.

On Exit:

target The result.

Comments:

The routine starts at the left-hand end of source and target and EQUIVALENCEs the bits together, storing the result in target. The truth table for this is:

source | target | result
0 | 0 | 1
0 | 1 | 0
1 | 0 | 0
1 | 1 | 1
Parent topic: Logical Operator Routines
Parent topic: Alphabetical List of Library Routines


CBL_IMP

Does a logical IMPLIES between the bits of two data items.

Syntax:

call "CBL_IMP" using    source
                        target
               by value length

Parameters:

 | Using call prototype (see Key) | Picture
source | cblt-x1-compx | Any data item.
target | cblt-x1-compx | Any data item.
length | cblt-os-size | Numeric literal, pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

source | One of the data items to IMPLIES.
target | The other data item to IMPLIES.
length | The number of bytes of source and target to IMPLIES. Positions in target beyond this are unchanged.

On Exit:

target The result.

Comments:

The routine starts at the left-hand end of source and target and IMPLIES the bits together, storing the result in target. The truth table for this is:

source | target | result
0 | 0 | 1
0 | 1 | 1
1 | 0 | 0
1 | 1 | 1
Parent topic: Logical Operator Routines
Parent topic: Alphabetical List of Library Routines


CBL_NOT

Does a logical NOT on the bits of a data item.

Syntax:

call "CBL_NOT" using    target
               by value length

Parameters:

 | Using call prototype (see Key) | Picture
target | cblt-x1-compx | Any data item.
length | cblt-os-size | Numeric literal, pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

target The data to operate on.

On Exit:

target | The data with the bits inverted.
length | The number of bytes of target to change. Positions beyond this are unchanged.

Comments:

The routine starts at the left-hand end of target and inverts bits. The truth table for this is:

before | after
0 | 1
1 | 0
Parent topic: Logical Operator Routines
Parent topic: Alphabetical List of Library Routines


CBL_OR

Does a logical OR between the bits of two data items.

Syntax:

call "CBL_OR" using    source
                       target
              by value length

Parameters:

 | Using call prototype (see Key) | Picture
source | cblt-x1-compx | Any data item.
target | cblt-x1-compx | Any data item.
length | cblt-os-size | Numeric literal or pic x(4) comp-5. or pic x(8) comp-5 (64-bit native programs only)

On Entry:

source | Source data to OR into the target data.
target | Target data to be ORed with the source data.
length | The number of bytes of source and target to OR. Positions in target beyond this are unchanged.

On Exit:

target The result of Oring source with target.

Comments:

The routine starts at the left-hand end of source and target and ORs the bits together, storing the result in target. The truth table for this is:

source | target | result
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 1
Parent topic: Logical Operator Routines
Parent topic: Alphabetical List of Library Routines


CBL_XOR

Does a logical XOR between the bits of two data items.

Syntax:

call "CBL_XOR" using    source
                        target
               by value length

Parameters:

 | Using call prototype (see Key) | Picture
source | cblt-x1-compx | Any data item.
target | cblt-x1-compx | Any data item.
length | cblt-os-size | Numeric literal, pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

source | One of the data items to exclusive-OR.
target | The other data item to exclusive-OR.
length | The number of bytes of source and target to exclusive-OR. Positions in target beyond this are unchanged.

On Exit:

target The result.

Comments:

The routine starts at the left-hand end of source and target and exclusive-ORs the bits together, storing the result in target. The truth table for this is:

source | target | result
0 | 0 | 0
0 | 1 | 1
1 | 0 | 1
1 | 1 | 0
Parent topic: Logical Operator Routines
Parent topic: Alphabetical List of Library Routines


Memory Allocation Routines

  • CBL_ALLOC_MEM
    Dynamically allocates memory, and can associate allocated heap data with a thread and/or the calling program.
  • CBL_ALLOC_DYN_MEM
    Dynamically allocates memory, and can associate it with the calling program.
  • CBL_ALLOC_SHMEM
    Dynamically allocates shared memory.
  • CBL_ALLOC_THREAD_MEM
    Allocates thread-specific heap memory.
  • CBL_FREE_DYN_MEM
    Frees dynamically allocated memory allocated by the CBL_ALLOC_DYN_MEM routine.
  • CBL_FREE_MEM
    Frees dynamically allocated memory.
  • CBL_FREE_SHMEM
    Frees dynamically allocated shared memory.
  • CBL_FREE_THREAD_MEM
    Frees dynamically allocated thread-specific heap memory.
  • CBL_MEM_STRATEGY
    Changes the memory strategy for an application dynamically.
  • CBL_MEM_VALIDATE
    Validates memory allocations, monitored freed memory, and, if the operating system supports it, compacts memory heaps.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_ALLOC_MEM

Dynamically allocates memory, and can associate allocated heap data with a thread and/or the calling program.

Syntax:

call "CBL_ALLOC_MEM" using     mem-pointer
                     by value  mem-size
                     by value  flags
                     returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mem-pointer | cblt-pointer | usage pointer. Must be level 01.
mem-size | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
flags | cblt-os-flags | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
status-code | See Library Routines - Key |

On Entry:

mem-size
The number of bytes of memory to allocate.
flags
The type of memory required. You can set the following bits:
Bit 0 | Allocate this memory as shared.
Bit 1 | Reserved. Must be set to zero.
Bit 2 | Allocate this memory independently from any calling program. If bit 3 is set it will be freed automatically when the calling thread ends. If bit 3 is unset it will be freed when the run-unit ends.
Bit 3 | Allocate this memory as thread local. If bit 2 is unset and there is a direct or indirect (in a mixed language environment) calling COBOL program, it will be freed when the calling program is canceled or the thread ends - whichever comes first.
Remaining bits | Reserved. Must be set to 0.

On Exit:

mem-pointer
A pointer to the memory allocated. The allocated memory is not initialized.

Comments:

The memory allocated is not initialized to any value.

Updates to any shared memory allocated to this function are not serialized or protected by the run-time system; you should use semaphores to maintain the integrity of the data.

If the memory has been allocated by a thread, it is freed when the calling thread terminates.

The maximum size of nonshared memory is restricted only by your operating system (unless the -l run-time switch is set).

The maximum size of shared memory is restricted by the operating system and the run-time system. The run-time tunable, shared_memory_segment_size, can be used to set the maximum size. The default is 65536, and the minimum is 8192 bytes.

Bit 1 and bit 2 or bit 3 are mutually exclusive. This is checked and error 181 returned otherwise. If there is no calling program (directly or indirectly in a mixed language environment) bit 2 is ignored.

If bit 2 is not set all standard memory allocated by CBL_ALLOC_MEM is freed when the program that allocated it is canceled (logically or physically), if there is a COBOL program that is directly or indirectly the caller.

Parent topic: Memory Allocation Routines
Parent topic: Alphabetical List of Library Routines


CBL_ALLOC_DYN_MEM

Dynamically allocates memory, and can associate it with the calling program.

Syntax:

call "CBL_ALLOC_DYN_MEM" using     mem-pointer
                         by value  mem-size
                                   flags
                         returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mem-pointer | cblt-pointer | usage pointer. Must be level 01.
mem-size | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
flags | cblt-os-flags | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
status-code | See Library Routines - Key |

On Entry:

mem-size
The number of bytes of memory to allocate.
flags
The type of memory required. You can set the following bits:
Bits 0-1 | Reserved. Must be set to 0.
Bit 2 | Allocate this memory independently from any calling program.
Remaining bits | Reserved. Must be set to 0.

On Exit:

mem-pointer
A pointer to the memory allocated. The allocated memory is not initialized.
status-code
0 | Successful allocation
157 | Unable to allocate memory
181 | Contradictory flags specification

Comments:

The memory allocated is not initialized to any value.

The maximum size of this allocated memory is restricted only by your operating system (unless the -l run-time switch is set).

If bit 2 is not set the memory allocated by CBL_ALLOC_DYN_MEM is freed when the program that allocated it is canceled (logically or physically), if there is a COBOL program that is directly or indirectly the caller. If bit 2 is set, this memory is freed when the run unit terminates, if it has not been previously freed by CBL_FREE_DYN_MEM.

Parent topic: Memory Allocation Routines
Parent topic: Alphabetical List of Library Routines


CBL_ALLOC_SHMEM

Dynamically allocates shared memory.

Syntax:

call "CBL_ALLOC_SHMEM" using     mem-pointer
                       by value  mem-size
                       returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mem-pointer | cblt-pointer | usage pointer. Must be level 01.
mem-size | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
status-code | See Library Routines - Key |

On Entry:

mem-size
The number of bytes of memory to allocate.

On Exit:

mem-pointer
A pointer to the memory allocated. The allocated memory is not initialized.
status-code
0 | Successful allocation
157 | Unable to allocate memory

Comments:

The memory allocated is not initialized to any value.

Updates to any shared memory allocated to this function are not serialized or protected by the run-time system; you should use semaphores to maintain the integrity of the data.

The maximum size of shared memory is restricted by the operating system and the run-time system. The run-time tunable, shared_memory_segment_size, can be used to set the maximum size. The default is 65536, and the minimum is 8192 bytes.

Parent topic: Memory Allocation Routines
Parent topic: Alphabetical List of Library Routines


CBL_ALLOC_THREAD_MEM

Allocates thread-specific heap memory.

Syntax:

call "CBL_ALLOC_THREAD_MEM" using      mem-pointer
                            by value  mem-size
                            by value  flags
                            returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mem-pointer | cblt-pointer | usage pointer. Must be level 01.
mem-size | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
flags | cblt-os-flags | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
status-code | See Library Routines - Key |

On Entry:

mem-size
The number of bytes of memory to allocate.
flags
Bits 0-1 | Reserved. Must be set to 0.
Bit 2 | Allocate this memory independently from any calling program.
Remaining bits | Reserved. Must be set to 0.

On Exit:

mem-pointer
A pointer to the memory allocated. The allocated memory is not initialized.
status-code
0 | Successful allocation
157 | Unable to allocate memory
181 | Contradictory flags specification

Coments:

If bit 2 is not set the memory allocated by CBL_ALLOC_THREAD_MEM is freed when the program that allocated it is canceled (logically or physically), if there is a COBOL program that is directly or indirectly the caller.

If bit 2 is set, this memory is freed when the thread that allocated it terminates, if it has not been previously freed by CBL_FREE_THREAD_MEM.

Parent topic: Memory Allocation Routines
Parent topic: Alphabetical List of Library Routines


CBL_FREE_DYN_MEM

Frees dynamically allocated memory allocated by the CBL_ALLOC_DYN_MEM routine.

Syntax:

call "CBL_FREE_DYN_MEM" using by value mem-pointer
                        returning      status-code

Parameters:

 | Using call prototype (see Key) | Picture
mem-pointer | cblt-pointer | usage pointer. Must be level 01.
status-code | See Library Routines - Key

On Entry:

mem-pointer The pointer returned when the memory was allocated using CBL_ALLOC_DYN_MEM.

On Exit:

None

Comments:

This routine releases memory allocated by the CBL_ALLOC_DYN_MEM routine.

Parent topic: Memory Allocation Routines
Parent topic: Alphabetical List of Library Routines


CBL_FREE_MEM

Frees dynamically allocated memory.

Syntax:

call "CBL_FREE_MEM" using by value mem-pointer
                    returning      status-code

Parameters:

 | Using call prototype (see Key) | Picture
mem-pointer | cblt-pointer | usage pointer.
status-code | See Library Routines - Key

On Entry:

mem-pointer The pointer returned when the memory was allocated using CBL_ALLOC_MEM.

On Exit:

None

Comments:

This routine releases memory allocated by the CBL_ALLOC_MEM routine.

Parent topic: Memory Allocation Routines
Parent topic: Alphabetical List of Library Routines


CBL_FREE_SHMEM

Frees dynamically allocated shared memory.

Syntax:

call "CBL_FREE_SHMEM" using by value    mem-pointer
                      returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mem-pointer | cblt-pointer. Must be level 01. | usage pointer. Must be level 01.
status-code | See Library Routines - Key

On Entry:

mem-pointer The pointer returned when the memory was allocated using CBL_ALLOC_SHMEM.

On Exit:

None

Comments:

This routine releases memory allocated by the CBL_ALLOC_SHMEM routine.

Parent topic: Memory Allocation Routines
Parent topic: Alphabetical List of Library Routines


CBL_FREE_THREAD_MEM

Frees dynamically allocated thread-specific heap memory.

Syntax:

call "CBL_FREE_THREAD_MEM" using by value mem-pointer
                           returning      status-code

Parameters:

 | Using call prototype (see Key) | Picture
mem-pointer | cblt-pointer | usage pointer.
status-code | See Library Routines - Key

On Entry:

mem-pointer The pointer returned when the memory was allocated using CBL_ALLOC_THREAD_MEM.

On Exit:

None

Comments:

This routine releases memory allocated by the CBL_ALLOC_THREAD_MEM routine.

Parent topic: Memory Allocation Routines
Parent topic: Alphabetical List of Library Routines


CBL_MEM_STRATEGY

Changes the memory strategy for an application dynamically.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_MEM_STRATEGY" using by value     func
                              by reference flags
                              returning    status-code

Parameters:

 | Using call prototype (see Key) | Picture (32-bit systems)
func | cblt-x4-comp-5 | pic x(4) comp-5.
flags | cblt-x4-comp-5 | pic x(4) comp-5.
status-code | See Library Routines - Key

On Entry:

func
0 | Get memory strategy
1 | Set memory strategy
2 | Get number of freed memory blocks being checked
3 | Set number of freed memory blocks to be checked
flags
If func is set to 1, flags indicates the memory strategy to set, as follows:
Bit 0
0 | No action
1 | Check bytes strategy: prepend and append check bytes to each memory allocation
Bit 1
0 | No action
1 | Check freed memory strategy: monitor for subsequent corruption the last n memory blocks freed, where n is the current value as set when func is set to 3
Bit 2
0 | No action
1 | Reuse strategy: allow freed memory being monitored for corruption to be used to satisfy allocation requests
Bits 3-29
Reserved for future use. Must be set to zero.
Bit 30
0 | No action
1 | Compatibility strategy: maintain compatibility with previous versions of the run-time system
Bit 31
0 | No action
1 | Validate strategy: validate memory each time an allocation or free operation occurs
If func is set to 3, flags indicates the number of freed memory blocks to be monitored for corruption.

On Exit:

flags
If func is set to 0, flags indicates the current memory strategy,as follows:
Bit 0
0 | No action
1 | Check bytes strategy: prepend and append check bytes to each memory allocation
Bit 1
0 | No action
1 | Check freed memory strategy: monitor for subsequent corruption the last n memory blocks freed, where n is the current value as set when func is set to 3
Bit 2
0 | No action
1 | Reuse strategy: allow freed memory being monitored for corruption to be used to satisfy allocation requests
Bits 3-29
Reserved for future use. Set to zero.
Bit 30
0 | No action
1 | Compatibility strategy: maintain compatibility with previous versions of of the run-time system
Bit 31
0 | No action
1 | Validate strategy: validate memory each time an allocation or free operation occurs
If func is set to 2, flags indicates the number of freed memory blocks being monitored for corruption.
status-code
Status of operation:
0 | All memory allocations are intact
1000 | Insufficient memory to perform request
1009 | Invalid parameter specified

Comments:

Use this routine to change the memory strategy for an application from within the application. It provides the same functionality as that provided by the memory_strategy and memory_free_check_size run-time tunables.

Parent topic: Memory Allocation Routines
Parent topic: Alphabetical List of Library Routines


CBL_MEM_VALIDATE

Validates memory allocations, monitored freed memory, and, if the operating system supports it, compacts memory heaps.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_MEM_VALIDATE" using by value     flags
                              by reference param
                              returning    status-code

Parameters:

flags
Using call prototype (see Key): cblt-x4-comp-5
Picture: pic x(4) comp-5.
param
Group predefined as :
01 cblt-mem-validate-param
   03 cblte-mv-version    cblt-x4-comp-5    *> pic x(4) comp-5.
   03 cblte-mv-flags      cblt-x4-comp-5    *> pic x(4) comp-5.
   03 cblte-mv-type       cblt-x4-comp-5    *> pic x(4) comp-5.
   03 cblte-mv-size       cblt-os-size    		*> 32-bit: pic x(4) comp-5.
                                                                                64-bit: pic x(8) comp-5.
   03 cblte-mv-address    cblt-pointer      *> pointer

On Entry:

flags
Validation control flags:
Bit 0
0 | No action
1 | Validate all memory allocations
Bit 1
0 | No action
1 | Validate all freed memory
2-30 | Reserved for future use. Must be set to zero.
Bit 31
0 | No action
1 | Compact memory
cblte-mv-version
Parameter block version; must be zero.

On Exit:

param
Fields are set only if the routine returns 1000
cblte-mv-flags
Information flags:
Bit 0
0 | cblte-mv-address not set
1 | cblte-mv-address contains address of corrupted memory block
Bit 1
0 | cblte-mv-address is user data address
1 | cblte-mv-address is memory header address
Bit 2
0 | cblte-mv-size not set
1 | cblte-mv-size contains size of corrupt memory block
Bit 3
0 | cblte-mv-type not set
1 | cblte-mv-type contains type of corrupt memory block
Bit 4
0 | Corruption in allocated memory
1 | Corruption in freed memory
Bit 5
0 | Corruption detected by run-time system
1 | Corruption detected by operating system
Bits 6-31
Reserved for future use.
status-code
Status of operation:
0 | All memory allocations are intact
1000 | Memory corruption detected
1009 | Invalid parameter specified

Comments:

Use this routine to validate memory allocations, monitored freed memory, and, if the operating system supports it, to compact memory heaps. Use this routine in preference to the validate memory strategy, set using the memory_strategy run-time tunable.

If you set the Compact memory flag, the routine attempts to compact memory to the extent that the operating system allows. There is no information flag setting that indicates the result.

Parent topic: Memory Allocation Routines
Parent topic: Alphabetical List of Library Routines


Mouse Routines

Note: The CBL_mouse routines do not work with the x"AF" mouse routines.

Using the Routines

The mouse is useful for applications that require users to select from a list of options or move objects around on the screen.

To use these routines, you must ensure that your system knows that you have a mouse attached.

You must hide the mouse during the execution of any ANSI ACCEPT or DISPLAY statement that operates on the area of the screen where the mouse pointer is located.

The attributes referred to in the descriptions of routines are screen attributes, not user attributes. The top left-hand corner of the screen is row 0, column 0.

Mouse Events

Whenever the mouse is moved or a button on the mouse is pressed or released, the mouse hardware causes an interrupt. The mouse device driver takes control and, depending on a mask you have set, either saves it in a queue or ignores it. This prevents events being lost if a subsequent interrupt occurs before the application has read the event. With the mouse routines, you can read the event queue and determine how many events are in the queue.

When an event is generated, a description of it is stored in a data structure called the event-data. If the mask allows (see below), this is added to the queue. The layout of event-data is:

   event-type           pic x(2) comp-x.
         event-time           pic x(4) comp-x.
         event-row            pic x(2) comp-x.
         event-col            pic x(2) comp-x.

where the parameters are:

event-type
The action (that is, change of state) that took place:
bit 7-4 | reserved
bit 3 | set = button 3 pressed
bit 2 | set = button 2 pressed
bit 1 | set = button 1 pressed
bit 0 | set = mouse moved
A button release is indicated by the bit for that button changing from 1 to 0. For example, if the mouse moves and button 1 is pressed at the same time, event-type contains 3.
event-time
The time elapsed between when the event took place and some arbitrary but fixed starting time.
event-row
Gives the row in which the mouse was positioned when the event took place.
event-col
Gives the column in which the mouse was positioned when the event took place.

The Event Mask

The event mask, which you supply, tells the system which kinds of event should be queued and which ignored. It has the same structure as event-type. An event is queued only if it happens while the corresponding mask bit is on, or while another state is on whose mask bit is on. When an event-data is queued, the bit for each state is set correctly; that is, the mask does not mask them out.

For example, the operator moving the mouse generates an event if either the mask bit for "mouse moved" is off or the operator is holding down a button and the mask bit for that button is off.

  • CBL_GET_MOUSE_MASK
    Returns the mouse event mask.
  • CBL_GET_MOUSE_POSITION
    Returns the screen position of the mouse pointer.
  • CBL_GET_MOUSE_STATUS
    Finds out the number of events in the queue.
  • CBL_HIDE_MOUSE
    Makes the mouse pointer invisible.
  • CBL_INIT_MOUSE
    Initializes mouse support. This routine must be called before other mouse routines can be called.
  • CBL_READ_MOUSE_EVENT
    Reads the mouse event queue and returns information about an event.
  • CBL_SET_MOUSE_MASK
    Sets the mouse event mask.
  • CBL_SHOW_MOUSE
    Makes the mouse pointer visible.
  • CBL_TERM_MOUSE
    Terminates mouse support, releasing internal resources.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_GET_MOUSE_MASK

Returns the mouse event mask.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_GET_MOUSE_MASK" using     mouse-handle
                                    event-mask
                          returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mouse-handle | cblt-x4-compx | pic x(4) comp-x.
event-mask | cblt-x2-compx | pic x(2) comp-x.
status-code | See Library Routines - Key |

On Entry:

mouse-handle Mouse identifier, obtained by earlier call to CBL_INIT_MOUSE.

On Exit:

event-mask See Mouse Routines

Comments:

The CBL_ mouse routines do not work with the x"AF" mouse routines.

Parent topic: Mouse Routines
Parent topic: Alphabetical List of Library Routines


CBL_GET_MOUSE_POSITION

Returns the screen position of the mouse pointer.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_GET_MOUSE_POSITION" using     mouse-handle
                                        mouse-position
                              returning status-code

Parameters

mouse-handle
Call prototype (see Key): cblt-x4-compx
Picture: pic x(4) comp-x.
mouse-position
Group predefined as cblt-mouse-pos containing
01 cblt-mouse-pos      typedef.
  03 cblte-mpos-row    cblt-x2-compx. 	*> pic x(2) comp-5.
  03 cblte-mpos-col    cblt-x2-compx. 	*> pic x(2) comp-5.
status-code
See Library Routines - Key.

On Entry:

mouse-handle Mouse identifier, obtained by earlier call to CBL_INIT_MOUSE.

On Exit:

mouse-position The screen position of the mouse pointer.

Comments:

The CBL_ mouse routines do not work with the x"AF" mouse routines.

Parent topic: Mouse Routines
Parent topic: Alphabetical List of Library Routines


CBL_GET_MOUSE_STATUS

Finds out the number of events in the queue.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_GET_MOUSE_STATUS"  using     mouse-handle
                                      mouse-queue-size
                            returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mouse-handle | cblt-x4-compx | pic x(4) comp-x.
mouse-queue-size | cblt-x2-compx | pic x(2) comp-x.
status-code | See Library Routines - Key

On Entry:

mouse-handle Mouse identifier, obtained by earlier call to CBL_INIT_MOUSE.

On Exit:

mouse-queue-size The number of events in the queue.

Comments:

The CBL_ mouse routines do not work with the x"AF" mouse routines.

Parent topic: Mouse Routines
Parent topic: Alphabetical List of Library Routines


CBL_HIDE_MOUSE

Makes the mouse pointer invisible.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_HIDE_MOUSE" using      mouse-handle
                      returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mouse-handle | cblt-x4-compx | pic x(4) comp-x.
status-code | See Library Routines - Key

On Entry:

mouse-handle Mouse identifier, obtained by earlier call to CBL_INIT_MOUSE.

On Exit:

None.

Comments:

After this routine has been called, mouse events still take place, but the mouse pointer is not displayed.

The CBL_ mouse routines do not work with the x"AF" mouse routines.

Parent topic: Mouse Routines
Parent topic: Alphabetical List of Library Routines


CBL_INIT_MOUSE

Initializes mouse support. This routine must be called before other mouse routines can be called.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_INIT_MOUSE" using     mouse-handle
                                mouse-buttons
                      returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mouse-handle | cblt-x4-compx | pic x(4) comp-x.
mouse-buttons | cblt-x2-compx | pic x(2) comp-x.
status-code | See Library Routines - Key

On Entry:

None.

On Exit:

mouse-handle | Mouse identifier. You pass this to any mouse routines you call subsequently.
mouse-buttons | The number of buttons on the mouse.

Comments:

If status-code (or RETURN-CODE) contains a nonzero status on return from this routine, mouse handling is not available and calls to any of the mouse routines should not be made.

The CBL_ mouse routines do not work with the x"AF" mouse routines.

Parent topic: Mouse Routines
Parent topic: Alphabetical List of Library Routines


CBL_READ_MOUSE_EVENT

Reads the mouse event queue and returns information about an event.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_READ_MOUSE_EVENT" using     mouse-handle
                                      event-data
                                      read-type
                            returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mouse-handle | cblt-x4-compx | pic x(4) comp-x.
event-data | See Mouse Routines
read-type | cblt-x1-compx | pic x comp-x.
status-code | See Library Routines - Key

On Entry:

mouse-handle
Mouse identifier, obtained by earlier call to CBL_INIT_MOUSE.
read-type
Indicates what to do if there are no events in the queue:
0 | Return immediately
1 | Wait for an event and then return

On Exit:

event-data
See Mouse Routines

Comments:

If there are no events in the event queue, the return from this routine depends on the value of read-type. If read-type is zero, the routine returns immediately with all zero values in event-data. If read-type has a value of one, return is delayed until an event has been queued.

The CBL_ mouse routines do not work with the x"AF" mouse routines.

Parent topic: Mouse Routines
Parent topic: Alphabetical List of Library Routines


CBL_SET_MOUSE_MASK

Sets the mouse event mask.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_SET_MOUSE_MASK" using      mouse-handle
                                    event-mask
                          returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mouse-handle | cblt-x4-compx | pic x(4) comp-x.
event-mask | cblt-x2-compx | pic x(2) comp-x.
status-code | See Library Routines - Key

On Entry:

mouse-handle | Mouse identifier, obtained by earlier call to CBL_INIT_MOUSE.
event-mask | See Mouse Routines

On Exit:

None

Comments:

CBL_GET_MOUSE_MASK should be called first to find out which events are enabled.

The CBL_ mouse routines do not work with the x"AF" mouse routines.

Parent topic: Mouse Routines
Parent topic: Alphabetical List of Library Routines


CBL_SHOW_MOUSE

Makes the mouse pointer visible.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_SHOW_MOUSE" using      mouse-handle
                      returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mouse-handle | cblt-x4-compx | pic x(4) comp-x.
status-code | See Library Routines - Key

On Entry:

mouse-handle Mouse identifier, obtained by earlier call to CBL_INIT_MOUSE.

On Exit:

None

Comments:

When the mouse support has been initialized by the CBL_INIT_MOUSE call, the pointer is not displayed until this routine is called. After this call the system displays the mouse pointer until a routine to hide the mouse or terminate mouse support is called. This routine cancels any collision area defined earlier by PC_SET_MOUSE_HIDE_AREA.

The CBL_ mouse routines do not work with the x"AF" mouse routines.

Parent topic: Mouse Routines
Parent topic: Alphabetical List of Library Routines


CBL_TERM_MOUSE

Terminates mouse support, releasing internal resources.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_TERM_MOUSE" using     mouse-handle
                      returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
mouse-handle | cblt-x4-compx | pic x(4) comp-x.
status-code | See Library Routines - Key

On Entry:

mouse-handle Mouse identifier, obtained by earlier call to CBL_INIT_MOUSE.

On Exit:

None

Comments:

The routine releases internal resources allocated by CBL_INIT_MOUSE. After this routine, mouse-handle is no longer valid and calling any mouse routine other than CBL_INIT_MOUSE results in an error.

The CBL_ mouse routines do not work with the x"AF" mouse routines.

Parent topic: Mouse Routines
Parent topic: Alphabetical List of Library Routines


Multi-threading Routines

Call-by-name library routines provide a programming interface through which you can implement and control multi-threading in your applications.

  • Thread-control Routines
  • Synchronization Routines
  • Routines for Handling Thread-specific Data
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines
RETURN-CODE Values For Thread-control Routines
RETURN-CODE Values For Thread-specific Data Handling Routines


Thread-control Routines

  • CBL_THREAD_CREATE
    Creates a thread from a named entry point.
  • CBL_THREAD_CREATE_P
    Creates a thread from a procedure pointer.
  • CBL_THREAD_DETACH
    Frees thread resources when the thread terminates.
  • CBL_THREAD_EXIT
    Terminates the current thread.
  • CBL_THREAD_IDDATA_ALLOC
    Allocates an id-data area for the current thread.
  • CBL_THREAD_IDDATA_GET
    Returns a pointer to the id-data area for the specified thread.
  • CBL_THREAD_KILL
    Kills the specified thread, terminating it abnormally and detaching all resources associated with it.
  • CBL_THREAD_LIST_END
    Used in conjunction with CBL_THREAD_LIST_START and CBL_THREAD_LIST_NEXT to obtain a list of all currently existing threads that the run-time system knows about. It is required to terminate a CBL_THREAD_LIST_START.
  • CBL_THREAD_LIST_NEXT
    Used in conjunction with CBL_THREAD_LIST_START and CBL_THREAD_LIST_END to obtain a list of all currently existing threads that the run-time system knows about. The CBL_THREAD_LIST_NEXT call takes returns the next item in the list of threads.
  • CBL_THREAD_LIST_START
    Used in conjunction with CBL_THREAD_LIST_NEXT and CBL_THREAD_LIST_END to obtain a list of all currently existing threads that the run-time system knows about.
  • CBL_THREAD_LOCK
    Locks most functions of the thread-handling routines.
  • CBL_THREAD_PROG_LOCK
    With CBL_THREAD_PROG_UNLOCK, provides a single pre-initialized synchronization object per calling COBOL program
  • CBL_THREAD_PROG_UNLOCK
    With CBL_THREAD_PROG_LOCK, provides a single pre-initialized synchronization object per calling COBOL program
  • CBL_THREAD_RESUME
    Resumes a thread that was or will be suspended by CBL_THREAD_SUSPEND.
  • CBL_THREAD_SUSPEND
    Suspends the current thread.
  • CBL_THREAD_SELF
    Stores the thread identifier of the current thread.
  • CBL_THREAD_SLEEP
    Causes the calling thread to give up control to the processor for the given number of milliseconds.
  • CBL_THREAD_UNLOCK
    Unlocks most functions of the thread handling routines.
  • CBL_THREAD_WAIT
    Waits for completion of the specified non-detached thread, or returns immediately if the thread has already completed.
  • CBL_THREAD_YIELD
    Yields the rest of the current thread's timeslice.
  • RETURN-CODE Values For Thread-control Routines
  • Using the Program Thread-locking Routines
  • Using CBL_THREAD_SELF to Check Operating System
Parent topic: Multi-threading Routines
Related information
Alphabetical List of Library Routines


CBL_THREAD_CREATE

Creates a thread from a named entry point.

Syntax:

call "CBL_THREAD_CREATE" using by reference entry-name
                         by reference       thread-param
                         by value           param-size
                         by value           flags
                         by value           priority
                         by value           stack-size
                         by reference       thread-id

Parameters:

 | Using call prototype (see Key) | Picture
entry-name | pic x(n) space or null terminated | pic x(n) space or null terminated
thread-param | pic x(n) space or null terminated | Any data item.
param-size | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
flags | cblt-os-flags | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
priority | cblt-sx4-comp5 | pic s9(9) comp-5
stack-size | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
thread-id | cblt-pointer | usage pointer.

On Entry:

entry-name
Space or null terminated name for the thread
thread-param
Parameter passed to the new thread
param-size
Set to one of the following values:
0 | Only the address of thread-param is passed as the parameter to the entry point in the new thread without any copying of data values
>0 | The value of thread-param is copied for a length of param-size and the address of this copy area is passed to the new thread. The value of thread-param will still be intact for the created thread, even if the creating thread changes or deallocates thread-param immediately after the CBL_THREAD_CREATE call.
flags
A number, in which the bits can be set as follows:
Bit 0
0 | Detach thread immediately when the thread terminates.
1 | Do not detach thread immediately. Even when the thread has terminated, its resources are not freed until the thread is detached.
Bit 1
0 | Thread priority is relative (-100 to +100).
1 | Thread priority is absolute (0 to 100).
Bit 2
0 | Any monitors locked by this thread when the thread terminates can cause a run-time system error.
1 | An error will not be issued if monitors are locked when the thread terminates
Bit 3
0 Create active
1 Create suspended
Restriction: This is deprecated in the .NET environment
Bit 4
0 | Multi-threaded Apartment model (MTA)
1 | Single threaded Apartment model (STA)
Remaining bits
Reserved
priority
Set the priority. Normally, the priority is in the range -100 to+100 and is relative to the current thread's priority. Values of -1 and +1 indicate the smallest decrement/increment that gives the thread a lower/higher priority than the caller (unless the caller already has the lowest/highest possible priority). If a negative/positive value would take the thread's priority lower/higher than is possible, then the lowest/highest value is used. If bit 1 of flags is set to 1, then the priority is an absolute value 0 to 100.
stack-size
Tell the run-time system how big a stack to give the new thread. A value of 0 causes a sensible default to be used. If the parameter appears to be invalid, the run-time system will either ignore it, or return an error indicating an invalid value was provided.

On Exit:

thread-id
A thread identifier.
return-code
A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines.

Comments:

The entry point specified can be implemented in any language.

If the call succeeds and a new thread is created, its thread identifier is stored in thread-id and the RETURN-CODE is set to 0. This is true even if the thread is created detached, however in this case the caller should take care to ensure that the new thread still exists before using the thread-id in any other call.

If the call fails thread-id is set to NULL and an error number is set in RETURN-CODE.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
RETURN-CODE Values For Thread-control Routines
Routines for Handling Thread-specific Data
Multi-threading Routines
RETURN-CODE Values For Thread-specific Data Handling Routines


CBL_THREAD_CREATE_P

Creates a thread from a procedure pointer.

Syntax:

call "CBL_THREAD_CREATE_P" using  by value entry-point
                           by reference    thread-param
                           by value        param-size
                           by value        flags
                           by value        priority
                           by value        stack-size
                           by reference    thread-id

Parameters:

 | Using call prototype (see Key) | Picture
entry-point | cblt-ppointer | usage procedure-pointer.
thread-param | pic x(n) null or space terminated | Any data item.
param-size | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
flags | cblt-os-flags | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
priority | cblt-sx4-comp5 | pic s9(9) comp-5
stack-size | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
thread-id | cblt-pointer | usage pointer.

On Entry:

entry-point
Procedure-pointer set to the appropriate entry point of program to execute.
thread-param
Parameter passed to the new thread
param-size
Set to one of the folllowing:
0 | Only the address of thread-param is passed as the parameter to the entry point in the new thread without any copying of data values
>0 | The value of thread-param is copied for a length of param-size and the address of this copy area is passed to the new thread. The value of thread-param will still be intact for the created thread, even if the creating thread changes or deallocates thread-param immediately after the CBL_THREAD_CREATE call.
flags
A number in which the bits can be set as follows:
Bit 0
0 | Detach thread immediately when the thread terminates.
1 | Do not detach thread immediately. Even when the thread has terminated, its resources are not freed until thread is detached.
Bit 1
0 | Thread priority is absolute (0 to 100).
1 | Thread priority is relative (-100 to +100).
Bit 2
0 | Any monitors locked by this thread when the thread terminates can cause a run-time system error.
1 | An error will not be issued if monitors are locked when the thread terminates
Bit 3
0 Create active
1 Create suspended
Restriction: This is deprecated in the .NET environment
Bit 4
0 | Multi-threaded Apartment model (MTA)
1 | Single threaded Apartment model (STA)
Remaining bits
Reserved.
priority
Sets the priority. Normally, the priority is in the range -100 to+100 and is relative to the current thread's priority. Values of -1 and +1 indicate the smallest decrement/increment that gives the thread a lower/higher priority than the caller (unless the caller already has the lowest/highest possible priority). If a negative/positive value would take the thread's priority lower/higher than is possible, then the lowest/highest value is used. If bit 1 of flags is set to 1, then the priority is an absolute value 0 to 100.
stack-size
Tells the run-time system how big a stack to give the new thread. A value of 0 causes a sensible default to be used. If the parameter appears to be invalid, the run-time system will either ignore it, or return an error indicating an invalid value was provided.

On Exit:

thread-id
A thread identifier.
return-code
A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines.

Comments:

The entry point specified can be implemented in any language.

If the call succeeds and a new thread is created, its thread identifier is stored in thread-id and the RETURN-CODE is set to 0. This is true even if the thread is created detached, however in this case the caller should take care to ensure that the new thread still exists before using the thread-id in any other call.

If the call fails thread-id is set to NULL and an error number is set in RETURN-CODE.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
RETURN-CODE Values For Thread-control Routines
Routines for Handling Thread-specific Data
Multi-threading Routines
RETURN-CODE Values For Thread-specific Data Handling Routines


CBL_THREAD_DETACH

Frees thread resources when the thread terminates.

Syntax:

call "CBL_THREAD_DETACH" using by value thread-id

Parameters:

 | Using call prototype (see Key) | Picture
thread-id | cblt-pointer | usage pointer.

On Entry:

thread-id A pointer to the thread identifier.

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines.

Comments:

CBL_THREAD_DETACH enables a thread's resource to be freed when that thread terminates. When a thread is created (non-detached) a handle is returned to the creator. That handle can be used to wait for a thread, retrieve a return-code from the thread, inspect a thread's state, and so on. If a thread terminates, that handle is still valid until a WAIT or DETACH is done; that is, resources are still allocated to the (terminated) thread. If a thread is detached then all resources from a terminated thread are freed immediately; if the thread is still active those resources are marked to be freed when the thread terminates.

Behavior is undefined if:

  • thread-id is undefined
  • Two threads attempt to call CBL_THREAD_WAIT and/or CBL_THREAD_DETACH for the same thread at the same time

If successful, RETURN-CODE is set to 0. If unsuccessful, the call will attempt to return an error number. However, because some behaviors are undefined, a call that fails could result in a run-time system error.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_EXIT

Terminates the current thread.

Syntax:

call "CBL_THREAD_EXIT" using by value return-value

Parameters:

 | Using call prototype (see Key) | Picture
return-value | cblt-pointer | usage pointer.

On Entry:

None.

On Exit:

return-value | Value returned from the thread processing
return-code | A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines.

Comments:

In a thread created by CBL_THREAD_CREATE, this call has the same effect as executing STOP RUN RETURNING return-value from a COBOL program, or cobexit() from a program in another language. This function can also be called from a program in another programming language, in preference to using cobexit().

This call will fail, returning an error code, if the current thread was not created with CBL_THREAD_CREATE.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_IDDATA_ALLOC

Allocates an id-data area for the current thread.

Syntax:

CBL_THREAD_IDDATA_ALLOC using by reference iddata
                        by value  iddatasize

Parameters:

 | Using call prototype (see Key) | Picture
iddata | cblt_pointer | pic x(n).
iddatasize | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

iddata | Id-data area for the current thread
iddatasize | Size of the id-data area. If it is zero, the thread will have no id-data area.

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines.

Comments:

This call allocates an id-data area for the current thread, and registers it so that a further call to CBL_THREAD_IDDATA_GET with this thread's handle will return the pointer to this data area. A call to CBL_THREAD_LIST_START or CBL_THREAD_LIST_NEXT can also be used to retrieve the pointer to this data area.

If there was already an id-data area for this thread, the old one is freed and replaced by the new one. This will not happen if the call fails; typically this occurs if there is not enough memory to allocate the new id-data area.

If the iddata parameter is passed as 'by value 0' then any area allocated is initialized to low-values. Otherwise iddata provides the initialization data for the memory area allocated.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_IDDATA_GET

Returns a pointer to the id-data area for the specified thread.

Syntax:

call "CBL_THREAD_IDDATA_GET" using by reference iddata-ptr
                             by value           thread-id

Parameters:

 | Using call prototype (see Key) | Picture
iddata-ptr | cblt-pointer | usage pointer.
thread-id | cblt-pointer | usage pointer.

On Entry:

iddata-ptr | Pointer tp the id-data area for the specified thread
thread-id | Pointer to the thread identifier

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

Returns a pointer to the id-data area for the specified thread or NULL if no id-data area has been allocated to date.

thread-id might be NULL, in which case a pointer to the current thread's id-data area is returned.

If another thread's id-data area is retrieved by this function the user should make sure that any attempts to access it in all threads are protected by some form of locking (for example, by using CBL_THREAD_LOCK and CBL_THREAD_UNLOCK to frame all accesses to it).

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_KILL

Kills the specified thread, terminating it abnormally and detaching all resources associated with it.

Syntax:

call "CBL_THREAD_KILL" using by value thread-id

Parameters:

 | Using call prototype (see Key) | Picture
thread-id | cblt-pointer | usage pointer.

On Entry:

thread-id A pointer to the thread identifier

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

This routine can only be used to kill a thread that was created with CBL_THREAD_CREATE, and not threads created in other ways.

If the target thread has already completed, but was not detached, this call simply detaches it and discards any return value.

This call can be used with thread-id set to the current thread. In this case its effect is the same as CBL_THREAD_EXIT with a NULL return value.

Behavior is undefined:

  • If thread-id is invalid
  • For any thread that has a call to CBL_THREAD_WAIT for the killed thread
Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_LIST_END

Used in conjunction with CBL_THREAD_LIST_START and CBL_THREAD_LIST_NEXT to obtain a list of all currently existing threads that the run-time system knows about. It is required to terminate a CBL_THREAD_LIST_START.

Syntax:

call "CBL_THREAD_LIST_END"

Parameters:

None.

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

If unsuccessful, this routine returns an error number in RETURN_CODE. However, because some behaviors are undefined, a call to this routine that fails could result in a run-time system error.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_LIST_NEXT

Used in conjunction with CBL_THREAD_LIST_START and CBL_THREAD_LIST_END to obtain a list of all currently existing threads that the run-time system knows about. The CBL_THREAD_LIST_NEXT call takes returns the next item in the list of threads.

Syntax:

call "CBL_THREAD_LIST_NEXT" using by reference thread-id
                            by reference       thread-state
                            by reference       thread-iddata

Parameters:

 | Using call prototype (see Key) | Picture
thread-id | cblt-pointer | usage pointer.
thread-state | cblt-x4-compx | pic x(4) comp-x.
thread-iddata | cblt-pointer | usage pointer.

On Entry:

None

On Exit:

thread-id
First thread identifier in this routine's internal list
thread-state
The state of the thread:
Bit 0
0 | Detached
1 | Not detached
Bit 1
0 | Not suspended.
1 | Suspended by CBL_THREAD_SUSPEND
Bit 2
0 | Thread is not the main thread.
1 | Thread is from a program in another language, and is known to the run-time system, or is the main thread
Bits 3-31
Undefined; could be any value
thread-iddata
A pointer to the thread's id-data, if that data area exists (otherwise NULL). id-data is specified by the routine CBL_THREAD_ALLOC_IDDATA.
return-code
A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

Only information on existing threads, that is, threads that have not terminated, is returned. This routine will not return a thread-id for a thread that has terminated but has not been detached.

If thread-id is NULL then the first item in the list is returned (but there must have been a previous CBL_THREAD_LIST_START call).

Behavior is undefined if thread-id is invalid.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_LIST_START

Used in conjunction with CBL_THREAD_LIST_NEXT and CBL_THREAD_LIST_END to obtain a list of all currently existing threads that the run-time system knows about.

Syntax:

call "CBL_THREAD_LIST_START" using by reference thread-id
                             by reference       thread-state
                             by reference       thread-iddata

Parameters:

 | Using call prototype (see Key) | Picture
thread-id | cblt-pointer | usage pointer.
thread-state | cblt-x4-compx | pic x(4) comp-x.
thread-iddata | cblt-pointer | usage pointer.

On Entry:

None.

On Exit:

thread-id
First thread identifier in this routine's internal list.
thread-state
The state of the thread:
Bit 0
0 | Detached
1 | Not detached
Bit 1
0 | Not suspended.
1 | Suspended by CBL_THREAD_SUSPEND
Bit 2
0 | Thread is not the main thread.
1 | Thread is from a program in another language, and is known to the run-time system, or is the main thread
Bits 3-31
Undefined; could be any value
thread-iddata
A pointer to the thread's id-data, if that data area exists (otherwise NULL). id-data is specified by the routine CBL_THREAD_ALLOC_IDDATA.
return-code
A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

Only information on existing threads, that is, threads that have not terminated, is returned. This routine will not return a thread-id for a thread that has terminated but has not been detached.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_LOCK

Locks most functions of the thread-handling routines.

Syntax:

call "CBL_THREAD_LOCK"

Parameters:

None.

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

This routine can also be used to synchronize access to global or external data, id-data and error handling.

Any thread that obtains a CBL_THREAD_LOCK must not exit before doing a CBL_THREAD_UNLOCK.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_PROG_LOCK

With CBL_THREAD_PROG_UNLOCK, provides a single pre-initialized synchronization object per calling COBOL program

Syntax:

call "CBL_THREAD_PROG_LOCK"

Parameters:

None.

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

This function, in conjunction with CBL_THREAD_PROG_UNLOCK, provides a single pre-initialized synchronization object per calling COBOL program. This makes it especially useful for initializing any program local data items or synchronization objects.

Example:

Example

These functions must be called either directly or indirectly from a COBOL program. The calling COBOL program is the one with which the lock is associated.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_PROG_UNLOCK

With CBL_THREAD_PROG_LOCK, provides a single pre-initialized synchronization object per calling COBOL program

Syntax:

call "CBL_THREAD_PROG_UNLOCK"

Parameters:

None.

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

This function, in conjunction with CBL_THREAD_PROG_LOCK, provides a single pre-initialized synchronization object per calling COBOL program. This makes it especially useful for initializing any program local data items or synchronization objects.

Example:

Example

These functions must be called either directly or indirectly from a COBOL program. The calling COBOL program is the one with which the lock is associated.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_RESUME

Resumes a thread that was or will be suspended by CBL_THREAD_SUSPEND.

Syntax:

call "CBL_THREAD_RESUME" using by value thread-id

Parameters:

 | Using call prototype (see Key) | Picture
thread-id | cblt-pointer | usage pointer.

On Entry:

thread-id A pointer to the thread identifier

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

If the specified thread is suspended when a call to this routine is made, then RETURN-CODE is set to 0. If the specified thread was not suspended then the RETURN-CODE is set to the negative value of the number of times the target thread will have to call CBL_THREAD_SUSPEND before its execution is actually suspended.

Behavior is undefined if thread-id is invalid.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_SUSPEND

Suspends the current thread.

Syntax:

call "CBL_THREAD_SUSPEND" using by value thread-id

Parameters:

 | Using call prototype (see Key) | Picture
thread-id | cblt-pointer | usage pointer.

On Entry:

thread-id A pointer to the thread identifier

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

If thread-id is NULL or is the current thread, this routine suspends the current thread until another thread does a CBL_THREAD_RESUME on it. If successful, RETURN_CODE is set to 0. If one or more CBL_THREAD_RESUME routines have already targeted this thread then RETURN_CODE is set to the negative value of the number of further times CBL_THREAD_SUSPEND will have to be called before the thread is actually suspended.

Otherwise, the call returns a non-zero (positive) error code.

You cannot suspend threads other than the current thread.

Behavior is undefined if thread-id is invalid.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_SELF

Stores the thread identifier of the current thread.

Syntax:

call "CBL_THREAD_SELF" using by reference thread-id

Parameters:

 | Using call prototype (see Key) | Picture
thread-id | cblt-pointer | usage pointer.

On Entry:

thread-id A pointer to the thread identifier.

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

The run-time system returns the thread identifier and stores it in thread-id.

You can check that the run-time system under which your program is running supports multi-threading by a call to CBL_THREAD_SELF.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines
Related tasks
Using CBL_THREAD_SELF to Check Operating System


CBL_THREAD_SLEEP

Causes the calling thread to give up control to the processor for the given number of milliseconds.

Syntax:

call "CBL_THREAD_SLEEP" using by value milliseconds

Parameters:

 | Using call prototype (see Key) | Picture
milliseconds | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

milliseconds Number of milliseconds

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

If the operating system does not support yielding a thread for millisecond granularity, then the units are scaled to a granularity that the operating system supports. The scaling is performed rounding to the nearest operating system supported unit.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_UNLOCK

Unlocks most functions of the thread handling routines.

Syntax:

call "CBL_THREAD_UNLOCK"

Parameters:

None.

On Exit:

return-code A value indicating success or otherwise. See RETURN-CODE Values For Thread-control Routines

Comments:

This routine can also be used to synchronize access to global or external data, id-data and error handling.

Any thread that obtains a CBL_THREAD_LOCK must not exit before doing a CBL_THREAD_UNLOCK.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_WAIT

Waits for completion of the specified non-detached thread, or returns immediately if the thread has already completed.

Syntax:

call "CBL_THREAD_WAIT" using by value thread-id
                       by reference   thr-return
                       returning      status-code

Parameters:

 | Using call prototype (see Key) | Picture
thread-id | cblt-pointer | usage pointer.
thr-return | cblt-pointer | usage pointer.

On Entry:

thread-id A pointer to the thread identifier

On Exit:

thr-return | The thread's return value.
status-code | See RETURN-CODE Values For Thread-control Routines

Comments:

The behavior of this routine is undefined if:

  • thread-id is invalid.
  • thread-id specifies a previously detached thread.
  • Two threads attempt to use CBL_THREAD_WAIT and/or CBL_THREAD_DETACH on the same thread at the same time.
  • While in a CBL_THREAD_WAIT, the target thread is killed by CBL_THREAD_KILL.

If the routine is successful, the thread's return value is stored in thr-return, the target thread is detached, and the call returns 0.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


CBL_THREAD_YIELD

Yields the rest of the current thread's timeslice.

Syntax:

call "CBL_THREAD_YIELD"

Parameters:

None.

On Exit:

return-code A value indicating whether the routine has succeeded or not. See RETURN-CODE Values For Thread-control Routines

Comments:

If possible this routine yields to other threads in the same process, but might yield to a thread in a different process.

Parent topic: Thread-control Routines
Parent topic: Alphabetical List of Library Routines


RETURN-CODE Values For Thread-control Routines

The following values are provided as RETURN-CODE values from the thread-control routines:

0 | No error was encountered.
1000 | Memory allocation error.
1001 | The thread is invalid. The handle is not a valid handle for the synchronization object, and no operations are valid on it. It is possible that the handle specified was once valid but it has been closed and memory reused.
1002 | The thread has been closed. No operations are valid on this handle. The handle was once valid but has since been closed.
1003 | The thread is detached. CBL_THREAD_DETACH cannot detach the thread since it has already been detached. CBL_THREAD_WAIT cannot wait on the thread since it has already been detached.
1004 | Too many threads. CBL_THREAD_CREATE cannot create another thread since too many threads exist in the system already.
1005 | The stack size is invalid. CBL_THREAD_CREATE cannot create this thread as the operating system will not allow the provided stack size to be used.
1006 | Invalid operation. CBL_THREAD_CREATE cannot create a thread while the system is deinitializing. or: An invalid thread-control routine was attempted on a thread that was not created with CBL_THREAD_CREATE. or: CBL_THREAD_PROG_LOCK was not called directly or indirectly from a COBOL program.
1007 | A system error was encountered. The last operation caused a system error in low level object manipulation.
1008 | Threading not supported in this run-time system. A threaded application attempted to use a multi-threading routine while running with a non-threaded run-time system.
1009 | Invalid parameter passed into a multi-threading library routine. A parameter has been detected that is not within the valid range, or that is inconsistent with the library routine.
1010 | No resources available. A semaphore or mutex cannot be acquired because its count is zero and the user requested no automatic wait. or: An event is not posted and the user has no wait on the CBL_EVENT_WAIT call.
1011 | Program or entry-point name not found. The program or entry-point name specified to CBL_THREAD_CREATE was not found, or there was an error loading it.
Parent topic: Thread-control Routines


Using the Program Thread-locking Routines

The following code at the entry to a program ensures that only the first thread entering a program will initialize data and all following threads will have that preinitialized data available:

if  first-time = 0
         call "cbl_thread_prog_lock"
        if  first-time = 0
             initialize my-data-division
            move 1 to first-time
        end-if
        call "cbl_thread_prog_unlock"
    end-if

Note the double check of the first-time variable. The first check is an optimization that avoids the overhead of locking the program if we know for sure that it has already been initialized.

Parent topic: Thread-control Routines


Using CBL_THREAD_SELF to Check Operating System

You can use CBL_THREAD_SELF to check that the operating system supports multi-threading as follows:

call 'cbl_thread_self' using thread-id
     on exception
         *> no cbl_thread api support
     end-call
     if  return-code = 1008
         *> running in a single threaded only rts
     end-if
Parent topic: Thread-control Routines
Related reference
CBL_THREAD_SELF


Synchronization Routines

Mutexes, semaphores, monitors and events can be used to synchronize threads. Synchronization objects are named, and the name is visible throughout the system, not just in the creating process.

  • Synchronization Routines - Monitors
  • Synchronization Routines - Semaphores
  • Synchronization Routines - Mutexes
  • Synchronization Routines - Events
  • RETURN-CODE Values For Synchronization Routines
Parent topic: Multi-threading Routines


Synchronization Routines - Monitors

Note: These routines are not supported in JVM COBOL.
  • Monitors - General Notes
  • CBL_MONITOR_BROWSE
    Acquires the specified monitor's browse capability for the current thread, blocking until that capability can be acquired.
  • CBL_MONITOR_BROWSE_TO_READ
    Converts monitor browse capability already acquired by the current thread to read capability.
  • CBL_MONITOR_BROWSE_TO_WRITE
    Converts monitor browse capability already acquired by the current thread to write capability, blocking until this can be achieved.
  • CBL_MONITOR_CLOSE
    Closes the supplied monitor handle.
  • CBL_MONITOR_OPEN_INTRA
    Creates a monitor synchronization object for thread synchronization within one process.
  • CBL_MONITOR_READ
    Acquires the specified monitor's read capability for the current thread/process, blocking until that capability can be acquired.
  • CBL_MONITOR_RELEASE
    Releases any lock currently applied to the specified monitor by CBL_MONITOR_WRITE, CBL_MONITOR_READ or CBL_MONITOR_BROWSE.
  • CBL_MONITOR_UNBROWSE
    Releases the monitor's browse capability that was acquired by CBL_MONITOR_BROWSE or CBL_MONITOR_WRITE_TO_BROWSE.
  • CBL_MONITOR_UNREAD
    Releases the monitor's read capability that was acquired by CBL_MONITOR_READ or CBL_MONITOR_BROWSE_TO_READ.
  • CBL_MONITOR_UNWRITE
    Releases the monitor's write capability that was acquired by CBL_MONITOR_WRITE or CBL_MONITOR_BROWSE_TO_WRITE.
  • CBL_MONITOR_WRITE
    Acquires the specified monitor's write capability for the current thread, blocking until that capability can be acquired.
  • CBL_MONITOR_WRITE_TO_BROWSE
    Converts monitor write capability already acquired by the current thread to browse capability.
Parent topic: Synchronization Routines
Related information
Synchronization Routines
RETURN-CODE Values For Synchronization Routines


Monitors - General Notes

A monitor is a synchronization object which can be locked for read, browse, and write operations. This type of synchronization is typically used to protect a data structure in which different threads might want to read and write.

A monitor can only be used as an intra-process synchronization object.

Any monitors created or opened using the library routines are automatically closed when the run-time system terminates (for example, as a consequence of a STOP RUN).

A write lock locks out all other read, browse, and write locks. Typically, a write lock is used when writing to the data structure.

A browse lock locks out other write and browse locks, but allows simultaneous read locks. Typically, a browse lock is used when reading a data structure with a view to writing to it depending on the results of the read. To this end, a function is provided to convert a browse lock to a write lock without letting in any other writers.

A read lock only locks out write locks. Typically, a read lock is used when reading a data structure without any intention of writing to it.

A thread that has acquired a read lock on a particular monitor might acquire another read lock on the same monitor. However, when a read lock has been acquired, the thread may not request a browse or write lock, unless an "outer" browse or write lock exists in which the read lock is nested. Any attempt to break this rule will result in an run-time system error. When interleaved priority is requested on a monitor it is possible that a nested read lock will block waiting for a writer to finish his request, but since the first read lock is still active, the writer will never be granted write access - this is single thread deadlock. If you expect nested read locks to be obtained then either use reader priority or obtain a write or browse lock at the highest level of locking.

A thread that has acquired a browse lock on a particular monitor may acquire another browse lock on the same monitor. It may also acquire a write lock. It may also acquire a read lock, as long as that read lock is released before the original browse lock is converted into a write lock, and before any write lock is requested.

A thread that has acquired a write lock on a particular monitor may also acquire another write, browse or read lock on the same monitor.

Parent topic: Synchronization Routines - Monitors


CBL_MONITOR_BROWSE

Acquires the specified monitor's browse capability for the current thread, blocking until that capability can be acquired.

Syntax:

call "CBL_MONITOR_BROWSE" using by value monitor-handle

Parameters:

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer | usage pointer.

On Entry:

monitor-handle The monitor handle.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

If the thread terminates abnormally, all monitors acquired by that thread are released. If the thread terminates normally with monitors acquired, then either these are released or a run-time system error is given, depending on the flag setting when the thread was created with CBL_THREAD_CREATE.

Behavior is undefined if monitor-handle is invalid.

Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


CBL_MONITOR_BROWSE_TO_READ

Converts monitor browse capability already acquired by the current thread to read capability.

Syntax:

call "CBL_MONITOR_BROWSE_TO_READ" using by value monitor-handle

Parameters:

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer | usage pointer.

On Entry:

monitor-handle The monitor handle.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

Behavior is undefined if:

  • No previous browse lock was obtained by this thread on the specified monitor
  • monitor-handle is invalid.
Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


CBL_MONITOR_BROWSE_TO_WRITE

Converts monitor browse capability already acquired by the current thread to write capability, blocking until this can be achieved.

Syntax:

call "CBL_MONITOR_BROWSE_TO_WRITE" using by value monitor-handle

Parameters:

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer | usage pointer.

On Entry:

monitor-handle The monitor handle.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

Behavior is undefined if:

  • No previous browse lock was obtained by this thread on the specified monitor
  • monitor-handle is invalid.
Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


CBL_MONITOR_CLOSE

Closes the supplied monitor handle.

Syntax:

call "CBL_MONITOR_CLOSE" using by value monitor-handle

Parameters:

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer | usage pointer.

On Entry:

monitor-handle The monitor handle.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

If this process is the last process that has a handle to the monitor, then the monitor is destroyed.

Behavior is undefined if monitor-handle is invalid.

Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


CBL_MONITOR_OPEN_INTRA

Creates a monitor synchronization object for thread synchronization within one process.
Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_MONITOR_OPEN_INTRA" using by reference monitor-handle
                              by value           open-flags

Parameters

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer | usage pointer.
open-flags | cblt-os-flags | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

open-flags
A value indicating the priority algorithm used to grant locks:
Bit 0
0 | Readers and writers have interleaved priority; that is, if a write request is issued, any further read requests will block until the first write request is granted and finished
1 | Read requests always have priority, possibly leading to writer starvation.
Remaining bits
Reserved and should be set to zero.

On Exit:

monitor-handle
The monitor handle.
return-code
A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

If open-flags bit 0 is set to 0, and nested read locks are requested, then single thread deadlock is possible.

Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


CBL_MONITOR_READ

Acquires the specified monitor's read capability for the current thread/process, blocking until that capability can be acquired.

Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_MONITOR_READ" using by value monitor-handle

Parameters:

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer | usage pointer.

On Entry:

monitor-handle A monitor name.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

If the thread terminates abnormally, all monitors acquired by that thread are released. If the thread terminates normally with monitors acquired, then either these are released or a run-time system error is given, depending on the flag setting when the thread was created with CBL_THREAD_CREATE.

Behavior is undefined if monitor-handle is invalid.

Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


CBL_MONITOR_RELEASE

Releases any lock currently applied to the specified monitor by CBL_MONITOR_WRITE, CBL_MONITOR_READ or CBL_MONITOR_BROWSE.

Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_MONITOR_RELEASE" using by value monitor-handle

Parameters:

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer | usage pointer.

On Entry:

monitor-handle The monitor handle.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

If the thread terminates abnormally, all monitors acquired by that thread are released. If the thread terminates normally with monitors acquired, then either these are released or a run-time system error is given, depending on the flag setting when the thread was created with CBL_THREAD_CREATE.

Behavior is undefined if either monitor-handle is invalid or no previous lock was obtained by this thread on the specified monitor.

Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


CBL_MONITOR_UNBROWSE

Releases the monitor's browse capability that was acquired by CBL_MONITOR_BROWSE or CBL_MONITOR_WRITE_TO_BROWSE.

Syntax:

call "CBL_MONITOR_UNBROWSE" using by value monitor-handle

Parameters:

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer | usage pointer.

On Entry:

monitor-handle A space-terminated or null-terminated monitor name.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

Behavior is undefined if either monitor-handle is invalid or no previous browse lock was obtained by this thread on the specified monitor.

Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


CBL_MONITOR_UNREAD

Releases the monitor's read capability that was acquired by CBL_MONITOR_READ or CBL_MONITOR_BROWSE_TO_READ.

Syntax:

call "CBL_MONITOR_UNREAD" using by value monitor-handle

Parameters:

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer. | usage pointer.

On Entry:

monitor-handle A space-terminated or null-terminated monitor name.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

Behavior is undefined if either monitor-handle is invalid or no previous browse lock was obtained by this thread on the specified monitor.

Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


CBL_MONITOR_UNWRITE

Releases the monitor's write capability that was acquired by CBL_MONITOR_WRITE or CBL_MONITOR_BROWSE_TO_WRITE.

Syntax:

call "CBL_MONITOR_UNWRITE" using by value monitor-handle

Parameters:

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer. | usage pointer.

On Entry:

monitor-handle A space-terminated or null-terminated monitor name.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

Behavior is undefined if either monitor-handle is invalid or no previous browse lock was obtained by this thread on the specified monitor.

Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


CBL_MONITOR_WRITE

Acquires the specified monitor's write capability for the current thread, blocking until that capability can be acquired.

Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_MONITOR_WRITE" using by value monitor-handle

Parameters:

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer. | usage pointer.

On Entry:

monitor-handle A space-terminated or null-terminated monitor name.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

If the thread terminates abnormally, all monitors acquired by that thread are released. If the thread terminates normally with monitors acquired, then either these are released or a run-time system error is given, depending on the flag setting when the thread was created.

Behavior is undefined if monitor-handle is invalid.

Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


CBL_MONITOR_WRITE_TO_BROWSE

Converts monitor write capability already acquired by the current thread to browse capability.

Syntax:

call "CBL_MONITOR_WRITE_TO_BROWSE" using by value monitor-handle

Parameters:

 | Using call prototype (see Key) | Picture
monitor-handle | cblt-pointer. | usage pointer.

On Entry:

monitor-handle A space-terminated or null-terminated monitor name.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

Behavior is undefined if either monitor-handle is invalid or no previous browse lock was obtained by this thread on the specified monitor.

Parent topic: Synchronization Routines - Monitors
Parent topic: Alphabetical List of Library Routines


Synchronization Routines - Semaphores

  • Semaphores - General Notes
  • CBL_SEMAPHORE_ACQUIRE
    Acquires one of the resources represented by the semaphore by decrementing the associated count.
  • CBL_SEMAPHORE_CLOSE
    Closes the specified semaphore.
  • CBL_SEMAPHORE_OPEN_INTRA
    Creates an intra-process semaphore.
  • CBL_SEMAPHORE_RELEASE
    Releases one of the resources represented by the semaphore by incrementing the associated count.
Parent topic: Synchronization Routines
Related information
RETURN-CODE Values For Synchronization Routines
Synchronization Routines


Semaphores - General Notes

Semaphores can be used for thread synchronization within the same process.

A semaphore is a synchronization object which has a count associated with it, typically representing the available number of some limited resource. A thread acquires one of these resources by using the acquire call; if none of the resources is available, the call either blocks or returns with an error depending on a "wait" option. If a resource is available (the count is non-zero), the count is decremented and the call returns with no error.

A thread releases a resource using the release call, which increments the count; if other threads are blocked because no resources are available (the count is zero), one of them is released. The others remain blocked because in the process of releasing the first one, the count is decremented back to zero.

Parent topic: Synchronization Routines - Semaphores


CBL_SEMAPHORE_ACQUIRE

Acquires one of the resources represented by the semaphore by decrementing the associated count.
Restriction: This routine is not currently supported in COBOL for JVM.

Syntax:

call "CBL_SEMAPHORE_ACQUIRE" using by value semaphore-handle
                                   by value flags
                                  [by value timeout]

Parameters:

 | Using call prototype (see Key) | Picture
semaphore-handle | cblt-pointer | usage pointer
flags | cblt-os-flags | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
timeout |  | pic x(4) comp-5

On Entry:

semaphore-handle
Semaphore handle.
flags
A value that determines the action of the routine if the count is zero:
Bit 0
0 Block the thread/process until the count is non-zero, then the count is decremented and the call returns.
1

If no timeout is supplied (i.e. bit 1 = 0) then return immediately, no decrement

If timeout supplied (i.e. bit 1=1 ) then block until count is non-zero or timeout duration has expired. If the timeout expires, return error code 1010 ("no resources available"), else decrement count and return

Bit 1
0 | No timeout parameter supplied
1 | Timeout parameter is supplied and used if bit 0=1
Remaining bits
Reserved. Must be set to zero.
timeout
The timeout value in milliseconds. A value of zero returns immediately. This parameter is mandatory if bit 1=1 for the flags parameter; otherwise, it is optional.

On Exit:

return-code
A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines

Comments:

Behavior is undefined if semaphore-handle is invalid.

Parent topic: Synchronization Routines - Semaphores
Parent topic: Alphabetical List of Library Routines


CBL_SEMAPHORE_CLOSE

Closes the specified semaphore.

Syntax:

call "CBL_SEMAPHORE_CLOSE" using by value semaphore-handle

Parameters:

semaphore-handle pointer

On Entry:

semaphore-handle Semaphore handle.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines

Comments:

The semaphore is destroyed.

Behavior is undefined if semaphore-handle is invalid.

Parent topic: Synchronization Routines - Semaphores
Parent topic: Alphabetical List of Library Routines


CBL_SEMAPHORE_OPEN_INTRA

Creates an intra-process semaphore.
Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_SEMAPHORE_OPEN_INTRA" using by reference semaphore-handle
                                by value           semaphore-start
                                by value           open-flags

Parameters:

 | Using call prototype (see Key) | Picture
semaphore-handle | cblt-pointer | usage pointer.
semaphore-start | cblt-x4-comp5 | pic x(4) comp-5.
open-flags | cblt-os-flags | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

semaphore-start | Initial count for the semaphore.
open-flags | Reserved. Should be set to zero.

On Exit:

semaphore-handle | Semaphore handle.
return-code | A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines

Comments:

None.

Parent topic: Synchronization Routines - Semaphores
Parent topic: Alphabetical List of Library Routines


CBL_SEMAPHORE_RELEASE

Releases one of the resources represented by the semaphore by incrementing the associated count.

Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_SEMAPHORE_RELEASE" using by value semaphore-handle

Parameters:

 | Using call prototype (see Key) | Picture
semaphore-handle | cblt-pointer | usage pointer.

On Entry:

semaphore-handle Semaphore handle.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines

Comments:

If the count was zero before the increment, and some other threads are blocked in a CBL_SEMAPHORE_ACQUIRE call waiting for the count to become non-zero, then one of those threads is released, so it can decrement the count and return from CBL_SEMAPHORE_ACQUIRE.

Behavior is undefined if semaphore-handle is invalid.

Parent topic: Synchronization Routines - Semaphores
Parent topic: Alphabetical List of Library Routines


Synchronization Routines - Mutexes

Mutexes, semaphores, monitors and events can be used to synchronize threads. Synchronization objects are named, and the name is visible throughout the system, not just in the creating process.

  • Mutexes - General Notes
  • CBL_MUTEX_ACQUIRE
    Acquires a mutex for the specified thread.
  • CBL_MUTEX_CLOSE
    Closes the specified mutex.
  • CBL_MUTEX_OPEN_INTRA
    Create an intra-process mutex.
  • CBL_MUTEX_RELEASE
    Releases the specified mutex.
Parent topic: Synchronization Routines
Related information
RETURN-CODE Values For Synchronization Routines
Synchronization Routines


Mutexes - General Notes

Mutexes can be used for thread synchronization within the same process.

Mutexes are implemented where possible by calling the operating system directly, thus they give lower level functionality than monitors.

A mutex is a synchronization object which at any one time zero or one thread "owns". If a thread has acquired a mutex, and another thread requests it, depending on a "wait" option, the second thread either returns without acquiring the mutex, or blocks until the first thread has released it. If several threads are blocked waiting for the mutex, only one of them is unblocked; all the others continue to wait.

Parent topic: Synchronization Routines - Mutexes


CBL_MUTEX_ACQUIRE

Acquires a mutex for the specified thread.
Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_MUTEX_ACQUIRE" using by value mutex-handle
                               by value nowait-flag

Parameters:

 | Using call prototype (see Key) | Picture
mutex-handle | cblt-pointer. | usage pointer.
nowait-flag | cblt-os-flags. | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

mutex-handle
Mutex handle
nowait-flag
A number that determines what happens if the mutex cannot be acquired immediately:
Bit 0
0 | The routine blocks the thread/process until the mutex can be acquired .
1 | The routine returns immediately with a non-zero return value.
Remaining bits
Reserved. Must be set to zero.

On Exit:

return-code
A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

Behavior is undefined if mutex-handle is invalid.

Parent topic: Synchronization Routines - Mutexes
Parent topic: Alphabetical List of Library Routines


CBL_MUTEX_CLOSE

Closes the specified mutex.

Syntax:

call "CBL_MUTEX_CLOSE" using by value mutex-handle

Parameters:

 | Using call prototype (see Key) | Picture
mutex-handle | cblt-pointer. | usage pointer.

On Entry:

mutex-handle Mutex handle

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

The mutex is destroyed.

Behavior is undefined if mutex-handle is invalid.

Parent topic: Synchronization Routines - Mutexes
Parent topic: Alphabetical List of Library Routines


CBL_MUTEX_OPEN_INTRA

Create an intra-process mutex.
Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_MUTEX_OPEN_INTRA" using by reference mutex-handle
                            by value           open-flags

Parameters:

 | Using call prototype (see Key) | Picture
mutex-handle | cblt-pointer. | usage pointer.
open-flags | cblt-os-flags. | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)

On Entry:

open-flags
A value that determines how the mutex is to be opened:
Bit 0
0 | Mutex is not acquired by the current thread at creation.
1 | Mutex is acquired by the current thread at creation.
Remaining bits
Reserved. Set to zero

On Exit:

mutex-handle
Mutex handle
return-code
A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

mutex-handle is local to the process.

Parent topic: Synchronization Routines - Mutexes
Parent topic: Alphabetical List of Library Routines


CBL_MUTEX_RELEASE

Releases the specified mutex.

Syntax:

call "CBL_MUTEX_RELEASE" using by value mutex-handle

Parameters:

 | Using call prototype (see Key) | Picture
mutex-handle | cblt-pointer. | usage pointer.

On Entry:

mutex-handle Mutex handle

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines.

Comments:

If one or more threads are blocked in a CBL_MUTEX_ACQUIRE routine waiting for this mutex, one of them unblocks and returns from its call with the mutex acquired.

Behavior is undefined if either the current thread has not acquired the mutex or mutex-handle is invalid.

Parent topic: Synchronization Routines - Mutexes
Parent topic: Alphabetical List of Library Routines


Synchronization Routines - Events

  • Events - General Notes
  • CBL_EVENT_CLEAR
    Clears the specified event.
  • CBL_EVENT_CLOSE
    Closes the supplied event handle.
  • CBL_EVENT_OPEN_INTRA
    Creates an intra-process event.
  • CBL_EVENT_POST
    Posts the specified event.
  • CBL_EVENT_WAIT
    Waits for the event to be posted.
Parent topic: Synchronization Routines
Related information
RETURN-CODE Values For Synchronization Routines
Synchronization Routines


Events - General Notes

Events can be used for thread synchronization within the same process.

Events are implemented where possible by calling the operating system directly, thus they give lower level functionality than monitors.

An event is a synchronization object which can be posted and cleared by different threads. A thread may wait for an event to become posted; if there are several threads waiting when the event becomes posted, all the threads are then allowed to continue.

Parent topic: Synchronization Routines - Events


CBL_EVENT_CLEAR

Clears the specified event.

Syntax:

call "CBL_EVENT_CLEAR" using by value event-handle

Parameters:

 | Using call prototype (see Key) | Picture
event-handle | cblt-pointer | usage pointer.

On Entry:

event-handle The event handle.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines

Comments:

The routine has no effect if the event was already clear.

Behavior is undefined if event-handle is invalid.

Parent topic: Synchronization Routines - Events
Parent topic: Alphabetical List of Library Routines


CBL_EVENT_CLOSE

Closes the supplied event handle.

Syntax:

call "CBL_EVENT_CLOSE" using by value event-handle

Parameters:

 | Using call prototype (see Key) | Picture
event-handle | cblt-pointer | usage pointer.

On Entry:

event-handle The event handle.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines

Comments:

The event is destroyed.

Behavior is undefined if event-handle is invalid.

Parent topic: Synchronization Routines - Events
Parent topic: Alphabetical List of Library Routines


CBL_EVENT_OPEN_INTRA

Creates an intra-process event.
Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_EVENT_OPEN_INTRA" using by reference event-handle
                            by value           open-flags

Parameters:

event-handle
Call prototype (see Key): cblt-pointer
Picture: usage pointer.
open-flags
Call prototype (see Key): cblt-os-flags
Picture: pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only).

On Entry:

open-flags
A number specifying how the event is to be created:
Bit 0
0 | The event is created not posted.
1 | The event is created posted.
Remaining bits
Reserved. Should be set to zero.

On Exit:

event-handle
The event handle
return-code
A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines

Comments:

event-handle is local to the process.

Parent topic: Synchronization Routines - Events
Parent topic: Alphabetical List of Library Routines


CBL_EVENT_POST

Posts the specified event.

Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_EVENT_POST" using by value event-handle

Parameters:

 | Using call prototype (see Key) | Picture
event-handle | cblt-pointer | usage pointer.

On Entry:

event-handle The event handle.

On Exit:

return-code A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines

Comments:

If any threads are waiting for the event to be posted in the CBL_EVENT_WAIT call, they are all allowed to run and hence return from their CBL_EVENT_WAIT calls. The call has no effect if the event was already posted. The call returns zero for success.

Behavior is undefined if event-handle is invalid.

Parent topic: Synchronization Routines - Events
Parent topic: Alphabetical List of Library Routines


CBL_EVENT_WAIT

Waits for the event to be posted.
Note: This routine is not supported in JVM COBOL.

Syntax:

call "CBL_EVENT_WAIT" using by value event-handle
                      by value       nowait-flag

Parameters:

event-handle
Call prototype (see Key): cblt-pointer
Picture: usage pointer.
nowait-flag
Call prototype (see Key): cblt-os-flags
Picture: pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only).

On Entry:

event-handle
The event handle.
nowait-flag
A value that specifies the action to take if the event has not been posted:
Bit 0
0 | The thread blocks until the event is posted, and then returns.
1 | The call returns immediately with an error value
Remaining bits
Reserved. Must be set to zero.

On Exit:

return-code
A value of 0 indicates that the call was successful. Any other value indicates an error. See RETURN-CODE Values For Synchronization Routines

Comments:

If the event is already posted, the call returns immediately.

Behavior is undefined if event-handle is invalid.

Parent topic: Synchronization Routines - Events
Parent topic: Alphabetical List of Library Routines


RETURN-CODE Values For Synchronization Routines

The following values are provided as RETURN-CODE values from the synchronization routines:

0 | No error was encountered.
1000 | Memory allocation error.
1001 | The thread is invalid. The handle is not a valid handle for the synchronization object, and no operations are valid on it. It is possible that the handle specified was once valid but it has been closed and memory reused.
1002 | The thread has been closed. No operations are valid on this handle. The handle was once valid but has since been closed.
1003 | The thread is detached. CBL_THREAD_DETACH cannot detach the thread since it has already been detached. CBL_THREAD_WAIT cannot wait on the thread since it has already been detached.
1004 | Too many threads. CBL_THREAD_CREATE cannot create another thread since too many threads exist in the system already.
1005 | The stack size is invalid. CBL_THREAD_CREATE cannot create this thread as the operating system will not allow the provided stack size to be used.
1006 | Invalid operation. CBL_THREAD_CREATE cannot create a thread while the system is deinitializing. or: An invalid thread-control routine was attempted on a thread that was not created with CBL_THREAD_CREATE. or: CBL_THREAD_PROG_LOCK was not called directly or indirectly from a COBOL program.
1007 | A system error was encountered. The last operation caused a system error in low level object manipulation.
1008 | Threading not supported in this run-time system. A threaded application attempted to use a multi-threading routine while running with a non-threaded run-time system.
1009 | Invalid parameter passed into a multi-threading library routine. A parameter has been detected that is not within the valid range, or that is inconsistent with the library routine.
1010 | No resources available. A semaphore or mutex cannot be acquired because its count is zero and the user requested no automatic wait. or: An event is not posted and the user has no wait on the CBL_EVENT_WAIT call.
1011 | Program or entry-point name not found. The program or entry-point name specified to CBL_THREAD_CREATE was not found, or there was an error loading it.
Parent topic: Synchronization Routines


Routines for Handling Thread-specific Data

The easiest way to handle thread-local data is to use a Thread-Local-Storage Section in your program. It is assumed that you understand the Thread-Local Storage facility.

Library routines are also provided to give you control over the way in which thread-specific data is handled. These routines enable your program to:

  • Allocate thread-local data from the dynamic heap
  • Access thread-local data from an initialized thread-storage handle

Allocating Thread-local Data From the Dynamic Heap

You can allocate thread-local data from the dynamic heap via CBL_ALLOC_MEM or the modular CBL_ALLOC_THREAD_MEM. The advantage of this form of allocation is that multiple memory blocks of varying sizes can be allocated and associated with a thread and/or program.

CBL_ALLOC_MEM can associate allocated heap data with a thread and the calling program. depending on the setting of the input parameters. CBL_ALLOC_THREAD_MEM always associates any allocated heap data with a thread, and optionally the calling program.

Memory allocated by these routines is automatically cleaned-up when the thread terminates.

Note that any pointer to thread-local storage returned by these calls should be saved in a Thread-Local Storage defined pointer, so that its value can be retrieved on subsequent calls to the program that allocated the thread-local storage area. Saving the returned pointer in a Working-Storage defined pointer and subsequently using that value causes the thread local heap area to be shared among threads and is bad programming practice.

Accessing Thread-local Data From an Initialized Thread-storage Handle

Routines are supplied that enable a program to access thread-local data from an initialized thread-storage handle. This handle is returned by the CBL_TSTORE_CREATE routine. Memory is returned by CBL_TSTORE_GET using a specific handle. The memory is of a fixed size and is the same across all invocations of CBL_TSTORE_GET within that thread. These routines provide, in essence, a distinct thread-local-storage area for each initialized handle.

  • CBL_TSTORE_CLOSE
    Closes a handle returned by CBL_TSTORE_CREATE.
  • CBL_TSTORE_CREATE
    Creates a handle for and specifies the size of a thread-storage area. These values can be used in subsequent calls to CBL_TSTORE_GET. The new thread-storage area is initialized to zeroes.
  • CBL_TSTORE_GET
    Gets a pointer to the thread-specific memory specified by CBL_TSTORE_CREATE.
  • Thread-specific Data Handling Routines - Example
  • RETURN-CODE Values For Thread-specific Data Handling Routines
Parent topic: Multi-threading Routines
Related information
Alphabetical List of Library Routines
Multi-threading Routines
Thread-control Routines
RETURN-CODE Values For Thread-control Routines
Synchronization Routines
Routines for Handling Thread-specific Data


CBL_TSTORE_CLOSE

Closes a handle returned by CBL_TSTORE_CREATE.

Syntax:

call "CBL_TSTORE_CLOSE" using by value tstore-handle

Parameters:

 | Using call prototype (see Key) | Picture
tstore-handle | cblt-pointer | usage pointer.

On Entry:

tstore-handle The thread-storage handle

Comments:

This routine closes a handle to a thread-storage area that was returned by CBL_TSTORE_CREATE, freeing all allocated memory for all threads.

Parent topic: Routines for Handling Thread-specific Data
Parent topic: Alphabetical List of Library Routines


CBL_TSTORE_CREATE

Creates a handle for and specifies the size of a thread-storage area. These values can be used in subsequent calls to CBL_TSTORE_GET. The new thread-storage area is initialized to zeroes.

Syntax:

call "CBL_TSTORE_CREATE" using    tstore-handle
                         by value tstore-size
                         by value tstore-flags

Parameters:

 | Using call prototype (see Key) | Picture
tstore-handle | cblt-pointer | usage pointer.
tstore-size | cblt-os-size | picture x(4) comp-5 or pic x(8) comp-5 (64-bit native only)
tstore-flags | cblt-os-flags | picture x(4) comp-5 or pic x(8) comp-5 (64-bit native only)

On Entry:

tstore-size
Size of thread-storage area that will be returned to every thread that calls CBL_TSTORE_GET using the returned handle.
tstore-flags
The type of thread-storage area required:
Bit | Meaning
0 | Reserved, should be set to 0
1 | Reserved, should be set to 0
2 0: Allocate a thread-storage handle. The handle is not independent of the calling program, and is deallocated automatically when the calling program is canceled.

1: Allocate a thread-storage handle that is independent from any calling program. If this bit is set the thread-storage handle will be closed at the end of the run-unit

Remaining bits | Reserved, should be set to 0

On Exit:

tstore-handle
The thread-storage handle.
return-code
Indicates success or otherwise of the routine:
0 | Successful allocation
1000 | Unable to allocate thread storage handle

Comments:

CBL_TSTORE_CREATE specifies the size of the memory block that will be returned by any subsequent calls to CBL_TSTORE_GET and, optionally, associates that handle with the calling program so that when the calling program is canceled the returned handle is automatically closed. In any event the returned handle will be closed at termination of the run-unit or a call to CBL_TSTORE_CLOSE, whichever comes first.

If this thread-storage handle is not associated with a program, then the thread-storage handle is closed at the end of the run-unit.

You should ensure that this routine is called in single-threaded mode by forcing single-threaded behavior within a monitor lock, or by calling it only when initializing the application in single-threaded mode.

Parent topic: Routines for Handling Thread-specific Data
Parent topic: Alphabetical List of Library Routines


CBL_TSTORE_GET

Gets a pointer to the thread-specific memory specified by CBL_TSTORE_CREATE.

Syntax:

call "CBL_TSTORE_GET" using by value tstore-handle
                                     tstore-ptr

Parameters:

 | Using call prototype (see Key) | Picture
tstore-handle | cblt-pointer | usage pointer
tstore-ptr | cblt-pointer | usage pointer

On Entry:

tstore-handle
A non-null handle. This is the handle returned by CBL_TSTORE_CREATE.

On Exit:

tstore-ptr
A pointer to a memory block of the size specified by CBL_TSTORE_CREATE. This pointer is unique to this thread.
return-code
Indicates success or otherwise of the routine:
0 | Success
1000 | Could not get the memory block requested
1001 | Bad handle
1002 | Closed handle

Comments:

Returns a pointer to a block of memory of the size specified by CBL_TSTORE_CREATE. This pointer is unique for each calling thread. A block of memory containing all zeroes indicates that CBL_TSTORE_GET has been run for the first time.

A value is returned in RETURN-CODE, indicating success or otherwise of the routine:

Parent topic: Routines for Handling Thread-specific Data
Parent topic: Alphabetical List of Library Routines


Thread-specific Data Handling Routines - Example

This program initializes a thread-storage handle and then starts off several threads which each use the handle to access thread local data. Consistency checks are made within each entry to ts-test, on termination of each thread and on termination of the run-unit. This program takes advantage of the Thread-Local-Storage Section, external data items, exit procedures and basic synchronization to achieve this function.

Source Code

$set reentrant sourceformat(free)
 copy "cblproto.cpy".

************************************************************
* tstore-main.                                             *
* Main routine to initialize tables and kick off threads.  *
*                                                          *
************************************************************

 program-id. 'tstore'.
 environment division.
 special-names. command-line is cmdln.

 working-storage section.
 78 THREAD-COUNT VALUE 5.

 01 tstore-handle    cblt-pointer is external.
 01 c-0              cblt-x1-compx.
 01 foo-item         pic 9(9) value 0.
 01 thredid          pic xxxx comp-5.
 01 thread-handle    cblt-pointer.
 01 thread-entry     cblt-ppointer.

 01 exitparms        cblt-exit-params.

 thread-local-storage section.
 01 filler.
     05 tl-count pic x value 'x'.
     05 tl-ptr   cblt-pointer.

 linkage section.
 01 tstore-item.
     05 filler       pic x.
       88 TSTORE-INIT VALUE 'Y'.
     05 tstore-count pic 999.

 procedure division.
*>
*> Initialize thread table and set up for clean exit
*>
     call "CBL_TSTORE_CREATE" using         tstore-handle
                            by value length tstore-item
                            by value        h'04'
*>
*> Set up for clean exit
*>
     move low-values  to exitparms
     set cblte-ep-install-addr   to entry 'exitproc'
     move 0    to c-0
     call 'CBL_EXIT_PROC'    using c-0 exitparms

     call 'ts-get'           using tl-ptr
     set address of tstore-item to tl-ptr
     move THREAD-COUNT   to tstore-count
     set thread-entry    to entry "ts-entry"
     move 1    to thredid
     perform THREAD-COUNT times
         call "CBL_THREAD_CREATE_P" using by value thread-entry
           by reference thredid
           by value length of thredid
           by value     0
           by value     0
           by value     0
           by reference thread-handle
         if return-code not = 0
             call 'CBL_THREAD_PROG_LOCK'
             display "FAIL: Cannot create thread"
             call 'CBL_THREAD_PROG_UNLOCK'
             stop run
         end-if
         add 1 to thredid
     end-perform
     stop run.

 entry "exitproc".
     call "CBL_TSTORE_GET" using by value     tstore-handle
                                 by reference tl-ptr
     set address of tstore-item to tl-ptr
     if tl-ptr = NULL
     or not TSTORE-INIT
     or tstore-count not = THREAD-COUNT
         display "FAIL: TSTORE not initialized properly!"
     else
         display "PASS: Main thread has count " tstore-count
     end-if
     call "CBL_TSTORE_CLOSE" using by value tstore-handle
     exit program.

 end program 'tstore'.

************************************************************
*                                                          *
* ts-entry.                                                *
* Root entry point for threads created by application.     *
*                                                          *
************************************************************
 program-id. 'ts-entry'.
 working-storage section.
 78 REP-COUNT VALUE 5.

 01 tl-ptr   cblt-pointer.

 linkage section.
 01 lnk-thredid pic xxxx comp-5.

 01 tstore-item.
     05 filler pic x.
         88 TSTORE-INIT VALUE 'Y'.
     05 tstore-count pic 999.

 procedure division using lnk-thredid.
 thread-section.
     perform REP-COUNT times
         call 'ts-test' using lnk-thredid
     end-perform

     call 'ts-get'  using tl-ptr
     set address of tstore-item to tl-ptr

     call "CBL_THREAD_PROG_LOCK"
     if tstore-count not = REP-COUNT
        display "FAIL: Thread storage rep-count BAD"
     else
        display "PASS: Thread storage rep-count good"
     end-if
     call "CBL_THREAD_PROG_UNLOCK"
     exit program.
 end program 'ts-entry'.

************************************************************
*                                                          *
* ts-test.                                                 *
* Routine to get a thread storage area and increment its   *
* count                                                    *
*                                                          *
************************************************************
 program-id. 'ts-test'.

 working-storage section.
 01 global-count pic 99999 value 0.

 thread-local-storage section.
 01 tl-ptr     cblt-pointer.
 01 tl-count   pic 999 value 0.

 linkage section.
 01 lnk-thredid  pic xxxx comp-5.

 01 tstore-item.
   05 filler   pic x.
       88 TSTORE-INIT VALUE 'Y'.
   05 tstore-count  pic 999.
 procedure division using lnk-thredid.
 thread-section.
     call 'ts-get'   using tl-ptr
     set address of tstore-item    to tl-ptr
     add 1       to tstore-count
     add 1       to tl-count

     if tstore-count not = tl-count
         display "ERROR: inconsistent thread local data"
         stop run
     end-if

     call "CBL_THREAD_PROG_LOCK"
     add 1 to global-count
     display "MESSAGE: thread-test has been called " tstore-count
         " by thread " lnk-thredid
     display "MESSAGE: thread-test has been called " global-count " globally "
     call "CBL_THREAD_PROG_UNLOCK"

     exit program.

 end program 'ts-test'.

************************************************************
* ts-get.                                                  *
* Common routine to get and initialize the thread storage  *
* area allocated by CBL_TSTORE_GET.                        *
*                                                          *
************************************************************
 program-id. 'ts-get'.
 data division.
 working-storage section.
 01 tstore-handle cblt-pointer external.

 thread-local-storage section.
 01 tl-ptr    cblt-pointer.

 linkage section.
 01 tstore-item.
     05 filler       pic x.
         88 TSTORE-INIT VALUE 'Y'.
     05 tstore-count pic 999.
 01 lnk-ptr usage pointer.

 procedure division using lnk-ptr.
     call "CBL_TSTORE_GET" using by value     tstore-handle
                                 by reference tl-ptr
     if tl-ptr = NULL
         display "FAIL: Error in getting thread " &
                 "storage data"
         stop run
     end-if
     set address of tstore-item to tl-ptr
     if not TSTORE-INIT
         move 0 to tstore-count
     end-if
     set tstore-init to true
     set lnk-ptr to tl-ptr

 exit program.

 end program 'ts-get'.
Parent topic: Routines for Handling Thread-specific Data


RETURN-CODE Values For Thread-specific Data Handling Routines

The following values are provided as RETURN-CODE values from the thread-specific data handling routines:

0 | No error was encountered.
1000 | Memory allocation error.
1001 | Thread-storage handle is invalid. No operations are valid on this thread-storage handle. It is possible that the handle specified was once valid but it has been closed and the memory reused.
1002 | Thread-storage handle is invalid. The thread storage handle has previously been closed and is no longer valid.
1009 | Invalid parameter passed into a thread-specific data-handling library routine. A parameter has been detected as being out of valid ranges or inconsistent with the library routine.
1010 | Resource busy. A synchronization object was still locked upon thread termination and when the thread was created the user requested an error to be reported if this condition occurred.
Parent topic: Routines for Handling Thread-specific Data


NLS Message-file Handling Routines

  • CBL_NLS_COMPARE
    Compares two strings.
  • CBL_NLS_INFO
    Gets/sets national language information.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_NLS_COMPARE

Compares two strings.

Syntax:

call "CBL_NLS_COMPARE" using        string1
                                    string2
                       by value     string1-length
                       by value     string2-length
                       by reference result-byte
                       returning    status-code

Parameters:

 | Using call prototype (see Key) | Picture
string1 | pic x(n). | pic x(n).
string2 | pic x(n). | pic x(n).
string1-length | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
string2-length | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
result-byte | cblt-sx1-comp5 | pic s9(2) comp-5.
status-code | See Library Routines - Key |

On Entry:

string1
The first string.
string2
The second string.
string1-length
Length of the first string.
string2-length
Length of the second string.

On Exit:

result-byte
Result of the comparison:
0 | The two strings are the same
-1 | string1 < string2
+1 | string1 > string2
status-code
Indicates whether the routine was successful:
0 | Success
105 | Memory allocation error
Parent topic: Using NLS Library Routines in Your Programs
Parent topic: NLS Message-file Handling Routines
Parent topic: Alphabetical List of Library Routines


CBL_NLS_INFO

Gets/sets national language information.

Syntax:

call "CBL_NLS_INFO" using     function-code
                              info-category
                              info-buffer
                    returning status-code

Parameters:

function-code
Call prototype (see Key): cblt-x1-compx.
Picture: pic x comp-x.
Contains one of the following:
1 | Get national language information
2 | Set national language information
info-category
Call prototype (see Key): cblt-x1-compx.
Picture: pic x comp-x.
info-buffer
Call prototype (see Key): pic x(n).
Picture: pic x(n).
status-code
See Library Routines - Key

On Entry:

With function-code = 1
info-category
Category of information to get from the NLS module:
1 | Currency symbol
2 | Thousands separator
3 | Decimal separator
With function-code = 2
info-category
Category of information to set:
1 | Currency symbol
2 | Thousands separator
3 | Decimal separator
info-buffer
Information to set (null-terminated). The thousands and decimal separators are each one character long. The currency symbol is up to 10 characters long.

On Exit:

With function-code = 1
info-category
Category of information to get from the NLS module:
1 | Currency symbol
2 | Thousands separator
3 | Decimal separator
status code
Indicates whether the routine was successful:
0 | Success
164 | Invalid parameter specified
200 | Internal error
With function-code = 2
info-category
Category of information to set:
1 | Currency symbol
2 | Thousands separator
3 | Decimal separator
info-buffer
Information to set (null-terminated). The thousands and decimal separators are each one character long. The currency symbol is up to 10 characters long.
status code
Indicates whether the routine was successful:
0 | Success
164 | Invalid parameter specified
200 | Internal error

Comments:

This routine enables you to both get and set information about the national language. With function-code = 2 (set information) the change made applies only to the program that made the call.

Parent topic: Using NLS Library Routines in Your Programs
Parent topic: NLS Message-file Handling Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
NLS
NLS Message-file Handling Routines


Operating System Information Routines

  • CBL_GET_OS_INFO
    Returns information about the operating system environment.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_GET_OS_INFO

Returns information about the operating system environment.

Syntax:

call "CBL_GET_OS_INFO" using     parameter-block
                       returning status-code

Parameters

parameter-block
Group predefined as cblt-os-info-params containing
01 cblt-os-info-params               typedef.
  03 cblte-osi-length                cblt-x2-compx.	 *> pic x(2) comp-x value 28.
  03 cblte-osi-os-type               cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-osi-os-version            cblt-x4-compx. 	*> pic x(4) comp-x.
  03 cblte-osi-dbcs-support          cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-osi-char-coding           cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-osi-country-id            cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-osi-code-page             cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-osi-process-type          cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-osi-rts-capabilities      cblt-x4-compx. 	*> pic x(4) comp-x.
  03 cblte-osi-product               cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-osi-product-version       cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-osi-product-revision      cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-osi-product-sp            cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-osi-fixpack               cblt-x2-compx. 	*> pic x(2) comp-x.
status-code
See Library Routines - Key.

On Entry:

cblte-osi-os-length
Length of the information expected to be returned.

On Exit:

cblte-osi-os-length
Length of the information returned; this can be less than or equal to the length on entry
cblte-osi-os-type
131 for Windows systems, 128 for COBOL systems on UNIX
cblte-osi-os-version
Use is specific to the operating system. Can include information such as chip type and the operating system version number. For Windows the third and fourth bytes contain the minor and major release operating system version numbers respectively.
cblte-osi-dbcs-support
DBCS support flag:
Bit 0
0 | if DBCS validation unsupported
1 | if DBCS validation supported
Bit 1
0 | if PIC N data-type unsupported
1 | if PIC N data-type supported
cblte-osi-char-coding
Character encoding:
0 | ASCII
1 | Shift-JIS
2 | EUC Japan
3 | BIG-5 (Traditional Chinese)
4 | 5550 (Traditional Chinese)
5 | GB (Simplified Chinese)
6 | KS-CODE (Korean)
7 | PC-CODE (Korean)
8 | EUC Taiwan
9 | Other EUC locales
cblte-osi-country-id

Country code. See your operating system documentation for an explanation of country codes.

cblte-osi-code-page

Code page. See your operating system documentation for an explanation of code page codes.

cblte-osi-process-type
Process type:
0 | Process is running in a full screen session
3 | Process is running as a true graphical application
cblte-osi-rts-capabilities
Characteristics of run-time system. Set as follows:
Bit | Description
0

multi-threading multi-threaded rts

1 | Mainframe offloading capabilities, namely mainframe pointer emulation
2 | 64-bit capability; the run-time system supports the running of 64-bit applications
3 | Indicates whether the program is running under the control of Enterprise Server
4 | Indicates that the run-time system is running in Enterprise Server mode
5 | Indicates whether the program is running under the CLR (Common Language Runtime)
6-31 | Reserved for future use and will be set to 0 by this routine
cblte-osi-product
Product identifier:
0 | Unknown (backward compatibility)
1 | Server Express
2 | Net Express
3 | Mainframe Express (up to V3.0)
4 | Mainframe Express (V3.01 or later)
5 | Studio Enterprise Edition
cblte-osi-product-version
Product version, for example, for the COBOL development system 4.0, this field would be set to 4
cblte-osi-product-revision
Product revision, for example, for the COBOL development system 4.5, this field would be set to 5
cblte-osi-product-sp
Product service pack level, for example, for Server Express 4.0 Service Pack 1, this field would be set to 1
cblte-osi-fixpack
On Windows this field indicates the RTS fixpack version, for example, for the COBOL development system 4.0 RTS09N40 FixPack, this field would be set to 9. On UNIX, where individual component fixpacks are not provided, this field indicates the product fixpack version.
Parent topic: Operating System Information Routines
Parent topic: Alphabetical List of Library Routines


Portability Routines

Restriction: This routine is supported for native COBOL only.

This routine is provided to help you make existing applications portable to other environments. It should not be used in new applications where alternative mechanisms are provided.

  • CBL_SCR_SET_PC_ATTRIBUTES
    Sets up the current COBOL attribute table so as to emulate, as closely as possible, the IBM-PC attribute table.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_SCR_SET_PC_ATTRIBUTES

Sets up the current COBOL attribute table so as to emulate, as closely as possible, the IBM-PC attribute table.
Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_SCR_SET_PC_ATTRIBUTES" returning status-code

Parameters:

status-code See Library Routines - Key

On Entry:

None

On Exit:

status-code See Library Routines - Key
status-code The return status:
0
Successful.
1
Successful, but one or more colors not exact.
2
Failed.

Comments:

Using this routine is equivalent to setting the entire IBM-PC attribute table using the generic attribute routines. It is provided to enable you to apply generic attributes to existing programs, making their attribute handling portable. However, this routine is inefficient because it defines every possible attribute. For new applications use the generic attribute routines and define only the attributes you need.

Parent topic: Portability Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
Display Attribute Routines
Portability Routines


Printer Routines

The printer handling routines enable greater control over printing than the standard COBOL syntax.

  • PC_PRINT_FILE
    Prints the contents of the specified file, optionally displaying printer control, font, and progress indicator dialog boxes, before commencing the print.
  • PC_PRINTER_CLOSE
    Closes a previously opened printer channel.
  • PC_PRINTER_CONTROL
    Sends a print command to a printer.
  • PC_PRINTER_DEFAULT_FONT
    Sets the default font for all PC_PRINTER_ routines.
  • PC_PRINTER_DEFAULT_NAME
    Sets the default printer for all PC_PRINTER_ routines.
  • PC_PRINTER_DEFAULT_PROPERTIES
    Sets one or more of the properties of the default printer for all PC_PRINTER_ routines.
  • PC_PRINTER_DRAW_RECTANGLE
    Draws an outline or filled rectangle at position start-x,start-y to end-x,end-y.
  • PC_PRINTER_ENUM_CLOSE
    Ends the process of enumerating printers.
  • PC_PRINTER_ENUM_NEXT
    Gets the name of the next enumerated printer.
  • PC_PRINTER_ENUM_START
    Starts the process of enumerating printers.
  • PC_PRINTER_FREE_BMP
    Frees a bitmap from memory, releasing its image and palette back to the operating system.
  • PC_PRINTER_GET_BMP_INFO
    Retreives the height and width of loaded bitmap
  • PC_PRINTER_GET_COLOR
    Gets the color on the printer.
  • PC_PRINTER_GET_FONT
    Gets the font on the printer.
  • PC_PRINTER_INFO
    Returns a native device context handle, and other information that can be used to enhance the printing of a document by calling native graphics functions directly.
  • PC_PRINTER_LINE_FROM_TO
    Draws a line from start-x,start-y to end-x,end-y.
  • PC_PRINTER_LOAD_BMP
    Loads a bitmap or other supported file format into memory ready for the PC_PRINTER_WRITE_BMP function.
  • PC_PRINTER_OPEN
    Opens a printer channel, giving it a document title, and optionally displaying printer control, font, and progress indicator dialog boxes
  • PC_PRINTER_REDIRECTION_PROC
    Registers a user function that is called when a program uses OPEN OUTPUT syntax and the ASSIGN TO PRINTER clause.
  • PC_PRINTER_SET_BACKGROUND_MIX_MODE
    Sets background printing mode.
  • PC_PRINTER_SET_COLOR
    Sets the color on the printer.
  • PC_PRINTER_SET_DEFAULT
    Sets a process-wide default printer before a printer is opened.
  • PC_PRINTER_SET_FONT
    Sets the current font for the printer.
  • PC_PRINTER_SET_PEN
    Set the width, style and colour for lines and rectangles when drawn using a printer.
  • PC_PRINTER_SET_POSITION
    Move the logicial printer position ready for the next PC_PRINTER_WRITE.
  • PC_PRINTER_WRITE
    Writes a text string to the printer.
  • PC_PRINTER_WRITE_BMP
    Write a loaded bitmap to a printer at a specified position with a given size.
  • Printer Handling Routines Return Codes
Parent topic: Library Routines


PC_PRINT_FILE

Prints the contents of the specified file, optionally displaying printer control, font, and progress indicator dialog boxes, before commencing the print.

Syntax:

CALL "PC_PRINT_FILE" using     filename
                               document-title
                     by value  flags
                     by value  window-handle
                     returning status-code

Parameters:

filename
Group predefined as cblt-printer-name containing:
01 cblt-printer-name       typedef
  03 cblt-pn-name-length   cblt-x2-comp5  *> pic x(2) comp-5
  03 cblt-pn-name          pic x(n).      *> pic x(n).
document-title
Group predefined as cblt-printer-name containing:
01 cblt-printer-name       typedef
  03 cblt-pn-name-length   cblt-x2-comp5  *> pic x(2) comp-5
  03 cblt-pn-name          pic x(n).      *> pic x(n).
flags
Using call prototype (see Key) : Numeric literal or cblt-x4-comp5.
Picture: Numeric literal or pic x(4) comp-5.
window-handle
Using call prototype (see Key) : Numeric literal or cblt-x4-comp5.
Picture: Numeric literal or pic x(4) comp-5.
status-code
See Library Routines - Key

On Entry:

filename
The name of the file to be printed (null or space terminated)
document-title
The title of the document to be printed
flags
A set of bits to define printer options:
bit 0 | Display a printer control dialog to allow you to define the printer characteristics - cannot be used with bit 2 or bit 3
bit 1 | Display a font dialog box to allow you to define the default font for the document
bit 2 | Print in portrait orientation - cannot be used with bit 0 or bit 3
bit 3 | Print in landscape orientation - cannot be used with bit 0 or bit 2
bit 4 | Display a progress indicator dialog box
window-handle
Handle of parent window. The parent window is used as a reference for positioning dialog boxes. If window-handle is 0 the dialog boxes will be positioned in a system dependent position on the screen.

On Exit:

status-code
Printer Handling Routines Return Codes
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_CLOSE

Closes a previously opened printer channel.

Syntax:

call "PC_PRINTER_CLOSE" using     printer-handle
                        returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
printer-handle | cblt-x4-comp5 | pic x(4) comp-5.
status-code | See Library Routines - Key

On Entry:

printer-handle The printer handle returned when the printer was opened

On Exit:

status-code Printer Handling Routines Return Codes
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_CONTROL

Sends a print command to a printer.

Syntax:

call "PC_PRINTER_CONTROL" using     printer-handle
                          by value  print-command
                          returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
printer-handle | cblt-x4-comp5 | pic x(4) comp-5.
print-command | Numeric literal or cblt-x4-comp5 | Numeric literal or pic x(4) comp-5.
status-code | See Library Routines - Key

On Entry:

printer-handle
The printer handle returned when the printer was opened.
print-command
The command to send to the printer:
1 | Abort printing the document and close the printer
2 | Throw a page
3 | Flush the print buffers
4 | Start a new line

On Exit:

status-code
Printer Handling Routines Return Codes
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_DEFAULT_FONT

Sets the default font for all PC_PRINTER_ routines.

Syntax:

call "PC_PRINTER_DEFAULT_FONT" using     font-family-name
                               by value  font-size
                               by value  font-style
                               returning status-code

Parameters

font-family-name
Group predefined as cblt-printer-name containing:
01 cblt-printer-name       typedef.
  03 cblte-pn-name-length  cblt-x2-comp5. *> pic x(2) comp-5.
  03 cblte-pn-name         cblt-x1.       *> Occurs depending on
                                          *> cblte-pn-name-length.  pic x(n).
font-size
Call prototype (see Key): Numeric literal or cblt-x4-comp5
Picture: Numeric literal or pic x(4) comp-5.
font-style
Call prototype (see Key): Numeric literal or cblt-x4-comp5
Picture: Numeric literal or pic x(4) comp-5.
status-code
See Library Routines - Key.

On Entry:

cblte-pn-name-len | The length of the font family name.
cblte-pn-name | The family name of the font to be used (for example, Courier, Helvetica, Times, Symbol, Times New Roman, Roman, and so on).
font-size | Point size of font. If the point size is zero the font is reset to the system defaults.
font-style The font-style set:
Bit 15
The high-order 32-bits contain a printer character set as defined by Windows
Bit 3
Bold
Bit 2
Strikeout
Bit 1
Underline
Bit 0
Italic

All remaining bits are reserved for future use and should not be set.

status-code | Printer Handling Routines Return Codes

On Exit:

status-code Printer Handling Routines Return Codes

Comments:

Default parameters are not validated until the default printer is opened.

Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines
Related information
Printer Handling Routines Return Codes
Printer Routines


PC_PRINTER_DEFAULT_NAME

Sets the default printer for all PC_PRINTER_ routines.

Syntax:

call "PC_PRINTER_DEFAULT_NAME" using by value     flags
                                     by reference printer-name
                                     returning    status-code

Parameters

flags
Call prototype (see Key): Numeric literal or cblt-x4-comp5
Picture: Numeric literal or pic x(4) comp-5.
printer-name
Group predefined as cblt-printer-name containing:
01 cblt-printer-name       typedef.
  03 cblte-pn-name-length  cblt-x2-comp5. *> pic x(2) comp-5.
  03 cblte-pn-name         cblt-x1.       *> Occurs depending on
                                          *> cblte-pn-name-length.  pic x(n).
status-code
See Library Routines - Key.

On Entry:

flags | Flags controlling the behavior of the call. Must be set to 1.
cblte-pn-name-len | The length of the printer name.
cblte-pn-name | The text of the printer name to be used as the default printer.

On Exit:

status-code Printer Handling Routines Return Codes
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_DEFAULT_PROPERTIES

Sets one or more of the properties of the default printer for all PC_PRINTER_ routines.

Syntax:

call "PC_PRINTER_DEFAULT_PROPERTIES" using by value     flags
                                           by reference properties
                                           returning    status-code

Parameters

flags
Using call prototype (see Library Routines - Key) : cblt-os-flags
Picture: Numeric literal, pic x(4) comp-5, or pic x(8) comp-5 (64-bit native programs only).
properties
Group predefined as cblt-printer-properties containing:
01 cblt-printer-properties typedef
  03 cblte-pp-len           cblt-x2-comp5    pic x(2) comp-5.
  03 cblte-pp-papersize     cblt-sx2-comp5   pic s9(4) comp-5.
  03 cblte-pp-paperlength   cblt-sx2-comp5   pic s9(4) comp-5.
  03 cblte-pp-paperwidth    cblt-sx2-comp5   pic s9(4) comp-5.
  03 cblte-pp-scale         cblt-sx2-comp5   pic s9(4) comp-5.
  03 cblte-pp-copies        cblt-sx2-comp5   pic s9(4) comp-5.
  03 cblte-pp-papertray     cblt-sx2-comp5   pic s9(4) comp-5.
  03 cblte-pp-printquality  cblt-sx2-comp5   pic s9(4) comp-5.
  03 cblte-pp-color         cblt-sx2-comp5   pic s9(4) comp-5.
  03 cblte-pp-duplex        cblt-sx2-comp5   pic s9(4) comp-5.
  03 cblte-pp-orientation   cblt-sx2-comp5   pic s9(4) comp-5.
  03 cblte-pp-yresolution   cblt-sx2-comp5   pic s9(4) comp-5.
status-code
See Library Routines - Key

On Entry:

flags
Flags controlling which of the properties to change. Value is a combination of the following:
P-PAPERSIZE | 1
P-PAPERLENGTH | 2
P-PAPERWIDTH | 4
P-SCALE | 8
P-COPIES | 16
P-PAPERTRAY | 32
P-PRINTQUALITY | 64
P-COLOR | 128
P-DUPLEX | 256
P-ORIENTATION | 512
P-YRESOLUTION | 1024
cblte-pp-len
Must be set to the size of the properties buffer.
cblte-pp-papersize
Paper size, using one of the DMPAPER- constants defined in the file WINDOWS.CPY.
cblte-pp-paperlength
Paper length in tenths of a millimeter.
cblte-pp-paperwidth
Paper width in tenths of a millimeter.
cblte-pp-scale
Factor by which the output is to be scaled.
cblte-pp-copies
The number of copies to be printed.
cblte-pp-papertray
The number of the paper tray to be used, using one of the DMBIN- constants defined in the file WINDOWS.CPY.
cblte-pp-printquality
The print quality, using one of the DMRES- constants defined in the file WINDOWS.CPY, or if a positive value is used, the horizontal resolution in dots per inch.
cblte-pp-color
Switch between monochrome and color printing using one of the DMCOLOR- constants.
cblte-pp-duplex
Select duplex or double-sided printing using one of the DMDUP- constants.
cblte-pp-orientation
Select the paper orientation using one of the DMORIENT- constants.
cblte-pp-yresolution
The vertical resolution in dots per inch.
status-code
Printer Handling Routines Return Codes

On Exit:

status-code
Printer Handling Routines Return Codes

Comments:

The file WINDOWS.CPY is provided with this COBOL system.

Default parameters are not validated until the default printer is opened.

Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines
Related information
Printer Handling Routines Return Codes
Printer Routines


PC_PRINTER_DRAW_RECTANGLE

Draws an outline or filled rectangle at position start-x,start-y to end-x,end-y.

Syntax:

call "PC_PRINTER_DRAW_RECTANGLE" using
                                 by value printer-handle
                                 by value draw-rectangle-options
                                 by value box-style
                                 by value start-x
                                 by value start-y
                                 by value end-x
                                 by value end-y
end-call

Parameters:

 | Using call prototype (see Key) | Picture
draw-rectangle-options | cblt-x4-comp5 | pic x(4) comp-5.
start-x | cblt-x4-comp5 | pic x(4) comp-5.
end-x | cblt-x4-comp5 | pic x(4) comp-5.

On Entry:

 | Value | Meaning
box-style | 0 | outline
 | 1 | filled

On Exit:

status-code Printer Handling Routines Return Codes

Comments:

Does not change the logicial position on the page.

Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_ENUM_CLOSE

Ends the process of enumerating printers.

Syntax:

call "PC_PRINTER_ENUM_CLOSE" using by reference enum-handle

Parameters

enum-handle
Call prototype (see Key): cblt-pointer.
Picture: pointer.

On Entry:

enum-handle
A valid enum-handle returned from PC_PRINTER_ENUM_START

On Exit:

return-value
One of:
0
Enumeration close completed
!= 0
PC_PRINTER error code

Example

01 enum-handle           pointer.
01 printer-name.
   03 p-name-len           pic x(2) comp-5.
   03 p-name               pic x(255).
01 enum-flags              pic x(4) comp-5 value 0.
01 enum-printers-found     pic x(4) comp-5 value 0.
01 p-counter      binary-long.

procedure division.
  move 1 to p-counter
  set p-name-len to length of p-name
  call "PC_PRINTER_ENUM_START" using
          by reference enum-handle
          by value enum-flags
          by reference enum-printers-found
  end-call
  if return-code not equal 0
       display "RC: Enum-Start : " return-code
  end-if
  display "Printers found : " enum-printers-found
  perform until return-code not equal 0
       set p-name-len to length of p-name
       call "PC_PRINTER_ENUM_NEXT" using
              by value enum-handle
              by reference printer-name
       end-call
       if return-code not equal 0
              display "RC: Enum-Next : " return-code
       else
              display p-counter " " p-name(1:p-name-len)
                   " size " p-name-len
       end-if
       add 1 to p-counter
  end-perform

  call "PC_PRINTER_ENUM_CLOSE" using
                  by reference enum-handle
  end-call
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines
Related information
Printer Handling Routines Return Codes
Printer Routines


PC_PRINTER_ENUM_NEXT

Gets the name of the next enumerated printer.

Syntax:

call "PC_PRINTER_ENUM_NEXT" using by value enum-handle
                                   by reference printer-name

Parameters

enum-handle
Call prototype (see Key): cblt-pointer
Picture: pointer.
printer-name
A group predefined as
01 printer-name typedef.
  03 cblte-pn-name-len  pic x(2) comp-5.
  03 cblte-pn-name      pic x(n).

On Entry:

enum-handle
Valid enum-handle returned from PC_PRINTER_ENUM_START.
cblte-pn-name-len
The length of cblte-pn-name.
cblte-pn-name
Not set.

On Exit:

cblte-pn-name-len
The length of cblte-pn-name returned.
cblte-pn-name
The printer name.
return-value
One of:
0
Enumeration started
29
End of enumeration
30
cblte-pn-name is too small
or another PC_PRINTER error code

Example

01 enum-handle           pointer.
01 printer-name.
   03 p-name-len           pic x(2) comp-5.
   03 p-name               pic x(255).
01 enum-flags              pic x(4) comp-5 value 0.
01 enum-printers-found     pic x(4) comp-5 value 0.
01 p-counter      binary-long.

procedure division.
  move 1 to p-counter
  set p-name-len to length of p-name
  call "PC_PRINTER_ENUM_START" using
          by reference enum-handle
          by value enum-flags
          by reference enum-printers-found
  end-call
  if return-code not equal 0
       display "RC: Enum-Start : " return-code
  end-if
  display "Printers found : " enum-printers-found
  perform until return-code not equal 0
       set p-name-len to length of p-name
       call "PC_PRINTER_ENUM_NEXT" using
              by value enum-handle
              by reference printer-name
       end-call
       if return-code not equal 0
              display "RC: Enum-Next : " return-code
       else
              display p-counter " " p-name(1:p-name-len)
                   " size " p-name-len
       end-if
       add 1 to p-counter
  end-perform

  call "PC_PRINTER_ENUM_CLOSE" using
                  by reference enum-handle
  end-call

Comments

If cblte-pn-name-len is zero on entry, then cblte-pn-name-len is updated with the size required for cblte-pn-name (not the size of the group) and the enumeration remains on the current entry.

Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines
Related information
Printer Handling Routines Return Codes
Printer Routines


PC_PRINTER_ENUM_START

Starts the process of enumerating printers.

Syntax:

call "PC_PRINTER_ENUM_START" using by reference enum-handle
                                   by value enum-flags
                                   by reference number-of-printers-found

Parameters

enum-handle
Call prototype (see Key): cblt-pointer
Picture: pointer.
enum-flags
Call prototype (see Key): cblt_os_flags
Picture: pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
number-of-printers-found
Call prototype (see Key): cblt_os_size
Picture: pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).

On Entry:

enum-handle
Not set.
enum-flags
Flags controlling the behavior of the call. Must be set to 0.
number-of-printers-found
Not set.

On Exit:

enum-handle
Valid enumeration handle if number of printers > 0
number-of-printers-found
Number of printers found
return-value
One of:
0
Enumeration started
!= 0
PC_PRINTER error code

Example

01 enum-handle           pointer.
01 printer-name.
   03 p-name-len           pic x(2) comp-5.
   03 p-name               pic x(255).
01 enum-flags              pic x(4) comp-5 value 0.
01 enum-printers-found     pic x(4) comp-5 value 0.
01 p-counter      binary-long.

procedure division.
  move 1 to p-counter
  set p-name-len to length of p-name
  call "PC_PRINTER_ENUM_START" using
          by reference enum-handle
          by value enum-flags
          by reference enum-printers-found
  end-call
  if return-code not equal 0
       display "RC: Enum-Start : " return-code
  end-if
  display "Printers found : " enum-printers-found
  perform until return-code not equal 0
       set p-name-len to length of p-name
       call "PC_PRINTER_ENUM_NEXT" using
              by value enum-handle
              by reference printer-name
       end-call
       if return-code not equal 0
              display "RC: Enum-Next : " return-code
       else
              display p-counter " " p-name(1:p-name-len)
                   " size " p-name-len
       end-if
       add 1 to p-counter
  end-perform

  call "PC_PRINTER_ENUM_CLOSE" using
                  by reference enum-handle
  end-call
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines
Related information
Printer Handling Routines Return Codes
Printer Routines


PC_PRINTER_FREE_BMP

Frees a bitmap from memory, releasing its image and palette back to the operating system.

Syntax:

call "PC_PRINTER_FREE_BMP" using     printer-handle
                           by value  bmp-id
                           returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
printer-handle | cblt-x4-comp5 | pic x(4) comp-5.
bmp-id | cblt-x4-comp5 | pic x(4) comp-5.
status-code | See Library Routines - Key

On Entry:

printer-handle
The printer handle returned when the printer was opened.
bmp-id
The unique id of the loaded bitmap, returned when the bitmap was loaded.

On Exit:

status-code
Printer status code:
0 | Successful
3 | Printer device not open
20 | Failed to free bitmap

Example:

call "PC_PRINTER_FREE_BMP" using     printer-handle
                           by value  bmp-idlogo
                           returning printer-retcode
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_GET_BMP_INFO

Retreives the height and width of loaded bitmap

Syntax:

call "PC_PRINTER_GET_BMP_INFO" using
                               by value bitmap-handle
                               by value bitmap-height
                               by value bitmap-width
end-call

Parameters:

 | Using call prototype (see Key) | Picture
bitmap-height | cblt-x4-comp5 | pic x(4) comp-5.

On Entry:

bitmap-handle Must be valid handle returned from PC_PRINTER_LOAD_BMP

On Exit:

status-code Printer Handling Routines Return Codes
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_GET_COLOR

Gets the color on the printer.

Syntax:

call "PC_PRINTER_GET_COLOR" using        printer-handle
                            by value     fore-or-back
                            by reference color-red
                            by reference color-green
                            by reference color-blue
                            returning    status-code

Parameters:

 | Using call prototype (see Key) | Picture
printer-handle | cblt-x4-comp5 | pic x(4) comp-5.
fore-or-back | cblt-x2-comp5 | pic x(2) comp-5.
color-red | cblt-x2-comp5 | pic x(2) comp-5.
color-green | cblt-x2-comp5 | pic x(2) comp-5.
color-blue | cblt-x2-comp5 | pic x(2) comp-5.
status-code | See Library Routines - Key |

On Entry:

printer-handle
The printer handle returned when the printer was opened.
fore-or-back
Whether to get the foreground or background color:
1 | Foreground
2 | Background

On Exit:

color-red
A value between 0 and 255, giving the intensity of red.
color-greem
A value between 0 and 255, giving the intensity of green.
color-blue
A value between 0 and 255, giving the intensity of blue.
status-code
Printer status code:
0 | Successful
3 | Printer device not open
22 | Failed to free bitmap

Comments:

You must open the printer before using this routine.

You can find out if your printer supports color by using the PC_PRINTER_INFO library routine.

Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_GET_FONT

Gets the font on the printer.

Syntax:

call "PC_PRINTER_GET_FONT" using     printer-handle
                                      font-family-name
                                      font-size
                                      font-style
                            returning status-code

Parameters

printer-handle
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
font-family-name
Group predefined as cblt-printer-name containing:
01 cblt-printer-name       typedef.
  03 cblte-pn-name-length  cblt-x2-comp5. *> pic x(2) comp-5.
  03 cblte-pn-name         cblt-x1.       *> Occurs depending on
                                          *> cblte-pn-name-length.  pic x(n).
font-size
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
font-style
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
status-code
See Library Routines - Key.

On Entry:

printer-handle | The printer handle returned when the printer was opened.
cblte-pn-name-len | The length of the buffer for the font-family name.

On Exit:

printer-handle
The printer handle returned when the printer was opened.
cblte-pn-name-len
The length of the buffer for the font-family name.
name-len
The length of the buffer for the font-family name. If the length is zero no font is returned, and the operating system default is used (font-size and font-style are then invalid).
name-text
The family name of the font to be used (for example, Courier, Helvetica, Times, and so on).
font-size
The point-size of the font.
font-style
The font-style set:
3 | Bold
2 | Strikeout
1 | Underline
0 | Italic

All remaining bits are reserved for future.

Example:

 working-storage section.
 01.
   03 document-title.
     05 title-len           pic x(2) comp-5.
     05 title-text          pic x(20).

   03 font-family.
     05 font-family-namelen  pic x(2) comp-5 value 80.
     05 font-family-name     pic x(80).

   03 font-size              pic x(4) comp-5.
   03 font-style             pic x(4) comp-5.

   03 abort                  pic x(4) comp-5 value 1.
   03 control                pic x(4) comp-5 value 2.
   03 flags                  pic x(4) comp-5 value 3.
   03 handle                 pic x(4) comp-5.

 procedure division.
     move 17 to title-len
     move "Printer Info Test" to title-text

     call "PC_PRINTER_OPEN" using by reference handle
                                  by reference document-title
                                  by value flags
                                  by value 0
     end-call

     if return-code = zero
         call "PC_PRINTER_GET_FONT"
                               using by reference handle
                                     by reference font-family
                                     by reference font-size
                                     by reference font-style
         end-call
         if return-code equal zero
             if font-size equal zero
                 display "Current Font   : no font selected"
             else
                 display "Current Font   : "
                       font-family-name(1:font-family-namelen)
                 display "Font size      : " font-size
                 display "Raw Font Style : " font-style
             end-if
         else
             display "PC_PRINTER_GET_FONT failed"
         end-if
     end-if

     perform close-down-printer
     .

 close-down-printer section.
     call "PC_PRINTER_CONTROL" using by reference handle
                                     by value abort
     end-call

     call "PC_PRINTER_CLOSE" using by reference handle
     end-call
     .
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_INFO

Returns a native device context handle, and other information that can be used to enhance the printing of a document by calling native graphics functions directly.

Syntax:

call "PC_PRINTER_INFO using     cblt-pi-printer-handle
                                cblt-pi-printer-info-struct
                      returning status-code

Parameters:

cblt-pi-printer-handle
Using call prototype (see Library Routines - Key) : cblt-x4-comp5
Picture: pic x(4) comp-5.
cblt-pi-printer-info-struct
Group containing
01 print-info-struct
  03 cblt-pi-struct-size               cblt-os-size   *> pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
  03 cblt-pi-printer-hdc               cblt-pointer   *> pointer.
  03 cblt-pi-printer-hps               cblt-os-size   *> pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
  03 cblt-pi-printer-orientation       cblt-x4-comp5  *> pic x(4) comp-5.
  03 cblt-pi-printer-rows              cblt-x4-comp5  *> pic x(4) comp-5.
  03 cblt-pi-printer-cols              cblt-x4-comp5  *> pic x(4) comp-5.
  03 cblt-pi-printer-rows-left         cblt-x4-comp5  *> pic x(4) comp-5.
  03 cblt-pi-printer-max-horiz         cblt-x4-comp5  *> pic x(4) comp-5.
  03 cblt-pi-printer-max-vert          cblt-x4-comp5  *> pic x(4) comp-5.
  03 cblt-pi-printer-min-horiz         cblt-x4-comp5  *> pic x(4) comp-5.
  03 cblt-pi-printer-min-vert          cblt-x4-comp5  *> pic x(4) comp-5.
  03 cblt-pi-printer-curr-horiz        cblt-x4-comp5  *> pic x(4) comp-5.
  03 cblt-pi-printer-curr-vert         cblt-x4-comp5  *> pic x(4) comp-5.
  03 cblt-pi-printer-copies            cblt-x2-comp5  *> pic 9(4) comp-5.
  03 cblt-pi-printer-quality           cblt-x2-comp5  *> pic 9(4) comp-5.
  03 cblt-pi-printer-color             cblt-x1-comp5  *> pic 99 comp-5.
  03 cblt-pi-reserved-item1            cblt-x1-comp5  *> pic 99 comp-5.
  03 cblt-pi-printer-device-ver        cblt-x2-comp5  *> pic 9(4) comp-5.
  03 cblt-pi-printer-name
    05 cblt-pi-printer-pname-size      cblt-os-size   *> pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
    05 cblt-pi-printer-pname           cblt-pointer   *> pointer.
  03 cblt-pi-printer-type
    05 cblt-pi-printer-ptype-size      cblt-os-size   *> pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
    05 cblt-pi-printer-ptype           cblt-pointer   *> pointer.
  03 cblt-pi-printer-device
    05 cblt-pi-printer-pdevice-size    cblt-os-size   *> pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
    05 cblt-pi-printer-pdevice         cblt-pointer   *> pointer.
  03 cblt-pi-printer-location
    05 cblt-pi-printer-plocation-size  cblt-os-size   *> pic x(4) comp-5 or	pic x(8) comp-5 (64-bit native only).
    05 cblt-pi-printer-plocation       cblt-pointer   *> pointer.
  03 p-comment
    05 cblt-pi-printer-pcomment-size   cblt-os-size   *> pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
    05 cblt-pi-printer-pcomment        cblt-pointer   *> pointer.
  03 cblt-pi-printer-type
    05 cblt-pi-printer-papersize-size  cblt-os-size   *> pic x(4) comp-5 or pic x(8) comp-5 (64-bit native only).
    05 cblt-pi-printer-papersize       cblt-pointer   *> pointer.
status-code
See Library Routines - Key

On Entry:

printer-handle
The printer handle returned when the printer was opened
cblt-pi-struct-size
The size of the structure
cblt-pi-printer-papersize
The size of the associated buffers
cblt-pi-printer-pcomment
The address of the buffer

On Exit:

cblt-pi-printer-hdc
Handle to the printer device context
cblt-pi-printer-hps
Reserved
cblt-pi-printer-orientation
Orientation of the printed output:
1 | portrait
2 | landscape
cblt-pi-printer-cols
Total number of columns on a page in the current font
cblt-pi-printer-rows_left
Number of rows left on the current page in the current font
cblt-pi-printer-max-horiz
Maximum value of graphics coordinate available in the horizontal axis
cblt-pi-printer-max-vert
Maximum value of graphics coordinate available in the vertical axis
cblt-pi-printer-min-horiz
Minimum value of graphics coordinate available in the horizontal axis
cblt-pi-printer-min-vert
Minimum value of graphics coordinate available in the vertical axis
cblt-pi-printer-curr-horiz
Current graphics X coordinate
cblt-pi-printer-curr-vert
Current graphics Y coordinate
cblt-pi-printer-copies
Number of copies
cblt-pi-printer-quality
The quality the printer is set to. Can be one of:
0 | Draft
1 | Low
2 | Medium
3 | High
4 | Printer's default
Otherwise the DPI is returned.
cblt-pi-printer-color
Color capabilities of the printer:
0 | Monochrome
1 | Color
cblt-pi-printer-version
Version number of the printer driver
cblt-pi-printer-pname-size
Size of the printer name
cblt-pi-printer-pname
Pointer to the name of the printer
cblt-pi-printer-ptype-size
Size of the printer type
cblt-pi-printer-ptype
Pointer to the cblt-pi-printer-type
cblt-pi-printer-pdevice-size
Size of the printer device
cblt-pi-printer-pdevice
Pointer to the printer device
cblt-pi-printer-plocation-size
Size of the printer's location
cblt-pi-printer-plocation
Pointer to the location of the printer
cblt-pi-printer-pcomment-size
Size of the printer's comment
cblt-pi-printer-pcomment
Pointer to the printer's comment
cblt-pi-printer-papersize-size
Size of the printer's paper size
cblt-pi-printer-papersize
Pointer to the printer's paper size
status-code
Printer Handling Routines Return Codes

Comments:

cblt-pi-printer-type specifies the type of printer; for example, HP or Canon.

cblt-pi-printer-device specifies the printer device; for example, lpt1:, :file or :com1. This parameter can be set to multiple devices; each device is separated by a comma (for example, lpt1:,lpt2:).

cblt-pi-printer-comment specifies any comment associated with the printer (for example, the printer might have the comment "Printer for accounts" defined for it).

paper-size defines the paper-size; for example, A4, or Letter.

Example:

$set remove(control)
working-storage section.
copy "cbltypes.cpy".
01 PRT-INFO-1 is typedef.
  03 pi-struct-size      cblt-os-size.
  03 hdc                 cblt-pointer.
  03 hps                 cblt-os-size.
  03 orientation         pic x(4) comp-5.
  03 rows                pic x(4) comp-5.
  03 cols                pic x(4) comp-5.
  03 rows-left           pic x(4) comp-5.
  03 max-horiz           pic x(4) comp-5.
  03 max-vert            pic x(4) comp-5.
 03 min-horiz           pic x(4) comp-5.
  03 min-vert            pic x(4) comp-5.
  03 curr-horiz          pic x(4) comp-5.
  03 curr-vert           pic x(4) comp-5.
  03 copies              pic 9(4) comp-5.
  03 quality             pic 9(4) comp-5.
  03 color               pic 99 comp-5.
  03 reserved1           pic x comp-5.
  03 driver-ver          pic 9(4) comp-5.
  03 pname.
    05 cbsize            cblt-os-size.
    05 buffer            pointer.
  03 ptype.
    05 cbsize            cblt-os-size.
    05 buffer            pointer.
  03 pdevice.
    05 cbsize            cblt-os-size.
    05 buffer            pointer.
  03 plocation.
    05 cbsize            cblt-os-size.
    05 buffer            pointer.
  03 pcomment.
    05 cbsize            cblt-os-size.
    05 buffer            pointer.
  03 ppapersize.
    05 cbsize            cblt-os-size.
    05 buffer            pointer.
01.
  03 document-title.
    05 title-len         pic x(2) comp-5.
    05 title-text        pic x(20).
      03  font-family.
    05 font-family-namelen  pic x(2) comp-5 value 80.
    05 font-family-name     pic x(80).
  03 print-info          PRT-INFO-1.
  03 abort               pic x(4) comp-5 value 1.
  03 control             pic x(4) comp-5 value 2.
  03 flags               pic x(4) comp-5 value 3.
  03 handle              pic x(4) comp-5.
01 cblt-pi-printer-name          pic x(255).
01 cblt-pi-printer-type          pic x(255).
01 cblt-pi-printer-device        pic x(255).
01 cblt-pi-printer-location      pic x(255).
01 cblt-pi-printer-comment       pic x(255).
01 cblt-pi-printer-papersize     pic x(255).

procedure division.
    move 17 to title-len
    move "Printer Info Test" to title-text

    call "PC_PRINTER_OPEN" using by reference handle
                                 by reference document-title
                                 by value flags
                                 by value 0
    end-call

    if return-code = zero
        move all x"0" to print-info
        move length of print-info to pi-struct-size
        set buffer of pname of print-info
            to address of cblt-pi-printer-name
        move 255 to cbsize of pname of print-info
        set buffer of ptype of print-info
            to address of cblt-pi-printer-type
        move 255 to cbsize of ptype of print-info
        set buffer of pdevice of print-info
             to address of cblt-pi-printer-device
        move 255 to cbsize of pdevice of print-info
        set buffer of plocation of print-info
            to address of cblt-pi-printer-location
        move 255 to cbsize of plocation of print-info
        set buffer of pcomment of print-info
            to address of cblt-pi-printer-comment
        move 255 to cbsize of pcomment of print-info
        set buffer of ppapersize of print-info
            to address of cblt-pi-printer-papersize
        move 255 to cbsize of ppapersize of print-info
        call "PC_PRINTER_INFO" using by reference handle
                                     by reference print-info
        end-call
        display return-code
        if return-code not equal zero
            display "PC_PRINTER_INFO failed (return-code)"
            display "   === " return-code
            perform close-down-printer
            stop run
        end-if
        display "Orientation   : " orientation of print-info
        display "Rows          : " rows of print-info
        display "Cols          : " cols of print-info
        display "Rows Left     : " rows-left of print-info
        display "Max horz      : " max-horiz of print-info
        display "Max vert      : " max-vert of print-info
        display "Min horz      : " min-horiz of print-info
        display "Min vert      : " min-vert of print-info
        display "Current horz  : " curr-horiz of print-info
        display "Current vert  : " min-vert of print-info
        display "Copies        : " copies of print-info
        display "Quality       : " no advancing
        evaluate quality of print-info
         when 0 display "Draft"
         when 1 display "Low"
         when 2 display "Medium"
         when 3 display "High"
         when 4 display "printers default used"
         when other display quality of print-info " DPI"
        end-evaluate
        display "Color         : " no advancing
        if color of print-info equals 0
            display "Mono Chrome"
        else
            display "Color"
        end-if
        if cbsize of pname of print-info equal 0
            display "Printer name  : not available"
        else
            display "Printer name  : "
                    cblt-pi-printer-name(1:
                         cbsize of pname of print-info)
           display "Printer name  size : "
                   cbsize of pname of print-info
        end-if
        if cbsize of ptype of print-info equal 0
           display "Printer type  : not available"
        else
            display "Printer type  : "
                    cblt-pi-printer-type(1:
                         cbsize of ptype of print-info)
            display "Printer type size : "
                    cbsize of ptype of print-info
        end-if
        if cbsize of pdevice of print-info equal 0
            display "Printer device: not available"
        else
            display "Printer device(s): "
                    cblt-pi-printer-device(1:
                         cbsize of pdevice of print-info)
            display "Printer device size : "
                    cbsize of pdevice of print-info
        end-if
        if cbsize of plocation of print-info equal 0
            display "Printer location: not available"
        else
            display "Printer location: "
                    cblt-pi-printer-location(1:
                         cbsize of plocation of print-info)
            display "Printer location size : "
                    cbsize of plocation of print-info
        end-if
        if cbsize of pcomment of print-info equal 0
            display "Printer comment: not available"
        else
            display "Printer comment: "
                    cblt-pi-printer-comment(1:
                         cbsize of pcomment of print-info)
            display "Printer comment size : "
                    cbsize of pcomment of print-info
        end-if
        if cbsize of ppapersize of print-info equal 0
            display "Printer papersize: not available"
        else
            display "Printer papersize: "
                    cblt-pi-printer-papersize(1:
                         cbsize of ppapersize of print-info)
            display "Printer papersize size : "
                    cbsize of ppapersize of print-info
        end-if
        display "Driver version : "driver-ver of print-info
    end-if
    perform close-down-printer
    .

close-down-printer section.
    call "PC_PRINTER_CONTROL" using by reference handle
                                    by value abort
    end-call

    call "PC_PRINTER_CLOSE" using by reference handle
    end-call
    .
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_LINE_FROM_TO

Draws a line from start-x,start-y to end-x,end-y.

Syntax:

call "PC_PRINTER_LINE_FROM_TO" using
                               by value printer-handle
                               by value lineFrom-options
                               by value start-x
                               by value start-y
                               by value end-x
                               by value end-y
end-call

Parameters:

 | Using call prototype (see Key) | Picture
lineFrom-options | cblt-x4-comp5 | pic x(4) comp-5.
start-y | cblt-x4-comp5 | pic x(4) comp-5.
end-y | cblt-x4-comp5 | pic x(4) comp-5.

On Exit:

status-code Printer Handling Routines Return Codes

Comments:

Does not change the logicial position on the page.

Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_LOAD_BMP

Loads a bitmap or other supported file format into memory ready for the PC_PRINTER_WRITE_BMP function.

Syntax:

call "PC_PRINTER_LOAD_BMP"  using        printer-handle
                           by reference bmpfilename
                           by reference bmp-id
                           returning    status-code

Parameters:

 | Using call prototype (see Key) | Picture
printer-handle | cblt-x4-comp5 | pic x(4) comp-5.
bmpfilename | pic x(n). | pic x(n).
bmp-id | cblt-x4-comp5 | pic x(4) comp-5.
status-code | See Library Routines - Key

On Entry:

printer-handle
The printer handle returned when the printer was opened.
bmpfilename
The name of the bitmap or other supported file format to be loaded (the name should be terminated with a null or space).

On Exit:

bmp-id
A unique identifier for the loaded file.
status-code
Printer status code:
0 | Successful
3 | Printer device not open
18 | Failed to load bitmap
19 | Invalid bitmap identifier

Comments:

The following file formats are supported: BMP, GIF, EXIF, JPG, PNG and TIFF.

This routine is available only in the Windows environment.

Example:

call "PC_PRINTER_LOAD_BMP" using printer-handle
                             by reference "mflogo.bmp" & x"0"
                             by reference bmp-id
                           returning  printer-retcode.
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_OPEN

Opens a printer channel, giving it a document title, and optionally displaying printer control, font, and progress indicator dialog boxes

Syntax:

call "PC_PRINTER_OPEN" using     printer-handle
                                 document-title
                       by value  flags
                       by value  window-handle
                       returning status-code

Parameters

printer-handle
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
document-title
Group predefined as cblt-printer-name containing:
01 cblt-printer-name       typedef.
  03 cblte-pn-name-length  cblt-x2-comp5. *> pic x(2) comp-5.
  03 cblte-pn-name         cblt-x1.       *> Occurs depending on
                                          *> cblte-pn-name-length.  pic x(n).
flags
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
window-handle
Call prototype (see Key): Numeric literal or cblt-x4-comp5
Picture: Numeric literal or pic x(4) comp-5.
status-code
See Library Routines - Key.

On Entry:

cblte-pn-name-length | The length of the document title
cblte-pn-name | The title of the document to be printed
flags A set of bits to define printer options:
Bit 0
Display a printer control dialog to allow you to define the printer characteristics (cannot be used with bit 2 or bit 3)
Bit 1
Display a font dialog box to allow you to define the default font for the document
Bit 2
Print in portrait orientation (cannot be used with bit 0 or bit 3)
Bit 3
Print in landscape orientation (cannot be used with bit 0 or bit 2)
Bit 4
Display a progress indicator dialog box

All remaining bits are reserved for future use and should not be set

window-handle | Handle of parent window to use for positioning of dialog boxes. If handle is 0 the dialog boxes will be positioned in a system-dependent position on the screen.
printer-handle | Returns a handle to be used for subsequent printer operations for a successful open.
status-code | Printer Handling Routines Return Codes

On Exit:

printer-handle | Returns a handle to be used for subsequent printer operations for a successful open.
status-code | Printer Handling Routines Return Codes
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines
Related information
Printer Handling Routines Return Codes
Printer Routines


PC_PRINTER_REDIRECTION_PROC

Registers a user function that is called when a program uses OPEN OUTPUT syntax and the ASSIGN TO PRINTER clause.

Syntax:

call "PC_PRINTER_REDIRECTION_PROC" by value flags
                                            user-func

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5.
user-func | cblt-ppointer | usage procedure pointer.

On Entry:

flags | Reserved for future use. Must be set to 0.
user-func | A pointer to a procedure that will manipulate the printer.

Comments:

This routine enables you to set and manipulate fonts on the printer while using standard COBOL OPEN OUTPUT syntax and the ASSIGN TO PRINTER clause.

You must set the tunable printer-redirection in order for this call to operate correctly.

You must set the COBOL clause local-storage section in the program, to avoid run-time system error 166.

A call to PC_PRINTER_REDIRECTION_PROC registers the user function pointed to by user-func with the run-time system.

The user function should have the form:

entry "user-func" using by value printer-handle
 ...
 ...
exit program returning return-value.

printer-handle should be defined as a pic x(4) comp-5 data item.

When an OPEN statement opens a printer the user function is called and the printer handle returned in printer-handle. The user function can then manipulate the printer using the PC_PRINTER_ library routines. The user function should return a value to the run-time system to determine the next sequence of events.

You should code your user procedure to return a return-code 0 if it is called successfully, and any other value if it is not. If your user function does return a non-zero value, the run-time system closes the printer and a file status 9/005 is returned on the OPEN OUTPUT statement that invoked the user function.

Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_SET_BACKGROUND_MIX_MODE

Sets background printing mode.

Syntax:

call "PC_PRINTER_SET_BACKGROUND_MIX_MODE" using
                                          by value printer-handle
                                          by value background-mode
end-call

Parameters:

 | Using call prototype (see Key) | Picture
background-mode | cblt-x4-comp5 | pic x(4) comp-5.

On Entry:

 | Value | Meaning
background-mode | 0 | transparent
 | 1 | opaque

On Exit:

status-code Printer Handling Routines Return Codes
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_SET_COLOR

Sets the color on the printer.

Syntax:

call "PC_PRINTER_SET_COLOR"  using    printer-handle
                            by value  fore-or-back
                            by value  color-red
                            by value  color-green
                            by value  color-blue
                            returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
printer-handle | cblt-x4-comp5 | pic x(4) comp-5.
fore-or-back | cblt-x2-comp5 | pic x(2) comp-5.
color-red | cblt-x2-comp5 | pic x(2) comp-5.
color-green | cblt-x2-comp5 | pic x(2) comp-5.
color-blue | cblt-x2-comp5 | pic x(2) comp-5.
status-code | See Library Routines - Key

On Entry:

printer-handle
The handle of the printer, returned when the printer was opened.
fore-or-back
Whether to set the foreground or background color:
1 | Foreground
2 | Background
color-red
Value between 0 and 255; intensity of red
color-green
Value between 0 and 255; intensity of green
color-blue
Value between 0 and 255; intensity of blue

On Exit:

status-code
No status codes are returned by this routine.

Comments:

You must open the printer before using this routine.

You specify the color you want by combinations of values showing the intensity of the three primary colors. For example, to get the colors in the following table, you set the RGB values as shown:

Color | Red | Green | Blue
Red | 255 | 0 | 0
Yellow | 255 | 255 | 0
Green | 0 | 255 | 0
Cyan | 0 | 255 | 255
Blue | 0 | 0 | 255
Magenta | 255 | 0 | 255
White | 255 | 255 | 255
Black | 0 | 0 | 0

Some other, more unusual, colors are:

Color | Red | Green | Blue
Dark orange | 255 | 140 | 0
Navy blue | 0 | 0 | 128
Violet | 238 | 120 | 238
Beige | 245 | 245 | 220

If your printer does not support color, it is up to the printer device driver to interpret these values. For example, some perform gray-shading; others choose either black or white for each color.

Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_SET_DEFAULT

Sets a process-wide default printer before a printer is opened.

Syntax:

call "PC_PRINTER_SET_DEFAULT" using by value default-option
                              by reference   default-struct
                              returning      status-code

Parameters

default-option
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
default-struct
Group predefined as cblt-printer-default containing:
01 cblt-printer-default                typedef.
  03 cblte-pd-printer-name.
    05 cblte-pd-printer-name-length    cblt-x2-comp5.	*> pic x(4) comp-5.
    05 cblte-pd-printer-name           cblt-x1.       *> Occurs depending on
                                                      *> cblte-pd-printer-name-length.
                                                      *> pic x (printer name length)
  03 cblte-pd-printer-browse REDEFINES cblte-pd-printer-name.
    05 cblte-pd-printer-browse-hwnd    cblt-HWND.
    05 cblte-pd-printer-browse-namelen cblt-x2-comp5. *> pic x(4) comp-5.
    05 cblte-pd-reserved               cblt-x2-comp5. *> pic x(4) comp-5.
    05 cblte-pd-printer-browse-name    cblt-x1.       *> Occurs depending on
                                                      *> cblte-pd-printer-browse-namelen.
                                                      *> pic x (printer name length)
status-code
See Library Routines - Key.

On Entry:

default-option
Specifies the default option:
1 | Sets the default printer to be used
2 | Browses for a default printer.
Whendefault-option is set to 1:
printer-name-length
The length of the printer-name
printer-name
The name of the printer
Whendefault-option is set to 2:
browser-hwnd
The handle for the printer browser

On Exit:

When default-option is set to 2:
printer-name-length
The length of the printer-name
printer-name
The name of the printer
reserved
Reserved.
status-code
Printer Handling Routines Return Codes

Comments:

If you set default-option to 2, this function returns the user-selected printer but does not set it as the default printer.

The printer name must be entered as UNC format (that is, the device's full name as it appears on the network).

Examples:

Example 1:

The following example shows how to use PC_PRINTER_SET_DEFAULT to set the default printer.

 working-storage section.
 01 MyDocumentInfo.
   03 filename.
     05 len              pic x(2) comp-5.
     05 body             pic x(128).
   03 document.
     05 len              pic x(2) comp-5.
     05 body             pic x(128).
   03 document-flags     pic x(4) comp-5.
   03 window-hwnd        pic x(4) comp-5.
 01 Printer-RetCode pic  9(4) comp-5.

 78 USE-OPEN-DIALOG      value 1.
 78 USE-FONT-DIALOG      value 2.
 78 USE-FORCE-PORTRAIT   value 4.
 78 USE-FORCE-LANDSCAPE  value 8.
 78 USE-PROGRESS-DIALOG  value 16.

 01 default-info.
   03 option             pic x(4) comp-5.
   03 ourprinter.
     05 len              pic x(2) comp-5.
     05 body             pic x(128).

 78 SET-DEFAULT-PRINTER  value h"0001".
 procedure division.

     move "My Color PS"
       to body of ourprinter of default-info
     move 11 to len of ourprinter of default-info
     move SET-DEFAULT-PRINTER to option of default-info

     call "PC_PRINTER_SET_DEFAULT" using
                     by value option of default-info,
                     by reference ourprinter of default-info
           returning Printer-RetCode
     end-call

     if Printer-RetCode not equal zero
         display "Unable to setup a default printer"
         display " + Retcode = " Printer-RetCode
         stop run
     end-if

     move "c:\config.sys" to body of filename
     move 13 to len of filename

     move "My Config.sys" to body of document
     move 13 to len of document

     move USE-PROGRESS-DIALOG to document-flags
     move zero to window-hwnd

     call "PC_PRINT_FILE" using by reference filename
                                by reference document
                                by value document-flags
                                by value window-hwnd
                                returning Printer-RetCode
     end-call

     if Printer-RetCode not equal zero
         display "PC_PRINT_FILE failed.. " Printer-RetCode
     else
         display "PC_PRINT_FILE: OK"
     end-if
     .

Example 2:

The following example shows how to use PC_PRINTER_SET_DEFAULT to browse for a printer.

 working-storage section.
 01 MyDocumentInfo.
   03 filename.
     05 len                 pic x(2) comp-5.
     05 body                pic x(128).
   03 document.
     05 len                 pic x(2) comp-5.
     05 body                pic x(128).
   03 document-flags        pic x(4) comp-5.
   03 window-handle         pic x(4) comp-5.

 01 MyDefaultPrinter.
   03 hwnd                  pic x(4) comp-5.
   03 len                   pic x(2) comp-5.
   03 reserved              pic x(2) comp-5.
   03 body                  pic x(128).

 01 Printer-RetCode         pic 9(4) comp-5.

 78 USE-OPEN-DIALOG         value 1.
 78 USE-FONT-DIALOG         value 2.
 78 USE-FORCE-PORTRAIT      value 4.
 78 USE-FORCE-LANDSCAPE     value 8.
 78 USE-PROGRESS-DIALOG     value 16.

 01 default-info.
   03 option                pic x(4) comp-5.
   03 ourprinter.
     05 len                 pic x(2) comp-5.
     05 body                pic x(128).

 78 SET-DEFAULT-PRINTER     value h"0001".
 78 BROWSE-DEFAULT-PRINTER  value h"0002".

 linkage section.
 01 lnk-hwnd                 pic x(4) comp-5.

 procedure division using by value lnk-hwnd.
     move BROWSE-DEFAULT-PRINTER to option of default-info
     move lnk-hwnd to hwnd of MyDefaultPrinter
     move 127 to len of MyDefaultPrinter

     call "PC_PRINTER_SET_DEFAULT" using
                             by value option of default-info
                             by reference hwnd
                   returning Printer-RetCode
     end-call

     if Printer-RetCode not equal zero
         display "Unable to browse for a default printer"
         display " + Retcode = " Printer-RetCode
         stop run
     end-if

     display "Browse Printer : "
         body of MyDefaultPrinter(1:len of MyDefaultPrinter)

     move SET-DEFAULT-PRINTER to option of default-info
     move len of MyDefaultPrinter to len of ourprinter
     move body of MyDefaultPrinter(1:len of MyDefaultPrinter)
         to body of ourprinter

     call "PC_PRINTER_SET_DEFAULT" using
                     by value option of default-info
                     by reference ourprinter of default-info
                     returning Printer-RetCode
     end-call

     if Printer-RetCode not equal zero
         display "Unable to set a default printer"
         display " + Retcode = " Printer-RetCode
         stop run
     end-if

     move "c:\config.sys" to body of filename
     move 13 to len of filename

     move "My Config.sys" to body of document
     move 13 to len of document

     move USE-PROGRESS-DIALOG to document-flags
     move zero to window-handle

     call "PC_PRINT_FILE" using by reference filename
                                by reference document
                                by value document-flags
                                by value window-handle
                          returning Printer-RetCode
     end-call

     if Printer-RetCode not equal zero
         display "PC_PRINT_FILE failed.. " Printer-RetCode
     else
         display "PC_PRINT_FILE: OK"
     end-if
     .
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_SET_FONT

Sets the current font for the printer.

Syntax:

call "PC_PRINTER_SET_FONT" using     printer-handle
                                     font-family-name
                           by value  font-size
                           by value  font-style
                           returning status-code

Parameters

printer-handle
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
font-family-name
Group predefined as cblt-printer-name containing:
01 cblt-printer-name       typedef.
  03 cblte-pn-name-length  cblt-x2-comp5. *> pic x(2) comp-5.
  03 cblte-pn-name         cblt-x1.       *> Occurs depending on
                                          *> cblte-pn-name-length.  pic x(n).
font-size
Call prototype (see Key): Numeric literal or cblt-x4-comp5
Picture: Numeric literal or pic x(4) comp-5.
font-style
Call prototype (see Key): Numeric literal or cblt-x4-comp5
Picture: Numeric literal or pic x(4) comp-5.
status-code
See Library Routines - Key.

On Entry:

printer-handle | The printer handle returned when the printer was opened.
name-len | The length of the font family name.
name-text | The family name of the font to be used (for example, Courier, Helvetica, Times, Symbol, Times New Roman, Roman, and so on).
font-size | Point size of font.
font-style Set of bits defining the required font style:
Bit 15
The high-order 32-bits contain a printer character set as defined by Windows
Bit 3
Bold
Bit 2
Strikeout
Bit 1
Underline
Bit 0
Italic

All remaining bits are reserved for future use and should not be set.

status-code | Printer Handling Routines Return Codes

On Exit:

status-code Printer Handling Routines Return Codes
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines
Related information
Printer Handling Routines Return Codes
Printer Routines


PC_PRINTER_SET_PEN

Set the width, style and colour for lines and rectangles when drawn using a printer.

Syntax:

call "PC_PRINTER_SET_PEN" using
                          by value Printer-Handle
                          by value Pen-Width
                          by value Pen-Style
                          by value Pen-red
                          by value Pen-blue
                          by value Pen-green
end-call

Parameters:

 | Using call prototype (see Key) | Picture
pen-width | cblt-x4-comp5 | pic x(4) comp-5.
pen-red | cblt-x | pic x
pen-blue | cblt-x | pic x

On Entry:

 | Value | Meaning
pen-style | 0 | solid line
 | 1 | dash
 | 2 | dot
 | 3 | dash, Dot
 | 4 | dash, dot, dot
 | 5 | invisible
pen-red | Value between 0 and 255 | intensity of red
pen-green | Value between 0 and 255 | intensity of green
pen-blue | Value between 0 and 255 | intensity of blue

On Exit:

status-code Printer Handling Routines Return Codes
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_SET_POSITION

Move the logicial printer position ready for the next PC_PRINTER_WRITE.

Syntax:

call "PC_PRINTER_SET_POSITION" using
                               by value printer-handle
                               by value set-options
                               by value new-x
                               by value new-y
end-call

Parameters:

 | Using call prototype (see Key) | Picture
set-options | cblt-x4-comp5 | pic x(4) comp-5.
new-y | cblt-x4-comp5 | pic x(4) comp-5.

On Entry:

 | Value | Meaning
set-options | 0 | use logical units
 | 1 | use char units

On Exit:

status-code Printer Handling Routines Return Codes

Comments:

If SET-OPTIONS-USE-CHAR-UNITS is used, ensure you have selected a fixed pitch/monospace font such as Courier New and Lucida Console.

Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_WRITE

Writes a text string to the printer.

Syntax:

call "PC_PRINTER_WRITE" using     printer-handle
                                  print-buffer
                        by value  print-buffer-len
                        returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
printer-handle | cblt-x4-comp5 | pic x(4) comp-5.
print-buffer | pic x(n). | pic x(n).
print-buffer-len | Numeric literal or cblt-x4-comp5 | Numeric literal or pic x(4) comp-5.
status-code | See Library Routines - Key |

On Entry:

printer-handle | The printer handle returned when the printer was opened
print-buffer | The buffer from which the bytes are to be printed
print-buffer-len | The number of bytes to print

On Exit:

status-code Printer Handling Routines Return Codes
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


PC_PRINTER_WRITE_BMP

Write a loaded bitmap to a printer at a specified position with a given size.

Syntax:

call "PC_PRINTER_WRITE_BMP" using      printer-handle
                            by value  bmp-id
                            by value  options
                            by value  bmp-row
                            by value  bmp-col
                            by value  bmp-width
                            by value  bmp-height
                            returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
printer-handle | cblt-x4-comp5 | pic x(4) comp-5.
options | cblt-x4-comp5 value 0 | pic x(4) comp-5 value 0.
bmp-id | cblt-x4-comp5 | pic x(4) comp-5.
bmp-row | cblt-x4-comp5 | pic x(4) comp-5.
bmp-col | cblt-x4-comp5 | pic x(4) comp-5.
bmp-width | cblt-x4-comp5 | pic x(4) comp-5.
bmp-height | cblt-x4-comp5 | pic x(4) comp-5.
status-code | See Library Routines - Key

On Entry:

printer-handle
The printer handle returned when the printer was opened.
options
Bit 1: Preserve the aspect ratio of the bitmap.
Bit 2: Center the bitmap if bitmap aspect ratio is preserved.
Bit 9: Use bmp-row, bmp-col, bmp-width, bmp-height as logical units rather than character positions.
bmp-id
The unique id of the bitmap to print.
bmp-row
The row at which the bitmap is to be printed.
bmp-width
The width of the bitmap in characters. The value you specify is multiplied by the width of the currently selected font to determine the width that is used when printing the bitmap.
bmp-height
The height of the bitmap in characters. The value you specify is multiplied by the height of the currently selected font to determine the height that is used when printing the bitmap.
status-code
Printer status code:
0 | Successful
3 | Printer device not open
4 | Out of memory while printing
5 | Disk full while spooling file
7 | Print job aborted, no file spooled to Print Manager
11 | Write failure
21 | Failed to print bitmap
31 | Bad position; x or y out of bounds
32 | Move to x,y failed
33 | Line to x,y failed
34 | Rectangle failed to be drawn

On Exit:

status-code
Printer Handling Routines Return Codes

Comments:

This routine is available only in the Windows environment.

Restrictions:

  • This routine works with PostScript and HP PCL printers.
  • This routine is not supported on HP Deskjet or dot matrix printers.

Example:

 call "PC_PRINTER_WRITE_BMP" USING printer-handle
                                   BY VALUE  bmp-id-logo
                                   BY VALUE  3 size 4
                                   BY VALUE  7 size 4
                                   BY VALUE  5 size 4
                                   BY VALUE  25 size 4
                                   BY VALUE  15 size 4
                                                     RETURNING printer-retcode
 end-call
Parent topic: Printer Routines
Parent topic: Alphabetical List of Library Routines


Printer Handling Routines Return Codes

Possible return codes from the printer handling library routines are:

0 | Success
1 | Could not open printer device
2 | Invalid printer control code specified
3 | No printer device associated with specified handle
4 | Out of memory while printing
5 | Failed to open file
6 | Disk full while spooling file
7 | Print job aborted. No job sent to print spooler
8 | Printer information structure badly constructed
9 | No default printer found
10 | Error attempting to display dialog
11 | Write failure
12 | No fonts found usable with this printer
13 | The font requested does not exist
14 | User aborted print job
15 | Reserved
16 | Reserved
17 | Reserved
18 | Failed to load bitmap
19 | Invalid bitmap id
20 | Failed to free bitmap
21 | Failed to print bitmap
22 | Bad parameter
23 | Internal error
24 | User pressed Cancel on the printer setup dialog or on the font selection dialog
25 | Unsupported function
26 | Duplex not supported
27 | Paper tray not found
28 | Paper size not supported
29 | Printer enumeration started
30 | End of printer enumeration
31 | Bad position - x or y out of bounds
32 | Move to x,y failed
33 | Line to x,y failed
34 | Rectangle failed to be drawn
Parent topic: Printer Routines
Related information
Alphabetical List of Library Routines


Program Canceling Routines

  • CBL_CANCEL
    Cancels a COBOL program.
  • CBL_CANCEL_PROC
    Provides control over program cancels.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_CANCEL

Cancels a COBOL program.

Syntax:

call "CBL_CANCEL"  using by value     flags
                         by reference program-name
                            returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
flags | cblt-x4-comp5250 | pic x(4) comp-5
program-name | pic x(n) | pic x(n)
status-code | See Library Routines - Key |

On Entry:

flags
The type of cancel behavior required. You can set the following bits:
Bit pair 0/1 (value 1/2)
logical/physical flags
00 | Perform the default CANCEL behavior
01 | Physically cancel the program
10 | Logically cancel the program if possible, otherwise physically cancel it.
11 | Reserved. Must not be used.
Bit 2 (value 4)
Reserved. Must not be used.
Bit 3 (value 8)
Prevent .dll code and shared object code from being physically canceled as part of a logical cancel operation.
0 | Physically cancel .dll code and shared object code as part of a logical cancel operation
1 | Do not physically cancel .dll code and shared object code as part of a logical cancel operation
program-name
The space- or null-terminated name of the program you want to cancel. The name can contain spaces as long as it starts with a double quote character (").

On Exit:

None.

Comments:

This routine provides finer run-time control of program cancelation than the COBOL CANCEL statement. It always returns zero, whether or not it was successful.

Any imported .dll files are automatically removed from memory when the .dll file which imports them is cancelled.

Parent topic: Program Canceling Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
File and Filename Routines


CBL_CANCEL_PROC

Provides control over program cancels.

Syntax:

call "CBL_CANCEL_PROC" using by value function
                       by reference   parameter-block
                       by value       cblte-cppb-userdata-length
                       returning      status-code

Parameters

function
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
parameter-block
Group predefined as cblt-cancel-proc-params containing
01 cblt-cancel-proc-params      typedef.
    03 cblte-cppb-version       cblt-x4-comp5. *> pic x(4) comp-5 value 0.
    03 cblte-cppb-flags         cblt-x4-comp5. *> pic x(4) comp-5.
    03 cblte-cppb-callback      cblt-ppointer  *> usage procedure-pointer.
    03 cblte-cppb-handle        cblt-pointer   *> usage pointer.
    03 cblte-cppb-userdata      cblt-pointer   *> usage pointer.
    03 cblte-cppb-priority      cblt-x4-comp5. *> pic x(4) comp-5.
cblte-cppb-userdata-length
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
status-code
See Library Routines - Key.

On Entry:

function
Can be set to one of the following:
0 | Installs a cancel-routine at the default priority of 64:
1 | Installs a cancel-routine at a specified priority. See the section Comments.
2 | Enables a program to change the priority of a previously installed cancel routine:
3 | Enables a cancel-registration to be de-installed without causing the cancel-routine to be called.
4 | Enables a cancel-registration to be de-installed after causing the cancel-routine to be called. Note that the cancel-routine can detect if it is being called because of a de-install rather than a real CANCEL.
All other values are reserved for future expansion.
cblte-cppb-version
The "version" number of the parameter block. The parameter block described here must have this field set to zero.
cblte-cppb-flags
None defined at present. Must be set to zero.
cblte-cppb-callback
If function is set to:
0, 1 | The cancel-routine to install.
2-4 | Ignored.
cblte-cppb-handle
If function is set to:
0, 1 | The program-handle of the program to which to attach the cancel-routine, or NULL. See the discussion on program-handles in the section Comments.
2 | The handle of the cancel-routine to modify registration.
3, 4 | The handle returned from when function was set to either 0 or 1. This is the handle of the cancel-routine to de-register.
user-data
If function is set to:
0, 1 | User-defined data area. See discussion on user-data areas in the section Comments.
2-4 | Ignored.
user-data-length
If function is set to:
0, 1 | The length of the cblte-cppb-userdata block, or zero. See discussion on user-data areas in the section Comments.
2-4 | Ignored.

On Exit:

cblte-cppb-version
Ignored.
flags
Ignored.
cblte-cppb-callback
Ignored.
cblte-cppb-handle
If function is set to:
0, 1 | The handle for the cancel-registration, or NULL.
2 | Ignored.
3, 4 | NULL.
cblte-cppb-userdata
Ignored.
cblte-cppb-priority
Ignored.
status-code
0000 | Success - The operation was performed as requested.
1000 | Memory allocation error processing request.
1001 | Bad handle passed to API (Registration-handle).
1007 | System error (that is, any error not listed here).
1009 | Bad parameter passed (in function, param, and so on).

Comments

This routine provides a mechanism by which a COBOL program can receive notification of an impending cancel of either itself, or another COBOL program.

Such notification enables a COBOL program to finalize its use of, and deallocate, any resources it has allocated during its existence that are not already handled automatically by the COBOL run-time system or the operating system. These resources are normally those provided by the operating system or run-time system, but could also be some resource provided by another module in the application itself.

The COBOL run-time system performs notifications by processing a list (the cancel-list) which it has associated with the program being canceled. Therefore, to enable a notification, the COBOL run-time system must be instructed to create an entry in the cancel-list. Managing entries in cancel-lists is the purpose of CBL_CANCEL_PROC.

To create an entry in the cancel-list, CBL_CANCEL_PROC needs to know three things:

  • The program which, when canceled, triggers the notification. This program is identified by a program-handle (set on entry by the parameter cblte-cppb-handle).
  • The cblte-cppb-callback to call. The cblte-cppb-callback is the entry point called when the program is canceled.
  • A cancel-priority. This is the priority for this notification.

This information is provided to the run-time system by setting the parameter function to 0 or 1. By doing this, you create an entry in the cancel-list associated with the program cblte-cppb-handle. The entry specifies that the cblte-cppb-callback should be called when notification is due. The position in the list is determined by the value of cancel-priority.

The entry in the cancel-list created can be referenced using the value returned by the registration call in the cblte-cppb-handle parameter on exit. This enables a program to modify the registration at a later time, using this routine with function set to 2, 3 or 4; for example, you can change the priority of the registration, or remove it from the list.

A program-handle is a unique value which the COBOL run-time system associates with a cancelable entity. Therefore, all entry-points in a COBOL program share the same program-handle, as cancelling any entry-point in a COBOL program cancels all entry points in that program.

There are two basic methods of using the CBL_CANCEL_PROC routine, and the amount of work a program needs to do in order to obtain the correct program-handle depends on which method is necessary.

Local registration

When a program wishes to receive a notification that it is to be canceled, it can make a local registration - usually in its "first time in" code. For this method of registration, the program need only pass NULL as a program-handle. The CBL_CANCEL_PROC routine then automatically locates the correct program-handle and creates an entry in the correct list.

Usually, the cblte-cppb-callback specified in a local registration is an entry-point in the registering program (though it doesn't have to be).

An example would be a program which allocated some resource directly from the operating system and which needed the opportunity to deallocate it before being canceled.

Service registrations

This is a slightly more complicated type of registration, and is used when a service program (that is, a program which manages a resource on behalf of other COBOL programs) needs to receive notification that one of its clients is being canceled. For this method of registration, the program-handle should be obtained using a call to the CBL_GET_PROGRAM_INFO routine. The parameters to CBL_PROGRAM_INFO depend on what functionality you require. The most usual usage would be to get the program-handle of the calling program using function 2 of the CBL_GET_PROGRAM_INFO routine.

Usually, the cblte-cppb-callback specified in a service registration is an entry-point in the service program (though it doesn't have to be).

An example would be a file-handler module which opens and manages files on behalf of several other COBOL programs; when a given program is canceled, all files opened on behalf of that program must be closed automatically according to the semantics of COBOL.

Notice that this example could also be handled by including a local registration in each program which opens a file, which simply closes its files. However, such an approach would be prone to error, does not conform to COBOL semantics, and is very untidy.

When using the CBL_CANCEL_PROC routine for a service program, it is important that when an applicable resource is relinquished by the client program, the notification for it is removed from the cancel-list of that client program. This should be done by setting function to 3 or 4. To make this efficient, the service program could store the program-handle, returned when function is set to 0 or 1, within the resource structure, so that it can be easily located to be passed back as the registration-handle when function is set to 3 or 4.

If the service program fails to de-register a registration using function 3 or 4, a spurious notification will occur when the client program is eventually canceled, leading to unpredictable results.

If the cancel routine cancels other programs, those programs should not themselves have a CBL_CANCEL_PROC installed.

In addition to the three mandatory pieces of information required by CBL_CANCEL_PROC (that is, program-handle, cblte-cppb-callback and cancel-priority; function set to 0 or 1) set using , it can accept an optional fourth, cblte-cppb-userdata.

User Data Areas

By using the cblte-cppb-userdata parameter, a program registering a cblte-cppb-callback can specify a parameter to be passed to the cblte-cppb-callback when it is notified that a program has been canceled. You can specify a different cblte-cppb-userdata parameter for each registration, or the same cblte-cppb-userdata field can be specified for multiple registrations. In addition, you can specify that the cblte-cppb-userdata parameter is copied (and the copy passed to the cblte-cppb-callback as a parameter), by specifying a non-zero cblte-cppb-userdata-length parameter.

This facility is extremely useful when used by a service program - the service program does not need to manage a list to associate a client program with a service "handle", but can receive the service "handle" directly as a parameter to the cblte-cppb-callback provided it passed the "handle" to the CBL_CANCEL_PROC registration process as a cblte-cppb-userdata parameter.

Specifying a non-zero cblte-cppb-userdata-length parameter

This is more convenient than using a cblte-cppb-userdata-length parameter set to zero, but should typically be used only for small cblte-cppb-userdata areas. If the cblte-cppb-userdata-length parameter is set to non-zero, the specified number of bytes are copied from the address in the cblte-cppb-userdata parameter, and that copy is retained in the list entry. When the program associated with the relevant program-handle is canceled, the cblte-cppb-callback receives the copy of the cblte-cppb-userdata area as a parameter. The copy is deleted automatically by the COBOL run-time system after the cblte-cppb-callback has returned.

It should be noted that the CBL_CANCEL_PROC routine knows nothing about the structure of the cblte-cppb-userdata area passed to it, and only copies a flat memory block. For instance, items of USAGE POINTER embedded within the block will be copied, but the memory to which they point will not. In this case it is probably more appropriate for the application to allocate and copy the entire data structure itself, and pass the copy using a cblte-cppb-userdata-length of zero.

In .NET, do not specify a cblte-cppb-userdata-length of zero.

Specifying a cblte-cppb-userdata-length parameter of zero

If the cblte-cppb-userdata-length parameter is set to zero (and therefore the original cblte-cppb-userdata parameter specified to the registration process is passed to the cblte-cppb-callback), it is up to the cblte-cppb-callback to delete or deallocate all data structures within that block.

It should be noted that special care must be taken when using this method to pass a cblte-cppb-userdata parameter, especially if the same cblte-cppb-userdata area is registered to more than one registration-handle (the registration handle is returned on exit by the cblte-cppb-handle parameter). Specifically, care must be taken to ensure that any allocated resources are deallocated exactly once, and that allocated resources remain valid until after the last registration-handle to which they are associated has been destroyed. This can usually be accomplished by having a usage-count field somewhere in the cblte-cppb-userdata area, which is incremented each time the cblte-cppb-userdata parameter is registered to a registration-handle and decremented each time a cblte-cppb-callback is called with it as a parameter.

Priorities (set using a value of 1 to function) must be between 0 and 127 for user-code. Priorities 200 to 209 are reserved for File Handler usage. Specifying any other priority value will cause unpredictable results. The default value of 64 should be acceptable for most applications.

Implementation of a CANCEL routine

This section describes how to implement a cancel routine suitable for installing with CBL_CANCEL_PROC.

 working-storage section.
 01 cancel-status   pic x(4) comp-5.

 linkage section.
 01 cancel-reason   pic x(4) comp-5.
 01 cancel-flags    pic x(4) comp-5.
 01 prog-id      usage pointer.
 01 cblte-cppb-userdata       usage pointer.

 procedure division.
 entry "user-cblte-cppb-callback" using by value cancel-reason
                             by value       cancel-flags
                             by value       prog-id
                             by value       cblte-cppb-userdata.
 cblte-cppb-callback section.
 cblte-cppb-callback-para.
*> This is where the code which handles the CANCEL-notification goes.
*> The cblte-cppb-userdata field specified in the registration is passed
*> to us here, along with the program-id of the program being canceled.
*> If this routine is handling registrations which specified a
*> cblte-cppb-userdata-field length of zero, then the memory pointed to
*> by cblte-cppb-userdata may also need to be freed before returning.

 exit program returning cancel-status.

The cancel-reason parameter describes the reason for the CANCEL. When set:

Bit 0 (value 1) | CANCEL is due to STOP RUN processing.
Bit 6 (value 64) | CANCEL is due to DEINSTALL (CBL_CANCEL_PROC called with function set to 4).

All other bits are reserved and should be ignored.

The cancel-flags parameter is currently reserved and should be ignored.

Parent topic: Program Canceling Routines
Parent topic: Alphabetical List of Library Routines


Program Information Routines

Restriction: This routine is supported for native COBOL only.

The program information routine enables you to get information about a program.

  • CBL_GET_PROGRAM_INFO
    Returns information for a named program, or a program in the current call stack.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_GET_PROGRAM_INFO

Returns information for a named program, or a program in the current call stack.

Restriction: Function 8 of this routine (return number of arguments) is supported for native COBOL only.

Syntax:

call "CBL_GET_PROGRAM_INFO" using by value function
                            by reference   param-block
                            by reference   return-buf
                            by reference   return-buf-len
                            returning      status-code

Parameters

function
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
param-block
Group predefined as cblt-prog-info-params containing
 01 cblt-prog-info-params   typedef.
   03 cblte-gpi-size        cblt-x4-comp5.   *> pic x(4) comp-5.
   03 cblte-gpi-flags       cblt-x4-comp5.   *> pic x(4) comp-5.2.
   03 cblte-gpi-handle      cblt-pointer.    *> usage pointer.
   03 cblte-gpi-prog-id     cblt-pointer.    *> usage pointer.
   03 cblte-gpi-attrs       cblt-x4-comp5.   *> pic x(4) comp-5.
return-buf
Call prototype (see Key): cblt-prog-info-arg-info
Picture: pic x(n).
return-buf-len
Call prototype (see Key): cblt-x4-comp5
Picture: pic x(4) comp-5.
status-code
See Library Routines - Key.

On Entry:

function
Specifies the function to be performed:
0 Return status information for the current program. If you want to retrieve further information on this program, then bit 0 of the cblte-gpi-flags parameter must be set to indicate that this function should return cblte-gpi-handle, which will be used as an input to function 2 through 8. The initial program associated with cblte-gpi-handle is the current program.

When other functions that use cblte-gpi-handle have completed, you must use CBL_GET_PROGRAM_INFO again, with function set to 3, to deallocate the handle.

1 Return status information for named program. If you want to retrieve further information on this program, then bit 0 of the cblte-gpi-flags parameter must be set to indicate that this function should return cblte-gpi-handle, which will be used as an input to function 2 through 8. The initial program associated with cblte-gpi-handle is the named program.

When other functions that use cblte-gpi-handle have completed, you must use CBL_GET_PROGRAM_INFO again, with function set to 3, to deallocate the handle.

2 Return status information for the program that called the program currently associated with cblte-gpi-handle. This function requires that cblte-gpi-handle has been set up using functions 0 or 1. The program associated with cblte-gpi-handle is updated to the calling program.

When other functions that use cblte-gpi-handle have completed, you must use CBL_GET_PROGRAM_INFO again, with function set to 3, to deallocate the handle.

3 | Close a previously created cblte-gpi-handle. This function requires a valid cblte-gpi-handle to have been created using function 0 or 1. A call with this function must be made when cblte-gpi-handle is finished with.
4 | Find the first entry point of the program currently associated with cblte-gpi-handle. cblte-gpi-handle must have been set up using function 0 or 1. Once a call with this function has been made, you can repeatedly use this routine with function set to 5 to retrieve all remaining entry points in the program. Once all of the required entry points have been returned, you can use this routine with function set to 6 to terminate the entry-point search.
5 | Find the next entry point of the program currently associated with cblte-gpi-handle. This function requires a valid cblte-gpi-handle to have been set up using function 0 or 1, and for function 4 to have been used to initiate the find first/next entry-point sequence.
6 | Terminate the entry-point search. It requires a valid cblte-gpi-handle to have been set up using function 0 or 1, and for function 4 to have been called to initiate the find first/next entry-point sequence.
7 | Return the full program-name of the program currently associated with cblte-gpi-handle. This function requires a valid cblte-gpi-handle to have been set up using function 0 or 1.
8 Return the number of arguments the program currently associated with cblte-gpi-handle was called with. This information can only be returned if the program is on the current call stack.
Restriction: Function 8 (return number of arguments) is supported for native COBOL only.
cblte-gpi-size
The size of the parameter block including this field. This should be set to a value of 20 on 32-bit systems, or 28 on 64-bit systems.
cblte-gpi-flags
A 32-bit word indicating what information is to be returned:
Bit 0
Determines whether functions 0 and 1 return cblte-gpi-handle. For all other functions, this bit is ignored.
0 | Do not return cblte-gpi-handle (if function is set to 0 or 1)
1 | Return cblte-gpi-handle (if function is set to 0 or 1)
Bit 1
Determines whether functions 0 and 2 should return the program's basename in name-buf as part of the program status information.
0 | Do not return basename of program (if function is set to 0 or 2)
1 | Return basename of program in name-buf (if function is set to 0 or 2)
Bit 2
Determines whether basenames and full program names that are input or returned in name-buf should be in null-terminated or space- terminated format.
0 | All input and output names are space-terminated
1 | All input and output names are null-terminated.
Bit 3
Determines whether functions 0, 1and 2 should return the program's attributes in cblte-gpi-attr.
0 | Do not return program attributes in cblte-gpi-attr.
1 | Return program attributes in cblte-gpi-attr.
Bits 4-31
Reserved for future use - must be set to 0.
cblte-gpi-handle
A handle created by function 0 or 1.
return-buf
If function is set to:
0 The basename of the program for which information is required.
8 A group predefined as
01 RETURN-BUF.
     05 cblte-gpiai-size        pic x(4) comp-5 value zeroes.
     05 cblte-gpiai-argc        pic x(4) comp-5 value zeroes.
     05 cblte-gpiai-reserved1   pointer value null.
     05 cblte-gpiai-reserved2   pointer value null.

cblte-gpiai-size must be set to either 16 on 32-bit systems or 24 on 64-bit systems.

return-buf-len
The length of return-buf. If this is too small for the information being returned, the routine fails.

On Exit:

cblte-gpi-handle
The handle returned by functions 0 and 1, which must be used for all other functions.
cblte-gpi-prog-id
Unique identifier for the program currently associated with cblte-gpi-handle.
cblte-gpi-attr
Attributes of the program currently associated with cblte-gpi-handle.
Bit 0
0 | Program not compiled using AMODE"24" Compiler directive.
1 | Program compiled using the AMODE(24) Compiler directive (this Compiler directive is supported in native code only).
Bit 1
0 | Program not compiled using AMODE"32" Compiler directive.
1 | Program compiled using the AMODE(31) Compiler directive (this Compiler directive is supported in native code only).
Bit 2
0 | Program compiled using the CHARSET(ASCII) Compiler directive.
1 | Program compiled using the CHARSET(EBCDIC) Compiler directive.
Bit 3
0 | Program not compiled using the ANS85 Compiler directive.
1 | Program compiled using the ANS85 Compiler directive.
Bit 4
0 | Program not compiled using the VSC2 Compiler directive.
1 | Program compiled using the VSC2 Compiler directive (this Compiler directive is supported in native code only).
Bit 5
0 | Program not compiled using the OSVS Compiler directive.
1 | Program compiled using the OSVS Compiler directive (this Compiler directive is supported in native code only).
Bit 6-25
Reserved for future use - must be set to 0.
Bit 26
0 | Program is not a system program.
1 | Program is a system program.
Bit 27
Reserved for future use - must be set to 0.
Bit 28
0 | Program is not a member not of a subsystem.
1 | Program is a member of a subsystem.
Bit 29
0 | Program exists in current call stack.
1 | Program does not exist in current call stack.
Bit 30
0 | Program is not canceled.
1 | Program is canceled.
Bit 31
0 | Program is COBOL.
1 | Program is non-COBOL.
return-buf
If function was set to:
0, 2 | The basename that was requested.
4, 5 | The entry point name that was requested.
7 | The full program name that was requested.
8 The call parameter information that was requested, where cblte-gpiai-argc contains the number of arguments the program was called with.

cblte-gpiai-reserved1 and cblte-gpiai-reserved2 remain set to NULL.

return-buf-len
Length of the name returned in name-buf, or required buffer length if the status-code is 1013.
status-code
Status of operation:
0 | Success.
500 | End of information (returned by function 2 when there is no caller of the currently associated program, or by function 5 when no more entry points exist).
1000 | Memory allocation error.
1001 | Invalid cblte-gpi-handle input.
1006 | Invalid operation on handle (returned by function 8 if the program associated with cblte-gpi-handle is not on the call stack).
1009 | Invalid parameter.
1011 | Program or entry name not found.
1013 | Buffer too small for information to be returned.
Parent topic: Program Information Routines
Parent topic: Alphabetical List of Library Routines


Run-unit Handling Routines

The multiple run-unit routines enable you to make use of the Concurrency support provided with this system.

  • CBL_ABORT_RUN_UNIT
    Aborts the current run unit irrespective of the state of existing threads.
  • CBL_CULL_RUN_UNITS
    Clears any dead run units.
  • CBL_EXEC_RUN_UNIT
    Creates a synchronous or asynchronous run unit.
  • CBL_GET_SHMEM_PTR
    Reads a named value.
  • CBL_PUT_SHMEM_PTR
    Creates or updates a named value.
  • CBL_YIELD_RUN_UNIT
    Yields the remainder of a run-unit's time-slice.
Parent topic: Library Routines
Related information
Memory Allocation Routines
Alphabetical List of Library Routines


CBL_ABORT_RUN_UNIT

Aborts the current run unit irrespective of the state of existing threads.

Syntax:

call 'CBL_ABORT_RUN_UNIT' using by value ret-value

Parameters:

 | Using call prototype (see Key) | Picture
ret-value | cblt-x4-comp5 | pic x(4) comp-5.

On Entry:

ret-value Return-code to be returned to the operating system by this run unit when it terminates.

Comments:

In a single-threaded application or run-time system this call is equivalent to the following syntax:

stop run returning ret-value

In a multi-threaded application STOP RUN waits for all existing threads to exit before terminating the run unit. CBL_ABORT_RUN_UNIT, however, does not wait for any existing thread to exit. It cancels all running threads and then terminates the run unit, returning control to the operating system.

Note: We recommend that you use this call only when a serious problem has been detected in the application. Calling this routine in a multi-threaded application could cause severe problems, as threads might be terminated in the middle of critical file operations.
Parent topic: Run-unit Handling Routines
Parent topic: Alphabetical List of Library Routines


CBL_CULL_RUN_UNITS

Clears any dead run units.

Syntax:

call "CBL_CULL_RUN_UNITS"

Parameters:

None.

Comments:

This routine clears any run units that have been terminated by a STOP RUN or kill, but have not yet been removed.

Parent topic: Run-unit Handling Routines
Parent topic: Alphabetical List of Library Routines


CBL_EXEC_RUN_UNIT

Creates a synchronous or asynchronous run unit.

Syntax:

call "CBL_EXEC_RUN_UNIT" using        command-line
                         by value     command-line-len
                         by reference run-unit-id
                         by value     stack-size
                         by value     flags
                         returning    status-code

Parameters:

 | Using call prototype (see Key) | Picture
command-line | pic x(n). | pic x(n).
command-line-len | cblt-os-size. | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
run-unit-id | cblt-x8-comp5. | pic x(8) comp-5. Must be level 01.
stack-size | cblt-os-size. | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
flags | cblt-os-flags. | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
status-code | See Library Routines - Key

On Entry:

command-line
The command passed to the new . This should be the program-name followed by any parameters.
line-length
The length of the command line.
stack-size
This parameter is ignored.
flags
A word indicating how the new run unit is created as follows:
Bit 0
0 | CBL_EXEC_RUN_UNIT returns to the caller immediately after creating the child process.
1 | CBL_EXEC_RUN_UNIT waits for the new run unit to complete before returning to the caller.
Bit 1
Ignored.
Bit 2
0 | The newly created run unit inherits the caller's console for screen I/O. Only one member of the coru should access this console at a time, otherwise unpredictable results may be encountered.
1 | The newly created run unit has a new console for terminal I/O allocated to it. This console is independent from the parent and can be used for screen I/O.
Remaining bits
Reserved - must be set to 0.

On Exit:

run unit-id
If bit 0 of flags is not set, the unique handle identifying the new run-unit. If bit 0 of flags is set, this value is unchanged.
status-code
Status of operation:
0 | Success
157 | Out of memory
181 | Invalid parameter
200 | Internal logic error
255 | Called program not found
Other non-zero | Returned error code from the executed program

Comments:

The run unit that makes the call is known as the parent, while the run unit created is known as the child. When the child is created it inherits certain attributes from its parent. The attributes inherited by the child are copies of the attributes in the parent at the exact time of the call; any changes made to the attributes of the parent after the call are not reflected in the child's attributes. Similarly, any changes made to the child's attributes are not reflected in the parent's attributes.

Bit 1 flag controls which attributes of the parent are inherited by the child.

In the .NET environment, the run unit created by this command does not inherit any COBOL or run-time switches, or environment variables. CBL_EXEC_RUN_UNIT does not open libraries for the run unit it creates.

The set of run units containing the initial run unit and all run units created from it is known as the coru.

You should be aware of the following when using run units:

  • All COBOL programs in the child are in their initial state.
  • Data can be shared between run units by allocating it as shared memory using CBL_ALLOC_MEM or CBL_ALLOC_SHMEM, and then passing the address of this memory between the run units using CBL_PUT_SHMEM_PTR and CBL_GET_SHMEM_PTR
  • Open files and heaps are never inherited from the parent.
  • Screen I/O from one run-unit can interfere with that from another run-unit causing unexpected results. This is particularly a problem on UNIX but can also be an issue on Windows if the console is being shared by two or more processes. Avoid screen I/O operations from more than one concurrent run-unit.
Parent topic: Run-unit Handling Routines
Parent topic: Alphabetical List of Library Routines


CBL_GET_SHMEM_PTR

Reads a named value.

Syntax:

call "CBL_GET_SHMEM_PTR" using     node-value
                                   node-name
                         returning status-code

Parameters

node-value
Call prototype (see Key): cblt-pointer
Picture: usage pointer.
node-name
Group predefined as cblt-node-name containing:
01  cblt-node-name          typedef.
  03 cblte-nname-name-len   cblt-x1-comp5. *> pic x comp-5 value n.
  03 cblte-nname-name-text  cblt-x1.       *> occurs depending cblte-nname-name-len.
                                           *> pic x(n) value "name".
status-code
See Library Routines - Key.

On Entry:

cblte-nname-name-len
The length of name.
cblte-nname-name-text
The value assigned to node-name.

On Exit:

node-value
The value of the named value.

Comments:

In .NET, this call only works within a run unit, meaning that memory cannot be shared across run units.

Named values provide a way of passing pointers between different run units using a name agreed at run time. Named values can be read simultaneously by all units in the coru because the run-time system protects and serializes any updates. The maximum number of named values depends on how much memory your machine has.

Parent topic: Run-unit Handling Routines
Parent topic: Alphabetical List of Library Routines


CBL_PUT_SHMEM_PTR

Creates or updates a named value.

Syntax:

call "CBL_PUT_SHMEM_PTR" using by value     node-value
                               by reference node-name
                         returning          status-code

Parameters

node-value
Call prototype (see Key): cblt-pointer
Picture: usage pointer.
node-name
Group predefined as cblt-node-name containing:
01  cblt-node-name          typedef.
  03 cblte-nname-name-len   cblt-x1-comp5. *> pic x comp-5 value n.
  03 cblte-nname-name-text  cblt-x1.       *> occurs depending cblte-nname-name-len.
                                           *> pic x(n) value "name".
status-code
See Library Routines - Key.

On Entry:

node-value | The value to assign to the created/updated named value.
cblte-nname-name-len | The length of name.
cblte-nname-name-text | The name of the named value.

On Exit:

None

Comments:

In .NET, this call only works within a run unit, meaning that memory cannot be shared across run units.

Named values provide a way of passing pointers between different run-units using a name agreed at run-time. Named values can be read simultaneously by all units in the coru because the run-time system protects and serializes any updates. The maximum number of named values depends on how much memory your machine has.

Parent topic: Run-unit Handling Routines
Parent topic: Alphabetical List of Library Routines


CBL_YIELD_RUN_UNIT

Yields the remainder of a run-unit's time-slice.

Syntax:

call "CBL_YIELD_RUN_UNIT"

Parameters:

None

Comments:

The remainder of the run-unit's time-slice is yielded to unspecified run-units.

Parent topic: Run-unit Handling Routines
Parent topic: Alphabetical List of Library Routines


Screen Routines

Restriction: These routines are supported for native COBOL only.

A number of the screen routines specify the screen-position parameter. In this COBOL system, the top left corner of the screen is row 0, column 0. For example, if you want to change attributes beginning in row 5, column 8, you specify row-number as 4 and column-number as 7.

The CBL_GET_SCR routines enable you to make use of generic line drawing to produce the best possible representation of graphics characters available in any supported environment without having to modify your source programs.

  • CBL_CLEAR_SCR
    Clears the whole screen to a specified character and attribute.
  • CBL_GET_CSR_POS
    Returns the cursor position.
  • CBL_GET_SCR_GRAPHICS
    Returns operating system independent codes for graphics characters.
  • CBL_GET_SCR_LINE_DRAW
    Returns a table of values defining the character values required by the run-time system screen output routines to correctly display given line drawing characters.
  • CBL_GET_SCR_SIZE
    Returns information about the size of the screen.
  • CBL_READ_SCR_ATTRS
    Reads a string of attributes from the screen.
  • CBL_READ_SCR_CHARS
    Reads a string of characters from the screen.
  • CBL_READ_SCR_CHATTRS
    Reads a string of characters and their attributes from the screen.
  • CBL_SET_CSR_POS
    Moves the cursor.
  • CBL_SWAP_SCR_CHATTRS
    Swaps a string of characters and their attributes with a string from the screen.
  • CBL_WRITE_SCR_ATTRS
    Writes a string of attributes to the screen.
  • CBL_WRITE_SCR_CHARS
    Writes a string of characters to the screen.
  • CBL_WRITE_SCR_CHARS_ATTR
    Writes a string of characters to the screen, giving them all the same attribute.
  • CBL_WRITE_SCR_CHATTRS
    Writes a string of characters and their attributes to the screen.
  • CBL_WRITE_SCR_N_ATTR
    Writes a specified attribute to a string of positions on the screen.
  • CBL_WRITE_SCR_N_CHAR
    Writes a specified character to a string of positions on the screen.
  • CBL_WRITE_SCR_N_CHATTR
    Writes a specified character and attribute to a string of positions on the screen.
  • CBL_WRITE_SCR_TTY
    Writes a string of characters to the screen starting at the current position and scrolling.
  • X"A7" function 17
    Sets the cursor type.
  • X"A7" function 18
    Makes console I/O redirectable.
  • X"A7" function 25
    Returns the current screen type as recognized by the run-time system.
  • X"AF" function 18
    Displays a character to the screen at the current cursor position.
  • X"AF" function 22
    Sounds the terminal alarm.
  • X"E5"
    Sounds the bell.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_CLEAR_SCR

Clears the whole screen to a specified character and attribute.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_CLEAR_SCR" using     character
                               attribute
                     returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
character | cblt-x1-compx | pic x.
attribute | cblt-x1-compx | pic x.
status-code | See Library Routines - Key |

On Entry:

character | The character to write.
attribute | The attribute to write.

On Exit:

None.

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_GET_CSR_POS

Returns the cursor position.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_GET_CSR_POS" using     screen-position
                       returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing
01 cblt-screen-position     typedef.
  03 cblte-scrp-row         cblt-x1-compx.  *> pic x comp-x.
  03 cblte-scrp-col         cblt-x1-compx.  *> pic x comp-x.
status-code
See Library Routines - Key.

On Entry:

None

On Exit:

screen-position The screen position of the cursor. The top left corner is row 0, column 0. If the cursor is invisible, cblte-scrp-row and cblte-scrp-col are both set to 255.
Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_GET_SCR_GRAPHICS

Returns operating system independent codes for graphics characters.

Restriction: This routine is supported for native COBOL only.

Syntax

        call "CBL_GET_SCR_GRAPHICS" using     graphics-params
        returning status-code

Parameters

graphics-params
Group predefined as cblt-get-scr-graphics-buffer, a group containing:
01 cblt-get-scr-graphics-buffer          typedef.
  03 cblte-gsgb-flag                     cblt-x1-compx.     *> pic x comp-x.
  03 cblte-gsgb-buf-size                 cblt-x2-compx.     *> pic x(2) comp-x.
  03 cblte-gsgb-buf.
    04 cblte-gsgb-up-arrow.
      05 cblte-gsgb-up-arrow-dbflag      cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-up-arrow-arrow       cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-down-arrow.
      05 cblte-gsgb-down-arrow-dbflag    cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-down-arrow-arrow     cblt-x1-compx.     *> pic x
    04 cblte-gsgb-right-arrow.
      05 cblte-gsgb-right-arrow-dbflag   cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-right-arrow-arrow    cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-left-arrow.
      05 cblte-gsgb-left-arrow-dbflag    cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-left-arrow-arrow     cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-maximize.
      05 cblte-gsgb-maximize-dbflag      cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-maximize-char        cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-minimize.
      05 cblte-gsgb-minimize-dbflag      cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-minimize-char        cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-check.
      05 cblte-gsgb-check-dbflag         cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-check-char           cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-restore.
      05 cblte-gsgb-restore-dbflag       cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-restore-char         cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-radio.
      05 cblte-gsgb-radio-dbflag         cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-radio-char           cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-scroll.
      05 cblte-gsgb-scroll-dbflag        cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-scroll-char          cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-rubber-band.
      05 cblte-gsgb-rubber-band-dbflag   cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-rubber-band-char     cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-sysmenu.
      05 cblte-gsgb-sysmenu-char-dbflag  cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-sysmenu-char-char    cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-editor-char.
      05 cblte-gsgb-editor-char-dbflag   cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-editor-char-char     cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-hyhelp-tab.
      05 cblte-gsgb-hyhelp-tab-dbflag    cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-hyhelp-tab-char      cblt-x1-compx.     *> pic x.
    04 cblte-gsgb-hyhelp-btab.
      05 cblte-gsgb-hyhelp-btab-dbflag   cblt-x1-compx.     *> pic x comp-x.
      05 cblte-gsgb-hyhelp-btab-char     cblt-x1-compx.     *> pic x.
status-code
See Library Routines - Key.

On Entry

cblte-gsgb-flag
Type of character code to return:
Code | Description
0 | Either single-byte or double-byte character set as appropriate for the host environment
1 | Only single-byte character set (SBCS)
2 | Only double-byte character set (DBCS)
cblte-gsgb-buf-size
Length of cblte-gsgb-buf in bytes. The normal value of cblte-gsgb-buf-size is 30, although by specifying a smaller value you can request only the graphics values you require.

You must not set cblte-gsgb-buf-size to be greater than the length of cblte-gsgb-buf. If cblte-gsgb-buf-size exceeds the length of cblte-gsgb-buf, the run-time system continues to write to memory past the buffer, which could corrupt other data.

On Exit

cblte-gsgb-buf-size
Number of bytes filled.
cblte-gsgb-buf
Character codes for each entry that is completely contained in the cblte-gsgb-buf-size byte count. The contents of any character code which is only partially in the byte count is undefined. Any character codes wholly outside the byte count are ignored.

The byte count should include the whole of any DBCS character-part, even if DBCS is not requested or expected.

For the cblte-gsgb-*-dbflg data items, zero indicates single-byte character codes have been returned; a nonzero value is the first byte of the double-byte character returned.

status-code
Return status:
Code | Description
0 | Success
1 | Not all requested codes were available; cblte-gsgb-buf-size contains the number of bytes that were returned
2 | cblte-gsgb-buf could not be filled with the character codes specified (either SBCS or DBCS). In this case, the characters that were not available were filled as though cblte-gsgb-flag was set to 0.
3 | Both the errors signaled by status-code = 1 and 2 occurred.
Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_GET_SCR_LINE_DRAW

Returns a table of values defining the character values required by the run-time system screen output routines to correctly display given line drawing characters.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_GET_SCR_LINE_DRAW" using     function-code
                                       line-draw-table
                             returning status-code

Parameters

function-code
Call prototype (see Key): cblt-x1-compx
Picture: pic x comp-x.
Contains one of the following:

0: Request for single-byte line drawing table

1: Request for double-byte line drawing table

2: Request for a single single-byte line drawing code

3: Request for a single double-byte line drawing code

line-draw-table
Group predefined as cblt-get-scr-line-draw-buffer containing:
01   cblt-get-scr-line-draw-buffer        typedef.
  03 cblte-gsld-draw-code                 cblt-x1-compx.  *> pic x comp-x.
  03 cblte-gsld-dbcs-draw-char            cblt-x2-compx.  *> various pic x(2) Occurs n times
  03 cblte-gsld-draw-char
     redefines cblte-gsld-dbcs-draw-char  cblt-x1-compx.  *> Occurs n times
status-code
See Library Routines - Key.

On Entry:

With function-code = 2 or 3
cblte-gsld-draw-code
The offset (shape description) of the character required.

On Exit:

cblte-gsld-draw-code
Byte filled in by the run-time system to determine any mapping that has taken place in the table as follows:
For bits 0 through 2, line types are mapped to the first available of single, double, extended or ASCII character.
bit 7 - 3 | Reserved (set to 0)
bit 2 | Extended lines not supported - mapped
bit 1 | Double lines not supported - mapped
bit 0 | Single lines not supported - mapped
With function-code = 0
cblte-gsld-draw-char
The single-byte line drawing table. Bytes in the table are arranged as follows:
bits 6 and 7 | The North line.
bits 4 and 5 | The South line
bits 2 and 3 | The West line
bits 0 and 1 | The East line
  • The bit pairs are combined and used as an index into the table.
  • Non-valid combinations will map to a space.
  • For a valid combination any two of the bit pairs must each have at least one bit set.
  • You must specify at least 2 bit pairs.
With function-code = 1
cblte-gsld-dbcs-draw-char
The double-byte line drawing table. Bytes in the table are arranged as follows:
bits 6 and 7 | The North line.
bits 4 and 5 | The South line
bits 2 and 3 | The West line
bits 0 and 1 | The East line
With function-code = 2
cblte-gsld-draw-char
The requested single single-byte line drawing code.
With function-code = 3
cblte-gsld-dbcs-draw-char
The requested single double-byte line drawing code.

Comments:

When requesting a single line drawing character (function-code = 2 or 3), the cblte-gsld-draw-code parameter is used to tell the run-time system which character you require. The cblte-gsld-draw-code parameter for a given cblte-gsld-drawing shape can be calculated by splitting a byte into four bit-pairs. Each bit-pair defines the type of line that you want to appear in one of the four directions:

Bits | Direction
7 and 6 | North
5 and 4 | South
3 and 2 | West
1 and 0 | East

Each bit-pair can have one of the following values:

00 | In the given direction, there is no line
01 | There is a single-thickness line
10 | There is a double-thickness line
11 | There is an extended-type line.

The extended line type is available only for systems which have additional types of line drawing, such as dotted lines. If a system has more than one additional type, only one can be used at a time.

For example, if you wished to find out the screen handler's character code for a line which would define the bottom-left of a box with single thickness sides and a double thickness bottom, you would make the following calculations:

Bit-pairs:

North: | 01 (single)
South: | 00 (blank)
West: | 00 (blank)
East: | 10 (double)

This gives the binary value of 01000010 or a decimal value of 66. Therefore, you would move 66 to cblte-gsld-draw-code before calling CBL_GET_SCR_LINE_DRAW in order to obtain the correct character for this shape.

If you use function-code = 0 or 1 to obtain the full line drawing table, a given character can be located in the table using the bit-pair algorithm described above, which yields a numeric value for a given shape. However, by default, COBOL subscripts begin at one, not zero. Therefore, if you use the following construct to obtain the full line drawing table:

  03 cblte-gsld-draw-char    pic x occurs 256 times.

you need to add 1 to the result of the bit-pair algorithm to locate the correct character (and, therefore, need a subscript which is larger than one byte).

However, you can use the following construct to obtain the table:

With function-code = 0:

  03
filler  pic x.
  03 cblte-gsld-draw-char    pic x occurs 255 times.

With function-code = 1:

  03 filler  pic x(2).
  03 cblte-gsld-dbcs-draw-char  pic x(2) occurs 255 times.

You must ensure that the NOBOUND Compiler directive is set to enable you to use subscripts 0 to 255, which map directly onto the result from the bit-pair algorithm.

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_GET_SCR_SIZE

Returns information about the size of the screen.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_GET_SCR_SIZE" using     depth
                                  width
                        returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
depth | cblt-x1-compx | pic x comp-x.
width | cblt-x1-compx | pic x comp-x.
status-code | See Library Routines - Key |

On Entry:

None.

On Exit:

depth | Number of lines.
width | Number of columns.
Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_READ_SCR_ATTRS

Reads a string of attributes from the screen.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_READ_SCR_ATTRS" using     screen-position
                                    attribute-buffer
                                    string-length
                          returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position   typedef.
  03 cblte-scrp-row       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-scrp-col       cblt-x1-compx. 	*> pic x comp-x.
attribute-buffer
Call prototype (see Key): pic x (n).
Picture: pic x (n).
string-length
Call prototype (see Key): pic x (n).
Picture: pic x (n).
status-code
See Library Routines - Key.

On Entry:

screen-position | The screen position to start reading at. The top left corner is row 0, column 0. See Screen Routines.
string-length | The length of the string to read.

On Exit:

attribute-buffer | The attributes read from the screen. This data item must be at least as long as specified by string-length; positions in it beyond that length are unchanged.
string-length | If the end of the screen is reached the length read is returned in here.
Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_READ_SCR_CHARS

Reads a string of characters from the screen.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_READ_SCR_CHARS" using     screen-position
                                    character-buffer
                                    string-length
                          returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position   typedef.
  03 cblte-scrp-row       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-scrp-col       cblt-x1-compx. 	*> pic x comp-x.
character-buffer
Call prototype (see Key): pic x (n).
Picture: pic x (n).
string-length
Call prototype (see Key): pic x (n).
Picture: pic x (n).
status-code
See Library Routines - Key.

On Entry:

screen-position | The screen position to start reading at. The top left corner is row 0, column 0. See Screen Routines.
string-length | The length of the string to read.

On Exit:

character-buffer | The characters read from the screen. This data item must be at least as long as specified by string-length; positions in it beyond that length are unchanged.
string-length | If the end of the screen is reached, the length read is returned in here.
Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_READ_SCR_CHATTRS

Reads a string of characters and their attributes from the screen.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_READ_SCR_CHATTRS"  using    screen-position
                                      character-buffer
                                      attribute-buffer
                                      string-length
                            returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position   typedef.
  03 cblte-scrp-row       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-scrp-col       cblt-x1-compx. 	*> pic x comp-x.
character-buffer
Call prototype (see Key): pic x (n).
Picture: pic x (n).
attribute-buffer
Call prototype (see Key): pic x (n).
Picture: pic x (n).
string-length
Call prototype (see Key): pic x (n).
Picture: pic x (n).
status-code
See Library Routines - Key.

On Entry:

screen-position | The screen position to start reading at. The top left corner is row 0, column 0. See Screen Routines.
string-length | The length of the string to read.

On Exit:

character-buffer | The characters read from the screen. This data item must be at least as long as specified by string-length; positions in it beyond that length are unchanged.
attribute-buffer | The attributes read from the screen. This data item must be at least as long as specified by string-length; positions in it beyond that length are unchanged.
string-length | If the end of the screen is reached, the length read (in cells, that is, character-attribute pairs) is returned in here.
Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_SET_CSR_POS

Moves the cursor.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_SET_CSR_POS" using     screen-position
                       returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position   typedef.
  03 cblte-scrp-row       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-scrp-col       cblt-x1-compx. 	*> pic x comp-x.
status-code
See Library Routines - Key.

On Entry:

screen-position The screen position at which to put the cursor. The top left corner is row 0, column 0. See Screen Routines

On Exit:

None

Comments:

To make the cursor invisible, set cblte-scrp-row and cblte-scrp-col to 255. Any other legal on-screen values make the cursor visible.

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_SWAP_SCR_CHATTRS

Swaps a string of characters and their attributes with a string from the screen.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_SWAP_SCR_CHATTRS"  using     screen-position
                                      character-buffer
                                      attribute-buffer
                                      string-length
                            returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position   typedef.
  03 cblte-scrp-row       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-scrp-col       cblt-x1-compx. 	*> pic x comp-x.
character-buffer
Call prototype (see Key): pic x (n).
Picture: pic x (n).
attribute-buffer
Call prototype (see Key): pic x (n).
Picture: pic x (n).
string-length
Call prototype (see Key): pic x (n).
Picture: pic x (n).
status-code
See Library Routines - Key.

On Entry:

screen-position | The screen position at which to start writing. The top left corner is row 0, column 0. See Screen Routines
character-buffer | The characters to write.
attribute-buffer | The attributes to write.
string-length | The length of the string to write. If this would go off the end of the screen, the write finishes at the end of the screen.

On Exit:

character-buffer | The characters read from the screen. This data item must be at least as long as specified by string-length; positions in it beyond that length are unchanged.
attribute-buffer | The attributes read from the screen. This data item must be at least as long as specified by string-length; positions in it beyond that length are unchanged.
string-length | If the end of the screen is reached the length swapped (in cells, that is, character-attribute pairs) is returned in here.
Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_WRITE_SCR_ATTRS

Writes a string of attributes to the screen.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_WRITE_SCR_ATTRS" using     screen-position
                                     attribute-buffer
                                     string-length
                           returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position       typedef.
   03 cblte-scrp-row          cblt-x1-compx. 	*> pic x comp-x.
   03 cblte-scrp-col          cblt-x1-compx. 	*> pic x comp-x.
attribute-buffer
Call prototype (see Key): pic x (n).
Picture: pic x (n).
string-length
Call prototype (see Key): pic x (n).
Picture: pic x (n).
status-code
See Library Routines - Key.

On Entry:

screen-position | The screen position at which to start writing. The top left corner is row 0, column 0. See Screen Routines
attribute-buffer | The attributes to write.
string-length | The length of the string to write. If this would go off the end of the screen, the write finishes at the end of the screen.

On Exit:

None

Comments:

The blink attribute is not supported on this COBOL system. Specifying that a character is to blink results in the character being displayed with a bright background color.

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_WRITE_SCR_CHARS

Writes a string of characters to the screen.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_WRITE_SCR_CHARS" using     screen-position
                                     character-buffer
                                     string-length
                           returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position   typedef.
  03 cblte-scrp-row       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-scrp-col       cblt-x1-compx. 	*> pic x comp-x.
character-buffer
Call prototype (see Key): pic x (n).
Picture: pic x (n).
string-length
Call prototype (see Key): pic x (n).
Picture: pic x (n).
status-code
See Library Routines - Key.

On Entry:

screen-position | The screen position at which to start writing. The top left corner is row 0, column 0. See Screen Routines
character-buffer | The characters to write.
string-length | The length of the string to write. If this would go off the end of the screen, the write finishes at the end of the screen.

On Exit:

None

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_WRITE_SCR_CHARS_ATTR

Writes a string of characters to the screen, giving them all the same attribute.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_WRITE_SCR_CHARS_ATTR" using     screen-position
                                          character-buffer
                                          string-length
                                          attribute
                                returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position   typedef.
  03 cblte-scrp-row       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-scrp-col       cblt-x1-compx. 	*> pic x comp-x.
character-buffer
Call prototype (see Key): pic x (n).
Picture: pic x (n).
string-length
Call prototype (see Key): pic x (n).
Picture: pic x (n).
status-code
See Library Routines - Key.

On Entry:

screen-position | The screen position at which to start writing. The top left corner is row 0, column 0. See Screen Routines
character-buffer | The characters to write.
attribute | The attribute to write.
string-length | The length of the string to write. If this would go off the end of the screen, the write finishes at the end of the screen.

On Exit:

None

Comments:

The blink attribute is not supported on this COBOL system. Specifying that a character is to blink results in the character being displayed with a bright background color.

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_WRITE_SCR_CHATTRS

Writes a string of characters and their attributes to the screen.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_WRITE_SCR_CHATTRS" using     screen-position
                                       character-buffer
                                       attribute-buffer
                                       string-length
                             returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position                 typedef.
   03    cblte-scrp-row                  cblt-x1-compx. 	*> pic x comp-x.
   03    cblte-scrp-col                  cblt-x1-compx. 	*> pic x comp-x.
character-buffer
Call prototype (see Key): pic x (n).
Picture: pic x (n).
attribute-buffer
Call prototype (see Key): pic x (n).
Picture: pic x (n).
string-length
Call prototype (see Key): pic x (n).
Picture: pic x (n).
status-code
See Library Routines - Key.

On Entry:

screen-position | The screen position at which to start writing. The top left corner is row 0, column 0. See Screen Routines
character-buffer | The characters to write.
attribute-buffer | The attributes to write.
string-length | The length of the string to write. If this would go off the end of the screen, the write finishes at the end of the screen.

On Exit:

None

Comments:

The blink attribute is not supported on this COBOL system. Specifying that a character is to blink results in the character being displayed with a bright background color.

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_WRITE_SCR_N_ATTR

Writes a specified attribute to a string of positions on the screen.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_WRITE_SCR_N_ATTR"  using     screen-position
                                      attribute
                                      fill-length
                            returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position   typedef.
  03 cblte-scrp-row       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-scrp-col       cblt-x1-compx. 	*> pic x comp-x.
attribute
Call prototype (see Key): pic x1-compx
Picture: pic x.
fill-length
Call prototype (see Key): pic x2-compx
Picture: pic x (2) comp-x.
status-code
See Library Routines - Key.

On Entry:

screen-position | The screen position at which to start writing. The top left corner is row 0, column 0. See Screen Routines
attribute | The attribute to write.
string-length | The number of screen positions to write the attribute to. If this would go off the end of the screen, the write finishes at the end of the screen.

On Exit:

None

Comments:

The blink attribute is not supported on this COBOL system. Specifying that a character is to blink results in the character being displayed with a bright background color.

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_WRITE_SCR_N_CHAR

Writes a specified character to a string of positions on the screen.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_WRITE_SCR_N_CHAR"  using     screen-position
                                      character
                                      fill-length
                            returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position   typedef.
  03 cblte-scrp-row       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-scrp-col       cblt-x1-compx. 	*> pic x comp-x.
character
Call prototype (see Key): pic x1-compx
Picture: pic x.
fill-length
Call prototype (see Key): pic x2-compx
Picture: pic x (2) comp-x.
status-code
See Library Routines - Key.

On Entry:

screen-position | The screen position at which to start writing. The top left corner is row 0, column 0. See Screen Routines
attribute-buffer | The attributes to write.
string-length | The number of screen positions to write the character to. If this would go off the end of the screen, the write finishes at the end of the screen.

On Exit:

None

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_WRITE_SCR_N_CHATTR

Writes a specified character and attribute to a string of positions on the screen.

Restriction: This routine is supported for native COBOL only.

Syntax:

call "CBL_WRITE_SCR_N_CHATTR" using     screen-position
                                        character
                                        attribute
                                        fill-length
                              returning status-code

Parameters

screen-position
Group predefined as cblt-screen-position containing:
01 cblt-screen-position   typedef.
  03 cblte-scrp-row       cblt-x1-compx. 	*> pic x comp-x.
  03 cblte-scrp-col       cblt-x1-compx. 	*> pic x comp-x.
character
Call prototype (see Key): cblt-x1-compx
Picture: pic x.
attribute
Call prototype (see Key): cblt-x1-compx
Picture: pic x.
fill-length
Call prototype (see Key): cblt-x2-compx
Picture: pic x(2) comp-x.
status-code
See Library Routines - Key.

On Entry:

screen-position | The screen position at which to start writing. The top left corner is row 0, column 0. See Screen Routines
character | The character to write.
attribute | The attribute to write.
string-length | The number of screen positions to write the character-attribute pair to. If this would go off the end of the screen, the write finishes at the end of the screen.

On Exit:

None

Comments:

The blink attribute is not supported on this COBOL system. Specifying that a character is to blink results in the character being displayed with a bright background color.

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


CBL_WRITE_SCR_TTY

Writes a string of characters to the screen starting at the current position and scrolling.

Note: This routine is supported for native COBOL only.

Syntax:

call "CBL_WRITE_SCR_TTY" using     character-buffer
                                   string-length
                         returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
character-buffer | pic x(n). | pic x(n).
string-length | cblt-x2-compx | pic x(2) comp-x.
status-code | See Library Routines - Key |

On Entry:

character-buffer | The characters to write.
string-length | The length of the string to write. If this would go off the edge of the screen, the screen is scrolled up a line and the write continues on the bottom line.

On Exit:

None

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


X"A7" function 17

Sets the cursor type.

Note: This routine is supported for native COBOL only.

Syntax:

call X"A7" using function-code
                 cursor-type

Parameters:

function-code
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
cursor-type
Group containing:
01 cursor-type
  03 cursor-end   cblt-x1-compx   *> pic x comp-x.
  03 cursor-start cblt-x1-compx   *> pic x comp-x.

On Entry:

function-code | Value 17.
cursor-end | Scan line cursor ends on.
cursor-start | Scan line cursor starts on.

On Exit:

None

Comments:

Details of cursor-start and end lines can be found in your IBM BIOS Technical Reference manual.

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


X"A7" function 25

Returns the current screen type as recognized by the run-time system.

Note: This routine is supported for native COBOL only.

Syntax:

call x"A7" using function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
function-code | cblt-x1-compx | pic x comp-x.
parameter | cblt-x1-compx | pic x comp-x.

On Entry:

function-code
Value 25

On Exit:

parameter
Bit settings indicating the type of screen as follows:
bit 0 | unset = monochrome screen
bit 1 | reserved
bit 2 | reserved
bit 3 | set = EGA-type screen
bit 4 | set = VGA-type screen
bit 5 | reserved
bit 6 | reserved
bit 7 | reserved
Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


X"AF" function 18

Displays a character to the screen at the current cursor position.

Note: This routine is supported for native COBOL only.

Syntax:

call x"AF" using function-code
                 char

Parameters:

 | Using call prototype (see Key) | Picture
function-code | cblt-x1-compx | pic x comp-x.
char | pic x | pic x

On Entry:

function-code | Value 18
char | The character to be displayed.

On Exit:

None

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


X"E5"

Sounds the bell.

Syntax:

call x"E5"

Parameters:

None

Comments:

The duration and pitch of the bell depends on the environment.

Parent topic: Screen Routines
Parent topic: Alphabetical List of Library Routines


State Maintenance Routines

Restriction: These routines are supported for native COBOL only.

The state maintenance routines enable you to create an internet application which can store user and application state information on the web server.

For more details on using the state maintenance routines, see the CGI-based Applications book.

  • MF_CLIENT_STATE_ALLOCATE
    Allocates a client identifier.
  • MF_CLIENT_STATE_DELETE
    Deletes an existing client identifier and its associated client information.
  • MF_CLIENT_STATE_EXPIRY
    Returns a date string for use in the cookie expiry field.
  • MF_CLIENT_STATE_FILE
    Specifies the file to be used on the server to store state information.
  • MF_CLIENT_STATE_PURGE
    Deletes all client information older than the number of days specified.
  • MF_CLIENT_STATE_RESTORE
    Restores a previously saved or allocated record which matches the client identifier.
  • MF_CLIENT_STATE_SAVE
    Updates the information in the state file.
  • State Maintenance Routines Status
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


MF_CLIENT_STATE_ALLOCATE

Allocates a client identifier.

Note: This routine is supported for native COBOL only.

Syntax:

call "MF_CLIENT_STATE_ALLOCATE" using  client-id
                                       client-length
                                       server-status

Parameters:

 | Using call prototype (see Key) | Picture (32-bit systems)
client-id | pic x(30). | pic x(30).
client-length | cblt-x4-compx | pic x(4) comp-x.
server-status | cblt-x1-compx | pic x comp-x.

On Entry:

client-id | The client identifier. See Comments below.
client-length | The length of the empty record for the state information.

On Exit:

client-id | The client identifier. See Comments below.
server-status | The status of the operation. See State Maintenance Routines Status.

Comments:

This routine:

  • Allocates a new empty record for the state information, with the length given in client-length.
  • Returns a new client-id, and allocates an empty record, if the value passed in client-id is set to spaces. Otherwise, if client-id is set to a valid client identifier, this routine allocates an empty record with that client identifier.

Example:

 working-storage section.
 ...
 01 client-id                pic x(30).
 01 client-length            pic xxxx comp-x.
 01 state-status             pic x comp-x.
 ...
 procedure division.
 ...
     call "MF_CLIENT_STATE_ALLOCATE"
          using client-id client-length state-status
 ...
Parent topic: State Maintenance Routines
Parent topic: Alphabetical List of Library Routines


MF_CLIENT_STATE_DELETE

Deletes an existing client identifier and its associated client information.

Note: This routine is supported for native COBOL only.

Syntax:

call "MF_CLIENT_STATE_DELETE " using client-id
                                     server-status

Parameters:

 | Using call prototype (see Key) | Picture (32-bit systems)
client-id | pic x(30). | pic x(30).
server-status | cblt-x1-compx | pic x comp-x.

On Entry:

client-id The client identifier.

On Exit:

server-status The status of the operation. See State Maintenance Routines Status.
Parent topic: State Maintenance Routines
Parent topic: Alphabetical List of Library Routines


MF_CLIENT_STATE_EXPIRY

Returns a date string for use in the cookie expiry field.

Note: This routine is supported for native COBOL only.

Syntax:

call "MF_CLIENT_STATE_EXPIRY" using date-criteria
                                  expiry-string

Parameters:

 | Using call prototype (see Key) | Picture (32-bit systems)
date-criteria | cblt-x4-compx | pic x(4) comp-x.
expiry-string | pic x(50). | pic x(50).

On Entry:

date-criteria The number of days after which client records are to expire.

On Exit:

expiry-string The expiry date to be used in the cookie expiry field.

Comments:

expiry-string returns a value with the format day, dd-month-yyyy hh:mm:ss GMT

Parent topic: State Maintenance Routines
Parent topic: Alphabetical List of Library Routines


MF_CLIENT_STATE_FILE

Specifies the file to be used on the server to store state information.

Note: This routine is supported for native COBOL only.

Syntax:

call "MF_CLIENT_STATE_FILE" using filename
                                  server-status

Parameters:

 | Using call prototype (see Key) | Picture (32-bit systems)
filename | pic x(255). | pic x(255).
server-status | cblt-x1-compx | pic x comp-x.

On Entry:

filename The filename.

On Exit:

server-status The status of the operation. See State Maintenance Routines Status.

Example:

 working-storage section.
 ...
 01 state-status             pic x comp-x.
 01 state-filename           pic x(255)
               value "MF-STATE-SAVE.DAT".
 ...
 procedure division.
 ...
     call "MF_CLIENT_STATE_FILE" using state-filename
                                       server-status
 ...
Parent topic: State Maintenance Routines
Parent topic: Alphabetical List of Library Routines


MF_CLIENT_STATE_PURGE

Deletes all client information older than the number of days specified.

Note: This routine is supported for native COBOL only.

Syntax:

call "MF_CLIENT_STATE_PURGE" using date-criteria
                                   server-status

Parameters:

 | Using call prototype (see Key) | Picture (32-bit systems)
date-criteria | cblt-x4-compx | pic x(4) comp-x.
server-status | cblt-x1-compx | pic x comp-x.

On Entry:

date-criteria The number of days after which client information should be purged.

On Exit:

server-status The status of the operation. See State Maintenance Routines Status.
Parent topic: State Maintenance Routines
Parent topic: Alphabetical List of Library Routines


MF_CLIENT_STATE_RESTORE

Restores a previously saved or allocated record which matches the client identifier.

Note: This routine is supported for native COBOL only.

Syntax:

call "MF_CLIENT_STATE_RESTORE " using client-id
                                      client-state
                                      client-length
                                      server-status

Parameters:

 | Using call prototype (see Key) | Picture (32-bit systems)
client-id | pic x(n). | pic x(30).
client-state | cblt-x4-compx | pic x(4) comp-x.
client-length | See Comments.
server-status | cblt-x1-compx | pic x comp-x.

On Entry:

client-id | The client identifier.
client-state | The state information to be saved. See Comments.
client-length | The length of the empty record for the state information.

On Exit:

client-state | The state information to be saved. See Comments.
server-status | The status of the operation. See State Maintenance Routines Status.

Comments:

On entry, client-length is the length of the buffer. On exit, client-length returns the length of the data recovered. The data is truncated to fit the client-length specified on entry.

You can define any format for client-state records. Define the length of the client-state record in the client-length field.

Example:

 working-storage section.
 ...
 01 client-id                pic x(30).
 01 client-length            pic xxxx comp-x.
 01 state-status             pic x comp-x.
01 client-state.
   03 user-preferences       pic x(10).
   03 user-selection-list    pic x(80).
...
 procedure division.
 ...
     call "MF_CLIENT_STATE_RESTORE"
            using client-id client-state
                  client-length state-status
 ...
Parent topic: State Maintenance Routines
Parent topic: Alphabetical List of Library Routines


MF_CLIENT_STATE_SAVE

Updates the information in the state file.

Note: This routine is supported for native COBOL only.

Syntax:

call "MF_CLIENT_STATE_SAVE" using client-id
                                  client-state
                                  client-length
                                  server-status

Parameters:

 | Using call prototype (see Key) | Picture (32-bit systems)
client-id | pic x(n). | pic x(30).
client-state | cblt-x4-compx | pic x(4) comp-x.
client-length | See Comments. |
server-status | cblt-x1-compx | pic x comp-x.
status-code | See Library Routines - Key |

On Entry:

client-id | The client identifier.
client-state | The state information to be saved. See Comments.
client-length | The length of the empty record for the state information.

On Exit:

server-status The status of the operation. See State Maintenance Routines Status.

Comments:

This routine saves a previously allocated client-id and client state, or rewrites a previously saved client-id and client state. client-length can be updated.

You can define any format for client-state records. Define the length of the client-state record in the client-length field.

Example:

 working-storage section.
 ...
 01 client-id                pic x(30).
 01 client-length            pic x(4) comp-x.
 01 state-status             pic x comp-x.
 01 client-state.
   03 user-preferences       pic x(10).
   03 user-selection-list    pic x(80).
...
 procedure division.
 ...
     call "MF_CLIENT_STATE_SAVE"
            using client-id client-state
                  client-length state-status
 ...
Parent topic: State Maintenance Routines
Parent topic: Alphabetical List of Library Routines


State Maintenance Routines Status

0 | Call is successful
1 | Call failed
2 | Duplicate client-id has been found (allocate)
3 Possible causes:
  • Client-id not found (save and restore).
  • Trying to save/restore/delete a record with no matching key.
  • Another internal error happens (due to incorrect CALL order).
  • Record allocation problem.
Parent topic: State Maintenance Routines


Text Routines

  • CBL_TOLOWER
    Converts a string of letters to lower case.
  • CBL_TOUPPER
    Converts a string of letters to upper case.
  • PC_WIN_SET_CHARSET
    Specifies the character set to be used by the case conversion routines CBL_TOUPPER and CBL_TOLOWER.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_TOLOWER

Converts a string of letters to lower case.

Syntax:

call "CBL_TOLOWER" using      string
                   by value length
                   returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
string | pic x(n). | pic x(n).
length | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
status-code | See Library Routines - Key |

On Entry:

string | The string to convert.
length | The number of bytes of string to change; positions beyond this are unchanged.

On Exit:

string The converted string.

Comments:

The routine starts at the left-hand end of string and converts letters to lower case (also called folding to lower case).

Parent topic: Text Routines
Parent topic: Alphabetical List of Library Routines


CBL_TOUPPER

Converts a string of letters to upper case.

Syntax:

call "CBL_TOUPPER" using     string
                   by value  length
                   returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
string | pic x(n). | pic x(n).
length | cblt-os-size | pic x(4) comp-5 or pic x(8) comp-5 (64-bit native programs only)
status-code | See Library Routines - Key |

On Entry:

string | The string to convert.
length | The number of bytes of string to change; positions beyond this are unchanged.

On Exit:

string The converted string.

Comments:

The routine starts at the left-hand end of string and converts letters to upper case (also called folding to upper case).

Parent topic: Text Routines
Parent topic: Alphabetical List of Library Routines


Virtual Heap Routines

A heap is a byte-stream file which is buffered in available memory.

The status word specified when the heap is created is associated with each heap. It is written to when an operation on the heap fails. Each heap is thereby attached to a particular program, namely the program which contains the heap's status word, and is automatically deallocated (unless it has already been explicitly deallocated by a call to CBL_CLOSE_VFILE) when that program is canceled.

A heap is identified by a heap identifier word. This can be passed around between programs so that the heap can be read or written by any program. However, in order to check for failure, the program needs to have access (using a pointer variable, for example, or via normal linkage section mapping) to the associated status word.

Alternatively the RETURN-CODE register can be examined to catch a general heap function failure. The specific error can then be determined by examining the heap status word.

If the read/write succeeds, the RETURN-CODE is zero. If it fails, the RETURN-CODE is nonzero and the heap status first byte contains "9", with detail in the second byte.

The buffer used with CBL_READ_VFILE and CBL_WRITE_VFILE can reside anywhere in the Data or Linkage Section, or it can be dynamically allocated using the CBL_ALLOC_MEM routine.

Each heap is paged, if necessary. A heap is paged into a separate file on disk with name sourcename.Vnn, where sourcename is the base-name of the program to which the heap is attached and nn is an integer from 1 to 99. Once nn reaches 99, the V is overwritten. The maximum number allowed for the extension is 384.

The number of local heaps is configurable, up to 65535.

You can use reference modification in the buffer call parameter to declare the heap buffer in the middle of a COBOL record. This is compiled efficiently provided the length is given as fixed; since the length is ignored by the call interface, you can give it as one.

  • CBL_CLOSE_VFILE
    Closes a heap.
  • CBL_OPEN_VFILE
    Opens a heap.
  • CBL_READ_VFILE
    Reads bytes from a heap.
  • CBL_WRITE_VFILE
    Writes bytes to a heap.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


CBL_CLOSE_VFILE

Closes a heap.

Syntax:

call "CBL_CLOSE_VFILE" using by value heap-id
                       returning      status-code

Parameters:

 | Using call prototype (see Key) | Picture
heap-id | cblt-vfile-handle | pic x(2) comp-5.
status-code | See Library Routines - Key

On Entry:

heap-id This contains the heap handle assigned when the heap was opened.

On Exit:

None.

Parent topic: Virtual Heap Routines
Parent topic: Alphabetical List of Library Routines


CBL_OPEN_VFILE

Opens a heap.

Syntax:

call "CBL_OPEN_VFILE" using     heap-id
                                status-word
                      returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
heap-id | cblt-vfile-handle. | pic x(2) comp-5.
status-word | cblt-vfile-handle. | pic x(2).
status-code | See Library Routines - Key.

On Entry:

None

On Exit:

heap-id
The heap handle assigned. A heap handle of zero means the open failed.
status-word
The status word for the heap, set to zero on the open. When status-word (1:1) = '9', binary values in the second status byte are:
000 | Heap closed by user request
001 | Heap access failure - out of buffers
002 | Heap deallocated while program inactive
014 | Backing-file failure: too many files
037 | Backing-file failure: file access denied
201 | Backing-file failure: I/O failure
status-word remains associated with the heap until the heap is closed; the first byte is set to ASCII zero by a successful OPEN; status-word is written as file status data by a subsequent heap READ, WRITE or CLOSE that encounters allocation or I/O errors (but is not reset to zero by successful operations).
If a program in which a heap status word actually exists (that is, it is not in a Linkage Section) is canceled, all heaps with status words in that program are automatically canceled, and the heap identifiers (which might have been passed to other programs) should not be used any more.
Parent topic: Virtual Heap Routines
Parent topic: Alphabetical List of Library Routines


CBL_READ_VFILE

Reads bytes from a heap.

Syntax:

call "CBL_READ_VFILE" using by value heap-id
                                     heap-ref
                                     heap-length
                      by reference   heap-buffer
                      returning      status-code

Parameters:

 | Using call prototype (see Key) | Picture
heap-id | cblt-vfile-handle. | pic x(2) comp-5.
heap-ref | cblt-x4-comp5. | pic x(4) comp-5.
heap-length | cblt-x4-comp5. | pic x(4) comp-5.
heap-buffer | pic x(n). | pic x(n).
status-code | See Library Routines - Key. |

On Entry:

heap-id | This contains the heap handle assigned when the heap was opened.
heap-ref | Offset in the heap at which to start reading. In .NET, this is limited to a maximum value of 0x7fffffff.
heap-length | Number of bytes to read.

On Exit:

heap-buffer Buffer into which bytes are read. It is your responsibility to ensure that the buffer is large enough to hold the number of bytes being read.

Comments:

Trying to read data from an area of the heap which has not yet been written results in indeterminate data being returned to the buffer.

Parent topic: Virtual Heap Routines
Parent topic: Alphabetical List of Library Routines


CBL_WRITE_VFILE

Writes bytes to a heap.

Syntax:

call "CBL_WRITE_VFILE" using by value heap-id
                                      heap-ref
                                      heap-length
                       by reference   heap-buffer
                        returning     status-code

Parameters:

 | Using call prototype (see Key) | Picture
heap-id | cblt-vfile-handle | pic x(2) comp-5.
heap-ref | cblt-x4-comp5 | pic x(4) comp-5.
heap-length | cblt-x4-comp5 | pic x(4) comp-5.
heap-buffer | pic x(n). | pic x(n).
status-code | See Library Routines - Key |

On Entry:

heap-id | The heap handle assigned when the heap was opened.
heap-ref | Offset in the heap at which to start writing. In .NET, this is limited to a maximum value of 0x7fffffff.
heap-length | Number of bytes to write.
heap-buffer | Buffer from which bytes are written. It is your responsibility to ensure that the buffer is large enough to hold the number of bytes being written.

On Exit:

None.

Parent topic: Virtual Heap Routines
Parent topic: Alphabetical List of Library Routines


Windows Routines

These routines are used when creating Windows API applications.

  • PC_ISAPI_GET_EXT
    Returns the ISAPI extension block.
  • PC_WIN_HANDLE
    Returns the handle of the window used for screen I/O.
  • PC_WIN_INIT
    Returns the Windows startup values.
Parent topic: Library Routines


PC_ISAPI_GET_EXT

Returns the ISAPI extension block.

Note: This routine is supported for native COBOL only.

Syntax:

call "PC_ISAPI_GET_EXT"  using    ext-block
                            returning pc-status-code

Parameters:

file-details
Group containing
01 extension-control-block    typedef
   03 cbsize                  DWORD
   03 dwversion               DWORD
   03 connid                  HCONN
   03 dwhttpstatuscode        DWORD
   03 lpszlogdata             PIC x(hse-log-buffer-len)
   03 lpszmethod              LPSTR
   03 lpszquerystring         LPSTR
   03 lpszpathinfo            LPSTR
   03 lpszpathtranslated      LPSTR
   03 cbtotalbytes            DWORD
   03 cbavailable             DWORD
   03 lpbdata                 LPBYTE
   03 lpszcontenttype         LPSTR
   03 getservervariable       procedure-pointer
   03 writeclient             procedure-pointer
   03 readclient              procedure-pointer
   03 serversupportfunction   procedure-pointer
pc-status-code
See Library Routines - Key

On Entry:

cbsize
Length of extension block.

On Exit:

ext-block
ISAPI extension block as passed from the Web server.
pc-status-code
One of the following codes:
0 | OK
1 | Non-ISAPI environment
2 | cbsize smaller than current ISAPI extension block
Parent topic: Windows Routines
Parent topic: Alphabetical List of Library Routines


PC_WIN_HANDLE

Returns the handle of the window used for screen I/O.

Note: This routine is supported for native COBOL only.

Syntax:

call "PC_WIN_HANDLE" using      hwnd
                     returning  status-code

Parameters:

 | Using call prototype (see Key) | Picture (32-bit systems) | Picture (64-bit systems)
hwnd | cblt-HWND. | pic x(4) comp-x. | pic x(8) comp-x.
status-code | See Library Routines - Key |  |

On Entry:

None

On Exit:

hwnd Contains the window handle.

Comments:

This routine is available only in the Windows environment.

Parent topic: Windows Routines
Parent topic: Alphabetical List of Library Routines


PC_WIN_INIT

Returns the Windows startup values.

Syntax:

call "PC_WIN_INIT" using     hInst
                             hPrevInst
                             lpszCmdLine
                             nCmdShow
                   returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
hInst | cblt-HINSTANCE | usage pointer.
hPrevInst | cblt-HINSTANCE | usage pointer.
lpszCmdLine | cblt-pointer | usage pointer.
nCmdShow | cblt-x4-comp5 | pic x(4) comp-5.
status-code | See Library Routines - Key

On Entry:

None

On Exit:

hInst | The handle of this instance.
hPrevInst | The handle of the previous instance.
lpszCmdLine | A pointer to the command line. Not for COBOL use.
nCmdShow | Flags to indicate the attributes attached to any windows created.

Comments:

When starting a Windows application Windows returns four start-up values. These are required when calling a number of the Windows API routines. When using the shared run-time system, it is necessary to call this routine to get the start-up values so you can then use the Windows API.

You should not access the command line using the parameter passed here. Use ACCEPT ... FROM COMMAND-LINE instead.

This library routine is supported by the JVM runtime.

Parent topic: Windows Routines
Parent topic: Alphabetical List of Library Routines


Miscellaneous Routines

  • X"91" function 11
    Sets the programmable COBOL switches.
  • X"91" function 12
    Reads the programmable COBOL switches.
  • X"91" function 13
    Sets the run-time switches
  • X"91" function 14
    Reads the run-time switches
  • X"91" function 15
    Checks for the existence of the specified program.
  • X"91" function 16
    Shows how many of the parameters in the call statement of the calling program have been transferred to the called subprogram.
  • X"91" function 35
    Performs an EXEC call (like the DOS 4B call) to the specified program file, executing it.
  • X"91" function 69
    Searches a directory for a given file specification.
Parent topic: Library Routines
Related information
Alphabetical List of Library Routines


X"91" function 11

Sets the programmable COBOL switches.

Syntax:

call x"91" using result
                 function-code
                 parameter

Parameters:

result
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
function-code
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
parameter
Group containing:
01 parameter
  03 switch-flag cblt-x1-compx occurs 8  *> pic x comp-x occurs 8
  03 debug-flag  cblt-x1-compx           *> pic x comp-x

On Entry:

function-code | Value 11
switch-flag | The values (0 or 1) to set in switches 0 through 7.
debug-flag | If set to 1, the ANSI Debug module is enabled.

On Exit:

result Set to zero if the call was successful, nonzero otherwise.

Comments:

To update one switch without affecting the others, you should read the switches with X"91" function 12, update parameter, and then call this function.

Parent topic: Miscellaneous Routines
Parent topic: Alphabetical List of Library Routines


X"91" function 12

Reads the programmable COBOL switches.

Syntax:

call x"91" using result
                 function-code
                 parameter

Parameters:

result
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
function-code
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
parameter
Group containing:
01 parameter
  03 switch-flag cblt-x1-compx occurs 8  *> pic x comp-x occurs 8
  03 debug-flag  cblt-x1-compx           *> pic x comp-x

On Entry:

function-code Value 12

On Exit:

result | Set to zero if the call was successful, nonzero otherwise.
switch-flag | The values of switches 0 through 7.
debug-flag | Set to 1 if the ANSI Debug module is enabled, otherwise zero.
Parent topic: Miscellaneous Routines
Parent topic: Alphabetical List of Library Routines


X"91" function 13

Sets the run-time switches

Note: This function is not supported in JVM COBOL.

Syntax:

call x"91" using result
                 function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
result | cblt-x1-compx | pic x comp-x.
function-code | cblt-x1-compx | pic x comp-x.
parameter | cblt-x1-compx occurs 26 | pic x comp-x occurs 26

On Entry:

function-code | Value 13
parameter | Each byte represents one of the switch letters and each bit in a byte is the state to set the numeric switch for that letter. For example, parameter(1) bit 0 represents switch A (or A0), bit 5 of parameter(19) represents switch S5.

On Exit:

result Set to zero if the call was successful, nonzero otherwise.

Comments:

To update one switch without affecting the others, you should read the switches with Function 14, update parameter, and then call this function.

Parent topic: Miscellaneous Routines
Parent topic: Alphabetical List of Library Routines


X"91" function 14

Reads the run-time switches

Note: This function is not supported in JVM COBOL.

Syntax:

call x"91" using result
                 function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
result | cblt-x1-compx | pic x comp-x.
function-code | cblt-x1-compx | pic x comp-x.
parameter | cblt-x1-compx occurs 26 | pic x comp-x occurs 26

On Entry:

function-code Value 14

On Exit:

parameter | Each byte represents one of the switch letters and each bit in a byte is the state of the numeric switch for that letter. For example, parameter (1) bit 0 represents switch A (or A0), bit 5 of parameter (19) represents switch S5.
result | Set to zero if the call was successful, nonzero otherwise.
Parent topic: Miscellaneous Routines
Parent topic: Alphabetical List of Library Routines


X"91" function 15

Checks for the existence of the specified program.

Note: This function is not supported in JVM COBOL.

Syntax:

call x"91" using result
                 function-code
                 parameter

Parameters:

result
Using call prototype (see Library Routines - Key) : cblt-x1-compx
Picture: pic x comp-x.
function-code
Using call prototype (see Library Routines - Key) : cblt-x1-compx
Picture: pic x comp-x.
parameter
Group containing:
name-len   cblt-x1-compx   *> pic x comp-x
progname   pic x(n)        *> pic x(n)

On Entry:

function-code | Value 15
name-len | The length of the name in filename.
progname | The name of the program to be looked for. This parameter must be at least 65 characters long.

On Exit:

progname | If the program is found, contains the full name.
result | Set to zero if the program was found, non-zero otherwise.

Comments:

If the program file is found, you must then call the program using the filename returned.

This call must not be used to check for the existence of data files; use CBL_CHECK_FILE_EXIST instead.

Parent topic: Miscellaneous Routines
Parent topic: Alphabetical List of Library Routines


X"91" function 16

Shows how many of the parameters in the call statement of the calling program have been transferred to the called subprogram.

Restriction: This routine is supported for native COBOL only.
Note: This routine has been deprecated in Net Express 4.0 onwards: it is provided for backward compatibility only. You should instead use CBL_GET_PROGRAM_INFO using by value 8.

Syntax:

call x"91" using result
                 function-code
                 parameter

Parameters:

 | Using call prototype (see Key) | Picture
result | cblt-x1-compx | pic x comp-x.
function-code | cblt-x1-compx | pic x comp-x.
parameter | cblt-x1-compx | pic x comp-x.

On Entry:

function-code Value 16

On Exit:

parameter | The number of parameters.
result | Set to zero if the call was successful, nonzero otherwise.

Comments:

This function is used in the called program; for the function to work in generated code, the program must be compiled with the PARAMCOUNTCHECK directive.

This function can only be used if the program is called from a COBOL program.

Parent topic: Miscellaneous Routines
Parent topic: Alphabetical List of Library Routines


X"91" function 35

Performs an EXEC call (like the DOS 4B call) to the specified program file, executing it.

Note:
  • This function is not supported in JVM COBOL.
  • This function is not supported on UNIX.

Syntax:

call x"91" using result
                 function-code
                 parameter

Parameters:

result
Using call prototype (see Library Routines - Key) : cblt-x1-compx
Picture: pic x comp-x.
function-code
Using call prototype (see Library Routines - Key) : cblt-x1-compx
Picture: pic x comp-x.
parameter
Group containing:
name-len   cblt-x1-compx   *> pic x comp-x
progname   pic x(n)        *> pic x(n)

On Entry:

function
Value 35
name-len
The number of characters in the name of the program. If this is set to zero, whatever has been previously written to the command line is executed.
progname
The filename of the program to be executed.

On Exit:

result
Zero if the EXEC call was successful, non-zero otherwise. If the reason for failure is a non-zero return code from the executed program then that value is returned. For other error conditions a value of 255 is returned. However, in .NET, if the target program does not exist, no error is returned.

Comments:

To execute a command line instead of just a named program, set name-len to zero, and set the command line using the DISPLAY...UPON COMMAND-LINE syntax.

Parent topic: Miscellaneous Routines
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
Alphabetical List of Library Routines


X"91" function 69

Searches a directory for a given file specification.

Note:
  • This function has been deprecated and is provided for backward compatibility only. You should instead use the CBL_DIR_SCAN routines.
  • This function is not supported in JVM COBOL.

Syntax:

call X"91" using result
                 function-code
                 parameter

Parameters:

result
Group containing:
01 result
  03 f-error    cblt-x1-compx   *> pic x comp-x.
  03 f-handle   cblt-x2-compx   *> pic x(2) comp-x.
  03 f-attrout  cblt-x1-compx   *> pic x comp-x.
  03 f-time     cblt-x2-compx   *> pic x(2) comp-x.
  03 f-date     cblt-x2-compx   *> pic x(2) comp-x.
  03 f-size     cblt-x4-compx   *> pic x(4) comp-x.
  03 f-fileout  pic x(n)        *> pic x(n)
function-code
Call prototype: cblt-x1-compx
Picture: pic x comp-x.
parameter
Group containing:
01 parameter
  03 f-action   cblt-x1-compx   *> pic x comp-x.
  03 f-attrin   cblt-x1-compx   *> pic x comp-x.
  03 f-filein   pic x(m)        *> pic x(m)

On Entry:

function-code
Contains 69
f-action
Defines the action to perform:
0 | Find the first matching file
1 | Find the next matching file
2 | Terminate the search early
3 | Find one matching file
f-attrin
Attribute byte. All normal files, plus those with the attributes specified by setting this parameter, are to be included. To specify attributes, set the bits as follows:
bit 7 | Unused
bit 6 | Unused
bit 5 | Archived file
bit 4 | Subdirectory
bit 3 | Unused
bit 2 | System file
bit 1 | Hidden file
bit 0 | Read-only file
f-filein
The space-terminated filename specification of the file(s) required. This can contain a drive/directory or any wildcard characters.

On Exit:

f-error
Contains a status of the result:
0 | Success/file found
1 | No more files
2 | Error
f-handle
The find handle. This field is set by the find-first function (see f-action above) and should not be altered until the corresponding terminate search has been done.
f-attrout
Attribute byte of file found:
bit 7 | Unused
bit 6 | Unused
bit 5 | Archived file
bit 4 | Subdirectory
bit 3 | Volume label
bit 2 | System file
bit 1 | Hidden file
bit 0 | Read-only file
f-time
Time file was created, in DOS format:
bits 15-11 | Hour, 0-23
bits 10-5 | Minute, 0-59
bits 4-0 | Bi-second, 0-29
f-date
Date file was created, in DOS format:
bits 15-9 | Year, 0-119 (1980-2099)
bits 8-5 | Month, 1-12
bits 4-0 | Day, 1-31
f-size
The size of the file in bytes.
f-fileout
The name of the file found, space-terminated.

Comments:

To find a single file, use the find-one function.

To find several files, use the find-first function and then use the find-next function repeatedly. When there are no more matching files, find-next returns with 1 in f-error. If you do not keep calling find-next until this happens, you must finish by calling the terminate-search function.

The f-handle field should be set to zero before you execute the find-first or find-one function. After that, if you are using the first/next/terminate sequence this field should not be changed until after the terminate search. If you are using the find-one function this field is automatically reset to 0 after that call.

If at any time f-error returns 1 or 2, a terminate search has been carried out automatically, and you should not execute the terminate-search function.

This routine cannot be used to check the existence of a network share resource, such as \\server1\share1, but it can be used to locate files or directories on that share, such as \\server1\share1\*.

Parent topic: Miscellaneous Routines
Parent topic: Alphabetical List of Library Routines


Alphabetical List of Library Routines

  • CBL_ABORT_RUN_UNIT
    Aborts the current run unit irrespective of the state of existing threads.
  • CBL_ALLOC_DYN_MEM
    Dynamically allocates memory, and can associate it with the calling program.
  • CBL_ALLOC_MEM
    Dynamically allocates memory, and can associate allocated heap data with a thread and/or the calling program.
  • CBL_ALLOC_SHMEM
    Dynamically allocates shared memory.
  • CBL_ALLOC_THREAD_MEM
    Allocates thread-specific heap memory.
  • CBL_AND
    Does a logical AND between the bits of two data items.
  • CBL_CANCEL
    Cancels a COBOL program.
  • CBL_CANCEL_PROC
    Provides control over program cancels.
  • CBL_CFGREAD_DYNFH
    The CBL_CFGREAD_DYNFH option determines whether the File Handler should reread its configuration file for configurable custom file handlers.
  • CBL_CFGREAD_EXTFH
    Forces the File Handler to reread its configuration file.
  • CBL_CHANGE_DIR
    Changes the current directory.
  • CBL_CHECK_FILE_EXIST
    Checks whether a file exists and if it does, returns details of when the file was last modified.
  • CBL_CLEAR_SCR
    Clears the whole screen to a specified character and attribute.
  • CBL_CLOSE_FILE
    Closes a file opened for byte-stream operations.
  • CBL_CLOSE_VFILE
    Closes a heap.
  • CBL_COPY_FILE
    Copies a file.
  • CBL_CREATE_DIR
    Creates a subdirectory.
  • CBL_CREATE_FILE
    Creates a new file and leaves it open for byte-stream operations.
  • CBL_CTF_COMP_PROPERTY_GET
    Returns a named property value for a component.
  • CBL_CTF_COMP_PROPERTY_SET
    Specifies a value for a component's property.
  • CBL_CTF_DEST
    Specifies an output destination by associating (or disassociating) an emitter with (or from) a component or the default emitter list.
  • CBL_CTF_EMITTER_PROPERTY_GET
    Returns a named property value for an emitter.
  • CBL_CTF_EMITTER_PROPERTY_SET
    Sets a named property value for an emitter.
  • CBL_CTF_LEVEL
    Specifies the trace level to be used for a specific component, or the default trace level if a component identifier is not specified.
  • CBL_CTF_TRACE
    Outputs an event to one or more output destinations.
  • CBL_CTF_TRACER_GET
    Returns a tracer handle that can be passed to other tracing routines to identify a component.
  • CBL_CTF_TRACER_LEVEL_GET
    Returns a tracer's current threshold trace level.
  • CBL_CTF_TRACER_NOTIFY
    Installs or uninstalls a tracer configuration callback function.
  • CBL_CULL_RUN_UNITS
    Clears any dead run units.
  • CBL_DEBUGBREAK
    Enables a COBOL program to invoke the debugger.
  • CBL_DEBUG_START
    Enables a COBOL program to initiate advanced remote debugging or cross-session debugging.
  • CBL_DEBUG_STOP
    Enables a COBOL program to stop or suspend animation.
  • CBL_DELETE_DIR
    Deletes a directory. The directory is deleted only if it is empty.
  • CBL_DELETE_FILE
    Deletes a file.
  • CBL_DIR_SCAN_END
    Terminates a search operation.
  • CBL_DIR_SCAN_READ
    Searches for the next entry in the file system using a search handle returned by a previous CBL_DIR_SCAN_START.
  • CBL_DIR_SCAN_START
    Initializes a search for a file or directory.
  • CBL_EQ
    Does a logical EQUIVALENCE between the bits of two data items.
  • CBL_ERROR_PROC
    Installs or removes an error procedure to be invoked automatically when a run-time system error occurs.
  • CBL_EVENT_CLEAR
    Clears the specified event.
  • CBL_EVENT_CLOSE
    Closes the supplied event handle.
  • CBL_EVENT_OPEN_INTRA
    Creates an intra-process event.
  • CBL_EVENT_POST
    Posts the specified event.
  • CBL_EVENT_WAIT
    Waits for the event to be posted.
  • CBL_EXEC_RUN_UNIT
    Creates a synchronous or asynchronous run unit.
  • CBL_EXIT_PROC
    Installs or removes a closedown procedure to be invoked automatically when the application terminates.
  • CBL_FILENAME_CONVERT
    Converts a filename between space-terminated and null-terminated format.
  • CBL_FILENAME_MAX_LENGTH
    Returns the maximum size of a filename that the run-time system and the current operating system can handle. This size does not include any terminators (null or space).
  • CBL_FLUSH_FILE
    Ensures all file buffers for a file are written to disk. This includes both run-time system buffers and operating system buffers.
  • CBL_FREE_DYN_MEM
    Frees dynamically allocated memory allocated by the CBL_ALLOC_DYN_MEM routine.
  • CBL_FREE_MEM
    Frees dynamically allocated memory.
  • CBL_FREE_RECORD_LOCK
    Releases a record lock on a file.
  • CBL_FREE_SHMEM
    Frees dynamically allocated shared memory.
  • CBL_FREE_THREAD_MEM
    Frees dynamically allocated thread-specific heap memory.
  • CBL_GET_CSR_POS
    Returns the cursor position.
  • CBL_GET_CURRENT_DIR
    Returns the current directory.
  • CBL_GET_EXIT_INFO
    Enables an application to determine under what circumstances an exit procedure has been invoked.
  • CBL_GET_KBD_STATUS
    Checks whether there is a character waiting to be read from the keyboard.
  • CBL_GET_MOUSE_MASK
    Returns the mouse event mask.
  • CBL_GET_MOUSE_POSITION
    Returns the screen position of the mouse pointer.
  • CBL_GET_MOUSE_STATUS
    Finds out the number of events in the queue.
  • CBL_GET_OS_INFO
    Returns information about the operating system environment.
  • CBL_GET_PROGRAM_INFO
    Returns information for a named program, or a program in the current call stack.
  • CBL_GET_RECORD_LOCK
    Obtains a record lock on a file.
  • CBL_GET_SCR_GRAPHICS
    Returns operating system independent codes for graphics characters.
  • CBL_GET_SCR_LINE_DRAW
    Returns a table of values defining the character values required by the run-time system screen output routines to correctly display given line drawing characters.
  • CBL_GET_SCR_SIZE
    Returns information about the size of the screen.
  • CBL_GET_SHMEM_PTR
    Reads a named value.
  • CBL_HIDE_MOUSE
    Makes the mouse pointer invisible.
  • CBL_IMP
    Does a logical IMPLIES between the bits of two data items.
  • CBL_INIT_MOUSE
    Initializes mouse support. This routine must be called before other mouse routines can be called.
  • CBL_JOIN_FILENAME
    Forms a filename by joining together its component parts; that is, the pathname, basename and extension.
  • CBL_LOCATE_FILE
    This routine has two uses. It can be used to expand an environment variable in a file specification, where the environment variable contains a list of several paths. It can also determine whether an OPEN INPUT statement using a particular file specification finds the file in a library file or as a separate disk file.
  • CBL_MEM_STRATEGY
    Changes the memory strategy for an application dynamically.
  • CBL_MEM_VALIDATE
    Validates memory allocations, monitored freed memory, and, if the operating system supports it, compacts memory heaps.
  • CBL_MONITOR_BROWSE
    Acquires the specified monitor's browse capability for the current thread, blocking until that capability can be acquired.
  • CBL_MONITOR_BROWSE_TO_READ
    Converts monitor browse capability already acquired by the current thread to read capability.
  • CBL_MONITOR_BROWSE_TO_WRITE
    Converts monitor browse capability already acquired by the current thread to write capability, blocking until this can be achieved.
  • CBL_MONITOR_CLOSE
    Closes the supplied monitor handle.
  • CBL_MONITOR_OPEN_INTRA
    Creates a monitor synchronization object for thread synchronization within one process.
  • CBL_MONITOR_READ
    Acquires the specified monitor's read capability for the current thread/process, blocking until that capability can be acquired.
  • CBL_MONITOR_RELEASE
    Releases any lock currently applied to the specified monitor by CBL_MONITOR_WRITE, CBL_MONITOR_READ or CBL_MONITOR_BROWSE.
  • CBL_MONITOR_UNBROWSE
    Releases the monitor's browse capability that was acquired by CBL_MONITOR_BROWSE or CBL_MONITOR_WRITE_TO_BROWSE.
  • CBL_MONITOR_UNREAD
    Releases the monitor's read capability that was acquired by CBL_MONITOR_READ or CBL_MONITOR_BROWSE_TO_READ.
  • CBL_MONITOR_UNWRITE
    Releases the monitor's write capability that was acquired by CBL_MONITOR_WRITE or CBL_MONITOR_BROWSE_TO_WRITE.
  • CBL_MONITOR_WRITE
    Acquires the specified monitor's write capability for the current thread, blocking until that capability can be acquired.
  • CBL_MONITOR_WRITE_TO_BROWSE
    Converts monitor write capability already acquired by the current thread to browse capability.
  • CBL_MUTEX_ACQUIRE
    Acquires a mutex for the specified thread.
  • CBL_MUTEX_CLOSE
    Closes the specified mutex.
  • CBL_MUTEX_OPEN_INTRA
    Create an intra-process mutex.
  • CBL_MUTEX_RELEASE
    Releases the specified mutex.
  • CBL_NLS_CLOSE_MSG_FILE
    Closes a National Locale Support (NLS) message file.
  • CBL_NLS_COMPARE
    Compares two strings.
  • CBL_NLS_INFO
    Gets/sets national language information.
  • CBL_NLS_OPEN_MSG_FILE
    Open a National Locale Support (NLS) message file.
  • CBL_NLS_READ_MSG
    Reads a message from a National Locale Support (NLS) message file.
  • CBL_NOT
    Does a logical NOT on the bits of a data item.
  • CBL_OPEN_FILE
    Opens an existing file for byte-stream operations.
  • CBL_OPEN_VFILE
    Opens a heap.
  • CBL_OR
    Does a logical OR between the bits of two data items.
  • CBL_PUT_SHMEM_PTR
    Creates or updates a named value.
  • CBL_READ_FILE
    Reads bytes from a file.
  • CBL_READ_KBD_CHAR
    Waits until a character is typed and then reads it with no echo.
  • CBL_READ_MOUSE_EVENT
    Reads the mouse event queue and returns information about an event.
  • CBL_READ_SCR_ATTRS
    Reads a string of attributes from the screen.
  • CBL_READ_SCR_CHARS
    Reads a string of characters from the screen.
  • CBL_READ_SCR_CHATTRS
    Reads a string of characters and their attributes from the screen.
  • CBL_READ_VFILE
    Reads bytes from a heap.
  • CBL_RENAME_FILE
    Changes the name of a file.
  • CBL_SCR_ALLOCATE_COLOR
    Finds an entry in the colormap for each of one or more given RGB values.
  • CBL_SCR_ALLOCATE_VC_COLOR
    Sets one or more specified virtual colormap entries to the RGB values supplied.
  • CBL_SCR_CREATE_VC
    Creates a virtual colormap and copies the contents of the system colormap to it.
  • CBL_SCR_DESTROY_VC
    Destroys a virtual colormap, causing the run-time system to revert to using the system colormap.
  • CBL_SCR_GET_ATTR_INFO
    Returns information about the attribute system for the environment.
  • CBL_SCR_GET_ATTRIBUTES
    Gets the character attribute code, and foreground and background colormap indexes for one or more entries in the attribute table.
  • CBL_SCR_NAME_TO_RGB
    Converts a single named color into an RGB value.
  • CBL_SCR_QUERY_COLORMAP
    Returns the RGB value for one or more colormap entries.
  • CBL_SCR_RESTORE
    Restores an area of the character-mode screen previously saved with a call to the CBL_SCR_SAVE call-by-name routine.
  • CBL_SCR_RESTORE_ATTRIBUTES
    Restores the attribute table to the saved values that are associated with the specified buffer handle.
  • CBL_SCR_SAVE
    Saves away an area of the screen (text and attributes) for subsequent restoration.
  • CBL_SCR_SAVE_ATTRIBUTES
    Saves the current settings of the attribute table.
  • CBL_SCR_SET_ATTRIBUTES
    Defines the character attribute, and foreground and background colormap indexes associated with each of one or more COBOL attribute values (attribute table indexes).
  • CBL_SCR_SET_PC_ATTRIBUTES
    Sets up the current COBOL attribute table so as to emulate, as closely as possible, the IBM-PC attribute table.
  • CBL_SEMAPHORE_ACQUIRE
    Acquires one of the resources represented by the semaphore by decrementing the associated count.
  • CBL_SEMAPHORE_CLOSE
    Closes the specified semaphore.
  • CBL_SEMAPHORE_OPEN_INTRA
    Creates an intra-process semaphore.
  • CBL_SEMAPHORE_RELEASE
    Releases one of the resources represented by the semaphore by incrementing the associated count.
  • CBL_SET_CSR_POS
    Moves the cursor.
  • CBL_SET_MOUSE_MASK
    Sets the mouse event mask.
  • CBL_SHOW_MOUSE
    Makes the mouse pointer visible.
  • CBL_SPLIT_FILENAME
    Splits a filename into its component parts; that is, the pathname, basename and extension.
  • CBL_SUBSYSTEM
    Declares or deallocates subsystems.
  • CBL_SRV_SERVICE_FLAGS_GET
    Enables a program running within a COBOL container as part of a service to determine the service's execution characteristics.
  • CBL_SRV_SERVICE_FLAGS_SET
    Enables a program running within a COBOL container as part of a service to set one or more the service's execution characteristics.
  • CBL_SWAP_SCR_CHATTRS
    Swaps a string of characters and their attributes with a string from the screen.
  • CBL_TERM_MOUSE
    Terminates mouse support, releasing internal resources.
  • CBL_TEST_RECORD_LOCK
    Tests for an existing record lock on a file.
  • CBL_THREAD_CREATE
    Creates a thread from a named entry point.
  • CBL_THREAD_CREATE_P
    Creates a thread from a procedure pointer.
  • CBL_THREAD_DETACH
    Frees thread resources when the thread terminates.
  • CBL_THREAD_EXIT
    Terminates the current thread.
  • CBL_THREAD_IDDATA_ALLOC
    Allocates an id-data area for the current thread.
  • CBL_THREAD_IDDATA_GET
    Returns a pointer to the id-data area for the specified thread.
  • CBL_THREAD_KILL
    Kills the specified thread, terminating it abnormally and detaching all resources associated with it.
  • CBL_THREAD_LIST_END
    Used in conjunction with CBL_THREAD_LIST_START and CBL_THREAD_LIST_NEXT to obtain a list of all currently existing threads that the run-time system knows about. It is required to terminate a CBL_THREAD_LIST_START.
  • CBL_THREAD_LIST_NEXT
    Used in conjunction with CBL_THREAD_LIST_START and CBL_THREAD_LIST_END to obtain a list of all currently existing threads that the run-time system knows about. The CBL_THREAD_LIST_NEXT call takes returns the next item in the list of threads.
  • CBL_THREAD_LIST_START
    Used in conjunction with CBL_THREAD_LIST_NEXT and CBL_THREAD_LIST_END to obtain a list of all currently existing threads that the run-time system knows about.
  • CBL_THREAD_LOCK
    Locks most functions of the thread-handling routines.
  • CBL_THREAD_PROG_LOCK
    With CBL_THREAD_PROG_UNLOCK, provides a single pre-initialized synchronization object per calling COBOL program
  • CBL_THREAD_PROG_UNLOCK
    With CBL_THREAD_PROG_LOCK, provides a single pre-initialized synchronization object per calling COBOL program
  • CBL_THREAD_RESUME
    Resumes a thread that was or will be suspended by CBL_THREAD_SUSPEND.
  • CBL_THREAD_SELF
    Stores the thread identifier of the current thread.
  • CBL_THREAD_SLEEP
    Causes the calling thread to give up control to the processor for the given number of milliseconds.
  • CBL_THREAD_SUSPEND
    Suspends the current thread.
  • CBL_THREAD_UNLOCK
    Unlocks most functions of the thread handling routines.
  • CBL_THREAD_WAIT
    Waits for completion of the specified non-detached thread, or returns immediately if the thread has already completed.
  • CBL_THREAD_YIELD
    Yields the rest of the current thread's timeslice.
  • CBL_TOLOWER
    Converts a string of letters to lower case.
  • CBL_TOUPPER
    Converts a string of letters to upper case.
  • CBL_TSTORE_CLOSE
    Closes a handle returned by CBL_TSTORE_CREATE.
  • CBL_TSTORE_CREATE
    Creates a handle for and specifies the size of a thread-storage area. These values can be used in subsequent calls to CBL_TSTORE_GET. The new thread-storage area is initialized to zeroes.
  • CBL_TSTORE_GET
    Gets a pointer to the thread-specific memory specified by CBL_TSTORE_CREATE.
  • CBL_WRITE_FILE
    Writes bytes to a file.
  • CBL_WRITE_SCR_ATTRS
    Writes a string of attributes to the screen.
  • CBL_WRITE_SCR_CHARS
    Writes a string of characters to the screen.
  • CBL_WRITE_SCR_CHARS_ATTR
    Writes a string of characters to the screen, giving them all the same attribute.
  • CBL_WRITE_SCR_CHATTRS
    Writes a string of characters and their attributes to the screen.
  • CBL_WRITE_SCR_N_ATTR
    Writes a specified attribute to a string of positions on the screen.
  • CBL_WRITE_SCR_N_CHAR
    Writes a specified character to a string of positions on the screen.
  • CBL_WRITE_SCR_N_CHATTR
    Writes a specified character and attribute to a string of positions on the screen.
  • CBL_WRITE_SCR_TTY
    Writes a string of characters to the screen starting at the current position and scrolling.
  • CBL_WRITE_VFILE
    Writes bytes to a heap.
  • CBL_XOR
    Does a logical XOR between the bits of two data items.
  • CBL_YIELD_RUN_UNIT
    Yields the remainder of a run-unit's time-slice.
  • MF_CLIENT_STATE_ALLOCATE
    Allocates a client identifier.
  • MF_CLIENT_STATE_DELETE
    Deletes an existing client identifier and its associated client information.
  • MF_CLIENT_STATE_EXPIRY
    Returns a date string for use in the cookie expiry field.
  • MF_CLIENT_STATE_FILE
    Specifies the file to be used on the server to store state information.
  • MF_CLIENT_STATE_PURGE
    Deletes all client information older than the number of days specified.
  • MF_CLIENT_STATE_RESTORE
    Restores a previously saved or allocated record which matches the client identifier.
  • MF_CLIENT_STATE_SAVE
    Updates the information in the state file.
  • mFFH
    Initializes the File Handler.
  • MFFH_MODIFY_DISABLE
    Disables all File Handler trace modification set by previous MFFH_MODIFY_TRACE calls.
  • MFFH_MODIFY_TRACE
    Modifies some FCD fields, to save directly accessing the FCD. You can use this call whether you are issuing standard COBOL I/O statements or calling the File Handler explicitly using the API.
  • PC_FIND_DRIVES
    Returns all valid drives on a PC.
  • PC_ISAPI_GET_EXT
    Returns the ISAPI extension block.
  • PC_PRINT_FILE
    Prints the contents of the specified file, optionally displaying printer control, font, and progress indicator dialog boxes, before commencing the print.
  • PC_PRINTER_CLOSE
    Closes a previously opened printer channel.
  • PC_PRINTER_CONTROL
    Sends a print command to a printer.
  • PC_PRINTER_DEFAULT_FONT
    Sets the default font for all PC_PRINTER_ routines.
  • PC_PRINTER_DEFAULT_NAME
    Sets the default printer for all PC_PRINTER_ routines.
  • PC_PRINTER_DEFAULT_PROPERTIES
    Sets one or more of the properties of the default printer for all PC_PRINTER_ routines.
  • PC_PRINTER_DRAW_RECTANGLE
    Draws an outline or filled rectangle at position start-x,start-y to end-x,end-y.
  • PC_PRINTER_ENUM_CLOSE
    Ends the process of enumerating printers.
  • PC_PRINTER_ENUM_NEXT
    Gets the name of the next enumerated printer.
  • PC_PRINTER_ENUM_START
    Starts the process of enumerating printers.
  • PC_PRINTER_FREE_BMP
    Frees a bitmap from memory, releasing its image and palette back to the operating system.
  • PC_PRINTER_GET_BMP_INFO
    Retreives the height and width of loaded bitmap
  • PC_PRINTER_GET_COLOR
    Gets the color on the printer.
  • PC_PRINTER_GET_FONT
    Gets the font on the printer.
  • PC_PRINTER_INFO
    Returns a native device context handle, and other information that can be used to enhance the printing of a document by calling native graphics functions directly.
  • PC_PRINTER_LINE_FROM_TO
    Draws a line from start-x,start-y to end-x,end-y.
  • PC_PRINTER_LOAD_BMP
    Loads a bitmap or other supported file format into memory ready for the PC_PRINTER_WRITE_BMP function.
  • PC_PRINTER_OPEN
    Opens a printer channel, giving it a document title, and optionally displaying printer control, font, and progress indicator dialog boxes
  • PC_PRINTER_REDIRECTION_PROC
    Registers a user function that is called when a program uses OPEN OUTPUT syntax and the ASSIGN TO PRINTER clause.
  • PC_PRINTER_SET_BACKGROUND_MIX_MODE
    Sets background printing mode.
  • PC_PRINTER_SET_COLOR
    Sets the color on the printer.
  • PC_PRINTER_SET_DEFAULT
    Sets a process-wide default printer before a printer is opened.
  • PC_PRINTER_SET_FONT
    Sets the current font for the printer.
  • PC_PRINTER_SET_PEN
    Set the width, style and colour for lines and rectangles when drawn using a printer.
  • PC_PRINTER_SET_POSITION
    Move the logicial printer position ready for the next PC_PRINTER_WRITE.
  • PC_PRINTER_WRITE
    Writes a text string to the printer.
  • PC_PRINTER_WRITE_BMP
    Write a loaded bitmap to a printer at a specified position with a given size.
  • PC_READ_DRIVE
    Returns the current default drive letter.
  • PC_SET_DRIVE
    Sets the default drive letter.
  • PC_WIN_CHAR_TO_OEM
    Translates a buffer of ANSI characters into the OEM character set.
  • PC_WIN_HANDLE
    Returns the handle of the window used for screen I/O.
  • PC_WIN_INIT
    Returns the Windows startup values.
  • PC_WIN_OEM_TO_CHAR
    Translates a buffer of OEM characters into the ANSI character set.
  • PC_WIN_SET_CHARSET
    Specifies the character set to be used by the case conversion routines CBL_TOUPPER and CBL_TOLOWER.
  • X"91" function 11
    Sets the programmable COBOL switches.
  • X"91" function 12
    Reads the programmable COBOL switches.
  • X"91" function 13
    Sets the run-time switches
  • X"91" function 14
    Reads the run-time switches
  • X"91" function 15
    Checks for the existence of the specified program.
  • X"91" function 16
    Shows how many of the parameters in the call statement of the calling program have been transferred to the called subprogram.
  • X"91" function 35
    Performs an EXEC call (like the DOS 4B call) to the specified program file, executing it.
  • X"91" function 46
    Enables insertion of a null character x"00" before data characters whose value is less than x"20" in line sequential files.
  • X"91" function 47
    Disables insertion of a null character x"00" before data characters whose value is less than x"20" in line sequential files.
  • X"91" function 48
    Enables insertion of tab characters in line sequential files.
  • X"91" function 49
    Disables insertion of tab characters in line sequential files.
  • X"91" function 69
    Searches a directory for a given file specification.
  • X"A7" functions 6 and 7
    Reads and sets user attribute.
  • X"A7" function 16
    Turns the user attribute on or off.
  • X"A7" function 17
    Sets the cursor type.
  • X"A7" function 18
    Makes console I/O redirectable.
  • X"A7" functions 20 and 21
    Reads and sets system attributes.
  • X"A7" function 25
    Returns the current screen type as recognized by the run-time system.
  • X"AF" function 1
    Sets various configurable features of Adis, including enabling or disabling individual user function, Adis or data keys, or a series of consecutive keys at run-time.
  • X"AF" function 18
    Displays a character to the screen at the current cursor position.
  • X"AF" function 22
    Sounds the terminal alarm.
  • X"AF" function 26
    Gets a character from the keyboard.
  • X"AF" Function 81
    Enables SCREEN SECTION ACCEPT and DISPLAY statements to inherit Keisen attributes written by preceding CBL_ calls.
  • X"B0" function 0
    Creates a function-key table.
  • X"B0" function 2
    Tests the status of the Shift, Alt, Ctrl and Lock keys.
  • X"B0" function 4
    Disables keyboard interrupts (Ctrl+Break).
  • X"E5"
    Sounds the bell.
  • X"F5"
    Unpacks the bits in a byte into eight bytes.
  • X"F4"
    Packs the least significant bits in eight bytes into a single byte.
Parent topic: Library Routines


CBL_NLS_CLOSE_MSG_FILE

Syntax:

call "CBL_NLS_CLOSE_MSG_FILE" using    msg-file-handle
                              returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
msg-file-handle | cblt-x4-compx | pic x(4).
status-code | See Library Routines - Key

On Entry:

msg-file-handle
The identifying handle returned when the message file was opened.

On Exit:

status-code
0 | Success
404 | Invalid msg-file-handle

Comments:

This routine enables you to close a National Locale Support (NLS) message file that had been previously opened using the CBL_NLS_OPEN_MSG_FILE routine.

Parent topic: Using NLS Library Routines in Your Programs
Parent topic: Alphabetical List of Library Routines
Related information
Library Routines - Key
NLS
NLS Message-file Handling Routines


CBL_NLS_OPEN_MSG_FILE

Syntax:

call "CBL_NLS_OPEN_MSG_FILE" using     msg-filename
                                       msg-filename-ln
                                       msg-file-handle
                             returning status-code

Parameters:

 | Using call prototype (see Key) | Picture
msg-filename | pic x(n). | pic x(n).
msg-filename-ln | cblt-x1-compx. | pic x comp-x.
msg-file-handle | cblt-x4-compx. | pic x(4).
status-code | See Library Routines - Key.

On Entry:

msg-filename
The name of the message file to be opened.
msg-filename-ln
The length of msg-filename.

On Exit:

msg-file-handle
The identifying handle.
status-code
Indicates whether the routine was successful:
0 | Success
403 | Resulting message too long
405 | Illegal or empty supplied file name
If status-code contains a value other than these, it is the number of a run-time error message.

Comments:

This routine opens an NLS message file returning an identifying handle that you can use with the CBL_NLS_READ_MSG and CBL_NLS_CLOSE_MSG_FILE routines.

You can create different message files for each language you want your program to work with, using the same call to access each message in the appropriate national language. You can use a default message file, or create your own.

Parent topic: Using NLS Library Routines in Your Programs
Parent topic: Alphabetical List of Library Routines


CBL_NLS_READ_MSG

Syntax:

call "CBL_NLS_READ_MSG" using     msg-file-handle
                                  full-msg-number
                                  msg-ins-struct
                                  msg-buffer
                        returning status-code

Parameters

msg-file-handle
Call prototype (see Key): cblt-x4-compx .
Picture: pic x(4).
full-msg-number
Group predefined as cblt-nls-msg-params containing:
01 cblt-nls-msg-params          typedef.
  03 cblte-nmpb-set-number      cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-nmpb-number          cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-nmpb-max-buffer-len  cblt-x2-compx. 	*> pic x(2) comp-x.
  03 cblte-nmpb-actual-msg-len  cblt-x2-compx. 	*> pic x(n) comp-x.
  03 cblte-nmpb-flags           cblt-x2-compx. 	*> pic x(2) comp-x.
msg-ins-struct
Group predefined as cblt-nls-msg-ins-struct containing:
01 cblt-nls-msg-ins-struct      typedef.
  03 cblte-nmis-ins-count       cblt-x2-compx.  *> pic x(2) comp-x.
  03 cblte-nmis-ins-pointer     cblt-pointer.   *> usage pointer.
                                                *> Occurs depending on ins-count.
msg-buffer
Call prototype (see Key): pic x(n).
Picture: pic x(n).
status-code
See Library Routines - Key.

On Entry:

msg-file-handle
The identifying handle of the message file to fetch the message from.
cblte-nmnp-set-number
The set in the message file to fetch the message from.
cblte-nmnp-number
The message number in the message set to fetch the message from.
cblte-nmis-ins-count
The number of portions of text to insert in the message.
cblte-nmis-ins-pointer
A pointer to a null-terminated portion of text to insert in the message.
cblte-nmb-buff-len
The length of msg-buff-text.

On Exit:

cblte-nmb-buff-text
The returned text (null-terminated).
status-code
Indicates whether the routine was successful:
0 | Success
40 | NLS module not initialized
401 | Message set not found
402 | Message not found in set
403 | Message too long for message text buffer
404 | Invalid msg-file-handle
If status-code contains a value other than these, it is the number of a run-time error message.

Comments:

In each message file, messages are divided into sets; this enables you to define your own message set in the default message file if you want. This routine also enables you to insert portions of text in a message fetched from the message file in the order appropriate to the rules of the grammar for the national language

Parent topic: Using NLS Library Routines in Your Programs
Parent topic: Alphabetical List of Library Routines


Restrictions, Compiler Limits, and System Limits

There are a number of areas that need care when you use them, as well as various limits imposed by the Compiler, the Run-time system, and your hardware and operating system.

The Compiler and the intermediate code that it produces are environment independent. The limits associated with the Compiler are environment independent also and cannot be exceeded in any environment. Run-time, operating system and hardware limits might also exist which might well be lower than those of the Compiler.

  • ALTER and ACCEPT Statement Restrictions
  • Command Line Length
  • Size and Number of Data Items
  • ENTRY Statement Restrictions
  • Filename Restrictions
  • Floating-point Numbers
  • Hardware or Operating System Limits
  • Maximum Number of Methods in a Class
  • Size of Names, Literals and PICTURE Character Strings
  • Nested Statement Restrictions
  • Restrictions on the Size of Numbers
  • Number of PERFORM Ranges
  • Program Source File Limits
  • Size of Programs, Divisions and Sections
  • Number of Files for Sorting or Merging
  • Table Dimension Limits
  • Number of USE Statements
  • Number of Parameters in a USING Phrase
  • Managed COBOL Restrictions
    Most COBOL functionality is supported in managed code. However, there are some restrictions.
Parent topic: General Reference


ALTER and ACCEPT Statement Restrictions

Exercise care when using the following statements:

  • ALTER

    In a segmented program, you must not alter code outside the current segment. However, if you do this, the Compiler does not report an error. The Compiler alters the code when the segment is entered.

  • ACCEPT identifier FROM LINE NUMBER

    This syntax is only suitable for use with operating systems that typically support many terminal lines. On Windows, it always returns zero.

Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
The ACCEPT Statement
The ALTER Statement


Command Line Length

With COBOL the maximum length of a command line is determined by the operating system.

Some Micro Focus tools limit the command line length to 128 characters. However, user applications should be able to use the operating system limit.

Parent topic: Restrictions, Compiler Limits, and System Limits
Related information
Hardware or Operating System Limits


Size and Number of Data Items

The following table shows the maximum size and number of data items.

Data Item | Maximum Size or Number
Alphanumeric/Group | 256MB
Alphanumeric Edited/ Numeric Edited | Can consist of 32 parts, each of which can contain up to 16 occurrences of a single edited character type subject to a total size of 512 bytes
Numeric | All significant digits must be within 18, 31 or 38 digits of the decimal point, depending on your COBOL environment: ANSI'85: 18 significant digits ISO2000: 31 significant digits Micro Focus: 38 significant digits
COMP/COMP-5 format | 8 bytes
EXTERNAL data item | No specifiable limit
File record size | 62KB
ACCEPT FROM CONSOLE | Limits (if any) are imposed by the operating system.
Full screen DISPLAY/ACCEPT | One screen less one character (the last character position on the screen is not usable)
Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
The File Control Entry
File Description Entry Skeleton
Data Description Entry Skeleton
Screen Section Entry Skeleton
The ACCEPT Statement
The ALTER Statement
The EXTERNAL Clause
The USAGE Clause
The USAGE Clause in the Screen Section


ENTRY Statement Restrictions

Entry points defined using the ENTRY statement can be accessed only after the main entry point (identified by Program-Id) has been called, unless the program is statically linked, or the MFENTMAP facility has been used.

A nested program cannot contain ENTRY statements.

An entry point is an alternative route into a program; an entry point is not treated as a separate program.

All program entry point names are truncated to 30 characters (so the first 30 characters of all entry point names must be unique).

Parent topic: Restrictions, Compiler Limits, and System Limits


Filename Restrictions

A file is identified in a COBOL program by a filename which is a user-defined word. Outside the COBOL system it is identified by a filename which must be in an external, operating-system format. There are four components:

  • A drive
  • A path
  • A base-name
  • An extension

The length of the filename is limited to 261 characters. The length of the basename and extension together is 256 characters.

COBOL imposes no other limits, but in order for the operating system to handle the filename correctly, any operating system limits must be observed when the program is run.

Parent topic: Restrictions, Compiler Limits, and System Limits


Floating-point Numbers

This COBOL system provides IEEE floating-point support. This is fully compatible with the various languages supplied by Microsoft, including Microsoft Visual C++ V6.0.

Floating-point values must be in the range:

For COMP-1 data, | 8.43E-37 | through | 3.37E38
 | -8.43E-37 | through | -3.37E38
For COMP-2 data, | 4.19E-307 | through | 1.67E308
 | -4.19E-307 | through | -1.67E308

Note that although the above ranges are supported internally, this COBOL system supports only 2 digit exponents, and the range is effectively:

For COMP-2 data, | 4.19E-99 | through | 1.67E99
 | -4.19E-99 | through | -1.67E99

The accuracy of floating-point values is:

For COMP-1 data (4 bytes) | 6-7 significant digits
For COMP-2 data (8 bytes) | 15-16 significant digits
For literals, floating-point values must be in the range:
  • 0.54E-78 through 0.72E+76
  • -0.54E-78 through -0.72E+76
Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
Data Description Entry Skeleton
The USAGE Clause


Hardware or Operating System Limits

Operating system or hardware configurations and parameter settings directly constrain a COBOL application. Check your operating system and hardware for any limits. You might need to consider the following:

Item | Limit
Environment variables | Limited to a maximum of 64 Kilobytes (or the machine's free space, whichever is smaller) of written environment variables at any one time during the run of an application.
File locks | Operating system dependent
CALL nesting | Limited by stack space allocated by the operating system
Length of contents of DD_ environment variables | Up to the maximum operating system size for each path
Total data and procedure size | Limited by available free memory
Simultaneously loaded subprograms | Limited by available free memory
File and record sizes | Limited by operating system environment
Files open simultaneously | Limited by operating system environment.
Filename size and format | Operating system dependent
Index key size and number | Might be limited if a non-standard file handler is used
Sort key size and number | Might be limited if a non-standard SORT support routine is used
Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
The File Control Entry
The CALL Statement
The I-O-Control Paragraph
The SORT Statement
Related information
File Handling - Run-time Limits
File Handling - COBOL Compiler Limits


Maximum Number of Methods in a Class

The maximum number of methods allowed in a class is limited to 999.

This limit does not apply to managed (.NET) programs.

Parent topic: Restrictions, Compiler Limits, and System Limits


Size of Names, Literals and PICTURE Character Strings

Language elements are limited to the following sizes:

Language Element | Maximum Size
Alphanumeric literal values | 8192 bytes
PICTURE character string | 30 characters
PICTURE replication (for example, n in PIC X(n)) | 256,000,000
Program-Id name | 30 characters
Entry point names | 30 characters
Programmer defined words | 30 characters
External filenames (for program source and object files, copybooks, data files) | 265 characters
Dynamically loadable program names | 265 characters
Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
The Special-Names Paragraph
Data Description Entry Skeleton
The PICTURE Clause
Screen Section Entry Skeleton
The PICTURE Clause in the Screen Section
Related information
Filename Restrictions
Calling Entry Points in Subprograms


Nested Statement Restrictions

Type of Nested Statement | No of Levels
PERFORM statements:
- intermediate code | 100
- generated code | depends on the amount of memory allocated by the operating system
- debugging | 254. If your program exceeds this level, Debugger will only Step, even if Zoom mode is specified.
IF statements (compiled code only)

Limited by:

  • the amount of stack space available when compiling the program
  • the run-time system to 255
CALL statements | No specifiable limit. However, this is limited by the stack space allocated by the operating system.
Parent topic: Restrictions, Compiler Limits, and System Limits
Related information
Programming Tips


Restrictions on the Size of Numbers

According to the ANSI standard, numbers are limited to 18 significant decimal digits. All significant digits must be within 18 digits of the decimal point.

Micro Focus COBOL gives an ON SIZE ERROR if either of the following conditions occurs:

  • A multiplication or division gives a result which is greater than 36 digits
  • An addition or subtraction gives a result which is greater than 37 digits
Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
The Special-Names Paragraph
The File Control Entry
The I-O-Control Paragraph
Data Description Entry Skeleton
The OCCURS Clause
The ADD Statement
The CALL Statement
The DIVIDE Statement
The ENTRY Statement
The EXIT Statement
The GOBACK Statement
The INVOKE Statement
The MERGE Statement
The MULTIPLY Statement
The SORT Statement


Number of PERFORM Ranges

The maximum number of distinct PERFORM ranges in a program is 65535 .

This limit doesn't apply to .NET programs.

Parent topic: Restrictions, Compiler Limits, and System Limits


Program Source File Limits

The following limits apply to program source files:

Source File Item | Number of Items or Size of Item
Source lines | 999,999
Data and procedure-names | 64,000
Host variables | 8,000 or database system limit if lower
Literal values | No limit
Words in COPY pseudo-text | 65,000
BY clauses in a COPY REPLACING statement | 65,000
Actual fixed format line | 80 bytes
Effective fixed format line | 72 bytes
Free format line | 160 bytes
Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
The COPY Statement


Size of Programs, Divisions and Sections

The following table shows the maximum size of program divisions and sections.

Object | Maximum Size
Total | No limit
Data Division | 256MB
Local-Storage Section | Platform specific
Procedure Division | 816MB
Number of sections, paragraphs and labels in Procedure Division | 65535 (64K)
COBOL segment | 16MB
Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
Language Fundamentals
Procedure Division General Description
General Description
Local-Storage Section


Number of Files for Sorting or Merging

The maximum number of files in a SORT filename GIVING or MERGE filename GIVING phrase is 128.

Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
The SORT Statement
The MERGE Statement
The File Control Entry
The I-O-Control Paragraph
The PROCEDURE DIVISION Header
The ADD Statement
The CALL Statement
The DIVIDE Statement
The ENTRY Statement
The EXIT Statement
The GOBACK Statement
The INVOKE Statement
The MULTIPLY Statement
Related information
Mixed Language Programming with Native COBOL
Passing Parameters to a Called Program
Optimizing Parameter Handling


Table Dimension Limits

Table Element | Limit
Total size | No limit
Nesting of OCCURS clause | No limit
In Screen Section | No specifiable limit
Number of subscripts | 16
OCCURS in Screen Section | Limited by the number of fields and/or the levels of occurrence. It is not possible to give an actual limit, but exceeding the limit will result in an error when you compile your program.
Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
Data Description Entry Skeleton
The OCCURS Clause
Screen Section Entry Skeleton
The OCCURS Clause in the Screen Section
General Description
The BLANK Clause
The DISPLAY Statement


Number of USE Statements

The maximum number of USE statements in a program is 250.

Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
The USE Statement
General Description
The USE BEFORE REPORTING Statement


Number of Parameters in a USING Phrase

The following maximum numbers of parameters are permitted in each type of USING phrase:

Statement with USING Phrase | Maximum Parameters
CALL statement | 65535
PROCEDURE DIVISION header | 65535
ENTRY statement | 65535
CALL prototype | 40
Parent topic: Restrictions, Compiler Limits, and System Limits
Related reference
The PROCEDURE DIVISION Header
The CALL Statement
The ENTRY Statement
The MERGE Statement
The SET Statement
The SORT Statement
The USE Statement
The XML PARSE Statement
Related information
Mixed Language Programming with Native COBOL
Passing Parameters to a Called Program
Optimizing Parameter Handling


Managed COBOL Restrictions

Most COBOL functionality is supported in managed code. However, there are some restrictions.

  • COBOL Syntax Restrictions in Managed COBOL
    There is a range of syntax designed specifically for managed COBOL. In addition, the native COBOL syntax is supported in managed COBOL, with a few exceptions. Also there are some words are now reserved.
  • Compiler Directives Restrictions in Managed COBOL
    Most Compiler directives are supported for managed COBOL, in addition to those directives designed specifically for compiling managed code. There are a few native COBOL Compiler directives that are not supported in managed COBOL.
  • File Handling Restrictions in Managed COBOL
    Managed COBOL supports virtually all file handling functionality. However there are one or two features that are not supported.
  • COBOL Services as COM, Java or Web Services
    Any COBOL services, such as COM interfaces, Java interfaces and Web Services, that you created using the Service Interfaces feature or the Interface Mapping Toolkit can continue to run under Server Enterprise Edition.
  • Mixed-language Implications in Managed COBOL
    Managed COBOL programs can interoperate seamlessly with programs in other managed languages.
  • Object-Oriented (OO) COBOL Restrictions in Managed Code
    Applications that use the native Object-Oriented (OO) COBOL syntax will probably require significant work to migrate them to managed COBOL. We recommend that you contact Micro Focus support for extra help with this.
  • SQL Restrictions in Managed COBOL
    Managed COBOL provides extensive support for SQL. However, there are one or two features of SQL are not supported in managed COBOL.
  • Unsupported Functionality in Managed COBOL
    Some areas of functionality are not supported in managed COBOL.
Parent topic: Restrictions, Compiler Limits, and System Limits
Related information
Visual Studio and COBOL


COBOL Syntax Restrictions in Managed COBOL

There is a range of syntax designed specifically for managed COBOL. In addition, the native COBOL syntax is supported in managed COBOL, with a few exceptions. Also there are some words are now reserved.

There is syntax designed specifically for managed COBOL. We recommend you use this syntax, although you can continue to use the original native COBOL syntax, in virtually all situations.

However, there are some words that are now reserved. If your native code uses these reserved words, you get a Compiler error when you compile to managed code. You can change your data item names so that they don't conflict with a reserved word or you can unreserve the necessary words using the REMOVE Compiler directive.

In addition, the following syntax is not supported in managed COBOL:

  • ACCEPT statement format 5.
  • Adis (Extended Accept/Display).
  • ALTER statement. This is supported but in segmented programs, an altered paragraph remains altered even when a segment is reloaded.
  • CALL-CONVENTION.
  • CHAIN statement. This is mapped to a CALL statement.
  • DISPLAY of numeric fields. A signed numeric field displays an integer. Plus signs are not displayed.
  • DISPLAY statement format 3.
  • GLOBAL declaratives in nested programs.
  • Mainframe pointers.
  • Mainframe PERFORM statements (perform-type(osvs/vsc2)).
  • Program names. Generally, .dll names, program names and method names used in CALL and INVOKE statements must always be specified in upper case. However, if the AS phrase has been used in the called program to modify the program name, the case used in the CALL or INVOKE statement must exactly match that specified in the AS phrase.
  • Screen section.

The syntax designed specifically for managed COBOL and some additional words are now reserved. If your native code uses words that are now reserved, you get a Compiler error when you compile to managed code. You can change your data item names so that they don't conflict with a reserved word or you can unreserve the necessary words using the REMOVE Compiler directive.

Parent topic: Managed COBOL Restrictions
Related reference
Managed COBOL Reference


Compiler Directives Restrictions in Managed COBOL

Most Compiler directives are supported for managed COBOL, in addition to those directives designed specifically for compiling managed code. There are a few native COBOL Compiler directives that are not supported in managed COBOL.

Most Compiler directives are supported for managed COBOL, in addition to those directives designed specifically for compiling managed code.

The following Compiler directives are not supported in managed COBOL:

  • ACTUAL-PARAMS
  • BOUNDOPT
  • CHECK
  • COBIDY
  • FASTCALL
  • FASTLINK
  • FAULTFIND
  • FIXOPT
  • GNT
  • HOSTSIGNS
  • INT
  • INTLEVEL
  • KEEP-INT
  • LINKCHECK
  • LITLINK
  • LNKALIGN
  • OBJ
  • OPT
  • PARAMCOUNTCHECK
  • PERFORMOPT
  • RECURSECHECK
  • SCHEDULER
  • SEG
  • SOURCEASM
  • TRICKLE
  • WEBSERVER
Parent topic: Managed COBOL Restrictions
Related information
Compiler Directives
Managed COBOL Command Line Compiler Directives


File Handling Restrictions in Managed COBOL

Managed COBOL supports virtually all file handling functionality. However there are one or two features that are not supported.

Managed COBOL supports virtually all file handling functionality.

The following file handling features are not supported in managed COBOL:

  • Fileshare
  • .lbr files
  • LPT[2-n] devices
  • Printer redirection
  • Timeout support within the support for LPT1

The Managed Code File Handler is not verifiable.

Parent topic: Managed COBOL Restrictions
Related information
File Handling


COBOL Services as COM, Java or Web Services

Any COBOL services, such as COM interfaces, Java interfaces and Web Services, that you created using the Service Interfaces feature or the Interface Mapping Toolkit can continue to run under Server Enterprise Edition.

Server Enterprise Edition can run any Java interfaces, COM interfaces or Web Services that you exposed using the Interface Mapping Toolkit.

However, the Interface Mapping Toolkit is not available in Studio Enterprise Edition, so you cannot create new interfaces or services like this.

Parent topic: Managed COBOL Restrictions
Related information
Java and COBOL
Web Application Projects


Mixed-language Implications in Managed COBOL

Managed COBOL programs can interoperate seamlessly with programs in other managed languages.

Managed COBOL programs can interoperate seamlessly with programs in other managed languages.

Non-COBOL projects that call COBOL code require a reference to the MicroFocus.COBOL.Runtime assembly.

There is a small performance overhead for calls between native COBOL and managed code. There is no performance penalty for method invocations between managed COBOL and other managed languages.

Parent topic: Managed COBOL Restrictions
Related information
Interoperability
Data Marshaling and Type Conversion for Managed Code Interoperation


Object-Oriented (OO) COBOL Restrictions in Managed Code

Applications that use the native Object-Oriented (OO) COBOL syntax will probably require significant work to migrate them to managed COBOL. We recommend that you contact Micro Focus support for extra help with this.

Applications that use the native OO COBOL syntax will probably require significant work to migrate them to managed COBOL. We recommend that you contact Micro Focus support for extra help with this.

Some of the significant differences between native OO COBOL and managed COBOL are:

  • Managed code is typed, unlike native OO COBOL. The Compiler enforces type checking on object references in managed COBOL. This is different to native OO COBOL where all object references are simply of type "object" and can hold a reference to instances of any class of object.
  • Object references must be defined at level-01 in managed COBOL, because the compiled code and the run-time system now conform to the rules for type-safe code. This conforms with the ISO2002 COBOL standard.
  • The Micro Focus OO class libraries are not supported for managed COBOL.
  • The CLASS-OBJECT syntax is not available in managed COBOL.
  • Multiple inheritance is not supported in native OO COBOL, although it is part of the ISO 2002 standard. Managed COBOL supports single inheritance of classes, but you can inherit (implement) multiple interfaces.
  • Interface files (.if) and the vocabularies syntax do not have an equivalent in managed COBOL.
Parent topic: Managed COBOL Restrictions
Related information
Micro Focus OO COBOL Extensions


SQL Restrictions in Managed COBOL

Managed COBOL provides extensive support for SQL. However, there are one or two features of SQL are not supported in managed COBOL.

Managed COBOL provides extensive support for SQL.

The following features of SQL are not supported in managed COBOL:

  • Dynamic SQL using the SQL Descriptor Area (SQLDA) is not supported for OpenESQL applications compiled with the SQL(DBMAN=ODBC) directive.
  • CONNECT ... WITH PROMPT syntax is not supported with applications compiled with SQL(DBMAN=ADO)
Parent topic: Managed COBOL Restrictions
Related information
Database Access Concepts
Reference


Unsupported Functionality in Managed COBOL

Some areas of functionality are not supported in managed COBOL.

The following functionality is not supported in managed COBOL:

  • ANSI debug
  • CGI
  • Micro Focus class libraries
Parent topic: Managed COBOL Restrictions


Mainframe Reference

  • Assembler Reference
  • CICS Preprocessor Options
  • CICS Support Commands
    Lists the CICS Support commands
  • Micro Focus BMS Screen Painter
  • IMS Support
Parent topic: General Reference


Assembler Reference

The implementation of Assembler provided by Studio Enterprise Edition is as defined in the following IBM manuals, with certain exceptions and differences:

High Level Assembler for MVS, VM and VSE Language Reference SC26-4940-03

ESA/390 Principles of Operation SA22-7201-07

z/Architecture Principles of Operation SA22-7832-00

  • Assembler File Types
    Lists the file types you can use with Assembler applications, and a description of each.
  • Assembler Input and Output Directories
    Specify input and output directories for Assembler macros, copybooks and other files using environment variables, a configuration file or both.
  • Assembler Command Line Reference
  • Assembler Compiler Directives
  • Assembler Linker Directives
  • Assembler Link Files
    Describes the format and usage of .lin files containing linker commands.
  • Assembler Link File Commands
  • Macros and SVCs
  • Assembler Pseudo Operations
  • Configuring an Enterprise Server for Assembler Support
    Describes the configuration requirements for an enterprise server instance that runs assembler applications using JCL and CICS.
Parent topic: Mainframe Reference


Assembler File Types

Lists the file types you can use with Assembler applications, and a description of each.
The most commonly used assembler file type is .mlc, which represents an Assembler source file.You can also use the following file types:
  • .asm – Assembler source file (same as .mlc)
  • .mac – Assembler macro file
  • .lin – Linker input file (refer to “Assembler Link File Commands” section)
  • .cap – CICS Assembler program (Assembler program that contains EXEC CICS statements)
  • .obj – Assembler object modules produced by Assembler
  • .390 – Executable assembler modules
  • .MOD – CICS table files created by the assembler linker
  • .lst – Linker list file
  • .prn – Assembler list file
Parent topic: Assembler Reference


Assembler Input and Output Directories

Important: Enclose path names in double quotes if the path contains one or more spaces.

MF370CTL.CFG Configuration File

We supply a configuration file, MF370CTL.CFG you can use to customize your input and output directories by editing the values for a series of SYS variables. This file is located by default in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory.

The assembler looks for MF370CTL.CFG in the current working directory before searching for it in the default location.

All output variables take a single directory specification.

Output Variables | Description
SYSIN | Macro input .mlc files
SYSLIST | Assemble and Link listing files .mat, .prn, and .lst
SYSWORK | Assemble, Link and debugger 370 work files .bal, .idf, and .idx
SYSPUNCH | Assemble output .pch files for PUNCH statements
SYSMPC | Assemble input precompiled macros .mpc
SYSLIN | Link input .lin files and Assemble output .obj files
SYSLMOD | Link output load-member .390 files

The SYSLIB and OBJ370 input variables take multiple directories, separated by semicolons, allowing you to specify several search directories for macros and copybooks. The SYSPARM input variable takes a single parameter.

Input Variables | Description
SYSLIB | Assemble input macro and copy files .mac and .cpy
OBJ370 | Link input .obj files (must contain SYSLIN specification)
SYSPARM | Macro input SYSPARM value. The default is MF370.

For example, to specify an output directory:

SET SYSLIB=.;C:\SYSLIB;C:\USERLIB1;"C:\USERLIB2 MFASM TEST.MLC"

This example instructs the assembler to search the listed directories, in order, for macro and copybooks as they are encountered during assembly. By setting SYSLMOD, output files such as .390 files can be directed to specific output directories.

Environment Variables

You can override any variable specified in the MF370CTL.CFG file by setting it directly in the environment, using the same name as found in the MF370CTL.CFG file.

Note: The Assembler support provided with Studio Enterprise Edition is essentially the same support as found in the Micro Focus Mainframe Express product.
Parent topic: Assembler Reference


Assembler Command Line Reference

You can use the MFASM command, or a series of run commands to assemble and link executable modules and data tables for Assembler applications.

All commands must be executed from aNet Express command prompt, 32-bit.

  • MFASM
    Use the MFASM command to assemble and link Assembler applications in one step, producing executable subroutines, and debugging modules.
  • mm370asm
    Assembles an Assembler source (.mlc) file.
  • mf370lnk
    Links an object (.obj) file into an executable file (.390).
  • mf370chk
    Assembles an Assembler source (.mlc) file and links it to an executable (.390) file.
Parent topic: Assembler Reference


mm370asm

Assembles an Assembler source (.mlc) file.

Syntax:

run mm370asm filename[.mlc] [compDirective[ ...]][;]

Parameters:

filename
The name of an assembler source file.
compDirective
One or more Assembler compiler directives, separated by a space. See Assembler Compiler Directives for more information.

Comments:

Command line compatibility with the assembler component of the Micro Focus Mainframe Express product is maintained. Batch files used with Mainframe Express should work correctly under Studio Enterprise Edition. In particular the MF370CHK (Micro Focus 370 Checker) module along with the MM370ASM (standalone assembler) and the MF370LNK (standalone assembler linker) are present. So command lines used under Mainframe Express to assemble and link assembler modules do work

Examples:

Mainframe Express Command Line

RUN MF370CHK TEST.MLC OMF(390) NOANIM NOLIST;

Assemble and Link Modules in Separate Commands

RUN MM370ASM TEST.MLC NOANIM; RUN MF370LNK TEST.OBJ NOANIM NOLIST ;
Parent topic: Assembler Command Line Reference


mf370lnk

Links an object (.obj) file into an executable file (.390).

Syntax:

run mm370lnk filename[.obj] [linkerDirective[ ...]] | linkfile.LIN][;]

Parameters:

filename
The name of an object file.
linkerDirective
One or more linker directives, separated by a space. See Assembler Linker Directives for more information.
linkfile
The name of a link file containing linker directives. See Assembler Link Files for more information.
Parent topic: Assembler Command Line Reference


mf370chk

Assembles an Assembler source (.mlc) file and links it to an executable (.390) file.

Syntax:

run mm370chk filename[.mlc] compDirective[ ...]][{linkerDirective ... | linkfile.LIN}][;]

Parameters:

filename
The name of an assembler source file.
compDirective
One or more Assembler compiler directives, separated by a space. See Assembler Compiler Directives for more information.
linkerDirective
One or more linker directives, separated by a space. See Assembler Linker Directives for more information.
linkfile
The name of a link file containing linker directives. See Assembler Link Files for more information.
Parent topic: Assembler Command Line Reference


Assembler Compiler Directives

You can specify Assembler compiler directives on the command line when building from the command line, or in your project properties when building from the IDE.

Note: Take care when setting compiler directives in the Additional Directives field on the Assembler tab of your project properties Assembler page as these could conflict with a default setting.
  • AAT
    Generate Assembler Analysis Tool (AAT) outputs; used to determine required macro and copybook files, all external references to called modules, all SVCs, MNOTEs generated, etc.
  • ALLOW
    Suppress error and warning messages.
  • AMODE
    Set the memory address type.
  • ANIM
    Generate .idf and .idx files required to debug an Assembler module during execution.
  • ASM
    Perform a complete compilation, that is, both pre-process macros and assemble the resulting .bal file, producing an .obj file.
  • BAL
    Create a source file (.bal) in the load library; this file contains the output from the macro pre-process stage of compilation.
  • BALLIST
    Create a listing file of the .bal file that shows each macro call and the relative byte address of each expanded macro instruction.
  • BALWTO
    Create a listing file of the .bal file that shows each macro call and the relative byte address of each expanded macro instruction, and display each line on the Output Window. Also reduces the output buffer for the .mop file to 1,000 bytes to ensure that the .mop file and the current screen between them supply a complete record of the pre-process phase in the event of a failure.
  • CACHE
    Cache all access to the virtual files used during compilation. The cache is a pool of 4 kilobyte (Kb) buffers with least recently used replacement.
  • CALL
    Attempt to automatically resolve any remaining external references by repeatedly searching the load library for .obj files matching external names.
  • CICS
    Enables the use of the EXEC CICS preprocessor to convert the CICS commands you supply into calls to the CICS command-level API.
  • COMPATM
    Force all macro parameters not in quotes to be upper case for compatibility with the previous Micro Focus Assembler product, MF370.
  • COMPATS
    Treat all sublists in macro parameters as character strings for compatibility with the previous Micro Focus Assembler product, MF370.
  • EID2
    Generate two-byte external symbol ids in object code. If you specify NOEID2, one-byte external symbol ids are generated; this format is compatible with versions of the previous Micro Focus Assembler product, MF370, before 4.0.06.
  • EPILOG
    Insert DFHEIRET macro in the EXEC CICS code.
  • ESD
    Include external symbol directory (ESD) records in .370 files.
  • LINK
    Create a .390 file when compilation is complete, by linking in all other modules called by the main module.
  • LIST
    Create a compilation listing in filename.prn in the output library.
  • LISTCALL
    Include macro call statements with parameters in the .bal file.
  • LISTPARM
    Create a trace of all macro parameters and their values (including all nested macro calls).
  • MACLIST
    Create a macro listing in filename.prn in the output library.
  • MCALLS
    Execute called macros during macro pre-process stage.
  • MOPLIST
    Create a detailed macro execution trace file showing each line of code executed with the name of the macro, the relative byte address, the opcode, the current variable name or macro sequence symbol name, and the current seta, setb, and setc values. The listing file has the extension .mop.
  • MOPWTO
    In addition to the functionality of MOPLIST, MOPWTO displays each line in the Output Window. It also reduces the output buffer for the .mop file to 1,000 bytes to ensure that the .mop file and the current screen between them supply a complete record of the pre-process phase in the event of a failure.
  • MPC
    Determines the level of macro processing.
  • MPCGEN
    Recreate new .mpc files containing compiled macro code replacing previous versions if any.
  • MPCLIST
    List generated macro code after each macro source line during macro pre-process phase.
  • OBJ370
    Generate mainframe-compatible sequential fixed-block object code file, filename.370, in the load library.
  • OBJECT
    Generate object code in either filename.obj (default) or filename.370 format depending on current OBJ370 setting.
  • OMF
    Specifies the type of output - load module or CICS data table.
  • OPT
    Make an extra pass of macro object code to resolve references to addresses.
  • OLDCICS
    Specify the level of the CICS preprocessor to use.
  • PLISTUB
    Generate a PLI stub program in the source directory for each entry point in the Assembler module being compiled.
  • PROLOG
    Insert DFHEIENT, DFHEIEND, and DFHEISTG macros in the EXEC CICS code. You can set this directive only if you have set the CICS directive.
  • RENT
    Mark module as re-entrant; this prevents reloading of the module each time it is called.
  • REUS
    Mark load module as serially reusable; this prevents reloading of the module each time it is called.
  • RLD
    Generate relocation records for relocatable address constants in the object code file filename.obj.
  • RMODE
    Specify a residence mode for the load module.
  • STATIC
    Generate code from macro statements with no symbolic parameters without parsing them for parameter substitution.
  • SYSPARM
    Define string to be substituted in macros for the variable symbol &SYSPARM.
  • TOTALS
    Write totals to syslist.wto showing internal statistics on macro compiles, symbol table lookups, external symbols, literals, physical file input/output, virtual file input/output, memory usage, etc.
  • TRACE
    Generate trace of events during compilation in syslist.wto
  • UFUNC
    Specify how to handle unsupported CICS functions.
  • UOPT
    Specify how to handle unsupported CICS options.
  • VSECOMP
    Set a macro variable that allows the Studio Enterprise Edition Assembler implementation to correctly interpret DOS/VSE macro operands where these differ from their MVS counterparts.
  • XMAC
    Include a cross-reference listing in filename.prn for all macros and copybooks showing the relative line numbers of the generated statements.
  • XREF
    Include a cross-reference listing in filename.prn for all labels and literals showing the relative line numbers of the generated statements.
  • XSVC
    Include an entry for each SVC in the module in filename.prn in a cross-reference table that shows the relative line numbers of all the statements that reference that SVC.
Parent topic: Assembler Reference


AAT

Generate Assembler Analysis Tool (AAT) outputs; used to determine required macro and copybook files, all external references to called modules, all SVCs, MNOTEs generated, etc.

Syntax:

[NO]AAT

Properties:

Default: NOAAT

Build Settings:

Check Create Assembler Analysis Tool (AAT) information on the Assembler tab of your project properties Assembler page.

Comments:

The AAT directive creates the following output files in the load library:
  • filename.aat - Contains summary messages about files, SVCs, etc.
  • filename.aas - Contains a table of all the symbols defined in the module showing for each symbol its name, type, address, length and the file and line number of the definition; there are also entries for each SVC and MNOTE in the module.
  • filename.aaf - Contains the file number and fully qualified filename.
  • filename.aax - Contains a table showing the file and relative number of each reference to each symbol, macro, copybook, SVC and MNOTE in the module.

You can view these four files in any text editor.

Parent topic: Assembler Compiler Directives


ALLOW

Suppress error and warning messages.

Syntax:

[NO]ALLOW

Properties:

Default: ALLOW

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

The purpose of the ALLOW option is to provide compatibility with the mainframe, which does not generate error or warning messages for these cases. You may choose to use NOALLOW to improve the quality of your code. One particular benefit is that you can identify all undefined macro labels at macro compile time rather than only when a branch to a label is attempted at execution time.

Enables the following compilation behavior:

  • Allow duplicate variable definitions within macros and ignore all but the first one (that is, allow definitions in a macro that duplicate earlier definitions; whether the earlier definition is in the same macro or is a parameter it overrides the later definition).
  • Allow branches to undefined labels in AIF instructions. (Such branches cause errors during execution). Allow fullword and halfword definitions to have values enclosed in parentheses as well as single quotes; for example you can code F(D0) or F'D0'
  • Allow the instruction DROP for registers with no current USING.
  • Suppress string sublist function and return entire string; for example, &T SETC '(ABC)'(1) returns (ABC), not ABC.
  • Allow literal pool references across CSECT boundaries. This works on the PC, but on the mainframe the Assembler Linker may replace or reorder CSECTS, thereby rendering some literal pool references invalid. Under these circumstances specify NOALLOW.
  • Allow conditional assembly macro references to the length (L' operator) of symbols defined on EQU statements with no third operand that explicitly defines the length; during the macro pre-process stage the length defaults to one, but during the assembly phase it is set to its actual value, and the code generated is incorrect.
  • Issue no warning about the presence of blank lines.
  • Issue no warning about the presence of dead code, that is code that can never be executed.
  • Issue no warning about a POP instruction without a preceding PUSH.

When NOALLOW is specified, error or warning messages are issued for the above.

Parent topic: Assembler Compiler Directives


AMODE

Set the memory address type.

Syntax:

AMODE({24|31})

Parameters:

24
Use three-byte (24-bit addresses), compatible with memory below the line on the mainframe.
31
Use 31-bit addresses, compatible with memory above and below the line on the mainframe.

Properties:

Default: AMODE(31)

Build Settings:

Choose an AMODE setting from the Addressing mode list on the Assembler tab of your project properties Assembler page.

Comments:

All COBOL programs passing parameters to Assembler subroutines must be compiled with the AMODE(24) or AMODE(31) compile option themselves or a SOC5 (addressing error) abend occurs at call time. Unless they are specifically coded to accept ASCII data, Assembler subroutines expect all alphanumeric data to be EBCDIC, so the calling COBOL module should be compiled with the CHARSET(EBCDIC) option to override the default of CHARSET(ASCII).

Parent topic: Assembler Compiler Directives


ANIM

Generate .idf and .idx files required to debug an Assembler module during execution.

Syntax:

[NO]ANIM

Properties:

Default: ANIM

Build Settings:

Check Create debug information on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives
Parent topic: Assembler Linker Directives


ASM

Perform a complete compilation, that is, both pre-process macros and assemble the resulting .bal file, producing an .obj file.

Syntax:

[NO]ASM

Properties:

Default: ASM

Dependencies:

If you specify NOASM, directives BAL, NOOBJECT and NOLIST are set automatically.

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

NOASM only performs the macro pre-process stage, and it passes undefined opcodes and macros through to the .bal file. Setting NOASM is equivalent to just running the macro pre-process stage of the previous Micro Focus Assembler product, MF370. NOASM is particularly useful when you want to preprocess BMS macros to produce a file than can be input to the CICS BMS screen painter. See BMS Screen Painter for more information.

Parent topic: Assembler Compiler Directives


BAL

Create a source file (.bal) in the load library; this file contains the output from the macro pre-process stage of compilation.

Syntax:

[NO]BAL

Properties:

Default: NOBAL

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

The .bal file created is very similar but not identical to the .bal file created by the previous Micro Focus Assembler product, MF370. The files are functionally equivalent but the formatting is not identical. If you specify the LISTCALL directive, each macro call statement is included in the .bal file for cross reference purposes.

Parent topic: Assembler Compiler Directives


BALLIST

Create a listing file of the .bal file that shows each macro call and the relative byte address of each expanded macro instruction.

Syntax:

[NO]BALLIST

Properties:

Default: NOBALLIST

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

The listing file has the extension .mop. If XFLN is on, the listing also includes the relative line number of each expanded macro instruction.

This listing of the .bal file is sometimes useful for debugging large macros since it shows parameters passed to each macro and where each call was issued from. You can obtain a more detailed listing by specifying the MOPLIST directive.

Parent topic: Assembler Compiler Directives


BALWTO

Create a listing file of the .bal file that shows each macro call and the relative byte address of each expanded macro instruction, and display each line on the Output Window. Also reduces the output buffer for the .mop file to 1,000 bytes to ensure that the .mop file and the current screen between them supply a complete record of the pre-process phase in the event of a failure.

Syntax:

[NO]BALLIST

Properties:

Default: NOBALWTO

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


CACHE

Cache all access to the virtual files used during compilation. The cache is a pool of 4 kilobyte (Kb) buffers with least recently used replacement.

Syntax:

[NO]CACHE

Properties:

Default: NOCACHE

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

A new buffer is allocated for each request for file access until the pool reaches 64Kb (that is, 16 buffers). From this point, if the hit rate drops below 98%, where hit rate is the percentage of requests for data that is already in existing buffers, a request for data that is not already in existing buffers results in the allocation of a another new buffer, until a maximum of 1 megabyte (Mb) is in use. If the hit rate stays at or above 98%, a request for data that is not already in existing buffers results in the reuse of the least recently used buffer. The cache includes macro code, local and global macro variables, symbols, literals, working .bal file, working token file, and working relocation record file. You can save up to 1Mb of main memory by specifying NOCACHE, but your compilations can take longer.

Parent topic: Assembler Compiler Directives


CALL

Attempt to automatically resolve any remaining external references by repeatedly searching the load library for .obj files matching external names.

Syntax:

[NO]CALL

Properties:

Default: CALL

Build Settings:

Check Resolve external calls at link time on the Assembler tab of your project properties Assembler page.

Comments:

If the loading of these modules in turn adds additional external references, the process is repeated until there are no remaining unresolved external references or until the last pass fails to resolve any additional external references.

Error messages are issued for any unresolved external references.

Parent topic: Assembler Compiler Directives


CICS

Enables the use of the EXEC CICS preprocessor to convert the CICS commands you supply into calls to the CICS command-level API.

Syntax:

[NO]CICS

Properties:

Default: NOCICS

Build Settings:

Check EXEC CICS on the Assembler tab of your project properties Assembler page.

Comments:

If the compiler finds an EXEC CICS statement in the source, CICS is automatically specified.

See also EPILOG and PROLOG.

Parent topic: Assembler Compiler Directives


COMPATM

Force all macro parameters not in quotes to be upper case for compatibility with the previous Micro Focus Assembler product, MF370.

Syntax:

[NO]COMPATM

Properties:

Default: NOCOMPATM

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


COMPATS

Treat all sublists in macro parameters as character strings for compatibility with the previous Micro Focus Assembler product, MF370.

Syntax:

[NO]COMPATS

Properties:

Default: NOCOMPATS

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


EID2

Generate two-byte external symbol ids in object code. If you specify NOEID2, one-byte external symbol ids are generated; this format is compatible with versions of the previous Micro Focus Assembler product, MF370, before 4.0.06.

Syntax:

[NO]EID2

Properties:

Default: EID2

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


EPILOG

Insert DFHEIRET macro in the EXEC CICS code.

Syntax:

[NO]EPILOG

Properties:

Default: NOEPILOG

Dependencies:

To use EPILOG, you must also specify CICS.

Build Settings:

Check EXEC CICS on the Assembler tab of your project properties Assembler page; then check Insert standard epilog macro on the EXEC CICS Options dialog box.

Comments:

If the compiler finds an EXEC CICS statement in the source, CICS is automatically specified.

Parent topic: Assembler Compiler Directives


ESD

Include external symbol directory (ESD) records in .370 files.

Syntax:

[NO]ESD

Properties:

Default: ESD

Dependencies:

You must also set the OBJ370 directive.

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


LINK

Create a .390 file when compilation is complete, by linking in all other modules called by the main module.

Syntax:

[NO]LINK

Properties:

Default: LINK

Dependencies:

If the CALL directive is also specified, an attempt is made to resolve any remaining external references.

Build Settings:

Check Automatically link moduleon the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


LIST

Create a compilation listing in filename.prn in the output library.

Syntax:

[NO]LIST

Properties:

Default: NOLIST

Build Settings:

Check Generate listing file on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


LISTCALL

Include macro call statements with parameters in the .bal file.

Syntax:

[NO]LISTCALL

Properties:

Default: NOLISTCALL

Dependencies:

You must also set the BAL directive.

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

Macro calls are always shown on filename.prn unless suppressed by PRINT NOGEN.

Parent topic: Assembler Compiler Directives


LISTPARM

Create a trace of all macro parameters and their values (including all nested macro calls).

Syntax:

[NO]LISTPARM

Properties:

Default: NOLISTPARM

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

This trace is useful for verifying which parameter value was passed to which parameter in applications where there are many parameters. The trace is put in syslist.wto, in the project folder.

Parent topic: Assembler Compiler Directives


MACLIST

Create a macro listing in filename.prn in the output library.

Syntax:

[NO]MACLIST

Properties:

Default: NOMACLIST

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

This listing shows macro source lines with their relative byte addresses. Dead code in macros is listed with type code "DEAD" so you can scan for it.

Parent topic: Assembler Compiler Directives


MCALLS

Execute called macros during macro pre-process stage.

Syntax:

[NO]MCALLS

Properties:

Default: MCALLS

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

If you specify NOMCALLS, the macros are not executed, just expanded. You can use this option in conjunction with MPC or MPCGEN to compile macros without expanding them. To create .mpc files for all the macros in a folder just copy the folder list into a .mlc file and compile it using options MPCGEN and NOMCALLS.

Parent topic: Assembler Compiler Directives


MOPLIST

Create a detailed macro execution trace file showing each line of code executed with the name of the macro, the relative byte address, the opcode, the current variable name or macro sequence symbol name, and the current seta, setb, and setc values. The listing file has the extension .mop.

Syntax:

[NO]MOPLIST

Properties:

Default: NOMOPLIST

Dependencies:

You must also set the BALLIST directive.

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

This listing is extremely useful for debugging difficult macro execution errors. However, the output can be very large (around 50 MB); We recommend that you use this directive with some caution, preferably on reduced test cases which contain the problem.

Parent topic: Assembler Compiler Directives


MOPWTO

In addition to the functionality of MOPLIST, MOPWTO displays each line in the Output Window. It also reduces the output buffer for the .mop file to 1,000 bytes to ensure that the .mop file and the current screen between them supply a complete record of the pre-process phase in the event of a failure.

Syntax:

[NO]MOPWTO

Properties:

Default: NOMOPWTO

Dependencies:

You must also set the BALLIST directive.

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


MPC

Determines the level of macro processing.

Syntax:

[NO]MPC

Properties:

Default: NOMPC

Build Settings:

Check Use pre-assembled macros on the Assembler tab of your project properties Assembler page.

Comments:

If a valid pre-processed macro file (.mpc) is found, it is used as input to the assembly phase, and the macro pre-process phase is bypassed. If a valid .mpc file is not found or one is found but it predates the corresponding macro source file, the macro from source is compiled and saved as an .mpc file for future use.

Using .mpc files can shorten compilation time by up to 50% for large assemblies that use many complex macros.

This directive is not available on the mainframe.

The Assembler compiler does not check whether macro copybooks have changed since the .mpc file was created, so if you change macro copybooks, you should delete all .mpc files or use the MPCGEN directive to force regeneration.

Setting the MPC directive also has the effect of removing the file and relative line number information from the compilation error messages displayed and from the reports produced by setting the BALLIST, MACLIST, XMAC and XREF directives.

Parent topic: Assembler Compiler Directives


MPCGEN

Recreate new .mpc files containing compiled macro code replacing previous versions if any.

Syntax:

[NO]MPCGEN

Properties:

Default: NOMPCGEN

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

You can use MPCGEN in conjunction with MCALLS to compile entire macro library in one assembly.

Parent topic: Assembler Compiler Directives


MPCLIST

List generated macro code after each macro source line during macro pre-process phase.

Syntax:

[NO]MPCLIST

Properties:

Default: NOMPCLIST

Dependencies:

When you specify MPCLIST, MACLIST is set automatically.

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

Both MACLIST and MPCLIST show the relative byte address of each macro statement. This is unique and is the easiest way to distinguish between possible multiple instances of macro copybook code generated within a single macro.

If there is an error during the macro pre-process stage the relative byte address of the failing statement is shown to help you pinpoint error location and the point from which the macro was called.

Parent topic: Assembler Compiler Directives


OBJ370

Generate mainframe-compatible sequential fixed-block object code file, filename.370, in the load library.

Syntax:

[NO]OBJ370

Properties:

Default: NOOBJ370

Dependencies:

When you specify NOOBJECT, the OBJ370 directive is ignored and no object code output is generated.

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

If default NOOJB370 is set, then Assembler generates a compressed binary object file called filename.obj in the load library.

Parent topic: Assembler Compiler Directives


OBJECT

Generate object code in either filename.obj (default) or filename.370 format depending on current OBJ370 setting.

Syntax:

[NO]OBJECT

Properties:

Default: OBJECT

Dependencies:

When you specify NOOBJECT, the OBJ370 directive is ignored and no object code output is generated.

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


OMF

Specifies the type of output - load module or CICS data table.

Syntax:

OMF({390|MOD})

Parameters:

390
Executable format in filename.390.
MOD
Non-executable table format in filename.MOD. The file contains assembled object code with no header and no relocation data. This option is often used to create CICS tables.

Properties:

Default: OMF(390)

Build Settings:

Choose an OMF setting from the Linker output list on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


OPT

Make an extra pass of macro object code to resolve references to addresses.

Syntax:

[NO]OPT

Properties:

Default: NOOPT

Build Settings:

Check Create optimized code on the Assembler tab of your project properties Assembler page.

Comments:

If the compilation of your program involves the execution of many macros, you can reduce the total compilation time by specifying this directive.

When OPT is on, the MOPLIST and MOPWTO macro trace output does not include AGO labels or local variable symbol names since the extra pass eliminates them.

Parent topic: Assembler Compiler Directives


OLDCICS

Specify the level of the CICS preprocessor to use.

Syntax:

[NO]OLDCICS

Properties:

Default: NOOLDCICS

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

Use NOOLDCICS if you want to use the version that is compatible with IBM's CICS Transaction Server 1.3. Use OLDCICS if you want to use the previous version.

NOOLDCICS generates more efficient run-time code.

You can run programs compiled with OLDCICS with programs compiled with NOOLDCICS.

Parent topic: Assembler Compiler Directives


PLISTUB

Generate a PLI stub program in the source directory for each entry point in the Assembler module being compiled.

Syntax:

[NO]PLISTUB

Properties:

Default: NOPLISTUB

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

The name of the stub program is #nnnnnnn where nnnnnnn is the entry point name.

Use this directive where you have a PL/I application that issues calls to Assembler modules without specifying the language option ASM You must add the stub programs to the PL/I project and compile them along with the PL/I program that calls them.

Parent topic: Assembler Compiler Directives


PROLOG

Insert DFHEIENT, DFHEIEND, and DFHEISTG macros in the EXEC CICS code. You can set this directive only if you have set the CICS directive.

Syntax:

[NO]PROLOG

Properties:

Default: NOPROLOG

Build Settings:

Check EXEC CICS and Options on the Assembler tab of your project properties Assembler page; then check Insert standard prolog macros on the EXEC CICS Options dialog box.

Comments:

If the compiler finds an EXEC CICS statement in the source, CICS is automatically specified.

Parent topic: Assembler Compiler Directives


RENT

Mark module as re-entrant; this prevents reloading of the module each time it is called.

Syntax:

[NO]RENT

Properties:

Default: RENT

Build Settings:

Check Mark module as reentrant on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


REUS

Mark load module as serially reusable; this prevents reloading of the module each time it is called.

Syntax:

[NO]REUS

Properties:

Default: REUS

Build Settings:

Check Mark load module as serially reusable on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


RLD

Generate relocation records for relocatable address constants in the object code file filename.obj.

Syntax:

[NO]RLD

Properties:

Default: RLD

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


RMODE

Specify a residence mode for the load module.

Syntax:

RMODE({24|31})

Parameters:

24
Load the module into memory below the line, for compatibility with mainframe 24-bit (3-byte) addresses.
31
Load the module into memory either above or below the line, for compatibility with mainframe 31-bit (4-byte) addresses.

Properties:

Default: RMODE(31)

Build Settings:

Choose an RMODE setting from the Residency mode list on the Assembler tab of your project properties Assembler page.

Comments:

If the link process run by the Compiler detects any 24-bit address fields in the load module, it issues a warning message and automatically changes the directive to RMODE(24), while leaving the AMODE setting unchanged.

Parent topic: Assembler Compiler Directives


STATIC

Generate code from macro statements with no symbolic parameters without parsing them for parameter substitution.

Syntax:

[NO]STATIC

Properties:

Default: STATIC

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

If you specify NOSTATIC, all macro statements are parsed for parameter substitution. This directive only affects speed of compilation, and the output is identical.

Parent topic: Assembler Compiler Directives


SYSPARM

Define string to be substituted in macros for the variable symbol &SYSPARM.

Syntax:

SYSPARM(value)

Parameters:

value
A string to substitute for the &SYSPARM variable.

Properties:

Default: SYSPARM() (null string)

Build Settings:

Type a value into the $SYSPARM substitution value field on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


TOTALS

Write totals to syslist.wto showing internal statistics on macro compiles, symbol table lookups, external symbols, literals, physical file input/output, virtual file input/output, memory usage, etc.

Syntax:

[NO]TOTALS

Properties:

Default: NOTOTALS

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

The syslist.wto file is created in the project folder.

Parent topic: Assembler Compiler Directives


TRACE

Generate trace of events during compilation in syslist.wto

Syntax:

Format 1:

TRACE{5|7|8|9|#nnnnn}

Format 2:

NOTRACE

Parameters:

5
Each macro line is traced.
7
All virtual and physical input/output is traced.
8
All tokens are traced.
9
Program calls and temporary memory usage are traced.
#nnnnn
A level 9 trace for just statement nnnnn is generated.

Properties:

Default: NOTRACE

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

The traces are cumulative, and so can become voluminous.

Parent topic: Assembler Compiler Directives


UFUNC

Specify how to handle unsupported CICS functions.

Syntax:

UFUNC({A|N|E})

Parameters:

A
Issue a warning when the program is compiled and an abend at run time
N
Issue a warning when the program is compiled and treat the function as a NO-OP. User response fields are updated only if you set directive NOOLDCICS.
E
Issue an error when the program is compiled.

Properties:

Default: UFUNC(E)

Build Settings:

Check EXEC CICS and Options on the Assembler tab of your project properties Assembler page; then choose the type of handling you require from the Unsupported function handling list on the EXEC CICS Options dialog box.

Parent topic: Assembler Compiler Directives


UOPT

Specify how to handle unsupported CICS options.

Syntax:

UOPT({A|N|I|E})

Parameters:

A
Issue a warning when the program is compiled and an abend at run time
N
Issue a warning when the program is compiled and treat the function as a NO-OP. User response fields are updated only if you set directive NOOLDCICS.
I
Issue a warning when the program is compiled and ignore the option at run time.
E
Issue an error when the program is compiled.

Properties:

Default: UOPT(E)

Build Settings:

Check EXEC CICS and Options on the Assembler tab of your project properties Assembler page; then choose the type of handling you require from the Unsupported option handling list on the EXEC CICS Options dialog box.

Parent topic: Assembler Compiler Directives


VSECOMP

Set a macro variable that allows the Studio Enterprise Edition Assembler implementation to correctly interpret DOS/VSE macro operands where these differ from their MVS counterparts.

Syntax:

[NO]VSECOMP

Properties:

Default: NOVSECOMP

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


XMAC

Include a cross-reference listing in filename.prn for all macros and copybooks showing the relative line numbers of the generated statements.

Syntax:

[NO]XMAC

Properties:

Default: NOXMAC

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

If you also specify the XFLN directive, the cross-reference listing shows the file and relative line numbers of the original statements that reference the macros and copybooks.

Parent topic: Assembler Compiler Directives


XREF

Include a cross-reference listing in filename.prn for all labels and literals showing the relative line numbers of the generated statements.

Syntax:

[NO]XREF

Properties:

Default: NOXREF

Build Settings:

Check Include cross-reference listing on the Assembler tab of your project properties Assembler page.

Comments:

If you also specify the XFLN directive, the cross-reference listing shows the file and relative line numbers of the original statements that reference the labels and literals, in addition to the numbers of the generated statements.

Parent topic: Assembler Compiler Directives


XSVC

Include an entry for each SVC in the module in filename.prn in a cross-reference table that shows the relative line numbers of all the statements that reference that SVC.

Syntax:

[NO]XSVC

Properties:

Default: NOXSVC

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Parent topic: Assembler Compiler Directives


Assembler Linker Directives

You can specify Assembler Linker directives on the command line when building from the command line, or in your project properties when building from the IDE.

Note: Take care when setting compiler directives in the Additional Directives field on the Linker tab of your project properties Assembler page as these could conflict with a default setting.
  • AMODE
    Set the memory address type.
  • ANIM
    Generate .idf and .idx files required to debug an Assembler module during execution.
  • ASM
    Specify the Assembler language.
  • AUTOALIAS
    Create entries in the mfentmap.dat file for all entry points in all included Assembler modules.
  • CALL
    Attempt to automatically resolve any remaining external references by repeatedly searching the load library for .obj files matching external names.
  • COMPOSITE
    Do not automatically include the main module in the executable program file.
  • EXPORT
    Export all CSECT names and entry names so that COBOL modules can call them at run time (using LOAD and BALR instructions).
  • LIST
    Create a listing of the CSECTs in filename.390 with their addresses relative to the beginning of the program, entry points, and external cross references in filename.lst in the listing library.
  • NONCAN
    Mark the filename.390 file as re-entrant and non-cancel; this prevents it from being removed from storage at the end of execution, even if it is executed from IMS or CICS.
  • OMF
    Specifies the type of output - load module or CICS data table.
  • RENT
    Mark the filename.390 file as re-entrant; this prevents reloading of the module each time it is called.
  • REUS
    Mark load module as serially reusable; this prevents reloading of the module each time it is called.
  • RMODE
    Specify a residence mode for the load module.
  • TRACE
    Display trace of Assembler Linker execution to aid in debugging linking problems.
Parent topic: Assembler Reference


AMODE

Set the memory address type.

Syntax:

AMODE({24|31})

Parameters:

24
Use three-byte (24-bit addresses), compatible with memory below the line on the mainframe.
31
Use 31-bit addresses, compatible with memory above and below the line on the mainframe.

Properties:

Default: AMODE(31)

Build Settings:

Choose an AMODE setting from the Addressing mode list on the Linker tab of your project properties Assembler page.

Parent topic: Assembler Linker Directives


ASM

Specify the Assembler language.

Syntax:

[NO]ASM

Properties:

Default: ASM

Build Settings:

Type directly into the Additional Directives field on the Assembler tab of your project properties Assembler page.

Comments:

Directives ASM and PLI are alternatives to one another.

Parent topic: Assembler Linker Directives


AUTOALIAS

Create entries in the mfentmap.dat file for all entry points in all included Assembler modules.

Syntax:

[NO]AUTOALIAS

Properties:

Default: NOAUTOALIAS

Build Settings:

Type directly into the Additional Directives field on the Linker tab of your project properties Assembler page.

Parent topic: Assembler Linker Directives


CALL

Attempt to automatically resolve any remaining external references by repeatedly searching the load library for .obj files matching external names.

Syntax:

[NO]CALL

Properties:

Default: CALL

Build Settings:

Check Resolve external calls at link time on the Linker tab of your project properties Assembler page.

Comments:

If the loading of these modules in turn adds additional external references, the process is repeated until there are no remaining unresolved external references or until the last pass fails to resolve any additional external references.

Error messages are issued for any unresolved external references.

Parent topic: Assembler Linker Directives


COMPOSITE

Do not automatically include the main module in the executable program file.

Syntax:

[NO]COMPOSITE

Properties:

Default: NOCOMPOSITE

Dependencies:

When this option is specified, you must add an INCLUDE statement for the main module to the link file.

Build Settings:

Type directly into the Additional Directives field on the Linker tab of your project properties Assembler page.

Parent topic: Assembler Linker Directives


EXPORT

Export all CSECT names and entry names so that COBOL modules can call them at run time (using LOAD and BALR instructions).

Syntax:

[NO]EXPORT

Properties:

Default: EXPORT

Build Settings:

Type directly into the Additional Directives field on the Linker tab of your project properties Assembler page.

Comments:

Specify NOEXPORT if there are names in statically linked modules that match names in dynamically linked modules, and the dynamically linked modules are to be executed. When NOEXPORT is specified, only entry names specified on ALIAS link file commands are exported.

Parent topic: Assembler Linker Directives


LIST

Create a listing of the CSECTs in filename.390 with their addresses relative to the beginning of the program, entry points, and external cross references in filename.lst in the listing library.

Syntax:

[NO]LIST

Properties:

Default: NOLIST

Build Settings:

Check Generate listing file on the Linker tab of your project properties Assembler page.

Comments:

The actual load address of each CSECT is determined at load time and all address constants are then updated.

Parent topic: Assembler Linker Directives


NONCAN

Mark the filename.390 file as re-entrant and non-cancel; this prevents it from being removed from storage at the end of execution, even if it is executed from IMS or CICS.

Syntax:

[NO]NONCAN

Properties:

Default: NONONCAN

Build Settings:

Type directly into the Additional Directives field on the Linker tab of your project properties Assembler page.

Parent topic: Assembler Linker Directives


OMF

Specifies the type of output - load module or CICS data table.

Syntax:

OMF({390|MOD})

Parameters:

390
Executable format in filename.390.
MOD
Non-executable table format in filename.MOD. The file contains assembled object code with no header and no relocation data. This option is often used to create CICS tables.

Properties:

Default: OMF(390)

Build Settings:

Choose an OMF setting from the Linker output list on the Linker tab of your project properties Assembler page.

Parent topic: Assembler Linker Directives


RENT

Mark the filename.390 file as re-entrant; this prevents reloading of the module each time it is called.

Syntax:

[NO]RENT

Properties:

Default: RENT

Build Settings:

Check Mark load module as reentrant on the Linker tab of your project properties Assembler page.

Parent topic: Assembler Linker Directives


REUS

Mark load module as serially reusable; this prevents reloading of the module each time it is called.

Syntax:

[NO]REUS

Properties:

Default: REUS

Build Settings:

Check Mark load module as serially reusable on the Linker tab of your project properties Assembler page.

Parent topic: Assembler Linker Directives


RMODE

Specify a residence mode for the load module.

Syntax:

RMODE({24|31})

Parameters:

24
Load the module into memory below the line, for compatibility with mainframe 24-bit (3-byte) addresses.
31
Load the module into memory either above or below the line, for compatibility with mainframe 31-bit (4-byte) addresses.

Properties:

Default: RMODE(31)

Build Settings:

Choose an RMODE setting from the Residency mode list on the Linker tab of your project properties Assembler page.

Comments:

If the link process run by the Compiler detects any 24-bit address fields in the load module, it issues a warning message and automatically changes the directive to RMODE(24), while leaving the AMODE setting unchanged.

Parent topic: Assembler Linker Directives


TRACE

Display trace of Assembler Linker execution to aid in debugging linking problems.

Syntax:

[NO]TRACE

Properties:

Default: NOTRACE

Build Settings:

Type directly into the Additional Directives field on the Linker tab of your project properties Assembler page.

Comments:

The information displayed includes an external symbol dictionary (ESD) table, information about each ESD type entry in the load module, information about each pass made by the linker while attempting to resolve undefined external CALLs, and information about each relocation address generated to allow the module to be loaded at any location in memory.

Parent topic: Assembler Linker Directives


Assembler Link Files

Describes the format and usage of .lin files containing linker commands.

The Assembler linker takes commands from both the linker command line and also an optional linker input file with the extension .lin. The commands contained in the .lin file tell the linker what to include in the executable file, and the filename and other properties of the executable output file. By default, the assembler linker input file exists in the same directory as the Assembler .obj files. The linker looks first for a .lin, and if found, processes it before any found .obj files.

For example, if the Assembler object filename is test.obj, you can write a linker input file called test.lin and specify the following include commands:
// INCLUDE TEST2.OBJ
// INCLUDE TEST3.OBJ
// INCLUDE TEST4.OBJ

The resulting .390 executable module has four assembler modules linked into it.

A common usage of the linker command is to specify which entry points are actually in COBOL modules. Take the following example:
// INCLUDE TEST2.OBJ
// INCLUDE TEST3.OBJ,TYPE=CBL

In this example, TEST3 is an external symbol in a COBOL module. The linker does not look for test.obj. Instead the linker generates a small stub Assembler module so that if the TEST3 entry point is ever branched to by an Assembler module, a transfer of control is be done to give the COBOL TEST3 module control.

Parent topic: Assembler Reference


Assembler Link File Commands

In the link file command descriptions, square brackets, "[]", indicate optional parameters that can be omitted, braces, "{}", indicate parameters of which at least one must be selected, "{}..." indicates parameters that can be repeated, and vertical bars, "|", indicate alternative parameters of which no more than one can be selected.

Assembler link file command usually have the extension .LIN and can have optional slashes put in front of the commands, for example:

// include asm1.obj
// include cob1,type=CBL

Comments may be placed in the file by preceding them, either with a semicolon as follows:

// include asm1.obj   ; main assembler entry point comment

Or by placing an asterick character in column one as follows:

*this is the main assembler entry point
// include asm1.obj

The link file commands can start anywhere after the first column.

  • ALIAS Link File Command
    Creates an entry in the mfentmap.dat file to allow the load module (filename.390) to be called by an alternate name.
  • CHANGE Link File Command
    Provides compatibility with the IBM binder that replaces the IBM linkage editor. However, the Studio Enterprise Edition Assembler implementation emulates the linkage editor, not the binder.
  • ENTRY Link File Command
    Specifies an entry point for the load module (.390 file), where its external name is not the entry point.
  • INCLUDE Link File Command
    Specifies an object file to be linked into the executable file.
  • Name Link File Command
    Specifies a name for the load module.
Parent topic: Assembler Reference


ALIAS Link File Command

Creates an entry in the mfentmap.dat file to allow the load module (filename.390) to be called by an alternate name.

Syntax:

ALIAS aliasname

Parameters:

aliasname
The alternate name to be used to call the load module.

Comments:

The ALIAS command can start anywhere after the first column.

Parent topic: Assembler Link File Commands


CHANGE Link File Command

Provides compatibility with the IBM binder that replaces the IBM linkage editor. However, the Studio Enterprise Edition Assembler implementation emulates the linkage editor, not the binder.

Syntax:

CHANGE {oldname(newname),}...

Parameters:

oldname
The external symbol to be changed.
newname
The new name to which the external symbol is to be changed.

Comments:

You can repeat the parameters to change multiple external symbols. Continuation lines are not accepted, so use multiple CHANGE commands if you have more entries than will fit on one line.

If you want to change external symbols in the main module, use the COMPOSITE linker directive to suppress the automatic inclusion of the main module, then specify your CHANGE commands followed by an INCLUDE command for the main module.

Parent topic: Assembler Link File Commands


ENTRY Link File Command

Specifies an entry point for the load module (.390 file), where its external name is not the entry point.

Syntax:

ENTRY esdname

Parameters:

esdname
The name of the entry point for the load module.

Comments:

The ENTRY command can start anywhere after the first column.

Parent topic: Assembler Link File Commands


INCLUDE Link File Command

Specifies an object file to be linked into the executable file.

Syntax:

INCLUDE SYSLIB(filename),[TYPE={ASM|CBL}],[PARMS={VL|IMS|nnn}]

Parameters:

SYSLIB(filename)
Module to include.
TYPE
Module type. Optional. Default: ASM
ASM | Assembler object module (.obj)
CBL | COBOL module (.int or .gnt)
PARMS
Parameter processing. Required only when TYPE=CBL and register 0 is not available for passing the number of parameters.
VL | Scan for high bit in last parameter address to determine number of parameters.
IMS | Check first parameter for full-word integer value between 1 and 19. If found, set parameter count to value + 1. If not found, perform VL scan of up to 19 parameters including null parameters. Set parameter count to 19 if no VL bit found.
nnn | Set parameter count to specific value.

Comments:

The INCLUDE command can start anywhere after the first column.

If TYPE=CBL, you must either specify the PARMS parameter, or pass the number of parameters in register 0, using the high byte of the register to indicate the method. A value of h"00" indicates that the number of parameters is in the bottom 24 bits of register 0. A value of h"80" is equivalent to PARMS=VL, and a value of h"40' is equivalent to PARMS=IMS.

Parent topic: Assembler Link File Commands


Name Link File Command

Specifies a name for the load module.

Syntax:

NAME filename (R)

Parameters:

SYSLIB(filename)
Module to include.
(R)
Replace the load module if it already exists (optional). If you do not specify R and the load module already exists, it is not replaced.

Comments:

The NAME command can start anywhere after the first column.

If omitted, the name is the same as the name of the source module, with the extension .390.

Parent topic: Assembler Link File Commands


Macros and SVCs

Assembler support incorporates a number of macros and SVCs (supervisor calls). Those that are supported are, in general, not compatible with the equivalent macros and SVCs on the mainframe, so wherever possible, use macros to get the desired SVC function.

Some macro options are not fully supported in that they do compile, but have no effect when executed. There are also some macros which are supported in stub form, that is, macro code exists but it simply returns control to the calling program. These stubs are provided for macros that perform tasks that have no meaning on the PC. An example stub macro is provided in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\include\stub.mac; you can use this to create your own stub macros.

There are two categories of macro:

  • Assembler services macros. These provide services for interfacing with the Assembler run-time system, managing memory, calling other programs and for general functions such as saving and restoring registers. There are also services for accessing the catalog and for dynamically allocating and deallocating data sets at execution time.
  • File handling macros. These provide access to files.

Many Assembler services macros equate to SVCs. You can choose whether to code the macro or its equivalent SVC, but in general it is easier to use the macros. The following table relates the SVCs and service macros:

SVC | Macro | Description
4 | GETMAIN L LC LU E EC EU, VC, VU | Get memory (list, element and variable requests).
5 | FREEMAIN L LC LU E EC EU, VC, VU | Free memory (list, element and variable requests).
6 | LINK | Link to another Assembler program.
8 | LOAD | Load another Assembler program or a COBOL program.
9 | DELETE | Delete a loaded module.
10 | GETMAIN R | Get memory (R type register requests).
11 | TIME | Get the time of day and the date.
13 | ABEND | Terminate the program and open the Assembler debugger if possible, or display information about the state of the program when the abend occurred.
14 | SPIE | Handle a program exception within the executing module.
26 | CATALOG and LOCATE | Uncatalog a data set; return a volume list for a data set.
29 | SCRATCH | Delete a data set.
35 | WTO WTOR | Display a message on the screen. Display a message on the screen and wait for a reply.
39 | LINKC2 | Link to a COBOL program.
41 | IDENTIFY | Associate a name you specify with an already loaded program.
62 |  | Remove the executing program. There is no corresponding macro.
99 | DYNALLOC | Allocate or deallocate a resource at execution time.
103 | XLATE | Convert between ANSI and EBCDIC.
120 | GETMAIN RU, RC, VRC, VRU; FREEMAIN R, RU, RC, VRC and VRU; STORAGE | Get memory (RU and RC type register requests) Free memory (all types of register requests). Get memory or free memory
 | CALL | Transfer control to a statically linked module. There is no corresponding SVC.
 | CAMLST | Create parameter list for CATALOG, LOCATE or SCRATCH. There is no corresponding SVC.
 | DEQ | Relinquish control of one or more serially reusable resources. There is no corresponding SVC.
 | ENQ | Request control of one or more serially reusable resources. There is no corresponding SVC.
 | EXTRACT | Obtain information from control block. There is no corresponding SVC.
 | RETURN | Restore registers and sets the address to return to. There is no corresponding SVC.
 | SAVE | Save registers. There is no corresponding SVC.
 | SPLEVEL | Test or set the level of MVS macro compatibility. There is no corresponding SVC.
 | WAIT | Wait for event completion. There is no corresponding SVC.
  • Macro Instructions
  • Supervisor Services (SVCs)
Parent topic: Assembler Reference


Macro Instructions

The following topics contain information on macro instructions.

  • MVS Macro Instructions
  • DOS/VSE Macro Instructions
Parent topic: Macros and SVCs


MVS Macro Instructions

The MVS macro instructions supported for Assembler are divided into the groups described below. Please select the group you require.

  • Assembler services macro instructions. These provide services for interfacing with the Assembler run-time system, managing memory, calling other programs and performing general functions such as saving and restoring registers.
  • File handling macro instructions. These provide access to files.
The descriptions of the macros provided in this online help are intended just to remind you of their purpose and use. For full descriptions and background information you need to consult the IBM manuals:
  • OS/390 MVS Assembler Services Reference SC26-8265
  • OS/390 MVS Macro Instructions for Data Sets SA22-7201

The conventions used in the macro specifications are explained in the Key to Macro Instructions help topic.

Many macros are available in list and execute forms as well as the standard form. Some of the file handling macros are also available in generate form. The help topic for each macro states which other forms are available in addition to the standard form. The help topic for WTO provides syntax and examples for list and execute forms.

We provide stubs for some macros that perform no useful function on the PC. The stub code simply returns control to the calling program. The stub macros are as follows:

AMODE

FREEPOOL

MODESET

RMODE

There are no help topics for these macros.

Parent topic: Macro Instructions


DOS/VSE Macro Instructions

Studio Enterprise Edition Assembler support includes many DOS/VSE macros, essentially by mapping DOS/VSE functions onto MVS functions. The VSECOMP Assembler Compiler directive allows Assembler Option to correctly interpret DOS/VSE macro operands where these differ from their MVS counterparts.

DOS/VSE-specific macros other than those listed above are not supported.

For more information, please consult the IBM manual VSE/ESA System Macros Reference SC33-6516.

  • Macros That Require VSECOMP Directive
  • Macros Common with MVS
  • DOS/VSE-specific Macros
Parent topic: Macro Instructions


Macros That Require VSECOMP Directive

The following DOS/VSE macros require the use of the VSECOMP directive to ensure that their operands are interpreted correctly:

  • CLOSE
  • GET
  • LOAD
  • OPEN
  • PUT
Parent topic: DOS/VSE Macro Instructions


CLOSE

[label] CLOSE (address[,(options)],...)

[,MODE=24|31]

Parameters

address
The address of the ACB or DCB for each file to close.
MODE=24|31
For QSAM and BSAM files, specifies whether the program is running in 24-bit or 31-bit mode. No effect for VSAM files.

Comments

Closes an active VSAM, BSAM or QSAM file or files at execution time.

List and execute forms are also available.

If the VSECOMP compiler directive is specified, Studio Enterprise Edition Assembler support includes emulating the DOS/VSE version of this macro. In this case the expanded code is larger than that produced on the mainframe and may cause NO BASE REGISTER error messages. The unusual DOS/VSE register conventions for register 1 are also supported, so syntax of the form CLOSE (1) is accepted. However, the multiple operand syntax of the DOS/VSE CLOSE macro is not supported, so use the MVS syntax instead.

The DOS/VSE-specific macro CLOSER (Close a File Relocatable) is simply mapped to the standard CLOSE macro. Self-relocating code is not generated as it would be under the DOS/VSE environment so modules using CLOSER cannot be relocated at execution time by simply copying the generated machine code from one address to another.

CLOSE VSAMFILE
Parent topic: Macros That Require VSECOMP Directive


GET

[label] GET RPL=address|dcb-address,[area-address]

Parameters

RPL=address
RPL to use with a VSAM GET request.
dcb-address
Data control block to use with a QSAM GET request.
area-address
Address of the area to hold the record read from the QSAM file.

Comments

Retrieves a record from a VSAM or QSAM file.

If the VSECOMP compiler directive is specified, Studio Enterprise Edition Assembler support includes emulating the DOS/VSE version of this macro. In this case the expanded code is larger than that produced on the mainframe and may cause NO BASE REGISTER error messages. The unusual DOS/VSE register conventions for register 1 and 0 are also supported, so syntax of the form GET (1) or GET (1)(0) is accepted.

A utility macro SADV (Save Address Value) used by GET expands slightly differently when VSECOMP is specified. Normally, SADV expands to LA register,dcb-address. With VSECOMP specified the instruction L register,=A(dtf-address) is produced instead.

Examples

GET RPL=INRPL

GET INFILE,RECORD

Parent topic: Macros That Require VSECOMP Directive


LOAD

[label] LOAD EP=program-name|EPLOC=program-address|DE=list-entry-addr

[,DCB=dcb-addr]

[,ERRET=err-rtn-addr]

[,LSEARCH=NO|YES]

[,LOADPT=addr]

[,RELATED=value]

Parameters

EP= program-name
Name of the program to be loaded, up to a maximum of eight characters. A file extension is not required; the LOAD routine first attempts to load a file with the extension .390 and then a file with the extension .mod. If it fails to find either, it generates a stub Assembler program that loads and links to a COBOL program called program-name.
EPLOC= program-address
Name of the data element that contains the address of the program name.
ERRET=err-rtn-addr
The address of an exit to receive control when an error condition is detected. err-rtn-addr is an A-type address or register (2) through (12).
LOADPT=addr
The starting address at which the program was loaded. addr is an A-type address or register (2) through (12).

Comments

Loads the specified program into memory.

Assembler LOADs:

The LOAD macro loads the program in memory above or below the line depending on its RMODE setting. At the completion of the LOAD, register 15 has a binary value of zero, register 0 has the address of where the program was loaded, register 1 contains the length of the program, and the high order bit of register 0 is set to indicate the AMODE setting of the loaded program, as follows:

0=AMODE(24)

1=AMODE(31)

COBOL LOADs:

The LOAD macro loads the stub Assembler program below the line. When the stub Assembler program is executed, it loads the COBOL program above or below the line depending on its AMODE setting; a COBOL program's Working-Storage Section may be loaded separately if the program's DATA directive does not match its AMODE directive. If an AMODE(31) Assembler program LOADs an AMODE(24) COBOL program, then an 0C5 abend occurs at the time the stub code is executed, since the 31-bit Assembler parameter addresses cannot be successfully passed to the 24-bit COBOL program.

DOS/VSE compatibility:

If the VSECOMP compiler directive is specified, Studio Enterprise Edition Assembler support includes emulating the DOS/VSE version of this macro. In this case the first positional parameter is the name of a program to load (the EP keyword is not required). At the completion of the LOAD, register 1 has the address of where the program was loaded, with the high order bit set to indicate the AMODE setting of the loaded program.

Examples

LOAD EP=MYPROG

LOAD  EPLOC=PNAME
    PNAME    DC    CL8'MYPROG'
Parent topic: Macros That Require VSECOMP Directive


OPEN

[label] OPEN (address[,INPUT|OUTPUT|UPDAT|EXTEND],...)

[,MODE=24|31]

Parameters

address
Address of an ACB or DCB associated with the file to be activated.
INPUT|OUTPUT |UPDAT|EXTEND
These options are specified for QSAM and BSAM files only and indicate the type of processing to be enabled for the opened file. Option UPDAT is not available for BSAM files. Options specified for VSAM files are ignored.
MODE=24|31
For QSAM and BSAM files, specifies whether the program is running in 24-bit or 31-bit mode. No effect for VSAM files.

Comments

Opens a QSAM, BSAM or VSAM file or files for file handling.

List and execute forms are also available.

If the VSECOMP compiler directive is specified, Studio Enterprise Edition Assembler support includes emulating the DOS/VSE version of this macro. In this case the expanded code is larger than that produced on the mainframe and may cause NO BASE REGISTER error messages. The unusual DOS/VSE register conventions for register 1 are also supported so syntax of the form OPEN (1) is accepted. However, the multiple operand syntax of the DOS/VSE OPEN macro is not supported, so use the MVS syntax instead.

The DOS/VSE-specific macro OPENR (Open a File Relocatable) is simply mapped to the standard OPEN macro. Self-relocating code is not generated as it would be under the DOS/VSE environment so modules using OPENR cannot be relocated at execution time by simply copying the generated machine code from one address to another.

Example

OPEN (INDCB,(OUTPUT))

OPEN ((2))

Parent topic: Macros That Require VSECOMP Directive


PUT

[label] PUT RPL=address|dcb-address,[area-address]

Parameters

RPL=address
Request parameter list to use for writing to a VSAM file.
dcb-address
Data control block to use for writing to a QSAM file.
area-address
Address of the record to be written to a QSAM file.

Comments

Writes a data record to an open QSAM or VSAM file.

If the VSECOMP compiler directive is specified, Studio Enterprise Edition Assembler emulates the DOS/VSE version of this macro. In this case the expanded code is larger than that produced on the mainframe and may cause NO BASE REGISTER error messages. The unusual DOS/VSE register conventions for register 1 and 0 are also supported, so syntax of the form PUT (1) or PUT (1)(0) is accepted.

A utility macro SADV (Save Address Value) used by PUT expands slightly differently when VSECOMP is specified. Normally, SADV expands to LA register,dcb-address. With VSECOMP specified the instruction L register,=A(dtf-address) is produced instead.

Example

PUT RPL=OUTRPL

PUT OUTDCB,RECORD

Parent topic: Macros That Require VSECOMP Directive


Macros Common with MVS

The following DOS/VSE macros are common with MVS:

  • CALL DOS/VSE Macro
  • DEQ
  • ENQ
  • EXTRACT
  • READ
  • RETURN
    Enter a short description of your reference here (optional).
  • SAVE
  • WTO
  • WTOR
Parent topic: DOS/VSE Macro Instructions


CALL DOS/VSE Macro

[label] CALL progname

,(parm01,parm02,...)

[,VL]

[,ID=id-number]

Parameters

progname
Name of the CSECT to be called.
parm01,parm02
Names of the parameters that will be used to create a parameter address list for loading into register 1.
VL
Cause the high-order bit of the address of the last parameter to be set on; include this if the CSECT can be passed a variable number of parameters.
ID=id-number
Generate a NOP branch instruction with the id-number in the low order 12 bits. The purpose of this is to enable you to identify each call uniquely during debugging. Id-number can be a value between 0 and 4095.

Comments

Passes control to another program.

Examples

CALL MYPROG

CALL MYPROG,(PARM1,PARM2,PARM3),VL

Parent topic: Macros Common with MVS


DEQ

[label] DEQ (qname-addr

,rname-addr

,[rname-length]

,[STEP|SYSTEM|SYSTEMS])

[,LOC=BELOW|ANY]

[,RET=HAVE|NONE]

[,RNL=YES|NO]

[,RELATED=value]

[,UCB=ucb-address]

Parameters

qname-addr
Address of major resource name. The name may contain up to 8 characters.
rname-addr
Address of minor resource name. The name may contain up to 255 characters. The first byte must contain the length if rname-length is 0.
rname-length
Length of rname, between 0 and 255. 0 indicates that the length is in the first byte of rname. If omitted the assembled rname label length is used.
STEP|SYSTEM |SYSTEMS
Defines the scope of the request:

STEP=This job step only (default)

SYSTEM=This system only

SYSTEMS=Multiple systems

RET=HAVE |NONE
Type of resource request:

HAVE=Request now if not previously requested

NONE=Request unconditionally (default)

RNL=YES|NO
YES requests that global resource serialization perform resource name list (RNL) processing, which can cause the scope value of a resource to change.
RELATED= value
Specifies where related documentary text is located.

List and execute forms are also available.

Comments

Relinquishes control of one or more serially reusable resources.

The first four parameters (qname-addr through STEP|SYSTEM|SYSTEMS) may be repeated to specify multiple requests, up to a limit of 255 characters.

The final five parameters (LOC through UCB) apply to all the requests specified.

Example

DEQ (MAJOR1,MINOR1,,SYSTEM)

This example relinquishes ownership of one resource. The length of the minor resource name defaults to the assembled length.

DEQ (MAJOR2,MINOR2,12,,MAJOR3,MINOR3,,)RET=HAVE,RNL=NO

This example relinquishes ownership of two resources. The length of the second minor resource name defaults to the assembled length. The scope of both requests defaults to this job step only. Both requests are implemented only if the resources are immediately available. The requests are subject to resource name list processing.

Parent topic: Macros Common with MVS


ENQ

[label] ENQ (qname-addr

,rname-addr

,E|S

[,rname-length]

[,{STEP|SYSTEM|SYSTEMS}])

[,RET=CHNG|HAVE|TEST|USE|NONE]

[,RNL=YES|NO]

[,RELATED=value]

Requests control of one or more serially reusable resources.

List and execute forms are also available.

Parameters

qname-addr
Address of major resource name. The name may contain up to 8 characters.
rname-addr
Address of minor resource name. The name may contain up to 255 characters. The first byte must contain the length if rname-length is 0.
E|S E
indicates exclusive ownership. S indicates shared ownership.
rname-length
Length of rname, between 0 and 255. 0 indicates that the length is in the first byte of rname. If omitted the assembled rname label length is used.
STEP|SYSTEM |SYSTEMS

Defines the scope of the request:

STEP=This job step only (default)

SYSTEM=This system only

SYSTEMS=Multiple systems

RET=CHNG| HAVE|TEST| USE|NONE

Type of resource request:

CHNG=Change from shared to exclusive

HAVE=Request now if not previously requested

TEST=Test if available

USE=Request if immediately available. Program continues if not available.

NONE=Request unconditionally (default). Program waits.

RNL=YES|NO
YES requests that global resource serialization perform resource name list (RNL) processing, which can cause the scope value of a resource to change.
RELATED= value
Specifies where related documentary text is located.

Comments

The first five parameters (qname-addr through STEP|SYSTEM|SYSTEMS) may be repeated to specify multiple requests, up to a limit of 255 characters.

The final three parameters (RET through RELATED) apply to all the requests specified.

Examples

Example 1:

ENQ (MAJOR1,MINOR1,E,,SYSTEM)

This example requests exclusive ownership of one resource. The length of the minor resource name defaults to the assembled length.

Example 2:

ENQ (MAJOR2,MINOR2,E,12,,MAJOR3,MINOR3,S,,)RET=USE,RNL=YES

Parent topic: Macros Common with MVS


EXTRACT

[label] EXTRACT answer-addr

[,tcb-addr]

,FIELDS=(tcb-info)

Parameters

answer-addr
The address of the answer area to contain the requested information. A-type address or register (2) through (12).
tcb-info
The task control block information requested. The only currently supported value is FIELDS=(TIOT).

Comments

Causes the system to provide information from specified fields of the task control block or a subsidiary control block for either the active task or one of its subtasks.

Example

EXTRACT ANSADDR,FIELDS=(TIOT)

Parent topic: Macros Common with MVS


READ

[label] READ decb

,SF|SB

,dcb-address

,area-address

[,length|'S']

Parameters

decb
Label to use for generated data event control block.
dcb-address
Address of DCB for file to read.
area-address
Address of buffer to receive data.
length|'S'
Number of bytes to transfer or 'S' to indicate entire block should be read (default). The single quote marks around the S are required.

The format of the data event control block is as follows:

Bytes | Contains
0-3 | Full word of zeroes.
4 | Type flag: x'80' if 'S' parameter used in macro else x'00'.
5 | Subtype flag: always x'20'.
6 - 7 | Two-byte binary field set to value of the length parameter unless 'S' specified or register notation used in which case the field will be set to 0.
8 - 11 | Address of DCB.
12 - 15 | Address of area to receive data.

Comments

Causes one block of a BSAM file to be transferred from a file to a buffer in memory. The user program is responsible for any deblocking or other processing that may be required if the block contains more than one logical record.

The data event control block (DECB) generated by the macro is mainframe-compatible, however, each READ operation is synchronous, that is, control is not returned to the calling program until the operation is complete.

Input/output parameter blocks are not generated or used.

Examples

Example 1:

QREAD READ INDECB,SF,INFILE,INBUF,'S'

This example reads one entire block from file identified by the open DCB at INFILE into a buffer identified by INBUF.

Example 2:

READ RDECB5,SF,(*,FILEADDR),(3)

This example reads one block from DCB identified by the indirect S type address constant (*,FILEADDR) into the buffer whose address is held in register 3.

Parent topic: Macros Common with MVS


RETURN

[label] RETURN (lit1,lit2)

,[T]

,RC=n|(n)

Parameters

(lit1,lit2)
T
Causes the control program to flag the save area used by the calling program.
RC=n
Sets the return code to the numeric value specified by n.
RC=(n)
Numeric values from 0 through 15 that specify the from and to registers to restore from the register save area. This area is normally pointed to by register 13.

Comments

Sets the return code to the numeric value in register n.

Restores the specified registers and returns to the calling program.

lit1 is the first register to restore. lit2 is the last register to restore. lit1 and lit2 must be values between 0 and 15. If lit1 is greater than lit2 then the registers saved are lit1 through 15 and 0 through lit2. However, register 15 is never restored, because it is always used to hold the return code.

If the calling program is in Assembler the return code is available in register 15. If the calling program is in COBOL, the return code is available in RETURN-CODE.

Examples

Example 1

RETURN (14,12)

Restores the contents of registers 14 and 0 through 12 from the register save area specified in register 13.

Example 2

RETURN (14,12),,RC=0

Restores the contents of registers 14 and 0 through12 and sets the return code (and hence register 15) to zero.

Example 3

RETURN (14,12),,RC=(15)

Restores the contents of register 14 and 0 through 12 and sets the return code to the current value of register 15.

Parent topic: Macros Common with MVS


SAVE

[label] SAVE (lit1,lit2)

,[T]

,id-name

Parameters

(lit1,lit2)
Numeric values from 0 through 15 that specify the from and to registers to save into the register save area. This area is normally pointed to by register 13.
T
Specifies that registers 14 and 15 are to be stored in word 4 and 5, respectively, of the save area.
Id-name
Specifies an identifier to be associated with the SAVE macro. If an asterisk (*) is coded, the identifier is the label associated with the SAVE macro, or, if the label field is blank, the control section name is used.

Comments

Saves the specified general-purpose registers.

lit1 is the first register to save. lit2 is the last register to save. lit1 and lit2 must be values between 0 and 15. If lit1 is greater than lit2 then the registers saved are lit1 through 15 and 0 through lit2.

Examples

SAVE (14,12)

Saves the contents of registers 14 through 15 and 0 through 12 to the register save area specified by register 13.

Parent topic: Macros Common with MVS


WTO

Standard Form:

[label] WTO 'message'|('text',line-type)|TEXT=(text-addr,line-type)

[,ROUTCDE=]

[,MCSFLAG=]

[,DESC=]

[,CART=]

[,KEY=]

[,TOKEN=]

[,CONSID=]

[,CONSNAME=]

Execute Form:

[label] WTO TEXT=(text-addr,line-type)

[,ROUTCDE=]

[,MCSFLAG=]

[,DESC=]

[,CART=]

[,KEY=]

[,TOKEN=]

[,CONSID=]

[,CONSNAME=]

,MF=(E,label1)

List Form:

[label1] WTO 'message'|('text',line-type)|TEXT=(text-addr,line-type)

[,ROUTCDE=]

[,MCSFLAG=]

[,DESC=]

[,CART=]

[,KEY=]

[,TOKEN=]

[,CONSID=]

[,CONSNAME=]

,MF=L

Parameters

message
Message text to be displayed. It must be in quotes.
text
Message text to be displayed. It must be in quotes.
text-area
Address of message text to be displayed
label1
Label of either list form WTO instruction or parameter block

Comments

Examples

Example 1

WTO 'THIS IS A SIMPLE WTO MACRO INSTRUCTION'

Example 2

WTO MF=(E,MESSAGE)

MESSAGE WTO 'THIS IS A WTO-LIST MESSAGE',MF=L

Example 3

WTO MF=(E,MESSAGE)

MESSAGE EQU *

DC H'84' MESSAGE LENGTH PLUS 4

DC H'0'

DC CL80'THIS IS MY MESSAGE'

Parent topic: Macros Common with MVS


WTOR

[label] WTOR 'message'|('text',line-type)|TEXT=(text-addr,line-type)

,reply

,reply-length

,ecb-addr

[,ROUTCDE=]

[,MCSFLAG=]

[,DESC=]

[,CART=]

[,KEY=]

[,TOKEN=]

[,CONSID=]

[,CONSNAME=]

Parameters

message
Message text to be displayed. It must be in quotes.
text
Message text to be displayed. It must be in quotes.
text-addr
Address of message text to be displayed
reply
The field that will contain the reply. It may be a symbolic label or be in register notation.
reply-length
Length of the reply field. It may be an arithmetic value or be in register notation.

Comments

Writes to operator and waits for a reply, that is, displays a message in the Application Output window and waits for the operator to type a value and press the Enter key.

Examples

WTOR 'THIS IS MY MESSAGE',REPLY,10

REPLY DC CL10'

Parent topic: Macros Common with MVS


DOS/VSE-specific Macros

The following DOS/VSE-specific macros are supported:

  • CANCEL
  • CCB
  • CDLOAD
  • COMRG
  • DTFMT
  • DTFCD
  • DTFPR
  • DTFSD
  • EOJ
  • EXCP
  • FREEVIS
  • GETIME
  • GETVIS
  • WAIT

DOS/VSE-specific macros other than those listed above are not supported.

Parent topic: DOS/VSE Macro Instructions


Supervisor Services (SVCs)

Select the supervisor call (SVC) you require from the list:

  • SVC 4, GETMAIN (all E and L options, VU and VC)
  • SVC 5, FREEMAIN (all E and L options, VU and VC)
  • SVC 6, LINK
  • SVC 8, LOAD
  • SVC 9, DELETE
  • SVC 10, GETMAIN (R option)
  • SVC 11, TIME
  • SVC 13, ABEND
  • SVC 14, SPIE
  • SVC 26, CATALOG and LOCATE
  • SVC 29, SCRATCH
  • SVC 35, WTO and WTOR
  • SVC 39, LINKC2
  • SVC 41, IDENTIFY
  • SVC 62, Detach
  • SVC 99, DYNALLOC
  • SVC 103, XLATE
  • SVC 120
Parent topic: Macros and SVCs


SVC 4, GETMAIN (all E and L options, VU and VC)

INPUT
  • Register 1

    Address of parameter list.

OUTPUT
  • Register 0

    Amount of memory obtained

  • Register 1

    Address of allocated memory.

  • Register 15
    Return code:
    • 0=Successful
    • 4=Insufficient memory available

Parameter list, 10 bytes in length.

Bytes | Description
0-3

Element request: length requested

Variable request: address of a double-word containing the minimum and maximum lengths requested. Format is:

0 Zero

1-3 Minimum length

4 Zero

5-7 Maximum length

List request: address of a list of lengths requested (one word per request, the last word contains X'80' in byte 0.)

4 | Zero
5-7 Element request: address of a word GETMAIN initialized with the address of the area acquired

Variable request: address of a double-word GETMAIN initialized with the address of the area acquired and the actual length allocated.

List request: address of a list area GETMAIN initialized with the addresses of the areas allocated for each requested length in the list.

8 8 Flag byte:

10 Request is for storage aligned on a page boundary.

00 Unconditional element request.

20 Conditional element request.

80 Unconditional list request.

A0 Conditional list request.

C0 Unconditional variable request.

E0 Conditional variable request.

9 | Subpool to which memory should be allocated.
Parent topic: Supervisor Services (SVCs)


SVC 5, FREEMAIN (all E and L options, VU and VC)

INPUT
  • Register 1

    Address of parameter list.

OUTPUT
  • Register 15
    Return code:
    • 0=Successful
    • 4=4=Status of memory unchanged

Parameter list, 10 bytes in length.

Bytes | Description
0-3 | Element request: length requested List request: address of a list of lengths requested (one word per request, the last word contains X'80' in byte 0.)
4 -7 | Single area request: address of a word containing the address of the area to be freed. List-request: address of a list of addresses of areas to be freed. Variable request: address of a double-word containing the address to be freed in the first word and the length to be freed in the second word.
8 | Flag byte: 10 Request is for storage aligned on a page boundary. 00 Unconditional element request. 20 Conditional element request. 80 Unconditional list request. A0 Conditional list request. C0 Unconditional variable request. E0 Conditional variable request.
9 | Subpool that the memory belongs to
Note: A conditional request with a failure should result in an abend without returning to the calling program.
Parent topic: Supervisor Services (SVCs)


SVC 6, LINK

INPUT
  • Register 0

    Number of parameters being passed

  • Register 1

    Address of list of addresses of parameters being passed

  • Register 15

    Address of parameter list

Parameter list, 12 bytes in length.

Bytes | Description
0

Flag byte:

  • 00: EP and EPLOC form of macro instruction
  • 80: DE form of macro instruction
1-3

Address of directory entry if byte 0 = 80

Address of entry point name if byte 0 = 00

4 | Indicates extended parameter list if 80
5-7 | DCB address or zero
8-11 | Contains address of routine to get control on error (ERRET parameter) if byte 4 = 80
Parent topic: Supervisor Services (SVCs)


SVC 8, LOAD

INPUT
  • Register 15

    Return code:

OUTPUT
  • Register 0

    Load address of module. The high-order bit is set to indicate the AMODE setting of the loaded module:

    0=AMODE(24)

    1=AMODE(31).

  • Register 1

    Length of program module.

  • Register 15

    Return code:

    • 0=Successful
    • 1=Module size exceeds available memory
    • 4=Module not found
    • 8=Not enough memory available
Note: The module is loaded above or below the line depending on its RMODE setting.
Parent topic: Supervisor Services (SVCs)


SVC 9, DELETE

INPUT
  • Register 0

    Address of the name of the module to be deleted.

OUTPUT
  • Register 15

    Return code:

    • 0=Successful
    • 4=Module not found in load list
    • 8=Module in load list multiple times
Parent topic: Supervisor Services (SVCs)


SVC 10, GETMAIN (R option)

INPUT
Register 0
Bits | Meaning
0-23 | Amount of memory to obtain; always below the line
23-31 | Subpool number, in the range 0 through 127, 131 and 132
OUTPUT
  • Register 1

    Address of memory obtained.

  • Register 15

    Return code:

    • 0=Memory obtained
    • 4=Memory not obtained
Parent topic: Supervisor Services (SVCs)


SVC 11, TIME

Parent topic: Supervisor Services (SVCs)


SVC 13, ABEND

This SVC is not mainframe compatible, so you must code the ABEND macro.

Parent topic: Supervisor Services (SVCs)


SVC 14, SPIE

INPUT
Register 1

Address of parameter list

OUTPUT
Register 1

If a SPIE environment is already active when you issue the SPIE macro, the address of the previous PICA (Program Interruption Control Area) is returned in register 1. If no previous SPIE environment is active, a 0 is returned in register 1.

Parameter list, 6 bytes in length.

Bytes | Description
0-3 | Address of SPIE exit routine to be enabled.
4-5 | 2-byte field where bits 0 to 15 correspond to the 16 possible program interruption types to be handled by this exit. A bit setting of 1 indicates that the exit routine is to handle the corresponding interruption type. For example, the vale x'4000' would enable the handler for interruption type 1.
Parent topic: Supervisor Services (SVCs)


SVC 26, CATALOG and LOCATE

INPUT
Register 1

Address of parameter list generated by the CAMLST macro

OUTPUT
Register 15

Return code:

0=Successful

Any other value indicates an error. For further details see the IBM manual DFSMS DFP Advanced Services SC26-4921.

Parameter list, 20 bytes in length.

Bytes Description
0

Bits Meaning

0=1 CVOL specified

1=1 CAMLST macro generated

2=1 CATALOG or CATBX specified

3=1 RECAT specified

4=1 UNCAT or UCATDX specified

5=1 Reserved

6=1 LOCATE by TTR specified

7=1 Reserved

1

Bits Meaning

0=1 Do not allocate CVOL

1=1 BLDX or CATBX specified

2=1 BLDG specified

3=1 BLDA specified

4=1 LNKX specified

5=1 DLTX or UCATDX specified

6=1 DSCB TTR specified

7=1 RLTA specified

2

Bits Meaning

0=1 DRPX specified

1=1 DELETE specified

2=1 RENAME specified

3=1 SYSZTIOT is enqueued exclusively

4=1 EMPTY specified

5=1 Reserved

6=1 Reserved

7=0 Caller supplied a CAMLST

7=1 Caller supplied a CTGPL

3

Maximum generation count for a generation data group or zeros.

4-7

Address of the data set name or TTR if byte 0, bit 6 is on.

8-11

Address of the volume serial number of the CVOL catalog, or zeros if byte 0, bit 0 is zero.

12-15

If CATALOG was specified, the address of the volume list.

The address of an 8-byte area that contains an alias for a high-level index

If LNKX was specified, the address of a 10-byte area that contains a 4-byte device code followed by the 6-byte volume serial number of the CVOL to be connected

If the LOCATE macro was coded, the address of a 265-byte work area that must start on a doubleword boundary. if the issuer of LOCATE has a non-zero protect key, then the work area must have a matching storage protect key.

16-19

Address of the DSCB TTR if CATALOG was specified and byte 1 bit 6 is set to 1.

Parent topic: Supervisor Services (SVCs)


SVC 29, SCRATCH

INPUT
Register 1

Address of parameter list generated by the CAMLST macro

OUTPUT
Register 15

Return code:

0=Successful

Any other value indicates an error. For further details see the IBM manual DFSMS DFP Advanced Services SC26-4921.

Parameter list, 20 bytes in length.

Bytes | Description
0 | x'41': the opcode for SCRATCH
1 | Bits Meaning 0=1 Dynamic deallocation by job or step termination 1=1 If the JSCBPASS bit in the job step control block is on, then password protection is bypassed. If it is off, password protection is not bypassed. 2-7 Reserved (set to zeros)
2 | Bits Meaning 0=1 Dynamic deallocation; TIOT is enqueued by the caller 1=1 & 3=0 Check purge date 1=1 & 3=1 Override purge date 2 Reserved 4=1 If caller is in supervisor state, RACF processing is bypassed. 5-7 Reserved
3 | Reserved; set to zeros
4 | Bits Meaning 0=1 SVC called by job or step termination 1=1 SVC called by reader or writer 2-7 Reserved (set to zeros)
5-7 | Address of data set name.
8-11 | Reserved; set to zeros
12-15 | Address of the volume list.
Parent topic: Supervisor Services (SVCs)


SVC 35, WTO and WTOR

This SVC displays a message on the screen (WTO and WTOR)).

INPUT
Register 1

Address of the WTO or WTOR buffer.

OUTPUT
Register 15

Return code.

The WTO buffer must be in the following format:

Bytes | Description
0 | Binary zero.
1 | Length of display message plus 4
2-3 | Multiple console routing flags (not used)
4-nn | The text to be displayed on the screen.

The WTOR buffer must be in the following format:

Bytes | Description
0 | x'80'.
1-3 | Address of reply buffer.
5-7 | Address of reply event control block (not used)
8 | Binary zero
9 | Length of reply in bytes
10 | Length of display message plus 4
11-12 | Multiple console routing flags (not used)
13-nn | The text to be displayed on the screen.
Parent topic: Supervisor Services (SVCs)


SVC 39, LINKC2

INPUT

Register 15 Address of 8-byte COBOL program name in EBCDIC

Register 0 If bits 24-31 = 0, then bits 0-23 = parameter count.

  • If bits 24-31 = x'80', then find last parameter with high bit on and set r0 to number of parameters found.
  • If bits 24-31 = x'40', then process IMS parameters as follows: If first parameter <= F'18' then set r0 to value in first parameter + 1 else if first parameter > F'18' then find last parameter with high bit on and set r0 to number of parameters found.

Register 1 Address of list of addresses of parameters being passed

OUTPUT

Register 15 Return code:

  • 0=Successful
  • 16=Failure due to invalid name, duplicate name, or invalid address.
Parent topic: Supervisor Services (SVCs)


SVC 41, IDENTIFY

INPUT

Register 1 Address of parameter list

OUTPUT

Register 15 Return code.

0=Successful

Anything else means Identify failed.

Parameter list, 8 bytes in length.

Bytes | Description
0-3 | Address of 8-byte entry name
4-7 | Address of full word address of entry
Parent topic: Supervisor Services (SVCs)


SVC 62, Detach

DETACH just removes the currently executing program from the system. There is no corresponding macro and no SVC input or output parameters.

Parent topic: Supervisor Services (SVCs)


SVC 99, DYNALLOC

INPUT
Register 1

Address of request parameter block pointer

OUTPUT
Register 15

Return code:

0=Successful

Any other value indicates an error. For further details see the IBM manual MVS Programming: Authorized Assembler Services Guide GC28-1763.

Request parameter block pointer (S99RBPTR): Holds the 31-bit address of the request parameter block). High-order bit must be set on.

Request parameter block (S99RB), 20 bytes in length.

Bytes | Description
0 | Length of request block (always 20 bytes)
1 | One-byte verb code: x'01' Data set name allocation x'02' Data set name deallocation x'03' Not supported x'04' Not supported x'05' Not supported x'06' Not supported x'07' DD name allocation
2-3 | 2-byte flag field
4-5 | 2-byte error code field
6-7 | 2-byte information code field
8-9 | Address of text unit parameter list
12-15 | Address of request block extension
16-19 | 4-byte flag field

Text unit parameter list (S99TUPL): array of 31-bit addresses with each address pointing to one text unit. Last address must have high-order bit set.

Text unit (S99TUNIT): data structure containing the following fields:

Bytes | Field | Description
0-1 | Key | Contains hexadecimal code indicating which function is being requested
2-3 | Number | Number of length and parameter combinations in the text unit (the next two fields)
 | Length | The length of the following parameter field
 | Parameter | A variable-length field containing input information specific to the particular key function being requested

Request parameter block extension (S99RBX), 34 bytes in length.

Bytes | Description
0-5 | Identifier string ' S99RBX'
6 | Version number
7 | Processing options
8 | Message block subpool number
9 | Storage key
10 | Severity level
11 | Severity level
12 | Number of message blocks
13-16 | CPPL address
17-18 | Reserved
19 | Message processing reason code
20 | Message block freeing reason code
21-24 | PUTLINE or WTO return code
25-28 | Message block chain address
29-30 | Information retrieval error code
31-32 | Erroneous information retrieval key
33 | SMS reason code
Note: You should use the equates and DSECTs provided by the IBM macros IEFZB4D0 and IEFZB4D2 to construct the SVC99 parameter structures.
Parent topic: Supervisor Services (SVCs)


SVC 103, XLATE

INPUT
Register 0

Number of bytes to translate

Register 1

Bits Meaning

0=0 Convert ANSI to EBCDIC

0=1 Convert EBCDIC to ANSI

2-31 Address of first byte of area to translate

Parent topic: Supervisor Services (SVCs)


SVC 120

GETMAIN (options RU, RC, VRC and VRU), FREEMAIN (options R, RU, RC, VRC and VRU), and STORAGE

INPUT
Register 0 Number of bytes of memory to obtain or free.
Register 1 Address of memory to free (zero for GETMAIN)
Register 15
Byte | Meaning:
0 | Zero
1 | Key of memory to obtain or free (not supported)
2 | Subpool number of memory to obtain or free
3 Option byte: 00 Conditional GETMAIN

01 Conditional FREEMAIN

02 Unconditional GETMAIN

03 Unconditional FREEMAIN

04 Page boundary bit (not supported)

OUTPUT
Register 1 Address of allocated storage if GETMAIN

Register 15 Return code:

0= Memory obtained or freed

4= Memory not obtained or freed

Parent topic: Supervisor Services (SVCs)


Assembler Pseudo Operations

This section lists:

  • Fully supported pseudo operations.

    Refer to the IBM documentation for usage details

  • The pseudo operations for which only the name is supported.

    These pseudo-operations provide no functionality, but the usage does not generate errors. The compiler ignores them.

  • Supported Pseudo Operations
  • Pseudo Operations with Name Only Support
Parent topic: Assembler Reference


Supported Pseudo Operations

Studio Enterprise Edition Assembler support includes the following pseudo operations. The operations flagged as Name only support provide no functionality, and are treated as comments when they occur in code:

  • actr

    Name only support

  • aeject

    Name only support

  • ago

    Name only support

  • aif

    Name only support

  • amode

    Name only support

  • anop

    Name only support

  • aread

    Name only support

  • aspace

    Name only support

  • ccw
  • ccw1
  • ceject
  • chkcst
  • cnop
  • com
  • copy
  • csect
  • cxd
  • dc
  • drop
  • ds
  • dsect
  • dxd
  • eject
  • end
  • entry
  • equ
  • extrn
  • gbla
  • gblb
  • gblc
  • ictl
  • instr
  • iseq
  • lcla
  • lclb
  • lclc
  • loctr
  • ltorg
  • macro
  • mend
  • mexit
  • mhelp
  • mnote
  • opsyn
  • org
  • pop
  • print
  • punch
  • push
  • repro
  • rmode
  • rsect
  • seta
  • setaf
  • setb
  • setc
  • setcf
  • space
  • start
  • title
  • using
  • wtrn
Parent topic: Assembler Pseudo Operations


Pseudo Operations with Name Only Support

This section lists the pseudo operations where the name usage is treated as a comment, and the functionality is not supported.

  • actr
  • aeject
  • ago
  • aif
  • amode
  • anop
  • aread
  • aspace
Parent topic: Assembler Pseudo Operations


Configuring an Enterprise Server for Assembler Support

All Enterprise Servers

When you add an enterprise server instance using Enterprise Server Administration, configure it as follows:

  • Set the Working Mode to 32-bit.
  • Set the Server Type to Micro Focus Enterprise Server with Mainframe Subsystem Support.
  • If you want to be able to see the console daemon when you start the enterprise server, check Show Local Console.
  • For JCL-enabled enterprise servers, uncheck Create TN3270 listener.
  • For CICS-enabled enterprise servers, check Create TN3270 listener and specify a port.

JCL Support

On the Server > Properties > MSS > JES > General tab:

  • Uncheck Create TN3270 listener.
  • Specify the path to your program files as the JES Program Path and the Default Allocated Dataset Location.
  • Specify the path and filename of the catalog.dat file as the System Catalog.
  • Specify SYS1.PROCLIB for the System Procedure Library.

From the Server > Properties > MSS > JES > Initialize tab, Add an initiator, specifying a Name and Class of your choice.

CICS Support

On the Server > Properties > General tab, type the following into the Configuration Information field:
[ES-Environment]
ES_MFASM_SUPPORT=Y

On the Server > Properties > MSS > CICS tab:

  • Set the System Initialization Table to ASMIVP.
  • Check Mainframe Subsystem Support enabled.
  • In the Transaction Path and File Path fields, specify the location of your program executables, which is your Visual Studio project directory.
  • In the Map Path field, specify the path to your BMS modules (.mod files). This is usually the \bin\x86\debug subdirectory under your Visual Studio project directory or the directory containing your program executables.
  • Point the Resource Definition File Path to your resource definition (.rdf) file. This is the system subdirectory you created in your Visual Studio project.
Parent topic: Assembler Reference


CICS Preprocessor Options

There are two types of CICS preprocessor options that you set in your project properties, on the COBOL tab:

  1. Choose Project > MyProject Properties.
  2. Click the COBOL tab.
  3. Check EXEC CICS.
  • Options that you set by checking them in the CICSECM Options dialog box. You shouldn't try to set these explicitly. These are:
    • FUNCTION
    • OPTION
  • Options that you set explicitly by typing them into the Additional CICSECM options field, preceded by the directive CICSECM, for example, CICSECM(LINKAGE=NO). These are:
    • EXCI
    • HIDE
    • LINKAGE
    • SEVERITY
  • EXCI
    The CICS preprocessor EXCI option enables you to specify that the program being compiled uses the external CICS interface (EXCI) to call a CICS application.
  • FUNCTION
    The CICS preprocessor FUNCTION option enables you to specify how to handle unsupported CICS functions.
  • HIDE
    The CICS preprocessor HIDE option enables you to prevent specific error messages from being displayed.
  • LINKAGE
    The CICS preprocessor LINKAGE option enables you to control whether or not the preprocessor inserts the DFHEIBLK and COMMAREA into a program's Linkage Section and updates the USING clause of the PROCEDURE DIVISION header
  • OPTION
    The CICS preprocessor OPTION option enables you to specify how to handle unsupported options of CICS functions.
  • SEVERITY
    The CICS preprocessor SEVERITY option enables you to change the severity of specific error messages.
Parent topic: Mainframe Reference
Related reference
FUNCTION
OPTION
EXCI
HIDE
LINKAGE
SEVERITY


EXCI

The CICS preprocessor EXCI option enables you to specify that the program being compiled uses the external CICS interface (EXCI) to call a CICS application.
CAUTION:

A CICS EXCI call can only be executed in a service that is Container Managed. An EXCI call executed in an Application Managed generates an abend: EXIA

EXCI=YES
The program uses the external CICS interface (EXCI) to call a CICS application
EXCI=NO
The program does not use the external CICS interface (EXCI) to call a CICS application. This is the default.

For example, /CICSECM(EXCI=YES).

Note: When you specify this option, do not check EXEC CICS on the Compile tab of the Build Settings dialog box.
Parent topic: CICS Preprocessor Options
Related information
CICS Preprocessor Options
FUNCTION
HIDE
LINKAGE
OPTION
SEVERITY
EXCI


FUNCTION

The CICS preprocessor FUNCTION option enables you to specify how to handle unsupported CICS functions.
FUNCTION=ABEND
Requests that unsupported functions result in an abend at run time.
FUNCTION=NOOP
Requests that unsupported functions are treated as comments (that is, ignored).

The default is that the CICS preprocessor treats unsupported CICS functions as Compiler errors.

Parent topic: CICS Preprocessor Options
Related information
CICS Preprocessor Options
FUNCTION
HIDE
LINKAGE
OPTION
SEVERITY
EXCI


HIDE

The CICS preprocessor HIDE option enables you to prevent specific error messages from being displayed.

HIDE=nnnn

where

nnnn
The error ID (in the range of 1000 to 1999).

For example, /CICSECM(HIDE=1000).

Parent topic: CICS Preprocessor Options
Related information
CICS Preprocessor Options
FUNCTION
HIDE
LINKAGE
OPTION
SEVERITY
EXCI


LINKAGE

The CICS preprocessor LINKAGE option enables you to control whether or not the preprocessor inserts the DFHEIBLK and COMMAREA into a program's Linkage Section and updates the USING clause of the PROCEDURE DIVISION header
LINKAGE=NO
Do not insert the DFHEIBLK and COMMAREA into a program's Linkage Section or update the USING clause of the PROCEDURE DIVISION header
LINKAGE=YES
Do insert the DFHEIBLK and COMMAREA into a program's Linkage Section and update the USING clause of the PROCEDURE DIVISION header. This is the default

You can shorten LINKAGE to LINK, YES to Y and NO to N.

For example, /CICSECM(LINKAGE=NO).

Parent topic: CICS Preprocessor Options
Related information
CICS Preprocessor Options
FUNCTION
HIDE
LINKAGE
OPTION
SEVERITY
EXCI


OPTION

The CICS preprocessor OPTION option enables you to specify how to handle unsupported options of CICS functions.
OPTION=ABEND
Requests that unsupported functions result in an abend at run time.
OPTION=NOOP
Requests that unsupported functions are treated as comments (that is, ignored by the preprocessor).
OPTION=IGNORE
Requests that unsupported functions are ignored at run time.

The default is that the CICS preprocessor treats unsupported CICS options as Compiler errors.

Parent topic: CICS Preprocessor Options
Related information
CICS Preprocessor Options
FUNCTION
HIDE
LINKAGE
OPTION
SEVERITY
EXCI


SEVERITY

The CICS preprocessor SEVERITY option enables you to change the severity of specific error messages.

SEVERITY=nnnnX

where:

nnnn
is the error ID (in the range of 1000 to 1999).
X
is the new severity level (can be I, W, E or S).
  • I means Informational
  • W means Warning
  • E means Error
  • S means Severe

For example, /CICSECM(SEVERITY=1000W).

Parent topic: CICS Preprocessor Options
Related information
CICS Preprocessor Options
FUNCTION
HIDE
LINKAGE
OPTION
SEVERITY
EXCI


CICS Support Commands

Lists the CICS Support commands

The following commands are available for CICS support:

  • CICS API Calls
  • CICS SPI Calls
Parent topic: Mainframe Reference


CICS API Calls

  • ABEND
    The ABEND function is supported.
  • ADD SUBEVENT
    The ADD SUBEVENT function is not supported.
  • ADDRESS
    The ADDRESS function is supported.
  • ADDRESS SET
    The ADDRESS SET function is supported.
  • ALLOCATE
    The ALLOCATE function is supported.
  • ASKTIME
    The ASKTIME function is supported.
  • ASSIGN
    The ASSIGN function is supported.
  • BIF DEEDIT
    The BIF DEEDIT function is supported.
  • BIF DIGEST
    The BIF DIGEST function is not supported.
  • BUILD ATTACH
    The BUILD ATTACH function is not supported.
  • CANCEL
    The CANCEL function is supported.
  • CHANGE PASSWORD
    The CHANGE PASSWORD function is not supported.
  • CHANGE PHRASE
    The CHANGE PHRASE function is not supported.
  • CHECK ACQACTIVITY
    The CHECK ACQACTIVITY function is not supported.
  • CHECK ACQPROCESS
    The CHECK ACQPROCESS function is not supported.
  • CHECK ACTIVITY
    The CHECK ACTIVITY function is not supported.
  • CHECK TIMER
    The CHECK TIMER function is not supported.
  • CONNECT PROCESS
    The CONNECT PROCESS function is supported.
  • CONVERSE
    The CONVERSE function is supported.
  • CONVERTTIME
    The CONVERTTIME function is not supported.
  • DEFINE ACTIVITY
    The DEFINE ACTIVITY function is not supported.
  • DEFINE COMPOSITE CREATE
    The DEFINE COMPOSITE CREATE function is not supported.
  • DEFINE COUNTER
    The DEFINE COUNTER function is not supported.
  • DEFINE DCOUNTER
    The DEFINE DCOUNTER function is not supported.
  • DEFINE INPUT EVENT
    The DEFINE INPUT EVENT function is not supported.
  • DEFINE PROCESS
    The DEFINE PROCESS function is not supported.
  • DEFINE TIMER
    The DEFINE TIMER function is not supported.
  • DELAY
    The DELAY function is supported.
  • DELETE
    The DELETE function is supported.
  • DELETE ACTIVITY
    The DELETE ACTIVITY function is not supported.
  • DELETE CONTAINER
    The DELETE CONTAINER function is supported.
  • DELETE COUNTER
    The DELETE COUNTER function is not supported.
  • DELETE DCOUNTER
    The DELETE DCOUNTER function is not supported.
  • DELETE EVENT
    The DELETE EVENT function is not supported.
  • DELETE RIDFLD
    The DELETE RIDFLD function is supported.
  • DELETE TIMER
    The DELETE TIMER function is not supported.
  • DELETEQ
    The DELETEQ function is supported.
  • DELETEQ TD
    The DELETEQ TD function is supported.
  • DELETEQ TS
    The DELETEQ TS function is supported.
  • DEQ
    The DEQ function is supported.
  • DOCUMENT CREATE
    The DOCUMENT CREATE function is supported.
  • DOCUMENT DELETE
    The DOCUMENT DELETE function is supported.
  • DOCUMENT INSERT
    The DOCUMENT INSERT function is supported.
  • DOCUMENT RETRIEVE
    The DOCUMENT RETRIEVE function is supported.
  • DOCUMENT SET
    The DOCUMENT SET function is supported.
  • DUMP
    The DUMP function is supported.
  • DUMP SYSTEM
    The DUMP SYSTEM function is supported.
  • DUMP TRANSACTION
    The DUMP TRANSACTION function is supported.
  • ENDBR
    The ENDBR function is supported.
  • ENDBROWSE ACTIVITY
    The ENDBROWSE ACTIVITY function is not supported.
  • ENDBROWSE CONTAINER
    The ENDBROWSE CONTAINER function is supported.
  • ENDBROWSE EVENT
    The ENDBROWSE EVENT function is not supported.
  • ENDBROWSE PROCESS
    The ENDBROWSE PROCESS function is not supported.
  • ENQ
    The ENQ function is supported.
  • ENTER TRACEID
    The ENTER TRACEID function is supported.
  • ENTER TRACENUM
    The ENTER TRACENUM function is supported.
  • FEPI
    The FEPI function is not supported.
  • FORCE TIMER
    The FORCE TIMER function is not supported.
  • FORMATTIME
    The FORMATTIME function is supported.
  • FREE
    The FREE function is supported.
  • FREEMAIN
    The FREEMAIN function is supported.
  • GDS ALLOCATE
    The GDS ALLOCATE function is supported.
  • GDS ASSIGN
    The GDS ASSIGN function is supported.
  • GDS CONNECT PROCESS
    The GDS CONNECT PROCESS function is supported.
  • GDS EXTRACT ATTRIBUTES
    The GDS EXTRACT ATTRIBUTES function is supported.
  • GDS EXTRACT PROCESS
    The GDS EXTRACT PROCESS function is supported.
  • GDS FREE
    The GDS FREE function is supported.
  • GDS ISSUE ABEND
    The GDS ISSUE ABEND function is supported.
  • GDS ISSUE CONFIRMATION
    The GDS ISSUE CONFIRMATION function is supported.
  • GDS ISSUE ERROR
    The GDS ISSUE ERROR function is supported.
  • GDS ISSUE PREPARE
    The GDS ISSUE PREPARE function is supported.
  • GDS ISSUE SIGNAL
    The GDS ISSUE SIGNAL function is supported.
  • GDS RECEIVE
    The GDS RECEIVE function is supported.
  • GDS SEND
    The GDS SEND function is supported.
  • GDS WAIT
    The GDS WAIT function is supported.
  • GET CONTAINER
    The GET CONTAINER function is supported.
  • GET COUNTER
    The GET COUNTER function is not supported.
  • GET DCOUNTER
    The GET DCOUNTER function is not supported.
  • GETMAIN
    The GETMAIN function is supported.
  • GETNEXT ACTIVITY
    The GETNEXT ACTIVITY function is not supported.
  • GETNEXT CONTAINER
    The GETNEXT CONTAINER function is supported.
  • GETNEXT EVENT
    The GETNEXT EVENT function is not supported.
  • GETNEXT PROCESS
    The GETNEXT PROCESS function is not supported.
  • HANDLE ABEND
    The HANDLE ABEND function is supported.
  • HANDLE AID
    The HANDLE AID function is supported.
  • HANDLE CONDITION
    The HANDLE CONDITION function is supported.
  • IGNORE CONDITION
    The IGNORE CONDITION function is supported.
  • INVOKE SERVICE
    The INVOKE SERVICE function is not supported.
  • ISSUE ABEND
    The ISSUE ABEND function is supported.
  • ISSUE ABORT
    The ISSUE ABORT function is not supported.
  • ISSUE ADD
    The ISSUE ADD function is not supported.
  • ISSUE CONFIRMATION
    The ISSUE CONFIRMATION function is supported.
  • ISSUE COPY
    The ISSUE COPY function is not supported.
  • ISSUE DISCONNECT
    The ISSUE DISCONNECT function is supported.
  • ISSUE END
    The ISSUE END function is not supported.
  • ISSUE ENDFILE
    The ISSUE ENDFILE function is not supported.
  • ISSUE ENDOUTPUT
    The ISSUE ENDOUTPUT function is not supported.
  • ISSUE EODS
    The ISSUE EODS function is not supported.
  • ISSUE ERASE
    The ISSUE ERASE function is not supported.
  • ISSUE ERASEAUP
    The ISSUE ERASEAUP function is supported.
  • ISSUE ERROR
    The ISSUE ERROR function is supported.
  • ISSUE LOAD
    The ISSUE LOAD function is not supported.
  • ISSUE NOTE
    The ISSUE NOTE function is not supported.
  • ISSUE PASS
    The ISSUE PASS function is not supported.
  • ISSUE PREPARE
    The ISSUE PREPARE function is supported.
  • ISSUE PRINT
    The ISSUE PRINT function is supported.
  • ISSUE QUERY
    The ISSUE QUERY function is not supported.
  • ISSUE RECEIVE
    The ISSUE RECEIVE function is not supported.
  • ISSUE REPLACE
    The ISSUE REPLACE function is not supported.
  • ISSUE RESET
    The ISSUE RESET function is supported.
  • ISSUE SEND
    The ISSUE SEND function is not supported.
  • ISSUE SIGNAL
    The ISSUE SIGNAL function is supported.
  • ISSUE WAIT
    The ISSUE WAIT function is not supported.
  • JOURNAL
    The JOURNAL function is supported.
  • LINK
    The LINK function is supported.
  • LINK ACQACTIVITY
    The LINK ACQACTIVITY function is not supported.
  • LINK ACQPROCESS
    The LINK ACQPROCESS function is not supported.
  • LINK ACTIVITY
    The LINK ACTIVITY function is not supported.
  • LOAD
    The LOAD function is supported.
  • MONITOR
    The MONITOR function is not supported.
  • MOVE CONTAINER
    The MOVE CONTAINER function is supported.
  • POINT
    The POINT function is not supported.
  • POP
    The POP function is supported.
  • POP HANDLE
    The POP HANDLE function is supported.
  • POST
    The POST function is supported.
  • PURGE MESSAGE
    The PURGE MESSAGE function is supported.
  • PUSH
    The PUSH function is supported.
  • PUSH HANDLE
    The PUSH HANDLE function is supported.
  • PUT CONTAINER
    The PUT CONTAINER function is supported.
  • QUERY COUNTER
    The QUERY COUNTER function is not supported.
  • QUERY DCOUNTER
    The QUERY DCOUNTER function is not supported.
  • QUERY SECURITY
    The QUERY SECURITY function is supported.
  • READ
    The READ function is supported.
  • READNEXT
    The READNEXT function is supported.
  • READPREV
    The READPREV function is supported.
  • READQ
    The READQ function is supported.
  • READQ TD
    The READQ TD function is supported.
  • READQ TS
    The READQ TS function is supported.
  • RECEIVE
    The RECEIVE function is supported.
  • RECEIVE MAP
    The RECEIVE MAP function is supported.
  • RECEIVE MAP MAPPINGDEV
    The RECEIVE MAP MAPPINGDEV function is not supported.
  • RECEIVE MAPSET
    The RECEIVE MAPSET function is supported.
  • RECEIVE PARTN
    The RECEIVE PARTN function is not supported.
  • RELEASE
    The RELEASE function is supported.
  • REMOVE SUBEVENT
    The REMOVE SUBEVENT function is not supported.
  • RESET ACQPROCESS
    The RESET ACQPROCESS function is not supported.
  • RESET ACTIVITY
    The RESET ACTIVITY function is not supported.
  • RESETBR
    The RESETBR function is supported.
  • RESUME
    The RESUME function is not supported.
  • RETRIEVE
    The RETRIEVE function is supported.
  • RETRIEVE REATTACH
    The RETRIEVE REATTACH function is not supported.
  • RETRIEVE SUBEVENT
    The RETRIEVE SUBEVENT function is not supported.
  • RETURN
    The RETURN function is supported.
  • REWIND COUNTER
    The REWIND COUNTER function is not supported.
  • REWIND DCOUNTER
    The REWIND DCOUNTER function is not supported.
  • REWRITE
    The REWRITE function is supported.
  • ROUTE
    The ROUTE function is not supported.
  • RUN
    The RUN function is not supported.
  • SEND
    The SEND function is supported.
  • SEND CONTROL
    The SEND CONTROL function is supported.
  • SEND MAP
    The SEND MAP function is supported.
  • SEND MAP MAPPINGDEV
    The SEND MAP MAPPINGDEV function is not supported.
  • SEND MAPSET
    The SEND MAPSET function is supported.
  • SEND PAGE
    The SEND PAGE function is supported.
  • SEND PARTNSET
    The SEND PARTNSET function is not supported.
  • SEND TEXT
    The SEND TEXT function is supported.
  • SEND TEXT MAPPED
    The SEND TEXT MAPPED function is supported.
  • SEND TEXT NOEDIT
    The SEND TEXT NOEDIT function is supported.
  • SIGNAL EVENT
    The SIGNAL EVENT function is not supported.
  • SIGNOFF
    The SIGNOFF function is supported.
  • SIGNON
    The SIGNON function is supported.
  • SOAPFAULT ADD
    The SOAPFAULT ADD function is not supported.
  • SOAPFAULT CREATE
    The SOAPFAULT CREATE function is not supported.
  • SOAPFAULT DELETE
    The SOAPFAULT DELETE function is not supported.
  • SPOOLCLOSE
    The SPOOLCLOSE function is supported.
  • SPOOLCLOSE REPORT
    The SPOOLCLOSE REPORT function is supported.
  • SPOOLOPEN ESCAPE
    The SPOOLOPEN ESCAPE function is not supported.
  • SPOOLOPEN INPUT
    The SPOOLOPEN INPUT function is not supported.
  • SPOOLOPEN MAPNAME
    The SPOOLOPEN MAPNAME function is not supported.
  • SPOOLOPEN OUTPUT
    The SPOOLOPEN OUTPUT function is supported.
  • SPOOLOPEN REPORT ASA
    The SPOOLOPEN REPORT ASA function is supported.
  • SPOOLOPEN REPORT JCL
    The SPOOLOPEN REPORT JCL function is supported.
  • SPOOLOPEN REPORT MCC
    The SPOOLOPEN REPORT MCC function is supported.
  • SPOOLOPEN REPORT NOCC
    The SPOOLOPEN REPORT NOCC function is supported.
  • SPOOLOPEN REPORT SCS
    The SPOOLOPEN REPORT SCS function is not supported.
  • SPOOLOPEN REPORT T3270
    The SPOOLOPEN REPORT T3270 function is not supported.
  • SPOOLOPEN RESUME
    The SPOOLOPEN RESUME function is not supported.
  • SPOOLREAD
    The SPOOLREAD function is not supported.
  • SPOOLWRITE
    The SPOOLWRITE function is supported.
  • SPOOLWRITE MAPNAME
    The SPOOLWRITE MAPNAME function is not supported.
  • SPOOLWRITE REPORT
    The SPOOLWRITE REPORT function is supported.
  • START
    The START function is supported.
  • START ATTACH
    The START ATTACH function is not supported.
  • START BREXIT
    The START BREXIT function is supported.
  • START CHANNEL
    The START CHANNEL function is supported.
  • STARTBR
    The STARTBR function is supported.
  • STARTBROWSE ACTIVITY
    The STARTBROWSE ACTIVITY function is not supported.
  • STARTBROWSE CONTAINER
    The STARTBROWSE CONTAINER function is supported.
  • STARTBROWSE EVENT
    The STARTBROWSE EVENT function is not supported.
  • STARTBROWSE PROCESS
    The STARTBROWSE PROCESS function is not supported.
  • SUSPEND
    The SUSPEND function is supported.
  • SYNCPOINT
    The SYNCPOINT function is supported.
  • TEST EVENT
    The TEST EVENT function is not supported.
  • TRACE
    The TRACE function is not supported.
  • TRANSFORM DATATOXML
    The TRANSFORM DATATOXML function is not supported.
  • TRANSFORM XMLTODATA
    The TRANSFORM XMLTODATA function is not supported.
  • UNLOCK
    The UNLOCK function is supported.
  • UPDATE COUNTER
    The UPDATE COUNTER function is not supported.
  • UPDATE DCOUNTER
    The UPDATE DCOUNTER function is not supported.
  • VERIFY PASSWORD
    The VERIFY PASSWORD function is supported.
  • WAIT CONVID
    The WAIT CONVID function is supported.
  • WAIT EVENT
    The WAIT EVENT function is supported.
  • WAIT EXTERNAL
    The WAIT EXTERNAL function is not supported.
  • WAIT JOURNAL
    The WAIT JOURNAL function is supported.
  • WAIT JOURNALNAME
    The WAIT JOURNALNAME function is not supported.
  • WAIT JOURNALNUM
    The WAIT JOURNALNUM function is supported.
  • WAIT SIGNAL
    The WAIT SIGNAL function is not supported.
  • WAIT TERMINAL
    The WAIT TERMINAL function is not supported.
  • WAITCICS
    The WAITCICS function is supported.
  • WEB CLOSE
    The WEB CLOSE function is supported.
  • WEB CONVERSE
    The WEB CONVERSE function is supported.
  • WEB ENDBROWSE FORMFIELD
    The WEB ENDBROWSE FORMFIELD function is supported.
  • WEB ENDBROWSE HTTPHEADER
    The WEB ENDBROWSE HTTPHEADER function is supported.
  • WEB ENDBROWSE QUERYPARM
    The WEB ENDBROWSE QUERYPARM function is supported.
  • WEB EXTRACT
    The WEB EXTRACT function is supported.
  • WEB OPEN
    The WEB OPEN function is supported.
  • WEB PARSE
    The WEB PARSE function is supported.
  • WEB READ FORMFIELD
    The WEB READ FORMFIELD function is supported.
  • WEB READ HTTPHEADER
    The WEB READ HTTPHEADER function is supported.
  • WEB READ QUERYPARM
    The WEB READ QUERYPARM function is supported.
  • WEB READNEXT FORMFIELD
    The WEB READNEXT FORMFIELD function is supported.
  • WEB READNEXT HTTPHEADER
    The WEB READNEXT HTTPHEADER function is supported.
  • WEB READNEXT QUERYPARM
    The WEB READNEXT QUERYPARM function is supported.
  • WEB RECEIVE
    The WEB RECEIVE function is supported.
  • WEB RECEIVE SESSTOKEN
    The WEB RECEIVE SESSTOKEN function is supported.
  • WEB RETRIEVE
    The WEB RETRIEVE function is supported.
  • WEB SEND
    The WEB SEND function is supported.
  • WEB SEND SESSTOKEN
    The WEB SEND SESSTOKEN function is supported.
  • WEB STARTBROWSE FORMFIELD
    The WEB STARTBROWSE FORMFIELD function is supported.
  • WEB STARTBROWSE HTTPHEADER
    The WEB STARTBROWSE HTTPHEADER function is supported.
  • WEB STARTBROWSE QUERYPARM
    The WEB STARTBROWSE QUERYPARM function is supported.
  • WEB WRITE
    The WEB WRITE function is supported.
  • WRITE
    The WRITE function is supported.
  • WRITE JOURNALNAME
    The WRITE JOURNALNAME function is not supported.
  • WRITE JOURNALNUM
    The WRITE JOURNALNUM function is supported.
  • WRITE OPERATOR
    The WRITE OPERATOR function is supported.
  • WRITEQ
    The WRITEQ function is supported.
  • WRITEQ TD
    The WRITEQ TD function is supported.
  • WRITEQ TS
    The WRITEQ TS function is supported.
  • WSACONTEXT BUILD
    The WSACONTEXT BUILD function is not supported.
  • WSACONTEXT DELETE
    The WSACONTEXT DELETE function is not supported.
  • WSACONTEXT GET
    The WSACONTEXT GET function is not supported.
  • WSAEPR CREATE
    The WSAEPR CREATE function is not supported.
  • WSAEPR EVENT
    The WSAEPR EVENT function is not supported.
  • WSAEPR PROCESS
    The WSAEPR PROCESS function is supported.
  • XCTL
    The XCTL function is supported.
Parent topic: CICS Support Commands


ABEND

The ABEND function is supported.

Operand | Support
ABCODE (data-value) | Full
CANCEL | Full
NODUMP | Full
Parent topic: CICS API Calls


ADD SUBEVENT

The ADD SUBEVENT function is not supported.

Parent topic: CICS API Calls


ADDRESS

The ADDRESS function is supported.

Operand | Support
ACEE (ptr-ref) | Full
COMMAREA (ptr-ref) | Full
CSA (ptr-ref) | Partial: returns a NULL pointer
CWA (ptr-ref) | Full
EIB (ptr-ref) | Full
TCTUA (ptr-ref) | Full
TWA (ptr-ref) | Full
Parent topic: CICS API Calls


ADDRESS SET

The ADDRESS SET function is supported.

Operand | Support
SET (ptr-ref) | Full
USING (ptr-ref) | Full
Parent topic: CICS API Calls


ALLOCATE

The ALLOCATE function is supported.

Operand | Support
NOQUEUE | Full
NOSUSPEND | Full
PARTNER (data-value) | Validated
PROFILE (data-value) | Validated
SESSION (data-value) | Validated
STATE (cvda) | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


ASKTIME

The ASKTIME function is supported.

Operand | Support
ABSTIME (data-area) | Full
Parent topic: CICS API Calls


ASSIGN

The ASSIGN function is supported.

Operand | Support
ABCODE (data-area) | Full
ABDUMP (data-area) | Partial: returns x"00" meaning "No dump has been produced"
ABPROGRAM (data-area) | Partial: returns x"00" meaning "Indeterminable"
ACTIVITY (data-area) | Validated
ACTIVITYID (data-area) | Validated
ALTSCRNHT (data-area) | Full
ALTSCRNWD (data-area) | Full
APLKYBD (data-area) | Partial: returns x"00" meaning "No"
APLTEXT (data-area) | Partial: returns x"00" meaning "No"
APPLID (data-area) | Full
ASRAINTRPT (data-area) | Partial: returns x"00"
ASRAKEY (data-area) | Validated
ASRAPSW (data-area) | Partial: returns x"00"
ASRAREGS (data-area) | Partial: returns x"00"
ASRASPC (data-area) | Validated
ASRASTG (data-area) | Validated
BRIDGE (data-area) | Full
BTRANS (data-area) | Partial: returns x"00" meaning "No"
CHANNEL (data-area) | Full
CMDSEC (data-area) | Partial: returns Blank meaning "No"
COLOR (data-area) | Full
CWALENG (data-area) | Full
DEFSCRNHT (data-area) | Full
DEFSCRNWD (data-area) | Full
DELIMITER (data-area) | Partial: returns x"00"
DESTCOUNT (data-area) | Partial: returns x"0000"
DESTID (data-area) | Partial: INVREQ occurs
DESTIDLENG (data-area) | Partial: INVREQ occurs
DS3270 (data-area) | Partial: returns x"00" meaning "No"
DSSCS (data-area) | Partial: returns x"00" meaning "No"
EWASUPP (data-area) | Full
EXTDS (data-area) | Full
FACILITY (data-area) | Full
FCI (data-area) | Full
GCHARS (data-area) | Full
GCODES (data-area) | Full
GMMI (data-area) | Full
HILIGHT (data-area) | Full
INITPARM (ptr-ref) | Partial: returns x"00" meaning "No parameters"
INITPARMLEN (data-area) | Partial: returns x"00" meaning "No parameter"
INPARTN (data-area) | Partial: returns spaces
INVOKINGPROG (data-area) | Full
KATAKANA (data-area) | Partial: returns x"00" meaning "No"
LANGINUSE (data-area) | Validated
LDCMNEM (data-area) | Partial: returns x"00"
LDCNUM (data-area) | Partial: returns x"00"
MAPCOLUMN (data-area) | Full
MAPHEIGHT (data-area) | Full
MAPLINE (data-area) | Full
MAPWIDTH (data-area) | Full
MSRCONTROL (data-area) | Partial: returns x"00" meaning "No"
NATLANGINUSE (data-area) | Partial: returns "E" meaning "English (US)"
NETNAME (data-area) | Full
NEXTTRANSID (data-area) | Full
NUMTAB (data-area) | Partial: returns x"00"
OPCLASS (data-area) | Full
OPERKEYS (data-area) | Full
OPID (data-area) | Full
OPSECURITY (data-area) | Full
ORGABCODE (data-area) | Full
OUTLINE (data-area) | Full
PAGENUM (data-area) | Full
PARTNPAGE (data-area) | Partial: returns spaces
PARTNS (data-area) | Partial: returns x"00" meaning "No"
PARTNSET (data-area) | Partial: returns spaces meaning "No application partition set"
PRINSYSID (data-area) | Full
PROCESS (data-area) | Validated
PROCESSTYPE (data-area) | Validated
PROGRAM (data-area) | Full
PS (data-area) | Full
QNAME (data-area) | Full
RESSEC (data-area) | Full
RESTART (data-area) | Partial: returns x"00" meaning "Normal Start"
RETURNPROG (data-area) | Full
SCRNHT (data-area) | Full
SCRNWD (data-area) | Full
SIGDATA (data-area) | Partial: returns spaces
SOSI (data-area) | Full
STARTCODE (data-area) | Full
STATIONID (data-area) | Partial: returns x"00"
SYSID (data-area) | Full
TASKPRIORITY (data-area) | Full
TCTUALENG (data-area) | Full
TELLERID (data-area) | Partial: returns x"00"
TERMCODE (data-area) | Full
TERMPRIORITY (data-area) | Full
TEXTKYBD (data-area) | Partial: returns x"00" meaning "No"
TEXTPRINT (data-area) | Partial: returns x"00" meaning "No"
TRANPRIORITY (data-area) | Full
TWALENG (data-area) | Full
UNATTEND (data-area) | Full
USERID (data-area) | Full
USERNAME (data-area) | Partial: returns spaces
USERPRIORITY (data-area) | Full
VALIDATION (data-area) | Partial: returns x"00" meaning "No"
Parent topic: CICS API Calls


BIF DEEDIT

The BIF DEEDIT function is supported.

Operand | Support
FIELD (data-area) | Full
LENGTH (data-value) | Full
Parent topic: CICS API Calls


BIF DIGEST

The BIF DIGEST function is not supported.

Parent topic: CICS API Calls


BUILD ATTACH

The BUILD ATTACH function is not supported.

Operand | Support
ATTACHID (data-value) | Recognized
DATASTR (data-area) | Recognized
IUTYPE (data-area) | Recognized
PROCESS (data-value) | Recognized
QUEUE (data-value) | Recognized
RECFM (data-area) | Recognized
RESOURCE (data-value) | Recognized
RPROCESS (data-value) | Recognized
RRESOURCE (data-value) | Recognized
Parent topic: CICS API Calls


CANCEL

The CANCEL function is supported.

Operand | Support
REQID (data-value) | Full
SYSID (data-value) | Full
TRANSID (data-value) | Full
Parent topic: CICS API Calls


CHANGE PASSWORD

The CHANGE PASSWORD function is not supported.

Operand | Support
ESMREASON (data-area) | Recognized
ESMRESP (data-area) | Recognized
NEWPASSWORD (data-value) | Recognized
PASSWORD (data-value) | Recognized
USERID (data-value) | Recognized
Parent topic: CICS API Calls


CHANGE PHRASE

The CHANGE PHRASE function is not supported.

Operand | Support
ESMREASON (data-area) | Recognized
ESMRESP (data-area) | Recognized
NEWPHRASE (data-area) | Recognized
NEWPHRASELEN (data-value) | Recognized
PHRASE (data-area) | Recognized
PHRASELEN (data-value) | Recognized
USERID (data-value) | Recognized
Parent topic: CICS API Calls


CHECK ACQACTIVITY

The CHECK ACQACTIVITY function is not supported.

Parent topic: CICS API Calls


CHECK ACQPROCESS

The CHECK ACQPROCESS function is not supported.

Parent topic: CICS API Calls


CHECK ACTIVITY

The CHECK ACTIVITY function is not supported.

Parent topic: CICS API Calls


CHECK TIMER

The CHECK TIMER function is not supported.

Parent topic: CICS API Calls


CONNECT PROCESS

The CONNECT PROCESS function is supported.

Operand | Support
CONVID (data-value) | Full
PARTNER | Validated
PIPLENGTH (data-value) | Full
PIPLIST (data-area) | Full
PROCLENGTH (data-value) | Full
PROCNAME (data-area) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
SYNCLEVEL (data-value) | Full
Parent topic: CICS API Calls


CONVERSE

The CONVERSE function is supported.

Operand | Support
ALTERNATE | Full
ASIS | Full
CONVID (data-value) | Full
CTLCHAR (data-value) | Full
DEFAULT | Full
DEFRESP | Validated
DEST (data-value) | Validated
ERASE | Full
FMH | Full
FROM (data-area) | Full
FROMFLENGTH (data-value) | Full
FROMLENGTH (data-value) | Full
INTO (data-area) | Full
MAXFLENGTH (data-value) | Full
MAXLENGTH (data-value) | Full
NOTRUNCATE | Full
SESSION (data-value) | Full
SET (ptr-ref) | Full
STATE (cvda) | Full
STRFIELD | Full
TOFLENGTH (data-area) | Full
TOLENGTH (data-area) | Full
Parent topic: CICS API Calls


CONVERTTIME

The CONVERTTIME function is not supported.

Operand | Support
ABSTIME (data-area) | Recognized
DATESTRING (data-area) | Recognized
Parent topic: CICS API Calls


DEFINE ACTIVITY

The DEFINE ACTIVITY function is not supported.

Parent topic: CICS API Calls


DEFINE COMPOSITE CREATE

The DEFINE COMPOSITE CREATE function is not supported.

Parent topic: CICS API Calls


DEFINE COUNTER

The DEFINE COUNTER function is not supported.

Operand | Support
COUNTER (data-value) | Recognized
MAXIMUM (data-value) | Recognized
MINIMUM (data-value) | Recognized
POOL (data-value) | Recognized
VALUE (data-value) | Recognized
Parent topic: CICS API Calls


DEFINE DCOUNTER

The DEFINE DCOUNTER function is not supported.

Operand | Support
DCOUNTER (data-value) | Recognized
MAXIMUM (data-area) | Recognized
MINIMUM (data-area) | Recognized
POOL (data-value) | Recognized
VALUE (data-area) | Recognized
Parent topic: CICS API Calls


DEFINE INPUT EVENT

The DEFINE INPUT EVENT function is not supported.

Parent topic: CICS API Calls


DEFINE PROCESS

The DEFINE PROCESS function is not supported.

Parent topic: CICS API Calls


DEFINE TIMER

The DEFINE TIMER function is not supported.

Parent topic: CICS API Calls


DELAY

The DELAY function is supported.

Operand | Support
FOR | Full
HOURS (data-value) | Full
INTERVAL (data-value) | Full
MINUTES (data-value) | Full
REQID (data-value) | Full
SECONDS (data-value) | Full
TIME (data-value) | Full
UNTIL | Full
Parent topic: CICS API Calls


DELETE

The DELETE function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
GENERIC | Full
KEYLENGTH (data-value) | Full
NUMREC (data-area) | Full
RBA | Validated
RIDFLD (data-area) | Full
RRN | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full
Parent topic: CICS API Calls


DELETE ACTIVITY

The DELETE ACTIVITY function is not supported.

Parent topic: CICS API Calls


DELETE CONTAINER

The DELETE CONTAINER function is supported.

Operand | Support
CHANNEL (data-value) | Full
CONTAINER (data-value) | Full
SYSTEM (cvda) | Full
USER (cvda) | Full
Parent topic: CICS API Calls


DELETE COUNTER

The DELETE COUNTER function is not supported.

Operand | Support
COUNTER (data-value) | Recognized
POOL (data-value) | Recognized
Parent topic: CICS API Calls


DELETE DCOUNTER

The DELETE DCOUNTER function is not supported.

Operand | Support
DCOUNTER (data-value) | Recognized
POOL (data-value) | Recognized
Parent topic: CICS API Calls


DELETE EVENT

The DELETE EVENT function is not supported.

Parent topic: CICS API Calls


DELETE RIDFLD

The DELETE RIDFLD function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
GENERIC | Full
KEYLENGTH (data-value) | Full
NUMREC (data-area) | Full
RBA | Validated
RIDFLD (data-area) | Full
RRN | Full
SYSID (data-value) | Full
TOKEN (data-area) | Validated
Parent topic: CICS API Calls


DELETE TIMER

The DELETE TIMER function is not supported.

Parent topic: CICS API Calls


DELETEQ

The DELETEQ function is supported.

Operand | Support
QNAME (data-value) | Full
QUEUE (data-value) | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


DELETEQ TD

The DELETEQ TD function is supported.

Operand | Support
QUEUE (data-value) | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


DELETEQ TS

The DELETEQ TS function is supported.

Operand | Support
QNAME (data-value) | Full
QUEUE (data-value) | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


DEQ

The DEQ function is supported.

Operand | Support
LENGTH (data-value) | Full
LUW (cvda) | Full
MAXLIFETIME (data-value) | Full
RESOURCE (data-value) | Full
TASK (cvda) | Full
Parent topic: CICS API Calls


DOCUMENT CREATE

The DOCUMENT CREATE function is supported.

Operand | Support
BINARY (data-area) | Full
DELIMITER (data-value) | Full
DOCSIZE (data-area) | Full
DOCTOKEN (data-area) | Full
FROM (data-area) | Full
FROMDOC (data-area) | Full
HOSTCODEPAGE (data-value) | Full
LENGTH (data-value) | Full
LISTLENGTH (data-value) | Full
SYMBOLLIST (data-area) | Full
TEMPLATE (data-value) | Full
TEXT (data-area) | Full
UNESCAPED | Full
Parent topic: CICS API Calls


DOCUMENT DELETE

The DOCUMENT DELETE function is supported.

Operand | Support
DOCTOKEN (data-area) | Full
Parent topic: CICS API Calls


DOCUMENT INSERT

The DOCUMENT INSERT function is supported.

Operand | Support
AT (data-value) | Full
BINARY (data-area) | Full
BOOKMARK (data-value) | Full
DOCSIZE (data-area) | Full
DOCTOKEN (data-area) | Full
FROM (data-area) | Full
FROMDOC (data-area) | Full
HOSTCODEPAGE (data-value) | Full
LENGTH (data-value) | Full
SYMBOL (data-value) | Full
TEMPLATE (data-value) | Full
TEXT (data-area) | Full
TO (data-value) | Full
Parent topic: CICS API Calls


DOCUMENT RETRIEVE

The DOCUMENT RETRIEVE function is supported.

Operand | Support
CLNTCODEPAGE (data-value) | Full
DATAONLY | Full
DOCTOKEN (data-area) | Full
INTO (data-area) | Full
LENGTH (data-area) | Full
MAXLENGTH (data-value) | Full
Parent topic: CICS API Calls


DOCUMENT SET

The DOCUMENT SET function is supported.

Operand | Support
DELIMITER (data-value) | Full
DOCTOKEN (data-area) | Full
LENGTH (data-value) | Full
SYMBOL (data-value) | Full
SYMBOLLIST (data-area) | Full
UNESCAPED | Full
VALUE (data-area) | Full
Parent topic: CICS API Calls


DUMP

The DUMP function is supported.

Operand | Support
COMPLETE | Full
DCT | Full
DUMPCODE (data-value) | Full
FCT | Full
FLENGTH (data-value) | Full
FROM (data-area) | Full
LENGTH (data-value) | Full
PCT | Full
PPT | Full
PROGRAM | Full
SIT | Full
STORAGE | Full
TABLES | Full
TASK | Full
TCT | Full
TERMINAL | Full
Parent topic: CICS API Calls


DUMP SYSTEM

The DUMP SYSTEM function is supported.

Operand | Support
CALLER (data-value) | Full
CALLERLENGTH (data-value) | Full
DUMPCODE (data-value) | Full
DUMPID (data-area) | Full
TITLE (data-value) | Full
TITLELENGTH (data-value) | Full
Parent topic: CICS API Calls


DUMP TRANSACTION

The DUMP TRANSACTION function is supported.

Operand | Support
COMPLETE | Full
DCT | Full
DUMPCODE (data-value) | Full
DUMPID (data-area) | Full
FCT | Full
FLENGTH (data-value) | Full
FROM (data-area) | Full
LENGTH (data-value) | Full
LENGTHLIST (data-area) | Full
NUMSEGMENTS (data-area) | Full
PCT | Full
PPT | Full
PROGRAM | Full
SEGMENTLIST (data-area) | Full
SIT | Full
STORAGE | Full
TABLES | Full
TASK | Full
TCT | Full
TERMINAL | Full
TRT | Full
Parent topic: CICS API Calls


ENDBR

The ENDBR function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
REQID (data-value) | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


ENDBROWSE ACTIVITY

The ENDBROWSE ACTIVITY function is not supported.

Parent topic: CICS API Calls


ENDBROWSE CONTAINER

The ENDBROWSE CONTAINER function is supported.

Operand | Support
BROWSETOKEN (data-area) | Full
Parent topic: CICS API Calls


ENDBROWSE EVENT

The ENDBROWSE EVENT function is not supported.

Parent topic: CICS API Calls


ENDBROWSE PROCESS

The ENDBROWSE PROCESS function is not supported.

Parent topic: CICS API Calls


ENQ

The ENQ function is supported.

Operand | Support
LENGTH (data-value) | Full
LUW (cvda) | Full
MAXLIFETIME (data-value) | Full
NOSUSPEND | Full
RESOURCE (data-value) | Full
TASK (cvda) | Full
UOW (cvda) | Full
Parent topic: CICS API Calls


ENTER TRACEID

The ENTER TRACEID function is supported.

Operand | Support
ACCOUNT (data-area) | Validated
ENTRYNAME (data-value) | Validated
FROM (data-area) | Full
MONITOR | Validated
PERFORM | Validated
RESOURCE (data-value) | Validated
TRACEID (data-value) | Full
Parent topic: CICS API Calls


ENTER TRACENUM

The ENTER TRACENUM function is supported.

Operand | Support
EXCEPTION | Full
FROM (data-area) | Full
FROMLENGTH (data-value) | Full
RESOURCE (data-value) | Full
TRACENUM (data-value) | Full
Parent topic: CICS API Calls


FEPI

The FEPI function is not supported.

Parent topic: CICS API Calls


FORCE TIMER

The FORCE TIMER function is not supported.

Parent topic: CICS API Calls


FORMATTIME

The FORMATTIME function is supported.

Operand | Support
ABSTIME (data-area) | Full
DATE (data-area) | Full
DATEFORM (data-area) | Full
DATESEP (data-value) | Full
DAYCOUNT (data-area) | Full
DAYOFMONTH (data-area) | Full
DAYOFWEEK (data-area) | Full
DDMMYY (data-area) | Full
DDMMYYYY (data-area) | Full
FULLDATE (data-area) | Full
MMDDYY (data-area) | Full
MMDDYYYY (data-area) | Full
MONTHOFYEAR (data-area) | Full
TIME (data-area) | Full
TIMESEP (data-value) | Full
YEAR (data-area) | Full
YYDDD (data-area) | Full
YYDDMM (data-area) | Full
YYMMDD (data-area) | Full
YYYYDDD (data-area) | Full
YYYYDDMM (data-area) | Full
YYYYMMDD (data-area) | Full
Parent topic: CICS API Calls


FREE

The FREE function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


FREEMAIN

The FREEMAIN function is supported.

Operand | Support
DATA (data-area) | Full
DATAPOINTER (ptr-ref) | Full
Parent topic: CICS API Calls


GDS ALLOCATE

The GDS ALLOCATE function is supported.

Operand | Support
CONVID (data-area) | Full
MODENAME (data-value) | Validated
NOQUEUE | Full
PARTNER (data-value) | Validated
RETCODE (data-area) | Full
STATE (cvda) | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


GDS ASSIGN

The GDS ASSIGN function is supported.

Operand | Support
PRINCONVID (data-area) | Full
PRINSYSID (data-area) | Full
RETCODE (data-area) | Full
Parent topic: CICS API Calls


GDS CONNECT PROCESS

The GDS CONNECT PROCESS function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
PARTNER (data-value) | Validated
PIPLENGTH (data-value) | Full
PIPLIST (data-area) | Full
PROCLENGTH (data-value) | Full
PROCNAME (data-area) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
SYNCLEVEL (data-value) | Full
Parent topic: CICS API Calls


GDS EXTRACT ATTRIBUTES

The GDS EXTRACT ATTRIBUTES function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


GDS EXTRACT PROCESS

The GDS EXTRACT PROCESS function is supported.

Operand | Support
CONVID (data-area) | Full
MAXPROCLEN (data-area) | Full
PIPLENGTH (data-area) | Full
PIPLIST (ptr-ref) | Full
PROCLENGTH (data-area) | Full
PROCNAME (data-area) | Full
RETCODE (data-area) | Full
SYNCLEVEL (data-area) | Full
Parent topic: CICS API Calls


GDS FREE

The GDS FREE function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


GDS ISSUE ABEND

The GDS ISSUE ABEND function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


GDS ISSUE CONFIRMATION

The GDS ISSUE CONFIRMATION function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


GDS ISSUE ERROR

The GDS ISSUE ERROR function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


GDS ISSUE PREPARE

The GDS ISSUE PREPARE function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


GDS ISSUE SIGNAL

The GDS ISSUE SIGNAL function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


GDS RECEIVE

The GDS RECEIVE function is supported.

Operand | Support
BUFFER | Full
CONVDATA (data-area) | Full
CONVID (data-area) | Full
FLENGTH (data-area) | Full
INTO (data-area) | Full
LLID | Full
MAXFLENGTH (data-value) | Full
RETCODE (data-area) | Full
SET (ptr-ref) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


GDS SEND

The GDS SEND function is supported.

Operand | Support
CONFIRM | Full
CONVDATA (data-area) | Full
CONVID (data-value) | Full
FLENGTH (data-value) | Full
FROM (data-area) | Full
INVITE | Full
LAST | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
WAIT | Full
Parent topic: CICS API Calls


GDS WAIT

The GDS WAIT function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


GET CONTAINER

The GET CONTAINER function is supported.

Operand | Support
ACQACTIVITY | Validated
ACQPROCESS | Validated
ACTIVITY (data-value) | Validated
CHANNEL (data-value) | Full
CONTAINER (data-value) | Full
FLENGTH (data-area) | Full
INTO (data-area) | Full
INTOCCSID (data-area) | Validated
NODATA | Full
PROCESS | Validated
SET (ptr-ref) | Full
SYSTEM (cvda) | Full
USER (cvda) | Full
Parent topic: CICS API Calls


GET COUNTER

The GET COUNTER function is not supported.

Operand | Support
COMPAREMAX (data-value) | Recognized
COMPAREMIN (data-value) | Recognized
COUNTER (data-value) | Recognized
INCREMENT (data-value) | Recognized
POOL (data-value) | Recognized
REDUCE | Recognized
VALUE (data-area) | Recognized
WRAP | Recognized
Parent topic: CICS API Calls


GET DCOUNTER

The GET DCOUNTER function is not supported.

Operand | Support
COMPAREMAX (data-area) | Recognized
COMPAREMIN (data-area) | Recognized
DCOUNTER (data-value) | Recognized
INCREMENT (data-area) | Recognized
POOL (data-value) | Recognized
REDUCE | Recognized
VALUE (data-area) | Recognized
WRAP | Recognized
Parent topic: CICS API Calls


GETMAIN

The GETMAIN function is supported.

Operand | Support
BELOW | Validated
CICSDATAKEY | Validated
FLENGTH (data-value) | Full
INITIMG (data-value) | Full
LENGTH (data-value) | Full
NOSUSPEND | Full
SET (ptr-ref) | Full
SHARED | Full
USERDATAKEY | Validated
Parent topic: CICS API Calls


GETNEXT ACTIVITY

The GETNEXT ACTIVITY function is not supported.

Parent topic: CICS API Calls


GETNEXT CONTAINER

The GETNEXT CONTAINER function is supported.

Operand | Support
BROWSETOKEN (data-area) | Full
CONTAINER (data-area) | Full
Parent topic: CICS API Calls


GETNEXT EVENT

The GETNEXT EVENT function is not supported.

Parent topic: CICS API Calls


GETNEXT PROCESS

The GETNEXT PROCESS function is not supported.

Parent topic: CICS API Calls


HANDLE ABEND

The HANDLE ABEND function is supported.

Operand | Support
CANCEL | Full
LABEL (label) | Full
PROGRAM (data-value) | Full
RESET | Full
Parent topic: CICS API Calls


HANDLE AID

The HANDLE AID function is supported.

Parent topic: CICS API Calls


HANDLE CONDITION

The HANDLE CONDITION function is supported.

Parent topic: CICS API Calls


IGNORE CONDITION

The IGNORE CONDITION function is supported.

Parent topic: CICS API Calls


INVOKE SERVICE

The INVOKE SERVICE function is not supported.

Parent topic: CICS API Calls


ISSUE ABEND

The ISSUE ABEND function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


ISSUE ABORT

The ISSUE ABORT function is not supported.

Parent topic: CICS API Calls


ISSUE ADD

The ISSUE ADD function is not supported.

Parent topic: CICS API Calls


ISSUE CONFIRMATION

The ISSUE CONFIRMATION function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


ISSUE COPY

The ISSUE COPY function is not supported.

Operand | Support
CTLCHAR (data-value) | Recognized
TERMID (data-value) | Recognized
WAIT | Recognized
Parent topic: CICS API Calls


ISSUE DISCONNECT

The ISSUE DISCONNECT function is supported.

Parent topic: CICS API Calls


ISSUE END

The ISSUE END function is not supported.

Parent topic: CICS API Calls


ISSUE ENDFILE

The ISSUE ENDFILE function is not supported.

Parent topic: CICS API Calls


ISSUE ENDOUTPUT

The ISSUE ENDOUTPUT function is not supported.

Parent topic: CICS API Calls


ISSUE EODS

The ISSUE EODS function is not supported.

Parent topic: CICS API Calls


ISSUE ERASE

The ISSUE ERASE function is not supported.

Parent topic: CICS API Calls


ISSUE ERASEAUP

The ISSUE ERASEAUP function is supported.

Operand | Support
WAIT | Full
Parent topic: CICS API Calls


ISSUE ERROR

The ISSUE ERROR function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


ISSUE LOAD

The ISSUE LOAD function is not supported.

Parent topic: CICS API Calls


ISSUE NOTE

The ISSUE NOTE function is not supported.

Parent topic: CICS API Calls


ISSUE PASS

The ISSUE PASS function is not supported.

Operand | Support
FROM (data-area) | Recognized
LENGTH (data-value) | Recognized
LOGMODE (data-value) | Recognized
LOGONLOGMODE | Recognized
LUNAME (data-value) | Recognized
NOQUIESCE | Recognized
Parent topic: CICS API Calls


ISSUE PREPARE

The ISSUE PREPARE function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


ISSUE PRINT

The ISSUE PRINT function is supported.

Parent topic: CICS API Calls


ISSUE QUERY

The ISSUE QUERY function is not supported.

Parent topic: CICS API Calls


ISSUE RECEIVE

The ISSUE RECEIVE function is not supported.

Parent topic: CICS API Calls


ISSUE REPLACE

The ISSUE REPLACE function is not supported.

Parent topic: CICS API Calls


ISSUE RESET

The ISSUE RESET function is supported.

Parent topic: CICS API Calls


ISSUE SEND

The ISSUE SEND function is not supported.

Parent topic: CICS API Calls


ISSUE SIGNAL

The ISSUE SIGNAL function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


ISSUE WAIT

The ISSUE WAIT function is not supported.

Parent topic: CICS API Calls


JOURNAL

The JOURNAL function is supported.

Operand | Support
FROM (data-area) | Full
JFILEID (data-value) | Full
JOURNALNUM (data-value) | Full
JTYPEID (data-value) | Full
LENGTH (data-value) | Full
NOSUSPEND | Full
PFXLENG (data-value) | Full
PREFIX (data-area) | Full
REQID (data-area) | Full
STARTIO | Full
WAIT | Full
Parent topic: CICS API Calls


LINK

The LINK function is supported.

Operand | Support
CHANNEL (data-value) | Full
COMMAREA (data-area) | Full
DATALENGTH (data-value) | Full
INPUTMSG (data-area) | Full
INPUTMSGLEN (data-value) | Full
LENGTH (data-value) | Full
PROGRAM (data-value) | Full
SYNCONRETURN | Full
SYSID (data-value) | Full
TRANSID (data-value) | Full
Parent topic: CICS API Calls


LINK ACQACTIVITY

The LINK ACQACTIVITY function is not supported.

Parent topic: CICS API Calls


LINK ACQPROCESS

The LINK ACQPROCESS function is not supported.

Parent topic: CICS API Calls


LINK ACTIVITY

The LINK ACTIVITY function is not supported.

Parent topic: CICS API Calls


LOAD

The LOAD function is supported.

Operand | Support
ENTRY (ptr-ref) | Full
FLENGTH (data-area) | Full
HOLD | Full
LENGTH (data-area) | Full
PROGRAM (data-value) | Full
SET (ptr-ref) | Full
Parent topic: CICS API Calls


MONITOR

The MONITOR function is not supported.

Operand | Support
DATA1 (data-area) | Recognized
DATA2 (data-area) | Recognized
ENTRYNAME (data-area) | Recognized
POINT (data-value) | Recognized
Parent topic: CICS API Calls


MOVE CONTAINER

The MOVE CONTAINER function is supported.

Operand | Support
AS (data-value) | Full
CHANNEL (data-value) | Full
CONTAINER (data-value) | Full
TOCHANNEL (data-value) | Full
Parent topic: CICS API Calls


POINT

The POINT function is not supported.

Parent topic: CICS API Calls


POP

The POP function is supported.

Parent topic: CICS API Calls


POP HANDLE

The POP HANDLE function is supported.

Parent topic: CICS API Calls


POST

The POST function is supported.

Operand | Support
AFTER | Full
AT | Full
HOURS (data-value) | Full
INTERVAL (data-value) | Full
MINUTES (data-value) | Full
REQID (data-value) | Full
SECONDS (data-value) | Full
SET (ptr-ref) | Full
TIME (data-value) | Full
Parent topic: CICS API Calls


PURGE MESSAGE

The PURGE MESSAGE function is supported.

Parent topic: CICS API Calls


PUSH

The PUSH function is supported.

Parent topic: CICS API Calls


PUSH HANDLE

The PUSH HANDLE function is supported.

Parent topic: CICS API Calls


PUT CONTAINER

The PUT CONTAINER function is supported.

Operand | Support
ACQACTIVITY | Validated
ACQPROCESS | Validated
ACTIVITY (data-value) | Validated
BIT (cvda) | Full
CHANNEL (data-value) | Full
CHAR (cvda) | Full
CONTAINER (data-value) | Full
DATATYPE (data-value) | Full
FLENGTH (data-area) | Full
FROM (data-area) | Full
FROMCCSID (data-area) | Validated
PROCESS | Validated
SYSTEM (cvda) | Full
USER (cvda) | Full
Parent topic: CICS API Calls


QUERY COUNTER

The QUERY COUNTER function is not supported.

Operand | Support
COUNTER (data-value) | Recognized
MAXIMUM (data-area) | Recognized
MINIMUM (data-area) | Recognized
POOL (data-value) | Recognized
VALUE (data-area) | Recognized
Parent topic: CICS API Calls


QUERY DCOUNTER

The QUERY DCOUNTER function is not supported.

Operand | Support
DCOUNTER (data-value) | Recognized
MAXIMUM (data-area) | Recognized
MINIMUM (data-area) | Recognized
POOL (data-value) | Recognized
VALUE (data-area) | Recognized
Parent topic: CICS API Calls


QUERY SECURITY

The QUERY SECURITY function is supported.

Operand | Support
ALTER (data-area) | Full
CONTROL (data-area) | Full
LOG (cvda) | Full
LOGMESSAGE (data-value) | Full
NOLOG (cvda) | Full
READ (data-area) | Full
RESCLASS (data-value) | Full
RESID (data-value) | Full
RESIDLENGTH (data-value) | Full
RESTYPE (data-value) | Full
UPDATE (data-area) | Full
Parent topic: CICS API Calls


READ

The READ function is supported.

Operand | Support
CONSISTENT | Validated
DATASET (data-value) | Full
DEBKEY | Validated
DEBREC | Validated
EQUAL | Full
FILE (data-value) | Full
GENERIC | Full
GTEQ | Full
INTO (data-area) | Full
KEYLENGTH (data-value) | Full
LENGTH (data-area) | Full
NOSUSPEND | Full
RBA | Full
REPEATABLE | Validated
RIDFLD (data-area) | Full
RRN | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full
UNCOMMITTED | Validated
UPDATE | Full
XRBA | Full
Parent topic: CICS API Calls


READNEXT

The READNEXT function is supported.

Operand | Support
CONSISTENT | Validated
DATASET (data-value) | Full
FILE (data-value) | Full
INTO (data-area) | Full
KEYLENGTH (data-value) | Full
LENGTH (data-area) | Full
RBA | Full
REPEATABLE | Validated
REQID (data-value) | Full
RIDFLD (data-area) | Full
RRN | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full
UNCOMMITTED | Validated
UPDATE | Full
XRBA | Full
Parent topic: CICS API Calls


READPREV

The READPREV function is supported.

Operand | Support
CONSISTENT | Validated
DATASET (data-value) | Full
FILE (data-value) | Full
INTO (data-area) | Full
KEYLENGTH (data-value) | Full
LENGTH (data-area) | Full
RBA | Full
REPEATABLE | Validated
REQID (data-value) | Full
RIDFLD (data-area) | Full
RRN | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full
UNCOMMITTED | Validated
UPDATE | Full
XRBA | Full
Parent topic: CICS API Calls


READQ

The READQ function is supported.

Operand | Support
INTO (data-area) | Full
ITEM (data-value) | Full
LENGTH (data-area) | Full
NEXT | Full
NUMITEMS (data-area) | Full
QNAME (data-value) | Full
QUEUE (data-value) | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


READQ TD

The READQ TD function is supported.

Operand | Support
INTO (data-area) | Full
LENGTH (data-area) | Full
NOSUSPEND | Full
QUEUE (data-value) | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


READQ TS

The READQ TS function is supported.

Operand | Support
INTO (data-area) | Full
ITEM (data-value) | Full
LENGTH (data-area) | Full
NEXT | Full
NUMITEMS (data-area) | Full
QNAME (data-value) | Full
QUEUE (data-value) | Full
SET (ptr-ref) | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


RECEIVE

The RECEIVE function is supported.

Operand | Support
ASIS | Full
BUFFER | Full
CONVID (data-value) | Full
FLENGTH (data-area) | Full
INTO (data-area) | Full
LEAVEKB | Validated
LENGTH (data-area) | Full
MAXFLENGTH (data-value) | Full
MAXLENGTH (data-value) | Full
NOTRUNCATE | Full
SESSION (data-value) | Full
SET (ptr-ref) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


RECEIVE MAP

The RECEIVE MAP function is supported.

Operand | Support
ASIS | Full
FROM (data-area) | Full
INPARTN (data-value) | Validated
INTO (data-area) | Full
LENGTH (data-value) | Full
MAP (data-value) | Full
MAPSET (data-value) | Full
SET (ptr-ref) | Full
TERMINAL | Full
Parent topic: CICS API Calls


RECEIVE MAP MAPPINGDEV

The RECEIVE MAP MAPPINGDEV function is not supported.

Operand | Support
AID (data-area) | Recognized
CURSOR (data-value) | Recognized
FROM (data-area) | Recognized
INTO (data-area) | Recognized
LENGTH (data-value) | Recognized
MAP (data-value) | Recognized
MAPPINGDEV (data-value) | Recognized
MAPSET (data-value) | Recognized
SET (ptr-ref) | Recognized
Parent topic: CICS API Calls


RECEIVE MAPSET

The RECEIVE MAPSET function is supported.

Operand | Support
ASIS | Full
FROM (data-area) | Full
INPARTN (data-value) | Validated
INTO (data-area) | Full
LENGTH (data-value) | Full
MAP (data-value) | Full
MAPSET (data-value) | Full
SET (ptr-ref) | Full
TERMINAL | Full
Parent topic: CICS API Calls


RECEIVE PARTN

The RECEIVE PARTN function is not supported.

Operand | Support
ASIS | Recognized
INTO (data-area) | Recognized
LENGTH (data-area) | Recognized
PARTN (data-area) | Recognized
SET (ptr-ref) | Recognized
Parent topic: CICS API Calls


RELEASE

The RELEASE function is supported.

Operand | Support
PROGRAM (data-value) | Full
Parent topic: CICS API Calls


REMOVE SUBEVENT

The REMOVE SUBEVENT function is not supported.

Parent topic: CICS API Calls


RESET ACQPROCESS

The RESET ACQPROCESS function is not supported.

Parent topic: CICS API Calls


RESET ACTIVITY

The RESET ACTIVITY function is not supported.

Parent topic: CICS API Calls


RESETBR

The RESETBR function is supported.

Operand | Support
DATASET (data-value) | Full
EQUAL | Full
FILE (data-value) | Full
GENERIC | Full
GTEQ | Full
KEYLENGTH (data-value) | Full
RBA | Full
REQID (data-value) | Full
RIDFLD (data-area) | Full
RRN | Full
SYSID (data-value) | Full
XRBA | Full
Parent topic: CICS API Calls


RESUME

The RESUME function is not supported.

Parent topic: CICS API Calls


RETRIEVE

The RETRIEVE function is supported.

Operand | Support
INTO (data-area) | Full
LENGTH (data-area) | Full
QUEUE (data-area) | Full
RTERMID (data-area) | Full
RTRANSID (data-area) | Full
SET (ptr-ref) | Full
WAIT | Full
Parent topic: CICS API Calls


RETRIEVE REATTACH

The RETRIEVE REATTACH function is not supported.

Parent topic: CICS API Calls


RETRIEVE SUBEVENT

The RETRIEVE SUBEVENT function is not supported.

Parent topic: CICS API Calls


RETURN

The RETURN function is supported.

Operand | Support
CHANNEL (data-value) | Full
COMMAREA (data-area) | Full
ENDACTIVITY | Validated
IMMEDIATE | Full
INPUTMSG (data-area) | Full
INPUTMSGLEN (data-value) | Full
LENGTH (data-value) | Full
TRANSID (data-value) | Full
Parent topic: CICS API Calls


REWIND COUNTER

The REWIND COUNTER function is not supported.

Operand | Support
COUNTER (data-value) | Recognized
INCREMENT (data-value) | Recognized
POOL (data-value) | Recognized
Parent topic: CICS API Calls


REWIND DCOUNTER

The REWIND DCOUNTER function is not supported.

Operand | Support
DCOUNTER (data-value) | Recognized
INCREMENT (data-area) | Recognized
POOL (data-value) | Recognized
Parent topic: CICS API Calls


REWRITE

The REWRITE function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
FROM (data-area) | Full
LENGTH (data-value) | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full
Parent topic: CICS API Calls


ROUTE

The ROUTE function is not supported.

Operand | Support
AFTER | Recognized
AT | Recognized
ERRTERM (data-value) | Recognized
HOURS (data-value) | Recognized
INTERVAL (data-value) | Recognized
LDC (data-value) | Recognized
LIST (data-area) | Recognized
MINUTES (data-value) | Recognized
NLEOM | Recognized
OPCLASS (data-area) | Recognized
REQID (data-value) | Recognized
SECONDS (data-value) | Recognized
TIME (data-value) | Recognized
TITLE (data-area) | Recognized
Parent topic: CICS API Calls


RUN

The RUN function is not supported.

Parent topic: CICS API Calls


SEND

The SEND function is supported.

Operand | Support
ALTERNATE | Full
ATTACHID (data-value) | Validated
CNOTCOMPL | Validated
CONFIRM | Full
CONVID (data-value) | Full
CTLCHAR (data-value) | Full
DEFAULT | Full
DEFRESP | Validated
DEST (data-value) | Validated
ERASE | Full
FLENGTH (data-value) | Full
FMH | Full
FROM (data-area) | Full
INVITE | Full
LAST | Full
LEAVEKB | Validated
LENGTH (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
STRFIELD | Full
WAIT | Full
Parent topic: CICS API Calls


SEND CONTROL

The SEND CONTROL function is supported.

Operand | Support
ACCUM | Full
ACTPARTN (data-value) | Validated
ALARM | Full
ALTERNATE | Full
CURSOR (data-value) | Full
DEFAULT | Full
ERASE | Full
ERASEAUP | Full
FORMFEED | Full
FREEKB | Full
FRSET | Full
HONEOM | Full
L40 | Full
L64 | Full
L80 | Full
LAST | Full
LDC (data-value) | Validated
MSR (data-value) | Validated
OUTPARTN (data-value) | Validated
PAGING | Full
PRINT | Full
REQID (data-value) | Validated
SET (ptr-ref) | Full
TERMINAL | Full
WAIT | Full
Parent topic: CICS API Calls


SEND MAP

The SEND MAP function is supported.

Operand | Support
ACCUM | Full
ACTPARTN (data-value) | Validated
ALARM | Full
ALTERNATE | Full
CURSOR (data-value) | Full
DATAONLY | Full
DEFAULT | Full
ERASE | Full
ERASEAUP | Full
FMHPARM | Validated
FORMFEED | Full
FREEKB | Full
FROM (data-area) | Full
FRSET | Full
HONEOM | Full
L40 | Full
L64 | Full
L80 | Full
LAST | Full
LDC (data-value) | Validated
LENGTH (data-value) | Full
MAP (data-value) | Full
MAPONLY | Full
MAPSET (data-value) | Full
MSR (data-value) | Validated
NLEOM | Full
NOFLUSH | Validated
OUTPARTN (data-value) | Validated
PAGING | Full
PRINT | Full
REQID (data-value) | Validated
SET (ptr-ref) | Full
TERMINAL | Full
WAIT | Full
Parent topic: CICS API Calls


SEND MAP MAPPINGDEV

The SEND MAP MAPPINGDEV function is not supported.

Operand | Support
ALARM | Recognized
CURSOR (data-value) | Recognized
DATAONLY | Recognized
ERASE | Recognized
ERASEAUP | Recognized
FORMFEED | Recognized
FREEKB | Recognized
FROM (data-area) | Recognized
FRSET | Recognized
LENGTH (data-value) | Recognized
MAP (data-value) | Recognized
MAPONLY | Recognized
MAPPINGDEV (data-value) | Recognized
MAPSET (data-value) | Recognized
PRINT | Recognized
SET (ptr-ref) | Recognized
Parent topic: CICS API Calls


SEND MAPSET

The SEND MAPSET function is supported.

Operand | Support
ACCUM | Full
ACTPARTN (data-value) | Validated
ALARM | Full
ALTERNATE | Full
CURSOR (data-value) | Full
DATAONLY | Full
DEFAULT | Full
ERASE | Full
ERASEAUP | Full
FMHPARM | Validated
FORMFEED | Full
FREEKB | Full
FROM (data-area) | Full
FRSET | Full
HONEOM | Full
L40 | Full
L64 | Full
L80 | Full
LAST | Full
LDC (data-value) | Validated
LENGTH (data-value) | Full
MAP (data-value) | Full
MAPONLY | Full
MAPSET (data-value) | Full
MSR (data-value) | Validated
NLEOM | Full
NOFLUSH | Validated
OUTPARTN (data-value) | Validated
PAGING | Full
PRINT | Full
REQID (data-value) | Validated
SET (ptr-ref) | Full
TERMINAL | Full
WAIT | Full
Parent topic: CICS API Calls


SEND PAGE

The SEND PAGE function is supported.

Operand | Support
ALL | Validated
AUTOPAGE | Full
CURRENT | Validated
FMHPARM (data-value) | Validated
LAST | Full
NOAUTOPAGE | Full
OPERPURGE | Full
RELEASE | Full
RETAIN | Full
SET (ptr-ref) | Full
TRAILER (data-area) | Full
TRANSID (data-value) | Full
Parent topic: CICS API Calls


SEND PARTNSET

The SEND PARTNSET function is not supported.

Operand | Support
PARTNSET (data-value) | Recognized
Parent topic: CICS API Calls


SEND TEXT

The SEND TEXT function is supported.

Operand | Support
ACCUM | Full
ACTPARTN (data-value) | Validated
ALARM | Full
ALTERNATE | Full
CURSOR (data-value) | Full
DEFAULT | Full
ERASE | Full
FMHPARM (data-value) | Validated
FORMFEED | Full
FREEKB | Full
FROM (data-area) | Full
HEADER (data-area) | Full
HONEOM | Full
JUSFIRST (cvda) | Full
JUSLAST (cvda) | Full
JUSTIFY (data-value) | Full
L40 | Full
L64 | Full
L80 | Full
LAST | Full
LDC (data-value) | Validated
LENGTH (data-value) | Full
MSR (data-value) | Validated
NLEOM | Full
OUTPARTN (data-value) | Validated
PAGING | Full
PRINT | Full
REQID (data-value) | Validated
SET (ptr-ref) | Full
TERMINAL | Full
TRAILER (data-area) | Full
WAIT | Full
Parent topic: CICS API Calls


SEND TEXT MAPPED

The SEND TEXT MAPPED function is supported.

Operand | Support
FROM (data-area) | Full
LAST | Full
LENGTH (data-value) | Full
PAGING | Full
REQID (data-value) | Validated
TERMINAL | Full
WAIT | Full
Parent topic: CICS API Calls


SEND TEXT NOEDIT

The SEND TEXT NOEDIT function is supported.

Operand | Support
ALARM | Full
ALTERNATE | Full
CURSOR (data-value) | Validated
DEFAULT | Full
ERASE | Full
FREEKB | Full
FROM (data-area) | Full
HONEOM | Full
L40 | Full
L64 | Full
L80 | Full
LAST | Full
LENGTH (data-value) | Full
OUTPARTN (data-value) | Validated
PAGING | Full
PRINT | Full
REQID (data-value) | Validated
TERMINAL | Full
WAIT | Full
Parent topic: CICS API Calls


SIGNAL EVENT

The SIGNAL EVENT function is not supported.

Parent topic: CICS API Calls


SIGNOFF

The SIGNOFF function is supported.

Parent topic: CICS API Calls


SIGNON

The SIGNON function is supported.

Operand | Support
ESMREASON (data-area) | Full
ESMRESP (data-area) | Full
GROUPID (data-value) | Full
LANGINUSE (data-area) | Validated
LANGUAGECODE (data-value) | Validated
NATLANG (data-value) | Validated
NATLANGINUSE (data-area) | Validated
NEWPASSWORD (data-value) | Full
NEWPHRASE (data-area) | Validated
NEWPHRASELEN (data-value) | Validated
OIDCARD (data-value) | Validated
PASSWORD (data-value) | Full
PHRASE (data-area) | Validated
PHRASELEN (data-value) | Validated
USERID (data-value) | Full
Parent topic: CICS API Calls


SOAPFAULT ADD

The SOAPFAULT ADD function is not supported.

Parent topic: CICS API Calls


SOAPFAULT CREATE

The SOAPFAULT CREATE function is not supported.

Parent topic: CICS API Calls


SOAPFAULT DELETE

The SOAPFAULT DELETE function is not supported.

Parent topic: CICS API Calls


SPOOLCLOSE

The SPOOLCLOSE function is supported.

Operand | Support
DELETE | Full
KEEP | Full
TOKEN (data-value) | Full
Parent topic: CICS API Calls


SPOOLCLOSE REPORT

The SPOOLCLOSE REPORT function is supported.

Operand | Support
DELETE | Full
DISP (data-value) | Full
HOLD | Full
KEEP | Full
LOG | Validated
RELEASE | Full
REPORT (data-value) | Full
RESUME | Validated
TOKEN (data-value) | Full
Parent topic: CICS API Calls


SPOOLOPEN ESCAPE

The SPOOLOPEN ESCAPE function is not supported.

Parent topic: CICS API Calls


SPOOLOPEN INPUT

The SPOOLOPEN INPUT function is not supported.

Operand | Support
CLASS (data-value) | Recognized
TOKEN (data-area) | Recognized
USERID (data-value) | Recognized
Parent topic: CICS API Calls


SPOOLOPEN MAPNAME

The SPOOLOPEN MAPNAME function is not supported.

Parent topic: CICS API Calls


SPOOLOPEN OUTPUT

The SPOOLOPEN OUTPUT function is supported.

Operand | Support
ASA | Full
CLASS (data-value) | Full
MCC | Full
NOCC | Full
NODE (data-value) | Full
OUTDESCR (ptr-ref) | Partial: handles USERID and recognizes other values
PRINT | Full
PUNCH | Full
RECORDLENGTH (data-value) | Full
TOKEN (data-area) | Full
USERID (data-value) | Partial: handles * and recognizes other values
Parent topic: CICS API Calls


SPOOLOPEN REPORT ASA

The SPOOLOPEN REPORT ASA function is supported.

Operand | Support
ASA | Full
BOTHNUM | Validated
CLASS (data-value) | Full
COPIES | Validated
DATETIME | Validated
DESTINATION | Validated
FCB | Validated
FOOT (data-area) | Validated
FOOTNUM | Validated
FORMS | Validated
HEAD (data-area) | Validated
HEADNUM | Validated
LINELENGTH (data-value) | Full
LINES | Validated
LOG | Validated
LOGICAL | Validated
MCC | Full
NOCC | Full
NODE (data-value) | Full
NONUM | Validated
NOSEP | Validated
OUTDESCR (ptr-ref) | Full
PHYSICAL | Validated
PRINTFAIL | Validated
PRIORITY | Validated
PWRSYSID | Validated
REPORT (data-value) | Full
RSL | Validated
SEP | Validated
SOSI1 | Validated
SOSI2 | Validated
TITLE (data-area) | Validated
TOKEN (data-area) | Full
USERDATA | Validated
USERID (data-value) | Full
Parent topic: CICS API Calls


SPOOLOPEN REPORT JCL

The SPOOLOPEN REPORT JCL function is supported.

Operand | Support
JCL | Full
LOG | Validated
REPORT (data-value) | Full
TOKEN (data-area) | Full
Parent topic: CICS API Calls


SPOOLOPEN REPORT MCC

The SPOOLOPEN REPORT MCC function is supported.

Operand | Support
ASA | Full
BOTHNUM | Validated
CLASS (data-value) | Full
COPIES | Validated
DATETIME | Validated
DESTINATION | Validated
FCB | Validated
FOOT (data-area) | Validated
FOOTNUM | Validated
FORMS | Validated
HEAD (data-area) | Validated
HEADNUM | Validated
LINELENGTH (data-value) | Full
LINES | Validated
LOG | Validated
LOGICAL | Validated
MCC | Full
NOCC | Full
NODE (data-value) | Full
NONUM | Validated
NOSEP | Validated
OUTDESCR (ptr-ref) | Full
PHYSICAL | Validated
PRINTFAIL | Validated
PRIORITY | Validated
PWRSYSID | Validated
REPORT (data-value) | Full
RSL | Validated
SEP | Validated
SOSI1 | Validated
SOSI2 | Validated
TITLE (data-area) | Validated
TOKEN (data-area) | Full
USERDATA | Validated
USERID (data-value) | Full
Parent topic: CICS API Calls


SPOOLOPEN REPORT NOCC

The SPOOLOPEN REPORT NOCC function is supported.

Operand | Support
ASA | Full
BOTHNUM | Validated
CLASS (data-value) | Full
COPIES | Validated
DATETIME | Validated
DESTINATION | Validated
FCB | Validated
FOOT (data-area) | Validated
FOOTNUM | Validated
FORMS | Validated
HEAD (data-area) | Validated
HEADNUM | Validated
LINELENGTH (data-value) | Full
LINES | Validated
LOG | Validated
LOGICAL | Validated
MCC | Full
NOCC | Full
NODE (data-value) | Full
NONUM | Validated
NOSEP | Validated
OUTDESCR (ptr-ref) | Full
PHYSICAL | Validated
PRINTFAIL | Validated
PRIORITY | Validated
PWRSYSID | Validated
REPORT (data-value) | Full
RSL | Validated
SEP | Validated
SOSI1 | Validated
SOSI2 | Validated
TITLE (data-area) | Validated
TOKEN (data-area) | Full
USERDATA | Validated
USERID (data-value) | Full
Parent topic: CICS API Calls


SPOOLOPEN REPORT SCS

The SPOOLOPEN REPORT SCS function is not supported.

Parent topic: CICS API Calls


SPOOLOPEN REPORT T3270

The SPOOLOPEN REPORT T3270 function is not supported.

Parent topic: CICS API Calls


SPOOLOPEN RESUME

The SPOOLOPEN RESUME function is not supported.

Parent topic: CICS API Calls


SPOOLREAD

The SPOOLREAD function is not supported.

Operand | Support
INTO (data-area) | Recognized
MAXFLENGTH (data-value) | Recognized
TOFLENGTH (data-value) | Recognized
TOKEN (data-value) | Recognized
Parent topic: CICS API Calls


SPOOLWRITE

The SPOOLWRITE function is supported.

Operand | Support
FLENGTH (data-value) | Full
FROM (data-area) | Full
LINE | Full
PAGE | Full
TOKEN (data-value) | Full
Parent topic: CICS API Calls


SPOOLWRITE MAPNAME

The SPOOLWRITE MAPNAME function is not supported.

Parent topic: CICS API Calls


SPOOLWRITE REPORT

The SPOOLWRITE REPORT function is supported.

Operand | Support
FLENGTH (data-value) | Full
FROM (data-area) | Full
LOG | Validated
REPORT (data-value) | Full
TOKEN (data-value) | Full
Parent topic: CICS API Calls


START

The START function is supported.

Operand | Support
AFTER | Full
AT | Full
FMH | Validated
FROM (data-area) | Full
HOURS (data-value) | Full
INTERVAL (data-value) | Full
LENGTH (data-value) | Full
MINUTES (data-value) | Full
NOCHECK | Full
PROTECT | Full
QUEUE (data-value) | Full
REQID (data-value) | Full
RTERMID (data-value) | Full
RTRANSID (data-value) | Full
SECONDS (data-value) | Full
SYSID (data-value) | Full
TERMID (data-value) | Full
TIME (data-value) | Full
TRANSID (data-value) | Full
USERID (data-value) | Full
Parent topic: CICS API Calls


START ATTACH

The START ATTACH function is not supported.

Operand | Support
FROM (data-area) | Recognized
LENGTH (data-value) | Recognized
TRANSID (data-value) | Recognized
Parent topic: CICS API Calls


START BREXIT

The START BREXIT function is supported.

Operand | Support
BRDATA (data-area) | Full
BRDATALENGTH (data-area) | Full
BREXIT (data-value) | Full
TRANSID (data-value) | Full
USERID (data-value) | Full
Parent topic: CICS API Calls


START CHANNEL

The START CHANNEL function is supported.

Operand | Support
CHANNEL (data-value) | Full
SYSID (data-value) | Full
TERMID (data-value) | Full
TRANSID (data-value) | Full
USERID (data-value) | Full
Parent topic: CICS API Calls


STARTBR

The STARTBR function is supported.

Operand | Support
DATASET (data-value) | Full
DEBKEY | Validated
DEBREC | Validated
EQUAL | Full
FILE (data-value) | Full
GENERIC | Full
GTEQ | Full
KEYLENGTH (data-value) | Full
RBA | Full
REQID (data-value) | Full
RIDFLD (data-area) | Full
RRN | Full
SYSID (data-value) | Full
XRBA | Full
Parent topic: CICS API Calls


STARTBROWSE ACTIVITY

The STARTBROWSE ACTIVITY function is not supported.

Parent topic: CICS API Calls


STARTBROWSE CONTAINER

The STARTBROWSE CONTAINER function is supported.

Operand | Support
ACTIVITYID (data-value) | Validated
BROWSETOKEN (data-area) | Full
CHANNEL (data-value) | Full
PROCESS (data-value) | Validated
PROCESSTYPE (data-value) | Validated
Parent topic: CICS API Calls


STARTBROWSE EVENT

The STARTBROWSE EVENT function is not supported.

Parent topic: CICS API Calls


STARTBROWSE PROCESS

The STARTBROWSE PROCESS function is not supported.

Parent topic: CICS API Calls


SUSPEND

The SUSPEND function is supported.

Parent topic: CICS API Calls


SYNCPOINT

The SYNCPOINT function is supported.

Operand | Support
ROLLBACK | Full
Parent topic: CICS API Calls


TEST EVENT

The TEST EVENT function is not supported.

Parent topic: CICS API Calls


TRACE

The TRACE function is not supported.

Parent topic: CICS API Calls


TRANSFORM DATATOXML

The TRANSFORM DATATOXML function is not supported.

Parent topic: CICS API Calls


TRANSFORM XMLTODATA

The TRANSFORM XMLTODATA function is not supported.

Parent topic: CICS API Calls


UNLOCK

The UNLOCK function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
SYSID (data-value) | Full
TOKEN (data-area) | Full
Parent topic: CICS API Calls


UPDATE COUNTER

The UPDATE COUNTER function is not supported.

Operand | Support
COMPAREMAX (data-value) | Recognized
COMPAREMIN (data-value) | Recognized
COUNTER (data-value) | Recognized
POOL (data-value) | Recognized
VALUE (data-value) | Recognized
Parent topic: CICS API Calls


UPDATE DCOUNTER

The UPDATE DCOUNTER function is not supported.

Operand | Support
COMPAREMAX (data-area) | Recognized
COMPAREMIN (data-area) | Recognized
DCOUNTER (data-value) | Recognized
POOL (data-value) | Recognized
VALUE (data-area) | Recognized
Parent topic: CICS API Calls


VERIFY PASSWORD

The VERIFY PASSWORD function is supported.

Operand | Support
CHANGETIME (data-area) | Full
DAYSLEFT (data-area) | Full
ESMREASON (data-area) | Full
ESMRESP (data-area) | Full
EXPIRYTIME (data-area) | Full
INVALIDCOUNT (data-area) | Full
LASTUSETIME (data-area) | Full
PASSWORD (data-value) | Full
USERID (data-value) | Full
Parent topic: CICS API Calls


WAIT CONVID

The WAIT CONVID function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
Parent topic: CICS API Calls


WAIT EVENT

The WAIT EVENT function is supported.

Operand | Support
ECADDR (ptr-ref) | Full
NAME (data-value) | Full
Parent topic: CICS API Calls


WAIT EXTERNAL

The WAIT EXTERNAL function is not supported.

Operand | Support
ECBLIST (data-area) | Recognized
NAME (data-value) | Recognized
NOTPURGEABLE (cvda) | Recognized
NUMEVENTS (data-value) | Recognized
PURGEABILITY (data-value) | Recognized
PURGEABLE (cvda) | Recognized
Parent topic: CICS API Calls


WAIT JOURNAL

The WAIT JOURNAL function is supported.

Operand | Support
JFILEID (data-value) | Full
JOURNALNUM (data-value) | Full
REQID (data-value) | Full
STARTIO | Full
Parent topic: CICS API Calls


WAIT JOURNALNAME

The WAIT JOURNALNAME function is not supported.

Operand | Support
JOURNALNAME (data-value) | Recognized
REQID (data-value) | Recognized
Parent topic: CICS API Calls


WAIT JOURNALNUM

The WAIT JOURNALNUM function is supported.

Operand | Support
JFILEID (data-value) | Full
JOURNALNUM (data-value) | Full
REQID (data-value) | Full
STARTIO | Full
Parent topic: CICS API Calls


WAIT SIGNAL

The WAIT SIGNAL function is not supported.

Parent topic: CICS API Calls


WAIT TERMINAL

The WAIT TERMINAL function is not supported.

Parent topic: CICS API Calls


WAITCICS

The WAITCICS function is supported.

Operand | Support
ECBLIST (data-area) | Full
NAME (data-value) | Full
NOTPURGEABLE (cvda) | Full
NUMEVENTS (data-value) | Full
PURGEABILITY (data-value) | Full
PURGEABLE (cvda) | Full
Parent topic: CICS API Calls


WEB CLOSE

The WEB CLOSE function is supported.

Operand | Support
SESSTOKEN (data-area) | Full
Parent topic: CICS API Calls


WEB CONVERSE

The WEB CONVERSE function is supported.

Operand | Support
ACTION (data-value) | Full
AUTHENTICATE (data-value) | Full
BASICAUTH (cvda) | Full
BODYCHARSET (data-area) | Full
CHANNEL (data-value) | Full
CHARACTERSET (data-value) | Full
CLICONVERT (cvda) | Full
CLIENTCONV (data-value) | Full
CLOSE (cvda) | Full
CLOSESTATUS (data-value) | Full
CONTAINER (data-value) | Full
DELETE (cvda) | Full
DOCDELETE (cvda) | Full
DOCSTATUS (data-value) | Full
DOCTOKEN (data-value) | Full
EXPECT (cvda) | Full
FROM (data-area) | Full
FROMLENGTH (data-value) | Full
GET (cvda) | Full
HEAD (cvda) | Full
INTO (data-area) | Full
MAXLENGTH (data-value) | Full
MEDIATYPE (data-value) | Full
METHOD (data-value) | Full
NOCLICONVERT (cvda) | Full
NOCLOSE (cvda) | Full
NODOCDELETE (cvda) | Full
NOINCONVERT (cvda) | Full
NONE (cvda) | Full
NOOUTCONVERT (cvda) | Full
NOTRUNCATE | Full
OPTIONS (cvda) | Full
PASSWORD (data-area) | Full
PASSWORDLEN (data-value) | Full
PATH (data-area) | Full
PATHLENGTH (data-value) | Full
POST (cvda) | Full
PUT (cvda) | Full
QUERYSTRING (data-area) | Full
QUERYSTRLEN (data-value) | Full
SESSTOKEN (data-area) | Full
SET (ptr-ref) | Full
STATUSCODE (data-value) | Full
STATUSLEN (data-value) | Full
STATUSTEXT (data-area) | Full
TOCHANNEL (data-value) | Full
TOCONTAINER (data-value) | Full
TOLENGTH (data-area) | Full
TRACE (cvda) | Full
URIMAP (data-value) | Full
USERNAME (data-area) | Full
USERNAMELEN (data-value) | Full
Parent topic: CICS API Calls


WEB ENDBROWSE FORMFIELD

The WEB ENDBROWSE FORMFIELD function is supported.

Operand | Support
FORMFIELD | Full
Parent topic: CICS API Calls


WEB ENDBROWSE HTTPHEADER

The WEB ENDBROWSE HTTPHEADER function is supported.

Operand | Support
HTTPHEADER | Full
SESSTOKEN (data-area) | Full
Parent topic: CICS API Calls


WEB ENDBROWSE QUERYPARM

The WEB ENDBROWSE QUERYPARM function is supported.

Operand | Support
QUERYPARM | Full
Parent topic: CICS API Calls


WEB EXTRACT

The WEB EXTRACT function is supported.

Operand | Support
HOST (data-area) | Full
HOSTLENGTH (data-value) | Full
HOSTTYPE (data-value) | Full
HTTPMETHOD (data-area) | Full
HTTPVERSION (data-area) | Full
METHODLENGTH (data-value) | Full
PATH (data-area) | Full
PATHLENGTH (data-value) | Full
PORTNUMBER (data-area) | Full
QUERYSTRING (data-area) | Full
QUERYSTRLEN (data-value) | Full
REALM (data-area) | Full
REALMLEN (data-value) | Full
REQUESTTYPE (cvda) | Full
SCHEME (cvda) | Full
SESSTOKEN (data-area) | Full
URIMAP (data-area) | Full
VERSIONLEN (data-value) | Full
Parent topic: CICS API Calls


WEB OPEN

The WEB OPEN function is supported.

Operand | Support
CERTIFICATE (data-value) | Full
CIPHERS (data-value) | Full
CODEPAGE (data-value) | Full
HOST (data-value) | Full
HOSTLENGTH (data-value) | Full
HTTP (cvda) | Full
HTTPRNUM (data-area) | Full
HTTPS (cvda) | Full
HTTPVNUM (data-area) | Full
NUMCIPHERS (data-value) | Full
PORTNUMBER (data-value) | Full
SCHEME (data-value) | Full
SESSTOKEN (data-area) | Full
URIMAP (data-value) | Full
Parent topic: CICS API Calls


WEB PARSE

The WEB PARSE function is supported.

Operand | Support
HOST (data-area) | Full
HOSTLENGTH (data-value) | Full
HOSTTYPE (data-value) | Full
PATH (data-area) | Full
PATHLENGTH (data-value) | Full
PORTNUMBER (data-area) | Full
QUERYSTRING (data-area) | Full
QUERYSTRLEN (data-value) | Full
SCHEMENAME (data-area) | Full
URL (data-value) | Full
URLLENGTH (data-value) | Full
Parent topic: CICS API Calls


WEB READ FORMFIELD

The WEB READ FORMFIELD function is supported.

Operand | Support
CHARACTERSET (data-value) | Full
CLNTCODEPAGE (data-value) | Full
FORMFIELD (data-area) | Full
HOSTCODEPAGE (data-value) | Full
NAMELENGTH (data-value) | Full
SET (ptr-ref) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full
Parent topic: CICS API Calls


WEB READ HTTPHEADER

The WEB READ HTTPHEADER function is supported.

Operand | Support
HTTPHEADER (data-area) | Full
NAMELENGTH (data-value) | Full
SESSTOKEN (data-area) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full
Parent topic: CICS API Calls


WEB READ QUERYPARM

The WEB READ QUERYPARM function is supported.

Operand | Support
HOSTCODEPAGE (data-value) | Full
NAMELENGTH (data-value) | Full
QUERYPARM (data-area) | Full
SET (ptr-ref) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full
Parent topic: CICS API Calls


WEB READNEXT FORMFIELD

The WEB READNEXT FORMFIELD function is supported.

Operand | Support
FORMFIELD (data-area) | Full
NAMELENGTH (data-value) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full
Parent topic: CICS API Calls


WEB READNEXT HTTPHEADER

The WEB READNEXT HTTPHEADER function is supported.

Operand | Support
HTTPHEADER (data-area) | Full
NAMELENGTH (data-value) | Full
SESSTOKEN (data-area) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full
Parent topic: CICS API Calls


WEB READNEXT QUERYPARM

The WEB READNEXT QUERYPARM function is supported.

Operand | Support
NAMELENGTH (data-value) | Full
QUERYPARM (data-area) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full
Parent topic: CICS API Calls


WEB RECEIVE

The WEB RECEIVE function is supported.

Operand | Support
BODYCHARSET (data-area) | Full
CHARACTERSET (data-value) | Full
CLNTCODEPAGE (data-value) | Full
HOSTCODEPAGE (data-value) | Full
INTO (data-area) | Full
LENGTH (data-area) | Full
MAXLENGTH (data-value) | Full
MEDIATYPE (data-value) | Full
NOSRVCONVERT (cvda) | Full
NOTRUNCATE | Full
SERVERCONV (data-value) | Full
SET (ptr-ref) | Full
SRVCONVERT (cvda) | Full
TOCHANNEL (data-value) | Full
TOCONTAINER (data-value) | Full
TYPE (cvda) | Full
Parent topic: CICS API Calls


WEB RECEIVE SESSTOKEN

The WEB RECEIVE SESSTOKEN function is supported.

Operand | Support
BODYCHARSET (data-area) | Full
CLICONVERT (cvda) | Full
CLIENTCONV (data-value) | Full
INTO (data-area) | Full
LENGTH (data-value) | Full
MAXLENGTH (data-area) | Full
MEDIATYPE (data-area) | Full
NOCLICONVERT (cvda) | Full
NOTRUNCATE | Full
SESSTOKEN (data-area) | Full
SET (ptr-ref) | Full
STATUSCODE (data-value) | Full
STATUSLEN (data-value) | Full
STATUSTEXT (data-area) | Full
TOCHANNEL (data-value) | Full
TOCONTAINER (data-value) | Full
Parent topic: CICS API Calls


WEB RETRIEVE

The WEB RETRIEVE function is supported.

Operand | Support
DOCTOKEN (data-value) | Full
Parent topic: CICS API Calls


WEB SEND

The WEB SEND function is supported.

Operand | Support
ACTION (data-value) | Full
CHANNEL (data-value) | Full
CHARACTERSET (data-value) | Full
CHUNKEND (cvda) | Full
CHUNKING (data-value) | Full
CHUNKNO (cvda) | Full
CHUNKYES (cvda) | Full
CLNTCODEPAGE (data-value) | Full
CLOSE (cvda) | Full
CLOSESTATUS (data-value) | Full
CONTAINER (data-value) | Full
DOCDELETE (cvda) | Full
DOCSTATUS (data-value) | Full
DOCTOKEN (data-value) | Full
EVENTUAL (cvda) | Full
FROM (data-area) | Full
FROMLENGTH (data-value) | Full
HOSTCODEPAGE (data-value) | Full
IMMEDIATE (cvda) | Full
LENGTH (data-value) | Full
MEDIATYPE (data-value) | Full
NOCLOSE (cvda) | Full
NODOCDELETE (cvda) | Full
NOSRVCONVERT (cvda) | Full
SERVERCONV (data-value) | Full
SRVCONVERT (cvda) | Full
STATUSCODE (data-value) | Full
STATUSLEN (data-value) | Full
STATUSTEXT (data-area) | Full
Parent topic: CICS API Calls


WEB SEND SESSTOKEN

The WEB SEND SESSTOKEN function is supported.

Operand | Support
ACTION (data-value) | Full
AUTHENTICATE (data-value) | Full
BASICAUTH (cvda) | Full
CHANNEL (data-value) | Full
CHARACTERSET (data-value) | Full
CHUNKEND (cvda) | Full
CHUNKING (data-value) | Full
CHUNKNO (cvda) | Full
CHUNKYES (cvda) | Full
CLICONVERT (cvda) | Full
CLIENTCONV (data-value) | Full
CLOSE (cvda) | Full
CLOSESTATUS (data-value) | Full
CONTAINER (data-value) | Full
DELETE (cvda) | Full
DOCDELETE (cvda) | Full
DOCSTATUS (data-value) | Full
DOCTOKEN (data-value) | Full
EXPECT (cvda) | Full
FROM (data-area) | Full
FROMLENGTH (data-value) | Full
GET (cvda) | Full
HEAD (cvda) | Full
MEDIATYPE (data-value) | Full
METHOD (data-value) | Full
NOCLICONVERT (cvda) | Full
NOCLOSE (cvda) | Full
NODOCDELETE (cvda) | Full
NONE (cvda) | Full
OPTIONS (cvda) | Full
PASSWORD (data-area) | Full
PASSWORDLEN (data-value) | Full
PATH (data-area) | Full
PATHLENGTH (data-value) | Full
POST (cvda) | Full
PUT (cvda) | Full
QUERYSTRING (data-area) | Full
QUERYSTRLEN (data-value) | Full
SESSTOKEN (data-area) | Full
TRACE (cvda) | Full
URIMAP (data-value) | Full
USERNAME (data-area) | Full
USERNAMELEN (data-value) | Full
Parent topic: CICS API Calls


WEB STARTBROWSE FORMFIELD

The WEB STARTBROWSE FORMFIELD function is supported.

Operand | Support
CHARACTERSET (data-value) | Full
CLNTCODEPAGE (data-value) | Full
FORMFIELD (data-value) | Full
HOSTCODEPAGE (data-value) | Full
NAMELENGTH (data-value) | Full
Parent topic: CICS API Calls


WEB STARTBROWSE HTTPHEADER

The WEB STARTBROWSE HTTPHEADER function is supported.

Operand | Support
HTTPHEADER | Full
SESSTOKEN (data-area) | Full
Parent topic: CICS API Calls


WEB STARTBROWSE QUERYPARM

The WEB STARTBROWSE QUERYPARM function is supported.

Operand | Support
HOSTCODEPAGE (data-value) | Full
NAMELENGTH (data-value) | Full
QUERYPARM (data-value) | Full
Parent topic: CICS API Calls


WEB WRITE

The WEB WRITE function is supported.

Operand | Support
HTTPHEADER (data-area) | Full
NAMELENGTH (data-value) | Full
SESSTOKEN (data-area) | Full
VALUE (data-area) | Full
VALUELENGTH (data-value) | Full
Parent topic: CICS API Calls


WRITE

The WRITE function is supported.

Operand | Support
DATASET (data-value) | Full
FILE (data-value) | Full
FROM (data-area) | Full
KEYLENGTH (data-value) | Full
LENGTH (data-value) | Full
MASSINSERT | Full
NOSUSPEND | Validated
RBA | Full
RIDFLD (data-area) | Full
RRN | Full
SYSID (data-value) | Full
XRBA | Full
Parent topic: CICS API Calls


WRITE JOURNALNAME

The WRITE JOURNALNAME function is not supported.

Operand | Support
FLENGTH (data-value) | Recognized
FROM (data-area) | Recognized
JOURNALNAME (data-value) | Recognized
JTYPEID (data-value) | Recognized
NOSUSPEND | Recognized
PFXLENG (data-value) | Recognized
PREFIX (data-area) | Recognized
REQID (data-area) | Recognized
WAIT | Recognized
Parent topic: CICS API Calls


WRITE JOURNALNUM

The WRITE JOURNALNUM function is supported.

Operand | Support
FROM (data-area) | Full
JFILEID (data-value) | Full
JOURNALNUM (data-value) | Full
JTYPEID (data-value) | Full
LENGTH (data-value) | Full
NOSUSPEND | Full
PFXLENG (data-value) | Full
PREFIX (data-area) | Full
REQID (data-area) | Full
STARTIO | Full
WAIT | Full
Parent topic: CICS API Calls


WRITE OPERATOR

The WRITE OPERATOR function is supported.

Operand | Support
ACTION (data-value) | Full
CRITICAL (cvda) | Full
EVENTUAL (cvda) | Full
IMMEDIATE (cvda) | Full
MAXLENGTH (data-value) | Validated
NUMROUTES (data-value) | Validated
REPLY (data-area) | Validated
REPLYLENGTH (data-area) | Validated
ROUTECODES (data-value) | Validated
TEXT (data-value) | Full
TEXTLENGTH (data-value) | Full
TIMEOUT (data-value) | Validated
Parent topic: CICS API Calls


WRITEQ

The WRITEQ function is supported.

Operand | Support
AUXILIARY | Full
FROM (data-area) | Full
ITEM (data-area) | Full
LENGTH (data-value) | Full
MAIN | Full
NOSUSPEND | Validated
NUMITEMS (data-area) | Full
QNAME (data-value) | Full
QUEUE (data-value) | Full
REWRITE | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


WRITEQ TD

The WRITEQ TD function is supported.

Operand | Support
FROM (data-area) | Full
LENGTH (data-value) | Full
QUEUE (data-value) | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


WRITEQ TS

The WRITEQ TS function is supported.

Operand | Support
AUXILIARY | Full
FROM (data-area) | Full
ITEM (data-area) | Full
LENGTH (data-value) | Full
MAIN | Full
NOSUSPEND | Validated
NUMITEMS (data-area) | Full
QNAME (data-value) | Full
QUEUE (data-value) | Full
REWRITE | Full
SYSID (data-value) | Full
Parent topic: CICS API Calls


WSACONTEXT BUILD

The WSACONTEXT BUILD function is not supported.

Parent topic: CICS API Calls


WSACONTEXT DELETE

The WSACONTEXT DELETE function is not supported.

Parent topic: CICS API Calls


WSACONTEXT GET

The WSACONTEXT GET function is not supported.

Parent topic: CICS API Calls


WSAEPR CREATE

The WSAEPR CREATE function is not supported.

Parent topic: CICS API Calls


WSAEPR EVENT

The WSAEPR EVENT function is not supported.

Parent topic: CICS API Calls


WSAEPR PROCESS

The WSAEPR PROCESS function is supported.

Operand | Support
CONVDATA (data-area) | Full
CONVID (data-value) | Full
PARTNER (data-value) | Validated
PIPLENGTH (data-value) | Full
PIPLIST (data-area) | Full
PROCLENGTH (data-value) | Full
PROCNAME (data-area) | Full
RETCODE (data-area) | Full
STATE (cvda) | Full
SYNCLEVEL (data-value) | Full
Parent topic: CICS API Calls


XCTL

The XCTL function is supported.

Operand | Support
CHANNEL (data-value) | Full
COMMAREA (data-area) | Full
INPUTMSG (data-area) | Full
INPUTMSGLEN (data-value) | Full
LENGTH (data-value) | Full
PROGRAM (data-value) | Full
Parent topic: CICS API Calls


CICS SPI Calls

  • ACQUIRE TERMINAL
    The ACQUIRE TERMINAL function is not supported.
  • COLLECT STATISTICS
    The COLLECT STATISTICS function is not supported.
  • CREATE CONNECTION
    The CREATE CONNECTION function is not supported.
  • CREATE CORBASERVER
    The CREATE CORBASERVER function is not supported.
  • CREATE DB2CONN
    The CREATE DB2CONN function is not supported.
  • CREATE DB2ENTRY
    The CREATE DB2ENTRY function is not supported.
  • CREATE DB2TRAN
    The CREATE DB2TRAN function is not supported.
  • CREATE DJAR
    The CREATE DJAR function is not supported.
  • CREATE DOCTEMPLATE
    The CREATE DOCTEMPLATE function is not supported.
  • CREATE ENQMODEL
    The CREATE ENQMODEL function is not supported.
  • CREATE FILE
    The CREATE FILE function is not supported.
  • CREATE JOURNALMODEL
    The CREATE JOURNALMODEL function is not supported.
  • CREATE LSRPOOL
    The CREATE LSRPOOL function is not supported.
  • CREATE MAPSET
    The CREATE MAPSET function is not supported.
  • CREATE PARTITIONSET
    The CREATE PARTITIONSET function is not supported.
  • CREATE PARTNER
    The CREATE PARTNER function is not supported.
  • CREATE PROCESSTYPE
    The CREATE PROCESSTYPE function is not supported.
  • CREATE PROFILE
    The CREATE PROFILE function is not supported.
  • CREATE PROGRAM
    The CREATE PROGRAM function is not supported.
  • CREATE REQUESTMODEL
    The CREATE REQUESTMODEL function is not supported.
  • CREATE SESSIONS
    The CREATE SESSIONS function is not supported.
  • CREATE TCPIPSERVICE
    The CREATE TCPIPSERVICE function is not supported.
  • CREATE TDQUEUE
    The CREATE TDQUEUE function is not supported.
  • CREATE TERMINAL
    The CREATE TERMINAL function is not supported.
  • CREATE TRANCLASS
    The CREATE TRANCLASS function is not supported.
  • CREATE TRANSACTION
    The CREATE TRANSACTION function is not supported.
  • CREATE TSMODEL
    The CREATE TSMODEL function is not supported.
  • CREATE TYPETERM
    The CREATE TYPETERM function is not supported.
  • DISABLE PROGRAM
    The DISABLE PROGRAM function is supported.
  • DISCARD AUTINSTMODEL
    The DISCARD AUTINSTMODEL function is not supported.
  • DISCARD CONNECTION
    The DISCARD CONNECTION function is not supported.
  • DISCARD CORBASERVER
    The DISCARD CORBASERVER function is not supported.
  • DISCARD DB2CONN
    The DISCARD DB2CONN function is not supported.
  • DISCARD DB2ENTRY
    The DISCARD DB2ENTRY function is not supported.
  • DISCARD DB2TRAN
    The DISCARD DB2TRAN function is not supported.
  • DISCARD DJAR
    The DISCARD DJAR function is not supported.
  • DISCARD DOCTEMPLATE
    The DISCARD DOCTEMPLATE function is supported.
  • DISCARD ENQMODEL
    The DISCARD ENQMODEL function is not supported.
  • DISCARD FILE
    The DISCARD FILE function is not supported.
  • DISCARD JOURNALMODEL
    The DISCARD JOURNALMODEL function is not supported.
  • DISCARD JOURNALNAME
    The DISCARD JOURNALNAME function is not supported.
  • DISCARD PARTNER
    The DISCARD PARTNER function is not supported.
  • DISCARD PROCESSTYPE
    The DISCARD PROCESSTYPE function is not supported.
  • DISCARD PROFILE
    The DISCARD PROFILE function is not supported.
  • DISCARD PROGRAM
    The DISCARD PROGRAM function is supported.
  • DISCARD REQUESTMODEL
    The DISCARD REQUESTMODEL function is not supported.
  • DISCARD TCPIPSERVICE
    The DISCARD TCPIPSERVICE function is supported.
  • DISCARD TDQUEUE
    The DISCARD TDQUEUE function is not supported.
  • DISCARD TERMINAL
    The DISCARD TERMINAL function is not supported.
  • DISCARD TRANCLASS
    The DISCARD TRANCLASS function is not supported.
  • DISCARD TRANSACTION
    The DISCARD TRANSACTION function is not supported.
  • DISCARD TSMODEL
    The DISCARD TSMODEL function is not supported.
  • DISCARD URIMAP
    The DISCARD URIMAP function is supported.
  • ENABLE PROGRAM
    The ENABLE PROGRAM function is supported.
  • EXTRACT ATTACH
    The EXTRACT ATTACH function is not supported.
  • EXTRACT ATTRIBUTES
    The EXTRACT ATTRIBUTES function is supported.
  • EXTRACT CERTIFICATE
    The EXTRACT CERTIFICATE function is supported.
  • EXTRACT EXIT
    The EXTRACT EXIT function is supported.
  • EXTRACT LOGONMSG
    The EXTRACT LOGONMSG function is not supported.
  • EXTRACT PROCESS
    The EXTRACT PROCESS function is supported.
  • EXTRACT TCPIP
    The EXTRACT TCPIP function is supported.
  • EXTRACT TCT
    The EXTRACT TCT function is not supported.
  • EXTRACT WEB
    The EXTRACT WEB function is supported.
  • INQUIRE ACTIVITYID
    The INQUIRE ACTIVITYID function is not supported.
  • INQUIRE AUTINSTMODEL
    The INQUIRE AUTINSTMODEL function is not supported.
  • INQUIRE AUTOINSTALL
    The INQUIRE AUTOINSTALL function is not supported.
  • INQUIRE BEAN
    The INQUIRE BEAN function is not supported.
  • INQUIRE BRFACILITY
    The INQUIRE BRFACILITY function is not supported.
  • INQUIRE CFDTPOOL
    The INQUIRE CFDTPOOL function is not supported.
  • INQUIRE CONNECTION
    The INQUIRE CONNECTION function is supported.
  • INQUIRE CONTAINER
    The INQUIRE CONTAINER function is not supported.
  • INQUIRE CORBASERVER
    The INQUIRE CORBASERVER function is not supported.
  • INQUIRE DATASET
    The INQUIRE DATASET function is supported.
  • INQUIRE DB2CONN
    The INQUIRE DB2CONN function is not supported.
  • INQUIRE DB2ENTRY
    The INQUIRE DB2ENTRY function is not supported.
  • INQUIRE DB2TRAN
    The INQUIRE DB2TRAN function is not supported.
  • INQUIRE DELETSHIPPED
    The INQUIRE DELETSHIPPED function is not supported.
  • INQUIRE DISPATCHER
    The INQUIRE DISPATCHER function is not supported.
  • INQUIRE DJAR
    The INQUIRE DJAR function is not supported.
  • INQUIRE DOCTEMPLATE
    The INQUIRE DOCTEMPLATE function is supported.
  • INQUIRE DSNAME
    The INQUIRE DSNAME function is not supported.
  • INQUIRE DUMPDS
    The INQUIRE DUMPDS function is not supported.
  • INQUIRE ENQ
    The INQUIRE ENQ function is not supported.
  • INQUIRE ENQMODEL
    The INQUIRE ENQMODEL function is not supported.
  • INQUIRE EVENT
    The INQUIRE EVENT function is not supported.
  • INQUIRE EXCI
    The INQUIRE EXCI function is not supported.
  • INQUIRE EXITPROGRAM
    The INQUIRE EXITPROGRAM function is not supported.
  • INQUIRE FILE
    The INQUIRE FILE function is supported.
  • INQUIRE IRC
    The INQUIRE IRC function is not supported.
  • INQUIRE JOURNALMODEL
    The INQUIRE JOURNALMODEL function is not supported.
  • INQUIRE JOURNALNAME
    The INQUIRE JOURNALNAME function is not supported.
  • INQUIRE JOURNALNUM
    The INQUIRE JOURNALNUM function is supported.
  • INQUIRE JVMPOOL
    The INQUIRE JVMPOOL function is not supported.
  • INQUIRE MODENAME
    The INQUIRE MODENAME function is not supported.
  • INQUIRE MONITOR
    The INQUIRE MONITOR function is not supported.
  • INQUIRE NETNAME
    The INQUIRE NETNAME function is supported.
  • INQUIRE PARTNER
    The INQUIRE PARTNER function is not supported.
  • INQUIRE PIPELINE
    The INQUIRE PIPELINE function is supported.
  • INQUIRE PROCESS
    The INQUIRE PROCESS function is not supported.
  • INQUIRE PROCESSTYPE
    The INQUIRE PROCESSTYPE function is not supported.
  • INQUIRE PROFILE
    The INQUIRE PROFILE function is not supported.
  • INQUIRE PROGRAM
    The INQUIRE PROGRAM function is supported.
  • INQUIRE REQID
    The INQUIRE REQID function is supported.
  • INQUIRE REQUESTMODEL
    The INQUIRE REQUESTMODEL function is not supported.
  • INQUIRE RRMS
    The INQUIRE RRMS function is not supported.
  • INQUIRE STATISTICS
    The INQUIRE STATISTICS function is not supported.
  • INQUIRE STORAGE
    The INQUIRE STORAGE function is not supported.
  • INQUIRE STREAMNAME
    The INQUIRE STREAMNAME function is not supported.
  • INQUIRE SYSDUMPCODE
    The INQUIRE SYSDUMPCODE function is not supported.
  • INQUIRE SYSTEM
    The INQUIRE SYSTEM function is supported.
  • INQUIRE TASK
    The INQUIRE TASK function is supported.
  • INQUIRE TASK LIST
    The INQUIRE TASK LIST function is supported.
  • INQUIRE TCLASS
    The INQUIRE TCLASS function is supported.
  • INQUIRE TCPIP
    The INQUIRE TCPIP function is not supported.
  • INQUIRE TCPIPSERVICE
    The INQUIRE TCPIPSERVICE function is supported.
  • INQUIRE TDQUEUE
    The INQUIRE TDQUEUE function is supported.
  • INQUIRE TERMINAL
    The INQUIRE TERMINAL function is supported.
  • INQUIRE TIMER
    The INQUIRE TIMER function is not supported.
  • INQUIRE TRACEDEST
    The INQUIRE TRACEDEST function is not supported.
  • INQUIRE TRACEFLAG
    The INQUIRE TRACEFLAG function is not supported.
  • INQUIRE TRACETYPE
    The INQUIRE TRACETYPE function is not supported.
  • INQUIRE TRANCLASS
    The INQUIRE TRANCLASS function is supported.
  • INQUIRE TRANDUMPCODE
    The INQUIRE TRANDUMPCODE function is not supported.
  • INQUIRE TRANSACTION
    The INQUIRE TRANSACTION function is supported.
  • INQUIRE TSMODEL
    The INQUIRE TSMODEL function is not supported.
  • INQUIRE TSPOOL
    The INQUIRE TSPOOL function is not supported.
  • INQUIRE TSQNAME
    The INQUIRE TSQNAME function is not supported.
  • INQUIRE TSQUEUE
    The INQUIRE TSQUEUE function is supported.
  • INQUIRE UOW
    The INQUIRE UOW function is not supported.
  • INQUIRE UOWDSNFAIL
    The INQUIRE UOWDSNFAIL function is not supported.
  • INQUIRE UOWENQ
    The INQUIRE UOWENQ function is not supported.
  • INQUIRE UOWLINK
    The INQUIRE UOWLINK function is not supported.
  • INQUIRE URIMAP
    The INQUIRE URIMAP function is supported.
  • INQUIRE VOLUME
    The INQUIRE VOLUME function is not supported.
  • INQUIRE VTAM
    The INQUIRE VTAM function is not supported.
  • INQUIRE WEB
    The INQUIRE WEB function is not supported.
  • INQUIRE WEBSERVICE
    The INQUIRE WEBSERVICE function is supported.
  • PERFORM CORBASERVER
    The PERFORM CORBASERVER function is not supported.
  • PERFORM DELETSHIPPED
    The PERFORM DELETSHIPPED function is not supported.
  • PERFORM DJAR
    The PERFORM DJAR function is not supported.
  • PERFORM DUMP
    The PERFORM DUMP function is supported.
  • PERFORM ENDAFFINITY
    The PERFORM ENDAFFINITY function is not supported.
  • PERFORM RESETTIME
    The PERFORM RESETTIME function is not supported.
  • PERFORM SECURITY REBUILD
    The PERFORM SECURITY REBUILD function is not supported.
  • PERFORM SHUTDOWN
    The PERFORM SHUTDOWN function is supported.
  • PERFORM STATISTICS RECORD
    The PERFORM STATISTICS RECORD function is not supported.
  • RESYNC ENTRYNAME
    The RESYNC ENTRYNAME function is not supported.
  • SET AUTOINSTALL
    The SET AUTOINSTALL function is not supported.
  • SET BRFACILITY
    The SET BRFACILITY function is not supported.
  • SET CONNECTION
    The SET CONNECTION function is supported.
  • SET CORBASERVER
    The SET CORBASERVER function is not supported.
  • SET DATASET
    The SET DATASET function is supported.
  • SET DB2CONN
    The SET DB2CONN function is not supported.
  • SET DB2ENTRY
    The SET DB2ENTRY function is not supported.
  • SET DB2TRAN
    The SET DB2TRAN function is not supported.
  • SET DELETSHIPPED
    The SET DELETSHIPPED function is not supported.
  • SET DISPATCHER
    The SET DISPATCHER function is not supported.
  • SET DOCTEMPLATE
    The SET DOCTEMPLATE function is supported.
  • SET DSNAME
    The SET DSNAME function is not supported.
  • SET DUMPDS
    The SET DUMPDS function is not supported.
  • SET ENQMODEL
    The SET ENQMODEL function is not supported.
  • SET FILE
    The SET FILE function is supported.
  • SET IRC
    The SET IRC function is not supported.
  • SET JOURNALNAME
    The SET JOURNALNAME function is not supported.
  • SET JOURNALNUM
    The SET JOURNALNUM function is supported.
  • SET JVMPOOL
    The SET JVMPOOL function is not supported.
  • SET MODENAME
    The SET MODENAME function is not supported.
  • SET MONITOR
    The SET MONITOR function is not supported.
  • SET NETNAME
    The SET NETNAME function is supported.
  • SET PIPELINE
    The SET PIPELINE function is supported.
  • SET PROCESSTYPE
    The SET PROCESSTYPE function is not supported.
  • SET PROGRAM
    The SET PROGRAM function is supported.
  • SET STATISTICS
    The SET STATISTICS function is not supported.
  • SET SYSDUMPCODE
    The SET SYSDUMPCODE function is not supported.
  • SET SYSTEM
    The SET SYSTEM function is supported.
  • SET TASK
    The SET TASK function is not supported.
  • SET TCLASS
    The SET TCLASS function is not supported.
  • SET TCPIP
    The SET TCPIP function is not supported.
  • SET TCPIPSERVICE
    The SET TCPIPSERVICE function is supported.
  • SET TDQUEUE
    The SET TDQUEUE function is supported.
  • SET TERMINAL
    The SET TERMINAL function is supported.
  • SET TRACEDEST
    The SET TRACEDEST function is not supported.
  • SET TRACEFLAG
    The SET TRACEFLAG function is not supported.
  • SET TRACETYPE
    The SET TRACETYPE function is not supported.
  • SET TRANCLASS
    The SET TRANCLASS function is not supported.
  • SET TRANDUMPCODE
    The SET TRANDUMPCODE function is not supported.
  • SET TRANSACTION
    The SET TRANSACTION function is supported.
  • SET TSQNAME
    The SET TSQNAME function is not supported.
  • SET TSQUEUE
    The SET TSQUEUE function is not supported.
  • SET UOW
    The SET UOW function is not supported.
  • SET UOWLINK
    The SET UOWLINK function is not supported.
  • SET URIMAP
    The SET URIMAP function is supported.
  • SET VOLUME
    The SET VOLUME function is not supported.
  • SET VTAM
    The SET VTAM function is not supported.
  • SET WEB
    The SET WEB function is not supported.
  • SET WEBSERVICE
    The SET WEBSERVICE function is supported.
Parent topic: CICS Support Commands


ACQUIRE TERMINAL

The ACQUIRE TERMINAL function is not supported.

Parent topic: CICS SPI Calls


COLLECT STATISTICS

The COLLECT STATISTICS function is not supported.

Operand | Support
AUTOINSTALL | Recognized
CONNECTION (data-value) | Recognized
CORBASERVER | Recognized
DISPATCHER | Recognized
DTB | Recognized
FILE (data-value) | Recognized
IRCBATCH | Recognized
JOURNALNUM (data-value) | Recognized
JVMPOOL | Recognized
LASTRESET (data-area) | Recognized
LASTRESETHRS (data-area) | Recognized
LASTRESETMIN (data-area) | Recognized
LASTRESETSEC (data-area) | Recognized
LSRPOOL (data-value) | Recognized
MONITOR (data-value) | Recognized
PROGRAM (data-value) | Recognized
REQUESTMODEL | Recognized
SET (ptr-ref) | Recognized
STORAGE | Recognized
SYSDUMPCODE (data-value) | Recognized
TABLEMGR | Recognized
TASKCONTROL | Recognized
TCLASS (data-area) | Recognized
TCPIP | Recognized
TCPIPSERVICE | Recognized
TDQUEUE (data-value) | Recognized
TERMINAL (data-value) | Recognized
TRANDUMPCODE (data-value) | Recognized
TRANSACTION (data-value) | Recognized
TSQUEUE | Recognized
VTAM | Recognized
Parent topic: CICS SPI Calls


CREATE CONNECTION

The CREATE CONNECTION function is not supported.

Parent topic: CICS SPI Calls


CREATE CORBASERVER

The CREATE CORBASERVER function is not supported.

Parent topic: CICS SPI Calls


CREATE DB2CONN

The CREATE DB2CONN function is not supported.

Parent topic: CICS SPI Calls


CREATE DB2ENTRY

The CREATE DB2ENTRY function is not supported.

Parent topic: CICS SPI Calls


CREATE DB2TRAN

The CREATE DB2TRAN function is not supported.

Parent topic: CICS SPI Calls


CREATE DJAR

The CREATE DJAR function is not supported.

Parent topic: CICS SPI Calls


CREATE DOCTEMPLATE

The CREATE DOCTEMPLATE function is not supported.

Operand | Support
ATTRIBUTES (data-area) | Recognized
ATTRLEN (data-value) | Recognized
DOCTEMPLATE (data-value) | Recognized
LOG (cvda) | Recognized
LOGMESSAGE (data-value) | Recognized
NOLOG (cvda) | Recognized
Parent topic: CICS SPI Calls


CREATE ENQMODEL

The CREATE ENQMODEL function is not supported.

Parent topic: CICS SPI Calls


CREATE FILE

The CREATE FILE function is not supported.

Parent topic: CICS SPI Calls


CREATE JOURNALMODEL

The CREATE JOURNALMODEL function is not supported.

Parent topic: CICS SPI Calls


CREATE LSRPOOL

The CREATE LSRPOOL function is not supported.

Parent topic: CICS SPI Calls


CREATE MAPSET

The CREATE MAPSET function is not supported.

Parent topic: CICS SPI Calls


CREATE PARTITIONSET

The CREATE PARTITIONSET function is not supported.

Parent topic: CICS SPI Calls


CREATE PARTNER

The CREATE PARTNER function is not supported.

Parent topic: CICS SPI Calls


CREATE PROCESSTYPE

The CREATE PROCESSTYPE function is not supported.

Parent topic: CICS SPI Calls


CREATE PROFILE

The CREATE PROFILE function is not supported.

Parent topic: CICS SPI Calls


CREATE PROGRAM

The CREATE PROGRAM function is not supported.

Parent topic: CICS SPI Calls


CREATE REQUESTMODEL

The CREATE REQUESTMODEL function is not supported.

Parent topic: CICS SPI Calls


CREATE SESSIONS

The CREATE SESSIONS function is not supported.

Parent topic: CICS SPI Calls


CREATE TCPIPSERVICE

The CREATE TCPIPSERVICE function is not supported.

Parent topic: CICS SPI Calls


CREATE TDQUEUE

The CREATE TDQUEUE function is not supported.

Parent topic: CICS SPI Calls


CREATE TERMINAL

The CREATE TERMINAL function is not supported.

Parent topic: CICS SPI Calls


CREATE TRANCLASS

The CREATE TRANCLASS function is not supported.

Parent topic: CICS SPI Calls


CREATE TRANSACTION

The CREATE TRANSACTION function is not supported.

Parent topic: CICS SPI Calls


CREATE TSMODEL

The CREATE TSMODEL function is not supported.

Parent topic: CICS SPI Calls


CREATE TYPETERM

The CREATE TYPETERM function is not supported.

Parent topic: CICS SPI Calls


DISABLE PROGRAM

The DISABLE PROGRAM function is supported.

Operand | Support
ENTRYNAME (data-value) | Full
EXIT (data-value) | Full
EXITALL | Full
FORMATEDF | Validated
PROGRAM (data-value) | Full
SHUTDOWN | Full
STOP | Full
TASKSTART | Full
Parent topic: CICS SPI Calls


DISCARD AUTINSTMODEL

The DISCARD AUTINSTMODEL function is not supported.

Operand | Support
AUTINSTMODEL (data-value) | Recognized
Parent topic: CICS SPI Calls


DISCARD CONNECTION

The DISCARD CONNECTION function is not supported.

Parent topic: CICS SPI Calls


DISCARD CORBASERVER

The DISCARD CORBASERVER function is not supported.

Parent topic: CICS SPI Calls


DISCARD DB2CONN

The DISCARD DB2CONN function is not supported.

Parent topic: CICS SPI Calls


DISCARD DB2ENTRY

The DISCARD DB2ENTRY function is not supported.

Parent topic: CICS SPI Calls


DISCARD DB2TRAN

The DISCARD DB2TRAN function is not supported.

Parent topic: CICS SPI Calls


DISCARD DJAR

The DISCARD DJAR function is not supported.

Parent topic: CICS SPI Calls


DISCARD DOCTEMPLATE

The DISCARD DOCTEMPLATE function is supported.

Operand | Support
DOCTEMPLATE (data-value) | Full
Parent topic: CICS SPI Calls


DISCARD ENQMODEL

The DISCARD ENQMODEL function is not supported.

Parent topic: CICS SPI Calls


DISCARD FILE

The DISCARD FILE function is not supported.

Operand | Support
FILE (data-value) | Recognized
Parent topic: CICS SPI Calls


DISCARD JOURNALMODEL

The DISCARD JOURNALMODEL function is not supported.

Parent topic: CICS SPI Calls


DISCARD JOURNALNAME

The DISCARD JOURNALNAME function is not supported.

Parent topic: CICS SPI Calls


DISCARD PARTNER

The DISCARD PARTNER function is not supported.

Operand | Support
PARTNER (data-value) | Recognized
Parent topic: CICS SPI Calls


DISCARD PROCESSTYPE

The DISCARD PROCESSTYPE function is not supported.

Parent topic: CICS SPI Calls


DISCARD PROFILE

The DISCARD PROFILE function is not supported.

Operand | Support
PROFILE (data-value) | Recognized
Parent topic: CICS SPI Calls


DISCARD PROGRAM

The DISCARD PROGRAM function is supported.

Operand | Support
PROGRAM (data-value) | Full
Parent topic: CICS SPI Calls


DISCARD REQUESTMODEL

The DISCARD REQUESTMODEL function is not supported.

Parent topic: CICS SPI Calls


DISCARD TCPIPSERVICE

The DISCARD TCPIPSERVICE function is supported.

Operand | Support
TCPIPSERVICE (data-value) | Full
Parent topic: CICS SPI Calls


DISCARD TDQUEUE

The DISCARD TDQUEUE function is not supported.

Parent topic: CICS SPI Calls


DISCARD TERMINAL

The DISCARD TERMINAL function is not supported.

Parent topic: CICS SPI Calls


DISCARD TRANCLASS

The DISCARD TRANCLASS function is not supported.

Parent topic: CICS SPI Calls


DISCARD TRANSACTION

The DISCARD TRANSACTION function is not supported.

Operand | Support
TRANSACTION (data-value) | Recognized
Parent topic: CICS SPI Calls


DISCARD TSMODEL

The DISCARD TSMODEL function is not supported.

Parent topic: CICS SPI Calls


DISCARD URIMAP

The DISCARD URIMAP function is supported.

Operand | Support
URIMAP (data-value) | Full
Parent topic: CICS SPI Calls


ENABLE PROGRAM

The ENABLE PROGRAM function is supported.

Operand | Support
ENTRY (ptr-ref) | Full
ENTRYNAME (data-value) | Full
EXIT (data-value) | Full
FORMATEDF | Validated
GAENTRYNAME (data-value) | Full
GALENGTH (data-value) | Full
LINKEDITMODE | Validated
PROGRAM (data-value) | Full
SHUTDOWN | Full
START | Full
TALENGTH (data-value) | Full
TASKSTART | Full
Parent topic: CICS SPI Calls


EXTRACT ATTACH

The EXTRACT ATTACH function is not supported.

Parent topic: CICS SPI Calls


EXTRACT ATTRIBUTES

The EXTRACT ATTRIBUTES function is supported.

Operand | Support
CONVID (data-value) | Full
SESSION (data-value) | Full
STATE (cvda) | Full
Parent topic: CICS SPI Calls


EXTRACT CERTIFICATE

The EXTRACT CERTIFICATE function is supported.

Operand | Support
CERTIFICATE (data-area) | Full
COMMONNAME (data-area) | Full
COMMONNAMLEN (data-area) | Full
COUNTRY (data-area) | Full
COUNTRYLEN (data-area) | Full
ISSUER | Full
LENGTH (data-area) | Full
LOCALITY (data-area) | Full
LOCALITYLEN (data-area) | Full
ORGANIZATION (data-area) | Full
ORGANIZATLEN (data-area) | Full
ORGUNIT (data-area) | Full
ORGUNITLEN (data-area) | Full
OWNER | Full
SERIALNUM (data-area) | Full
SERIALNUMLEN (data-area) | Full
STATE (data-area) | Full
STATELEN (data-area) | Full
USERID (data-area) | Full
Parent topic: CICS SPI Calls


EXTRACT EXIT

The EXTRACT EXIT function is supported.

Operand | Support
ENTRYNAME (data-value) | Full
GALENGTH (data-area) | Full
GASET (ptr-ref) | Full
PROGRAM (data-value) | Full
Parent topic: CICS SPI Calls


EXTRACT LOGONMSG

The EXTRACT LOGONMSG function is not supported.

Operand | Support
INTO (data-area) | Recognized
LENGTH (data-area) | Recognized
SET (ptr-ref) | Recognized
Parent topic: CICS SPI Calls


EXTRACT PROCESS

The EXTRACT PROCESS function is supported.

Operand | Support
CONVID (data-area) | Full
MAXPROCLEN (data-area) | Full
PIPLENGTH (data-area) | Full
PIPLIST (ptr-ref) | Full
PROCLENGTH (data-area) | Full
PROCNAME (data-area) | Full
SESSION (data-area) | Full
SYNCLEVEL (data-area) | Full
Parent topic: CICS SPI Calls


EXTRACT TCPIP

The EXTRACT TCPIP function is supported.

Operand | Support
AUTHENTICATE (cvda) | Full
CADDRLENGTH (data-area) | Full
CLIENTADDR (data-area) | Full
CLIENTADDRNU (data-area) | Full
CLIENTNAME (data-area) | Full
CNAMELENGTH (data-area) | Full
MAXDATALEN (data-area) | Full
PORTNUMBER (data-area) | Full
PORTNUMNU (data-area) | Full
PRIVACY (data-area) | Partial: returns "NOTSUPPORTED"
SADDRLENGTH (data-area) | Full
SERVERADDR (data-area) | Full
SERVERADDRNU (data-area) | Full
SERVERNAME (data-area) | Full
SNAMELENGTH (data-area) | Full
SSLTYPE (cvda) | Full
TCPIPSERVICE (data-area) | Full
Parent topic: CICS SPI Calls


EXTRACT TCT

The EXTRACT TCT function is not supported.

Parent topic: CICS SPI Calls


EXTRACT WEB

The EXTRACT WEB function is supported.

Operand | Support
HOST (data-area) | Full
HOSTLENGTH (data-value) | Full
HOSTTYPE (data-value) | Full
HTTPMETHOD (data-area) | Full
HTTPVERSION (data-area) | Full
METHODLENGTH (data-value) | Full
PATH (data-area) | Full
PATHLENGTH (data-value) | Full
PORTNUMBER (data-area) | Full
QUERYSTRING (data-area) | Full
QUERYSTRLEN (data-value) | Full
REALM (data-area) | Full
REALMLEN (data-value) | Full
REQUESTTYPE (cvda) | Full
SCHEME (cvda) | Full
SESSTOKEN (data-area) | Full
URIMAP (data-area) | Full
VERSIONLEN (data-value) | Full
Parent topic: CICS SPI Calls


INQUIRE ACTIVITYID

The INQUIRE ACTIVITYID function is not supported.

Parent topic: CICS SPI Calls


INQUIRE AUTINSTMODEL

The INQUIRE AUTINSTMODEL function is not supported.

Operand | Support
AUTINSTMODEL (data-value) | Recognized
NEXT | Recognized
Parent topic: CICS SPI Calls


INQUIRE AUTOINSTALL

The INQUIRE AUTOINSTALL function is not supported.

Operand | Support
CURREQS (data-area) | Recognized
ENABLESTATUS (data-area) | Recognized
MAXREQS (data-area) | Recognized
PROGRAM (data-area) | Recognized
Parent topic: CICS SPI Calls


INQUIRE BEAN

The INQUIRE BEAN function is not supported.

Parent topic: CICS SPI Calls


INQUIRE BRFACILITY

The INQUIRE BRFACILITY function is not supported.

Parent topic: CICS SPI Calls


INQUIRE CFDTPOOL

The INQUIRE CFDTPOOL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE CONNECTION

The INQUIRE CONNECTION function is supported.

Operand | Support
ACCESSMETHOD (cvda) | Partial: returns "VTAM"
ACQSTATUS (cvda) | Full
AUTOCONNECT (cvda) | Partial: returns "NONAUTOCONN"
CONNECTION (data-value) | Full
CONNSTATUS (cvda) | Full
EXITTRACING (cvda) | Partial: returns "NOEXITTRACE"
NETNAME (data-area) | Full
NEXT | Full
PENDSTATUS (cvda) | Partial: returns "NOTPENDING"
PROTOCOL (cvda) | Partial: returns "APPC"
SERVSTATUS (cvda) | Full
XLNSTATUS (cvda) | Partial: returns "XNOTDONE"
ZCPTRACING (cvda) | Partial: returns "NOZCPTRACE"
Parent topic: CICS SPI Calls


INQUIRE CONTAINER

The INQUIRE CONTAINER function is not supported.

Parent topic: CICS SPI Calls


INQUIRE CORBASERVER

The INQUIRE CORBASERVER function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DATASET

The INQUIRE DATASET function is supported.

Operand | Support
ACCESSMETHOD (cvda) | Partial: returns "VSAM"
ADD (cvda) | Full
BASEDSNAME (data-area) | Full
BASENAME (data-area) | Full
BLOCKFORMAT (cvda) | Partial: returns "BLOCKED"
BLOCKKEYLEN (data-area) | Partial: returns 0
BLOCKSIZE (data-area) | Partial: returns 0
BROWSE (cvda) | Full
CATNAME (data-area) | Validated
CFDTPOOL (data-area) | Validated
DATASET (data-value) | Full
DELETE (cvda) | Full
DISPOSITION (cvda) | Partial: returns "SHARE"
DSNAME (data-area) | Full
EMPTYSTATUS (cvda) | Full
ENABLESTATUS (cvda) | Full
EXCLUSIVE (cvda) | Partial: returns "NOTAPPLIC"
FILE (data-value) | Full
FWDRECSTATUS (cvda) | Partial: returns "NOTFWDRCVBLE"
JOURNALNUM (data-area) | Partial: If the Journal is a remote file, returns -1 If FWDRECSTATUS=NOTFWDRCVBLE, returns 0 If FWDRECSTATUS=FWDRECOVBLE, returns 1
KEYLENGTH (data-area) | Full
KEYPOSITION (data-area) | Full
LOADTYPE (cvda) | Validated
LSRPOOLID (data-area) | Partial: returns 0
MAXNUMRECS (data-area) | Partial: returns 0
NEXT | Full
OBJECT (cvda) | Full
OBJECTNAME (data-area) | Full
OPENSTATUS (cvda) | Full
READ (cvda) | Full
READINTEG (cvda) | Validated
RECORDFORMAT (cvda) | Full
RECORDSIZE (data-area) | Full
RECOVSTATUS (cvda) | Full
RELTYPE (cvda) | Partial: returns "NOTAPPLIC"
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
REMOTETABLE (cvda) | Validated
RLSACCESS (cvda) | Validated
STRINGS (data-area) | Partial: returns 1
TABLE (cvda) | Partial: returns "NOTTABLE"
TABLENAME (data-area) | Validated
TYPE (cvda) | Full
UPDATE (cvda) | Full
UPDATEMODEL (cvda) | Validated
Parent topic: CICS SPI Calls


INQUIRE DB2CONN

The INQUIRE DB2CONN function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DB2ENTRY

The INQUIRE DB2ENTRY function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DB2TRAN

The INQUIRE DB2TRAN function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DELETSHIPPED

The INQUIRE DELETSHIPPED function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DISPATCHER

The INQUIRE DISPATCHER function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DJAR

The INQUIRE DJAR function is not supported.

Parent topic: CICS SPI Calls


INQUIRE DOCTEMPLATE

The INQUIRE DOCTEMPLATE function is supported.

Operand | Support
APPENDCRLF (cvda) | Full
CACHESIZE (data-area) | Full
DDNAME (data-area) | Full
DOCTEMPLATE (data-value) | Full
DSNAME (data-area) | Full
EXITPGM (data-area) | Full
FILE (data-area) | Full
HFSFILE (data-area) | Full
MEMBER (data-area) | Full
NEXT | Full
PROGRAM (data-area) | Full
TDQUEUE (data-area) | Full
TEMPLATENAME (data-area) | Full
TEMPLATETYPE (cvda) | Full
TSQUEUE (data-area) | Full
TYPE (cvda) | Full
Parent topic: CICS SPI Calls


INQUIRE DSNAME

The INQUIRE DSNAME function is not supported.

Operand | Support
ACCESSMETHOD (cvda) | Recognized
BACKUPTYPE (cvda) | Recognized
BASEDSNAME (data-area) | Recognized
BKOUTSTATUS (cvda) | Recognized
DSNAME (data-value) | Recognized
FILECOUNT (data-area) | Recognized
FWDRECOVLOG (data-area) | Recognized
NEXT | Recognized
OBJECT (cvda) | Recognized
RECOVSTATUS (cvda) | Recognized
VALIDITY (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE DUMPDS

The INQUIRE DUMPDS function is not supported.

Operand | Support
CURRENTDDS (data-area) | Recognized
INITIALDDS (data-area) | Recognized
OPENSTATUS (cvda) | Recognized
SWITCHSTATUS (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE ENQ

The INQUIRE ENQ function is not supported.

Parent topic: CICS SPI Calls


INQUIRE ENQMODEL

The INQUIRE ENQMODEL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE EVENT

The INQUIRE EVENT function is not supported.

Parent topic: CICS SPI Calls


INQUIRE EXCI

The INQUIRE EXCI function is not supported.

Parent topic: CICS SPI Calls


INQUIRE EXITPROGRAM

The INQUIRE EXITPROGRAM function is not supported.

Parent topic: CICS SPI Calls


INQUIRE FILE

The INQUIRE FILE function is supported.

Operand | Support
ACCESSMETHOD (cvda) | Partial: returns "VSAM"
ADD (cvda) | Full
BASEDSNAME (data-area) | Full
BASENAME (data-area) | Full
BLOCKFORMAT (cvda) | Partial: returns "BLOCKED"
BLOCKKEYLEN (data-area) | Partial: returns 0
BLOCKSIZE (data-area) | Partial: returns 0
BROWSE (cvda) | Full
CATNAME (data-area) | Validated
CFDTPOOL (data-area) | Validated
DATASET (data-value) | Full
DELETE (cvda) | Full
DISPOSITION (cvda) | Partial: returns "SHARE"
DSNAME (data-area) | Full
EMPTYSTATUS (cvda) | Full
ENABLESTATUS (cvda) | Full
EXCLUSIVE (cvda) | Partial: returns "NOTAPPLIC"
FILE (data-value) | Full
FWDRECSTATUS (cvda) | Partial: returns "NOTFWDRCVBLE"
JOURNALNUM (data-area) | Partial: If the Journal is a remote file, returns -1 If FWDRECSTATUS=NOTFWDRCVBLE, returns 0 If FWDRECSTATUS=FWDRECOVBLE, returns 1
KEYLENGTH (data-area) | Full
KEYPOSITION (data-area) | Full
LOADTYPE (cvda) | Validated
LSRPOOLID (data-area) | Partial: returns 0
MAXNUMRECS (data-area) | Partial: returns 0
NEXT | Full
OBJECT (cvda) | Full
OBJECTNAME (data-area) | Full
OPENSTATUS (cvda) | Full
READ (cvda) | Full
READINTEG (cvda) | Validated
RECORDFORMAT (cvda) | Full
RECORDSIZE (data-area) | Full
RECOVSTATUS (cvda) | Full
RELTYPE (cvda) | Partial: returns "NOTAPPLIC"
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
REMOTETABLE (cvda) | Validated
RLSACCESS (cvda) | Validated
STRINGS (data-area) | Partial: returns 1
TABLE (cvda) | Partial: returns "NOTTABLE"
TABLENAME (data-area) | Validated
TYPE (cvda) | Full
UPDATE (cvda) | Full
UPDATEMODEL (cvda) | Validated
Parent topic: CICS SPI Calls


INQUIRE IRC

The INQUIRE IRC function is not supported.

Operand | Support
OPENSTATUS (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE JOURNALMODEL

The INQUIRE JOURNALMODEL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE JOURNALNAME

The INQUIRE JOURNALNAME function is not supported.

Parent topic: CICS SPI Calls


INQUIRE JOURNALNUM

The INQUIRE JOURNALNUM function is supported.

Operand | Support
ARCHSTATUS (cvda) | Partial: returns "NOAUTOARCH"
CURRENTVOL (data-area) | Partial: returns spaces
DISKASTATUS (cvda) | Partial: returns "CURRENT"
DISKBSTATUS (cvda) | Partial: returns "NOTAPPLIC"
DISKXSTATUS (cvda) | Partial: returns "NOTAPPLIC"
JOURNALNUM (data-value) | Full
JTYPE (cvda) | Partial: returns "DISK1"
NEXT | Full
OLDESTPART (data-area) | Partial: returns spaces
OPENSTATUS (cvda) | Full
Parent topic: CICS SPI Calls


INQUIRE JVMPOOL

The INQUIRE JVMPOOL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE MODENAME

The INQUIRE MODENAME function is not supported.

Operand | Support
ACTIVE (data-area) | Recognized
AUTOCONNECT (cvda) | Recognized
AVAILABLE (data-area) | Recognized
CONNECTION (data-value) | Recognized
MAXIMUM (data-area) | Recognized
MAXWINNERS (data-area) | Recognized
MODENAME (data-value) | Recognized
NEXT | Recognized
Parent topic: CICS SPI Calls


INQUIRE MONITOR

The INQUIRE MONITOR function is not supported.

Operand | Support
EVENTCLASS (cvda) | Recognized
EXCEPTCLASS (cvda) | Recognized
PERFCLASS (cvda) | Recognized
STATUS (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE NETNAME

The INQUIRE NETNAME function is supported.

Operand | Support
ACCESSMETHOD (cvda) | Partial: returns "VTAM"
ACQSTATUS (cvda) | Partial: returns "ACQUIRED"
ALTPAGEHT (data-area) | Full
ALTPAGEWD (data-area) | Full
ALTPRINTER (data-area) | Partial: returns spaces
ALTPRTCOPYST (cvda) | Partial: returns "NOALTPRTCOPY"
ALTSCRNHT (data-area) | Full
ALTSCRNWD (data-area) | Full
ALTSUFFIX (data-area) | Partial: returns spaces
APLKYBDST (cvda) | Partial: returns "NOAPLKYBD"
APLTEXTST (cvda) | Partial: returns "NOAPLTEXT"
ASCII (cvda) | Full
ATISTATUS (cvda) | Partial: returns "ATI"
AUDALARMST (cvda) | Partial: returns "AUDALARM"
AUTOCONNECT (cvda) | Full
BACKTRANSST (cvda) | Partial: returns "NOBACKTRANS"
COLORST (cvda) | Full
COPYST (cvda) | Partial: returns "NOCOPY"
CREATESESS (cvda) | Partial: returns "NOCREATE"
DATASTREAM (data-area) | Full
DEFPAGEHT (data-area) | Full
DEFPAGEWD (data-area) | Full
DEFSCRNHT (data-area) | Full
DEFSCRNWD (data-area) | Full
DEVICE (cvda) | Partial: returns "T3277L"
DEVICEST (cvda) | Full
DISCREQST (cvda) | Partial: returns "DISCREQ"
DUALCASEST (cvda) | Partial: returns "DUALCASE"
EXITTRACING (cvda) | Partial: returns "NOEXITTRACE"
EXTENDEDDSST (cvda) | Partial: returns "EXTENDEDDS"
FMHPARMST (cvda) | Partial: returns "NOFMHPARM"
FORMFEEDST (cvda) | Partial: returns "NOFORMFEED"
GCHARS (data-area) | Full
GCODES (data-area) | Full
HFORMST (cvda) | Partial: returns "NOHFORM"
HILIGHTST (cvda) | Partial: returns "HILIGHT"
KATAKANAST (cvda) | Partial: returns "NOKATAKANA"
LIGHTPENST (cvda) | Partial: returns "NOLIGHTPEN"
MODENAME (data-area) | Full
MSRCONTROLST (cvda) | Partial: returns "NOMSRCONTROL"
NATLANG (data-area) | Partial: returns "E" (meaning US English)
NATURE (cvda) | Full
NETNAME (data-value) | Full
NEXTTRANSID (data-area) | Partial: returns spaces
OBFORMATST (cvda) | Partial: returns "NOOBFORMAT"
OBOPERIDST (cvda) | Partial: returns "NOOBOPERID"
OPERID (data-area) | Full
OUTLINEST (cvda) | Partial: returns "NOOUTLINE"
PAGEHT (data-area) | Full
PAGESTATUS (cvda) | Partial: returns "PAGEABLE"
PAGEWD (data-area) | Full
PARTITIONSST (cvda) | Partial: returns "NOPARTITIONS"
PRINTADAPTST (cvda) | Partial: returns "NOPRINTADAPT"
PRINTER (data-area) | Partial: returns spaces
PROGSYMBOLST (cvda) | Partial: returns "NOPROGSYMBOL"
PRTCOPYST (cvda) | Partial: returns "NOPRTCOPY"
QUERYST (cvda) | Partial: returns "NOQUERY"
RELREQST (cvda) | Partial: (VTAM only) returns "NORELREQ"
REMOTENAME (data-area) | Partial: returns spaces
REMOTESYSTEM (data-area) | Partial: returns spaces
SCREENHEIGHT (data-area) | Full
SCREENWIDTH (data-area) | Full
SCRNHT (data-area) | Full
SCRNWD (data-area) | Full
SECURITY (cvda) | Partial: returns "NOPRESETSEC"
SERVSTATUS (cvda) | Full
SESSIONTYPE (cvda) | Partial: returns "NOTAPPLIC"
SIGNONSTATUS (cvda) | Full
SOSIST (cvda) | Partial: returns "NOSOSI"
TASKID (data-area) | Partial: returns 0 meaning no task is using the terminal
TCAMCONTROL (data-area) | Partial: returns x"00" meaning null
TERMINAL (data-area) | Full
TERMMODEL (data-area) | Partial: returns 2
TERMPRIORITY (data-area) | Full
TERMSTATUS (cvda) | Full
TEXTKYBDST (cvda) | Partial: returns "NOTEXTKYBD"
TEXTPRINTST (cvda) | Partial: returns "NOTEXTPRINT"
TRACING (cvda) | Partial: returns "STANTRACE"
TRANSACTION (data-area) | Full
TTISTATUS (cvda) | Partial: returns "TTI"
UCTRANST (cvda) | Full
USERAREA (data-area) | Full
USERAREALEN (data-area) | Full
USERID (data-area) | Full
USERNAME (data-area) | Partial: returns spaces
VALIDATIONST (cvda) | Partial: returns "NOVALIDATION"
VFORMST (cvda) | Partial: returns "NOVFORM"
ZCPTRACING (cvda) | Partial: returns "NOZCPTRACE"
Parent topic: CICS SPI Calls


INQUIRE PARTNER

The INQUIRE PARTNER function is not supported.

Operand | Support
NETNAME (data-area) | Recognized
NETWORK (data-area) | Recognized
NEXT | Recognized
PARTNER (data-value) | Recognized
PROFILE (data-area) | Recognized
TPNAME (data-area) | Recognized
TPNAMELEN (data-area) | Recognized
Parent topic: CICS SPI Calls


INQUIRE PIPELINE

The INQUIRE PIPELINE function is supported.

Operand | Support
CONFIGFILE (data-area) | Full
ENABLESTATUS (cvda) | Partial: returns only "ENABLED" or "DISABLED"
NEXT | Full
PIPELINE (data-value) | Full
SHELF (data-area) | Full
WSDIR (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE PROCESS

The INQUIRE PROCESS function is not supported.

Parent topic: CICS SPI Calls


INQUIRE PROCESSTYPE

The INQUIRE PROCESSTYPE function is not supported.

Parent topic: CICS SPI Calls


INQUIRE PROFILE

The INQUIRE PROFILE function is not supported.

Operand | Support
NEXT | Recognized
PROFILE (data-value) | Recognized
Parent topic: CICS SPI Calls


INQUIRE PROGRAM

The INQUIRE PROGRAM function is supported.

Operand | Support
CEDFSTATUS (cvda) | Partial: returns "NOCEDF"
COBOLTYPE (cvda) | Partial: If the program has a PPT, returns "COBOLII" If not, returns "NOTAPPLIC"
CONCURRENCY (cvda) | Validated
COPY (cvda) | Full
DATALOCATION (cvda) | Partial: returns "ANY"
DYNAMSTATUS (cvda) | Validated
ENTRYPOINT (ptr-ref) | Full
EXECKEY (cvda) | Partial: returns "CICSEXECKEY"
EXECUTIONSET (cvda) | Partial: returns "FULLAPI"
HOLDSTATUS (cvda) | Full
HOTPOOLING (cvda) | Validated
JVMCLASS (data-area) | Validated
JVMDEBUG (cvda) | Validated
JVMPROFILE (cvda) | Validated
LANGDEDUCED (cvda) | Validated
LANGUAGE (cvda) | Partial: returns "ASSEMBLER", "C", "COBOL", "PLI" or "NOTAPPLIC" (based on the program's PPT entry).
LENGTH (data-area) | Full
LOADPOINT (ptr-ref) | Full
LPASTATUS (cvda) | Partial: returns "NOTLPA"
NEXT | Full
PROGRAM (data-value) | Full
PROGTYPE (cvda) | Partial: returns "PROGRAM"
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
RESCOUNT (data-area) | Full
RUNTIME (cvda) | Validated
SHARESTATUS (cvda) | Full
STATUS (cvda) | Partial: if program is local, returns "PRIVATE"; if program is remote, returns "NOTAPPLIC"
TRANSID (data-area) | Full
USECOUNT (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE REQID

The INQUIRE REQID function is supported.

Operand | Support
AFTER (data-area) | Validated
AT (data-area) | Validated
FMHSTATUS (cvda) | Validated
INTERVAL (data-area) | Full
LENGTH (data-value) | Validated
NEXT | Full
REQID (data-value) | Full
REQTYPE (cvda) | Validated
RTERMID (data-value) | Validated
RTRANSID (data-value) | Validated
SET (ptr-ref) | Validated
TERMID (data-value) | Validated
TIME (data-area) | Validated
TRANSID (data-value) | Full
Parent topic: CICS SPI Calls


INQUIRE REQUESTMODEL

The INQUIRE REQUESTMODEL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE RRMS

The INQUIRE RRMS function is not supported.

Parent topic: CICS SPI Calls


INQUIRE STATISTICS

The INQUIRE STATISTICS function is not supported.

Operand | Support
ENDOFDAY (data-area) | Recognized
ENDOFDAYHRS (data-area) | Recognized
ENDOFDAYMIN (data-area) | Recognized
ENDOFDAYSEC (data-area) | Recognized
INTERVAL (data-area) | Recognized
INTERVALHRS (data-area) | Recognized
INTERVALMIN (data-area) | Recognized
INTERVALSEC (data-area) | Recognized
NEXTTIME (data-area) | Recognized
NEXTTIMEHRS (data-area) | Recognized
NEXTTIMEMIN (data-area) | Recognized
NEXTTIMESEC (data-area) | Recognized
RECORDING (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE STORAGE

The INQUIRE STORAGE function is not supported.

Parent topic: CICS SPI Calls


INQUIRE STREAMNAME

The INQUIRE STREAMNAME function is not supported.

Parent topic: CICS SPI Calls


INQUIRE SYSDUMPCODE

The INQUIRE SYSDUMPCODE function is not supported.

Operand | Support
CURRENT (data-area) | Recognized
MAXIMUM (data-area) | Recognized
NEXT | Recognized
SHUTOPTION (cvda) | Recognized
SYSDUMPCODE (data-value) | Recognized
SYSDUMPING (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE SYSTEM

The INQUIRE SYSTEM function is supported.

Operand | Support
ACTOPENTCBS (data-area) | Validated
AKP (data-area) | Partial: returns 0 meaning keypoints are not being taken
AMAXTASKS (data-area) | Full
CDSASIZE (data-area) | Partial: returns 0
CICSSTATUS (cvda) | Full
CICSSYS (data-area) | Partial: returns "U", "2" or "D"
CICSTSLEVEL (data-area) | Validated
CMDPROTECT (cvda) | Validated
COLDSTATUS (cvda) | Validated
CSCS (data-area) | Partial: returns 0
DB2CONN (data-area) | Validated
DFLTUSER (data-area) | Validated
DSALIMIT (data-area) | Validated
DSRTPROGRAM (data-area) | Validated
DTRPROGRAM (data-area) | Partial: returns spaces
DUMPING (cvda) | Partial: returns "SYSDUMP"
ECDSASIZE (data-area) | Partial: returns 0
ECSCS (data-area) | Partial: returns 0
EDSALIMIT (data-area) | Validated
ERDSASIZE (data-area) | Partial: returns 0
ERSCS (data-area) | Partial: returns 0
ESDSASIZE (data-area) | Validated
EUDSASIZE (data-area) | Partial: returns 0
EUSCS (data-area) | Partial: returns 0
FORCEQR (cvda) | Validated
GMMLENGTH (data-area) | Validated
GMMTEXT (data-area) | Validated
GMMTRANID (data-area) | Full
INITSTATUS (cvda) | Validated
JOBNAME (data-area) | Full
LOGDEFER (data-area) | Validated
MAXOPENTCBS (data-area) | Validated
MAXTASKS (data-area) | Partial: returns 999 (x"03E7")
MROBATCH (data-area) | Partial: returns 0
OPREL (data-area) | Full
OPSYS (data-area) | Partial: returns "U", "2" or "D"
OSLEVEL (data-area) | Validated
PROGAUTOCTLG (cvda) | Validated
PROGAUTOEXIT (data-area) | Validated
PROGAUTOINST (cvda) | Validated
PRTYAGING (data-area) | Partial: returns 0
RDSASIZE (data-area) | Validated
REENTPROTECT (cvda) | Validated
RELEASE (data-area) | Full
RLSSTATUS (cvda) | Validated
RUNAWAY (data-area) | Partial: returns 0
SCANDELAY (data-area) | Partial: returns 0
SDSASIZE (data-area) | Validated
SDTRAN (data-area) | Validated
SECURITYMGR (cvda) | Partial: returns "NOSECURITY"
SHUTSTATUS (cvda) | Validated
SOSSTATUS (cvda) | Validated
STARTUP (cvda) | Partial: returns "COLDSTART"
STARTUPDATE (data-area) | Validated
STOREPROTECT (cvda) | Partial: returns "INACTIVE"
TIME (data-area) | Partial: returns 0
TRANISOLATE (cvda) | Validated
UDSASIZE (data-area) | Partial: returns 0
USCS (data-area) | Partial: returns 0
XRFSTATUS (cvda) | Partial: returns "PRIMARY"
Parent topic: CICS SPI Calls


INQUIRE TASK

The INQUIRE TASK function is supported.

Operand | Support
ACTIVITY (data-area) | Validated
ACTIVITYID (data-area) | Validated
ATTACHTIME (data-area) | Full
BRIDGE (data-area) | Full
CMDSEC (cvda) | Partial: returns "CMDSECNO"
DB2PLAN (data-area) | Validated
DTB (cvda) | Partial: returns "BACKOUT"
DTIMEOUT (data-area) | Partial: returns 0
DUMPING (cvda) | Full
FACILITY (data-area) | Full
FACILITYTYPE (cvda) | Full
IDENTIFIER (data-area) | Full
INDOUBT (cvda) | Validated
INDOUBTMINS (data-area) | Validated
INDOUBTWAIT (cvda) | Validated
ISOLATEST (cvda) | Partial: returns "ISOLATE"
PRIORITY (data-area) | Full
PROCESS (data-area) | Validated
PROCESSTYPE (data-area) | Validated
PROFILE (data-area) | Partial: returns "DFHCICST"
PROGRAM (data-area) | Full
PURGEABILITY (cvda) | Partial: returns "NOTPURGEABLE"
RECUNITID (data-area) | Full
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
RESNAME (data-area) | Full
RESSEC (cvda) | Full
ROUTING (cvda) | Full
RTIMEOUT (data-area) | Full
RUNAWAY (data-area) | Partial: returns 0
RUNSTATUS (cvda) | Partial: returns "RUNNING" or "SUSPENDED"
SCRNSIZE (cvda) | Partial: returns "DEFAULT"
STARTCODE (data-area) | Full
STORAGECLEAR (cvda) | Partial: returns "NOCLEAR"
SUSPENDTIME (data-area) | Partial: returns 0 meaning the task is running or dispatchable
SUSPENDTYPE (data-area) | Partial: returns spaces meaning the task is running or dispatchable
SUSPENDVALUE (data-area) | Partial: returns spaces meaning the task is running or dispatchable
TASK (data-value) | Full
TASKDATAKEY (cvda) | Partial: returns "USERDATAKEY"
TASKDATALOC (cvda) | Partial: returns "ANY"
TCB (cvda) | Validated
TCLASS (data-area) | Full
TRACING (cvda) | Full
TRANCLASS (data-area) | Partial: returns "DFHTCL00"
TRANPRIORITY (data-area) | Full
TRANSACTION (data-area) | Full
TRPROF (data-area) | Partial: returns spaces
TWASIZE (data-area) | Full
UOW (data-area) | Validated
USERID (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE TASK LIST

The INQUIRE TASK LIST function is supported.

Operand | Support
DISPATCHABLE | Full
LISTSIZE (data-area) | Full
RUNNING | Full
SET (ptr-ref) | Full
SETTRANSID (ptr-ref) | Full
SUSPENDED | Full
Parent topic: CICS SPI Calls


INQUIRE TCLASS

The INQUIRE TCLASS function is supported.

Operand | Support
CURRENT (data-area) | Full
MAXIMUM (data-area) | Full
TCLASS (data-value) | Full
Parent topic: CICS SPI Calls


INQUIRE TCPIP

The INQUIRE TCPIP function is not supported.

Parent topic: CICS SPI Calls


INQUIRE TCPIPSERVICE

The INQUIRE TCPIPSERVICE function is supported.

Operand | Support
ATTACHSEC (cvda) | Full
AUTHENTICATE (cvda) | Full
BACKLOG (data-area) | Full
CERTIFICATE (data-area) | Full
CIPHERS (data-area) | Full
CLOSETIMEOUT (data-area) | Full
CONNECTIONS (data-area) | Partial: returns 0
DNSGROUP (data-area) | Full
DNSSTATUS (cvda) | Partial: returns "UNAVAILABLE"
GRPCRITICAL (cvda) | Full
IPADDRESS (data-area) | Full
MAXDATALEN (data-area) | Full
NEXT | Full
NUMCIPHERS (data-area) | Full
OPENSTATUS (cvda) | Partial: returns only "OPEN" or "CLOSED"
PORT (data-area) | Full
PRIVACY (cvda) | Full
PRIVACY (cvda) | Full
PROTOCOL (cvda) | Full
SOCKETCLOSE (cvda) | Full
SSLTYPE (cvda) | Full
TCPIPSERVICE (data-value) | Full
TRANSID (data-area) | Full
TSQPREFIX (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE TDQUEUE

The INQUIRE TDQUEUE function is supported.

Operand | Support
ATIFACILITY (cvda) | Full
ATITERMID (data-area) | Full
ATITRANID (data-area) | Full
BLOCKFORMAT (cvda) | Full
EMPTYSTATUS (cvda) | Full
ENABLESTATUS (cvda) | Full
INDIRECTNAME (data-area) | Full
IOTYPE (cvda) | Full
NEXT | Full
NUMITEMS (data-area) | Full
OPENSTATUS (cvda) | Full
PRINTCONTROL (cvda) | Full
RECORDFORMAT (cvda) | Full
RECORDLENGTH (data-area) | Full
RECOVSTATUS (cvda) | Full
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
TDQUEUE (data-value) | Full
TRIGGERLEVEL (data-area) | Full
TYPE (cvda) | Full
Parent topic: CICS SPI Calls


INQUIRE TERMINAL

The INQUIRE TERMINAL function is supported.

Operand | Support
ACCESSMETHOD (cvda) | Partial: returns "VTAM"
ACQSTATUS (cvda) | Partial: (VTAM only) returns "ACQUIRED"
ALTPAGEHT (data-area) | Full
ALTPAGEWD (data-area) | Full
ALTPRINTER (data-area) | Partial: returns spaces
ALTPRTCOPYST (cvda) | Partial: returns "NOALTPRTCOPY"
ALTSCRNHT (data-area) | Full
ALTSCRNWD (data-area) | Full
ALTSUFFIX (data-area) | Partial: returns spaces
APLKYBDST (cvda) | Partial: returns "NOAPLKYBD"
APLTEXTST (cvda) | Partial: returns "NOAPLTEXT"
ASCII (cvda) | Full
ATISTATUS (cvda) | Partial: returns "ATI"
AUDALARMST (cvda) | Partial: returns "AUDALARM"
AUTOCONNECT (cvda) | Full
BACKTRANSST (cvda) | Partial: returns "NOBACKTRANS"
COLORST (cvda) | Full
COPYST (cvda) | Partial: returns "NOCOPY"
CREATESESS (cvda) | Partial: returns "NOCREATE"
DATASTREAM (data-area) | Full
DEFPAGEHT (data-area) | Full
DEFPAGEWD (data-area) | Full
DEFSCRNHT (data-area) | Full
DEFSCRNWD (data-area) | Full
DEVICE (cvda) | Partial: returns "T3277L"
DEVICEST (cvda) | Full
DISCREQST (cvda) | Partial: returns "DISCREQ"
DUALCASEST (cvda) | Partial: returns "DUALCASE"
EXITTRACING (cvda) | Partial: returns "NOEXITTRACE"
EXTENDEDDSST (cvda) | Partial: returns "EXTENDEDDS"
FMHPARMST (cvda) | Partial: returns "NOFMHPARM"
FORMFEEDST (cvda) | Partial: returns "NOFORMFEED"
GCHARS (data-area) | Full
GCODES (data-area) | Full
HFORMST (cvda) | Partial: returns "NOHFORM"
HILIGHTST (cvda) | Partial: returns "HILIGHT"
KATAKANAST (cvda) | Partial: returns "NOKATAKANA"
LIGHTPENST (cvda) | Partial: returns "NOLIGHTPEN"
MAPNAME (data-area) | Validated
MAPSETNAME (data-area) | Full
MODENAME (data-area) | Full
MSRCONTROLST (cvda) | Partial: returns "NOMSRCONTROL"
NATLANG (data-area) | Partial: returns "E" meaning US English
NATURE (cvda) | Full
NETNAME (data-area) | Full
NEXT | Full
NEXTTRANSID (data-area) | Partial: returns spaces
OBFORMATST (cvda) | Partial: returns "NOOBFORMAT"
OBOPERIDST (cvda) | Partial: returns "NOOBOPERID"
OPERID (data-area) | Full
OUTLINEST (cvda) | Partial: returns "NOOUTLINE"
PAGEHT (data-area) | Full
PAGESTATUS (cvda) | Partial: returns "PAGEABLE"
PAGEWD (data-area) | Full
PARTITIONSST (cvda) | Partial: returns "NOPARTITIONS"
PRINTADAPTST (cvda) | Partial: returns "NOPRINTADAPT"
PRINTER (data-area) | Partial: returns spaces
PROGSYMBOLST (cvda) | Partial: returns "NOPROGSYMBOL"
PRTCOPYST (cvda) | Partial: returns "NOPRTCOPY"
QUERYST (cvda) | Partial: returns "NOQUERY"
RELREQST (cvda) | Partial: returns "NORELREQ"
REMOTENAME (data-area) | Partial: returns spaces
REMOTESYSTEM (data-area) | Partial: returns spaces
SCREENHEIGHT (data-area) | Full
SCREENWIDTH (data-area) | Full
SCRNHT (data-area) | Full
SCRNWD (data-area) | Full
SECURITY (cvda) | Partial: returns "NOPRESETSEC"
SERVSTATUS (cvda) | Full
SESSIONTYPE (cvda) | Partial: returns "NOTAPPLIC"
SIGNONSTATUS (cvda) | Full
SOSIST (cvda) | Full
TASKID (data-area) | Partial: returns 0 meaning no task is using the terminal
TCAMCONTROL (data-area) | Partial: returns x"00" meaning null
TERMINAL (data-value) | Full
TERMMODEL (data-area) | Partial: returns 2
TERMPRIORITY (data-area) | Full
TERMSTATUS (cvda) | Full
TEXTKYBDST (cvda) | Partial: returns "NOTEXTKYBD"
TEXTPRINTST (cvda) | Partial: returns "NOTEXTPRINT"
TRACING (cvda) | Partial: returns "STANTRACE"
TRANSACTION (data-area) | Full
TTISTATUS (cvda) | Partial: returns "TTI"
UCTRANST (cvda) | Full
USERAREA (ptr-ref) | Full
USERAREALEN (data-area) | Partial: returns 0
USERID (data-area) | Full
USERNAME (data-area) | Partial: returns spaces
VALIDATIONST (cvda) | Partial: returns "NOVALIDATION"
VFORMST (cvda) | Partial: returns "NOVFORM"
ZCPTRACING (cvda) | Partial: returns "NOZCPTRACE"
Parent topic: CICS SPI Calls


INQUIRE TIMER

The INQUIRE TIMER function is not supported.

Parent topic: CICS SPI Calls


INQUIRE TRACEDEST

The INQUIRE TRACEDEST function is not supported.

Operand | Support
AUXSTATUS (cvda) | Recognized
CURAUXDS (data-area) | Recognized
GTFSTATUS (cvda) | Recognized
INTSTATUS (cvda) | Recognized
SWITCHSTATUS (cvda) | Recognized
TABLESIZE (data-area) | Recognized
Parent topic: CICS SPI Calls


INQUIRE TRACEFLAG

The INQUIRE TRACEFLAG function is not supported.

Operand | Support
SINGLESTATUS (cvda) | Recognized
SYSTEMSTATUS (cvda) | Recognized
TCEXITSTATUS (cvda) | Recognized
USERSTATUS (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE TRACETYPE

The INQUIRE TRACETYPE function is not supported.

Operand | Support
AP (data-area) | Recognized
APPLICATION (data-area) | Recognized
BF (data-area) | Recognized
BM (data-area) | Recognized
CP (data-area) | Recognized
CPI (data-area) | Recognized
DC (data-area) | Recognized
DI (data-area) | Recognized
DISPATCHER (data-area) | Recognized
DM (data-area) | Recognized
DOMAINMGR (data-area) | Recognized
DS (data-area) | Recognized
DU (data-area) | Recognized
DUMP (data-area) | Recognized
EI (data-area) | Recognized
FC (data-area) | Recognized
GC (data-area) | Recognized
GLOBALCATLG (data-area) | Recognized
IC (data-area) | Recognized
IS (data-area) | Recognized
JC (data-area) | Recognized
KC (data-area) | Recognized
KE (data-area) | Recognized
KERNEL (data-area) | Recognized
LC (data-area) | Recognized
LD (data-area) | Recognized
LM (data-area) | Recognized
LOADER (data-area) | Recognized
LOCALCATLG (data-area) | Recognized
LOCKMGR (data-area) | Recognized
ME (data-area) | Recognized
MESSAGE (data-area) | Recognized
MN (data-area) | Recognized
MONITOR (data-area) | Recognized
PA (data-area) | Recognized
PARAMGR (data-area) | Recognized
PC (data-area) | Recognized
SC (data-area) | Recognized
SM (data-area) | Recognized
SP (data-area) | Recognized
SPECIAL | Recognized
ST (data-area) | Recognized
STANDARD | Recognized
STATISTICS (data-area) | Recognized
STORAGE (data-area) | Recognized
SZ (data-area) | Recognized
TC (data-area) | Recognized
TD (data-area) | Recognized
TI (data-area) | Recognized
TIMER (data-area) | Recognized
TR (data-area) | Recognized
TRACE (data-area) | Recognized
TS (data-area) | Recognized
UE (data-area) | Recognized
Parent topic: CICS SPI Calls


INQUIRE TRANCLASS

The INQUIRE TRANCLASS function is supported.

Operand | Support
ACTIVE (data-area) | Full
MAXACTIVE (data-area) | Full
NEXT | Full
PURGETHRESH (data-area) | Full
QUEUED (data-value) | Full
TRANCLASS (data-value) | Full
Parent topic: CICS SPI Calls


INQUIRE TRANDUMPCODE

The INQUIRE TRANDUMPCODE function is not supported.

Operand | Support
CURRENT (data-area) | Recognized
MAXIMUM (data-area) | Recognized
NEXT | Recognized
SHUTOPTION (cvda) | Recognized
SYSDUMPING (cvda) | Recognized
TRANDUMPCODE (data-value) | Recognized
TRANDUMPING (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE TRANSACTION

The INQUIRE TRANSACTION function is supported.

Operand | Support
BREXIT (data-area) | Full
CMDSEC (cvda) | Partial: returns "CMDSECNO"
DTB (cvda) | Full
DTIMEOUT (data-area) | Partial: returns 0
DUMPING (cvda) | Full
FACILITYLIKE (data-area) | Full
ISOLATEST (cvda) | Full
NEXT | Full
OTSTIMEOUT (data-area) | Validated
PRIORITY (data-area) | Full
PROFILE (data-area) | Partial: returns spaces
PROGRAM (data-area) | Full
PURGEABILITY (cvda) | Partial: returns "NOTPURGEABLE"
REMOTENAME (data-area) | Full
REMOTESYSTEM (data-area) | Full
RESSEC (cvda) | Full
ROUTING (cvda) | Partial: returns "STATIC"
RTIMEOUT (data-area) | Full
SCRNSIZE (cvda) | Partial: returns "DEFAULT"
STATUS (cvda) | Full
TASKDATAKEY (cvda) | Partial: returns "CICSDATAKEY"
TASKDATALOC (cvda) | Partial: returns "ANY"
TCLASS (data-area) | Partial: returns 0
TRACING (cvda) | Partial: returns "STANTRACE"
TRANCLASS (data-area) | Partial: returns spaces
TRANSACTION (data-value) | Full
TRPROF (data-area) | Partial: returns spaces
TWASIZE (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE TSMODEL

The INQUIRE TSMODEL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE TSPOOL

The INQUIRE TSPOOL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE TSQNAME

The INQUIRE TSQNAME function is not supported.

Operand | Support
FLENGTH (data-area) | Recognized
LASTUSEDINT (data-area) | Recognized
LOCATION (cvda) | Recognized
MAXITEMLEN (data-area) | Recognized
MINITEMLEN (data-area) | Recognized
NEXT | Recognized
NUMITEMS (data-area) | Recognized
POOLNAME (data-value) | Recognized
RECOVSTATUS (data-area) | Recognized
SYSID (data-value) | Recognized
TRANSID (data-value) | Recognized
TSQNAME (data-value) | Recognized
Parent topic: CICS SPI Calls


INQUIRE TSQUEUE

The INQUIRE TSQUEUE function is supported.

Operand | Support
FLENGTH (data-area) | Partial: returns -1
LASTUSEDINT (data-area) | Validated
LOCATION (cvda) | Partial: returns "AUXILIARY"
MAXITEMLEN (data-area) | Partial: returns -1
MINITEMLEN (data-area) | Partial: returns -1
NEXT | Full
NUMITEMS (data-area) | Partial: returns -1
POOLNAME (data-value) | Validated
RECOVSTATUS (data-area) | Validated
SYSID (data-value) | Validated
TRANSID (data-value) | Validated
TSQUEUE (data-value) | Full
Parent topic: CICS SPI Calls


INQUIRE UOW

The INQUIRE UOW function is not supported.

Operand | Support
AGE (data-area) | Recognized
LINK (data-area) | Recognized
NETNAME (data-area) | Recognized
NETUOWID (data-area) | Recognized
NEXT | Recognized
SYSID (data-area) | Recognized
TASKID (data-area) | Recognized
TERMID (data-area) | Recognized
TRANSID (data-area) | Recognized
UOW (data-value) | Recognized
UOWSTATE (data-area) | Recognized
USERID (data-area) | Recognized
WAITCAUSE (cvda) | Recognized
WAITSTATE (cvda) | Recognized
Parent topic: CICS SPI Calls


INQUIRE UOWDSNFAIL

The INQUIRE UOWDSNFAIL function is not supported.

Parent topic: CICS SPI Calls


INQUIRE UOWENQ

The INQUIRE UOWENQ function is not supported.

Parent topic: CICS SPI Calls


INQUIRE UOWLINK

The INQUIRE UOWLINK function is not supported.

Parent topic: CICS SPI Calls


INQUIRE URIMAP

The INQUIRE URIMAP function is supported.

Operand | Support
ANALYZERSTAT (cvda) | Full
CERTIFICATE (data-area) | Full
CHARACTERSET (data-area) | Full
CIPHERS (data-area) | Full
CONVERTER (data-area) | Full
ENABLESTATUS (cvda) | Full
HFSFILE (data-area) | Full
HOST (data-area) | Full
HOSTCODEPAGE (data-area) | Full
LOCATION (data-area) | Full
MEDIATYPE (data-area) | Full
NEXT | Full
NUMCIPHERS (data-area) | Full
PATH (data-area) | Full
PIPELINE (data-area) | Full
PROGRAM (data-area) | Full
REDIRECTTYPE (cvda) | Full
SCHEME (cvda) | Full
TCPIPSERVICE (data-area) | Full
TEMPLATENAME (data-area) | Full
TRANSACTION (data-area) | Full
URIMAP (data-value) | Full
USAGE (cvda) | Full
USERID (data-area) | Full
WEBSERVICE (data-area) | Full
Parent topic: CICS SPI Calls


INQUIRE VOLUME

The INQUIRE VOLUME function is not supported.

Operand | Support
AVAILSTATUS (cvda) | Recognized
DATE (data-area) | Recognized
EMPTYSTATUS (cvda) | Recognized
JOURNALNUM (data-area) | Recognized
NEXT | Recognized
OPENSTATUS (cvda) | Recognized
PART (data-area) | Recognized
TIME (data-area) | Recognized
VOLUME (data-value) | Recognized
Parent topic: CICS SPI Calls


INQUIRE VTAM

The INQUIRE VTAM function is not supported.

Operand | Support
OPENSTATUS (data-area) | Recognized
Parent topic: CICS SPI Calls


INQUIRE WEB

The INQUIRE WEB function is not supported.

Parent topic: CICS SPI Calls


INQUIRE WEBSERVICE

The INQUIRE WEBSERVICE function is supported.

Operand | Support
BINDING (cvda) | Partial: returns spaces
CONTAINER (data-area) | Partial: returns spaces
ENDPOINT (data-area) | Partial: returns spaces
LASTMODTIME (data-area) | Partial: returns 0
NEXT | Full
PGMINTERFACE (cvda) | Partial: returns "COMMAREA"
PIPELINE (data-area) | Full
PROGRAM (data-area) | Partial: returns spaces
STATE (cvda) | Partial: returns "UNUSABLE"
URIMAP (data-area) | Partial: returns spaces
VALIDATIONST (cvda) | Full
WEBSERVICE (data-value) | Full
WSBIND (data-area) | Partial: returns spaces
WSDLFILE (data-area) | Full
Parent topic: CICS SPI Calls


PERFORM CORBASERVER

The PERFORM CORBASERVER function is not supported.

Parent topic: CICS SPI Calls


PERFORM DELETSHIPPED

The PERFORM DELETSHIPPED function is not supported.

Parent topic: CICS SPI Calls


PERFORM DJAR

The PERFORM DJAR function is not supported.

Parent topic: CICS SPI Calls


PERFORM DUMP

The PERFORM DUMP function is supported.

Operand | Support
CALLER (data-value) | Full
CALLERLENGTH (data-value) | Full
DUMPCODE (data-value) | Full
DUMPID (data-area) | Full
TITLE (data-value) | Full
TITLELENGTH (data-value) | Full
Parent topic: CICS SPI Calls


PERFORM ENDAFFINITY

The PERFORM ENDAFFINITY function is not supported.

Parent topic: CICS SPI Calls


PERFORM RESETTIME

The PERFORM RESETTIME function is not supported.

Parent topic: CICS SPI Calls


PERFORM SECURITY REBUILD

The PERFORM SECURITY REBUILD function is not supported.

Operand | Support
ESMRESP (data-area) | Recognized
Parent topic: CICS SPI Calls


PERFORM SHUTDOWN

The PERFORM SHUTDOWN function is supported.

Operand | Support
DUMP | Full
IMMEDIATE | Full
NORESTART | Full
NOSDTRAN | Validated
PLT (data-value) | Full
SDTRAN (data-value) | Validated
TAKEOVER | Validated
XLT (data-value) | Validated
Parent topic: CICS SPI Calls


PERFORM STATISTICS RECORD

The PERFORM STATISTICS RECORD function is not supported.

Operand | Support
ALL | Recognized
AUTOINSTALL | Recognized
CONNECTION | Recognized
CORBASERVER | Recognized
DISPATCHER | Recognized
DTB | Recognized
FILE | Recognized
IRCBATCH | Recognized
JOURNALNUM | Recognized
JVMPOOL | Recognized
LSRPOOL | Recognized
MONITOR | Recognized
PROGRAM | Recognized
REQUESTMODEL | Recognized
RESETNOW | Recognized
STATS | Recognized
STORAGE | Recognized
SYSDUMP | Recognized
TABLEMGR | Recognized
TASKCONTROL | Recognized
TCLASS | Recognized
TCPIP | Recognized
TCPIPSERVICE | Recognized
TDQUEUE | Recognized
TERMINAL | Recognized
TRANDUMP | Recognized
TRANSACTION | Recognized
TSQUEUE | Recognized
VTAM | Recognized
Parent topic: CICS SPI Calls


RESYNC ENTRYNAME

The RESYNC ENTRYNAME function is not supported.

Operand | Support
ENTRYNAME (data-value) | Recognized
IDLIST (data-value) | Recognized
IDLISTLENGTH (data-value) | Recognized
QUALIFIER (data-value) | Recognized
Parent topic: CICS SPI Calls


SET AUTOINSTALL

The SET AUTOINSTALL function is not supported.

Operand | Support
MAXREQS (data-value) | Recognized
PROGRAM (data-value) | Recognized
Parent topic: CICS SPI Calls


SET BRFACILITY

The SET BRFACILITY function is not supported.

Parent topic: CICS SPI Calls


SET CONNECTION

The SET CONNECTION function is supported.

Operand | Support
ACQSTATUS (data-value) | Full
ACQUIRED (cvda) | Full
CONNECTION (data-value) | Full
CONNSTATUS (data-value) | Full
EXITTRACE (cvda) | Full
EXITTRACING (data-value) | Full
FORCEPURGE (cvda) | Full
INSERVICE (cvda) | Full
NOEXITTRACE (cvda) | Full
NOTPENDING (cvda) | Full
NOZCPTRACE (cvda) | Full
OUTSERVICE (cvda) | Full
PENDSTATUS (data-value) | Partial: requires "NOTPENDING"
PURGE (cvda) | Full
PURGETYPE (data-value) | Full
RELEASED (cvda) | Full
SERVSTATUS (data-value) | Full
ZCPTRACE (cvda) | Full
ZCPTRACING (data-value) | Partial: requires "NOZCPTRACE"
Parent topic: CICS SPI Calls


SET CORBASERVER

The SET CORBASERVER function is not supported.

Parent topic: CICS SPI Calls


SET DATASET

The SET DATASET function is supported.

Operand | Support
ADD (data-value) | Full
ADDABLE (cvda) | Full
BROWSABLE (cvda) | Full
BROWSE (data-value) | Full
BUSY (data-value) | Full
CFDTPOOL (data-value) | Validated
CFTABLE (cvda) | Validated
CICSTABLE (cvda) | Validated
CLOSED (cvda) | Full
CONSISTENT (cvda) | Validated
CONTENTION (cvda) | Validated
DATASET (data-value) | Full
DELETABLE (cvda) | Full
DELETE (data-value) | Full
DISABLED (cvda) | Full
DISPOSITION (data-value) | Partial: requires "SHARE"
DSNAME (data-area) | Full
EMPTYREQ (cvda) | Full
EMPTYSTATUS (data-value) | Full
ENABLED (cvda) | Full
ENABLESTATUS (data-value) | Full
EXCLUSIVE (data-value) | Partial: requires "NOTAPPLIC"
EXCTL (cvda) | Full
FILE (data-value) | Full
FORCE (cvda) | Full
KEYLENGTH (data-value) | Validated
LOAD (cvda) | Validated
LOADTYPE (data-value) | Validated
LOCKING (cvda) | Validated
LSRPOOLID (data-area) | Partial: requires 0
MAXNUMRECS (data-area) | Partial: requires 0
NOEMPTYREQ (cvda) | Full
NOEXCTL (cvda) | Full
NOLOAD (cvda) | Validated
NOTADDABLE (cvda) | Full
NOTAPPLIC (cvda) | Validated
NOTBROWSABLE (cvda) | Full
NOTDELETABLE (cvda) | Full
NOTREADABLE (cvda) | Full
NOTRLS (cvda) | Validated
NOTTABLE (cvda) | Validated
NOTUPDATABLE (cvda) | Full
NOWAIT (cvda) | Full
OBJECTNAME (data-area) | Full
OLD (cvda) | Full
OPEN (cvda) | Full
OPENSTATUS (data-value) | Full
READ (data-value) | Full
READABLE (cvda) | Full
READINTEG (data-value) | Validated
RECORDSIZE (data-value) | Validated
REPEATABLE (cvda) | Validated
RLS (cvda) | Validated
RLSACCESS (data-value) | Validated
SHARE (cvda) | Full
STRINGS (data-area) | Partial: requires 1
TABLE (data-value) | Validated
TABLENAME (data-value) | Validated
UNCOMMITTED (cvda) | Validated
UPDATABLE (cvda) | Full
UPDATE (data-value) | Full
UPDATEMODEL (data-value) | Validated
USERTABLE (cvda) | Validated
WAIT (cvda) | Full
Parent topic: CICS SPI Calls


SET DB2CONN

The SET DB2CONN function is not supported.

Parent topic: CICS SPI Calls


SET DB2ENTRY

The SET DB2ENTRY function is not supported.

Parent topic: CICS SPI Calls


SET DB2TRAN

The SET DB2TRAN function is not supported.

Parent topic: CICS SPI Calls


SET DELETSHIPPED

The SET DELETSHIPPED function is not supported.

Parent topic: CICS SPI Calls


SET DISPATCHER

The SET DISPATCHER function is not supported.

Parent topic: CICS SPI Calls


SET DOCTEMPLATE

The SET DOCTEMPLATE function is supported.

Operand | Support
COPY (data-value) | Full
DOCTEMPLATE (data-value) | Full
NEWCOPY (cvda) | Full
Parent topic: CICS SPI Calls


SET DSNAME

The SET DSNAME function is not supported.

Operand | Support
ACTION (data-value) | Recognized
AVAILABILITY (data-value) | Recognized
AVAILABLE (cvda) | Recognized
BACKOUT (cvda) | Recognized
BKOUTSTATUS (data-value) | Recognized
BUSY (data-value) | Recognized
COMMIT (cvda) | Recognized
DSNAME (data-value) | Recognized
FAILEDBKOUT (cvda) | Recognized
FORCE (cvda) | Recognized
IMMQUIESCED (cvda) | Recognized
NORMALBKOUT (cvda) | Recognized
NOWAIT (cvda) | Recognized
QUIESCED (cvda) | Recognized
QUIESCESTATE (data-value) | Recognized
RECOVERED (cvda) | Recognized
REMOVE (cvda) | Recognized
RESETLOCKS (cvda) | Recognized
RETRY (cvda) | Recognized
UNAVAILABLE (cvda) | Recognized
UNQUIESCED (cvda) | Recognized
UOWACTION (data-value) | Recognized
WAIT (cvda) | Recognized
Parent topic: CICS SPI Calls


SET DUMPDS

The SET DUMPDS function is not supported.

Operand | Support
CLOSED (cvda) | Recognized
INITIALDDS (data-value) | Recognized
NOSWITCH (cvda) | Recognized
OPEN (cvda) | Recognized
OPENSTATUS (data-value) | Recognized
SWITCH (cvda) | Recognized
SWITCHNEXT (cvda) | Recognized
SWITCHSTATUS (data-value) | Recognized
Parent topic: CICS SPI Calls


SET ENQMODEL

The SET ENQMODEL function is not supported.

Parent topic: CICS SPI Calls


SET FILE

The SET FILE function is supported.

Operand | Support
ADD (data-value) | Full
ADDABLE (cvda) | Full
BROWSABLE (cvda) | Full
BROWSE (data-value) | Full
BUSY (data-value) | Full
CFDTPOOL (data-value) | Validated
CFTABLE (cvda) | Validated
CICSTABLE (cvda) | Validated
CLOSED (cvda) | Full
CONSISTENT (cvda) | Validated
CONTENTION (cvda) | Validated
DATASET (data-value) | Full
DELETABLE (cvda) | Full
DELETE (data-value) | Full
DISABLED (cvda) | Full
DISPOSITION (data-value) | Partial: requires "SHARE"
DSNAME (data-area) | Full
EMPTYREQ (cvda) | Full
EMPTYSTATUS (data-value) | Full
ENABLED (cvda) | Full
ENABLESTATUS (data-value) | Full
EXCLUSIVE (data-value) | Partial: requires "NOTAPPLIC"
EXCTL (cvda) | Full
FILE (data-value) | Full
FORCE (cvda) | Full
KEYLENGTH (data-value) | Validated
LOAD (cvda) | Validated
LOADTYPE (data-value) | Validated
LOCKING (cvda) | Validated
LSRPOOLID (data-area) | Partial: requires 0
MAXNUMRECS (data-area) | Partial: requires 0
NOEMPTYREQ (cvda) | Full
NOEXCTL (cvda) | Full
NOLOAD (cvda) | Validated
NOTADDABLE (cvda) | Full
NOTAPPLIC (cvda) | Validated
NOTBROWSABLE (cvda) | Full
NOTDELETABLE (cvda) | Full
NOTREADABLE (cvda) | Full
NOTRLS (cvda) | Validated
NOTTABLE (cvda) | Validated
NOTUPDATABLE (cvda) | Full
NOWAIT (cvda) | Full
OBJECTNAME (data-area) | Full
OLD (cvda) | Full
OPEN (cvda) | Full
OPENSTATUS (data-value) | Full
READ (data-value) | Full
READABLE (cvda) | Full
READINTEG (data-value) | Validated
RECORDSIZE (data-value) | Validated
REPEATABLE (cvda) | Validated
RLS (cvda) | Validated
RLSACCESS (data-value) | Validated
SHARE (cvda) | Full
STRINGS (data-area) | Partial: requires 1
TABLE (data-value) | Validated
TABLENAME (data-value) | Validated
UNCOMMITTED (cvda) | Validated
UPDATABLE (cvda) | Full
UPDATE (data-value) | Full
UPDATEMODEL (data-value) | Validated
USERTABLE (cvda) | Validated
WAIT (cvda) | Full
Parent topic: CICS SPI Calls


SET IRC

The SET IRC function is not supported.

Operand | Support
CLOSED (cvda) | Recognized
IMMCLOSE (cvda) | Recognized
OPEN (cvda) | Recognized
OPENSTATUS (data-value) | Recognized
Parent topic: CICS SPI Calls


SET JOURNALNAME

The SET JOURNALNAME function is not supported.

Parent topic: CICS SPI Calls


SET JOURNALNUM

The SET JOURNALNUM function is supported.

Operand | Support
ADVANCE (cvda) | Full
CLOSED (cvda) | Full
CLOSELEAVE (cvda) | Full
JOURNALNUM (data-value) | Full
OPENOUTPUT (cvda) | Full
OPENSTATUS (data-value) | Full
Parent topic: CICS SPI Calls


SET JVMPOOL

The SET JVMPOOL function is not supported.

Parent topic: CICS SPI Calls


SET MODENAME

The SET MODENAME function is not supported.

Operand | Support
ACQSTATUS (data-area) | Recognized
ACQUIRED (cvda) | Recognized
AVAILABLE (data-value) | Recognized
CLOSED (cvda) | Recognized
CONNECTION (data-value) | Recognized
MODENAME (data-value) | Recognized
Parent topic: CICS SPI Calls


SET MONITOR

The SET MONITOR function is not supported.

Operand | Support
EVENT (cvda) | Recognized
EVENTCLASS (data-value) | Recognized
EXCEPT (cvda) | Recognized
EXCEPTCLASS (data-value) | Recognized
NOEVENT (cvda) | Recognized
NOEXCEPT (cvda) | Recognized
NOPERF (cvda) | Recognized
OFF (cvda) | Recognized
ON (cvda) | Recognized
PERF (cvda) | Recognized
PERFCLASS (data-value) | Recognized
STATUS (data-value) | Recognized
Parent topic: CICS SPI Calls


SET NETNAME

The SET NETNAME function is supported.

Operand | Support
EXITTRACE (cvda) | Full
EXITTRACING (data-value) | Partial: requires "NOEXITTRACE"
NETNAME (data-value) | Full
NOEXITTRACE (cvda) | Full
Parent topic: CICS SPI Calls


SET PIPELINE

The SET PIPELINE function is supported.

Operand | Support
DISABLED (cvda) | Full
ENABLED (cvda) | Full
ENABLESTATUS (data-value) | Full
PIPELINE (data-value) | Full
Parent topic: CICS SPI Calls


SET PROCESSTYPE

The SET PROCESSTYPE function is not supported.

Parent topic: CICS SPI Calls


SET PROGRAM

The SET PROGRAM function is supported.

Operand | Support
CEDF (cvda) | Full
CEDFSTATUS (data-value) | Partial: requires "NOCEDF"
COPY (data-value) | Full
DISABLED (cvda) | Full
DPLSUBSET (cvda) | Full
ENABLED (cvda) | Full
EXECUTIONSET (data-value) | Partial: requires "FULLAPI"
FULLAPI (cvda) | Full
HOTPOOL (cvda) | Validated
HOTPOOLING (data-value) | Validated
JVM (cvda) | Validated
JVMCLASS (data-area) | Validated
NEWCOPY (cvda) | Full
NOCEDF (cvda) | Full
NOJVM (cvda) | Validated
NOTHOTPOOL (cvda) | Validated
PHASEIN (cvda) | Full
PRIVATE (cvda) | Full
PROGRAM (data-value) | Full
RUNTIME (data-value) | Validated
SHARED (cvda) | Full
SHARESTATUS (data-value) | Partial: requires ""
STATUS (data-value) | Partial: if program is local, returns "PRIVATE"; if program is remote, returns "NOTAPPLIC"
VERSION (data-value) | Partial: requires "NEWCOPY"
Parent topic: CICS SPI Calls


SET STATISTICS

The SET STATISTICS function is not supported.

Operand | Support
ENDOFDAY (data-value) | Recognized
ENDOFDAYHRS (data-value) | Recognized
ENDOFDAYMINS (data-value) | Recognized
ENDOFDAYSECS (data-value) | Recognized
INTERVAL (data-value) | Recognized
INTERVALHRS (data-value) | Recognized
INTERVALMINS (data-value) | Recognized
INTERVALSECS (data-value) | Recognized
OFF (cvda) | Recognized
ON (cvda) | Recognized
RECORDING (data-value) | Recognized
RECORDNOW | Recognized
RESETNOW | Recognized
Parent topic: CICS SPI Calls


SET SYSDUMPCODE

The SET SYSDUMPCODE function is not supported.

Operand | Support
ACTION (data-value) | Recognized
ADD (cvda) | Recognized
MAXIMUM (data-value) | Recognized
NOSHUTDOWN (cvda) | Recognized
NOSYSDUMP (cvda) | Recognized
REMOVE (cvda) | Recognized
RESET (cvda) | Recognized
SHUTDOWN (cvda) | Recognized
SHUTOPTION (data-value) | Recognized
SYSDUMP (cvda) | Recognized
SYSDUMPCODE (data-value) | Recognized
SYSDUMPING (data-value) | Recognized
Parent topic: CICS SPI Calls


SET SYSTEM

The SET SYSTEM function is supported.

Operand | Support
AKP (data-value) | Partial: requires "FULLAPI"
AMAXTASKS (data-value) | Full
CSCS (data-value) | Partial: requires ""
CUSHION (data-value) | Partial: requires ""
DTRPROGRAM (data-value) | Full
DUMPING (data-value) | Partial: requires ""
ECSCS (data-value) | Validated
ECUSHION (data-value) | Validated
ERSCS (data-value) | Validated
EUSCS (data-value) | Validated
MAXTASKS (data-value) | Partial: requires 999
MROBATCH (data-value) | Full
NEWMAXTASKS (data-value) | Full
NOSYSDUMP (cvda) | Full
PRTYAGING (data-value) | Full
RUNAWAY (data-value) | Full
SCANDELAY (data-value) | Full
SYSDUMP (cvda) | Full
TIME (data-value) | Full
USCS (data-value) | Validated
Parent topic: CICS SPI Calls


SET TASK

The SET TASK function is not supported.

Operand | Support
FORCEPURGE (cvda) | Recognized
PRIORITY (data-value) | Recognized
PURGE (cvda) | Recognized
PURGETYPE (data-value) | Recognized
TASK (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TCLASS

The SET TCLASS function is not supported.

Operand | Support
MAXIMUM (data-value) | Recognized
TCLASS (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TCPIP

The SET TCPIP function is not supported.

Parent topic: CICS SPI Calls


SET TCPIPSERVICE

The SET TCPIPSERVICE function is supported.

Operand | Support
BACKLOG (data-area) | Full
CLOSED (cvda) | Full
DEREGISTERED (cvda) | Full
DNSSTATUS (data-value) | Partial: not yet implemented
IMMCLOSE (cvda) | Full
MAXDATALEN (data-area) | Full
OPEN (cvda) | Full
OPENSTATUS (data-value) | Partial: IMMCLOSE sets CLOSED
TCPIPSERVICE (data-value) | Full
URM (data-value) | Full
Parent topic: CICS SPI Calls


SET TDQUEUE

The SET TDQUEUE function is supported.

Operand | Support
ATIFACILITY (data-value) | Full
ATITERMID (data-value) | Full
ATITRANID (data-value) | Full
CLOSED (cvda) | Full
DISABLED (cvda) | Full
ENABLED (cvda) | Full
ENABLESTATUS (data-value) | Full
NOTERMINAL (cvda) | Full
OPEN (cvda) | Full
OPENSTATUS (data-value) | Full
TDQUEUE (data-value) | Full
TERMINAL (cvda) | Full
TRIGGERLEVEL (data-value) | Full
Parent topic: CICS SPI Calls


SET TERMINAL

The SET TERMINAL function is supported.

Operand | Support
ACQSTATUS (data-value) | Full
ACQUIRED (cvda) | Full
ALTPRINTER (data-value) | Partial: requires spaces
ALTPRTCOPY (cvda) | Full
ALTPRTCOPYST (data-value) | Partial: requires "NOALTPRTCOPY"
ATI (cvda) | Full
ATISTATUS (data-value) | Full
AUTOPAGEABLE (cvda) | Full
COLDACQ (cvda) | Full
CREATE (cvda) | Full
CREATESESS (data-value) | Partial: requires "NOCREATE"
DISCREQ (cvda) | Full
DISCREQST (data-value) | Full
EXITTRACE (cvda) | Full
EXITTRACING (data-value) | Partial: requires "NOEXITTRACE"
FORCEPURGE (cvda) | Full
INSERVICE (cvda) | Full
NEXTTRANSID (data-value) | Full
NOALTPRTCOPY (cvda) | Full
NOATI (cvda) | Full
NOCREATE (cvda) | Full
NODISCREQ (cvda) | Full
NOEXITTRACE (cvda) | Full
NOOBFORMAT (cvda) | Full
NOPRTCOPY (cvda) | Full
NORELREQ (cvda) | Full
NOTTI (cvda) | Full
NOUCTRAN (cvda) | Full
NOZCPTRACE (cvda) | Full
OBFORMAT (cvda) | Full
OBFORMATST (data-value) | Partial: requires "NOOBFORMAT"
OPERID (data-value) | Full
OUTSERVICE (cvda) | Full
PAGEABLE (cvda) | Full
PAGESTATUS (data-value) | Full
PRINTER (data-value) | Full
PRTCOPY (cvda) | Full
PRTCOPYST (data-value) | Partial: requires "NOPRTCOPY"
PURGE (cvda) | Full
PURGETYPE (data-value) | Full
RELEASED (cvda) | Full
RELREQ (cvda) | Full
RELREQST (data-value) | Partial: requires "NORELREQ"
SERVSTATUS (data-value) | Full
SPECTRACE (cvda) | Full
STANTRACE (cvda) | Full
TCAMCONTROL (data-value) | Partial: requires x"00" meaning no change
TERMINAL (data-value) | Full
TERMPRIORITY (data-value) | Full
TERMSTATUS (data-value) | Full
TRACING (data-value) | Partial: requires "STANTRACE"
TRANIDONLY (cvda) | Full
TTI (cvda) | Full
TTISTATUS (data-value) | Full
UCTRAN (cvda) | Full
UCTRANST (data-value) | Full
ZCPTRACE (cvda) | Full
ZCPTRACING (data-value) | Partial: requires "NOZCPTRACE"
Parent topic: CICS SPI Calls


SET TRACEDEST

The SET TRACEDEST function is not supported.

Operand | Support
AUXPAUSE (cvda) | Recognized
AUXSTART (cvda) | Recognized
AUXSTATUS (data-value) | Recognized
AUXSTOP (cvda) | Recognized
GTFSTART (cvda) | Recognized
GTFSTATUS (data-value) | Recognized
GTFSTOP (cvda) | Recognized
INTSTART (cvda) | Recognized
INTSTATUS (data-value) | Recognized
INTSTOP (cvda) | Recognized
NOSWITCH (cvda) | Recognized
SWITCH (cvda) | Recognized
SWITCHACTION (data-value) | Recognized
SWITCHALL (cvda) | Recognized
SWITCHNEXT (cvda) | Recognized
SWITCHSTATUS (data-value) | Recognized
TABLESIZE (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TRACEFLAG

The SET TRACEFLAG function is not supported.

Operand | Support
SINGLEOFF (cvda) | Recognized
SINGLEON (cvda) | Recognized
SINGLESTATUS (data-value) | Recognized
SYSTEMOFF (cvda) | Recognized
SYSTEMON (cvda) | Recognized
SYSTEMSTATUS (data-value) | Recognized
TCEXITALL (cvda) | Recognized
TCEXITALLOFF (cvda) | Recognized
TCEXITNONE (cvda) | Recognized
TCEXITSTATUS (data-value) | Recognized
TCEXITSYSTEM (cvda) | Recognized
USEROFF (cvda) | Recognized
USERON (cvda) | Recognized
USERSTATUS (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TRACETYPE

The SET TRACETYPE function is not supported.

Operand | Support
AP (data-value) | Recognized
APPLICATION (data-value) | Recognized
BF (data-value) | Recognized
BM (data-value) | Recognized
CP (data-value) | Recognized
CPI (data-value) | Recognized
DC (data-value) | Recognized
DI (data-value) | Recognized
DISPATCHER (data-value) | Recognized
DM (data-value) | Recognized
DOMAINMGR (data-value) | Recognized
DS (data-value) | Recognized
DU (data-value) | Recognized
DUMP (data-value) | Recognized
EI (data-value) | Recognized
FC (data-value) | Recognized
GC (data-value) | Recognized
GLOBALCATLG (data-value) | Recognized
IC (data-value) | Recognized
IS (data-value) | Recognized
JC (data-value) | Recognized
KC (data-value) | Recognized
KE (data-value) | Recognized
KERNEL (data-value) | Recognized
LC (data-value) | Recognized
LD (data-value) | Recognized
LM (data-value) | Recognized
LOADER (data-value) | Recognized
LOCALCATLG (data-value) | Recognized
LOCKMGR (data-value) | Recognized
ME (data-value) | Recognized
MESSAGE (data-value) | Recognized
MN (data-value) | Recognized
MONITOR (data-value) | Recognized
PA (data-value) | Recognized
PARAMGR (data-value) | Recognized
PC (data-value) | Recognized
SC (data-value) | Recognized
SM (data-value) | Recognized
SP (data-value) | Recognized
SPECIAL | Recognized
ST (data-value) | Recognized
STANDARD | Recognized
STATISTICS (data-value) | Recognized
STORAGE (data-value) | Recognized
SZ (data-value) | Recognized
TC (data-value) | Recognized
TD (data-value) | Recognized
TI (data-value) | Recognized
TIMER (data-value) | Recognized
TR (data-value) | Recognized
TRACE (data-value) | Recognized
TS (data-value) | Recognized
UE (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TRANCLASS

The SET TRANCLASS function is not supported.

Parent topic: CICS SPI Calls


SET TRANDUMPCODE

The SET TRANDUMPCODE function is not supported.

Operand | Support
ACTION (data-value) | Recognized
ADD (cvda) | Recognized
MAXIMUM (data-value) | Recognized
NOSHUTDOWN (cvda) | Recognized
NOSYSDUMP (cvda) | Recognized
NOTRANDUMP (cvda) | Recognized
REMOVE (cvda) | Recognized
RESET (cvda) | Recognized
SHUTDOWN (cvda) | Recognized
SHUTOPTION (data-value) | Recognized
SYSDUMP (cvda) | Recognized
SYSDUMPING (data-value) | Recognized
TRANDUMP (cvda) | Recognized
TRANDUMPCODE (data-value) | Recognized
TRANDUMPING (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TRANSACTION

The SET TRANSACTION function is supported.

Operand | Support
DISABLED (cvda) | Full
DUMPING (data-value) | Full
ENABLED (cvda) | Full
NOTPURGEABLE (cvda) | Full
NOTRANDUMP (cvda) | Full
OTSTIMEOUT (data-area) | Validated
PRIORITY (data-value) | Full
PRIORITY (data-value) | Validated
PURGEABILITY (data-value) | Full
PURGEABLE (cvda) | Full
RUNAWAYTYPE (data-value) | Validated
SHUTDISABLED (cvda) | Validated
SHUTDOWN (data-value) | Validated
SHUTENABLED (cvda) | Validated
SPECTRACE (cvda) | Full
SPRSTRACE (cvda) | Full
STANTRACE (cvda) | Full
STATUS (data-value) | Full
SYSTEM (cvda) | Validated
TCLASS (data-value) | Full
TRACING (data-value) | Partial: requires "STANTRACE"
TRANCLASS (data-value) | Full
TRANDUMP (cvda) | Full
TRANSACTION (data-value) | Full
USER (cvda) | Validated
Parent topic: CICS SPI Calls


SET TSQNAME

The SET TSQNAME function is not supported.

Operand | Support
ACTION (data-value) | Recognized
DELETE (cvda) | Recognized
LASTUSEDINT (data-value) | Recognized
POOLNAME (data-value) | Recognized
SYSID (data-value) | Recognized
TSQNAME (data-value) | Recognized
Parent topic: CICS SPI Calls


SET TSQUEUE

The SET TSQUEUE function is not supported.

Operand | Support
ACTION (data-value) | Recognized
DELETE (cvda) | Recognized
LASTUSEDINT (data-value) | Recognized
POOLNAME (data-value) | Recognized
SYSID (data-value) | Recognized
TSQUEUE (data-value) | Recognized
Parent topic: CICS SPI Calls


SET UOW

The SET UOW function is not supported.

Operand | Support
BACKOUT (cvda) | Recognized
COMMIT (cvda) | Recognized
FORCE (cvda) | Recognized
UOW (data-value) | Recognized
UOWSTATE (data-value) | Recognized
Parent topic: CICS SPI Calls


SET UOWLINK

The SET UOWLINK function is not supported.

Parent topic: CICS SPI Calls


SET URIMAP

The SET URIMAP function is supported.

Operand | Support
DISABLED (cvda) | Full
ENABLED (cvda) | Full
ENABLESTATUS (data-value) | Full
LOCATION (data-area) | Full
NONE (cvda) | Full
PERMANENT (cvda) | Full
REDIRECTTYPE (cvda) | Full
TEMPORARY (cvda) | Full
URIMAP (data-value) | Full
Parent topic: CICS SPI Calls


SET VOLUME

The SET VOLUME function is not supported.

Operand | Support
ACTION (data-value) | Recognized
ADD (cvda) | Recognized
AVAILSTATUS (data-value) | Recognized
JOURNALNUM (data-value) | Recognized
NOWRITE (cvda) | Recognized
OK (cvda) | Recognized
REMOVE (cvda) | Recognized
VOLUME (data-value) | Recognized
Parent topic: CICS SPI Calls


SET VTAM

The SET VTAM function is not supported.

Operand | Support
CLOSED (cvda) | Recognized
FORCECLOSE (cvda) | Recognized
IMMCLOSE (cvda) | Recognized
OPEN (cvda) | Recognized
OPENSTATUS (data-value) | Recognized
Parent topic: CICS SPI Calls


SET WEB

The SET WEB function is not supported.

Parent topic: CICS SPI Calls


SET WEBSERVICE

The SET WEBSERVICE function is supported.

Operand | Support
NOVALIDATION (cvda) | Full
VALIDATION (cvda) | Full
VALIDATIONST (data-value) | Full
WEBSERVICE (data-value) | Full
Parent topic: CICS SPI Calls


Overview of the BMS Painter

The BMS Painter is a powerful, flexible tool for designing maps and generating the BMS macros necessary for creating displayable mapset objects. The painter can also generate the corresponding copybooks needed for using these maps from your program, and compile them into executable modules.

It is assumed that you are familiar with BMS fields, maps and mapsets and with the DFHMDF, DFHMDI and DFHMSD macros.

The following terminology is used both in this chapter and by the painter itself:

Field
An area, of a specified number of columns on an entry or display panel, designed to contain a single item of information of specified attributes and properties. Fields are arranged for display on a map. A painter field corresponds to a BMS field and is generated as a DFHMDF macro.
Attributes
Settings for the visible appearance of a field, for example, foreground and background color and highlighting.
Properties
Settings for the behavior and internal representation of a field or a map (for example, picture, justification, validation) or of a mapset (for example, BMS level, language, storage).
Map
An arrangement of fields on a display panel, designed for the entry and display of related items of information. A painter map corresponds to a BMS display map and is generated into the BMS macro file as a DFHMDI macro.
Mapset
A collection of related maps that generally are used for a single transaction. A painter mapset corresponds to a BMS mapset and is generated into the BMS macro file as a DFHMSD macro.
  • Using the BMS Painter
    Use the painter to design and define panels for the entry and display of data.
  • The Painter Window
    Use the painter window to create and edit maps.
Parent topic: Micro Focus BMS Screen Painter


Using the BMS Painter

Use the painter to design and define panels for the entry and display of data.

To do this, you define maps and mapsets and generate these definitions into the corresponding BMS macros and COBOL and Assembler copybooks. You can create new maps or edit existing ones, whether created by you or downloaded from the mainframe (see the section Working with Previously Created Maps). You can create and edit a mapset either within a project or independently of any project.

You create a map by painting on it fields with specified attributes and properties. You design the map on-screen, so you can control precisely how it should appear.

Everything you paint on a map in a painter session is either static text or a named field. Both are automatically defined as fields (DFHMDF macros) when you generate the BMS macro file. For example:

  • If you only specify the text Name: on a map and then generate the BMS macro file, the painter defines that text as a 5-character autoskip (display-only) field with a constant value. (This is an unnamed DFHMDF macro.)
  • If, on the other hand, you want to control the usage of an area on the screen and the type of values it can contain, you must use the painter to define it explicitly as a field. This results in either a protected or an unprotected field defined in the BMS macro file and the appropriate variable described in the copybook.

By default, the painter generates copybook data descriptions for each field at the same level. You can, however, create group items by defining groups of fields in the painter.

Each field you create in the painter is generated as a BMS DFHMDF macro. Each field is also part of a map. With the painter you can group a collection of maps into a mapset. When you generate the BMS macro file, a DFHMDI macro defines each map and a DFHMSD macro defines the mapset.

The BMS Painter generates a BMS macro file (.bms file) as its output. By compiling this BMS macro file from the Files View you can generate a BMS COBOL copybook (.cpy file), Assembler copybook (.mac file) and a BMS load module (.mod file). Output options are explained in more detail in the section Generating Output from the Painter.

Parent topic: Overview of the BMS Painter
Related concepts
Working with Previously Created Maps
Generating Output from the Painter


The Painter Window

Use the painter window to create and edit maps.

The window, shown in the figure below, is divided into two panes.

The left-hand pane contains a tree view of the mapset that is being edited. At the top level of the tree is the mapset name and beneath it, at the second level, are the names of the maps within the mapset. Beneath each map name, at the third level, are the names of the individual fields within the map. If a field does not have a name because it is a protected field that cannot receive input, the tree shows the field as "static text". You can expand and contract the tree view by clicking the + and - symbols to the left of the mapset and map names.

The right-hand pane of the painter window shows the contents of the map you are editing as it would appear on the terminal screen when displayed by the CICS transaction that uses it. In the right-hand pane you can add and delete fields and move and copy individual fields or groups of fields. You can initialize fields with text and define whether or not they can receive input. While you are editing the map in the right-hand pane, the tree view in the left-hand pane is constantly updated to highlight the field that is being edited.

You can edit more than one map in a painter session by using the new window function of the IDE (click New Window on the Window menu). You can then use the painter clipboard to copy from one map to another within a mapset. You can also have more than one painter session open (although they must be for different mapsets) and, again using the painter clipboard, you can copy between mapsets.

Note: You cannot copy and paste between the painter and the system clipboard.

The title bar at the top of the painter window shows the name of the BMS macro (.bms) file you are editing (unless this is a new file which you have not yet saved). You see an asterisk to the right of this filename whenever there are unsaved changes during the painter session. The asterisk disappears when the BMS macro file is saved.

The status line at the bottom of the IDE window shows, on the left, the painter operation being performed and, on the right, the position of the cursor. The cursor position is shown both as the line number and column number within the map and as the absolute position (or offset) from the start of the map.

Parent topic: Overview of the BMS Painter


Configuring the Painter

You can configure the BMS screen painter using the BMS Screen Painter Options dialog box.

Click BMS on the Options menu of the IDE to display this dialog box as shown in the figure below.

The default settings on this dialog box should enable you to edit an existing BMS macro file or create a new mapset.

See the popup help for each field for a description of what it does - click ? in the title bar, then click the field.

You can see the View page of this dialog box in the figure below.

Here you can specify whether the tree view shows macro entries or copybook entries.

Parent topic: Micro Focus BMS Screen Painter


Build Settings for the BMS Screen Painter

You specify BMS build settings for the BMS screen painter in the properties of the BMS file within Studio Enterprise Edition.

When the BMS file is opened from the Studio Enterprise Edition IDE, the BMS build settings are passed to the BMS screen painter.

You can use the Studio Enterprise Edition templates to create and add BMS mapsets to your projects. In the IDE, you can open the BMS file properties and set the required BMS build settings. These settings are then used when you invoke the BMS screen painter from Studio Enterprise Edition.

The BMS build settings enable you to:

  • Specify what types of output you want the screen painter to produce
  • Enable SDF features
  • Specify an SDF prefix
  • Specify alignment
  • Override the default names given to output files (but only if you are specifying build settings for an individual .bms file)
  • Specify what COBOL levels you want to be used for data items generated by the screen painter
  • Specify decimal point and currency characters
  • Specify that long macro lines can be used
  • Specify additional directives
Parent topic: Micro Focus BMS Screen Painter
Related concepts
Generating Output from the Painter
Working with Maps
Working with Previously Created Maps
Copybooks and Load Modules


Working with Maps

When you have a map open in the BMS screen painter, you can:

  • Define individual fields

    Fields can be single or repeating and you define them by specifying text or by marking the relevant area on the map in the painter window.

    Any string of characters that you specify on a map is automatically generated by the painter as an autoskip BMS field. You must explicitly define any field you intend to use for displaying or accepting variable data; see the section Defining Field Properties.

  • Define groups of fields: standard BMS groups and SDF groups

    You can define groups of fields, for which you can specify common attributes for all the fields in the group. When you define a standard BMS group, you generate both a value for the BMS GRPNAME operand and a group item in the copybook.

  • Define SDF arrays

    You can define an SDF array by creating additional occurrences of a single field that you have already defined. The field must have a name defined for it on the Field Properties dialog box either in Field Name on the General page or in Name in the Field section on the SDF page. In the latter case the painter generates a field name on the General page.

    To create an SDF group or an SDF array you must have enabled the SDF option in the BMS file properties. See Build Settings for the BMS Screen Painter.

  • Move fields

    You can move fields within a map either as single fields or in groups of fields. You can move fields between maps using the clipboard

  • Copy fields and groups

    You can copy fields within a map either as single fields or in groups of fields. When a field is copied, its properties are copied as well, except for any SDF array or SDF group information.

  • Delete fields

    You can delete fields and groups of fields.

Parent topic: Micro Focus BMS Screen Painter
Related concepts
Build Settings for the BMS Screen Painter


Defining Field, Map and Mapset Properties

You define the properties of fields, maps and mapsets using the Field Properties, Map Properties and Mapset Properties dialog boxes.

Many properties appear in all three dialog boxes, and where such properties are concerned, there is a hierarchy, with field properties at the top and mapset properties at the bottom. For example, you can specify at mapset level that entry fields are white; you can override this setting at the map level for all the fields in a map, and at field level for an individual field.

Note:

If you specify the blink attribute, each affected field is displayed in the BMS Screen Painter window exactly as it would appear on the terminal screen. However, this attribute cannot be displayed in the Application Output window when the project is being run or debugged within the development system

  • Defining Field Properties
    Use the Field Properties dialog box to define the properties of a field.
  • Defining Map Properties
    Use the Map Properties dialog box to define the properties of the map.
  • Defining Mapset Properties
    Use the Mapset Properties dialog box to define the properties of the mapset.
Parent topic: Micro Focus BMS Screen Painter


Defining Field Properties

Use the Field Properties dialog box to define the properties of a field.

Right-click the field in the right-hand pane of the painter window and click Properties to display the Field Properties dialog box shown in the figure below.

The properties shown on the General page are the ones you are most likely to want to set. In particular, to make a field able to accept input you must set it as unprotected. To do this, click Unprot in the Attrb area of the General page.

Parent topic: Defining Field, Map and Mapset Properties


Defining Map Properties

Use the Map Properties dialog box to define the properties of the map.

Double-click the map name in the tree view in the left-hand pane of the painter window to display the Map Properties dialog box, shown in the figure below.

These properties set the operand values for the corresponding BMS map definition macro DFHMDI.

Pages on the dialog box show the map properties. Depending on the configuration options set for the painter, some of the pages may not be displayed.

  • The Standard BMS page is displayed only if the painter is configured for standard or full BMS.
  • The Full BMS page is displayed only if the painter is configured for full BMS.

DBCS attributes are displayed on the DBCS page but they cannot be changed.

Note:

You can use the painter to specify values for all the DFHMDI operands, even though they might not be applied to the BMS macro file that is generated.

Parent topic: Defining Field, Map and Mapset Properties


Defining Mapset Properties

Use the Mapset Properties dialog box to define the properties of the mapset.

Double-click the mapset name in the tree view in the left-hand pane of the painter window to display the Mapset Properties dialog box, shown in the figure below.

These properties set the operand values for the corresponding BMS map definition macro DFHMSD.

Pages on the dialog box show the mapset properties. The Standard BMS page is displayed only if the painter is configured for standard or full BMS. DBCS attributes are displayed on the DBCS page but they cannot be changed

Parent topic: Defining Field, Map and Mapset Properties


Working with Previously Created Maps

You can open and work on a mapset that has been downloaded to your PC from the mainframe but as yet does not belong to a project.

When working on maps and mapsets created on the mainframe, you should bear the following in mind:

Maps and mapsets created on the mainframe may use the
        POS=number convention (as opposed to
        POS=(row,col)). The BMS macros are generated always in the
        POS=(row,col) format.

Overlapping fields are supported on downloaded maps but cannot be created with the painter. You can move an overlapping field by dragging it, but once it has been fixed on another part of the map it cannot be returned to its original overlapping position.

BMS files that contain conditional Assembler statements or COPY statements cannot be directly read.

Parent topic: Micro Focus BMS Screen Painter
Related concepts
Build Settings for the BMS Screen Painter


Generating Output from the Painter

The painter can generate the following types of file:

BMS macro (.bms) files

Copybook (.cpy and .mac) files. Copybooks are generated when you have specified TYPE=DSECT in the mapset definition or by means of the SYSPARM build settings.

Load module mapset (.mod) files. A load module is also known as a CSECT and is generated when you have specified TYPE=MAP in the mapset definition or by means of the SYSPARM build settings.

The painter generates the files using the name that you gave to the mapset. You can specify different filenames using build settings; see the section Build Settings for the BMS Screen Painter

  • BMS Macro Files
    You create a BMS macro (.bms) file by saving the file that is open in the painter. You can save the file at any time while working on it in the painter or you can save it when you exit from the painter.
  • Copybooks and Load Modules
    You generate the copybook and load module files by compiling the BMS (.bms) file.
Parent topic: Micro Focus BMS Screen Painter
Related concepts
Build Settings for the BMS Screen Painter


BMS Macro Files

You create a BMS macro (.bms) file by saving the file that is open in the painter. You can save the file at any time while working on it in the painter or you can save it when you exit from the painter.

To save the file from the painter click Save on the File menu of the IDE. If you want to create a new BMS macro file click Save As on the File menu of the IDE and specify the new filename.

To save the file and exit from the painter click the close icon on the title bar of the painter and click Yes to save the changes. You cannot specify a new filename if you save the file in this way.

Parent topic: Generating Output from the Painter


Copybooks and Load Modules

You generate the copybook and load module files by compiling the BMS (.bms) file.

The files generated are determined by the options specified on the General page of the Mapset Properties dialog box.

The language selected in the Lang group specifies the value of the LANG operand of the DFHMSD macro in the BMS source file. When you compile a BMS macro file, the value of the LANG operand is used to determine which type of copybook or include file to generate:

  • COBOL for a COBOL copybook (.cpy file)
  • ASM for an Assembler copybook (.mac file)
Note:

Generation of C DSECT (include) files is not currently supported.

The option selected in Type determines the files generated:

  • DSECT for a copybook
  • MAP for a load module
  • &&SYSPARM to indicate that the files to be generated are specified in the BMS build settings

If &&SYSPARM is selected you must specify whether you want to generate the copybook, the load module, or both, . See Build Settings for the BMS Screen Painter.

The copybook (.cpy or .mac file) is created in the copylib folder of the project and the load module (.mod file) is created in the loadlib folder of the project.

Parent topic: Generating Output from the Painter
Related concepts
Build Settings for the BMS Screen Painter


mfbmscl Command Line Tool

Compiles BMS mapsets from the command line.

Syntax:

mfbmscl mymapset.bms/options

Parameters:

mymapset.bms
The file containing the BMS maps to be compiled
options
For details of the optional parameters, type mfbmscl in a command prompt, without defining any parameters or options
Parent topic: Micro Focus BMS Screen Painter


BMS Screen Painter Technical Details

It is assumed that you are familiar with BMS fields, maps, and mapsets, and with the DFHMDF, DFHMDI, and DFHMSD macros.

  • The EXTATT, MAPATTS, and DSATTS Operands
  • Examples of SDF Copybooks
    The following examples show the copybook entries created for different SDF arrays and groups. All these examples assume that the BMS screen painter is set up for SDF and displays copybook entries in the tree view.
  • Handling Comments in BMS Macros
Parent topic: Micro Focus BMS Screen Painter


The EXTATT, MAPATTS, and DSATTS Operands

The painter allows you to specify only the MAPATTS and DSATTS operands for map and mapset properties. You cannot specify the EXTATT operand (this was the old method of specifying attributes in the DFHMDI macro). You can find the MAPATTS and DSATTS operands on the Common Attributes page of the Map Properties and Mapset Properties dialog boxes.

Note:

The DSATTS attributes are generated in the order CPHVUMTO for the output portion of the symbolic description map to correspond to the CICS/ESA V3.3 data areas layout. The attributes are as follows:

C | Field Color
P | Programmed Symbol Set (PSS)
H | Field Highlight
V | Field Validation
U | Field Outlining
M | SO/SI Creation
T | Field Transparency
O | Output Data
Parent topic: BMS Screen Painter Technical Details


Examples of SDF Copybooks

The following examples show the copybook entries created for different SDF arrays and groups. All these examples assume that the BMS screen painter is set up for SDF and displays copybook entries in the tree view.
  • SDF Array
  • SDF Group
Parent topic: BMS Screen Painter Technical Details


SDF Array

To create a one-dimensional SDF array:

  1. Create a field and name it on the Field Properties dialog box.
  2. Right-click the field and click Make Horizontal Array on the popup menu.
  3. Right-click the field and click Add Array Column on the popup menu.
  4. Right-click the field and click Add Array Row on the popup menu.
  5. Right-click the field and click Add Array Row on the popup menu.

Although the fields on the screen look as though they are arranged in a two-dimensional array, the copybook entry shows a one-dimensional SDF array. See the figure below.

The BMS macro file generated is:

SDFARR  DFHMSD LANG=COBOL,    -
               MODE=INOUT,    -
               STORAGE=AUTO,  -
               TIOAPFX=YES,   -
               TYPE=&&SYSPARM
SDFARR  DFHMDI SIZE=(24,80)
* FIELD
FIELD   DFHMDF LENGTH=4,      -
               POS=(5,9)
* FIELD
FIELD2  DFHMDF LENGTH=4,      -
               POS=(5,14)
* FIELD
FIELD3  DFHMDF LENGTH=4,      -
               POS=(5,19)
* FIELD
FIELD6  DFHMDF LENGTH=4,      -
               POS=(6,9)
* FIELD
FIELD5  DFHMDF LENGTH=4,      -
               POS=(6,14)
* FIELD
FIELD4  DFHMDF LENGTH=4,      -
               POS=(6,19)
* FIELD
FIELD9  DFHMDF LENGTH=4,      -
               POS=(7,9)
* FIELD
FIELD8  DFHMDF LENGTH=4,      -
               POS=(7,14)
* FIELD
FIELD7  DFHMDF LENGTH=4,      -
               POS=(7,19)
        DFHMSD TYPE=FINAL
        END

You can see that this is a horizontal array by looking at the SDF properties of the second field of the top row:

  1. Double-click the second field of the top row.
  2. Click the SDF tab.

This shows the field as "Index 2 of 9". The fields are counted across the screen.

If you make the array a vertical array by checking Vertical Array and look at the SDF properties again, the field is now shown as "Index 4 of 9". The fields are now counted down the screen.

Parent topic: Examples of SDF Copybooks


SDF Group

To create an SDF group:

  1. Create a field and name it on the Field Properties dialog box.
  2. Create a second and third field and name them.
  3. Select all three fields.
  4. Right-click one of the selected fields and click Make SDF Group on the popup menu.

Look at the SDF properties for one of the fields. The BMS Screen Painter has assigned a default SDF group name. If you want to refer explicitly to the group array in the copybook, you must change this default group name. If you don't change the SDF group name, it will not be included in the BMS macro file.

Having created the SDF group you can repeat it:

  1. Right-click one of the fields in the group.
  2. Click Add Group Row on the popup menu.

The copybook entries show that this is a one-dimensional array (a repeated group).

The map now looks like the one shown in the figure below.

The default group name (assigned by the BMS Screen Painter) was not changed and so does not appear in the generated BMS macro file:

SDFGRP1  DFHMSD
               LANG=COBOL,    -
               MODE=INOUT,    -
               STORAGE=AUTO,  -
               TIOAPFX=YES,   -
               TYPE=&&SYSPARM
SDFGRP  DFHMDI SIZE=(24,80)
* FIELDA
FIELDA  DFHMDF LENGTH=4,      -
               POS=(3,10)
* FIELDB
FIELDB  DFHMDF LENGTH=5,      -
               POS=(3,19)
* FIELDC
FIELDC  DFHMDF LENGTH=6,      -
               POS=(3,29)
* FIELDA
FIELDA2 DFHMDF LENGTH=4,      -
               POS=(4,10)
* FIELDB
FIELDB2 DFHMDF LENGTH=5,      -
               POS=(4,19)
* FIELDC
FIELDC2 DFHMDF LENGTH=6,      -
               POS=(4,29)
        DFHMSD TYPE=FINAL
        END
Parent topic: Examples of SDF Copybooks


Handling Comments in BMS Macros

The painter can recognize several types of comment embedded in the BMS macros. These comments are generated in the BMS macros by products such as IBM SDF and SDF II, and are used to specify long names for COBOL fields that are generated in the copybook (.cpy file). The painter also uses a special comment type that is used for fields that are repeated vertically or horizontally.

It is important to know what type of comments are embedded in your BMS macros before you try to import them into the painter. If you specify the wrong type, you might encounter problems because certain fields are not imported properly.

Note:

The painter only processes SDF comments and ignores any incidental comments that are embedded in the BMS source. Incidental comments are those that are for documentation and are not related to COBOL field names as described above. These incidental comments are ignored during BMS import and are not regenerated in the output BMS produced by the BMS screen painter.

The comment formats that the painter can handle when the Enable SDF features check box is selected on the BMS build settings are as follows:

* 'COBOL-Name'
    DFHMDF POS=
* COBOL-Name
    DFHMDF POS=
* Group-Name.COBOL-name
DFHMDF POS=
* 'Group-Name.COBOL-Name'
    DFHMDF POS=
Parent topic: BMS Screen Painter Technical Details


BMS Directives

There are a number of Compiler directives that are applicable to BMS files, and depending on the directive, can be set one of two ways.

There are two categories of BMS directives:

    • ALIGN
    • CS
    • DP
    • DSECT
    • HLL
    • IGNORE
    • LEVEL
    • MAP
    • PREFIX
    • SDF
    • SYSPARM
  2. Directives that you set explicitly by typing them into Additional Directives:
    • NAMES
    • PCOMP
    • PREPASM
    • REDEFINPUT
    • STRNAME
    • SYSLIB
    • VERBOSE
  • Key to BMS Directives
    Descriptions for all of the BMS directives appear alphabetically.
  • ALIGN
    Specifies that data items are to be aligned on halfword boundaries.
  • CS
    Specifies the character to be used as the currency sign.
  • DP
    Specifies the character used as the decimal point.
  • DSECT
    Specifies the filename you want to use for the copybook to be created when the .bms file is compiled.
  • HLL
    Specifies whether or not long labels can be used for macros in .bms files.
  • IGNORE
    Specifies that any SDF comment lines are to be ignored.
  • LEVEL
    Specifies that data definitions generated in the copybook are to use a specific set of level numbers.
  • MAP
    Specifies the filename you want to use for the load module to be created when the .bms file is compiled.
  • NAMES
    Specifies additional NLS (National Locale Support) characters that are to be allowed in macro labels.
  • PREFIX
    Specifies the SDF prefix to be used for SDF data items generated in the copybook.
  • PCOMP
    Enables you to specify a user program as a precompiler for BMS files.
  • PREPASM
    Specifies that the Assembler preprocessor is to be called before the BMS source is compiled, to expand COPY statements and hand-coded BMS macros in the BMS files into standard BMS statements.
  • REDEFINPUT
    Specifies that each field's attribute byte redefines the flag byte in the input map.
  • SDF
    Specifies that the .bms file contains SDF features.
  • STRNAME
    Specifies a top-level name for a map to be generated in the copybook.
  • SYSPARM
    Specifies which files are to be generated when the .bms file is compiled.
  • SYSLIB
    Specifies the location of the Assembler macro library when the /PREPASM directive is specified.
  • VERBOSE
    Specifies that informational and warning messages will be displayed during the compilation of the .bms file.
Parent topic: Micro Focus BMS Screen Painter


Key to BMS Directives

Descriptions for all of the BMS directives appear alphabetically.

DIRECTIVE-NAME

A brief description of the function of DIRECTIVE-NAME.

Syntax:

>>--/-----.-----DIRECTIVE-NAME=parameter(s)---><
          +-----DIRECTIVE-NAME----------------+

The syntax of the Compiler directives is shown using diagrams called "railroad tracks", in which a directive and its parameters are shown joined by lines indicating the order in which they should be written. You read these diagrams from left to right. Each diagram starts with $$ and ends with $%. Sometimes the track forks to show alternatives and then joins up again. The length of a track has no significance.

If a parameter is specified after a comma, but the filename is omitted, the directive must be preceded by a slash (/). Otherwise, the directive is incorrectly assumed to be a filename.

Parameters:

Lists and describes valid parameter(s), if any, for the directive.

Properties:

Default
Indicates the directive's default setting.
Setting in the IDE:
Describes how to set the directive using the Build settings dialog in the IDE.

Comments:

Contains any additional information about the directive.

Parent topic: BMS Directives


ALIGN

Specifies that data items are to be aligned on halfword boundaries.

Syntax:

>>--/----ALIGN-------------><

Parameters:

None

Properties:

Default
Data items are not aligned on halfword boundaries.
Setting in the IDE:
Check Align data items on half word boundaries on the General page.
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


CS

Specifies the character to be used as the currency sign.

Syntax:

>>--/----CS=currency-sign-------------><

Parameters:

currency-sign
The character to be used as the currency sign in the .bms file or files.

Properties:

Default
CS=$
Setting in the IDE:
Specify a character in Currency character on the Advanced page.
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


DP

Specifies the character used as the decimal point.

Syntax:

>>--/----DP=decimal-point-------------><

Parameters:

decimal-point
The character to be used as the decimal point in the .bms file or files, either . (period) or , (comma)

Properties:

Default
DP=.
Setting in the IDE:
To set this directive, specify a character in Decimal point character on the Advanced page.
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


DSECT

Specifies the filename you want to use for the copybook to be created when the .bms file is compiled.

Syntax:

>>--/----DSECT=dsect-name-------------><

Parameters:

dsect-name
The filename you want the copybook to have. The value *member* indicates that the copybook is to use the name of the PDS member for the mapset.

Properties:

Default
The name for the copy book is taken from the label of the DFHMSD macro.
Setting in the IDE:
Check Use DSECT name on the Advanced page and specify the name in the entry field. You can set this directive only for individual .bms files.

Comments:

The filename extension is .cpy if the option selected in the Lang group on the General page of the Mapset properties is COBOL, and .mac if the option selected is ASM.

Parent topic: BMS Directives
Related concepts
Key to BMS Directives


HLL

Specifies whether or not long labels can be used for macros in .bms files.

Syntax:

>>--/----HLL-------------><

Parameters:

None

Properties:

Default
Macros can have only standard-length labels, that is, labels with up to seven characters.
Setting in the IDE:
To set this directive, check Allow long macro label names on the Advanced page.
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


IGNORE

Specifies that any SDF comment lines are to be ignored.

Syntax:

>>--/----IGNORE-------------><

Parameters:

None

Properties:

Default
None.
Setting in the IDE:
To set this directive, uncheck Enable SDF features on the General page.
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


LEVEL

Specifies that data definitions generated in the copybook are to use a specific set of level numbers.

Syntax:

>>--/----LEVEL=xx,yy,zz-------------><

Parameters:

LEVEL
The level numbers to be used.

Properties:

Default
LEVEL=01,03,05
Setting in the IDE:
To set this directive, check Use COBOL levels on the Advanced page, and select one of the sets of levels.
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


MAP

Specifies the filename you want to use for the load module to be created when the .bms file is compiled.

Syntax:

>>--/----MAP=map-name-------------><

Parameters:

map-name
The filename you want the load module to have. The value *member* indicates that the load module is to use the name of the PDS member for the mapset.

Properties:

Default
The name for the load module (.mod file) is taken from the label of the DFHMSD macro.
Setting in the IDE:
To set this directive, check Use MAP name on the Advanced page and specify the name in the entry field.

Comments:

You can set this directive only for individual .bms files.

Parent topic: BMS Directives
Related concepts
Key to BMS Directives


NAMES

Specifies additional NLS (National Locale Support) characters that are to be allowed in macro labels.

Syntax:

>>--/----NAMES=nls-characters-------------><

Parameters:

nls-characters

Properties:

Default
No NLS characters are allowed in macro labels other than those allowed by IBM CICS.
Setting in the IDE:
Specify in Additional directives.
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


PREFIX

Specifies the SDF prefix to be used for SDF data items generated in the copybook.

Syntax:

>>--/----PREFIX=prefix-------------><

Parameters:

prefix
The prefix to use for SDF data items. The string "*map*" signifies that you want the map name to be used as a prefix. You can follow the string with an optional separator character, for example: "*map*-", "*map*_".

Properties:

Default
No prefix is used.
Setting in the IDE:
Check Use SDF prefix on the Advanced page and specify the prefix in the entry field. To set this directive, you must have checked Enable SDF features on the General page.
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


PCOMP

Enables you to specify a user program as a precompiler for BMS files.

Syntax:

>>--/----PCOMP=userprog-------------><

Parameters:

userprog
The user program to be used as a precompiler.

Properties:

Default
None

Comments:

The user program should return an internal filename.

If userprog is not found, the compilation fails.

The user program can use CBL_EXIT_PROC to perform some post-build processing.

Example:

working-storage section.
       01.
           05 install-flag       pic x comp-x.
           05 install-params.
               10 exit-proc-ptr  usage procedure-pointer.
               10                pic x.

       01 p-exit-block.
           03 p-block-size       pic x(4) comp-5 value 16.
           03 p-return-code      pic x(4) comp-5.
           03 p-rts-error        pic x(4) comp-5.
           03 p-exit-flags       pic x(4) comp-5.

       linkage section.
       01 source-file            pic x(256).

       procedure division using source-file.
           display source-file
      * On exit the file specified in source-file is the one
      * the compiler will actually compile
              move "EMPLOY.BMS" to source-file

           set exit-proc-ptr to entry "exitproc"
           move 0 to install-flag
           call "CBL_EXIT_PROC" using install-flag
                                       install-params
           end-call

      * Zero means continue, non-zero abort
       move 0 to return-code
           exit program
           .

       exitproc section.
       entry "exitproc".
           display "in exit proc"

           call "CBL_GET_EXIT_INFO" using     p-exit-block

           exit program
           .
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


PREPASM

Specifies that the Assembler preprocessor is to be called before the BMS source is compiled, to expand COPY statements and hand-coded BMS macros in the BMS files into standard BMS statements.

Syntax:

>>--/----PREPASM-------------><

Parameters:

None

Properties:

Default
The Assembler preprocessor is not called.
Setting in the IDE:
Specify in Additional directives.

Comments:

You must have Studio Enterprise Edition Assembler support installed on your machine to make use of this directive.

You can specify the location of the copybook requiring preprocessing with the SYSLIB directive.

Parent topic: BMS Directives
Related concepts
Key to BMS Directives


REDEFINPUT

Specifies that each field's attribute byte redefines the flag byte in the input map.

Syntax:

>>--/----REDEFINPUT-------------><

Parameters:

None

Properties:

Default
Each field's attribute byte does not redefine the flag byte in the input map.
Setting in the IDE:
Specify in Additional directives.
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


SDF

Specifies that the .bms file contains SDF features.

Syntax:

>>--/----SDF-------------><

Parameters:

None

Properties:

Default
None.
Setting in the IDE:
To set this directive, check Enable SDF features on the General page.
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


STRNAME

Specifies a top-level name for a map to be generated in the copybook.

Syntax:

>>--/----STRNAME=DFHMDI-name(map-structure-name)-------------><

Parameters:

DFHMDI-name
Name of map in .bms file, that is, the name of the DFHMDI macro for the map
map-structure-name
Name to be generated in the copybook

Properties:

Default
The name in the copybook is the same as the name in the .bms file.
Setting in the IDE:
Specify in Additional directives.

Comments:

You can repeat this directive for different map names within the mapset.

Parent topic: BMS Directives
Related concepts
Key to BMS Directives


SYSPARM

Specifies which files are to be generated when the .bms file is compiled.

Syntax:

>>--/----SYSPARM=output-type-------------><

Parameters:

output-type
The type of output file to be generated: MAP Load module containing screen-handling code
DSECT
Copybook containing data definitions for the screen

Properties:

Default
No files are generated, unless you have the TYPE= statement coded in the DFHMSD macro.
Setting in the IDE:
To set this directive for the value MAP, check Map in the SYSPARM group on the General page.
To set this directive for the value DSECT, check DSECT in the SYSPARM group on the General page.

Comments:

You can specify both Map and DSECT.

Parent topic: BMS Directives
Related concepts
Key to BMS Directives


SYSLIB

Specifies the location of the Assembler macro library when the /PREPASM directive is specified.

Syntax:

>>--/----SYSLIB=directory-name-------------><

Parameters:

directory-name
The name of the directory containing the Assembler macro library.

Properties:

Default
mfe\mfasm\include
Setting in the IDE:
Specify in Additional directives.

Comments:

You must have Studio Enterprise Edition Assembler support installed on your machine to make use of this directive.

You should specify this directive only if you also specify the /PREPASM directive.

Parent topic: BMS Directives
Related concepts
Key to BMS Directives


VERBOSE

Specifies that informational and warning messages will be displayed during the compilation of the .bms file.

Syntax:

        >>--/----VERBOSE-------------><

Parameters:

None

Properties:

Default
Informational and warning messages are not displayed.
Seeting in the IDE:
Specify in Additional directives.
Parent topic: BMS Directives
Related concepts
Key to BMS Directives


BMS Painter Keyboard Shortcuts

The following actions and navigational tools have the following keyboard shortcuts:

Menu Action | Key Sequence
Context menu | Shift+F10
Enable BMS Painter menu | ALT
Save mapset | Ctrl+S
Navigation | Key Sequence
Context menu | Shift+F10
Enable IDE menu | ALT
Save mapset | Ctrl+S
Bottom of map | End, End
End of line | End
First map (in mapset) | Ctrl+Home
Last map (in mapset) | Ctrl+End
Next field | Ctrl+Right
Next map | Ctrl+PgDn
Previous field | Ctrl+Left
Previous map | Ctrl+PgUp
Select field | Ctrl+Space
Start of field | Home
Start of line | Home, Home
Top of map | Home, Home, Home
Parent topic: Micro Focus BMS Screen Painter


BMS Painter Compile Messages

  • BMSCH1003S - BMSCH1020E
    Lists the BMS Painter compile messages from BMSCH1003S through BMSCH1020E.
  • BMSCH1021E - BMSCH1040W
    Lists the BMS Painter compile messages from BMSCH1021E through BMSCH1040W.
  • BMSCH1041E - BMSCH1060I
    Lists the BMS Painter compile messages from BMSCH1041E through BMSCH1060I.
  • BMSCH1061I - BMSCH1080I
    Lists the BMS Painter compile messages from BMSCH1061I through BMSCH1080I.
  • BMSCH1081S - BMSCH1084W
    Lists the BMS Painter compile messages from BMSCH1081S through BMSCH1084W.
Parent topic: Micro Focus BMS Screen Painter


BMSCH1003S - BMSCH1020E

Lists the BMS Painter compile messages from BMSCH1003S through BMSCH1020E.
  • BMSCH1003S Error opening filename
    File filename could not be opened.
  • BMSCH1004W Warning filename may already be open. Read only access acquired
    The painter could not obtain read/write access to the source file. It may be open in another process or the file may be marked as read only.
  • BMSCH1005I Opening file filename
    File filename is being opened.
  • BMSCH1008W feature is invalid if MAPATTS(feature) omitted
    feature is specified in a DFHMDF macro but not at the map or map set level.
  • BMSCH1010W Field overlaps another with MODE=IN/INOUT
    The field attribute byte of one field falls within another field. This often occurs with stopper bytes that are defined with a length of one; the preferred length is zero. If editing, overlapping fields will be displayed correctly but once moved cannot be put back into an overlapping location.
  • BMSCH1011E Unexpected scanning error on filename
    Unexpected I/O error encountered reading source file, file may contain bad characters.
  • BMSCH1012S No DFHMSD macro was found
    The source file does not contain a DFHMSD macro.
  • BMSCH1013E Multiple DFHMSD macros found, only one permitted per file
    The source file contains more than one DFHMSD macro.
  • BMSCH1014E Unexpected verb verb-name found, remainder of macro discarded
    Whilst scanning for the DFHMSD new macro an unexpected or unrecognized keyword was found.
  • BMSCH1015E Error closing file
    The file could not be closed.
  • BMSCH1016W Mutually exclusive operands operands found in macro-name macro, last value assumed
    Two mutually exclusive operands were found in the same macro, for example INITIAL and XINIT operands on a DFHMDF macro.
  • BMSCH1017W Duplicate operands (operands) found in macro-name macro, last value assumed
    The same operand was found twice within the same macro.
  • BMSCH1018E Unrecognized option option-name found processing operand operand of macro-name macro
    An unrecognized or unsupported option was found processing the specified operand. For each operand (for example COLOR) there are a set of valid options that can be specified (for example BLUE, RED, PINK, GREEN, TURQUOISE, YELLOW, and NEUTRAL).
  • BMSCH1019E The length option (HONEOM, L40, L64, or L80) for the CTRL operand for the macro-name macro was encountered more than once
  • BMSCH1020E name was expected but found name
    An error occurred when tokenizing a macro. For example, options for the ATTRB operand can be enclosed in parenthesis such as ATTRB=(UNPROT,NORM).
Parent topic: BMS Painter Compile Messages


BMSCH1003S Error opening filename

File filename could not be opened.

Resolution:

Check that the file exists.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1004W Warning filename may already be open. Read only access acquired

The painter could not obtain read/write access to the source file. It may be open in another process or the file may be marked as read only.

Resolution:

You can still edit a mapset that has read-only access. Selecting "Save" for a read-only file results in a "Save As" dialog that lets you save the file with a different filename.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1005I Opening file filename

File filename is being opened.
Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1008W feature is invalid if MAPATTS(feature) omitted

feature is specified in a DFHMDF macro but not at the map or map set level.

Resolution:

Remove feature from the DFHMDF macro or specify it at the map or map set level.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1010W Field overlaps another with MODE=IN/INOUT

The field attribute byte of one field falls within another field. This often occurs with stopper bytes that are defined with a length of one; the preferred length is zero. If editing, overlapping fields will be displayed correctly but once moved cannot be put back into an overlapping location.
Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1011E Unexpected scanning error on filename

Unexpected I/O error encountered reading source file, file may contain bad characters.

Resolution:

Correct the file.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1012S No DFHMSD macro was found

The source file does not contain a DFHMSD macro.

Resolution:

Correct the source.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1013E Multiple DFHMSD macros found, only one permitted per file

The source file contains more than one DFHMSD macro.

Resolution:

Correct the source.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1014E Unexpected verb verb-name found, remainder of macro discarded

Whilst scanning for the DFHMSD new macro an unexpected or unrecognized keyword was found.

Resolution:

Correct the source.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1015E Error closing file

The file could not be closed.

Resolution:

Check that connections to the mainframe are still operational.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1016W Mutually exclusive operands operands found in macro-name macro, last value assumed

Two mutually exclusive operands were found in the same macro, for example INITIAL and XINIT operands on a DFHMDF macro.

Resolution:

Correct the source.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1017W Duplicate operands (operands) found in macro-name macro, last value assumed

The same operand was found twice within the same macro.

Resolution:

Correct the source.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1018E Unrecognized option option-name found processing operand operand of macro-name macro

An unrecognized or unsupported option was found processing the specified operand. For each operand (for example COLOR) there are a set of valid options that can be specified (for example BLUE, RED, PINK, GREEN, TURQUOISE, YELLOW, and NEUTRAL).

Resolution:

Correct the source.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1019E The length option (HONEOM, L40, L64, or L80) for the CTRL operand for the macro-name macro was encountered more than once

Resolution:

Correct the source.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1020E name was expected but found name

An error occurred when tokenizing a macro. For example, options for the ATTRB operand can be enclosed in parenthesis such as ATTRB=(UNPROT,NORM).

This error would be produced if the closing parenthesis was not found.

Resolution:

Correct the source.

Parent topic: BMSCH1003S - BMSCH1020E


BMSCH1021E - BMSCH1040W

Lists the BMS Painter compile messages from BMSCH1021E through BMSCH1040W.
  • BMSCH1021E Missing label for DFHMSD macro
    The DFHMSD macro has no label.
  • BMSCH1022W Operand operand of the macro-name macro is not supported at Minimum BMS level (Standard/Full required)
  • BMSCH1023I The painter is currently at the level BMS support level
  • BMSCH1024S End of file encountered before DFHMDI
  • BMSCH1025E Bad char found processing FLDSEP, length should be <= value
  • BMSCH1026W Operand keyword keyword of the macro-name macro only available at FULL BMS support level
  • BMSCH1027E DFHMSD label (label) too long - truncating to label
  • BMSCH1028E FLDSEP hex value's length should be <= value
  • BMSCH1029E LDC string value length should be value
  • BMSCH1030E Unexpected option option-name found processing operand operand of macro-name macro
  • BMSCH1031I BOX cannot be specified for OUTLINE with LEFT, RIGHT, OVER, or UNDER
  • BMSCH1032W Duplicate options (option-name) found for operand operand of the macro-name macro
  • BMSCH1033E Bad char found processing PS, length should be <= value
  • BMSCH1034E PS hex value's length should be <= value
  • BMSCH1035E Bad value specified for SUFFIX parameter, length should be value
  • BMSCH1036E Mutually exclusive operands operand found in macro-name macro, last value ignored
  • BMSCH1037S Missing label for DFHMDI macro
  • BMSCH1038E Mutually exclusive options option-name for operand operand in macro-name macro
  • BMSCH1039W Option option-name for the operand operand of the macro-name macro only available at FULL BMS support level
  • BMSCH1040W DFHMSD label mismatch - original (label), ending (label)
Parent topic: BMS Painter Compile Messages


BMSCH1021E Missing label for DFHMSD macro

The DFHMSD macro has no label.

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1022W Operand operand of the macro-name macro is not supported at Minimum BMS level (Standard/Full required)

Resolution:

Delete the operand or change the level of BMS that the screen painter is using.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1023I The painter is currently at the level BMS support level

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1024S End of file encountered before DFHMDI

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1025E Bad char found processing FLDSEP, length should be <= value

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1026W Operand keyword keyword of the macro-name macro only available at FULL BMS support level

Resolution:

Delete the keyword or change the level of BMS that the screen painter is using.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1027E DFHMSD label (label) too long - truncating to label

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1028E FLDSEP hex value's length should be <= value

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1029E LDC string value length should be value

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1030E Unexpected option option-name found processing operand operand of macro-name macro

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1031I BOX cannot be specified for OUTLINE with LEFT, RIGHT, OVER, or UNDER

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1032W Duplicate options (option-name) found for operand operand of the macro-name macro

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1033E Bad char found processing PS, length should be <= value

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1034E PS hex value's length should be <= value

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1035E Bad value specified for SUFFIX parameter, length should be value

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1036E Mutually exclusive operands operand found in macro-name macro, last value ignored

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1037S Missing label for DFHMDI macro

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1038E Mutually exclusive options option-name for operand operand in macro-name macro

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1039W Option option-name for the operand operand of the macro-name macro only available at FULL BMS support level

Resolution:

Correct the source or change the level of BMS that the screen painter is using.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1040W DFHMSD label mismatch - original (label), ending (label)

Resolution:

Correct the source.

Parent topic: BMSCH1021E - BMSCH1040W


BMSCH1041E - BMSCH1060I

Lists the BMS Painter compile messages from BMSCH1041E through BMSCH1060I.
  • BMSCH1041E A bad token, token-name, was encountered before processing DFHMDI
  • BMSCH1042S End of file encountered before end of DFHMDI processing
  • BMSCH1043E Duplicate DFHMDI label label, skipping map
  • BMSCH1044W COPY not supported
  • BMSCH1045E Invalid hex value value specified for operand operand of macro-name macro
  • BMSCH1046E DFHMDF label (label) too long - truncating to label
  • BMSCH1047E Duplicate DFHMDF label label, skipping field
  • BMSCH1048W Single quote found in INITIAL string
  • BMSCH1049W Single ampersand found in INITIAL string
  • BMSCH1050W Truncating PARTN name from name to name
  • BMSCH1051W Unrecognized operand operand found processing macro-name macro
  • BMSCH1052W DSATTS option-name option specified, assuming corresponding MAPATTS for macro-name macro
  • BMSCH1053S Out of memory, allocating new item
  • BMSCH1054S End of file encountered before end of DFHMDF processing
  • BMSCH1055E Error (value) occurred verifying name at position value of name
    The picture clause specified in the PICIN/PICOUT statement was determined to be illegal.
  • BMSCH1056E Hex string string is not even length, ignoring last character
  • BMSCH1057E DFHMDI label (label) too long - truncating to label
  • BMSCH1058W Fields starting at bottom right corner of map cannot have ATTRB=IC - ignoring option
  • BMSCH1059E Error interpreting SDF information - continuing with SDF support disabled
    SDF features are enabled for the file but an unexpected error occurred processing the comment fields preceding the DFHMDF macros. The file may not contain valid SDF information or may be in a format not recognized by the screen painter.
  • BMSCH1060I BMS source load complete, interpreting SDF information
Parent topic: BMS Painter Compile Messages


BMSCH1041E A bad token, token-name, was encountered before processing DFHMDI

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1042S End of file encountered before end of DFHMDI processing

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1043E Duplicate DFHMDI label label, skipping map

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1044W COPY not supported

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1045E Invalid hex value value specified for operand operand of macro-name macro

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1046E DFHMDF label (label) too long - truncating to label

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1047E Duplicate DFHMDF label label, skipping field

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1048W Single quote found in INITIAL string

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1049W Single ampersand found in INITIAL string

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1050W Truncating PARTN name from name to name

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1051W Unrecognized operand operand found processing macro-name macro

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1052W DSATTS option-name option specified, assuming corresponding MAPATTS for macro-name macro

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1053S Out of memory, allocating new item

Resolution:

Close some applications on your PC to make more memory available.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1054S End of file encountered before end of DFHMDF processing

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1055E Error (value) occurred verifying name at position value of name

The picture clause specified in the PICIN/PICOUT statement was determined to be illegal.

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1056E Hex string string is not even length, ignoring last character

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1057E DFHMDI label (label) too long - truncating to label

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1058W Fields starting at bottom right corner of map cannot have ATTRB=IC - ignoring option

Resolution:

Correct the source.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1059E Error interpreting SDF information - continuing with SDF support disabled

SDF features are enabled for the file but an unexpected error occurred processing the comment fields preceding the DFHMDF macros. The file may not contain valid SDF information or may be in a format not recognized by the screen painter.

Resolution:

Correct the source or turn off SDF features for the file.

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1060I BMS source load complete, interpreting SDF information

Parent topic: BMSCH1041E - BMSCH1060I


BMSCH1061I - BMSCH1080I

Lists the BMS Painter compile messages from BMSCH1061I through BMSCH1080I.
  • BMSCH1061I Detected repeating group of fields in map mapname, generating implied SDF group (groupname)
    An duplicate SDF field name was found separated by other named fields. This is assumed to be a repeating SDF group. An implied SDF group name was generated to logically identify fields belonging to the SDF group.
  • BMSCH1062I Detected repeating field (fieldname) in map mapname, processing as SDF field array
    A duplicate SDF field name that was not separated by other named fields was found. This is assumed to be an SDF array.
  • BMSCH1063I Processing map mapname
  • BMSCH1064W Missing comma after last operand, continuation cards ignored
  • BMSCH1065E Quoted string missing terminating quote
  • BMSCH1066S value syntax errors found, parsing terminated at line value
    Multiple errors were found during the loading of the source file so loading was terminated. These errors may be a result of an earlier parsing error so try to determine the cause of the initial error.
  • BMSCH1067S Error interpreting SDF field array (name) - all array fields must be equal length
  • BMSCH1068S Invalid or unrecognized SDF comment format (name)
  • BMSCH1069S Error processing SDF group (groupname), continuing with SDF support disabled
  • BMSCH1070I Detected repeating SDF group (groupname) in map mapname
  • BMSCH1071I SDF interpretation complete
  • BMSCH1072S Found DFHMDF macro before DFHMDI
    The DFHMDI macro must precede any DFHMDF macros.
  • BMSCH1073S Found DFHMDI macro before DFHMSD
    The DFHMSD macro must precede any DFHMDI macros.
  • BMSCH1074W ATTRB option name conflicts with name, defaulting to ASKIP
  • BMSCH1075E Length of picture clause picture specified for PICIN/PICOUT does not match field length of length"
    The picture length specified with either a PICIN or PICOUT operand does not match the field length specified with the LENGTH operand in the DFHMDF macro.
  • BMSCH1076E Illegal character found at position posn of PICIN/PICOUT picture clause picture
    The character at position posn in the PICIN / PICOUT operand is not a valid picture character for the language specified with the LANG operand in the DFHMSD macro.
  • BMSCH1077E PICIN/PICOUT picture clause is too long (picture)
    COBOL has a limit of 30 characters in a picture clause. The picture you have specified in the PICIN or PICOUT field exceeds this limit.
  • BMSCH1078W Unable to locate picture clause validation routines, unable to validate picture picture specified in PICIN/PICOUT
    Studio Enterprise Edition has been unable to find the picture clause validation routines. These routines are installed as part of the Studio Enterprise Edition installation procedure and may have been deleted, moved or corrupted.
  • BMSCH1079W PICIN/PICOUT is illegal for languages other than COBOL and PL/I
    The PICIN and PICOUT operands are only valid for mapsets created for COBOL and PL/I programs. Studio Enterprise Edition disregards PICIN and PICOUT operands for languages other than COBOL and PL/I.
  • BMSCH1080I Enabling SDF features to convert BMS/GT format source
    This message is displayed when you open a map created with GT Software's BMS/GT program. These maps make use of SDF features so Studio Enterprise Edition enables SDF support.
Parent topic: BMS Painter Compile Messages


BMSCH1061I Detected repeating group of fields in map mapname, generating implied SDF group (groupname)

An duplicate SDF field name was found separated by other named fields. This is assumed to be a repeating SDF group. An implied SDF group name was generated to logically identify fields belonging to the SDF group.
Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1062I Detected repeating field (fieldname) in map mapname, processing as SDF field array

A duplicate SDF field name that was not separated by other named fields was found. This is assumed to be an SDF array.
Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1063I Processing map mapname

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1064W Missing comma after last operand, continuation cards ignored

Resolution:

Correct the source.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1065E Quoted string missing terminating quote

Resolution:

Correct the source.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1066S value syntax errors found, parsing terminated at line value

Multiple errors were found during the loading of the source file so loading was terminated. These errors may be a result of an earlier parsing error so try to determine the cause of the initial error.

Resolution:

Correct the source.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1067S Error interpreting SDF field array (name) - all array fields must be equal length

Resolution:

Correct the source.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1068S Invalid or unrecognized SDF comment format (name)

Resolution:

Correct the source.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1069S Error processing SDF group (groupname), continuing with SDF support disabled

Resolution:

Correct the source.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1070I Detected repeating SDF group (groupname) in map mapname

Resolution:

Correct the source.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1071I SDF interpretation complete

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1072S Found DFHMDF macro before DFHMDI

The DFHMDI macro must precede any DFHMDF macros.

Resolution:

Correct the source.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1073S Found DFHMDI macro before DFHMSD

The DFHMSD macro must precede any DFHMDI macros.

Resolution:

Correct the source.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1074W ATTRB option name conflicts with name, defaulting to ASKIP

Resolution:

Correct the source.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1075E Length of picture clause picture specified for PICIN/PICOUT does not match field length of length"

The picture length specified with either a PICIN or PICOUT operand does not match the field length specified with the LENGTH operand in the DFHMDF macro.
Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1076E Illegal character found at position posn of PICIN/PICOUT picture clause picture

The character at position posn in the PICIN / PICOUT operand is not a valid picture character for the language specified with the LANG operand in the DFHMSD macro.

Resolution:

Change the illegal picture character specified in the PICIN / PICOUT operand to one that is valid for the specified language.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1077E PICIN/PICOUT picture clause is too long (picture)

COBOL has a limit of 30 characters in a picture clause. The picture you have specified in the PICIN or PICOUT field exceeds this limit.

Resolution:

Specify a picture that doesn't exceed the 30-character limit.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1078W Unable to locate picture clause validation routines, unable to validate picture picture specified in PICIN/PICOUT

Studio Enterprise Edition has been unable to find the picture clause validation routines. These routines are installed as part of the Studio Enterprise Edition installation procedure and may have been deleted, moved or corrupted.

Resolution:

You should be able to fix this problem by reinstalling Studio Enterprise Edition.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1079W PICIN/PICOUT is illegal for languages other than COBOL and PL/I

The PICIN and PICOUT operands are only valid for mapsets created for COBOL and PL/I programs. Studio Enterprise Edition disregards PICIN and PICOUT operands for languages other than COBOL and PL/I.

Resolution:

If this mapset is intended for use with a COBOL or PL/I program, correctly set the language on the Mapset Properties dialog box.

If this mapset is not intended for use with a COBOL or PL/I program, delete the PICIN or PICOUT picture definition on the Other page of the Field Properties dialog box.

Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1080I Enabling SDF features to convert BMS/GT format source

This message is displayed when you open a map created with GT Software's BMS/GT program. These maps make use of SDF features so Studio Enterprise Edition enables SDF support.
Parent topic: BMSCH1061I - BMSCH1080I


BMSCH1081S - BMSCH1084W

Lists the BMS Painter compile messages from BMSCH1081S through BMSCH1084W.
  • BMSCH1081S LENGTH operand missing for labeled DFHMDF macro
    The LENGTH operand describes the length of the field (1 – 256 bytes) and is required for all labeled DFHMDF macros (unless you specify a picture with PICIN or PICOUT).
  • BMSCH1082E PICIN/PICOUT picture clause invalid with specified MODE
    A PICIN picture has been specified for a field in a MODE=OUT mapset or a PICOUT picture has been specified for a field in a MODE=IN mapset.
  • BMSCH1084W Continuation statement may be in error
    A line in the macro being processed ends in a comma but there is no continuation statement.
  • BMSCH1100S COPY file filename not found
    The copybook specified was not found.
  • BMSCH1101S COPY file expansion requires directive /PREPASM
    The /PREPASM directive was not specified when compiling with COPY file expansion.
Parent topic: BMS Painter Compile Messages


BMSCH1081S LENGTH operand missing for labeled DFHMDF macro

The LENGTH operand describes the length of the field (1 – 256 bytes) and is required for all labeled DFHMDF macros (unless you specify a picture with PICIN or PICOUT).

Resolution:

Correctly set Length on the General page of the Field Properties dialog box to the length of the field.

Parent topic: BMSCH1081S - BMSCH1084W


BMSCH1082E PICIN/PICOUT picture clause invalid with specified MODE

A PICIN picture has been specified for a field in a MODE=OUT mapset or a PICOUT picture has been specified for a field in a MODE=IN mapset.

Resolution:

If MODE=IN (and this is correct), move the offending PICOUT picture clause to PICIN (or delete it).

If MODE=OUT (and this is correct), move the offending PICIN picture clause to PICOUT (or delete it).

If the MODE is set incorrectly, change the Mode setting on the General page of the Mapset Properties dialog box.

Parent topic: BMSCH1081S - BMSCH1084W


BMSCH1084W Continuation statement may be in error

A line in the macro being processed ends in a comma but there is no continuation statement.

Resolution:

Correct the source.

Parent topic: BMSCH1081S - BMSCH1084W


BMSCH1100S COPY file filename not found

The copybook specified was not found.

Resolution:

Specify the correct path and/or filename of the copybook; then recompile.

Parent topic: BMSCH1081S - BMSCH1084W


BMSCH1101S COPY file expansion requires directive /PREPASM

The /PREPASM directive was not specified when compiling with COPY file expansion.

Resolution:

Recompile the source using the /PREPASM directive.

Parent topic: BMSCH1081S - BMSCH1084W


BMS Painter Generate Messages

  • BMSCM1001I Saving BMS file filename
  • BMSCM1002I Generating type DSECT : filename (1)
  • BMSCM1003I Generating CSECT filename
  • BMSCM1012W Generation of C DSECT not currently supported
  • BMSCM1013W DFHMSD TYPE=name does not match requested SYSPARM (sysparm)
    The DFHMSD macro contains a TYPE operand that does not match the requested SYSPARM options in the build settings. For example, TYPE=DSECT implies that only a copybook should be generated from this BMS source file. To control the objects created during compilation through the build settings, specify TYPE=&&SYSPARM in the DFHMSD macro.
  • BMSCM1014W No SYSPARM specified, defaulting to MAP and DSECT
    No SYSPARM settings were passed to the BMS compilation process. Both TYPE=MAP and TYPE=DSECT are assumed.
  • BMSCM1015W No SYSPARM specified. Specify type of map to be generated in build settings
    No SYSPARM settings were passed to the BMS compilation process. An illegal command line must have been specified.
  • BMSCM1017W DFHMSD TYPE=MAP does not match specified SYSPARM, forcing DSECT generation as SDF features are enabled
    The TYPE operand of the DFHMSD macro indicates that a copybook should not be generated as part of the compilation process. As SDF features are enabled, the value of the TYPE operand is ignored.
  • BMSCM1018E Error saving filename, could not open file for output
  • BMSCM1019E A file error occurred whilst saving filename
  • BMSCM1020E An error occured re-opening filename following the save request, read only access assumed
  • BMSCM1021E Error opening output file for language DSECT : filename (1)
    An error occurred while trying to create the DSECT output file. This is usually due to insufficient free disk space or file access permissions preventing you from writing the file.
  • BMSCM1022W Assuming TIOAPFX=YES (required for command-level applications)
    TIOAPFX=YES should always be specified for command-level applications. If the program is a command-level application and TIOAPFX=YES has not been specified in the DFHMSD macro, Mainframe Express will display this warning and assume TIOAPFX=YES.
Parent topic: Micro Focus BMS Screen Painter


BMSCM1001I Saving BMS file filename

Parent topic: BMS Painter Generate Messages


BMSCM1002I Generating type DSECT : filename (1)

Parent topic: BMS Painter Generate Messages


BMSCM1003I Generating CSECT filename

Parent topic: BMS Painter Generate Messages


BMSCM1012W Generation of C DSECT not currently supported

Parent topic: BMS Painter Generate Messages


BMSCM1013W DFHMSD TYPE=name does not match requested SYSPARM (sysparm)

The DFHMSD macro contains a TYPE operand that does not match the requested SYSPARM options in the build settings. For example, TYPE=DSECT implies that only a copybook should be generated from this BMS source file. To control the objects created during compilation through the build settings, specify TYPE=&&SYSPARM in the DFHMSD macro.

Resolution:

Correct the source or change the build settings.

Parent topic: BMS Painter Generate Messages


BMSCM1014W No SYSPARM specified, defaulting to MAP and DSECT

No SYSPARM settings were passed to the BMS compilation process. Both TYPE=MAP and TYPE=DSECT are assumed.
Parent topic: BMS Painter Generate Messages


BMSCM1015W No SYSPARM specified. Specify type of map to be generated in build settings

No SYSPARM settings were passed to the BMS compilation process. An illegal command line must have been specified.

Resolution:

Correct the build settings.

Parent topic: BMS Painter Generate Messages


BMSCM1017W DFHMSD TYPE=MAP does not match specified SYSPARM, forcing DSECT generation as SDF features are enabled

The TYPE operand of the DFHMSD macro indicates that a copybook should not be generated as part of the compilation process. As SDF features are enabled, the value of the TYPE operand is ignored.
Parent topic: BMS Painter Generate Messages


BMSCM1018E Error saving filename, could not open file for output

Resolution:

Try saving the file with a different file name or in a different directory.

Parent topic: BMS Painter Generate Messages


BMSCM1019E A file error occurred whilst saving filename

Resolution:

Try saving the file with a different file name or in a different directory.

Parent topic: BMS Painter Generate Messages


BMSCM1020E An error occured re-opening filename following the save request, read only access assumed

Resolution:

Try saving the file with a different file name or in a different directory.

Parent topic: BMS Painter Generate Messages


BMSCM1021E Error opening output file for language DSECT : filename (1)

An error occurred while trying to create the DSECT output file. This is usually due to insufficient free disk space or file access permissions preventing you from writing the file.

Resolution:

If there is enough free disk space, check your write access permission on both the file (if it already exists) and the directory where the file is being created.

Parent topic: BMS Painter Generate Messages


BMSCM1022W Assuming TIOAPFX=YES (required for command-level applications)

TIOAPFX=YES should always be specified for command-level applications. If the program is a command-level application and TIOAPFX=YES has not been specified in the DFHMSD macro, Mainframe Express will display this warning and assume TIOAPFX=YES.

Resolution:

Specify TIOAPFX=YES in the DFHMSD macro.

Parent topic: BMS Painter Generate Messages


IMS Support

  • mfims Command
    Enables you to generate DBDs, PSBs, and MFS.
  • mfims Directives
  • mfims imsdbu Command
    Enables you to run the IMSDBU utility from the command line.
  • mfims imsdbu Directives
  • IMS Error Messages
Parent topic: Mainframe Reference


mfims Command

Enables you to generate DBDs, PSBs, and MFS.

Syntax:

mfims utility filename [directives]

Parameters:

utility Can be one of:
  • dbdgen
  • msfgen
  • psbgen
filename | The name of the .psb, .dbd, or .mfs file to generate.
directives | A sequence of one or more directives. Directives can appear after any filename. Each directive must be separated by a space and must not be broken across two lines.
Parent topic: IMS Support


mfims Directives

The mfims command supports several directives you can use on the command line to specify details of file generation. The following is an alphabetical list of all mfims directives.

  • CLS
    Clears the screen before starting the utility.
  • COPYEXT
    Specifies the copybook extension to be used when generating the complete copybook name for a DBD, MFS or PSB COPY statement.
  • CP
    Enables the CP preprocessor.
  • DEFAULTEXT
    Specifies the default file extension added to the input file name when no extension is specified.
  • ECHO
    Controls the interaction with the DBDGEN, MFSGEN and PSBGEN utilities.
  • EXCLUPDT
    Opens the output files for exclusive use by this instance of DBDGEN and no other task can read or update the DBDGEN files until DBDGEN completes.
  • HEXFILL
    Enables you to retain the hexadecimal value of input characters when deploying an IMS EBCDIC application.
  • IMSLIBNO
    Specifies which IMS Load library directory in Workgroups is updated when multiple IMS Load Library directories are used.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • MAP
    Runs the DBDMAP utility upon successful completion of DBDGEN.
  • /PATH
    Specifies the directory in which to save control blocks generated by MFSGEN.
  • SHRUPDT
    Opens the output files for sharing so other tasks can read and update these files while the DBDGEN utility is running.
  • VERIFY
    Runs the PSB Verify utility upon successful completion of PSBGEN.
  • DBDGEN Directives
  • MFSGEN Directives
  • PSBGEN Directives
Parent topic: IMS Support


CLS

Clears the screen before starting the utility.
Note: Supported by all mfims utilities.

Syntax:

>>-.----.--CLS------><
   +-NO-+

Parameters:

None

Properties:

Default: CLS

Dependencies:

None

Comments:

NOCLS prevents the initial clear screen and can be helpful when you are running a series of utilities in a command file.

Parent topic: mfims Directives
Parent topic: DBDGEN Directives
Parent topic: MFSGEN Directives
Parent topic: PSBGEN Directives


COPYEXT

Specifies the copybook extension to be used when generating the complete copybook name for a DBD, MFS or PSB COPY statement.
Note: Supported by all mfims utilities.

Syntax:

>>-----COPYEXT--(ext)------><

Parameters:

ext
The file extension used to override the default file extension. This can be any one- to three-character extension, or NULL.

Properties:

Default: COPYEXT(defaultExt)

Where defaultExt is the file extension of the specified DBD, MFS, or PSB source copybook name.

Dependencies:

None

Comments:

By default, the file extension of the original DBD, MFS or PSB source copybook file name is appended to the COPY member name. For example, if the original MFS copybook name was MYMFS1.MFS, and a COPY statement asked to include member MYINDX, then the copybook MYINDX.MFS is copied. If you specify COPYEXT(CPY), for example, this produces an included copybook name of MYINDX.CPY.

COPYEXT(NULL) indicates that the copybook file name has no extension.

COPYEXT process -INC and ++INCLUDE statements as COPY statements.

Member names longer than eight characters are truncated to eight characters with no warning message.

Parent topic: mfims Directives
Parent topic: DBDGEN Directives
Parent topic: MFSGEN Directives
Parent topic: PSBGEN Directives


CP

Enables the CP preprocessor.
Note: Supported by the MFSGEN mfims utility.

Syntax:

>>-.----.--CP------><
   +-NO-+

Parameters:

None

Properties:

Default: NOCP

Dependencies:

None

Comments:

Use CP to generate an MFS that includes multiple nested copybooks.

Runs during the syntax check phase.

$SET is initial.

Parent topic: mfims Directives
Parent topic: MFSGEN Directives


DEFAULTEXT

Specifies the default file extension added to the input file name when no extension is specified.
Note: Supported by all mfims utilities.

Syntax:

>>-----DEFAULTEXT--(ext)------><

Parameters

ext
An input file name extension.

Properties:

Default: DEFAULTEXT(DBD)

Dependencies:

None

Comments:

The value specified for ext replaces the default extension. For example, when you specify DEFAULTEXT(PSB), an input file name of MYFILE results in a name of MYFILE.PSB.

Parent topic: mfims Directives
Parent topic: DBDGEN Directives
Parent topic: MFSGEN Directives
Parent topic: PSBGEN Directives


ECHO

Controls the interaction with the DBDGEN, MFSGEN and PSBGEN utilities.
Note: Supported by all mfims utilities.

Syntax:

>>-----ECHO--(keyword,msglvl,stoplvl)------><

Parameters:

keyword
The category of information displayed. One of the following:
ALL
Always displays processing messages, input source or detail information and the ending message. Warning and error messages are displayed and stop for user input if the message level is equal to or greater than the msglvl and stoplvl values.
MSGS
Always displays processing messages and the ending message. No source or detail information is displayed. Warning and error messages are displayed and stop for user input if the message level is equal to or greater than the msglvl and stoplvl values.
ERREND
Always displays the utility ending message. Warning and error messages are displayed and stop for user input if the message level is equal to or greater than the msglvl and stoplvl values.
ENDMSG
Displays ending message only if the utility ending return code is equal to or greater than msglvl. A "Press any key to continue" message is displayed and stops for input if the utility ending return code is equal to or greater than the stoplvl. Enter a msglvl and/or stoplvl value of zero to display and/or stop on every ending message.
COND
Both the warning/error and ending messages are conditional on the msglvl and stoplvl values. Warning and error messages are displayed and stop for user input if the message level is equal to or greater than the msglvl and stoplvl values. The ending message is displayed if the ending return code is equal to or greater than msglvl. You see the message "Press any key to continue" which requires input if the utility ending return code is equal to or greater than the stoplvl.
ERRORS
You see warning and error messages which require input if the message level is equal to or greater than the msglvl and stoplvl. You do not see the ending message.
msglvl
A value from 4 through 20 to indicate the severity of messages to display. See below for more information.
stoplvl
A value from 4 through 20 to indicate the severity of messages to stop for user input. See below for more information.

Properties:

Default: ECHO(MSGS,4,8)

Comments:

The msglvl and stoplvl parameters can take the following values:

Value | Category | Example Cause
4 | General warning message | A minor coding error in DBD source which DBDGEN can make an assumption about and continue.
6 | IMS specific warning message | A warning that a keyword or statement is not supported and is ignored - processing can continue.
8 | General severe error | An incorrect coding in DBD source which cannot be compensated for, such as 'no DBD statement'.
10 | IMS Option specific severe error | An unsupported feature was defined which cannot be compensated for, such as 'Exceeded some maximum'.
12 | Severe error - possible temporary condition | A temporary I/O error such as a 'file locked' or 'database locked' status.
16 | Severe error- permanent - likely installation problem | A permanent I/O error, such as an invalid data set name or member name, was input to a utility or an environment variable is not set correctly.
20 | Severe error - permanent | An unrecoverable I/O error or some other unexpected error.
Parent topic: mfims Directives
Parent topic: DBDGEN Directives
Parent topic: MFSGEN Directives
Parent topic: PSBGEN Directives
Parent topic: Reorganize Directives
Related concepts
IMSDBU Automation


EXCLUPDT

Opens the output files for exclusive use by this instance of DBDGEN and no other task can read or update the DBDGEN files until DBDGEN completes.
Note: Supported by all mfims utilities.

Syntax:

{SHR | EXCL}UPDT

Parameters:

None

Properties:

Default: None

Dependencies:

Mutually exclusive to the SHRUPDT mfims directive.

Parent topic: mfims Directives
Parent topic: DBDGEN Directives
Parent topic: MFSGEN Directives
Parent topic: PSBGEN Directives


HEXFILL

Enables you to retain the hexadecimal value of input characters when deploying an IMS EBCDIC application.
Note: Supported by the MFSGEN mfims utility.

Syntax:

>>-----HEXFILL------><

Parameters:

None

Properties:

Default: None

Dependencies:

None

Comments:

When running EBCDIC applications under Server Enterprise Edition, if there are input fill characters coded as hexadecimal values in the MFS source, and those values should not be converted to EBCDIC at run time, compile your source specifying the HEXFILL directive. This causes hexadecimal values to remain as hexadecimal values at run time, and are not converted to EBCDIC.

Parent topic: mfims Directives
Parent topic: MFSGEN Directives


IMSLIBNO

Specifies which IMS Load library directory in Workgroups is updated when multiple IMS Load Library directories are used.
Note: Supported by all mfims utilities.

Syntax:

>>-----IMSLIBNO--(x)------><

Parameters:

x
An integer in the range 1 to 25 to indicate the load library directory to update.

Properties:

Default: IMSLIBNO(1)

Dependencies:

None

Comments:

During generation, the DBDGEN files updated by default are located in the first load library directory as defined in the Workgroup. This is load library 1. An IMSLIBNO x value of 2 through 25 updates one of the second through the twenty-fifth load libraries defined, depending on the value specified.

Parent topic: mfims Directives
Parent topic: DBDGEN Directives
Parent topic: MFSGEN Directives
Parent topic: PSBGEN Directives


LIST

Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
Note: Supported by all mfims utilities.

Syntax:

>>-.---.-.-------LIST--(filespec)--.-----><
   +-/-+ +.----.-LIST--------------+
          +-NO-+

Parameters:

filespec
The name and location to use for the listing file. filespec can include a drive and/or directory if required. If you do not specify a drive or directory, MFIMS or IMSDBU creates the listing file in the current directory.

Properties:

Default: LIST(*.LST)

Comments:

NOLIST suppresses the creation of the listing file.

To specify a path, you can use the convention of placing a dollar sign ($) in front of the name of an environment variable that represents a path. For example, LIST($ENVVAR\*.DOC) creates a list file of dbdname.DOC in the directory named by the ENVVAR environment variable.

Specifying LIST(*.LST) or LIST(*.RPT) causes the listing file to be created in the project listing directory. If no path is specified, the listing file is created in the current directory.

Specifying LIST is equivalent to specifying LIST(*.LST).

The default setting of LIST(*.LST) creates a listing file with a name that uses the base filename part of the input file name plus a file extension of .LST. For example, with MYPSB.PSB as the input name, LIST(*.LST) creates a file named MYPSB.LST. The default setting creates a list file named DBDLIST.LST, MFSLIST.LST or PSBLIST.LST respectively. NOLIST suppresses the output listing.

Parent topic: mfims Directives
Parent topic: DBDGEN Directives
Parent topic: MFSGEN Directives
Parent topic: PSBGEN Directives
Parent topic: PtrUpdate Directives
Parent topic: Runlist Directives
Related concepts
Reports, Statistics and Logs


MAP

Runs the DBDMAP utility upon successful completion of DBDGEN.
Note: Supported by the DBDGEN mfims utility.

Syntax:

>>-.----.--MAP------><
   +-NO-+

Parameters:

None

Properties:

Default: NOMAP

Dependencies:

None

Comments:

The return code from the DBDMAP utility does not affect the ending return code from DBDGEN.

Parent topic: mfims Directives
Parent topic: DBDGEN Directives


/PATH

Specifies the directory in which to save control blocks generated by MFSGEN.
Note: Supported by the MFSGEN mfims utility.

Syntax:

>>-----/PATH=pathname------><

Parameters:

pathname
The full path to the directory in which to save control blocks generated by MFSGEN.

Properties:

Default: /PATH=currentDir

Where currentDir is the full path to the current directory.

Dependencies:

None

Comments:

The pathname you specify overrides the path specified by the ES_MFSLIB environment variable.

Parent topic: mfims Directives
Parent topic: MFSGEN Directives


SHRUPDT

Opens the output files for sharing so other tasks can read and update these files while the DBDGEN utility is running.
Note: Supported by all mfims utilities.

Syntax:

>>-----SHRUPDT------><

Parameters:

None

Properties:

Default: SHRUPDT

Dependencies:

Mutually exclusive to the EXCLUPDT mfims directive.

Parent topic: mfims Directives


VERIFY

Runs the PSB Verify utility upon successful completion of PSBGEN.
Note: Supported by the PSBGEN mfims utility.

Syntax:

>>-.----.--VERIFY------><
   +-NO-+

Parameters:

None

Properties:

Default: NOVERIFY

Dependencies:

None

Parent topic: mfims Directives
Parent topic: PSBGEN Directives


DBDGEN Directives

  • CLS
    Clears the screen before starting the utility.
  • COPYEXT
    Specifies the copybook extension to be used when generating the complete copybook name for a DBD, MFS or PSB COPY statement.
  • DEFAULTEXT
    Specifies the default file extension added to the input file name when no extension is specified.
  • ECHO
    Controls the interaction with the DBDGEN, MFSGEN and PSBGEN utilities.
  • EXCLUPDT
    Opens the output files for exclusive use by this instance of DBDGEN and no other task can read or update the DBDGEN files until DBDGEN completes.
  • IMSLIBNO
    Specifies which IMS Load library directory in Workgroups is updated when multiple IMS Load Library directories are used.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • MAP
    Runs the DBDMAP utility upon successful completion of DBDGEN.
Parent topic: mfims Directives


MFSGEN Directives

  • CLS
    Clears the screen before starting the utility.
  • COPYEXT
    Specifies the copybook extension to be used when generating the complete copybook name for a DBD, MFS or PSB COPY statement.
  • CP
    Enables the CP preprocessor.
  • DEFAULTEXT
    Specifies the default file extension added to the input file name when no extension is specified.
  • ECHO
    Controls the interaction with the DBDGEN, MFSGEN and PSBGEN utilities.
  • EXCLUPDT
    Opens the output files for exclusive use by this instance of DBDGEN and no other task can read or update the DBDGEN files until DBDGEN completes.
  • HEXFILL
    Enables you to retain the hexadecimal value of input characters when deploying an IMS EBCDIC application.
  • IMSLIBNO
    Specifies which IMS Load library directory in Workgroups is updated when multiple IMS Load Library directories are used.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • /PATH
    Specifies the directory in which to save control blocks generated by MFSGEN.
Parent topic: mfims Directives


PSBGEN Directives

  • CLS
    Clears the screen before starting the utility.
  • COPYEXT
    Specifies the copybook extension to be used when generating the complete copybook name for a DBD, MFS or PSB COPY statement.
  • DEFAULTEXT
    Specifies the default file extension added to the input file name when no extension is specified.
  • ECHO
    Controls the interaction with the DBDGEN, MFSGEN and PSBGEN utilities.
  • EXCLUPDT
    Opens the output files for exclusive use by this instance of DBDGEN and no other task can read or update the DBDGEN files until DBDGEN completes.
  • IMSLIBNO
    Specifies which IMS Load library directory in Workgroups is updated when multiple IMS Load Library directories are used.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • VERIFY
    Runs the PSB Verify utility upon successful completion of PSBGEN.
Parent topic: mfims Directives


mfims imsdbu Command

Enables you to run the IMSDBU utility from the command line.

Syntax:

mfims imsdbu function-id {database-name|filename}[directives]

Parameters:

function-id
An identifier denoting the function you want to perform. One of:
function-id | Function
ADD | Add
DEL | Delete
LOAD | Load
MAKE | Makelist
PTRU | PtrUpdate
REOR | Reorganize
RUN | Runlist
UNLO | Unload
USEQ | Useq
Zero | Zeroload
database-name
The name of a database on which the function operates.
filename
The name of a file that supplies information to the function.
directives
Directives for this function. The help for each function includes full information on the directives it can take.

Comments:

You can combine a series of commands in an operating system command file. IMSDBU also supports its own Runlist command files. These are similar to operating system command files but allow you to process a series of functions as a group. A combination of operating system commands and Runlist files provides a great deal of flexibility for automating repetitive functions.

Parent topic: IMS Support
Related concepts
IMSDBU Utility
Related information
Compiler Prompts
OSEXT
Compiler Directives
Overview - Compiling
-d option (cbllink)


mfims imsdbu Directives

The mfims imsdbu command invokes the IMSDBU utility, and can take several command-line directives that specify details of database management tasks for the various IMSDBU functions. The following is an alphabetical list of all mfims imsdbu directives.

  • CLS
    Clears the screen before starting the utility.
  • COMPRESS
    Specifies whether compression was used when the input or output data file was created.
  • DATA
    Specifies the starting position of the segment data in the data record.
  • DSN
    Specifies the dataset name of the input file containing the segment data.
  • ECHO
    Controls the display of and interaction with the messages displayed by IMSDBU.
  • INI
    Specifies the default directives file.
  • LAYOUT
    Specifies the type of the input or output file.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • LISTOPEN
    Controls the open disposition of the detail listing file.
  • LOG
    Specifies the IMSDBU activity log.
  • LRECL
    Specifies the length for fixed length generic layout input or output files.
  • MAKELISTDSN
    Specifies the dataset name of the output file for the IMSDBU commands.
  • PROGRESS
    Controls the frequency of progress reporting.
  • RECFM
    Specifies the format of the input or output records.
  • REPLACE
    Specifies how duplicate root segments are to be processed.
  • SEGEXIT
    Specifies the name of a user-supplied exit program that can be used to control selection and modification of segment data during the add, load, or unload process.
  • SEGM
    Specifies the starting position of the 8-byte segment name in the data record.
  • Add Directives
  • Delete Directives
  • Load Directives
  • Makelist Directives
  • PtrUpdate Directives
  • Reorganize Directives
  • Runlist Directives
  • Unload Directives
  • Useq Directives
  • Zeroload Directives
Parent topic: IMS Support


CLS

Clears the screen before starting the utility.
Note: Supported by all mfims imsdbu functions.

Syntax:

>>-.----.--CLS------><
   +-NO-+

Parameters:

None

Properties:

Default: CLS

Dependencies:

None

Comments:

NOCLS prevents the initial clear screen and can be helpful when you are running a series of utilities in a command file.

Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Delete Directives
Parent topic: Load Directives
Parent topic: Makelist Directives
Parent topic: PtrUpdate Directives
Parent topic: Reorganize Directives
Parent topic: Runlist Directives
Parent topic: Unload Directives
Parent topic: Useq Directives
Parent topic: Zeroload Directives


COMPRESS

Specifies whether compression was used when the input or output data file was created.
Note: Supported by the following mfims imsdbu functions:
  • Add
  • Load
  • Unload

Syntax:

>>-.---.-.-------COMPRESS--(program)--.-----><
   +-/-+ +.----.-COMPRESS-------------+
          +-NO-+

Parameters:

program
The name of a compression/expansion routine to use instead of the system-supplied routine.

Properties:

Default: NOCOMPRESS

Comments:

The COMPRESS directive enables or disables the expansion of the input data file records.

The COMPRESS directive is only used when when LAYOUT(G) is specified. It is not required and is ignored when LAYOUT(D), LAYOUT(I) or LAYOUT(S) is specified.

Specifying COMPRESS with no program name causes decompression using the CBLDCIMS program (built-in to the MFIMS software libraries). You can override the name of the compression/expansion routine by specifying a user-written program name.

Add and Load functions
The compression directive for loading must match the setting used when creating the input file. The compression settings are ignored when loading LAYOUT(D) input files as the compression setting is stored in the unload file header record. For generic format loads, ensure that the COMPRESS directive is set correctly to avoid data corruption.
Unload function
When using an Unload file for a subsequent Load, the compression directive used for unloading must also be used when loading. For the IMSDBU-specific LAYOUT(D) formats, this is automatic as the compression setting is stored in the unload file header record. For generic format unloads, ensure that the COMPRESS directive is set correctly to avoid data corruption.
Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Load Directives
Parent topic: Unload Directives
Related concepts
Specialized and Generic Load Inputs
Load and Unload Exits
Related reference
LAYOUT


DATA

Specifies the starting position of the segment data in the data record.
Note: Supported by the following mfims imsdbu functions:
  • Add
  • Load
  • Unload

Syntax:

>>-----DATA--(position)------><

Parameters:

position
The starting position of the segment data within the data record.

Properties:

Default: DATA(9)

Comments:

A value of 1 corresponds to the first byte of the record data.

When RECFM(V) is specified, the variable length record prefix (LL) is not considered part of the record data and does not affect this value.

Add and Load functions
The DATA directive is only used when LAYOUT(G) is specified. It is not required and is ignored when LAYOUT(D), LAYOUT(I) or LAYOUT(S) is specified.
Unload function
The DATA directive is only used when LAYOUT(G) or LAYOUT(S) is specified. It is not required and is ignored when LAYOUT(D) or LAYOUT(I) is specified.
Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Load Directives
Parent topic: Unload Directives
Related concepts
Specialized and Generic Load Inputs
Related reference
LAYOUT
RECFM
LRECL


DSN

Specifies the dataset name of the input file containing the segment data.
Note: Supported by the following mfims imsdbu functions:
  • Add
  • Load
  • Unload
  • Useq

Syntax:

>>-----DSN--(filespec)------><

Parameters:

filespec
Add and Load functions
The dataset name of the input file containing the segment data.
Unload function
The dataset name of the output file for the segment data.
Useq function
The dataset name of the output file for the SDEP segment data.

Properties:

Default: DSN(*.DBU)

Comments:

Add and Load functions
If you specify the basename of filespec as an asterisk (*) it is replaced by the DBD name. The input dataset resides in the current directory unless you specify a drive and/or directory.
The input file name, not including the drive and directory, must not be the same as the name of the files for the database. The data files for a database named MYDBD, for example, would be MYDBD.DAT and MYDBD.IDX, and the input file name cannot be either of these file names. We recommend using unique extensions for the output file names. This is enforced even if the database data files are in a different directory than the input file.
Unload and Useq functions
If you specify the basename of filespec as an asterisk (*) it replaced by the DBD name. The output file resides in the current directory unless you specify a drive and/or directory.
The output file name, not including the drive and directory, must not be the same as the name of the files for the database. The data files for a database named MYDBD, for example, would be MYDBD.DAT and MYDBD.IDX, and the output file name cannot be either of these file names. We recommend using unique extensions for the output file names. This is enforced even if the database data files are in a different directory than the output file.
Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Load Directives
Parent topic: Unload Directives
Parent topic: Useq Directives


ECHO

Controls the display of and interaction with the messages displayed by IMSDBU.
Note: Supported by all mfims imsdbu functions.

Syntax:

>>-----ECHO--(keyword,msglvl,stoplvl)------><

Parameters:

keyword
The category of information displayed. One of the following:
ALL
Always displays processing messages, input source or detail information and the ending message. Warning and error messages are displayed and stop for user input if the message level is equal to or greater than the msglvl and stoplvl values.
MSGS
Always displays processing messages and the ending message. No source or detail information is displayed. Warning and error messages are displayed and stop for user input if the message level is equal to or greater than the msglvl and stoplvl values.
ERREND
Always displays the utility ending message. Warning and error messages are displayed and stop for user input if the message level is equal to or greater than the msglvl and stoplvl values.
ENDMSG
Displays ending message only if the utility ending return code is equal to or greater than msglvl. A "Press any key to continue" message is displayed and stops for input if the utility ending return code is equal to or greater than the stoplvl. Enter a msglvl and/or stoplvl value of zero to display and/or stop on every ending message.
COND
Both the warning/error and ending messages are conditional on the msglvl and stoplvl values. Warning and error messages are displayed and stop for user input if the message level is equal to or greater than the msglvl and stoplvl values. The ending message is displayed if the ending return code is equal to or greater than msglvl. You see the message "Press any key to continue" which requires input if the utility ending return code is equal to or greater than the stoplvl.
ERRORS
You see warning and error messages which require input if the message level is equal to or greater than the msglvl and stoplvl. You do not see the ending message.
msglvl
A value from 4 through 20 to indicate the severity of messages to display. See below for more information.
stoplvl
A value from 4 through 20 to indicate the severity of messages to stop for user input. See below for more information.

Properties:

Default: ECHO(MSGS,4,8)

Comments:

The msglvl and stoplvl parameters can take the following values:

Value | Category | Example Cause
4 | General warning message | A minor coding error in DBD source which DBDGEN can make an assumption about and continue.
6 | IMS specific warning message | A warning that a keyword or statement is not supported and is ignored - processing can continue.
8 | General severe error | An incorrect coding in DBD source which cannot be compensated for, such as 'no DBD statement'.
10 | IMS Option specific severe error | An unsupported feature was defined which cannot be compensated for, such as 'Exceeded some maximum'.
12 | Severe error - possible temporary condition | A temporary I/O error such as a 'file locked' or 'database locked' status.
16 | Severe error- permanent - likely installation problem | A permanent I/O error, such as an invalid data set name or member name, was input to a utility or an environment variable is not set correctly.
20 | Severe error - permanent | An unrecoverable I/O error or some other unexpected error.
Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Delete Directives
Parent topic: Load Directives
Parent topic: Makelist Directives
Parent topic: PtrUpdate Directives
Parent topic: Runlist Directives
Parent topic: Unload Directives
Parent topic: Useq Directives
Parent topic: Zeroload Directives


INI

Specifies the default directives file.
Note: Supported by all mfims imsdbu functions.

Syntax:

>>-.---.-.-------INI--(filespec)--.-----><
   +-/-+ +.----.-INI--------------+
          +-NO-+

Parameters:

filespec
The name and location of the .INI file containing directives that will override the IMSDBU programmed defaults. filespec can include a drive and/or directory if required. If you do not specify a drive or directory, IMSDBU looks for the named .INI file in the current directory.

Properties:

Default: None

Comments:

Directives listed in the .INI file override the IMSDBU programmed defaults. Directives entered on the command line or interactive screen override directives in the .INI file.

Specifying NOINI prevents any .INI file from overriding the programmed defaults.

If you specify an .INI that does not exist, the programmed default directives are used as if NOINI were specified.

An .INI file is an ASCII text file. mfims imsdbu directives are identified by the heading [IMSDBU], starting in column 1. The list of directives follows this heading. Only one directive is allowed per line. A line is terminated by the next heading or an end-of-file. Comment lines are indicated by an asterisk (*) or semi-colon (;) in column 1. For example:

[IMSDBU]
PROGRESS(1000)
;use local log
LOG(C:\MYDIR\MYDB.LOG)
Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Delete Directives
Parent topic: Load Directives
Parent topic: Makelist Directives
Parent topic: PtrUpdate Directives
Parent topic: Reorganize Directives
Parent topic: Runlist Directives
Parent topic: Unload Directives
Parent topic: Useq Directives
Parent topic: Zeroload Directives


LAYOUT

Specifies the type of the input or output file.
Note: Supported by the following mfims imsdbu functions:
  • Add
  • Load
  • Unload

Syntax:

>>-----LAYOUT--(type)------><

Parameters:

Add and Load functions
type
The type of input file. One of:
D
The input file is an IMSDBU file layout. No additional directives are required to describe the input file.
G
The input file is a generic layout. Additional directives are required to describe the input file and its contents.
I
The input file is an IBM format. No additional directives are required to describe the input file.
S
The input file is a sequential file. Additional directives are required to describe the input file and its contents.
Unload function
type
The type of output file. One of:
D
The output file is an IMSDBU file layout. No additional directives are required to describe the output file.
G
The output file is a generic layout. Additional directives are required to describe the output file and its contents.
I
The output file is an IBM format. No additional directives are required to describe the output file.
S
The output file is a sequential file. Additional directives are required to describe the output file and its contents.

Properties:

Default: LAYOUT(D)

Comments:

The additional directives required for the G and S parameters are RECFM, LRECL, SEGM, and DATA.

Add and Load functions
LAYOUT(I) output files are not suitable for uploading to the mainframe and reloading IMS/ESA databases.
Unload function
Specifying LAYOUT(I) automatically sets the directives RECFM(V), LRECL(0), SEGM(7), DATA(36) and NOCOMPRESS. LAYOUT(I) output files are not suitable for uploading to the mainframe and reloading IMS/ESA databases.
Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Load Directives
Parent topic: Unload Directives
Related concepts
Specialized and Generic Load Inputs
Related reference
COMPRESS
DATA
SEGM


LIST

Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
Note: Supported by all mfims imsdbu functions.

Syntax:

>>-.---.-.-------LIST--(filespec)--.-----><
   +-/-+ +.----.-LIST--------------+
          +-NO-+

Parameters:

filespec
The name and location to use for the listing file. filespec can include a drive and/or directory if required. If you do not specify a drive or directory, MFIMS or IMSDBU creates the listing file in the current directory.

Properties:

Default: LIST(*.LST)

Comments:

NOLIST suppresses the creation of the listing file.

To specify a path, you can use the convention of placing a dollar sign ($) in front of the name of an environment variable that represents a path. For example, LIST($ENVVAR\*.DOC) creates a list file of dbdname.DOC in the directory named by the ENVVAR environment variable.

Specifying LIST(*.LST) or LIST(*.RPT) causes the listing file to be created in the project listing directory. If no path is specified, the listing file is created in the current directory.

Specifying LIST is equivalent to specifying LIST(*.LST).

If you specify the basename of filespec as an asterisk (*) it is replaced by the DBD name; this allows IMSDBU to provide separate reports for functions which can operate on multiple databases, such as Reorganize. It also assists in maintaining historical detailed reports by DBD name.

Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Delete Directives
Parent topic: Load Directives
Parent topic: Makelist Directives
Parent topic: Reorganize Directives
Parent topic: Unload Directives
Parent topic: Useq Directives
Parent topic: Zeroload Directives


LISTOPEN

Controls the open disposition of the detail listing file.
Note: Supported by all mfims imsdbu functions.

Syntax:

>>-----LISTOPEN--(disp)------><

Parameters:

disp
The disposition to use. One of:
NEW
Creates a new listing file or overwrites an existing one.
MOD
Appends the list output to an existing file or creates a new listing if one does not exist. MOD allows you to maintain a detailed historical record of database functions.

Properties:

Default: LISTOPEN(NEW)

Comments:

LISTOPEN is ignored when NOLIST is specified.

Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Delete Directives
Parent topic: Load Directives
Parent topic: Makelist Directives
Parent topic: PtrUpdate Directives
Parent topic: Reorganize Directives
Parent topic: Runlist Directives
Parent topic: Unload Directives
Parent topic: Useq Directives
Parent topic: Zeroload Directives
Related concepts
Reports, Statistics and Logs
IMSDBU Automation


LOG

Specifies the IMSDBU activity log.
Note: Supported by all mfims imsdbu functions.

Syntax:

>>-.---.-.-------LOG--(filespec)--.-----><
   +-/-+ +.----.-LOG--------------+
          +-NO-+

Parameters:

filespec
The name and location of the file to use as the IMSDBU activity log. filespec can include a drive and/or directory if required. If you do not specify a drive or directory, the listing is placed in the current directory.

Properties:

Default: LOG(IMSDBU.LOG)

Comments:

The activity log shows the ending message status for each function.

Specifying NOLOG suppresses the log file output.

The log file is created if it does not exist. The log file is historical. The most recent entries are written to the end of the file. This file grows in size and might require deletion periodically.

Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Delete Directives
Parent topic: Load Directives
Parent topic: Makelist Directives
Parent topic: PtrUpdate Directives
Parent topic: Reorganize Directives
Parent topic: Runlist Directives
Parent topic: Unload Directives
Parent topic: Useq Directives
Parent topic: Zeroload Directives
Related concepts
Reports, Statistics and Logs


LRECL

Specifies the length for fixed length generic layout input or output files.
Note: Supported by the following mfims imsdbu functions:
  • Add
  • Load
  • Unload

Syntax:

>>-----LRECL--(length)------><

Parameters:

length
The length for fixed length generic layout input (Add and Load functions) or output (Unload function) records.

Properties:

Default: LRECL(0)

Comments:

An LRECL is required when loading from a fixed-length generic file; that is, when LAYOUT(G) is specified. It is not required and is ignored when LAYOUT(D), LAYOUT(I) or LAYOUT(S) is specified.

Unload function
LRECL(0) causes IMSDBU to assign the smallest possible value. The value used will appear in the detail report listing.
Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Load Directives
Parent topic: Unload Directives
Related reference
DATA
RECFM


MAKELISTDSN

Specifies the dataset name of the output file for the IMSDBU commands.
Note: Supported by the Makelist mfims imsdbu function.

Syntax:

>>----MAKELISTDSN--(output-dsn)------><

Parameters:

output-dsn
The dataset name of the output file for the IMSDBU commands.

Properties:

Default: MAKELISTDSN(MAKELIST.RUN)

Comments:

This file is written to the current directory if no drive or directory is provided.

Parent topic: mfims imsdbu Directives
Parent topic: Makelist Directives
Related concepts
The Makelist Function's Inputs and Outputs


PROGRESS

Controls the frequency of progress reporting.
Note: Supported by all mfims imsdbu functions.

Syntax:

>>-------PROGRESS--(no-of-segments)---><

Parameters:

no-of-segments
A value between 0 and 9999 indicating the number of segments to process before displaying a progress message. 0 disables progress reporting.

Properties:

Default: PROGRESS(200)

Comments:

Depending of the function being carried out, the progress message shows the number of segments processed or the percentage complete and an estimate of the time remaining.

In general, we recommend not reducing this value below its default. Very small values measurably reduce the performance of the database function. For relatively fast systems, setting the value higher (such as to 1000 or larger) may improve performance slightly.

Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Delete Directives
Parent topic: Load Directives
Parent topic: Makelist Directives
Parent topic: PtrUpdate Directives
Parent topic: Reorganize Directives
Parent topic: Runlist Directives
Parent topic: Unload Directives
Parent topic: Useq Directives
Parent topic: Zeroload Directives
Related concepts
Reports, Statistics and Logs


RECFM

Specifies the format of the input or output records.
Note: Supported by the following mfims imsdbu functions:
  • Add
  • Load
  • Unload

Syntax:

>>----RECFM--(format)------><

Parameters:

format
The format of the input (Add and Load functions) or output (Unload function) records. One of:
V
Records are variable length. With LAYOUT(G), each record is prefixed with a 2-byte record length (LL) and the file is in the same format as created by the VRECGEN utility. With LAYOUT(S), files are in Micro Focus record sequential format.
F
Records are a fixed length. Requires the LRECL directive to specify the record length.

Properties:

Default: RECFM(V)

Comments:

The RECFM directive is only used when LAYOUT(G) or LAYOUT(S) is specified. It is not required and is ignored when LAYOUT(D) or LAYOUT(I) is specified.

Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Load Directives
Parent topic: Unload Directives
Related concepts
Specialized and Generic Load Inputs
Related reference
DATA
LRECL
SEGM


REPLACE

Specifies how duplicate root segments are to be processed.
Note: Supported by the Add mfims imsdbu function.

Syntax:

>>-.----.--REPLACE------><
   +-NO-+

Parameters:

None

Properties:

Default: NOREPLACE

Comments:

When adding segments to a database, a root collision occurs when the key of a root segment in the input file already exists in the database. Specifying REPLACE causes the existing database root segment (and its children) to be deleted and the segments from the input file to be inserted. Specifying NOREPLACE causes the segments in the input file to be ignored and the existing database segments to be left as they were.

Parent topic: mfims imsdbu Directives
Parent topic: Add Directives


SEGEXIT

Specifies the name of a user-supplied exit program that can be used to control selection and modification of segment data during the add, load, or unload process.
Note: Supported by the following mfims imsdbu functions:
  • Add
  • Load
  • Unload

Syntax:

>>-.---.-.-------SEGEXIT--(program)--.-----><
   +-/-+ +.----.-SEGEXIT-------------+
          +-NO-+

Parameters:

program
The name of the exit program to use.

Properties:

Default: NOSEGEXIT

Comments:

NOSEGEXIT disables this exit.

Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Load Directives
Parent topic: Unload Directives
Related concepts
Load and Unload Exits


SEGM

Specifies the starting position of the 8-byte segment name in the data record.
Note: Supported by the following mfims imsdbu functions:
  • Add
  • Load
  • Unload

Syntax:

>>-----SEGM--(position)------><

Parameters:

position
The starting position of the 8-byte segment name in the data record.

Properties:

Default: SEGM(1)

Comments:

A value of 1 corresponds to the first byte of the record data.

When RECFM(V) is specified, the variable length record prefix (LL) is not considered part of the record data and does not affect this value. That is, if the segment name is the first field following the LL field in a variable length file, specify 1 for the SEGM value.

Add function
When loading Fast Path databases which use LTERM keys (related or non-related), the SEGM directive indicates the position of the LTERM name and not the segment name.
Add and Load functions
The SEGM directive is only used when LAYOUT(G) is specified. It is not required and is ignored when LAYOUT(D), LAYOUT(I) or LAYOUT(S) is specified.
Load and Unload functions
When loading GSAM files, the SEGM value is ignored. When loading Fast Path databases which use LTERM keys (related or non-related), the SEGM directive indicates the position of the LTERM name and not the segment name.
Unload function
The SEGM directive is only used when when LAYOUT(G) or LAYOUT(S) is specified. It is not required and is ignored when LAYOUT(D) or LAYOUT(I) is specified.
Parent topic: mfims imsdbu Directives
Parent topic: Add Directives
Parent topic: Load Directives
Parent topic: Unload Directives
Related concepts
Specialized and Generic Load Inputs
Related reference
LAYOUT
RECFM


Add Directives

The following mfims imsdbu directives are available when using the Add function:

  • CLS
    Clears the screen before starting the utility.
  • COMPRESS
    Specifies whether compression was used when the input or output data file was created.
  • DATA
    Specifies the starting position of the segment data in the data record.
  • DSN
    Specifies the dataset name of the input file containing the segment data.
  • ECHO
    Controls the display of and interaction with the messages displayed by IMSDBU.
  • INI
    Specifies the default directives file.
  • LAYOUT
    Specifies the type of the input or output file.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • LISTOPEN
    Controls the open disposition of the detail listing file.
  • LOG
    Specifies the IMSDBU activity log.
  • LRECL
    Specifies the length for fixed length generic layout input or output files.
  • PROGRESS
    Controls the frequency of progress reporting.
  • RECFM
    Specifies the format of the input or output records.
  • REPLACE
    Specifies how duplicate root segments are to be processed.
  • SEGEXIT
    Specifies the name of a user-supplied exit program that can be used to control selection and modification of segment data during the add, load, or unload process.
  • SEGM
    Specifies the starting position of the 8-byte segment name in the data record.
Parent topic: mfims imsdbu Directives
Related concepts
The Add Function


Delete Directives

The following mfims imsdbu directives are available when using the Delete function:

  • CLS
    Clears the screen before starting the utility.
  • ECHO
    Controls the display of and interaction with the messages displayed by IMSDBU.
  • INI
    Specifies the default directives file.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • LISTOPEN
    Controls the open disposition of the detail listing file.
  • LOG
    Specifies the IMSDBU activity log.
  • PROGRESS
    Controls the frequency of progress reporting.
Parent topic: mfims imsdbu Directives
Related concepts
The Delete Function


Load Directives

The following directives are available when using the Load function:

  • CLS
    Clears the screen before starting the utility.
  • COMPRESS
    Specifies whether compression was used when the input or output data file was created.
  • DATA
    Specifies the starting position of the segment data in the data record.
  • DSN
    Specifies the dataset name of the input file containing the segment data.
  • ECHO
    Controls the display of and interaction with the messages displayed by IMSDBU.
  • INI
    Specifies the default directives file.
  • LAYOUT
    Specifies the type of the input or output file.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • LISTOPEN
    Controls the open disposition of the detail listing file.
  • LOG
    Specifies the IMSDBU activity log.
  • LRECL
    Specifies the length for fixed length generic layout input or output files.
  • PROGRESS
    Controls the frequency of progress reporting.
  • RECFM
    Specifies the format of the input or output records.
  • SEGEXIT
    Specifies the name of a user-supplied exit program that can be used to control selection and modification of segment data during the add, load, or unload process.
  • SEGM
    Specifies the starting position of the 8-byte segment name in the data record.
Parent topic: mfims imsdbu Directives
Related concepts
The Load Function


Makelist Directives

The following directives are available when using the Makelist function:

  • CLS
    Clears the screen before starting the utility.
  • ECHO
    Controls the display of and interaction with the messages displayed by IMSDBU.
  • INI
    Specifies the default directives file.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • LISTOPEN
    Controls the open disposition of the detail listing file.
  • LOG
    Specifies the IMSDBU activity log.
  • MAKELISTDSN
    Specifies the dataset name of the output file for the IMSDBU commands.
  • PROGRESS
    Controls the frequency of progress reporting.
Parent topic: mfims imsdbu Directives
Related concepts
The Makelist Function


PtrUpdate Directives

There are no directives specific to the PtrUpdate function; however the following mfims imsdbu directives are available when using the PtrUpdate function:

  • CLS
    Clears the screen before starting the utility.
  • ECHO
    Controls the display of and interaction with the messages displayed by IMSDBU.
  • INI
    Specifies the default directives file.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • LISTOPEN
    Controls the open disposition of the detail listing file.
  • LOG
    Specifies the IMSDBU activity log.
  • PROGRESS
    Controls the frequency of progress reporting.
Parent topic: mfims imsdbu Directives
Related concepts
The PtrUpdate Function


Reorganize Directives

There are no directives specific to the Reorganize function; however the following mfims imsdbu directives are available when using the Reorganize function:

  • CLS
    Clears the screen before starting the utility.
  • ECHO
    Controls the interaction with the DBDGEN, MFSGEN and PSBGEN utilities.
  • INI
    Specifies the default directives file.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • LISTOPEN
    Controls the open disposition of the detail listing file.
  • LOG
    Specifies the IMSDBU activity log.
  • PROGRESS
    Controls the frequency of progress reporting.
Parent topic: mfims imsdbu Directives
Related concepts
The Reorganize Function


Runlist Directives

There are no directives specific to the Runlist function; however you can use the mfims imsdbu directives listed below.

Any directives entered for Runlist are passed to the functions that Runlist is executing. When processing functions using Runlist, the sequence for processing directives is:

  1. IMSDBU programmed defaults.
  2. Directives in the .INI file override the programmed defaults.
  3. When starting Runlist from the interactive screen, any directives from the Runlist entry screen override the previous directives.
  4. When starting Runlist from the command line, any directives entered on the Runlist command line override the previous directives.
  5. Directives specified for a function in the Runlist command file take precedence over all other directives.

The Makelist function adds directives to the function commands in its output Runlist command file. It only adds directives which are specific to a function. Any changes to the .INI file directives between the Makelist and the Runlist will not affect the function directives in the Runlist command file. Makelist does not add any common directives. For example, the LIST, LOG, and ECHO directives. The common directives used by Runlist are the ones active when starting Runlist - not when creating the command file using Makelist.

You can add common directives to the Runlist command file if you want to ensure that changes to the .INI file directives will not affect the operation of Runlist.

  • CLS
    Clears the screen before starting the utility.
  • ECHO
    Controls the display of and interaction with the messages displayed by IMSDBU.
  • INI
    Specifies the default directives file.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • LISTOPEN
    Controls the open disposition of the detail listing file.
  • LOG
    Specifies the IMSDBU activity log.
  • PROGRESS
    Controls the frequency of progress reporting.
Parent topic: mfims imsdbu Directives
Related concepts
The Runlist Function


Unload Directives

The following directives are available when using the Unload function:

  • CLS
    Clears the screen before starting the utility.
  • COMPRESS
    Specifies whether compression was used when the input or output data file was created.
  • DATA
    Specifies the starting position of the segment data in the data record.
  • DSN
    Specifies the dataset name of the input file containing the segment data.
  • ECHO
    Controls the display of and interaction with the messages displayed by IMSDBU.
  • INI
    Specifies the default directives file.
  • LAYOUT
    Specifies the type of the input or output file.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • LISTOPEN
    Controls the open disposition of the detail listing file.
  • LOG
    Specifies the IMSDBU activity log.
  • LRECL
    Specifies the length for fixed length generic layout input or output files.
  • PROGRESS
    Controls the frequency of progress reporting.
  • RECFM
    Specifies the format of the input or output records.
  • SEGEXIT
    Specifies the name of a user-supplied exit program that can be used to control selection and modification of segment data during the add, load, or unload process.
  • SEGM
    Specifies the starting position of the 8-byte segment name in the data record.
Parent topic: mfims imsdbu Directives
Related concepts
The Unload Function


Useq Directives

The following directive is available when using the Useq function; however the following mfims imsdbu directives are available when using the Useq function:

  • CLS
    Clears the screen before starting the utility.
  • DSN
    Specifies the dataset name of the input file containing the segment data.
  • ECHO
    Controls the display of and interaction with the messages displayed by IMSDBU.
  • INI
    Specifies the default directives file.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • LISTOPEN
    Controls the open disposition of the detail listing file.
  • LOG
    Specifies the IMSDBU activity log.
  • PROGRESS
    Controls the frequency of progress reporting.
Parent topic: mfims imsdbu Directives
Related concepts
The Useq Function


Zeroload Directives

There are no directives specific to the Zeroload function; however the following mfims imsdbu directives are available when using the Zeroload function:

  • CLS
    Clears the screen before starting the utility.
  • ECHO
    Controls the display of and interaction with the messages displayed by IMSDBU.
  • INI
    Specifies the default directives file.
  • LIST
    Controls the location and name of the detail listing file, which includes items such as source listings, completion status, error messages and execution statistics.
  • LISTOPEN
    Controls the open disposition of the detail listing file.
  • LOG
    Specifies the IMSDBU activity log.
  • PROGRESS
    Controls the frequency of progress reporting.
Parent topic: mfims imsdbu Directives
Related concepts
The Zeroload Function


IMS Error Messages

  • DBD Error Messages
  • DBUTIL Error Messages
  • IMS Database Editor Error Messages
  • IMS Run-time System Error Messages
  • MFS Error Messages
  • PSB Error Messages
  • SECRMT MSG ID: RMTSEC REMOTE IMS REQUESTER
  • IMS Stage 1 Import/Export Error Messages
Parent topic: IMS Support


DBD Error Messages

  • Messages DBDUT0401 to DBDUT0417
  • Messages DBDUT04A1 to DBDUT04A6
  • Messages DBDUT04E1 to DBDUT04E2
  • Messages DBDUT0801 to DBDUT0882
  • Messages DBDUT08A1 to DBDUT08A3
  • Messages DBDUT08P1 to DBDUT08P2
  • Messages DBDUT0L02 to DBDUT0L99
  • Messages DBDUT0LA1 to DBDUT0LA2
  • Messages DBDUT0LP1 to DBDUT0LP3
  • Messages DBDUT0U01 to DBDUT0U35
  • Messages DBDUT0W01 to DBDUT0W19
  • Messages DBDUT0WA1 to DBDUT0WA9
  • Messages DBDUT0WE1 to DBDUT0WE2
  • Messages DBDUT0WF1 to DBDUT0WF2
  • DBDUT0WP2W MFIMS supports a maximum of %2% data capture exit routines per segment, first %2% routines accepted
Parent topic: IMS Error Messages


Messages DBDUT0401 to DBDUT0417

  • DBDUT0401W More than one DBD macro present, all but the first ignored
  • DBDUT0402W DBD RMNAME operand invalid with ACCESS %8, RMNAME ignored
  • DBDUT0403W More than one DBDGEN statement present, all but the first ignored
  • DBDUT0404W Unknown keyword, %8 for %8, ignored
  • DBDUT0405W DBDGEN statement appeared before %8 macro
  • DBDUT0406W Field TYPE=H (Halfword), assumed to be two bytes long
  • DBDUT0407W Field TYPE=F (Fullword), assumed to be four bytes long
  • DBDUT0408W DATASET SCAN operand is invalid for ACCESS %8, SCAN ignored
  • DBDUT0409W DATASET FRSPC operand is invalid for ACCESS %8, FRSPC ignored
  • DBDUT0410W Exceeded maximum of 10 DATASET macros with operands
  • DBDUT0411W Label %8, only the first DATASET with a common label can contain operands
  • DBDUT0412W DATASET contains no operands but label %8 not previously defined
  • DBDUT0413W Duplicate DATASET DDNAME %8 in DD1, DD2, or OVFLW
  • DBDUT0414W Label %8, DD1 %8, previous DATASET group contains no segments
  • DBDUT0415W SEGM macro not preceded by DATASET macro. DATASET is required for access type: %8
  • DBDUT0416W Incorrect RULES specified for sequential dependent segment %8, FIRST rules assumed
  • DBDUT0417W Missing required DBDGEN macro statement, assumed present
Parent topic: DBD Error Messages


DBDUT0401W More than one DBD macro present, all but the first ignored

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0402W DBD RMNAME operand invalid with ACCESS %8, RMNAME ignored

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0403W More than one DBDGEN statement present, all but the first ignored

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0404W Unknown keyword, %8 for %8, ignored

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0405W DBDGEN statement appeared before %8 macro

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0406W Field TYPE=H (Halfword), assumed to be two bytes long

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0407W Field TYPE=F (Fullword), assumed to be four bytes long

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0408W DATASET SCAN operand is invalid for ACCESS %8, SCAN ignored

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0409W DATASET FRSPC operand is invalid for ACCESS %8, FRSPC ignored

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0410W Exceeded maximum of 10 DATASET macros with operands

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0411W Label %8, only the first DATASET with a common label can contain operands

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0412W DATASET contains no operands but label %8 not previously defined

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0413W Duplicate DATASET DDNAME %8 in DD1, DD2, or OVFLW

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0414W Label %8, DD1 %8, previous DATASET group contains no segments

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0415W SEGM macro not preceded by DATASET macro. DATASET is required for access type: %8

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0416W Incorrect RULES specified for sequential dependent segment %8, FIRST rules assumed

Parent topic: Messages DBDUT0401 to DBDUT0417


DBDUT0417W Missing required DBDGEN macro statement, assumed present

Parent topic: Messages DBDUT0401 to DBDUT0417


Messages DBDUT04A1 to DBDUT04A6

  • DBDUT04A1W Continuation cannot start in column 1
  • DBDUT04A2W Expected "=", found "(", "=" is assumed
  • DBDUT04A3W Continuation expected, none received
  • DBDUT04A4W Invalid character following final quote "%1"
  • DBDUT04A5W %8 has a non-numeric value "%8", assumed zero
  • DBDUT04A6W Duplicate keyword %8 specified, last one used
Parent topic: DBD Error Messages


DBDUT04A1W Continuation cannot start in column 1

Parent topic: Messages DBDUT04A1 to DBDUT04A6


DBDUT04A2W Expected "=", found "(", "=" is assumed

Parent topic: Messages DBDUT04A1 to DBDUT04A6


DBDUT04A3W Continuation expected, none received

Parent topic: Messages DBDUT04A1 to DBDUT04A6


DBDUT04A4W Invalid character following final quote "%1"

Parent topic: Messages DBDUT04A1 to DBDUT04A6


DBDUT04A5W %8 has a non-numeric value "%8", assumed zero

Parent topic: Messages DBDUT04A1 to DBDUT04A6


DBDUT04A6W Duplicate keyword %8 specified, last one used

Parent topic: Messages DBDUT04A1 to DBDUT04A6


Messages DBDUT04E1 to DBDUT04E2

  • DBDUT04E1W EQU %8 error, keyword already has data
  • DBDUT04E2W EQU %8 error, data already has a keyword
Parent topic: DBD Error Messages


DBDUT04E1W EQU %8 error, keyword already has data

Parent topic: Messages DBDUT04E1 to DBDUT04E2


DBDUT04E2W EQU %8 error, data already has a keyword

Parent topic: Messages DBDUT04E1 to DBDUT04E2


Messages DBDUT0801 to DBDUT0882

  • DBDUT0801E SEGM macro not preceded by DBD macro. DBD macro must be first statement in DBD source
  • DBDUT0802E DBD macro missing required NAME operand
  • DBDUT0803E HDAM or DEDB database missing required RMNAME operand
  • DBDUT0804E PARENT segment %8 for segment %8 not previously defined in this database
  • DBDUT0805E Source segment %8 for XDFLD %8 not defined
  • DBDUT0806E SEGM macro missing required NAME operand
  • DBDUT0807E Missing required DBDGEN statement
  • DBDUT0808E SEGM %8 has missing or invalid BYTES operand
  • DBDUT0809E SEGM %8, minimum bytes (%5%) exceeds maximum bytes (%5%)
  • DBDUT0810E DEDB root segment %8, field %8 not unique
  • DBDUT0811E Non-related MSDB segment %8, field %8 not unique
  • DBDUT0812E INDEX DBD segment %8 must contain a sequence field. Field %8 not a sequence field
  • DBDUT0813E FIELD macro not preceded by SEGM macro
  • DBDUT0814E Segment %8, FIELD macro missing required NAME operand
  • DBDUT0815E SEGM %8, FIELD %8, contains invalid data in name parameter, 3rd operand %1
  • DBDUT0816E DEDB sequential dependent segment %8 contains invalid sequence field %8
  • DBDUT0817E SEGM %8, FIELD %8 contains invalid data in name parameter, 2nd operand %4 not SEQ
  • DBDUT0818E Segment %8, sequence field %8 must be first field after SEGM for IMS/ESA compatibility. Use system config, IBM DLI PLATFORM setting for DOS/VS syntax
  • DBDUT0819E COPY statement missing required name parameter
  • DBDUT0820E COPY member %8 not found
  • DBDUT0821E Segment %8, field %8 not unique
  • DBDUT0822E Segment %8, field %8 packed length cannot exceed 16 bytes
  • DBDUT0823E Segment %8, field %8, BYTES operand missing or invalid
  • DBDUT0824E Segment %8, field %8 missing required START operand
  • DBDUT0825E Field %8 extends beyond segment maximum size of %5%, field start %5%, length %5%
  • DBDUT0826E Segment name %8 not unique within this DBD
  • DBDUT0827E %8 ACCESS type requires DATASET DD1 operand when DATASET does not have a label
  • DBDUT0828E DATASET SCAN value of %5%, exceeds maximum of 255
  • DBDUT0829E DATASET FRSPC (free block frequency) of %5% must be in range of zero to 100, but not 1
  • DBDUT0830E DATASET FRSPC percentage of %3% must be in range of 0 to 99
  • DBDUT0831E LOGICAL DATASET not valid with ACCESS %8
  • DBDUT0832E MSDB missing required DATASET REL operand
  • DBDUT0833E Only 1 SEGM statement allowed in MSDB database
  • DBDUT0834E SEGM %8 missing required PARENT operand
  • DBDUT0835E Segment %8, length %6% exceeds maximum segment length of 32760
  • DBDUT0836E Segment %8 level is deeper than 15, parent segment %8
  • DBDUT0837E DBD ACCESS %8 does not support Virtual segments
  • DBDUT0838E LCHILD missing required segment NAME operand
  • DBDUT0839E LCHILD segment operand %8 missing required DBD NAME operand in index DBD
  • DBDUT0840E LCHILD PAIR operand not supported with ACCESS %8
  • DBDUT0841E XDFLD statement not supported with ACCESS %8
  • DBDUT0842E GSAM DATASET macro missing required RECFM operand
  • DBDUT0843E Missing required DBD macro statement
  • DBDUT0844E SEGM statement not found, DBD requires at least one
  • DBDUT0845E Paired segment %8 not found in DBD or occurred more than once
  • DBDUT0846E Index DBD can contain only one LCHILD statement
  • DBDUT0847E Index DBD missing required LCHILD statement
  • DBDUT0848E XDFLD missing required NAME operand
  • DBDUT0849E XDFLD %8 missing required SRCH operand
  • DBDUT0850E XDFLD %8 precedes SEGM statement and is missing SEGMENT operand
  • DBDUT0851E XDFLD %8 has more than 5 SUBSEQ fields
  • DBDUT0852E XDFLD %8 has more than 5 DDATA fields
  • DBDUT0853E XDFLD %8 has more than 5 SRCH fields
  • DBDUT0854E LCHILD %8, XDFLD %8, key length %4% exceeds maximum CONST,SRCH,SUBSEQ length of 240
  • DBDUT0855E XDFLD %8, SEGMENT %8 not defined in database
  • DBDUT0856E XDFLD %8, SRCH field %8 not in source segment %8
  • DBDUT0857E XDFLD %8, DDATA field %8 not in source segment %8
  • DBDUT0858E XDFLD %8, source segment %8, DDATA field %8 cannot be a /SX field
  • DBDUT0859E XDFLD %8, SUBSEQ field %8 not in source segment %8
  • DBDUT0860E XDFLD %8, target segment %8 not parent of source segment %8
  • DBDUT0862E Sequence field %8 in root segment %8 must be unique for database type %8
  • DBDUT0863E GSAM minimum record length exceeds maximum for RECFM=V
  • DBDUT0865E SEGM statement limit of 255 exceeded
  • DBDUT0866E FIELD statement limit of 1000 exceeded
  • DBDUT0867E Segment %8, key sequence field %8, length %4% exceeds maximum
  • DBDUT0868E Virtual logical child segment %8 not referenced by an LCHILD PAIR statement
  • DBDUT0869E Paired (real) logical child segment %8 missing logical PARENT specification
  • DBDUT0870E DBD statement missing required ACCESS operand
  • DBDUT0871E MSDB missing required DATASET REL operand
  • DBDUT0872E XDFLD has no preceding LCHILD statement
  • DBDUT0873E Sequence field %8, start %5%, length %5% extends beyond SEGM minimum size of %5% bytes
  • DBDUT0874E Segment %8, sequence field %8 invalid, only 1 sequence field allowed for this segment type
  • DBDUT0875E Segment %8, field %8, START value %8 not numeric or names a field which is not defined for this SEGM
  • DBDUT0876E EXIT parameter is not allowed with ACCESS of %8
  • DBDUT0877E Logical SEGM %8 missing required SOURCE operand
  • DBDUT0878E Segment %8, hierarchy sequence error
  • DBDUT0879E First ACCESS statement must precede first SEGM
  • DBDUT0880E ACCESS statement contains mutually exclusive keywords RMRTN and REF
  • DBDUT0881E ACCESS statement only valid with DBD ACCESS=HD
  • DBDUT0882 Segment FIELD statement limit of 255 exceeded
Parent topic: DBD Error Messages


DBDUT0801E SEGM macro not preceded by DBD macro. DBD macro must be first statement in DBD source

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0802E DBD macro missing required NAME operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0803E HDAM or DEDB database missing required RMNAME operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0804E PARENT segment %8 for segment %8 not previously defined in this database

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0805E Source segment %8 for XDFLD %8 not defined

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0806E SEGM macro missing required NAME operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0807E Missing required DBDGEN statement

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0808E SEGM %8 has missing or invalid BYTES operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0809E SEGM %8, minimum bytes (%5%) exceeds maximum bytes (%5%)

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0810E DEDB root segment %8, field %8 not unique

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0811E Non-related MSDB segment %8, field %8 not unique

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0812E INDEX DBD segment %8 must contain a sequence field. Field %8 not a sequence field

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0813E FIELD macro not preceded by SEGM macro

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0814E Segment %8, FIELD macro missing required NAME operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0815E SEGM %8, FIELD %8, contains invalid data in name parameter, 3rd operand %1

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0816E DEDB sequential dependent segment %8 contains invalid sequence field %8

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0817E SEGM %8, FIELD %8 contains invalid data in name parameter, 2nd operand %4 not SEQ

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0818E Segment %8, sequence field %8 must be first field after SEGM for IMS/ESA compatibility. Use system config, IBM DLI PLATFORM setting for DOS/VS syntax

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0819E COPY statement missing required name parameter

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0820E COPY member %8 not found

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0821E Segment %8, field %8 not unique

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0822E Segment %8, field %8 packed length cannot exceed 16 bytes

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0823E Segment %8, field %8, BYTES operand missing or invalid

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0824E Segment %8, field %8 missing required START operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0825E Field %8 extends beyond segment maximum size of %5%, field start %5%, length %5%

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0826E Segment name %8 not unique within this DBD

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0827E %8 ACCESS type requires DATASET DD1 operand when DATASET does not have a label

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0828E DATASET SCAN value of %5%, exceeds maximum of 255

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0829E DATASET FRSPC (free block frequency) of %5% must be in range of zero to 100, but not 1

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0830E DATASET FRSPC percentage of %3% must be in range of 0 to 99

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0831E LOGICAL DATASET not valid with ACCESS %8

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0832E MSDB missing required DATASET REL operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0833E Only 1 SEGM statement allowed in MSDB database

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0834E SEGM %8 missing required PARENT operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0835E Segment %8, length %6% exceeds maximum segment length of 32760

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0836E Segment %8 level is deeper than 15, parent segment %8

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0837E DBD ACCESS %8 does not support Virtual segments

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0838E LCHILD missing required segment NAME operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0839E LCHILD segment operand %8 missing required DBD NAME operand in index DBD

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0840E LCHILD PAIR operand not supported with ACCESS %8

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0841E XDFLD statement not supported with ACCESS %8

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0842E GSAM DATASET macro missing required RECFM operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0843E Missing required DBD macro statement

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0844E SEGM statement not found, DBD requires at least one

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0845E Paired segment %8 not found in DBD or occurred more than once

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0846E Index DBD can contain only one LCHILD statement

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0847E Index DBD missing required LCHILD statement

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0848E XDFLD missing required NAME operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0849E XDFLD %8 missing required SRCH operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0850E XDFLD %8 precedes SEGM statement and is missing SEGMENT operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0851E XDFLD %8 has more than 5 SUBSEQ fields

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0852E XDFLD %8 has more than 5 DDATA fields

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0853E XDFLD %8 has more than 5 SRCH fields

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0854E LCHILD %8, XDFLD %8, key length %4% exceeds maximum CONST,SRCH,SUBSEQ length of 240

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0855E XDFLD %8, SEGMENT %8 not defined in database

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0856E XDFLD %8, SRCH field %8 not in source segment %8

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0857E XDFLD %8, DDATA field %8 not in source segment %8

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0858E XDFLD %8, source segment %8, DDATA field %8 cannot be a /SX field

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0859E XDFLD %8, SUBSEQ field %8 not in source segment %8

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0860E XDFLD %8, target segment %8 not parent of source segment %8

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0862E Sequence field %8 in root segment %8 must be unique for database type %8

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0863E GSAM minimum record length exceeds maximum for RECFM=V

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0865E SEGM statement limit of 255 exceeded

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0866E FIELD statement limit of 1000 exceeded

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0867E Segment %8, key sequence field %8, length %4% exceeds maximum

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0868E Virtual logical child segment %8 not referenced by an LCHILD PAIR statement

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0869E Paired (real) logical child segment %8 missing logical PARENT specification

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0870E DBD statement missing required ACCESS operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0871E MSDB missing required DATASET REL operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0872E XDFLD has no preceding LCHILD statement

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0873E Sequence field %8, start %5%, length %5% extends beyond SEGM minimum size of %5% bytes

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0874E Segment %8, sequence field %8 invalid, only 1 sequence field allowed for this segment type

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0875E Segment %8, field %8, START value %8 not numeric or names a field which is not defined for this SEGM

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0876E EXIT parameter is not allowed with ACCESS of %8

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0877E Logical SEGM %8 missing required SOURCE operand

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0878E Segment %8, hierarchy sequence error

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0879E First ACCESS statement must precede first SEGM

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0880E ACCESS statement contains mutually exclusive keywords RMRTN and REF

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0881E ACCESS statement only valid with DBD ACCESS=HD

Parent topic: Messages DBDUT0801 to DBDUT0882


DBDUT0882 Segment FIELD statement limit of 255 exceeded

Parent topic: Messages DBDUT0801 to DBDUT0882


Messages DBDUT08A1 to DBDUT08A3

  • DBDUT08A1E Unmatched parentheses
  • DBDUT08A2E Unmatched quotes
  • DBDUT08A3E Positional operand cannot follow keyword operand: %60%
Parent topic: DBD Error Messages


DBDUT08A1E Unmatched parentheses

Parent topic: Messages DBDUT08A1 to DBDUT08A3


DBDUT08A2E Unmatched quotes

Parent topic: Messages DBDUT08A1 to DBDUT08A3


DBDUT08A3E Positional operand cannot follow keyword operand: %60%

Parent topic: Messages DBDUT08A1 to DBDUT08A3


Messages DBDUT08P1 to DBDUT08P2

  • DBDUT08P1E Number of list operands exceeds MFIMS maximum of %3%
  • DBDUT08P2E Macro %8, keyword %8 has unmatched parentheses
Parent topic: DBD Error Messages


DBDUT08P1E Number of list operands exceeds MFIMS maximum of %3%

Parent topic: Messages DBDUT08P1 to DBDUT08P2


DBDUT08P2E Macro %8, keyword %8 has unmatched parentheses

Parent topic: Messages DBDUT08P1 to DBDUT08P2


Messages DBDUT0L02 to DBDUT0L99

  • DBDUT0L02E MFIMS does not support GSAM undefined length records
  • DBDUT0L05E Bidirectional pairings exceed MFIMS limit of %4% per DBD
  • DBDUT0L09E XDFLD statements exceed MFIMS limit of %4% per DBD
  • DBDUT0L10E Index DBD can only contain one SEGM statement in MFIMS. Shared index databases must be defined with separate DBDs
  • DBDUT0L11E This database requires a %5% byte MFIMS control key and exceeds the maximum of %4% bytes
  • DBDUT0L12E XDFLD exceeds MFIMS maximum index record size of %5%
  • DBDUT0L13E MFIMS user data extension incorrectly used for XDFLD %8. USTART operand is required when PTR=SYMB and concatenated key (CK) BYTES or START overridden
  • DBDUT0L14E MFIMS user data extension incorrectly used in XDFLD %8. XDFLD USTART operand is not beyond lengths of CONST,SRCH,SUBSEQ, and DDATA fields
  • DBDUT0L15E Segment %8, IMS86KEY value %5% must be less than field %8 BYTES value %5%
  • DBDUT0L16E IMS86KEY operand only valid for sequenced segments
  • DBDUT0L17E Number of logical children segments exceed MFIMS limit of %4% per DBD
  • DBDUT0L18E Segment %8, field %8 exceeds MFIMS limit of 8 sequence fields for a virtual logical child segment
  • DBDUT0L20E Database %8, specifies ACCESS=HD and requires MFIMS IBM DLI PLATFORM configuration to be set to DOS/VS
  • DBDUT0L21E ACCESS statements exceed MFIMS limit of %4% per DBD
  • DBDUT0L99E Valid software license not present. Reason code (%4%)
Parent topic: DBD Error Messages


DBDUT0L02E MFIMS does not support GSAM undefined length records

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L05E Bidirectional pairings exceed MFIMS limit of %4% per DBD

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L09E XDFLD statements exceed MFIMS limit of %4% per DBD

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L10E Index DBD can only contain one SEGM statement in MFIMS. Shared index databases must be defined with separate DBDs

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L11E This database requires a %5% byte MFIMS control key and exceeds the maximum of %4% bytes

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L12E XDFLD exceeds MFIMS maximum index record size of %5%

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L13E MFIMS user data extension incorrectly used for XDFLD %8. USTART operand is required when PTR=SYMB and concatenated key (CK) BYTES or START overridden

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L14E MFIMS user data extension incorrectly used in XDFLD %8. XDFLD USTART operand is not beyond lengths of CONST,SRCH,SUBSEQ, and DDATA fields

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L15E Segment %8, IMS86KEY value %5% must be less than field %8 BYTES value %5%

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L16E IMS86KEY operand only valid for sequenced segments

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L17E Number of logical children segments exceed MFIMS limit of %4% per DBD

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L18E Segment %8, field %8 exceeds MFIMS limit of 8 sequence fields for a virtual logical child segment

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L20E Database %8, specifies ACCESS=HD and requires MFIMS IBM DLI PLATFORM configuration to be set to DOS/VS

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L21E ACCESS statements exceed MFIMS limit of %4% per DBD

Parent topic: Messages DBDUT0L02 to DBDUT0L99


DBDUT0L99E Valid software license not present. Reason code (%4%)

Parent topic: Messages DBDUT0L02 to DBDUT0L99


Messages DBDUT0LA1 to DBDUT0LA2

  • DBDUT0LA1E Positional operand cannot follow keyword operand: %60% MFIMS does not perform MFSGEN syntax error recovery
  • DBDUT0LA2E Length of operand exceeds MFIMS maximum of %4 bytes
Parent topic: DBD Error Messages


DBDUT0LA1E Positional operand cannot follow keyword operand: %60% MFIMS does not perform MFSGEN syntax error recovery

Parent topic: Messages DBDUT0LA1 to DBDUT0LA2


DBDUT0LA2E Length of operand exceeds MFIMS maximum of %4 bytes

Parent topic: Messages DBDUT0LA1 to DBDUT0LA2


Messages DBDUT0LP1 to DBDUT0LP3

  • DBDUT0LP1E Length of operand exceeds MFIMS size of %4% bytes
  • DBDUT0LP2E Number of list operands exceeds MFIMS maximum of %3%
  • DBDUT0LP3E Length of list exceeds MFIMS maximum of %4% bytes
Parent topic: DBD Error Messages


DBDUT0LP1E Length of operand exceeds MFIMS size of %4% bytes

Parent topic: Messages DBDUT0LP1 to DBDUT0LP3


DBDUT0LP2E Number of list operands exceeds MFIMS maximum of %3%

Parent topic: Messages DBDUT0LP1 to DBDUT0LP3


DBDUT0LP3E Length of list exceeds MFIMS maximum of %4% bytes

Parent topic: Messages DBDUT0LP1 to DBDUT0LP3


Messages DBDUT0U01 to DBDUT0U35

  • DBDUT0U01U File status %A5 opening file %C60. %B40%
  • DBDUT0U02U File status %A5 issuing close for file %C60. %B40%
  • DBDUT0U03U File status %A5 issuing read for file %C60. %B40%
  • DBDUT0U04U File status %5 issuing set/date for DBDGEN. %40%
  • DBDUT0U05U File status %5 issuing close for DBDGEN file. %40%
  • DBDUT0U06U File status %5 issuing close for DBDGEN field file. %40%
  • DBDUT0U07U File status %5 issuing create file for DBDGEN. %40%
  • DBDUT0U08U File status %5 issuing create file for DBDGEN field file. %40%
  • DBDUT0U09U File status %5 issuing delete for DBDGEN. %40%
  • DBDUT0U10U File status %5 issuing delete for DBDGEN field file. %40%
  • DBDUT0U11U File status %5 issuing write for DBDGEN file. %40%
  • DBDUT0U12U File status %5 issuing start/read for DBDGEN file. %40%
  • DBDUT0U13U File status %5 issuing read by key for DBDGEN file. %40%
  • DBDUT0U35U File not found %C60
Parent topic: DBD Error Messages


DBDUT0U01U File status %A5 opening file %C60. %B40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U02U File status %A5 issuing close for file %C60. %B40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U03U File status %A5 issuing read for file %C60. %B40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U04U File status %5 issuing set/date for DBDGEN. %40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U05U File status %5 issuing close for DBDGEN file. %40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U06U File status %5 issuing close for DBDGEN field file. %40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U07U File status %5 issuing create file for DBDGEN. %40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U08U File status %5 issuing create file for DBDGEN field file. %40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U09U File status %5 issuing delete for DBDGEN. %40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U10U File status %5 issuing delete for DBDGEN field file. %40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U11U File status %5 issuing write for DBDGEN file. %40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U12U File status %5 issuing start/read for DBDGEN file. %40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U13U File status %5 issuing read by key for DBDGEN file. %40%

Parent topic: Messages DBDUT0U01 to DBDUT0U35


DBDUT0U35U File not found %C60

Parent topic: Messages DBDUT0U01 to DBDUT0U35


Messages DBDUT0W01 to DBDUT0W19

  • DBDUT0W01W Nested COPY statements are not supported by MFIMS: %50%
  • DBDUT0W03W MFIMS statement continuation overflow, extras ignored. Maximum number of lines per statement is %2%
  • DBDUT0W04W SEGM %8, SSPTR not supported by MFIMS, SSPTR ignored
  • DBDUT0W06W Segment %8, field %8 length %5% exceeds MFIMS SSA/FSA limit of %3%, length reduced to %3%
  • DBDUT0W08W XDFLD %8, EXTRNCBL %8 operand no longer required
  • DBDUT0W09W Segment %8, RULES=HERE for logical children is not supported by MFIMS, RULES changed to LAST
    MSS does not support the RULES=HERE clause on a SEGM statement for logical children. The RULES=HERE clause has been changed to RULES=LAST.
  • DBDUT0W10W Segment %8, RULES=HERE on a root segment is not supported by MFIMS, RULES changed to LAST
  • DBDUT0W11W MFIMS IMS86KEY extension specified for segment %8 field %8
  • DBDUT0W13W MFIMS does not support asynchronous data capture, EXIT option for %8 changed from LOG to NOLOG
  • DBDUT0W14W MFIMS does not support asynchronous data capture, EXIT parameter name "*" ignored
  • DBDUT0W15W Variable GSAM RECORD value missing minimum length, MFIMS assuming minimum length 1
  • DBDUT0W16W Unknown statement "%8" ignored, unsupported by MFIMS
  • DBDUT0W17W DBDGEN VERSION truncated to MFIMS maximum 128 bytes
  • DBDUT0W18W Comment line continuation has non-blanks in columns 1-15, MFIMS assumes blank: %15%
  • DBDUT0W19W Duplicate keys for secondary index %8 not supported by MFIMS for DOS/VS ACCESS=HD database, index assumed unique. See Technical Reference "For the DBA" chapter.
Parent topic: DBD Error Messages


DBDUT0W01W Nested COPY statements are not supported by MFIMS: %50%

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W03W MFIMS statement continuation overflow, extras ignored. Maximum number of lines per statement is %2%

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W04W SEGM %8, SSPTR not supported by MFIMS, SSPTR ignored

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W06W Segment %8, field %8 length %5% exceeds MFIMS SSA/FSA limit of %3%, length reduced to %3%

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W08W XDFLD %8, EXTRNCBL %8 operand no longer required

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W09W Segment %8, RULES=HERE for logical children is not supported by MFIMS, RULES changed to LAST

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W10W Segment %8, RULES=HERE on a root segment is not supported by MFIMS, RULES changed to LAST

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W11W MFIMS IMS86KEY extension specified for segment %8 field %8

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W13W MFIMS does not support asynchronous data capture, EXIT option for %8 changed from LOG to NOLOG

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W14W MFIMS does not support asynchronous data capture, EXIT parameter name "*" ignored

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W15W Variable GSAM RECORD value missing minimum length, MFIMS assuming minimum length 1

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W16W Unknown statement "%8" ignored, unsupported by MFIMS

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W17W DBDGEN VERSION truncated to MFIMS maximum 128 bytes

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W18W Comment line continuation has non-blanks in columns 1-15, MFIMS assumes blank: %15%

Parent topic: Messages DBDUT0W01 to DBDUT0W19


DBDUT0W19W Duplicate keys for secondary index %8 not supported by MFIMS for DOS/VS ACCESS=HD database, index assumed unique. See Technical Reference "For the DBA" chapter.

Parent topic: Messages DBDUT0W01 to DBDUT0W19


Messages DBDUT0WA1 to DBDUT0WA9

  • DBDUT0WA1W BLANK line not allowed, MFIMS ignores blank lines
  • DBDUT0WA2W Exceeded MFIMS maximum number of operands, extras ignored
  • DBDUT0WA3W Columns 1-15 non-blank on continuation, MFIMS assumes blank
  • DBDUT0WA4W LABEL exceeds 8 bytes, MFIMS truncated to 8
  • DBDUT0WA5W Statement type must be on 1st line, ignored
  • DBDUT0WA6W %8 and other macro control statements not supported by MFIMS. This and subsequent control statements ignored
  • DBDUT0WA7W Column 16 on continuation was blank, MFIMS ignoring line
  • DBDUT0WA8W Missing comma for continuation, MFIMS assumed present
  • DBDUT0WA9W Invalid value "%8" - MFIMS ignored keyword and value
Parent topic: DBD Error Messages


DBDUT0WA1W BLANK line not allowed, MFIMS ignores blank lines

Parent topic: Messages DBDUT0WA1 to DBDUT0WA9


DBDUT0WA2W Exceeded MFIMS maximum number of operands, extras ignored

Parent topic: Messages DBDUT0WA1 to DBDUT0WA9


DBDUT0WA3W Columns 1-15 non-blank on continuation, MFIMS assumes blank

Parent topic: Messages DBDUT0WA1 to DBDUT0WA9


DBDUT0WA4W LABEL exceeds 8 bytes, MFIMS truncated to 8

Parent topic: Messages DBDUT0WA1 to DBDUT0WA9


DBDUT0WA5W Statement type must be on 1st line, ignored

Parent topic: Messages DBDUT0WA1 to DBDUT0WA9


DBDUT0WA6W %8 and other macro control statements not supported by MFIMS. This and subsequent control statements ignored

Parent topic: Messages DBDUT0WA1 to DBDUT0WA9


DBDUT0WA7W Column 16 on continuation was blank, MFIMS ignoring line

Parent topic: Messages DBDUT0WA1 to DBDUT0WA9


DBDUT0WA8W Missing comma for continuation, MFIMS assumed present

Parent topic: Messages DBDUT0WA1 to DBDUT0WA9


DBDUT0WA9W Invalid value "%8" - MFIMS ignored keyword and value

Parent topic: Messages DBDUT0WA1 to DBDUT0WA9


Messages DBDUT0WE1 to DBDUT0WE2

  • DBDUT0WE1W MFIMS EQU limit of %4 exceeded, extras ignored
  • DBDUT0WE2W EQU %8 contains unbalanced quotes. Maximum MFIMS EQU length is %4
Parent topic: DBD Error Messages


DBDUT0WE1W MFIMS EQU limit of %4 exceeded, extras ignored

Parent topic: Messages DBDUT0WE1 to DBDUT0WE2


DBDUT0WE2W EQU %8 contains unbalanced quotes. Maximum MFIMS EQU length is %4

Parent topic: Messages DBDUT0WE1 to DBDUT0WE2


Messages DBDUT0WF1 to DBDUT0WF2

  • DBDUT0WF1W In-line CSECT or DSECT is not supported by MFIMS. Ignoring all statements until END statement
  • DBDUT0WF2W In-line macro definitions not supported by MFIMS. Ignoring all statements until MEND statement
Parent topic: DBD Error Messages


DBDUT0WF1W In-line CSECT or DSECT is not supported by MFIMS. Ignoring all statements until END statement

Parent topic: Messages DBDUT0WF1 to DBDUT0WF2


DBDUT0WF2W In-line macro definitions not supported by MFIMS. Ignoring all statements until MEND statement

Parent topic: Messages DBDUT0WF1 to DBDUT0WF2


DBDUT0WP2W MFIMS supports a maximum of %2% data capture exit routines per segment, first %2% routines accepted

Parent topic: DBD Error Messages


DBUTIL Error Messages

These messages are output by the IMS DBUTIL utility and have the prefix IMSUT. Some are environment dependent, so your particular environment might not support them all. When you select an error message number, the text and severity of each message is described, the error or problem that causes the message is described, and advice is given on how to prevent it.

  • IMSUT0115I DBUTIL: Processing complete - %6 calls were issued
  • IMSUT0532E DD statement missing for %8
  • IMSUT0533E SYSIN LRECL exceeds DBUTIL maximum of %5%
  • IMSUT0534E Dynamic memory allocation failure. RC=%8% Size=%5%
  • IMSUT0535E Function is required for interactive calls
  • IMSUT0536E PCB Number is required for interactive calls
  • IMSUT0537E Cannot mix control cards with interactive call
  • IMSUT0538E SYSIN dataset not found. DSN=%60
  • IMSUT0539E SYSIN dataset open failure status=%5% DSN=%60
  • IMSUT0540E terminated "LDIX" due to status code of %2%
  • IMSUT0541E SEGM %8 is not in PCB for: %8
  • IMSUT0542E Dataset not found: %60
  • IMSUT0543E DBUTIL terminated %4 due to status code of %2%
  • IMSUT0544E Error status= %5% reading input dataset DSN=%60
  • IMSUT0545E Invalid length in record. Length=%8
  • IMSUT0546E Error opening input dataset. Status code: %5% DSN=%60
  • IMSUT0547E Input file not found. DSN=%60
  • IMSUT0548E "MLOD" can only be issued for MSDBs
  • IMSUT0549E Invalid command syntax. DSN required
  • IMSUT0550E Cannnot load remote database %8
  • IMSUT0551E Cannot "LOAD" "INDEX" database %8
  • IMSUT0552E Cannot "LOAD" database %8 USING "PROCSEQ" PCB
  • IMSUT0553E "USEQ" does not support "REMOTE" database
  • IMSUT0554E "USEQ" does not support "USER CAT" database
  • IMSUT0555E Error status %5% opening output dataset DSN=%60
  • IMSUT0556E LRECL for unload not given and default not available
  • IMSUT0557E "UNLO" of logical DBD requires a non-zero LRECL specification, or variable length RECFM
  • IMSUT0558E "USEQ" does not support variable length
  • IMSUT0559E Invalid command syntax. RC=%4
  • IMSUT0560E Invalid command syntax. DSN required
  • IMSUT0561E Database selected is not a DEDB
  • IMSUT0562E GSAM PCB missing required "RECLEN" parameter
  • IMSUT0563E PCB number %3 not defined in PSB
  • IMSUT0564E GSAM PCB missing required RECLEN parameter
  • IMSUT0565E Cannot issue calls against IO or ALT TP PCBs
  • IMSUT0566E DBD referenced by PCB number not defined
  • IMSUT0567E PCB number not numeric
  • IMSUT0568E PCB number cannot be zero
  • IMSUT0569E DBD name not found in PCB list
  • IMSUT0570E No PCB ID provided
  • IMSUT0571E Continuation error card number %6. Card=%65
  • IMSUT0572E "LOAD" of logical DBD requires a non-zero LRECL specification, or variable length RECFM
  • IMSUT0573E LRECL for load not given and default not available
  • IMSUT0574E This version of DBUTIL does not support %4
  • IMSUT0575E %4 function only available when run as DBB or DLI
  • IMSUT0576E This version of IMSDBU only supports the batch interface
  • IMSUT0577E SYSOUT dataset open failure status=%5% DSN=%60
  • IMSUT0578E Write to SYSOUT dataset failure status=%5%
  • IMSUT0580E Information for PSB %8 not found in configuration file
  • IMSUT0602E Input card dataset is busy. Try later. DSN=%60
Parent topic: IMS Error Messages


IMSUT0115I DBUTIL: Processing complete - %6 calls were issued

Parent topic: DBUTIL Error Messages


IMSUT0532E DD statement missing for %8

Parent topic: DBUTIL Error Messages


IMSUT0533E SYSIN LRECL exceeds DBUTIL maximum of %5%

Parent topic: DBUTIL Error Messages


IMSUT0534E Dynamic memory allocation failure. RC=%8% Size=%5%

Parent topic: DBUTIL Error Messages


IMSUT0535E Function is required for interactive calls

Parent topic: DBUTIL Error Messages


IMSUT0536E PCB Number is required for interactive calls

Parent topic: DBUTIL Error Messages


IMSUT0537E Cannot mix control cards with interactive call

Parent topic: DBUTIL Error Messages


IMSUT0538E SYSIN dataset not found. DSN=%60

Parent topic: DBUTIL Error Messages


IMSUT0539E SYSIN dataset open failure status=%5% DSN=%60

Parent topic: DBUTIL Error Messages


IMSUT0540E terminated "LDIX" due to status code of %2%

Parent topic: DBUTIL Error Messages


IMSUT0541E SEGM %8 is not in PCB for: %8

Parent topic: DBUTIL Error Messages


IMSUT0542E Dataset not found: %60

Parent topic: DBUTIL Error Messages


IMSUT0543E DBUTIL terminated %4 due to status code of %2%

Parent topic: DBUTIL Error Messages


IMSUT0544E Error status= %5% reading input dataset DSN=%60

Parent topic: DBUTIL Error Messages


IMSUT0545E Invalid length in record. Length=%8

Parent topic: DBUTIL Error Messages


IMSUT0546E Error opening input dataset. Status code: %5% DSN=%60

Parent topic: DBUTIL Error Messages


IMSUT0547E Input file not found. DSN=%60

Parent topic: DBUTIL Error Messages


IMSUT0548E "MLOD" can only be issued for MSDBs

Parent topic: DBUTIL Error Messages


IMSUT0549E Invalid command syntax. DSN required

Parent topic: DBUTIL Error Messages


IMSUT0550E Cannnot load remote database %8

Parent topic: DBUTIL Error Messages


IMSUT0551E Cannot "LOAD" "INDEX" database %8

Parent topic: DBUTIL Error Messages


IMSUT0552E Cannot "LOAD" database %8 USING "PROCSEQ" PCB

Parent topic: DBUTIL Error Messages


IMSUT0553E "USEQ" does not support "REMOTE" database

Parent topic: DBUTIL Error Messages


IMSUT0554E "USEQ" does not support "USER CAT" database

Parent topic: DBUTIL Error Messages


IMSUT0555E Error status %5% opening output dataset DSN=%60

Parent topic: DBUTIL Error Messages


IMSUT0556E LRECL for unload not given and default not available

Parent topic: DBUTIL Error Messages


IMSUT0557E "UNLO" of logical DBD requires a non-zero LRECL specification, or variable length RECFM

Parent topic: DBUTIL Error Messages


IMSUT0558E "USEQ" does not support variable length

Parent topic: DBUTIL Error Messages


IMSUT0559E Invalid command syntax. RC=%4

Parent topic: DBUTIL Error Messages


IMSUT0560E Invalid command syntax. DSN required

Parent topic: DBUTIL Error Messages


IMSUT0561E Database selected is not a DEDB

Parent topic: DBUTIL Error Messages


IMSUT0562E GSAM PCB missing required "RECLEN" parameter

Parent topic: DBUTIL Error Messages


IMSUT0563E PCB number %3 not defined in PSB

Parent topic: DBUTIL Error Messages


IMSUT0564E GSAM PCB missing required RECLEN parameter

Parent topic: DBUTIL Error Messages


IMSUT0565E Cannot issue calls against IO or ALT TP PCBs

Parent topic: DBUTIL Error Messages


IMSUT0566E DBD referenced by PCB number not defined

Parent topic: DBUTIL Error Messages


IMSUT0567E PCB number not numeric

Parent topic: DBUTIL Error Messages


IMSUT0568E PCB number cannot be zero

Parent topic: DBUTIL Error Messages


IMSUT0569E DBD name not found in PCB list

Parent topic: DBUTIL Error Messages


IMSUT0570E No PCB ID provided

Parent topic: DBUTIL Error Messages


IMSUT0571E Continuation error card number %6. Card=%65

Parent topic: DBUTIL Error Messages


IMSUT0572E "LOAD" of logical DBD requires a non-zero LRECL specification, or variable length RECFM

Parent topic: DBUTIL Error Messages


IMSUT0573E LRECL for load not given and default not available

Parent topic: DBUTIL Error Messages


IMSUT0574E This version of DBUTIL does not support %4

Parent topic: DBUTIL Error Messages


IMSUT0575E %4 function only available when run as DBB or DLI

Parent topic: DBUTIL Error Messages


IMSUT0576E This version of IMSDBU only supports the batch interface

Parent topic: DBUTIL Error Messages


IMSUT0577E SYSOUT dataset open failure status=%5% DSN=%60

Parent topic: DBUTIL Error Messages


IMSUT0578E Write to SYSOUT dataset failure status=%5%

Parent topic: DBUTIL Error Messages


IMSUT0580E Information for PSB %8 not found in configuration file

Parent topic: DBUTIL Error Messages


IMSUT0602E Input card dataset is busy. Try later. DSN=%60

Parent topic: DBUTIL Error Messages


IMS Database Editor Error Messages

  • Could not open database, IMS logon failed, rc=RC, rc2=RC2
    Your attempt to log on to the IMS component has failed, where:
  • Logoff for database failed, rc=RC, rc2=RC2
    Your attempt to log off from the IMS component has failed, where:
  • Cannot open database, abend 476, invalid PCB address. DBD database may not have been genned
    You have tried to open a database that IMS cannot find, where database is the name of the database.
  • Cannot open database, generate PCB from DBD failed, rc=RC, rc2=RC2
    When you tried to open a database, IMS could not generate a PCB from the DBD, where:
  • Cannot open database, generate PCB from PSB failed, rc=RC, rc2=RC2
    When you tried to open a database, IMS could not generate a PCB from the PSB, where:
  • Cannot open database, failed to read details required to edit DBD database, status: status
    When you attempted to open a database, IMS had problems reading the IMS Option database information, where:
  • Cannot open database, failed to read details required to edit PCB #PCB in PSB database, status: status
    When you attempted to open a database, IMS had problems reading the PSB information, where:
  • Cannot open PCB #PCB in PSB database, the secondary index must be genned before opening
    You have attempted to open a PCB before compiling the secondary index database definition (DBD), where:
  • Failed to load bookmark_file, status: status
    You have attempted to load a bookmark file and encountered a general failure:
  • Failed to load bookmarks, file is not an IMS DB Editor bookmark file
    You have attempted to download bookmarks from a file that is not a bookmark file, where file is the name of your selected file.
  • Failed to save bookmark_file, status: status
    When attempting to save a bookmark file, you encountered a general failure, where:
Parent topic: IMS Error Messages


Could not open database, IMS logon failed, rc=RC, rc2=RC2

database | is the name of the database
RC | is the RC value in the format RCnnnn
RC2 | is the RC2 value in the format RC2nnnn

Resolution:

If RC=0012:

See the IMS System log for more information.

Otherwise:

If the problem persists, report to Technical Support.

Parent topic: IMS Database Editor Error Messages


Logoff for database failed, rc=RC, rc2=RC2

database | is the name of the database
RC | is the RC value in the format RCnnnn
RC2 | is the RC2 value in the format RC2nnnn

Resolution:

If the problem persists, report to Technical Support.

Parent topic: IMS Database Editor Error Messages


Cannot open database, abend 476, invalid PCB address. DBD database may not have been genned

Resolution:

Recompile the database definition (DBD).

Parent topic: IMS Database Editor Error Messages


Cannot open database, generate PCB from DBD failed, rc=RC, rc2=RC2

RC | is the RC value in the format RCnnnn
RC2 | is the RC2 value in the format RC2nnnn

Resolution:

If the problem persists, report to Technical Support.

Parent topic: IMS Database Editor Error Messages


Cannot open database, generate PCB from PSB failed, rc=RC, rc2=RC2

RC | is the RC value in the format RCnnnn
RC2 | is the RC2 value in the format RC2nnnn

If RC=0012 and RC2=2053:

the PSB contains no database PCBs.

Otherwise:

the Schedule PSB (psbname) failed.

Resolution:

If RC=0012 and RC2=2053:

You cannot use this PSB to edit an IMS database.

Otherwise:

If the problem persists, report to Technical Support.

Parent topic: IMS Database Editor Error Messages


Cannot open database, failed to read details required to edit DBD database, status: status

database | is the name of the database
status | is the error returned from GIO

Resolution:

If the problem persists, report to Technical Support.

Parent topic: IMS Database Editor Error Messages


Cannot open database, failed to read details required to edit PCB #PCB in PSB database, status: status

database | is the name of the database
status | is the error returned from GIO

Resolution:

If the problem persists, report to Technical Support.

Parent topic: IMS Database Editor Error Messages


Cannot open PCB #PCB in PSB database, the secondary index must be genned before opening

PCB | is the PCB number
database | is the PSB-name

When using the IMS Database Editor to edit a PCB which specifies a secondary processing sequence (PROCSEQ), you must compile the secondary index database definition (DBD).

You can use a primary processing sequence to edit a database without compiling the secondary index DBD.

Resolution:

To use a secondary processing sequence (PROCSEQ) to edit the database, compile the secondary index database definition (DBD) beforehand. Otherwise, use a primary processing sequence to edit the database.

Parent topic: IMS Database Editor Error Messages


Failed to load bookmark_file, status: status

bookmark_file | is the filename of the bookmark file
status | is the Callable File Handler status code

Resolution:

Check that the bookmark file has not been corrupted.

Parent topic: IMS Database Editor Error Messages


Failed to load bookmarks, file is not an IMS DB Editor bookmark file

Resolution:

Locate the bookmark file you require and try again.

Parent topic: IMS Database Editor Error Messages


Failed to save bookmark_file, status: status

bookmark_file | is the filename you have chosen for the bookmark file
status | is the Callable File Handler status code

Resolution:

Examine the Callable File Handler status code and take appropriate action.

Parent topic: IMS Database Editor Error Messages


IMS Run-time System Error Messages

These messages are output by the IMS run-time system, so can be produced at any time when you are running your IMS application. Some are environment dependent, so your particular environment might not support them all. When you select an error message number, the text and severity of each message is described, the error or problem that causes the message is described, and advice is given on how to prevent it. These messages have the prefix IMSRT.

  • IMSRT0039E ACB failure for %8. %60%
  • IMSRT0040E PSB Authorization failure for %8.
  • IMSRT0041E No ACEE available. Function %4 can't test authorization of %8
  • IMSRT0042E Error initializing MFIMS - IMS terminating. %12% not found or incorrect version
  • IMSRT0043E Error initializing MFIMS - IMS terminating. Error opening/reading IMSCONFG file. File Status: %6 Description: %40%
  • IMSRT0044E Error initializing MFIMS - IMS terminating. Error opening %6 files. File Status: %6 Description: %40%
  • IMSRT0045E Error initializing MFIMS - IMS terminating. Failure reason code: %4
  • IMSRT0052I The following POP-UP was suppressed during shutdown
  • IMSRT0053I The following POP-UP was suppressed by system request
  • IMSRT0054I Suppression resulted in automatic termination
  • IMSRT0055I End of message
  • IMSRT0056I OPTION VALUE MUST BE "C" OR "T"
  • IMSRT0057I OPTION VALUE MUST BE "Y" OR "N"
  • IMSRT0058I OPTION VALUE MUST BE "R" OR "T"
  • IMSRT0059I INVALID KEY PRESSED
  • IMSRT0060I ONLY 4 DIGITS ARE ALLOWED
  • IMSRT0061I LIMIT VALUE NOT NUMERIC
  • IMSRT0062I STATUS CODE MUST BE TWO BYTE VALUE OR BLANK
  • IMSRT0063I OPTION MUST BE "C", "T", OR "S"
  • IMSRT0064I SAVE OPTION ONLY AVAILABLE ON WINDOWS NT
  • IMSRT0065I USERID IS A REQUIRED FIELD
  • IMSRT0066I PASSWORD IS A REQUIRED FIELD
  • IMSRT0068I MFIMS SYSTEM WINDOW ERROR
  • IMSRT0069I CONTACT TECHNICAL SUPPORT
  • IMSRT0070I PRESS ENTER TO TERMINATE
  • IMSRT0080E Error allocating memory for ACB DBD field blocks REF1: %4 REF2: %5
  • IMSRT0081E ACB create/modify failure: Too many DBD fields Total DBD fields required for this PSB exceeds: %6
  • IMSRT0082E ACB create/modify failure: Caching SENSEG/SENFLD SENSEG/SENFLD cache exceeded reserved memory
  • IMSRT0083E Error allocating memory for ACB PCB SENFLD blocks REF1: %4 REF2: %5
  • IMSRT0084E ACB create/modify failure: Too many SENFLD statements More than 10,000 SENFLDs in this PSB
  • IMSRT1012E MFIMS DATABASE SHARING MANAGER A database record is in use by %12%. Database: %8 Root Key: %50%
Parent topic: IMS Error Messages


IMSRT0039E ACB failure for %8. %60%

Parent topic: IMS Run-time System Error Messages


IMSRT0040E PSB Authorization failure for %8.

Parent topic: IMS Run-time System Error Messages


IMSRT0041E No ACEE available. Function %4 can't test authorization of %8

Parent topic: IMS Run-time System Error Messages


IMSRT0042E Error initializing MFIMS - IMS terminating. %12% not found or incorrect version

Parent topic: IMS Run-time System Error Messages


IMSRT0043E Error initializing MFIMS - IMS terminating. Error opening/reading IMSCONFG file. File Status: %6 Description: %40%

Parent topic: IMS Run-time System Error Messages


IMSRT0044E Error initializing MFIMS - IMS terminating. Error opening %6 files. File Status: %6 Description: %40%

Parent topic: IMS Run-time System Error Messages


IMSRT0045E Error initializing MFIMS - IMS terminating. Failure reason code: %4

Parent topic: IMS Run-time System Error Messages


IMSRT0052I The following POP-UP was suppressed during shutdown

Parent topic: IMS Run-time System Error Messages


IMSRT0053I The following POP-UP was suppressed by system request

Parent topic: IMS Run-time System Error Messages


IMSRT0054I Suppression resulted in automatic termination

Parent topic: IMS Run-time System Error Messages


IMSRT0055I End of message

Parent topic: IMS Run-time System Error Messages


IMSRT0056I OPTION VALUE MUST BE "C" OR "T"

Parent topic: IMS Run-time System Error Messages


IMSRT0057I OPTION VALUE MUST BE "Y" OR "N"

Parent topic: IMS Run-time System Error Messages


IMSRT0058I OPTION VALUE MUST BE "R" OR "T"

Parent topic: IMS Run-time System Error Messages


IMSRT0059I INVALID KEY PRESSED

Parent topic: IMS Run-time System Error Messages


IMSRT0060I ONLY 4 DIGITS ARE ALLOWED

Parent topic: IMS Run-time System Error Messages


IMSRT0061I LIMIT VALUE NOT NUMERIC

Parent topic: IMS Run-time System Error Messages


IMSRT0062I STATUS CODE MUST BE TWO BYTE VALUE OR BLANK

Parent topic: IMS Run-time System Error Messages


IMSRT0063I OPTION MUST BE "C", "T", OR "S"

Parent topic: IMS Run-time System Error Messages


IMSRT0064I SAVE OPTION ONLY AVAILABLE ON WINDOWS NT

Parent topic: IMS Run-time System Error Messages


IMSRT0065I USERID IS A REQUIRED FIELD

Parent topic: IMS Run-time System Error Messages


IMSRT0066I PASSWORD IS A REQUIRED FIELD

Parent topic: IMS Run-time System Error Messages


IMSRT0068I MFIMS SYSTEM WINDOW ERROR

Parent topic: IMS Run-time System Error Messages


IMSRT0069I CONTACT TECHNICAL SUPPORT

Parent topic: IMS Run-time System Error Messages


IMSRT0070I PRESS ENTER TO TERMINATE

Parent topic: IMS Run-time System Error Messages


IMSRT0080E Error allocating memory for ACB DBD field blocks REF1: %4 REF2: %5

Parent topic: IMS Run-time System Error Messages


IMSRT0081E ACB create/modify failure: Too many DBD fields Total DBD fields required for this PSB exceeds: %6

Parent topic: IMS Run-time System Error Messages


IMSRT0082E ACB create/modify failure: Caching SENSEG/SENFLD SENSEG/SENFLD cache exceeded reserved memory

Parent topic: IMS Run-time System Error Messages


IMSRT0083E Error allocating memory for ACB PCB SENFLD blocks REF1: %4 REF2: %5

Parent topic: IMS Run-time System Error Messages


IMSRT0084E ACB create/modify failure: Too many SENFLD statements More than 10,000 SENFLDs in this PSB

Parent topic: IMS Run-time System Error Messages


IMSRT1012E MFIMS DATABASE SHARING MANAGER A database record is in use by %12%. Database: %8 Root Key: %50%

Parent topic: IMS Run-time System Error Messages


MFS Error Messages

  • Messages MFSUT0401 to MFSUT0431
  • Messages MFSUT04A1 to MFSUT04A6
  • Messages MFSUT04E1 to MFSUT04E2
  • Messages MFSUT0801 to MFSUT0845
  • Messages MFSUT08A1 to MFSUT08A3
  • Messages MFSUT08P1 to MFSUT08P2
  • Messages MFSUT0L01 to MFSUT0L24
  • Messages MFSUT0L91 to MFSUT0L99
  • Messages MFSUT0LA1 to MFSUT0LA2
  • Messages MFSUT0LP1 to MFSUT0LP3
  • Messages MFSUT0U01 to MFSUT0U35
  • Messages MFSUT0W01 to MFSUT0W20
  • Messages MFSUT0WA1 to MFSUT0WA9
  • Messages MFSUT0WE1 to MFSUT0WE2
  • Messages MFSUT0WF1 to MFSUT0WF2
  • Messages MFSUT0WP1 to MFSUT0WP3
Parent topic: IMS Error Messages


Messages MFSUT0401 to MFSUT0431

  • MFSUT0401W MSG %8 has invalid OPT=%1, defaulting to OPT=1
  • MFSUT0402W Cannot specify FILL on input MSG, FILL ignored
  • MFSUT0403W Cannot specify PAGE on input MSG, PAGE ignored
  • MFSUT0405W MFLD LTH operand missing, defaulting to LTH=0001. MFLD: %50%
  • MFSUT0406W EXIT ignored, only input MFLDs can use field exits. MFLD: %50%
  • MFSUT0407W MFLD literals cannot specify ATTR=YES, ATTR=NO assumed. MFLD literal: %45%
  • MFSUT0408W EXIT ignored, MFLD literals cannot use field exits. MFLD literal: %45%
  • MFSUT0409W ATTR=YES only valid when MFLD names DFLD, ATTR=NO assumed
  • MFSUT0410W MSG(%8), SEG GRAPHIC not YES or NO, assumed YES
  • MFSUT0411W MSG(%8), EXIT ignored, only input messages can use segment exits
  • MFSUT0412W MOD LPAGE's COND operand missing, assuming last LPAGE of set
  • MFSUT0413W MSG(%8), MSGEND statement missing, assumed present
  • MFSUT0414W No STACK is on to issue STACK OFF
  • MFSUT0415W MFLD's DFLD name in DO truncated to 6 characters
  • MFSUT0416W Initial cursor position defaulting to row 1, column 2
  • MFSUT0417W LABEL ignored, labeled DFLDs should not have PASSWORD
  • MFSUT0418W DFLD label in DO truncated to 6 characters
  • MFSUT0419W Recommended END statement missing, assumed present
  • MFSUT0420W ENDDO statement missing, assumed present
  • MFSUT0421W FMTEND statement missing, assumed present
  • MFSUT0422W MFLD JUST operand invalid with system literal %8. JUST operand ignored for MFLD %19
  • MFSUT0423W MFLD ATTR operand invalid with system literal %8. ATTR operand ignored for MFLD %19
  • MFSUT0424W MFLD LTH operand invalid with system literal %8. LTH operand ignored for MFLD %19
  • MFSUT0425W OPCTL operand ignored, not valid with literal DFLDs
  • MFSUT0426W MOD(%8), LPAGE(%3%) contains no MFLDs, this MOD/LPAGE bypassed
  • MFSUT0427W MOD(%8), MID(%8), DPAGE(%8), could not find MID for MOD/LPAGE selected or MID contains no MFLDs or all MIDs specified LPAGE and no SOR stated this DPAGE
  • MFSUT0428W FMT name %8 greater than 6 characters, truncated to 6 possibly causing duplicates
  • MFSUT0429W EGCS "G" literal missing an SO or SI character. Literal assumed to contain valid SO/SI pair. Card: %50%
  • MFSUT0430W EGCS "G" literal contains odd number of bytes, literal accepted as specified. Card: %50%
  • MFSUT0431W Invalid DFLD ATTR value "%8" ignored
Parent topic: MFS Error Messages


MFSUT0401W MSG %8 has invalid OPT=%1, defaulting to OPT=1

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0402W Cannot specify FILL on input MSG, FILL ignored

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0403W Cannot specify PAGE on input MSG, PAGE ignored

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0405W MFLD LTH operand missing, defaulting to LTH=0001. MFLD: %50%

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0406W EXIT ignored, only input MFLDs can use field exits. MFLD: %50%

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0407W MFLD literals cannot specify ATTR=YES, ATTR=NO assumed. MFLD literal: %45%

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0408W EXIT ignored, MFLD literals cannot use field exits. MFLD literal: %45%

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0409W ATTR=YES only valid when MFLD names DFLD, ATTR=NO assumed

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0410W MSG(%8), SEG GRAPHIC not YES or NO, assumed YES

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0411W MSG(%8), EXIT ignored, only input messages can use segment exits

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0412W MOD LPAGE's COND operand missing, assuming last LPAGE of set

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0413W MSG(%8), MSGEND statement missing, assumed present

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0414W No STACK is on to issue STACK OFF

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0415W MFLD's DFLD name in DO truncated to 6 characters

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0416W Initial cursor position defaulting to row 1, column 2

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0417W LABEL ignored, labeled DFLDs should not have PASSWORD

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0418W DFLD label in DO truncated to 6 characters

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0419W Recommended END statement missing, assumed present

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0420W ENDDO statement missing, assumed present

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0421W FMTEND statement missing, assumed present

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0422W MFLD JUST operand invalid with system literal %8. JUST operand ignored for MFLD %19

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0423W MFLD ATTR operand invalid with system literal %8. ATTR operand ignored for MFLD %19

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0424W MFLD LTH operand invalid with system literal %8. LTH operand ignored for MFLD %19

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0425W OPCTL operand ignored, not valid with literal DFLDs

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0426W MOD(%8), LPAGE(%3%) contains no MFLDs, this MOD/LPAGE bypassed

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0427W MOD(%8), MID(%8), DPAGE(%8), could not find MID for MOD/LPAGE selected or MID contains no MFLDs or all MIDs specified LPAGE and no SOR stated this DPAGE

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0428W FMT name %8 greater than 6 characters, truncated to 6 possibly causing duplicates

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0429W EGCS "G" literal missing an SO or SI character. Literal assumed to contain valid SO/SI pair. Card: %50%

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0430W EGCS "G" literal contains odd number of bytes, literal accepted as specified. Card: %50%

Parent topic: Messages MFSUT0401 to MFSUT0431


MFSUT0431W Invalid DFLD ATTR value "%8" ignored

Parent topic: Messages MFSUT0401 to MFSUT0431


Messages MFSUT04A1 to MFSUT04A6

  • MFSUT04A1W Continuation cannot start in column 1
  • MFSUT04A2W Expected "=", found "(", "=" is assumed
  • MFSUT04A3W Continuation expected, none received
  • MFSUT04A4W Invalid character following final quote "%1"
  • MFSUT04A5W %8 has a non-numeric value "%8", assumed zero
  • MFSUT04A6W Duplicate keyword %8 specified, last one used
Parent topic: MFS Error Messages


MFSUT04A1W Continuation cannot start in column 1

Parent topic: Messages MFSUT04A1 to MFSUT04A6


MFSUT04A2W Expected "=", found "(", "=" is assumed

Parent topic: Messages MFSUT04A1 to MFSUT04A6


MFSUT04A3W Continuation expected, none received

Parent topic: Messages MFSUT04A1 to MFSUT04A6


MFSUT04A4W Invalid character following final quote "%1"

Parent topic: Messages MFSUT04A1 to MFSUT04A6


MFSUT04A5W %8 has a non-numeric value "%8", assumed zero

Parent topic: Messages MFSUT04A1 to MFSUT04A6


MFSUT04A6W Duplicate keyword %8 specified, last one used

Parent topic: Messages MFSUT04A1 to MFSUT04A6


Messages MFSUT04E1 to MFSUT04E2

  • MFSUT04E1W EQU %8 error, keyword already has data
  • MFSUT04E2W EQU %8 error, data already has a keyword
Parent topic: MFS Error Messages


MFSUT04E1W EQU %8 error, keyword already has data

Parent topic: Messages MFSUT04E1 to MFSUT04E2


MFSUT04E2W EQU %8 error, data already has a keyword

Parent topic: Messages MFSUT04E1 to MFSUT04E2


Messages MFSUT0801 to MFSUT0845

  • MFSUT0801E MSG(%8) has TYPE=%6, must be INPUT or OUTPUT
  • MFSUT0802E MSG(%8) missing required SOR operand
  • MFSUT0803E MFLD indicates no DFLD, literal or LTH
  • MFSUT0804E MFLD JUST must be R or L
  • MFSUT0805E MFLD EXIT number %5% exceeds maximum value of 127. MFLD: %50%
  • MFSUT0806E MFLD EXIT vector %5% exceeds maximum value of 255. MFLD: %50%
  • MFSUT0807E MSG(%8), SEG EXIT number %5% exceeds maximum of 127
  • MFSUT0808E MSG(%8), SEG EXIT vector %5% exceeds maximum of 255
  • MFSUT0809E MSG(%8), LPAGE missing required SOR operand
  • MFSUT0810E MSG(%8), COND operand has %3% parameters, requires 3
  • MFSUT0811E MSG(%8), LPAGE COND operand missing, only last LPAGE in MOD may omit COND
  • MFSUT0812E LPAGE COND label %8 not an MFLD label in MOD %8
  • MFSUT0813E DO COUNT is not numeric
  • MFSUT0814E DO/ENDDO pair mismatch
  • MFSUT0815E First STACK parameter must be blank, ON, or OFF
  • MFSUT0816E Cannot start STACK before ending previous STACK
  • MFSUT0817E UNSTACK cannot appear within a STACK
  • MFSUT0818E UNSTACK requested unknown stack name %8
  • MFSUT0819E COPY statement missing required NAME parameter
  • MFSUT0820E COPY member %8 not found
  • MFSUT0821E DPAGE CURSOR column specification "%8" not numeric. Valid forms are CURSOR=name or CURSOR=(rrr,ccc,name)
  • MFSUT0822E DFLD %8 not preceded by DEV statement
  • MFSUT0823E DFLD literals cannot have a label starting in column 1
  • MFSUT0824E DFLD literals must be bound by single quotes
  • MFSUT0825E DFLD requires non-zero POS row and column
  • MFSUT0826E 3270 DFLD cannot start in row 1, column 1
  • MFSUT0827E DFLD %8, POS column value %3% exceeds DEV width value %4%
  • MFSUT0828E DFLD %8, POS column value %4% exceeds 3270 model 1 maximum value of 40
  • MFSUT0829E DFLD %8, POS column value %4% exceeds 3270 models 2,3,4 maximum value of 80
  • MFSUT0830E DFLD %8, POS column value %4% exceeds 3270 model 5 maximum value of 132
  • MFSUT0831E DFLD requires a literal, PASSWORD, or LTH
  • MFSUT0832E Duplicate DFLD label %8. Labels must be unique within DPAGE and physical page
  • MFSUT0833E FMT %6 contains no DFLDs. Verify that STACK and MODEL directives are properly set, or correct the format
  • MFSUT0834E Attribute for DFLD at row %2, col %3% overlaps prior field
  • MFSUT0835E DFLD at row %2, col %3% overlaps prior field
  • MFSUT0836E FMT %6, DPAGE %8, PPAGE %4 contains no DFLDs
  • MFSUT0837E DFLD %8 row value %4% exceeds 3270 model %1% maximum value of %2%
  • MFSUT0838E LPAGE COND relational operator "%2" invalid
  • MFSUT0839E DFLD %8 not preceded by DEV statement
  • MFSUT0840E MOD %8, FMT %8, DPAGE %8, could not find FMT or DPAGE for MOD/LPAGE selected or FMT or DPAGE contains no DFLD statements
  • MFSUT0841E MFLD LTH %5% is not larger than attribute bytes %5%. MFLD: %50%
  • MFSUT0842E DFLD PASSWORD cannot have a label starting in column 1
  • MFSUT0843E Required label missing for MSG statement
  • MFSUT0844E MFLD ATTR value "%14" not YES, NO, or number of extended attributes
  • MFSUT0845E DFLD ATTR value "%14" not YES, NO, or number of extended attributes
Parent topic: MFS Error Messages


MFSUT0801E MSG(%8) has TYPE=%6, must be INPUT or OUTPUT

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0802E MSG(%8) missing required SOR operand

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0803E MFLD indicates no DFLD, literal or LTH

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0804E MFLD JUST must be R or L

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0805E MFLD EXIT number %5% exceeds maximum value of 127. MFLD: %50%

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0806E MFLD EXIT vector %5% exceeds maximum value of 255. MFLD: %50%

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0807E MSG(%8), SEG EXIT number %5% exceeds maximum of 127

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0808E MSG(%8), SEG EXIT vector %5% exceeds maximum of 255

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0809E MSG(%8), LPAGE missing required SOR operand

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0810E MSG(%8), COND operand has %3% parameters, requires 3

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0811E MSG(%8), LPAGE COND operand missing, only last LPAGE in MOD may omit COND

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0812E LPAGE COND label %8 not an MFLD label in MOD %8

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0813E DO COUNT is not numeric

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0814E DO/ENDDO pair mismatch

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0815E First STACK parameter must be blank, ON, or OFF

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0816E Cannot start STACK before ending previous STACK

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0817E UNSTACK cannot appear within a STACK

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0818E UNSTACK requested unknown stack name %8

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0819E COPY statement missing required NAME parameter

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0820E COPY member %8 not found

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0821E DPAGE CURSOR column specification "%8" not numeric. Valid forms are CURSOR=name or CURSOR=(rrr,ccc,name)

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0822E DFLD %8 not preceded by DEV statement

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0823E DFLD literals cannot have a label starting in column 1

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0824E DFLD literals must be bound by single quotes

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0825E DFLD requires non-zero POS row and column

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0826E 3270 DFLD cannot start in row 1, column 1

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0827E DFLD %8, POS column value %3% exceeds DEV width value %4%

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0828E DFLD %8, POS column value %4% exceeds 3270 model 1 maximum value of 40

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0829E DFLD %8, POS column value %4% exceeds 3270 models 2,3,4 maximum value of 80

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0830E DFLD %8, POS column value %4% exceeds 3270 model 5 maximum value of 132

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0831E DFLD requires a literal, PASSWORD, or LTH

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0832E Duplicate DFLD label %8. Labels must be unique within DPAGE and physical page

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0833E FMT %6 contains no DFLDs. Verify that STACK and MODEL directives are properly set, or correct the format

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0834E Attribute for DFLD at row %2, col %3% overlaps prior field

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0835E DFLD at row %2, col %3% overlaps prior field

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0836E FMT %6, DPAGE %8, PPAGE %4 contains no DFLDs

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0837E DFLD %8 row value %4% exceeds 3270 model %1% maximum value of %2%

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0838E LPAGE COND relational operator "%2" invalid

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0839E DFLD %8 not preceded by DEV statement

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0840E MOD %8, FMT %8, DPAGE %8, could not find FMT or DPAGE for MOD/LPAGE selected or FMT or DPAGE contains no DFLD statements

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0841E MFLD LTH %5% is not larger than attribute bytes %5%. MFLD: %50%

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0842E DFLD PASSWORD cannot have a label starting in column 1

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0843E Required label missing for MSG statement

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0844E MFLD ATTR value "%14" not YES, NO, or number of extended attributes

Parent topic: Messages MFSUT0801 to MFSUT0845


MFSUT0845E DFLD ATTR value "%14" not YES, NO, or number of extended attributes

Parent topic: Messages MFSUT0801 to MFSUT0845


Messages MFSUT08A1 to MFSUT08A3

  • MFSUT08A1E Unmatched parentheses
  • MFSUT08A2E Unmatched quotes
  • MFSUT08A3E Positional operand cannot follow keyword operand: %60%
Parent topic: MFS Error Messages


MFSUT08A1E Unmatched parentheses

Parent topic: Messages MFSUT08A1 to MFSUT08A3


MFSUT08A2E Unmatched quotes

Parent topic: Messages MFSUT08A1 to MFSUT08A3


MFSUT08A3E Positional operand cannot follow keyword operand: %60%

Parent topic: Messages MFSUT08A1 to MFSUT08A3


Messages MFSUT08P1 to MFSUT08P2

  • MFSUT08P1E Number of list operands exceeds MFIMS maximum of %3%
  • MFSUT08P2E Macro %8, keyword %8 has unmatched parentheses
Parent topic: MFS Error Messages


MFSUT08P1E Number of list operands exceeds MFIMS maximum of %3%

Parent topic: Messages MFSUT08P1 to MFSUT08P2


MFSUT08P2E Macro %8, keyword %8 has unmatched parentheses

Parent topic: Messages MFSUT08P1 to MFSUT08P2


Messages MFSUT0L01 to MFSUT0L24

  • MFSUT0L01E Exceeded MFIMS limit of %4% MFLD statements which name a DFLD in any one MSG/LPAGE
  • MFSUT0L02E Maximum MFIMS MFLD LTH is 4095 bytes
  • MFSUT0L04E Maximum number of extended ATTR bytes in MFIMS is 10. MFLD: %50%
  • MFSUT0L05E Exceeded maximum MFIMS MFLD literal length of 94, including outermost quotes and imbedded single quotes
  • MFSUT0L07E Maximum MFIMS DFLD LTH is 4095 bytes
  • MFSUT0L08E Exceeded MFIMS limit of %4% labeled DFLD statements per DPAGE
  • MFSUT0L09E MFIMS maximum DFLD literal length is %3% bytes
  • MFSUT0L10E MFS preprocessor requested MFSGEN termination due to:
  • MFSUT0L11E MFS preprocessor error, invalid return code: %5%
  • MFSUT0L12E MFS preprocessor not found. Preprocessor: %60%
  • MFSUT0L13E MFIMS limit of %3% physical pages per device page exceeded
  • MFSUT0L14E LPAGE COND literal value length %3% exceeds MFIMS limit of 42 bytes. Literal: %40%
  • MFSUT0L15E No FMT statements found in source input, MFIMS requires MID, MOD and FMT to be in same source input
  • MFSUT0L16E PF key length %4% exceeds MFIMS maximum of %3%
  • MFSUT0L17E The resultant control block for this format is %6% bytes and exceeds the MFIMS limit of %5%
  • MFSUT0L18E Exceeded MFIMS DFLD literal pool limit of %5%
  • MFSUT0L19E Exceeded MFIMS MOD literal pool limit of %5%
  • MFSUT0L20E Exceeded MFIMS MID default literal pool limit of %5%
  • MFSUT0L21E Exceeded MFIMS MID static literal pool limit of %5%
  • MFSUT0L22E Exceeded MFIMS limit of %3% SEG statements per MSG
  • MFSUT0L23E Exceeded MFIMS MFLD temporary table limit of %5% and possibly exceeded MFIMS limit of 500 MFLDs per SEG
  • MFSUT0L24E Exceeded MFIMS printer DPAGE literal pool limit of %5%
Parent topic: MFS Error Messages


MFSUT0L01E Exceeded MFIMS limit of %4% MFLD statements which name a DFLD in any one MSG/LPAGE

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L02E Maximum MFIMS MFLD LTH is 4095 bytes

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L04E Maximum number of extended ATTR bytes in MFIMS is 10. MFLD: %50%

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L05E Exceeded maximum MFIMS MFLD literal length of 94, including outermost quotes and imbedded single quotes

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L07E Maximum MFIMS DFLD LTH is 4095 bytes

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L08E Exceeded MFIMS limit of %4% labeled DFLD statements per DPAGE

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L09E MFIMS maximum DFLD literal length is %3% bytes

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L10E MFS preprocessor requested MFSGEN termination due to:

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L11E MFS preprocessor error, invalid return code: %5%

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L12E MFS preprocessor not found. Preprocessor: %60%

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L13E MFIMS limit of %3% physical pages per device page exceeded

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L14E LPAGE COND literal value length %3% exceeds MFIMS limit of 42 bytes. Literal: %40%

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L15E No FMT statements found in source input, MFIMS requires MID, MOD and FMT to be in same source input

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L16E PF key length %4% exceeds MFIMS maximum of %3%

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L17E The resultant control block for this format is %6% bytes and exceeds the MFIMS limit of %5%

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L18E Exceeded MFIMS DFLD literal pool limit of %5%

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L19E Exceeded MFIMS MOD literal pool limit of %5%

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L20E Exceeded MFIMS MID default literal pool limit of %5%

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L21E Exceeded MFIMS MID static literal pool limit of %5%

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L22E Exceeded MFIMS limit of %3% SEG statements per MSG

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L23E Exceeded MFIMS MFLD temporary table limit of %5% and possibly exceeded MFIMS limit of 500 MFLDs per SEG

Parent topic: Messages MFSUT0L01 to MFSUT0L24


MFSUT0L24E Exceeded MFIMS printer DPAGE literal pool limit of %5%

Parent topic: Messages MFSUT0L01 to MFSUT0L24


Messages MFSUT0L91 to MFSUT0L99

  • MFSUT0L91E %5% DFLD records exceeds MFIMS maximum of %4% allowed
  • MFSUT0L92E %5% MID records exceeds MFIMS maximum of %4% allowed
  • MFSUT0L93E %5% MOD records exceeds MFIMS maximum of %4% allowed
  • MFSUT0L99E Valid software license not present. Reason code (%4%)
Parent topic: MFS Error Messages


MFSUT0L91E %5% DFLD records exceeds MFIMS maximum of %4% allowed

Parent topic: Messages MFSUT0L91 to MFSUT0L99


MFSUT0L92E %5% MID records exceeds MFIMS maximum of %4% allowed

Parent topic: Messages MFSUT0L91 to MFSUT0L99


MFSUT0L93E %5% MOD records exceeds MFIMS maximum of %4% allowed

Parent topic: Messages MFSUT0L91 to MFSUT0L99


MFSUT0L99E Valid software license not present. Reason code (%4%)

Parent topic: Messages MFSUT0L91 to MFSUT0L99


Messages MFSUT0LA1 to MFSUT0LA2

  • MFSUT0LA1E Positional operand cannot follow keyword operand: %60% MFIMS does not perform MFSGEN syntax error recovery
  • MFSUT0LA2E Length of operand exceeds MFIMS maximum of %4 bytes
Parent topic: MFS Error Messages


MFSUT0LA1E Positional operand cannot follow keyword operand: %60% MFIMS does not perform MFSGEN syntax error recovery

Parent topic: Messages MFSUT0LA1 to MFSUT0LA2


MFSUT0LA2E Length of operand exceeds MFIMS maximum of %4 bytes

Parent topic: Messages MFSUT0LA1 to MFSUT0LA2


Messages MFSUT0LP1 to MFSUT0LP3

  • MFSUT0LP1E Length of operand exceeds MFIMS size of %4% bytes
  • MFSUT0LP2E Number of list operands exceeds MFIMS maximum of %3%
  • MFSUT0LP3E Length of list exceeds MFIMS maximum of %4% bytes
Parent topic: MFS Error Messages


MFSUT0LP1E Length of operand exceeds MFIMS size of %4% bytes

Parent topic: Messages MFSUT0LP1 to MFSUT0LP3


MFSUT0LP2E Number of list operands exceeds MFIMS maximum of %3%

Parent topic: Messages MFSUT0LP1 to MFSUT0LP3


MFSUT0LP3E Length of list exceeds MFIMS maximum of %4% bytes

Parent topic: Messages MFSUT0LP1 to MFSUT0LP3


Messages MFSUT0U01 to MFSUT0U35

  • MFSUT0U01U File status %A5 opening file %C60. %B40%
  • MFSUT0U02U File status %A5 issuing close for file %C60. %B40%
  • MFSUT0U04U File status %5 issuing set/date for MFSPEF file. %40%
  • MFSUT0U05U File status %5 reading MFSGEN LPAGE control record. %40%
  • MFSUT0U06U File status %5 updating MFSGEN LPAGE control record. %40%
  • MFSUT0U07U File status %A5 writing %C8 to IMSVSFMT file. %B40%
  • MFSUT0U08U File status %5 writing MOD LPAGE to MFSPEF file. %40%
  • MFSUT0U09U File status %5 issuing delete for MFSPEF file. %40%
  • MFSUT0U10U File status %5 chaining LPAGE for MOD in MFSPEF file. %40%
  • MFSUT0U11U File status %5 issuing write for MFSPEF file. %40%
  • MFSUT0U12U File status %5 repositioning MOD LPAGE in MFSPEF file. %40%
  • MFSUT0U13U File status %5 writing MOD PPAGE to MFSPEF file. %40%
  • MFSUT0U14U File status %A5 issuing write for file %C60 %B40%
  • MFSUT0U15U File status %A5 issuing delete for file %C60 %B40%
  • MFSUT0U16U File status %5 reading MFSGEN PPAGE control record. %40%
  • MFSUT0U17U File status %5 updating MFSGEN PPAGE control record. %40%
  • MFSUT0U18U File status %5 chaining PPAGE for MOD in MFSPEF file. %40%
  • MFSUT0U19U File status %5 repositioning MOD PPAGE in MFSPEF file. %40%
  • MFSUT0U20U File status %A5 issuing create for file %C60 %40%
  • MFSUT0U35U File not found %C60
Parent topic: MFS Error Messages


MFSUT0U01U File status %A5 opening file %C60. %B40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U02U File status %A5 issuing close for file %C60. %B40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U04U File status %5 issuing set/date for MFSPEF file. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U05U File status %5 reading MFSGEN LPAGE control record. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U06U File status %5 updating MFSGEN LPAGE control record. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U07U File status %A5 writing %C8 to IMSVSFMT file. %B40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U08U File status %5 writing MOD LPAGE to MFSPEF file. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U09U File status %5 issuing delete for MFSPEF file. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U10U File status %5 chaining LPAGE for MOD in MFSPEF file. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U11U File status %5 issuing write for MFSPEF file. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U12U File status %5 repositioning MOD LPAGE in MFSPEF file. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U13U File status %5 writing MOD PPAGE to MFSPEF file. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U14U File status %A5 issuing write for file %C60 %B40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U15U File status %A5 issuing delete for file %C60 %B40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U16U File status %5 reading MFSGEN PPAGE control record. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U17U File status %5 updating MFSGEN PPAGE control record. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U18U File status %5 chaining PPAGE for MOD in MFSPEF file. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U19U File status %5 repositioning MOD PPAGE in MFSPEF file. %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U20U File status %A5 issuing create for file %C60 %40%

Parent topic: Messages MFSUT0U01 to MFSUT0U35


MFSUT0U35U File not found %C60

Parent topic: Messages MFSUT0U01 to MFSUT0U35


Messages MFSUT0W01 to MFSUT0W20

  • MFSUT0W01W MFLD LTHs of form LTH=(pp,nn) are not supported by MFIMS. The starting position is assumed to be 1 (pp=1). MFLD: %50%
  • MFSUT0W03W STACK processing disabled by use of STACKOFF directive
  • MFSUT0W04W STACK processing disabled by use of STACKAUTO directive. STACK follows DEV, assumed to be for multi-devices
  • MFSUT0W05W Exceeded maximum of %4% STACK statements suppressed by STACKAUTO directive. All subsequent UNSTACKs ignored
  • MFSUT0W06W UNSTACK suppressed by STACKAUTO directive
  • MFSUT0W07W Only two levels of nested copy statements are supported by MFIMS. Further nested COPYs ignored. Card: %50%
  • MFSUT0W08W Removing MFLD for PASSWORD, not supported by MFIMS
  • MFSUT0W09W Only ALPHA statements which contain the lower case characters a through z are supported by MFIMS
  • MFSUT0W10W DEV macro TYPE operand missing, only 3270 devices supported by MFIMS
  • MFSUT0W11W MFIMS statement continuation overflow, extras ignored. Maximum number of lines per statement is %2%
  • MFSUT0W12W %8 macro or statement not supported by MFIMS, ignored
  • MFSUT0W13W MFLD %8, FILL=NULL changed to FILL=C' '. MFIMS only supports NULL for PF key field with physical paging
  • MFSUT0W14W MID, MFLD %8 not defined in DFLDs so will always contain default literal or FILL value
  • MFSUT0W15W MID, MFLD %8 not defined in DFLDs so will always be compressed from MID due to FILL=NULL
  • MFSUT0W16W MOD, MFLD %8 not defined in DFLDs or listed more than once in MOD. Processed as MFLD LTH=%4%
  • MFSUT0W17W DFLD PASSWORD not supported by MFIMS, ignored
  • MFSUT0W19W Unknown statement "%8" ignored, unsupported by MFIMS
  • MFSUT0W20W Unknown keyword "%8" for "%8" ignored, unsupported by MFIMS
Parent topic: MFS Error Messages


MFSUT0W01W MFLD LTHs of form LTH=(pp,nn) are not supported by MFIMS. The starting position is assumed to be 1 (pp=1). MFLD: %50%

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W03W STACK processing disabled by use of STACKOFF directive

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W04W STACK processing disabled by use of STACKAUTO directive. STACK follows DEV, assumed to be for multi-devices

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W05W Exceeded maximum of %4% STACK statements suppressed by STACKAUTO directive. All subsequent UNSTACKs ignored

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W06W UNSTACK suppressed by STACKAUTO directive

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W07W Only two levels of nested copy statements are supported by MFIMS. Further nested COPYs ignored. Card: %50%

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W08W Removing MFLD for PASSWORD, not supported by MFIMS

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W09W Only ALPHA statements which contain the lower case characters a through z are supported by MFIMS

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W10W DEV macro TYPE operand missing, only 3270 devices supported by MFIMS

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W11W MFIMS statement continuation overflow, extras ignored. Maximum number of lines per statement is %2%

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W12W %8 macro or statement not supported by MFIMS, ignored

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W13W MFLD %8, FILL=NULL changed to FILL=C' '. MFIMS only supports NULL for PF key field with physical paging

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W14W MID, MFLD %8 not defined in DFLDs so will always contain default literal or FILL value

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W15W MID, MFLD %8 not defined in DFLDs so will always be compressed from MID due to FILL=NULL

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W16W MOD, MFLD %8 not defined in DFLDs or listed more than once in MOD. Processed as MFLD LTH=%4%

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W17W DFLD PASSWORD not supported by MFIMS, ignored

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W19W Unknown statement "%8" ignored, unsupported by MFIMS

Parent topic: Messages MFSUT0W01 to MFSUT0W20


MFSUT0W20W Unknown keyword "%8" for "%8" ignored, unsupported by MFIMS

Parent topic: Messages MFSUT0W01 to MFSUT0W20


Messages MFSUT0WA1 to MFSUT0WA9

  • MFSUT0WA1W BLANK line not allowed, MFIMS ignores blank lines
  • MFSUT0WA2W Exceeded MFIMS maximum number of operands, extras ignored
  • MFSUT0WA3W Columns 1-15 non-blank on continuation, MFIMS assumes blank
  • MFSUT0WA4W LABEL exceeds 8 bytes, MFIMS truncated to 8
  • MFSUT0WA5W Statement type must be on 1st line, ignored
  • MFSUT0WA6W %8 and other macro control statements not supported by MFIMS. This and subsequent control statements ignored
  • MFSUT0WA7W Column 16 on continuation was blank, MFIMS ignoring line
  • MFSUT0WA8W Missing comma for continuation, MFIMS assumed present
  • MFSUT0WA9W Invalid value "%8" - MFIMS ignored keyword and value
Parent topic: MFS Error Messages


MFSUT0WA1W BLANK line not allowed, MFIMS ignores blank lines

Parent topic: Messages MFSUT0WA1 to MFSUT0WA9


MFSUT0WA2W Exceeded MFIMS maximum number of operands, extras ignored

Parent topic: Messages MFSUT0WA1 to MFSUT0WA9


MFSUT0WA3W Columns 1-15 non-blank on continuation, MFIMS assumes blank

Parent topic: Messages MFSUT0WA1 to MFSUT0WA9


MFSUT0WA4W LABEL exceeds 8 bytes, MFIMS truncated to 8

Parent topic: Messages MFSUT0WA1 to MFSUT0WA9


MFSUT0WA5W Statement type must be on 1st line, ignored

Parent topic: Messages MFSUT0WA1 to MFSUT0WA9


MFSUT0WA6W %8 and other macro control statements not supported by MFIMS. This and subsequent control statements ignored

Parent topic: Messages MFSUT0WA1 to MFSUT0WA9


MFSUT0WA7W Column 16 on continuation was blank, MFIMS ignoring line

Parent topic: Messages MFSUT0WA1 to MFSUT0WA9


MFSUT0WA8W Missing comma for continuation, MFIMS assumed present

Parent topic: Messages MFSUT0WA1 to MFSUT0WA9


MFSUT0WA9W Invalid value "%8" - MFIMS ignored keyword and value

Parent topic: Messages MFSUT0WA1 to MFSUT0WA9


Messages MFSUT0WE1 to MFSUT0WE2

  • MFSUT0WE1W MFIMS EQU limit of %4 exceeded, extras ignored
  • MFSUT0WE2W EQU %8 contains unbalanced quotes. Maximum MFIMS EQU length is %4
Parent topic: MFS Error Messages


MFSUT0WE1W MFIMS EQU limit of %4 exceeded, extras ignored

Parent topic: Messages MFSUT0WE1 to MFSUT0WE2


MFSUT0WE2W EQU %8 contains unbalanced quotes. Maximum MFIMS EQU length is %4

Parent topic: Messages MFSUT0WE1 to MFSUT0WE2


Messages MFSUT0WF1 to MFSUT0WF2

  • MFSUT0WF1W In-line CSECT or DSECT is not supported by MFIMS. Ignoring all statements until END statement
  • MFSUT0WF2W In-line macro definitions not supported by MFIMS. Ignoring all statements until MEND statement
Parent topic: MFS Error Messages


MFSUT0WF1W In-line CSECT or DSECT is not supported by MFIMS. Ignoring all statements until END statement

Parent topic: Messages MFSUT0WF1 to MFSUT0WF2


MFSUT0WF2W In-line macro definitions not supported by MFIMS. Ignoring all statements until MEND statement

Parent topic: Messages MFSUT0WF1 to MFSUT0WF2


Messages MFSUT0WP1 to MFSUT0WP3

  • MFSUT0WP1W MFIMS maximum of 24 PF Keys exceeded, extras ignored
  • MFSUT0WP3W MFIMS maximum number of %3% default cursor positions exceeded. Remaining physical pages defaulting to (1,2)
Parent topic: MFS Error Messages


MFSUT0WP1W MFIMS maximum of 24 PF Keys exceeded, extras ignored

Parent topic: Messages MFSUT0WP1 to MFSUT0WP3


MFSUT0WP3W MFIMS maximum number of %3% default cursor positions exceeded. Remaining physical pages defaulting to (1,2)

Parent topic: Messages MFSUT0WP1 to MFSUT0WP3


PSB Error Messages

  • Messages PSBUT0401 to PSBUT0453
  • Messages PSBUT04A1 to PSBUT04A6
  • Messages PSBUT04E1 to PSBUT04E2
  • Messages PSBUT0801 to PSBUT0873
  • Messages PSBUT08A1 to PSBUT08A3
  • Messages PSBUT08P1 to PSBUT08P2
  • Messages PSBUT0L01 to PSBUT0L99
  • Messages PSBUT0LA1 to PSBUT0LA2
  • Messages PSBUT0LP1 to PSBUT0LP3
  • Messages PSBUT0U01 to PSBUT0U58
  • Messages PSBUT0W01 to PSBUT0W55
  • Messages PSBUT0WA1 to PSBUT0WA9
  • Messages PSBUT0WE1 to PSBUT0WE2
  • Messages PSBUT0WF1 to PSBUT0WF2
Parent topic: IMS Error Messages


Messages PSBUT0401 to PSBUT0453

  • PSBUT0401W More than one PSBGEN macro, all but the first ignored
  • PSBUT0402W PCB(%3%) %8, TYPE=%8 invalid, assumed TYPE=DB
  • PSBUT0403W Invalid PCB PROCOPT "%6", assumed PROCOPT "%4"
  • PSBUT0404W PCB(%3%) %8, SENSEG %8 PROCOPT operand ignored. SENSEG PROCOPT must be omitted when PCB PROCOPT is %4
  • PSBUT0405W Unknown keyword %8 for %8 ignored
  • PSBUT0406 PCB #%3% %8, SENSEG %8 PROCOPT=%4 invalid.
  • PSBUT0407W PCBNAME or label %8 is not unique. This parameter has been ignored for PCB #%3% in PSB %8
  • PSBUT0451W PCB(%3%) %8, an I/O PCB will not be created when this PSB is used in a CICS program or an IMS program defined as a type DLI
  • PSBUT0452W PCB(%3%) %8, insert calls not allowed to INDEX DBD, ACBGEN will remove insert sensitivity
  • PSBUT0453W PCB(%3%) %8, SENSEG %8 must have sensitivity to sequence field for inserts using field level sensitivity
Parent topic: PSB Error Messages


PSBUT0401W More than one PSBGEN macro, all but the first ignored

Parent topic: Messages PSBUT0401 to PSBUT0453


PSBUT0402W PCB(%3%) %8, TYPE=%8 invalid, assumed TYPE=DB

Parent topic: Messages PSBUT0401 to PSBUT0453


PSBUT0403W Invalid PCB PROCOPT "%6", assumed PROCOPT "%4"

Parent topic: Messages PSBUT0401 to PSBUT0453


PSBUT0404W PCB(%3%) %8, SENSEG %8 PROCOPT operand ignored. SENSEG PROCOPT must be omitted when PCB PROCOPT is %4

Parent topic: Messages PSBUT0401 to PSBUT0453


PSBUT0405W Unknown keyword %8 for %8 ignored

Parent topic: Messages PSBUT0401 to PSBUT0453


PSBUT0406 PCB #%3% %8, SENSEG %8 PROCOPT=%4 invalid.

Parent topic: Messages PSBUT0401 to PSBUT0453


PSBUT0407W PCBNAME or label %8 is not unique. This parameter has been ignored for PCB #%3% in PSB %8

Parent topic: Messages PSBUT0401 to PSBUT0453


PSBUT0451W PCB(%3%) %8, an I/O PCB will not be created when this PSB is used in a CICS program or an IMS program defined as a type DLI

Parent topic: Messages PSBUT0401 to PSBUT0453


PSBUT0452W PCB(%3%) %8, insert calls not allowed to INDEX DBD, ACBGEN will remove insert sensitivity

Parent topic: Messages PSBUT0401 to PSBUT0453


PSBUT0453W PCB(%3%) %8, SENSEG %8 must have sensitivity to sequence field for inserts using field level sensitivity

Parent topic: Messages PSBUT0401 to PSBUT0453


Messages PSBUT04A1 to PSBUT04A6

  • PSBUT04A1W Continuation cannot start in column 1
  • PSBUT04A2W Expected "=", found "(", "=" is assumed
  • PSBUT04A3W Continuation expected, none received
  • PSBUT04A4W Invalid character following final quote "%1".
  • PSBUT04A5W %8 has a non-numeric value "%8", assumed zero
  • PSBUT04A6W Duplicate keyword %8 specified, last one used
Parent topic: PSB Error Messages


PSBUT04A1W Continuation cannot start in column 1

Parent topic: Messages PSBUT04A1 to PSBUT04A6


PSBUT04A2W Expected "=", found "(", "=" is assumed

Parent topic: Messages PSBUT04A1 to PSBUT04A6


PSBUT04A3W Continuation expected, none received

Parent topic: Messages PSBUT04A1 to PSBUT04A6


PSBUT04A4W Invalid character following final quote "%1".

Parent topic: Messages PSBUT04A1 to PSBUT04A6


PSBUT04A5W %8 has a non-numeric value "%8", assumed zero

Parent topic: Messages PSBUT04A1 to PSBUT04A6


PSBUT04A6W Duplicate keyword %8 specified, last one used

Parent topic: Messages PSBUT04A1 to PSBUT04A6


Messages PSBUT04E1 to PSBUT04E2

  • PSBUT04E1W EQU %8 error, keyword already has data
  • PSBUT04E2W EQU %8 error, data already has a keyword
Parent topic: PSB Error Messages


PSBUT04E1W EQU %8 error, keyword already has data

Parent topic: Messages PSBUT04E1 to PSBUT04E2


PSBUT04E2W EQU %8 error, data already has a keyword

Parent topic: Messages PSBUT04E1 to PSBUT04E2


Messages PSBUT0801 to PSBUT0873

  • PSBUT0801E PSBGEN macro missing required PSBNAME operand
  • PSBUT0802E Required PSBGEN macro statement missing
  • PSBUT0803E PCB(%3%), %4 PCB missing required NAME/DBDNAME operand
  • PSBUT0804E PCB(%3%) %8, SENSEG statement invalid for GSAM PCB
  • PSBUT0805E PCB(%3%) %8, SENSEG(%3%) missing required NAME operand
  • PSBUT0806E PCB(%3%) %8, senseg %8 missing required PARENT operand or more than one SENSEG in PCB indicates PARENT=0
  • PSBUT0807E PCB(%3%) %8, SENSEG %8, parent segment %8 not previously defined in this PCB
  • PSBUT0808E PCB(%3%) %8, SENSEG %8 not unique
  • PSBUT0809E PCB(%3%) %8, at least one SENSEG statement is required for a DB PCB
  • PSBUT0810E COPY statement missing required NAME parameter
  • PSBUT0811E COPY member %8 not found
  • PSBUT0812E PCB(%3%) %8, SENSEG statement limit of %4% per PSB exceeded.
  • PSBUT0813E PCB(%3%) %8 SENFLD statement limit of %5% per PSB exceeded
  • PSBUT0814E PCB(%3%) %8, SENSEG %8, SENFLD statement limit of %4% per SENSEG exceeded
  • PSBUT0815E SENFLD statement cannot precede PCB statement
  • PSBUT0816E PCB(%3%) SENFLD statement only valid with TYPE=DB PCB
  • PSBUT0817E PCB(%3%) SENFLD statement cannot precede SENSEG statement
  • PSBUT0818E PCB(%3%) %8, SENSEG %8, SENFLD statement missing required NAME operand
  • PSBUT0819E PCB(%3%) %8, SENSEG %8, SENFLD %8 statement missing required START operand
  • PSBUT0820E PCB(%3%) %8, SENSEG %8, SENFLD %8 START value exceeds 32767
  • PSBUT0821E PCB statement limit of %4% per PSB exceeded
  • PSBUT0822E SENSEG statement limit of %4% per PCB exceeded
  • PSBUT0823E PCB(%3%) %8, SENSEG %8, DOS/VS VIRFLD statement not valid for IMS/ESA (MVS) compatibility. Use system config IBM DLI PLATFORM for DOS/VS syntax
  • PSBUT0824E PCB(%3%), SENSEG %8, SENFLD %8's BYTES, TYPE, or RTNAME keywords not valid for IMS/ESA (MVS) compatibility. Use system config IBM DLI PLATFORM for DOS/VS syntax
  • PSBUT0825E SENSEG statement cannot precede PCB statement
  • PSBUT0826E PCB(%3%), SENSEG statement only valid with TYPE=DB PCB
  • PSBUT0851E PCB (%3%) %8, DBD access %5 does not support alternate processing sequence %8
  • PSBUT0852E PCB (%3%) %8, SENSEG %8 not in database
  • PSBUT0853E PCB (%3%) %8, segment %8, SENSEG parent %8 is not same as database SEGM parent %8
  • PSBUT0854E PCB (%3%) %8, SENSEG %8 does not have DBD LCHILD statement for alternate processing sequence %8
  • PSBUT0855E PCB (%3%), SENSEG %8 logical DBD %8 refers to physical DBD %8 which has not been Genned
  • PSBUT0856E PCB (%3%), index database %8 refers to physical database %8 which has not been Genned
  • PSBUT0857E PCB (%3%) %8, dynamic ACBGEN failed, reason code %4%
  • PSBUT0858E PCB (%3%) %8, ACBGEN lookup failed, reason code %4%
  • PSBUT0859E PCB (%3%) %8, SENSEG %8, SENFLD %8 not defined as field in database
  • PSBUT0860E PCB (%3%) %8, GSAM PCB references non-GSAM DBD, access will result in 476 abend
  • PSBUT0862E PCB (%3%) %8, SENSEG %8 specifies incorrect logical child segment
  • PSBUT0863E PCB (%3%) %8, SENSEG %8 specifies incorrect destination parent segment
  • PSBUT0864E PCB (%3%) %8, SENSEG %8, invalid parentage structure
  • PSBUT0865E PCB (%3%) %8, SENSEG %8 is a duplicate of senseg %8
  • PSBUT0866E PCB (%3%) %8, SENSEG %8, logical parent segment %8 not found in source database %8
  • PSBUT0867E PCB (%3%) %8, SENSEG %8, invalid parentage structure in source database %8 for logical parent segment %8
  • PSBUT0868E PCB (%3%) %8, SENSEG %8 is not root segment and no PROCSEQ has been specified
  • PSBUT0869E PCB (%3%) %8, ACB block failure, reason code %4%.
  • PSBUT0870E PCB (%3%) %8, paired logical child segment %8 intersection data length mismatch
  • PSBUT0871E PCB (%3%) %8, SENSEG %8, DBD field %8 referenced by PCB SENFLD %8, overlaps variable length segment length code (LL)
  • PSBUT0872E PCB (%3%) %8, ACB(L2) verify failure, reason code %4%
  • PSBUT0873 PCB #%3%, DBD %8 not Genned, ACB will not be generated
Parent topic: PSB Error Messages


PSBUT0801E PSBGEN macro missing required PSBNAME operand

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0802E Required PSBGEN macro statement missing

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0803E PCB(%3%), %4 PCB missing required NAME/DBDNAME operand

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0804E PCB(%3%) %8, SENSEG statement invalid for GSAM PCB

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0805E PCB(%3%) %8, SENSEG(%3%) missing required NAME operand

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0806E PCB(%3%) %8, senseg %8 missing required PARENT operand or more than one SENSEG in PCB indicates PARENT=0

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0807E PCB(%3%) %8, SENSEG %8, parent segment %8 not previously defined in this PCB

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0808E PCB(%3%) %8, SENSEG %8 not unique

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0809E PCB(%3%) %8, at least one SENSEG statement is required for a DB PCB

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0810E COPY statement missing required NAME parameter

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0811E COPY member %8 not found

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0812E PCB(%3%) %8, SENSEG statement limit of %4% per PSB exceeded.

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0813E PCB(%3%) %8 SENFLD statement limit of %5% per PSB exceeded

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0814E PCB(%3%) %8, SENSEG %8, SENFLD statement limit of %4% per SENSEG exceeded

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0815E SENFLD statement cannot precede PCB statement

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0816E PCB(%3%) SENFLD statement only valid with TYPE=DB PCB

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0817E PCB(%3%) SENFLD statement cannot precede SENSEG statement

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0818E PCB(%3%) %8, SENSEG %8, SENFLD statement missing required NAME operand

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0819E PCB(%3%) %8, SENSEG %8, SENFLD %8 statement missing required START operand

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0820E PCB(%3%) %8, SENSEG %8, SENFLD %8 START value exceeds 32767

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0821E PCB statement limit of %4% per PSB exceeded

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0822E SENSEG statement limit of %4% per PCB exceeded

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0823E PCB(%3%) %8, SENSEG %8, DOS/VS VIRFLD statement not valid for IMS/ESA (MVS) compatibility. Use system config IBM DLI PLATFORM for DOS/VS syntax

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0824E PCB(%3%), SENSEG %8, SENFLD %8's BYTES, TYPE, or RTNAME keywords not valid for IMS/ESA (MVS) compatibility. Use system config IBM DLI PLATFORM for DOS/VS syntax

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0825E SENSEG statement cannot precede PCB statement

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0826E PCB(%3%), SENSEG statement only valid with TYPE=DB PCB

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0851E PCB (%3%) %8, DBD access %5 does not support alternate processing sequence %8

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0852E PCB (%3%) %8, SENSEG %8 not in database

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0853E PCB (%3%) %8, segment %8, SENSEG parent %8 is not same as database SEGM parent %8

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0854E PCB (%3%) %8, SENSEG %8 does not have DBD LCHILD statement for alternate processing sequence %8

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0855E PCB (%3%), SENSEG %8 logical DBD %8 refers to physical DBD %8 which has not been Genned

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0856E PCB (%3%), index database %8 refers to physical database %8 which has not been Genned

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0857E PCB (%3%) %8, dynamic ACBGEN failed, reason code %4%

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0858E PCB (%3%) %8, ACBGEN lookup failed, reason code %4%

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0859E PCB (%3%) %8, SENSEG %8, SENFLD %8 not defined as field in database

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0860E PCB (%3%) %8, GSAM PCB references non-GSAM DBD, access will result in 476 abend

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0862E PCB (%3%) %8, SENSEG %8 specifies incorrect logical child segment

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0863E PCB (%3%) %8, SENSEG %8 specifies incorrect destination parent segment

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0864E PCB (%3%) %8, SENSEG %8, invalid parentage structure

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0865E PCB (%3%) %8, SENSEG %8 is a duplicate of senseg %8

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0866E PCB (%3%) %8, SENSEG %8, logical parent segment %8 not found in source database %8

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0867E PCB (%3%) %8, SENSEG %8, invalid parentage structure in source database %8 for logical parent segment %8

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0868E PCB (%3%) %8, SENSEG %8 is not root segment and no PROCSEQ has been specified

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0869E PCB (%3%) %8, ACB block failure, reason code %4%.

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0870E PCB (%3%) %8, paired logical child segment %8 intersection data length mismatch

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0871E PCB (%3%) %8, SENSEG %8, DBD field %8 referenced by PCB SENFLD %8, overlaps variable length segment length code (LL)

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0872E PCB (%3%) %8, ACB(L2) verify failure, reason code %4%

Parent topic: Messages PSBUT0801 to PSBUT0873


PSBUT0873 PCB #%3%, DBD %8 not Genned, ACB will not be generated

Parent topic: Messages PSBUT0801 to PSBUT0873


Messages PSBUT08A1 to PSBUT08A3

  • PSBUT08A1E Unmatched parentheses
  • PSBUT08A2E Unmatched quotes.
  • PSBUT08A3E Positional operand cannot follow keyword operand: %60%
Parent topic: PSB Error Messages


PSBUT08A1E Unmatched parentheses

Parent topic: Messages PSBUT08A1 to PSBUT08A3


PSBUT08A2E Unmatched quotes.

Parent topic: Messages PSBUT08A1 to PSBUT08A3


PSBUT08A3E Positional operand cannot follow keyword operand: %60%

Parent topic: Messages PSBUT08A1 to PSBUT08A3


Messages PSBUT08P1 to PSBUT08P2

  • PSBUT08P1E Number of list operands exceeds MFIMS maximum of %3%.
  • PSBUT08P2E Macro %8, keyword %8 has unmatched parentheses
Parent topic: PSB Error Messages


PSBUT08P1E Number of list operands exceeds MFIMS maximum of %3%.

Parent topic: Messages PSBUT08P1 to PSBUT08P2


PSBUT08P2E Macro %8, keyword %8 has unmatched parentheses

Parent topic: Messages PSBUT08P1 to PSBUT08P2


Messages PSBUT0L01 to PSBUT0L99

  • PSBUT0L01E MFIMS PCB macro statement limit reached. Only %4% PCB macros per PSB with PSBGEN format 2 files
  • PSBUT0L02E PCB(%3%) %8, minimum RECLEN exceeds maximum RECLEN
  • PSBUT0L03E PSBGEN format 2 SENSEG macro statement limit of %4% per PSB exceeded
  • PSBUT0L54E PCB (%3) %8, SENSEG %8, logical parent segment %8 concatenated key not unique in database %8. MFIMS requires that the LPCK is unique
  • PSBUT0L55E No DBDs have been genned, verify cannot complete
  • PSBUT0L99E Valid software license not present. Reason code (%4%)
Parent topic: PSB Error Messages


PSBUT0L01E MFIMS PCB macro statement limit reached. Only %4% PCB macros per PSB with PSBGEN format 2 files

Parent topic: Messages PSBUT0L01 to PSBUT0L99


PSBUT0L02E PCB(%3%) %8, minimum RECLEN exceeds maximum RECLEN

Parent topic: Messages PSBUT0L01 to PSBUT0L99


PSBUT0L03E PSBGEN format 2 SENSEG macro statement limit of %4% per PSB exceeded

Parent topic: Messages PSBUT0L01 to PSBUT0L99


PSBUT0L54E PCB (%3) %8, SENSEG %8, logical parent segment %8 concatenated key not unique in database %8. MFIMS requires that the LPCK is unique

Parent topic: Messages PSBUT0L01 to PSBUT0L99


PSBUT0L55E No DBDs have been genned, verify cannot complete

Parent topic: Messages PSBUT0L01 to PSBUT0L99


PSBUT0L99E Valid software license not present. Reason code (%4%)

Parent topic: Messages PSBUT0L01 to PSBUT0L99


Messages PSBUT0LA1 to PSBUT0LA2

  • PSBUT0LA1E Positional operand cannot follow keyword operand: %60% MFIMS does not perform MFSGEN syntax error recovery
  • PSBUT0LA2E Length of operand exceeds MFIMS maximum of %4 bytes
Parent topic: PSB Error Messages


PSBUT0LA1E Positional operand cannot follow keyword operand: %60% MFIMS does not perform MFSGEN syntax error recovery

Parent topic: Messages PSBUT0LA1 to PSBUT0LA2


PSBUT0LA2E Length of operand exceeds MFIMS maximum of %4 bytes

Parent topic: Messages PSBUT0LA1 to PSBUT0LA2


Messages PSBUT0LP1 to PSBUT0LP3

  • PSBUT0LP1E Length of operand exceeds MFIMS size of %4% bytes
  • PSBUT0LP2E Number of list operands exceeds MFIMS maximum of %3%
  • PSBUT0LP3E Length of list exceeds MFIMS maximum of %4% bytes
Parent topic: PSB Error Messages


PSBUT0LP1E Length of operand exceeds MFIMS size of %4% bytes

Parent topic: Messages PSBUT0LP1 to PSBUT0LP3


PSBUT0LP2E Number of list operands exceeds MFIMS maximum of %3%

Parent topic: Messages PSBUT0LP1 to PSBUT0LP3


PSBUT0LP3E Length of list exceeds MFIMS maximum of %4% bytes

Parent topic: Messages PSBUT0LP1 to PSBUT0LP3


Messages PSBUT0U01 to PSBUT0U58

  • PSBUT0U01U File status %A5 opening file %C60. %B40%
  • PSBUT0U02U File status %A5 issuing close for file %C60. %B40%
  • PSBUT0U03U File status %A5 issuing read for file %C60. %B40%
  • PSBUT0U04U File status %5 issuing close for PSBGEN file. %40%
  • PSBUT0U05U File status %5 issuing close for PSBGEN SENFLD file. %40%
  • PSBUT0U06U File status %5 issuing create file for PSBGEN. %40%
  • PSBUT0U07U File status %5 converting PSBGEN file. %40%
  • PSBUT0U08U File status %5 issuing delete for PSBGEN. %40%
  • PSBUT0U09U File status %5 issuing delete for PSBGEN field file. %40%
  • PSBUT0U10U File status %5 issuing read/rewrite for PSBGEN file. %40%
  • PSBUT0U11U File status %5 issuing write for PSBGEN file. %40%
  • PSBUT0U12U File status %5 issuing get lock for PSBGEN file. %40%
  • PSBUT0U13U File status %5 issuing set/date for PSBGEN. %40%
  • PSBUT0U35U File not found %C60.
  • PSBUT0U54U File status %5 issuing read for PSBGEN. %40%
  • PSBUT0U55U File status %5 issuing read for PSBGEN field file. %40%
  • PSBUT0U56U File status %5 issuing read for DBDGEN field file. %40%
  • PSBUT0U57U PSB %8 not genned, PSB must be genned prior to verification
  • PSBUT0U58U File status %5 issuing start/read for DBDGEN file. %40%
Parent topic: PSB Error Messages


PSBUT0U01U File status %A5 opening file %C60. %B40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U02U File status %A5 issuing close for file %C60. %B40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U03U File status %A5 issuing read for file %C60. %B40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U04U File status %5 issuing close for PSBGEN file. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U05U File status %5 issuing close for PSBGEN SENFLD file. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U06U File status %5 issuing create file for PSBGEN. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U07U File status %5 converting PSBGEN file. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U08U File status %5 issuing delete for PSBGEN. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U09U File status %5 issuing delete for PSBGEN field file. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U10U File status %5 issuing read/rewrite for PSBGEN file. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U11U File status %5 issuing write for PSBGEN file. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U12U File status %5 issuing get lock for PSBGEN file. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U13U File status %5 issuing set/date for PSBGEN. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U35U File not found %C60.

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U54U File status %5 issuing read for PSBGEN. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U55U File status %5 issuing read for PSBGEN field file. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U56U File status %5 issuing read for DBDGEN field file. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U57U PSB %8 not genned, PSB must be genned prior to verification

Parent topic: Messages PSBUT0U01 to PSBUT0U58


PSBUT0U58U File status %5 issuing start/read for DBDGEN file. %40%

Parent topic: Messages PSBUT0U01 to PSBUT0U58


Messages PSBUT0W01 to PSBUT0W55

  • PSBUT0W01W MFIMS statement continuation overflow, extras ignored. Maximum number of lines per statement is %2%
  • PSBUT0W02W Only one level of nested copy statements supported by MFIMS, further nested COPYs ignored
  • PSBUT0W03W PCB(%3%), GSAM PCB %8 has MFIMS RECLEN of zero
  • PSBUT0W04W PCB(%3%), GSAM PCB %8, RECLEN operand truncated to 32768
  • PSBUT0W05W PCB(%3%) %8, SENSEG %8, SSPTR operand ignored. MFIMS does not support the SSPTR operand for DEDBs
  • PSBUT0W06W PCB(%3%) %8, SENSEG %8, INDICES operand ignored, not supported by MFIMS
  • PSBUT0W07W PCB(%3%) %8, SENSEG %8, VIRFLD statement ignored, not supported by MFIMS
  • PSBUT0W08W PCB(%3%), SENSEG %8, SENFLD %8, DOS/VS SENFLD keywords of BYTES, TYPE or RTNAME ignored, not supported by MFIMS. This message suppressed for other occurrences
  • PSBUT0W09W PCB(%3%), ALTRESP=YES not supported by MFIMS, changed to ALTRESP=NO
  • PSBUT0W10W PCB(%3%), VIEW=MSDB not supported by MFIMS, changed to VIEW=DEDB
  • PSBUT0W11W Unknown statement "%8" ignored, unsupported by MFIMS
  • PSBUT0W12W Comment line continuation has non-blanks in columns 1-15, assumed blank by MFIMS: %15%
  • PSBUT0W51W PCB (%3%), DBD %8 not Genned, access will result in 476 abend
  • PSBUT0W52W PCB (%3%) %8, SENFLD statements not verified, physical DBD not Genned with MFIMS Version 2.5 or later
  • PSBUT0W53W PCB (%3%) %8, KEYLEN operand value %3 is less than concatenated key length %3
  • PSBUT0W54W PCB (%3%) %8, logical parent database %8 not Genned, access may produce unpredictable results
  • PSBUT0W55W No DBDs have been genned
Parent topic: PSB Error Messages


PSBUT0W01W MFIMS statement continuation overflow, extras ignored. Maximum number of lines per statement is %2%

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W02W Only one level of nested copy statements supported by MFIMS, further nested COPYs ignored

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W03W PCB(%3%), GSAM PCB %8 has MFIMS RECLEN of zero

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W04W PCB(%3%), GSAM PCB %8, RECLEN operand truncated to 32768

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W05W PCB(%3%) %8, SENSEG %8, SSPTR operand ignored. MFIMS does not support the SSPTR operand for DEDBs

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W06W PCB(%3%) %8, SENSEG %8, INDICES operand ignored, not supported by MFIMS

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W07W PCB(%3%) %8, SENSEG %8, VIRFLD statement ignored, not supported by MFIMS

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W08W PCB(%3%), SENSEG %8, SENFLD %8, DOS/VS SENFLD keywords of BYTES, TYPE or RTNAME ignored, not supported by MFIMS. This message suppressed for other occurrences

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W09W PCB(%3%), ALTRESP=YES not supported by MFIMS, changed to ALTRESP=NO

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W10W PCB(%3%), VIEW=MSDB not supported by MFIMS, changed to VIEW=DEDB

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W11W Unknown statement "%8" ignored, unsupported by MFIMS

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W12W Comment line continuation has non-blanks in columns 1-15, assumed blank by MFIMS: %15%

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W51W PCB (%3%), DBD %8 not Genned, access will result in 476 abend

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W52W PCB (%3%) %8, SENFLD statements not verified, physical DBD not Genned with MFIMS Version 2.5 or later

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W53W PCB (%3%) %8, KEYLEN operand value %3 is less than concatenated key length %3

CAUTION:
This warning is an indication that the PSB is not valid on the mainframe. If you intend to move the PSB back to the mainframe, you must first correct it.
Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W54W PCB (%3%) %8, logical parent database %8 not Genned, access may produce unpredictable results

Parent topic: Messages PSBUT0W01 to PSBUT0W55


PSBUT0W55W No DBDs have been genned

Parent topic: Messages PSBUT0W01 to PSBUT0W55


Messages PSBUT0WA1 to PSBUT0WA9

  • PSBUT0WA1W BLANK line not allowed, MFIMS ignores blank lines
  • PSBUT0WA2W Exceeded MFIMS maximum number of operands, extras ignored
  • PSBUT0WA3W Columns 1-15 non-blank on continuation, MFIMS assumes blank
  • PSBUT0WA4W LABEL exceeds 8 bytes, MFIMS truncated to 8
  • PSBUT0WA5W Statement type must be on 1st line, ignored
  • PSBUT0WA6W %8 and other macro control statements not supported by MFIMS. This and subsequent control statements ignored
  • PSBUT0WA7W Column 16 on continuation was blank, MFIMS ignoring line.
  • PSBUT0WA8W Missing comma for continuation, MFIMS assumed present.
  • PSBUT0WA9W Invalid value "%8" - MFIMS ignored keyword and value
Parent topic: PSB Error Messages


PSBUT0WA1W BLANK line not allowed, MFIMS ignores blank lines

Parent topic: Messages PSBUT0WA1 to PSBUT0WA9


PSBUT0WA2W Exceeded MFIMS maximum number of operands, extras ignored

Parent topic: Messages PSBUT0WA1 to PSBUT0WA9


PSBUT0WA3W Columns 1-15 non-blank on continuation, MFIMS assumes blank

Parent topic: Messages PSBUT0WA1 to PSBUT0WA9


PSBUT0WA4W LABEL exceeds 8 bytes, MFIMS truncated to 8

Parent topic: Messages PSBUT0WA1 to PSBUT0WA9


PSBUT0WA5W Statement type must be on 1st line, ignored

Parent topic: Messages PSBUT0WA1 to PSBUT0WA9


PSBUT0WA6W %8 and other macro control statements not supported by MFIMS. This and subsequent control statements ignored

Parent topic: Messages PSBUT0WA1 to PSBUT0WA9


PSBUT0WA7W Column 16 on continuation was blank, MFIMS ignoring line.

Parent topic: Messages PSBUT0WA1 to PSBUT0WA9


PSBUT0WA8W Missing comma for continuation, MFIMS assumed present.

Parent topic: Messages PSBUT0WA1 to PSBUT0WA9


PSBUT0WA9W Invalid value "%8" - MFIMS ignored keyword and value

Parent topic: Messages PSBUT0WA1 to PSBUT0WA9


Messages PSBUT0WE1 to PSBUT0WE2

  • PSBUT0WE1W MFIMS EQU limit of %4 exceeded, extras ignored
  • PSBUT0WE2W EQU %8 contains unbalanced quotes. Maximum MFIMS EQU length is %4
Parent topic: PSB Error Messages


PSBUT0WE1W MFIMS EQU limit of %4 exceeded, extras ignored

Parent topic: Messages PSBUT0WE1 to PSBUT0WE2


PSBUT0WE2W EQU %8 contains unbalanced quotes. Maximum MFIMS EQU length is %4

Parent topic: Messages PSBUT0WE1 to PSBUT0WE2


Messages PSBUT0WF1 to PSBUT0WF2

  • PSBUT0WF1W In-line CSECT or DSECT is not supported by MFIMS. Ignoring all statements until END statement
  • PSBUT0WF2W In-line macro definitions not supported by MFIMS. Ignoring all statements until MEND statement
Parent topic: PSB Error Messages


PSBUT0WF1W In-line CSECT or DSECT is not supported by MFIMS. Ignoring all statements until END statement

Parent topic: Messages PSBUT0WF1 to PSBUT0WF2


PSBUT0WF2W In-line macro definitions not supported by MFIMS. Ignoring all statements until MEND statement

Parent topic: Messages PSBUT0WF1 to PSBUT0WF2


SECRMT MSG ID: RMTSEC REMOTE IMS REQUESTER

The following information is also displayed with this error:

SECRMT Security invalid.  Remote system requires userid and password.
SECRMT
SECRMT ---reserved internal for userid   field--- %10
SECRMT ---reserved internal for password field--- %10
SECRMT
SECRMT Enter userid, password, and select option:
SECRMT   C - Connect with these values
SECRMT   T - Terminate application
SECRMT   ---reserved for option S description---
Parent topic: IMS Error Messages


IMS Stage 1 Import/Export Error Messages

These messages are output by the IMS stage 1 import/export utility. Some are environment dependent, so your particular environment might not support them all. When you select an error message number, the text and severity of each message is described, the error or problem that causes the message is described, and advice is given on how to prevent it. These messages have the prefix IMSUT.

  • IMSUT1000E Error opening input (STAGE 1) file, Status: %5 DSN: %60
  • IMSUT1001E Error opening output (EXTRACT) file, Status: %5 DSN: %60
  • IMSUT1002E Error opening input (EXTRACT) file, Status: %5 DSN: %60
  • IMSUT1003E No output (EXTRACT) file specified; stage1ext ending
  • IMSUT1004E Error opening .LST file, Status: %5 DSN: %60
Parent topic: IMS Error Messages


IMSUT1000E Error opening input (STAGE 1) file, Status: %5 DSN: %60

Parent topic: IMS Stage 1 Import/Export Error Messages


IMSUT1001E Error opening output (EXTRACT) file, Status: %5 DSN: %60

Parent topic: IMS Stage 1 Import/Export Error Messages


IMSUT1002E Error opening input (EXTRACT) file, Status: %5 DSN: %60

Parent topic: IMS Stage 1 Import/Export Error Messages


IMSUT1003E No output (EXTRACT) file specified; stage1ext ending

Parent topic: IMS Stage 1 Import/Export Error Messages


IMSUT1004E Error opening .LST file, Status: %5 DSN: %60

Parent topic: IMS Stage 1 Import/Export Error Messages


Managed COBOL

  • Managed COBOL Reference
  • Type Compatibility of Managed COBOL with Other Managed Languages
    Many managed COBOL types have a strict correspondence with managed types in other languages, such as binary-long and float-short. For those that don't have a correspondence, there are alternatives.
  • MicroFocus.COBOL.RuntimeServices
Parent topic: General Reference


Managed COBOL Reference

Managed COBOL supports the key aspects of the managed framework (both .NET and JVM). It provides new syntax specifically designed to support these features.

In addition, managed COBOL continues to support all of the existing COBOL syntax (for native COBOL) with very few exceptions.

This reference describes the syntax designed and recommended for managed COBOL. The syntax for native COBOL is documented in the COBOL Language Reference.

  • Program Structure
  • Structural Syntax Elements - Alphabetic List
  • Common Phrases
  • Statements - Alphabetic List
  • Concepts - Managed COBOL
Parent topic: Managed COBOL
Related information
COBOL Language Reference


Program Structure

The overall structure of a program is one or more type specifications.

type-specification ...
Parent topic: Managed COBOL Reference


Types

Context:

    Program Structure

type-specification

class-specification delegate-specification enum-specification interface-specification valuetype-specification

Example

Class A.
...
end class.

Interface I.
...
end interface.


Classes

A class defines the data members and function members for object instances that are created from that class. Managed COBOL allows a class to inherit from one or more other classes.

Context:

    Program Structure
        Types

class-specification

class-header constraints-paragraph constraints-paragraph static-or-instance-member type-specification

class-header

access-modifier type-specifier type-specifier attribute-clause generic-using-phrase

Example

class A.
01 sField string.
Method doStuff.
   ...
end method.

class nestedClass.
...
end class.

end class.

See also the Core sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Class Header Keywords

ABSTRACT
Declares a class that is only intended to be used as a base class. An abstract class can be thought of as an incomplete class that must be inherited to access its members.
FINAL
Declares a class whose definition is complete. The FINAL modifier on a class implies that the class cannot have subclasses.
STATIC
Declares a class that cannot be instantiated.
PARTIAL
Indicates that the declaration is one of two or more parts that make up the full declaration. Partial classes enable you split a class declaration into logical parts.
INHERITS
Defines that a class is inherited, where type-specifier specifies the class that is inherited. Inheritance enables a class to implicitly contain members of its inherited class type.
IMPLEMENTS
Indicates that an interface is implemented, where type-specifier specifies the interface that is implemented.

Abstract Classes

An abstract class is a class that cannot be instantiated, but can only be inherited from. Because of this, an abstract class is typically used as a base class. Members of an abstract class are only declared in the abstract class, and cannot be implemented. Because abstract classes must be inherited from, the FINAL modifier cannot be used when declaring an abstract class.

An abstract class typically contains abstract methods, which cannot be implemented in the class declaration, similar to method declarations in an interface. Because abstract classes cannot be instantiated, subclasses that inherit the abstract class must provide the implementations of abstract methods defined in the abstract class. Only an abstract class can contain abstract methods.

Abstract classes are useful when you do not want objects created from the class. Declare a class as abstract when you want to use subclasses to complete the implementation.

When any non-abstract class derives from an abstract class through inheritance, the inherited class must implement all the abstract members of the abstract class. Use OVERRIDE when implementing the members of an abstract class in the non-abstract members of the derived class, as shown in the following example:

       class-id. Animal abstract.
       method-id MakeNoise abstract.
      *> No implementation allowed
       end method.

       end class.

       class-id Dog inherits type Animal.
      *> Overrides the MakeNoise method in the Animal class
       method-id MakeNoise override.
           display "Woof!"
       end method.
       end class.

In this example, the abstract class Animal contains the abstract method MakeNoise. Because the non-abstract class Dog inherits from the abstract class Animal, it must provide an implementation of MakeNoise using the OVERRIDE modifier.

An abstract class can contain non-abstract methods in addition to abstract methods.

A class that inherits an abstract class must also be declared as an abstract class if it does not provide implementation of the inherited class' members.

Final Classes

A final class cannot be inherited. Because of this, methods in a final class cannot be overridden.

Declaring a class as FINAL is useful to prevent subversion of the class. It prevents a subclass from potentially changing the intended class functionality by overriding its intended behavior.

Nested Classes

Nested classes can access static fields, properties and methods within the containing classes using the syntax:

self::memberName

The optional SHARING PARENT phrase in the nested class definition enables the nested class to access the instance fields, properties and methods in the containing class.

    class-id ContainingClass.
    ...
    class-id Nested1.
        ...
    end class.
    class-id Nested2 sharing parent.
       ...
    end class.
    end class.

Nested Classes with SHARING PARENT

Nested classes with the SHARING PARENT phrase may only be instantiated from within an instance method in the enclosing class. They can access the instance members from that containing class using the self:: syntax, even when those instance members are private.

Such a nested class contains an implicit reference to an instance of its containing class. The nested class uses this reference to access the enclosing class's instance members. This means that the containing class instance will not be garbage collected until all references to the inner class held externally have themselves been garbage collected.

For example:

    class-id ContainingClass.
    01 companyName string value "Micro Focus".

    method-id instance1.
    01 o type Nested2.
        set o to new Nested2
        ...
    end method

    class-id Nested2 SHARING PARENT.
    method-id method2
        display self::companyName
    end method.
    end class.

    end class.

Nested Classes without SHARING PARENT

Nested classes defined without the SHARING PARENT phrase may be declared as public, private or internal. Depending on the visibility specified, they can be instantiated from any context, not just from the containing class, and not just from instance methods. They cannot access instance members of the containing class with the self:: syntax, but only do it using an explicit object reference.

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Access Modifiers
Attributes
Constraints Paragraph
Related information
Program Structure - in COBOL and C#
Objects - in COBOL and C#
Nested Classes in Managed COBOL


Constraints Paragraph

The Constraints paragraph allows specification of properties of parameters of a generic type or method, and therefore allows the use of methods or properties on data items whose type is specified as that parameter.

Context:

    Classes
     ValueTypes
     Interfaces
     Methods

constraints-paragraph

type-specifier type-specifier

Example

The following shows a static generic method with a USING phrase that declares the generic argument T. This generic argument is constrained as the type System.IComparable. The method expects two parameters both of which must be of the same type as the generic argument.

       method-id Min using T static.
       constraints.
           constrain T implements type System.IComparable.
       procedure division using by value item1 as T item2 as T
                      returning res as T.
           if item1::CompareTo(item2) < 0
               set res to item1
           else
               set res to item2
           end-if
       end method.

In this case the CompareTo method may be invoked since T is known to implement the IComparable interface.

Parent topic: Common Phrases
Related reference
Access Modifiers
Attributes
Classes
Interfaces
Properties
ValueTypes
Generic Using Phrase
Related information
Generics, Defining - in COBOL and C#


Fields

A class, valuetype and interface can define a set of static or instance fields.

Context:

    Classes
     ValueTypes
     Interfaces
     Methods

static-or-instance-field

variable-field constant-field

variable-field

type-specifier access-modifier attribute-clause

constant-field

type-specifier access-modifier attribute-clause

Example

    01 dAmount  decimal.
    01 asNames string occurs 5.
    01 abFigures binary-long occurs any.

    78 Max_Students value 25.  *> default is public, binary-long

See also the Core sample available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

INITIALIZE ONLY Keywords

The INITIALIZE ONLY phrase defines a static or instance field that can only be modified within a class constructor or constructor (respectively). For example:

    class-id a.
    01 s string static value "Shouldn't see this" initialize only.
    method-id main static.
        display s
    end method.
    method-id new static.
        set s to "Hello world"
    end method.
    end class.

INITIALIZE ONLY fields and constant fields differ as follows:

INITIALIZE ONLY field:
  • Can be either instance-level or static
  • Evaluated at run time
  • Can be initialized in declaration or by code in the constructor
Constant field (78-level):
  • Always implicitly static
  • Evaluated at compile time
  • Initialized at declaration only

EVENT Keyword

The EVENT keyword is allowed only on items that are declared as delegates.

The keyword EVENT on a delegate instance ChangeEvent creates two methods, which are named add_ and remove _ with the delegate instance name appended. These methods can be used to hook a new method into the delegate, and subsequently to remove it, respectively.

For example, the keyword EVENT in the following statement creates two methods add_ChangeEvent and remove_ChangeEvent:

       01 ChangeEvent type ChangeDelegate event public.
       ...
       delegate-id ChangeDelegate.
       procedure division using by value x1 as binary-long.
       end delegate.

See also the Events sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET.

PROPERTY Keyword

You can expose a field as a property using the PROPERTY keyword. By default, the property name will be the same as the field name (and in the same case). You can use the AS clause to specify a different external name.

01 public-field pic x property as "Property1".

The PROPERTY keyword generates two accessor methods to retrieve and update the field. The names of these methods are derived from the property name by prefixing it with 'get_' and 'set_' (.NET) or with 'get' and 'set' (JVM). These methods are commonly known as getter and setter methods. Languages that support properties will hide these methods from you and appear to allow you to get and set these member fields directly. In fact, the Compiler is substituting the property name with the relevant getter or setter.

The property thus defined is virtual by default, which means that it can be overridden in derived classes.

Use the following clauses to modify the characteristics of the property.

The FINAL Clause

Use the FINAL clause to make the property non-virtual, so that it cannot be overridden in a derived class.

 01 public-field pic x property as "Property1" FINAL.

The OVERRIDE Clause

Use the OVERRIDE clause to override a property of this name and type in an inherited class. Only virtual properties in the inherited class can be overridden in this way.

 01 public-field pic x property as "Property1" OVERRIDE.

The REDEFINE Clause

Use the REDEFINE clause to redefine a property of this name and type in an inherited class. Both virtual and non-virtual properties in the inherited class can be redefined in this way.

01 public-field pic x property as "Property1" REDEFINE.

Example:

The output from the following program should be:

P1 in b

P2 in a

P3 in a

M1 in b

M2 in a

M3 in a

class-id myTesterClass.
method-id main static.
   01 a type a value new b.

   display a::P1
   display a::P2
   display a::P3
   invoke a::M1
   invoke a::M2
   invoke a::M3
end method.
end class.

class-id a.

01 P1 string property value "P1 in a".
01 P2 string property value "P2 in a".
01 P3 string property final value "P3 in a".

method-id M1.
   display "M1 in a".
end method.

method-id M2.
   display "M2 in a".
end method.

method-id M3 final.
   display "M3 in a".
end method.

end class.

class-id b inherits type a.

01 P1 string property override value "P1 in b".
01 P2 string property redefine value "P2 in b".
01 P3 string property redefine value "P3 in b".

method-id M1 override.
   display "M1 in b".
end method.

method-id M2 redefine.
   display "M2 in b".
end method.

method-id M3 redefine.
   display "M3 in b".
end method.
end class.

See also the Properties sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Delegates and Events
Properties
Local Data Item Declaration
Access Modifiers
Attributes
Type Specifier
Related information
Data Types - in COBOL and C#
Constants - in COBOL and C#
String Handling in Managed COBOL


Type Members

Context:

    Classes
     ValueTypes
     Interfaces
     Methods

static-or-instance-member

method-specification constructor-specification property-specification indexer-specification operator-specification iterator-specification
Parent topic: Structural Syntax Elements - Alphabetic List


Methods

A method defines a block of code to be executed when the method is invoked.

Context:

    Classes
    ValueTypes
    Interfaces
        Type Members

method-specification

method-header constraints-paragraph procedure-division

method-header

access-modifier attribute-clause

Example

method-id methodA static.
01 s string value "Hello".
procedure division.
   display s
end method.

See also the Core sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Static and Instance Methods

Methods can be either static methods or instance methods, and are by default instance. An instance method operates on a given instance of a class, whereas a static method does not operate on a given instance.

A static method can invoke static methods only and can access static fields only. A static method can reside in a static class or an instance class. Where a static method is in an instance class, all objects instantiated from the class share a single copy of the static methods.

For example, the following class contains static and instance methods, and static and instance fields.

       class-id MyCounter.

       01 totalCount binary-long static.
       01 myCount binary-long.

       method-id New.
       procedure division.
           set myCount to totalCount
           set totalCount to totalCount + 1
       end method.

       method-id GetCount.
       procedure division returning returnItem as binary-long.
           set returnItem to myCount
       end method.

       method-id GetTotalCount static.
       procedure division returning returnItem as binary-long.
           set returnItem to totalCount
       end method.

       method-id SetCount static.
       procedure division using by value aCount as binary-long.
           set totalCount to aCount
       end method.
       end class.

Here is the program that invokes the above code:

       program-id StaticInstanceProgram.
       01 myInstance1 type MyCounter.
       01 myInstance2 type MyCounter.

       procedure division.
           invoke type MyCounter::SetCount(10)
           set myInstance1 to new type MyCounter
           set myInstance2 to new type MyCounter
           display myInstance1::GetCount()         *> displays 10
           display myInstance2::GetCount()         *> displays 11
           display type MyCounter::GetTotalCount() *> displays 12

       end program.

To use static and instance methods:

  • To declare a static method, use the STATIC keyword. If the method is in a static class, you must specify STATIC.
  • To declare an instance method, don't use the keyword STATIC.
  • To access a static method, you use the name of the class, followed by :: and then the method name. For example: MyCounter::GetTotalCount() as in the above code.
  • To access an instance method, you use the name of the instance object, then :: followed by the method. For example: myInstance1::GetCount() as in the above code.

Instance Method Modifiers

The following modifiers indicate the extent to which the method inherits and is inherited:

ABSTRACT
declares an empty method. To use an abstract method, you must inherit it and include the required code in the subclass.
OVERRIDE

specifies that this method overrides the inherited method of the same name and signature.

REDEFINE

hides a method in a superclass, where the subclass contains the redefine method. The REDEFINE keyword hides the superclass method only when the redefine method is invoked on an item defined as being in the subclass containing the redefine method.

FINAL
prevents a derived class from further overriding the method.

In summary, you can think of the keywords like this:

  • An abstract method provides the name and signature of a method
  • A virtual method is the first implementation of a method
  • An override method is another implementation of a method
  • A final method is the last implementation of a method

Abstract Methods

An abstract method has no implementation. To use an abstract method, you inherit it and in the inheriting subclass, you provide the implementation of the method. An abstract class can contain methods that are not abstract, as well as abstract ones. The methods that aren't abstract can provide a default implementation, which can be overridden by a subclass method. For example:

class-id MyAbstractClass abstract.
       01 myField  value 0 binary-long property.

       method-id AbstractMethod abstract. *> no implementation
       end method.

       method-id NonAbstractMethod.       *> not abstract
       procedure division.
            set myField to 1   *> Default behavior, which can be overridden
       end method.

       end class.

An abstract class can contain methods that are not abstract. These methods can provide a default implementation, which can be overridden by a subclass method.

       class-id MySubClass inherits type MyAbstractClass.

       method-id AbstractMethod override.
       procedure division.
           *> Subclass method implements abstract method
           display "myField is: " self::myField  *> displays 0
       end method.

       method-id NonAbstractMethod override.
       procedure division.
           *> Subclass method overrides method that is not abstract
           set self::myField to 6
           display "myField is: " self::myField  *> displays 6
       end method.

       end class.

To define and use methods in abstract classes:

  • You use the ABSTRACT keyword to define any members that are abstract, and omit it for members that are not abstract. Abstract members must be within an abstract class.
  • The subclass must inherit the abstract superclass, and must contain an implementation of all the abstract members of the superclass. However, the subclass itself can be abstract and in this case, will not contain implementations.
  • The subclass methods must use the keyword OVERRIDE.
  • An abstract method cannot be private. It can be public, protected or internal.

Override Methods

An override method is a method that overrides an inherited virtual method of the same name and signature.

For example, a subclass Circle inherits from a superclass Shape. Both classes contain a Draw method. The Draw method in the Circle subclass overrides the Draw method in the Shape superclass.

       class-id Shape.
       method-id Draw.
           display "let's draw a super shape"
       end method.
       end class.

       class-id Circle inherits type Shape.
       method-id Draw override.
           display "let's draw a circle"
       end method.
       end class.

To define an override method:

  • Specify the OVERRIDE modifier in the method-id header
  • Ensure that the method has the same name and signature as the method to be overridden in the inherited class

You cannot override a final method in the inherited class. You can override only virtual methods (methods not defined as final).

Redefine Methods

The REDEFINE keyword is used to hide a method inherited from a class. To hide an inherited method, declare it in the derived class using the same name and specify REDEFINE.

A redefine method is similar to an override method, in that it is a method with the same name and signature as a method in the superclass. However, unlike an override method, the redefine method might or might not override depending on how it is invoked. When the method is invoked on an item defined as being in the:

  • Superclass, even when that item actually holds an instance of the subclass, the superclass method is executed
  • Subclass - the subclass redefine method is executed and the superclass method is overridden

For example, we have two subclasses Circle and Square, which inherit from the Shapes superclass. All the classes have a Draw method. The Circle class's Draw method overrides the Draw method in the Shapes superclass. The Square class's Draw method redefines the Draw method in the Shapes superclass.

       class-id Shape.
       method-id Draw.
           display "let's draw a super shape"
       end method.
       end class.

       class-id Circle inherits type Shape.
       method-id Draw override.
           display "let's draw a circle"
       end method.
       end class.

       class-id Square inherits type Shape.
       method-id Draw redefine.
           display "let's draw a square"
       end method.
       end class.

You can invoke the Circle and Square classes as follows:

       program-id. RedefineSampleProgram.

       01 myShape type Shape.
       01 myCircle type Circle.
       01 mySquare type Square.

       procedure division.
           set myShape to new type Shape
           set myCircle to new type Circle
           set mySquare to new type Square

           invoke myCircle::Draw   *> Circle Draw method is invoked
           invoke mySquare::Draw   *> Square Draw method is invoked
                                   *> Shape Draw method is hidden, redefined

           set myShape to myCircle *> Superclass instance is set to subclass
           invoke myShape::Draw    *> Circle Draw method is invoked
                                   *> as it overrides Shape Draw method

           set myShape to mySquare *> Superclass instance is set to subclass
           invoke myShape::Draw    *> Shape Draw method is invoked as
                                   *> Square Draw method doesn't override it

       end program.

The above invocations produce the following output:

let’s draw a circle
let’s draw a square
let’s draw a circle
let’s draw a super shape

Another place to use REDEFINE is where the method in the superclass is defined as FINAL and so it cannot be inherited nor overridden. In this case, you can use REDEFINE to hide the subclass method and use the superclass method instead, when polymorphism in use.

Final Methods

A method that is declared as final is prevented from being overridden in any subclasses. This enables a class to inherit a superclass, while preventing a superclass method from being overridden in the subclass.

For example, we have a class MySubClass, which inherits from MySuperClass. MySuperClass has one final method and one virtual (not final) method. The subclass overrides the virtual method, but it cannot inherit or override the final method.

       class-id MySuperClass.

       method-id VirtualMethod. *> Methods are virtual by default
       procedure division.
           display "Virtual method in the superclass"
       end method.

       method-id FinalMethod final. *> Final methods are not virtual
       procedure division.
           display "Final method in the superclass"
       end method.

       end class.

The subclass is defined as follows:

       class-id MySubClass inherits type MySuperClass.

       method-id VirtualMethod override.
       procedure division.
           display "Overridden virtual method in the subclass"
       end method.

      * method-id FinalMethod override.
      *>COBCH0954 Method 'FinalMethod' cannot OVERRIDE a nonvirtual method

       end class.

The classes are invoked as follows:

       program-id FinalOverrideSampleProgram.
       01 mySuper type MySuperClass.
       01 mySub type MySubClass.

       procedure division.
           set mySuper to new type MySuperClass
           invoke mySuper::FinalMethod()
           invoke mySuper::VirtualMethod()

           set mySub to new type MySubClass
           invoke mySub::VirtualMethod()

       end program.

The above sample program produces output as follows:

Final method in the superclass
Virtual method in the superclass
Overridden virtual method in the subclass

Although a final method cannot be overridden in a subclass, it can be redefined in the subclass.

Extension Methods

The EXTENSION keyword declares a method as an extension method.

Extension methods enable you to add methods to existing types without the need to edit or recompile the code. Extension methods appear as additional methods available on an object instance while they are implemented elsewhere.

For example, the following extension method extends the string class, by adding a method to count the number of words in a string:
       class-id MyCount static.
       method-id CountWords extension. *> extension method is implicitly static
       procedure division using str as string
                          returning wordCount as binary-long.
            set wordCount to str::Split(' ')::Length
       end method.
       end class.

To declare an extension method:

  • Use the EXTENSION keyword in the method header.
  • The method must be in a static class that is not nested or generic. The method is implicitly static.
  • In the method body, the first parameter is the type to extend. It is always a value parameter.

There is no special syntax for calling extension methods from managed COBOL. You consume an extension method in the same way as any other method, except you specify the first parameter as the type of the method, using this syntax:

parameter-1::method-name(more parameters)

In JVM COBOL, there are two extensions that are preloaded before compilation:

  • An extension operator for string equality
  • An extension method for substring

These two extensions ensure that managed COBOL produces the same results, regardless of whether it is compiled to JVM COBOL or .NET COBOL. For more detail, see Extension Methods and Operators.

Synchronized Methods

The SYNC modifier locks the values of the arguments sent to the method, so that they do not change while the method is processing.

When an argument is sent to a method and is received as a reference parameter, the value of the parameter and its corresponding sending argument might be updated. Without the SYNC modifier, the value of the sending argument is unknown, while the method is processing.

The SYNC modifier on a method is equivalent to wrapping the whole method in a SYNC statement.

For example:

       01 a binary-long value 20.
       ...
       invoke self::Adjust(a)
       display a                 *> displays 93

       method-id Adjust sync.
       procedure division using reference x as binary-long
           set x to x + 73
       end method.
       end class.

In the above example, the SYNC modifier is applied to the method Adjust(). This ensures that the variables within the method (in this case, the variable x locally, but variable a in the invoking code) cannot be accessed until the method has finished processing.

Invoking a Method

You can invoke a method in two ways: by using the INVOKE statement or by invoking inline using the SET statement.

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Constructors
Access Modifiers
Attributes
Procedure Division
INVOKE Statement
SET Statement
Related information
Extension Methods and Operators
Method Overloading in Managed COBOL
Functions, Methods - in COBOL and C#
Constructors and Deconstructors - in COBOL and C#
Invoking a Method
Extension Methods and Operators


Procedure Division

The procedure division defines the code to be executed, when a type or member is invoked. The procedure division header defines any parameters to pass in to the code and any returning item to pass back.

Context:

    Methods
    Constructors
    Iterators
    Operators

procedure-division

procedure-division-header statement-block

procedure-division-header

attribute-clause attribute-clause attribute-clause attribute-clause attribute-clause

The PARAMS phrase is optional, but must be last.

See the Core sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Constructors


Constructors

A constructor is a class method that is executed when the class is created.

Context:

    Classes
    ValueTypes
    Interfaces
        Type Members

constructor-specification

constructor-header procedure-division

constructor-header

attribute-clause

Example

method-id new.
procedure division.
    set powerLevel to 0
end method.

method-id new.
procedure division using by value powerLevel as binary-long.
    set powerLevel to powerLevel
end method.

Further Information

A constructor is a class method that is executed when the class is created. Constructors are named "new", and do not have a returning item.

A class can define multiple constructors with different arguments.

If no constructor is defined, the Compiler generates a default one.

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Attributes
Methods
Procedure Division
Related information
Functions, Methods - in COBOL and C#
Constructors and Deconstructors - in COBOL and C#


Properties

Properties are members with associated types. They are similar to fields but they have accessors that provide the means to read and write values.

Context:

    Classes
    ValueTypes
    Interfaces
        Type Members

property-specification

property-header procedure-division-header access-modifier statement-block access-modifier statement-block

property-header

type-specifier access-modifier attribute-clause

Example

class-id MyClass.
working-storage section.
01 volume binary-long private.
property-id Volume binary-long.
  getter.
    set property-value to volume
  setter.
    if property-value < 0
      set volume to 0
    else
      set volume to property-value
    end-if
end property.
end class.
property-id PropertyReadOnly string.
  getter.
    set property-value to field-5
end property.

See also the Properties sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Further Information

A property specified using PROPERTY-ID must contain a get or set accessor (or both), using the GETTER and SETTER keywords respectively. The Compiler then generates get_ and set_ methods accordingly.

There are two ways of exposing a field as a property within a COBOL program:

  • The simplest way is to specify the keyword PROPERTY on any data declaration within the program. This automatically sets up two accessor methods for getting and setting the value of the data item. There are optional phrases that follow the PROPERTY keyword that you can use to suppress either the get or the set accessor. You can also use the AS clause to change the external name.
  • The alternative way is to specify a PROPERTY-ID with the GETTER or SETTER phrases to be executed whenever the property is accessed. This mechanism, though slightly more complicated than the PROPERTY keyword, gives you complete control over the statements that are executed when the property is accessed. See PROPERTY Keyword
Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Indexers
Access Modifiers
Attributes
Constraints Paragraph
Fields
Type Specifier
Related information
Properties - in COBOL and C#


Procedure Division Header

The procedure division header defines the parameters passed to a member and also any returning item, the value computed by the member.

Context:

    Procedure Division
    Delegates and Events
    Indexers

procedure-division-header

attribute-clause attribute-clause attribute-clause attribute-clause attribute-clause

The PARAMS phrase is optional, but must be last.

See the Core sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parameters

Parameters are values or variable references that are passed to a method. The actual values of the parameters are specified when the method is invoked. Each parameter and its type is specified in the procedure division header in the USING clause.

When you invoke a method, you specify the parameters in the invocation. The invoked method receives the parameters in the same order as in the invocation. For example:

       invoke type MyClass::MyMethod(a,b)
       ...
       method-id MyMethod.
       procedure division using x as string
                                y as binary-long.
       ...
       end method.

The arguments a and b above are passed to the invoked method, and these correspond to the parameters x and y respectively, in the invoked method. The types of the parameters are specified in the AS phrase of the USING clause.

The following types of parameters can be passed:

  • Value parameters. These are used for input only. Any updates are not passed back to the invoking code.
  • Reference parameters. These are used for both input and output. Unlike a value parameter, when the method finishes, any updates are passed back to the invoking code.
  • Output parameters. These are similar to reference parameters. The main difference is that they don't need to be assigned on entry to the method, but they must be assigned on exit from the method.
  • Returning items. These are for output only .

Parameters are passed by reference by default (except in extension methods where they are passed by value). You can change the default to be value parameters by setting the METHODDEFAULT (VALUE) Compiler directive.

When specifying multiple value parameters, the keyword VALUE is assumed for subsequent consecutive parameters. In the following example, v and vv are passed by value, and the others are passed by reference:

       procedure division using a as binary-long
                          value v as binary-long
                                vv as binary-long
                      reference r as binary-long
                                rr as binary-long.

VALUE Parameters

A value parameter corresponds to a local variable. Its initial value is established when the method is invoked. When the method processes, it can change the value of the local variable. When the method finishes, the original argument in the invoking code remains unchanged. For example:

       declare a as binary-long=3.
       invoke type MyUtils::CheckByValue(a)
       display a              *> a is still 3

       method-id CheckByValue static.
       procedure division using value x as binary-long.
           set x to x + 1          *> x is now 4
       end method.

In the above example, the parameter a is passed by value. The invoked method increments the value. However, on return to the invoking code, the variable a remains unchanged.

Usage:

  • Use a value parameter for input to a method. Use a value parameter when you don't need to output the parameter from the method.
  • To pass a parameter by value, specify the VALUE keyword for the parameter in the method signature in the procedure division using clause. When specifying multiple value parameters, the keyword VALUE is assumed for subsequent consecutive parameters.
  • Value parameters that are managed types are exposed as the corresponding COBOL types. For example, signed numeric items with no implied decimal point are exposed as int8, int16, int32, int64, depending on the size.

    Value parameters that are not managed types but are other COBOL data types are exposed as defined in the COBOL Type Compatibility table. For example: PIC X fields and groups are exposed as string. See Type Compatibility of Managed COBOL with Other Managed Languages.

REFERENCE Parameters

A reference parameter contains a reference to the required value rather than the value itself.

A reference parameter corresponds to a local variable, whose value is established when the method is invoked, and whose value can change while the method is processing. Unlike a value parameter, when the method finishes, the value of the original argument in the invoking code is changed accordingly.

Note, that a reference parameter does not necessarily create a copy of the variable local to the method. Instead, it might refer to the original argument in the location in use when the method was invoked. While the method is processing, the variable can change locally, but the original argument in the invoking code does not necessarily change. It might change or it might not. The value of the original argument is unknown until the method finishes. When the method finishes and returns to the invoking code, the value of the original argument in the invoking code is updated.

For example:

       declare a as binary-long=3.
       invoke type MyUtils::CheckByReference(a)
       display a              *> a is now 4

       method-id CheckByReference static.
       procedure division using reference x as binary-long.
           set x to x + 1          *> x is now 4
       end method.

In the above example, the parameter a is passed by reference. The invoked method increments the variable a. On return to the invoking code, the variable a is updated with the incremented value.

Usage:

  • Use a reference parameter for both input and output. Use it to input a value to the method and to output the resulting value to the invoking code.
  • Parameters are passed by reference by default, except where the previous parameter in the method signature is not a reference parameter. In this case, the keyword REFERENCE is required.
  • While the method is running, the value of a sending argument that corresponds to a reference parameter might change. The value is unknown. To lock the sending argument so that it does not change while the method is running, use the SYNC clause. When the method finishes, the lock is released and the sending argument is updated as necessary.
  • Reference parameters that refer to managed types are exposed directly as managed pointers to the corresponding managed type.

    Reference parameters that do not correspond to managed types (such as PIC X fields, groups, numeric fields other than binary-long and so on) are exposed as COBOL pointers .

OUTPUT Parameters

Like reference parameters, output parameters don't create a new storage location, but use the storage location of the variable specified on the invocation.

Output parameters are very similar to reference parameters. The main difference is that they must be assigned before returning to the invoking code.

For example:

       declare a as binary-long=4.
       declare b as binary-long.
       invoke type MyUtils::CheckByOutput(a,b)
       display "Value Param a = " &  a          *> a is still 4
       display "Output Param b = " & b          *> b is 16

       method-id CheckByOutput static.
       procedure division using value x as binary-long
                               output y as binary-long.
           set x to x + 10     *> x is now 14
           set y to x + 2      *> y is now 16
       end method.

In the above example, two parameters are passed, where variable b is not initialized and passed by output. The method CheckByOutput updates the variables x and y. On return, the output variable b is updated but the variable a remains unchanged.

Usage:

  • Typically used in methods where there are multiple return values.
  • Can optionally be initialized or assigned a value for input to the method.
  • Must be assigned for return, when the method finishes.
  • Output parameters that refer to managed types are exposed directly as managed pointers to the corresponding managed type.

    Output parameters that do not correspond to managed types (such as PIC X fields, groups, numeric fields other than binary-long and so on) are exposed as COBOL pointers .

RETURNING Items

Returning items pass the results of a method back to the invoking code. For example:

        procedure division returning myReturn as condition-value.

Each method can have only one returning item. However you can package a set of return information in an object. For example, the following AddMins() method receives and returns an instance object reference myTime :

       program-id ParamAsObject.
       01 myTime type MyTimer value new MyTimer(5 45).

       procedure division.
           set myTime to myTime::AddMins(myTime 70) *> inline invocation
           display myTime::anHour & ":" myTime::aMin
       end program.

       class-id MyTimer.
       01 anHour binary-long property.  *> property keyword enables get/set
       01 aMin binary-long property.
       ...
       method-id AddMins.
       01 h binary-long value 0.
       01 m binary-long value 0.
       procedure division using value a as type MyTimer
                                      b as binary-long
                            returning c as type MyTimer.
           set b to a::aMin + b
           divide b by 60 giving h remainder m
           set c to new MyTimer(a::anHour + h , m)
       end method.

       end class.

The example above shows the inline invocation syntax, in the statement:

       set myTime to myTime::AddMins(myTime 70)

Here, the invoked method AddMins() returns an item, myTime. The invoked method specifies the returning item in its signature.

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
INVOKE Statement
Local Data Item Declaration
Related information
Type Compatibility of Managed COBOL with Other Managed Languages
Types and Type Conversion
Type Mappings from Native COBOL to Managed Code


Indexers

Indexers resemble properties except that their accessors take parameters. Indexers allow instances of a class or valuetype to be indexed just like arrays.

Context:

    Classes
    ValueTypes
    Interfaces
        Type Members

indexer-specification

indexer-header procedure-division-header access-modifier statement-block access-modifier statement-block

indexer-header

type-specifier access-modifier attribute-clause

Example

In the following example, a class is defined and provided with simple getter and setters as a means of assigning and retrieving values. Square brackets used to access arrays, use 0-based indexing. Round brackets use 1-based indexing.

       class-id SimpleIndexer.
       01 myArray string occurs 100.

       indexer-id string.
       procedure division using by value i as binary-long.
       getter.
           set property-value to myArray[i]
       setter.
           set myArray[i] to property-value
       end indexer.

       end class.

See also the IndexerDemo.cbl in the Properties sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Access Modifiers
Attributes
Properties
Iterators
Type Specifier
Related information
Arrays - in COBOL and C#
Iterators - in COBOL and C#


Operators

A set of default operators are predefined and implemented. You can overload an operator and define your own behavior for it.

Context:

    Classes
    ValueTypes
    Interfaces
        Type Members

operator-specification

operator-header procedure-division

operator-header

operator-name attribute-clause

operator-name

binary-operator
comparison-operator arithmetic-operator bitwise-operator
  • =
  • <>
  • <=
  • <
  • >=
  • >
  • +
  • -
  • *
  • /
  • **
  • B-AND
  • B-OR
  • B-XOR
  • B-NOT
  • B-LEFT
  • B-RIGHT
unary-operator
  • +
  • -
  • EXPLICIT
  • IMPLICIT

Example

       operator-id + .
       01 iMins binary-long.
       01 iHour binary-long.
       procedure division
             ...
       end operator.

See also the Operator Overloading sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Conversion Operators, IMPLICIT and EXPLICIT

Conversion operators can be overloaded, so that the appropriate conversion operator is used according to the parameter types in the calling code. The operator with the matching signature (procedure division using clause) is executed. For example, where a data item of type Timer requires converting to binary-long, the operator used is the operator with an input parameter of type Timer and output parameter of binary-long.

To define and use conversion operators:

  • Use the IMPLICIT or EXPLICIT keyword on the operator-id header
  • The operator converts the types specified in the operator's signature (its procedure division using clause)
  • The types converted can be either classes or value-types, but not interfaces
  • Types that inherits from one another cannot be converted using a conversion operator
  • The same conversion cannot be defined twice: once as implicit and as explicit

Operator Overloading

You can overload operators to provide alternative behavior, or behavior for different operand types. For example, where a Timer type is expressed as hours and minutes, you could define one + (plus) operator to add two Timers and another + (plus) operator to add a number of minutes to a Timer type.

To declare overloaded operators:

  • Overloaded operators are public and static. They cannot be defined as abstract, final or override.
  • The parameters in the operator's signature must be declared by value.
  • The following operators can be overloaded, and require the following operator-id signatures:
Operators that can be overloaded | Overload operator-id signature | Notes
Conditional operators, such as: t1 = t2, t1 equals t2 | value t1 t2 returning condition-value | Conditional operators must be specified in pairs. If you declare an equality operator (=), you must also declare an inequality operator (<>).
Binary operators, such as: t1 + t2 | value t1 t2 returning t3 | Binary operators must have two arguments. For binary operators, you might need to specify a pair of operators to enable the two operands to be passed in either order.
Unary operators, such as: -t1 | value t1 returning t3 | Unary overloaded operators can have only one argument.
Logical operators, such as: t1 b-or | value t1 t2 returning t3 |
Shift operators, such as: t1 b-right | value t1 t2 returning t3 |

While the arithmetic operators for addition, subtraction, multiplication and division can all be overloaded, their verb equivalents cannot. For example, ADD in the following statement cannot be overloaded:

       add a to b giving c

To use overloaded operators, the overloaded operator must be in scope.

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Attributes
Type Specifier
Related information
Operators - in COBOL and C#
Operator Overloading in Managed COBOL


Iterators

An iterator is a section of code that returns an ordered sequence of values. You can create an iterator by defining a member as an iterator, using iterator-id.

Context:

    Classes
    ValueTypes
    Interfaces
        Type Members

iterator-specification

iterator-header procedure-division

iterator-header

access-modifier attribute-clause

Example

Here we use an iterator-id paragraph GetEven to return the even numbers in the FibonacciArray

    01 m-FibonacciArray binary-long occurs any static.
    01 anyNumber    binary-long.
    procedure division
       ...
       set content of m-FibonacciArray to (1 2 3 5 8 13 21 34 55 89 144)

        display "Even numbers"
        perform varying evenNumbers through iterators::GetEven
            display evenNumbers
        end-perform

    iterator-id GetEven static.
    01 i binary-long.
    procedure division yielding res as binary-long.
        perform varying i through m-FibonacciArray
            if i b-and 1 = 0
                set res to i
                goback
            end-if
        end-perform
        stop iterator *> stops the iterator immediately
    end iterator.     *> stops the iterator implicitly

See also the Iterators sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Further information

The STOP ITERATOR statement stops the iteration.

This statement is not needed if the next statement is END ITERATOR.

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Indexers
Access Modifiers
Attributes
Related information
Iterators - in COBOL and C#


ValueTypes

Value types can contain data members and function members, similar to classes. The difference is that value types store the data as values and don't require heap allocation.

Context:

    Program Structure
        Types

valuetype-specification

valuetype-header constraints-paragraph static-or-instance-field static-or-instance-member

valuetype-header

access-modifier type-specifier attribute-clause

Example

valuetype-id StudentRecord.
01 aName string public.
01 gpa float-short public.
method-id new.
procedure division using by value nam as string,
                                  gpa as float-short.
    set aName to nam
    set self::"gpa" to gpa
end method.
end valuetype.

class-id a.
method-id main static.
local-storage section.
01 stu type StudentRecord value new StudentRecord("Bob", 3.5).
01 stu2 type StudentRecord.
procedure division.
    set stu2 to stu
    set stu2::name to "Sue"
    display stu::name   *> Prints Bob
    display stu2::name  *> Prints Sue
end method.
end class.

See also the ValueTypes sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET.

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Access Modifiers
Attributes
Constraints Paragraph
Related information
Structures, Value Types - in COBOL and C#


Interfaces

An interface is a list of instance methods specifying names and signatures but without implementation.

Context:

    Program Structure
        Types

interface-specification

interface-header constraints-paragraph interface-member

interface-header

access-modifier type-specifier attribute-clause generic-using-phrase

interface-member

method-specification property-specification indexer-specification

Example

*> Interface definition
interface-id IAlarmClock.
  ...
end interface.

*> Inheriting an interface
interface-id IAlarmClock inherits type IClock.
  ...
end interface.

*> Interface implementation
class-id WristWatch implements type IAlarmClock, type ITimer.
   ...
end class.

See also the Interfaces sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET.

About Interfaces

An interface is a list of instance methods specifying names and signatures but without implementation.

When a program declares that it implements a particular interface this means that the program is required to have implementations for all the methods defined in the interface. To implement an interface you use the IMPLEMENTS phrase of the OBJECT clause in a class definition to declare that a program provides an implementation for the specified interface. You can also declare an object reference to this interface type.

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Access Modifiers
Attributes
Constraints Paragraph
Related information
Interfaces - in COBOL and C#


Delegates and Events

The delegate system is the object-oriented equivalent of the procedure pointer and is a type safe solution. The use of procedure or function pointers is a common enough occurrence in many languages, and in .NET they are generally used as a mechanism for one software component to notify another about an event which has occurred.

Context:

    Program Structure
        Types

delegate-specification

delegate-header procedure-division-header

delegate-header

access-modifier attribute-clause

Example

delegate-id MsgArrivedEventHandler.
procedure division using by value msg as string.
end delegate.

class-id a.
01 MsgArrivedEvent type MsgArrivedEventHandler event static.
    *> Delegates must be used with events in COBOL

method-id main static.
*> Combining delegates
    set MsgArrivedEvent to MsgArrivedEvent + method self::My_MsgArrivedEventCallback
       *> Throws exception if obj is null
    invoke run MsgArrivedEvent("Test message")
    set MsgArrivedEvent to MsgArrivedEvent - method self::My_MsgArrivedEventCallback

*> Attaching to an event
    attach method self::My_MsgArrivedEventCallback to self::MsgArrivedEvent
    invoke run MsgArrivedEvent("Test message 2")
end method.

method-id My_MsgArrivedEventCallback static.
procedure division using by value str as string.
    display str
end method.
end class.

See also the Delegates and Events samples, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET.

Further Information

A delegate is a class that can hold a reference to a method and, in the case of an instance method, an object on which that method can be invoked.

Once an instance of a delegate class has been created, it can be invoked, at which point the referenced method is invoked on the stored instance.

A delegate type can only hold references to methods of a particular signature, so creating and invoking delegates is type safe.

To define a delegate in COBOL, you use the DELEGATE-ID keyword, and the PROCEDURE DIVISION header to specify the signature. For example, to declare a delegate that has a string parameter and returns a binary-long:

delegate-id del.
procedure division using by value s1 as string returning n1 as binary-long.
end delegate.
Method Groups

A method group is a method invocation expression preceded by the keyword METHOD, and without any parameters. When a method group is specified, it denotes one of the set of methods with the specified name in the specified class.

An implicit conversion exists between a method group and a specific delegate type, if one of the methods identified by the method group has a signature which is compatible with that delegate type.

For example, to create an instance of the delegate MyDelegate you declared above, that points to a suitable method:

01 d type MyDelegate.
01 c type Class1.
...
set d to method c::m

class-id Class1.
method-id m.
procedure division using by value s1 as string returning n1 as binary-long.
end method.

method-id m.
procedure division using by value s1 as string s2 as string returning n1 as binary-long.
end method.

end class.

In the example above, the SET statement automatically selects the first overload of the method m as it has a signature which is compatible with that of the delegate type MyDelegate.

A method group can also be used as a parameter to a method, when that method has an argument of a compatible delegate type. Again, an implicit conversion from the method group to the delegate type will take place, and that delegate will be passed as the parameter to the target method.

Anonymous methods

You can set a delegate to point to a piece of code, without formally setting that code up as a specific method. Such a piece of code is called an Anonymous Method, and you use the keywords DELEGATE and END-DELEGATE to specify it.

You specify any parameters and return values with the words USING and RETURNING attached to the word DELEGATE.

The following shows how you can attach an anonymous method to the delegate MyDelegate you created in the previous examples:

01 d type MyDelegate.
set d to delegate using s1 as string
                                returning n1 as binary-long
                  set n1 to s1::Length
              end-delegate.
Invoking delegates

To invoke a delegate after it has been created, you use the keyword RUN followed by the delegate name, and any parameters enclosed in parentheses. For example, to run the delegate d created above and displaying the results, type:

display run d(“Hello”)

This statement causes the anonymous method to be invoked and return a value of 5. This value is then displayed.

Example of creating and invoking delegates
       delegate-id del.
       procedure division using by value s1 as string returning n1 as binary-long.
       end delegate.

       class-id a.
       method-id main static.
       01 d type del.
       01 c type Class1 value new Class1.

       set d to method c::m
       display run d("ABC")

       set d to delegate using s1 as string
                         returning n1 as binary-long
                    set n1 to s1::Length
                end-delegate
       display run d("XYZ")
       end method.
       end class.

       class-id Class1.
       method-id m.
       procedure division using by value s1 as string returning n1 as binary-long.
           set n1 to size of s1 + 3
       end method.
       method-id m.
       procedure division using by value s1 as string s2 as string returning n1 as binary-long.
       end method.
       end class.
Combining delegates

A single delegate can hold references to more than one object/method pairs. In such cases, at the time when the delegate is invoked, each one of the methods will be invoked in the order in which they were added to the delegate.

  • You use the operator '+' to add a method group, anonymous method or another delegate to a delegate.
  • You use the operator '-' to remove methods from a delegate.
Note: At least one side of such an expression must be an instance of a delegate type.

For example:

       class-id DelegateCombining.
       method-id main static.
       01 cd1 type D.
       01 cd2 type D.
       01 cd3 type D.
       01 cd4 type D.
       01 c type C value new C.
           set cd1 to method type C::M1
           invoke cd1(-1)
           set cd2 to method type C::M2
           invoke cd2(-2)
           set cd3 to cd 2 + method type C::M1
           invoke cd3(10)
           set cd3 to method type C::M1 + cd3
           invoke cd3(20)

           set cd4 to method c::M3
           set cd3 to cd3 + method c::M3
           invoke cd3(30)

           set cd3 to cd3 - method type C::M1
           invoke cd3(40)
           set cd3 to cd3 - method c::M3
           invoke cd3(50)
           set cd3 to cd3 - method type C::M2
           invoke cd3(60)
           set cd3 to cd3 - cd2
           invoke cd3(60)
           set cd3 to cd3 - cd1
           try
               invoke cd3(70)
           catch
               display "null reference exception caught"
           end-try
           set cd3 to cd3 - cd1
           display "Hello"

           set cd1 to method type C::M1
           set cd2 to method type C::M2
           set cd3 to cd1 + cd2 + cd2 + cd1
           invoke cd3(80)
           set cd3 to cd3 - cd1
           invoke cd3(90)
           set cd3 to cd1 + cd2 + cd2 + cd1
           set cd3 to cd3 - (cd1 + cd2)
           invoke cd3(100)
           set cd3 to cd1 + cd2 + cd2 + cd1
           set cd3 to cd3 - (cd2 + cd2)
           invoke cd3(110)
           set cd3 to cd1 + cd2 + cd2 + cd1
           set cd3 to cd3 - (cd2 + cd1)
           invoke cd3(120)
           set cd3 to cd1 + cd2 + cd2 + cd1
           set cd3 to cd3 - (cd1 + cd1)
           invoke cd3(130)

       end method.
       end class.

       delegate-id D.
       procedure division using by value i as binary-long.
       end delegate.

       class-id C.
       method-id M1 static.
       procedure division using by value i as binary-long.
           display "C::M1 --> " i
       end method.
       method-id M2 static.
       procedure division using by value i as binary-long.
           display "C::M2 --> " i
       end method.
       method-id M3.
       procedure division using by value i as binary-long.
           display "C::M3 --> " i
       end method.
       end class.

Events

An event is a way in which a class can provide notifications when something of interest happens, such as a key being pressed in a GUI environment.

To define an event, you add the keyword EVENT to a delegate field. For example:

       01 ChangeEvent type ChangeDelegate event public.

Delegates of the same type, or compatible method groups or anonymous methods can be attached to the event, and will be invoked at the time when the owning class of the event invokes the backing delegate.

The relationship between an event and its backing delegate is very similar to the relationship between a property and its backing storage.

Attaching a method or a delegate to an event

You use the ATTACH statement to attach a delegate, method group or an anonymous method to an event:

ATTACH {delegate-instance}    TO event-expression
                {method-group}
                {anonymous-method}

For example:

       01 names type myList.
       01 del type ChangeDelegate.
       procedure division.
           set names to new myList
           attach method self::ListChanged to names::ChangeEvent
           set del to method self::ListChanged
           attach del to names::ChangeEvent
To detach a method or a delegate from an event

To detach a delegate or method group from an event use the DETACH statement:

DETACH {delegate-instance}    FROM  event-expression
                {method-group}

For example:

           detach del from names::ChangeEvent
           detach method self::ListChanged from names::ChangeEvent

Further Examples

See also the Delegates sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET.

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Access Modifiers
Attributes
Fields
Related information
Delegates and Events - in COBOL and C#


Enums

An enumeration represents a list of constant values, such as values for the days of the week. You can declare an enum type that defines the values and symbolic names for them. You can then refer to the values by name.

Context:

    Program Structure
        Types

enum-specification

enum-header type-specifier enum-constant

enum-header

access-modifier attribute-clause

enum-constant

type-specifier

Example

enum-id Action public.
working-storage section.
01 binary-long.         *> Underlying type for the enum.
                        *> binary-long is the default
    78 Starter value 0. *> Declare enum values as level-78 items
    78 Stop    value 1.
    78 Rewind  value 2.
    78 Forward value 3.
end enum.

See also the Enums sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Further Information

The Compiler adds a static method called 'values' that returns an array containing the values of the enum. You can use this method together with the PERFORM THROUGH construct to iterate over the values of an enum type.

The enum-header is followed by a working-storage section consisting of:

  • A single numeric field of one of the predefined types. By default, this is binary-long.
  • Any number of level 78 items defining the values for the enum. The default value of the first item is 0 and the values of subsequent items are incremented by default.
Note:

In COBOL for .NET, but not JVM, you need to set the attribute System.FlagsAttribute. This attribute applied to an enum means that the distinct values are to be regarded as bit settings, and can therefore be combined. For example:

enum-id DaysOfWeek attribute System.FlagsAttribute.
Note:

In COBOL for JVM, as in Java, the enum declaration defines an enum class, which is a class that derives from java.lang.Enum. In Java, this enum class can include methods and other fields explicitly declared by the user, whereas this is not allowed in COBOL.

Parent topic: Structural Syntax Elements - Alphabetic List
Related reference
Access Modifiers
Attributes
Related information
Enumeration - in COBOL and C#


Structural Syntax Elements - Alphabetic List

  • Classes
    A class defines the data members and function members for object instances that are created from that class. Managed COBOL allows a class to inherit from one or more other classes.
  • Constructors
    A constructor is a class method that is executed when the class is created.
  • Delegates and Events
    The delegate system is the object-oriented equivalent of the procedure pointer and is a type safe solution. The use of procedure or function pointers is a common enough occurrence in many languages, and in .NET they are generally used as a mechanism for one software component to notify another about an event which has occurred.
  • Enums
    An enumeration represents a list of constant values, such as values for the days of the week. You can declare an enum type that defines the values and symbolic names for them. You can then refer to the values by name.
  • Fields
    A class, valuetype and interface can define a set of static or instance fields.
  • Indexers
    Indexers resemble properties except that their accessors take parameters. Indexers allow instances of a class or valuetype to be indexed just like arrays.
  • Interfaces
    An interface is a list of instance methods specifying names and signatures but without implementation.
  • Iterators
    An iterator is a section of code that returns an ordered sequence of values. You can create an iterator by defining a member as an iterator, using iterator-id.
  • Methods
    A method defines a block of code to be executed when the method is invoked.
  • Operators
    A set of default operators are predefined and implemented. You can overload an operator and define your own behavior for it.
  • Procedure Division
    The procedure division defines the code to be executed, when a type or member is invoked. The procedure division header defines any parameters to pass in to the code and any returning item to pass back.
  • Procedure Division Header
    The procedure division header defines the parameters passed to a member and also any returning item, the value computed by the member.
  • Properties
    Properties are members with associated types. They are similar to fields but they have accessors that provide the means to read and write values.
  • Type Members
    A class, valuetype or interface can define a set of members, such as methods and properties.
  • ValueTypes
    Value types can contain data members and function members, similar to classes. The difference is that value types store the data as values and don't require heap allocation.
Parent topic: Managed COBOL Reference


Common Phrases

  • Access Modifiers
    The access modifiers of an item control the visibility (accessibility) of the item to other code. For example, you can call public methods from anywhere, whereas private methods can be called only from other methods within the same type.
  • Attributes
    Attributes are used to provide additional information about elements within your program.
  • Constraints Paragraph
    The Constraints paragraph allows specification of properties of parameters of a generic type or method, and therefore allows the use of methods or properties on data items whose type is specified as that parameter.
  • Expressions
    An expression is a sequence of operators and operands.
  • Generic Using Phrase
    Generic types and methods can be defined in COBOL with the USING phrase.
  • Local Data Item Declaration
    Local data items are data items (also known as variables) that are declared in the procedure division body.
  • Type Specifier
    A type specifier is a declaration of a type, such as a class, interface, enum and so on.
Parent topic: Managed COBOL Reference


Access Modifiers

The access modifiers of an item control the visibility (accessibility) of the item to other code. For example, you can call public methods from anywhere, whereas private methods can be called only from other methods within the same type.

Context:

    Classes
    ValueTypes
    Interfaces
    Delegates and Events
    Enums

    Fields

    Methods
    Properties
    Indexers
    Iterators

access-modifier

Further Information

By default, all types and members are PUBLIC, with the exception of fields which are PRIVATE.

The modifier affects the visibility of an item as follows:

Modifier: | Item is visible:
PUBLIC | always
PRIVATE | when the calling type is the same as the target type
PROTECTED | when the calling type inherits from the target type.
INTERNAL | when the calling type is in the same assembly as the target
PROTECTED INTERNAL or INTERNAL PROTECTED | when the calling type derives from the target type, or the calling type is in the same assembly as the target
PUBLIC
Indicates that this item may be accessed from any code.
PRIVATE
Indicates that this item may be accessed only from within the containing type.
PROTECTED
Indicates that this item may be accessed only from within the containing type or from a subtype that inherits from the containing type. You cannot specify PROTECTED on an abstract member. PROTECTED restricts access within an inheritance tree. For example, a protected field in a superclass can be accessed from any subclass, but it can't be accessed from a class outside the inheritance tree.
INTERNAL
Indicates that this item may be accessed only from within the current compilation unit.
PROTECTED INTERNAL or INTERNAL PROTECTED
Indicates that this item may be accessed only from within the containing type, from a subtype that inherits from the containing type, or from within the current compilation unit.
Parent topic: Common Phrases
Related reference
Constraints Paragraph
Classes
Delegates and Events
Enums
Indexers
Interfaces
Iterators
Properties
ValueTypes
Fields
Related information
Comparison of COBOL with Other Managed Languages


Attributes

Attributes are used to provide additional information about elements within your program.

Context:

    Classes
    ValueTypes
    Interfaces
    Delegates and Events
    Enums

    Fields

    Methods
    Constructors
    Properties
    Indexers
    Operators
    Iterators

attribute-clause

constructor-parameters property-name = property-value

Example

*> Define attributes on a class
class-id MyClass
          attribute WebService(name Description = "My service")
          attribute Obsolete.

*> Define attributes on a field
01 a binary-long attribute XmlAttribute("UpperB")
          attribute Obsolete static.

*> Define attributes on a property
*> Note that in this case, the attributes must follow
*> the reserved word PROPERTY
01 b binary-long property
          attribute XmlAttribute("UpperB")
          attribute Obsolete static.

*> Define attributes on an event
*> Note that the attributes must follow
*> the reserved word EVENT.
01 d type fred event
          attribute Obsolete static.

*> Define attributes on a method
method-id main
          attribute Obsolete static.
procedure division
    move 999 to a
    display a

end method.

*> Define attributes on a method parameter and return type
method-id stat static.
procedure division
          using by value l1 as binary-long
                   attribute CLSCompliant(true)
                   attribute MarshalAs(3)
          returning l2 as binary-long
                   attribute CLSCompliant(true)
                   attribute MarshalAs(2).
    move 999 to a
    display a
    set d to null
end method.

*> Define attributes on a property
method-id set property prop
          attribute Obsolete static.
procedure division using by value l1 as binary-long.
    move l1 to a
end method.

end class.

*> Define attribute on a delegate
delegate-id fred attribute Obsolete.
procedure division using by value l1 as binary-long.
end delegate.

See also the Custom Attributes sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET.

To Specify Attributes

You can specify attributes using:

constructor parameters
These specify the parameters of a constructor for that attribute. The constructor parameters used in the attribute specification must match a constructor defined by the attribute. In the following example, the constructor expects a single parameter of type string:
 01 a binary-long attribute xml("UpperB").
NAME property-name = property-value
These are named parameters and correspond to properties defined on the attribute class. The named parameters must match properties defined by the attribute. In the following example, Description is a property of type string defined for the attribute class WebService:
attribute WebService(NAME Description="My service")

About Attributes

Attributes (also known as custom attributes) are used to provide additional information about elements within your program. Attributes may be used to describe methods, data items, properties, events, delegates, method parameters, assemblies, classes and method return values.

Much of the syntax used in a COBOL program describes program elements, such as the visibility of methods and fields (such as PUBLIC, PRIVATE and PROTECTED). All these descriptions are embedded as ‘Metadata’ into the dll or exe file output by the Compiler, and can be interrogated by other programs using Reflection. Attributes are a way of adding additional metadata to program elements in a way that is open ended and unlimited.

The attribute specified becomes part of the metadata describing the subject of the entry and is visible to a reflector.

Parent topic: Common Phrases
Related reference
Constraints Paragraph
Classes
Constructors
Delegates and Events
Enums
Indexers
Interfaces
Iterators
Operators
Properties
ValueTypes
Fields
Related information
Attributes - in COBOL and C#


Expressions

An expression is a sequence of operators and operands.

expression

unary-expression binary-expression

unary-expression

unary-operator

binary-expression

binary-operator

method-invocation-expression

type-specifier method-arguments

Where:

method-arguments
The method arguments are values or variable references that are passed to a method. The actual values of the arguments are specified when the method is invoked. Each argument and its type is specified in the method’s procedure division header in the USING clause.

When you invoke a method, you specify the arguments in the invocation. The invoked method receives the arguments in the same order as in the invocation.

subscript-expression

[ subscript ] ( subscript )

Where:

[ subscript ]
Square brackets [ ] indicate that the subscript is zero based. For example:
     myArray[5]   *> sixth item in the array

Square brackets can also be used to pass the parameters to an indexer expression.

( subscript )
Round parentheses ( ) indicate that the subscript is one based. For example:
     myArray(5)   *> fifth item in the array

literal

identifier

Parent topic: Common Phrases


Generic Using Phrase

Generic types and methods can be defined in COBOL with the USING phrase.

Context:

    Classes
    ValueTypes
    Interfaces
    Methods

generic-using-phrase

generic-argument

generic-argument

generic-argument conventionally has a single character upper case name such as T and U.

Example

In this example, the main method finds and displays the greater and the smaller number from two ones. T is a generic argument to the Min method, which in this case is a static generic method. The Min method expects two parameters both of which should be of the same type as the generic parameter. The CompareTo method may be invoked since T is known to implement the IComparable interface.

       class-id GenericMath.

       method-id main static.
       01 n1 binary-double.
       01 n2 binary-double.
           set n1 to 999
           set n2 to 100
           display n1 space n2
           display self::Min[binary-double](n1 n2)
           display self::Max[binary-double](n1 n2)
           goback.
       end method.
       method-id Min using T static.
       constraints.
           constrain T implements type System.IComparable.
       procedure division using by value item1 as T item2 as T
                      returning res as T.
           if item1::CompareTo(item2) < 0
               set res to item1
           else
               set res to item2
           end-if
       end method.
       method-id Max using T static.
       constraints.
           constrain T implements type System.IComparable.
       procedure division using by value item1 as T item2 as T
                      returning res as T.
           if item1::CompareTo(item2) < 0
               set res to item2
           else
               set res to item1
           end-if
       end method.

       end class.

See also the Generics samples, which are available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET.

Parent topic: Common Phrases
Related reference
Constraints Paragraph
Related information
Generics, Defining - in COBOL and C#


Local Data Item Declaration

Local data items are data items (also known as variables) that are declared in the procedure division body.

Context

    Procedure Division
        DECLARE Statement
        PERFORM Statement
        TRY Statement

local-declaration

type-specifier

Example

       declare i1 as binary-long
       display i1

       *>   Optionally, the variables can be initialised inline
        declare c2 as condition-value = true
        display c2

        declare string-list2 as string occurs 3 = table of string("Bill", "Ben", "LittleWeed")

      **************************************************************************
      * Iteration Variables
      **************************************************************************

      *>   A variable can be declared at the point of use in an iterator.
      *>   In this case the scope of i will be until the end-perform.
           perform varying i as binary-long from 1 by 1 until i > 10
               display i
           end-perform

      **************************************************************************
      * Exception Variables
      **************************************************************************

      *>   The example below shows that you can declare e at the point of use.
      *>   It is in scope until the end-try.
           try
               display "exception test"
           catch e as type Exception
               display e::Message
           end-try

See also the Local Variables sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Further Information

The scope of any inline local variable is from the point of declaration until the end of the innermost containing block, where paragraphs, sections and the whole method are considered to be blocks.

Parent topic: Common Phrases
Related reference
DECLARE Statement
Type Specifier
Procedure Division Header
Fields
Related information
Data Types - in COBOL and C#


Type Specifier

A type specifier is a declaration of a type, such as a class, interface, enum and so on.

Context:

    Classes
    ValueTypes
    Interfaces
    Enums
    Properties
    Indexers
    Fields

type-specifier

simple-type-specifier

simple-type-specifier

predefined-type-specifier

predefined-type-specifier

Example

Predefined Types
  01 dAmount  decimal.
  01 asNames string occurs 5.
  01 abFigures binary-long occurs any.
TYPE keyword
  01 objMyType type MyType.
  01 objDataTime type DateTime.        *> .NET COBOL
  01 objDataTime type java.util.Date.  *> JVM COBOL

Where:

  • objMyType is defined as an object of type MyType
  • objDataTime is defined as an object type DateTime in .NET COBOL or java.util.Date in JVM COBOL.

Long Type Names

To define a namespace to represent long class names so that you need to type a short name only, use the ILUSING directive.

Type Compatibility with Managed Types

All the predefined COBOL data types and any further managed types that you define are mapped onto the corresponding native managed type (.NET or JVM), but they must conform to the following rules. They:

  • Must be declared at 01 (or 77) level
  • Must have no REDEFINES or RENAMES
  • Must never be the subject of reference modification
  • Must never be the subject of the ADDRESS OF clause
  • May use format 3 of the OCCURS clause to declare an array

Any COBOL data item that does not follow these rules, or is of any other category, is not considered to be a managed type (.NET or JVM) and is allocated by the Compiler within an internally managed byte array. COBOL pointer data items always point into one of these byte arrays.

Generic Types

In .NET COBOL, to refer to a generic type using the TYPE literal syntax, you enumerate the generic parameters within square brackets. The following example declares myNames as an item of type Dictionary with both generic parameters set to string (System.String):

myNames type System.Collections.Generic.Dictionary[string, string].
Parent topic: Common Phrases
Related reference
Indexers
Operators
Properties
Local Data Item Declaration
Fields
Related information
Operator Overloading in Managed COBOL
String Handling in Managed COBOL
Types and Type Conversion
Type Compatibility of Managed COBOL with Other Managed Languages
Type Mappings from Native COBOL to Managed Code


Statements - Alphabetic List

  • Statements
  • ACCEPT Statement
    Takes data keyed at the console or supplied by the operating system and makes it available to the program in a specified data item.
  • ADD Statement
    Adds two or more numeric operands and stores the result.
  • Attach Statement
    Attaches a delegate, a method group or an anonymous method to an event.
  • CREATE Collection Statement
    Creates or constructs an instance of a list or dictionary.
  • COMPUTE Statement
    Assigns to one or more data items the value of an arithmetic expression.
  • CONTINUE Statement
    The CONTINUE statement is a no operation statement, indicating that no executable statement is present.
  • DECLARE Statement
    Declares one or more local variables within the procedure division body. The scope of any inline local variable is from the point of declaration until the end of the innermost containing block, where paragraphs, sections and the whole method are considered to be blocks.
  • DELETE Collection Statement
    Deletes an element from the list or dictionary.
  • Detach Statement
    Detaches a delegate or a method group from an event.
  • DISPLAY Statement
    Displays the specified data items.
  • DIVIDE Statement
    Divides one numeric data item into others and sets the values of data items equal to the quotient and remainder.
  • EVALUATE Statement
    Describes a multi-branch, multi-join structure, which can evaluate multiple conditions. The subsequent action of the run-time element depends on the results of these evaluations.
  • EXIT Statement
    Causes an exit from a perform loop, method or iterator.
  • GOBACK Statement
    Causes a return from a method.
  • IF Statement
    Evaluates a condition and takes subsequent action depending on whether the value of the condition is true or false.
  • INVOKE Statement
    Invokes a method.
  • MOVE Statement
    Transfers data to one or more data areas.
  • MULTIPLY Statement
    Multiplies numeric data items and sets the values of data items equal to the results.
  • PERFORM Statement
    Controls execution of a statement block in the scope of the PERFORM statement. This statement can also process each element of an array or collection.
  • RAISE Statement
    Raises an exception.
  • READ Collection Statement
    Reads an element in the list or in the dictionary from a given key.
  • RESET Collection Statement
    Deletes all the elements from the list or dictionary.
  • REWRITE Collection Statement
    Overwrites an element in the list or dictionary.
  • SET Statement
    Can set the size of an array; initialize the contents of an array and set the size accordingly; and set the value of a data item or a boolean data item.
  • SORT Statement
    Sorts the elements of a table.
  • SUBTRACT Statement
    Subtracts one, or the sum of two or more, numeric data items from one or more items, and set the values of one or more items equal to the results.
  • SYNC Statement
    Marks a statement block as a critical section by obtaining the mutual-exclusion lock for a given object, executing a block of statements, and then releasing the lock.
  • TRY Statement
    The TRY...CATCH...FINALLY...END-TRY structure is the basis for structured exception handling. The TRY block allows you to test a section of code for exceptions that may occur during its execution. The CATCH block must specify the type of exception you wish to handle if one should occur during the execution of the TRY block. The FINALLY block allows you to execute a section of code following the TRY block, whether or not an exception occurred.
  • WRITE Collection Statement
    Writes an element to the list or dictionary.
Parent topic: Managed COBOL Reference


Statements

Context:

Procedure Division

statement-block

Parent topic: Statements - Alphabetic List


ACCEPT Statement

Takes data keyed at the console or supplied by the operating system and makes it available to the program in a specified data item.

Context:

    Procedure Division
        Statements

accept-statement

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.
Parent topic: Statements - Alphabetic List
Related reference
The ACCEPT Statement


ADD Statement

Adds two or more numeric operands and stores the result.

Context:

    Procedure Division
        Statements

add-statement

Parent topic: Statements - Alphabetic List


Attach Statement

Attaches a delegate, a method group or an anonymous method to an event.

Context:

    Procedure Division
        Statements

attach-statement

Parent topic: Statements - Alphabetic List


CREATE Collection Statement

Creates or constructs an instance of a list or dictionary.

Context:

    Procedure Division
        Statements

create-collection-statement

Where: identifier is the name of the list or dictionary collection type.

Example

The following declares and creates a list collection: and then writes an element to the list:

       declare stringList as list[string]
       create stringList
       write stringList from "item 0"

See also the Collections sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Statements - Alphabetic List


COMPUTE Statement

Assigns to one or more data items the value of an arithmetic expression.

Context:

    Procedure Division
        Statements

compute-statement

Parent topic: Statements - Alphabetic List


CONTINUE Statement

The CONTINUE statement is a no operation statement, indicating that no executable statement is present.

Context:

    Procedure Division
        Statements

continue-statement

Parent topic: Statements - Alphabetic List


DECLARE Statement

Declares one or more local variables within the procedure division body. The scope of any inline local variable is from the point of declaration until the end of the innermost containing block, where paragraphs, sections and the whole method are considered to be blocks.

Context:

    Procedure Division
        Statements

declare-statement

Example

       declare i1 as binary-long
       display i1

       *>   Optionally, the variables can be initialised inline
        declare c2 as condition-value = true
        display c2

        declare string-list2 as string occurs 3 = table of string("Bill", "Ben", "LittleWeed")

See also the Local Variables sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Statements - Alphabetic List
Related reference
Local Data Item Declaration


DELETE Collection Statement

Deletes an element from the list or dictionary.

Context:

    Procedure Division
        Statements

delete-collection-statement

Where: identifier is the name of the list or dictionary collection type.

Parent topic: Statements - Alphabetic List


Detach Statement

Detaches a delegate or a method group from an event.

Context:

    Procedure Division
        Statements

detach-statement

Parent topic: Statements - Alphabetic List


DISPLAY Statement

Displays the specified data items.

Context:

    Procedure Division
        Statements

display-statement

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.
Parent topic: Statements - Alphabetic List
Related reference
The DISPLAY Statement


DIVIDE Statement

Divides one numeric data item into others and sets the values of data items equal to the quotient and remainder.

Context:

    Procedure Division
        Statements

divide-statement

Parent topic: Statements - Alphabetic List


EVALUATE Statement

Describes a multi-branch, multi-join structure, which can evaluate multiple conditions. The subsequent action of the run-time element depends on the results of these evaluations.

Context:

    Procedure Division
        Statements

evaluate-statement

Parent topic: Statements - Alphabetic List


EXIT Statement

Causes an exit from a perform loop, method or iterator.

Context:

    Procedure Division
        Statements
Program Structure
   Types
      { Classes ValueTypes Interfaces Delegates Enums  }
           *
               Procedure Division
                  statement-block

exit-statement

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.
Parent topic: Statements - Alphabetic List
Related reference
The EXIT Statement


GOBACK Statement

Causes a return from a method.

Context:

    Procedure Division
        Statements

goback-statement

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.
Parent topic: Statements - Alphabetic List
Related reference
The GOBACK Statement


IF Statement

Evaluates a condition and takes subsequent action depending on whether the value of the condition is true or false.

Context:

    Procedure Division
        Statements

if-statement

Parent topic: Statements - Alphabetic List
Related information
Choices - in COBOL and C#


INVOKE Statement

Invokes a method.

Context:

    Procedure Division
        Statements

invoke-statement

method-invocation-expression

Example

In the following example, the arguments a and b above are passed to the invoked method, and these correspond to the parameters x and y respectively, in the invoked method. The types of the parameters are specified in the AS phrase of the USING clause.

       01 a string.
       01 b binary-long.
       invoke type MyClass::MyMethod(a,b)
       ...

       method-id MyMethod.
       procedure division using x as string
                                y as binary-long.
       ...
       end method.

See also the Core sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Statements - Alphabetic List
Related reference
Procedure Division Header
SET Statement
Related information
Types and Type Conversion
Functions, Methods - in COBOL and C#
Objects - in COBOL and C#
Invoking a Method


MOVE Statement

Transfers data to one or more data areas.

Context:

    Procedure Division
        Statements

move-statement

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.
Parent topic: Statements - Alphabetic List
Related reference
The MOVE Statement


MULTIPLY Statement

Multiplies numeric data items and sets the values of data items equal to the results.

Context:

    Procedure Division
        Statements

multiply-statement

Parent topic: Statements - Alphabetic List


PERFORM Statement

Controls execution of a statement block in the scope of the PERFORM statement. This statement can also process each element of an array or collection.

Context:

    Procedure Division
        Statements

perform-statement

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.

Example of local declaration within an iterator

A variable can be declared at the point of use in an iterator, and its scope is until the end of the perform block.

      *>   In this case, the scope of i is until the end of the perform block.
           perform varying i as binary-long from 1 by 1 until i > 10
               display i
           end-perform

      *>   So the i in the following perform block is a new instance of i,
      *>   independent of the i in the preceding perform block.
           perform varying i as binary-short from 0 by 1 until i > 10
               display i
           end-perform

Here, k is declared inline to iterate through a dictionary. Again, it is in scope until the corresponding end-perform.

    01 dict1 dictionary[string string].
           create dict1
           write dict1 from "Anthony" key "A"
           write dict1 from "Brian" key "B"
           write dict1 from "Charles" key "C"
           perform varying key k as string value val as string through dict1
               display k ":" val
           end-perform
           perform varying value val as string through dict1
               display val
           end-perform
           perform varying key k as string through dict1
               display k
           end-perform

See also the Local Variables sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Statements - Alphabetic List
Related reference
The PERFORM Statement
Related information
Loops - in COBOL and C#


RAISE Statement

Raises an exception.

Context:

    Procedure Division
        Statements

raise-statement

Example

See the Exception Handling sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET.

Parent topic: Statements - Alphabetic List
Related reference
TRY Statement
Related information
Exception Handling - in COBOL and C#


READ Collection Statement

Reads an element in the list or in the dictionary from a given key.

Context:

    Procedure Division
        Statements

read-collection-statement

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.

Where: identifier is the name of the list or dictionary collection type.

Example

The following reads an element from a list collection:

       declare val as string
       read stringList into val key 0

The following example, shows exception handling and catching an exception on reading an invalid key in a dictionary collection:

       display "reading an invalid key message : "
       read stringDictionary into val key "RUBBISH"
       invalid key
           display "Caught invalid key"
       not invalid key
           display "Shouldn't see this"
       end-read

See also the Collections sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Statements - Alphabetic List


RESET Collection Statement

Deletes all the elements from the list or dictionary.

Context:

    Procedure Division
        Statements

reset-collection-statement

Where: identifier is the name of the list or dictionary collection type.

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.
Parent topic: Statements - Alphabetic List


REWRITE Collection Statement

Overwrites an element in the list or dictionary.

Context:

    Procedure Division
        Statements

rewrite-collection-statement

Where: identifier is the name of the list or dictionary collection type.

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.

Example

The following overwrites the first element in the list stringList.

       rewrite stringList from "ITEM REWRITE" key 0
       display "The contents of the list after rewrite element 0 : "
       invoke self::displayListContents(stringList)

See also the Collections sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Statements - Alphabetic List


SET Statement

Can set the size of an array; initialize the contents of an array and set the size accordingly; and set the value of a data item or a boolean data item.

Context:

    Procedure Division
        Statements

set-statement

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.

Example

See the Core sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Statements - Alphabetic List
Related reference
INVOKE Statement
The SET Statement
Related information
Invoking a Method
Arrays - in COBOL and C#
Objects - in COBOL and C#


SORT Statement

Sorts the elements of a table.

Context:

    Procedure Division
        Statements

sort-statement

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.
Parent topic: Statements - Alphabetic List
Related reference
The SORT Statement


SUBTRACT Statement

Subtracts one, or the sum of two or more, numeric data items from one or more items, and set the values of one or more items equal to the results.

Context:

    Procedure Division
        Statements

subtract-statement

Parent topic: Statements - Alphabetic List


SYNC Statement

Marks a statement block as a critical section by obtaining the mutual-exclusion lock for a given object, executing a block of statements, and then releasing the lock.

Context:

    Procedure Division
        Statements

sync-statement

Example

class-id Account.
  working-storage section.
  01 balance binary-long.
  01 r type Random value new Random.
  method-id new.
  procedure division using value init as binary-long.
      move init to balance
  end method.

  method-id Withdraw.
  procedure division using value amount as binary-long returning ret as binary-long.
  *> This condition will never be true unless the lock statement
  *> is commented out:
      if balance > 0
          display "< 0"
          raise new Exception("Negative Balance")
      end-if
      sync on self
          if balance >= amount
               display "In critical section"
               *>display "Balance before Withdrawal :  " balance
               *>display "Amount to Withdraw        : -" amount
               compute balance = balance - amount
               *>display "Balance after Withdrawal  :  " balance
               move amount to ret
          else
               display "In critical section"
               move 0 to ret
          end-if
      end-sync
  end method.

  method-id DoTransactions.
  local-storage section.
  01 i binary-long.
  procedure division.
      perform varying i from 0 by 1 until i = 100
          invoke self::Withdraw(r::Next(1, 100))
      end-perform
  end method.
end class.
Parent topic: Statements - Alphabetic List
Related information
Synchronization - in COBOL and C#


TRY Statement

The TRY...CATCH...FINALLY...END-TRY structure is the basis for structured exception handling. The TRY block allows you to test a section of code for exceptions that may occur during its execution. The CATCH block must specify the type of exception you wish to handle if one should occur during the execution of the TRY block. The FINALLY block allows you to execute a section of code following the TRY block, whether or not an exception occurred.

Context:

    Procedure Division
        Statements

try-statement

Example of a local declaration of an exception

      *>   The example below shows that you can declare e at the point of use.
      *>   It is in scope until the end-try.
           try
               display "exception test"
           catch e as type Exception
               display e::Message
           end-try

See also the Local Variables sample and Exception Handling sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Further Information

In the TRY statement, the:

TRY statement-block
specifies a block the section of code to be tested for exceptions that may occur during its execution
CATCH statement-block
specifies the type of exception to handle if an exception occurs during execution of the TRY block
FINALLY statement-block
specifies the section of code to execute following the TRY block, whether or not an exception occurred

Your program can raise an exception using the RAISE statement and pass this exception back to the caller. This is commonly referred to as "throwing an exception".

Parent topic: Statements - Alphabetic List
Related reference
RAISE Statement
Related information
Exception Handling - in COBOL and C#


WRITE Collection Statement

Writes an element to the list or dictionary.

Context:

    Procedure Division
        Statements

write-collection-statement

Note: Other formats of this statement are available. See Statements in the COBOL Language Reference.

Example

The following declares and creates a list collection and then writes an element to the list:

       declare stringList as list[string]
       create stringList
       write stringList from "item 0"

The following writes 5 more elements to the list using a perform loop:

       perform varying i as binary-long from 1 by 1 until i > 5
           write stringList from "item " & i
       end-perform

       display "The contents of the list : "
       invoke self::displayListContents(stringList)

See also the Collections sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Statements - Alphabetic List


Concepts - Managed COBOL

  • Extension Methods and Operators
    Extension methods enable you to add methods to existing types thereby providing additional functionality without the need to edit or recompile the code.
  • Invoking a Method
    You can invoke a method in two ways: by using the invoke statement or by using the inline invocation syntax.
  • Method Overloading in Managed COBOL
    Managed COBOL supports method overloading
  • Operator Overloading in Managed COBOL
    You can overload operators to provide alternative behavior, or behavior for different operand types.
  • String Handling in Managed COBOL
    Managed COBOL provides a predefined managed string type and provides powerful techniques for handling strings.
  • Types and Type Conversion
    Types can be converted into other types using the AS syntax or a conversion operator.
  • Type Compatibility of Managed COBOL with Other Managed Languages
    Many managed COBOL types have a strict correspondence with managed types in other languages, such as binary-long and float-short. For those that don't have a correspondence, there are alternatives.
  • Type Mappings from Native COBOL to Managed Code
    COBOL data items are exposed as managed types, when the code is compiled with the ILSMARTLINKAGE directive.
Parent topic: Managed COBOL Reference


Extension Methods and Operators

Extension methods enable you to add methods to existing types thereby providing additional functionality without the need to edit or recompile the code.

Extension Methods

Similar to other managed code languages such as C#, managed COBOL supports extension methods, which enable you to add methods to existing types thereby providing additional functionality without the need to edit or recompile the code.

For example, the following extension method extends the string class, by adding a method to count the number of words in a string:

       class-id MyCount static.
       method-id CountWords extension. *> extension method is implicitly static
       procedure division using str as string
                          returning wordCount as binary-long.
            set wordCount to str::Split(' ')::Length
       end method.
       end class.

You extend a method when you cannot override it. The method you want to extend might be in a final class or in code that you don't have access to. In these cases, you can define and compile the extension method separately and then use it freely.

Defining an extension method

Use the following construction to define an extension method:

       class-id MyExtension static.
       method-id MyExtensionMethod extension.
       procedure division using myName as ExtendedType
                      returning myReturnName as returnType.
           set myReturnName to my code...
       end method.
       end class.

To define an extension method:

  • Use the EXTENSION keyword in the method header.
  • The method must be in a static class that is not nested or generic. The method is implicitly static.
  • In the method body, the first parameter is the type to extend. It is always a value parameter.
Consuming an extension method

There is no special syntax for calling extension methods. You consume extension methods in much the same way as any other method, except you specify the first parameter as the type that is extended. You use this syntax:

parameter-1::method-name(more parameters)

In the example below, you consume with code such as aString::CountWords:

       class-id MyWords.
       method-id CheckWords.
       01 myWordCount binary-long.
       procedure division using value aString as string
                          returning b as condition-value.
           set myWordCount to aString::CountWords
           if myWordCount < 10
               set b to true
           else
               set b to false
           end-if
       end method.
       end class.

You use extension methods as if they were instance methods defined in another class or interface. Extension methods appear as additional methods available on an object instance and yet they are implemented elsewhere. Intellisense shows all methods you can use including the extension methods that are declared elsewhere. An extension method is indicated with a different icon and its tooltip includes the phrase (extension).

When you invoke an extended method, the extension method is not contained in the class specified in the invoking statement. It is contained in another class elsewhere. The invoking and executing classes are different. The method's defined and execution containing types are different.

Extension methods work like this:

  • The Compiler produces a static method with parameters. The type of the first parameter is the type being executed (or invoked). The second and subsequent parameters are the declared parameters. For example, the Compare method effectively has two parameters: the type of the first parameter is a string, and the second parameter is s2.
  • The first parameter is annotated with the System.run-time.CompilerServices.ExtensionAttribute attribute (or in the case of a JVM program, an equivalent that is defined in the JVM runtime system). This attribute is also applied to the containing class and assembly.

Extension Operators

Extension operators are very similar to extension methods. They enable you to provide alternative behavior for an operator, without the need to edit or recompile the code. You define and use extension operators in the same way as extension methods.

For example, you could define and use an extension plus operator, as follows:

       set timer3 to timer1 + myMins
       operator-id + extension.
       01 sumMins binary-long.
       01 m binary-long value 0.
       01 h binary-long value 0.
       procedure division using value a as type Timer
                                      b as binary-long
                            returning c as type Timer.
           set sumMins to a::pMins + b
           divide sumMins by 60 giving h remainder m
           set c to new Timer(a::pHour + h , m)
       end operator.

You extend an operator when you cannot overload it. The operator you want to extend might be in a final class or in code that you don't have access to. In these cases, you can define and compile the extension operator separately and then use it freely.

To declare and use an extension operator:

  • Declare the operator using the EXTENSION keyword. The operator must be in a static class.
  • There is no special syntax for using extension operators.
  • In JVM managed COBOL, the extension operator must be available to the Compiler. You might need to use the ILREF directive in combination with the JVMGEN directive. See Extension Methods for full details.

Extension operators are implemented as methods, such as an op_Equality or op_Addition method. This method is added to a specific dictionary in TypeInfo. This enables the code looking for operator overloads and extensions to look in this dictionary in addition to the classes of the two operands.

Extension Methods (and Operators) in JVM COBOL

When you invoke a method, you specify the class in which the method belongs. In our example, the method CheckWords() in the myWord class and is invoked as follows:

       01 myWord type MyWords.
       01 myDoc string.
       01 sizeOK condition-value.
           set sizeOK to myWord::CheckWords(myDoc)
           ...
       class-id MyWords final.
       method-id CheckWords.
       ...

In the above, since the class can be found, so can the method. The class loader architecture uses the class on which a method is defined to know when to load a class. In this case, the myWord class is loaded before the method CheckWords() is invoked. This happens in much the same way during compilation. When the myWord::CheckWords method is referred to in a class that is being compiled, the Compiler uses a class loader to load the CheckWords method to resolve the method signature and understand how to generate the appropriate code.

Problem: extensions can't be found

However, when you invoke an extended method (or operator), the extension method is not contained in the class specified in the invoking statement. In our example, the extension method CountWords() is invoked on the type of the aString variable (which is a string), but it is executed in your extension class, as follows:

       01 aString string.
       01 myWordCount binary-long.
           set myWordCount to aString::CountWords
           ...
       class-id MyCount static.
       method-id CountWords extension.
       ...

Although the method is invoked on the String class, the method to be executed is contained in a different class (the MyCount class). The class loader can't find the method, because its defined and execution containing types are different. For the Compiler to use extension methods (and extension operators), it has to load their defining classes before compiling the classes that refer to those extensions.

Solution: preload the extensions

To ensure that the Compiler can find the extensions, you use ILREF directive at the command line, combined with the JVMGEN directive. The following example loads the class defined within the ops.class file. The name and package of the class defined in ops.class does not need to be the same as the name and directory of the class file.

Windows:

cobol x.cbl jvmgen ilref(ops.class);

UNIX:

cob x.cbl –C jvmgen  -C ilref(ops.class)

The following command unpacks the file ops.jar and loads the moreOps.class. Note that the .jar file needs to be on the CLASSPATH environment variable or specified in the JVMCLASSPATH directive for it to work.

Windows:

cobol -j x.cbl jvmclasspath(ops.jar) ilref(moreOps.class);

UNIX:

cob -j x.cbl -C jvmclasspath(ops.jar) –C ilref(moreOps.class)

The ILREF directive requires a file in class format. Files with the .class extension are treated as class format.

Preloaded Extensions for JVM

The following extensions are supplied for JVM:

  • String equality extension operator
  • Substring extension method

The classes containing the extensions are preloaded by the Compiler by using the ILREF directive.

String Equality Extension Operator

An extension operator for string equality is preloaded by the Compiler before compilation. This ensures that a check for equality gives the same results in the .NET environment as in the JVM environment. For example, the following code compares two strings:

       01 string1 string value “12345”.
       01 string2 string value “12345”.
       if string1 = string2
              display “the values are the same”
       else
           display “error - the values look the same, but the equality returned false”
       end-if

Without the preloaded extension, the code sees the strings as different, because the JVM java.lang.String::equality(string) method compares the references and the .NET System.String::equality(string) method compares the values. With the preloaded extension, the code sees the strings as the same.

The string equality extension extends both the = and equals operators for the type string. The operator returns true if the two string instances contain exactly the same character sequence, false otherwise. The operator extension is defined as:

       operator-id = extension.
       procedure division using value a as string
                                      b as string
                          returning r as condition-value.

To check for object equality between string instances use:

       if a as object = b as object
Substring Extension Method for JVM COBOL

An extension method for Substring is preloaded by the Compiler before compilation. This ensures that the Substring method gives the same results in the .NET environment as in the JVM environment. For example:

       01 x string value “1234567890”.
       display x::Substring(2,3) “ The .NET way of doing things”
       display x::substring(2,3) “ The JDK way of doing things”

Since, the .NET behavior of System.String::Substring(int, int) differs from the JVM behavior of java.lang.String::Substring(int int), you get different results for .NET and JVM, if the extension is not installed. However, if the extension is installed, the JVM behavior matches that of .NET and you get the same results.

The Substring extension method extends the string type (which is also java.lang.String). This method returns a new instance of string with a signature that matches that of the Substring method in .NET. The Substring method extension is defined as follows:

       method-id Substring extension.
       procedure division using value a as string
                                startIdx as binary-long
                                sslength as binary-long
                      returning r as string.

String Equality Extension Operator for JVM

An extension operator for string equality is preloaded by the Compiler before compilation. This ensures that a check for equality gives the same results in the .NET environment as in the JVM environment. For example, the following code compares two strings:

       01 string1 string value “12345”.
       01 string2 string value “12345”.
       if string1 = string2
              display “the values are the same”
       else
           display “error - the values look the same, but the equality returned false”
       end-if

Without the preloaded extension, the code sees the strings as different, because the JVM java.lang.String::equality(string) method compares the references and the .NET System.String::equality(string) method compares the values. With the preloaded extension, the code sees the strings as the same.

The string equality extension extends both the = and equals operators for the type string. The operator returns true if the two string instances contain exactly the same character sequence, false otherwise. The operator extension is defined as:

       operator-id = extension.
       procedure division using value a as string
                                      b as string
                          returning r as condition-value.

To check for object equality between string instances use:

       if a as object = b as object

Substring Extension Method for JVM COBOL

An extension method for Substring is preloaded by the Compiler before compilation. This ensures that the Substring method gives the same results in the .NET environment as in the JVM environment. For example:

       01 x string value “1234567890”.
       display x::Substring(2,3) “ The .NET way of doing things”
       display x::substring(2,3) “ The JDK way of doing things”

Since, the .NET behavior of System.String::Substring(int, int) differs from the JVM behavior of java.lang.String::Substring(int int), you get different results for .NET and JVM, if the extension is not installed. However, if the extension is installed, the JVM behavior matches that of .NET and you get the same results.

The Substring extension method extends the string type (which is also java.lang.String). This method returns a new instance of string with a signature that matches that of the Substring method in .NET. The Substring method extension is defined as follows:

       method-id Substring extension.
       procedure division using value a as string
                                startIdx as binary-long
                                sslength as binary-long
                      returning r as string.
Parent topic: Concepts - Managed COBOL
Related reference
Methods
Related information
Functions, Methods - in COBOL and C#


Invoking a Method

You can invoke a method in two ways: by using the invoke statement or by using the inline invocation syntax.

INVOKE statement

For example, the following INVOKE statement invokes the replace method on the input string obj-string and returns the results in obj-string. Notice that the case of the method name is different for .NET and JVM. It is replace in .NET and Replace in JVM.

       invoke obj-string::replace("Some" "New")   *> .NET
       invoke obj-string::Replace("Some" "New")   *> JVM
       display obj-string

Inline invocation

Similarly, the following SET statement uses the inline invocation syntax, which employs an implicit set property method. This example statement invokes the Replace() method on the input string obj-string and sets the results in the aString variable.

       set aString to obj-string::replace("Some" "New")   *> .NET
       set aString to obj-string::Replace("Some" "New")   *> JVM
       display aString

In addition, you can use the inline invocation syntax to access properties. In the following example, the Length property of the string myString is accessed and is displayed:

       display "Total characters is " myString::Length

You can invoke any method in the same compilation as the invoking code, either a static or instance method, as follows:

Invoking a static method

To invoke a static method, you specify the class name, followed by :: and then the method name. For example, SimpleClass::StaticMethod as in the invoke statement below:

       invoke type SimpleClass::StaticMethod
       ...
       class-id SimpleClass.
       method-id StaticMethod  static.
          display "In static method"
       end method.
       end class.

Invoking an instance method

To invoke an instance method in the same compilation unit, you instantiate an object first. You can then specify the instance object, followed by :: and then the method name. For example, mySimpleObj::InstanceMethod as in the invoke statement below:

       01 mySimpleObj type SimpleClass.
       set mySimpleObj to new SimpleClass("Hello")
       invoke mySimpleObj::InstanceMethod
       ...
       class-id SimpleClass.
       01 thisString string.

       method-id New.
       procedure division using by value aString as string.
           set thisString to aString
       end method.

       method-id InstanceMethod.
       procedure division.
           display "In instance method"
           display "Instance data is " thisString
       end method.

Examples

See also the Core sample, which is available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Concepts - Managed COBOL
Related reference
SET Statement
INVOKE Statement
Related information
Functions, Methods - in COBOL and C#
Objects - in COBOL and C#


Method Overloading in Managed COBOL

About Overloading

Overloading is a programming technique where you overload a method name with more than one implementation.

For example, there may be a method called CalculateBill, taking as a parameter a list of purchases. We may want to have a variant of this method which, in addition to the list of purchases, has another parameter representing a discount code. The two methods can have the same name, and, when the method is invoked, the required one is selected based on the presence or absence of the discount code parameter.

Method Overloading in Managed COBOL

In managed COBOL, it is permissible (and very common practice) for a given class or interface to have multiple methods with the same name, which are distinguished from each other by having different signatures. The signature of a method is determined by the:

  • Number of parameters
  • Type of each parameter
  • Passing mode (BY VALUE, BY REFERENCE, or BY OUTPUT) of each parameter
  • Return type , which in .NET COBOL, this type may be System.Void, which represents a method with no RETURNING item

When code written in COBOL, or any other language, attempts to invoke a method in some class or interface, and more than one method with the given name exists, then a choice of the available methods is made. The choice is based on the number of parameters and the ‘best’ type match for the parameters (the precise definition of ‘best’ is complex and is treated later). If no method with a suitable signature can be found, a ‘method not found’ error results. If there is no method that provides a better match than all the other possible methods with this name, an ‘ambiguous match’ error is given.

Although the type of the RETURNING item is a part of the method's signature, the choice of method to be invoked is never based on the RETURNING type. This is different from .NET and JVM, which allow a class to have multiple methods that differ only by returning type. This is not generally good practice, and COBOL produces an error if it finds such multiple methods within a single class. The only time when such multiple methods can arise from a COBOL program is in the case of the explicit and implicit operators.

Method Signatures

The type of a COBOL parameter may be specified by:

  • Referencing the type explicitly in the PROCEDURE DIVISION phrase using the AS syntax
  • Declaring a linkage section item with a given type and referencing that linkage section item in the PROCEDURE DIVISION USING phrase

For REFERENCE and OUTPUT parameters, managed types are exposed directly as managed pointers to the corresponding managed type. COBOL data types that do not correspond to managed types (such as PIC X fields, groups, numeric fields other than BINARY-LONG and so on) are exposed as COBOL pointers (objects of type MicroFocus.COBOL.Program.Reference, in .NET COBOL).

For VALUE parameters, and RETURNING items, types are exposed as follows:

COBOL types: are exposed as:
Managed types | objects of the corresponding type
Numeric items with more than 19 decimal digit positions | MicroFocus.COBOL.Program.BigDecimal
Numeric items with implied decimal point, such as PIC 9(9)v99, all sizes | - System.Decimal in .NET COBOL
Unsigned numeric items with no implied decimal point: In .NET COBOL:
  • < 3 numeric digits - unsigned int8
  • < 5 numeric digits - unsigned int16
  • < 10 numeric digits - unsigned int32
  • < 19 numeric digits - unsigned int64

In JVM COBOL, they are exposed the same as signed numeric items.

Signed numeric items with no implied decimal point:
  • < 3 numeric digits - int8
  • < 5 numeric digits - int16
  • < 10 numeric digits - int32
  • < 19 numeric digits - int64
All other types PIC X, group and so on | string

Method Overload Resolution

Method overload resolution takes place in two phases:

  1. Selection of all applicable methods, that is, selection of all those methods with the given name for which the arguments specified in the invoking program are compatible with the parameters of the target methods. If no such applicable method is found, then an error (method not found) is produced.
  2. Selection of the ‘best’ match from within the set of applicable methods. The general intent of the selection process is to produce the best match (in the sense of most specific match) for the given set of arguments.

    Formally, the method overload that is ‘better’ than any other of the applicable method overloads is chosen. If no single overload is determined to be better than any other overload, then the match is considered to be ambiguous, and a compiler error results.

    If this process does not result in a unique best match, an error (ambiguous match error) is produced

Note:

In this discussion, the term arguments means the set of parameters specified in the invoking method (for example obj01 in the statement:

INVOKE self::Method1(obj01)

The term parameters means the formal parameters specified in each method definition (in the PROCEDURE DIVISION USING header).

Selection of Applicable Methods

We start with the complete set of all methods with the required name that exist in the target class or in any of its parent classes (excluding those with identical signatures). From this set, any methods that are not visible from the invoking program, based on the visibility attribute encoded into the method, are discarded as follows:

Attribute | Visibility
PRIVATE | Visible only if the calling class is the same as the target class
PUBLIC | Always visible
PROTECTED | Visible only if the calling class derives from the target class
INTERNAL | Visible only if the target class is in the same assembly as the calling class
PROTECTED INTERNAL | Visible only if the calling class derives from the target class, or the calling class is in the same assembly as the target

Next, if the required method is an instance method (a method that is applied to an object instance), all static methods are discarded. Similarly, if the required method is a static method, all instance methods are discarded.

Now each method is examined in turn to see whether it is applicable in normal form. This is determined as follows:

  1. If the number of arguments is different from the number of parameters in the method, then this method is discarded.
  2. If the type of the parameter in the target method is generic COBOL data passed by reference (in .NET, MicroFocus.COBOL.Program.Reference), then any argument type is assumed to match except for .NET native types.
  3. For each argument with an explicit parameter passing mode (BY CONTENT, BY VALUE or BY OUTPUT), that mode must correspond to the definition of the parameter in the method being examined.

  4. For a REFERENCE or OUTPUT parameter, the type of the argument must be exactly the same as the parameter type.

    For a VALUE parameter, an implicit conversion must exist from the type of the argument to the type of the corresponding parameter. If any of these implicit conversions require truncation, this method is said to be a ‘truncation match’.

If a method is not applicable according to these rules, an attempt is made to match the method in expanded form, if both the following are true:

  • The last parameter of the method is an array with the ‘params’ attribute
  • The total number of method parameters (excluding this array parameter) is less than or equal to the number of arguments

The expanded form of the method is derived from the normal form by replacing the array parameter by zero or more value parameters of the same type as the array element, so that the total number of parameters is the same as the number of invoking arguments. If the class already contains a method in normal form with this same expanded signature, then this method is determined to be not applicable. Otherwise the expanded form is tested for applicability in the same way as the test for normal form above.

After the above selection procedure:

  1. If exactly one member is found to be applicable, then that method is known to be the required method.
  2. If more than one method is found to be applicable, then an attempt is made to find the best method.
  3. If any non-truncation matches are found, then all truncation matches are discarded.
  4. If the only matches found are truncation matches, then if only one such match has been found, this becomes the chosen method and a warning is produced. If more than one truncation match is found, then the Compiler returns an error:
    ambiguous match
  5. If no methods are found to be applicable, then the Compiler returns an error:
    method not found

Better Method Overload

Suppose we have an argument list A with a set of argument types (A1, A2,…An) and two applicable method overloads Mp and Mq with parameter types (P1…Pn) and (Q1,…Qn), where if necessary the parameters have been converted to expanded form (see above).

Then, Mp is said to be a better method overload than Mq if both the following are true:

  • For each argument, the implicit conversion from Ax to Px is not worse than the conversion from Ax to Qx (see below for definition of better conversion)
  • There is at least one argument for which the conversion from Ax to Px is better than the conversion from Ax to Qx

Suppose we have two conversions, from type S to types T1 and T2, then T1 is the better conversion when T1 and T2 are as follows:

T1 is: And T2 is one of:
same as S anything
binary-char
  • binary-char unsigned
  • binary-short unsigned
  • binary-long unsigned
  • binary-double unsigned
binary-short
  • binary-short unsigned
  • binary-long unsigned
  • binary-double unsigned
binary-long
  • binary-long unsigned
  • binary-double unsigned
binary-double
  • binary-double unsigned

Otherwise neither conversion is better.

Example of Simple Method Overloading

The following example shows how, even in the case where the supplied argument is not exactly the same as that for any of the target methods, the “most specific” rule takes effect.

       class-id. Class1.
       method-id main static.
       01 objAnyObject object.
       01 objString string.
       01 objDateTime type "DateTime".
       01 ref1 type "Class1".
       procedure division.
           set ref1 to new Class1
           invoke ref1::"method1"                 *> uses variant 1
           invoke ref1::"method1" (objAnyObject)  *> uses variant 2
           invoke ref1::"method1" (objString)     *> uses variant 3
           invoke ref1::"method1" (objDateTime)   *> uses variant 2,
              *>because an object of type System.DateTime can be
              *>assigned to a System.Object but not to a System.String
        end method main.

       method-id method1.     *> Variant 1 (no parameters)
       procedure division.
           display "variant 1"
       end method method1.

       method-id method1.     *> Variant 2 (object parameter)
       procedure division using by value objAnyObject as object.
           display "variant 2"
       end method method1.

       method-id method1.     *> Variant 3 (string parameter)
       procedure division using by value objString as string.
           display "variant 3"
       end method method1.

       end class Class1.

Implicit Conversion

An implicit conversion exists from type S to type T if it is possible to assign an object of type S to an object of type T, with the equivalent of the following statement:

SET obj-T TO obj-S

The following types of implicit conversion are available:

Identity conversions

This simply means that S is the same type as T

Implicit numeric conversions

COBOL generally allows any numeric item to be assigned to any other, with any loss of data being the responsibility of the user. However, when determining if a conversion exists for the purposes of method overloading, we distinguish between proper conversions and truncation conversions. Proper conversions are those for which no loss of data magnitude should result, though even in this case precision can be lost when converting between fixed point and floating point.

For managed COBOL types, proper implicit conversions include:

binary-char
  • binary-short
  • binary-long
  • binary-double
  • float-short
  • float-long
  • decimal
binary-char unsigned

The same as binary-char, plus:

  • binary-short unsigned
  • binary-long unsigned
  • binary-double unsigned
binary-short
  • binary-long
  • binary-double
  • float-short
  • float-long
  • decimal
binary-short unsigned

The same as binary-short, plus:

  • binary-long unsigned
  • binary-double unsigned
binary-long
  • binary-double
  • float-short
  • float-long
  • decimal
binary-long unsigned

The same as binary-long, plus:

  • binary-double unsigned
binary-double
  • float-short
  • float-long
  • decimal
binary-double unsigned

The same as binary-double

character
  • binary-short unsigned
  • binary-long
  • binary-long unsigned
  • binary-double
  • binary-double unsigned
  • float-short
  • float-long
  • decimal
float-short
  • float-long
Implicit enumeration conversions

The value 0 may be converted to any enum type

Implicit reference conversions

If S and T are reference types, S may be assigned to T when:

  • Type S is derived (directly or indirectly) from type T. This includes the case where T is System.Object, since all types derive from that
  • Type S implements interface type T
  • If S is an array type with element type E1 and T is an array type with element type E2, then S can be assigned to T provided:
    • S and T have the same number of dimensions
    • Both E1 and E2 are reference types
    • An implicit conversion exists from E1 to E2
  • Any array type may be assigned to type System.Array in .NET COBOL
  • Any delegate type may be assigned to type System.Delegate
  • Null may be assigned to any reference type
Boxing conversions

Any value type can be converted to a System.Object, type by a process known as boxing. As part of this process the value is copied onto the object heap and a reference is created

Implicit constant expression conversions

Any numeric constant can be converted to any type capable of containing the full value of that constant. For instance the value 1 can be converted both to BINARY-CHAR UNSIGNED and to BINARY-CHAR.

User defined implicit conversions

A user defined implicit conversion consists of an optional implicit numeric conversion from S to S1 followed by the execution of a user defined implicit conversion operator resulting in T1, followed by another optional implicit numeric conversion to T. User defined implicit conversion operators are defined in COBOL with OPERATOR-ID IMPLICIT and result in methods with the name op_Implicit.

Parent topic: Concepts - Managed COBOL
Related reference
Access Modifiers
Methods
Related information
Functions, Methods - in COBOL and C#
Type Compatibility of Managed COBOL with Other Managed Languages
Type Mappings from Native COBOL to Managed Code


Operator Overloading in Managed COBOL

You can overload operators to provide alternative behavior, or behavior for different operand types. For example, where a Timer type is expressed as hours and minutes, you could define one plus operator to add two Timers and another plus operator to add a number of minutes to a Timer type, as follows:

       operator-id + .
       01 sumMins binary-long.
       01 sumHour binary-long.
       01 m binary-long value 0.
       01 h binary-long value 0.
       procedure division using value a as type Timer
                                      b as type Timer
                            returning c as type Timer.
           set sumHour to a::pHour + b::pHour
           set sumMins to a::pMins + b::pMins
           if sumMins >= 60
               divide sumMins by 60 giving h remainder m
               set c to new Timer(sumHour + h, m)
           else
               set c to new Timer(sumHour sumMins)
           end-if
       end operator.

       operator-id + .
       01 sumMins binary-long.
       01 m binary-long value 0.
       01 h binary-long value 0.
       procedure division using value a as type Timer
                                      b as binary-long
                            returning c as type Timer.
           set sumMins to a::pMins + b
           divide sumMins by 60 giving h remainder m
           set c to new Timer(a::pHour + h , m)
       end operator.

To use the overloaded operators, you use statements such as the following:

       program-id OpConversionExtension.
       01 timer1 type Timer value new Timer(1 45).
       01 timer2 type Timer value new Timer(2 45).
       01 timer3 type Timer value new Timer.
       01 myMins binary-long value 30.

       procedure division.
      *> Overloaded operators:
           set timer3 to timer1 + myMins   *> Plus operator adds binary-long to a Timer
           display timer3::pHour & ":" & timer3::pMins   *> displays 2:15

           set timer3 to timer1 + timer2   *> Plus operator adds 2 Timer types
           display timer3::pHour & ":" & timer3::pMins   *> displays 4:30
       end program.

The appropriate operator is executed according to the types of operands being operated on. The operator with a matching signature (procedure division using clause) is executed. Where two Timer types are being added, the operator with a signature that adds two Time types is executed.

Note that the operator signature requires that the arguments are passed in the defined order. In the above example, the Timer type must be first and the binary-long second, as follows:

       set timer3 to timer1 + myMins
       ...
       operator-id + .
       procedure division using value a as type Timer
                                      b as binary-long
                            returning c as type Timer.

To enable the arguments to be passed in the opposite order, you need to declare an another operator where the operands are in the opposite order in the operator's signature. For example:

       set timer3 to myMins + timer1
       ...
       operator-id + .
       procedure division using value a as binary-long
                                      b as type Timer
                            returning c as type Timer.

To use overloaded operators, the overloaded operator must be in scope.

While the arithmetic operators for addition, subtraction, multiplication and division can all be overloaded, their verb equivalents cannot. For example, ADD in the following statement cannot be overloaded:

       add a to b giving c

Further Examples

See also the Operator Overloading sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Samples, under COBOL for .NET .

Parent topic: Concepts - Managed COBOL
Related reference
Operators
Type Specifier
Related information
Operators - in COBOL and C#


String Handling in Managed COBOL

Managed COBOL provides a predefined managed string type and provides powerful techniques for handling strings.

In managed COBOL, you can:

  • Construct a string implicitly by assigning a value
  • Concatenate strings using &
  • Get a substring using the (offset:length) syntax
  • Get the length of a string, using SIZE OF
  • Compare strings using = and <>

The String Predefined Type

Managed COBOL provides a predefined string type corresponding to the managed code string type. You use this type name when declaring a data item, and anywhere that a class name is expected. For example:

01 obj-string string.

Constructing String Objects

String objects are not normally constructed using the "New" method. You can simply assign a value to the string reference and the compiler automatically performs the construction for you. The string value may be set up in this way either to a literal value, or to an alphanumeric, national or group data item. For example:

       set obj-string to "   Some text..."
        display obj-string

Substringing

Substringing is built into managed COBOL with the syntax (offset:stringLength). For example, the following line displays two characters of the string 'a' starting at the sixth character:

display a(6:2)

This looks simple enough, 'a' is a string not a 'pic x'. To do this with C# or Java you have to use a substring method, whereas managed COBOL it is in syntax.

Concatenation

Concatenation is easy using & (ampersand).

You can do string concatenation and string reference modification in the same line; not only that but it seamlessly concatenates COBOL quoted constants with string objects. For example:

       set a to a(1:5) & "-" & a(7:)
       display a

You can concatenate strings with the following using & (ampersand):

string variables | a & b
substrings | a & b(1:3)
quoted string constants | a & "-"
non-string types | 23 & " is a number"
return values from invokes | a & type COBOLString::Split(b,13,7)

The following example combines substringing with concatenation. Here a COBOL quoted constant is automatically cast to a string and the string returned from the invoke is then concatenated with two COBOL quoted constants.

       set a to "Micro Focus Managed COBOL is "                  & *>Micro Focus Managed COBOL is
           type COBOLString::Split("The cake is amazing", 13, 7) & *>amazing
           "ly good for working with strings!"                     *>ly good for working with strings!
       display a

Where the COBOLString::Split() method contains:

       set stringOut to stringIn(offset:stringLength)

Getting the String Length

To get the length of a string, use SIZE OF. For example:

       set n to size of myString

Concatenating Numbers and Strings

The following example concatenates a string variable (a COBOL quoted constant, which is automatically cast to a string) with a number returned from an invoke, which is then concatenated with another COBOL quoted constant.

           display a                           &
              " (this string is "              & *> (this string is
               type COBOLString::CharCount(a)  & *>69
              " bytes long)"                     *> bytes long)

Comparing Strings

To compare strings, use = and <>. For example:

           if a = b
               display "a = b"
            end-if
            if a <> b
               display "a <> b"
            end-if

String comparisons are implemented as overloads to the = and <> operators, which compare character by character (rather than compare object references).

Further Examples

See also the String Handling sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition > Samples, under COBOL for .NET.

Parent topic: Concepts - Managed COBOL
Related reference
Fields
Type Specifier
Related information
Strings - in COBOL and C#


Types and Type Conversion

Value Types, Reference Types and Boxing

Managed COBOL distinguishes between:

  • Value types (such as binary-long and System.DateTime in .NET). Value type data items contain the actual data. For example, a COBOL binary-long data item contains a 32 bit integer.
  • Reference types, which are allocated on the object heap. Reference type data items hold a reference into the object heap. Reference types are under the management of the garbage collector.

All value types can be turned into reference types by a process known as boxing. For example, you can set an object reference to a value type, such as a binary-long.

Boxing happens automatically when needed, for example when a value type is passed as a parameter to a method that expects an object as a parameter.

You can box explicitly by assigning a value type to a generic object (such as System.Object in .NET COBOL or java.lang.Object in JVM COBOL).

You can unbox value types to restore the original value type.

When you specify TYPE classname in the data item definition:

  • If classname represents a reference type, you get a reference type object.
  • If classname represents a value type, you get a value type object.

During boxing, the system copies the value into the object heap and returns a reference to it. When the reference is no longer active (because nothing in the program is holding on to it), the space in the object heap will eventually be regained by the garbage collector.

See the ValueTypes sample, available from Start > All Programs > Micro Focus Studio Enterprise Edition > Samples and under COBOL for .NET.

Type Information

Every class has an associated root object, which can be used to get information about the class such as its fields and methods. To obtain type information, you use the following:

  • In NET COBOL, GetType() - to obtain the System.Type object for an object reference
  • In JVM COBOL, getClass() - to obtain the java.lang.Object to obtain the class of an object reference
  • TYPE OF - to obtain the System.Type object for a class, interface, delegate or enumeration
    imperative-clause TYPE OF object

For example, in .NET COBOL:

*> Type information
01 x binary-long.
display x::GetType            *> Prints System.Int32
display type of binary-long   *> Prints System.Int32
display x::GetType::Name      *> Prints Int32

For example, in JVM COBOL:

*> Type information
01 x binary-long.
display x::getClass           *> Prints System.Int32
display type of binary-long   *> Prints System.Int32
display x::getClass::Name     *> Prints Int32

Type Conversion Operators

A conversion operator converts a data item from one data type into another, such as from a type that you have defined into a integer. Conversion operators can be overloaded, so that the appropriate conversion operator is used according to the parameter types in the calling code.

For example, the type Timer, which contains hours and minutes, is converted into minutes as binary-long using the following conversion operator:

       set myMins to timer3 ...
       operator-id Implicit.
       procedure division using value a as type Timer
                          returning b as binary-long.
            set b to a::pHour * 60 + a::pMins
       end operator.

Similarly, you can convert from a binary-long data item (representing a number of minutes) to the type Timer, which is expressed in hours and minutes, using the following conversion operator:

       set timer4 to myMins ...
       operator-id Implicit.
       procedure division using value a as binary-long
                          returning b as type Timer.
             set b to new Timer
             if a >= 60
                 set b::pHour to 1
                 set b::pMins to a - 60
             else
                 set b::pMins to a
             end-if
       end operator.

You can define explicit conversions, in addition to implicit conversions. They differ as follows:

Explicit conversions
Explicit conversions occur only in statements that explicitly state the type to convert from. For example, where the conversion operator is defined as explicit, only the second statement below works:
       set timer4 to myString                *> fails
       set timer4 to myString as type Timer  *> succeeds
       operator-id Explicit.
       01 strH type String.
       01 strM type String.
       01 colonPos  binary-long value 0.

       procedure division using value a as String returning b as Type Timer.
           set b to new Timer()
           set colonPos to a::IndexOf(":")
           try
               set strH to a::Substring(0 colonPos)
               set strM to a::Substring(colonPos + 1 2)
               set b::pHour to type Int32::Parse(strH)
               set b::pMins to type Int32::Parse(strM)
           catch
               display "Invalid time format"
           end-try
       end operator.

You use explicit conversions (as opposed to implicit ones) where the conversion has the potential to lose information or throw an exception. In the above example, the string might contain text or be invalid somehow. In this case, a try-catch block is required to handle the failure.

Implicit conversions
Implicit conversions can occur in all sorts of places, such as assignments and member invocations and an explicit conversion. See the earlier examples.

You can invoke an implicit conversion implicitly or explicitly. For example, the following statements both invoke the implicit conversion:

       set myMins to timer3
       set myMins to timer3 as binary-long

You use implicit conversions where the conversion is reliable, where it will not lose information and will not throw an exception.

Casting Object References Using AS

You can cast an object reference to an instance of another type using AS. The Compiler can then check whether the operation is type safe or not.

In the following example, we know that obj-object points to a System.AppDomain reference so we know we can cast up the class hierarchy from System.Object to System.AppDomain.

    *> set obj-app-domain to obj-object             *> fails if uncommented
     set obj-app-domain to obj-object as type System.AppDomain *> succeeds

Casts can be inline, so you can do the following:

display obj-object as type System.AppDomain::FriendlyName

A cast is only legal if the target type (the type being cast to) derives directly from the source type, or vice versa. In the following statement a System.Type reference (obj-type) can never point to a System.AppDomain instance because the classes are unrelated in the hierarchy.

       *>set obj-app-domain to obj-type as type System.AppDomain *> fails if uncommented

If the cast fails, a System.InvalidCastException is thrown by the CLR. To avoid this, either test for a valid cast first using INSTANCE OF or wrap the cast in an exception block (see exception handling example for more information).

An exception is thrown in the following as we are claiming obj-object references a System.AppDomain instance where in fact it's referencing a System.Type instance.

   *> these statements fail if uncommented
       *> set obj-object to obj-type
       *> set obj-app-domain to obj-object as type System.AppDomain
Parent topic: Concepts - Managed COBOL
Related reference
Procedure Division Header
INVOKE Statement
Type Specifier
Related information
Data Types - in COBOL and C#
Type Compatibility of Managed COBOL with Other Managed Languages
Type Mappings from Native COBOL to Managed Code


Type Compatibility of Managed COBOL with Other Managed Languages

Many managed COBOL types have a strict correspondence with managed types in other languages, such as binary-long and float-short. For those that don't have a correspondence, there are alternatives.

The following table lists the correspondence between managed COBOL types and classes and types in other managed languages.

Managed COBOL | .NET class | JVM type | C# type | Description
Integer types:
binary-char | System.SByte | byte | sbyte | An 8-bit signed integer Not CLS-compliant
binary-char unsigned | System.Byte |  | byte | An 8-bit unsigned integer
binary-short | System.Int16 | short | short | A 16-bit unsigned integer Not CLS-compliant
binary-short unsigned | System.UInt16 |  | ushort | A 16-bit signed integer
binary-long | System.Int32 | int | int | A 32-bit signed integer
binary-long unsigned | System.UInt32 |  | uint | A 32-bit unsigned integer Not CLS-compliant.
binary-double | System.Int64 | long | long | A 64-bit signed integer
binary-double unsigned | System.UInt64 |  | ulong | A 64-bit unsigned integer Not CLS-compliant
Floating point types:
float-short | System.Single | float | float | A single-precision (32-bit) floating-point number
float-long | System.Double | double | double | A double-precision (64-bit) floating-point number
Logical Types:
condition-value | System.Boolean | boolean | bool | A boolean value (true or false)
Other types:
pic n usage national | System.Char | char | char | A unicode (16-bit) character
object reference sys-Decimal * | System.Decimal |  | decimal | A 96-bit decimal value
object reference sys-IntPtr * | System.IntPtr |  |  | A signed integer whose size depends on the underlying platform (a 32-bit value on a 32-bit platform and a 64-bit value on a 64-bit platform)
object reference sys-UIntPtr * | System.UIntPtr |  |  | An unsigned integer whose size depends on the underlying platform (a 32- bit value on a 32-bit platform and a 64-bit value on a 64-bit platform) Not CLS-compliant
Class objects:
object reference | System.Object | java.lang.Object | object | The root of the object hierarchy
object reference sys-String * | System.String | java.lang.String | string | An immutable, fixed-length string of Unicode characters

Where sys-decimal, sys-IntPtr, sys-UIntPtr, sys-Object and sysString are names that you choose, and where the code defines these as follows:

repository .
    class sys-decimal as "System.Decimal"
    class sys-IntPtr as "System.IntPtr"
    class sys-UIntPtr as "System.UIntPtr"
    class sys-Object as "System.Object"
    class sys-String as "System.String"
.
Parent topic: Concepts - Managed COBOL
Parent topic: Managed COBOL
Related reference
Procedure Division Header
Type Specifier
Related information
Type Compatibility in Interoperation with Managed Code
Types and Type Conversion
Data Types - in COBOL and C#
Type Mappings from Native COBOL to Managed Code


MicroFocus.COBOL.RuntimeServices

MicroFocus.COBOL.RuntimeServices assembly provides the following classes:

  • CallableAttribute
  • CharsetAttribute
  • Interop
  • MarshallUtils
  • RunUnit
Restriction: MicroFocus.COBOL.RuntimeServices are supported for .NET managed COBOL only.

The Help is available in the file MicroFocus.COBOL.RuntimeServices.chm, which is installed in the Help folder of your installation. The default location is %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Help.

To open the Help, double-click MicroFocus.COBOL.RuntimeServices.chm in Windows Explorer.

Parent topic: Managed COBOL
Related information
Developing an Application for Multiple Run Units in .NET


Open PL/I Language Reference Manual

This book provides a reference to the language used in Micro Focus Open PL/I.

  • Language Concepts
    This chapter provides an overview of the Open PL/I language, explaining the following basic concepts: program structure and statement syntax, block structure, variables, files, input and output.
  • Data Types
    This chapter discusses the various data types that are available to you in Open PL/I.
  • Storage Classes
    This chapter describes storage classes and how they are used.
  • Declarations and Attributes
    This chapter explains how label prefixes and DECLARE statements are used for declarations, and also describes the attributes that can be used in a DECLARE statement.
  • References
    This chapter describes each type of reference and the rules and basic steps involved in resolving references.
  • Expressions
    This chapter explains expressions and how they are used.
  • Data Type Conversions
    This chapter defines the conversions that result from assignments to arithmetic variables, bit-string variables, and pictured variables.
  • Statements
    This chapter defines the Open PL/I statements. The statements are presented in alphabetical order by name.
  • Open PL/I Built-ins
    This chapter defines the built-in functions and subroutines provided by Open PL/I.
  • Open PL/I Macro Preprocessor
  • Features Unsupported by Open PL/I
    A list of features that are currently unsupported by Open PL/I.
  • Glossary
    This chapter provides definitions for terms used in the Open PL/I manuals.
Parent topic: General Reference
Related information
Language Concepts


Language Concepts

  • Statements
  • Names
  • Constants
  • Punctuation
  • Comments
  • Statement Sub-Groups
  • Text Replacement and Insertion Statements
  • Modules
  • Blocks
  • BEGIN Blocks
  • Variables
  • Files
  • Input and Output
Parent topic: Open PL/I Language Reference Manual


Statements

Open PL/I is a block-structured language. Each block consists of a group of statements. Statements are used to declare constants and variables, and to express actions to be performed by your program. For example:

READ FILE (G) INTO (Y) ;

In this example, the READ statement reads the next record in file G into storage Y.

Each Open PL/I statement consists of a series of elements ending with a semicolon. These elements can be PL/I keywords, user-specified identifiers, literal constants, or punctuation symbols.

Parent topic: Language Concepts


Names

A name used to denote part of a statement such as a verb, option, or clause, is called a keyword. All statements, except the assignment statement, begin with a keyword that identifies the purpose of the statement.

A name can also denote an object operated upon by the program, such as a variable, file, or label. These names are known as identifiers. Their meanings are established by a declaration.

In this example, G and Y are identifiers. READ, FILE, and INTO are keywords.

READ FILE (G) INTO (Y) ;

There are no reserved words in Open PL/I. In this example, TO names a storage location.

GOTO L;
CALL S(B,C,D);
RETURN;
STOP;
DO K = 1 TO 11;
TO = 20; /* ASSIGNMENT STATEMENT*/

The following example shows how names can either establish an object to be operated on or denote part of a statement.

DECLARE X(5) FIXED;
L: X(3) = 25;

Both X and L are identifiers, but DECLARE and FIXED are keywords. X is declared by a DECLARE statement; L is implicitly declared as a label.

A name consists of any combination of the following:

  • letters
  • digits
  • _ (underscore character)
  • @ (at sign character)
  • # (pound sign character)
  • $ (dollar sign character)
  • a sequence of any of the above characters

The following rules apply to names.

  • Any of the alphanumeric characters A through Z, a through z, and 0 through 9 can be used.
  • A name must not contain more than 32 characters.
  • Names cannot contain blanks or hyphens.

Examples:

STREET_NAME
@BETA
#Y7
C
$7

Names can be written using both uppercase and lowercase letters.

By default, all lowercase letters are interpreted as their uppercase equivalents. The -lowercase compiler option causes the reverse of this behavior. Refer to the Open PL/I User's Guide for more information on this option.

Because there are no reserved names in Open PL/I. Names that are used as keywords, such as READ or INTO, can also be identifiers. However, this practice makes programs difficult to read and should be avoided whenever possible.

  • Declarations of Names
  • References to Names
Parent topic: Language Concepts
Related information
Open PL/I User's Guide


Declarations of Names

The meaning of a name is normally determined by its declaration. However, in some cases a name can be implicitly declared by the context in which it is used. (For more information, see the sections Compiler-supplied Defaults and DEFAULT .) The declaration of a name consists of a user-specified identifier and the attributes of that name.

Open PL/I permits two kinds of explicit declarations: the DECLARE statement and the label prefix.

The DECLARE statement declares the names of files, variables, and external procedures. A DECLARE statement can appear anywhere within the program, except as part of a compound statement. Regardless of where it appears, DECLARE is not an executable statement and has no effect except to establish the meaning of names.

Examples:

DECLARE F FILE;
DECLARE A(5) FLOAT;
DECLARE (I,J,K) FIXED BINARY(15);

In the previous examples, F is declared as the name of a file constant; A is declared as a floating-point array variable; and I, J, and K are declared as integer variables.

A label, also called a label prefix, is a user-specified identifier that names a statement so that it can be referenced elsewhere in your program. The label comes before the statement and is terminated with a colon (:).

Examples:

F: FORMAT(F(8,2),A(5));
P: PROCEDURE;
L: READ FILE(F) INTO(X);

In these examples, F is declared as a format name, P as a procedure name, and L as a statement label.

Labels can appear on all Open PL/I statements except DECLARE statements, target statements of ON statements (called ON-units), ELSE or THEN clauses in IF statements, and WHEN or OTHERWISE clauses in SELECT statements.

Parent topic: Names
Related information
Compiler-supplied Defaults
DEFAULT
ON


References to Names

Use of a name in any context, other than in a declaration, constitutes a reference to the name. To determine the meaning of the reference, the Compiler searches for a declaration of the name. This search resolves the reference by associating it with a declaration. For example:

DECLARE A FIXED BINARY(15);
DECLARE B FLOAT;

B = B+1;

A = A+1;

In the previous example, the Compiler knows that it must generate a floating-point add for B+1 because it has resolved the reference B to the second DECLARE statement. Likewise, it knows that it must generate an integer add for A+1 because it has resolved the reference A to the first DECLARE statement.

Parent topic: Names
Related information
Reference Resolution


Constants

A constant is a sequence of characters that represents a particular, unchanging value. In Open PL/I, five kinds of constants are permissible:

  • Literal constants

    These are actual numbers or strings written in the source program. Literal constants are restricted to character strings, bit strings, and fixed- or floating-point numbers.

  • Label constants

    These are established using a label prefix in the source program that declares a name either as the name of a format or a procedure, or as a statement label. Label constants cannot be declared in a DECLARE statement.

  • File and entry constants

    These constants are typically established by DECLARE statements. File constants are identifiers declared with the FILE attribute to describe the type of input/output to be performed on a file. Entry constants are used to invoke procedures at certain entry points.

  • Replace constants

    These are identifiers that are to be changed with the %REPLACE statement. Like literal constants, constant identifiers can also be character strings, bit strings, and fixed- or floating-point decimal numbers.

  • Named constants

    These constants are scalar identifiers that are declared by the VALUE attribute. They can be declared for arithmetic data, string data, and for pointers and offsets.

Examples:

Constant | Type
25 | Integer constant
7.5 | Fixed-point decimal constant
3.12E-01 | Floating-point decimal constant
'How are you?' | Character-string constant
'1'B | Bit-string constant (binary notation)
'1011'B | Bit-string constant (binary notation)
'775'B3 | Bit-string constant (octal notation)
'A7O'B4 | Bit-string constant (hexadecimal notation)
'100'XN | Binary fixed-point (XN) constant (hexadecimal notation)
STARTUPD: | Label constant
%REPLACE TABLE_SIZE BY 350; | TABLE_SIZE is an identifier to be replaced by an integer constant
DECLARE E ENTRY; | E is an entry constant
DECLARE F FILE; | F is a file constant

For a table showing the expansion of nonbinary notation into binary notation, see the section Bit-String Data.

Arithmetic constants represent decimal values, whereas binary arithmetic values have no constant representation. Nevertheless, any decimal constant can be converted easily to a binary value by using it in a context that expects a binary arithmetic value.

As a result of Open PL/I language rules, all constants that appear as floating-point numbers in a source program are actually of type float decimal and are subject to the rules of float decimal arithmetic.

A character-string constant can contain any character, except that, if an apostrophe is required within a character-string constant, it is written as two apostrophes. For example,

'He said, "I''m fine."'
Note:

The double quotation mark character is not equivalent to a single quotation mark or two adjacent single quotation marks and has no more significance than any other character within a constant.

In Open PL/I, the maximum size of a string constant is 256 characters or bits (for details, see the section Open PL/I Compiler Implementation Limits). The Compiler checks this limit after bit-string constants written in the B2, B3, or B4 format have been expanded. Refer to the data type descriptions in the chapter Language Concepts in your Open PL/I User's Guide for the maximum size limits for floating- and fixed-point data.

A named constant is similar to a scalar declaration with the appropriate data attributes, plus the VALUE attribute. The VALUE attribute signifies this identifier is a named constant, with all of the attributes taken as applied to the declaration.

Named constants differ from simple constants in that they retain the attributes from the declaration. For example,

declare i fixed bin (15) value(1);
declare j fixed bin (15);

j = 1;    /* 1 is fixed decimal, requires conversion */
j = i;    /* i is fixed bin (15), no conversion (integer 1 assigned, not "i" ) */

For string data items, the length is determined from the length of the string value when the length is not specified.

declare string char value ('abcdef') ; /* string is char(6) */

An XN constant is a SIGNED REAL fixed binary constant in hexadecimal notation. An XN constant with eight or fewer digits has a precision of 31. An XN constant with more than eight digits has a precision of 63.

The XN constant hexadecimal value is the value specified, padded on the left with hexadecimal zeros if needed. For example:

'102'XN 			/* same as '00000102'XN with value 258 */
'9C40'XN /* same as '00009C40'XN with value 40,000 */
'7FFF'XN /* same as '00007FFF'XN with value 32,767 */

In Open-PLI, named constants can be declared as arithmetic or string; pointers and offsets are not yet supported. Named constants can be declared before or after being used, and the same scoping rules as any declaration apply.

Example:

cool: proc options(main);

   dcl pname char (16) value (procedurename());

   dcl flag bit(1) aligned static init(true);

   dcl true bit(1) value ('1'b);
   dcl false bit(1) value('0'b);

   dcl myarr (n) fixed bin (15);

   dcl n fixed bin(15) value (800);

   dcl arr (k/3) fixed bin (15) static init (k+1, k, k+3);

   dcl arr1 (100+100) fixed bin (15);
   dcl arr2 (n+100) fixed bin (15);

   dcl i fixed bin (15);
   dcl k fixed bin (15) value (9);

   if flag then
       put skip list ('Named Constants are ', pname);

   put skip list(arr);

   i = n + 100;
   arr1 (k) = 99;

   put skip list (size(arr1), size(arr2), i, arr1(K*2-K));

   put skip list(arr);
end;

Named Constants are     COOL
       10               9              12
      400            1800             900              99
       10               9              12

You can punctuate arithmetic, bit, and hexadecimal constants with the break character ( _ ) to improve readability. For example:

'1100_1111'B is the same as '11001111'B

'F_E'B4 is the same as 'fe'b4

16_666_667 is the same as 16666667

Parent topic: Language Concepts
Related information
Text Replacement and Insertion Statements
Bit-String Data
Open PL/I Compiler Implementation Limits
B-Format
Language Concepts


Punctuation

In Open PL/I, punctuation symbols are either operators or separators.

Operators define the arithmetic or comparative operations to be performed on expressions in a statement. The table below lists the Open PL/I operators.

Symbol | Meaning
+ | Addition or the plus prefix
- | Subtraction or the minus prefix
* | Multiplication
** | Exponentiation
/ | Division
^ or ~ | Logical NOT
| or ! | Logical OR
& | Logical AND
> | Greater than
< | Less than
= | Equal to
^> or –> | Not greater than
^< or –< | Not less than
^= or ~= | Not equal to
>= | Greater than or equal to
<= | Less than or equal to
|| or !! | String concatenation
–> | Pointer resolution

Separators delimit and separate identifiers, keywords, and constants in statements. The table below lists the Open PL/I separators.

Symbol
 | Meaning
( ) | Encloses lists, defines order of expression evaluation, separates names of statements and options from specific keywords
, (comma) | Separates subscripts and procedure arguments, separates identifiers in a structure name, and precedes the BY NAME option
' (single quote) | Delimits bit strings and character strings
. (period) | Specifies a decimal point. Connects elements of a qualified name
: | Terminates a procedure name or a statement label
; | Delimits statements

Names and constants may be separated from one another by one or more blanks, or tabs, rather than by separators. Additional blanks surrounding punctuation symbols are optional. In the following examples, blanks are represented by boxes ( Blank representation).

Examples of blank usage

The first statement requires no blanks because each name is separated from the next by a punctuation symbol. The second statement shows the optional use of extra blanks. The third statement shows optional blanks surrounding the equal symbol (=) and after the semicolon, the remaining blanks being required blanks.

Note that when an arithmetic constant is followed by a name, at least one blank or punctuation symbol is required to separate the arithmetic constant from the name.

Parent topic: Language Concepts


Comments

Comments are used to document an Open PL/I program. A comment can appear anywhere that a blank can appear and is equivalent to a blank. Comments cannot be nested. The general form of a comment is:

/*Comments open with a slash* and close with a *slash */

For example,

/*HERE IS A COMMENT*/
IF A<25 /* HERE IS ANOTHER ONE */ THEN
/*HERE IS AN /* ERRONEOUS */ COMMENT */

The final comment is invalid because comments cannot be nested; it ends at the first * / in the line and the Compiler attempts to interpret COMMENT */ as code and produces an error message.

The Compiler puts an asterisk (*) into the line number field of the listing file for each line on which a comment is continued from a preceding line. This convention can be used to determine if some text was accidentally included in a comment.

Comments can continue over any number of lines of program text; thus, if the */ is omitted from a comment, all program text up to the next */ is considered part of the comment. This causes part of the program to be ignored by the Compiler and may cause it to produce misleading error messages. The same problem occurs if a character-string or bit-string constant is not terminated with an apostrophe.

Parent topic: Language Concepts


Statement Sub-Groups

This section introduces certain Open PL/I statements that, alone or in conjunction with other statements, provide specific capabilities within Open PL/I.

  • Compound Statements
  • Statements that Alter the Order of Execution
  • Statement that Handles Exception Conditions
Parent topic: Language Concepts
Related information
Statements


Compound Statements

Open PL/I has four compound statements:

  • IF
  • ON
  • DO
  • SELECT

They are called compound statements because they each contain other statements.

  • IF Statement
  • ON Statement
  • DO Statement
  • SELECT Statement
Parent topic: Statement Sub-Groups


IF Statement

The IF statement tests an expression and performs a specified action if the result of the expression is true. Its general form is:

IF expression
    THEN statement;
    [ELSE statement];

where expression is any valid expression that yields a scalar bit-string value, and statement is any unlabeled statement (except DECLARE, END, ENTRY, FORMAT, or PROCEDURE) or an unlabeled DO-group or BEGIN block. For example:

IF A>B
    THEN READ FILE (F) INTO (X);

In this example, the IF statement contains the READ statement. If the expression A>B is true, the READ statement executes.

The IF statement needs no semicolon of its own because each statement contained within it has its own semicolon. IF statements can be nested, as shown in the following example.

IF A>B
    THEN IF D<C
        THEN READ FILE(F) INTO(X);
        ELSE STOP;

In this example, the second IF statement has both a THEN clause and an ELSE clause. An ELSE clause always corresponds to the THEN clause that immediately precedes it. The first IF statement has only a THEN clause. If you want to STOP when A ^> B, you may provide a null ELSE clause to the innermost IF, forcing the ELSE STOP to be associated with the first IF. It is preferable to use structured IF, THEN, and DO statements to accomplish this, as shown in the following example.

IF A>B THEN DO;
    IF D<C THEN READ FILE(F) INTO (X);
    END;
ELSE STOP;
Parent topic: Compound Statements


ON Statement

The ON statement defines the action to be taken when a specific condition is signaled during the execution of a program. Its general form is:

ON condition–name ON-unit,

or

ON condition–name SYSTEM

where:

condition-name is ANYCONDITION, AREA, ATTENTION, CONDITION(name), CONVERSION, ENDFILE(f), ENDPAGE(f), ERROR, FINISH, KEY(f), OVERFLOW, RECORD(f), SIZE, UNDEFINEDFILE(f), UNDERFLOW, USERCONDITION(expression), USERCONDITION(SS$_UNWIND), or ZERODIVIDE.

ON-unit is a BEGIN block or any statement other than DECLARE, DEFAULT, DO, END, ENTRY, FORMAT, LEAVE, OTHERWISE, PROCEDURE, RETURN, or SELECT.

The keyword SYSTEM indicates that, instead of executing user-specified code in the ON-unit, a system-generated message describing the condition is displayed and the ERROR condition is signaled. For example:

ON ENDFILE (F )
    BEGIN;
       .
       .
       .
    END;

In this example, the block of statements between the BEGIN and END statement executes if the end-of-file condition is reached.

ON is a compound statement, but it cannot be nested. The ON statement's use in responding to exceptional conditions is explained more fully in the section Statement that Handles Exception Conditions.

Parent topic: Compound Statements
Related information
Statement that Handles Exception Conditions


DO Statement

The DO statement begins a sequence of statements to be executed in a group, called a DO-group. Its general form is:

DO;
  .
  .
  .
END;

For example:

IF B < C THEN DO;
   PUT LIST ('ADDED DATA REQUIRED');
   GET LIST (VALUE);
   B = B + VALUE;
   END;

In this example, the PUT LIST, GET LIST, and assignment statements execute if B < C.

DO statements can contain IF statements, other DO-groups, RETURN statements, or GOTO statements that alter the order of execution.

Parent topic: Compound Statements


SELECT Statement

The SELECT statement tests a series of expressions and performs the action specified with the first true test, or the action associated with the OTHERWISE clause (if present) and none of the tests evaluates true. Its general form is:

SELECT[select-expression];
    WHEN (e1[,e2[,e3[...]]])    action_1;
    WHEN (e4[,e5[,e6[...]]])    action_2;
       .
       .
       .
    [OTHERWISE action_m;]
END;

where select-expression and e1, e2... are valid expressions, and each action is a single or compound statement or a BEGIN block. For example:

SELECT;
    WHEN (F=40) G=G+1;
    WHEN (F=50) IF G > 0 THEN G=G+2;
       .
       .
       .
    OTHERWISE DO;
              .
              .
              .
              END;
END;

This example shows the SELECT statement used with the expression omitted. When the expression is omitted from the SELECT statement, each WHEN clause expression is evaluated and converted, if necessary, to a bit string. The action after the WHEN clause is performed if the resulting bit string is nonzero. In the above example, if F=40 is true, the action G=G+1 is executed and the SELECT group is exited. If F=50 is true, the IF statement is executed and the SELECT group is exited. If more than one WHEN statement is true, the action associated with the first true WHEN clause is executed. If no WHEN clauses are true, the DO group associated with the OTHERWISE clause is executed.

When control reaches a SELECT statement with a select–expression present, the select-expression is evaluated and its value saved. Next, the expressions in the WHEN clauses are evaluated in the order in which they appear, and each value is compared with the value of select–expression. If a value is found that is equal to the value of select–expression, the action following the corresponding WHEN clause is performed, and no further WHEN clause expressions are evaluated. If none of the expressions in the WHEN clauses is equal to the select–expression, the action specified after the OTHERWISE clause is executed unconditionally. for more information, see the section SELECT in the chapter Statements.

Parent topic: Compound Statements
Related information
SELECT


Statements that Alter the Order of Execution

Statements are typically executed in the order in which they are written; however, certain statements control the order of execution of the program. These statements are GOTO (used with a statement label), IF, and DO.

The GOTO statement causes control to be transferred to a labeled statement in the current procedure or in another active procedure. Its general form is:

GOTO label–reference[OTHERWISE];

or

GO TO label–reference[OTHERWISE];

where:

label–reference is a label constant or an expression that, when evaluated, yields a label value. (A label value denotes a statement in the program.) For example:

A = 5;
   GOTO L2;
L1:
   B = 7;
     .
     .
     .
L2:
   B = 4;

In this example, A is assigned 5 and B is assigned 4. The statements beginning with label L1 can be executed only if a GOTO statement transfers control to the label L1.

Although labels are a convenient means to represent a specific location in a program, programs that contain many labels are generally more difficult to read and modify. The use of labels and GOTOs can be avoided or minimized by using the compound statements IF and DO to control the order of statement execution.

The DO statement causes all statements between the DO statement and its corresponding END statement to be executed a number of times as determined by the form of the DO statement.

Parent topic: Statement Sub-Groups


Statement that Handles Exception Conditions

The ON statement gives your Open PL/I programs the ability to respond to exception conditions that occur during the execution of a program, such as end-of-file, or computational errors such as division by zero. For example:

ON ERROR
   BEGIN;
      .
      .
      .
   END;

Execution of the ON statement establishes the ON-unit as a block of statements that are executed if the specified condition occurs. If the specified condition occurs after the ON statement is executed, processing is interrupted and the specified ON–unit is executed. In the above example, the block of statements between the BEGIN and END statements are established as the ON–unit, which executes if the ERROR condition occurs. Execution of the ON statement does not cause immediate execution of the ON-unit.

An ON-unit is established within its containing block's current activation and remains established until that block returns to its caller, or until another ON-unit is established for the same condition within the same block activation, or until the ON-unit is reverted using the REVERT statement.

If one of the possible conditions occurs during the execution of a block, and that block does not have an established ON-unit for that condition, the calling block's ON-unit is used to respond to the condition. If the calling block has no established ON-unit for the condition, its caller's ON-unit is used, and so on. If no ancestor has an ON-unit for the condition, a default action is taken. Except for the ENDPAGE, FINISH, and UNDERFLOW conditions, this default action ends program execution and issues a run-time error message.

ON-units for the ERROR condition cannot resume execution of the statement in which the error was detected.

Parent topic: Statement Sub-Groups


Text Replacement and Insertion Statements

When a program module is being compiled, the Compiler is able to recognize and evaluate two statements that alter the program text: %INCLUDE and %REPLACE. Both of these statements can be used anywhere within a procedure or source file to simplify the job of writing programs.

Other statements that alter program text are described in Open PL/I Macro Preprocessor.

  • The %INCLUDE Statement
  • The %REPLACE Statement
Parent topic: Language Concepts
Related information
Open PL/I Macro Preprocessor


The %INCLUDE Statement

The %INCLUDE statement incorporates text from other files into the current source file during compilation. The general form of this statement is:

%INCLUDE filename[,filename]...;

where:

filename is one of the following:

  • A character string
  • An Open PL/I name
  • An Open PL/I name enclosed in parentheses

The specified filename is used to locate a text file whose content is inserted into the program text in place of the %INCLUDE statement.

Your selection of one of these forms in combination with the presence or absence of the -ipath compiler option affects the search pattern used in locating files to be included. For more information, see the section %INCLUDE in the chapter Statements.

Note:

The Open PL/I Macro Preprocessor has its own %INCLUDE statement. Its use is documented in the appendix Open PL/I Macro Preprocessor.

Parent topic: Text Replacement and Insertion Statements
Related information
%INCLUDE
Open PL/I Macro Preprocessor


The %REPLACE Statement

The %REPLACE statement specifies that an identifier is to be replaced by a specified constant or other name during compilation. The general form of this statement is:

%REPLACE name BY constant-or-name;

Beginning at the point at which the %REPLACE statement is encountered, each occurrence of name that follows the %REPLACE statement is replaced by the specified constant or other name until the end of compilation.

The %REPLACE statement is often used to supply the sizes of tables or to give names to special constants whose meaning would not otherwise be obvious. For example:

%REPLACE TRUE BY '1'B;
%REPLACE TABLE_SIZE BY 400;
%REPLACE MOTOR_POOL BY 5;
%REPLACE X BY -3.0E0;
DECLARE X(TABLE_SIZE) FIXED STATIC;
DO K = 1 TO TABLE_SIZE;
IF DEPARTMENT_NUMBER = MOTOR_POOL
   THEN DO;
    .
    .
    .

Both the %REPLACE and %INCLUDE statements operate on the program text without regard to the meaning of the text.

The %REPLACE statement substitutes all subsequent occurrences of the name without regard to the block structure of the module, as explained in the section Blocks.

Parent topic: Text Replacement and Insertion Statements
Related information
Blocks


Modules

One or more external procedures can be present within a single Open PL/I source file. All external procedures within a source file will be compiled by the Compiler into a single object file.

A module is defined as a single compilation unit, a source file that is compiled into object code. A module consists of one or more external procedures.

A source file may contain declarations that appear outside the scope of any external procedure, as long as all variables that appear in such declarations are BASED, STATIC, or DEFINED. A variable that is defined this way is known within the scope of all external procedures. If a declaration is provided with the EXTERNAL attribute, it will be known outside the source file.

A source file may also contain %REPLACE statements and declarations of named constants (for example, file and entry constants) before the first external procedure.

The following example illustrates a source file that has declarations and %REPLACE statements preceding the first external procedure. There are two procedures (GETREC and PUTREC) in the source file that can be used as part of the program. By default, Open PL/I declares these entry constants, GETREC and PUTREC, with the EXTERNAL attribute; therefore, a procedure from another module outside of this source file can invoke GETREC or PUTREC. If a procedure in another module needs to reference GETREC and PUTREC, they must be declared within that module with the attributes ENTRY and EXTERNAL.

At the top of this source file are other items (REC, NAME, ADDRESS) that are hidden from any procedures compiled in other modules, and are known only to GETREC and PUTREC. Because Open PL/I, by default, provides file constant declarations with the EXTERNAL attribute, the file DATA_BASE can be known in other modules.

%REPLACE DATA_SIZE BY 80;
DECLARE 1 REC BASED
            2 NAME CHAR(40),
            2 ADDRESS CHAR(DATA_SIZE);
DECLARE DATA_BASE KEYED FILE UPDATE;

GETREC: PROCEDURE(P);
DECLARE P POINTER;
READ FILE(DATA_BASE) INTO(P->REC);
END GETREC;

PUTREC: PROCEDURE(P);
   DECLARE P POINTER;
    REWRITE FILE(DATA_BASE) FROM(P->REC);
END PUTREC;
Parent topic: Language Concepts


Blocks

PL/I is a block-structured language. Just as certain language elements make up statements, groups of statements make up blocks. Two types of blocks exist in Open PL/I:

  • Procedure blocks
  • BEGIN blocks

A procedure block is the basic executable program unit of Open PL/I and is made up of a group of statements contained within the limits of a pair of statements, PROCEDURE and END.

A BEGIN block is a program unit into which control flows during the typical execution of a procedure. The statements within a BEGIN block are contained within the limits of a pair of statements, BEGIN and END.

Whenever a procedure block or BEGIN block is entered, a block activation is created for that block. The block activation consists of the allocation of storage for the variables declared within the block and the system information that links that block to the previous block in the activation chain.

The following sections provide detailed information on procedure and BEGIN blocks and activation of these blocks.

  • Procedure Blocks
Parent topic: Language Concepts


Procedure Blocks

A procedure is a sequence of statements beginning with a PROCEDURE statement and ending with an END statement. The purpose of a procedure is to "package" a set of executable statements and declarations to form a block that can be executed from several places in the program simply by calling it. Because a procedure defines a block of statements, it is typically called a procedure block. The following example shows two procedure blocks, A and B:

A: PROCEDURE;
      .
      .
      .
   END A;

B: PROCEDURE;
      .
      .
      .
   END B;

Procedures contained within other procedures are called nested or internal procedures. Procedures not contained within other procedures are called external procedures. A program module consists of one or more external procedures. For example:

A: PROCEDURE;
      .
      .
      .
   B: PROCEDURE;
             .
             .
             .
   END B;
   C: PROCEDURE
      .
      .
      .
      D: PROCEDURE;
             .
             .
             .
      END D;
   END C;
END A;

In this example, Procedure A is external, and procedures B and C are nested within it. Procedure D is nested within procedure C.

  • Scope
  • Calls and Returns
  • Parameters and Arguments
  • Block Activation and Recursion
  • Guidelines for Using Procedures
  • Dynamic Fetching and Releasing of External Procedures
Parent topic: Blocks


Scope

Each procedure block establishes a distinct region of the program text called "scope," throughout which the names declared within that procedure block are known. The scope of a name is defined as the region of the program in which the name has meaning and can be referenced.

The scope of a name includes the procedure in which the name is declared and all procedures contained within that procedure, except those contained procedures in which the same name is redeclared. For example:

A: PROCEDURE;
   DECLARE (X,Y) FLOAT;
      .
      .
      .
   B: PROCEDURE;
      DECLARE X FILE;
      DECLARE Z FIXED;
            .
            .
            .
   END B;
END A;

In this example, the scope of Y includes both procedure A and procedure B. The scope of X as a float is only procedure A. The scope of X as a file is procedure B. The scope of Z is procedure B. Z cannot be referenced from within procedure A. The scope of the procedure name B includes both procedure A and procedure B.

Parent topic: Procedure Blocks


Calls and Returns

Statements within a procedure block are executed only when the procedure block is called from another procedure block. The CALL statement enables procedure calling. For example:

A: PROCEDURE;
      .
      .
      .
   CALL B;
      .
      .
      .
B: PROCEDURE;
      .
      .
      .
   END B;
      .
      .
      .
   END A;

In this example, procedure B is executed only when it is called from procedure A. Procedure A resumes execution at the statement following the call when B is completed.

A procedure returns to its caller either by executing its END statement or by executing a RETURN statement, as shown in the following example:

A: PROCEDURE;
      .
      .
      .
   IF X<0 THEN RETURN;
      .
      .
      .
   END A;

Control does not "flow" into a procedure; that is, if control reaches a statement immediately preceding a procedure declaration, then (unless the statement is a control-flow statement such as GOTO) control will automatically skip to the statement following the declared procedure.

Parent topic: Procedure Blocks


Parameters and Arguments

The usefulness of a procedure block is increased greatly if it can be made to operate on different values each time it is called. Arguments and parameters enable such operation.

Arguments are the values passed to a procedure block at invocation. Parameters are the names used by the invoked procedure block to refer to these arguments.

Open PL/I typically passes an argument to an invoked procedure by referencing its storage address.

For example:

   CALL P(A,B);
      .
      .
      .
   CALL P(D,E);
      .
      .
      .
P: PROCEDURE(X,Y);
      .
      .
      .
   PUT FILE (F) LIST(X,Y);
      .
      .
      .
   END P;

In this example, A and B are arguments of the first call to the procedure P. While P is executing as a result of the first call, the argument A is said to correspond to the parameter X and the argument B corresponds to the parameter Y. While P is executing as a result of the second call, D corresponds to X and E corresponds to Y.

When an argument is a variable, the actual address of the variable is passed to the called procedure. This allows the invoked procedure to change the value of the argument.

When an argument is a constant or an expression, a temporary location is used to store the current value of the argument, and the address of that temporary location is passed to the called procedure.

Parent topic: Procedure Blocks


Block Activation and Recursion

Each time a procedure block is called, it is said to be active, and it remains active until it returns from the call (or until a non-local GOTO transfers control to a containing block activation). Such procedure activation has an associated block of storage allocated on a stack. This block of storage is called a stack frame, and it is used to hold information (such as the location to which control should return from the activation) that is unique to each procedure activation.

The stack frame contains storage for the automatic data declared within the block. Thus, each activation of the block has its own copy of the automatic data.

If procedure A calls procedure B, the stack frame associated with the activation of A is pushed down by the stack frame associated with the activation of B. When B returns, its stack frame is popped from the stack and the stack frame of A is then the current stack frame.

If procedure A calls itself directly or indirectly by invoking a chain of procedures in which A is again called, A is said to be a recursive procedure. For example:

A: PROCEDURE RECURSIVE;
      .
      .
      .
   CALL A;
      .
      .
      .
   END A;

The following example shows a program that makes a copy of a tree structure using block activation and recursion principles.

   .
   .
NEW = COPY(OLD);
   .
   .
COPY: PROCEDURE(IN) RETURNS(POINTER)| RECURSIVE;
      DECLARE     (IN,OUT) POINTER;
      DECLARE     1 RECORD BASED,
                        2 FIELD1 FLOAT,
                        2 FIELD2 FLOAT,
                        2 DAUGHTER POINTER,
                        2 SON POINTER;
DECLARE NULL BUILTIN;

IF IN = NULL THEN RETURN(NULL);
ALLOCATE RECORD SET(OUT);
OUT->RECORD.FIELD1 = IN->RECORD.FIELD1;
OUT->RECORD.FIELD2 = IN->RECORD.FIELD2; OUT->RECORD.DAUGHTER =
      COPY(IN->RECORD.DAUGHTER);
OUT->RECORD.SON = COPY(IN->RECORD.SON);
RETURN(OUT);

END COPY;

As demonstrated in this example, each record of the original tree structure may be linked using pointers to a SON record and/or a DAUGHTER record. Either the SON or the DAUGHTER field may contain a null pointer value. COPY is called with a pointer to the root in the original tree structure. It returns a pointer to the root in a new tree structure that is a copy of the original. Each activation of the COPY procedure has its own instance of the variables IN and OUT.

For additional information about recursive procedures, see the section Entry Data in the chapter Data Types.

Parent topic: Procedure Blocks
Related information
Entry Data


Guidelines for Using Procedures

Procedures are a natural division of the program and therefore provide the best mechanism to represent program modularity. The program should be organized or structured as a set of modules, each of which is written as a procedure.

Adhere to the following guidelines when using procedures:

  • Write procedures with minimal dependence on their ability to access the values of their containing procedure. All such use of nonlocal variables should be clearly documented by comments in both the declaring and the using procedures.
  • Write procedures that are used only from within a given procedure as internal procedures within the calling procedure. Write internal procedures following the executable statements of the containing procedure.
  • Make each procedure as small as possible to enable understanding of program logic.
Parent topic: Procedure Blocks


Dynamic Fetching and Releasing of External Procedures

An external procedure can be dynamically fetched or released by a program. This means that it can be loaded or deleted by the program using the FETCH and RELEASE statements. When the procedure is not in main storage, it can be loaded into it and then deleted from it at any time during the execution of the calling procedure. This is useful when it is not necessary to call the external procedure every time when the calling procedure is executed.

A procedure has to be loaded into main storage before it can be executed, unless it is already there. Once loaded, the procedure can remain in main storage until the execution of the whole program is completed, or it can be deleted at any time using the RELEASE statement.

A fetched procedure is compiled and linked separately from the calling procedure. For more information, see Compiling, Linking and Debugging of Fetchable Procedures.

Whenever the load module containing the fetched procedure is loaded into memory, the STATIC variables in the fetched procedure are given the initial values indicated by their declarations.

Note that EXTERNAL files and CONDITION conditions are shared across the whole application, including the fetched procedures.

  • FETCH Statement
  • RELEASE Statement
  • Restrictions
Parent topic: Procedure Blocks
Related information
Compiling, Linking and Debugging of Fetchable Procedures


FETCH Statement

Purpose

Dynamically loads an external procedure into main storage.

Syntax

FETCH entry-constant [SET(ptr-ref)][TITLE (char-expr)]

Parameters

entry-constant
The name by which the loaded procedure is known to the operating system. It is the same as the one used in the corresponding CALL statement, or CALL option of an INITIAL attribute, or function reference.
ptr-ref
A pointer reference that is set to the address of the entry point of the module that is loaded.
char-expr
Any character expression.

Description

The FETCH statement is used to dynamically load modules into main storage. It must specify an entry constant, which is the name by which the fetched procedure is known to the operating system. When this name is referenced in a FETCH statement, the procedure can also be loaded into main storage when a CALL statement, or a CALL option of an INITIAL attribute, or a function reference is executed.

Restrictions

See Restrictions under Dynamic Fetching and Releasing of External Procedures.

Parent topic: Dynamic Fetching and Releasing of External Procedures
Related reference
RELEASE Statement
Related information
Dynamic Fetching and Releasing of External Procedures


RELEASE Statement

Purpose

Deletes from main storage a previously fetched procedure.

Syntax

RELEASE entry-constant

Parameters

entry-constant
The RELEASE statement must specify an entry constant. It is the name by which the loaded procedure is known to the operating system. It is the same as the one used in the corresponding FETCH statement, CALL statement, CALL option of an INITIAL attribute, or function reference.

Description

The RELEASE statement releases (deletes) from main storage a previously fetched modules. RELEASE * deletes all previously fetched modules. It must not be executed from within a fetched module.

Restrictions

See Restrictions under Dynamic Fetching and Releasing of External Procedures.
Note: RELEASE* is not currently supported but an API can be provided if this functionality is needed.
Parent topic: Dynamic Fetching and Releasing of External Procedures
Related reference
FETCH Statement
Related information
Dynamic Fetching and Releasing of External Procedures


Restrictions

  • If you have an ON CONVERSION on unit that is located in the main program and triggered by a fetchable procedure, or located within a fetchable procedure and triggered within another fetchable procedure that is subordinate to it on the callstack, then the ONCHAR() and ONSOURCE() built-in functions will not correctly "reset" the triggering variables values within the fetchable procedure that caused the condition. If the ON CONVERSION on unit is within the triggering fetchable procedure (or main program), then there is no problem.
  • If the fetchable module has its procedure declared with OPTIONS(MAIN) or if when linking you specify the options -cics, -ims, or -mvs, then your fetchable routine will have its own runtime context and ON UNIT's memory chains, and file variables will not be shared across fetchable boundaries.

  • For any program which does any form of file I/O, the following needs to be done:

    • For each FILE declaration it must have storage allocated to its FILE constant. This is achieved through the use of the -defext compile option and/or through the use of an optional parameter called GLOBALDEF. It is important that within a fetchable procedure or a program compiled with OPTIONS(MAIN), this is done exactly one time per FILE constant. If this is not done, the results are completely unpredictable and the behaviors will not be supported.
    • For typical usage, compiling with -defext is more than adequate. If you have two or more subroutines which are all accessing the same FILE constant, and they are linked into a single fetchable procedure or program, only one of the programs should be compiled with -defext. As an alternative approach you can add the attribute GLOBALDEF to one of the file declarations and not use the -defext switch for any of the compiles.
Parent topic: Dynamic Fetching and Releasing of External Procedures


BEGIN Blocks

A BEGIN block is a sequence of Open PL/I statements into which control flows during the routine execution of a program. A BEGIN block differs from a procedure in that it is invoked by executing its BEGIN statement, it cannot have any parameters, and it always returns by executing its END statement. In addition, execution of a RETURN statement within a BEGIN block returns to the caller of the procedure that immediately contains the BEGIN block. And, unlike a procedure, a BEGIN block can be used as the ON–unit of an ON statement.

The BEGIN block groups a set of program statements and defines a scope for the names declared within it. Generally, the reason for using a BEGIN block is to create a new scope and/or a new block activation. BEGIN blocks can contain DO-groups, SELECT groups, DECLARE statements, and procedures, as well as other BEGIN blocks.

The statements of a BEGIN block are bounded by BEGIN and END statements, as shown in the following example:

BEGIN;
   .
   .
   .
END;

Since the BEGIN block contains declarations and ON-units, as well as executable statements, it can be used to permit temporary redefinitions of names and exception handlers, as well as to provide a means of allocating and freeing AUTOMATIC variables within it. (For additional information about AUTOMATIC variables, see the section Storage Classes.) For example:

DECLARE SUM FIXED BINARY;
   .
   .
   .
BEGIN;
DECLARE SUM FILE;
DECLARE X(1000) FLOAT;
   .
   .
   .
END;

In this example, SUM is redeclared within the BEGIN block so that it can be used as a file. A large array X is declared within the BEGIN block and is allocated storage only during the execution of the BEGIN block.

Parent topic: Language Concepts
Related information
Storage Classes


Variables

A variable is a named object that is capable of holding values. Each variable has two properties:

Data type
Determines the kind of values a variable holds.
Storage class
Determines the duration of a variable's existence and how it is referenced.
  • Data Types and Conversion
  • Storage Classes
Parent topic: Language Concepts


Data Types and Conversion

Each variable must be declared to have a data type. Except for cases under control of the DEFAULT statement, failure to specify a data type causes the Compiler to issue a warning and to give the variable a data type of Fixed Binary(15) if its name begins with any of the letters I through N; otherwise, the variable is given a data type of Float Decimal(6).

A complete discussion of data types is contained in the chapter Data Types. The following examples show several data types available in Open PL/I.

Examples:

DECLARE A FLOAT DECIMAL(7);
DECLARE N FIXED BINARY(15);
DECLARE C CHARACTER(30);
DECLARE B BIT(1);

In these examples, variable A is capable of holding any floating-point decimal value with mantissa of up to 7 digits and exponent of up to 3 digits; variable N is capable of holding any binary integer value between -32768 and +32767 inclusive; variable C is capable of holding any string of 30 characters; and variable B is capable of holding either '1'B or '0'B.

Although each variable is capable of holding values of only a specific data type, the Open PL/I language provides a complete set of operations that convert values from one data type to another. Whenever a value is assigned to a variable, it is first converted to the data type of the variable, as illustrated in the following examples (which refer to the declarations in the previous examples).

Examples:

A = 1; /* converts 1 to FLOAT DECIMAL(7) */
N = 2.5; /* converts 2.5 to the FIXED BIN(15) integer 2 */
C = -4.5; /* converts -4.5 to a character string */
B = 0; /* converts integer 0 to '0'B */

For a complete discussion of data type conversions, see the chapter Data Type Conversions.

Parent topic: Variables
Related information
Data Types
Data Type Conversions


Storage Classes

A variable's storage class determines when and for how long storage is to be allocated for the variable. Since this storage holds the variable's value, the storage class of a variable determines how long the variable retains its value.

The Open PL/I language permits the following six storage classes, which are fully explained in the chapter Storage Classes.

  • AUTOMATIC
  • BASED
  • CONTROLLED
  • DEFINED
  • STATIC (INTERNAL or EXTERNAL)
  • parameter

Unless declared otherwise, a variable's storage class is AUTOMATIC, meaning that it is allocated storage each time its immediately enclosing scope becomes active (as happens during a procedure call or the execution of a BEGIN statement. Exiting the scope frees this allocated storage (as happens at procedure or BEGIN block termination). Consequently, AUTOMATIC variables do not retain their values after deactivation of the block in which they are contained.

If a variable must retain its value between calls of its containing procedure, it should be declared to have the STATIC storage class. For example:

DECLARE K FIXED BINARY STATIC;
DECLARE TABLE(4) CHARACTER(5)
      STATIC INITIAL('A','B','C','D');

In this example, each element of the array TABLE is given an initial value.

Storage for STATIC variables is allocated prior to program execution by the Compiler and linker. Consequently, the length (precision) of each STATIC variable must be constant at compile time.

Parent topic: Variables
Related information
Storage Classes


Files

In Open PL/I, a file is a source of input data or a target for data output. Files are referenced in I/O statements by using a file name declared with the FILE attribute. The file reference actually refers to a file constant or to a file variable that has been assigned a value.

Each file used by the program must be declared in exactly one module in the program. That module must either declare the file with the GLOBALDEF attribute or must be compiled with the -defext option.

  • File Constants
  • File Variables
  • Using Environment Variables
Parent topic: Language Concepts


File Constants

A file constant is an identifier declared with the FILE attribute and without the VARIABLE attribute. For example:

DECLARE F FILE;

In this example, F is the name of a file constant.

A file constant cannot be the target of an assignment operation, and is external, by default. (For a discussion of assignment statements, see the chapter Statements.)

Each file constant is associated with a block of static storage called a file control block. The file control block retains information about the current status of the file while the file is open. In effect, the file constant is a pointer to, or a designator of, a file control block. File constants require the use of the -defext compiler option.

Each file control block's file identifier (ID) is the NAME of its associated file constant. The file ID in the previous example is F. This ID is used as the default TITLE of the file when it is being opened.

Parent topic: Files
Related information
Statements


File Variables

A file variable is a variable that can be assigned file values. A file variable can be given a value by receiving a file constant passed as an argument, by receiving a file constant as the value of a function, or by simple assignment. A file variable is declared with the VARIABLE attribute. For example:

DECLARE G FILE;
DECLARE F FILE;
DECLARE V FILE VARIABLE;

V=F;
...
V=G;

In this example, F and G are file constants, each of which has an associated file control block. V is a file variable that can be assigned file values. After the first assignment, both F and V designate the same file control block. Any operation performed on V is equivalent to the same operation performed on F. After the second assignment, any operation performed on V is equivalent to the same operation performed on G, because both V and G designate the same file control block.

A file name used as a parameter is a file variable and designates the same file control block as its corresponding argument.

Parent topic: Files


Using Environment Variables

To determine the system name of a file to match with a PL/I file, Open PL/I uses the name specified in the TITLE option of the OPEN statement. If the TITLE option is omitted, Open PL/I uses, by default, the name of the file constant or file variable in the PL/I program (shifted to uppercase). You can, instead, use system environment variables to easily specify the system names of files at run-time. The environment variable must be named in this fashion:

LPI_name system-filename

where:

name is the TITLE-specified or default name indicated by the program.

Examples:

DECLARE DATA2 UPDATE FILE;   OPEN FILE(DATA2) /* no title */;
DECLARE FACTS STREAM FILE;   OPEN FILE(FACTS) TITLE('Report');

If you do not use environment variables to connect these openings with systems files, the following system names will be assumed for the files: DATA2 and Report.

Instead, prior to running the application, you could set environment variables as follows, causing the specified system files to be used. (Any directories used in the path names must exist.)

setenv LPI_DATA2 /dir1/dir2/master.data
setenv LPI_Report /doc/reports/deptA/week23.rep

In the second example, LPI_Report was used rather than LPI_FACTS, because of the TITLE option in that file's OPEN statement.

Parent topic: Files


Input and Output

Open PL/I provides two types of Input/Output processing: stream I/O and record I/O. Each type of I/O has its own statements, and each type operates on its own kind of files. Open PL/I can process more than 32,767 records per file and supports UNIX named pipes, which enables the reading and writing of massive data sets - greater than 2 GB - something not normally permitted in UNIX I/O.

A stream file is a sequence of characters organized into lines and pages. When reading or writing a file using stream I/O, the data is treated as if it formed a continuous stream of ASCII characters. Stream files are written by PUT statements and are read by GET statements.

A record file is a set of discrete records that are accessible either sequentially or by keys. When reading or writing a file using record I/O, only one record is processed upon the execution of the I/O statement. Record files are read and written by READ, WRITE, REWRITE, and DELETE statements.

The following sections provide detailed information on the two types of input and output processing available through Open PL/I: stream I/O and record I/O.

  • Stream I/O
  • Record I/O
Parent topic: Language Concepts


Stream I/O

Stream I/O treats data in the external file as a stream of ASCII characters. In a stream I/O operation, a list of program variables is associated with actual input or output fields of data.

Two forms of stream I/O statements exist:

  • List-directed stream I/O, as performed by the GET LIST and PUT LIST statements.
  • Edit-directed stream I/O, as performed by the GET EDIT and PUT EDIT statements.

In both list-directed and edit-directed stream I/O, the files are written by the PUT statement and are read by the GET statement. In edit-directed stream I/O, data is transmitted to or from a stream file under the control of a format-list. In list-directed stream I/O, data is transmitted to and from the stream file without a format-list. In edit-directed stream I/O, format-lists can be part of the GET or PUT statement or can be given by a FORMAT statement.

Execution of a GET or PUT statement transmits data from or to the current line of a stream file and may not consume or produce an entire line of the stream file. Several PUT statements can be used to build a given line, or a single PUT statement can be used to output several lines. Similarly, several GET statements can read values from a given line, or a single GET statement can be used to read one or more lines. Lines read from a disk file are not modified by Open PL/I in any way; however, lines read from all other devices have trailing blanks removed and have one blank appended to the end of each line that is read by a GET statement. This blank ensures that a field typed at the beginning of a line is not appended to a field typed at the end of the previous line.

Each stream file has an associated line size that is determined when the file is opened. Lines of an output file contain n characters, where n is the line size of the file. (For more information, see the discussion of the LINESIZE option in the section Stream File Attributes.) A shorter line can be created by using the SKIP option on a PUT statement, as shown in the following example of a list-directed stream I/O statement. The shorter lines are padded to the right with blanks to obtain a length of n characters. For example:

PUT FILE(F) SKIP LIST(A,B,C);
PUT FILE(F) SKIP;

In this example, the current line (consisting of data previously output) is output and one or more new lines containing the values of A, B, and C are created. The second PUT statement forces the last line containing A, B, and C to be output and starts a new line. The SKIP option is always executed before any new data is transmitted.

On input, each line can be of any length up to the value of the line size. Execution of a GET statement reads from the current line until a new line is reached, the new line is ignored, and execution continues reading values and lines until the list of variables has been read. A SKIP option can be used to force a new line to be read prior to reading any values, as shown in the following example.

GET FILE(F) LIST(A,B,C);
GET FILE(F) LIST(D);
GET FILE(F) SKIP LIST(X,Y);

In the previous example, A, B, and C are read from the current line or from as many lines as are necessary. D is read from the same line as C, unless C happened to be the last value on its line. The SKIP option skips to a new line and consequently ignores any values remaining on the line after the value received by D. X and Y are read from the line that is current after the SKIP option, as well as any additional, necessary lines.

The PAGE option can be used in a PUT statement to begin a new page prior to transmitting any values, as shown in the following example.

PUT FILE(F) PAGE LIST(A,B,C);

For a complete discussion of GET, PUT, and FORMAT statements, see the chapter Statements.

Note:

Standard PL/I, in a stream file, does not provide a way to read a variable-length input line from the current position to a newline indicator. Open PL/I provides two nonstandard methods to read all characters from current position to new line into a character varying variable: a READ statement and an edit-directed GET statement. To read a variable-length line with a GET statement, you must use an A-format without a field width.

  • List-Directed Stream I/O
  • Data-Directed Stream I/O
  • Edit-Directed Stream I/O
  • Terminal I/O on a Stream File
Parent topic: Input and Output
Related information
Stream File Attributes
Statements
READ
A-Format


List-Directed Stream I/O

Values transmitted by list-directed stream I/O are separated by blanks or commas on input and by blanks on output. Each value is transmitted in a readable format determined by the value's data type.

In a GET LIST operation, Open PL/I automatically converts ASCII input data to the data types of the variables specified in the GET LIST statement. In a PUT LIST operation, Open PL/I converts a computational expression to its ASCII equivalent for output.

The following example of simple terminal output demonstrates list-directed stream I/O:

PUT LIST(A,B);

In this example, if A is an integer declared fixed binary whose current value is -75, and B is a character-string declared character(5) whose current value is HAT Boxes, the example produces:

in the current output line of file F. The field boxes -75 is produced by converting the fixed binary(15) integer to a character-string. The many blanks allow for the maximum possible value, plus sign and decimal point and leading 0 for fractional values, as explained in the section Arithmetic to Character-String Conversion in the chapter Data Type Conversions. A single blank separates the value of A from the value of B. The last blank separates B from the next field.

For input, list-directed I/O considers each blank or comma as a field terminator. Excess commas are not allowed. Excess blanks within a field to be assigned to an arithmetic variable are ignored. Such fields must simply contain a valid constant, as could be written in the text of a program.

A field to be assigned to a character-string variable may contain a character-string constant, as written in the text of a program, or it may contain a sequence of any characters. In the latter case, the sequence begins with the first non-blank character in the field and ends with the character immediately preceding the next comma or blank, as shown in the following example of a GET LIST operation. Note that character sequences containing blanks or commas that are to be treated as a unit must be enclosed in single quotation marks ("). For example:

GET FILE(F) LIST(A,B);

In this example, if A is fixed binary(15) and B is character(5), the following lines have the indicated effect on the values of A and B.

Line | A | B
boxes | 5 | boxes
boxes | -4 5 | boxes
boxes | -4 5 | abc-4
Parent topic: Stream I/O
Related information
Arithmetic to Character-String Conversion


Data-Directed Stream I/O

Data-directed stream I/O is similar to list-directed stream I/O. The difference is that with data-directed stream I/O, the actual Open PL/I program names of the data values are included in the stream file along with the values. For example, if your program contains the structure:

DECLARE 1 STRUC,
            2 NUM(2) FIXED BIN(15) INIT(255,-432),
            2 TEXT CHAR(4) INIT('abcd');

and outputs this data with a PUT DATA statement, the characters emitted for STRUC would be:

STRUC.NUM(1)     255  STRUC.NUM(2)=   -432 STRUC.TEXT='abcd' ;

Each data value is preceded by the fully-qualified and specifically subscripted PL/I program name of that data value, as shown. The values themselves are formatted as they would be by a PUT LIST statement, except that character values are always enclosed in quotes.

Parent topic: Stream I/O


Edit-Directed Stream I/O

Values transmitted by edit-directed stream I/O are transmitted into fixed-length fields whose length and content are controlled by data-formats. Data-formats specifically control the type of conversion to be performed and the number of characters or digits in an input or output field. Each data-format corresponds to an element of the GET or PUT statement's value list and causes that value to be converted and transmitted. For example:

PUT FILE(F) EDIT(A,B) (F(7,2),A(6));

In this example, if A is declared fixed binary(15) and has a current value of -45, and B is declared character(4) and has a current value of HAT box, the following is written into the current line of file F.

Control formats can be used to force new lines and skip parts of lines, as shown in the next example. If there are more format items than values to be transmitted in the statement's I/O list, the extra format items are ignored. For example:

PUT FILE(F) EDIT(A,B) (X(3),F(7,2),SKIP,X(4),A(6),SKIP);

Using the same values of A and B as in the previous example, the above statement produces the following:

In this example, the first line is placed at the end of the current line, and the second line starts a new output line. The PUT statement does not start another new line, because B was the last item output; hence, the PUT statement terminated before the second SKIP was executed.

Edit-directed input requires that each input line be described precisely by the controlling format. If the current input line contains fewer characters than are required to satisfy the format, additional lines are read until the format is satisfied, as shown in the following example.

GET FILE(F) EDIT (X) (A(80));

In this example, if X is declared as character(100) and the current line contains only 60 characters, the 60 characters are read, a new line is read, processing advances to the next line, and 20 additional characters are read from that line. The 80 characters thus read are then assigned to X, and 20 blanks are used to pad the value of X on the right.

Parent topic: Stream I/O


Terminal I/O on a Stream File

If a terminal device is opened as a stream file, the file is unlike any other stream file in the following respects:

  • Each PUT statement transmits data to the device without waiting for the line to be filled.
  • A GET statement resets the current column position used by subsequent PUT statements.
  • Stream File Attributes
  • Print Files
Parent topic: Stream I/O


Stream File Attributes

The following attributes are appropriate for use with stream files. Some may be used in either the DECLARE statement for the file constant or in the OPEN statement, others only in the OPEN statement.

Attribute | Permitted in Specification
STREAM | DECLARE or OPEN
INPUT | DECLARE or OPEN
OUTPUT | DECLARE or OPEN
PRINT | DECLARE or OPEN
LINESIZE | OPEN
PAGESIZE | OPEN
TITLE | OPEN

The use of PRINT implies STREAM OUTPUT. If neither INPUT, OUTPUT, nor PRINT is specified, INPUT is assumed. LINESIZE and PAGESIZE can be used only for PRINT files. If neither STREAM nor RECORD is specified, the default is STREAM. (See the section Record I/O.) STREAM and RECORD are mutually exclusive, as are INPUT and OUTPUT. If attributes are specified both in the DECLARE statement and the OPEN statement for a file, the attributes used are the combination of those in the two statements. The combination may include only one of each mutually exclusive set.

The TITLE option is used to associate a file as declared in the PL/I program with a file or device as known to the operating system. In the following examples of OPEN statements, the quoted text in the TITLE options specifies the system filename or device name to be used in I/O operations with the opening of the PL/I file indicated by the FILE option. If the TITLE option is not specified in an OPEN statement, the declared name of the file constant is used as the default title.

The LINESIZE option is used in an OPEN statement to specify the maximum number of characters that can be output in a single line for a STREAM file. If no line size is specified, a default line size is assumed. For more information on LINESIZE, see the section PUT in the chapter Statements.

The LINESIZE option can appear in the OPEN statement only and is valid only with STREAM OUTPUT files. During output, a newline will be inserted whenever the column position equals (LINESIZE+1). The SKIP or LINE options with a PUT statement cause a newline character to be inserted and the column position to be reset. The COLUMN format with a PUT EDIT statement may cause a newline to be inserted.

The default may vary according to the file name or device. In Open PL/I, the default value of the LINESIZE option is 120.

The PAGESIZE option is used in an OPEN statement to specify the maximum number of lines that can be written to a print file without signaling the ENDPAGE condition. If no page size is specified, a default page size is supplied. In Open PL/I, the default value of the PAGESIZE option is 60.

If a GET or PUT statement is executed on a file that has not been opened, the file is implicitly opened as a STREAM file using the declared name of the file constant as the title. A file so opened by a GET statement is opened as an INPUT file, one so opened by a PUT statement is opened as an OUTPUT file.

You can add text to any existing stream file (any ASCII file) by using the -APPEND option in the TITLE option of the OPEN statement. Thus, if the file you wish to append to is named "logfile," open it with the following TITLE option:

TITLE('logfile -APPEND')

Any subsequent PUT statements to this file simply append their output to the end of the file.

  • Examples:
Parent topic: Terminal I/O on a Stream File
Related information
Record I/O
PUT
TITLE Options


Examples:

OPEN FILE(F) OUTPUT TITLE('thedata');

OPEN FILE(TTY) TITLE('CONSOLE')
   STREAM INPUT;

OPEN FILE(PTR) TITLE('LPT1')
   STREAM OUTPUT PRINT LINESIZE(132)
   PAGESIZE(60);

OPEN FILE(MSG_FILE) INPUT;
                  /* The default title is 'MSG_FILE' */
Parent topic: Stream File Attributes


Print Files

An output stream file opened with the PRINT attribute indicates that the file is a print file. When a file is declared as a print file, the LINESIZE and PAGESIZE options may be specified at file opening to designate the maximum width of an output line and the maximum number of lines per page. The current line number and current page number of the print file can also be accessed using the PAGENO and LINENO built-in functions.

The LINENO built-in function allows you to access the current line number of an output stream file opened with the PRINT attribute. Each time a line is written to the output stream, the line number is incremented by one. Each new line is initially positioned so that the next item is written to column 1 of the line.

The PAGENO built-in function lets you read the current page number of an output stream file opened with the PRINT attribute. The current page number can be set using the PAGENO pseudo-variable. The ENDPAGE condition is signaled when the line to be written has a line number that is the page size plus one, or when a SKIP option positions the file to (or past) page size + 1.

Each time a new page is written, the line number is reset to one and the page number is incremented by one.

If an ON-unit for the ENDPAGE condition does not write a new page, the line number is allowed to increase indefinitely until a new page is written. The ENDPAGE condition is signaled only when the line to be written has a line number that is one greater than the page size.

A new page is written only by a PAGE option of a PUT statement, by a PAGE format-item, and by the default ON-unit for the ENDPAGE condition.

In Open PL/I, tab stops are set every eight columns for a stream file that has the PRINT attribute.

Parent topic: Terminal I/O on a Stream File


Record I/O

In Record I/O, file data is treated in terms of records. Record files are used with the READ, WRITE, REWRITE, and DELETE statements. Execution of one of these statements transmits one record to or from the file and updates the current position of the file.

A record is a contiguous set of bytes of data in the file. The records of the file may all be of the same fixed length, as specified when the file is created, or they may be of varying lengths. Certain files with variable-length records require that a maximum length be specified when the file is created.

The data bytes that comprise a record file may be ASCII characters, but they may also be any kind of binary data, including being paired as halfwords, grouped as binary fullwords or double words, grouped as packed-decimal strings, or considered as bit fields of any length.

Record files may be keyed or not. If a record file does not have keys, its records can be accessed only in sequential order as they exist in the file, one after the other from the beginning of the file to the end. Open PL/I supports two keyed access methods: indexed (VSAM) I/O, which is based on character-string keys, and relative record I/O, which is based on integer record numbers.

  • Record File Attributes
  • Consecutive Record I/O
  • Indexed Record I/O
  • Relative Record I/O
  • REGIONAL(1) Record I/O
  • TITLE Options
Parent topic: Input and Output


Record File Attributes

The following attributes are appropriate for use with record files. Some may be used in either the DECLARE statement for the file constant or in the OPEN statement, others only in the OPEN statement. Some attributes, if present, imply the presence of certain others.

Attribute | Permitted in Specification | Implied
RECORD | DECLARE or OPEN |
INPUT | DECLARE or OPEN |
OUTPUT | DECLARE or OPEN |
UPDATE | DECLARE or OPEN | RECORD
SEQUENTIAL | DECLARE or OPEN | RECORD
KEYED | DECLARE or OPEN | RECORD
DIRECT | DECLARE or OPEN | RECORD KEYED
ENVIRONMENT | DECLARE |
TITLE | OPEN |

If neither INPUT, OUTPUT, nor UPDATE is specified, INPUT is assumed. If neither SEQUENTIAL nor DIRECT is specified, SEQUENTIAL is assumed. If neither STREAM nor RECORD is specified, the default is STREAM. (See the section Stream I/O.) The following sets of attributes are mutually exclusive:

  • STREAM and RECORD
  • INPUT, OUTPUT, and UPDATE
  • SEQUENTIAL and DIRECT

If attributes are specified both in the DECLARE statement and the OPEN statement for a file, the attributes used are the combination of those in the two statements. The combination may include only one of each mutually exclusive set.

The TITLE option is used to associate a file as declared in the PL/I program with a file as known to the operating system. In the following examples of OPEN statements, the quoted text in the TITLE options specifies the system filename to be used in I/O operations with this opening of the PL/I file indicated by the FILE option. If the TITLE option is not specified in an OPEN statement, the declared name of the file constant is used as the default title.

Examples:

OPEN FILE(F) RECORD OUTPUT TITLE('thedata');

OPEN FILE(F) RECORD INPUT; /* The default title is 'F' */

If a READ, WRITE, REWRITE, or DELETE statement is executed on a file that has not been opened, the file is implicitly opened as a RECORD file using the declared name of the file constant as the title. The attributes assigned to the file implicitly opened depend on the I/O statement used, as indicated below:

Record I/O Statement | Assigned Attributes
READ | RECORD INPUT
WRITE | RECORD OUTPUT
REWRITE | RECORD UPDATE
DELETE | RECORD UPDATE

Record input and output operations are restricted to files opened with certain attributes. These restrictions are shown in the following table:

File Attributes | Permitted I/O Operations
INPUT | READ
OUTPUT | WRITE
UPDATE | READ, WRITE, REWRITE, DELETE

If a file opened for INPUT or UPDATE does not exist, an error is signaled.

If a file opened for OUTPUT does not exist, a file is created. If the file has been opened as DIRECT or KEYED SEQUENTIAL, a keyed file is created; otherwise, a non-keyed file is created.

If a file opened for OUTPUT already exists, it is deleted and a new file is created.

However, if the -APPEND option is specified in opening the file, an existing file can be opened for OUTPUT. You can add records to an existing record file by using the -APPEND option in the TITLE option of the OPEN statement. Thus, if the file you wish to append to is named "logfile," open it with the following TITLE option:

TITLE ('logfile -APPEND')

Any subsequent WRITE statements to this file simply append their output to the end of the file.

A REWRITE statement replaces an existing record in an UPDATE file with a new record. A DELETE statement basically removes an existing record from an UPDATE file. A WRITE to an existing record and a READ from a nonexistent record are not allowed. A WRITE to a record past EOF will append the record to the end of the file. A DELETE or REWRITE of a nonexistent record signals a KEY condition. (For further information, see the description of KEY in the section ON in the chapter Statements.)

Record I/O statements copy the storage of a variable to or from a record in a file (except in the case of READ operations using locate mode I/O, see below).

No conversion is performed and no check is made to ensure that the data being read is of the proper type to store into the variable. The variables used in INTO or FROM options cannot be unaligned bit strings or structures consisting entirely of unaligned bit strings, because such variables normally share a portion of their storage with other members of the same array or structure. Also, an expression cannot be used in a FROM or INTO option.

Note:

Structures with the UNION attribute cannot be used as variables in READ, WRITE, PUT, and GET statements.

READ operations can be performed in two "modes": move mode and locate mode. A READ statement that specifies the INTO option causes the input data to be stored directly into the variable referenced by the INTO option. This is called a "move mode" READ. A READ statement that specifies the SET option instead of the INTO option causes the input data to be stored in an unnamed storage buffer and causes the address of this buffer to be assigned to the pointer variable referenced by the SET option. This is called a "locate mode" READ.

A complete discussion of record I/O statements is found in the chapter Statements.

Examples:

READ FILE(CUSTOMERS) KEY(CUST_ID) INTO(CUST_RECORD);
PUT SKIP LIST(CUST_RECORD.NAME);
READ FILE(CUSTOMERS) KEY(CUST_ID) SET(CPTR);
PUT SKIP LIST(CPTR->BASED_RECORD.NAME);
Parent topic: Record I/O
Related information
Stream I/O
TITLE Options
ON
Statements


Consecutive Record I/O

A record file without keys is called a consecutive file. The records of such a file can be read only in the same sequential order in which they were written. Thus, a consecutive file can be read only one record after the other, starting with the first record in the file. A record of a consecutive file can be rewritten, but only immediately after it has been read.

A consecutive file is declared by including the CONSECUTIVE option of the ENVIRONMENT attribute. For example,

DECLARE ULOG RECORD OUTPUT FILE
        ENVIRONMENT(CONSECUTIVE RECSIZE(130));

In this example the RECSIZE option causes all records to be of length 130 bytes. If RECSIZE is omitted, variable length records may be written. In the latter case, there is no information automatically recorded in the file to indicate the length of the records. A program reading the file must have the ability to know how many bytes to read with each READ statement.

Example:

CONFILE: PROCEDURE OPTIONS(MAIN);

   DECLARE TEST RECORD OUTPUT FILE ENV(CONSECUTIVE);
   DECLARE REC1 CHAR(5) INIT('AAAAA');
   DECLARE REC2 CHAR(10) INIT('BEEBBBBBBB');

   OPEN FILE(TEST) TITLE('testdata');
   WRITE FILE(TEST) FROM(REC1);
   WRITE FILE(TEST) FROM(REC2);
   WRITE FILE(TEST) FROM(REC1);
   CLOSE FILE(TEST);

END CONFILE;

The file testdata resulting from this program will contain the following 20 bytes:

AAAAABBBBBBBBBBAAAAA
Note:

Open PL/I has an older method of accomplishing the same thing. It is done by using the TITLE option of the OPEN statement rather than the ENVIRONMENT attribute of the DECLARE statement. The following illustrates the old method.

DECLARE RECORD TEST OUTPUT FILE;
OPEN FILE (TEST) TITLE ('testfile -SAM');
Parent topic: Record I/O
Related information
TITLE Options


Indexed Record I/O

Open PL/I's indexed I/O, also called VSAM (Virtual Storage Access Method), involves the use of character-string keys that are stored in the records of the file. Every record has a key, and the keys are ordered lexicographically in an index that is associated with the file. The records can be accessed randomly by specifying the key of the desired record, or they can be accessed sequentially according to the order of the keys, or they can be accessed by a combination of these methods, as illustrated in the following table:.

File Attributes | Permitted Access
SEQUENTIAL | SEQUENTIAL only
DIRECT | KEYED only
KEYED SEQUENTIAL | SEQUENTIAL and/or KEYED in combination

An INDEXED (equivalently, VSAM) file is declared by including either the INDEXED or the VSAM option of the ENVIRONMENT attribute. For example,

DECLARE MASTER RECORD OUTPUT FILE
   ENVIRONMENT(VSAM KEYLOC(1)
   KEYLENGTH(12) RECSIZE(130));

The KEYLOC option specifies the byte position of the first byte of the key in the records, counting the first byte as KEYLOC(1). The KEYLENGTH option specifies the number of characters in the key. RECSIZE specifies the record length or, in the case of a file of variable-length records, it specifies the maximum record length.

Actually, it is necessary to specify RECSIZE, KEYLOC, and KEYLENGTH for a file only when it is created. Programs that read or update an existing indexed file do not need to include these options, although they may. Open PL/I can determine these characteristics from an existing file. If you are using full IBM mode, file header information is used when opening a VSAM file for output, rather than requiring you to specify RECSIZE, KEYLOC, or KEYLENGTH with the ENVIRONMENT attribute.

There are a number of options that can be specified with the ENVIRONMENT attribute. These options are described in the table below. This table also lists a number of options that are not needed or not supported in Open PL/I, but which a user may expect to find based on experience with other compilers.

Option
 | Description
ASCII | The ASCII option is assumed in Open PL/I.
BKWD | Specifies backward processing for indexed files read in the SEQUENTIAL mode; that is, sequential processing will start with the current record (or last, by default) in the file and proceed to previous records.
BUFFERS | The BUFFERS option is not needed in Open PL/I. If it is used, the Compiler ignores it.
BUFOFF | The BUFOFF option is not needed in Open PL/I. If it is used, the Compiler ignores it.
BUFND | The BUFND option is not needed in Open PL/I. If it is used, the Compiler ignores it.
BUFNI | The BUFNI option is not needed in Open PL/I. If it is used, the Compiler ignores it.
BUFSP | The BUFSP option is not needed in Open PL/I. If it is used, the Compiler ignores it.
CONSECUTIVE | Specifies a file with consecutive organization. For related information, see the description of the -defext compiler option in your Open PL/I User's Guide.
CTLASA | The CTLASA option is ignored.
CTL360 | The CTL360 option is not implemented in Open PL/I. If it is used, the Compiler issues a warning.
F | FB | FS | FBS | Specifies record format, where F = fixed length, B = blocked, and S = standard. Open PL/I treats any such specification as though it were F alone — fixed length.
GENKEY | Specifies a generic key, a character string that is a prefix of a key. A READ with a KEY clause returns the first record whose key is greater than or equal to the string specified by the KEY clause. A subsequent sequential READ (no KEY clause) will return the next record greater than the current record.
INDEXAREA(n) | The INDEXAREA option is not needed in Open PL/I. If it is used, the Compiler ignores it.
INDEXED | Specifies a file with indexed organization. For related information, see the description of the -defext compiler option in your Open PL/I User's Guide.
KEYLENGTH(n) | Specifies the length, n, of the embedded key for indexed files. KEYLENGTH can be specified only when INDEXED or VSAM is specified.
KEYLOC(n) | Specifies the starting location of an embedded key in a record. n must be within the limits: 1 ? n ? recordsize – keylength + 1. The default KEYLOC value is 1. KEYLOC can be specified only when INDEXED or VSAM is specified. Note: Be sure that KEYLOC considers the 2-byte prefix generated by specification of the SCALARVARYING option.
LEAVE | The LEAVE option is not needed in Open PL/I. If it is used, the Compiler ignores it.
MINRECSIZE(n) | Specifies the minimum record length, n. n must be an integer. This option allows for better disk space utilization. The MINRECSIZE option is required with V (variable-length) record formats. It is ignored for F (fixed-length) record formats. The values specified for the KEYLOC and KEYLENGTH options must be within the value specified by the MINRECSIZE option. For more information on the MINRECSIZE option, see below.
NCP(n) | The NCP option is not applicable in Open PL/I. Open PL/I treats INDEXED files the same as VSAM files.
NOWRITE | The NOWRITE option is not needed in Open PL/I. If it is used, the Compiler ignores it.
PASSWORD(pwd) | The PASSWORD option is not implemented in Open PL/I. If it is used, the Compiler issues a warning.
RECSIZE(n) | Specifies the maximum record length, n. n must be an integer.
REGIONAL(1 | 2 | 3) | The REGIONAL(1) option specifies files whose records are identified by their region numbers. The REGIONAL(2) and REGIONAL(3) options are not implemented in Open PL/I. If they are used, the Compiler flags it as an error.
REUSE | The REUSE option specifies that an OUTPUT file associated with a VSAM data set is to be used as a work file. .
SCALARVARYING | Used for the input and output of varying length records. SCALARVARYING enables the recognition of a two-byte prefix that specifies the current length of the records. Note: Be sure that KEYLOC considers the 2-byte prefix generated by specification of the SCALARVARYING option.
SIS | The SIS option is not needed in Open PL/I. If it is used, the Compiler ignores it.
SKIP | The SKIP option is not needed in Open PL/I. If it is used, the Compiler ignores it.
TP(MIR) | The TP(MIR) option is not implemented in Open PL/I. If it is used, the Compiler flags it as an error.
TRKOFL | The TRKOFL option is not needed in Open PL/I. If it is used, the Compiler ignores it.
U | D | DB | Specifies record format. Open PL/I treats any such specification as though it were F – fixed length.
V | VB | VS | VBS | Specifies record format, where V = variable length, B = blocked, and S = spanned. Open PL/I treats any such specification as though it were V.
VSAM | Specifies files organized for the virtual storage access method (VSAM). For related information, see the description of the -defext compiler option in your Open PL/I User's Guide.

A random access read of a record in an indexed (VSAM) file opened with the INPUT or UPDATE attribute is accomplished by a READ statement that includes the KEY option. For example,

READ FILE(PARTS) INTO(PART_REC) KEY(PART_NUM);

A sequential read reads the next record of the file after the last one read — using the key ordering — or the first record of the file, if no record has previously been read. For a sequential READ statement, the KEY option is omitted.

If a record has previously been read from a file opened with the UPDATE attribute, and no other intervening I/O operation has been performed, a REWRITE without key may be executed. In this case, the previously read record is overwritten with the new value. For example,

READ FILE(PARTS) INTO(PART_REC) KEY(PART_NUM);
PART_REC = NEW VALUE;
REWRITE FILE(PARTS) FROM(PART_REC);

However, a record of an indexed file can be randomly updated by specifying the KEYFROM option in the REWRITE statement. For example,

REWRITE FILE(PARTS) FROM(PART_REC) KEYFROM('12XJ04');

If an indexed file has been opened with the OUTPUT or UPDATE attribute, a WRITE statement using the KEYFROM option can be used to add new records to the file. The WRITE statement without KEYFROM is used to sequentially add new records to a file.

The DELETE statement can be used to remove records from an indexed file opened with the UPDATE attribute. The KEY option must be used to delete a record.

All keys used in an indexed (VSAM) file must by of type CHARACTER. If a KEY or KEYFROM option references a value that is not of type CHARACTER, the value is converted to CHARACTER before the I/O operation begins. Note that keys of type PICTURE are converted to CHARACTER without any actual change in the key contents. (See the chapter Data Type Conversions.)

An indexed (VSAM) file can have either fixed-length or variable-length records. The records are fixed-length if the F option is used with the ENVIRONMENT attribute when the file is created; they are variable-length if the V option is used. (See the table above.) If neither F nor V is specified, F is assumed.

In a fixed-length record file, all records must have the same length, which is the length specified by the RECSIZE option of the ENVIRONMENT attribute when the file was created. For a variable-length record file, RECSIZE specifies the maximum record length that is permitted in the file. The MINRECSIZE option must also be specified for a variable-length record file. This value specifies the minimum length that all records in the file must have. The keys of the file must be contained within this minimum portion of the file.

The SCALARVARYING option specifies that there is a two-byte prefix on all records in the data file. A user must take this into account when specifying the KEYLOC value. The KEYLOC value is the absolute byte position of the record starting at 1. This option can be used on either F or V record formats. It allows for more general use of character varying records in I/O statements, although character records can also be transmitted. When a character varying item is used in a WRITE or REWRITE statement, the two-byte prefix is retained with the record as it gets written out to the data file, if the SCALARVARYING option is set. Without the SCALARVARYING option, the prefix is not written; in this case, the remainder of the record is undefined beyond its current length. When a character record is written, a prefix will be added if SCALARVARYING option is set. The SCALARVARYING option lets you write and read records smaller then your max record size, without getting the RECORD condition. It also is useful when doing locate mode I/O.

When setting KEYLOC, it is very important to "compensate" for the two-byte prefix when the SCALARVARYING option is used.

The use of V type records provide a way to transmit partial records. Open PL/I does not require control bytes in the record for this support. The run-time system will automatically retain information concerning the number of bytes transmitted. Since no control information is needed in the record, the user should not change KEYLOC based on the record type. Only the SCALARVARYING option has impact on the KEYLOC location.

Although the PL/I language does not provide a mechanism by which multiple keys can be specified for a file, Open PL/I does provide a means for accessing data via multiple keys. After an indexed file has been created using one key (which is called the primary key), you can use the utility Ipivsam to add additional indexes (that is, keys) to the file. In the PL/I program each different key version of the data must be declared as a separate file. However, all of these declared files can actually be referencing the same set of data. For example,

DECLARE EMPFILE1 RECORD UPDATE FILE
   ENV(VSAM KEYLOC(1) KEYLENGTH(6) RECSIZE(145));
DECLARE EMPFILE2 RECORD UPDATE FILE
   ENV(VSAM KEYLOC(31) KEYLENGTH(3) RECSIZE(145) GENKEY);
DECLARE 1 EMP_
   2 EMP_ID       (CHAR(6),
   2 NAME         (CHAR(24),
   2 DEPARTMT     (CHAR(3),
   ...

OPEN FILE(CUSTFILE1) TITLE('employee');
OPEN FILE(CUSTFILE2) TITLE('employee');
                        /* same file, different key */

The following example program illustrates the use of the ENVIRONMENT variable and its options for I/O on a file with VSAM organization.

/* Example of VSAM I/O */

TEST: PROCEDURE OPTIONS(MAIN);

   %REPLACE TRUE BY '1'B; %REPLACE FALSE BY '0'B;

   DECLARE DB FILE ENV(VSAM KEYLOC(21) KEYLENGTH(120) RECSIZE(244));
   DECLARE DBG FILE ENV(INDEXED GENKEY KEYLOC(21)
      KEYLENGTH(120) RECSIZE(244));

   DECLARE 1 DB_RECORD,
      2 HEADER     CHAR(20),
      2 DBKEY      CHAR(120),
      2 STUFF      CHAR(100),
      2 NUMBER     FIXED BIN(31);

   DECLARE I FIXED BIN(31);
   DECLARE CS CHAR(26) STATIC
                     INIT('THEQUICKBROWNFXJMPSVLAZYDG');
   DECLARE C(26) CHAR DEFINED(CS);
   DECLARE LETTERS CHAR(30);

   /* CREATE DB */
   OPEN FILE(DB) RECORD KEYED SEQUENTIAL OUTPUT
               TITLE('MYFILE1');
   HEADER = 'DATA RECORD HEADER';
   STUFF = COPY('ABCDE',20);
   DO I = 1 TO 26;
      NUMBER = I;
      DBKEY = '@'||C(I) ||COPY('@',118);
      WRITE FILE(DB) FROM(DB_RECORD) KEYFROM(DBKEY);
      END;
   CLOSE FILE(DB);

   /* TRY A GENERIC READ THEN MOVE SEQUENTIALLY THRU THE FILE */
   OPEN FILE(DBG) RECORD KEYED SEQUENTIAL INPUT
               TITLE('MYFILE1');
   ON ENDFILE(DBG) GOTO EXIT_1;
   READ FILE(DBG) KEY('@') INTO(DB_RECORD);
   LETTERS = SUBSTR(DBKEY,2,1);
   DO WHILE(TRUE);
      READ FILE(DBG) INTO(DB_RECORD);
      LETTERS = TRIM(LETTERS) ||SUBSTR(DBKEY,2,1);
      END;
EXIT_1:
   CLOSE FILE(DBG);
   PUT EDIT(LETTERS)(A);
   IF LETTERS = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ' THEN
      PUT SKIP LIST('TEST PASSES');
   ELSE PUT SKIP LIST('TEST FAILS');

   PUT SKIP;
END TEST;
Parent topic: Record I/O
Related information
Open PL/I User's Guide
Data Type Conversions


Relative Record I/O

Open PL/I also provides an I/O method for accessing consecutive files by a numeric key representing the relative record numbers of the records in the file. This is called relative record I/O. It can be used only with files of fixed-length records, and it cannot be used with indexed (VSAM) files.

Relative record I/O files are regarded as keyed files, but the keys are not stored in the file. They are just the ordinal numbers of the records in the file. The keys must be positive integers. Any value used in a KEY or KEYFROM option of an I/O statement must be an integer or be capable of conversion to an integer.

The ENVIRONMENT attribute is not used in the declaration of a relative record I/O file. Instead, such a file is specified by using an extension of the TITLE option of the OPEN statement. The format of this TITLE option is as follows:

TITLE('filename -DAM n')

where n is the length of the records in the file. The length n includes two bytes that are normally added to the beginning of each record. This halfword is used to record special information about the file.(See the section TITLE Options.)

In general, the same set of PL/I I/O operations can be used with relative record I/O files as with indexed files.

A relative record I/O file can be created using an additional extension in the TITLE option, as follows:

TITLE('filename -DAM n -NOSIZE')

The -NOSIZE option indicates that the two-byte special field is not to be added to the data records. If -NOSIZE is specified for a file, the DELETE statement cannot be used with the file.

Parent topic: Record I/O
Related information
TITLE Options


REGIONAL(1) Record I/O

A REGIONAL(1) file does not have keys recorded in the records. Instead, each record is identified by its region number, which is an unsigned integer. The keys for a REGIONAL(1) file may be character strings consisting only of decimal digits, possibly preceded by leading spaces (which are interpreted as zeros), or the keys can be of integer type.

A REGIONAL(1) file contains data records and dummy records. A dummy record is identified by having a first byte with the hex value FF. Dummy records represent records that have been deleted or whose region numbers have been skipped over when the file was first created. You can also create them explicitly by writing a record whose first byte has the value hex FF. Dummy records are not ignored when the REGIONAL(1) file is read. An Open PL/I program reading a REGIONAL(1) file must be designed to deal with dummy records. You can replace dummy records with valid data records.

You can create a REGIONAL(1) file only by use of DIRECT OUTPUT mode using keyed WRITE statements. The records must be written in ascending region number order, but you may skip over region numbers. When a region number is skipped, a dummy record is written in its place. The KEY condition is raised if you attempt to write records other than in increasing sequence or if you attempt to write a record with a duplicate key.

An existing REGIONAL(1) file can be accessed in SEQUENTIAL INPUT or UPDATE mode, or in DIRECT INPUT or UPDATE mode. (Opening the file in OUTPUT mode causes the existing file to be overwritten.)

If a REGIONAL(1) file is opened for SEQUENTIAL access (INPUT or UP_ DATE), the records are retrieved in ascending order of their region numbers. Dummy records are retrieved as well as valid data records. With SEQUENTIAL INPUT, you can read all records of the file in ascending region number order; with SEQUENTIAL UPDATE, you can so read all records and update those you choose (including changing dummy records to valid data records, and valid data records to dummy records). The rules for sequential READ and REWRITE for REGIONAL(1) are the same as for CONSECUTIVE files.

A REGIONAL(1) file can be opened for INPUT or UPDATE in DIRECT access mode, in which case keyed READ, WRITE, REWRITE, and DELETE statements can be used. READ accesses dummy records as well as valid data records. WRITE and REWRITE are equivalent; either replaces an existing record (data or dummy record) with a replacement record (again, either a data or a dummy record). DELETE converts the record with the specified region number into a dummy record.

  • Example of REGIONAL(1) I/O
Parent topic: Record I/O


Example of REGIONAL(1) I/O

/* This program creates and updates a REGIONAL(1) file */

sample: procedure options(main);
   declare File1 file environment(regional(1) recsize(20));/*requires -defext
   declare Buffer char(20);
   declare FirstByte char(1) defined(Buffer);
   declare Key char(4) varying;
   declare Eof bit;

   put skip list('Creating REGIONAL(1) file with records 1, 5 and 9.');
   open file(File1) output;
   Buffer = copy('1',size(Buffer));
   write file (File1) from(Buffer) keyfrom (1);
   Buffer = copy('5',size(Buffer));
   write file (File1) from(Buffer) keyfrom (5);
   Buffer = copy('9',size(Buffer));
   write file (File1) from(Buffer) keyfrom (9);
   close file(File1);

   open file(File1) update;
   on endfile(File1) Eof = '1'b1;
   Eof '0'b1;       /* Initialize */
   put skip list('Reading file and updating the even numbered records.');
   read file(File1) into(Buffer) keyto(Key);
   do while (^Eof);
     if unspec(FirstByte) = 'FF'b4 then do;  /* dummy record */
       if (mod(fixed(Key,15),2) = 0) then do;  /* change even number ones *
       Buffer = 'rewritten';
       rewrite file(File1) from (Buffer);  /* rewrite current record */
       end;
     end;
    read file(File1) into (Buffer) keyto(Key);
    end;
   Eof = '0'b1; /* Reset */
   put skip(2) list ('Reading and displaying all records in file.');
   Key = '1';
   read file(File1) into(Buffer) key(Key);     /* direct read */
   do while (^Eof);
      if unspec(FirstByte) = 'FF'b4 then put skip list(Key,'<dummy record>');
      else put skip list(Key,Buffer);
      read file(File1) into(Buffer) keyto(Key);  /* sequential read */
      end;
   close file(File1);
   put skip;
end sample;

You can compile, link, execute, and display the output of the above sample program with the following commands:

mfplx sample.pl1 -defext -o sample.out
sample.out

The output is as follows:

Creating REGIONAL(1) file with records 1, 5 and 9.
Reading file and updating the even numbered records.

Reading and displaying all records in file.
1       11111111111111111111
2       rewritten
3       <dummy record>
4       rewritten
5       55555555555555555555
6       rewritten
7       <dummy record>
8       rewritten
9       99999999999999999999
Parent topic: REGIONAL(1) Record I/O


TITLE Options

Open PL/I supports a number of non-standard TITLE options that can be used to indicate the type of file being opened. These are as follows:

-SAM [n]

-DAM [n]

-NOSIZE

-APPEND [n]

-DELABORT [n]

where n is an integer indicating that the file has fixed-length records of length n bytes.

These options are included in the operand of the TITLE option immediately following the filename and separated from it by one or more spaces, as shown in the following examples:

TITLE('recfile.dat       -SAM 80')
TITLE('keyfile -DAM')

The -SAM and -APPEND options can be used with stream files, in which case the length, if specified, is ignored. -SAM is never required for stream files.

-SAM [n] specifies that the file is a consecutive file. If n is specified when the file is created, the file is created with records of fixed length n. The maximum value for n is 131,017 bytes. If n is not specified when the file is created, records written to the file can be of any length and of varying lengths. If -SAM is used when opening a file for OUTPUT, if the file already exists, it is deleted and a new file is created.

-DAM [n] specifies that the file is a relative record I/O file. If n is specified when the file is created, the file is created with records of fixed length n. If n is not specified when the file is created, the file is created as a variable-length record file. If -NOSIZE is not also specified, this length n includes the two bytes that are added as a halfword of length information at the beginning of each record.

-NOSIZE can be used alone or in combination with -DAM [n]. It specifies that the length halfword is not included at the beginning of each record. If -NOSIZE is used without -DAM [n], -DAM is implied.

-APPEND [n] has the same meaning as -SAM, except that when used in opening a file for OUTPUT, it causes an already existing file to be appended to rather than replaced.

-DELABORT causes the file to be deleted when it is closed.

If a file is opened for OUTPUT and none of these TITLE options is specified, and there is no ENVIRONMENT attribute in the file declaration, if the opening is for a DIRECT file, -DAM is assumed, and if the opening is not for a DIRECT file, -SAM is assumed.

Parent topic: Record I/O


Data Types

  • Introduction
  • Arithmetic Data
  • Picture Data
  • Character-String Data
  • Wide Character-String Data (UTF-16 Support)
  • Bit-String Data
  • Area Data
  • Locator Data
  • Label Data
  • Entry Data
  • File Data
  • Arrays
  • Structures
  • Arrays of Structures
  • Data Size and Alignment
Parent topic: Open PL/I Language Reference Manual


Introduction

Each value has a data type that determines which operations can be performed on the value and the way in which the value is represented in storage.

Data types are declared for variables, function results, named constants (such as files), and external procedures. They are also used with the ENTRY attribute to describe the data type of each parameter of a procedure.

Data types are declared using the following attributes:

Computational Data | Non-Computational Data
FIXED BINARY | POINTER
FIXED DECIMAL | LABEL
FLOAT BINARY | ENTRY
FLOAT DECIMAL | FILE
PICTURE | OFFSET
CHARACTER | AREA
CHARACTER VARYING |
WIDECHAR | AREA
WIDECHAR VARYING |
BIT |

The attributes in the first column represent data items whose values can be manipulated by arithmetic or string operations and are therefore computational. The attributes in the second column refer to data used within a program for control structures and linkage and are therefore non-computational.

The data type of a value produced by an expression is determined by the operands and the built-in functions within the expression. The data type of a constant is determined by the syntax of the constant.

A variable capable of storing only one value, such as an integer or a character string, at any one time is called a scalar variable. An array variable is a collection of variables all of the same type. For example, an array might consist of 20 individual character strings. The variables contained in the array are called elements of the array. These elements all have the same name as the array. They are ordered by a numeric index, or perhaps several indices, and they are referenced by use of these indices. A structure variable is a collection of variables of arbitrarily mixed types. The variables contained in a structure are called members of the structure. The members each have their own name. A member may be referenced by its name alone, or its name may be qualified by the structure name to distinguish it from a member of another structure. A structure can contain subordinate structures as members, as well as array members and scalar members. Also, the elements of an array can be structures.

This chapter discusses each data type, beginning with computational data types.

Parent topic: Data Types
Related information
ENTRY
Types of Operators
Open PL/I Built-Ins


Arithmetic Data

Each arithmetic value is characterized by a base (binary or decimal), a scale (fixed-point or floating-point), and a precision (the number of digits in the value). These three properties collectively constitute the data type of the arithmetic value.

The data type of arithmetic values is expressed using the following attributes:

  • FIXED BINARY(p) and FIXED DECIMAL(p,q) for fixed-point data
  • FLOAT BINARY(p) and FLOAT DECIMAL(p) for floating-point data

where p is the precision and q is the number of fractional digits in the precision.

Each implementation of PL/I imposes limits on the maximum values of p and q, and these limits typically differ for each combination of base and scale. Refer to your Open PL/I User's Guide for information on the default precision and maximum precision for each arithmetic data type in Open PL/I.

  • Fixed-Point Binary Literals
  • Floating-Point Binary Literals
  • Fixed-Point Data
  • Floating-Point Data
Parent topic: Data Types


Fixed-Point Binary Literals

Fixed-point binary literals are treated the same way as fixed-point decimal literals. Examples of fixed-point binary literals are:

1000b, 1000.101B
Parent topic: Arithmetic Data


Floating-Point Binary Literals

The IBM compiler converts binary floating-point literals to short floating-point values if the precision is less than 21. However, Open PL/I ignores precision, and always converts the string to a floating-point decimal with the maximum permitted precision. Examples of floating-point binary literals are:

1000E201b, 1000.101E2B
Parent topic: Arithmetic Data


Fixed-Point Data

Fixed-point numbers contain p digits. For fixed-point decimal numbers, q of those digits may be fractional digits. Fixed-point binary numbers are always integers (q =0). For example:

DECLARE K FIXED BINARY(15);
DECLARE D FIXED DECIMAL(7,2);

In this example, the values of K are fixed-point integers with 15 binary digits. Therefore, K can hold any value in the range -32768 to +32767 or -(2**?15) to (2**?15)-1. The values of D are fixed-point numbers with seven decimal digits, two of which are fractional digits. Therefore, D can hold any value in the range -99999.99 to +99999.99.

Because most computers operate most efficiently with binary integers, fixed binary variables should be used whenever possible. The relative efficiency of fixed binary variables used as subscripts, string lengths, DO index variables, and so forth is very significant.

Refer to your Open PL/I User's Guide for a description of the -Iongint compiler option, which alters the default precision of fixed binary variables from 15 to 31.

Fixed decimal values generally require more bits of storage and are often more computationally complex than values represented in binary, but fixed decimal values are more efficiently converted to and from an external form (for example, at input and output). In certain instances, fixed decimal values may also be less prone to rounding error than their binary counterparts.

An attempt to calculate a fixed decimal value too large to be supported results in a signal of the ERROR condition. An attempt to calculate a fixed binary value too large to be supported will not result in any error and may cause unexpected results. For rules on precision and scale, see the chapter Data Type Conversions.

Operations involving both decimal and binary values always produce a binary result value. However, if the operation must yield a result that has a fractional part, the result is decimal.

If a fixed-point value is converted to a character string or bit string, the length of the string is determined by the declared precision of the fixed-point value p. For a discussion of the conversion rules, see the chapter Data Type Conversions.

Fixed-point values are never rounded unless explicitly rounded by the use of a built-in function. Assignment to a fixed-point variable truncates excess low-order digits. All possible roundings can be performed by using the CEIL, FLOOR, TRUNC, or ROUND built-in functions.

Fixed-point decimal values are always stored as an accurate representation of decimal fractions. A fixed-point decimal value of 10.50 is never represented as 10.49.

Fixed-point constants are written as decimal numbers with or without a decimal point, as shown in the following examples:

5
4.5
4100.01

If a fixed-point constant contains a decimal point, it is considered to be a scaled fixed-point value and is stored and accessed like a fixed decimal variable. Fixed-point constants without a decimal point are integer constants and can be used safely in operations with any other arithmetic value, regardless of that value's base or scale. It is advisable to always write integer constants without a decimal point.

The precision of a fixed-point constant is the number of digits in the constant.

Parent topic: Arithmetic Data
Related information
Open PL/I User's Guide
Data Type Conversions
Open PL/I Built-Ins


Floating-Point Data

Floating-point data is used to represent values whose magnitudes are too great or too small to be represented by fixed-point data. It may also be used to minimize precision loss in calculations where terms differ considerably in magnitude.

Unexpected results may appear when using floating-point values. The limited precision of floating-point variables and the fact that they cannot precisely represent most fractional values combine to produce behavior in a program that may seem strange. Furthermore, the floating-point implementation on many machines carries more precision in intermediate results than is strictly required by the rules of PL/I. Also, floating-point variables and constants are usually limited to only one or two actual internal precision values. For example, most implementations of the IEEE floating-point standard allow only "short" (23-bit) and "long" (52-bit) floating-point values. Finally, precise results may vary depending on the level of program optimization.

For example, consider the following program:

SAMPLE: PROCEDURE OPTIONS (MAIN);
DECLARE
   (F,G)    FLOAT BINARY (23);
   F = 3111;
   G = .14;
   IF F + G ^= 3111.14 THEN
      PUT LIST ('UNEQUAL RESULT');
END SAMPLE;

This program will actually print the UNEQUAL RESULT message when run on many machines, because the constant .14 and 3111.14 are not precisely representable as floating-point binary numbers. The assignment of .14 to G puts about 23 bits of precision of the constant into the variable. On most implementations, the sum is computed with an actual precision of 52 or more bits, preserving the 23 bits of precision that apply to the fractional part. However, that sum is being compared to the constant 3111.14. The constant will have 23 or 52 bits of precision. (In fact, a strict implementation of the rules of the language requires only that it have 20 bits of precision; for more information, see the chapter Data Type Conversions.) If 3111.14 is represented as a short floating-point number, 14 of the 23 bits of precision are taken up to represent 3111 and hence only 9 bits of the fraction appear in the constant. This will not result in an equal comparison to the constant 3111.14. If the constant is a long floating-point number, 38 of the 25 precision bits will be fractional and the comparison will still fail.

One attempt to fix this might be to change the program as follows:

SAMPLE: PROCEDURE OPTIONS (MAIN);
DECLARE
   (F, G, H) FLOAT BINARY (23);
   RESULT    FLOAT BINARY (23) STATIC INITIAL (3111.14)
   F = 3111;
   G = .14;
   H = F + G
   IF H ^= 3111.14 THEN
      PUT LIST ('UNEQUAL RESULT')
END SAMPLE;

This appears to truncate the sum to a "real" 23 bits of precision and to compare it to a constant of known precision. This will normally work. However, in the presence of optimization, the value of F + G may be used without reducing its precision through storing it in H and then reloading it.

Thus, as a general rule, comparing floating-point numbers for equality and inequality does not work reliably. Instead, check for equality using the following method:

ABS(FIRST-SECOND) < EPSILON

where the constant EPSILON must be chosen considering the goal of the application.

Floating-point numbers consist of a mantissa m, a base b, and an exponent e. A floating-point number is represented in the following format:

m*b**e

The mantissa m is a fraction containing at least p digits. The value of b and the possible range of e are defined by each implementation (for information on this implementation, refer to your Open PL/I User's Guide); however, if the base is binary, m contains the equivalent of at least p binary digits, and if the base is decimal, m contains the equivalent of at least p decimal digits. For example:

DECLARE X FLOAT BINARY(23);
DECLARE Y FLOAT DECIMAL(7);

In this example, the values of X are floating-point numbers whose mantissa contains the equivalent of at least 23 binary digits. The values of Y are floating-point numbers whose mantissa contains the equivalent of at least 7 decimal digits.

The representation of floating-point values in storage also depends on the implementation. An implementation may represent the mantissa in any base that it chooses, provided that it contains an equivalent of at least p binary or p decimal digits. On some computers, decimal floating-point values are represented by using a decimal mantissa, while other implementations use a binary or hexadecimal mantissa for all floating-point numbers.

Open PL/I represents floating-point decimal using a decimal mantissa and decimal exponent, and represents floating-point binary using a binary mantissa and binary exponent. For more information, refer to your Open PL/I User's Guide.

Because floating-point values may be represented in either base, and because excess digits may be lost during calculations, floating-point values may be approximate. However, any integer value that is converted to floating-point and converted back to integer retains its original value. Likewise, the floating-point calculations of addition, subtraction, and multiplication, when performed on integer values, produce integer values.

Floating-point constants are written as fixed-point constants followed by an exponent, as shown in the following examples:

5E+02
4.5E1
100E-04
.001E-04
0E0

Floating-point constants have a decimal precision of p, where p is the number of digits in the fixed-point constant. For example, 4.5E1 has a precision of 2.

When fixed-point constants such as 1.5 are used in operations with floating-point values, they should be written with an exponent to avoid run-time conversion of fixed-point decimal values to floating-point.

If floating-point values are converted to character strings or bit strings, the length of the resulting string is determined by p, not by the actual value. For a discussion of conversion rules, see the chapter Data Type Conversions.

Caution is necessary when using floating-point constants in arithmetic expressions. Floating-point constants are considered to be of type Float Decimal, and the rules for the precision of arithmetic results specify that the precision of the result of a floating-point operation is the maximum of the precisions of the operands. Consider the following example:

SAMPLE2: PROCEDURE OPTIONS(MAIN);
DECLARE
   X FLOAT BIN(52);
   X = 1E0 + .4999E0;
   PUT SKIP LIST(X);
END SAMPLE2;

The answer printed by this program is, surprisingly, .500000000000000E+000. This is because the two constants are Float Decimal with precisions of 1 and 4, respectively. The addition is performed and the result is converted to Float Decimal(4); the intermediate result of 1.4999 is rounded to 4 decimal digits, and the result is converted to Float Binary and stored in X. An attempt to correct this might be to change the expression to read

X = BINARY(1E0) + BINARY(.4999E0);

This does the computation in Float Binary. However, this converts the first constant to Float Bin(4) and the second to Float Bin(14), and does the computation in short floating-point on most machines. The short floating-point result is lengthened to Float Bin(52) and is then stored in X, giving an answer of 1.499900013208389E+000. The correct fix is to use the two-argument form of the BINARY built-in function:

X = BINARY(1E0,52) + BINARY(.4999E0,52);

This produces long floating-point constants and the computation is done with maximal precision, printing 1.499900000000000E+000. Another solution would be to rewrite the constants using trailing zeros to indicate a more precise constant:

X = 1.0000000000000000E0 + .4999000000000000E0;

This also gives 1.499900000000000E+000, since the computation is done in large enough precision and the result is converted directly to a high-precision floating-point value.

In general, when using floating-point constants in arithmetic expressions with floating-point variables, the precision of the result can be controlled by using the FLOAT and BINARY built-in functions on the operands. The results of operations on two floating-point constants may not be what is expected.

Exponentiation, MOD, and all transcendental functions (including SORT) operations on floating-point decimal data are actually performed using the floating-point binary operations. Thus, the range of the operands and the results of these operations are limited to the ranges for floating-point binary numbers.

Parent topic: Arithmetic Data
Related information
Data Type Conversions
Open PL/I User's Guide


Picture Data

Picture data represents fixed-point decimal or character values that are stored internally as character strings. The strings contain the characters that represent the numeric or character values in a specified-format (as indicated by special embedded symbols, such as a period or a comma).

Picture data is best used to manipulate a string or numeric quantity arithmetically and then print or display its value using a special output format.

A pictured value is any value whose data type is either declared by a PICTURE attribute or is acquired by the P format in a FORMAT statement. Picture characters are the special characters that make up the picture specification in the PICTURE attribute and in the P format item. Following are examples of picture specifications declared by the PICTURE attribute:

DECLARE F PICTURE '$ZZ,ZZZV.99CR';
DECLARE G PICTURE '$$$,$$$V.99-';
DECLARE H PICTURE '$**,***V.999';
DECLARE I PICTURE '----9V.999';
DECLARE J PICTURE '9999V9999S';

If the value -1234.56 was assigned to each of the variables in these examples, the resulting picture values would be as follows:

Repetition factors can be used for sequences of identical picture characters. For example, the following declaration of J is equivalent to the one given above:

DECLARE J PICTURE '(4)9V(4)9S';
  • Picture Specification Characters
  • Rules for Using Numeric Picture Data
  • Picture Repetition Factors
Parent topic: Data Types


Picture Specification Characters

A picture specification is a sequence of picture characters. A picture specification can be either a character picture specification or a numeric character picture specification. The picture specification is enclosed in single or double quotation marks.

The sequence of picture characters describe the contents of each position of either a character data item or numeric character data item, as well as the contents of the output. An A or X character in the picture specification defines it as a character picture specification. A picture specification without an A or X character is a numeric character picture specification.

Character Picture Specification

A character pictured item consists of alphabetic characters, decimal digits, blanks, currency symbols, and punctuation characters.

A character picture specification includes:

Character | Description
X, A, 9 | Validate each character of data with allowed character set.

The character picture characters are:

Character | Description
X | Any character of the 256 possible bit combinations represented by the 8-bit byte.
A | Any alphabetic or extra-lingual (#, @, $) character, or blank.
9 | Any digit, or blank. Blanks are only allowed for character data.

A character picture specification describes a nonvarying character data item. You can specify that any position in the data item contain characters only from certain subsets of the available character set. Data consists of alphabetic characters, decimal digits, and blanks. The only valid characters in a character picture specification are X, A, and 9.

When a character value is assigned or transferred to a picture character data item, the particular character in each position is validated according to the corresponding picture specification character. If the character data does not match the specification at a given position, the CONVERSION condition is raised for the invalid character.

In the following example, valid values for PartNum include:

'BF123M'

'KL092/'

'BT013'

declare PartNum picture'AA999X';
put skip edit(PartNum)(P'AA999X');

Numeric Character Picture Specification

A numeric character pictured item consists only of decimal digits, an optional decimal point, and optional plus or minus signs. While other arithmetic characters such as currency symbols can also be specified, they are not part of the variable's numeric character value. Other arithmetic characters however are stored with the digits and are part of the variable's character value.

A numeric character picture specification includes:

Category | Character | Description
decimal place character | V | Affects the numeric interpretation of the value only. The decimal point character is not actually stored.
digit characters | 9, Z, *, Y | Mark the positions occupied by decimal digits and affect both the numeric interpretation and character representation of the value.
encoded sign characters | T, I, R | Represent a digit that has the sign of the value encoded in the same position with the digit, thereby affecting both the numeric interpretation and character representation of the value. These characters can be used wherever the digit specifier '9' is valid.
drifting characters | $, +, –, S | Indicates digits or symbols to be inserted in the internal representation of a character. (See the section Drifting Characters and Strings.)
insertion characters | Decimal point (.), comma (,), slash (/), and space (B) | Inserted between digits to indicate that characters are inserted in the internal representation of the pictured value. Drifting characters also function as insertion characters when they are used singly.
credit and debit | CR, DB | Always specified as two-character symbols. (See the section Credit and Debit Characters.)
Note: A character picture specification cannot be mixed with numeric picture specification. However the character 9 can be used both as a character picture character and a numeric picture character.

The following describes the numeric picture characters.

Character | Description
V Indicates the position of the "assumed" decimal point. All digit positions to the right of the 'V' are fractional digits.

Any value assigned to a pictured value is first scaled so that its decimal point is aligned with the 'V'. Only one 'V' character can appear in a picture. If a picture does not contain the 'V' character, it is assumed to be at the right end of the picture, implying an integer value.

B, ./ Indicate the positions at which a space (B), comma, decimal point, or slash, respectively, are inserted. These picture characters are inserted into the pictured value only if they are preceded by a nonzero digit or if they are preceded by a '9' or 'V' picture character. If they are not inserted, a zero suppression character (a blank) or an asterisk (*) is inserted instead.

If an asterisk or drifting string occupies the position preceding the insertion character and that position corresponds to a leading zero, the asterisk or drifting string character also suppresses the insertion character.

The 'V' and decimal point (.) must be adjacent to one another to ensure that the decimal point is in the same position in both the numeric and character interpretations. The period should follow the 'V' to ensure that it will be in the correct location and will appear whenever any fractional digit is significant.

Z Indicates a decimal digit with leading zero suppression.

The 'Z' causes zero suppression using a blank as the suppression character. A 'Z' must not be preceded by a '9' or a drifting string. A picture containing a 'Z' must also not contain an asterisk (*).

If 'Z' picture characters appear to the left of 'V', all leading zeros in positions corresponding to those 'Z' characters are suppressed. Nonzero digits and significant zeros are never suppressed. Suppressed zeros are represented by spaces.

If a 'Z' appears to the right of 'V', all digits in the value must be indicated by 'Z' characters. Fractional zeros are then suppressed only if all fractional digits are zero and all integer digits are suppressed. In this case, the internal representation contains only spaces in the digit positions.

Note:

Refer to the examples in the section Rules for Using Picture Data.

* Indicates a decimal digit with leading zero suppression. The '*' causes zero suppression using an asterisk as the suppression character. An '*' must not be preceded by a '9' or a drifting string. A picture containing an '*' must also not contain a 'Z'.

The rules for '*' are otherwise the same as those for 'Z'.

S Indicates the position of the plus sign (+) or minus sign (-), which may or may not be drifting. The 'S' causes the plus sign to be inserted if the numeric value is greater than or equal to zero, and causes the minus sign to be inserted if the value is less than zero.

If an 'S' occurs more than once in a picture, the entire field of 'S's is a drifting string and can only contain a 'V' and one or more 'B' , '.' or '/' picture characters. Such a field cannot be preceded by a '9', 'Z', or '*', and if it contains a 'V' followed by one or more 'S's, it cannot be followed by a '9'.

The total number of digits represented by a drifting string is one less than the number of 'S's in the field. The digits are zero suppressed and a sign of '+' or '-' is inserted immediately preceding the most significant digit of the value.

A single 'S' causes a sign of '+' or '-' to be inserted into the pictured value, at the location implied by the position of 'S' in the picture.

+ Indicates the position of the plus sign (+) to be inserted if the numeric value is greater than or equal to zero. Operates exactly like 'S', except that the sign of negative values is indicated by a blank.
– Indicates the position of the minus sign (–) to be inserted if the numeric value is less than zero. Operates exactly like 'S', except that the sign of positive values is indicated by a blank.
$ Indicates the position of the dollar sign ($) to be inserted. Operates like 'S', except that a '$' is inserted instead of either sign.
9 | Indicates a decimal digit, including leading zeros. The position occupied by '9' always contains a decimal digit, regardless of whether the digit is, or is not, significant in the numeric interpretation of the pictured value.
Y | Indicates the position of a decimal digit in which the zero digit is always suppressed by a blank, regardless of the position of 'Y' relative to other picture characters.
CR | Indicates the position at which 'CR' is inserted if the number is less than zero. These two characters must appear as a pair on the rightmost end of the picture. They are replaced by two blanks in internal representation if the value is not negative.
DB | Indicates the position at which 'DB' is inserted if the number is less than zero. Like 'CR,' these two characters must appear as a pair, may only appear on the rightmost end of the picture, and are replaced by two blanks in internal representation if the value is not negative.
T | Indicates the position of a decimal digit with an encoded plus or minus sign. The digit contains an encoded plus sign if the numeric value is greater than or equal to zero and an encoded minus sign if the value is less than zero. (See table below for representations of encoded sign digits.)
I | Indicates the position of a decimal digit with an encoded plus sign if the numeric value is greater than or equal to zero. If the value is less than zero, the position contains an ordinary digit.
R | Indicates the position of a decimal digit with, possibly, an encoded minus sign if the numeric value is less than zero. If the value is greater than or equal to zero, the position contains an ordinary digit.
Digit | ASCII Character | Digit | ASCII Character
–0 | } | +0 | {
–1 | J | +1 | A
–2 | K | +2 | B
–3 | L | +3 | C
–4 | M | +4 | D
–5 | N | +5 | E
–6 | O | +6 | F
–7 | P | +7 | G
–8 | Q | +8 | H
–9 | R | +9 | I
Parent topic: Picture Data
Related information
Drifting Characters and Strings
Credit and Debit Characters
Rules for Using Picture Data


Rules for Using Numeric Picture Data

The rules for using numeric picture data are as follows:

  1. A numeric picture cannot contain more than one sign character ('+', '–', 'S', 'T', 'I', 'R', 'CR', or 'DB') unless all such sign characters are part of a drifting string.
  2. When a zero value is assigned to a numeric pictured variable and the numeric picture does not contain at least one '9', the entire value is filled with blanks or with asterisks (*), depending on which zero-suppression character was used.
  3. When a nonzero value is assigned to a numeric pictured variable, and the 'V' is followed by zero-suppression characters or by part of a drifting string, the 'V' stops zero suppression. For example:
    DECLARE A PICTURE 'ZZZV.ZZ';
DECLARE B PICTURE '***V.**CR';

    In this example, a value of . 01 assigned to A and B produces boxes and . boxes. A value of zero assigned to A and B produces boxes and ********.

  4. If a 'V' is not given, a 'V' is implied at the rightmost end of the numeric picture.
  5. Each '9', 'Z', or '*' is considered to be a digit of precision. Within a drifting string each 'S', '+', '–', or '$', except the first one, is considered to be a digit of precision. All digits of precision following the 'V' are fractional digits. For example:
    DECLARE A PICTURE 'ZZZV.ZZ'
DECLARE B PICTURE '---V.z--'

    In this example, A has a precision of (5,2), while B has a precision of (4,2).

  6. Negative values cannot be assigned to a numeric pictured variable unless the picture contains a 'CR', 'DB', '–', or 'S'. An error condition is signaled if a negative value is assigned to a numeric pictured variable that does not contain 'S', '+', '–', 'T', 'I', 'R', 'CR', or 'DB'.
  7. Values assigned to numeric pictured variables are truncated and aligned with the `V' as they would be when assigned to a fixed decimal variable of the equivalent precision.
  8. Used in contexts that expect an arithmetic value, or used with a relational operator, numeric pictured values are converted to fixed-point decimal values with a precision p and q that are determined by the numeric picture.
  9. A numeric pictured value is operated upon as if it were a character-string value only when it is assigned to a character-string variable, and when it is an operand of the concatenate operator or of a built-in function that expects character-string operands. In all other contexts, numeric pictured values are operated upon as if they were fixed-point decimal values.

Following are more examples of picture format output.

Example | Data | Picture | Output
1 | 12345.60 | $SSSSSSSSV.99 | $ boxes +12345.60
2 | 1.23 | **********V.99 | .********1.23
3 | 1.23 | ZZZZZZZZZZV.99S | boxes 1.23
4 | 1234.56 | Z.ZZZ ZZZV,99 | boxes 1.234,56
5 | 11011111 | 9999B9999 | 1101 boxes 1111
6 | 011335 | **/**/** | *1/13/35
7 | 1234567890 | 999999999V.99 | 234567890.00
8 | .33 | ZV.ZZ | box .33
9 | .75 | ZV.ZZ | box .75
10 | 1234567.89 | $999,999,999V.99DB | $001,234,567.89
11 | -1234567.89 | $999,999,999V.99CR | $001,234,567.89CR
12 | 1023 | YYYYY | 1 23

In example 1, '$' is a static character because it appears only once, whereas 'S' is a drifting character because it appears all the way to the decimal.

In examples 2, 3, and 4, the characters 'Z' and '*' are zero-suppression characters. The asterisk prints wherever a zero or blank would have printed, and the 'Z' substitutes blanks.

In example 5 the insertion character 'B' results in a space (blank). A blank is inserted wherever the 'B' appears in the numeric picture format unless it is in a field of zero-suppression characters that are suppressing zeros at the time.

In example 7, the appearance of the character '9' results in the printing of a digit. All digits 0 through 9 are printed, except the leading one, which is truncated.

In examples 8 and 9, the character 'V', once encountered, turns off suppression; all characters after the 'V' are printed. Note that in Example 8, 'V' is not used before the decimal point, so the point is turned off, not on.

Examples 10 and 11 show the result of positive and negative data applied to numeric pictures that contain either 'CR' or 'DB'.

  • Drifting Characters and Strings
  • Credit and Debit Characters
Parent topic: Picture Data


Drifting Characters and Strings

Used alone in a picture, one drifting character marks the position where a special symbol or space is to be inserted. It does not affect the value's numeric interpretation. In this context, the character must appear either before or after all characters that specify digit positions.

If a series of n (n >1) drifting characters appears in a picture, the rightmost n-1 of the characters in the series also specify digit positions. If the digit is a leading zero, the leading zero is suppressed, and the leftmost character "drifts" to the right. In internal representation, the character appears either in the position of the last drifting character in the series or immediately to the left of the first significant digit, whichever comes first. In this context, the n-1 drifting characters also define a portion of the numeric precision of the picture variable, because they describe at least some positions occupied by decimal digits.

A drifting string is a series of more than one of the same drifting character. Only one drifting string can be used in a picture; other drifting characters can be used only individually to designate insertion characters, not digits.

The 'Z' and '*' characters cannot appear to the right of a drifting string.

A digit position cannot be specified to the left of a drifting string.

These rules apply to insertion characters embedded in a drifting string:

  • If the drifting string contains an insertion character, the insertion character is inserted in the internal representation only if a significant digit appears to its left. In the position of the insertion character, a space appears if the leftmost significant digit is more than one position to the right; the drifting symbol appears if the next position to the right contains the leftmost significant digit.
  • If the drifting string contains a 'V' character, all digit positions to the right of the 'V' (the fractional digits) must also be part of the drifting string. Insignificant fractional digits are suppressed only if all integral and fractional digits are zeros; if so, they are replaced by spaces in the internal representation. If any digit is not zero, all fractional digits appear as actual digits.
  • Insertion characters that appear to the immediate right of a drifting string are considered part of the drifting string.
Note:

Refer to the examples in the section Rules for Using Numeric Picture Data.

Parent topic: Rules for Using Numeric Picture Data
Related information
Rules for Using Numeric Picture Data


Credit and Debit Characters

Regardless of which character pair is included, 'CR' or 'DB', that character pair appears in the internal representation if the numeric value is less than zero. If the numeric value is greater than or equal to zero, the associated positions in the internal representation contain two spaces.

The credit and debit characters are always inserted with the same case used in the picture; for example, if lowercase 'db' is used in the picture, then lowercase letters are inserted into the pictured value, and if the combination of uppercase and lowercase characters, such as 'Db', is used, 'Db' is inserted into the pictured value. The 'CR' and 'DB' character pairs cannot be used in the same picture, and neither pair can be used in the same picture with any other character that specifies the sign of the value, namely, 'S', '+', '–' and the encoded-sign characters ('T', 'I', 'R').

Parent topic: Rules for Using Numeric Picture Data


Picture Repetition Factors

A picture repetition factor is an integer specifying the number of times the following picture character is to be repeated. The repetition factor is enclosed within parentheses (there can be no blanks within the parentheses). If the value of the repetition is 0, the following picture character is ignored. For example:

pic '(4)9V(2)9'

is the same as

pic '9999V99'
Parent topic: Picture Data


Character-String Data

A character-string value is a sequence of characters. The number of characters in a sequence is called the length of the sequence. In Open PL/I, the maximum length of a string value is 32767 bytes or characters.

A character-string of zero length is called a null string.

Note:

Any string produced as an intermediate result requires storage allocated either on the stack or in the system storage area used to support the ALLOCATE statement. Allocation of a large temporary storage block that exceeds the amount of available storage results in a signal of the ERROR condition.

A character-string variable or character-string valued function is declared with the following attributes:

CHARACTER(n)

or

CHARACTER(n) VARYING

where n is an integer valued expression that specifies the maximum length of all string values that can be held by the variable or returned by the function.

The VARYING attribute causes the string variable or function to hold or return values of varying lengths. Internally, the length of the varying string is recorded along with the value. Varying strings are not padded to assume their maximum length, n. The representation of a varying string variable in storage is such that any string up to n characters may be held by the variable, and the length of the current string is retained as part of the value.

Without the VARYING attribute, a string variable or function always holds or returns values of length n. An assignment to a nonvarying string always extends short values with blanks on the right to make them n characters long.

Assignments of a string of more than n characters to either a VARYING or a nonvarying string variable cause only the leftmost n characters to be assigned and excess characters to be truncated.

Character-string values are compared from left to right using the collating sequence of the computer. Strings of unequal length are compared by effectively extending the shorter string with blanks on the right.

Nonvarying character-string variables always occupy exactly n bytes of storage. As elements of arrays or members of a structure, they begin on the next available byte and are not aligned on word or other storage address boundaries. This permits an array of nonvarying characters to be stored and accessed as if it were a single string. See the section Storage Sharing in the chapter Storage Classes.

Varying character-string variables always occupy n+2 bytes of storage. The first 2 bytes contain an integer L (0 <= L <= n) that specifies the length of the string value currently stored in the variable. The string text occupies the first L bytes of the storage following the 2 length bytes. The value of the last n–L bytes of the variable is undefined. The value L can be accessed using the LENGTH built-in function. An array of varying character strings cannot be accessed as if it were a single character string.

See the Open PL/I User's Guide for specific alignment of varying character strings.

A character-string constant is written in the following format:

'Any characters except quote'

If an apostrophe is required within the constant, it must be written as an adjacent pair of apostrophes.

Examples:

'ABC'
'He said, "I don"t know."'
''

In these examples, the second string displays a pair of single quotation marks used within the text string "don't". This text string also shows that the double quotation mark is insignificant as a delimiter of a character-string constant. The string in the last example is a null string.

  • String Repetition Factors
Parent topic: Data Types
Related information
Storage Sharing
Open PL/I User's Guide


String Repetition Factors

Repetition factors can be used with character and bit strings. For example:

(4)'Abc'

is equivalent to a character constant where 'Abc' is repeated four times, 'AbcAbcAbcAbc'

and

(4) '10'B

is equivalent to

'10101010'B

The maximum string repetition factor is 32767.

Parent topic: Character-String Data
Related information
Picture Repetition Factors


Wide Character-String Data (UTF-16 Support)

A wide character-string value is a sequence of double-byte characters or byte-pairs. The number of byte-pairs in a wide character string or sequence is called the length of the string or sequence. In Open PL/I, the maximum length of a wide string value is 16383 byte-pairs or double-byte characters. The byte-pairs are always stored in big-endian format.

A wide character-string of zero length is called a null wide string.

Note:

Any string produced as an intermediate result requires storage allocated either on the stack or in the system storage area used to support the ALLOCATE statement. Allocation of a large temporary storage block that exceeds the amount of available storage results in a signal of the ERROR condition.

A wide character-string variable or character-string valued function is declared with the following attributes:

WIDECHAR(n)

or

WIDECHAR(n) VARYING

where n is an integer valued expression that specifies the maximum length of all wide string values that can be held by the variable or returned by the function. WCHAR can be used as a synonym for WIDECHAR.

The VARYING attribute causes the string variable or function to hold or return values of varying lengths. Internally, the length of the varying string is recorded along with the value. Varying strings are not padded to assume their maximum length, n. The representation of a varying string variable in storage is such that any string up to n wide characters may be held by the variable, and the length of the current string is retained as part of the value. The length field is always stored according the native architecture of the machine for fixed binary (15) data items.

Without the VARYING attribute, a wide string variable or function always holds or returns values of length n. An assignment to a non-varying string always extends short values with blanks (0x0020) on the right to make them n wide characters long.

Assignments of a string of more than n wide characters to either a VARYING or a non-varying string variable cause only the leftmost n wide characters to be assigned and excess characters to be truncated.

Character-string values are compared from left to right using the binary values of the byte-pairs. Strings of unequal length are compared by effectively extending the shorter string with blanks (0x0020) on the right.

Non-varying character-string variables always occupy exactly n*2 bytes of storage. As elements of arrays or members of a structure, they begin on the next available byte and are not aligned on word or other storage address boundaries. This permits an array of non-varying characters to be stored and accessed as if it were a single wide string.

Varying wide character-string variables always occupy (n*2)+2 bytes of storage. The first 2 bytes contain an integer L (0 <= L <= n) that specifies the length of the wide string value currently stored in the variable. The string text occupies the first L*2 bytes of the storage following the 2-byte length field. The value of the last n-L byte-pairs of the variable is undefined. The value L can be accessed using the LENGTH built-in function. An array of varying wide character strings cannot be accessed as if it were a single wide character string.

See the Open PL/I User's Guide for specific alignment of varying character strings.

Restrictions

  • All WIDECHAR byte-pairs are stored in Big Endian format.
  • All WIDECHAR VARYING length-fields are stored in the native machine architecture for integer values.
  • WIDECHAR characters in source files is not supported.
  • W string constants is not supported.
  • WIDECHAR expressions in stream I/O is not supported.
  • Implicit conversions to/from WIDECHAR in record I/O are not supported.
  • Implicit endian-ness flags in record I/O are not supported.
  • Only Big Endian byte-pairs within WIDECHAR files is supported.
  • WIDECHAR(x) VARYINGZ is not supported.
  • Surrogate pairs are not supported.
  • UTF-8 is not supported.

Wide Character String Constants

A wide character-string constant must written as a Wide Character String Hexadecimal Literal. For example:

Dcl wstr widechar (2) init   (‘039103AA’Wx) ;
/* Greek upper case ALPHA OMEGA */

For wide character string literals with all byte-pair binary values < 0x0080 (ASCII collating sequence 0 - 127 hex), character string literals may be used, and the compiler will do the appropriate internal conversion to type WIDECHAR. For example:

Dcl wstr widechar (32) varying init (‘Hello Widechar!!’);
Parent topic: Data Types


Bit-String Data

A bit-string is a sequence of binary digits (bits). The number of bits in the sequence is called the length of the value.

A bit-string of zero length is called a null string.

A bit-string variable or bit-string valued function is declared with the following attributes:

BIT(n)

or

BIT(n) ALIGNED | UNALIGNED

where n is an integer valued expression that specifies the maximum length of all string values that can be held by the variable or returned by the function.

If a value of less than n bits is assigned to a bit-string variable, the variable is extended on the right with zero bits to make it n bits long. If a value of more than n bits is assigned, only the leftmost n bits are stored, and the excess bits are truncated.

The ALIGNED attribute causes the associated bit-string variable to be aligned on the storage boundary (described in your Open PL/I User's Guide) so as to make it more efficiently accessed. This attribute may also cause the variable to occupy more than n bits, but it does not increase the size of values that can be stored in the variable.

The UNALIGNED attribute causes the associated bit-string variable to be aligned at the next available bit so as to reduce storage requirements. If neither ALIGNED nor UNALIGNED is specified, UNALIGNED is assumed by default.

In the following structure declaration,

DECLARE 1 S ALIGNED,
        2 A BIT(3),
        2 B BIT(7) UNALIGNED,
        2 C BIT(1) UNALIGNED;
        2 D BIT(5);

the bit strings are stored as follows:

Stored Bit Strings

In this example the A and D strings are aligned because they inherit the ALIGNED attribute from the structure declaration. A bit string occupies a full byte. If the structure S had been declared with the UNALIGNED attribute, the A and D strings would be unaligned.

Bit-string values are compared from left to right, a bit at a time until an inequality is found. The shorter operand is effectively extended by zero bits on the right to make it the length of the other operand for purposes of comparison.

A bit-string is not a word of storage in a computer and is not an arithmetic value. It is a sequence of bits that is always operated upon from left to right, just as a character string is operated upon from left to right.

A bit-string constant is written as a quoted string of zeros and ones followed by a B.

A bit string of length one is a boolean value with the possible values of '0'B and '1'B, which denote false and true, respectively.

Note: No assumptions should be made about the form in which a bit-string is stored.

Examples:

'1'B
'10110'B
'O'B
''B

The last string in the previous set of examples is a null bit string.

Bit-string constants may also be written using a string of characters to represent the bit string:

'character string'Bn

where n is 1, 2, 3, or 4 and is the number of bits each character represents. The table below gives the set of permissible characters and shows the corresponding bit-string values. In this table, a '–' indicates 'invalid.'

Character
 | B or B1 | B2 | B3 | B4
0 | 0 | 00 | 000 | 0000
1 | 1 | 01 | 001 | 0001
2 | – | 10 | 010 | 0010
3 | – | 11 | 011 | 0011
4 | – | – | 100 | 0100
5 | – | – | 101 | 0101
6 | – | – | 110 | 0110
7 | – | – | 111 | 0111
8 | – | – | – | 1000
9 | – | – | – | 1001
A | – | – | – | 1010
B | – | – | – | 1011
C | - | - | _ | 1100
D | – | – | – | 1101
E | – | – | – | 1110
F | – | – | – | 1111

For example:

Bit-String | Equivalent Value
'073'B3 | '000111011'B
'A04'134 | '101000000100'B
Parent topic: Data Types


Area Data

An area is a region of storage in which based variables can be allocated and freed. Area variables can have any storage class and may be scalars or arrays. Explicit declaration with an area attribute has the following format:

AREA[(exp [REFER (variable)])]

or

AREA (*)

The exp used with the area attribute specifies the number of bytes reserved for the area. This size is rounded up to an 8-byte boundary as necessary.

For an area with the STATIC storage class, the size must be an integer constant.

For areas having the AUTOMATIC, CONTROLLED, or BASED storage classes, the size is defined by an integer expression; if an area is a member of a BASED structure, however, the size specification can use the REFER option.

If neither expression nor asterisk is specified, the default size is 1000 bytes. For example,

DECLARE AREA1   AREA(4096),
   AREA2        AREA,
   1 S       BASED,
   2 X       FIXED BIN(15),
   2 AREA3(1024 REFER(X));

An alternate way to declare an AREA is implicitly, through its use in the following contexts:

  • The IN option of an ALLOCATE statement. For example:
    ALLOCATE X IN(A1);
  • The OFFSET attribute of an offset variable declaration. For example:
    DECLARE 0 OFFSET(A1);

Area variables are always aligned on 8-byte boundaries. The UNALIGNED attribute is not applicable to AREA variables.

Only based variables can be allocated in an area. Use of an area allows related items to be allocated and freed only in that region of storage reserved for the area. The area can be assigned or transmitted as a unit, complete with all the allocations it contains. To preserve the desired alignment constraints in the area, the size of any allocation within the area is always rounded to an 8-byte boundary.

The amount of reserved storage that is actually in use is known as the "extent" of the area. When first allocated (prior to any allocation in it), the extent of the area is zero. The maximum extent is represented by the "area size." When a based variable is allocated or freed, the extent of the area is updated to reflect the change in the amount of storage in use. In addition, when a based variable is freed, the storage it occupied is added to a chain of available storage blocks within the area. The area extent and the free chain are maintained in an 8-byte control block, adjacent to the space reserved for the area.

Areas may be assigned and passed as arguments. However, areas cannot be compared or otherwise have any operators applied to them.

When an area variable is assigned to another, all allocations in the target area are freed and the extent of the target area is set equal to that of the source area.

The AREA condition is raised for an illegal area assignment detected at run-time. This situation occurs if the maximum size of the source area exceeds that of the target area. The AREA condition is also raised when an attempt is made to allocate a based variable within an area that has too little free storage to accommodate it. For more information about the AREA condition, see the "Area" section in the section ON in the chapter Statements.

Offset variables are used to indicate the locations of based variables within the area. See the discussion in the section Offset Data.

Parent topic: Data Types
Related information
ON
Offset Data


Locator Data

Locator data is data whose purpose is to specify the location of other, usually based or controlled, data. Open PL/I supports two types of locator data: pointers and offsets.

  • Pointer Data
  • Offset Data
Parent topic: Data Types


Pointer Data

A pointer value is the address of a variable's storage. For example:

DECLARE K FIXED BINARY(15);
DECLARE A(5) FIXED BINARY(15);
DECLARE P POINTER;
   .
   .
   .
P = ADDR(A(K));

In this example, P is a pointer variable that is capable of holding the address of any variable, with the possible exception of unaligned bit strings (for more information, see your Open PL/I User's Guide). The assignment statement uses the ADDR built-in function to calculate the address of A (K) and assigns that address as the value of P.

A pointer is used with a template to access the storage to which it points. For example:

DECLARE X FIXED BINARY(15) BASED;
   .
   .
   .
P->X = 10;

In this example, X is a based variable (that is, a template) describing a fixed-point binary integer. P is the pointer variable from the example at the beginning of this section. The assignment assigns 10 to A (K).

Pointers are often used to locate the storage of dynamically allocated based variables as described in the section Based Variables in the chapter Storage Classes, but may provide a mechanism for accessing another variable's storage, as shown in the previous two examples.

The null pointer value is produced by the NULL built-in function. It is a unique value that does not address any variable and is used to indicate that a pointer variable does not currently address anything, as shown in the following example:

DECLARE CHAIN_HEAD POINTER;
   .
   .
   .
CHAIN_HEAD = NULL();

The internal representation of NULL is determined by the -setnull compiler option. For more information on compiler options, see your Open PL/I User's Guide.

Pointer values may be assigned, compared for equality or inequality, passed as arguments, and returned from functions, but no calculations or conversions can be performed on them. They cannot be transmitted in stream I/O.

If the variable whose storage is addressed by a pointer value is freed, the pointer value should no longer be used. Use of such a pointer to access the storage causes unpredictable results.

The ADDR built-in function must not be used to calculate the address of an unaligned bit data. Consequently, when such a restriction is imposed, pointer values never address unaligned bit-string data. However, all other data can always be addressed by a pointer, regardless of the addressing capabilities of the computer.

Note:

The based variable that is used as a template normally must have the same data type as the variable addressed by the pointer. Violations of this rule cause unpredictable results. Programs that violate this rule and produce "correct" results may fail when compiled with optimization enabled or may fail when moved to another implementation of PL/I.

A pointer value cannot be represented by a constant. However, the NULL built-in function can be used in any context, including an INITIAL attribute, where a constant might be desired.

Parent topic: Locator Data
Related information
Open PL/I User's Guide
Based Variables
Storage Sharing


Offset Data

The OFFSET attribute describes a locator data type that is used to specify the location of a based variable within an area. The format of the OFFSET attribute is:

OFFSET [(area-variable)]

An offset variable is a locator used only in conjunction with an area variable. The value of an offset variable specifies the location of a based variable within an area, relative to the beginning of the area. Since an offset value specifies a relative location, the value remains valid even when the area is assigned to another region of storage.

To use an offset variable to identify a particular based variable, the offset variable must be associated with an area. For example:

DECLARE A   AREA,
        O   OFFSET(A),
        X   FIXED BASED(O),
        Z   OFFSET,
        P   POINTER;

ALLOCATE X IN(A) SET(O);
X = 5;                  /* Implies area and offset */

This association can be done in the declaration by specifying the area variable, as shown in the previous example. This type of declaration has the convenience of implicitly referring to the associated area whenever a reference is made to the offset variable used as a locator.

When an offset value is assigned to or compared with another offset variable, only its actual value is used — the implicit area reference is ignored. However, when used as a locator, or when compared to or assigned to a pointer, the offset value is implicitly converted to a pointer by generating an address derived from the offset value combined with the address of the area with which it is associated. If this association was not done in the declaration, it can still be done using the POINTER built-in function:

P = POINTER(Z, A);   /* offset Z was not associated with
                           area A in its declaration */

Note that, if the offset variable did not have an area association in its declaration, then it is only with the POINTER built-in function that the offset variable can be used as a locator to address a variable within an area. For more information, see the description of the POINTER built-in function in the section POINTER in the chapter Open PL/I Built-Ins.

An OFFSET variable may be assigned a value in the following ways:

  • With the ALLOCATE statement

    For example:

    DECLARE X    FIXED BIN(31 BASED(01),
       Al    AREA,
       01    OFFSET(A1);

ALLOCATE X;     /*sets 01 = to the offset
                   of X in area A1 */

    Since the locator for X and the associated area of 01 are both specified in their respective declarations, the previous ALLOCATE statement is equivalent to:

    ALLOCATE X IN(A1) SET(01);
  • By assignment of another locator (offset or pointer) value
  • By assignment of the NULL() built-in function
  • By assignment of the OFFSET built-in function, which complements the POINTER built-in function (see the section POINTER in the chapter Open PL/I Built-Ins).
Parent topic: Locator Data
Related information
POINTER


Label Data

A label prefix on a statement, other than a PROCEDURE or FORMAT statement, is a declaration of a statement label.

The LABEL attribute can be used to declare variables and functions whose values are labels. For example:

A: PROCEDURE;
   DECLARE L LABEL;
      .
      .
      .
   L1:
      .
      .
      .
   L = L1;

In this example, the label variable L is assigned a statement label value. A subsequent GOTO L; would transfer control to the statement labeled L1.

A label value is a descriptor that consists of two parts. One part designates a statement (the instructions compiled for the statement) and the other part designates a stack frame of the block that immediately contains the statement. In the previous example, the assignment of L1 to L assigns a designator to the statement labeled L1 as part one of L, and assigns a designator to the current stack frame of procedure A as part two of L. The execution of a subsequent GOTO statement uses the stack frame designator only if the GOTO statement is executed in a block activation other than that indicated by the label value. For example:

A: PROCEDURE;
   DECLARE L LABEL;
      .
      .
      .
   L1:
      .
      .
      .
   L = L1;
      .
      .
      .
   GOTO L;
      .
      .
      .
   B: PROCEDURE;
      .
      .
      .
      GOTO L;
           .
           .
           .

In this example, execution of the first GOTO statement simply transfers control to L1 because it occurs within the same block activation in which L1 was assigned to L (and consequently, the stack frame component of L designates the stack frame that is current when the GOTO statement is executed). However, execution of the second GOTO statement occurs within a block activation other than that whose designator was assigned to L. Execution of the second GOTO statement first uses the stack frame designator of L to terminate the block activation of B and restore the block activation of A. The second GOTO statement then transfers control to the statement labeled L1. If A were a recursive procedure with more than one activation, the statement GOTO L in B would restore the most recent activation of A. Note that a label variable that is given L as a value will denote the activation of A current at the moment L is assigned, which may not be A's most recent activation. Use of a label variable after its associated block has exited may cause unpredictable results.

A single, optionally signed integer constant in the range -32768 to +32767 may be used to subscript a label. An array of labels is declared by the occurrence of subscripted labels. The elements of the array are all the subscripted labels having the same name and appearing within the same block. The highest subscript used is the upper bound of the array. The lowest subscript used is the lower bound of the array. The number of integers between the lower bound and the upper bound, inclusive, is the extent of the array. The array contains one element of each integer in the extent, although there may not be a subscripted label corresponding to the element. If you refer to an undefined element, the result is unpredictable. For example:

      GOTO CASE(K);
CASE(1):
   .
   .
   .
CASE(2):
   .
   .
   .
CASE(3):
   .
   .
   .
CASE(6):
   .
   .
   .

In this example, CASE is a one-dimensional array of statement labels containing six elements. Elements 4 and 5 are undefined and should not be used. Using an undefined element produces unpredictable results.

Label prefixes on PROCEDURE, FORMAT, BEGIN, and ENTRY statements cannot be subscripted.

Because the label array is declared by label prefixes, it cannot also be declared as a LABEL variable by appearing in a DECLARE statement.

Label values may be assigned, compared for equality or inequality, passed as arguments, and returned from functions, but no calculations or conversions can be performed on them. You may specify potential label values that can be assigned to a LABEL variable. They cannot be transmitted in stream I/O.

Parent topic: Data Types


Entry Data

Entry constants and variables are used to invoke procedures through specific entry points. Entry values specify entry points and block activations of procedures.

  • Entry Constants
  • Entry Variables
  • Entry Values
Parent topic: Data Types


Entry Constants

Entry constants are declared by labels or by PROCEDURE or ENTRY statements.

The leftmost label on a PROCEDURE statement is a declaration of the primary entry point of a procedure. Secondary entry points are established by the ENTRY statement. Names of external procedures that are not part of the compiled module must be declared using an ENTRY attribute and, if they are functions, a RETURNS attribute. For example:

DECLARE E ENTRY(FIXED BINARY(15), POINTER);
DECLARE F ENTRY((5) FLOAT DECIMAL(7))
   RETURNS(FLOAT DECIMAL(7));

In this example, E is declared as a procedure name that requires two arguments and that must be called as a subroutine by a CALL statement. F is declared as a procedure name that must be referenced as a function. F requires an array of five Float Decimal(7) values as its arguments and returns a Float Decimal(7) result.

Procedures, other than external procedures that are not part of the compiled module, are declared by their PROCEDURE statement and cannot be declared in a DECLARE statement.

Failure to declare a referenced external procedure that is part of another program module results in error messages from the Compiler.

Parent topic: Entry Data


Entry Variables

Entry variables are variables, including parameters, that take entry values.

The ENTRY attribute together with the VARIABLE attribute can be used to declare variables whose values are entry values. The ENTRY attribute can be used in a RETURNS attribute to indicate that a function returns entry values. For example:

A: PROCEDURE;
      .
      .
      .
   DECLARE E ENTRY VARIABLE;
      .
      .
      .
   E = A;

In this example, E is an entry variable that is capable of being assigned any entry value. The assignment causes the value of E to become a descriptor of the procedure named A.

Any parameter attribute or RETURNS attribute specified as part of an ENTRY attribute has no effect on the values that can be assigned to the ENTRY variable. However, when the entry variable is called, the value that it currently holds must designate a PROCEDURE statement whose parameters and RETURNS option match those given in the declaration of the entry variable.

In the previous example, a program that calls E as a function or calls E with arguments is invalid and produces unpredictable results.

Parent topic: Entry Data


Entry Values

Like a label value, an entry value is a descriptor containing two parts. The first part designates an entry point of a procedure, and the second part designates a stack frame of the block in which the procedure is declared. The second part of an ENTRY value that designates an external procedure is null.

The second part of the entry value is relevant only when there is more than one activation of a given procedure, as is the case with recursive procedures; otherwise, an entry value can be considered simply as a designator of an entry point.

Entry values can be assigned, compared for equality or inequality, passed as arguments, and returned from functions, but no calculations or conversions can be performed on them, and they cannot be transmitted in stream I/O.

The following discussion explains the second part of the entry value, called the stack frame designator.

  • The Stack Frame Designator
Parent topic: Entry Data


The Stack Frame Designator

If a procedure references variables local to its containing procedure, the inner procedure must be given a designator to the outer procedure's stack frame for it to be able to access the outer procedure's variables. The designator to the outer procedure's stack frame is the stack frame designator.

Except when the outer procedure has been activated recursively, only one stack frame for the outer procedure exists. The existing stack frame is the one that is always used when the inner procedure references variables declared in the outer procedure.

If the outer procedure has been activated recursively, the entry value used to call the inner procedure determines which stack frame is to be used when the inner procedure references the outer procedure's variables. For example:

A: PROCEDURE RECURSIVE;
   DECLARE X FIXED BINARY(15);
   DECLARE E ENTRY VARIABLE STATIC;
   IF FIRST-TIME
      THEN E=B;
      ELSE CALL F;
   CALL G;
.
.
.
B: PROCEDURE;
      .
      .
      .
      X=5;

In this example, assume that A calls G and that G calls A, then A calls F, and F calls the entry value held by E. When E is called, an activation of B results, because B was assigned to E. When that activation of B references X, two stack frames containing an instance of X exist. Two stack frames exist because two calls of A are still active. However, because the first of these two activations of A assigned B to E, E contains a designator to the first stack frame of A. Consequently, B assigns 5 to the first instance of X. If B were called directly from A, B would always use the most recent stack frame of A when referencing X.

An older stack frame is used only when an entry name is assigned to an entry variable or passed as an argument to an entry parameter. When the entry name is thus passed or assigned, the current stack frame of its containing block is assigned as the second component of the entry value produced by that assignment.

If the procedure name being assigned or passed as an argument is not declared within the block that is assigning or passing it, but is declared in a containing block, the containing block's stack frame is found using the same principle as was used to find X in the previous example. Once found, a designator to that stack frame is assigned as part two of the entry value.

Each stack frame for a block A has a designator to a stack frame of the block that contains A. That designator is the designator that was supplied as the second part of the entry value used to activate A. Unless the activation of A was the result of calling an entry variable or entry parameter, and unless recursion has been used, the stack frame thus designated is also the immediately preceding stack frame.

Parent topic: Entry Values


File Data

A file constant is represented by a file control block, which is an internal data structure maintained by Open PL/I. A file control block can be opened or closed and can thereby be connected to various files and devices known to the operating system. For example:

DECLARE F FILE;

In this example, F is a file constant that designates a file control block. That file control block can be opened, closed, and used to perform I/O on files and devices known to the operating system.

A file variable is represented internally as a longword containing a pointer to a file control block. When evaluated, the value of the file variable is the address of the associated file's control block.

A file variable is capable of being assigned any file value; it is declared using both the FILE and VARIABLE attributes. For example:

DECLARE G FILE VARIABLE;
DECLARE F FILE;
   .
   .
   .
   G = F;

In the previous example, G is a file variable assigned the value of the file constant F. After the assignment, operations on G are equivalent to operations on F because they both designate the file control block belonging to F.

File values may be assigned, compared for equality or inequality, passed as arguments, or returned from functions; however, no calculations or conversions can be performed on them, and they cannot be transmitted by stream l/o.

Parent topic: Data Types
Related information
File Constants


Arrays

An array is an ordered set of values all having the same data type. Elements of an array are referenced by their position within the array. Each array has a specified number of dimensions and each dimension has a specified lower and upper bound. The default low bound of a dimension is 1.

Array elements are stored in row-major order. The successive elements of a row are stored in adjacent memory locations. In arrays with more than two dimensions, the net effect is that when the elements are accessed in their storage order, the rightmost subscript varies most rapidly.

Examples:

DECLARE A(1:4) FIXED BINARY(15);
DECLARE B(0:3,0:5) FLOAT BINARY(21);
DECLARE C(-2:10) CHARACTER(5);
DECLARE D(25,4,2) POINTER;

In these examples, A is a one-dimensional array capable of holding fixed-point binary values. The lower bound is 1, the upper bound is 4, and the number of elements is 4.

B is a two-dimensional array capable of holding floating-point binary values. Both lower bounds are zero, and the upper bounds are 3 and 5. Therefore, B has 4 rows of 6 columns each.

C is a one-dimensional array capable of holding character-string values each of which has 5 characters. Its lower bound is -2 and its upper bound is 10, giving it a total of 13 elements.

D is a three-dimensional array capable of holding pointer values. Because no lower bounds are given, they are assumed to be 1. The array has a total of 200 elements organized as 25 planes, each of which is 4 rows in length and 2 columns in width.

The maximum number of array dimensions is 8. An array bound may be any number in the range -2^31 to 2^31 -1. Array bounds are also subject to the following restrictions:

  • The lower bound must be less than or equal to the upper bound.
  • The value (upper bound — lower bound) must be less than 2^31 -1.
  • The total size of the array must be less than 2^31 bytes. For information on calculating the size of an individual array element, see your Open PL/I User's Guide.
Note: The particular implementation of PL/I or the underlying operating system may also impose restrictions on the size of an individual data item, or on the total sizes of static and/or automatic data regions. For more information, see your Open PL/I User's Guide.

The bounds of AUTOMATIC, DEFINED, CONTROLLED, or BASED arrays may be specified by integer-valued expressions, as explained in the chapter Storage Classes. The bounds of STATIC arrays must be integer constants. The bounds of parameter arrays can be either integer constants or an asterisk (*). If an asterisk is given as the bound of a parameter array, it represents both the lower and upper bound and means that the actual bounds of the corresponding array argument are to be used as the bounds of the array parameter. For example:

DECLARE A(0:5) FIXED BINARY;
CALL P(A);
   .
   .
   .
P: PROCEDURE(X);
   DECLARE X(*) FIXED BINARY;
      .
      .
      .

During the call of P in the previous example, the bounds of X are (0:5), and any reference to X is a reference to A.

The elements of an array are referenced using as many subscripts as the array has dimensions. For example:

DECLARE A(-2:5,4,3) FIXED BINARY;

In this example, a reference to A (-2 ,1,1) is a reference to the element in the first column of the first row in the first plane. A reference to A (3,2,1) is a reference to the element in the first column of the second row in the sixth plane.

A subscript of an array must be an integer valued expression. The use of fixed-point fractions or floating-point values as subscripts results in an error message from the Compiler. However, such values can be converted to integer values by use of the TRUNC, CEIL, FLOOR, or ROUND built-in functions.

Each subscript must lie within the range specified by its corresponding lower and upper bound. Unless subscript range checking has been requested, the Compiler does not produce code to check the range of subscript values. If checking is requested, any subscript that exceeds its range results in a signal of the ERROR condition.

Subscripted references to array elements can be used in any context that permits a variable reference.

A cross-section of an array may be referenced by using an asterisk as a subscript. The asterisk refers to the entire range of the corresponding dimension (lower bound through upper bound). In the previous example, a reference to A (*,1,1), refers to the first-row, first-column elements in all eight planes. A reference to A ( *, *,*), refers to all 96 elements of the array.

Array cross-sections may be transmitted in stream or record I/O, passed as arguments, and assigned to other arrays of the same size and shape.

Parent topic: Data Types
Related information
Storage Classes


Structures

A structure is a hierarchically ordered set of values that may be of different data types. The immediate components of a structure are called members of the structure. A structure that is itself a member of another structure is called a substructure. A structure that is not a substructure is called a major structure.

The hierarchical organization of a structure is specified by using level-numbers, as shown in the following example:

DECLARE 1 S,
      2 A FIXED BINARY,
      2 B FLOAT BINARY,
      2 T,
            3 P POINTER,
            3 Q CHARACTER(10);

In this example, S is a major structure, also called a level-one structure. All major structures must have a level-number of 1. The members of S are A, B, and T. T is a substructure with members P and Q.

Members normally have a level-number that is 1 greater than their containing structure; however, they may be given any level-number that is greater than the level-number of their containing structure and less than the level-numbers they contain. For example:

DECLARE 1 S,
      20 A FIXED BINARY,
      20 B FLOAT BINARY,
      20 T,
            30 P POINTER,
            30 Q CHARACTER(10);

The structure shown in this example is equivalent to the structure shown in the example immediately preceding it.

An entire structure may be transmitted in stream or record I/O, passed as an argument, or assigned to another structure of identical size and shape and having members of corresponding identical data types, but no conversions or calculations can be performed on entire structures.

If a structure contains one or more members with a variable size, place all such members at the end of the structure following all the members with a fixed size. This placement improves the addressing of the fixed size members.

Members of structures can be referenced in any context that permits a reference to a variable. If a member's name is not otherwise declared in the same scope (that is, in the same block or containing block), the member may be referenced by its name alone.

The name of a member must be unique within its immediately containing structure, but may be used as the name of members of other structures or as the name of a nonmember. If a member's name has been used for more than one object, each reference to the member must be sufficiently qualified by the names of its containing structures to uniquely identify the intended member. In a qualified reference, the names used are listed in their hierarchical order, separated by periods. For example:

DECLARE        A FIXED BINARY;
DECLARE        1 S,
                  2 A FLOAT BINARY,
                  2 T,
                     3 A POINTER;

In this example, a reference to A is a reference to the fixed-point variable. A reference to S.A is a reference to the floating-point variable. A reference to T.A or S.T.A is a reference to the pointer variable.

Use of the major structure name as a qualifier is recommended. It is also advisable to avoid using the same member name more than once anywhere within the major structure or any contained structures. For more information, see the section Reference Resolution in the chapter References.

A structure may have the UNION attribute applied to it, which causes all immediate members of that structure to occupy the same memory locations. For more information, see the chapter Declarations and Attributes.

Parent topic: Data Types
Related information
Reference Resolution
Declarations and Attributes


Arrays of Structures

Structures, like other variables, can be declared as arrays and can contain arrays as members. For example:

DECLARE 1 S(5),
      2 A FIXED BINARY,
      2 B(4) FLOAT BINARY,
      2 T(3),
            3 P POINTER,
            3 Q(6) CHARACTER(10);

In this example, S is an array of 5 structures. Each structure contains a fixed- point member followed by an array of 4 floating-point values, followed by an array of 3 substructures. Each substructure contains a pointer variable followed by an array of 6 character-string variables. The entire structure contains 5 occurrences of A, 20 occurrences of B, 15 occurrences of T, 15 occurrences of P, and 90 occurrences of Q.

Each member of a structure array is itself an array because there exist as many instances of the member as there are elements in the structure array. If a member is an array in its own right because it has its own dimension information (as do B, T, and Q in the previous example), the array inherits the additional dimensions from its containing structures. For instance, in the previous example, Q is a three-dimensional array whose bounds are (5,3,6).

Any member of a dimensioned structure is an array and must be referenced using a subscript for each of its dimensions. The subscripts may be written anywhere within the structure-qualified reference, but it is preferable to write each subscript immediately following the name to which it applies. Using the previous example to illustrate this recommended programming practice:

S(K) .A | is a reference to the Kth element of A
S(K) .B(J) | is equivalent to B (K, J)
S(K) .T(J) .Q(I) | is equivalent to S.T.Q (K, J, I) or S.T(K,J) .Q(I) or S(K,J, I) .T.Q,

It is not possible to use an asterisk to reference an entire extent (cross section) of a structure array.

Members of dimensioned structures can be used only as arrays in stream I/O and as arguments to array parameters whose bounds have been specified as asterisks. They cannot be assigned, used in record I/O, used in ADDR or DEFINED, or passed to parameters with constant bounds.

Subscripted references to members of dimensioned structures can be used in any context that permits a variable reference.

Parent topic: Data Types


Data Size and Alignment

Refer to your Open PL/I User's Guide for the size and alignment of each Open PL/I data type.

Data not contained in a structure or array is allocated on a word or double word boundary, except for Character(1) and Bit(1) aligned data, which is allocated on a byte boundary.

  • ALIGNED and UNALIGNED Attributes
Parent topic: Data Types
Related information
Open PL/I User's Guide


ALIGNED and UNALIGNED Attributes

ALIGNED and UNALIGNED are optional data type attributes that control the storage boundary of data.

ALIGNED allows the Compiler to align the data on an implementation-defined storage boundary, with the possible side effect that more bits of storage are used than specified by the declared length. (Refer to your Open PL/I User's Guide for more information.)

UNALIGNED allows the Compiler to align the data on the next byte boundary (or, in the case of fixed-length bit strings, the next bit) rather than on implementation-defined storage boundaries. This can reduce storage requirements.

ALIGNED or UNALIGNED can be specified for scalar, array, or structure variables. The application of either attribute to a structure is equivalent to applying the attribute to all contained elements that do not have explicit alignment declaration. Operations on ALIGNED data tend to be more efficient; operations on UNALIGNED data usually are slower. They are considered part of the data type for purposes of argument/parameter matching and storage sharing.

The UNALIGNED attribute is the default for character and bit data types, while ALIGNED is the default for all other data types.

The UNALIGNED attribute has no effect with an AREA variable, which is always aligned on an 8-byte boundary.

Parent topic: Data Size and Alignment
Related information
Parameter Storage Class
Storage Sharing
Bit-String Data


Storage Classes

  • Introduction
  • Automatic Storage
  • Static Storage
  • Based Variables
  • Controlled Variables
  • Defined Variables
  • Parameter Storage Class
  • Storage Sharing
Parent topic: Open PL/I Language Reference Manual


Introduction

Every variable has a storage class that determines how and when storage is allocated for it. A variable's storage class specifically determines whether storage will be allocated for it at compile time or dynamically during program execution.

Storage classes are declared for all variables, except those used as parameters, using one of the following attributes:

  • AUTOMATIC
  • STATIC
  • BASED
  • CONTROLLED
  • DEFINED

If no storage class is specified for a variable declared in a procedure, other than a parameter variable, the default is AUTOMATIC. If a variable is declared outside the scope of all external procedures in a source module, the default storage class is STATIC.

A parameter shares storage with its argument. As such, the storage class is ultimately determined by that of the associated argument. For convenience, a parameter may be considered to have a distinct "parameter" storage class.

A variable's storage size is determined by its extents. A string variable's extent is its declared length. An array variable's extents are determined from the number of its dimensions and the range of its subscript bounds. The extents of both types of variables are evaluated when storage is allocated for the variable. The permitted forms for extents differ for each storage class and are described during the discussions of each storage class.

Parent topic: Storage Classes


Automatic Storage

Storage for an automatic variable is allocated with each activation of the procedure or the BEGIN block in which the variable is declared. Storage is allocated within the stack frame that represents that block activation. If a block is activated recursively, each of its stack frames contains a distinct instance of all automatic variables declared in that block.

When a block activation ends, its stack frame is popped from the stack, thereby freeing the storage of all automatic variables allocated within it. This phenomenon normally occurs when a procedure returns to its caller or when a BEGIN block executes its END statement; however, it also occurs when a GOTO statement transfers control back to a previous block activation. In the latter case, all block activations between the one to which control is transferred and the one in which the GOTO was executed are ended. Their stack frames are popped from the stack, releasing the storage for all of their automatic variables. The INITIAL attribute can be specified in the declaration of an automatic variable to initialize the variable.

Extents of automatic character string and array variables may be specified as integer valued expressions, provided these do not contain references to other non-static variables declared in the same block. Extent expressions for these automatic variables are evaluated each time the containing block is activated. The extent expression values are saved in the stack frame and effectively fix the size of the automatic variable for that block activation. Subsequent assignment to a variable used as an extent does not affect the size of the associated automatic variable. For example:

DECLARE STRING_SIZE FIXED;
   .
   .
   .
COPY: BEGIN;
DECLARE TEXT CHARACTER(STRING_SIZE);

When the BEGIN block in this example is activated, the extent of TEXT is evaluated. The variable is allocated storage depending on the value of STRING_SIZE, which must be a valid integer value. For example:

DECLARE A(N) FIXED;
   .
   .
   .
N = 10; /* WILL NOT AFFECT THE SIZE OF ARRAY A */

In this example, the size of A is determined upon entry to the containing block by evaluating N and storing its value in the stack frame. The assignment to N does not change the size of A. Upon entry to the block, N must have a correct value and must not be a non-static variable declared in this block. Use of the HBOUND built-in function within this block activation would return the original value of N that was saved in the stack frame.

Parent topic: Storage Classes
Related information
INITIAL
HBOUND Function


Static Storage

Storage for a static variable is allocated by the Compiler and/or linker prior to program execution. Storage remains allocated throughout program execution.

Only one instance of a static variable's storage is allocated, regardless of whether the variable is declared in a recursive procedure. Values assigned to a static variable are retained between calls to the procedure in which the variable is declared.

All extents specified for static character string, 8-bit area variables, and array variables must be constants.

Static variables can be declared with the INTERNAL or EXTERNAL attribute. If neither attribute is specified, INTERNAL is assumed.

An internal static variable is known in its containing block and in all contained blocks, except those blocks in which the same name is redeclared. This is the normal scope rule that applies to all other variables.

An external static variable is known in its containing block and in all contained blocks, except those blocks in which the same name is redeclared. However, all declarations of the same name that have the EXTERNAL attribute, including those in separate modules of the program, share the same storage and must specify identical attributes, including any initial values. External static variables are known and shared by all program modules in a manner similar to the common variables of FORTRAN, except that each external static variable is shared independently of others.

Parent topic: Storage Classes
Related information
INTERNAL
EXTERNAL


Based Variables

The BASED attribute defines a template for storage that will be accessed through the use of a locator. A based variable differs from all other variables in the sense that it is a description of storage, but does not have storage of its own. Since it has no storage, it has no address. For example:

DECLARE X CHARACTER(30) BASED;
DECLARE P POINTER;
   .
   .
   .
P->X = 'ABC';

In this example, assume that an address or pointer value has been assigned to P. The reference P–>X is called a pointer qualified reference, and it enables assignment to the storage addressed by P as if that storage contained a character-string variable like X.

A pointer value can be obtained in two primary ways: from the address of a variable's storage as calculated and returned by the ADDR built-in function, or from the address of storage obtained dynamically by the ALLOCATE statement. For example:

DECLARE K FIXED BINARY(15);
DECLARE X(5) FLOAT BINARY;
DECLARE Y FLOAT BINARY BASED;
DECLARE P POINTER;
   .
   .
   .
P = ADDR(X(K));
P->Y = 10;

In this example, P is assigned the address of X (K) , which is returned by the ADDR built-in function. The second assignment places the value 10 in the storage location given by P in a manner prescribed by the template Y, effectively assigning 10 to X (K) .

A third way to obtain a pointer value is with the POINTER built-in function, which may be used to convert an area offset value to a pointer.

The indiscriminate use of pointers to access the storage of other variables should be discouraged because of the possibilities of unexpected assignment side effects and because the excessive use of pointers makes a program hard to read. Please also note that no checking is performed to ensure that the based variable provides a data description compatible with the declaration of the reference storage. For instance, the statement P–>Y = 10 might produce undesirable results if Y were declared as a data type incompatible with the data type of elements in X. For a discussion of storage sharing using based variables, see the section Storage Sharing.

The ALLOCATE statement uses a based variable to allocate a block of storage that can later be accessed by a based variable together with the locator returned by the ALLOCATE statement. For example:

DECLARE P POINTER;
DECLARE X(C,N) CHAR BASED(P);
N = 10;
C = 10;
ALLOCATE X SET(P);
   .
   .
   .
P -> X(10,5) = 'A';

In the preceding example, the ALLOCATE statement allocates a storage block of sufficient size to hold a two-dimensional array of 100 one-byte character values and assigns a pointer to that block of storage to P . P–>X thereafter is a reference to that block of storage as an array of 100 one-byte character values.

Based variables can be subscripted just like any other variable. Referring again to the previous example, the statement P–> X (10,5) = ' A' assigns the character 'A' to the element in row 10 and column 5 of the array qualified by P. Since the pointer variable may also be an array, it too can be subscripted. For example:

DECLARE P(3) POINTER;
DECLARE X(10) FLOAT BASED;
   .
   .
   .
ALLOCATE X SET(P(K));

In the preceding example, P (K)–>X refers to the entire array of ten floating-point elements qualified by the Kth pointer element of P. Likewise, P (K) –>X (J) refers to the Jth element of the floating-point array qualified by the Kth element of pointer array P.

The ALLOCATE statement is the only context in which a based variable can be used without an explicit or implicit locator qualifier. In this context, the based variable is used to describe how much storage is to be allocated.

Implicit locator qualification is a shorthand notation that can be used in cases where many of the references to a based variable use the same pointer. For example:

DECLARE X(10) FLOAT BASED(P);
DECLARE P POINTER;
   .
   .
   .
ALLOCATE X SET(P);

Because X was declared to be based on P in the previous example, unqualified references to X such as X (K) , X (5), or X are implicitly qualified by P and are equivalent to P–>X (K) , P–>X (5) , and P–>X. Any explicit qualification, such as Q–>X, may be used to temporarily override the implicit qualification and is unaffected by the specification of P in BASED (P) .

The extents of a based variable may be specified as integer valued expressions. The extents are evaluated for each allocation of the variable and for each reference of the variable. The extents are not captured when storage is allocated by an ALLOCATE statement. The extent expression can reference variables declared in the same block, as long as those variables have a value before the based variable is referenced. Changing the value of a variable referenced by an extent expression changes the extent of the based variable. For example:

DECLARE X(N) CHARACTER(1) BASED;

N = 10;
ALLOCATE X SET(P);
   .
   .
   .
N = M;
P->X(5) = 'A';

In this example, the ALLOCATE statement allocates an array of ten elements. The value of M must be greater than or equal to five and less than or equal to ten; otherwise, the reference to P–>x (5) is invalid and may cause unpredictable results.

A block of storage previously allocated by an ALLOCATE statement can be freed by a FREE statement. For example:

FREE P->X;

Once freed, the storage can no longer be accessed, and any attempt to use a pointer such as P that points to the block produces unpredictable results.

Note:

The storage obtained by an ALLOCATE statement is freed only by an explicit FREE. If a program continually allocates memory without freeing it, the program may run out of space at run-time.

Used with the ALLOCATE statement, based variables are powerful tools for applications in which the size of arrays or strings is not known at block entry and must be determined at run-time. Based variable allocations also supply a means for the dynamic creation of graph structure nodes (which may be linked by pointers to produce list and tree structures). See the example of a based structure in the section Block Activation and Recursion.

It is desirable to restrict the extent of based variables to constant values whenever possible to avoid unexpected side effects and to improve program readability. If the extent must be variable, it is preferable to avoid the use of extent expressions when declaring based variables for the same reasons. The size of the based variable is evaluated for each reference to the variable.

Parent topic: Storage Classes
Related information
POINTER Function
Storage Sharing
Block Activation and Recursion


Controlled Variables

The CONTROLLED attribute specifies a variable whose storage is dynamically allocated and freed in generations, independent of block boundaries. Controlled variables are allocated only when specified in an ALLOCATE statement. After being allocated, a controlled variable remains allocated until a FREE statement names the variable.

A reference to a controlled variable refers to the generation of the variable created by the most recent ALLOCATE statement. The FREE statement frees the most recent generation of the controlled variable, exposing the previous generation. For example:

DECLARE STACK (STACK_ITEM_SIZE) CHAR(32) CTL;
DECLARE STACK_ITEM_SIZE FIXED BIN;
DECLARE I FIXED BIN;

   /* Push a first stack item. */
   STACK_ITEM_SIZE = 4;
   ALLOCATE STACK;

   DO I = 1 TO STACK_ITEM_SIZE;
      STACK(I) = CHAR(I) || '_1';
   END;

   /* Push a second stack item. */
   STACK_ITEM_SIZE = 3;
   ALLOCATE STACK;

   DO I = 1 TO STACK_ITEM_SIZE;
      STACK(I) = CHAR(I) || '_2';
   END;

   PUT SKIP LIST ('Print second item on the stack');
   PUT SKIP LIST (STACK);

   /* Pop the last element on the stack. */
   FREE STACK;

   PUT SKIP LIST ('Print first item on the stack');
   PUT SKIP LIST (STACK);

   /* Pop the last element on the stack.
      The stack is empty now. */
   FREE STACK;

CONTROLLED variables can be declared with asterisk (*) extents, and when such a variable is allocated, its extents can be made explicit by the use of the ALLOCATE statement with specified attributes. CONTROLLED variables can also be declared with explicit extents (constant or variable), and these explicit extents can be overridden by use of the ALLOCATE statement with specified attributes.

It is also possible to specify attributes with asterisk extents in the ALLOCATE statement. This causes the extents to be copied from the corresponding extents used for the previous allocation of the same CONTROLLED variable. If an asterisk is specified in the ALLOCATE statement for one dimension of a variable, it must be specified for all dimensions of that variable.

If level numbers are specified, the first variable in the ALLOCATE statement must be specified with a level-num of 1 and be declared as a level-1 structure, and in this case, all members of the structure must be included in the ALLOCATE statement just as they appear in the declaration of the structure.

Any bound, length, size, or initial value specified in the ALLOCATE statement overrides the corresponding attribute specified in the declaration of the variable. A bound, length, or size can be specified in the ALLOCATE statement with an asterisk, and, in this case, the bound, length, or size is taken from the current generation of that CONTROLLED variable. If a bound, length, size, or initial value specified in the ALLOCATE statement contains a reference to the variable being allocated, the reference is to the current generation of the variable.

Evaluations of expressions for bounds, lengths, sizes, and initial values during the execution of the ALLOCATE statement are done according to the normal rules for PL/I references, and must be capable of logical execution (that is, without circularity). Evaluations depending on the existence of a prior generation of a variable require that that generation has previously been allocated.

Controlled variables provide an easy way to implement a stack, because only the most recent generation is available to the program. The ALLOCATE statement is equivalent to a push operation and the FREE statement is equivalent to a pop operation. The ALLOCATION built-in function is used to determine the number of generations of a controlled variable that are available.

Examples

DECLARE 1 A CONTROLLED,
     2 B CHAR(*),
     2 C CHAR(20),
     2 D(2) FIXED BIN(31),
     2 E(4,4) CHAR(*),
     2 F FIXED BIN(31);
...
ALLOCATE 1 A, 2 B CHAR(12), 2 C, 2 D(6), 2 E CHAR(3), 2 F INIT(128);
...
ALLOCATE 1 A, 2 B CHAR(12), 2 C CHAR(10), 2 D(D(1)), 2 E CHAR(3), 2 F;

In this example, the structure A is first allocated with member B of length 12, with array member D with dimension (6) instead of the declared (2), array member E with its declared dimensions of (4,4) and element lengths of 3, and member F with an initial value of 128. The second generation of A is allocated with member C of length only 10 and with the dimension of array member D the value contained in the first generation of A.D(1).

DECLARE X(*,*) CONTROLLED;
ALLOCATE X(3,7);
ALLOCATE X(*,*);

In the second allocation of array X, the bounds are implicitly (3,7), as derived from the previous allocation.

For CONTROLLED parameters, CONTROLLED must be explicitly stated in the parameter descriptor for the ENTRY declaration. This is required by the PL/I language specification. For example, if you compile and link together the following two procedures:

t.pl1
 TSTENTM: PROC OPTIONS(MAIN);

   DCL   N  CHAR(10) CONTROLLED;

   DCL  TSTENT ENTRY(CHAR(10));

   ALLOCATE N;
   N = 'CONTROLLED';

   CALL TSTENT(N);
 END;

t1.pl1
 TSTENT:  PROC(N);
   DCL   N  CHAR(10) CONTROLLED;
   PUT SKIP LIST ('N = ',N);
   RETURN;
 END;

Upon execution you will get:

*** Condition ERROR raised
*** Unhandled condition SIGSEGV at PC=004011AE
N =

To avoid this, add the controlled attribute to the ENTRY declaration:

DCL  TSTENT ENTRY(CHAR(10)CTL);
Parent topic: Storage Classes


Defined Variables

A defined variable is one for which no storage is allocated. Instead, the variable shares the storage of a specified basis variable.

A defined variable is declared with the DEFINED attribute, which also specifies the basis variable. Any reference to the defined variable is a reference to all or part of the storage of the basis variable.

When the declaration of a variable includes the DEFINED attribute, that variable's description applies to the storage associated with the basis variable. For example:

DECLARE A(5) CHARACTER(1);
DECLARE X CHARACTER(5) DEFINED(A);

In this example, X is a defined character-string variable of length 5. X shares storage with, and is an alternate description of, the array A. Similarly, the following statement:

X = 'abcde';

assigns 'a' to A (1) , 'b' to A(2), and so on.

The extents of a defined variable can be integer valued expressions. They are evaluated upon block entry and stored in the stack frame just like the extents of automatic variables. Such an extent expression must not contain a reference to any non-static variable declared in the same block.

For additional information on defined variables, see the section Storage Sharing, which discusses the rules for giving alternate descriptions of storage.

Parent topic: Storage Classes
Related information
Storage Sharing


Parameter Storage Class

A parameter shares storage with its argument. As such, the storage class is ultimately determined by that of the associated argument. Technically, the parameter variable itself is an AUTOMATIC variable containing the address of the corresponding argument. For convenience, a parameter may be considered to have a distinct "parameter" storage class. For example:

DECLARE X FLOAT;
CALL P (X);
   .
   .
   .
P: PROCEDURE (Y);
      DECLARE Y FLOAT;

In this example, X is an argument and Y is a parameter variable. A parameter variable is declared within a procedure declaration and receives a value when that procedure is invoked. Simple Open PL/I variable arguments are passed by reference.

A parameter has a data type, perhaps a data type with extents, and in the simplest case, an argument passed to the parameter will have the same data type and extents as the parameter. If this is not the case, Open PL/I will, whenever possible, convert the argument to a value with the same data type and extents as the parameter and pass that value to the parameter.

In the absence of specifications to the contrary, when a variable is passed as an argument to a parameter with matching data type and extents, the argument is passed "by reference." This means that it is the address of the actual variable itself that is passed as the argument, and the parameter is sharing storage with this variable. Hence, any assignment to the parameter is actually changing the argument variable itself.

In other cases — that is, when the argument is a variable whose data type and extents do not match the parameter, or when the argument is an expression, a constant, a function reference, or a simple variable enclosed in parentheses — the argument is passed "by value." This means that the value of the 'argument is converted as described above and stored in a temporary location. It is the address of this temporary location that is passed as the argument. Hence, any assignment to the parameter can have no effect on any variable in the calling procedure.

The precision of arithmetic data is part of its data type. This means that a Float Decimal(7) variable cannot be passed by reference to anything except a Float Decimal(7) parameter. The VARYING and ALIGNED attributes, as well as the declared string length, are part of a string variable's data type and must match those of the corresponding parameter for the parameter to share storage with the actual argument (true pass-by-reference). A picture variable can be passed by reference only if the corresponding parameter has an identical picture. The ALIGNED and UNALIGNED attributes of non-string arguments and parameters must match.

The VALUE attribute is an argument-passing attribute that indicates that the value and not the address of the parameter has been passed to the procedure.

An array parameter with constant extents can be passed only those array arguments that have identical constant extents and an identical data type. A parameter structure can be passed only a structure or substructure of identical size, shape, and component data types. Array or structure arguments cannot be passed by value.

The ANY attribute is an argument-passing attribute that specifies, for a parameter, that the corresponding argument can be of any data type.

A procedure that has a character or bit-string parameter with a constant length may be called with string arguments of variable length or differing constant length. Since all such arguments are passed by value, they are effectively converted to the length of the parameter. For example:

CALL P(A,(B));

In this example, A is passed by reference if it matches its corresponding parameter and is passed by value if it does not. B is always passed by value.

If the argument is an expression, function reference, built-in function reference, constant, parenthetical variable reference, or a reference to a variable whose data type does not match that of the parameter, the argument is copied to a temporary block of storage in the caller's stack frame and is said to be passed by value. The value of the variable in the caller will not be modified if it is passed by value. Actually, the address of the temporary is passed, and the parameter shares the storage allocated to the temporary.

The extents of a parameter can be either integer constants or asterisks (*). If the parameter's extents are integer constants, any argument to be passed by reference must have identical constant extents. If the parameter's extents are asterisks, its corresponding argument may have extents of any value. In the latter case, the extents of the parameter are those of its corresponding argument. For example:

DECLARE A(10) FLOAT;
DECLARE B(25) FLOAT;
   .
   .
   .
CALL P(A);
   .
   .
   .
CALL P(B);
   .
   .
   .
P: PROCEDURE(X);
   DECLARE X(*) FLOAT;

During the first call in this example, the extents of X are (1:10). During the second call, they are (1:25).

Parent topic: Storage Classes
Related information
Value
ANY


Storage Sharing

Open PL/I provides two storage classes that are explicitly designed to permit storage locations to be shared by several variables. These storage classes are BASED and DEFINED. (Use of the UNION attribute also allows variables to explicitly share storage.)

Based variables are allocated no storage when they are declared. Instead, they serve to determine storage to be allocated by an ALLOCATE statement or to describe storage qualified by a pointer reference.

Defined variables use the storage of a specified basis variable. A defined variable is declared with the DEFINED attribute, which also specifies the basis variable.

A defined variable and its basis reference must satisfy one of the following criteria in order to share storage:

  1. All variables sharing storage have identical data types.
  2. All variables sharing storage are nonvarying character strings and therefore are suitable for character-string overlay defining.
  3. All variables sharing storage are unaligned bit strings and therefore are suitable for bit-string overlay defining.

A variable is suitable for overlay defining if it consists entirely of characters or bits that are packed into adjacent storage without gaps. (Gaps can be caused by the alignment of data in user-defined structures.)Variables suited for overlay defining are arrays, structures containing only the required type of string data, or scalar string variables. For example:

DECLARE X(4,4) CHARACTER(1);
DECLARE Y(16) CHARACTER(1) DEFINED(X);
DECLARE Z CHARACTER(5) DEFINED(X);
DECLARE 1 S BASED,
   2 A CHARACTER(8),
   2 B CHARACTER(8);

In this example, X has a block of storage containing 16 characters. The entire block is shared by Y, but Z shares only the first 5 characters of the block. S could be used to access all 16 characters, while S.A could be used to access the first 8, and S.B could be used to access the last 8. A based character string of more than 16 characters would produce undefined results, but a string of 16 or fewer characters could be used. A similar example could be constructed using all unaligned bit data.

Storage sharing of other data types requires that the data types match exactly, but an element of an array can be shared with a nonarray variable of the same data type. Similarly, a member of a structure can be shared with a nonmember of the same data type.

Members of structures that have the attribute UNION also share physical storage locations with one another. A UNION is a variation of a structure in which all immediate members occupy the same physical storage location. Unions provide capabilities similar to those of defined variables. The UNION attribute, which can be used only in conjunction with a level number in a structure declaration, signifies that all immediate members of the major or minor designated structure occupy the same storage. An immediate member is any member having a level number greater than its containing structure but not greater than the level number of its fellow members. Typically, an immediate member has a level number that is one greater than its containing structure. (For more information on this attribute, see the section Union.)

Arrays can share storage with other arrays only if they have the same data type and/or are equivalent left-to-right. Structures can share storage with other structures only if they are equivalent, left-to-right, to the structure whose storage is being shared.

Left-to-right equivalence means that the sharing structures must be valid descriptions of the left part of the storage being shared. To be a valid description of the left part of storage, the sharing structures must have identical members up to and including all members contained anywhere within the last level-two item being shared. If any part of a level-two item is to be shared, all of it must be shared. For example:

DECLARE   1 S,  DECLARE  1 T BASED,  DECLARE  1 U BASED,
          2 A,           2 A,                 2 A,
          2 B,           2 B,                 2 B,
          3 C,           3 C,                 3 C;
          3 D;           3 D;
          2 E;

In this example, a reference to T.B.C is a valid reference to S.B.C, but a reference to U.B.C is not valid, because the declaration of U does not describe the entire level-two item S.B.

A picture variable can share storage only with other picture variables that have identical pictures.

As is the case for argument/parameter matching, the ALIGNED, UNALIGNED, and VARYING attributes and the declared length of a string variable are part of its data type and must match, unless the strings qualify for string overlay sharing.

The base, scale, and precision of arithmetic variables must always match if they are to share storage.

Parent topic: Storage Classes
Related information
Union


Declarations and Attributes

  • Introduction
  • Label Prefixes
  • DECLARE Statements
  • Attributes of DECLARE Statements
Parent topic: Open PL/I Language Reference Manual


Introduction

All variables in an Open PL/I program (except those under the control of the DEFAULT statement) must be declared. Each name, except the name of a built-in function, must be declared using a DECLARE statement (or if it is a label, by using the label as a statement prefix).

Each declaration is associated with a scope or region of the program in which a reference to the associated name is valid. The scope of a declaration includes the block in which it is declared and all nested blocks, except those in which the name has been redeclared.

Identifier attributes used in DECLARE statements are specified by either keyword or syntax. A name declared with the EXTERNAL attribute has the same scope rule as any other name, except that the object identified by that name is unique throughout the entire program. All declarations of a given name that have the EXTERNAL attribute identify the same object. Only files, static variables, and names of external procedures can have the EXTERNAL attribute. Files and procedures acquire the attribute by default, but static variables have internal scope unless they are explicitly declared with the EXTERNAL attribute.

A given name cannot be declared more than once within the same block, unless it is declared as the name of a structure member. In that case, the name may be redeclared within the same block, provided no two members at the same level of the same structure have the same name. (See the section Scope.)

Parent topic: Declarations and Attributes
Related information
Scope


Label Prefixes

A label prefix declares a name as a procedure name, format name, or statement label, depending on the type of statement to which the prefix is attached.

A label prefix on a PROCEDURE statement declares a name as a procedure name. The name is declared in the block that contains the PROCEDURE statement, and its scope is that containing block and all blocks contained by the procedure. The declaration lists each parameter referenced by the PROCEDURE statement, as well as the data type specified by any RETURNS option in the PROCEDURE statement. For example:

E: PROCEDURE(A,B) RETURNS(POINTER);
   DECLARE A FIXED BINARY;
   DECLARE B FLOAT DECIMAL;

In this example, E is declared as a procedure name in the block that contains the PROCEDURE statement. The attributes of that declaration are RETURNS(pointer) and ENTRY(fixed binary, float decimal).

The label prefix on a FORMAT statement declares a name as a format name. The name is declared in the block that contains the FORMAT statement and all contained blocks. A format name is not a statement label and cannot be used in a GOTO statement. A format name can be used only in a format statement.

The label prefix of a PROCEDURE or FORMAT statement cannot be sub- scripted.

A label prefix attached to statements other than PROCEDURE or FORMAT statements declares a name as a statement label. The declaration is established in the block that contains the statement to which the prefix is attached. For example, a label prefix attached to a BEGIN statement is declared in the block that contains the BEGIN statement and its scope is that containing block and all blocks contained by the BEGIN statement.

The label prefix of a PROCEDURE or FORMAT statement cannot be sub- scripted; however, label prefixes attached to statements other than PROCEDURE or FORMAT may be subscripted by a single optionally signed integer constant. Within its scope, all occurrences of a given name used in this manner must be subscripted, and all such prefixes collectively constitute a declaration of the name as an array of statement labels. For example:

   GOTO CASE(K);
CASE(1):
   .
   .
   .
CASE(2):
   .
   .
   .
CASE(3):
   .
   .
   .
CASE(6):
   .
   .
   .

In this example, CASE is declared as an array of statement labels whose bounds are (1:6) and whose fourth and fifth elements are undefined. Defining arrays with undefined elements is not recommended, as it produces unpredictable results.

An array of statement labels cannot be used as an array value, but its elements can be used in any context that permits a statement label.

Procedure names, format names, and statement labels cannot be declared in a DECLARE statement in the same block, except that the names may be used as the structure member names.

Names of external procedures that are part of another program module must be declared by a DECLARE statement if they are to be referenced by the current program module. (For more information, see the section Modules.) Only external procedure names can be declared by a DECLARE statement.

Parent topic: Declarations and Attributes
Related information
FORMAT
Modules


DECLARE Statements

A DECLARE statement declares one or more names by giving the attributes or properties of the named objects. A DECLARE statement is not an executable statement. It may appear as a part of a WHEN or OTHERWISE clause in a SELECT statement; anywhere within a procedure or BEGIN block, except as the THEN clause or ELSE clause of an IF statement; or as an ON-unit of an ON statement.

For the sake of readability, all DECLARE statements belonging to a given block should be placed at the beginning of that block, rather than among the executable statements.

  • Recommended Forms
  • The General Form
  • Defaults
  • Attribute Consistency
Parent topic: Declarations and Attributes


Recommended Forms

This section describes the recommended forms of the DECLARE statement within the following statement categories: simple declarations, factored declarations, and structure declarations.

  • Simple Declarations
  • Factored Declarations
  • Structure Declarations
Parent topic: DECLARE Statements


Simple Declarations

A simple declaration defines a single name and describes its attributes. Its recommended form is:

DECLARE name a?1 a?2 a?n;

where name is the declared name and a1 through an are attributes. For example:

DECLARE A FIXED BINARY(15);
DECLARE B CHARACTER(10) VARYING STATIC INITIAL('ABC');
DECLARE C DIMENSION(5) FLOAT DECIMAL(7);

The last statement in this example could also be given without the keyword DIMENSION by using the following format:

DECLARE C(5) FLOAT DECIMAL(7);
Parent topic: Recommended Forms


Factored Declarations

Factored declarations define two or more names having the same attributes. The recommended form of a factored declaration is:

DECLARE (name-1[,name-2]…)a?1 a?2…a?n;

where each name is declared to have all of the attributes a?1 through a?n. In factored declarations, the names must be enclosed in parentheses.

Examples:

DECLARE (A,B,C) FIXED BINARY(15);
DECLARE (P,Q) POINTER STATIC INITIAL(NULL);
DECLARE (X,Y)(5) FLOAT DECIMAL(7);

The last example is equivalent to the following statement:

DECLARE (X,Y) DIMENSION(5) FLOAT DECIMAL(7);

The bounds must be the first attribute in an attribute list if they appear without the DIMENSION keyword.

Parent topic: Recommended Forms


Structure Declarations

The declaration of a structure defines the organization of the structure and the names of members at each level of the structure. The general form of this declaration is:

DECLARE 1 structure_name a?1 a?2 … a?n,
       k member_name-1 a?1 a?2 … a?n,
       k member_name-2 a?1 a?2 …. a?n,
           .
           .
           .
       k member_name–m a?1 a?2 … a?n;

where each member_name specifies a member of the structure preceded by a level-number, k, and where the level-number of each member must be greater than the level-number of its containing structure, equal to level-numbers of members at the same level, and less than the level-numbers of members it contains. The major structure name is declared as structure level 1.

The only attributes given to the structure itself are storage class, ALIGNED, UNALIGNED, DIMENSION, REFER, and UNION. Each member is declared to have all attributes following its name up to the next comma or up to the end of the statement. For example:

DECLARE 1 S    STATIC,
            2  A(5) FLOAT DECIMAL(7),
            2  B  FIXED BINARY(15),
            2  C,
                  3 D   POINTER,
                  3 E   CHARACTER(10) INITIAL('ABC');

In this example, S is a static structure with members A, B, and C. C is a substructure with members D and E. Initial attributes can be given to elementary members of static structures, but not to structures themselves.

Parent topic: Recommended Forms


The General Form

Following is the general form of the DECLARE statement:

DECLAREd?1[,d?2 …];

or

DCL d?1 [,d?2 …];

where each d is:

[k]name a?1 a?2 … a?n

or

[k](d?1[,d?2]…)a?1 a?2 … a?n

where k is an optional level number, each a is an attribute, and name is a name to be declared.

Examples:

DECLARE ((A FIXED, B FLOAT) DECIMAL, C BIT) STATIC;
DECLARE 1 S STATIC, 2 (A FIXED, B FLOAT) INITIAL(0);

These examples illustrate more factored declarations, as indicated by the fact that the DECLARE statements contain parenthetical lists of names. Factored declarations can be transformed into nonfactored declarations by copying the level number and attribute list of the innermost set of parentheses onto each name contained within the parentheses, removing the parentheses, and repeating this process with the next set of parentheses.

After defactoring, the previous examples are:

DECLARE A FIXED DECIMAL STATIC;
DECLARE B FLOAT DECIMAL STATIC;
DECLARE C BIT STATIC;
DECLARE 1 S STATIC,
      2 A FIXED INITIAL(0),
      2 B FLOAT INITIAL(0);

Factored declarations, other than as shown in the recommended form (see the section Factored Declarations) are generally more difficult to read than their unfactored equivalents.

If defactoring produces more than one level number for a given name, even if the level numbers are equal, the factored declaration is invalid and causes the Compiler to issue an error message.

Specification of duplicate attributes containing more than a simple keyword is also invalid, even when the attributes are exact duplicates.

Parent topic: DECLARE Statements
Related information
Factored Declarations


Defaults

If the attributes specified for a name in a DECLARE statement are incomplete, the missing attributes can be supplied either by the Compiler or by the user with the DEFAULT statement.

  • Compiler-supplied Defaults
  • The Default Statement
Parent topic: DECLARE Statements


Compiler-supplied Defaults

The Compiler supplies the required additional attributes, as follows:

Specified | Missing | Supplied
binary | fixed | float | fixed
decimal | fixed | float | fixed
fixed | binary | decimal | decimal
float | binary | decimal | decimal
static | internal | external | internal
bit | length | length of one
character | length | length of one
area | size | size of 1000

Defaults are also supplied for the following conditions.

  • STATIC is supplied if EXTERNAL is specified without a storage class and the declared name is not an entry or file constant.
  • AUTOMATIC is supplied if the name is the name of a nonparameter variable that is not a member of a structure and no storage class was specified.
  • The default precision is supplied if precision is not specified for arithmetic data. For information on the Open PL/I default precisions, see your Open PL/I User's Guide.
  • VARIABLE is supplied if a storage class, array bounds, or member's level number is specified with FILE or ENTRY.
  • EXTERNAL is supplied if FILE or ENTRY is specified and VARIABLE is neither specified nor supplied under the previous rule. In this case, the named object is a constant rather than a variable.
  • UNALIGNED is supplied for bit-string data; ALIGNED for all other types of data.
Parent topic: Defaults
Related information
Open PL/I User's Guide


The Default Statement

You can change Compiler-supplied defaults, or you can apply a completely new set of default attributes, using the DEFAULT statement.

Parent topic: Defaults
Related information
DEFAULT


Attribute Consistency

After default attributes have been supplied, each declaration is checked by the Compiler for consistency and completeness.

If no data type is specified, either explicitly or by the DEFAULT statement, the declaration is invalid and incomplete. The Compiler issues an error message and supplies a type of Fixed Binary(15) for names beginning with any of the letters I through N, and Float Decimal(6) for names beginning with any other alphabetic character.

A declaration is inconsistent and invalid if it specifies more than one data type or more than one storage class.

These are the valid data types:
  • Fixed Binary(p)
  • Fixed Decimal(p[,q])
  • Float Binary(p)
  • Float Decimal(p)
  • Picture
  • Character(n) [Varying]
  • Bit(n)[Aligned]
  • Pointer
  • Offset
  • Area
  • Label
  • Entry [returns][variable]
  • File [variable]
  • Builtin
  • Structure
These are the valid storage classes:
  • automatic
  • based or based(pointer-reference)
  • static internal
  • defined(reference)
  • parameter
  • member of structure

A declaration is also inconsistent and invalid if it violates the following attribute-specific restrictions:

  • A name declared with the BUILTIN attribute cannot have any other attribute.
  • A name declared with the FILE or ENTRY attribute, but without the VARIABLE attribute, is a named constant, not a variable, and its scope is external. (Recall, however, that the presence of a storage class, an array bound, or a member's level-number causes the VARIABLE attribute to be supplied by default to declarations containing the ENTRY and FILE attributes.)
Parent topic: DECLARE Statements


Attributes of DECLARE Statements

This section describes, in alphabetical order, the attributes that are permitted in a DECLARE statement.

The discussion of each attribute assumes that the attributes have been made complete by the application of defaults, as described in the section Defaults.

Each attribute discussed in this section falls into one of the following categories:

  • Arithmetic or string data attributes, which define arithmetic or string data.
    • ALIGNED
    • BIGENDIAN
    • BINARY
    • BIT
    • CHARACTER
    • DECIMAL
    • FIXED
    • FLOAT
    • NATIVE
    • NONNATIVE
    • PICTURE
    • REAL
    • UNALIGNED
    • VARYING
  • Data type attributes, which apply to program data not used for computation.
    • AREA
    • CONDITION
    • DIMENSION
    • ENTRY
    • EXCLUSIVE
    • FILE
    • LABEL
    • LIKE
    • OFFSET
    • POINTER
    • TYPE
  • Storage class and scope attributes, which control the allocation and storage use for a data variable and define the variable's scope.
    • AUTOMATIC
    • BASED
    • CONTROLLED
    • CONNECTED
    • DEFINED
    • EXTERNAL
    • GLOBALDEF
    • GLOBALREF
    • INITIAL
    • INTERNAL
    • NOINIT
    • PARAMETER
    • POSITION
    • REFER
    • STATIC
    • UNION
  • File description attributes, which can be applied to file constants or may be used in OPEN statements (except ENVIRONMENT, which can be used only in the DECLARE statement).
    • DIRECT
    • ENVIRONMENT
    • INPUT
    • KEYED
    • OUTPUT
    • PRINT
    • RECORD
    • SEQUENTIAL
    • STREAM
  • Entry name attributes, which can be applied to identifiers of entry points. These include:
    • BUILTIN
    • ENTRY
    • IRREDUCIBLE
    • OPTIONS(DESCRIPTOR)
    • OPTIONS(NODESCRIPTOR)
    • OPTIONS(VARIABLE)
    • REDUCIBLE
    • RETURNS
    • VARIABLE
  • Argument-passing attributes, which describe parameters of external procedures. These include:
    • ANY
    • VALUE
Note:

File description attributes specified in a DECLARE statement apply to all openings of the file control block associated with the file constant. For further discussion of these attributes, see the sections Input and Output in the chapter Language Concepts and OPEN in the chapter Statements.

  • ALIGNED
  • ANY
  • AREA
  • AUTOMATIC
  • BASED
  • BIGENDIAN
  • BINARY
  • BIT
  • BUILTIN
  • CHARACTER
  • CONDITION
  • CONNECTED
  • CONTROLLED
  • DECIMAL
  • DEFINED
  • DIMENSION
  • DIRECT
  • ENTRY
  • ENVIRONMENT
  • EXCLUSIVE
  • EXTERNAL
  • FILE
  • FIXED
  • FLOAT
  • GLOBALDEF
  • GLOBALREF
  • INITIAL
  • INPUT
  • INTERNAL
  • IRREDUCIBLE
  • KEYED
  • LABEL
  • LIKE
  • NATIVE
  • NOINIT
  • NONNATIVE
  • OFFSET
  • OPTIONS(DESCRIPTOR)
  • OPTIONS(NODESCRIPTOR)
  • OPTIONS(VARIABLE)
  • OUTPUT
  • PARAMETER
  • PICTURE
  • POINTER
  • POSITION
  • PRINT
  • READONLY
  • REAL
  • RECORD
  • REDUCIBLE
  • REFER
  • RETURNS
  • SEQUENTIAL
  • STATIC
  • STREAM
  • TYPE
  • UNALIGNED
  • UNION
  • UPDATE
  • VALUE
  • VARIABLE
  • VARYING
Parent topic: Declarations and Attributes
Related information
Defaults
Input and Output
OPEN


ALIGNED

ALIGNED is a data type attribute that controls the storage boundary of data.

ALIGNED is an optional part of the data type specification. Its presence allows the Compiler to align the data on an implementation-defined storage boundary, with the possible side effect that more bits or bytes of storage are used than specified by the declared length.

Parent topic: Attributes of DECLARE Statements
Related information
ALIGNED and UNALIGNED Attributes
Bit-String Data


ANY

The ANY attribute specifies that the corresponding argument for a parameter can be of any data type. The ANY attribute is applicable only to the declaration of entry names and is valid only in a parameter descriptor. ANY is not valid as an attribute in a PROCEDURE or ENTRY statement.

Parent topic: Attributes of DECLARE Statements
Related information
ENTRY


AREA

AREA is a non-computational data type attribute used to define a region of storage in which based variables can be allocated and freed. The format is:

AREA[(exp[REFER(variable)])]

or

AREA(*)

For a complete description of area data and the use of the AREA attribute, see the section Area Data in the chapter Data Types.

Parent topic: Attributes of DECLARE Statements
Related information
Area Data


AUTOMATIC

Abbreviation: AUTO

AUTOMATIC is a storage class attribute that specifies that the declared name is a variable that is allocated storage with each activation of its containing procedure or BEGIN block.

The AUTOMATIC attribute is supplied by default to any name of a non-parameter variable that is not a member of a structure and that has no storage class.

Parent topic: Attributes of DECLARE Statements
Related information
Automatic Storage


BASED

BASED is a storage class attribute that specifies that the declared name is a based variable. Its format is:

BASED[(r)]

In the optional form, r is a reference to a locator variable or a locator-valued function that serves as the default (implicit) locator qualifier for unqualified references to the name.

Parent topic: Attributes of DECLARE Statements
Related information
Based Variables


BIGENDIAN

BIGENDIAN is a data type attribute (applying to Fixed Binary items only) that specifies the internal storage for a data item is MSB first (or MSB "left -to- right"). This attribute is applicable only to Little-Endian machine architectures (such as Intel). For Big-Endian architectures, this attribute is ignored.

Example:

dcl flag fixed bin (15) static initial (1) bigendian;
Parent topic: Attributes of DECLARE Statements


BINARY

Abbreviation: BIN

BINARY is an arithmetic data type attribute that specifies that the base is binary. Its format is:

BINARY[(p)]

The precision p may be supplied with the BINARY attribute or with the FIXED or FLOAT attribute, but it cannot be specified twice. The precision p must be a positive integer. If no precision is specified, a default precision is supplied. For information on the default precisions, see your Open PL/I User's Guide and the section DEFAULT in the chapter Statements.

If BINARY is specified without FIXED or FLOAT, FIXED is assumed.

When used with FIXED, BINARY specifies integer arithmetic values that contain at least p bits.

When used with FLOAT, BINARY specifies floating-point arithmetic values that have a mantissa that contains the equivalent of at least p bits.

Parent topic: Attributes of DECLARE Statements
Related information
DEFAULT
Arithmetic Data


BIT

BIT is a bit-string data type attribute that identifies a variable as a bit-string variable. Its format is:

BIT[(n)]

Length n is an extent expression or integer constant, depending on the storage class of the declared name. The length n must be a non-negative integer constant or an expression that evaluates to a non-negative integer. A default length of 1 is supplied if no length is given.

For more information on BIT, see the chapter Storage Classes and the section Bit-String Data in the chapter Data Types.

Parent topic: Attributes of DECLARE Statements
Related information
Storage Classes
Bit-String Data


BUILTIN

BUILTIN is an entry name attribute that indicates that the declared name is a built-in function. Unless an empty argument list is used in a reference to a built-in function having no parameters, the function must be declared with the BUILTIN attribute.

BUILTIN can be used to redeclare a built-in function name that was declared as something else in an outer block. The declared name must be one of the names given in the chapter Open PL/I Built–Ins.

Parent topic: Attributes of DECLARE Statements
Related information
Open PL/I Built–Ins


CHARACTER

Abbreviation: CHAR

CHARACTER is a character-string data type attribute that identifies a variable as a character-string variable. Its format is:

CHARACTER[(n)]

Length n is an extent expression or integer constant, depending on the storage class of the declared name. The length n must be a non-negative integer constant or an expression that evaluates to a non-negative integer. A default length of 1 is supplied if no length is specified. For a discussion of storage classes, see the chapter Storage Classes and the section Character-String Data in the chapter Data Types.

Parent topic: Attributes of DECLARE Statements
Related information
Storage Classes
Character-String Data


CONDITION

Abbreviation: COND

CONDITION is an attribute that indicates that the declared name is a condition name. Its format is:

CONDITION

Condition names can be used only in ON, SIGNAL, or REVERT statements. The default scope of condition name is external. Note that a name that appears with the CONDITION condition in an ON, SIGNAL, or REVERT statement is contextually declared to be a condition name.

Parent topic: Attributes of DECLARE Statements
Related information
ON


CONNECTED

Abbreviation: CONN

The CONNECTED attribute may be used only for parameters. It cannot be specified for a member of a structure and it cannot be specified for CONTROLLED parameters. The CONNECTED attribute asserts that any argument passed to the parameter is in connected storage.

Parent topic: Attributes of DECLARE Statements


CONTROLLED

Abbreviation: CTL

CONTROLLED is a storage class attribute that specifies a variable whose storage is dynamically allocated and freed in generations. Its format is:

CONTROLLED
Parent topic: Attributes of DECLARE Statements
Related information
Controlled Variables


DECIMAL

Abbreviation: DEC

DECIMAL is an arithmetic data type attribute that specifies that the base is decimal. Its format is:

DECIMAL[(p[,q])]

The precision p,q (q is optional and represents fractional digits) may be supplied with the DECIMAL attribute or with the FIXED or FLOAT attribute, but it cannot be specified twice. The precision p and the scale q (if specified) must be positive integers. If a precision or scale is not specified, a default is assumed. For more information on default precisions, see your Open PL/I User's Guide and the section DEFAULT in the chapter Statements.

If DECIMAL is supplied without FIXED or FLOAT, FIXED is the default. If FIXED or FLOAT is specified without BINARY or DECIMAL, DECIMAL is the default.

When used with FIXED, DECIMAL specifies fixed-point arithmetic values that contain at least p decimal digits. If q is specified, p minus q digits are integral digits and q digits are fractional digits. If q is omitted, q = 0 is assumed. These values are integers containing at most p decimal digits.

Note: FIXED DECIMAL fractions with a precision less than the scale are not supported.
declare fd fixed decimal (1,2) init (2)  /* not supported. */

When used with FLOAT, DECIMAL specifies floating-point arithmetic values whose mantissa contains the equivalent of at least p decimal digits. In this case, q cannot be specified.

Parent topic: Attributes of DECLARE Statements
Related information
DEFAULT
Arithmetic Data


DEFINED

Abbreviation: DEF

DEFINED is a storage class attribute that specifies that the declared name is a defined variable that shares storage with a basis variable. Its format is:

DEFINED(r)

where r is the basis variable.

Parent topic: Attributes of DECLARE Statements
Related information
Defined Variables


DIMENSION

Abbreviation: DIM

DIMENSION is an attribute that specifies that a declared name is an array and defines the number and extent of its dimensions. Its format is:

DIMENSION(b1[,b2]…)

Each b represents one bound pair, which specifies the number of elements in a single dimension of the array. Each bound pair specifies an optional lower bound (lb) and a requisite upper bound (hb) for that dimension. A bound pair can be specified as follows.

* | The asterisk format of a bound pair, when used to define a parameter for a procedure or function, specifies that both the upper and lower bound of this dimension are to be taken from the corresponding array argument. If one bound pair is specified as asterisks, all bound pairs must be specified as asterisks.
lb:hb | This format specifies the minimum and maximum subscripts that can be used for the dimension. lb is an extent expression or optionally signed integer constant, depending on the storage class of the array, which specifies the lower bound of the dimension. Like lb, hb is either an extent expression or an optionally signed integer constant, depending on the storage class. It specifies the upper bound of the dimension.
hb | This format specifies only the upper bound of the dimension. The lower bound is assumed to be 1.

For example:

DECLARE X(5) FLOAT;
DECLARE Y DIMENSION(5) FLOAT;

In this example, both X and Y are arrays of five floating-point values.

The DIMENSION attribute is normally written immediately after the variable's name and is written without the DIMENSION keyword.

When specified with the FILE or ENTRY attributes, DIMENSION causes the associated name to become a variable rather than a named constant.

Parent topic: Attributes of DECLARE Statements


DIRECT

DIRECT is a file description attribute that indicates that a file can be accessed nonsequentially, that is, by key or by relative record number.

The DIRECT attribute may be given either in the declaration of a file constant or in an OPEN statement. It must not be specified in the declaration of a file variable.

Parent topic: Attributes of DECLARE Statements


ENTRY

ENTRY is a data type attribute that declares a constant or variable whose value is an entry point, and describes the attributes of the parameters, if any, that are declared for the entry point. Its format is:

ENTRY [([parameter-list])]

where parameter-list is:

()|parameter-descriptor[,parameter-descriptor]...

where parameter-descriptor is:

attribute[attribute] ... |*|,|structure-descriptor

where structure-descriptor is:

1 [attribute] ... ,level[attribute] ... [,level[attribute]] ...

An arbitrary parameter-descriptor can be indicated by use of an asterisk ( * ) or by a blank parameter-descriptor position, as indicated by the commas. For example,

ENTRY(FIXED BIN, , FLOAT  /* Three parameters. The
                          second is of any data type. */
ENTRY(FIXED BIN, * ,FLOAT)/* Three parameters. The
                          second is of any data type. */
ENTRY(, , ,)   /* Four parameters of any data type. */
ENTRY()        /* No parameters allowed. */
ENTRY          /* Any number of parameters is allowed. */

The ENTRY attribute without the RETURNS option has an implicit RETURNS data type. It is determined by the I–n rule. External entries with the implicit RETURNS can be called as functions or procedures.

Open PL/I does not require that if any entry statement in a multiple entry procedure has a RETURNS option, then all entries must have one.

ENTRY can be used with or without the VARIABLE attribute. Used without the VARIABLE attribute, the ENTRY attribute declares a constant that is the name of an external procedure. In this case, each p is a list of attributes that is either identical to the attributes specified for the corresponding parameter in the external procedure, or is ANY. For example:

DECLARE E ENTRY(FIXED BINARY(15), POINTER);

In this example, E refers to a procedure that accepts a fixed binary and a pointer argument.

Used with the VARIABLE attribute, the ENTRY attribute specifies that the declared name is a variable of the data type entry, which can be assigned any procedure name. When the entry variable is called, it must hold an entry value that designates a PROCEDURE statement whose parameters have attributes that are identical (unless the attribute is ANY) to the corresponding attributes given by p1, p2, and so forth. Using the declaration for E from the previous example, a compatible procedure declaration would be as follows:

E: PROCEDURE(X,Y);
   DECLARE X FIXED BINARY(15);
   DECLARE Y POINTER;

If a PROCEDURE statement has one or more parameters that are structures, the ENTRY attribute used to declare the procedure name must have a set of attributes for each member of the structure, including all substructures, as shown in the following example:

DECLARE E ENTRY(1,2 FIXED, 2 FLOAT, POINTER);

In the previous example, E is a procedure having two parameters; the first parameter is a structure with two members, and the second parameter is a pointer. The parameter attributes given in the ENTRY attribute include the level numbers and attributes of all members, as well as the level number and attributes of the parameter structure.

All string lengths or array bounds given in an ENTRY attribute must be exactly the same as those given in the parameters of the PROCEDURE statement. Programs that violate this rule may produce unpredictable results.

The ENTRY attribute can be used with the ANY, OPTIONS(VARIABLE), RETURNS(returns_descriptor), and VALUE options according to the following format:

DECLARE
   entry_nameENTRY[(parameter_descriptor[VALUE]…)]
        [OPTIONS(VARIABLE)]
        [RETURNS(returns_descriptor)];

The RETURNS attribute is required for entry points that are invoked by function references and is invalid for procedures invoked by CALL statements. Parameter descriptors are not allowed if the ENTRY attribute is within a RETURNS descriptor.

The parameter descriptor lists attributes for each parameter and must include either the data type of the parameter or the attribute ANY. The VALUE attribute indicates that the corresponding argument is to be passed by immediate value. The OPTIONS(VARIABLE) option indicates that the specified external procedure can be invoked with a variable number of arguments. The following options can be specified as part of the OPTIONS(VARIABLE) attribute when declaring an ENTRY:

  • ASSEMBLER NOMAP [map-list]
  • COBOL NOMAPIN [map-list]
  • FORTRAN NOMAPOUT [map-list]
  • INTER NOEXECOPS
  • TASK RETCODE

The RETURNS(retums_descriptor) option gives the data type attributes of the function value returned for an entry invoked as a function reference. The VARIABLE attribute is not valid in a parameter descriptor or in a RETURNS descriptor.

The VALUE attribute can be used in an ENTRY declaration in conjunction with the data types Fixed Binary, Pointer, Character, Aligned Bit, Entry, or Float Binary. For more information, see the section VALUE.

If the ANY attribute is included as a parameter descriptor, the argument that corresponds to that parameter descriptor can be of any data type. If the argument is a variable, its address is passed to the called procedure. If the argument is a constant or an expression, a dummy argument is created and its address is passed to the called procedure. The following conversions take place when creating the dummy argument:

Written Data Type | Dummy Data Type
Bit (Unaligned) | Bit(n) Aligned, where n is the length of the string
Fixed Binary or Fixed Decimal(p,O) | Fixed Binary(31)
Char Varying | Char(n), where n is the length of the string

For more information, see the chapter Storage Classes and your Open PL/I User's Guide.

The OPTIONS(VARIABLE) attribute is used to indicate that it is valid for a discrepancy to exist between the number of parameter descriptors in the declaration of the procedure and the number of arguments in the argument list used to call the procedure.

The following rules apply when using the OPTIONS(VARIABLE) option:

  • If a procedure is called with more arguments than there are parameter descriptors, the trailing arguments are passed using the attributes of the last parameter descriptor. In this case, use of at least one parameter descriptor is required.
  • If a procedure is called with some arguments omitted, a null pointer is passed to the called routine in place of the missing argument. (The null pointer indicates an omitted argument.) An argument is considered to be omitted if two commas are found adjacent to one another in a call to a procedure, or if a comma comes after the left parenthesis or before the right parenthesis; that is, ( , a, ) indicates two missing arguments.
  • If a procedure is called with more arguments than there are parameter descriptors, and the trailing arguments are omitted (as indicated by adjacent commas), a null pointer is passed for each of the omitted arguments.

The following examples show how the ENTRY attribute can be used with the VALUE, ANY, OPTIONS(VARIABLE), and RETURNS(retums_descriptor) options. For a further description of these options, refer to each option by name within this chapter.

The following example causes the value of A to be converted to Fixed Binary(31) and the immediate value (25) to be passed directly to P5, followed by an immediate value representing the address of A:

DECLARE
   P5 ENTRY (FIXED BIN(31) VALUE, POINTER VALUE),
   A FIXED BIN(15),
   B POINTER;
   A = 25;
   B = ADDR (A);
   CALL P5(A,B);

The following example illustrates the use of the ENTRY attribute with the OPTIONS( VARIABLE) and ANY options:

DECLARE
   P1 ENTRY (FIXED BINARY(15), ANY) OPTIONS(VARIABLE),
   A FIXED BINARY(15),
   B FLOAT BINARY(23),
   C CHARACTER(1);
CALL P1(A, B);
CALL P1(A, C, B);

In the previous example, the second parameter descriptor is declared as ANY. In the first call to P1, B, a Float Binary(23) variable is the second argument passed; in the second call to P1, C, a Char(1) variable is passed. In both calls, the variable is passed by reference. Since the OPTIONS(VARIABLE) attribute is used, the second call to P1 passes argument three, B, using the attribute for parameter descriptor two, ANY. In the second call, the variable B is passed by reference.

The following example illustrates a procedure called with some arguments omitted.

DECLARE
   P2 ENTRY (FIXED BINARY(15), FIXED BINARY(15),
      FIXED BINARY(15)) OPTIONS(VARIABLE),
   (A,B) FIXED BINARY(15);

CALL P2(A, ,B);

In the previous example, the arguments to be passed are A, a missing argument, and B. This configuration causes the address of A to be passed, followed by a null value, followed by the address of B.

The following example illustrates a procedure called with more arguments than there are parameter descriptors:

DECLARE
   P3 ENTRY (FIXED BINARY(15),FIXED BINARY(15))
      OPTIONS(VARIABLE),
   (A,B) FIXED BINARY(15),
   C FLOAT BINARY(31);
CALL P3 (A, B, ,);
CALL P3 (A, B, C);

In the previous example, the first call to P3 is declared with two parameter descriptors and called with four arguments, the last two being null. The addresses of the last two arguments will be represented by null values. The second call to P3 passes C as a Fixed Binary(15), since it is a trailing argument and is passed with the attribute of the last parameter descriptor. This configuration requires that C be converted from Float Binary to Fixed Binary, and that the address of the resulting temporary be passed.

The following example illustrates constants and expressions being passed with the ANY option:

DECLARE P4 ENTRY (ANY,ANY),
   ( A, B ) FIXED BINARY(15);
CALL P4( 3, 'ABC');
CALL P4( '1'B, AB );

In the first call to P4, the constant 3 will be converted to Fixed Binary(31) and the address of the temporary variable containing the converted value will be passed as the first argument; the character-string constant 'ABC' will be converted to Character(3) and its temporary address passed as the second argument. In the second call to P4, the bit-string constant '1' B will be converted to Bit(1) Aligned, AB will be converted to Fixed Binary(31), and the respective addresses of the temporaries will be passed to P4.

The following example illustrates the use of the RETURNS(retums_descriptor) option:

DECLARE F ENTRY(FIXED) RETURNS(POINTER);
DECLARE G ENTRY(FLOAT)
   RETURNS(CHARACTER(32)VARYING);

In this example, F is declared as the name of a function procedure that returns pointer values. G is declared as the name of a function procedure that returns varying character-string values whose maximum length is 32 characters.

Parent topic: Attributes of DECLARE Statements
Related information
Storage Classes


ENVIRONMENT

Abbreviation: ENV

The ENVIRONMENT attribute and its options specify many record characteristics that are not part of the PL/I language. Its format is:

ENVIRONMENT(options–list)

options-list can contain any of a number options specifying record characteristics. For example,

ENVIRONMENT(VSAM KEYLOC(1) KEYLENGTH(12));

The ENVIRONMENT attribute is not supported for use with a STREAM file.

Parent topic: Attributes of DECLARE Statements
Related information
Record I/O


EXCLUSIVE

Abbreviation: EXCL

The EXCLUSIVE attribute specifies that the records in a file can be locked when accessed by one process to prevent access by another process. When the EXCLUSIVE attribute is used, the entire file is locked.

Parent topic: Attributes of DECLARE Statements


EXTERNAL

Abbreviation: EXT

EXTERNAL is a scope attribute that specifies that the declared name has external scope. This means that all declarations of this name anywhere in the program that also have the EXTERNAL attribute identify the same object.

The EXTERNAL attribute can be used only in the declaration of variables whose storage class is STATIC or CONTROLLED. (It can be redundantly specified for variables of storage classes GLOBALDEF and GLOBALREF, which are implicitly EXTERNAL STATIC.) If EXTERNAL is specified for a variable and no storage class attribute is specified, STATIC is supplied by default. Its format is:

EXTERNAL[(global_name)]

global_name is either a character-string constant or a %REPLACE name for a character string constant. global_name is used by the linker when references are made to the entry. Open PL/I makes no restrictions on the contents of global_name, but the underlying operating system may have restrictions.

EXTERNAL must be specified when the entry is declared in another module. EXTERNAL(global_name) is specified as an option either on a PROCEDURE statement or on an ENTRY statement.

By using the EXTERNAL(global_name) option, an alternative name can be specified for an external entry constant. Instead of the usual entry constant name, the alternative name (global_name) is used to invoke the procedure at the entry point.

OZS: PROCEDURE;
      DECLARE PROC1 ENTRY;
      DECLARE ALSO_PROC1 ENTRY EXTERNAL('PROC1');
      DECLARE PROC2 ENTRY EXTERNAL('ILL.EGAL');
      CALL PROC1;
      CALL ALSO_PROC1;
      CALL PROC2;
      END OZS;

      /*======== A SEPARATE MODULE ========*/

      PROC1: PROCEDURE;

      PROC2: ENTRY EXTERNAL('ILL.EGAL');

      END PROC1;

In this example, the program declares explicitly the entry constants PROC1 and PROC2.

Parent topic: Attributes of DECLARE Statements


FILE

FILE is a data type attribute. Used without the VARIABLE attribute, it specifies that the declared name is a file identifier having external scope and an associated file control block that can be used to perform I/O on files and devices known to the operating system. In this case, the EXTERNAL attribute and any of the file description attributes RECORD, STREAM, INPUT, OUTPUT, UPDATE, KEYED, DIRECT, SEQUENTIAL, and PRINT may also be specified. Any file description attributes specified in the declaration are merged with attributes supplied by the OPEN statement or attributes implied by the I/O statement that implicitly opens the file control block.

Used with the VARIABLE attribute, FILE specifies that the declared name is a file variable that can be assigned file values. In this case, the file description attributes cannot be supplied because a file variable has no associated file control block until a file value is assigned to it. File description attributes are attributes of a file control block and are not attributes of a file value or file variable.

Some attributes for a name declared implicitly can be determined from the context in which the name appears. These cases are called contextual declarations. A name that appears in a FILE option, or in an ON, SIGNAL, or REVERT statement for a condition that requires a file name, is given the FILE attribute. For example,

OPEN FILE(F);
WRITE FILE(W) FROM(BUF);
READ FILE(R) INTO(BUF);
CLOSE FILE(C);

In all four above cases the names used with the FILE option will be implicitly declared as having File data type.

Parent topic: Attributes of DECLARE Statements


FIXED

FIXED is an arithmetic data type attribute that defines a fixed-point arithmetic variable. Its format is:

FIXED[(p[,q])]

The precision p,q (q is optional and represents fractional digits) may be supplied with this attribute or with the BINARY or DECIMAL attribute, but it cannot be specified twice. The precision p and the scale q (if specified) must be positive integers. If a precision or scale is not specified, a default is assumed. If FIXED is specified without BINARY or DECIMAL, DECIMAL is assumed. For details on precisions, see your Open PL/I User's Guide and the section DEFAULT in the chapter Statements.

When used with BINARY, FIXED specifies integer arithmetic values that contain at least p bits. In this case, q must not be specified.

When used with DECIMAL, FIXED specifies fixed-point arithmetic values that contain at least p decimal digits. If q is specified, p minus q digits are integral digits and q digits are fractional digits. If q is omitted, q = 0 is assumed. These values are integers containing at least p decimal digits.

Note: FIXED DECIMAL fractions with a precision less than the scale are not supported.
declare fd fixed decimal (1,2) init (2)  /* not supported. */
Parent topic: Attributes of DECLARE Statements
Related information
DEFAULT
Arithmetic Data


FLOAT

FLOAT is an arithmetic data type attribute that defines a floating-point arithmetic value. Its format is:

FLOAT[(p)]

The precision p may be supplied with this attribute or with the BINARY or DECIMAL attribute, but it cannot be specified twice. The precision p must be a positive integer. If a precision is not specified, a default precision is assumed. for information on the Open PL/I default precisions, see your Open PL/I User's Guide and the section DEFAULT in the chapter Statements.

If FLOAT is specified without BINARY or DECIMAL, DECIMAL is the default. If BINARY or DECIMAL is supplied without FIXED or FLOAT, FIXED is the default.

When used with BINARY, FLOAT specifies floating-point arithmetic values whose mantissa contains the equivalent of at least p bits.

When used with DECIMAL, FLOAT specifies floating-point arithmetic values whose mantissa contains the equivalent of at least p decimal digits.

Parent topic: Attributes of DECLARE Statements
Related information
DEFAULT
Arithmetic Data


GLOBALDEF

GLOBALDEF is a storage class and scope attribute that declares an external variable or external file constant and causes storage to be allocated for the variable or constant. Its format is:

GLOBALDEF [(name)]

where name is an identifier that is accepted as legal syntax for compatibility with other Open PL/I extensions, but is ignored, having no effect.

For variables, the GLOBALDEF attribute implies the EXTERNAL and STATIC attributes. For file constants, it implies the EXTERNAL attribute. A given variable or file constant may be declared with the GLOBALDEF attribute in only one procedure.

Parent topic: Attributes of DECLARE Statements


GLOBALREF

GLOBALREF is a storage class and scope attribute that declares a global symbol, which is defined in an external procedure either with the GLOBALDEF attribute or, if the external procedure is written in another programming language, with its equivalent in that language. Its format is:

GLOBALREF [(name)]

where name is an identifier that is accepted as legal syntax for compatibility with other Open PL/I extensions, but is ignored, having no effect.

The GLOBALREF attribute implies the EXTERNAL and STATIC attributes. A variable may be declared with the GLOBALREF attribute in as many procedures as desired. Unlike GLOBALDEF, GLOBALREF does not cause actual storage to be allocated for the external variable, but allows access to the storage that was allocated by some other external procedure.

If GLOBALREF is present, any INITIAL attribute for the variable is ignored.

P1: PROCEDURE;         P2: PROCEDURE;
DECLARE                   DECLARE
   XVAR FIXED BIN(15)        XVAR FIXED BIN(15)
      GLOBALDEF;             GLOBALREF;
XVAR = 23;             IF XVAR > 0 THEN XVAR = 100;
CALL P2;               .
.                      .
.                      .
.

In this example, XVAR is declared with the GLOBALDEF attribute in procedure P1 and is assigned storage as a result. The value 23 is assigned to XVAR. Procedure P2 has declared XVAR with the GLOBALREF attribute and will access the same memory location allocated by P1 . Procedure P2 can test and/or change the value of XVAR.

Parent topic: Attributes of DECLARE Statements


INITIAL

Abbreviation: INIT

INITIAL is a storage class attribute that specifies the initial value of a variable or member of a structure. The INITIAL attribute has two formats. The first specifies an initial constant, expression, or variable whose value is assigned to a variable when storage is allocated to it. The second format specifies that the CALL option invokes a procedure to perform initialization at allocation. The variable is initialized by assignment during the execution of the called routine, rather than by the routine being invoked as a function that returns a value to the point of invocation. The formats of the INITIAL attribute are:

Format 1:

INITIAL(item[,item]…)

where item is:

*|constant|variable|expression|iteration-spec

where iteration-spec is:

(iteration-factor) iteration-item

where iteration-item is:

*|constant|variable|expression

where iteration-factor is:

*|expression

where constant is:

arithmetic-constant|bit-constant|character-constant|
entry-constant1 label-constant
Note: Open PL/I supports the ANSI PL/I Subset G specification for the INITIAL attribute, not the full mainframe PL/I specification.

In the context of item or iteration-item, asterisk ( * ) specifies that the element is to be left uninitialized.

In the context of iteration-factor, asterisk (* ) specifies that the entire array is to be initialized with the iteration-item.

For static variables, any value specified in an INITIAL attribute is assigned at the time the program is first loaded into memory for execution.

For automatic variables, which are allocated at each activation of the declaring block, any specified initial value is assigned at the time of each allocation.

For based and controlled variables, which are allocated at the execution of ALLOCATE statements, any specified initial value is assigned at the time of each allocation.

The INITIAL attribute may not be used with variables of storage classes other than those mentioned above.

Only constant values with no operations can be specified in the INITIAL attribute for static variables, with the following exceptions:

  • The NULL() built-in function can be used to initialize a static pointer variable.
  • Expressions containing concatenated string constants can be used to initialize static string variables. For example:
    DECLARE STRING CHAR(11) STATIC INIT ('MICRO'|| ' FOCUS');

Format 2:

INITIAL CALL entry(arg[,arg]…)

The INITIAL call cannot be used to initialize static data.

  • Examples of the INITIAL Attribute
Parent topic: Attributes of DECLARE Statements


Examples of the INITIAL Attribute

The following example will initialize all elements of 3x3 matrix A with the exception of its diagonal elements A (1,1), A(2,2), and A(3,3):

DECLARE A(3,3) FIXED BIN INIT(*,(3)0,*,(3)0,*);

The following example will initialize all elements of array B to the value of the expression (X+10 ) where X is a procedure parameter.

SUB; PROCEDURE(X);
DECLARE X FIXED BIN(15);
DECLARE B(5) FLOAT BIN INIT((HBOUND(B,1))(X+10));

The following example demonstrates the usage of asterisk repeat factor and will initialize the entire array Z to the value of 1.0.

SUB1: PROCEDURE(DIM);
DECLARE DIM FIXED BIN(15);
DECLARE Z(DIM) FLOAT BIN(23) INIT((*)1.0);

The INITIAL CALL is used to initialize automatic, based, or controlled variables by calling an external entry. The following is an example.

TEST: PROCEDURE OPTIONS(MAIN);

/* Initialize all elements of array TEN */
   DECLARE TEN(10) FIXED BIN(15)
      INIT CALL INITIALIZE(ADDR(TEN),HBOUND(TEN,1));

INITIALIZE: PROCEDURE(P,DIM);

DECLARE
   P           POINTER,
   DIM         FIXED BIN(15);
DECLARE
   I           FIXED BIN,
   ARRAY(1000) FIXED BIN(15) BASED;

   DO I = 1 TO DIM;
      P->ARRAY(I)=75;
   END;

END INITIALIZE;
END TEST;
Parent topic: INITIAL


INPUT

INPUT is a file description attribute that specifies that a file will be used for input.

The INPUT attribute may be given in the declaration of a file constant or in an OPEN statement. It must not be specified in the declaration of a file variable.

File description attributes specified in a DECLARE statement apply to all openings of the file control block associated with the file constant.

Parent topic: Attributes of DECLARE Statements
Related information
Input and Output
OPEN


INTERNAL

Abbreviation: INT

INTERNAL is a scope attribute that limits the scope of a variable to the block in which it is defined.

The INTERNAL attribute may be given with any storage class attribute or to parameters, but it has no significance since these variables always have internal scope. If STATIC is used without INTERNAL or EXTERNAL, INTERNAL is the default.

Parent topic: Attributes of DECLARE Statements


IRREDUCIBLE

Abbreviation: IRRED

IRREDUCIBLE is an attribute sometimes used by IBM mainframe PL/I programs. It is not needed by Open PL/I. It is simply parsed and otherwise ignored.

Parent topic: Attributes of DECLARE Statements


KEYED

KEYED is a file description attribute that indicates that records in a specified file may be accessed randomly. The KEYED attribute implies the RECORD attribute.

KEYED may be given in the declaration of a file constant or in an OPEN statement. It must not be specified in the declaration of a file variable.

Parent topic: Attributes of DECLARE Statements
Related information
OPEN


LABEL

LABEL is a data type attribute that specifies label values. When used in the declaration of a name, it specifies that the declared name is a label variable. When used in an ENTRY attribute, it specifies that the corresponding parameter is a label variable, and when used in a RETURNS attribute, it specifies that the procedure returns label values.

For a discussion of label values, see the section Label Data in the chapter Data Types.

Parent topic: Attributes of DECLARE Statements
Related information
Label Data


LIKE

LIKE specifies that the variable being declared has the same structure as the referenced variable. Its format is:

LIKE reference

where reference is a reference to a structure variable.

The variable being declared must be a structure variable. LIKE causes it to have exactly the same members, in name and attributes, as the referenced structure variable. Only the level numbers are changed as needed to adapt to the variable being declared.

In the following example, structure members are duplicated from one declaration to another by way of the LIKE attribute:

DECLARE 1 TEMPLATE BASED,
   2 NAME CHAR(45),
   2 SALARY FIXED BIN(15),
   2 EMP_NO FIXED BIN(15);
DECLARE 1 EMPLOYEE_INFO(1000) LIKE TEMPLATE;

Duplication of the members from TEMPLATE expands the declaration of EMPLOYEE_INFO, with the result that the declaration of EMPLOYEE_INFO is equivalent to:

DECLARE 1 EMPLOYEE_INFO(1000),
   2 NAME CHAR(45),
   2 SALARY FIXED BIN(15),
   2 EMP_NO FIXED BIN(15);

The referenced variable can be a major or a minor structure. It may be qualified, but may not be pointer-qualified. The following restrictions apply to the referenced variable:

  • It must be known in the block containing the LIKE attribute specification.
  • It cannot be subscripted.
  • It cannot contain a REFER variable.
  • Neither the referenced variable nor any of its substructures can be declared with the LIKE attribute.
  • It cannot be a substructure of a structure declared with the LIKE attribute.

The function of the LIKE attribute is similar to that of the TYPE attribute . With LIKE, the storage class of the referenced structure is not carried over to the created structure (same as TYPE). However, neither are the alignment attributes and/or dimensions of the referenced variable carried over (unlike TYPE). Only the alignment and dimensions of substructures and elements of the referenced variable are carried over.

Note: Because the UNALIGNED attribute is not carried forward with LIKE, two LIKE structures could have differing alignment characteristics and sizes because of structure mapping conventions.
Parent topic: Attributes of DECLARE Statements
Related information
TYPE


NATIVE

NATIVE is a data type attribute (applying to Fixed Binary items only) that specifies the internal storage for the data item is LSB first (or MSB "right -to- left"). This attribute is applicable only to Little-Endian machine architectures (such as Intel), and is the default if not specified. For Big-endian architectures, this attribute is ignored.

Example:

dcl flag fixed bin (15) static initial (1) native;
Parent topic: Attributes of DECLARE Statements


NOINIT

NOINIT is a storage attribute used to ignore any INITIAL attributes.

The NOINIT attribute can be used with the LIKE attribute to inherit all the substructuring from an existing variable declared using LIKE, but without any of its INITIAL values. This lets you declare a variable from an existing variable, then create a different set of INITIAL values.

The NOINIT attribute is valid only on level-1 structures.

This example declares a new variable that inherits all the substructuring from an existing variable using NOINIT to ignore any INITIAL attributes.

dcl 1 s1,
    2 i fixed bin (31) init(88),
    2 j fixed bin (31) init(99);

dcl s2 like s1 noinit;
Parent topic: Attributes of DECLARE Statements


NONNATIVE

NONNATIVE is equivalent to BIGENDIAN.

Example:

dcl flag fixed bin (15) static initial (1) nonnative;
Parent topic: Attributes of DECLARE Statements
Related information
BIGENDIAN


OFFSET

The OFFSET attribute defines a locator data type used to specify the relative location of a based variable within an area. The format is:

OFFSET[(area–variable)]

For a complete description of offset data and the use of the OFFSET attribute, see the sections Offset Data and Area Data in the chapter Data Types.

Parent topic: Attributes of DECLARE Statements
Related information
Offset Data
Area Data


OPTIONS(DESCRIPTOR)

OPTIONS(DESCRIPTOR) is an entry name attribute. It specifies that argument descriptors will be passed to this entry by callers. This is the default for entry names. Argument descriptors are used to pass specific details about actual parameters in cases where parameter declarations contain CHAR(*) or DIMENSION(*) attributes.

Parent topic: Attributes of DECLARE Statements


OPTIONS(NODESCRIPTOR)

OPTIONS(NODESCRIPTOR) is an entry name attribute. It specifies that argument descriptors will not be passed to this entry by callers. Argument descriptors are used to pass specific details about actual parameters in cases where parameter declarations contain CHAR(*) or DIMENSION(*) attributes. The OPTIONS(NODESCRIPTOR) attribute is normally used to suppress the generation and passing of the descriptor(s) to a non-PL/I procedure.

Note:

OPTIONS(ASM) and OPTIONS(COBOL) are equivalent to OPTIONS(NODESCRIPTOR).

Parent topic: Attributes of DECLARE Statements


OPTIONS(VARIABLE)

OPTIONS(VARIABLE) is an entry name attribute that indicates, for an ENTRY descriptor, that a specified external procedure can be invoked with a variable number of arguments; a discrepancy may exist between the number of parameter descriptors in the declaration of the procedure and the number of arguments in the argument list used to call the procedure.

OPTIONS(VARIABLE) attribute is parsed and is otherwise ignored. It is an invalid attribute for a PROCEDURE or ENTRY statement, as opposed to the ENTRY attribute.

Parent topic: Attributes of DECLARE Statements
Related information
ENTRY


OUTPUT

OUTPUT is a file description attribute that indicates that data should be written to, and not read from, the associated file or device.

The OUTPUT attribute may be given in the declaration of a file constant or in an OPEN statement. It must not be specified in the declaration of a file variable.

Parent topic: Attributes of DECLARE Statements
Related information
OPEN


PARAMETER

A parameter is contextually declared with the parameter attribute by specifying it in a PROCEDURE or ENTRY statement. The parameter should be explicitly declared with appropriate attributes.

The PARAMETER attribute can also be specified in the contextual declaration. If attributes are not supplied in a DECLARE statement, default attributes are applied. The parameter name must not be subscripted or qualified.

A name that appears in the parameter list of a PROCEDURE or ENTRY statement is given the PARAMETER attribute.

This example shows the use of the PARAMETER attribute in a DECLARE statement.

sub: proc (j);

    dcl j fixed bin (31) parameter;   /* ok */
    dcl k fixed bin (31) parameter;   /* incorrect, not a parameter */

end;
Parent topic: Attributes of DECLARE Statements


PICTURE

Abbreviation: PIC

PICTURE is a data type attribute that specifies pictured values. Its format is:

PICTURE'p'

The picture 'p' contains an image of the data and specifies the editing to be performed each time a value is assigned to a pictured variable. It also governs the conversion of pictured values to fixed-point decimal values.

For a discussion of pictured data and the picture characters, see the section Picture Data in the chapter Data Types.

Parent topic: Attributes of DECLARE Statements
Related information
Picture Data


POINTER

Abbreviation: PTR

POINTER is a data type attribute that specifies pointer values. A pointer value is the address of a variable and is discussed in the section Pointer Data in the chapter Data Types.

Parent topic: Attributes of DECLARE Statements
Related information
Pointer Data


POSITION

Abbreviation: POS

POSITION is an attribute that is used in conjunction with the DEFINED attribute. It specifies the bit or character within the basis variable at which the defined variable is to begin. Its format is:

POSITION(expression)

where expression is an integer expression that specifies the position relative to the start of the basis variable. The range of the expression is from 1 to n, where n is defined as:

n = basis_length – defined_length+1

where basis_length is the length of the basis variable in bits or characters and defined_length is the length of the defined variable in bits or characters.

Both the defined variable and the basis variable must be fixed-length bit strings, fixed-length character strings, pictured variables, or aggregates containing any of these data types.

In the following example, the two DO-groups accomplish the same purpose. The second makes use of the POSITION attribute:

DECLARE X CHARACTER(200);
DECLARE Y CHARACTER(1) DEF X POS(I);

DO I = 1 to 200;
   IF SUBSTR(x,i,1) = '?' THEN
      CALL ERROR();

DO I = 1 to 200;
   IF Y = '?' THEN   /* Uses position attributes */
      CALL ERROR();
Parent topic: Attributes of DECLARE Statements


PRINT

PRINT is a file description attribute used to declare a print file.

PRINT may be given in the declaration of a file constant or in an OPEN statement, but it must not be specified in the declaration of a file variable.

Parent topic: Attributes of DECLARE Statements
Related information
OPEN


READONLY

The READONLY attribute is parsed and is otherwise ignored. This is a compatibility feature to allow Open PL/I programs written for other systems to compile without error.

Parent topic: Attributes of DECLARE Statements


REAL

REAL is an arithmetic data type attribute. It specifies that the associated variable is used for real numbers (that is, single-part numbers, as opposed to complex). Arithmetic variables are assumed to be REAL by default.

Parent topic: Attributes of DECLARE Statements


RECORD

RECORD is a file description attribute that indicates that data in an input or output file is made up of separate records, and that the file will be processed by record I/O statements.

RECORD may be given in the declaration of a file constant or may be given in an OPEN statement. It must not be specified in the declaration of a file variable.

Parent topic: Attributes of DECLARE Statements
Related information
OPEN


REDUCIBLE

Abbreviation: RED

REDUCIBLE is an attribute sometimes used by IBM mainframe PL/I programs. It is not needed by Open PL/I. It is simply parsed and otherwise ignored.

Parent topic: Attributes of DECLARE Statements


REFER

REFER is an attribute of a based structure that specifies that the value of one member is used to determine the amount of storage space allocated for another member of the same structure. Its format is:

expressionREFER(variable)

where expression is evaluated and converted to Fixed Binary (15) and is the initial extent when the based structure is allocated. Variables used in the expression being evaluated as operands must not belong to the member containing the REFER attribute.

variable must be a variable contained by the structure being allocated and defined prior to the extent whose size it determines. For example:

DECLARE 1 STRUC BASED(P),
      2 I FIXED BINARY,
      2 A CHARACTER(20 REFER(I));

Multiple REFER attributes are allowed in the declaration of a structure.

Parent topic: Attributes of DECLARE Statements


RETURNS

RETURNS is an entry name attribute that specifies that the entry value designates a function procedure that returns a value of data type t, where t is a list of attributes that specify a data type. Its format is:

RETURNS[(t)];

For example:

DECLARE F ENTRY(FIXED) RETURNS(POINTER);
DECLARE G ENTRY(FLOAT)
      RETURNS(CHARACTER(32)VARYING);

In this example, F is declared as the name of a function procedure that returns pointer values. G is declared as the name of a function procedure that returns varying character-string values whose maximum length is 32 characters.

Any string length given in a RETURNS attribute must be an integer constant. The only attributes that can be given in a RETURNS attribute are data type attributes. DIMENSION or level numbers cannot be given, because functions cannot return arrays or structures.

Parent topic: Attributes of DECLARE Statements
Related information
ENTRY


SEQUENTIAL

Abbreviation: SEQL

SEQUENTIAL is a file description attribute that indicates that records in the file will be accessed sequentially.

SEQUENTIAL may be given in the declaration of a file constant or in an OPEN statement. It must not be specified in the declaration of a file variable.

Parent topic: Attributes of DECLARE Statements
Related information
OPEN


STATIC

STATIC is a storage class attribute that specifies that the storage for the declared variable is allocated by the Compiler and/or linker prior to program execution and remains allocated throughout program execution. The default attribute is AUTOMATIC.

Parent topic: Attributes of DECLARE Statements
Related information
Static Storage


STREAM

STREAM is a file description attribute that indicates that the file consists of ASCII characters and will be processed using the GET and PUT statements.

The STREAM attribute may be given in the declaration of a file constant or in an OPEN statement, but it cannot be specified in the declaration of a file variable.

Parent topic: Attributes of DECLARE Statements
Related information
OPEN


TYPE

The TYPE attribute allows a declaration to inherit structure members and attributes from another declaration. It has the following format, where reference is a reference to a variable:

TYPE(reference)

If, for example, a variable INTEGER is declared as fixed binary, another variable that needs to be declared as fixed binary can be declared as TYPE (INTEGER) instead. For example:

DECLARE INTEGER   FIXED BIN(31);    /* TYPE DEFINITION */
DECLARE CODE      TYPE(INTEGER);    /* TYPED VARIABLE */

In this example, Open PL/I copies the attributes from INTEGER to CODE, which makes the declaration of CODE become the following:

DECLARE CODE   FIXED BIN(31);

In the previous example, INTEGER is referred to as a type definition and CODE is referred to as a typed variable. A type definition is a normal variable declaration. It can be given the based storage class, because storage will not be allocated for the type definition.

In the following example, structure members are duplicated from one declaration to another by way of the TYPE attribute:

DECLARE 1 TEMPLATE BASED, /* TYPE DEFINITION */
   2 NAME CHAR(45),
   2 SALARY FIXED BIN(15),
   2 EMP_NO FIXED BIN(15);
DECLARE EMPLOYEE_INFO TYPE(TEMPLATE); /* TYPED VARIABLE */

Duplication of the members from TEMPLATE expands the declaration of EMPLOYEE_INFO, with the result that the declaration of EMPLOYEE_INFO is now:

DECLARE 1 EMPLOYEE_INFO
   2 NAME CHAR(45),
   2 SALARY FIXED BIN(15),
   2 EMP_NO FIXED BIN(15);

The TYPE attribute can be used in any of the following locations:

  • Within a variable declaration.
  • Within a parameter declaration.
  • As a parameter description within the explicit declaration of an ENTRY constant or ENTRY variable.
  • Within a RETURNS option of a PROCEDURE or ENTRY statement.
  • As a RETURNS attribute of an ENTRY declaration.

The following example illustrates all uses of the TYPE attribute:

/*----------- TYPE DEFINITION -----------*/
/* (LINE MAY ALSO BE USED AS A VARIABLE) */
DECLARE LINE CHAR(80) VARYING;
/*---------------------------------------*/

/* VARIABLE DECLARATION */
DECLARE FORMAT_LINE TYPE(LINE);

/* PARAMETER DECLARATION */
DECLARE PARAM TYPE(LINE);

/* PARAMETER DESCRIPTOR */
DECLARE WRITE_LINE ENTRY(TYPE(LINE));

/* RETURNS OPTION IN PROCEDURE STATEMENT */
GET_LINE: PROC RETURNS(TYPE(LINE));

/* RETURNS OPTION IN ENTRY STATEMENT */
READ_LINE: ENTRY RETURNS(TYPE(LINE));

/* RETURNS ATTRIBUTE IN DECLARE STATEMENT */
DECLARE GET_LINE ENTRY RETURNS(TYPE(LINE));

A typed variable can inherit only the following attributes from its type definition (storage class is not inherited):

  • ALIGNED
  • BINARY
  • BIT
  • CHARACTER
  • DECIMAL
  • ENTRY
  • FILE
  • FIXED
  • FLOAT
  • LABEL
  • PICTURE
  • OPTIONS
  • POINTER
  • RETURNS
  • UNALIGNED
  • UNION
  • VARIABLE
  • VARYING
  • string length
  • arithmetic precision
  • array dimensions.
  • TYPE Attribute Extensions
  • TYPE and Extent Expressions
  • Using the TYPE Attribute
  • Examples of the TYPE Attribute
Parent topic: Attributes of DECLARE Statements


TYPE Attribute Extensions

The TYPE attribute can be used to declare a function that returns an aggregate (that is, array or structure) result. For example:

/* TYPE DEFINITION */
DECLARE ARRAY(10) CHAR(80),
   1 STRUCTURE,
      2 LEVEL1 BINARY(15)
      2 LEVEL2 BINARY(15)
DECLARE       FUNCTION1 ENTRY RETURNS(TYPE(ARRAY));
   FUNCTION2 ENTRY RETURNS(TYPE(STRUCTURE));
Note:

All extents in the type definition of the function must have constant values. For example, the dimension attribute of ARRAY (10) in the preceding declaration could not be a variable.

The TYPE attribute also allows an aggregate variable to be passed by value in one of the following two situations:

  • When a typed variable (enclosed in parentheses) is used in an argument list (see the following example).
  • When a function reference used as an argument has a RETURNS value that is declared with the TYPE attribute (see the following example).
      DECLARE XARR(10) FIXED BIN(15)
          YYR TYPE( XARR ),
          RTE ENTRY( TYPE(XARR) ),
          FCA ENTRY RETURNS( TYPE(XARR) );
CALL RTE( (XARR) );  /* CASE 1 */
CALL RTE( (YYR) );   /* CASE 1 */
CALL RTE( (FCA()) ); /* CASE 2 */

The parameter in the called routine must have the same TYPE attribute as the argument. In the above example, RTE's parameter has the attribute TYPE (XARR) (see the third line). This TYPE attribute is the same TYPE attribute that is used by the arguments in the subsequent calls to RTE (see the last 3 lines).

All extents in a type definition must have constant values when an aggregate variable is passed by value. For example, in the preceding program fragment, XARR. could not be declared as:

DECLARE N FIXED BINARY(31) INIT(10);
DECLARE XARR(N) FIXED BIN(15),
      .
      .
      .

Dimensions (array bounds) can be specified on either the type definition or the typed variable, but not on both. For example, the following declaration of an array of arrays is invalid:

DECLARE XXX(10) CHAR(80), /* VALID */
   YYY TYPE( XXX ),
/* VALID */
   ZZZ(10) TYPE( XX );
/* INVALID -- ARRAY OF ARRAYS */
Parent topic: TYPE


TYPE and Extent Expressions

Any extent expressions are inherited by a typed variable from that typed variable's type definition, as illustrated by the following example. A typed variable's dimensions and element lengths are dependent on the current values of the extent expressions.

/* TYPE DEFINITION */
DECLARE CHARX(N,N) CHAR( LENGTH(STRING) ) BASED,
   N FIXED BINARY(15),
   STRING CHAR(80) VARYING;
/* TYPED VARIABLE */
DECLARE ARRAY TYPE(CHARX) BASED;

The evaluation of extents when the array is referenced follows the same rules that apply to the evaluation of based variables. In the following example, the variable array is declared in a different block from CHARX:

/*--------------------------------------------------*/
START:      PROCEDURE;
   DECLARE CHARX(N,N) CHAR( LENGTH(STRING) ) BASED,
      N FIXED BINARY(15),
      STRING CHAR(80) VARYING;
      .
      .
      .
/*--------------------------------------------------*/
NEXT: PROCEDURE;
   DECLARE ARRAY TYPE(CHARX) BASED,
      N FIXED BINARY(15),
      STRING CHAR(80) VARYING;
      .
      .
      .
END NEXT;

/*--------------------------------------------------*/
      .
      .
      .
END START;
/*--------------------------------------------------*/

In the preceding example, Open PL/I uses the declarations in procedure NEXT to evaluate the extent expressions of ARRAY. Declarations in the current block are always used to evaluate extent expressions, even for variables that have not been declared with the TYPE attribute. (In the preceding example, if procedure NEXT did not declare N and STRING, those variable declarations in procedure START would be used.)

If the REFER option is used in a type definition, the following are true:

  • If the type definition is a structure that has the BASED attribute with a REFER option, the BASED attribute for the corresponding typed variable must be specified.

    For example, in the following program fragment, VAR1 is a type definition, and VAR2 is a corresponding typed variable. The BASED attribute and a REFER option are specified in the declaration of VAR1. Therefore, the BASED attribute must be specified in the VAR2 declaration.

    DECLARE N FIXED BIN(15);

/* TYPE DEFINITION: */
DECLARE 1 VAR1 BASED,
        2 SIZE FIXED BIN(15),
        2 ITEMS( N REFER(VAR1.SIZE) ) CHAR(80);

DECLARE VAR2 TYPE(VAR1) BASED;

    when expanded yields:

    DECLARE 1 VAR2 BASED,
        2 SIZE FIXED BIN(15),
        2 ITEMS (N REFER (VAR2.SIZE)) CHAR(80);
  • A variable declared with a REFER extent cannot be used as a type definition.

    For example, in the previous program fragment, VAR1.ITEMS cannot be used as a type definition.

  • The reference in REFER(reference) must indicate a variable declared in the type definition (structure).

    For example, in the previous program fragment, VAR1.SIZE is the reference in the REFER option and must be a member of VAR1, the type definition. In addition, the expanded form of the VAR2 declaration contains a substitution of VAR2.SIZE for VAR1.SIZE as the REFER(reference).

Parent topic: TYPE


Using the TYPE Attribute

The reference in TYPE(reference) cannot:

  • Be pointer-qualified
  • Be a constant
  • Possess a subscript list or argument list

For example, the following declarations are invalid:

DECLARE MYFILE FILE STREAM OUTPUT PRINT;
DECLARE ZZZ TYPE( P -> Q );      /* INVALID -
                                 POINTER-QUALIFIED */
DECLARE URFILE TYPE( MYFILE );   /* INVALID - MYFILE IS
                                    CONSTANT */
DECLARE XXX TYPE( AAA(8) );      /* INVALID - HAS
                                    SUBSCRIPT LIST */
DECLARE YYY TYPE( FUN( ) );      /* INVALID -
                                    HAS ARGUMENT LIST */

The type definition cannot have the TYPE attribute, nor can it be any of the following:

  • A parameter
  • A member
  • Any structure declared with the TYPE attribute.

For example, the following declarations are invalid:

EXPROC: PROCEDURE( XYZ );
   DECLARE XYZ FIXED BIN(15),
      AAA TYPE( XYZ );/* INVALID - XYZ IS A PARAMETER */

   DECLARE INT FIXED BIN(15),
      B TYPE(INT),
      Y TYPE(B); /* INVALID - B IS TYPED */

   DECLARE 1 STRUCA,
      2 PROG TYPE (INT),
      2 NAMES CHAR(80);
      STRUCT1 TYPE(STRUCA),
      STRUCT2 TYPE(STRUCT1.NAMES); /* INVALID - NAMES IS
                                 IN TYPED STRUCTURE */

The reference in TYPE(reference) must not directly or indirectly refer to the variable that is declared, because then a circular definition will be created.

For example, the following declarations are invalid:

DECLARE 1 PROG,
   2 MOD CHAR(80),
   2 INT FIXED BIN(15),
   2 STRUCZ TYPE(PROG);/* INVALID - DIRECTLY CIRCULAR */

DECLARE 1 STRUCA,
   2 MOD CHAR(80),
   2 INT FIXED BIN(15),
   2 STRUCA TYPE(STRUCB); /* INVALID - INDIRECTLY
                           CIRCULAR */

DECLARE 1 STRUCB,
   2 MOD CHAR(80),
   2 INT CHAR(80),
   2 STRUCA TYPE(STRUCA); /*INVALID - INDIRECTLY
                           CIRCULAR */
Parent topic: TYPE


Examples of the TYPE Attribute

The following declarations are examples of other ways the TYPE attribute can be used:

DECLARE INT FIXED BIN(31);

/* DEFINE AN OPERATION ON CHARACTERS */
DECLARE RADIANS ENTRY( TYPE(INT), TYPE(INT) )
RETURNS( TYPE(INT) );

/* DEFINE ABSTRACT DATA TYPE */
DECLARE 1 LIST,
      2 HEAD POINTER,
   2 TAIL POINTER;

/* DEFINE OPERATION ON 'LISTS' */
DECLARE EXTEND_LIST ENTRY( TYPE(LIST),POINTER )
       RETURNS( TYPE(LIST) );

/* DEFINE AN ABSTRACT DATA TYPE */
DECLARE 1 COMPLEX_INTEGER,
   2 REAL TYPE( INTEGER ),
   2 IMAGINARY TYPE( INTEGER );

/* DEFINE OPERATIONS ON COMPLEX_INTEGER */
DECLARE (CIADD, CISUB, CIDIV, CIMUL)
   ENTRY( TYPE(COMPLEX_INTEGER),
            TYPE(COMPLEX_INTEGER) )
   RETURNS( TYPE(COMPLEX_INTEGER) );
Parent topic: TYPE


UNALIGNED

Abbreviation: UNAL

UNALIGNED is a data type attribute that controls the storage boundary of data.

UNALIGNED is an optional part of the data type specification. Its presence allows the Compiler to align the data at the next available bit or byte, rather than on implementation-defined storage boundaries. This can reduce storage requirements.

Parent topic: Attributes of DECLARE Statements
Related information
ALIGNED and UNALIGNED Attributes
Bit-String Data


UNION

UNION is an attribute applied to a structure, which causes all immediate members of that structure to occupy the same memory locations. An immediate member is any member having a level number greater than its containing structure, equal to the level number of its fellow members, and less than the level of members it contains. Typically, an immediate member has a level number that is one greater than its containing structure.

All members of a UNION will start at the same address. If extra bytes are required for proper alignment of one member, those bytes will appear before the beginning of the structure, that is, before all other members. The size of the UNION will be the size of its largest member.

In the following example, the 30-character ADDRESS_STRING and the members of ADDRESS_PIECES occupy the same memory. Changing ADDRESS_PIECES.CITY changes ADDRESS_STRING:

DECLARE
   1 ADDRESS UNION,
      2 ADDRESS_STRING CHARACTER(30),
      2 ADDRESS_PIECES,
            3 NUMBER CHARACTER(6),
            3 STREET CHARACTER(12),
            3 CITY CHARACTER(12);

In the following example, the data can be examined as 16 individual bits or as a single entity comprising one fixed binary number.

1 NUMBER UNION,
   2 FIXED_NUM FIXED BINARY(15),
   2 FIXED_NUM_BIT BIT(16);
Note: Code based on a particular representation of data types is highly machine-dependent and should be used cautiously.
Parent topic: Attributes of DECLARE Statements
Related information
Storage Sharing


UPDATE

UPDATE is a file description attribute that indicates that the file with which it is associated is to be used for both input and output.

UPDATE may be given in the declaration of a file constant or in an OPEN statement, but it must not be specified in the declaration of a file variable.

Parent topic: Attributes of DECLARE Statements
Related information
OPEN


VALUE

VALUE can be used as an attribute in an ENTRY declaration, or can be applied to a parameter.

  • When used in a parameter descriptor in an ENTRY declaration, the VALUE attribute is a storage class and scope attribute that specifies that the corresponding argument is to be passed by immediate value. (For more information on using VALUE in a parameter descriptor, see the section ENTRY.)
  • If applied to a parameter, the VALUE attribute is an argument-passing attribute. (As an argument-passing attribute, VALUE indicates that the value and not the address of the parameter has been passed to the procedure. A new value assigned to a parameter with the VALUE attribute does not change the value of the argument in calling procedures.)

The VALUE attribute may only be applied to a parameter and parameter descriptors of the following types:

Fixed Binary(n) | where n ? 31
Float Binary(n) | where n ? 23 (when calling PL/I)
Float Binary(n) | where n ? 52 (when calling non-PL/I)
Aligned Bit(n) | where n ? 32
Character |
Pointer |
Entry |

The VALUE attribute is ignored if it is applied to a variable that is not a parameter.

If a parameter is multi-positional (appears in one or more of the PROCEDURE and ENTRY statements in a particular procedure) it may not have the VALUE attribute applied to it.

When a procedure is called from an Open PL/I procedure, the VALUE attribute should be applied only to a parameter whose corresponding parameter descriptor was also declared with VALUE in the calling procedure's ENTRY declaration in the called procedure. For example:

P: PROCEDURE( A, B, Q);
DECLARE
   A FIXED BIN(31) VALUE,
   (B,C) FIXED BIN(15),
   Q POINTER VALUE,
   X FIXED BIN(15) BASED (Q);
B = A + 2;
A = 2 * B;
C = X;
ALLOCATE X SET(Q);
X = A + C;
END;

In this example, the value passed by A is incremented by 2 and returned to the calling procedure through B. The assignment of 2 * B to A does not affect the calling procedure; the value of the first argument of the CALL is unchanged by the assignment to A in the called procedure. Similarly, the value of the argument in the calling procedure that corresponds to Q is not changed by the ALLOCATE statement.

Parent topic: Attributes of DECLARE Statements
Related information
ENTRY


VARIABLE

VARIABLE is an entry name attribute that specifies that the declared name is a file or entry variable rather than a file name or procedure name.

Parent topic: Attributes of DECLARE Statements
Related information
Entry Data
File Data
ENTRY


VARYING

Abbreviation: VAR

VARYING is a character-string data type attribute that specifies that the string values may have any length that does not exceed the declared length.

For more information on this attribute, see the section Character-String Data in the chapter Data Types.

Parent topic: Attributes of DECLARE Statements
Related information
Character-String Data


References

  • Introduction
  • Simple and Subscripted References
  • Structure Qualified References
  • Locator Qualified References
  • Procedure References
  • Built-In Function References
  • Variable References
  • Reference Resolution
Parent topic: Open PL/I Language Reference Manual


Introduction

A reference is the declared name of a variable or constant, along with any subscript list, pointer qualifier (–>), or structure qualifier necessary to indicate its purpose. References to procedures or built-in functions may also include an argument list.

Examples:

X
Y(5,K)
F(Z*5+B,SQRT(Z))
P->S.A(K)
Q.NEXT->NODE.FIELD1

The first example is a simple reference, and the second is a subscripted reference. The third example is a reference to a procedure. The fourth and fifth examples are pointer qualified references.

A reference is associated with a declaration according to the scope of the declared name. The process of associating a reference with a declaration is called reference resolution, and it occurs during compilation of the program.

Parent topic: References


Simple and Subscripted References

A simple reference is a name without any subscripts, pointer qualifiers, structure names, or argument lists.

A subscripted reference is a name that has been declared as an array, followed by a parenthetical list of subscript expressions. Each subscript expression must produce an integer fixed-point value that lies within the lower and upper bounds specified for that dimension in the array declaration. The number of subscript expressions must be equal to the number of dimensions.

An asterisk subscript refers to the entire array bounds range for the corresponding dimension. Subscripts containing asterisks do not refer to a single data item. Thus, such references are array expressions, not element expressions.

A cross-section of an array may reference two or more elements that are not stored adjacently in memory. Such storage is referred to as non-connected storage.

DECLARE A(5,5) FLOAT;
DECLARE B(10) FLOAT;
   .
   .
   .
A(K*2,*) = B(1);
A(*,*) = 5;

In the preceding example, both A (K*2,*) and B (1) are subscripted references; K is a simple reference. A(*,*) references the entire array and A(K*2,*) references the entire 2Kth row.

Parent topic: References


Structure Qualified References

Because the names of structure members (with the exception of the major structure name) can be redeclared or reused within the same block, their scopes overlap. If a member's name has been redeclared within the same block, any reference to that member must be qualified by the name of its containing structure. If the containing structure's name has been redeclared within the same block, it must be qualified, in turn, by the name of its containing structure until an unambiguous reference is created.

A structure qualified reference is a sequence of names written left-to-right in order of increasing level-numbers. The names are separated by periods, and blanks may be written around the periods. The sequence need not include all containing structure names, but it must include sufficient names to make the reference unique. For example:

DECLARE       1  S,
     2          A  FIXED,
     2          B,
     3          A  FLOAT,
     3          C  FLOAT;

In this example, a reference to A is ambiguous because the scope of A FLOAT overlaps the scope of A FIXED. A structure qualified reference to S.A refers to A FIXED. A structure qualified reference to B.A refers to A FLOAT, as does S.B.A.

A structure qualified reference that includes the name of each containing structure from the major structure down to the member is a fully qualified reference. If the name of one or more of the containing structures is omitted, the reference is a partially qualified reference. In the previous example, B.A is a partially qualified reference, and S.B.A is a fully qualified reference, as are S.A, S.B, and S.B.C.

Subscripts can be used anywhere within a structure qualified reference, but it is best to write each set of subscripts immediately following the name that has the corresponding bounds declared for it. For example:

DECLARE     1   S(10),
     2        A    FIXED,
     2        B(3)    FLOAT,
     2        C(3),
     3        D   POINTER;

In the previous example, a reference to S(K).A and a reference to S.A(K) are equivalent, but a reference to S(K).A is preferred. Other recommended references are S(K).B(J) and S(K).C(J).

Parent topic: References


Locator Qualified References

A reference to a based variable may be qualified by a reference to a pointer or offset variable. For example:

DECLARE A(10) FLOAT BASED;
DECLARE P POINTER;

In this example, P –>A and P –>A(K) are pointer qualified references to the based variable A.

Since a pointer variable may itself be based, multiple qualification is possible. For example:

DECLARE     1 NODE BASED,
            2 NEXT POINTER,
            2 VALUE FLOAT;
DECLARE HEAD POINTER;

In this example, HEAD –>NODE.NEXT–>NODE.VALUE is a pointer qualified reference to NODE.VALUE. It is qualified by NODE.NEXT, which is, in turn, qualified by HEAD.

Pointer-valued functions and pointer-valued built-in functions may also be used as pointer qualifiers.

DECLARE NEXT_NODE ENTRY RETURNS(POINTER);

In this example, NEXT_NODE() –>NODE.VALUE is a pointer qualified reference to NODE.VALUE whose qualifier is a function reference.

When addressing data allocated in an area, an offset variable can be used as a locator qualifier in the same fashion as the pointer is in the above examples. The offset value will be implicitly converted to a pointer value by adding the address of the area specified in the OFFSET attribute of its declaration.

Parent topic: References
Related information
Offset Data


Procedure References

A procedure reference is any reference followed by an argument list consisting of a parenthetical list of expressions separated by commas or followed by an empty argument list (). A procedure reference that returns a value is called a function reference. A procedure reference that does not return a value is called a subroutine reference.

If an argument list or empty argument list is given, the referenced name must be declared as an entry either by appearing as a label prefix on a PROCEDURE statement or by a DECLARE statement. Unless the reference is part of a CALL statement, the referenced entry must return a value. If the reference is part of a CALL statement, the entry must not return a value; therefore, a procedure that returns a value must always be called as a function, and a procedure that does not return a value must always be called as a subroutine.

A name declared as an entry is called only when it is referenced with an argument list or when it is called by a CALL statement. A function that has no parameters must be referenced with an empty argument list.

Except when it is part of a CALL statement, a reference to an entry written without an argument list is a reference to the entry value, rather than a function reference that calls the entry.

The following example demonstrates a range of procedure references.

DECLARE F ENTRY RETURNS(POINTER);
DECLARE G ENTRY(FIXED) RETURNS(FLOAT);
DECLARE V ENTRY VARIABLE RETURNS(POINTER);
DECLARE P POINTER, X FLOAT;
   .
   .
   .
P = F();
V = F;
X = G(0);

In this example, a reference to F() calls F and produces a pointer value. A reference to F is a reference to the entry value of F and can be assigned to the entry variable V. A reference to G is also a reference to an entry value and does not call G. G is called by references containing an argument list.

An array of entry variables may be referenced with subscripts and with an argument list. In this case, the argument list follows the subscript fist, as shown in the following example:

DECLARE E(5) ENTRY(FIXED) VARIABLE
      RETURNS(POINTER);

According to E's declaration, E is a reference to the entire array of entry values. E (k) (j) is a pointer valued function reference that calls E (kf, passing it the argument j. E (k) is an entry value that may be passed to an entry parameter or assigned to an entry variable. If E had been declared without parameters, E (k) would have to be invoked using an empty argument list — E(k) () .

Parent topic: References


Built-In Function References

A reference to a built-in function always produces the value of that function and is never an entry value. Built-in functions cannot be assigned to entry variables or passed as arguments to entry valued parameters.

Built-in functions that take arguments do not have to be declared, but built-in functions that take no arguments, such as NULL and ONCODE, must either be referenced with an empty argument list () or must be declared with the BUILTIN attribute.

Parent topic: References


Variable References

A reference to a variable may occur in a context that expects a value, or it may occur in a context that assigns a value to the variable. If a value is expected, the variable must have previously been assigned a value or must be a variable declared with the INITIAL attribute. A reference to the value of a variable that has no value produces unpredictable results.

The left side of an assignment operator or the format-list of a GET statement causes assignment to a variable. Using a variable as the argument to a procedure or function call may also cause assignment to the variable if the corresponding parameter is given a value. The ADDR, HBOUND, LBOUND, DIMENSION, and LENGTH built-in functions reference a variable but do not expect a value. (However, LENGTH of a varying string variable does require that the string variable have a value.) A variable passed by reference to a parameter does not need to have a value if the parameter is not expected to have a value upon entry to its procedure. The record I/O statements copy a variable's storage and do not require the variable to have a value.

Parent topic: References


Reference Resolution

The following is the sequence of steps taken by the Compiler to resolve references:

  1. Determine the initial block in which the search for the declaration begins.
  2. Find the referenced declaration and the block to which it belongs. Find the activation associated with that block.
  3. Evaluate the locator qualifier (if any) to obtain a pointer value.
  4. Evaluate the basis reference (if the reference is to a defined variable) and pointer.
  5. Determine all the extents (if any) of the referenced variables.
  6. Interpret the subscripts (if any).
  7. Invoke the procedure (if any).

Remember the following points when preparing for reference resolution:

  • A fully or partially qualified structure reference is applicable to declarations of structures that include the same hierarchy of names as is used in the structure reference. A simple or subscripted reference to a name is applicable to any declaration of the name.
  • A reference is resolved by finding the innermost block that contains any applicable declaration. If no containing block has an applicable declaration, the reference is invalid. If the block has only one applicable declaration, the reference is resolved to that declaration. If the block has more than one applicable declaration, the reference must be fully qualified to cite only one declaration in that block; otherwise, the reference is ambiguous and invalid.
  • Once a block containing an applicable declaration is found, no containing blocks are searched in an attempt to resolve a reference.
  • The presence of subscripts, arguments, or a locator qualifier has no effect on the resolution of a reference and cannot make an ambiguous reference unique.
  • A simple or subscripted reference to a name X is considered to be a fully qualified reference to a nonmember declaration of X. This means that if a member and a nonmember are declared to have the name X in the same block, a reference to X is resolved to the nonmember. The member must be referenced using a structure qualified reference.
Parent topic: References


Expressions

  • Introduction
  • Order of Evaluation
  • Array Expressions
  • Types of Operators
Parent topic: Open PL/I Language Reference Manual


Introduction

An expression is a representation of a value or of the computation of a value. Expressions are classified as either element (scalar) expressions or array expressions.

Element expressions represent element values, including elementary names within a structure or a subscripted name that specifies a single element of an array. Array expressions represent either an entire array or a cross-section of an array. Element variables and array variables may be used in the same expression.

Expressions are used for the following reasons:

  • To indicate constant values or scalar variables. For example:
    D = 40;
  • To perform algebraic or logical calculations on constants or variables. For example:
    A = B + 10;
  • To compare values of two or more expressions and obtain a Boolean result. For example:
    IF C < D THEN E = 12;
  • To concatenate bit-string or character-string values. For example:
    ADDRESS = CITY | STATE;

All expressions, except for single constants and references, are made up of an operator and one or more operands. An operator requires specific types of operands (arithmetic, character-string, or bit-string) and produces a result of a specific type. Operands can be constants, variable references, user-defined function references, built-in function references, or other expressions that match the type required by the operator.

Operators can be either infix or prefix. An infix operator is written between its two operands, and a prefix operator is written in front of its operands, as shown in the following table of operators.

Operator | Category | Example
+ – * / ** | arithmetic infix | B+C
+ – | arithmetic prefix | -C
= ^= > < >= <= ^< ^> | relational | B=C
| or & | bit-string infix | BIC
^ | bit-string prefix | ^C
|| or !! | concatenate | B||C

One expression can contain both an infix and a prefix operator. For example:

A*-B
Note:

Open PL/I supports the use of a tilde (~) as an operator symbol equivalent to a caret (^).

Open PL/I supports the use of an exclamation point (!) as an operator symbol equivalent to a single bar (|), and a double exclamation point (!!) as equivalent to a double bar (||).

Parent topic: Expressions


Order of Evaluation

When an expression contains more than one operator, the order in which each expression is evaluated is determined by the presence or absence of parentheses and by the priority of the expression's operators.

The following table shows the operators in order of descending priority. Operators listed on the same line have equal priority.

Operators
**
^ – (prefix unary operators)
*/
+ – (binary operators)
|| or !!
= ^= > < >= <= ^< ^>
&
|
Note:

Open PL/I supports the use of a tilde (~) as an operator symbol equivalent to a caret (^).

Open PL/I supports the use of an exclamation point (!) as an operator symbol equivalent to a single bar (|), and a double exclamation point (!!) as equivalent to a double bar (||).

In expressions without parentheses, operators are evaluated in order of decreasing priority. For example:

B**3+C<D

is evaluated as:

((B**3)+C)<D

Operations of equal priority without parentheses are generally evaluated from left to right. For example:

A*B/C

is evaluated as:

(A*B)/C

The only exception to this rule is the prefix operators and the exponentiation operator (**), which are evaluated from right to left. For example:

A**B**C

is evaluated as:

A**(B**C)

If the expression contains parentheses, the expression within the parentheses is evaluated first according to the previous rules of priority. Its resulting value is used as a single operand. For example:

A+B*C

is evaluated as:

A+(B*C)

because * has higher priority than +; however, parentheses can be used to force another order:

(A+B)*C

If the result of an expression can be determined without evaluating all of its operands, the operands are not necessarily evaluated. A program that depends on all operands being evaluated is invalid and may produce unexpected results when compiled with optimization enabled, or when moved to another implementation of PL/I. Likewise, a program that depends on some operands not being evaluated is invalid. For example:

IF A = 0 | B/A = 5 THEN …

In this example, the Compiler can evaluate B/A before checking to see if A = 0, and the complete expression may produce a ZERODIVIDE condition. However, the order of evaluation is not guaranteed by the Compiler. In particular, if A is in fact 0, the value B/A may or may not be computed. This optimization, in which parts of a conditional expression may cause other "unnecessary" parts not to be evaluated, is called "short circuit evaluation." Such evaluation is done at the discretion of the Compiler and its optimizer. To force A = 0 to be evaluated first, rewrite the example as follows:

IF A ^= 0 THEN
   IF B/A ^= 5 THEN
      GOTO L;
      .
      .
      .
   L:

The remainder of this chapter describes each type of operator.

Parent topic: Expressions


Array Expressions

Array expressions can be used only in assignment statements. The result of the evaluation of an array expression is an array. Operations on arrays are performed element by element in row-major order. All arrays referred to in an array expression must have identical dimensions and bounds. Arithmetic operators excluding ** (exponentiation) can be used for array cross-sections.

Array expressions can be used with these operators:

Operator | Operation
prefix + | Plus
prefix - | Minus
+ | Addition
- | Subtraction
* | Multiplication
/ | Division
= | Equal
^= | Not Equal
> | Greater than
< | Less than
>= | Greater than or equal to
<= | Less than or equal to
& | and
| | inclusive or
^ | not (complement)
|| or !! | Concatenate

Array expressions can be used with these built-ins.

ABS | HBOUND | STRING
ALL | LBOUND | SUBSTR
ANY | LOWERCASE | SUM
BOOL | PROD | TRANSLATE
DIMENSION | REVERSE | UPPERCASE

Array expressions may include any of the following:

  • Prefix and/or infix operators
  • Element variables
  • Array variables
  • Constants

The operation and data conversion rules are the same as for element expressions.

  • Prefix Operators and Arrays
  • Infix Operators and Arrays
  • Array and Element Operations
  • Array and Array Operations
Parent topic: Expressions


Prefix Operators and Arrays

An array expression that contains prefix operators results in an array with identical bounds, with each element reflecting the result of the operation performed on the original element. For example:

Array A before operation | Operation | Array A after operation
1 | 2 | -3 | -A | -1 | -2 | 3
4 | 5 | 6 |  | -4 | -5 | -6
7 | 8 | -9 |  | -7 | -8 | 9
Parent topic: Array Expressions


Infix Operators and Arrays

Array expressions contain an array, an infix operator, and either an element or another array. The result of such an expression is an array with identical bounds and dimensions that reflect the result of the operation on the elements of the original array.

Parent topic: Array Expressions


Array and Element Operations

An array expression that contains an infix operator, array, and element results in an array with identical bounds, with each element reflecting the result of the operation performed on the original array element and the single element. For example:

Array A before operation | Operation | Array A after operation
1 | 2 | -3 | A = A * 2 | 2 | 4 | -6
4 | 5 | 6 |  | 8 | 10 | 12

The element operand may be an element of the array:

Array A before operation | Operation | Array A after operation
1 | 2 | -3 | A = A * A(1,3) | -3 | -6 | 9
4 | 5 | 6 |  | 36 | 45 | 54

In the preceding example, the element A(1,3) was -3 in the original array. When that element was operated on and resulted in 9, 9 was used in the operations on the rest of the array.

Parent topic: Array Expressions


Array and Array Operations

An array expression that contains an infix operator and two arrays results in an array with identical bounds, with each element reflecting the result of the operation performed on the corresponding elements of the original arrays. For example:

Array A | * | Array B | = | Result
1 | 2 | -3 |  | 2 | 3 | 4 | 2 | 6 | -12
4 | 5 | 6 |  | 5 | 6 | 7 | 20 | 30 | 42
Note:

This is not the same as mathematical matrix multiplication.

Parent topic: Array Expressions


Types of Operators

The types of operators are arithmetic, relational, bit-string, and concatenate.

  • Arithmetic Operators
  • Relational Operators
  • Bit-String Operators
  • The Concatenate Operator
Parent topic: Expressions


Arithmetic Operators

The arithmetic operators and the operations they stand for are:

Operator | Operation
prefix + | Plus
prefix – | Minus
+ | Addition
– | Subtraction
* | Multiplication
/ | Division
** | Exponentiation

There are also compound assignment operators. These are:

+= -= *= /=

Each of the following pairs of statements are equivalent:

a = a + b;
a += b;
a = a - b ;
a -= b;
a = a * b;
a *= b;
a = a / b;
a /= b;

The arithmetic operators require arithmetic operands. Although these operands can be of different arithmetic types, all operations must be performed on objects of the same type. Pictured values are converted to fixed decimal values, but other nonarithmetic values must be converted to arithmetic values by one of the conversion built-in functions, such as BINARY, DECIMAL, FIXED, or FLOAT.

If the data types of two operands of an infix operator (other than **) differ, the operands are converted to a common arithmetic data type, as shown in the following table.

One Operand | Other Operand | Common Operand
fixed | float | float
binary | decimal | binary (for floating-point or integer result)
binary | decimal | decimal (for fixed-point noninteger result)

All arithmetic operations except for exponentiation are performed in the derived type of the two operands. (For the precision resulting from the conversion of an operand to its derived type, see the table in Arithmetic to Arithmetic Conversion.) Though two converted operands may have the same derived base and scale, they may each have different values for p and q (scale and base, respectively).

All arithmetic operations, including exponentiation, produce a result that has the same data type as the type in which the operations are performed. In all operations but exponentiation, the data type is derived.

If an arithmetic operation is performed in floating point, the precision of the result is the maximum of the precisions of the two operands for binary operators, and is equal to the precision of the operand for unary operators. If this is not the desired result precision, use the FLOAT() built–in function to increase the precision of one or both of the operands.

An exponentiation operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

The remainder of this topic defines a series of rules, called fixed-point precision rules, which effectively allow the result of an expression to be formed by aligning the decimal points of the two operands to produce a fixed-point result. The number of digits in the result is always limited by the maximum number of digits allowed by the implementation for the result base; however, as many fractional digits as are allowed by the implementation are preserved, except for the result of divide. (For details on this implementation, see your Open PL/I User's Guide.) For divide, all integer quotient digits are preserved and as many fractional digits as can be allowed by the implementation are preserved.

The results of all arithmetic operations, except for exponentiation, always have a precision that is the maximum of the precisions of the converted operands.

The rules for determining the precision of the results of arithmetic expressions are as follows:

  1. Plus and minus produce a result whose data type is the same as the converted operand.
  2. Add and subtract of fixed-point values produce a fixed-point result whose base is the common base and whose precision is:
    FIXED(P,Q)±FIXED(R,S)

    and yields

    P=MIN(N,1+MAX(P-Q,R-S)+MAX(Q,S))
Q=MAX(Q,S)

    where:

    N is the implementation's maximum allowed precision for fixed-point values of the result base (described in your Open PL/I User's Guide).

    (P,Q) is the converted precision of the first operand

    (R,S) is the converted precision of the second operand

  3. For integer operands (Q=0 and S=0), the result precision formula reduces to:
    FIXED(P,0)±FIXED(R,0)

    and yields

    P=MIN(N,1+MAX(P,R))
Q=0
  4. Multiplication of fixed-point values produces a fixed-point result whose base is the common base and whose precision is:
    FIXED(P,Q)*FIXED(R,S)

    and yields

P=MIN(N,P+R+1) Q=Q+S

    where:

    N is the implementation's maximum allowed precision for fixed-point values of the result base (described in your Open PL/I User's Guide).

    (P,Q) is the converted precision of the first operand,

    (R,S) is the converted precision of the second operand

  5. For integer operands (Q=0 and S=0), the result precision formula reduces to:
    FIXED(P,0)/FIXED(R,0)

    and yields

    P=MIN(N,P+R+1)
Q=0
  6. Division of fixed-point values is possible only if both operands are fixed decimal. The result is a fixed decimal value of precision:
    FIXED(P,Q)/FIXED(R,S)

    and yields

P=N
Q=N-P+Q-S

    where:

    N is the maximum fixed-point decimal precision

    (P,Q) is the precision of the first operand

    (R,S) is the precision of the second operand

  7. For integer operands (Q=0 and S=0), the previous formula reduces to:
    FIXED(P,0)/FIXED(R,0)

    and yields

    P=N
Q=N-P

    The formula produces a result quotient that has sufficient precision for all integral digits of the quotient and as many fractional digits as are allowed by the implementation (for Open PL/I's limits, see your Open PL/I User's Guide).

  8. The result of a division operation may have a large fractional part, and in such instances, may not be able to be added or multiplied with another value because alignment of the decimal point with the other value produces a result that is too big for LPI-PLI to support.
  9. The ADD, DIVIDE, and MULTIPLY built-in functions can be used to add, divide, and multiply fixed-point binary values, as well as fixed-point decimal values. These functions provide you with control over the result precision. See the section DECIMAL Function in the chapter Open PL/I Built-Ins.
  10. Exponentiation produces a result whose base, scale, and precision depends on the operands. The result is determined as follows:

    Case 1:

    If the first operand is fixed-point and the second operand is an integer constant whose value is Y, and if (P+1)*Y-1 does not exceed N, the result is a fixed-point value whose base is that of the first operand and whose precision is:

    FIXED(P,Q)**Y     /* Y is an integer constant */

    and yields

    P=(P+1)*Y-1
Q=Q*Y
P<=N

    where N is the maximum precision allowed for fixed-point values of the base of the first operand, (P,Q) is the precision of the first operand, and Y is the value of the second operand.

    Case 2:

    If the second operand is a fixed-point integer value, but Case 1 does not apply, the result is a floating-point value whose base is the base of the first operand and whose precision is:

    P=MIN(N,P)

    where N is the maximum precision allowed for floating-point values of the resulting base and P is the precision of the first operand.

    Case 3:

    If neither Case 1 nor Case 2 applies, the result is a floating-point value having the common base and whose precision is:

    P=MIN(N,MAX(P,R))

    where N is the maximum precision allowed for floating values having the result base, P is the converted precision of the first operand, and R is the converted precision of the second operand.

  11. The result of exponentiation is normally the first operand raised to the power of the second operand. The following are exceptions to this general rule.

    Given X is the value of operand one and Y is the value of operand two:

    • If X = 0 and Y <= 0, ERROR is signaled.
    • If X< 0 and Case 1 does not apply, ERROR is signaled.
Parent topic: Types of Operators
Related information
DECIMAL Function
Arithmetic to Arithmetic Conversion


Relational Operators

The relational operators and the operations they stand for are as follows:

Operators | Operations
= | Equal
^= | Not equal
> | Greater than
< | Less than
>= | Greater than or equal to
<= | Less than or equal to
^< | Not less than (equivalent to >=)
^> | Not greater than (equivalent to <=)
Note:

Open PL/I supports the use of a tilde (~) as an operator symbol equivalent to a caret (^).

The relational operators test the relationship of two operands. The result is always a Boolean value (a bit string of length 1). If the comparison is true, the resulting value is '1'B; if the comparison is false, the resulting value is '0'B. All relational operators are infix operators.

All operands used with relational operators must be scalar. If either operand is an arithmetic value or a pictured value, the operands are converted to a common arithmetic type as if they were operands of an add operator. If one operand is a pointer value and the other is an offset value, the offset is converted to a pointer, but only for = and ^= comparisons. In all other cases, the data types of the two operands must be equivalent.

When determining if two data types are equivalent, the ALIGNED, VARYING, RETURNS, UNALIGNED, VARIABLE, and string length attributes are ignored. Label, entry, file, and pointer data may be compared only for equality or inequality. Arithmetic and string data may be compared using any relational operator.

Arithmetic and pictured values are compared algebraically.

Character-string values are compared from left-to-right one character at a time until an inequality is found. The shorter value is effectively extended on the right with blank characters to make it the length of the longer value. Characters are compared using the collating sequence of the computer.

Bit-string values are compared from left-to-right one bit at a time until an inequality is found. The shorter value is effectively extended with zero bits on its right until it is the length of the longer value.

Pointer values are equal only if they address the same storage location.

Label and entry values are equal only if they designate the same statement and the same stack frame.

File values are equal only if they designate the same file control block.

Only comparisons of = and ^= are allowed for offset values. Area variables cannot be compared.

Wide character-string values are compared from left-to-right one wide character (or "byte-pair") at a time until an inequality is found. The shorter value is effectively extended on the right with blank characters (0x0020) to make it the length of the longer value. Characters are compared using the binary value of the byte-pair.

Parent topic: Types of Operators


Bit-String Operators

The bit-string operators and the operations they stand for are as follows:

Operators | Operations
& | and
| | inclusive or
^ | not (complement)
Note:

Open PL/I supports the use of a tilde (~) as an operator symbol equivalent to a caret (^).

Open PL/I supports the use of an exclamation point (!) as an operator symbol equivalent to a single bar (|).

Bit-string operators require bit-string operands. Operands of other data types must be converted to bit-string values using the BIT built-in function.

The infix operators & and | operate on operands of dissimilar length by effectively extending the shorter value to the length of the longer value. This is done by appending zero bits to the right end of the shorter value.

The result of ^ is a bit string whose bits are the complement of the bits in the operand; that is, each 0 bit becomes a 1 bit and each 1 bit becomes a 0 bit.

The result of & and | is a bit string whose length is that of the larger operand. Each bit of the result is listed as follows:

First Operand | Second Operand | & | |
0 | 0 | 0 | 0
0 | 1 | 0 | 1
1 | 0 | 0 | 1
1 | 1 | 1 | 1

For instance, if X is '01011'B and Y is '11001'B, ^X produces '10100'B, X&Y produces '01001'B, and X | Y produces '11011'B. X&'11'B would produce '01000'B.

Parent topic: Types of Operators
Related information
BIT Function


The Concatenate Operator

The concatenate operator, || or !!, is used to concatenate two strings to produce a string result.

The compound assignment operator ||= is also supported. The following two statements are equivalent:

s = s || s1;
s ||= s1;

If both operands are bit strings, the concatenate operator produces a bit-string result. Otherwise, both operands are converted to character strings, and the concatenate operator produces a character-string result. If either operand is a wide character-string, both operands are converted to type WIDECHAR, and the result is WIDECHAR. For example:

C = ‘004100420043’Wx;     /* wide ‘ABC’ */
D = ‘004400450046’Wx;     /* wide ‘DEF’ */

C || D produces WIDECHAR string containing 0x004100420043004400450046 (length = 6).

The length of the string result is the sum of the lengths of the converted operands, as shown in the following example:

A = 'ABC';
B = 'XYZ';

In the previous example, A | | B produces ABCXYZ, and A | ! 5 produces ABC     5. The conversion rule that produces the blanks is explained in the topic Arithmetic to Character-String Conversion in the chapter Data Type Conversions.

Parent topic: Types of Operators
Related information
Arithmetic to Character-String Conversion


Data Type Conversions

  • Introduction
  • Arithmetic to Arithmetic Conversion
  • Arithmetic to Bit-String Conversion
  • Arithmetic to Character-String Conversion
  • Bit-String to Arithmetic Conversion
  • Bit-String to Character-String Conversion
  • Character-String to Arithmetic Conversion
  • Character-String to Bit-String Conversion
  • Format Controlled Conversion
  • Pictured to Arithmetic Conversion
  • Pictured to Bit-String Conversion
  • Pictured to Character-String Conversion
  • Conversion to Pictured Data
Parent topic: Open PL/I Language Reference Manual


Introduction

Each arithmetic, pictured, or string value can be converted to another value whose data type is any other arithmetic, pictured, or string data type. Conversion is not possible for data other than arithmetic, pictured, or string data.

Conversions occur as a result of using the assignment, arithmetic, relational, or concatenate operators; from the use of certain built-in functions; from GET/ PUT statements during parameter passing; and from statement options such as KEY and KEYFROM.

Each conversion begins with a source value to be converted and a complete or partial data type called the target data type. The target data type is determined by the context that caused the conversion. For example, the data type of the variable on the left side of the assignment operator provides the target data type for the conversion that is to be performed for that assignment. A partial target data type may result from the use of a conversion built-in function such as FIXED, FLOAT, BINARY, DECIMAL, BIT, or CHARACTER, as well as from other contexts, such as the use of arithmetic operators.

The conversion rules described in the section Arithmetic Operators define the target data type for conversions that result from arithmetic or relational operators. The section The Concatenate Operator gives the target data type for conversions that result from using the concatenate operator. Conversion between pointers and offsets is discussed in the section Locator Data.

The following table shows the specific conversions described in this chapter.

Data Type | Conversion
Arithmetic | Arithmetic to Arithmetic Arithmetic to Bit string Arithmetic to Character string
String | Bit string to Arithmetic Bit string to Character string Character string to Arithmetic Character string to Bit string Format Controlled
Pictured | Pictured to Arithmetic Pictured to Bit string Pictured to Character string Conversion to Pictured Data

The CEIL function used in many of the conversion rules gives the smallest integer that is greater than or equal to the function's argument. For example,

CEIL(1.1)

produces the value two.

Parent topic: Data Type Conversions
Related information
Arithmetic Operators
The Concatenate Operator
Locator Data


Arithmetic to Arithmetic Conversion

Arithmetic to arithmetic conversion assigns any arithmetic data type to any other arithmetic data type. This type of conversion occurs most frequently as a result of using operands of differing arithmetic types in an arithmetic or relational operation. In all cases, the target base and scale are supplied by the conversion rules of the operator or built-in function, but the target precision is not supplied.

If a target precision is not supplied, it is determined from the data type of the source value (listed vertically) and the target base and scale (listed horizontally), as shown in the table below.

Target Base And Scale, Precision r[,s] | Source Base And Scale, Precision p[,q]
 | Fixed Binary | Fixed Decimal | Float Binary | Float Decimal
Fixed Binary | r = p | r = MIN(CEIL (p*3.32)+1,n) | * | *
Fixed Decimal | r= MIN(CEIL(p/3.32)+1, n) | r= p | * | *
Float Binary | s=0 r =MIN(p,n) | s = q r= MIN (CEIL(p*3.32),n) | r= p | r=MIN(CEIL(p*3.32),n)
Float Decimal | r=MIN (CEIL(p/3.32),n) | r=MIN(p,n) | r = MIN (CEIL(p/3.32),n) | r= p
* | These conversions arise only in cases where the target precision is explicitly known, as in the case of assignment to a fixed-point variable.
n | The maximum number of digits allowed by Open PL/I for the target base and scale. For precision limits, see your Open PL/I User's Guide.

Conversion of a fixed-point decimal value containing a fraction to floating-point or vice versa produces an approximate value. The result is the number in the target scale and precision that is closest to the source value and is produced by rounding at the last binary or decimal digit position.

Conversion of a fixed-point decimal value containing a fraction to a fixed-point value with no fraction or fewer fractional digits results in truncation of excess digits without rounding. Rounding can be performed by using the ROUND, CEIL, FLOOR, or TRUNC built-in functions, as described in the chapter Open PL/I Built-ins.

If the target precision does not provide sufficient digits to hold all integral digits of the converted value, the program is in error. This error is not detected by Open PL/I and may or may not be detected by another implementation of PL/I. If detected, the ERROR condition is signaled. If undetected, the program produces unpredictable results. Programs that contain this undetected error and produce "correct" results may fail when moved to another implementation of PL/I.

The following shows the target precisions given, in the table above, for some common source values and target data types. Note that for some implementations, the target precision may be limited to a value smaller than what is shown here.

Source | Target
Fixed Binary(15) | Fixed Decimal(6,0)
Fixed Binary(31) | Fixed Decimal(11,0)
Float Binary(21) | Float Decimal(7)
Float Binary(52) | Float Decimal(16)
Fixed Decimal(4) | Fixed Binary(15)
Fixed Decimal(7) | Fixed Binary(25)
Float Decimal(6) | Float Binary(20)
Float Decimal(15) | Float Binary(50)
Parent topic: Data Type Conversions
Related information
Open PL/I Built-ins


Arithmetic to Bit-String Conversion

Arithmetic to bit-string conversion converts the absolute value of an arithmetic value to a bit string, but may not produce the result you expect.

The arithmetic source value is first converted to fixed binary(K) where K is determined by the source data type, as shown in the following table.

Source Data Type | Value of K
Fixed Decimal(P,Q) | MIN(N,MAX(CEIL((P-Q)*3.32),0))
Float Decimal(P) | MIN(N,CEIL(P*3.32))
Fixed Binary(P) | (P)
Float Binary(P) | MIN(N,P)

The absolute value of the resulting integer is considered to be a bit string of length K. If the context that caused the conversion supplied a target length, this bit string is extended on the right with zero bits to make it the length of a longer target, or excess bits are truncated from the right to make it the length of a shorter target. The program is in error and may produce unpredictable results if the value of the source is too large to be converted to an integer of precision (K). For example, if V is a Fixed Binary(15) variable with the value of 5, its value when converted to a bit string of length 15 is '000000000000101'B. If the target is Bit(16), the result is '0000000000001010'B, because padding occurs on the right. If the target is Bit(5), the result is '00000'B, because all excess bits are truncated from the right.

Parent topic: Data Type Conversions


Arithmetic to Character-String Conversion

Arithmetic to character-string conversion often arises during list-directed stream output, concatenation, or during assignment to a character string.

The arithmetic source value is first converted to a decimal value having the same scale as the source and with a decimal precision determined by the target precision data shown in the table in Arithmetic to Arithmetic Conversion.

The decimal value whose precision is now (p,q) is then converted to a character string whose value is given by one of the following cases:

  • Case 1
  • Case 2
  • Case 3
Parent topic: Data Type Conversions
Related information
Arithmetic to Arithmetic Conversion


Case 1

If the decimal value is floating-point, the length of the resulting character string is p+n+4, and its value consists of a minus if the value is negative or a blank if it is not negative, followed by the most significant digit of the mantissa, followed by a decimal point, followed by p-1 digits of the mantissa, followed by the letter E, followed by the sign of the exponent, followed by n exponent digits. The number of exponent digits depends on the implementation, but is constant for a given implementation. In Open PL/I, three exponent digits are produced.

  • Examples
Parent topic: Arithmetic to Character-String Conversion


Examples

The values in the above examples could result from conversion of a Float Binary(21) value. Seven digits are produced, because Float Binary(21) converts to Float Decimal(7). For more information, see the table in Arithmetic to Arithmetic Conversion.

Parent topic: Case 1
Related information
Arithmetic to Arithmetic Conversion


Case 2

If the decimal value is fixed-point with no fraction (q=0), the length of the resulting character string is p+3, and its value consists of sufficient blanks to fill the p+3 character result, followed by a minus if the value is negative, followed by the p digits of the decimal value with no leading zeros (the value zero has one zero digit).

  • Examples
Parent topic: Arithmetic to Character-String Conversion


Examples

The values in the previous examples could result from conversion of a Fixed Binary(15) value. The result is nine characters long, because Fixed Binary(15) converts to Fixed Decimal(6), and the result is 6+3 characters long.

Parent topic: Case 2


Case 3

If the decimal value is fixed-point with a fraction (q^=0), the length of the resulting character string is p+3, and its value consists of leading blanks (if needed to fill the p+3 character result) followed by a minus if the value is negative, followed by p-q integral digits with no leading zeros (fractions and the value zero have one integral zero digit), followed by a decimal point, followed by q fractional digits.

  • Examples
Parent topic: Arithmetic to Character-String Conversion


Examples

The values in the previous examples could result from converting a Fixed Decimal(5,2) value.

The extra three characters produced for fixed-point values are intended to allow room for a sign, a zero, and a decimal point.

Parent topic: Case 3


Bit-String to Arithmetic Conversion

Bit-string to arithmetic conversion assigns a bit string to any arithmetic data type.

Bit-string to arithmetic conversion produces reasonable results and permits bit strings to be used to hold positive integers. However, because arithmetic operators require arithmetic operands, the BINARY or DECIMAL built-in function should be used to produce an explicit conversion of a bit-string value to a binary or decimal integer value.

The conversion is invalid if the length of the source bit string exceeds N where N is the maximum precision allowed by the implementation for fixed-point binary values. For the maximum precision allowed by Open PL/I, see your Open PL/I User's Guide.

If no target base or scale is given by the context that caused the conversion, fixed binary is supplied by default. If a target precision is not given, the maximum precision allowed for the target base and scale is supplied.

The rightmost bit of the source value is considered to be the units position of a positive binary integer value of precision p, where p is the length of the source bit-string value. The value of that binary integer is then converted to conform to the base, scale, and precision of the target using the normal rules for arithmetic to arithmetic conversion. A null bit-string value converts to zero, as shown in the following examples.

Source | Result
'101'B | 5
"B | 0
'0000'B | 0
Parent topic: Data Type Conversions
Related information
Arithmetic to Arithmetic Conversion


Bit-String to Character-String Conversion

Bit-string to character-string conversion converts a bit-string value to a character-string value of the same length as the bit string. Each bit of the bit string is converted to a 0 or 1 character in the resulting character string. A null bit string is converted to a null character string.

Source | Result
'0'B | '0'
"B | "
'1011'B | '1011'

If the context that caused the conversion gives a target length, the character string is truncated to conform to a shorter target or is padded on the right with blanks to conform to a longer target.

Parent topic: Data Type Conversions


Character-String to Arithmetic Conversion

Character-string to arithmetic conversion converts a character string to any arithmetic data type.

If the context that caused the conversion does not give a target base or scale, fixed or decimal is supplied by default. If it does not supply a target precision, the maximum precision allowed by the implementation for the target base and scale is supplied. For the maximum precision allowed by Open PL/I, see your Open PL/I User's Guide.

If the source character-string value is a null string or if it contains all blanks, the value of the result is zero; otherwise, the source string must contain a valid optionally signed constant surrounded by optional blanks. The constant is converted to conform to the data type of the target using the normal rules for arithmetic to arithmetic conversion.

Source | Result
boxes | 5
 | -7
 | 0

The results in the previous example would be produced by converting a Character(6) source value to a fixed-point integer result value.

Parent topic: Data Type Conversions
Related information
Arithmetic to Arithmetic Conversion


Character-String to Bit-String Conversion

Character-string to bit-string conversion converts a string of 0 and 1 characters to the 0s and 1s of a bit string. A character-string source value that contains any characters other than 0 and 1, including spaces, cannot be converted to a bit-string value; any attempt to perform such a conversion results in a signal of the ERROR condition.

A character-string value is converted to a bit-string value of the same length as the character string. Each character is converted to a 0 or a 1 bit in the resulting bit string. A null character string is converted to a null bit string.

If the context that caused the conversion gives a target length (for example, assignment to a bit-string variable or use of the BIT built-in function with two arguments), the converted bit string is padded on the right with zero bits to conform to the longer target, or the rightmost excess bits are truncated to conform to a shorter target.

Source | Result
" | "B
'010'S | '010'B
' ' | invalid, ERROR signaled
Parent topic: Data Type Conversions


Format Controlled Conversion

Format controlled conversions occur only when a format list is used by a GET or PUT statement to control the conversion of data between the program and an input or output stream, and to control positioning within those streams.

An input conversion occurs when a field of an input line is converted to a value specified by a data format. That value is then assigned to a variable given by the format list of the GET statement. If the data type of the variable differs from the data type of the value produced by the format, an additional conversion results from the assignment.

An output conversion occurs when a value given in the format list of a PUT statement is converted to an output field by a format item.

The following sections describe the five data format items that are used for input and output of data in various formats. These data format items comprise the format specifications that are included in your GET or PUT statements.

  • F-Format
  • E-Format
  • A-Format
  • B-Format
  • P-Format
Parent topic: Data Type Conversions


F-Format

The F-Format is used for fixed-point formats, as shown in the following:

F(w) or F(w,d)

where:

w is an integer constant that specifies the width of the field

d is an integer constant that specifies the number of fractional digits in the field.

  • Input Conversion
  • Output Conversion
Parent topic: Format Controlled Conversion


Input Conversion

For F-Format input conversion, a field of w characters from the input line is converted to a fixed-point decimal value of precision (p,q). If the field contains a decimal point, q is the number of digits following the decimal point; otherwise, q is the value of d or is zero if d is omitted. If the field contains all blanks, the result value is zero, and p is the value of MIN(n,w) where n is the maximum precision allowed by the implementation for fixed-point decimal data. (For the maximum precision allowed by Open PL/I, see your Open PL/I User's Guide.) If the field does not consist entirely of blanks, it must contain an optionally signed fixed-point constant with optional leading and/or trailing blanks. In that case, p is the precision of the constant. If an invalid field is read, the Compiler signals ERROR.

Field | Result | Precision
boxe | 0 | (5,1)
-700 boxes | -70.0 | (3,1)
boxes 0 | 0 | (1,0)
25.6 boxes | 25 | (2,0)
boxes 5E+1 | invalid |
Parent topic: F-Format
Related information
Open PL/I User's Guide


Output Conversion

For F-Format output conversion, an arithmetic or string value from the format list of a PUT statement is converted to a fixed-point decimal value that is then rounded and formatted as a character string of w characters containing a value with d fractional digits.

If d = 0, or if d is omitted, the source value is converted to a fixed-point decimal value with no fractional digits, and the resulting integer value is placed, right-justified, in the field of w blank characters with leading zeros suppressed. (The value zero has one zero digit.) For negative values, the first significant digit is preceded by a minus sign. If the value and its sign cannot fit in w characters, the ERROR condition is signaled.

The following results are produced by an F(4) format.

Value | Result
0 | boxes 0
25 | boxes 25
-8 | boxes -8
13.5 | boxes 14
17.08 | boxes 17
1000 | 1000
-1000 | invalid

If d^= 0, the source value is converted to a fixed-point decimal value with d+1 fractional digits. The value is rounded by adding 5 to the last fractional digit; the last fractional digit is then deleted. The resulting value is placed, right-justified, in a field of w characters with leading integral zero digits suppressed by blanks (fractional values and zero have one integral zero digit). The leading digit is preceded by a minus sign if the value is negative. If the value, its decimal point, and its sign cannot fit in w characters, the ERROR condition is signaled. For the maximum precision allowed by Open PL/I, see your Open PL/I User's Guide.

The following results are produced by an F(5,2) format.

Source | Field
0 | boxes 0.00
-1 | -1.00
.005 | boxes 0.01
.0005 | boxes 0.00
10 | 10.00
-10 | invalid
Parent topic: F-Format
Related information
Open PL/I User's Guide


E-Format

The E-Format is used for floating-point formats, as shown in the following.

E(w)

or

E(w,d)

where:

w is an integer constant that specifies the width of the field

d is an integer constant that specifies the number of fractional digits in the field. If d is omitted, d = O.

  • Input Conversion
  • Output Conversion
Parent topic: Format Controlled Conversion


Input Conversion

For E-Format input conversion, a field of w characters from the input line is converted to a floating-point decimal value of precision p. If the field contains a decimal point and/or an exponent, the value of d is ignored; otherwise, d indicates that the last d digits in the field are fractional digits. If a field contains all blanks, p is MIN(n,w), where n is the maximum precision allowed by the implementation for floating-point decimal values; otherwise, p is the precision of the constant contained within the field. The field must either be all blank or must contain an optionally signed fixed-point or floating-point constant preceded or followed by optional blanks.

The following results are produced by an E(6,1) format.

Field | Result
boxes | 0E0
boxes -1 boxes | -0.1E0
-25E10 | -25E10
boxes 7.41 boxes | 7.41E0
boxes 150 boxes | 15E0
Parent topic: E-Format


Output Conversion

For E-Format output conversion, an arithmetic or string value from a PUT statement's list is converted to a floating-point decimal value and placed, right-justified, in a field of w blanks.

The result field contains a minus sign if the value is negative, followed by the most significant digit of the mantissa, followed by a decimal point, followed by d digits of the mantissa (if d is omitted, it is taken to be p-1), followed by the letter E, followed by the sign of the exponent, followed by n exponent digits, where n is an implementation defined constant. For the maximum precision allowed by Open PL/I, see your Open PL/I User's Guide.

If the value and its sign cannot fit in w characters, the ERROR condition is signaled.

The following results are produced by both forms of the E-format.

Value | Format | Field
0 | E(10,3) | 0.000E+000
-15 | E(10,3) | -1.500E+001
12345678 | E(10,3) | 1.234E+0 07
7.3E-10 | E(10,3) | 7.300E-010
0 | E(14) | boxes 0.000000 E+000
-25 | E(14) | boxes -2.500000E+001

The last two examples assume that the precision of the value to be converted is 7, giving a default value of 6 for d.

Parent topic: E-Format
Related information
Open PL/I User's Guide


A-Format

The A-Format is used for character-string formats, as shown in the following:

A or A(w)

where w is an integer constant that specifies the width of a field.

  • Input Conversion
  • Output Conversion
Parent topic: Format Controlled Conversion


Input Conversion

For A-Format input conversion, w must be specified (unless the A-Format is used to read a variable-length line, as explained below). The result is a character string containing the next w characters from the input stream file.

The A-Format is used without a field width to read a variable-length line. The A-Format reads the content of the current line, starting with the current column and ending with the end of the line, then sets the column position so that the next operation will read a new line.

Parent topic: A-Format


Output Conversion

For A-Format output conversion, an arithmetic or string value given by the PUT statement's format list is converted to a character string using the normal rules for conversion to character string. If w is omitted, it is taken to be the length of the character string. The string is placed, left-justified, in a field of w blanks.

Parent topic: A-Format


B-Format

The B-Format is used for bit-string formats, as shown in the following:

B or B(w)
B1 or B1(w)
B2 or B2(w)
B3 or B3(w)
B4 or B4(w)

where w is an integer constant that specifies the width of a field.

  • Input Conversion
  • Output Conversion
Parent topic: Format Controlled Conversion


Input Conversion

For B-Format input conversion, w must be specified. The next w characters from the input stream are converted to a bit string, just as if they had appeared in a bit-string constant that was followed by B, B1, B2, B3, or B4. For a list of the valid characters and their translation to bits, see Bit-String Data. If the field of w characters contains an invalid character (including blank), the ERROR condition is signaled.

Parent topic: B-Format
Related information
Bit-String Data


Output Conversion

For B-Format output conversion, an arithmetic or string value given by the PUT statement's format list is converted to a bit string using the normal rules for conversion to bit strings. The resulting bit string is then padded on the left with sufficient zero bits to make it a multiple of k bits in length, where kis the 1, 2, 3, or 4 following the B in the format code. The padded bit string is then converted to a character string of length n, where n is the length of the padded string divided by k. (All k bits are converted to one character, as shown in the table in Bit-String Data.) If w is omitted, w is the length of the character string. The character string is right-justified in a field of w blanks. w must be sufficient to hold all of the characters in the string.

The following results are produced by the various forms of the B-Format.

Value | Format | Field
'00'B | B | 00
'1'B | B(4) | boxes 1
"B | B(4) | boxes
'1101'B | B2(2) | 31
'110101'B | B3(2) | 65
'10011101'B | B4(2) | 9D
'10111'B | B2(4) | boxes 113
Parent topic: B-Format
Related information
Bit-String Data


P-Format

The P-Format is used for the input or output of data in a pictured format.

P 'picture'

where picture must be a valid picture as described in the section Picture Data in the chapter Data Types.

  • Input Conversion
  • Output Conversion
Parent topic: Format Controlled Conversion
Related information
Picture Data


Input Conversion

For P-Format input, the next field of w characters is assigned as a pictured value to the variable in the GET statement's format list. The number of characters, w, is the number of characters in the picture, excluding any V characters.

Parent topic: P-Format


Output Conversion

For P-Format output conversion, an arithmetic or string value from the PUT statement's format list is converted to a fixed-point decimal value described by the picture. The decimal value is then edited into an output field of w characters as if an assignment had been made to the pictured field. For a discussion of picture controlled conversion, see the section Conversion to Pictured Data.

Parent topic: P-Format
Related information
Conversion to Pictured Data


Pictured to Arithmetic Conversion

When a pictured value is converted to an arithmetic value, it is first converted to a fixed-point decimal value whose precision is determined by the picture, as described in the section Picture Data in the chapter Data Types.

If the context that caused the conversion specified a different data type, the fixed-point value is converted to another value that conforms to the required data type using the normal rules for arithmetic to arithmetic conversion.

Parent topic: Data Type Conversions
Related information
Picture Data


Pictured to Bit-String Conversion

Pictured data is converted to bit-string data by first converting the pictured value to a fixed-point decimal value and then converting the decimal value to a bit string using the rules given previously in the section Arithmetic to Bit-String Conversion.

Parent topic: Data Type Conversions
Related information
Arithmetic to Bit-String Conversion


Pictured to Character-String Conversion

Pictured data is character-string data and is not converted when used in a context that expects character-string data.

Parent topic: Data Type Conversions


Conversion to Pictured Data

When an arithmetic or string value is converted to a pictured value, it is first converted to a fixed-point decimal value described by the picture, as explained in the section Picture Data in the chapter Data Types. The decimal value is then edited into a character string of length w, where w is the number of characters in the picture, excluding any 'V' characters.

If the fixed-point decimal value described by the picture is not sufficient to retain all digits to the left of the decimal point, the program may be in error and could produce unpredictable results. Excess fractional digits are truncated.

The fixed-point decimal value is formed into the pictured result value under control of the picture edit characters, as described in Picture Data in the chapter Data Types.

If the fixed-point value is zero and the picture does not contain at least one '9' character, the result is a field of w blanks or w asterisks, depending on which zero-suppression picture characters were used.

Negative values cannot be edited unless the picture contains at least one sign picture character. If this rule is violated, the ERROR condition is signaled.

Value | Picture | Result
5.2 | ZZZVZZ | boxes 520
0.01 | ZZZVZZ | boxes 01
0 | ZZZ | boxes
1234 | ZZZZV | 1234
12345 | 99999 | 12345
123 | 99999 | 00123
-105.02 | $**,***V.99 | invalid
-105.02 | $**,***V.99CR | $***105.02CR
-75 | ––––V–– | boxes -7500
75 | ––––V–– | boxes 7500
-20 | -999 | -020
20 | -999 | boxes 020
-275.03 | $$$$$V.99- | boxes $275.03-
25.01 | $$$$$V.99- | boxes $25.01 boxes
-7.5 | $$,$$$V.99DB | boxes $7.50DB
0 | -****V. ** | ********
5 | -****V.** | ****5.00
-75 | -****V.** | -**75.00
.75 | Z.VZZ | boxes 75
.75 | ZV.ZZ | boxes .75
0 | ZZ$ | boxes
Parent topic: Data Type Conversions
Related information
Picture Data


Statements

  • Introduction
  • ALLOCATE
  • Assignment
  • BEGIN
  • CALL
  • CLOSE
  • DECLARE
  • DEFAULT
  • DELAY
  • DELETE
  • DISPLAY
  • DO
  • END
  • ENTRY
  • FETCH
  • FORMAT
  • FREE
  • GET
  • GOTO
  • IF
  • %INCLUDE
  • LEAVE
  • %LIST
  • %NOLIST
  • NULL
  • ON
  • OPEN
  • %OPTION
  • %PAGE
  • %POP
  • %PRINT
  • %NOPRINT
  • PROCEDURE
  • %PROCESS
  • *PROCESS
  • %PUSH
  • PUT
  • READ
  • RELEASE
  • %REPLACE
  • RETURN
  • REVERT
  • REWRITE
  • SELECT
  • SIGNAL
  • %SKIP
  • STOP
  • WRITE
  • %XINCLUDE
Parent topic: Open PL/I Language Reference Manual


Introduction

Each statement definition consists of the following subsections: purpose, syntax, parameters, description (the effect of executing the statement), examples (one or more examples of the statement's usage), and restrictions (any limitations on using the statement). In most cases, the statement is described in the context of the example(s) given in the Example section of the statement definition.

Where one statement has several different forms, each form of the statement is presented. The header lists the main statement with the variation of that statement following it. For example:

The previous example shows the header for the INT pseudovariable assignment, which is one type of assignment statement.

Statements may be prefixed by one or more statement labels. A statement label is a name followed by a colon (:). The name can be specified with a subscript. For example:

DCL_TOP: DECLARE (A,B) FIXED BINARY(31)
...
LL(1): READ FILE(F) INTO(REC(1)); GOTO NAME_X;
LL(2): READ FILE(F) INTO(REC(2)); GOTO NAME_Y;
...
NAME_X: NAME_Y: A = B + 1

Square brackets used in the syntax diagrams indicate optional parts of statements and are not part of statement punctuation. Unless a label prefix is required by a statement, it is not shown in the syntax diagram of the statement.

Parent topic: Statements


ALLOCATE

Purpose:

Allocates a block of storage for the values described by a based or controlled variable. The ALLOCATE statement also permits the assignment of explicit attributes to CONTROLLED variables at the time of allocation.

Syntax:

ALLOCATE var_ref [IN
             (area_ref)] [SET(loc_ref)] [, var_ref [IN ( area_ref)]
             [SET( loc_ref)]]...

For CONTROLLED variables:

ALLOCATE based-or-controlled-alloc[, based-or-controlled-alloc]...;

where based-or-controlled-alloc is:

Parameters:

var_ref
One or more references to a based or controlled nonmember variable or variables.
loc_ref
Specifies the locator variable (for based variables) to which the storage location is assigned if the SET option is chosen.
area_ref
Identifies the area in which the based storage is allocated if the IN option is used.
cvar_ref
A CONTROLLED variable

The dimension-attribute can be specified only for variables that are declared with a dimension-attribute, and it must specify the same number of dimensions as in the declaration.

The CHARACTER, BIT, and AREA attributes can be specified only for variables that are declared with the same attribute.

For more detailed information on BASED and CONTROLLED variables and their use with ALLOCATE statements, see the sections Based Variables and Controlled Variables in the chapter Storage Classes.

Description:

The ALLOCATE statement allocates a block of storage for the values described by a based variable.

The SET option and the IN option are not required in an ALLOCATE statement. If used, they can be specified in either order.

If the SET option is used in conjunction with any var_ref, the address of the allocated storage will be stored in the specified loc_ref for that var_ref. The SET option cannot be used when controlled variables are allocated.

If the SET option is not used, the allocated address will be stored in the locator reference that was assigned with the based variable when it was declared. If no locator reference was assigned with the based variable, an error occurs.

If the IN option is used, or if the SET option specifies an offset variable, the allocation occurs in an area. If the IN option is omitted and the SET option specifies an offset variable, that variable must, in its declaration, have been associated with an area. See the description of the OFFSET attribute in the section OFFSET in the chapter Declarations and Attributes.

Example:

Example 1

DECLARE
   1 A_STRUCT BASED (A_PTR),
      2 A_MEMBER FIXED BIN(15);

DECLARE (A_PTR, B_PTR, C_PTR) POINTER;

DECLARE
   1 B_STRUCT BASED (B_PTR),
      2 B_MEMBER FIXED BIN(15);

DECLARE
   1 C_STRUCT BASED (C_PTR);
      2 C_MEMBER FLOAT BIN(23);

DECLARE (P,Q) POINTER;

ALLOCATE A_STRUCT;
A_STRUCT.A_MEMBER = 5;
ALLOCATE B_STRUCT SET (P), C_STRUCT SET(Q);

In the preceding example, A_STRUCT is allocated, and since no SET option was specified and A_STRUCT was declared as based on A PTR, the allocated address is stored in A_PTR. When B_STRUCT is allocated, the SET option specifies that P is to be assigned the allocated address. When B_STRUCT and C_STRUCT are allocated, the SET options cause the addresses of the allocated storage for them to be assigned to P and Q, respectively.

Example 2

DECLARE (A, B)      AREA;
DECLARE A1          CHAR(20) BASED;
DECLARE A2          CHAR(20) BASED(02);
DECLARE A3          CHAR(20) BASED(03);
DECLARE (01, 02)    OFFSET(A);
DECLARE 03          OFFSET;
DECLARE (P1, P3)    POINTER;

ALLOCATE A1 SET(P1);

ALLOCATE A1 SET(01);

ALLOCATE A2;

ALLOCATE A3 IN(B);
P3 = POINTER(03, B);

In Example 2 above, the first allocation of A1 is not in an area because the locator reference in the SET option specifies a pointer variable. The second allocation of A1 occurs in area A, because the locator in the SET option specifies an offset variable associated with area A. The allocation of A2 again occurs in area A, because A2 is based on offset variable 02, which was associated with area A in its declaration. The IN option causes the allocation of A3 to occur in area B. (Note that, in order to address A3, the POINTER built-in function must be used, because 03 was not declared with an area association).

Restrictions

None.

Parent topic: Statements
Related information
Based Variables
Controlled Variables
OFFSET


Assignment

Purpose

Assigns a value to one or more specified variables.

Syntax

target[,targetn]… =expression[,BY NAME];

Parameters:

target(s)
Either variable references or pseudovariables.
expression
Any valid expression.

Description

The assignment statement evaluates expression and assigns its value to the specified variable or variables.

The assignment statement evaluates the target references and the expression in an unspecified order, converts the expression's value to the data type of each target, and then assigns the converted value to each of the targets in turn (in left-to-right order). For the rules for converting data types, see the chapter Data Type Conversions.

Assignments to a bit-string or character-string target that is shorter than the converted source value cause truncation of the rightmost bits or characters of the source value.

Assignments to nonvarying character-string targets result in padding of the converted source value on the right with sufficient blanks to make it the length of the target.

Assignments to a varying character-string target cause the target to obtain the current length of the newly assigned value.

Assignments to bit-string targets result in padding of the source value on the right with sufficient zero bits to make it the length of the target.

The value of expression can be assigned to more than one target. If the assignment is a structure assignment using the BY NAME option, such a multiple assignment affects only those elementary items that have names in common in all of the structures on both sides of the statement.

The BY NAME option is used in structure assignments to assign to the target structure only the values of those items in the structures specified in expression that have names in common with items contained in the target. The BY NAME option can be used only when the right-hand side contains at least one structure. In such a case, the BY NAME structure assignment is equivalent to a series of scalar or array assignments. There is one such assignment for each scalar or array member of the target structure for which the following condition is true: every structure referenced in the right-hand side has a corresponding scalar or array member whose full structure name (except for the top-level structure name) is identical to the target member's full structure name (except for its top-level structure name). These separate assignments are generated in the order in which the scalar and array members occur in the target structure. For example:

DECLARE 1 STRUC1,
   2 A … ,
   2 B,
      3 M … ,
      3 N … ,
      3 O … ,
   2 C … ,
   2 D … ;

DECLARE 1 STRUC2,
   5 C … ,
   5 D … ,
   5 B,
      10 L … ,
      10 M … ,
      10 O … ;

DECLARE 1 STRUC3,
   2 A … ,
   2 D … ,
   2 C … ,
   2 E,
      3 M … ,
      3 N … ,
      3 O … ,
   2B,
      3 M … ,
      3 N … ;

STRUC1 = STRUC2 + STRUC3, BY NAME;

This assignment is equivalent to the series of assignments:

STRUC1.B.M = STRUC2.B.M + STRUC3.B.M;
STRUC1.C = STRUC2.C + STRUC3.C;
STRUC1.D = STRUC2.D + STRUC3.D;
Note: BYNAME is accepted as a synonym for BY NAME.

Examples

A = B+C;
A,B = B*C;   /*A and B will each have the value of B*C */
X(K) = 5;
P->NODE.VALUE = SQRT(X(J));
SUBSTR(S,I,J) = 'ABC';

Restriction

In case of array assignment, each target variable must be an array. The right-hand side can be an array or element expression. If the right-hand side contains an array, its shape must be identical to the shape of the target array.

In case of structure assignment, each target variable must be a structure. The right-hand side can be a structure or element expression. If the right-hand side contains a structure, its shape must be identical to the shape of the target structure.

Because the target and the expression are evaluated in an unspecified order, functions or ON-units called during these evaluations may be affected by possible side effects, such as assignments to subscripts or pointers used in the target reference or freeing the target's storage. Likewise, the storage of the target must not be freed by the execution of a function or ON-unit called during evaluation of the expression.

Programs that depend on the order of evaluation may fail when moved to other implementations of PL/I.

  • Assignment - INT Pseudovariable
  • Assignment - ONCHAR Pseudovariable
  • Assignment - ONSOURCE Pseudovariable
  • Assignment - PAGENO
  • Assignment - POSINT Pseudovariable
  • Assignment - STRING Pseudovariable
  • Assignment - SUBSTR Pseudovariable
  • Assignment - UNSPEC
Parent topic: Statements
Related information
Data Type Conversions


Assignment - INT Pseudovariable

Purpose

Assigns a signed integer value to specified storage.

Syntax

INT(reference[, position[, length]]) =
             expression

Parameters:

reference
A reference to connected storage; reference cannot be an array, structure, or named constant.
position
A positive integer value specifying the position of the first bit in the field.
length
A positive integer value in the range 0 – 32 specifying the length of the field.

Description

The INT pseudovariable assigns a signed integer value to specified storage. expression is converted to Fixed Bin(31). The internal representation of the resulting integer value is then assigned to the storage specified by the arguments to INT.

If position is specified, its minimum value is 1 and its maximum value is the length in bits of the storage specified by reference. If positionis omitted, the default value is 1.

If length is specified, its minimum value is 0 and its maximum value is the length in bits of the storage specified by reference, less the value of position. If length is omitted, the default value is equal to the number of bits from the bit indicated by position to the end of the storage specified by reference.

INT and POSINT are identical pseudovariables, except that POSINT assigns an unsigned integer.

The result of this pseudovariable is dependent on the native byte ordering of the hardware you are using. For this reason, the use of this function may not be portable across different platforms.

Restrictions

None.

Parent topic: Assignment
Related information
POSINT


Assignment - ONCHAR Pseudovariable

Purpose

Sets the current value of the ONCHAR built-in function.

Syntax

ONCHAR() = string

or

ONCHAR = string

The second syntax form can be used only when ONCHAR has been explicitly declared using the BUILTIN attribute.

Parameters

string
An expression that is converted to a character string of length 1.

Description

The ONCHAR pseudovariable is used to replace the invalid character that caused the CONVERSION condition to be raised. This new character is used when the conversion is attempted again.

The ONCHAR pseudovariable is valid only in the context of a CONVERSION ON-unit. In all other cases the ONCHAR pseudovariable is ignored.

Example

DCL I FIXED BIN(15);
ON CONVERSION BEGIN;
   ONCHAR() = '0';
END;

I ='34Z9';
PUT LIST(I);

In the above example, an invalid character, 'Z,' is changed to '0'; therefore, the program will display an integer value of 3409.

Restrictions

None.

Parent topic: Assignment


Assignment - ONSOURCE Pseudovariable

Purpose

Sets the current value of the ONSOURCE built-in function.

Syntax

ONSOURCE() = string

or

ONSOURCE = string

The second syntax form can be used only when ONSOURCE has been explicitly declared using the BUILTIN attribute.

Parameters

string
An expression that is converted to a character string. If the length of the field that caused the CONVERSION condition is greater than the length of string, string is padded with blanks. If the length of the field is less than the length of string, string is truncated to match the field length.

Description

The ONSOURCE pseudovariable is used to replace the invalid string that caused the CONVERSION condition to be raised. This new string is used when the conversion is attempted again.

The ONSOURCE pseudovariable is valid only in the context of a CONVERSION ON-unit. In all other cases, the ONSOURCE pseudovariable is ignored.

Example:

DCL I FIXED BIN(15);
ON CONVERSION BEGIN;
   ONSOURCE() = '0';
END;

I = STRING VALUE;
PUT LIST(I);

If STRING_VALUE contains an invalid character, use of the ONSOURCE pseudovariable in the above example resets STRING_VALUE to zero. Therefore, the program will display an integer value of 0.

Restrictions

None.

Parent topic: Assignment


Assignment - PAGENO

Purpose

Changes the current page number that serves as the value of the PAGENO built-in function.

Syntax

PAGENO(f) = e;

Parameters

f
A reference to a file constant, or to a file variable that has been assigned a file constant value.
e
Any valid expression.

Description

The PAGENO pseudovariable refers to the page number of the referenced print file.

Assignment to the PAGENO pseudovariable modifies the current page number by causing the expression e to be evaluated and converted to a binary integer value of default precision, then assigned as the current page number of the file identified by f. (For details on default precisions, see your Open PL/I User's Guide.)

The file must be open and must describe a STREAM OUTPUT PRINT file.

The PAGENO assignment does not cause any additional pages to be output to the file; it simply changes the current page number that serves as the value of the PAGENO built-in function.

Example

DECLARE F FILE;
   .
   .
   .
PAGENO(F) = 10;

Restrictions

None.

Parent topic: Assignment


Assignment - POSINT Pseudovariable

Purpose

Assigns an integer value to specified storage.

Syntax

POSINT(expression1[,position[,length]]) = expression2

Parameters

expression1
A reference to connected storage; expression1 cannot be an array, structure, or named constant.
position
A positive integer value specifying the position of the first bit in the field.
length
A positive integer value in the range 0 – 32 specifying the length of the field.
expression2
Any expression that evaluates to an integer.

Description

The POSINT pseudovariable assigns an integer value to specified storage. expression2 is converted to Fixed Bin(31). The internal representation of the resulting integer value is then assigned to the storage specified by the arguments to POSINT

If position is specified, its minimum value is 1 and its maximum value is the length in bits of the storage specified by expression1. If position is omitted, the default value is 1.

If length is specified, its minimum value is 0 and its maximum value is the length in bits of the storage specified by expression1, less the value of position. If length is omitted, the default value is equal to the number of bits from the bit indicated by position to the end of the storage specified by expression1.

POSINT and INT are identical pseudovariables, except that INT assigns a signed integer.

The result of this pseudovariable is dependent on the native byte ordering of the hardware you are using. For this reason, the use of this function may not be portable across different platforms.

Restrictions

None.

Parent topic: Assignment
Related information
INT


Assignment - STRING Pseudovariable

Purpose

Assigns the converted value of the expression e to r, as if r were a string variable whose length is the total number of characters or bits in the variable identified by r.

Syntax

STRING(r)=e;

Parameters

r
A reference to a string, array, or structure variable that:
  • r is not union or structure containing unions
  • if r is a scalar, r must be a character or bit string. If r is a character string, it must be of type char, char varying, or picture.
  • if r is a structure, it must comprised of all type bit, or all of type char, char varying, and/or picture.
e
Any valid expression.

Description

The STRING pseudovariable interprets an appropriate reference as a reference to a fixed-length string.

The STRING assignment assigns the converted value of the expression e to r, as if r were a string variable whose length is the total number of characters or bits in the variable identified by r. The STRING assignment can modify an entire aggregate with a single string assignment or assign the aggregate to a pictured variable as if it were a character-string variable.

Example

DECLARE A(5) CHARACTER(1);
   .
   .
   .
STRING(A) = 'ABCDE';

After the previous assignment, A (1) has the value of 'A' , A (2 ) has the value of 'B', and so forth.

Restrictions

Arrays containing char varying data items when applied as the argument to the STRING pseudo variable is not currently supported.

Parent topic: Assignment


Assignment - SUBSTR Pseudovariable

Purpose

Modifies only the substring.

Syntax

SUBSTR(r,i,j)=e;
SUBSTR(r,i)=e;

or

SUBSTR(array,i,j)=string_value;

Parameters

r
A reference to a character or bit-string variable.
I
A fixed-point integer-valued expression; the index of the first character or bit in r to change.
j
A fixed-point integer-valued expression; the number of bits or characters to be changed.
e
An expression that can be converted to a character string or bit string.
array
A character or bit string array, as in: susbtr (array(i,j) = string_value;

Description

The SUBSTR pseudovariable refers to a substring of a specific string variable reference.

Assignment to the SUBSTR pseudovariable modifies only the substring portion of r. If r identifies a varying string, the substring assignment does not modify the length component of that string.

If r identifies a varying string, w is the current length of r. If r identifies a nonvarying string, w is the declared length of the string variable. If j is omitted, j is assumed to be w-I+1. The value of e is assigned to the substring according to the assignment rules for nonvarying strings.

Example

DECLARE S CHARACTER(10);
   .
   .
   .
SUBSTR(S,3,4) = 'ABC';

After the assignment, the 3rd character of S is 'A', the 4th is 'B', the 5th is 'C', and the 6th is blank. The other characters of S are unchanged by the assignment.

Restrictions

The following restrictions on I, j, and w must be satisfied or the program may be in error, causing the ERROR condition to be generated if compiled with subscript checking enabled, or unpredictable results if compiled without subscript checking enabled.

1<=I<=w
I+j-1<=w
j>0

The previous restrictions ensure that I is the index of a character or bit within the string, and that a substring of j characters or bits beginning with the Ith character or bit can be accessed without exceeding the length of the string. These formulas also ensure that I is less than or equal to the length of string r if j=0. If j is omitted, the substring begins with the Ith character or bit and extends to the end of the string. No other portion of the target string is affected by the assignment.

The substring described by I and j is assigned the converted value of the expression e as if the substring were a nonvarying string.

Parent topic: Assignment


Assignment - UNSPEC

Purpose

Evaluates and converts an expression to a bit string.

Syntax

UNSPEC(r)=e;

Parameters

r
A reference to any variable except an array or structure.
e
Any valid expression.

Description

The UNSPEC pseudovariable interprets any reference to a scalar variable as a reference to a bit string.

Assignment to the UNSPEC pseudovariable evaluates and converts the expression e to an implementation-defined bit string that is copied into the storage of r (For more information, see your Open PL/I User's Guide.) Subsequent use of r is invalid unless the bit string is a valid value for that variable.

Use of the UNSPEC pseudovariable is discouraged, since it relies heavily on particulars of the PL/I implementation and, as such, may prove to be an obstacle to portability.

Example

UNSPEC©) = '0'B;

After the previous assignment, C contains all zero bits.

Restrictions

None.

Parent topic: Assignment


BEGIN

Purpose

Groups a set of program statements and defines a scope for the names declared within it.

Syntax

BEGIN[ORDER|REORDER];

Description

The BEGIN statement defines a begin block and indicates the start of that block. The block must end with an END statement.

The BEGIN statement is an executable statement that may appear as a THEN clause or as an ELSE clause of an IF statement, as an ON-unit of an ON statement, or as a simple statement anywhere in a procedure.

When the BEGIN statement executes, it activates the begin block. The block activation terminates when the corresponding END statement executes, when a RETURN statement executes (which terminates the enclosing procedure), or when a GOTO statement that references a label external to the block executes.

Since the execution of a BEGIN statement incurs the additional time and space overhead needed to set up a block activation, a simple DO group is preferred for elementary statement bracketing. Note, however, that the DO group cannot serve as an ON-unit, nor does it introduce a new scope for declarations. The BEGIN statement must be used in such instances.

ORDER and REORDER are options sometimes used for optimization in IBM mainframe PL/I programs. They are not needed by Open PL/I; these options are simply parsed and otherwise ignored by Open PL/I.

Example

BEGIN;
   .
   .
   .
END;
ON ERROR
   BEGIN;
      .
      .
      .
   END;

Restrictions

None.

Parent topic: Statements


CALL

Purpose

Transfers control to an entry point of a procedure and optionally passes arguments to the procedure.

Syntax

CALL reference[([argument][,argument]…)];

Parameters

reference
Identifies an entry name, entry variable, or entry-valued function.
argument
An expression

Description

The CALL statement transfers control to an entry point of a procedure and optionally passes arguments to the procedure.

Execution of a CALL statement activates the procedure block identified by a reference, which can be an entry name, entry variable, or entry-valued function. The procedure designated by that entry value is called and passed any arguments given with the reference. The procedure thus activated must not have a RETURNS option and must have the same number of parameters as the reference has arguments, unless the declaration of the ENTRY name includes the OPTIONS(VARIABLE) attribute. A procedure with no argument can be called using a reference with an empty argument list () or no argument list. If the procedure is called with an argument list, each argument in that list is evaluated and, if necessary, converted to the data type of the corresponding parameter. For a discussion of argument passing and parameters, see the section Parameter Storage Class in the chapter Storage Classes.

The order in which arguments and other components of the reference in a CALL statement are evaluated is unspecified.

Example

DECLARE E ENTRY (FIXED BINARY, FIXED BINARY, FLOAT BIN);
DECLARE F ENTRY;
DECLARE G ENTRY;
CALL E(A,B,5+X);
CALL F;
CALL G();

Restrictions

None.

Parent topic: Statements
Related information
Parameter Storage Class


CLOSE

Purpose

Disassociates a file value from the physical file with which it was associated when it was opened.

Syntax

CLOSE FILE(reference)[ENVIRONMENT(LEAVE|REREAD)]
[,FILE(reference)[ENVIRONMENT(LEAVE|REREAD)]]…;

Abbreviation(s): ENV for ENVIRONMENT.

Parameters

reference
Identifies one or more file constants, file variables, or file-valued functions.
ENVIRONMENT
An option used by IBM PL/I programs to control disposition of magnetic tapes after the file is closed. Open PL/I simply parses and otherwise ignores this option.

Description

The CLOSE statement disassociates an Open PL/I file value from the physical file with which it was associated when it was opened.

Execution of a CLOSE statement closes the files identified by the references. Once closed, the files can be reopened and given different file attributes. It can also be used to designate a different operating system file or device.

Closing a closed file has no effect and is not an error.

Upon program termination (including abnormal termination), files not closed will be implicitly closed.

Example

CLOSE FILE(F);
CLOSE FILE(G(K));
CLOSE FILE (L), FILE (M);

Restrictions

None.

Parent topic: Statements


DECLARE

Purpose

Specifies the attributes associated with names.

Syntax

DECLARE declaration[,declaration]…;

Abbreviation(s): DCL for DECLARE.

Parameters

declaration

One or more declarations consisting of an identifier and attributes. The format of each declaration is:

[level]identifier[(bound-pair,…)][attribute…]

or

[level](declaration,…)[(bound-pair,…)] [attribute…]

where:

level specifies the relationship of members of structures

bound-pair specifies the dimensions of arrays

attribute specifies one or more attributes of the identifier

If a level is specified, it must be written first in the declaration.

If a bound-pair is used, it must be in parentheses and must immediately follow the identifier or the parenthetical list of declarations.

The format of the DECLARE statement varies according to the number and nature of the items being declared. For example, the DECLARE statement can list one identifier and optionally specify a level, bound-pair list, and other attributes for that identifier. Or the statement can include, in parentheses, a list of declarations to which the level and all subsequent levels apply. The declarations in the second case can be simple identifiers or can include attributes that are specific to individual identifiers.

Description

The DECLARE statement specifies the attributes associated with names. This statement has five formats:

  • Simple declarations
  • Declarations outside of procedures
  • Multiple declarations
  • Factored declarations
  • Array declarations.

Each of these formats is described separately in the following sections. (for more information on attributes, see the chapter Declarations and Attributes.)

Restrictions

A DECLARE statement cannot be used as a THEN clause or ELSE clause of an IF statement or as the ON-unit of an ON statement. A DECLARE statement cannot be used in a WHEN or OTHERWISE clause of a SELECT statement.

  • DECLARE - Array Format
  • DECLARE - Factored Format
  • DECLARE - Multiple Format
  • DECLARE - Outside of Procedure Format
  • DECLARE - Simple Format
  • DECLARE - Structure Format
Parent topic: Statements
Related information
Declarations and Attributes


DECLARE - Array Format

Purpose

Specifies the dimensions of the array and the bounds of each dimension.

Syntax

DECLARE identifier(bound-pair,…)[attribute…];

Or

DECLARE(declaration,…)(bound-pair,…)[attribute…];

Parameters

Each bound-pair has the format:

[lower-bound:]upper-bound

or

*

Description

The declaration of an array specifies the dimensions of the array and the bounds of each dimension.

One bound-pair is specified for each dimension of the array. The number of elements per dimension is defined by the bound pair. The extent of the array is the product of the numbers of elements in its dimensions. If the lower bound is omitted, the lower bound for that dimension is 1 by default.

The asterisk (*) can be used as the bound pair when arrays are declared as parameters of a procedure. The asterisk causes the indicated parameter subscript to be the same bound pair as the corresponding argument subscript. (If one dimension is specified with an asterisk, then all dimensions must be so specified.)

Example

DECLARE SALARIES(200) FIXED DECIMAL(6,2);

In the previous example, the DECLARE statement declares a 200-element array with the identifier SALARIES. Each element of the array is a fixed-point decimal number with a total of six digits, two of which are fractional.

The identifier in the previous statement can be replaced with a list of declarations, to declare several objects with the same attributes, as shown in the following example:

DECLARE (SALARIES,PAYMENTS) (100) FIXED DECIMAL(6,2);

This declaration declares SALARIES and the array PAYMENTS with the same dimensions and the same type.

DECLARE TOTALS(*,*) FIXED BINARY(15);

This declaration declares TOTALS with two subscripts, each with variable extents. Note that TOTALS must be a parameter.

Restrictions

Up to eight subscripts can be used to reference the elements of an array. For example:

DECLARE TOTALS(*,*) FIXED BINARY(15);

This declaration declares TOTALS with two subscripts, each with variable extents. Note that TOTALS must be a parameter.

Parent topic: DECLARE


DECLARE - Factored Format

Purpose

Allows two or more names that have the same attribute to be combined into a single, factored declaration.

Syntax

DECLARE(identifier[,identifier…])[attribute…];

Parameters

Names that share common attributes can be placed within parentheses and must be separated with commas. The attributes that follow the parenthetical list of names are applied to all of the named identifiers.

You can also specify, within the parentheses, attributes that are unique to specific variable names using the following format:

DECLARE(identifier[attribute]…,identifier[attribute]…)attribute…;

Description

When two or more names have the same attribute, you can combine the declarations into a single, factored declaration. (For more information on attributes, see the chapter Declarations and Attributes.)

Example

DECLARE (COUNTER, RATE, INDEX) FIXED BINARY (6) INITIAL (0);

In this example, the variables COUNTER, RATE, and INDEX share the attributes FIXED BINARY (6) and are given the initial value of zero.

DECLARE (INFILE INPUT RECORD, OUTFILE OUTPUT STREAM) FILE;

In this example, the DECLARE statement declared INFILE as a RECORD INPUT file and OUTFILE as an OUTPUT STREAM file.

Parentheses can be nested, as shown in the following example.

DECLARE ((INFILE INPUT, OUTFILE OUTPUT) RECORD, SYSFILE STREAM) FILE;

In this example, the DECLARE statement declares INFILE as a RECORD INPUT file, OUTFILE as a RECORD OUTPUT file, and SYSFILE as a STREAM INPUT file (STREAM implies INPUT).

Restrictions

None.

Parent topic: DECLARE
Related information
Declarations and Attributes


DECLARE - Multiple Format

Purpose

Defines two or more names and their individual attributes.

Syntax

DECLARE identifier[attribute…][,identifier[attribute…]]…;

Description

Multiple declarations define two or more names and their individual attributes. (for more information on attributes, see the chapter Declarations and Attributes.)

Each set of names and its attributes must be separated from other sets of names and their attributes by a comma. A semicolon must follow the last name.

Example

DECLARE COUNTER FIXED BINARY (6),
   TEXT_STRING CHARACTER (79) VARYING,
   Y FILE;

In this example, the variable COUNTER is declared with the data type attribute FIXED and BINARY (6), the variable TEXT_STRING is declared with the attribute CHARACTER (79) and VARYING, and the variable Y is declared with the data type attribute FILE .

Restrictions

None.

Parent topic: DECLARE
Related information
Declarations and Attributes


DECLARE - Outside of Procedure Format

Purpose

Allows a variable to be declared outside of any procedure and to be visible within all procedures contained in the module.

Syntax

DECLARE identifier[attribute];

Description

A variable can be declared outside of any procedure and will be visible within all procedures contained in the module (for more information, see the section Modules in the chapter Language Concepts). If no storage class is specified, STATIC is supplied by default.

The storage class for declarations outside of procedures cannot be AUTOMATIC.

Example

DECLARE B STATIC FIXED BINARY(31);
   .
   .
   .
SECOND: PROCEDURE;
   DECLARE C FIXED BINARY (31);
      .
      .
      .
THIRD: PROCEDURE;
   DECLARE D FIXED BINARY(31);
      .
      .
      .
END THIRD;
END SECOND;

In this example, variable B can be referenced from both the SECOND and the THIRD procedure.

Restrictions

None.

Parent topic: DECLARE
Related information
Modules


DECLARE - Simple Format

Purpose

Defines one name and describes its attributes.

Syntax

DECLARE identifier[attribute];

Parameters

identifier
A user-supplied name of 1 – 32 characters that is unique within the current block and can consist of any alphanumeric character A through Z, a through z, 0 through 9, @, #, $, and _, but must begin with a letter, dollar sign ($), at sign (@), or underscore (_).
attribute
One or more valid attributes of the name, each of which must be separated by a space, but can appear in any order.

Description

A simple declaration defines one name and describes its attributes. (For more information on attributes, see the chapter Declarations and Attributes.)

Example

DECLARE COUNTER FIXED BINARY (8);
DECLARE TEXT_STRING CHARACTER (60) VARYING BASED (P);

In this example, the variable COUNTER is declared with the data type attribute FIXED and BINARY (8) , and the variable TEXT_STRING is declared with the attribute CHARACTER (60), VARYING, and BASED (P).

Restrictions

None.

Parent topic: DECLARE
Related information
Declarations and Attributes


DECLARE - Structure Format

Purpose

Defines the organization of the structure and the names of members at each level of the structure.

Syntax

DECLARE declaration[,…];

Parameters

Each declaration is:

level identifier[(bound-pair)][(,…bound-pair)][attribute…]

or

level(declaration)[,…(declaration)][(bound-pair)][(,…bound-pair)][attribute…]

Description

The declaration of a structure defines the organization of the structure and the names of members at each level of the structure. Each declaration specifies a member of the structure and must be preceded by a level-number. A single variable can be declared at a particular level, or the level can contain one or more complete declarations, including declarations of arrays or other structures. The major structure name is declared as structure level 1. Minor members must be declared with level-numbers greater than 1.

Example

DECLARE 1 PAYROLL,
   2 NAME,
      3 LAST CHARACTER(70) VARYING,
      3 FIRST CHARACTER(70) VARYING,
   2 SALARY FIXED DECIMAL(6,2);

The following statement declares a structure named PAYROLL, whose last name can be accessed with a qualified reference:

PAYROLL.NAME.LAST = 'JONES';

Since the last and first names have the same attributes, the same structure can be declared as follows:

DECLARE 1 PAYROLL,
   2 NAME,
      3 (LAST,FIRST) CHARACTER(70) VARYING
   2 SALARY FIXED DECIMAL(6,2);

The following example shows a declaration containing the UNION attribute.

DECLARE 1 CONSUMER_INFO,
   .
   .
   .
      3 PHONE_DATA UNION,
            4 PHONE_NUMBER CHARACTER (13),
            4 ELEMENTS,
               5 LEFT_PAREN CHARACTER (1),
               5 AREA_CODE CHARACTER (3),
               5 RIGHT_PAREN CHARACTER (1),
               5 EXCHANGE CHARACTER (3),
               5 HYPHEN CHARACTER (1),
               5 ACTUAL_NUMBER CHARACTER (4),
      3 ADDRESS_DATA,
            .
            .
            .

In this example, the UNION attribute associated with the declaration of PHONE_DATA's immediate members (PHONE_NUMBER and ELEMENTS) share the same storage, so any change to PHONE NUMBER also changes one or more members of ELEMENTS. Conversely, changing a member of ELEMENTS also changes PHONE_NUMBER. However, the UNION attribute does not apply to the members of ADDRESS_DATA, because these members are not immediate members of PHONE_DATA. The members of ADDRESS_DATA occupy separate storage, as is typical for structure members.

Restrictions

None.

Parent topic: DECLARE


DEFAULT

Purpose

Specifies data attribute defaults in cases where attribute sets are incomplete.

Syntax

DEFAULT simple-spec|factored-spec[,simple-spec|factored-spec]…;

where simple-spec is:

RANGE(letter[:letter][,letter[:letter]…)attribute-spec;

or

RANGE(*)[attribute-spec];

where factored-spec is:

(simple-spec|factored-spec[,simple-spec|factored-spec]…)[attribute-spec]

where attribute-spec is:

[attribute-list][VALUE(value-spec[,value-spec]…)

where attribute-list is a list of attributes separated by at least one space.

attribute[ attribute]…

where attribute is:

ALIGNED | AREA | AUTOMATIC | BASED | BINARY | BIT | CHARACTER | CONTROLLED
             | DECIMAL | DEFINED | DIMENSION | ENTRY | EXTERNAL | FILE | FIXED | FLOAT | INITIAL | INTERNAL | LABEL
             | OFFSET | PICTURE | POINTER | STATIC | VARYING | UNALIGNED | VARIABLE

where value-spec is:

CHARACTER(length)|BIT(length)|AREA(size)|numeric-spec

where numeric-spec is:

FIXED|FLOAT|BINARY|DECIMAL[(precision[,scale])]

Abbreviation(s):

  • DEC for DECIMAL
  • DFT for DEFAULT
  • AUTO for AUTOMATIC
  • BIN for BINARY
  • CHAR for CHARACTER
  • CTL for CONTROLLED
  • EXT for EXTERNAL
  • INIT for INITIAL
  • INT for INTERNAL
  • PIC for PICTURE
  • PTR for POINTER
  • VAR for VARYING

Parameters

RANGE (letter:letter)
Specifies that the defaults apply to names with initial letters that either correspond to the two letters specified or to any letters between the two in alphabetic sequence. The letters given in the specification must be in increasing alphabetic order.
RANGE (letter)
Specifies that the defaults apply to names beginning with the letter specified.
RANGE (*)
Specifies that the defaults apply to all names.
VALUE
Establishes default rules for a string length and numeric precision. The only attributes that the VALUE option can influence are length and precision. Other attributes in the option, such as FIXED or DECIMAL, merely indicate which attributes the value is associated with.
Note:

A length or precision specification can be made only in the VALUE clause. They may not be specified with the attributes in attribute-list.

Description

Specifies data attribute defaults in cases where declared attribute sets are incomplete. Any attributes not suppled by the DEFAULT statement for any incomplete explicit, contextual, or implicit declarations are supplied by the Open PL/I default rules. (See the section Compiler-supplied Defaults in the chapter Declarations and Attributes.)

Structure elements are given default attributes according to the name of the element, not the qualified structure element name. The DEFAULT statement cannot be used to declare a structure.

You can use more than one DEFAULT statement within a block. The scope of a DEFAULT statement includes the block in which it occurs and all nested blocks, except those which include another DEFAULT statement with the same range or which are contained in a block having a DEFAULT statement with the same range.

Note the following special case of a DEFAULT statement that is used to restore language-specified defaults in the containing block:

MAIN: PROCEDURE;
DEFAULT RANGE (a:d) FIXED DECIMAL
   VALUE (FIXED DECIMAL(10,2));
DCL CL_INDEX;
   BEGIN;
   DEFAULT RANGE (*);
   DCL C_INTERNAL FIXED DECIMAL;
   END;
END MAIN:

in the previous example, the CL_INDEX in the MAIN routine will have precision and scale of (10,2) in accordance with the DEFAULT statement specification, while the C_INTERNAL variable will have a language default precision (5,0).

Example

DEFAULT RANGE (l:m) FLOAT;
DECLARE (low, medium) BINARY;

/*In this case both variables, low and medium, will be declared as FLOAT BINARY(23).*/

DFT RANGE (*) STATIC;
DECLARE (x,y) FIXED BINARY(15) INITIAL (0);
DECLARE t FLOAT DECIMAL AUTOMATIC;

/* In this example both x and y will have STATIC storage class, while t will have AUTOMATIC storage class due to its explicit storage class declaration. */

DEFAULT RANGE (t) VALUE (CHARACTER(6));
DCL tony CHAR;
DCL tiger CHAR(20);

This statement specifies that all character variables whose name begins with the letter t have the length of 10 characters. Here, tony will have length 6, while tiger will have its explicitly specified length of 20.

Restrictions

None.

Parent topic: Statements
Related information
Compiler-supplied Defaults


DELAY

Purpose

Delays execution for a specified length of time.

Syntax

DELAY(expression)

Parameters

expression is evaluated and converted to a Fixed Binary(31) value.

Description

The DELAY statement delays execution for a length of time equal to the number of milliseconds specified by expression, rounded to the nearest whole second.

Example

/* Both of the following statements suspend /*
/* execution for one second. */

DELAY (10**3);
DELAY (800);
Parent topic: Statements


DELETE

Purpose

Deletes a record from a DIRECT UPDATE or a KEYED SEQUENTIAL UPDATE file.

Syntax

DELETE FILE(reference)[KEY(e)];

Parameters

reference
Identifies a file value that has been opened with the DIRECT UPDATE or KEYED SEQUENTIAL UPDATE attributes.
e
Any valid key expression.

Description

The DELETE statement deletes a record from a DIRECT UPDATE or a KEYED SEQUENTIAL UPDATE file. For both DIRECT UPDATE and KEYED SEQUENTIAL UPDATE files, the key expression is evaluated and converted to the appropriate form. For an indexed (VSAM) file, the key expression is converted to CHARACTER. For a relative record I/O file, it is converted to a positive integer. For indexed (VSAM) files, if the KEY clause is omitted, the last record read is deleted. The KEY clause is required for relative record I/O files. If a record with that key does not exist, the KEY condition is signaled. Return from a KEY condition ON-unit resumes execution with the statement following the DELETE statement. (For more information on record I/O, see the section Input and Output in the chapter Language Concepts.)

Example

DELETE FILE(F) KEY('203XJ42');

Restrictions

None.

Parent topic: Statements
Related information
Input and Output


DISPLAY

Purpose

Displays a message on the user’s screen and optionally requests a response.

Syntax

DISPLAY (expression) [REPLY char-ref]

Parameters

expression
Is converted, where necessary, to a character string. This character string is displayed. It can contain mixed character data. If the expression has the GRAPHIC attribute, it is not converted.
char-ref
Specifies a character reference that receives the user-entered response. The response can contain CHARACTER, GRAPHIC, or mixed data.

Description

The DISPLAY statement displays a message on the user’s screen and optionally requests the user to enter a response to the message.

Example

display ('Communication link established.');

displays the message:

Communication link established.

Restrictions

The REPLY option suspends program execution until the user enters a response.

If GRAPHIC data is entered in the REPLY, it is received as character data that contains mixed data. Such character data can be converted to GRAPHIC data using the GRAPHIC BUILTIN.

Note:

The REPLY parameter is supported when running Open PL/I under the control of Enterprise Server.

Parent topic: Statements


DO

Purpose

Begins a sequence of statements to be executed as a group, possibly to be executed iteratively.

Syntax

DO [while-until-spec]|[index = iteration-spec[,iteration-spec]…];

where while-until-spec is:

WHILE(test-expression)[UNTIL(test-expression)]

or

UNTIL(test-expression)[WHILE(test-expression)]

and where

iteration-spec is:

start[to-by-spec|repeat-spec][while-until-spec]

where

to-by-spec is:

TO finish[BY increment]

or

BY increment[TO finish]

and where repeat-spec is:

REPEAT next

Parameters

test-expression
Any expression that yields a scalar bit string value of length >= 1. If any bit of the value is 1, the test-expression is true; otherwise, it is false. test-expression must be enclosed in parentheses.
index
A reference to a scalar variable.
start, next, finish, and increment
Expressions valid for assignment to index.

Description

The DO statement begins a sequence of statements to be executed in a group. The group ends with the nonexecutable statement END.

A DO-group is executed a variable number of times under the control of its DO statement.

A DO statement cannot be used as an ON-unit, but can appear anywhere within a procedure or BEGIN block, including a THEN or ELSE clause of an IF statement or as an object of a WHEN or OTHERWISE clause.

The following sections explain each DO statement. In all of these discussions, you can assume that the DO-group neither transfers control out of the group nor skips statements within the group when the statements of the group are executed once, twice, n times, and so on. However, any DO-group can contain IF statements, other DO-groups, RETURN, or GOTO statements that alter the order of execution.

Control cannot be transferred initially into a non-simple DO-group except by executing that DO-group's DO statement. Also, if control is transferred out of a non-simple DO-group (other than by a procedure or function call), control cannot generally be transferred back into the group. Violation of these rules causes unpredictable results.

  • Simple DO Statement
  • DO WHILE and DO UNTIL Statements
  • DO REPEAT Statement
  • Iterative DO Statement
  • DO List Statement
  • Complex Iterative DO Statement
Parent topic: Statements


Simple DO Statement

Description

The simple DO statement causes the statements in the DO-group to be executed one time only. Control may be transferred into a simple DO-group by a GOTO statement, but this should be avoided in structured programming.

Example

IF C < D THEN DO;
   PUT LIST ('More data needed');
   GET LIST (VALUE);
   C = C + VALUE;
   END;
Parent topic: DO


DO WHILE and DO UNTIL Statements

Description

The DO WHILE statement causes the statements in the DO-group to be executed in a loop, provided the condition specified in the test expression is satisfied. When the condition is not true, the statements in the DO-group are not executed, and control passes to the statement following the END statement.

Execution of a DO WHILE statement causes the test expression to be evaluated to produce a value b, which must be a bit-string of length greater than or equal to one.

The test expression will be considered true if any of the bits in the string are one, and will be considered false only when all bits are zero.

If b is true, the statements of the group are executed; when the corresponding END statement is executed, control is transferred back to evaluate the test expression again, and the new value of b is tested. If b is false, the statements in the group are not executed, and execution resumes with the statement following the END statement.

The DO UNTIL statement causes a group of statements to execute until a certain condition is satisfied. As long as the condition is false, the group is repeated.

The test-expression is evaluated after each execution of the DO-group. For the DO-group to be repeated, the expression must have a false value. If the expression has a true value, control passes to the next executable statement following the END statement that terminates the DO-group.

The DO UNTIL option resembles the DO WHILE option, in that both options evaluate the status of test expressions; however, the DO WHILE option checks the test expression's value at the beginning of the DO-group, whereas the DO UNTIL statement checks its value at the end of the DO-group. Consequently, a DO-group containing a DO UNTIL statement with no WHILE clause will always be executed at least one time, but a DO-group containing a DO WHILE statement may never be executed.

Example

DO WHILE(EOF = 0);/* an end of file ON-unit sets EOF = 1 */
   READ FILE(F) INTO(REC);
   END;

DO UNTIL(B = 1);
   ARRAY(B) = B;
   B = B - 1;
   END;

DO WHILE(EOF = 0) UNTIL(SUBSTR(REC,1,6) = 'marker');
   READ FILE(F) INTO(REC);
   END;
Parent topic: DO


DO REPEAT Statement

Description

The DO REPEAT statement executes a DO-group repetitively for different values of a variable.

The variable is assigned a start value that is used on the first iteration of the group. The REPEAT expression is evaluated before each subsequent iteration, and its result is assigned to the variable. If a WHILE option is included, the WHILE expression is evaluated before each iteration, including the first. If an UNTIL option is included, the UNTIL expression is evaluated at the end of each iteration. Unless the WHILE or UNTIL option is present, the loop repeats indefinitely.

The DO REPEAT statement causes the start expression to be evaluated and assigned to the index variable. If the WHILE option is given, the test expression is evaluated to produce a value b, which must be a bit-string of length greater than or equal to one. (See the section DO WHILE and DO UNTIL Statements.) If b is false, execution resumes with the statement following the corresponding END statement. If b is true or if a WHILE option is not given, the statements of the group are executed. When control reaches the END statement, if the UNTIL option is given, the test expression is evaluated to produce a value b. If b is true, execution resumes with the statement following the corresponding END statement. Otherwise, the next expression contained in the REPEAT option is evaluated and assigned to the index variable. Any WHILE option is again evaluated; if the value is true or the WHILE is omitted, the group is executed again.

index must be a reference to a variable whose data type makes it a suitable target for assignment of both start and next. Both start and next may be expressions of any data type, provided they both can be assigned to index.

The index reference is not completely reevaluated each time a next value is assigned to it. The original values of any subscripts, pointer qualifiers, or string lengths used in index are used in all subsequent assignments of next values. The next and test expressions are completely reevaluated each time.

The index variable must not be an array or structure, but it can be a reference to an element of an array or a member of a structure.

Example

DECLARE (HEAD,P) POINTER;
DECLARE 1 NODE BASED;
   2 VALUE FLOAT;
   2 NEXT POINTER;
DO P = HEAD REPEAT(P->NODE.NEXT) WHILE(P^=NULL);
   .
   .
   .
END;

The previous DO-group is executed repeatedly for each non-null pointer in the chain of nodes rooted in the pointer HEAD.

Parent topic: DO
Related information
DO WHILE and DO UNTIL Statements


Iterative DO Statement

Description

The iterative DO statement identifies a variable whose value controls the execution of the DO-group and defines the conditions under which the control variable is to be modified and tested.

Execution of an iterative DO causes the start, finish, and increment expressions, as well as the index reference, to be evaluated in an unspecified order. Once evaluated, the finish and increment values are used throughout execution of the group and are not reevaluated. The subscripts, pointers, and so on, in the index reference are also not reevaluated.

The start value is converted, if necessary, to the data type of the index variable, and the converted value is assigned to the index variable.

If a WHILE option is given, the test-expression is evaluated to produce a value b that must be a bit-string of length greater than or equal to one. (See the section DO WHILE and DO UNTIL Statements.) If b is false, execution resumes with the statement following the END statement.

If b is true or a WHILE option is not given, the value of the index variable is compared to the finish value. If the increment is positive or zero, and if the index value is greater than the finish value, execution resumes with the statement following the END statement.

If the increment is negative and the index value is less than the finish value, execution resumes with the statement following the END statement.

If none of the above conditions caused execution of the group to end, the statements of the group are executed. If an UNTIL option is given, the test-expression is evaluated to produce a value b that must be a bit string of length 1. If b is true, execution resumes with the statement following the END statement, the increment value is added to the index variable, and any WHILE test is reevaluated. The new values of b and index are then used to determine if the group should be executed again.

The TO and BY options may be given in any order followed by the WHILE or UNTIL options. Either of the TO or the BY options may be omitted. If the BY option is omitted, a default increment of one is supplied. If the TO option is omitted, index is not compared against limit and the group repeats indefinitely unless stopped by the WHILE or UNTIL option. If both the TO option and the WHILE option are omitted, the DO-group repeats indefinitely. Both the WHILE and UNTIL options may be specified.

Example

DO K = 1 TO 10;
   .
   .  /* EXECUTES 10 TIMES */
   .
END;

DO K = 10 TO 1 BY -1;
   .
   .  /* EXECUTES 10 TIMES */
   .
END;

DO K = 1 TO 1 BY -1;
   .
   .  /* EXECUTES 1 TIME */
   .
END;

DO K = 1 TO 10 WHILE(B<0);
   .
   .
   .
END;

In this last example, the DO-group executes 10 times or until B ? 0, whichever comes first.

DO A(J) = B+1 TO N BY -M WHILE(T);
   .
   .
   .
END;

In the previous example, the DO-group executes [B-N+2/M] times or until T becomes false, whichever comes first. All executions of the DO-group use the same element of A as the index, even if J has been altered by the execution of the group. These executions also all use the initial values of B+1, N and -M. However, T is repeatedly evaluated.

Parent topic: DO
Related information
DO WHILE and DO UNTIL Statements


DO List Statement

Description

A special form of iterative DO statement is one in which none of the TO, BY, or REPEAT options are used, but in which multiple instances of the start expression are specified. In this case the DO-group is executed once for each specified start value.

Example

DO name 'Bob', 'Ann', 'Fred', 'Joan', 'Sue';
      READ FILE(F) KEY(name) INTO(REC);
      CALL SEND_REPT;
      END;
Parent topic: DO


Complex Iterative DO Statement

Description

An iterative DO statement can include multiple instances of the iteration-spec. The DO list statement described above is a simple example of this. When multiple instances of the iteration-spec are specified, the DO-group is first executed as many times as required to satisfy the conditions for the first iteration-spec, then as many times as required for the second iteration-spec, and so on, until all instances of the iteration-spec have been used.

Example

DO J = 1 TO 9 WHILE(B(J) ^-= 'xx'), J = 16 TO 20 BY 2;
      READ FILE(F) INTO(REC);
      B(J) = SUBSTR(REC,6,2);
      END;

If none of the first eight records read by this loop produce B (J) = 'xx', entries B (1) through B (9) , plus B (16) , B (18) , and B (20) , are set by the loop. If, for example, the third record read produces B (J) = 'xx', only entries B (1) through B (3) , plus B (16) , B (18) , and B (20) are set.

Parent topic: DO


END

Purpose

Terminates a block or group headed by the most recent DO, PROCEDURE, SELECT, or BEGIN statement.

Syntax

END [statement_label];

Parameters

statement_label
The label prefix of the corresponding statement.

Description

The END statement terminates a block or group headed by the most recent DO, PROCEDURE, SELECT, or BEGIN statement.

Execution of an END statement that closes a DO-group may cause the group to be repeated, depending on the DO statement that heads the group. (Refer to previous sections of this chapter regarding DO statements.)

Execution of an END statement that closes a PROCEDURE statement is valid only if the PROCEDURE statement does not contain a RETURNS option. Open PL/I or another implementation of PL/I might not diagnose all violations of this requirement. The END statement ends the current block activation and returns control to the statement following the CALL statement that called the procedure.

Execution of an END statement that closes a BEGIN block ends the current block activation and resumes execution of the previous block activation with the statement following the END statement. If the BEGIN block is an ON-unit, control returns to the source of the signal. This return is not possible if the ON-unit has been established for the ERROR condition; an attempt to return to the source of the ERROR condition stops execution of the program and produces a run-time error message.

An END statement can have a label prefix and can be referenced by a GOTO statement, including GOTO statements contained within the DO-group or block that is closed by the END statement.

If a name is given, it must be the same name as occurs in the label prefix of the corresponding DO, BEGIN, or PROCEDURE statement. If the name is not the same, the Compiler issues an error message.

An END statement cannot appear as a THEN, ELSE, WHEN, or OTHERWISE clause or as an ON-unit.

Example

P: PROCEDURE;
   DO K=1 TO 10;
      .
      .
      .
   END;
   END P;

If control passes to an END statement that implicitly closes a repetitive DO group, no further repetitions of the DO group occur. It is equivalent to a branch out of the DO group.

Restrictions

None.

Parent topic: Statements


ENTRY

Purpose

Defines an alternate entry point to a procedure.

Syntax

name:ENTRY[(parameter,…)][RETURNS(returns-descriptor)][EXTERNAL|INTERNAL];

Parameters

name
Identifies the entry point.
parameter
Represents any parameters required by the procedure at this entry point.

Description

The scope of name is external if the ENTRY statement is contained in an external procedure. The scope of name is internal if the ENTRY statement is contained in an internal procedure.

The RETURNS option is required for entry points that are invoked by function references and provides the data type attributes of the function value returned. The RETURNS option is invalid for entry points procedures that are invoked by CALL statements.

The COBOL NOMAP [map-list] option

The FORTRAN NOMAPIN [map-list] option

The TASK NOMAPOUT [map-list] option

The NOEXECOPS option

The OPTION(BYTEADDR) option can be used to ensure the passing of byte addresses, even for items allocated on a bit boundary. When this option is not specified, Open PL/I passes bit addresses for unaligned bit strings. When this option is specified, Open PL/I passes just the address of the first byte of unaligned bit strings.

Only one of EXTERNAL or INTERNAL may be specified and only on top-level procedures, that is, those that are not contained within the scope of any other procedure. If EXTERNAL is given, the procedure will be external to the current file being compiled and can be called by other separately compiled procedures. This is the default. If INTERNAL is given, the procedure can be called only by other procedures within the current compilation. Its name is not made available outside this file.

For more information, see the sections Entry Data in the chapter Data Types and ENTRY in the chapter Declarations and Attributes.

Example

FILE_MANAGER: PROCEDURE;
DECLARE 1 FILE_IOCB BASED (IOCB_PTR),
      .
      .
      .
OPEN: ENTRY (IOCB_PTR, FILE_PTR, OPEN_MODE);
      .
      .
      .
RETURN;
CLOSE: ENTRY(IOCB_PTR);
      .
      .
      .
RETURN;
READ_RECORD: ENTRY (IOCB_PTR, BUFFER_PTR, READ_COUNT);
.
.
.
END;

FILE_MANAGER is a single procedure that has been designed to process three kinds of calls:

  • A call to open a file.
  • A call to read a record from the file.
  • A call to close the file.

A separate entry has been created for each kind of call, each with its own parameters.

Restrictions

ENTRY statements are not allowed in BEGIN blocks, ON-units, or DO groups, except for simple DOs.

Parent topic: Statements
Related information
Entry Data
ENTRY


FETCH

The FETCH statement is described in the Dynamic Fetching and Releasing of External Procedures section.

Parent topic: Statements
Related reference
FETCH Statement


FORMAT

Purpose

Controls the transmission of data to and from a stream I/O file by a GET or PUT statement.

Syntax

name:FORMAT(format-list);

Parameters

name
An unsubscripted label prefix that is not a statement label and cannot be used by a GOTO statement.
format-list
A list of format specification items.

Description

The FORMAT statement describes the format-specification list to be used by the GET or PUT statement to control the transmission of data to and from a stream I/O file or string. The FORMAT statement has no effect unless it occurs as a consequence of executing the GET or PUT statement.

The format list consists of a list of format items separated by commas. Each format item can be preceded by an optional repetition factor. The repetition factor is either an expression enclosed in parentheses or an integer. The repeat count must be separated from the item by at least one space for all but the parenthetical format list. The value of the repetition factor must be greater than zero and less than 255.

The format items are:

  • (format-list)
  • A(w) or A
  • B(w) or B
  • B1 (w) or B1
  • B2(w) or B2
  • B3(w) or B3
  • B4(w) or B4
  • E(w) or E(vv,d)
  • F(w) or F(w,d)
  • P 'Picture'
  • R (name)
  • COLUMN(n) or COL(n)
  • LINE(n)
  • PAGE
  • SKIP or SKIP(n)
  • TAB or TAB(n)
  • X(n) or X

(format-list) is a parenthetical format list used as a format item; A–P are data format items; and each w, d, or n is an integer constant or an expression whose value k must be 0<=k<=255, unless further restricted by the definition of a particular format item.

Each time control passes to a format list, all format items between the last used format item and the next data format item are evaluated. The next data format item is then used to control the conversion of the data being transmitted to or from the stream file.

If control reaches the end of a format list in a FORMAT statement, it returns to the R-format that transferred control to the FORMAT statement.

If control reaches the end of a format list in a GET or PUT statement, and one or more values are still to be transmitted in the statement's I/O list, control transfers to the beginning of the format list. If there are more format items than values to be transmitted in the statement's I/O list, the extra format items are ignored.

Each format item is described as follows. (Examples of the FORMAT statement are included in the format item descriptions.)

  • The parenthetical format list (format-list)

    When a parenthetical format list is used as a format item, it is used as many times as specified by its repeat count.

    F: FORMAT(F(10,4),2(A(5),E(14,3)),SKIP);

    This example is equivalent to:

    F: FORMAT(F(10,4),A(5),E(14,3),A(5),E(14,3),SKIP);
  • The data format items (A, B, B1, B2, B3, B4, E, F, and P)

    The data format items A, B, B1, B2, B3, B4, E, F, and P control the transmission and conversion of a value to or from a stream file. Each data format causes w characters to be read from an input stream or written to an output stream, where w is the field width given in the format or calculated during the conversion. (For additional information, see the chapter Data Type Conversions.)

    If fewer than w characters remain in an input line, any characters remaining on that line are read and a fresh line is obtained. Additional characters are then read from the fresh line so that a total of w characters are read.

    If fewer than w characters remain in an output line, as many characters as fit are written on that line and a fresh line is begun. Any remaining characters are written onto the line so that a total of w characters are written.

    For a detailed description of how each data format controls conversion of a value, see the section Format Controlled Conversion in the chapter Data Type Conversions .

  • R(label)

    The R(label) format item indicates that format items are to be acquired from the FORMAT statement at the specified label. That is, the R(label) format item transfers control to the format list of the FORMAT statement whose name appears in the R-format.

    The effect of this transfer is as if the format list of the FORMAT statement were called as a subroutine; when the remote format list is exhausted, control returns to the format item following the R-format.

    F: FORMAT(A,X(3));
PUT EDIT(P,Q) (R(F),E(14,3));

    In the previous example, the value of P is transmitted by the A-format contained in the FORMAT statement. Transmission of Q finishes the remote format list by evaluating the X control format and returns to use the E-format to transmit the value of Q. This is equivalent to the following:

    PUT EDIT(P,Q) (A,X(3),E(14,3));
  • COLUMN(n) or COL(n)

    The COLUMN or COL format item puts blanks into an output stream or skips characters of an input stream so that the next character is read or written into column n of a line.

    The COLUMN format is valid for files only.

    If the current output line contains exactly n-1 characters, no output is performed and the next output begins in column n of the current line.

    If the current output line contains less than n-1 characters and n is less than or equal to the line size, sufficient blanks are placed into the current line to cause the next output to begin in column n.

    If the current output line contains less than n-1 characters and n is greater than the line size of this file, the current line is written and a new line is begun. The next output begins in column 1 of the new line.

    If the current output line already contains more than n characters, it is written to the stream file and a new line is begun. If n is greater than the line size of this file, no blanks are placed into the new line; otherwise, n-1 blanks are placed into the new line, causing the next output to begin in column n of the line.

    If the current input line is positioned such that the next character to be read is located in column n, no characters are skipped.

    If the current input line is positioned such that the current column is less than column n and n does not exceed the size of the current line, sufficient characters of the line are skipped so that the next input occurs from column n.

    If the current input line is positioned such that the current column is less than column n, but n exceeds the size of the current line, or if the current column is greater than column n, a fresh line is read. If n exceeds the size of the fresh line, no characters are skipped and the next input occurs from column 1; otherwise, n-1 characters are skipped, causing the next input to occur from column n.

    The value n must be greater than zero.

    Example:

    COL(n) | COLUMN | LINENO | NEW COLUMN | NEW LINENO
    25 | 25 | 1 | 25 | 1
    24 | 25 | 1 | 24 | 2
    26 | 25 | 1 | 26 | 1
    30 | 25 | 1 | 1 | 2

    The previous examples assume a linesize, s, that is 26?s?30.

  • LINE(n)

    The LINE format item sets a print file to a specific line; therefore, it can be used only to control output to a stream file that has been opened with the PRINT attribute and that, consequently, has a page size.

    The LINE format item is valid for print files only; it positions the stream file to a specified line relative to the top of a page.

    If the current line number is less than n and n does not exceed the page size, sufficient lines are written to the output so that the current line is line number n.

    If the current line number is greater than n or if n exceeds the page size, the remainder of the page is filled with blank lines and the ENDPAGE condition is signaled, unless the current line number already exceeds the page size. In that case, a new page is begun without signaling the ENDPAGE condition.

    If n equals the current line and the current column is one, no output occurs. If n equals the current line, but the current column is not one, the ENDPAGE condition is signaled, unless the current line number already exceeds the page size. In that case, a new page is begun without signaling the ENDPAGE condition.

    The value n must be greater than zero.

  • PAGE

    The PAGE format item is used with print files to begin a new page. It can be used only to control output to a stream file that has been opened with the PRINT attribute.

    The PAGE format item positions the stream to the top of a new page and thereby resets the line number to one and increases the page number by one.

  • SKIP(n) or SKIP

    The SKIP format item sets a stream file to a new position relative to the current line. It can be used only with input and output files.

    The SKIP format item applied to an input stream skips the rest of the current input line and n-1 subsequent lines; that is, it skips over n line boundaries.

    A SKIP format applied to an output stream writes the current line and n-1 empty lines; that is, it writes n line boundaries.

    If n is omitted, a value of one is supplied. The value of n must be greater than zero. If the value of n is less than or equal to zero, the SKIP option is ignored.

    If the output stream file has been opened with the PRINT attribute, and if the total number of lines written as a result of the SKIP format item would exceed the page size, the current line is written, followed by sufficient empty lines to fill the page, and the ENDPAGE condition is signaled.

  • TAB(n) or TAB

    The TAB format item sets a print file to a specified tab stop n. It can be used only to control output to a stream file opened with the PRINT attribute.

    The TAB format item causes sufficient blanks to be placed into the current line to position it to the nth tab stop relative to the current column of the line. The relative positions of tabs are implementation-defined (8 characters apart in this implementation). Other implementations may differ and may in fact not place tab stops at constant intervals.

    If the current column is a tab stop, the TAB format item produces sufficient blanks to cause the next output to begin at the next tab stop.

    If n tab stops do not remain on the current line, the current line is written and a new line begun. If the first tab stop is not column 1, sufficient blanks are placed into this line to position it to the first tab stop.

    If TAB format items are used, line size must not be less than the first tab stop. If n is omitted, a default value of one is supplied.

    The value of n must be greater than zero.

    If either of the two preceding rules are violated, a line feed is inserted and data continues to be transmitted.

  • X(n) or X

    The X format item writes n blanks to an output file or skips n positions in an input file. If n is omitted, the default value of n is 1. The X format item is valid with both the FILE and STRING options of the GET EDIT and PUT EDIT statements.

    If fewer than n characters remain in the current line, the remaining characters are skipped on input or written as blanks on output, and additional characters are skipped or written as blanks on the next line so that a total of n characters are written or skipped.

    The value of n must be greater than zero.

Restrictions

None.

Parent topic: Statements
Related information
Data Type Conversions
Format Controlled Conversion


FREE

Purpose

Frees the storage that was allocated for a based or controlled variable identified by reference.

Syntax

FREE reference[IN(area-reference)]…;

Parameters

reference
One or more references to based or controlled variables.
area-reference
A reference to a scalar or subscripted area variable.

Description

The FREE statement frees all blocks of storage that were allocated for based or controlled variables identified by reference.

If the reference is not locator-qualified in the FREE statement, the variable will be implicitly qualified using the locator from the declaration of the based variable. If the declaration had no locator, the FREE statement is in error.

If the allocation to be freed occurred in an area, either the IN clause must be specified or the based variable must be qualified by an offset variable that was associated with an area in its declaration.

The locator qualifier used explicitly or implicitly by the reference must point to a block of storage allocated by execution of an ALLOCATE statement. The results are unpredictable when a FREE statement is used on a based or controlled variable that has not had storage allocated for it by an ALLOCATE statement.

The reference must not be subscripted and must identify a nonmember based or controlled variable whose size, shape, and component data types are the same as were used when the storage was allocated.

When a FREE statement has freed storage allocated for a controlled variable, the next most recent allocation for that variable is made available and subsequent references refer to that allocation.

When a FREE statement has freed storage allocated for a based variable, that block of storage must no longer be referenced. Any pointers that address the block are invalid and must not be used. Violation of this rule produces unpredictable results.

Example

In the following example, the FREE statement frees the storage block allocated by the ALLOCATE statement.

DECLARE TABLE(100) FLOAT BASED;
DECLARE P POINTER;
   .
   .
   .
ALLOCATE TABLE SET(P);
   .
   .
   .
FREE P->TABLE;

In the following example, the FREE statement frees an AREA.

DECLARE ITEM1    BIN BASED(O1);
DECLARE ITEM2    BIN BASED(02);
DECLARE ITEM3    BIN BASED;
DECLARE A        AREA(64);
DECLARE 01       OFFSET(A);
DECLARE 02       OFFSET;
DECLARE 03       OFFSET;

ALLOCATE ITEM1;               /* implicitly in area A;
                                 implicitly set 01 */

ALLOCATE ITEM2 IN(A);         /* explicitly in area A;
                                 implicitly set 02 */

ALLOCATE ITEM3 IN(A) SET(03); /* explicitly in area A;
                                 explicitly set 03 */

FREE ITEM1;                   /* both implicit */

FREE ITEM2 IN(A);             /* IN is required */

FREE 03->ITEM3 IN(A);         /* Locator and IN required */

Restrictions

None.

Parent topic: Statements


GET

Purpose

Gets data from an input stream that is either a stream file or a character-string expression.

Syntax

GET [FILE(f)][SKIP[(n)]][LIST](input-list);

or

GET [FILE(f)][SKIP[(n)]]EDIT(input-list)(format-list)[(input-list)(format-list)]…;

or

GET STRING(s)[LIST](input-list);

or

GET STRING(s) EDIT(input-list)(format-list)[(input-list)(format-list)]…;

If neither LIST nor EDIT is specified, LIST is assumed. In this default case, the

input-list must occur immediately after the word GET.

Parameters

input-list is input-item [,input-item]...

An input-item is either:

variable-reference

or

(input-list iterative-DO)

No comma separates the iterative-DO from its associated input list.

An input list consisting of one iterative-DO has two sets of parentheses, as shown in the following example:

GET LIST (((ARR(I,J) DO I = 1 TO 5) DO J = 1 TO 5))

Each variable reference may be either an array reference, structure reference, or scalar variable reference. Structures with the UNION attribute cannot be used as variables in a GET statement.

The options may appear in any order.

Description

The GET statement gets data from an input stream that is either a stream file or a character-string expression. The input file may be declared either with the STREAM attribute or with the default SYSIN, commonly associated with the user's default input device.

The GET statement has several forms, which include the following options: format-list, FILE, SKIP, STRING, and LIST, or EDIT.

format-list
Specifies a list of format items separated by commas.
FILE
References a file value whose associated file has either been opened as a STREAM input file, or is closed. If closed, the file is opened by the GET statement, as described in the section Stream I/O in the chapter Language Concepts, and given the STREAM and INPUT attributes.
STRING
Specifies that the input item is a character-string expression. The STRING option cannot be used with the FILE or SKIP option.
SKIP
Advances the input file a specified number of lines before processing the input list. The expression in the SKIP option must produce a positive fixed-point integer value n. The SKIP option skips across n line boundaries and resets the current column to one.
LIST
Specifies list-directed input.
EDIT
Specifies edit-directed input.

The FILE, SKIP, and LIST options or the FILE, SKIP, and EDIT options may be given in any order, but a format list is contained in the EDIT option and must immediately follow the input list. If SKIP is given without (n), a value of one is supplied. If FILE is not given, FILE(SYSIN) is supplied by default.

After any SKIP option has been evaluated, the input list is evaluated together with any format list.

The input list is evaluated from left-to-right. Each variable reference may be an array reference, structure reference, or scalar variable reference.

A scalar variable reference causes one value to be transmitted from the input stream and, if EDIT is specified, it uses one data format. An array variable causes n values to be transmitted, where n is the number of elements in the array. If EDIT is specified, it uses n data formats. Values are transmitted to the array in row-major order, as defined in the section Arrays in the chapter Data Types. A structure variable causes all members of the structure and members of all contained substructures to receive a value. The values are transmitted in left-to-right order. If EDIT is specified, each value requires a data format.

Only arithmetic, pictured, and string values can be transmitted by a GET statement. In Open PL/I, the maximum length of a string value transmitted by a GET statement is 256 bits for bit strings or 256 characters for character strings.

A parenthetical input list containing an iterative-DO transmits values under control of the iterative-DO as if it were a DO-group.

The number of lines read by a GET statement is determined by the size of the list, the SKIP option, and any control formats given in the format list. However, unless control items or SKIP forces new lines to be read, transmission begins with the current position of the current line and uses as many lines as are necessary to satisfy the input list.

The maximum length of any line in the input file is limited to the larger of 258 or the value of the LINESIZE option (specified in the OPEN statement) plus 2. If a line in the file is longer than this limit, the GET processing will truncate it with no run-time warning.

Examples

The following example shows a GET statement whose input list consists of one iterative-DO.

GET FILE(F) LIST((A(K),B(K) DO K = 1 TO 10))

Note that this is the same as:

DO K = 1 TO 10;
   GET FILE(F) LIST(A(K),B(K));
END;

The following example shows a GET statement whose parenthetical input-list contains an iterative-DO, which transmits values under control of the iterative- DO as if it were a DO-group.

DECLARE A(10) FLOAT;
DECLARE (B,C) FLOAT;
   .
   .
   .
GET FILE(F) LIST(A,B,C);
GET FILE(F) EDIT(A(K),K,B(K)) (3 E(14,6));
GET FILE(F) LIST(B,(A(K) DO K = 1 TO 5),C);

In this example, the first GET statement transmits 10 values to the array A and then transmits values to B and C in that order. The second GET statement transmits a value to A (K) , transmits a value to K, and then transmits a value to B (K) using the new value of K as a subscript. All three values are transmitted using the same E-format. The third GET statement transmits a value to B, transmits values to A(1),A(2),A(3),A(4), and A(5), and to C in that order.

The following example shows a GET statement with the STRING option.

GET EDIT (NAME.FIRST,NAME.LAST) (A(8),X(3),A(20))
STRING('Deborah M. Park                ');

In this example, the GET statement assigns the character string 'Deborah box ' to the structure NAME.FIRST, skips the middle initial, periods, and space, and assigns the character string 'Park boxes ' to NAME.LAST. Blanks may be used to separate items in list-directed I/O, but for edit-directed I/O they are interpreted differently for character strings. For example, the same example would be interpreted as follows for edit-directed I/O with the format (A (10) , X (3) , A(20)):

For list-directed I/O, the following example:

GET LIST(NAME.FIRST, NAME.LAST)
STRING('Deborah M. Park                ');

would assign 'Deborah' to NAME.FIRST and 'M.' to NAME.LAST.

The following sections contain additional information on the EDIT and LIST options.

  • Edit-Directed Input
  • List-Directed Input
Parent topic: Statements
Related information
Stream I/O
Arrays


Edit-Directed Input

The EDIT option of the GET statement specifies edit-directed input.

The GET EDIT statement uses a format list to control scanning of the input stream and conversion of fields. Each field is first converted under control of a data format and the converted value is then assigned to the corresponding list variable. An additional conversion may occur as part of that assignment.

For a description of each data format conversion, see the section Format Controlled Conversion in the chapter Data Type Conversions, and for a description of format-list evaluation, see the section FORMAT Statement.

GET FILE(F) EDIT(A,B,C) (E(14,3),SKIP,F(10));
GET FILE(F) EDIT(D) (A(10));

In this example, A is assigned the field converted by E (14,3) , a new line is read by SKIP, B is assigned the field converted by F (10) , and C is assigned the next field converted by E (14, 3). The SKIP is not evaluated a second time, because no variables remain in the list. D receives a value from the field converted by A (10) . That field is the 10 characters that immediately follow the second field that was converted by E (14, 3) and assigned to C. Note that the A-Format is used without a field width to read a variable-length line, as discussed in the section A-Format in the chapter Data Type Conversions.

When multiple (input-list) (format-list) pairs are specified, this is equivalent to specifying all the input items consecutively in one list, then all the format items consecutively in one list.

Parent topic: GET
Related information
Format Controlled Conversion
FORMAT Statement
A-Format


List-Directed Input

The LIST option of the GET statement specifies list-directed input.

The GET LIST statement causes each value expected by the input list to be read from the stream file without the use of a format item.

For list-directed input, the stream file must contain a sequence of fields, each of which is followed by a blank or a comma. Excess blanks may occur between fields.

A field whose value is to be assigned to an arithmetic, pictured, or bit-string variable X must contain an optionally signed constant of the same form as could appear on the right side of an assignment statement whose target was X.

A field whose value is to be assigned to a character-string variable begins with the next non-blank character in the stream and ends with the character immediately before the next blank or comma. However, the field can be delimited by single quote characters, and in this case it can contain embedded blanks and commas. If single quote delimiters are used, two adjacent single quotes are interpreted as one single quote in the field's value.

Parent topic: GET


GOTO

Purpose

Transfers control to a labeled statement in the current procedure or in another active procedure.

Syntax

GOTOlabel-reference[OTHERWISE];

Alternate form: GO TO for GOTO

Abbreviation(s): OTHER for OTHERWISE.

Parameters

label-reference
Identifies a label value.

Description

The GOTO statement transfers control to a labeled statement in the current procedure or in another active procedure.

If the label value is a label variable or label-valued function, its value must designate a statement in the current procedure block or in a containing procedure block. The value must also designate a stack frame belonging to a Nock activation of that block.

If the statement to which control is transferred is not within the current block, the current block activation is ended, as are all previous block activations back to the block containing the statement. That block activation is made current, and control is transferred to the statement.

The OTHERWISE option can be used only with a subscripted GOTO statement. A subscripted GOTO statement is defined as a statement directing control to a label that is subscripted.

References to an invalid subscripted label in a GOTO statement are generally considered to be errors. For example, ALABEL ( 1 ) in the second example below, is an undefined member of the array, and ALABEL ( 3 ) is a member that is out of bounds of the array.

However, the OTHERWISE option can be used to cause control to pass to the statement that follows the GOTO statement if the element referred to is not a valid member of the array of label constants.

For a more complete discussion of label values, see the section Label Data in the chapter Data Types.

Example

GOTO L;
GOTO CASE(K);
GO TO L;

The following example contains an array of subscripted label constants called ALABEL. The GOTO statement directs control to the statement that accompanies the subscripted label ALABEL (2) .

ALABEL(0): STATEMENT;
ALABEL(2): STATEMENT;
   X = 2; GOTO ALABEL( X );

The following program sample presents the variable I used as a subscript in a GOTO statement that is subscripted on the third line. If the reference ALABEL ( I ) is not valid, the OTHERWISE option causes control to pass directly to the PUT LIST statement on the fourth line.

NEXT: GET LIST (I);
   GOTO ALABEL (I) OTHERWISE;
   PUT LIST( "INVALID");
   GOTO NEXT;

ALABEL( 1 ):
   .
   .
   .
GOTO NEXT;

ALABEL( 2 ):
   .
   .
   .
GOTO NEXT;

Restrictions

None.

Parent topic: Statements
Related information
Label Data


IF

Purpose

Conditionally executes code based on a test expression.

Syntax

IF test-expression THEN clause[;ELSEclause];

Parameters

test-expression
Any expression that results in a scalar bit string value of length ?1. The test-expression is considered true if any bit in the string is one; the expression is considered false only when all bits are zero.
clause
Either a BEGIN block, DO-group, or statement other than END, PROCEDURE, DECLARE, or FORMAT.

Description

The IF statement evaluates the test-expression. If the expression is true, the THEN clause is executed; otherwise, the ELSE clause, if present, is executed.

When an IF statement is used as a THEN or ELSE clause of another IF statement, any ELSE is always matched with the nearest unmatched preceding THEN.

test-expressions in IF statements may produce bit(n) values, where n>1. In this case, the test expression will be considered true if any of the bits in the string are 1 and false only when all bits are 0.

Example

IF A>B
   THEN IF C>D
      THEN X = 5;
      ELSE X = 10;

In this example, the ELSE clause is associated with IF C > D THEN X = 5 ;

To associate an ELSE with the first THEN, you may write an ELSE or an empty ELSE with the second THEN, as shown in the following examples.

IF A>B;
   IF C>D THEN X=5;
   ELSE;
ELSE X = 10;

or

IF A>B THEN DO;
   IF C>D THEN X=5;
   END;
ELSE X = 10;

Restrictions

None.

Parent topic: Statements


%INCLUDE

Purpose

Incorporates text from other files into the current source file during compilation.

Syntax

%INCLUDE filename[,filename]…;

Parameters

filename
One of the following: a character string, an Open PL/I name, or an Open PL/I name enclosed in parentheses.

The specified filename is used to locate a text file whose content is inserted into the program text in place of the %INCLUDE statement.

Description

The %INCLUDE statement incorporates text from other files into the current source file during compilation.

The %INCLUDE statement can appear in place of a name, constant, or punctuation symbol. The included text may contain additional %INCLUDE statements. %INCLUDE statements normally contain declarations that are common to more than one program module.

Open PL/I searches for a file to satisfy the %INCLUDE statement according to the following rules. (See the section Compiler Options in the chapter Using Open PL/I in your Open PL/I User's Guide).

In the following rules, we use the term "absolute directory path" for a path specifier beginning with a slash (/), such as /tmp/inc, and "relative directory path" for other path specifiers, such as sys/ or .. /.

  • When the %INCLUDE 'filename'; form is used; that is, the quoted filename form:
    • filename may be more than just a simple PL/I identifier. For example, it may contain the commonly used "." (period) character, as in,
      %INCLUDE 'fiiename.pl1.inc';

      It may also contain a directory path, as in,

      %INCLUDE '/pl1/src/inc/filename';
    • If the %INCLUDE statement specifies an absolute directory path, the indicated file will be sought in the specified directory and that directory only.
    • If the %INCLUDE statement does not specify an absolute directory path and the -ipath option is not specified, the indicated file is sought in the current working directory.
    • If the %INCLUDE statement does not specify an absolute directory path and the -ipath option is specified, the indicated file is sought in the directories specified by the -ipath option. These directories are searched in the order in which they are specified. If the file is not found in these directories, a final check is made for it in the current working directory.
    • When the quoted filename form is used, the -isuffix option is never used.
    • When the quoted filename form is used, Open PL/I searches for the file using the character case of each letter of filename exactly as specified. That is, the filename is not converted to uppercase, and no additional searches using other cases are conducted.
  • When the %INCLUDE filename; or the equivalent %INCLUDE (filename), form is used:
    • If the -ipath option is not specified, the indicated file is sought in the current working directory.
    • If the -ipath option is specified, the indicated file is sought in the directories specified by the -ipath option. These directories are searched in the order in which they are specified. If the file is not found in these directories, a final check is made for it in the current working directory.
    • If the -isuffix option is used in the compiler invocation, the character string specified in the -isuffix option is appended to filename before the file search is conducted. For example, if -isuffix.inc is specified, the file to be searched for is filename.inc.

      In this case, with the filename not in quotes, Open PL/I first searches for the file with filename in uppercase characters; that is, FILENAME. If that search fails, Open PL/I tries again using lowercase letters.

Example

%INCLUDE 'FILE1.IN','FILE2.IN','FILE3.IN';

%INCLUDE FILE4,'FILE5',(FILE6),(FILE7);

%INCLUDE 'TOTAL.IN';

In the previous examples, the contents of the files referenced by FILEn, and so on, and by 'TOTAL.IN' will be copied into the current file at compile time.

DECLARE I
%INCLUDE 'FDCL.IN'; STATIC INITIAL (0);

Assuming that the file referenced by ' FDCL.IN ' contains the single line FIXED BINARY (31) , this example is equivalent to the following:

DECLARE I FIXED BINARY (31) STATIC INITIAL (0);

Restrictions

None.

Parent topic: Statements
Related information
Compiler Options


LEAVE

Purpose

Transfers control out of the immediately containing DO-group or the containing DO-group whose label is specified with the statement.

Syntax

LEAVE [label-reference];

Parameters

label-reference
A reference to a label on a DO statement that heads a containing DO-group. The label reference must be a label constant or a subscripted label constant for which the subscript is specified with an integer constant.

Description

The LEAVE statement transfers control out of the immediately containing DO-group or the containing DO-group whose label is specified with the statement.

Execution of a LEAVE statement with no label reference transfers control to the first statement following the END statement that ends the immediately controlling DO-group. If the LEAVE statement has a label, control is passed to the first executable statement after the END statement for the corresponding DO label indicated in the LEAVE statement. In this manner, the LEAVE statement serves as an alternate means to end the execution of a DO-group.

A LEAVE statement with a label reference can cause several nested DO-groups to be ended as control transfers outside the referenced DO-group.

Example

In the following example, the LEAVE statement, shown without a label reference, transfers control directly to the PUT statement if the condition in the IF statement is satisfied.

DO K = 9 TO 91;
   .
   .
   .
   IF COMMAND = 'QUIT' THEN LEAVE;
   .
   .
   .
END;
PUT LIST ('Job finished');

In the next example, the LEAVE statement, shown with a label reference, transfers control to the first statement following the END statement that ends LOOP2:

LOOP2: DO WHILE (MORE);
   .
   .
   .
   LOOP3: DO J = 2 TO 5;
   .
   .
   .
      IF QUAN(J) > 150 THEN LEAVE LOOP2;
   END;     /* Loop 3 */
   .
   .
   .
END;       /* Loop 2 */

Restrictions

The LEAVE statement must be contained within a DO-group and must be in the same block as the DO statement to which it refers.

If the LEAVE statement has a label reference, it must refer to a label on a DO statement that heads a DO-group that contains the LEAVE statement. The LEAVE statement must be in the same block as the labeled DO statement.

The label reference cannot be a label variable or a subscripted label constant.

Parent topic: Statements


%LIST

Purpose

Causes the Compiler to resume placement of listing information to the list file.

Syntax

%LIST;

Description

The %LIST statement causes the Compiler to resume placement of listing information to the list file.

Restrictions

None.

Parent topic: Statements


%NOLIST

Purpose

Stops the placement of listing information to the list file.

Syntax

%NOLIST;

Description

The %NOLIST statement stops the placement of listing information to the list file.

Restrictions

None.

Parent topic: Statements


NULL

Purpose

Placeholder statement.

Syntax

;

Description

The NULL statement performs no action, but is used to provide null THEN or ELSE clauses in IF statements, null ON-units in ON statements, or to allow multiple label prefixes.

Example

A:;
B:;
C: ON ENDPAGE (F);

In this example, the ON statement has a null ON-unit and is preceded by two labeled null statements, effectively giving the ON statement three labels. However, these labels do not compare equally because they designate different statements.

Restrictions

None.

Parent topic: Statements


ON

Purpose

Identifies the action to be taken when a particular condition is raised during execution of a program.

Syntax

ON condition-name ON-unit;

or

ON condition-name SYSTEM;

Parameters

condition-name
ANYCONDITION, AREA, ATTENTION, CONDITION(name), CONVERSION, ENDFILE(f), ENDPAGE(f), ERROR, FINISH, FIXEDOVERFLOW, KEY(f), OVERFLOW, RECORD(f), SIZE, UNDEFINEDFILE(f), UNDERFLOW, USERCONDITION (expression), USERCONDITION(SS$_UNWIND), VAXCONDITION (expression), or ZERODIVIDE.
ON-unit
A BEGIN block or a statement other than PROCEDURE, DO, END, DECLARE, FORMAT, or RETURN, which may include the CALL RESIGNAL statement.
Note:

Abbreviation(s):

  • ATTN for ATTENTION
  • COND for CONDITION
  • CONV for CONVERSION
  • OFL for OVERFLOW
  • UFL for UNDERFLOW
  • UNDF for UNDEFINEDFILE
  • ZDIV for ZERODIVIDE

Description

The ON statement identifies the action to be taken when a particular condition is signaled during execution of a program.

The ON statement is executable and must be executed before the statement that signals the specified condition.

Execution of the ON statement establishes the ON-unit as if it were a procedure that is to be called when the condition is signaled. It does not execute the ON-unit.

If an ON-unit for this condition has already been established in the current block activation, it is replaced by this ON-unit.

During its execution, an ON-unit can do any of the following:

  • Handle the condition, then return control to the point at which the condition was signaled.
  • Resignal the condition and ask Open PL/I to find another ON-unit to handle the condition.
  • Execute a nonlocal GOTO statement, which causes Open PL/I to unwind the call stack.
  • End the program.

An ON-unit remains established until it is replaced by another, until it is reverted by a REVERT statement, or until the block activation in which it was established is ended.

When a condition is signaled, each block activation, beginning with the current block activation, is examined to see if it has an established ON-unit for the condition. If it does not, the previous block activation is examined until an ON-unit for the condition is found. If no ON-unit exists, a default ON-unit is invoked. The default ON-unit for ENDFILE signals the ERROR condition. The default ON-unit for ENDPAGE puts a new page; that is, it is equivalent to executing a PUT PAGE statement. The default ON-unit for FINISH returns control to the point in the program following the location where the signal occurred. The default ON-unit for all the other conditions signal the ERROR condition which, if not handled by an ON-unit for ERROR, causes an error diagnostic to display and then halts the program.

The consequence of this mechanism is that a block may establish its own ON-unit for a condition or may choose to let its caller's ON-unit handle the condition. Any ON-unit established by a block is reverted to when the block returns to its caller or is otherwise terminated.

A signal causes an ON-unit to be called just as if it were a procedure that had no parameters. The block activation resulting from this call is terminated when the ON-unit executes a GOTO or executes its END statement. In the latter case, control returns to the source of the signal.

A GOTO executed within an ON-unit and transferring control out of the ON-unit terminates the block activation of the ON-unit and any block activations back to, but not including, the activation of the block to which control is transferred.

The ON-conditions ENDFILE, ENDPAGE, KEY, and UNDEFINEDFILE are uniquely established for each file control block and are always written with a reference f that must identify a file value. The condition so referenced is effectively qualified by the file control block associated with f. Thus, ENDFILE(g) and ENDFILE(h) are different conditions if g and h identify different file control blocks, but they are the same condition if g and h identify the same file control block.

Just before these conditions are signaled, the value of the ONFILE built-in function is set to the file ID of the file control block for which the condition is being signaled. An ON-unit must not have a label prefix.

Unless otherwise specified, the default ON-units for the following conditions signal the ERROR condition which, if not caught, will print a message and end the execution of the program.

The SYSTEM keyword indicates that instead of executing the code in the ON-unit, a message describing the condition is printed and the ERROR condition is raised.

The ON condition SYSTEM statement can be useful when the user is trying to prevent an infinite loop in the exception handler when, for instance, an ERROR condition is raised in an ERROR ON-unit .

ON ERROR BEGIN;
        ON ERROR SYSTEM;
.
.
.
END;

If in the above example, the code following the ON ERROR SYSTEM statement causes an error exception, the program will be terminated after the message describing the error condition is printed.

The ON conditions are described as follows.

  • ANYCONDITION

    The ANYCONDITION ON-unit handles any signaled condition that cannot be handled by any other ON-unit. The ANYCONDITION ON-unit executes after every other ON-unit established in the block has been examined and found not to match the signaled condition.

  • AREA

    The AREA condition is raised when an attempt is made to allocate a based variable within an area that has too little free storage to accommodate it. The ON-unit for the AREA condition (for example, for a based area) can change the value of the pointer qualifying the area reference to point to a different area, where the allocation will be attempted again; or it can write out the area and reset it to empty.

    The AREA condition is also raised when an area assignment is attempted where the maximum size of the source area exceeds that of the target area.

  • ATTENTION

    The ATTENTION condition is raised when you signal attention at the terminal during program execution. This condition interrupts processing to enter an ATTENTION ON-unit.

    Upon return from an ATTENTION ON-unit, processing resumes at the point in the program immediately after the point at which the interrupt occurred.

  • CONDITION(name)

    The CONDITION condition is signaled by a SIGNAL statement that specifies the appropriate name. The name specified in the SIGNAL statement specifies which CONDITION condition is to be signaled. Note that the name specified in the CONDITION should be a condition name.

    This condition allows the user to establish an ON-unit that will be executed whenever a SIGNAL statement is executed specifying CONDITION and a name that matches the name in the ON statement.

    The following is an example of an ON CONDITION statement:

    ON CONDITION(OVERDRAFT) BEGIN;

   PUT SKIP LIST('ACCOUNT HAD AN OVERDRAFT ON'||DATE())');

END;
.
.
.
IF ACCOUNT_BALANCE < TOTAL WITHDRAWAL THEN SIGNAL CONDITION(OVERDRAFT);
  • CONVERSION

    The CONVERSION condition is signaled whenever an invalid conversion is attempted on character data. This attempt can be made during direct assignment of character data to numeric variable or during an input/output operation. For example, this condition can be raised when a character value that is being converted to a Fixed Binary value contains non-numeric characters, or if a character other than 0 or 1 is being converted to a bit data type.

    All conversions of character data are carried out character-by-character in a left-to-right sequence. The condition is raised for every invalid character.

    When an invalid character is encountered, the invalid character can be replaced within the ON-unit by using the ONSOURCE or ONCHAR pseudovariables.

    Upon return from a CONVERSION ON-unit, the program will retry the conversion if the ONSOURCE or ONCHAR pseudovariable has been used. If the error is not corrected, the ERROR condition is raised and control is passed back to the code that caused the exception to occur.

  • ENDFILE(f)

    The ENDFILE condition is signaled when an attempt is made to read past the end of a file. The end-of-file status of the file control block remains set so that subsequent reads also cause the signal to occur.

    Returning from the ON-unit transfers control to the statement following the GET or READ statement.

  • ENDPAGE(f)

    The ENDPAGE condition is signaled when the line to be written has a line number that is one greater than the page size or when a line number option that specifies a line number less then the current line number is issued for the STREAM OUTPUT PRINT file identified by f.

    If an ON-unit returns without writing a new page, the line number of the file increases indefinitely and the ENDPAGE condition is not signaled by subsequent output. However, if a new page is written by the ON-unit or at any time later, it resets the line number and allows ENDPAGE to be signaled the next time that the line number is one greater than the page size.

    Returning from the ON-unit returns to the point where the signal occurred and any additional output is then written to the stream.

    The default ON-unit puts a new page and returns.

  • ERROR

    The ERROR condition is signaled whenever the implementation detects an error. Just prior to signaling the condition, the value of the ONCODE built-in function is set to an implementation-defined integer value that serves as an error code that indicates which error occurred. (For more information, see your Open PL/I User's Guide.)

    Returning from the ON-unit produces an error message and ends program execution by executing a STOP statement.

    The default ON-unit writes an error message on an implementation-defined error file and executes a STOP statement. (For more information, see your Open PL/I User's Guide.)

    The following is an example of an ON ERROR statement.

    ON ERROR BEGIN;
   PUT SKIP LIST ('AN UNIDENTIFIED ERROR OCCURRED');
END;
  • FINISH

    The FINISH condition handles the following conditions:

    • A STOP statement has been executed.
    • The main procedure has executed a RETURN statement or END statement.
    • The program is exiting because of an error condition not handled by any ON-unit.

    The default ON-unit does nothing and simply returns. If an ON FINISH ON-unit executes a STOP statement, the result is undefined.

  • FIXEDOVERFLOW

    Open PL/I accepts the syntax for the ON FIXEDOVERFLOW statement. However, since there is not adequate hardware support for this condition on the computers supported by Open PL/I, the FIXEDOVERFLOW condition is never raised (unless explicitly raised by the SIGNAL statement).

  • KEY(f)

    The KEY condition is signaled when a READ, REWRITE, or DELETE statement containing a KEY option cannot find a record with the specified key. It is also signaled by a WRITE statement whose KEYFROM option specifies a key of an existing record.

    Just before the condition is signaled, the key value is assigned as the value to be returned by the ONKEY built-in function.

    Returning from the ON-unit resumes execution with the statement following the record I/O statement.

    The following is an example of the ON KEY(f) statement.

    ON KEY(OUTFILE) BEGIN;
   PUT SKIP LIST('INVALID KEY SPECIFIED FOR OUTFILE');
   PUT SKIP LIST('KEY WAS'||ONKEY());
END;
  • OVERFLOW

    The OVERFLOW condition is signaled when the result of an arithmetic operation on a floating-point value exceeds the maximum value that can be represented.

    The maximum values for decimal float values and binary float numbers are described in your Open PL/I User's Guide.

    Returning from the ON-unit produces an error message and ends program execution by executing a STOP statement.

  • RECORD(f)

    The RECORD condition can be raised during a READ, WRITE, or REWRITE operation. This condition is raised when:

    • The record variable is smaller than the record size. This may occur for one of the following reasons.
      • The record is larger than the variable in a READ INTO statement. The remainder of the record is lost.
      • The record length specified for a file with fixed-length records is larger than the variable in a WRITE or REWRITE statement. The remainder of the record is undefined. If the variable is a varying-length string, the RECORD condition is not raised if the SCALARVARYING option is applied to the file.
    • The record variable is larger than the record size. This may occur for one of the following reasons.
      1. The record length specified for a file with fixed-length records is smaller than the variable in a READ INTO statement. The remainder of the variable is undefined. If the variable is a varying-length string, the RECORD condition is not raised if the SCALARVARYING option is applied to the file.
      2. The maximum record length is smaller than the variable in a WRITE or REWRITE statement. The remainder of the variable is lost.
      3. The variable in a WRITE or REWRITE statement indicates a zero length. No transmission occurs. If the variable is a varying-length string, the RECORD condition is not raised if the SCALARVARYING option is applied to the file.
    • The record variable length is either zero or too short to contain the embedded key. This occurs because the variable in a WRITE or REWRITE statement is too short to contain the embedded key.
  • SIZE

    The SIZE is disabled by default. Because Open PL/I does not support condition prefixes, which is the language mechanism by which this behavior is enabled, an alternate method is provided.

    The following Open-PLI runtime call is exposed as built-in subroutine:
    call P$SZCOND(1);  /*  enables the SIZE condition */
call P$SZCOND(0);  /*  disables the SIZE condition */
  • UNDEFINEDFILE(f)

    The UNDEFINEDFILE condition is signaled when an error occurs while attempting to open a file.

    Returning from the ON-unit transfers control to the statement following the OPEN statement.

  • UNDERFLOW

    The UNDERFLOW condition is signaled when the absolute value of the result of an arithmetic operation on a floating-point value is smaller than the minimum value that can be represented. (See your Open PL/I User's Guide.)

    The default ON-unit simply returns. The value resulting from an operation that causes the UNDERFLOW condition is set to zero.

  • USERCONDITION (expression)

    The USERCONDITION (expression) ON-unit handles the condition specified by expression, which must be evaluated to an integer. This ON-unit is invoked in response to execution of the SIGNAL USERCONDITION statement matching the expression value. For more information, see the section SIGNAL Statement.

    The USERCONDITION condition may be signaled using the SIGNAL statement. The value of the expression specified as the USERCONDITION is determined when the ON statement is executed, and not when the condition is signaled. A range of numbers specified in your Open PL/I User's Guide will be allocated for system use.

  • USERCONDITION (SS$_UNWIND)

    The USERCONDITION (SS$_UNWIND) ON-unit handles the condition that is signaled by an UNWIND condition. An UNWIND condition occurs when a nonlocal GOTO forces execution to proceed from a previous block which, in turn, causes frames to be removed from the call stack.

    This is a special case of USERCONDITION (expression). The name SS$_UNWIND is available as a GLOBALREF and must be declared as such.

  • VAXCONDITION (expression)

    The VAXCONDITION (expression) ON-unit is synonymous with the USERCONDITION (expression) ON-unit, and is provided for ease of program conversion. An ON-unit for one can be used to catch a SIGNAL of either.

  • ZERODIVIDE

    The ZERODIVIDE condition is signaled when the divisor in a division operation has a value of zero. The resulting value is undefined.

    Returning from the ON-unit produces an error message and ends program execution by executing a STOP statement.

Restrictions

None.

Parent topic: Statements
Related information
Introduction
Statement that Handles Exceptional Conditions
SIGNAL Statement


OPEN

Purpose

Causes the file identified by file_id to be opened with the attributes specified. .

Syntax

OPEN file_attribute_list[,file_attribute_list]…;

Parameters

file_attribute_list must include the FILE(file_id) option. It may include any of the following: [TITLE(s)] [LINESIZE(n)] [PAGESIZE(m)] [STREAM] [RECORD] [INPUT] [OUTPUT] [UPDATE] [PRINT] [KEYED] [SEQUENTIAL] [DIRECT], where:
file_id
One or more references to the files to be opened, and bracketed items are file attributes.
s
The name by which the operating system knows the file(s).
n
The maximum number of characters that can be output in a single line for the STREAM file.
m
The maximum number of lines that can be written to the print file without signaling the ENDPAGE condition.

These attributes, including FILE(file_id), may be in any order.

Description

Execution of the OPEN statement causes the file identified by file_id to be opened with the attributes specified in the OPEN statement.

The FILE option must be specified and file_id must be a reference that produces a file value. If the file identified by file_id is already open, the OPEN statement is ignored, even if its attributes disagree with those of the already opened file. The program in which file_id is declared should be compiled with the -defext compiler option. For more information on compiler options, see your Open PL/I User's Guide

The OPEN statement opens each specified file with a specified set of attributes that describe both the file and the file access method. The options and attributes may be specified in any order. If specified, line size n and pagesize m must be expressions that produce positive integer values. The default value of the LINESIZE option is 120, and the default value of the PAGESIZE option is 60.

For indexed or VSAM files, the record size is specified in the ENVIRONMENT options in the declaration of the file.

Example

OPEN FILE(F) STREAM INPUT;
OPEN FILE(F) TITLE ('MASTER_FILE.NEW') UPDATE;
OPEN FILE(G) LINESIZE(80) PAGESIZE(60) STREAM OUTPUT PRINT;

Restrictions

None.

Parent topic: Statements
Related information
Input and Output


%OPTION

%OPTION is accepted without a diagnostic message and ignored for now.
Parent topic: Statements


%PAGE

Purpose

Causes the statement following the %PAGE statement in the program listing to be printed on the first line of the next page.

Syntax

%PAGE;

Description

The %PAGE statement causes the statement following the %PAGE statement in the program listing to be printed on the first line of the next page of the listing file.

Restrictions

None.

Parent topic: Statements


%POP

Purpose

Restores the previously pushed status of %PRINT, %NORPINT, %LIST and %NOLIST from the push-down stack.

Syntax

%POP;

Description

%POP allows you to restore the status of %PRINT, %NOPRINT, %LIST and %NOLIST saved by a %PUSH directive.

%POP is commonly used in included files and macros.

Parent topic: Statements
Related reference
%PRINT
%LIST
%NOPRINT
%NOLIST
%PUSH


%PRINT

%PRINT is a synonym for %LIST.

Parent topic: Statements
Related reference
%LIST


%NOPRINT

%NOPRINT is a synonym for %NOLIST.

Parent topic: Statements
Related reference
%NOLIST


PROCEDURE

Purpose

Defines the start of a procedure block and specifies the parameters of the procedure, if any.

Syntax

name:PROCEDURE[(parameter-list][RETURNS(t)][EXTERNAL|INTERNAL]
             [RECURSIVE][ORDER|REORDER][REDUCIBLE|IRREDUCIBLE]
             [OPTIONS(options-list)];
Note:

Abbreviation(s):

  • PROC for PROCEDURE
  • EXT for EXTERNAL
  • INT for INTERNAL
  • RED for REDUCIBLE
  • IRRED for IRREDUCIBLE

Parameters

parameter-list
One or more parameters, separated by commas, which are expected by the procedure when it is activated. Each parameter specifies the name of a variable declared in the procedure headed by the PROCEDURE statement.
t
A list of data type attributes.
options-list
May be MAIN or VARIABLE.

Options may be specified in any order.

Description

The PROCEDURE statement defines the start of a procedure block and specifies the parameters of the procedure, if any. If the procedure is invoked as a function, the PROCEDURE statement also specifies the data type attributes of the value that the function returns to its point of invocation. Execution of a PROCEDURE statement as a consequence of the normal flow of control from the previous statement has no effect and execution resumes with the statement following the procedure's END statement.

The PROCEDURE statement must have a label prefix that declares the name of the procedure. The label declares the primary entry point. That declaration is established in the block that contains the PROCEDURE statement, and consequently makes the name known in that block and in all contained blocks. The procedure's END statement may contain the name of the procedure so that it can be easily identified as the closing END statement. (See the section END Statement.)

Each name in the parameter-list must be declared within the procedure, must not be a member of a structure, and must not be declared with a storage class attribute.

Every call to a procedure not declared with the OPTIONS(VARIABLE) attribute must be made with an argument list containing the same number of arguments as there are parameters in the parameter list, and each argument must be capable of being passed either by reference or by value to its corresponding parameter.

If a RETURNS option is not specified, the procedure must always be called by a CALL statement, and it must not contain any RETURN statements that specify a return value.

If a RETURNS option is specified, t must be a set of data type attributes that specify a scalar value. All values returned by the procedure are converted to this data type prior to being returned as the function value of the procedure. All RETURN statements must specify a return value and the procedure must not execute its own END statement. All calls to the procedure must result from the evaluation of a function reference.

Only one of EXTERNAL or INTERNAL may be specified and only on top-level procedures, that is, those procedures that are not contained within the scope of any other procedure. If EXTERNAL is given, the procedure will be external to the current file being compiled and can be called by other separately compiled procedures. This is the default. If INTERNAL is given, the procedure can only be called by other procedures within the current compilation. Its name is not made available outside this file.

OPTIONS(MAIN) explicitly defines the routine where execution of the program begins. Only one OPTIONS(MAIN) statement is allowed within a program. In a linked executable program, one and only one procedure must be so identified as the main procedure. See the section Main Procedure in the chapter Language Concepts in your Open PL/I User's Guide.

ORDER and REORDER are options sometimes used for optimization in IBM mainframe PL/I programs. Similarly, REDUCIBLE and IRREDUCIBLE are attributes sometimes used by IBM mainframe PL/I programs. None of these are needed by Open PL/I. These options are simply parsed and otherwise ignored by Open PL/I.

The COBOL NOMAP [map-list] option

The FORTRAN NOMAPIN [map-list] option

The TASK NOMAPOUT [map-list] option

The NOEXECOPS option

The OPTION(BYTEADDR) option can be used to ensure the passing of byte addresses, even for items allocated on a bit boundary. When this option is not specified, Open PL/I passes bit addresses for unaligned bit strings. When this option is specified, Open PL/I passes just the address of the first byte of unaligned bit strings.

The word RECURSIVE may be supplied for purposes of documentation. All Open PL/I procedures are capable of recursive use, provided they follow standard recursive programming requirements, such as not using STATIC data.

Procedures may contain other procedures and BEGIN blocks, as well as any other statements.

Example

P: PROCEDURE(A,B) RETURNS(FIXED BINARY(15));
   DECLARE(A,B) FLOAT;
   DECLARE C FIXED BINARY(15);
   .
   .
   .
   RETURN ©);
   END P;

Q:PROCEDURE(X) RECURSIVE;
   DECLARE X CHARACTER(*);
   .
   .
   .
   CALL Q('HELLO');
   END Q;

Restrictions

None.

Parent topic: Statements
Related information
END Statement
Parameter Storage Class
Main Procedure


%PROCESS

Purpose

Specifies the following set of compiler options: MARGINS, NAMES, OR ('|'), NOT ('^')

Syntax

%PROCESS [compiler-option] ...;

Parameters

MARGINS
Sets the margins within which characters of the source file are interpreted as source code and outside which all characters are ignored by the Compiler. The statement may be inserted anywhere within the source file. The limits apply to all source code following the %PROCESS MARGINS statement until another %PROCESS MARGINS statement is encountered or until the file ends. If tabs are used, each tab is counted as a single character.
Note: The same effect may be achieved for an entire source file by using the -margins compiler option switch. For more information, see your Open PL/I User's Guide.
%PROCESS[MARGINS l,r[,p]];
I
The column number of the leftmost character to be interpreted as source code.
r
The column number of the rightmost character to be interpreted as source code.
p
The column number of the pointer control character. This is currently ignored by the Open PL/I Compiler.
NAMES
Defines the extralingual characters that are allowed in identifiers.
%PROCESS NAMES ('#@$' '#@$')
OR ('|')
Accepts up to seven optional string characters which may be used as the OR symbol.
NOT ('^')
Accepts up to seven optional string characters which may be used as the NOT symbol.

Example

%PROCESS MARGINS (5,55) OR('!|') NOT('^~')
In this example, only the text contained between columns 5 and 55 of the source line will be interpreted by the Compiler; however, the source listing will contain the whole source line. ! and | will be interpreted as the OR symbol and ^ and ~ will be interpreted as the NOT symbol.

Restrictions

None.

Parent topic: Statements


*PROCESS

A synonym for % PROCESS.
Parent topic: Statements
Related reference
%PROCESS


%PUSH

Purpose

Saves the current status of %PRINT, %NORPINT, %LIST and %NOLIST in a push-down stack.

Syntax

%PUSH;

Description

%PUSH allows you to save the current status of %PRINT, %NOPRINT, and %LIST and %NOLIST in a push-down stack on a last-in, first-out basis.

%PUSH is commonly used in included files and macros.

Parent topic: Statements
Related reference
%PRINT
%LIST
%NOPRINT
%NOLIST
%POP


PUT

Purpose

Transfers data from the program to the output stream.

Syntax

PUT[FILE(f)][SKIP[(n)]][LINE(m)][PAGE][list];

or

PUT STRING(r)[list];

Parameters

list
[LIST](output-list)

or

DATA (output-list)

or

EDIT(output-list) (format-list)[(output-list) (format-list)]...

output-list
output-item [,output-item]...
output-item
expression

or

(output-list iterative-DO)

If specified:

n and m
Expressions that produce integer values.
f
A reference that produces a file value.
r
A reference to a character-string variable that is the output stream.

For the definition of a format list, see the section FORMAT Statement.

No comma separates an iterative-DO from its output-list.

An output-list containing one iterative-DO has two sets of parentheses, as shown in the following example:

PUT LIST (((ARR(I,J) DO I = 1 TO 5) DO J = 1 TO 5))

A parenthetical output-list containing an iterative-DO transmits values under control of the iterative-DO, as if it were a DO-group.

If none of LIST, DATA, EDIT is specified, LIST is assumed. In this default case, the output-list must occur immediately after the word PUT.

Description

The PUT statement transfers data from the program to the output stream. The output stream can be either a stream file or a character-string variable.

The PUT statement has several forms that include the following options: format-list, FILE, SKIP, STRING, LINE, PAGE, and LIST, DATA, or EDIT.

The options may be given in any order, but the format-list is part of the EDIT option and must always immediately follow the output-list.

The FILE option must reference a file value whose associated file control block has either been opened as a STREAM OUTPUT file or is closed. If closed, it is opened automatically by the PUT statement and with the attributes STREAM OUTPUT LINESIZE(80). If the FILE option is omitted, FILE(SYSPRINT) is supplied by default. When SYSPRINT is opened, it acquires the PRINT attribute by default. Note that the LINESIZE value for an implicit OPEN differs from that in an explicit OPEN where the LINESIZE option is omitted.

The SKIP option positions the output file at the start of a new line. The expression in the SKIP option must produce a positive integer value n. The option writes n lines, beginning with the current line so that any subsequent output begins on a new line. If SKIP is given without n, a value of one is supplied by default.

The STRING option specifies that the output item is a referenced character-string variable rather than a file. The STRING option cannot be used with FILE, LINE, PAGE, or SKIP. The target of the PUT STRING operation must have sufficient space allocated to store the entire result of the operation, including any spaces, semicolons, and quotation marks added by the PUT LIST or PUT DATA processing. If the target does not have enough space, the ERROR condition is signaled.

The LINE option positions the stream file to a specific line relative to the top of the page. Subsequent output begins on that line. The LINE option is evaluated as if it were a LINE format; see the section LINE(n). If n is less than the current line position, the ENDPAGE condition is signaled.

If both SKIP and LINE are specified, LINE is evaluated first.

The PAGE option positions the output file at the start of a new page so that subsequent output begins on line one of that page. If the PAGE and LINE options are both given, PAGE is evaluated first.

SKIP, PAGE, and LINE are always evaluated prior to writing any output produced by the PUT statement, regardless of their position in the PUT statement. If the output from a statement does not share its last line with subsequent output, two statements must be used. (See the section Examples.)

The output-list is evaluated from left-to-right. Each expression may be either an array reference, structure reference, or scalar-valued expression. Structures with the UNION attribute cannot be used as variables in a PUT statement.

A scalar value causes one value to be transmitted to the output stream and, if EDIT is specified, uses one data format. An array variable causes n values to be transmitted, where n is the number of elements in the array. If EDIT is specified, it uses n data formats. Values are transmitted from the array in row-major order, as defined in the section Arrays in the chapter Data Types. A structure variable causes all members of the structure and members of all contained substructures to transmit a value. The values are transmitted in left-to-right order. If EDIT is specified, each value requires a data format.

Only arithmetic, pictured, or string values can be transmitted by a PUT statement.

The number of lines written by a PUT statement is determined by the number of values specified by the output-list, as well as by the SKIP, LINE, and PAGE options, and any control formats given in the format list. However, unless control items or options force new lines to be written, transmission begins with the current position of the current line and uses as many lines as are necessary to satisfy the output list.

  • List-Directed Output
  • Data-Directed Output
Parent topic: Statements
Related information
FORMAT Statement
LINE(n)
Arrays


List-Directed Output

The LIST option specifies list-directed output.

The PUT LIST statement causes each value specified by the output list to be written to the stream file without the use of a format item. Each value to be output is converted to a character-string value using the normal rules for converting to a character string given in the chapter Data Type Conversions.

If the original output value is a bit string, the resulting character string is enclosed in quotation marks and a B is appended to its right end.

Parent topic: PUT
Related information
Data Type Conversions


Data-Directed Output

The DATA option specifies data-directed output.

The PUT DATA statement is equivalent to the PUT LIST statement, with the following differences:

  • An output-list item can be a scalar, element, array, or structure reference, not an expression. The reference may contain structure qualifiers and subscripts, but may not be locator qualified.
  • The dataname of each reference is written along with the value. This is done in the form dataname=value. If the value is an array, each element is written with its array name and the actual value of its subscript(s). If the value is a structure, each elementary member is written with its dataname fully qualified and with all subscripts at the end.
  • The dataname=value combinations are separated by spaces except when writing to a PRINT file, when each such item will be aligned on a TAB stop. A semicolon is written following the last value.
  • The data values are written, in most cases, just as they are in PUT LIST. However, for character data, the data value is always enclosed in quotes when it is written out.
  • A based variable in the output-list must be declared with an explicit pointer.
  • Edit-Directed Output
Parent topic: PUT


Edit-Directed Output

The EDIT option specifies edit-directed output.

The PUT EDIT statement uses a format list to control the position of the output stream and the conversion of the values specified by the output list. Each output value is converted under control of a data format, and the resulting characters are written to the output stream.

When multiple (output-list) (format-list) pairs are specified, this is equivalent to specifying all the output items consecutively in one list, then all the format items consecutively in one list.

For a description of each data format conversion, see the section Format Controlled Conversion in the chapter Data Type Conversions, and for a description of format list evaluation, see the section FORMAT Statement.

PUT FILE(F) EDIT(A,B,C) (E(14,3),SKIP,F(10));
PUT FILE(F) EDIT(D) (A);

In this example, A is converted under control of E (14,3), and 14 characters are written to the output stream, a new line is begun by SKIP, B is converted under control of F (10), and 10 characters are written to the output stream, C is then converted under control of E (14,3) and written to the output stream. The SKIP is not evaluated a second time because no more values remain to be output from the output list. The second statement converts D to a character string whose length is determined by the normal rules for conversion to character string. For further information on conversions, see the chapter Data Type Conversions. The resulting value is written to the same line as C, unless C happened to just fill a line. In that case, D begins on the next line.

If the original output value is a character string or a pictured value, and the file control block does not have the PRINT attribute, each contained quotation mark is replaced by two quotation marks and the entire string is enclosed by quotation marks.

The possibly modified character string is placed into the output stream followed by a single blank. If the file control block has the PRINT attribute and LINESIZE 20, for example, the value is followed by sufficient blanks to ensure that the next output begins in the next tab stop. At least one blank always separates fields.

If a character string does not fit on a line, a new line is begun and the string is written on that line and subsequent lines, if necessary.

PUT FILE(F) LIST(52,1.07E+5);
PUT FILE(F) LIST('ABCX');

would produce (assuming a line size of 20): boxes

In this example, the value 52 converts to boxes 52 and is output followed by a single blank, 1.07E+5 converts to box 1.07E+05 and is followed by a single blank, and 'ABCX ' converts to ABCX. The resulting value does not fit on a line of size 20, so it is written on the next line followed by a blank. If the file control block had the PRINT attribute, the last value would be output without quotation marks and each value would be followed by sufficient blanks to ensure that the next value would begin at the next tab stop.

If the PRINT attribute does not exist, the output would look like this:

Parent topic: Data-Directed Output
Related information
Format Controlled Conversion
FORMAT Statement
Data Type Conversions


READ

Purpose

Reads a record from an input or update file.

Syntax

READ FILE(f)[INTO(v) [KEY(k)|KEYTO(r)]|
           SET(p)[KEY(k)|KEYTO(r)]
           IGNORE(expr)];

Parameters

f
A reference to the file from which the record is to be read.
v
A reference to the variable to which the record contents are to be assigned.
p
A pointer variable.
expression
Is evaluated and converted to an integer value.
k
An expression that specifies the key to be used to locate the record to be read.
r
The designated variable to which the key of the record being read is to be assigned.

The FILE, INTO, KEYTO, and KEY specifiers may be written in any order. KEYTO must not be specified if KEY is specified. A READ statement without an INTO, SET, or IGNORE option is equivalent to a READ with an IGNORE(1).

Description

The READ statement reads a record from a record file.

The FILE option must contain a reference f that produces a file value. The file identified by f must either have been previously opened with RECORD INPUT or UPDATE, or must be closed. If closed, it is opened by the READ statement and given the INPUT RECORD SEQUENTIAL attributes.

If the file has been opened with the KEYED SEQUENTIAL attributes, the KEY option may be specified. If the file has been opened with the DIRECT attribute, the KEY option must be specified.

The READ statement with INTO option copies the data record into the referenced variable. The SET option specifies a pointer variable that is set to point to the location in a buffer into which data has been moved during the READ operation. The storage for this buffer is handled by the run-time system.

In the following example, the value of the pointer value P is set to the location of F in the buffer of the next sequential record:

READ FILE (F) SET (P) ;

The IGNORE option can be used in a READ statement for any indexed SEQUENTIAL INPUT or SEQUENTIAL UPDATE file.

expression in the IGNORE option is evaluated and converted to an integer value, n. If n is greater than zero, n records are ignored. A subsequent READ statement for the file will access the (n+1)th record. If n is less than 1, the READ statement has no effect.

The IGNORE option cannot be used with non-indexed files.

The following example specifies that the next five records in the file are to be ignored:

READ FILE (IN) IGNORE (5 ) ;

If specified for non-indexed files, the KEY option must be an expression whose value can be converted to a positive integer. Its value must be a key value of a record in the keyed file identified by the file associated with f. An attempt to read the file using a key value that does not identify a record in f results in a signal of the KEY condition. For indexed (VSAM) files, the key value is treated as a Character, and is converted to Character if necessary.

If specified, the KEYTO option must reference a character string variable whose maximum length is implementation-defined. (For details, see your Open PL/I User's Guide.) The file must be a keyed file. The key value of the record is assigned to r.

If a KEY option is given, the file must have been opened previously with the KEYED attribute. The presence of the KEY option does not cause implicit opening to produce the KEYED attribute.

Regardless of how the file was opened, it must have either the INPUT or UPDATE attribute.

If a KEY option is given, the file is positioned to read the record identified by the key value; otherwise, it is positioned to read the current record of a SEQUENTIAL file. After reading the record, the current position is advanced to the next record if the file is SEQUENTIAL. The current position for a DIRECT file is not changed.

Open PL/I allows the use of READ with a stream file, as long as the READ statement specifies a scalar character varying string variable in its INTO option. The READ statement reads the next complete input line and assigns it to the character varying string specified by the INTO option. The string does not include any new-line character.

Example

READ FILE(F) INTO(X);
READ FILE(G) INTO(Y) KEY(N+1);
READ FILE (TOWN_FILE) INTO (TOWN_BUFFER) KEYTO (SAVE_ADDRESS);

In the last example, the READ statement reads the next sequential record in the file TOWN_FILE into the variable TOWN_BUFFER. The key associated with the record that is read is copied into the variable SAVE_ADDRESS.

Restrictions

None.

Parent topic: Statements


RELEASE

The RELEASE statement is described in the Dynamic Fetching and Releasing of External Procedures section.

Parent topic: Statements
Related reference
RELEASE Statement


%REPLACE

Purpose

Specifies that an identifier is a constant of a given value.

Syntax

%REPLACE name BY constant;

Description

The %REPLACE statement specifies that an identifier is a constant of a given value.

Beginning at the point at which the %REPLACE statement is encountered, each occurrence of name that follows the %REPLACE statement is replaced by the constant until the end of compilation.

The %REPLACE statement is normally used to supply the sizes of tables or to give names to special constants whose meaning would not otherwise be obvious.

Example

%REPLACE TRUE BY '1'B;
%REPLACE TABLE_SIZE BY 400;
%REPLACE MOTOR_POOL BY 5;
%REPLACE X BY -3.0E0;
DECLARE X(TABLE_SIZE) FIXED STATIC;
DO K = 1 TO TABLE_SIZE;
IF DEPARTMENT_NUMBER = MOTOR_POOL
   THEN DO;
      .
      .
      .

Restrictions

The %REPLACE statement operates on the program text without regard to the meaning of the text, which means that a replaced name can accidentally be a keyword such as STOP or READ. in this case, an "unrecognizable statement" error message is issued by the Compiler when it reads a subsequent STOP or READ statement. An error statement is also issued by the Compiler when an attempt is made to replace one name by two different constants.

The %REPLACE statement substitutes all subsequent occurrences of the name without regard to the block structure of the module.

Parent topic: Statements
Related information
Introduction
Procedure Blocks


RETURN

Purpose

Ends execution of the current procedure and returns control to the calling block.

Syntax

RETURN[(result)];

Parameters

result
Must be an expression whose value can be converted to the data type specified in the RETURNS option of the containing procedure.

Description

The RETURN statement ends execution of the current procedure and returns control to the calling block.

If a result is specified, the containing procedure must have a RETURNS option and must have been called by a function reference. In this case, the result expression is evaluated, converted to the data type specified by the RETURNS option of the PROCEDURE statement, and returned as the function value.

If a result is not specified, the containing procedure must not have a RETURNS option and can be called only by a CALL statement.

A RETURN statement executed in a BEGIN block returns from the activation of the containing procedure block and terminates any BEGIN blocks that contain the RETURN statement.

Example

RETURN;
RETURN(A+B);
RETURN('STRING RESULT');
RETURN('1'B);

Restrictions

A BEGIN block that is an ON-unit must not contain a RETURN statement.

Parent topic: Statements


REVERT

Purpose

Cancels an ON-unit established for a specified condition in the current block.

Syntax

REVERT condition-name;

Parameters

condition-name
The keyword name associated with the condition for which the ON-unit is to be reverted, namely: ANYCONDITION, AREA, ATTENTION, CONDITION(name), CONVERSION, ENDFILE(f), ENDPAGE(f), ERROR, FINISH, FIXEDOVERFLOW, KEY(f), OVERFLOW, RECORD(f), UNDEFINEDFILE, UNDERFLOW, USERCONDITION(expression), USERCONDITION(SS$_UNWIND), VAXCONDITION(expression), or ZERODIVIDE.
Note:

Abbreviation(s):

  • ATTN for ATTENTION
  • COND for CONDITION
  • CONV for CONVERSION
  • OFL for OVERFLOW
  • UFL for UNDERFLOW
  • UNDF for UNDEFINEDFILE
  • ZDIV for ZERODIVIDE

Description

The REVERT statement cancels an ON-unit established for a specified condition in the current block. If no ON-unit for the condition is established in the current block activation, the REVERT statement has no effect.

The reference given in an I/O condition name must produce a file value. The I/O condition is qualified by the file I/O associated with f. This means that in the example below, REVERT ENDPAGE (F) ; and REVERT ENDPAGE (G); revert to different ON-units if F and G designate different files; otherwise, they revert to the same ON-unit.

Example

REVERT ERROR;
REVERT ENDPAGE(F);
REVERT ENDPAGE(G);

Restrictions

None.

Parent topic: Statements


REWRITE

Purpose

Replaces a record in a DIRECT UPDATE, SEQUENTIAL UPDATE, or a KEYED SEQUENTIAL UPDATE file.

Syntax

REWRITE FILE(f)[FROM(v)][KEY(k)];

Parameters

f
A reference to the file containing the record to be replaced.
v
A reference to the variable whose value is to be used to rewrite the specified record.
k
An expression specifying the key to be used to locate the record to be rewritten.

Description

The REWRITE statement replaces a record in an UPDATE file. For SEQUENTIAL UPDATE files, the REWRITE statement specifies that the last record read form the file is to be rewritten. Note that, in this case, a record must be read before it can be rewritten. For DIRECT UPDATE files, and for KEYED SEQUENTIAL UPDATE files associated with indexed (VSAM) files, any record can be rewritten, whether or not it has first been read.

Because the set of file attributes that would be supplied as a result of an implicit file opening caused by a REWRITE statement does not include DIRECT, the FILE specifier must reference a file value whose associated file has been opened with the DIRECT and UPDATE attributes.

The KEY option is required for DIRECT non-indexed files and not allowed for SEQUENTIAL files.

The FROM specifier must contain a variable reference. The storage of that variable is copied as the new record. The FROM specifier must not contain a variable that is an unaligned bit string or a structure that consists entirely of unaligned bit strings or a structure with the UNION attribute.

If the last record read was read by a READ statement with the INTO option, a REWRITE statement without the FROM option has no effect. If the last record read was read by a READ statement with the SET option, a REWRITE without the FROM option causes the data record to be updated with the current contents of the buffer indicated by the pointer variable specified by the SET option of the READ.

The FILE, FROM, and KEY specifiers may be given in any order.

Example

REWRITE FILE(F) FROM(X) KEY(N+1);
REWRITE FILE(F) FROM(Y(K)) KEY('ABC');

Restrictions

None.

Parent topic: Statements


SELECT

Purpose

Heads a SELECT-group, which provides a multi-path conditional branch.

Syntax

SELECT[(select-expression)];
   WHEN(e?1[,e?2[,e?3[…]]]) action_1;
   WHEN(e?4[,e?5[,e?6[…]]]) action_2;
   .
   .
   .
   OTHERWISE action_m;
END;

Abbreviation(s): OTHER for OTHERWISE.

Parameters

select-expression and e?1, e?2... are all valid expressions, and each action is a single or compound statement, a DO-group, a SELECT-group, an ON-unit, or a BEGIN block.

Description

The SELECT statement heads a SELECT-group, which provides a multi-path conditional branch. The SELECT statement tests the expressions in the SELECT-group and performs a particular action if the result of any test is true.

SELECT;
   WHEN (condition B)
      SELECT;
            WHEN (condition B1) statement_1;
            WHEN (condition B2) statement_2;
      END;
   WHEN (condition C)
      SELECT;
            WHEN (condition C1) statement_3;
            WHEN (condition C2) statement_4;
            OTHERWISE statement_5;
      END;
   OTHERWISE statement_6;
END;

statement_1 is executed when both B and B1 are true conditions and statement_2 is executed when both B and B2 are true conditions. If B is true, but B1 and B2 are false, nothing happens. If condition B is false, the C conditions are checked. statement_5 is executed when condition B is false, condition C is true, and conditions C1 and C2 are false. statement_6 is executed when condition B and condition C are both false.

When control reaches a SELECT statement with a select-expression present, the select-expression is evaluated and its value saved. Next, the expressions in the WHEN clauses are evaluated in the order in which they appear, and each value is compared with the value of select-expression. If a value is found that is equal to the value of select-expression, the action following the corresponding WHEN clause is performed, and no further WHEN clause expressions are evaluated. If none of the expressions in the WHEN clauses is equal to the select-expression, the action specified after the OTHERWISE clause, if present, is executed unconditionally. If there is no OTHERWISE clause and there is no matching WHEN value, the ERROR condition is raised.

Note:

OTHERWISE may be abbreviated to OTHER.

After the action has been performed, control passes to the first executable statement following the SELECT-group, unless the normal flow is changed by the specified action.

If the select-expression is omitted, each WHEN clause expression is evaluated and converted, if necessary, to a bit string. The action after the WHEN clause is performed if any bit in the resulting bit string is a '1'B.

If a SELECT-group does not contain any WHEN clauses, the action in the OTHERWISE clause is executed unconditionally. If the OTHERWISE clause is omitted, and execution of the SELECT-group does not result in the selection of a WHEN clause, the ERROR condition is raised.

In nested SELECT statements, conditions are checked from top to bottom. If two conditions are true, only the first course of action is taken.

You must close each group in nested SELECT-groups with an END statement.

Example

SELECT;
   WHEN (9>B, C,D, FOUND) CALL PROC_1;
   WHEN (A=B) CALL PROC_2;
   OTHERWISE CALL PROC_3;
END;

In the previous example, select-expression is omitted, so each WHEN clause expression is evaluated and converted to bit strings. The action after the WHEN clause is performed if any bit in any resulting string is a 1.

DECLARE MONTH CHAR(3),
      YEAR PIC'99',
      NO_DAYS FIXED BINARY;
.
.
.
SELECT(MONTH);
   WHEN ('FEB')
      SELECT (MOD(YEAR,4));
            WHEN (0) NO_DAYS = 29;
            OTHERWISE NO_DAYS = 28;
      END;
   WHEN ('APR','JUN','SEPT','NOV') NO_DAYS = 30;
   OTHERWISE NO_DAYS = 31;
END;

The previous example shows nested SELECT-groups used to set a variable to the number of days in a specified month. Here, the MOD built-in function returns the remainder when YEAR is divided by 4. (The algorithm is incorrect for some century years.)

Restrictions

None.

Parent topic: Statements


SIGNAL

Purpose

Causes a specified condition to be signaled.

Syntax

SIGNAL condition-name;

Parameters

condition-name
ANYCONDITION, AREA, ATTENTION, CONDITION(name), CONVERSION, ENDFILE(f), ENDPAGE(f), ERROR, FINISH, FIXEDOVERFLOW, KEY(f), OVERFLOW, RECORD(f), UNDEFINEDFILE(f), UNDERFLOW, USERCONDITION (expression), USERCONDITION(SS$_UNWIND), VAXCONDITION (expression), or ZERODIVIDE.
Note:

Abbreviations:

  • ATTN for ATTENTION
  • COND for CONDITION
  • CONV for CONVERSION
  • OFL for OVERFLOW
  • UFL for UNDERFLOW
  • UNDF for UNDEFINEDFILE
  • ZDIV for ZERODIVIDE

Description

The SIGNAL statement forces a specified condition to be raised. for detailed information on condition handling, see the section ON Statement.

A signal from a SIGNAL statement or from a condition raised during run-time calls the most recently established ON-unit for the specified condition.

Example

SIGNAL ERROR;
SIGNAL ENDFILE(F);

Restrictions

The ONCODE built-in function returns the value of the expression in the SIGNAL USERCONDITION (expression) or VAXCONDITION (expression) statement that caused the ON-unit to be invoked. For this reason, take care to choose expression values that do not conflict with any of the values used to indicate system or run-time errors or conditions.

In general, you can avoid conflicts with system and run-time-defined codes by using values greater than or equal to 100000 (one hundred thousand) for user-defined conditions. Code values between 0 and 99999 that are currently unused by the system are reserved for future expansions.

Parent topic: Statements
Related information
ON Statement


%SKIP

Purpose

Causes a specified number of lines in the list file to be left blank.

Syntax

%SKIP (n);

Parameters

n
An integer in the range of 1 to 999. If n is omitted, the default value of 1 is supplied.

Description

The %SKIP statement causes n lines following the %SKIP statement in the program listing to be left blank. The %SKIP statement does not appear in the listing.

Restrictions

None.

Parent topic: Statements


STOP

Purpose

Raises the FINISH condition, closes all open files, and ends program execution.

Syntax

STOP;

Description

The STOP statement raises the FINISH condition, closes all open files, and ends program execution.

A RETURN from a main procedure (declared with OPTIONS(MAIN)) has the same effect as STOP.

Example

CLOSE:
   PROCEDURE;

   IF CLOSEDATE(FILE_NO) = 0
      THEN CALL ERROR(7);
      .
      .
      .
   STOP;
END CLOSE;

Restrictions

None.

Parent topic: Statements


WRITE

Purpose

Adds a record to a STREAM OUTPUT, RECORD OUTPUT, or RECORD UPDATE file.

Syntax

WRITE FILE(f)FROM(v)[KEYFROM(k)];

Parameters

f
A reference to the file to which the record will be written.
v
A reference to the variable that contains data for the output record.
k
An expression that specifies a key position.

The FILE, FROM, and KEYFROM specifiers may be written in any order.

Description

The WRITE statement adds a record to a file, either at the end of the file having the SEQUENTIAL and OUTPUT attributes, or into a file having the KEYED and OUTPUT attributes or the KEYED and UPDATE attributes.

The variable that contains data for the output record cannot be an unaligned bit string, a structure consisting entirely of unaligned bit strings, or a structure with the UNION attribute.

If the file associated with f has been opened with the KEYED and SEQUENTIAL attributes, the KEYFROM option may be specified. If the KEYFROM option is specified, the value of the expression k serves as the key value of the new record. If a record with this key value already exists, the KEY condition is signaled.

For non-VSAM files, if the file associated with f has been opened with the KEYED and DIRECT attributes, the KEYFROM option must be specified. The value of the expression k serves as the record number of the new record. If a record with this record number already exists, the KEY condition is signaled.

If a KEYFROM option is given, the file must have been previously opened with the KEYED attribute. The presence of the KEYFROM option does not supply the KEYED attribute in an implicit file opening.

The FILE option must contain a reference f that produces a file value. The file associated with f must either have been previously opened with RECORD OUTPUT, or it must be closed. If closed, it is opened by the WRITE statement and given the OUTPUT RECORD SEQUENTIAL attributes.

Open PL/I allows the use of WRITE with a stream file, as long as the WRITE statement specifies a scalar character varying string variable in its FROM option. The WRITE statement does an implicit SKIP and then writes a line consisting of the current value of the varying string specified by the FROM option followed by a new-line character.

Example

WRITE FILE(F) FROM(CUSTOMER) KEYFROM(N+1);
DECLARE 1 CUSTOMER,
      2 NAME CHAR(20) VARYING,
      2 ADDRESS
            3 NUMBER FIXED BINARY(15),
            3 STREET CHAR(12) VARYING,
            3 CITY CHAR(20) VARYING;
DECLARE F FILE;
   .
   .
   .

Restrictions

For DIRECT and KEYED SEQUENTIAL files the first WRITE that is performed on the file sets the default record size. This means that if a small record is the first record written to a file, subsequent WRITEs of large records could cause errors to occur. For example:

DECLARE F1 FILE,
      RECORD_ONE CHAR(5),
      RECORD_TWO CHAR(6);

OPEN FILE(F1) RECORD DIRECT OUTPUT;
WRITE FILE(F1) FROM(RECORD_ONE) KEYFROM(1);
WRITE FILE(F1) FROM(RECORD_TWO) KEYFROM(2);

In the previous program the first WRITE will cause the default record size to be set to 5. Since the second WRITE is of a value greater than 5, an ERROR will be signaled. This restriction does not apply if the file is opened with the -DAM switch in the TITLE option to specify the record size in the file. For example, the program fragment in the above example would have worked correctly if the OPEN statement had read:

OPEN FILE(F1) TITLE('TESTFILE -DAM 10') RECORD DIRECT OUTPUT;

This would have set the default record size to 10 and the WRITE of both the CHAR (5) and CHAR ( 6 ) would have worked correctly.

Parent topic: Statements


%XINCLUDE

Purpose

Incorporates text from other files into the current source file during compilation but the requested file is included only if it has not been included already.

Syntax

%XINCLUDE filename[,filename]…;

Parameters

filename
One of the following: a character string, an Open PL/I name, or an Open PL/I name enclosed in parentheses.

The specified filename is used to locate a text file whose content is inserted into the program text in place of the %XINCLUDE statement.

Description

%XINCLUDE is very similar to %INCLUDE because it incorporates text from other files into the current source file during compilation but the difference is that the requested file is included only if it has not been included already.

Example

%XINCLUDE 'FILE1','FILE2',(FILE3),(FILE4);

Restrictions

None.

Parent topic: Statements
Related reference
%INCLUDE


Open PL/I Built-ins

  • Introduction
  • ABS Function
  • ACOS Function
  • ADD Function
  • ADDR Function
  • ADDRDATA
  • ALL Function
  • ALLOCATION Function
  • ANY Function
  • ASIN Function
  • ATAN Function
  • ATAND Function
  • ATANH Function
  • BINARY Function
  • BINARYVALUE Function
  • BIT Function
  • BOOL Function
  • BYTE Function
  • CEIL Function
  • CENTERLEFT / CENTRELEFT Function
  • CENTERRIGHT / CENTRERIGHT Function
  • CHARACTER Function
  • COLLATE Function
  • CONJG Function
  • COPY Function
  • COS Function
  • COSD Function
  • COSH Function
  • COUNT Function
  • CURRENTSTORAGE Function
  • DATAFIELD Function
  • DATE Function
  • DATETIME Function
  • DECIMAL Function
  • DIMENSION Function
  • DIVIDE Function
  • EMPTY Function
  • ERF Function
  • ERFC Function
  • EXP Function
  • FILEDDINT Function
  • FILEDDWORD Function
  • FILEOPEN Function
  • FIXED Function
  • FLOAT Function
  • FLOOR Function
  • FLUSH Subroutine
  • GRAPHIC Function
  • HBOUND Function
  • HEX Function
  • HIGH Function
  • HUGE Function
  • INDEX Function
  • INT Function
  • LBOUND Function
  • LENGTH Function
  • LEFT Function
  • LINENO Function
  • LOG Function
  • LOG10 Function
  • LOG2 Function
  • LOW Function
  • LOWERCASE Function
  • LPIPARAMCOUNT Function
  • MAX Function
  • MAXLENGTH Function
  • MIN Function
  • MOD Function
  • MPSTR Function
  • MULTIPLY Function
  • NULL Function
  • OFFSET Function
  • ONCHAR Function
  • ONCODE Function
  • ONFILE Function
  • ONKEY Function
  • ONLOC Function
  • ONSOURCE Function
  • PACKAGENAME Function
  • PAGENO Function
  • PLIRETC Subroutine
  • PLIFILL Subroutine
  • PLIMOVE Subroutine
  • PLIOVER Subroutine
  • PLIRETV Function
  • PLISRTx Subroutines
  • PLITEST Subroutine
  • POINTER Function
  • POINTERADD Function
  • POINTERDIFF / PTRDIFF Function
  • POINTERSUBTRACT / PTRSUBTRACT
  • POINTERVALUE Function
  • POLY Function
  • POSINT Function
  • PRECISION Function
  • PROCEDURENAME() Function
  • PROD Function
  • RANDOM Function
  • RANK Function
  • REPEAT Function
  • RESIGNAL() Subroutine
  • REVERSE Function
  • RIGHT Function
  • ROUND Function
  • SEARCH Function
  • SEARCHR Function
  • SIGN
  • SIN Function
  • SIND Function
  • SINH Function
  • SIZE Function
  • SQRT Function
  • STORAGE Function
  • STRING Function
  • SUBSTR Function
  • SUM Function
  • SYSNULL Function
  • TALLY Function
  • TAN Function
  • TAND Function
  • TANH Function
  • TIME Function
  • TINY Function
  • TRANSLATE Function
  • TRIM Function
  • TRUNC Function
  • UNSPEC Function
  • UPPERCASE Function
  • VALID Function
  • VERIFY Function
  • WCHARVAL Function
  • WHIGH Function
  • WIDECHAR Function
  • WLOW Function
Parent topic: Open PL/I Language Reference Manual


Introduction

Built-in functions and subroutines are procedures provided by the Open PL/I language. They can be used wherever an expression is valid.

The built-in functions and subroutines provided by Open PL/I can be grouped into the following classes:

  • Arithmetic built-in functions, which provide information about the properties of arithmetic values, or that perform ordinary arithmetic calculations. These include:
    ABS | EXP | LOG10 | MOD | SIGN
    ADD | FLOOR | LOG2 | MULTIPLY | SORT
    CEIL | INT | MAX | POSINT | TRUNC
    DIVIDE | LOG | MIN | ROUND
  • Trigonometric built-in functions, which perform standard mathematical calculations in floating-point. These include:
    ACOS | ATAND | COSD | SIND | TAND
    ASIN | ATANH | COSH | SINH | TANH
    ATAN | COS | SIN | TAN
  • String built-in functions, which process character-string and bit-string values. These include:
    BOOL | HIGH | LOW | SUBSTR | VALID
    COLLATE | INDEX | REPEAT | TRANSLATE | VERIFY
    COPY | LENGTH | STRING | TRIM
  • Conversion built-in functions, which convert data from one data type to another. These include:
    BINARY | BYTE | DECIMAL | FLOAT | RANK
    BIT | CHARACTER | FIXED
  • Condition-handling built-in functions, which provide information about interrupts that are caused by signaled conditions. These include:
    ONCHAR ONFILE ONKEY ONLOC ONSOURCE
    ONCODE
  • Array-handling built-in functions, which provide information about arrays and array elements. These include:
    ALL | DIMENSION | LBOUND | PROD | SUM
    ANY | HBOUND
  • Storage-handling built-in functions, which provide information on the storage requirements and location of variables. These include:
    ADDR | CURRENTSTORAGE | OFFSET | SIZE | STORAGE
    ALLOCATION | NULL | POINTER
  • Miscellaneous built-in functions and subroutines. These include:
    DATE | LINENO | PLIRETV | PLITEST | TIME
    DATETIME | PAGENO | PLISRTx | RESIGNAL | UNSPEC
    FLUSH | PLIRETC
  • Built-in character-handing functions which accept or return WIDECHAR character-type only.
    WIDECHAR / WCHAR WCHARVAL WHIGH WLOW
  • Built-in character-handing functions which accept WIDECHAR arguments where character-type arguments apply; when the return value is a character-string the return type is WIDECHAR if any WIDECHAR arguments are passed.
    LEFT | RIGHT | CENTERLEFT / CENTRELEFT | CENTERRIGHT / CENTRERIGHT | CHARACTER / CHAR
    COPY | INDEX | LENGTH | MAXLENGTH | RANK
    REPEAT | REVERSE | SEARCH | SEARCHR | SUBSTR
    TALLY | TRIM | UNSPEC | VERIFY | VERIFYR

This chapter describes each built-in. The built-ins are presented in alphabetical order by name. Each built-in definition consists of the following subsections: syntax, description (the effect of the built-in), examples (one or more examples of the built-in usage and results) and restrictions (any restrictions in the use of the built-in).

Arguments to built-ins are effectively passed by value, that is, no alteration of the arguments is done.

Parent topic: Open PL/I Built-ins


ABS Function

Purpose

Returns the absolute value of an arithmetic value.

Syntax

ABS(x)

Parameters

x is an arithmetic expression.

Description

ABS(x) returns the absolute value of x.

The result has the same data type and precision as x.

Examples

ABS(-132)  /* returns 132 */
ABS(12.5)  /* returns 12.5 */

Restrictions

The ABS function may produce unexpected results when x is fixed binary and has the maximum negative value for its precision. For example, if x is Fixed Binary(15) and has the value -32768, ABS(x) is -32768.

Parent topic: Open PL/I Built-ins


ACOS Function

Purpose

Returns the arc cosine of a floating-point value.

Syntax

ACOS(x)

Parameters

x is a floating-point value such that -1 ? x ? 1, or is an expression that can be converted to such a value.

Description

ACOS(x) returns the arc cosine of x expressed in radians, such that 0 ? ACOS(x) ? ?. The result is a floating-point value.

Examples

ACOS(1.0)   /* returns 0.0 */

Restrictions

An ACOS operation on Float Decimal data is actually performed using its Float Binary equivalent. Thus, the ranges of the operands and the result are limited to the range of Float Binary data.

Parent topic: Open PL/I Built-ins


ADD Function

Purpose

Returns the sum of two arithmetic values.

Syntax

ADD(x,y,p,[q])

Parameters

x and y are arithmetic values, and p and q are integer constants that represent precision and scale factor, respectively.

Description

ADD(x,y,p) returns the arithmetic value x+y with precision and scale (p,0). ADD(x,y,p,q) returns x+y with precision and scale (p,q). The result has the common data type of x and y. If the arguments differ, they are converted as described in the section Arithmetic to Arithmetic Conversion in the chapter Data Type Conversions.

The ADD function can also be used for subtraction. To subtract, precede the operand to be subtracted with a minus sign.

Examples

DECLARE (PRICE, TAX) DECIMAL(5,2);
   .
   .
   .
PUT LIST ('TOTAL COST IS' ||
      ADD (PRICE, TAX, 6,2));

Restrictions

The parameter q must not be specified unless the result type is decimal.

Parent topic: Open PL/I Built-ins
Related information
Arithmetic to Arithmetic Conversion


ADDR Function

Purpose

Returns a pointer to the storage referenced by the specified variable.

Syntax

ADDR(x)

Parameters

x is a specified variable.

Description

The ADDR function returns a pointer to the storage referenced by a specified variable x. If x is an unconnected array cross-section, ADDR returns the address of the first element of the first element of the cross-section.

x must not be a reference to a parameter whose corresponding argument was passed by value.

Examples

DECLARE ELEMENT FIXED BINARY BASED;
DECLARE A(10) FIXED BINARY;
DECLARE P POINTER;
   P = ADDR (A(5));   /* ADDRESS OF 5TH ELEMENT */
   P -> ELEMENT = -1;

Restrictions

On many implementations, x must not be an unaligned bit string or a structure consisting entirely of unaligned bit strings. (For information on this implementation, see your Open PL/I User's Guide.)

Parent topic: Open PL/I Built-ins


ADDRDATA

Purpose

Returns a pointer to the storage referenced by the specified variable.

Syntax

ADDRDATA(x)

Parameters

x is a specified variable.

Description

The ADDRDATA function returns a pointer to the storage referenced by a specified variable x. Its behavior is similar to that of ADDR except when x is a reference to a varying string. In this case ADDRDATA returns the address of the first data byte of the string.

Examples

myprog: proc options (main);

    dcl str char(12) var init ('abcdefgh');
    dcl s   char (4) based;

    dcl i fixed bin (15) init (99);
    dcl fb15 fixed bin (15) based;
    dcl p ptr;

    p = addrdata(str);
    put skip list (addrdata(i)->fb15, addr(str)->fb15, p->s,
                                         ptradd(addrdata(str),4)->s);
end;

Results in:

      99               8       abcd    efgh
Parent topic: Open PL/I Built-ins


ALL Function

Purpose

Returns a bit string that is the logical AND of the elements of a bit string array.

Syntax

ALL(x)

Parameters

x is an array expression. If x is not a bit string array, it is converted to one.

Description

The ALL function returns a bit string whose length is equal to the length of the longest bit string value in the array. Each bit of the result is 1 if and only if the corresponding bit exists and has the value 1 in every element of the array.

Examples

DCL BIT_TEST(3) BIT(5) INITIAL ('10011'B, '10111'B, 10110'B);
DCL BIT_RES BIT(5);
BIT_RES = ALL(BIT_TEST);   /* returns '10010'B */
Parent topic: Open PL/I Built-ins


ALLOCATION Function

Purpose

Returns a fixed-point binary integer that is the number of existing generations of a controlled variable.

Syntax

ALLOCATION (x)

Abbreviation(s): ALLOCN for ALLOCATION.

Parameters

x is a controlled variable.

Description

The ALLOCATION function returns a fixed-point binary integer that is the number of existing generations of a specified controlled variable. If x is not currently allocated, the result is zero.

Examples

DECLARE INPUT CHAR(10) CONTROLLED,
   A CHAR(3) VARYING;
      .
      .
      .
      DO UNTIL (INPUT = 'STOP');
            ALLOCATE INPUT;
            GET LIST (INPUT);
               .
               .
               .
            END;
   A = ALLOCATION(INPUT);
   PUT SKIP LIST('Generations = ', A);

Restrictions

None.

Parent topic: Open PL/I Built-ins


ANY Function

Purpose

Returns a bit string that is the logical OR of the elements of a bit string array.

Syntax

ANY(x)

Parameters

x is an array expression. If x is not a bit string array, it is converted to one.

Description

The ANY function returns a bit string whose length is equal to the length of the longest bit string value in the array. Each bit of the result is 1 if the corresponding bit exists and has the value 1 in any element of the array.

Examples

DECLARE BIT_TEST(3) BIT(5) INITIAL ('10011'B, '10111'B, 10110'B);
DECLARE BIT_RES BIT(5);
BIT_RES = ANY(BIT_TEST);   /* returns '10111'B */

Restrictions

None.

Parent topic: Open PL/I Built-ins


ASIN Function

Purpose

Returns the arc sine of a floating-point value.

Syntax

ASIN(x)

Parameters

x is a floating-point value such that -1 ? x ? 1, or is an expression that can be converted to such a value.

Description

ASIN(x) returns the arc sine of x expressed in radians, such that -?/2 ? ASIN(x) ? ?/2. The result is a floating-point value.

Examples

ASIN(0.0) /* returns 0.0. */

Restrictions

An ASIN operation on Float Decimal data is actually performed using its Float Binary equivalent. Thus, the ranges of the operands and the result are limited to the range of Float Binary data.

Parent topic: Open PL/I Built-ins


ATAN Function

Purpose

Returns the arc tangent of an arithmetic expression.

Syntax

ATAN(x,[y])

Parameters

x and y are floating-point values such that y is not zero, or are expressions that can be converted to such values.

Description

ATAN(x) returns the arc tangent of x. The result is such that -?/2 ? ATAN(x) ? ?/2. The result is expressed in radians and has the same data type as x.

ATAN(x,y) returns the arc tangent of x/y. The result is such that if x/y ? 0, then 0 ? ATAN(x,y) ? ?; and, if x/y < 0, then -? ? ATAN(x,y) ? 0. The result is expressed in radians and has the same data type as x/y, and has the maximum precision of xand y.

Examples

X = 3.14157;
Y = 2.0;
RADIANS = ATAN(X);   /* 1.26 */

or

RADIANS ATAN(X,Y);  /* 1.00 */

Restrictions

An ATAN operation on Float Decimal data is actually performed using its Float Binary equivalent. Thus, the ranges of the operands and the result are limited to the range of Float Binary data.

Parent topic: Open PL/I Built-ins


ATAND Function

Purpose

Returns the arc tangent of an arithmetic expression expressed in degrees.

Syntax

ATAND(x)

or

ATAND(x,y)

Parameters

x is a single floating-point value (syntax 1) or both x and y are floating-point values (syntax 2).

Description

The ATAND function returns a floating-point value that is the arc tangent of a single arithmetic expression x or an arc tangent computed from two arithmetic expressions x and y. If two arguments are supplied, they must not both be zero.

ATAND(x) returns the arctangent of x. The result is expressed in degrees and has the same data type as x such that -90 ? ATAND(x) ? 90.

ATAND(x,y) returns the angle in degrees whose tangent is x/y. The result is the common type and maximum precision of x and y such that if x/y ? 0, then 0 ? ATAND(x,y) ? 180, and if x/y < 0, then -180 ? ATAND(x,y) ? 0.

Examples

ATAND(1.0)   /* returns 45.0. */
ATAND(-1.0,1.0)  /* returns -45.0. */
ATAND(1.0,0.0)   /* returns 45.0. */

X = 3.14157;
Y = 2.0;
DEGREES = ATAND(X);   /* 7.2343E+01 */

or

DEGREES = ATAND(X,Y)   /* 5.7518E+01 */

Restrictions

An ATAND operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


ATANH Function

Purpose

Returns the hyperbolic arc tangent of an arithmetic expression.

Syntax

ATANH(x)

Parameters

x is a floating-point value such that -1 < x < 1.

Description

The ATANH(x) function returns the hyperbolic arc tangent of x. The result has the same data type as x.

Examples

ATANH(0.5)   /* returns 0.54930 */

Restrictions

An ATANH operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


BINARY Function

Purpose

Converts an arithmetic or string value to a binary number with an optionally specified precision.

Syntax

BINARY(x[,p])

Abbreviation(s): BIN for BINARY.

Parameters

x is an arithmetic or string value, and p is an integer constant specifying an optional precision.

Description

The BINARY function converts an arithmetic or string value x to binary radix (Float Binary or Fixed Binary data type), with an optionally specified precision p.

If x is a Fixed Decimal value with a non-zero scale factor, p must be given.

If x is a Float Decimal value, the result is a Float Binary value; otherwise, the result is a Fixed Binary value. A non-zero scale factor is not allowed with a Float Decimal. If p is omitted, the result has a precision that is determined by the rules for data type conversion given in the chapter Data Type Conversions.

Examples

BINARY('2000',31);

In fixed–point context, this example returns the value 2000 as a Fixed Bin(31) integer.

Restrictions

None.

Parent topic: Open PL/I Built-ins
Related information
Data Type Conversions


BINARYVALUE Function

Purpose

Returns a fixed binary integer that is the converted value of a pointer, offset, or ordinal.

Syntax

BINARYVALUE(x)

Abbreviation: BINVALUE for BINARYVALUE.

Parameters

x is an expression.

Restrictions

None.

Parent topic: Open PL/I Built-ins


BIT Function

Purpose

Converts an arithmetic or string value to a bit string.

Syntax

BIT(s)

or

BIT(s,l)

Parameters

s is an arithmetic or string value of an optionally specified length l, and l is a positive integer.

Description

The BIT function converts an arithmetic or string value to a bit string of an optionally specified length.

s is first converted to a bit string whose length is determined by the rules for data type conversion given in the chapter Data Type Conversions. Then, if the length l is specified, the bit string is truncated on the right or padded on the right with zero bits to the specified length.

Examples

DECLARE INTEGER FIXED BINARY(15);
DECLARE BIT_STRING BIT(15);

INTEGER = 20;
BIT_STRING = BIT(INTEGER);
/* BIT_STRING NOW EQUALS '000000000010100'B */

Restrictions

None.

Parent topic: Open PL/I Built-ins
Related information
Data Type Conversions


BOOL Function

Purpose

Performs a Boolean operation on two bit-string arguments.

Syntax

BOOL(x,y,z)

Parameters

x and y are bit-string arguments, and z is a bit string.

Description

The BOOL function performs a Boolean operation on two bit-string arguments, x and y, and returns the result as a bit string with the length of the longer argument.

z should be a bit string 4 bits long. If not, it is converted to Bit (4).

If x and y are null strings, the result is a null string. If x is not the same length as y, the shorter string is extended on the right with zero bits until x and y are the same length. The bit values within z are m1, m2, m3, m4 from left-to-right, respectively.

The Ith bit value of the result is set to one of the values m1, m2, m3, m4 depending on the Ith bit value of x and y according to table below.

X(I) | Y(I) | RESULT(I)
0 | 0 | m1
0 | 1 | m2
1 | 0 | m3
1 | 1 | m4

In other words, bit string z defines the result of some Boolean function. For instance, to define the function OR, the value of bit string z is given as '0111'b. To define the function AND, bit string z is '0001'b. The result is a bit string of the same length as x and y, obtained by applying the function rule described by z to each bit position of string x and string y.

Examples

BOOL('1100110'b,'0101'b,'0110'b)  /*returns '1001110'b */

In this example, the second argument is extended to '0101000'b. For bit 1, x is 1 and y is 0. Therefore, the resulting bit is the value m3or 1. For bit 2, x is 1 and y is 1, therefore the resulting bit is the value of m4 or 0. A comparison of bits 3, 0, and 0 produces the value m1 or 0.

Restrictions

None.

Parent topic: Open PL/I Built-ins


BYTE Function

Purpose

Returns a single character whose ASCII code corresponds to the specified value.

Syntax

BYTE(x)

Parameters

x is a fixed-point binary integer value.

Description

The BYTE function returns a single character whose ASCII code corresponds to the value x. The index into COLLATE() is taken by considering only the rightmost bits of x (one byte). The BYTE function uses a 256-byte collating string.

Examples

CHAR=BYTE(66)   /* returns 'B' for the American English ASCII collating sequence */

Restrictions

None.

Parent topic: Open PL/I Built-ins


CEIL Function

Purpose

Returns the smallest integer greater than or equal to the specified arithmetic expression.

Syntax

CEIL(x)

Parameters

x is an arithmetic expression.

Description

The CEIL function returns the smallest integer greater than or equal to x with precision (p,q). The result has the same data type as x.

If x is a floating-point value, the precision of the result is the precision of x. If x is a fixed-point value, the precision of the result is (MIN(n,MAX(p-q+1,1)),0). n is the maximum precision allowed for a fixed-point value of the result type. (For details, see your Open PL/I User's Guide.)

Examples

CEIL(-3.1)  /* returns -3.0 */
CEIL(3.1)  /* returns 4.0 */
CEIL(0)  /* returns 0 */

Restrictions

None.

Parent topic: Open PL/I Built-ins


CENTERLEFT / CENTRELEFT Function

Purpose

Returns the result of inserting a string in the center or one position to the left of the center of another string with a certain length. It can be padded on the left and on the right with a character.

Syntax

CENTERLEFT(s,l,c)

Parameters

s
A string that is inserted inside another sting. It must have a computational type and a character type. If it does not have a character type, it is converted to character.
l
The length of a string in which s is inserted. It must have a computational type and a character type and is converted to Fixed Binary(31,0).
c
Optional padding character, inserted to the left and to the right of the string. It must have a nonvarying character type.

Examples:

dcl s char (40) var;
    dcl t char (40) var;

    s = 'This string is 33 characters long';
    t = centerleft(s, 40, '+');
    put skip list (t);

will print:

+++This string is 33 characters long++++

Restrictions

None.

Parent topic: Open PL/I Built-ins


CENTERRIGHT / CENTRERIGHT Function

Purpose

Returns the result of inserting a string in the center or one position to the right of the center of another string with a certain length. It can be padded on the left and on the right with a character.

Syntax

CENTERRIGHT(s,l,c)

Parameters

s
A string that is inserted inside another sting. It must have a computational type and a character type. If it does not have a character type, it is converted to character.
l
The length of a string in which s is inserted. It must have a computational type and a character type and is converted to Fixed Binary(31,0).
c
Optional padding character, inserted to the left and to the right of the string. It must have a nonvarying character type.

Examples

dcl s char (40) var;
    dcl t char (40) var;

    s = 'This string is 33 characters long';
    t = centerright(s, 40, '+');
    put skip list (t);

will print:

++++This string is 33 characters long+++

Restriction

None.

Parent topic: Open PL/I Built-ins


CHARACTER Function

Purpose

Converts an arithmetic or string value to a character string.

Syntax

CHARACTER(s)

or

CHARACTER(s, l)

Abbreviation(s): CHAR for CHARACTER.

Parameters

s is an arithmetic or string value, and l is a positive integer value.

Description

The CHARACTER function converts an arithmetic or string value s to a character string of an optionally specified length l. s is first converted to a character string whose length is determined by the rules for data type conversion given in the chapter Data Type Conversions. Then, if l is given, s is either truncated on the right or extended on the right with blanks to be l characters long.

Examples

DECLARE X FIXED BINARY (15);
DECLARE Y CHARACTER(14) VARYING;
X = 2;
Y = CHARACTER(X);
PUT LIST ('$'||Y);      /* $    2 */

Restrictions

The CHARACTER function does not support unaligned BIT(n) parameters.

Parent topic: Open PL/I Built-ins
Related information
Data Type Conversions


COLLATE Function

Purpose

Returns a string consisting of the character set of the National Language being used, in ascending order.

Syntax

COLLATE()

or

COLLATE

The second syntax form can be used only when the BUILTIN attribute is specified.

Description

The COLLATE function returns a character string, of a length determined for the National Language support being used (128 characters for American English), that consists of the set of characters in the computer's character set in ascending order.

In Open PL/I, COLLATE returns a string consisting of the number of characters of the character set as determined by the National Language support.

The COLLATE function uses a 256-byte collating string.

Examples

DECLARE X CHARACTER(5);
X = SUBSTR(COLLATE(), 100, 5);   /* returns X = 'cdefg' */

This example assumes American English National Language support.

Restrictions

None.

Parent topic: Open PL/I Built-ins


CONJG Function

Purpose

Returns the conjugate of the specified expression; that is, the value of the expression with the sign of the imaginary part reversed.

Syntax

CONJG(x)

Parameters

x is an expression.

Description

If x is real, it is converted to complex. The result has the base, scale, mode, and precision of x.

Restrictions

None.

Parent topic: Open PL/I Built-ins


COPY Function

Purpose

Copies a particular string a certain number of times and concatenates the result into a single string.

Syntax

COPY(x,y)

Parameters

x is a character-string, bit-string, or picture value, and y is a positive integer expression. If x is an arithmetic value, it is converted to a bit string if it is binary, or to a character string if it is decimal.

Description

The COPY function copies a particular string, x, a certain number of times, y, and concatenates the result into a single string. COPY effectively returns a string containing y occurrences of the string argument, with length y* length (x).

The result is obtained by concatenating y occurrences of x together.

Examples

DECLARE X CHAR(6);
X = COPY('AB',3)   /* returns X = 'ABABAB' */

Note that the same result could be produced by using a string repetition factor, as illustrated below:

X = (3) 'AB';

Restrictions

None.

Parent topic: Open PL/I Built-ins


COS Function

Purpose

Returns a value that is the cosine of the specified angle expressed in radians.

Syntax

COS(X)

Parameters

x is a floating-point value.

Description

The COS function returns a value that is the cosine of the angle x expressed in radians. The result has the same data type as x such that -1 ? COS(x) ? 1.

Examples

COS(0.0)   /* returns 1.0 */

Restrictions

A COS operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


COSD Function

Purpose

Returns a value that is the cosine of the specified angle expressed in degrees.

Syntax

COSD(x)

Parameters

x is a floating-point value.

Description

The COSD function returns a value that is the cosine of the angle x expressed in degrees. The result has the same value type as x such that -1 ? COSD(x) ? 1.

Examples

COSD(60.0)    /* returns 0.5 */

Restrictions

A COSD operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


COSH Function

Purpose

Returns a value that is the hyperbolic cosine of the specified arithmetic value.

Syntax

COSH(x)

Parameters

x is a floating-point value.

Description

The COSH function returns a value that is the hyperbolic cosine of the angle x expressed in radians.

The result has the same data type as x such that COSH(x) ? 1.

Examples

COSH(0.0)    /* returns 1.0 */

Restrictions

A COSH operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


COUNT Function

Purpose

Returns an unscaled real fixed binary value specifying the number of data items transmitted during the last GET or PUT operation on the specified file-reference.

Syntax

COUNT(x)

Parameters

x is a file-reference. The file must be open and have the STREAM attribute.

Description

The count of transmitted items for a GET or PUT operation on x is initialized to zero before the first data item is transmitted, and is incremented by one after the transmission of each data item in the list. If x is not open in the current program, a value of zero is returned.

If an ON-unit or procedure is entered during a GET or PUT operation, and within that ON-unit or procedure, a GET or PUT operation is executed for x, the value of COUNT is reset for the new operation. It is restored when the original GET or PUT is continued.

Restrictions

None.

Parent topic: Open PL/I Built-ins


CURRENTSTORAGE Function

Purpose

Returns a Fixed Bin(15) value that is the number of bytes of storage used by the current value of the referenced variable.

Syntax

CURRENTSTORAGE(reference)

Abbreviation(s): CSTG for CURRENTSTORAGE.

Parameters

reference is a variable.

Description

For constant-length strings and other fixed-size variables, the CURRENTSTORAGE function returns a Fixed Bin(15) integer that is the number of bytes allocated for the referenced variable.

A variable-length string consists of two parts: the text field and the length field. CURRENTSTORAGE returns the number of bytes of the text field currently in use plus two, since the length field always uses two bytes.

For a scalar area or an element of an array of areas, the CURRENTSTORAGE function returns the sum of the current extent of the area plus the size of the area header. Any bytes at the end of the area that have not been allocated are not included in the area extent value. Note, however, that the extent does include the size of any holes in the area that have developed as a result of ALLOCATE and FREE operations. For an array of areas, the CURRENTSTORAGE function returns the maximum size of the array, including the header bytes for each area element of the array.

Examples

DCL A FIXED BIN(15) INIT (1);   /* CSTG (A) = 2 */
DCL B CHAR(5) INIT ('XY');          /* CSTG (B) = 5 */
DCL C CHAR(5) VARYING INIT ('XY');  /* CSTG ©) = 4 */
DCL D BIT(4) INIT ('1010'B);        /* CSTG (D) = 1 */

Restrictions

None.

Parent topic: Open PL/I Built-ins


DATAFIELD Function

Purpose

In a NAME condition ON-unit (or any of its dynamic descendants), or an ON-unit (or any of its dynamic descendants) for an ERROR or FINISH condition raised as part of the implicit action for the NAME condition, returns a character string whose value is the contents of the field that raised the condition.

Syntax

DATAFIELD[()]

Parameters

None.

Description

If the string that raised the condition contains DBCS identifiers, GRAPHIC data, or mixed character data, DATAFIELD returns a mixed character string. If DATAFIELD is used out of context, a null string is returned.

Restrictions

None.

Parent topic: Open PL/I Built-ins


DATE Function

Purpose

Returns a character string that represents the system date.

Syntax

DATE()

or

DATE

The second form can be used only when the BUILTIN attribute is specified.

Description

The DATE function returns a character string of length 6 that represents the system date in the form yymmdd, where yy, mm, and dd are in the ranges 00–99, 01–12, and 01–31, respectively, and represent year, month, and day, respectively.

You may also define the LPI_YEAR environment variable to return any year value you want (such as 2009).

If you are using Bourne shell, do this:

LPI_YEAR=2009;
export LPI_YEAR

If you are using C-shell, do this:

setenv LPI_YEAR 2009;

Examples

DATE()  /* returned '891017' on October 17, 1989 */
Parent topic: Open PL/I Built-ins


DATETIME Function

Purpose

Returns a character string that represents the system date and time of day.

Syntax

DATETIME()

or

DATETIME

The second form can be used only when DATETIME has been declared with the BUILTIN attribute.

Description

The DATE function returns a character string of length 17 that represents the system date in the form yyyymmddhhmmssttt, where:

String | Range | Represents
yyyy | 0000–9999 | year
mm | 01–12 | month
dd | 01–31 | day
hh | 00–23 | hour
mm | 00–59 | minute
ss | 00–59 | second
ttt | 000–999 | millisecond

You may also define the LPI_YEAR environment variable to return any year value you want (such as 2009).

If you are using Bourne shell, do this:

LPI_YEAR=2009;
export LPI_YEAR

If you are using C-shell, do this:

setenv LPI_YEAR 2009;

Examples

DATETIME()  /* returned '19940526163111585' on May 26,
                   1994 at 11.585 seconds after 4:31 PM */

Restrictions

None.

Parent topic: Open PL/I Built-ins


DECIMAL Function

Purpose

Converts an arithmetic or string value to a DECIMAL number.

Syntax

DECIMAL(x)

or

DECIMAL(x,p)

or

DECIMAL(x,p,q)

Abbreviation(s): DEC for DECIMAL.

Parameters

x is an arithmetic or string value, and p and q are integer constants representing precision and scale factor, respectively.

Description

The DECIMAL function converts an arithmetic or string value x to a DECIMAL number of an optionally specified precision p and scale factor q. p indicates the precision of the result. q indicates the scale of the result. If p alone is given, q is assumed to be zero.

If x is a floating-point value, the result is a float decimal value, and q must be omitted; otherwise, the result is a fixed decimal value, and if q is omitted, the result is an integer of precision p.

If p is omitted, the result has a precision determined by the rules for type conversion given in the chapter Data Type Conversions.

Examples

DECIMAL('3.14')  /* returns 3 */
Parent topic: Open PL/I Built-ins
Related information
Data Type Conversions


DIMENSION Function

Purpose

Returns a fixed binary integer that is the number of elements in the specified dimension of an array.

Syntax

DIMENSION(x[,n])

Abbreviation(s): DIM for DIMENSION.

Parameters

x is an array and n is an integer constant greater than zero that indicates the dimension of the array.

Description

The DIMENSION function returns an integer that is the number of elements in the specified dimension of an array x. This is useful for arrays with * extents.

n is an optional integer constant indicating the nth dimension of x. If n is not specified, the first dimension is assumed. The resulting binary integer gives the number of elements in the nth dimension of x.

The type of the result is Fixed Binary(31). x must have at least n dimensions.

Examples

DECLARE R FIXED BINARY;
DECLARE A(3:5,1:2,10:10,4:7);
   .
   .
   .
R=DIMENSION(A,1);  /*R=3*/
   .
   .
   .

Restrictions

The DIMENSION function is not supported with expression arguments.

Parent topic: Open PL/I Built-ins


DIVIDE Function

Purpose

Divides an arithmetic value by an arithmetic value and returns the quotient with a specified precision and an optionally specified scale factor.

Syntax

DIVIDE(x,y,p)

or

DIVIDE(x,y,p,q)

Parameters

x and y are arithmetic values, and p and q are integer constants that represent precision and scale factor, respectively.

Description

The DIVIDE function divides an arithmetic value, x, by an arithmetic value, y, and returns the quotient with a specified precision p and an optionally specified scale factor q.

The result is xly, having the common data type of x and y.

The precision of the result is (p,q) or (p). In the latter case, q equals zero.

If y equals zero, the program is in error and the ZERODIVIDE condition is raised.

Examples

DECLARE SUM FIXED BINARY(15);
   .
   .
   .
PUT LIST ('HALF PRICE IS'||DIVIDE (SUM, 2, 15));

Restrictions

The parameter q must not occur unless the result type is decimal.

Parent topic: Open PL/I Built-ins


EMPTY Function

Purpose

Returns an area whose extent is zero. This can be used to free all allocations in an area.

Syntax

EMPTY()

or

EMPTY

The second syntax form can be used only if EMPTY has been declared with the BUILTIN attribute.

Description

The value returned by this function is the same as the one used by the Compiler to initialize an area when it is allocated.

Examples

DECLARE  A AREA,
         O OFFSET(A),
         X FIXED BASED(O);

ALLOCATE X IN(A) SET(O);

A = EMPTY();     /* Frees all allocations in A. */

Restrictions

None.

Parent topic: Open PL/I Built-ins


ERF Function

Purpose

Returns a real floating point value that is an approximation of the error function of x.

Syntax

ERF(x)

Parameters

x is a real expression.

Description

The result has the base and precision of x, and a value given by (2/ &sqrt.(&pi.) ) &integral.(x)[0] EXP(-(t(2) ))dt.

Restrictions

None.

Parent topic: Open PL/I Built-ins


ERFC Function

Purpose

Returns a real floating point value that is an approximation of the complement of the error function of x.

Syntax

ERFC(x)

Parameters

x is a real expression.

Description

The result has the base and precision of x, and a value given by: 1 - ERF(x).

Restrictions

None.

Parent topic: Open PL/I Built-ins


EXP Function

Purpose

Returns the base of the natural logarithm raised to the specified power.

Syntax

EXP(x)

Parameters

x is an arithmetic expression.

Description

The EXP function returns the value of the base of the natural logarithm e raised to the power of x or e**x.

The result has the same data type as x.

Examples

EXP(2.0)  /* returns approximately 7.389056 */

Restrictions

An EXP operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


FILEDDINT Function

Purpose

Returns a FIXED BIN(31) value that is the value of attribute c for file x .

Syntax

FILEDDINT(x,c)

Parameters

x
File reference.
c
Character string that holds the attribute to be queried.

Description

FILEDDINT returns a FIXED BIN(31) value that is the value of attribute c for file x. When using FILEDDINT, the following are valid values for c:

  • blksize
  • bufsize
  • delay
  • filesize
  • keylen
  • keyloc
  • recsize
  • retry

These options return the following values:

  • FILEDDINT(x,'BLKSIZE') is valid only for programs executed under Enterprise Server.
  • FILEDDINT(x,'BLKSIZE') will return the blocksize for a CONSECUTIVE file. It will return 0 for a VSAM file.
  • FILEDDINT(x,'FILESIZE') will always return a value of 0.
  • FILEDDINT(x,'KEYLOC') and FILEDDINT(x,'KEYLEN') are valid only for VSAM KSDS files.
  • FILEDDINT(x,'delay') and FILEDDINT(x,'retry') will always return a value of 0.
  • FILEDDINT(x,'KEYLOC') and FILEDDINT(x,'KEYLEN') are valid only for VSAM KSDS files.

Restrictions

The ERROR condition with oncode 1010 is raised when the file is not open or the attribute is invalid for the file being queried.

Parent topic: Open PL/I Built-ins


FILEDDWORD Function

Purpose

Returns a character string that is the value of the attribute c for file x.

Syntax

FILEDDWORD(x,c)

Parameters

x
File reference.
c
Character string that holds the attribute to be queried.

Description

FILEDDWORD returns a character string that is the value of the attribute c for file x. When using FILEDDWORD, the following are valid options for c:

  • access
  • amthd
  • action
  • charset
  • filename
  • organization
  • recfm
  • type

These options return the following values:

  • ACCESS returns SEQUENTIAL or DIRECT.
  • ACTION returns INPUT, OUTPUT, or UPDATE.
  • AMTHD returns VSAM KSDS, VSAM ESDS or VSAM RRDS, FILESYS when run under Enterprise Server and FILESYS when run outside of Enterprise Server.
  • CHARSET returns ASCII or EBCDIC.
  • On the Enterprise Server the FILENAME returns an MVS dataset name. For an MVS dataset that is a member of a PDS or PDSE, the name returned includes the member name. When run outside of Enterprise Server it returns the fully qualified path name of the file.
  • ORGANIZATION returns CONSECUTIVE, RELATIVE, REGIONAL(1) or INDEXED.
  • RECFM returns the appropriate record format setting for the file, and U for VSAM files. This option is only valid on Enterprise Server.
  • TYPE returns RECORD or STREAM.

Restrictions

The ERROR condition with oncode 1010 is raised when the file is not open or the attribute is invalid for the file being queried.

Parent topic: Open PL/I Built-ins


FILEOPEN Function

Purpose

Returns '1'B if the file x is open and '0'B if the file is not open.

Syntax

FILEOPEN (x)

Parameters

x is the file name.

Parent topic: Open PL/I Built-ins


FIXED Function

Purpose

Converts an arithmetic or string value to a fixed-point arithmetic value with a specified precision and, optionally, a scale factor.

Syntax

FIXED(x,p)

or

FIXED(x,p,q)

Parameters

x is an arithmetic or string value, and p and q are integer constants representing precision and scale factor, respectively.

Description

The FIXED function converts an arithmetic or string value x to a fixed-point arithmetic value with a specified precision p and, optionally, a scale factor q. If q is omitted, q equals zero. The resulting fixed-point arithmetic value is converted according to the rules for type conversion given in the chapter Data Type Conversions.

Examples

FIXED(9.8614E+01,15,2)   /* returns 98.61 */

Restrictions

None.

Parent topic: Open PL/I Built-ins
Related information
Data Type Conversions


FLOAT Function

Purpose

Converts a string or arithmetic value to a floating-point arithmetic value, with a specified precision.

Syntax

FLOAT(x,p)

Parameters

x is a string or arithmetic value, and p is an integer representing precision.

Description

The FLOAT function converts a string or arithmetic value x to a floating-point arithmetic value, with a specified precision p. The resulting floating-point arithmetic value is converted according to the rules for type conversion given in the chapter Data Type Conversions.

Examples

FLOAT(98.614,8)   /* returns 9.8614 E+01 */
Parent topic: Open PL/I Built-ins
Related information
Data Type Conversions


FLOOR Function

Purpose

Returns the largest integer that is less than or equal to the specified arithmetic expression.

Syntax

FLOOR(x)

Parameters

x is an arithmetic expression.

Description

The FLOOR function returns the largest integer that is less than or equal to an arithmetic expression x.

If x is a floating-point value, the precision of the result is the precision of x. If x is a fixed-point value, the precision of the result is (MIN(n,MAX(p-q+1,1)),0). n is the maximum precision allowed for fixed-point values of the result type. (For details on maximum precisions, see your Open PL/I User's Guide.)

Examples

FLOOR(3.125)    /* returns 3.000 */
FLOOR(-3.125)   /* returns -4.000 */
FLOOR(0)        /* returns 0 */

Restrictions

None.

Parent topic: Open PL/I Built-ins


FLUSH Subroutine

Purpose

Ensures that all disk I/O on a specified file has been written to disk, as opposed to remaining in I/O buffers.

Syntax

FLUSH(f);

Parameters

f is a filename.

Description

The FLUSH subroutine is used to ensure that all disk I/O on file f has been written to disk. This subroutine might be called in order to ensure some sort of synchronization, such as during critical I/O, or if there is a concern of a system crash or some other serious problem such that you may to want to make sure that the last I/O was in fact written out to disk.

Examples

DECLARE MYFILE FILE;

WRITE FILE(MYFILE) FROM(RECORD);
CALL FLUSH(MYFILE);

Restrictions

  • Not valid for SYSPRINT or STDOUT files.
  • The asterisk used to flush all output files, for example call FLUSH(*), is not supported.
Parent topic: Open PL/I Built-ins


GRAPHIC Function

Purpose

Can be use to explicitly convert character (or mixed character) data to GRAPHIC data. All other data first converts to character, and then to the GRAPHIC data type.

Returns the graphic value of x, with a length in graphic symbols specified by y.

Characters convert to graphics. The content of x is checked for validity during conversion, using the same rules as for checking graphic and mixed character constants.

Syntax

GRAPHIC(x[,y])

Parameters

x and y are expressions.

Description

When x is GRAPHIC it is subject to a length change, with appropriate padding or truncation. When x is nongraphic it is converted to character, if necessary. SBCS characters are converted to equivalent DBCS characters.

When necessary, y is converted to a real fixed-point binary value. If y is omitted, the length is determined by the rules for type conversion. y must not be negative.

If y = 0, the result is the null graphic string.

The following rules apply:

  • If y is greater than the length needed to contain the graphic string, the result is padded with graphic blanks.
  • If y is less than the length needed to contain the graphic string, the result is truncated.

Restrictions

None.

Parent topic: Open PL/I Built-ins


HBOUND Function

Purpose

Returns a fixed-point binary integer that is the upper bound of a specified dimension of an array.

Syntax

HBOUND(x[,n])

Parameters

x is an array variable and n is an integer constant indicating the nth dimension of x.

Description

The HBOUND function returns a fixed-point binary integer that is the upper bound of a specified dimension of an array x. This allows you to determine the upper bound of an array with * extents.

n is the specified dimension of the array. If n is not present, 1 is assumed. When present, n must be greater than zero and less than or equal to the number of dimensions declared.

The precision of the result is Fixed Binary(31).

Examples

DECLARE R FIXED BINARY;
DECLARE A(3:5,2,-10:10,4:7);
   .
   .
   .
R = HBOUND(A,1);     /*R = 5*/
   .
   .
   .
R = HBOUND(A,2);     /*R = 2*/
   .
   .
   .

Restrictions

The HBOUND function is now supported with expression arguments.

Parent topic: Open PL/I Built-ins


HEX Function

Purpose

Returns a character string which contains the hexadecimal representation of the variable x.

Syntax

HEX(x,y)

Parameters

x is a variable and y is an expression that must have a nonvarying character type.

Description

HEX returns the hexidecimal representation of the bytes that contain x. Its length is 2 * size(x) when x is the only parameter, i.e. HEX(x). When there is a second parameter, i.e. HEX(x,y), it returns a hexidecimal character string that contains x with y inserted between every set of eight characters. Its length is 2 * size(x) + ((size(x) - 1)/4).

The output character string for the data types Fixed Binary, Pointer, Offset, and Char Varying (applies to the leading 2-byte Fixed Bin size field) will be constructed in big-endian form.

Note: The hexadecimal representation of arrays and structures containing the 4 data types above will be constructed in native format.

Examples

dcl s char (32) varying;

   s = 'The witch cast a terrible spell.';

    put skip list (hex(s));
    put skip list (hex(s,'+'));

Will print:

002054686520776974636820636173742061207465727269626C65207370656C6C2E
00205468+65207769+74636820+63617374+20612074+65727269+626C6520+7370656C+6C2E

Restrictions

None.

Parent topic: Open PL/I Built-ins


HIGH Function

Purpose

Returns a character string made up of the highest character in the collating sequence.

Syntax

HIGH(x)

Parameters

x is an expression whose value is a non-negative integer.

Description

The HIGH function returns a character string of length x, in which each character is the highest character in the collating sequence (ASCII = hex 7F).

The HIGH function uses a 256-byte collating string.

The value of x must be non-negative. If x = 0, the result is the null character string.

Examples

HIGH(3)    /* Returns a character string whose length
                  is equal to 3 characters and in which
                  each character is hexadecimal 7F. */

Restrictions

None.

Parent topic: Open PL/I Built-ins


HUGE Function

Purpose

Returns the largest positive value allowable for a floating-point variable.

Syntax

HUGE(x)

Parameters

x is an expression of type FLOAT BINARY or FLOAT DECIMAL.

Description

HUGE returns a floating-point value that is the largest positive value x can have. It has the base, mode, and precision of x.

The HUGE built-in is not allowed during restricted expression evaluation.

Example

This example shows the IEEE FLOAT BINARY values returned for the HUGE built-in.

dcl d float bin (52);
dcl f float bin (23);

   d = huge(d);    /* 1.7976931348623157E+308 */
   f = huge(f);    /* 3.402823466E+38         */
Parent topic: Open PL/I Built-ins


INDEX Function

Purpose

Searches a string for a specified substring and returns a fixed binary integer value indicating its position.

Syntax

INDEX(s,c,l)

Parameters

s and c are both either character or bit strings, and c may be a substring of s. l is a third optional parameter which specifies the location in s from which to start searching.

Description

The INDEX function searches a string, s, for a specified substring, c, and returns an integer value indicating the position of c within s. l specifies the location in the string from which the search begins.

If either s or c is a null string, the result is zero. If the substring c is not contained within s, the result is zero; otherwise, the result is an integer indicating the position within s of the leftmost character or bit (if s and c are bit strings) of the substring c. The result precision is Fixed Binary(15).

l must have a computational type and is converted to Fixed Binary(31,0). If l is less than 1 or if l is greater than 1 + length(s), the STRINGRANGE condition is raised, and the result is zero.

Examples

Example of INDEX(s,c):

dcl s char (40) ;
    dcl i fixed bin (15);

    s = 'dmf plb cp js acb ltt dsa';
    i = index(s, 'd');
    put skip list (substr(s, i, 3));

will print:

dmf

Example of INDEX(s,c,l):

dcl s char (40) ;
    dcl i fixed bin (15);

    s = 'dmf plb cp js acb ltt dsa';
    i = index(s, 'd', 5);
    put skip list (substr(s, i, 3));

will print:

dsa

Restrictions

None.

Parent topic: Open PL/I Built-ins


INT Function

Purpose

Interprets specified storage as a signed integer and returns the value of that integer.

Syntax

INT(expression[,position[,length]])

Parameters

expression is a scalar expression or reference to connected storage. expression cannot be an array, structure, or named constant. position is a positive integer value specifying the position of the first bit in the field; length is a positive integer value in the range 0–32 specifying the length of the field.

Description

The INT function interprets the storage specified as a signed integer and returns the value of that integer. the INT function does not perform conversion, so that the value returned depends on the data type of the variable contained in the specified storage.

If position is specified, its minimum value is 1 and its maximum value is the length in bits of the storage specified by expression. If position is omitted, the default value is 1.

If length is specified, its minimum value is 0 and its maximum value is the length in bits of the storage specified by expression, less the value of position. If length is omitted, the default value is equal to the number of bits from the bit indicated by position to the end of the storage specified by expression.

If position and length are not specified, the length of the storage referenced by expression cannot exceed 32 bits.

INT returns a value of type Fixed Bin(31). If the field has a length of zero, INT returns zero.

INT and POSINT are identical functions, except that POSINT returns an unsigned integer.

The result of this function is dependent on the native byte ordering of the hardware you are using. For this reason, the use of this function may not be portable across different platforms.

Examples

DCL A BIT(32);

   A = '12345678'B4;
   PUT SKIP LIST(INT(A,5,4));
END TEST;

Restrictions

None.

Parent topic: Open PL/I Built-ins
Related information
POSINT


LBOUND Function

Purpose

Returns a fixed binary integer value giving the lower bound of the specified dimension of an array.

Syntax

LBOUND(x[,n])

Parameters

x is an array variable, and n is an integer constant indicating the dimension of x.

Description

The LBOUND function returns an integer value that gives the lower bound of the nth dimension of x. This is useful for arrays with * extents.

n is the specified dimension of the array. If n is not present, 1 is assumed. When present, n must be greater than zero and less than or equal to the number of dimensions declared.

Examples

DECLARE R FIXED BINARY;
DECLARE A(3:5,2,-10:10,4:7);
   .
   .
   .
R = LBOUND(A,1);     /*R = 3*/
   .
   .
   .
R = LBOUND(A,2);    /*R = 1*/
   .
   .
   .

Restrictions

The LBOUND function is not supported with expression arguments.

Parent topic: Open PL/I Built-ins


LENGTH Function

Purpose

Returns a Fixed Binary integer that gives the number of characters or bits in the specified string.

Syntax

LENGTH(s)

Parameters

s is a Character, Bit String, or Picture value. If s is a binary value, it is converted to a Bit string. If it is a decimal value, it is converted to a character string.

Description

The LENGTH function returns an integer that gives the number of characters or bits in the string s, where s is either a character string or a bit string. For character varying strings, this is the length of the string currently stored in the variable.

The precision of the result is Fixed Binary(15). A null string has length zero.

Examples

    dcl s char (40) varying;
    dcl t char (40) ;

    s = 'The Lawn, 22-30 Old Bath Road';

    put skip list ('length(s) is: ', length(s));   /* char var */
    put skip list ('length(t) is: ', length(t));   /* char       */

will print:

length(s) is:          29
length(t) is:          40

Restrictions

None.

Parent topic: Open PL/I Built-ins


LEFT Function

Purpose

Returns the result of inserting a string to the left of another string with a certain length. It can be padded on the right with a character.

Syntax

LEFT(s,l,c)

Parameters

s
A string that is inserted to the left of another sting. It must have a computational type and a character type. If it does not have a character type, it is converted to character.
l
The length of a string to the left of which s is inserted. It must have a computational type and a character type and is converted to Fixed Binary(31,0).
c
Optional padding character, inserted to the right of the string. It must have a nonvarying character type.

Description

LEFT returns a string which is formed by inserting a string s to the left of another string with length l. An optional padding character c can be attached to the right.

Examples

dcl s char (40) var;
    dcl t char (40) var;

    s = 'This string is 33 characters long';
    t = left(s, 40, '+');
    put skip list (t);

will print:

This string is 33 characters long+++++++

Restrictions

None.

Parent topic: Open PL/I Built-ins


LINENO Function

Purpose

Returns a Fixed Binary integer that gives the line number of an open file control block with the specified PRINT attribute.

Syntax

LINENO(x)

Parameters

x is a file value representing a file control block.

Description

The LINENO function returns an integer that gives the line number of an open file control block identified by x.

The precision of the result is Fixed Binary(15).

x must identify an open file control block with the PRINT attribute.

Examples

DECLARE X FILE;
   .
   .
   .
CURRENT = LINENO(X);  /* GET CORRECT LINE # */

Restrictions

None.

Parent topic: Open PL/I Built-ins


LOG Function

Purpose

Returns the natural logarithm of an arithmetic expression.

Syntax

LOG(x)

Parameters

x is a floating-point value greater than zero.

Description

The LOG function returns the natural logarithm of x. Note that LOG(x) is the inverse of EXP(x), that is, LOG(EXP(x)) = x = EXP(LOG(x)).

The result has the same data type as x.

Examples

LOG(7.389056)    /* returns 2 */

Restrictions

An LOG operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


LOG10 Function

Purpose

Returns the logarithm of an arithmetic expression to the base 10.

Syntax

LOG10(x)

Parameters

x is a floating-point value greater than zero.

Description

The LOG10 function returns the logarithm of x to the base 10. Note that LOG10(x) is the inverse of 10**x, that is, 10**LOG10(x) = x = LOG10(10**x).

The result has the same data type as x.

Examples

LOG10(100.0)   /* returns 2 */

Restrictions

A LOG10 operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


LOG2 Function

Purpose

Returns the logarithm of an arithmetic expression to the base 2.

Syntax

LOG2(x)

Parameters

x is a floating-point value greater than zero.

Description

The LOG2 function returns the logarithm of x to the base 2. Note that LOG2(x) is the inverse of 2**x, that is, 2**LOG2(x) = x = LOG2(2**x).

The result has the same data type as x.

Examples

LOG2(0.5)    /* returns -1 */

Restrictions

An LOG2 operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


LOW Function

Purpose

Returns a character string made up of the lowest character in the collating sequence.

Syntax

LOW(x)

Parameters

x is an expression whose value is a non-negative integer.

Description

The LOW function returns a character string of length x, in which each character is the lowest character in the collating sequence (hex 00).

The LOW function uses a 256-byte collating string.

The value of x must be non-negative. If x = 0, the result is the null character string.

Examples

LOW(3)    /* Returns a character string whose length
                 is equal to 3 characters and in which
                 each character is hexadecimal 00. */

Restrictions

None.

Parent topic: Open PL/I Built-ins


LOWERCASE Function

Purpose

Returns a character string with all the alphabetic characters from A to Z converted to their lowercase equivalent.

Syntax

LOWERCASE(x)

Parameters

x is an expression. It can be converted to character.

Examples

dcl s char (40) varying;

    s = 'Lead is an element with the symbol Pb';
    s = lowercase(s);
    put skip list (s);

will print:

lead is an element with the symbol pb

Restrictions

Only flat structure expressions are allowed. Arrays, arrays of structures, and structure member arrays are not yet supported.

Parent topic: Open PL/I Built-ins


LPIPARAMCOUNT Function

Purpose

Returns a fixed binary(15) integer that represents the number of parameters passed to a PL/I subroutine.

Syntax

LPIPARAMCOUNT()

or

LPIPARAMCOUNT

Description

The LPIPARAMCOUNT built-in function returns the number of parametes passed to an Open PL/I procedure from another PL/I procedure. To be able to use this function, the calling procedure has to be compiled with the -paramount compile time option, or that procedure has to have an entry name attribute OPTIONS(LPIPARAMCOUNT).

Examples

main: procedure options(main);
declare subr entry;
...
call subr();
...
call subr(x,y,z);
end main;

subr: procedure(p1,p2,p3,p4);
...
declare no_of_args fixed bin(15);
no_of_args = lpiparamcount();
put skip list ('Number of arguments passed to SUBR:  ',
                no_of_args);
end subr;

If the main program is compiled with the -paramcount option, the above example will print:

Number of arguments passed to SUBR: 0
Number of arguments passed to SUBR: 3

Restrictions

None.

Parent topic: Open PL/I Built-ins


MAX Function

Purpose

Returns the greatest of one or more values.

Syntax

MAX(x,…)

Parameters

x and any subsequent values are arithmetic values.

Description

The MAX function returns the largest of a set of arithmetic values. x and any subsequent values are converted to a common arithmetic data type (using the conversion rules for arithmetic infix operators) before the operation is performed. x and any subsequent values cannot be string values. The result is the largest of these converted values and has the common arithmetic data type.

Examples

MAX(5, -118, 1)        /* returns 5 */
MAX(12.3, 13, 9.68)    /* returns 13.0 */

Restrictions

None.

Parent topic: Open PL/I Built-ins


MAXLENGTH Function

Purpose

Returns the maximum length of a string.

Syntax

MAXLENGTH(x)

Parameters

x is an expression that must have a computational type and should have a string type. Otherwise, it is converted to character.

Examples

dcl s char (40) varying;
    dcl t char (40) ;

    s = 'The Lawn, 22-30 Old Bath Road';

    put skip list ('maxlength(s) is: ', maxlength(s));   /* char var */
    put skip list ('maxlength(t) is: ', maxlength(t));   /* char       */

will print:

maxlength(s) is:               40
maxlength(t) is:               40

Restrictions

None.

Parent topic: Open PL/I Built-ins


MIN Function

Purpose

Returns the smallest of one or more values.

Syntax

MIN(x,...)

Parameters

x and any subsequent values are arithmetic values.

Description

The MIN function returns the smallest of a set of arithmetic values. x and any subsequent values are converted to a common arithmetic data type (using the conversion rules for arithmetic infix operators) before the operation is performed. x and any subsequent values cannot be string values. The result is the smallest of these converted values and has the common arithmetic data type.

Examples

MIN(5,-118, 1)         /* returns -118 */
MIN(12.3, 11, 9.68)    /* returns 9.68 */

Restrictions

None.

Parent topic: Open PL/I Built-ins


MOD Function

Purpose

Returns the truncated remainder of x divided by y.

Syntax

MOD(x,y)

Parameters

x and y are arithmetic values.

Description

The MOD function returns the truncated remainder of x divided by y. The result is x-y*FLOOR(x/y) and has the common data type of x and y.

To determine the precision of the result, let (px,qx) and (py,qy) represent the precision of x and y, respectively. If the common type of x and y is fixed point, the precision of the result is:

(MIN(n,py-qy+MAX(qx,qy)),MAX(qx,qy))

Otherwise, the precision of the result is MAX(px,py). n is the maximum precision allowed for the common type of x and y. For details on maximum precisions, see your Open PL/I User's Guide.

Examples

MOD(15,2)    /* returns 1 */

Restrictions

The value of y must not be 0.

An MOD operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


MPSTR Function

Purpose

Truncates a string at a logical boundary and returns a mixed character string. It does not truncate a double-byte character between bytes. The length of the returned string is equal to the length of the expression x, or to the value specified by y.

Syntax

MPSTR(x,r[,y])

Parameters

x, y, and r are expressions.

Description

x yields the character string result. The value of x is converted to character if necessary.

r yields a character result. The expression cannot be GRAPHIC and is converted to character if necessary. r specifies the rules to be used for processing the string.

The characters that can be used in r and the rules for them are as follows:

V or v
Validates the mixed string x and returns a mixed string.
S or s
Removes any null DBCS strings, creates a new string, and returns a mixed string.

If both V and S are specified, V takes precedence over S, regardless of the order in which they were specified. If S is specified without V, the string x is assumed to be a valid string. If the string is not valid, results are undefined.

y, if necessary, is converted to a real fixed point binary value. If y is omitted the length is determined by the rules for type conversion. The value of y cannot be negative.

If y = 0, the result is the null character string. If y is greater than the length needed to contain x, the result is padded with blanks. If y is less than the length needed to contain x, the result is truncated by discarding excess characters from the right (if they are SBCS characters), or by discarding as many DBCS characters (2-byte pairs) as needed.

Restrictions

r is ignored on Intel and AIX.

Parent topic: Open PL/I Built-ins


MULTIPLY Function

Purpose

Multiplies an arithmetic value by an arithmetic value and returns the product with a specified precision and an optionally specified scale factor.

Syntax

MULTIPLY(x,y,p)

or

MULTIPLY(x,y,p,q)

Parameters

x and y are arithmetic values, and p and q are integer constants that represent precision and scale factor, respectively.

Description

The MULTIPLY function multiplies an arithmetic value, x, by an arithmetic value, y, and returns the product with a specified precision p and an optionally specified scale factor q.

The result is x*y, having the common data type of x and y.

The precision of the result is (p,q) or (p). In the latter case, q equals zero.

Examples

DECLARE (LENGTH, WIDTH) FIXED BINARY(15);
   .
   .
   .
PUT LIST ('TOTAL AREA IS'||MULTIPLY (LENGTH, WIDTH, 31));

Restrictions

The parameter q must not occur unless the result type is decimal.

Parent topic: Open PL/I Built-ins


NULL Function

Purpose

Returns a null pointer value.

Syntax

NULL()

or

NULL

The second syntax form can be used only when the BUILTIN attribute is specified.

Description

The NULL function returns a null pointer value. The default NULL value is -1 (all 1 bits). This value is a fictitious address, which is distinct from any valid pointer address.

The -setnull compiler option allows you to designate a particular null pointer value for the NULL function at compile time. For a description of the -setnull compiler option, see your Open PL/I User's Guide.

Examples

IF LAST_POINTER = NULL() THEN CALL FINISH;

In this example, the IF statement determines whether the pointer variable LAST_POINTER is null; if so, the CALL statement executes.

Restrictions

None.

Parent topic: Open PL/I Built-ins


OFFSET Function

Purpose

Returns an offset value relative to an area and derived from a pointer.

Syntax

OFFSET(p,a)

Parameters

p is a pointer reference identifying a based variable; a is the area containing the based variable.

Description

The OFFSET function returns an offset value that is the relative byte offset of a based variable stored within an area variable.

If p is the null pointer value, the OFFSET function returns the null offset value.

Examples

DECLARE (A, B) AREA;
DECLARE (A1, A2) CHAR(20) BASED;
DECLARE (P1, P2) POINTER;
DECLARE (01, 02) OFFSET(A);
DECLARE (03, 04) OFFSET(B);

ALLOCATE A1 IN(A) SET(01);
ALLOCATE A2 IN(A) SET(02);

B = A;                /* assign area */

P1 = ADDR(01->A1);    /* address of A1 in A */
P2 = POINTER(02, B);  /* address of A2 in B */

03 = OFFSET(P1, A);   /* offset value of A1 -
                         same in A and B */
04 = OFFSET(P2, B);   /* offset value of A2 -
                         same in A and B */

Restrictions

None.

Parent topic: Open PL/I Built-ins


ONCHAR Function

Purpose

Returns a character string of length 1, containing the character that caused the CONVERSION condition to be signaled.

Syntax

ONCHAR()

or

ONCHAR

The second syntax form can be used only when ONCHAR has been explicitly declared with the BUILTIN attribute.

Description

The ONCHAR function returns a character string of length 1, containing the character that caused the CONVERSION condition to be signaled.

The ONCHAR function can be used in an ON-unit established for a CONVERSION condition. It can also be used for an ERROR ON-unit that obtains control as the result of unsuccessful error correction in the CONVERSION ON-unit.

Examples

DCL I FIXED BIN(15);
ON CONVERSION BEGIN;
 PUT LIST ('Incorrect character is:',ONCHAR());
END;

I = '34Z9';

In the above example, the program will display the character "Z" that caused the conversion error to occur.

Restrictions

None.

Parent topic: Open PL/I Built-ins


ONCODE Function

Purpose

Returns a fixed-point binary integer that is the status value of the most recent run-time error that signaled the current ON condition.

Syntax

ONCODE()

or

ONCODE

The second syntax form can be used only when the BUILTIN attribute is specified.

Description

The ONCODE function returns a binary integer that is the status value of the most recent run-time error that signaled the current ON condition. The result has an implementation-defined precision. (For details on precisions, see your Open PL/I User's Guide.) The ONCODE function can be used in any ON-unit to ascertain the exact error that caused the condition. Used within any context other than an ON-unit, the ONCODE function returns a zero.

For the values of the run-time errors that signal particular ON conditions, see your Open PL/I User's Guide.

Examples

ON ERROR BEGIN;
   PUT EDIT ('ERROR NUMBER', ONCODE()) (SKIP, A, F(10));
END;

Restrictions

None.

Parent topic: Open PL/I Built-ins
Related information
Introduction


ONFILE Function

Purpose

Returns the name of a file constant for which the most recent ENDPAGE, ENDFILE, KEY, or UNDEFINEDFILE condition was signaled.

Syntax

ONFILE()

Description

The ONFILE function returns the name of a file constant for which the most recent ENDPAGE, ENDFILE, KEY, or UNDEFINEDFILE condition was signaled. The ONFILE function can also be used in an ERROR ON-unit that gets control as a consequence of the default Open PL/I action for file-related errors. (The default action for file-related errors is to signal the ERROR condition.)

The returned value is a varying length character string.

On some systems, you may need to specify the -defext compile-time option for ONFILE to return the correct value. For specific information, see your Open PL/I User's Guide.

Restrictions

If referenced outside an ON-unit or within an ON-unit that is executed as a result of a SIGNAL statement, the ONFILE function returns a null string.

If used outside an ON-unit or within an ON-unit that has been invoked as the result of a condition unrelated to any file, the ONFILE function returns a null string.

All other uses of such files must be in other modules compiled without the -defext compile-time option or declared with the GLOBALREF attribute.

Parent topic: Open PL/I Built-ins
Related information
GLOBALREF


ONKEY Function

Purpose

Returns the key value that precipitated the signaling of the condition during an input/output operation to a file that is being accessed.

Syntax

ONKEY()

Description

The ONKEY function returns the key value that precipitated the signaling of the KEY condition during an input/output operation to a file that is being accessed by key.

The ONKEY function can be used in an ON-unit established for the ENDFILE, KEY, RECORD, and UNDEFINEDFILE conditions. It can also be used for an ERROR ON-unit that obtains control as a result of the default Open PL/I action for the KEY condition. (The default action is to signal the ERROR condition.)

The returned value is a varying length character string.

Examples

ON KEY(DFILE) BEGIN;
 PUTEDIT ('DFILE KEY',ONKEY(),'NOT FOUND')(SKIP,3 A);
END;

Restrictions

If the ONKEY function is referenced outside an ON-unit or within an ON-unit executed as a consequence of a condition not related to a file being accessed by key, it will return the null string.

Parent topic: Open PL/I Built-ins


ONLOC Function

Purpose

Returns the name of an entry in which a condition was raised.

Syntax

ONLOC()

Description

When the ONLOC function is called under the control of an ON-unit (that is, from the ON-unit or any procedure called by the ON-unit), it returns a character string whose value is the name of the entry in which the condition was raised that caused the ON-unit to be invoked. If a call to the ONLOC function is made not under the control of an ON-unit, ONLOC() returns the null string.

Examples

SUBPROG: PROCEDURE(X) RETURNS(FLOAT BIN(23));
   DECLARE X FLOAT BIN(23);
   ON ERROR BEGIN;
      PUT LIST('Error at ', ONLOC());
      PUT SKIP;
      GOTO HIGHER_LEVEL_EXIT;
      END;
   X = X / (X-X);
   RETURN(X);
END SUBPROG;

Execution of this subprogram causes the following text to be displayed:

Error at SUBPROG

Restrictions

This feature is currently available only on Sun SPARC Solaris 2.

Parent topic: Open PL/I Built-ins


ONSOURCE Function

Purpose

Returns a character string whose value is the context of the field that was being processed when the CONVERSION condition was signaled.

Syntax

ONSOURCE()

or

ONSOURCE

The second syntax form can be used only when ONSOURCE has been explicitly declared with the BUILTIN attribute.

Description

The ONSOURCE function returns a character string whose value is the context of the field that was being processed when the CONVERSION condition was signaled.

The ONSOURCE function can be used in an ON-unit established for a CONVERSION condition. It can also be used for an ERROR ON-unit that obtains control as the result of unsuccessful error correction in the CONVERSION ON-unit.

The returned value is a varying-length character string.

Examples

DCL BT BIT(4);
ON CONVERSION BEGIN;
PUT LIST ('Incorrect string is:',ONSOURCE());
END;

T = '1021';

In the above example, the program will display the string "1021" that caused the conversion error to occur because only characters 0 and 1 are valid for a bit data type.

Restrictions

None.

Parent topic: Open PL/I Built-ins


PACKAGENAME Function

Purpose

Since packages are not supported, the name of the outermost procedure is returned.

Syntax

PACKAGENAME()

Examples

   /* Since Open PL/I does not support Packages, the name of the outermost  */
   /* procedure is aways returned for the PACKAGENAME() built-in.          */

Micro: proc options(main);

    call Focus();

    Focus: proc;
           put skip list (packagename() || ' ' || procedurename() );
    end;

end;

will print:

MICRO FOCUS
Parent topic: Open PL/I Built-ins


PAGENO Function

Purpose

Returns a fixed binary integer that gives the current page number in the specified file.

Syntax

PAGENO(x)

Parameters

x is a file value that identifies a file control block.

Description

The PAGENO function returns an integer that gives the current page number in the file control block identified by x.

The precision of the result is Fixed Binary(15).

If x does not identify an open file control block with the PRINT attribute, the program is in error. This implementation of PL/I may not diagnose all violations of this restriction.

For a description of the PAGENO function's use as a pseudovariable, see the section Assignment in the chapter Statements.

Examples

DECLARE X FILE;
   .
   .
   .
CURRENT = PAGENO(X);  /* GET CURRENT PAGE # */

Restrictions

None.

Parent topic: Open PL/I Built-ins
Related information
Assignment


PLIRETC Subroutine

Purpose

Sets the Open PL/I return code.

Syntax

CALL PLIRETC(x);

Parameters

x is an arithmetic value.

Description

The PLIRETC built-in subroutine sets a return code that can be examined using the PLIRETV built-in function. When the program ends, the last value used in a call to PLIRETC is returned to the system as the program's exit status.

The argument to PLIRETC is converted to a Fixed Binary (31) value, but the actual precision of the value that is stored and returned to the system may be lower, depending on the implementation. For details on precisions, see your Open PL/I User's Guide.

Examples

ON ERROR CALL PLIRETC (1);

Restrictions

None.

Parent topic: Open PL/I Built-ins
Related information
PLIRETV Function


PLIFILL Subroutine

Purpose

Fills n bytes at an address with a specified byte value.

Syntax

CALL PLIFILL(x, y, z);

Parameters

x is an expression that must be declared POINTER or OFFSET. If OFFSET, you must use the AREA attribute to declare x.

y is a byte that must be declared CHARACTER(1) NONVARYING.

z is an expression that is converted to FIXED BINARY(31,0).

Description

PLIFILL moves z copies of the specified byte ( y) to a location ( x) without any conversions, padding, or truncation.

The PLIFILL, PLIMOVE and PLIOVER built-in subroutines are also useful in managing buffers.

Examples

foo: proc() options(main);

DCL PLIFILL builtin;

DCL mystring char(10) init('AAAAAAAAA');

CALL PLIFILL (addr(mystring), 'B', length(mystring));

PUT DATA(mystring);

Restrictions

None.

Parent topic: Open PL/I Built-ins


PLIMOVE Subroutine

Purpose

Fills n bytes from one address to another.

Syntax

CALL PLIMOVE(x, y, z);

Parameters

x and y are expressions declared POINTER or OFFSET. If OFFSET, x or y must be declared with the AREA attribute.

z is an expression that is converted to FIXED BINARY(31,0).

Description

The PLIMOVE built-in subroutine moves z storage units (bytes) from location y to location x, without any conversions, padding, or truncation. Unlike the PLIOVER built-in, subroutine, storage at locations x and y are assumed to be unique.

The PLIFILL, PLIMOVE and PLIOVER built-in subroutines are also useful in managing buffers.

Examples

foo: proc() options(main);

DCL PLIMOVE builtin;

DCL mystring char(10) init('AAAAAAAAAA');
DCL mystring2 char(10) init('BBBBBBBBBB');

CALL PLIMOVE(addr(mystring), addr(mystring2), length(mystring2));

PUT DATA(mystring);

end;

Restrictions

If storage overlaps, unpredictable results can occur.

Parent topic: Open PL/I Built-ins


PLIOVER Subroutine

Purpose

Moves n bytes from one address to another, compensating for possible overlap of the source and target. Usage of PLIOVER is the same as PLIMOVE, with the exception that storage for x and y can overlap.

Syntax

CALL PLIOVER(x, y, z);

Parameters

x and y are expressions declared POINTER or OFFSET. If OFFSET, x or y must be declared with the AREA attribute.

z is an expression that is converted to FIXED BINARY(31,0).

Description

The PLIOVER built-in subroutine moves z storage units (bytes) from location y to location x, without any conversions, padding, or truncation. Unlike the PLIMOVE built-in, subroutine, storage at locations x and y can overlap. The PLIFILL, PLIMOVE and PLIOVER built-in subroutines are also useful in managing buffers.

Examples

foo: proc() options(main);

DCL PLIOVER builtin;

DCL mystring char(10) init('BBBBBAAAAA');

CALL PLIMOVE(addr(mystring), addr(mystring)+ 5, 5);

PUT DATA(mystring);

end;

Restrictions

None.

Parent topic: Open PL/I Built-ins


PLIRETV Function

Purpose

Returns a fixed binary integer that is the Open PL/I return code.

Syntax

PLIRETV()

or

PLIRETV

Description

The PLIRETV function returns the most recent value specified by a CALL PLIRETC statement. Note that the precision of the returned value may be smaller than that of the value passed to PLIRETC, and the precision of the value returned to the system at program termination may be even smaller than that returned by PLIRETV, depending on the implementation. (For more information on this implementation, see your Open PL/I User's Guide.) For example, the PLIRETC and PLIRETV routines may preserve their fixed binary (31) value, but the value may be truncated (using the MOD function) to only the rightmost byte of that value when the program exits.

Examples

CALL READ_LINE (BUFFER);
IF PLIRETV ()
THEN PUT LIST ("ERROR ON INPUT");

Restrictions

None.

Parent topic: Open PL/I Built-ins
Related information
PLIRETC Function


PLISRTx Subroutines

Purpose

These routines enable data to be sorted, with source and destination as indicated by the following table:

 | Input Data From | Output Data To
PLISRTA | Input file | Output file
PLISRTB | Procedure | Output file
PLISRTC | Input file | Procedure
PLISRTD | Procedure | Procedure
RECORD | Input file | ??

Syntax

CALL PLISRTA(fields–spec, records-spec, storage,
             ret-code [,prefix][,msg-level]
             [,algorithm]);
CALL PLISRTB(fields-spec, records-spec, storage,
             ret-code, input-proc[,prefix][msg-level][,algorithm]);
CALL PLISRTC(fields-spec, records-spec, storage,
             ret-code, output-proc [,prefix][,msg-level]
             [,algorithm]);
CALL PLISRTD(fields-spec, records-spec, storage,
             ret-code, input-proc, output-proc [,prefix]
             [,msg-level][,algorithm]);

Parameters

fields-spec is a character-string having the following format:

` box SORT box FIELDS=(pos,len,type,seq,[,posj,lenj,typej,seqj]...) [,options-list] box '

box, in each of the three instances, represents one or more space characters. These are the only spaces that may occur in the string.

  • pos is the start position of a sort key-field with the records. The position is given in bytes, with 1 representing the first byte.
  • len is the length of the key in bytes.
  • type is the key type, as follows:
    CH | character string
    ZD | pictured
    PD | fixed decimal
    Fl | fixed binary
    BI | bit string
    FL | float binary
  • seq must be A or D, indicating whether to sort with ascending or descending values of this key.

    The following items can be specified in the options-list:

    FILSZ=n | Specifies the number of records in the sort. This option is ignored.
    SKIPREC=n | Specifies that n records at the beginning of the input file are to be skipped.
    CKPT or CHKPT | Specifies that checkpoints are to be taken. This option is ignored.
    EQUALS | Specifies a stable sort algorithm (that is, that records with identical key values are to be kept in the same order they have in the input file or were given by the input procedure.
    NOEQUALS | Specifies that a stable sort algorithm will not be used. This is the default.
    DYNALLOC=(d,n) | Specifies the intermediate storage. This option

records–spec is a character-string having the following format:

` box RECORD box TYPE=rectype,LENGTH=(len)[,ftype] box '

box, in each of the three instances, represents one or more space characters. These are the only spaces that may occur in the string.

  • rectypeis F or V, indicating fixed-length records or variable-length ASCII records, respectively.
  • len specifies the length of the records to be sorted.
  • ftype is INDEXED. If ftype is omitted, CONSECUTIVE is assumed.

storage: This argument is ignored.

Description

The input records are sorted as specified by the parameters and written to the output file or passed to the output procedure, as appropriate.

If an input or output procedure is used, it is called repeatedly by the sort subroutine, once for each record involved in the sort. Hence, the procedure must be written so as to process one record at a time. These procedures are ordinary PL/I procedures, and all PL/I language rules apply. Any contained AUTOMATIC variables are reinitialized at each invocation of the procedure and any allocated BASED or CONTROLLED variables are freed when the procedure returns.

An input procedure must have the form:

IN_PROC: PROCEDURE RETURNS(CHAR(len));
   DECLARE S CHAR(len);
   IF LAST_REC THEN DO;
      CALL PLIRETC(8);
/* must tell the sort routine all records have been sent */
      RETURN(S);
      END;
   ELSE DO;
      /* code to produce the record goes here */
      CALL PLIRETC(12);
/* tell the sort routine this is not the last record */
      RETURN(S);
      END;
END IN_PROC;

An output procedure must have the form:

OUT_PROC: PROCEDURE(S);
   DECLARE S CHAR(*);
   /* code to process the sorted record goes here */
   CALL PLIRETC(4);
/* tell the sort routine to continue sending records */
END OUT_PROC;

In the output procedure, use CALL PLI RETC(16); to tell the sort routine to terminate unsuccessfully.

Examples

Example 1

 plisrt1: proc options(main);
   /*
      Examples of the PLISRT Built in functions.

      This program uses a data file named 'SRT1IN',
      with a record length of 20, which must already exist.
   */

   dcl  (plisrta, plisrtb, plisrtc, plisrtd) builtin;

   declare ret_code fixed bin(31);
   declare eof bit(1);
   declare chkdata file;
   declare rec char(20);

   put skip list('Plisrt1 starting...');
   put skip(2) list('Contents of SRT1IN :-');

   /* display the input file */
   open file(chkdata) record title('SRT1IN');
   eof = '0'b;
   on endfile(chkdata) eof='1'b;
   read file(chkdata) into(rec);
   do while(eof = '0'b);
      put skip list(rec);
      read file(chkdata) into(rec);
      end;
   close file(chkdata);
   revert endfile(chkdata);

   put skip(2) list('Calling plisrta ---------------------------->');
   call plisrta(' sort fields=(1,10,ch,a),equals',
             ' record type=F,length=(20) ',
             0 ,              /* strg */
             ret_code,
             'SRT1',         /* data name prefix */
             'AP',           /* msg level */
             'xxxx'          /* sort method */);
   put skip list('result code is ', ret_code);

   /* display output file of above */
   put skip(2) list('Contents of SRT1OUT :-');
   open file(chkdata) record title('SRT1OUT');
   eof = '0'b;
   on endfile(chkdata) eof='1'b;
   read file(chkdata) into(rec);
   do while(eof = '0'b);
      put skip list(rec);
      read file(chkdata) into(rec);
      end;
   close file(chkdata);
   revert endfile(chkdata);

   put skip(2) list('Calling plisrtb ---------------------------->');
   call plisrtb(' sort fields=(1,10,ch,a)',
             ' record type=f,length=(20) ',
             0 ,              /* strg */
             ret_code,
             input_proc,
             ,               /* data name prefix */
             'AP',           /* msg level */
             'xxxx'          /* sort method */);
   put skip list('result code is ',ret_code);

   /* display output file of above */
   put skip(2) list('Contents of SORTOUT :-');
   open file(chkdata) record title('SORTOUT');
   eof = '0'b;
   on endfile(chkdata) eof='1'b;
   read file(chkdata) into(rec);
   do while(^eof);
      put skip list(rec);
      read file(chkdata) into(rec);
      end;
   close file(chkdata);
   revert endfile(chkdata);

   put skip(2) list('Calling plisrtc ---------------------------->');
   call plisrtc(' sort fields=(1,10,ch,a) ',
             ' record type=f,length=(20) ',
             0 ,              /* strg */
             ret_code,
             output_proc,
             'SRT1',          /* data name prefix */
             'AP',            /* msg level */
             'xxxx'           /* sort method */);
   put skip list('result code is ',ret_code);

   put skip(2) list('Calling plisrtd ---------------------------->');
   call plisrtd(' sort fields=(1,10,ch,a),skiprec=3 ',
             ' record type=f,length=(20) ',
             0 ,              /* strg */
             ret_code,
             input_proc,
             output_proc,
             ,                /* data name prefix */
             'AP',            /* msg level */
             'xxxx'          /* sort method */);
   put skip list('result code is ',ret_code);

   /* reset the PL/1 return code */
   call pliretc(0);
   put skip(2) list('Plisrt1 processing completed');

 input_proc: procedure returns(char(20));
   dcl x char(20);
   dcl cnt fixed bin(31) static internal initial(0);
   dcl rec(1:5) char(20) static internal initial (
        'abc2', 'abc4', 'abc1', 'abc6', 'abc3');

   cnt = cnt + 1;
   if cnt <= 5 then do;
      x=rec(cnt);
      call pliretc(12);
      end;
   else do;
      x = '';
      call pliretc(8);   /* no more */
      cnt = 0;
      end;
   return(x);
 end input_proc;

 output_proc: procedure(y);
   dcl y char(*);

   put skip list(y);
   call pliretc(4);    /* ready for more */
 end output_proc;

end plisrt1;

Example 2

test: proc options(main);

   /* Test of SORT Bif using a indexed file as input.
   /* The input file is 1st created by this program prior to the sort. */

/*
/* How to compile/link
/*
/* mfplx srt2.pl1 -defext -cisam
*/

/* Output of this program:
/*
/* Creating a indexed file with following records:
/*
/* Calling plisrtc ---------------------------------------
/* Sorting on 2nd column ASCENDING, 1st column DECENDING
/*    Boston                             abc
/*    Albany                             ccc
/*    Westboro                           xyz
/*    Milford                            xyz
/*    Acton                              xyz
/*
/**/

   dcl   plisrtd builtin;
   declare ret_code fixed bin(31);
   declare (input_proc,output_proc) entry;

   dcl SORTIN direct env(vsam keylength(8) keyloc (5) recsize(50));
   dcl rec char(50);

   %replace KEY2 by 40;       /* be sure to change other references */
   %replace KEY2_LEN by 3;    /* be sure to change other references */

   put skip list('Creating a indexed file with following records:');
   open file(SORTIN) output;

   rec = ' ';
   substr(rec,KEY2,KEY2_LEN) = 'ccc';
   write file(SORTIN) from(rec) keyfrom('Albany');

   rec = ' ';
   substr(rec,KEY2,KEY2_LEN) = 'xyz';
   write file(SORTIN) from(rec) keyfrom('Acton');

   rec = ' ';
   substr(rec,KEY2,KEY2_LEN) = 'abc';
   write file(SORTIN) from(rec) keyfrom('Boston');

   rec = ' ';
   substr(rec,KEY2,KEY2_LEN) = 'xyz';
   write file(SORTIN) from(rec) keyfrom('Westboro');

   rec = ' ';
   substr(rec,KEY2,KEY2_LEN) = 'xyz';
   write file(SORTIN) from(rec) keyfrom('Milford');
   close file(SORTIN);
   put skip;

   put skip list('Calling plisrtc ---------------------------------------');
   put skip list('Sorting on 2nd column ASCENDING, 1st column DECENDING');
   call plisrtc(' sort fields=(40,3,ch,a,5,8,ch,d) ',
             ' record type=f,length(50),indexed ',
             0 ,            /* strg */
             ret_code,      /* result status */
             output_proc,
             ,              /* data name prefix */
             'AP',          /* msg level */
             'xxxx'         /* sort method */);
   put skip list('result code is ',ret_code);

end test;

output_proc: procedure(x);
   dcl x char(*);

   put skip list(x);
   call pliretc(4);    /* ready for more */
end output_proc;

Restrictions

Open PLI supports up to 64 sort keys. All sort control keys must fit into 1024 bytes.

Parent topic: Open PL/I Built-ins
Related information
Using Open PL/I with Other Software Products


PLITEST Subroutine

Purpose

Attaches a debugger to a set point in a program to execute a series of commands.

Syntax

CALL PLITEST(Debug_Commands, Display Address, PLITEST_FLAGS);

Parameters

Debug_Commands is a string of CodeWatch commands you want executed immediately after PLITEST has attached to your process.

Display_Address is the IP address or host name, and XWindows Display Number on which the debugger is invoked. It is only used for Linux/UNIX installations and is ignored for Window platforms.

PLITEST_Flags is a series of flags that can be used to control specialized behaviors, such as whether the java user interface is used or cwcmd under control of an XTERM environment.

Description

PLITEST is an API called from User programs that causes a debugger to dynamically attach itself and execute a series of commands. A PLITEST call is typically inserted in a user application where debugging is to start at a given point in the execution flow.

Examples

DCL PLITEST ENTRY(CHAR(1024) varying,  char(100) varying, fixed bin(31) );

DCL Debug_Commands  char(1024) varying
    init(‘SHLIB MYPROG.so;ENV MYPROG;BR MYLABEL;C’);

DCL Display_Address char(100) varying init(’10.24.11.80:0’);

DCL PLITEST_Flags   fixed bin(31) init(1);
/*1 = Use cw_java debugger interface*/

CALL PLITEST(Debug_Commands, Display_Address, PLITEST_FLAGS);

Restrictions

An XWindows Server such as Micro Focus ViewNow must be running on the client machine if debugging an application on a Linux/UNIX client machine in order to host the debugger user interface.

Java runtime environment (JRE) 1.6.0_11 or later must be installed on the machine executing the app calling PLITEST.

Parent topic: Open PL/I Built-ins
Related information
Using Open PL/I with Other Software Products


POINTER Function

Purpose

Returns a pointer value specifying the generation of a based variable in an area.

Syntax

POINTER(o,a)

Abbreviation(s): PTR for POINTER.

Parameters

o is an offset reference that specifies the generation of a based variable in the area identified by a.

Description

If o is the null offset value, the POINTER function returns the null pointer value; otherwise, the value of o must be the offset of some based variable's allocation in an area, but not necessarily in a.

The result returned by the POINTER function is the sum of the offset value, o, plus the address of the beginning of the area, a.

Examples

DECLARE (A, B) AREA;
DECLARE (A1, A2) CHAR(20) BASED;
DECLARE (P1, P2) POINTER;
DECLARE (01, 02) OFFSET;

ALLOCATE A1 IN(A) SET(01);
ALLOCATE A2 IN(A) SET(02);

B = A;                  /* assign area */

P1 = POINTER(01, B);    /* address of A1 in B */
P2 = POINTER(02, B);    /* address of A2 in B */

Restrictions

None.

Parent topic: Open PL/I Built-ins


POINTERADD Function

Purpose

Increments (or decrements) a pointer value by an integer value.

Syntax

POINTERADD(x,y)

Abbreviation(s): PTRADD for POINTERADD.

Parameters

x is a pointer expression. y is a fixed binary(31) value or a value that can be converted to a fixed binary(31) value.

Description

The POINTERADD function returns a pointer value that is the pointer value x incremented by y bytes (or decremented by y bytes if y is negative).

Examples

DECLARE A CHAR(10) BASED INIT('0123456789');
DECLARE B CHAR(3);
DECLARE P POINTER;
ALLOCATE A SET(P);
B = POINTERADD(P,3)->A;   /* This yields B = '345'. */

Restrictions

None.

Parent topic: Open PL/I Built-ins


POINTERDIFF / PTRDIFF Function

Purpose

Returns the difference between two pointers, which is FIXED BINARY(31,0).

Syntax

POINTERDIFF(x,y)

Parameters

x and y are expressions declared as POINTER.

Description

POINTERDIFF returns the difference between two pointers, which is FIXED BINARY(31,0). It can be abbreviated as PTRDIFF.

Restrictions

None.

Parent topic: Open PL/I Built-ins


POINTERSUBTRACT / PTRSUBTRACT

Purpose

Equivalent to POINTERADD(x,-y).

Syntax

POINTERSUBTRACT(x,y)

Parameters

x
A pointer expression.
y
Expression that has a computational type and is converted to FIXED BINARY(31,0).

Description

POINTERSUBTRACT is equivalent to POINTERADD(x,-y). It can be abbreviated as PTRSUBTRACT.

Restrictions

None.

Parent topic: Open PL/I Built-ins


POINTERVALUE Function

Purpose

Returns a pointer value that is the converted value of the specified expression.

Syntax

POINTERVALUE(x)

Abbreviation: PTRVALUE for POINTERVALUE.

Parameters

x is an expression. It must have either the HANDLE attribute, or have a computational type. If x has a computational type, it is converted to fixed binary.

Description

You can use POINTERVALUE(x) to initialize static pointer variables if x is a constant.

Restrictions

None.

Parent topic: Open PL/I Built-ins


POLY Function

Purpose

Returns a floating point value that is an approximation of a polynomial formed from the specified one-dimensional array expression. The returned value has the same attributes as the first argument.

Syntax

POLY(x,y)

Parameters

x is an array expression, and y is an element expression.

Description

x must be real float and y is converted to the attributes of x, if necessary.

If x has lower bound 0 and upper bound n, the result is a classic polynomial of degree n in y with coefficients given by x: x(0) + x(1)*y + x(2)*y**2 + ... + x(n)*y**n.

In the general case, where x has lower bound m and upper bound n, the result is the polynomial x(m) + x(m+1)*y + x(m+2)*y**2 + ... + x(n)*y**(n-m)

Parent topic: Open PL/I Built-ins


POSINT Function

Purpose

Interprets specified storage as an unsigned integer and returns the value of that integer.

Syntax

POSINT(expression[,position[,length]])

Parameters

expression is a scalar expression or reference to connected storage. expression cannot be an array, structure, or named constant. position is a positive integer value specifying the position of the first bit in the field; length is a positive integer value in the range 0 – 32 specifying the length of the field.

Description

The POSINT function interprets the storage specified as an unsigned integer and returns the value of that integer. The POSINT function does not perform conversion, so that the value returned depends on the data type of the variable contained in the specified storage.

If position is specified, its minimum value is 1 and its maximum value is the length in bits of the storage specified by expression. If position is omitted, the default value is 1.

If length is specified, its minimum value is 0 and its maximum value is the length in bits of the storage specified by expression, less the value of position. If length is omitted, the default value is equal to the number of bits from the bit indicated by position to the end of the storage specified by expression.

If position and length are not specified, the length of the storage referenced by expression cannot exceed 32 bits.

POSINT returns a value of type Fixed Bin(31). If the field has a length of zero, POSINT returns zero. Because POSINT returns an unsigned integer, it is possible for the value returned to be too large for assignment to Fixed Bin(31). The result of such an operation is undefined.

POSINT and INT are identical functions, except that INT returns a signed integer.

The result of this function is dependent on the native byte ordering of the hardware you are using. For this reason, the use of this function may not be portable across different platforms.

Examples

DCL A BIT(32);

   A = '12345678'B4;
   PUT SKIP LIST(POSINT(A,5,4));

END TEST;

Restrictions

None.

Parent topic: Open PL/I Built-ins
Related information
INT


PRECISION Function

Purpose

Returns the value of the specified expression using specified precsion.

Syntax

PRECISION(x,p[,q])

Abbreviation: PREC for PRECISION.

Parameters

x is an expression, and p and q are restricted expressions.

Description

p specifies the number of digits that the value of the expression x is to have after conversion.

q specifies the scaling factor of the result. For a fixed-point result, if q is omitted a scaling factor of zero is assumed. For a floating-point result, q must be omitted.

The base, mode, and scale of the returned value are the same as that of x.

Restrictions

None.

Parent topic: Open PL/I Built-ins


PROCEDURENAME() Function

Purpose

Returns the name of the most closely nested procedure as a character-string. PROCNAME() can be used equivalently.

Syntax

PROCEDURENAME();
or
PROCNAME();

Examples

Example 1:

myprog: proc options(main);

    dcl procedurename builtin;

    call sub1(procedurename());

   sub1: proc( caller);

    dcl caller char (*);

    put skip list('The calling procedure is: ' || caller);

    /* Note: procname() is equiv. of procedurename() */
    put skip list('The current procedure is: ' || procname());

   end;
end;

This program prints:

The calling procedure is: MYPROG
The current procedure is: SUB1

Example 2:

   /* Since Open PL/I does not support Packages, the name of the outermost  */
   /* procedure is aways returned for the PACKAGENAME() built-in.          */

Micro: proc options(main);

    call Focus();

    Focus: proc;
           put skip list (packagename() || ' ' || procedurename() );
    end;

end;

will print:

MICRO FOCUS
Parent topic: Open PL/I Built-ins


PROD Function

Purpose

Returns the product of all the elements of an array.

Syntax

PROD(x)

Parameters

x is an array expression.

Description

The PROD function returns the product of all the elements of the array.

If the elements of x are strings, they are converted to fixed-point values. If they are neither fixed-point values nor strings, they are converted to floating-point values. In the latter case, the result is a floating-point value; otherwise, it is a fixed-point value.

Examples

DECLARE (A(4), I) FIXED BIN (15);

DO I = 1 to 4;
   A(I) = I;
END

I = PROD(A);       /* returns 24 */

Restrictions

None.

Parent topic: Open PL/I Built-ins


RANDOM Function

Purpose

Returns a random number generated using an expression as the given seed.

Syntax

RANDOM(x)

Parameters

x is an expression that must have a computational type and should have an arithmetic type.

Description

The RANDOM function returns a random number generated using an expression x as the given seed. If the expression is omitted, the random number is generated using the seed of the last RANDOM function that has a seed. If there is no RANDOM function with a seed invoked before that, the default seed is 1.

If the expression x that is used as a seed is numeric, it must be real. If it is not specified FIXED BINARY(31,0), it is converted.

If x is not greater than 0 and less than 2,147,483,646, the ERROR condition is raised.

The output of RANDOM is a value distributed between 0 and 1. It is generated using the following multiplicative congruential method:

seed(x) = mod(950706376 * seed(x - 1), 2147483647)
random(x) = seed(x) / 2147483647

The seed is maintained at the program level.

Examples

rand: proc options(main);

    dcl x float bin (52);
    dcl i fixed bin (31);

    put skip list ('---- seed: 10 -------------');
    x = random(10);
    put skip list (x);

    do i = 1 to 6;
       x = random();
       put skip list (x);
    end;

    put skip list ('---- seed: 100000 ---------');

    x = random(100000);
    put skip list (x);

    do i = 1 to 6;
       x = random();
       put skip list (x);
    end;
end;

will print:

---- seed: 10 -------------
 9.843643940912393E-001
 3.341328461347766E-001
 1.034361082610842E-001
 5.866471489829230E-001
 7.405739988854965E-001
 3.124010266328235E-001
 7.504689692288959E-001
---- seed: 100000 ---------
 2.727828287858436E-001
 4.692549409667286E-001
 1.388299465825921E-001
 3.343486782788991E-001
 9.890356291965748E-002
 8.330502211270156E-001
 3.848663831059199E-001

Restrictions

None.

Parent topic: Open PL/I Built-ins


RANK Function

Purpose

Returns a fixed binary integer that is the position of the character x within the collating sequence.

Syntax

RANK(x)

Parameters

x is a character string of length one.

Description

The RANK function returns a fixed binary integer that is the position of the character x within the collating sequence.

The result is defined as RANK(x) = INDEX(COLLATE(),x)-1 and has an implementation-defined precision. For details on precisions, see your Open PL/I User's Guide.

The RANK function uses a 256-byte collating string.

Examples

DECLARE X FIXED BINARY(15);
X = RANK('2');   /* X IS SET TO 50 */

Restrictions

None.

Parent topic: Open PL/I Built-ins


REPEAT Function

Purpose

Returns a string consisting of the source string concatenated to itself the number of times specified by the second argument.

Syntax

REPEAT(x,y)

Parameters

xis a character-string, bit-string, or picture value, and y is a positive integer expression. If x is an arithmetic value, it is converted to a bit string if it is binary, or to a character string if it is decimal.

Description

The REPEAT function copies a particular string, x, a certain number of times, y, and concatenates the result to the original string x. REPEAT effectively returns a string containing (y+1) occurrences of the string argument with length (y+1) * length (x).

Examples

DECLARE X CHAR(8);

X = REPEAT('AB',3);       /* returns X = 'ABABABAB' *

Note that the same result could be produced by using a string repetition factor, as illustrated below:

X = (4) 'AB';

Here is an example of using the REPEAT function for bit–strings:

DECLARE B_STRING BIT(4) STATIC INIT('1110'B);
DECLARE B_RESULT BIT(8);

B_RESULT = REPEAT(B_STRING,1);

The above example will produce B_RESULT equal to '11101110'B.

Restrictions

None.

Parent topic: Open PL/I Built-ins


RESIGNAL() Subroutine

Purpose

Continues to search for another ON-unit to handle a condition.

Syntax

CALL RESIGNAL();

Description

In Open PL/I, an ON-unit can determine that it does not want to handle a condition and can subsequently request that, instead of returning control to the point of interruption, Open PL/I continue to search for another ON-unit to handle the condition. The RESIGNAL built-in subroutine is available for this purpose.

CALL RESIGNAL() is used in an ON-unit to pass the signaled condition back to the run-time system so that it can look for another ON-unit to handle the condition. The condition is passed at the end of the current ON-unit, that is, execution of the RESIGNAL does not immediately cause a return to the run-time system, but merely sets up the conditions so that when the ON-unit completes its execution and returns, the run-time system will continue searching for another ON-unit that matches the signaled condition.

Examples

ON ERROR BEGIN;
 PUT SKIP LIST('AN UNIDENTIFIED ERROR OCCURRED IN GETREC');
 CALL RESIGNAL();
END;

Restrictions

None.

Parent topic: Open PL/I Built-ins


REVERSE Function

Purpose

Returns a nonvarying string that contains the elements of an expression in reverse order.

Syntax

REVERSE(x)

Parameters

x is an expression.

Description

REVERSE returns a nonvaying string that contains the elements of an expression x in reverse order. x must have a computational type and a string type. If it does not have a string type, it is converted to string (that is, from numeric to bit or character), according to the rules for concatenation.

Examples

dcl s char (40) varying;

    s = 'NeverOddOrEven';
    s = reverse(s);
    put skip list (s);

will print:

nevErOddOreveN

Restrictions

Only flat structure expressions are allowed. Arrays, arrays of structures, and structure member arrays are not yet supported.

Parent topic: Open PL/I Built-ins


RIGHT Function

Purpose

Returns the result of inserting a string at the right of another string with a certain length. It can be padded on the left with a character. If no padding character is inserted, a blank is used as a padding.

Syntax

RIGHT(s,l,c)

Parameters

s
A string that is inserted to the right of another sting. It must have a computational type and a character type. If it does not have a character type, it is converted to character.
l
The length of a string to the rigth of which s is inserted. It must have a computational type and is converted to Fixed Binary(31,0).
c
Optional padding character, inserted to the left of the string. It must have a nonvarying character type.

Description

RIGHT returns a string which is formed by inserting a string s to the right of another string with length l. An optional padding character c can be attached to the left. If not, a blank is used as a padding.

Examples

dcl s char (40) var;
    dcl t char (40) var;

    s = 'This string is 33 characters long';
    t = right(s, 40, '+');
    put skip list (t);

will print:

+++++++This string is 33 characters long

Restrictions

None.

Parent topic: Open PL/I Built-ins


ROUND Function

Purpose

Rounds a given value at a specified digit and pads spare digit positions with zeros.

Syntax

ROUND(x,k)

Parameters

x is a fixed-point arithmetic or decimal picture value to be rounded, and k is an integer constant that specifies the digit at which the value x is to be rounded.

Description

The ROUND function rounds a given value x at a specified digit and pads positions k+1 to q (q is the scale factor) with zeros. The result is the value of x rounded such that the kth position of x is expressed to its nearest integer. For example, if the argument is 8.77 and it is desired to round to the first fractional digit, the result would be 8.80.

The first argument, x, may be an element expression or array name representing the value (or values, in the case of an array). If the value to be rounded is negative, its absolute value is rounded, but its sign remains unchanged.

The second argument, k, may be unsigned or signed. If k is positive, rounding occurs at the kth digit to the right of the decimal (or binary) point in the first argument; if k is zero, rounding occurs at the first digit to the left of the decimal (or binary) point in the first argument; if k is negative, rounding occurs at the (1 - k) digit to the left of the decimal (or binary) point in the first argument.

Examples

DCL (X,K) DECIMAL FIXED (7,4);
X = 123.7261;
K = ROUND(X,3);       /* K IS NOW 123.7260 */
K = ROUND(X,2);       /* K IS NOW 123.7300 */
K = ROUND(X,1);       /* K IS NOW 123.7000 */
K = ROUND(X,0);       /* K IS NOW 124.0000 */
X = -123.7261;
K = ROUND(X,2);       /* K IS NOW -123.7300 */
K = ROUND(X,0);       /* K IS NOW -124.0000 */
K = ROUND(X,-1);      /* KIS NOW -120.0000 */
X = 9.9999;
K = ROUND(X,0);       /* K IS NOW 10.0000 */

Restrictions

None.

Parent topic: Open PL/I Built-ins


SEARCH Function

Purpose

Returns the first position in a string where a character or bit of another string appears. You can also specify the location from which to start searching.

Syntax

SEARCH(x,y,z)

Parameters

x
An expression which pecifies the string in which to search for a character or bit that appears in another string.
y
An expression where a character or bit appears.
z
An optional expression which specifies the location in the string x from which to start searching. It must have a computational type and is converted to Fixed Binary(31,0).

Description

SEARCH returns the first position in the string x where a character or bit of the string y appears. The result is an unscaled real fixed binary value.If any of these two expressions is a null string, the result is zero. If y doesn't appear in x, the result is zero.

You can also specify the location from which to start searching with the expression z.

The SEARCH function can be used to find delimiters in a string of numbers.

Examples

dcl s char (16);
    dcl i fixed bin (15);

    s = 'Newbury, England';
    i = search (s, 'ry');            /* i = 6, ‘r’ found starting from the left */

Restrictions

None.

Parent topic: Open PL/I Built-ins


SEARCHR Function

Purpose

Similar to the SEARCH function with a few differences.

Syntax

SEARCHR(x,y,z)

Parameters

x
An expression which specifies the string in which to search for a character or bit that appears in another string.
y
An expression where a character or bit appears.
z
An optional expression which specifies the location in the string x from which to start searching. It must have a computational type and is converted to Fixed Binary(31,0).

Description

SEARCHR does the same as SEARCH, i.e. it returns the first position in a string where a character or bit of another string appears. However, there are a few differences between them. With SEARCHR search is done from right to left and the default value for z is LENGTH(x).

Examples

dcl s char (16);
    dcl i fixed bin (15);

    s = 'Newbury, England';
    i = searchr (s, 'ry');            /* i = 7, ‘y’ found starting from the right */

Restrictions

None.

Parent topic: Open PL/I Built-ins


SIGN

Purpose

Returns a 1, -1, or 0, indicating whether the specified value is positive, negative, or zero, respectively.

Syntax

SIGN(x)

Parameters

x is an arithmetic expression.

Description

The SIGN function returns a 1, -1, or 0, indicating whether x is positive, negative, or zero, respectively. The precision of the result is Fixed Binary(15).

Examples

IF SIGN(X) = 1 THEN
   PUT LIST ('SIGN OF X IS POSITIVE');

Restrictions

None.

Parent topic: Open PL/I Built-ins


SIN Function

Purpose

Returns a floating-point value that is the sine of an arithmetic expression.

Syntax

SIN(x)

Parameters

x is an arithmetic expression.

Description

The SIN function returns a floating-point value that is the sine of an arithmetic expression x, where x is an angle in radians such that -1 ? SIN(x) ? 1.

The sine is computed in floating-point, and the result has the same data type as x.

Examples

SIN(0.0)    /* returns 0.0 */

Restrictions

An SIN operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


SIND Function

Purpose

Returns a floating-point value that is the sine of the specified angle expressed in degrees.

Syntax

SIND(x)

Parameters

x is a floating-point value representing the sine of an angle.

Description

The SIND function returns the sine of the angle x expressed in degrees. The result has the same data type as x such that -1 ? SIND(x) ? 1.

Examples

SIND(30.0)      /* returns 0.5 */

Restrictions

An SIND operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


SINH Function

Purpose

Returns a floating-point value that is the hyperbolic sine of the arithmetic value x.

Syntax

SINH(x)

Parameters

x is a floating-point value representing the sine of an angle.

Description

The SINH function returns the hyperbolic sine of the angle x expressed in radians. The result has the same data type as x.

Examples

SINH(0.0)   /* returns 0.0 */

Restrictions

An SINH operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


SIZE Function

Purpose

Returns a Fixed Bin(31) value that is the number of bytes allocated for the referenced variable.

Syntax

SIZE(reference)

Parameters

reference is a variable of any data type and storage class.

Description

This function is identical to the STORAGE function and is provided for compatibility with earlier versions of Open PL/I (formerly called LPI-PL/I).

The SIZE function returns a Fixed Bin(31) integer that is the number of bytes allocated for the referenced variable. The variable can be a scalar, an array, an array element, a structure, or a member of a structure. The reference cannot be made to a constant or an expression.

When a reference is made to an individual array element, the value returned is the size of the element of the array and not the size of the entire array. The SIZE function can be used with an unconnected array argument.

If the variable is a bit string that does not fill an integral number of bytes, the value returned is rounded up to the next byte. If the variable is of the type character varying, the value returned is the declared length of the string plus two, where the extra two bytes are the bytes needed to store the current length of the string.

Examples

In the following example, the returned values are shown in the comment.

Note: The sizes in the example are accurate for Open PL/I, but may not be correct for different implementations of PL/I that have different precision, alignment, boundaries, or datatype representations. For information on this implementation, see your Open PL/I User's Guide.
DECLARE
   S FIXED BIN(31),
   A FIXED BIN(15),
   B FIXED BIN(31),
   C FLOAT BIN(23),
   D CHAR(5),
   E CHAR(5) VARYING,
   F BIT(11),
   G POINTER;

S = SIZE(A);   /* S = 2 */
S = SIZE(B);   /* S = 4 */
S = SIZE©);   /* S = 4 */
S = SIZE(D);   /* S = 5 */
S = SIZE(E);   /* S = 7 */
S = SIZE(F);   /* S = 2 */
S = SIZE(G);   /* S = 4 */

DECLARE
   S FIXED BIN(31),
   1 A_STRUCT
      2 A FIXED BIN(31),
      2 B CHAR (2),
   C(20) FIXED BIN(15);

S = SIZE(A_STRUCT);    /* S = 6 */
S = SIZE(A STRUCT.A);  /* S = 4 */
S = SIZE(A_STRUCT.B);  /* S = 2 */
S = SIZE©);           /* S = 40 */
S = SIZE©(13));       /* S = 2 */

DECLARE
   S FIXED BIN(31),
   1 STRUC1,
      2 A BIT(1),
      2 B BIT(3);
DECLARE
   1 STRUC2,
      2 C BIT(1) ALIGNED,
      2 D BIT(3) ALIGNED;

S = SIZE(STRUC1);   /* S = 1 */
S = SIZE(STRUC2);   /* S = 2 */

Restrictions

None.

Parent topic: Open PL/I Built-ins


SQRT Function

Purpose

Returns the positive square root of the specified value.

Syntax

SQRT(x)

Parameters

x is a positive or zero floating-point value.

Description

The SORT function returns the positive square root of x. The result has the same data type as x.

Examples

SQRT(4.0)    /* returns 2.0 */

Restrictions

An SQRT operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


STORAGE Function

Purpose

Returns a Fixed Bin(31) value that is the number of bytes allocated for the referenced variable.

Syntax

STORAGE(reference)

Abbreviation(s): STG for STORAGE.

Parameters

reference is a variable.

Description

The STORAGE function returns a Fixed Bin(31) integer that is the number of bytes allocated for the referenced variable. The variable can be a scalar, an array, an array element, a structure, or a member of a structure.

When a reference is made to an individual array element, the value returned is the size of the element of the array and not the size of the entire array. If the variable is a bit string that does not fill an integral number of bytes, the value returned is rounded up to the next byte.

If the variable is of the type character varying it consists of two parts: the text field and the length field. STORAGE returns the declared length of the text field plus two, since the length field always uses two bytes.

If the variable is an area, STORAGE returns the maximum size of the area plus the size of the area header.

For more information on data storage, see your Open PL/I User's Guide.

Examples

DCL A FIXED BIN(15);
      DCL 1 FOO,
            2 AB FIXED BIN(15),
            2 F001,
               5 A0 CHAR(12),
               5 A2 FIXED BIN(31),
               5 A1 CHAR(5) VARYING,
            2 ABC CHAR(4);

          PUT SKIP LIST('Should see 2 ->',SIZE (A));
          PUT SKIP LIST('Should see 2 ->',STG (A));
          PUT SKIP LIST('Should see 23 ->',STG (F001));
          PUT SKIP;

Restrictions

None.

Parent topic: Open PL/I Built-ins


STRING Function

Purpose

Concatenates the elements of an array or a structure and returns the results.

Syntax

STRING(s)

Parameters

s is an arithmetic value, string value, picture value, or an array or structure containing all string or picture values.

Description

The STRING function concatenates the elements of an array s or a structure s and returns the results. If s is scalar, it is converted to a string.

If s is an array or structure, it must:
  • have connected storage
  • not be union or structure containing unions
  • must be comprised of all type bit, or all of type char, char varying, and/or picture.

The result is converted to a string according to the rules for data type conversion given in the chapter Data Type Conversions.

For a description of the STRING function's use as a pseudovariable, see the section Assignment in the chapter Statements.

Examples

DECLARE S(4) CHAR(1);
S(1) = 'A';
S(2) = 'B';
S(3) = 'C';
S(4) = 'D';

STR = STRING(S);   /* 'ABCD' */

Restrictions

  • Structure arrrays containing char varying data items when applied as the argument to the STRING built-in is not yet supported.
  • Structures containing char varying data items when applied as the argument to the STRING pseudo-variable is not yet supported.
Parent topic: Open PL/I Built-ins
Related information
Data Type Conversions
Assignment


SUBSTR Function

Purpose

Returns a string that is a copy of a specified part of the specified string.

Syntax

SUBSTR(s,i,j)

or

SUBSTR(s,i)

Parameters

s is a bit string, character string, or picture value. If s is not a string, it is converted to a bit string if it is binary or to a character string if it is decimal. I is an integer value indicating the first bit (if s is a bit string) or character of a substring within s; and j is an integer value indicating the length of the substring within s.

Description

The SUBSTR function returns a string that is a copy of a part of the string s starting at the Ith character for a length j. If j is not given, j = LENGTH(s)-I+1, that is, the remainder of the string s.

The program is in error if I < 1 or (I + j -1) > LENGTH(s) or j < 0. If the program is compiled with subscript checking enabled, these errors result in the ERROR condition; otherwise, these errors produce unpredictable results.

For a description of the SUBSTR function's use as a pseudovariable, and for the description of the ASSIGNMENT statement, see the section Assignment in the chapter Statements.

Examples

SUBSTR('ABCDE',2,2)   /* returns 'BC' */
SUBSTR('ABCDE',2)         /* returns 'BCDE' */

Restrictions

None.

Parent topic: Open PL/I Built-ins
Related information
Assignment


SUM Function

Purpose

Returns the sum of all the elements in an array.

Syntax

SUM(x)

Parameters

x is an array expression.

Description

The SUM function returns the sum of all the elements in the array.

If the elements of the array are strings, they are converted to fixed-point values. If they are neither fixed-point values nor strings, they are converted to floating-point values. In the latter case, the result is a floating-point value; otherwise, it is a fixed-point value.

Examples

DECLARE (A(4), I) FIXED BIN (15);

DO I = 1 to 4;
   A(I) = 4;
END

I = SUM(A);     /* returns 10 */

Restrictions

None.

Parent topic: Open PL/I Built-ins


SYSNULL Function

Purpose

Returns the system null pointer value.

Syntax

SYSNULL()

or

SYSNULL

The second syntax form can be used only when the BUILTIN attribute is specified.

Parameters

None.

Description

The SYSNULL function returns a null pointer value. The SYSNULL value is 0.

This value cannot be changed by the -setnull compiler option, which applies only to the NULL built-in. For a description of the -setnull compiler option, see your Open PL/I User's Guide.

Examples

IF LAST_POINTER = SYSNULL() THEN CALL FINISH;

In this example, the IF statement determines whether the pointer variable LAST_POINTER is system null; if so, the CALL statement executes.

Restrictions

None.

Parent topic: Open PL/I Built-ins


TALLY Function

Purpose

Returns the number of times a string appears in another string.

Syntax

TALLY(x,y)

Parameters

x and y are string expressions that must have computational type and should be character or bit.

Description

TALLY returns the number of times the string x appears in the string y. The result is a Fixed Binary (31,0) value. If y does not appear in x, the result is zero. If any of these two expressions is a null string, the result is zero.

Examples

dcl s char (40);
   dcl n fixed bin (15);

   s = 'peter piper picked a peck of pickled peppers.';

   n = tally(s, 'p');
   put skip list ("'p'  appears " || trim(n) || ' times.');

   n = tally(s, 'pe');
   put skip list ("'pe' appears " || trim(n) || ' times.');

   n = tally(s, 'pi');
   put skip list ("'pi' appears " || trim(n) || ' times.');

   n = tally(s, 'ck');
   put skip list ("'ck' appears " || trim(n) || ' times.');

will print:

'p'  appears 8 times.
'pe' appears 4 times.
'pi' appears 3 times.
'ck' appears 3 times.

Restrictions

None.

Parent topic: Open PL/I Built-ins


TAN Function

Purpose

Returns the tangent of the specified angle expressed in radians.

Syntax

TAN(x)

Parameters

x is a floating-point value representing an angle and cannot be an odd multiple of ?/2.

Description

The TAN function returns the tangent of the angle x expressed in radians. The result has the same data type as x.

Examples

TAN(0.0)    /* returns 0.0 */

Restrictions

A TAN operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


TAND Function

Purpose

Returns the tangent of the specified angle expressed in degrees.

Syntax

TAND(x)

Parameters

x is a floating-point value representing an angle and cannot be an odd multiple of 90.

Description

The TAND function returns the tangent of the angle x expressed in degrees. The result has the same data type as x.

Examples

TAND(45.0)    /* returns 1.0 */

Restrictions

A TAND operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


TANH Function

Purpose

Returns the hyperbolic tangent of the specified arithmetic value.

Syntax

TANH(x)

Parameters

x is a floating-point value representing an angle.

Description

The TANH function returns the hyperbolic tangent of the angle x expressed in radians such that -1 ? TANH(x) ? 1.

The result has the same data type as x.

Examples

TANH(0.0)       /* returns 0.0 */

Restrictions

A TANH operation on floating-point decimal data is actually performed using the floating-point binary operation. Thus, the range of the operands and the result of the operation are limited to the ranges for floating-point binary numbers.

Parent topic: Open PL/I Built-ins


TIME Function

Purpose

Returns a character string that represents the time of day.

Syntax

TIME()

or

TIME

The second syntax form can be used only if the BUILTIN attribute was specified.

Description

The TIME function returns a character string of the form hhmmssttt that represents the time of day, where hh, mm, and ss are in the ranges 00 – 23, 00 – 59, and 00 – 59, respectively, and represent hours, minutes, and seconds, respectively. ttt represents thousandths of a second. If your system is not capable of supplying ttt, zeros are returned in these positions. (Releases of Open PL/I prior to release 5.0 returned only two fractional digits, that is, hundredths, instead of three. To retain that behavior, compile with the -pl1g option. (See your Open PL/I User's Guide.)

Examples

The value of TIME at 6 seconds after 11:15 P.M. is '231506000 '.

Restrictions

None.

Parent topic: Open PL/I Built-ins


TINY Function

Purpose

Returns the smallest positive value allowable for a floating-point variable.

Syntax

TINY(x)

Parameters

x is an expression of type FLOAT BINARY or FLOAT DECIMAL.

Description

TINY returns a floating-point value that is the smallest positive value x can have. It has the base, mode, and precision of x.

The TINY built-in is not allowed during restricted expression evaluation.

Example

This example shows the IEEE FLOAT BINARY values returned for the TINY built-in.

dcl d float bin (52);
dcl f float bin (23);

   d = tiny(d);    /* 4.9406564584124654E-324 */
   f = tiny(f);    /* 1.401298464E-45         */
Parent topic: Open PL/I Built-ins


TRANSLATE Function

Purpose

Replaces occurrences of a character in a string with a corresponding translation character and returns the resulting string.

Syntax

TRANSLATE(s,t)

or

TRANSLATE(s,t,x)

Parameters

s, t, and x are all character strings.

Description

Given a character string argument, the TRANSLATE function replaces occurrences of a character with a corresponding translation character and returns the resulting string. If x is not given, it is assumed to be COLLATE(). (The TRANSLATE function uses a 256-byte collating string.) If x is the null string, s is returned without translation.

If t is shorter than x, t is padded on the right with blanks until the length of t is equal to the length of x. If t is longer than x, the rightmost extra characters of t are ignored.

The occurrence of an element of x in the string s is replaced by the corresponding element in the string t.

If s is the null string, the result is the null string. If s is not the null string, for each character of s, s(k), the value I is calculated to be equal to INDEX(x,s(k)). If the value of I is 0, the corresponding character of the result is s(k); otherwise, the corresponding character of the result is t(I).

Examples

TRANSLATE('TEXT','abcdefghijklmnopqrstuvwxyz',
        'ABCDEFGHIJKLMNOPQRSTUVWXYZ')    /*returns 'text'*/

Restrictions

None.

Parent topic: Open PL/I Built-ins


TRIM Function

Purpose

Strips blanks or specified characters from the beginning and end of a character string value and returns the resulting string.

Syntax

TRIM(string[,a,b])

Parameters

string is a character string value (variable or constant). a, if present, is a string consisting of the set of characters to be trimmed from the beginning of string. b, if present, is a string consisting of the set of characters to be trimmed from the end of string.

Description

The TRIM built-in function strips the characters specified in a from the beginning of string and the characters specified in b from the end of string and returns the resulting string.

If the second and third arguments are not present, blanks are trimmed from the beginning and end of the first argument.

Examples

The following example returns the values shown in the comment.

DECLARE
   S CHAR(25)VARYING,
   A CHAR(5);
A = 'ABC';
S = TRIM(A);            /* S = 'ABC' */
S = TRIM(' HELLO');     /* S = 'HELLO' */
S = TRIM(' GOODBYE ');  /* S = 'GOODBYE' */
S = TRIM('');           /* S = '' null string */
S = TRIM('abcdefghi','cba', 'high');    /* S = 'def' */
S = TRIM('abc','abc','abc')   /* S = '' null string */

Restrictions

None.

Parent topic: Open PL/I Built-ins


TRUNC Function

Purpose

Returns the integer part of a specified value.

Syntax

TRUNC(x)

Parameters

x is an arithmetic expression.

Description

The TRUNC function returns the integer part of x. If x is floating-point, the precision of the result is the precision of x.

If x is fixed-point, the precision of the result is (MIN(n,MAX(p-q+1,1)),0). n is the maximum precision allowed for values of the result type. For details on maximum precisions, see your Open PL/I User's Guide.

For x < 0, the result is CEIL(x). For x ? 0, the result is FLOOR(x).

Examples

TRUNC(3.125)    /* returns 3 */
TRUNC(-3.125)   /* returns -3 */

Restrictions

None.

Parent topic: Open PL/I Built-ins


UNSPEC Function

Purpose

Returns a bit string containing the internal representation of the specified value.

Syntax

UNSPEC(x)

or

UNSPEC(SUBSTR(char_string,i,j))

Parameters

x is a reference to a scalar variable.

?

Description

The UNSPEC function returns a bit string containing the internal representation of x.

The length and content of the result value depend on the data type and value of x and are implementation-defined. For details, see your Open PL/I User's Guide.

Examples

DECLARE CH CHAR(1);
DECLARE MINUS_ONE FIXED BIN;
MINUS_ONE = -1;
UNSPEC(CH) = UNSPEC(MINUS_ONE);
BIT(8) = UNSPEC(CH);   /* '11111111'B */
Parent topic: Open PL/I Built-ins
Related information
Assignment


UPPERCASE Function

Purpose

Returns a character string with all the alphabetic characters from a to z converted to their uppercase equivalent.

Syntax

UPPERCASE(x)

Parameters

x is an expression. It can be converted to character.

Examples

    dcl s char (40) varying;

    s = 'Lead is an element with the symbol Pb';
    s = uppercase(s);
    put skip list (s);

will print:

LEAD IS AN ELEMENT WITH THE SYMBOL PB

Restrictions

Only flat structure expressions are allowed. Arrays, arrays of structures, and structure member arrays are not yet supported.

Parent topic: Open PL/I Built-ins


VALID Function

Purpose

Determines whether a reference to a scalar pictured value has a value that is valid with respect to its picture specification.

Syntax

VALID(x)

Parameters

x is a reference to a scalar pictured value.

Description

The VALID function determines whether x, a reference to a scalar pictured value, has a value that is valid with respect to its picture specification. The result is a bit string of length one that indicates if the character-string value of x can be edited into the picture declared for x.

If the character-string value of x can be edited into the picture declared for x, the result value is '1' B; otherwise, the result is '0' B.

The VALID function can be used when a pictured data item or a pictured item that is a member of a structure is read using the READ statement. Record input done with READ does not perform the validation that is normally done when a value is assigned to a pictured data item.

Examples

VALIDATE_FILE: PROCEDURE (BALANCES, REC_COUNT);
   DECLARE BALANCES FILE RECORD;
   DECLARE REC_COUNT FIXED BIN(31);
   DECLARE TOTAL PICTURE '999V.99';

DO I = 1 TO REC_COUNT;
   READ FILE(BALANCES) INTO (TOTAL);
   IF ^VALID(TOTAL) THEN
      DO;
      PUT LIST('Invalid total value:', TOTAL);
      PUT SKIP;
      END;
   END;
END VALIDATE_FILE;

Restrictions

None.

Parent topic: Open PL/I Built-ins


VERIFY Function

Purpose

Compares a string with a test string and verifies that all characters appearing in the string also appear in the test string.

Syntax

VERIFY(s,c)

Parameters

s and c are both either character-string or picture values.

Description

The VERIFY function compares a string s with a test string c and verifies that all characters appearing in the string also appear in the test string. If each of the characters in s occurs in c, the result is 0. If all of the characters in s do not occur in c, the result is a fixed-point binary integer that indicates the leftmost character in s that is not found in c. If only s is null, a 0 is returned. If only c is null, a 1 is returned. If both s and c are null, a 0 is returned.

Examples

VERIFY('2a56b','0123456789')
/* returns the value 2 to indicate the first */
/* non-numeric character in the string '2a56b' */

Restrictions

None.

Parent topic: Open PL/I Built-ins


WCHARVAL Function

Purpose

Returns a WIDECHAR(1) character value corresponding to an integer value.

Syntax

WCHARVAL(x)

Parameters

x is an expression converted to SIGNED FIXED BIN (15).

Note: UNSIGNED FIXED BIN (16) is not a currently supported data type.

Description

The WCHARVAL function converts an expression to FIXED BIN(15) and returns the corresponding WIDECHAR(1) character.

Examples

DCL WC WCHAR (1);
DCL C  CHAR (1);

WC = WCHARVAL(65);
PUT SKIP LIST (HEX(WC));   /* 0041 */
C = WC;
PUT SKIP LIST(C);          /* A    */

Restrictions

None.

Parent topic: Open PL/I Built-ins


WHIGH Function

Purpose

Returns a wide character string made up of the highest wide character value (0xFFFF).

Syntax

WHIGH(x)

Parameters

x is an expression whose value is a non-negative integer.

Description

The WHIGH function returns the wide character string of length x, in which each wide character is the highest wide character value (0xFFFF).

The value of x must be non-negative and less than 16383 (maximum length of the wide character string). If x = 0, the result is the null character string.

Examples

WHIGH(3)
/* Returns a wide character string whose length */
/* is equal to 3 wide characters where */
/* each character is hexadecimal 0xFFFF. */

Restrictions

None.

Parent topic: Open PL/I Built-ins


WIDECHAR Function

Purpose

Converts an arithmetic or string value to a wide character string.

Syntax

WIDECHAR(s)

or

WIDECHAR(s, l)
Abbreviation(s): WCHAR for WIDECHAR

Parameters

s is an arithmetic or string value, and l is a positive integer value.

Description

The WIDECHAR function converts an arithmetic or string value s to a wide character string of an optionally specified length l. s is first converted to a wide character string whose length is determined by the rules for data type conversion given in the Data Type Conversions chapter. Then, if i is given, s is either truncated on the right or extended on the right with blanks to be i characters long.

Examples

DECLARE X FIXED BINARY (15);
DECLARE Y WIDECHAR (14) VARYING;
X = 2;
Y = WIDECHAR(X);
PUT SKIP LIST (HEXIMAGE(ADDRDATA(Y), LENGTH(Y)*2)); /* 002000200020002000200020002000200032 */

Restrictions

The WIDECHAR function does not support unaligned BIT(n) parameters.

Parent topic: Open PL/I Built-ins
Related information
Data Type Conversions


WLOW Function

Purpose

Returns a wide character string made up of the lowest wide character value (0x0000).

Syntax

WLOW(x)

Parameters

x is an expression whose value is a non-negative integer.

Description

The WLOW function returns the wide character string of length x, in which each wide character is the lowest wide character value (0x0000).

The value of x must be non-negative and less than 16363 (maximum length of the wide character string). If x = 0, the result is the null character string.

Examples

WLOW(3)
/* Returns a wide character string whose length */
/* is equal to 3 wide characters where */
/* each character is hexadecimal 0x0000. */

Restrictions

None.

Parent topic: Open PL/I Built-ins


Open PL/I Macro Preprocessor

This appendix describes the Open PL/I Macro Preprocessor and defines the statements, procedures, and built-ins available for use with the preprocessor. For information on invoking the Open PL/I Macro Preprocessor refer to the chapter Using Open PL/I in your Open PL/I User's Guide.

  • Overview
  • Preprocessor Scan
  • Preprocessor Variables and Data Elements
  • Preprocessor References and Expressions
  • Scope of Preprocessor Names
  • Preprocessor Statements
  • Preprocessor Procedures
Parent topic: Open PL/I Language Reference Manual
Related information
Using Open PL/I


Overview

The Open PL/I Macro Preprocessor enables the PL/I programmer to have control of the source program during compile time. It is executed prior to the compilation, and its output is passed to the Open PL/I Compiler.

  • Preprocessor I/O
Parent topic: Open PL/I Macro Preprocessor


Preprocessor I/O

The preprocessor input is a file containing an Open PL/I source module, possibly including Open PL/I Macro Preprocessor statements. The preprocessor output is an Open PL/I source module containing no further preprocessor statements, but with the source code modified according to the semantics of the preprocessor statements that were encountered in the input file.

  • Preprocessor Statements
  • Listing Control Statements
Parent topic: Overview


Preprocessor Statements

Preprocessor statements, with the exception of preprocessor procedures, are executed as they are encountered. Preprocessor procedures must be invoked in order to be executed. Preprocessor statements, except those in preprocessor procedures, begin with a percent symbol (%). Blanks, tabs, and returns may separate the percent symbol from the rest of the statement, except where indicated.

The preprocessor executes preprocessor statements and alters the input text accordingly. Preprocessor statements can cause parts of the input text to be altered in any of the following ways:

  • Any identifier (and optional argument list) appearing in the input text can be changed to become an arbitrary string of text.
  • If a conditional compilation is desired, the programmer can indicate which sections of the program are to be compiled and which discarded.
  • Strings of text residing in different files can be incorporated into the source program.
Parent topic: Preprocessor I/O


Listing Control Statements

Listing control statements are not copied to the preprocessor output. A warning message is given when these are found. These statements are:

  • %CONTROL (ignored by the preprocessor)
  • %NOPRINT
  • %PAGE
  • %PRINT
  • %SKIP
Parent topic: Preprocessor I/O


Preprocessor Scan

The preprocessor starts its scan at the beginning of its input and proceeds sequentially. When preprocessor statements are found they are executed immediately (except for preprocessor procedures, which are executed only when referenced).

An identifier that matches the name of an active preprocessor variable is replaced in the preprocessor output by the value of the variable. When an identifier matches the name of an active preprocessor function (either programmer-written or built-in) the function is invoked and the invocation is replaced by the returned value. For a discussion about activation, replacement, and rescanning, see the %ACTIVATE statement.

Parent topic: Open PL/I Macro Preprocessor
Related information
%ACTIVATE statement


Preprocessor Variables and Data Elements

Preprocessor local variables function like static storage, rather than automatic storage, so values are maintained across invocations of a preprocessor procedure.

Preprocessor names are formed according to the rules for other Open PL/I names.

A preprocessor variable is specified in a %DECLARE statement with the FIXED, CHARACTER, or BIT attribute. No other attributes can be declared for a preprocessor variable.

A preprocessor variable declared with the FIXED attribute is given the PL/I attribute DECIMAL and precision (5,0). Fixed decimal constants in preprocessor expressions must be integers.

A preprocessor variable declared with the CHARACTER attribute is given the PL/I VARYING attribute with certain restrictions on its length, as described elsewhere in this manual. String repetition factors are not allowed for character constants in preprocessor expressions.

There are no preprocessor bit variables. However, bit constants are allowed. They are converted to their corresponding decimal value and treated as fixed constants. Only the rightmost 17 digits are used. A conversion result greater than 99999 is given that value. String repetition factors are not allowed for bit constants in preprocessor expressions.

Parent topic: Open PL/I Macro Preprocessor


Preprocessor References and Expressions

Preprocessor references and expressions are written and evaluated the same way as PL/I references and expressions are, with the following restrictions:

  • Operands of a preprocessor expression can consist only of preprocessor variables, references to preprocessor procedures, fixed decimal constants, bit constants, character constants, and references to preprocessor built-in functions. Strings or character constants are limited in size to 1023 characters.
  • The exponent symbol (**) cannot be used. When found, it is converted to a plus symbol (+) and a warning message is issued.
  • For arithmetic operations, only decimal arithmetic of precision (5.0) is performed; that is, each operand is converted to a decimal fixed-point integer value of precision (5,0) before the operation is performed, and the decimal fixed-point result is converted to precision (5,0). When the value of an operand or a result of an operation exceeds 99999 (the limit of precision (5,0)) that value is set to zero.
  • The concatenation of strings is limited to 2047 characters.
Parent topic: Open PL/I Macro Preprocessor


Scope of Preprocessor Names

The scope of a preprocessor name is determined by where it is declared:

  • The scope of a name declared within a preprocessor procedure is that procedure.
  • The scope of a name declared within an included string is that included string and all input text scanned after that string is included (except any preprocessor procedure in which the name is also declared).
  • The scope of any other name is the entire preprocessor input (except any preprocessor procedure in which the name is also declared).
Parent topic: Open PL/I Macro Preprocessor


Preprocessor Statements

This section lists alphabetically, the preprocessor statements and discusses each. The characters /* introduce a comment, which terminates with the characters */. Comments do not nest and can appear within a preprocessor statement wherever blanks can appear. Comments within preprocessor statements are not inserted into the preprocessor output text.

  • %ACTIVATE
  • %ASSIGNMENT
  • %DEACTIVATE
  • %DECLARE
  • %DO
  • %END
  • %GOTO
  • %IF
  • %INCLUDE
  • %NOTE
  • %NULL
  • %REPLACE
Parent topic: Open PL/I Macro Preprocessor


%ACTIVATE

Purpose

Renders identifiers active and eligible for replacement.

Syntax

%[label:]...ACTIVATE ident[RESCAN|NORESCAN][,ident[RESCAN|NORESCAN]]...;

Abbreviation(s): %ACT for %ACTIVATE.

Parameters

Each identifier must be a preprocessor variable, a preprocessor procedure name, or a preprocessor built-in function name.

Description

When a preprocessor variable is declared, it is automatically activated. It can be deactivated by use of the %DEACTIVATE statement and reactivated by use of the %ACTIVATE statement.

If neither RESCAN nor NORESCAN is specified, RESCAN is assumed. RESCAN implies that, after a text replacement has been made, this text will be rescanned to see if any further substitutions apply. NORESCAN implies the opposite.

The appearance of an identifier in a %ACTIVATE statement makes it active and eligible for replacement; that is, any subsequent encounter of that identifier in a nonprocessor statement, while the identifier is active, will initiate replacement activity, except when the identifier appears within a comment or within single quotes.

Example

Example 1.

%DECLARE A FIXED, B CHARACTER;
%DEACTIVATE B;
%A = 24;
%B = 'VAR_NAME';
NUM = B + A;
%ACTIVATE B;
%DEACTIVATE A;
NUM = B + A;

The text generated by this example would be as follows:

NUM = B + 24;
NUM = VAR_NAME + A;

Example 2.

%DECLARE (C,D) CHARACTER;
%C = D**2;
%D = 'NUM';
NUM = C;
%ACTIVATE C NORESCAN;
NUM = C;

The text generated by this example would be as follows:

NUM = NUM**2;
NUM = D**2;

Restrictions

A %ACTIVATE statement cannot appear within a preprocessor procedure. The replacement in a rescan operation is limited to 1023 characters.

References to preprocessor procedures will not be recognized when rescanning an identifier for replacement.

Parent topic: Preprocessor Statements


%ASSIGNMENT

Purpose

Assigns a value to a specified preprocessor variable.

Syntax

%[label:]... preprocessor-variable = preprocessor-expression;

Parameters

preprocessor-variable is a preprocessor variable reference, and preprocessor-expression is any valid expression.

Description

The %ASSIGNMENT statement is used to evaluate preprocessor expressions and to assign the result to a preprocessor variable.

Example

Example 1.

%DECLARE A FIXED (B,C) CHARACTER;
%A = 1024;
%B = 'BALANCE(CUST(I,J),DATE())';
%C = 'ALLOCATE STRUC SET(STRUC_PTR);';
C
STRUC.BAL(A) = B;

The text generated by this example would be as follows:

ALLOCATE STRUC SET(STRUC_PTR);
STRUC.BAL(1024) = BALANCE(CUST(I,J),DATE());

Example 2.

%DECLARE (D,E) CHAR;
%D = 'TEST_CASE';
%E = D || '_0';
F = E;

The text generated by this example would be as follows:

F = TEST_CASE_0;
Parent topic: Preprocessor Statements


%DEACTIVATE

Purpose

Renders identifiers inactive and ineligible for replacement.

Syntax

%[label:]... DEACTIVATE ident[,ident]...;

Abbreviation(s): %DEACT for %DEACTIVATE.

Parameters

Each identifier must be a preprocessor variable, a preprocessor procedure name, or a preprocessor built-in function name.

Description

The appearance of an identifier in a %DEACTIVATE statement makes it inactive and ineligible for replacement; that is, any subsequent encounter of that identifier in a nonpreprocessor statement will not initiate any replacement activity (unless, of course, the identifier is later reactivated by use of the %ACTIVATE statement).

Parent topic: Preprocessor Statements


%DECLARE

Purpose

Specifies that an identifier is a preprocessor variable or a preprocessor procedure name.

Syntax

%[label]... DECLARE(ident[,ident]...);

Abbreviation(s): %DCL for %DECLARE.

Parameters

ident is a PL/I name.

Description

The %DECLARE statement establishes an identifier as a preprocessor variable or a preprocessor procedure name and also serves to activate that identifier with the RESCAN option.

When declaring parameters in a preprocessor procedure, they should all be declared together in the first statement.

CHARACTER (abbreviation, CHAR) specifies that the identifier represents a varying length character string of up to 4096 characters. FIXED specifies that the variable is also given the PL/I attributes DECIMAL (5,0). BIT specifies that the identifier represents a bit string of maximum length 16.

An ENTRY declaration can be specified for each preprocessor entry name in the source program. The declaration activates the entry name. The declaration of a preprocessor procedure entry name can be performed explicitly by its appearance as the label of a %PROCEDURE statement. This explicit declaration, however, does not activate the preprocessor procedure name. Preprocessor built-in function names must not be used to name preprocessor procedures.

BUILTIN specifies that the identifier is the preprocessor built-in function of the same name.

Factoring of attributes is allowed. Attributes common to several names can be factored to eliminate repeated specification of the same attribute. Factoring is achieved by enclosing names in parentheses, and following this by a set of attributes that apply to all of the names. Declarations within the parenthesized list are separated by commas.

Example

%DECLARE A FIXED, (B,C) CHARACTER;
%DECLARE SUBSTR BUILTIN;

/* Note that preprocessor variables B and C are declared using factored declaration. */
Parent topic: Preprocessor Statements


%DO

Purpose

Begins a sequence of preprocessor statements to be executed in a group.

Syntax

%[labe1:]... DO[index = start[TO finish[BY increment]] |
                                  [BY increment [TO finish]]];

Parameters

Where index is a preprocessor variable; start, finish, and increment are preprocessor expressions.

Description

The %DO statement and its corresponding %END statement delimit a preprocessor DO group and can also specify repetitive execution of the DO group.

Preprocessor DO groups can be nested. Both preprocessor statements and text other than preprocessor statements can appear within a preprocessor DO group. However, only the preprocessor statements are executed. Nonpreprocessor statements are scanned but only for possible replacement activity. Non-iterative preprocessor DO groups are useful as THEN or ELSE clauses of %IF statements.

If increment is ? 0 or start > finish, the body of the loop is not executed.

Example

%DECLARE IX FIXED;
%DO IX = 1 TO 4;
A(IX) = IX;
%END

The text generated by this example would be as follows:

A(1) = 1;
A(2) = 2;
A(3) = 3;
A(4) = 4;
Parent topic: Preprocessor Statements


%END

Purpose

Terminates a block or group headed by the most recent %DO or %PROCEDURE statement.

Syntax

%[label:]... END [label];

Parameters

Description

The %END statement is used in conjunction with %DO or %PROCEDURE statements to delimit preprocessor DO groups or preprocessor procedures.

The label following the END can be a label of a %PROCEDURE or %DO statement. No checking is done.

Restrictions

Multiple closure, that is, using one %END to close multiple groups and/or blocks, is not permitted.

Parent topic: Preprocessor Statements


%GOTO

Purpose

Transfers control to a labeled preprocessor statement.

Syntax

%[label:]... GOTO statement-label;

Alternate form: %GO TO for %GOTO.

Parameters

statement-label is a reference to a preprocessor statement.

Description

The %GOTO statement causes the preprocessor to continue its scan at the specified label.

The label following the GOTO specifies the point to which the scan will be transferred. It must be a label of a preprocessor statement.

A preprocessor GOTO statement appearing within a preprocessor procedure cannot transfer control to a point outside of that procedure.

A GOTO statement can transfer control to a label in another included file at an inner level of nesting.

Example

%DECLARE A CHARACTER;
%A = 'NAME';
%GOTO PREP_LABEL;
C = A;
%PREP_LABEL:;           /* Null statement */
D = A;

The text generated by this example would be as follows:

D = NAME;

Restrictions

The label following the GOTO cannot be the label of a preprocessor procedure.

Parent topic: Preprocessor Statements


%IF

Purpose

Conditionally executes code based on a test expression.

Syntax

%[label:]... IF expr %THEN clause-1 [%ELSE clause-2]

Parameters

expr is any expression that results in a scalar bit string value of length ? 1. The test-expression is considered true if any bit in the string is one; the expression is considered false only when all bits are zero. clause-n is any single preprocessor statement (other than %DECLARE, %PROCEDURE, %END or %DO), or a preprocessor DO group. Otherwise, the description is the same as that of Open PL/I IF statements.

Description

The %IF statement can control the flow of the scan according to the value of a preprocessor expression.

The preprocessor expression is evaluated. If the result of the evaluation is 1 or greater than 1, clause-1 is executed and clause-2 is ignored, if present. If the result of the evaluation is 0, clause-1 is ignored and clause-2, if present, is executed. In either case, the scan resumes immediately following the IF statement, unless, of course, a %GOTO in any of the clauses causes the scan to resume elsewhere. %IF statements can be nested according to the rules for nesting Open PL/I IF statements.

Example

%DECLARE (A,B) CHARACTER;
%A ='CONTROL_1';
%B = 'NAME';
%IF A = 'CONTROL_1'
%THEN %DO;
   RES = B + F(X);
%END;
%ELSE %DO;
   RES = B - F(X) + SQRT(X);
   LST = F(X) + 1;
%END;

The text generated by this example would be as follows:

RES = NAME + F(X);
Parent topic: Preprocessor Statements


%INCLUDE

Purpose

Incorporates external text into the program being scanned.

Syntax

%[label:] . . . INCLUDE pathname [,pathname] . . . ;

Parameters

pathname can be any legal UNIX pathname.

Description

The %INCLUDE statement is used to include or incorporate strings of external text into the source program being scanned.

Included text can contain nonpreprocessor and/or preprocessor statements. The scan continues with the first character in the included text. The included text is scanned in the same manner as the source program.

%INCLUDE statements can be nested to a limit of eight levels.

Parent topic: Preprocessor Statements


%NOTE

Purpose

Generates a preprocessor diagnostic message.

Syntax

%[label:]... NOTE (message [, code]);

Parameters

message is a character string expression whose value is the required diagnostic message. code is a fixed expression whose value (in a range of 0 to 16) indicates the severity of the diagnostic. If code is omitted, 0 is assumed.

Description

The %NOTE statement enables the user to generate a preprocessor diagnostic message of specified text and severity.

A code of 16 (the maximum) causes immediate termination of the preprocessing.

Parent topic: Preprocessor Statements


%NULL

Purpose

Placeholder statement.

Syntax

%[label:]... ;

Parameters

Description

The %NULL statement does nothing and does not modify sequential statement execution. It can be used to provide transfer targets for %GOTO statements. It is also useful for balancing ELSE clauses in nested %IF statements.

Parent topic: Preprocessor Statements


%REPLACE

Purpose

Specifies that an identifier is a constant of a given value.

Syntax

%REPLACE name BY constant;

Description

The %REPLACE statement specifies that an identifier is a constant of a given value.

Beginning at the point at which the %REPLACE statement is encountered, each occurrence of name that follows the %REPLACE statement, as interpreted by the macro preprocessor, is replaced by the constant until the end of compilation or until another %REPLACE statement that specifies the same name is encountered.

The %REPLACE statement is normally used to supply the sizes of tables or to give names to special constants whose meaning would not otherwise be obvious.

Example

%REPLACE MSG BY 'login';
PUT SKIP LIST(MSG);
...
%REPLACE MSG BY 'logout';
PUT SKIP LIST(MSG);
Parent topic: Preprocessor Statements


Preprocessor Procedures

Preprocessor procedures are function procedures. A preprocessor procedure is delimited by %PROCEDURE and %END statements and contains at least one RETURN statement. Preprocessor statements in a preprocessor procedure do not begin with a percent symbol.

  • Invocation of Preprocessor Procedures
  • Preprocessor Built-In Functions
Parent topic: Open PL/I Macro Preprocessor


Invocation of Preprocessor Procedures

A preprocessor procedure is invoked by the appearance of its entry name, together with an optional list of arguments. The procedure must have been previously activated by use of the %ACTIVATE statement or by its inclusion in a %DECLARE statement.

The argument list must be a parenthesized list of positional arguments following the entry name. Trailing arguments can be omitted; their absence is detected by use of the PARMSET built-in.

  • %PROCEDURE
  • RETURN
Parent topic: Preprocessor Procedures


%PROCEDURE

Purpose

Defines a procedure entry and specifies the parameters of the procedure, if any.

Syntax

%label:[label:]... PROCEDURE[(ident[,ident]...)]
[STATEMENT]RETURNS(CHARACTER|FIXED|BIT);

Abbreviation(s): %PROC for %PROCEDURE.

Parameters

ident is a PL/I name.

Description

The %PROCEDURE statement is used in conjunction with a %END statement to delimit a preprocessor procedure. Such a preprocessor procedure is an internal function procedure that can be executed only by the preprocessor.

The STATEMENT option is ignored in this version of Open PL/I. One of the attributes, CHARACTER, FIXED, or BIT, must be specified in the RETURNS attribute list to indicate the type of value returned by the function procedure. There can be no default.

The preprocessor statements ASSIGNMENT, DECLARE, DO, GOTO, IF, NULL, RETURN, and NOTE can be used within a preprocessor procedure. Inside the preprocessor procedure the % symbols are omitted.

Example

%DECLARE (A,B,C) CHARACTER;
%ACTIVATE CAT;
%A = 'AAA';
%B = 'BBB';
%C = 'CCC';
RES_STRING_3 = CAT(A,B,C);
RES_STRING_2 = CAT (A,B);
RES_STRING_1 = CAT(A);
%CAT: PROCEDURE(X,Y,Z) RETURNS(CHAR);
DECLARE (X,Y,Z) CHAR;
DECLARE S CHAR;
IF PARMSET(Z) THEN S = ''''||X||Y||Z||'''';
ELSE IF PARMSET(Y) THEN S = ''''||X||Y||'''';
ELSE S = ''''||X||'''';
RETURN(S);
%END CAT;

The text generated by this example would be as follows:

RES_STRING_3 = 'AAABBBCCC';
RES_STRING_2 = 'AAABBB';
RES_STRING_1 = 'AAA';

This example also shows how to generate a character string constant using the preprocessor. To do so, use four successive apostrophes, followed by the concatenation symbol, followed by the expression for the desired character string constant, followed by another concatenation symbol, followed by four more apostrophes.

Parent topic: Invocation of Preprocessor Procedures


RETURN

Purpose

Returns control and a value back to the point of invocation.

Syntax

[label:]...RETURN(expr);

Parameters

expr is any valid preprocessor expression.

Description

The preprocessor RETURN statement can be used only in a preprocessor procedure and can have no leading percent symbol. It returns a value as well as control back to the point from which the preprocessor procedure was invoked.

Parent topic: Invocation of Preprocessor Procedures


Preprocessor Built-In Functions

A reference to a preprocessor built-in function in input text is executed by the preprocessor only if the built-in function name is active. The functions are explained in the following table:

Function Name | Use
COMPILETIME | Returns a character string containing the current date and time in the following format: DD MMM YY HH.MM.SS
COUNTER | Returns a character string containing a decimal number. The returned number is 00001 for the first invocation and is incremented by one on each successive invocation.
INDEX(x,y) | Returns a FIXED value indicating the starting position within the character expression x of a substring identical to character expression y.
LENGTH(x) | Returns a FIXED value specifying the current length of a given character expression x.
PARMSET(x) | Used to determine whether a specified parameter has been set on the invocation of a procedure.
SUBSTR(x,y[,z]) | Returns a substring of the character expression x, starting at position y with length z.
TRANSLATE(s,t,x) | Replaces occurrences in the character string s of a character in the specified string x with the corresponding translation character in translation string t and returns the resulting string.
VARIANT | Returns a character string specified on the command line.

Examples

Example 1.

%ACTIVATE COMPILETIME;
%DECLARE TOC CHAR;
%TOC = ''''||COMPILETIME||'''';
PUT LIST ('COMPILED AT' ||TOC);
PUT SKIP;

The text generated by this example would be as follows:

PUT LIST('COMPILED AT '||' 14 NOV 93 15.53.12');
PUT SKIP;

Example 2.

%DECLARE XXX CHAR, COUNTER BUILTIN, I FIXED;
%DO I = 1 TO 4;
%XXX = 'DECLARE NAME_'|| COUNTER || 'FIXED BIN(31);';
XXX
%END;

The text generated by this example would be as follows:

DECLARE NAME_00001 FIXED BIN(31);
DECLARE NAME_00002 FIXED BIN(31)
DECLARE NAME_00003 FIXED BIN(31)
DECLARE NAME_00004 FIXED BIN(31)
Parent topic: Preprocessor Procedures


Features Unsupported by Open PL/I

  • Built-in Subroutines
  • Attributes
  • Options
  • Conditions
  • Statements
  • Constants
  • Items
  • Operations
  • Arrays
  • Others
Parent topic: Open PL/I Language Reference Manual


Built-in Subroutines

The following lists the unsupported built-in subroutines:

  • ASMTDLI subroutine
  • ONCOUNT subroutine
  • PLICANC subroutine
  • PLICKPT subroutine
  • PLIREST subroutine
Parent topic: Features Unsupported by Open PL/I


Attributes

The following lists the unsupported attributes:

  • BACKWARDS - Only supported when running Open PL/I programs within Enterprise Server.
  • COMPLEX
  • ENTRYADDR
  • EVENT
  • EXCLUSIVE
  • GENERIC
  • GRAPHIC
  • IMAG
  • ONCOUNT
  • REAL
  • SAMEKEY
  • TASK
  • TRANSIENT
Parent topic: Features Unsupported by Open PL/I


Options

The following lists the unsupported options:

  • BACKWARDS - Only supported when running Open PL/I programs within Enterprise Server.
  • COPY
  • DATA
  • ENVIRONMENT options:
    • CTL360
    • GRAPHIC
    • NCP
    • PASSWORD
    • REGIONAL
    • TP
  • EVENT
  • NOLOCK
  • PRIORITY
  • SNAP
  • TASK
  • TRANSIENT
Parent topic: Features Unsupported by Open PL/I


Conditions

The following lists the unsupported conditions:

  • (NO)CHECK condition prefix
  • (NO)CONVERSION condition prefix
  • (NO)FIXEDOVERFLOW condition prefix
  • (NO)OVERFLOW condition prefix
  • (NO)SIZE condition prefix
  • (NO)STRINGRANGE condition prefix
  • (NO)STRINGSIZE condition prefix
  • (NO)SUBSCRIPTRANGE condition prefix
  • (NO)UNDERFLOW condition prefix
  • (NO)ZERODIVIDE condition prefix
  • CHECK
  • NAME
  • PENDING
  • STRINGRANGE
  • STRINGSIZE
  • SUBSCRIPTRANGE
  • TRANSMIT
Parent topic: Features Unsupported by Open PL/I


Statements

The following lists the unsupported statements:

  • LOCATE
  • UNLOCK
  • WAIT
Parent topic: Features Unsupported by Open PL/I


Constants

  • G(Graphic)
  • GX(Graphic Hex)
  • Imaginary
  • M(Mixed)
Parent topic: Features Unsupported by Open PL/I


Items

  • C-FORMAT
  • E-FORMAT item with significant digits specifier
  • F-FORMAT item with scaling factor specifier
  • G-FORMAT
Parent topic: Features Unsupported by Open PL/I


Operations

The '/' divide operator applied to FIXED BINARY values.

Parent topic: Features Unsupported by Open PL/I


Arrays

  • Array cross-sections
  • Bit(*) arrays are not supported for ANY and ALL array built-ins.
  • Using built-ins like SIZE, LBOUND, and HBOUND for unallocated arrays of controlled storage class.
  • The detection of and error while allocating controlled-storage-class array of unspecified size for example arrays declared with an asterisk (*).
Parent topic: Features Unsupported by Open PL/I


Others

  • iSUB defining
  • PICTURE symbols (E, F, or K)
  • VARYING bit strings
  • FLUSH built-in for sysprint/stdout/stdin
  • For unallocated controlled variables the only supported built-in function is ALLOCATION. All other built-in functions that reference controlled variables require at least one allocate of the controlled variable to take place before their use.
Parent topic: Features Unsupported by Open PL/I


Glossary

A

application program

A program used to perform a particular data processing task such as inventory control or payroll.

argument

A value passed to an invoked function, procedure, or program.

arithmetic operation

An operation such as addition, subtraction, multiplication, or division that is performed only on numeric fields.

array

An ordered set of values, all having the same data type.

array element

A data item in an array.

array index

The actual number of an element in an array, or the field containing the number or relative position of an element in an array.

attribute

Characteristics the compiler uses to interpret and store the data in a program.

B

based variable

A variable that does not have a block of storage of its own, or an address. Serves as a description of the storage, but a pointer value must be used to supply the address of the storage.

binary

Relating to, being, or belonging to a numbering system with a base of 2. Valid digits are 0 and 1.

binary format

Representation of a decimal value in which each field must be 2 or 4 bytes long. The sign (4. or –) is the leftmost bit of the field and the integer value is in the remaining bits of the field. Positive numbers have a zero in the sign bit and are in two's complement form.

bit string

A sequence of bits.

branching

The technique of bypassing specific instructions or operations to alter the sequential execution of instructions in a program.

by reference

An invoked procedure for a parameter uses the same memory location as the invoking procedure for the corresponding argument.

byte

A group of eight adjacent binary digits that represents one ASCII character.

by value

An argument is copied to a temporary block of storage in the calling routine's stack frame. The parameter is a description of the temporary storage.

C

called program

A program whose execution is requested by another program, a calling program.

calling program

A program that controls the execution of another program, a called program.

comment

Words or statements in a program, command, or file that serve as documentation instead of as instructions.

compilation

Translation of a source program into an executable program.

compiler

A program that translates a source program into an executable program.

compound statement

A statement that includes another statement.

constant

Data that has an unchanging, predefined value to be used in processing. A constant does not change during the execution of a program.

controlled variable

A variable whose storage is dynamically allocated and freed in generations. Controlled variables are allocated oniy when specified in an ALLOCATE statement.

D

data format

Controls the transmission and conversion of a value to or from a stream file.

data set

A collection of data external to a program.

data structure

An area in storage that is composed of one or more subfields. A data structure can be either program described or externally described.

declared name

A name used to denote an object operated upon by the program such as a variable, file, or label.

dynamic

Occurring at execution time.

E

execution

The carrying out of the instructions of a computer program by a processing unit.

expression

Consists of operands and operators.

extent

The range indicated by the bounds of an array dimension (the upper bound minus the lower bound plus 1) and the declared length of a string variable.

external procedure

A procedure not contained within another procedure.

F

factored declarations

Declare statements that contain parenthesized lists of names.

field

An area that is reserved and used for a particular item of information.

file

A named representation of a data set.

file constant

A pointer to, or designator of, a file control block.

file control block

A block of static storage in which information about the current status of a file is retained while the file is opened.

file value

Designates a file control block.

file variable

A variable that can be assigned file values.

format list

A list of format items that controls the transmission of data to or from a stream I/O file.

H

hexadecimal

Pertaining to a numbering system with a base of 16. Valid numbers are the digits 0 through 9 and the characters A through F, where A represents 10 and F represents 15.

I

internal procedure

A procedure nested within another procedure.

K

key

A value which is used to identify a record during an I/O operation.

keyword

A name used to denote part of a statement, such as a verb, option, or clause.

L

label

A symbolic name that represents a specific location in a program. A label can serve as the destination point for one or more branching operations.

M

major structure

A structure that is not a substructure.

members

Immediate components of a structure.

N

name

A single letter, or a sequence of letters, digits, and the underscore character. Also referred to as an identifier.

null pointer value

Unique value that does not address any variable. Indicates a pointer variable and does not address anything.

null string

A string of zero length.

O

ON-unit

A block of statements that are executed if a specifiedcondition occurs.

operand

A constant, a variable reference, a built-in function reference, or an expression.

operation

A defined action performed on one or more data items, such as adding, multiplying, comparing, or moving information.

P

parameter

A name that an invoked function, procedure, or program uses to refer to an argument.

picture

A string of symbols that defines the character occupying the corresponding space.

pictured value

Character-string values that represent fixed-point decimal numbers.

pointer value

The address of a variable's storage.

precision

The number of digits in an arithmetic value.

procedure

A sequence of statements, beginning with a PROCEDURE statement and ending with an END statement. Also referred to as a block.

program

A set of instructions that directs the computer to perform a series of tasks in a specified order. Consists of one or more external procedures.

R

record

A copy of a scalar, structure, or array variable.

record file

A sequence of discrete records that are either accessible sequentially or by character-string valued keys.

reference

A name together with any subscripts, pointer qualifier, or structure names necessary to indicate the purpose of the reference.

S

scalar variable

A variable that can have only a single value.

scope

The distinct region of the program text in which a name can be referenced.

self-defining structure

A BASED structure that contains information about its own fields. The value of one member is used to determine the amount of storage space allocated for another member of the same structure.

separator

A character or series of characters used to separate names, constants, numbers, and character strings.

sequential file

A file into which records are entered one after the other. If the file is keyed, the records are processed in the sequence of the access path.

simple reference

A name without any subscripts, pointer qualifier, or structure names.

stack frame

A block of storage allocated on a stack.

statement

A sequence of tokens ending with a semicolon. Except for assignment statements, all statements start with a keyword.

statement label

A name followed by a colon (:) that prefixes a statement.

stream file

A sequence of characters organized into lines and pages.

structure

A hierarchically ordered set of values that may be of different data types.

structure qualified reference

A sequence of names written left-to-right in order of increasing level numbers.

subscript

An integer valued expression used to reference an element of an array.

subscripted reference

A name that has been declared as an array, followed by a parenthesized list of subscript expressions.

substructure

A structure that is itself a member of another structure.

T

token

A name, constant, punctuation symbol, comment, or compile-time text modification statement.

V

variable

A name to which a value can be assigned during the execution of a program. A variable can only take on values of the type specified in its variable declaration.

Parent topic: Open PL/I Language Reference Manual


Run-time System Configuration

Restriction: The run-time switches and tunables are supported for native COBOL only.

You can configure the run-time system environment to ensure it behaves appropriately for the application, regardless of the configuration used by other COBOL applications. You can configure run-time behavior through environment variables, run-time tunables, and run-time switches.

  • Run-time Switches
  • Run-time Tunables
Parent topic: General Reference
Related information
Overview of Linking Native COBOL Applications and Run-time Systems


Run-time Switches

Restriction: These switches are supported for native COBOL only.

You can control the behavior of a program by setting run-time switches. For example, there is a switch to hide trailing spaces in DISPLAY ... UPON CONSOLE statements, and a switch to direct error messages to a log file or the console. Most switches affect specific COBOL features.

  • Introduction to Switches
  • Setting Run-time Switches
  • Syntax for Setting Switches
  • List of General Run-time Switches
Parent topic: Run-time System Configuration


Introduction to Switches

A switch is a parameter you pass to the run-time system to control the behavior of your program at run time. These switches fall into two categories:

Run-time switches
Run-time switches are acted on by the run-time system itself. Each consists of an upper-case or lower-case letter. These switches affect optional aspects of the behavior of certain COBOL features at run time.
Programmable switches
COBOL programmable switches are numbered from 0 to 8. Each can be set to "off" or "on" when your application is started. Their state can be read by your application at any time when it is running.

The switches must be defined using a condition name in the Special-Names paragraph. For example:

 special-names.
     switch-0 is job-origin on status is us-office
                            off status is uk-office
  ...
 procedure division.
     evaluate job-origin
      when us-office...
      when uk-office...
  ...
Parent topic: Run-time Switches


Setting Run-time Switches

Restriction: These switches are supported for native COBOL only.

You can specify switches:

  • In the project's application configuration file in the IDE. These switch settings are built into your application and are the defaults used for your application. These settings can be overridden when you run the application.
  • In the environment variables COBSW and OOSW (for switches for object-oriented programs). These switch settings take effect when you start the application. We recommend that for switches affecting file handling, you do not use COBSW, but edit the file handler configuration file Extfh instead.

    The following command sets the programmable switches 1 and 4 on, and all the others (2, 3, 5-8) are off by default:

    set COBSW=+1+4
  • On the command line. These switch settings take effect when you start the application. Switch settings on the command line take precedence over those in COBSW.

    For example, the following command loads the program myprog with programmable switches 5 and 7 on and switch 2 off, and all the others (0, 1, 3, 4, 6 and 8) are off by default. Note that switch 7 is turned on, since the last setting of it (that is +7) is the one used.

    myprog -2+5-7+7

    The following command loads the program myprog with switch T on and switch O off:

    myprog (+T-O)
Parent topic: Run-time Switches
Related concepts
Application Configuration
Related information
To add a configuration file


Syntax for Setting Switches

To set switches on the command line, use the following command:

({ {+|-|/}s }...)

To set switches using COBSW use the following command:

SET COBSW={ {+|-|/}switch }...

where:

{ | } | Choose one of the items either side of the |.
{ }... | You can repeat this item.
switch | Either a programmable switch with a digit in the range 0 through 8, or a run-time switch with an upper-case or lower-case letter. A letter is equivalent to the same letter followed by the digit 0. For example B, B0, b, b0 all refer to the same switch.
+ | Sets the switch on.
- | Sets the switch off.

Notes

  • Switches can be separated by spaces (but this is not required); however, there must not be a space between the sign ("+" or "-") and its associated switch
  • Switches can be specified in any order, but each programmable or alphabetic switch must be preceded by a sign
  • Individual switches can be set more than once, but the last setting of any particular switch is the one accepted by the system
  • Switches remain set when COBOL subprograms are called
  • Switches set on the command line take precedence over those defined in the COBSW environment variable
  • Switches are case sensitive
Parent topic: Run-time Switches


List of General Run-time Switches

Restriction: These switches are supported for native COBOL only.
  • 0, 1, 2, 3, 4, 5, 6, 7 and 8 run-time switches
    Sets the corresponding COBOL switch when the program is entered.
  • A run-time switch
    Starts the debugger to debug an application which is either invoked using the cobrun command or dynamically loaded by a linked module.
  • A1 run-time switch
    Disables the display of trailing spaces by causing DISPLAY ... UPON CONSOLE statements to strip off any trailing spaces in the data item being displayed before outputting the data to the screen.
  • B, B1 run-time switches
    Causes the record pointer to be updated past any locked record encountered when using the READ NEXT statement.
  • C4 run-time switch
    Forces the screen in 43-line mode on an EGA or VGA monitor, or with the COBOL Text Window.
  • C5 run-time switch
    Forces the screen in 50-line mode on an EGA or VGA monitor, or with the COBOL Text Window.
  • D run-time switch
    Invokes the standard ANSI COBOL Debug module.
  • d run-time switch
    Specifies the amount of memory in bytes to be used for the run-time system dynamic paging buffers.
  • E run-time switch
    Enables the execution of intermediate code which contains S-level syntax-check errors.
  • F run-time switch
    Checks all numeric items for valid numeric data.
  • I2 run-time switch
    Redirects run-time system errors to STDERR.
  • l run-time switch
    Enables you to set the maximum amount of memory to be made available to the run-time system, or to cause the run-time system to perform physical cancels instead of logical cancels.
  • L1 run-time switch
    Disables the interactive popup window that appears when an exception error occurs.
  • L2 run-time switch
    Determines the character(s) to be used as the record terminator when reading a line sequential file.
  • N run-time switch
    Enables null insertion for all line sequential files in your program.
  • S5 run-time switch
    Enables redirectable console I/O.
  • T run-time switch
    Enables insertion of tab characters in all line sequential files.
  • Z run-time switch
    Enables conversion of double-byte character set (DBCS) spaces to ASCII spaces when reading a line sequential file or input from the console.
  • List of Run-time Switches for OO Programs
  • Key to Run-time Switches
Parent topic: Run-time Switches


0, 1, 2, 3, 4, 5, 6, 7 and 8 run-time switches

Sets the corresponding COBOL switch when the program is entered.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | All off
Type: | General

Comments:

These switches enable the COBOL switches 0-8 that you defined in the Special-Names paragraph of your program. You can specify these switches in any order, but each individual switch must be preceded by a sign.

Parent topic: List of General Run-time Switches
Related concepts
Application Configuration
Configuration Section
The Special-Names Paragraph
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


A run-time switch

Starts the debugger to debug an application which is either invoked using the cobrun command or dynamically loaded by a linked module.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | General

Comments:

If you want to debug an application created by the cob command directly, you can use the anim command. If you use anim there is no need to set this switch.

If this switch is on, the debugger checks the DISPLAY environment variable. If DISPLAY is set, it attempts to open a new X window at the location specified in the DISPLAY environment variable; otherwise it uses the current terminal.

Parent topic: List of General Run-time Switches


A1 run-time switch

Disables the display of trailing spaces by causing DISPLAY ... UPON CONSOLE statements to strip off any trailing spaces in the data item being displayed before outputting the data to the screen.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | General

Comments:

This switch provides compatibility with earlier COBOL systems from Micro Focus. When this switch is off, the trailing spaces are included in the display, as required by the ANSI COBOL Standard.

Parent topic: List of General Run-time Switches
Related reference
The File Control Entry
Data Description Entry Skeleton
The USAGE Clause
Screen Section Entry Skeleton
The USAGE Clause in the Screen Section
The DISPLAY Statement
Related information
List of Run-time Switches for OO Programs
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


B, B1 run-time switches

Causes the record pointer to be updated past any locked record encountered when using the READ NEXT statement.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | File handling

Comments:

Set the B switch for indexed sequential files open INPUT or I-O. Set the B1 switch for indexed sequential files open INPUT. Setting either of these switches permits a file to be sequentially read, even if another process has records locked in that file.

A file status of "locked record" is returned when a locked record is read when the B switch is set; a file status of "00" is returned when a locked record is read when the B1 switch is set.

Note: This switch also affects relative and record sequential files when your program is compiled with the CALLFH directive set.
Parent topic: List of General Run-time Switches
Related reference
CALLFH
The OPEN Statement
The SORT Statement
The USE Statement
XML Syntax - OPEN Statement
The File Control Entry
The READ Statement
XML Syntax - READ Statement
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


C4 run-time switch

Forces the screen in 43-line mode on an EGA or VGA monitor, or with the COBOL Text Window.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | General

Comments:

The original screen mode is restored upon return to the operating system.

Setting this switch causes the components to start in 43-line mode.

Parent topic: List of General Run-time Switches
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


C5 run-time switch

Forces the screen in 50-line mode on an EGA or VGA monitor, or with the COBOL Text Window.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | General

Comments:

The original screen mode is restored upon return to the operating system.

Setting this switch causes the components to start in 50-line mode.

Parent topic: List of General Run-time Switches
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


D run-time switch

Invokes the standard ANSI COBOL Debug module.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | General

Comments:

This switch must be set on the command line.

Example:

The following command loads the program Myprog with the standard ANSI COBOL Debug module invoked:

myprog (+D)
Parent topic: List of General Run-time Switches
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


d run-time switch

Specifies the amount of memory in bytes to be used for the run-time system dynamic paging buffers.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | -d245760 (240 K)
Type: | General

Comments:

Dynamic paging is used by programs such as the Compiler. By increasing the amount of memory you might be able to improve the performance of such programs. Once the amount of memory allocated for dynamic paging is exceeded, the run-time system pages any further requirements onto disk.

For example, when compiling a large COBOL program, the amount of memory for dynamic paging buffers might be exceeded due to the Compiler requiring a large amount of dictionary to store the symbol table it creates. When the dynamic paging buffer space is exhausted, the run-time system starts to page dynamic accesses to disk, which might have a performance overhead. By raising the amount of memory for dynamic buffering, paging to disk can be avoided (or at least reduced) and therefore better Compiler performance achieved.

Example:

To double the amount of memory (to 500k) the run-time system could use before paging to disk, you would set the COBSW environment variable as follows:

COBSW=-d500000
Parent topic: List of General Run-time Switches
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


E run-time switch

Enables the execution of intermediate code which contains S-level syntax-check errors.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | General

Comments:

If you try to run intermediate code programs which contain S-level Compiler errors when this switch is set to off, you receive a run-time system error.

Parent topic: List of General Run-time Switches
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


F run-time switch

Checks all numeric items for valid numeric data.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | On
Type: | General

Comments:

If the data is not valid, run-time system error 163 ("Illegal character in numeric field") is produced. Setting this switch to off suppresses this checking.

This checking is only done on generated code created with the CHECKNUM Compiler directive, and on intermediate code.

The run-time system and generated code try to optimize many types of numeric operations. These operations can cause invalid results if the numeric operands do not contain valid numeric data. By default, the run-time system gives the run-time system error 163 when a numeric operation is tried with invalid numeric data.

Invalid data is handled differently by intermediate and native code. We recommend that you enable numeric field checking while you are developing your program.

If you receive run-time error 163, we recommend that you adjust your code so that no invalid data is used. You can locate the invalid numeric data in your code by setting the +F switch on and then animating your program until run-time system error 163 is detected.

If you are not able to correct your code, you might want to use one or more of the following Compiler directives to resolve invalid data in numeric fields:

  • HOSTSIGNS - enables arithmetic with COMP-3 items that have illegal sign nibbles to produce the desired result.
  • HOSTNUMCOMPARE - controls the operation of comparisons between integer numeric data items of USAGE DISPLAY and alphanumeric literals or figurative constants. You can set the ZWB Compiler directive with HOST-NUMCOMPARE to affect comparisons involving signed and unsigned data items. These directives emulate mainframe behavior, so you do not need to change your data.
  • HOSTNUMMOVE - causes the Compiler to switch off checking for illegal characters in numeric fields during the execution of certain MOVE statements. (Use with care.)
  • SIGN-FIXUP - provides limited emulation of mainframe compiler options NUMPROC(NOPFD) and NUMPROC(PFD) for MOVE and COMPARE statements if you also set HOSTNUMCOMPARE or HOSTNUMMOVE.
  • SPZERO - causes space characters in numeric data items of USAGE DISPLAY to be treated as zeros.

Example:

working-storage section.
    01 item-a       pic 9.
procedure division.
    If item-a =  0.
        Display "zero"
    else
        display "nonzero"
    end-if.

The variable item-a is not initialized by a VALUE clause, and so contains a space character x"20". Running this program with the F switch set on causes the run-time system to check whether the numeric field contains a non-numeric value resulting in run-time error 163.

Parent topic: List of General Run-time Switches
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


I2 run-time switch

Redirects run-time system errors to STDERR.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | General

Comments:

The I2 switch is enabled only when used in conjunction with the +S5 switch.

If set off, run-time system error messages are sent to STDOUT (standard output). If set on, the error messages are sent to STDERR (standard error).

This switch has no effect when running under Windows.

Parent topic: List of General Run-time Switches
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


l run-time switch

Enables you to set the maximum amount of memory to be made available to the run-time system, or to cause the run-time system to perform physical cancels instead of logical cancels.
Note: Restriction:

These switches are supported for native COBOL only.

Properties:

Default: | The maximum number of bytes available to the run-time system.
Type: | General

Comments:

This switch is lower-case "L", not upper-case "I".

The format of this switch is lnnnnnn, where nnnnnn is the amount of memory in bytes to be made available to the run-time system.

You can use this switch to limit the amount of memory the run-time system will use. This might be useful to enable you to tune your system.

By default the run-time system performs logical cancels unless all available memory has been used up. As far as your programs are concerned, the behavior of logical and physical cancels is identical, but logical cancels are faster. A logical cancel flushes all file buffers but does not release any memory. To force all cancels to be physical, you must specify this switch with parameter zero; for example:

+l0

By default, when the run-time system requires memory space it checks that the new request does not exceed the available memory. If it does, the memory that should have been freed by any cancels is freed and the run-time system repeats its request for memory. The run-time system loads programs that have been logically canceled in preference to reloading from disk.

Statically linked COBOL programs cannot be physically canceled because they cannot be removed from memory.

Duplicate entry point names are not allowed in statically linked programs; you must ensure that all such programs have unique entry point names.

Logical cancels behave in the same way as these physical cancels under statically linked programs. Therefore, an application developed using .int and .gnt files with logical cancels should exhibit the same behavior when generated as object code files and statically linked. However, if you used physical cancels and duplicated entry point names while developing the application, the application might fail to static link.

Parent topic: List of General Run-time Switches
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview
default_cancel_mode


L1 run-time switch

Disables the interactive popup window that appears when an exception error occurs.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | General

Comments:

Instead of the interactive popup window, a general Windows error message is displayed and control is returned to the operating system without any user intervention.

Parent topic: List of General Run-time Switches
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


L2 run-time switch

Determines the character(s) to be used as the record terminator when reading a line sequential file.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | File handling

Comments:

When off (-L2), x"0A" is taken as the record terminator.

When on (+L2), x"0D0A" is taken as the record terminator. This provides compatibility with earlier versions of this system, correctly reading files written using a WRITE ... AFTER ADVANCING statement.

This switch only affects read operations and not write operations.

Use of the +L2 switch is in many respects unnecessary for the majority of applications. The File Handler is able to recognize line sequential delimiters for data files created on either Windows or UNIX systems, irrespective of the platform on which the files are processed. Using this method to change the delimiters will not result in the user record area ever containing x'0D' characters (unless escaped using the INSERTNULL option) because these are discarded as noise characters by the File Handler. This is in contrast to OCDS behavior.

Parent topic: List of General Run-time Switches
Related reference
The WRITE Statement
XML Syntax - WRITE Statement
Related information
List of Run-time Switches for OO Programs
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


N run-time switch

Enables null insertion for all line sequential files in your program.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | On
Type: | File handling

Comments:

This switch is especially useful if the format of your files is incompatible with this COBOL system.

Setting this switch to on means that when a program writes records to a line sequential file with a record containing control characters (that is, all characters with ASCII codes less than or equal to x"1F"), the system adds a null character (x"00") before each control character. Similarly, on reading a record from a line sequential file, these null characters are stripped from the control characters.

Setting this switch affects only the physical storage of data in a line sequential file. Records written with one setting and read back with the same setting are returned in exactly the same way. However, if you try to read a file with one setting which was written with the other setting, the results are unpredictable.

Setting this switch off enables control characters to be written and read in the same way as other characters.

When the N switch is on:

  • Any character is allowed in the data record of a line sequential file.
  • Each record is examined before it is written. All characters whose value is less than or equal to x"1F" are written with a preceding null (x"00") to form two-byte pairs. On output to disk, trailing spaces are removed, and a record terminator of x"0D0A" is appended to terminate the record.
  • The file is read as records, some of which might contain two-byte pairs where the first byte is null. The records are terminated by a record terminator. The leading null of each two-byte pair is removed to give the final data record. Tabs (x"09") that do not form part of a two-byte pair are expanded.

The File Handler configuration option INSERTNULL takes precedence over the N run-time switch:

Note: Control characters depend on the operating system. Their hexadecimal values are always less than x"1F". CR (x"0D"), LF (x"0A"), TAB (x"09"), NUL (x"00"), and EOF (x"1A") are all recognized control characters on Windows.

When the N switch is off:

  • Data records in a line sequential file must contain only ASCII text characters (those with a value greater than x"1F").
  • Trailing spaces are removed on output to disk, and a record terminator of x"0D0A" is appended to terminate the record. Printer control characters might also be written to disk.
  • The file is read as data records with each record terminated by a record terminator. If the data contains either x"0D" or x"0A", results can be unpredictable. Tab characters (x"09") are expanded to spaces; otherwise the data record is returned intact.

Example:

The command:

a:myprog (-n)

loads the program Myprog from drive a:. It also specifies that, in line sequential files, all characters less than or equal to x"1F", except for Tab and the file control characters, are treated as data. Null is not inserted before data characters less than x"1F" on output.

Parent topic: List of General Run-time Switches
Related reference
EXPANDTAB
INSERTNULL
EXPANDTAB
Related information
List of Run-time Switches for OO Programs
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


S5 run-time switch

Enables redirectable console I/O.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | General

Comments:

This function is achieved by the run-time system forcing all ACCEPT FROM/DISPLAY UPON CONSOLE statements to be executed such that I/O to and from the screen and keyboard can be redirected by using the > and < operators on the operating system command line.

Parent topic: List of General Run-time Switches
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview
Introduction to Run-time Switches
Run-time Switches for OO Programs
Key to Run-time Switches
Run-time Tunables
The ACCEPT Statement
ALTER and ACCEPT Statement Restrictions
The File Control Entry
Data Description Entry Skeleton
The USAGE Clause
Screen Section Entry Skeleton
The USAGE Clause in the Screen Section
The DISPLAY Statement
I2 run-time switch


T run-time switch

Enables insertion of tab characters in all line sequential files.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | File handling

Comments:

This switch is especially useful if the format of your files is incompatible with this COBOL system.

On output to disk, multiple spaces before a tab stop position are written as one tab character. The T switch does not affect any trailing spaces as these are not part of the line sequential record, and they are removed on output. Tab positions are every 8 character positions (for example, 9, 17, 25) and cannot be changed.

On input, tab characters are always expanded to spaces to the next position, regardless of the setting of the T switch.

With this switch set to off, all spaces in a line sequential file are written to disk as space characters.

Parent topic: List of General Run-time Switches
Related reference
Trailing Blanks in Line Sequential Files
EXPANDTAB
Related information
List of Run-time Switches for OO Programs
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


Z run-time switch

Enables conversion of double-byte character set (DBCS) spaces to ASCII spaces when reading a line sequential file or input from the console.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | General

Comments:

DBCS spaces such as x"8140" for Shift-JIS and x"A1A1" for EUC in Japanese environments are converted to ASCII spaces x"2020".

Parent topic: List of General Run-time Switches


List of Run-time Switches for OO Programs

Restriction: These switches are supported for native COBOL only.

To set OO run-time switches, use the environment variable OOSW. For example, the following turns off the v switch and turns on the d switch:

set oosw=-v+d
  • d OO run-time switch
    Enables debugging by preventing reuse of object handles from finalized objects.
  • f OO run-time switch
    Enables you to name the message trace file.
  • g1 OO run-time switch
    Sets a guard page before Object-Storage sections
  • g2 OO run-time switch
    Sets a guard page after Object-Storage sections.
  • l OO run-time switch
    Sets the Class Library to be preloaded by the run-time system.
  • t OO run-time switch
    Generate a trace file showing every message sent by your application.
Parent topic: List of General Run-time Switches


d OO run-time switch

Enables debugging by preventing reuse of object handles from finalized objects.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | OO

Comments:

In normal operation, each time an object is finalized its object handle is available for reuse by the run-time system and can be assigned when a new object is created. Setting +d prevents the run-time system from reallocating object handles.

Do not use this switch for production applications – the run-time system can eventually run out of memory to allocate new handles.

Parent topic: List of Run-time Switches for OO Programs
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


f OO run-time switch

Enables you to name the message trace file.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | OO

Comments:

The format of the switch is:

ftrace.log

where trace.log is the name of the message trace file. The default trace filename is trace.log.

Parent topic: List of Run-time Switches for OO Programs
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


g1 OO run-time switch

Sets a guard page before Object-Storage sections
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | OO

Comments:

You can't set +g1+g2.

Parent topic: List of Run-time Switches for OO Programs
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


g2 OO run-time switch

Sets a guard page after Object-Storage sections.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | OO

Comments:

You can't set +g1+g2.

Parent topic: List of Run-time Switches for OO Programs
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


l OO run-time switch

Sets the Class Library to be preloaded by the run-time system.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | On
Type: | OO

Comments:

The format of this switch is:

lclass

where class is the name of the class that you want pre-loaded.

Set this switch off to disable loading of the Class Library. You should do this if you want to debug the class library.

If you have your own class library in a .lbr file, you can load that instead of the Micro Focus Class Library. Set:

+lfilename

where filename is the name of the .dll file.

You can load more than one class library with the +l switch; separate the names with semicolons (;). For example:

+lclass1;class2

Do not leave any spaces between the names.

Parent topic: List of Run-time Switches for OO Programs
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


t OO run-time switch

Generate a trace file showing every message sent by your application.
Restriction: These switches are supported for native COBOL only.

Properties:

Default: | Off
Type: | OO

Comments:

The trace file is named trace.log by default. You can specify a name for the file with the f switch.

The trace file shows you the messages sent by your application and is useful for debugging. Do not set this switch when running production applications – trace slows down execution, and the log file grows in size continuously while the application runs.

Parent topic: List of Run-time Switches for OO Programs
Related information
Setting Run-time Switches
Run-time Switches
Run-time Configuration Tunables - Overview


Key to Run-time Switches

Restriction: These switches are supported for native COBOL only.

The following information is shown for each switch:

Function:

The function that the switch performs.

Properties:

Default: The default setting of the switch.
Type: Indicates how you set the switch. The type can be:
  • General. Set on the command line or using the environment variable COBSW.
  • OO. Set using the environment variable OOSW.
  • File handling. Set in the file handler configuration file extfh.cfg

Comments:

Additional information about the switch.

Parent topic: List of General Run-time Switches


Run-time Tunables

You can use run-time tunables to control the behavior of a program. Run-time tunables are stored in a run-time configuration file.

  • Run-time Configuration Tunables - Overview
  • Format of a Configuration File for Native COBOL
  • List of Run-time Tunables
Parent topic: Run-time System Configuration


Run-time Configuration Tunables - Overview

You normally configure your run-time system using a project's properties in the IDE. However, some run-time behavior cannot be configured using the IDE; this must be configured using run-time tunables, which are stored in a run-time configuration file.

These run-time IDE settings can be saved in a file called <configuration name>.gcf which may be created automatically when a project is built.

When your run-time system or linked executable starts up, it attempts to read the run-time configuration file. The run-time configuration file specifies values for the run-time tunables.

If a setting specified in the IDE conflicts with a setting in the configuration file, the setting specified in the IDE takes precedence.

If you use the Interface Mapping Toolkit to generate COBOL services for execution in Enterprise Server, you can specify settings for some tunables for the application container, a version of the run-time system used in Enterprise Server. If a setting specified by the Interface Mapping Toolkit conflicts with a setting in the configuration file, the setting specified in the Interface Mapping Toolkit always takes precedence.

The run-time configuration file is shared by all users of the run-time system.

For native COBOL, you create or edit the run-time configuration file with a text editor, and then specify the location and name of the run-time configuration file using the COBCONFIG_ environment variable.

For example, if you want to use a configuration file called myconf.cfg , you set COBCONFIG_ as follows.

set COBCONFIG_=e:\mydir\myconf.cfg

The use of a configuration file is optional - no error is issued if it does not exist.

Parent topic: Run-time Tunables
Related information
To add a configuration file


Format of a Configuration File for Native COBOL

The configuration file conforms to this format:

  • Each run-time tunable appears on a new line.
  • Blank lines are ignored.
  • A comment line starts with a # character. However, as the configuration file is processed at run-time, we advise that you limit the number of comments, in order to keep to a minimum the time taken to process the configuration file.
  • The maximum number of characters permitted in a comment line is 80, including any new-line or carriage return characters that might be placed at the end of the line by some editors.
  • Each space in the definition can be replaced with tabs or more than one space. For example:
    setenv dd_MYFILE /usr/mydir/myfile
set cobconfig_error_report=TRUE

The format of each tunable is:

set configurable_name=value
where:
configurable_name
The name of the run-time tunable .
value
The value to be assigned to the run-time tunable.

Where value is numeric, a leading zero indicates that the value should be treated as octal (that is, base 8). For example, 07 (octal) is 7 (decimal), while 010 (octal) is 8 (decimal); however, 08 (octal) and 09 (octal) are invalid octal values. Hexadecimal values can also be set by using numeric values that begin with with 0x.

Parent topic: Run-time Tunables


List of Run-time Tunables

Restriction: These tunables are supported for native COBOL only.
  • ansi_input_mode
    Specifies whether the run-time system uses ANSI or OEM character sets when inputting keystrokes from a console or Application Output window.
  • arguments_are_initial
    Affects the COBOL command line arguments returned from the syntax ACCEPT ... FROM ARGUMENT-NUMBER and ACCEPT ... FROM ARGUMENT-VALUE.
  • cobconfig_error_report
    Specifies whether any errors detected during the processing of the configuration file are reported.
  • command_line_accept
    Specifies whether the first ACCEPT or READ from STDIN takes the input from the command line.
  • command_line_linkage
    Enables you to call a program and pass the command line to the main program as a parameter to be accessed via the Linkage Section.
  • core_filename
    Specifies the name of the file that is generated when the core_on_error tunable is set to 3.
  • core_on_error
    Specifies in what circumstances a core file is produced.
  • current_day
    Specifies the day of the month required to be returned when the ACCEPT identifier FROM DATE syntax or the CURRENT-DATE intrinsic function is used.
  • current_hour
    Specifies the hour of the day that is to be returned when the ACCEPT identifier FROM TIME syntax or the CURRENT-DATE intrinsic function is used.
  • current_minute
    Specifies the minute of the hour that is to be returned when the ACCEPT identifier FROM TIME syntax or the CURRENT-DATE intrinsic function is used.
  • current_month
    Specifies the month of the year required to be returned when the ACCEPT identifier FROM DATE syntax or the CURRENT-DATE intrinsic function is used.
  • current_second
    Specifes the second of the minute that is to be returned when the ACCEPT identifier FROM TIME syntax or the CURRENT-DATE intrinsic function is used.
  • current_year
    Specifies the year required to be returned when the ACCEPT identifier FROM DATE syntax or the CURRENT-DATE intrinsic function is used.
  • datewarp_dynamic
    Specifies whether the day, month, and year values specified by the current_day, current_month, and current_year tunables return static or "rolling" values.
  • debug_on_error
    Specifies whether to enable just-in-time debugging.
  • default_cancel_mode
    Specifies whether logical or physical cancels are used.
  • device_name_detection
    Specifies whether programs can use filenames that are normally reserved for device-names.
  • entry_point_mapper
    Specifies whether entry point mapper support is to be enabled.
  • entry_point_mapper_alias_exists_error
    Specifies whether the Entry Point Mapping facility causes a run-time system error COBRT198 ("Load failure") when a program with the same name as an alias definition is found on disk, or whether the aliasing occurs without loading the program with the same name from disk.
  • entry_point_mapper_search_order
    Specifies whether to use entry point mapping to look for programs before or after searching for the programs on disk.
  • environment_mapper
    Specifies whether the External File Mapper is enabled. The External File Mapper allows you to assign values to environment variables in a file. If the External File Mapper is enabled the system searches for the file mfextmap.dat.
  • error_on_duplicate_entry_point
    Controls whether an RTS 119 error is generated when an attempt is made to load a program containing a duplicate entry-point.
  • faultfind_config
    Controls the inclusion of program memory data in the Faultfinder output file.
  • faultfind_level
    Specifies whether FaultFinder is enabled. FaultFinder enables you to get information on unexpected program termination at run time.
  • faultfind_outfile
    Specifies the file to which a FaultFinder report is written.
  • faultfind_recsize
    Specifies the internal cache size used to store FaultFinder trace operations.
  • lock_mode
    Selects the locking implementation to be used.
  • mainframe_floating_point
    Specifies whether mainframe floating-point emulation is required.
  • memory_free_check_size
    Specifies the number of freed memory blocks that are to be monitored for subsequent corruption.
  • memory_strategy
    Sets a memory management strategy.
  • mfpm_access_cancelled_data
    Specifies whether the Working-Storage Sections of AMODE programs that have been canceled continue to be addressable.
  • mfpm_external_data31
    Specifies whether external data items are registered with Mainframe Pointer Manager (MFPM) above or below the 16 Mb line.
  • mfpm_logging
    Specifies whether Mainframe Pointer Manager (MFPM) events are to be traced.
  • no_mfredir
    Enables you to reduce the time the run-time system takes to initialize if your project or application does not execute remote programs.
  • os_error_log
    Specifies whether an event is written to the Windows Application Event log whenever run-time system error COBRT199 occurs.
  • printer_redirection
    Redirects WRITE statements through the Windows print spooler.
  • profile_behavior
    Specifies the behavior of the Profiler with regard to the counting of time spent in called programs.
  • program_search_intgnt
    Changes the position of file extensions in the program search order in which the run-time system searches for program files.
  • program_search_order
    Changes the order of locations in which the run-time system searches for program files.
  • screen_cols
    Specifies the initial width of the Application Output window or console.
  • screen_lines
    Specifies the initial height of the Application Output window or console.
  • shared_memory_segment_size
    Specifies the initial size of the shared memory block allocated by the run-time system.
  • signal_regime
    Specifies whether or not the run-time system is to use its own signal handlers.
  • strictvsam
    Specifies strict mainframe emulation during file processing of VSAM files.
  • subsystem_cancel_mode
    Specifies whether logical or physical cancels are used for CBL_SUBSYSTEM cancels.
  • timewarp_dynamic
    Specifies whether the hours, minutes, and seconds values specified by the current_hour, current_minute, and current_second tunables return static or "rolling" values.
Parent topic: Run-time Tunables


ansi_input_mode

Specifies whether the run-time system uses ANSI or OEM character sets when inputting keystrokes from a console or Application Output window.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set ansi_input_mode=----.-TRUE-.---------><
                               +-FALSE+

Parameters:

TRUE | Use the ANSI character set to input keystrokes
FALSE | Use the OEM character set to input keystrokes

Properties:

Default: | FALSE
IDE equivalent: | None

Comments:

Using ANSI enables characters such as the Euro symbol, which does not exist in the OEM character set, to be input and displayed.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


arguments_are_initial

Affects the COBOL command line arguments returned from the syntax ACCEPT ... FROM ARGUMENT-NUMBER and ACCEPT ... FROM ARGUMENT-VALUE.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set arguments_are_initial=---.-TRUE-.-------------><
                                    +-FALSE+

Parameters:

TRUE | The COBOL command line arguments are the same as the initial ones passed to the run-unit by the operating system. When using a trigger, such as run , argument 0 is the trigger name and argument 1 is the name of the main COBOL program.
FALSE | The COBOL command line arguments do not contain any trigger name. Instead, argument 0 is always the name of the main COBOL program. When set to FALSE this tunable gives consistent results no matter how your application is packaged.

Properties:

Default: | FALSE
IDE equivalent: | None Service > Settings > Enterprise Server Run-time Configuration > Program Execution > Return trigger executable name as argument zero

Comments:

See the Language Reference for more details of the ACCEPT ... FROM ARGUMENT-NUMBER and ACCEPT ... FROM ARGUMENT-VALUE syntax.

If you are using a system executable to start your application, argument 0 is always the name of the executable (which, by default, is also the name of the main COBOL program), irrespective of the setting of this tunable.

For example, the command line:

myapp arg1 arg2

always returns myapp as argument 0, whereas the command line:

run myapp arg1 arg2

returns myapp as argument 0 when this tunable is set to FALSE; when the tunable is set to TRUE the trigger name ( run ) is returned as argument 0 and myapp as argument 1.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


cobconfig_error_report

Specifies whether any errors detected during the processing of the configuration file are reported.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set cobconfig_error_report=----.-TRUE-.----><
                                      +-FALSE+

Parameters:

TRUE | Errors are reported and result in processing of the configuration file being terminated
FALSE | Errors are not reported

Properties:

Default: | TRUE
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


command_line_accept

Specifies whether the first ACCEPT or READ from STDIN takes the input from the command line.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set command_line_accept=---.-TRUE-.-------------><
                                  +-FALSE+

Parameters:

TRUE | The first ACCEPT or READ from STDIN takes the input from the command line.
FALSE | The first ACCEPT or READ from STDIN takes the input from the user. This provides direct ANSI conformance.

Properties:

Default: | FALSE
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
command_line_linkage


command_line_linkage

Enables you to call a program and pass the command line to the main program as a parameter to be accessed via the Linkage Section.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set command_line_linkage=---.-TRUE--.------><
                                   +-FALSE-+

Parameters:

TRUE | The command line can be accessed via the Linkage Section
FALSE | The command line cannot be accessed via the Linkage Section

Properties:

Default: | FALSE
IDE equivalent: | None

Example:

When using this tunable, the command line will be passed to the main program using the following parameter structure:

Linkage section.
01 CommandLinePass.
  03 CommandLineLen   pic 9(4) comp.
  03 CommandLine      pic x(256).

CommandLineLen contains the length of the parameters being passed and CommandLine contains the actual arguments being passed.

Comments:

This run-time tunable is provided for backward compatibility only. It works only with linked executables.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
command_line_accept


current_day

Specifies the day of the month required to be returned when the ACCEPT identifier FROM DATE syntax or the CURRENT-DATE intrinsic function is used.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set current_day=---integer------><

Parameters:

integer A value in the range 1 through 31, representing the required day of the month. The value you specify is returned when you use the ACCEPT identifier FROM DATE syntax or the CURRENT-DATE intrinsic function.

Properties:

Default: | The current day specified by the system clock.
IDE equivalent: | None

Comments:

If the datewarp_dynamic tunable is set to TRUE, the day value specified is treated as the day the clock is started, and changes each time the system clock passes midnight.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
current_hour
current_minute
current_month
current_second
current_year
datewarp_dynamic
timewarp_dynamic


current_hour

Specifies the hour of the day that is to be returned when the ACCEPT identifier FROM TIME syntax or the CURRENT-DATE intrinsic function is used.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set current_hour=---integer-------------><

Parameters:

integer A value from 0 - 23 indicating the required hour of the day. The value you specify is returned when you use the ACCEPT identifier FROM TIME syntax or the CURRENT-DATE intrinsic function

Properties:

Default: | The current hour as returned by the system clock.
IDE equivalent: | None

Comments:

If the timewarp_dynamic tunable is set to TRUE, the hour value specified is treated as the hour at which the clock is started, and will change every 60 minutes.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
current_day
current_minute
current_month
current_second
current_year
datewarp_dynamic
timewarp_dynamic


current_minute

Specifies the minute of the hour that is to be returned when the ACCEPT identifier FROM TIME syntax or the CURRENT-DATE intrinsic function is used.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set current_minute=---integer-------------><

Parameters:

integer A value from 0 - 59 indicating the required minute of the hour. The value you specify is returned when you use the ACCEPT identifier FROM TIME syntax or the CURRENT-DATE intrinsic function.

Properties:

Default: | The current minute as returned by the system clock.
IDE equivalent: | None

Comments:

If the timewarp_dynamic tunable is set to TRUE, the minute value specified is treated as the minute at which the clock is started, and will change every 60 seconds.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
current_day
current_hour
current_month
current_second
current_year
datewarp_dynamic
timewarp_dynamic


current_month

Specifies the month of the year required to be returned when the ACCEPT identifier FROM DATE syntax or the CURRENT-DATE intrinsic function is used.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set current_month=---integer------><

Parameters:

integer A value in the range 1 through 12, representing the required month of the year. The value you specify is returned when you use the ACCEPT identifier FROM DATE syntax or the CURRENT-DATE intrinsic function.
Note: A leading 0 indicates to the system that the value should be treated as octal. As a result, month values of 08 and 09 generate an error. For the months of September and October, use 8 and 9 rather than 08 and 09.

Properties:

Default: | The current month specified by the system clock.
IDE equivalent: | None

Comments:

None

If the datewarp_dynamic tunable is set to TRUE, the month value specified is treated as the month the clock is started, and changes when the system clock passes midnight on the last day of each month.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
current_day
current_hour
current_minute
current_second
current_year
datewarp_dynamic
timewarp_dynamic


current_second

Specifes the second of the minute that is to be returned when the ACCEPT identifier FROM TIME syntax or the CURRENT-DATE intrinsic function is used.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set current_second=---integer-------------><

Parameters:

integer A value from 0 - 59 indicating the required second of the minute. The value you specify is returned when you use the ACCEPT identifier FROM TIME syntax or the CURRENT-DATE intrinsic function

Properties:

Default: | The current second as returned by the system clock.
IDE equivalent: | None

Comments:

If the timewarp_dynamic tunable is set to TRUE, the second value specified is treated as the second at which the clock is started, and will change as the system clock changes.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
current_day
current_hour
current_minute
current_month
current_year
datewarp_dynamic
timewarp_dynamic


current_year

Specifies the year required to be returned when the ACCEPT identifier FROM DATE syntax or the CURRENT-DATE intrinsic function is used.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set current_year=---integer------><

Parameters:

integer A value representing the required year. The value you specify is returned when you use the ACCEPT identifier FROM DATE or ACCEPT identifier FROM DAY syntax or the CURRENT-DATE intrinsic function.

Properties:

Default: | The current year specified by the system clock.
IDE equivalent: | None

Comments:

If the datewarp_dynamic tunable is set to TRUE, the year value specified is treated as the year the clock is started and changes each time midnight passes on December 31st.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
current_day
current_hour
current_minute
current_month
current_second
datewarp_dynamic
timewarp_dynamic


datewarp_dynamic

Specifies whether the day, month, and year values specified by the current_day, current_month, and current_year tunables return static or "rolling" values.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set datewarp_dynamic=---.-TRUE-.-------------><
                               +-FALSE+

Parameters:

TRUE | The day, month, and year values specified for the current_day, current_month and current_year tunables are treated as the clock start values and will "roll" once they have been set.
FALSE | The day, month, and year values specified for the current_day, current_month, and current_year tunables are static values that will always be returned when the ACCEPT identifier FROM DATE syntax or the CURRENT-DATE intrinsic function is used.

Properties:

Default: | FALSE
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
current_day
current_hour
current_minute
current_month
current_second
current_year
timewarp_dynamic


debug_on_error

Specifies whether to enable just-in-time debugging.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set debug_on_error=---.-0-.-----------><
                             +-1-+

Parameters:

0 | Disables just-in-time debugging.
1 | Enables just-in-time debugging: the Debugger starts if a running program terminates with a run-time system error.

Properties:

Default: | 0
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
core_on_error
signal_regime


default_cancel_mode

Specifies whether logical or physical cancels are used.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set default_cancel_mode---.-0-.-----------><
                                 +-1-+

Parameters:

0 | Physical cancels: any program canceled during run time will be freed from memory, making more memory available.
1 | Logical cancels: any program canceled during run time will not be freed from memory. The program is available to be reused and hence the performance of CALL/CANCEL statements is greatly increased.

As far as your program is concerned, the behavior of logical and real cancels is identical.

Properties:

Default
1
IDE equivalent
None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


device_name_detection

Specifies whether programs can use filenames that are normally reserved for device-names.
Note: Restriction:

These tunables are supported for native COBOL only.

Syntax:

>>-----set device_name_detection=---.-TRUE-.------><
                                    +-FALSE+

Parameters:

TRUE | The run-time system treats certain predefined names (such as ERR) as device-names.
FALSE | No predefined device-names are used by the run-time system.

Properties:

Default: | TRUE
IDE equivalent: | None

Comments:

When you set device_name_detection=TRUE, the run-time system treats the following as device-names, so they cannot be used as filenames in your programs:

  • :BB
  • :CE
  • :CI
  • :CO
  • :LP
  • AUX
  • COM<n>
  • CON
  • ERR
  • LPT
  • LPT<n>
  • LST
  • NUL
  • PRN
  • PUN
  • RDR
  • STDERR
  • STDIN
  • STDOUT
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


entry_point_mapper

Specifies whether entry point mapper support is to be enabled.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set entry_point_mapper=---.-TRUE-.-------------><
                                 +-FALSE+

Parameters:

TRUE | Enable entry point mapper support.
FALSE | Disable entry point mapper support.

Properties:

Default: | FALSE
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related concepts
Entry Point Mapping for COBOL Programs
Related tasks
Run-time Configuration Tunables - Overview
Related reference
entry_point_mapper_alias_exists_error
entry_point_mapper_search_order


entry_point_mapper_alias_exists_error

Specifies whether the Entry Point Mapping facility causes a run-time system error COBRT198 ("Load failure") when a program with the same name as an alias definition is found on disk, or whether the aliasing occurs without loading the program with the same name from disk.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set entry_point_mapper_alias_exists_error=---.-TRUE-.-------------><
                                                    +-FALSE+

Parameters:

TRUE | Run-time system error COBRT198 occurs when a program with the same name as an alias definition occurs on disk.
FALSE | Aliasing occurs without loading the program with the same name from disk.

Properties:

Default: | TRUE
IDE equivalent: | None

Comments:

This tunable is only relevant if the entry_point_mapper_search_order tunable is set to 1; that is, pre-disk searching is enabled.

Parent topic: List of Run-time Tunables
Related concepts
Entry Point Mapping for COBOL Programs
Related tasks
Run-time Configuration Tunables - Overview
Related reference
entry_point_mapper
entry_point_mapper_search_order


entry_point_mapper_search_order

Specifies whether to use entry point mapping to look for programs before or after searching for the programs on disk.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set entry_point_mapper_search_order=---.-0-.-----------><
                                              +-1-+

Parameters:

0 | Programs are looked for on disk before using entry point mapping.
1 | Programs are looked for using entry point mapping before looking on disk.

Properties:

Default: | 0
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related concepts
Entry Point Mapping for COBOL Programs
Related tasks
Run-time Configuration Tunables - Overview
Related reference
entry_point_mapper
entry_point_mapper_alias_exists_error


environment_mapper

Specifies whether the External File Mapper is enabled. The External File Mapper allows you to assign values to environment variables in a file. If the External File Mapper is enabled the system searches for the file mfextmap.dat.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set environment_mapper=---.-TRUE-.-------><
                                 +-FALSE+

Parameters:

TRUE | The External File Mapper is enabled
FALSE | The External File Mapper is not enabled.

Properties:

Default: | FALSE
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


error_on_duplicate_entry_point

Controls whether an RTS 119 error is generated when an attempt is made to load a program containing a duplicate entry-point.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set error_on_duplicate_entry_point =---.-TRUE-.------><
                                              +-FALSE+

Parameters:

TRUE | Force an RTS 119 error to be generated when loading a duplicate entry point.
FALSE | Silently ignore duplicate entry-points.

Properties:

Default: | FALSE
Setting: | None

Example:

If program A is loaded and contains entry-point ENTA, and then program B is loaded which also contains entry-point ENTA, the RTS can either issue an RTS 119 error ("Symbol redefined") when it encounters ENTA in program B, or silently ignore it.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


faultfind_config

Controls the inclusion of program memory data in the Faultfinder output file.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set faultfind_config=----integer---------><

Parameters:

integer The action to perform and the type of memory as follows:

These values can be combined to suppress combinations of types of memory, for example, a value of 5 will suppress working storage and dynamically allocated memory from being included.

0 | Include all types of memory (default)
1 | Exclude working storage
2 | Exclude thread-local storage
4 | Exclude dynamically allocated memory
Default: | 0
IDE equivalent: | None

Properties:

Default: | 0
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
faultfind_level
faultfind_outfile
faultfind_recsize
Related information
FaultFinder Tunables


faultfind_level

Specifies whether FaultFinder is enabled. FaultFinder enables you to get information on unexpected program termination at run time.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set faultfind_level=----integer---------><

Parameters:

integer Any positive value up to 100,000. Specifying this tunable turns on FaultFinder. The last integer events are dumped to a FaultFinder report if abnormal application termination occurs. The greater the value of integer, the more memory is used.

Properties:

Default: | 0 (off)
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
faultfind_config
faultfind_outfile
faultfind_recsize
Related information
FaultFinder Tunables


faultfind_outfile

Specifies the file to which a FaultFinder report is written.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set faultfind_outfile--=----"[>>]filename"----><

Parameters:

filename The file to which a FaultFinder report is written. If you specify >>, the output is appended to filename, if it already exists, otherwise a new file named filename is created. If filename contains the string %p, this string is replaced by the process ID of the program that started FaultFinder.

Properties:

Default: | fltfnd_out.pid, in the current working directory, where pid is the process ID of the process that triggered the FaultFinder output.
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
faultfind_config
faultfind_level
faultfind_recsize
Related information
FaultFinder Tunables


faultfind_recsize

Specifies the internal cache size used to store FaultFinder trace operations.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set faultfind_recsize=---rec_size--------><

Parameters:

rec_size A numeric value, in bytes, that specifies the internal cache size used to store read/write data for the operation traceback log. All read/write data is stored and reported. By using this tunable you might improve performance. The maximum value is 1024.

Properties:

Default: | 64
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
faultfind_config
faultfind_level
faultfind_outfile
Related information
FaultFinder Tunables


lock_mode

Selects the locking implementation to be used.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set lock_mode=---.-0-.-----------><
                        +-1-+
                        +-2-+

Parameters:

0 | Uses the locking mechanism provided by Micro Focus COBOL V3.1 and earlier versions.
1 | Provides compatibility with DOS and OS/2 locking mechanisms.
2 | Provides interlanguage locking. This method causes record locks to lock the physical record.

Properties:

Default: | 1
IDE equivalent: | None

Comments:

This tunable is only applicable if the File Handler configuration option FILEMAXSIZE is set to 4.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


mainframe_floating_point

Specifies whether mainframe floating-point emulation is required.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set mainframe_floating_point=---.-TRUE-.-------------><
                                       +-FALSE+

Parameters:

TRUE | Mainframe floating-point emulation is required.
FALSE | Mainframe floating-point emulation is not required.

Properties:

Default: | FALSE
IDE equivalent: | None

Comments:

Specifying this tunable has the same effect as specifying the MAINFRAME_FLOATING_POINT environment variable. If both are specified, the setting of the MAINFRAME_FLOATING_POINT environment variable overrides the setting of the mainframe_floating_point tunable.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


memory_free_check_size

Specifies the number of freed memory blocks that are to be monitored for subsequent corruption.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set memory_free_check_size=---freed-memory-blocks------><

Parameters:

freed-memory-blocks A numeric value defining the number of freed memory blocks to monitor

Properties:

Default: | 100
IDE equivalent: | None

Comments:

You should use this tunable in conjunction with the check freed memory and reuse freed memory strategies offered by the memory_strategy tunable.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
memory_strategy


memory_strategy

Sets a memory management strategy.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set memory_strategy=---strategy-specification------><

Parameters:

strategy-specification A numeric value representing one or more of the following flags (see Comments for information about valid combinations):
0x00000001
Check bytes strategy: prepend and append check bytes to each memory allocation
0x00000002
Check freed memory strategy: monitor for subsequent corruption the last n memory blocks freed, where n is the current value set using the memory_free_check_size run-time tunable
0x00000004
Reuse strategy: allow freed memory being monitored for corruption to be used to satisfy allocation requests
0x40000000
Compatibility strategy: maintain compatibility with previous versions of the run-time system
0x80000000
Validate strategy: validate memory each time an allocation or free operation occurs

Properties:

Default: | 0x00000001
IDE equivalent: | None

Comments:

You can use this tunable to enable a process to be executed with one or more memory management strategies in place. For example, to specify that each memory allocation made by the run-time system is to have check bytes prepended and appended, and that each time an allocation or free operation takes place memory is to be validated, you would set the tunable as follows:

set memory_strategy=0x80000001

Only certain combinations of strategies are valid:

  • Check bytes, check freed memory, reuse and validate can be used together in any combination.
  • Compatibility can be used only with validate.

When the check bytes memory management strategy is in place, and the run-time system receives a request to free a memory block, the run-time system checks that the check bytes have not been corrupted, and then releases the memory. A corruption occurs when a program has written past the end of another memory block into the header of this one, or a program has written past the end of this memory block. If the run-time system detects a corruption, it issues run-time system error COBRT252 indicating the memory block address and type of memory that has been corrupted, for example:

Execution error: file 'MYFILE'
error code: 252, pc=0, call=1, seg=0
252 Memory corruption detected (addr=00376068, type=136/1)

When the check freed memory strategy is in place, and the run-time system receives a request to free a memory block, the run-time system does not release the memory, but instead:

  • Clears the contents of the memory block to a predefined check value
  • Stores a reference to the block. The run-time tunable memory_free_check_size defines how many blocks the run-time system handles. If the limit has been reached, the run-time system:
    1. Validates the contents of the memory pointed to by the oldest entry stored. If the validation fails (that is, the memory does not contain the expected check value), the run-time system issues run-time system error COBRT252.
    2. Frees the memory pointed to by the oldest entry stored.

You should use the check freed memory strategy strategy with caution as it can lead to memory fragmentation and a significantly larger memory footprint for the process than would normally be expected.

You can use the reuse memory management strategy in conjunction with the check freed memory strategy to allow freed memory to be used to satisfy new allocation requests. When the reuse strategy is in effect and the run-time system needs to allocate a new block of memory, it first checks whether an area of freed memory will satisfy the allocation request. An allocation request will be satisfied from freed memory only if the size and type of the freed memory exactly match the size and type of the allocation request. When an allocation request is satisfied from freed memory, the run-time system first validates the contents of the freed memory. If the validation fails (that is, the memory does not contain the expected check value), the run-time system issues run-time system error COBRT252.

The compatibility memory strategy is provided to give compatibility with the memory management provided in earlier versions of the run-time system. If this strategy is specified, all other strategies except validation are ignored. This strategy does not perform any memory validation or tracking, and silently ignores any memory chaining errors it encounters if an attempt is made to free a memory block more than once.

The validation memory management strategy causes all memory allocations previously made by the run-time system using the check bytes memory management strategy and all freed memory to be validated each time the run-time system is requested to perform a memory allocate or free operation. Additionally, if the operating system allows it, an operating-system memory heap validation check is performed. You should use this strategy with caution since it will lead to a major performance degradation in those applications that perform a large number of memory allocate and free operations.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
memory_free_check_size


mfpm_access_cancelled_data

Specifies whether the Working-Storage Sections of AMODE programs that have been canceled continue to be addressable.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set mfpm_access_cancelled_data=---.-TRUE-.-------------><
                                         +-FALSE+

Parameters:

TRUE | The Working-Storage Sections of AMODE programs are addressable after they have been canceled.
FALSE | The Working-Storage Sections of AMODE programs are not addressable after they have been canceled.

Properties:

Default: | FALSE
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
mfpm_external_data31
mfpm_logging


mfpm_external_data31

Specifies whether external data items are registered with Mainframe Pointer Manager (MFPM) above or below the 16 Mb line.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set mfpm_external_data31=---.-TRUE-.-------------><
                                   +-FALSE+

Parameters:

TRUE | External data items are registered with Mainframe Pointer Manager above the 16 Mb line, making them addressable to only AMODE(31) programs.
FALSE | External data items are registered with Mainframe Pointer Manager below the 16 Mb line, making them addressable to both AMODE(24) and AMODE(31) programs.

Properties:

Default: | FALSE
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
mfpm_access_cancelled_data
mfpm_logging


mfpm_logging

Specifies whether Mainframe Pointer Manager (MFPM) events are to be traced.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set mfpm_logging(option)=---.-TRUE-.-------><
                                   +-FALSE+

Parameters:

option
0
Mainframe Pointer Manager events and address map are traced.
1
Mainframe Pointer Manager events are traced.
2
Mainframe Pointer Manager address map is traced.
Default: | 0
IDE equivalent: | None

Properties:

Default: | 0
IDE equivalent: | None

Comments:

Mainframe Pointer Manager logging is performed using the Consolidated Tracing Facility (CTF). Setting this tunable implicitly sets the mf.rts#mfpm Consolidated Tracing Facility property, and the Consolidated Tracing Facility trace level to "info" if not already set.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
mfpm_access_cancelled_data
mfpm_external_data31


no_mfredir

Enables you to reduce the time the run-time system takes to initialize if your project or application does not execute remote programs.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set no_mfredir=---.-TRUE-.-------------><
                         +-FALSE+

Parameters:

TRUE | The run-time system initializes without searching for the optional module _MFREDIR.
FALSE | The run-time system searches for _MFREDIR when initializing.

Properties:

Default: | FALSE
IDE equivalent: | None

Comments:

The _MFREDIR module is only required to enable remote program execution. As most applications do not require remote program execution, _MFREDIR rarely exists resulting in many unnecessary lookups being made in the folders on the application and system search paths.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


os_error_log

Specifies whether an event is written to the Windows Application Event log whenever run-time system error COBRT199 occurs.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set os_error_log=---.-TRUE-.-------------><
                           +-FALSE+

Parameters:

TRUE | An event is written to the Windows Application Event log whenever run-time system error COBRT199 occurs. This was the behavior in previous versions of this COBOL system.
FALSE | An event is not written to the Windows Application Event log whenever run-time system error COBRT199 occurs.

Properties:

Default: | FALSE
IDE equivalent: | None

Comments:

Regardless of the setting of os_error_log, a Consolidated Tracing Facility warning event can be generated whenever run-time system error COBRT199 occurs. See the help for the COBRT199 message for information on configuring Consolidated Tracing Facility to enable this.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


printer_redirection

Redirects WRITE statements through the Windows print spooler.

The following details are for native COBOL only.

Syntax:

>>-----printer_redirection=----.-TRUE-.-------><
                               +-FALSE+

Parameters:

TRUE | Redirect WRITE statements to files defined with the ASSIGN TO PRINTER syntax through the Windows print spooler, rather than sending the output directly to the printer port.
FALSE | Output is sent directly to the printer port.

Properties:

Default: | FALSE
IDE equivalent: | None

Comments:

You can also set printer redirection by calling the PC_PRINTER_REDIRECTION_PROC routine.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related information
The File Control Entry


profile_behavior

Specifies the behavior of the Profiler with regard to the counting of time spent in called programs.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set profile_behavior=---.-0-.-----------><
                               +-1-+

Parameters:

0 | Time spent in a called program is counted both in the called program and in the calling program.
1 | Time spent in a called program is counted only in the called program.

Properties:

Default: | 0
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related information
Introduction to Profiler


program_search_intgnt

Changes the position of file extensions in the program search order in which the run-time system searches for program files.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set program_search_intgnt=----.-TRUE-.--------><
                                     +-FALSE+

Parameters:

TRUE | The search order is .int, then .gnt, then .lbr
FALSE | The search order is .gnt, then .int, then .lbr

Properties:

Default: | FALSE
IDE equivalent: | None
Parent topic: List of Run-time Tunables


program_search_order

Changes the order of locations in which the run-time system searches for program files.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set program_search_order=---.-1-.-----------><
                                   +-2-+
                                   +-3-+
                                   +-4-+

Parameters:

1 Uses the following search sequence:
  1. The run-time system is checked to see if the program is loaded or statically linked. If it is, the search ends.
  2. If the COBPATH environment variable is set, the paths specified are searched in order. Otherwise, the current directory is searched. (You should not modify the COBPATH environment variable as it is used by this COBOL system.)
  3. The path in which the calling program was loaded is searched.
  4. If the COBDIR environment variable is set, the paths specified are searched in order.
2 Uses the following search sequence:
  1. The run-time system is checked to see if the program is loaded or statically linked. If it is. the search ends.
  2. The path in which the calling program was loaded is searched.
  3. If the COBPATH environment variable is set, the paths specified are searched in order. Otherwise, the current directory is searched. (You should not modify the COBPATH environment variable as it is used by this COBOL system.)
  4. If the COBDIR environment variable is set, the paths specified are searched in order.
3 Uses the following search sequence:
  1. The run-time system is checked to see if the program is loaded or statically linked. If it is. the search ends.
  2. The current directory is searched.
  3. If the COBPATH environment variable is set, the paths specified are searched in order. (You should not modify the COBPATH environment variable as it is used by this COBOL system.)
  4. If the COBDIR environment variable is set, the paths specified are searched in order.
4 Uses the following search sequence:
  1. The run-time system is checked to see if the program is loaded or statically linked. If it is. the search ends.
  2. If the COBPATH environment variable is set, the paths specified are searched in order. Otherwise, the current directory is searched. (You should not modify the COBPATH environment variable as it is used by this COBOL system.)
  3. The path in which the calling program was loaded is searched.
  4. If the COBDIR environment variable is set, the paths specified are searched in order.
  5. The current directory is searched.

Properties:

Default: | 4
IDE equivalent: | None

Comments:

Set program_search_order to 2 for compatibility with previous UNIX versions of Micro Focus COBOL, or to 3 for compatibility with previous DOS versions.

Note:

If a program is called with a specific path the search sequence is not affected by the value of program_search_order and instead:

  1. The run-time system is checked to see if the program is loaded or statically linked.
  2. The path specified in the call is searched.
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


screen_cols

Specifies the initial width of the Application Output window or console.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set screen_cols=----integer--------------><

Parameters:

integer A value in the range 0 through 132 indicating the width of the Application Output window or console.

Properties:

Default: | For console windows, the current screen width as returned by the operating system; for the Application Output window, 80.
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


screen_lines

Specifies the initial height of the Application Output window or console.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set screen_lines=----integer------------><

Parameters:

integer A value in the range 0 through 60 indicating the height of the Application Output window or console.

Properties:

Default:
  • For console windows, the current screen height as returned by the operating system
  • 25 for the Application Output window
  • 43 if COBSW=C4 is set
  • 50 if COBSW=C5 is set
IDE equivalent: None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


shared_memory_segment_size

Specifies the initial size of the shared memory block allocated by the run-time system.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set shared_memory_segment_size=---integer-----------><

Parameters:

integer Specifies the initial size of the shared memory block allocated by the run-time system, in bytes. The minimum value you can specify is 8192 (8 K).

Properties:

Default: | 65536 (64 K)
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview


signal_regime

Specifies whether or not the run-time system is to use its own signal handlers.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set signal_regime(sig)=integer---------><

or

>>-----set signal_regime=1---------><

Parameters:

sig The number of the signal, between 1 and the maximum signal number on your operating system. See your operating system documentation for details on signal numbers.
integer The action the run-time system is to take for the signal sig. integer can take one of the following values:
0 - The signal sig is used if needed
By default, the run-time system sets up signal handlers for all signals whose operating system default action would cause termination. The run-time system can thus catch these signals and tidy up (for example, close any open files to prevent file corruption) before exiting.
1 - The signal sig is used only if a handler was not already posted for this signal
This is useful if the third-party software is invoked before your COBOL system and sets up a handler for signal sig. If this tunable is not set for this signal, the run-time system overwrites the third-party software's handler with its own; this leads to unpredictable behavior, such as run-time system error COBRT115 ("Unexpected signal") being produced.

If a handler was posted, the run-time system will not post any handlers for this signal and so any run-time system functionality which relies on this signal will not work.

2 - The signal sig is used
This is only of use if the third-party software is invoked after the run-time system and sets up a handler for signal sig. Use of this setting is strongly discouraged for any signal whose operating system default action is to cause termination; if this signal is received between the run-time system being invoked and the third-party software setting up its handler, the default action of the operating system occurs, and the process exits without the run-time system being able to tidy up. This could lead to problems such as file corruption.

Any run-time system functionality which relies on this signal will not work.

Properties:

Default: | 0 for all signals
IDE equivalent: | None

Comments:

If you use the alternative syntax (set signal_regime=1), the signal regime for all signals is set to 1.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
core_on_error
debug_on_error
cobpostsighandler
cobremovesighandler
Related information
Signal Handling Overview
Third Party Software that Uses Signals


strictvsam

Specifies strict mainframe emulation during file processing of VSAM files.

Syntax:

>>---strictvsam=-.-ON---.----><
                 +-OFF--+

Parameters:

ON
File status 37 is returned when an existing VSAM file is opened for OUTPUT if:
  • the file has data or previously had data written to it.
  • the file is of a different format to the file on disk.
OFF
File status 0 is returned and a new file is created when an existing VSAM file is opened for OUTPUT.

Properties:

Default: | OFF
IDE equivalent: | None
Parent topic: List of Run-time Tunables


subsystem_cancel_mode

Specifies whether logical or physical cancels are used for CBL_SUBSYSTEM cancels.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set subsystem_cancel_mode=--.-0-.-----------><
                                   +-1-+

Parameters:

0 | Physical cancels: any program canceled with a CBL_SUBSYSTEM cancel will be freed from memory, making more memory available.
1 | Logical cancels: any program canceled with a CBL_SUBSYSTEM cancel will not be freed from memory. The programs are available to be reused and hence the performance of CALL/CANCEL statements is greatly increased.

Properties:

Default: | 0
IDE equivalent: | None

Comments:

As far as your program is concerned, the behavior of logical and physical cancels is identical.

Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
CBL_SUBSYSTEM


timewarp_dynamic

Specifies whether the hours, minutes, and seconds values specified by the current_hour, current_minute, and current_second tunables return static or "rolling" values.
Restriction: These tunables are supported for native COBOL only.

Syntax:

>>-----set timewarp_dynamic=---.-TRUE-.-------------><
                               +-FALSE+

Parameters:

TRUE | The hours, minutes, and seconds values specified for the current_hour, current_minute and current_second tunables are treated as clock start values and will "roll" once they have been set.
FALSE | The hours, minutes, and seconds values specified for the current_hour, current_minute and current_second tunables are static values that will always be returned when the ACCEPT identifier FROM TIME syntax or the CURRENT-DATE intrinsic function is used.

Properties:

Default: | FALSE
IDE equivalent: | None
Parent topic: List of Run-time Tunables
Related tasks
Run-time Configuration Tunables - Overview
Related reference
current_day
current_hour
current_minute
current_month
current_second
current_year
datewarp_dynamic


Deployment

  • Deploying Native COBOL Applications
  • Configuration and Administration
    This is the Enterprise Server Configuration and Administration help. It contains the information you need for setting up and configuring an Enterprise Server installation.
  • Mainframe Support for Deployed Applications
  • Secure Communications (SSL)
Parent topic: Micro Focus Studio Enterprise Edition 6.0


Configuration and Administration

  • Enterprise Server Configuration and Administration
  • Deploying and Configuring Modernized Applications
  • Working with Mainframe Files
  • Enterprise Server Task Index
  • Enterprise Server Reference
    Contains information on Enterprise Server configuration commands, error messages, user exits and switching modules.
  • Reference for MSS Deployment
    Contains information on general and CICS commands, data conversion, resource definitions, and supplied transactions.
  • Enterprise Server Security
Parent topic: Deployment


Enterprise Server Configuration and Administration

This section describes the processes for setting up, configuring, and maintaining an Enterprise Server installation. The information it contains relates to both COBOL systems running as services, and mainframe subsystems that operate in an Enterprise Server environment.

  • Overview and Architecture
  • Configuration and Administration User Interface
  • Planning your Configuration
  • Configuring the Server Instance Environment
  • Configuring and Administering Enterprise Server Instances
  • Configuring Client-Server Communications
  • Monitoring Enterprise Server
  • User Exits for Request Handlers
  • Troubleshooting
  • Enterprise Server Administration Console Help Pages
Parent topic: Configuration and Administration


Overview and Architecture

This section provides an overview of an Enterprise Server installation and its components, and describes the architecture.

  • Enterprise Server Overview
  • Enterprise Server Architecture
  • enterprise server instance Architecture
  • The Micro Focus Directory Server
  • Service Execution Process (SEP)
  • Request Handlers
  • Communications Processes
  • Listeners
  • Implementation Packages
  • XA Resources
  • Enterprise Server Processes
Parent topic: Enterprise Server Configuration and Administration


Enterprise Server Overview

Enterprise Server provides an execution environment for COBOL application programs. Within an Enterprise Server, you can operate a number of enterprise server instances. enterprise server instances provide session and state management for COBOL applications, as well as optionally interfacing with external resource managers to coordinate resource updates.

The type of applications you can run on an Enterprise Server installation fall into the following categories:

  • COBOL applications running as services

    A service can contain a number of operations. Clients that use these operations supply the required input, and the service returns the results.

  • CICS regions

    In an Enterprise Server environment, a CICS region can operate as an enterprise server instance. These CICS regions behave in the same manner as those operating in a mainframe CICS environment. You can configure a CICS region operating as an enterprise server instance to communicate with a CICS region running on a mainframe.

  • IMS applications

    You can configure an enterprise server instance to run IMS applications.

  • JCL jobs

    You can configure an enterprise server instance to run batch initiator and batch printer JCL jobs.

Parent topic: Overview and Architecture


Enterprise Server Architecture

An Enterprise Server installation consists of a Micro Focus Directory Server, and a number of enterprise server instances. An enterprise server instance provides a pool of pre-initialized service execution processes (SEPs), within which COBOL applications are executed. For example, in an Enterprise Server CICS implementation, a CICS region runs as an enterprise server instance.

When you install Enterprise Server, depending on the Micro Focus product, a number of enterprise server instances are automatically set up for you. You can create further enterprise server instances as required.

As an administrator, you log on to the Enterprise Server administration user interface operating on the Micro Focus Directory Server. From this user interface, you can configure installation-wide settings. From this user interface, you can also access the administration user interfaces for each enterprise server instance operating in the installation.

Parent topic: Overview and Architecture


enterprise server instance Architecture

The following figure shows a high-level view of the enterprise server instance architecture and components.

Figure 1. enterprise server instance architecture

An enterprise server instance consists of some processes and an area used for inter-process communication.

As the COBOL applications run within their own address spaces, they are isolated from other programs executed within the enterprise server instance. Multiple execution processes enable concurrent processing of COBOL programs responding to client request messages.

The instance processes include a console daemon, server manager and communications process. These processes provide the following functionality:

  • The console daemon manages enterprise server instance processes and logs messages.
  • The server manager creates and manages the inter-process communication area and works in conjunction with the console daemon to provide process management.
  • The communications process receives incoming client requests and forwards them on to the appropriate services. It also receives the output from the request processing and sends it back to the clients. The requests can come from the following types of client:
    • Clients requesting a Web service. Requests from these clients arrive over HTTP as SOAP (Simple Object Access Protocol) messages.
    • J2EE clients requesting a service. Requests from J2EE clients arrive using a Micro Focus encoding and transport protocol.

All types of requests use TCP/IP as the underlying communications mechanism.

An enterprise server instance is created with one communications process, but you can add more to improve reliability and fault tolerance.

An enterprise server instance is created with two service execution processes (SEPs). A SEP is the process that actually executes the COBOL program that handles the client request. You can add more SEPs if the processing load requires it.

The inter-process communication area consists of a shared memory area that contains definitions of all the services that are available within the enterprise server instance. These definitions are located on the Directory Server. It sits outside the enterprise server instance, and can contain information for the enterprise server instances running in your installation. The inter-process communication area is also used to pass requests and responses between the enterprise server instance processes.

Parent topic: Overview and Architecture


The Micro Focus Directory Server

The Micro Focus Directory Server (MFDS) is a process that maintains the Enterprise Server operating information. It maintains information on the following components:

  • enterprise server instances and the services that are operating
  • Communications processes
  • Listeners
  • Request handlers
  • Implementation packages
  • XA resources

When you deploy a COBOL application as a service using the Interface Mapping Toolkit, much of the operating information maintained on the MF Directory Server is created automatically. An administrator can edit this information to respond to changing needs.

By default the Directory Server runs on the same machine as your enterprise server instances.

In addition to maintaining information on enterprise server instances, the Directory Server can also store information about CCI servers. These are servers that provide services using the Micro Focus Common Communication Interface (CCI), using the Directory Server as a naming server instead of registering with a CCITCP2 process. CCI servers are supported for backward compatibility:

  • Directory Server Information
  • Repository Statistics
Parent topic: Overview and Architecture


Directory Server Information

The Directory Server maintains information on all of the objects that it controls. These are:

  • Servers
  • Services
  • Communications processes
  • Service listeners
  • Request handlers
  • Implementation packages
  • XA resources
Parent topic: The Micro Focus Directory Server


Repository Statistics

Some items of information about the repository appear on the Statistics page:

  • Total count – the total number of objects currently in the repository
  • Repository status – the current status of the repository, for example, when Directory Server started and how many objects were loaded into the Directory Server from the repository
  • Repository location – the directory where the repository is located. By default this is C:\Documents and Settings\All Users\Micro Focus\Net Express\6.0\mfds.

You can also find the repository location by using the /m option of the mfds command-line utility (e.g. mfds /m).

Parent topic: The Micro Focus Directory Server


Service Execution Process (SEP)

An enterprise server instance can run a number of SEPs, depending on the functionality it provides. When a SEP has finished processing a request, it becomes available to process other requests as they are generated. A SEP contains the following components:

  • Application container

    The COBOL run-time system adapted to operate in the Enterprise Server environment. Within a SEP, application runs inside an application container.

  • Transaction management component

    Manages transactions for container-managed services, that is, it coordinates COMMITs and ROLLBACKs.

  • Request handler

    Decodes requests that are received. There is a Micro Focus request handler for each type of client request that Enterprise Server can handle. The request handler maps the output parameters into a form the client will understand.

    There are request handlers for the SOAP protocol and for the Micro Focus binary protocol. You can configure user exits to customize the request provided for the SOAP protocol.

  • Resource manager interface

    Handles requests for resources such as database and file access.

The processing of a request proceeds as follows:

  1. An enterprise server instance's communications manager receives a client request. The request is queued within the shared memory area and is scheduled for execution.
  2. When a SEP becomes available, it starts processing the request: it calls the application container.
  3. The application container then calls a request handler to decode the received request.

    The request handler uses the mapping information created by the Interface Mapping Toolkit to map the request parameters into the call interface of the COBOL application.

  4. Once the transaction or application has finished processing the request, the application container calls the request handler to map the output parameters into a form the client will understand.
  5. The application container then passes the response to the communications manager, which sends it back to the client.
Parent topic: Overview and Architecture


Request Handlers

A handler, or request handler, is a program that receives a client request for access to the service, and translates the request into a form that the service can understand. After the service has completed its task, the request handler translates the output back into a form that the client can understand, then passes the output to the client, via the communications process.

We provide request handlers for the SOAP protocol and for the Micro Focus binary protocol. You can customize the request provided for the SOAP protocol using user exits.

Parent topic: Overview and Architecture


Communications Processes

Communications processes are responsible for listeners. When you add a new enterprise server instance, it is created with one communications process, containing listeners for the two system services. You then add further listeners as required to deal with the expected workload of the enterprise server instance. Once you have the process defined as you want, you can create additional communications processes by copying the existing one. The advantages of having more than one communications process are:

  • The enterprise server instance is more robust in the event of communications failures. If one communications process encounters a problem, the others can continue to receive and process client requests and send back the replies.
  • The enterprise server instance can handle more client requests, because communications processes use a threaded architecture, and more communications processes means that more threads are available.
Parent topic: Overview and Architecture


Listeners

A listener object contains a network address that accepts incoming client requests on behalf of services. A service can have multiple listeners, and a listener can accept client requests on behalf of multiple services.

You can configure a listener to use SSL (Secure Sockets Layer), a facility for secure, encrypted communication and checking online identities.

Each listener is associated with a connector. This is software that can process the type of requests the listener handles.

Enterprise Server comes with several connectors, including:

  • The soap connector, which handles both Web Services SOAP requests and the Micro Focus Binary Protocol used for J2EE requests.
  • The http-switch connector, which provides simple web server capabilities and is used for service deployment.
  • The http-echo connector, which responds to HTTP requests with a short HTML reply and can be used for connection testing.
Parent topic: Overview and Architecture


Implementation Packages

An implementation package object contains information about the COBOL application that provides the service. A package is associated with an interface definition table (IDT), which contains the information that allows a client request to be mapped onto a COBOL program interface.

Parent topic: Overview and Architecture
Related information
Services, Packages and Request Handlers


XA Resources

An XA Resource object contains information about an XA-compliant database manager required to provide database access to one or more container-managed services. .

Parent topic: Overview and Architecture
Related information
Resource Management
Resource Managers


Enterprise Server Processes

CASCD - Region Console Daemon
CASCD manages region processes and console log messages. There is one of these console daemon process for every region. It is started by the casstart process.

CASCD is the parent of all other processes that run for the lifetime of the region. If it detects they have died, it informs CASMGR and restarts them.

Responsibities:

  • Starting processes
  • Monitoring started processes
  • Informing Server Manager of any process termination
  • Console Messages
CASMGR - Region Server Manager
CASMGR is started by the CASCD process, and works in conjunction with the Console Daemon to provide process management. There is one server manager process per region, represented by a DCA control block in shared memory.

Responsibilities:

  • Creates and manages the IPC area (shared memory) based on configuration data from MFDS
  • Controls the system state of Enterprise Server
  • Participates in error recovery processing
  • Handles CICS Interval Control Processing
  • Monitors region state for timeouts and deadlocks
  • Dispatches JCL jobs to initiators
CASTSC - Region Temporary Storage, Channels and Containers Control (TSC)
CASTSC controls temporary storage, channels, and containers. There is one process per region. It is started by CASCD.

Responsibilities:

  • CICS Channels and Containers support
  • Historical Statistics Facility
  • Auxiliary trace logging
  • CICS journal control
  • CICS extra-partition transient data processing
  • Distribution of system events to interested parties
CASSI - Service Execution Process (SEP)

A Service Execution Process is the process that executes the COBOL applications and acts as the container for user jobs and transactions. There can be multiple SEPs per region.

There are several different types of SEP:

  • Standard or Generic, which process CICS and generic service requests
  • JES Initiator, which process JCL workload based on job class
  • IMS MPR, which process IMS messages
  • Transient, an EZASOKET Listener - that is, a SEP that has been replaced and will probably terminate once the current request has been processed
  • Admin, a SEP that only processes administration requests from ESMAC and doesn't get blocked with standard request processing
  • Auxiliary, not a SEP but a view within ESMAC of support processes such as CASMGR, event manager and journal daemon.

CASSI is started by CASCD and represented by a DCA control block in shared memory.

MFCS - Micro Focus Communication Server

MFCS is the region communication component which handles the communication between clients and the Enterprise Server. There can be one or more communications servers per region depending on capacity needs.

MFCS is started by CASCD and contains the following service listeners:

  • TN3270
  • CICS ISC
  • Web Services

It is represented by a TCTS control block in shared memory.

CASDBC - IMS Database Control

CASDBC is responsible for IMS DB support and is an optional component with one for every region. It is started by CASCD.

CASTMC - IMS Transaction Manager Control
CASTMC is responsible for IMS TM support, and is an optional component with one for every region. It is started by CASCD.
Parent topic: Overview and Architecture


Configuration and Administration User Interface

This section introduces the Enterprise Server Administration web interface and the configuration process. You can use the administration interface to configure, monitor, and control enterprise server instances locally, across the Internet, or on your intranet, from a computer that has any of the following browsers installed:

  • Internet Explorer V6.0 or greater
  • Netscape V6.0 or greater
  • Mozilla V1.3 or greater
Note: By default Directory Server uses port 86. If you have an active firewall on the Directory Server machine, you need to make sure that it is configured to allow access to this port.
  • About the Enterprise Server Administration User Interface
  • User Interface Tables
  • Navigation
  • Accessing the Enterprise Server Administration UI
Parent topic: Enterprise Server Configuration and Administration


About the Enterprise Server Administration User Interface

When you access the Enterprise Server user interface, the Home page is displayed. What you can see depends on your access permissions, set by your login ID.

Menus

The Enterprise Server Administration menus appear in a panel on the left-hand side of the page. The menu options are grouped under headings, such as Actions. You see only the menu options that are appropriate to your permission level. Some Enterprise Server Administration; actions are available as push buttons on tables.

Status line

The status line appears towards the top of the page, under the Enterprise Server Administration heading. This line provides information about the status of the Directory Server. If the information is an error message, it appears in red.

enterprise server instances

Information about the enterprise server instances is presented in tables on the user interface. You can modify the level of information displayed on the home page by using the the expand button and the contract button buttons in the top left-hand corner of the servers table.

Most tables contain one or more Edit buttons, which you can click to go to a page to update the selected object's attributes, and an Add button, which you can click to go to a page where you can add an object of that type.

Refreshing a page

Many pages contain a Refresh button. Click this after you have performed an action that should be reflected in the contents of that page's table. For example, if you have just added a server, click Refresh on the Home page, and the details of the new server will appear in the servers table. Some pages also include an Auto-refresh interval field that enables you to specify the interval (in seconds) between automatic refreshes. The default (and the minimum) is 10 seconds; a blank space means no automatic refresh.

Parent topic: Configuration and Administration User Interface


User Interface Tables

Information about the objects in the Directory Server is presented in tables. The table that you see on the Home page after you have logged on presents information about the servers in the Directory Server repository. You can modify the level of information displayed on the home page by using the the expand button and the contract button buttons in the top left-hand corner of the servers table

The servers table has a number of Details push buttons, which you can click to go to a page with more detail on that particular type of object.

In the server table some columns are white while others are beige. Information in the white columns applies to both enterprise servers and CCI servers, while information in the beige columns applies only to enterprise servers.

As soon as you select a server to edit, or one of the other tables to view, such as the service table, the page changes to a tabbed format, enabling you to switch between communications processes, services, request handlers and implementation packages. The figure below shows the Edit Server page. The numbers in parentheses after the tabs on the top row indicate how many objects of that type are registered with the server.

Figure 1. Edit Server Page Showing Tabs
Edit Server Page Showing Tabs

Most tables also contain one or more Edit buttons, which you can click to go to a page where you can update the selected object's attributes, and an Add button, which you can click to go to a page where you can add an object of that type.

Parent topic: Configuration and Administration User Interface


Navigation

Enterprise Server Administration provides two sets of facilities, each with its own mode of navigation:

  • You perform various administrative tasks, such as saving and restoring Directory Server information, and creating new users, by selecting items from the menu in the left-hand panel. What you can select depends on your permission level.
  • You work with objects in the repository by clicking buttons in the main part of the page, usually in the table currently being shown. For example, if you want to add a new request handler, you need to:
    1. Click Details against Request Handlers in the table of servers on the Home page, to see the table of request handlers.
    2. Click Add in the bottom left-hand corner in the request handlers table, to reach the Add Request Handler page.

You can always return to the Home page wherever you are by clicking Home at the top of the menu in the left-hand panel, or upwards-pointing arrow in the top left-hand corner of the server details page or any of the object details pages.

Note:

We recommend that you do not use the Back button on your Web Browser tool bar to return to the previous page, as doing this might resubmit an administration request that is no longer valid.

Parent topic: Configuration and Administration User Interface


Accessing the Enterprise Server Administration UI

Providing the MF Directory Server is running, you can access the user interface directly from a web browser:

  • Open a Web browser and enter the URL http://targetname:86. Where targetname is the machine on which Enterprise Server Administration is running. For example, if Enterprise Server Administration is running on your local machine, enter http://localhost:86.

    Enterprise Server Administration opens with the Home page. If user access is restricted, you must logon before you can access any other features.

You can also access Enterprise Server administration from the Start menu. The option varies depending on the Micro Focus product you are using. For example, for Studio Enterprise Edition, you can choose the following option: Start > All Programs > Micro Focus Studio Enterprise Edition x.xConfiguration > Enterprise Server Configuration

If you have Studio Enterprise Edition installed, there are two alternative methods of accessing Enterprise Server Administration on your local machine:
  • In the IDE, open the Server Explorer then right-click Micro Focus Servers and choose Administration from the context menu.
  • Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Configuration > Enterprise Server Administration

If you see the message "The Page cannot be displayed", it might be that the Directory Server has stopped and needs restarting.

  • Displaying Server Information
  • Refreshing a Page
Parent topic: Configuration and Administration User Interface
Parent topic: Enterprise Server Task Index


Displaying Server Information

To see the information about servers managed by the Directory Server, access the server table on the Enterprise Server Administration Home page.

Note:

The server information displayed depends on the user and group permission that are set. For example, if you have not been granted "read" permission for a particular server, you will be unable to view it in the list.

The server table is available in two modes, summary and expanded. When you first start Enterprise Server Administration, it is shown in summary mode. You can switch to expanded mode by clicking the icon at the top left-hand corner of the table.

Figure 1. Server Table in Expanded Mode
Server Table in Expanded Mode
Parent topic: Accessing the Enterprise Server Administration UI
Parent topic: Monitoring the Directory Server


Refreshing a Page

Many pages contain a Refresh button. Click this after you have performed an action that should be reflected in the contents of that page's table. For example, if you have just added a server, click Refresh on the Server Information page, and the details of the activity are updated.

You can also configure the ESMAC pages to automatically refresh. To do this:

  1. In the Interval field, which is adjacent to the Refresh button, enter the number of seconds to wait between each refresh. This must be a number greater than 10.
  2. Click the Refresh button.
Parent topic: Accessing the Enterprise Server Administration UI
Parent topic: The ESMAC User Interface


Planning your Configuration

This section describes the issues and performance considerations that affect how you will configure Enterprise Server after you have installed it.

  • Introduction
  • Security Options
  • Enterprise Server Execution Control Under Windows
  • Firewall configuration
  • About Communications Processes
  • Deployment Services and Listeners
  • Enterprise Server Instance Configuration Issues
  • Performance Considerations
Parent topic: Enterprise Server Configuration and Administration


Introduction

After installation and before users start working with Enterprise Server, you need to:

  1. Decide on a user account strategy and implement it.
  2. Based on your security requirements, configure your security options.

    This is a complex subject, and is covered in a separate section.

  3. Set configuration options for the Directory Server.
  4. Set configuration options for your enterprise server instances.
Parent topic: Planning your Configuration


Security Options

By default, an application running in an enterprise server instance has the access permissions of the login ID that started the session under which it is running.

You can configure security managers to control access to applications and resources, regardless of the access level that the operating system allows.

We recommend that you carefully consider the security options that you require and configure your system appropriately.

Note: To ensure system robustness, you should use the same security configurations for both the MF Directory Server and the enterprise server instances that the MF Directory Server controls. If you do not, there is a risk that you will configure a system where an application has insufficient rights to access the resources that it needs.

Details on securing your installation, and the resources invoked from within your applications are included in a separate section of the help: Securing an Enterprise Server Installation.

  • About Securing an Enterprise Server Installation
Parent topic: Planning your Configuration


About Securing an Enterprise Server Installation

You use the Enterprise Server security facility to implement user authentication, and to control access to the applications and resources that a system uses.

You control access to Enterprise Server administrative features, MSS applications and application resources through the use of security managers, sometimes refered to as external security managers (ESMs). Through the use of these security managers, you can implement measures such as verifying users against the operating system configuration or incorporating an LDAP repository into your Enterprise Server security.

Securing an installation involves securing access to the following system components:

  • The Directory Server (MFDS)

    The Directory Server maintains records of system components and their configurations. You use the Enterprise Server Administration user interface (ESMAC) to create and modify these configurations. Securing the Directory Server controls who can configure the system.

  • Enterprise Servers

    Enterprise Servers use the application's program files, data files, and other items that a system uses while operating.

  • Inter-system communications

    You can configure SSL links between components to secure these communications. This is covered in another part of the help.

Note: It is possible to apply different security configurations to the Directory Server and the Enterprise Servers. This can cause problems during operation however. For example an administrator can have MFDS access permissions to configure a resource, but if the enterprise server does not have access permissions to use the resource, it cannot be used during operation. The safest thing to do is to apply the same security configuration to the Directory Server and the Enterprise Servers it controls.

User ID and password constraints

Enterprise Server emulates the mainframe operating system on Microsoft Windows, UNIX and Linux operating system platforms. Mainframe user authentication constraints and technical limitations are therefore emulated through the Enterprise Server External Security Facility (ESF) Manager to ensure mainframe compatibility.

These constraints and technical limitations apply to many components of Enterprise Server including:
  • CICS
  • Job Entry Subsystem (JES)
  • Micro Focus Directory Server (MFDS)
  • IMS
User IDs and passwords are limited to a maximum of eight ASCII characters.

To avoid issues with user signon and similar functions, avoid attempting to create user IDs or passwords that do not meet these requirements.

Parent topic: Security Options
Parent topic: Architecture and Overview


Enterprise Server Execution Control Under Windows

This topic describes the execution control of COBOL programs running as services and executables.

When a COBOL program runs as a Micro Focus service in an enterprise server instance, it inherits its security credentials from the server manager process that started the SEP.

Usually, Enterprise Server is started using the Micro Focus Enterprise Server Administration user interface, the Web interface to the MF Directory Server. In this event, Enterprise Server Administration (ES Admin) runs as a Windows system service. It is listed as Micro Focus Directory Server in the Services Control Panel. Windows system services run under the user account specified in their Startup options. You can view and change the Startup options using the Services Control Panel.

If Enterprise Server is started using the casstart program, run from the command line by an interactive user, then COBOL service programs use that user's security credentials.

When Enterprise Server is installed, the MF Directory Server is installed as a system service using the Local System user account, with the Allow service to interact with the desktop option selected. With this option selected:

  • The Directory Server is started when Windows boots up. You do not need to log into the system to start the Directory Server. Note that any system service can be set to start up when Windows boots, regardless of the user account it runs under.
  • Using this option allows the console daemon window to display when an enterprise server instance is running. User accounts other than the Local System user account cannot use the Allow service to interact with the desktop option.
  • If the Allow service to interact with the desktop option is not selected, the console daemon window is not displayed. You can however still view the console daemon messages through the ES Admin user interface.

The Local System account does not have privileges for network file access. That means that COBOL service programs that are running in an enterprise server instance that was started through MFDS, using the default configuration, are unable to open network files. To enable network file access from your COBOL service programs, use one of these methods:

  • Log in to Windows using an account with the network file access permissions that you want, and from the command line, start the enterprise server instance using the casstart command.

    COBOL service programs use the logged-in user's network credentials and can access the files that the logged-in user has authorization for.

    The disadvantage of this method is that it must be done manually, that is, the enterprise server instance must be stopped manually (using the casstop command) rather than through ES Admin.

  • Disable MFDS in the Services Control Panel and then start it from the command line using the mfds command while logged in as a user who has the appropriate network file access. When the enterprise server instance is started from ES Admin, it will inherit MFDS's user credentials.

    The disadvantages of this method are similar to the method above, though ES Admin can be used to start and stop enterprise server instances in this case.

  • Change the user account for the MFDS service. If you have the MFDS service running under a user account that has the appropriate network file access, your COBOL service programs will be able to open those files. Note that your programs will need to use UNC paths (that is, file path name of the form \\server\share\path-to-file\filename) and not drive mappings, to reliably open network files.

    The main disadvantage of this method is that Enterprise Server cannot display the console daemon window. However, this does improve the security of the installation, since access to the local desktop is a security risk. Running COBOL application programs under a normal user account (if it has reduced privileges), rather than under the Local System account (which is equivalent to an Administrator account for local security purposes) is more secure.

We recommend that for Enterprise Server on Windows (whether or not your COBOL service programs need network file access), you create a user account specifically for MFDS and the COBOL service programs running under it. Set the permissions on this account appropriately, that is, don't grant it any permissions that the COBOL programs don't need. For additional security, you can set ACLs to grant or deny access to particular objects (directories, files, registry keys) for this user to further control what COBOL service programs can do.

Parent topic: Planning your Configuration
Related information
Defining Enterprise Server Instance Administrators


Firewall configuration

If you have an active firewall on the machine that is running your Directory Server and enterprise server instances, and you want remote clients to be able to connect to them, you must ensure that the firewall allows access to the ports that you are using.

For example, Directory Server is configured, by default, to use port 86. Your must configure your firewall to allow TCP and UDP access to this port. Similarly, the default enterprise server instance, ESDEMO, has a Web Services and J2EE listener that uses port 9003. For remote clients to be able to submit requests to this listener, your firewall must permit access to this port.

We recommend that, if you want remote users to access Enterprise Server functionality through the firewall, you use fixed port values so that you can control access via these.

Note: If you are using Microsoft Windows XP and have installed Service Pack 2, you might find that you cannot see certain Enterprise Server Administration pages, because of firewall restrictions. To get round this, you need to enable access to the ports you are using, for example, 86 for the Enterprise Server Administration Home page and 9003 for the default enterprise server, ESDEMO. Use the Windows Security Center to do this.
Parent topic: Planning your Configuration


About Communications Processes

Communications processes handle communications between clients and the enterprise server instance, and consist of a number of service listeners. When an enterprise server instance is created it contains one communications process. If there is a communications failure for any reason, the enterprise server instance cannot process any work until the communications process is restarted. So, to improve the ability of an enterprise server instance to withstand communications failures, you can create one or more additional communications processes per enterprise server instance. You create an additional communications process by copying an existing one. The new communications process is an exact clone of the original, except that any fixed port numbers are not cloned. The first communications process in a newly created enterprise server, Communications Process 1, contains a Web Services and J2EE listener and a Web (deployment) listener. If you are creating a new enterprise server, you might want to modify this communications process definition before you copy it, depending on the particular workload you have planned for the server.

For fault tolerance you need at least two communications processes. You might need more than two to overcome operating system thread limits. The maximum is 32.

Parent topic: Planning your Configuration
Parent topic: Configuring the Server Instance Environment
Parent topic: Configuring Client-Server Communications


Deployment Services and Listeners

The facility in the Interface Mapping Toolkit to deploy services automatically to a running enterprise server delivers your services using a system service called a deployment service.

After installation, the enterprise server instance ESDEMO has a default deployment service named "Deployer". You can modify this deployment service or create additional deployment services with different configurations. You can also add deployment services to enterprise servers that you create.

The Deployer service uses a listener called Web, which uses the http-switch connector. If you modify the Deployer service, you will probably need to change the configuration of the Web listener too. You can also create your own listeners for use with deployment services.

  • Deployment Services
  • Deployment Listeners
Parent topic: Planning your Configuration


Deployment Services

All deployment services must have their Service Class attribute set to 'MF deployment'. They must be associated with a listener that uses the conversation type 'Web'.

The configuration information for a deployment service looks like this:

[MF client]
 scheme=http
 URL=virtual-directory-name-1/mfdeploy.exe/virtual-directory-name-2
 accept=application/x-zip-compressed

where virtual-directory-name-1 specifies the directory that holds the deploy program, mfdeploy.exe, and virtual-directory-name-2 specifies a directory to contain deployed services.

The values for the scheme and accept parameters must not be changed, but when you are creating a new deployment service you can omit them, as these are the defaults.

The settings for the Deployer service of ESDEMO are:

[MF client]
 scheme=http
 URL=/cgi/mfdeploy.exe/uploads
 accept=application/x-zip-compressed

The configuration of a deployment service must match the configuration of the listener for the service. The URL parameter must specify the same virtual directory name for the location of the mfdeploy.exe program as the listener uses. You can change the virtual path to receive deployed services to any virtual directory name configured for the listener.

For example, if the listener's configuration was:

then you might create a deployment service named "project1" with this configuration:
[MF client]
 scheme=http
 URL=/studioenterpriseedition/mfdeploy.exe/project1
 accept=application/x-zip-compressed

and services deployed using the "project1" service would be stored under c:\development\project1. You could create a similar service for project2.

Note that the deployment directory must have a .mfdeploy file. Copy the .mfdeploy file from %ProgramFiles(x86)%\Micro Focus\Server Enterprise Edition x.x\bin if Server Enterprise Edition is installed stand alone, and %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\deploy if Server Enterprise Edition is installed as part of Studio Enterprise Edition and modify it as necessary.

For example, if Server Enterprise Edition is installed in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x, then "<ES>/deploy" becomes %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin\deploy.

Parent topic: Deployment Services and Listeners


Deployment Listeners

The configuration information for a deployment listener consists of the section name "[virtual paths]" followed by a list of URL top-level directories and the paths they will be converted to. For example, the Web listener used by ESDEMO's Deployer service looks like this:

[virtual paths]
 cgi=<ES>/bin
 uploads=<ES>/deploy
 <default>=/dev/null

The "cgi" virtual path is used to specify the location of the mfdeploy.exe program that receives the COBOL archive file being deployed, and the "uploads" virtual path tells mfdeploy.exe where to create the directory for the uploaded COBOL archive file.

mfdeploy.exe is located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin and \base\bin\win64.

On Windows platforms, the special token "<ES>" is translated into the installation directory. For example, if Enterprise Server is installed as part of Studio Enterprise Edition in the default installation directory, then "<ES>/deploy" becomes %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin\deploy.

Only the first directory in the URL specified by the client performing the deployment is checked against the list, and the entries in the list have to be just a single directory name.

The "<default>" directory is used if the first directory in the URL specified by the client doesn't match any of the entries in the list. The default directory must be one that does not exist, so that when the communications process translates the URL into a full path, the request will fail. This stops any attempt by a client to browse arbitrary directories on the machine. You don't need to specify a default directory, since the communications process uses a safe default anyway.

Here is another example:

[virtual paths]
 <default>=c:/web
 docs=c:/web/documents
 images=d:/media/images

With this configuration, the URL http://host:port/docs/a.html will return the file c:\web\documents\a.html, and the URL http://host:port/images/gif/b.gif will return the file d:\media\images\gif\b.gif.

Parent topic: Deployment Services and Listeners


Enterprise Server Instance Configuration Issues

You can configure various attributes of an enterprise server instance, for example how much memory is available to it, how many service execution processes it starts up with, what information is traced. Most of these options are fairly straightforward; in any case detailed advice on these options is available in the help for the Add Server and Edit Server pages.

An enterprise server instance and the objects it contains (services, listeners, etc) each have a specific Configuration Information field, accessible on the Add and Edit pages for each type of object. Entries in the Configuration Information field use the .ini file format, with section names in square brackets followed by name/value pairs:

[ASection]
name1=value1
name2=value2

Most settings are case-insensitive except:

  • The names of virtual paths for the "Web" listener are case-sensitive.
  • On UNIX, settings for environment variables (in [ES-Environment]) and values that include file or directory names are case-sensitive.
  • Shared Memory Area
  • Shared Memory Cushion
  • Number of Service Execution Processes
Parent topic: Planning your Configuration


Shared Memory Area

The shared memory area is an area of memory where an enterprise server instance stores all the information it needs to run (see the section Server Enterprise Edition Architecture in the chapter Introduction). The shared memory area is measured in pages of 4KB each. The shared memory area has to be big enough to contain all the definitions of the objects in the server, and all the current client requests. If you run out of shared memory while the server is running, the performance of the enterprise server instance will be significantly affected and this could prevent client requests from being processed.

Use the calculation described in this section to estimate the number of shared pages to allocate to an enterprise server instance.

Actual requirements vary according to the nature of the workload, but you are advised to allow a generous safety margin. Enterprise Server optimizes the use of the shared memory resource by minimizing the number of physical pages used at lower than maximum processing volumes.

Perform the calculations in the middle column of the table below and enter the result of each calculation in the right-hand column. The sum of these answers is the minimum number of bytes required for the shared memory. Divide this number by 4096 and round up to a whole number to get a figure for the number of shared pages needed.

Item | Calculation | Result
Overhead | Fixed size | 8192
Shared memory area management | Shared memory area size / 4096 |
Trace | If auxiliary trace not active: Number of entries x 24 |
Trace | If auxiliary trace active: Number of entries x 24 x 11 |
Local trace | Number of service execution processes x number of entries x 24 |
Services | Number of services x (128 + service-name-length) |
Service execution processes | Number of service execution processes x 144 |
Request handlers | Number of request handlers x (128+handler-name-length) |
Packages | Number of packages x (128+IDT-name-length + application-path-length + module-name-length) |
Resident IDTs | Number of resident IDTs x IDT-length |
Client requests | Number of client requests being processed at any one time x (256 + average size of client request) |
Clients | Peak number of concurrent clients x 64 |
Access Control Environment Elements | Peak number of signed-on users x 428 The number of signed-on users should include the 4 default users used by the system. |
Total |  |

where:

service-name-length | is the length of the service name
handler-name-length | is the length of the name of the request handler
IDT-name-length | is the length of the IDT name
application-path-length | is the length of the path to the COBOL application in the package
module-name-length | is the length of the name of the module containing the application
IDT-length | is the size of the IDT file for a package
Parent topic: Enterprise Server Instance Configuration Issues


Shared Memory Cushion

The shared memory cushion is part of the shared memory area. Its function is to handle short-term high demands on the server. When an enterprise server instance starts, the shared memory cushion is not available for use, and it is never used by incoming client requests. It is used only when a response needs to be passed back to a client, and there is insufficient free memory in the main area to handle the response.

The shared memory cushion is also measured in pages of 4KB each. Set the shared memory cushion to 10% of the size of the shared memory area.

Parent topic: Enterprise Server Instance Configuration Issues


Number of Service Execution Processes

When an enterprise server instance is created it contains two service execution processes (SEPs). SEPs process incoming client requests. When a response has been returned to a client, the SEP becomes available again to handle another request. If all the SEPs are busy handling requests, incoming requests must wait for one to become free. The number of SEPs in an enterprise server instance impacts performance. The kind of impact depends on a number of variables. You will need to experiment to find out the optimum number of SEPs in any particular enterprise server. For more advice see the section Performance Considerations .

You can change the number of SEPs in an enterprise server while it is running, although any change you make has an effect only until you stop the server. At this point the number of SEPs reverts to the value you set when you added the server or edited the server details.

Parent topic: Enterprise Server Instance Configuration Issues


Performance Considerations

How you configure an enterprise server instance for performance depends on a number of factors. One obvious factor is the expected workload of the server. You need to consider the frequency with which client requests arrive, and the required speed of response to those requests.

Two more factors are the type of services that run within the server and the type of requests for the services. Services can be categorized as I/O-bound or CPU-bound, while client requests can be categorized as short-running or long-running.

  • I/O-bound Services
  • CPU-bound Services
  • Short-running Client Requests
  • Long-running Client Requests
Parent topic: Planning your Configuration


I/O-bound Services

Services that perform a lot of I/O requests are often dormant while they are running, while they wait for the responses to their requests. However, processing I/O requests can sometimes make considerable demands on the CPU. You need to consider whether you might need more service execution processes for this type of service.

Parent topic: Performance Considerations


CPU-bound Services

Services that do not perform any I/O requests (or very few) are usually constrained by the use they make of the central processor. With CPU-bound services, fewer service execution processes usually work better, because the central processor switches between the running tasks, and this is an overhead.

Parent topic: Performance Considerations


Short-running Client Requests

Short-running client requests are requests where there is just one interaction between the client and the service; the client request arrives, the service runs, and a response is returned to the client. Requests from Web services clients are always short-running.

With short-running requests, you only need to consider whether or not the the service itself is I/O-bound or CPU-bound.

Parent topic: Performance Considerations


Long-running Client Requests

Long-running client requests are requests where the same client can make repeated requests of a service and needs data to be preserved between invocations of the service. In Java terms, they are stateful requests. So if the client is a stateful Java bean running in an application server such as WebLogic or WebSphere, the service will run for as long as the bean runs. In these circumstances, you need more service execution processes, even if the service itself is CPU-bound rather than I/O-bound.

If the enterprise server instance detects that the request is stateful, a new service execution process is started automatically. Dynamic growth of service execution processes consumes machine resources and can affect the performance of the enterprise server. We recommend that, unless your application design actually requires stateful interaction, you keep these types of request to a minimum.

Parent topic: Performance Considerations


Configuring the Server Instance Environment

You can use the Configuration Information field on the Add Server and Edit Server pages for configuration data specific to each enterprise server instance. This field can contain the following section:

[ES-Environment]

Settings in this section are added to the environment of programs running under this enterprise server. You can use it to set arbitrary environment variables required by your programs, such as DDNAMEs, or to set system or COBOL run-time variables such as PATH and COBPATH. On UNIX, settings in this section are case-sensitive.

You can also configure a setting that allows you to access and run JCL files from the local machine. For example, if you are managing a Unix enterprise server from a Windows machine, you can access and run JCL files stored on the local Windows machine.

You can also use the Configuration Information field on the Add Server and Edit Server pages to set parameters for communications processes belonging to that enterprise server instance. Communications process settings in the server object apply to all of the communications processes for that enterprise server instance. To set parameters for only one communications process, use the Configuration Information field on the Add Communications Process or Edit Communications Process pages.

In order to add comments within your configuration information, prefix each line of text with the number sign (#).

  • Configuring Environment Variables
  • About Communications Processes
  • Configuring Fileshare
  • Using XA-Compliant Resources
Parent topic: Enterprise Server Configuration and Administration


Configuring Fileshare

You will need to set the FHREDIR environment variable to specify the location of the FHREDIR configuration file if any services in your enterprise server instance make use of Fileshare to access files across the network. For example:

[ES-Environment]
FHREDIR=home/mydir/client.cfg

As the FHREDIR configuration is static, the contents of the FHREDIR configuration file are read at when the enterprise server instance is initialized and cannot be dynamically changed. This means that the FHREDIR configuration file should contain entries for all services that are deployed, or could be deployed to the enterprise server instance. If a service is dynamically deployed to an enterprise server instance and it requires different configuration for Fileshare then there is no option but to stop and restart the enterprise server instance.

If all your enterprise server instances use the same configuration file, you can set $FHREDIR on the command line before you start the Directory Server, rather than have separate configuration entries for each enterprise server instance.

You should start all the Fileshare servers that the services in an enterprise server instance might need to access before you start the enterprise server instance. You should stop the enterprise server instance before you stop the Fileshare servers.

For more information about Fileshare see the section of the help that covers Fileshare.

Parent topic: Configuring the Server Instance Environment


Using XA-Compliant Resources

  • XA-Compliant Resources Overview
  • XA Switch Modules
  • Configuring XA Resources for an Enterprise Server Instance
  • XA Troubleshooting
  • Handling XA Connection Errors
Parent topic: Configuring the Server Instance Environment


XA-Compliant Resources Overview

If you configure your enterprise server instance to run container-managed services (web services or EJBs), CICS or IMS Transactions, or JES jobs accessing databases or MQSeries resources, you also need to configure your server so that it can interact with the resource managers that the application wants to access. In that context you can only use resource managers that are XA-compliant. The XA interface describes a structure called a switch table, which lists the names of the xa_ routines implemented in the resource manager. This structure is called xa_switch_t. To access an XA-compliant resource manager, you need a switch module, the purpose of which is to obtain the address of the XA switch data structure implemented by the resource manager.

If you want to access Oracle, IBM DB2, SQL Server, or XDB databases from JES JCLs using IKJEFT01, you must build an additional switch module to use along with the standard switch module.

You specify the details of XA resource managers using the Edit Server > Properties > XA Resources page in the Web interface. You can also edit and delete XA resource manager definitions. You can enable resource managers individually to control which are active when an enterprise server instance starts.

Parent topic: Using XA-Compliant Resources


XA Switch Modules

Note: Source code for XA switch modules is not installed with Server Enterprise Edition or Studio Enterprise Edition Test Server.

Studio Enterprise Edition includes the source code for switch modules for Oracle, IBM DB2, XDB, SQL Server, a generic one-phase ODBC switch module, a two-phase MQSeries switch module, and the additional switch modules for using with JES-initiated transactions in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source\enterpriseserver\xa directory.

With the exception of the two-phase MQSeries switch module, you must build each switch module in your development environment, and then copy it to your deployment server. The files are:
ESORAXA.CBL | Oracle
ESDB2XA.CBL | IBM DB2
ESMSSQL.CBL | SQL Server
ESODBCXA.CBL | Generic one-phase commit for ODBC
ESMQXA.DLL | MQSeries1
ESORAOPC.pco | JES-initiated transactions connecting to Oracle data sources
ESDB2OPC.CBL | JES-initiated transactions connecting to IBM DB2 data sources
ESXDBXA.CBL | XDB
ESXDBOPC.CBL | JES-initiated transactions connecting to XDB Server
1 The MQSeries module provided is a built module, not a source code file. It is available in both your development and deployment environments. For more information, see The MQSeries XA Switch later in this topic.
SQL Server Requirements
The SQL Server module provides two-phase commit support utilizing the Microsoft Distributed Transaction Server (MS DTC), and ensures that any database connections made using this switch module all participate in a single XA transaction. MSDTC must be running on both the client machine, and also the machine(s) where SQL Server is hosted.
SQL Server and ODBC Requirements
Some OpenESQL directives are process-based, and typically need to be set in within the code of the program that makes the database connection. If you are executing services under Enterprise Server that are deployed as container-managed applications, or if you are invoking JES-initiated transactions using IKJEFT01, these directives must be specified when compiling the XA switch module, rather then when compiling your program source.
ODBC Limitations
The ODBC module supports only a one-phase commit, and hence:
  • Cannot be used in conjunction with other resource managers that use this module because, within a given region, the generic ODBC one-phase commit module supports only one active Resource Manager at a time.
  • Can only be used for a single database connection; multiple data source connections are not supported
SQL Server and Generic One-phase Commit for ODBC Limitations
When using the SQL Server and Generic one-phase commit for ODBC switch modules, the following SQL operations are not supported in the source for your deployed container-managed service:
  • CONNECT
  • DISCONNECT
  • BEGIN TRANSACTION
  • COMMIT
  • ROLLBACK
ODBC Requirements
Some OpenESQL directives are process-based, and typically need to be set in within the code of the program that makes the database connection. If you are executing services under Enterprise Server that are deployed as container-managed applications, or if you are invoking JES-initiated transactions using IKJEFT01, these directives must be specified when compiling the XA switch module, rather then when compiling your program source.
ODBC Limitations
The ODBC module supports only a one-phase commit, and hence:
  • Cannot be used in conjunction with other resource managers that use this module because, within a given region, the generic ODBC one-phase commit module supports only one active Resource Manager at a time.
  • Can only be used for a single database connection; multiple data source connections are not supported
Additional Oracle Resources
For more information on using the Oracle XA switch module, including the Open String definition and details of supported SQL operations, see the following:
  • The Database Access Support topic for Third-party Software in the Start Here section of this documentation.
  • The Developing Applications with Oracle XA help topic available in the Oracle RDBMS documentation.
Additional IBM DB2 Resources
For more information on using the IBM DB2 XA switch module, including the Open String definition and details of supported SQL operations, see the following:
  • The Database Access Support topic for Third-party Software in the Start Here section of this documentation.
  • The Transaction Managers help topic available in the IBM RDBMS documentation.
  • DB2 9.1 - The X/Open XA Interface programming considerations help topic available in the IBM RDBMS documentation.

To build a switch module

As well as the switch module sources, the directory contains the build.bat batch file that you can use to build the switch module you need.

  • For 32-bit applications:
    1. Open aNet Express command prompt, 32-bit.
    2. Change to the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Base\SOURCE\ENTERPRISESERVER\XA directory (default location).
    3. Enter build switch-module
  • For 64-bit applications:
    1. Open aNet Express command prompt, 64-bit.
    2. Change to the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\Base\SOURCE\ENTERPRISESERVER\XA directory (default location).
    3. Enter build switch-module
where switch-module is the type of module you want to build, as follows:
Value of switch-module | Module type
ora10 | Oracle 10 databases
ora11 | Oracle 11 databases
db2 | IBM DB2 Important: Before building this switch module, ensure your LIB environment variable contains the path to your DB2 LIB directory.
odbc | Generic one-phase commit for ODBC
xdb | XDB
You must also build these additional modules if you need to connect to resources from JES-initiated tasks over IKJEFT01. These modules must be loaded by the main switch module; therefore include the full path to any additional switch modules in your system's PATH environment variable:
Value of switch-module | Module type
ora1pc | Oracle databases
db21pc db2_database_alias [db2_userid db2_password IBM DB2. Parameters:
db2_database_alias
The database alias cataloged to the DB2 client on the machine where Enterprise Server is running
db2_userid db2_password
The user ID and password for connecting to DB2; required only if different from the user ID and password for the user currently logged in
odbc | Generic one-phase commit for ODBC1
xdb1pc | XDB
Important: If you are running Server Enterprise Edition, build the required switch module in Studio Enterprise Edition, and make it available for use with the standalone Server Enterprise Edition.

The MQSeries XA Switch

The ESMQXA module is provided as part of the product and does not need to be built. The filename for the built module is esmqxa.dll.

By default, the ESMQXA module operates in two-phase commit mode. You can set the environment variable ES_MQ_1PC to Yes or True in order for the module to operate in one-phase commit mode, but you should only do this if advised to by Micro Focus.

Important: Set the MQ Connection in one of these two places:
  • XA Resource Manager
  • System Initialization Table (SIT)
Do not set it in both. Doing so results in two connections between the Server Enterprise Edition region and the MQ Queue Manager. Only one is required.
Parent topic: Using XA-Compliant Resources
Related concepts
Scope - OpenESQL SQL Compiler Directive Options


Configuring XA Resources for an Enterprise Server Instance

  • To Add an XA Resource
  • To Delete an XA Resource
  • To Edit an XA Resource
  • To Enable or Disable an XA Resource
Parent topic: Using XA-Compliant Resources


To Add an XA Resource

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server that you want to edit.
  2. Click the XA Resources tab.
  3. Click Add.
  4. Specify the details of the resource manager:
    ID
    Specify a resource manager ID, used internally to identify a particular XA configuration. This must be unique within the enterprise server. Mandatory.
    Name
    Specify the name by which the resource manager is known. It should match the name returned in the name field of the xa_switch_t structure. Mandatory.
    Module
    Specify the location of the executable file (.dll on Windows),(.sl on HP-UX PA-RISC, .so on other UNIX platforms) that contains the entry point that returns the xa_switch_t structure to the enterprise server. Mandatory.
    Open string
    Specify the string that is passed to the resource manager on the xa_open() call. It usually contains at least the database name, and the user ID and password for connecting to the database. The contents of this string are database-specific.

    Where the resource manager supports dynamic registration, and the database vendor requires the name of the module that provides the ax_reg function, you should specify casaxlib.

    Close string
    The string that is passed to the resource manager on the xa_close() call. To find out whether or not you need to supply Close string, see your database vendor's documentation.
    Description
    Specify an optional text description of the resource manager definition.
    Enabled
    Check this to enable the resource manager. It is checked by default.
  5. Click Add.
Note: You cannot add a resource manager until all the mandatory fields have values.
  • Resource Manager Definition for SQL Server Switch Module
  • Resource Manager Definition for XDB Switch Module
  • Resource Manager Definition for Generic One-phase Commit for ODBC Switch Module
  • Resource Manager Definition for DB2 Switch Module
  • Resource Manager Definition for Oracle Switch Module
  • Resource Manager Definition for MQSeries
Parent topic: Configuring XA Resources for an Enterprise Server Instance
Parent topic: Work with Servers
Parent topic: Database Managers Supported


Resource Manager Definition for SQL Server Switch Module

To define the SQL Server XA switch module in Enterprise Server, add an XA resource including the following values.

  • In the Module field, enter the full path to esmssql.dll
  • In the Open string field, type the following:
    DSN=odbc_dsn[,USRPASS=userid.password][,CONNECTNAME=connectname]
   [,DTCSERVER=dtcsrvr]
    where the parameters are:
    odbc_dsn
    The ODBC Data Source Name used to connect to the data source as defined within the Windows ODBC Data Source Administrator utility.1
    userid
    The user ID required to connect to the data source. Not required when using trusted connections.1
    password
    The password required to connect the user ID to the data source. Not required when using trusted connections. 1
    connectname
    The name used by OpenESQL to identify the connection. Specify this only if you have multiple connections.2
    dtcsrvr
    The name of the machine hosting the Microsoft Distributed Transaction Coordinator (MSDTC) that creates the transaction objects. If not specified, the local machine is used.
Parent topic: To Add an XA Resource
1 Alternatively, you can specify the DSN, user ID, and password by manually coding them into the esmssql.cbl source. This can be helpful if you want to ease security. To do this, search for CUSTOMIZE within esmssql.cbl to see where to apply the required changes.
2 You must also code a reference to this connection name into the source for your deployed container-managed service as follows:
EXEC SQL SET CONNECTION connectname END-EXEC

Where connectname is the name specified in the Open string field on the Enterprise Server XA Resources tab.


Resource Manager Definition for XDB Switch Module

To define the XDB switch module in Enterprise Server, add an XA resource including the following values in the Open string field. Enclose values containing spaces in double quotes.

[{SERVER | SRV}=["]server-name["],] [{LOCATION | LOC | DB}=["]location-name["],]
     [{USERID | UID}=["]userid["],] {PASSWORD | PWD}=["]password["]
The parameters are:
server-name
The name of your XDB Server. The default is the value set in the Server Name field of the Options Utility. Optional.
location-name
Your XDB location. The default is the value set in the Locations field of the Options Utility. Optional.
userid
The user ID required to connect to the XDB server. The default is the value set in the AuthID field of the Options Utility. Optional.
password
The password required to connect the user ID to the XDB Server. Required.
Note: You can access the Options Utility from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > SQL Option for DB2 > Configuration > Client Options.
Parent topic: To Add an XA Resource
Related information
Options Utility


Resource Manager Definition for Generic One-phase Commit for ODBC Switch Module

To define the generic one-phase commit for ODBC XA switch module in Enterprise Server, add an XA resource including the following values.

  • In the Module field, enter the full path to esodbcxa.dll.
  • In the Open string field, type the following:
    DSN=odbc_dsn[,USRPASS=userid.password]
    where the parameters are:
    odbc_dsn
    The ODBC Data Source Name used to connect to the data source as defined within the Windows ODBC Data Source Administrator utility.
    userid
    The user ID required to connect to the data source. Not required when using trusted connections.
    password
    The password required to connect the user ID to the data source. Not required when using trusted connections.

Alternatively, you can specify the DSN, user ID, and password by manually coding them into the ESODBCXA.CBL source. This can be helpful if you want to ease security. To do this, search for CUSTOMIZE within ESODBCXA.CBL to see where to apply the required changes.

Parent topic: To Add an XA Resource


Resource Manager Definition for DB2 Switch Module

To define the DB2 switch module in Enterprise Server, add an XA resource including the following values in the Open string field.

Note: The open string format is defined by IBM. We strongly recommend that you become familiar all of the available options by reviewing the DB2 Administration Guide and the Application Programmer's Guide in your IBM documentation. Example settings are shown in this topic for guidance only.

Enclose values containing spaces in double quotes.

db=name,uid=identifier,pwd=password,axlib=casaxlib
The parameters are:
db
The name of your DB2 database.
uid
The user ID required to connect to the DB2 server.
pwd
The password required to connect the user ID to the XDB Server. Required.
axlib
The fully-qualified name of the library that contains the transaction manager's ax_reg and ax_unreg functions. Must be set to casaxlib or casaxlib64 for 64-bit applications.
Parent topic: To Add an XA Resource


Resource Manager Definition for Oracle Switch Module

To define the Oracle switch module in Enterprise Server, add an XA resource including the following values in the Open string field.

Important: The open string format is defined by Oracle. We strongly recommend that you become familiar all of the available options by reviewing the Oracle Application Developer's Guide - Fundamentals topic in your Oracle documentation. Example settings are shown in this topic for guidance only.

Enclose values containing spaces in double quotes.

LogDir=path+DbgFl=value+Oracle_XA+SesTm=time+SqlNet=name+Acc=P/user/password
The parameters are:
LogDir
Fully-qualified path to the directory where the XA library error and tracing information may be logged.
DbgFl
Extent of tracing. Possible values are
  • 0x1, trace the entry and exit to each procedure in the XA interface
  • 0x2, trace the entry to and exit from other non-public XA library routines
  • 0x4, trace various other calls made by the XA library, such as specific calls to the Oracle Call Interface
Oracle_XA
The name of the resource manager.
SesTm
The maximum length of time a transaction can be inactive before it is automatically aborted by the system.
SqlNet
A string providing the Net8 database link used to log on to the Oracle system.
Acc
User access credentials, which must be prefixed by "P/".
Parent topic: To Add an XA Resource


Resource Manager Definition for MQSeries

To define the MQSeries XA switch module in Enterprise Server, add an XA resource including the following values.

  • In the Module field, enter the full path to esmqxa.extension.
  • n the Open string field, type the following:
    QMNAME=queue_manager_name,TPM=CICS,AXLIB=casaxlib,CHANNEL,TRPTYPE,CONNAME
    where the parameters are:
    QMNAME
    The name of the queue manager. This is a mandatory parameter.
    TPM
    The transaction manager being used. Must be set to CICS.
    AXLIB
    The name of the library that contains the transaction manager's ax_reg and ax_unreg functions. Must be set to casaxlib.
    CHANNEL
    The name of an MQI channel. If this parameter is supplied, the CONNAME parameter must also be supplied.
    TRPTYPE
    The communications protocol for the MQI channel. The following are valid values:
    LU62
    SNA LU 6.2
    NETBIOS
    NetBIOS
    SPX
    IPX/SPX
    TCP
    TCP/IP
    The default is TCP.
    CONNAME
    The network address of the queue manager. The valid values of this parameter depend on the value of the TRPTYPE parameter.
    If TRPTYPE is set to: CONNAME must be:
    LU62 A symbolic destination name, which identifies a CPI-C side information entry.

    You cannot use the network qualified name of a partner LU or a partner LU alias.

    NETBIOS | A NetBIOS name.
    SPX A 4-byte network address, a 6-byte node address, and an optional 2-byte socket number.

    These values must be specified in hexadecimal notation. A period must separate the network and node addresses, and any socket number must be enclosed in parentheses. For example:

    0a0b0c0d.804abcde23a1(5e86)

    The default value is 5e86.

    TCP | A host name or an IP address, optionally followed by a port number in parentheses. The default value is 1414.
    If this parameter is supplied, the CHANNEL parameter must also be supplied.
Parent topic: To Add an XA Resource


To Delete an XA Resource

CAUTION:

Deleting a registered XA resource might cause application connection errors and loss of data.

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server that owns the XA resource you want to delete.
  2. Click the XA Resources tab.
  3. Click Edit next to the XA resource you want to delete.
  4. Click Delete.
  5. Click OK on the confirmation page.
Note:

You cannot delete an XA resource if the server is started.

Parent topic: Configuring XA Resources for an Enterprise Server Instance
Parent topic: Work with Servers


To Edit an XA Resource

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server that owns the XA resource you want to edit.
  2. Click the XA Resources tab.
  3. Click Edit next to the XA resource you want to edit.
  4. Update the attributes on the page as required.
  5. Click OK.
Note: You cannot update the attributes of an XA resource if the server is started.

To reconnect to an XA resource following an error

Set the ES_xxxxx_NB_RETRIES environment variables in Configuration Information on the Edit Server page, where xxxxx is the ID of the resource. This specifies the number of times a SEP will attempt to reconnect to the XA resource following an error. The default is 5. If no connection is made, the switch is disabled.

Parent topic: Configuring XA Resources for an Enterprise Server Instance
Parent topic: Work with Servers


To Enable or Disable an XA Resource

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server that owns the XA resource you want to enable or disable.
  2. Click the XA Resources tab.
  3. Click Edit next to the XA resource you want to enable or disable.
  4. Check or uncheck Enabled as required.
  5. Click OK on the confirmation page.
Parent topic: Configuring XA Resources for an Enterprise Server Instance
Parent topic: Work with Servers


XA Troubleshooting

  • XA Troubleshooting
  • XA Return Codes
  • XA Switch Module Diagnostics
  • XDB Diagnostics
Parent topic: Using XA-Compliant Resources


XA Troubleshooting

Reading Error Messages in console.log

On an XA call failure a message is displayed in the log containing :

  • the target resource manager
  • the failing XA call
  • the return code from the call
  • the XID, a transaction identifier
For example, the log entry
111012 14063540   1924 XATEST   CASXO0004S Resource Manager for resource DB7R Transaction end failed: reason -00007, XID: MF_CASDEMOXATEST  000012000000000000000001000001  14:06:35
The XA End call for resources DB7R failed with return code -00007
includes the following information:
  • CASXO0004S is the error code
  • DB7R is the resource manager
  • Transaction end is the stage of the transaction where the failure occured
  • -00007 is a code indicating the resource manager is unavailable
  • MF_CASDEMOXATEST 000026000000000000000001000001 is the XID

Refer to the specific database documentation for recommendations on the action to take when transactions might have failed.

Understanding Enterprise Server XIDs

The XID transaction identifier consists of the following parts:

Element | Length | Description
fxid-id | 6 char | Constant
xid-sysid | 4 char | System identifier (SYSID of your enterprise server)
xid-applid | 8 char | Region name (APPLID)
xid-tran-no | 6 numeric | CICS task number
xid-mgr-id | 18 numeric | Position of this resource manager in the resource manager table
xid-branch-no | 6 numeric | Branch number
For example, the XID
MF_CASDEMOCICS-FS 000049000000000000000001000001
is made up of the following:
  • MF_CAS is a constant
  • DEMO is the system ID
  • CICS-FS is the region
  • 000049 is the task number
  • 000000000000000001 indicates this is the first resource manager in the table
  • 000001 indicates this is the first branch

Reading CAS Traces

If you have enabled resource manager interface or exit traces, or if an XA call fails (in which case traces are unconditionally written) you can trace XA calls. Some examples follow.

Example 1
This trace shows a sucessful start call for a resource called NJFXA1.
Succesful START call
uExit(NJFXA1..) 288 61 11100 40 e90181 9171356 <NJFX A1..> 4e4a4658 41310000 SEP dfheserv(dfhcpuex)
XA(start) 290 61 11100 6d 6d0183 9171356 <XA-- STRT> 58412d2d 53545254 SEP dfhexa()
XA-ID(NJFXA1..) 291 61 11100 6d 6d0282 9171356 <NJFX A1..> 4e4a4658 41310000 SEP dfhexa()
XA-StartT( 61 )Br( 1 ) 292 61 11100 6d 6da081 9171356 <...= ....> 0000003d 00000001 SEP dfhexa()
XA-Start( 0 ) 293 61 11100 6d 6d1182 9171356 <XSTR ....> 58535452 00000000 SEP dfhexa()
XA-Return( 0 ) 294 61 11100 6d 6d0384 9171356 <XARC ....> 58415243 00000000 SEP dfhexa()
Example 2
This trace shows a failing start call for NJFXA1, which returns code 4 "Found the previous Start call for this Failing Commit call". The trace includes the XA transaction ID and the resource manager ID.
uExit(NJFXA1..) 120 57 11100 40 e90181 9165273 <NJFX A1..> 4e4a4658 41310000 SEP dfheserv(dfhcpuex)
XA(T-Sync) 122 57 11100 6d 6d0183 9165273 <XA-T SYNC> 58412d54 53594e43 SEP dfhexa()
XA-ID(NJFXA1..) 123 57 11100 6d 6d0282 9165273 <NJFX A1..> 4e4a4658 41310000 SEP dfhexa()
XA-CommitRC( 4 ) 124 57 11100 6d 6d5082 9165273 <XCOM ....> 58434f4d 00000004 SEP dfhexa()
XA-CommitRC( 4 ) 125 57 11100 6d 6d52f9 9165273 <COMM ....> 434f4d4d 00000004 SEP dfhexa()
XA-Return( 1 ) 130 57 11100 6d 6d0384 9165313 <XARC ....> 58415243 00000001 SEP dfhexa()
XA-StartT( 61 )Br( 1 ) 292 61 11100 6d 6da081 9171356 <...= ....> 0000003d 00000001 SEP dfhexa()

The XID for the failing transaction is MF_CASDEMOCICS-FS 00006 0000000000000000001000001.

Parent topic: XA Troubleshooting


XA Return Codes

As with flag definitions, all transaction managers and resource managers must ensure interchangeability by using these return codes, defined in the xa.h header.

ax_() return codes (transaction manager reports to resource manager)

#define | Code | Description
TM_JOIN | 2 | Caller is joining existing transaction branch
TM_RESUME | 1 | Caller is resuming association with suspended transaction branch
TM_OK | 0 | Normal execution
TMER_TMERR | -1 | An error occurred in the transaction manager
TMER_INVAL | -2 | Invalid arguments were given
TMER_PROTO | -3 | Routine invoked in an improper context

xa_() return codes (resource manager reports to transaction manager)

#define | Code | Description
XA_RBBASE | 100 | The inclusive lower bound of the rollback codes
XA_RBROLLBACK | XA_RBBASE | The rollback was caused by an unspecified reason
XA_RBCOMMFAIL | XA_RBBASE+1 | The rollback was caused by a communication failure
XA_RBDEADLOCK | XA_RBBASE+2 | A deadlock was detected
XA_RBINTEGRITY | XA_RBBASE+3 | A condition that violates the integrity of the resources was detected
XA_RBOTHER | XA_RBBASE+4 | Tthe resource manager rolled back the transaction branch for a reason not on this list
XA_RBPROTO | XA_RBBASE+5 | A protocol error occurred in the resource manager
XA_RBTIMEOUT | XA_RBBASE+6 | A transaction branch took too long
XA_RBTRANSIENT | XA_RBBASE+7 | May retry the transaction branch
XA_RBEND | XA_RBTRANSIENT | The inclusive upper bound of the rollback codes
XA_NOMIGRATE | 9 | Resumption must occur where suspension occurred
XA_HEURHAZ | 8 | The transaction branch may have been heuristically completed
XA_HEURCOM | 7 | The transaction branch has been heuristically committed
XA_HEURRB | 6 | The transaction branch has been heuristically rolled back
XA_HEURMIX | 5 | The transaction branch has been heuristically committed and rolled back
XA_RETRY | 4 | Routine returned with no effect and may be reissued
XA_RDONLY | 3 | The transaction branch was read-only and has been committed
XA_OK | 0 | Normal execution
XAER_ASYNC | -2 | Asynchronous operation already outstanding
XAER_RMERR | -3 | A resource manager error occurred in the transaction branch
XAER_NOTA | -4 | The XID is not valid
XAER_INVAL | -5 | Invalid arguments were given
XAER_PROTO | -6 | Routine invoked in an improper context
XAER_RMFAIL | -7 | Resource manager unavailable
XAER_DUPID | -8 | The XID already exists
XAER_OUTSIDE | -9 | Resource manager doing work outside
Parent topic: XA Troubleshooting


XA Switch Module Diagnostics

The SQL Server, DB2, Oracle, and ODBC switch modules have been coded to use the Consolidated Trace Facility to aid in debugging any errors returned during operation. We have provided a configuration file, ctf.cfg, by default located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source\enterpriseserver\xa directory, to serve as a starting point. To enable this facility:

  1. Edit the ctf.cfg file using any text editor and change the location parameter on line 6 to the directory where you want to store your trace files.
  2. Create a new system environment variable named MFTRACE_CONFIG, and set its value to the full path where ctf.cfg is located.
  3. Reboot your system to register MFTRACE_CONFIG.
  4. Start Enterprise Server.

Once enabled, the Consolidated Trace Facility writes SQLCODE, SQLSTATE and any associated SQL error messages to a trace file named cassi.textfile.processid.log, located in the directory you specified. Processid is the process ID under which the Enterprise Server SEP was running when the logfile was created.

Parent topic: XA Troubleshooting
Related information
Components Traced by CTF


XDB Diagnostics

You can configure the XDB XA Switch module to trace error conditions by enabling the XATrace option in the xdb.ini file as follows:

 [Trace]
XATrace=filename

Where filename is the full path to and filename of a file used to collect trace information. Each entry in this file contains a timestamp, the error message generated at that time, and possibly some diagnostic information. For example, following entry might be produced by an incorrect XA open string:

 XA PID = 7336 : 2011-08-29 15:27:04.247000 :
Error parsing connection string :
LOC = MYLOC, UID=MFIABC, XDBPWD='xxxxxxxx'
Reason = Invalid token XDBPWD at position 26
Parent topic: XA Troubleshooting


Handling XA Connection Errors

The way a server instance handles XA resource connection errors is controlled by the following environment variables:

ES_XA_RECONNECT
If this environment variable is set to True, when an error occurs on a call to XA, the server attempts to reconnect to the Resource Manager.

If it cannot reconnect, the server monitors the number of attempts made.

ES_XA_????_NB_RETRIES
The format for setting this is:
ES_XA_????_NB_RETRIES=nnnn

where ???? defines the XA ID, and nnnn is the number of subsequent XA call failures allowed before the SEP is recycled and the switch disabled. The default is 5 and its maximum value is 254. If you set nnnn to -1 or a number greater than 254, your switch module will never be disabled and reconnection attempts will continue indefinitely.

If the maximum number of call failures is reached, disabling your switch module, and ES_XA_RECONNECT is set to True, you can reenable the switch by starting Enterprise Server Monitoring and Control (ESMAC) and performing the following steps:

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To reenable the switch module:

  1. In the Resources options, select Active.
  2. Select XAT.
  3. Click on the relevant disabled resource from the list of active ones to open the details for that XAT.
  4. Check the Enable box.
Parent topic: Using XA-Compliant Resources


Configuring and Administering Enterprise Server Instances

The Enterprise Serveer user interface displays a list of the enterprise server instances that your installation maintains. The interface displays whether each enterprise server instance is running or stopped, and also some details for each server.

You can view and configure the details for each enterprise server instance, and for the ones that are running, you can access the Enterprise Server Monitor and Control (ESMAC) screen, to view and configure operating configurations.

  • Creating and Configuring Enterprise Server Instances
  • Connecting to a Server Instance
  • Administering Enterprise Server Instances using ESMAC
  • Stopping and Restarting an Installation
  • Using the Command-line Interface
Parent topic: Enterprise Server Configuration and Administration


Creating and Configuring Enterprise Server Instances

This section describes the processes and methods for creating, licensing, configuring, and deleting Enterprise Server instances.

  • To Add an Enterprise Server Instance
  • To Change the Number of ES licenses
  • To Copy an Enterprise Server Instance
  • To Delete an Enterprise Server Instance
  • To Delete a CCI Server
  • To Export Server Information
Parent topic: Configuring and Administering Enterprise Server Instances


To Add an Enterprise Server Instance

  1. On the Home page of Enterprise Server Administration, click Add at the bottom of the table of servers.
  2. Specify a name for the server in Name.
  3. Select the Working Mode for the server. If you are creating your server in an environment that supports both 32-bit and 64-bit applications, you must specify the server's working mode. A server with a 32-bit working mode can run only 32-bit applications. A server with a 64-bit working mode can run only 64-bit applications.
    Note:
    • You cannot change the working mode of the server once it has been created. You can however, change the mode when you copy or import a server.
  4. Choose a server type:
    • Click Micro Focus Enterprise Server if you plan to run COBOL application programs as services in a service-oriented architecture.
    • Click Micro Focus Enterprise Server with Mainframe Transaction Option if you plan to run CICS or JCL applications that have been migrated from the mainframe.
  5. Click Next>>.
  6. Specify a host name or IP address in the second of the two fields next to Server Address. You can leave the value as *:*, where the first asterisk (*) indicates the IP address of the current machine and the second indicates any available port number.
  7. Specify the location for files output by the Directory Server, such as trace and dump diagnostics files, in System Directory. This directory cannot be shared between enterprise servers. The default is %USERPROFILE%\Documents\Micro Focus\Net Express x.x\WORKAREA \es-name where es-name is the name of the enterprise server.

    If you specify a directory in this field, that directory must exist; Enterprise Server does not create it for you.

  8. Specify the start-up configuration you want in the fields under Startup Options.
  9. Specify any trace flags you want to be set in the fields under Trace Flags.
  10. Specify any configuration information the server requires in Configuration Information For information on what you can specify, see the section Configuration Information in the chapter Servers in your Configuration and Administration Guide.
  11. Specify a text description of the server in Description (optional).
  12. Click Add.
Parent topic: Creating and Configuring Enterprise Server Instances
Parent topic: Work with Servers
Related information
Configuring an Enterprise Server for a CICS service
Configuring an Enterprise Server for an IMS service
Configuring an Enterprise Server for a COBOL Program service


To Change the Number of ES licenses

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the enterprise server instance for which you want to change the number of licenses.

    The Server > Properties > General page is displayed.

  2. Specify the new number of licenses in Requested Licenses.
  3. Click OK.
Note:

If the status of the enterprise server instance is "Started", you can also change the number of licenses by clicking Details in the Current status column, then on the Enterprise Server > Control page, specifying the new number in Requested licenses and clicking Update. The Directory Server allocates additional licenses requested immediately, up to the number available. It removes any unwanted licenses immediately. However, any change you make here is temporary only; after you stop the server, the number of processes reverts to the number set on the Server > Properties > General page.

Parent topic: Creating and Configuring Enterprise Server Instances
Parent topic: Work with Servers


To Copy an Enterprise Server Instance

Note:

When you copy an enterprise server instance to another of the same working mode, the default behavior is to copy all the objects associated with it - communications processes, service listeners, services, request handlers and implementation packages. If the working mode of the new enterprise server instance is different from that of the existing server, the copy process cannot copy deployed services (that is, services that have an associated package and handler). Therefore, where the existing server has deployed services and you want the copy to have a different working mode, you must check Do not copy deployed services and packages.

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the enterprise server instance that you want to copy.
  2. On the Properties > General page click Copy.
  3. Specify the name of the new server in Name under ...to new server...
  4. Click the Working Mode checkbox if you want to change the working mode for the new server.
  5. In Initial Communications Processs Address under ...to new server... specify a host name or IP address to replace the first asterisk (*) and a port number to replace the second asterisk. You can leave the value as *:*, where the first asterisk (*) indicates the IP address of the current machine and the second indicates any available port number.
  6. Click Do not copy deployed services and packages if you do not want to copy the deployed services and packages to the new server.
  7. Click OK.
Parent topic: Creating and Configuring Enterprise Server Instances
Parent topic: Work with Servers


To Delete an Enterprise Server Instance

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server that you want to delete.
  2. Click Delete on the Properties > General page.
  3. Click OK on the Confirmation page.
CAUTION:

Deleting a registered server might cause application connection errors and loss of data.

Parent topic: Creating and Configuring Enterprise Server Instances
Parent topic: Work with Servers


To Delete a CCI Server

CAUTION:

Deleting a registered server might cause application connection errors and loss of data.

  • Click Delete to the left of the server name on the Home page.
Note:

Only CCI servers are deleted in this way. CCI servers are identified by type MFCCI.

Parent topic: Creating and Configuring Enterprise Server Instances
Parent topic: Work with Servers


To Export Server Information

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server for which you want to change the number of instances.

    The Server > Properties > General page is displayed.

  2. Click Export.
  3. On the Export Server page, specify the location to which you want to save the server information in Target directory. This defaults to C:\Documents and Settings\All Users\Micro Focus\Net Express\6.0\mfds.
  4. Click OK.

    If the location you specified contains previously exported information, you will now be presented with a confirmation page. This displays details of the information currently held in the target location. The details shown include: any Enterprise Servers, the Security Manager pool, and Security Manager lists and security configuration settings.

    If you confirm the export, existing information in the target location will be overwritten.

Note:
  • When you export server information, you create a backup copy of the server definition.
  • If you specify a directory that does not exist, it will be created if the directory containing it exists; otherwise it will not be created and the export will fail.
  • You can export all server definitions in the MF Directory Server repository. See To export the repository.
  • For instructions on importing server definitions, see To import a repository.
Parent topic: Creating and Configuring Enterprise Server Instances
Parent topic: Work with Servers


Connecting to a Server Instance

From Enterprise Server Administration you can connect to the enterprise server instance and access the details of the server that you want to monitor.

Provided the server has been started, you can access the Enterprise Server Monitoring and Control (ESMAC) screen from the server's Details screen.

You can return to Enterprise Server Administration by clicking Home from the left pane of these screens.

  • To start an enterprise server instance
  • To stop a server Instance
  • To Edit an Enterprise Server Instance
  • To Log On to Enterprise Server Administration
  • To Log Off from Enterprise Server Administration
  • Using Start and Stop Scripts
Parent topic: Configuring and Administering Enterprise Server Instances


To start an enterprise server instance

  1. In the table of servers on the Enterprise Server Administration Home page, find the row for the server that you want to start, and click Start in the Current Status column.

    A screen is displayed showing the server details and security configuration information. This screen also gives you the option of specifying operating system and Enterprise Server security credentials to be used.

  2. Click OK.

    The Enterprise Server Administration Home page is displayed, and progress is shown in the in the Status Log column. If you have Show local console checked on the Edit Server page, the enterprise server console daemon window appears indicating the progress.

  3. After a few seconds click Refresh on the Home page.

    When the server starts, the value in Current Status changes to Started.

Note:

If the server does not start for a prolonged time the reason might be that it has encountered an unrecoverable error but the server process remains active. In this case click Details to go to the Server > Control page, then click Stop Server to shut down the unsuccessful server process. Alternatively it might have encountered an unrecoverable error during the startup process and shut down without informing the Directory Server. In this case you can restart it using Start Server on the Server > Control page.

Parent topic: Connecting to a Server Instance
Parent topic: Work with Servers
Parent topic: Configuring the Enterprise Server
Parent topic: To change the SIT associated with a server
Related concepts
Configuring IMS Printers
Related tasks
To define specific printers for an IMS-enabled enterprise server
To enable printer security for an IMS-enabled enterprise server
Related information
Configuring and Starting Transaction Data Collection
Viewing HSF Information in ESMAC


To stop a server Instance

This procedure describes how to stop an enterprise server instance from the Enterprise Server Administration screen. You can use the server shut down process if you need more control over the process, or you want to produce a system dump.

  1. In the table of servers on the Home page of Enterprise Server Administration, find the row for the server that you want to stop, and click Stop in the Current Status column.

    A screen is displayed indicating the server details and security configuration information. This screen also gives you the option of specifying operating system and Enterprise Server security credentials to be used. For more about security credentials, see the help section on Enterprise Server security.

  2. Click OK.

    The Home page of Enterprise Server Administration is displayed, and the Status Log column displays server termination progress messages. If you have Show local console checked on the Edit Server page, the enterprise server console daemon window appears, showing progress messages.

  3. After a few seconds click Refresh on the Home page.

    The value in Current Status changes to "Stopped".

Note:

If the server remains in the "Stopping" state for a prolonged time the reason might be that it has encountered an unrecoverable error during the shutdown. You can force a shutdown by clicking Details to go to the Server > Control page, then clicking Force Stop. Alternatively it might have encountered an unrecoverable communications error and shut down without informing the Directory Server. In this case you can restart it using Start Server on the Server > Control page.

Parent topic: Connecting to a Server Instance
Parent topic: Work with Servers
Parent topic: To change the SIT associated with a server


To Edit an Enterprise Server Instance

  1. In the table of servers on the Home page of Server Enterprise Edition Administration, click Edit to the left of the row for the server that you want to edit.
  2. The top row of tabs displays Server, Listeners, Services, Handlers and Packages. Select the tab for the type of attribute you want to edit.
  3. Click the Edit button for each listener, service, handler or package that you want to edit.
  4. Update the attributes as required.
  5. Click OK.
  6. Click the Server tab.
  7. Click one of the tabs: Properties, Control, and Diagnostics to select the type of attribute you want to update. The Properties page is the default.
  8. What you do next depends on what tab you selected in the previous step:
    • If you selected Properties, click one of the tabs General, XA Resources, MSS, Scripts, Permissions and Security to select the page containing the attributes you want to update. The General page is the default.
    • If you selected Control, you see the Control page. If the server is not running all you see is a message giving the server state. If the server is running, the number and type of processes will be displayed. Click ES Monitor & Control... to display server information and diagnostics.
    • If you selected Diagnostics, click one of the tabs Trace, Dump, ES Console and CS Console to select the page containing the attributes you want to update. The Trace page is the default.
  9. Update the attributes on the page as required.
  10. Click OK.
Parent topic: Connecting to a Server Instance
Parent topic: Work with Servers


To Log On to Enterprise Server Administration

  1. Click Log On on the menu on the left-hand side of the Enterprise Server Administration home page.
  2. Specify your user ID in User ID.
  3. Specify your password in Password.
  4. Click OK.
  5. Click Continue on the Welcome page.
Note:

You can see the Log On option only if user access is restricted and you are not currently logged on.

Parent topic: Connecting to a Server Instance
Parent topic: Log On and Off


To Log Off from Enterprise Server Administration

  • Click Log Off on the menu on the left-hand side of an Enterprise Server Administration Web page.
    Note:

    You can see the Log Off option only if user access is restricted and you are currently logged on.

Parent topic: Connecting to a Server Instance
Parent topic: Log On and Off


Using Start and Stop Scripts

You can supply start and stop scripts to take additional actions before or after starting or stopping an enterprise server. You must include the casstart command in your start script, and the casstop command in your stop script. If you omit them the server will not actually be started or stopped.

The Directory Server sets some environment variables in the scripts' environment, which you can use in your scripts:

ES_HOME | Server work directory (location of log files); this comes from the System Directory field on the Add Server or Edit Server > Properties > General page.
ES_SERVER | Server name (note that Enterprise Server will use this as the server name if no -r switch is specified on casstart or casstop).
MFDS_PORT | The port on which the Directory Server listens (usually 86).
For example, the start script could be used to set environment variables for the server, as follows;
set MY_VARIABLE=value
rem start the enterprise server
echo Enterprise Server %ES_SERVER% is starting
casstart

where value is the value of the environment variable.

If your stop script contains commands that should only be executed after the server has stopped completely, it should pause after executing casstop until thecascd process for that server has exited. This is because the casstop command returns before the server has actually finished shutting down. You would need third-party tools to do this on Windows.

Then you could back up the log files or perform other tasks that should only be started after the server finishes shutting down.

When you click the server's Start or Stop button, the commands that you specify are used to generate a Windows batch file, which is then executed.

You can also create an "On server not responding" script. This script will be executed when all of the running communications processes for a server have entered the "Not Responding" state. That might indicate that the server is hung or has crashed, or it might result from network connectivity problems between the Directory Server and the enterprise server (if they run on different systems). You can use this script to notify a system administrator of the problem.

You specify start, stop and "On server not responding" scripts on the Edit Server > Properties > Advanced page.

Parent topic: Connecting to a Server Instance


Administering Enterprise Server Instances using ESMAC

Enterprise Server Monitor and Control (ESMAC) enables you to view and control enterprise server instances, and the services, packages, and handlers that run on them.

Note: The enterprise server instance to administer must be started before the ESMAC screen becomes available.

From ESMAC, you can:

  • Monitor and control an enterprise server instance, including service execution processes, services, packages, and so on.
  • Monitor the current activity and performance of enterprise server instances and applications, and monitor the trends in that activity and performance.
  • Obtain diagnostic information (dumps and traces) for your applications.

ESMAC enables you to define who can use ESMAC, and the permissions they have to view and update resources. For more information on setting up ESMAC users, see the section Security.

  • To Start ESMAC for an enterprise server instance
  • To Shut Down a Server from ESMAC
  • Viewing Enterprise Server Instance Details
  • The ESMAC User Interface
  • Defining Enterprise Server Instance Administrators
  • Managing an Enterprise Server Instance's SEPs
  • Interacting with Services
Parent topic: Configuring and Administering Enterprise Server Instances


To Start ESMAC for an enterprise server instance

The enterprise server instance must be started before the ESMAC screen becomes available.

  1. Open the Enterprise Server Administration user interface.
  2. In the list of servers next to the server to access, click Details in the Status column to display the details screen for the enterprise server instance.
  3. On the enterprise server instance details screen, click the ES Monitor & Control button.

    The ESMAC screen is displayed.

Parent topic: Administering Enterprise Server Instances using ESMAC
Parent topic: Administer a Server Using ESMAC
Parent topic: To change the SIT associated with a server
Related concepts
Configuring IMS Printers
Related tasks
To define specific printers for an IMS-enabled enterprise server
To enable printer security for an IMS-enabled enterprise server


To Shut Down a Server from ESMAC

You can shut down a server from the Monitor and Control (ESMAC) screen. This allows you more control over the shutdown process, and you can specify that the shut down process produces a dump.

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To shut down a server

  1. Click Control.
  2. If you want a dump, check Dump. A system dump is produced at the beginning and at the end of the final stage of system shutdown.
  3. If you want an immediate shutdown, check Immediate. If you force an immediate shutdown, you will see the "The page cannot be displayed" error, as there is no longer a server to connect to.
  4. Click Shutdown.
Parent topic: Administering Enterprise Server Instances using ESMAC
Parent topic: Administer a Server Using ESMAC


Viewing Enterprise Server Instance Details

ESMAC provides information about the enterprise server you are currently viewing. Use the tabs at the top of the page to access the information that you want.

For example, click the Server tab to display the Server Information page. The Server Information page provides information that enables you to monitor the operation of the enterprise server, providing details on:

  • Times - such as the time the enterprise server was started, and the time for which it has been available.
  • Counts - such as the number of services, dumps, and trace blocks.
  • Sizes - such as maximum number of tasks enabled on the server, the amount of memory available, and the size of diagnostic files.
  • States - such as the dump state and the currently set dump datasets.
  • Activity - average times taken to complete tasks.

The information provided enables you to quickly determine the state of the server. For example:

  • The Activity information enables you to see whether any services are behaving in unexpected ways by, for example, taking more time to complete than you expect.
  • The State information provides information on the current dump state, showing, for example, that a dump is taken when the system abends, but not when the service abends.

Based on the information presented on this page you can make changes using other ESMAC pages that you can access using the tabs.

Parent topic: Administering Enterprise Server Instances using ESMAC


The ESMAC User Interface

The ESMAC interface is displayed using a browser. You can, therefore, monitor and control enterprise server instances across the Internet, or your intranet, from a browser.

When you first view ESMAC, the Server Information page is displayed, as shown below:

Figure 1. ESMAC Server information page
ESMAC Server information page

ESMAC enables you to:

  • Obtain information about the server you are currently connected to.
  • Monitor services occurring on the server.
  • View and change various parameters associated with server, such as the number of service execution processes, the active diagnostic datasets, and any trace control flags set.
  • View information about service execution processes (SEPs), stop SEPs and obtain trace information for them.
  • View information about client processes running on the server.
  • View console logs, and dump and trace information.
  • View information about the services, packages and request handlers defined on the server.
  • Add, delete and change the permissions of users who can administer servers.
  • View the environment variables associated with the server.
  • Login as an administrator.

The ESMAC interface is split into two areas:

  • A menu, in a sidebar on the left side of the page, which provides buttons with which you can control ESMAC.
  • The main body of the page, which displays the monitor and control information. The information and controls available here depend on the button you click in the menu.
  • Sidebar
  • Body
  • Status Line
  • Refreshing a Page
Parent topic: Administering Enterprise Server Instances using ESMAC


Sidebar

The ESMAC menu appears in a sidebar on the left side of the page. You see only the menu options that are appropriate to your permission level.

Parent topic: The ESMAC User Interface


Body

Control and monitor information is presented in the body of the page.

The body of the page changes when you click a button in the menu. The body of the page usually contains one or more controls, which you can use to enter and modify information required by the enterprise server instance.

Parent topic: The ESMAC User Interface


Status Line

The status line appears at the top of the page. This line tells you:

  • The enterprise server you are connected to.
  • The server on which the enterprise server is running.
  • Your user name.
  • The date and time at which the current page was displayed.
Parent topic: The ESMAC User Interface


Defining Enterprise Server Instance Administrators

This topic describes how to set up the users who can access Enterprise Server administration, and set the appropriate permissions for those users.

The default security access configuration depends on how your system is set up. A system can be set up with or without the special user mfuser defined:

  • If mfuser is not defined, by default all users can perform any action.

    For an installation used for development, we recommend that you do not configure an mfuser.

  • If mfuser is defined, the default security level is the same as that defined for mfuser.

    For an installation used for production, we recommend that you do configure an mfuser, and give mfuser only minimum privileges.

You create user names, passwords, and set permissions using the Users page.

You can see which administrators are currently set up by accessing the ESMAC screen and clicking Users. This displays the Users page, which lists all users. Click Details on the Users page to get detailed information on a user's permissions.

If you do not have the required read or update permissions, the options available to you in ESMAC are limited. You can only:

  • View server information. See the section Server Information for details.
  • Monitor the performance. See the section Monitoring Services for details.
  • View environment variables. See the section Environment Variables for information.
  • Change to a different user.
Parent topic: Administering Enterprise Server Instances using ESMAC
Related information
Enterprise Server Execution Control Under Windows


Managing an Enterprise Server Instance's SEPs

You can view details of the SEPs running in an enterprise server instance using ESMAC. You do this using the Control page, which can be displayed by clicking Control on the ESMAC menu.

For example, you can view various information about an enterprise server instance, including the dump state. If you wanted to change the dump state, you would use the Control page.

The Control page enables you to veiw the following details:

  • The number of SEPs running on the enterprise server instance.
  • Dump and trace parameters, including the size of the auxiliary trace and dump file, the datasets to be used for dumps and traces, and so on.
  • Whether programs are reloaded each time they are invoked.
  • The trace control flags set.
  • The size of the data blocks passed across shared memory for HTTP output.
  • The timeout value that will be used for all users of the enterprise server instance who do not have a timeout value set for their user ID.

You can also shut down the enterprise server instance from this page, and you can obtain a dump of the server on shutdown.

  • About Service Execution Processes
  • To Change the Number of SEPs
Parent topic: Administering Enterprise Server Instances using ESMAC


About Service Execution Processes

Service execution processes are provided within an enterprise server. COBOL applications are executed within these service execution processes. For more information on service execution processes, see the section Service Execution Processes in the chapter Configuration in your Enterprise ServerConfiguration and Administration Guide.

You can view information on the SEPs running on an enterprise server by displaying the SEPs (Service Execution Processes) page. To do this, click SEPs in the menu.

The SEPs (Service Execution Processes) page displays details for all SEPs on the current enterprise server, including:

  • The process ID
  • The type of SEP
  • The task number
  • The number of services that have run in this SEP

You can also terminate SEPs and create and view traces for SEPs.

Parent topic: Managing an Enterprise Server Instance's SEPs


To Change the Number of SEPs

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server for which you want to change the number of instances.

    The Server > Properties > General page is displayed.

  2. Specify the new number of instances in Service execution processes.
  3. Click OK.
Note:

If the status of the server is "Started", you can also change the number of service execution processes by clicking Details in the Current status column, then on the Enterprise Server > Control page, specifying the new number in Requested service execution processes and clicking Update. The new processes will take a few seconds to appear in the list. However, any change you make here is temporary only; after you stop the server, the number of processes reverts to the number set on the Server > Properties > General page.

Parent topic: Managing an Enterprise Server Instance's SEPs
Parent topic: Work with Servers


Interacting with Services

Programs running as services in an enterprise server can include ACCEPT FROM CONSOLE and DISPLAY UPON CONSOLE statements. When execution reaches a DISPLAY UPON CONSOLE statement, the display text is displayed in the console log, and the service continues. When execution reaches an ACCEPT FROM CONSOLE statement, the service pauses and asks for input using pages in ESMAC. You must provide the input in order for the service to continue executing.

  • To Reply to an ACCEPT FROM CONSOLE Statement
Parent topic: Administering Enterprise Server Instances using ESMAC


To Reply to an ACCEPT FROM CONSOLE Statement

  1. Click Reply in the menu. You see a page listing all the current pending ACCEPTs. They are identified by PID (Process ID).
  2. Click Select next to the process that you want to reply to.
  3. Specify your reply in the Enter field, then click Reply just above it.
Parent topic: Interacting with Services
Parent topic: Administer a Server Using ESMAC


Stopping and Restarting an Installation

Before stopping the Directory Server or shutting the machine down, you should stop all enterprise server instances that are running. When you stop the Directory Server using Enterprise Server Administration, there is an option to stop all servers first.

On system restart, unless Restore Servers on Startup on the Configure Options page is checked, the Directory Server does not automatically start any enterprise server instances that were not stopped before shutdown (and so are still marked as "Started" in the Directory Server repository). If the Server Monitor is enabled on the Configure Options page it will check whether these enterprise server instances are still active, and will mark them as "Not Responding" in the Enterprise Server Administration servers table on the Home page. Each enterprise server instance will then need to be restarted manually. You can do this by clicking Details and then clicking Start Server for each server.

If Restore Servers on Startup is selected, when Directory Server is restarted, it reads the list of servers that were previously marked as started, checks to see if they are running, and if not, attempts to restart them.

Parent topic: Configuring and Administering Enterprise Server Instances


Using the Command-line Interface

A number of commands are available for administering servers. You can run these commands from an application command prompt. For example to access the Windows application command prompt from a Micro Focus Studio Enterprise Edition installation, from the Start menu, select: Micro Focus Studio Enterprise Edition > Compatibility Tools > Net Express Command Prompt Start > All Programs > Micro Focus Studio Enterprise Edition x.x> Tools > Product Name Command Prompt.

  • casdump
    Forces a system dump.
  • casdup
    Formats a system dump or auxiliary trace so that it is suitable for analysis.
  • cassi
    Starts a service execution process. You should use this command only when you want to debug a service, using the /a option.
  • casstart
    Starts an enterprise server.
  • casstop
    Stops an enterprise server.
Parent topic: Configuring and Administering Enterprise Server Instances


casdump

Forces a system dump.

Syntax:

casdump [/res-name]
        [/d]
        [/f]
        [/i]
        [/b]
        [/udump-code]

Parameters:

/res-name | Name of the enterprise server to dump. Defaults to ESDEMO
/d | Do not lock shared memory
/f | Dump the FAQE chain
/i | Trigger an IMS TM dump
/b | Dump shared memory as a block
/udump-code | Sets the dump code for the dump

Dependencies:

To use this command:

  • You must have started the enterprise server named with the /r flag first.
  • You must be running under the same user ID as the enterprise server named with the /r flag. If the Directory Server was started as a system service, and the enterprise server was started using the Administration interface, then the enterprise server is probably running under the LOCAL_SYSTEM user ID, and this command will not work. For more information see the section Starting and Stopping the Directory Server in the chapter Introduction to Enterprise Server Administration in your Enterprise Server Configuration and Administration Guide.
Note:

The parameters /d and /i cannot be used at the same time.

Comments:

On UNIX you can use a dash (-) before a parameter as an alternative to a forward slash (/).

Parent topic: Using the Command-line Interface
Parent topic: Administration and Configuration Commands


casdup

Formats a system dump or auxiliary trace so that it is suitable for analysis.

Syntax:

casdup [/res-name]
       [/a|/b|/x]
       [/c]
       [/d]
       [/ffile-name]
       [/ifile-name]
       [/l]
       [/n]
       [/mxx{,xx}...]
       [/pnn{,nn}...]
       [/snnnnnn]
       [/w]
       [/0]
       [/1]
       [/2]
       [/3]
       [/4]
       [aux]

Parameters:

/res-name | Name of the enterprise server that owns the dump. Defaults to ESDEMO
/a | Use the A data set (default)
/b | Use the B data set
/x | Use the X data set (for external dumps produced by casdump /d)
/c | Display only the application program information entries
/d | Display module IDs
/ffile-name | The name of the output formatted dump file
/ifile-name | The name of the input trace file. Overrides /a, /b, /r, /x and aux
/l | List summary information only
/n | Omit page headers
/mxx{,xx}... | The module IDs to be included in the trace
/pnn{,nn}... | The process IDs to be included in the trace
/snnnnnn | Split output after every nnnnnn lines
/w | Wide trace format
/0 | Module/transaction trace
/1 | /0 level trace plus API
/2 | /1 level trace plus RTS and EXTFH trace
/3 | All formatted trace
/4 | All trace (default)
aux | Format an auxiliary trace dump data set. The default is that a system dump is formatted

Dependencies:

You must have created a system dump or auxiliary trace before you can issue casdup.

Comments:

You can use a dash (-) before a parameter as an alternative to a forward slash (/).

Parent topic: Using the Command-line Interface
Parent topic: Administration and Configuration Commands


cassi

Starts a service execution process. You should use this command only when you want to debug a service, using the /a option.

Syntax

cassi [/res-name]
      [/a]

      [/atterminal-id]     (CICS specific)
      [/axtransaction-id]  (CICS specific)

      [/bjob-class-list]   (JCL specific)
      [/poutput-class-list](JCL specific)
      [/qprinter-name]     (JCL specific)
      [/zprinter-exit]     (JCL specific)

      [/v]                 (IMS specific)
                      [/wmpr-name]         (IMS specific)

Parameters

General
/res-name | Name of the enterprise server for which to start a service execution process. Defaults to ESDEMO
/a | Debug any application that runs in this service execution process
CICS specific
/atterminal-id | Debug any application that runs in response to a request from the terminal identified by terminal-id
/axtransaction-id | Debug any application that runs in response to a non-facility transaction identified by transaction-id
JCL specific
/bjob-class-list | Start a batch inititiator SEP to handle the job classes named in job-class-list
[/poutput-class-list] | Start a batch printer SEP to handle the output classes named in output-class-list
[/qprinter-name] | Send output to printer-name, which must be the name of a printer defined on your machine.
[/zprinter-exit] | Direct output through the program printer-exit
IMS specific
[/v] Specify IMS transaction classes when debugging (using the /a parameter)

In order to debug an IMS transaction running in a specific IMS region, from a telnet shell, after you have unset DISPLAY and used the appropriate umask, start the command:

cassi –a –v <trans-classes> -r REGION
where <trans-classes> contains the IMS classes that you want to debug for.
[/wmpr-name] Name of the IMS MPR to be used.

Dependencies

To use this command:

  • You must have started the enterprise server named with the /r flag first.
  • You must be running under the same user ID as the enterprise server named with the /r flag. If the Directory Server was started as a system service, and the enterprise server was started using the Administration interface, then the enterprise server is probably running under the LOCAL_SYSTEM user ID, and this command will not work. For more information see the section Starting and Stopping the Directory Server in the chapter Introduction to Enterprise Server Administration in your Enterprise Server Configuration and Administration Guide.

Comments:

If the execution of this command takes the number of service execution processes over the configured number, Enterprise Server will terminate one of the service execution processes.

On UNIX you can use a dash (-) before a parameter as an alternative to a forward slash (/).

Parent topic: Using the Command-line Interface
Parent topic: Administration and Configuration Commands


casstart

Starts an enterprise server.

Syntax:

casstart [/res-name] [/oconfig-name][/uusername] [/ppassword] [/cgroup] [/w]

Parameters:

/res-name | Name of the enterprise server to start. Defaults to ESDEMO
/oconfig-name | When using this option in MSS enabled regions, the config-name should be the name of a SIT. The region will start up using the specified SIT rather than the one defined in the Enterprise Server Administration pages.
/uuserid | An authorized user. This user must exist within the security domains of both: the enterprise server and MF Directory Server. That is, the security configuration for both enterprise server and Directory Server must be able to verify the user credentials supplied. Note that enterprise server and Directory Server may be using different security managers. Therefore, it may be necessary that the user is defined in more than one security repository. In order to update Directory Server status information, within the Directory Server domain, the user must have modify permission on the appropriate enterprise server resource within the Servers resource class. In order to successfully run the casstart command, within the enterprise server's security domain, the user must have alter permissions on the casstart resource within the OPERCMDS resource class. Note: This is only required if you have configured security.
/ppassword | The password for the user
/cgroup | The sign-on group for the user. By default, when a user requests access to a resource, some external security managers will only apply rules that refer to that user and the user's current sign-on group. If this option is not specified, the user is signed on with a default group as determined by the security manager.
/wdelay | The delay (in seconds) to wait before starting the region. If you omit the /w option the system does not wait, or if you specify /w without delay the system waits for 15 seconds.

Comments:

On UNIX you can use a dash (-) before a parameter as an alternative to a forward slash (/).

The command line utilities: casstart, casstop, casfile, casout, and cassub can be invoked by program using the call interface and passing the command line parameters to the call. For instance, we might use the following to start a server:

01 ws-cmd-parms.
     05 ws-cmd-len         pic x(02) comp-x.
     05 ws-cmd-value     pic x(1024).
......
......
......
      *> Start up the Server
      move 1                to ws-cmd-len
      move low-values  to ws-cmd-value
      string "-rMyRegion" delimited by size
               " -uSYSAD -pSYSAD /w" delimited by size
               into ws-cmd-value with pointer ws-cmd-len
      end-string
      subtract 1 from ws-cmd-len
      call 'casstart' using ws-cmd-parms end-call
......
......

When used on platforms that support running both 32-bit and 64-bit applications, casstart checks its environment to determine whether to start the Enterprise Server in 32-bit or 64-bit mode. If the server's working mode (as specified when it was created) does not match the mode specified by the environment, casstart will fail and issue an appropriate message. On Unix platforms, you choose the mode by setting the COBMODE environment variable to 32 or 64 as appropriate. On Windows platforms, you can choose the environment by choosing the relevant command prompt from the Start menu.

Parent topic: Using the Command-line Interface
Parent topic: Administration and Configuration Commands


casstop

Stops an enterprise server.

Syntax:

casstop [/res-name] [/sprototype:host:WebServiceport] [/lserver-name] [/i] [/w] [/f] [/uuserid] [/ppassword] [/ggroup] [/tshutdowntransaction

Parameters:

/res-name Name of the enterprise server to stop. Defaults to ESDEMO. To use this option:
  • You must have started the enterprise server named with the /r flag first.
  • You must be running under the same user ID as the enterprise server named with the /r flag. If the Directory Server was started as a system service, and the enterprise server was started using the Administration interface, then the enterprise server is probably running under the LOCAL_SYSTEM user ID, and this command will not work. For more information see the section Starting and Stopping the Directory Server in the chapter Introduction to Enterprise Server Administration in your Enterprise Server Configuration and Administration Guide.
Note:

When calling this utility from JCL or from a WEB service (that is, when you are running the utility within a SEP) you cannot use the /r option to connect to the server. Where this is the case, you must use the /s or /l options to connect to the server.

or:
/sprototype:host:WebServiceport | Location of the Web Services listener for the enterprise server to be stopped. For example, /stcp:localhost:9003
or:
/lserver-name | Name of the enterprise server. This differs from the /s option, in that it performs a lookup to locate the Web Service for the enterprise server
/i Immediate shutdown

When you use this option, all SEPs and all in-progress transactions are immediately terminated, and the PLT shutdown is not run. The region then terminates normally.

/w | Wait for shutdown to be completed
/f Force a shutdown. This option cannot be used in conjunction with /s or -/l

When you use this option, all processes are killed and the region stops with no shutdown processing.

/uuserid An authorized user. This user must exist within the security domains of both: the enterprise server and MF Directory Server. That is, the security configuration for both enterprise server and Directory Server must be able to verify the user credentials supplied. Note that enterprise server and Directory Server may be using different security managers. Therefore, it may be necessary that the user is defined in more than one security repository.

In order to update Directory Server status information, within the Directory Server domain, the user must have modify permission on the appropriate enterprise server resource within the Servers resource class. In order to successfully run the casstop command, within the enterprise server's security domain, the user must have alter permissions on the casstop resource within the OPERCMDS resource class.

Note:

This is only required if you have configured security.

/ppassword | The password for the user
/cgroup The sign-on group for the user. By default, when a user requests access to a resource, some external security managers will only apply rules that refer to that user and the user's current sign-on group.

If this option is not specified, the user is signed on with a default group as determined by the security manager.

/ttransaction-id | The MSS shutdown transaction to run. If none is specified, this defaults to CQIT.
Note:

Options /r, /s, /l are alternative ways of identifying the enterprise server to be stopped and are mutually exclusive.

Note:

Where an external security manager is configured for the enterprise server, a userid and password must be supplied when stopping it.

Comments:

On UNIX you can use a dash (-) before a parameter as an alternative to a forward slash (/).

Many of the command line utilities, including casstart, casstop, casfile, casout, and cassub, can be invoked by program using the call interface and passing the command line parameters to the call. For an example, see casstart.

Parent topic: Using the Command-line Interface
Parent topic: Administration and Configuration Commands


Configuring Client-Server Communications

A communications process is the component of an enterprise server instance that handles communications between clients and the enterprise server instance. It contains a number of service listeners. An enterprise server instance is created with one communications process, but you can add more.

A service listener accepts incoming client requests on behalf of services. A service can have multiple listeners, and a listener can accept client requests on behalf of multiple services.

  • About Communications Processes
  • Displaying Communications Process and Listener Information
  • Securing Communications
  • Configuring Communications Processes
  • Configuring Listener Conversation Types
  • Configuring Listeners
Parent topic: Enterprise Server Configuration and Administration


Displaying Communications Process and Listener Information

You can see the information held in the repository for communications processes and listeners by clicking Details on the Home page in the Communications Process column for the enterprise server instance that you are interested in. The communications process and listener table is shown below.

Figure 1. Communications Processes and Service Listeners Table
Communications Processes and Service Listeners Table

The information for a communications process is as follows:

  • Auto-start - whether or not the communications process is started automatically when the enterprise server instance starts.
  • Listeners - the number of listeners owned by this communications process.
  • Process ID - the process ID of this communications process. This is present only when the communications process is running.
  • Control Channel Address - this is an internal address used by enterprise server instance components for communications. An asterisk at the end of the IP address or port number indicates that this part of the address is not fixed but supplied by the host system on startup.
  • Status information - you can see the current status and the time of the last status change.
  • Status log - this supplies information about the most recent event that occurred for this communications process.
  • Version - this is the version number of the communications process software.

Communications processes do not have names; instead they have sequence numbers. The communications process that is automatically created when you add a new enterprise server instance is Communications Process 1, and any further communications processes that you create are numbered in ascending order of creation. When you delete a communications process, existing communications processes are not renumbered, however, the next communications process you create will use the same number as the process that was deleted - the lowest available number.

The information for a listener is as follows:

  • Name
  • Address - this is the network address on which the listener listens for incoming client requests. An asterisk at the end of the IP address or port number indicates that this part of the address is not fixed but supplied by the communications process on startup.
  • Status information - you can see the current status and the time of the last status change
  • Status Log - this supplies information about the most recent event that occurred for this listener
  • Conversation Type - this indicates what type of client requests the listener handles. Possible values are:
    • Web Services and J2EE for SOAP or J2EE requests
    • Web for World Wide Web (HTTP) requests; Enterprise Server uses a Web listener for service deployment
    • Fileshare for Fileshare client requests
    • TN3270 for requests from TN3270 terminals
    • MSS Inter-System Communication, MSS Inter-System Communication (inbound only) and CICS Transaction Gateway for CICS Intersystem Communication (peer-to-peer) and for requests for CICS transactions from non-CICS programs
    • Custom for any other type of requests

    TN3270 and the MSS ISC types are only available for use with MSS.

  • Custom configuration data - for more information see the section Configuration Information
  • Description

Listener display flters control how much listener information you can see. These appear just above the infomation for the first communications process. There are three listener display filters:

  • Process (communications process)
  • Conversation type
  • Status

Each has a number of options that vary depending on the field; for example the Process filter allows you to select to see no listener details, all listener details, or listener details for a particular communications process, while the Status filter allows you to see all listener details regardless of status or just listener details for listeners with a specifc status:

For example, to see listener details for communications process 2, choose 2 in Listener Display Filters Process; to see only Web Services and J2EE listeners, choose Web Services and J2EE in Listener Display Filters Conversation Type; to see all listener details choose All in all three filters. Use all the filters in combination to achieve the maximum control over the level of detail you see.

When you first see the Communications Process and Listeners table, the Process filter is set to None and the other filters are set to All.

Parent topic: Configuring Client-Server Communications
Related information
Configuration Information


Securing Communications

There are a number of additional configuration options, for logging and setting an SSL passphrase, that can be set in the file mf-server.dat, located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin. These are mostly options that require setting before the Micro Focus Communication Server (MFCS) contacts the MF Directory Server. In the case of logging, this can be useful where there are problems with the connection between MFCS and MFDS. For instructions on the use of mf-server.dat to configure logging for MFCS, see the topics on securing communications in the Security section, or see the topic Communications Process Log Files in the Troubleshooting section.

Parent topic: Configuring Client-Server Communications


Configuring Communications Processes

Your responsibilities as administrator include:

  • Adding communications processes as required, by copying and editing existing ones
  • Updating and deleting communications processes as required
  • Starting and stopping communications processes
  • Adding, updating and deleting listeners as required
  • Associating listeners with services and disassociating them
  • Starting and stopping listeners
Note: You can use the Configuration Information field on the Edit Communications Process page, and the Add Listener and Edit Listener pages for configuration data specific to a communications process or a listener.
  • Editing Communications Settings
  • To Edit a Communications Process
  • To Copy a Communications Process
  • To Delete a Communications Process
  • To Start a Communications Process
  • To Stop a Communications Process
  • To View Communications Processes and Listeners for an Enterprise Server Instance
  • To View Statistics for a Communications Process
Parent topic: Configuring Client-Server Communications


Editing Communications Settings

The Configuration Information field on the Edit Communications Process page can contain the following sections and settings:

[CCI]
timeout-grain=timeout-grain-number-of-seconds
[ISC]
listener-wait=listener-wait-number-of-seconds
[listeners]
logging=logging-level
[MFCC]
trace=trace-setting
[threading]
limit=number-of-threads

The parameters are explained below.

  • timeout-grain
    Specifies the CCI timeout in seconds. Any MFCS timeout will be rounded up to a multiple of this value.
  • listener-wait (MSS only)
    Specifies how many seconds to wait for a local ISC listener to become available when starting an ISC outbound connection to connect to another MSS instance or other ISC-compatible system.
  • logging
    Enables additional logging when starting listeners.
  • trace
    Controls common client (MFCC) tracing, in conjunction with the MFCC configuration file.
  • limit
    Specifies the thread limit.
Parent topic: Configuring Communications Processes


timeout-grain

Syntax:

timeout-grain=timeout-grain-number-of-seconds

Properties:

Default: 5 seconds

Comments:

The communications process (MFCS) lets each conversation and listener set its own timeout value for receiving data, but because MFCS runs as part of CCI, and CCI only maintains one global timeout value for the whole process, the granularity of MFCS timeout values is limited by the CCI timeout setting. Setting a larger value than the default will make MFCS timeouts less precise, but will reduce CPU consumption, interrupts, and other factors, improving performance.

Parent topic: Editing Communications Settings


listener-wait (MSS only)

Syntax:

listener-wait=listener-wait-number-of-seconds

Properties:

Default: 10 seconds

Comments:

MFCS needs to have an ISC listener available to support outbound ISC communications. This is most useful if you have outbound ISC connections configured at startup.

Parent topic: Editing Communications Settings


logging

Syntax:

logging=logging-level

Parameters:

logging-level Can be one of:
0 | No extra logging (default)
1 or Yes | Basic logging, which includes extra CCI error information
2 | Also log CCI loading and configuration, and listener address information
3 | Also log SSL configuration
Default: 0

Properties:

Default: 0
Parent topic: Editing Communications Settings


trace

Syntax:

trace=trace-setting

Parameters:

trace-setting
One of:
0 | Disable MFCC tracing
any non-zero value | Enable MFCC tracing during MFCS startup

Properties:

Default: 0

Comments:

MFCC tracing is off by default but can be enabled in the configuration file, which by default is mf-client.dat, located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin, but you can create your own configuration file of any name or location and identify it using the MFC_CONFIG environment variable. MFCS uses MFCC during startup to verify that its control channel is working. If MFCC tracing is enabled in the configuration file, you can set this option to “0” to disable MFCC tracing in MFCS. Alternatively, you can set it to a non-zero value to enable MFCC tracing during MFCS startup, to diagnose a failure there.

Parent topic: Editing Communications Settings


limit

Syntax:

limit=number-of-threads

Properties:

Default: 2000 on Windows and 200 on UNIX

Comments:

MFCS limits the number of threads it will try to start, in order to avoid exceeding system limits. Currently, MFCS uses one thread for each active conversation, so this limit directly affects the number of simultaneous conversations. Note that the operating system might not allow MFCS to actually create as many threads as the number you set.

Parent topic: Editing Communications Settings


To Edit a Communications Process

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details in the Communications Processes cell for the server whose communications process you want to edit.
  3. On the Edit Server - Listeners page click Edit to the left of the row for the communications process you want to edit.
  4. Update the attributes of the communications process as required.
  5. Click OK.
Note:

You can make some changes to a communications process on the Edit Server - Listeners page: toggle Auto-start, and stop and start the communications process.

Parent topic: Configuring Communications Processes
Parent topic: Work with Communication Processes and Service Listeners


To Copy a Communications Process

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details in the Communications Processes cell for the server whose communications process you want to copy.
  3. On the Edit Server - Listeners page click Copy at the top right-hand side of the area that shows the details of the communications process you want to copy.
  4. In Control Channel Address specify a host name or IP address to replace the first asterisk (*) and a port number to replace the second asterisk. You can leave the value as *:*, where the first asterisk (*) indicates the IP address of the current machine and the second indicates any available port number.
  5. Check Auto-start if you want the new communications process to be started automatically when the enterprise server starts or, if the enterprise server is already running, after it is created. It is checked by default.
  6. Click OK.
Note:

When you copy a communications process, you also copy all the listeners associated with it; the new communications process has exactly the same number and type of listeners as the original, with the same names. You might want to edit the names to reduce confusion.

Parent topic: Configuring Communications Processes
Parent topic: Work with Communication Processes and Service Listeners


To Delete a Communications Process

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details in the Communications Processes cell for the server whose communications process you want to delete.
  3. On the Edit Server > Listeners page click Delete at the top right-hand side of the area that shows the details of the communications process you want to delete.
  4. Click Delete on the confirmation page.
Note:

If an enterprise server has only one communications process, you cannot delete it.

Parent topic: Configuring Communications Processes
Parent topic: Work with Communication Processes and Service Listeners


To Start a Communications Process

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking
    expand button
  2. Click Details in the Communications Processes cell for the server whose communications process you want to delete.
  3. On the Edit Server - Listeners page click Start at the top right-hand side of the area that shows the details of the communications process you want to start.
Note:
  • You can start a communications process only if:
    • The enterprise server is started.
    • The status of the communications process is "Stopped".

    When an enterprise server starts, any stopped communications processes are started automatically if Auto-start is set on.

  • When a communications process starts, all the service listeners it owns start too.
Parent topic: Configuring Communications Processes
Parent topic: Work with Communication Processes and Service Listeners


To Stop a Communications Process

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details in the Communications Processes cell for the server whose communications process you want to delete.
  3. On the Edit Server - Listeners page click Stop at the top right-hand side of the area that shows the details of the communications process you want to stop.
Note:
  • You can stop a communications process only if:
    • The enterprise server is started.
    • The status of the communications process is "Started".
  • When a communications process stops, all the service listeners it owns stop too.
Parent topic: Configuring Communications Processes
Parent topic: Work with Communication Processes and Service Listeners


To View Communications Processes and Listeners for an Enterprise Server Instance

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details in the Communications Processes cell for the server whose listeners you want to view.
  3. If you can't see the listeners, choose All from the list of options in Listener Display Filters Process.
Parent topic: Configuring Communications Processes
Parent topic: Work with Communication Processes and Service Listeners


To View Statistics for a Communications Process

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details in the Communications Processes cell for the server whose communications process you want to view statistics for. This server must have been started already.
  3. On the Edit Server - Listeners page click Statistics at the top right-hand side of the area that shows the details of the communications process.

    The Statistics are displayed in a new Web browser window.

Parent topic: Configuring Communications Processes
Parent topic: Work with Communication Processes and Service Listeners


Configuring Listener Conversation Types

A listener's conversation type is shown in the Conversation Type column on the listener configuration page.

The available configuration settings for a listener are grouped its conversation type.

Some conversation types use TCP/IP protocol, and some use Legacy Micro Focus Application Format. The format that the conversation uses is shown on the Legacy Micro Focus Application Format checkbox on the Edit Listener page. With the Custom Format type, you can choose whether or not to use Legacy Micro Focus Application Format.

  • Web Services and J2EE conversation type
  • Web conversation type
  • Fileshare conversation type
  • TN3270 conversation type
  • TN3270E conversation type
  • MSS Inter-System Communication conversation type
  • MSS Inter-System Communication (inbound only) conversation type
  • CICS Transaction Gateway conversation type
Parent topic: Configuring Client-Server Communications


Web Services and J2EE conversation type

There are no settings for this conversation type.

Parent topic: Configuring Listener Conversation Types


Web conversation type

These options are checked for each request.

The [virtual paths] section is used to translate between the top-level path elements specified in URLs and the actual file-system directories they correspond to. For example, for the URL “http://host/path/to/file”, the [virtual paths] section will be consulted for an entry for “path”. Entries in this section are case-sensitive. For a more detailed explanation of the way these settings work, see the section Deployment Services and Listeners in the chapter Configuration.

The [allow] section is used to restrict what files the Web connector will serve out of a given directory.

[options]
logging=logging-level
[virtual paths]
<default>=default-directory
element=file-system-path
[allow]
element=list-of-filenames
  • logging
    Controls what information is logged.
  • default
    Specifies the directory to which unrecognized URL top-level path elements will be mapped.
  • element in [virtual paths] Section
    Specifies the file-system path to which element will be mapped.
  • element in [allow] Section
    Lists one or more filenames or wildcard pattern specifications, separated by spaces, which the connector is allowed to serve for files on this virtual path.
Parent topic: Configuring Listener Conversation Types
Related information
Deployment Services and Listeners


logging

Syntax:

logging=logging-level

Parameters:

logging-level
Can be one of:
yes or 1 | Log various information while processing web requests, including path translation and CGI program execution
any other value | No logging

Properties:

Default: No logging
Parent topic: Web conversation type


default

Syntax:

default=default-directory

Properties:

Default: /dev/null

Comments:

The default directory must not exist, so that when the communications process translates the URL into a full path, the request will fail.

Parent topic: Web conversation type


element in [virtual paths] Section

Syntax:

 element=file-system-path

Parameters:

element The file-system path that element will be mapped to. element must be the top-level (first) element in the URL’s path. Some special tokens can be specified at the beginning of the value:
<ES>: | Replaced with the path to the base installation directory on Windows, or $COBDIR on UNIX
<ASEE>: | Historical synonym for ES.
<$name>: | Replaced with the contents of environment variable name
Parent topic: Web conversation type


element in [allow] Section

Syntax:

element=list-of-filenames

Parameters:

element | The file-system path that element will be mapped to.
list-of-filenames | Zero or more filenames or filename patterns, separated by spaces. Only files which match one of these filenames will be served. You can use the wildcards "?" (matches any one character) and "*" (matches zero or more characters).

Properties:

Default: Permit serving all files
Parent topic: Web conversation type


Fileshare conversation type

The Fileshare connector checks these settings at the beginning of each conversation. Changes to them will take effect for subsequent conversations.

[Operation]
timeout=number-of-seconds
[Trace]
control=control-flow-trace
data=data-trace
file=pathname
  • timeout
    Sets the timeout, in seconds, for receiving data from the client.
  • control
    Enables the tracing of control flow in the connector.
  • data
    Enables the tracing of sent and received data.
  • file
    Specifies the full path of the file to receive trace messages.
Parent topic: Configuring Listener Conversation Types


timeout

Syntax:

timeout=number-of-seconds

Properties:

Default: Timeout for the communications process, which is 7200 seconds (two hours)
Parent topic: Fileshare conversation type


control

Syntax:

control=control-flow-trace

Parameters:

control-flow-trace Set to "yes" to trace various connector activities, such as passing a request to an enterprise server

Properties:

Default: Control flow tracing is disabled
Parent topic: Fileshare conversation type


data

Syntax:

data=data-trace

Parameters:

data-trace Set to "yes" to include data in the trace

Properties:

Default: Data tracing is disabled.
Parent topic: Fileshare conversation type


file

Syntax:

file=pathname

Properties:

Default: Trace messages are written to the MFCS log (as HTML)
Parent topic: Fileshare conversation type


TN3270 conversation type

The TN3270 connector checks the settings below periodically; changes affect current and new conversations.

[logging]
client-close=client-close-logging
[Operation]
default-terminal-type=terminal-type-name
Timeout=number-of-seconds
TN3270E=negotiation-type
[Trace]
trace=control-flow-trace
data=data-trace
length=trace-length
sem=send-semaphore-trace
file=trace-filename
  • client-close
    Controls the logging of client disconnection.
  • default-terminal-type
    Overrides an invalid terminal type sent by the client.
  • Timeout
    Specifies the receive timeout, in seconds.
Parent topic: Configuring Listener Conversation Types


client-close

Parameters:

client-close-logging If this is set to “yes”, log normal client disconnection

Properties:

Default: Log only abnormal client disconnection
Parent topic: TN3270 conversation type


default-terminal-type

Parameters:

terminal-type-name A valid terminal-type name, for example, “ibm-3278-2”

Properties:

Default: None

Comments:

TN3270 conversation negotiation includes the client telling the server what terminal type it is emulating. TN3270E specifies a set of allowed terminal types, but classic TN3270 has less strict requirements, and even some TN3270E clients do not conform to the specification. When the connector receives an illegal terminal type, it normally asks the client to specify a different one, but some clients (for example NetManage ViewNow) do not respond correctly. In this case you are advised to provide this setting.

Parent topic: TN3270 conversation type


Timeout

Syntax:

Timeout=number-of-seconds

Properties:

Default: 84600 seconds (one day)
Parent topic: TN3270 conversation type


TN3270E conversation type

Syntax:

Disables TN3270E (Enhanced TN3270) negotiation.

TN3270E=negotiation-type

Parameters:

negotiation-type Set to “no” to disable TN3270E negotiation

Properties:

Default: Enhanced TN3270 negotiation is enabled

Comments:

Currently required for some NetManage terminal emulator products, such as ViewNow 1.0 Host Access Quick Connect 3270.

  • trace
    Enables the tracing of control flow in the connector.
  • data
    Enables data tracing.
  • length
    Specifies the maximum number of data bytes to include in the data trace.
  • sem
    Enables the tracing of operations on the send semaphore.
  • file
    Specifies the full path of the file to receive trace messages. The file is written as HTML (unlike the Fileshare and ISC traces).
Parent topic: Configuring Listener Conversation Types


trace

Syntax:

trace=control-flow-trace

Parameters:

control-flow-trace Set to “yes” to enable control flow tracing

Properties:

Default: Tracing is disabled
Parent topic: TN3270E conversation type


data

Syntax:

data=data-trace

Parameters:

data-trace
Can be one of:
yes or all
Trace all data flows
nvt
Trace data flows only in NVT mode (which essentially means only during negotiation)
any other value
Disable data tracing

Properties:

Default: Tracing is disabled
Parent topic: TN3270E conversation type


length

Syntax:

length=trace-length

Properties:

Default: 40 bytes
Parent topic: TN3270E conversation type


sem

Syntax:

sem=send-semaphore-trace

Parameters:

send-semaphore-trace Set to “yes” to trace operations on the send semaphore

Properties:

Default: Tracing is disabled

Comments:

This setting might be useful useful when problems with the send semaphore are suspected, for example, because conversations seem to hang but ESMAC does not show them as busy.

Parent topic: TN3270E conversation type


file

Syntax:

file=trace-filename

Properties:

Default: Trace messages are written to the MFCS log (as HTML)
Parent topic: TN3270E conversation type


MSS Inter-System Communication conversation type

Only one listener with this conversation type can be active for a region. To create others, use the MSS Inter-System Communication (inbound only) or the CICS Transaction Gateway types depending on your requirements.

[Operation] changes take effect for the conversations that commence after you make changes, but not for the current conversation.

[Trace] changes take effect for both new and existing conversations.

[Operation]
timeout=number-of-seconds
[Trace]
trace=control-flow-trace
data-trace=data-trace-setting
allmax=dump-size
file=pathname
  • timeout
    Sets the timeout, in seconds, for receiving data from the client.
  • trace
    Enables the tracing of control flow in the connector.
  • data-trace
    Enables the tracing of sent and received data.
  • allmax
    If data-trace is set to “all”, sets the maximum number of bytes to include in the user data dump.
  • file
    Specifies the full path of the file to receive trace messages. The file is plain text.
Parent topic: Configuring Listener Conversation Types


timeout

Syntax:

timeout=number-of-seconds

Properties:

Default: Timeout for the communications process, which is 7200 seconds (two hours)
Parent topic: MSS Inter-System Communication conversation type
Parent topic: MSS Inter-System Communication (inbound only) conversation type
Parent topic: CICS Transaction Gateway conversation type


trace

Syntax:

trace=control-flow-trace

Parameters:

control-flow-trace Set to “yes” to trace various connector activities, such as passing a request to an enterprise server

Properties:

Default: Tracing is disabled
Parent topic: MSS Inter-System Communication conversation type
Parent topic: MSS Inter-System Communication (inbound only) conversation type
Parent topic: CICS Transaction Gateway conversation type


data-trace

Syntax:

data-trace=data-trace-setting

Parameters:

data-trace-setting
Can be one of:
no
Do not trace data flows
header
Create formatted trace of CTG protocol headers
fmh or structure
Create formatted trace of CTG headers and request and response headers
all
Create formatted trace of headers and dump of user data
dump
Create unformatted dump of all data

Properties:

Default: Tracing is disabled
Parent topic: MSS Inter-System Communication conversation type
Parent topic: MSS Inter-System Communication (inbound only) conversation type
Parent topic: CICS Transaction Gateway conversation type


allmax

Syntax:

allmax=dump-size

Parameters:

dump-size Set to 0 (unlimited) if you want to include all the data

Properties:

Default: Unlimited, that is, include all the data.
Parent topic: MSS Inter-System Communication conversation type
Parent topic: MSS Inter-System Communication (inbound only) conversation type
Parent topic: CICS Transaction Gateway conversation type


file

Syntax:

file=pathname

Properties:

Default: Trace messages are written to the MFCS log (as HTML).
Parent topic: MSS Inter-System Communication conversation type
Parent topic: MSS Inter-System Communication (inbound only) conversation type
Parent topic: CICS Transaction Gateway conversation type


MSS Inter-System Communication (inbound only) conversation type

Describes the MSS Inter-System Communication (inbound only) listener type.

This conversation type is used for MSS ISC listeners other than MF MTO Inter-System Communication.

[Operation] changes take effect for the conversations that commence after you make changes, but not for the current conversation.

[Trace] changes take effect for both new and existing conversations.

[Operation]
timeout=number-of-seconds
[Trace]
trace=control-flow-trace
data-trace=data-trace-setting
allmax=dump-size
file=pathname
  • timeout
    Sets the timeout, in seconds, for receiving data from the client.
  • trace
    Enables the tracing of control flow in the connector.
  • data-trace
    Enables the tracing of sent and received data.
  • allmax
    If data-trace is set to “all”, sets the maximum number of bytes to include in the user data dump.
  • file
    Specifies the full path of the file to receive trace messages. The file is plain text.
Parent topic: Configuring Listener Conversation Types


CICS Transaction Gateway conversation type

This conversation type is used for MSS ISC listeners other than MF MSS Inter-System Communication that do not use the Legacy Micro Focus Application format.

[Operation] changes take effect for the conversations that commence after you make changes, but not for the current conversation.

[Trace] changes take effect for both new and existing conversations.

[Operation]
timeout=number-of-seconds
[Trace]
trace=control-flow-trace
data-trace=data-trace-setting
allmax=dump-size
file=pathname
  • timeout
    Sets the timeout, in seconds, for receiving data from the client.
  • trace
    Enables the tracing of control flow in the connector.
  • data-trace
    Enables the tracing of sent and received data.
  • allmax
    If data-trace is set to “all”, sets the maximum number of bytes to include in the user data dump.
  • file
    Specifies the full path of the file to receive trace messages. The file is plain text.
Parent topic: Configuring Listener Conversation Types


Configuring Listeners

This section covers the tasks involved in creating and configurings service listeners.

  • To Add a Service Listener to an Enterprise Server Instance
  • To Edit a Listener
  • To Associate a Listener with a Service
  • To delete a listener
  • To Disassociate a Listener from a Service
  • To Start a Listener
  • To Stop a Listener
Parent topic: Configuring Client-Server Communications


To Add a Service Listener to an Enterprise Server Instance

  1. If the table of servers on the Enterprise Server administration page is displayed in summary form, expand it by clicking expand button
  2. Click Details in the Communications Processes cell for the server to which you want to add the listener.
  3. Click Add in the Listeners column for the communications process to which you want to add the listener.
  4. Specify a name for the service listener in Name.
  5. In Endpoint Address specify a host name or IP address to replace the first asterisk (*) and a port number to replace the second asterisk. You can leave the value as *:*, where the first asterisk (*) indicates the IP address of the current machine and the second indicates any available port number. Endpoint Protocol is always TCP.
  6. Choose an initial status from the list in Initial Status. Usually you should choose "Stopped".
  7. Click one button to choose a Supported Conversation Type for the listener:
    • Web Services / J2EE for client requests that use either of the conversation protocols supported by the Micro Focus request handlers, MFRHBINP and MFRHSOAP
    • Web for World Wide Web (HTTP) requests; Enterprise Server uses a Web listener for service deployment
    • Fileshare for Fileshare client requests
    • TN3270 for requests from TN3270 terminals
    • MSS Inter-System Communication for CICS Intersystem Communication (peer-to-peer) and for requests for CICS transactions from non-CICS programs. This conversation type handles both inbound and outbound calls. Only one listener of this type can be used with an enterprise server. The corresponding conversation type in previous Enterprise Server software releases is Micro Focus MTO Inter-System Communication.

      This conversation type uses Legacy Micro Focus Application Format.

    • MSS Inter-System Communication (inbound only) is similar in functionality to the MSS Inter-System Communications conversation type. The corresponding conversation type in previous Enterprise Server software releases is the MSS ISC type that did not have a name of Micro Focus MTO Inter-System Communciations.

      This conversation type uses Legacy Micro Focus Application Format.

    • CICS Transaction Gateway is similar in functionality to the previous two conversation types, except that it does not use Legacy Micro Focus Application Format.
    • Custom can be used for any other type of requests. You can select whethr or not to use Legacy Micro Focus Application Format.
  8. If you clicked Custom in step 6, enter the name of the connector module for this type of request in the entry field next to Custom.
  9. Specify any configuration information the listener requires in Configuration Information.
  10. Specify a text description of the listener in Description (optional).
  11. Click Add.
Note: You can also reach the Add Listener page by clicking Edit to the left of the server to which you want to add the listener, clicking the Listeners tab and clicking Add.
Parent topic: Configuring Listeners
Parent topic: Work with Communication Processes and Service Listeners
Parent topic: Common Configuration Tasks


To Edit a Listener

  1. If the table of servers on the Enterprise Server administration page is displayed in summary form, expand it by clicking expand button
  2. Click Details in the Communications Processes cell for the server that owns the listener you want to edit.
  3. If you can't see the listener you want to edit, choose All from the list of options in Listener Display Filters Process.
  4. Click Edit to the left of the row containing the service listener that you want to edit.
  5. Update the attributes of the listener as required.
  6. Click OK.
Parent topic: Configuring Listeners
Parent topic: Work with Communication Processes and Service Listeners


To Associate a Listener with a Service

  1. Click Details in the Objects column for the server that owns the service that you want to associate the listener with.
  2. Click Edit in the Operation column of the row containing the service that you want to associate the listener with.
  3. In Available Listeners click the service listener that you want to associate with the service.
  4. Click Add.

    The Directory Server associates the listener with the service immediately and redisplays the service table.

  5. If you want to associate another listener with this service, repeat steps 3 through 5.
Note: A service must always have at least one listener associated with it.
Parent topic: Configuring Listeners
Parent topic: Work with Communication Processes and Service Listeners


To delete a listener

  1. If the table of servers on the Enterprise Server administration page is displayed in summary form, expand it by clicking expand button
  2. Click Details in the Communications Processes cell for the server that owns the listener you want to delete.
  3. If you can't see the listener you want to delete, choose All from the list of options in Listener Display Filters Process.
  4. Click Edit to the left of the row containing the service listener that you want to delete.
  5. Click Delete.
  6. Click Delete on the confirmation page.
Note:
  • You cannot delete a listener if it is the only listener for a communications process.
  • You cannot delete a service listener if it is associated with any service.
  • You cannot delete the deployment listener called Web that is created automatically when you create a new enterprise server.
Parent topic: Configuring Listeners
Parent topic: Work with Communication Processes and Service Listeners


To Disassociate a Listener from a Service

  1. Click Details at the bottom of the Objects column.
  2. Click Edit in the Operation column for the row containing the service from which you want to disassociate the listener.
  3. In Associated Listeners click the service listener that you want to disassociate from the service.
  4. Click Remove.

    The Directory Server disassociates the listener from the service immediately and redisplays the service table.

  5. If you want to disassociate another listener from this service, repeat steps 3 through 5.
Note: A service must always have at least one listener associated with it.
Parent topic: Configuring Listeners
Parent topic: Work with Communication Processes and Service Listeners


To Start a Listener

  1. If the table of servers on the Enterprise Server administration page is displayed in summary form, expand it by clicking expand button
  2. Click Details in the Communications Processes cell for the server that owns the listener you want to start.
  3. If you can't see the listener you want to start, choose All from the list of options in Listener Display Filters Process.
  4. Click Edit to the left of the row containing the service listener that you want to start.
  5. Click Started in New Status.
  6. Click OK.
Note:

You can start a listener only if the server is started. When a server starts, any stopped listeners are started automatically.

Parent topic: Configuring Listeners
Parent topic: Work with Communication Processes and Service Listeners


To Stop a Listener

  1. If the table of servers on the Enterprise Server administration page is displayed in summary form, expand it by clicking expand button
  2. Click Details in the Communications Processes cell for the server that owns the listener you want to stop.
  3. If you can't see the listener you want to stop, choose All from the list of options in Listener Display Filters Process.
  4. Click Edit to the left of the row containing the service listener that you want to stop.
  5. Click Stopped in New Status.
  6. Click OK.
Note: You can stop a listener only if the server is started. When a server starts, any stopped listeners are started automatically.
Parent topic: Configuring Listeners
Parent topic: Work with Communication Processes and Service Listeners


Monitoring Enterprise Server

  • Server Instance Statuses
  • Monitoring the Directory Server
  • Collecting and Viewing Data on Transactions
  • Windows Event Log
  • Performance Counters
  • Management Packs for System Center Operations Manager
Parent topic: Enterprise Server Configuration and Administration


Server Instance Statuses

An enterprise server instance can have any of the following statuses:

Stopped | The server is currently not running.
Stopping | The server is currently in the process of terminating. This is normally a short-lived status value which should be shortly followed by a change to the value "Stopped".
Started | The server is currently running and can respond to client and server requests. At least one communications process is started.
Starting | The server is currently in the process of starting. This is normally a short-lived status value which should be shortly followed by a change to the value "Started".
Not Responding The server process was previously marked as "Started", but the server monitor has subsequently not been able to contact it. There may be some network connection error, or the server itself may have abnormally terminated without first marking itself as "Stopped".

If network communications are restored, and the server is still running, and the server monitor is on, then the server will be remarked as "Started" when the server monitor next checks whether the server is active.

The server might have encountered an unrecoverable communications error and the server process remains active, in which case you can shut it down by using Stop Server on the Server Details page.

The server might have encountered an unrecoverable communications error, that is, all the communications processes are inactive or not responding. If this happens, the server process shuts down. You can start it by using Start Server on the Server Details page.

Invalid | An error has occurred such that it has not been possible to set the status to any other value.

A CCI Server can only have the status Registered. This status indicates that the Directory Server has been notified that a CCI server has started. When the server stops, it deregisters itself and disappears from the list of servers.

Parent topic: Monitoring Enterprise Server


Monitoring the Directory Server

This section describes the facilities for monitoring the activities of the Directory Server.

  • Starting and Stopping the Directory Server
  • Displaying Server Information
  • Accessing Remote MF Directory Servers
  • Monitoring Facilities
Parent topic: Monitoring Enterprise Server


Starting and Stopping the Directory Server

In order to access the Enterprise Server Administration user interface, the Directory Server must be running.

When Enterprise Server is installed, the Directory Server is configured to start automatically as a Windows service. As with other Windows services, you can stop the Directory Server and start it again if required.

You can also start Directory Server from the command line using the mfds command. This method of starting the Directory Server is useful if you want to debug applications running as services. Before you can use the mfds command, you must stop Directory Server running as a Windows service. If you start Directory Server using the mfds command, you must stop it using a menu option on the Web interface.

The mfds command also provides options to deinstall and reinstall the Directory Server as a Windows service.

To access the Directory Server using the Web interface, you start a Web browser and enter the address where the Directory Server is running.

Alternatively, if you are running Studio Enterprise Edition, you can right click on Enterprise Servers in the Server Explorer pane and select Administration from the drop-down menu.

Depending on how the Directory Server has been configured, and what you want to do, you might require a user ID and password. What you see and what you can do using Enterprise Server Administration depends on the security configuration settings and the permissions granted to your user account.

  • To Start the Directory Server
  • To Start the Directory Server from the Command Line
  • To Stop the Directory Server
  • To stop the Directory Server when not running as a service
  • To Delete the Repository
  • To Import a Repository
  • To Restore the Repository
  • To Export the Repository
Parent topic: Monitoring the Directory Server


To Start the Directory Server

  1. Open the Windows Control Panel.
  2. Select Services; how you do this differs between Windows operating systems.
  3. In the list of services select Micro Focus Directory Server.
  4. Click Start.
Note: You would normally need to do this only if you stopped the Directory Server using the Services dialog. This is because the Directory Server is configured at installation time to start automatically when Windows starts.
Parent topic: Starting and Stopping the Directory Server
Parent topic: Start and Stop the Directory Server


To Start the Directory Server from the Command Line

  1. If you are running Directory Server on UNIX, log in as root.
  2. Enter:
    mfds /param

    where param can be:

    d | Show debug information
    j journal-path | Override the journal path
    k | Use SSL and specify SSL certificate, keyfile and password
    n network-address Bind to specific adapter.
    Note: You can use the CCITCP2_PORT environment variable to bind to a non-standard port, but this option should be used with caution, as many programs depend on Directory Server using the default port (86).
    o | Specify alternate MFDS options file
    r | Refuse access to the Enterprise Server Administration interface
    z | Override initial repository location
  3. In addition to options for starting Directory Server, the mfds command also provides a number of other options for reporting and exporting information, stopping the server, and for the installation or removal of Windows services.
    c | Install as a service: show debug console
    e | Export MFDS user information to an LDIF file
    i | Install as a service: do not show debug console
    l | Export MFDS schema as an LDIF file
    m | Display current repository path
    s | Request controlled shutdown
    u | Remove as a service
    v | Show version information
    t | Convert journal file to text format
    x | Export repository data
    g | Import repository data
Parent topic: Starting and Stopping the Directory Server
Parent topic: Start and Stop the Directory Server


To Stop the Directory Server

Note: You can leave Directory Server running all the time, whether or not you are using Enterprise Server Administration. You should not shut down Directory Server if servers are started.

  1. Open the Windows Control Panel.
  2. Select Services; how you do this differs between Windows operating systems.
  3. In the list of services select Micro Focus Directory Server.
  4. Click Stop.

From the command line

Enter:
mfds -s
Parent topic: Starting and Stopping the Directory Server
Parent topic: Start and Stop the Directory Server


To stop the Directory Server when not running as a service

When the Directory Server is not running as a Windows service, you can shut it down from the Enterprise Server Administration user interface:

  1. Click Shut down on the menu on the left-hand side of any Enterprise Server Administration Web page.
  2. Click Yes on the confirmation page.
Note: You can leave Directory Server running all the time, whether or not you are using Enterprise Server Administration. You should not shut down Directory Server if servers are started.
Parent topic: Starting and Stopping the Directory Server
Parent topic: Start and Stop the Directory Server


To Delete the Repository

CAUTION:

When you click Delete, all information in the current repository is deleted. If you have currently active clients and services, this will cause client application connection errors and loss of data.

  1. Click Delete All under Actions on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. If you are sure you want to delete the repository, click OK. Otherwise click Cancel.
Parent topic: Starting and Stopping the Directory Server
Parent topic: Work with the Directory Server Repository


To Import a Repository

  1. Click Import under Actions on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Specify the location of the repository that you want to import in Source directory containing server data to restore. By default, this is C:\Documents and Settings\All Users\Micro Focus\Net Express\6.0\mfds.

    A list of recently used locations is supplied. Choosing an item from this list and clicking Select puts the value into Source directory containing server data to restore.

  3. Click Next and follow the screen prompts.
Note: When you import, you have the option of excluding any server that has the same name as one already present in the repository. Where the export contains security information, you also have the option of including or excluding it. See the context help for details.
Parent topic: Starting and Stopping the Directory Server
Parent topic: Work with the Directory Server Repository


To Restore the Repository

  1. Click Restore under Actions on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Specify the location from which you want the repository to be restored in Source directory containing server data to restore. This defaults to C:\Documents and Settings\All Users\Micro Focus\Net Express\6.0\mfds.
  3. Choose whether you want to set the status of all restored servers to "Stopped", or to whatever they were when the servers were last saved, by clicking one of the radio buttons under When restoring servers.
  4. Check restore even if source repository is a duplicate, in part or whole, of the current one if you want server data to be restored even if all the server names in the backup repository are duplicates of server names in the current repository.
  5. Click OK.
Note: You can go back to the repository as it was when Enterprise Server was originally installed, by restoring from the \ivp subdirectory of C:\Documents and Settings\All Users\Micro Focus\Net Express\6.0\mfds.
Warning: If you want to keep the information currently in the repository make sure you have saved it before you restore. When you restore the repository all the information in the repository is overwritten with the restored data. This might cause application connection errors and loss of data.
Parent topic: Starting and Stopping the Directory Server
Parent topic: Work with the Directory Server Repository


To Export the Repository

  1. Click Export under Actions on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Specify the location where you want to save the repository in Export information to this directory. This defaults to C:\Documents and Settings\All Users\Micro Focus\Net Express\6.0\mfds.
  3. Choose the export option that you require and click OK.
    Note: If the target directory contains previously exported information, you will be presented with a confirmation page. This page will show the contents of the target directory. Proceeding with the export will overwrite previously exported details.
Note:
  • We recommend that you export the repository only when all the registered servers have a status of "Stopped".
  • When exporting to a file system location, if you specify a directory that does not exist, it will be created if the directory containing it exists, otherwise it will not be created and the export will fail.
  • Export enables you to export either: server definitions only, Security Manager definitions only, or server definitions and all related security configuration information.
Parent topic: Starting and Stopping the Directory Server
Parent topic: Work with the Directory Server Repository


Accessing Remote MF Directory Servers

Providing you have sufficient authorization, you can log on to remote MF Directory Servers and administer the installations they maintain. You can display all directory servers accessible from your network that are listening on port 86.

  • To View and Use Remote Directory Server Instances
Parent topic: Monitoring the Directory Server


To View and Use Remote Directory Server Instances

  1. Click Directories on the menu on the left-hand side of the Enterprise Server Administration Web page.

    Enterprise Server searches the network for all MF Directory Servers that use port 86, and displays a list of the MF Directory Servers that it finds.

  2. Click the right-pointing arrow in the DNS Resolved Hostname column for the remote machine that you want to view.

    A new browser window opens at the home page of Enterprise Server Adminstration for the instance of Directory Server running on the other machine.

Parent topic: Accessing Remote MF Directory Servers
Parent topic: Monitor Directory Server
Parent topic: Submitting to a Remote Machine


Monitoring Facilities

Enterprise Server Administration provides four facilities for monitoring the activities of the Directory Server:

  • The Directories Page
  • Viewing a MF Directory Server's Statistics
  • Viewing a MF Directory Server's Sessions List
  • Viewing the Journal
Parent topic: Monitoring the Directory Server


The Directories Page

The Directories page displays a table of all the other instances of Directory Server that are running on the local network and that are using the default Directory Server port (86). For each instance, it shows:

  • The version number of Directory Server
  • The IP address of the machine on which it is running
  • The DNS-resolved hostname of the machine on which it is running. Next to the hostname is a right-pointing arrow, which you can click to open a new Enterprise Server Administration window on your machine, giving you access to the other Directory Server and its objects without having to remember its IP address.
Note:

You should take care to ensure that an appropriate level of security has been set up for all the instances of Directory Server on a local network, to reduce the possibility of unauthorised access using the Directories page. For more on security and the options available, see Introduction to Server Enterprise Edition Security.

Parent topic: Monitoring Facilities
Related information
Introduction to Enterprise Server Security


Viewing a MF Directory Server's Statistics

The Statistics page displays statistics and other information about the Directory Server and the current activity on it. The information is of four types:

  • Repository location and status
  • Objects in the repository, subdivided into servers, listeners, services, request handlers and packages, with a total. The services number actually represents the number of service operations
  • Request processing statistics
  • Configuration options settings
  • File paths used by the Directory Server

You might find the information on this page helpful if you are experiencing problems, for example, if you deployed a service, but you cannot find it in the Services table, you can check whether the numbers of services and packages have changed.

  • To View Directory Server Statistics
Parent topic: Monitoring Facilities


To View Directory Server Statistics

  • Click Statistics on the menu on the left-hand side of any Enterprise Server Administration Web page.
Parent topic: Viewing a MF Directory Server's Statistics
Parent topic: Monitor Directory Server


Viewing a MF Directory Server's Sessions List

The Sessions list is a list of all the Web browser client and program clients currently connected to the MF Directory Server. The sessions may be active, or they may be dormant but not yet removed because the time period between inactivity and removal has not yet been exceeded.

If user access is unrestricted (that is, if security has not been configured for Directory Server), only one Web browser client session is shown, with the Session ID "Developer".

If user access is restricted, individual sessions are shown for each Web browser client session user, identifed by unique user IDs.

  • To View the Sessions List
Parent topic: Monitoring Facilities


To View the Sessions List

  • Click Sessions on the menu on the left-hand side of any Enterprise Server Administration Web page.
Parent topic: Viewing a MF Directory Server's Sessions List
Parent topic: Monitor Directory Server


Viewing the Journal

The Journal is a file that records some of the activity occurring on the MF Directory Server. It can track usage and help with support issues.

You can choose one of three levels of journaling:

  • Errors only (default)
  • Errors and warnings
  • All information. With this level there is a performance degradation. The scale of the degradation depends on many factors such as file system performance and client traffic; a system with a large number of highly active program clients suffers the most

You set the journaling level using the Configure Options page.

  • To View the Journal
  • To Export the Journal as a Text File
  • To Delete Journal Entries
Parent topic: Monitoring Facilities


To View the Journal

  • Click Journal on the menu on the left-hand side of any Enterprise Server Administration Web page.
Parent topic: Viewing the Journal
Parent topic: Directory Server Journal
Parent topic: Monitor Directory Server


To Export the Journal as a Text File

  1. Click Journal on the menu on the left-hand side of any Enterprise Server Administration Web page.
  2. Click Export as Text. The text file journal.txt will be created in the directory C:\Documents and Settings\All Users\Application Data\Micro Focus\<product name> x.x \ver (assuming your %SYSTEMDRIVE% is c:). If the file already exists it will be overwritten.
Parent topic: Viewing the Journal
Parent topic: Monitor Directory Server


To Delete Journal Entries

  1. Click Journal on the menu on the left-hand side of any Enterprise Server Administration Web page.
  2. Click Delete. A new journal is started.
Parent topic: Viewing the Journal
Parent topic: Monitor Directory Server


Collecting and Viewing Data on Transactions

You can create records for tasks that have been executed and completed under Enterprise Server using the Historical Statistics Facility (HSF). These records can be written to a .csv file and also a limited number can be saved in memory to view in the Enterprise Server Monitoring and Control console (ESMAC).

The records contain information such as the ID of a user that initiates the task, the response time, and names of any files accessed.

Information is provided for the following resources:

  • CICS transactions
  • IMS transactions
  • Batch jobs (JCL) - for each JCL job, HSF generates a start record, an end record and one record for each step
  • Web services
  • CGI programs
  • Configuring and Starting Transaction Data Collection
  • Viewing HSF Information in ESMAC
  • Viewing HSF Information as a .csv File
  • Analyzing Aggregated HSF Data in .csv Files
Parent topic: Monitoring Enterprise Server


Configuring and Starting Transaction Data Collection

In order to use HSF to collect data about transactions, you need to set a number of configuration options in Enterprise Server Administration. You can also use ESMAC to override these settings dynamically.

Note: In order to collect information on EXEC SQL statements, you need to compile the application with the SMFTRACE directive set.

To configure HSF

  1. Access the Enterprise Server Administration screen for your installation.
  2. Check that the server you want has stopped, and if not, stop it.
  3. In the Status column of the Enterprise Server to monitor, click Details.
  4. Select the Historical Statistics tab.
  5. Set the configuration options:
    Enable collection of HSF records
    This switches on HSF processing.
    Write to disk
    Enables writing of HSF records to comma-separated files. These are called cashsf-a.csv and cashsf-b.csv, and are written to the system directory. Only one file is written to at any one time - this is called the active file.

    You write to the active file until you click the ESMAC Switch button or when the active file reaches the maximum size, at which point the alternate file becomes active. If the alternate file already exists it will be backed up with the name cashsf.nnn where nnn is the number of the backup. When you start an enterprise server, cashsf-a.csv is always set as the active file, and if it already exists it is backed up.

    Backup extensions are numbered from .001 up to .999. When a backup with extension .999 exists then the next backup will be created as cashsf.001. If cashsf.001 already exists then it will be overwritten.

    Max HSF file size
    If you have selected Write to disk, this is the size in kilobytes the .csv file will reach before Enterprise Server switches to the alternate .csv file. A value 0 selects the maximum size possible (4 Gb).
    Number of records to view in ESMAC
    The number of HSF records that Enterprise Server will hold in memory. These records can be viewed by clicking on the HSF button in ESMAC while the server is running. When this number is reached, older records will be deleted when a new one is created. Records older than one hour are deleted too.
    The minimum value is 0 (no HSF data displays in ESMAC), the maximum is 4096.

To reconfigure HSF while a server is running

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the Status column of the started Enterprise Server, click Details.
  3. Select the Server > Control tab and click ES Monitor & Control, then click Control.
  4. Set the configuration options. These are the same as those in the Enterprise Server Administration Historical Statistics tab described above apart from the following differences:
    Enable collection of HSF records
    To enable this option you must first either set Write to disk or enter a value in the Number of records to view field.
    Switch
    Clicking this button will switch collection to the alternate .csv file before the active file has reached the maximum size.
  5. Click Apply to start collecting the data.
Parent topic: Collecting and Viewing Data on Transactions
Related reference
HSFTRACE
Related information
To start an enterprise server instance


Viewing HSF Information in ESMAC

If you have enabled collection of HSF records and specified the number of records to collect in ESMAC, you can use ESMAC to view aggregated information on transactions, and details of individual runs of those transactions.

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To view the transaction information:

  1. Click the HSF button.

This shows the period of time (displayed in minutes and seconds next to Historical Statistics) between the earliest records displayed and the current time. Records older than one hour are deleted. The following information is shown for each transaction:

Average Latency
The average time, in hundredths of a second, between Enterprise Server receiving the requests and the tasks beginning to run.
Average Response Time
The average time, in hundredths of a second, that the tasks ran for (not including latency time).
Count
How many times the task has run.

By clicking on the magnifying glass icon [image] next to a task you get a detailed view of the individual runs.

Latency+Resp
The sum of latency and response time averages.
Transaction
The name of task:
  • for CICS and IMS tasks, the transaction ID
  • for JCL, the job name
  • for Web services, the service name
  • for CGI programs, the program name
Program
  • for CICS and IMS tasks, the program name
  • for JCL, the program name or the job number, depending on the JCL record type
Process ID
Process ID of the SEP which ran the task.
Task Number
A unique task number.
Date
The date the task started to run, in the format yyymmdd.
Time
The time the task started to run, in the format hhmmsscc.
User
The ID of the user that initiated the task.
LU/Step
  • for CICS tasks, the logical unit or net name (the identifier of the terminal used to initiate the task).
  • for JCL, either the step name, the JOBSTART constant indicator, or the job return code depending on the JCL record type. All three of these record types are generated for each JCL job.
Parent topic: Collecting and Viewing Data on Transactions
Related information
To start an enterprise server instance


Viewing HSF Information as a .csv File

If you have enabled the collection and writing of HSF records to disk, you can view details of individual runs of transactions in comma-separated files that you can import into a spreadsheet. These files contain one HSF record per line. The filenames are cashsf-a.csv and cashsf-a.csv.

Once the active file is full, or when you click the the Switch button in ESMAC, records are then written to the alternate file until the maximum file size is reached or the Switch button is clicked.

The files are saved in the system directory.

The .csv files have the header
#HSFVer=01
Type,PID,Task,Date,Time,Tran,User,LU,Prog,Latent,Resp,API,SQL,IMS,File1,Count1,Time1,File2,Count2,Time2,File3,Count3,Time3,File4,Count4,Time4,File5,Count5,Time5,TS1,Count1,Time1,TS2,Count2,Time2,TS3,Count3,Time3,TS4,Count4,Time4,TS5,Count5,Time5
and contain the following fields.
Important:
This version of the product generates cashsf-n.csv files that start with the line:
#HSFVer=01
HSF output from earlier versions of the product does not have this line.
Earlier .csv files do not have the IMS field, and have this header:
Type,PID,Task,Date,Time,Tran,User,LU,Prog,Latent,Resp,API,SQL,File1,Count1,Time1,File2,Count2,Time2,File3,Count3,Time3,File4,Count4,Time4,File5,Count5,Time5,TS1,Count1,Time1,TS2,Count2,Time2,TS3,Count3,Time3,TS4,Count4,Time4,TS5,Count5,Time5
Type
The type of task. One of:
  • CICS
  • IMS
  • JCL
  • WEB
  • CGI
PID
Process ID of the SEP which ran the task.
Task
A unique task number.
Date
The date the task started to run, in the format yyyymmdd.
Time
The time the task started to run, in the format hhmmsscc.
Tran
The name of task:
  • for CICS and IMS tasks, the transaction ID
  • for JCL, the job name
  • for Web services, the service name
  • for CGI programs, the program name
User
The ID of the user that initiated the task.
LU
  • for CICS tasks, the logical unit or net name (the identifier of the terminal used to initiate the task).
  • for JCL, either the step name, the JOBSTART constant indicator, or the job return code depending on the JCL record type. All three of these record types are generated for each JCL job.
Prog
  • for CICS and IMS tasks, the program name
  • for JCL, the program name or the job number, depending on the JCL record type
Latent
The time, in hundredths of a second, between Enterprise Server receiving the request and the task beginning to run.
Resp
The time, in hundredths of a second, that the task ran for (not including latency time).
API
The time, in hundredths of a second, spent in CICS API (EXEC CICS statements) for this task.
SQL
The time spent, in hundredths of a second, in SQL API (EXEC SQL statements) for this task.
IMS
The time spent, in hundredths of a second, in IMS DL/I API for this task.

The following additional fields may be repeated up to five times:

File(x)
The name of a file that the transaction accessed.
Count(x)
The number of times the transaction accessed this filex.
Time(x)
The time, in hundredths of a second, the transaction spent accessing filex.
Ts(x)
The name of a temporary storage queue (TSQ) that the transaction accessed.
Count(x)
The number of times the transaction accessed Ts x.
Time(x)
The time, in hundredths of a second, the transaction spent accessing Ts x.

Sample content viewed in Microsoft Excel

Parent topic: Collecting and Viewing Data on Transactions


Analyzing Aggregated HSF Data in .csv Files

You can use the statistics utility program, casfhsf, to output aggregated data from the .csv files created by the Historical Statistics Facility (HSF). casfhsf outputs this data as a comma-separated value file.

You can use the information to review system performance on a regular basis and avoid going through a large volume of data in order to determine if corrective tuning action is required.

Note: The .csv files do not have to be generated on the same platform as the one on which you run casfhsf.

Using the casfhsf statistics utility program

From the Net Express command prompt, launch casfhsf.exe.

The following switches are available. A dash may replace the slash, and switches can be upper or lower case.

Switch | Description
/A | Process only cashsf-a.csv.
/B | Process only cashsf-b.csv.
/C | Process both cashsf-a.csv and cashsf-b.csv (default).
/D | Process only backup files cashsf.nnn.
/E | Process all files: cashsf-a.csv, cashsf-b.csv, and cashsf.nnn.
/S{sd,st,ed,et} | Aggregate the output data by the second. Where {sd,st,ed,et} = yyyymmdd, hhmmss, yyyymmdd, hhmmss - start date, start time, end date, end time.
/M{sd,st,ed,et} | Aggregate the output data by the minute (default if error). Where {sd,st,ed,et} = yyyymmdd, hhmm, yyyymmdd, hhmm - start date, start time, end date, end time.
/IP | The location of the input files. The default value is the current directory.
/OP | The location of the path of the output file. The default value is the current directory. The output file is called OutFile.csv.

To aggregate certain transactions or programs, you may specify these using parameters in the form:

{type},{id}[[,{type},{id}]...]
The parameters are:
type
Transaction type:
  • CICS= a CICS transaction
  • IMS = an IMS transaction
  • JCL = a JCL batch job
  • WEB = a Web Service
  • CGI = a CGI program
id
The identifier of the transaction, job, service or program ID to be aggregated. If id is "Auto", this is an alias for CICS Auto install transaction (x'feffffff').

You can specify between zero and five type,id pairs. Each type must be separated from its corresponding id by a comma. If more than one pair is specified, each pair must be separated by a comma.

If no pair is specified, an aggregate of all transactions is accumulated in the first unallocated slot. The default behavior in this case is to aggregate all data in slot one.

An extfh.cfg file is generated in the current directory, if one is not already present, to allow large file inputs.

If no switches or parameters are specified, the utility will ask if you wish to continue using the default values.

Example
casfhsf /a /s /ipc:\es\region2\system CICS,ABCD,CICS,WXYZ
This processes cashsf-a.csv in the directory c:\es\region2\system, and aggregates times (in seconds) separately for the CICS transactions ABCD and WXYZ.
Example
casfhsf /op"c:\Users\All Users\Micro Focus"
Using the input defaults, this processes both cashsf-a.csv and cashsf-b.csv in the current directory, aggregates times in minutes for all transactions and programs, and creates the output file in the folder c:\Users\All Users\Micro Focus.

The Output File

This is a comma-separated value file with the following header:
time,TPS,Latency,min,max,Response,min,max,System,min,max,API,min,max,SQL,min,max,IMS,min,max...
After the time field, the rest of the fields occur five times.
Field | Description
time | The time period in minutes (hh:mm format) or seconds (hh:mm:ss format) into which the input monitoring times are aggregated. The format is determined by the /S or /M switch.
TPS | The average number of transactions per second or minute.
Latency,min,max | The average latency - delay or waiting time - for this time period, and the minimum and maximum latency.
Response,min,max | The average time taken for Enterprise Server to respond to the transaction request, and the minimum and maximum response times.
System,min,max | The total of the average latency and response times (Latency + Response) , and the minimum and maximum totals of latency plus response time of a particular transaction run.
API,min,max | The average time, in hundredths of a second, spent in CICS API (EXEC CICS statements) for this task, and the minimum and maximum times.
SQL,min,max | The average time, in hundredths of a second, spent in SQL API (EXEC SQL statements) for this task, and the minimum and maximum times.
IMS,min,max | The average time, in hundredths of a second, spent in IMS DL/I API for this task, and the minimum and maximum times.

There is also a secondary header depending on the parameters supplied to the utility.

If there are no parameters, then all the aggregate values are accumulated under "Everything", and the other four columns are marked as "Unused".

Versions of input files

This version of the product generates cashsf-n.csv files that start with the line:
#HSFVer=01
HSF output from earlier versions of the product does not have this line.

If you are processing multiple files, casfhsf will only aggregate data from files of the same version as the first file it receives. Other versions are ignored. However, whatever version it processes, the output file OutFile.csv will contain all the fields listed above, with values of zero for any missing fields.

Example

  1. An input file cashsf-a.csv was created during a short run of a CICS region.
  2. The following command was executed in the directory containing the input file:
    casfhsf /a /m CICS,ACCT

    This command processes cashsf-a.csv in the current directory, places the output file in the current directory, and aggregates times by the minute.

  3. An output file, OutFile.csv is created. The figure below shows the content viewed in Microsoft Excel:

    This shows, for example, that at 13:45 aggregated statistics for the CICS transaction ACCT are:
    • the number of transactions per second is 0.08
    • the average latency is 10 milliseconds
    • the average response time is 10 milliseconds
    • the total (system) response time is 20 milliseconds
Parent topic: Collecting and Viewing Data on Transactions


Windows Event Log

The Enterprise Server product can be configured to log the console log messages to the Windows Event Log. Each enterprise server instance, which is configured to enable this feature, will then log each console log message as a separate Windows event under the Enterprise Server Windows Event Log. The events logged under the Enterprise Server Windows Event Log can be viewed using the Windows Event Viewer.

  • To Enable Windows Event Logging
  • To Use Windows Event Logging
Parent topic: Monitoring Enterprise Server


To Enable Windows Event Logging

  1. In Enterprise Server Administration, click Edit against the server that you want to configure for Windows Event Logging.
  2. Go to the Windows Monitoring and Management option by selecting the Server, Properties and General tabs.
  3. Choose the category of messages to be logged by selecting the appropriate checkboxes.
  4. Click Apply.
  5. Click OK.
  6. Start the server. If any of the checkboxes were selected, the following message will be displayed upon the console daemon, indicating that Event Logging has been enabled:
    CASCD4005I Windows Event logging Enabled
Parent topic: Windows Event Log
Parent topic: Monitor and Manage Enterprise Server


To Use Windows Event Logging

  1. Start the Windows Event Viewer from Windows Administrative tools, or by typing eventvwr.exe at the Windows command prompt.
  2. To view the event properties logged by the enterprise servers, select the Micro Focus Server Windows Event Log in the Left Hand pane.
  3. To monitor the log from a remote computer, select connect to another computer under the Actions menu.
Note:

Severe messages appear in the Event Log as Error Type. These can be distinguished by an ‘S’ at the end of the error code given in the event description.

Parent topic: Windows Event Log
Parent topic: Monitor and Manage Enterprise Server


Performance Counters

You are able to configure Enterprise Server to provide custom Windows performance counters through the WMI infrastructure. Each enterprise server instance that is configured to provide performance counters exposes performance information through the WMI. This information can then be monitored using applications such as the Windows Perfmon tool.

The provided performance counters are:

  • Available Shared Memory
  • Average Request Latency
  • Average Task Duration
  • Dump Count (since start-up)
  • Pending request Count
  • SEP Count
  • Task Count (last 60 seconds)
  • Task Count (since start-up)
  • To Enable Performance Counters
  • To Use Performance Counters
Parent topic: Monitoring Enterprise Server


To Enable Performance Counters

  1. In Enterprise Server Administration, click Edit against the server that you want to configure for Performance Monitoring.
  2. Go to the Windows Monitoring and Management option by selecting the Server, Properties and General tabs.
  3. Select the Allow Performance Monitoring checkbox.
  4. Click Apply.
  5. Click OK.
  6. Start the server. The following message will be displayed in the console daemon to indicate that Performance Monitoring has been enabled:
    CASAM3016I ES Monitoring and Management Support Enabled
Parent topic: Performance Counters
Parent topic: Monitor and Manage Enterprise Server


To Use Performance Counters

  1. Launch the Windows Event Viewer from Windows Administrative tools, or by typing Perfmon.exe at the Windows command prompt.
  2. Right click on the graph in the right hand pane and select Add Counters.
  3. Select Micro Focus Server System from the list in the Add Counters dialog box.
  4. Select the counters to be plotted from the counters list.
  5. Select the servers for which you wish to plot the counters from the instances list.
  6. Click Add.
Note:

After starting an enterprise server, it takes up to a minute before Server Enterprise Edition updates the performance information. During this time, all performance counters will have a value of "Zero". Thereon, information is updated every minute.

Parent topic: Performance Counters
Parent topic: Monitor and Manage Enterprise Server


Management Packs for System Center Operations Manager

System Center Operations Manager (SCOM) is a Microsoft product that manages Windows Server Systems. It enables event, health and performance monitoring and also provides the capability to highlight relevant and important information to help prevent issues from going unseen.

Management Packs are provided in Enterprise Server to define specific rules and monitors. In addition, they provide a means of discovering instances of enterprise server instances and their properties, monitoring of the Windows Event Log for key messages and displaying performance counter data.

Integration with Operations Manager requires a SCOM agent to be deployed to each machine that is to be managed. This agent monitors events and performance data based upon rules defined in the Management Packs. For information on how to deploy SCOM agents, refer to the System Center Operations Manager documentation.

There are three Enterprise Server Management Packs:

  • MicroFocus.Server.Core.Library.mp
  • MicroFocus.Server.EnterpriseServer.ManagementPack.mp
  • MicroFocus.Server.EnterpriseServer.MTO.ManagementPack.mp
Note:

Discovery occusr for each enterprise server instance regardless of whether it is enabled for event logging or performance monitoring.

The discovery interval is 60 minutes, so a change of properties in a server may not immediately appear in Operations Manager.

  • Monitors
  • Rules
  • Discovery
  • Enterprise Server Tasks
  • To import Server Management Packs into Operations Manager
  • To View Server Instances and Properties in Operations Manager
  • Extending and Overriding Management Packs
Parent topic: Monitoring Enterprise Server


Monitors

A monitor is a state machine that is used to represent a particular aspect of the application, device, or service being monitored. They are used to determine the health state of a particular component and are integral part of the health model. The monitor can check for a single event or a wide range of events that represent many different problems.

When a key message is reported to the event log, it will be indicated in the Health Explorer for the relevant enterprise server instance. The server's overall state will also indicate that an error or warning has occurred.

In the event of an error, a monitor will need to be reset in order to return it to a healthy state. An exception to this is the Shared memory storage constrained message. If a message is detected that indicates the constraint has ended, then the health state for that monitor will return to healthy.

The following monitors, with associated error codes and descriptions, are included in the Micro Focus Management Packs:

  • Monitor Category: Availability
  • Monitor Category: Configuration
  • Monitor Category: Micro Focus Server Operation
  • Monitor Category: Performance
Parent topic: Management Packs for System Center Operations Manager


Monitor Category: Availability

The following Availability monitors, with associated codes and descriptions, are included in the Micro Focus Management Packs:

Database Connectivity
Code | Error Description
CASRM0002S | ODBC resource manager initialization terminated abnormally
Processes
Code | Error Description
CASSP0003E | Process termination recovery initiation failed
CASSP0004E | Process termination recovery initiation failed
CASSP0014S | Process termination due to RTS error
Resources
Code | Error Description
CASSI0006S | Error opening RDO file
CASFC0008I | Error accessing file. File closed and disabled.
CASCS5011W | Failed to open port for TCPIPSERVICE
SEPs
Code | Error Description
CASCD0144S | SEP failed to initialize
CASCD0154S | SEP abended
Server Manager Operation state
Code | Error Description
CASCD0152S | Service execution process manager abended
CASCD0142S | Service execution process manager abended
CASCD0141S | Service execution process manager failed in initialization
CASSI1001S | Service execution process manager initialization failure
CASSI1002S | Server manager failed the license check
CASSI1003W | Service execution process manager initialization error, no MSS license found
CASCD0143S | Service execution process manager failed in termination
CASCD0151S | Service execution process manager abended in initialization
CASCD0153S | Service execution process manager abended in termination
XA Resources
Code | Error Description
CASXO0001S | XA Resource Manager initialization error
CASXO0016S | XA interface initialization failure
CASXO0023S | Severe error detected in XA interface, RM interface disabled
CASXO0025I | XA Switch enabled on demand
CASXO0015I | XA interface initialized successfully
ES Communications Server
Code | Error Description
CASCD0169S | ES Communications Service execution process abended
CASCD1040S | ES Communications Service execution process exited
Parent topic: Monitors


Monitor Category: Configuration

The following Configuration monitors, with associated error codes and descriptions, are included in the Micro Focus Management Packs:

General
Error Code | Error Description
CASSI0005S | Requested SIT could not be found
Parent topic: Monitors


Monitor Category: Micro Focus Server Operation

The following Micro Focus Server Operation monitors, with associated error codes and descriptions, are included in the Micro Focus Management Packs:

Database Connectivity
Error Code | Error Description
CASRM0005S | ODBC resource manager error
Processes
Error Code | Error Description
CASKC6001S | Unable to kill process
Resources
Error Code | Error Description
CASSP0010S | Syncpoint failure - resource state unpredictable
CASSP0011S | Syncpoint failure - resources ROLLEDBACK
CASSP0013S | Rollback failure - resource state unpredictable
XA Resources
Error Code | Error Description
CASXO0002S | Switch Load Module failed to load
Parent topic: Monitors


Monitor Category: Performance

The following performance monitors, with associated error codes and descriptions, are included in the Micro Focus Management Packs:

Shared Memory
Error Code | Error Description
CASKC0007W | Shared memory storage constrained
CASKC0008I | Shared memory storage constraint ended
Transactions (CICS)
Transaction ABENDs
Error Code | Error Description
CASKC0001E | Transaction abend (system)
CASKC0041E | Transaction abend (timeout)
CASKC0042I | Transaction abend (user)
Transaction Thresholds
Error Code | Error Description
CASKC6003I | Transaction threshold breached
CASKC6004I | Transaction completed, but threshold breached
JES Time Threshold (JES only)
Error Code | Error Description
CASKC6002I | Job terminated due to exceeding TIME parameter
IMS Time Threshold (IMS only)
Error Code | Error Description
CASIP0026I | Transaction completed but exceeded its threshold
CASKC6005I | Transaction has exceeded its threshold
Parent topic: Monitors


Rules

Rules collect data from Micro Focus provided Performance Counters and event log occurrences. Alerts can be generated from the collected monitoring data.

An example rule is included which monitors for abnormal SEP termination (CASCD0154S). If this particular error is reported to the event log, then an alert will be raised indicating which enterprise server reported the alert.

Parent topic: Management Packs for System Center Operations Manager


Discovery

Once an agent has been installed on a machine, it will discover all enterprise server instances that reside there. For each instance, the following, if defined, is also discovered:

  • Properties from the General tab in the ES Admin pages
  • Listeners and their properties
  • Services and their properties
  • Request Handlers and their properties
  • Packages and their properties
  • CICS properties
  • JES properties
  • JES Initiators and their properties
  • JES printers and their properties
  • IMS properties
  • IMS DB properties
  • IMS TM properties
  • IMS MPRs' and their properties
Note:

Discovery will occur for each enterprise server instance regardless of whether it is enabled for event logging or performance monitoring.

The discovery interval is 1 hour, so a change of properties in a server may not immediately appear in Operations Manager.

Parent topic: Management Packs for System Center Operations Manager


Enterprise Server Tasks

The management packs give you two tasks in Operations Manager's Actions pane that you can use to start administration pages.

View Enterprise Server Administration Page
Opens the Enterprise Server Administration page for the machine on which the selected server is installed.
SEPs View
Opens the Enterprise Server Monitor and Control page for the selected server in SEPs view.
Parent topic: Management Packs for System Center Operations Manager


To import Server Management Packs into Operations Manager

Monitoring using the Management Pack definitions begins as soon as an agent has been installed on a client machine.

  1. Start Operations Manager.
  2. In the Operations Console, click Administration.
  3. Right click on Management Packs.
  4. Select Import Management Packs.
  5. Navigate to the directory containing the Server Enterprise Edition Management Packs: %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source\enterpriseserver\monitoring\mps. Select all and click Open.
  6. Click Import.
Parent topic: Management Packs for System Center Operations Manager
Parent topic: Monitor and Manage Enterprise Server


To View Server Instances and Properties in Operations Manager

  1. Start Operations Manager.
  2. In the Operations Console, click Monitoring.
  3. Navigate the directory tree: Micro Focus Monitoring and Management > Product Name > Enterprise Server . The following are displayed in the tree:
    • Server overall state
    • MSS
    • Performance view

To work with Server overall state take the following steps:

  1. Select Server overall state from the directory tree. A list of enterprise server instances is displayed in the main panel.
  2. To display a list monitoring and performance options for a specific server, right click the server name and take the Open option.
  3. Select the list item you wish to view. To view properties of a specific server, select Diagram view, expand the diagram tree if necessary, and click on the appropriate server icon. To view the health state of a server, select Health Explorer for Server-name.
  4. Select File->Close to return to the list of servers.

To work with MSS take the following steps:

  1. Expand MSS in the directory tree.
  2. Select MSS systems state from the directory tree. A list of MTO enabled enterprise server instances is displayed in the main panel.
  3. To display a list monitoring and performance options for a specific server, right click the server name and take the Open option.
  4. Select the list item you wish to view. To view properties of a specific server, select Diagram view, expand the diagram tree if necessary, and click on the appropriate server icon. To view the health state of a server, select Health Explorer for Server-name.
  5. Select File->Close to return to the list of servers.

To work with Performance view take the following steps:

  1. Select Performance view from the directory tree. A graph with a list of counter instances for each enterprise server running that is enabled for performance monitoring is displayed in the main panel.
  2. Select the appropriate performance counter check box to plot the counter value on the graph.
Parent topic: Management Packs for System Center Operations Manager
Parent topic: Monitor and Manage Enterprise Server


Extending and Overriding Management Packs

Although the Enterprise Server Management Packs cannot be modified directly, custom Management Packs can be created to override and extend their behaviour. Refer to the System Center Operations Manager documentation for details on how to do this.

Parent topic: Management Packs for System Center Operations Manager


User Exits for Request Handlers

This section describes how to write user exit programs that allow you to customize the behavior of the Micro Focus MFRHSOAP request handler.

The Micro Focus MFRHSOAP request handler provides a number of user exit points, enabling you to supply a user exit program that can perform additional processing of input and output parameters.

You can also provide a user exit program for use with a custom request handler, if you find this approach offers advantages over including all the code you need in the request handler itself.

You specify a user exit program and the exit points at which it is to be invoked by the request handler at run time as part of the interface mapping process, described in the chapter COBOL Web Services with the Interface Mapping Toolkit in your Web Services and COBOL book. This information is built into the interface definition table (IDT) associated with the mapped service.

  • User Exit Points Provided
  • Structure Definitions and Type Definitions
  • Linkage Section Field Names
  • Deploying a User Exit Program
Parent topic: Enterprise Server Configuration and Administration


User Exit Points Provided

Figure 0-1 shows the interaction between request handlers, the application container and the run-time interface mapper.

Figure 1. Request Handler Exit Points
Request Handler Exit Points
The user exit points are indicated by squares numbered from 1 through 9. The table below gives the name and purpose of the exit points.
Number | Name | Description
1 | External data value modification – input parameter | Enables you to modify the external data value specified in a client request before the request handler’s default mapping for the parameter occurs. This exit point is invoked for each external-to-internal input parameter mapping that is specified in the IDT.
2 | Internal data value modification – input parameter | Enables you to override the internal data value created by the request handler’s default mapping for a parameter. This exit point is invoked for each external-to-internal input parameter mapping that is specified in the IDT.
3 | Unmapped named external input parameter | Enables you to provide processing of any input parameters that do not have associated input parameter mappings defined in the IDT. This exit point is invoked for each unmapped named input parameter.
4 | End of input request processing | Enables you to set up parameter values other than the external parameters specified in the client request. It also provides the opportunity for any resources allocated in exit points 1 through 3 to be released.
5 | Start of response processing | Enables you to bypass completely the default mapping used to build a client response. The exit program is responsible for the creation of the response that will be sent back to the client by the application container.
6 | Internal data value modification – output parameter | Enables you to modify the internal data value as created by the user application before the request handler’s default mapping for the parameter occurs. This exit point is invoked for each internal-to-external output parameter mapping that is specified in the IDT.
7 | External data value modification – output parameter | Enables you to override the external data value created by the request handler’s default mapping for a parameter. This exit point is invoked for each internal-to-external output parameter mapping that is specified in the IDT.
8 | End of response processing | Enables you to modify the response generated by the default mapping.
9 | End of request processing | Enables you to release any resources that were allocated in exit points 1 through 8.
Parent topic: User Exits for Request Handlers


Structure Definitions and Type Definitions

To help COBOL and C programmers, we provide a COBOL copybook (cbltypes.cpy) and a C header file (svext.h) with Server Enterprise Edition. These files contain definitions of the structures and interfaces that you will require to write user exits and custom request handlers.

One of these is the IDP_EXIT_INFO structure, which is used for passing the information required by the exit routines for processing at each exit point. A pointer to this structure, together with the exit point identifier, is passed to each exit routine. The information passed and returned depends on the exit point.

For definitions of the information passed at each exit point see the reference Help topics Exit Points.

For definitions of support functions see the reference Help topics Functions.

Parent topic: User Exits for Request Handlers
Related information
Exit Interface Definition
External Data Value Modification - Input Parameter (Exit Point 1)
Internal Data Value Modification - Input Parameter (Exit Point 2)
Unmapped Named External Input Parameter (Exit Point 3)
End of Input Request Processing (Exit Point 4)
Start of Response Processing (Exit Point 5)
Internal Data Value Modification - Output Parameter (Exit Point 6)
External Data Value Modification - Output Parameter (Exit Point 7)
End of Response Processing (Exit Point 8)
End of Request Processing (Exit Point 9)
PFV_IDPES_FN_ALLOC_MEM
PFV_IDPES_FN_FREE_MEM
PFI
PFI_IDPES_FN_DISPLAY_TO_UTF16
PFI_IDPES_FN_UTF16_TO_DISPLAY
IDP_EXIT_INFO
IDP_EXIT_SERVICE_FUNCS


Linkage Section Field Names

Several of the exit points are provided so that you can manipulate an input or output field. The way you pass a field name in the exit interface depends on how it is defined in the Linkage Section of the program providing the service. There are two possibilities:

  • The item is defined at level 01. In this case, the field name passed in the exit interface is the same as the field name in the Linkage Section
  • The item is defined at a level subordinate to level 01. In this case, the field name passed in the exit interface is composed of the field name prefixed by a concatenation of the names of the group items that it belongs to. The individual names are separated by "." characters. For example: field "e" in the record below would be uniquely identified as "a.b.c.e".
    01 a.
   03 b.
      05 c.
         07 d     pic x(4).
         07 e     pic x(4).
         07 f     pic x(4).
      05 g        pic x(4).
   03 h           pic x(4).

    If the field itself, or any of the group items that it belongs to, are tables, the required table index is specified by appending “(n)” to the name, where n indicates the position of the field or item in the table. For example, field “f” of the fourth element of “c” in the record below would be uniquely identified as “a.b.c(4).f”:

    01 a.
   03 b.
      05 c occurs 10.
         07 d     pic x(4).
         07 e     pic x(4).
         07 f     pic x(4).
      05 g        pic x(4).
   03 h           pic x(4).
Parent topic: User Exits for Request Handlers


Deploying a User Exit Program

To deploy a user exit program, copy it into %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin (32-bit) or \base\bin\win64 (64-bit) if Server Enterprise Edition is installed as part of Studio Enterprise Edition, and %ProgramFiles(x86)%\Micro Focus\Server Enterprise Edition x.x\bin(32-bit) or \bin\win64 (64-bit) if Server Enterprise Edition is installed stand alone.

Parent topic: User Exits for Request Handlers


Troubleshooting

This section describes how to set about diagnosing common problems that can occur with running applications in Enterprise Server and gives some advice about overcoming them.

Failures fall into the following categories:

  • Incorrect output (an application or system function produces the wrong results or exhibits unexpected behaviors). These include application abends.
  • Unexpected system terminations. Either the whole enterprise server terminates or a subsystem (support process) terminates.
  • System loops. These include application loops and enterprise server subsystem loops. They are characterized by an abnormal accumulation of CPU time by an enterprise server process and may display the same external symptoms as a system hang.
  • System hangs. Any problem where the enterprise server appears to stop responding to its clients (except for loops).

    This can also be the result of problems with inter-system communications.

  • Determining the Failure Type
  • Collecting Information
  • Data Capture
  • Checking the Communications Process
  • Using the Console Logs
  • Using a Diagnostics Server
  • What You Can Do with Dumps and Traces
Parent topic: Enterprise Server Configuration and Administration


Determining the Failure Type

Key initial classifiers for a failure are:

  • The console log.

    This contains an easy-to-read history of enterprise server system activity leading up to the problem. When viewing the console log:

    • Investigate messages with levels other than information first.
    • Frequently, the enterprise server will continue to appear normal for some time after a failure so the 10 to 15 minutes before the failure should be investigated in detail (including the information messages).
  • The list of processes.

    Inspect the processes associated with the failing enterprise server (providing the server did not shut down). Loops may be indicated if there is a significant difference in the CPU time for a process between the list in the healthy data capture and the list in the problem data capture.

  • The list of shared memory areas and semaphores.

    An unusual number of objects may indicate an operating system problem. To evaluate this, compare the list with one obtained when the enterprise server system is in a healthy state.

These classifiers coupled with the external symptoms should provide enough information to assign the failure to one of the types of failure listed.

  • Incorrect Output
  • Unexpected System Termination
  • Invalid Credentials Error
Parent topic: Troubleshooting


Incorrect Output

The next step here is to differentiate between application problems and enterprise server infrastructure problems.

Application failures other than abends are often application problems. Look at the active trace dataset coupled with the system trace table in the dump X dataset (casdumpx.rec) to establish the application activity before the failure.

Application abends can be due to application problems or enterprise server infrastructure problems. Look in the active dump dataset for an RTS error dump. If found, evaluate the RTS error and classify the problem from this. What module experienced the failure, application or enterprise server infrastructure?

Parent topic: Determining the Failure Type


Unexpected System Termination

Inspect the system console log for messages indicating the cause of the shutdown and classify the failure from these.

  • Loops
  • System Hangs
Parent topic: Determining the Failure Type


Loops

Use the name of the looping process to classify the failure. If the looping process is a service execution process (cassi on Windows and cassi32 on UNIX, but referred to in the remainder of this chapter as cassi), the loop could either be in an enterprise server subsystem or in the application; look at the active trace dataset and the system trace table from the dump X dataset to determine which module last got control. If it was the application, consider using FaultFind on the process to acquire more information on the next occurrence of the failure.

If the looping process is cassi but the last module to get control was not part of the application, or if the looping process is not cassi, you should refer the problem to Micro Focus technical support.

Parent topic: Unexpected System Termination


System Hangs

Find out whether all client requests are suffering from lack of response from the enterprise server, or just one type of request.

Try dynamically increasing the number of service execution processes by clicking Details in the Current status column, then on the Enterprise Server Details page, specifying the new number in Requested Service Execution Processes and clicking Update. The new processes should appear in the list after a short delay. Success shows that shared memory is not locked and that the enterprise server is still functioning correctly at some level, even though the external symptoms of the problem might still be present.

Check the number of active service execution processes (cassi processes), using the dump X dataset. Inspect the despatch control blocks, one for each service execution process. Are all service execution processes currently occupied with a transaction? Is the occupying transaction the same for each cassi process or was the last command executed by each cassi process the same? If either of these is true, consider the following possibilities:

  • That enough requests of the problem type have arrived to block all the available cassi processes, such that it appears that the whole enterprise server has failed. This might indicate a customer application issue.
  • That enough normal long running requests have arrived to occupy all available cassi processes, such that it appears that the whole enterprise server has failed. If this seems likely, you might be able to fix the problem by increasing the number of service execution processes.

Another possibility is that the server's shared memory is locked. The best way to check for this is to compare the date and time of the last trace entry in the dump X dataset to the date and time of the dump. The larger the gap between the two times, the more likely it is that shared memory is locked. If shared memory is not locked, try to determine what the server is waiting for. If shared memory is locked, try to determine which process left shared memory in this condition.

  • One Type Of Request is Failing
  • All Client Requests are Failing
Parent topic: Unexpected System Termination


One Type Of Request is Failing

Consider the possibility that the application is suffering the effects of resource contention. Consider the possibility that the service listener has failed.

Parent topic: System Hangs


All Client Requests are Failing

Try dynamically increasing the number of service execution processes by clicking Details in the Current status column, then on the Enterprise Server Details page, specifying the new number in Requested Service Execution Processes and clicking Update. The new processes should appear in the list after a short delay. Success shows that shared memory is not locked and that the enterprise server instance is still functioning correctly at some level, even though the external symptoms of the problem might still be present.

Check the number of active service execution processes (cassi processes), using the dump X dataset. Inspect the despatch control blocks, one for each service execution process. Are all service execution processes currently occupied with a transaction? Is the occupying transaction the same for each cassi process or was the last command executed by each cassi process the same? If either of these is true, consider the following possibilities:

  • That enough requests of the problem type have arrived to block all the available cassi processes, such that it appears that the whole enterprise server instance has failed. This might indicate a customer application issue.

  • That enough normal long running requests have arrived to occupy all available cassi processes, such that it appears that the whole enterprise server instance has failed. If this seems likely, you might be able to fix the problem by increasing the number of service execution processes.

Another possibility is that the enterprise server instance's shared memory is locked. The best way to check for this is to compare the date and time of the last trace entry in the dump X dataset to the date and time of the dump. The larger the gap between the two times, the more likely it is that shared memory is locked. If shared memory is not locked, try to determine what the enterprise server instance is waiting for. If shared memory is locked, try to determine which process left shared memory in this condition.

Parent topic: System Hangs


Invalid Credentials Error

If you get an INVALID_CREDENTIALS error in the console log when an enterprise server starts up, as follows:

CASCD4002W Error (INVALID_CREDENTIALS) binding to MFDS CASCD0102F TX Daemon Failed to Initialize

this indicates a problem with the internal files that hold details of Directory Server user IDs and passwords (in encrypted form). If you see this error, you should check that the following files exist in the Micro Focus Directory Server schema directory, which by default is C:\Documents and Settings\All Users\Micro Focus\Net Express\6.0\mfds:

  • usr.dat

  • ugp.dat

  • ace.dat

  • prm.dat

These files are initially created from the cciusers.dat file located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin. If there was a problem reading this file or creating the initial security information, you can attempt to recreate the data by re-importing this file. To do this:

  1. On the home page of Enterprise Server Administration, click Users in the menu on the left hand side.

  2. Click Import... under the list of users.

    This displays a page confirming the location of the cciusers.dat file, and asking whether you wish to replace all existing user information (default: yes).
    Note: Import... is not available when your Directory Server is running in restricted mode.

  3. Click OK.

To start an enterprise server requires that certain system user accounts exist. The user IDs required are mf_mdsa and mf_cs, and they should exist in the default cciusers.dat file which is shipped with the product.

Parent topic: Determining the Failure Type


Collecting Information

For all troubleshooting exercises it is essential to gather as much information as possible about the state of the enterprise server when the problem occurred and about the events leading up to the problem.

When a problem occurs, you need to capture not only the current log files, dumps and traces, but also the contents of various files, directories and areas, and the output from a number of operating system tools. It is important to have data capture mechanisms in place in advance of a failure so that the data can easily be obtained when required.

In a production system, we recommend that you restore the enterprise server service to its clients before you start analyzing the data you have captured. We also recommend that you perform data capture on the enterprise server in a healthy state shortly after the supporting operating system has been rebooted and the enterprise server started. You should retain this healthy data capture to compare with the failure data capture.

You should also check whether the enterprise server is responding to client requests, and to requests from ESMAC. Lack of response points to problems with the communications process (MFCS).

  • Directory Server Journal
  • Enterprise Server System Directory
  • Enterprise Server Log Files
  • Dumps and Traces
Parent topic: Troubleshooting


Directory Server Journal

The Directory Server logs events to its journal. This is usually under the C:\Documents and Settings\All Users\Application Data\Micro Focus\ folder, in a sub-folder, <product name>\X.X\journal.dat. The most recent entries are also available on a page of the Enterprise Server Administration Web interface.

You can change the maximum file size, the number of entries displayed and the level of logging on the Configure Options page of Enterprise Server Administration. When the journal reaches the maximum file size set, the most recent journal entries overwrite the oldest journal entries. For troubleshooting purposes, you might want to increase the maximum file size to 256 KB or more.

The three levels of logging available are:

  • Errors only
  • Errors and warnings
  • All information

For troubleshooting purposes, you might want to set the maximum level of logging.

  • To View the Journal
Parent topic: Collecting Information
Related information
To configure the Directory Server
To view the journal


Enterprise Server System Directory

Each Enterprise Server writes log, dump and trace information to files in its System Directory. The default location for the System Directory is usually a sub-folder underC:\Documents and Settings\user-ID\My Documents\Micro Focus . The sub folder is \<product name>X.X\WORKAREA\es-name(where <product name> is the name of the product you installed, and user-ID is the user account that is running Enterprise Server).

You can change the location of the System Directory by editing the Enterprise Server's definition in Enterprise Server Administration.

Note:

If you are running the Directory Server as a service that logs on as the Local System account (LocalService), any Enterprise Server that it starts will also run under that account. Hence, the default location of the log file will be C:\Documents and Settings\LocalService\My Documents\Micro Focus\<product name>\ X.X\WORKAREA\es-name\console.log. By default, Windows hides the LocalService subdirectory of Documents and Settings. In order to view this directory, you must configure your Windows Explorer so that: Show hidden files and folders is set, and Hide protected operating system files is not set.

  • To Change the System Directory
Parent topic: Collecting Information
Related information
Moving the Diagnostics Data


To Change the System Directory

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server for which you want to change the number of instances.

    The Server > Properties > General page

    is displayed/
  2. Specify the new System Directory location.
    Note:
    • If you specify a directory in this field, that directory must exist; Enterprise Server does not create it for you.
    • The System Directory cannot be shared between enterprise servers.
  3. Click OK.
  4. You must restart the server for the changes to take effect.
    1. If the server is started, stop it.
    2. Start the server.
Parent topic: Enterprise Server System Directory
Parent topic: Work with Servers


Enterprise Server Log Files

An enterprise server logs messages to a file, console.log, in its System Directory.

When an enterprise server starts, it renames any existing console.log file to console.bak, erasing any existing console.bak file. You should include both console.log and console.bak in your data collection. Make sure you copy them to a safe place before restarting the enterprise server.

  • Communications Process Log Files
Parent topic: Collecting Information


Communications Process Log Files

Communications processes (MFCS) log messages to the communications process log file, log.html, in its System Directory.

If multiple communications processes are running, the date and time stamp at the beginning of each message is followed by an instance identifier in square brackets, for example, [2].

By default, there is only one log file which grows continuously until it is deleted by an administrator. However, you can use the mf-server.dat file to activate rotating log files, and to change the level of logging. The mf-server.dat file is located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin. It uses the ini-file format of section tags in square brackets followed by name=value pairs.

With rotating log files, MFCS uses multiple log files, named log-1.html, log-2.html, etc. When a log file reaches a configured size, MFCS moves on to the next file (which will be deleted first if it already exists). When it reaches the configured number of log files, it returns to log-1.html, overwriting it.

The syntax is as follows:

[logging]
 files=number-of-files
 filesize=maxsize
 dscontrol=none|standard|all
 dirsvc=none|unusual|processing|not-found|all

All the parameters are optional. However, to activate rotating log files, both files= and filesize= must be set, and files= must be set to a number greater than 1. These parameters configure rotating log files, as explained above. If both are set, then the total log file space required by MFCS will not exceed files*filesize (approximately). For example, to limit the log to three files of 100 KB each:

[logging]
files=3
filesize=100

The parameters are explained below.

  • Files
  • filesize
  • dscontrol
  • dirsvc
Parent topic: Enterprise Server Log Files
Related information
System Directory


Files

files=number-of-files
Specifies the number of log files.
Parent topic: Communications Process Log Files


filesize

filesize=maxsize
Specifies the maximum size of a log file in kilobytes (KB)
Parent topic: Communications Process Log Files


dscontrol

dscontrol=none|standard|all

Sets the level of logging for control messages. These messages normally come from Directory Server (MFDS) though they can come from other sources as well. These messages include server monitor probes, requests for log and dump data, and dynamic configuration changes.

none
Don't log control messages.
standard
Log control messages that update MFCS configuration or status. Don't log messages that just request information, such as the KEEPALIVE probe messages that MFDS uses to check if the enterprise server is still running.
all
Log all control messages.

You might want to set this to "all" if you are investigating a problem with the server monitor or other control flows, or set it to "none" if you want to avoid logging messages about configuration changes or other control requests.

Default = standard

Parent topic: Communications Process Log Files


dirsvc

dirsvc=none|unusual|processing|not-found|all
none

Don't log information about Directory Server activities.

unusual
Only log unusual results, such as duplicate object names, which may indicate configuration problems.
processing
Also log some messages about the progress of normal processing. This is the default.
not-found
Also log some messages about searches that return a not-found status. Normally these are not logged because MFCS expects some optional configuration items to be missing if they are not needed. In some cases, though, logging all not-found results may help diagnose configuration issues.
all

Log even more information, including normal MLDAP unbind operations.

Default: processing

Parent topic: Communications Process Log Files


Dumps and Traces

We recommend that you always run a production system with some diagnostics switched on. This is necessary so that you can troubleshoot unexpected problems. Diagnostics consume resources, and there is always contention between problem determination facilities and performance. You need to decide how important it is to be able to diagnose a problem the first time it occurs rather than having to try to recreate it or having to just turn on diagnostics and wait for it to reoccur. We suggest the following level of diagnostics as a minimum:

  • Turn on tracing for the application component.
  • Select dump on system abend.
  • Turn on the auxiliary trace and select a dump dataset size such that a minimum of 10 minutes of data can be held within a single trace dataset. If you set more trace points or transaction volumes increase, you will need to increase the diagnostic dataset size even more in order to achieve this objective.
  • Set the local trace table size to at least 70.

You might also need to turn on tracing for task control, storage control and application container components.

You specify settings for traces and internally triggered dumps on the Edit Server > Diagnostics page or the Control page of ESMAC. The trace flags on the ESMAC Control page that are equivalent to the trace flags on the Edit Server > Diagnostics page are as follows:

Edit Server > Diagnostics page | ESMAC Control page
Application | API
Task Control | KCP
Storage Control | SCP
Application Container | RTS

Settings you make on the Edit Server > Diagnostics page override those you make on the ESMAC Control page.

Dumps created when the system or a transaction abends are internally triggered dumps; as long as you have selected them on the Control page, they will be created when abends occur. You can also obtain an externally triggered dump, that is, a dump that is taken immediately in response to a command. There are several ways of initiating an externally triggered dump:

  • Click Create Dump on the Edit Server > Diagnostics > Dump page
  • Click Dump on the ESMAC Control page
  • Run the command casdump; for more information see the help topic casdump.

The casdump command gives you more flexibility.

Note: Note:

casdump will not work if the Directory Server is running as a system service and you started the server from the Enterprise Server Administration interface, because the server will not be running under your user ID; in order for casdump to work you must do one of:

  • Run the Directory Server under your own user ID; see the section Starting and Stopping in the chapter Introduction to Enterprise Server Administration.
  • Run the Directory Server as a system service, but start the enterprise server using the command casstart (see the help topic casstart).
  • Run the Directory Server as a system service, but change the system service definition to use your user ID rather than LOCAL_SYSTEM. Note that this will prevent the enterprise server console window from being displayed; you can still view the console from the Administration Interface.

First run casdump as follows:

casdump /res-name

By default, casdump attempts to lock shared memory before creating the dump. If enterprise server fails in a way that leaves shared memory locked, the command might hang.

If the command hangs, you can run it again with the /d option:

casdump /res-name /d

Using /d means "do not lock shared memory". This could also cause the command to fail due to shared memory being changed by the running enterprise server while casdump is chasing and dumping storage chains.

Alternatively, use the /b option which dumps all of shared memory as a block at the very beginning before it starts to chase chains and format blocks.

If you are planning to send the dump file to Micro Focus for investigation, you might also be asked to run the command with the /f option; this option dumps the FAQE chain (Free Area Queue Element) and shared memory as a block.

An externally triggered dump is written to the dump X dataset, casdumpx.rec, if you specify the /d option, or the current dump dataset casdumpa.rec or casdumpb.rec if you do not specify it.

  • Producing a core dump for run-time errors
Parent topic: Collecting Information
Related information
To view a dump
To change the trace dataset
To transfer the in-memory trace data to the auxiliary dataset at rollover
casdump
casstart
Starting and Stopping the Directory Server


Producing a core dump for run-time errors

By default, Enterprise Server does not create a core dump for run-time errors. For example, by default, if the operating system detects a memory access violation caused by your application, no core dump is produced. You must configure the system to produce a core dump for these situations.

Once you have produced a core dump, you can debug the core dump to help determine the cause of the error.

Note:
  • This functionality is available for the Windows and AIX operating systems only.
  • The functionality does not identify memory corruption issues. You can use it to identify application problems only.

To configure the system so that it creates a core dump for run-time errors, you need to create a run-time tunable configuration file, and add the tunable configuration file's details to your Enterprise Server region.

  • To create a run-time tunable file, create a text file, for example COBCONFIG.CORE.TXT with the following entries:
    SET CORE_ON_ERROR=131
SET CORE_FILENAME="core.%p@%t_%d"
  • To add the configuration to Enterprise Server, add the entry to your Enterprise Server region configuration. When you start the region, core dumps will be produced by run-time errors. See the illustration below for an example.
Figure 1. Configuring Enterprise Server core dumps for run-time errors
Configuring Enterprise Server core dumps for run-time errors
Parent topic: Dumps and Traces


Data Capture

The minimum items for data capture are:

  • Your enterprise server's System Directory, %USERPROFILE%\Documents\Micro Focus\Net Express x.x\WORKAREA \ESName, contains:
    • The console log: console.log and console.bak.
    • The communications process log file or files; see the topic Communications Process Log Files.
    • The trace diagnostic datasets, casauxta.rec and casauxtb.rec.
    • The system abend dump, if one exists (casdumpa.rec, casdumpb.rec or casdumpx.rec).
    • The externally triggered dump (filenames as for the system abend dump).
    Note: If your enterprise server is running under the Windows LocalService account, the directory might be hidden by Windows. See System Directory for more information.
  • A copy of the file cobver, located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin and \base\bin\win64 , and that holds the name and version of the product you are using.
  • If it exists, the mf-server.dat file is located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin.
  • The Directory Server configuration directory, usually under the C:\Documents and Settings\All Users\Micro Focus\Net Express\6.0\mfds directory.
  • The Directory Server log file (usually under the C:\Documents and Settings\All Users\Application Data\Micro Focus\NetExpress\6.0 directory); see the section Directory Server Journal.
  • Logs for other components that may be enabled such as Fileshare and FaultFind.
  • A list of processes running on the machine. You should obtain two lists - one at the beginning of the data capture list, and one at the end. You can obtain this from the Windows Task Manager.
  • A list of shared memory areas and semaphores. You can obtain this using third-party tools such as Process Explorer.
  • A list of network connections and listening sockets, obtained by running the netstat command.
  • Optionally, a list of open files. You can obtain this using third-party tools such as Process Explorer.
Note:
  • The operating system tools that you can use to obtain information such as Process Explorer provide a range of options. You can obtain advice on the most useful options from Micro Focus technical support.
  • Many of these items are held in the enterprise serve directory, so it's best to start by taking the whole directory

It is important that the data capture process is non-destructive, that is, does not damage a healthy system, and that it is non-blocking, that is, does not wait on anything that may not complete in a sick system.

Parent topic: Troubleshooting
Related information
Communications Process Log Files
System Directory
Directory Server Journal


Checking the Communications Process

When you take the data capture, you should also check that the communications process (MFCS) is still running. If it is, you can then check what it is currently doing. To do this:

  1. Write down the hostname of the machine where the enterprise server instance is running.
  2. Go to the Enterprise Server Administration Web interface. In the list of servers on the Home page, find the enterprise server instance that you want to check. The Communications Processes column lists one or more communications processes for that server. Write down each of the port numbers shown in the column. (The port number is the last part of the address, after the second colon.)
  3. In a web browser, go to the following URL:
    http://hostname:port/MF_KEEPALIVE

    where hostname is the hostname (or IP address) from step 1 and port is the first port number from step 2.

    If MFCS is working correctly, you should see a response similar to the following:

    Server=ESDEMO
ServerType=GKC
Version=1.2.5
Status=Started
  4. Repeat step 3 using "MF_STATISTICS" instead of "MF_KEEPALIVE". You then see a response showing what MFCS is currently doing, how many conversations it has processed, and other information.

If you are running multiple communications processes, you can check each one in turn using this method. Each of the port numbers you recorded in step 2 corresponds to a communications process. Note that some of your communications processes for a given server may be disabled; they do not need to be checked.

Parent topic: Troubleshooting


Using the Console Logs

For each enterprise server instance, you can view the console logs to help identify the cause of any problems. There are two consoe logs available:

  • The server console log (ES Console on the ESMAC tab menu) provides information about the server instance. This includes such details as when the server was started or stopped, the SEPs that were created, and so on.
  • The communications console log (CS Console on the ESMAC tab menu) provides information on the communications processes.
  • To View the Console Log for an Enterprise Server Instance
Parent topic: Troubleshooting


To View the Console Log for an Enterprise Server Instance

  1. On the Home page click Edit to the left of the server whose console log you want to view.
  2. Click the Diagnostics tab.
  3. Click the ES Console tab.
  4. If you want to see the whole log since the server was started, click Show Entire Log. The log opens in a text editor window.
  5. To return to ESMAC, click Back in your browser.

You can display the console log by clicking Display in the Diagnostics group of the left-pane menu when it is available. To return to ESMAC, click Back in your browser.

Parent topic: Using the Console Logs
Parent topic: Work with Servers


Using a Diagnostics Server

You can obtain the most value from the diagnostics aids if you use a dedicated enterprise server instance solely for investigating problems. This enterprise server instance is a diagnostics server.

You can then generate dumps and traces from the diagnostics server and compare them with the dump and trace data collected from the live server that experienced the problem.

  • Configuring a Diagnostics Server
  • Moving the Diagnostics Data
  • Viewing the Diagnostic Server Console Log
  • Viewing a System Trace: Diagnostics Example
  • Viewing a Dump
Parent topic: Troubleshooting


Configuring a Diagnostics Server

A diagnostics server is the same as any other enterprise server instance, that is it does not provide any additional diagnostics facilities.

The only difference is that a diagnostics server is configured not to produce any diagnostic information itself. This allows it to be used to process the diagnostic information from another server. The figure below shows the recommended configuration for a diagnostics server.

Figure 1. Configuration for a Diagnostics Server
Configuration for a Diagnostics Server
Parent topic: Using a Diagnostics Server


Moving the Diagnostics Data

Before you can start work on the data collected from the server that experienced the problem, you need to copy it into the diagnostics server. Here are the commands you need to move the collected data and the log files into a diagnostics server, assuming that:

  • You are in the System Directory of the enterprise server that experienced the problem
  • The diagnostics server is using the default System Directory location and %SystemDrive% is C:

In the examples below, Enterprise Server is installed as part of Studio Enterprise Edition:

copy *.rec "C:\Documents and Settings\username\My Documents\Micro Focus
\Studio Enterprise Edition X.X\WORKAREA\diagnostics-server-name"
copy console.log "C:\Documents and Settings\username\My Documents\Micro Focus\
Studio Enterprise Edition X.X\WORKAREA\diagnostics-server-name\console.aux"
copy console.bak "C:\Documents and Settings\username\My Documents\Micro Focus\
Studio Enterprise Edition X.X\WORKAREA\diagnostics-server-name\console.bak"

Here is a sample script that copies the required data to a diagnostics server called diagnose.

copy *.rec "C:\Documents and Settings\username\My Documents\
Micro Focus\Studio Enterprise Edition X.X\WORKAREA\diagnose\"
copy console.log "C:\Documents and Settings\username\My Documents\Micro Focus\
Studio Enterprise Edition X.X\WORKAREA\diagnose\console.aux"
copy console.bak "C:\Documents and Settings\username\My Documents\Micro Focus\
Studio Enterprise Edition X.X\WORKAREA\diagnose\console.bak"

Restart the server that experienced the problem after you have moved the data to the diagnostics server.

Parent topic: Using a Diagnostics Server
Related information
Enterprise Server System Directory
Moving the Diagnostics Data


Viewing the Diagnostic Server Console Log

Extra options exist for viewing a diagnostic server's console log. These commands are available with any enterprise server instance, but they are useful only in the context of a diagnostics server with the diagnostic files loaded from the problem server, copied using the commands described in Moving the diagnostics data.

To access the diagnostic server's ESMAC screen:

  1. In the Enterprise Server Administration screen, click the diagnostic server's Details button to access the server's Details screen.
  2. On the Details screen, click the ES Monitor & Control button to access the diagnostic server's ESMAC screen.

To use these extra options:

  • In the left pane in the Diagnostics area, select the Log and the C/x radio buttons (for current), then Display to view the current console log file, that is, the console.log file of the diagnostics server.
  • In the left pane in the Diagnostics area, select the Log and B radio buttons (for backup), then Display to view the backup console log of the problem server (console.bak). Note that this works only if you copied the data collection into the diagnostics server after you started it, because the process of starting it replaces the backup console log from the problem server with the backup console log of the diagnostics server
  • In the left pane in the Diagnostics area, select the Log and A radio buttons (for auxiliary), then Display to view the console log of the problem server (copied to console.aux)
Parent topic: Using a Diagnostics Server


Viewing a System Trace: Diagnostics Example

This subject is covered in the help topic To view a system trace. However, the options are complex and it is worth looking at an example.

To obtain a trace of the system trace table:

  1. In the Enterprise Server Administration screen, click the diagnostic server's Details button to access the server's Details screen.
  2. On the Details screen, click the ES Monitor & Control button to access the diagnostic server's ESMAC screen.
  3. In the Diagnostics area in the left pane, select the Trace radio button, and select either the A or B radio button to select the A or B dataset. (Don't select C, since the in-memory trace table belongs to the diagnostics server).
  4. In the Blocks field, specify the number of trace blocks that are to be aggregated into one trace index entry.
  5. Click Display.
Figure 1. Trace Index Page
Trace Index Page

Each block is the same size as the system trace table, that is, it contains the number of trace entries specified in Trace Table Size on the Edit Server page for the server. The index entries are displayed with a timestamp against each one. This is the timestamp of the first trace entry in each set of blocks. These timestamps help you narrow down your search to particular events.

To view the actual trace, go to one of the index entries, and make selections in the following fields:

  • In Blocks (immediately to the right of Details), specify how many blocks you want to be included in the trace. This defaults to the value you entered in Blocks in the Diagnostics group of the menu. You can change it to any value you want. Having two Blocks controls helps you control what is displayed in the formatted trace more precisely.
  • In Level, (the next control to the right), specify the level of detail that you want to see in the formatted trace. The options are:
    0 | Service start, module start, module end, service end. This is the default.
    1 | Enterprise server API entries and exits
    2 | Subsystem trace entries
    3 | All entries where it is possible to provide some formatting of the data
    4 | All trace entries
  • In PIDs (next to the right), check the check boxes for the process IDS of the processes in which you are interested. Check boxes are provided for all the processes that have trace entries in the blocks represented by this trace index entry. Process IDS are prefixed with a letter or number indicating the function of the process. The following letters are used:
    C | communications process (MFCS)
    F | Fileshare server (internal)
    J | journal control
    M | server manager
    R | recovery
    S | service execution process (SEP)
    U | unknown
    Z | generic terminal or client
  • In Task IDs (next to the right), check the check boxes for the task IDS of the tasks in which you are interested. Check boxes are provided for all the tasks that have trace entries in the blocks represented by this trace index entry.

The Level, PIDs and Task IDs controls are filters that help you select just the specific information of interest. If you leave the level as 0, the default, and don't check any process IDs or task IDs, you will see the minimum level of information for all processes and tasks that have entries in the block represented by the trace index entry. Note that it is possible to make selections such that no trace information is generated. This happens if you select both processes and tasks, and none of the selected tasks ran on the selected processes; a task cannot run on more than one process. If a task requires communications work, that work has its own process and task, and there is no automated way of relating the two task IDs. You always see the first trace entry in the block, irrespective of filtering.

Here is an example of how you can use the controls to select the information you want to see. Suppose you specify 10 in Blocks in the Diagnostics group of the menu. There are actually 60 blocks of information in the dataset, so 6 index entries are displayed. Suppose you were interested in a particular SEP, which you can see listed in the third and fourth index entries. You might then specify 20 in Blocks for the third index entry, check the box next to the process ID for the SEP, then click Details. Now you can only see trace entries for that SEP, in all the blocks that contain them, starting with the first block of the third index entry.

Each trace entry contains the following information:

Heading | Contents
None | An interpretation of the traced event, if one can be supplied
Seq | Sequence number of the entry in ascending order
Task-Nbr | The five-digit task number
ProcessID | The five-digit process ID
ID | the ID of the event, command, or instruction that was traced. This is a four-byte hexadecimal number.
hhmmsshh | A time stamp that indicates when the trace entry was written. The time stamp is in hours, minutes, seconds, and hundredths of a second.
aaaa bbbb | Eight bytes of entry-specific data

When you have finished viewing a trace, click Back to return to the trace index page.

Parent topic: Using a Diagnostics Server
Related information
To View a System Trace


Viewing a Dump

This topic provides an example of viewing a dump to locate the source of a problem.

You can obtain either a summary or a detailed dump. The summary information is included at the end of a detailed dump. Dumps whether summary or detailed include both system traces and local traces (traces for SEPs).

To access the diagnostic server's ESMAC screen:

  1. In the Enterprise Server Administration screen, click the diagnostic server's Details button to access the server's Details screen.
  2. On the Details screen, click the ES Monitor & Control button to access the diagnostic server's ESMAC screen.
  3. In the Diagnostics area in the left pane, select the Dump radio button, and select either the A or B radio button to select the A or B dataset. Select C to select the dump X dataset (the one created by an externally triggered dump).

    Ignore Blocks - it has no effect on the output.

  4. Click Display.
Figure 1. Dump Index Page
Dump Index Page

The index entries are displayed with the following information against each one:

  • The process ID
  • A code that helps identify the dump
  • The origin of the dump request
  • A date and timestamp

To view a dump, go to one of the index entries, and in Level, (the third control to the right), specify the level of trace detail that you want to see in the formatted dump. The options are:

0 | Service start, module start, module end, service end.
1 | Enterprise server API entries and exits
2 | Subsystem trace entries
3 | All entries where it is possible to provide some formatting of the data
4 | All trace entries. This is the default

Local trace tables (traces for SEPs) only have levels 0 and 1.

Note that this option has an effect on what you see in a detailed dump, but not in a summary dump.

Then click Details to see a full dump or Sum to see a summary dump.

When you have finished viewing a dump, click Back to return to the dump index page.

Parent topic: Using a Diagnostics Server
Related information
To View a Dump


What You Can Do with Dumps and Traces

This section details the tasks that you can perform on dumps and traces.

  • To Change the Trace Dataset
  • To Configure Dumps
  • To initiate a system dump
  • To specify what information is traced
  • To Transfer the In-memory Trace Data to the Auxiliary Dataset at Rollover
  • To View a Dump
  • To View a Local Trace for a Client Process
  • To View a Local Trace for a SEP
  • To View a System Trace
  • To Configure Run-time Core Dumps
Parent topic: Troubleshooting


To Change the Trace Dataset

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To change the trace dataset

  1. In the left pane, click Control.

    The Control page is displayed.

  2. Click Trace n, Switch (where n is A or B). If the dataset is currently set to A, it is switched to B. If it is B, the dataset is switched to A.
Note:

By default, the enterprise server uses the A dataset to record trace information.

Parent topic: What You Can Do with Dumps and Traces
Parent topic: Administer a Server Using ESMAC


To Configure Dumps

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To configure a dump:

  1. Click Control.

    The Control page is displayed.

  2. Check Dump on Abend, Sys if you want a dump created if the system abends. Click Dump on Abend, Trans if you want a dump created if the service abends. You can check both check boxes if you want to create dumps on both types of abend.
Note:

By default, the enterprise server uses the A dataset to record dumps. If you want to change the dataset, click Dump n, Switch (where n is A or B). If the dataset is currently set to A, it is switched to B. If it is B, the dataset is switched to A.

Parent topic: What You Can Do with Dumps and Traces
Parent topic: Administer a Server Using ESMAC


To initiate a system dump

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To initiate a system dump

  1. Click Control.

    The Control page is displayed.

  2. Click Dump.
Note:

You can also initiate a system dump using Enterprise Server Administration.

Parent topic: What You Can Do with Dumps and Traces
Parent topic: Administer a Server Using ESMAC


To specify what information is traced

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To specify what information is traced

  1. Click Control.

    The Control page is displayed.

  2. Check the required check boxes in the Trace Points group.

    The help for the Control page explains the meaning of each check box.

Parent topic: What You Can Do with Dumps and Traces
Parent topic: Administer a Server Using ESMAC


To Transfer the In-memory Trace Data to the Auxiliary Dataset at Rollover

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To transfer the in-memory trace data to the auxiliary dataset at rollover

  1. Click Control.

    The Control page is displayed.

  2. Check Active Trace DS, active
Note:

By default, the enterprise server uses the A dataset to record trace information.

Parent topic: What You Can Do with Dumps and Traces
Parent topic: Administer a Server Using ESMAC


To View a Dump

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To view a dump

  1. Click Dump in the Diagnostics group.
  2. Click A or B to select the dump dataset, or C to select the X dataset.
  3. Click Display.

    A list of dumps is displayed.

  4. For the dump you want to display, in the field below the heading Level, choose a level of trace information to be included in the trace tables in the dump. The larger the number, the more detail will be shown. The options are:
    0 | Service start, module start, module end, service end. This is the default.
    1 | Enterprise server API entries and exits
    2 | Subsystem trace entres
    3 | All entries where it is possible to provide some formatting of the data
    4 | All trace entries

    Each level includes all lower-level information. Local trace tables (traces for SEPs) only have levels 0 and 1.

  5. For the dump you want to display, click Details to see a detailed dump or Sum to see a summary dump.

    The dump is formatted and displayed. To return to ESMAC, click the Back button in your browser.

Note:

The X dataset contains dumps triggered by the external command casdump /d. You use casdump /d when a dump cannot be obtained normally; for example, when the enterprise server is not responding and shared memory is locked. The dataset has the filename casdumpx.rec.

Parent topic: What You Can Do with Dumps and Traces
Parent topic: Administer a Server Using ESMAC
Related reference
casdump
Related information
Viewing a Dump
To create an ESMAC user
To start ESMAC for a server
To monitor services
To configure dumps
To initiate a system dump
To specify what information is traced
To change the trace dataset
To transfer the in-memory trace data to the auxiliary dataset at rollover
To view a system trace
To record service input and output
To view a local trace for a SEP
To view a local trace for a client process
To kill a SEP
To reply to an ACCEPT FROM CONSOLE statement
To shut down a server
Troubleshooting


To View a Local Trace for a Client Process

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To view a local trace for a client process

  1. Click Clients in the menu.
  2. Click Trace next to the client process for which you want to view a local trace.

    The trace is formatted and displayed. To return to ESMAC, click Back in your browser.

Note: Local traces are available only for MQSeries listeners and communications processes (MFCS).
Parent topic: What You Can Do with Dumps and Traces
Parent topic: Administer a Server Using ESMAC


To View a Local Trace for a SEP

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To view a local trace for a SEP

  1. Click SEPs in the menu.
  2. Click Trace next to the SEP for which you want to view a local trace. Auxiliary processes are listed underneath SEPs, and you can obtain traces for some of them: the Fileshare process, JCP (journal control program), and TDP (extra-partition transient data process).

    The trace is formatted and displayed. To return to ESMAC, click Back in your browser.

Parent topic: What You Can Do with Dumps and Traces
Parent topic: Administer a Server Using ESMAC


To View a System Trace

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To view a system trace

  1. Click Trace in the Diagnostics group.
  2. Click A or B to select the dataset, or C to select the in-memory trace table.
  3. Specify the number of trace blocks that are to be aggregated into one trace index entry in Blocks in the Diagnostics group. This defaults to 10.
  4. Click Display.

    A list of traces is displayed: this acts as an index to the detailed trace information. For each entry in the index list the following information is shown, from left to right:

    • The process IDs of all processes that have entries in the blocks represented by this trace index entry.
    • The task IDs of all tasks that have entries in the blocks represented by this trace index entry
    • The date and time stamp of the first entry in the trace.
  5. If you want to change the number of blocks to be included in the Details, specify a new number of blocks in the field immediately to the right of Details and below the heading Blocks (this defaults to the number you entered in the Diagnostics group).
  6. In the next field, below the heading Level, choose a level of tracing where the larger the number, the more detail will be shown. The options are:
    0 | Service start, module start, module end, service end. This is the default.
    1 | Enterprise server API entries and exits
    2 | Subsystem trace entres
    3 | All entries where it is possible to provide some formatting of the data
    4 | All trace entries

    Each level includes all lower-level information.

  7. In the next group of fields, below the heading PIDs, if you don't want to see trace entries for all processes, check the check boxes next to the process IDs that you do want to see details for.
  8. In the next group of fields, below the heading Task IDs, if you don't want to see trace entries for all tasks, check the check boxes next to the task IDs that you do want to see details for.
  9. Click Details for the trace you want to display.

    The trace is formatted and displayed. To return to ESMAC, click Back in your browser.

Parent topic: What You Can Do with Dumps and Traces
Parent topic: Administer a Server Using ESMAC
Related information
Viewing a System Trace: Diagnostics Example
To create an ESMAC user
To start ESMAC for a server
To monitor services
To configure dumps
To view a dump
To initiate a system dump
To specify what information is traced
To change the trace dataset
To transfer the in-memory trace data to the auxiliary dataset at rollover
To record service input and output
To view a local trace for a SEP
To view a local trace for a client process
To kill a SEP
To reply to an ACCEPT FROM CONSOLE statement
To shut down a server
Troubleshooting


To Configure Run-time Core Dumps

By default, Enterprise Server does not create a core dump for run-time errors. To configure an Enterprise Server region to produce a core dump for run-time errors:

  1. Create a run-time tunable text file, for example COBCONFIG.CORE.TXT with the following entries:
    SET CORE_ON_ERROR=131
SET CORE_FILENAME="core.%p@%t_%d"
  2. Access the Enterprise Server Administration screen, and in the Status column, click the Details button for the enterprise server instance.
  3. To add the configuration to enterprise server instance, add the entry to your Enterprise Server region configuration. When you start the region, core dumps will be produced by run-time errors. See the illustration below for an example.

Parent topic: What You Can Do with Dumps and Traces
Parent topic: Monitor Directory Server


Enterprise Server Administration Console Help Pages

The topics in this section contain the context-sensitive information that relates to the Enterprise Server user interface.

A version of this help is available directly from the Enterprise Server administration user interface.

Note: While the information available from the user interface still applies, this version is the most current.
  • Enterprise Server Administration Side Bar Menu
  • Enterprise Server Administration Home Page
  • Edit Server Instance Properties
  • Listeners
  • Services
  • Handlers
  • Packages
  • Security Configuration Screen Help
Parent topic: Enterprise Server Configuration and Administration


Enterprise Server Administration Side Bar Menu

The sidebar appears at the left of the Enterprise Server Administration screen. It contains the folllowing areas and options:

Home

Click this to return to the Home page.

Actions

These menu options provide administrative actions. The options that are displayed in this area varies depending on the user's permission level.

Renew

Click this to refresh the IP address information cached by your Directory Server. Use this option when the IP address of the machine running your Directory Server changes.

Directory Server uses the IP address to locate the servers that it manages. When the cached IP address is out of date, Directory Server may be unable to connect to its servers and may report inaccurate information to clients.

Export

Click this to show the Export page. This page enables you to save a copy of the whole repository to a location of your choice. This menu option is available only if you logged on with Administrator or Schema Administrator permission level.

Import

Click this to show the Import page. This page enables you to update the repository with additional objects from an import directory. Imported objects can include servers (along with all of their child objects), and Security Manager definitions. This menu option is available only if you logged on with Schema Administrator permission level.

Delete All

Click this to show the Delete confirmation page. This page enables you to confirm that you want the repository to be completely erased and all registered objects to be deleted. This menu item is available only if you logged on with Schema Administrator permission level.

Logon

Click this to show the log on page. This menu option is shown only if the session is not currently logged on and the User Access setting on the Options page is "Restricted".

Logoff

Click this to log off from an administrative session that is currently logged on. There is no log off confirmation. This menu option is shown only if the session is currently logged on and the User Access setting on the Options page is "Restricted".

Configure

The heading for the menu option that enables you to configure Directory Server. This menu heading and its associated menu option are available only if you logged on with Administrator permission level or higher.

Options

Click this to show the Directory Server Options page. This page enables you to configure the Directory Server.

Security

Click this to show the pages used for configuring security options.

Display

The heading for menu options that enable you to view information about the state of the Directory Server and about the events that have taken place on the server.

Directories

Click this to show the Directories page. This page lists all the instances of Directory Server that are running on the network and using the default Directory Server port (86).

Statistics

Click this to show the Statistics page. This page shows statistics and status information about Directory Server.

Sessions

Click this to show the Sessions page. This page shows the list of currently logged on Web browser client sessions, and also any bound program client sessions.

Journal

Click this to show the Journal page. This page shows the Directory journal, which is a record of Directory Server activity.

Shut Down

Click this to show the Shut Down confirmation page. This page enables you to shut down the Directory Server. This menu option is available only if you logged on with Schema Administrator permission level This menu option is available only if you logged on with Schema Administrator permission level and Directory Server is not running as a Windows service.

Help

The heading for menu options that enable you to view documentation about the Directory Server and Enterprise Server Administration.

This page

Click this to view help for the page you are currently viewing and for all the controls on the page.

Contents

Click this to view the Contents of the Enterprise Server documentation.

CAUTION:
This version of the help has not been updated to reflect the latest product changes. For the latest help, go to the Micro Focus Product Documentation site.
Note:

For this link to work, you must be using an enterprise server that has a Web listener with the following entry in the [virtual paths] section:

  • For Windows systems:
    docs=<ES>/help
  • For UNIX systems:
    docs=<ES>/docs/html

This enterprise server must be started.

The default enterprise server, ESDEMO, has a web listener with this configuration information. When you create a new enterprise server, a Web listener with the required configuration information entry is automatically created.

Support

Click this to contact Micro Focus Technical Support via the Supportline website to report problems or ask any questions about using Micro Focus software.

Feedback

Click this to open your email client and send general feedback to Micro Focus.

  • Export
  • Import Server Information (Page 1 of 4)
  • Configure Repository Options
  • Display Directories
  • Display Statistics
  • Display Sessions
  • Journal
Parent topic: Enterprise Server Administration Console Help Pages


Export

Target directory

Use this page to save all server information in the Directory Server repository to a backup location.

Specify the name of the directory the server information will be exported to. If the directory does not exist, the export process will attempt to create it.

Export options:

You use these radio buttons to choose which information is included in the export. You can choose to:

  • Export Enterprise Server configuration and Security Manager definitions

    This will export all of the configuration information for your Enterprise Servers. It will also export the pool of Security Manager definitions, and the Security Manager lists for your servers, along with security configuration details. (A Security Manager list indicates which managers are used by a given server.)

  • Export just the current Enterprise Server configuration

    The Security Manager definitions, Security Manager lists and security configuration details will not be included in the export.

  • Export just the Security Manager definitions

    Only the pool of Security Manager definitions will be exported. This will not include the security configuration details or the Security Manager lists.

    Note:

    Security Manager lists are only exported when you choose the first of these options.

When you import, you can choose whether to include or exclude security details, if these have been exported. Where the import excludes the security details, or where the security details were not included in the export, the imported servers will use the Default ES Security configured on the importing system.

Where the import includes security details, all existing security information - the Security Manager pool, Security Manager lists and other security configuration details - will be removed and replaced with the imported information. One consequence of this is that servers that are not replaced during the import will have their security details set to use the Default ES Security configuration.

Parent topic: Enterprise Server Administration Side Bar Menu


Import Server Information (Page 1 of 4)

Use this page to import server definitions. The effect of this is to add the servers and their child objects (services, listeners, etc.) to your current repository.

Selected source directory containing server data to be imported
Specify the type and location of the directory from which data is to be imported. The source directory should have been previously populated by a repository export, an export of an individual Enterprise Server, or a compatible process. It can be a file system location or an LDAP repository.

For file system storage, the location is the directory in which the exported data is stored.

For LDAP storage, the location is the address of the LDAP server containing the exported data.

Note: When you specify ldap:// as the directory type, additional fields are displayed for specifying the container in which the data is stored, and the LDAP user credentials required to read from the container.
Repository Container Distinguished Name
The distinguished name of the LDAP container in which the exported data is stored.
User DN:
The distinguished name of the LDAP user with which to access the repository. This user must have permission to read from the container.
User Password:
The password of the user with which to access the repository.
Recent directories
This contains a list of directories from which you have previously imported data.
Note: By default the directory will only be added to the list if the import is successful, but you can choose to include the directory even if the import fails.
Delete
This button enables you to remove an entry from the list of recent directories.
Parent topic: Enterprise Server Administration Side Bar Menu


Configure Repository Options

Use this page to change configuration settings for the Directory Server.

Repository Location

Specify the type of storage and the location containing the repository. You can store the repository in the file system or in an LDAP repository.

For file system storage, the location is the directory in which the repository data will be stored.

For LDAP storage, the location is the address of the LDAP server that will be used.

In order to store the repository in an LDAP server, the server must be updated to support the Micro Focus configuration objects.

CAUTION:

If you change the location and the destination already contains a repository, you will be warned and given the opportunity to overwrite it or to cancel the operation.

Note:

When you specify ldap:// as the storage mechanism, additional fields are displayed for specifying the container in which the data will be stored, and the LDAP user credentials required to write to the container.

Repository Container Distinguished Name

The distinguished name of the LDAP container in which the repository is to be stored.

User DN:

The distinguished name of the LDAP user with which to access the repository. This user must have permission to read and write to the container.

User Password:

The password of the user with which to access the repository.

Parent topic: Enterprise Server Administration Side Bar Menu


Display Directories

Use this page to view a list of all MF Directory Server instances that are running on the local network and using the default MF Directory Server port (86).

Version

Shows the version of the Directory Server software in use.

IP Address

Shows the IP address of the machine on which the Directory Server is running.

DNS Resolved Hostname

Shows the DNS-resolved hostname of the machine on which the Directory Server is running. If there is a right-pointing arrow next to this name, you can click it to open Enterprise Server Administration for the instance of Directory Server running on the other machine. What you can do depends on how security has been configured on the other machine.

Parent topic: Enterprise Server Administration Side Bar Menu


Display Statistics

Use this page to view statistics and status information about the Directory Server.

Repository

This table shows information about the repository.

Location

Shows the directory containing the repository of all registered object information. If the path is relative it is relative to the Directory Server current directory.

Status

Shows the last action performed on the repository.

Objects

This table contains statistics about the objects stored in the local repository.

Servers

Shows the number of servers stored in the local repository.

Communications processes

Shows the number of communications processes stored in the local repository.

Listeners

Shows the number of listeners stored in the local repository.

Services

Shows the number of service operations stored in the local repository.

Handlers

Shows the number of request handlers stored in the local repository.

Packages

Shows the number of implementation packages stored in the local repository.

XA Resources

Shows the number of defintions of XA resources stored in the local repository.

Total Count

Shows the total number of objects stored in the local repository.

Request Processing

This table contains information about incoming client requests.

TCP Requests

Shows the number of TCP requests received since the Directory Server was started. These can come from either program clients or Web browser clients.

UDP Requests

Shows the number of UDP requests received since the Directory Server was started. These come only from program clients.

MLDAP Requests

Shows the number of TCP or UDP MLDAP requests received since the Directory Server was started. These can be generated by enterprise servers or program clients

Maximum Thread Count

Shows the maximum number of concurrent MLDAP requests that have been processed at any time since the Directory Server was started

Current Thread Count

Shows the number of MLDAP requests currently being processed.

Options

This table contains some of the current Directory Server option settings.

User Access

Shows what level of access is available to users. Possible values are:

Restricted | Access is allowed only by an authorized user who has logged on.
Unrestricted | Access is allowed by any user.
Server Monitor

Indicates whether the server monitor is currently active or not. The server monitor checks whether all enterprise servers registered with the Directory Server and not marked "Stopped" are responding to potential client requests. If they are, their status is marked as "Started", otherwise, if they are currently marked as "Started" and they are not responding, they are marked as "Not Responding".

Having the server monitor on ensures that the Current status field for a server is up to date, even if the server itself cannot contact the Directory Server for some reason, for example, a network connection or machine failure.

You can enable and disable the server monitor and change the time interval between checks on the Configure Options page.

Journal Level

Indicates what level of journal logging is in force.

Paths

This table contains the paths that the Directory Server is using for its own resources.

COBDIR

Shows the setting of the COBDIR environment variable, which holds the location of your installed development system or standalone Enterprise Server. This field might be empty if the Directory Server is being run as a Windows service, as this environment variable is not one that is set by the Windows system.

Executables

Shows the location of the system programs that make up Enterprise Server.

Artwork

Shows the location of the graphics files that the Directory Server uses in its interface.

Help and documentation

Shows the location of the documentation for Enterprise Server.

Trace and journaling

Shows the location of the trace files and journals created by Enterprise Server.

Parent topic: Enterprise Server Administration Side Bar Menu


Display Sessions

Use this page to view a list of currently logged on Web browser clients and program clients. The sessions may be really active, or they may be dormant but not yet removed because the time period between inactivity and removal has not yet been exceeded.

Session ID

Shows the unique identifier string of the session. The session ID is in the format userid-string where userid is the user ID that was used to authenticate the session and string is a unique internal identifier for a Web browser session. string is not present for a program client.

Last Active

Shows the local date and time that the session last requested a response from the Directory Server, for example, a browser refresh or a client program request.

Permission Level

Shows the permission level of the session user. The possible values are:

Unauthenticated | The user is a program client that is performing a query and does not need to be authenticated.
Modify | Values stored in the schema can be modified.
Add/Delete | Values stored in the schema can be modified and objects can be added and deleted. This is normally the highest permission level a program client would need.
Administrator | All of the above, plus objects can be backed up, imported, and the Directory Server can be remotely terminated.
Schema Administrator | All of the above, plus users can be added, modified and deleted and the entire repository can be deleted.
Session Type

Shows the type of user session. The possible values are:

UI | Web browser client
API | Program client
Parent topic: Enterprise Server Administration Side Bar Menu


Journal

Use this page to view the journal, a file that records some of the Web browser client and program client activity occurring on the Directory Server.

Note:
  • You can scroll up and down the list of entries using the scroll buttons on the right-hand side of the table.
  • The most recent entries are shown first.
Entries generated

Shows the total number of journal entries generated since this journal file was started. This could be the same or more than the value in Entries held, depending on whether the oldest entries have been overwritten by more recent ones.

Entries held

Shows the total number of journal entries currently stored in the journal file. The maximum value is determined by the configured maximum journal file size; once it is reached, new journal entries overwrite the oldest journal entries.

Journal Size

Shows the current size of the journal file in bytes.

Entry

Shows the entry number of the journal record. When the journal file is restarted or deleted, the entry number is reset back to 1, and is sequentially incremented for each following journal entry.

Time

Shows the local date and time that the journal record was written to the journal file.

Requester

Shows the unique identifier string associated with a particular session. For a Web browser session logged onto the user interface, this is the same identifier as appears in the top right-hand corner of the Web page. For a program client session, the source network address for the request is also shown.

If no requester identifier is shown, the journal event was generated by an internal action or there was no information available about the requester.

Event

Shows the text of the journal event, up to 128 characters.

Green text indicates that the journal event has been generated by program client requests.

Red text indicates that the journal event has been generated by Web browser requests.

Black text indicates that the journal event has been generated by the Directory Server itself.

Delete

Click this to delete this journal and start a new one. You might want to do this if you are debugging a problem with a service and you want a well-defined journal starting-point.

Export As Text

Click this to export the journal entries to a text file. The text file will be called journal.txt and will be saved in your Documents and Settings\All Users\Application Data\Micro Focus\NetExpress\5.0 directory on Windows or your /var/mfcobol/logs directory on UNIX. You might do this to load the journal file in a text editor to search for events involving specific objects or to annotate entries.

If the journal.txt already exists, it will be overwritten.

Parent topic: Enterprise Server Administration Side Bar Menu


Enterprise Server Administration Home Page

Important: Use the Help > This Page option in the left side-bar to display up-to-date context help on the current Enterprise Server screen. To access up-to-date Enterprise Server product help, go to the Micro Focus Product Documentation site.

This is the Enterprise Server Administration home page that lists the Enterprise Server instances. It is displayed:

  • When you have just logged onto Enterprise Server Administration
  • Any time you click Home at the top of the menu bar on another page.

You use this page as a starting point for all the administration functions.

From this page you can:

  • Add a server
  • Change the attributes of a server
  • Change the status of a server
  • Go to a more detailed view of the listeners, services, request handlers and implementation packages.
Note:

The options available to you depend on the permissions granted to the user groups of which your user account is a member. Those options that are not available to you are hidden.

Use the side bar menu items to access your installation's configuration options, maintained on the Micro Focus Dirctory Server (MFDS).

Expand/Contract button

Click [image] in the left-hand corner of the servers table to see an expanded version of the information in the Objects column, or the minus icon ( [image]) to see a contracted version of the information in the Service Listeners, Services, Request Handlers and Implementation Packages columns.

Refresh Icon

Click Refresh to update the display to show changes in the server status and attributes.

Show

Specify the number of servers to show at a time. Click Refresh to update the screen display.

Previous

Click this to view the previous page of servers. You can click this only if the number of servers is greater than can be shown on one page.

Next

Click this to view the next page of servers. You can click this only if the number of servers is greater than can be shown on one page.

Filter

Click this to update the display according to the Type, Name and Status attributes selected.

Filter by Type

Select the type of server from the drop-down list that you want to be displayed in the server list. Click Refresh to update the screen display with your selection.

Filter by Name

Type the name of the server you want to see in the server list. You can use wildcard characters '*' and '?' to modify your criteria. Click Refresh to update the screen display with your selection.

Filter by Status

Select the status from the drop-down list to display a list of matching servers. Click Refresh to update the screen display with your selection.

Delete

Click this to delete this server. You can see this only if this server is a CCI server.

Edit

Click this to edit configuration settings for this server.

Type

Shows the server type. There are two types of server:

  • MFES

    A Micro Focus enterprise server. This is a server type that provides a run-time environment for COBOL programs running as services. MSS in parentheses after MFES indicates that the server has Mainframe Subsystem Support (MSS) enabled.

  • MFCCI

    A Micro Focus Common Communications Interface server. This is a server that provides services using the Common Communications Interface (CCI), using the Directory Server as a naming service instead of registering with a CCITCP2 process.

The icon in the Type column will display '64' if the server has been set up for 64-bit working mode.

You can start and stop enterprise servers using Enterprise Server Administration. You cannot start and stop MFCCI servers from Enterprise Server Administration; if an MFCCI server is running on the network and has been configured to use the Directory Server, it appears in the list of servers automatically, with the status "registered". For more information about CCI, see your Configuring CCI book.

Name

Shows the name of the server.

Current Status

Shows the current status of this server. The possible values are:

Stopped | The server is currently not running.
Stopping | The server is currently in the process of terminating. This is normally a short-lived status value which should be shortly followed by a change to the value "Stopped".
Started | The server is currently running and can respond to client and server requests.
Starting | The server is currently in the process of starting. This is normally a short-lived status value which should be shortly followed by a change to the value "Started".
Not Responding | The server process was previously marked as "Started", but the server monitor has subsequently not been able to contact it. There may be some network connection error, or the server itself may have abnormally terminated without first marking itself as "Stopped".
Invalid | An error has occurred such that it has not been possible to set the status to any other value.
Registered | This status is applicable only to CCI servers. It indicates that the Directory Server has been notified that a CCI server has started.
Start

Click this to start the server. You cannot see this push button unless the server has the status "Stopped" .

Current Status Details

Click this to move to a page giving more detailed information about the current status of the server. You cannot see this push button when the server has the status "Stopped".

Stop

Click this to start the server. You cannot see this push button unless the server has the status "Started" or "Not Responding".

Communications Processes

Lists the communications processes owned by the enterprise server. By default an enterprise server owns one communications process; you can create additional ones. For each process the following information is shown:

  • The number of the process. Numbers are allocated from 1 sequentially.
  • The network address used by the communications process to accept incoming client requests. The format is:

    protocol:ip-address:port

    where:

    • protocol is tcp.
    • ip-address is the IP address of the server listener. An asterisk (*) indicates that the address is dynamically assigned for the enterprise server when it starts.
    • port is the port value. An asterisk (*) indicates that the port is dynamically assigned for the enterprise server when it starts.
  • The TCP/IP hostname that is equivalent to the IP address.

The total number of listeners owned by all the communications processes.

Listeners Details

Click this to move to a page giving more detailed information about the service listeners owned by the communications processes.

Licenses

Shows license information. The number before the slash is the number of licenses allocated to this server. When the server is stopped a dash is displayed, because the number of licenses that will be allocated is unknown until the server is started. When the server is running an asterisk can be displayed, indicating that unlimited licenses were allocated. The number after the slash is the number of licenses requested by this server.

Last Status Change

Shows the date and time that the server's current status was last updated; this is local to the machine where the Directory Server is running. You can see this only in the expanded view of the Home page.

Status Log

Shows information about the most recent event that occurred on this server, and how long the server has been in its current state.

Objects

Shows how many of each type of object (services, handlers, packages) the server owns. This is a summary view - it changes when you click the Expand the plus button button

Services

Shows a list of the service operations registered with the Directory Server. If there are more than five, only the first five are shown.

Service Details

Click this to move to a page giving more detailed information about the services registered with the Directory Server.

Request Handlers

Shows a list of the request handlers registered with the Directory Server.

Request Handlers Details

Click this to move to a page giving more detailed information about the request handlers registered with the Directory Server.

Implementation Packages

Shows a list of the implementation packages registered with the Directory Server. If there are more than five, only the first five are shown.

Implementation Packages Details

Click this to move to a page giving more detailed information about the implementation packages registered with the Directory Server.

Description

Shows a description of the server.

Add

Click this to add a new server.

  • Add Server instance
  • Delete Server instance
Parent topic: Enterprise Server Administration Console Help Pages


Add Server instance

Use this page to provide the attributes for an enterprise server (MFES).

Note:

For more information about the configurable attributes of servers, see the chapter Configuration in your Configuration and Administration Guide.

Name

Shows the name of the server.

Server Address

Specify the network address used by the server to accept incoming client requests. The format is:

protocol:ip-address:port

where:

  • protocol is tcp.
  • ip-address is either the text host name or IP address of the server listener. An asterisk (*) indicates that the address is dynamically assigned for the enterprise server when it starts.
  • port is the port value. An asterisk (*) indicates that the port is dynamically assigned for the enterprise server when it starts.

If this network address is not unique in the repository, this might cause enterprise server startup problems.

System Directory

Specify the location for system work files output by the Enterprise Server, such as the console log, and trace and dump diagnostics files. This directory cannot be shared between Enterprise Servers. The default is %USERPROFILE%\Documents\Micro Focus\Net Express x.x\WORKAREA \es-name (where es-name is the name of the enterprise server).

If you specify a directory in this field, that directory must exist; Enterprise Server does not create it for you.

Working Mode

Choose whether this Enterprise Server is to run 32-bit or 64-bit applications.

A 32-bit working mode server can run only 32-bit applications. A 64-bit working mode server can run only 64-bit applications.

You cannot change the working mode of the server once it has been created; you can however, change the mode when you copy or import a server.

Startup Options

Use these fields to specify the server configuration you want when the server first starts up. Any changes you make to these fields while a server is running do not take effect until the next time you start the server.

Shared Memory Pages

Specify the number of shared pages in memory to be reserved for all the processes that run in the Directory Server. Each page is 4KB long.

Service Execution Processes

Specify the number of service execution processes that are to be started at server initialization.

Shared Memory Cushion

Specify the number of 4KB pages that should be reserved from the shared memory pages to allow the server to continue processing when the shared memory allocation is too small for the operational requirements of the server. The range is 1 through the number of shared memory pages.

Trace Table Size

Specify the number of entries the trace buffer can hold before it wraps back to the start. (The trace buffer is also written to disk at this point if you checked Auxiliary Trace Active.) A value of 2 means that there is space for only one entry, and if you checked Auxiliary Trace Active each entry is written straight out to disk. Each entry is 24 bytes long.

Local Trace Size

Specify the number of entries the local trace table can hold before it wraps back to the start. A value of 0 (zero) means that no local trace table is allocated. Each service execution process has its own local trace table. Each entry is 24 bytes long.

Maximum Diagnostics File Size

Specify the maximum size of the auxiliary trace and dump file in kilobytes. A value of 0 (zero) means that there is no maximum size.

Requested Licenses

Specify the number of licenses this enterprise server requires.

Cold Start Diagnostics File

Check this to indicate that the auxiliary trace and dump files are to be deleted when the server starts.

Dump on System Abend

Check this to indicate that the server should produce a dump if one of its own processes, such as a service execution process, terminates abnormally. The dump information can help you to determine the cause of the abnormal termination

Auxiliary Trace Active

Check this to indicate that trace records are to be flushed to disk before the trace table is overwritten. You should do this only if you have adequate disk space available, since the file can become very big very quickly. If you have a high-activity system use this field in conjunction with Maximum Diagnostics File Size to limit the disk usage. Writing out to a file also degrades performance.

Show Local Console

Check this if you want to see a text window containing enterprise server messages while the server is running. the messages are written to a file called console.log, in the directory specified in System Directory. You can see the text window only on the machine running the enterprise server. The system messages are also available on the Enterprise Server Console page.

Mainframe Subsystem Support

Check this to indicate that this server is an MSS-enabled server, that is, a server that can run CICS applications.

Trace Flags

Use these flags to control what information is written to the trace file for this server. Any changes you make to these fields while a server is running take effect immediately.

Task Control

Check this to indicate that the server is to trace its task control component.

Storage Control

Check this to indicate that the server is to trace its storage control component.

Table Management

Check this to indicate that the server is to trace its table management component.

Application Container

Check this to indicate that the server is to trace its application container component.

Request Handler

Check this to indicate that the server is to trace its request handler component.

RM Interface

Check this to indicate that the server is to trace its resource manager interface component.

Communications

Check this to indicate that the server is to trace its communications component.

Application

Check this to indicate that the server is to trace the CICS API calls made by a CICS application.

Exit

Check this to indicate that the server is to trace user and system exits.

Configuration Information

Specify textual configuration information that determines the start-up and run-time behavior of the server. Optional. For details of the valid entries, see the section Configuration Information in the chapter Servers in your Configuration and Administration Guide.

Description

Specify a text description of the server, for example, its purpose and owner. Optional.

Add

Click this to add the new server to the Directory Server repository.

Back

Click this to return to the previous page.

Parent topic: Enterprise Server Administration Home Page


Delete Server instance

Use this page to delete the selected server.

Note:

Deleting a registered server may cause application connection errors and loss of data.

Type

Shows the server type. There are two types of server:

  • MFES

    A Micro Focus enterprise server. This is a special server type that provides a run-time environment for COBOL programs running as services.

  • MFCCI

    A Micro Focus Common Communication Interface server. This is a server that provides services using the Common Communication Interface (CCI), using the Micro Focus Directory Server as a name server instead of registering with a Micro Focus CCITCP2 process.

Name

Shows the unique name of the server.

Status Log

Shows information about the most recent event that occurred on this server.

Services

Shows the number of services registered with this server.

Description

Shows a text description of the server.

Stop server before deleting it

Check this if you want the server to be stopped before it is deleted.

Parent topic: Enterprise Server Administration Home Page


Edit Server Instance Properties

CAUTION:
Changing the properties of a registered enterprise server instance may cause application connection errors and loss of data.
  • Server Instance Properties: General
  • Server Instance Properties: XA Resources
  • Server Instance Properties: MSS Support
  • Server Instance Properties: Scripts
  • Server Instance Properties: Permissions
  • Server Instance Control
  • Server Instance Diagnostics
  • Server Instance Properties: Security
  • Enterprise Server Monitor and Control (ESMAC)
Parent topic: Enterprise Server Administration Console Help Pages


Server Instance Properties: General

Use this page to change the basic configurable attributes of an enterprise server instance.

To access this page:

  1. On the server instance screen, select the Server > Properties > General tabs.
CAUTION:
Changing the properties of a registered enterprise server instance may cause application connection errors and loss of data.
Name

Specify the unique name of the server, up to 8 characters. You can change the name only if the server has the status "Stopped". You cannot include angle brackets (<>) or ampersands (&) in the name.

System Directory

Specify the location for system work files output by the Enterprise Server, such as the console log, and trace and dump diagnostics files. This directory cannot be shared between Enterprise Servers. The default is %USERPROFILE%\Documents\Micro Focus\Net Express x.x\WORKAREA \es-name (where es-name is the name of the enterprise server).

If you specify a directory in this field, that directory must exist; Enterprise Server does not create it for you.

Working Mode

Shows whether this Enterprise Server is to run 32-bit or 64-bit applications.

A 32-bit working mode server can run only 32-bit applications. A 64-bit working mode server can run only 64-bit applications.

You cannot change the working mode of the server once it has been created; you can however, change the mode when you copy or import a server.

Startup Options

Use these fields to specify the server configuration you want when the server first starts up. Any changes you make to these fields while a server is running do not take effect until the next time you start the server.

Shared Memory Pages

Specify the number of shared pages in memory to be reserved for all the processes that run in the Directory Server. Each page is 4 KB long.

Service Execution Processes

Specify the number of service execution processes that are to be started at server initialization.

Shared Memory Cushion

Specify the number of 4KB pages that should be reserved from the shared memory pages to allow the server to continue processing when the shared memory allocation is too small for the operational requirements of the server. The range is 1 through the number of shared memory pages.

Requested Licenses

Specify the number of licenses this enterprise server requires.

Show Local Console

Check this if you want to see a text window containing enterprise server messages while the server is running. the messages are written to a file called console.log, in the directory specified in System Directory. You can see the text window only on the machine running the enterprise server. The system messages are also available on the Enterprise Server Console page.

Allow Dynamic Debugging

Check this if you want to use a local or remote IDE to debug applications running in this enterprise server.

Start on System Start

Check this if you want to start the ES server when the MF Directory Server process is started. The MF Directory Server process (mfds) is usually started at system startup (e.g. on Windows it is registered as a system service by default). Typical usage is to ensure a set of ES servers are re-started automatically if a machine is re-booted. If security is enabled and the default credentials are disabled, ensure valid credentials are specified in the server "Security" properties "Automated Execution Control Enterprise Server Credentials" section.

64-Bit Working Mode

This box is for information only and will be checked if the server has a working mode of 64-bit.

Purge Old Logs

Check this if you want to remove existing console.nnn backups.

Console Log Size

Specify the maximum size of the console.log. Once this size is reached, it will be backed up as console.nnn (with nnn being incremented with each new backup) and subsequent messages will be logged to a new console.log. If set to 0, a single console.log will be created (if one already exists on startup, this will be backed up as console.bak).

Windows Monitoring and Management

Use these fields to specify and configure the performance and event logging options when the server first starts up. Any changes you make to these fields while a server is running do not take effect until the next time you start the server.

Allow Performance Monitoring

Check this box if you want to enable a server to provide performance counters through the Windows Management Instrumentation. Performance information can then subsequently be viewed through Windows Perfmon.

Event Logging

Check the appropriate boxes to specify which events will be logged to the Windows Event Log.

Configuration Information

Specify textual configuration information that determines the startup and run-time behaviour of the server. Optional. Prefix comments with the number sign (#).

Description

Specify a text description of the server, for example, its purpose and owner. Optional.

Export

Click this to export information about this server and the objects it contains in a specified location.

Copy

Click this to create a new server that is identical to this server apart from its name.

Delete

Click this to delete this server.

Validate

Click this to generate a Validation report for this server. The Validation report informs you of any server configuration errors.

Parent topic: Edit Server Instance Properties


Server Instance Properties: XA Resources

Use this page to view a list of the external resource managers registered with the currently selected server. From this page you can also:

  • Edit the resource manager definition
  • Add a new resource manager

To access this page:

  1. On the server instance screen, select the Server > Properties > XA Resources tabs.
ID

Shows the resource manager ID, used internally to identify a particular XA configuration.

Name

Shows the name by which the resource manager is known.

Module

Shows the location of the executable file (.dll on Windows),(.sl on HP-UX PA-RISC, .so on other UNIX platforms) that contains the entry point that returns the xa_switch_t structure to the enterprise server.

Open string

Shows the string that is passed to the resource manager on the xa_open() call. It usually contains at least the database name, and the user ID and password for connecting to the database. The contents of this string are database-specific.

Close string

Shows the string that is passed to the resource manager on the xa_close() call.

Description

Shows an optional text description of the resource manager definition.

Add

Click this to add a resource manager.

Enabled

Shows the status of the resource manager. A tick indicates that it is enabled.

  • Server Instance Properties: Add XA Resource
Parent topic: Edit Server Instance Properties


Server Instance Properties: Add XA Resource

Use this page to specify the details of an external resource manager that the server needs to communicate with on behalf of container-managed applications.

To access this page:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Properties > XA Resources tabs.
  3. Select the XA resource to display.
ID
Specify a resource manager ID, used internally to identify a particular XA configuration. This must be unique within the enterprise server. Mandatory.
Name
Specify the name by which the resource manager is known. It should match the name returned in the name field of the xa_switch_t structure. Mandatory.
Module
Specify the location of the executable file (.dll on Windows),(.sl on HP-UX PA-RISC, .so on other UNIX platforms) that contains the entry point that returns the xa_switch_t structure to the enterprise server. Mandatory.
Open string
Specify the string that is passed to the resource manager on the xa_open() call. It usually contains at least the database name, and the user ID and password for connecting to the database. The contents of this string are database-specific.

Where the resource manager supports dynamic registration, and the database vendor requires the name of the module that provides the ax_reg function, you should specify casaxlib.

Close string
The string that is passed to the resource manager on the xa_close() call. To find out whether or not you need to supply Close string, see your database vendor's documentation.
Description
Specify an optional text description of the resource manager definition.
Enabled
Check this to enable the resource manager. It is checked by default.
Parent topic: Server Instance Properties: XA Resources


Server Instance Properties: MSS Support

Check Mainframe Subsystem Support enabled to .

Use this page to enable MSS for this enterprise server instance.

To access this page:

  1. On the server instance screen, select the Server > Properties > MSS tabs.
Note:

You can use the resolved value of an environment variable in any fields for the entry of file or directory paths. To do this, prefix the environment variable you want to include with a dollar ($) sign; for example:

$production\programs

where production is an environment variable.

If you want to use a dollar sign as part of the value, rather than as an indicator of an environment variable, you must escape the dollar sign character with a backslash(\); for example:

\$production\programs

In this case, $production will not be replaced by the value of the environment variable.

  • Server Instance Properties: MSS CICS
  • Server Instance Properties: MSS JES
  • Server Instance Properties: MSS IMS General
  • Server Instance Properties: MSS IMS DB
  • Server Instance Properties: MSS IMS TM General
  • Server Instance Properties: MSS IMS TM MPRs
Parent topic: Edit Server Instance Properties


Server Instance Properties: MSS CICS

Use this page to enable Mainframe Subsystem Support (MSS) and configure CICS support for this server.

To access this page:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Properties > MSS > CICS tabs.
CICS enabled

Indicates whether or not CICS is enabled. In this release, CICS is automatically enabled when Mainframe Subsystem Support is enabled.

System Initialization Table

Specify the system initialization table (SIT) to be used by this enterprise server. Defaults to DFH$IVP.

Transaction Path

Specify the full path of the CICS transaction programs that will run in this enterprise server. Separate multiple paths with semi-colons on Windows or colons on UNIX. Mandatory if you use any other SIT than DFH$IVP.

VSAM File Path

Specify the full path of the VSAM files required by the CICS transaction programs that will run in this enterprise server. Separate multiple paths with semi-colons on Windows or colons on UNIX. Mandatory if you use any other SIT than DFH$IVP.

Map Path

Specify the full path of any BMS map load modules required by the CICS transaction programs that will run in this enterprise server. Separate multiple paths with semi-colons on Windows or colons on UNIX. Mandatory if you use any other SIT than DFH$IVP.

Resource Definition File Path

Specify the full path of the resource definition file for this enterprise server. Mandatory if you use any other SIT than DFH$IVP.

EZASOKET support

Check this to enable support for CICS and JCL applications that use the EZASOKET APIs.

Parent topic: Server Instance Properties: MSS Support


Server Instance Properties: MSS JES

Use this page to enable Mainframe Subsystem Support (MSS) and to configure the Job Entry Subsystem (JES) for JCL on this server.

To access this page:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Properties > MSS > JES tabs.
Job Entry Subsystem enabled

Check this to enable the Job Entry Subsystem for this server.

JES Path

Specify the path for the executable files that your JCL jobs will run.

Put your .gnt and .dll files on this path. For debugging, you will also need to put your .int, .idy and .cbl files on this path.

System Catalog

Specify the full name (including the path) of your system catalog file. This file holds the details of data files, their attributes and locations.

Note: You cannot share a catalog between servers.
Default Allocated Dataset Location

Specify the default directory to be used for the creation of new data sets.

System Procedure Library

Specify the name of your system procedure library.

Fileshare Configuration Location

Specify the path and name of the Fileshare Configuration file.

Parent topic: Server Instance Properties: MSS Support


Server Instance Properties: MSS IMS General

Use this page to enable Mainframe Subsystem Support (MSS) and configure IMS support for this enterprise server.

To access this page:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Properties > MSS > IMS > General tabs.
IMS enabled

Indicates whether or not IMS is enabled for this enterprise server.

Codeset bias

Choose the default codeset to use for transactions running on this enterprise server:

  • ASCII - Transactions use ASCII.
  • EBCDIC - Transactions use EBCDIC.
Configuration directory

This field is no longer used.

GEN file directory

Specify the location for the .dat, .idx, and .acb files produced by DBDGENs, IMSGENs and PSBGENs.

Parent topic: Server Instance Properties: MSS Support


Server Instance Properties: MSS IMS DB

Use this page to configure IMS DB support for this enterprise server.

To access this page:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Properties > MSS > IMS > DB tabs.
Database path

Specify the location of the IMS data files and any .slf files to be used by the IMSDBUEA segment exit routine.

Locked resource timeout

Specify the maximum time in seconds that a message processing region in this enterprise server will permit a transaction to wait for a resource that has been locked by another process. The value must be in the range 0 through 9999. The default is 30. A value of 0 indicates that there is no timeout.

Data compression
Key compression
These setting correspond to the IDX-8 KEY/DATA compression options.

The data compression routine number and the key compression number. Valid values for each are the same as those that can be specified for the Compiler directives DATACOMPRESS and KEYCOMPRESS.

Parent topic: Server Instance Properties: MSS Support


Server Instance Properties: MSS IMS TM General

Use this page to configure IMS TM support for this enterprise server.

To access this page:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Properties > MSS > IMS > TM > General tabs.
Message queue

Use these fields to define the attributes of the IMS message queue.

Name

Specify the path to use for the message queue. The default is ESDEMO/IMSMESGQ.dat in the enterprise server's work area directory.

Maximum blocks

The message queue consists of blocks of approximately 64 kb.These consist of 254 segments (not message segments) which are the allocation unit for queue space.

Specify the maximum number of blocks to be used to store the message queue. The value must be in the range 4 through 63488. The default is 32.

When space is not available, a thread waits until the allocation request can be satisfied. The failure mode for "out of space" is a hang condition.

Queue buffer count
This is the tuning control. More buffers means less swapping of blocks in memory for message queue activity.
Note: Carefully consider changing this setting.
Cold start

Choose what happens when you next start this enterprise server:

  • None - No information is deleted.
  • Stats only - Only statistics are deleted.
  • Definitions and stats - Resource definitions and statistics are deleted.
  • Everything - All information (including the message queue) is deleted.
Persist

Check this to specify that the action you specified in the Cold start option occurs each time this enterprise server starts.

MFS path

Specify the location for the files produced by MFSGENs.

MFS attribute bias

Choose how attributes are assumed to be defined for transaction programs running on this enterprise server:

  • Binary - The programs define attributes as binary values, for example:
    05 ATTRIBUTE-VARIABLES.
   10 CURSOR-ATTR    PIC X(2) VALUE X"C0C1".
   10 ERROR-ATTR     PIC X(2) VALUE X"C0C9".
   10 OK-ATTR        PIC X(2) VALUE X"00C1".
   10 PROT-ATTR      PIC X(2) VALUE X"00F1".
  • Character - The programs define attributes as characters, for example:
    05 ATTRIBUTE-VARIABLES.
   10 CURSOR-ATTR PIC X(2) VALUE "{A".
   10 ERROR-ATTR PIC X(2) VALUE "{I".
   10 OK-ATTR PIC X(2) VALUE " A".
   10 PROT-ATTR PIC X(2) VALUE " 1".

    This setting only has an effect on programs compiled using the ASCII character set; it is ignored for programs compiled using EBCDIC.

    Where you specify Character, Enterprise Server will automatically translate the values of MFS attributes to those that would be used if the program were compiled as EBCDIC. For example: the hexadecimal 7B41 value produced by assigning '{A' to an attribute and compiling with ASCII, will be converted to the correct C0C1 value. Where you specify that attribute values have been coded as binary data, Enterprise Server will take no action.

MFS null character

Specify the character to use as the MFS NULL character. You can enter the value in character or hexadecimal form. The default is X'36'.

This setting only has an effect on programs compiled using the ASCII character set; it is ignored for programs compiled using EBCDIC.

Actvity keypoint frequency

Specify how many thread requests are to be processed before a keypoint is generated. This must be in the range 0 through 65535. The default is 64. Specifying 0 indicates that keypoints are only generated when the enterprise server starts and shuts down.

Trailing space

Check this to specify that you must add a trailing space when entering transaction names in this enterprise server.

Transaction threshold

Specify the maximum length of time in seconds that a transaction can run before a message is logged to the console to indicate that it has exceeded its threshold. This must be in the range 0 through 65535. A value of 0 indicates that there is no threshold.

Application path

Specify the location of the transaction programs running on this enterprise server.

Transaction definition file path

Specify the full path of the transaction definition file for this enterprise server.

Parent topic: Server Instance Properties: MSS Support


Server Instance Properties: MSS IMS TM MPRs

Use this page to configure message processing regions (MPRs) for this server. From this page you can also:

  • View a list of MPRs
  • Add a new MPR
  • Edit an existing MPR

To access this page:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Properties > MSS > IMS > TM > MPRs tabs.
Edit

Click this to edit the MPR definition.

Name

Shows the name of the MPR.

Class

The list of transaction classes that this MPR can run.

Description

Shows an optional text description of the MPR.

Add

Click this to add an MPR.

Parent topic: Server Instance Properties: MSS Support


Server Instance Properties: Scripts

Use this page to edit advanced attributes of an enterprise server.

To access this page:

  1. On the server instance screen, select the Server > Properties > Scripts tabs.
ES Start Script

Specify a script to be executed to start the enterprise server. This will override the casstart command that is executed when you start an enterprise server. It is used only if you check Enabled (start script).

Enabled(start script)

Check this to enable the ES Start Script.

ES Stop Script

Specify a script to be executed to stop the enterprise server. This will override the casstop command that is executed when you stop an enterprise server. It is used only if you check Enabled (stop script).

Enabled(stop script)

Check this to enable the ES Stop Script.

On server not responding after n connection attempts

Specify the number of reconnection attempts that you want to take place before taking the action in the small entry field; the default is 1. Specify a script to be executed when the server has failed to respond to the server monitor the number of times specified in the large entry field. It is used only if you check Enabled (non-response script).

Enabled (non-response script)

Check this to enable the non-response script.

Process User ID

UNIX only. Specify a user ID to be attached to all processes started for this enterprise server, including the server itself. If you do not specify a Process User ID, the value set in Default Process User ID on the Configure Options page is used, if there is one. Otherwise, all processes run as user root, which can create problems with security and access to files. You can specify either a numeric user ID or a username.

Parent topic: Edit Server Instance Properties


Server Instance Properties: Permissions

Use this page to specify the permissions of user groups for this enterprise server.

To access this page:

  1. On the server instance screen, select the Server > Properties > Scripts tabs.
Select

Choose group for which you wish to set permissions. Those groups that have already been granted explicit permissions on this enterprise server are marked with an asterisk.

Settings

Check each permission that you want to grant. To grant all permissions, click Allow All.

The permissions are displayed in an inverted tree structure. Those on lower branches include the permissions on the branches from which they descend. For example, the permission to restore a repository includes the permission to import a repository. Therefore, restore is shown as a descendant of import.

When you grant a particular permission, any permissions that it includes are automatically granted. Hence, when you check the Restore Repository permission, the Import Repository permission is automatically checked as well.

Where a check box for a permission is greyed out, it indicates that the permission is included by other permissions that have been granted to the group. To revoke a permission that is included by others, you must first revoke those other permissions.

Parent topic: Edit Server Instance Properties


Server Instance Control

Use this page to monitor an enterprise server instance's processes, and to access the Enterprise Server Monitor and Control (ESMAC) user interface.

To access this page:

  1. On the server instance screen, select the Server > Control tabs.
  • Server Instance Control Settings
Parent topic: Edit Server Instance Properties


Server Instance Control Settings

Use this page to view and change detailed status information for a running an Enterprise Server instance, and to access ESMAC.

To access this page:

  1. On the server instance screen, select the Server > Control tabs.
ES Monitor and Control

Click this to go to Enterprise Server Monitor and Control (ESMAC), which provides a range of monitoring and control facilities for enterprise servers.

Service execution processes

Shows a list of all the service execution processes running on this enterprise server..

Count

Shows a sequence number for the service execution process.

Type
Shows the type of service execution process. The possible values are:
Debug
A service execution process that is being used to debug a service. This service execution process must have been started from the command line.
Normal
A normal service execution process started from the Home page of Server Administration.
Transient
A service execution process that is executing a service which has corrupted the application container, or a service that is responding to a long-running Java stateful session bean. The transient service execution process will terminate when the current service is complete, and be replaced by a new service execution process.
PID

Shows the process identifier of the service execution process. You can use this for tracking and debugging purposes.

TR Count

Shows the number of transactions this service execution process has handled since the server was started.

State
Shows what state the server is in. The possible values are:
Idle
The server is idle and waiting for client requests.
Running
The server is busy, that is, one of the services is currently processing a client request.
Executing

Shows the name of the service that is currently being executed.

Start Time

Shows the time that the current transaction started. This time is local to the machine where the Directory Server is running.

Local Time

Shows the current time. This time is local to the machine where the Directory Server is running.

Duration

Shows how long the current transaction has been running.

Auxiliary processes

Shows a list of all the auxiliary processes running on this enterprise server. Auxiliary processes are system processes that support the activity of the enterprise server.

Type (auxiliary processes)

Shows the type of auxiliary process.

PID (auxiliary processes)

Shows the process identifier of the auxiliary process. You can use this for tracking and debugging purposes.

Requested service execution processes

Specify a new number of service execution processes.

Allocated licenses

Shows the number of licenses allocated to this enterprise server. Can display "Unlimited" if an unlmited number of licenses were allocated.

Requested licenses

Specify a new number of licenses required for this server. You cannot specify a new number of licenses if Allocated licenses is set to "Unlimited".

Update

Click this to update the number of service execution processes or licenses available for this server. When you change the number of service execution processes, the server takes about 20 seconds to start the new processes or shut down existing processes. When you change the number of licenses, extra licenses are granted or refused immediately, and any licenses not required are returned to the pool of unused licenses. When the server is restarted it will use the number of service execution processes and the number of licenses configured in the Edit Server page.

Stop Server

Click this to stop the server.

The server begins to shut down and you are returned to the Home page.

Parent topic: Server Instance Control


Server Instance Diagnostics

Use this page to change the basic configurable attributes of an enterprise server instance.

To access this page:

  1. On the Edit screen, select the Diagnostics tab.
CAUTION:
Changing the properties of a registered enterprise server instance may cause application connection errors and loss of data.
  • Server Instance Diagnostics: Trace
  • Server Instance Diagnostics: Dump
  • Server Instance Diagnostics: ES Console
  • Server Instance Diagnostics: CS Console
Parent topic: Edit Server Instance Properties


Server Instance Diagnostics: Trace

Use this page to change the trace attributes of a server.

CAUTION:
Changing the properties of a registered server may cause application connection errors and loss of data.

To access this page:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Diagnostics > Trace tabs.
Trace Table Size

Specify the number of entries the trace buffer can hold before it wraps back to the start. (The trace buffer is also written to disk at this point if you checked Auxiliary Trace Active.) A value of 2 means that there is space for only one entry, and if you checked Auxiliary Trace Active each entry is written straight out to disk. Each entry is 24 bytes long.

Local Trace Size

Specify the number of entries the local trace table can hold before it wraps back to the start. A value of 0 (zero) means that no local trace table is allocated. Each service execution process has its own local trace table. Each entry is 24 bytes long.

Maximum Diagnostics File Size

Specify the maximum size of the auxiliary trace and dump file in kilobytes. A value of 0 (zero) means that there is no maximum size.

Cold Start Diagnostics File

Check this to indicate that the auxiliary trace and dump files are to be deleted when the server starts.

Dump on System Abend

Check this to indicate that the server should produce a dump if one of its own processes, such as a service execution process, terminates abnormally. The dump information can help you to determine the cause of the abnormal termination

Auxiliary Trace Active

Check this to indicate that trace records are to be flushed to disk before the trace table is overwritten. You should do this only if you have adequate disk space available, since the file can become very big very quickly. If you have a high-activity system use this field in conjunction with Maximum Diagnostics File Size to limit the disk usage. Writing out to a file also degrades performance.

Trace Flags

Use these flags to control what information is written to the trace file for this server. Any changes you make to these fields while a server is running take effect immediately.

Task Control

Check this to indicate that the server is to trace its task control component.

Storage Control

Check this to indicate that the server is to trace its storage control component.

Table Management

Check this to indicate that the server is to trace its table management component.

Application Container

Check this to indicate that the server is to trace its application container component.

Request Handler

Check this to indicate that the server is to trace its request handler component.

RM Interface

Check this to indicate that the server is to trace its resource manager interface component.

Communications

Check this to indicate that the server is to trace its communications component.

Application

Check this to indicate that the server is to trace the CICS API calls made by a CICS application.

Exit

Check this to indicate that the server is to trace user and system exits.

Parent topic: Server Instance Diagnostics


Server Instance Diagnostics: Dump

Use this page to view a list of diagnostic dumps created for this server.

To access this page:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Diagnostics > Dump tabs.
Note: If no diagnostic dumps have been created, this list is empty, and instead you see some text explaining this and the Create Dump button.
Show

Click this to view the dump on this row.

Create Dump

Click this to create a diagnostic dump for this server.

Parent topic: Server Instance Diagnostics


Server Instance Diagnostics: ES Console

Use this page to view the Enterprise Server console log for this enterprise server instance.

To access this page:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Diagnostics > ES Console tabs.
Note: If the enterprise server is not running, you see the message: "No live console data returned."
Show Entries

Click the radio button to the left of this control if you want to view a subset of the entries. Then specify the start and end of the subset in the two entry fields to the right. Click Refresh to view the specified subset.

Show Last

Click this if you want to view a subset of the entries at the end of the log. Then enter the number of entries you want to view in the entry field to the right. The default is that the last 10 lines are shown. Click Refresh to view the specified subset.

Entry

Shows the number of the event. Events are numbered in chronological order, with the most recent last.

Event

Shows a description of the event. Each description starts with the date and time it occurred and the name of the enterprise server.

Show Entire Log

Click this if you want to view the entire log. It should open in whatever application your browser is configured to use for text files.

Historical data available

If the status of the server is anything other than "Started", and the Directory Server is running on your machine, shows the location on your machine of the most recent console log for the server. If you click the right-pointing arrow at the end of the location, the file should open in whatever application your browser is configured to use for text files. If the file fails to open, you can go to the location and open it from there.

Parent topic: Server Instance Diagnostics


Server Instance Diagnostics: CS Console

Use this page to view the communications processes console log for this enterprise server.

Note: If the enterprise server is not running, you see the message: "No live console data returned."

To access this page:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Diagnostics > CS Console tabs.
Show Entries

Click the radio button to the left of this control if you want to view a subset of the entries. Then specify the start and end of the subset in the two entry fields to the right. Click Refresh to view the specified subset.

Show Last

Click this if you want to view a subset of the entries at the end of the log. Then enter the number of entries you want to view in the entry field to the right. The default is that the last 10 lines are shown. Click Refresh to view the specified subset.

Entry

Shows the number of the event. Events are numbered in chronological order, with the most recent last.

Event

Shows a description of the event. Each description starts with the date and time it occurred.

Show Entire Log

Click this if you want to view the entire log. It should open in another browser window.

Historical data available

If the status of the server is anything other than "Started", and the Directory Server is running on your machine, shows the location on your machine of the most recent comms console log for the server. If you click the right-pointing arrow at the end of the location, the file should open in another browser window. If the file fails to open, you can go to the location and open it from there.

Parent topic: Server Instance Diagnostics


Server Instance Properties: Security

Use this page to define the security settings to be used with this enterprise server.

Use default Security Configuration

Check this if you want to use your default security settings for this enterprise server. To define the default settings, click Security on the menu on the left hand side, and then click Security > Default Security Configuration.

Restrict user access

Check this to cause all access to the enterprise server through Enterprise Server Administration to be checked by the security managers specified in the Security Manager Priority List.

Verify against all Security Managers

Set this if you want each security query to be checked by all entries on the Security Manager Priority List.

If this is not set, the entries will be queried in the order that they appear on the Priority List until one gives a response of Allow, Deny, or Fail (equivalent to Deny). This response will then be used to decide what action should be taken.

If this field is set, all entries on the list will be queried, and if any returns a Deny or Fail, the access request will be denied. If there are no Deny or Fail responses and at least one of the entries on the list gives Allow as its response, the request will be allowed.

If a security manager does not have a rule for the resource or user specified in the request, it gives a response of Unknown. Whatever the setting of the Verify against all Security Managers field, if all of the entries on the priority list respond with Unknown, the request will be denied unless you have checked Allow unknown resources or Allow unknown users.

Allow unknown resources

Check this if you want the security facility to permit access to any unknown resource; that is, any resource for which all entries on the priority list return Unknown.

You might use this in circumstances where you only want to restrict access to some resources.

Allow unknown users

Check this if you want to allow unknown users to log in.

Use all groups

Check this if a user requesting authorization is to have the permissions of every group to which he or she belongs.

Uncheck this if the user is to have only the permissions of the group specified in the initial security API call that requested verification (authentication) of the user's credentials. Where no group is specified in the verify call, a default group is used.

Cache limit:

Enter the maximum size in kilobytes that enterprise server's security facility can use for caching the results of security queries.

Cache TTL:

Enter the maximum time in seconds that an entry in the cache can be used to satisfy requests before the details must be requeried from the security manager.

Create audit events

Check this to enable the enterprise server to generate security audit events. These events can be captured and logged by the Audit Facility.

Configuration Information
Enter any security configuration information in this area.
Automated Execution Control Enterprise Server Credentials:
Enter the credentials to use for server start (user ID and password) to be used when the server instance is set to start when the MFDS process starts. This could be after a system re-start, or when a server is stopped from the user interface and the Restart option is selected.
ES Security Manager Priority List

This is the list of security manager (taken from the available pool) that the enterprise server can use to perform security queries.

Note: Security managers are queried in the order that they appear in the list. If the Verify against all Security Managers checkbox is not checked, the first manager in the list that responds with a definite answer will determine the result of a security query. See the text for Verify against all Security Managers for more details.

Use the up and down arrows to reposition the selected entry.

Select
Use this to select a security manager for removal or for moving to a different position in the list.
Name

This column indicates the name that used to identify a security manager.

Module

This column indicates the module used by a security manager to access an external security manager or to implement the security rules.

Description

The description column indicates the description for a security manager.

Enabled

This column indicates whether or not the security manager is enabled. If it is not enabled, it will be ignored by Directory Server and those enterprise servers that reference it.

Add

Click this to add a security manager from the pool of available managers.

Remove

Click this to remove the currently selected security manager from this list.

Note: The manager is only removed from this list, not from the available pool of managers.
Parent topic: Edit Server Instance Properties


Enterprise Server Monitor and Control (ESMAC)

Use ESMAC to change the basic configurable attributes of an enterprise server instance.

To access ESMAC:

  1. From the Enterprise Server Administration home page, at the left of the Enterprise Server instance to configure, click Edit.
  2. On the server instance screen, select the Server > Control tabs.
  3. On the Control page, click ES Monitor & Control.
  • Enterprise Server Monitor and Control - S2 Sidebar Help
  • Server
  • Monitor (1, 15)
  • HSF
  • Control
  • SEPs
  • Clients
  • Diagnostics
  • Resources
  • Users
  • Env.Vars.
  • Dyn-Dbg.
  • System Sign On
Parent topic: Edit Server Instance Properties


Enterprise Server Monitor and Control - S2 Sidebar Help

Enterprise Server Monitor and Control enables you to monitor and control servers, services, packages and handlers on your Enterprise Server. You can also monitor and control CICS-enabled applications, and create and edit CICS SITs, startup lists, groups, resources, and so on. The sidebar menu enables you access to these functions. When you click a button in the sidebar, the body of the page changes, providing information, or controls which you can use to modify settings. For help on the body of the page, click Help, Body.

Home

Click this to return to the Enterprise Server Adminstration home page.

Server

Click this to display information about the current server.

Monitor 1, 15

Click Monitor 1 to display information about tasks, collected at one minute intervals. Click Monitor 15 to display information about tasks, collected at 15 minute intervals.

Control

Click this to view and change control information for this server.

SEPs

Click this to view information about the SEPs (service execution processes) running on this server.

Clients

Click this to view information about the clients using this server.

Diagnostics

Click Display to view the console log, or a dump or trace data set. To select the diagnostic information to view, click:

  • Log - displays the console log. The buttons A, B and C/x have no effect with this button.
  • Dump - displays the dump data set specified by the button A, B or C/x. If you select C/x, the X dump data set is displayed.
  • Trace - displays the trace data set specified by the button A, B or C/x. If you select C/x, the in-memory trace table is displayed.
  • Blocks - specifies the number of blocks of diagnostic information to display.
Reply

Click this to view the list of current outstanding replies to ACCEPT FROM CONSOLE statements. You can see this button only if there is at least one outstanding reply.

Resources

Use the buttons in this group to:

  • View the services, packages and handlers available on this server.
  • Submit JCL jobs and view and update spool queues and the catalog.
  • View and maintain all active resource tables for this server.
  • View and maintain all resource tables for this server.

To access the relevant pages, click the dropdown box. You can choose an item from the list. When you choose an item, extra buttons are displayed that enable you to display the information required. You can select:

  • Services - when you select this, you can click:
    • Services - to view the services available on this server.
    • Package - to view the implementation packages available on this server.
    • Handlers - to view the request handlers available on this server.
  • JES - when you select this, you can click:
    • Spool - to view and manage spool queues.
    • Catalog - to view and manage the catalog and data sets.
    • Control - to submit JCL jobs and start batch initiator and batch printer SEPs.
    • Locks - to view the current resource locks for this server.
  • IMS - when you select this you can click:
    • Transact. - to view the defined IMS transactions
    • Control - to perform IMS-related administration functions
  • Active - when you select this, you can click:
    • ACEEs - to view the active ACEEs for this server.
    • DCT - to view the active DCTs for this server.
    • FCT - to view the active FCTs for this server.
    • ICE - to view the interval control elements for this server.
    • JCT - to view the active JCTs for this server.
    • Locks - to view the current resource locks for this server.
    • PCT - to view the active PCTs for this server.
    • PPT - to view the active PPTs for this server.
    • Sys-C - to view the active CCI connection definitions for this server.
    • T-Type - to view the active T-Types for this server.
    • TST - to view the active TSTs for this server.
  • by Group - when you select this, you can click:
    • Groups - to view the CICS resource groups for this server.
    • Startup - to view the startup lists for this server.
    • SIT - to view the SITs for this server.
  • by Start L - displays the resources, defined for the startup list used by the SIT in use on this server, and the resource groups they are associated with. When you click this, you can select:
    • DCT - to view the DCTs in this startup list.
    • FCT - to view the FCTs in this startup list.
    • JCT - to view the JCTs in this startup list.
    • PCT - to view the PCTs in this startup list.
    • PLT - to view the PLTs in this startup list.
    • PPT - to view the PPTs in this startup list.
    • Sys62 - to view the LU6.2 connection definitions in this startup list.
    • SysC - to view the CCI connection definitions in this startup list..
    • Term - to view the Terminal definitions in this startup list.
    • TST - to view the TSTs in this startup list.
    • T-Type - to view the T-types in this startup list.
    • XAT - to view the XA-compliant database table definitions in this startup list.
  • by Type - displays the resources available on this server, by type, and shows the resource group the resource is associated with. When you click this, you can select:
    • DCT - to view the available DCTs.
    • FCT - to view the available FCTs.
    • JCT - to view the available JCTs.
    • PCT - to view the available PCTs.
    • PPT - to view the available PPTs.
    • Sys62 - to view the available LU6.2 connection definitions.
    • SysC - to view the available CCI connection definitions.
    • Term - to view the available Terminal definitions.
    • TST - to view the available TSTs.
    • T-Type - to view the available T-Types.
    • XAT - to view the available XA-compliant database table definitions.
Users

Click this to view the users able to use ESMAC.

Env. Vars.

Click this to view the environment variables for this server.

Dyn Debug
Displays the status of dynamic debugging with details of in-force debug criteria.
Chg. User.

Click this to view the System Sign On page, which enables you to sign on as another user, or to change your password.

Parent topic: Enterprise Server Monitor and Control (ESMAC)


Server

Use this page to view system information for the server.

Times

Shows the date and time at which the current server was started, and the number of days, hours, minutes and seconds that have passed since the server was started.

Counts

Shows the following information:

  • Transactions - the number of transactions that have occurred since the server was started.
  • Dumps - the number of dumps generated since the server was started.
  • Per hour - the number of transactions per hour, based on the number of transactions shown in Transactions.
  • Trace Blocks - the number of trace blocks generated since the server was started.
  • Active Clients - the number of clients that have been active since the server was started.
  • Limit - the number of concurrent client licenses allowed.
Sizes

Shows the following information:

  • Max Tasks - the maximum number of tasks that can run concurrently on this server. A task handles a process such as a CICS transaction, a SOAP service, and so on.
  • HTTP Out - the size of the data blocks passed across shared memory for HTTP output.
  • Diagnostics Size - the maximum size of a diagnostic data set. When this size is exceeded, the alternate (A or B) data set is used (and any data in that data set is overwritten). A value of 0 (zero) means that there is no maximum size.
  • ID Timeout - the global user ID timeout specified. If no ID timeou ha been defined, this field is blank.
  • Shared Memory - the number of shared pages in memory reserved for all the processes that run in the enterprise server. Each page is 4 KB long.
  • SM Total - the amount of shared memory available to this server, shown in kilobytes.
  • SM Cushion - the number of kilobytes reserved from the shared memory pages to enable the server to continue processing when the shared memory allocation is too small for the operational requirements of the server.
  • SM Free - the amount of shared memory currently free, shown in kilobytes.
States

Shows the following information:

  • Working Mode - the current working bit mode of the server.
  • Perf Enabled - enables reporting of performance data that can be viewed in Perfmon and Operations Manager,
  • Force Phase In - the current state of Force Phase In. If Force Phase In is set, MSS reloads programs each time they are invoked. This applies only to programs that are not marked resident and have not been loaded with the hold attribute. If Yes, Force Phase In is set; if No, it is not. You can set the state of Force Phase In on the Control page, which can be displayed by clicking Control
  • Dump - shows which data set is currently set to receive dump information, which can be A or B.

    You can set the data set to be used for dump information on the Control page, which can be displayed by clicking Control.

  • Dump on Abend - the dump state. The dump state can be:
    • Sys: No Tran: No
    • Sys: Yes Tran: No
    • Sys: No Tran: Yes
    • Sys: Yes Tran: Yes

    where Sys indicates a system dump, and Tran indicates a transaction dump.

    You can set the dump state on the Control page, which can be displayed by clicking Control.

  • Trace - shows which data set is currently set to receive trace information, which can be A or B.

    You can set the data set to be used for trace information on the Control page, which can be displayed by clicking Control.

  • Active trace - indicates whether the in-memory trace is currently being recorded to the active auxiliary diagnostic data set.

    You can switch the active trace on and off on the Control page, which can be displayed by clicking Control.

Startup

This group is displayed only if you have enabled MSS. It contains the following information:

  • Sit - the name of the SIT currently used by this server.
  • PLT-PI - the program list table (PLT) that specifies the initialization programs to be run when the region is started. If this is blank, no special processing is done when the region is started.
  • SYSID - the system ID of the SIT.
  • PLT-SD - the program list table (PLT) that specifies the shutdown programs to be run when the region is stopped. If this is blank, no special processing is done when the region is stopped.
  • Fileshare user - the user ID used by the region to log on to all Fileshare servers that MSS is configured to use.
  • Security - indicates whether or not the server has security enabled.
Activity

Contains the following information:

  • The time at which sampling of activity was started. The time is shown in 24-hour format. The duration of sampling is 15 minutes. To see the latest activity statistics for this 15-minute period, click Refresh.
  • Average latency (100/sec) - The average latency for transactions on this server. This is shown in hundredths of a second, and as a graphical representation in yellow.
  • Average tasks (100/sec) - The average time taken to complete a task on this server. This is shown in hundredths of a second, and as graphical representation in blue.
  • Task/sec - The average number of tasks completed per second on this server. This is shown as a number, and as a graphical representation in green.
Parent topic: Enterprise Server Monitor and Control (ESMAC)


Monitor (1, 15)

Use this page to view information on transactions that have occurred in the last n minutes, where n is 1 or 15. The display is cumulative, showing activity in n-minute intervals over the last half-an-hour for Monitor (1 minute intervals), and over the last 8 hours for Monitor (15 minute intervals).

hh:mm

Shows the time, in 24-hour format, at which the last statistics collection period ended.

The rest of the row shows:

  • The average latency for a transaction. This is shown as a figure in hundredths of a second, and as a graphical representation in yellow.
  • The average time taken to complete a task. This is shown as a figure in hundredths of a second, and as a graphical representation in blue.
  • The task count - the number of tasks completed within the one-minute interval. This is shown as a figure, and as a graphical representation in green.
Parent topic: Enterprise Server Monitor and Control (ESMAC)


HSF

  • HSF (summary)
  • HSF (transaction name)
Parent topic: Enterprise Server Monitor and Control (ESMAC)


HSF (summary)

Use this page to view summary HSF information for this server.

This shows the period of time (displayed in minutes and seconds next to Historical Statistics) between the earliest records displayed and the current time. Records older than one hour are deleted. The following information is shown for each transaction:

Average Latency
The average time, in hundredths of a second, between Enterprise Server receiving the requests and the tasks beginning to run.
Average Response Time
The average time, in hundredths of a second, that the tasks ran for (not including latency time).
Count
How many times the task has run.
Parent topic: HSF


HSF (transaction name)

Use this page to view detailed HSF information for this transaction.

Latency+Resp
The sum of latency and response time averages.
Transaction
The name of task:
  • for CICS and IMS tasks, the transaction ID
  • for JCL, the job name
  • for Web services, the service name
  • for CGI programs, the program name
Program
  • for CICS and IMS tasks, the program name
  • for JCL, the program name or the job number, depending on the JCL record type
Process ID
Process ID of the SEP which ran the task.
Task Number
A unique task number.
Date
The date the task started to run, in the format yyymmdd.
Time
The time the task started to run, in the format hhmmsscc.
User
The ID of the user that initiated the task.
LU/Step
  • for CICS tasks, the logical unit or net name (the identifier of the terminal used to initiate the task).
  • for JCL, either the step name, the JOBSTART constant indicator, or the job return code depending on the JCL record type. All three of these record types are generated for each JCL job.
Parent topic: HSF


Control

Use this page to view and change control information for this server.

Apply

Click this to save changes you have made to the page and refresh the page. This button is displayed only if you have the required permissions.

General
SEPS

Shows the number of concurrent service execution processes currently supported by this server. You can change the number by entering a value in the field.

Force Phase In, Yes

Check this to have MSS reload programs each time they are invoked. This applies only to programs that are not marked resident and have not been loaded with the hold attribute.

Admin
The number of Admin SEPs defined
Initial Tran
The transaction to run when a TN3270 session connects to the server.
HTTP Out

Shows the size of the data blocks passed across shared memory for HTTP output. You can change the HTTP size by entering a value in the HTTP Size field.

Timeouts
ID

Shows the time in minutes that the system will allow an ESMAC or TN3270 client session to remain idle before logging off the user. At system startup, this is initialized to the value specified in the System Initialization Table. A value of 0 indicates that there is no timeout. Please note that if you change the value, the change will not be saved at system shutdown.

Runaway

Shows the maximum continuous period of time in seconds that the region will allow a transaction to run without making a CICS, EZASOKET or MQSeries API call. When this value is exceeded, the transaction is abended. At system startup, this is initialized to the value specified in the System Initialization Table. A value of 0 indicates that there is no timeout. Please note that if you change the value, the change will not be saved at system shutdown. Note also that you can override this value for an individual transaction through the relevant Program Control Table entry.

Input

Shows the maximum time in seconds allowed for operator response to an explicit CICS RECEIVE command before the transaction is abended. At system startup, this is initialized to the value specified in the System Initialization Table. A value of 0 indicates that there is no timeout. Please note that if you change the value, the change will not be saved at system shutdown. Note also that you can override this value for an individual transaction through the relevant Program Control Table entry.

Deadlock

Shows the maximum time in seconds that the region will permit an application to wait for a resource that has been locked by another process. At system startup, this is initialized to the value specified in the System Initialization Table. A value of 0 indicates that there is no timeout. Please note that if you change the value, the change will not be saved at system shutdown. Note also that you can override this value for an individual transaction through the relevant Program Control Table entry.

Diagnostics
Size

Shows the maximum size of the auxiliary trace and dump file in kilobytes. A value of 0 (zero) means that there is no maximum size. You can change the size by entering a value, in kilobytes, in the Diagnostic Size field. The maximum size you can enter in this field is 999999 kilobytes.

Dump

Shows the current data set used for dump information.

Switch

Click this to switch between the A and B data sets that are used to store dump information.

Dump

Click this to initiate a dump. Dump information is stored in the data set identified by Active Dump DS. If you do not initiate a dump using Dump, dumps occur when the system and/or transaction abends, or if the program executes the EXEC CICS DUMP command. A dump will occur on an abend only if Sys and/or Tran is checked in the Dump on Abend group.

Countn

Shows the number of dumps (n) that have occurred.

Trace

Shows the current data set used for trace information.

Switch

Click this to switch between A and B data sets used to store trace information.

Aux, active

If checked, the in-memory trace data is transferred to the auxiliary (diagnostic) data set at the roll-over of the system trace table.

Blocks

Shows the number of blocks of trace information captured.

Dump on ABEND
Sys
Check this to indicate that MSS should produce a dump if an abend occurs in its own code.
Tran
Check this to indicate that MSS should produce a dump if an abend occurs in any of your transaction programs. If you check this field, then you can control whether or not a dump is produced for an individual program by checking or unchecking Dump on abend on the PCT properties dialog box. If you leave this field unchecked, MSS ignores the setting of Dump on abend on the PCT properties dialog box.
Debugger
Check this to enable dynamic debugging.
HSF Data
Enable collection of HSF records
This switches on HSF processing.
Write to disk
Enables writing of HSF records to comma-separated files. These are called cashsf-a.csv and cashsf-b.csv, and are written to the system directory. Only one file is written to at any one time - this is called the active file.

You write to the active file until you click the ESMAC Switch button or when the active file reaches the maximum size, at which point the alternate file becomes active. If the alternate file already exists it will be backed up with the name cashsf.nnn where nnn is the number of the backup. When you start an enterprise server, cashsf-a.csv is always set as the active file, and if it already exists it is backed up.

Backup extensions are numbered from .001 up to .999. When a backup with extension .999 exists then the next backup will be created as cashsf.001. If cashsf.001 already exists then it will be overwritten.

Max HSF file size
If you have selected Write to disk, this is the size in kilobytes the .csv file will reach before Enterprise Server switches to the alternate .csv file. A value 0 selects the maximum size possible (4 Gb).
Number of records to view in ESMAC
The number of HSF records that Enterprise Server will hold in memory. These records can be viewed by clicking on the HSF button in ESMAC while the server is running. When this number is reached, older records will be deleted when a new one is created. Records older than one hour are deleted too.
The minimum value is 0 (no HSF data displays in ESMAC), the maximum is 4096.

Clicking the Switch button will switch collection to the alternate .csv file before the active file has reached the maximum size.

Trace Points

Shows the currently set trace points. The trace points shown are those that have been set by the SIT. You can change individual trace points by checking the check box next to each trace point, or you can use all to change all the settings at once. This overrides the trace points set by the SIT. Any changes you make are effective immediately you click Apply. The changes are lost, however, the next time the server is initialized.

all
Choose a setting to apply to all the trace points:
  • On - enables all the trace points
  • Off - disables all the trace points
Attention: When you set all the trace points on at once, the trace points CCI, fh and fh-enable are unaffected. This is because these trace points should be used only when advised by Micro Focus.
Server
dmp
Check this to indicate that MSS is to trace its dump control component.
lock-data
Check this to trace lock management for non-threaded processes.
scp
Check this to indicate that MSS is to trace its storage control component.
tsc
Check this to trace calls to the castsc process.
exits
Check this to indicate that MSS is to trace the user exits.
msg
Check this to indicate that MSS is to trace its messages component.
sql-api
Not used.
tsc-data
Check this to trace the data in calls to the castsc process.
fh
Do not check this unless advised by Micro Focus.
reqh
Check this to indicate that MSS is to trace its request handler component.
tmp
Check this to indicate that MSS is to trace its table management component.
tsc-thread
Check this to trace thread processing and lock management in the castsc process.
fh-enable
Do not check this unless advised by Micro Focus.
rm
Check this to indicate that MSS is to trace its resource manager component.
trd
Check this to trace thread processing in all threaded processes.
xfp
Check this to trace data in transformer processing.
jcp
Check this to indicate that MSS is to trace its journal control component.
rts
Check this to indicate that MSS is to trace its run-time system (application container) component.
trd-enq
Check this to trace processes and data in transformer processing.
xfp-all
Check this to trace data and processes in transformer processing.
tcp
Check this to indicate that MSS is to trace its terminal control component.
saf(security)
Check this trace System Authorization Facility (SAF) calls.
trd-stg
Check this to trace memory management in threaded processes.
xfp-data
Check this to trace data in transformer processing for threaded processes.
JCL/JES
common
Not used.
hsf
Check this to indicate that MSS is to trace the creation of Historical Statistics Facility (HSF) records for JCL.
CICS
api

Check this to indicate that MSS is to trace the CICS API calls.

icp
Check this to indicate that MSS is to trace its interval control component.
ts-td
Check this to indicate that MSS is to trace its temporary storage/transient data (TS/TD) component.
fcp
Check this to indicate that MSS is to trace its file control component.
kcp
Check this to indicate that MSS is to trace its task control component.
user
Check this to enable a user trace.
IMS
api
Check this to indicate that MSS is to trace IMS DL/I API entry points.
dbc
Check this to indicate that MSS is to trace IMS DB control processing.
i/o
Check this to indicate that MSS is to trace IMS physical/virtual file I/O.
sys
Check this to indicate that MSS is to trace miscellaneous IMS processing.
cli
Check this to indicate that MSS is to trace IMS MPR, JES and SEP processing.
ES-DB
Check this to indicate that MSS is to trace ES IMS DB processing.
stg
Check this to indicate that MSS is to trace IMS dynamic memory allocation/freeing.
TM-ctl
Check this to indicate that MSS is to trace IMS TM control processing.
data
Not used.
ES-stg
Check this to indicate that MSS is to trace ES IMS memory management.
DB-thread
Check this to indicate that MSS is to trace lock management for IMS DB.
TM-thread
Check this to indicate that MSS is to trace lock management for IMS TM.
TM-buffer
Check this to indicate that MSS is to trace the buffer for IMS TM lock management.
Communications
cci
Do not check this unless advised by Micro Focus.
data
Check this to trace basic data in the communication module and IMS TM.
mfcs-cg
Check this to trace Micro Focus Communications Server (MFCS) requests
common
Check this to trace thread processing in the communications module.
data-all
Check this to trace extended data in communication module and IMS TM.
cg-thread
Check this to trace lock management in the communications module.
Memory Strategy
Use this to control the frequency and type of runtime memory validation, as well as specifying the processes to which these settings apply.
Debug SEP
Start
Starts a debug SEP. A value of "Any" indicates that any transaction can be debugged in this SEP.
Transaction
Indicates the only transaction to be debugged in this SEP.

If terminals are connected, the additional option Terminal enables you to debug only those transactions initiated from the selected terminal.

Shutdown
Click this to shut down the current server. You restart the server using Enterprise Server Administration.
Dump
A system dump is taken when the server shuts down.
Immediate

Check this to force an immediate shutdown when you click Shutdown. If you force an immediate shutdown, you will see "The page cannot be displayed" error, as there is no longer a server to connect to.

Parent topic: Enterprise Server Monitor and Control (ESMAC)


SEPs

Use this page to view information about the service execution processes (SEPs) on the current server.

The page is divided into five sections:

  • Standard - SEPs executing your transactions.
  • Auxiliary - processes run by the server that provide auxiliary services to the SEPs.
  • Debug - processes handling debug requests. You see this section only if there are debug processes executing.
  • Transient - long running processes. Once the process has completed, the SEP is removed from the list.
  • JES Init - batch initiators, that is, SEPs that execute JCL applications.
  • JES Print - processes that handle the sending of files output by JCL jobs to printers.
Trace

Click this to view a system trace for the SEP.

Kill

Click this to kill the SEP while a task is running.

Stop

Click this to stop the SEP when the current task completes.

Process ID, Start Time, Service/TranID

This column shows the process ID, the time at which the service was started, and the service or transaction ID (where available).

Type, Duration

This column shows the type of service and the amount of time the service has been running. The type can be:

  • SEP - service execution process
  • CAS Manager - An enterprise server management service
  • JCP - journal control program
  • TDP - extra-partition transient data program
  • Fileshare - A Fileshare service
Task Number, Client, Function

This column shows the task number for the service, the process ID (pid) of the client using this server, and the function. You can see which clients are associated with a process ID by displaying the Clients page; click Clients to do this.

Tran. count, Wait ID/Duration, User ID

This column shows the number of transactions performed by this SEP, the wait ID and user ID. The wait ID indicates, for suspended services, the ID of the process that is waiting to complete and the amount of time the process has been waiting. The user ID displays the ID of the signed-on client that is currently being processed.

Process ID, Start Time

This column shows the process ID and the time at which the service was started.

Initiator Classes, Duration

This column shows the classes that the batch initiator SEP handles and the amount of time the SEP has been running.

Job Number, Job Name

This column shows the job number and the job name of the JCL job that the SEP is handling.

Job Count, Step Name, User ID

This column shows the number of jobs this SEP has run since it was started, the step name currently being executed and the user ID under which the job is running. If you did not specify a USER on the JOB card, the user ID is the name of the enterprise server.

SYSOUT Classes, Duration

This column shows the classes that the batch printer SEP handles and the amount of time the SEP has been running.

Job Count, DD Name

This column shows the number of jobs this SEP has run since it was started, and the DD name of the file being printed.

Device

Shows the name of the printer being used.

Exit

Shows the pathname of the printer exit program that this batch printer SEP uses when it prints jobs, if any.

Parent topic: Enterprise Server Monitor and Control (ESMAC)


Clients

Use this page to display Client information for this server.

Trace

Click this to view a local trace for the associated process. This is available only for MQ listeners.

Process ID

Shows the process ID of the client.

Type

Shows the type of client:

  • 3270
  • 3270 Bridge
  • CCI - A client that uses CCI (Common Communications Interface) to connect to the server
  • CCI HTTP - A client that uses HTTP (Hyper Text Transmission Protocol) - such as SOAP, BINP, CGI
  • Comms Server - Client communications controller process (listener)
  • ECI - External Call Interface
  • FileShare - Traditional Fileshare2 client
  • Generic
  • IBM MQ - IBM Message Queuing listener
  • Other
  • SESSION - A LU6.2-type session that is multiplexed on a link
  • Spool - System spooler client
  • SURROGATE - Surrogate for a client attached to another server
  • SURROGATE-t
  • SYSTEM - A peer server
  • TN3270 - A Telnet 3270 client
  • UniCli - An IBM universal client
Net Name

Shows the assigned SNA network node name for that client.

User ID

Shows the user ID of the user running the client. This might be a system ID, such as HTTP Soap for system services such as the SOAP listener.

Parent topic: Enterprise Server Monitor and Control (ESMAC)


Diagnostics

  • Dump data set
  • Trace store
Parent topic: Enterprise Server Monitor and Control (ESMAC)


Dump data set

Use this page to view dump information, contained in data set, for the transactions on this server. data set can be A, B or X.

Details

Click this to see detailed information for the dump selected. The detailed information includes the summary information at the end.

Sum

Click this to see summary information for the dump selected.

Level

Choose a level of trace information that you want to be included in the trace tables in the dump. The trace information includes system trace tables and local trace tables. The options are:

0 | Service start, module start, module end, service end.
1 | Enterprise server API entries and exits
2 | Subsystem trace entres
3 | All entries where it is possible to provide some formatting of the data
4 | All trace entries. This is the default.

This option affects what you see in a detailed dump, not a summary dump. Local trace tables (traces for SEPs) only have levels 0 and 1.

PID, Code (Caller)

Shows information about the dump:

  • The process ID
  • A code that helps identify the dump
  • The origin of the dump request
Date(mm/dd/yy) Time

Shows a date and time stamp for the dump. The time stamp is in hours, minutes, seconds, and hundredths of a second.

Parent topic: Diagnostics


Trace store

Use this page to view trace information contained in a dataset or in memory. store can be A or B, for the A or B datasets, or X to indicate an in-memory trace.

Details

Click this to see detailed information for the trace selected.

Blocks

Specify the number of blocks that you want to be included in the detailed trace information starting at the first block in this index entry. The default is the number you specified in Blocks in the Diagnostics group in the menu.

Level

Choose a level of trace information that you want to be included in the details:

0 | Service start, module start, module end, service end. This is the default.
1 | Enterprise server API entries and exits
2 | Subsystem trace entres
3 | All entries where it is possible to provide some formatting of the data
4 | All trace entries
PIDs

If you want to filter the details by process ID, check the check boxes next to the process IDS of the processes you want detailed trace information for.

Task IDs

If you want to filter the details by task ID, check the check boxes next to the task IDS of the tasks you want detailed trace information for.

Date(mm/dd/yy) Time

Shows a date and time stamp for the dump. The time stamp is in hours, minutes, seconds and hundredths of a second.

Parent topic: Diagnostics


Resources

  • Services
  • Active
  • by Group
  • by StartL
  • by Type
  • JES
  • IMS
  • Pages for Creating Resources
  • Pages for Viewing and Editing Resources
Parent topic: Enterprise Server Monitor and Control (ESMAC)


Services

  • Lists of Services
  • Details of Individual Services
Parent topic: Resources


Lists of Services

  • Services
  • Service Packages
  • Request Handlers
Parent topic: Services


Services

Use this page to view information about the services currently available on the server.

Details

Click this to view detailed information for the service.

The rest of the information in this row shows:

  • The location of a service
  • The protocol used by the service
Show Sys Entries

Click this to view the system services.

The page expands to include all the system services currently running. You can click Details for any of these system services to get more information.

Hide Sys Entries

Click this to hide the system services.

This button is displayed only if you have previously clicked Show Sys Entries.

Parent topic: Lists of Services


Service Packages

Use this page to view information about the implementation packages available on the current server.

Details

Click this to display detailed information for the package.

The rest of the information in this row shows the name of the implementation package.

Parent topic: Lists of Services


Request Handlers

Use this page to view information about the request handlers available on the current server.

Details

Click this to view detailed information for the request handler.

The rest of the information in this row shows the name of the request handler.

Parent topic: Lists of Services


Details of Individual Services

  • Service
  • Service Package
  • Request Handler
Parent topic: Services


Service

Use this page to view information about a particular service, selected from the Services page. You can also change the log status and create a new copy of the IDT.

Apply

Click this to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the service.

Name

Shows the service namespace.

Transaction

Shows the characteristics of the service. The characteristics relate to the commit/rollback of protected resources accessed by the service. Values can be Container Managed or Application Managed.

RTS Trace

Specifies the state of entry and exit tracing for the service:

  • None - no tracing is done
  • User - user applications are traced
  • System - the system is traced
  • Both - both applications and the system are traced
Log I/O

Shows whether, for each request for this service the request and response blocks are written to the enterprise server dump data set. If None, nothing is logged. If Dump, request and response blocks are written to the enterprise server dump data set. To set the log to None or Dump, click on the dropdown box, select the required setting, and click Change.

Only use this option if you need diagnostics, as it degrades performance.

Ref. Count

Shows the number of applications that reference this service.

Service Status

Shows the current status of the service. The possible statuses are:

  • In service - the service is available.
  • Error - an error has occurred such that it has not been possible to set the status to any other value.
  • Disabled - the service is disabled.
Parent topic: Details of Individual Services


Service Package

Use this page to view information about a particular implementation package, selected from the Service Packages page. You can also use this page to force the load of a new copy of the IDT.

Name

Shows the name of the implementation package for this service.

IDT

Shows the path of the IDT (interface definition table) for the package.

IDT Size

Shows the physical size of the specified IDT. The IDT size is shown only if the IDT is currently loaded and held in shared memory.

New Copy

Click this to force a new copy of the IDT to be loaded for the next execution of the service. If an IDT is resident (that is, in shared memory), New Copy removes it, forcing the system to reload the IDT from disk the next time a service requests it.

Module

Shows the name of the library that contains the package, if any.

Status

Shows the current status of the implementation package. The possible statuses are:

  • In service - the package is available.
  • Error - an error has occurred such that it has not been possible to set the status to any other value.
  • Disabled - the package is disabled.
Location

Shows the path where the package file is located.

Ref. Count

Shows the number of programs that have made use of this package since the server started.

Parent topic: Details of Individual Services


Request Handler

Use this page to view information about a particular request handler, selected from the Request Handlers page.

Name

Shows the name of the request handler.

Handle ID

Shows the unique ID assigned to this handler by the server.

Status

Shows the current status of the request handler:

  • In service - the request handler is available.
  • Error - an error has occurred such that it has not been possible to set the status to any other value.
  • Disabled - the request handler is disabled.
Type

Shows the type of request handler:

  • Other
  • Soap
  • CGI
  • Undefined
Location

Shows the path where the handler is located.

Ref. Count

Shows the number of programs that have made use of this handler since the server started.

Parent topic: Details of Individual Services


Active

  • Lists of Active Resources
  • Details of an Active Resource
Parent topic: Resources


Lists of Active Resources

  • ACEEs (Active)
  • DCT (Active)
  • FCT (Active)
  • ICE (Active)
  • JCT (Active)
  • Locks (Active)
  • PCT (Active)
  • PPT (Active)
  • SysC (Active)
  • T-TYPE (Active)
  • XAT (Active)
  • TST (Active)
  • URIMAP (Active)
  • TCPIPSv (Active)
  • DOCTEMPLATE (Active)
Parent topic: Active


ACEEs (Active)

Use this page to view the list of active Access Control Environment Elements (ACEE).

Details

Click to display detailed information for the ACEE.

The rest of the information in this row shows:

  • The name of the ACEE.
  • The group to which this ACEE belongs.
Parent topic: Lists of Active Resources


DCT (Active)

Use this page to view the DCTs available on this server.

Details

Click this to display detailed information for the DCT.

The rest of the information in this row shows:

  • The name of the DCT.
  • Whether the DCT is enabled or disabled.
  • The type of DCT.
Parent topic: Lists of Active Resources


FCT (Active)

Use this page to view the FCTs available on this server.

Details

Click this to display detailed information for the FCT.

The rest of the information in this row shows:

  • The name of the FCT.
  • Whether the FCT is enabled or disabled.
Parent topic: Lists of Active Resources


ICE (Active)

Use this page to view and delete the interval control elements active on this server.

You can delete an interval control element by clicking Delete button to the left of its row in the table.

Request ID

Shows the ID of the request for a time-delayed event. This is specified in the CICS API call that initiated the interval control element.

Transaction

Shows the transaction in which the call was executed.

Terminal

Shows the terminal where the transaction was entered.

Day/Time

Shows the day and time for which the time-delayed event is scheduled. Day 0 means today, day 1 means tomorrow, etc.

Parent topic: Lists of Active Resources


JCT (Active)

Use this page to view the JCTs active on this server.

Details

Click this to view detailed information for the JCT.

The rest of the information in this row shows:

  • The name of the JCT.
  • The status of the JCT.
  • The type of JCT.
Parent topic: Lists of Active Resources


Locks (Active)

Use this page to view the current resource locks on this server.

Lock Ownership
Lists the current locks.
PID

Shows the process ID (PID) of a process that has issued a lock or wishes to issue a lock.

res-ID

Shows a resource ID allocated to the locked resource for the purposes of linking the information in the Lock Ownership part of the table with the information in the Resource Details part of the table.

Type

Shows the type of lock.

State

Shows the state of the lock. Possible states are:

Controlled | The requester has control of the resource
Waiting | The requester is waiting to gain control of the resource (synchronous request)
Pending | The requester has issued the request but has continued with other work (asynchronous request)
Persistence

Shows how long the lock lasts. Possible values are:

LUW | The lock lasts until the logical unit of work ends
Task | The lock lasts until the task ends
Lock Manager | There is no implicit release of the lock.
Process | The lock lasts until the process ends
Seq
The order in which requesters are to be handled.
Resource Details
Lists the resources that are locked.
Res ID (Resource Details)

Shows a resource ID allocated to the locked resource for the purposes of linking the information in the Lock Ownership part of the table with the information in the Resource Details part of the table.

Queue

Shows the lock namespace.

Length

Length of the resource name in characters.

Resource Name

Shows the name of the resource given to it by the requester.

Parent topic: Lists of Active Resources
Parent topic: Locks


PCT (Active)

Use this page to view the PCTs available on this server.

(Details)

Click this icon to view detailed information for the PCT.

The rest of the information in this row shows:

  • The name of the PCT.
  • The average time it takes for the transaction to complete.
  • The number of times the transaction has been executed since the server started.
Parent topic: Lists of Active Resources


PPT (Active)

Use this page to view the PPTs available on this server.

Details

Click this to display detailed information for the PPT.

The rest of the information in this row shows:

  • The name of the PPT.
  • The type of PPT.
  • Whether the PPT is enabled or disabled.
  • The programming language of the program associated with the PPT.
Parent topic: Lists of Active Resources


SysC (Active)

Use this page to view the SysCs active on this server. A SysC is a definition of a CCI system connection.

Details

Click this to view detailed information for the SysC.

The rest of the information in this row shows:

  • The name of the SysC.
  • The status of the SysC.
  • The type of SysC.
Parent topic: Lists of Active Resources


T-TYPE (Active)

Use this page to view the T-types active on this server.

Details

Click to display detailed information for the T-type.

The rest of the information in this row shows:

  • The name of the T-type.
  • The status of the T-type.
  • The type of T-type.
Parent topic: Lists of Active Resources


XAT (Active)

Use this page to view the list of XATs defined in resource groups used by the startup list name.

Details

Click this to see detailed information for the XAT in this row.

The rest of the information in this row shows:

  • The name of the XAT
  • Whether it is currently enabled or disabled
Parent topic: Lists of Active Resources


TST (Active)

Use this page to:

  • View the TSTs active on this server
  • View and delete the actual data queues in the TSTs
  • View and delete data records associated with interval control elements. These are held as special single-record TS queues.
Details

Click this to view detailed information for the TST.

The rest of the information in this row shows:

  • The name of the TST.
  • The status of the TST.
  • A description of the TST.
TS Unit Table Queues

Shows the actual data queues and interval control element data records that currently exist on this server. Hexadecimal IDs (those that contain non-displayable characters) are displayed in both hexadecimal notation and display notation (with the non-displayable characters replaced with full stop characters “.”).

You can delete an entry in the TS Unit Table by clicking Delete button to the left of its row in the table. When you delete an IC (interval control element) data record, you also delete the interval control element that it is associated with. The delete request is actioned immediately, and a message comfirming this is displayed at the top of the TST information.

Current

Shows the position in the queue of this item. It is used to resolve which queue item a generic READQ will return.

Depth

Shows the current number of items in the queue.

Type

Shows the type of data queue or interval control element data record. The meanings of the abbrevations are:

rc
recoverable
nr
unrecoverable
TS
temporary storage queue
IC
interval control element
Parent topic: Lists of Active Resources


URIMAP (Active)

Use this page to view the URIMAPs available on this server.

Details
Click this to display detailed information for the URIMAP.

The rest of the information in this row shows and the name of the URIMAP, whether the URIMAP definition is for an HTTP server or client, and whether it is enabled or disabled.

Parent topic: Lists of Active Resources


TCPIPSv (Active)

Use this page to view the TCPIPServices available on this server.

Details
Click this to display detailed information for the TCPIPService.

The rest of the information in this row shows the name of the TCPIPService and its current status.

Parent topic: Lists of Active Resources


DOCTEMPLATE (Active)

Use this page to view the DOCTEMPLATEs available on this server.

Details
Click this to display detailed information for the DOCTEMPLATE.

The rest of the information in this row shows the name of the DOCTEMPLATE and the type of its source.

Parent topic: Lists of Active Resources


Details of an Active Resource

  • ACEE for Username
  • DCT Entry (dct_name)
  • FCT Entry (fct_name)
  • JCT Entry (jct_name)
  • PCT Entry (pct_name)
  • PPT Entry (ppt_name)
  • SysC Entry (sysc_name)
  • T-TYPE Entry (ttype_name)
  • XAT
  • TST Entry (tst_name)
  • URIMAP Entry (urimap_name)
  • TCPIPService Entry (tcpipsv_name)
  • DOCTEMPLATE Entry (doctemplate_name)
Parent topic: Active


ACEE for Username

Use this page to view the Access Control Environment Element (ACEE) for a user.

ACEE

This is the id of a user who signed on to the system.

Group

The sign-on group of the user.

Long Name

The long name of the user.

Operator ID

The identification code that you assign to the operator.

Timeout

The time in minutes that the system will allow an ESMAC or TN3270 terminal to client session to remain idle before logging off the user. If the value is 0, the system value is used.

Operator Class

The operator class used for routing messages initiated in a CICS transaction.

Priority

The value used by the system to determine task priority for CICS transactions invoked by the user at a terminal.

Resource Keys
All

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys.
  • Off - disables all the resource keys.
1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Security Keys
All

Choose a setting to apply to the security keys:

  • On - enables all the security keys.
  • Off - disables all the security keys.
1 - 64

Check any of the boxes 1 through 64 to activate that security key.

Surrogate Keys
All

Choose a setting to apply to all the surrogate keys:

  • On - enables all the surrogate keys
  • Off - disables all the surrogate keys
1 - 24

Check any of the boxes 1 through 24 to activate that surrogate key.

JCL Submit

Check this to enable this user to submit JCL jobs via the cassub utility.

ES Security

Check this for the user ID mfuser to enable ESMAC security.

ESMAC Access
all

Choose a setting for the level of access the user will have to all types of resource:

  • Rd - sets all items to read access
  • Upd - sets all items to update access
  • No - denies access for all items
Master Flag

Check this to enable the user to access the main ESMAC screens. If unchecked, the user will only be able to view summary server information and environment variables.

JES - IMS

Choose what type of access this user can have to a resource of this type:

  • Rd - sets the item to read access
  • Upd - sets the item to update access
  • No - sets the item to no access
Dump Display, Table

Click this to create and view a dump of the ACEE.

Parent topic: Details of an Active Resource


DCT Entry (dct_name)

Use this page to view information about the DCT named dct_name, selected from the DCT (Active) page. You can also view a dump of the DCT.

This page mainly provides information about the DCT. To set values for the DCT, use the CICS DCT page.

Apply

Click this to save changes you have made to the page and refresh the page.

DCT

Shows the name of this DCT. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the DCT have been saved and the DCT updated. Click Refresh to remove this message.

Resource Keys
all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys.
  • Off - disables all the resource keys.
1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Dump Display, Table

Click this to create and view a dump of the DCT.

Parent topic: Details of an Active Resource


FCT Entry (fct_name)

Use this page to view information about the FCT named fct_name, selected from the FCT (Active) page. You can view information about the FCT, and change the status of the FCT.

This page mainly provides information about the FCT. To set values for the FCT, use the CICS FCT page.

Apply

Click this to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the FCT.

FCT

Shows the name of this FCT. If you click Apply, the message "Update complete" is also displayed when any changes you have made to the FCT have been saved and the FCT updated. Click Refresh to remove this message.

Dataset Name

Shows the data set name for this file as used on the mainframe.

Status

Shows information about the current state of the file. This includes not only the current setting of Status as shown on the CICS FCT page and the CICS FCT - fct_name (grp_name) page, but also the Access fields and a subset of the Set fields.

The first item of information is the open/closed status. This is a transient state a transient state controlled by the system. Possible values are:

  • Open
  • Closed
  • Opening
  • Closing
  • CloseRequest - a request to close the file has been issued by an application
Enabled/Disabled/Unenabled

Indicates whether the file is currently accessible to transactions:

  • Enabled - the file is currently accessible to transactions.
  • Disabled - the file is not currently accessible to transactions. A disabled file returns the reference "DISABLED". This can cause problems for some applications; if this is true for your application, set Unenabled instead.
  • Unenabled - the file is not currently accessible to transactions. An unenabled file returns a reference "NOTOPEN", which can be handled by those applications that cannot handle a "DISABLED" reference.

You can change this setting on this page.

Disabling

Yes indicates that the file is currently being disabled. Disabling is a transient state controlled by the system.

Start Empty

Yes indicates that the current contents of the file are deleted at system startup.

Recoverable

Yes indicates that the file is a protected resource, changes to which can be backed out.

The file must be accessed through a Fileshare server.

Forward Recoverable

Yes indicates that journals are used to record changes to the file to enable forward recovery.

The file must be accessed through a Fileshare server.

Readable

If checked, indicates that users can read records from the file. You can change this setting.

Addable

If checked, indicates that users can add records to the file. You can change this setting.

Browsable

If checked, indicates that users can browse the file. You can change this setting.

Deletable

If checked, indicates that users can delete records from the file. You can change this setting.

Updatable

If checked, indicates that users can update records in the file. You can change this setting.

Exclusive

If checked, indicates that the file cannot be read by other transactions while an update is in progress. You can change this setting.

Type

Shows the file type. This can be one of:

  • KSDS Variable ASCII - Key sequence data set
  • ESDS - Entry sequence data set
  • RRDS - Relative record data set
  • Alternate to fct_name type - Alternate index. fct_name tells you the FCT for which this is an alternate index, and type describes the type of file represented by fct_name.
  • Undefined - Remote file
Record

Shows the maximum and minimum lengths possible for a record.

Key

Shows the length and starting position of the key.

Resource Group

Shows which resource group this FCT belongs to.

Use Count

Shows the number of times this FCT has been used.

Dump Display, Table

Click this to create and view a dump of this FCT.

Parent topic: Details of an Active Resource


JCT Entry (jct_name)

Use this page to view information about the JCT named jct_name, selected from the JCT (Active) page. You can also display a dump of the JCT.

This page mainly provides information about the JCT. To set values for the JCT, use the CICS JCT page.

Apply

Click this to save changes you have made to the page and refresh the page.

JCT

Shows the name of this JCT. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the JCT have been saved and the JCT updated. Click Refresh to remove this message.

Dump Display, Table

Click this to create and view a dump of the JCT.

Parent topic: Details of an Active Resource


PCT Entry (pct_name)

Use this page to view information about the PCT named pct_name, selected from the PCT (Active) page. You can also change the status of the PCT, and change various parameters of the PCT.

This page mainly provides information about the PCT. To set values for the PCT, use the CICS PCT page.

Click Apply to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the PCT.

PCT

Shows the name of this PCT. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the PCT have been saved and the PCT updated. Click Refresh to remove this message.

Program Name

Shows the program name of a local program to be run when this transaction is invoked.

Status
Shows the current settings that apply to this PCT. You can change any of the settings.
Enabled
Click this to enable the program.
Disabled
Click this to disable the program.
UC Translation

Check this to have the transaction program translate input into upper case.

Screen Default

Click this to have the transaction program use the default screen size (as defined in the Typeterm entry).

Screen Alternate

Click this to have the transaction program use the alternate screen size (as defined in the Typeterm entry).

DTB Backout

Click this to indicate that if a transaction program using intersystem communication abends at a critical moment during syncpoint or abend processing, the effects of the transaction are backed out using ROLLBACK. To use this option, files used by the transaction program must have Backward Recovery checked on the CICS FCT page.

DTB Commit

Click this to indicate that if a transaction program using intersystem communication abends at a critical moment during syncpoint or abend processing, any changes are committed.

DTB Wait

Click this to indicate that if a transaction program using intersystem communication abends at a critical moment during syncpoint or abend processing, critical resources are locked until the session has recovered, and are then backed out or committed in step with the remote system.

Dump on Abend

Check this to indicate that a program dump is to be created if the transaction program abends.

Type

Indicates whether the program is local or remote. If the program is remote, the system and transaction IDs are also displayed.

Transaction
TWA Size
Shows the size of the transaction program's Transaction Working Area (TWA) in bytes.
Input Timeout

The maximum time in seconds allowed for operator response to an explicit CICS RECEIVE, WEB OPEN, WEB SEND, WEB RECEIVE, or WEB CONVERSE command before this transaction is abended. A value of 0 indicates that there is no timeout, and the system will wait indefinitely for a response.

Runaway Timeout

The maximum continuous period of time in seconds that the region will allow a transaction to run without making a CICS, EZASOKET or MQSeries API call. When this time is exceeded, the transaction is abended. A value of 0 indicates that there is no timeout.

Deadlock Timeout

Shows the deadlock timeout used for task processing. This is the period after which a suspended task is terminated. A zero value means that no deadlock timeout is used.

Transaction Threshold

Specify the maximum length of time in seconds that a transaction can run before a message is logged to the console to indicate that it has exceeded its threshold. A value of 0 indicates that there is no threshold.

Tracing

Indicates the type of tracing set for this program. You can also change the type of tracing by clicking one of the buttons:

  • Standard - standard tracing is performed
  • Suppress - no tracing is performed
  • Special - special tracing is performed
Use Count

Shows the number of times this PCT has been used.

Dump Display, Table

Click this to create and view a dump of the DCT.

Parent topic: Details of an Active Resource


PPT Entry (ppt_name)

Use this page to view information about the PPT named ppt_name, selected from the PPT (Active) page. You can also change the status of the PPT, and change various parameters of the PPT.

This page mainly provides information about the PPT. To set values for the PPT, use the CICS PPT page.

Apply

Click this to save changes you have made to the page and refresh the page.

PPT

Shows the name of this PPT. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the PPT have been saved and the PPT updated. Click Refresh to remove this message.

Load Module

Shows the location and name of the executable file in use. You see an entry in this field only after the executable file has been used.

Status

Shows the current settings that apply to this PPT. You can change any of the settings.

Enabled

Click this to enable the PPT.

Disabled

Click this to disable the PPT.

DPL API Subset

Check this to limit the program to the Distributed Program Link API subset of commands; there is no terminal control, BMS, and so on.

CEDF Enabled

Check this to allow the use of the CICS Execution Diagnostic Facility, which enables debugging at the CICS command level.

Resident

Check this to indicate that the program resides in the application server's program cache after it has been loaded.

COBOL

Click this to indicate that the program language is COBOL.

PL1

Click this to indicate that the program language is PL/I.

C

Click this to indicate that the program language is C.

Assembler

Click this to indicate that the program language is Assembler.

WS Integrity

Check this to indicate that load requests are ignored if the program is already in storage. Leave unchecked to indicate that a fresh copy of the program is loaded every time a load request for the program is issued.

Type

Shows whether the PPT is associated with a program or data.

Size

Shows the size of the module and the minimum size of the Commarea.

Counts

Shows:

  • Resident - the number of programs resident in the server's program cache.
  • Hold Count - the number of outstanding LOAD HOLD commands that have not been countered by a RELEASE.
  • Index - the number of times a LOAD SET ENTRY() has been executed.
  • In Use Count - the number of outstanding LOAD commands that have not been countered by an exit from current units of work.
  • Reference Count
Dump Display, Table

Click this to create and view a dump of the DCT.

Parent topic: Details of an Active Resource


SysC Entry (sysc_name)

Use this page to view information about the SysC named sysc_name, selected from the SysC (Active) page. You can also display a dump of the SysC. A SysC is a definition of a CCI system connection.

This page mainly provides information about the SysC. To set values for the SysC, use the CICS SysC page.

Apply

Click this to save changes you have made to the page and refresh the page.

SysC

Shows the name of this SysC. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the SysC have been saved and the SysC updated. Click Refresh to remove this message.

Dump Display, Table

Click this to create and view a dump of the SysC.

Parent topic: Details of an Active Resource


T-TYPE Entry (ttype_name)

Use this page to view information about the T-type named ttype_name, selected from the TTYPE (Active) page. You can also view a dump of the T-type.

This page mainly provides information about the T-type. To set values for the T-type, use the CICS T-type page.

Apply

Click this to save changes you have made to the page and refresh the page.

T-Type

Shows the name of this T-type. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the T-type have been saved and the T-type updated. Click Refresh to remove this message.

Dump Display, Table

Click this to create and view a dump of the T-type.

Parent topic: Details of an Active Resource


XAT

Use this page to view the XATs (XA-compliant database tables) defined for the server.

Switch Module

The location of the executable file (.dll on Windows, .sl on HP-UX PA-RISC, .so on other UNIX platforms) that contains the entry point that returns the xa_switch_t structure to the enterprise server.

Open String

The string that is passed to the resource manager on the xa_open() call. An entry in this field usually contains at least the database name, and the user ID and password for connecting to the database. The contents of this string are database-specific.

For DB2, the contents are documented in IBM's DB2 Administration Guide; for additional information see the Application Programmer's Guide.

For Oracle, see the Oracle Application Developer's Guide - Fundamentals.

Where the resource manager supports dynamic registration, and the database vendor requires the name of the module that provides the ax_reg function, you should specify casaxlib.

Close String

The string that is passed to the resource manager on the xa_close() call. To find out whether or not you need to supply Close string, see your database vendor's documentation.

Enabled

Whether this XAT resource is enabled or disabled.

Parent topic: Details of an Active Resource


TST Entry (tst_name)

Use this page to view information about the TST named tst_name, selected from the TST (Active) page. You can also view a dump of the TST.

This page mainly provides information about the TST. To set values for the TST, use the CICS TST page.

Apply

Click this to save changes you have made to the page and refresh the page.

TST

Shows the name of this TST. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the TST have been saved and the TST updated. Click Refresh to remove this message.

Dump Display, Table

Click this to create and view a dump of the TST.

Parent topic: Details of an Active Resource


URIMAP Entry (urimap_name)

Use this page to view information and set values for the URIMAP named urimap_name, selected from the URIMAP (Active) page.

Click Apply to save changes you have made to the page and refresh the page.

URIMAP
The name of this URIMAP definition. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the URIMAP have been saved and the entry updated. Click Refresh to remove this message.
Usage
Specifies whether this URIMAP definition is for:
  • CICS as an HTTP server
  • CICS as an HTTP client
Status
Specifies whether this URIMAP definition is installed in an enabled or disabled state.
Analyzer
Indicates whether an analyzer program is used in processing the HTTP request.
Scheme
The scheme component of the URI.
Redirect Type
Specifies the type of redirection for requests that match this URIMAP definition, either NONE, TEMPORARY or PERMANENT.
TCPIPService
The name of a TCPIPService resource definition that defines an inbound port.
Host
The host name, or IPv4 or IPv6 address, of the URI.
Path
The path component of the URI.
Port
The number of the port used by the user application when it communicates with a server.
Transaction
The name of an alias transaction used either to run the user application that composes the HTTP response, or to start the pipeline.
Converter
The name of a converter program used to convert (or perform other processing) on the request and response.
Program
The name of the user application program that composes the HTTP response.
Pipeline
Not supported for this release.
Web Service
Not supported for this release.
User Id
Not supported for this release.
Certificate
The label of the X.509 certificate that is used as the SSL client certificate during the SSL handshake.
Ciphers
A string of up to 56 hexadecimal digits that is interpreted as a list of up to 28 2-digit cipher suite codes.
Authenticate
Specifies whether to send basic authentication information in the HTTP response to a client request.
Template Name
Not supported for this release.
HFS File
Not supported for this release.
Media Type
Not supported for this release.
Character Set
Not supported for this release.
Host Codepage
Not supported for this release.
Location
Not supported for this release.
Parent topic: Details of an Active Resource


TCPIPService Entry (tcpipsv_name)

Use this page to view information about the TCPIPService named tcpipsv_name, selected from the TCPIPSv (Active) page. You can also display a dump of the service.

This page mainly provides information about the TCPIPService. To set values for it, use the CICS TCPIPService page.

Click Apply to save changes you have made to the page and refresh the page.

TCPIPService
The name of this TCPIPService.
Status
The initial status of the service after installation, either OPEN if CICS is to begin listening for this TCPIPService after installation, or CLOSE if not.
Port
The number of the port on which CICS listens for incoming client requests.
Protocol
The application level protocol used on the TCP/IP port.
SSL Type
Indicates whether the TCPIPService is to use the secure sockets layer (SSL) for encryption and authentication.
Transaction
The ID of the CICS transaction to process new requests that this service receives.
Authenticate
The authentication and identification scheme used for inbound TCP/IP connections for the HTTP, IPIC, USER and IIOP protocols.
Backlog
Not supported for this release.
Max Data Length
Specifies the maximum length of data that may be received by CICS as an HTTP server. This value must be between 3 and 524,288 kilobytes.
URM
The name of a user-replaceable program that this TCPIPService invokes.
Privacy
The level of SSL encryption required for inbound connections.
Cipher
A list of cipher suite codes.
Host
Specifies the 116-character IPv4 or IPv6 address or host name on which this TCPIPSERVICE will listen for incoming connections.
IP Address
The IPv4 address on which this TCPIPService will listen for incoming connections.
Socket Close
How long CICS waits before closing the socket.
DNS Group
Not supported for this release.
DNS Status
The current state of Workload Manager/Domain Name System (DNS) registration of this service.
GRP Critical
Not supported for this release.
Certificate
The SSL client certificate authentication used to authenticate and identify the client.
Attach Security
Not supported for this release.
TSQ Prefix
A code to identify items in the temporary storage queue (TSQ).

Click Table to create and view a table of dump information for this service.

Parent topic: Details of an Active Resource


DOCTEMPLATE Entry (doctemplate_name)

Use this page to view information about the DOCTEMPLATE called doctemplate_name, selected from the DOCTEMPLATE (Active) page. You can also display a dump of the loaded DOCTEMPLATE in memory.

DOCTEMPLATE
The name of this template.
Append CR/LF
Indicates whether CICS deletes trailing blanks from, and appends carriage return/line feed to, each logical record of the template.
Type
The format of the template contents, either BINARY, EBCDIC or ASCII.
Template Type
The type for the source of the template, namely one of the following types.
Template Name
The name by which the template is known to application programs that use it.
File
The name of the CICS file which contains the template.
TS Queue
The name of the temporary storage queue containing the template.
TD Queue
The name of the transient storage queue containing the template.
Program
The name, of the CICS program that contains the template.
Exit Program
The name of the exit program that generates this template.
DD Name
The name of the MVS partitioned data set (PDS) containing the template. If you enter a value for Member Name but no DD Name, it defaults to "DFHHTML".
Member Name
The name of the member in the MVS partitioned data set containing the template.
HFS File
The name of the z/OS UNIX System Services file containing the template.

Click Table to create and view a table of dump information for this resource.

Parent topic: Details of an Active Resource


by Group

  • CICS Resource Groups
  • Startup
  • SIT
Parent topic: Resources


CICS Resource Groups

Use this page to view the CICS resource groups available on this server.

New

Click this to create a new CICS resource group.

Details

Click this to view detailed information for the CICS resource group.

The rest of the information in this row shows:

  • The name of the CICS resource group.
  • A description of the CICS resource group.
  • CICS Resource Group
  • Create a New CICS Group
  • View and Edit CICS Group group_name
Parent topic: by Group


CICS Resource Group

Use this page to view the resources within the resource group name.

Details

Click this to display detailed information for the CICS resource.

The rest of the information in this row shows:

  • The name of the resource.
  • The type of resource, such as FCT or PPT.
  • A short description of the resource.
New

Click one of the buttons to create a new resource.

Parent topic: CICS Resource Groups


Create a New CICS Group

Use this page to create a new resource group.

Group List

Click this to view the group list for this group. The group list page will be empty until you have clicked Add.

Add

Click this to save changes you have made to the page, refresh the page and add the new resource group to the list of groups. The name of the button changes to Apply.

Name

Specify a name for this resource group.

Description

Specify a description for this resource group.

Parent topic: CICS Resource Groups


View and Edit CICS Group group_name

Use this page to view a resource group and to change its description.

Group List

Click this to view the group list for this group.

Apply

Click this to save changes you have made to the page and refresh the page.

Name

Shows the name of this resource group.

Description

Specify a description for this resource group.

Parent topic: CICS Resource Groups


Startup

Use this page to view the startup lists available on this server.

Details

Click this to display detailed information for the startup list.

The rest of the information in this row shows:

  • The name of the startup list
  • A short description of the startup list
  • Create a New CICS Startup List
  • View and Edit a CICS Startup List
  • CICS Startup List list_name or CICS Defined resource
Parent topic: by Group


Create a New CICS Startup List

Use this page to create a new startup list.

Add

Click this to save changes you have made to the page and refresh the page. The button changes to Apply.

Name

Specify a name for this startup list.

Description

Specify a short description of the startup list.

Entry Count

Shows the number of resource groups in this startup list.

Production

Check this to indicate that this is a production startup list. Leave this unchecked to indicate that this is a development startup list.

01

Specify the name of the first resource group in the startup list.

Parent topic: Startup


View and Edit a CICS Startup List

Use this page to view the startup list name or to edit the values on this page. This page is displayed either when you select a startup list from the CICS Startup Lists page or when you are creating a startup list and have just added the first resource group to it. You can edit the values on this page and add new resource groups only if you have the necessary permission.

Apply

Click this to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the startup list.

Name

Shows the name of the startup list.

Description

Specify a short description of the startup list.

Entry Count

Shows the number of resource groups in this startup list.

Production

Check this to indicate that this is a production startup list. leave this unchecked to indicate that this is a development startup list.

01 - nn

Lists the resource groups in the startup list.

A startup list can reference up to 64 resource groups.

To add a resource group, click in the next empty field in the list, and enter the name.

You can change the order of the resource groups in the startup list. Use Down arrow button to move a resource down the list. Use Up arrow button to move a resource up the list. Delete an entry in the resource list by clicking Delete button.

Delete

Click this to delete this startup list. You see this button only if you have permission to edit the startup list.

Copy

Click this to create a new startup list. The values on the current page will be used as the basis for the values in the new startup list.

Dump

Click this to create and view display a dump of the startup list information.

Parent topic: Startup


CICS Startup List list_name or CICS Defined resource

Use this page to view resources of a particular type.

If you displayed this page by clicking on one of the buttons displayed when you click Resources, by Start L, this page lists the resources of a particular type available to the current startup list.

If you displayed this page by clicking on one of the buttons displayed when you click Resources, by Type, this page lists the resources of a particular type available to the current server.

Details

Click this to view detailed information for the resource.

The rest of the information in this row shows:

  • The name of the resource.
  • The type of resource.
  • The group to which the resource belongs.
  • A short description of the resource.
New

Click one of the buttons to create a new resource.

Parent topic: Startup
Parent topic: by Type


SIT

Use this page to view the list of system initialization tables (SITs) defined for an enterprise server.

New

Click this to create a new SIT.

Details

Click this to view detailed information for the SIT.

The rest of the information in this row shows:

  • The name of the SIT.
  • The startup list used by the SIT.
  • A short description of the SIT.
  • Create a New CICS SIT
  • CICS SIT Details
Parent topic: by Group


Create a New CICS SIT

Use this page to create a new SIT.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new SIT.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Name

Shows the name of the SIT.

Description

Specify a short description of the SIT. The SIT description can contain the characters A-Z, 0-9, #, @, and $.

Startup List

Choose the startup list that you want to associate with this SIT from the dropdown list. The startup list determines which resources are loaded when the server is initialized.

Work Area

Specify the size of the region's common work area (CWA) in bytes in the range 0 through 32767. This area is shared among applications running in the region (enterprise server).

SysID

Specify the system ID of the region (enterprise server). (This is the name by which it is known to other regions.)

Initial Tran ID

Specify the ID of an initial transaction that runs on every terminal when it logs on to the region.

Auto Install Exit

Specify the name of the program to be used to autoinstall terminals. Choose from:

  • DFHZATDX - the autoinstall program supplied with MSS. This is the default value.
  • user-specified - the name of your autoinstall exit program. Up to 8 characters from 0 through 9, A through Z, @, # and $. The first character must not be numeric.
Date Format

Choose the display format used to display the date. This is used in conjunction with the FULLDATE (for four-digit years) or DATE (for two-digit years) operands of the EXEC CICS FORMATTIME command. This setting only determines the order of day, month, and year; it does not prevent four digits from being displayed.

3270 Print

Check this to indicate that the region supports a printer.

3270 SNA Simulate end-bracket

Check this if you want MSS to simulate SNA end-of-transaction keyboard unlock. You might want to do this if you have migrated applications that were accessed on the mainframe from SNA devices and are now using TN3270 clients to access them. It is an alternative to specifying the free keyboard bit in the CTLCHAR operand of the SEND 3270 CICS command.

Remote 3270

Check this to indicate that when a remote CICS region handles a START request shipped to it by this CICS region, and the terminal that should be started is not defined on the remote system, the remote region should assume that the terminal is defined on the originating system and should start a terminal anyway. If you leave this unchecked, the remote system returns a TERMIDERR to the originating region.

Separators

Specify Date for the character used to separate the day, month and year components of the date. You can specify any displayable character.

Specify Time for the character used to separate the hours, minutes and seconds components of the time. You can specify any displayable character.

Addressing
Specify the format in which pointers are stored.

Native: pointers are stored in the format used by the operating system.

24: pointers are stored in a 24-bit format. This format is compatible with "below-the-line" storage on the mainframe, in which the top eight bits of the pointer are masked off when the address of a linkage item is set from the pointer. This means that the top eight bits can be manipulated directly by the user's code.

31: pointers are stored in a 31-bit format. This format is compatible with "above-the-line" storage on the mainframe, in which the top bit of the pointer is masked off when the address of a linkage item is set from the pointer. This means that the top bit can be manipulated directly by the user's code.

TCP Connect: Yes, Port

Not used.

ID Timeout

Specify the time in minutes that the system will allow an ESMAC or TN3270 client session to remain idle before logging off the user. A value of 0 indicates that there is no timeout. You can override this value at runtime by changing the ID Timeout on the ESMAC Control screen.

IBM Client

Check Yes to indicate that an IBM Universal Clients gateway is to be established when the region starts up.

Use Port to specify the TCP/IP port number to use for the Universal Clients gateway. This must match the TCP/IP port number you specify in the Universal Clients configuration file except that if you use the defaults, the value in the configuration file is 0 whereas the value here is 1435.

Use Count to specify the number of sessions you want allocated to servicing inbound requests per connection, where connection corresponds to a client machine.

Input Timeout

Specify the maximum time in seconds allowed for operator response to an explicit CICS RECEIVE command before the transaction is abended. A value of 0 indicates that there is no timeout. You can override this value at runtime by changing the Input Timeout on the ESMAC Control screen. You can also override this value for an individual transaction through the relevant Program Control Table entry.

Local Trace Entry Count (MFCS)

Specify the number of entries the local trace table for service execution processes can hold before it wraps back to the start. A value of 0 (zero) means that no local trace table is allocated. Each service execution process has its own local trace table. Each entry is 24 bytes long.

The default is the value specified in Local Trace Size on the Server > Properties > Diagnostics page in ES Admin. If you specify a value here it overrides that value.

Runaway Timeout

Specify the maximum continuous period of time in seconds that the region will allow a transaction to run without making a CICS, EZASOKET or MQSeries API call. When this time is exceeded, the transaction is abended. A value of 0 indicates that there is no timeout. You can override this value at runtime by changing the Runaway Timeout on the ESMAC Control screen. You can also override this value for an individual transaction through the relevant Program Control Table entry.

Local Trace Entry Count (AUX)

Specify the number of entries the local trace table for auxiliary processes can hold before it wraps back to the start. A value of 0 (zero) means that no local trace table is allocated. Auxiliary processes include processes that handle journal control, extra-partition transient data, etc. Each auxiliary process has its own local trace table. Each entry is 24 bytes long.

The default is the value specified in Local Trace Size on the Server > Properties > Diagnostics page in ES Admin. If you specify a value here it overrides that value.

Deadlock Timeout

Specify the maximum time in seconds that the region will permit an application to wait for a resource that has been locked by another process. A value of 0 indicates that there is no timeout. You can override this value at runtime by changing the Deadlock Timeout on the ESMAC Control screen. You can also override this value for an individual transaction through the relevant Program Control Table entry.

Transaction Threshold

Specify the maximum length of time in seconds that a transaction can run before a message is logged to the console to indicate that it has exceeded its threshold. A value of 0 indicates that there is no threshold.

The Transaction Threshold value can be overridden using the Transaction Threshold field of a PCT entry.

IBM MQ

Check this to enable support for IBM MQSeries®.

The MQ Connection should be set either in XA Resource Manager or the System Initialization Table (SIT). Do not set it in both or you will have two connections between the ES region and the MQ Queue Manager. Only one is required.

Q Manager

Specify the name of the IBM MQSeries® queue manager. Can be up to 48 characters.

IBM MQ CKTI

Check this to enable the transaction CKTI, which monitors the IBM MQSeries® initiation queue.

Initiation Q

Specify the name of the IBM MQSeries® initiation queue. Can be up to 48 characters.

Print Destination

Specify the printer destination, up to 14 characters in length. You must check 3270 Print before you specify a printer destination.

Program Lists

Use Post Initialization to specify a program list table (PLT) entry that specifies the initialization programs to be run when the region is started. If you leave this field blank then no special processing is done when the region is started.

Use Shut Down to specify a program list table (PLT) entry that specifies the shutdown programs to be run when the region is stopped. If you leave this field blank then no special processing is done when the region is stopped.

Fileshare

Check this to create a dedicated Fileshare server process as part of region startup.

Fileshare User

Specify the user ID to be used by the region to log on to all Fileshare servers that MSS is configured to use. Can be up to 20 characters. You should specify a user ID only if Fileshare security is enabled. If you specify a user ID, you must also specify a password in Password. The user ID and password combination must correspond to an entry in the password file of each Fileshare server the region is to access.

Password

Specify the 20-character password used in conjunction with User ID to log on to all Fileshare servers that MSS is configured to use. There are two password fields; you need to enter the password in both fields, and the two entries must match. Can be up to 20 characters.

Ext. Shutdown

Choose the type of external shutdown that you want. An external shutdown is a shutdown of the server initiated by you clicking Shutdown on the Control page, Stop Server on the Enterprise Server Administration Server Details page, or issuing a casstop command. You can choose from:

  • Allowed: no special privileges are required
  • Logon: a successful logon must be made first
  • None: no external shutdown is allowed
Note: If you choose Logon, you cannot shut down the server by clicking Stop Server on the Enterprise Server Administration Server Details page. You must use casstop and must supply an ESMAC user ID and password.
Ext. Shutdown, Security Key

Specify a security key number. MSS checks this against the shutdown security key specified when you shut down the region. You need to specify a security key number only if you choose Logon in External Shutdown.

CICS Release

Choose the version of CICS that MSS is emulating. This is the number returned by an EXEC CICS INQUIRE SYSTEM RELEASE () command.

Program

Check this to have MSS reload programs each time they are invoked. This applies only to programs that are not marked resident and have not been loaded with the hold attribute.

Development SIT

Check this to indicate that this is a development SIT. The effect of this is:

  • If you have defined a group with the same name as the SIT, the group is automatically added to the startup list
  • Security is turned off even if the group has security turned on
Terminal

Check this to have MSS wait on each terminal control or BMS SEND operation until it receives a response. If you leave the box unchecked (the default) MSS does not wait on each SEND, thus enabling terminal control and send operations to be buffered, which improves performance.

Commarea

Specify the minimum amount of storage to be allocated to the communications area (COMMAREA) to allow MSS to behave like mainframe CICS. The size is in the range 0 through 32767. The effect of this is that when a program is passed a COMMAREA smaller than the COMMAREA defined in the program, the passed COMMAREA is automatically extended in length to fill the defined space.

Defer Install

Choose the number of PCT groups whose loading you want to defer.

If you choose None, all PCT entries are loaded into memory when the region starts up. This is the default.

If you choose All groups, none of the PCT entries are loaded into memory when the region starts up.

If you choose one of the other values, Last 63 groups, Last 62 groups and so on, the PCT entries in those groups are not loaded into memory when the region starts up. For example, if you choose Last 3 groups, the last three groups in the startup list's precedence order are not loaded into memory when the region starts up.

Dump On, Abend

Check this to indicate that MSS should produce a dump if an abend occurs in any of your transaction programs. If you check this field, then you can control whether or not a dump is produced for an individual program by checking or unchecking Dump on ABEND on the PCT page. If you leave this field unchecked, MSS ignores the setting of Dump on ABEND on the PCT page.

Dump On, System Abend

Check this to indicate that MSS should produce a dump if an abend occurs in its own code.

Aux Trace

Check this to indicate that trace records are to be written to a file. You should do this only if you have adequate disk space available, since the file can become very big very quickly. Writing out to a file also degrades performance.

Cold Start

Check this to indicate that the auxiliary trace and dump file is to be deleted at region startup.

Trace Points
all

Choose a setting to apply to all the trace points:

  • On - enables all trace points.
  • Off - disables all trace points.
Note: When you set all the trace points on at once, the trace points CCI, fh and fh-enable are unaffected. This is because these trace points should be used only when advised by Micro Foucs.
Server
dmp

Check this to indicate that MSS is to trace its dump control component.

tcp

Check this to indicate that MSS is to trace its terminal control component.

tmp

Check this to indicate that MSS is to trace its table management component.

exits

Check this to indicate that MSS is to trace the user exits.

fh-enable

Do not check this unless advised by Micro Focus.

msg

Check this to indicate that MSS is to trace its messages component.

fh

Do not check this unless advised by Micro Focus.

jcp

Check this to indicate that MSS is to trace its journal control component.

scp

Check this to indicate that MSS is to trace its storage control component.

CICS
api

Check this to indicate that MSS is to trace the CICS API calls.

icp

Check this to indicate that MSS is to trace its interval control component.

ts-td

Check this to indicate that MSS is to trace its temporary storage/transient data (TS/TD) component.

fcp

Check this to indicate that MSS is to trace its file control component.

kcp

Check this to indicate that MSS is to trace its task control component.

user

Check this to enable user trace.

Communications
cci

Do not check this unless advised by Micro Focus.

comms

Check this to indicate that MSS is to trace its communications component.

Temp. Storage

Check Cold Start to indicate that MSS should reset temporary storage queues at region startup.

Specify a Fileshare server ID for non-recoverable temporary storage queues.

Path (nr)

Specify the path for non-recoverable temporary storage queues.

Recoverable (recoverable temporary storage queues)

Check Cold Start to indicate that MSS should reset temporary storage queues at region startup.

Specify a Fileshare server ID for recoverable temporary storage queues.

Path (rc)

Specify the path for recoverable temporary storage queues.

Transient Data

Check Cold Start to indicate that MSS should reset transient data queues at region startup.

Specify a Fileshare server ID for non-recoverable transient data queues.

Check Require Def. to indicate that a transaction program executing in this region can write to a transient data queue only if it has been defined in the destination control table (DCT). If this option is not checked, when a program attempts to write to a TDQ that has not been defined in the DCT, CICS will create a non-recoverable intra-partition TDQ that has no transaction associated with it. This may result in unexpected program and/or system behaviour if the intention was to write to a pre-defined TDQ of a similar name. We recommend that this option is always checked.

Path (rc)

Specify the path for recoverable temporary storage queues.

Recoverable (recoverable transient data queues)

Check Cold Start to indicate that MSS should reset transient data queues at region startup.

Specify a Fileshare server ID for recoverable transient data queues.

Path (nr)

Specify the path of for non-recoverable temporary storage queues.

Basic Mapping Page Commands

Use Retrieve to specify the character string that BMS control is to interpret as the BMS paging command RETRIEVE.

Use Chain to specify the character string that BMS control is to interpret as the BMS paging command CHAIN

Use Purge to specify the character string that BMS control is to interpret as the BMS paging command PURGE

Use Copy to specify the character string that BMS control is to interpret as the BMS paging command COPY

Single Key

For each key from PF1 through PF24 and PA1 through PA3, specify a character string on the PC that is to equate to a BMS paging command.

Parent topic: SIT


CICS SIT Details

Use this page to view the details for the System Initialization Table (SIT) named sit_name. If you have the required permissions, you can also:

  • Edit the configurable settings of the current SIT
  • Delete the current SIT
  • Create a new SIT, based on the settings in this SIT

Click Apply to save changes you make to the page. This button is displayed only if you have permission to edit the SIT.

Name

Shows the name of the SIT.

Description

Specify a short description of the SIT. The SIT description can contain the characters A-Z, 0-9, #, @, and $.

Startup List

Choose the startup list that you want to associate with this SIT from the dropdown list. The startup list determines which resources are loaded when the server is initialized.

Work Area

Specify the size of the region's common work area (CWA) in bytes in the range 0 through 32767. This area is shared among applications running in the region (enterprise server).

SysID

Specify the system ID of the region (enterprise server). (This is the name by which it is known to other regions.)

Initial Tran ID

Specify the ID of an initial transaction that runs on every terminal when it logs on to the region.

Auto Install Exit

Specify the name of the program to be used to autoinstall terminals. Choose from:

  • DFHZATDX - the autoinstall program supplied with MSS. This is the default value.
  • user-specified - the name of your autoinstall exit program. Up to 8 characters from 0 through 9, A through Z, @, # and $. The first character must not be numeric.
Date Format

Choose the display format used to display the date. This is used in conjunction with the FULLDATE (for four-digit years) or DATE (for two-digit years) operands of the EXEC CICS FORMATTIME command. This setting only determines the order of day, month, and year; it does not prevent four digits from being displayed.

3270 Print

Check this to indicate that the region supports a printer.

3270 SNA Simulate end-bracket

Check this if you want MSS to simulate SNA end-of-transaction keyboard unlock. You might want to do this if you have migrated applications that were accessed on the mainframe from SNA devices and are now using TN3270 clients to access them. It is an alternative to specifying the free keyboard bit in the CTLCHAR operand of the SEND 3270 CICS command.

Remote 3270

Check this to indicate that when a remote CICS region handles a START request shipped to it by this CICS region, and the terminal that should be started is not defined on the remote system, the remote region should assume that the terminal is defined on the originating system and should start a terminal anyway. If you leave this unchecked, the remote system returns a TERMIDERR to the originating region.

Separators

Specify Date for the character used to separate the day, month and year components of the date. You can specify any displayable character.

Specify Time for the character used to separate the hours, minutes and seconds components of the time. You can specify any displayable character.

Addressing
Specify the format in which pointers are stored.

Native: pointers are stored in the format used by the operating system.

24: pointers are stored in a 24-bit format. This format is compatible with "below-the-line" storage on the mainframe, in which the top eight bits of the pointer are masked off when the address of a linkage item is set from the pointer. This means that the top eight bits can be manipulated directly by the user's code.

31: pointers are stored in a 31-bit format. This format is compatible with "above-the-line" storage on the mainframe, in which the top bit of the pointer is masked off when the address of a linkage item is set from the pointer. This means that the top bit can be manipulated directly by the user's code.

TCP Connect: Yes, Port

Not used.

ID Timeout

Specify the time in minutes that the system will allow an ESMAC or TN3270 client session to remain idle before logging off the user. A value of 0 indicates that there is no timeout. You can override this value at runtime by changing the ID Timeout on the ESMAC Control screen.

IBM Client

Check Yes to indicate that an IBM Universal Clients gateway is to be established when the region starts up.

Use Port to specify the TCP/IP port number to use for the Universal Clients gateway. This must match the TCP/IP port number you specify in the Universal Clients configuration file except that if you use the defaults, the value in the configuration file is 0 whereas the value here is 1435.

Use Count to specify the number of sessions you want allocated to servicing inbound requests per connection, where connection corresponds to a client machine.

Input Timeout

Specify the maximum time in seconds allowed for operator response to an explicit CICS RECEIVE command before the transaction is abended. A value of 0 indicates that there is no timeout. You can override this value at runtime by changing the Input Timeout on the ESMAC Control screen. You can also override this value for an individual transaction through the relevant Program Control Table entry.

Local Trace Entry Count (MFCS)

Specify the number of entries the local trace table for service execution processes can hold before it wraps back to the start. A value of 0 (zero) means that no local trace table is allocated. Each service execution process has its own local trace table. Each entry is 24 bytes long.

The default is the value specified in Local Trace Size on the Server > Properties > Diagnostics page in ES Admin. If you specify a value here it overrides that value.

Runaway Timeout

Specify the maximum continuous period of time in seconds that the region will allow a transaction to run without making a CICS, EZASOKET or MQSeries API call. When this time is exceeded, the transaction is abended. A value of 0 indicates that there is no timeout. You can override this value at runtime by changing the Runaway Timeout on the ESMAC Control screen. You can also override this value for an individual transaction through the relevant Program Control Table entry.

Local Trace Entry Count (AUX)

Specify the number of entries the local trace table for auxiliary processes can hold before it wraps back to the start. A value of 0 (zero) means that no local trace table is allocated. Auxiliary processes include processes that handle journal control, extra-partition transient data, etc. Each auxiliary process has its own local trace table. Each entry is 24 bytes long.

The default is the value specified in Local Trace Size on the Server > Properties > Diagnostics page in ES Admin. If you specify a value here it overrides that value.

Deadlock Timeout

Specify the maximum time in seconds that the region will permit an application to wait for a resource that has been locked by another process. A value of 0 indicates that there is no timeout. You can override this value at runtime by changing the Deadlock Timeout on the ESMAC Control screen. You can also override this value for an individual transaction through the relevant Program Control Table entry.

Transaction Threshold

Specify the maximum length of time in seconds that a transaction can run before a message is logged to the console to indicate that it has exceeded its threshold. A value of 0 indicates that there is no threshold.

The Transaction Threshold value can be overridden using the Transaction Threshold field of a PCT entry.

IBM MQ

Check this to enable support for IBM MQSeries®.

The MQ Connection should be set either in XA Resource Manager or the System Initialization Table (SIT). Do not set it in both or you will have two connections between the ES region and the MQ Queue Manager. Only one is required.

Q Manager

Specify the name of the IBM MQSeries® queue manager. Can be up to 48 characters.

IBM MQ CKTI

Check this to enable the transaction CKTI, which monitors the IBM MQSeries® initiation queue.

Initiation Q

Specify the name of the IBM MQSeries® initiation queue. Can be up to 48 characters.

Print Destination

Specify the printer destination, up to 14 characters in length. You must check 3270 Print before you specify a printer destination.

Program Lists

Use Post Initialization to specify a program list table (PLT) entry that specifies the initialization programs to be run when the region is started. If you leave this field blank then no special processing is done when the region is started.

Use Shut Down to specify a program list table (PLT) entry that specifies the shutdown programs to be run when the region is stopped. If you leave this field blank then no special processing is done when the region is stopped.

Fileshare

Check this to create a dedicated Fileshare server process as part of region startup.

Fileshare User

Specify the user ID to be used by the region to log on to all Fileshare servers that MSS is configured to use. Can be up to 20 characters. You should specify a user ID only if Fileshare security is enabled. If you specify a user ID, you must also specify a password in Password. The user ID and password combination must correspond to an entry in the password file of each Fileshare server the region is to access.

For more information about Fileshare security, see the chapter Security in the Fileshare Guide.

Password

Specify the 20-character password used in conjunction with User ID to log on to all Fileshare servers that MSS is configured to use. There are two password fields; you need to enter the password in both fields, and the two entries must match. Can be up to 20 characters.

Ext. Shutdown

Choose the type of external shutdown that you want. An external shutdown is a shutdown of the server initiated by you clicking Shutdown on the Control page, Stop Server on the Enterprise Server Administration Server Details page, or issuing a casstop command. You can choose from:

  • Allowed: no special privileges are required
  • Logon: a successful logon must be made first
  • None: no external shutdown is allowed
Note: If you choose Logon, you cannot shut down the server by clicking Stop Server on the Enterprise Server Administration Server Details page. You must use casstop and must supply an ESMAC user ID and password.
Ext. Shutdown, Security Key

Specify a security key number. MSS checks this against the shutdown security key specified when you shut down the region. You need to specify a security key number only if you choose Logon in External Shutdown.

CICS Release

Choose the version of CICS that MSS is emulating. This is the number returned by an EXEC CICS INQUIRE SYSTEM RELEASE () command.

Program

Check this to have MSS reload programs each time they are invoked. This applies only to programs that are not marked resident and have not been loaded with the hold attribute.

Development SIT

Check this to indicate that this is a development SIT. The effect of this is:

  • If you have defined a group with the same name as the SIT, the group is automatically added to the startup list
  • Security is turned off even if the group has security turned on
Terminal

Check this to have MSS wait on each terminal control or BMS SEND operation until it receives a response. If you leave the box unchecked (the default) MSS does not wait on each SEND, thus enabling terminal control and send operations to be buffered, which improves performance.

Commarea

Specify the minimum amount of storage to be allocated to the communications area (COMMAREA) to allow MSS to behave like mainframe CICS. The size is in the range 0 through 32767. The effect of this is that when a program is passed a COMMAREA smaller than the COMMAREA defined in the program, the passed COMMAREA is automatically extended in length to fill the defined space.

Defer Install

Choose the number of PCT groups whose loading you want to defer.

If you choose None, all PCT entries are loaded into memory when the region starts up. This is the default.

If you choose All groups, none of the PCT entries are loaded into memory when the region starts up.

If you choose one of the other values, Last 63 groups, Last 62 groups and so on, the PCT entries in those groups are not loaded into memory when the region starts up. For example, if you choose Last 3 groups, the last three groups in the startup list's precedence order are not loaded into memory when the region starts up.

Dump On, Abend

Check this to indicate that MSS should produce a dump if an abend occurs in any of your transaction programs. If you check this field, then you can control whether or not a dump is produced for an individual program by checking or unchecking Dump on ABEND on the PCT page. If you leave this field unchecked, MSS ignores the setting of Dump on ABEND on the PCT page.

Dump On, System Abend

Check this to indicate that MSS should produce a dump if an abend occurs in its own code.

Aux Trace

Check this to indicate that trace records are to be written to a file. You should do this only if you have adequate disk space available, since the file can become very big very quickly. Writing out to a file also degrades performance.

Cold Start

Check this to indicate that the auxiliary trace and dump file is to be deleted at region startup.

Trace Points
all

Choose a setting to apply to all the trace points:

  • On - enables all trace points.
  • Off - disables all trace points.
Note: When you set all the trace points on at once, the trace points CCI, fh and fh-enable are unaffected. This is because these trace points should be used only when advised by Micro Foucs.
Server
dmp

Check this to indicate that MSS is to trace its dump control component.

tcp

Check this to indicate that MSS is to trace its terminal control component.

tmp

Check this to indicate that MSS is to trace its table management component.

exits

Check this to indicate that MSS is to trace the user exits.

fh-enable

Do not check this unless advised by Micro Focus.

msg

Check this to indicate that MSS is to trace its messages component.

fh

Do not check this unless advised by Micro Focus.

jcp

Check this to indicate that MSS is to trace its journal control component.

scp

Check this to indicate that MSS is to trace its storage control component.

CICS
api

Check this to indicate that MSS is to trace the CICS API calls.

icp

Check this to indicate that MSS is to trace its interval control component.

ts-td

Check this to indicate that MSS is to trace its temporary storage/transient data (TS/TD) component.

fcp

Check this to indicate that MSS is to trace its file control component.

kcp

Check this to indicate that MSS is to trace its task control component.

user

Check this to enable user trace.

Communications
cci

Do not check this unless advised by Micro Focus.

common

Check this to indicate that MSS is to trace its communications component.

Temp. Storage

Check Cold Start to indicate that MSS should reset temporary storage queues at region startup.

Specify a Fileshare server ID for non-recoverable temporary storage queues.

Path (nr)

Specify the path for non-recoverable temporary storage queues.

Recoverable (recoverable temporary storage queues)

Check Cold Start to indicate that MSS should reset temporary storage queues at region startup.

Specify a Fileshare server ID for recoverable temporary storage queues.

Path (rc)

Specify the path for recoverable temporary storage queues.

Transient Data

Check Cold Start to indicate that MSS should reset transient data queues at region startup.

Specify a Fileshare server ID for non-recoverable transient data queues.

Check Require Def. to indicate that a transaction program executing in this region can write to a transient data queue only if it has been defined in the destination control table (DCT). If this option is not checked, when a program attempts to write to a TDQ that has not been defined in the DCT, CICS will create a non-recoverable intra-partition TDQ that has no transaction associated with it. This may result in unexpected program and/or system behaviour if the intention was to write to a pre-defined TDQ of a similar name. We recommend that this option is always checked.

Path (rc)

Specify the path for recoverable temporary storage queues.

Recoverable (recoverable transient data queues)

Check Cold Start to indicate that MSS should reset transient data queues at region startup.

Specify a Fileshare server ID for recoverable transient data queues.

Path (nr)

Specify the path of for non-recoverable temporary storage queues.

Basic Mapping Page Commands

Use Retrieve to specify the character string that BMS control is to interpret as the BMS paging command RETRIEVE.

Use Chain to specify the character string that BMS control is to interpret as the BMS paging command CHAIN

Use Purge to specify the character string that BMS control is to interpret as the BMS paging command PURGE

Use Copy to specify the character string that BMS control is to interpret as the BMS paging command COPY

Single Key

For each key from PF1 through PF24 and PA1 through PA3, specify a character string on the PC that is to equate to a BMS paging command.

Delete

Click this to delete the current SIT. You see this button only if you have editing permissions for the SIT.

Copy

Click this to create a new SIT, based on the entries in the current SIT.

Dump

Click this to create and view dump information for this SIT.

Parent topic: SIT


by StartL

  • DCTs for CICS Startup List name
  • FCTs for CICS Startup List name
  • JCTs for CICS Startup List name
  • PCTs for CICS Startup List name
  • PLTs for CICS Startup List name
  • PPTs for CICS Startup List name
  • Sys62s for CICS Startup List name
  • SysCs for CICS Startup List name
  • Terms for CICS Startup List name
  • TSTs for CICS Startup List name
  • T-Types for CICS Startup List name
  • URIMAPs for CICS Startup List name
  • TCPIPServices for CICS Startup List name
  • XATs for CICS Startup List name
  • DOCTEMPLATEs for CICS Startup List name
Parent topic: Resources


DCTs for CICS Startup List name

Use this page to view the DCTs defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details

Click this to see detailed information for the DCT resource group in this row.

The rest of the information in this row shows:

  • The name of the DCT.
  • The type of resource (in this case, a DCT).
  • The resource group this DCT belongs to.
  • The short description of the DCT.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


FCTs for CICS Startup List name

Use this page to view the FCTs defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details

Click this to see detailed information for the FCT.

The rest of the information in this row shows:

  • The name of the FCT.
  • The type of resource (in this case, an FCT).
  • The resource group this FCT belongs to.
  • The short description of the FCT.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


JCTs for CICS Startup List name

Use this page to view the JCTs defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details

Click this to see detailed information for the JCT in this row.

The rest of the information in this row shows:

  • The name of the JCT.
  • The type of resource (in this case, a JCT).
  • The resource group this JCT belongs to.
  • The short description of the JCT.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


PCTs for CICS Startup List name

Use this page to view the PCTs defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details

Click this to see detailed information for the PCT in this row.

The rest of the information in this row shows:

  • The name of the PCT.
  • The type of resource (in this case, a PCT).
  • The resource group this PCT belongs to.
  • The short description of the PCT.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


PLTs for CICS Startup List name

Use this page to view the PLTs defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details

Click this to see detailed information for the PLT in this row.

The rest of the information in this row shows:

  • The name of the PLT.
  • The type of resource (in this case, a PLT).
  • The resource group this PLT belongs to.
  • The short description of the PLT.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


PPTs for CICS Startup List name

Use this page to view the PPTs defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details

Click this to see detailed information for the PPT in this row.

The rest of the information in this row shows:

  • The name of the PPT.
  • The type of resource (in this case, a PPT).
  • The resource group this PPT belongs to.
  • The short description of the PPT.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


Sys62s for CICS Startup List name

Use this page to view the Sys62s defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details

Click this to see detailed information for the Sys62 in this row.

The rest of the information in this row shows:

  • The name of the Sys62.
  • The type of resource (in this case, a Sys62).
  • The resource group this Sys62 belongs to.
  • The short description of the Sys62.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


SysCs for CICS Startup List name

Use this page to view the SysCs defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details

Click this to see detailed information for the SysC in this row.

The rest of the information in this row shows:

  • The name of the SysC.
  • The type of resource (in this case, a SysC).
  • The resource group this SysC belongs to.
  • The short description of the SysC.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


Terms for CICS Startup List name

Use this page to view the Terms defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details

Click this to see detailed information for the Term in this row.

The rest of the information in this row shows:

  • The name of the Term.
  • The type of resource (in this case, a Term).
  • The resource group this Term belongs to.
  • The short description of the Term.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


TSTs for CICS Startup List name

Use this page to view the TSTs defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details

Click this to see detailed information for the TST in this row.

The rest of the information in this row shows:

  • The name of the TST.
  • The type of resource (in this case, a TST).
  • The resource group this TST belongs to.
  • The short description of the TST.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


T-Types for CICS Startup List name

Use this page to view the T-Types defined in resource groups used by the startup list name.

Details

Display detailed information for the T-Type.

The rest of the information in this row shows:

  • The name of the T-Type.
  • The type of resource (in this case, a T-Type).
  • The resource group this T-Type belongs to.
  • The short description of the T-Type.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


URIMAPs for CICS Startup List name

Use this page to view all defined URIMAPs defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details
Click this to see detailed information for the URIMAP in this row.

The rest of the information in this row shows the name of the URIMAP, the group to which it belongs, whether the URIMAP definition is for an HTTP server or client, and its description.

New
Click one of the buttons to create a new resource.
Parent topic: by StartL


TCPIPServices for CICS Startup List name

Use this page to view all defined TCPIPSERVICEs defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details
Click this to see detailed information for the TCPIPSERVICE in this row.

The rest of the information in this row shows the name of the TCPIPSERVICE, the group to which it belongs and a description of the service.

New
Click one of the buttons to create a new resource.
Parent topic: by StartL


XATs for CICS Startup List name

Use this page to view the XATs defined in resource groups used by the startup list name. You can also create a new resource from this page.

Details

Click this to see detailed information for the XAT in this row.

The rest of the information in this row shows:

  • The name of the XAT.
  • The type of resource (in this case, a XAT).
  • The resource group this XAT belongs to.
  • The short description of the XAT.
New

Click one of the buttons to create a new resource.

Parent topic: by StartL


DOCTEMPLATEs for CICS Startup List name

Use this page to view all DOCTEMPLATEs defined in resource groups used by the startup list name.

Details
Click this to display detailed information for the DOCTEMPLATE.

The rest of the information in this row shows the name of the DOCTEMPLATE, the group to which it belongs, and the description of the template.

New
Click one of the buttons to create a new resource.
Parent topic: by StartL


by Type

  • CICS Startup List list_name or CICS Defined resource
  • CICS Defined DCT
  • CICS Defined FCT
  • CICS Defined JCT
  • CICS Defined PCT
  • CICS Defined PLT
  • CICS Defined PPT
  • CICS Defined Sys62
  • CICS Defined SysC
  • CICS Defined Term
  • CICS Defined TST
  • CICS Defined T-Type
  • CICS Defined XAT
  • CICS Defined URIMAP
  • CICS Defined TCPIP Service
  • CICS Defined DOCTEMPLATE
Parent topic: Resources


CICS Defined DCT

Use this page to view all defined DCTs. You can also create a new resource from this page.

Details

Click this to see detailed information for the DCT in this row.

The rest of the information in this row shows:

  • The name of the DCT.
  • The type of resource (in this case, a DCT).
  • The resource group this DCT belongs to.
  • The short description of the DCT.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined FCT

Use this page to view all defined FCTs. You can also create a new resource from this page.

Details

Click this to see detailed information for the FCT.

The rest of the information in this row shows:

  • The name of the FCT.
  • The type of resource (in this case, an FCT).
  • The resource group this FCT belongs to.
  • The short description of the FCT.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined JCT

Use this page to view all defined JCTs. You can also create a new resource from this page.

Details

Click this to see detailed information for the JCT in this row.

The rest of the information in this row shows:

  • The name of the JCT.
  • The type of resource (in this case, a JCT).
  • The resource group this JCT belongs to.
  • The short description of the JCT.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined PCT

Use this page to view all the defined PCTs. You can also create a new resource from this page.

Details

Click this to see detailed information for the PCT in this row.

The rest of the information in this row shows:

  • The name of the PCT.
  • The type of resource (in this case, a PCT).
  • The resource group this PCT belongs to.
  • The short description of the PCT.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined PLT

Use this page to view all the defined PLTs. You can also create a new resource from this page.

Details

Click this to see detailed information for the PLT in this row.

The rest of the information in this row shows:

  • The name of the PLT.
  • The type of resource (in this case, a PLT).
  • The resource group this PLT belongs to.
  • The short description of the PLT.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined PPT

Use this page to view all the PPTs defined on this server. You can also create a new resource from this page.

Details

Click this to see detailed information for the PPT in this row.

The rest of the information in this row shows:

  • The name of the PPT.
  • The type of resource (in this case, a PPT).
  • The resource group this PPT belongs to.
  • The short description of the PPT.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined Sys62

Use this page to view all the Sys62s defined on this server. You can also create a new resource from this page.

Details

Click this to see detailed information for the Sys62 in this row.

The rest of the information in this row shows:

  • The name of the Sys62.
  • The type of resource (in this case, a Sys62).
  • The resource group this Sys62 belongs to.
  • The short description of the Sys62.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined SysC

Use this page to view all the SysCs defined on this server. You can also create a new resource from this page.

Details

Click this to see detailed information for the SysC in this row.

The rest of the information in this row shows:

  • The name of the SysC.
  • The type of resource (in this case, a SysC).
  • The resource group this SysC belongs to.
  • The short description of the SysC.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined Term

Use this page to view all the Terms defined on this server. You can also create a new resource from this page.

Details

Click this to display detailed information for the Term in this row.

The rest of the information in this row shows:

  • The name of the Term.
  • The type of resource (in this case, a Term).
  • The resource group this Term belongs to.
  • The short description of the Term.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined TST

Use this page to view all the TSTs defined on this server. You can also create a new resource from this page.

Details

Click this to see detailed information for the TST in this row.

The rest of the information in this row shows:

  • The name of the TST.
  • The type of resource (in this case, a TST).
  • The resource group this TST belongs to.
  • The short description of the TST.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined T-Type

Use this page to view a list of all the T-Types defined on this server. You can also create a new resource from this page.

Details

Click this to see detailed information for the T-Type in this row.

The rest of the information in this row shows:

  • The name of the T-Type.
  • The type of resource (in this case, a T-Type).
  • The resource group this T-Type belongs to.
  • The short description of the T-Type.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined XAT

Use this page to view all the defined XATs. You can also create a new resource from this page.

Details

Click this to see detailed information for the XAT in this row.

The rest of the information in this row shows:

  • The name of the XAT.
  • The type of resource (in this case, a XAT).
  • The resource group this XAT belongs to.
  • The short description of the XAT.
New

Click one of the buttons to create a new resource.

Parent topic: by Type


CICS Defined URIMAP

Use this page to view all defined URIMAPs. You can also create a new resource from this page.

Details
Click this to see detailed information for the URIMAP in this row.

The rest of the information in this row shows the name of the URIMAP, the group to which it belongs, whether the URIMAP definition is for an HTTP server or client, and whether it is enabled or disabled.

New
Click one of the buttons to create a new resource.
Parent topic: by Type


CICS Defined TCPIP Service

Use this page to view all defined TCPIPSERVICE. You can also create a new resource from this page.

Details
Click this to see detailed information for the TCPIPSERVICE in this row.

The rest of the information in this row shows the name of the TCPIPSERVICE and its current status.

New
Click one of the buttons to create a new resource.
Parent topic: by Type


CICS Defined DOCTEMPLATE

Use this page to view the DOCTEMPLATEs available on this server.

Details
Click this to display detailed information for the DOCTEMPLATE.

The rest of the information in this row shows the name of the DOCTEMPLATE and the type of its source.

New
Click one of the buttons to create a new resource.
Parent topic: by Type


JES

  • Spool
  • Catalog
  • Control
  • Locks
  • Alias
Parent topic: Resources


Spool

  • JES queue type Queue
  • Job job-number
  • Job job-name - ddname
Parent topic: JES


JES queue type Queue

Use this page to view the spool files that have been created as a result of submitting JCL on this server.

Note: The title of the page indicates the type of queue that is currently being displayed, either Input, Held Input , Active, Output, Held Output, or Printed.
Job

Enter a job number in the display field then click this to see details of that job.

Filters

Use this group of fields to apply filters to the list of data sets so that you can just view a subset.

Name filter

Enter the job name of the job for which you want to view the list of data sets in a queue. You can use a single asterisk as a wild card.

User filter

Enter the user ID for which you want to view the list of data sets in a queue. If you did not specify a USER on the JOB card, the user ID is the name of the enterprise server. You can use a single asterisk as a wild card.

Job No filter

Enter the job number of the job for which you want to view the list of data sets in a queue. You can use a single asterisk as a wild card.

Queue

Click one of the buttons to the right of this field to choose a queue to view.

Input

Click this to see the input queue. This lists jobs waiting to start (usually because no initiator for the correct class is currently available).

In Hold

Click this to see the held input queue. This lists jobs that are held (HOLD on the JOB card, or Hold button on a job’s entry in the input queue).

Active

Click this to see the active jobs queue. This lists jobs that are currently running.

Output

Click this to see the output queue. This lists finished jobs whose output is waiting to be sent to an output device (usually because no SYSOUT processor for the correct class is currently available).

Out Hold

Click this to see the held output queue. This lists finished jobs whose output data sets are held (Hold button on a job’s entry in the output queue).

Printing

Click this to see the printing queue. This lists data sets that are currently being printed.

Display

Click this to see details of one of the jobs in the queue. First click the check box to the left of the row describing the job of interest.

Delete

Click this to delete one or more of the jobs in the queue. First click the check boxes to the left of the rows describing the jobs you want to delete. To delete all the jobs click the check box to the left of Display; this selects all the jobs.

Name

Shows the name of the job as specified on the JOB card.

Job No

Shows the number of the job as allocated by JCL Support.

C

Shows the class of the job, as specified on the JOB card.

Pr

Shows the priority of the job, as specified on the JOB card.

User

Shows the user ID under which the job as run. If you did not specify a USER on the JOB card, the user ID is the name of the enterprise server.

Status

Shows the current status of the job. The possible values are

Active | The job is currently being executed
Dispatched | The job is scheduled to a batch or printer process but not yet actioned (transient state)
Input Hold | The job is currently held in the input queue: it will not be executed until you release it
Input Ready | The job is currently in the input queue
Other | The status is unknown
Output Hold | The output from the job is held awaiting release
Output Ready | The output from the job is available to be scheduled
Parsing | MSS is currently parsing the JCL
SYSOUT Disp | The output data set is scheduled to an output device but not yet actioned (transient state)
SYSOUT Hold | The output data set is held awaiting release
SYSOUT Print | The output data set has been printed but other parts of the job are still pending
SYSOUT Ready | The output data set is available to be scheduled to an output device
Submitted

Shows the date and time when the job was submitted.

Parent topic: Spool


Job job-number

Use this page to view details of a job's execution and change control information for a job.

Job

Specify the number of a different job from the one being displayed, then click this to go to the Details page for that job.

Name

Shows the name of the job as specified on the JOB card.

Status

Shows the current status of the job. The possible values are

Active | The job is currently being executed; the Process ID (PID) of the job is shown.
Dispatched | The job is scheduled to a batch or printer process but not yet actioned (transient state)
Input Hold | The job is currently held in the input queue: it will not be executed until you release it
Input Ready | The job is currently in the input queue
Other | The status is unknown
Output Hold | The output from the job is held awaiting release
Output Ready | The output from the job is available to be scheduled
Parsing | MSS is currently parsing the JCL
Hold

Click this to hold the job, so that it cannot run until you click Release. (This button changes to a Release button when you click it.) If you have also changed the value for Class or Priority the change is applied.

Release

Click this to release a held job, so that it can run. (This button changes to a Hold button when you click it.) If you have also changed the value for Class or Priority the change is applied.

Class

Shows the class of the job, as specified on the JOB card. If you want to change the class of the job, specify the new class and click Update. For example, you might want to change the class of a job to a class that has a batch printer SEP defined for it, so that the output data sets can be printed.

Priority

Shows the priority of the job, as specified on the JOB card. If you want to change the priority of the job, specify the new priority and click Update.

Update

Click this to apply any changes you have made to Class or Priority.

User

Shows the user ID under which the job was run. If you did not specify a USER on the JOB card, the user ID is the name of the enterprise server.

Delete

Click this to delete the job from the queue. All the files associated with the DD statements in the job are deleted.

File

Shows the full path of the file containing the JCL that was run.

Messages

The area under Page and File contains all the messages that were output by the JES system during the running of the job, in chronological order.

Reply

Click this to provide a reply to an ACCEPT FROM CONSOLE statement, once you have entered the reply in Enter. You see this only if the job is halted pending a reply.

Enter

Specify your reply to the ACCEPT FROM CONSOLE statement.

SYSOUT

Lists the output files that were created during the running of the job.

Status (output file)

Shows the current status of an output file created by the job:

Active | The job is currently being executed
Complete | The file has been printed
Input Hold | The job is currently held in the input queue: it will not be executed until you release it
Input Ready | The job is currently in the input queue
Other | The status is unknown
Output Hold | The output from the job is held awaiting release
Output Ready | The output from the job is available to be scheduled
Parsing | MSS is currently parsing the JCL
SYSOUT Disp | The output data set is scheduled to an output device but not yet actioned (transient state)
SYSOUT Hold | The output data set is held awaiting release
SYSOUT Printed | The output data set has been printed but other parts of the job are still pending
SYSOUT Ready | The output data set is available to be scheduled to an output device
Class (output file)

Shows the class of the job, as it was when the output files were created.

DDNAME

Shows the name of the data set produced by the job step; the first entry is always for the system log, sys.log.

Step

Shows the name of the job step that produced this file.

Nbr

Shows the number of the job step.

Proc Step

Shows the procedure step, where an output data set was created by a step in a procedure.

Records

Shows the number of records in the output file.

Details

Click this to display details of the output from an individual job step.

Parent topic: Spool


Job job-name - ddname

Use this page to view details of an output file from a job and to change control information for the file.

Job Name
Shows the name of the job to the right of the label. Shows the ddname of the output file to the left of the label.
Status
Shows the current status of the data set. The possible values are
Active | The job is currently being executed
Complete | The file has been printed
Input Hold | The job is currently held in the input queue: it will not be executed until you release it
Input Ready | The job is currently in the input queue
Other | The status is unknown
Output Held | The output from the job is held awaiting release
Output Ready | The output from the job is available to be scheduled
Parsing | MSS is currently parsing the JCL
SYSOUT Disp | The output data set is scheduled to an output device but not yet actioned (transient state)
SYSOUT Print | The output file is currently being printed
SYSOUT Hold | The output data set is scheduled to an output device but not yet actioned (transient state)
SYSOUT Ready | The output data set is available to be scheduled to an output device
Hold
Click this to hold the file, so that its status cannot be changed. (This button changes to a Release button when you click it.) If you have also changed the value for Class or Priority the change is applied.
Release
Click this to release a held file, so that its status can be changed. (This button changes to a Hold button when you click it.) If you have also changed the value for Class or Priority the change is applied.
Class
Shows the class of the file, as specified on the JOB card. If you want to change the class of the file, specify the new class and click Update.
Priority
Shows the priority of the file, as specified on the JOB card. If you want to change the priority of the file, specify the new priority and click Update.
Update
To change the class or priority of a file, modify the appropriate field and then click this.
User
Shows the user ID under which the job was run. If you did not specify a USER on the JOB card, the user ID is the name of the enterprise server.
Records
Shows the number of records in the output file.
Purge

Click this to delete the file.

Step
Shows the name of the job step that produced this file.
Proc Step
Shows the name of the procedure step, where an output data set was created by a step in a procedure.
Step Number
Shows the number of the job step that produced this file.
Proc Step No
Shows the number of the procedure step, where an output data set was created by a step in a procedure.
Codeset

Shows the codeset of the output file.

Created

Shows the date and time the output file was created.

LRECL Min / Max
Shows the maximum and minimum record lengths.
Referenced
Shows the date and time the file was last used in a job.
DS Name
Shows the data set name of the output file, in mainframe format.
PC Name
Shows the filename of the output file, in the format of your local operating system.
Display
Click this to display the contents of the file.
Start
Specify the number of the record where you want the display of the file contents to start. Defaults to 1.
for
Specify how many records you want to be displayed. Clear the field to view all the records in a file. Defaults to 10000. If there were more records than you requested, the final line in the listing warns you that the output was curtailed.
Codeset (for display)
Specify the codeset in which you want the contents to be displayed. Defaults to ASCII.

If you select Both, the system tries to display the contents without regard to the codeset used. For example, the strings x'41424344' and x'a1a2a3a4' are both displayed as "ABCD". You might find this of use if you are not sure what codeset was used to create the file.

The value 'Dump' gives you a hexadecimal dump of the file.

Details
Check this if you want extra details to be included in the display of the file contents.
Job
Specify the number of a different job from the one being displayed, then click this to go to the Details page for that job.
Parent topic: Spool


Catalog

  • Data Catalog (JES)
  • Catalog Entry (JES)
Parent topic: JES


Data Catalog (JES)

Use this page to view the data catalog. This holds information about data sets. No entries are displayed until you click the List button.

List

This is a filter. Enter a string of one or more characters to limit the list of data sets shown to those that begin with the string. For example, enter "ABC*" to view only those data sets that begin with ABC. You can use a single asterisk as a wild card.

Cataloged Only

Choose whether to view just cataloged data sets or uncataloged ones as well as cataloged.

New

Click this to add an entry for a data set to the catalog.

Details

Click this to see details of an individual data set.

DS Org
Shows the data set organization of the data set. Can be one of:
DA | Direct access
GDG | Generation data group
IS | Indexed sequential
PDSM | Partitioned data set member (Micro Focus organization)
PO | Partitioned
PS | Physical sequential
VSAM | Virtual storage access method
DS Name

Shows the data set name of the output file, in mainframe format.

Parent topic: Catalog


Catalog Entry (JES)

Use this page to add an entry to the catalog or to view and change information for a cataloged data set.

Apply

Click this to apply your changes to the entry in the catalog.

Copy

Click this to copy a catalog entry.

Delete

Click this to delete the data set from the disk.

DS Name

If you are adding an entry, specify the data set name of the file, in mainframe format. If you are viewing an entry, shows the data set name of the file, in mainframe format.

Catalog

Check this if you want the file to be included in the catalog.

Physical File

If you are adding an entry, specify the filename of the physical file held on your machine, in the format of your local operating system. If you are viewing an entry, shows the filename of the file, in the format of your local operating system.

DSOrg

Shows the data set organization of the data set. Can be one of:

DA | Direct access
GDG | Generation data group
IS | Indexed sequential
PDSM | Partitioned data set member (Micro Focus organization)
PO | Partitioned
PS | Physical sequential
VSAM | Virtual storage access method
RECFM

Shows the record format of the data set. For all data set organizations except VSAM can be one of:

F | Fixed
FA | Fixed
FB | Fixed blocked
FBA | Fixed blocked
FBM | Fixed blocked
FBS | Fixed blocked, spanned
FM | Fixed
FS | Fixed spanned
LSEQ | Line sequential
U | Undefined
V | Variable
VA | Variable
VB | Variable blocked
VBA | Variable blocked
VBM | Variable blocked
VBS | Variable blocked, spanned
VM | Variable
VS | Variable, spanned

For VSAM data set organization can be one of:

ES | Entry sequence
KS | Key sequence
LS | Linear sequence
RR | Relative record
Codeset

Specify the codeset in which you want the contents to be stored. Defaults to ASCII.

Created

Shows the date and time the file was created.

LRECL

Specify the record length for fixed-length records, or the maximum record length for variable-length records, including the 4-byte record header.

Referenced

Shows the date and time the file was last used in a job.

BLKSIZE
Specify the length of a block in bytes.
Display

Click this to display the contents of the file.

Start

Specify the number of the record where you want the display of the file contents to start. Defaults to 1.

for

Specify how many records you want to be displayed. Clear the for field to view all the records in a file. Defaults to 10000. If there were more records than you requested, the final line in the listing warns you that the output was curtailed.

Attention: If you ask for all the records to be displayed in a very large file, your browser will take some time to display all the records, and might run out of memory.
Codeset (for display)

Choose the codeset in which you want the contents to be displayed. Defaults to ASCII.

If you select Both, the system tries to display the contents without regard to the codeset used. For example, the strings x'41424344' and x'a1a2a3a4' are both displayed as "ABCD". You might find this of use if you are not sure what codeset was used to create the file.

The value 'Dump' gives you a hexadecimal dump of the file.

Details

Check this if you want extra details to be included in the display of the file contents.

Parent topic: Catalog


Control

  • JCL Control
Parent topic: JES


JCL Control

Use this page to submit JCL jobs and start batch initiator and batch printer SEPs for this server.

Reply

Click this to provide a reply to an ACCEPT FROM CONSOLE statement. You see this only if the job is halted pending a reply.

PID

Shows the Process ID of the job waiting for the reply.

Description

Shows the job number of the job waiting for the reply and the reason why the reply is required.

Please enter a JCL file name (local to this ES).

Specify the path and name of the file containing the JCL job that you want to run.

Submit

Click this to run the JCL job you have specified.

Browse

Click this to search for the JCL file on your file system.

VSE

Click this if the job uses VSE JCL.

JES2

Click this if the job uses JES2 JCL.

JES3

Click this if the job uses JES3 JCL.

Start

Click this to start a batch initiator SEP or a batch printer SEP dynamically - it is created and starts at once, and exists only until the enterprise server is stopped. Specify details of the SEP in other fields on this page first.

Classes

Specify the classes that you want the batch initiator SEP or a batch printer SEP you are about to start to support.

Type

Choose the type of SEP you want to start from the list.

Exit Module

Specify the name of a printer exit module that you want to be invoked when the batch printer SEP is printing a file. Specify this only if you chose Printer in Type.

Debug

Click this if you want to debug the JCL job that will run in this SEP.

Printer Name

Select the printer that you want files output by this batch printer SEP to be sent to. Only printers known to the operating system are shown.

Job

Enter a job number in the entry field then click this to see details of that job.

Parent topic: Control


Locks

  • Locks (Active)
Parent topic: JES


Alias

  • Alias Table
Parent topic: JES


Alias Table

Lists the Micro Focus implementations of well-known mainframe utilities. You can add additional entries to this list or change the entry so that your own utility is used.

The use of this table means that mainframe JCL that references any of these mainframe utilities does not need to be changed to run in Enterprise Server.

Program Name
The name of the mainframe utility.
Alias
The Micro Focus implementation of the utility.
Parent topic: Alias


IMS

  • IMS Transactions
  • Create, View and Edit an IMS Transaction
  • IMS Control
Parent topic: Resources


IMS Transactions

Use this page to view the IMS transactions defined on the current server.

New

Click this to define a new transaction for use on the current server.

Details

Click this to view detailed information for the transaction. The rest of this row shows the following information for a transaction:

  • Name.
  • PSB name.
  • Description.
Parent topic: IMS


Create, View and Edit an IMS Transaction

Use this page to define a new transaction or view an existing one.

Name

Specify the name of the description.

Description

Specify a description for the transaction.

PSB Name

Specify the name of the PSB associated with this transaction.

Class

Specify the message class for this transaction.

Program Name

Specify the name of the application program associated with this transaction.

Schedule

Choose whether the application program can be scheduled into more than one message processing region simulatneously:

  • Parallel - the application program can be scheduled into more than one message processing region simulatneously.
  • Serial - the application program cannot be scheduled into more than one message processing region simulatneously.
SPA Size

Specify the size of the conversational scratchpad area (SPA). The size specified must be between 16 bytes and 32767 bytes.

SPA Truncate

Choose the setting of the truncated data option:

  • unspecified - the data option currently in effect for the conversation is used.
  • STRUNC - truncated data option is on.
  • RTRUNC - truncated data option is off.
Wait for input

Check this to specify that this is a wait-for-input (WFI) transaction.

Transaction threshold

Specify the maximum length of time in seconds that a transaction can run before a message is logged to the console to indicate that it has exceeded its threshold. This must be in the range 0 through 65535. A value of 0 indicates that there is no threshold.

Check Use System Value to use the system wide value for the transaction time threshold set in the ESMAC IMS Control page.

Priority

Specify the priority assigned to this transaction (and any messages it creates) when the number of input transactions enqueued and waiting to be processed is less than the value specified in P-Limit Count. The priority must be in the range 0 through 14. The default is 1.

Priority Limit

Specify the priority assigned to this transaction (and any messages it creates) when the number of input transactions enqueued and waiting to be processed is greater than or equal to the value specified in P-Limit Count. The priority must be in the range 0 through 14. The default is 1.

Max Segments

Specify the maximum number of application program output segments that are allowed into the message queues for each Get Unique (GU) call from the application program. The number must be in the range 0 through 65535. The default is 0. Specifying 0 indicates that the number of segments is not checked at execution time.

P-Limit Count

Specify the number of input transactions enqueued and waiting to be processed that determines whether the transaction's priority is the value specified in Priority or Priority Limit. The count must be in the range 1 through 65535. The default is 65535.

Deadlock Timeout

Specify the maximum time in seconds that the message processing region will permit this transaction to wait for a resource that has been locked by another process. A value of 0 indicates that there is no timeout.

P-Limit Time

Specify how many seconds a program can spend processing this transaction (or a message from it) in a single scheduling. The number must be in the range 1 through 65535. The default is 65535. Specifying 65535 indicates that no limit is to be imposed.

Status

Choose the status of the transaction program:

  • Enabled - the transaction program is enabled.
  • Disabled - the transaction program is disabled.
Process Limit

Specify how many of this transaction's messages a program can process in a single scheduling. This must be in the range 1 through 9999. The default is 9999. Specifying 9999 indicates that no limit is to be imposed.

Edit

Choose whether or not input data is to be translated to uppercase:

  • ULC - input data is not to be translated to uppercase.
  • UC - input data is to be translated to uppercase.
Edit Exit

This feature is currently not supported.

Fast Path

Specify the the size of the EMH buffer required to run the transaction using Fast Path processing. The minimum value is 12 and the maximum is 30720. Specifying 0 indicates that the transaction cannot be run using Fast Path processing.

In Doubt

Choose what happens if a transaction program using intersystem communication abends at a critical moment during syncpoint or abend processing:

  • Backout - the effects of the transaction are backed out using ROLLBACK.
  • Commit - any changes are committed.
  • Wait - critical resources are locked until the session has recovered, and are then backed out or committed in step with the remote system.
Response Mode

Check this to specify that, for terminals with a default of OPTIONS=TRANRESP, no additional messages are to be allowed after this transaction is entered until this transaction sends a response message back to the terminal. Leave this option unchecked to specify that input should not stop after this transaction is entered.

Tracing

Choose the type of tracing to be performed for the transaction:

  • Standard - tracing is performed.
  • Special - special tracing is performed.
  • No - no tracing is performed.
Codeset

Choose the codeset to use for this transaction:

  • Default - The transaction inherits the system bias codeset.
  • ASCII - The transaction uses ASCII.
  • EBCDIC - The transaction uses EBCDIC.
Dump On ABEND

Check this to request a program dump if the transaction program abends.

MFS Attributes

Choose how attributes are defined in the transaction program:

  • Default - The program defines attributes as defined by the system bias value (which is binary, by default).
  • Binary - The program defines attributes as binary values, for example:
    05 ATTRIBUTE-VARIABLES.
   10 CURSOR-ATTR    PIC X(2) VALUE X"C0C1".
   10 ERROR-ATTR     PIC X(2) VALUE X"C0C9".
   10 OK-ATTR        PIC X(2) VALUE X"00C1".
   10 PROT-ATTR      PIC X(2) VALUE X"00F1".
  • Character - The program defines attributes as characters, for example:
    05 ATTRIBUTE-VARIABLES.
   10 CURSOR-ATTR PIC X(2) VALUE "{A".
   10 ERROR-ATTR PIC X(2) VALUE "{I".
   10 OK-ATTR PIC X(2) VALUE " A".
   10 PROT-ATTR PIC X(2) VALUE " 1".

    This setting only has an effect if the program is compiled using the ASCII character set; it is ignored if the program is compiled using EBCDIC.

MFS Null

Specify the character to use as the NULL. You can enter the value in character form or hexadecimal form (X'nn'). The default is X'1A'.

This setting only has an effect if the program is compiled using the ASCII character set; it is ignored if the program is compiled using EBCDIC.

Security Keys
all
Choose a setting to apply to all the security keys:
  • On - enables all the security keys
  • Off - disables all the security keys
1-64

Check any of the boxes 1 through 24 to activate that security key.

Active, Install

Click this to install (make active) this resource.

Delete

Click this to delete this transaction. You see this button only if you have permission to edit the transaction.

Copy

Click this to create a new transaction. The values on the current page will be used as the basis for the values in the new transaction.

Dump

Click this to create and view display a dump of the transaction information.

Parent topic: IMS
Parent topic: Pages for Creating Resources


IMS Control

Use this page to start message processing regions (MPRs) and perform a number of other IMS-related administration functions for this server.

Commands
/dis TRAN all

Click this to execute a /dis TRAN all command. The results are displayed below the entry field.

/dis USER all

Click this to execute a /dis USER all command. The results are displayed below the entry field.

/dis DB all

Click this to execute a /dis DB all command. The results are displayed below the entry field.

/dump TM

Click this to execute a /dump TM command. The results are displayed below the entry field.

Enter

Click this to execute the command specified in the entry field to the right. The results are displayed below the entry field.

Start IMS MPRs (Message Processing Regions)
Start
Click this to start a message processing region.
MPR Classes

Specify the transaction classes that can run in the message processing region.

Debug

Click this if you want to debug the IMS transactions that will run in this message processing region.

Renew MFS Formats and IMS ACBs
Renew
Click this to delete information from the system cache and to reload the current information from disk.
MFS Formats
Select this to delete information on MFS format blocks.
ACBs
Select this to delete information on application control blocks

TM System Overview and Control
Transaction Threshold
Specify the maximum length of time in seconds that a transaction can run before a message is logged to the console to indicate that it has exceeded its threshold. This must be in the range 0 through 65535. A value of 0 indicates that there is no threshold.
Keypoint Frequency
Specify how many thread requests are to be processed before a keypoint is generated. This must be in the range 0 through 65535. The default is 64. Specifying 0 indicates that keypoints are only generated when the enterprise server starts and shuts down.
TM Message Queue Diagnostics
Display summary overview of IMS Message Queues
Click this to view the content of the IMS message queue.
Display block-number/segment of message queue

Click this to view a specified segment of the IMS message queue.

Parent topic: IMS


Pages for Creating Resources

  • CICS DCT
  • CICS FCT
  • CICS JCT
  • CICS PCT
  • CICS PLT
  • CICS PPT
  • CICS Sys62
  • CICS SysC
  • CICS T-Type
  • CICS Term
  • CICS TST
  • CICS URIMAP
  • CICS TCPIPSERVICE
  • CICS XAT
  • CICS DOCTEMPLATE
  • Create, View and Edit an IMS Transaction
Parent topic: Resources


CICS DCT

Use this page to create a new DCT. A DCT is a definition of a transient data queue.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new DCT.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Group List

Click this to display the CICS Group group_name.

Add

Click this to save changes you have made to the page, refresh the page and add the new DCT to the group you specify in Grp. The button changes to Apply.

Name

Specify a name for the DCT (can be up to 60 characters).

Grp

Choose a group to which this DCT will belong. The list of groups from which you can choose include only those which can be edited by you.

Description

Specify a description for the DCT (can be up to 60 characters).

Type

Choose the destination for transient data:

  • Intra-Part - intrapartition
  • Indirect - indirect
  • Extra-Part - extrapartition
  • Internal Rdr - the internal reader to which CICS applications can direct a JCL jobstream for execution by the JCL engine
Indirect Name

Specify the symbolic name of the indirect destination. The symbolic name is used when writing to the destination. The name can be one to four characters in length. This control has an effect only if you selected Indirect in the Type control.

Recoverable

Check this to enable recovery of the destination in the event of an abnormal termination of either MSS or the transaction processing the destination. This control only has an effect if you selected Intra in the Type control.

Name (Remote Queue)

Specify the name of a remote transient data destination.

SYSID

Specify the system or region in which the remote transient data destination resides. The name specified must be the same as that given in Name in the SysC or Sys62 definition.

Transaction

Specify the name of the transaction that is to be automatically initiated when the trigger level specified in Trigger Level is reached. If no transaction is specified, or Trigger Level is set to 0, some other means must be used to schedule transactions to read records from the destinations.

Terminal

Specify the terminal associated with the transient data destination. The terminal must be defined to MSS.

Trigger Level

Specify the number of records to be accumulated before a task is automatically initiated to process them. The maximum number you can enter is 32767.

File Name

Specify the filename of the extrapartition file.

File Path

Specify the pathname of the extrapartition file.

Extension

Specify the filename extension of the extrapartion file.

Fileshare

Specify the name of the stand-alone Fileshare server that controls this file (if required).

Record Max

Specify the maximum length of a record in the extrapartition file.

Record Min

Specify the minimum length of a record in the extrapartition file.

Initial State

Choose the initial status of the data set:

  • Open - the data set is opened by system initialization.
  • Closed - the data set remains closed until you indicate that you want to open it.
Type (Extra-partition File Characteristics)

Choose whether the file is line sequential:

  • Normal - The file is not line sequential.
  • Line Sequential - The file is line sequential.
Print Attributes

Choose whether or not a forms control character is contained in the first position of each record:

  • No Control - Records have no forms control character.
  • ASA - Records contain a form control character that is in ASA format.
  • Machine - Records contain a form control character that is in machine format.
I/O Type

Choose the type of input/output:

  • Input - Input data.
  • Output - Output data.
  • Read Backwards - Input data read from the end of the dataset to the beginning.
Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys.
  • Off - disables all the resource keys.
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Active, Display

Click this to display the currently installed definition of this resource.

Active, Install

Click this to install (make active) this resource.

Delete

Click this to delete this DCT. This button is displayed only after you click Add.

Copy

Click this to create a new DCT, using the values set on this page as the basis for the new DCT. This button is displayed only after you click Add.

Dump

Click this to create and view dump information for this DCT. This button is displayed only after you click Add.

Parent topic: Pages for Creating Resources


CICS FCT

Use this page to create a new FCT.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new FCT.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Group List

Click this to display the CICS Group group_name page.

Add

Click this to save changes you have made to the page, refresh the page and add the new FCT to the group you specify in Grp. The button changes to Apply.

Name

Specify a name for this FCT.

Grp

Choose a group to which this FCT will belong. The list of groups from which you can choose include only those which can be edited by you.

Description

Specify a description of the file (can be up to 60 characters).

Type

Choose the file type:

  • KSDS - key sequence data set
  • ESDS - entry sequence data set
  • RRDS - relative record data set
  • Alt Index - alternate index
  • Undefined - remote file (Specify the System ID on the Remote page)

You must uncheck Use Catalog before you can specify a file type. This is because if you use the catalog this information is stored there, not in the FCT entry.

Format

Choose the format for the file. You must uncheck Use Catalog before you can choose a file format. This is because if you use the catalog this information is stored there, not in the FCT entry.

LRECL Min

Specify the minimum logical record length of the file, in bytes, in the range 1 through 32767. This must not be greater than the value of Max LRECL.

For fixed length records, set this value equal to Max LRECL.

You must uncheck Use catalog before you can specify a minimum logical record length. This is because if you use the catalog this information is stored there, not in the FCT entry.

LRECL Max

Specify the maximum logical record length of the file, in bytes in the range 1 through 32767. This must not be less than the value of Min LRECL.

For fixed length records, set this value equal to Min LRECL.

Key Position

For files of type KSDS or ALT specify the byte number at which the record key begins in the range 1 through 32767. Bytes are numbered from 1.

Key Length

For files of type KSDS or ALT, specify the length of the record key in bytes (within the range 1 through 32767). The value "Key position+Key length-1" must not be greater than Min LRECL.

For files of type Undefined, specify the length of the record key, which must not be greater than Max LRECL.

Use Catalog

Check this if you want to use the catalog to store information about the file. If you check this, certain parameters on this page become irrelevant; the description for each parameter indicates whether Use Catalog affects that parameter.

Base Name

Specify the base filename for an alternate index. CICS references alternate indexes by a user-assigned name. This connects the alternate index definition to the base file.

Dataset Name

Specify the data set name for this file as used on the mainframe. You must check Use Catalog before you can specify a data set name. This is because the catalog uses this information.

Status

Choose whether the file is accessible to transactions at system startup

  • Enable - the file is accessible to transactions at system startup.
  • Disable - the file is not accessible to transactions at system startup. A disabled file returns the reference "DISABLED". This can cause problems for some applications; if this is true for your application, set Unenable instead.
  • Unenable - the file is not accessible to transactions at system startup. An unenabled file returns a reference "NOTOPEN", which can be handled by those applications that cannot handle a "DISABLED" reference.

The value set by this control is ignored if the file resides on a remote system.

Access

Check one or more boxes to set the read/write permissions for the file. You can check:

  • Read - enables applications to read records from the file.
  • Add - enables applications to add records to the file.
  • Browse - enables applications to browse the file.
  • Delete - enables applications to delete records from the file.
  • Update - enables applications to update records in the file.
  • Exclusive - CICS Exclusive Control. Enables application to gain exclusive control of a record within a file.
Set

Check one or more boxes to set various file parameters. You can select the following options:

  • Start Open - check this to indicate that the file is to be opened at system startup. If you want the file to be opened at system startup and accessible to transactions, you must also select Enabled in the Status select box.
  • Start Empty - check this to indicate that the current contents of the file are to be deleted at system startup.
  • Backward Recovery - check this to indicate that the file is a protected resource changes to which can be backed out. The file must be accessed through a Fileshare server.
  • Forward Recovery - check this to indicate that journals are to be used to record changes to the file to enable forward recovery. The file must be accessed through a Fileshare server.
  • Allow Duplicate Keys - check this if the file can have duplicate keys. The file must be an alternate index (Type set to Alt index) and you must have unchecked Use Catalog, because if you use the catalog this information is stored there, not in the FCT entry.
  • EBCDIC Collating Sequence - check this to indicate that the EBCDIC collating sequence is to be used for this file. You must uncheck Use Catalog before you can check this, because if you use the catalog this information is stored there, not in the FCT entry.
Remote SYSID

Specify the system ID of the remote system on which the file resides. The name specified must be the same as that given in Name in the SysC or Sys62 definition.

You must uncheck Use Catalog before you can specify a system ID for the remote system. This is because the catalog is used only for storing information about files held locally.

Remote File

Specify the name of the file on the remote system. You must uncheck Use Catalog before you can specify a name for a remote file. This is because the catalog is used only for storing information about files held locally.

Override File Name

Specify the filename of the physical file if you want to override the default. Do not include the file extension. Can be up to 255 characters.

If you do not specify this entry, the physical file name defaults to the name of the FCT entry.

You cannot use this default if you specify a Fileshare server; you must specify a physical file name.

You must uncheck Use Catalog before you can specify a filename. This is because if you use the catalog this information is stored there, not in the FCT entry.

File Extension

Specify the file extension of the physical file if you want to override the default. Can be up to 3 characters. You must uncheck Use Catalog before you can specify an extension. This is because if you use the catalog this information is not required.

File Path

Specify the path of the physical file if you want to override the default. Do not include the filename or file extension. Can be up to 255 characters. You must uncheck Use catalog before you can specify a path. This is because if you use the catalog this information is stored there, not in the FCT entry.

Fileshare Server

Specify the ID of the Fileshare server on which the file resides. Can be up to 16 characters. You must uncheck Use Catalog before you can specify a Fileshare server. This is because if you use the catalog this information is stored there, not in the FCT entry.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys.
  • Off - disables all the resource keys.
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Active, Display

Check this to display the currently installed definition of this resource.

Active, Install

Check this to install (make active) this resource.

Delete

Check this to delete this FCT. This button is displayed only after you click Add.

Copy

Check this to create a new FCT, using the values set on this page as the basis for the new FCT. This button is displayed only after you click Add.

Dump

Check this to create and view dump information for this FCT. This button is displayed only after you click Add.

Parent topic: Pages for Creating Resources


CICS JCT

Use this page to create a new JCT (journal control table).

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new JCT.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Group List

Display the CICS Group group_name page.

Add

Click this to save changes you have made to the page, refresh the page and add the new JCT to the group you specify in Grp. The button changes to Apply.

Name

Specify a name for this JCT.

Grp

Choose a group to which this JCT will belong. The list of groups from which you can choose include only those which can be edited by you.

Description

Specify a description for the JCT (can be up to 60 characters).

Type

Choose the type of journal:

  • Disk 1 - A journal on disk that has one data set to be reused when full.
  • Disk 2 - A journal on disk that has two data sets to be used alternately. You must specify this to minimize operator involvement during a takeover.
  • Disk 2 Pause - A journal on disk that has two data sets to be used alternately. When the second data set is full, the system is paused to enable the operator to copy the data sets to another location before resuming with the first data set.
  • SMF - Mainframe System Management Facility format
  • Tape 1 - A journal on one tape drive.
  • Tape 2 - A journal on two tape drives.
File Name

Specify the filename of the journal.

File Path

Specify the pathname of the journal file.

Extension

Specify the filename extension of the journal file.

Fileshare

Specify the name of the Fileshare server that controls this data set.

Record Max

Specify the maximum length of a record in the journal file.

Record Min

Specify the minimum length of a record in the journal file.

Initial State

Choose the initial status of the journal:

  • New - a new journal data set is created at system initialization.
  • Append - data is appended to an existing journal data set.
Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys
  • Off - disables all the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Delete

Click this to delete this JCT. This button is displayed only after you click Add.

Copy

Click this to create a new JCT, using the values set on this page as the basis for the new JCT. This button is displayed only after you click Add.

Dump

Click this to create and view dump information for this JCT. This button is displayed only after you click Add.

Parent topic: Pages for Creating Resources


CICS PCT

Use this page to create a new PCT.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new PCT.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Group List

Click this to display the CICS Group page group_name.

Add

Click this to save changes you have made to the page, refresh the page and add the new PCT to the group you specify in Grp.

Name

Specify a name for this PCT.

Grp

Choose a group to which this PCT will belong. The list of groups from which you can choose includes only those which can be edited by you.

Description

Specify a description of the transaction program (can be up to 60 characters).

Program Name

For local programs only, specify the name of the application program to be run when this transaction is invoked. Leave this field blank if you enter a value in the remote system ID field.

Can be up to eight characters (A-Z, 0-9, #, @, or $). The name is translated to upper case.

Work Area

Specify the size of the transaction program's Transaction Working Area (TWA) in bytes, in the range 0 through 32767.

Remote SysID

Specify the system ID of the remote system. The name specified must be the same as that given in Name in the SysC or Sys62 definition.

Remote PCT

Specify the transaction ID of the transaction program on the remote system. You must specify Remote SysID before you can specify a transaction ID.

Can be up to four alphanumeric characters, the first of which must be a letter. Do not use the letter C as the first character; transaction IDs beginning with C are reserved for use by MSS.

Status

Choose a status for the transaction program:

  • Enabled - the transaction program is enabled.
  • Disabled - the transaction program is disabled.
In Doubt

Choose what is to happen if a transaction program using intersystem communication abends at a critical moment during syncpoint or abend processing:

  • Backout - the effects of the transaction are backed out using ROLLBACK. To use this option, files used by the transaction program must have Backward recovery checked on the FCT page.
  • Commit - any changes are committed.
  • Wait - critical resources are locked until the session has recovered, and are then backed out or committed in step with the remote system.
Upper Case

Check this if you want the transaction program to translate input into upper case

Tracing

Choose the type of tracing to be performed for the transaction program:

  • None - No tracing is performed.
  • Normal - Tracing is performed.
  • Special - Special tracing is performed.
Dynamic Route

Check this to have the program status (local or remote) determined dynamically at user invocation time. If this is unchecked, the program status is made local or remote according to the value of System ID.

Security

Use these check boxes to control the way in which resource authorization checks are performed. If they are not checked, the only check performed will be to confirm that the user has authority to run the transaction. If you check RLS (Resource Level Security), Enterprise Server will check the user's authorization for all resources that the transaction accesses (e.g. file access, TDQ, TSQ, LINK, DPL, START and so on). Checking CMD(for Command) will check the authorization on all the EXEC CICS command operations (e.g. EXEC CICS SET/ENABLE/DISABLE).

Note that IBM Category 3 Transactions do not have security checking at all, so the transactions are allowed for everyone with no authorization calls.

Priority

Specify the transaction priority of the transaction program in the range 0 through 255, where 255 is the highest priority.

The priority of a transaction is the sum of:

  • The terminal priority
  • The transaction priority (this field)
  • The operator priority

This sum must not be greater than 255.

Dump on ABEND

Check this to create a program dump if the transaction program abends.

3270 Screen

Specify the screen size to be used by the transaction program. Select:

  • Default to use the default screen size (as defined in the Typeterm entry).
  • Alternate to use the alternate screen size (as defined in the Typeterm entry).
Inbound

Check this to indicate that this transaction can be initiated by an inbound user action.

Input Timeout

Specify the maximum time in seconds allowed for operator response to an explicit CICS RECEIVE, WEB OPEN, WEB SEND, WEB RECEIVE, or WEB CONVERSE command before this transaction is abended. A value of 0 indicates that there is no timeout, and the system will wait indefinitely for a response.

Check Use System Value to use the system wide value for Input Timeout (as shown on the ESMAC Control screen) rather than the PCT entry.

Runaway Timeout

Specify the maximum continuous period of time in seconds that the region will allow this transaction to run without making a CICS, EZASOKET or MQSeries API call. When this time is exceeded, the transaction is abended. A value of 0 indicates that there is no timeout.

Check Use System Value to use the system wide value for Runaway Timeout (as shown on the ESMAC Control screen) rather than the PCT entry.

Deadlock Timeout

Specify the maximum time in seconds that the region will permit this transaction to wait for a resource that has been locked by another process. A value of 0 indicates that there is no timeout.

Check Use System Value to use the system wide value for Deadlock Timeout (as shown on the ESMAC Control screen) rather than the PCT entry.

Transaction Threshold

Specify the maximum length of time in seconds that a transaction can run before a message is logged to the console to indicate that it has exceeded its threshold. A value of 0 indicates that there is no threshold.

Check Use System Value to use the system wide value for the transaction time threshold (as shown on the ESMAC Control screen) rather than the PCT entry.

Resource Keys, all

Choose a setting to apply to the resource keys:

  • On - enables all the resource keys.
  • Off - disables all the resource keys.

Check any of the boxes 1 through 24 to activate that resource key.

Security Keys, all

Choose a setting to apply to the security keys:

  • On - enables all the security keys.
  • Off - disables all the security keys.

Check any of the boxes 1 through 64 to activate that security key.

Active

Click Display to display the currently installed definition of this resource.

Click Install to install (make active) this resource.

Delete

Click this to delete this PCT. This button is displayed only after you click Add.

Copy

Click this to create a new PCT, using the values set on this page as the basis for the new PCT. This button is displayed only after you click Add.

Dump

Click this to create and view dump information for this PCT. This button is displayed only after you click Add.

Parent topic: Pages for Creating Resources


CICS PLT

Use this page to create a new PLT.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new PLT.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Group List

Click this to display the CICS Group page group_name.

Add

Click this to save changes you have made to the page, refresh the page and add the new PLT to the group you specify in Grp. When you click Add, the button changes to Apply.

Name

Specify a name for the PLT.

Grp

Choose a group to which this PLT will belong. The list of groups from which you can choose include only those that can be edited by you.

Description

Specify a description of the transaction program (can be up to 60 characters).

01 - nn

A numbered list of programs.

If you are creating a PLT, you see one empty field numbered 01. Enter a program to be used by this PLT. Click Add. The startup list is saved. If there are no errors, the page is refreshed, a new empty field (labeled 02) is added to the page, and the Add button changes to Apply. Each time you add a resource group, click Apply.

If you are creating a PLT based on an existing PLT, you will see as many fields are there were programs specified in the PLT from which you created this PLT. Note that, if you can edit the PLT, there is always a blank field added at the end of the list.

You can change the order of the programs in the PLT. Use Down arrow button to move a program down the list. Use Up arrow button to move a program up the list.

Delete an entry in the PLT by clicking Delete button.

Run once/Run in each process

Click Run once to specify that the program should only run once, when the PLT is first initiated. Click Run in each process to specify that the program should run every time the PLT is initiated.

Delete

Click this to delete this PLT. This button is displayed only after you click Add.

Copy

Click this to create a new PLT, using the values set on this page as the basis for the new PLT. This button is displayed only after you click Add.

Dump

Click this to create and view dump information for this PLT. This button is displayed only after you click Add.

Parent topic: Pages for Creating Resources


CICS PPT

Use this page to create a new PPT.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new PPT.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Group List

Click this to display the CICS Group page group_name.

Add

Click this to save changes you have made to the page, refresh the page and add the new PPT to the group you specify in Grp.

Name

Specify a name for this PPT.

Grp

Choose a group to which this PPT will belong. The list of groups from which you can choose includes only those that can be edited by you.

Description

Specify a description of the transaction program (can be up to 60 characters).

Status

Choose a status for the program:

  • Enabled - enables this program to be used in a normal manner.
  • Disabled - prevents the program from being used until specifically enabled using master terminal services.
Type

Choose a type for the resource:

  • Program - this resource is a program.
  • Data Area - this resource is a data table.
Resident

Check this if you want to enable this program to reside in the application server's program cache after it has been loaded.

Commarea

Specify the amount of storage to be allocated to the communications area (COMMAREA) to enable MSS to behave like mainframe CICS. The size is in the range 0 through 32767. The effect of this is that when a program is passed a COMMAREA smaller than the COMMAREA defined in the program, the passed COMMAREA is automatically extended in length to fill the defined space.

Language

Choose the language the program is written in.

Save, Working Storage

Check this to have load requests ignored if the program is already in storage.

Uncheck this to have a fresh copy of the program loaded every time a load request for the program is issued.

Remote SysID

If the program resides in a remote region, specify the 4-character, remote system identifier. The name specified must be the same as that given in Name in the SysC or Sys62 definition.

If the program resides in the local region, leave this field blank.

Rmt Trans ID

Specify the transaction ID of the transaction program on the remote system. You must specify System ID before you can specify a transaction ID.

Can be up to four alphanumeric characters, the first of which must be a letter. Do not use the letter C as the first character; transaction ids beginning with C are reserved for use by MSS.

Remote Prog

If the program resides in a remote region, specify the name by which the program is known there. You must specify Remote SysID before you can specify a remote program ID.

If you specify a remote system ID but leave this field blank, the local identifier for this program will be sent to the remote region.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys.
  • Off - disables all the resource keys.
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Active, Display

Click this to display the currently installed definition of this resource.

Active, Install

Click this to install (make active) this resource.

Delete

Click this to delete this PPT. This button is displayed only after you click Add.

Copy

Click this to create a new PPT, using the values set on this page as the basis for the new PPT. This button is displayed only after you click Add.

Dump

Click this to create and view dump information for this PPT. This button is displayed only after you click Add.

Parent topic: Pages for Creating Resources


CICS Sys62

Use this page to create a new Sys62 sys62. A Sys62 is a definition of an LU6.2 system connection.

The title bar gives details of the Sys62 you are editing and the resource group it belongs to.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new Sys62.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Group List

Click this to display the CICS Group group_name page.

Add

Click this to save changes you have made to the page, refresh the page and add the new Sys62 to the group you specify in Grp. The button changes to Apply.

Name

Specify the name of this Sys62. Can be up to four characters: the first character must be A-Z, @, #, or $; trailing characters can be any of these, or 0-9. The name is forced to upper case.

Grp

Choose a group to which this Sys62 will belong. The list of groups from which you can choose include only those which can be edited by you.

Description

Specify a short description of the Sys62. Acceptable characters are A through Z, 0 through 9, $, @ and #.

LU Alias

Specify the parameter used to connect this definition to the LU6.2 protocol stack definition for this connection.

Mode Table

Specify the parameter that tells the LU6.2 protocol stack which Mode (or session characteristics) Table to use for this connection.

Partner Alias

Specify the parameter required to associate this definition with a peer server's definition within the LU6.2 protocol stack definitions.

APPLID

Specify the SNA Application ID of the peer partner server for this connection.

Net Name

Specify the network name that identifies the remote system. The name can be up to eight characters in length. The name follows assembler language rules. It must start with an alphabetic character. The acceptable characters are: A-Z 0-9 $ @ and #. Lower-case characters are converted to upper-case except when using the CREATE command.

Net Name is the APPLID of the remote system or region, unless you are defining an APPC or LUTYPE6.1 link to a VTAM generic resource group. If you are defining an LUTYPE6.1 link to a generic resource, Net Name must specify the generic resource name, not the APPLID of one of the group members. If you are defining an APPC link to a generic resource, Net Name can specify either the group’s generic resource name or the APPLID (member name) of one of the group members. However, if you specify a member name, and this CICS is not itself a member of a CICS Transaction Server for OS/390 generic resource, the connection must always be acquired by this CICS. For VTAM, the APPLID is the label of the remote ACF/VTAMÑ VBUILD TYPE=APPL statement. If you do not supply a Net Name, the CONNECTION name is used by default. You cannot have two or more APPC links with the same Net Name.

Session Max

Specify the maximum number of parallel sessions allowed to be active on this LU.

Transaction

Specify the permanent four-character transaction code to be attached to handle unsolicited input

Priority

Specify the facility-related priority to be used for work that is running with this as the primary facility.

In Service

Check this to enable this facility to default to (or start initially as) being “in service”.

User ID

Specify the permanent user ID for this LU. Any work running against this facility will inherit the permissions of this user ID.

Language

Specify the default language for user interfaces connected to this facility.

Session Name

Specify the name for the session.

Attach

Specify the level of attach-time user security required for the connection:

  • Identify - Incoming attach requests must specify a user identifier. IDENTIFY is used when the connecting system has a security manager; for example, if it is another CICS system.
  • Local - The authority of the user is taken to be that of the link itself, and you rely on link security alone to protect your resource. Local must be specified if the PROTOCOL attribute on the CONNECTION definition is LU6.1.
  • Mixed - Incoming attach requests may be using either or both IDENTIFY or PERSISTENT security types. The security type actually used depends on the incoming attach request.
  • Persistent - Incoming attach requests must specify a user identifier and a user password on the first attach request. Subsequent attach requests require only the user identifier. This should be used only between a PWS (programmable workstation, for example, an IBM Personal System/2) and CICS.
  • Verify - Incoming attach requests must specify a user identifier and a user password. Enter Verify when the connecting system has no security manager and hence cannot be trusted. Do not specify Verify for CICS-to-CICS communication, because CICS does not send passwords.
Oper ID

Specify the three-character Operator ID associated with the permanent User ID - returned on ASSIGN OPID() command for transaction attached to this facility.

Oper Priority

Specify the operator priority for transactions run from this terminal. Specify this for a terminal that cannot be signed on, such as a printer. If you specify it for a terminal that can be signed on, it is overridden by the operator priority specified in the user's sign-on table entry. Defaults to 0(zero). Operator priority is one factor in determining a transaction's execution priority, which is the sum of:

  • Terminal priority
  • Transaction priority
  • Operator priority (this field)

The sum cannot be greater than 255.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all of the resource keys
  • Off - disables all of the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Delete

Click this to delete this Sys62. This button is displayed only after you click Add.

Copy

Click this to create a new Sys62, using the values set on this page as the basis for the new Sys62. This button is displayed only after you click Add.

Dump

Click this to create and view dump information for this Sys62. This button is only displayed after you click Add.

Parent topic: Pages for Creating Resources


CICS SysC

Use this page to create a new SysC. A SysC is a definition of a CCI system connection.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new SysC.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Group List

Click this to display the CICS Group page group_name.

Add

Click this to save changes you have made to the page, refresh the page and add the new SysC to the group you specify in Grp. The button changes to Apply.

Name

Specify the name of this SysC. Can be up to four characters: the first character must be A-Z, @, #, or $; trailing characters can be any of these, or 0-9. The name is forced to upper case.

Grp

Choose a group to which this SysC will belong. The list of groups from which you can choose include only those which can be edited by you.

Description

Specify a description of the transaction program (can be up to 60 characters).

Machine Name

Specify the machine name; consists of the Local LU Alias of the client machine and the Mode used by CCIAPPC when issuing the APPC ALLOCATE verb to initiate a conversation with the server TP. The format is:

LUNAME.MODENAME

where the parameters are:

LUNAME | The Local LU Alias of the client machine. This name must also be defined as a Partner LU Alias on the server machine.
MODENAME | A Mode defined on both the client and server machines.
Protocol

Specify the CCI protocol to be used by this connection:

MF Node

Specify the text hostname or dotted decimal address of the target server.

MF Port

Specify the decimal value of the port that the target server listens on.

Net Name

Specify the name of the network over which the connection is established.

Session Max

Specify the maximum number of sessions that can use this connection.

Transaction

Specify the one- to four-character transaction ID. When MSS receives a request to start a transaction, it only looks at the first four characters of the TP name.

Priority

Specify the priority for transactions run from this terminal. Defaults to 0 (zero). Terminal priority is one factor in determining a transaction's execution priority, which is the sum of:

  • Terminal priority (this field)
  • Transaction priority
  • Operator priority

The sum cannot be greater than 255.

In Service

Check this to specify that the connection defined by this SysC is in service.

User ID

Specify a user ID to be associated with the connection. Mandatory if no sign-on takes place on the connection.

Language

Choose the national language in which messages are sent over the connection. You can choose English or Kanji.

Session Name

Specify the security name of the connection. Can be up to eight alphanumeric characters from the set A through Z, 0 through 9, $, @ and #.

Attach

Choose the level of security required when a user issues an attach request over this connection:

  • Identify - Incoming attach requests must specify a user ID.
  • Verify - Incoming attach requests must specify both a user ID and a password.
  • Persistent - The first attach request must specify both a user ID and a password, but subsequent attach requests require only a user ID.
  • Mixed - Incoming attach requests can specify either Identify or Persistent.
  • Local - The authority of the user is taken to be that of the link.
Oper ID

Specify an operator ID used for routing messages. Specify this for a terminal that cannot be signed on, such as a printer. If you specify an operator ID for a terminal that can be signed on, it is overridden by the operator ID specified in the user's sign-on table entry. Up to three alphanumeric characters.

Oper Priority

Specify the operator priority for transactions run from this terminal. Specify this for a terminal that cannot be signed on, such as a printer. If you specify it for a terminal that can be signed on, it is overridden by the operator priority specified in the user's sign-on table entry. Defaults to 0(zero). Operator priority is one factor in determining a transaction's execution priority, which is the sum of:

  • Terminal priority
  • Transaction priority
  • Operator priority (this field)

The sum cannot be greater than 255.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all of the resource keys
  • Off - disables all of the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that security key.

Delete

Click this to delete this SysC. This button is displayed only after you click Add.

Copy

Click this to create a new SysC, using the values set on this page as the basis for the new SysC. This button is displayed only after you click Add.

Dump

Click this to create and view dump information for this SysC. This button is displayed only after you click Add.

Parent topic: Pages for Creating Resources


CICS T-Type

Use this page to create a new T-type (terminal type definition).

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new T-type.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Group List

Click this to display the CICS Group page group_name.

Add

Click this to save changes you have made to the page, refresh the page and add the new T-type to the group you specify in Grp. When you click Add, the button changes to Apply.

Name

Specify a name for the T-type.

Grp

Choose a group to which this T-type will belong. The list of groups from which you can choose include only those that can be edited by you.

Description

Specify a description of the T-type. The text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.

Type

Choose the type of terminal device:

  • 3270 - A 3270 display device
  • Non-Facility - A non-physical device
  • Generic - Non-specific facility definition
  • ECI - External Call Interface dummy facility
  • System - A peer CICS or ES server
  • Printer - Printer device
  • Dialog Sys - Dialog System client facility
Shippable

Check this to indicate that this physical terminal definition may be shipped to a remote system in support of a transaction routing request. Ifa physical terminal definition is not marked shippable, then the target system must have the terminal explicitly defined as a remote terminal for the transaction routing request to succeed.

Map Size, Width

Specify the page width for the terminal type being defined. The width is defined as a number of columns, in the range 0 through 999. The default is 80.

Map Size, Height

Specify the page height for the terminal type being defined. The height is defined as a number of rows, in the range 0 through 999. The default is 24.

Alternate Map, Width

Specify the page width for the terminal type being defined, if you have specified an alternate screen size (non-default values for Alt Screen, Width and Alt Screen, Height). Alternate page width is defined as a number of columns, in the range 0 through 999. The default is 80. Unexpected results may occur if the number of columns is not the same as the number of columns you specify for Alt Screen, Width. Defaults to the values specified in Map Size, Width.

Alternate Map, Height

Specify the page height for the terminal type being defined, if you have specified an alternate screen size (non-default values for Alt Screen, Width and Alt Screen, Height). Alternate page height is defined as a number of rows, in the range 0 through 999. Unexpected results may occur if the number of rows is not the same as the number of rows you specify for Alt Screen, Height. Defaults to the values specified in Map Size, Height

OB Oper ID, Yes

Check this to enable MSS to use the outbound operator identifiers to support the BMS routing facilities required by this terminal type definition.

Outboard Fmt, Yes

Check this to enable MSS BMS to delegate part of the presentation formatting to the client facility.

ASCII

Choose whether or not this terminal type has an ASCII feature:

No | The terminal type does not have an ASCII feature
7 Bit | Terminals of this type are ASCII-7 terminals. All outbound data is translated to 7-bit ASCII, and all inbound data is translated to EBCDIC
8 Bit | Terminals of this type are ASCII-8 terminals. All outbound data is translated to 8-bit ASCII, and all inbound data is translated to EBCDIC
Send Size

Specify the size, in bytes, of the receive buffer of a terminal of this type. This represents the maximum amount of data that the terminal can receive, and depends on the capability of the device. Considerations of line quality might lead you to specify a buffer size that is less than the terminal type's maximum buffer size. A message longer than the receive buffer is broken into as many request units as are necessary. Defaults to 0 (zero). If you specify a zero buffer size, the message is not broken up; the whole message is presented.

Receive Size

Specify the maximum size, in bytes, of a request unit that can satisfy a receive request. The value you specify might be rounded down.

Routed Msg

Indicates whether or not messages are routed to a terminal of this type by the EXEC CICS ROUTE command. Check this to indicate that BMS is to route to this terminal messages that are destined for all terminals, as well as messages destined for this terminal. Leave unchecked to specify that no messages should be routed to this terminal, even if they are specifically destined for this terminal.

Logon Msg

Check this to specify that the logon transaction is initiated when a session is established and displays the logon message on the terminal. Automatic Transaction Initiation (ATI) is used to start the transaction, so you must check ATI. The transaction competes with any other ATI transactions for use of the terminal. If you check Lastline, the logon message does not overwrite any error message currently displayed.

Auto Connect

Check this to specify that a session is to be established with the terminal when the region starts up. Leave unchecked to specify that a session is to be established when the user signs on at the terminal.

ATI

Check this to enable a transaction to be automatically initiated on this terminal. If you leave this unchecked, you should check TTI to enable users to initiate transactions.

Create Sess

Check this to specify that a session can be initiated from a terminal of this type: EXEC START requests and Automatic Transaction Initiation (ATI) requests are allowed to create sessions automatically. Leave unchecked to specify that EXEC START requests and Automatic Transaction Initiation (ATI) requests are not allowed to create sessions automatically. Such requests are queued or rejected if a session has not been established.

TTI

Check this to enable users to initiate transactions at this terminal. If you leave this unchecked, you should check ATI to enable transactions to be automatically initiated.

NEP Class

Specify the transaction class of the node error program. Defaults to 0000 (zero), which indicates that the default node error program is to be used.

Signoff

Choose which action is to be taken when GNTRAN (CESF or user-defined transaction) is attached and attempts to sign off the terminal. If you are using RACF 1.9 or later, specify the TIMEOUT limit in the RACF segment:

No | The terminal is not automatically signed off in the absence of user input.
Signoff | When the specified time has elapsed after the last input from the operator, the terminal is automatically signed off from MSS.
Signoff/Logoff When the specified time has elapsed after the last input from the operator, the terminal is automatically signed off from MSS and then logged off from VTAM. (This is not supported for TCAM-attached terminals.) Signoff/Logoff is useful for an autoinstall model, because virtual storage is not wasted on entries for terminals that have been timed out. If GNTRAN fails to attach because of unprocessed data in the terminal buffer (resulting in a BID failure), the terminal will be signed off and logged off. GNTRAN will not run and will have no effect.
Note: You cannot change the value of this attribute when DEVICE(APPC) is specified. The default value in that case is Signoff(No).
Notify

Choose how the user is notified of system recovery. This option applies to the recovery of sessions for terminals in a CICS region running with either VTAM persistent sessions or with XRF. It is for use in situations where a terminal user may have to take action, such as to sign on again, after a CICS restart:

None | The user is not notified
Message | A message is displayed on the screen to say that the system has recovered. The message is specified in two BMS maps; DFHXRC1 and DFHXRC2 for XRF; and DFHXRC3 and DFHXRC4 for VTAM persistent sessions. These maps are in mapset DFHXMSG. If reduced takeover time is important, use MESSAGE rather than TRANSACTION. The terminal must be capable of displaying BMS maps, and ATI.must be checked, to specify this option.
Transaction | A transaction is initiated at the terminal. The name of the transaction is specified by the RMTRAN system initialization parameter. (The default transaction for RMTRAN is the one specified in the GMTRAN system initialization parameter: the good-morning transaction.) ATI must be checked to specify this option.
Option

Choose how MSS recovers the session and returns the terminal to normal service:

Sys Default | MSS selects the best recovery strategy based on session activity and the characteristics of the terminal.
Clear Receive | MSS sends a CLEAR request to reset the conversation state, or an UNBIND request if the session does not support the CLEAR request. MSS sends the CLEAR or UNBIND request only if the session was busy.
Release Sess | MSS sends an UNBIND request to clear the active session, if the session was busy.
Unconditional | MSS sends an UNBIND request to clear the active session, whether or not the session was busy.
None | The terminal session is not automatically recovered. If you checked Auto Connect, the terminal is automatically reconnected.
Last Line

Check this to specify that error messages are to be displayed at the bottom of the screen, starting at a position that enables the entire message to be shown at once. If messages are received in quick succession, an earlier message might be overwritten before the user has time to read it. Messages displayed in this way might have the additional attributes specified by Intensify, Color and Highlight. If you leave this unchecked, an error message is displayed at the current cursor position, and without any additional attributes.

Intensify

Check this to have error messages displayed in an intensified field (bold). This has an effect only if Last Line is checked.

Color (Diagnostic Display)

Choose the color in which error messages are to be displayed on a terminal of this type. A setting other than No takes effect only if Last Line is checked.

Highlight (Diagnostic Display)

Choose the type of highlighting to be used for error messages displayed on a terminal of this type. A setting other than No takes effect only if Last Line is checked.

Def. Screen, Width

Specify the default screen width for the 3270 terminal type being defined. This is the screen width that is used when a transaction definition specifies a default screen. Screen width is defined as columns, in the range 0 through 999. The default is 80. There is no validity checking; incorrect sizes might lead to unpredictable behavior.

Def. Screen, Height

Specify the default screen height for the 3270 terminal type being defined. This is the screen height that is used when a transaction definition specifies a default screen. Screen height is defined as rows, in the range 0 through 999 The default is 24. There is no validity checking; incorrect sizes might lead to unpredictable behavior.

Alt. Screen, Width

Specify the alternate screen width for the 3270 terminal type being defined. This is the screen width that is used when a transaction definition specifies an alternate screen. Screen width is defined as columns, in the range 0 through 999. The default is 80. There is no validity checking; incorrect sizes might lead to unpredictable behavior.

Alt. Screen, Height

Specify the alternate screen height for the 3270 terminal type being defined. This is the screen height that is used when a transaction definition specifies an alternate screen. Screen height is defined as rows, in the range 0 through 999 The default is 24. There is no validity checking; incorrect sizes might lead to unpredictable behavior.

APL Keyboard

Check this to specify that the terminal type has the APL keyboard feature.

APL Text

Check this to specify that the terminal type can support the APL text character set.

Audible Alarm

Check this to specify that the terminal type has the audible alarm feature.

Color

Check this to specify that the terminal type has the color feature, which enables colors to be selected for individual fields.

Dual case kbd

Check this to specify that the terminal has a typewriter keyboard. Leave this unchecked to specify that the terminal has an operator console keyboard. Both types of keyboard transmit both upper-case and lower-case data.

Copy (Device Properties)

Check this to specify that the terminal type has the copy feature.

Extended DS

Check this to specify that the terminal type supports extensions to the 3270 data stream. You must check this if Color or Hilight are checked.

Highlight

Check this to specify that the terminal type has the extended highlight feature, enabling individual fields or characters to be displayed in bold, reverse video, or blinking.

Katakana

Check this to specify that the terminal type is a Katakana terminal. Katakana terminals do not support mixed-case output. Upper-case characters appear as upper-case English, but lower-case characters appear as Katakana characters.

Light Pen

Check this to specify that the terminal type has the light pen selector feature. MSS emulates this feature using mouse clicks.

Form Feed

Check this to specify that the device has the form feed feature.

CGSCID

Specify the coded graphic character set global identifier (CGCSGID) that enables transaction programs to determine what character set is supported by this terminal. Defaults to 0,0, which means that the terminal type does not support this feature. The first field specifies the graphic character set global identifier (GCSGID), and the second field specifies the code page global identifier (CPGID).

Horizontal Form

Check this to specify that the device has the horizontal form feature. The devices that can use this feature are batch, batch data interchange, interactive, SCSPRT or LUTYPE4 logical units. If checked, BMS uses horizontal tabbing when formatting output documents. If unchecked, the HTAB option in the BMS map definition is ignored.

Vertical FF

Check this to specify that the device has the vertical form feature. The devices that can use this feature are batch, batch data interchange, interactive, SCSPRT or LUTYPE4 logical units. If checked, BMS uses vertical tabbing when formatting output documents. If unchecked, the VTAB option in the BMS map definition is ignored.

EWA Support

Check this to enable a 3270 device to shift its display into its alternate mode.

SOSI

Check this to specify that the terminal type supports mixed EBCDIC and DBCS fields.

PS

Check this to specify that the terminal type supports the programmed symbol facility. This facility enables you to use a maximum of six sets of 191 characters

Outline

Check this to specify that the terminal type supports field outlining.

Numeric Lock

Check this to enable the numeric lock.

Buffer

Check this to specify that BMS buffers formatted data streams that are sent to a terminal of this type, that is, when an application issues a series of SEND TEXT PRINT commands, MSS sends a page to the terminal only when it is full. Leave thus unchecked to specify that when an application issues a series of SEND TEXT PRINT commands, MSS sends a page to the terminal for every command issued, filling up the page by appending blank lines if necessary.

Print Adapter

Check this to specify that output BMS screens with the PRINT option set on are to be copied automatically to an attached printer.

Transparency

Check this to enable background transparency.

Query

Check this to enable MSS to use the QUERY structured field to determine the characteristics of the device.

Text KB

Check this to specify that the 3270 device has the text-keyboard feature.

Mag Stripe Rdr

Check this to specify that the terminal type has the magnetic stripe reader feature. MSS emulates this feature using mouse clicks.

Validation

Check this:

  • For 8775 devices to enable the extended validation feature, which allows fields to be defined as TRIGGER, MANDATORY FILL, or MANDATORY ENTER.
  • For 3290 devices to enable the validation feature, which allows fields to be defined as MANDATORY FILL or MANDATORY ENTER.
Partition Support

Check this to enable the device to use partitions. This option is not valid for SCS printers.

Build Chain

Check this to specify that MSS is to reassemble request units into a complete message before passing data from a terminal of this type to a transaction program. Leave this unchecked to specify that messages are to be received by the transaction program in individual request units.

User Area

Specify the size, in bytes, of the user area of a terminal of this type. Defaults to 0 (zero).

In Shared Stg

Check this to force the user area into shared storage such that it can be accessed by transactions that do not have this device as the primary facility.

Uppercase Trans

Choose how data entered in lower case is to be treated:

Yes | Data input in lower case is translated to upper case.
No | Data input in lower case is not translated to upper case.
Tranid | Transaction identifiers input in lower case are translated to upper case; not other input data is translated.
I/O Area

Specify the minimum and maximum sizes, in bytes, of the terminal I/O area to be passed to a transaction program when it issues a RECEIVE. If you enter a number in the first field, a terminal I/O area of at least that size is passed to the transaction program. If you specify values in both fields, and a message longer than that specified by the first field, but shorter than that specified by the second field is received, then a terminal I/O area of the maximum size is passed to the transaction program. A message longer than that specified by the second field causes the node abnormal condition program to send an exception response to the terminal. Defaults to 0,0. If you check ATI, you must specify a terminal I/O area of at least one byte.

Active, Display

Click this to display the currently installed definition of this resource.

Active, Install

Click this to install (make active) this resource.

Delete

Click this to delete this T-type. This button is displayed only after you click Add.

Copy

Click this to create a new T-type, using the values set on this page as the basis for the new T-type. This button is displayed only after you click Add.

Dump

Click this to create and view dump information for this T-type. This button is displayed only after you click Add.

Parent topic: Pages for Creating Resources


CICS Term

Use this page to create a new Term (terminal).

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new Term.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Group List

Click this to display the CICS Group group_name page.

Add

Click this to save changes you have made to the page, refresh the page and add the new Term to the group you specify in Grp. The button changes to Apply..

Name

Specify the name for this Term.

Grp

Choose a group to which this Term will belong. The list of groups from which you can choose include only those which can be edited by you.

Description

Specify a description for this Term.

Model

Choose whether or not this terminal definition can be used as a model terminal definition for autoinstall:

  • No - can be used only for a specific device that is not autoinstalled.
  • Yes - can be used as a model for autoinstall, as well as for a specific device that is not autoinstalled.
  • Only - can be used only as a model for autoinstall.
Model Name

Applicable only if Model is Yes or Only. Specify the name by which the definition is known to the Autoinstall Control Program. Specify a name of up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Defaults to the name of this Term.

Terminal Type

Specify the associated Typerterm definition, which must exist. Mandatory.

Net Name

Specify the terminal's network name. Mandatory if Model is 'Yes' or 'No'. The name can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. The first character must be a letter.

Remote Name

Specify the remote name. Applicable only for remote terminals. Necessary only if it differs from the local terminal name.

Remote SysID

Specify the remote system ID that holds the terminal definition. Applicable only for remote terminals. This must correspond to one of:

  • The Local SYSID field in the SIT used to run the related remote MSS region.
  • The APPLID of another CICS system.
Transaction

Specify a transaction name. This specifies the only transaction that users can run from this terminal, apart from print and paging requests. Optional. If not specified, users can run any transaction from this terminal.

Priority

Specify the priority for transactions run from this terminal. Defaults to 0 (zero). Terminal priority is one factor in determining a transaction's execution priority, which is the sum of:

  • Terminal priority (this field)
  • Transaction priority
  • Operator priority

The sum cannot be greater than 255.

In Service

Check this to specify that this terminal is in service; that is, transactions can be initiated and messages sent.

Main Printer

Specify the printer used for handling print requests. This printer must be owned by the system that owns the terminal. The name can be up to four characters in length.

Prt. Copy

Check this to specify that the hardware copy feature (using the printer defined for this terminal) is used for print requests issued from this terminal.

Alternate Printer

Specify the printer used for handling print requests if the printer specified in Main Printer is unavailable. This printer must be owned by the system that owns the terminal. The name can be up to four characters in length.

Alt. Prt. Copy

Check this to specify that the hardware copy feature (using the alternate printer defined for this terminal) is to be used for print requests issued from this terminal.

User ID

Specify a user ID to be associated with the terminal. Mandatory if no sign-on takes place on the connection.

Language

Choose the national language in which messages are sent over the connection. You can choose English or Kanji.

Security Name

Specify the security name for the terminal. Required only if the terminal is owned by a remote system and the connection method is APPC. Can be up to eight alphanumeric characters from the set A through Z, 0 through 9, $, @ and #.

Attach

Choose the level of security required when a user issues an attach request from this terminal:

  • Identify - Incoming attach requests must specify a user ID
  • Verify - Incoming attach requests must specify both a user ID and a password
  • Persistent - The first attach request must specify both a user ID and a password, but subsequent attach requests require only a user ID
  • Mixed - Incoming attach requests may specify either Identify or Persistent
  • Local - The authority of the user is taken to be that of the link
Oper ID

Specify an operator ID to be used for routing messages. Specify this for a terminal that cannot be signed on, such as a printer. If you specify an operator ID for a terminal that can be signed on, it is overridden by the operator ID specified in the user's sign-on table entry. Up to three alphanumeric characters.

Oper Priority

Specify the operator priority for transactions run from this terminal. Specify this for a terminal that cannot be signed on, such as a printer. If you specify it for a terminal that can be signed on, it is overridden by the operator priority specified in the user's sign-on table entry. Defaults to 0 (zero). Operator priority is one factor in determining a transaction's execution priority, which is the sum of:

  • Terminal priority
  • Transaction priority
  • Operator priority (this field)

The sum cannot be greater than 255.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys
  • Off - disables all the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Active, Display

Click this to display the currently installed definition of this resource.

Active, Install

Click this to install (make active) this resource.

Delete

Click this to delete this Term. This button is displayed only after you click Add.

Copy

Click this to create a new Term, using the values set on this page as the basis for the new Term. This button is displayed only after you click Add.

Dump

Click this to create and view dump information for this Term. This button is displayed only after you click Add.

Parent topic: Pages for Creating Resources


CICS TST

Use this page to view and edit the TST tst_name, selected from the CICS Group group_name page.

The title bar gives details of the TST you are editing and the resource group it belongs to.

Group List

Click this to display the CICS Group page group_name.

Add

Click this to save changes you have made to the page, refresh the page and add the new TST to the group you specify in Grp. The button changes to Apply.

Name

Specify the name of this TST.

Grp

Choose a group to which this TST will belong. The list of groups from which you can choose include only those which can be edited by you.

Description

Specify a description for the TST (can be up to 60 characters).

Recoverable

Check this to enable recovery of the temporary storage queue in the event of an abnormal termination of either MSS or the transaction processing the destination.

Name (Remote Queue)

Specify the name of a temporary storage queue.

SYSID

Specify the system or region in which the temporary storage queue resides. The name specified must be the same as that given in Name in the SysC or Sys62 definition.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys
  • Off - disables all the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Security Keys, all

Choose a setting to apply to all the security keys:

  • On - enables all of the security keys
  • Off - disables all of the security keys
Security Keys, 1 - 64

Check any of the boxes 1 through 64 to activate that security key.

Delete

Click this to delete this TST. This button is displayed only after you click Add.

Copy

Click this to create a new TST, using the values set on this page as the basis for the new TST. This button is displayed only after you click Add.

Dump

Click this to create and view dump information for this TST. This button is displayed only after you click Add.

Parent topic: Pages for Creating Resources


CICS URIMAP

Use this page to create a new URIMAP.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new URIMAP.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Click Apply to save changes you have made to the page and refresh the page.

Name
The name of this URIMAP definition. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the URIMAP have been saved and the entry updated. Click Refresh to remove this message.
Description
A description of this URIMAP definition.
Status
Specifies whether this URIMAP definition is installed in an enabled or disabled state.
Usage
Specifies whether this URIMAP definition is for:
  • CICS as an HTTP server
  • CICS as an HTTP client
Universal Resource Identifier:
Scheme
The scheme component of the URI.
Port
The number of the port used by the user application when it communicates with a server.
Host
The host name, or IPv4 or IPv6 address, of the URI.
Path
The path component of the URI.
Associated CICS Resources:
TCPIPService
The name of a TCPIPSERVICE resource definition that defines an inbound port.
Analyzer
Indicates whether an analyzer program is used in processing the HTTP request.
Converter
The name of a converter program used to convert (or perform other processing) on the request and response.
Transaction
The name of an alias transaction used either to run the user application that composes the HTTP response, or to start the pipeline.
Program
The name of the user application program that composes the HTTP response.
Pipeline
Not supported for this release.
WebService
Not supported for this release.
Security Attributes:
Ciphers
A string of up to 56 hexadecimal digits that is interpreted as a list of up to 28 2-digit cipher suite codes.
Certificate
The label of the X.509 certificate that is used as the SSL client certificate during the SSL handshake.
Authenticate
Specifies whether to send basic authentication information in the HTTP response. Basic authentication can only be set when the ES region itself is secure.
Static Document Properties:
Not supported for this release.
Redirection:
Not supported for this release.
Parent topic: Pages for Creating Resources


CICS TCPIPSERVICE

Use this page to create a new TCPIPSERVICE.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new TCP/IP service.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Click Apply to save changes you make to the page, and refresh the page.

Name
The name of this TCPIPSERVICE definition. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the definition have been saved and the entry updated. Click Refresh to remove this message.
Description
A description of this definition.
URM
The name of a user-replaceable program that this service invokes.
Port No
The number of the port on which CICS listens for incoming client requests.
Status
Specifies the initial status of the service after installation, either OPEN if CICS is to begin listening for this service after installation, or CLOSE if not.
Protocol
The application level protocol used on the TCP/IP port.
Transaction
The ID of the CICS transaction to process new requests that this service receives.
Backlog
Not supported for this release.
TSQ Prefix
A code to identify items in the temporary storage queue (TSQ).
IP Address
Not supported for this release.
Socket Close
Not supported for this release.
Max Data Length
Not supported for this release.
Security:
Not supported for this release.
DNS Connection Balancing:
Not supported for this release.
Parent topic: Pages for Creating Resources


CICS XAT

Use this page to create a new XAT (XA-compliant database table).

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new XAT.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Group List

Click this to display the CICS Group page group_name.

Add

Click this to save changes you have made to the page, refresh the page and add the new XAT to the group you specify in Grp. The button changes to Apply.

Name

Specify the name of this XAT.

Grp

Choose a group to which this XAT will belong. The list of groups from which you can choose include only those that can be edited by you.

Description

Specify a short description of the XAT. Acceptable characters are A through Z, 0 through 9, $, @ and #.

Switch Module

Specify the location of the executable file (.dll on Windows, .sl on HP-UX PA-RISC, .so on other UNIX platforms) that contains the entry point that returns the xa_switch_t structure to the enterprise server.

DB Name

Specify the name by which the resource manager is known.

User ID

Specify a resource manager ID, used internally to identify a particular XA configuration. This must be unique within the enterprise server.

Password

Specify the password required for the User ID. If you are entering a new password, you have to confirm it by entering it in PW Verify.

PW Verify

Specify the password again, if you are creating a new password, to verify you have entered it correctly.

Open String, Free Format

Specify the string that is passed to the resource manager on the xa_open() call. An entry in this field usually contains at least the database name, and the user ID and password for connecting to the database. The contents of this string are database-specific.

For DB2, the contents are documented in IBM's DB2 Administration Guide; for additional information see the Application Programmer's Guide.

For Oracle, see the Oracle Application Developer's Guide - Fundamentals.

Where the resource manager supports dynamic registration, and the database vendor requires the name of the module that provides the ax_reg function, you should specify casaxlib.

Close String, Free Format

Specify the string that is passed to the resource manager on the xa_close() call. To find out whether or not you need to supply Close string, see your database vendor's documentation.

Load Module

Choose an external resource manager that the server needs to communicate with on behalf of container-managed applications.

Load Module, Name

if you chose User in Load Module, specify the name of the module that supplies the run-time support for the database calls made by the application.

Parent topic: Pages for Creating Resources


CICS DOCTEMPLATE

Use this page to create a new DOCTEMPLATE.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new template.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Click Add to save changes you have made to the page, refresh the page and add the new template to the group you specify in Grp. When you click Add, the button changes to Apply.

Name
The name of this template.
Grp
The group to which this resource belongs. Do not use group names beginning with "DFH" as these are reserved for use by CICS.
Description
A description of this template. This can be up to 58 characters long.
Append CR/LF
Specifies whether CICS deletes trailing spaces from, and appends carriage return/line feed to, each logical record of the template.
Content Type
The format of the template contents, either BINARY or EBCDIC. If you choose BINARY, when the template is loaded its contents are not parsed; if you select EBCDIC, the template contents are parsed as EBCDIC text.
Template Name
The name by which the template is know to application programs that use it. The name can be up to 48 characters long. If you do not enter a value, it defaults to the value of Name.
Template Type
The type for the source of the template.
Enter details for one of the following:
File
The name of a CICS file which contains the template. This name can be up to eight characters long.
TS Queue
The name of a temporary storage queue containing the template. This name can be up to 16 characters long.
TD Queue
The name of a transient storage queue containing the template. This name can be up to four characters long.
Program
The name of the CICS program that contains the template. This name can be up to 48 characters long. If you do not specify a value, the template name is used.
Exit Program
The name of the exit program that generates this template. This name can be up to eight characters long.
MVS PDS
The details of an MVS partitioned data set (PDS) containing the template.
  • DD Name, the name of the PDS. This name can be up to eight characters long. The default is "DFHHTML".
  • Member Name, the name of a member in the PDS. This name can be up to eight characters long.
HFS File
The name of a z/OS UNIX System Services file containing the template. This can be either the absolute name including all directories and beginning with a slash, or a name relative to the home directory of the CICS region. The name can be up to 255 characters long.
Parent topic: Pages for Creating Resources


Pages for Viewing and Editing Resources

  • CICS DCT - dct_name (group_name)
  • CICS FCT - fct_name (group_name)
  • CICS JCT - jct_name (group_name)
  • CICS PCT - pct_name (group_name)
  • CICS PLT - plt_name (group_name)
  • CICS PPT - PPT_name (group_name)
  • CICS Sys62 - sys62_name (group_name)
  • CICS SysC - sysc_name (group_name)
  • CICS T-Type - ttype_name (group_name)
  • CICS Term - term_name (group_name)
  • CICS TST - tst_name (group_name)
  • CICS XAT - xat_name (group_name)
  • CICS URIMAP - urimap_name (group_name)
  • CICS TCPIPSERVICE - tcpipservice_name (group_name)
  • CICS DOCTEMPLATE - doctemplate_name (group_name)
Parent topic: Resources


CICS DCT - dct_name (group_name)

Use this page to view and edit the DCT dct_name, selected from the CICS Group group_name page.

The title bar gives details of the DCT you are editing and the resource group it belongs to.

Group List

Click this to display the CICS Group page group_name.

Apply

Click this to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the group in which the DCT resides.

Name

Shows the name for this DCT.

Description

Specify a description for this DCT (can be up to 60 characters).

Type

Choose the destination for transient data:

  • Intra-Part - intrapartition
  • Indirect - indirect
  • Extra-Part - extrapartition
  • Internal Rdr - the internal reader to which CICS applications can direct a JCL jobstream for execution by the JCL engine
Indirect Name

Specify the symbolic name of the indirect destination. The symbolic name is used when writing to the destination. The name can be one to four characters in length. This control has an effect only if you selected Indirect in the Type control.

Recoverable

Check this to enable recovery of the destination in the event of an abnormal termination of either MSS or the transaction processing the destination. This control has an effect only if you selected Intra in the Type control.

Name (Remote Queue)

Specify the name of a remote transient data destination.

SYSID

Specify the system or region in which the remote transient data destination resides. The name specified must be the same as that given in Name in the SysC or Sys62 definition.

Transaction

Specify the name of the transaction that is to be automatically initiated when the trigger level specified in Trigger Level is reached. If no transaction is specified, or Trigger Level is set to 0, some other means must be used to schedule transactions to read records from the destinations.

Terminal

Specify the terminal associated with the transient data destination. The terminal must be defined to MSS.

Trigger Level

Specify the number of records to be accumulated before a task is automatically initiated to process them. The maximum number you can enter is 32767.

File Name

Specify the filename of the extrapartition file.

File Path

Specify the pathname of the folder that contains the extrapartition file.

Extension

Specify the filename extension of the extrapartion file.

Fileshare

Specify the name of the stand-alone Fileshare server that controls this file (if required).

Record Max

Specify the maximum length of a record in the extrapartition file.

Record Min

Specify the minimum length of a record in the extrapartition file.

Initial State

Choose the initial status of the data set:

  • Open - the data set is opened by system initialization.
  • Closed - the data set remains closed until you indicate that you want to open it.
Type (Extra-partition File Characteristics)

Choose whether the file is line sequential:

  • Normal - the file is not line sequential.
  • Line Sequential - the file is line sequential.
Print Attributes

Choose whether or not a forms control character is contained in the first position of each record:

  • No Control - records have no forms control character.
  • ASA - records contain a form control character that is in ASA format.
  • Machine - records contain a form control character that is in machine format.
I/O Type

Choose the type of input/output:

  • Input - input data.
  • Output - output data.
  • Read Backwards - input data read from the end of the dataset to the beginning.
Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys
  • Off - disables all the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Active, Display

Click this to display the currently installed definition of this resource.

Active, Install

Click this to install (make active) this resource.

Delete

Click this to delete this DCT. You see this button only if you have editing permissions for the group to which the DCT belongs.

Copy

Click this to create a new DCT using the entries specified on this page.

Dump

Click this to create and view dump information for this DCT.

Parent topic: Pages for Viewing and Editing Resources


CICS FCT - fct_name (group_name)

Use this page to view and, if you have the required permissions, to edit the FCT fct_name, selected from the CICS Group group_name page.

The bar at the top of the page gives details of the FCT you are editing and the resource group it belongs to.

Group List

Display the CICS Group page group_name.

Apply

Click this to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the group in which the FCT resides.

Name

Shows the name for this FCT

Description

Specify a description for this FCT (can be up to 60 characters).

Type

Choose the file type:

  • KSDS - Key sequence data set
  • ESDS - Entry sequence data set
  • RRDS - Relative record data set
  • Alt Index - Alternate index
  • Undefined - Remote file (You must specify Remote SYSID.)

You must uncheck Use Catalog before you can specify a file type. This is because if you use the catalog this information is stored there, not in the FCT entry.

Format

Specify the format for the file. You must uncheck Use Catalog before you can choose a file format. This is because if you use the catalog this information is stored there, not in the FCT entry.

LRECL Min

Specify the minimum logical record length of the file, in bytes, in the range 1 through 32767. This must not be greater than the value of Max LRECL.

For fixed length records, set this value equal to Max LRECL.

You must uncheck Use catalog before you can specify a minimum logical record length. This is because if you use the catalog this information is stored there, not in the FCT entry.

LRECL Max

Specify the maximum logical record length of the file, in bytes in the range 1 through 32767. This must not be less than the value of Min LRECL.

For fixed length records, set this value equal to Min LRECL.

Key Position

For files of type KSDS or ALT, specify the byte number at which the record key begins in the range 1 through 32767. Bytes are numbered from 1.

Key Length

For files of type KSDS or ALT, specify the length of the record key in bytes (within the range 1 through 32767). The value "Key position+Key length-1" must not be greater than Min LRECL.

For files of type Undefined, specify the length of the record key, which must not be greater than Max LRECL.

Use Catalog

Check this if you want to use the catalog to store information about the file. If checked, certain parameters on this page become irrelevant; the description for each parameter indicates whether Use Catalog affects that parameter.

AIX Base

Specify the base filename for an alternate index. MSS references alternate indexes by a user-assigned name. This connects the alternate index definition to the base file.

Dataset Name

Specify the data set name for this file as used on the mainframe. You must check Use Catalog before you can specify a data set name. This is because the catalog uses this information.

Status

Choose whether the file is accessible to transactions:

  • Enabled - the file is accessible to transactions at system startup.
  • Disabled - the file is not accessible to transactions at system startup. A disabled file returns the reference "DISABLED". This can cause problems for some applications; if this is true for your application, set Unenable instead.
  • Unenabled - the file is not accessible to transactions at system startup. An unenabled file returns a reference "NOTOPEN", which can be handled by those applications that cannot handle a "DISABLED" reference.

The value set by this control is ignored if the file resides on a remote system.

Access

Check one or more boxes to set the read/write permissions for the file:

  • Read - enables applications to read records from the file
  • Add - enables applications to add records to the file
  • Browse - enables applications to browse the file
  • Delete - enables applications to delete records from the file
  • Update - enables applications to update records in the file
  • Exclusive - CICS Exclusive Control. Enables an application to gain exclusive control of a record within a file.
Set

Check one or more boxes to set various file parameters:

  • Start Open - check this to indicate that the file is to be opened at system startup. If you want the file to be opened at system startup and accessible to transactions, you must also select Enabled in the Status select box.
  • Start Empty - check this to indicate that the current contents of the file are to be deleted at system startup
  • Backward Recovery - check this to indicate that the file is a protected resource changes to which can be backed out. The file must be accessed through a Fileshare server.
  • Forward Recovery - check this to indicate that journals are to be used to record changes to the file to enable forward recovery. The file must be accessed through a Fileshare server.
  • Allow Duplicate Keys - check this if the file can have duplicate keys. The file must be an alternate index (Type set to Alt index) and you must have unchecked Use Catalog, because if you use the catalog this information is stored there, not in the FCT entry.
  • EBCDIC Collating Sequence - check this to indicate that the EBCDIC collating sequence is to be used. You must uncheck Use Catalog before you can check this, because if you use the catalog this information is stored there, not in the FCT entry.
Remote SYSID

Specify the system ID of the remote system on which the file resides. The name specified must be the same as that given in Name in the SysC or Sys62 definition.

Use Catalog must be unchecked before you can specify a system ID for the remote system. This is because the catalog is used only for storing information about files held locally.

Remote File

Specify the name of the file on the remote system. Use Catalog must be unchecked before you can specify a name for a remote file. This is because the catalog is used only for storing information about files held locally.

Override File Name

Specify the filename of the physical file if you want to override the default. Do not include the file extension. Can be up to 255 characters.

If you do not specify this entry, the physical file name defaults to the name of the FCT entry.

You cannot use this default if you specify a Fileshare server; you must specify a physical file name.

Use Catalog must be unchecked before you can specify a filename. This is because if you use the catalog this information is stored there, not in the FCT entry.

File Extension

Specify the file extension of the physical file if you want to override the default. Can be up to 3 characters. Use Catalog must be unchecked before you can specify an extension. This is because if you use the catalog this information is not required.

File Path

Specify the path of the physical file if you want to override the default. Do not include the filename or file extension. Can be up to 255 characters. Use catalog must be unchecked before you can specify a path. This is because if you use the catalog this information is stored there, not in the FCT entry.

Fileshare Server

Specify the ID of the Fileshare server on which the file resides. Can be up to 16 characters. You must uncheck Use Catalog before you can specify a Fileshare server. This is because if you use the catalog this information is stored there, not in the FCT entry.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - Enables all the resource keys
  • Off - Disables all the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Active, Display

Click this to display the currently installed definition of this resource.

Active, Install

Click this to install (make active) this resource.

Delete

Click this to delete this FCT. You see this button only if you have editing permissions for the group to which the FCT belongs.

Copy

Click this to create a new FCT using the entries specified on this page.

Dump

Click this to create and view a dump of the FCT.

Parent topic: Pages for Viewing and Editing Resources


CICS JCT - jct_name (group_name)

Use this page to view and, if you have the you have the required permissions, edit the JCT jct_name, selected from the CICS Group group_name page.

The title bar gives details of the JCT you are editing and the resource group it belongs to.

Group List

Click this to display the CICS Group group_name page.

Apply

Click this to save changes you have made to the page and refresh the page. This button is only displayed if you have permission to edit the group in which the JCT resides.

Name

Shows the name of this JCT.

Description

Specify adescription of the JCT. The description can be up to 60 characters long.

Type

Choose the type of journal:

  • Disk 1 - a journal on disk that has one data set to be reused when full.
  • Disk 2 - a journal on disk that has two data sets to be used alternately. You must specify this to minimize operator involvement during a takeover.
  • Disk 2 Pause - a journal on disk that has two data sets to be used alternately. When the second data set is full, the system is paused to enable the operator to copy the data sets to another location before resuming with the first data set.
  • SMF - mainframe System Management Facility format.
  • Tape 1 - a journal on one tape drive.
  • Tape 2 - a journal on two tape drives.
File Name

Specify the filename of the journal.

File Path

Specify the pathname of the journal file.

Extension

Specify the filename extension of the journal file.

Fileshare

Specify the name of the Fileshare server that controls this data set.

Record Max

Specifies the maximum length of a record in the journal file.

Record Min

Specifies the minimum length of a record in the journal file.

Initial State

Choose the initial status of the journal:

  • New - a new journal data set is created at system initialization.
  • Append - data is appended to an existing journal data set.
Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys
  • Off - disables all the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Delete

Click this to delete this JCT. You see this button only if you have editing permissions for the group to which the JCT belongs.

Copy

Click this to create a new JCT that uses the values in this JCT.

Dump

Click this to create and view dump information for this JCT.

Parent topic: Pages for Viewing and Editing Resources


CICS PCT - pct_name (group_name)

Use this page to view and, if you have the required permissions, to edit the PCT pct_name.

The title bar gives the name (pct_name) of the PCT you are editing and the resource group (group_name) it belongs to.

Click Apply to save changes you make to the page then refresh the page. This button is displayed only if you have permission to edit the group in which the PCT resides.

Group List

Click this to display the CICS Group page group_name.

Name

Shows the name for this PCT.

Description

Specify a description of the transaction program (can be up to 60 characters).

Program Name

For local programs only, specify the name of the application program to be run when this transaction is invoked. Leave this field blank if you enter a value in the remote system ID field.

Can be up to eight characters (A-Z, 0-9, #, @, or $). The name is translated to upper case.

Work Area

Specify the size of the transaction program's Transaction Working Area (TWA) in bytes, in the range 0 through 32767.

Remote SysID

Specify the system ID of the remote system. The name specified must be the same as that given in Name in the SysC or Sys62 definition.

Remote PCT

Specify the transaction ID of the transaction program on the remote system. You must specify Remote SysID before you can specify a transaction ID.

Can be up to four alphanumeric characters, the first of which must be a letter. Do not use the letter C as the first character; transaction IDs beginning with C are reserved for use by MSS.

Status

Choose a status for the transaction program:

  • Enabled - the transaction program is enabled.
  • Disabled - the transaction program is disabled.
In Doubt

Choose what is to happen if a transaction program using intersystem communication abends at a critical moment during syncpoint or abend processing:

  • Backout - the effects of the transaction are backed out using ROLLBACK. To use this option, files used by the transaction program must have Backward recovery checked on the FCT page.
  • Commit - any changes are committed.
  • Wait - critical resources are locked until the session has recovered, and are then backed out or committed in step with the remote system.
Upper Case

Check this if you want the transaction program to translate input into upper case

Tracing

Choose the type of tracing to be performed for the transaction program:

  • None - No tracing is performed.
  • Normal - Tracing is performed.
  • Special - Special tracing is performed.
Dynamic Route

Check this to have the program status (local or remote) determined dynamically at user invocation time. If this is unchecked, the program status is made local or remote according to the value of System ID.

Security

Use these check boxes to control the way in which resource authorization checks are performed. If they are not checked, the only check performed will be to confirm that the user has authority to run the transaction. If you check RLS (Resource Level Security), Enterprise Server will check the user's authorization for all resources that the transaction accesses (e.g. file access, TDQ, TSQ, LINK, DPL, START and so on). Checking CMD(for Command) will check the authorization on all the EXEC CICS command operations (e.g. EXEC CICS SET/ENABLE/DISABLE).

Note that IBM Category 3 Transactions do not have security checking at all, so the transactions are allowed for everyone with no authorization calls.

Priority

Specify the transaction priority of the transaction program in the range 0 through 255, where 255 is the highest priority.

The priority of a transaction is the sum of:

  • The terminal priority
  • The transaction priority (this field)
  • The operator priority

This sum must not be greater than 255.

Dump on ABEND

Check this to create a program dump if the transaction program abends.

3270 Screen

Specify the screen size to be used by the transaction program. Select:

  • Default to use the default screen size (as defined in the Typeterm entry).
  • Alternate to use the alternate screen size (as defined in the Typeterm entry).
Inbound

Check this to indicate that this transaction can be initiated by an inbound user action.

Input Timeout

Specify the maximum time in seconds allowed for operator response to an explicit CICS RECEIVE, WEB OPEN, WEB SEND, WEB RECEIVE, or WEB CONVERSE command before this transaction is abended. A value of 0 indicates that there is no timeout, and the system will wait indefinitely for a response.

Check Use System Value to use the system wide value for Input Timeout (as shown on the ESMAC Control screen) rather than the PCT entry.

Runaway Timeout

Specify the maximum continuous period of time in seconds that the region will allow this transaction to run without making a CICS, EZASOKET or MQSeries API call. When this time is exceeded, the transaction is abended. A value of 0 indicates that there is no timeout.

Check Use System Value to use the system wide value for Runaway Timeout (as shown on the ESMAC Control screen) rather than the PCT entry.

Deadlock Timeout

Specify the maximum time in seconds that the region will permit this transaction to wait for a resource that has been locked by another process. A value of 0 indicates that there is no timeout.

Check Use System Value to use the system wide value for Deadlock Timeout (as shown on the ESMAC Control screen) rather than the PCT entry.

Transaction Threshold

Specify the maximum length of time in seconds that a transaction can run before a message is logged to the console to indicate that it has exceeded its threshold. A value of 0 indicates that there is no threshold.

Check Use System Value to use the system wide value for the transaction time threshold (as shown on the ESMAC Control screen) rather than the PCT entry.

Resource Keys, all

Choose a setting to apply to the resource keys:

  • On - enables all the resource keys.
  • Off - disables all the resource keys.

Check any of the boxes 1 through 24 to activate that resource key.

Security Keys, all

Choose a setting to apply to the security keys:

  • On - enables all the security keys.
  • Off - disables all the security keys.

Check any of the boxes 1 through 64 to activate that security key.

Active

Click Display to display the currently installed definition of this resource.

Click Install to install (make active) this resource.

Delete

Click this to delete this PCT. You see this button only if you have editing permissions for the group to which the PCT belongs.

Copy

Click this to create a new PCT, using the values set on this page as the basis for the new PCT.

Dump

Click this to create and view dump information for this PCT.

Parent topic: Pages for Viewing and Editing Resources


CICS PLT - plt_name (group_name)

Use this page to view and edit the PLT plt_name, selected from the CICS Group group_name page.

The title bar gives details of the PLT you are editing and the resource group it belongs to.

Group List

Click this to display the CICS Group page group_name.

Apply

Click this to save changes you have made to the page, and refresh the page. You see this button only if you have permission to edit the PLT.

Name

Shows the name of the PLT.

Description

Specify a description of the PLT (can be up to 60 characters).

01 - nn

Shows a numbered list of programs.

Note that, if you can edit the PLT, there is always a blank field added at the end of the list.

You can add a new program in the blank field, if required. If you do so, you must click Apply. The page is refreshed, and the new program is added to the list.

You can edit a program name by clicking in the name and making your changes. Your changes do not take effect until you click Apply.

You can change the order of the programs in the PLT. Use Down arrow button to move a program down the list. Use Up arrow button to move a program up the list.

Delete an entry in the PLT by clicking Delete button.

Run once/Run in each process

Click Run once to specify that the program should only run once, when the PLT is first initiated. Click Run in each process to specify that the program should run every time the PLT is initiated.

Delete

Click this to delete this PLT. You see this button only if you have editing permissions for the group to which the PLT belongs.

Copy

Click this to create a new PLT, using the values set on this page as the basis for the new PLT.

Dump

Click this to create and view dump information for this PLT.

Parent topic: Pages for Viewing and Editing Resources


CICS PPT - PPT_name (group_name)

Use this page to edit the PPT PPT_name, selected from the CICS Group group_name page.

The bar at the top of the page gives details of the PPT you are editing and the resource group it belongs to.

Group List

Click this to display the CICS Group page group_name.

Apply

Click this to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the group in which the PPT resides.

Name

Shows the name for this PPT.

Description

Specify a description of the transaction program (can be up to 60 characters).

Status

Choose a status for the program:

  • Enabled - enables this program to be used in a normal manner.
  • Disabled - prevents the program from being used until specifically enabled using master terminal services.
Type

Choose a type for the resource:

  • Program - this resource is a program.
  • Data Area - this resource is a data table.
Resident

Check this if you want to enable this program to reside in the application server's program cache after it has been loaded.

Commarea

Specify the amount of storage to be allocated to the communications area (COMMAREA) to enable MSS to behave like mainframe CICS. The size is in the range 0 through 32767. The effect of this is that when a program is passed a COMMAREA smaller than the COMMAREA defined in the program, the passed COMMAREA is automatically extended in length to fill the defined space.

Language

Choose the language the program is written in.

Save, Working Storage

Check this to have load requests ignored if the program is already in storage.

Uncheck this to have a fresh copy of the program loaded every time a load request for the program is issued.

Remote SysID

If the program resides in a remote region, specify the 4-character, remote system identifier (as defined in the TCT).

If the program resides in the local region, leave this field blank.

Rmt Trans ID

Specify the transaction ID of the transaction program on the remote system. A System ID must be specified before a transaction ID can be specified.

The remote transaction ID can be up to four alphanumeric characters, the first of which must be a letter. Do not use the letter C as the first character; transaction IDs beginning with C are reserved for use by MSS.

Remote Prog

If the program resides in a remote region, specify the name by which the program is known there. Remote SysID must be specified before a remote program ID can be specified.

If you specify a remote system ID but leave this field blank, the local identifier for this program will be sent to the remote region.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys
  • Off - disables all the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Active, Display

Click this to display the currently installed definition of this resource.

Active, Install

Click this to Install (make active) this resource.

Delete

Click this to delete this PPT. You see this button only if you have editing permissions for the group to which the PPT belongs.

Copy

Click this to create a new PPT using the entries specified on this page.

Dump

Click this to create and view a dump of this PPT.

Parent topic: Pages for Viewing and Editing Resources


CICS Sys62 - sys62_name (group_name)

Use this page to view and edit the Sys62 sys62, selected from the CICS Group group_name page. A Sys62 is a definition of an LU6.2 system connection.

The title bar gives details of the Sys62 you are editing and the resource group it belongs to.

Group List

Click this to display the CICS Group group_name page.

Apply

Click this to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the group in which the Sys62 resides.

Name

Shows the name of this Sys62.

Description

Specify a short description of the Sys62. Acceptable characters are A through Z, 0 through 9, $, @ and #.

LU Alias

Specify the parameter used to connect this definition to the LU6.2 protocol stack definition for this connection.

Mode Table

Specify the parameter that tells the LU6.2 protocol stack which Mode (or session characteristics) Table to use for this connection.

Partner Alias

Specify the parameter required to associate this definition with a peer server's definition within the LU6.2 protocol stack definitions.

APPLID

Specify the SNA Application ID of the peer partner server for this connection.

Net Name

Specify the network name that identifies the remote system. The name can be up to eight characters in length. The name follows assembler language rules. It must start with an alphabetic character. The acceptable characters are: A-Z 0-9 $ @ and #. Lower-case characters are converted to upper case except when using the CREATE command.

Net Name is the APPLID of the remote system or region, unless you are defining an APPC or LUTYPE6.1 link to a VTAM generic resource group. If you are defining an LUTYPE6.1 link to a generic resource, Net Name must specify the generic resource name, not the APPLID of one of the group members. If you are defining an APPC link to a generic resource, Net Name can specify either the group’s generic resource name or the APPLID (member name) of one of the group members. However, if you specify a member name, and this CICS is not itself a member of a CICS Transaction Server for OS/390 generic resource, the connection must always be acquired by this CICS. For VTAM, the APPLID is the label of the remote ACF/VTAMÑ VBUILD TYPE=APPL statement. If you do not supply a Net Name, the CONNECTION name is used by default. You cannot have two or more APPC links with the same Net Name.

Session Max

Specify the maximum number of parallel sessions allowed to be active on this LU.

Transaction

Specify the permanent four character transaction code to be attached to handle unsolicited input.

Priority

Specify the facility related priority to be used for work that is running with this as the primary facility.

In Service

Check this to enable this facilityto default to (or start initially as) being “in service”.

User ID

Specify the permanent user ID for this LU. Any work running against this facility will inherit the permissions of this user ID.

Language

Specify the default language for user interfaces connected to this facility.

Session Name

Specify the name for the session.

Attach

Specify the level of attach-time user security required for the connection:

  • Identify - Incoming attach requests must specify a user identifier. IDENTIFY is used when the connecting system has a security manager; for example, if it is another CICS system.
  • Local - The authority of the user is taken to be that of the link itself, and you rely on link security alone to protect your resource. Local must be specified if the PROTOCOL attribute on the CONNECTION definition is LU6.1.
  • Mixed - Incoming attach requests may be using either or both IDENTIFY or PERSISTENT security types. The security type actually used depends on the incoming attach request.
  • Persistent - Incoming attach requests must specify a user identifier and a user password on the first attach request. Subsequent attach requests require only the user identifier. This should be used only between a PWS (programmable workstation, for example, an IBM Personal System/2) and CICS.
  • Verify - Incoming attach requests must specify a user identifier and a user password. Enter Verify when the connecting system has no security manager and hence cannot be trusted. Do not specify Verify for CICS-to-CICS communication, because CICS does not send passwords.
Oper ID

Specify the three-character operator ID associated with the permanent user ID - returned on ASSIGN OPID() command for transaction attached to this facility.

Oper Priority

Specify the operator-related priority for transactions running against this facility.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all of the resource keys
  • Off - disables all of the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Delete

Click this to delete this Sys62. You only see this button if you have editing permissions for the group to which the Sys62 belongs.

Copy

Click this to create a new Sys62, using the values set on this page as the basis for the new Sys62.

Dump

Click this to create and view dump information for this Sys62.

Parent topic: Pages for Viewing and Editing Resources


CICS SysC - sysc_name (group_name)

Use this page to view and edit the SysC sysc_name, selected from the CICS Group group_name or CICS Startup List startup_list page. A SysC is a definition of a CCI system connection.

The title bar gives details of the SysC you are editing and the resource group it belongs to.

Group List

Click this to display the CICS Group page group_name.

Apply

Click this to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the group in which the SysC resides.

Name

Shows the name of this SysC.

Description

Specify a description of the transaction program (can be up to 60 characters).

Machine Name

Specify the machine name; consists of the Local LU Alias of the client machine and the Mode used by CCIAPPC when issuing the APPC ALLOCATE verb to initiate a conversation with the server TP. The machine name must be specified in the following format:

LUNAME.MODENAME

where the parameters are:

LUNAME | The Local LU Alias of the client machine. This name must also be defined as a Partner LU Alias on the server machine.
MODENAME | A Mode defined on both the client and server machines.
Protocol

Specify the CCI protocol to be used by this connection.

MF Node

Specify the text hostname or dotted decimal address of the target server.

MF Port

Specify the decimal value of the port that the target server listens on.

Net Name

Specifiy the name of the network over which the connection is established.

Session Max

Specify the maximum number of sessions that can use this connection.

Transaction

Specify the one- to four-character transaction ID. When MSS receives a request to start a transaction, it only looks at the first four characters of the TP name.

Priority

Specify the priority for transactions run from this terminal. Defaults to 0 (zero). Terminal priority is one factor in determining a transaction's execution priority, which is the sum of:

  • Terminal priority (this field)
  • Transaction priority
  • Operator priority

The sum cannot be greater than 255.

In Service

Check this to specify that the connection defined by this Sys62 is in service.

User ID

Specify a user ID to be associated with the connection. Mandatory if no sign-on takes place on the connection.

Language

Choose the national language in which messages are sent over the connection. You can choose English or Kanji.

Session Name

Specify the security name of the connection. Can be up to eight alphanumeric characters from the set A through Z, 0 through 9, $, @ and #.

Attach

Choose the level of security required when a user issues an attach request over this connection:

  • Identify - incoming attach requests must specify a user ID.
  • Verify - incoming attach requests must specify both a user ID and a password.
  • Persistent - the first attach request must specify both a user ID and a password, but subsequent attach requests require only a user ID.
  • Mixed - incoming attach requests can specify either Identify or Persistent.
  • Local - the authority of the user is taken to be that of the link.
Oper ID

Specify an operator ID used for routing messages. Specify this for a terminal that cannot be signed on, such as a printer. If you specify an operator ID for a terminal that can be signed on, it is overridden by the operator ID specified in the user's sign-on table entry. Up to three alphanumeric characters.

Oper Priority

Specify the operator priority for transactions run from this terminal. Specify this for a terminal that cannot be signed on, such as a printer. If you specify it for a terminal that can be signed on, it is overridden by the operator priority specified in the user's sign-on table entry. Defaults to 0(zero). Operator priority is one factor in determining a transaction's execution priority, which is the sum of:

  • Terminal priority
  • Transaction priority
  • Operator priority (this field)

The sum cannot be greater than 255.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys
  • Off - disables all the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that security key.

Delete

Click this to delete this SysC. You only see this button if you have editing permissions for the group to which the SysC belongs.

Copy

Click this to create a new SysC that uses the values in this SysC.

Dump

Click this to create and view dump information for this SysC.

Parent topic: Pages for Viewing and Editing Resources


CICS T-Type - ttype_name (group_name)

Use this page to view and edit the T-type (terminal type definition) ttype_name. group_name indicates the group to which this T-type belongs.

The title bar gives details of the T-type you are editing and the resource group it belongs to.

Group List

Click this to display the CICS Group page group_name.

Apply

Click thtis to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the group in which the T-type resides.

Name

Shows the name for this T-type.

Description

Specify a description of the T-type. The text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.

Type

Choose the type of terminal device:

  • 3270 - A 3270 display device
  • Non-Facility - A non-physical device
  • Generic - Non-specific facility definition
  • ECI - External Call Interface dummy facility
  • System - A peer CICS or ES server
  • Printer - Printer device
  • Dialog Sys - Dialog System client facility
Shippable

Check this to indicate that this physical terminal definition may be shipped to a remote system in support of a transaction routing request. Ifa physical terminal definition is not marked shippable, then the target system must have the terminal explicitly defined as a remote terminal for the transaction routing request to succeed.

Map Size, Width

Specify the page width for the terminal type being defined. The width is defined as a number of columns, in the range 0 through 999. The default is 80.

Map Size, Height

Specify the page height for the terminal type being defined. The height is defined as a number of rows, in the range 0 through 999. The default is 24.

Alternate Map, Width

Specify the page size for the terminal type being defined, if you have specified an alternate screen size (non-default values for Alt Screen, Width and Alt Screen, Height). Alternate page size width is defined as a number of columns, in the range 0 through 999. The default is 80. Unexpected results may occur if the number of columns is not the same as the number of columns you specify for Alt Screen, Width. Defaults to the values specified in Map Size, Width.

Alternate Map, Height

Specify the page size for the terminal type being defined, if you have specified an alternate screen size (non-default values for Alt Screen, Width and Alt Screen, Height). Alternate page size height is defined as a number of rows, in the range 0 through 999. Unexpected results may occur if the number of columns is not the same as the number of columns you specify for Alt Screen, Height. Defaults to the values specified in Map Size, Height.

OB Oper ID, Yes

Check this to enable MSS to use the outbound operator identifiers to support the BMS routing facilities required by this terminal type definition.

Outboard Fmt, Yes

Check this to enable MSS BMS to delegate part of the presentation formatting to the client facility.

ASCII

Choose whether or not this terminal type has an ASCII feature:

No | The terminal type does not have an ASCII feature
7 Bit | Terminals of this type are ASCII-7 terminals. All outbound data is translated to 7-bit ASCII, and all inbound data is translated to EBCDIC
8 Bit | Terminals of this type are ASCII-8 terminals. All outbound data is translated to 8-bit ASCII, and all inbound data is translated to EBCDIC
Send Size

Specify the size, in bytes, of the receive buffer of a terminal of this type. This represents the maximum amount of data that the terminal can receive, and depends on the capability of the device. Considerations of line quality might lead you to specify a buffer size that is less than the terminal type's maximum buffer size. A message longer than the receive buffer is broken into as many request units as are necessary. Defaults to 0 (zero). If you specify a zero buffer size, the message is not broken up; the whole message is presented.

Receive Size

Specify the maximum size, in bytes, of a request unit that can satisfy a receive request. The value you specify may be rounded down.

Routed Msg

Indicates whether or not messages are routed to a terminal of this type by the EXEC CICS ROUTE command. Check this to indicate that BMS is to route to this terminal messages that are destined for all terminals, as well as messages destined for this terminal. If not checked, no messages are routed to this terminal, even if they are specifically destined for this terminal.

Logon Msg

Check this to specify that the logon transaction is initiated when a session is established and displays the logon message on the terminal. Automatic Transaction Initiation (ATI) is used to start the transaction, so you must check ATI. The transaction competes with any other ATI transactions for use of the terminal. If you check Lastline, the logon message does not overwrite any error message currently displayed.

Auto Connect

Check this to specify that a session is to be established with the terminal when the region starts up. Leave unchecked to specify that a session is to be established when the user signs on at the terminal.

ATI

Check this to enable a transaction to be automatically initiated on this terminal. If you leave this unchecked, you should check TTI to enable users to initiate transactions.

Create Sess

Check this to specify that a session can be initiated from a terminal of this type: EXEC START requests and Automatic Transaction Initiation (ATI) requests are allowed to create sessions automatically. Leave unchecked to specify that EXEC START requests and Automatic Transaction Initiation (ATI) requests are not allowed to create sessions automatically. Such requests are queued or rejected if a session has not been established.

TTI
Check this to enable users to initiate transactions at this terminal. If you leave this unchecked, you should check ATI to enable transactions to be automatically initiated.
NEP Class

Specify the transaction class of the node error program. Defaults to 0 (zero), which indicates that the default node error program is to be used.

Signoff
Choose which action is to be taken when GNTRAN (CESF or user-defined transaction) is attached and attempts to sign off the terminal. If you are using RACF 1.9 or later, specify the TIMEOUT limit in the RACF segment:
No | The terminal is not automatically signed off in the absence of user input.
Signoff | When the specified time has elapsed after the last input from the operator, the terminal is automatically signed off from CICS.
Signoff/Logoff When the specified time has elapsed after the last input from the operator, the terminal is automatically signed off from CICS and then logged off from VTAM. (This is not supported for TCAM-attached terminals.) LOGOFF is useful for an autoinstall model, because virtual storage is not wasted on entries for terminals that have been timed out. If GNTRAN fails to attach because of unprocessed data in the terminal buffer (resulting in a BID failure), the terminal will be signed off and logged off. GNTRAN will not run and will have no effect.
Note: You cannot change the value of this attribute when DEVICE(APPC) is specified. The default value in that case is SIGNOFF(NO).
Notify
Choose how the user is notified of system recovery. This option applies to the recovery of sessions for terminals in a CICS region running with either VTAM persistent sessions or with XRF. It is for use in situations where a terminal user may have to take action, such as sign on again, after a CICS restart:
None | The user is not notified.
Message | A message is displayed on the screen to say that the system has recovered. The message is specified in two BMS maps; DFHXRC1 and DFHXRC2 for XRF; and DFHXRC3 and DFHXRC4 for VTAM persistent sessions. These maps are in map set DFHXMSG. If reduced takeover time is important, use MESSAGE rather than TRANSACTION. The terminal must be capable of displaying BMS maps, and ATI.must be checked, to specify this option.
Transaction | A transaction is initiated at the terminal. The name of the transaction is specified by the RMTRAN system initialization parameter. (The default transaction for RMTRAN is the one specified in the GMTRAN system initialization parameter: the good-morning transaction.) If reduced takeover time is important, use MESSAGE rather than TRANSACTION. ATI must be checked to specify this option.
Option

Choose how MSS recovers the session and returns the terminal to normal service.

Sys Default | MSS selects the best recovery strategy based on session activity and the characteristics of the terminal.
Clear Receive | MSS sends a CLEAR request to reset the conversation state, or an UNBIND request if the session does not support the CLEAR request. MSS sends the CLEAR or UNBIND request only if the session was busy.
Release Sess | MSS sends an UNBIND request to clear the active session, if the session was busy.
Unconditional | MSS sends an UNBIND request to clear the active session, whether or not the session was busy.
None | The terminal session is not automatically recovered. If you checked Auto Connect, the terminal is automatically reconnected.
Last Line

Check this to specify that error messages are to be displayed at the bottom of the screen: If checked, an error message is displayed at the bottom of the screen, starting at a position that enables the entire message to be shown at once. If messages are received in quick succession, an earlier message might be overwritten before the user has time to read it. Messages displayed in this way may have the additional attributes specified by Intensify, Color and Highlight. If Last Line is not checked, an error message is displayed at the current cursor position, and without any additional attributes.

Intensify

Check this to have error messages displayed in an intensified field (bold). This only has an effect if Last Line is checked.

Color (Diagnostic Display)

Choose the color in which error messages are to be displayed on a terminal of this type. A setting other than No takes effect only if Last Line is checked.

Highlight (Diagnostic Display)

Choose the type of highlighting to be used for error messages displayed on a terminal of this type. A setting other than No takes effect only if Last Line is checked.

Def. Screen, Width

Specify the default screen width for the 3270 terminal type being defined. This is the screen width that is used when a transaction definition specifies a default screen. Screen width is defined as columns, in the range 0 through 999. The default is 80. There is no validity checking; incorrect sizes might lead to unpredictable behavior.

Def. Screen, Height

Specify the default screen height for the 3270 terminal type being defined. This is the screen height that is used when a transaction definition specifies a default screen. Screen height is defined as rows, in the range 0 through 999 The default is 24. There is no validity checking; incorrect sizes might lead to unpredictable behavior.

Alt. Screen, Width

Specify the alternate screen width for the 3270 terminal type being defined. This is the screen size that is used when a transaction definition specifies an alternate screen. Screen width is defined as columns, in the range 0 through 999. The default is 80. There is no validity checking; incorrect sizes might lead to unpredictable behavior.

Alt. Screen, Height

Specify the alternate screen height for the 3270 terminal type being defined. This is the screen size that is used when a transaction definition specifies an alternate screen. Screen height is defined as rows, in the range 0 through 999 The default is 24. There is no validity checking; incorrect sizes might lead to unpredictable behavior.

APL Keyboard

Check this to specify that the terminal type has the APL keyboard feature.

APL Text

Check this to specify that the terminal type can support the APL text character set.

Audible Alarm

Check this to specify that the terminal type has the audible alarm feature.

Color

Check this to specify that the terminal type has the color feature, which enables colors to be selected for individual fields.

Dual case kbd

Check this to specify that the terminal has a typewriter keyboard. Leave this unchecked to specify that the terminal has an operator console keyboard. Both types of keyboard transmit both upper-case and lower-case data.

Copy (Device Properties)

Check this to specify that the terminal type has the copy feature.

Extended DS

Check this to specify that the terminal type supports extensions to the 3270 data stream. You must check this if Color or Hilight are checked.

Highlight

Check this to specify that the terminal type has the extended highlight feature, enabling individual fields or characters to be displayed in bold, reverse video, or blinking.

Katakana

Check this to specify that the terminal type is a Katakana terminal. Katakana terminals do not support mixed case output. Upper-case characters appear as upper-case English, but lower-case characters appear as Katakana characters.

Light Pen

Check this to specify that the terminal type has the light pen selector feature. MSS emulates this feature using mouse clicks.

Form Feed

Check this to specify that the device has the form feed feature.

CGSCID

Specify the coded graphic character set global identifier (CGCSGID) that enables transaction programs to determine what character set is supported by this terminal. Defaults to 0,0, which means that the terminal type does not support this feature. The first field specifies the graphic character set global identifier (GCSGID), and the second field specifies the code page global identifier (CPGID).

Horizontal FF

Check this to specify that the device has the horizontal form feature. The devices that can use this feature are batch, batch data interchange, interactive, SCSPRT or LUTYPE4 logical units. If checked, BMS uses horizontal tabbing when formatting output documents. If unchecked, the HTAB option in the BMS map definition is ignored.

Vertical FF

Check this to specify that the device has the vertical form feature. The devices that can use this feature are batch, batch data interchange, interactive, SCSPRT or LUTYPE4 logical units. If checked, BMS uses vertical tabbing when formatting output documents. If unchecked, the VTAB option in the BMS map definition is ignored.

EWA Support

Check this to enable a 3270 device to shift its display into its alternate mode.

SOSI

Check this to specify that the terminal type supports mixed EBCDIC and DBCS fields.

PS

Check this to specify that the terminal type supports the programmed symbol facility. This facility enables you to use a maximum of six sets of 191 characters.

Outline

Check this to specify that the terminal type supports field outlining.

Numeric Lock

Check this to enable the numeric lock.

Buffer

Check this to specify that BMS buffers formatted data streams that are sent to a terminal of this type, that is, when an application issues a series of SEND TEXT PRINT commands, MSS sends a page to the terminal only when it is full. Leave thus unchecked to specify that when an application issues a series of SEND TEXT PRINT commands, MSS sends a page to the terminal for every command issued, filling up the page by appending blank lines if necessary.

Print Adapter

Check this to specify that output BMS screens with the PRINT option set on are copied automatically to an attached printer.

Transparency

Check this to enable background transparency.

Query

Check this to enable MSS to use the QUERY structured field to determine the characteristics of the device.

Text KB

Check this to specify that the 3270 device has the text-keyboard feature.

Mag Stripe Rdr

Check this to specify that the terminal type has the magnetic stripe reader feature. MSS emulates this feature using mouse clicks.

Validation

Check this:

  • For 8775 devices to enable the extended validation feature, which allows fields to be defined as TRIGGER, MANDATORY FILL, or MANDATORY ENTER.
  • For 3290 devices to enable the validation feature, which allows fields to be defined as MANDATORY FILL or MANDATORY ENTER.
Partition Support

Check this to enable the device to use partitions. This option is not valid for SCS printers.

Build Chain

Check this to specify that MSS is to reassemble request units into complete messages before passing data from a terminal of this type to a transaction program. Leave this unchecked to specify that messages are to be received by the transaction program in individual request units.

User Area

Specify the size, in bytes, of the user area of a terminal of this type. Defaults to 0 (zero).

In Shared Stg

Check this to force the user area into shared storage such hat it can be accessed by transactions that do not have this device as the primary facility.

Uppercase Trans

Choose how data entered in data entered in lower case is to be treated:

Yes | Data input in lower case is translated to upper case.
No | Data input in lower case is not translated to upper case.
Tranid | Transaction identifiers input in lower case are translated to upper case; not other input data is translated.
I/O Area

Specify the minimum and maximum sizes, in bytes, of the terminal I/O area to be passed to a transaction program when it issues a RECEIVE. If you enter a number in the first field, a terminal I/O area of at least that size is passed to the transaction program. If you specify values in both fields, and a message longer than that specified by the first field, but shorter than that specified by the second field is received, then a terminal I/O area of the maximum size is passed to the transaction program. A message longer than that specified by the second field causes the node abnormal condition program to send an exception response to the terminal. Defaults to 0,0. If you check ATI, you must specify a terminal I/O area of at least one byte.

Active, Display

Click this to display the currently installed definition of this resource.

Active, Install

Click this to install (make active) this resource.

Delete

Click this to delete this T-type. You only see this button if you have editing permissions for the group to which the T-type belongs.

Copy

Click this to create a new T-type, using the values set on this page as the basis for the new T-type.

Dump

Click this to create and view dump information for this T-type.

Parent topic: Pages for Viewing and Editing Resources


CICS Term - term_name (group_name)

Use this page to view and edit the Term term_name, selected from the CICS Group group_name page.

The title bar gives details of the Term you are editing and the resource group it belongs to.

Group List

Click this to display the CICS Group page group_name.

Apply

Click this to save changes you have made to the page, and refresh the page and add the new JCT to the group you specify in Grp. You see this button only if you have editing permissions for the group to which the FCT belongs.

Name

Shows the name for this Term.

Description

Specify the description for this Term.

Model

Choose whether or not this terminal definition can be used as a model terminal definition for autoinstall:

  • No - can be used only for a specific device that is not autoinstalled.
  • Yes - can be used as a model for autoinstall, as well as for a specific device that is not autoinstalled.
  • Only - can be used only as a model for autoinstall.
Model Name

Applicable only if Model is Yes or Only. Specify the name by which the definition is known to the Autoinstall Control Program. Specify a name of up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Defaults to the name of this Term.

Terminal Type

Specify the associated Typerterm definition, which must exist. Mandatory.

Net Name

Specify the terminal's network name. Mandatory if Model is Yes or No. Specify a name of up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. The first character must be a letter.

Remote Name

Specify the remote name. Applicable only for remote terminals. Necessary only if it differs from the local terminal name.

Remote SysID

Specify the remote system ID that holds the terminal definition. Applicable only for remote terminals. This must correspond to either:

  • The Local SYSID field in the SIT used to run the related remote MSS region.
  • The APPLID of another CICS system.
Transaction

Specify a transaction name. This specifies the only transaction that users can run from this terminal, apart from print and paging requests. Optional. If not specified, users can run any transaction from this terminal.

Priority

Specify the priority for transactions run from this terminal. Defaults to 0 (zero). Terminal priority is one factor in determining a transaction's execution priority, which is the sum of:

  • Terminal priority (this field)
  • Transaction priority
  • Operator priority

The sum cannot be greater than 255.

In Service

Check this to specify that this terminal is in service; that is, transactions can be initiated and messages sent.

Main Printer

Specify the printer used for handling print requests. This printer must be owned by the system that owns the terminal. The name can be up to four characters in length.

Prt. Copy

Check this to specify that the hardware copy feature (using the printer defined for this terminal) is used for print requests issued from this terminal.

Alternate Printer

Specify the printer used for handling print requests if the printer specified in Main Printer is unavailable. This printer must be owned by the system that owns the terminal. The name can be up to four characters in length.

Alt. Prt. Copy

Check this to specify that the hardware copy feature (using the alternate printer defined for this terminal) is to be used for print requests issued from this terminal.

User ID

Specify a user ID to be associated with the terminal. Mandatory if no sign-on takes place on the connection.

Language

Specify the national language in which messages are sent over the connection. You can select English or Kanji.

Session Name

Specify the security name of the terminal. Required only if the terminal is owned by a remote system and the connection method is APPC. Can be up to eight alphanumeric characters from the set A through Z, 0 through 9, $, @ and #.

Attach

Choose the level of security required when a user issues an attach request from this terminal:

  • Identify - incoming attach requests must specify a user ID
  • Verify - incoming attach requests must specify both a user ID and a password
  • Persistent - the first attach request must specify both a user ID and a password, but subsequent attach requests require only a user ID
  • Mixed - incoming attach requests may specify either Identify or Persistent
  • Local - the authority of the user is taken to be that of the link
Oper ID

Specify an operator ID to be used for routing messages. Specify this for a terminal that cannot be signed on, such as a printer. If you specify an operator ID for a terminal that can be signed on, it is overridden by the operator ID specified in the user's sign-on table entry. Up to three alphanumeric characters.

Oper Priority

Specify the operator priority for transactions run from this terminal. Specify this for a terminal that cannot be signed on, such as a printer. If you specify it for a terminal that can be signed on, it is overridden by the operator priority specified in the user's sign-on table entry. Defaults to 0 (zero). Operator priority is one factor in determining a transaction's execution priority, which is the sum of:

  • Terminal priority
  • Transaction priority
  • Operator priority (this field)

The sum cannot be greater than 255.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys
  • Off - disables all the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Active, Display

Click this to display the currently installed definition of this resource.

Active, Install

Click this to install (make active) this resource.

Delete

Click this to delete this Term. You see this button only if you have editing permission for the group to which the Term belongs.

Copy

Click this to create a new Term using the entries specified on this page.

Dump

Click this to create and view dump information for this Term.

Parent topic: Pages for Viewing and Editing Resources


CICS TST - tst_name (group_name)

Use this page to view and edit the TST pct_name, selected from the CICS Group group_name page.

The title bar gives details of the TST you are editing and the resource group it belongs to.

Group List

Click this to display the CICS Group page group_name.

Apply

Click this to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the group in which the TST resides.

Name

Shows the name for the TST.

Description

Specify a description for the TST (can be up to 60 characters).

Recoverable

Check this to enable recovery of the temporary storage queue in the event of an abnormal termination of either MSS or the transaction processing the destination.

Name (Remote Queue)

Specify the name of a temporary storage queue.

SYSID

Specify the system or region in which the temporary storage queue resides. The name specified must be the same as that given in Name in the SysC or Sys62 definition.

Resource Keys, all

Choose a setting to apply to all the resource keys:

  • On - enables all the resource keys
  • Off - disables all the resource keys
Resource Keys, 1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Security Keys, all

Choose a setting to apply to all the security keys:

  • On - enables all the security keys
  • Off- disables all the security keys
Security Keys, 1 - 64

Check any of the boxes 1 through 64 to activate that security key.

Delete

Click this to delete this TST. You only see this button if you have editing permissions for the group to which the TST belongs.

Copy

Click this to create a new TST using the entries specified on this page.

Dump

Click this to create and view dump information for this TST.

Parent topic: Pages for Viewing and Editing Resources


CICS XAT - xat_name (group_name)

Use this page to view and, if you have the required permissions, edit the XAT xat_name, selected from the CICS Group group_name page. An XAT is an XA-compliant database table.

The title bar gives details of the XAT you are editing and the resource group it belongs to.

Group List

Click this to display the CICS Group page group_name.

Apply

Click this to save changes you have made to the page and refresh the page. This button is displayed only if you have permission to edit the group in which the XAT resides.

Name

Shows the name of this XAT.

Description

Specify a description of the XAT. Acceptable characters are A through Z, 0 through 9, $, @ and #.

Switch Module

Specify the location of the executable file (.dll) that contains the entry point that returns the xa_switch_t structure to the enterprise server.

DB Name

Specify the name by which the resource manager is known.

User ID

Specify a resource manager ID, used internally to identify a particular XA configuration. This must be unique within the enterprise server.

Password

Specify the password required for the User ID. If you are entering a new password, you have to confirm it by entering it in PW Verify.

PW Verify

Specify the password again, if you are creating a new password, to verify you have entered it correctly.

Open String, Free Format

Specify the string that is passed to the resource manager on the xa_open() call. An entry in this field usually contains at least the database name, and the user ID and password for connecting to the database. The contents of this string are database-specific.

For DB2, the contents are documented in IBM's DB2 Administration Guide; for additional information see the Application Programmer's Guide.

For Oracle, see the Oracle Application Developer's Guide - Fundamentals.

Where the resource manager supports dynamic registration, and the database vendor requires the name of the module that provides the ax_reg function, you should specify casaxlib.

Close String, Free Format

Specify the string that is passed to the resource manager on the xa_close() call. To find out whether or not you need to supply Close string, see your database vendor's documentation.

Load Module

Choose an external resource manager that the server needs to communicate with on behalf of container-managed applications.

Load Module, Name

if you chose User in Load Module, specify the name of the module that supplies the run-time support for the database calls made by the application.

Delete

Click this to delete this XAT. You see this button only if you have editing permissions for the group to which the XAT belongs.

Copy

Click this to create a new XAT using the entries specified on this page.

Dump

Click this to create and view dump information for this XAT.

Parent topic: Pages for Viewing and Editing Resources


CICS URIMAP - urimap_name (group_name)

Use this page to view and edit the URIMAP pct_name, selected from the CICS Group group_name page.

Click Apply to save changes you have made to the page and refresh the page.

Name
The name of this URIMAP definition. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the URIMAP have been saved and the entry updated. Click Refresh to remove this message.
Description
A description of this URIMAP definition.
Status
Specifies whether this URIMAP definition is installed in an enabled or disabled state.
Usage
Specifies whether this URIMAP definition is for:
  • CICS as an HTTP server
  • CICS as an HTTP client
Universal Resource Identifier:
Scheme
The scheme component of the URI.
Port
The number of the port used by the user application when it communicates with a server.
Host
The host name, or IPv4 or IPv6 address, of the URI.
Path
The path component of the URI.
Associated CICS Resources:
TCPIPService
The name of a TCPIPSERVICE resource definition that defines an inbound port.
Analyzer
Indicates whether an analyzer program is used in processing the HTTP request.
Converter
The name of a converter program used to convert (or perform other processing) on the request and response.
Transaction
The name of an alias transaction used either to run the user application that composes the HTTP response, or to start the pipeline.
Program
The name of the user application program that composes the HTTP response.
Pipeline
Not supported for this release.
WebService
Not supported for this release.
Security Attributes:
Ciphers
A string of up to 56 hexadecimal digits that is interpreted as a list of up to 28 2-digit cipher suite codes.
Certificate
The label of the X.509 certificate that is used as the SSL client certificate during the SSL handshake.
Authenticate
Specifies whether to send basic authentication information in the HTTP response.
Static Document Properties:
Not supported for this release.
Redirection:
Not supported for this release.
Parent topic: Pages for Viewing and Editing Resources


CICS TCPIPSERVICE - tcpipservice_name (group_name)

Use this page to view and edit a the TCPIPSERVICE tcpservice_name, selected from the CICS Group group_name page.

Click Apply to save changes you make to the page, and refresh the page.

Name
The name of this TCPIPSERVICE definition. If you click Apply, the message "Update complete" is also displayed when the changes you have made to the definition have been saved and the entry updated. Click Refresh to remove this message.
Description
A description of this definition.
URM
The name of a user-replaceable program that this service invokes.
Port No
The number of the port on which CICS listens for incoming client requests.
Status
Specifies the initial status of the service after installation, either OPEN if CICS is to begin listening for this service after installation, or CLOSE if not.
Protocol
The application level protocol used on the TCP/IP port.
Transaction
The ID of the CICS transaction to process new requests that this service receives.
Backlog
Not supported for this release.
TSQ Prefix
A code to identify items in the temporary storage queue (TSQ).
IP Address
Not supported for this release.
Socket Close
Not supported for this release.
Max Data Length
Not supported for this release.
Security:
Not supported for this release.
DNS Connection Balancing:
Not supported for this release.
Parent topic: Pages for Viewing and Editing Resources


CICS DOCTEMPLATE - doctemplate_name (group_name)

Use this page to view and edit the DOCTEMPLATE doctemplate_name, selected from the CICS Group group_name page.

Click Add to save changes you have made to the page, refresh the page and add the new template to the group you specify in Grp. When you click Add, the button changes to Apply.

Name
The name of this template.
Grp
The group to which this resource belongs. Do not use group names beginning with "DFH" as these are reserved for use by CICS.
Description
A description of this template. This can be up to 58 characters long.
Append CR/LF
Specifies whether CICS deletes trailing spaces from, and appends carriage return/line feed to, each logical record of the template.
Content Type
The format of the template contents, either BINARY or EBCDIC. If you choose BINARY, when the template is loaded its contents are not parsed; if you select EBCDIC, the template contents are parsed as EBCDIC text.
Template Name
The name by which the template is know to application programs that use it. The name can be up to 48 characters long. If you do not enter a value, it defaults to the value of Name.
Template Type
The type for the source of the template.
Enter details for one of the following:
File
The name of a CICS file which contains the template. This name can be up to eight characters long.
TS Queue
The name of a temporary storage queue containing the template. This name can be up to 16 characters long.
TD Queue
The name of a transient storage queue containing the template. This name can be up to four characters long.
Program
The name of the CICS program that contains the template. This name can be up to 48 characters long. If you do not specify a value, the template name is used.
Exit Program
The name of the exit program that generates this template. This name can be up to eight characters long.
MVS PDS
The details of an MVS partitioned data set (PDS) containing the template.
  • DD Name, the name of the PDS. This name can be up to eight characters long. The default is "DFHHTML".
  • Member Name, the name of a member in the PDS. This name can be up to eight characters long.
HFS File
The name of a z/OS UNIX System Services file containing the template. This can be either the absolute name including all directories and beginning with a slash, or a name relative to the home directory of the CICS region. The name can be up to 255 characters long.
Parent topic: Pages for Viewing and Editing Resources


Users

  • Users List
  • Create a New CICS SNT
  • View and Edit a CICS SNT
Parent topic: Enterprise Server Monitor and Control (ESMAC)


Users List

Use this page to view the users defined for this server.

New

Click this to create a new user.

Details

Click this to display information about a user.

The information in the rest of the row shows you the name of the user, the operator ID, and a short description of the user.

Parent topic: Users


Create a New CICS SNT

Use this page to create a new user for ESMAC.

If you displayed this page by clicking Copy on a previous page, the values on the previous page are used as the basis for the new SNT.

If you displayed this page by clicking New on a previous page, some values on this page are already set to default values.

Add

Click this to save changes you have made to the page, refresh the page, and add the user.

Name

Specify the user's name.

Description

Specify a short description of this SNT.

Password

Specify a password for this user. The maximum number of characters is 8.

Repeat PW

Respecify the password to ensure that it has been entered correctly.

Upper Case

Check this to force the password into upper case.

Remove PW
Check this to remove the password from the resource definition file. If no password is specified the user does not require a password.
Operator ID

Specify an operator ID. This is a three-character code that identifies the user to applications.

Priority

Specify the operator priority for transactions. Defaults to 0 (zero). Operator priority is one factor in determining a transaction's execution priority, which is the sum of:

  • Terminal priority
  • Transaction priority
  • Operator priority (this field)

The sum cannot be greater than 255.

Timeout

Specify the maximum interval in minutes since the last activity of an ESMAC or TN3270 client before the user ID is automatically logged off. The default value is 0, meaning no timeout. This value overrides ID Timeout on the SIT page.

Note: Terminal timeouts (SIT parameter or user ID parameter) must be less than 16 hours.
Group Prefix

Do not use. The group prefix is a Mainframe Express feature that gives developers control over resource groups with a specific name prefix.

Oper Class

Specify a value for the operator class, which is normally used for message routing but can be used for any user/application relationship.

Resource Keys
all
Choose a setting to apply to all the resource keys:
  • On - enables all the resource keys
  • Off - disables all the resource keys
1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Security Keys
all
Choose a setting to apply to all the resource keys:
  • On - enables all the security keys
  • Off - disables all the security keys
1 - 64
Check any of the boxes 1 through 64 to activate that security key.
Surrogate Keys
all
Choose a setting to apply to all the surrogate keys:
  • On - enables all the surrogate keys
  • Off - disables all the surrogate keys
1 - 24

Check any of the boxes 1 through 24 to activate that surrogate key.

JCL Submit

Check this to enable this user to submit JCL jobs via the cassub utility.

ES Security

Check this for the user ID mfuser to enable ESMAC security.

ESMAC Access
Master Flag

Check this to enable the user to access the main ESMAC screens. If unchecked, the user will only be able to view summary server information and environment variables.

all
Choose a setting for the level of access the user will have to all types of resource:
  • Rd - sets all items to read access
  • Upd - sets all items to update access
  • No - denies access for all items
JES - XAT

Choose what type of access this user can have to a resource of this type:

  • Rd - sets the item to read access
  • Upd - sets the item to update access
  • No - sets the item to no access
Parent topic: Users


View and Edit a CICS SNT

Use this page to view information about the SNT you selected from the Users page. You can view information about the SNT, and change various parameters of the SNT.

Apply

Click this to save changes you have made to the page and refresh the page. You see this button only if you have permission to edit the SNT.

Name

Shows the name for this SNT.

Description

Specify a short description for this SNT.

Password

Specify the password for this user. The maximum number of characters is 8.

Repeat PW

Specify the password again, if you are changing the password, to ensure that it has been entered correctly.

Upper Case

Check this to force the password into upper case.

Operator ID

Specify an operator ID. This is a three-character code that identifies the user to applications.

Priority

Specify the operator priority for transactions. Defaults to 0 (zero). Operator priority is one factor in determining a transaction's execution priority, which is the sum of:

  • Terminal priority
  • Transaction priority
  • Operator priority (this field)

The sum cannot be greater than 255.

Timeout

Specify the maximum interval in minutes since the last activity of an ESMAC or TN3270 client before the user ID is automatically logged off. The default value is 0, meaning no timeout. This value overrides ID Timeout on the SIT page.

Note: Note that Terminal timeouts (SIT parameter or user ID parameter) must be less than 16 hours.
Group Prefix

Do not use. The group prefix is an Mainframe Express feature that gives developers control over resource groups with a specific name prefix.

Oper Class

Specify a value for the operator class, which is normally used for message routing but can be used for any user/application relationship.

Resource Keys
all
Choose a setting to apply to all the resource keys:
  • On - enables all the resource keys
  • Off - disables all the resource keys
1 - 24

Check any of the boxes 1 through 24 to activate that resource key.

Security Keys
all
Choose a setting to apply to all the resource keys:
  • On - enables all the security keys
  • Off - disables all the security keys
1 - 64
Check any of the boxes 1 through 64 to activate that security key.
Surrogate Keys
all
Choose a setting to apply to all the surrogate keys:
  • On - enables all the surrogate keys
  • Off - disables all the surrogate keys
1 - 24

Check any of the boxes 1 through 24 to activate that surrogate key.

JCL Submit

Check this to enable this user to submit JCL jobs via the cassub utility.

ES Security

Check this for the user ID mfuser to enable ESMAC security.

ESMAC Access
Master Flag

Check this to enable the user to access the main ESMAC screens. If unchecked, the user will only be able to view summary server information and environment variables.

all
Choose a setting for the level of access the user will have to all types of resource:
  • Rd - sets all items to read access
  • Upd - sets all items to update access
  • No - denies access for all items
JES - XAT

Choose what type of access this user can have to a resource of this type:

  • Rd - sets the item to read access
  • Upd - sets the item to update access
  • No - sets the item to no access
Delete

Click this to delete this SNT. You only see this button if you have editing permissions for the SNT.

Copy

Click this to create a new SNT using the entries specified on this page.

Dump

Click this to create and view dump information for this SNT.

Parent topic: Users


Env.Vars.

Use this page to view information about the environment variables used by this server.

Name

Lists all of the environment variables currently in use by the server.

Value

Lists the values for all of the environment variables listed in the Name column.

Parent topic: Enterprise Server Monitor and Control (ESMAC)


Dyn-Dbg.

Use this page to view the debugging criteria for active dynamic debug sessions. You can use X to remove the entry for a particular session.

Type

The type of application or service being debugged.

Criteria

The criteria used to identify the application or service instance to debug.

Parent topic: Enterprise Server Monitor and Control (ESMAC)


System Sign On

Use this page to sign on to the system. You can also use this page to change your password.

Sign On

Click this to sign on. You must first enter your user ID and password.

ID

Enter your user ID.

Password

Enter the password associated with your user ID.

Group
The group of which this user is a member.
New Password

If you want to create a new password for your user ID, enter it in this field. You must enter your current password in the Password field before you can change your password.

Repeat PW

Confirm your new password by re-entering it in this field.

Default

Click this to sign onto the system using the default user ID, and display the System page. Any changes you made to the page before you clicked Default are lost.

Parent topic: Enterprise Server Monitor and Control (ESMAC)


Listeners

Use this page to view a list of the communications processes and service listeners registered for the currently selected server. From this page you can also:

  • Make some specific edits to a communications process
  • Create a communications process by copying an existing one
  • Delete a communications process
  • Edit the configurable settings of a listener
  • Add a new listener

To access this page:

  1. On the server instance screen, select the Listeners tab.
Listener Display Filters

Use this group of fields to apply filters to the list of listeners so that you can just view a subset.

Note:

It is possible to specify filters such that no information is displayed.

Process

Choose an option for filtering by communications process:

All | To list all service listeners regardless of communications process
None | To list no service listeners
n | To list just the service listeners that belong to communications process n
Conversation Type (filter)

Choose an option for filtering by conversation type:

All | To list all service listeners regardless of conversation type
Custom | To list service listeners with a custom conversation type
Web Services and J2EE | To list Web Services and J2EE service listeners
Web | To list Web service listeners
Fileshare | To list Fileshare service listeners
TN3270 | To list service listeners for TN3270 clients (MSS only)
MSS ISC | To list service listeners for MSS Intersystem Communication
Status

Choose an option for filtering by status:

All To list all service listeners regardless of status
status-type To list service listeners with the status status-type, where status-type can be one of:
  • Started
  • Stopped
  • Disabled
  • Blocked
  • Not Responding; this means any listener whose status is unknown because the server it is registered with is not responding to the server monitor
  • Not Started; this means any listener with a status other than Started
  • Not Stopped; this means any listener with a status other than Stopped
Auto-start

Check this to indicate that this communications process is started automatically when the enterprise server starts.

Statistics

Click this to see detailed information about the listener activity on this enterprise server. The information is shown in a new window. You can click this only if the enterprise server is started.

Change

Changes into Stop or Start when the enterprise server is started.

Stop

Click this to stop the communications process and all its listeners. You can click this only if the enterprise server is started, the communications process is started, and this communications process is not Communications Process 1.

Start

Click this to start the communications process and all its listeners. You can click this only if the enterprise server is started, the communications process is not started, and this communications process is not Communications Process 1.

Copy

Click this to create a new communications process by copying this one.

Delete

Click this to delete this communications process. If a server only has one communications process you cannot delete it.

Edit (communications process)

Click this to edit configurable settings for this communications process.

Listeners

Shows the number of listeners owned by this communications process.

Add

Click this to add a new listener.

Process ID

Shows the process ID of this communications process.

Control Channel Address

Shows the internal address used by the communications process for communicating with other components of the enterprise server. The format is:

protocol:ip-address:port

where:

  • protocol is tcp.
  • ip-address is either the text host name or IP address of the communications process. An asterisk (*) indicates that the address is dynamically assigned for the communications process when it starts.
  • port is the port value. An asterisk (*) indicates that the port is dynamically assigned for the communications process when it starts.

Under the network address is the DNS-resolved TCP/IP hostname.

Status (communications process)

Shows the current status of the communications process. The possible statuses are:

Not responding | The communications process status is unknown because the server it is registered with is not responding to the server monitor.
Started | The communications process is running.
Stopped | The communications process is stopped.
Last Status Change (communications process)

Shows the time that the communications process's current status was last updated; this time is local to the machine where the Directory Server is running.

Status Log (communications process)

Shows information about the most recent event that occurred on this communications process.

Version

Shows the version string of the communications process. This consists of three elements in decreasing order of significance: major version, minor version, build version. This can be used to distinguish between communications processes of the same name.

Edit (listener)

Click this to edit configurable settings for this listener.

Name

Shows the name of the service listener.

Address

Shows the network address used by the listener to accept incoming client requests. The format is:

protocol:ip-address:port

where:

  • protocol is tcp.
  • ip-address is either the text host name or IP address of the server listener. An asterisk (*) indicates that the address is dynamically assigned for the listener when it starts.
  • port is the port value. An asterisk (*) indicates that the port is dynamically assigned for the listener when it starts.

Under the network address is the DNS-resolved TCP/IP hostname.

Status (listener)

Shows the current status of the service listener. The possible statuses are:

Blocked | The listener is started when the server starts, but it does not accept client requests.
Disabled | The listener is stopped and is therefore not available to any client
Invalid | An error has occurred such that it has not been possible to set the status to any other value
Not responding | The listener status is unknown because the server it is registered with is not responding to the server monitor
Started | The server listener is running.
Stopped | The listener is stopped.
Start Pending | The SSL-enabled communications process is waiting for you to enter a password to give access to its private key. Less commonly, a password may also be required to give access to its certificate. To do this, click Authorize. On the page that appears in a second browser, enter the password (leave the certificate password blank unless it's required) and click Set Passphrases. Then close that browser.
Last Status Change (listener)

Shows the time that the listener's current status was last updated; this time is local to the machine where the Directory Server is running.

Status Log (listener)

Shows information about the most recent event that occurred on this listener.

Conversation Type

Shows the conversation type of the listener.

Custom Configuration Data

Shows optional textual configuration information that determines the start-up and run-time behavior of the listener. For details of the entries, see the section Configuration Information in the chapter Communications Processes and Service Listeners in your Configuration and Administration Guide.

Description

Shows an optional text description of the listener, for example, its purpose and owner.

  • Add Listener
  • Edit Listener
  • Delete Listener
  • Copy Communications Process
  • Edit Communications Process
  • Delete Communications Process
Parent topic: Enterprise Server Administration Console Help Pages


Add Listener

Use this page to add a new service listener to the selected communications process.

To access this page:

  1. On the Listeners screen, in the Communications process area, click Edit.
Name

Specify the unique name of the new service listener, up to 255 characters in length. You cannot include angle brackets (<>) or ampersands (&) in the name.

Endpoint Protocol

Specify the communications protocol used by the listener to accept incoming client requests. TCP is the only option.

Endpoint Address

Specify the network address used by the listener to accept incoming client requests. The format is:

ip-address:port

where:

  • ip-address is either the text host name or IP address of the server listener. An asterisk (*) indicates that the address is the IP address of the current machine.
  • port is the port value. An asterisk (*) indicates that the port is dynamically assigned for the listener when it starts.

If this network address is not unique in the repository, this may cause listener startup problems.

Secure Sockets Layer

Not currently used.

Legacy Micro Focus Application Format

Check this if you want the listener to handle non-standard TCP/IP flows, for example, for Fileshare clients.

Initial Status

Choose a status from the list. The possible statuses are:

Blocked | The listener is started when the server starts, but it does not accept client requests. One use for this status is where you want to allow requests from only one client, perhaps for debugging purposes. You could amend the client code to ignore a status of "Blocked"and allow requests through.
Disabled | The listener is not started when the server starts and is therefore not available to any client
Stopped | The listener is available but stopped. This is the default. To start a listener use the Edit Listener page. When you add a stopped listener to a server that has a status of "Started", the server will attempt to start the listener immediately. If you add a stopped listener to a server that has a status of "Stopped", when the server is started it will attempt to start the listener.
Supported Conversation Type

if you chose TCP in Endpoint Protocol, click one button to choose a conversation type:

  • Web Services / J2EE for client requests that use a conversation protocol supported by the request handlers provided by Micro Focus, MFRHBINP and MFRHSOAP.
  • Web for World Wide Web (HTTP) client requests. Enterprise Server uses a Web listener for service deployment.
  • Fileshare for Fileshare client requests.
  • TN3270 for client requests for CICS transations that use the TN3270 protocol. You can only use TN3270 listeners with Mainframe Subsystem Support.
  • MSS ISC for client requests from non-CICS programs for CICS transactions. You can only use MSS Inter System Communications listeners with Mainframe Subsystem Support.
  • Custom for other kinds of client requests. Specify the name of the connector module in the entry field next to Custom.
Configuration Information

Specify textual configuration information that determines the startup and run-time behavior of the listener. Optional. For details of the valid entries, see the section Configuration Information in the chapter Communications Processes and Service Listeners in your Configuration and Administration Guide.

Description

Specify an optional text description of the listener, for example, its purpose and owner. Optional.

Add

Click this to add the listener to the current server.

Parent topic: Listeners


Edit Listener

Use this page to change configurable attributes of a listener.

To access this page:

  1. On the Listeners screen, next to the listener to edit, click Edit.
Servers

Click this to return to the list of all the servers on this Directory Server, on the Home page.

Listeners

Click this to view a list of all the service listeners registered with the current server.

Services

Click this to view a list of all the services registered with the current server.

Handlers

Click this to view a list of all the request handlers registered with the current server.

Packages

Click this to view a list of all the packages registered with the current server.

Name

Specify the unique name of the listener, up to 255 characters in length. You cannot include angle brackets (<>) or ampersands (&) in the name.

Connection Endpoint

Specify the network address used by the listener to accept incoming client requests. The format is:

protocol:ip-address:port

where:

  • protocol is tcp.
  • ip-address is either the text host name or IP address of the server listener. An asterisk (*) indicates that the address is dynamically assigned for the listener when it starts.
  • port is the port value. An asterisk (*) indicates that the port is dynamically assigned for the listener when it starts.

If this network address is not unique in the repository, this may cause listener start-up problems.

Secure Sockets Layer

This is accessible if you have the Micro Focus Security Pack installed.

Legacy Micro Focus Application Format

Check this if you want the listener to handle non-standard TCP/IP flows, for example, for Fileshare clients.

Current Status

Shows the current status of the listener:

Blocked | The listener is started when the server starts, but it does not accept client requests.
Disabled | The listener is stopped and is therefore not available to any client
Invalid | An error has occurred such that it has not been possible to set the status to any other value
Not responding | The listener status is unknown because the server it is registered with is not responding to the server monitor
Started | The server listener is running.
Stopped | The listener is stopped.
New Status

Choose a status from the list. If the status of the server is "Started", the possible listener statuses are:

Blocked | The listener is still running but will not be found by clients searching for this listener in a "Started" state. One use for this status is where you want to allow requests from only one client, perhaps for debugging purposes. You could amend the client code to ignore a "Blocked" status and allow requests through.
Disabled | The listener is stopped and will not be started.
Started | The server listener is started.
Stopped | The listener is stopped.

If the status of the server is "Stopped", the possible statuses are:

Blocked | The listener is stopped. The listener is started when the server starts, but will not be found by clients searching for this listener in a "Started" state. One use for this status is where you want to allow requests from only one client, perhaps for debugging purposes. You could amend the client code to ignore a "Blocked" status and allow requests through.
Disabled | The listener is stopped and it will not be started when the server starts.
Stopped | The listener is stopped. It will be started when the server starts.
Supported Conversation Type

Shows the conversation type of the listener.

  • MFES Requests for client requests that use a conversation protocol supported by the request handlers provided by Micro Focus, MFRHBINP and MFRHSOAP.
  • Custom for other kinds of client requests. Specify the name of the connector module in the entry field next to Custom.
Configuration Information

Specify textual configuration information that determines the start-up and run-time behavior of the listener. Optional.

Description

Specify a text description of the listener, for example, its purpose and owner. Optional.

Apply

Click this to apply your changes to the listener.

Delete

Click this to delete the listener. You cannot delete a listener if it is registered for use with a service.

Parent topic: Listeners


Delete Listener

Use this page to delete the selected listener.

To access this page:

  1. On the Listeners screen, next to the listener to edit, click Delete.
CAUTION:

Deleting a registered listener may cause application connection errors and loss of data

Name

Shows the name of the listener.

Connection Endpoint

Shows the network address used by the listener to accept incoming client requests. The format is:

protocol:ip-address:port

where:

  • protocol is tcp.
  • ip-address is either the text host name or IP address of the server listener. An asterisk (*) indicates that the address is dynamically assigned for the listener when it starts.
  • port is the port value. An asterisk (*) indicates that the port is dynamically assigned for the listener when it starts.
Current Status

Shows the current status of the service listener. The possible statuses are:

Blocked | The listener is started when the server starts, but it does not accept client requests.
Disabled | The listener is stopped and is therefore not available to any client
Invalid | An error has occurred such that it has not been possible to set the status to any other value
Not responding | The listener status is unknown because the server it is registered with is not responding to the server monitor
Started | The server listener is running.
Stopped | The listener is stopped.
Description

Shows a text description of the listener.

Parent topic: Listeners


Copy Communications Process

Use this page to create a new communications process by copying the details of an existing communications process.

To access this page:

  1. On the Listeners screen, in the Communications process area, click Edit.
Control Channel Address

Specify the network address used by the communications process to accept incoming client requests. The format is:

protocol:ip-address:port

where:

  • protocol is tcp.
  • ip-address is either the text host name or IP address of the communications process. An asterisk (*) indicates that the address is the IP address of the current machine.
  • port is the port value. An asterisk (*) indicates that the port is dynamically assigned for the communications process when it starts.

If this network address is not unique in the repository, this may cause communications process startup problems.

Secure Sockets Layer

Not currently used.

Auto-start

Check this to indicate that the new communications process is started automatically when the enterprise server is started. If you copy a communications process while the enterprise server is running, and you check this, the new communications process is started immediately.

Parent topic: Listeners


Edit Communications Process

Use this page to change configurable attributes of a communications process.

To access this page:

  1. On the Listeners screen, in the Communications process area, click Edit.
Control Channel Address

Specify the network address used by the communications process to accept incoming client requests. The format is:

protocol:ip-address:port

where:

  • protocol is tcp.
  • ip-address is either the text host name or IP address of the communications process. An asterisk (*) indicates that the address is dynamically assigned for the communications process when it starts.
  • port is the port value. An asterisk (*) indicates that the port is dynamically assigned for the communications process when it starts.

If this network address is not unique in the repository, this may cause communications process startup problems.

Secure Sockets Layer

Not currently used.

Configuration Information

Specify textual configuration information that determines the start-up and run-time behavior of the communications process. Optional. You cannot change this if the enterprise server has a status of "Started". For details of the valid entries, see the section Configuration Information in the chapter Communications Processes and Service Listeners in your Configuration and Administration Guide.

Parent topic: Listeners


Delete Communications Process

Use this page to delete the selected communications process.

CAUTION:

Deleting a communications process may cause application connection errors and loss of data.

Name

Shows the name of the communications process.

Address

Shows the network address used by the communications process to accept incoming client requests. The format is:

protocol:ip-address:port

where:

  • protocol is tcp.
  • ip-address is either the text host name or IP address of the communications process. An asterisk (*) indicates that the address is dynamically assigned for the communications process when it starts.
  • port is the port value. An asterisk (*) indicates that the port is dynamically assigned for the communications process when it starts.
Listeners

Shows the number of listeners owned by the communications process.

Parent topic: Listeners


Services

Use this page to view a list of the services registered for the currently selected server. From this page you can also:

  • Edit the configurable settings of a service
  • Add a new service
Service Display Filters

Use this group of fields to apply filters to the list of services so that you can just view a subset.

Note:

It is possible to specify filters such that no information is displayed.

Service

Specify a service namespace to see just the details for that service namespace.

Class

Choose an option for filtering by service class:

All | To list all service namespaces regardless of service class
Some | To list those service namespaces that have a value in Service Class
None | To list those service namespaces that have no value in Service Class
Handler

Choose an option for filtering by request handler:

All | To list all service namespaces regardless of which request handler is associated with the service
Some | To list those service namespaces that have a value in Request Handler
None | To list those service namespaces that have no value in Request Handler
Package

Choose an option for filtering by implementation package:

All | To list all service namespaces regardless of which implementation package is associated with the service
Some | To list those service namespaces that have a value in Implementation Package
None | To list those service namespaces that have no value in Implementation Package
Show

Specify the number of service namespaces to show at a time. If you change this, you have to click Refresh to see the effect.

Previous

Click this to view the previous page of service namespaces. You can click this only if the number of service namespaces is greater than can be shown on one page.

Next

Click this to view the next page of service namespaces. You can click this only if the number of service namespaces is greater than can be shown on one page.

Edit

Click this to edit configurable settings for the service.

Service Namespace

Shows the service namespace. For more information about service namespace and service operation see your Configuration and Administration book.

Operation

Shows the name of the operations in the service namespace.

Service Class

Shows the class of the service. This field provides a means of grouping services, so that a client program can ask for a class of service rather than a specific named service. Service classes beginning with MF are reserved for Micro Focus use.

Search Order

Shows the search order of the service. The lower the search order, the higher the search priority where there is more than one service object of the same name in the repository.

Listeners

Lists the listeners allocated to this service. For each listener the fofllowing information is shown:

  • The communications process that it belongs to, for example CP1 (communications process 1)
  • Its name
  • Its address in both IP address and hostname formats
Request Handler

Shows the name and path of the request handler for this service.

Implementation Package

Shows the name of the implementation package for this service.

Current Status

Shows the current status of the service. The possible statuses are:

Available | The service is available.
Invalid | An error has occurred such that it has not been possible to set the status to any other value.
Disabled | The service is disabled.
Status Log

Shows information about the most recent event that occurred on this service.

Custom Configuration

Shows optional textual configuration information that determines the start-up and run-time behavior of the service. For details of the entries, see the section Configuration Information in the chapter Services, Packages and Request Handlers in your Configuration and Administration Guide.

Description

Shows an optional text description of the service.

Add

Click this to add a new service.

  • Edit Service
  • Delete Service
  • Delete Service Operation
Parent topic: Enterprise Server Administration Console Help Pages


Edit Service

Use this page to change configurable attributes of a service.

CAUTION:

Changing the properties of a registered service may cause application connection errors and loss of data

Name

Specify the name of the service, up to 255 characters. You cannot include angle brackets (<>) or ampersands (&) in the name.

A service name can consist of a service namespace and an operation name, separated by a special character. The character depends on which request handler is being used, MFRHSOAP or MFRHBINP.

If there is no separating character, the name of the operation is considered to be the same as the service namespace.

If the service will be using the MFRHSOAP request handler, the text before the first pound character (#) in the name is considered to be the service namespace and the text after is considered to be the name of the operation.

If the service will be using the MFRHBINP request handler, the text before the last period character (.) in the name is considered to be the service namespace and the text after is considered to be the name of the operation.

Note:

You can change the name of a service only when the server has a status of "Stopped".

Search Order

Specify the search order of the service. If more than one service object has the same name, then a program client can use Search Order to decide which service to use. The lower the search order is, the higher the search priority.

Service Class

Specify the service class of the service (optional). This field provides a means of grouping services, so that a client program can ask for a class of service rather than a specific named service. Service classes beginning with MF are reserved for Micro Focus use. Service Class can be up to 32 characters in length.

Version

Specify the version string of the service. This consists of three elements in decreasing order of significance: major version, minor version, build version. This can be used to distinguish between services of the same name or class.

Logging

Check this to request that for each request for this service the request and response blocks are written to the enterprise server dump data set. Only use this option if you need diagnostics as it degrades performance.

Transaction Management

Click one button to choose the type of transaction management that this service uses:

  • Application for a service in which the COBOL application manages their own transactions.
  • Container for a service in which the COBOL application leaves transaction management to the application container.

If the client is transactional, such as a J2EE transactional request, this setting is ignored and the service is forced to be container-managed. Container-managed services should not make any explicit transactional requests, for example, EXEC SQL COMMIT WORK statements.

Current Status

Shows the current status of the service. The possible statuses are:

Available | The service is available.
Invalid | An error has occurred such that it has not been possible to set the status to any other value
Disabled | The service is disabled.
New Status

Choose a status from the list. The possible statuses are:

Available | The service is available.
Disabled | The service is disabled.
Accepting Listeners

Shows the listeners that will accept incoming client requests.

Available Listeners

Lists the listeners that are available to be allocated to this service. Click a listener to select it for adding to Accepting Listeners. A service can have more than one listener.

Remove

Click this to remove the selected listener from Accepting Listeners. There must be more than one listener in Accepting Listeners before you can click this.

Add

Click this to add the selected listener to Accepting Listeners.

Available Handlers

Lists the available request handlers. Click a request handler to select it to become the Associated Handler. You must add a listener before you can see Available Handlers and associate a handler with the service.

Select Handler

Click this to make the selected request handler the Associated Handler.

Associated Handler

Shows the request handler that is associated with this service, if any.

Available Packages

Lists the available implementation packages. Click a package to select it to become the Associated Package. You must add a listener before you can see Available Packages and associate a package with the service.

Select Package

Click this to make the selected package the Associated Package.

Associated Package

Shows the implementation package that is associated with this service, if any.

Configuration Information

Specify textual configuration information that determines the startup and run-time behavior of the service. Optional. For details of the valid entries, see the section Configuration Information in the chapter Services, Packages and Request Handlers in your Configuration and Administration Guide.

Description

Specify a text description of the service, for example, its purpose and owner. Optional.

Parent topic: Services


Delete Service

Use this page to delete a service and all of its operations. You can also optionally delete the packages associated with the operations.

CAUTION:

Deleting registered services and packages may cause application connection errors and loss of data.

Full Name

Shows the full name of the service, consisting of service namespace, separator and operation name

Service Class

Shows the service class of the service.

Version

Shows the version string of the service. This consists of three elements in decreasing order of significance: major version, minor version, build version.

Listener

Shows the listener associated with the service operation.

Request Handler

Shows the request handler associated with the service operation.

Implementation Package

Shows the implementation package associated with the service operation.

Description (service)

Shows a text description of the service operation.

Name

Shows the name of the package associated with the service operation.

IDT

Shows the pathname of the interface definition table (IDT) associated with the service operation.

Description (package)

Shows a text description of the package.

Delete associated packages

Check this to delete the packages associated with the service.

Delete

Click this to delete this service, its operations and optionally the associated packages.

Parent topic: Services


Delete Service Operation

Use this page to delete an individual service operation, or a service that contains no operations.

CAUTION:

Deleting a registered service may cause application connection errors and loss of data.

Name

Shows the name of the service.

Service Class

Shows the service class of the service.

Version

Shows the version string of the service. This consists of three elements in decreasing order of significance: major version, minor version, build version.

Listener

Shows the listener associated with the service.

Current Status

Shows the current status of the service. The possible statuses are:

Available | The service is available.
Invalid | An error has occurred such that it has not been possible to set the status to any other value.
Disabled | The service is disabled.
Status Log

Shows information about the most recent event that occurred on this service.

Description

Shows a text description of the service.

Delete

Click this to delete this service.

Parent topic: Services


Handlers

Use this page to view a list of the request handlers registered for the currently selected server. From this page you can also:

  • Edit the configurable settings of a request handler
  • Add a new request handler
Edit

Click this to edit configurable settings for the server or one of the request handlers.

Module Name

Shows the filename of the request handler.

Module Path

Shows the path where the request handler file is located.

Current Status

Shows the current status of the request handler. The possible statuses are:

Enabled | The handler is enabled
Invalid | An error has occurred such that it has not been possible to set the status to any other value
Disabled | The handler is disabled
Status Log

Shows information about the most recent event that occurred on this handler.

Custom Configuration

This field is not used.

Description

Shows an optional text description of the handler.

Add

Click this to add a new request handler.

  • Edit Handler
  • Add Handler
Parent topic: Enterprise Server Administration Console Help Pages


Edit Handler

Use this page to change configurable attributes of a request handler

Module Name

Specify the name of the request handler, up to 255 characters.

Note: Note:

You can change the name of a handler only when the server has the status "Stopped". You cannot include angle brackets (<>) or ampersands (&) in the name.

Current Status

Shows the current status of the request handler. The possible statuses are:

Enabled | The handler is enabled
Invalid | An error has occurred such that it has not been possible to set the status to any other value
Disabled | The handler is disabled
New Status

Choose a status from the list. The possible statuses are:

Enabled | The handler is enabled. This is the default
Disabled | The handler is disabled
Note:

You can change the status of a handler only when the server has the status "Stopped".

Module Path

Specify the path where the request handler file is located.

Configuration Information

This field is not used.

Description

Specify a text description of the request handler, for example, its purpose and owner. Optional.

Delete

Click this to delete the handler.

Note:

You cannot delete the MFRHBINP request handler.

Parent topic: Handlers


Add Handler

Use this page to add a new request handler to a server.

Module Path

Specify the path where the request handler file is located.

Status

Choose a status from the list. The possible statuses are:

Enabled | The handler is enabled. This is the default.
Disabled | The handler is disabled.
Configuration Information

This field is not used.

Description

Specify a text description of the request handler, for example, its purpose and owner. Optional.

Add

Click this to add the handler to the selected server.

Parent topic: Handlers


Packages

Use this page to view a list of the implementation packages registered for the currently selected server. From this page you can also:

  • Edit the configurable settings of an implementation package
  • Add a new implementation package
Show

Specify the number of packages to show at a time. If you change this, you have to click Refresh to see the effect.

Previous

Click this to view the previous page of packages. You can click this only if the number of packages is greater than can be shown on one page.

Next

Click this to view the next page of packages. You can click this only if the number of packages is greater than can be shown on one page.

Edit

Click this to edit configurable settings for the implementation package.

Name

Shows the name of the package.

Current Status

Shows the current status of the package. The possible statuses are:

Available | The package is available. This is the default.
Invalid | An error has occurred such that it has not been possible to set the status to any other value.
Disabled | The package is disabled.
Status Log

Shows information about the most recent event that occurred on this package.

Package Module

Shows the name of the library that contains the package, if any.

IDT

Shows the path of the IDT (interface definition table) for the package.

Package Path

Shows the path where the package file is located.

Custom Configuration

This field is not used.

Description

Shows an optional text description of the package.

Add

Click this to add an implementation package.

  • Add Package
  • Edit Package
  • Delete Package
Parent topic: Enterprise Server Administration Console Help Pages


Add Package

Use this page to add an implementation package to the server.

Name

Specify the name of the new package, up to 255 characters. You cannot include angle brackets (<>) or ampersands (&) in the name.

Status

Choose a status from the list. The possible statuses are:

Available | The package is available. This is the default.
Disabled | The package is disabled.
Package Module

Specify the name of the library that contains the new package. You need to specify this only if the program is in a library that has a different name than the package name. Include the extension; library files have the extension .lbr or .dll on Windows, .lbr or .so on UNIX (.lbr or .sl on HP-UX PA-RISC).

IDT

Specify the pathname of the IDT (interface definition table) for the package.

IDT Remains Resident

Check this if you want the IDT to be loaded into the shared memory area while the service is running. This can help performance if the service is frequently used and there are no constraints on shared memory.

Package Path

Specify the path or paths where the executable program or programs are located. Separate paths with semicolons on Windows, and with colons on UNIX. If you do not specify this, the Directory Server looks for the file first in the path included in the interface definition table, and then in the paths specified by the COBDIR environment variable.

Configuration Information

This field is not used.

Description

Text description of the package. Optional.

Add

Click this to add the new package to the server. You must add a listener before you can click Add.

Parent topic: Packages


Edit Package

Use this page to change configurable attributes of an implementation package.

Name

Specify the name of the package, up to 255 characters. You can change the name only if the server has the status "Stopped". You cannot include angle brackets (<>) or ampersands (&) in the name.

Current Status

Shows the current status of the package.

New Status

Choose a status from the list. The possible statuses are:

Available | The package is available.
Disabled | The package is disabled.
Package Module

Specify the name of the library that contains the new package. You need to specify this only if the program is in a library that has a different name than the package name. Include the extension; library files have the extension .lbr or .dll on Windows, .lbr or .so on UNIX (.lbr or .sl on HP-UX PA-RISC).

IDT

Specify the pathname of the IDT (interface definition table) for the package.

IDT Remains Resident

Check this if you want the IDT to be loaded into the repository while the service is running. This can help performance if the service is frequently used and there are no constraints on shared memory.

Package Path

Specify the path where the package file is located. If you do not specify this, the Directory Server looks for the file first in the path included in the interface definition table, and then in the paths specified by the COBDIR environment variable.

Configuration Information

This field is not used.

Description

Specify a text description of the package. Optional.

Delete

Click this to delete the package. You cannot delete a package if it is associated with a service.

Parent topic: Packages


Delete Package

Use this page to delete the selected package.

CAUTION:

Deleting a registered package may cause application connection errors and loss of data

Name

Shows the name of the package.

Package Module

Shows the name of the library that contains the package.

IDT

Shows the path of the IDT (interface definition table) for the package.

Description

Shows a text description of the package.

Parent topic: Packages


Security Configuration Screen Help

This section contains the context sensitive help available when configuring Enterprise Server security. This help is also available from the user interface. To access the help, select Help > This Page from the left pane.

Note: The context help in this section is the most up-to-date version.
  • MF Directory Server Users, Add or Edit
  • Add Resource Class
  • Add Resource Entity
  • Add Security Manager
  • Add to Default ES Security Manager List
  • Add to ES Security Manager List
  • Add to MF Directory Server Security Manager List
  • Configure General Options
  • Confirm Password
  • Configure Journal Options
  • Configure Monitor Options
  • Configure Repository Options
  • Default ES Security Configuration
  • Directory Server Users
  • Edit Resource Class
  • Edit resource entity
  • Edit Security Manager
  • Left Pane Menu Items
  • MF Directory Server Security
  • Remove Security Manager Reference Confirmation
  • Security Managers Pool
  • SSL Options
  • Shut Down the MF Directory Server
  • Update User
  • User Group Members
  • User Groups
  • User Import: another user registry
  • User Import: previous version
Parent topic: Enterprise Server Administration Console Help Pages
Parent topic: Managing an LDAP from the Enterprise Server UI


MF Directory Server Users, Add or Edit

Use this page to add new users, select a user for updating or deleting, and to import user accounts. This screen is divided into tabs. The label of the tab indicates the start character(s) of the account IDs that are listed on the tab.

Account ID
The ID for the user account.
Add
Click this to add a new user.
Advanced Configuration (read only)
Displays user information retrieved from the LDAP.
Allow Logon
Indicates whether this user can logon.
Custom Configuration
An area where you can add custom user configurations, if your LDAP allows it.
Description
A description of the user account.
Edit
Click this to select the highlighted user ID for updating or deleting
Import
Click this to import user data from an installation of a previous version of Micro Focus Directory Server.
Journal
Click this to show the Journal page. This page shows the Directory journal, which is a record of Directory Server activity.
Logon
Click this to show the log on page. This menu option is shown only if the session is not currently logged on and the User Access setting on the Options page is "Restricted".
Member of
A comma separated list of the user groups of which the the user is a member.
Name
The full name of the person assigned to this account.
Sessions
Click this to show the Sessions page. This page shows the list of currently logged on Web browser client sessions, and also any bound program client sessions.
Shut Down
Click this to show the Shut Down confirmation page. This page enables you to shut down the Directory Server. This menu option is available only if you logged on with Schema Administrator permission level This menu option is available only if you logged on with Schema Administrator permission level and Directory Server is not running as a Windows service.
Parent topic: Security Configuration Screen Help


Add Resource Class

Use this page to add the details of a new resource class.

Add

Click here to add the new definition.

Class name

Specify the unique name of the resource class.

Description

Specify a description of the resource class.

Parent topic: Security Configuration Screen Help


Add Resource Entity

Use this page to add the details of a new resource entity to the current resource class.

Entity name

Specify the name of the resource entity. This must be unique within the resource class.

Description

Specify a description of the resource entity.

Add

Click here to add the new definition.

Parent topic: Security Configuration Screen Help


Add Security Manager

Use this page to add a new security manager.

Authorized ID and Password

If the module requires credentials to connect to the external security manager, specify them here.

As with the connection path, the content and format of these fields depend on the module that you are using. For details, please see the documentation supplied with the module.

Cache limit:

If the module has a configurable cache for holding responses from the security manager, enter its maximum size in kilobytes here.

Cache TTL:

If the module has a configurable cache for holding responses from the security manager, enter the maximum time in seconds that an entry in the cache can be used to satisfy requests before the details must be requeried from the security manager.

Note: Enterprise Server and Directory Server also have their own configurable caches for security information. These are checked before submitting queries to the security manager module.
Configuration information

Specify any additional configuration settings that the module requires.

Connection Path:

If the module requires a connection string that tells it how to connect to the external security manager, specify it here.

The information supplied in the string and its format depend on the module that you are using. For details, please see the documentation supplied with the module.

Description

Specify a description of the security manager.

Enabled

Check this to enable this security manager. If it is disabled, it will be ignored by Directory Server and those enterprise servers that reference it.

Module

Specify the module used to access an external security manager or to implement the security rules. If you specify it with a relative path (which includes no path) it is relative to %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin.

Name

Specify the name used to identify the security manager.

Parent topic: Security Configuration Screen Help


Add to Default ES Security Manager List

Use this page to add Security Managers to the Default ES Security Manager List. This is the list of security managers (taken from the available pool) that enterprise servers can use to perform security queries.

The screen shows a table that contains the available pool of Security Managers.

Select

Use this to select a security manager for addition to the Default ES Security Manager List.

Name

This column indicates the name that used to identify a security manager.

Module

This column indicates the module used by a security manager to access an external security manager or to implement the security rules.

Used by

This column shows the security manager lists that include this security manager.

Description

The description column indicates the description for a security manager.

Enabled

This column indicates whether or not the security manager is enabled. If it is not enabled, it will be ignored by Directory Server and those enterprise servers that reference it.

Add

Click this to add the currently selected security manager to the Default ES Security Manager List.

Parent topic: Security Configuration Screen Help


Add to ES Security Manager List

Use this page to add Security Manager to a particular enterprise server's Security Manager List. This is the list of security manager (taken from the available pool) that the enterprise server can use to perform security queries.

The screen shows a table that contains the available pool of Security Managers.

Select

Use this to select a security manager for addition to the Security Manager List.

Name

This column indicates the name that used to identify a security manager.

Module

This column indicates the module used by a security manager to access an external security manager or to implement the security rules.

Description

The description column indicates the description for a security manager.

Enabled

This column indicates whether or not the security manager is enabled. If it is not enabled, it will be ignored by Directory Server and those enterprise servers that reference it.

Add

Click this to add the currently selected security manager to the Security Manager List.

Parent topic: Security Configuration Screen Help


Add to MF Directory Server Security Manager List

Use this page to add Security Managers to the MFDS Security Manager List. This is the list of security manager (taken from the available pool) that Directory Server can use to perform security queries.

The screen shows a table that contains the available pool of Security Manager.

Add

Click this to add the currently selected security manager to the MF Directory Server Security Manager List.

Description

The description column indicates the description for a security manager.

Enabled

This column indicates whether or not the security manager is enabled. If it is not enabled, it will be ignored by Directory Server and those enterprise servers that reference it.

Module

This column indicates the module used by a security manager to access an external security manager or to implement the security rules.

Name

This column indicates the name that used to identify a security manager.

Select

Use this to select a security manager for addition to the MFDS Security Manager List.

Used by

This column shows the security manager lists that include this security manager.

Parent topic: Security Configuration Screen Help


Configure General Options

Use this page to change configuration settings for the Directory Server.

Maximum Directory Server object count

Specify the maximum number of objects that the repository can hold.

The minimum is 64 objects. The maximum is 9999 objects. The default value is 128 objects.

Generate UDP search requests

When a CCI client request cannot be satisfied by this Directory Server it can forward the request to any other compatible naming services on the local network by issuing the request using a UDP broadcast. You might want to minimize broadcast traffic or force clients to search for locally registered servers by disabling this feature.

The default is enabled.

Restore server states when Directory Server starts up

Check this if you want servers that were previously started when the Directory Server closed down to be restarted when the Directory Server is started. For example, if your system is configured to run Directory Server automatically at system startup, and this flag is checked, then whenever you reboot your machine, Directory Server will attempt to restart any servers that were running when it closed down.

The default is "Disabled".

Save Legacy Micro Focus Servers

Check this if you want legacy Micro Focus servers to be included when you save the Directory Server repository. Legacy Micro Focus servers are CCI servers.

The default is "Disabled".

Servers marked "Started" only when all listeners started

Check this if you want the server status to remain "Stopped" until all of the auto-start and startable listeners (those not marked as Disabled) have been set to "Started" status.

If this is unchecked, the server status is set to "Started" when the first MFCS instance that starts up modifies the server status. This will be shortly after the Communications Process Control Channel listener becomes active. At this point, any remaining listeners for that Communications Process, and any other Communications Processes for that server, will probably still be starting up.

By default this is unchecked.

Clear dynamically assigned address values when servers stop

Check this box to override the option on the individual stop server confirmation page so that the dynamic address values for the server are cleared when it stops. This will happen regardless of whether it is started remotely, from the command line, or from the Enterprise Server Administration GUI.

By default this is unchecked.

Default Process User ID

UNIX only. Specify a default user ID to be attached to all processes started from the Directory Server, for example, service execution processes. You can override this default process user ID for an individual enterprise server by specifying a value for Process User ID on the Edit Server Advanced page. If you do not specify a user ID in either place, all processes run as user root, which can create problems with security and access to files. You can specify either a numeric user ID or a username.

Defaults

Click this to restore the default settings.

Note:
  • If the current number of objects exceeds the default object count, the default is not restored.
Parent topic: Security Configuration Screen Help


Confirm Password

Use this page to confirm your user ID and password after you have changed the mode of Directory Server from Unrestricted to Restricted.

User ID

Specify your user ID. User IDs are case sensitive.

Password

Specify your password. Passwords are case sensitive.

Parent topic: Security Configuration Screen Help


Configure Journal Options

Use this page to change configuration settings for the Directory Server journal.

Journal

The journal is a file that records some of the Web browser client and program client activity occurring on the Directory Server. It can track usage and help with support issues.

The level of journaling in force affects performance; the more entries written, the more performance is degraded. The scale of the degradation depends on many factors such as file system performance and client traffic; a system with a large number of highly active program clients suffers the most.

Maximum file size

Specify the maximum file size in kilobytes (KB) of the journal file. Once the journal file grows to this size, the most recent journal entries overwrite the oldest journal entries.

The minimum is 32 KB. The default value is 256 KB.

CAUTION:

Changing the size of the journal erases any previous journal entries.

Entries displayed

Specify the number of journal entries that will be displayed on the page at a single time.

The minimum is 5 entries. The default value is 23 entries.

Journal level - Errors only

Check this if you want journal entries to be written for errors only.

Journal level - Errors and warnings

Check this if you want journal entries to be written for errors and warnings only.

Journal level - All information

Check this if you want journal entries to be written for all events.

CTF trace

Check this if you want journal entries to be written through the Consolidated Trace Facility.

Defaults

Click this to restore the default settings.

Note:
  • Restoring the default maximum file size of the journal has the effect of erasing the journal, unless the maximum size is already set to the default.
Parent topic: Security Configuration Screen Help


Configure Monitor Options

Use this page to change configuration settings for the Server Monitor.

Acceptable response time

Specify the interval (in seconds) that the server monitor is to wait for a response after sending a keep-alive request to a server before assuming it is not responding. If you know that the network is normally quiet or busy, you can adjust this time accordingly.

The default value is 5 seconds.

Defaults

Click this to restore the default settings.

Enabled

Check Enabled to start the server monitor. Uncheck it to stop the server monitor at the next keep-alive interval timeout.

The default is Enabled.

Keep-alive interval

Specify the interval (in seconds) that the server monitor is to wait between each cycle of server interrogations. Since each cycle of interrogations takes a finite amount of time, depending on how many servers are registered and how responsive they and the network are, the actual time taken between checks is longer than this interval.

The default value is 60 seconds.

Server Monitor

The server monitor checks whether all enterprise servers registered with the Directory Server and not marked "Stopped" or "Disabled" are responding to potential client requests. If they are, their status is marked as "Started", otherwise, if they are currently marked as "Started" and they are not responding, they are marked as "Not Responding".

Having the server monitor on ensures that Current Status for a server is up to date, even if the server itself cannot contact the Directory Server for some reason, for example, a network connection or machine failure.

Parent topic: Security Configuration Screen Help


Configure Repository Options

Use this page to change configuration settings for the Directory

Repository Location

Specify the type of storage and the location containing the repository. You can store the repository in the file system or in an LDAP repository.

For file system storage, the location is the directory in which the repository data will be stored.

For LDAP storage, the location is the address of the LDAP server that will be used.

In order to store the repository in an LDAP server, the server must be updated to support the Micro Focus configuration objects.

Warning:

If you change the location and the destination already contains a repository, you will be warned and given the opportunity to overwrite it or to cancel the operation.

Note: When you specify ldap:// as the storage mechanism, additional fields are displayed for specifying the container in which the data will be stored, and the LDAP user credentials required to write to the container.
Repository Container Distinguished Name

The distinguished name of the LDAP container in which the repository is to be stored.

User DN
The distinguished name of the LDAP user with which to access the repository. This user must have permission to read and write to the container.
User Password
The password of the user with which to access the repository.
Parent topic: Security Configuration Screen Help


Default ES Security Configuration

Use this page to define default security settings that can be used with Directory Server and enterprise servers. You can override these defaults for individual servers

Add

Click this to add a security manager from the pool of available definitions.

Allow unknown resources

Check this if you want the security facility to permit access to any unknown resource; that is, any resource for which all entries on the priority list return Unknown.

You might use this in circumstances where you only want to restrict access to some resources.

Allow unknown users

Check this if you want to allow unknown users to log in.

Enabled

This column indicates whether or not the security manager is enabled. If it is not enabled, it will be ignored by Directory Server and those enterprise servers that reference it.

Cache limit:

Enter the maximum size in kilobytes that the Directory Server or enterprise server's security facility can use for caching the results of security queries.

Cache TTL:

Enter the maximum time in seconds that an entry in the cache can be used to satisfy requests before the details must be requeried from the security manager.

Create audit events

Check this to enable the enterprise server or Directory Server to generate security audit events. These events can be captured and logged by the Audit Facility.

Configuration information

Specify any additional configuration settings that the security facility requires.

Default ES Security Manager List

This is the list of security managers (taken from the available pool) that can be used to perform security queries.

Note: Security managers are queried in the order that they appear in the list. If the Verify against all Security Managers checkbox is not checked, the first manager in the list that responds with a definite answer will determine the result of a security query. See the text for Verify against all Security Managers for more details.

Use the up and down arrows to reposition the selected entry.

Module

This column shows the module used by a security manager to access an external security manager or to implement the security rules.

Name

This column shows the name that used to identify a security manager.

Priority

Indicates the position of the security manager in the sequence in which the security managers are queried.

Select

Use this to select a security manager for removal or for moving to a different position in the list.

Description

The description column shows the description for a security manager.

Remove

Click this to remove the currently selected definition from this list.

Note: The definition is only removed from this list, not from the available pool of definitions.
Use all groups

Check this if a user requesting authorization is to have the permissions of every group to which he or she belongs.

Uncheck this if the user is to have only the permissions of the group specified in the initial security API call that requested verification (authentication) of the user's credentials. Where no group is specified in the verify call, a default group is used.

Verify against all Security Managers

Set this if you want each security query to be checked by all entries on the Security Manager Priority List.

If this is not set, the entries will be queried in the order that they appear on the Priority List until one gives a response of Allow, Deny, or Fail (equivalent to Deny). This response will then be used to decide what action should be taken.

If this field is set, all entries on the list will be queried, and if any returns a Deny or Fail, the access request will be denied. If there are no Deny or Fail responses and at least one of the entries on the list gives Allow as its response, the request will be allowed.

If a security manager does not have a rule for the resource or user specified in the request, it gives a response of Unknown. Whatever the setting of the Verify against all Security Managers field, if all of the entries on the priority list respond with Unknown, the request will be denied unless you have checked Allow unknown resources or Allow unknown users.

Parent topic: Security Configuration Screen Help


Directory Server Users

Use this page to add new users, select a user for updating or deleting, and to import user accounts. This screen is divided into tabs. The label of the tab indicates the start character(s) of the account IDs that are listed on the tab.

Account ID

The ID for the user account.

Name

The full name of the person assigned to this account.

Member of

A comma separated list of the user groups of which the the user is a member.

Description

A description of the user account.

Allow Logon

Indicates whether this user can logon.

Edit

Click this to select the highlighted user ID for updating or deleting

Add

Click this to add a new user.

Import

Click this to import user data from an installation of a previous version of Micro Focus Directory Server.

Parent topic: Security Configuration Screen Help


Edit Resource Class

Use this page to edit the details of a resource class and to add resource entities to the class.

Description

Specify a description of the resource class in this field.

Apply

Click this to apply any change that you have made to the description text.

Delete

Click this to delete this resource class. Note that you cannot delete a resource class that contains resource entities.

Entity

This column specifies the name of each resource entity that is included in this resource class.

Entity Description

This column specifies the description of each resource entity that is included in this resource class.

ACL String

This column specifies the Access Control List (ACL) string of each resource entity that is included in this resource class. The ACL specifies the access rights for the resource entity. Each entry in an ACL is referred to as an Access Control Entry, or ACE. These entries are separated by semi-colons.

Each ACE specifies an actor, which is a user, a wildcard pattern for users, or a group, and one or more permissions that are granted (allow) or denied (deny) to that actor. The format for the ACE is as follows:

setting:actor:action-1,...,action-n

Where:

  • setting is allow or deny
  • actor is the name of a user, a pattern with one or more wildcards (see Wildcards) string that will be matched against the user's name, or a group name or wildcard pattern followed by a space and the word group (eg "ADMIN group")
  • action-1 through action-n are permission tokens:
    • none
    • execute
    • read
    • update
    • add
    • delete
    • control
    • alter
    • all
Edit

Click this to edit the resource entity in this row.

Add

Click this to add a new resource entity to this resource class.

Parent topic: Security Configuration Screen Help


Edit resource entity

Use this page to edit the details of a resource entity.

Description

Specify a description of the resource entity.

ACL String

Specify the Access Control List(ACL) string for the resource entity. The ACL specifies the access rights for the resource entity. Each entry in an ACL is referred to as an Access Control Entry, or ACE. These entries are separated by semi-colons.

Each ACE specifies an actor, which is a user, a wildcard pattern for users, or a group, and one or more permissions that are granted (allow) or denied (deny) to that actor. The format for the ACE is as follows:

setting:actor:action-1,...,action-n

Where:

  • setting is allow or deny
  • actor is the name of a user, a pattern with one or more wildcards (see Wildcards) string that will be matched against the user's name, or a group name or wildcard pattern followed by a space and the word group (eg "ADMIN group")
  • action-1 through action-n are permission tokens:
    • none
    • execute
    • read
    • update
    • add
    • delete
    • control
    • alter
    • all

For example, the following ACL string:

allow:Test group:Execute,Read,Update,Add,Delete;allow:Operator group:Read

assigns the Test group execute, read, update, add and delete permissions for the resource, and assigns the Operator group read permission.

Parent topic: Security Configuration Screen Help


Edit Security Manager

Use this page to amend the details of a security manager.

Name

Specify the name used to identify the security manager.

Module

Specify the module used to access an external security manager or to implement the security rules. If you specify it with a relative path (which includes no path) it is relative to %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin.

Connection Path

If the module requires a connection string that tells it how to connect to the external security manager, specify it here.

The information supplied in the string and its format depend on the module that you are using. For details, please see the documentation supplied with the module.

Authorized ID and Password

If the module requires credentials to connect to the external security manager, specify them here.

As with the connection path, the content and format of these fields depend on the module that you are using. For details, please see the documentation supplied with the module.

Enabled

Check this to enable this security manager. If it is disabled, it will be ignored by Directory Server and those enterprise servers that reference it.

Cache limit

If the module has a configurable cache for holding responses from the security manager, enter its maximum size in kilobytes here.

Cache TTL

If the module has a configurable cache for holding responses from the security manager, enter the maximum time in seconds that an entry in the cache can be used to satisfy requests before the details must be requeried from the security manager.

Note: Enterprise Server and Directory Server also have their own configurable caches for security information. These are checked before submitting queries to the security manager module.
Description

Specify a description of the security manager.

Configuration information

Specify any additional configuration settings that the module requires.

Properties

Click this to access pages for the management of users, groups and resources controlled by this security manager.

Important: You will only be able to manage users, groups and resources where the security manager is on the priority list used by Directory Server. That is:
  • if Directory Server uses the Default ES Security configuration, the security manager must be on the Default ES Security manager list
  • if Directory Server uses its own configuration options, the security manager must be on the Directory Server's own security manager list

In addition, the ESM module and the external security manager to which it connects must also support user, group and resource administration via the Security Facility.

Parent topic: Security Configuration Screen Help


Left Pane Menu Items

The following items appear on the left pane menu:

Home menu option

Click this to return to the Home page.

Actions

The heading for menu options that provide administrative actions. The actual number of options displayed below this heading is variable, depending on the permission level of the user.

Logon

Click this to show the log on page. This menu option is shown only if the session is not currently logged on and the User Access setting on the Options page is "Restricted".

Logoff

Click this to log off from an administrative session that is currently logged on. There is no log off confirmation. This menu option is shown only if the session is currently logged on and the User Access setting on the Options page is "Restricted".

Renew

Click this to refresh the IP address information cached by your Directory Server. Use this option when the IP address of the machine running your Directory Server changes.

Directory Server uses the IP address to locate the servers that it manages. When the cached IP address is out of date, Directory Server may be unable to connect to its servers and may report inaccurate information to clients.

Export

Click this to show the Export page. This page enables you to save a copy of the whole repository to a location of your choice. This menu option is available only if you logged on with Administrator or Schema Administrator permission level.

Import

Click this to show the Import page. This page enables you to update the repository with additional objects from an import directory. Imported objects can include servers (along with all of their child objects), and Security Manager definitions. This menu option is available only if you logged on with Schema Administrator permission level.

Delete All

Click this to show the Delete confirmation page. This page enables you to confirm that you want the repository to be completely erased and all registered objects to be deleted. This menu item is available only if you logged on with Schema Administrator permission level.

Shut Down

Click this to show the Shut Down confirmation page. This page enables you to shut down the Directory Server. This menu option is available only if you logged on with Schema Administrator permission level This menu option is available only if you logged on with Schema Administrator permission level and Directory Server is not running as a Windows service.

Configure

The heading for the menu option that enables you to configure Directory Server. This menu heading and its associated menu option are available only if you logged on with Administrator permission level or higher.

Options

Click this to show the Directory Server Options page. This page enables you to configure the Directory Server.

Security

Click this to show the pages used for configuring security options.

Display

The heading for menu options that enable you to view information about the state of the Directory Server and about the events that have taken place on the server.

Directories

Click this to show the Directories page. This page lists all the instances of Directory Server that are running on the network and using the default Directory Server port (86).

Statistics

Click this to show the Statistics page. This page shows statistics and status information about Directory Server.

Sessions

Click this to show the Sessions page. This page shows the list of currently logged on Web browser client sessions, and also any bound program client sessions.

Journal

Click this to show the Journal page. This page shows the Directory journal, which is a record of Directory Server activity.

Help

The heading for menu options that enable you to view documentation about the Directory Server and Enterprise Server Administration.

This page

Click this to view help for the page you are currently viewing and for all the controls on the page.

Contents

Click this to view the Contents of the Enterprise Server documentation.

Note: Note:

For this link to work, you must be using an enterprise server that has a Web listener with the following entry in the [virtual paths] section:

docs=<ES>/help

This enterprise server must be started.

The default enterprise server, ESDEMO, has a web listener with this configuration information. When you create a new enterprise server, a Web listener with the required configuration information entry is automatically created.

Support

Click this to contact Micro Focus Technical Support via the Supportline website to report problems or ask any questions about using Micro Focus software.

Feedback

Click this to open your email client and send general feedback to Micro Focus.

Parent topic: Security Configuration Screen Help


MF Directory Server Security

Use this page to define the security settings to be used with Directory Server.

Add

Click this to add a security manager from the pool of available definitions.

Allow unknown resources

Check this if you want the security facility to permit access to any unknown resource; that is, any resource for which all entries on the priority list return Unknown.

You might use this in circumstances where you only want to restrict access to some resources.

Allow unknown users

Check this if you want to allow unknown users to log in.

Authenticated client sessions

There are two main methods that a remote user can use to connect to the Directory Server:

  • Using Enterprise Server Administration, which runs in a Web browser. This method is intended for the administrative functions. These clients are known as Web browser clients.
  • Using the underlying MLDAP API, usually via some higher level application interface or product, to carry out some short-lived operation such as to search for the address of a service or to modify the properties of an object. These clients are known as program clients.

If Directory Server is running in Restricted mode, Web browser clients have to authenticate themselves to the Directory Server, carry out any operations, and then log off. (Program clients always run in Restricted mode.) During the time period between the authentication and removal the client is entered into the authenticated client list maintained internally by the Directory Server process. To s the list from accidentally growing too large (not all users or applications log off correctly after they have been authenticated) and also to maintain security, the Directory Server removes both Web browser and program client sessions after a configurable timeout period.

Cache limit:

Enter the maximum size in kilobytes that enterprise server's security facility can use for caching the results of security queries.

Cache TTL:

Enter the maximum time in seconds that an entry in the cache can be used to satisfy requests before the details must be requeried from the security manager.

Certificate
Custom server certificate path.
Certificate passphrase

Custom server certificate passphrase (optional).

Change

Click this to add a security manager from the pool of available definitions. This button is only present if you are using the MFDS Internal Security Manager. As MFDS Internal Security cannot be used alongside other security managers, when you add the new manager MFDS Internal Security will be removed.

Client program timeout

Specify the maximum interval in seconds since the last activity of a program client before it is automatically unbound.

The minimum value is 60 seconds (1 minute). A value of -1 indicates an infinite timeout period.

The default value is 6000 seconds (100 minutes).

Configuration information

Specify any additional configuration settings that the enterprise server security facility requires.

Create audit events

Check this to enable the enterprise server to generate security audit events. These events can be captured and logged by the Audit Facility.

Description

The description column indicates the description for a security manager.

Enabled

This column indicates whether or not the security manager is enabled. If it is not enabled, it will be ignored by Directory Server and those enterprise servers that reference it.

Keyfile

Custom keyfile path.

Keyfile passphrase

Custom keyfile passphrase.

Module

This column indicates the module used by a security manager to access an external security manager or to implement the security rules.

Name

This column indicates the name that used to identify a security manager.

Priority

Indicates the position of the security manager in the sequence in which the security managers are queried.

Remove

Click this to remove the currently selected definition from this list.

Note: The definition is only removed from this list, not from the available pool of definitions.
Restrict user access

Check this to cause all administrative access to the Directory Server to be authenticated and authorized by the entries on the Security Manager Priority List.

Secure Port

Unless a specific secure port is specified, the SSL connection will use a dynamically assigned port each time the MF Directory Server process is restarted. A fixed known port may be useful if configuring firewall settings.

Security Manager List

This is the list of security managers (taken from the available pool) that MF Directory Server can use to perform security queries.

Note: Security managers are queried in the order that they appear in the list. If the Verify against all Security Managers checkbox is not checked, the first manager in the list that responds with a definite answer will determine the result of a security query. See the text for Verify against all Security Managers for more details.

Use the up and down arrows to reposition the selected entry.

Select

Use this to select a security manager for removal or for moving to a different position in the list.

Use all groups

Check this if a user requesting authorization is to have the permissions of every group to which he or she belongs.

Uncheck this if the user is to have only the permissions of the group specified in the initial security API call that requested verification (authentication) of the user's credentials. Where no group is specified in the verify call, a default group is used.

Use custom server ID certificate

If this is turned off, the default DemoCA root certificate, server certificate, keyfile and passphrase that are installed with the product will be used. For production purposes it is recommended that the default certificates are not used, and that the customers own certificates are specified. In addition, the MF_ROOT_CERT environment variable will need to be set so that the MF Directory Server process can pick up the value of the root certificate path.

Update when external Security Manager properties change
Check this to update the configuration to reflect changes made to any external Security Manager used.
Use default ES Security Manager List

Check this if you want to use your default ES security manager list for Directory Server, rather than the Security Manager List below. To define the default ES Security settings, click Security on the menu on the left hand side, and then click Security > Default ES Security.

Use encrypted connections

Select this if you want to start Enterprise Server Administration so that it requires authorized browser connections to use SSL. If the state is changed from the current active selection then the MF Directory Server process will need to be re-started to use the new setting. If encrypted connections are selected, administrative access must also be set to restricted.

Verify against all Security Managers

Set this if you want each security query to be checked by all entries on the Security Manager Priority List.

If this is not set, the entries will be queried in the order that they appear on the Priority List until one gives a response of Allow, Deny, or Fail (equivalent to Deny). This response will then be used to decide what action should be taken.

If this field is set, all entries on the list will be queried, and if any returns a Deny or Fail, the access request will be denied. If there are no Deny or Fail responses and at least one of the entries on the list gives Allow as its response, the request will be allowed.

If a security manager does not have a rule for the resource or user specified in the request, it gives a response of Unknown. Whatever the setting of the Verify against all Security Managers field, if all of the entries on the priority list respond with Unknown, the request will be denied unless you have checked Allow unknown resources or Allow unknown users.

Web browser timeout

Specify the maximum interval in seconds since the last activity of a Web browser client, for example, a browser refresh, before it is automatically logged off.

The minimum value is 60 seconds (1 minute). A value of -1 indicates an infinite timeout period. We recommend you use this value sparingly and always reset to a finite period as soon as possible. This is because if the Directory Server is running with an infinite Web client timeout, there is more likelihood that an unauthorised user might gain access to the system using an unattended machine; also the Directory Server will tend to become overloaded with clients who have not logged off.

The default value is 300 seconds (5 minutes).

Parent topic: Security Configuration Screen Help


Remove Security Manager Reference Confirmation

Enterprise Server Administration displays this page in the following situations:

  • when you choose to remove a security manager from the MF Directory Server's security manager list and that security manager is the only one present in the list. When the security manager is removed, it is automatically replaced by the MFDS Internal security manager.
  • The MFDS Internal security manager cannot be used in a list that contains other security managers. Therefore, when you choose to add a different security manager to the MF Directory Server's security manager list, the MFDS Internal security manager, if present in the list, will be automatically removed.

This screen checks that you want to proceed with the removal.

Parent topic: Security Configuration Screen Help


Security Managers Pool

Use this page to manage the pool of security managers available for Directory Server and enterprise servers to use for resolving security queries.

You can have multiple definitions for any given external security manager. Each definition may be used by Directory Server and one or more enterprise servers.

Add

Click this to add a new security manager.

Description

The description column shows the description for a security manager.

Edit

Click this to edit details of the currently selected security manager.

Enabled

This column indicates whether or not the security manager is enabled. If it is not enabled, it will be ignored by Directory Server and those enterprise servers that reference it.

Module

This column shows the module used by a security manager to access an external security manager or to implement the security rules.

Name

This column shows the name that used to identify a security manager.

Select

Use this to select a security manager for editing or removal.

Update All
Click this to update the security managers so that they display the correct current status.
Used by

This column shows the security manager lists that include this security manager.

Parent topic: Security Configuration Screen Help


SSL Options

Use this page to set options for encryption and for authentication of online entities.

Accept all clients

Click this to allow all clients to communicate with the server without being checked for an SSL certificate.

Request client certificate, and verify if present

Click this to request the client for a certificate, and to verify the returned certificate. If the client doesn't return a ceritficate, communication continues between the client and server. If a certificate is returned and it fails to verify, communication stops.

If you check this, you must specify the CA root certificates file below.

Require client certificate and verify

Click this to always require a client certificate and to verify it. This ensures that the client is trusted. If a certificate is not returned or it cannot be verified, communication between the client and server is stopped.

If you check this, you must specify the CA root certificates file below.

CA root certificates file

This field is mandatory if you have chosen to request or require a client certificate.

Specify the path and filename of the file containing certificates of root CAs that you trust. This file must contain the CA root certificate of the CA that signed the client's certificate. For example, in the demoCA environment, this is CARootcert.pem in the private directory of the DemoCA area in the client system.

Parent topic: Security Configuration Screen Help


Shut Down the MF Directory Server

Use this page to confirm that you want to shut down the MF Directory Server.

Note: This is available only if MFDS is running as a program. Under normal circumstances, MFDS runs as a service, and this screen is unavailable.
CAUTION:

Shutting down the server might cause application connection errors and loss of data if currently running applications rely on reaching data registered in the Directory Server repository.

Stop servers before shutting down

Check this if you want the servers to be stopped before the Directory Server stops.

Yes

Click this to shut down the Directory Server. Enterprise Server Administration will no longer be available after you have shut down the Directory Server.

Parent topic: Security Configuration Screen Help


Update User

Use this page to modify the details of registered users and to delete users.

Account ID

Indicates the ID of the accout being edited.

Name

Specify the full name of the person assigned to this account.

Description

Specify a description of the user.

Default Group

Specify a default user group for this user.

Where a user verification request does not specify a group, this default group is used.

Allow Logon

Check this to permit the user to logon.

Member of:

Lists the user groups of which this user is a member. Click a group to select it for removal from this list.

User groups:

Lists all available user groups. Click a group to select it for adding to the Member of list.

Remove-->

Click this to remove the selected group from Member of.

<--Add

Click this to add the selected group to Member of.

New Password

Specify the new password of the user. Passwords can contain alphabetical and numeric characters only and are case sensitive. If you leave this field blank, the existing password is unchanged.

Confirm Password

Specify the case-sensitive new password of the user. If you enter a value that does not match the value in New Password, an error is generated and the existing password is unchanged.

Delete

Click this to delete this user.

Parent topic: Security Configuration Screen Help


User Group Members

Use this page to edit the details of a user group.

Group Members

Lists the members of this user group. Click a member to select it for removal from this list.

Add

Click this to add the specified user to the group. Note that the user must exist.

Remove

Click this to remove the selected member from the group.

Parent topic: Security Configuration Screen Help


User Groups

Use this page to add new groups, and to select a group for updating or deleting.

Name

The name of the group.

Description

A description of the group.

Members

Shows the number of users in the group.

Edit

Click this to select the adjacent group for updating or deleting

Add

Click this to add a new group.

Parent topic: Security Configuration Screen Help


User Import: another user registry

Use this page to import user data to another user registry.

Note: User data is stored in a user definition file called CCIUSERS.dat, located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin.

Also, the fields available on this screen depend on whether you are importing from a file or from an LDAP server.

User registry

Specify the location of the user registry from which you want to import users.

If the registry is in a file, the location is the full name of the file.

If the registry is in an LDAP server, the location is the address of the LDAP server.

Note: When you specify ldap:/// as the type of registry, additional fields are displayed for specifying which users are to be imported, and the user credentials required for reading the data from the LDAP server.
Base DN

Specify the base distinguished name for the container from which the user entries will be obtained.

Filter

Specify any filter condition to restrict the list of users imported.

Credentials

Specify the credentials required to access the LDAP server.

User DN:

The distinguished name of the LDAP user with which to access the repository.

Password:

The password of the user with which to access the repository.

Replace all existing user information

Check this if you want all existing users to be removed and replaced with the users that you are importing. If this is not checked, existing users will not be changed and only those users in the import file that are not already present in your repository will be imported.

Replace existing duplicate user information

Check this to replace any existing user that is a duplicate of one being imported.

Import only users who are members of these groups

Restrict the users imported to those within the groups named in this field.

Add imported users into this group

Specify a group to which all imported users should be assigned.

Parent topic: Security Configuration Screen Help


User Import: previous version

Use this page to import user data from a previous version of Micro Focus Directory Server.

Note: Prior to this release, user data was stored in a user definition file called CCIUSERS.dat. This was located in the install-dir\base\bin\ for Net Express or install-dir\bin\ where Enterprise Server was installed standalone.

Note also, the fields available on this screen will depend on whether you are importing from a file or from an LDAP server.

User registry

Specify the location of the user registry from which you want to import users.

If the registry is in a file, the location is the full name of the file.

If the registry is in an LDAP server, the location is the address of the LDAP server.

Note:

When you specify ldap:/// as the type of registry, additional fields are displayed for specifying which users are to be imported, and the user credentials required for reading the data from the LDAP server.

Base DN

Specify the base distinguished name for the container from which the user entries will be obtained.

Filter

Specify any filter condition to restrict the list of users imported.

Credentials

Specify the credentials required to access the LDAP server.

User DN:

The distinguished name of the LDAP user with which to access the repository.

Password:

The password of the user with which to access the repository.

Replace all existing user information

Check this if you want all existing users to be removed and replaced with the users that you are importing. If this is not checked, existing users will not be changed and only those users in the import file that are not already present in your repository will be imported.

Replace existing duplicate user information

Check this to replace any existing user that is a duplicate of one being imported.

Import only users who are members of these groups

Restrict the users imported to those within the groups named in this field.

Add imported users into this group

Specify a group to which all imported users should be assigned.

Parent topic: Security Configuration Screen Help


Deploying and Configuring Modernized Applications

The topics in this chapter describe how to configure and administer modernized COBOL applications running in the Enterprise Server environment.

  • About Modernized Applications
  • Managing Resources
  • Adding and Deleting Services
  • Configuring and Monitoring Services
  • Configuring Implementation Packages
  • Deploying Interfaces Generated by the Interface Mapping Toolkit
  • Deploying EJBs and Resource Adapters
Parent topic: Configuration and Administration


About Modernized Applications

COBOL applications can be modernized so that they run in the Enterprise Server environment. A modernized COBOL application can be deployed as a service that perform the application's operations.

A service provides access to specific business functionality. A COBOL program implemented as a service reads in a parameter block, processes it and returns a results block.

The Interface Mapping Toolkit, part of your COBOL development system, allows you to expose services to clients. These COBOL services can then be invoked by clients as Web Services or through a J2EE connector or through the COM interface. Services that have been deployed using the Interface Mapping Toolkit always contain one or more operations.

A service that you create within Enterprise Server can contain one or more operations, depending on the name you give the service and which request handler is associated with it (if any). If you create a service with no request handler associated with it or if the name you use does not contain a valid separator, the service and the operation are one and the same. The Enterprise Server documentation uses the term "simple service" for services of this type. System services such as the Deploy service of the default enterprise server instance, ESDEMO are simple services.

  • Service Names and Operations
  • Types of Services Supported
  • Configuration Parameters
Parent topic: Deploying and Configuring Modernized Applications


Service Names and Operations

Service names can be of two forms, depending on whether or not the service contains any operations. The two forms are:

  • Names consisting of one part, for example, Test or my_service. Simple services have this type of name.
  • Names consisting of three parts, for example, http:/tempuri.org/wmapserv#Add. The parts are:
    • The service namespace. This is the part of the name before the first pound (#) character
    • The separator, in this case, the pound (#) character
    • The operation name, in this case Add

    Services with operations have this type of name.

    Service names for Web services use the first pound (#) character as a separator, while names for services that form part of a J2EE application use the last period ( ) character, for example, mybinpservice.operation.

    You can include more than one pound character or period in a service name; Enterprise Server will interpret the first pound character or last period character it finds as the separator.

  • The Services Table
  • Configuring Services
Parent topic: About Modernized Applications


The Services Table

You can see the information held in the repository for services by clicking Details against Services in the table of servers on the Home page. The services table is shown below.

Figure 1. Services Table
Services Table

The information is as follows:

  • Service namespace - a unique label within the enterprise server that identifies the service and if it contains operations, groups the operations together
  • Operation - a list of the individual operations within a service; if the service is a simple service, there is just one item in this list, and it bears the same name as the service itself
  • Service class - for Micro Focus use only; set to MF deployment for all deployment services
  • Search order - the order in which services of the same name are sorted for searching purposes
  • Listeners - a list of the listeners allocated to this service
  • Request handler - the request handler for this service
  • Implementation package - the implementation package that provides the business functionality
  • Status information - you can see the current status and the time of the last status change
  • Status log - this supplies information about the most recent event that occurred on this service
  • Custom configuration data - for more information see the section Configuration Information
  • Description

Service display flters control how much service information you can see. These appear at the top of the services table. There are four service display filters:

  • Service: to use this filter, specify the name of the service you want to view; you need only enter enough characters to identify the service uniquely
  • Class
  • Handler
  • Package

Except for Service, each has three options

  • None: choose this to see no services for this filter
  • Some: choose this to see services that have a value for this filter
  • All: choose this to see all services for this filter

For example, to see service details for services of class 1, choose Some in Service Display Filters Class; to see only services that do not have a request handler associated with them, choose None in Service Display Filters Handler; to see all services choose All in all three filters that have options and leave Service blank. Use all the filters in combination to achieve the maximum control over the level of detail you see.

When you first see the Services table, all the filters that have options are set to All and the Service filter is blank.

Parent topic: Service Names and Operations
Related information
Configuration Information


Configuring Services

You can use the Configuration Information field on the Add Service and Edit Service pages for configuration data specific to services.

The only Configuration Information settings for services are for deployment services, the special services with Service Class “MF Deployment” which are used by the Interface Mapping Toolkit to deploy Web Services and J2EE EJBs.

The [MF client] settings provide configuration for MFCC when it is creating the deployment request.

The [destination] settings are used by mfdepinst when it creates service and package objects in the Directory Server while installing a deployment package (.car file).

Note: These settings are only used when deployment is done via MFCS, using the IMTK or another deployment client. If you run mfdepinst manually from the command line to install a .car file, it is not invoked for a particular deployment service, so it has no deployment service configuration to consult.
[MF client]
scheme=protocol
URL=virtual-directory-name-1/mfdeploy.exe/virtual-directory-name-2
accept=request-data-type
[destination]
listener=listener-name
server=server-name
Parent topic: Service Names and Operations


Types of Services Supported

Enterprise Server applications deployed as services can be one of three types:

  • Web services

    These are components using standards and mechanisms that enable software components to be invoked across the Web. A client application using a Web service can invoke the service, and pass data to and from it in the form of XML files sent using a standard protocol such as HTTP.

  • J2EE services
  • COM services
Parent topic: About Modernized Applications


Configuration Parameters

  • scheme
    Specifies the protocol to use for the request.
  • URL
    Sets the base path portion of the request URL.
  • accept
    Tells MFCC what kind of request data this service accepts.
  • listener
    Specifies the name of the listener which will own the new services. By default this is “Web Services”. You can set this value if you want to deploy services to a listener with a different name.
  • server
    Specifies the name of the server which will own the new services and packages. By default this is the server that the deployment service belongs to. You can set this value so that an enterprise server accepts deployment requests for services that will be deployed to a different enterprise server on the same system.
Parent topic: About Modernized Applications


scheme

Syntax:

scheme=protocol

Parameters:

protocol Set to “http”

Properties:

Default: None.
Parent topic: Configuration Parameters


URL

Syntax:

URL=virtual-directory-name-1/mfdeploy.exe/virtual-directory-name-2

Parameters:

virtual-directory-name-1/ | Must correspond to a virtual directory in the listener’s configuration which is mapped to the directory containing mfdeploy.exe
virtual-directory-name-2 | Must correspond to a virtual directory where the new deployment directory will be created. (This directory must contain an .mfdeploy file.)

Properties:

Default: /cgi/mfdeploy.exe/uploads

Comments:

You can have multiple deployment services under a single Web listener, directing deployment packages to different locations, by creating additional virtual directories in the listener’s configuration and specifying the appropriate directory here. For more information see the section Deployment Services and Listeners in the chapter Configuration.

Parent topic: Configuration Parameters
Related information
Deployment Services and Listeners


accept

Syntax:

accept=request-data-type

Parameters:

request-data-type Set to “application/x-zip-compressed”

Properties:

Default: None
Parent topic: Configuration Parameters


listener

Syntax:

listener=listener-name

Properties:

Default: Web Services

Comments:

You can set this value if you want to deploy services to a listener with a different name.

Parent topic: Configuration Parameters


server

Syntax:

server=server-name

Properties:

Default: The server that the deployment service belongs to.

Comments:

You can set this value so that an enterprise server accepts deployment requests for services that will be deployed to a different enterprise server on the same system.

Parent topic: Configuration Parameters


Managing Resources

A COBOL application providing a service that uses external resources, such as databases and files, can manage its own resources or let the application container manage them. A service that manages its own resources is known as application-managed, while a service that does not manage its own resources is known as container-managed.

If a service updates files through Fileshare, you must specify the name and location of an fhredir.cfg file for the enterprise server in which the service runs.

  • Application-managed Services
  • Container-managed Services
  • Mixing Container-managed and Application-managed Services
Parent topic: Deploying and Configuring Modernized Applications


Application-managed Services

A service must manage its own resources if:

  • The application accesses files or databases (or both) in a transactional way, and contains transactional logic: that is, it includes COMMITs and ROLLBACKs
  • The application uses a resource manager that we do not support in the Enterprise Server environment; see the list in Supplementary Information.

A service in which the application accesses files in a non-transactional way (that is, it does not includes COMMITs and ROLLBACKs), should be application managed.

A transactional application-managed service must contain all the transactional logic it needs, that is, it must complete with all resources either committed or rolled back.

CAUTION:

A CICS EXCI call can only be executed in a service that is Container Managed. An EXCI call executed in an Application Managed generates an abend: EXIA

Application-managed services are executed in a similar way to applications in a conventional execution environment such as Enterprise Server or Enterprise Server. One of the main differences is that the process is not terminated at the end of execution of the service.

Parent topic: Managing Resources


Container-managed Services

If an application running as a service uses databases and files but does not contain any transactional logic, it can let the application container manage its resources.

The application container must know in advance what resource managers will be required. You define resources not by service, but by enterprise server instance. You can only define resource managers that are XA-compliant.

When an enterprise server instance and its service execution processes start up, the enterprise server manager opens connections to all the resources that might be needed by the services that run in that enterprise server instance. When a container-managed service is invoked, the enterprise server manager performs all file and database actions that it requires.

The application container manages databases by issuing XA commands.

The application container decides whether to commit or roll back resources using information supplied when the enterprise server instance was created and deployed in your COBOL development system. However, if there is an error in the application container itself, resources are always rolled back.

CAUTION:

A CICS EXCI call can only be executed in a service that is Container Managed. An EXCI call executed in an Application Managed generates an abend: EXIA

Parent topic: Managing Resources


Mixing Container-managed and Application-managed Services

You can mix container-managed and application-managed services in the same enterprise server, but in these circumstances it is even more important that the application-managed services complete with all resources either committed or rolled back. This is because when the application container commits or rolls back resources on behalf of a container-managed application, it commits or rolls back all outstanding updates, including any outstanding from application-managed services that ran previously.

Parent topic: Managing Resources


Adding and Deleting Services

You can add services and implementation packages to an enterprise server instance, and update and delete them whether or not the enterprise server instance is running.

If the enterprise server instance is running (that is, if it has the status "Started") when you are adding services and packages, the changes are immediately reflected in the enterprise server. As long as the service is not currently responding to a client request, any updates are also accepted and take immediate effect.

You cannot delete a service, package or request handler if the resources are in use by a client request. You cannot delete a package if it is associated with a service, whether or not the service is running. If a service has operations, you can delete a service and all its operations and packages in one step, or you can delete individual operations and packages.

When you delete services, packages and request handlers, you are deleting objects in the Directory Server repository, not physical files. Every time a developer deploys a service using the Deploy tool or the imtkmake command, a new directory is created in the enterprise server's deploy directory to hold all the deployed files. If a developer redeploys a service that has already been deployed, the old deployment directory is no longer referenced, since the old service and package objects will have been deleted. You might want to delete old deployment directories from time to time.

If an enterprise server instance is running and you add, edit or delete resources, administration messages are sent to the enterprise server console indicating the success or otherwise of your changes.

It is possible for the Directory Server repository to become out-of-step with an enterprise server instance if the Directory Server accepts updates that the enterprise server instance rejects. If this happens you should stop the server and restart it to enable it to pick up the updates.

  • Creating Services Manually
  • To Add a Service to an Enterprise Server Instance
  • To Associate a Package with a Service
Parent topic: Deploying and Configuring Modernized Applications


Creating Services Manually

When you deploy a service using the Interface Mapping Toolkit, all the objects required are created automatically, complete with their relationships.

If you add services manually to an enterprise server instance, you need to create the objects for them and their relationships in a certain order, as follows:

  1. Add the implementation package to the enterprise server instance
  2. Add one or more service listeners
  3. Add the service, and associate the listener or listeners, implementation package and request handler with it
Parent topic: Adding and Deleting Services


To Add a Service to an Enterprise Server Instance

  1. Click Details against Services in the Objects column for the server you want to add the service to.
  2. Click Add.
  3. Specify a name for the service in Name.
  4. If you have more than one service of the same name in the repository, specify a search order for the service in Search Order. The lower the search order, the higher the search priority .
  5. If you want to enable clients to search for services by class, specify the class in Service Class.
  6. Change the default value in Version, if required.
  7. Choose the type of transaction management appropriate to this service: check either Application or Container.
  8. Click a listener you want to use on this service in Available Listeners and then click Add. You can repeat this step to add extra listeners. The listener is added immediately.
  9. Click the request handler you want to use on this service in Available Request Handlers and then click Select Handler. The selection is active immediately.
  10. Click the implementation package that is to provide the service functionality in Available Packages and then click Select Package. The selection is active immediately.
  11. Choose a status for the service from the list in Initial status.
  12. Specify any configuration information the service requires in Configuration Information.
  13. Specify a text description of the service in Description (optional).
  14. Click Add.
Note:
  • You can also reach the Add Service page by clicking Edit to the left of the server to which you want to add the service, clicking the Services tab and clicking Add.
  • You do not have to select a request handler and package for the service when you first add it to the server. You can do this at a later time by going to the Edit Service page.
Parent topic: Adding and Deleting Services
Parent topic: Work with Services
Related information
To manually deploy a service interface
To Add a Package to an Enterprise Server Instance


To Associate a Package with a Service

  1. On the Enterprise Server Administration screen, click Edit to the left of the server to which you want to add the package.
  2. Click the Packages tab and then click Add.
  3. Click Edit to the left of the row containing the service with which you want to associate the package.
  4. In Available Packages click the package that you want to associate with the service.
  5. Click Select Package.
Note:

A service can have just one package associated with it.

Parent topic: Adding and Deleting Services
Parent topic: Work with Packages


Configuring and Monitoring Services

When you are running services on an enterprise server instance, you need to ensure that services are starting and stopping as expected, and that no service is using more resources than expected.

The Monitor page enables you to view the performance of services, providing information about:

  • The average latency, in hundredths of a second.
  • The average time taken to complete a task, in hundredths of a second.
  • The number of tasks completed per second.

For example, if the average time taken to complete a task is large, this would indicate that a service is a long running or stateful service. If the number of tasks completed per second suddenly rises beyond what you expect, this might indicate that a task is repeatedly calling another task in error.

  • Services and Permissions
  • To Monitor Services
  • To Record Service Input and Output
  • To Add a Service for Integration with the Micro Focus Development Tools
  • To Change the Status of a Service
  • To Delete a Simple Service or an Operation
  • To Delete a Service with Operations
  • To Edit a Service
  • To Switch Logging On for a Service
  • To View Services for an Enterprise Server Instance
Parent topic: Deploying and Configuring Modernized Applications


Services and Permissions

If you have Modify permission level or higher you can:

  • Edit the attributes of a service
  • Switch logging on or off for a service. When logging is on, the service's request and result blocks are written to the enterprise server's dump data set
  • Change the status of a service between available and disabled

If you have Add/Delete permission level or higher you can also:

  • Add a service
  • Delete a simple service or operation
  • Delete a service with operations. When you delete a service with operations you delete all the operations associated with it. You can also delete the packages associated with it
Parent topic: Configuring and Monitoring Services


To Monitor Services

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To monitor services

  • Click either:

    • Monitor, 1 - This displays the Monitor (1 Minute Intervals) page. Use this to monitor the current situation. This page displays information on the last 32 minutes of activity.
    • Monitor, 15 - This displays the Monitor (15 Minute Intervals) page. Use this to gain information on how the system is performing overall. This page displays information on the last eight hours of operation.
Parent topic: Configuring and Monitoring Services
Parent topic: Administer a Server Using ESMAC


To Record Service Input and Output

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To record service input and output

  1. Click Services.

    The Services page is displayed.

  2. Click Details for the service for which you want the input and output to be recorded.

    The Services page is displayed.

  3. Click the Log I/O dropdown.

    Select Dump.

  4. Click Change.
Note:

If you set input and output to be recorded, they are only recorded during this enterprise server session. If you stop and restart the enterprise server, input and output will no longer be recorded.

If you want input and output to always be recorded, you can specify this using Enterprise Server Administration.

Parent topic: Configuring and Monitoring Services
Parent topic: Administer a Server Using ESMAC


To Add a Service for Integration with the Micro Focus Development Tools

  1. Click Details in the Object column for the server you want to add the service to.
  2. Click Add.
  3. In both Name and Service Class type: MF ES
  4. Leave the type of transaction management as Application.
  5. In Available Listeners, select the line containing Web Services and J2EE. Then click <-Add below this field.
  6. In Description type a suitable description, such as ES utility service.
  7. Click Add.
Note:
  • You can also reach the Add Service page by clicking Edit to the left of the server to which you want to add the service, clicking the Services tab and clicking Add.
  • Do not associate this service with a handler.
Parent topic: Configuring and Monitoring Services
Parent topic: Work with Services


To Change the Status of a Service

  1. Click Details against Services in the Objects column for the server you want to change.
  2. Click Edit in the Operation column for the service whose status you want to change.
  3. Choose the new status from the list in New Status.
  4. Click Apply.
Note:

Depending on the status of the change request, one of three messages is displayed in the Enterprise Server Administration GUI status bar:

  • MDS0112I Update success
  • MDS0111W Update request failure

In the case of a failure the state of the service, as reported by the ES Administration GUI, changes from "Available" or "Disabled" to a pending state. The next time the ES instance starts it will use the new configuration.

  • MDS0110W The specified configuration change may not take effect until the server is restarted

The state of the service, as reported by the Enterprise Server Administration GUI, changes from "Available" or "Disabled" to "Changes made to service: a server restart may be required for the new configuration to take effect". To check whether the service update was effective, use the ES Monitor and Control HTML GUI and select the "Services" resource list page.

Parent topic: Configuring and Monitoring Services
Parent topic: Work with Services


To Delete a Simple Service or an Operation

CAUTION:

Deleting a registered service might cause application connection errors and loss of data.

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details against Services in the Objects column for the server that owns the service you want to delete.
  3. Click Edit in the Operation column for the simple service or operation that you want to delete.
  4. Click Delete.
  5. Click OK on the confirmation page.
Parent topic: Configuring and Monitoring Services
Parent topic: Work with Services


To Delete a Service with Operations

CAUTION:

Deleting a registered service might cause application connection errors and loss of data.

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking
    expand button
  2. Click Details against Services in the Objects column for the server that owns the service you want to delete.
  3. Click Delete to the left of the row containing the service with operations that you want to delete. You see a page summarizing what you have requested.
  4. If you want to delete the packages associated with the operations, check Delete associated packages.
  5. Click OK.
Note:

When you delete a service, you are removing the service object from the Directory Server repository; the actual deployed files that make up the service are not deleted. For information on deleting old deployed files, see the link in Related Topics.

Parent topic: Configuring and Monitoring Services
Parent topic: Work with Services


To Edit a Service

CAUTION:

Changing the properties of a registered service might cause application connection errors and loss of data.

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details against Services in the Objects column for the server you want to edit.
  3. Click Edit in the Operation column for the service that you want to edit.
  4. Update the attributes of the service as required.
  5. Click OK.
Note:

If you make any changes to the listener or listeners, request handler or package associated with the service, the changes take effect immediately, not when you click OK.

Parent topic: Configuring and Monitoring Services
Parent topic: Work with Services


To Switch Logging On for a Service

  1. Click Details in the Objects column for the server that owns the service for which you want to switch logging on.
  2. Click Edit in the Operation column for the service for which you want to switch logging on.
  3. Check Logging.
  4. Click OK.
Note:

The effect of switching logging on is that the service's request and response blocks are written to a diagnostics file each time the service is invoked. This file is stored in the server's system directory, which defaults to %SYSTEMDRIVE%\Documents and Settings\user-ID\My Documents\Micro Focus\<product name> X.X\WORKAREA\es-name where es-name is the name of the enterprise server and user-ID is the user account that is running it. The file is named casdumpa.rec (or it might be named casdumpb.rec if you specified a maximum diagnostics file size on the Edit Server page).

If you are running the Directory Server as a service that logs on as the Local System account (LocalService), any Enterprise Server that it starts will also run under that account. Hence, the location of the files will typically be C:\Documents and Settings\LocalService\My Documents\Micro Focus\<product name> X.X\WORKAREA\es-name. By default, Windows hides the LocalService subdirectory of Documents and Settings. In order to view this directory, you must configure your Windows Explorer so that: Show hidden files and folders is set, and Hide protected operating system files is not set.

You can format and view the information from the Edit Server > Diagnostics > ES Console page. The client request is shown in a block named user-storage-type under the part of the dump entitled CAS-REQ. The server response is shown in a similar block under the title CAS-RESP.

Only switch logging on if you need diagnostics as it degrades performance.

Parent topic: Configuring and Monitoring Services
Parent topic: Work with Services


To View Services for an Enterprise Server Instance

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details against Services in the Objects column for the server for which you want to view services.
Parent topic: Configuring and Monitoring Services
Parent topic: Work with Services


Configuring Implementation Packages

An implementation package defines the application that provides the business functionality.

  • The Packages Table
  • Configuring Packages
  • Configuring Request Handlers
Parent topic: Deploying and Configuring Modernized Applications


The Packages Table

You can see the information held in the repository for packages by clicking Details next to Packages in the table of servers on the Home page. The packages table is shown below.

Figure 1. Packages Table
Packages Table

The information is as follows:

  • Name – this is unique in an enterprise server
  • Current status
  • Status log – this supplies information about the most recent event that occurred on this package
  • Package module – the name of the library containing the package, if it is part of a library
  • IDT – the name of the interface definition table (IDT) for this package
  • Package path – the location of the package module
  • Custom configuration data - this field is not used
  • Description
Parent topic: Configuring Implementation Packages


Configuring Packages

If you have Modify permission level or higher you can:

  • Edit the attributes of a package
  • Change the status of a package between available and unavailable
  • Associate a package with a service
  • Disassociate a package from a service

If you have Add/Delete permission level or higher you can also:

  • Add a package to an enterprise server
  • Delete a package, as long as it is not associated with any service

Outside Enterprise Server Administration, you can delete old deployment directories.

  • To Add a Package to an Enterprise Server Instance
  • To Delete a Package
  • To Edit a Package
  • To Disassociate a Package from a Service
  • To View Packages for an Enterprise Server Instance
  • To Delete Old Deployed Package Files
Parent topic: Configuring Implementation Packages


To Add a Package to an Enterprise Server Instance

  1. On the Enterprise Server Administration screen, click Edit to the left of the server to which you want to add the package.
  2. Click the Packages tab and then click Add.
  3. Specify a name for the package in Name.
  4. Choose a status from the list in Status.
  5. If the entry point that exposes this service is in a library that has a different name than the package itself, specify the name of the library in Module Package. Include the extension; library files have the extension .lbr or .dll
  6. Specify a full pathname for the interface definition table (IDT) in IDT.
  7. Check IDT Remains Resident if you want the IDT to be loaded into the repository while the service is running. This can help performance if the service is frequently used and there are no constraints on shared memory.
  8. Specify a full pathname for the executable file in Package Path. If you have set the COBPATH environment variable at enterprise server level in Configuration Information in the Add Server or Edit Server page, you must specify $COBPATH here, to add the value set at enterprise level to the search path for this package.
  9. Ignore Configuration Information; this field is not used.
  10. Specify a text description of the package in Description (optional).
  11. Click Add.
Parent topic: Configuring Packages
Parent topic: Work with Packages
Related information
To manually deploy a service interface
To Add a Service to an Enterprise Server Instance


To Delete a Package

  1. On the Enterprise Server Administration screen, click Edit to the left of the server to which you want to add the package.
  2. Click the Packages tab to display the packages for the enterprise server instance.
  3. Click Edit to the left of the row containing the package that you want to delete.
  5. Click Delete for the package.
  6. Click Delete on the confirmation page.
Note:
  • You can also delete a package by using the mfpackage command.
  • You cannot delete a package if it is associated with any service.
  • When you delete a package, you are removing the package object from the Directory Server repository; the actual deployed files that make up the package are not deleted.
Parent topic: Configuring Packages
Parent topic: Work with Packages


To Edit a Package

  1. On the Enterprise Server Administration screen, click Edit to the left of the server to which you want to add the package.
  2. Click Edit to the left of the row containing the package that you want to edit.
  3. Update the attributes of the package as required.
  4. Click Apply.
Parent topic: Configuring Packages
Parent topic: Work with Packages


To Disassociate a Package from a Service

  1. On the Enterprise Server Administration screen, click Edit to the left of the server to which you want to add the package.
  2. Click the Packages tab and then click Add.
  3. Click Edit to the left of the row containing the service from which you want to disassociate the package.
  4. In Available Packages click the package that you want to replace the currently associated package.
  5. Click Select Package.
Note:

A service can have just one package associated with it.

Parent topic: Configuring Packages
Parent topic: Work with Packages


To View Packages for an Enterprise Server Instance

  1. On the Enterprise Server Administration screen, click Edit to the left of the server to which you want to add the package.
  2. Click the Packages tab to display the packages for the enterprise server instance.
Parent topic: Configuring Packages
Parent topic: Work with Packages


To Delete Old Deployed Package Files

CAUTION:
Use this procedure with great care. Be sure that you are deleting the correct directory, and delete the service containing the packages from the Directory Server repository before you delete the old package files.
  1. Go to the Deploy folder of the enterprise server to which the service was deployed. By default this is %ProgramFiles(x86)%\Micro Focus\Server Enterprise Edition x.x\bin if Server Enterprise Edition is installed stand alone, and %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\deploy if Server Enterprise Edition is installed as part of Studio Enterprise Edition . Here you will find several directories with names of the form: service-name.random-string where service-name is the name of the service supplied during the creation of the service interface, and random-string is a string of random characters generated by the deploy process.
  2. Identify the directory that you want to delete; the date and time of creation of the directory are probably the best guide.
  3. Right-click the directory and click Delete on the popup menu.
Parent topic: Configuring Packages
Parent topic: Work with Packages


Configuring Request Handlers

A request handler is software that receives a client request for access to the service, and translates the request into a form that the application providing the business functionality can understand. The following request handlers are provided with Enterprise Server :

  • MFRHSOAP – handles requests that use SOAP (Simple Object Access Protocol). These are requests for Web services. They are coded in XML.
  • MFRHBINP – handles binary requests made by the Micro Focus J2EE connector.
  • The Request Handlers Table
  • Configuring Handlers
Parent topic: Configuring Implementation Packages


The Request Handlers Table

You can see the information held in the repository for request handlers by clicking Details against Request Handlers in the table of servers on the Home page. The request handlers table is shown below.

Figure 1. Request Handlers Table
Request Handlers Table

The information is as follows:

  • Module name
  • Module path
  • Current status
  • Status log – this supplies information about the most recent event that occurred on this request handler
  • Custom configuration data - this field is not used
  • Description
Parent topic: Configuring Request Handlers


Configuring Handlers

If you have Modify permission level or higher you can:

  • Edit the attributes of a request handler
  • Change the status of a request handler between available and unavailable
  • Associate a request handler with a service
  • Disassociate a request handler from a service

If you have Add/Delete permission level or higher you can also:

  • Add a request handler to an enterprise server instance
  • Delete a request handler. You cannot delete MFRHBINP
  • To Add a Request Handler to an Enterprise Server Instance
  • To Edit a Request Handler
  • To Associate a Request Handler with a Service
  • To Disassociate a Request Handler from a Service
  • To Delete a Request Handler
  • To View Request Handlers for an Enterprise Server Instance
Parent topic: Configuring Request Handlers


To Add a Request Handler to an Enterprise Server Instance

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details against Handlers in the Objects column for the server you want to add the request handler to.
  3. Click Add.
  4. Specify a name for the request handler in Module Name.
  5. Specify a full pathname for the request handler in Module Path.
  6. Choose a status from the list in Status.
  7. Ignore Configuration Information; this field is not used.
  8. Specify a text description of the request handler in Description (optional).
  9. Click Add.
Note:

You can also reach the Add Handler page by clicking Edit to the left of the server to which you want to add the handler, clicking the Handlers tab and clicking Add.

Parent topic: Configuring Handlers
Parent topic: Work with Request Handlers


To Edit a Request Handler

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details against Handlers in the Objects column for the server that owns the request handler you want to edit.
  3. Click Edit to the left of the row containing the request handler that you want to edit.
  4. Update the attributes of the request handler as required.
  5. Click OK.
Note:

Any changes that you make only affect the request handler object that the current server owns. Request handler objects of the same name in other enterprise servers are unaffected.

Parent topic: Configuring Handlers
Parent topic: Work with Request Handlers


To Associate a Request Handler with a Service

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button.
  2. Click Details against Handlers in the Objects column for the server that owns the service with which you want to associate the request handler.
  3. Click Edit to the left of the row containing the service that you want to associate the request handler with.
  4. In Available Request Handlers click the request handler that you want to associate with the service.
  5. Click Select Handler.
Note:

A service can have just one request handler associated with it.

Parent topic: Configuring Handlers
Parent topic: Work with Request Handlers


To Disassociate a Request Handler from a Service

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details against Handlers in the Objects column for the server that owns the service from which you want to disassociate the request handler.
  3. Click Edit to the left of the row containing the service from which you want to disassociate the request handler.
  4. In Available Request Handlers click the request handler that you want to replace the currently associated request handler.
  5. Click Select Handler.
Note:

A service can have just one request handler associated with it.

Parent topic: Configuring Handlers
Parent topic: Work with Request Handlers


To Delete a Request Handler

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details against Handlers in the Objects column for the server that owns the handler you want to delete.
  3. Click Edit to the left of the row containing the request handler that you want to delete.
  4. Click Delete.
  5. Click OK on the confirmation page.
Note: You cannot delete a request handler if it is associated with any service. You cannot delete the MFRHBINP request handler.
Parent topic: Configuring Handlers
Parent topic: Work with Request Handlers


To View Request Handlers for an Enterprise Server Instance

  1. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button
  2. Click Details against Handlers in the Objects column for the server for which you want to view request handlers.
Parent topic: Configuring Handlers
Parent topic: Work with Request Handlers


Deploying Interfaces Generated by the Interface Mapping Toolkit

Before you can run a service interface that has been generated using the Interface Mapping Toolkit, it needs to be deployed to an enterprise server. The service interface comprises the mapping information and might include the COBOL program and any required data.

During development the developer usually deploys the interface automatically using the Deploy tool in the Interface Mapping Toolkit. Once it is ready for use in a production environment however, you should deploy it using the .car file that was produced when the Deploy tool was run for the last time.

  • About IMTK Deployment
Parent topic: Deploying and Configuring Modernized Applications


About IMTK Deployment

After a COBOL program has been mapped using the Interface Mapping Toolkit, it needs to be deployed to an enterprise server instance. During the development process the developer deploys the interface using the Deploy tool, which is part of the Toolkit. This tool not only automatically deploys the interface to an enterprise server instance, it also packages all the files required to deploy a service to a COBOL archive file (.car file). Typically, once the service is ready to be run in a production environment, deployment becomes your responsibility. You deploy the interface from the .car file created when the Deploy tool was last used.

If the service has been mapped as an EJB interface, there are some extra tasks to perform:

  • Deploy the EJB to a J2EE application server
  • Deploy a resource adapter
  • Deploying the .car Fle Using mfdepinst
  • Deploying the .car File Manually
Parent topic: Deploying Interfaces Generated by the Interface Mapping Toolkit


Deploying the .car Fle Using mfdepinst

The mfdepinst command handles the server-side part of the process of deploying a service to enterprise server. The tool installs the services contained in a .car onto the enterprise server. It is the equivalent of unpacking the .car file manually and adding the files using Enterprise Server Administration.

The mfdepinst command extracts the files (.int, .idt, and so on) from the .car file, updates the Directory Service directory for the new services and packages, and if the enterprise server is running tells it about the new services so they are available for use.

  • mfdepinst
    Installs the services contained in a COBOL archive file (.car file) onto the enterprise server.
Parent topic: About IMTK Deployment


mfdepinst

Installs the services contained in a COBOL archive file (.car file) onto the enterprise server.

Syntax:

mfdepinst myservice.car

Parameters:

myservice.car The name of the .car file containing the service to be deployed

Dependencies:

mfdepinst must be in the same directory as the .car file.

There must be a .mfdeploy file in the parent directory. So, for example, if the .car file is in $COBDIR/deploy/test, there must be a .mfdeploy file in $COBDIR/deploy (which is the installation default deployment directory).

Comments:

mfdepinst extracts files from the .car file into the current directory. It extracts files with relative pathnames into subdirectories, which it creates as necessary. Files without paths or with absolute pathnames are extracted into the current directory. mfdepinst overwrites any files in the current directory with those in the .car file.

mfdepinst records its progress in the file deploylog.txt in the current directory, overwriting any existing deploylog.txt. After mfdepinst completes, you can examine this file to find out if deployment succeeded.

Example:

To install the services from /tmp/myservice.car:

cd $COBDIR/deploy
    mkdir myservice
    cd myservice
    cp /tmp/myservice.car .
    mfdepinst myservice.car
    cat deploylog.txt
Parent topic: Deploying the .car Fle Using mfdepinst
Parent topic: Administration and Configuration Commands


To manually deploy a service interface

  1. Unzip the COBOL archive file for the service interface, using a utility such as Winzip. This archive file is called myservice.car and is in \myservice\myservice.deploy
  2. Start Enterprise Server Administration.
  3. Add the implementation package of the COBOL service being deployed. Among other things, you specify the path and name of the IDT, the executable file and the data files.
  4. Add the COBOL service. Among other things, you specify the listener to use on this service, and the implementation package that is to provide the service functionality.
Parent topic: Deploying the .car File Manually
Parent topic: Deploy Interfaces
Related information
To Add a Service to an Enterprise Server Instance
To Add a Package to an Enterprise Server Instance
Deploying the .car File Manually


Deploying EJBs and Resource Adapters

An EJB running a COBOL service runs in two places: the COBOL service runs under an enterprise server, and the EJB and client run under a third party J2EE application server, such as WebSphere or WebLogic.

Resource adapters enable EJBs deployed on J2EE to communicate with COBOL on an enterprise server. Resource adapters are also known loosely as J2EE connectors

  • Enterprise Server Acting as a Resource Manager
  • Deploying EJBs Overview
  • Resource Adapters Supplied by Micro Focus
  • Deployment Descriptors that Are Required
  • CustomRecord and the RuntimeProperties Support
  • Third Party Application Server Deployment
  • Troubleshooting
Parent topic: Deploying and Configuring Modernized Applications


Enterprise Server Acting as a Resource Manager

J2EE clients run in a J2EE application server such as IBM WebSphere or Oracle WebLogic. When a service is processing requests from a J2EE client, the J2EE application server can be a transaction manager coordinating updates to all the resources involved in a transaction. In this situation, the enterprise server instance behaves like a resource manager and responds to commit and rollback requests from the J2EE application server, whether the COBOL service is container-managed or application-managed.

Parent topic: Deploying EJBs and Resource Adapters


Deploying EJBs Overview

An EJB running a COBOL service runs in two places: the COBOL service runs under an enterprise server, and the EJB and client run under a third party J2EE application server, such as WebSphere or WebLogic.

You deploy the COBOL service from the .car file or, if you are a developer, by using the Deploy tool in the Interface Mapping Toolkit.

You deploy the EJB and client by deploying the following to a J2EE application server:

  • The enterprise archive file myservice.ear. This file is created automatically when you generate a Java client. The file contains the:
    • EJB archive file myservice.jar. This file is created when you generate a client and also when you use the Deploy tool to deploy the service interface.
    • Client archive file myservice.war. This file is created when you generate a client.

    If you haven't generated an .ear file, but have only the .jar file, you might be able to deploy the .jar file instead. Your J2EE application might require you to package the .jar file into an .ear before deploying it, or you might find it simpler to do that.

  • One of the supplied resource adapters, mfcobol*.rar. A resource adapter enables the EJB to communicate through its J2EE application server with an enterprise server. Resource adapters are also known as J2EE connectors and they are packaged in resource archive (.rar) files.

Many J2EE application servers are supported, such as BEA WebLogic and IBM WebSphere. Each application server has different deployment requirements and different utilities to help.

  • Deploying EJBs
  • To Add Micro Focus Support for EJBs
  • To Create an .ear File for your EJB
  • To Deploy to WebLogic
  • To Deploy to WebSphere
  • To Deploy to JBoss
  • To deploy to Oracle Application Server
Parent topic: Deploying EJBs and Resource Adapters


Deploying EJBs

Deploying EJBs involves configuring them in the third party application server on the J2EE machine, so that the EJBs, resource adapter and Enterprise Server can locate each other.

When you deploy an EJB you use the interface for your third-party application server. Many application servers provide a Web-based interface, such as the WebLogic Server Console, which takes you step by step through the deployment process. Most third-party application servers require the EJB to be packaged in an application .ear file, together with the client and all the necesssary deployment descriptors and other files.

This .ear file is generated automatically when you generate a client using the Interface Mapping Toolkit.

If you don't have an application .ear file, you can often use your application server's administration interface to create one, or you can use the jar command.

Parent topic: Deploying EJBs Overview


To Add Micro Focus Support for EJBs

  1. Locate the file mfejblib.jar, which contains the Micro Focus support for EJBs.

    Specific versions of this file are supplied for each supported application server and J2EE version. They are available in subdirectories under %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin\j2ee14 and \javaee5 in your COBOL system installation or the CD or DVD. They are in the following the application server subdirectories:

    • j2ee14/beaweblogic9
    • j2ee14/ibmwebsphere6
    • j2ee14/ibmwebsphere61
    • j2ee14/jboss4
    • javaee5/ibmwebsphere7
  2. Copy mfejblib.jar to the root directory of your enterprise archive file (.ear). By default, the mfejblib.jar belongs in the root because the classpath is set to this in the EJB's manifest.mf file.

    If you copy mfejblib.jar to a different directory, you need to change the classpath in the manifest.mf file in the EJB's .jar file, which is in \myservice\myservice.deploy.

  3. Add the mfejblib.jar file to the archive file that you want to deploy.

    For most application servers, you can do this using their administrative tools. Alternatively, you can use a jar command similar to the following:

    jar -uvf myApplication .ear mfejblib.jar

Parent topic: Deploying EJBs Overview
Parent topic: Deploy Interfaces


To Create an .ear File for your EJB

If you have generated a client and EJB together, they are automatically packaged into an enterprise archive file (.ear) and you do not need to do this. Otherwise:

  1. Package the EJB's .jar file into an .ear for your application. To do this use a jar command similar to the following:

    jar -cvf myApplication .ear myService.jar

    If you have a client .war file you can add that to the .ear file in the same way.

  2. Create a deployment descriptor application.xml either using your application server's tools or by copying and editing a sample, as follows:
    1. Locate a sample .ear, which is in examples directory in mapdemo/mapdemo/repos/myService.deploy/JMapServ-WL.ear
    2. Extract the descriptor application.xml from the .ear file, using the following jar command:
      jar -xvf JMapServ-WL.ear META-INF/application.xml
    3. Make a copy of the application.xml descriptor and edit it, replacing JMapServ with the name of your .jar file. You can also add the name of your .war file if you added that to the .ear file.
    4. Put the descriptor in the meta-inf subdirectory of the directory containing your .ear file.
    5. Package the descriptor into your .ear file using a jar command similar to:
      jar -uvf myService.ear META-INF/application.xml
Parent topic: Deploying EJBs Overview
Parent topic: Deploy Interfaces


To Deploy to WebLogic

This topic describes how to deploy an application developed using the Interface Mapping Toolkit to WebLogic Application Server.

  1. If you have not set up a WebLogic server domain, set one up using the WebLogic Domain Configuration Wizard, following the instructions in the wizard. You can start the wizard from the Start menu.
  2. If your COBOL system (either Studio Enterprise Editionor Server Enterprise Edition) is installed in a location that uses a spacey path, you need to copy the following files to a non-spacey location:
    • mfcobolpure.jar - This is by default in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin and \base\bin\win64 of your COBOL system installation.
    • mfconnector.jar - This is by default in a subdirectory under %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin\j2ee14 and \javaee5 of your COBOL system installation. You need the jar file that corresponds to the WebLogic version that you are using, such as the mfconnector.jar in the j2ee14\beaweblogic9 subdirectory.
  3. Open the startup script for your project in a text editor. This startup script is StartWebLogic.cmd , and is located in your domain directory of your WebLogic installation.
  4. Go to the end of the file.
  5. Above the line @rem Call WebLogic Server , add the following lines:
    set java_home=jdk_path
set mf_home=mfcobolpure_path
set classpath=%java_home%\lib\tools.jar;
              %mf_home%\mfconnector_path\mfconnector.jar;
              %mf_home%\mfcobolpure.jar

    Where:

    • jdk_path is the location of the JDK installation to use for WebLogic.
    • mfcobolpure_path is the path containing mfcobolpure.jar.
    • mfconnector_path is the path containing the required mfconnector.jar. If you have copied this jar into the same directory as mfcobolpure.jar, you don't need to specify this path.
  6. Save the file.
  7. You can now run the startup script.

To start WebLogic

  1. Set up a WebLogic server domain and edit the startup script, if you have not already done so.
  2. Go to the Start menu for WebLogic and choose the domain and server that you specified in your startup script. This Start menu item runs the startup script.

    You cannot start WebLogic using Services in Windows Control Panel and you cannot configure it in Control Panel to start automatically when you reboot the machine.

To start WebLogic server console:

  1. Start WebLogic.
  2. Open a browser.
  3. Enter the URL, http://localhost:7001/console where 7001 is the default port for the server console.

To deploy a resource adapter to WebLogic

  1. Start WebLogic server and the WebLogic Server Console.
  2. In the left pane of WebLogic Server Console, expand your-domain >Deployments>Connectors
  3. Click Configure a new Connector Component and follow the steps on the page. When you are asked to upload the resource adapter file, upload the required mfcobol*.rar file.

    The resource adapter must be deployed on a machine where your COBOL system (either Studio Enterprise Editionor Server Enterprise Edition) is installed.

    You do not need to create a connection factory or specify the JNDI name of the resource adapter because these are already specified in the deployment descriptor for the connection factory, weblogic-ra.xml

  4. Confirm that the resource adapter has been successfully deployed, by examining the Deployment Activity table on the page on the right. The resource adapter should also be listed in the hierarchy on the left.
Note: To deploy the local transaction connector (mfcobol-localtx.rar), first deploy the XA transaction connector (mfcobol-xa.rar) and then undeploy it. You will then be able to install the local transaction connector.

To deploy an EJB to WebLogic

  1. If you don't have a .ear file containing your EJB, package the EJB into an.ear file now. You will have an .ear file if you generated a client and EJB together, and it will be in myProject\repos\myservice.deploy
  2. Start WebLogic server and the WebLogic Server Console.
  3. Deploy the .ear file as follows:
    1. In the left pane expand mydomain >Control> myserver
    2. Click Configure a new Application on the right, and follow the steps on the page.
    3. Confirm that the application has been successfully deployed, by examining the Deployment Activity table on the page on the right. The application should also be listed in the hierarchy on the left

To stop WebLogic

  1. Start the WebLogic server console, if it is not already started.
  2. Navigate to your server in the left-hand pane. This will probably mean expanding: mydomain >Control> myserver
  3. Right-click your server.
  4. Click Start/Stop server and follow the instructions.

TheWebLogic Server Console will not be available until you restart the server.

Parent topic: Deploying EJBs Overview
Parent topic: Deploy Interfaces


To Deploy to WebSphere

This topic describes how to deploy an application developed using the Interface Mapping Toolkit to WebSphere Application Server.

To start WebSphere server:

Either start the server from the Start menu, or run the startup script by entering the following command from the bin directory of your WebSphere installation:

startserver myServer

To start WebSphere administrative console

  1. Start WebSphere server and WebSphere Administrative Console.
  2. In the left pane click ResourcesResource Adapters
  3. Click Install RAR on the page on the right, and follow the instructions on the screen.

    When you are asked for the resource adapter file, specify the required mfcobol*.rar file.

  4. The new resource adapter is now listed on the right. Click it to display its properties.
  5. Add a connection factory for the resource adapter. You might need to scroll to Additional Properties at the end and then click J2C Connection Factories. Then click New and follow the instructions on the screen to specify:
    • CCIMFCobol_v1.5 as the reference name for the connection factory
    • eis/MFCobol_v1.5 as the JNDI name for the connection factory
  6. Confirm that the new resource adapter is now listed on the right.
Note: The resource adapter must be deployed on a machine where your COBOL development system is installed.

To deploy an EJB to WebSphere

  1. If you don't have an .ear file containing your EJB, package the EJB into an .ear file now. You will have a. ear if you generated a client and EJB together, and it will be in myProject\repos\myservice.deploy.
  2. Start WebSphere server and WebSphere Administrative Console.
  3. In the Administrative Console, click ApplicationsInstall New Application on the left
  4. Follow the instructions on the screen. Most of the information will default to information in the generated deployment descriptors and you do not need to change it. You will however need to specify the following:
    Path to ear file
    Specify the path to your .ear file
    Deploy EJBs
    Check this
    JNDI name of EJB
    Specify any name you like, but it must match the JNDI name that other components of your application use when they refer your EJB
    Map EJB ref to an enterprise bean
    Specify the same JNDI name that you specified above

To stop WebSphere server

Either stop the server from the Start menu or:

  • Run the stop script by entering the following command from the bin directory of your WebSphere installation:
    stopserver myserver
Parent topic: Deploying EJBs Overview
Parent topic: Deploy Interfaces


To Deploy to JBoss

This topic describes how to deploy an application developed using the Interface Mapping Toolkit to JBoss Application Server.

Installing JBoss Application Server

You can download JBoss Application Server from http://www.jboss.com, and install it from there.

To open JBoss Application Server:

  • Enter the URL http://localhost:8080 in your Web browser, where 8080 is the default port.

Administering JBoss Application Server

JBoss Application Server provides a Web interface for administering the application server. This administration interface is called the JBoss console. To start the console:

  • Enter http://localhost:8080/jmx-console/ in your Web browser, where 8080 is the default port.

Setting up JBoss Application Server

The JBoss Application Server provides deployment descriptors. These are packaged into the application archive (.ear) files when you generate EJBs using the Interface Mapping Toolkit. The deployment descriptors require some changes before generating EJBs. These changes are described below, in which JBOSS_HOME is the top-level directory of your JBoss installation, and default is the location of the default server configuration in your JBoss installation.

For JBoss 4.2.3, change the following:

  • In JBOSS_HOME\server\default\conf\jboss-service.xml set the following attribute to true:
    • CallByValue
  • In JBOSS_HOME\server.home\default\deploy\ear-deployer.xml change the following attributes:
    • Isolated - set to false
    • CallByValue - set to true
  • In JBOSS_HOME\server.home\default\deploy\jboss-web.deployer\META-INF\jboss-service.xml set the following attributes:
    • Java2ClassLoadingCompliance - to true
    • UseJBossWebLoader - to false

For JBoss 5.1.0, change the following:

  • In JBOSS_HOME\server\default\conf\jboss-service.xml set the following attribute to true:
    • CallByValue
  • In JBOSS_HOME\server\default\deployers\ear-deployer-jboss-beans.xml change the following attributes:
    • Isolated - set to false
    • CallByValue - set to true
  • In JBOSS_HOME\server\default\deployers\ejb-deployer-jboss-beans.xml set the following attribute to true:
    • CallByValue
  • In JBOSS_HOME\server\default\deployers\jboss-web.deployer\META-INF\war-deployers-jboss-beans.xml set the following attribute to true:
    • Java2ClassLoadingCompliance

Starting and Stopping JBoss Application Server

You can start and stop JBoss Application Server from the JBoss console or from the command line, as follows.

:

  • Run jboss_home\bin\run.bat to start it.
  • Run jboss_home\bin\shutdown.bat -S to stop it.

:

Deploying the Resource Adapter

Resource adapters, named mfcobol*.rar, are supplied together with JBoss-specific deployment descriptors for using the resource adapters with the JBoss Application Server. The descriptors have names corresponding to the resource adapters, as follows:

  • mfcobol-notx-ds.xml is the desciptor for the resource adapter mfcobol-notx.rar
  • mfcobol-localtx-ds.xml is for mfcobol-localtx.rar
  • mfcobol-xa-ds.xml is for mfcobol-xa.rar

To deploy a resource adapter:

  1. Copy the appropriate .rar file into your JBoss deployment directory, which is by default jboss_home\server\default\deploy
  2. Copy the corresponding deployment descriptor,*ds.xml , for the resource adapter into the same directory. For example, if you are deploying mfcobol-notx.rar, copy mfcobol-notx-ds.xml.

Deploying the Application .ear File

When you generate an application .ear file the JBoss Application Server requires that the .ear file contains deployment descriptors that specify deployment information about your application. When you use generate a client and EJB using the Interface Mapping Toolkit, these deployment descriptors are automatically created and packaged into the .ear.

To deploy your application .ear file:

  1. Copy the application .ear file from the directory my-project\repos\my-service.deploy\my-service.ear into your JBoss deployment directory which is, by default, jboss_home\server\default\deploy

Logging

JBoss stores log files and traces by default in jboss_home\server\default\log\server.log

Configuring a JDBC Data Source for XA Transactions

If the application being deployed connects to a third party database, you will need to configure a JDBC data source and specify information such as the JNDI name of the data source. For an Oracle database, you edit the Oracle-supplied deployment descriptor oracle-xa-ds.xml. For full details see the JBoss administration documentation on configuring JDBC data sources.

Further Information

For further information, see the Release Notes for your JBoss Application Server installation and the JBoss Web site.

Parent topic: Deploying EJBs Overview
Parent topic: Deploy Interfaces


To deploy to Oracle Application Server

This topic describes how to deploy an application developed using the Interface Mapping Toolkit to Oracle Application Server.

Introduction

To run an application on Oracle Application Server you need to:

  • Have Oracle Application Server installed.
  • Deploy one of the Micro Focus resource adapters, which are supplied, together with default deployment descriptors.
  • Deploy the application .ear file. You can generate this automatically when you generate a client for your EJB using the Interface Mapping Toolkit. Default deployment descriptors are also generated and packaged in the .ear file when you generate a client.

You can deploy using the Web-based administration console, called Enterprise Manager, or you can deploy using the command line tool dcmctl.

When you deploy an application .ear file or a resource adapter, you deploy it to an instance of Oracle Application Server Containers for J2EE (OC4J). An OC4J instance called Home is created by default when you install Oracle Application Server.

Installing and Starting Oracle Application Server

You can install Oracle Application Server by downloading it from http://www.oracle.com

To open Oracle Application Server, enter the URL http://localhost:7777 in your browser.

To start the administration console, Enterprise Manager, enter the URL http://localhost:1810 in your browser.

The default ports are:

7777: | HTTP port
4443: | HTTPS port
1810: | Enterprise Manager port

Resource Adapters

The following resource adapters are supplied for Oracle Application Server:

  • mfcobol-notx-ora.rar - does not support transactions
  • mfcobol-localtx-ora.rar - supports local transactions
  • mfcobol-xa-ora.rar - supports XA transactions

For the location and details of the resource adapters, see the section Resource Adapters in the chapter Deploying Interfaces in your Configuration and Administration Guide

Deployment Descriptors

Oracle Application Server requires that deployment information is supplied in deployment descriptors. For background, see the section Deployment Descriptors in the chapter Mapping a Java Interface and Using Resource Adapters in your Java and COBOL book.

For background on deployment descriptors, see the chapter Mapping a Java Interface and Using Resource Adapters in your Java and COBOL book.

Default deployment descriptors for your application are automatically generated when you generate a client for the EJB. They are packaged in the archive files (.ear .jar .war) and are named orion-*.xml

A default deployment descriptor for the resource adaptors is included in the supplied .rar archive files. This deployment descriptor,oc4j-ra.xml contains configurations for deploying resource adapters to OC4J. It includes:

  • EIS connection information that matches the information specified in the deployment descriptor of the resource adapter
  • JNDI name to be used
  • Connection pooling parameters
  • Resource principal mapping mechanism and configurations

You might need to modify oc4j-ra.xml. For example, you might need to change the server host from localhost to the name of the machine on which your enterprise server is running. To modify this file, extract it from the required .rar file, and reinstate it there after editing.

Note: Do not change the connector-factory location, which must remain set to: eisMFCobol_v1.0

Deploying Using the Command Line

You can use the command line tool dcmctl to deploy a resource adapter or your application .ear file, and for other administration tasks. For full details of all the commands and their syntax, see the Oracle documentation. The following commands are a few simple examples.

To start Oracle Application Server, go to the Start menu and select your Oracle Application Server.

To deploy the resource adapter mfcobol-notx-ora.rar, use a command such as:

dcmctl deployApplication -f d:\product name X.X\base\bin\mfcobol-notx-ora.rar -a mfcobol-notx-ora

To deploy the application myapplication.ear, use a command such as:

dcmctl deployApplication -f d:\myproject\repos\myapplication.ear -a myapplication

Setting Up Logging

To switch on logging, use Enterprise Manager. Go to the Command Line Options and specify the following options:

In this field: | Enter:
OC4J Options | -properties -out oc4j.out -err oc4j.err
Java Options | -Dhttp.session.debug=true -Dtransaction.debug=true

Further Information

For further information, see the Release Notes for your Oracle Application Server installation and the OC4J Connectors FAQ on the Oracle Web site.

Parent topic: Deploying EJBs Overview
EJBs and Resource Adapters
To add support for Micro Focus resource adapters
To deploy a Micro Focus resource adapter to a J2EE application server


Resource Adapters Supplied by Micro Focus

The Micro Focus resource adapters enable EJBs deployed on J2EE to communicate with COBOL on an enterprise server. Resource adapters are also known loosely as J2EE connectors.

Before an EJB can communicate with the COBOL code running on an enterprise server, you need to:

  • Deploy a resource adapter to the J2EE application server. Only one resource adapter can be deployed at a time. This resource adapter then handles all the binary requests being sent to the enterprise server.

    You must deploy a resource adapter appropriate to your application server and the J2EE version it uses. The following resource adapters are supplied for each supported application server and J2EE version:

    • mfcobol-notx.rar - does not support transactions
    • mfcobol-localtx.rar - supports local transactions
    • mfcobol-xa.rar - supports XA transactions
  • Ensure that support for the resource adapter is available, by adding the archive files mfcobolpure.jar and mfconnector.jar to your classpath environment variable. Again, you must add support for the resource adapter appropriate to your application server and the J2EE version it uses.

The information needed to deploy the resource adapters is set up in deployment descriptors.

  • To Add Support for Micro Focus Resource Adapters
  • To Deploy a Micro Focus Resource Adapter to a J2EE Application Server
Parent topic: Deploying EJBs and Resource Adapters
Related information
To add support for Micro Focus resource adapters
To deploy a Micro Focus resource adapter to a J2EE application server
Deployment Descriptors that Are Required


To Add Support for Micro Focus Resource Adapters

  1. Edit the classpath to point to the archive files mfcobolpure.jar and mfconnector.jar, which contain the classes that support for the Micro Focus resource adapters.

    To do this, use the command:

    set classpath=
          %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin\mfcobolpure.jar;jar_path\mfconnector.jar;%classpath%

    where jar_path is the path to the archive files appropriate to your application server.

    Specific versions of these files are supplied for each supported application server and J2EE version. They are available in the application server subdirectories under %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin\j2ee14 and \javaee5 in your COBOL system installation or on the CD or DVD, as follows:

    • j2ee14/beaweblogic9
    • j2ee14/ibmwebsphere6
    • j2ee14/ibmwebsphere61
    • j2ee14/jboss4
    • javaee5/ibmwebsphere7
    • javaee5/jboss5
Parent topic: Resource Adapters Supplied by Micro Focus
Parent topic: Deploy Interfaces


To Deploy a Micro Focus Resource Adapter to a J2EE Application Server

  1. Start your J2EE application server and its administration console, and navigate to where you add resource adapters.

    The resource adapter must be deployed on a machine where a COBOL system such as Server Enterprise Edition or Studio Enterprise Edition is installed.

  2. Specify the resource adapter to deploy. These can be one of the following:
    • mfcobol-notx.rar - does not support transactions
    • mfcobol-localtx.rar - supports local transactions
    • mfcobol-xa.rar - supports XA transactions

    Specific versions of these files are supplied for each supported application server and J2EE version. They are available in the application server subdirectories under %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin\j2ee14 and \javaee5 in your COBOL development system, as follows:

    • j2ee13/beaweblogic8
    • j2ee13/oracle1012
    • j2ee14/beaweblogic9
    • j2ee14/ibmwebsphere6
    • j2ee14/ibmwebsphere61
    • j2ee14/jboss4
    • j2ee14/oracle1013
    • javaee5/ibmwebsphere7
  3. Ensure that the support for the resource adapters and ensure it is on your path and classpath environment variables.
  4. You might need to provide the application server with a deployment descriptor for the resource adapter. Deployment descriptors are supplied for the following application servers:
    • JBoss - mfcobol*ds.xml, which are supplied in the folder with the .rar files
    • Oracle - oc4j-ra.xml, which is packaged in each .rar file
    • WebLogic - weblogic-ra.xml, which is packaged in each .rar file
    • WebSphere - does not require deployment descriptors

    Among other things, the deployment descriptors specify the following connection information, and you must not change this.

    Note: The JNDI name and the reference name that you enter both depend upon your J2EE version.
    JNDI name | Reference name
    J2EE 1.3 | eis\MFCobol_v1.0 | CCIMFCobol_v1.0
    J2EE 1.4 | eis\MFCobol_v1.5 | CCIMFCobol_v1.5
    Java EE 5 | eis\MFCobol_v1.5 | CCIMFCobol_v1.5
    Java EE 6 | eis\MFCobol_v1.5 | CCIMFCobol_v1.5
    Note: The resource adapter must be deployed on a machine where either Micro Focus Server or your COBOL development system is installed.
Parent topic: Resource Adapters Supplied by Micro Focus
Parent topic: Deploy Interfaces


Deployment Descriptors that Are Required

Deployment descriptors are xml files that describe the component to be deployed. J2EE application servers require deployment descriptors for the archive files (.jar, .war and .ear) to be deployed. At run time, the application server reads the descriptors and acts accordingly.

When you generate an EJB or client using the COBOL development system Studio Enterprise Edition, generic deployment descriptors are created and they are packaged into the relevant archive files. Some J2EE application servers require additional deployment descriptors and these are generated automatically for the supported application servers.

If your application server requires additional deployment descriptors and these are not generated, you need to create them manually and add them to the archive files. In many cases, you can create deployment descriptors using the administration console for your application server. Alternatively you can edit them in a text editor.

For example, the deployment descriptor weblogic-ra.xml, which is in the archive file mfcobol-notx.rar, contains the following lines:

<connection-factory-name>CCIMFCobol_ver</connection-factory-name>
<jndi-name>eis/MFCobol_ver</jndi-name>

Where ver is v1.5 for j2ee14

  • To Create Deployment Descriptors Manually
Parent topic: Deploying EJBs and Resource Adapters
To create deployment descriptors manually


To Create Deployment Descriptors Manually

You can create deployment descriptors using the administration tool provided by your J2EE application server. Alternatively, you can generate a sample descriptor using the Interface Mapping Toolkit and edit the sample. You need to specify the following information in the deployment descriptor:

  • The JNDI name of the EJB. This can be any name you like, but it must match the JNDI name that other components of your application use when they refer your EJB.
  • The JNDI name and resource reference name of the Micro Focus resource adapter.

    Among other things, the deployment descriptors specify the following connection information, and you must not change this.

    Note: The JNDI name and the reference name that you enter both depend upon your J2EE version.
    JNDI name | Reference name
    J2EE 1.3 | eis\MFCobol_v1.0 | CCIMFCobol_v1.0
    J2EE 1.4 | eis\MFCobol_v1.5 | CCIMFCobol_v1.5
    Java EE 5 | eis\MFCobol_v1.5 | CCIMFCobol_v1.5
    Java EE 6 | eis\MFCobol_v1.5 | CCIMFCobol_v1.5

To create deployment descriptors from dummy ones:

  1. Generate a dummy EJB and client using the Interface Mapping Toolkit.
  2. Create deployment descriptors, by deploying the dummy EJB using the Deploy tool:

    The descriptors are packaged in the myService.ear file in the folder repos/myService.deploy. The following descriptors are generated:

    • *application*.xm?
    • *ejb-jar*.xm?
    • *web*.xm?
  3. Extract the descriptors from the .ear file using jar commands similar to the following for WebSphere:
    jar -xvf JMapServ-WS.ear JMapServ.jar JMapServ.war
jar -xvf JMapServ-WS.ear META-INF/ibm-application-bnd.xmi
jar -xvf JMapServ-WS.ear META-INF/ibm-application-ext.xmi
jar -xvf JMapServ.jar META-INF/ibm-ejb-jar-bnd.xmi
jar -xvf JMapServ.jar META-INF/ibm-ejb-jar-ext.xmi
jar -xvf JMapServ.war WEB-INF/ibm-ejb-web-bnd.xmi
jar -xvf JMapServ.war WEB-INF/ibm-ejb-web-ext.xmi
  4. Make copies of the descriptors and edit them using an XML editor of your choice, making sure that you retain valid XML. Edit the descriptors as follows:
    • *application*.xm?. Replace the .jar and .war filenames with the names of your files.

      For WebLogic, a weblogic-application.xml file is not required.

    • *ejb-jar*.xm?. Replace the JNDI name with the JNDI name of your EJB. Notice that the JNDI name of the resource adapter is set to eis/MFCobol_*** (where *** is the version), which you must not change.
    • *web*.xm?. Replace the JNDI name with the JNDI name of your EJB.
  5. Put each descriptor into a subdirectory below the archive file to which the descriptor belongs, as follows:
    Descriptor | Directory
    *application*.xm? | my-ear-dir\meta-inf
    *ejb-jar*.xm? | my-jar-dir\meta-inf
    *web*.xm? | my-war-dir\web-inf
  6. Package your descriptors into your archive files using jar commands similar to:
    jar -uvf myService.ear META-INF/myAppServer-application.xml
jar -uvf myService.jar META-INF/myAppServer-ejb-jar.xml
jar -uvf myService.war WEB-INF/myAppServer-web.xml
  7. Package your updated .jar and .war into your .ear file, using jar command similar to:
    jar -uvf myService.ear myService.jar myService.war

Note that deployment descriptors are automatically created for the supported application servers that are listed in Servers > Settings on the EJB Generation tab in the Application server field.

Parent topic: Deployment Descriptors that Are Required
Parent topic: Deploy Interfaces
Related information
EJBs and Resource Adapters


CustomRecord and the RuntimeProperties Support

Support for the CustomRecord and the RuntimeProperties interfaces is provided in mfejblib.jar for EJBs and in mfj2se.jar for J2SE Java beans.

For J2SE Java beans, you need to make sure that the mfj2se.jar is available to the Java run-time system and is on the Java classpath.

For EJBs, this support is automatically included in the application .ear file when you generate a client for the EJB. If you create a client manually, you need to add the mfejblib.jar to your .ear file, manually. Specific versions of this file are supplied for each supported application server and J2EE version.

Parent topic: Deploying EJBs and Resource Adapters


Third Party Application Server Deployment

Several third party application servers are supported for use during development and in production. For example WebSphere and WebLogic.

Most third party application servers come with a Web-based administration console, which you use to deploy EJB and resource adapters. These take you step by step through deployment and provide information online.

When you have changed the modules deployed on the server, we recommend that you stop and restart the server.

Parent topic: Deploying EJBs and Resource Adapters
Related information
To deploy a Micro Focus resource adapter to a J2EE application server
To add support for Micro Focus resource adapters
To create deployment descriptors manually
To create an .ear file for your EJB
To deploy to WebLogic
To deploy to WebSphere
To deploy to JBoss


Troubleshooting

If your deployed EJB does not work, check the following things:

  • Have you stopped and restarted the application server? Sometimes this is required to pick up changes to deployments and configuration. Whenever you reboot the WebLogic machine, you also need to restart the WebLogic server from the Start menu.
  • Is the enterprise server you require running?
  • Are the required services deployed to the enterprise server? Were they deployed successfully? You can check this by looking in the Enterprise Server Administration console, http://locahost:86, in deploy\...\deploylog.txt and %USERPROFILE%\Documents\Micro Focus\Net Express x.x\WORKAREA \esname\console.log, where esname is your enterprise server name, such as ESDEMO.
  • Was any information written to the resource adapter log file cobcon.log? This log file is located in the directory defined in your Java system's user.home property. This directory equates by default to your user profile directory. If there wasn't any information written to the log file, the failure occurred before the resource adapter was invoked. The failure might lie in the application server setup. Notice that there are backup log files cobcon1.log and cobcon2.log.
  • Was any information written to the communications server log file log.html? See the section Communications Server Log Files in the Troubleshooting chapter.
  • When you generated your EJB using the Deploy tool, did you use the J2EE connector classes specific to your application server? For example, you must use WebLogic.jar for WebLogic EJB generation and j2ee.jar for WebSphere EJB generation. You specify these classes in the Classpath settings of the Deploy tool.
  • Is the JNDI name of the resource adapter set to eis/MFCobol_v1.0? Is this JNDI name mapped to the resource references of the EJB.
  • Is the JNDI name for each EJB the same wherever it is referred to? When you assign a JNDI name to an EJB, any client or other software that uses that EJB must use that same JNDI name.
  • Are the EJB and the resource adapter successfully deployed in your application server?
  • What failures are recorded in your application server's log files? All the supported application servers have a logs subdirectory.
Parent topic: Deploying EJBs and Resource Adapters
Related information
Communications Process Log Files


Working with Mainframe Files

Studio Enterprise Edition provides functionality that you can use to work with files and data located on the mainframe. This section describes the functionality.

Note:

You can also configure an SNA server and set up links between CICS regions running in an Enterprise Server environment, and CICS regions running on a mainframe. This functionality is covered in a different area of the help.

  • About Enterprise Server and Mainframe Access
  • Configuring and Administering the Mainframe
  • Using Enterprise Server with a Mainframe
Parent topic: Configuration and Administration
Related concepts
Setting Up Communications with Mainframe CICS Regions


About Enterprise Server and Mainframe Access

Enterprise Server provides the following components that allow you to work with programs and data on a mainframe:

  • The Automatic Synchronize and Compile (ASC) utility enables users to automatically synchronize components on the PC with components on the mainframe
  • Drag and Drop allows you to transfer files easily between mainframe and PC environments. It provides a simple drag and drop user interface to do this.
  • Compare and Synchronization Monitor allows you to synchronize mainframe and PC versions of files. For example, changes made to PC-environment files can be configured to synchronize with corresponding files in the mainframe environment, and vice versa.
  • Mainframe Call Generator allows you to set up application to mainframe calls.
  • The Remote Job Step Execution (RJSE) facility enables execution of one or more steps of a job on a remote z/OS host
  • SourceConnect allows you to map a mainframe environment to a PC drive. With SourceConnect for example, you can use applications running in a PC environment to access resources on a mainframe.
Parent topic: Working with Mainframe Files


Configuring and Administering the Mainframe

This section describes how to configure and administer a Mainframe Access installation's mainframe components.

Mainframe Access is middleware that runs on OS/390 and z/OS mainframes and provides access to mainframe resources for Micro Focus client products.

This help is for mainframe system administrators who are responsible for configuring and running Mainframe Access. You should be familiar with z/OS system definitions and the TSO-ISPF interface.

  • Mainframe Access Overview
  • Configuration
  • Administration Using Console Commands
  • Administration Using the Web Interface
  • Troubleshooting
  • Customizing Data Connect
  • Configuring Access to External Library Management Systems
  • Configuring Access to Enterprise Server Mainframe Subsystem Support
  • Configuring the Enterprise Server Environment
  • Mainframe Access Messages
Parent topic: Working with Mainframe Files


Mainframe Access Overview

Mainframe Access is the OS/390 and z/OS server for Micro Focus development environments. It is a common component providing access to host resources for environments. One installation of Mainframe Access can support all of these products, providing connectivity to any number of DB2, IMS, and CICS systems located anywhere in an enterprise. It can also provide access to JES facilities, VSAM data sets, non-VSAM data sets, and data controlled by external library management products such as Panvalet, Librarian and Endevor.

Note: Mainframe Access is supported on z/OS (up to V1R4) and OS/390 environments. Unless specifically stated otherwise, references to z/OS also apply to OS/390.

Mainframe Access is data and transaction middleware that exploits the best features of workgroup and enterprise architectures. Micro Focus client programs can achieve the same performance levels, security, and data integrity that native mainframe applications deliver. The technology requires no changes to existing mainframe security, database, and transaction processing systems.

Mainframe Access provides access to:

  • DB2 for z/OS and OS/390 from clients
  • CICS transactions and data from clients
  • IMS data from clients via the Remote IMS Server
  • Non-relational data sets (VSAM, sequential, partitioned, etc.) from Mainframe Access Client
  • Mainframe source control systems the Mainframe Access Client
  • JES2 and JES3 from the Mainframe Access Client

The figure below illustrates the relationships between Mainframe Access, its client systems and the z/OS services it provides.

Figure 1. Mainframe Access Architecture
Mainframe Access Architecture
  • Communications
  • Security
  • Data Set Services
  • Administration
  • Dependent Address Space Services
  • Mainframe Access Services
Parent topic: Configuring and Administering the Mainframe


Communications

Mainframe Access provides comprehensive support for communications between PC clients and mainframe servers. Mainframe Access supports both TCP/IP and LU6.2 protocols. Mainframe Access' ability to bridge client TCP/IP connections to SNA LU6.2 server connections eliminates the need to install, configure and maintain SNA software packages on your client and server workstations. You can even access any DB2 for z/OS and OS/390 database using TCP/IP client connections, without the need for specific levels of DB2 software. Normally, DB2 Version 5.1, or later, is required for TCP/IP access. Mainframe Access, however, dynamically associates TCP/IP client connections with traditional LU6.2 DRDA connections to the DB2 systems.

Details are as follows:

  • TCP/IP Communications

    Mainframe Access has two TCP/IP socket listeners, one for TCP/IP clients using proprietary protocols and one for HTTP clients. The listeners accept client connection requests and examine the request data to determine the target server or internal destination for the request. When the target server is external, the client connection is then associated with an LU6.2 connection to the target server. For each target server type, Mainframe Access creates an initial number of tasks (z/OS TCBs) to handle the client/server connection association and processing. As each connection request arrives, Mainframe Access scans all available tasks for the target server and assigns the new connection request to the task with the lightest load. Mainframe Access' TCP/IP communications support can be used with IBM's z/OS TCP/IP implementation or CA's TCPaccess product.

  • LU6.2 Communications

    When the first client request for an LU6.2 target server is received, Mainframe Access establishes the LU6.2 connection to the target server and negotiates session limits for the mode name associated with conversations (user transactions) to the target server. Mainframe Access then prepares an LU6.2 Function Management Header 5 (FMH-5) and allocates a conversation to the target server. The FMH-5 includes any LU6.2 security subfields (user ID and password) provided by the client and an LUW ID (SNA Logical Unit of Work ID) generated by Mainframe Access to manage the unit of work. Packaged user data to be processed by the transaction program follows the FMH-5. Acceptance of the conversation request by the target server starts the execution of the remote transaction program that will process the request. Response data from the remote transaction program is received by Mainframe Access and returned to the requesting client through the TCP/IP connection. If an LU6.2 communications error occurs during the request processing, Mainframe Access creates a special packet containing the LU6.2 error information and returns this to the requesting client.

Parent topic: Mainframe Access Overview


Security

Mainframe Access provides security features that interact with existing mainframe, operating system, and software security schemes. They are:

  • System Authorization Facility (SAF) interface

    Mainframe Access' security component uses the z/OS SAF interface to verify the user IDs and passwords and to check the authorization of users to access and update z/OS data sets. The Password Expiration Manager (PEM) feature of Mainframe Access is used by some client products; PEM allows PC end users to change their mainframe password using the SAF interface. Mainframe Access uses the SAF RACROUTE interface, and therefore exploits the existing security definitions in your external security manager, such as IBM's RACF, CA-ACF-2, and CA-Top Secret.

  • Encryption

    Mainframe Access and its associated products use several methods of encryption and encoding, including 32-bit private key algorithms, to manage the encryption and decryption of passwords and data.

  • Access List Checking

    You can use this optional feature to restrict client connections based on the IP address of the incoming client. You create an access list that specifies which client IP addresses, or ranges of addresses, are allowed or disallowed. Once you have enabled access list checking, Mainframe Access always validates the incoming client's IP address using your specifications and rejects unauthorized connection attempts.

  • Audit Logging

    Mainframe Access' optional audit logging facility records client login and logout information to a VSAM file. The information that is recorded includes user ID, login and logout times, target server, security status, and other data.

Parent topic: Mainframe Access Overview


Data Set Services

Mainframe Access' Data Set Services component uses state-of-the-art z/OS data management interfaces and facilities to provide file services for z/OS data sets. Data Set Services is designed to support the data access and security requirements of VSAM and non-VSAM data sets in a high-performance, multi-user environment.

Parent topic: Mainframe Access Overview


Administration

Mainframe Access provides functions to monitor and control the processing of work, for example:

  • Client Timeout Management

    Mainframe Access monitors the activity of clients that have a persistent connection to Mainframe Access for activity and disconnects them from the system after a length of idle time that you specify. It also releases all of the associated client resources on the mainframe, including LU6.2 conversations with server systems.

  • Trace Facility

    The tracing facility of Mainframe Access traces both the client flow (usually TCP/IP) and server flow (usually LU6.2) simultaneously, recording all control information and data to a single output destination. The trace information is very useful for diagnosing client/server communication problems. You can turn tracing on and off dynamically while Mainframe Access is running.

Mainframe Access provides a set of simple commands that you can use to monitor and control its run-time operations. You can use the commands from an z/OS console or from a Telnet client; for further information see the chapter Administration Using Console Commands. Mainframe Access also includes a more comprehensive graphical interface to administrative functions that runs in a Web browser; this is described in the chapter Administration Using the Web Interface.

You can use Mainframe Access' administrative interfaces to obtain comprehensive displays of current system activity and internal components of the system. The information provided extends from overall systems operation down to details about individual client/server connections. You can update important operational definitions and functions of the system, such as target server parameters, idle timeout value, access list specifications and trace activity while the system is running.

Parent topic: Mainframe Access Overview
Related information
Administration Using Console Commands
Administration Using the Web Interface


Dependent Address Space Services

Mainframe Access' Dependent Address Space Services component uses standard z/OS facilities to create and manage auxiliary Application Server address spaces for program execution. This feature is used to automatically start a Mainframe Access Data Connect server address space during Mainframe Access initialization. The Data Connect server is also stopped automatically during Mainframe Access shutdown.

Parent topic: Mainframe Access Overview


Mainframe Access Services

Mainframe Access Drag & Drop and Source Connect functions are seamlessly integrated into the overall server workload. Mainframe Access' high-performance task, communications, transaction and data set management services are leveraged to increase the speed, reliability and scalability for these functions.

Parent topic: Mainframe Access Overview


Configuration

This chapter describes how to configure Mainframe Access and verify that it is correctly installed and configured and is ready to run.

  • Configuration Overview
  • Installing and Configuring Mainframe Libraries
  • Quick Configuration
  • Advanced Configuration Activities
  • Running Multiple Instances of Mainframe Access Server
Parent topic: Configuring and Administering the Mainframe


Configuration Overview

There are two types of configuration tasks that you must complete before you can start and use Mainframe Access. These are:

  • Updating the z/OS mainframe system to create an execution environment for Mainframe Access
  • Setting parameters to meet your requirements

The process of configuring Mainframe Access is separated into two distinct procedures; Quick Configuration and Advanced Configuration Activities.

Quick configuration is performed using the UpQuick instructions as indicated during the CD installation process. These configuration steps must be completed for all installations. Quick configuration takes care of all of the z/OS customizations and many basic Mainframe Access customizations. This quick configuration is the only mainframe Mainframe Access setup required for Mainframe Access Drag and Drop, SQL Option for DB2, Mainframe Access Web Administration and basic Mainframe Access Data Connect server functions.

Additional setup is required if you will be using Mainframe Access Data Connect server and you need to use the file name mapping table and/or alter the processing in the SAF security exits. Additional setup is also required if you will be using Remote IMS, CICS Option, IMS support, ES/MSS support, Mainframe Access's access list checking, Mainframe Access's audit log, and/or Mainframe Access's support for external library management systems. The section on advanced configuration describes these additional customizations.

If you have completed the installation process, including the UpQuick configuration steps, and if you are not going to use features that require additional setup, your configuration is complete.

If you have uploaded and restored the Mainframe Access data sets but you have not completed the UpQuick configuration, you should begin with Quick Configuration.

If you have completed the configuration and testing of your basic Mainframe Access server and you need to customize for an advanced feature, you should continue at Advanced Configuration Activities.

  • Mainframe Access Data Sets
  • Mainframe Access Samples
Parent topic: Configuration


Mainframe Access Data Sets

Following the instructions on the CD, you should have already completed the upload and restore of the Mainframe Access data sets. During that process you selected a high level qualifier to be used for all of your Mainframe Access data sets. This guide refers to the qualifier that you selected as <hlq> or hlq. The data sets that you restored are listed in the following table.

DATA SET | DESCRIPTION
<hlq>.CNTL | Samples for Mainframe Access server. These include JCL for jobs to be run, JCL for started task procedures and parameter files. The members in this data set are referred to frequently in these configuration instructions.
<hlq>.LOADLIB | The load module library for Mainframe Access server. This library must be APF-authorized.
<hlq>.MFAVCTL | A pre-allocated library for Mainframe Access Data Connect server dynamic allocation control file members. This data set is allocated during installation but no members are restored into it. You may use this data set during customization for the Data Connect feature.
<hlq>.RIMS | All of the product source and object files that you may need during setup of the Remote IMS Server feature.
<hlq>.SASC.LINKLIB | The load module library for SAS/C runtime programs used by Mainframe Access server. This library must be APF-authorized.
<hlq>.TABLES | Translation tables used by Mainframe Access server.
<hlq>.WEBROOT.CLASS | Classes used by Mainframe Access web administration.
<hlq>.WEBROOT.GIF | Images used by Mainframe Access web administration.
<hlq>.WEBROOT.HTML | Pages used by Mainframe Access web administration.
<hlq>.WEBROOT.PUBLIC.HTML | Pages used by Mainframe Access web administration.
Parent topic: Configuration Overview


Mainframe Access Samples

The installation procedure places many samples in the <hlq>.CNTL data set. If a sample is provided for a configuration task, use it as a starting point for your configuration. Usually you need to edit the sample, replacing provided information with information that is unique to your system.

The following table summarizes the samples that are provided for Mainframe Access.

MEMBER | DESCRIPTION
ACCESS | List used to restrict access to Mainframe Access consisting of the IP addresses of connecting clients. The access list also contains the list of user IDs that are authorized to access the Mainframe Access administration functions through the Web browser interface. You should add the IP addresses and user IDs for your system; see the section Editing Access List Definitions.
AUDIT | JCL for creating and initializing a Mainframe Access audit log data set. The audit log is a VSAM key sequenced data set (KSDS). You should edit the sample to include JOB card information, data set names and a volume serial number.
AUDRPT | JCL for running the Mainframe Access audit log report program to list the contents of the audit log data set. You should edit the sample to include JOB card information and data set names.
FRESTORE | A copy of the FRESTORE job for reference purposes. This job was originally transferred from CD to the <hlq>.UPLOAD data set during installation. The job was customized and submitted to allocate the permanent Mainframe Access data sets and restore the data set content from other uploaded files.
GTFCNTL | Input control statements referenced by the sample JCL procedure in member MFAGTF.
INSTALL | A copy of the installation upload instructions for reference purposes. These are the instructions that describe how to allocate the <hlq>.UPLOAD data set and transfer the CD content into that data set.
MFA | JCL for executing Mainframe Access. You should edit the sample to include your data set names. This JCL contains references to the ACCESS, PARMS and SERVERS sample members.
MFAAS | JCL for executing a Mainframe Access Application Server. Application servers are auxiliary address spaces that process specific types of client requests such as Endevor transactions. You should edit the sample to include your data set names. This JCL contains a reference to the PARMSAS sample member.
MFAGTF | JCL for running IBM's Generalized Trace Facility (GTF). GTF provides high-performance recording of diagnostic data and can be useful during problem determination. You should edit the sample to include your data set names.
MFANLS | JCL for re-compiling the default code page that may be configured at a client workstation. This is equivalent to the MFLSCTRN load module of Mainframe Access Version 2. During installation the default is set to use code pages E037/A437 for EBCDIC/ASCII translation. The sample JCL contains instructions for changing the default code pages selected by installation.
MFAS | JCL for executing the Mainframe Access Data Connect server. You should edit the sample to include your data set names.
MFAVTAM | Definition of VTAM applications for Mainframe Access, Mainframe Access Data Connect, ES/MSS and Remote IMS Server. You can edit the sample to include your own ACB names and network names (see the section VTAMLST Definitions).
PARMS | Parameters that are read when Mainframe Access is initialized. The sample JCL for executing Mainframe Access refers to this member for parameter input. You will need to edit some of these parameters. For full details see the section Editing Mainframe Access Parameters .
PARMSAS | Parameters that are read when a Mainframe Access Application Server address space initializes. The sample JCL MFAAS, for executing a Mainframe Access Application Server, refers to this member for parameter input. You will need to edit some of these parameters. For full details see the section Editing Mainframe Access Parameters .
PVSUFFX | JCL for executing a migration tool which extracts a text definition from the MFLSCPAN load module of Mainframe Access Version 2. For full details see the section Panvalet in Appendix C.
SERVERS | Definitions that describe the z/OS subsystems that will be providing service in response to client requests. The servers are your IMS and CICS subsystems, the Mainframe Access Data Connect server and ES/MSS servers. You must edit the sample to include information specific to your servers and also coordinate the information with definitions in the client packages.
TSOXMIT | Sample job that uses TSO XMIT to package diagnostic data for transmission.
UPQUICK | A copy of the quick configuration instructions for reference purposes. These are the instructions that describe how to quickly configure z/OS and Mainframe Access to create an operational Mainframe Access server system. These same instructions are reiterated in the Quick Configuration section.
Parent topic: Configuration Overview
Related information
Editing Access List Definitions
VTAMLST Definitions
Editing Mainframe Access Parameters
Panvalet
Quick Configuration


Installing and Configuring Mainframe Libraries

The z/OS libraries for Mainframe Access, Mainframe Access Data Connect and the Remote IMS Server are stored on the CD in a compressed format. Follow the upload instructions on the CD to transfer the compressed files up to a mainframe partitioned data set and then run the restore job to expand all of the compressed files into proper z/OS data sets. All of the product data sets for Mainframe Access, Mainframe Access Data Connect and Remote IMS Server will then be ready to use.

The upload instructions refer you to the UpQuick instructions for Mainframe Access. This file is contained in one of the restored mainframe data sets. Follow the UpQuick instructions to complete the basic customization of z/OS and product parameters for Mainframe Access and Mainframe Access Data Connect. Upon completion of the UpQuick procedure you will be able to start Mainframe Access (Mainframe Access Data Connect will be automatically started as part of Mainframe Access initialization) and validate the successful installation of the software. This quick configuration is the only Mainframe Access setup required for Drag and Drop, SQL Option for DB2, Mainframe Access web administration and basic Mainframe Access Data Connect functions.

The additional setup required for Mainframe Access' access list checking, audit log, and/or external library management system interfaces is described in the chapter Configuration.

If you will be using Remote IMS, CICS Option, or Mainframe Subsystem Support, there are Mainframe Access parameters that you must configure to define and activate these features. . Some of the Mainframe Access configuration information must be coordinated with the client configuration for these features.

Note:
  • Mainframe Access is not supplied in SMP/E format.
Parent topic: Configuration


Quick Configuration

After you have uploaded the mainframe files and successfully run the FRESTORE job, there are some basic customization tasks that must be completed. Quick configuration works through these configuration tasks quickly and gets you to the point where the software can be started and a basic installation verification check can be performed. After the installation verification check, continue with Advanced Configuration Activities if there are additional features that you need to set up.

You should be familiar with TSO, ISPF, SDSF, z/OS system commands, JCL procedures and proclibs, VTAMLST definitions and RACF.

Note:

These instructions refer to RACF as the security subsystem. Mainframe Access does use the SAF interface to the security subsystem and is compatible with other security products that provide the SAF API. When these instructions refer to RACF-related customizations, please refer to your security product documentation to determine the corresponding security subsystem changes.

If you are using the ISPF editor to make the configuration changes, use the change command once to make the first update to the hlq value and then use ISPF's Rchange command (usually PF6) to apply the same change in all the members that you need to update. For example: use "c HLQ MY.HIGH.LEVEL" the first time and then PF6 to apply the same change in other places. Changes to other parameters are easily accomplished by overtyping the preset value.

  • Before You Begin
  • Add Your Userid to the Access List
  • MFA Started Task JCL Procedure
  • MFAAS Started Task JCL Procedure
  • MFAS Started Task JCL Procedure
  • Mainframe Access PARMS
  • VTAMLST Definitions
  • Add Started Task JCL Procedures to a Proclib
  • APF-Authorize the Load Module Libraries
  • Define Mainframe Access to the Security Subsystem
  • Starting Mainframe Access
  • Testing Mainframe Access Web Administration
  • Stopping Mainframe Access
Parent topic: Configuration
Related concepts
Prerequisites
Advanced Configuration Activities
Related information
Advanced Configuration Activities


Before You Begin

The following table lists important configuration data that you will need to know in order to complete the quick configuration. Review these items and determine the appropriate values before you proceed with customization.

ITEM | DESCRIPTION
userid | TSO user ID that can update proclib , update vtamlst , update RACF, and issue z/OS system commands through SDSF. Alternatively, the cooperation of individuals with the appropriate authorities.
hlq | High level qualifier that was given to all Mainframe Access data sets when the FRESTORE job was run.
clientport | A TCP/IP port number on the mainframe that you will reserve for Mainframe Access and client connections.
adminport | A TCP/IP port number on the mainframe that you will reserve for Mainframe Access Web Administration connections from web browsers.
stcuserid | RACF user ID that you want to associate with the Mainframe Access started tasks
stcgroup | RACF group ID that you want to associate with the Mainframe Access started tasks.
tcpdata | Data set name of the IBM TCP/IP "TCPIP.DATA" data set that provides configuration information to programs that use TCP/IP. This data set is not need if you are using CA TCPaccess.
proclib | Data set name of a system procedure library.
vtamlst | Data set name of the active VTAMLST definitions data set.
netid | VTAM SNA network id used on your system. See NETID= in the active ATCSTRxx vtamlst member.
loadvolser | DASD volume serial number of the volume containing the Mainframe Access load module libraries and the SAS/C runtime library. FRESTORE allocated and built these libraries.
Parent topic: Quick Configuration


Add Your Userid to the Access List

Customize member ACCESS in the CNTL data set. Change ADMUSER=MFAUSER to ADMUSER= userid . This will allow userid to log on to Mainframe Access Web Administration. The ADMUSER= line can also be repeated to add additional userids.

Parent topic: Quick Configuration


MFA Started Task JCL Procedure

Customize member MFA in the CNTL data set. This is the started task JCL procedure for Mainframe Access server. Use the ISPF change command to change HLQ to your qualifier ( hlq ).

If you are using IBM's TCP/IP, overtype TCPIP.OS390.TCPDATA with the name of your installation's "TCPIP.DATA" data set ( tcpdata ). This is the data set used by client programs to obtain the name of the TCP/IP started task and other installation-dependent TCP/IP information.

Parent topic: Quick Configuration


MFAAS Started Task JCL Procedure

Customize member MFAAS in the CNTL data set. This is the started task JCL procedure for Mainframe Access Application Servers. Use the ISPF change command to change HLQ to your qualifier ( hlq ).

If you are using IBM's TCP/IP, overtype TCPIP.OS390.TCPDATA with the name of your installation's "TCPIP.DATA" data set ( tcpdata ).

Parent topic: Quick Configuration


MFAS Started Task JCL Procedure

Customize member MFAS in the CNTL data set. This is the started task JCL procedure for Mainframe Access Data Connect server. Use the ISPF Rchange command to change HLQ to your qualifier ( hlq ).

Parent topic: Quick Configuration


Mainframe Access PARMS

Customize member PARMS in the CNTL data set. These are the Mainframe Access server initialization parameters referenced by the Mainframe Access started task JCL.

Use the ISPF Rchange command to change HLQ to your qualifier ( hlq ) in the WEB_ROOT=HLQ.WEBROOT parameter. This parameter specifies the prefix for data sets used by the Mainframe Access web server feature.

Change TCP_PORT=2020 to TCP_PORT= clientport . This is the port number that Micro Focus client software should be configured to use.

Change ADMIN_PORT=2021 to ADMIN_PORT= adminport . This is the port number that a web browser should use to access Web Administration.

Change NETWORK ID=DDINET1 to NETWORK ID= netid , the VTAM SNA network id of your system.

If you are using CA TCPaccess, change TCPACCESS=NO to TCPACCESS=YES to select Mainframe Access server's interface to TCPaccess.

Parent topic: Quick Configuration


VTAMLST Definitions

Copy member MFAVTAM to vtamlst . This application major node definition contains APPL definitions for Mainframe Access server, Mainframe Access Data Connect server and Remote IMS Server. Use the z/OS VARY command to activate the definition:

V NET,ACT,ID=MFAVTAM
Note:
  • If you change any ACBNAME= values or the PRTCT= value in the MFAVTAM sample you must make corresponding changes:
    • in member PARMS (if ACBNAME=MFM62ACB is changed)
    • in member PARMS (if PRTCT=MFM62PSW is changed)
    • in member SERVERS (if ACBNAME=MFA62ACB is changed)
    • in member MFAS (if ACBNAME=MFA62ACB is changed)
    • in member SERVERS (if ACBNAME=MFAMTO1 is changed)
    • in member SERVERS (if ACBNAME=MFAMTO2 is changed)
  • You will want to add MFAVTAM into the vtamlst (ATCCONxx) member so that this application major node is automatically activated during VTAM initialization.
Parent topic: Quick Configuration


Add Started Task JCL Procedures to a Proclib

Copy members MFA, MFAAS and MFAS to proclib .

Note:
  • If you store proc MFAS in proclib using a different name, you must also change ASPROC=MFAS in member SERVERS to specify that new proc name.
  • If you store proc MFAAS in proclib using a different name, you must also change ASPROC=MFAAS in member SERVERS to specify that new proc name.
Parent topic: Quick Configuration


APF-Authorize the Load Module Libraries

Use z/OS SETPROG commands to APF-authorize the load libraries:

SETPROG APF,ADD,DSNAME=hlq.LOADLIB,VOLUME=loadvolser
SETPROG APF,ADD,DSNAME=hlq.SASC.LINKLIB,VOLUME=loadvolser
Note:

You will want to add these APF library definitions to a SYS1.PARMLIB(PROGxx) member so that these same authorizations are automatically activated during z/OS system initialization.

Parent topic: Quick Configuration


Define Mainframe Access to the Security Subsystem

Use RACF TSO commands to define the Mainframe Access started tasks (MFA, MFAAS and MFAS) and assign a userid and groupid to the tasks. The stcuserid should have appropriate access to the Mainframe Access data sets and should also have a basic OMVS RACF segment defined. At a minimum, the stcuserid OMVS segment must have a UID. The stcgroup must also have an OMVS segment with a GID. The following REDEFINE will provide the necessary definition for all of the started tasks (MFA, MFAAS and MFAS).

RDEFINE STARTED MFA*.* STDATA(USER(stcuserid) GROUP(stcgroup))
   OWNER(stcuserid)
SETROPTS RACLIST(STARTED) REFRESH

If you are using another security product such as CA-ACF2 or CA-Top Secret you will need to make similar updates to your security system definitions. MFA, MFAAS and MFAS will need a started task definition with an OMVS segment and they will need access to the SAF API for security subsystem calls. Please refer to your security product documentation.

Parent topic: Quick Configuration


Starting Mainframe Access

When you have completed all of the tasks described in the preceding sections you are ready to start Mainframe Access to perform some simple installation verification tests. Start Mainframe Access by issuing the following z/OS START command at a system console or using the TSO/ISPF SDSF command facility:

S MFA

Here is an example that shows the messages displayed during startup. The start command is issued for MFA, the name of the started task JCL sample that has been customized and copied into a system procedure library. The SERVERS sample also defines the Mainframe Access Data Connect server as an application server address space that should be started automatically by Mainframe Access during initialization. Mainframe Access issues an internal start command for MFAS, the name of the started task JCL sample for the Mainframe Access Data Connect server.

15:49:32.45 CSIRLW1  00000290  S MFA
15:49:32.47 STC05579 00000090  $HASP100 MFA ON STCINRDR
15:49:32.55 STC05579 00000290  IEF695I START MFA WITH JOBNAME MFA IS ASSIGNED TO USER RWITEK, GROUP DEVELOP
15:49:32.55 STC05579 00000090  $HASP373 MFA  STARTED
15:49:32.55 STC05579 00000090  IEF403I MFA - STARTED - TIME=15.49.32
15:49:32.85 STC05579 00000090  MFM0014I: Mainframe Access V3.10 (BASE) for YOUR_COMPANY_NAME
15:49:32.85 STC05579 00000090  MFM0066I: Address space type is CTLRGN
15:49:32.86 STC05579 00000090  MFM0057I: GTF user record id (eid) is 00E9
15:49:32.86 STC05579 00000090  MFM0012I: TCP port number is 1503
15:49:32.86 STC05579 00000090  MFM0013I: Admin port number is 1504
15:49:32.86 STC05579 00000090  MFM0047I: DSS maximum shared public files is 10
15:49:32.86 STC05579 00000090  MFM0055I: DSS scan interval is 30 minutes
15:49:32.86 STC05579 00000090  MFM0054I: SMF recording is off, record id is zero or invalid
15:49:32.87 STC05579 00000090  MFM0063I: MFA Direct is active
15:49:32.87 STC05579 00000090  MFM0064I: MFA Direct number of processing tasks is 5
15:49:33.16 STC05579 00000090  MFMDS052I CA/PanValet Ready
15:49:33.21 STC05579 00000090  MFMDS055I MCG/RPC feature inactive
15:49:33.22 STC05579 00000090  MFMDS001I DSS Server Ready
15:49:36.92 STC05579 00000090  MFM0001I: Mainframe Access V3.10 (BASE) is active
15:49:37.00 STC05580 00000090  $HASP100 MFAS ON STCINRDR
15:49:37.06 STC05580 00000090  $HASP373 MFAS  STARTED
15:49:37.06 STC05580 00000090  IEF403I MFAS - STARTED - TIME=15.49.37
15:49:37.23 STC05580 00000090  MFA302I.MFAS.MFDSTART / ATTACHING VTAM PROCESSOR
15:49:37.24 STC05580 00000090  MFA303I.MFAS.MFDSTART / MFA/DATACONNECT V3.10 BASE  COPYRIGHT (C)
                               1987-2007 MICRO FOCUS INTERNATIONAL LTD.
15:49:37.24 STC05580 00000090  MFA110I.MFAS.MFDFSQ00 / VTAM PROCESSOR ACTIVE USING VTAMAPPL MFA62ACB
Parent topic: Quick Configuration


Testing Mainframe Access Web Administration

A successful connection to the Mainframe Access Web Administration feature from a standard Web browser program verifies that basic client connectivity through the TCP/IP network is functioning correctly. Specify the URL to the Web browser as

http://your.mainframe.hostname:adminport

where your.mainframe.hostname is the TCP/IP hostname or IP address for the z/OS system where Mainframe Access is executing and adminport is the port number that you specified in the Mainframe Access parameters. The administration port number is also identified in the Mainframe Access startup messages.

When you successfully connect, you will receive the Mainframe Access Web Administration sign-on page. Type your userid and password and press login to access the Web Administration home page. No explicit logout is necessary when you wish to leave Web Administration.

Parent topic: Quick Configuration


Stopping Mainframe Access

Stop Mainframe Access by issuing the following z/OS STOP command at a system console or using the TSO/ISPF SDSF command facility:

P MFA

Here is an example that shows the messages displayed during shutdown. The stop command is issued only for Mainframe Access, the Mainframe Access server. Mainframe Access issues an internal stop command for MFAS, the application server address space for Mainframe Access Data Connect that was defined in the SERVERS member and started automatically by Mainframe Access. MFAS ends first and then Mainframe Access completes its shutdown processing.

16:44:18.52 CSIRLW1  00000290  P MFA
16:44:21.52 STC05579 00000290  P MFAS
16:44:21.53 STC05580 00000090  MFA112I.MFAS.MFAFSQ00 / VTAM PROCESSOR HAS TERMINATED
16:44:21.68 STC05580 00000090  MFA317I.MFAS.MFARSC00 / HAS BEEN TERMINATED
16:44:21.69 STC05579 00000090  MFMDS005I DSS Server shutdown
16:44:21.70 STC05580 00000090  IEF404I MFAS - ENDED - TIME=16.44.21
16:44:21.70 STC05580 00000090  $HASP395 MFAS  ENDED
16:44:32.77 STC05579 00000090  MFM0011I: Mainframe Access shutdown completed
16:44:32.82 STC05579 00000090  IEF404I MFA - ENDED - TIME=16.44.32
16:44:32.82 STC05579 00000090  $HASP395 MFA  ENDED
Parent topic: Quick Configuration


Advanced Configuration Activities

Mainframe Access is a general purpose server supporting a variety of Micro Focus client products. The Quick Configuration process that you have completed enables a large number of Mainframe Access server features that will satisfy most access requirements. This section describes the customizations (beyond the quick configuration) that are needed to enable various additional features of Mainframe Access server.

The following table summarizes the required updates on a per-feature basis. This will help you to select the correct configuration activities for a specific feature.

Feature | Customization
Audit Log | Refer to Allocating and Initializing an Audit Log Data Set to prepare the data set. Then see Editing Mainframe Access Parameters and update the audit log parameter to AUDIT LOG=YES.
Access List | Refer to Editing Access List Definitions for guidance in defining IP addresses and address ranges. Then see Editing Mainframe Access Parameters and update the access list check parameter to ACCESS LIST CHECK=YES.
CICS Option | Using CICS Option, clients can interact with z/OS CICS servers for file access, remote program execution, transaction execution, etc. Activate support for this feature by setting MCO FEATURE=YES and setting MCOLINK_MAXTASKS=2. The number of tasks supporting this feature can be increased in the future as your usage dictates. To complete the setup for this feature you will need to customize your client and the z/OS CICS server.
Remote IMS Option | Using the Remote IMS Option, clients can execute DL/I calls that are processed by a z/OS IMS server. Activate support for this feature by setting REMOTE IMS FEATURE=YES and setting IMSLINK_MAXTASKS=2. The number of tasks supporting this feature can be increased in the future as your usage dictates. To complete the setup for this feature you will need to customize your client and the z/OS IMS server. You must also install the Remote IMS server software in the target z/OS IMS server and enable APPC/MVS communications for that IMS server. All of the machine-readable installation materials for your Remote IMS Server can be found in the <hlq>.RIMS data set.
List DB2 | Mainframe Access' List DB2 feature dynamically identifies z/OS DB2 and IMS servers that are active on the z/OS system where Mainframe Access server is executing. A summary of the server information can be viewed using the web administration interface. This information can be helpful when defining these systems to Mainframe Access server and clients. Activate support for this feature by setting LIST DB2=YES .
Data Connect | Quick Configuration installs the Mainframe Access Data Connect server with SAF security checking active and without special customizations for PC to mainframe file name mapping. If you need to alter this basic setup see the appendix Data Connect .
Enterprise Server/Mainframe Subsystem Support | Enterprise Server/Mainframe Subsystem Support (ES/MSS) enables Mainframe Access server to accept CICS ISC requests initiated by z/OS CICS and route them to an ES/MSS server for execution. The combination of ES/MSS support and the CICS Option support creates a bi-directional ISC connection between ES/MSS and z/OS CICS. To complete the setup for this feature you need to customize your ES/MSS server(s) and the z/OS CICS server(s). See your Enterprise Server documentation and IBM z/OS CICS publications for help with these customizations.
ChangeMan interface | Mainframe Access' Source Connect feature works with ChangeMan to provide client access to ChangeMan-managed files. For more information see the section ChangeMan ZMF in the appendix External Library Management Systems .
Panvalet interface | Mainframe Access' Source Connect feature works with Panvalet to provide client access to Panvalet-managed files. For more information see the section Panvalet in the appendix External Library Management Systems .
Librarian interface | Mainframe Access' Source Connect feature works with Librarian to provide client access to Librarian-managed files. For more information see the section Librarian in the appendix External Library Management Systems .
Endevor interface | Mainframe Access' Source Connect feature works with Endevor to provide client access to Endevor-managed files. For more information see the section Endevor in the appendix External Library Management Systems .
Note:

As noted in the preceding customization summaries, you also need to prepare the external servers and clients that Mainframe Access works with.

  • Editing Mainframe Access Parameters
  • Editing Mainframe Access Server Definitions
  • Editing Access List Definitions
  • Allocating and Initializing an Audit Log Data Set
  • Adding Mainframe Access to TCP/IP's Autolog List
  • Setting Up a Mainframe Access GTF Procedure
Parent topic: Configuration
Related concepts
Quick Configuration
Prerequisites


Editing Mainframe Access Parameters

You edit the Mainframe Access parameter definitions located in member PARMS to customize them for your system. The sample parameter definitions are provided here as a convenient reference while you read. Lines that begin with an asterisk are treated as comments and are skipped in processing. All parameters must be contained on a single input statement and we recommend that you begin your parameter keywords in column 1. The first blank character following a parameter value indicates the end of the parameter keyword and value pair and any text following that blank is treated as a comment.

*--------------------------------------------------------------------*
*                                                                    *
* Micro Focus Mainframe Access - Initialization Parameters           *
*                                                                    *
* For minimum customization during installation you should review    *
* the following parameters and change them to suit your              *
* installation, if necessary.  These customizations will allow you   *
* to complete the installation and perform basic installation        *
* verification testing.  These minimum customizations are also       *
* sufficient to enable testing of MFA and MFE SQL Option client      *
* functions.                                                         *
*                                                                    *
* TCP_PORT         port to be used by client applications            *
* ADMIN_PORT       port to be used for web administration (browser)  *
* WEB_ROOT         change HLQ                                        *
*                  to the value selected during installation         *
* NETWORK ID       see VTAM definitions in SYS1.VTAMLST(ACTSTRxx)    *
* LU62 APPLID      update if you changed sample MFAVTAM              *
* APPLID PASSWORD  update if you changed sample MFAVTAM              *
* TCPACCESS        specify YES if you are using CA TCPAccess         *
*                                                                    *
* Additional customization and/or setup work is required to enable   *
* the use of other product functions.  After installation            *
* verification testing, refer to the product documentation to        *
* continue with customization for these additional functions:        *
*                                                                    *
* MFE CICS Option                                                    *
* MFE IMS Option                                                     *
* MFA access list checking                                           *
* MFA audit logging                                                  *
* MFA support for external library managers                          *
* ES/MTO                                                             *
*                                                                    *
*                                                                    *
*                          Change Log                                *
*                                                                    *
*                                                                    *
* ChangeID  Description                                              *
* --------  -------------------------------------------------------- *

* SP2       New parameter - BIND_NETADDR=0.0.0.0                     *
* SP2       New parameter - MFA_MCG_DB2CONNECTION=RRSAF              *
* SP2       New parameter - CHANGEMAN_SSID=                          *
* SP2       New parameter - CHANGEMAN_ASGROUP=CGMQ                   *
* SP2       New parameter - CHANGEMAN_INTERFACE=SERXMLAC             *
* SP2       New parameter - CHANGEMAN_DSNQUALIFIER=                  *
* WS05HF1   New parameter - CHANGEMAN_COMMON_BUILD=NO                *
* WS05HF1   New parameter - CHANGEMAN_TEST_OPTION=NO                 *
* WS05HF1   New parameter - MFA_ENDEVOR_INTERFACE=YES                *
* WS05HF1   New parameter - MFA_PANVALET_INTERFACE=YES               *
* WS05HF1   New parameter - MFA_LIBRARIAN_INTERFACE=YES              *
* WS05HF1   New parameter - MFA_LIBRARIAN_DIR_INFO=LONG              *
* WS06      New parameter - ES/MTO OUTBOUND FEATURE=NO               *
* WS06      ChangeMan parameters moved to MFA services section       *
*--------------------------------------------------------------------*
*
*--------------------------------------------------------------------*
* General Parameters                                                 *
*--------------------------------------------------------------------*
*
SYSOUT=A                       --- Required if TRACE=SYSPRINT
ROUTE=(2,11)                   --- Console message route codes
ORGANIZATION=YOUR_COMPANY_NAME --- Company name (no embedded spaces)
ASTYPE=CTLRGN                  --- Parms for MFA control region
NETWORK ID=DDINET1             --- SNA network ID where MFA is running
LU62 APPLID=MFM62ACB           --- VTAM LU6.2 APPL
APPLID PASSWORD=MFM62PSW       --- VTAM LU6.2 APPL password
TRACE=SYSPRINT                 --- "SYSPRINT", "GTF" or "CONSOLE"
TRACING=NO                     --- Start tracing (YES/NO)
LIST PARMS=YES                 --- List parameters on sysout (YES/NO)
EID=00E9                       --- Required if TRACE=GTF
COMPRESSION=NO                 --- Compression for SQL Option traffic
ACCESS LIST CHECK=NO           --- Access List checking (YES/NO)
AUDIT LOG=NO                   --- Audit Logging (YES/NO)
TCP_PORT=2020                  --- TcpIp port for MFE, MFA, TELNET
ADMIN_PORT=2021                --- TcpIp port for Web Server
BACKLOG=5                      --- TcpIp "listen" backlog
BUFFER SIZE=0                  --- TcpIp send/recv buffer size (0=MAX)
TIME OUT FOR CONNECTION=30     --- TcpIp idle timeout minutes (0=NONE)
TIME OUT FOR INITIAL RECV=10   --- Initial recv tot seconds (1<x<59)
MAX_PUBLIC_FILES=10            --- Dataset Services max shared files
DSS_SCAN_INTERVAL=30           --- Dataset Services scan interval
SMF_RECORDID=0                 --- SMF record ID
TCPACCESS=NO                   --- NO=IBM TCP/IP; YES=CA TCPACCESS
CGMQOTMA LOGDD=SYSOUT          --- CG production log DDname or "SYSOUT"
BIND_NETADDR=0.0.0.0           --- Hostname/IP address for listeners
WEB_ROOT=HLQ.WEBROOT
*
*--------------------------------------------------------------------*
* Mainframe Access services parameters                               *
*--------------------------------------------------------------------*
*

MFA_ENDEVOR_INTERFACE=YES      --- Use Endevor   interface (YES,NO)

MFA_PANVALET_INTERFACE=YES     --- Use Panvalet  interface (YES,NO)
MFA_LIBRARIAN_INTERFACE=YES    --- Use Librarian interface (YES,NO)
MFA_ENDEVOR_HISTORY=YES        --- Endevor MFALOGE history (YES,NO)
MFA_LIBRARIAN_HISTORY=YES      --- Librarian MFALOG history (YES,NO)
MFA_LIBRARIAN_UPD_MODULE=AFOLIBR - Librarian batch update module name
MFA_LIBRARIAN_DIR_INFO=LONG    --- Librarian dir list (SHORT or LONG)
MFA_PANVALET_HISTORY=YES       --- Panvalet MFALOG history (YES,NO)
MFA_PANVALET_UPD_MODULE=PAN#1  --- Panvalet batch update module name
MFA_SAF_HISTORY=YES            --- Data set access MFALOG history
MFA_SYSOUT_CLASS=A             --- MFALOG,MFALOGE,SNAPDUMP class
MFA_SYSOUT_DEST=LOCAL          --- MFALOG,MFALOGE,SNAPDUMP dest
MFA_MCG_DB2CONNECTION=RRSAF    --- MCG DB2 connection (CAF or RRSAF)
CHANGEMAN_SSID=                --- ChangeMan subsystem ID x ("SERx")
CHANGEMAN_ASGROUP=CGMQ         --- ChangeMan address space group name
CHANGEMAN_INTERFACE=SERXMLAC   --- ChangeMan XML batch client interface
CHANGEMAN_DSNQUALIFIER=        --- ChangeMan DSN qualifier
CHANGEMAN_COMMON_BUILD=NO      --- ChangeMan shared build opts (YES/NO)
CHANGEMAN_TEST_OPTION=NO       --- ChangeMan <TEST> option (YES/NO)
*
*--------------------------------------------------------------------*
* Services to be activated                                           *
*--------------------------------------------------------------------*
*
TCP LINK FEATURE=YES           --- MFE SQL Option, Telnet client
MFADIRECT=YES                  --- Mainframe Access services
MFA FEATURE=YES                --- Mainframe Access Data Connect Server
PEM FEATURE=YES                --- MFE Password Expiration Manager
MCO FEATURE=NO                 --- MFE CICS Option
REMOTE IMS FEATURE=NO          --- MFE IMS Option
LIST DB2=NO                    --- DB2 and IMS subsystem finder
ES/MTO OUTBOUND FEATURE=NO     --- ES/MTO Outbound support
*
*--------------------------------------------------------------------*
* Number of tasks to run for each service                            *
*--------------------------------------------------------------------*
*
TCPLINK_MAXTASKS=2             --- # of TCBS for TCP LINK feature
WWWS_MAXTASKS=2                --- # of TCBS for Web Server
ISPI_MAXTASKS=2                --- # of TCBS for Web Server ISPI pgms
MFALINK_MAXTASKS=2             --- # of TCBS for MFA Server routing
MFADIRECT_MAXTASKS=5           --- # of TCBS for MFA processing
IMSLINK_MAXTASKS=0             --- # of TCBS for MFE IMS Option
MCOLINK_MAXTASKS=0             --- # of TCBS for MFE CICS Option
*
END
The order shown here is a logical one. However, you can enter the parameters in any order, as long as they are followed by the END marker. We strongly recommend that the SYSOUT and ROUTE parameters be specified at the beginning of the definitions to ensure that startup messages issued during the remainder of parameter processing reach the proper destinations. The following table lists and describes the parameters in alphabetical order.
Parameter | Description
ACCESS LIST CHECK | Indicates whether or not the access list feature is to be activated for clients. This enables you to restrict access to Mainframe Access according to the connecting client's IP address (see the section Editing Access List Definitions). Specify NO to accept all client connection requests, regardless of the client's IP address. Specify YES to permit client connections based on the PERMIT and REJECT rules for IP addresses defined in your access list.
ADMIN_PORT | The port number that accepts connections from HTTP clients, including Web Administration clients. The specified port number must be reserved for use by Mainframe Access. You can explicitly reserve the port for Mainframe Access by updating the MVS TCP/IP profile data set. If the specified port is not available during Mainframe Access startup, startup will fail. Specify any valid TCP/IP port number.
APPLID PASSWORD | The ACF/VTAM ACB password to be used when Mainframe Access opens its VTAM ACB. Specify a password consisting of between one and eight characters. This value must match the password value specified by the PRTCT parameter in the Mainframe Access VTAM application program major node definition in VTAMLST.
ASTYPE Specifies the type of Mainframe Access server region. Valid values are CTLRGN, STANDARD and APPSERVER:
  • CTLRGN starts a full-function Mainframe Access server control region capable of managing dependent address spaces. This is the normal setting for your Mainframe Access server.
  • STANDARD (the default) starts Mainframe Access server without support for dependent address spaces. The standard server is full-function but it cannot automatically start and stop the Mainframe Access Data Connect server and Mainframe Access application servers.
  • APPSERVER starts a Mainframe Access server dependent region for transaction processing. This setting is used in the initialization parameters for application server regions that are started and controlled by a Mainframe Access server control region.
AUDIT LOG | Indicates whether or not the audit log is to be activated. Specify YES to activate or NO to deactivate. If audit logging is selected, be sure to complete the tasks described in the section Allocating and Initializing an Audit Log Data Set, above.
BACKLOG | The number of pending TCP/IP connection requests that the TCP/IP network software should hold while Mainframe Access is processing the current connection request. Connection processing is typically handled very quickly and a small backlog of between 5 and 10 should be adequate for most installations. If you have an unusually high number of concurrent connection requests, some end users might receive a connection reject message. Specify a positive integer value in the range 5 through 50.
BIND_NETADDR | Selects the network address(es) to which the Mainframe Access listening ports (TCP_PORT and ADMIN_PORT) should be bound. Specify 0.0.0.0 (or omit this parameter) to bind the ports to all network addresses assigned to the host system. Specify a specific network address or a logical host name (64-character maximum) to restrict Mainframe Access to a single, specific host network address.
BUFFER SIZE | The maximum amount of data that Mainframe Access should send or receive through the TCP/IP network software in one send or receive operation. Specify 0 (zero) to allow Mainframe Access to use the optimum buffer size; this is recommended, as it will reduce the number of send or receive calls made to the TCP/IP network software. Specify an explicit value in the range 512 to 32767 only if you have diagnosed a problem with your TCP/IP network software that is associated with large message sizes.
CHANGEMAN_COMMON_BUILD | Specifies whether or not Mainframe Access accommodates group builds submitted under AppMaster Builder. Specify YES to enable group builds or NO to disable them. The default is NO. When enabled for group builds, MFA modifies the build options for each member of the AMB group to match the component name and type submitted, ensuring that each build request in the group is properly executed.
CHANGEMAN_DSNQUALIFIER Specifies a high-level qualifier for dynamically allocated data sets created by MFA Server to hold input files during the staging process. MFA Server creates these data sets dynamically as card-image sequential data sets that are deleted when the associated client request completes. The default qualifier is the login ID of the current user. You should set an alternate qualifier if your installation’s SERNET does not have RACF authority to read or write data into files stored in data sets named with the current user’s login ID as the high-level qualifier.

If an alternate qualifier is required, see your ChangeMan administrator or your security administrator for assistance in selecting a proper value.

If your ChangeMan functionality is restricted by security subsystem authorizations, you might need to specify your dataset high-level qualifier such that read access to the data sets is always permitted.

CHANGEMAN_INTERFACE Specifies the name of the ChangeMan ZMF module. During ChangeMan request processing, MFA Server loads and branch enters this module. Valid values are SERXMLBC and SERXMLAC. The default is SERXMLAC.

The preferred interface module is SERXMLAC, which is not documented by Serena; however, it provides better interface performance than SERXMLBC by using virtual storage instead of data sets for XML input and output exchange between MFA Server (the requester) and ChangeMan ZMF.

Serena documents only the SERXMLBC interface, which is the XML services batch client. SERXMLBC is intended for use in a batch job stream and requires XMLIN and XMLOUT DD statements to define its required data sets. The MFAAS JCL sample provides sample DD statements for XMLIN and XMLOUT; however, they are commented out. If you must use SERXMLBC, contact SupportLine for assistance with data set definitions.

This parameter is required in both the PARMS member and the PARMSAS member used by application server address spaces.

CHANGEMAN_SSID Initializes the Mainframe Access ChangeMan interface by providing the final character of the z/OS subsystem ID used to identify ChangeMan. Omit this parameter to bypass Mainframe Access initialization for the ChangeMan interface. Valid values are any single alphabetic or numeric character. The character specified is appended to the subsystem ID string "SER", completing the four-character ID. For example, if you specify CHANGEMAN_SSID=A, the z/OS subsystem ID becomes "SERA".

This parameter is required in both the PARMS member and the PARMSAS member used by application server address spaces.

Your ChangeMan administrator can help you to determine the correct subsystem ID to use.

CHANGEMAN_TEST_OPTION | Specify whether or not MFA uses the XML trace option. Specify YES to enable XML trace or NO to disable it. The default is NO. When enabled, SERNET logs information in XML format into the standard SERPRINT DD file. This file can be used to identify problems and to validate MFA services. Enabling XML trace is not recommended for production systems due to the large volume of log data generated.
COMPRESSION | Indicates whether or not Mainframe Access should apply data compression when communicating with SQL Option for DB2 clients. Specify YES to activate data compression or NO to deactivate it.
DSS_SCAN_INTERVAL | The time period in minutes between Data Set Services checks for abandoned buffers or open files. Due to unforeseen environmental errors, transactions may abnormally terminate while holding open files and other I/O resources. These scans locate idle resources and return them to an available status and ensure that no file is held idle for more than two consecutive scan intervals. Specify the number of minutes as an integer value between 30 and 90. The default is 30 minutes.
EID | The event ID of Mainframe Access GTF user trace records. The EID must be available for exclusive use by Mainframe Access and must match the USR=(eid) parameter specified to GTF when GTF is started (see the sample member GTFCNTL). This parameter is valid only when TRACE=GTF is specified. Specify a hexadecimal number of up to four bytes that GTF recognizes as a valid user trace record identifier.
ES/MTO OUTBOUND FEATURE Controls whether or not Mainframe Access accommodates ES/MSS. Specify YES to enable ES/MSS support or NO to disable it. The default is NO.

When disabled, MFA Server initialization ignores all ES/MSS server definitions contained in the SERVERS startup member.

When enabled, MFA Server processes ES/MSS server definitions at startup, initializing and allocating the VTAM ACBs defined for ES/MSS support. MFA Server also starts the required processes to manage ISC conversations initiated by the defined z/OS CICS systems to the defined ES/MSS servers.

IMSLINK_MAXTASKS | The number of z/OS subtasks (TCBs) to be started and dedicated to processing requests from IMS Option (Remote IMS) clients. Specify 0 (zero) or a positive integer value between 1 and 50.
ISPI_MAXTASKS | The number of z/OS subtasks (TCBs) to be started and dedicated to processing HTTP requests to execute server-side programs performing Mainframe Access Web Administration. Web Administration uses the Mainframe Access Internet Server Programming Interface (ISPI) to analyze the various administrative requests received from Web browsers and create dynamic HTML responses. Specify a positive integer value between 1 and 50.
LIST DB2 | Indicates whether or not the Mainframe Access LIST DB2 feature is to be activated. This obtains information about the DB2 and IMS subsystems. Specify YES to activate LIST DB2 or NO to deactivate it.
LIST PARMS | Controls the listing of Mainframe Access parameter definitions on the XDBOUT sysout data set. The parameter listing is helpful when you need to examine the active configuration settings. Specify YES to echo parameter definitions to the XDBOUT sysout data set or NO to inhibit the listing.
LU62 APPLID | The ACF/VTAM ACBNAME to be used by Mainframe Access. This ACBNAME must match the ACBNAME parameter of an active VTAM application major node (see the section Editing Mainframe Access Server Definitions ). Mainframe Access issues a VTAM OPEN request for this ACBNAME during startup and initialization fails if the OPEN is not successful. This ACBNAME (or the possibly different "network name" specified in the VTAM application major node definition) is the SNA LU name that identifies Mainframe Access to other applications in your SNA network. Specify the ACBNAME that has been defined and activated for Mainframe Access.
MAX_PUBLIC_FILES | The maximum number of shared public files that Mainframe Access Data Set Services should keep available. When the maximum is reached the next request for a new public file will be rejected, and you must close one of the item libraries to make space for the new one. Specify an integer value between 24 and 64. Defaults to 32.
MCOLINK_MAXTASKS | The number of z/OS subtasks (TCBs) to be started and dedicated to processing requests from CICS Option clients. Specify 0 (zero) or a positive integer value between 1 and 50.
MFADIRECT | Indicates whether or not Mainframe Access Source Connect and Drag & Drop services are to be activated. Specify YES to activate these services or NO to disable these services. The default value is YES (the recommended setting).
MFADIRECT_MAXTASKS | The number of z/OS subtasks (TCBs) to be started and dedicated to processing requests from Mainframe Access Drag & Drop and Source Connect clients, including Mainframe Access client functions and other development environment clients. Specify 0 (zero) or a positive integer value between 1 and 50. The default value is 5.
MFA_ENDEVOR_HISTORY | YES is the default. This will dynamically create a cumulative Endevor transaction history file (MFALOGE) to house the access history of all file access attempts using Endevor. The Endevor API interface produces this log for each access requested.
MFA_ENDEVOR_INTERFACE | YES is the default. Specify NO to prevent MFA Server from offering access to Endevor services.
MFA FEATURE | Indicates whether or not communication with the Mainframe Access Data Connect server is to be activated. Specify YES to activate the Mainframe Access Data Connect feature or NO to deactivate it.
MFA_LIBRARIAN_HISTORY | YES is the default. This will include a summary audit trail of all LIBRARIAN data accesses as part of the MFALOG output log.
MFA_LIBRARIAN_DIR_INFO | LONG is the default. This directs MFA Server to request complete member information from Librarian. The LONG specification significantly increases response time when accessing Librarian master files containing over 1,000 members. Specify SHORT to reduce the amount of member information requested from Librarian.
MFA_LIBRARIAN_INTERFACE | YES is the default. Specify NO to prevent MFA Server from offering access to Librarian services.
MFA_LIBRARIAN_UPD_MODULE | The name of the Librarian Batch update utility originally shipped as AFOLIBR by Computer Associates. If this module has not been renamed, then this parameter need not be specified.
MFALINK_MAXTASKS | The number of z/OS subtasks (TCBs) to be started and dedicated to processing requests from Mainframe Access Data Connect clients including Mainframe Access client functions originating in COBOL development environment clients. Specify 0 (zero) or a positive integer value between 1 and 50.
MFA_MCG_DB2CONNECTION | Controls which attachment facility is used by Mainframe Access Server for DB2 connections. Specify CAF (to use the DB2 call attach facility) or RRSAF (to use the DB2 Recoverable Resource Manager Services attachment facility). RRSAF is the default if this parameter is omitted.
MFA_PANVALET_HISTORY | YES is the default. This will include a summary audit trail of all user accesses to Panvalet as part of the MFALOG output log.
MFA_PANVALET_INTERFACE | YES is the default. Specify NO to prevent MFA Server from offering access to Panvalet services.
MFA_PANVALET_UPD_MODULE | The name of the Panvalet Batch update utility originally shipped as PAN#1 by Computer Associates. If this module has not been renamed, then this parameter need not be specified.
MFA_SAF_HISTORY | YES is the default. This will include a summary audit trail of all file access authorizations as part of the MFALOG output log.
MFA_SYSOUT_CLASS | Default value is A. This is used as the SYSOUT class for any held data produced by Mainframe Access. This includes MFALOG, MFALOGE, and SNAPDUMP message files.
MFA_SYSOUT_DEST | Default value is LOCAL. This is used as the SYSOUT destination for any held data produced by Mainframe Access. This includes MFALOG, MFALOGE, and SNAPDUMP message files.
NETWORK ID | The SSCP network ID used by ACF/VTAM on this z/OS system. This parameter must match the NETID parameter in the active ATCSTRxx VTAM start parameters member of VTAMLST. This Network ID value is used by Mainframe Access to build an LUWID (SNA Logical Unit of Work ID for LU6.2) when an LU6.2 conversation is allocated to the DB2 DDF. Specify the 1 to 8 character Network ID from ACF/VTAM's startup parameters.
ORGANIZATION | Your company name or other meaningful identifier up to 40 characters in length. Spaces are not permitted. Use underscores or other non-blank characters to separate words if necessary.
PEM FEATURE | Indicates whether or not the Mainframe Access Password Expiration Manager (PEM) feature is to be activated. The PEM feature must be active to allow Web Administration to access the operating system SAF interface for authentication of administration users. If PEM is not active, Web Administration will only verify that the logon userid is properly defined in the Mainframe Access access list dataset and no SAF authentication of the password data will be requested. PEM is also used in some Micro Focus client products to allow users of the client software on PCs to change passwords for their z/OS user IDs without logging on directly to z/OS. This is especially useful when the security subsystem indicates that the current password is expired and must be replaced. Specify YES (this setting is recommended) to activate the PEM feature or NO to deactivate it.
REMOTE IMS FEATURE | Indicates whether or not communication with IMS subsystems used by the IMS Option (Remote IMS) is to be activated. Specify YES to activate the Remote IMS feature or NO to deactivate it.
ROUTE | The message route codes to be used by Mainframe Access when console messages are issued using the z/OS WTO (Write to Operator) and WTOR (Write to Operator with Reply) services. See your IBM system documentation for valid values.
SMF_RECORDID | The SMF user record ID that Mainframe Access should use when writing SMF (IBM's System Management Facility) records to the z/OS SMF data sets. If an SMF user record ID is specified, that ID value should be assigned to Mainframe Access exclusively. Specify a valid SMF user record ID number to activate the Mainframe Access SMF support. Specify 0 (zero), or omit the parameter altogether, to disable the writing of SMF records.
SYSOUT | The SYSOUT class for the XDBOUT data set if it is dynamically allocated. Mainframe Access operational messages and trace data (when TRACE=SYSPRINT is specified and tracing is active) are written to this data set. XDBOUT is dynamically allocated to this SYSOUT class if an XDBOUT DD statement is not present in the Mainframe Access JCL. Specify a SYSOUT class designator that is valid for your z/OS system.
TCP LINK FEATURE | Indicates whether or not the TCP/IP connection feature is to be activated. You must specify YES.
TCPACCESS | Selects the TCP/IP stack to be used. Specify NO (the default) to use the IBM TCP/IP stack. Specify YES if you are using the CA TCPaccess stack.
TCP_PORT | The port number to accept connections from Micro Focus clients other than HTTP clients (see ADMIN_PORT). The specified port number must be reserved for Mainframe Access. You can explicitly reserve the port for Mainframe Access by updating the MVS TCP/IP profile data set. If the specified port is not available during Mainframe Access startup, startup will fail. Specify any valid TCP/IP port number.
TCPLINK_MAXTASKS | The number of z/OS subtasks (TCBs) to be started and dedicated to processing requests from SQL Option for DB2 clients. Specify a positive integer value between 1 and 50.
TIME OUT FOR CONNECTION | The number of minutes that a client connection can remain idle, after which the connection will be broken and Mainframe Access resources dedicated to the client will be released. Resources that are released when an idle client is disconnected include allocated storage, TCP/IP resources and connections to server subsystems such as DB2, IMS, CICS and Mainframe Access. Specify 0 (zero) to disable the client timeout feature and allow unlimited idle time, or a positive integer value.
TIME OUT FOR INITIAL RECV | The number of seconds that the listener process (Micro Focus client listener or Web Server listener) will wait to receive the initial client message after a socket connection has been accepted from a new client. If the time value expires before a complete initial message is received, the client is disconnected and the listening process prepares to accept another client connection request. The default value of 3 seconds is appropriate for all installations. This low value helps keep the listeners running smoothly, even during occasional network and/or client malfunctions. Specify a positive integer value between 1 and 59 (inclusive) to alter the time out value. This may be useful for diagnostic purposes.
TRACE The destination for trace data when tracing is activated.
  • Specify SYSPRINT to send print formatted trace output to the data set identified by the XDBOUT DD statement, normally a SYSOUT data set. We recommend this setting during initial product testing and when you are performing controlled problem determination.
  • Specify GTF to trace a very active Mainframe Access that is processing a high transaction volume. Trace data collected by GTF is written to external storage (tape or DASD) in a raw data format while tracing is active. You can use IBM's IPCS (Interactive Problem Control System) to format the data for analysis after tracing has been completed. Trace records are sent to the console if GTF is not available when TRACE=GTF is specified.
  • Specify CONSOLE to send trace output to the system log and console (not recommended because of the large volume of messages).
TRACING | Specifies whether or not detailed tracing of Mainframe Access Server program activity should be started during initialization processing. Normally tracing should be turned off during initialization and during normal product operation. Activity tracing writes detailed information to the XDBOUT sysout data set and this can slow down performance in a busy server. Tracing is normally controlled by the TRACE ON and TRACE OFF commands after initialization is complete. The TRACING parameter makes it possible to trace the initialization activity, before the server is ready to accept TRACE ON/OFF commands. Activity trace started by the TRACING parameter can be stopped later using the TRACE OFF command. Specify YES to activate tracing during initialization or specify NO to inhibit activity tracing until a TRACE ON command is issued.
WEBROOT | The character string that prefixes all of the Web resource data sets installed with Mainframe Access. Specify <hlq>.WEBROOT, substituting the value that was chosen for <hlq> when the software was installed.
WWWS_MAXTASKS | The number of z/OS subtasks (TCBs) to be started and dedicated to processing HTTP requests from Web browsers. Requests for static resource such as Web pages, images, etc. are handled by these tasks. Specify a positive integer value between 1 and 50.
Parent topic: Advanced Configuration Activities
Related information
Editing Access List Definitions
Allocating and Initializing an Audit Log Data Set
Editing Mainframe Access Server Definitions


Editing Mainframe Access Server Definitions

The SERVERS definitions describe both application servers and target servers. Target server definitions provide an ID label and the LU 6.2 parameters needed to contact the server using SNA LU 6.2 protocols. The ID label is used in some client configurations to select a specific target server.

Application servers define address spaces that can be started and controlled by Mainframe Access server. The definition provides a JCL procedure name that can be used to start the address space, a server program name, values that govern the number of address spaces that can be started, etc.

If you will be using CICS Option or IMS Option, you must edit the Mainframe Access sample target server definitions located in member SERVERS to customize them for your system. The application server and target server definitions for the Mainframe Access Data Connect server will need to be edited only if you have changed the JCL procedure name or the VTAM APPL ACBNAME, or if the default logmode name cannot be used. All parameters for one target server should be grouped together following the <…ID…> assignment that starts the definition. The <END> statement is used to end each target server definition. All parameters for one application server should be grouped together following the <ASGROUP…> assignment that starts the definition. The <END> statement is used to end each application server definition.

The sample definitions for target servers that you will not be using can be left as they are and they will not affect the operation of Mainframe Access with target servers that you have customized. For example, if you are not using CICS Option you can leave the sample CICS target server definitions unchanged in the SERVERS member; or you can change each line of the unused definitions to a comment by inserting an asterisk in column 1; or you can delete them altogether.

The sample server definitions are provided here as a convenient reference while you read. Lines that begin with an asterisk are treated as comments and are skipped in processing.

*--------------------------------------------------------------------*
*                                                                    *
* Micro Focus Mainframe Access - Server Definitions                  *
*                                                                    *
* For minimum customization during installation you should review    *
* the following parameters and change them to suit your              *
* installation, if necessary.  These customizations will allow you   *
* to complete the installation and perform basic installation        *
* verification testing.  These minimum customizations are also       *
* sufficient to enable testing of MFA and MFE SQL Option client      *
* functions.                                                         *
*                                                                    *
* ASPROC=MFAS      update if you changed the name of the MFAS sample *
*                  JCL procedure for the MFA Data Connect server     *
*                                                                    *
* ASPROC=MFAAS     update if you changed the name of the MFAAS       *
*                  sample JCL procedure for the Application Servers. *
*                                                                    *
* LUNAME=MFA62ACB  update if you changed sample MFAVTAM.             *
*                  This name must match the name in the MFAVTAM      *
*                  definition and the startup parameter value on     *
*                  the MFAS PROC statement.                          *
*                                                                    *
* Additional customization and/or setup work is required to enable   *
* the use of other product functions.  After installation            *
* verification testing, refer to the product documentation to        *
* continue with customization for these additional functions:        *
*                                                                    *
* MFE CICS Option                                                    *
* MFE IMS Option                                                     *
* ES/MTO                                                             *
*                                                                    *
*                          Change Log                                *
*                                                                    *
*                                                                    *
* ChangeID  Description                                              *
* --------  -------------------------------------------------------- *
* WS06      New server definition - Two ES/MTO server samples added  *
*--------------------------------------------------------------------*
*
*--------------------------------------------------------------------*
* Application Server address space definitions                       *
*--------------------------------------------------------------------*
*
* Mainframe Access Server (Data Connect) address space
*
<ASGROUP=MFAS>
ASPROC=MFAS
ASJOB=*
ASSERVER=MFARSC00
ASMINIMUM=1
ASMAXIMUM=1
ASGROUPID=0
<END>
*
* Mainframe Access Application Server(s) for Endevor
*
<ASGROUP=ENDV>
ASPROC=MFAAS
ASJOB=MFAE
ASSERVER=DACALL
ASMINIMUM=0
ASMAXIMUM=2
ASGROUPID=0
<END>
*
* Mainframe Access Application Server(s) for CG processing
*
<ASGROUP=CGMQ>
ASPROC=MFAAS
ASJOB=MFAC
ASSERVER=DACALL
ASMINIMUM=0
ASMAXIMUM=2
ASGROUPID=0
<END>
*
*--------------------------------------------------------------------
* MFA Data Connect server - only one DEFAULT server is supported
*--------------------------------------------------------------------
*
<MFAID=DEFAULT>
LUNAME=MFA62ACB
TPNAME=FILESHR2
MODENAME=#INTER
SYNCLEVEL=1
SECURITY=NONE
<END>
*
*--------------------------------------------------------------------
* Sample IMS servers - multiple servers may be defined
*--------------------------------------------------------------------
*
<IMSID=IMSA>
LUNAME=IMSSYSA
TPNAME=MFDBTP6
MODENAME=IBMRDB
SYNCLEVEL=0
SECURITY=NONE
<END>
*
<IMSID=DEFAULT>
LUNAME=IMSTEST
TPNAME=MFDBTP6
MODENAME=IBMRDB
SYNCLEVEL=0
SECURITY=NONE
<END>
*
*--------------------------------------------------------------------
* Sample CICS servers - multiple servers may be defined
*--------------------------------------------------------------------
*
<MCOID=CICA>
LUNAME=CICSSYSA
TPNAME=*
MODENAME=#INTER
SYNCLEVEL=0
SECURITY=NONE
<END>
*
<MCOID=DEFAULT>
LUNAME=CICSTEST
TPNAME=*
MODENAME=#INTER
SYNCLEVEL=0
SECURITY=NONE
<END>
*
*--------------------------------------------------------------------
* Sample ES/MTO servers - multiple servers may be defined
*--------------------------------------------------------------------
*
<ES/MTOID=MTO1>
ACBNAME=MFAMTO1
IPADDRESS=YOUR.MTO.HOSTNAME
PORT=2200
SESSIONS=4
SOCKETS=1
<END>
*
<ES/MTOID=MTO2>
ACBNAME=MFAMTO2
IPADDRESS=101.102.103.104
PORT=3300
SESSIONS=4
SOCKETS=1
<END>
*
*--------------------------------------------------------------------
* Sample CG MQ OTMA queue defintions - multiple queues may be defined
*--------------------------------------------------------------------
*
<CGMQOTMA=MYQ1>
QMANAGER=QMG1
QUEUE=MESSAGE.QUEUE.NUMBER1
ASGROUP=CGMQ
WAIT=4
<END>
*
<CGMQOTMA=MYQ2>
QMANAGER=QMG2
QUEUE=MESSAGE.QUEUE.NUMBER2
ASGROUP=CGMQ
WAIT=4
<END>
*
  • Application Server Parameters for the Mainframe Access Data Connect Server
  • Target Server Parameters for ES/MSS
  • Target Server Parameters for the Mainframe Access Data Connect Server
  • Target Server Parameters for IMS Option (Remote IMS)
  • Target Server Parameters for CICS Option
  • Application Server Parameters for ChangeMan Processing
  • Application Server Parameters for Mainframe Access Endevor Support
Parent topic: Advanced Configuration Activities


Application Server Parameters for the Mainframe Access Data Connect Server

Parameter | Description
<ASGROUP=MFAS> | Signals the beginning of a Mainframe Access Data Connect application server definition. The group name must be MFAS for the Data Connect server. Specify MFAS.
ASPROC | The name of the started task JCL procedure that can be used to start the Data Connect server. This procedure must be stored in a procedure library that is available to z/OS START command processing. The Mainframe Access Data Connect server JCL is distributed as member MFAS but this name may be changed to suit your installation. Specify a JCL procedure name of up to eight characters.
ASJOB | The jobname prefix to be used for address spaces that are started for this group. For multiple-instance address spaces this is a prefix of 1 to 4 characters and Mainframe Access server will pad this prefix to a full 8-character jobname by appending a 4 to 7 digit sequence number. For example, ASJOB=ABC will result in jobnames ABC00001, ABC00002, etc. If you specify an asterisk (*) for this parameter the JCL procedure name is used for the jobname. This is appropriate for single-instance application server address spaces. The Mainframe Access Data Connect server is single-instance (only one will be started) and the JCL procedure name is appropriate for the jobname, also. Specify *.
ASSERVER | Specifies the name of the processing module for requests sent to this application server. Specify MFARSC00.
ASMINIMUM | Specifies the minimum number of address spaces that Mainframe Access server will start for a multiple-instance group during initialization. Mainframe Access Data Connect server is a single-instance server. Specify 1.
ASMAXIMUM | Specifies the maximum number of address spaces that Mainframe Access server will start for a multiple-instance group. Additional address spaces beyond the minimum will be started in response to transaction load, up to the maximum allowed by this specification. Mainframe Access Data Connect server is a single-instance server. Specify 1.
ASGROUPID | Specifies a numeric ID that can be used in client requests to identify this application server group. Data Connect clients do not use the ASGROUPID feature. Specify 0.
<END> | Signals the end of this application server definition.
Parent topic: Editing Mainframe Access Server Definitions


Target Server Parameters for ES/MSS

These statements define an ES/MSS server and provide MFA Server with the information needed to establish a TCP/IP socket connection to the ES/MSS server. This definition also creates a VTAM ACB that represents the ES/MSS server to the z/OS CICS system(s).

Parameter | Description
<ES/MTOID=xxxx> | Signals the beginning of an ES/MSS target server definition and assigns an ID to this server definition. The MTOID can be one to four characters in length and must match the SYSID of the ES/MSS server being defined. The initial connection messages exchanged by MFA Server and ES/MSS use this MTOID.
ACBNAME | The name of the VTAM ACB associated with this ES/MSS server. MFA Server OPENs and initializes this ACBNAME during startup. The z/OS CICS system(s) must be configured to communicate with this ES/MSS server through this VTAM ACB name using CICS CONNECTION and SESSIONS definition statements.
IPADDRESS | The internet host name or IP address of the ES/MSS server. Specify either the host name that resolves to the correct IP address or the actual IP address in standard dotted-decimal format. The combination of IPADDRESS and PORT from this definition provides MFA Server with the information it needs to originate a socket connection to ES/MSS and to verify the authenticity of a socket connection request from ES/MSS.
PORT | The port number where ES/MSS is listening for ISC connections.
SESSIONS | Specifies the number of concurrent conversations MFA Server can initiate to the ES/MSS server over a single socket connection. If ES/MSS has a different definition for the number of concurrent sessions, the session count is negotiated to a common value at the time a socket connection is established. Specify a value that supports the required number of concurrently active conversations for your application.
SOCKETS | Specifies the maximum number of concurrent socket connections between MFA Server and the ES/MSS server. ES/MSS support is currently limited to a single socket connection between MFA Server and an ES/MSS server; therefore, specify a value of 1.
<END> | Signals the end of this target server definition.
Parent topic: Editing Mainframe Access Server Definitions


Target Server Parameters for the Mainframe Access Data Connect Server

Parameter | Description
<MFAID=DEFAULT> | Signals the beginning of a Mainframe Access Data Connect target server definition. Data Connect client requests do not specify a target server ID and Mainframe Access always looks for the DEFAULT Mainframe Access Data Connect target server definition. Specify DEFAULT.
NETID | The network ID of your SNA network. Specify a network ID of up to eight characters.
LUNAME | The LU name of the Mainframe Access Data Connect server (also known as the ACBNAME or VTAM APPLID). Specify an LU name of up to eight characters.
TPNAME | The transaction program name for Mainframe Access Data Connect server requests. Specify FILESHR2.
MODENAME | The SNA log mode name that will be used by Mainframe Access to indirectly specify SNA session parameters when Mainframe Access initiates sessions with the Mainframe Access Data Connect server. Specify a log mode name for LU6.2 sessions of up to eight characters. This log mode name must be present in the VTAM log mode table available to Mainframe Access. IBM's default log mode table, ISTINCLM, typically provides several standard log modes that can be used by Mainframe Access, including both IBMRDB and #INTER LU6.2 log modes.
SYNCLEVEL | The SNA LU6.2 sync level option to be used on conversations with the Mainframe Access Data Connect server. Specify 1. Conversations use LU6.2 CONFIRM protocols.
SECURITY | The security level to be indicated in SNA LU6.2 Attach FMH-5 requests sent to the Mainframe Access Data Connect server. Mainframe Access forwards security subfield information as provided by the Data Connect client and sets the FMH-5 fields accordingly. Specify NONE.
<END> | Signals the end of this target server definition.
Parent topic: Editing Mainframe Access Server Definitions


Target Server Parameters for IMS Option (Remote IMS)

Parameter | Description
<IMSID=xxxx> | Signals the beginning of an IMS target server definition and assigns an ID to this server definition. If an IMS Option client request does not specify a target server ID or the specified target server ID does not exist, Mainframe Access selects the DEFAULT IMS target server, if one has been defined. This IMS target server ID name is used in the configuration of the client. When a Remote IMS request is sent this name is sent in the request data and is used to locate the target server definition for the IMS system that will receive the request. Specify DEFAULT or an ID of up to four alphanumeric characters.
LUNAME | The LU name of the IMS server (also known as the ACBNAME or VTAM APPLID). Specify an LU name of up to eight characters. This name must match the ACBNAME defined in an APPC/MVS LU definition for the target IMS system.
TPNAME | The IMS server transaction program name for IMS Option transactions. This is the LU6.2 transaction program name that will be sent to the IMS server in SNA Attach FMH-5 requests to begin an IMS Option transaction. Specify the APPC/MVS transaction program name that was specified in the APPC/MVS definitions during installation of Remote IMS.
MODENAME | The SNA log mode name that will be used by Mainframe Access to indirectly specify SNA session parameters when Mainframe Access initiates sessions with the IMS server. Specify a log mode name for LU6.2 sessions of up to eight characters. This log mode name must be present in the VTAM log mode table available to Mainframe Access. IBM's default log mode table, ISTINCLM, typically provides several standard log modes that can be used by Mainframe Access, including both IBMRDB and #INTER LU6.2 log modes.
SYNCLEVEL | The SNA LU6.2 sync level option to be used on conversations with the IMS server. Specify 0.
SECURITY | The security level to be indicated in SNA LU6.2 Attach FMH-5 requests sent to the IMS server. Mainframe Access forwards security subfield information as provided by the IMS Option client and sets the FMH-5 fields accordingly. Specify NONE.
<END> | Signals the end of this target server definition.
Parent topic: Editing Mainframe Access Server Definitions


Target Server Parameters for CICS Option

Parameter | Description
<MCOID=xxxx> | Signals the beginning of a CICS target server definition and assigns an ID to this server definition. If a CICS Option client request does not specify a target server ID or the specified target server ID does not exist, Mainframe Access selects the DEFAULT CICS target server, if one has been defined. This CICS target server ID name is used in the configuration of the client. When a CICS Option request is sent to Mainframe Access this name is sent in the request data and is used to locate the target server definition for the CICS system that will receive the request. Specify DEFAULT or an ID of up to four alphanumeric characters.
LUNAME | The LU name of the CICS server (also known as the ACBNAME or VTAM APPLID). Specify an LU name of up to eight characters.
TPNAME | The server transaction program name for CICS Option requests. This is the LU6.2 transaction program name that will be sent to CICS in SNA Attach FMH-5 requests to begin a CICS Option transaction. Specify a transaction program name of up to eight characters or specify * to cause Mainframe Access to use the transaction program name provided by the CICS Option client. The CICS Option client prepares a partial FMH-5 request that specifies the standard CICS transaction program names for function shipping, distributed program linking and so on.
MODENAME | The SNA log mode name that will be used by Mainframe Access to indirectly specify SNA session parameters when Mainframe Access initiates sessions with mainframe CICS. Specify a log mode name for LU6.2 sessions of up to eight characters. This log mode name must be present in the VTAM log mode table available to Mainframe Access. IBM's default log mode table, ISTINCLM, typically provides several standard log modes that can be used by Mainframe Access, including both IBMRDB and #INTER LU6.2 log modes.
SYNCLEVEL | The SNA LU6.2 sync level option to be used on conversations with CICS. Specify 0.
SECURITY | The security level to be indicated in SNA LU6.2 Attach FMH-5 requests sent to the CICS server. Mainframe Access forwards security subfield information as provided by the CICS Option client and sets the FMH-5 fields accordingly. Specify NONE.
<END> | Signals the end of this target server definition.
Parent topic: Editing Mainframe Access Server Definitions


Application Server Parameters for ChangeMan Processing

ChangeMan requests are processed in application server address spaces. A single group of application server address spaces can be defined for ChangeMan processing. The parameters in the group definition provide information that Mainframe Access Server needs in order to start and manage the associated address spaces.

ChangeMan processing is associated with a specific address space group by the Mainframe Access Server startup parameter CHANGEMAN_ASGROUP in the PARMS member. You may want to create a distinct ASGROUP definition for ChangeMan processing. This might be done to separate the workload for usage reporting, workload management, etc.

The MFAAS JCL sample referenced in the address space group definition contains comments that describe how to customize this JCL for ChangeMan processing.

Parent topic: Editing Mainframe Access Server Definitions


Application Server Parameters for Mainframe Access Endevor Support

Parameter | Description
<ASGROUP=ENDV> | Signals the beginning of the application server definition for Mainframe Access Endevor support. The group name must be ENDV. Specify ENDV.
ASPROC | The name of the started task JCL procedure that can be used to start address spaces for this group. Sample JCL procedure MFAAS provides the basic JCL for an application server address space. Refer to the section Endevor in the appendix External Library Management Systems to learn how to customize this JCL for Endevor support. Specify a JCL procedure name of up to eight characters.
ASJOB | The jobname prefix to be used for address spaces that are started for this group. For multiple-instance address spaces this is a prefix of 1 to 4 characters and Mainframe Access Server will pad this prefix to a full 8-character jobname by appending a 4 to 7 digit sequence number. For example, ASJOB=MFAE will result in jobnames MFAE0001, MFAE0002, etc. Endevor support multiple-instance address spaces to allow concurrent execution of client requests. The sample prefix MFAE can be changed to meet the needs of your installation. If you do change the suggested prefix you will need to review the security subsystem definition for the Mainframe Access started tasks. The configuration process uses a generic STARTED task definition (the generic name specified during Quick Configuration is MFA*.*) that covers generated jobnames such as MFAExxxx, in addition to the MFA (the MFA Server control region) and MFAS (the MFA Server for Data Connect) started task names. Specify a jobname prefix of up to four characters.
ASSERVER | Specifies the name of the processing module for requests sent to the application server. Specify DACALL.
ASMINIMUM | Specifies the minimum number of address spaces that Mainframe Access server will start for a multiple-instance group during initialization. Specifying zero delays address space activation until the first client request is received. Specify a minimum value from zero up to the ASMAXIMUM value.
ASMAXIMUM | Specifies the maximum number of address spaces that Mainframe Access server will start for a multiple-instance group. Additional address spaces beyond the minimum will be started in response to transaction load, up to the maximum allowed by this specification. Endevor support can effectively utilize multiple address spaces to meet the concurrency requirement demanded by your transaction arrival rate. The sample suggests an initial value of 2 and this can be increased as your transaction load increases. Mainframe Access server issues messages (to the XDBOUT data set) when a client request must be queued to wait for an available processing address space. Increase the ASMAXIMUM value (by 1) when you observe frequent queueing of client requests. Specify a value from 1 to 10.
ASGROUP | Specifies a numeric ID that can be used in client requests to identify this application server group. The Mainframe Access Endevor clients do not use the ASGROUP ID feature. Specify 0.
<END> | Signals the end of this application server definition.
Parent topic: Editing Mainframe Access Server Definitions
Related information
Endevor


Editing Access List Definitions

You must edit the access list definitions located in member ACCESS to customize them for your installation. There are two types of definition in this list:

  • PERMIT and REJECT lines - these specify the IP addresses from which client connections will be allowed or rejected. Client connection requests are checked only if the Mainframe Access parameter ACCESS LIST CHECK is set to YES. You must customize the PERMIT and REJECT lines with appropriate values for your implementation
  • ADMUSER lines - these define the users that are authorized to use Mainframe Access Web Administration. Requests for access to Web Administration are always checked. You must customize the ADMUSER lines with appropriate values for your implementation

The sample access list definitions are provided here as a convenient reference while you read. Lines that begin with an asterisk are treated as comments and are skipped in processing.

*--------------------------------------------------------------------*
*                                                                    *
* Micro Focus Mainframe Access - Access List                         *
*                                                                    *
*--------------------------------------------------------------------*
*
*--------------------------------------------------------------------*
* Permission list                                                    *
*--------------------------------------------------------------------*
*
PERMIT=111.111.111
*
*--------------------------------------------------------------------*
* Rejection list                                                     *
*--------------------------------------------------------------------*
*
REJECT=222.222.222
*
*--------------------------------------------------------------------*
* Web Administration users                                           *
*--------------------------------------------------------------------*
*
ADMUSER=MFAUSER
*
END
  • Permission and Rejection Lists
  • Web Administration Users
Parent topic: Advanced Configuration Activities


Permission and Rejection Lists

If you specify ACCESS LIST CHECK=YES in the Mainframe Access parameter file and specify the access list filename in an //XDBACC DD statement in the Mainframe Access startup JCL, client connection requests are accepted or rejected according to the values you specify for the PERMIT and REJECT parameters:

PERMIT=ipaddress
REJECT=ipaddress

The format of the IP address is the familiar dotted decimal notation. A complete Internet address consists of four decimal numbers or address groups, each in the range 0 through 255, with the groups being separated by decimal points.

You can specify complete Internet addresses to permit or reject individual clients.

You can also specify a range of consecutive Internet addresses in a single statement, by omitting one or more trailing address groups. This is known as a masked address specification. To decide whether or not a particular request is to be allowed, Mainframe Access first shortens the client address by removing trailing address groups that correspond to address groups omitted in the specification, then compares the shortened address with the masked address.

If you are using the access list mechanism, client connection requests from all addresses not specified in PERMIT or REJECT parameters are rejected.

Here are two example sets of access list parameters

  • Example 1
  • Example 2
Parent topic: Editing Access List Definitions


Example 1

PERMIT = 111.111.148
REJECT = 111.111.148.244

The effect of these parameter values is that all client connection requests from IP addresses in the range 111.111.148.0 to 111.111.148.255 are accepted with the exception of client address 111.111.148.244. Client connections from all other IP addresses are rejected.

Parent topic: Permission and Rejection Lists


Example 2

PERMIT = 11.1.82
REJECT = 11.1.82.4
PERMIT = 111.202.111.18

The effect of these parameter values is that all client connection requests from IP addresses in the range 11.1.82.0 through 11.1.82.255 are accepted with the exception of client address 11.1.82.4. Client connections requests from the address 11.202.111.18 are also accepted. Connection requests from all other IP addresses are rejected

Parent topic: Permission and Rejection Lists


Web Administration Users

Access to the Web Administration feature is available only to users specified as administration users in the access list. You specify each administration user with a separate ADMUSER entry in the access list:

ADMUSER=userid

You can specify any user ID that is already defined to your security subsystem (or will be subsequently defined). This includes user IDs that are already defined for access to TSO, IMS, CICS or other z/OS subsystems. When an administration user enters a user ID and password on the Web Administration sign-on page, Mainframe Access calls the security subsystem to authenticate the user by verifying that the password supplied is valid for that user. If the security subsystem rejects the password the user is denied access to the Web Administration home page.

Here is an example:

ADMUSER=ANNZ
ADMUSER=BRUCEY

All Web Administration sign-on requests from these users are accepted if they are accompanied by their current passwords as maintained by the security subsystem. A sign-on request from CHRISW (or any other user), even when accompanied by a valid password, is denied access to Web Administration.

Parent topic: Editing Access List Definitions


Allocating and Initializing an Audit Log Data Set

The Mainframe Access audit log feature uses a VSAM data set to record client login and logout information. The information that is logged includes the user ID, client IP address, login and logout times, target server name and encryption usage. If you want to use the audit log feature you need to prepare the audit log data set and update the Mainframe Access JCL procedure.

Sample member AUDIT contains the JCL to allocate and initialize a Mainframe Access audit log VSAM data set. Edit the JOB card, data set names and volume serial number information, then submit the job and verify that the condition code for the INITLOG step is 0 (zero). Note that a condition code of 8 for the ALLOCLOG step is normal the first time that you run this job.

When editing the data set names you may use a global change command to change all instances of HLQ to the high level qualifier that you selected for Mainframe Access data sets during the installation procedure.

Edit the Mainframe Access startup JCL to make the audit log data set available. Do this by removing the keyword DUMMY and the trailing comma (DUMMY,) from the XDBAUDIT DD statement:

    //*
    //*-----------------------------
    //* Optional audit log data set
    //*-----------------------------
    //*
    //XDBAUDIT DD  DUMMY,DISP=SHR,DSN=&DSNQUAL..AUDIT
Parent topic: Advanced Configuration Activities


Adding Mainframe Access to TCP/IP's Autolog List

If you are using IBM's TCP/IP, you can add the Mainframe Access started task name (the name of the Mainframe Access JCL procedure in the system procedure library) to the TCP/IP autolog list. TCP/IP will then automatically start Mainframe Access when it starts and stop Mainframe Access when it stops. Do not perform this update until you have finished configuring Mainframe Access and are satisfied with the way Mainframe Access is running.

Parent topic: Advanced Configuration Activities


Setting Up a Mainframe Access GTF Procedure

Mainframe Access provides sample members MFAGTF and GTFCNTL to assist you when you need to use IBM's Generalized Trace Facility (GTF) to obtain trace data for problem determination. In some problem situations our Product Support will request a VTAM trace of an application LU, usually the Mainframe Access server LU.

  • Adding the GTF Procedure to a System Procedure Library
  • Testing the Mainframe Access GTF Procedure
Parent topic: Advanced Configuration Activities


Adding the GTF Procedure to a System Procedure Library

Sample JCL to run GTF as a started task is provided in member MFAGTF. Edit this JCL to customize the data set names for your installation and then copy the JCL into a system procedure library that is available when z/OS START commands are processed. Member GTFCNTL contains GTF control statements that are referenced by the sample GTF JCL procedure. The USR=(FF1,FEF,0E9) statement in this member specifies the recording of VTAM buffer trace records (FF1 and FEF) and Mainframe Access server trace records (0E9).

Note:

If you change the Mainframe Access EID=00E9 parameter setting (Editing Mainframe Access Parameters), you should update member GTFCNTL with the new value.

Parent topic: Setting Up a Mainframe Access GTF Procedure
Related information
Editing Mainframe Access Parameters


Testing the Mainframe Access GTF Procedure

After you customize and install procedure MFAGTF you can test out the procedure by issuing the following z/OS START command at a system console or using the TSO/ISPF SDSF command facility:

S MFAGTF.MYGTF

GTF will start and read the GTFCNTL parameter file. When the initialization complete message is issued GTF is ready to record trace data.

S MFAGTF.MYGTF
$HASP100 MFAGTF   ON STCINRDR
IEF695I START MFAGTF WITH JOBNAME MFAGTF IS ASSIGNED TO USER RWITEK, GROUP CSIDVLP
$HASP373 MFAGTF   STARTED
IEF403I MFAGTF - STARTED - TIME=19.08.44
AHL121I  TRACE OPTION INPUT INDICATED FROM MEMBER GTFCNTL OF PDS
<hlq>.CNTL
TRACE=USRP
USR=(FF1,FEF,0E9)
END
AHL103I  TRACE OPTIONS SELECTED --USR=(FEF,FF1,0E9)
AHL906I THE OUTPUT BLOCK SIZE OF    27998 WILL BE USED FOR OUTPUT 228
        DATA SETS:
          <hlq>.TRACE
AHL080I GTF STORAGE USED FOR GTF DATA: 229
        GTFBLOCK STORAGE       82K BYTES (BLOK=        40K)
        PRIVATE STORAGE      1038K BYTES
        SADMP HISTORY          54K BYTES (SADMP=       40K)
        SDUMP HISTORY          54K BYTES (SDUMP=       40K)
        ABEND DUMP DATA         0K BYTES (ABDUMP=       0K)
AHL031I GTF INITIALIZATION COMPLETE

You stop GTF by issuing the following z/OS STOP command at a system console or using the TSO/ISPF SDSF command facility:

P MYGTF

GTF acknowledges the stop command and closes down, as shown in the following example:

P MYGTF
AHL006I GTF ACKNOWLEDGES STOP COMMAND
IEF404I MFAGTF - ENDED - TIME=19.10.31
$HASP395 MFAGTF   ENDED
$HASP250 MFAGTF PURGED -- (JOB KEY WAS B9C101AA)
Parent topic: Setting Up a Mainframe Access GTF Procedure


Running Multiple Instances of Mainframe Access Server

Mainframe Access server is a robust server that is designed to efficiently handle all of the different client access requirements in high-volume usage. A single instance of Mainframe Access server will most likely meet the needs of your installation. It is, however, possible to run multiple instances of Mainframe Access server on your z/OS system. This might be desirable for establishing test and production servers, isolating specific user groups in their own server, isolating specific feature activations, etc.

Once you have a successful Mainframe Access server installation you can easily create additional instances as follows:

  • Create and activate VTAMLST APPL definitions for a new Mainframe Access server and a new Mainframe Access Data Connect server.
  • Reserve two unique TCP/IP ports for the new Mainframe Access server (a TCP_PORT and an ADMIN_PORT).
  • Create unique PARMS, SERVERS and ACCESS members for the new instance and customize them appropriately. You will definitely need to create a unique PARMS member and assign unique values to the LU62 APPLID=, TCP_PORT= and ADMIN_PORT= parameters. It is possible to share ACCESS definitions, if that will meet the needs of your configuration. An alternative method would be to create a copy of the CNTL data set and retain the original member names.
  • Allocate a unique audit log data set for the new instance if you are using this feature.
  • Create a copy of the MFA proc in the proclib data set and update the JCL to reference the new PARMS, SERVERS and ACCESS members for this instance. Also, update the audit log data set name if you are using this feature.
  • Create a copy of the MFAS proc in the proclib data set and update the JCL EXEC statement PARM field to specify the new MFAS ACBNAME in the APPLID= parameter. Also, update the VSAMCTL DD statement data set name if you want to allocate and manage a different set of mapping members for this instance.
  • Update the SERVERS definition for the new instance with the name of the new proc that was created from the MFAS proc (that is, update the ASPROC=MFAS value).
Parent topic: Configuration


Administration Using Console Commands

This section describes the console commands available for administering Mainframe Access.

  • Introduction
  • Console Commands
  • Using a Telnet Client
Parent topic: Configuring and Administering the Mainframe


Introduction

Mainframe Access provides a number of console commands that you can use to control execution and display the operational status of Mainframe Access. To use these commands, you must be authorized to use z/OS system console commands. Most of the commands are variants of the z/OS Modify (F) command, with the general format:

F your-procedure-name,command-text

where the parameters are:

your-procedure-name | The name of your Mainframe Access startup JCL as explained in the section Mainframe Access Data Sets in the chapter Configuration
command-text | One of the commands described in the section Console Commands

You use the z/OS Start (S) command to start Mainframe Access:

S your-procedure-name

You use the z/OS Stop (P) command to stop Mainframe Access:

P your-procedure-name

You can enter the commands in any of the following ways:

  • From an z/OS system console
  • Using an interface that allows the entry of z/OS system commands, such as IBM's TSO/ISPF SDSF (System Display and Search Facility)
  • Using a Telnet client through an Internet connection. You cannot start or stop Mainframe Access using a Telnet client. For more information on using a Telnet client see the section Using a Telnet Client

You can also control and monitor the operation of Mainframe Access through a Web browser interface that offers functionality in addition to that provided by the console commands. For further information on the Web browser interface see the chapter Administration Using the Web Interface.

Parent topic: Administration Using Console Commands
Related information
Mainframe Access Data Sets
Console Commands
Using a Telnet Client
Administration Using the Web Interface


Console Commands

All the available console commands are described in this section.

  • Start
  • Stop
  • TRACE ON and TRACE SHORT
  • REFRESH ACCESSLIST
  • DISPLAY LU
  • DISPLAY TCPSTATUS
  • DISPLAY CONVERSATION
  • C CONV=id
  • FLUSH XDBOUT
  • RESET TIMEOUT=n
  • SET TIMEOUT=n
Parent topic: Administration Using Console Commands


Start

Starts the Mainframe Access task. Mainframe Access automatically starts the Mainframe Access Data Connect server, MFAS, during initialization.

Here is an example of a Start command and the response:

15:49:32.45 CSIRLW1  00000290  S MFA
15:49:32.47 STC05579 00000090  $HASP100 MFA ON STCINRDR
15:49:32.55 STC05579 00000290  IEF695I START MFA WITH JOBNAME MFA IS ASSIGNED TO USER RWITEK, GROUP DEVELOP
15:49:32.55 STC05579 00000090  $HASP373 MFA  STARTED
15:49:32.55 STC05579 00000090  IEF403I MFA - STARTED - TIME=15.49.32
15:49:32.85 STC05579 00000090  MFM0014I: Mainframe Access V3.01 (ga) for YOUR_COMPANY_NAME
15:49:32.85 STC05579 00000090  MFM0066I: Address space type is CTLRGN
15:49:32.86 STC05579 00000090  MFM0057I: GTF user record id (eid) is 00E9
15:49:32.86 STC05579 00000090  MFM0012I: TCP port number is 1503
15:49:32.86 STC05579 00000090  MFM0013I: Admin port number is 1504
15:49:32.86 STC05579 00000090  MFM0047I: DSS maximum shared public files is 10
15:49:32.86 STC05579 00000090  MFM0055I: DSS scan interval is 2 minutes
15:49:32.86 STC05579 00000090  MFM0054I: SMF recording is off, record id is zero or invalid
15:49:32.87 STC05579 00000090  MFM0063I: MFA Direct is active
15:49:32.87 STC05579 00000090  MFM0064I: MFA Direct number of processing tasks is 5
15:49:33.16 STC05579 00000090  MFMDS052I CA/PanValet Ready
15:49:33.21 STC05579 00000090  MFMDS055I MCG/RPC feature inactive
15:49:33.22 STC05579 00000090  MFMDS001I DSS Server Ready
15:49:36.92 STC05579 00000090  MFM0001I: Mainframe Access V3.01 (ga) is active
15:49:37.00 STC05580 00000090  $HASP100 MFAS ON STCINRDR
15:49:37.06 STC05580 00000090  $HASP373 MFAS  STARTED
15:49:37.06 STC05580 00000090  IEF403I MFAS - STARTED - TIME=15.49.37
15:49:37.23 STC05580 00000090  MFA302I.MFAS.MFARSC00 / ATTACHING VTAM PROCESSOR
15:49:37.24 STC05580 00000090  MFA303I.MFAS.MFARSC00 / MFA/MVS V3.01 - PTF 2001PTF6 COPYRIGHT (C)
                               1987-2003 MICRO FOCUS INTERNATIONAL LTD.
15:49:37.24 STC05580 00000090  MFA110I.MFAS.MFAFSQ00 / VTAM PROCESSOR ACTIVE USING VTAMAPPL MFA62ACB
Parent topic: Console Commands


Stop

Stops the Mainframe Access task. Mainframe Access automatically stops the Mainframe Access Data Connect server, MFAS, during shutdown. Shutdown may take anywhere from 30 seconds to a few minutes, depending on the level of activity in the system.

Here is an example of a Stop command and the response:

16:44:18.52 CSIRLW1  00000290  P MFA
16:44:21.52 STC05579 00000290  P MFAS
16:44:21.53 STC05580 00000090  MFA112I.MFAS.MFAFSQ00 / VTAM PROCESSOR HAS TERMINATED
16:44:21.68 STC05580 00000090  MFA317I.MFAS.MFARSC00 / HAS BEEN TERMINATED
16:44:21.69 STC05579 00000090  MFMDS005I DSS Server shutdown
16:44:21.70 STC05580 00000090  IEF404I MFAS - ENDED - TIME=16.44.21
16:44:21.70 STC05580 00000090  $HASP395 MFAS  ENDED
16:44:32.77 STC05579 00000090  MFM0011I: Mainframe Access shutdown completed
16:44:32.82 STC05579 00000090  IEF404I MFA - ENDED - TIME=16.44.32
16:44:32.82 STC05579 00000090  $HASP395 MFA  ENDED
Parent topic: Console Commands


TRACE ON and TRACE SHORT

Activates detailed tracing of all Mainframe Access activity. Trace output is directed to the destination (SYSPRINT, GTF or CONSOLE) specified by the TRACE parameter during Mainframe Access startup. For more information about these options see the entry for the TRACE parameter in the section Editing Mainframe Access Parameters in the chapter Configuration. For a tip about viewing trace data sent to SYSPRINT interactively see the FLUSH XDBOUTcommand description

Here is an example of a TRACE ON command and the response:

F MFA,TRACE ON
MFM0015I: MFM0025I: Trace set to data level on

The TRACE SHORT command activates the same detailed tracing as does the TRACE ON command. The SHORT option limits the display of send data, receive data and storage areas to 256 characters. This can be useful in reducing the amount of trace output, particularly when the message sizes are large.

Here is an example of a TRACE SHORT command and the response:

F MFA,TRACE SHORT
MFM0015I: MFM0025I: Trace set to data level on
Parent topic: Console Commands
Related information
Editing Mainframe Access Parameters
FLUSH XDBOUT


REFRESH ACCESSLIST

Directs Mainframe Access to re-read the access list from the currently active access list data set (the access list identified by the //XDBACC DD statement in the Mainframe Access startup JCL). You can update the access list by adding, removing or updating PERMIT, REJECT and ADMUSER lines, as described in the section Editing Access List Definitions in the chapter Configuration. When your updates are complete, use REFRESH ACCESSLIST to replace the currently active access list with your updated list without stopping and restarting Mainframe Access.

Here is an example of a REFRESH ACCESSLIST command and the response:

F MFA,REFRESH ACCESSLIST
MFM0015I: Refresh Access List has completed
Parent topic: Console Commands
Related information
Editing Access List Definitions


DISPLAY LU

Displays information about the target servers which Mainframe Access has successfully connected to by establishing one or more LU6.2 sessions in response to client requests. Target servers are known to Mainframe Access by their SNA LU name or APPLID.

Here is an example of a DISPLAY LU command and the resulting display:

F MFA,DISPLAY LU
MFM0015I:  ***************************************************
MFM0015I:  *                   PLU Status                    *
MFM0015I:  ***************************************************
MFM0015I:
MFM0015I:  ******* Partner LU Status
MFM0015I:  LU Name..........LUDB27R
MFM0015I:     Mod Entry........IBMRDB
MFM0015I:     Status...........Active
MFM0015I:  LU Name..........MFA62ACB
MFM0015I:     Mod Entry........#INTER
MFM0015I:     Status...........Active
Parent topic: Console Commands


DISPLAY TCPSTATUS

Displays basic TCP/IP configuration information from the Mainframe Access parameters (port number, company name and connection backlog) followed by the information displayed by the DISPLAY LU and DISPLAY CONVERSATION commands. On a busy system this display can be very long and we recommend that you use the Web Administration interface for this function; see the sections Target LU Status Page and Conversation Status Page in the chapter Administration Using the Web Interface.

Here is an example of a DISPLAY TCPSTATUS command and the resulting display:

F MFA,DISPLAY TCPSTATUS
MFM0015I:  ***************************************************
MFM0015I:  *                   TCP Status                    *
MFM0015I:  ***************************************************
MFM0015I:
MFM0015I:  Server Port Number.......1503
MFM0015I:  Web Server Port Number...1504
MFM0015I:  OID....................YOUR_COMPANY_NAME
MFM0015I:  Number of Backlogs.......5
MFM0015I:  ******* Partner LU Status
MFM0015I:  LU Name..........LUDB27R
MFM0015I:     Mod Entry........IBMRDB
MFM0015I:     Status...........Active
MFM0015I:  LU Name..........MFA62ACB
MFM0015I:     Mod Entry........#INTER
MFM0015I:     Status...........Active
MFM0015I:  ******* Conversation Status
MFM0015I:  Conversation ID..1AA14028
MFM0015I:     Conv Address.....1AC79968
MFM0015I:     Alloc Address....1A928DC0
MFM0015I:     Task Address.....1AA4CE28
MFM0015I:     Conv Status......Active
MFM0015I:     TCP/IP Status....Send
MFM0015I:     User Id..........CSIRLW1
MFM0015I:     Target LU........LUDB27R
MFM0015I:     Peer IP address..10.10.11.130
MFM0015I:     Socket Number....9
MFM0015I:     Start Time.......07/17/03 15:10:32
MFM0015I:     LUW Id...........DDINE.MFM62ACB.B9BBC4F618400001
MFM0015I:     Packets Sent.....14
Parent topic: Console Commands
Related information
DISPLAY LU
DISPLAY CONVERSATION
Target LU Status Page
Conversation Status Page


DISPLAY CONVERSATION

Displays detailed information about every active conversation between Mainframe Access and the target servers. On a busy system this display can be very long and we recommend that you use the Web Administration interface for this function; see the section Conversation Status Page in the chapter Administration Using the Web Interface.

Here is an example of a DISPLAY CONVERSATION command and the resulting display:

F MFA,DISPLAY CONVERSATION
MFM0015I:  ***************************************************
MFM0015I:  *               Conversation Status               *
MFM0015I:  ***************************************************
MFM0015I:
MFM0015I:  ******* Conversation Status
MFM0015I:  Conversation ID..1AA14028
MFM0015I:     Conv Address.....1AC79968
MFM0015I:     Alloc Address....1A928DC0
MFM0015I:     Task Address.....1AA4CE28
MFM0015I:     Conv Status......Active
MFM0015I:     TCP/IP Status....Send
MFM0015I:     User Id..........CSIRLW1
MFM0015I:     Target LU........LUDB27R
MFM0015I:     Peer IP address..10.10.11.130
MFM0015I:     Socket Number....9
MFM0015I:     Start Time.......07/17/03 15:10:32
MFM0015I:     LUW Id...........DDINE.MFM62ACB.B9BBC4F618400001
MFM0015I:     Packets Sent.....14
MFM0015I:     Packets Rcv'd....27
MFM0015I:  Conversation ID..1ABFF2E0
MFM0015I:     Conv Address.....1ACD0968
MFM0015I:     Alloc Address....1A928BA0
MFM0015I:     Task Address.....1AA4CA78
MFM0015I:     Conv Status......Active
MFM0015I:     TCP/IP Status....Send
MFM0015I:     User Id..........CSIRLW1
MFM0015I:     Target LU........MFA62ACB
MFM0015I:     Peer IP address..10.10.11.130
MFM0015I:     Socket Number....13
MFM0015I:     Start Time.......07/17/03 15:11:40
MFM0015I:     LUW Id...........DDINET1.MFM62ACB.B9BBC538B9410001
MFM0015I:     Packets Sent.....4
Parent topic: Console Commands
Related information
Conversation Status Page


C CONV=id

Cancels a specific conversation. Theid parameter is a conversation identifier of eight hexadecimal characters as shown in the information displayed by DISPLAY CONVERSATION and DISPLAY TCPSTATUS commands. Canceling a conversation ends the LU6.2 conversation to the target server and releases the LU6.2 session for use by other conversations. It also disconnects the client by closing the client socket associated with the conversation and cancels the DDF thread if the conversation partner is DB2.

Here is an example of the CANCEL CONVERSATION command that cancels the second conversation shown in the DISPLAY CONVERSATION example:

F MFA,C CONV=1ABFF2E0
MFM0015I: Cancel Command accepted
Parent topic: Console Commands


FLUSH XDBOUT

Flushes trace data and operational messages to the //XDBOUT DD SYSOUT data set. Operational data is written to XDBOUT during normal operation; trace data is written to XDBOUT only when tracing is switched on and the trace destination is SYSPRINT. The FLUSH command causes any partially filled buffer to be written to the SYSOUT data set, making the output available for browsing. This can be helpful when you are testing and trying to view trace data interactively as the test progresses.

Here is an example of a FLUSH XDBOUT command and the response:

F MFA,FLUSH XDBOUT
MFM0015I: Flush XDBOUT completed
Parent topic: Console Commands


RESET TIMEOUT=n

Changes the TIME OUT FOR CONNECTION parameter value without you having to stop and restart Mainframe Access. The n parameter is the number of minutes that a client connection can remain idle before the connection will be broken and Mainframe Access resources dedicated to the client will be released. Resources that are released when an idle client is disconnected include allocated storage, TCP/IP resources and LU6.2 conversations to target servers such as DB2, IMS, CICS and Mainframe Access Data Connect. Specify 0 (zero) to disable the client timeout feature and allow unlimited idle time.

If you use the RESET TIMEOUT command to establish a new timeout value, rather than SET TIMEOUT, both the Mainframe Access timeout and any Mainframe Access client timeout remain in effect. The connection partner (Mainframe Access client or Mainframe Access) having the smaller timeout value initiates the disconnection first.

Here is an example of a RESET TIMEOUT command and the response:

F MFA,RESET TIMEOUT=30
MFM0015I: Timeout parameter reset to 30
Parent topic: Console Commands


SET TIMEOUT=n

Changes the TIME OUT FOR CONNECTION parameter value without you having to stop and restart Mainframe Access. The n parameter is the number of minutes that a client connection can remain idle after which the connection will be broken and Mainframe Access resources dedicated to the client will be released. Resources that are released when an idle client is disconnected include allocated storage, TCP/IP resources and LU6.2 conversations to target servers such as DB2, IMS, CICS and Mainframe Access Data Connect. Specify 0 (zero) to disable the client timeout feature and allow unlimited idle time.

If you use the SET TIMEOUT command to establish a new timeout value, rather than RESET TIMEOUT, then when a Mainframe Access client subsequently starts up, Mainframe Access' connection timeout is disabled, and only the inactivity timeout period specified by the Mainframe Access client is in effect.

Here is an example of a SET TIMEOUT command and the response:

F MFA,SET TIMEOUT=20
MFM0015I: Timeout parameter set to 20
Parent topic: Console Commands


Using a Telnet Client

This section describes how to connect to Mainframe Access using a Telnet client, enter commands and disconnect.

  • Connecting to Mainframe Access using a Telnet Client
  • Entering Commands from a Telnet Client
  • Disconnecting from a Telnet Client
Parent topic: Administration Using Console Commands


Connecting to Mainframe Access using a Telnet Client

To connect to Mainframe Access using Telnet, follow these steps:

  1. Start your Telnet client software.
  2. Click Remote System on the Connect menu.
  3. In the Connect dialog box, fill in the fields as follows:
    Host Name | TCP/IP host name of your z/OS system
    Port | The value in the Mainframe Access start-up parameter TCP_PORT
    TermType | A suitable terminal type emulation for your connection, such as VT100
  4. Click Connect.

An example is shown below.

Figure 1. Telnet Connect Dialog Box
Telnet Connect Dialog Box

After the connection is established, press Enter twice. This is essential to enable Mainframe Access to recognize the Telnet client, since Mainframe Access uses the same port for several different types of client connection. When Mainframe Access recognizes the Telnet client it sends out an initial prompting message and is ready to receive commands.

Parent topic: Using a Telnet Client


Entering Commands from a Telnet Client

You can enter any console command except Start and Stop by prefixing the command string with a single dollar sign ($). Mainframe Access responds by displaying the command output data followed by the prompting message to indicate readiness for another command. Figure 3-2 shows the command input line $display tcpstatus and the resulting command output data.

Figure 1. Entering a Command
Entering a Command
Parent topic: Using a Telnet Client


Disconnecting from a Telnet Client

To disconnect from a Telnet client, either:

  • Shut down your Telnet client software
  • Enter the "end" command with no dollar sign prefix
Parent topic: Using a Telnet Client


Administration Using the Web Interface

This chapter describes Mainframe Access administrative functions that are available using a Web browser.

  • Introduction
  • Accessing Web Administration
  • Using Web Administration
Parent topic: Configuring and Administering the Mainframe


Introduction

Mainframe Access' Web Administration feature provides a comprehensive administration interface for graphical Web browser clients. Using Web Administration you can display current operational information, target server information and internal data structures, dynamically refresh control lists and change operating parameters.

Parent topic: Administration Using the Web Interface


Accessing Web Administration

You need a graphics-enabled browser to use Web Administration. We recommend that you set your monitor's screen resolution to 800 by 600 pixels or better. You access the Web Administration login page by setting your browser to the URL for Mainframe Access' HTTP clients. Enter the URL on the address line of your browser as follows:

http://your.mainframe.name:admin_port

where the components of the address are:

your.mainframe.name | The TCP/IP hostname of your z/OS system or the actual IP address of that system
admin_port | The TCP/IP port number that was specified for the Mainframe Access ADMIN_PORT parameter in the PARMS member.

When the login page is displayed, enter a user ID and password combination that is known to your z/OS security subsystem. The user ID you specify must also be defined as an administrative user in the Mainframe Access access list definitions.

Parent topic: Administration Using the Web Interface


Using Web Administration

The Web Administration display area is divided into four panes. The top two panes remain constant as you work and provide helpful links:

  • The upper-left pane displays the Micro Focus logo. This provides a link to the current Micro Focus home page, from which you can access our Product Support home page that can be used as a starting point whenever you need help or advice with using Mainframe Access.
  • The upper-right pane displays a book icon that provides a link to to the Host Connectivity Bookshelf page. You can use this link at any time to download the bookshelf, a collection of publications from the Host Connectivity CD that includes this book (the Mainframe Access Administrator's Guide). During the transition to the new bookshelf format, the download page also provides a link to a traditional HTML version of the Administrator's Guide.

Once you have logged in, the lower-left pane remains constant as you work and provides links to each of the administrative functions. You select a function by clicking on the right-pointing arrow to the left of the function name. The large pane at the lower-right is the main display area where you see the results of your display requests and interact with specific administrative functions. You can select a different function from the lower-left pane at any time.

You do not need to log out when you have finished using Web Administration. Shutting down your browser prevents others from accessing Web Administration through your login, even if they restart your browser and attempt the access using browser history links.

The Web Administration display is shown in Figure 4-1.

Figure 1. Web Administration Home Page
Web Administration Home Page

The administrative functions are organized into five categories:

  • Display
  • Refresh
  • Action
  • List
  • Diagnostics

These are explained in the following sections.

  • Display Pages
  • Refresh Pages
  • Action Pages
  • List Pages
  • Diagnostics Pages
Parent topic: Administration Using the Web Interface


Display Pages

Display pages show the current operational status of various Mainframe Access communications elements.

  • Status Page
  • Target LU Status Page
  • Conversation Status Page
  • TCP Task Status Page
Parent topic: Using Web Administration


Status Page

The Status page displays the following TCP/IP configuration information:

Server port number | This is the port used by clients that communicate using Micro Focus's proprietary TCP/IP protocols. This includes Mainframe Access clients and COBOL development environment clients. Telnet clients also connect to this port to use Mainframe Access' Telnet client administration interface, as described in the section Using a Telnet Client in the chapter Administration Using Console Commands. Web Administration obtains the value from the Mainframe Access start-up parameter TCP_PORT.
Web server port number | This is the port used by clients using the standard HTTP protocol. This includes Web browsers accessing the Web Administration function. Web Administration obtains the value from the Mainframe Access start-up parameter ADMIN_PORT.
Organization name | Web Administration obtains this value from the Mainframe Access start-up parameter ORGANIZATION.
Number of backlogs | This is the maximum number of pending TCP/IP requests that the TCP/IP software can hold while Mainframe Access is processing the current request. Web Administration obtains the value from the Mainframe Access start-up parameter BACKLOG.

An example is shown below.

Figure 1. Status Page
Status Page
Parent topic: Display Pages
Related information
Using a Telnet Client


Target LU Status Page

The Target LU Status page shows all the VTAM server applications that have been connected to Mainframe Access through SNA LU6.2 sessions

Note:

Target LUs for Mainframe Access Data Connect, IMS Option and CICS Option must be defined in the server configuration. DB2 LUs are not defined in the server configuration; all necessary connection information for DB2 is specified in the XDB Link configuration for SQL Option for DB2 and this connection information is provided to Mainframe Access with the first client request for a particular DB2 server.

The example shown in Figure 4-3 shows that sessions have been established with a Mainframe Access Data Connect server, a DB2 subsystem (on behalf of a SQL Option for DB2 client), an IMS system (on behalf of an IMS Option client) and a CICS system (on behalf of a CICS Option client). The example also shows that the internal LU for Password Expiration Manager functions, PEMDB62, has been accessed. This LU name will always show a status of "Not Active" because it is only used internally by Mainframe Access. The example also shows two CICS LU names with a status of "Not Active". The appearance of an LU name in the list indicates that it has been requested by a client and the status of "Not Active" may indicate that the associated subsystem is not up or that the connection attempt by Mainframe Access was rejected, possibly due to a configuration error in Mainframe Access or in the subsystem.

Figure 1. Target LU Status Page
Target LU Status Page

Click Refresh to update the display.

Parent topic: Display Pages


Conversation Status Page

The Conversation Status page shows a summary of all LU6.2 conversations that are currently active. In general, for each active client connected to Mainframe Access, there is an active LU6.2 conversation between Mainframe Access and the client's target server. An example is shown below.

Figure 1. Conversation Status Page
Conversation Status Page

Click Refresh to update the display.

Click More Information to access a detailed display for a specific conversation. The figure below shows an example of the detailed display.

Figure 2. Conversation Details Page
Conversation Details Page

Click Refresh to update the display.

Click Back to return to the Conversation Status page.

Click Cancel to end the conversation and the associated client connection.

Use the Previous and Next links to step through the conversation details without returning to the main Conversation Status page. These links are displayed only when applicable.

Parent topic: Display Pages


TCP Task Status Page

The TCP Task Status page displays a summary of the z/OS tasks that have been activated by the TCPLINK_MAXTASKS initialization parameter. These tasks are used to process requests from SQL Option for DB2 clients and Telnet clients. The session counts summarize the SNA LU6.2 sessions that have been activated for client conversations with DB2 subsystems. Sessions are active when they are allocated to a specific conversation on behalf of a client and inactive when they are available for use by a new client request. An example is shown below.

Figure 1. TCP Task Status Page
TCP Task Status Page

Click Refresh to update the display.

Parent topic: Display Pages


Refresh Pages

Refresh functions dynamically update Mainframe Access definitions or remove existing copies of files so that Mainframe Access will need to acquire fresh copies the next time the information is needed.

  • Refresh Access List Page
  • Refresh Servers Page
  • Refresh Web File Cache Page
  • Refresh ISPI Program Page
Parent topic: Using Web Administration


Refresh Access List Page

The Refresh Access List page asks you to confirm that you want to refresh the access list.

Click Refresh to confirm the access list refresh. Mainframe Access discards all of the current operating information previously obtained from the access list and re-reads the access list definitions from the DASD file specified in the currently active Mainframe Access startup JCL. This refresh function enables you to update the access list while Mainframe Access is running. The new definitions take effect immediately. Finally, Mainframe Access displays a page that indicates that the refresh is complete.

If you change your mind about refreshing the access list, simply select another Web Administration function.

For more information about the access list, see the section Editing Access List Definitions in the chapter Configuration.

Parent topic: Refresh Pages
Related information
Editing Access List Definitions


Refresh Servers Page

The Refresh Servers page enables you to select the server definition types that you want to refresh and confirm the refresh request, as shown below.

Figure 1. Refresh Servers Page
Refresh Servers Page

Use the check boxes to select the server definition types that you want to refresh.

Click Reset to clear all the check boxes.

Click Refresh to confirm the request. Mainframe Access discards all of the current operating information previously obtained for the selected server types and re-reads the server definitions from the DASD file specified in the currently active Mainframe Access startup JCL. Using this refresh function you can add, remove and modify the target server specifications. The new definitions take effect immediately. Finally, Mainframe Access displays a page that indicates that the refresh is complete.

If you change your mind about refreshing the servers, simply select another Web Administration function.

Parent topic: Refresh Pages


Refresh Web File Cache Page

Mainframe Access normally reads a Web resource (such as an HTML page, GIF image, Java class) from the DASD data sets only once, when the first request for the resource is received from a client. That first request causes the resource to be saved in a virtual storage cache that is used to satisfy all subsequent requests. If you refresh the Web file cache, Mainframe Access responds to subsequent resource requests by re-reading the resource data from the DASD data sets, when the first request for a resource is again received. The refresh function makes it possible for you to update Web resources in the DASD data sets and have the changes take effect immediately.

When you select the Refresh Web File Cache function from the lower-left pane, the refresh is performed immediately. All virtual storage that has previously been allocated by Mainframe Access to cache Web resources is released.

Mainframe Access responds to the refresh request by displaying a page that indicates that the refresh is complete.

Parent topic: Refresh Pages


Refresh ISPI Program Page

The Refresh ISPI Program page enables you to specify the name of the program that you want to refresh and confirm the refresh request.

Enter the z/OS load module name of the program in the text box, without an extension. Click Refresh to confirm the request. Mainframe Access marks the current version of the program for removal and displays a page that indicates that the load module refresh has been scheduled. The program is removed from virtual storage using the z/OS DELETE service when all processes currently using the program are complete. Also, a fresh copy of the load module is brought into virtual storage using the z/OS LOAD service and all subsequent requests for the program are satisfied using the new copy, even while existing processes are completing their activity using the old copy.

If you change your mind about refreshing the ISPI program, simply select another Web Administration function.

Parent topic: Refresh Pages


Action Pages

Action pages enable you to change some aspects of the way Mainframe Access operates.

  • Activity Trace Page
  • Set Timeout Page
Parent topic: Using Web Administration


Activity Trace Page

The Activity Trace page enables you to activate or deactivate the Mainframe Access internal trace. Mainframe Access internal trace data may be requested by Micro Focus technical support during analysis of a reported problem. When trace is active, data is recorded either to the XDBOUT data set defined in the currently active Mainframe Access JCL or to the z/OS Generalized Trace Facility (GTF), depending on the initialization parameters in effect and the status of GTF in the system. The Activity Trace page is shown below.

Figure 1. Activity Trace Page
Activity Trace Page

Click Trace On if you want to activate the trace. Click Trace Off if you want to deactivate the trace. Then click Set to update the status of the activity trace. Mainframe Access responds by displaying a page that indicates the new status of the activity trace.

If you change your mind about changing the status of the activity trace, simply select another Web Administration function.

Parent topic: Action Pages


Set Timeout Page

The Set Timeout page enables you to specify a new timeout value and put it into effect. Mainframe Access monitors the activity of all connected clients and disconnects clients that remain idle longer than the timeout period. When an idle client is disconnected due to a timeout, any associated conversation with a target server is also ended.

Enter the new timeout value in minutes in the text box. Then click Set to update Mainframe Access' timeout value. Mainframe Access responds by displaying a page that indicates the timeout value that is now in effect.

If you change your mind about changing the current timeout value, simply select another Web Administration function.

Parent topic: Action Pages


List Pages

List functions report z/OS information for external transaction and data handling subsystems.

  • DB2 Subsystems Page
  • IMS Systems Page
Parent topic: Using Web Administration


DB2 Subsystems Page

The DB2 Subsystems page displays information about all DB2 subsystems that have been defined to the z/OS system on which Mainframe Access is running. This page is a useful source for DB2 subsystem information when you are configuring SQL Option for DB2 client. An example is shown below. In some cases Mainframe Access will include non-DB2 subsystem names in the display. In this example, CSQ1 and CSQ2 are MQ Series subsystems and there are no DB2 location names or lunames associated with these subsystems.

Figure 1. DB2 Subsystems Page
DB2 Subsystems Page

Click Refresh to update the display.

Parent topic: List Pages


IMS Systems Page

The IMS Systems page displays information about all IMS regions in the z/OS system on which Mainframe Access is running. This page is a useful source for IMS system information when you are configuring an IMS Option client and the corresponding Mainframe Access server definitions. An example is shown below.

Figure 1. IMS Systems Page
IMS Systems Page

Click Refresh to update the display.

Parent topic: List Pages


Diagnostics Pages

Diagnostics examine and display Mainframe Access control structures.

  • Task Hierarchy Page
  • Web File Cache Page
  • Service Level Page
  • Feature List Page
Parent topic: Using Web Administration


Task Hierarchy Page

The Task Hierarchy page displays all the z/OS tasks that have been created by Mainframe Access within the address space, indicating their parent-child relationships in a hierarchy. An example is shown below.

Figure 1. Task Hierarchy Page
Task Hierarchy Page

Each task name in the display is a link to a detailed display of information specific to that task. The example shown below displays the task-related information for the Mainframe Access job step task that is named XDRMAIN. There are further links in the detailed information; these links are normally used only by our Product Support.

Figure 2. Task Details Page
Task Details Page
Parent topic: Diagnostics Pages


Web File Cache Page

The Web File Cache page displays all the Web server resources that have been accessed in response to client requests and cached in z/OS virtual storage. For each resource in the cache the display shows the name of the resource, the type of Web resource, the number of bytes of storage used to cache the resource, and the DASD data set from which the resource was obtained. An example is shown below.

Figure 1. Web File Cache Page
Web File Cache Page
Parent topic: Diagnostics Pages


Service Level Page

The Service Level page displays the version number of Mainframe Access and the level of maintenance that has been applied to Mainframe Access using service packs. This information is important when you are reporting a problem to our Product Support. An example is shown below.

Figure 1. Service Level Page
Service Level Page

The Parm Address provides a link to a display of the current contents of Mainframe Access' primary parameter block. This information is the working copy of Mainframe Access control information that is obtained from the parameters file during initialization and may later be updated dynamically using administrative commands. An example is shown below.

Figure 2. Parameter Block Page
Parameter Block Page
Parent topic: Diagnostics Pages


Feature List Page

When you select Features from the lower-left pane, you see a page on which you can either:

  • Select to see a feature list based on the current production password. To do this, click Decode next to the text "Decode the current production password".
  • Select to see a feature list based on the password you received with an earlier version of Mainframe Manager. To do this, specify the password (16 hexadecimal characters) in the text box next to Enter password, and click Decode next to the text box. If you make a mistake and want to start again, click Reset to clear the text box.
Note: Note:

Beginning with Mainframe Manager Version 2.01, the product password is provided internally during initialization and all features are enabled by default. There is no need to enter a product password value in the initialization parameters. If you previously used a release of Mainframe Manager before Version 2.01, you can select the button to Decode the current production password to verify that all of your required features are now automatically enabled.

This page is shown below.

Figure 1. Features Page
Features Page

When you click either Decode button, Mainframe Access responds by displaying the Feature List page, as shown below. This page displays the Mainframe Access functions that are enabled based on either the current production password or an the alternative password that you entered.

Figure 2. Feature List Page
Feature List Page
Parent topic: Diagnostics Pages


Troubleshooting

This chapter contains information that will help you to diagnose software problems related to Mainframe Access.

  • Abend Codes
  • LU6.2 Diagnostic Information
  • Mainframe Access Host Error Codes
  • Mainframe Access Remote IMS Error Codes
  • IBM SAF and RACF Error Codes
  • Mainframe Access Audit Report Program
  • Obtaining a VTAM Buffer Trace
Parent topic: Configuring and Administering the Mainframe


Abend Codes

An abend, or abnormal end, is the most obvious way for a software problem to be indicated. The z/OS processing for an abend normally creates a dump of the failing program's address space storage for use in problem determination. An abend can be initiated by Mainframe Access itself or by other software components of the z/OS system. Although a program abend is most often the result of a software error within the failing program, abend conditions can also be caused by other software and hardware components of the system.

  • System Abend Codes
  • Mainframe Access User Abend Codes
  • SAS/C Run-time Library User Abend Codes
Parent topic: Troubleshooting


System Abend Codes

Many software failures are detected by z/OS and its components. These conditions are normally reported as system abends using a code consisting of the letter S identifying a system abend and three hexadecimal digits, for example, S0C4. Complete descriptions of these conditions can found in the IBM publications for your specific version of z/OS. If a system abend is reported for Mainframe Access, it is important to review the abend description. This will help you to make an initial determination as to whether this is most likely a Mainframe Access program failure or a failure caused by other system conditions that have affected the execution of Mainframe Access.

Parent topic: Abend Codes


Mainframe Access User Abend Codes

When Mainframe Access detects a condition that prevents the program from continuing, it requests z/OS to begin abend processing for a user abend. Many of these conditions are detected by Mainframe Access initialization or by the item library format utility. z/OS reports user abends using a code consisting of the letter U identifying a user abend and four decimal digits, for example, U2111. The user abend codes that can be issued by Mainframe Access and recommended actions are listed in the following table.

User Abend Code | Description of Cause | Recommended Action
99 | Issued when a Data Set Services ISPI module cannot determine the invocation reason. | Contact our Product Support.
801 | Processing to establish or remove a Mainframe Access ESTAEX error recovery routine has failed. | Contact our Product Support.
996 | The MFA Server DSS Services component failed to initialize properly. This is a should not occur condition. | Contact our Product Support.
997 | An Endevor error has occurred in the application server address space. Common causes include a general setup failure, MSGLOG allocation failure, or the Endevor C1DEFLTS module could not be found. Endevor requests cannot be processed. | Examine the joblog and syslog for system messages and server messages that can help identify the specific error. Contact our Product Support if you are unable to resolve the problem
998 | There is a difference between the Endevor support modules available to the MFA Server control region and the Endevor support modules available in the MFA Server application server region(s). Different versions of Endevor are being referenced by the regions. Endevor requests cannot be processed. | This is most likely caused by differences in the STEPLIB or JOBLIB concatenations in the JCL used to start the regions. Contact our Product Support if you are unable to resolve the problem.
999 | This abend code indicates that the Endevor support modules are not available to MFA Server. Endevor requests cannot be processed. | The Endevor AUTHLIB and CONLIB data sets must be included in the MFA started task JCL (for both the control region and the application server regions) or these data sets must be available in the standard system LNKLST specifications. Contact our Product Support if you are unable to resolve the problem.
2100 | Processing to establish or remove a Mainframe Access ESTAEX error recovery routine has failed. | Contact our Product Support.
3100 | Processing associated with Mainframe Access' dependent addresss space services has encountered a should not occur condition. | Contact our Product Support.
3101 | Work order allocation for a dependent address space service has failed. This is a should not occur condition. | Contact our Product Support.
3102 | Allocation for a dependent address space service program call block has failed. This is a should not occur condition. | Contact our Product Support.
3103 | Work order queuing for a dependent address space service has failed. This is a should not occur condition. | Contact our Product Support.
Parent topic: Abend Codes


SAS/C Run-time Library User Abend Codes

Mainframe Access' C language components are built with the SAS/C compiler and use the associated SAS/C run-time libraries during execution. Some software problems can be detected by the SAS/C run-time library routines. These SAS/C routines issue the following specific user abend codes to indicate the nature of the problem and create a storage dump. This list may not be complete; for a full up-to-date list of codes please see the SAS Web site http://www.sas.com. If you receive any of these abend codes contact our Product Support.

User Abend Code | Description of Cause
1200 | Storage corruption detected while freeing DSA.
1201 | Storage corruption detected while allocating DSA.
1202 | Storage corruption in the automatic storage stack.
1203 | Storage corruption detected while freeing automatic storage at the end of program execution.
1204 | Target of a longjmp cannot be found.
1205 | Storage corruption detected in heap storage during execution of calloc/malloc.
1206 | Storage corruption detected when attempting to reuse free heap storage.
1207 | Storage corruption detected while releasing a tract of heap storage.
1208 | Pointer to storage block to be freed is not valid.
1209 | Storage corruption of heap storage control blocks is detected during program termination.
1210 | The SIGABRT signal is raised and default handling is in effect.
1211 | The argument to unloadm does not address a function in a module previously loaded by loadm.
1212 | Required transient run-time functions cannot be loaded. Under z/OS, the transient library must have been installed into the system link list or be defined as part of STEPLIB or CTRANS.
1213 | A subordinate C load module is abused by calling it directly (for example, via EXEC PGM=) as if it were a main program.
1214 | More than one recursive error occurs during diagnostic message processing. This is probably a run-time library error.
1215 | CMS: an error occurs while trying to delete the storage occupied by a dynamically loaded module during a call to unloadm. The most likely cause is a storage overlay.
1216 | CMS: an invalid library control block is encountered during a call to unloadm. This is probably caused by a storage overlay.
1217 | CMS: an invalid library control block is encountered during a call to loadm. This is probably caused by a storage overlay.
1218 | CMS: an error occurs while trying to delete a buffer during dynamic loading. The most likely cause is a storage overlay.
1219 | The interface between the debugger and the library detects an error in its own processing or in the debugger.
1220 | The abort debugger command is executed, or multiple attention interrupts occur and the debugger is unable to respond normally due to a program loop or system slowdown.
1221 | CMS: an error is detected by CP while loading a library segment. It is probably an indication of a CP system error.
1222 | The library framework Access detects an error in its use. This is most likely a library error, but it can be caused by overlay of library control blocks.
1223 | TSO: indicates a system problem in the TSO SUBCOM interface. This is most likely a library or TSO error.
1224 | longjmp or exit attempts to terminate a non-C routine.
1225 | There is no handler for an asynchronous signal, such as SIGALRM, for which the default action is termination.
1226 | The Full-Screen Support Library detects an internal error.
1227 | A library error occurs terminating a co-process.
1228 | There is not enough storage available to extend the internal queue of IUCV or socket communication messages. The probable cause is that the number of incoming interrupts is greater than the program can handle.
1229 | CICS: not enough storage available for an unconditional GETMAIN.
1230 | A POSIX function cannot be executed because OpenEdition is not installed or active, but the function does not have any defined error conditions.
1231 | No TWA is defined for a CICS Indep Application.
1233 | An internal error occurred in the inter-language communication support routines. This is most likely a library error, but could be caused by an overlay of library control blocks.
1234 | A call is made from a C program to a routine written in another high-level language or from a program in another high-level language to a C function, but the framework for the called language has not been created.
1235 | An inter-language communication feature usage error. The error is explained by a preceding message.
1239 | CICS: an unexpected internal error is encountered during abnormal termination processing.
1240 | An unexpected program check occurs during library abend analysis. Possible storage overlay or a problem in the analysis routine.
Parent topic: Abend Codes


LU6.2 Diagnostic Information

Mainframe Access uses IBM's VTAM APPCCMD interface for LU6.2 communication with many of the target server systems, such as CICS, IMS and DB2. When problems arise and an error is reported for LU6.2 communication with one of these systems, the exact conditions of the error are indicated to Mainframe Access as return values from the APPCCMD call. These return values are logged to Mainframe Access' XDBOUT SYSOUT data set and can help you to identify and correct the situation. The following tables summarize the return value information. If you need more information, see the z/OS Communications Server SNA Programmer's LU 6.2 Reference manual for your level of z/OS and VTAM.

  • RTNCD and FDB2 Return Values for LU6.2 APPCCMD Calls
  • RCPRI and RCSEC Return Values for LU6.2 APPCCMD Calls
Parent topic: Troubleshooting


RTNCD and FDB2 Return Values for LU6.2 APPCCMD Calls

The RTNCD (return code) and FDB2 (feedback two) values are the major return values associated with an APPCCMD call. The following table summarizes these major return values.

RTNCD | FDB2 | Explanation
X'00' | X'0B' | An error occurred during the execution of the APPCCMD call. The specific nature of the error is indicated by secondary return values, RCPRI and RCSEC, as documented in the next section
X'04' | X'05' | Symbolic name known by network-qualified name only
X'10' | X'13' | Attempt to start 6.2 session: request rejected
X'10' | X'14' | Attempt to start 6.2 session: pending session terminated
X'10' | X'15' | An APPCCMD must be issued
X'14' | X'7F' | Policing error: non-APPC macro
Parent topic: LU6.2 Diagnostic Information


RCPRI and RCSEC Return Values for LU6.2 APPCCMD Calls

The RPL extension contains two fields in which return code information is passed to the application program at the completion of an LU6.2 APPCCMD macroinstruction execution. The RCPRI field returns a primary return code to the application; the RCSEC field returns a secondary return code to the application.

RCPRI | RCSEC | Explanation
X'0000' | X'0000' | OK; no errors
X'0000' | X'0001' | As specified; CNOS values were accepted
X'0000' | X'0002' | As negotiated; CNOS values changed by negotiation
X'0000' | X'0003' | Receive specific rejected
X'0000' | X'0004' | Partner LU supports single session
X'0000' | X'0005' | Internal VTAM error
X'0000' | X'0006' | Restore unnecessary; no modes to restore
X'0000' | X'0007' | Restore complete; input work area too small
X'0000' | X'0008' | No immediately available information
X'0000' | X'0009' | Request terminated by end of conversation
X'0000' | X'000A' | Sessions will use appl name, generic name requested
X'0000' | X'000B' | Sessions will use generic name, appl name requested
X'0000' | X'000C' | As specified, partner LU known by different name
X'0000' | X'000D' | As negotiated, partner LU known by different name
X'0004' | ALL | Allocation error
X'0004' | X'0000' | Allocation failure no retry
X'0004' | X'0001' | Allocation failure retry
X'0004' | X'0002' | Conversation type mismatch
X'0004' | X'0003' | PIP not allowed
X'0004' | X'0004' | PIP not specified correctly
X'0004' | X'0005' | Security not valid
X'0004' | X'0006' | Sync level not supported by LU
X'0004' | X'0007' | Sync level not supported by program
X'0004' | X'0008' | Transaction program name (TPN) not recognized
X'0004' | X'0009' | Transaction program name (TPN) not available; no retry
X'0004' | X'000A' | Transaction program name (TPN) not available; retry
X'0004' | X'000B' | Cannot reconnect transaction program; no retry
X'0004' | X'000C' | Cannot reconnect transaction program; retry
X'0004' | X'000D' | Reconnect not supported by program
X'0004' | X'000E' | Mode must be restored before using
X'0004' | X'000F' | Deallocation requested
X'0004' | X'0010' | Allocation error - sync level not valid for full duplex
X'0004' | X'0011' | Allocation error - LU pair not supporting FDX conversation
X'0008' | ALL | CNOS failure
X'0008' | X'0000' | Allocation failure; retry
X'0008' | X'0001' | Allocation failure; no retry
X'0008' | X'0002' | Transaction program not available; retry
X'0008' | X'0003' | Transaction program not available; no retry
X'0008' | X'0004' | Conversation type mismatch
X'0008' | X'0005' | Security not valid
X'0008' | X'0006' | Mode must be restored before using
X'0008' | X'0007' | Network qualified name mismatch
X'000C' | X'0000' | CNOS resource failure; no retry
X'0010' | X'0000' | Partner granted retry
X'0010' | X'0001' | Control operator for local LU retried
X'0010' | X'0002' | Partner CNOS in progress
X'0010' | X'0003' | LU in pending single state
X'0010' | X'0004' | Partner LU starting session
X'0014' | X'0000' | Deallocate abend program
X'0018' | X'0000' | Deallocate abend service
X'001C' | X'0000' | Deallocate abend timer
X'0020' | X'0000' | CNOS failure; retry
X'0024' | X'0000' | Logical record boundary error
X'0028' | X'0000' | LU mode session limit closed
X'002C' | ALL | Parameter error
X'002C' | X'0000' | Invalid LU name or network identifier
X'002C' | X'0001' | Invalid mode
X'002C' | X'0002' | Invalid conversation
X'002C' | X'0003' | Invalid LL
X'002C' | X'0004' | Invalid values for SNASVCMG mode
X'002C' | X'0005' | Invalid DRAINL change
X'002C' | X'0006' | SNASVCMG mode cannot currently be reset
X'002C' | X'0007' | MINWINL plus MINWINR exceeds SESSLIM
X'002C' | X'0008' | Supplied length insufficient
X'002C' | X'0009' | Incomplete structure supplied
X'002C' | X'000A' | Incomplete FMH5 supplied
X'002C' | X'000B' | Incomplete GDS variable supplied
X'002C' | X'000C' | Zero EXIT field
X'002C' | X'000D' | Zero ECB field
X'002C' | X'000E' | Request invalid for address space
X'002C' | X'000F' | Control block invalid
X'002C' | X'0010' | Invalid data address or length
X'002C' | X'0011' | Previous macroinstruction outstanding
X'002C' | X'0012' | Buffer list length invalid
X'002C' | X'0013' | No corresponding mode in LM table
X'002C' | X'0014' | Invalid BIND parameters
X'002C' | X'0015' | Invalid TPN
X'002C' | X'0016' | No corresponding LU in LM table
X'002C' | X'0017' | Invalid mode specified
X'002C' | X'0018' | Invalid limit specified
X'002C' | X'0019' | SNASVCMG mode already initialized
X'002C' | X'001A' | All modes specified on single session LU
X'002C' | X'001B' | SNASVCMG or CPSVCMG mode for single session LU
X'002C' | X'001C' | Single session, mode already initialized
X'002C' | X'001E' | CID invalid
X'002C' | X'001F' | APPCCMD issued for non-APPC
X'002C' | X'0020' | Previous REJECT request outstanding
X'002C' | X'0021' | Abnormal deallocate rejected; retry
X'002C' | X'0022' | Invalid CONTROL or QUALIFY value
X'002C' | X'0023' | Invalid session instance identifier
X'002C' | X'0024' | PS header not supplied
X'002C' | X'0025' | PS header length is insufficient
X'002C' | X'0026' | Session instance identifier and conversation identifier mismatch
X'002C' | X'0027' | Invalid deactivation type code
X'002C' | X'0028' | Cryptography not allowed on mode
X'002C' | X'0029' | Invalid LIST value specified on APPCCMD for restore
X'002C' | X'002A' | Invalid CGID value specified
X'002C' | X'002B' | Network-qualified name required
X'002C' | X'002C' | Parameter error; invalid expedited data length
X'002C' | X'002D' | Parameter error; invalid sense code value specified
X'002C' | X'002E' | Vector area not valid
X'002C' | X'002F' | Vector area length insufficient
X'002C' | X'0030' | Parameter error; storage type not valid
X'002C' | X'0031' | Parameter error; SENDRCV specified with OPTCD=BUFFLST/XBUFLST
X'002C' | X'0032' | Parameter error; unexpected vector provided on APPCCMD
X'002C' | X'0033' | Parameter error; required vector not provided or incorrect
X'002C' | X'0034' | Password substitution value set in error
X'0030' | X'0000' | Program error; no truncation
X'0034' | X'0000' | Program error purging
X'0038' | X'0000' | Program error truncating
X'003C' | X'0000' | Service error; no truncation
X'0040' | X'0000' | Service error purging
X'0044' | X'0000' | Service error truncating
X'0048' | X'0000' | Resource failure; no retry
X'004C' | X'0000' | Resource failure; retry
X'0050' | X'0000' | State error
X'0054' | X'0000' | Unrecognized mode name
X'0058' | X'0000' | Unsuccessful; session not available
X'005C' | ALL | User error code received
X'005C' | X'0000' | Following negative response
X'005C' | X'0001' | Without negative response
X'0060' | X'0000' | No FMH5 available
X'0064' | X'0000' | Activation failure
X'0068' | X'0000' | LU mode session limit exceeded
X'006C' | X'0000' | Session not pending
X'0070' | X'0000' | Temporary storage shortage or resource shortage
X'0074' | X'0000' | Halt issued
X'0078' | X'0000' | VTAM inactive for your ACB
X'007C' | X'0000' | Request aborted
X'0080' | X'0000' | Deallocate normal
X'0084' | X'0000' | Storage shortage
X'0088' | X'0000' | Canceled by reject or abnormal deallocate
X'008C' | X'0000' | Partner committed protocol violation
X'0090' | X'0000' | Application not APPC capable
X'0094' | X'0000' | Invalid condition for sending data
X'0098' | X'0000' | Temporary storage shortage while sending data
X'009C' | X'0000' | Restore rejected - restore issued before SETLOGON start
X'00A0' | ALL | Request not allowed
X'00A0' | X'0001' | LU pair does not support sending expedited data
X'00A0' | X'0002' | Request blocked
X'00A0' | X'0003' | Execution of request terminated
X'00A0' | X'0004' | CONTROL/QUALIFY value invalid for full-duplex conversation
X'00A0' | X'0005' | Response has not been received for a previous SENDEXPD request
X'00A0' | X'0006' | Program not authorized for requested function
X'00A4' | X'0000' | Mode must be restored before using
X'00A8' | ALL | Environment error
X'00A8' | X'0000' | OS level does not support request function
X'00A8' | X'0001' | Suspend failure
X'00A8' | X'0002' | Resume failure
X'00AC' | ALL | Error indication received
X'00AC' | X'0001' | Deallocate abend program
X'00AC' | X'0002' | Deallocate abend service
X'00AC' | X'0003' | Deallocate abend time
X'00AC' | X'0004' | Allocation error
X'00AC' | X'0005' | Unknown error code
X'00AC' | X'0006' | Resource failure; retry
X'00AC' | X'0007' | Resource failure; no retry
X'00B0' | ALL | Name resolution error
X'00B0' | X'0001' | LU name found in a variant name entry
X'00B0' | X'0002' | Name returned differs from associated name
X'00B0' | X'0003' | Name returned found in variant name entry
X'00B0' | X'0004' | Name returned found in supplied name entry
X'00B0' | X'0005' | Partner network name mismatch
X'00B0' | X'0006' | LU name found in an unusable name entry
X'00B0' | X'0007' | Name returned found in an unusable name entry
X'00B0' | X'0008' | LU name found in a disassociated name entry
X'00B4' | ALL | CSM detected error
X'00B4' | X'0001' | CSM detected error - not specified
X'00B4' | X'0002' | CSM detected error - invalid buffer token specified
X'00B4' | X'0003' | CSM detected error - invalid instance id specified
Parent topic: LU6.2 Diagnostic Information


Mainframe Access Host Error Codes

The return code and reason code values documented in the following table may appear in error responses sent from Mainframe Access to client products.

Return Code | Reason Code | Explanation | Action
X'00000008' | X'00000001' | XERROR_ALLOC The LU6.2 session allocation failed. | Check the target DB2 APPLID or MODNAME.
X'00000008 | X'00000002' | XERROR_ALLOC The LU6.2 session allocation failed without a conversation block. | Check the APPLID and MODNAME for the target DB2.
X'00000009' | X'00000001' | XERROR_INVALIDPACKET An invalid packet type; the correct packet is an allocation packet. | Check the client program.
X'00000009' | X'00000002' | XERROR_INVALIDPACKET An invalid packet type; the correct packet is a dellocation data packet. | Contact our Product Support.
X'00000010' | X'FFFFFFFF' | XERROR_SEND The maximum number of concurrent users was reached. | Contact a Micro Focus sales representative to purchase more seats for your license.
X'00000011' | X'00000001' | XERROR_RECEIVE The LU6.2 session failed in the receive mode. | Contact our Product Support.
X'00000013' | X'00000001' | XERROR_FUNCTIONNOTALLOWED The IMS/VSAM access feature is not available at your site. | Contact a Micro Focus sales representative to purchase a license for this feature.
X'00000013' | X'00000002' | XERROR_FUNCTIONNOTALLOWED The PEM feature is not available at your site. | Contact a Micro Focus sales representative to purchase a license for this feature.
X'00000014' | X'00000001' | XERROR_INVALIDTRAN The transaction type in the first packet is invalid. | Contact our Product Support.
X'00000015' | X'00000001' | XERROR_CONV The LU6.2 session lost the conversation control block. | Contact our Product Support.
X'00000017' | X'00000rpl' | XERROR_SENDRPL The LU6.2 session failed with the RPL code in the reason code block. | Contact our Product Support.
X'00000018' | X'00000rpl' | XERROR_RECEIVERPL The LU6.2 session failed in receive mode with the RPL code in the reason code block. | Contact our Product Support.
X'00000100' | X'00000100' | XERROR_INTERNAL Unknown request type. | Contact our Product Support.
Parent topic: Troubleshooting


Mainframe Access Remote IMS Error Codes

Return Code | Reason Code | Description of Cause | Action
400 | Bad request type | TYPE=ALLOCERR: Request type is invalid | The first packet's request type must be ALLOC. Resubmit an ALLOC packet.
400 | Bad request, ID block is missing | TYPE=ALLOCERR: Mainframe Access does not have the configuration for the IMSID | Check the IMSID and resubmit.
505 | Version not supported | TYPE=ALLOCERR: The client is not supported by Mainframe Access | Contact our Product Support.
602 | IMS Applid is not valid | TYPE=ALLOCERR: Either IMS is not available or IMS/APPC is not enabled. | Contact our Product Support.
604 | IMS Alloc Failure, RC = rc | TYPE=ALLOCERR: Routine failed to initiate a conversation with the target IMS system. rc is the decimal number of the return code from VTAM. | Contact our Product Support.
606 | Receive Error | TYPE=RPL,CODE=rc: Conversation to IMS has failed during a receive operation with RPL code. rc is the return code. The first two bytes are the RPL primary code; the next two bytes are the RPL secondary code. | Check the entries, correct any errors, and resubmit request.
606 | Send Error | TYPE=RPL,CODE=rc: Conversation to IMS has failed during a send operation with RPL code. The first two bytes are the RPL primary code; the next two bytes are the RPL secondary code. | Check the entries, correct any errors, and resubmit request.
606 | LU6.2 Error | TYPE=RPL,CODE=rc: Conversation to IMS has failed with RPL code. The first two bytes are the RPL primary code; the next two bytes are the RPL secondary code. | Check the entries, correct any errors, and resubmit request.
613 | Userid/Password Required | TYPE=ALLOCERR: Security is enforced in the configuration and user ID or password in the request packet is missing. | Check and correct user ID and password and resubmit request packet.
699 | Mainframe Access HTTP Parsing Error | TYPE=ALLOCERR: The input HTTP packet has invalid record or format. | Check the record or format of the HTTP packet and resubmit.
Parent topic: Troubleshooting


IBM SAF and RACF Error Codes

The return code and reason code values documented in the following table may appear in error messages associated with z/OS security subsystem request failures.

  • Error Codes for VERIFY Requests
  • Error Codes for AUTH Requests
Parent topic: Troubleshooting


Error Codes for VERIFY Requests

The return code and reason code values documented in the following table are associated with RACROUTE REQUEST=VERIFY requests that are issued to authenticate a user based on the userid and password that were submitted.

SAF Return Code | RACF Return Code | RACF Reason Code | Description
X'00' | X'00' | X'0000' | Request completed successfully.
X'00' | X'04' | X'000C' | Request completed successfully. TOKNIN was specified but the length was too large.
X'00' | X'04' | X'0010' | Request completed successfully. STOKEN was specified but the length was too large.
X'04' | X'00' | X'0000' | Request could not be completed. No RACF decision was possible. ENVIR=VERIFY was specified without SAF installation exit processing.
X'04' | X'04' | X'0000' | Request could not be completed. No RACF decision was possible. The user profile is not defined to RACF.
X'04' | X'20' | X'0000' | Request could not be completed. No RACF decision was possible. RACF is not active.
X'04' | X'58' | X'0000' | Request could not be completed. No RACF decision was possible. RJE or NJE operator FACILITY class profile not found.
X'08' | X'04' | X'0000' | Request failed. The user profile is not defined to RACF.
X'08' | X'08' | X'0000' | Request failed. The password is not authorized.
X'08' | X'0C' | X'0000' | Request failed. The password has expired.
X'08' | X'10' | X'0000' | Request failed. The new password is not valid.
X'08' | X'14' | X'0000' | Request failed. The user is not defined to the group.
X'08' | X'18' | X'0000' | Request failed. RACROUTE REQUEST=VERIFY was failed by the installation exit routine.
X'08' | X'1C' | X'0000' | Request failed. The user's access has been revoked.
X'08' | X'24' | X'0000' | Request failed. The user's access to the specified group has been revoked.
X'08' | X'28' | X'0000' | Request failed. OIDCARD parameter is required but not supplied.
X'08' | X'2C' | X'0000' | Request failed. OIDCARD parameter is not valid for specified user.
X'08' | X'30' | X'0000' | Request failed. The user is not authorized to the port of entry in the TERMINAL, JESINPUT, or CONSOLE class. Indicates the user is not authorized to the port of entry.
X'08' | X'30' | X'0004' | Request failed. The user is not authorized to the port of entry in the TERMINAL, JESINPUT, or CONSOLE class. Indicates the user is not authorized to access the system on this day, or at this time of day.
X'08' | X'30' | X'0008' | Request failed. The user is not authorized to the port of entry in the TERMINAL, JESINPUT, or CONSOLE class. Indicates the port of entry may not be used on this day, or at this time of day.
X'08' | X'34' | X'0000' | Request failed. The user is not authorized to use the application.
X'08' | X'38' | X'0004' | Request failed. SECLABEL checking failed. MLACTIVE requires a SECLABEL; none was specified.
X'08' | X'38' | X'0008' | Request failed. SECLABEL checking failed. Indicates the user is not authorized to the SECLABEL.
X'08' | X'38' | X'000C' | Request failed. SECLABEL checking failed. The system was in a multilevel secure status, and the dominance check failed.
X'08' | X'38' | X'0010' | Request failed. SECLABEL checking failed. Neither the user's nor the submitter's SECLABELs dominate. They are disjoint.
X'08' | X'44' | X'0000' | Request failed. A default token is used as input token.
X'08' | X'48' | X'0000' | Request failed. Indicates that an unprivileged user issued a RACROUTE REQUEST=VERIFY in a tranquil state (MLQUIET).
X'08' | X'4C' | X'0000' | Request failed. NODES checking failed. Submitter's node is not allowed access to execution node.
X'08' | X'4C' | X'0004' | Request failed. NODES checking failed. NJE failure: UACC of NONE for USERID type of NODES profile.
X'08' | X'4C' | X'0008' | Request failed. NODES checking failed. NJE failure: UACC of NONE for GROUP type of NODES profile.
X'08' | X'4C' | X'000C' | Request failed. NODES checking failed. NJE failure: UACC of NONE for SECLABEL type of NODES profile.
X'08' | X'4C' | X'0010' | Request failed. NODES checking failed. NJE failure: No local submit node specified.
X'08' | X'4C' | X'0014' | Request failed. NODES checking failed. NJE failure: Reverification of translated values failed.
X'08' | X'50' | X'0004' | Request failed. Indicates that a surrogate submit attempt failed. Indicates the SURROGAT class was inactive.
X'08' | X'50' | X'0008' | Request failed. Indicates that a surrogate submit attempt failed. Indicates the submitter is not permitted by the user's SURROGAT class profile.
X'08' | X'50' | X'000C' | Request failed. Indicates that a surrogate submit attempt failed. Indicates that the submitter is not authorized to the SECLABEL under which the job is to run.
X'08' | X'54' | X'0000' | Request failed. Indicates that a JESJOBS check failed.
X'08' | X'64' | X'0000' | Request failed. Indicates that the CHECK subparameter of the RELEASE keyword was specified on the execute form of the RACROUTE REQUEST=VERIFY macro; however, the list form of the macro does not have the same release parameter. Macro processing terminates.
Parent topic: IBM SAF and RACF Error Codes


Error Codes for AUTH Requests

The return code and reason code values documented in the following table are associated with RACROUTE REQUEST=AUTH requests. AUTH requests are issued to check the authorization of an already verified user to access a protected resource. The most common use of AUTH is to check if a user is authorized to access a specific data set.

SAF Return Code RACF Return Code RACF Reason Code Description
X'00' X'00' X'0000' Request completed successfully.

The user is authorized by RACF to obtain use of a RACF-protected resource.

X'00' X'00' X'0004' Request completed successfully.

The user is authorized by RACF to obtain use of a RACF-protected resource. Indicates one of the following:

  • STATUS=ERASE was specified and the data set is to be erased when scratched
  • the warning status of the resource was requested by the RACROUTE REQUEST=AUTH issuer's setting bit X'10' at offset 12 decimal in the request-specific portion of the RACROUTE REQUEST=AUTH parameter list with the resource in warning mode.
X'00' X'00' X'0010' Request completed successfully.

The user is authorized by RACF to obtain use of a RACF-protected resource. When CLASS=TAPEVOL, indicates the TAPEVOL profile contains a TVTOC.

X'00' X'00' X'0020' Request completed successfully.

The user is authorized by RACF to obtain use of a RACF-protected resource. When CLASS=TAPEVOL, indicates that the TAPEVOL profile can contain a TVTOC, but currently does not (for a scratch pool volume).

X'00' X'00' X'0024' Request completed successfully.

The user is authorized by RACF to obtain use of a RACF-protected resource. When CLASS=TAPEVOL, indicates that the TAPEVOL profile does not contain a TVTOC.

X'00' X'14' X'00XX' Request completed successfully.

Requested function with STATUS=ACCESS specified has completed successfully. The user's highest access to the specified resource is indicated by one of the following reason codes:

  • 00

    The user has no access.

  • 04

    The user has READ authority.

  • 08

    The user has UPDATE authority.

  • 0C

    The user has CONTROL authority.

  • 10

    The user has ALTER authority.

X'04' X'00' X'0000' Request could not be completed.

No RACF decision was possible. No security decision could be made. RACF is not installed -or- the specified requester, subsystem, or class is not in the RACF router table -or- the specified class is not in the RACF class descriptor table.

X'04' X'04' X'0000' Request could not be completed. No RACF decision was possible.

The specified resource is not protected by RACF.

Note: Note:

If PROTECTALL is active, no profile is found, and the user ID whose authority was checked does not have the SPECIAL attribute, RACF returns a return code X'08' instead of a return code X'04' and denies access.

One of the following has occurred:

  • There is no RACF profile protecting the resource
  • RACF is not active
  • Specified class is not active
  • Specified class requires SETROPTS RACLIST option to be active and it is not.
  • CLASS TEMPDSN was active and the dataset is a temporary dataset.
X'04' X'04' X'0004' Request could not be completed.

No RACF decision was possible. The specified resource is not protected by RACF.

Indicates STATUS=ERASE was specified and the data set is to be erased when scratched.

X'08' X'08' X'0000' Request failed. The user is not authorized by RACF to obtain use of the specified RACF-protected resource.

Indicates a normal completion. A possible cause would be PROTECTALL is active, no profile is found, and the user ID whose authority was checked does not have the SPECIAL attribute.

X'08' X'08' X'0004' Request failed. The user is not authorized by RACF to obtain use of the specified RACF-protected resource.

Indicates STATUS=ERASE was specified and the data set is to be erased when scratched.

X'08' X'08' X'0008' Request failed. The user is not authorized by RACF to obtain use of the specified RACF-protected resource.

Indicates DSTYPE=T or CLASS=TAPEVOL was specified and the user is not authorized to use the specified volume.

X'08' X'08' X'000C' Request failed. The user is not authorized by RACF to obtain use of the specified RACF-protected resource.

Indicates the user is not authorized to use the data set.

X'08' X'08' X'0010' Request failed. The user is not authorized by RACF to obtain use of the specified RACF-protected resource.

Indicates DSTYPE=T or CLASS=TAPEVOL was specified and the user is not authorized to specify TAPELBL=(,BLP).

X'08' X'08' X'0014' Request failed. The user is not authorized by RACF to obtain use of the specified RACF-protected resource.

Indicates the user is not authorized to open a non-cataloged data set.

X'08' X'08' X'0018' Request failed. The user is not authorized by RACF to obtain use of the specified RACF-protected resource.

Indicates the user is not authorized to issue RACROUTE REQUEST=AUTH when system is in tranquil state (MLQUIET).

X'08' X'08' X'001C' Request failed. The user is not authorized by RACF to obtain use of the specified RACF-protected resource.

A user with EXECUTE authority to the data set profile specified ATTR=READ, and RACF failed the access attempt.

X'08' X'08' X'0020' Request failed. The user is not authorized by RACF to obtain use of the specified RACF-protected resource.

The user's security label does not dominate that of the resource; it fails SECLABEL authorization checking.

X'08' X'08' X'0024' Request failed. The user is not authorized by RACF to obtain use of the specified RACF-protected resource.

The user's security label can never dominate that of the resource.

X'08' X'08' X'0028' Request failed. The user is not authorized by RACF to obtain use of the specified RACF-protected resource.

The resource must have a security label, but does not have one.

X'08' X'0C' X'0000' Request failed.

The OLDVOL specified was not part of the multivolume data set defined by VOLSER, or it was not part of the same tape volume defined by ENTITY.

X'08' X'10' X'00XX' Request failed.

RACROUTE REQUEST=VERIFY was issued by a third party, and RACROUTE REQUEST=AUTH failed. The reason code 00XX value is the RACF return code from the RACROUTE REQUEST=VERIFY.

X'08' X'64' X'0000' Request failed.

Indicates that the CHECK subparameter of the RELEASE keyword was specified on the execute form of the RACROUTE REQUEST=AUTH macro; however, the list form of the macro does not have the same RELEASE parameter. Macro processing terminates.

Parent topic: IBM SAF and RACF Error Codes


Mainframe Access Audit Report Program

Mainframe Access' optional audit log feature records client logon and logoff information to a VSAM data set. For a description of how to allocate the audit log data set and enable the recording see the section Allocating and Initializing an Audit Log Data Set in the chapter Configuration. Mainframe Access also provides a batch reporting program to list the audit log records. This section describes the use of the audit log report program.

  • Running the Audit Report Program
  • Audit Report Abend Codes
  • Audit Report Diagnostic Messages
Parent topic: Troubleshooting
Related information
Allocating and Initializing an Audit Log Data Set


Running the Audit Report Program

Member AUDRPT in the Mainframe Access <hlq>.CNTL data set is a sample job for running the audit report program. Customize this job with a valid JOB card and the correct data set qualifier for your installation. The sample member is shown below.

//MFASETUP JOB (MFA),'RUN AUDIT REPORT',CLASS=A,MSGCLASS=A
//*
//AUDITRPT PROC DSNQUAL='HLQ'
//*
//*------------------------------------------------------------------*
//*                                                                  *
//* Micro Focus Mainframe Access - Run the Audit Log Report          *
//*                                                                  *
//* Change the DSNQUAL value on the PROC statement to the correct    *
//* value for your installation.                                     *
//*------------------------------------------------------------------*
//*
//*------------------------------------------------------------------*
//* Step 1: Run the audit report utility to list the records in the  *
//*         audit log dataset.                                       *
//*------------------------------------------------------------------*
//*
//AUDITRPT EXEC PGM=AUDITRPT,REGION=0M
//STEPLIB  DD   DSN=&.DSNQUAL..LOADLIB,DISP=SHR
//AUDITIN  DD   DSN=&.DSNQUAL..AUDIT,DISP=SHR
//SYSPRINT DD   SYSOUT=*
//SYSTERM  DD   SYSOUT=*
//SYSUDUMP DD   SYSOUT=*
//         PEND
//AUDITRPT EXEC AUDITRPT

When you have customized the job, submit it for execution. A report similar to the following is written to a SYSOUT data set.

                                                            Audit Log Report

  Report date and time: FRI JUL 25 16:37:57 2003

  Audit data set: <hlq>.AUDIT

  Type     Record    Sess  User      IP Address       Partner    Date+Time                Type of
  of       Sequence  ID    ID                         LU                                  Encryption used (see note)
  Record

  Logoff        1    00000 CSIRLW2   10.24.11.15      MFADIR     FRI JUL 25 16:02:51 2003
  Logoff        3    00000 CSIRLW1   10.24.11.15      MFADIR     FRI JUL 25 16:03:33 2003
  Logoff        5    00000                                       FRI JUL 25 16:04:22 2003 N
  Logoff       10    00000                                       FRI JUL 25 16:35:48 2003 N
  Logon         0    00001 CSIRLW2   10.24.11.15      MFADIR     FRI JUL 25 16:02:27 2003
  Logon         2    00002 CSIRLW1   10.24.11.15      MFADIR     FRI JUL 25 16:03:20 2003
  Logon         4    00003 CSIRLW1   10.24.11.15      LUDB27R    FRI JUL 25 16:03:59 2003 P
  Logon         6    00004           10.24.11.15      CICSTSR7   FRI JUL 25 16:34:32 2003 N
  Logon         7    00005           10.24.11.15      CICSTSR6   FRI JUL 25 16:34:33 2003 N
  Logon         8    00006           10.24.11.15      CICSTSR3   FRI JUL 25 16:34:34 2003 N
  Logon         9    00007 CSIRLW1   10.24.11.15      IMS6PPC    FRI JUL 25 16:35:42 2003 N

  Note: Encryption values   N = None, P = Password, X = Packet encryption, C = Compression is in use

  Total type 0 records =         11
  Total logon records  =          7
  Total logoff records =          4
Parent topic: Mainframe Access Audit Report Program


Audit Report Abend Codes

The following table lists the user abends that may be issued by the audit report program.

User Abend Code | Description of Cause | Recommended Action
1211 | This abend is issued when a GETMAIN request fails. A console message is also issued to indicate the failure condition. A program dump is not requested. | Increase the region size for the audit report program. If the problem persists contact our Product Support.
Parent topic: Mainframe Access Audit Report Program


Audit Report Diagnostic Messages

The following messages may be issued by the audit report program when error conditions occur.

AUD0001E: DDNAME xxxxxxxx WAS NOT FOUND

This message appears when either the SYSPRINT or AUDITIN DD statements are missing. Add the missing DD statements to the JCL for the job.

AUD0002E: OPEN FAILED FOR xxxxxxxx FILE

This message appears when either SYSPRINT or AUDITIN fails to open. Examine associated system error messages to determine the reason for the failure.

AUD0003E: VSAM ACB FAILED FOR xxxxxxxx
AUD0003E: RETURN CODE IS xxxxxxxx
AUD0003E: REASON CODE IS xxxxxxxx

These messages appear when a critical error occurs while accessing the AUDITIN VSAM data set. The program terminates with the return code 16. Examine any associated system error messages and the VSAM return code and reason code values to determine the reason for the failure.

Parent topic: Mainframe Access Audit Report Program


Obtaining a VTAM Buffer Trace

During the process of resolving a problem, our Product Support may require you to obtain and submit a VTAM buffer trace (and possibly other VTAM trace data). This section describes how to use IBM's Generalized Trace Facility (GTF) to capture the relevant data.

The procedure for gathering the trace is as follows:

  1. Make sure that Mainframe Access, the clients and the target servers are all ready and at a point where you want to start tracing. For example, if the problem is associated with a specific CICS Option distributed transaction, bring the client up to the point where the transaction will be issued.
  2. Start GTF (see the section Starting GTF)
  3. Activate the VTAM trace (see the section Activating the VTAM Trace)
  4. Perform the activity that you want to trace (for example, run the transaction that fails)
  5. Deactivate the VTAM trace (see the section Deactivating the VTAM Trace)
  6. Stop GTF (see the section Stopping GTF)
  7. Package the raw GTF trace data set for transmission to our Product Support.
  8. Use the File Transfer Protocol (FTP) utility to send the packaged trace to Micro Focus. Use binary mode for the transfer.
  • Starting GTF
  • Activating the VTAM Trace
  • Deactivating the VTAM Trace
  • Stopping GTF
  • Formatting VTAM GTF Trace Records
  • Obtaining an SVC Dump of Mainframe Access
  • Packaging and Transmitting Diagnostic Data
Parent topic: Troubleshooting
Related information
Starting GTF
Activating the VTAM Trace
Deactivating the VTAM Trace
Stopping GTF


Starting GTF

Mainframe Access provides a sample procedure, MFAGTF, for running GTF; its use is described in the section Adding the GTF Procedure to a System Procedure Library in the chapter Configuration. You may want to pre-allocate a permanent GTF trace data set on DASD that can be reused each time you start MFAGTF. If you do so, update the MFAGTF procedure to use this data set.

A PDS member is normally used to automate the specification of GTF options when GTF is started and the sample procedure uses parameters from another sample member, GTFCNTL. This sample is set up to start GTF for recording Mainframe Access' activity trace (USR '0E9' records) and VTAM's buffer trace (USR 'FEF' and 'FF1' records).

A sample system log for the startup of GTF is shown below. Remember to have Mainframe Access and other software components that are part of the tracing activity already running, connected and ready to go, if possible.

  S MFAGTF.MYGTF
  $HASP100 MFAGTF   ON STCINRDR
  IEF695I START MFAGTF WITH JOBNAME MFAGTF IS ASSIGNED TO USER RWITEK, GROUP CSIDVLP
  $HASP373 MFAGTF   STARTED
  IEF403I MFAGTF - STARTED - TIME=16.34.12
  AHL121I  TRACE OPTION INPUT INDICATED FROM MEMBER GTFCNTL  OF PDS
  <hlq>.CNTL
  TRACE=USRP
  USR=(FF1,FEF,0E9)
  END
  AHL103I  TRACE OPTIONS SELECTED --USR=(FEF,FF1,0E9)
  AHL906I THE OUTPUT BLOCK SIZE OF    27998 WILL BE USED FOR OUTPUT 997
          DATA SETS:
            <hlq>.TRACE
  AHL080I GTF STORAGE USED FOR GTF DATA: 998
          GTFBLOCK STORAGE       82K BYTES (BLOK=        40K)
          PRIVATE STORAGE      1038K BYTES
          SADMP HISTORY          54K BYTES (SADMP=       40K)
          SDUMP HISTORY          54K BYTES (SDUMP=       40K)
          ABEND DUMP DATA         0K BYTES (ABDUMP=       0K)
  AHL031I GTF INITIALIZATION COMPLETE

GTF is now up and running and ready to record type 'FEF' and 'FF1' records from VTAM. z/OS may also force some USR records into the trace data set for system components. GTF wraps trace data when writing trace records to a DASD data set. This means that you can leave GTF tracing on for a long time to catch an intermittent problem, then stop the trace soon after the problem occurs. However, if you do not stop the trace soon after the problem occurs, the trace data that you collected may be overwritten by trace data from other system components.

Parent topic: Obtaining a VTAM Buffer Trace
Related information
Adding the GTF Procedure to a System Procedure Library


Activating the VTAM Trace

When you are ready to perform an action that you want to trace, activate the VTAM buffer trace for the Mainframe Access ACB. You do this using a z/OS Modify command to VTAM. In this example the VTAM JCL procedure name is VTAM. The name may be different on your z/OS system. The only other thing you may want to change is the ID= parameter so that it specifies the name of your Mainframe Access VTAM ACB.

  F VTAM,TRACE,TYPE=BUF,ID=MFM62ACB,AMOUNT=FULL
  IST097I MODIFY ACCEPTED
  IST1515I BUFFER TRACE ACTIVE
  IST1144I TRACE INITIATED FOR DDINET1.MFM62ACB 316
  IST1045I NODE TYPE = APPL
  IST314I END

GTF should now be up and running and VTAM should be creating TYPE=BUF trace records for any activity associated with MFM62ACB. If someone has previously started a TYPE=BUF trace for another VTAM resource and did not bother to stop the trace, these records may also appear in the trace data set and complicate the analysis of what you are tracing.

Parent topic: Obtaining a VTAM Buffer Trace


Deactivating the VTAM Trace

When you have finished performing the activity to be traced, turn off the VTAM TYPE=BUF trace for the Mainframe Access ACB. Use the z/OS Modify command as follows:

  F VTAM,NOTRACE,TYPE=BUF,ID=MFM62ACB
  IST097I MODIFY ACCEPTED
  IST1143I TRACE TERMINATED FOR DDINET1.MFM62ACB 349
  IST1045I NODE TYPE = APPL
  IST314I END
Parent topic: Obtaining a VTAM Buffer Trace


Stopping GTF

Stop the GTF process using the z/OS Stop (P) command. In this example GTF was started using "S MFAGTF.MYGTF" where the .MYGTF is assigned as an identifier for the GTF process that is then specified in the Stop command.

  P MYGTF
  AHL006I GTF ACKNOWLEDGES STOP COMMAND
  AHL904I THE FOLLOWING TRACE DATASETS CONTAIN TRACE DATA : 353
            <hlq>.TRACE
  IEF404I MFAGTF - ENDED - TIME=11.48.15
  $HASP395 MFAGTF   ENDED
  $HASP250 MFAGTF PURGED -- (JOB KEY WAS B5A444E4)

The trace data set, <hlq>.TRACE in this example, now has the raw GTF data.

Parent topic: Obtaining a VTAM Buffer Trace


Formatting VTAM GTF Trace Records

There may be times when you need, or want, to examine the GTF trace data. In this case, the raw data collected by GTF needs to be processed by a formatting program such as IBM's Interactive Problem Control System (IPCS). You can run IPCS either using a TSO command under ISPF or as a batch job. To run IPCS you need an IPCS dump directory VSAM data set. If you do not already have a dump directory, you can allocate one using a job similar to the following.

//jobname JOB (accounting),'name',CLASS=?,MSGCLASS=?,NOTIFY=userid
//--------------------------------------------------------------------
//* Allocate an IPCS dump directory VSAM data set
//--------------------------------------------------------------------
//IDCAMS   EXEC PGM=IDCAMS
//SYSPRINT DD   SYSOUT=*
 DELETE <hlq>.DIR
 DEFINE CLUSTER (NAME(<hlq>.DIR)                -
                SHAREOPTIONS(1)                 -
                RECSZ(256 3072)                 -
                KEYS(128 0)                     -
                VOLUMES(volser)
          INDEX (NAME(<hlq>.DIRINDEX)           -
                TRK(15 5))                      -
          DATA  (NAME(<hlq>.DIRDATA)            -
                CYLINDERS(5 1)                  -
                CISZ(X'1000'))

This example JCL runs IPCS to print all 'FEF' and 'FF1' records from the GTF trace data set.

//jobname JOB (accounting),'name',CLASS=?,MSGCLASS=?,NOTIFY=userid
//--------------------------------------------------------------------
//* Run IPCS batch to print GTF trace records
//--------------------------------------------------------------------
//IPCSBAT  EXEC PGM=IKJEFT01,DYNAMNBR=20,REGION=0M
//IPCSDDIR DD DSN=<hlq>.DIR,DISP=SHR
//IPCSPRNT DD SYSOUT=*
//TRACE    DD DSN=<hlq>.TRACE,DISP=SHR
//SYSTSPRT DD SYSOUT=*
//SYSTSIN  DD *
 IPCS NOPARM
 DROPDUMP DDNAME(TRACE)
 SETDEF DDNAME(TRACE) NOCONFIRM
 GTFTRACE DDNAME(TRACE),USR(FEF,FF1),TERMINAL,NOPRINT
 END
Parent topic: Obtaining a VTAM Buffer Trace


Obtaining an SVC Dump of Mainframe Access

During the process of resolving a problem, our Product Support may require you to obtain and submit a dump of the Mainframe Access address space. This section describes how to use IBM's DUMP command to create the dump data set. Using the following procedure, you can obtain a dump without stopping or canceling the Mainframe Access address space.

The procedure for creating the dump is as follows:

  1. Issue the DUMP command
  2. Respond to the DUMP command options request
  3. Package the dump data set for transmission to our Product Support
  4. Use the File Transfer Protocol (FTP) utility to send the packaged dump to Micro Focus. Use binary mode for the transfer.

The following example shows a DUMP command and the response to the request for operands in bold face. You use the COMM parameter of the DUMP command to specify a meaningful title for the dump. The operands specified in the sample reply, SDATA=(RGN,LSQA,PSA,SUM,SWA,TRT,CSA,LPA), are normally needed for any Mainframe Access dump; you should specify them as shown. Technical support may request additional, or different, options for a specific problem. After the options have been entered it will take the system anywhere from a few seconds to a few minutes to complete the dump. The IEA611I COMPLETE DUMP message indicates successful completion of the command and it identifies the dump data set that needs to be saved and packaged up for transmission. In this example, the system has created data set SYS1.CSIA.DMP00032 to contain the dump data.

  DUMP COMM=(MFA DUMP JULY 28 2003)
  *63 IEE094D SPECIFY OPERAND(S) FOR DUMP COMMAND
  R 63,JOBNAME=MFA,SDATA=(RGN,LSQA,PSA,SUM,SWA,TRT,CSA,LPA)
   IEE600I REPLY TO 63 IS;JOBNAME=MFA,SDATA=(RGN,LSQA,PSA,SUM,SWA,TRT
   IEA794I SVC DUMP HAS CAPTURED: 138
   DUMPID=032 REQUESTED BY JOB (*MASTER*)
   DUMP TITLE=MFA DUMP JULY 28 2003
   IEF196I IGD100I 0309 ALLOCATED TO DDNAME SYS00036 DATACLAS (        )
   IEF196I IEF285I   SYS1.CSIA.DMP00032                           CATALOGED
   IEF196I IEF285I   VOL SER NOS= DUMP01.
   IEA611I COMPLETE DUMP ON SYS1.CSIA.DMP00032 142
   DUMPID=032 REQUESTED BY JOB (*MASTER*)
   FOR ASID (00A5)
   INCIDENT TOKEN: ROCKPLEX CSIA     07/28/2003 21:56:11
Parent topic: Obtaining a VTAM Buffer Trace


Packaging and Transmitting Diagnostic Data

This section provides suggestions and guidelines that will help if you need to send diagnostic data to our Product Support. When you need to send relatively small amounts of text data (for example, short Mainframe Access activity traces, parameter settings, excerpts from the system log, excerpts from a dump listing, etc.), it is often convenient to simply include the text in an email or as a text file attachment to an email. Large amounts of data and non-textual information should be packaged and transmitted as described in the following paragraphs.

After gathering large amounts of diagnostic data (for example, SVC dumps, GTF traces, Mainframe Access activity traces, system log contents, etc.), the most expedient way to send the information is using the TCP/IP File Transfer Protocol (FTP) utility. Before you send the data, it is good practice to package the data for transmission. This will reduce transmission time by compressing the data and it will facilitate the handling of data when it is received.

Our Product Support can accommodate data that is packaged using the TSO Interactive Data Transmission Facility (the TSO XMIT and RECEIVE commands) or data that is packaged using IBM's TRSMAIN program (the terse utility). Mainframe Access sample TSOXMIT provides a job that demonstrates the use of TSO XMIT to package a data set for transmission. If you want to use TRSMAIN, we recommend that you start by asking the z/OS systems programming staff at your company if TRSMAIN is already installed and available for use. If it is not, you can download the IBM TRSMAIN program from the ftp.software.ibm.com Web site using FTP. You can access the download using the anonymous user ID with your email address provided as the password. Use change directory commands to locate the TRSMAIN downloads in /s390/mvs/tools/packlib at this IBM ftp site. You should find a single binary file and both plain text and HTML explanations of the procedure for installing the utility.

When your data is ready for transmission, our Product Support can provide additional instructions for sending your data to the ftp.microfocus.com site. This may include specific directory locations, filenames, etc. that should be used. After you have transferred the data, please send a follow-up email to your support representative. This note should list the files that you have sent, the packaging tool(s) that you have used, and the z/OS data set characteristics of both the packaged files and the data sets that will be created when the packages are opened. The z/OS data set characteristics should include the RECFM, LRECL, BLKSIZE, primary space allocation and secondary space allocation.

Parent topic: Obtaining a VTAM Buffer Trace


Customizing Data Connect

This section describes advanced configuration for the Mainframe Access Data Connect server.

  • Introduction
  • Samples for Configuration
  • JCL Change for Data Connect
  • Customizing the FSTAB Mapping Table and - 2
Parent topic: Configuring and Administering the Mainframe


Introduction

At the completion of Mainframe Access installation and quick configuration, the Mainframe Access Data Connect server is ready to use for most Data Connect applications. This chapter will help you with the necessary customization if you need to change the default user verification and data set authorization checking. This chapter also describes how to customize a FSTAB file mapping table and the MFAVCTL file mapping data set.

Parent topic: Customizing Data Connect


Samples for Configuration

The installation procedure places several samples in the <hlq>.MFACNTL data set. If a sample is provided for a configuration task, use it as a starting point for your configuration. Usually you need to edit the sample, replacing provided information with information that is unique to your system.

The following table summarizes the samples that are provided for Mainframe Access Data Connect server.

MEMBER | DESCRIPTION
FSTAB | Assembler language macro used by the MFASFTAB sample.
MFASFTAB | Sample job and source statements for creating your own FSTAB module for file name mapping operations.
Parent topic: Customizing Data Connect


JCL Change for Data Connect

In order to supply all MFA and Data Connect function within one authorized library, the Data Connect module names have been renamed, and slightly reorganized as static load modules rather than dynamic overlays. All Data Connect load modules now begin with the prefix MFD.

//*--------------------------------------------------------------*
       //* Micro Focus Mainframe Access - Data Connect V3.10
       //*--------------------------------------------------------------*
       //MFAS EXEC PGM=MFDSTART,PARM='APPLID=MFA62ACB',
       //   REGION=0M,TIME=1440
       //STEPLIB  DD DISP=SHR,DSN=MFA31.PROD.LOADLIB
       //SYSUDUMP DD SYSOUT=*
       //FSMSGA   DD SYSOUT=*         for IDCAMS
       //FSMSGC   DD SYSOUT=*         for APPC errors
       //FSMSGL   DD SYSOUT=*         for FileShare log
       //VSAMCTL  DD DISP=SHR,DSN=MFA31.PROD.MFAVCTL
Parent topic: Customizing Data Connect


Customizing the FSTAB Mapping Table and - 2

If you wish to define the Data Connect datasets and alternate indexes to be allocated, then you need to create the DDNAME/DSNAME cross reference table, FSTAB. The MFASFTAB member in the MFACNTL data set contains a job that you can user to create the FSTAB. The cross reference table converts filenames used in SELECT clauses in your COBOL application program to MVS dataset names or ddnames. In the COBOL program, you can assign a filename directly to an MVS ddname, an MVS dataset name or an entry requiring conversion by this table. If an entry is not found in the cross reference table, an assumption is made that the COBOL SELECT clause contains an MVS dataset name and dynamic allocation is attempted.

All entries in the table are optional. The table allows the following formats:

For short term dynamic allocation - dataset is freed at close:

FSTAB  'PC-NAME',DSN=MVS-DATASET-NAME
       [,MEM=MEMBNAME]   optional for PDS member name

For long term dynamic allocation - dataset freed at termination:

FSTAB  'PC-NAME',DSN=MVS-DATASET-NAME,DDN=DDNAME
       [,MEM=MEMBNAME]   optional for PDS member name

For long term allocation - //DDNAME in start-up JCL:

FSTAB  'PC-NAME',DDN=DDNAME

VSAM allocation adding alternate indexes:

FSTAB  'PC-NAME',DSN=MVS-DATASET-NAME,                 X
       AIX=(VSAM-AIX1,VSAM-AIX2,VSAM-AIX3)
Note:

COBOL application programs must define alternate indexes in the same order as they are defined in the table.

An exception to this rule is if the name is 1-8 characters without a period. In this case the name represents a member name in the dynamic allocation control file for new datasets (MFAVCTL). This enhancement to the MFA Data Connect Server is provided to remove the FSTAB requirement when using VSAM alternate indexes. This enhancement uses members in the MFAVCTL library to create dynamic FSTAB entries for VSAM files which have alternate indexes. Each member in the MFAVCTL library defines a VSAM file and its indexes. Only one VSAM file can be specified in each member. The control records within a member are 80 bytes long and begin with a keyword followed by its value. All member names for this facility must begin with a '$' or whatever keyboard character maps to a X'5C'. The keywords are VSAM= and AIXn=, when n is a value from 1 to 9. Following VSAM= is the MVS VSAM dataset name. This record must be the first record in the member. The keywords AIX1 through AIX9 identify the alternate index PATH files. They must be specified in the same order as in the COBOL program.

For example, in the COBOL program:

FILE-CONTROL.
 SELECT CLAIM-FILE ASSIGN TO PATCLMX
        ORGANIZATION IS INDEXED
        ACCESS IS RANDOM
        RECORD KEY IS PATIENT-CLIAM-NUMBER
        ALTERNATE RECORD KEY IS MEDICARE DUPLICATES
        ALTERNATE RECORD KEY IS MEDICAID-KEY DUPLICATES
        ALTERNATE RECORD KEY IS PRIVATE-INS-KEY DUPLICATES
        ALTERNATE RECORD KEY IS PATIENT-NAME
        ALTERNATE RECORD KEY IS CONTROL-NUMBER
        ALTERNATE RECORD KEY IS PAYMENT-ID
        STATUS IS VSAM-FILE-STATUS.

As an FSTAB entry:

FSTAB 'PATCLMX',
           DSN=CSI01V.PATCLM.PATIENT.BILLING,
           AIX=(CSI01V.PATCLM.BY.MEDICARE.PATH,
           CSI01V.PATCLM.BY.MEDICAID.PATH,
           CSI01V.PATCLM.BY.INS.POLICY.PATH,
           CSI01V.PATCLM.BY.NAME.PATH,
           CSI01V.PATCLM.BY.CONTROL.PATH,
           CSI01V.PATCLM.BY.PAYMENT.PATH)

As a MFAVCTL library member:

VSAM=CSI01V.PATCLM.PATIENT.BILLING
AIX1=CSI01V.PATCLM.BY.MEDICARE.PATH
AIX2=CSI01V.PATCLM.BY.MEDICAID.PATH
AIX3=CSI01V.PATCLM.BY.INS.POLICY.PATH
AIX4=CSI01V.PATCLM.BY.NAME.PATH
AIX5=CSI01V.PATCLM.BY.CONTROL.PATH
AIX6=CSI01V.PATCLM.BY.PAYMENT.PATH

Assume that the name of the MFAVCTL member for the above control statements is $PATCLM6, then the MFEXTMAP.DAT entry would be: PATCLMX $PATCLM6. The above FSTAB and MFAVCTL member are functionally equivalent.

Parent topic: Customizing Data Connect


Configuring Access to External Library Management Systems

This section describes the Mainframe Access support for external library management systems and change management systems.

  • About External Library Management
  • Panvalet
  • Librarian
  • Endevor
  • ChangeMan ZMF
Parent topic: Configuring and Administering the Mainframe


About External Library Management

Mainframe Access provides seamless access to objects housed in repositories controlled by the following external management systems:

  • Panvalet from Computer Associates (www.cai.com)
  • Librarian from Computer Associates (www.cai.com)
  • Endevor from Computer Associates (www.cai.com)
  • ChangeMan ZMF from Serena Software, Inc. (www.serena.com)

Contact the appropriate vendor for further information about these products.

Parent topic: Configuring Access to External Library Management Systems
Related information
www.cai.com
www.serena.com


Panvalet

Panvalet is a direct access library system marketed by Computer Associates. It's primary use is as a source control system for software development.

  • About Panvalet
  • References
  • Panvalet Suffix Table
  • Suffix Table Override
  • Panvalet Security Exit
Parent topic: Configuring Access to External Library Management Systems


About Panvalet

With Panvalet, all source members are managed as fixed length records. The default size is the historical card image of 80 bytes. Panvalet may be used to manage any fixed-length data up to 4096 characters in length.

Panvalet provides licensed users with programmable access to their repository services via the PAM API. This is a read-only interface which permits multiple concurrent access for Mainframe Access threads to browse source members residing in Panvalet repositories. During Server initialization, Mainframe Access will attempt to load this interface into memory. If this API interface is available through the standard search order (STEPLIB, JOBLIB, or SYS1.LINKLIB at the customer site) then Panvalet services will be offered. Startup initialization messages will indicate if Panvalet is available.

It is a customer responsibility to provide a suitable STEPLIB concatenation which will allow selection of the desired release and version of the Panvalet components. At most sites, PANVALET is installed as an MVS Subsystem. Therefore the API will already be available within SYS1.LINKLIB. No override would be necessary unless a new version is being tested.

     //STEPLIB DD DSN=your.MFA30.LOADLIB,DISP=SHR
     //        DD DSN=your.MFA30.SASC.LINKLIB,DISP=SHR
     //        DD DSN=CAI.PANV144.CAILIB,DISP=SHR

The following messages are typical of the information written to the SYSLOG during Mainframe Access startup:

       MFM0063I: MFA Direct is active
       MFM0064I: MFA Direct number of processing tasks is 5
       MFMDS051I CA/LIBrarian Ready
       MFMDS052I CA/PanValet Ready
       MFMDS053I CA/ENDEVOR API 39 Ready
       MFMDS055I MCG/RPC feature active
       MFMDS001I DSS Server Ready
       MFM0001I: Mainframe Access V3.01 (bt2) is active

For source additions or updates under Panvalet, Mainframe Access must invoke the standard Panvalet batch utility PAN#1. Access to this utility will be serialized, since Panvalet does not support multiple, concurrent access to this service. In some cases, a customer may have renamed the Batch Update utility PAN#1. If this is the case, the new name at this site must be defined to Mainframe Access as a parameter override.

Parent topic: Panvalet
Related concepts
Activating Panvalet


References

  • PANVALET System Management Guide
  • PANVALET Messages Guide
  • PANVALET Installation Guide
  • PANVALET User Guide
  • PANVALET Extended Features Guide
Parent topic: Panvalet


Panvalet Suffix Table

Panvalet recognizes the following programming language or object types:

  • BAL
  • COBOL
  • DATA
  • FORTRAN
  • JCL
  • PL/1
  • RPG

Specification of such a native language type allows Panvalet to format the source files, and automatically add or remove the sequence numbers in the appropriate position for that language. In order to automate this language selection process, Mainframe Access has introduced a Panvalet Suffix Table to specify the language type based upon the file suffix as used on the workstation. In addition, the Suffix Table also specifies the default options to be specified on the ADD command of the PAN#1 batch update utility.

SUFFIX | ++ADD Options
(default) | DATA,LIST,NOFORMAT
ASM | BAL,LIST,NOFORMAT
ASSEM | BAL,LIST,NOFORMAT
BAL | BAL,LIST,NOFORMAT
BMS | BAL,LIST,NOFORMAT
CBL | COBOL,LIST,NOFORMAT
CNTL | JCL,LIST,NOFORMAT
COB | COBOL,LIST,NOFORMAT
COBOL | COBOL,LIST,NOFORMAT
COP | COBOL,LIST,NOFORMAT
COPY | COBOL,LIST,NOFORMAT
CPY | COBOL,LIST,NOFORMAT
DATA | DATA,LIST,NOFORMAT
DBD | BAL,LIST,NOFORMAT
JCL | JCL,LIST,NOFORMAT
JOB | JCL,LIST,NOFORMAT
MAC | BAL,LIST,NOFORMAT
MFS | BAL,LIST,NOFORMAT
PLI | PL/1,LIST,NOFORMAT
PL1 | PL/1,LIST,NOFORMAT
PSB | BAL,LIST,NOFORMAT

The above table describes the default Suffix Table as provided within Mainframe Access. If no changes are desired, no further customization is necessary.

Parent topic: Panvalet


Suffix Table Override

The built-in Panvalet Suffix Table may be replaced by including a special DD card in the Mainframe Access task JCL as follows:

     //PANSUFX  DD  DSN=your.MFA30.CNTL(PANVALET),DISP=SHR

During initialization, this text file will be analyzed and a new Suffix Table will be created dynamically. The first entry defines a default language type to be used if no match is found in the table. The following extract illustrates the free-form format of the text file:

      *
      * MFA PANVALET CONFIGURATION CONVERSION TOOL
      *      AS ON 06/07/2003 AT 12:40
      *
      * SUFFIX TYPE     ++ADD OPTIONS
      ******** ******** ***********************
      *
      DEFAULT  DATA     LIST,NOFORMAT
      ASM      BAL      LIST,NOFORMAT
      ASSEM    BAL      LIST,NOFORMAT
      BAL      BAL      LIST,NOFORMAT
      BMS      BAL      LIST,NOFORMAT
      DBD      BAL      LIST,NOFORMAT
      MAC      BAL      LIST,NOFORMAT
      MFS      BAL      LIST,NOFORMAT
      MLC      BAL      LIST,NOFORMAT
      PSB      BAL      LIST,NOFORMAT
      CBL      COBOL    LIST,NOFORMAT
      COB      COBOL    LIST,NOFORMAT
      COBOL    COBOL    LIST,NOFORMAT
      COP      COBOL    LIST,NOFORMAT
      COPY     COBOL    LIST,NOFORMAT
      CPY      COBOL    LIST,NOFORMAT
      JCL      JCL      LIST,NOFORMAT
      JOB      JCL      LIST,NOFORMAT
      PLI      PL/I     LIST,NOFORMAT
      PL1      PL/I     LIST,NOFORMAT

In this way, customers may change the search order, the suffix name, and the Panvalet ADD options to meet their needs. Some customers may have already compiled a custom Suffix Table from Mainframe Access Version 2. A migration tool is provided to convert this configuration back into a text file which may be presented to Mainframe Access Version 3.

 //jobname  JOB (MFA),'PANVALET SUFFIX',CLASS=A,MSGCLASS=X
 //***************************************************************
 //*        EXTRACT PANVALET SUFFIX FROM MFA SERVER V2
 //***************************************************************
 //*
 //PVSUFFX  EXEC PGM=MFAUTL01,REGION=1M
 //STEPLIB   DD  DISP=SHR,DSN=your.MFA.V3.LOADLIB
 //MFALIB    DD  DISP=SHR,DSN=your.MFA.V2.LOADLIB
 //MFAPARM   DD  DISP=SHR,DSN=your.parms.CNTL(PANVALET)
 //
Parent topic: Panvalet


Panvalet Security Exit

MFA supports a customized user exit (MFAPVXIT) that enables you to implement member-level security within your Panvalet repositories. This user exit is required because security is not available via RACF, and a proprietary Panvalet exit (PSPILXIT) is only available under TSO dialogs.

MFAPVXIT is automatically invoked to approve access rights for all Panvalet activity: import, export, and directory requests. A sample exit and test harness is provided within the .CNTL file shipped with the MFA product libraries:

Member | Description
MFAPVXIT | Sample Panvalet member security exit
PVTESTX | Test harness for MFAPVXIT
ASMPVT | Assemble and link PVTESTX
ASMPVX | Assemble and link MFAPVXIT

MFA provides the user ID, member name, and Panvalet master file name to MFAPVXIT, and interprets a return code of zero to mean that access is permitted. Any other return code results in access being denied. This means that the MFAPVXIT can create a directory filter based on the access rights of the individual or his department. The algorithm is entirely up to the site, and will be based on table-driven data compiled into the exit. The sample exit demonstrates how naming conventions, or tables of authorized users can be used to accomplish this.

Parent topic: Panvalet


Librarian

Librarian is a powerful change management system for source modules and data records.

  • About Librarian
  • References
  • Librarian Exit Table
Parent topic: Configuring Access to External Library Management Systems


About Librarian

Under Librarian, all source is stored within proprietary Librarian master files in a highly compressed format. Individual source modules may be stored and retrieved by name. Multiple master files may be defined and shared among the user groups.

Librarian provides licensed users with programmable access to source modules via the File Access Interface Routines (FAIR) API. This is a read-only interface which permits multiple concurrent access for Mainframe Access threads to browse source members residing in a Librarian master file. During Server initialization, Mainframe Access will attempt to load this interface into memory. If this API interface is available through the standard search order (STEPLIB, JOBLIB, or SYS1.LINKLIB at the customer site) then Librarian services will be offered. Startup initialization messages will indicate if Librarian is available. It is a customer responsibility to provide a suitable STEPLIB concatenation which will allow selection of the desired release and version of the Librarian components.

        //STEPLIB DD DSN=your.MFA30.LOADLIB,DISP=SHR
        //        DD DSN=your.MFA30.SASC.LINKLIB,DISP=SHR
        //        DD DSN=CAI.LIBR43.CAILIB,DISP=SHR

For source additions or updates under Librarian, Mainframe Access will invoke the standard Librarian batch utility AFOLIBR. Access to this utility will be serialized, since Librarian does not support multiple, concurrent access to this service from the same address space. In some cases, a customer may have renamed the Batch Update utility AFOLIBR. If this is the case, the new name at this site must be defined to Mainframe Access as a parameter override.

        MFA_LIBRARIAN_HISTORY=YES           - MFA default
        MFA_LIBRARIAN_UPD_MODULE=LIBRUPD    - site override
Parent topic: Librarian
Related concepts
Activating Librarian


References

  • Librarian Command Reference Guide
  • Librarian File Access Interface Routines
  • Librarian Messages Guide
  • Librarian Installation Guide
  • Librarian User Guide
  • Librarian Systems Services Guide
  • Librarian Security Administration Guide
Parent topic: Librarian


Librarian Exit Table

Librarian does support user exits under its Batch Update facility. The user exit may be common, or may be assigned to a specific master file. In order to configure this option, MFA references a reserved DD named LIBXIT$. If specified in the JCL, MFA builds a memory table to specify the Output Exit to be used for the given master file.

*  Librarian Exit Table (fixed format)
*
*  EXIT columns 1-8 is an exit module name
*       found in the STEPLIB, JOBLIB, LINKLIB concatenation
*  LIBRARIAN MASTER name resides in columns 11-54
*       any master file with this prefix will invoke the exit
*
* EXIT    Librarian Master file prefix or full name
********  ********************************************
LIBREXIT  PROD.LIB
LBXIT02   MY.LIBRARIAN.MASTER
Parent topic: Librarian


Endevor

Endevor is a full function change control system with signout controls and extensive user customization.

  • About Endevour
  • References
  • Endevor Dependent Regions
  • Endevor C1DEFLTS File
  • Endevor Setup Errors
Parent topic: Configuring Access to External Library Management Systems


About Endevour

Through the use of Exits and Processor Groups, it is possible to automatically re-compile the changed objects, and re-link any components which require those objects. Endevor also has several optional system features such as External Security, and alternate RACF user ID support.

Starting with Release 39, Endevor provides licensed users a powerful Endevor Services API (ENA$NDVR). This interface permits full-function access to read or update source objects residing in an Endevor repository. During Server initialization, Mainframe Access will attempt to load this interface into memory. If this API interface is available through the standard search order (STEPLIB, JOBLIB, or SYS1.LINKLIB at the customer site) then Endevor services will be offered. Startup messages will indicate if Endevor is available. It is a customer responsibility to provide a suitable STEPLIB concatenation for selection of the desired release and version of the Endevor components. Mainframe Access will examine the Endevor C1DEFLTS table to determine the version of Endevor being used. This is necessary because the control structures used by the Endevor API versions are not fully downward-compatible. Mainframe Access must build the API request using the format demanded by the version in effect at your site. If no C1DEFLTS table is found, then ENDEVOR support will not be enabled.

        //STEPLIB DD DSN=your.MFA30.LOADLIB,DISP=SHR
        //        DD DSN=your.MFA30.SASC.LINKLIB,DISP=SHR
        //        DD DSN=CAI.NDVR40.AUTHLIB,DISP=SHR
        //        DD DSN=CAI.NDVR40.CONLIB,DISP=SHR

Note that the Endevor API was designed to be a batch-oriented service. It is a file-based interface, not a record-based interface. That is, an object is moved from an Endevor-managed repository, to a specified work file; or vice-versa. Mainframe Access will dynamically create the necessary files as required. A transaction history log is likewise written to a log file. Mainframe Access may optionally be configured to retain a full Endevor transaction log to be used as an audit trail. Access to the Endevor interface is serialized since Endevor does not support concurrent accesses from the same address space. At the same time, all Endevor user exits and packages are operational. This means that site customization will affect the response time for an end-user accessing Endevor data under Mainframe Access. This may require adjustments to the timeout parameters on the clients.

Since all data movement is facilitated through temporary files, Mainframe Access is not able to support the Dsname Validation feature of Endevor. The temporary file used by Mainframe Access is deleted as soon as the transaction (Import or Export) ends. For those sites employing this feature, users could use the Endevor dialog tools under TSO to move their members into their own PDS. Then Mainframe Access could be used to move the PDS member from the mainframe to the workstation, and vice-versa. A subsequent promotion to Endevor would then indeed come from the exact same PDS that received the file at sign-out.

Mainframe Access does maintain the user ID security context for each active thread using the standard IBM security environment and standard SAF calls. Mainframe Access will always invoke the Endevor API interface using the security credentials of the end-user as provided during client logon. To minimize some administrative overhead, Micro Focus recommends the adoption of an Alternate RACF user ID to simplify the administration of RACF access rights for the user population. Access security remains a SITE responsibility. This is no different than standard BATCH or TSO access under Endevor. Mainframe Access will not schedule any Endevor access using the Mainframe Access started-task profile. Also be mindful that some change control "processors" might better be managed by specialist personnel using the Endevor ISPF panels rather than being triggered repeatedly by online Mainframe Access users.

Endevor support is available for the following versions currently supported by Computer Associates:

  • Endevor 40
  • Endevor R7
  • Endevor R12
Parent topic: Endevor
Related concepts
Activating Endevor


References

  • Endevor Administration Guide
  • Endevor API Guide
  • Endevor Error Codes and Messages
  • Endevor Exits Guide
  • Endevor Footprints Guide
  • Endevor Installation Guide
  • Endevor Packages Guide
  • Endevor Security Guide
  • Endevor User Guide
  • Endevor Utilities Guide
Parent topic: Endevor


Endevor Dependent Regions

In order to isolate the Endevor run-time environment from the Mainframe Access address space, and improve the concurrency (and hence scalability) of Endevor accesses, Mainframe Access will schedule the execution of the Endevor API in an independent processing region referred to as an Endevor Dependent Region. This is a special purpose address space that Mainframe Access creates dynamically and shares with all Mainframe Access/Endevor users. It is serially assigned to whatever thread is in need of Endevor API services.

Multiple Endevor dependent regions may be started to meet your throughput requirements. The sample SERVERS member contains a definition for an Endevor address space group that allows a maximum of 2 address spaces to be started for Endevor processing. This value can be increased if the demands of your Endevor usage will benefit from greater concurrency.

You will need to update the started task JCL for dependent regions before you can use the Endevor support. Review the sample JCL member MFAAS and follow the instructions in that member to add your Endevor AUTHLIB and CONLIB program libraries to the STEPLIB concatenation. If you use Processor Groups to compile and relink automatically, specify DYNAMNBR=300 on the EXEC statement and eliminate the pre-allocation of SYSPRINT and SYSTERM which conflict with Endevor procedures to allocate compile and link output files.

For those sites where the logged in users may not have the authority to create transient files using their USERID as the high-level qualifier, there is a configuration parameter to set that high-level qualifier to some other value where all users have READ/WRITE/ALTER access.

DSNQUALIFIER_ENDEVOR=prefix         --- OVERRIDE FOR ENDEVOR ACCESS

This must be specified within the configuration parameters specified by DD=XDBIN both in the MFA Control region, and the MFA Endevor Dependant Region.

In addition, the Endevor Dependent Region will automatically shutdown after a pre-defined idle period. The default is 30 minutes. This automatic shutdown feature allows Endevor resource allocation to quiesce with non-use, and thereby permits overnight backups to run without manual intervention. This idle period is defined as two scan intervals as specified in the Dependent Region parameter file:

DSS_SCAN_INTERVAL=15                --- idle timeout for shutdown

By default, the Endevor Dependent Region will create a new VIO file (DDNAME=ENDVMSG) to be used as the Endevor transaction log for all subsequent transactions within that dependent region. The DCB attributes are:

PS,FBA,LRECL=133,UNIT=VIO,DISP=(NEW,DELETE),DSN=&MSGLOG

This file will effectively be a memory resident file, buffered by JES. Note that during initialization there is no end-user profile in effect. That means the VIO file will be owned by the started task. Therefore, the started task security profile must allow any end-user to write to this file. Endevor will OPEN the file as the transaction log. This behavior can be taken as the default, or specified by:

VIO_FOR_ENDEVOR_LOG=YES          default VIO

If this causes a security violation at your site, you may configure the log to be disk-resident, provided the high-level qualifier will allow universal READ/WRITE access to the log. To override the default, use:

VIO_FOR_ENDEVOR_LOG=N            use DISK

Now Mainframe Access will supply overrides to disk as follows:

UNIT=SYSALLDA,DSNAME=prefix.jobname.ASnnnnn.MSGLOG

where the jobname and address space number will ensure uniqueness. The prefix will be taken from the DSNQUALIFIER_ENDEVOR described above.

Parent topic: Endevor


Endevor C1DEFLTS File

It may be necessary to modify the C1DEFLTS table to facilitate the Endevor support in a multi-user environment. If you do modify the C1DEFLTS table, the resulting C1DEFLTS load module should be stored in the STEPLIB of the MFA server start-up JCL to allow for a custom usage. Your Endevor administrator will have the current C1DEFLTS source and corresponding JCL.

The following C1DEFLTS table change is required:

  • The BATCHID= parameter must be 1. This permits signout and security accesses to be based on the security profile of the user, not the MFA Server started task.
C1DEFLTS TYPE=MAIN,
         ACCSTBL=,       ACCESS SECURITY TABLE           X
         APRVFLG=N,      APPROVAL PROCESSING (Y/N)       X
         ASCM=0,         ASCM CONTROL PASSWORD           X
         BATCHID=1,      BATCH UID FROM JOBNAME/USER=    X
         CIPODSN=,       CCID VALIDATION DSNAME          X
          .
          .
          .
          .
C1DEFLTS TYPE=END
END
Parent topic: Endevor


Endevor Setup Errors

Several environmental conditions are validated when the first transaction is processed on an Endevor Dependent Region. Failure to provide a consistent run-time environment will result in the following abends:

Abend | Description
996 | MFAS startup error - no DSS environment found
997 | Endevor DR setup error - no MSGLOG established
998 | Endevor version mismatch between CR and DR
999 | No Endevor support found in STEPLIB or JOBLIB
Parent topic: Endevor


ChangeMan ZMF

Serena's ChangeMan ZMF is a comprehensive mainframe specific solution that provides reliable, streamlined implementation of changes in z/OS environments. Its version, build and release management functions can be used to manage system changes from development to deployment.

  • About ChangeMan ZMF
  • Customization
  • References
  • AppMaster Builder Support using APS Components
Parent topic: Configuring Access to External Library Management Systems


About ChangeMan ZMF

ChangeMan ZMF 5.3 introduced the Serena XML Services, an open interface for interoperability and data interchange with ChangeMan ZMF. This new interface is intended to replace the RPC and API interfaces that were used with earlier releases of ChangeMan. Mainframe Access Server implements the ChangeMan functions using the XML Services interface.

Mainframe Access requires ChangeMan Version 5.5.6 or later.

Parent topic: ChangeMan ZMF


Customization

The customizations required in Mainframe Access Server are simple and deal primarily with defining the interface to the ChangeMan ZMF subsystem. There are four MFA Server startup parameters for defining this interface and they are described in detail below. The parameters are also documented in the section Editing Mainframe Access Parameters in the chapter Configuration.

The Server's ChangeMan interface uses Mainframe Access Application Server address spaces (also known as dependent regions) to provide isolation for the ChangeMan processing. Separating the processing from the MFA Server control region avoids potential interference with other client requests being processed in the control region.

Both the control region and the dependent region(s) have startup parameter requirements for the ChangeMan interface definition. The sample control region parameters are found in member PARMS and the sample dependent region parameters are found in member PARMSAS. Review the startup parameter information in the sections that follow and update your parameter definitions with values appropriate for your installation.

  • Control Region Startup Parameters
  • Control Region Started Task JCL
  • Dependent Region Startup Parameters
  • Dependent Region Started Task JCL
Parent topic: ChangeMan ZMF
Related information
Editing Mainframe Access Parameters


Control Region Startup Parameters

CHANGEMAN_ASGROUP Specifies the name of the MFA Server address space group used to process all ChangeMan requests. The SERVERS sample defines an address space group named CGMQ that is shared by ChangeMan definitions. If you use both features of MFA Server it is possible, but not necessary, to create separate ASGROUP definitions.

The ASGROUP definition in the SERVERS member names a JCL procedure used to initiate the dependent region started tasks. MFA Server provides a procedure named MFAAS that serves as the basis for all dependent-region JCL procedures. You customize and add this JCL to a system procedure library during server installation. Some features of the MFAAS JCL procedure appear as JCL comment statements that you can customize yourself, including symbolic parameters and STEPLIB program library names. You can also customize any of several specialized ChangeMan DD statements in the procedure. The MFAAS JCL contains text that explains all required customizations for ChangeMan.

Specify the one- to four-character ASGROUP name to associate with ChangeMan processing. If you omit this parameter the address space group name defaults to CALL.

CHANGEMAN_COMMON_BUILD | Specifies whether or not Mainframe Access accommodates group builds submitted under AppMaster Builder. Specify YES to enable group builds or NO to disable them. The default is NO. When enabled for group builds, MFA modifies the build options for each member of the AMB group to match the component name and type submitted, ensuring that each build request in the group is properly executed.
CHANGEMAN_DSNQUALIFIER Specifies a high-level qualifier for dynamically allocated data sets created by MFA Server to hold input files during the staging process. MFA Server creates these data sets dynamically as card-image sequential data sets that are deleted when the associated client request completes. The default qualifier is the login ID of the current user. You should set an alternate qualifier if your installation's SERNET does not have RACF authority to read or write data into files stored in data sets named with the current user's login ID as the high-level qualifier.

If an alternate qualifier is required, see your ChangeMan administrator or your security administrator for assistance in selecting a proper value.

If your ChangeMan functionality is restricted by security subsystem authorizations, you might need to specify your dataset high-level qualifier such that read access to the data sets is always permitted.

CHANGEMAN_INTERFACE Specifies the name of the ChangeMan ZMF module. During ChangeMan request processing, MFA Server loads and branch enters this module. Valid values are SERXMLBC and SERXMLAC. The default is SERXMLAC.

The preferred interface module is SERXMLAC, which is not documented by Serena; however, it provides better interface performance than SERXMLBC by using virtual storage instead of data sets for XML input and output exchange between MFA Server (the requester) and ChangeMan ZMF.

Serena documents only the SERXMLBC interface, which is the XML services batch client. SERXMLBC is intended for use in a batch job stream and requires XMLIN and XMLOUT DD statements to define its required data sets. The MFAAS JCL sample provides sample DD statements for XMLIN and XMLOUT; however, they are commented out. If you must use SERXMLBC, contact SupportLine for assistance with data set definitions.

This parameter is required in both the PARMS member and the PARMSAS member used by application server address spaces.

CHANGEMAN_SSID Initializes the Mainframe Access ChangeMan interface by providing the final character of the z/OS subsystem ID used to identify ChangeMan. Omit this parameter to bypass Mainframe Access initialization for the ChangeMan interface. Valid values are any single alphabetic or numeric character. The character specified is appended to the subsystem ID string "SER", completing the four-character ID. For example, if you specify CHANGEMAN_SSID=A, the z/OS subsystem ID becomes "SERA".

This parameter is required in both the PARMS member and the PARMSAS member used by application server address spaces.

Your ChangeMan administrator can help you to determine the correct subsystem ID to use.

CHANGEMAN_TEST_OPTION | Specify whether or not MFA uses the XML trace option. Specify YES to enable XML trace or NO to disable it. The default is NO. When enabled, SERNET logs information in XML format into the standard SERPRINT DD file. This file can be used to identify problems and to validate MFA services. Enabling XML trace is not recommended for production systems due to the large volume of log data generated.
CHANGEMAN_XMS_SIZE | Specifies the size in megabytes of the cross-memory buffer used by MFA for transmitting XML requests and responses to the ChangeMan dependant Region. A single integer in the range of 1 through 7 is accepted. Note that about 2500 directory entries, or 10,000 lines of source code may be passed in 1 megabyte. If your requirements exceed these limits, then you can configure a more appropriate value. The default value with no configuration is 1 megabyte.
Parent topic: Customization


Control Region Started Task JCL

You can customize the sample JCL procedure for the MFA Server started task with required and optional DD statements for the ChangeMan interface.

  • CMNOPTS
  • CMNLIB$
  • CMNJOB$
Parent topic: Customization


CMNOPTS

Include and customize this DD to provide MFA with your site-dependent user options and your default build options. MFA reads the XML file you specify, using only the options defined for field names that correspond to build and user options. These options enable MFA to properly check out and stage ChangeMan components. See your Serena documentation for ZDD Build Options for more information.

//CMNOPTS DD  DSN=youroptions.xml,DISP=SHR

Where youroptions represents a filename prefix of your choice.

A sample XML file, CMNOPTS, is included within the PDS hlq.WEBROOT.PUBLIC.HTML. Another HTML file, CMNHELPO, is also supplied within hlq.WEBROOT.PUBLIC.HTML. You can tailor this file to present User Help information for the Build Option standards in place at your site.

The following is an example of an XML file containing user and build options:

<?xml version="1.0"?>
<options name="BUILD">
 <profile application="*" language="*" procname="*" libtype="*">
  <field name="Language"       editable="Y" default="CBL"/>
  <field name="BuildProc"      editable="Y" default="CMNCOB2/>
  <field name="Db2PreCompile"  editable="Y" default="N" />
  <field name="Db2Subsystem"   editable="Y" default="DSN7" />
  <field name="CompileOptions" editable="Y" default="RENT,LIST,XREF(SHORT)" />
  <field name="LinkOptions"    editable="Y" default="RENT,MAP,XREF" />
  <field name="UserOption01"   editable="Y" default="N"
     tag="Compile only"  required="Y"  validation="YN"   />
  <field name="UserOption02"   editable="Y" default="N"
     tag="IMS DLIT entry"  required="N"  validation="YN"   />
  <field name="UserOption03"   editable="Y" default="N"
     tag="CICS precompile"  required="N"  validation="YN"   />
  <field name="UserOption04"   editable="Y" default="N"
     tag="Drop INCLUDEs"  required="Y"  validation="YN"   />
  <field name="UserOption05"   editable="Y" default="N"
     tag="Easytrieve"  required="Y"  validation="YN"   />
  <field name="UserOption06"   editable="Y" default="N"
     tag="AMB Generation"  required="Y"  validation="YN"   />
 </profile>
</options>

The user build options tags <UserOptionnn> support a special keyword for validation. If the valuation="text" corresponds to a reserved keyword as described by Serena, then a generic test will be made for NUMERIC, ALPHABETIC, or ALPHANUMERIC text. Otherwise, the "text" characters themselves will be become the customized set of characters to be used as the validation string. Only a character found in this string will be allowed to act as the User Option value.

Parent topic: Control Region Started Task JCL


CMNLIB$

Optionally include and customize this DD to enable MFA to determine which component types are buildable, depending on the language type and build procedures specified. This not only identifies which Library types Drag & Drop may build, but also provides default language names for new components which have have no component history which would otherwise provide this information.

//CMNLIB$ DD  DSN=your.MFA30.CNTL(CMNLIB$),DISP=SHR

Where your is a dataset qualifier representing the location of the dataset.

The following is the default data:

*  ChangeMan Library Table (fixed format)
*          Like Source only
* L
* I BLDPROC  LANGUAGE
* B  NAME     Name
*** ******** ********
ASM CMNASM   ASM
COB CMNCOB2  COBOL
APS DGSAPCOM COBOL
ASC DGSAPSCR COBOL
Parent topic: Control Region Started Task JCL


CMNJOB$

Optionally include and customize this DD to define up to four job cards ChangeMan can submit for a build request, which is scheduled as an independent job by SERNET as part of the staging process.

//CMNJOB$ DD DSN=your.MFA30.CNTL(CMNJOB$),DISP=SHR

Where your is a dataset qualifier representing the location of the dataset.

The default job card contains:

//useridB  JOB (MFA),'CMN-BUILD',CLASS=A,MSGCLASS=X
//*
//*
//*
Parent topic: Control Region Started Task JCL


Dependent Region Startup Parameters

MFA supports the following dependent region startup parameters for ChangeMan:

  • CHANGEMAN_INTERFACE
  • CHANGEMAN_SSID

Both of these parameters are also control region parameters. When you specify the same parameter for both the control and dependent startup regions, their values must match.

Parent topic: Customization


Dependent Region Started Task JCL

The MFAAS sample JCL procedure contains JCL statements you must customize and enable for the ChangeMan interface. The preceding discussion of the CHANGEMAN_ASGROUP parameter highlights the required changes. If you update sample JCL in the MFA Server samples data set, be sure to copy it to the system procedure library.

Parent topic: Customization


References

  • Serena XML Services User Guide
  • ZMF Administrator Guide
  • ZMF Messages Guide
Parent topic: ChangeMan ZMF


AppMaster Builder Support using APS Components

ChangeMan contains an optional feature for managing APS file types in a ChangeMan application. This support is incompatible with the AppMaster Builder support for APS components as provided by Micro Focus as it does not allow you to over-ride the Build procedures to invoke the AppMaster Builder Generation process.

As a result, when configuring ChangeMan for use with applications and packages used by AppMaster Builder, ChangeMan Administration should not configure the file types using the Selectable Option column, as shown in the following screen shot from the ChangeMan Administration Panels under TSO:

--------------------- WAC4 - LIBRARY TYPES PART 1 OF 2 ----------- Row 1 of 65
 COMMAND ===>                                                  SCROLL ===> PAGE

 Enter END command to save changes or CANCEL to exit.
 Enter * in line command field for global staging libraries selection list.

      LIB                                               LIKE  DEFER TARGET SEL.
      TYPE DESCRIPTION                               (S/C/L/P)(Y/N)  TYPE  OPT.
 '''' COB  Cobol_______________________________________  S     Y     LOD   __
 '''' CPY  Copy Books__________________________________  C     Y     ___   __
 '''' JCL  Job Control Language________________________  P     Y     ___   __
 '''' CTC  Control cards_______________________________  P     Y     ___   __
 '''' LOD  Load Library________________________________  L     Y     ___   __
 '''' ACI  APS COBCICS_________________________________  S     Y     LCI   __
 '''' ACN  APS APSCNTL_________________________________  P     Y     ___   __
 '''' ADA  APS APSDATA_________________________________  P     Y     ___   __
 '''' ADE  APS APSDE___________________________________  P     Y     ___   __
 '''' ADG  APS COBDLG__________________________________  S     Y     LDG   __
 '''' AEX  APS APSEXPS_________________________________  P     Y     ___   __
 '''' AFE  APS APSSCFE_________________________________  P     Y     ___   __
 '''' AID  APS COBIDMS_________________________________  S     Y     LOD   __
 '''' AIM  APS COBIMS__________________________________  S     Y     LIM   __
 '''' AIO  APS APSCNIO_________________________________  P     Y     LOD   __
 '''' AIS  APS COBISPF_________________________________  S     Y     LOD   __
 '''' AMA  APS APSMACS_________________________________  C     N     ___   __
 '''' AMS  APS AMSERV__________________________________  P     Y     ___   __
 '''' AMV  APS COBMVS__________________________________  S     Y     LOD
Parent topic: ChangeMan ZMF


Configuring Access to Enterprise Server Mainframe Subsystem Support

Mainframe Subsystem Support (MSS) is an Enterprise Server feature that provides an execution environment for CICS transaction programs on Windows and UNIX platforms. These programs can be ones migrated from the z/OS platform, or entirely new applications, developed specifically for the Enterprise Server MSS environment.

Mainframe Access runs on z/OS and functions as middleware, providing a transparent bridge between your ES/MSS systems and your z/OS CICS systems and enabling a full range of peer ISC communications between these systems including transaction routing, function shipping, distributed program link and distributed transaction processing. The configuration elements in MFA Server create the relationship between MSS and CICS and enable MFA Server to convert between MSS's TCP/IP-based protocol and CICS's LU6.2-based ISC protocol.

This section presents a step-by-step approach to completing the Mainframe Access Server customizations for ES/MSS support. Use this section to work through the customizations.

  • Prerequisites
  • MFA Server Configuration for ES/MSS
  • Technical Details
Parent topic: Configuring and Administering the Mainframe


Prerequisites

Be sure to complete the basic configuration and installation testing of your Mainframe Access Server before you start the advanced configuration activities for ES/MSS support. See the section Quick Configuration in the Configuration chapter for information on the basic configuration. The configuration described in this appendix assumes that you have completed all of the quick configuration steps that establish your parameter file, server definitions, JCL procedures, etc. Also complete the installation verification testing to ensure that you have a running configuration.

Parent topic: Configuring Access to Enterprise Server Mainframe Subsystem Support
Related concepts
Quick Configuration
Advanced Configuration Activities
Related information
Quick Configuration


MFA Server Configuration for ES/MSS

The diagram below shows a single MSS to CICS connection. The MFA Server configuration statements that enable this bi-directional connection are highlighted in the diagram. Keep in mind that there are corresponding configuration requirements in MSS and CICS, and the entire configuration relies on the communications infrastructure provided by your TCP/IP stack and VTAM SNA server.

ES/MSS runs on a Windows or UNIX platform and is connected to your z/OS system by TCP/IP communications. The other software elements reside on a z/OS platform(s). MFA Server runs on z/OS and functions as middleware, providing a transparent connection between ES/MSS and the CICS system. MFA Server is normally installed on the same z/OS system as CICS, although this is not a requirement. The connection between MFA Server and CICS uses standard CICS ISC LU6.2 protocols and MFA Server and CICS may reside in different systems on your SNA network. ES/MSS and MFA Server participate in the TCP/IP network by starting socket listeners, and by accepting and originating socket connection requests. CICS and MFA Server participate in the VTAM SNA network as Logical Units (LUs) by creating and opening a VTAM Access Method Control Block (ACB), and by allocating and managing LU6.2 conversations.

The MFA Server configuration is easy. There are three distinct parts to the configuration, numbered 1, 2, and 3 in the diagram. Part 1 is a simple enabling, or activation, statement. Part 2 defines your z/OS CICS system and provides the information needed for a VTAM SNA connection to this system. Part 3 defines your ES/MSS system and provides the information needed for a TCP/IP connection to this system. All of these statements can be found in the PARMS (Part 1) and SERVERS (Parts 2 and 3) members of your MFA Server <hlq>.CNTL data set. The definitions shown here for ES/MSS and CICS are two of the actual samples from that data set. When you understand the configuration requirements and have determined the correct values for your systems, complete your configuration using a text editor to update these sample definitions with your values. There is no pre-processor or configuration utility used with the MFA Server definitions and there is no configuration information maintained by MFA Server across restarts. So, each time MFA Server is started, your current definitions will be read in during start up, processed and activated. If you need to make changes during your testing, simply update the configuration statements and restart MFA Server.

The following subsections describe the customizations needed for your ES/MSS - CICS connection. The discussion refers to sample definitions that are provided by MFA Server installation and if this is your first ES/MSS configuration it will be easy to update the sample definitions as described.

  • Enable ES/MSS Support
  • Define the Target z/OS CICS System
  • Define the Target ES/MSS Server
  • Restart MFA Server
Parent topic: Configuring Access to Enterprise Server Mainframe Subsystem Support


Enable ES/MSS Support

Your PARMS member in the MFA Server <hlq>.CNTL data set contains the ES/MSS OUTBOUND FEATURE parameter setting. This parameter is set to NO in the sample member. Change the setting to YES. This activates ES/MSS support the next time Mainframe Access Server is started. This specification directs MFA Server to activate the outbound feature and process other definition statements for the MSS feature. Without the YES specification the related ES/MSS server definitions (number 3 in the diagram) are ignored during start up.

*--------------------------------------------------------------------*
* Services to be activated                                           *
*--------------------------------------------------------------------*
*
TCP LINK FEATURE=YES           --- MFE SQL Option, Telnet client
MFADIRECT=YES                  --- Mainframe Access services
MFA FEATURE=YES                --- Mainframe Access Data Connect Server
PEM FEATURE=YES                --- MFE Password Expiration Manager
MCO FEATURE=NO                 --- MFE CICS Option
REMOTE IMS FEATURE=NO          --- MFE IMS Option
LIST DB2=NO                    --- DB2 and IMS subsystem finder
ES/MTO OUTBOUND FEATURE=YES    --- ES/MTO Outbound support
Parent topic: MFA Server Configuration for ES/MSS


Define the Target z/OS CICS System

Your SERVERS member in the MFA Server <hlq>.CNTL data set contains two sample CICS server definitions, one being the CICA sample shown here.

<MCOID=CICA>
LUNAME=CICSSYSA
TPNAME=*
MODENAME=#INTER
SYNCLEVEL=0
SECURITY=NONE
<END>

Parameter | Description
<MCOID=CICA> | Identifies the start of a z/OS CICS target server definition and provides the SYSID value for that server. Change this value to the SYSID of your z/OS CICS system. Specify the same SYSID when you define this CICS to your ES/MSS server in a connection definition.
LUNAME=CICSSYSA | Provides the SNA LU name (also referred to as the VTAM ACB name or VTAM APPL name) of your CICS system. Change the value to the LU name of your CICS system.
TPNAME=* | Identifies the transaction program name used in LU6.2 requests. The actual transaction program name used in each LU6.2 request depends on the function that is requested, and the value is supplied by the system that originates a request. MFA Server adapts depending on the value supplied. Leave this parameter as-is.
MODENAME=#INTER | Provides the name of the VTAM SNA logmode used for LU6.2 sessions. If necessary, change the value to the name of the VTAM SNA logmode you want to use for your LU6.2 sessions. This same logmode name should be used in your CICS SESSIONS definition for the ES/MSS server.
SYNCLEVEL=0 | Sets the synchronization level for LU6.2 requests and is supplied by the system that originates a request. MFA adapts depending on the value supplied. Leave this parameter as-is.
SECURITY=NONE | Sets the security level for LU6.2 requests and is supplied by the system that originates a request. MFA adapts depending on the value supplied. Leave this parameter as-is.
<END> | Marks the end of the definition.
Parent topic: MFA Server Configuration for ES/MSS


Define the Target ES/MSS Server

Your SERVERS member in the MFA Server <hlq>.CNTL data set contains two sample ES/MSS server definitions, one being the MSS1 sample shown here.

<ES/MTOID=MTO1>
ACBNAME=MFAMTO1
IPADDRESS=YOUR.MTO.HOSTNAME
PORT=2200
SESSIONS=4
SOCKETS=1
<END>
Parameter | Description
<ES/MTOID=MTO1> | Identifies the start of an ES/MSS target server definition and provides the ES/MSS SYSID needed to identify the ES/MSS system to MFA Server. Change this value to the SYSID of your ES/MSS server. Specify the same SYSID for the CONNECTION(name) when you define this ES/MSS server to your z/OS CICS system.
ACBNAME=MFAMTO1 | Assigns a VTAM ACB name (also referred to as the SNA LU name or VTAM APPL name) to the ES/MSS server. You can define more than one ES/MSS server and each server you define must have its own ACBNAME, giving it a unique identity in the z/OS CICS system. MFA Server provides two VTAM APPL definitions for ES/MSS servers - MFAMTO1 and MFAMTO2. These are installed and activated in your VTAM SNA configuration during MFA Server installation. If you are defining only one ES/MSS server, leave the ACBNAME as MFAMTO1. Use the MFAMTO2 ACB name if you define a second server. To define more than two ES/MSS servers, you must first install additional VTAM APPL definitions.
IPADDRESS=YOUR.MTO.HOSTNAME | Identifies the internet address of your ES/MSS server machine. Change this value to either the machine name of the server where you're running ES/MSS or the internet IP address of the server.
PORT=2200 | Identifies the TCP/IP port on your ES/MSS server that has been configured as an ISC listener. Change this value to the the ISC listener PORT number on your ES/MSS server.
SESSIONS=4 | Identifies the maximum number of transaction processing sessions that will be managed on a single socket connection. Each active LU6.2 conversation requires a session and the session traffic is interleaved on the MSS to MFA socket connection. For testing purposes, leave this value as-is. However, you might need to adjust it upwards to satisfy your installation's demand as usage increases.
SOCKETS=1 | Identifies the number of sockets available for each MSS to CICS connection. Because ES/MSS requires a single socket for each connection to CICS, leave this value as-is.
<END> | Marks the end of the definition.
Parent topic: MFA Server Configuration for ES/MSS


Restart MFA Server

When you complete the configuration steps, save your updated definitions and restart your MFA Server to activate the definitions. Be sure to complete the related configuration activites in ES/MSS and z/OS CICS before you begin testing.

Parent topic: MFA Server Configuration for ES/MSS


Technical Details

The more detailed tecnical information in this section will increase your understanding of the configuration requirements. You will also be better prepared to respond to operational issues that may arise during the testing of this feature.

  • How ES/MSS Understands the Connection
  • How z/OS CICS Understands the Connection
Parent topic: Configuring Access to Enterprise Server Mainframe Subsystem Support


How ES/MSS Understands the Connection

The communication between ES/MSS and MFA Server uses a proprietary TCP/IP protocol that conveys the necessary LU6.2 protocol information in TCP/IP packets. The SYSIDs used in the MFA Server configuration are the key to this communication. In the example definitions, the target z/OS CICS system is identified as CICA and the target ES/MSS server is identified as MTO1. The initial connection messages between ES/MSS and MFA Server use these SYSID values to exactly identify the two target systems.

If ES/MSS initiates the socket connection to MFA Server, ES/MSS will send a "bind" packet for SYSID CICA. The bind packet also contains the SYSID of the originating MSS, MTO1. The initial packet from ES/MSS is identical to the initial packet from a CICS Option client, so MFA Server needs to identify the type of requester. If MFA Server finds a definition for an ES/MSS server with a SYSID of MTO1 (the ES/MTOID in the definition) and the request originated from the IP address specified in that definition, then MFA Server recognizes this as a request from an ES/MSS server. Otherwise, the connection is recognized as a request from a CICS Option client.

At this point, it is important to note that support for CICS Option has been available in earlier versions of MFA Server and this support allows MFA Server clients to originate requests INTO a z/OS CICS system. This same level of support has also been used by ES/MSS systems, before the availability of the ES/MSS outbound feature. This level of support does not require a definition for the ES/MSS server and it does not require the ES/MSS outbound feature support. In this case, the only definition required is the definition of the target z/OS CICS system (number 2 in the diagram) and the activation of the MFA Server CICS Option support (using the PARMS statement MCO FEATURE=YES). If your only need is for ES/MSS requests into CICS, you may continue to configure your MFA Server in this way. However, our recommendation is that you follow the configuration requirements as outlined in this appendix and define a complete bi-directional connection for the systems that uses MFA Server's ES/MSS outbound feature. The extra effort is minimal and your systems will be ready to support CICS requests into ES/MSS, when they are needed. The complete configuration also results in each ES/MSS having a unique identity from the perspective of the z/OS CICS systems.

Once the initial connection is established, the ES/MSS and CICS definitions have been selected and MFA Server has all of the information it needs to accept a request from ES/MSS and send it into z/OS CICS over an LU6.2 ISC connection. MFA Server will allocate LU6.2 conversations using the MFAMTO1 ACB that has been defined for this ES/MSS. The conversation partner will be the z/OS CICS system that is using the ACB named CICSSYSA and the SNA session for the conversation will use the #INTER SNA logmode. The VTAM SNA logmodes are part of your VTAM SNA configuration and the suggested name can be changed to any other logmode name used for LU6.2 ISC connections in your system. Just be sure that the specified logmode definition is available to both MFA Server and CICS. The MFAMTO1 ACB name used in this sample definition is defined to the VTAM SNA network using a VTAM APPL definition. The APPL definition for MFAMTO1 is provided in another MFA Server sample, the MFAVTAM member in your <hlq>.CNTL data set. This member is installed in your VTAMLST definitions and activated during MFA Server installation.

Each ES/MSS server that you define must have its own ACBNAME and it is this ACBNAME that gives each server a unique identity in the z/OS CICS system(s).

Parent topic: Technical Details


How z/OS CICS Understands the Connection

The communication between z/OS CICS and MFA Server uses standard LU6.2 ISC protocol as implemented by CICS. The SNA logical unit names used in the MFA Server configuration are the key to this communication. In the example, the target z/OS CICS system is identified as CICSSYSA (LUNAME=CICSSYSA) and the target ES/MSS server is identified as MFAMTO1 (ACBNAME= MFAMTO1).

Our target z/OS CICS initiates work to ES/MSS when a request is directed to an external CICS SYSID that is associated with the MFAMTO1 LU name by CICS definitions. A CICS CONNECTION defines the MFAMTO1 LU name and assigns an external SYSID. A CICS SESSIONS definition for that connection defines the SNA logmode to be used for the ISC conversations. It is important to note that the SYSID values known to z/OS CICS do not have to match the SYSID values known to MFA Server and ES/MSS, however, MFA Server and ES/MSS must agree in their definitions. Although the SYSID values known to CICS can be different from the ES/MSS and MFA Server definitions, we recommend that the same SYSID values be used throughout the definitions.

CICS handles the request to the external SYSID by establishing the LU6.2 sessions that support the ISC exchanges, if they are not already established. CICS then sends the initial FMH-5 Attach request for the conversation to MFAMTO1. MFA Server recognizes this request as a conversation for ES/MSS because CICS used the MFAMTO1 LU name. MFA Server also checks that the request originated in a defined CICS server by locating the definition for the originator's LU name (CICSSYSA) and logmode name (#INTER) combination. Having located the two sets of definitions, MFA Server can forward the request on to the target ES/MSS server. If there is currently no socket connection to ES/MSS, MFA Server has the IP address and port number needed to contact ES/MSS's ISC listener. Now the request can be forwarded to ES/MSS over the socket connection associated with the MTO1-CICA SYSID combination.

Parent topic: Technical Details


Configuring the Enterprise Server Environment

The information in this section covers configuring Enterprise Server to connect to a mainframe.

  • Configuring the Environment
  • Defining a Mainframe Node
  • Setting the Mainframe Login Credentials
Parent topic: Configuring and Administering the Mainframe


Configuring the Environment

To configure the mainframe to PC environment, you need to set up the mainframe node or nodes that the PC environment will connect to and use.

You can also configure:

  • Environment variables to configure the various aspects of the system.
  • How embedded hex values are handled in files that are transferred.
  • Configuring Environment Variables
  • Handling Embedded hex Values
Parent topic: Configuring the Enterprise Server Environment


Configuring Environment Variables

The Drag and Drop applications check for optional environment variables to have been specified. These variables allow certain configuration information to be designated.

The environment variables that you can configure are:

CCITIMEOUT | Allows the specification, in tenths of seconds, of the maximum time out period that will be used with any LSC style application, such as Drag and Drop, SourceConnect, or the Monitor. The default is 2 minutes (1200), and the maximum value that can be used is 2,147,483,647. Example for setting this value to 4 minutes SET CCITIMEOUT=2400
MFAMAXSENDLENGTH | Sets the maximum length of data, in a single communication packet, that can be transmitted to or from the mainframe. This does not affect the size of the file that can be transmitted, but only the size of each of the numerous data chunks that are transmitted to make up the entire file. This is only useful, when there is a router that limits the transfer length of data to or from the mainframe, or there is a restriction in the length of data that can be transferred. Example: SET MFAMAXSENDLENGTH=4000
MFAMAXHOTLINKS | If using the hot-link software from Micro Focus, the LSC applications will route all communication request through this hot-link. The hot-link remains active to the mainframe until you shut down your workstation, or enter the command MFDAELSC CLOSE. The hot-link is able to allocate and load balance more than multiple simultaneous links and will start up an additional link if any request has to wait for more than 15 seconds for a time slice. The maximum number of simultaneous links can be specified, with a default of 4 and a maximum of 10, as follows: SET MFAMAXHOTLINKS=4
MFAIMBEDDEDHEX | Indicates that you wish to have all source code embedded hex values handled in the same way as the MDECONV application, in that all translated hex values less than x'1f' will have a null character inserted before the hex value. The COBOL run-time system will properly handle these imbedded hex values. Example: SET MFAIMBEDDEDHEX=COBOL
Parent topic: Configuring the Environment


Handling Embedded hex Values

Important note: Many mainframe installations own source code that contains embedded hex values. These hex values are handled by Drag and Drop, or Compare and Synchronization Monitor, in two different ways, depending upon your requirements.

  • The first method, the default, is to simply translate these hex values to ASCII and hope that the workstation applications handle them properly.
  • The second method is much more integrated with other Micro Focus applications, and may be the desired technique to be used. This method, will detect all imbedded hex values that translate to less than x'1f' and insert a null byte in front of each of them. This is the Micro Focus MDECONV technique, and all Micro Focus COBOL applications will properly detect this. To turn on this method, you must have set either the use MDECONV style imbedded hex processing in the configure options pulldown of Drag and Drop, or have set an environment variable specified as MFAIMBEDDEDHEX=COBOL. You may also mix applications and techniques if desired. One application environment setup can have this environment variable active, while another application, on the same workstation, can have it turned off.
Parent topic: Configuring the Environment


VSAM Record Length Restrictions

The maximum record length that Drag and Drop, SourceConnect and Compare and Synchronization Monitor can handle is 64,000 bytes. If you have defined a VSAM file with a maximum record length greater than 64,000, then it is still possible that it can be read. It depends upon whether or not a record actually exists in the data set that is longer than the 64,000 byte limit. This limit is actually 63,998 bytes because LSC appends a 2 byte length code.


Defining a Mainframe Node

In order to access mainframe files , you need to define the mainframe nodes that you want to access. Drag and Drop, SourceConnect and Compare and Synchronization Monitor all use the definitions that you define.

You use the Server Access Configuration dialog box to configure this node.

To display the Server Access Configuration dialog box, use either of the following options:

  • From the Visual Studio menu, select: Tools > Micro Focus COBOL Tools > Micro Focus Server Access
  • From the Windows Start menu, select :Micro Focus Product Name > Configuration > Mainframe Access Configuration

The Server Access Configuration dialog box is displayed.

  • Adding a Mainframe Node
  • Configuring the Cache
  • Editing a Mainframe Node Configuration
Parent topic: Configuring the Enterprise Server Environment
Related tasks
Starting Compare and Synchronization Monitor from the User Interface


Adding a Mainframe Node

To access a mainframe, you must define the mainframe node. This node definition is used by Drag and Drop, SourceConnect and Compare and Synchronization Monitor. That is, if you change the definition, the changes apply to all three components

To display the Server Access Configuration dialog box, use either of the following options:

  • From the Visual Studio menu, select: Tools > Micro Focus COBOL Tools > Micro Focus Server Access
  • From the Windows Start menu, select :Micro Focus Product Name > Configuration > Mainframe Access Configuration

The Server Access Configuration dialog box is displayed.

You must configure at least one mainframe node and its associated server name, machine parameters and communication protocol.

In the Server Access Configuration dialog box, the default node has a checkmark beside it. You can configure multiple server nodes, each pointing to different MFA mainframe servers on one or more mainframes.

To add a new node:

  1. In the Server Access Configuration dialog box, click Add and enter a name for the mainframe node.
    *
  2. Click Next, and select whether you are using TCP/IP or APPC for your communication method.
    *
  3. Click Next, and for TCP/IP, use the information below to define how to connect to the mainframe.
    *
    DirectConnect Name or IP address
    For TCP/IP direct connect, you would enter either the dotted decimal IP address or the DNS name of your mainframe.
    DirectConnect Port number
    For TCP/IP direct connect, you would enter the port number that the MFA mainframe server is listening on. This would usually be a 4 or 5 digit number.
    IndirectConnect Logical server name
    For TCP/IP indirect connect, you would specify the DNS name of the CCITCP2 daemon that has been set up on your system. Most users use the DirectConnect method instead of this IndirectConnect method.
    Standard server machine parms
    If you are using APPC, or direct connect TCP/IP then you will need to enter information here.
    • For TCP/IP direct connect, you would enter MFNODE:xxx.xxx.xxx.xxx,MFPORT:yyyy where:
      • xxx.xxx.xxx.xxx is the IP address, or DNS name, of your mainframe.
      • yyyy is the assigned TCP/IP port that the standard mainframe server is to listen on.
    • For APPC, you would most likely enter the LUname.mode, for example WKSLU010.#INTER where WKSLU010 is your LU name.

    For APPC, use the following information:
    *

    Connect to the mainframe using the APPC partner LU name and TP name
    For APPC, you would the partner LU name, followed by a decimal point (.) and then the TP name.
    Connect to the mainframe using the APPC local LU name and APPC mode name
    For APPC, you would enter the local LU name, followed by a decimal point (.) and then the mode, which would most likely be #INTER.
  4. Click Next to display a confirmation of the configurations that you entered.
    *
  5. Click Finish to set the configurations, or use Back to make changes.
Parent topic: Defining a Mainframe Node
Related concepts
Configuring the Cache
Logging On to the Mainframe
Related information
Starting and Configuring Drag and Drop
Configure PVCS Drives
Configure Mainframe Drives


Configuring the Cache

The drive mapping process caches files to a file or folder on your PC. The cache folder is also used to contain a log file detailing any exceptions that occur while accessing the mainframe files.

CAUTION:
You need to ensure that there is sufficient available space on your PC to contain the cache.

To configure the cache location:

  1. On the Server Access Configuration dialog box, select the General tab.
  2. Click Change to display the Browse for Folder dialog box.

    Use the dialog box to browse for and select a folder.

  3. Click OK to set the selected folder as the cache location.
Parent topic: Defining a Mainframe Node
Related concepts
Logging On to the Mainframe
Related information
Adding a Mainframe Node
Starting and Configuring Drag and Drop
Configure PVCS Drives
Configure Mainframe Drives


Editing a Mainframe Node Configuration

You can edit a mainframe node's configuration to change settings as required. You use the Server Access Configuration dialog box to do this.

To display the Server Access Configuration dialog box, use either of the following options:

  • From the Visual Studio menu, select: Tools > Micro Focus COBOL Tools > Micro Focus Server Access
  • From the Windows Start menu, select :Micro Focus Product Name > Configuration > Mainframe Access Configuration

The Server Access Configuration dialog box is displayed.

To edit a node:

  1. On the Server Access Configuration dialog box, select the Node tab.
  2. In the list, select the node to edit, and click Edit to display the Node Configuration dialog box.
  3. Complete the entries in the dialog box as required.

The Node Configuration dialog box contains the configurations that you set when you defined the node. In addition it contains the Credentials button. Use this to configure mainframe login credentials.

Parent topic: Defining a Mainframe Node


Setting the Mainframe Login Credentials

You can set the mainframe login credentials so that you do not need to configure them. You can select to save the credentials to an INI file so that you do not need to re-configure them each time you start a mainframe access session.

Note: If you do not set these credentials, components such as SourceConnect prompt you for the credentials each time they require mainframe access.
  • About MFDaemon
  • To Set the Mainframe Login Credentials
Parent topic: Configuring the Enterprise Server Environment


About MFDaemon

MFDaemon is a process that runs on your PC to maintain mainframe login access details. With mainframe credentials:
  • When you start a mainframe access session on your PC, MFDaemon checks for an INI file and loads any login configurations that it contains.
  • When you edit a node to set login credentials for the node, MFDaemon saves these credentials and supplies them as required when access authentication is required.
    Note: The saved password is encrypted in the INI file.

You can use the MFACLIENTINI environment variable to set the name of the INI file. If this variable is not set, the default name nad path of the INI file is:

c:\users\USERNAME\appdata\roaming\micro focus\mfaclient.ini

To start or stop MFDaemon:

  • From the Server Access Configuration dialog box, select the MFDaemon tab.

    The MFDaemon's status is displayed.

  • Click Stop Daemon or Start Daemon as appropriate.

    MFDaemon stops or starts depending on the button you click.

Parent topic: Setting the Mainframe Login Credentials
Related concepts
Security


To Set the Mainframe Login Credentials

To set the mainframe login credentials:

  1. Open the Server Access Configuration dialog box and open the Node Configuration dialog box for the node to edit.
  2. Click the Credentials button to display the Micro Focus Data Access Services dialog box.
  3. Enter the credential details to set and click OK to save them.
    • Select the Use to authenticate against all resources check box if the credentials are to be used to access any resources that your applications use.
    • Select the Save to INI file check box if you want to retain these credentials between sessions. The next time you start a session, MFDaemon checks for the INI file and uses the credentials it contains.
Parent topic: Setting the Mainframe Login Credentials


Mainframe Access Messages

Mainframe Access, the SAS/C run-time library and the z/OS operating system all use messages to document both normal and abnormal conditions while Mainframe Access is running. The z/OS system log, the Mainframe Access job log and the Mainframe Access SYSOUT data sets are all possible destinations for important messages about Mainframe Access operation. You should already be familiar with z/OS system messages.

  • Mainframe Access Server Messages
  • SAS/C Run-time Library Messages
  • Status Codes and Error Messages
Parent topic: Configuring and Administering the Mainframe


Mainframe Access Server Messages

Some Mainframe Access messages are directed to system consoles as specified by the ROUTE Mainframe Access configuration parameter. Other messages are directed to the job log for the started task or to the XDBOUT file (or both). If you experience problems with Mainframe Access operation, it is important that you review the various message destinations for information that may help you diagnose the problem. This section includes an explanation of each of these messages, ordered by message number.

  • Mainframe Access Operational Messages Format
  • Mainframe Access Messages
  • Data Set Services Messages
  • MFA Direct Messages
  • Data Connect Messages
  • Drag and Drop Error Messages
Parent topic: Mainframe Access Messages


Mainframe Access Operational Messages Format

Mainframe Access operational messages are of the form:

mm/dd/yy hh:mm:ss.t taskname taskid MFMnnnna text

or

mm/dd/yy hh:mm:ss.t taskname taskid MFMDSnnna-text

where

mm/dd/yy | indicates the date when the message was issued.
hh:mm:dd.t | indicates the time when the message was issued.
taskname | is the name of the Mainframe Access task that issued the message.
taskid | is a two hexadecimal digit task identifier that helps to uniquely identify the Mainframe Access task for tasks that share a common task name. For instance, task name XDBMFADM processes Mainframe Access Direct client requests and there may be several instances of this task, each managing the work of a different subset of client connections. When examining XDBOUT trace messages for a specific client, trace messages from other clients and their processing tasks may be interleaved with the trace messages for the client that is of interest. The taskid value helps to identify the messages associated with a particular task.
DS | indicates that the message was produced by the Data Set Services (DSS) component of Mainframe Access, which provides all file allocation and record access services.
nnnn | is an integer in the range 0001 through 9999
a | is I if the message is for information only, or E if the message indicates an error condition
text | is the error message text

Messages may be issued that do not have the MFMnnnna or MFMDSnnna message prefix. These messages are diagnostic and/or trace messages that are not documented in this messages section. They are intended for use by Product Support.

Parent topic: Mainframe Access Server Messages


Mainframe Access Messages

MFM0001I:
Mainframe Access version (service) is active

Issued when Mainframe Access initialization completes. version identifies the Mainframe Access product version and service indicates the current maintenance level that has been applied to Mainframe Access.

MFM0001I: Mainframe Access version (service) is active

Issued when Mainframe Access initialization completes. version identifies the Mainframe Access product version and service indicates the current maintenance level that has been applied to Mainframe Access.

MFM0002I: listener socket number is n

Issued during startup by the process that serves client requests arriving on the TCP port, as specified in your Mainframe Access configuration parameter TCP_PORT. This message identifies the socket number n that has been allocated for listening and accepting the client connections.

MFM0003I: getsockopt return code is n

Issued during startup by the process that serves client requests arriving on the TCP port, as specified in your Mainframe Access configuration parameter TCP_PORT. n is the return code from the TCP/IP getsockopt call and a value of zero indicates that startup is proceeding normally.

A non-zero value may indicate a problem. Refer to your TCP/IP provider's socket API return code documentation for an explanation of the non-zero value.

MFM0004I: setsockopt reus return code is n

Issued during startup by the process that serves client requests arriving on the TCP port, as specified in your Mainframe Access configuration parameter TCP_PORT. n is the return code from the TCP/IP setsockopt REUS call and a value of zero indicates that startup is proceeding normally.

A non-zero value may indicate a problem. Refer to your TCP/IP provider's socket API return code documentation for an explanation of the non-zero value.

MFM0005I: setsockopt linger return code is n

Issued during startup by the process that serves client requests arriving on the TCP port, as specified in your Mainframe Access configuration parameter TCP_PORT. n is the return code from the TCP/IP setsockopt call and a value of zero indicates that startup is proceeding normally.

A non-zero value may indicate a problem. Refer to your TCP/IP provider's socket API return code documentation for an explanation of the non-zero value.

MFM0006E: Tcpm socket error, sd=n1, function=name, errno=n2

Issued by the process that serves client requests arriving on the TCP port, as specified in your Mainframe Access configuration parameter TCP_PORT. This process establishes the client connection and then assigns the client to a processing subtask based on the client type (for example, CICS Option client, IMS client, Telnet client). This message indicates that an error has occurred during the processing of a socket API call associated with this connection establishment process. name identifies the specific socket API call, n1 identifies the socket (either the listening socket or a new socket created when a client request is accepted) and n2 is the TCP/IP errno value that was reported for the call.

Refer to your TCP/IP provider's socket API return code documentation for an explanation of the errno value for the specified function.

MFM0007E: Tcpm socket error, sd=n1, function=name, errno=n2

Issued by the process that serves client requests arriving on the TCP port, as specified in your Mainframe Access configuration parameter TCP_PORT. This process establishes the client connection and then assigns the client to a processing subtask based on the client type (for example, CICS Option client, IMS client, Telnet client). This message indicates that an error has occurred during the processing of a socket API call associated with this connection establishment process. name identifies the specific socket API call, n1 identifies the socket (either the listening socket or a new socket created when a client request is accepted) and n2 is the TCP/IP errno value that was reported for the call.

Refer to your TCP/IP provider's socket API return code documentation for an explanation of the errno value for the specified function.

MFM0008E: Parameter initialization has failed

Issued during initialization if parameters processed from the active configuration data set specified by the //XDBIN data definition statement contain errors that make it impossible for Mainframe Access to complete startup. Mainframe Access shuts itself down after issuing this message.

Review the startup messages to identify and correct any configuration errors before restarting Mainframe Access.

MFM0009E: APF authorization has failed

Issued during initialization if Mainframe Access finds that it is not executing as an z/OS authorized program. Mainframe Access must execute as an z/OS authorized program and the z/OS TESTAUTH service is used to verify this during startup. Mainframe Access shuts itself down with a U2199 abend after issuing this message.

Check each program library name in the //STEPLIB data definition statement and make sure that each is identified to z/OS' Authorized Program Facility as an authorized program library. Common mistakes are misspelled data set names and incorrect DASD volume identifications.

MFM0010E: Global data area initialization failed

Issued during initialization if Mainframe Access cannot load required service modules and initialize its global data areas. Mainframe Access shuts itself down with a U2202 abend after issuing this message.

If you see this message contact our Product Support.

MFM0011I: Mainframe Access shutdown completed

This is the last message issued during shutdown to indicate that all processes have been stopped. The Mainframe Access job or started task should end immediately after issuing this message. If the Mainframe Access stop command is issued and you do not see this message within a reasonable amount of time (approximately 30 seconds) there is most likely a problem quiescing one or more of the Mainframe Access processes. This may be due to a Mainframe Access problem or it may be the result of other problems in the system.

If such a condition occurs frequently and no associated system condition can be identified, contact our Product Support for assistance.

MFM0012I: TCP port number is n

Issued during initialization as parameters are processed from the active configuration data set specified by the //XDBIN data definition statement. n is the TCP port number for client connections, as specified in your Mainframe Access configuration parameter TCP_PORT.

MFM0013I: Admin port number is n

Issued during initialization as parameters are processed from the active configuration data set specified by the //XDBIN data definition statement. n is the administration port number for HTTP connections, as specified in your Mainframe Access configuration parameter ADMIN_PORT.

MFM0014I: Mainframe Access version (service) for company

Issued during initialization as parameters are processed from the active configuration data set specified by the //XDBIN data definition statement. version identifies the Mainframe Access product version and company is your company name as specified in your Mainframe Access configuration parameter ORGANIZATION.

MFM0015I: message text

Message MFM0015I is a blank template that is used during the creation of Mainframe Access displays in response to administrative commands. message text is a self-explanatory line of display information created by command processing routines. For examples of how this message is used see the sample command output in the chapter Administration Using Console Commands.

MFM0016E: Tcps socket error, sd=n1, function=name, errno=n2

Issued by the process that serves clients that use DB2 connectivity. This message indicates that an error has occurred during the processing of a socket API call associated with client communication. name identifies the specific socket API call, n1 identifies the client socket and n2 is the TCP/IP errno value that was reported for the call.

Refer to your TCP/IP provider's socket API return code documentation for an explanation of the errno value for the specified function.

MFM0017E Tcps socket error, sd=n1, function=name, errno=n2

Issued by the process that serves clients that use DB2 connectivity. This message indicates that an error has occurred during the processing of a socket API call associated with client communication. name identifies the specific socket API call, n1 identifies the client socket and n2 is the TCP/IP errno value that was reported for the call.

Refer to your TCP/IP provider's socket API return code documentation for an explanation of the errno value for the specified function.

MFM0018I: name-address Task initialization has completed

Issued during startup by Mainframe Access' specialized z/OS processing subtasks as they successfully complete initialization. name identifies the type of subtask and address is the address of Mainframe Access' task control block for the process.

MFM0019I: name-address Task shutdown has completed

Issued during shutdown by Mainframe Access' specialized z/OS processing subtasks as they complete shutdown. name identifies the type of subtask and address is the address of Mainframe Access' task control block for the process. These messages can sometimes help to identify the general nature of a Mainframe Access shutdown delay or failure by identifying the processes that have successfully finished their cleanup procedures.

MFM0020E: Wwwm socket error, sd=n1, function=name, errno=n2

Issued by the process that serves HTTP client requests arriving on the administration port. This process establishes the client connection and then assigns the client to a processing subtask based on the HTTP request (for example, simple resource retrieval of a page or image, Web Administration request, ISPI program request). This message indicates that an error has occurred during the processing of a socket API call associated with this connection establishment process. name identifies the specific socket API call, n1 identifies the socket (either the listening socket or a new socket created when a client request is accepted) and n2 is the TCP/IP errno value that was reported for the call.

Refer to your TCP/IP provider's socket API return code documentation for an explanation of the errno value for the specified function.

MFM0021E: Wwwm socket error, sd=n1, function=name, errno=n2

Issued by the process that serves HTTP client requests arriving on the administration port, as specified in your Mainframe Access configuration parameter ADMIN_PORT. This process establishes the client connection and then assigns the client to a processing subtask based on the HTTP request (for example, simple resource retrieval of a page or image, Web Administration request, ISPI program request). This message indicates that an error has occurred during the processing of a socket API call associated with this connection establishment process. name identifies the specific socket API call, n1 identifies the socket (either the listening socket or a new socket created when a client request is accepted) and n2 is the TCP/IP errno value that was reported for the call.

Refer to your TCP/IP provider's socket API return code documentation for an explanation of the errno value for the specified function.

MFM0022I: Wwwm listener socket number is n

Issued during startup by the process that serves HTTP client requests arriving on the administration port, as specified in your Mainframe Access configuration parameter ADMIN_PORT. This message identifies the socket number n that has been allocated for listening and accepting the client connections.

MFM0023E: Conversation id returned null for socket blockaddress

Issued by the processes that serve Remote IMS and CICS Option client requests arriving on the TCP port, as specified in your Mainframe Access configuration parameter TCP_PORT. This message indicates that an error occurred when Mainframe Access tried to access the LU6.2 conversation associated with this client's IMS or CICS connection. address identifies the Mainframe Access socket block associated with the requesting client.

If this problem occurs frequently, contact our Product Support for assistance.

MFM0024E: Client data length error, length is 0

Issued by the processes that serve Remote IMS and CICS Option client requests arriving on the TCP port, as specified in your Mainframe Access configuration parameter TCP_PORT. This message indicates that an error occurred when Mainframe Access received a request message from the client.

If this problem occurs frequently, contact our Product Support for assistance.

MFM0025I: Trace set to data level on

Issued in response to the Trace On command to confirm that Mainframe Access activity tracing has been initiated. Trace data is written to the destination specified by the configuration parameter TRACE, or to the default destination, the XDBOUT data set.

MFM0026I: Trace set to data level off

Issued in response to the Trace Off command to confirm that Mainframe Access activity tracing has been stopped.

MFM0027I: Telnet mode on

Issued to confirm that Mainframe Access is accepting Telnet client connection requests.

MFM0028I: Telnet mode off

Issued to confirm that Mainframe Access is not accepting Telnet client connection requests.

MFM0029E: Command is not allowed

Issued to indicate that the previously entered command could not be processed although it was entered correctly.

MFM0030E: name invalid command, please reenter

Issued to indicate that the previously entered command name could not be processed due to an error in the format of the command parameters.

Reenter the command with correct parameters.

MFM0031E: Wtrm task shutdown initiated for unrecoverable error

Issued by the Mainframe Access task that processes operator commands. This message indicates that a severe error occurred during the processing of a command. Commands can originate from the system console (z/OS Modify command), Web Administration users and Telnet clients.

Restart Mainframe Access after shutdown is complete. If this problem occurs frequently, contact our Product Support for assistance.

MFM0032E: Wtrm task is recovered

Issued by the Mainframe Access task that processes operator commands. This message indicates that a severe error occurred during the processing of a command and Mainframe Access was able to resume normal processing. Commands can originate from the system console (z/OS Modify command), Web Administration users and Telnet clients.

If this problem occurs frequently, contact our Product Support for assistance.

MFM0042E: DLL DD name is missing

Issued when a request for an ISPI program is received and Mainframe Access' ISPI program loader cannot find a data definition statement for the ISPI program libraries (the //DLL DD statement). An error response is sent to the requester.

Stop Mainframe Access, add the missing //DLL data definition statements to the Mainframe Access startup JCL and then restart Mainframe Access.

MFM0043E: Open DLL file has failed

Issued when a request for an ISPI program is received and Mainframe Access' ISPI program loader receives an error indication from z/OS when opening the ISPI program libraries identified by the //DLL DD statements. An error response is sent to the requester.

Examine the system log and job log for I/O error messages associated with this failure and use that information to correct the problem. If the problem persists or cannot be identified, contact our Product Support for assistance.

MFM0045E: Unable to allocate LU6.2 conversation with target CICS

Issued by the process that serves CICS Option client requests arriving on the TCP port, as specified in your configuration parameter TCP_PORT. This message indicates that an error has occurred while Mainframe Access was attempting to allocate an LU6.2 conversation to the target CICS region. In some cases the actual error may have occurred during session establishment with the target CICS system and preceding error messages may contain LU6.2 return code information that will be helpful in diagnosing the problem.

Verify that all of the Mainframe Access target server configuration parameters for the CICS region are correct. Also check that the CICS definitions for Mainframe Access are correct and that the VTAM log mode specified in the target server configuration is available to both CICS and Mainframe Access. If this problem occurs frequently, contact Micro Focus Product Support for assistance.

MFM0046E: Function ship error, errno=n, desc=text, data=string

Issued by the process that serves CICS Option client requests arriving on the TCP port, as specified in your configuration parameter TCP_PORT. This message indicates that an error has occurred while Mainframe Access was communicating with the target CICS region. n is an error code assigned by Mainframe Access. text provides a short description of the type of error or the current state of processing. string provides additional error information appropriate for the type of error being reported.

If this problem occurs frequently, contact our Product Support for assistance.

MFM0047I: DSS maximum shared public files is n

Issued during initialization as parameters are processed from the active configuration data set specified by the //XDBIN data definition statement. n is the value specified in the configuration parameter MAX_PUBLIC_FILES. This value indicates the maximum number of shared files that can be concurrently open.

MFM0049I: DLL name scheduled for MFM0049I: DLL name scheduled for refresh

Issued in response to the ISPI module refresh command to confirm that Mainframe Access has accepted the refresh request. A new copy of the requested ISPI load module will be brought into storage using the z/OS LOAD service and used to process subsequent HTTP requests for the program.

MFM0053I: SMF recording is on, record id is n

Issued during initialization as parameters are processed from the active configuration data set specified by the //XDBIN data definition statement. n is the value specified in the configuration parameter SMF_RECORDID. This is a valid user SMF record id and recording is activated.

MFM0054E: SMF recording is off, record id is zero or invalid

Issued during initialization as parameters are processed from the active configuration data set specified by the //XDBIN data definition statement. If the configuration parameter SMF_RECORDID was specified as 0 (zero), you have elected to disable SMF recording. If the configuration parameter SMF_RECORDID was specified as a non-zero value, the value is not valid for SMF user records. In this case, SMF recording is disabled.

If SMF recording is required, stop Mainframe Access, correct the parameter value and then restart Mainframe Access.

MFM0055I: DSS scan interval is n minutes

Issued during initialization as parameters are processed from the active configuration data set specified by the //XDBIN data definition statement. n is the value specified in the configuration parameter DSS_SCAN_INTERVAL.

MFM0056E: DSS scan interval is not valid, defaults to 2 minutes

Issued during initialization as parameters are processed from the active configuration data set specified by the //XDBIN data definition statement. An invalid value was specified for the configuration parameter DSS_SCAN_INTERVAL. The default value of two minutes was substituted for the invalid parameter value.

If two minutes is not an acceptable value, stop Mainframe Access, correct the parameter value and then restart Mainframe Access.

MFM0059E: BLDL for ISPI DLL module name failed

A request to execute ISPI module name was received from an HTTP client. The z/OS BLDL service was unable to locate this load module in the program library concatenation specified by the //DLL data definition statement.

Check that the load module name is correct and that all required program libraries are available.

MFM0060E: LOAD for ISPI DLL module name failed rc=n1 reason=n2

A request to execute ISPI module name was received from an HTTP client. The z/OS LOAD service reported a failure when reading the load module from the program library concatenation specified by the //DLL data definition statement. Return code n1 is the z/OS system completion code that would normally be reported as an abend failure by the z/OS LOAD service and n2 is the additional reason code associated with the abend code. Both values are given as hexadecimal numbers.

Refer to the z/OS system codes manual for your level of z/OS to interpret the return code/reason code pair and take appropriate corrective action.

MFM0061E: ISPI DLL module name unavailable due to rc=n1 reason=n2

A request to execute ISPI module name was received from an HTTP client. This ISPI module has been logically disabled by Mainframe Access due to a previous error condition associated with the module. The previous error may have been an z/OS LOAD service failure or a module execution failure. Return code n1 is the z/OS completion code that was reported for the original failure and n2 is the additional specific reason code associated with the completion code. Both values are given as hexadecimal numbers.

If the completion code value is of the form 00xxx000, xxx is an z/OS system completion code and you should refer to the z/OS system codes manual for your level of z/OS to interpret the return code/reason code pair and take appropriate corrective action. If the completion code value is of the form 00000xxx, the xxx value is a hexadecimal user abend code. User abend codes are normally documented as decimal values and you should convert the xxx hexadecimal value to decimal, if necessary. Refer to the program documentation for the meaning of the user abend code. You can reinstate the ISPI DLL module by using the Refresh ISPI program function of Mainframe Access' Web Administration interface (see the section Refresh ISPI Program Page in the chapter Administration Using the Web Interface).

MFM0062E: Initialization failed (by name - explanation)

During initialization processing a condition was encountered that would prevent proper execution of Mainframe Access. For example, Mainframe Access' listening process for client connections was unable to allocate and/or open a socket for TCP_PORT. The component that detected the condition has initiated shutdown processing. The name identifies the task that detected the condition and explanation provides a concise statement of the problem.

Examine associated error messages in the system log, joblog and XDBOUT data set to determine the cause of the initialization failure. In most cases, the related error messages can be found just before this message in the XDBLOG data set. Correct the problem and restart Mainframe Access.

MFM0063I: MFA Direct is active

This message is issued during initialization to acknowledge that MFADIRECT=YES was specified in the parameter file.

MFM0064I: MFA Direct number of processing tasks is n

This message is issued during initialization to acknowledge that the MFADIRECT_MAXTASKS=n parameter file specification has been processed. Mainframe Access will start n z/OS tasks for Mainframe Access request processing. During execution Mainframe Access will create up to n additional tasks for Mainframe Access request processing if the transaction rate and processing load warrant.

MFM0065I: usage port number for client connections is n

This message is issued during initialization to acknowledge that the TCP_PORT and ADMIN_PORT parameter file specifications have been processed. The usage indicates that either the "Server Enterprise Edition" (for TCP_PORT) or the "Web server" (for ADMIN_PORT) will be listening on port number n for client connections.

MFM0066I: Address space type is astype

This message is issued during initialization to acknowledge that the ASTYPE parameter file specification has been processed. The address space type can be "STANDARD", "CTLRGN" or "APPSERVER". The "STANDARD" address space is a stand-alone Mainframe Access server. The "CTLRGN" is a Mainframe Access server capable of starting application server regions such as the Mainframe Access Data Connect server. The "APPSERVER" address space is lightweight subset of the Mainframe Access server that is started and managed by a CTLRGN.

MFM0067I: TCPAccess support selected

This message is issued during initialization to acknowledge that the TCPACCESS=YES parameter file specification has been processed. The address space will use CA TCPaccess for TCP/IP network connections.

MFM0068I: parmname parameter specification invalid

This message is issued during initialization to indicate that the usage of parameter parmname is incorrect and this parameter was not successfully processed.

Correct the parameter specification and restart Mainframe Access.

MFM0069E: MFADirect not configured - rejecting sd=n ip=addr

Issued by the TCP/IP listener for TCP_PORT when a client connection request for Mainframe Access services is received and MFADirect services have not been configured in the initialization parameters. The client (from IP address addr on socket n) is disconnected.

Check that MFADirect services are enabled by the MFADIRECT and MFADIRECT_MAXTASKS initialization parameter settings. Restart Mainframe Access if parameter settings are changed.

MFM0070E: MFA Data Connect not configured - rejecting sd=n ip=addr

Issued by the TCP/IP listener for TCP_PORT when a client connection request for Mainframe Access Data Connect services is received and the Mainframe Access Data Connect server has not been configured in the initialization parameters. The client (from IP address addr on socket n) is disconnected.

Check that the Mainframe Access Data Connect server is enabled by the Mainframe Access FEATURE, MFALINK_MAXTASKS and ASTYPE initialization parameter settings. Restart Mainframe Access if parameter settings are changed.

MFM0071E: process access list check condition client ipaddr

This message may be issued by the TCP/IP port listeners when access list checking is active. If process is XDBTCPM, this is a connection attempt through the TCP_PORT for Micro Focus clients. If process is omitted, this is a connection attempt through the ADMIN_PORT for web browsers. Each client's IP address (ipaddr) is checked against the PERMIT and REJECT specifications in the access list. If the condition reported is "rejected", the client IP address was found to match a reject specification in the access list. In this case the client's connection request is immediately rejected. If the condition reported is "warning for", no matching reject or accept specification was found in the access list. In this case the client connection is accepted. You may wish to add an access list specification for this client or an appropriate range of similar client IP addresses.

MFM0072E: Shutdown starting due to failure (in taskname)

This message is issued when one of the Mainframe Access tasks encounters a software failure and ESTAEX processing is unable to fully recover and guarantee the integrity of subsequent processing in the address space. In this case, the ESTAEX recovery routine processing will start an automatic shutdown of Mainframe Access.

Examine the XDBOUT data set, joblog and system log for associated error messages. This may identify a problem that requires you to take a corrective action. Restart Mainframe Access and report the incident to Product Support.

MFM0074E: The following parameter statement is rejected (line n)

This message is issued during startup when an invalid parameter is found in the Mainframe Access configuration parameter file. The statement containing the invalid parameter is displayed in the message line that follows.

Mainframe Access Server completes processing of the parameter file and then shuts down due to the parameter error. Correct the invalid parameter and restart Mainframe Access Server.

MFM0077E: CG production log (ddname) open failed, errno=n _msgno=m

This message is issued during startup when the data set specified by Mainframe Access configuration parameter CGMQOTMA LOGDD cannot be OPENed. The errno is the SAS/C errno value for the failure. The _msgno is the SAS/C _msgno value that may provide more specific information information about the OPEN failure.

MFM0079I: CG production log closed

This message is issued during shutdown to confirm that the data set specified by the Mainframe Access configuration parameter CGMQOTMA LOGDD has been successfully closed.

MFM0080I: MQ message queue configuration information
MFM0083I: Cross-memory initialization starting (dac=address)

This message is issued during startup when dependent address spaces are configured. Mainframe Access is preparing to create the z/OS cross-memory resources that allow Mainframe Access address spaces to communicate using Program Call. The control region is first to initialize and it establishes the cross-memory environment that allows dependent regions to call back into the control region. As dependent regions initialize (either at startup or on-demand) each dependent creates a cross-memory environment that allows the control region to call into the dependent region. This creates a bi-directional calling mechanism between the control region and each dependent region. The DAC is the primary control table for dependent address space services.

MFM0084I: Cross-memory initialization complete

This message is issued during startup when Mainframe Access has completed the setup of z/OS cross-memory resources that allow Mainframe Access address spaces to communicate using Program Call.

MFM0085I: > Start_Program sent to [rcvd from] stcname (seq=n grp=cccc pgm=cccccccc uid=cccccccc)

This message is issued when Program Call is used to pass a Start Program request to a dependent address space. The control region issues the "sent" form of the message and the dependent region issues the "rcvd" form of the message. seq= is the request sequence number used to correlate the cross-memory activity grp= is the ASGROUP name for the dependent region pgm= is the name of the program to be called uid= is the user id that will provide the program execution security environment

MFM0086I: > Program_Complete sent to [rcvd from] stcname (seq=n ServerRC=n ProgramRC=xxxxxxxx)

This message is issued when Program Call is used to pass a Program Complete indication to the control region. The Program Complete indication returns the result of a Program Call request that was passed to the dependent region. seq= is the request sequence number used to correlate the cross-memory activity ServerRC= is the Mainframe Access return code 0 = the requested program was called and executed succesfully (ProgramRC contains the return code) 1 = the requested program abended (ProgramRC contains the ABEND code) 2 = the dependent region could not load the requested program module 3 = the dependent region Mainframe Access load and call service failed 4 = the call request was not successfully passed to a dependent processing region 5 = the user credentials (userid and password) were invalid ProgramRC= is the return code value from the called program (if the ServerRC is zero)

MFM0087I: Cross-memory environment created

This message is issued during startup to confirm that the z/OS cross-memory Program Call infrastructure was successfully created in this address space.

MFM0088I: Asparm extracted (length=n)
This message is issued during startup of a dependent region to confirm that information needed to establish cross-memory communication was successfully passed from the control region to this dependent region. The asparm data is displayed in dump format following this message.
MFM0089E: Cross-memory start failed (Da_Start rc=n rs=xxxxxxxx)

This message is issued during startup if Mainframe Access is unable to create the z/OS cross-memory Program Call infrastructure.

Mainframe Access ABENDs with code U3100. Contact product support if you cannot resolve the reason for the initialization failure by examining related messages, etc.

MFM0090I: Waiting for server task to initialize

This message is issued during startup when the dependent region has received a request and the required processing task has not yet complete initialization.

This message is issued repeatedly (every second) until the server task completes initialization and is ready to accept the request.

MFM0091I: < Appserver_Started received from stcname (dab=xxxxxxxx)

This message is issued by the control region when a started dependent region has completed its cross-memory initialization and issued a confirming Program Call back to the control region. The dependent's call provides the cross-memory information that the control region needs to Program Call into the dependent region.

MFM0092I: Appserver stcname connected (dab=xxxxxxxx)

This message is issued by the control region when a started dependent region has been successfully contacted by the control region using the dependent's cross-memory Program Call information.

MFM0093E: Appserver stcname connection failed (Da_Conn rc=n rs=xxxxxxxx)

This message is issued by the control region when a started dependent region could not be contacted by the control region using the dependent's cross-memory Program Call information.

Contact product support if this problem persists.

MFM0094I: < Ctlrgn_Acknowledgement received from stcname

This message is issued by the dependent region when the control region contacts the dependent by using the cross-memory Program Call information provided by the dependent.

MFM0095I: < Start_Shutdown received from stcname

This message is issued by the dependent region when the control region uses Program Call to start shutdown processing in the dependent region.

MFM0096I: Cross-memory cleanup complete

This message is issued during shutdown to confirm that all of the z/OS cross-memory resources allocated by this address space have been successfully released.

MFM0097E: Cross-memory cleanup failed (DA_Stop rc=n rs=xxxxxxxx)

This message is issued during shutdown to report that some z/OS cross-memory resources allocated by this address space were not successfully released.

Contact product support if this problem persists.

MFM0098I: Appserver stcname is being shutdown (dab=xxxxxxxx)

This message is issued during shutdown by the control region when an active dependent region is selected to receive a Start_Shutdown Program Call. After the call the PC linkage for the dependent is removed from the control region.

This message is also issued when a dependent region is being shut down in response to a request processing ABEND in that region. When a processing ABEND occurs the control region will shut down the associated dependent region because that address space is considered unstable. For example, storage contents may be corrupted, excessive storage allocations may be accumulating, etc. A new instance of a dependent region will be automatically started when one is needed for subsequent request processing.

MFM0099I: Appserver stcname disconnected (dab=xxxxxxxx)

This message is issued during shutdown by the control region to confirm that the named dependent region has received the Start_Shutdown Program Call and its PC linkage has been removed from the control region.

This message is also issued to confirm the shutdown of an dependent region that has become unstable due to a previous processing ABEND.

MFM0100E: Appserver stcname disconnect failed (Da_Ashut rc=n rs=xxxxxxxx)

This message is issued during shutdown by the control region when the cross-memory linkage to the named dependent region cannot be successfully removed.

Contact product support if this problem persists.

MFM0101I: groupname address space group successfully created (dag=xxxxxxxx)

This message is issued during startup by the control region when the definition for an address space group has been successfully processed. This message confirms that the control structures for managing the group's address spaces have been successfully created. Message MFM0102I follows and displays the parameter values for the group. Address space group definitions are read from the Mainframe Access SERVERS file during initialization.

This message does not confirm that all values in the address space group definition are valid and usable. For example, the JCL procedure name in the definition may not exist in the proclib or the JCL procedure may have syntactical errors that will prevent it from starting.

MFM0102I: groupname - Proc(name) STCprefix(cccc) GroupID(n) Min(n) Max(n) Server(name)

This message is issued during startup by the control region and follows message MFM0101I for a successful address space group creation. This message displays the parameter values from the SERVERS definition for the group.

MFM0103I: groupname is the default address space group

This message is issued during startup by the control region when an address space group definition with GroupID=1 is processed. GroupID=1 specifies that this is the definition for a default group that will be selected if the group name or group id in a request cannot be found in an active address space group definition.

MFM0104I: No default address space group has been defined

This message is issued during startup by the control region when all address space group definitions have been processed and no default group was defined. GroupID=1 is used in a group definition to indicate the default group. There is no requirement to define a default group and system operation can proceed normally without a default group definition. Processing requests that do not specify a valid active group name or group id will be rejected.

MFM0105I: Address space stcname started for group groupname (dab=xxxxxxxx)

This message is issued by the control region when a new dependent address space is started. The stcname is the started task name assigned to the job. The groupname identifies the address space group for which this address space was started.

MFM0106E: Address space for groupname could not be started (Da_Ascre rc=n rs=xxxxxxxx)

This message is issued by the control region when a new dependent address space cannot be started. The return code and reason code from the address space creation routine are reported in the message.

The most common reason, indicated by rc=5, indicates that the maximum number of address spaces defined for the group has been reached. When rc=5 is reported, the request that initiated the address space creation must be queued to wait for one of the existing address spaces to become available.

If rc=5 is frequently reported for your system you should increase the ASMAXIMUM value for the address space group by 1. This allows an additional address space to be started and reduces the queueing delays for client requests. Contact product support if the problem persists.

MFM0107E: Definition failed for group groupname (Da_Mkgrp rc=n rs=xxxxxxxx)

This message is issued during startup by the control region when the control structures for an address space group definition cannot be successfully created.

Mainframe Access ABENDs with code U3100. Contact product support if you cannot resolve the reason for the initialization failure by examining related messages, etc.

MFM0108I: > Start_Tran sent[rcvd] to groupname (seq=n pri=n len=n1+n2 grp=cccc src=n.n.n.n)

This message is issued when Program Call is used to pass a Start Transaction request to a dependent address space. The control region issues the "sent" form of the message and the dependent region issues the "rcvd" form of the message. seq= is the request sequence number used to correlate the cross-memory activity pri= is the priority assigned to the transaction by the originator len= shows the header length (n1) and the content length (n2) grp= is the ASGROUP name for the dependent region src= is the IP address of the originator

MFM0109I: > Tran_Complete sent to [rcvd from] groupname (seq=n ServerRC=n ProgramRC=xxxxxxxx)

This message is issued when Program Call is used to pass a Transaction Complete indication to the control region. The Transaction Complete indication returns the result of a Start Transaction request that was passed to the dependent region. seq= is the request sequence number used to correlate the cross-memory activity

ServerRC is the Mainframe Access return code 0 -> the requested transaction was called and executed succesfully (ProgramRC contains the transaction return code) 1 -> the requested transaction abended (ProgramRC contains the ABEND code) 2 -> the client socket connection could not be obtained by the dependent region

ProgramRC is the return code value from the called transaction program (if the ServerRC is zero)

MFM0110I: Request queued for group groupname (qcount=n dapc=xxxxxxxx rc=n rs=xxxxxxxx)

This message is issued when a request (Start Program or Start Transaction) is received and no dependent address space is immediately available to process the request. The request is queued to the address space group to wait for an available dependent address space. If the maximum number of address spaces for the group have not been started, a new dependent region will be started to process this request. qcount= is the current number of requests waiting in the queue for this address space group dapc= is the address of the control structure that represents the unit of work rc= and rs= are the return and reason code values from the Da_Qwork service .

If this message occurs frequently, your system may perform better if you update the servers definition file for the indicated group. Increasing the ASMAXIMUM value of the group by 1 will provide an additional address space for processing client requests. This should reduce the frequency of request queueing which should result in improved response time for requests that would otherwise be queued.

MFM0111I: SAF logon for userid (sd=n (xxxxxxxx) rc=n type=n aaausr=xxxxxxxx acee=xxxxxxxx)

This message is issued when a user at a Mainframe Access client successfully authenticates by providing a userid and password that are accepted by the z/OS SAF authentication routines. Security resources, including a z/OS SAF ACEE control block, are obtained to create a security environment for this user.

MFM0112I: SAF logoff for userid (sd=n (xxxxxxxx) rc=n type=n)

This message is issued when a previously authenticated user at a Mainframe Access client changes user ids or disconnects from the server. This message confirms that the z/OS SAF ACEE and related security resources have been released.

MFM0113E: SAF error for userid (sd=n (xxxxxxxx) SafRC=n RacfRC=n RacfRS=n

This message is issued when the userid and password submitted by a Mainframe Access client are rejected by z/OS SAF authentication routines. The specific SAF and RACF return and reason codes are reported in the message. The SAF and RACF return and reason code definitions are summarized elsewhere in this seciton.

MFM0114E: Timeout for sd=n n.n.n.n at mm/dd/yy hh:mm:ss, last time: mm/dd/yy hh:mm:ss

This message is issued when a Mainframe Access client is idle for the number of minutes specified by the TIME OUT FOR CONNECTION parameter. The idle client is disconnected and associated resources are released. sd= is the socket number of the client connection n.n.n.n is the IP address of the client mm/dd/yy hh:mm:ss is the date and time when the time out occurred The "last time" is the date and time when the last client TCP/IP activity occurred.

MFM0115E: Access list I/O task initialization has failed

This message is issued during initialization if the access list file (DDNAME XDBACC) is not usable.

Disregard this error message for dependent regions. Dependent regions do not use an access list data set. If the error message is for the control region, examine related Mainframe Access and system message to determine the cause of the error. Contact product support if the problem persists.

MFM0116E: Access list DDname is missing

This message is issued during initialization if a data definition statement for DDNAME XDBACC is not found in the started task JCL.

Disregard this error message for dependent regions. Dependent regions do not use an access list data set. If the error message is for the control region, correct the started task JCL for the Mainframe Access control region and restart Mainframe Access Server. Contact product support if the problem persists.

MFM0117I: Mainframe Access ParmBlock is located at xxxxxxxx

This message is issued during initialization to display the address of the Mainframe Access Server primary control table, the ParmBlock.

MFM0118I: type [parameter definition statement]

This message is issued during initialization to display the active parameter definitions when LIST PARMS=YES is specified in the Mainframe Access startup parameters. All statements from the XDBIN parameter file (type "Parms") and the SERVERS definition file (type "Srvrs") are echoed to the XDBOUT sysout data set.

MFM0119I: Mainframe Access jobname is cccccccc

This message is issued during initialization to display the jobname assigned to this Mainframe Access address space.

MFM0120E: Servers definition for MCOID=mcoid not found sd=n (xxxxxxxx)

This message indicates that an error has occurred while Mainframe Access was processing the initial client request to bind a target CICS region to the current socket connection. The mcoid contained in the client request did not match any of the defined CICS servers and no default CICS server was defined.

Verify that the MCOID is specified correctly in the client configuration. Also verify that the Mainframe Access Server definition for that target CICS system is correct. The "Connect id" in the CICS Resource Definition should match the MCOID in the Mainframe Access Server definition. You may also create a default CICS server definition that is to be used when the client-specified MCOID does not exist. If the definitions are correct and this problem persists, contact Micro Focus Product Support for assistance

MFM0121E: MFA startup error: no DSS environment

When a transaction arrives at an Endevor Dependant Region, MFA will attempt to validate that Global Storage has been assigned for Endevor use. This messages indicates that MFA initialization has failed, and no global work areas have been pre-assigned for Endevor.

MFM0122E: Endevor setup error: No MSGLOG established

When a transaction arrives at an Endevor Dependant Region, MFA will attempt to validate that an Endevor transaction message log has been successfully allocated to this job. This is either dynamically created as jobname.CR_jobname.MFA.ENDEVOR.MSGLOG or pre-defined by the site within the DR started task JCL:

  //ENDVMSG  DD DISP=NEW,DSN=&&MSGLOG,UNIT=VIO,
//            DCB=(RECFM=FBA,LRECL=133,BLKSIZE=13300),
  //            SPACE=(13300,(10,10))

An Endevor transaction cannot be processed without a MSGLOG file.

MFM0123E: Endevor version mismatch between CR and DR

When a transaction arrives at an Endevor Dependant Region, MFA will attempt to validate that the same Endevor API version was used in both address spaces. This is necessary because the Endevor API is not downward compatible. The transaction is aborted if the version does not match. The STEPLIB concatenation must specify the same Endevor load library version in both address spaces.

MFM0124E: No Endevor API modules found

When a transaction arrives at an Endevor Dependant Region, MFA will attempt to load the module ENA$NDVR. This the entry point of the Endevor API. The transaction is aborted if the Endevor API cannot be located.

MFM0125E: name-address Task shutdown forced

Issued during shutdown when one of the Mainframe Access subtasks does end properly. name identifies the type of subtask and address is the address of Mainframe Access' task control block for the process.

This message is normal when the associated task has had a processing failure prior to shutdown. Contact product support if this message appears frequently.

MFM0126E: Tasks (n) forced during shutdown forced

Issued during shutdown when one or more of the Mainframe Access subtasks does not end properly (see message MFM0125E).

This message is normal when the associated tasks have had processing failures prior to shutdown. Contact product support if this message appears frequently.

MFM0128I MCG subtask MCGEXEC cc xxxxxxxx started for XDBMFADM cc xxxxxxxx

This is a normal operational message to log the fact that a new subtask was started for Mainframe Call Generator program execution.

MFM0128E MCG Non-zero return from IGZERRE set call; rc=ddd

The IBM IGZERRE module was called to establish a COBOL run time environment but has indicated there is a problem by returning with a non-zero return code. See the section IGZERRE Entry Conditions and Return Codes in the appendix Mainframe Call Generator for information on the return code values.

MFM0128E MCG Module IGZERRE is not available for set call

This message indicates that the IBM IGZERRE module was not loaded during startup and could therefore not be called to establish a COBOL run time environment.

MFM0128E MCG Non-zero return from IGZERRE reset call; rc=ddd

The IBM IGZERRE module was called to terminate a COBOL runtime environment during Mainframe Call Generator cleanup but has indicated there is a problem by returning with a non-zero return code. See the section IGZERRE Entry Conditions and Return Codes in the appendix Mainframe Call Generator for information on the return code values.

MFM0128E MCG No IGZERRE COBOL environment found for reset

The Mainframe Call Generator cleanup service found that no COBOL environment was previously established for the Mainframe Call Generator session that is ending.

MFM0129E MCG Unable to execute user program cccccccc

An execute request could not be completed for the named program. The preceding error messages will identify the exact cause.

MFM0129E MCG Unable to find or load user program cccccccc

The z/OS BLDL or LOAD operation for the named program failed. The preceding error messages will identify the exact cause.

MFM0129E MCG Request message sequence error

An unexpected Mainframe Call Generator request message was received from the client. The Mainframe Call Generator request is not appropriate for the current state of the remote execution operation. Start the Mainframe Access Server trace facility and recreate the problem to create a log of messages showing the sequence of messages being exchanged.

MFM0129E MCG Request message not recognized

An unexpected request message was received from the client. The request message could not be identified as a Mainframe Call Generator request. Start the Mainframe Access Server trace facility and recreate the problem to log the erroneous message.

MFM0130E MCG cccccccc ABENDed, System=Sxxxx Reason=xxxxxxxx User=Udddd

This message is issued after the Mainframe Call Generator ESTAE extension has trapped and recovered from an ABEND condition. The message provides the system (hexadecimal) or user (decimal) ABEND code. System reason codes are also logged for system ABENDs. If a SYSUDUMP (or SYSMDUMP) DD statement is available to the server, a dump is recorded for the ABEND.

MFM0130E MCG unable to call cccccccc, iSvcRC=dddd iSvcRS=dddd

This message is issued when server preparation for the Mainframe Call Generator call operation encounters an internal logic error. The MD_MCGEXEC_RUN service was called to execute the user program but this service ended with an error indicated by the return code and reason code values. The preceding error messages identify the exact cause.

MFM0130E MCG cleanup failed, iSvcRC=dddd iSvcRS=dddd

This message is issued if the MD_MCGEXEC_CLEANUP service encounters an internal logic error. The preceding error messages identify the exact cause.

MFM0131E Task cccccccc xxxxxxxx TCB xxxxxxxx terminated Udddd; callrtm rc=ddd

This message is issued when a subtask is forcibly terminated by Mainframe Access Server. The Udddd user ABEND code will be U201 for forced terminations of a MCGEXEC subtask. This could occur when the end user logs off or terminates the client while a Mainframe Call Generator session is active.

Parent topic: Mainframe Access Server Messages


Data Set Services Messages

MFMDS001I DSS Server Ready

Mainframe Access has successfully initialized the DSS component. Any pre-allocated item libraries are now ready for use.

MFMDS002I DSS Initialization failed

Mainframe Access failed to initialize the DSS component. The services normally provided by DSS are therefore not available.

MFMDS003I Cell pool build failed

The DSS component was unable to acquire enough virtual memory to build a pool of reusable resources.

Adjust the configuration or memory allocation for the Mainframe Access started task.

MFMDS004I Public File non-VSAM

The DSS component was unable to initialize a shared public file because the file specified was not a VSAM key-sequenced data set. DSS discards the request and continues processing. All item libraries are shared public files.

Ensure that all item libraries are created as VSAM key-sequenced data sets.

MFMDS005I DSS Server shutdown

The DSS server has been successfully shut down as part of the Mainframe Access shutdown procedure.

MFMDS006I DSS Server unidentified request

The DSS server detected an invalid request. DSS discards the request and continues processing.

If you see this message contact our Product Support.

MFMDS008I Online ITEM LIBRARY=data-set-name

The item library named is now online and available.

MFMDS009I Offline ITEM LIBRARY=data-set-name

The item library named has been taken offline and is no longer available.

Adjust the configuration or memory allocation for the Mainframe Access started task.

Ensure that all item libraries are created as VSAM key-sequenced data sets.

If you see this message contact our Product Support.

MFMDS010I DAIR reas/info DSN=data-set-name

DSS encountered a dynamic allocation error while attempting to allocate the specified data set. Here are some possible reason and information codes:

Reason | Info | Description
02xx | Environmental errors: memory or authorization
0352 | 0002 | Invalid data set name
0003 | Invalid member name
0004 | Invalid disposition
1708 | 0002 | Unable to locate data set name in catalog

All reason codes and information codes are in hexadecimal notation. For a full list of errors and further information on z/OS dynamic allocation errors, see Chapter 26 of the IBM manual MVS Authorized Assembler Services Guide.

MFMDS011I TIOT ENQ INTERFERENCE

A dynamic allocation request has been aborted because another system service request within this task has already locked access to the TIOT (Task Input/Output Table). The request will be re-tried after a 50 millisecond delay. For further information on OS/390 Dynamic Allocation errors, refer to Chapter 26 of the IBM publication (GC27-1763) MVS Authorized System Services Guide.

MFMDS012I M=member ENQ FAILURE RC=nnn

A member of a PDS was to be locked for exclusive access by this operation. However, the PDS member could not be locked at this time due to competion from another user. This request has already been retried several times over a three second period, and now the transaction is being aborted due to BLOCKED status. For further information on OS/390 ENQ errors, refer to the IBM publication MVS Assembler Services Reference (GC28-1910).

RC | Description ENQ RET=USE
04 | Resource not available
08 | Task already has control of this resource
12 | Task has previously failed to acquire this resource
MFMDS013E OPEN FAILED FOR SNAP | READER | SYSOUT

A transient file was not opened properly for subsequent use by MFA resource cleanup (SNAP) or job submission (READER) or logging (SYSOUT). The request is aborted. Additional IBM messages may have been displayed on the SYSLOG to explain the nature of the failure. The MFA Direct server continues to run with degraded services.

MFMDS020E Invalid z/OS file format

The file named in the associated message MFMDS031 has a file format that is not currently supported by MFA. This includes such formats as ISAM, HFS files, direct-access keyed files, and various spanned record formats.

MFMDS021E LRECL too high

DSS detected an attempt to write a logical record which exceeded the maximum logical record size for the file named in the associated message MFMDS031.

MFMDS022E Invalid file handle

DSS detected an invalid parameter list passed by a calling program.

If you see this message contact our Product Support.

MFMDS024E Invalid file name

DSS detected an attempt to create an invalid filename.

If you see this message contact our Product Support.

MFMDS026E LRECL EXCEEDS DEFINITION FOR DSN=dsname

During an update operation, a logical record was too large to be written to the selected file. The operation was aborted.

MFMDS029E RECALL FAILURE=nnnnn FOR DSN=dsname

An internal error occurred during an attempt to recall a file from IBM's HSM (Hierarchical Storage Manager). See the product documentation DFSMShsm Managing Your Own Data (SC35-0420) for details.

RC | Description
100 | DFSMShsm not available
400 | Invalid request
402 | Dataset not found
403 | Invalid dataset name
806 | Service module not found
MFMDS030E STOW error RC=nn Reason=nnnn M=member

DSS encountered an error while writing to the PDS directory for the file named in the associated message MFMDS031. The first eight characters of the member name are displayed. Here are some possible return code (RC) and reason values:

RC | Reason | Description
4 | 0 | Member name specified already exists
8 | 0 | Member name specified could not be found
12 | 0 | No space remains in the directory
16 | 01 | Permanent physical error
02 | Unable to add EOF marker to directory
04 | Unable to flush system buffers
3383 | SD37 failure: no secondary space available
3639 | SE37 failure: no secondary space available

For a full list of return codes and reasons, see the IBM manual Macro Instructions f

MFMDS031I DSN=data-set-name

This information message may accompany other system messages to indicate which data set is affected. The data set name appears as a string of up to 44 characters.

MFMDS032E FIND error RC=nn Reason=nnnM=member

DSS encountered an error while locating a member in the PDS directory for the file named in the associated message MFMDS031. The first eight characters of the member name are displayed. Here are some possible return code (RC) and reason values:

RC | Reason | Description
4 | 0 | Member name specified could not be found
4 | Insufficient RACF authority for this request
8 | Share options not granted on this PDSE
12 | This PDSE already open for output on another member
8 | 0 | Permanent physical error
4 | Insufficient virtual storage available
8 | Invalid DEB (data extent block) or data set owned by another task
12 | Physical error on buffer flush
16 | Invalid DCB
MFMDS033E BLDL error RC=nnReason=nnn M=member

DSS encountered an error while building directory information from the PDS directory for the file named in the associated message MFMDS031. The first eight characters of the member name are displayed. Here are some possible return code (RC) and reason values:

RC | Reason | Description
4 | 8 | Member name specified could not be found
8 | 0 | Permanent physical error
4 | Insufficient virtual storage available
8 | 8 Invalid DEB (data extent block) or data set owned by another task

For a full list of return codes and reasons, see the IBM manual Macro Instructions for Data Sets.

MFMDS034E Directory error RC=nn Reason=nnnn

DSS encountered an error while trying to identify the PDS member for the file named in the associated message MFMDS031. Here are some possible return code (RC) and reason values:

RC | Reason | Description
8 | 1012 | No members found in directory
12 | 1041 | Invalid parameter list
1054 | Invalid DEB (data extent block)
1057 | PDS is not open
1058 | Invalid DCB

For a full list of return codes and reasons, see the topic DESERV (Directory Entry Services) in the IBM manual Macro Instructions for Data Sets.

MFMDS035E QSAM abend Sxxx-yy

DSS has detected a QSAM failure and has directed QSAM to ignore the failure. The failure occurred while DSS was processing the file named in the associated message MFMDS031. Sxxx is the abend or system completion code and yy is the reason code. These codes are presented in hexadecimal format. Possible failures include:

Abend | Reason | Description
C37 | 4 | Invalid extents found on end-of-volume
D37 | 4 | No secondary space specified on this file, and the primary space has been entirely used. Reallocate the file to allow secondary extents or a larger primary extent.
E37 | 4 | No secondary space was available on this volume, or the number of extents has already reached 16 for this file. Reallocate the file to use larger secondary extents or move the file to a different volume where space is available.

For a full list of abend codes and reasons, see the IBM manual MVS System Codes.

MFMDS040E VSAM error DD=ddname RC=nn FB=nnn REQ=verb
DSS has detected a VSAM error probably associated with an input/output operation on an item library. Possible values for verb include:
Verb | Description
GET | Read a record
PUT | Write a record
CHECK | Verify completion of an event
POINT | Position to a specific location
ENDREQ | Cancel an operation
ERASE | Erase a record

Common return code (RC) values and feedback code (FB) values include:

RC | FB | Description
8 | 8 | Attempt to store a duplicate key
12 | Conflicting options specified violate stored sequence
16 | Record not found
20 | Physical locking conflict
24 | Volume not available
28 | Insufficient space on volume to extend the
32 | Invalid relative byte address specified
36 | Key range specified in definition excludes this key
40 | Insufficient virtual storage in the Mainframe Access address space
48 | Conflicting options on VSAM request
64 | No virtual storage to handle this level of concurrency
68 | File not open for type of processing requested
72 | Keyed request made to an ESDS
88 | Invalid switch to sequential processing without positioning
92 | Invalid replace or erase without key
96 | Attempt to modify a key on update
104 | Conflicting RPL options
108 | Invalid record length specified
112 | Invalid key length specified
4 | Read error on data component of file
8 | Read error on index component of file
16 | Write error on data component of file
20 | Write error on index component of file

For a full list of return codes and reason codes see the IBM publication DFSMS/MVS Macro Instructions for Data Sets.

MFMDS041E VSAM open error DD-ddname RC=nnFB=nnn

DSS has detected an error while attempting to open a VSAM data set. This message is accompanied by the z/OS system message IEC161I to describe the problem further. Common return code (RC) values and feedback code (FB) values include:

RC | FB | Description
4 | 116 | Warning: file was not closed properly after previous use and has not been recovered using an internal VSAM verify
118 | Warning: file was not closed properly after previous use but has been recovered using an internal VSAM verify
8 | 128 | No DD statement was found for this file
136 | Not enough virtual storage to complete the open processing
144 | I/O error while reading the catalog
152 | RACF denied open access
160 | Inconsistent open options specified
168 | File already open by another user

For a full list of return codes and reason codes see the IBM publication DFSMS/MVS Macro Instructions for Data Sets. VSAM system messages are documented in the IBM manual z/OS System Messages Volume 4.

MFMDS050E DSS services not available

An attempt has been made to use DSS; however, it is not currently available. This may be due to a failure during initialization or configuration, or it may have been terminated during system shutdown while a transaction is still running.

Review the z/OS system log and the Mainframe Access job log and SYSOUT data sets for messages related to the failure. If you need further assistance contact our Product Support.

MFMDS052I CA/PANVALET READY

MFA has initialized full access to CA/Panvalet services.

MFMDS053I CA/ENDEVOR API REL=Brrvvv ESI=a UID=a

MFA has initialized full access to CA/Endevor API services using the release and version specified, and noting whether the External Security (ESI) or Alternate User ID (UID) features are active.

MFMDS054I Librarian Exit Table active

MFA has created a memory table to describe the selected exits to be specified during batch updates against the corresponding Librarian master file.

MFMDS055I MCG/RPC feature (in)active

Indicates whether the MCGLIB DD card was specified as the LOAD library for remote calls as used by the Mainframe Call Generator (MCG) interface.

MFMDS056I ChangeMan DD=CMNxxxx Open failure

Access to site overrides specified for DD=CMNLIB$ and DD=CMNOPTS (to define default build procedures and site options repectively) failed during MFA startup.

MFMDS057I CA/PANVALET member security exit loaded

The user exit MFAPVXIT was found and loaded to provide member-level security for Import, Export, and Directory access calls agains Panvalet master files.

MFMDS058I Librarian ELIPSGEN not found

This site configuration file is used to validate library types and language names for establishing Librarian run-time parameters. Without this information, new objects will default to TYPE=COB.

Parent topic: Mainframe Access Server Messages


MFA Direct Messages

MFA0101I LOGON USER=userid TIME=hhmm DAY=nnn ID=nnnnnnn VER=nn

This information message indicates the time and date that a user session was established with the MFA Direct component. The time is specified using 24-hour clock notation, and the day is the day of the year. The ID represents the relative session number so as to differentiate when the same user has logged on multiple times.

MFA0102I LOGOFF USER=userid ID=nnnnnnn

A user has logged off the system. This message is added to both the MFALOG and the SYSLOG.

MFA0103I AUTH FAIL USER=userid RC=rc RACF=rr/ss

A user logon failed to pass security authorization. The reason codes are tabulated below. MFA also inserts a logon failure message into the AUDIT log. Similarly, an IBM system diagnostic (RACF) may be added to the SYSLOG

RC | RACF | Description
04 | 04/00 | No decision made
04/04 | No RACF profile found
04/08 | Request failed
08 | 08/00 | Not authorized to logon
MFA0105I {AUTH or FAIL} USER=userid INTENT=action AM=method DSN=dsname
where:
action | is READ, WRITE or ALTER
method | is QSAM, BPAM, VSAM, LIBR, PANV, IMS or DB2
dsname | is the file being accessed

The results of a user access attempt are logged in the MFALOG. This provides an audit trail of the individual file accesses processed by MFA Direct. The information is only accumulated for those systems configured with the parameter: MFA_SAF_HISTORY=YES

MFA0111E MFA INVALID DISPATCHING VERB

MFA Direct has been scheduled with an invalid request. The request will not be serviced. This represents an internal protocol error by MFA. Please contact Micro Focus support if the problem persists.

MFA0112E MFA MCB Environment failure

MFA Direct is unable to initialize a new thread due to an unexpected environmental error. The new thread is rejected. Please contact Micro Focus support to report the problem.

MFA0113E MFA TSA already in use

An MFA thread has been unexpectedly re-dispatched while it is still processing a prior request. The new request is rejected. Please contact Micro Focus support to report the problem.

MFA0801E JES/SAPI RC=xx REASON=yy

A request using the JES Sysout API to retrieve a held file from JES spool has failed. Return codes and reason codes are documented in the IBM publication: Using the Subsystem Inferface (SC28-1879) A partial list is provided below:

RC | Reason | Description
08 | Invalid search argument(s)
12 | Unable to process now
16 | Duplicate job name
20 | Invalid destination
32 | Logic error
32 | Conflicting arguments
36 | Invalid destination arguments
40 | Invalid job number
44 | Invalid form
96 | SAPI request header error
36 | Invalid CLASS
40 | Invalid disposition options
MFA0802E I/O ERROR ON INTERNAL READER

A request to submit a job to the JES internal reader has failed. The action is aborted. There may be an associated IBM system diagnostic on the SYSLOG indicating the nature of the failure.

MFA0803E JES SSI ERROR FUNC=xx RC=yy

A request using the JES Subsystem interface has failed. The only functions issued by MFA are FUNC=79 (SYSOUT API) or FUNC=80 (Extended Status API). Return codes and reason codes are described in the IBM publication: Using the Subsystem Interface (SC28-1879) A partial list is provided below:

RC | Description
04 | Function not supported
08 | JES not available
12 | JES does not exist
16 | Fatal error
20 | Logic error
24 | SSI not initialized
MFA0804E JES STATUS RC=xx REASON=yy

A request using the JES Extended Status API to acquire details of the next held output on JES spool has failed. Return codes and reason codes are documented in the IBM publication: Using the Subsystem Interface (SC28-1879) A partial list is provided below:

RC | Reason | Description
04 | Invalid search argument(s)
08 | Logic error
04 | Invalid destination
08 | Job ID low invalid
0C | Job ID high invalid
10 | Job ID high too low
14 | Invalid Job class
20 | Unable to access Job queue
24 | Invalid control structure
28 | Invalid length
2C | Invalid job name
30 | Invalid user name
34 | Invalid system name
MFA1034I CSI CATALOG ERROR nn RC=nnn REASON=nnn (ID) filter

An error occurred within the Catalog Search Interface as provided by IBM as part of the DF/SMS z/OS middleware. The ID represents an internal IBM software module ID, and the filter is the Catalog Search argument derived from the client input. The return codes are described in the IBM publication DF/SMS Managing Catalogs (SC26-7401), but a partial list is shown below. Most other return codes and reason codes are documented as part of IBM System Message IDC3009I and can also be found using the IBM Web Service LOOKAT.

RC | REASON | Description
100 | 04 | Access error on catalog
122 | 04 | Invalid filter key
MFA1035I CATALOG ERROR RC=nnn VOL=volid DSN=dsname

An error occurred attempting to OBTAIN a catlog record for the specified dsname on the specified volume ID. The dsname may no longer be catalogued on that volume, and MFA is unable to determine the file attributes. It is possible that the volume is simply not mounted, or is no longer in active service. This file will be ignored and processing will continue. The return codes are described in the IBM publication DFSMSdfp Advanced Services (SC26-7400)

RC | Description
04 | Volume not mounted
08 | The format-1 DSCB was not found in the VTOC of the specified volume
12 | A permanent I/O error was encountered reading the VTOC of the specified volume
16 | An invalid workarea pointer was encountered
MFA1036I CSI VSAM ERROR RC=nnn REASON=nnn DSN=dsname

An error occurred attempting to use the CSI interface to identify the VSAM attributes of the specified dataset. This file will be ignored and processing continues. The return codes are as described for message MFA1034I.

MFA1037I CSI GDGB ERROR RC=nnn REASON=nnn DSN=dsname

An error occurred attempting to use the CSI interface to identify the file attributes of the specified generation data group. This file will be ignored and processing continues. The return codes are as described for message MFA1034I.

MFA4001E CA/LIBRARIAN ERROR REQ=aaaa RC=nnn

An internal CA/Librarian error occurred while processing the FAIR API request identified as: aaaa={OPN or LOC or MOD or REC or CLS} The return codes are described in the CA licensed documentation CA/Librarian File Access Interface Routines Guide. A partial list is provided below:

REQ | RC | Description
OPN | 1 | Invalid filename or unauthorized
2 | DDname missing
8 | Invalid parameter
9 | Not enough storage to process
LOC | 1 | Required module not found
2 | Caller not authorized for request
6 | Disk access failure
7 | Format error on access
8 | Invalid parameter
9 | Not enough storage to process
MOD | 1 | No modules found
2 | Caller not authorized for request
3 | Module not archived
6 | Disk access failure
7 | Format error on access
8 | Invalid parameter
9 | Virtual storage shortfall
REC | 1 | End of module
6 | Disk access error
7 | Format error on access
8 | Invalid parameter
9 | Virtual storage shortfall
CLS | 81 | Close failed
MFA4002E OPEN FAILED ON LIBRARIAN UPDATE

The system was unable to open a temporary work file for use with the batch update utility AFOLIBR in an attempted Librarian update operation. Additional information may be available on the SYSLOG if an associated IBM internal system problem was encountered. As well, a small MFA snap dump will be issued to provide additional problem determination data. No batch update will be attempted. If you are unable to resolve the problem, open an incident with Micro Focus product support, and include the Snap Dump and the MFALOG as part of the problem description.

MFA4003E WRITE ERROR ON LIBRARIAN UPDATE

The system was unable to write to a temporary work file for use with the batch update utility AFOLIBR. Additional information may be available on the SYSLOG if an associated IBM data access error was encountered. As well, a small MFA snap dump will be issued to provide additional problem determination data. No batch update will be attempted. The probable cause here is an attempt to write a record (from the workstation) which exceeds the logical record size of the work file.

MFA5001E CA/PANVALET ERROR REQ=aaaa RC=nnn MSG=PVnnn

An internal Panvalet error occurred while processing a PAM API request identified as: aaa={OPEN or CLS or READ or SRCH} The return codes and PanValet message numbers are documented within the CA licensed documentation: CA/Panvalet Messages Guide CA/Panvalet System Management Guide An incomplete summary follows:

Message | Description
PV001 | Invalid command
PV002 | Member name invalid
PV003 | Invalid sequence number
PV004 | Excessive parameters
PV005 | Required parameter missing
PV006 | Numeric parameter too large
PV007 | Parameter exceeds 10 characters
PV008 | Unsupported language format
PV009 | Invalid parameter
PV012 | No statement found
PV023 | Name not found
PV032 | Sequence error
PV033 | Library error
PV036 | Access error: member locked
PV043 | Library storage exceeded
PV046 | Panvalet library empty
PV047 | Virtual storage shortfall
PV051 | Invalid Library file
PV066 | Function terminated due to errors
PV070 | Statement truncated
PV095 | Invalid DCB for Library
PV118 | LRECL must be 80 for this language type
PV124 | Invalid file
MFA5002E CA/PANVALET LICENSE FAILURE: access quiesced

This site is not licensed to access the PanValet API. Further attempts to access PanValet will be suspended by MFA to avoid repetitive errors. Contact PanValet support to re-establish your license keys. Re-starting MFA will resume PanValet access attempts.

MFA5003E CA/PANVALET PAN#1 error RC=nnnnn

An internal Panvalet error was encountered while processing a batch update request using the PAN#1 utility. The return codes are described within the CA licensed documentation: CA/Panvalet Messages Guide CA/Panvalet User Guide

MFA5004E I/O ERROR on PANVALET Temporary file

A QSAM error was encountered while writing a temporary file needed as a pre-requisite for the PAN#1 batch update utility. Normally, an IBM system error will appear on the SYSLOG to describe the actual reason, The probable cause is an attempt to write a logical record from the workstation which exceeds the logical record size of the host file.

MFA6001E ENDEVOR API ERROR REQ=aaaa RC=nnn/rrrr/msgid

An Endevor internal processing error occurred while processing an API request identified as: aaaa={ERET or LELM or EADD} A copy of the actual Endevor error message is inserted into the MFALOGE listing if MFA_ENDEVOR_LOGGING is active. The return code, reason code, and Endevor message numbers are described in the licensed CA/Endevor documentation: Endevor for z/OS Messages and Codes Endevor for z.OS API Guide

MFA6002E I/O ERROR ON ENDEVOR TEMPORARY FILE

A QSAM error was encountered while writing a temporary file needed as a pre-requisite for an Endevor API request. Normally, an IBM system error will appear on the SYSLOG to describe the actual reason, The probable cause is an attempt to write a logical record from the workstation which exceeds the logical record size of the temporary file.

MFA6003E SYNTAX ERROR ON ENDEVOR ENVIRONMENT STRING

An invalid environment string was encountered during an Endevor request. The transaction is aborted. Use you client software to re-specify the Endevor prompts and properties correctly.

MFA6004E ENDEVOR INTERFACE ABEND: abend-reason userid session-id

The Mainframe Access ESTAE recovery routines detected an abend while processing an Endevor transaction. The transaction is aborted. The above message appears in the MFALOG showing the diagnostic abend code and reason code.

Parent topic: Mainframe Access Server Messages


Data Connect Messages

MFA100E ESTAE ENTERED ABEND CODE Uxxx/Sxxx

Data Connect has detected an abend. The client software is notified and the dump is normally suppressed. See the MVS console log for additional imformation.

MFA101E LIMIT OF 256 PROCESSES EXCEEDED

Logic within Data Connect can manage up to 256 concurrent sessions. It is unable to retain positioning and recovery information for additional sessions.

MFA110I VTAM PROCESSOR ACTIVE USING VTAMAPPL applid

Data Connect has successfully created a VTAM connection and is available to service message traffic using APPLID=applid.

MFA111W VTAM ACB CLOSE FAILURE

Data Connect was unable to close the VTAM connection successfully. This may be a VTAM environmental problem. See the MVS console log for additional information. Shutdown processing continues without VTAM access.

MFA112I VTAM PROCESSOR HAS TERMINATED

Data Connect is no longer servicing VTAM message traffic. Shutdown processing continues normally.

MFA113E USING VTAMAPPL applid ACB OPEN ERROR X"xx"

Data Connect was unable to open the specified APPLID. Therefore, access cannot be provided to network clients. Common errors are identified as described below.

Error | Description
54 | APPLID not defined to VTAM
58 | APPLID already in use
5A | APPLID inactive to VTAM
MFA114E APPC SESSION REJECTED PRI=xxxxxxxx SEC=xxxxxxxx

Data Connect was unable to complete the logon attempt. See the VTAM APPC documentation for a description of the primary and secondary return codes provided by IBM.

MFA115E MFA DOES NOT SUPPORT 3270 DATASTREAMS

Data Connect does not support LU2 3270 data stream connections. Only APPC VTAM message traffic is supportted.

MFA201W ERROR OPENING DDNAME=VSAMCTL

A file open error was encountered for the VSAM control file. Verify that DDNAME was provided in the Data Connect started task as shown in the sample JCL as MFAS. See the z/OS console log for additional error messages.

MFA202I ERROR READING VSAMCTL FOR membername

A file read error was encountered for the indicated member name. The physical data may be corrupted. See the z/OS console log for additional error information.

MFA299E ADDRESS SPACE NOT AUTHORIZED

The Data Connect modules must reside in an authorized library. The STEPLIB concatenation probably contains at least one load library which is not APF-authorized. Please call your system programmer to authorize your libraries.

MFA301E JCL PARM INVALID OR OMITTED

The parm passed on the // EXEC PGM=MFDSTART,PARM='...' is invalid. The only keyword supported is APPLID=applid. Correct the JCL before resubmitting this job.

MFA302I ATTACHING VTAM PROCESSOR

Data Connect is now initializing APPC access for client messages as relayed through the Host Connectivity interface.

MFA303I MFA/DATACONNECT V4.00 - vers

This message identifies the Data Connect version and copyright information.

MFA310E INVALID OPERATOR REQUEST IGNORED

An invalid operator command was sent to Data Connect. The command is being ignored.

MFA311W PROCESS ALREADY RUNNING

VTAM APPC support is already active. It is not possible to re-cycle commnications while the APPLID is still active.

MFA317I jobname HAS BEEN TERMINATED

The Data Connect task has been successfully terminated.

Parent topic: Mainframe Access Server Messages


Drag and Drop Error Messages

The Enterprise Server Mainframe Access functionality can generate the following error messages:

Error Message | Return code | Description
MFDAS01: Mainframe access problem. | 1001 | A communication problem has been detected. Refer to the MFAERROR.LOG file for more information.
MFDAS02: Cannot import multiple files to a single file. | 1002 | An illogical request has been made, in that the user is attempting to import more than one file into a single file.
MFDAS03: Cannot export multiple files to a single file. | 1003 | An illogical request has been made, in that the user is attempting to export more than one file into a single file.
MFDAS04: Module 'MFLSC' is missing or inaccessible. | 1004 | The required module MFLSC cannot be found. This is most likely an installation problem.
MFDAS05: File had no length, or does not exist. | 1005 | The file had either a zero length, or had been deleted but the display was not refreshed.
MFDAS06: Call to module 'DFCONV' failed. Unable to convert the VSAM/QSAM file. | 1006 | A bad return code was given by the converter program. Run the dfconvwg program on its own to determine the error.
MFDAS07: Value is not a valid number. | 1007 | A non-numeric value was given when a numeric value was expected.
MFDAS08: For VSAM/QSAM files, extensions of PRO, DAT, or IDX are reserved. | 1008 | You cannot use a restricted extension for a file transfer.
MFDAS09: Rename to file failed. | 1009 | An error was returned when trying to rename a file.
MFDAS10: The allocation of failed with message number. | 1010 | An error message has been returned from the COBOL development environment. See the product documentation for a description of the message.
MFDAS11: The allocation of differs from the mainframe. | 1011 | The DCB information for the COBOL development environment dataset differs from that of the mainframe.
MFDAS12: One or more of the fields have not been properly entered. | 1012 | Insufficient or incorrect information has been provided in the panel.
MFDAS13: The PC file name cannot have more than 4 subdirectory levels. | 1013 | The COBOL development environment is unable to support more than 4 subdirectory levels.
MFDAS14: Mismatch between new and repeat passwords. | 1014 | The new and repeat passwords given do not match.
MFDAS15: Unable to make the directory. | 1015 | An error was returned when trying to create a directory.
MFDAS16: Unable to remove directory. | 1016 | An error was returned when trying to remove a directory.
MFDAS17: Call to module 'PCIMS' failed. Unable to convert the IMS database. | 1017 | A bad return code was given by the PCIMS program. Run the PCIMS program on its own to determine the error.
MFDAS18: A catalog search criteria must be entered. | 1018 | You must enter one or more mainframe catalog search criteria. If specifying more than one, then separate them by commas. This catalog search criteria is similar to that when using ISPF 3.4.
MFDAS19: A real workstation drive must be used. | 1019 | The drive selected for the COBOL development environment dataset does not exist on this workstation.
MFDAS22: Call to module 'SQL-Wizard' failed. Unable to convert the XDB table. | 1022 | A bad return code was given by the SQL wizard program. Run the SQL wizard program on its own to determine the error.
MFDAS23: Cannot establish connection to the mainframe server. | 1023 | Unable to connect to the mainframe server.
MFDAS24: Network communication problems with blocks of size. | 1024 | The user's network is unable to transport a data block of the size specified. This is most likely a router configuration problem. To temporarily circumvent the problem, you can specify the MFAMAXSENDLENGTH environment variable, with the value set to a size below the size in error.
MFDAS25: CCI module was not found. | 1025 | The CCI communications file is not found.
MFDAS26: Module is not a CCI module. | 1026 | The module specified is not a CCI communications file.
MFDAS27: Unable to delete file. | 1027 | An error was returned when trying to delete a file.
MFDAS28: Either recall this dataset or assign a type. | 1028 | This dataset is migrated. Either use the right-mouse context to recall it, or assign a specific type.
MFDAS29: Assign a type to this dataset. | 1029 | Unknown DSORG for this dataset. You need to use the right-mouse context to assign a specific type.
MFDAS30: The workstation dataset is connected to the mainframe | 1030 | This workstation dataset you are tying to access is redirection to a mainframe dataset.
MFDAS31: Copy of file failed. | 1031 | Unable to copy from the Windows clipboard.
MFDAS32: Paste of file failed. | 1032 | Unable to paste the file to the Windows clipboard.
MFDAS33: PCIMS is not available. Unable to convert the IMS database. | 1033 | The PCIMS.LBR routines could not be found, or a project was not open.

Parent topic: Mainframe Access Server Messages
Parent topic: Drag and Drop


SAS/C Run-time Library Messages

The SAS/C run-time library issues diagnostic error messages when abnormal conditions or failures are detected. These messages are directed to the SYSTERM and/or SYSPRINT SYSOUT data set. If this data definition is removed from the Mainframe Access JCL, or is unusable for some reason, the SAS/C run-time library sends these messages to the z/OS system log. These messages can help you to diagnose failures. If you do not have SAS/C documentation and you need an explanation for a SAS/C run-time message, try the SAS corporate Web site at http://www.sas.com and search in the Service & Support section for the Online Product Documentation. Mainframe Access uses the SAS/C Release 7.50 run-time library. SAS/C run-time messages are generally identified by the LSCX prefix.

Parent topic: Mainframe Access Messages


Status Codes and Error Messages

This section contains a list of status codes that Mainframe Access servers can return to a client program. It also documents the anomalies in file status settings based upon the environment in which the I/O statements are executed.

Note: For additional information on MFA messages, see your Mainframe Access Administrator's Guide.
  • Status Codes Returned by the MVS Server
  • File Status Comparisons
Parent topic: Mainframe Access Messages


Status Codes Returned by the MVS Server

Table 1. File Status Codes Returned by the MVS Server
Status Code | Description
0/0 | The MVS server returns a status of 0/0 when writing a record to an indexed file which results in two or more records with identical keys. Both IBM VS COBOL II batch processing and Micro Focus COBOL return a status of 0/2 when such a condition arises.
0/5 | A file status 0/5 indicates an open operation was successful, but the file is empty. A file status of 0/5 is returned in some cases where IBM VS COBOL II returns a status of 0/0 and in other cases where IBM VS COBOL II returns a status of 3/5. See the appendix File Status Comparisons for some examples of the conditions under which this status code is returned during open processing.
4/3 | A status code of 4/3 is returned if an attempt is made to delete a VSAM record via an alternate index, if another record in that file contains the same key as the record being deleted.
4/6 | If an I/O operation is attempted which requires a previous I/O operation to have set the current record pointer, and the previous I/O operation failed, a file status of 4/6 is returned. It is also issued if the MVS server loses track of the current record position, probably due to an invalid sequence of I/O statements.
9/100 | A file status of 9/100 is returned if the MVS server receives an operation code that it does not support. This status is also returned when the server attempts to execute a command at a time when that command is invalid. In this case, the operation code received by the server was valid, but the I/O operation was invalid given the type of operation requested and the nature of the previous I/O operations executed for the file.
9/125 | A status code of 9/125 will be returned when the maximum number of concurrent Users has been exceeded.
9/242 | The requested function or component has not been licensed.
Parent topic: Status Codes and Error Messages


File Status Comparisons

This section documents the anomalies in file status settings based upon the environment in which the I/O statements are executed. Expected results, including expected anomalies (for example, the order of records returned when reading an alternate index in reverse order), are not included in this list unless they help clarify the conditions under which the anomalies were detected.

These results were compiled from a set of test programs executed in the following three environments:

  • MVS-batch using IBM VS COBOL II accessing VSAM datasets
  • OS/2 using Micro Focus COBOL accessing sequential
  • Relative and indexed files

The test programs used an extensive combination of file definitions (organization and access mode), open types (INPUT, I/O, OUTPUT, EXTEND, etc.), and I/O verbs for example READ, WRITE, REWRITE) to examine the behavior of execution environment and the results of the file status information returned to the test programs.

In the Cross Reference of File Status Setting table that follows, file status information obtained for the tests in each environment is displayed in the format 'a/b', where 'a' represents the first byte of the file status (file status 1) and 'b' represents the second byte of the file status (file status 2).

For run-time errors, the first byte displayed is '9' and the value for the second byte is the ordinal value of the file status 2 field (e.g. 9/100). When an I/O operation is invalid, a key of 'N/A' is used. When an I/O operation is valid but was not tested because of the results of an earlier I/O operations, a file status of '-/-' is used.

  • Cross Reference of File Status Setting
Parent topic: Status Codes and Error Messages


Cross Reference of File Status Setting

READ SEQUENTIAL TEST WITH EMPTY FILES

FILE ORG-ACC | I/O statements | MVS-BATCH COBOL II | OS/2 MF/COBOL | CICS server
SEQ SEQ | OPEN I/O | 3/5 | 0/5 | 0/5
 | READ NEXT | -/- | 1/0 | 1/0
SEQ SEQ | OPEN I/O REVERSED | N/A | 0/0 | 0/5
 | READ NEXT | -/- | 1/0 | 1/0
REL SEQ | OPEN I/O | 3/5 | 0/5 | 0/5
 | READ NEXT | -/- | 1/0 | 1/0
REL SEQ | OPEN I/O | 3/5 | 0/5 | 0/5
 | START RRN=20 | -/- | 2/3 | 2/3
REL SEQ | OPEN I/O | 3/5 | 0/0 | 3/5
 | START RRN=0 | -/- | 2/3 | -/-
IDX SEQ | OPEN INPUT | 0/0 | 3/5 | 0/0
 | READ NEXT | 1/0 | -/- | 1/0
IDX SEQ | OPEN I/O | 0/0 | 0/5 | 0/0
 | START KEY < VALUE | N/A | 2/3 | 2/3

When Micro Focus COBOL attempts to open a sequential dataset for I/O REVERSED processing and that dataset does not exist, a status code of 3/5 is returned. If the dataset does exist but is empty, a status code of 0/0 is returned on the open request.

WRITE SEQUENTIAL TEST WITH EMPTY FILES

FILE ORG-ACC | I/O statements | MVS-BATCH COBOL II | OS/2 MF/COBOL | CICS server
IDX SEQ | OPEN OUTPUT | 0/0 | 0/0 | 0/0
 | WRITE (RECORD W/DUPLICATE ALT KEY) | 0/2 | 0/2 | 0/0
IDX SEQ | OPEN EXTEND | 0/0 | 0/0 | 0/0
 | WRITE (RECORD W/DUPLICATE ALT KEY) | 0/2 | 0/2 | 0/0

The CICS server cannot determine if the result of this write operation would cause any alternate indexes to have two or more records with the same key value.

DELETE SEQUENTIAL TEST

FILE ORG-ACC | I/O statements | MVS-BATCH COBOL II | OS/2 MF/COBOL | CICS server
IDX SEQ | OPEN I/O | 0/0 | 0/0 | 0/0
 | START ALT KEY GTEQ LOW-VALUES | 0/0 | 0/2 | 0/0
 | DELETE | 0/0 | 0/0 | 1/0

The CICS server does not permit the deletion of a record via the alternate index if another record in the file has the same key for the alternate index. A status code of 4/3 is returned. The current record position is unaffected by the failed request.

RANDOM WRITE TEST

FILE ORG-ACC | I/O statements | MVS-BATCH COBOL II | OS/2 MF/COBOL | CICS server
IDX RAN | OPEN I/O | 0/0 | 0/0 | 0/0
 | WRITE (RECORD W/DUPLICATE ALT KEY) | 0/2 | 0/2 | 0/0

The CICS server cannot determine if the result of this write operation would cause any alternate indexes to have two or more records with the same key value.

READ SEQUENTIAL TEST WITH DATA IN FILES

FILE ORG-ACC | I/O statements | MVS-BATCH COBOL II | OS/2 MF/COBOL | CICS server
IDX SEQ | OPEN INPUT | 0/0 | 0/0 | 0/0
 | START KEY GTEQ HIGH-VALUES | 2/3 | 2/3 | 0/0
 | READ NEXT | -/- | -/- | 1/0

VSAM treats this as: 'position the current record pointer to the end of the file'; a subsequent READ PREVIOUS request would return the last record in the file.

READ DYNAMIC TEST WITH DATA IN FILES

FILE ORG-ACC | I/O statements | MVS-BATCH COBOL II | OS/2 MF/COBOL | CICS server
IDX DYN | OPEN INPUT | 0/0 | 0/0 | 0/0
 | START KEY GTEQ HIGH-VALUES | 2/3 | 2/3 | 0/0
 | READ NEXT | -/- | -/- | 1/0

VSAM treats this as: 'position the current record pointer to the end of the file'; a subsequent READ PREVIOUS request would return the last record in the file.

DELETE DYNAMIC TEST WITH DATA IN FILES

FILE ORG-ACC | I/O statements | MVS-BATCH COBOL II | OS/2 MF/COBOL | CICS server
IDX DYN | OPEN I/O | 0/0 | 0/0 | 0/0
 | START ALT KEY GTEQ LOW-VALUES | 0/0 | 0/0 | 0/0
 | READ NEXT (DUPLICATE KEY) | 0/2 | 0/2 | 0/2
 | READ NEXT (LAST OF DUPLICATE KEY) | 0/0 | 0/0 | 0/0
 | DELETE (LAST OF DUPLICATE KEY) | 0/0 | 0/0 | 4/3

The CICS server does not permit the deletion of a record via the alternate index if another record in the file has the same key for the alternate index. A status code of 4/3 is returned. The current record position is unaffected by the failed request.

Parent topic: File Status Comparisons


Using Enterprise Server with a Mainframe

The information in this section describes how to use the mainframe access functionality from within your Enterprise Server applications.

  • Drag and Drop
  • Remote Job Step Execution
  • Compare and Synchronization Monitor
  • SourceConnect: Mapping a PC Drive to Mainframe Data
Parent topic: Working with Mainframe Files


Drag and Drop

The Drag and Drop utility allows you to transfer files using drag and drop methods, between the mainframe and the PC environments.

The Drag and Drop utility includes:

  • An easy to use, powerful file transfer utility that provides access to workstation files, mainframe files, source code control system members and the mainframe internal reader and output spool.
  • A command line interface to the drag and drop file transfer utility.
  • An application programming interface to the drag and drop command line interface.
  • Starting and Configuring Drag and Drop
  • Using Drag and Drop
  • Exporting Files To the Mainframe
  • Importing Files From the Mainframe
  • Submitting Files To the Mainframe Internal Reader and Accessing Your Jobs
  • Configuring User Exits
  • Drag and Drop Error Messages
Parent topic: Using Enterprise Server with a Mainframe


Starting and Configuring Drag and Drop

Drag and Drop is installed automatically as part of the installation process of your COBOL development environment.

Before you can configure and use Drag and Drop functionality, you need to have configured a mainframe node and configured the cache.

  • Logging On to the Mainframe
  • Completing the Log on to the mainframe dialog
  • Configuring the Developing Environment
  • Configuring the File Translation Behaviour
  • Specifying Editors to Use
  • Activating Librarian
  • Activating Panvalet
  • Activating Endevor
Parent topic: Drag and Drop
Related concepts
Configuring the Cache
Logging On to the Mainframe
Related information
Adding a Mainframe Node
Configure PVCS Drives
Configure Mainframe Drives


Logging On to the Mainframe

Before you can log on to the mainframe, you need to have configured a mainframe node and configured the cache. To log on to the mainframe:

Drag and Drop remembers the details you configure, but for security reasons, not your mainframe password.

  1. Start a 32-bit Net Express command prompt and enter mfdasmx.

    The Log on to the mainframe dialog box is displayed.

  2. Alternatively, in Visual Studio, click Tools > Micro Focus COBOL Tools > Micro Focus Drag and Drop.
  3. Enter the values to configure your session and click OK.

    The Drag and Drop user interface is displayed.

Enter your details as described below and click OK to connect.

Parent topic: Starting and Configuring Drag and Drop
Related concepts
Configuring the Cache
Related information
Adding a Mainframe Node
Starting and Configuring Drag and Drop
Configure PVCS Drives
Configure Mainframe Drives


Completing the Log on to the mainframe dialog

Before you can log on to the mainframe, you need to have configured a mainframe node and configured the cache. To log on to the mainframe:

In the Log on to the mainframe dialog box, the Name pull-down list displays the mainframe nodes that you have defined.

Drag and Drop remembers the details you configure, but for security reasons, not your mainframe password.

Enter your details as described below and click OK to connect.

User-id and Password Prompt
User identification
Specify the user identification to be used for this application. Make sure that your userid has the appropriate dataset authorization.
Current Password

Specify the userid's password.

New Password, Repeat Password
You can change your mainframe password by entering a new one and repeating it in the Repeat field.
Catalog search criteria, delimited by commas
This required field is passed to the mainframe in order to obtain a list of data sets that match the fully qualified name, a partial name, or a name that contains an asterisk for additional matching possibilities. You can specify multiple search criteria in the same line, separated by commas or semi-colons.

The last twenty catalog search criteria items used are available from the drop down list.

Important: When using wildcards, an open search string could return many results and take a long time.
Minutes of inactivity before logoff
The time after which you are automatically logged off the mainframe if no activity A value of zero de-activates automatic logoff.
CCI Communication Type
Select either TCP/IP or VTAM's APPC as your communication method. You must make sure that the appropriate communication stack has been installed.
Standard Server Name (Optional)
Specify the name of the standard mainframe server, as known to the CCI daemon. If you are not using the CCI daemon, and using direct connect TCP/IP instead, then specify the name of the started mainframe task.
Standard Server IP node and Port (Optional)
Specify the machine parameters of any current MFA server that is running. If you are using direct connect TCP/IP then you will need to enter information here. You would enter either the DNS name of your mainframe, or the IP address in the form xxx.xxx.xxx.xxx for the IP node, and the assigned port number of the MFA server in the form yyyy for the port. To determine these values, you can refer to the $MFATCP member in the mainframe INSTLIB dataset.
Standard Server LU name and Mode
Specify the LU name and mode to be used with this APPC connection. Typically, #INTER is the usual mode to be used.
Note: Once connected, you can return to this dialog box by selecting User-id from the Configure menu.

The last twenty catalog search criteria items are kept, and may be selected directly from the drop down list.

The minutes of inactivity before logoff field indicates how many minutes must have gone by, without using your Drag and Drop session, before Drag and Drop will log you off the mainframe. You can specify zero to override and not have this happen.

Finally, the communication protocol information must be given. Typically, your would enter the name of the MFA server in the standard server name field: the name that the CCI daemon knows the mainframe server as. This would generally be enough, but if you are using APPC, or direct connect TCP/IP to the mainframe without the use of the CCI daemon, then some information must be entered for the server machine parameters.

Parent topic: Starting and Configuring Drag and Drop


Configuring the Developing Environment

You can specify additional configuration environmental options using the Environment dialog box. To access this, from the Drag and Drop main screen, select Environment from the Configure menu.

Catalog search criteria, delimited by commas
This required field is passed to the mainframe in order to obtain a list of data sets that match the fully qualified name, a partial name, or a name that contains an asterisk wildcard. You can specify multiple search criteria in the same line, separated by commas or semi-colons. The last twenty catalog search criteria items are available from the drop down list.
Endevor qualification
If you are an Endevor user and have purchased and installed the Endevor support interface add-on product to MFA, then you can access the Endevor system by specifying the proper qualification. It must be in the form, and typically the specification would consist of at least the ENV parameter, and optionally followed by the SYS, SUB, or STG parameters. The JCARD, JMBR and JLIB parameters are only required if your wish to override the defaults already defined in that particular Endevor library. ENV environment SYS system SUB subsystem STG stage id JCARD jobcardmember JMBR EndevorJCLmember JLIB EndevorJCLlibrary You can include quotes around any variables specified in the Endevor qualification area, if so desired. For example, ENV 'PROD' SYS 'ATM' SUB 'USA' would be a valid specification as well as ENV PROD SYS ATM SUB USA. The last Endevor qualifications are kept in the most recently used, first order, and may be selected directly from the drop down. All of these qualifications in the list will appear on the mainframe window.
Use codepage
The workstation code page that is used when performing ASCII to EBCDIC, and EBCDIC to ASCII translations, is sent to the mainframe during the initial connection. The default workstation code page may not be desired for non-North American workstations users.
To enable DBCS support, you must edit the started task JCL procedure; see MFA Started JCL Procedure for more information.

By setting the Use Codepage field to the proper code page, the associated code page is sent to the mainframe, instead of the workstation default one. By setting this field to mainframe default, no code page is sent from the workstation, but instead the default mainframe translate tables located in MFLSCTRN on the mainframe are used instead. The proper tables must have been selected during the mainframe installation of the server.

Limit browse lines to
This numeric field limits the number of lines that will be read and transferred when double clicking on a file or member. If you specify zero, there is no limit.
Default editor specification
You can specify the command and any optional parameters for a default editor to be used, when using the right mouse context button for the edit function. This default editor will be used, unless a Windows editor for the specific file extension has already been set up. You must fully qualify the editor command, include the path and extension of the program to invoke.
Add Command
Click this to add an editor to the Open with popup menu item (which is displayed when you right-click on a file). After clicking Add Command specify the editor's details in the Description, Command and Parameters fields, check Save Mainframe Edits? if appropriate, then click Save Commands.
Delete Command
Click this to delete the selected editor.
Save Commands
Click this to save the changes you have made to any editor definitions.
Reset All Commands
Click this to reset all editor commands to the default . After clicking this button (and clicking Yes on the subsequent confirmation message box), the only editor on the Open with popup menu item is Notepad. Any definitions you have added are lost.
Description
The name that will appear on the Open with menu item for an editor that you have defined. Specifying a single ampersand (&) causes an underscore to be displayed beneath the character following the ampersand, signaling a keyboard shortcut. To display an ampersand you need to specify two consecutive ampersands (&&).
Command
The command to run for the selected editor.
Parameters
The parameters to use on the command line for the selected editor. %s is used to denote the file that is to be edited.
Save Mainframe Edits?
Specifies whether the files changed by the selected editor are exported to the mainframe. This has no effect when using the editor on the PC side.

Configuration Environmental Options
Parent topic: Starting and Configuring Drag and Drop
Related concepts
MFA Started Task JCL Procedure


Configuring the File Translation Behaviour

You can configure the way that files are translated when transferred between the mainframe and the PC. To access the File Translation Behaviour dialog box, select Options from the Drag and Drop screen's Configure menu.

EBCDIC/ASCII translation
Set this flag for each data set type that is to be translated to/from ASCII/EBCDIC.
Warn if the target name does not match the source
Set this flag if you want to be warned that dragging a file or member would result in the target file having a different name from the source file.
Warn if the target exists
Set this flag if you want to be warned when dragging a file or member if the file already exists. Note that there is an overhead when using this flag as the mainframe must be checked for the existence of the file or member.
Warn if the source files contain embedded hex
Set this flag if you want to be informed in an imported source file contains unusual or unprintable characters.
Use MDECONV style embedded hex processing
This method, when selected, will detect all embedded hex values that translate to less than x'20' and insert a null byte in front of each of them. This is the Micro Focus Workbench MDECONV technique, and all Micro Focus COBOL applications will properly detect this.
Inform when submitted jobs have completed
Set this flag if you wish to be informed when your submitted jobstream has finished.
Inform when migrated datasets have been recalled
Set this flag if you want to be informed when a dataset you have asked to be recalled has completed.
Prompt for an extension on import
Set this flag if you want to ensure that a dragged member will be written out with a PC extension.
Refresh workstation member lists after subsetting
Set this flag if you want to force a refreshed member list after using the directory subsetting feature. There is a small overhead to this option.
Refresh mainframe member lists after subsetting
Set this flag if you want to force a refreshed member list after using the directory subsetting feature. There is a small overhead to this option.
Vsam Transfer - use host DCB average record length as default minimum length.
Set this flag if you want the average length, stored in the datasets DCB information on the host, to be used as the minimum length during transfers. This facilitates the case where VSAM fixed length records are used.
Vsam transfer - delete temporary .$_$ and .PRO files after transfer completes
Set this flag if after transferring VSAM files you want to delete the temporary files that were created during the transfer.
Suppress warning for automatic conversion to Micro Focus format
Set this flag to specify that you do not want an informational message box to be displayed each time a file is automatically converted to Micro Focus format.
Member download threshold before warning message is displayed
Specifies the maximum number of data set members that can be expanded before Drag and Drop displays a warning message advising that the operation will take some time.
Build Option Help Sheet Location
Specifies the HTML document to display when the Help button on the User Options tab of the ChangeMan Options dialog box is clicked. The background color of the field changes depending on whether or not the specified file exists; green indicates that the file exists while red indicates that it does not.

For more information see the section Customizing Help for User Options in the chapter Data Access Services in your Mainframe Access Installation and Usage Guide.

Scan imported members for copy statements
Set this flag if you want to have the file or member being dragged from the mainframe checked for copy type statements and allow an automatic import of the related copy files.
Copy Statement Scanner Parameters
When the Scan imported members for copy statements checkbox is checked, the downloaded files are scanned according to the rules in this group. Each rule consists of a description, a regular expression and an enabled flag.

Description is a free-format field and can include any descriptive text. This text appears as part of the title of the selection dialog of found copy members.

Regular expression can contain a UNIX style regular search expression. The most important part is the grouping place holder signified by the contents of the bracket pair. i.e. ([A-Z0-9]*).

  • Add Scan Rule adds a new scan rule to the scan list.
  • Delete Rule deletes the selected rule from the list.
  • Save Rules saves the rules.
  • Reset All Rules resets the entire rule list to Micro Focus Defaults.
  • The Scan Enabled checkbox enables or disables the selected scan rule.

Parent topic: Starting and Configuring Drag and Drop


Specifying Editors to Use

By default, Drag and Drop is configured to use Notepad to edit files. You can, however, use the controls in the Open With Configuration group of the Environment dialog box to specify other editors that you might prefer to use.

To make an editor available for use in Drag and Drop:

  1. Click Environment on the Configure menu.
  2. Click Add Command.

    The Description, Command and Parameters fields are populated with default information.

  3. Update the Description, Command and Parameters fields with information about the editor you want to make available. In the Parameters field, the parameter %s refers to the name of the file to be edited, so you should always include this parameter.
  4. If you are editing a file on the mainframe using a confgured editor, and want the changed file to be sent back to the mainframe, check Save Mainframe Edits?. This has no effect when using this editor on the PC side.
  5. Repeat steps 2 through 4 for any other editors you want to add.
  6. Click Save Commands, then click OK.

    The editors you specified are immediately available for use whenever you right-click on a file and click Open with on the popup menu.

You can also perform the following operations to configure the editors that are available:

  • Update an existing definition for an editor by clicking it in the list of defined editors, modifying its details, then clicking Save Commands.
  • Delete the definition for an editor by clicking it in the list of defined editors and clicking Delete Command.
  • Reset all editor commands to the default by clicking Reset All Commands. After clicking this button (and clicking Yes on the subsequent confirmation message box), the only editor available for use is Notepad. Any definitions you have added are lost.
Note:

When specifying the description, specifying a single ampersand (&) causes an underscore to be displayed beneath the character following the ampersand, signaling a keyboard shortcut. To display an ampersand you need to specify two consecutive ampersands (&&). For example, specifying "&MyEditor" results in "MyEditor" being displayed, while "&&MyEditor" results in "&MyEditor" being displayed.

Parent topic: Starting and Configuring Drag and Drop


Activating Librarian

To activate and use Librarian, you must perform the following steps. Once activated, the Librarian access item will be displayed in the right-hand mainframe window.

  1. Go to the Configure User pulldown, and specify the a catalog search criteria for the Librarian dataset.
  2. In the mainframe window, right-mouse click on the Librarian dataset, and then set the type in Source control to Librarian.
Parent topic: Starting and Configuring Drag and Drop
Related concepts
About Librarian


Activating Panvalet

To activate and use Panvalet, you must perform the following steps. Once activated, the Panvalet access item will be displayed in the right-hand mainframe window.

  1. Go to the Configure User pulldown, and specify the a catalog search criteria for the Panvalet data set
  2. In the mainframe window, right-mouse click on the Panvalet data set, and then set the type in Source control to Panvalet
Parent topic: Starting and Configuring Drag and Drop
Related concepts
About Panvalet


Activating Endevor

To activate and use Endevor, you must perform the following steps. Once activated, the Endevor access item will be displayed in the right-hand mainframe window.

  1. Go to the Configure User pulldown, and specify the correct MFA Endevor server name and machine parms. This will be different then the standard server name and machine parms.
  2. Go to the Configure Environment pulldown, and specify the correct Endevor system in the form of ENV xxx SYS xxx SUB xxx
Parent topic: Starting and Configuring Drag and Drop
Related concepts
About Endevour


Using Drag and Drop

Once Drag and Drop has collected the required information and accessed the mainframe for the data set list, based on the catalog search criteria you supplied, the user interface displays the workstation and mainframe file lists and you can begin using Drag and Drop.

  • The Drag and Drop User Interface
  • Hiding Items from the Mainframe View
Parent topic: Drag and Drop


The Drag and Drop User Interface

The Drag and Drop User Interface displays the following two lists. The left-hand list comprises the accessible drives, directories, files, and source code control systems on the workstation while the right-hand list comprises the mainframe internal reader, Endevor qualifications, and accessible data sets on the mainframe. You can use the right-hand mouse button for a variety of context menus that set values and perform functions. You will need to use this frequently to get the most out of the application.

Workstation and Mainframe File Lists
Parent topic: Using Drag and Drop


Hiding Items from the Mainframe View

Drag and Drop's right-hand pane shows the accessible data sets on the mainframe. When there is a large number of data sets on the mainframe it can be difficult for you to focus on only the data sets you are interested in, so Drag and Drop enables you to hide items from the right-hand pane.

By default, the right-hand pane shows all accessible mainframe items, and in this mode it is referred to as the Active Mainframe Item View. If you do not want to see an item in the Active Mainframe Item View you can hide it by moving it to the Hidden Mainframe Item View. Hiding items does not change them in any way; hidden items are removed from the Active Mainframe Item View and added to the Hidden Mainframe Item View, and you can switch between these two views as and when required. You can restore items from the Hidden Mainframe Item View back to the Active Mainframe Item View, and you can even view hidden items in the Active Mainframe Item View.

Parent topic: Using Drag and Drop


Moving an item to the Hidden Mainframe Item View

To hide an item from the Active Mainframe Item View, right click on it and click Show Hidden Mainframe Item View on the popup menu. The item is removed from the Active Mainframe Item View and added to the Hidden Mainframe Item View. Items in the Hidden Mainframe Item View are displayed the same as they are in the Active Mainframe Item View, but the items' identifying icons are grayed out.

If you hide a parent item, the parent and all of its sub-items are moved to the Hidden Mainframe Item View, and all of their identifying icons are grayed out.

If you hide a sub-item (a PDS member, for example), the sub-item's parent item is also added to the Hidden Mainframe Item View in order to show the sub-item's hierarchy in the Hidden Mainframe Item View. The parent item remains in the Active Mainframe Item View and its identifying icon in the Hidden Mainframe Item View is not grayed out (because it is not hidden).

Figure 1. The Hidden Mainframe Item View
The Hidden Mainframe Item View

For example, in the Hidden Mainframe Item View shown in Figure 9-4, the PDS MFIMIW.DEMO.COBOL and the ChangeMan package WAC5000001 have their identifying icons grayed out indicating that they (and all of their sub-items) are hidden. The icons for MFIMIW.ISPF.ISPPROF and MFIMIW.PROCLIB, however, are not grayed out, indicating that the PDS's themselves are not hidden, but some of their members are.


Switching Between Hidden Mainframe Item View and Active Mainframe Item View

To switch from Active Mainframe Item View to Hidden Mainframe Item View, right-click on any item in the Active Mainframe Item View and click Show Hidden Mainframe Item View on the popup menu.

To switch from Hidden Mainframe Item View to Active Mainframe Item View, right-click on any item in the Hidden Mainframe Item View and click Show Active Mainframe Item View on the popup menu.


Restoring an item to the Active Mainframe Item View

If you have hidden an item but subsequently decide that you want to stop hiding it, Drag and Drop enables you to restore it to the Active Mainframe Item View. To do this, right-click on the item in the Hidden Mainframe Item View and click Restore Item to Active Mainframe Item View on the popup menu.


Showing Hidden Items in the Active Mainframe Item View

If you have hidden an item, Drag and Drop enables you to display it in the Active Mainframe Item View without removing it from the Hidden Mainframe Item View. When you display an item in the Active Mainframe Item View in this way, the item is shown with its identifying icon grayed out to indicate that the item is currently hidden.

When showing hidden items in the Active Mainframe Item View you can control which hidden items you want to display:

  • To display all hidden items in the Active Mainframe Item View, right-click on any item in the Active Mainframe Item View and click Show hidden items > Show All Hidden Items in this view on the popup menu.
  • To only display hidden sub-items for a parent item in the Active Mainframe Item View, right-click on the parent item in the Active Mainframe Item View and click Show hidden items > Show Hidden Items in this folder on the popup menu.

Once you have displayed hidden items in the Active Mainframe Item View you can remove them, again controlling which items you don't want to see any more:

  • To remove all hidden items from the Active Mainframe Item View, right-click on any item in the Active Mainframe Item View and click Show hidden items > Hide all Hidden Items in this view on the popup menu.
  • To only remove hidden sub-items for a parent item from the Active Mainframe Item View, right-click on the parent item in the Active Mainframe Item View and click Show hidden items > Hide Hidden Items in this folder on the popup menu.


Filtering Member Lists

You can apply filters to member lists for partitioned, Librarian, Panvalet and Endevor data sets so that the only members that are displayed are those whose name matches a specified pattern. Two different sorts of filters are available, and you specify them by right-clicking the data set and clicking one of the following options on the popup menu:

  • Set pre-download member filter causes the filter to be applied whenever the data set is downloaded from the mainframe. After specifying a filter in this way Drag and Drop displays the filter pattern in parenthesis following the data set name, but the filter has no effect until the data set is next downloaded from the mainframe. Because this option controls the members that Drag and Drop downloads for a data set, specifying a pre-download filter for a data set that contains a lot of members can significantly reduce the amount of time taken to download the data set.
  • Set post-download member filter causes the filter to be applied to the members that have already been downloaded for the data set. The changes caused by the filter are reflected immediately. The post-download filter is useful to reduce the members displayed for a data set that has already been downloaded so that you can focus on the members you are interested in.

Selecting either of these filter options displays a dialog box in which you specify the pattern to use for the filter. You can use regular expressions or PC-style wildcard expressions to specify the pattern to be used.

You can specify both types of filter for a single data set.


Using the Mouse Buttons

This application uses both the left-hand and right-hand mouse buttons. It cannot be run using only the keyboard.

To expand a workstation drive, workstation directory, mainframe partitioned data set, or mainframe source code control system data set and see the list of files or members within, simply double click on the item with the left hand mouse button, or press the + sign at the start of the line.

To open a browse window and display a file containing the maximum number of lines specified in the configuration options, simply double click on the file or member. Notepad will be invoked, and you may have as many open windows as desired.

To open a file in an editor, right-click on the file and click Open with > editor-name on the popup menu. By default, Notepad is the only editor available. See the section Specifying Editors to use in Drag and Drop for information on specifying alternative editors.

To reset multiply selected items, use the pull down Reset.

For mainframe files, you can obtain a hexadecimal dump format of the file if the translation options for the file type have been turned off; otherwise a character representation is displayed.

The right hand mouse button, when used over the display windows, allows you to get information on the data set, or set the data set or source code control system type, as shown below. Drag and Drop is unable to automatically detect Librarian or Panvalet data sets and must rely on the user to set the proper type. The same is true for VSAM entry sequenced data sets and relative record data sets, unless your mainframe operating system is at a high enough level to support the integrated catalog facility calls. To set the data set type, simply single click over the data set name in the mainframe window and choose the appropriate type from the list. Data set type settings are retained from session to session.

Figure 1. Selection of Data Set Type
Selection of Data Set Type


Multiple Selection

You may select multiple files to be dragged by single clicking on number of items, or by using the shift key and single clicking for a range of items.


Positioning within a Member List

You may reposition either window to a file or member that begins with a specific character, by simply typing the desired character on the keyboard. The appropriate window will be repositioned to the member that comes closest to the specified character. This only works for files or members, not directories or data sets.


Accessing IAM Files

Although Drag and Drop does not include support specifically for Innovation Access Method (IAM) files, you can download IAM files once you have specified them as VSAM. To do this, right-click the host data set, click VSAM, then click the relevant VSAM type. Once you have done this you can download the file as you would normally.


Accessing Endevor Transaction Logs

MFA enables you to view the transaction log for the most recently performed Endevor operation. To view this information, right-click an Endevor item in the right-hand mainframe window and click Display last Endevor Transaction Log on the popup menu.

The lines below show the sort of information that you could expect to see in an Endevor transaction log.

1  (C) 2005 Computer Associates International, Inc.                                                20AUG07 13:36:12       PAGE   1

 13:36:12  API0101I  BEGINNING OF API ACTION PROCESSING
           API0100I  LIST ELEMENT
           API0100I     TO DDNAME: ENDVLIST
           API0100I     MESSAGE DDNAME: ENDVMSG
           API0100I     ENVIRONMENT: MVSTEST
           API0100I     STAGE ID: *
           API0100I     SYSTEM: ADMIN
           API0100I     SUBSYSTEM: UTILS
           API0100I     TYPE: JCL
           API0100I     ELEMENT: *
           API0100I     OPTIONS
           API0100I             PATH: L  RETURN: A  SEARCH: N
           API0100I     WHERE
           API0100I             LAST PROC FAILED:
           API0100I
           API0100I  API ACTION REQUEST DATA SUCCESSFULLY PRINTED
           API0100I
 13:36:12  API0102I  DISPATCHING API ACTION
 13:36:14  API0000I  RETURNED COUNT=00000009, SELECTED COUNT=00000009
 13:36:14  API0000I  PROCESSING COMPLETE - RC=00000 REASON=00000


Exporting Files To the Mainframe

You can export any of the items displayed in the workstation list as follows: place the mouse pointer over the item, single click, hold down the left hand mouse button, drag the mouse pointer over to the appropriate target location in the mainframe window and release the mouse button.

You can drag to any of the following:

  • A sequential data set
  • A partitioned data set
  • A Librarian source code control system
  • A Panvalet source code control system
  • An Endevor source code control system
  • Components in a ChangeMan source control system

You cannot export VSAM files from the workstation to the mainframe, however, you can set up a job stream with JCL and data and submit it to the mainframe internal reader.

Parent topic: Drag and Drop


Importing Files From the Mainframe

You can import any of the items displayed in the mainframe list as follows: place the mouse pointer over the item, single click and hold down the left hand mouse button, drag the mouse pointer over to the appropriate target location in the workstation window and release the mouse button. If you are dragging to the workstation, and hover the drag over a directory, then the directory will be automatically opened or closed for you.

You can drag any of the following:

  • A JES jobstream output
  • A sequential data set
  • A VSAM KSDS (Key Sequenced Data Set)
  • A VSAM ESDS (Entry Sequenced Data Set)
  • A VSAM RRDS (Relative Record Data Set)
  • An unloaded IMS database
  • An unloaded DB2 table
  • A single member of a partitioned data set
  • A several members of a partitioned data set
  • All members of a partitioned data set
  • A Librarian source code control system member
  • Several members of a Librarian source code control system data set
  • All members of a Librarian source code control system data set
  • A Panvalet source code control system member
  • Several members of a Panvalet source code control system data set
  • All members of a Panvalet source code control system data set
  • An Endevor source code control system member
  • Several members of an Endevor source code control system data set
  • All members of an Endevor source code control system data set
  • Components in a ChangeMan source control system

When a VSAM file is dragged to the workstation, Drag and Drop automatically builds the appropriate profile using the mainframe ACB and RPL information, and calls the Micro Focus DFCONV program to convert the dragged file to the proper Micro Focus format.

When an IMS unloaded database is dragged to the workstation, Drag and Drop automatically calls the Micro Focus IMS option, if it exists, to build the workstation version of the database. The mainframe input file, is a sequential variable length file, that has been created by either the Micro Focus IMS unload utility, or any other 3rd party unload utility. You must use the right-hand mouse context menu to set the type of this sequential file to an unloaded IMS database prior to dragging it over to the workstation. Refer to the Micro Focus IMS option for more information.

When a DB2 unloaded table is dragged to the workstation, Drag and Drop automatically calls the Micro Focus SQL option for DB2, if it exists, to build the workstation version of the table. The table must exist and the SQLWizard must be available on the path. The mainframe input file, is a sequential file, that has been created by a standard DSNTIAUL DB2 unload utility. You must use the right-hand mouse context menu to set the type of this sequential file to an unloaded DB2 table prior to dragging it over to the workstation. You must drag the file into a sub-directory, and not a .TAB file. Refer to the Micro Focus SQL option for DB2 for more information.

If you import an individual file or member and you have turned on the configuration option scan imported members for copy statements, the imported member is checked for a variety of copy type statements in the COBOL, PL/I, and 370 assembler languages. If the scan detects the presence of copy statements, an additional dialog box is displayed enabling you to import the copy statements from one or more partitioned data sets or source code control systems, separated by commas.

Figure 1. Copy Statements Detected
Copy Statements Detected
Parent topic: Drag and Drop


Submitting Files To the Mainframe Internal Reader and Accessing Your Jobs

You can submit any of the workstation files to the mainframe internal reader as follows: place the mouse pointer over the item, single click and hold down the left hand mouse button, drag the mouse pointer over to the My jobs item in the mainframe window and release the mouse button. You can see all of your jobs, by double-clicking on the line My jobs. This will display all of your jobs, whether they are waiting for execution, executing, or on the output queues. You can also display the output from your jobs or even drag this output down to the workstation. Note, that you may only access this output, if the job has finished. The use of the right mouse button context menu will allow you to hold, release or cancel one or more of your jobs.

You can drag any of the following:

  • A single file
  • Several of the files in a directory
  • All the files in a directory
Parent topic: Drag and Drop


Using the Command Line Interface

You can access various mainframe services and data sets through the command line interface provided with Drag and Drop.

With the command line interface, you use the MFDAS command with the appropriate parameters. Thes options are described in the following sections.


Providing Your Own Security Exit to The Command Line Interface

The command line interface, will by default, prompt you for the user ID and password to be used for the command. You can, however, provide this to the command line interface, by coding a COBOL GNT module with the name MFDASPWD. This program will be called and will be passed two linkage section items: user ID for 20 bytes and password for 20 bytes. Your exit program can then provide the user ID and password to be used, instead of prompting you for the information:

IDENTIFICATION DIVISION.
PROGRAM-ID. MFDASPWD.
ENVIRONMENT DIVISION.
DATA DIVISION.
WORKING-STORAGE SECTION.
01 Ws1          PIC X.
LINKAGE SECTION.
01 LsUserid     PIC X(20).
01 LsPassword   PIC X(20).
PROCEDURE DIVISION USING LsUserid LsPassword.
P1.
     Move 'MFIUVE' to LsUserid
     Move 'MF081190' to LsPassword
           GOBACK.

After compiling mfdaspwd.cbl, you must place mfdaspwd.gnt into the directory .

Keywords, enclosed in square brackets, are optional. Italicized keywords are user supplied data.


Importing Data

You can import individual members, or a collection of members defined by a filter, from the JES spool, a partitioned data set or source code control system, or you can import entire QSAM, VSAM data sets, IMS databases or DB/2 tables, with automatic data conversion to the appropriate Micro Focus format. You may optionally specify a control file containing one or more commands and allow MFDAS to run them as a batch. To do this, place the commands in a control file of any name, without the preceding MFDAS parameter, then run MFDAS with the parameter @filename, where filename is the name of the control file.

Note: You can configure user exits to perform actions after a successful import.

Text or binary transfers are possible. Use the BINARY or TEXT operand to override the default transfer type for the type. The default transfer type for PDS, Librarian, Panvalet or Endevor is TEXT. The default transfer type for QSAM is BINARY. VSAM, IMS and DB/2 cannot be overridden.

The MEMBER parameter can specify a specific mainframe member name, or can include special filter characters to allow multiple imports to occur based on the special filter characters that you specify. These special filter characters are:

  • * means any characters may follow
  • ? means any character in this position
  • + means the character in this position must be non-blank
  • - means the character in this position must be blank
  • \ means the character in this position must be non-numeric
  • / means the character in this position must be numeric

Example import commands are shown below.

JES

To import from the mainframe JES2 or JES3 spool:

MFDAS IMPORT filename FROM JES
JOB#####|filter

PDS

To import from a Partitioned data set:

MFDAS IMPORT {BINARY | TEXT} filename FROM PDS
pdsname
MEMBER {memname|filter}

Librarian

To import from a Librarian data set:

MFDAS IMPORT {BINARY | TEXT} filename FROM LIB
libname
MEMBER {memname|filter}

Panvalet

To import from a Panvalet data set:

MFDAS IMPORT {BINARY | TEXT} filename FROM PAN
panname
MEMBER {memname|filter}

Endevor

To import from an Endevor data set:

MFDAS IMPORT {BINARY | TEXT} filename FROM END
ENV 'env' SYS 'sys' SUB 'sub'
MEMBER {memname|filter}
STG 'stage'
TYPE memtype
CCID change-control-id
COMMENT user-comment
OVERRIDE SIGNOUT
LOCK=YES

QSAM

To import from a QSAM data set with automatic data conversion:

MFDAS
IMPORT {BINARY | TEXT} filename FROM QSAM
qsamname

VSAM KSDS

To import from a VSAM KSDS data set with automatic data conversion and produce a variable length workstation indexed file. If you wish to produce a fixed length indexed file, then use KSDS-FIXED instead of KSDS.

MFDAS IMPORT filename FROM KSDS
vsamksdsname

VSAM ESDS

To import from a VSAM ESDS data set with automatic data conversion and produce a variable length workstation indexed file. If you wish to produce a fixed length indexed file, then use ESDS-FIXED instead of ESDS.

MFDAS IMPORT filename FROM ESDS
vsamesdsname

VSAM RRDS

To import from a VSAM RRDS data set with automatic data conversion and produce a variable length workstation indexed file. If you wish to produce a fixed length indexed file, then use RRDS-FIXED instead of RRDS.

MFDAS IMPORT filename FROM RRDS
vsamrrdsname

IMS Database

To import from an unloaded IMS database with automatic data conversion and produce a workstation PCIMS format database. Three additional parameters are available after the mainframe IMS unloaded data setname field. These parameters are the required database name, location of segment name in the data record (relative to 1) and the location of the segment data in the data record (relative to 1). If the mainframe database has been unloaded using the Micro Focus PCIMS unload utility, then these three fields are not required, as they are automatically picked up from the mainframe unloaded data set.

MFDAS IMPORT filename FROM IMS
imsunloadedname
[databasename]
[segmentnamelocation]
[segmentdatalocation]

DB/2 Table

To import from an unloaded DB/2 table with automatic data conversion and produce a workstation XDB format table. Three additional parameters are required after the mainframe DB/2 unloaded data setname field. These parameters are the required location, authid, and table name. The mainframe table must have been unloaded into a sequential file using the DSNTIAUL DB/2 unload utility. The table must exist and the SQLWizard must be available on the path.

MFDAS IMPORTfilename FROM DB2
db2unloadedname location
authid tablename


Importing Data with Auto-catalog

When importing files using the MFDAS IMPORT command line you can use the auto-catalog feature so that imported PDS, QSAM, ESDS, RRDS, and KSDS data sets are automatically added into a catalog.

When using the auto-catalog feature, a number of additional new features are available to give you more control over the import and catalog process. To use the auto-catalog feature you specify the /CATLOC=catalog-file-name argument as part of an MFDAS IMPORT command, where catalog-file-name is the catalog file into which the imported data set should be cataloged.

Example:

MFDAS IMPORT c:\mfi01.test.data.txt FROM QSAM mfi01.test.data /CATLOC=c:\proj\catalog.dat


Importing PDS Members

When you use the auto-catalog feature you can import an entire PDS and all of its members, whereas a regular import only supports the import of individual PDS members.

Example:

MFDAS IMPORT c:\mfi01.test.cobol\ FROM PDS mfi01.test.cobol /CATLOC=c:\proj\catalog.dat

Executing this command results in the following files being imported:

  • C:\MFI01.TEST.COBOL\ (PDS folder)
  • C:\MFI01.TEST.COBOL\VSAMDEMO (PDS member)
  • C:\MFI01.TEST.COBOL\VSAMDEM2 (PDS member)

The IMPORT command creates the folder mfi01.test.cobol\ if it does not already exist, adds a catalog entry for the PDS, then imports and catalogs the PDS members into that folder.


Importing Non-Dynamic PDSs

By default, an imported PDS is stored in the catalog as a dynamic PDS.

To import a PDS as a non-dynamic PDS you need to use the /NONDYNAMIC argument.

Example:

MFDAS IMPORT c:\mfi01.test.cobol\ FROM PDS mfi01.test.cobol /CATLOC=c:\proj\catalog.dat /NONDYNAMIC


Detecting the Data Set Type

You can specify the AUTO keyword in place of the data set type to indicate that the type of the imported data set is to be determined from the mainframe catalog. Using this feature means that you don't need to know what the data set type is in order to import and catalog it.

Example:

MFDAS IMPORT c:\mfi01.test.data.txt FROM AUTO mfi01.test.data /CATLOC=c:\proj\catalog.dat


Substituting Data Set Names in the Import Destination

You can use an asterisk in the import location (specified after the IMPORT keyword) to avoid having to manually specify the data set name as part of the target path.

Using an asterisk in the destination path causes the asterisk to be replaced by the data set name.

Example - QSAM:

MFDAS IMPORT c:\data\* FROM AUTO mfi01.test.data /CATLOC=c:\proj\catalog.dat

Executing this command results in the following file being imported:

  • c:\data\MFI01.TEST.DATA

Example - PDS:

MFDAS IMPORT c:\data\* FROM AUTO mfi01.test.cobol /CATLOC=c:\proj\catalog.dat

Executing this command results in the following files being imported:

  • C:\data\MFI01.TEST.COBOL\ (PDS folder)
  • C:\data\MFI01.TEST.COBOL\VSAMDEMO (PDS member)
  • C:\data\MFI01.TEST.COBOL\VSAMDEM2 (PDS member)


Importing Relative to the Catalog File Folder

If the import location that you specify starts with the <catalogfolder> keyword, the keyword is replaced by the path of the folder containing the catalog file specified by the /CATLOC argument.

You must enclose the import location in quotes when using the <catalogfolder> keyword.

Example:

MFDAS IMPORT "<catalogfolder>\data\*.*" FROM AUTO mfi01.test.cobol /CATLOC=c:\proj\catalog.dat

Executing this command results in the following files being imported:

  • c:\proj\data\MFI01.TEST.COBOL\ (PDS folder)
  • c:\proj\data\MFI01.TEST.COBOL\VSAMDEMO.CBL (PDS member)
  • c:\proj\data\MFI01.TEST.COBOL\VSAMDEM2.CBL (PDS member)


Creating a Log File

Use the /CATLOG=log-file-location argument to specify the location of a log file for the auto-catalog process.

You can control the level of messages that are written to the log file by using the /LOGLEVEL=msg-level argument:

  • /LOGLEVEL=ERROR specifies that only error messages are written to the log file.
  • /LOGLEVEL=VERBOSE specifies that additional messages are written.

Specifying /LOGLEVEL=ERROR can significantly reduce the size of the log file.


Performing a Bulk Import

The following steps outline how you could perform a bulk import.

  1. Run the MFDAS CAT command to obtain a list of data sets matching a filter and pipe the output to a file. For example:
    MFDAS CAT mfi01.test.c*> datasets.txt
  2. Create a batch file to run the MFDAS IMPORT command for each entry in the data set list file. For example:
    FOR /F %%A IN (datasets.txt) DO MFDAS IMPORT "<catalogfolder>\data\*.*" FROM AUTO %%A /CATLOC=c:\proj\catalog.dat


Overwriting Existing Catalog Entries

By default, the catalog import command overwrites existing entries in the catalog file unless the imported data set type differs from the data set type in the catalog. You can use the /OVERWRITE=overwrite-status argument to specify the behavior of catalog imports when a catalog entry for a data set already exists:

/OVERWRITE=N
forces the import to fail if a catalog entry for an imported data set already exists in the catalog.
/OVERWRITE=Y
forces any existing catalog entries to be overwritten.


Limiting the Number of VSAM Records to be Imported

Use the /NUMREC=record-number argument to limit the number of records that are to be imported from VSAM files.

Example:

The following command imports an ESDS data set but only downloads the first record:

MFDAS IMPORT "<catalogfolder>\data\*.*" FROM AUTO MFI01.TESTDC.ESDS /CATLOC=c:\proj\catalog.dat /NUMREC=1

Executing this command results in the following file being imported:

  • c:\proj\data\MFI01.TEST.COBOL\MFI01.TESTDC.ESDS.DAT


Importing VSAM Files with Fixed Record Lengths

Use the /FIXEDVSAM argument to import and catalog any VSAM file with a fixed record length.

Example:

MFDAS IMPORT "<catalogfolder>\data\*.*" FROM AUTO MFI01.TESTDC.ESDS /CATLOC=c:\proj\catalog.dat /FIXEDVSAM


Converting to ASCII

By default, imported data sets are imported as binary and remain in EBCDIC encoding. You can use the TEXT keyword to convert them to ASCII.

Specifying the TEXT keyword causes PDS and QSAM data sets to be converted to ASCII (in the process their record format is converted to LSEQ), and the catalog entries for these data sets have charset=A (ascii). You cannot use the TEXT keyword to translate VSAM data sets to ASCII.

Example:

MFDAS IMPORT TEXT c:\data\*.* FROM AUTO mfi01.test.cobol /CATLOC=c:\proj\catalog.dat


Using UNIX Paths in the Catalog

By default, files are added to the catalog with their workstation file location set to the same path they were downloaded to. You can override this path using the /CATOVERRIDE=unix-path argument.

The value of the /CATOVERRIDE argument replaces the <catalogfolder> token when the file is added to the catalog. This enables you to import files to a Windows folder, but store them in the catalog as a Unix path. For this to work, the download target must start with the <catalogfolder> token, as this token is replaced by the value of the /CATOVERRIDE argument.

Example:

The following command downloads the file mfi01.test.data to c:\proj\dir\mfi01.test.data but then sets the catalog entry workstation file location to /user/user1/dir/mfi01.test.data. This happens because <catalogfolder> in the import target is replaced with c:\proj while downloading, but is then replaced with /user/user1/ when adding the entry to the catalog.

MFDAS IMPORT "<catalogfolder>\dir\*" FROM AUTO mfi01.test.data /CATLOC=c:\proj\catalog.dat /CATOVERRIDE=/user/user1/


Exporting Data

You can export individual files, or a collection of files defined by a filter, to a partitioned data set or source code control system, or you can export entire QSAM data sets. You may optionally specify a control file containing one or more commands and allow MFDAS to run them as a batch. To do this, place the commands in a control file of any name, without the preceding MFDAS parameter, then run MFDAS with the parameter @filename, where filename is the name of the control file.

Note: You can configure user exits to perform actions after a successful export.

Text or binary transfers are possible. Use the BINARY or TEXT operand to override the default transfer type for the type. The default transfer type for PDS, Librarian, Panvalet or Endevor is TEXT. The default transfer type for QSAM is BINARY.

The FILENAME parameter can specify a specific workstation file name, or can included special filter characters to allow multiple exports to occur based on the special filter characters that you specify. If you use any of these special filter characters to cause one or more files to be exported, then you must specify the MEMBER parameter as an asterisk (*) as the member name will be replaced by the file name. These special filter characters are:

  • * means any characters may follow
  • ? means any character in this position

Example export commands are shown below.

PDS

To export to a Partitioned data set:

MFDAS EXPORT {BINARY | TEXT} {filename|filter} TO PDS
pdsname
MEMBER memname

Librarian

To export to a Librarian data set:

MFDAS EXPORT {BINARY | TEXT} {filename|filter} TO LIB
libname
MEMBER memname

Panvalet

To export to a Panvalet data set:

MFDAS EXPORT {BINARY | TEXT} {filename|filter} TO PAN
panname
MEMBER memname

Endevor

To export to an Endevor data set:

MFDAS EXPORT {BINARY | TEXT} {filename|filter} TO END
ENV 'env' SYS 'sys' SUB 'sub'
MEMBER memname
TYPE memtype
[CCID change-control-id]
[COMMENT user-comment]
[OVERRIDE SIGNOUT]
[LOCK={YES | NO}]
[COMMENT user-comment]
[BYPASS GEN]
[PGRP processor-group]
Note:

This command always exports to stage 1. You cannot use this command to promote a stage 1 entity to a stage 2 entity.

QSAM

To export to a QSAM data set:

MFDAS EXPORT {BINARY | TEXT} filename TO QSAM
qsamname


Submitting Files

You can submit files, or a collection of files defined by a filter, to the mainframe internal reader for job execution. You may optionally specify a control file containing one or more commands and allow MFDAS to run them as a batch. To do this, place the commands in a control file of any name, without the preceding MFDAS parameter, then run MFDAS with the parameter @filename, where filename is the name of the control file. The format of the submit command is:

The FILENAME parameter can specify a specific workstation file name, or can included special filter characters to allow multiple submits to occur based on the special filter characters that you specify. These special filter characters are:

  • * means any characters may follow
  • ? means any character in this position

Example export commands are shown below.

MFDAS SUBMIT {filename|filter}

You can find out the status of all of your JOBS my issuing the STATUS command to the command line interface. The format of the status command is:

MFDAS STATUS


Locating Data Sets

You can check to see whether a data set exists on the mainframe by using the locate command. A zero return code indicates that the data set exists, and a non-zero return code indicates that it does not exist. You may optionally specify a control file containing one or more commands and allow MFDAS to run them as a batch. To do this, place the commands in a control file of any name, without the preceding MFDAS parameter, then run MFDAS with the parameter @filename, where filename is the name of the control file. The format of the locate command is:

MFDAS LOCATE datasetname


Retrieving Endevor Footprints

You can retrieve an Endevor footprint for one or all members in a PDS. The format of the command is as follows:

MFDAS DIR FOOT endevor.footprint.pds.dsname [FILTER membername]

where:

endevor.footprint.pds.dsname | is the dsname of the PDS containing the Endevor footprints.
membername | is the member whose footprint is to be returned. If omitted, footprints are returned for all members of the PDS.

The footprint information is returned inline in a 76-byte record as follows:

Information | Length
Member name | 16
Endevor type | 8
Date last modified | 8
Time last modified | 9
Version information | 10
Environment | 8
System | 8
SubSystem | 8
Stage | 1


Changing Your Mainframe Password

You can change your mainframe password by entering the following command. A zero return code indicates that the password was changed, and a non-zero return code indicates that it was not successful. You may optionally specify a control file containing one or more commands and allow MFDAS to run them as a batch. To do this, place the commands in a control file of any name, without the preceding MFDAS parameter, then run MFDAS with the parameter @filename, where filename is the name of the control file. The format of the password command is:

MFDAS PASSWORD
newpassword


Specifying Servers, Nodes and Ports

By default, when you run MFDAS from the command line it uses the server, node and port most recently specified by the Drag and Drop interface. You can, however, specify different settings to be used by the MFDAS command line by setting the MFA_SERVER_PARMS environment variable before running mfdas.exe. The format of this environment variable is as follows:

SET MFA_SERVER_PARMS=MFSRV:name,MFNODE:node,MFPORT:portnum

where:

name | is the name of the server to use. The example below specifies a server called MVSSRV.
node | is the URL to use or IP address to use. The example below specifies a URL of MVS.SERVER.COM.
portnum | is the port number to use. The example below specifies port number 6000.

Example:

SET MFA_SERVER_PARMS=MFSRV:MVSSRV,MFNODE:MVS.SERVER.COM,MFPORT:6000


Displaying a Directory List

You can display a directory list of the files or members of the mainframe system catalog, a partitioned data set or source code control system. You may optionally specify a control file containing one or more commands and allow MFDAS to run them as a batch. To do this, place the commands in a control file of any name, without the preceding MFDAS parameter, then run MFDAS with the parameter @filename, where filename is the name of the control file.

The PREFIX parameter indicates that you are interesting in displaying only the members that begin with the specified characters. It is equivalent to using the FILTER parameter of the specified characters followed by an asterisk (*).

The FILTER parameter can specify a specific mainframe member name, or can included special filter characters to allow multiple members to be displayed based on the special filter characters that you specify. These special filter characters are:

  • * means any characters may follow
  • ? means any character in this position
  • + means the character in this position must be non-blank
  • - means the character in this position must be blank
  • \ means the character in this position must be non-numeric
  • / means the character in this position must be numeric

Examples of the directory list command are shown below.

CAT

To list data sets based upon a catalog search criteria:

MFDAS CAT
catalogsearchcriteria

CATDCB

To list the extended attributes for data sets based upon a catalog search criteria:

MFDAS CATDCB
catalogsearchcriteria

PDS

To list members of a partitioned data set:

MFDAS DIR PDS
pdsname [{PREFIX prefix | FILTER filter}]

Librarian

To list members of a Librarian data set:

MFDAS DIR LIB
libraryname [{PREFIX prefix | FILTER filter}]

Panvalet

To list members of a Panvalet data set:

MFDAS DIR PAN
libraryname [{PREFIX prefix | FILTER filter}]

Endevor

To list members of an Endevor data set:

MFDAS DIR END
ENV 'env' SYS 'sys' SUB 'sub'
[{PREFIX prefix | FILTER filter}]
[TYPE type]


Using the Command Line Application Program Interface

You can invoke any of the command line interface options from within a COBOL program by executing the following code. Other programming languages, such as C, can be used to invoke the command line as well.

IDENTIFICATION DIVISION.
PROGRAM-ID. TESTCLIX.
ENVIRONMENT DIVISION.
CONFIGURATION SECTION.
SOURCE-COMPUTER.   IBM-PC.
OBJECT-COMPUTER.   IBM-PC.
DATA DIVISION.
WORKING-STORAGE SECTION.
01 RESULT          PIC X      COMP-X.
01 FUNC            PIC X      COMP-X VALUE 35.
01 COMMAND.
   05 LEN          PIC X      COMP-X VALUE 10.
   05 PGM          PIC X(10) VALUE 'MFDAS.EXE'.
PROCEDURE DIVISION.
   DISPLAY "DIR PDS CSI01.JPD.CNTL" UPON COMMAND-LINE
   CALL X'91' USING RESULT FUNC COMMAND
   IF RESULT = 0
*>    EXECUTE SUCCESSFUL CODE HERE
   END-IF

On return, Drag and Drop sets the COBOL RESULT variable. The following return-codes are produced:

00 | Successful call
01 | An error was returned from MFLSC
14 | The program MFLSC is missing
15 | Call to DFCONV failed
48 | The mainframe member is locked by another user
49 | A mainframe ABEND occurred
50 | A dynamic allocation error occurred when accessing a data set
51 | An open error occurred on the mainframe
52 | An invalid request for a valid function was detected
53 | An I/O error has occurred on a mainframe data set
54 | An invalid sub-code was given to the mainframe
55 | A load error on a program on the mainframe was detected
56 | A length error, at a record level, has been detected
57 | A general security error has been detected
58 | A hash code mismatch has been detected
59 | The remote execution failed
60 | The JES spool file is not an output file
61 | The JES spool file is not a held output file
100 | Syntax error in call
125 | Too many concurrent users are active
139 | The record length was too large
218 | The DCB is not supported. This is usually caused by trying to use RECFM=U
219 | The mainframe load libraries are not APF authorized
220-241 | Various SAF security return codes
242 | The component in use has not been activated on the mainframe
243 | Unable to write the specified file to the workstation
244 | Unable to read the specified file from the workstation
245 | The catalog search detected an error
246 | The catalog search did not yield any results
247 | The /F MFENDDRV* statement was not in FHREDIR.CFG
248 | The /F MFLSCDRV* statement was not in FHREDIR.CFG
249 | The file FHREDIR.CFG could not be located
250 | A communications failure occurred
251 | The file did not have a positive length
252 | An invalid mask was given
253 | The local access mask was not specified
254 | The local access mode was not set
255 | Invalid function was requested


Configuring User Exits

You can use the available user exits to write your own routines.

Parent topic: Drag and Drop


User exit after a successful import

After each successful import of a member from the mainframe, a user exit is called and if it exists, it will be passed the following 3 parameter addresses:

  • A 256 byte area containing the fully qualified name of the workstation file that was just created from the import
  • A 160 byte area containing the mainframe data set name or parameters used in the import
  • A 19 byte area containing the 16 byte mainframe member name used in the import, and a 3 byte field containing ADD if this was a new member being imported, or REP if this was a replacement member being imported.

You may write your own user exit in COBOL if you desire. The name of the program must be MFMONIMP.

IDENTIFICATION DIVISION.
PROGRAM-ID. MFMONIMP.
ENVIRONMENT DIVISION.
CONFIGURATION SECTION.
SOURCE-COMPUTER.    IBM-PC.
OBJECT-COMPUTER.    IBM-PC.
DATA DIVISION.
LINKAGE SECTION.
01 P-WORKSTATION    PIC X(256).
01 P-DATASETNAME    PIC X(160).
01 P-MEMBERAREA.
   05 P-MEMBERNAME  PIC X(16).
   05 P-MEMBERFLAG  PIC X(3).
PROCEDURE DIVISION USING P-WORKSTATION P-DATASETNAME
                         P-MEMBERAREA.
*> EXECUTE CODE HERE
   GOBACK.


User exit after a successful export

After each successful export of a member to the mainframe, a user exit is called and if it exists, it will be passed the following 3 parameter addresses:

  • A 256 byte area containing the fully qualified name of the workstation file that was used in the export
  • A 160 byte area containing the mainframe data set name or parameters used in the export
  • A 19 byte area containing the 16 byte mainframe member name used in the export, and a 3 byte field containing ADD if this was a new member being exported, or REP if this was a replacement member being exported.

You may write your own user exit in COBOL if you desire. The name of the program must be MFMONEXP.

IDENTIFICATION DIVISION.
PROGRAM-ID. MFMONEXP.
ENVIRONMENT DIVISION.
CONFIGURATION SECTION.
SOURCE-COMPUTER.     IBM-PC.
OBJECT-COMPUTER.     IBM-PC.
DATA DIVISION.
LINKAGE SECTION.
01 P-WORKSTATION     PIC X(256).
01 P-DATASETNAME     PIC X(160).
01 P-MEMBERAREA.
   05 P-MEMBERNAME   PIC X(16).
   05 P-MEMBERFLAG   PIC X(3).
PROCEDURE DIVISION USING P-WORKSTATION P-DATASETNAME
                         P-MEMBERAREA.
*> EXECUTE CODE HERE
   GOBACK.


User exit before a workstation delete

If the ALLOW WORKSTATION DELETES option is on, a user exit is called and if it exists, it will be passed the following 1 parameter address:

  • A 256 byte area containing the fully qualified name of the workstation file that is about to be deleted

You may write your own user exit in COBOL if you desire. The name of the program must be MFMONPDL.

IDENTIFICATION DIVISION.
PROGRAM-ID. MFMONPDL.
ENVIRONMENT DIVISION.
CONFIGURATION SECTION.
SOURCE-COMPUTER.    IBM-PC.
OBJECT-COMPUTER.    IBM-PC.
DATA DIVISION.
LINKAGE SECTION.
01 P-WORKSTATION    PIC X(256).
PROCEDURE DIVISION USING P-WORKSTATION.
*> EXECUTE CODE HERE
   GOBACK.
Note: Note:

If you do not want the workstation file to be deleted, ensure that MFMONPDL sets this 256 byte area to an empty string before it exits.


User exit after a workstation delete

If the ALLOW WORKSTATION DELETES option is on, a user exit is called and if it exists, it will be passed the following 1 parameter address:

  • A 256 byte area containing the fully qualified name of the workstation file that was deleted

You may write your own user exit in COBOL if you desire. The name of the program must be MFMONDEL.

IDENTIFICATION DIVISION.
PROGRAM-ID. MFMONDEL.
ENVIRONMENT DIVISION.
CONFIGURATION SECTION.
SOURCE-COMPUTER.    IBM-PC.
OBJECT-COMPUTER.    IBM-PC.
DATA DIVISION.
LINKAGE SECTION.
01 P-WORKSTATION    PIC X(256).
PROCEDURE DIVISION USING P-WORKSTATION.
*> EXECUTE CODE HERE
   GOBACK.


User exit after all synchronization has been done

After each successful logical synchronization (downloads and uploads) has been performed, and prior to the monitor going to sleep until the next wakeup time, a user exit is called if it exists which will be passed 1 parameter address:

  • A 1 byte area containing the value X'00' if no uploads or downloads were done this cycle, X'01' if only uploads were done this cycle, X'02' if only downloads were done this cycle, or X'03' if both uploads and downloads were done this cycle

You may write your own user exit in COBOL if you desire. The name of the program must be MFMONSYN.

IDENTIFICATION DIVISION.
PROGRAM-ID. MFMONSYN.
ENVIRONMENT DIVISION.
CONFIGURATION SECTION.
SOURCE-COMPUTER.    IBM-PC.
OBJECT-COMPUTER.    IBM-PC.
DATA DIVISION.
LINKAGE SECTION.
01 P-FLAG PIC X(1).
PROCEDURE DIVISION USING P-FLAG.
*> EXECUTE CODE HERE
   GOBACK.


Remote Job Step Execution

This chapter describes the Mainframe Remote Job Step Execution (RJSE) facility

  • Introduction
  • Configuring RJSE
  • Using RJSE
Parent topic: Using Enterprise Server with a Mainframe


Introduction

The Remote Job Step Execution (RJSE) facility enables execution of one or more steps of a job on a remote z/OS host. It automatically uploads and downloads required files as necessary with an end result the same as when all steps are executed locally.

Without the help of RJSE, you must execute a job step remotely if the resources required by the step are only available at the remote location. These resources could be any or all of the following:

  • Program(s), including those executed by the step that are either not available locally or are available locally but do not provide the required functions.
  • Special subsystems
  • Proprietary packages
  • Certain devices such as printers
  • Data, including data that is:
    • Too large to move
    • Heavily accessed
    • Stored in a proprietary format (for example, HISAM database)
    • On a special device
Parent topic: Remote Job Step Execution


Configuring RJSE

To use RJSE, you must configure your system as follows:

  1. Enable DataConnect for the project.
  2. Configure server access.
  3. To enable RJSE, set the MF_RCCF environment variable to one of the following values:
    • DELETEJOB - to keep all host job logs and the sysouts that have not been downloaded
    • KEEPJOB - to keep all host job logs and all sysouts
Parent topic: Remote Job Step Execution


Using RJSE

Use can use RJSE with all of its default settings or you can specify your own settings for the following components:

  • Programs
  • Datasets
  • Special DDs
  • RECFM=LSEQ Datasets

RJSE also provides a messaging system to trace execution and alert you of execution errors.

  • Programs
  • Datasets
  • Special DDs
  • RECFM=LSEQ Datasets
  • Host Step Execution Audit Trail
  • Error Messages
Parent topic: Remote Job Step Execution


Programs

Do one of the following to identify programs you want to execute on the host:

  • For each program that you want to execute on the host, code a job step that specifies host execution. Each step can be independent or within a PROC. For example, use a host-compatible JCL extension coded similar to the following:
    //SOMESTEP EXEC PGM=SOMEPGM,PARM='SOMEPARM'
//*MFE: %TYPEXEC=HOST
Parent topic: Using RJSE


Datasets

Datasets specified in steps that are executed on the host can reside either locally or on the host. By default, the RJSE facility automatically uploads or downloads datasets as necessary. However, if you want to override the default for one or more datasets, use the following JCL extensions:

  • %UPLOAD=[ YES | NO | AUTO ]
    • YES Upload the dataset referenced by the DD
    • NO Do not upload the dataset referenced by the DD
    • AUTO Let RJSE determine whether or not to upload the dataset referenced by the DD (default)
  • %DOWNLOAD=[ YES | NO | AUTO ]
    • YES Download the dataset referenced by the DD
    • NO Do not download the dataset referenced by the DD
    • AUTO Let RJSE determine whether or not to download the dataset referenced by the DD (default)
  • %PDSMEM=[ ALL | ONLY ]
    Use this in conjunction with %UPLOAD or %DOWNLOAD. RJSE ignores this setting if the dataset is not a PDS.

    • ALL Upload/Download the entire PDS of the dataset referenced by the DD
    • ONLY Upload/Download only the specified member of the dataset referenced by the DD (default)
Note: RJSE issues messages indicating the actions it performed to create, upload, download, and delete datasets. Use these to fine tune your dataset specifications.
Parent topic: Using RJSE


Special DDs

By default, RJSE neither uploads nor downloads datasets associated with the following DD statements:

  • SYSUDUMP
  • SYSABEND
  • SYSMDUMP
  • CEEDUMP
  • PLIDUMP
  • PL1DUMP
  • SYSCHK
  • SYSCKEOV
  • SORTLIB
  • JOBLIB
  • STEPLIB
  • JOBCAT
  • STEPCAT

You can override this default using the %UPLOAD and/or %DOWNLOAD JCL extensions as appropriate. For more information, see the section Datasets earlier in this chapter.

Parent topic: Using RJSE


RECFM=LSEQ Datasets

By default, when RJSE uploads RECFM=LSEQ datasets to the host, it uploads them as RECFM=FB datasets. To override this default, set the %LSEQRECF JCL extension keyword to specify which type of RECFM datasets to upload:

%LSEQRECF=[ V | VB | F | FB ]

Note: We strongly advise that you assign the LRECL for your local LSEQ dataset to an appropriate non-zero value. If you set the LSEQ dataset to a value of 0, RJSE generates a warning message and defaults to using a value of 80 for F and FB and 255 for V and VB which could lead to execution failures.
Parent topic: Using RJSE


Host Step Execution Audit Trail

For every step executed on the host, RJSE:

  • Issues messages indicating the actions it performed to create, upload, download, and delete datasets
  • Extracts select information from the host job log and inserts it into the local job log for the host-executed step
  • Downloads the host job log and spools it into in the local spool view under the DD name %ZJOBLOG.
Parent topic: Using RJSE


Error Messages

In rare cases, RJSE issues the following error messages:

  • JCLCM0118E Unexpected error from function RJSECA-FC-functionName RC=nnnnnnnn RS=nnnnnnnn.
  • JCLCM0119E Previous JCLCM0118E message is for DD/DSN ddname/datasetname.
  • JCLCM0121S Unexpected return type from RJSECA-FC-Execute %1$s.
  • JCLCM0122S Incorrect password caused SAF failure on the host.
  • JCLCM0123S Expired password caused SAF failure on the host.
  • JCLCM0124S Invalid user id caused SAF failure on the host.
  • JCLCM0125E %1$s is not supported.
  • JCLCM0126E %1$s is not yet supported.
  • JCLCM0127S Host dataset %1$s unexpectedly created by alien job.
  • JCLCM0128S Host dataset %1$s unexpectedly deleted by alien job.
  • JCLCM0129W LRECL of host RECFM F dataset %1$s assumed to be 80.
  • JCLCM0130W LRECL of host RECFM V dataset %1$s assumed to be 255.

If you get any JCLCMnnnns messages, please check the JCLCM Error Messages.

Parent topic: Using RJSE
Related reference
JCLCM Error Messages


Compare and Synchronization Monitor

Compare and Synchronization Monitor allows you to mirror mainframe data sets against either workstation directories, or PVCS archives. This mirroring, known as synchronizing, can occur in either direction, or both directions. Typically, a user would synchronize mainframe partitioned data sets or source control systems with a workstation directory for download.

Parent topic: Using Enterprise Server with a Mainframe


Starting Compare and Synchronization Monitor

You can start Compare and Synchronization Monitor from the Visual Studio user interface or from the command prompt. The command prompt method provides options for configuring Compare and Synchronization Monitor.


Starting Compare and Synchronization Monitor from the User Interface

You must have configured a mainframe server in order to perform this task.
You can use this task to logon to a standard mainframe server, or to an Endevor server.
  1. From the Visual Studio menu, select Tools > Micro Focus COBOL Tools > Micro Focus SynchMon

    The Log on to the mainframe dialog is displayed.

  2. Enter your user identification details and select the mainframe to log on to. The mainframe or mainframe details that you have configured are available in the pull-down lists
  3. Click OK. The Configure options dialog is displayed.
  4. Configure the Compare and Synchronization Monitor options:
    • Use the top section of the dialog to configure the monitor process.
    • Use the Add button at the bottom of the dialog to select the dataset types to be monitored.

      The process involves configuring a series of dialog box options, including the workstation location.

  5. Repeat the process to add all of the types to be monitored.
  6. Click OK to set your options and start the synchronization process. The results of the synchronization process, including any error details are displayed.
Related concepts
Defining a Mainframe Node


Starting Synchmon from the Command Line

To start Compare and Synchronization Monitor from the command line, from the application command prompt, enter the following command:

MFMONMX [options]

where options is any combination of the following options:

/AUTOLOGON
specifies that the Compare and Synchronization Monitor Utility is to call the MFDASPWD user exit. See the section Providing Your Own Security Exit to The Command Line Interface for more information on MFDASPWD.
/CFGFILE=filename
specifies the file (including a path) that contains configuration information to be used by Compare and Synchronization Monitor. If you do not specify this option, Compare and Synchronization Monitor looks for a file called mfmon.cfg first in the current directory, then in the directory containing mfmonmx.exe.
/DATFILE=filename
specifies the name (including full path) of the database.
/ERRFILE=filename
specifies the name (including full path) to use for the error message output file. The default name of this file is MFMON.ERR.
/LOGFILE=filename
specifies the name (including path) to use for the output log file. The default name of this file is MFMON.LOG.
/NOGUI
specifies that Compare and Synchronization Monitor is to run without displaying its graphical interface. If you use this option, you will need to use your operating system's Task Manager to close Compare and Synchronization Monitor.
/NOPROCESS
specifies that Compare and Synchronization Monitor will not try to access the mainframe when started. This enables you to change configuration options when you do not have a mainframe connection.
/PASS=password
specifies the mainframe password to use. Specifying the password and user ID from the command line means you will not be prompted for this information when Compare and Synchronization Monitor starts.
/RULEFILE=filename
specifies the file (including a path) that contains filtering information to be used by Compare and Synchronization Monitor. If you do not specify this option, Compare and Synchronization Monitor looks for a file called monrule.ini first in the current directory, then in the directory containing mfmonmx.exe.
/USER=userid
specifies the mainframe user ID to use.
Note: If you need to start Compare and Synchronization Monitor from a directory other than the one containing mfmonmx.exe, prefix the command with the fully qualified path of the directory containing mfmonmx.exe. For example, if mfmonmx.exe was installed into d:\mfa\bin, use the following command to start Compare and Synchronization Monitor:
d:\mfa\bin\mfmonmx [options]

Once started, the interactive configuration takes place for first time users. Subsequent configuration invocations can take place by using the Configure options pulldown.


Configuring Compare and Synchronization Monitor

Compare and Synchronization Monitor uses a configuration file as input to its processor. This configuration file, MFMON.CFG, contains the necessary statements to allow Compare and Synchronization Monitor to set up the proper synchronization between any number of workstation directories and mainframe data sets, or source code control systems. This configuration file must be located in the directory that you start up the monitor in. This is your current working directory.

You can configure MFMON.CFG in two ways:

  • Using the graphical interactive configuration tools. This is the simplest and recommended method for updating MFMON.CFG in most cases. The configuration tools are accessed from the configure options pulldown or the monitor, and take you through the necessary steps to define your environment. Typically you would click the add button on the bottom of the dialog box to add a new relationship. Online help is available for all dialog boxes within the configuration tool by clicking the Help button.
  • Manual editing. Although you can use the graphical tools to control all aspects of the Compare and Compare and Synchronization Monitor's behavior, there are situations where it is quicker to edit MFMON.CFG manually. For instance, you might want to add a large number of data sets, or you might want to maintain different versions of MFMON.CFG for different purposes.


MFMON.CFG Statements

The statements you can specify in MFMON.CFG are described below.


Allow

Syntax

ALLOW WORKSTATION DELETES

Specifies whether the Compare and Synchronize Monitor is to delete workstation files when it notices that the corresponding mainframe member has been deleted.

Parameters

None

Comments

The default is not to delete the workstation files.


AUTORECONNECT

Syntax

AUTORECONNECT requests

Specifies whether the Compare and Synchronize Monitor is to automatically terminate the connection to the mainframe and then initiate a new connection after a specified number of mainframe server requests.

Parameters

requests
The number of requests to fulfill before initiating a new connection. A typical value is 500.

Comments

The AUTORECONNECT statement is useful to overcome memory leaks that can occur when some mainframe source code control systems and operating system functions are called.


COMMENT

Syntax

* comment

The comment statement is ignored by the Compare and Synchronize Monitor. Any statement beginning with an asterisk '*' is treated as a comment.

Parameters

comment Any text.


MONITOR

Syntax

MONITOR[PVCS]
[BINARY]
direction [PREFIX filter]
dataset-type
drive:\directory\*.ext
AGAINST mainframe-parameters

Specifies which workstation directories (when MONITOR is used) or PVCS archives (when MONITORPVCS is used) are to be monitored against which mainframe data sets or source code control systems. Any number of these statements can be placed in the configuration file as desired.

Parameters

BINARY
Specifies that you do not want the Compare and Synchronize Monitor to perform any EBCDIC/ASCII translation. This option is useful if you have a PDS containing binary data, and is only available if you have set dataset-type to PDS or PARTITIONED. Synchronization of binary members is based on time stamps.
direction
The directions that the Compare and Synchronize Monitor is to monitor. This can be one of:
  • NONE

    Monitor, but do not allow an upload or download to occur. This produces a report only.

  • DOWNLOAD

    Monitor, but do not allow an upload to occur. This will allow download synchronization to occur.

  • UPLOAD

    Monitor, but do not allow a download to occur. This will allow upload synchronization to occur. This option is not applicable if dataset-type is VSAM-KSDS, VSAM-KSDS-FIXED, VSAM-ESDS, VSAM-ESDS-FIXED, VSAM-RRDS or VSAM-RRDS-FIXED.

  • BOTH

    Monitor, and allow both uploads and downloads to occur. This option is not applicable if dataset-type is VSAM-KSDS, VSAM-KSDS-FIXED, VSAM-ESDS, VSAM-ESDS-FIXED, VSAM-RRDS or VSAM-RRDS-FIXED.

filter
A specific member name or filter characters to specify a collection of members to be monitored. You can embed the filter characters with any other characters for pattern matching of the member name, similar to the usage of the wildcard characters on the workstation dir command:
  • * any character may follow
  • ? any character in this position
  • + the character in this position must be non-blank
  • - the character in this position must be a blank
  • / the character in this position must be numeric
  • \ the character in this position must be non-numeric

The value for filter can be from 1 to 16 characters long.

This parameter is optional when dataset-type is PDS (or PARTITIONED), LIBRARIAN, PANVALET and ENDEVOR, and is not applicable when dataset-type is set to anything else.

dataset-type
The type of the mainframe data set for which a monitoring relationship is to be built. This can be one of:
  • PDS

    Partitioned data set. Specifying PARTITIONED has the same effect as specifying PDS.

  • LIBRARIAN

    Computer Associates Librarian data set.

  • PANVALET

    Computer Associates Panvalet data set.

  • ENDEVOR

    Computer Associates Endevor data set.

  • SEQUENTIAL

    Sequential data set.

  • VSAM-KSDS

    Keyed (VSAM KSDS) data set. You cannot use MONITORPVCS when dataset-type is set to VSAM-KSDS.

    Set dataset-type to VSAM-KSDS if you want to monitor Innovation Access Method (IAM) files.

  • VSAM-ESDS

    Entry (VSAM ESDS) data set. You cannot use MONITORPVCS when dataset-type is set to VSAM-ESDS.

  • VSAM-RRDS

    Relative (VSAM RRDS) data set. You cannot use MONITORPVCS when dataset-type is set to VSAM-RRDS.

  • VSAM-KSDS-FIXED

    Keyed (VSAM KSDS) data set, where the resulting imported file is converted to Micro Focus format in fixed format, with the minimum record length set to the maximum record length. You cannot use MONITORPVCS when dataset-type is set to VSAM-KSDS-FIXED.

  • VSAM-ESDS-FIXED

    Entry (VSAM ESDS) data set, where the resulting imported file is converted to Micro Focus format in fixed format, with the minimum record length set to the maximum record length. You cannot use MONITORPVCS when dataset-type is set to VSAM-ESDS-FIXED.

  • VSAM-RRDS-FIXED

    Relative (VSAM RRDS) data set, where the resulting imported file is converted to Micro Focus format in fixed format, with the minimum record length set to the maximum record length. You cannot use MONITORPVCS when dataset-type is set to VSAM-RRDS-FIXED.

drive:\directory\*.ext
When using MONITOR, specify the fully qualified path and name of the workstation files to complete the monitor relationship. You must specify the specific extension, such as *.CBL, to be monitored against.

If you specify the extension as three asterisks (***), the download initially downloads the file with no extension. If the file extension is then changed, the next synchronization operation finds the first matching filename with any extension. Only one file with the same filename can exist in the target directory. For example, if a host PDS member name is ACCTOPEN and no file with the prefix ACCTOPEN exists in the PC target directory, the file is downloaded as ACCTOPEN. If the extension is then modified to ACCTOPEN.CBL, the next synchronization detects the target filename as ACCTOPEN.CBL and synchronizes against that.

When using MONITORPVCS, specify the fully qualified location of a PVCS archive configuration file to complete the monitor relationship. This is the name of the archive in the usual archivename.cfg format.

mainframe-parameters
Parameters defining the data sets on the mainframe. The parameters to be specified vary depending on the setting of dataset-type:

  • When dataset-type is PDS, PARTITIONED, SEQUENTIAL, VSAM-KSDS, VSAM-KSDS-FIXED, VSAM-ESDS, VSAM-ESDS-FIXED, VSAM-RRDS or VSAM-RRDS-FIXED, the format of mainframe-parameters is as follows:
    dataset
EXTENSION=extension
    where the parameters are:
    • dataset The name of the dataset to be monitored.
    • extension The extension of the datset to be monitored. This is optional.
  • When dataset-type is ENDEVOR, the format of mainframe-parameters is as follows:
    ENV 'environment' SYS
'system' SUB 'subsystem'
STG 'stage' TYPE=type
CCID=ccid COMMENT=comment
EXTENSION=extension

    where the parameters are:

    • environment

      The Endevor environment to be monitored.

    • system

      The Endevor system to be monitored.

    • subsystem

      The Endevor subsystem to be monitored.

    • stage

      The Endevor stage to be monitored. Must be 1 or 2.

    • type

      The Endevor type to be monitored.

    • ccid

      Change control ID.

    • comment

      Comment text.

  • When dataset-type is LIBRARIAN or PANVALET, the format of mainframe-parameters is as follows:
    dataset
[TYPE=type]
EXTENSION=ext

    where the parameters are:

    • dataset

      The fully qualified name of the data set to be monitored.

    • type
      Optional specific member types for your monitor relationship (if your installation has been set up to use valid Panvalet or Librarian types on the mainframe). You can specify a specific type, or use filter characters to be creative about a collection of types to be monitored. You can embed the filter characters with any other characters for pattern matching, similar to the usage of the wildcard characters on the workstation dir command: * any character may follow
      • ? any character in this position
      • + the character in this position must be non-blank
      • - the character in this position must be a blank
      • / the character in this position must be numeric
      • \ the character in this position must be non-numeric
  • ext

    The extension of the files to be monitored.


PERFORM

Syntax

PERFORM
nnnn TIME[S]

Specifies the number of times the Compare and Synchronize Monitor is to perform the analysis scan.

Parameters

nnnn
The number of times to perform the analysis scan.

Comments

If you do not specify a PERFORM statement, monitoring takes place indefinitely


STARTUP

Syntax

STARTUP
hh:mm

Specifies that the Compare and Synchronize Monitor is to start up at a specified time.

Parameters

hh:mm
The time at which the Compare and Synchronize Monitor is to start up. The format is in 24-hour time, so must be in the range 00:00 through 23:59.

Comments

If you specify a time that has already elapsed today, the task starts the following day. The STARTUP statement is generally used in conjunction with the WAKEUP statement.


TITLE

Syntax

TITLE
title-text

Specifies the text to display in the Compare and Synchronize Monitor title bar. This allows you to easily identify a specific monitor session from the task list.

Parameters

title-text
The text to be displayed in the title bar.


TRANSFERLIMIT

Syntax

TRANSFERLIMIT
limit

Specifies a limit on the number of imports or exports the Compare and Synchronize Monitor performs per cycle.

Parameters

limit
The number of of imports or exports to perform per cycle.

Comments

If you do not specify a TRANSFERLIMIT statement, all required files are transferred.


WAKEUP

Syntax

WAKEUP
nnnn {SECOND[S] | MINUTE[S] | HOUR[S] |
DAY[S]}

Specifies how long the Compare and Synchronize Monitor is to remain dormant after the initial analysis has completed but before analyzing the environment for subsequent changes to be processed.

Parameters

nnnn
The number of seconds, minutes, hours or days to wait between completing the initial analysis and analyzing the environment for subsequent changes.

Comments

If you do not specify a WAKEUP statement, the default is to remain dormant for 8 hours.


Example MFMON.CFG Statements

The following examples show typical statements that might be used in an MFMON.CFG file:

  • To monitor a workstation directory for files that have an extension of CBL against a partitioned data set for both upload and download:
    MONITOR BOTH PARTITIONED
C:\DEMO\*.CBL AGAINST SYS1.COBOL.SOURCE
  • To monitor a Librarian data set for download only for all members beginning with ABC:
    MONITOR
DOWNLOAD PREFIX ABC LIBRARIAN C:\DEMO\*.* AGAINST LIBR.MASTER
  • To monitor an Endevor data set for both upload and download for all members in of Endevor type CBL:
    MONITOR BOTH ENDEVOR C:\DEMO\*.CBL AGAINST ENV
'PROD' SYS 'SYST' SUB 'SUBS' TYPE=CBL CCID=userccid
COMMENT=user.comment.field


Log Output

All successful actions and files that were successfully transmitted will be logged in the output log named MFMON.LOG.


Error Message Output

All errors and files that were not successfully transmitted will be logged in the error message output log named MFMON.ERR.


ChangeMan Additional Features

This section highlights the Drag and Drop features that are specific to supporting ChangeMan. The information provided here assumes you are already familiar with concepts of Drag and Drop, ChangeMan, and the environment in which they are being used.

Note:

If you are interested in using this new support, please contact Micro Focus SupportLine for information on enabling it.


Specifying the ChangeMan Packages to Use

Before using ChangeMan you need to specify what packages you want to work with.

To specify the packages:

  1. Click Configure > Environment.

    The Environment dialog box opens.

  2. In the ChangeMan Package ID field either type the 10 character ChangeMan package ID or select it from the drop-down list.
  3. Check ChangeMan - No Suffixes if you do not want to use filename suffixes when components are checked out to your PC. When unchecked, the name of the component in the PC file system is shown with its type appended, similar to a standard file extension.
  4. Click OK.

    The Environment dialog box closes and the changes are applied.


Checking Out ChangeMan Baseline Components

To check out a baseline component you can use either a drag and drop, or a copy/paste operation.

During the check out process a ChangeMan baseline component is replicated from its baseline library to the folder on your PC. A copy is also automatically added to the associated package. If the selected component has already been checked out it will still be transferred to the PC, but the copy to the package does not occur. You can use this technique to refresh the copy on your PC.

Figure 1. The Check Out Baseline Dialog Box
The Check Out Baseline Dialog Box

Figure 0-8 shows the Check Out Baseline dialog box that opens when you check out a component. The dialog box displays information about the component being copied, and lets you specify some criteria to use for the check out and check in operations.

Component Name | The name of the component being checked out.
Component Type | The type of component being checked out.
Baseline Level | Specify the basesline level of the component you want to check out, where 000 is the current baseline, and -01 and -99, for example, are previous versions. The availability of previous versions depends on the arrangements and configuration at your site.
Lock this component | Check this to put an exclusive lock on the component, preventing others from checking it out.
Overlay Prior Version on Check In | Check this to overwrite the previous version when the component is next checked in.
Save Prior Version on Check In | Check this to save the component as a new baseline version when it is next checked in. The version number of the existing baseline version will be reduced by 1.
Suppress Notify | Check this to suppress the sending of notifications to other users of the components. When unchecked, TSO warning messages are sent to affected users.
Figure 2. The Enter the Required Information Dialog Box
The Enter the Required Information Dialog Box

Figure 0-9 shows the Enter the required information dialog box that opens during the check out operation. Use the text field in this dialog box to specify a different name for the component when it is stored on the PC.


Checking In ChangeMan Components

To check in a changed component from your PC you can use either a drag and drop or a copy/paste operation. If suffixes are not being used, ensure that the drop or paste target is in the appropriate folder type for the component in the current package.

Figure 1. The Enter ChangeMan Check-In Parameters Dialog Box
The Enter ChangeMan Check-In Parameters Dialog Box

Figure 0-10 shows the Enter ChangeMan Check-In Parameters dialog box that is displayed when you check in a component. The dialog box displays information about the component being moved and lets you specify some criteria used for the check-in operation.

Component Name | The name of the component being checked in.
Component Type | The type of component being checked in.
Change Description | Enter a brief description of the changes you made to the component.
Lock | Check this to lock the component after it is checked in.
Save Prior Version | Check this to create a staging version of the previous component. If not checked, the new version of the component will replace the previous one.
Activate | Check this to validate the check-in operation. No files are moved but possible problems are reported. For example the component may already be in use for another package or your rights may have been revoked due to a recent promotion of the same component.
Supress Notify | This function is not enabled


Building a Component

Once you have made changes to a component and have checked the latest version back in to the package, you can build it.

  1. Right-click on the component you want to build and select Build Component.

    The ChangeMan Options dialog box shown in Figure 0-11 opens. You should not need to change any of the options because they are set automatically using the component's history, or in the case of a new component predefined settings are used.

  2. Click OK to build the component.
Figure 1. The ChangeMan Options Dialog Box
The ChangeMan Options Dialog Box


Customizing Help for User Options

The User Options tab of the ChangeMan Options dialog box enables you to specify settings for up to 20 user options. Clicking Help on the User Options tab displays an HTML document that you can edit to provide information about the user options used in your organization.

The HTML document displayed by default is help\HelpTemplate.htm. You can either update this file to specify the relevant details for your user options or create a different HTML file and use that. If you create a new HTML file you must specify it in the Build Option Help Sheet Location field of the Options dialog box. (Click Configure > Options to display the Options dialog box.) The background color of the Build Option Help Sheet Location field changes depending on whether or not the specified file exists; green indicates that the file exists while red indicates that it does not.

If the file specified in Build Option Help Sheet Location does not exist or cannot be opened, clicking Help on the User Options tab of the ChangeMan Options dialog box displays the default HTML document (help\HelpTemplate.htm).


SourceConnect: Mapping a PC Drive to Mainframe Data

You can use SourceConnect to map a PC drive to a mainframe dataset. You can then access mainframe files and resources from a PC, or from applications running on a PC.

  • Configuring SourceConnect
Parent topic: Using Enterprise Server with a Mainframe


About SourceConnect

You use SourceConnect, to define mainframe datasets, or PVCS, so that they appear to Micro Focus applications as a normal workstation drive and directory structure. All mainframe source type datasets, such as PDS's, Librarian and Panvalet datasets, are available through SourceConnect. SourceConnect automatically filters out other datasets, such as sequential datasets, VSAM, and PDS's that are of record format U.

In addition, PVCS files are also handled by SourceConnect, which allows all of the SourceConnected applications to be able to access the various files within the PVCS archives as simply as accessing workstation drives and directories.

SourceConnect provides full security as well as data integrity in this cooperative mainframe/workstation environment. Security is maintained through the standard mainframe SAF mechanisms, such as RACF, ACF/2 or Top Secret. Data integrity is maintained through the SourceConnect interfaces with the mainframe.

By using SourceConnect, you can leave your source on the mainframe, and dynamically access it using Micro Focus tools that are SourceConnect enabled.


Controlling the Location of Files

When using SourceConnect to access source files on a mainframe, there will be files you want SourceConnect to read to and write from on the mainframe, but also files that you want to keep locally. SourceConnect uses mechanisms to enable you to control which files are based on the mainframe and which are workstation based.

When you edit your configuration to specify the mainframe files you want to be able to use, one of the entries you add is extensions. A file on the workstation with an extension specified in an extensions entry will be accessible on the mainframe as appropriate.

To decide whether or not a file is to be accessible on the mainframe:

  • SourceConnect first checks the drive the file is on. If the drive is logically specified in a drive entry in the configuration, the next process is to check the extension of the file.
  • If the file's extension is specified by an extensions entry (or specified by the extensions parameter of a Panvalet, PDS or Librarian system entry), the file is read from or written to the mainframe.
  • If the extension is not specified in the configuration file, or is not line sequential, it is read from or written to the current working directory instead, preserving the existing files on the mainframe.

This is not true for PVCS however, all files are automatically available to be read from or written to PVCS without the need of configuring the extension list.


Protecting Mainframe Files from Being Overwritten

When working on a mainframe, it is common practice to read a member from one dataset, edit it, then save it to a different dataset, avoiding the overwriting of the original member.

To emulate this behavior using SourceConnect., you use the if-writing-to, or dataset update redirection entry in the configuration.

This entry takes two parameters:

  • the first parameter defines a protected dataset
  • the second defines the alternate dataset to be written to when attempting to write to the protected dataset

SourceConnect prevents the first dataset from being over-written by performing all write operations transparently to the second dataset. Subsequent reads check this alternate dataset first before checking the protected dataset. If the member is found in the alternate dataset, then it is read from there.

A typical example of this would be to read files from a production dataset, but save edited versions of the files to a testing dataset.


Security

When you access a mainframe using SourceConnect, you are prompted for a user-id and password when needed. To avoid this prompt, SourceConnect can make use of MFDaemon to store the user-id and password. This information is stored in memory, and you can configure it to write to an INI file. This information is then available from the daemon whenever needed. When the PC is re-booted or the MFDAEMON CLOSE command is executed, MFDaemon reads the information from the INI file. Security must be turned on at all times.

Related concepts
About MFDaemon


Configuring SourceConnect

You use the Server Access Configuration dialog box to configure SourceConnect.

To display the Server Access Configuration dialog box, use either of the following options:

  • From the Visual Studio menu, select: Tools > Micro Focus COBOL Tools > Micro Focus Server Access
  • From the Windows Start menu, select :Micro Focus Product Name > Configuration > Mainframe Access Configuration

The Server Access Configuration dialog box is displayed.

  • Configure PVCS Drives
Parent topic: SourceConnect: Mapping a PC Drive to Mainframe Data


Configure Mainframe Drives

You define a PC drive letter for use within tools supporting SourceConnect technology. The drive letter you define is mapped to a mainframe catalog search value.

To configure a mainframe drive:

  1. On the Server Access Configuration dialog box, select the SourceConnect tab.
  2. Click Add to display the drive mapping dialog box.
  3. On the drive mapping dialog box:, select a drive letter and enter the manframe details to map to it.
    • Select the drive letter to map from the pull-down list. Only available drives are displayed.
    • In the Mainframe catalog search criteria field, enter a search string with wildcards that will find the catalogs that you want.
    • In the Node field, use the pull-down list to select a mainframe node that you have defined.
  4. Click OK to set your definitions.

    Each drive letter is associated with a specific node. This allows you to alter the node details without having to change the drive letter details.

    *

By selecting the type mainframe you are required to enter the catalog search criteria for that logical SourceConnect drive. The drive letter gives you access to the entire mainframe, subject to standard mainframe security rules, however, in a workstation directory list against the logical SourceConnect drive, only datasets that match the criteria will be displayed.

You can specify multiple search criteria, delimited by semi-colons, in this field. All datasets that match any of these criteria will be accessible.

Note: It is not recommended to enter search criteria that produces a large result. SourceConnect is limited to about 1300 returned entries for a catalog search, and for each one mapped to a drive, the VTOC information must be obtained. This can result in a performance problem for large-size results.

For example, if you defined drive S: with the catalog search criteria of CSI01.JPD;MFI01.LAS, then all datasets that start with either CSI01.JPD or MFI01.LAS will be displayed in a workstation directory list when S:\*.* is used.

You can use an asterisk in the middle or end of the search criteria as well. For example CSI01.*.COBOL will give all datasets that begin with CSI01 and end with COBOL.

You can map multiple drive letters onto various mainframes to enable you to perform default directory searches on multiple catalog-search prefixes. This means you can access more than one catalog-search environment as different drive letters. This is only necessary when you want to see a different directory list of mainframe datasets when drive-letter :\*.* is referenced.

Related concepts
Configuring the Cache
Logging On to the Mainframe
Related information
Adding a Mainframe Node
Starting and Configuring Drag and Drop
Configure PVCS Drives


Configure Partitioned Datasets

To access this feature, select the Configure your datasets on the SourceConnect tab.

This option defines a named dataset as being a PDS.

It is not recommended to use this entry, as all non-migrated PDS's are automatically picked up by SourceConnect, based on the catalog search criteria for the logical drive. By default the associated extension for the dataset is the last qualifier in the dataset name. You can globally override all datasets with a specific last qualifier to a specific workstation extension by using the configure global extension overrides item bar.

The only reasons to use this configure partitioned dataset item bar, would be if the dataset could be migrated or, if you wished to override the specific associated workstation extension for this partitioned dataset, without affecting the override for other partitioned datasets with the same last qualifier, as all of these entries are automatically added to the directory search function, then you may have additional datasets that do not match the search criteria appearing in the list..

Dataset
Specify the name of the partitioned dataset.
Extension
Specify the extension that members of this dataset are to be associated with

Any extensions specified here are automatically added to the configure controlled extensions list.


Configure Migrated Partitioned Datasets

If your PDS's are migratable, then SourceConnect is unable to determine the dataset type, based on the VTOC information, as this does not exist while a dataset is migrated. If you wish for SourceConnect to "see" these datasets as well, then you must explicitly add them to the configure partitioned datasets list.


Configure Librarian Datasets

To access this feature, select the Configure your datasets on the SourceConnect tab.

Defines a named dataset as being a Librarian dataset. By default the associated extension for the dataset is the last qualifier in the dataset name. You can globally override all datasets with a specific last qualifier to a specific workstation extension by using the configure global extension overrides item bar. With Librarian however, multiple extensions are possible as Librarian keeps information about the member type in its database. You can specify that these various types be associated with various workstation extensions. All of these entries are automatically added to the directory search function, then you may have additional datasets that do not match the search criteria appearing in the list.

Dataset
Specify the name of the Librarian dataset
Extension
The default may be specified for any members that do not match the specific extensions listed in the override list
Extension overrides
Specify the type/extension mapping that members of this dataset are to be associated with

Any extensions specified here are automatically added to the configure controlled extensions list.


Configure Panvalet Datasets

To access this feature, select the Configure your datasets on the SourceConnect tab.

Defines a named dataset as being a Panvalet dataset. By default the associated extension for the dataset is the last qualifier in the dataset name. You can globally override all datasets with a specific last qualifier to a specific workstation extension by using the configure global extension overrides item bar. With Panvalet however, multiple extensions are possible as Panvalet keeps information about the member type in its database. You can specify that these various types be associated with various workstation extensions. All of these entries are automatically added to the directory search function, then you may have additional datasets that do not match the search criteria appearing in the list.

Dataset
Specify the name of the Panvalet dataset
Extension
The default may be specified for any members that do not match the specific extensions listed in the override list
Extension overrides
Specify the type/extension mapping that members of this dataset are to be associated with

Any extensions specified here are automatically added to the configure controlled extensions list.


Configure Controlled Extensions

To access this feature, select the Configure your datasets on the SourceConnect tab.

This is one of the most important configuration parameters for SourceConnect. You will need to understand this statement, to be able to define and control mainframe files as SourceConnected files. This defines controlled extensions for input/output requests on the drive letters specified in the drive entries. Any file with an extension not in the list specified by this entry, or be in the default list, is written to the current working directory instead of to the relevant dataset on the mainframe. If an extension was defined in the partitioned dataset, Librarian dataset or Panvalet dataset, it does not have to be added here as well. This is done for you by SourceConnect. For PVCS however, all files are automatically available to be read from or written to PVCS without the need of configuring the extension list.

Extension
Specify the file extension that you want SourceConnect to control when accessing SourceConnect controlled drives. If the extension you are working with is not defined here, in the configure global extension overrides list, or in the default list supplied by SourceConnect, then SourceConnect will not try to access the file on the mainframe, but instead re-direct the request to the current working directory.

Use this entry to define which files Micro Focus tools can input/output to the mainframe. Do not include work files (such as .INT, .GNT, and .LST files) created by these tools in the list.

The following extensions are used by default:

ASSEM, ASSEMBLE, ASM, BMS, C, CBL, CIC, CNTL, CLIST, COB, COBOL, CONTROL, COP, COPY, COPYLIB, CPP, CPY, CSD, CTL, CTRL, DBD, DCT, DYL, ECL, FCT, GEN, H, INC, INCL, INCLUDE, JCL, JOB, LNK, MAC, MACLIB, MFS, MLC, PCT, PGM, PLI, PPT, PRC, PROC, PROCLIB, PSB, RCT, SCH, SRC, SOURCE, TSO, TXT, TEXT

There are a number of extensions you must not specify. These are as follows:

CSI, DLL, DLW, GDY, GNT, EXE, IDY, INT, LIST, LST, OBJ

Files with these extensions are always written to the current working directory. If you specified any of these extensions, a message is output when SourceConnect initializes.


Configure Global Extension Overrides

To access this feature, select the Configure your datasets on the SourceConnect tab.

This is one of the most important configuration parameters for SourceConnect. You will need to understand this statement, to be able to define and control mainframe files as SourceConnected files. This defines controlled extensions for input/output requests on the drive letters specified in the drive entries, with changes in the mainframe type to this specific extension. You may globally override mainframe types to be specific extensions with this statement. This is very useful, as it prevents you from having to code a partitioned dataset, Librarian dataset or Panvalet dataset statement for each dataset that you wish to override the extension with. For example, if you wanted to override all mainframe types of SOURCE to be CBL, then specify SOURCE as the mainframe type, and CBL as the associated workstation extension. You can of course add multiple of these parameters.

Mainframe
Specify the mainframe type that you want SourceConnect to convert to the workstation extension
Workstation
Specify the file extension that you want SourceConnect to use and control when accessing SourceConnect controlled drives for the mainframe type specified


Configure Dataset Update Redirections

To access this feature, select the Configure your datasets on the SourceConnect tab.

Forces all writes or rewrites to a specified dataset to be made to an alternative dataset, preserving the original. Additionally, the alternate dataset is checked first when doing a read of a member. A typical use for this entry is to ensure that source files are read from a production dataset, but any updated files are written to a separate, test dataset to avoid overwriting the existing files.

When writing to
Specify the name of the protected, typically production, dataset. This can be a partitioned dataset, Librarian dataset or Panvalet dataset.
Redirect to
Specify the name of the unprotected, typically development, dataset. This can be a partitioned dataset, Librarian dataset or Panvalet dataset.


Configure PVCS Drives

Defines a drive letter for use within tools supporting SourceConnect technology. The drive letter is mapped to a PVCS configuration file.

Select a drive letter that you wish to have mapped to PVCS. Existing real drives are made non-selectable.

To access PVCS, you would specify the fully qualified location of the PVCS configuration file to be used for your environment. You must be using PVCS version 5.2 or greater. Optionally, a promotion group or version label can be specified as well.

Important: if you are using the version label operand for the PVCS drive, then all files will be read from the labelled version level, but any updates will create a distinct branch, that the user is responsible to merge, using PVCS tools, when complete.
Parent topic: Configuring SourceConnect
Related concepts
Configuring the Cache
Logging On to the Mainframe
Related information
Adding a Mainframe Node
Starting and Configuring Drag and Drop
Configure Mainframe Drives


Enterprise Server Task Index

  • Accessing the Enterprise Server Administration UI
  • Accessing the ESMAC User Interface
  • Administer a Server Using ESMAC
  • Configure the Directory Server
  • Deploy Interfaces
  • Log On and Off
  • Monitor Directory Server
  • Monitor and Manage Enterprise Server
  • Start and Stop the Directory Server
  • Work with Communication Processes and Service Listeners
  • Work with Packages
  • Work with Request Handlers
  • Work with Servers
  • Work with Services
  • Work with the Directory Server Repository
  • CICS Support Tasks
  • JCL Support Tasks
  • IMS Support Tasks
Parent topic: Configuration and Administration


Accessing the ESMAC User Interface

You use the Enterprise Server Monitoring and Control (ESMAC) user interface to monitor and control the enterprise server instances that your installation is running. From the ESMAC user interface, you can monitor and control all aspects of each enterprise server instance.
  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details..

    The Details screen for the server is displayed.

  4. On the Details screen, click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

Parent topic: Enterprise Server Task Index


Administer a Server Using ESMAC

  • To Change the Trace Dataset
  • To Configure Dumps
  • To Create an ESMAC User
  • To initiate a system dump
  • To stop or kill a SEP
  • To Monitor Services
  • To Record Service Input and Output
  • To Reply to an ACCEPT FROM CONSOLE Statement
  • To Shut Down a Server from ESMAC
  • To specify what information is traced
  • To Start ESMAC for an enterprise server instance
  • To Transfer the In-memory Trace Data to the Auxiliary Dataset at Rollover
  • To View a Dump
  • To View a Local Trace for a Client Process
  • To View a Local Trace for a SEP
  • To View a System Trace
Parent topic: Enterprise Server Task Index


To Create an ESMAC User

Note: This procedure is supported for backward compatibility only.

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To create an ESMAC user:

  1. Click Users.

    The Users page is displayed

  2. Click New.

    The CICS SNT page is displayed.

  3. In the field Name, enter the name to be used by this user when logging in.
  4. Optionally, you can enter a short description for the user; enter it in the field Description.
  5. In the field Password, enter a password for the user.
  6. In the field Repeat PW, re-enter the password. This ensures that you type the password correctly.
  7. If you want the password always to be entered in upper case, check Upper case.
  8. In the field Operator ID, enter an operator ID for this user. This is optional.
  9. In the field Timeout, enter a timeout period, in minutes, for this user. This is optional.

    If the user does not interact with ESMAC for more minutes than defined in this field, security permissions revert to the default permissions.

  10. To set what aspects of a server and its definitions a user can change:
    1. Check Yes in the Definition Access group
    2. Click on the required dropdown, and select one of:
      • No - the user cannot read or update the selected definition
      • Upd - the user can read and update the selected definition
      • Rd - the user can read the selected definition

    By default, the user cannot read or update definitions; that is, the Definition Access, Yes check box is unchecked, and all definitions are set to No.

    If you set the definitions to Rd or Upd, these only have an effect if the Definition Access, Yes check box is checked.

    To set all definitions to No, Upd or Rd, click the all dropdown and select No, Rd or Upd, respectively.

  11. Click Add.

    The user is added to the list of users. The CICS SNT page is redisplayed, enabling you to change any details for this user.

Note:

You can ignore the controls Group prefix, Oper Class, and those for resource keys, security keys, and surrogate security keys.

Parent topic: Administer a Server Using ESMAC
Related information
To start ESMAC for a server
To monitor services
To configure dumps
To view a dump
To initiate a system dump
To specify what information is traced
To change the trace dataset
To transfer the in-memory trace data to the auxiliary dataset at rollover
To view a system trace
To record service input and output
To view a local trace for a SEP
To view a local trace for a client process
To kill a SEP
To reply to an ACCEPT FROM CONSOLE statement
To shut down a server


To stop or kill a SEP

You can stop or kill a service execution process (SEP).

If you stop a SEP it will stop when the SEP has completed the current task. Stopping a SEP is most useful if an associated JCL is looping, or if it is a SEP with a debugger attached.

Killing stops the SEP when it is currently running a task. If the task terminates prior to the kill process being initiated, ESMAC returns a message explaining that the target task was no longer active.

Note: After stopping a process, Enterprise Server will automatically replace the SEP to keep the configured number of SEPs - unless it is a debug SEP or a SEP that was started from the command prompt. In these cases it will stop the SEP but not replace it.

To start ESMAC:

  1. Access the Enterprise Server Administration screen for your installation.
  2. In the table of enterprise server instances, check that the server you want has started, and if not, start it.
  3. In the Status column of the enterprise server instance to monitor, click Details.

    The Details screen for the server is displayed.

  4. On the Details screen, select the Server > Control tab, then click ES Monitor & Control.

    The Enterprise Server Monitoring and Control (ESMAC) screen is displayed.

To stop or kill a SEP

  1. Click SEPs in the menu.
  2. Click Stop next to the SEP.

To kill a SEP

  1. Click SEPs in the menu.
  2. Click Kill next to the SEP.
Parent topic: Administer a Server Using ESMAC
Related information
To shut down a server
To view a local trace for a SEP


Configure the Directory Server

  • To Configure the MF Directory Server
Parent topic: Enterprise Server Task Index


To Configure the MF Directory Server

  1. Click Configure > Options on the menu on the left-hand side of any Enterprise Server Administration Web page.
  2. Update the attributes of the Directory Server as required.
  3. Click OK.
Note:

If you check Restricted under User Access, as soon as you click Apply you will be asked for a valid user ID and password with at least Administrator permission level, which you must provide to continue working.

Parent topic: Configure the Directory Server


Deploy Interfaces

  • To Deploy to WebSphere
  • To Deploy to WebLogic
  • To Deploy to JBoss
  • To manually deploy a service interface
  • To Create Deployment Descriptors Manually
  • To Create an .ear File for your EJB
  • To Add Micro Focus Support for EJBs
  • To Add Support for Micro Focus Resource Adapters
  • To Deploy a Micro Focus Resource Adapter to a J2EE Application Server
Parent topic: Enterprise Server Task Index


Log On and Off

  • To Log On to Enterprise Server Administration
  • To Log Off from Enterprise Server Administration
Parent topic: Enterprise Server Task Index


Monitor Directory Server

  • To View the Sessions List
  • To View the Journal
  • To View and Use Remote Directory Server Instances
  • To View Directory Server Statistics
  • To Export the Journal as a Text File
  • To Delete Journal Entries
  • To Configure Run-time Core Dumps
Parent topic: Enterprise Server Task Index


Monitor and Manage Enterprise Server

  • To View Server Instances and Properties in Operations Manager
  • To import Server Management Packs into Operations Manager
  • To Use Performance Counters
  • To Enable Performance Counters
  • To Use Windows Event Logging
  • To Enable Windows Event Logging
Parent topic: Enterprise Server Task Index


Start and Stop the Directory Server

  • To Start the Directory Server
  • To Start the Directory Server from the Command Line
  • To Stop the Directory Server
  • To stop the Directory Server when not running as a service
Parent topic: Enterprise Server Task Index


Work with Communication Processes and Service Listeners

  • To Add a Service Listener to an Enterprise Server Instance
  • To Associate a Listener with a Service
  • To Start a Communications Process
  • To Stop a Communications Process
  • To Copy a Communications Process
  • To Edit a Communications Process
  • To Delete a Communications Process
  • To Start a Listener
  • To Stop a Listener
  • To Edit a Listener
  • To Disassociate a Listener from a Service
  • To delete a listener
  • To View Communications Processes and Listeners for an Enterprise Server Instance
  • To View Statistics for a Communications Process
Parent topic: Enterprise Server Task Index


Work with Packages

  • To Add a Package to an Enterprise Server Instance
  • To Edit a Package
  • To Associate a Package with a Service
  • To Disassociate a Package from a Service
  • To View Packages for an Enterprise Server Instance
  • To Delete a Package
  • To Delete Old Deployed Package Files
Parent topic: Enterprise Server Task Index


Work with Request Handlers

  • To Add a Request Handler to an Enterprise Server Instance
  • To Edit a Request Handler
  • To Associate a Request Handler with a Service
  • To Disassociate a Request Handler from a Service
  • To View Request Handlers for an Enterprise Server Instance
  • To Delete a Request Handler
Parent topic: Enterprise Server Task Index


Work with Servers

  • To Add an Enterprise Server Instance
  • To Add an XA Resource
  • To Change the Number of ES licenses
  • To Change the Number of SEPs
  • To Change the System Directory
  • To Copy an Enterprise Server Instance
  • To Create and View a Diagnostic Dump for an Enterprise Server Instance
  • To Delete an Enterprise Server Instance
  • To Delete an XA Resource
  • To Delete a CCI Server
  • To Edit an Enterprise Server Instance
  • To Edit an XA Resource
  • To Enable Dynamic Debugging
  • To Enable or Disable an XA Resource
  • To Export Server Information
  • To start an enterprise server instance
  • To stop a server Instance
  • To View the Communications Console Log for an Enterprise Server Instance
  • To View the Console Log for an Enterprise Server Instance
  • To View the Control Page for an Enterprise Server Instance
Parent topic: Enterprise Server Task Index


To Create and View a Diagnostic Dump for an Enterprise Server Instance

  1. On the Home page click Edit to the left of the server whose console log you want to view.
  2. Click the Diagnostics tab.
  3. Click the Dump tab.
  4. Click Create Dump.

    The page is refreshed showing a table of dumps with one row for the dump you just created.

    Note:

    Create Dump is only available when the server is started.

  5. Click Show against the dump you just created. You briefly see a console window, then the dump file overwrites the contents of the Dump page.
  6. When you have finished viewing the dump, click Datasets to return to the Server > Diagnostics > Dump page.
Parent topic: Work with Servers


To Enable Dynamic Debugging

  1. In the table of servers on the Home page of Enterprise Server Administration, find the row for the server that you want to configure, and click Edit in the left hand column.
  2. In the Server > Properties > General section, select Allow Dynamic Debugging.
  3. Click OK to confirm your changes.
Important: You must restart the server for the changes to take effect.
Parent topic: Work with Servers


To View the Communications Console Log for an Enterprise Server Instance

  1. On the Enterprise Server Administration Home page click Edit to the left of the server whose communications console log you want to view.
  2. Click the Diagnostics tab.
  3. Click the CS Console tab.
  4. To view the entire log since the server was started, click Show Entire Log. The log opens in a new Web browser window. To return to ESMAC, click Back in your browser.
Parent topic: Work with Servers


To View the Control Page for an Enterprise Server Instance

  • In the Enterprise Server Administration screen, click Details in the Current status column of the enterprise server instance you want.
    Note:

    You can click Details only if the status of the Server is "Started".

Parent topic: Work with Servers


Work with Services

  • To View Services for an Enterprise Server Instance
  • To Add a Service to an Enterprise Server Instance
  • To Edit a Service
  • To Change the Status of a Service
  • To Switch Logging On for a Service
  • To Add a Service for Integration with the Micro Focus Development Tools
  • To Delete a Service with Operations
  • To Delete a Simple Service or an Operation
Parent topic: Enterprise Server Task Index


Work with the Directory Server Repository

  • To Import a Repository
  • To Export the Repository
  • To Restore the Repository
  • To Delete the Repository
Parent topic: Enterprise Server Task Index


CICS Support Tasks

  • Control and Configuration
  • Resources
Parent topic: Enterprise Server Task Index
Parent topic: CICS Support


Control and Configuration

The following control and configuration tasks are available:

  • To change the SIT associated with a server
  • To configure CICS search paths
  • To enable MSS for an enterprise server
  • To send a message to all 3270 terminals
  • To specify a listener for TN3270 terminals
  • To view and delete interval control elements
  • To view resource locks
Parent topic: CICS Support Tasks


To change the SIT associated with a server

  1. Click Home.
  2. Stop the server whose SIT you want to change:
  3. In the table of servers click Edit to the left of the row for the server whose SIT you want to change.
  4. Click Properties > MSS.
  5. Specify the new SIT in System Initialization Table.

    If this entry is not present, the SIT associated with a server defaults to DFH$IVP, the SIT for the CICS application that you use to perform the installation verification procedure.

  6. Click Apply.
  7. Start the server:
  8. Start ESMAC:
  • To stop a server Instance
  • To start an enterprise server instance
  • To Start ESMAC for an enterprise server instance
Parent topic: Control and Configuration
Parent topic: Changing the SIT for an MSS-Enabled Server
Related information
To stop an enterprise server
To start an enterprise server
To start ESMAC for a server
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To configure CICS search paths

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server that you want to configure CICS search paths for.
  2. Click the MSS tab.
  3. Enter the search path for CICS application programs in Transaction Path.
  4. Enter the search path for CICS VSAM datasets in VSAM File Path.
  5. Enter the search path for CICS BMS load modules in Map Path.
  6. Enter the search path for CICS resource definition files in Resource Definition File Path.
Note:

In all the path fields except Resource Definition File Path you can specify multiple paths by separating them with a semicolon character (;), for example, to set the search path for VSAM files you could enter

d:\cics\files;d:\cics\files2

in VSAM File Path.

Parent topic: Control and Configuration
Parent topic: Configuring CICS Search Paths
Parent topic: To enable MSS for an enterprise server
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To enable MSS for an enterprise server

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server that you want to enable MSS for.
  2. Click the MSS tab.
  3. Check Mainframe Subsystem Support enabled.

    This is the minimum you need do to enable MSS. By default the enterprise server uses the SIT DFH$IVP. The startup lists, groups and resources used by the enterprise server will, therefore, be those defined by DFH$IVP.

  4. If you want to use a SIT other than DFH$IVP, specify the name of the SIT in System Initialization Table.

    If you want to set a SIT that has a $ (dollar) character in its name you have to escape the $ character, for example MY\$SIT:

  5. If you specified a SIT other than DFH$IVP, specify CICS search paths, unless you are enabling MSS for JCL rather than CICS, in which case search paths are not required.
  6. Click Apply.
  7. Restart your server. The enterprise server will start as a MSS-enabled enterprise server, using either the default SIT, or the SIT you specified.
Note: You can disable or re-enable MSS by unchecking or checking Mainframe Subsystem Support enabled, then clicking OK and stopping and restarting the enterprise server.
  • To configure CICS search paths
Parent topic: Control and Configuration
Parent topic: Configuring the Enterprise Server
Parent topic: Enabling MSS for an Enterprise Server
Parent topic: Enabling MSS for an Enterprise Server
Parent topic: Enabling JCL for an Enterprise Server
Related concepts
Configuring IMS Printers
Related tasks
To define specific printers for an IMS-enabled enterprise server
Related information
To configure CICS search paths
To enable MTO for an enterprise server
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To send a message to all 3270 terminals

  1. Click Control.
  2. Specify the text of your message in Message all.
  3. Click Send.
Parent topic: Control and Configuration
Parent topic: Sending Messages to All Terminals
Related information
To create an ESMAC user
To start ESMAC for a server
To monitor services
To configure dumps
To view a dump
To initiate a system dump
To specify what information is traced
To change the trace dataset
To transfer the in-memory trace data to the auxiliary dataset at rollover
To view a system trace
To record service input and output
To view a local trace for a SEP
To view a local trace for a client process
To kill a SEP
To reply to an ACCEPT FROM CONSOLE statement
To shut down a server


To specify a listener for TN3270 terminals

  1. In the table of servers on the Home page of Enterprise Server Administration, click Details in the Communications Processes cell for the server to which you want to add the listener.
  2. Click Add in the Listeners column for the communications process to which you want to add the listener.
  3. In the Name field, specify a suitable name (for example, tn3270).
  4. Allow Endpoint Protocol to default to TCP.
  5. In Endpoint Address), set the port number for the listener to *.nnnn, where nnnn is a port number. You can use any number above 5000 that isn't in use.
  6. In the Supported Conversation Type group, click TN3270.
  7. Click Add.

    The Communications Processes page is redisplayed showing that the listener was added.

  8. Click Home.
  9. Stop the enterprise server.
  10. Restart the enterprise server.

    This has the effect of starting the listener.

Parent topic: Control and Configuration
Parent topic: Using Telnet 3270 terminal emulators
Parent topic: Specifying a Listener for TN3270 Terminals


To view and delete interval control elements

  1. Click the dropdown menu in the Resources group.
  2. Select Active.
  3. Click ICE. You see the Interval Control Elements (Active) page, containing a list of active ICE definitions.
  4. Click Delete button to the left of the row containing the interval control element you want to delete. The item is deleted immediately, and a message is displayed at the top of the ICE information confirming the deletion.
Note: You can delete interval control elements only if you have the appropriate permissions.
Parent topic: Control and Configuration
Parent topic: Controlling CICS Resources
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To view resource locks

  1. Click the dropdown menu in the Resources group.
  2. Click Active.
  3. Click Lock. You see the Lock page, containing information about the current resource locks. This display is in two parts. The first lists the locks held and applied for. The second part lists the resources. Information in the two parts is related by resource IDs.
Parent topic: Control and Configuration
Parent topic: Viewing Locks
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


Resources

The following Resources tasks are available:

  • To create a resource from an existing resource
  • To create a resource group
  • To create a resource table
  • To create a SIT
  • To create a startup list
  • To delete a resource
  • To modify a resource
  • To view a dump of a resource
  • To view active resources
  • To view and delete data queue items
  • To view detailed information for a resource
  • To view resources by group
  • To view resources by startup list
  • To view resources by type
Parent topic: CICS Support Tasks


To create a resource from an existing resource

  1. Click Details on any of the pages that list resources.
  2. Click Copy.

    You can find this button at the bottom of the page.

    ESMAC opens a new page, containing the values carried over from the previous page.

  3. In the Name field, enter a name for the resource.
  4. In pages that have a Group selector, select the group you want the resource to belong to.
  5. Edit fields and/or change controls to the values you require for your new resource.
  6. Click Add.

    The resource is added to the group you specified, or to the list of SITs, groups or startup lists.

Parent topic: Resources
Parent topic: Controlling CICS Resources
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To create a resource group

  1. Click Resources, by Group.
  2. Click Groups.
  3. Click New.
  4. Specify a name and a description for the group.
  5. Click Add.
  6. Click Group List.
  7. Add resources to the group as required: click one of the buttons at the foot of the page (FCT, TST etc), create the new table, and from the table page click Group List to return to the group list. Repeat to add more resources.
Parent topic: Resources
Parent topic: Configuring the Enterprise Server
Parent topic: Specifying IMS Resources to a Resource Group
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To create a resource table

  1. Select Resources, by Type.
  2. Click one of the table buttons (for example, FCT or DCT).
  3. Scroll to the bottom of the page.
  4. Click the button corresponding to the resource table you want to create (for example, FCT or DCT).

    The entry page corresponding to the button you clicked is displayed.

  5. Edit fields and/or change controls to the values you require for your new resource.

    The help for the page explains the meanings and values of controls and fields. To display the context help, click Body in the Help group in the sidebar.

  6. Click Add.

    The resource is added to the group you specified on the page.

Parent topic: Resources
Parent topic: Database Managers Supported
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To create a SIT

  1. Click Resources, by Group.
  2. Click SIT.
  3. Click New.
  4. Specify a name and description.
  5. Choose a startup list for the group from the list in Startup List.
  6. Edit fields or change controls to the values you require for your new SIT.

    The help for the page explains the meanings and values of controls and fields. To display the context help, click This page in the Help group in the sidebar.

  7. Click Add.

    The page is refreshed showing the SIT you have just added.

Parent topic: Resources
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To create a startup list

  1. Click Resources, by Group.
  2. Click Startup.
  3. Click New.
  4. Specify a name and description.
  5. Check Production if the startup list is for a production system.
  6. Specify a group to add to the startup list in 01.
  7. Click Add.

    A new empty row has been added, with the number 02, and icons have been added at the end of row 01 allowing you to move the group at this position up or down, or to delete it. When you move a group up or down, you change the order in which the resources are loaded at startup.

  8. Repeat steps 6 and 7 on the next row and click Apply. Continue until you have specified all the groups in the resource list.
Parent topic: Resources
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To delete a resource

  1. Click Details on any of the pages that list resources.
  2. click Delete on the detailed information page.
Note: If you do not have the required permissions to delete resources, the Delete button is not shown.
Parent topic: Resources
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To modify a resource

  1. Click Details on any of the pages that list resources.

    The detailed information page shows various information relating to the resource you selected. The page title reflects the resource and the method you chose to view it. For example, if you choose to view resources by startup list, click FCT to display a list of FCTs, and then click Details next to an FCT listed in the table, the detailed information page for the FCT you selected is displayed. The detailed information page has the title CICS FCT - fct_name (grp), where fct_name is the name of the FCT, and grp the group to which the FCT belongs. In this case, the detailed information page displays all of the values set for the FCT.

  2. Edit the fields or change controls on the page as required.
  3. Click Apply. If your changes are successfully applied, you see the message "Update successful".
Note: If you do not have the required permissions to modify resources, the Apply button is not shown.
Parent topic: Resources
Parent topic: Specifying IMS Resources to a Resource Group
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To view a dump of a resource

  1. Click Details on any of the pages that list resources.
  2. click Dump on the detailed information page. The dump is taken, formatted, and displayed.
  3. When you finished viewing the dump, click Back on your browser. This returns you to the details page you were viewing before you initiated the dump.
Parent topic: Resources
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To view active resources

  1. Click the dropdown menu in the Resources group.
  2. Select Active.
    The following buttons are displayed:
    • DCT
    • FCT
    • ICE
    • JCT
    • Lock
    • PCT
    • PPT
    • TST
    • T-Type
    • SysC
    • URIMAP
    • TCPIPSv
  3. Click one of the buttons (except for Lock and ICE) to display a page that contains a table listing all the active resources of that type. The page is called rsc (active), where rsc is the type of resource, such as DCT. For example, if you click FCT, the FCT (active) page is displayed, which lists all the active FCTs.

    Each row of the table lists the name of a resource, and gives further information that depends on the type of resource. For example, the DCT (active) page lists the name of the DCT, its state, and the type of DCT; the PPT page gives the name of the PPT, the type of PPT, and the programming language specified for the PPT.

    Each row also contains a Details button. Click this to display the detailed information page for the resource.

    The TST page also provides a table of actual data queues, including those created for interval control element data records. You can delete data queues on the TST page.

Parent topic: Resources
Parent topic: Controlling CICS Resources
Related information
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To send a message to all 3270 terminals


To view and delete data queue items

  1. Click the dropdown menu in the Resources group.
  2. Select Active.
  3. Click TST. You see the TST (active) page, containing a list of active TST definitions in the upper half, and a table of actual data queue items in the lower half. These include data queues associated with interval control elements.
  4. Click Delete button to the left of the row containing the data queue item you want to delete. The item is deleted immediately, and a message is displayed at the top of the TST information confirming the deletion.
Note: You can delete data queue items only if you have the appropriate permissions.
Parent topic: Resources
Parent topic: Controlling CICS Resources
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To view detailed information for a resource

  1. Click Details on any of the pages that list resources.

    The detailed information page displays various information relating to the resource you selected.

    The page title shows the resource and the method you chose to view it.

    For example, if you choose to view resources by startup list, click FCT to display a list of FCTs. Then click Details next to an FCT listed in the table. The detailed information page for the FCT you selected is displayed.

    The detailed information page has the title CICS FCT - fct_name (grp), where fct_name is the name of the FCT, and grp the group to which the FCT belongs. In this case, the detailed information page displays all of the values set for the FCT.

Parent topic: Resources
Parent topic: Controlling CICS Resources


To view resources by group

  1. Click the dropdown menu in the Resources group.
  2. Select by Group. The following buttons are displayed:
    • Groups - click this to view a list of all groups on this enterprise server. The page CICS Resource Groups is displayed, which lists the resource groups.
    • Startup Lists - click this to view a list of all startup lists on this enterprise server. The page CICS Startup Lists is displayed, which lists all startup lists.
    • SIT - click this to view all a list of all SITs available to this enterprise server. The CICS System Initialization Tables page is displayed, which lists all SITS.

    Each page displayed when you click one of the above buttons contains a table that lists the resources relevant to that button. For example, the CICS System Initialization Tables page, displayed when you click SIT, lists the SITs available.

    Each row of the table provides the name of the resource, and further information on that resource. For example, the CICS System Initialization Tables page shows the name of the SIT, the startup list for the SIT, and a short description of the SIT.

    Each row also contains a Details button. Click this to display the detailed information page for the resource.

Parent topic: Resources
Parent topic: Controlling CICS Resources
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To view resources by startup list

  1. Click the dropdown menu in the Resources group.
  2. Select by Start L. A number of buttons are displayed.
  3. Click one of the buttons to display a page that contains a table listing all the resources of that type for the current startup list. The current startup list is the startup list defined in the SIT that was initiated when the enterprise server was started.

    The page displayed is called CICS Startup List list, where list is the name of the startup list initiated by the SIT.

    Each row of the table lists the name of a resource of the type you selected, and gives further information that depends on the type of resource. For example, if the current SIT used the startup list DFH$IVP, and you clicked DCT, the page displayed is called CICS Startup List DFH$IVP, and lists the DCTs available to the startup list.

    Each row also contains a Details button. Click this to display the detailed information page for the resource.

Parent topic: Resources
Parent topic: Controlling CICS Resources
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


To view resources by type

  1. Click the dropdown menu in the Resources group.
  2. Select by Type. A number of buttons are displayed.
  3. Click one of the buttons to display a page that contains a table that lists all the resources of that type known to the current enterprise server.

    The page displayed is called CICS Defined rsc, where rsc is the name the type of resource you clicked.

    Each row of the table gives the name of a resource of the type you selected, and gives further information that depends on the type of resource. For example, if you clicked DCT, the page displayed is called CICS Defined DCT, and lists the DCTs known to the enterprise server.

    Each row also contains a Details button. Click this to display the detailed information page for the resource.

Parent topic: Resources
Parent topic: Controlling CICS Resources
Related information
To enable MTO for an enterprise server
To configure CICS search paths
To specify a listener for TN3270 terminals
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To modify a resource
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To send a message to all 3270 terminals


JCL Support Tasks

The following JCL support tasks are available:

  • JCL Configuration
  • Deploying and Running JCL Applications
  • Spool Queue Tasks
  • JCL Catalog Tasks
Parent topic: Enterprise Server Task Index
Parent topic: JCL Support


JCL Configuration

The following JCL configuration tasks are available:

  • To add a service for JCL
  • To define a batch initiator or printer SEP
  • To enable JCL support
  • To specify a handler for JCL requests
  • To automatically defer printing for specified message classes
Parent topic: JCL Support Tasks


To add a service for JCL

  1. Click Details in the Objects column for the server you want to add the service to.
  2. Click Add.
  3. In both Name and Service Class type: MF JES
  4. Leave the type of transaction management as Application.
  5. In Available Listeners, select the line containing Web Services and J2EE. Then click <-Add below this field.
  6. In Available Handlers, select MFRHJCL. Then click Select Handler. The selection is active immediately.
  7. In Description type a suitable description, such as Job Entry Subsystem service.
  8. Click Add.
Note: You can also reach the Add Service page by clicking Edit to the left of the server to which you want to add the service, clicking the Services tab and clicking Add.
Parent topic: JCL Configuration


To define a batch initiator or printer SEP

This defines a batch initiator or printer SEP that will be a permanent feature of the enterprise server, starting up whenever the enterprise server is started. If you want to start a batch initiator or printer SEP "on the fly" while the enterprise server is running, to run waiting jobs immediately, see To start a batch initiator or printer immediately.
  1. If you are starting a printer, make sure the enterprise server is running and was started from the command line.
  2. If the table of servers on the Home page is being displayed in summary form, expand it by clicking expand button.
  3. Click Edit by the server you want to add the initiator or printer to.
  4. Make sure the Server and Properties tabs are selected, then click MSS and then JES.
  5. Click Initiator or Printer.
  6. Click Add.
  7. Enter details in the fields.

    In Class, type the list of job classes you want this initiator to run, or this printer to print; for example, ABC. The JOB CLASS of a JCL jobstream must match the class of a batch initiator SEP in order for the SEP to run the job. The MSGCLASS or SYSOUT class must match the class of a batch printer SEP in order for the SEP to print the output.

  8. For a printer, select a printer in the list in Printer Name.
  9. Click Add.
Parent topic: JCL Configuration
Parent topic: SEPs for JCL
Related information
To start a batch initiator or printer immediately
To run a JCL job
To run a JCL job from the command line
To define a batch initiator or printer SEP
To start a batch initiator SEP from the command line
To deploy a JCL application to an enterprise server
To start a batch printer SEP from the command line
To run a JCL job on a remote enterprise server
To view resource locks
To reply to an ACCEPT FROM CONSOLE statement


To enable JCL support

  1. On the Enterprise Server Administration home page, click Edit next to the name of the enterprise server you want to enable.
  2. The Edit page that appears contains a hierarchy of tabs. Make sure the Server and Properties tabs are selected, and click MSS.
  3. Make sure that Mainframe Subsystem Support is checked.
  4. Click JES.
  5. Check Job Entry Subsystem enabled.
  6. Enter values into the fields on the JES tab. Click This Page in the help menu for more information.
  7. Click OK.
  8. Click Apply to save your changes.
Note: You also need to make sure the enterprise server has batch initiators for the JCL job classes you wish to run. See the Related Topics below.
Parent topic: JCL Configuration
Parent topic: Enabling JCL for an Enterprise Server
Related information
To specify a handler for JCL requests
To enable JCL support
To define a batch initiator or printer SEP
To add a service for JCL
To automatically defer printing for specified message classes
To add a service for integration with the Micro Focus Development Tools


To specify a handler for JCL requests

  1. On the Home page of Enterprise Server Administration, look at the Objects column for the enterprise server that you want to start a handler for. One entry there shows the number of handlers available in that enterprise server – it is at least 2, since the Web Services and J2EE handlers are there by default. Click Details next to this Handlers entry.
  2. On the page that appears, click Add.
  3. On the Add Handler page that appears, type MFRHJCL in Module Name, leave Module Path and Configuration Information blank, and type "Handles JCL requests" in Description.
  4. Click Add at the bottom of the page. The list on the Handlers page now includes MFRHJCL.
  5. Click Home on the menu at the left. The Objects column for the server now shows one more handler than before.
  6. Stop the enterprise server.
  7. Restart the enterprise server.

    This has the effect of starting the listener.

Note: You need to specify a handler for JCL requests only if you want to use an existing enterprise server for handling JCL jobs that does not already have this handler defined. Any new MSS-enabled servers you create will automatically have this request handler defined.
Parent topic: JCL Configuration
Related information
To stop an enterprise server
To start an enterprise server
To specify a handler for JCL requests
To enable JCL support
To define a batch initiator or printer SEP
To add a service for JCL
To automatically defer printing for specified message classes
To add a service for integration with the Micro Focus Development Tools


To automatically defer printing for specified message classes

You can configure your enterprise server to automatically route specified message classes to the Out Hold queue.

  1. On the Home page of ES Admin, click Edit next to the name of the enterprise server you want to enable.
  2. The Edit page that appears contains a hierarchy of tabs. Make sure that the Server>Properties>General tab is selected.
  3. In the Configuration Information field, set the ES_SYSOUT_HOLD environment variable to the message classes that you want to route to the Out Hold queue. For example:
    [ES-Environment]
ES_SYSOUT_HOLD=AB
    In this case, message classes A and B will be routed to the Out Hold queue.
  4. Click OK and restart your enterprise server.
Parent topic: JCL Configuration
Related information
To specify a handler for JCL requests
To enable JCL support
To define a batch initiator or printer SEP
To add a service for JCL
To automatically defer printing for specified message classes
To add a service for integration with the Micro Focus Development Tools


Deploying and Running JCL Applications

The following tasks are available for deploying and running JCL applications:

  • To deploy a JCL application to an enterprise server
  • To view resource locks
  • To reply to an ACCEPT FROM CONSOLE statement
  • To run a JCL job
  • To run a JCL job from the command line
  • To run a JCL job on a remote enterprise server
  • To start a batch initiator or printer immediately
  • To start a batch initiator SEP from the command line
  • To start a batch printer SEP from the command line
  • To stop a JES initiator from the command line
Parent topic: JCL Support Tasks


To deploy a JCL application to an enterprise server

  • Copy the executable files of the application to the folder where the enterprise server has been configured to look for executables when JCL was enabled.
Parent topic: Deploying and Running JCL Applications
Related information
To enable JCL support
To run a JCL job
To run a JCL job from the command line
To define a batch initiator or printer SEP
To start a batch initiator or printer immediately
To start a batch initiator SEP from the command line
To deploy a JCL application to an enterprise server
To start a batch printer SEP from the command line
To run a JCL job on a remote enterprise server
To view resource locks
To reply to an ACCEPT FROM CONSOLE statement


To view resource locks

  1. Click the dropdown menu in the Resources group.
  2. Click JES.
  3. Click Lock. You see the Lock page, containing information about the current resource locks. This display is in two parts. The first lists the locks held and applied for. The second part lists the resources. Information in the two parts is related by resource IDs.
Parent topic: Deploying and Running JCL Applications
Parent topic: Running and Controlling JCL Jobs
Related information
To run a JCL job
To run a JCL job from the command line
To define a batch initiator or printer SEP
To start a batch initiator or printer immediately
To start a batch initiator SEP from the command line
To deploy a JCL application to an enterprise server
To start a batch printer SEP from the command line
To run a JCL job on a remote enterprise server
To view resource locks
To reply to an ACCEPT FROM CONSOLE statement


To reply to an ACCEPT FROM CONSOLE statement

  1. Submit the job in the normal way, using Submit on ESMAC's JES Control page.
  2. The job begins and the first few lines of the job log appear on the Control page, ending with
    Processed jcl-filename

    where jcl-filename is the full pathname of the JCL file you submitted. The job pauses at this point.

  3. Now click Job at the bottom left-hand corner of the Control page to go to the Job page.
  4. Enter the text of your reply in Enter, below the line
    CASBJ0035I Console input request is pending.
  5. Click Reply.
  6. The job now continues.
Note: If you return to the Control page before you have entered your reply, you will see that a Pending Replies group has been added at the top of the page. There is a line of information for each pending reply, with a Reply button next to each line. If you click Reply on this page, you are returned to the Job page. The job remains paused until you enter a reply.
Parent topic: Deploying and Running JCL Applications
Parent topic: Interacting with JCL Jobs
Related information
To run a JCL job
To run a JCL job from the command line
To define a batch initiator or printer SEP
To start a batch initiator or printer immediately
To start a batch initiator SEP from the command line
To deploy a JCL application to an enterprise server
To start a batch printer SEP from the command line
To run a JCL job on a remote enterprise server
To view resource locks
To reply to an ACCEPT FROM CONSOLE statement


To run a JCL job

Important: If you are using Microsoft Internet Explorer's Enhanced Security Configuration feature you must disable it before following this procedure. For example:
  1. Close all instances of Internet Explorer.
  2. Select Start > Administrative Tools > Server Manager. If a User Account Control dialog box appears, click Continue..
  3. Under Security Summary, choose Configure IE ESC.
  4. Make sure both Administrators and Users are not selected.
  5. Click OK.
  1. In the dropdown list under Resources on the ESMAC menu, select JES.
  2. Click Control in the Resources part of the ESMAC menu.

    The JCL Control page that appears is for submitting jobs, and for starting additional printers and batch initiators.

  3. In the field by the Submit button, type the path and name of the JCL file you want to run. This file must exist on the machine on which the enterprise server is running.
  4. Click Submit.
Parent topic: Deploying and Running JCL Applications
Parent topic: Running and Controlling JCL Jobs


To run a JCL job from the command line

  1. Make sure the enterprise server you want to use is running, and was started from the command line.
  2. At aNet Express command prompt, enter:
    start cassub -jpath\jcl-file

    where path and jcl-file specify the JCL file to run. -j is the keyword identifying this parameter. There must be no space after the -j. For example:

    cassub -jc:\jclbatch\jclbatch.jcl

    You can specify the –j parameter more than once, in order to submit several JCL files in the same command.

    If you are submitting the job to an enterprise server that is local to your machine, you can use the –r parameter to specify the enterprise server to run the job. If you omit it, ESDEMO is assumed.

    If you want to submit the job to a remote enterprise server, you need to specify the -saddress parameter, where address is the address of the listener associated with the server's MF JES service.

    The job is run by the most recently started available initiator that can handle the class specified on the JOB card.

Parent topic: Deploying and Running JCL Applications
Related reference
cassub
Related information
To run a JCL job
To run a JCL job from the command line
To define a batch initiator or printer SEP
To start a batch initiator or printer immediately
To start a batch initiator SEP from the command line
To deploy a JCL application to an enterprise server
To start a batch printer SEP from the command line
To run a JCL job on a remote enterprise server
To view resource locks
To reply to an ACCEPT FROM CONSOLE statement


To run a JCL job on a remote enterprise server

Important: If you are using Microsoft Internet Explorer's Enhanced Security Configuration feature you must disable it before following this procedure. For example:
  1. Close all instances of Internet Explorer.
  2. Select Start > Administrative Tools > Server Manager. If a User Account Control dialog box appears, click Continue..
  3. Under Security Summary, choose Configure IE ESC.
  4. Make sure both Administrators and Users are not selected.
  5. Click OK.
  1. Open ES Admin for the remote enterprise server.
  2. In the list of servers, click Details in the Current Status column for the server to which you want to submit the job. The server must already be started.
  3. Click ES Monitor and Control.
  4. Submit the job using JES > Control in the usual way.
Note:
  • The JCL must be local to the machine you are submitting the job to.
  • While you are connected to the remote machine, you can view spool queues and the catalog in the usual way.
Parent topic: Deploying and Running JCL Applications
Parent topic: Running and Controlling JCL Jobs


To start a batch initiator or printer immediately

This starts a batch initiator or printer SEP "on the fly". You create it while the enterprise server is running, and it will immediately run any waiting jobs of the right class. It lasts until the enterprise server is stopped. If you want to define a batch initiator or printer SEP that will be a permanent feature of the enterprise server, starting up whenever the enterprise server is started, see To define a batch initiator or printer SEP.

  1. If you are starting a printer, make sure the enterprise server was started from the command line.
  2. In the dropdown list under Resources on the ESMAC menu, select JES.
  3. Click Control in the Resources part of the ESMAC menu.

    The JCL Control page that appears is for submitting jobs, and for starting additional printers and batch initiators.

  4. Select Initiator or Printer from the dropdown list by the Type field.
  5. In Classes, type the list of job classes you want this initiator to run, or this printer to print; for example, ABC. The JOB CLASS of a JCL jobstream must match the class of a batch initiator SEP in order for the SEP to run the job. The MSGCLASS or SYSOUT class must match the class of a batch printer SEP in order for the SEP to print the output.
  6. If you are defining an initiator for jobs that you want to debug, click Debug.
  7. For a printer, select a printer in the list in Printer Name.
  8. Click Start.

    The batch initiator or printer will start immediately and last until the enterprise server is stopped.

Parent topic: Deploying and Running JCL Applications
Parent topic: On-the-fly SEPs for JCL
Related information
To define a batch initiator or printer SEP
To run a JCL job
To run a JCL job from the command line
To start a batch initiator or printer immediately
To start a batch initiator SEP from the command line
To deploy a JCL application to an enterprise server
To start a batch printer SEP from the command line
To run a JCL job on a remote enterprise server
To view resource locks
To reply to an ACCEPT FROM CONSOLE statement


To start a batch initiator SEP from the command line

  1. Make sure the enterprise server you want to use is running, and was started from the command line.
  2. At aNet Express command prompt, enter:
    casout /iclasslist

    where classlist specifies the job classes that the initiator is to be able to run. There must be no space after the /b. For example:

    casout -iABC

    You can use the /r parameter to specify the enterprise server to run the job. If you omit it, ESDEMO is assumed.

Parent topic: Deploying and Running JCL Applications


To start a batch printer SEP from the command line

  1. Make sure the enterprise server was started from the command line or from the Visual Studio IDE.
  2. At a command prompt, enter:
    start cassi -pclasslist -q"printer" -renterprise-server

    or:

    start cassi -pclasslist -q"printer" -renterprise-server -zprinter-exit

    where classlist specifies the job classes that the SEP is to handle, printer is the name of the printer (as defined in Windows), enterprise-server is the enterprise server to start it in (default ESDEMO), and the optional printer-exit specifies a Printer Exit module. For example:

    start cassi -pABC -q"HP LaserJet 4L" -rESDEMO

    or:

    start cassi -pABC -q"HP LaserJet 4L" -rESDEMO -zSAMPPRNX

    Note that it’s advisable to run this command in a separate session, using the Windows start command as shown.

Parent topic: Deploying and Running JCL Applications
Related reference
cassi (JCL version)
Related information
To run a JCL job
To run a JCL job from the command line
To define a batch initiator or printer SEP
To start a batch initiator or printer immediately
To start a batch initiator SEP from the command line
To deploy a JCL application to an enterprise server
To start a batch printer SEP from the command line
To run a JCL job on a remote enterprise server
To view resource locks
To reply to an ACCEPT FROM CONSOLE statement


To stop a JES initiator from the command line

Use the casout command with the /t operand to stop a JES initiator without stopping the region.

Example

if test "$#" -ne 2
then
  echo "*** ERROR - missing parameters"
  echo "usage: stopclass region-name class"
  exit 99
fi

region=`echo $1 | sed 's/ .*$//'`
class=`echo $2 | tr '[a-z]' '[A-Z]'`

COBDIR=/opt/microfocus/cobol
export COBDIR
PATH=$COBDIR/bin:$PATH
export PATH
LD_LIBRARY_PATH=$COBDIR/lib:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH
casout -r$region -v
if test "$?" -eq 0
then

  casout -r$region -v | grep 'tor '$class | cut -d" " -f5 >startClass.txt
  processID=`cat startClass.txt | sed 's/ .*$//'`
  casout -r$region -t$processID
else
  echo "*** ERROR - Return Code: "$?
  exit $?
fi

jobrc=$?

case "$jobrc"
in
  0)   echo "Processing Successful: "$jobrc;;
  15)  echo "*** ERROR - Invalid Region Name: "$region
       echo "*** Return Code: "$jobrc;;
  99)  echo "*** ERROR - JES not available for Region: "$region
       echo "*** Return Code: "$jobrc;;
  199) echo "*** ERROR - User ID not authorised: "$region
       echo "*** Return Code: "$jobrc;;
  255) echo "*** ERROR - Region is not started: "$region
       echo "*** Return Code: "$jobrc;;
  *)   echo "*** ERROR - Return Code: "$jobrc;;
esac
Parent topic: Deploying and Running JCL Applications


Spool Queue Tasks

The following spool queue tasks are available:

  • To delete a job
  • To delete a job output file
  • To delete all jobs in a queue
  • To hold or release a job
  • To update control information for a job
  • To view details of a job output file
  • To view details of a job's execution
  • To view the contents of a job output file
  • To view the spool queues
Parent topic: JCL Support Tasks


To delete a job

  1. On the Spool page click the button for the queue that contains the job.
  2. Click the check box to the left of the row describing the job you want to delete.
  3. Click Delete.
Note: An alternative method is to go to the JOBnnnnn page, where nnnnn is the number of the job, and click Delete
Parent topic: Spool Queue Tasks
Parent topic: Managing and Viewing Spool Queues
Related information
To view the spool queues
To view details of a job's execution
To hold or release a job
To update control information for a job
To delete a job
To view details of a job output file
To delete a job output file
To view the contents of a job output file
To delete all jobs in a queue


To delete a job output file

  • On the job output file details page click Purge.
Parent topic: Spool Queue Tasks
Parent topic: Managing and Viewing Spool Queues
Related information
To view the spool queues
To view details of a job's execution
To hold or release a job
To update control information for a job
To delete a job
To view details of a job output file
To delete a job output file
To view the contents of a job output file
To delete all jobs in a queue


To delete all jobs in a queue

  1. On the Spool page click the button for the queue that contains the jobs.
  2. Click the check box to the left of the Display button. This selects all the jobs in the queue.
  3. Click Delete.
Parent topic: Spool Queue Tasks
Parent topic: Managing and Viewing Spool Queues
Related information
To view the spool queues
To view details of a job's execution
To hold or release a job
To update control information for a job
To delete a job
To view details of a job output file
To delete a job output file
To view the contents of a job output file
To delete all jobs in a queue


To hold or release a job

  • On the JOBnnnnn page, where nnnnn is the number of the job, or on the job output file details page, click Hold or Release.
Note:
  • Hold changes to Release after you have clicked it, and Release changes back to Hold after a further click. The Status field also changes accordingly.
  • If the job is in the input queue when you click Hold, it is not executed until you release it. if the job is in the output queue when you click Hold, the output files are not printed until you release it.
  • If you have also changed the value for Class or Priority, the change is applied.
Parent topic: Spool Queue Tasks
Parent topic: Managing and Viewing Spool Queues
Related information
To view the spool queues
To view details of a job's execution
To hold or release a job
To update control information for a job
To delete a job
To view details of a job output file
To delete a job output file
To view the contents of a job output file
To delete all jobs in a queue


To update control information for a job

  1. On the JOBnnnnn page, where nnnnn is the number of the job, or on the job output file details page, specify a new Class or Priority or both.
  2. Click Update.
Parent topic: Spool Queue Tasks
Parent topic: Managing and Viewing Spool Queues
Related information
To view the spool queues
To view details of a job's execution
To hold or release a job
To update control information for a job
To delete a job
To view details of a job output file
To delete a job output file
To view the contents of a job output file
To delete all jobs in a queue


To view details of a job output file

  • On the JOBnnnnn page, where nnnnn is the number of the job, click Details against the name of the output file that you want to view details for.
Parent topic: Spool Queue Tasks
Parent topic: Managing and Viewing Spool Queues
Related information
To view the spool queues
To view details of a job's execution
To hold or release a job
To update control information for a job
To delete a job
To view details of a job output file
To delete a job output file
To view the contents of a job output file
To delete all jobs in a queue


To view details of a job's execution

  1. On the Spool page click the button for the queue that contains the job.
  2. Click the check box to the left of the row describing the job that you want to view.
  3. Click Display.
Note: You can also view details of a job's execution by entering the job number in the field next to the Job button, then clicking Job. This facility is available on some of the other JCL-related pages in ESMAC.
Parent topic: Spool Queue Tasks
Parent topic: Running and Controlling JCL Jobs
Parent topic: Managing and Viewing Spool Queues
Related information
To view the spool queues
To view details of a job's execution
To hold or release a job
To update control information for a job
To delete a job
To view details of a job output file
To delete a job output file
To view the contents of a job output file
To delete all jobs in a queue


To view the contents of a job output file

  1. On the job output file details page find the line with a Display button at the left-hand side.
  2. Update the fields Start and for to indicate which records you want to view. Clear the for field to view all the records in a file. The default is that you view the first 10000 records or the whole file, whichever is the shorter.
  3. In Codeset choose the codeset that you want to be used for the display.
  4. If you want to see extra details check Details.
  5. Click Display.

    The contents of the output file are displayed. Click Back on your Browser toolbar to return to the job output file page.

Note:
  • If you are viewing the spool queues from ES Admin, and you attempt to view all the records in a large job output file, be aware that your browser will take some time to display all the records, and might run out of memory.
Parent topic: Spool Queue Tasks
Parent topic: Managing and Viewing Spool Queues
Related information
To view the spool queues
To view details of a job's execution
To hold or release a job
To update control information for a job
To delete a job
To view details of a job output file
To delete a job output file
To view the contents of a job output file
To delete all jobs in a queue


To view the spool queues

  1. In the dropdown list under Resources on the ESMAC menu, select JES.
  2. Click Spool in the Resources part of the ESMAC menu.
  3. The page that appears shows one of the spool queues. Click one of the row of buttons to select which queue is displayed.
Parent topic: Spool Queue Tasks
Parent topic: Managing and Viewing Spool Queues
Related information
To view the spool queues
To view details of a job's execution
To hold or release a job
To update control information for a job
To delete a job
To view details of a job output file
To delete a job output file
To view the contents of a job output file
To delete all jobs in a queue


JCL Catalog Tasks

The following JCL catalog tasks are available:

  • To copy a catalog entry for a data set
  • To create a catalog entry for a data set
  • To delete a catalog entry for a data set
  • To update a catalog entry for a data set
  • Importing and Exporting a Catalog: import export utility
    Describes how to use the catalog import-export utility
  • To view the catalog
  • To view the contents of a data set
  • To view the details of a catalog entry
Parent topic: JCL Support Tasks


To copy a catalog entry for a data set

  1. On the Data Catalog page click Details against the entry that you want to copy.
  2. On the Catalog Entry page click Copy.
  3. Specify the properties of the data set in the new catalog entry.
  4. Click Apply.
Parent topic: JCL Catalog Tasks
Parent topic: Viewing the Catalog and Data Sets


To create a catalog entry for a data set

  1. On the Data Catalog page click New.
  2. Specify the properties of the data set.
  3. Click Apply.
Parent topic: JCL Catalog Tasks
Parent topic: Viewing the Catalog and Data Sets


To delete a catalog entry for a data set

  1. On the Data Catalog page click Details against the entry that you want to delete.
    Note: No entries are shown on the Data Catalog page until you click the List button. You can use the field adjacent to the List button to enter a filter string to limit the number of entries displayed. For example, enter "ABC*" to view only those data sets that begin with ABC. You can use a single asterisk as a wild card.
  2. Click Delete.
Parent topic: JCL Catalog Tasks
Parent topic: Viewing the Catalog and Data Sets


To update a catalog entry for a data set

  1. On the Data Catalog page click Details against the entry that you want to update.
    Note: No entries are shown on the Data Catalog page until you click the List button. You can use the field adjacent to the List button to enter a filter string to limit the number of entries displayed. For example, enter "ABC*" to view only those data sets that begin with ABC. You can use a single asterisk as a wild card.
  2. Change the properties of the data set as required.
  3. Click Apply.
Parent topic: JCL Catalog Tasks
Parent topic: Viewing the Catalog and Data Sets


Importing and Exporting a Catalog: import export utility

The catalog import-export utility is supplied to make it easier to work with the contents of a catalog. You can use the catalog import export utility to:

  • Extract the contents of the system catalog to an XML file
  • Import a system catalog from a source XML file
  • Extract and/or update individual catalog records
Note:

This utility is intended as a tool for use during migrations. It is definitely NOT recommended that you use it for editing the catalog data for live systems. The recommended way of manipulating catalog entries is via JCL, where consistency can be guaranteed. For bulk changes to the PC-DSN field, MVSPCRN is recommended.

Use caution when performing catalog updates. Setting inconsistent field values will cause errors.

Setting the MFSYSCAT environment variable

In order to use the catalog import export utility, you need to set the MFSYSCAT environment variable to the catalog path and filename. For example:
set MFSYSCAT=c:\test\project\catalog.dat

Invoking the catalog import export utility from the command line

The utility can be invoked from the command line or by calling it from another program. Use the syntax:
Call MVSP0033 using ws-command-line
In the command above, ws-command-line is a command with the syntax and parameters described below.

Syntax

MFCATXML FUNC(xxxx) INFILE(filename)
OUTFILE(filename) KEY(xxxx)

The function's operation, and the parameters that you use, varies depending on the value of the FUNC parameter.

Export entire catalog: Func = EXP

Exports the entire catalog to an XML file.

OUTFILE The name of the file to hold the exported data.

Import a catalog: Func = IMP

Imports a catalog from an XML file.

INFILE The name of the file with the catalog data to be imported.

Export specific catlalog records: Func = GU

Reads details for specified catalog records and writes them to a file.

INFILE(filename) | The catalog entries for all the MVS DATASET names found in the XML document filename are retrieved
KEY(datasetname) | The record for the single MVS dataset name in the datasetname parameter is retrieved
KEY(@filename) | The records for all the MVS dataset name in the filename parameter are retrieved. filename must be a text file with each successive dataset on a new line.
OUTFILE(filename) | The output file for the catalog records.

Insert records into a catalog: Func = ISRT

Reads catalog record details from INFILE and inserts these catalog records.

INFILE(filename) The name of the XML file with the catalog data to be inserted.

Replace existing catalog records: Func = REPL

Reads catalog record details from INFILE and replaces corresponding existing catalog records.

INFILE(filename) The name of the XML file with the catalog data to be replaced.

Delete catalog records: Func = DLET

Deletes catalog records.

INFILE(filename) | Deletes catalog entries for all the MVS DATASET names found in filename.
KEY (datasetname) | Deletes the record for the single dataset name set defined in datasetname.
KEY(@filename) | Deletes all of the catalog records for all the MVS dataset names listed in filename. This file must be a text file with each successive dataset on a new line.

Examples

The following command creates the OUT.XML XML file that contains all of the data held in the catalog identified in the MFSYSCAT environment variable.

MFCATXML FUNC(EXP) OUTFILE(OUT.XML)

The resulting XML file can be edited and then imported using the following command:

MFCATXML FUNC(IMP) INFILE(OUT.XML)

Comments

When exporting large catalog files (>100,000 records), the export process spreads the contents over multiple XML files, to avoid memory problems. After the first file, subsequent files are appended with 001, 002, 003, etc. When importing one of these large catalog files, you must remember to run the import on each generated .xml file.

To set the threshold at which an additional .xml file is generated on export, set the MF_MVSP0034_LIMIT environment variable to the required threshold (number of records). The default is set to 100,000 records.

Parent topic: JCL Catalog Tasks
Parent topic: Viewing the Catalog and Data Sets
Parent topic: Administering JCL-enabled Enterprise Servers


To view the catalog

  1. In the dropdown list under Resources on the ESMAC menu, select JES.
  2. Click Catalog in the Resources part of the ESMAC menu.
  3. To limit the entries displayed, enter a filter string in the text field next to the List button. For example, enter "ABC*" to view only those data sets that begin with ABC. You can use a single asterisk as a wild card.
  4. Click the List button.
Note:

In addition to filtering list items, you can control the number of items in the catalog view by setting the ES_ESMAC_DISP_MAX_OVERRIDE environment variable.

For example, the maximum number of items displayed can be set to 100:

configuration:
[ES-Environment]
ES_ESMAC_DISP_MAX_OVERRIDE=100
Parent topic: JCL Catalog Tasks
Parent topic: Viewing the Catalog and Data Sets


To view the contents of a data set

  1. On the Data Catalog page click Details against the entry that you want to update.
    Note: No entries are shown on the Data Catalog page until you click the List button. You can use the field adjacent to the List button to enter a filter string to limit the number of entries displayed. For example, enter "ABC*" to view only those data sets that begin with ABC. You can use a single asterisk as a wild card.
  2. Update the fields Start and for to indicate which records you want to view. Clear the for field to view all the records in a file. The default is that you view the first 10000 records or the whole file, whichever is the shorter.
  3. In Codeset choose the codeset that you want to be used for the display.
  4. If you want to see extra details check Details.
  5. Click Display.

    The contents of the data set are displayed. Click Back on your Browser toolbar to return to the Catalog Entry page.

Note: If you are viewing the catalog from ES Admin, and you attempt to view all the records in a large file, be aware that your browser will take some time to display all the records, and might run out of memory.
Parent topic: JCL Catalog Tasks
Parent topic: Viewing the Catalog and Data Sets


To view the details of a catalog entry

  • On the Data Catalog page click Details against the entry that you want to view.
    Note: No entries are shown on the Data Catalog page until you click the List button. You can use the field adjacent to the List button to enter a filter string to limit the number of entries displayed. For example, enter "ABC*" to view only those data sets that begin with ABC. You can use a single asterisk as a wild card.
Parent topic: JCL Catalog Tasks
Parent topic: Viewing the Catalog and Data Sets


IMS Support Tasks

  • To add a resource group to a startup list
  • To add a message processing region to a resource group
  • To add PCT entries to a resource group
  • To enable IMS for an MSS-enabled enterprise server
  • To specify the location of genned files
  • To define a transaction manually
  • To define how MFS attributes are coded
  • To define the MFS null character
  • To start a WebSphere MQSeries trigger monitor
  • To stop a WebSphere MQSeries trigger monitor
  • To generate a PSB for a Trigger Monitor
  • To create an XA resource for a trigger monitor
Parent topic: Enterprise Server Task Index
Parent topic: IMS Support


To add a resource group to a startup list

  1. In the list of buttons under Resources on the ESMAC menu, click Startup.
  2. Click Details next to the entry for the startup list to which you want to add the resource group.
  3. Specify the name of the resource group in the empty field at the bottom of the list of resource groups.
  4. Click Apply.
  5. Click Home to return to the Home page of Enterprise Server Administration.
Parent topic: IMS Support Tasks
Parent topic: Adding a Resource Group to a Startup List
Related information
To enable IMS for an MTO-enabled enterprise server
To specify the location of genned files
To add PCT entries to a resource group
To add a message processing region to a resource group
To define a transaction manually


To add a message processing region to a resource group

  1. In the dropdown list under Resources on the ESMAC menu, select By Group.
  2. Click Groups, then click Details next to the resource group you want to update.
  3. Click JES.
  4. Specify IMS MPR in the Type field, the relevant classes in the Classes field, and an appropriate text in the Name and Description fields.
  5. Click Add.
  6. Click Group List.
Note:

Defining a message processing reigon for an enterprise server in this way causes a message processing region to start each time the enterprise server is started. For information on creating a message processing region that only exists until an enterprise server stops, see the section Temporary MPRs in the chapter Administering IMS-enabled Enterprise Servers in your Mainframe Subsystem Support Configuration and Administration Guide.

Parent topic: IMS Support Tasks
Parent topic: Adding a Message Processing Region to a Resource Group
Related information
To enable IMS for an MTO-enabled enterprise server
To specify the location of genned files
To add PCT entries to a resource group
To define a transaction manually


To add PCT entries to a resource group

  1. In the dropdown list under Resources on the ESMAC menu, select By Group.
  2. Click Groups, then click Details next to the resource group you want to update.
  3. Click PCT.
  4. Specify the name of the transaction in the Name field and the name of the associated program in the Program Name field.
  5. Click Add.
  6. Click Group List.
Parent topic: IMS Support Tasks
Related information
To enable IMS for an MTO-enabled enterprise server
To specify the location of genned files
To add a message processing region to a resource group
To define a transaction manually


To enable IMS for an MSS-enabled enterprise server

  1. On the Home page of Server Enterprise Administration, click Edit next to the name of the enterprise server you want to enable.
  2. The Edit page that appears contains a hierarchy of tabs. Click the Server, Properties, MSS, IMS and General tabs.
  3. Ensure that Mainframe Subsystem Support enabled is checked, then check IMS enabled.
  4. Click Apply.
Parent topic: IMS Support Tasks
Parent topic: Enabling IMS for an Enterprise Server
Related concepts
Configuring IMS Printers
Related tasks
To define specific printers for an IMS-enabled enterprise server
Related information
To specify the location of genned files
To add PCT entries to a resource group
To add a message processing region to a resource group
To define a transaction manually


To specify the location of genned files

  1. In the table of servers click Edit to the left of the row for the server you want to change.
  2. The Edit page that appears contains a hierarchy of tabs. Click the Server, Properties, MSS, IMS and General tabs.
  3. In the GEN file directory field, specify the name of the folder that this enterprise server will look in for files generated from DBD and PSB files.
  4. Click Apply to save the change.
  5. Click the Server, Properties, MSS, IMS, TM and General tabs.
  6. In the MFS path field, specify the name of the folder that this enterprise server will look in for files generated from MFS files.
  7. Click Apply to save the change.
  8. Click Home to return to the Home page of Server Enterprise Edition Administration.
Parent topic: IMS Support Tasks
Parent topic: Specifying the Location of Genned Files
Related information
To enable IMS for an MTO-enabled enterprise server
To add PCT entries to a resource group
To add a message processing region to a resource group
To define a transaction manually


To define a transaction manually

  1. In the dropdown list under Resources on the ESMAC menu, select IMS.
  2. Click Transact., then click New.
  3. Specify the values you require for your new transaction.
  4. Click Add then Apply.
Parent topic: IMS Support Tasks
Parent topic: Defining Transactions Manually
Related information
To add a resource group to a startup list
To enable IMS for an MTO-enabled enterprise server
To specify the location of genned files
To add PCT entries to a resource group
To add a message processing region to a resource group


To define how MFS attributes are coded

Transaction level

  1. In the dropdown list under Resources on the ESMAC menu, select IMS.
  2. Click Transact..
  3. Click Details for the transaction to be modified, or New if you are creating a new transaction.
  4. Select the appropriate value for the MFS Attributes field. Where you set this to 'Default', the value set at Enterprise Server level (see below) will be used.
  5. Click Add or Apply as appropriate.

Enterprise Server level

  1. On the Home page of Server Enterprise Edition Administration, click Edit next to the name of the enterprise server you want to enable.
  2. The Edit page that appears contains a hierarchy of tabs. Click the Server, Properties, MSS, IMS and TM tabs.
  3. Select the desired value for MFS attribute bias field.
    Note: You can override this value at transaction level.
  4. Click Apply.
Note: This task is only applicable if the codeset bias being used is 'ASCII'.
Parent topic: IMS Support Tasks
Parent topic: Special Characters in MFS Attributes
Related information
Migrating IMS Applications
To define the MFS null character


To define the MFS null character

Transaction level

  1. In the drop-down list under Resources on the ESMAC menu, select IMS.
  2. Click Transact.
  3. Click Details for the transaction to be modified, or New if you are creating a new transaction.
  4. Select the appropriate value for the MFS Null field. Where you set this to [default], the value set at Enterprise Server level (see below) will be used.
  5. Click Add or Apply as appropriate.

Enterprise Server level

  1. On the Home page of Server Enterprise Edition Administration, click Edit next to the name of the enterprise server you want to enable.
  2. The Edit page that appears contains a hierarchy of tabs. Click the Server, Properties, MSS, IMS and TM tabs.
  3. Select the desired value for MFS null character field.
    Note:

    You can override this value at transaction level.

  4. Click Apply.
Note: This task is only applicable if the codeset bias being used is 'ASCII'.
Parent topic: IMS Support Tasks
Parent topic: Null MFS Fields
Related information
Migrating IMS Applications
To define how MFS attributes are coded


To start a WebSphere MQSeries trigger monitor

  1. Copy the supplied file CSQ4TRMN.JCL to an appropriate location. This file can be found in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source folder.
  2. Edit the QMGRNAME and INITQUEUENAME parameters to match the WebSphere MQ Queue Manager and Initiation Queue objects.
  3. Change the job class if required.
  4. Ensure that an initiator for the job class has been started.
  5. Submit CSQ4TRMN.JCL using the JCL Control Page under Enterprise Server Monitor and Control, or by using the cassub command.
Parent topic: IMS Support Tasks
Parent topic: What You Can Do


To stop a WebSphere MQSeries trigger monitor

  1. Copy the supplied file CSQ4STOP.JCL to an appropriate location. This file can be found in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source folder.
  2. Edit the PARM line to specify the appropriate Queue Manager and Initiation Queue.
  3. Submit CSQ4STOP.JCL using the JCL Control Page under Enterprise Server Monitor and Control, or by using the cassub command.
Attention: The trigger monitor should be stopped before stopping the Enterprise Server region.
Parent topic: IMS Support Tasks
Parent topic: What You Can Do


To generate a PSB for a Trigger Monitor

  1. Copy the supplied file CSQ4TRMN.PSB to an appropriate location. This file can be found in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source folder.
  2. At a command prompt enter the following command:
    mfims psbgen csq4trmn.psb nocls echo(enderr,0,55)
Parent topic: IMS Support Tasks
Parent topic: What You Can Do


To create an XA resource for a trigger monitor

Follow the steps in the topic To Add an XA Resource to an Enterprise Server Instance using the following properties:

For one-phase commit transactions
ID | MQXA
Name | MQSERIES
Module | DFHEIBMQ
Open string | tpm=ESCICS,axlib=casaxlib.dll,qmname=queue manager name
Enabled | checked
For two-phase commit transactions
ID | MQXA
Name | MQSERIES
Module | ESMQXA
Open string tpm=CICS,axlib=casaxlib,qmname=queue manager name, channel, trptype, conname
QMNAME
The name of the queue manager. This is a mandatory parameter.
TPM
The transaction manager being used. Must be set to CICS.
AXLIB
The name of the library that contains the transaction manager's ax_reg and ax_unreg functions. Must be set to casaxlib.
CHANNEL
The name of an MQI channel. If this parameter is supplied, the CONNAME parameter must also be supplied.
TRPTYPE
The communications protocol for the MQI channel. The following are valid values:
LU62
SNA LU 6.2
NETBIOS
NetBIOS
SPX
IPX/SPX
TCP
TCP/IP
The default is TCP.
CONNAME
The network address of the queue manager. The valid values of this parameter depend on the value of the TRPTYPE parameter.
If TRPTYPE is set to: CONNAME must be:
LU62 A symbolic destination name, which identifies a CPI-C side information entry.

You cannot use the network qualified name of a partner LU or a partner LU alias.

NETBIOS | A NetBIOS name.
SPX A 4-byte network address, a 6-byte node address, and an optional 2-byte socket number.

These values must be specified in hexadecimal notation. A period must separate the network and node addresses, and any socket number must be enclosed in parentheses. For example:

0a0b0c0d.804abcde23a1(5e86)

The default value is 5e86.

TCP | A host name or an IP address, optionally followed by a port number in parentheses. The default value is 1414.
If this parameter is supplied, the CHANNEL parameter must also be supplied.
Enabled | checked
Parent topic: IMS Support Tasks
Parent topic: What You Can Do


Enterprise Server Reference

  • Administration and Configuration Commands
  • Error Messages
  • User Exits
Parent topic: Configuration and Administration


Administration and Configuration Commands

The following commands are available for performing Enterprise Server administration procedures.

  • casdump
    Forces a system dump.
  • casdup
    Formats a system dump or auxiliary trace so that it is suitable for analysis.
  • cassi
    Starts a service execution process. You should use this command only when you want to debug a service, using the /a option.
  • casstart
    Starts an enterprise server.
  • casstop
    Stops an enterprise server.
  • mfdepinst
    Installs the services contained in a COBOL archive file (.car file) onto the enterprise server.
  • mfds
    Manages the Directory Server.
  • mfpackage
    This utility is used for maintaining services and packages installed on an enterprise server. Its function is to delete all services and packages in a given namespace for a given enterprise server region.
Parent topic: Enterprise Server Reference


mfds

Manages the Directory Server.

Syntax for starting or stopping the Directory Server:

mfds [/d|/dn network-address|/n network-address] [/j journal-path] [/r] [/p port-number]

Syntax for stopping the Directory Server

mfds [/p port-number] -s option [username password]

Syntax for reporting and exporting information:

mfds /v
mfds /m
mfds /e root-DN user-partition-DN group-partition-DN
          resource-partition-DN schema-format ldif-filename
          sec-path
mfds /l [schema partition Distinguished Name] option ldif-filename [schema-version-1] [schema-version-2]

Syntax for exporting the currently active MFDS process repository to a specified path:

mfds -x [repository type] [repository address] [server name] <opts> <user id> <password>

Examples:

"mfds -x 1 c:\myrepository *"
"mfds -x 1 c:\myrepository * S"
"mfds -x 1 c:\myrepository * O"
"mfds /x 1 c:\myrepository * SO"
"mfds /x 1 c:\myrepository ESDEMO"
"mfds /x 1 c:\myrepository ESDEMO D myid mypwd"

Syntax for creating a readable journal file from a binary journal file:

mfds /t output-filename input-filename
Note:

If output-filename is not specified, a default file of journal.txt will be created in the same directory as the input-filename

If input-filename is not specified, the default journal.dat file as specified by the default MFDS options file (mfdsacfg.dat) will be used.

This option can only convert journal.dat files to text if they have originated on the same hardware and software platform; it is not guaranteed that journal files imported from UNIX can be read by Windows and visa versa.

Syntax for installing and uninstalling Windows services:

mfds /c
mfds /u
mfds /i

Parameters:

/c
Install the Directory Server as a Windows service, and when it runs, show the debug information console. Once you have issued the mfds command with this parameter, you start Directory Server using the Windows Control Panel.
/d
Show debug information; this is a record of activity on the Directory Server that can be useful when investigating problems
/dn network-address
Show debug information and bind to the specific network adapter at network-address, where network-address is four decimal numbers of up to three digits separated by full stops.
/e root DNuser partition DNgroup partition DNresource partition DNschema formatldif-filenamesec-path
Export Directory Server users and groups from the MF Directory Server repository to an LDIF file:
  • root-DN

    The application partition to which all of the exported entries will be assigned.

  • user-partition-DN

    The name of the container within the application partition to which the exprted users will be assigned.

  • group-partition-DN

    The container within the application partition to which the exported groups will be assigned.

  • root-DN

    The container within the application partition to which the exported resource definitions will be assigned.

  • schema-format

    Values: 1 = Active Directory (Default).

  • sec-path

    The location of the MF Directory Server repository.

/i
Install the Directory Server as a Windows service, and when it runs, do not show the debug information console. Once you have issued the mfds command with this parameter, you start Directory Server using the Windows Control Panel.
/j directory-path
Override the journal path. Journal data will be written to the filesystem directory that you specify. For example: mfds /j e:\journal
/l [schema partition Distinguished Name] optionldif-filename [schema-version-1] [schema-version-2]
Export the schema extensions that an LDAP server will require to support Micro Focus applications.
  • schema partition Distinguished Name

    Specifies the DN of the partition in the Directory Information Tree where the schema definition is held. The schema partition holds, amongst other things, attributeSchema and classSchema objectclass instances.

  • option

    Specifies the target directory server type: 0 = Microsoft Active Directory Application Mode (ADAM), 1 = Active Directory (Default), 2 = OpenLDAP, 3 = Sun Directory

    Note:

    If you specify the ldif-filename , you must also specify a value for this parameter.

  • ldif-filename

    Specifies the name of the destination file.

    Default: mfds_schema_[ mfds version ].ldf (e.g. mfds_schema_1.05.09.ldf)

  • schema-version-1

    Specifies the version of the schema extensions to be generated: 0 = current schema version (Default). Numbers greater than 0 specify older schema versions.

  • schema-version-2

    This option is used for upgrading from a previous schema. If schema-version-2 is specified and is less the schema-version-1, the output file is a delta between the schema-version-1 and schema-version-2.

    If schema-version-2 is greater than or equal to schema-version-1, this option is ignored.

/m
Display the location of the Directory Server repository.
/n network-address
Bind to the specific network adapter at network-address, where network-address is four decimal numbers of up to three digits separated by full stops.
/p port-number
Bind to a non-standard port.
Note:

Many programs depend on Directory Server using the default port (86). Therefore, if you use an alternative port, you may experience interoperability problems.

You should also consider carefully before using this option to run more than one Directory Server on the same machine. By default, both would use the same options file and repository, and might therefore encounter conflicts.

/r
Refuse access to the Enterprise Server Administration interface.
/s option [usernamepassword]
Request a controlled shutdown of a Directory Server and optionally the associated enterprise servers. If the Directory Server is not using the default port, the /p option must be used to specify the port that is being used.
Option:
  • Value 1: Shutdown the Directory Server only
  • Value 2: Shutdown the Directory Server and any associated enterprise servers.

Username and password: These must be supplied if the Directory Server is running with Restrict administration access checked.

/u
Uninstall Directory Server as a Windows service
/v
Show version information for Directory Server
/x [repository type]
1 = file:///
[server name]
* = export all servers
<opts>
  • D = (default) do not delete or overwrite any existing repository contents at specified location.
  • O = delete and overwrite any existing repository contents at specified location.
  • S = export server and security manager configuration.
<user id> <password>
These are the MFDS credentials required if administration access is restricted.

Comments:

Note: Issuing an mfds command with any of the parameters /c, /e, /i, /l, /m, /u, /v does not start the Directory Server.

On UNIX you should use a dash (-) before a parameter as an alternative to a forward slash (/).

Parent topic: Administration and Configuration Commands


mfpackage

This utility is used for maintaining services and packages installed on an enterprise server. Its function is to delete all services and packages in a given namespace for a given enterprise server region.

The utility is equivalent to deleting the services and packages using the Micro Focus Administration Console (MFDS), and can be used to prepare the server before deploying a new version of the service.

Syntax:

mfpackage [options] command service-namespace [parameters]

Parameters:

command | undeploy. Deletes the services and packages in the supplied namespace.
options | -m URL | host | Directory. Supported URL schemes are "file", "mrpi", and "ldap". Default is MFDS on the local system using the default port (equivalent to mrpi://localhost:86).
 | -s server | Operates on packages and services for this server. Required for undeploy.
 | -p password | Optional password for binding to directory.
 | service- namespace | The namespace for the services and packages. For a web service, this is everything before the "#" character in the service/package name. For a J2EE service, it is everything before the final "." character.

Example:

mfpackage -m mrpi://localhost -s ESDEMO undeploy http://tempuri.org/wmapserv
Parent topic: Administration and Configuration Commands


Error Messages

  • Client Messages
  • Directory Server Error Messages
  • Enterprise Server Error Messages
Parent topic: Enterprise Server Reference


Client Messages

This topic lists the messages that clients of Enterprise Server can display.

Error number | Meaning
-1 | Error status is unknown
0 | Success
00001 | Internal error in common client
00002 | Feature has not been implemented
00003 | Unsupported protocol version or feature
00004 | Requested object not found (in Directory Server repository)
00005 | Not used
00006 | Error in parameters to function
00007 | Resource unavailable, for example, memory allocation failed
00008 | Communications error
00009 | Object is in wrong state for operation
00010 | Bad data problem (for example, non-HTTP response to HTTP request)
00011 | Operating system error
00012 | An external component failed (for example MLDAP unable to bind to Directory Server)
00013 | Data was truncated
00014 | No data was available, possibly because the server was not available
00015 | Client request timed out
00016 | Requested service is not available
00017 | No user data was returned by the server
00100 | Invalid IDT version
00101 | Invalid message type
00102 | Servicename not found in IDT
00103 | Unsupported mapping
00150 | Unable to initialise request handler
00151 | Unable to initialise interface mapper
00250 | Unable to initialise SOAP parser
00400 | Invalid binary protocol version
00401 | Unrecognised binary protocol message
00402 | Program/entry point not found
00450 | Invalid namespace for SOAP envelope
00451 | Invalid namespace for SOAP header
00452 | Invalid namespace for SOAP body
00453 | Invalid SOAP message
00454 | No SOAP URI in SOAP message
00455 | SOAP action URI differs from SOAP Body URI
00456 | Unable to resolve href in SOAP message
00457 | Unrecognised encoding style
00458 | Illegal character in SOAP string
00500 | Parameter not found in IDT
00501 | External data not located
00502 | Invalid implementation language
00503 | Unsupported mapping
00504 | Expected mapping not defined
00505 | Invalid ODO item
00506 | Invalid structured mapping
00507 | Insuffient subscripts for external item
00508 | Subscript for external item does not exist
00509 | Too many subscripts for external item
00510 | Error in exit handler
00600 | External field not found
00601 | Unsupported external data type
00602 | Expected parameter not supplied by external interface
00603 | Expected external structure field not found
00604 | Expected external array field not found
00605 | Incorrect number of parameters supplied
00606 | Incorrect number of fields in supplied structure
00607 | External data type mismatch
00608 | Unknown external data type
00609 | Incorrect number of array elements
00610 | Too many array elements passed in message
01400 | HTTP response: bad request
01401 | HTTP response: unauthorized
01403 | HTTP response: forbidden
01404 | HTTP response: not found
01405 | HTTP response: method not allowed
01406 | HTTP response: not acceptable
01407 | HTTP response: proxy authentication required
01408 | HTTP response: request timeout
01409 | HTTP response: conflict
01410 | HTTP response: gone
01411 | HTTP response: length required
01412 | HTTP response: precondition failed
01413 | HTTP response: request entity too large
01414 | HTTP response: request-URI too long
01415 | HTTP response: unsupported media type
01416 | HTTP response: requested range not satisfiable
01417 | HTTP response: expectation failed
01500 | HTTP response: internal server error
01501 | HTTP response: not implemented
01502 | HTTP response: bad gateway
01503 | HTTP response: service unavailable
01504 | HTTP response: gateway timeout
01505 | HTTP version not supported
02000 | SOAP response fault
Parent topic: Error Messages


Directory Server Error Messages

This topic lists the messages that the Directory Server can display, and gives an explanation or advice or both for those that are not self-explanatory.

Format of Messages

The Directory Server displays messages in the status line in the format:

MDSnnnns message-text

where MDS stands for Micro Focus Directory Server and the variables are:

nnnn | A four-digit message number
s | One of the following severity codes: I Information only; no action is required W Warning: the action you attempted succeeded but with results that you need to be aware of E Error: the action you attempted failed
message-text | The text of the message

Messages with the severity E (for Error) appear in red.

  • Directory Server Error Messages 0 to 20
    Lists the Directory Server error messages from 0 through to 20
  • Directory Server Error Messages 21 to 40
    Lists the Directory Server Error Messages 21 to 40
  • Directory Server Error Messages 41 to 60
    Lists the Directory Server Error Messages, 41 to 60
  • Directory Server Error Messages 61 to 80
    Lists the Directory Server Error Messages 61 to 80
  • Directory Server Error Messages 81 to end
    Lists the Directory Server Error Messages 81 to the last error message in the range.
Parent topic: Error Messages


Directory Server Error Messages 0 to 20

  • MDS0000I OK
    The Directory Server has executed your previous instruction successfully
  • MDS0001I Logged on OK
    You have successfully logged on.
  • MDS0002E Logon failed
    Either the user ID or password used to log on were incorrect.
  • MDS0003I Logged off OK
    You have successfully logged off.
  • MDS0004I Repository cleared OK
    All the information in the current repository has been deleted successfully.
  • MDS0005I Network search complete
    The Directory Server has finished searching the network for other instances of Directory Server.
  • MDS0006I All objects copied successfully
  • MDS0007E Duplicate server exists
    You tried to create a server with the same name as one that already exists.
  • MDS0008E Duplicate server name already exists
    You tried to create a server with the same name as one that already exists.
  • MDS0009E Invalid server specified.
    You have specified an invalid server name or IP address when copying an enterprise server.
  • MDS0010E Invalid endpoint specified
    The address or port value or syntax of the endpoint value are incorrect or could not be understood by the Directory Server.
  • MDS0012E Duplicate service name exists
    You tried to create a service with the same name as one that already exists for this enterprise server.
  • MDS0013E Duplicate listener exists
    You tried to create a listener with the same name as one that already exists for this enterprise server.
  • MDS0014E Duplicate user already exists
    You tried to add a user but specified a user ID that already exists.
  • MDS0015E Schema Administrators cannot reduce their own permission level
    If you have logged on as a Schema Administrator, you cannot reduce your own permission level. This is because if you did so, it would be impossible for any users to be added, updated or deleted.
  • MDS0016E Invalid endpoint specified
    You specified an invalid endpoint for a listener.
  • MDS0017E Object must have a name
    You tried to add an object (such as a service or listener) but did not give it a name.
  • MDS0018I New server session
    The Directory Server has been stopped and restarted since the last time the browser connected to it.
  • MDS0019I Client session has timed out: please log on again
    A client session expires when the client performs no action for a period that exceeds the timeout period. When this occurs the client is automatically logged out and must log on again to continue working.
  • MDS0020E Minimum client timeout is 60 seconds
    You entered an invalid client timeout period.
Parent topic: Directory Server Error Messages


MDS0000I OK

Parent topic: Directory Server Error Messages 0 to 20


MDS0001I Logged on OK

Parent topic: Directory Server Error Messages 0 to 20


MDS0002E Logon failed

Resolution:

Retype your user ID and password, ensuring that you enter them correctly. User IDs and passwords are case sensitive.

Parent topic: Directory Server Error Messages 0 to 20


MDS0003I Logged off OK

Parent topic: Directory Server Error Messages 0 to 20


MDS0004I Repository cleared OK

Parent topic: Directory Server Error Messages 0 to 20


MDS0005I Network search complete

Parent topic: Directory Server Error Messages 0 to 20


MDS0006I All objects copied successfully

Parent topic: Directory Server Error Messages 0 to 20


MDS0007E Duplicate server exists

Parent topic: Directory Server Error Messages 0 to 20


MDS0008E Duplicate server name already exists

Parent topic: Directory Server Error Messages 0 to 20


MDS0009E Invalid server specified.

Resolution:

Repeat the operation specifying a valid server name of up to 8 characters with no include angle brackets (<>) or ampersands (&).

Parent topic: Directory Server Error Messages 0 to 20


MDS0010E Invalid endpoint specified

Parent topic: Directory Server Error Messages 0 to 20


MDS0012E Duplicate service name exists

Parent topic: Directory Server Error Messages 0 to 20


MDS0013E Duplicate listener exists

Parent topic: Directory Server Error Messages 0 to 20


MDS0014E Duplicate user already exists

Parent topic: Directory Server Error Messages 0 to 20


MDS0015E Schema Administrators cannot reduce their own permission level

Parent topic: Directory Server Error Messages 0 to 20


MDS0016E Invalid endpoint specified

Resolution:

Specify an endpoint of the form:

protocol:ip-address:port

where:

  • protocol is tcp
  • ip-address is either the text host name or IP address of the listener. An asterisk (*) indicates that the address is dynamically assigned for the listener when it starts.
  • port is the port value. An asterisk (*) indicates that the port is dynamically assigned for the listener when it starts
Parent topic: Directory Server Error Messages 0 to 20


MDS0017E Object must have a name

Parent topic: Directory Server Error Messages 0 to 20


MDS0018I New server session

Parent topic: Directory Server Error Messages 0 to 20


MDS0019I Client session has timed out: please log on again

Resolution:

You can change the client timeout period on the Configure Options page.

Parent topic: Directory Server Error Messages 0 to 20


MDS0020E Minimum client timeout is 60 seconds

Resolution:

Enter a value of 60 or greater, or 01, which indicates an indefinite timeout period.

Parent topic: Directory Server Error Messages 0 to 20


Directory Server Error Messages 21 to 40

  • MDS0021E Minimum page size is 5 entries
    You entered an invalid minimum page size for the journal.
  • MDS0022E Minimum journal size is 32 KB
    You entered an invalid minimum journal size for the journal.
  • MDS0023E Insufficient memory for this operation
    There was insufficient computer memory for this operation to succeed.
  • MDS0024E Password mismatch
    Password mismatch.
  • MDS0025E Confirmation password mismatch
    The confirmation password does not match the password you first entered.
  • MDS0026E Old password required
    Old password required.
  • MDS0027E New password required
    You have not specified a password when creating a new user.
  • MDS0028E Invalid characters in password
    Invalid characters in password.
  • MDS0029E Selected object does not exist
    You tried to edit an object that another user has just deleted.
  • MDS0030W Some or all objects not copied: see journal for details
    You tried to copy a server but the Directory Server was unable to copy all objects related to the server.
  • MDS0031E Maximum port value is 65535
    You entered a port value in an endpoint that exceeds 65535.
  • MDS0032E Object could not be added
    There was an error adding the object. See journal for more details of the error.
  • MDS0035E Minimum object limit is 64
    You tried to reduce the limit for the maximum number of objects below 64, which is not allowed.
  • MDS0036E Maximum object limit is 9999
    You tried to reduce the limit for the maximum number of objects above 9999, which is not allowed.
  • MDS0037E Operation would breach the configured object limit
    This action has been rejected because to perform it would mean increasing the number of objects in the repository above the maximum object count.
  • MDS0038E Minimum object limit is smaller than the current number of objects
    You tried to reduce the maximum object count to less than the current number of registered objects.
Parent topic: Directory Server Error Messages


MDS0021E Minimum page size is 5 entries

Resolution:

Enter a value of 5 or greater.

Parent topic: Directory Server Error Messages 21 to 40


MDS0022E Minimum journal size is 32 KB

Resolution:

Enter a value of 32 (KB) or greater.

Parent topic: Directory Server Error Messages 21 to 40


MDS0023E Insufficient memory for this operation

Resolution:

Try closing some application programs.

Parent topic: Directory Server Error Messages 21 to 40


MDS0024E Password mismatch

Parent topic: Directory Server Error Messages 21 to 40


MDS0025E Confirmation password mismatch

Parent topic: Directory Server Error Messages 21 to 40


MDS0026E Old password required

Parent topic: Directory Server Error Messages 21 to 40


MDS0027E New password required

Resolution:

Specify a valid password. Passwords can contain alphabetical and numeric characters only and are case sensitive.

Parent topic: Directory Server Error Messages 21 to 40


MDS0028E Invalid characters in password

Parent topic: Directory Server Error Messages 21 to 40


MDS0029E Selected object does not exist

Parent topic: Directory Server Error Messages 21 to 40


MDS0030W Some or all objects not copied: see journal for details

Resolution:

View the journal to find out which objects were not copied. Add them to the server individually.

Parent topic: Directory Server Error Messages 21 to 40


MDS0031E Maximum port value is 65535

Parent topic: Directory Server Error Messages 21 to 40


MDS0032E Object could not be added

Parent topic: Directory Server Error Messages 21 to 40


MDS0035E Minimum object limit is 64

Parent topic: Directory Server Error Messages 21 to 40


MDS0036E Maximum object limit is 9999

Parent topic: Directory Server Error Messages 21 to 40


MDS0037E Operation would breach the configured object limit

Resolution:

You can change the maximum object count on the Configure Options page.

Parent topic: Directory Server Error Messages 21 to 40


MDS0038E Minimum object limit is smaller than the current number of objects

Parent topic: Directory Server Error Messages 21 to 40


Directory Server Error Messages 41 to 60

  • MDS0043I Journal exported as text into file journal.txt OK
    The journal file has been successfully converted to a text file called journal.txt, located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.xbase\binor %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\bin if Enterprise Server is installed standalone.
  • MDS0044E Server name missing
    You tried to add a server without the mandatory server name value.
  • MDS0045E Duplicate request handler or package name exists
    You tried to create a request handler or a package with the same name as one that already exists for this enterprise server.
  • MDS0047E Package must have an IDT path
    You tried to add a package without a mandatory IDT path value, or you deleted the IDT path value while editing the package.
  • MDS0048E Server refused state change request
    The change you requested requires the enterprise server to take immediate action, but the Directory Server did not receive confirmation from the enterprise server that the action was completed.
  • MDS0049E Server refused state change request reason code:
    The change you requested requires the enterprise server to take immediate action, but the Directory Server did not receive confirmation from the enterprise server that the action was completed. The internal reason code is shown.
  • MDS0050E Server instance count must be at least 1
    You tried to reduce the number of service execution processes to less than 1.
  • MDS0051I Value change request accepted
    A request to change the number of service execution processes or licenses has been accepted.
  • MDS0052I Diagnostic dump request accepted
    The enterprise server has accepted the request to create a dump.
  • MDS0053E Diagnostic dump request failed
    The enterprise server has rejected the request to create a dump.
  • MDS0054I Configuration saved
    The current Directory Server configuration options have been saved.
  • MDS0055I Configuration defaults restored
    The default Directory Server configuration options have been restored.
  • MDS0056E Insufficient permission level for request
    You tried to perform an action that your permission level does not allow.
  • MDS0057E Resource manager ID field must have a value
    You tried to add an external resource manager in the enterprise server definition without a mandatory ID value or you deleted the ID value while editing the resource manager definition.
  • MDS0058E Resource manager name field must have a value
    You tried to add an external resource manager in the enterprise server definition without a mandatory name value or you deleted the name value while editing the resource manager definition.
  • MDS0059E Resource manager module field must have a value
    You tried to add an external resource manager in the enterprise server definition without a mandatory module value or you deleted the module value while editing the resource manager definition.
  • MDS0060E MFRHBINP cannot be deleted
    You tried to delete the MFRHBINP request handler. This request handler is required for some of the enterprise server internal functions, so it cannot be deleted.
Parent topic: Directory Server Error Messages


MDS0043I Journal exported as text into file journal.txt OK

Parent topic: Directory Server Error Messages 41 to 60


MDS0044E Server name missing

Parent topic: Directory Server Error Messages 41 to 60


MDS0045E Duplicate request handler or package name exists

Parent topic: Directory Server Error Messages 41 to 60


MDS0047E Package must have an IDT path

Parent topic: Directory Server Error Messages 41 to 60


MDS0048E Server refused state change request

Resolution:

Refresh the Enterprise Server Administration display to see if the action has now completed. Check the enterprise server console log and communications console log to see if any additional information is available. If the action you requested is temporary, such as changing a listener's status, you might want to try again. Otherwise, your change will take effect the next time you start the enterprise server.

Parent topic: Directory Server Error Messages 41 to 60


MDS0049E Server refused state change request reason code:

Resolution:

Refresh the Enterprise Server Administration display to see if the action has now completed. Check the enterprise server console log and communications console log to see if any additional information is available. If the action you requested is temporary, such as changing a listener's status, you might want to try again. Otherwise, your change will take effect the next time you start the enterprise server.

Parent topic: Directory Server Error Messages 41 to 60


MDS0050E Server instance count must be at least 1

Parent topic: Directory Server Error Messages 41 to 60


MDS0051I Value change request accepted

Parent topic: Directory Server Error Messages 41 to 60


MDS0052I Diagnostic dump request accepted

Parent topic: Directory Server Error Messages 41 to 60


MDS0053E Diagnostic dump request failed

Parent topic: Directory Server Error Messages 41 to 60


MDS0054I Configuration saved

Parent topic: Directory Server Error Messages 41 to 60


MDS0055I Configuration defaults restored

Parent topic: Directory Server Error Messages 41 to 60


MDS0056E Insufficient permission level for request

Parent topic: Directory Server Error Messages 41 to 60


MDS0057E Resource manager ID field must have a value

Parent topic: Directory Server Error Messages 41 to 60


MDS0058E Resource manager name field must have a value

Parent topic: Directory Server Error Messages 41 to 60


MDS0059E Resource manager module field must have a value

Parent topic: Directory Server Error Messages 41 to 60


MDS0060E MFRHBINP cannot be deleted

Parent topic: Directory Server Error Messages 41 to 60


Directory Server Error Messages 61 to 80

  • MDS0061I Stopping and deleting all servers...
    You made a "Delete All" request and asked for servers to be stopped before they are deleted. This status is shown while the servers are in "Stopping" state.
  • MDS0062E Entry range invalid
    You asked to view an enterprise server console entry outside the range of existing entries.
  • MDS0063E Cannot delete a listener which is associated with a service
    You tried to delete a listener which is associated with a service.
  • MDS0064E Cannot delete a package which is associated with a service
    You tried to delete a package which is associated with a service.
  • MDS0065E Requested new listener status not possible when server is stopped
    You tried to make a change to the status of a listener that is not possible when the enterprise server is not started.
  • MDS0066E There are no servers to delete
    You tried to perform a "Delete All" when no server information is stored in the current repository.
  • MDS0067E less than greater than ampersand characters are not allowed in object names
    You tried to add an object using a name containing one or more of the characters < > and &, which are not allowed.
  • MDS0068I Schema updated
    You have successfully updated the schema.
  • MDS0069I All servers deleted
    You have deleted the Directory Server schema.
  • MDS0070I Data imported
    You have imported a repository into the Directory Server schema.
  • MDS0071E Data import failed
    You have attempted to import a repository into the Directory Server schema, but the import failed.
  • MDS0072I Server data saved
    You have successfully saved the data for the current server.
  • MDS0073E Server data save failed
    You have attempted to save the data for one server, but the save failed.
  • MDS0074E User name required
    You tried to add a new user without supplying a user ID.
  • MDS0075E Too many multi-byte characters in name
    You entered one or more multi-byte characters into a fixed-length field, which resulted in the limit for the number of bytes being exceeded. In Japanese and some other languages a typed character can have more than one byte associated with it: so although the entry field will allow you to type the characters in, the number of bytes exceeds the field limit.
  • MDS0076E Too many multi-byte characters in path
    You entered one or more multi-byte characters into a fixed-length field, which resulted in the limit for the number of bytes being exceeded. In Japanese and some other languages a typed character can have more than one byte associated with it: so although the entry field will allow you to type the characters in, the number of bytes exceeds the field limit.
  • MDS0077E Too many multi-byte characters in type
    You entered one or more multi-byte characters into a fixed-length field, which resulted in the limit for the number of bytes being exceeded. In Japanese and some other languages a typed character can have more than one byte associated with it: so although the entry field will allow you to type the characters in, the number of bytes exceeds the field limit.
  • MDS0078E Too many multi-byte characters in ID
    You entered one or more multi-byte characters into a fixed-length field, which resulted in the limit for the number of bytes being exceeded. In Japanese and some other languages a typed character can have more than one byte associated with it: so although the entry field will allow you to type the characters in, the number of bytes exceeds the field limit.
  • MDS0079E Too many multi-byte characters in module
    You entered one or more multi-byte characters into a fixed-length field, which resulted in the limit for the number of bytes being exceeded. In Japanese and some other languages a typed character can have more than one byte associated with it: so although the entry field will allow you to type the characters in, the number of bytes exceeds the field limit.
  • MDS0080E Too many multi-byte characters in string
    You entered one or more multi-byte characters into a fixed-length field, which resulted in the limit for the number of bytes being exceeded. In Japanese and some other languages a typed character can have more than one byte associated with it: so although the entry field will allow you to type the characters in, the number of bytes exceeds the field limit.
Parent topic: Directory Server Error Messages


MDS0061I Stopping and deleting all servers...

Parent topic: Directory Server Error Messages 61 to 80


MDS0062E Entry range invalid

Parent topic: Directory Server Error Messages 61 to 80


MDS0063E Cannot delete a listener which is associated with a service

Resolution:

Disassociate the listener from the services with which it is associated, or delete the services that reference it. Then delete it.

Parent topic: Directory Server Error Messages 61 to 80


MDS0064E Cannot delete a package which is associated with a service

Resolution:

Disassociate the package from the services with which it is associated, or delete the services that reference it. Then delete it.

Parent topic: Directory Server Error Messages 61 to 80


MDS0065E Requested new listener status not possible when server is stopped

Parent topic: Directory Server Error Messages 61 to 80


MDS0066E There are no servers to delete

Parent topic: Directory Server Error Messages 61 to 80


MDS0067E less than greater than ampersand characters are not allowed in object names

Parent topic: Directory Server Error Messages 61 to 80


MDS0068I Schema updated

Parent topic: Directory Server Error Messages 61 to 80


MDS0069I All servers deleted

Parent topic: Directory Server Error Messages 61 to 80


MDS0070I Data imported

Parent topic: Directory Server Error Messages 61 to 80


MDS0071E Data import failed

Resolution:

See the journal for more detailed diagnostics.

Parent topic: Directory Server Error Messages 61 to 80


MDS0072I Server data saved

Parent topic: Directory Server Error Messages 61 to 80


MDS0073E Server data save failed

Resolution:

See the journal for more detailed diagnostics.

Parent topic: Directory Server Error Messages 61 to 80


MDS0074E User name required

Parent topic: Directory Server Error Messages 61 to 80


MDS0075E Too many multi-byte characters in name

Resolution:

Reduce the number of characters entered until the entry is accepted.

Parent topic: Directory Server Error Messages 61 to 80


MDS0076E Too many multi-byte characters in path

Resolution:

Reduce the number of characters entered until the entry is accepted.

Parent topic: Directory Server Error Messages 61 to 80


MDS0077E Too many multi-byte characters in type

Resolution:

Reduce the number of characters entered until the entry is accepted.

Parent topic: Directory Server Error Messages 61 to 80


MDS0078E Too many multi-byte characters in ID

Resolution:

Reduce the number of characters entered until the entry is accepted.

Parent topic: Directory Server Error Messages 61 to 80


MDS0079E Too many multi-byte characters in module

Resolution:

Reduce the number of characters entered until the entry is accepted.

Parent topic: Directory Server Error Messages 61 to 80


MDS0080E Too many multi-byte characters in string

Resolution:

Reduce the number of characters entered until the entry is accepted.

Parent topic: Directory Server Error Messages 61 to 80


Directory Server Error Messages 81 to end

  • MDS0081W A duplicate port value has been used: this may cause server startup errors
    You specified a port number for a listener or a server that is already in use. If both are started at the same time then this will cause startup problems. Depending on the operating system and the TCP stack implementation the second one to start might take the port or may refuse to start up, or some other problem might occur, which might or might not be reported to you.
  • MDS0082E Requested license value invalid, minimum value is 0
    You have asked for a negative number of licenses when creating an enterprise server. The enterprise server will be created with no licenses.
  • MDS0083W Cannot set auto-refresh period if web browser timeout is set
    You tried to set an auto-refresh period when a Web browser timeout period is set on the Configure Options page. This is not allowed if user access on that page is also set to restricted, because each refresh restarts the timeout countdown.
  • MDS0084E Cannot restore from current repository path
    You have tried to restore the repository from the location of the current repository.
  • MDS0085W Value changed but not saved
    You have changed a value on one of the Edit Server tabs, then switched to another tab or page without saving your changes.
  • MDS0086I At least one Communications Process must auto-start
    You have attempted to turn off auto-start for all the communications processes that belong to an enterprise server. At least one must auto-start. The change is ignored.
  • MDS0087E MFRHBINP cannot be renamed
    You have attempted to rename the Micro Focus request handler MFRHBINP. This is not permitted because if it were possible to rename it, it could then be deleted. Enterprise Server will not work without the presence of this request handler.
  • MDS0090E TN3270 listener port must have a valid value
    When adding an MSS-enabled ES server, a TN3270 listener is defined by default. This default listener has not had a port value defined for it, or the defined value is outside the standard TCP port value range.
  • MDS0091E ISC listener port must have a valid value
    MDS0091E ISC listener port has an invalid value,
  • MDS0095E Duplicate group name exists
    The group name exists. A user group name must be unique.
  • MDS0096I Server configuration updated
    This message is displayed after an administrator has run the Validate operation on a configuration, and then applied any suggested updates.
  • MDS0097E Duplicate initiator name exists
    An initiator name must be unique within the enterprise server configuration.
  • MDS0098W Cannot over-write existing repository data
    There is existing repository data in the chosen directory. Choose a different directory.
  • MDS0099I Server already in requested state
    Displayed whe a request is made to start an already-started enterprise server.
  • MDS0100E Duplicate printer name exists
    A printer name must be unique within the server configuration.
  • MDS0101E The maximum number of Communications Processes per server is 32
    When copying Communications Processes in the listener list page, the maximum number allowed is 32.
  • MDS0102W Passwords must contain alphanumeric characters only
    The password field for internal and external security users accepts only alphanumeric characters.
  • MDS0103E Security Manager already referenced in list
    When specifying a priority list of Security Managers, each entry in the list must refer to a unique Security Manager (no duplicate entries allowed).
  • MDS0104E There must be at least one Security Manager in list
    There must be at least one Security Manager in the Security Manager list.
  • MDS0105E Both certificate and keyfile required
    If both the MFDS SSL option and custom certificate option have both been specified, then a certificate and keyfile have to be specified.
  • MDS0106E Duplicate Security Manager name exists
    A Security Manager name must be unique within MFDS.
  • MDS0107E Security Managers cannot use a reserved module name
    Some Security Manager names are reserved for internal use only, for example “mfds_esm”.
  • MDS0108E Users must be a member of #AllUsrs group
    If using MFDS Internal Security, all users must be a member of the “#AllUsrs” group and cannot be removed from it.
  • MDS0109E Cannot copy deployed services or packages if server working mode is changed
    If copying an ES server definition to change the working mode from 32-bit to 64-bit or 64-bit to 32-bit, the deployed services of the original server will not be compatible with the new working mode. Therefore, the server definition cannot be copied.
  • MDS0110W The specified configuration change may not take effect until the server is restarted
    When changing the state of a service when an ES server is started, the requested state may not come into effect until the server is restarted.
  • MDS0111W Update request failure message CASRD1006E detected in the ES console log
    There has been a problem updating the started ES server with the requested configuration change.
  • MDS0112I Update success message CASRD1001I detected for this object in the ES console log
    The requested configuration change has been accepted by the started ES instance.
  • MDS0113W Users who are members of the #System user group cannot log on interactively
    When using MFDS Internal Security, the system accounts defined in the “#System” group, used internally by default in ES, cannot be used to log into the Enterprise Server Administration GUI if user access is set to restricted.
  • MDS1003E LDAP server connection error
    You have attempted to change the location of the MFDS repository to an LDAP directory server, and there is an error connecting to the server specified. The LDAP server error code and details are included in the message. Refer to your LDAP provider documentation for more information on the error.
Parent topic: Directory Server Error Messages


MDS0081W A duplicate port value has been used: this may cause server startup errors

Parent topic: Directory Server Error Messages 81 to end


MDS0082E Requested license value invalid, minimum value is 0

Resolution:

Update the number of licenses on the Edit Server > Properties > General page.

Parent topic: Directory Server Error Messages 81 to end


MDS0083W Cannot set auto-refresh period if web browser timeout is set

Parent topic: Directory Server Error Messages 81 to end


MDS0084E Cannot restore from current repository path

Resolution:

Specify a valid backup location from which to restore the repository.

Parent topic: Directory Server Error Messages 81 to end


MDS0085W Value changed but not saved

Resolution:

If you intended to make the change, return to the tab on which you made the change, make it again and click OK.

Parent topic: Directory Server Error Messages 81 to end


MDS0086I At least one Communications Process must auto-start

Parent topic: Directory Server Error Messages 81 to end


MDS0087E MFRHBINP cannot be renamed

Parent topic: Directory Server Error Messages 81 to end


MDS0090E TN3270 listener port must have a valid value

Parent topic: Directory Server Error Messages 81 to end


MDS0091E ISC listener port must have a valid value

Parent topic: Directory Server Error Messages 81 to end


MDS0095E Duplicate group name exists

Parent topic: Directory Server Error Messages 81 to end


MDS0096I Server configuration updated

Parent topic: Directory Server Error Messages 81 to end


MDS0097E Duplicate initiator name exists

Parent topic: Directory Server Error Messages 81 to end


MDS0098W Cannot over-write existing repository data

Parent topic: Directory Server Error Messages 81 to end


MDS0099I Server already in requested state

Parent topic: Directory Server Error Messages 81 to end


MDS0100E Duplicate printer name exists

Parent topic: Directory Server Error Messages 81 to end


MDS0101E The maximum number of Communications Processes per server is 32

Parent topic: Directory Server Error Messages 81 to end


MDS0102W Passwords must contain alphanumeric characters only

Parent topic: Directory Server Error Messages 81 to end


MDS0103E Security Manager already referenced in list

Parent topic: Directory Server Error Messages 81 to end


MDS0104E There must be at least one Security Manager in list

Parent topic: Directory Server Error Messages 81 to end


MDS0105E Both certificate and keyfile required

Parent topic: Directory Server Error Messages 81 to end


MDS0106E Duplicate Security Manager name exists

Parent topic: Directory Server Error Messages 81 to end


MDS0107E Security Managers cannot use a reserved module name

Parent topic: Directory Server Error Messages 81 to end


MDS0108E Users must be a member of #AllUsrs group

Parent topic: Directory Server Error Messages 81 to end


MDS0109E Cannot copy deployed services or packages if server working mode is changed

Parent topic: Directory Server Error Messages 81 to end


MDS0110W The specified configuration change may not take effect until the server is restarted

Parent topic: Directory Server Error Messages 81 to end


MDS0111W Update request failure message CASRD1006E detected in the ES console log

Parent topic: Directory Server Error Messages 81 to end


MDS0112I Update success message CASRD1001I detected for this object in the ES console log

Parent topic: Directory Server Error Messages 81 to end


MDS0113W Users who are members of the #System user group cannot log on interactively

Parent topic: Directory Server Error Messages 81 to end


MDS1003E LDAP server connection error

Parent topic: Directory Server Error Messages 81 to end


Enterprise Server Error Messages

  • CASAM error messages
    Server management error messages
  • CASBJ Error Messages
    Batch Job error messages
  • CASCD Error Messages
    Console Daemon error messages.
  • CASCF Error Messages
    Configuration support error messages.
  • CASCS Error Messages
    Communications error messages.
  • CASFD Error Messages
    Dump Formatter error messages
  • CASKC Error Messages
    Task control error messages.
  • CASMQ error messages
    Trigger monitor error messages
  • CASRD Error Messages
    Resource Definition error messages.
  • CASSP Error Messages
    Syncpoint and Recovery Services error messages.
  • CASST Error Messages
    Server termination error messages.
  • CASTS Error Messages
    TSC Service process error messages
  • CASXO Error Messages
    Transaction Manager error messages.
Parent topic: Error Messages


CASAM error messages

0001I Development region region-name created successfully
The %1$s development region has been successfully created.
  • System action: None
  • User response: None
  • Destination: standard error
  • Module: dfhcrtrg
0002F Region region-name not created
The request to create the region was not successful.
  • System action: The request is rejected.
  • User response: Check previous messages for cause of error. Correct the problem and retry the request.
  • Destination: standard error
  • Module: dfhcrtrg
0003E Too many arguments, maximum is 2
Too many arguments were specified, the maximum permitted is 2.
  • System action: The request is rejected
  • User response: Retry the request with the correct number of arguments
  • Destination: standard error
  • Module: dfhcrtrg
0004E Unrecognized option option-value
The specified option is not valid
  • System action: The request is rejected
  • User response: Retry the request with a valid option
  • Destination: standard error
  • Module: dfhcrtrg
0005E region-name is not a valid region name
region-name cannot be used as a region name. A region name must be alphanumeric, 4-8 characters long, and not a reserved system directory name
  • System action: The request is rejected
  • User response: Retry the request with a valid region name
  • Destination: standard error
  • Module: dfhcrtrg
0006E Development region region-name already exists
An attempt was made to create a development region that already exists
  • System action: The request is rejected
  • User response: Retry the request with a unique region name
  • Destination: standard error
  • Module: dfhcrtrg
0007E Development region region-name requires group of same name
When creating a development region the name must match that of an existing user group
  • System action: The request is rejected
  • User response: Create a user group of the same name and retry
  • Destination: standard error
  • Module: dfhcrtrg
0008S Failed to create directory directory-name, reason return-code
The OS returned a return code of return-code for the request to create the specified directory.
  • System action: The request is rejected
  • User response: None
  • Destination: standard error
  • Module: dfhcrtrg
0010S Region base path path-name does not exist
A specific path to the region has been specified but does not exist.
  • System action: The request is rejected
  • User response: Create the path or correct the configuration file dfhtx.cfg
  • Destination: standard error
  • Module: dfhcrtrg
0011S region-name is the default region name and cannot be created
region-name is the default or "global" region. It uses the base directory structure and therefore cannot be created with this utility. It is recommended that the global region (i.e. its directory structure) not be used for normal operations.
  • System action: The request is rejected
  • User response: Select another name for the region.
  • Destination: standard error
  • Module: dfhcrtrg
0012I Production region region-name created successfully
The production region has been successfully created.
  • System action: None
  • User response: None
  • Destination: standard error
  • Module: dfhcrtrg
0013I Production region region-name has been changed to development
The production region has been changed to development.
  • System action: None
  • User response: None
  • Destination: standard error
  • Module: dfhcrtrg
0014I Region base directory for region-name is region-base
The region-name is the region's base directory for region-base.
  • System action: None
  • User response: None
  • Destination: standard error
  • Module: dfhcrtrg
0015E Production region region-name already exists
An attempt was made to create a production region that already exists
  • System action: The request is rejected
  • User response: Retry the request with a unique region name
  • Destination: standard error
  • Module: dfhcrtrg
0017I Defaulting to a region-name region for region-type
No command line parameters were specified so the region was created as region-type by default. A production region is created unless the system locates a development configuration file, the default is then a development region.
  • System action: None
  • User response: None
  • Destination: standard error
  • Module: dfhcrtrg
1001W CFMT file (or dataset) name not supplied
The file name to action was not supplied. Usage is CFMT {fn} {file-name}
  • System action: None
  • User response: Correct the input and resubmit the request
  • Destination: Terminal
  • Module: dfhzcfmt
1002I CFMT Usage {fn} {file name} where fn={OPen,CLose,ENable,DIsable,INquire,NAme}
No input was supplied with the transaction. This message documents the required parameters. The user should enter the transaction ID, function, and file name. The function may be "open", "close", "enable", "disable", "inquire" or "name". The transaction considers only the first two letters of the function parameter to determine its action.
  • System action: None
  • User response: None
  • Destination: Terminal
  • Module: dfhzcfmt
1003I Zero length input for CFMT at terminal-id, user user-id
The transaction CFMT started on the terminal but there was no input data. The request executed on terminal terminal-id where user user-id was signed on.
  • System action: None
  • User response: Correct the input and resubmit the request
  • Destination: Terminal
  • Module: dfhzcfmt
1004W Invalid CFMT initiation at terminal-id, user user-id
The transaction CFMT started on the terminal but the start was not a valid start. The request executed on terminal terminal-id where user user-id was signed on.
  • System action: None
  • User response: Correct the transaction initiation and resubmit the request
  • Destination: Terminal
  • Module: dfhzcfmt
1005I CFMT - File file-id opened successfully; terminal-id, user user-id
The request to open the file was successful.
  • System action: The file was opened
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcfmt
1006I CFMT - File file-id closed successfully; terminal-id, user user-id
The request to close the file was successful.
  • System action: The file was closed
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcfmt
1007I CFMT - File file-id enabled successfully; terminal-id, user user-id
The request to enable the file was successful.
  • System action: The file was enabled
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcfmt
1008I CFMT - File file-id disabled successfully; terminal-id, user user-id
The request to disable the file was successful.
  • System action: The file was disabled
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcfmt
1009I CFMT - File file-id is open-status and enable-status; terminal-id, user user-id
The inquire request was successful. The status of file open-status and enable-status. If an unexpected CVDA value is returned for either of these statuses, the actual numeric status will be reported.
  • System action: None
  • User response: None
  • Destination: Terminal
  • Module: dfhzcfmt
1010W CFMT invalid request (request) for file file-id at terminal-id, user user-id
The request for the file was not recognized. It may be OPen, CLose, ENable, DIsable, INquire or NAme. Only the first two characters of the request are examined by the program. The request is not case sensitive.
  • System action: The request is ignored
  • User response: Correct the input and resubmit
  • Destination: Terminal
  • Module: dfhzcfmt
1011W CFMT file file-id not found; terminal-id, user user-id
The file was not found. The file name is case sensitive.
  • System action: The request is ignored
  • User response: Correct the input and resubmit
  • Destination: Terminal
  • Module: dfhzcfmt
1012E CFMT request not authorized for file file-id at terminal-id, user user-id
The request for the file is not authorized.
  • System action: The request is ignored
  • User response: Correct the input or consult with the security administrator.
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcfmt
1013E CFMT file file-id unexpected response (eibresp); terminal-id, user user-id
The requested action for the file resulted in an unexpected API response.
  • System action: The request is ignored
  • User response: Correct the input and resubmit
  • Destination: Terminal
  • Module: dfhzcfmt
1014W CFMT illogic response for request to file file-id; terminal-id, user user-id
The requested action for the file resulted in an illogic API response. The requested transition is not logical, for example, an open request for a file that is already open.
  • System action: The request is ignored
  • User response: Correct the input and resubmit
  • Destination: Terminal
  • Module: dfhzcfmt
1015I CFMT file file-id DSNAME (DSNAME)
The DSNAME associated with the file is displayed.
  • System action: None.
  • User response: None.
  • Destination: Terminal
  • Module: dfhzcfmt
1016I CFMT function function completed. error-count error(s) encountered. See CEBR.
The requested action has completed. The number of errors is shown.
  • System action: None.
  • User response: Use the CEBR transaction to view the log.
  • Destination: Terminal
  • Module: dfhzcfmt
1017E CFMT file file-id IOERR (eibresp-1/eibresp-2); terminal-id, user user-id
The requested action for the file resulted in an IOERR.
  • System action: The request is ignored
  • User response: Correct the input and resubmit
  • Destination: Terminal
  • Module: dfhzcfmt
1020W Error opening file (file-id) group (group-id) - status=(file-status-1, file-status-2)
A file marked as Start Open / Enabled could not be opened in system initialization due to the I/O error specified.
If file-status-1 is 3 then the error is a standard file status code. A file-status-2 of 9 indicates a RTS error.
Common values for status:
Status | Reason | Action
3005 | file not found | Correct file name in FCT or create file with CFCR if necessary.
9065 | file locked | Ensure that another program has not opened the file exclusively.
9124 | comms error | Make sure the Fileshare server is running and the correct CCI protocol is defined in the FHREDIR configuration file.
  • System action: The file will not be opened.
  • User response: Correct the error and open the file using the CFMT transaction.
  • Destination: Console
  • Module: dfhzplt
1030I CNCL Usage: CNCL {program-name}
No input was supplied with the transaction. This message documents the required parameters. The user should enter the transaction ID and program name.
  • System action: None
  • User response: None
  • Destination: Terminal
  • Module: dfhzcncl
1031I Zero length input for CNCL at terminal-id, user user-id
The transaction CNCL started on the terminal but there was no input data.
  • System action: None
  • User response: Correct the input and resubmit the request
  • Destination: Terminal
  • Module: dfhzcncl
1032W Invalid CNCL initiation at terminal-id, user user-id
The transaction CNCL started on the terminal but the start was not a valid start.
  • System action: None
  • User response: Correct the transaction initiation and resubmit the request
  • Destination: Terminal
  • Module: dfhzcncl
1033E Invalid cancel request at terminal-id, PPT entry found for program program-name, user user-id
The program name passed to CNCL was found as a PPT entry. The CPMT transaction should be used to issue NEWCOPY requests for CICS programs.
  • System action: None
  • User response: Use the CPMT transaction to release the CICS program.
  • Destination: Terminal
  • Module: dfhzcncl
1033E PPT entry found for program program-name not COBOL at terminal-id, user user-id
The program name passed to CNCL was found as a PPT entry which was not marked as a COBOL program. This transaction can only release COBOL programs.
  • System action: None
  • User response: Supply a valid program name or change the PPT definition.
  • Destination: Terminal
  • Module: dfhzcncl
1034E PPT entry found for program program-name not LOCAL at terminal-id, user user-id
The program name passed to CNCL was found as a PPT entry which was not a local program.
  • System action: None
  • User response: Supply a valid program name or change the PPT definition.
  • Destination: Terminal
  • Module: dfhzcncl
1035I CNCL request for program program-name issued at terminal-id, user user-id
The program release request was issued successfully.
  • System action: None
  • User response: None
  • Destination: Terminal
  • Module: dfhzcncl
1036W CNCL request for program program-name failed at terminal-id, user user-id
The program release request failed. This error will occur if the program was not actually in memory when the command was issued or logical cancel support is not enabled in the COBOL RTS.
  • System action: None
  • User response: None
  • Destination: Terminal
  • Module: dfhzcncl
1101W CKQC can only be run in multi-tasking mode to start an MQSeries CKTI monitor
The region is currently running in single-tasking mode. The MQSeries monitor may only be run in multi-tasking mode.
  • System action: None
  • User response: Restart CICS Option in multi-tasking mode, and reinvoke CKQC.
  • Destination: Terminal
  • Module: dfhzckqc
1102W Unexpected error (return-code) requesting CKTI
The CICS Option Process Requester returned an unexpected response.
  • System action: The CKTI monitor is not started.
  • User response: Retry the CKQC transaction. If the problem persists, contact Support.
  • Destination: Terminal
  • Module: dfhzckqc
1103W No initiation queue name given
To start an MQSeries monitor, you need to supply an initiation queue name.
  • System action: The CKTI monitor is not started.
  • User response: Resubmit, specifying a queue name.
  • Destination: Terminal
  • Module: dfhzckqc
1104I Usage: CKQC STARTCKTI <initiation-queue>
To start an MQSeries monitor via the LINK interface, you need to supply an initiation queue name.
  • System action: The CKTI monitor is not started.
  • User response: Resubmit, specifying a queue name.
  • Destination: Terminal
  • Module: dfhzckqc
1105W Invalid function key - use ENTER to accept data
The only keys that are recognized are: CLEAR, PF3 & ENTER.
  • System action: None
  • User response: Retry using a valid key.
  • Destination: Terminal
  • Module: dfhzckqc
1106E MQSeries queue manager name not found. RC=return-code
The MQSeries queue manager name cannot be found.
  • System action: None
  • User response: Check that MQSeries has been configured correctly in the system initialization table.
  • Destination: Terminal
  • Module: dfhzckqc
1107I CKTI requested for initiation-queue
A request to start a CKTI has been initiated.
  • System action: CICS Option attempts to initialize an MQSeries trigger monitor.
  • User response: Check console
  • Destination: Terminal
  • Module: dfhzckqc
2001W CPMT program or table name not supplied
The program name to action was not supplied. Usage is CPMT {fn} {program-name}.
  • System action: None
  • User response: Correct the input and resubmit the request
  • Destination: Terminal
  • Module: dfhzcpmt
2003I Zero length input for CPMT at terminal-id, user user-id
The transaction CPMT started on the terminal but there was no input data.
  • System action: None
  • User response: Correct the input and resubmit the request
  • Destination: Terminal
  • Module: dfhzcpmt
2004W Invalid CPMT initiation at terminal-id, user user-id
The transaction CPMT started on the terminal but the start was not a valid start.
  • System action: None
  • User response: Correct the transaction initiation and resubmit the request
  • Destination: Terminal
  • Module: dfhzcpmt
2005I CPMT - Program program-id newcopy; terminal-id, user user-id
The request to load a new copy of the program was successful.
  • System action: A new copy of the program is loaded.
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2006I CPMT - Program program-name phasein; terminal-id, user user-id
The request to load a new copy of %3$s by user %2$s at terminal %1$s was successful. The new copy will be used for all new requests.
  • System action: A new copy of the program is being phased in.
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2007I CPMT - Program program-name private; terminal-id, user user-id
The request to mark the program as private was successful.
  • System action:
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2008I CPMT - Program program-name shared; terminal-id, user user-id
The request to mark the program as shared was successful.
  • System action:
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2009I CPMT - Program program-name dplsubset; terminal-id, user user-id
The request to mark the program as dplsubset was successful.
  • System action:
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2010I CPMT - Program program-name fullapi; terminal-id, user user-id
The request to mark the program as fullapi successful.
  • System action:
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2011I CPMT - Program program-name cedf; terminal-id, user user-id
The request to mark the program as cedf was successful.
  • System action:
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2012I CPMT - Program program-name nocedf; terminal-id, user user-id
The request to mark the program as nocedf was successful.
  • System action:
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2013I CPMT - Program program-name is disabled; terminal-id, user user-id
The request to mark the program as disabled was successful.
  • System action:
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2014I CPMT - Program program-name is enabled; terminal-id, user user-id
The request to mark the program %3$s as enabled was successful.
  • System action:
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2016I Program program-name is not currently loaded
Program has not been loaded. The full name cannot be displayed until it has been accessed.
  • System action:
  • User response: Do a NEWCOPY or PHASEIN command and repeat this inquiry.
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2018W CPMT invalid request (request) for program program-name at terminal-id, user user-id
The request for the program was not recognized. It may be OPen, CLose, ENable, DIsable, or INquire. Only the first two characters of the request are examined by the program. The request is not case sensitive.
  • System action: The request is ignored
  • User response: Correct the input and resubmit
  • Destination: Terminal
  • Module: dfhzcpmt
2019W CPMT program program-name not found; terminal-id, user user-id
The program was not found. The program name is case sensitive on some platforms.
  • System action: The request is ignored
  • User response: Correct the input and resubmit
  • Destination: Terminal
  • Module: dfhzcpmt
2020E CPMT request not authorized for program program-name at terminal-id, user user-id
The request for the program is not authorized.
  • System action: The request is ignored
  • User response: Correct the input or consult with the security administrator.
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
2021E CPMT program program-name unexpected response (eibresp); terminal-id, user user-id
The requested action for the program resulted in an unexpected API response.
  • System action: The request is ignored
  • User response: Correct the input and resubmit
  • Destination: Terminal
  • Module: dfhzcpmt
2023I CPMT - PPT for Program program-name was discarded; terminal-id, user user-id
The request to discard the PPT for program %3$s by user %2$s at terminal %1$s was successful.
  • System action:
  • User response: None
  • Destination: Terminal, CSMT td queue, and console
  • Module: dfhzcpmt
3000S Critical Event Manager storage error
The Event Manager Process encountered a local storage failure that was not recoverable.
  • System action: The Event Manager will be terminated.
  • User response: Correct the error and restart the region.
  • Destination: Console and standard error.
  • Module: casevmgr
3001I Event Manager exit enabled (exit-program-name)
The Event Manager Process loaded the user-defined exit.
  • System action: The Event Manager call the exit at appropriate points.
  • User response: None
  • Destination: Console and standard error.
  • Module: casevmgr
3002W Event Manager unable to load exit (exit-program-name)
The Event Manager Process was unable to load the user-defined exit.
  • System action: The Event Manager will ignore the exit.
  • User response: Check the exit specification and ensure it is on the search path.
  • Destination: Console and standard error.
  • Module: casevmgr
3005E Unable to parse filter string. expected "expected-value"; found "actual-value-found" - at end of "filter-string"
The event manager was unable to process the event filter string because it was badly constructed.
  • System action: Event manager will switch off event filtering for this exit and send all events without being filtered
  • User response: Check the filter string, and restart the server
  • Destination: Console and standard error.
  • Module: casevmgr
3006I Event Filter for (exit-name) has been enabled/disabled. Filter string: "filter-string"
Event manager has enabled/disabled the event filter for this exit.
  • System action: none
  • User response: none
  • Destination: Console and standard error.
  • Module: casevmgr
3007E Unexpected logic error in program when parsing the event filter string. Exit: "exit-name" / Filter string: "filter-string"
Event manager encountered a logic error when parsing the filter string for the specified exit.
  • System action: none
  • User response: contact Micro Focus Team
  • Destination: Console and standard error.
  • Module: casevmgr
3008E Illegal Type-id: "type-id-found". Max type-id: "max-type-id"
The type ID specified exceeds the maximum type ID.
  • System action: none
  • User response: check and correct the filter string
  • Destination: Console and standard error.
  • Module: casevmgr
3009E Illegal sub-type-id: "sub-type-id-found". Max sub-type-id: "max-sub-type-id"
The subtype ID specified exceeds the maximum subtype ID.
  • System action: none
  • User response: check and correct the filter string
  • Destination: Console and standard error.
  • Module: casevmgr
3010E Illegal id range: "id-lo" - "id-hi"
The ID range specified is invalid.
  • System action: none
  • User response: check and correct the filter string
  • Destination: Console and standard error.
  • Module: casevmgr
3011W Exit initialisation failed. Exit name: "exit-name"
The exit returned a return code specifying its initialisation failed.
  • System action: none
  • User response: check the exit to find out why initialisation of the exit failed
  • Destination: Console and standard error.
  • Module: casevmgr
3012E Initialisation to generate Windows Events from EMP failed.
EMP is unable to generate Windows events based on the events reported to EMP.
  • System action: none
  • User response: contact Micro Focus
  • Destination: Console and standard error.
  • Module: casevmgr
3013E Unable to register server as active server for Monitoring and Management. Monitoring and Management support disabled.
Event Manager is unable to register the server as an active server for Monitoring and Management.
  • System action: none
  • User response: contact Micro Focus
  • Destination: Console and standard error.
  • Module: casevmgr
3014E Unable to create Server Monitoring and Management shared memory. Monitoring and Management support disabled.
Event Manager is unable to create the shared memory region for Monitoring and Management
  • System action: none
  • User response: contact Micro Focus
  • Destination: Console and standard error.
  • Module: casevmgr
3015W Unable to unregister the server from active servers list for Monitoring and Management. Error Accessing registry
Event Manager is unable to unregister the server from the active servers for Monitoring and Management list.
  • System action: none
  • User response: contact Micro Focus
  • Destination: Console and standard error.
  • Module: casevmgr
3016I ES Monitoring and Management support enabled
The Monitoring and management support for this server has been enabled
  • System action: none
  • User response: none
  • Destination: Console and standard error.
  • Module: casevmgr
3017E ES Monitoring and Management unable to open performance registry key: "Registry key", RC=Return code for WIN API call "RegOpenKeyExA" . M & M disabled.
Event manager encountered an error opening the performance registry key
  • System action: none
  • User response: none
  • Destination: Console and standard error.
  • Module: casevmgr
3018E ES Monitoring and Management unable to get performance registry key: "Registry key\Registry value name", RC=Return code for WIN API call "RegQueryValueExA" .
Event manager encountered an error retrieving the performance registry key value
  • System action: M & M is disabled.
  • User response: Perform an install repair on your system.
  • Destination: Console and standard error.
  • Module: casevmgr
3019W ES Monitoring and Management retrieved unexpected value for "Registry key\Registry value name": actual=Actual value of registry key, expected Expected value of registry key.
Event manager retrieved an unexpected value for the performance registry key value. You may have performed a Windows install repair, which has reinstated a back-level registry entry.
  • System action: M & M may have been disabled.
  • User response: Perform an install repair on your system. You may also need to run a script file to effect additional repairs on the registry settings. This is called perfreg.cmd and is provided in NX\Base\SOURCE\ENTERPRISESERVER\Monitoring.
  • Destination: Console and standard error.
  • Module: casevmgr
3020E ES Monitoring and Management detected non-zero value for "Registry key\Registry value name". M & M disabled.
Event manager has detected that performance monitoring has been disabled.
  • System action: M&M is disabled.
  • User response: Use the registry editor program, regedit, to delete the key value or set it to 0. Check the "library" entry is pointing to the correct version of cas0perf.dll. Check the server's console.log file for monitoring and management messages. Shut down and restart your server.
  • Destination: Console and standard error.
  • Module: casevmgr
3021W ES Monitoring and Management unable to get value for "Registry key\Registry value name": Return code for WIN API call "RegQueryValueExA"
Event manager retrieved an unexpected return code when querying the performance registry key value. The performance counters may not have been loaded correctly.
  • System action: none
  • User response: Perform an install repair on your system. If this fails to restore performance monitoring, you will need to run the load counter utility, LODCTR. First, locate the file cas0psys.ini, which is in NX\Base\Bin. Then run this command: lodctr cas0psys.ini
  • Destination: Console and standard error.
  • Module: casevmgr
3022W ES Monitoring and Management detected incorrect value for "Registry key\Registry value name": Performance monitoring load module name
Event manager retrieved an unexpected value when querying the performance registry key value. Performance monitoring may not have been behave correctly.
  • System action: none
  • User response: Perform an install repair on your system. If this fails to restore performance monitoring, you will need update the registry key. This should have a value of NX\Base\Bin\cas0perf.dll, where NX" is the folder where you installed the product.
  • Destination: Console and standard error.
  • Module: casevmgr
3023E Error accessing file casglm.lck "return-code".
While trying to access the file casglm.lck an error occurred.
  • System action: none
  • User response: Check the return code, and contact your technical support.
  • Destination: Console and standard error.
  • Module: casmgr
TXAM1020W Error opening file (file-id) group (group-id) - status=(file-status-1,file-status-2)
A file marked as Start Open / Enabled could not be opened in system initialization due to the I/O error specified in file-status. If file-status-1 is 3 then the error is a standard file status code. A file-status-2 of 9 indicates an RTS error.

Common values for status:

Status | Reason | Action
3005 | File not found | Correct file name in FCT or create file with CFCR if necessary.
9065 | File locked | Ensure that another program has not opened the file exclusively.
9124 | Comms error | Make sure the Fileshare server is running and the correct CCI protocol is defined in the FHREDIR configuration file.
  • System action: The file will not be opened.
  • User response: Correct the error and open the file using the CFMT transaction.
  • Destination: Console
  • Module: dfhzplt
Parent topic: Enterprise Server Error Messages


CASBJ Error Messages

Message | Description | Resolution
CASBJ0000I message | This is an ad hoc message for the JES subsystem | None
CASBJ0001I Batch Input Spool has been "cold-started" | An existing Input Spool Repository for this Server was not found and therefore a new one was created. The Input Spool Repository is effectively in a "cold start" condition. | None
CASBJ0002E JCL parser not available | The batch JCL parser is not available on this server | Correct the installation
CASBJ0003E JOBjob-number duplicates an existing job number | The Job Entry Subsystem generated a job number that duplicates an existing job number. | Retry the submission
CASBJ0004I JOBjob-number job-name class job-class, TYPRUN=type-run | The Job Entry Subsystem accepted the submitted job | None
CASBJ0005I Batch initiator started for job classes "job-classes" | The batch initiator was started an is available for processing MVS JCL and native batch scripts. Jobs will be selected from classes job-classes. | None
CASBJ0006I Batch initiator initialization started | The batch initiator process initialization started | None
CASBJ0007S Error return-code during initialization of server PCA | An error occurred whilst initializing the server's Process Control Area. The server will not complete its initialization. | Make sure that the region for which the server was to be started is running and retry.
CASBJ0008I Batch Input Spool has been "cold-started" | An existing Input Spool Repository for this Server was not found and therefore a new one was created. The Input Spool Repository is effectively in a "cold start" condition. | None
CASBJ0009I Batch initiator shutdown complete. | The batch initiator server process has shutdown normally. | None.
CASBJ0010E Batch Spool File Error; Status action-status. | The batch execution server failed trying to open the Spool reference file. The action and status are: action-status | Correct the problem with the spool file and retry
CASBJ0011E Batch Spool File Error; Status action-status. | The batch execution server failed trying to close the Spool reference file. The action and status are: action-status | Correct the problem with the spool file and retry
CASBJ0012I Batch Input Spool has been "cold-started" | An existing Input Spool Repository for this Server was not found and therefore a new one was created. The Input Spool Repository is effectively in a "cold start" condition. | None
CASBJ0013E Batch Spool File Error; Status action-status. | The batch execution server failed trying to open the Spool reference file. The action and status are: action-status | Correct the problem with the spool file and retry
CASBJ0014I JOBjob-number started | The batch initiator has started processing job-number | None
CASBJ0015I message | This reports informational messages from the JCL execution engine | None
CASBJ0016W message | This reports warning messages from the JCL execution engine | None
CASBJ0017E message | This reports error messages from the JCL execution engine | None
CASBJ0018S message | This reports severe error messages from the JCL execution engine | None
CASBJ0019U message | This reports unrecoverable error messages from the JCL execution engine | None
CASBJ0020I Batch printer initialization started | The batch printer process initialization started | None
CASBJ0021I Batch printer started for print output classes "output-classes" | The batch printer was started an is available for processing system output. Jobs will be selected from classes output-classes. | None
CASBJ0022I Batch printer definition-name: class(es) "print-classes" | The batch printer was started an is available for processing output. Job output will be selected from classes print-classes. | None
CASBJ0023I Batch initiator definition-name: class(es) "initiator-classes" | The batch initiator was started an is available for processing output. Jobs will be selected from classes initiator-classes. | None
CASBJ0024I Batch Printer: "printer-name" | The batch printer was started and will write to physical printer printer-name. | None
CASBJ0025E Printer not found: "printer-name" | The physical printer printer-name was not found. | Correct the printer name and retry the operation
CASBJ0026I Exit Module: "exit-module" | The batch printer is configured to use exit module exit-module. | None
CASBJ0027E Printer assignment failed. RC=return-code | Call to set assigned printer as the default for this processor failed with a return-code of return-code. | Correct the printer name and retry the operation
CASBJ0028E Load failed for exit Module: "exit-module" | The batch printer failed to load exit module exit-module. | Correct exit module name or location and restart printer
CASBJ0029I print-dataset-title on printer-name | The batch printer is printing "print-dataset-title" on printer printer-name | None
CASBJ0030E error-message | The batch print processor experienced the stated problem. | None
CASBJ0031E Printer open failed. RC=return-code | Call to open assigned printer failed with a return-code of return-code. | Correct the printer problem and retry the operation
CASBJ0032E Printer write failed. RC=return-code | Call to write to the assigned printer failed with a return-code of return-code. | Correct the printer problem and retry the job
CASBJ0033E Printer error accessing spool data: status-data | Print processor encountered an error accessing the spool data. The operation and status is status-data. | Correct the problem and retry the job
CASBJ0034I Printer process shutdown complete. | The print processor server process has shutdown normally. | None.
CASBJ0035I Console input request is pending.# | A job or service has requested input from the system console. | Reply to the request
CASBJ0036E job-number Spool purge processor not available# | Print processor could not locate the Spool purge processor. | Correct the problem and restart the print processor
CASBJ0037E job-number Spool purge failed: RC = return-code | Print processor failed. The return code was return-code. | Correct the problem and restart the print processor
CASBJ0038I job-number Spool SYSOUT Purged | Processing of job-number completed and the spool output has been purged | None
CASBJ0039E JES support not enabled; Start for Printer rejected | The requested Printer was not started because JES support is not enabled. | Enable support and retry the operation
CASBJ0040E JES support not enabled; Start for Initiator rejected | The requested Job Initiator was not started because JES support is not enabled. | Enable support and retry the operation
CASBJ0041E Printer JES interface initialization failed. RC=return-code | The requested Printer output processor failed to start because JES initialization failed. | Correct the error and retry the operation
CASBJ0042E Batch initiator JES interface initialization failed. RC=return-code | The requested initiator JES interface failed | Correct the error and retry the operation
CASBJ0043E JOB Submit JES interface initialization failed. RC=return-code | The requested JOB Submit JES interface failed | Correct the error and retry the operation
CASBJ0044I Batch initiator restart requested for job classes "job-classes" | A batch initiator is terminating because of a "dirty container" condition. It has requested that ES start a replacement for the classes "job-classes". | None
CASBJ0045I JOB%job-number, DD number dd-number, size dataset-size requested | [An external process requested this dataset and transmission has started | None
CASBJ0046S JES Submit: User ID "user-ID" invalid or password incorrect | A job submission request was submitted but the associated user ID was invalid or the supplied password was incorrect | Correct the credentials and retry the operation
CASBJ0047S JES Submit: User ID "user-ID" not authorized | A job submission request was submitted but the associated user ID is not authorized for this action | Retry the operation with authorized credentials
CASBJ0048S JES CASOUT: User ID "user-ID" invalid or password incorrect | An attempt was made to interact with a batch initiator, printer or retrieve spool information and the associated user ID was invalid or the supplied password was incorrect | Correct the credentials and retry the operation
CASBJ0049S JES CASOUT: User ID "user-ID" not authorized | An attempt was made to interact with a batch initiator, printer or retrieve spool information and the associated user ID is not authorized | Retry the operation with authorized credentials
CASBJ0050E JES support not enabled; Job rejected | The requested job was not submitted because JES support is not enabled. | Enable support and retry the operation
CASBJ0051E Batch initiator JES interface initialization failed for ES Cluster manager ES Cluster manager APPLID. RC=return-code | The requested initiator JES interface failed to connect to ES Cluster manager | Correct the error and retry the operation
CASBJ0052S Batch initiator JES interface initialization failed for ES Cluster manager ES Cluster manager APPLID. RC=return-code | Connection to the ES Cluster manager is lost, ES Cluster member cannot participate to the ES Cluster | Correct the error and retry the operation
Parent topic: Enterprise Server Error Messages


CASCD Error Messages

  • CASCD0001 - CASCD0015
  • CASCD0016 - CASCD0031
  • CASCD0050 - CASCD0099
  • CASCD0100 - CASCD0117
  • CASCD0120 - CASCD0139
  • CASCD0141 - CASCD0159
  • CASCD0160 - CASCD0175
  • CASCD1001 - CASCD1043
  • CASCD1057 - CASCD1069
  • CASCD4002 - CASCD4007
Parent topic: Enterprise Server Error Messages


CASCF Error Messages

  • CASCF0001 - CASCF0015
  • CASCF0016 - CASCF0030
  • CASCF0031 - CASCF0045
  • CASCF0046 - CASCF0063
Parent topic: Enterprise Server Error Messages


CASCS Error Messages

  • CASCS1001 - CASCS1018
  • CASCS1100 - CASCS1115
  • CASCS1116 - CASCS1138
  • CASCS1500 - CASCS2004
  • CASCS5010 - CASCS5103
Parent topic: Enterprise Server Error Messages


CASFD Error Messages

  • CASFD0001 - CASFD0014
Parent topic: Enterprise Server Error Messages


CASKC Error Messages

  • CASKC0000 - CASKC0015
  • CASKC0016 - CASKC0030
  • CASKC0031 - CASKC0045
  • CASKC1000 - CASKC1003
  • CASKC5006 - CASKC6006
Parent topic: Enterprise Server Error Messages


CASMQ error messages

CASMQ1001I Connection to MQ series re-established.
The MQSeries trigger monitor program (CKTI) has re-established the connection to the MQ server. CKTI will continue triggering transactions
  • System action: None
  • User response: None
  • Destination: Console
  • Module: dfhtmqgw
CASMQ1002E Connection to MQ series lost, RC = reason-code, retrying...
The MQSeries trigger monitor program (CKTI) has lost the connection to the MQ server. CKTI will retry to connect in the background
  • System action: None
  • User response: None
  • Destination: Console
  • Module: dfhtmqgw
CASMQ1003E Failed to start transaction transaction from CKTI
The MQSeries trigger monitor program (CKTI) has failed to start the CICS transaction specified from the initiation queue message process definition.
  • System action: None
  • User response: None
  • Destination: Console
  • Module: dfhtmqgw
CASMQ1004E Unexpected error reason from MQGET in CKTI, RC = reason-code
The MQSeries trigger monitor program (CKTI) has received an unexpected reason code from a MQGET API call.
  • System action: None
  • User response: None
  • Destination: Console
  • Module: dfhtmqgw
CASMQ1005E Unable to start trigger transaction trans-id, reason = reason-code
The MQSeries trigger monitor program (CKTI) could not start the transaction defined in the MQSeries trigger process definition. The transaction may not be defined to the local system.
  • System action: No transaction will be started.
  • User response: Make sure that the transaction is defined correctly within the MQSeries process definition and is defined as a local transaction to the CICS region
  • Destination: Console
  • Module: dfhtmqgw
CASMQ1006E Unexpected message format (msg-format) on MQGET in CKTI
The MQSeries trigger monitor program (CKTI) was expecting a trigger message (MQFMT-TRIGGER) but received an unexpected format.
  • System action: Trigger transaction will not be started.
  • User response: Check the MQSeries Process definition.
  • Destination: Console
  • Module: dfhtmqgw
CASMQ1007E Unexpected application type (appltype) on MQGET in CKTI
The MQSeries trigger monitor program (CKTI) was expecting an application type of CICS (MQAT-CICS) but received an unexpected appltype.
  • System action: Trigger transaction will not be started.
  • User response: Check the MQSeries Process definition.
  • Destination: Console
  • Module: dfhtmqgw
CASMQ1008I IMS Trigger Monitor initialization completed
The IMS MQSeries Trigger Monitor successfully initialized
  • System action: None
  • User response: None
  • Destination: Console
  • Module: csq4trmn
CASMQ1009I IMS Trigger Monitor is ready, initiation queue: initiation-queue-name
The IMS MQSeries Trigger Monitor is ready to process user requests
  • System action: None
  • User response: None
  • Destination: Console
  • Module: csq4trmn
CASMQ1010I IMS Trigger Monitor terminated
The IMS MQSeries Trigger Monitor terminated
  • System action: None
  • User response: None
  • Destination: Console
  • Module: csq4trmn
CASMQ1011E Unexpected error while connecting to queue manager queue-manager-name in IMS Trigger Monitor, status: status-code
The IMS Trigger Monitor received an error trying to connect to the Queue Manager
  • System action: The IMS Trigger Monitor is terminated
  • User response: Ensure that the Queue Manager in the Trigger Monitor startup JCL is correct
  • Destination: Console
  • Module: csq4trmn
CASMQ1012E Unexpected error while opening initiation queue initiation-queue-name in IMS Trigger Monitor, status: status-code
The IMS Trigger Monitor received an error trying to open the initiation queue
  • System action: The IMS Trigger Monitor is terminated
  • User response: Ensure that the initiation queue in the Trigger Monitor startup JCL is correct and that the initiation queue has been defined
  • Destination: Console
  • Module: csq4trmn
CASMQ1013E Unexpected error while getting message from the initiation queue initiation-queue-name in IMS Trigger Monitor, status: status-code
The IMS Trigger Monitor received an error retrieving a message token from the initiation queue that is being monitored
  • System action: The message token on the initiation queue will not be processed
  • User response: Check the completion and reason code to determine the cause of the error displayed in the message
  • Destination: Console
  • Module: csq4trmn
CASMQ1014E Unexpected error while closing initiation queue initiation-queue-name in IMS Trigger Monitor, status: status-code
The IMS Trigger Monitor could not close the initiation queue during termination
  • System action: None
  • User response: Check the completion and reason code to determine the cause of the error
  • Destination: Console
  • Module: csq4trmn
CASMQ1015E Unexpected error while disconnecting from queue manager queue-manager-name in IMS Trigger Monitor, status: status-code
An error was received during termination when the IMS Trigger Monitor attempted to disconnect from the Queue Manager
  • System action: None
  • User response: Check the completion and reason code to determine the cause of the error
  • Destination: Console
  • Module: csq4trmn
CASMQ1016E Unexpected application type appltype on MQGET in IMS Trigger Monitor
The IMS MQSeries Trigger Monitor was expecting an application type of IMS (MQAT-IMS) but received an unexpected appltype.
  • System action:The transaction specified in the MQSeries process definition will not be started.
  • User response: Check the MQSeries Process definition.
  • Destination: Console
  • Module: csq4trmn
CASMQ1017E Unexpected MQ message version message-version in IMS Trigger Monitor
The IMS MQSeries Trigger Monitor program (CSQ4TRMN) was expecting an MQ message version 1 (MQTM-VERSION-1) but received an unexpected version.
  • System action: Trigger transaction will not be started.
  • User response: Check the MQSeries Process definition.
  • Destination: Console
  • Module: csq4trmn
CASMQ1018E Unexpected MQ message structid mqtm-strucid in IMS Trigger Monitor
The IMS MQSeries Trigger Monitor program (CSQ4TRMN) was expecting a message with mqtm strucid of (MQTM-STRUC-ID) but received an unexpected mqtm strucid.
  • System action: Trigger transaction will not be started.
  • User response: Check the MQSeries Process definition.
  • Destination: Console
  • Module: csq4trmn
CASMQ1019E Unexpected error from IMS SYNC call, status code: status-code
An IMS SYNC issued by the IMS Trigger Monitor has failed.
  • System action: None
  • User response: Check the status code to determine the cause of the error
  • Destination: Console
  • Module: csq4trmn
CASMQ1020E Unexpected error from IMS CHNG call, status code:status-code
An IMS CHNG issued by the IMS Trigger Monitor has failed.
  • System action: Trigger transaction will not be started
  • User response: Check the status code to determine the cause of the error
  • Destination: Console
  • Module: csq4trmn
CASMQ1021E Unexpected error from IMS ISRT call, status code: status-code
An IMS ISRT call issued by the IMS Trigger Monitor has failed.
  • System action: Trigger transaction will not be started
  • User response: Check the status code to determine the cause of the error
  • Destination: Console
  • Module: csq4trmn
CASMQ1022E Unexpected error from IMS PURG call, status code: status-code
An IMS PURG call issued by the IMS Trigger Monitor has failed
  • System action: None
  • User response: Check the status code to determine the cause of the error
  • Destination: Console
  • Module: csq4trmn
CASMQ1023I Missing queue manager name, will try using the default queue manager
A MQSeries Queue Manager name was not specified in the IMS Trigger Monitor startup JCL
  • System action: The IMS Trigger Monitor will try using the default queue manager
  • User response: Specify a valid MQSeries Queue Manager name in the IMS Trigger Monitor startup JCL
  • Destination: Console
  • Module: csq4trmn
CASMQ1024E Missing initiation queue name
A MQSeries initiation queue name was not specified in the IMS Trigger Monitor startup JCL
  • System action: The IMS Trigger Monitor is not started
  • User response: Specify a valid MQSeries initiation queue name in the IMS Trigger Monitor startup JCL
  • Destination: Console
  • Module: csq4trmn
CASMQ1025E Unexpected error while connecting to queue manager queue-manager-name in the IMS Trigger Monitor, status: status-code
The IMS Trigger Monitor received an error trying to connect to the Queue Manager
  • System action: The IMS Trigger Monitor is not terminated
  • User response: Ensure that the Queue Manager in the Trigger Monitor startup JCL is correct
  • Destination: Console
  • Module: csq4trmn
CASMQ1026E Unexpected error while opening initiation queue initiation-queue-name in the IMS Trigger Monitor, status: status-code
The IMS Trigger Monitor received an error trying to open the initiation queue
  • System action: The IMS Trigger Monitor is not terminated
  • User response: Ensure that the initiation queue in the Trigger Monitor startup JCL is correct and that the initiation queue has been defined
  • Destination: Console
  • Module: csq4trmn
CASMQ1027E Unexpected error while putting message into the initiation queue initiation-queue-name in IMS Trigger Monitor, status: status-code
The IMS Trigger Monitor received an error placing a message token into the initiation queue that is being monitored
  • System action: The message token will not be placed into the initiation queue
  • User response: Check the completion and reason code to determine the cause of the error displayed in the message
  • Destination: Console
  • Module: csq4trmn
CASMQ1028E Unexpected error while closing initiation queue initiation-queue-name in IMS Trigger Monitor, status: status-code
The IMS Trigger Monitor could not close the initiation queue during termination
  • System action: None
  • User response: Check the completion and reason code to determine the cause of the error
  • Destination: Console
  • Module: csq4trmn
CASMQ1029E error-message
An error message generated from the IMS Trigger Monitor
  • System action: None
  • User response: Check the error message and take appropriate action
  • Destination: Console
  • Module: csq4trmn
CASMQ1030E Unexpected error while issuing MQCMIT call queue-manager-name in IMS Trigger Monitor, status: status-code
The IMS Trigger Monitor could not successfully issue a call to commit the MQSeries trigger token message after invoking the end user IMS program
  • System action: None
  • User response: Check the completion and reason code to determine the cause of the error
  • Destination: Console
  • Module: csq4trmn
Parent topic: Enterprise Server Error Messages


CASRD Error Messages

  • CASRD0001 - CASRD0015
  • CASRD0016 - CASRD0030
  • CASRD0031 - CASRD0045
  • CASRD0046 - CASRD0052
  • CASRD1000 - CASRD1015
  • CASRD1016 - CASRD1041
Parent topic: Enterprise Server Error Messages


CASSP Error Messages

  • CASSP0001 - CASSP0014
Parent topic: Enterprise Server Error Messages


CASST Error Messages

  • CASST0000 - CASST0020
  • CASST4000 - CASST4111
  • CASST5000 - CASST6002
Parent topic: Enterprise Server Error Messages


CASTS Error Messages

Message | Description | Resolution
CASTS0001I ES TSC Service Process restart in progress | The ES TSC Service process has been restarted and recovery operations are in progress | None
CASTS0002I ES TSC Service Process initialization complete | The ES TSC Service Process has completed initialization. | None
CASTS0003I ES TSC Service Process termination started | The ES TSC Service Process is terminating. | None
CASTS0004S ES TSC Service Process registration failed, reason = reason-code | The ES TSC Service Process failed registration. | Report failure to Micro Focus
CASTS0005I ES TSC Service Process termination complete# | The ES TSC Service Process has terminated. | None
CASTS0006I tsc-control-message | The ES TSC Service Process issued a message. | Action the message
CASTS0007I ES TSC Service Process initialization started | The server ES TSC Service Process initialization has started. | None
CASTS0008S ES TSC Service Process is not running in multi-threaded mode | The ES TSC Service Process has not started with the required underlying thread support. | Report failure to Micro Focus
CASTS0009W TS queue queue-number inconsistent end at location queue-file-block; should be expected-file-block. | The ES TSC process has encountered a problem with temporary storage queue queue-number. The reported block (expected-file-block) is the expected end and it may be orphaned. | Verify that important data has not been lost.
CASTS0010W TS queue queue-number invalid chain start at location queue-file-block. | The ES TSC process has encountered a problem with temporary storage queuequeue-number. The reported block is not of the proper TS data type. | The reported block is the expected first in the chain.
CASTS0011W TS queue queue-number invalid chain next reference queue-file-block from block next-file-block. | The ES TSC process has encountered a problem with temporary storage queuequeue-number. The reported block (queue-file-block) has a chain next pointer of next-file-block which is out of range. | The reported block is the expected first in the chain. Verify that important data has not been lost.
CASTS0018W TS queue queue-number invalid segment referenced segment-reference from block queue-file-block. | The ES TSC process has encountered a problem with temporary storage queue queue-number. The reported block (queue-file-block) has a chain next pointer which points to an invalid segment in the message queue file. | The reported block is the expected first in the chain. Verify that important data has not been lost.
CASTS5012S ES TSC Log and Intra-Partition TS/TD init failed. Reason (reason-code) The IMS TM Control Process failed to initialize its message queues. The reason code is one of the following and may be followed by a ":" and RTS file IO error code.
  • 0 - Queue file anchor array size mismatch
  • 1 - Failure reading queue file header
  • 2 - Failure during create of the queue file
  • 3 - Failure writing the queue file headers
  • 4 - Failure allocating queue file buffers
  • 5 - Failure allocating storage for the free space array
  • 6 - Failure writing the free space array
  • 7 - Failure reading the free space array
  • 8 - Queue file header record size mismatch
  • 9 - Queue file record size mismatch
  • A - Queue file record block number mismatch
Correct the message queues configuration and restart the Enterprise Server
CASTS5013I ES TSC Log and Intra-Partition TS/TD cold started | The ES TS/TD repository has been cold started. No old data has been retained. | None
CASTS5014W ES TSC Log and Intra-Partition TS/TD not properly closed previously | The ES TS/TD repository was not properly colsed the last time it was accessed. | None
CASTS5015I ES TSC Log and Intra-Partition TS/TD: queue-file-name | queue-file-name is the name of the IMS Message Queues file that will be used during this execution of ES. | None
CASTS5016I ES TSC Log and Intra-Partition TS/TD File size: block-count blocks (size bytes) | The allocated block count for the message queues is block-count. These blocks are composed of a block header plus 254 segments, each consisting of 244 bytes of queue data. The total file size is size bytes. | None
CASTS5017I ES TSC Log and Intra-Partition TS/TD running with queue-buffer-count buffers of buffer-size bytes each# | queue-buffer-count buffers are allocated for the message queues use during this execution of ES. Each buffer is buffer-size bytes in length. | None
CASTS5020S ES TSC Log and Intra-Partition TS/TD version mismatch. Disk version is version | The message queue disk file is written in a format that is not supported by this version of IMS TM. The version on disk appears to be version. | Upgrade the message queue file if a utility is available or cold start the IMS Message Queue
CASTS5021S ES TSC Log and Intra-Partition TS/TD upgrade or cold start is required. Version: version | The message queue disk file is written in a format that is not supported by this version of ES. The current TM software version is version. | Or continue with the current cold start.
CASTS5033S ES TSC Log and Intra-Partition TS/TD corruption detected: block queue-file-block | The ES TS/TD repository is corrupted. | Assess system damage, stop and repair system if necessary
CASTS5034S ES TSC Log and Intra-Partition TS/TD segment error: block queue-file-block; segment segment-number | The ES TS/TD repository disk storage is corrupted. | Assess system damage, stop and repair system if necessary
CASTS5036S ES TSC Log and Intra-Partition TS/TD structure problem encountered | The message queue disk file structure is not recognized. | Recover or cold start the TS/TD Repository.
CASTS5037I ES TSC old TS/TD File: Log and TS/TD repository name | Log and TS/TD repository name is the old ES Log and TS/TD repository that was replaced as a part of cold starting the repository. | None
CASTS5038I Cannot open HSF file because the file is locked. File: filename | The filename cannot be opened because the file is locked | Close any programs that have a lock on filename
CASTS5040I ES TSC Log and Intra-Partition TS/TD flush operations disabled | Flush operations for this file are bypassed. When this mode of operation is used, file integrity will not be assured in the event of a system failure. | None
CASTS5041I ES TSC Log and Intra-Partition TS/TD flush requests aggregate time aggregation-minimum milliseconds | A flush aggregation span of aggregation-minimum millisecond is now effective. This will cause flush requests to be accumulated during the specified interval and a single flush issued for all requests. | None
CASTS5042I ES TSC Log and Intra-Partition TS/TD flush requests aggregate disabled | Fush aggregation has been dynamically disabled | None
CASTS5043I ES TSC Log and Intra-Partition TS/TD flush requests enabled | Flush operations for this file are now enabled | None
Parent topic: Enterprise Server Error Messages


CASXO Error Messages

  • CASXO0001 - CASXO0015
  • CASXO0016 - CASXO0026
Parent topic: Enterprise Server Error Messages


User Exits

This contains the available user exits:

  • Exit Points
  • Support Functions
  • Structures
Parent topic: Enterprise Server Reference


Exit Points

The following exit points are available:

  • Exit Interface Definition
    Contains the information required by the exit routines for processing at each exit point. A pointer to this structure, together with the exit point identifier, is passed to each exit function.
  • External Data Value Modification - Input Parameter (Exit Point 1)
    Allows you to override the external value provided by the client request for the given COBOL program's Linkage Section item.
  • Internal Data Value Modification - Input Parameter (Exit Point 2)
    Allows you to override the internal value provided by the client request for the given COBOL program's Linkage Section item.
  • Unmapped Named External Input Parameter (Exit Point 3)
    Allows you to handle an unmapped named external input parameter that has been specified in the client request.
  • End of Input Request Processing (Exit Point 4)
    Allows you to initialize parameter values in the internal data areas addressed by argv other than those initialised during external parameter mapping.
  • Start of Response Processing (Exit Point 5)
    Allows you to bypass completely the default response processing.
  • Internal Data Value Modification - Output Parameter (Exit Point 6)
    Allows you to override the internal data value created during the execution of the application.
  • External Data Value Modification - Output Parameter (Exit Point 7)
    Allows you to override the internal data value created during the execution of the application.
  • End of Response Processing (Exit Point 8)
    Allows you to override the internal data value created during the execution of the application.
  • End of Request Processing (Exit Point 9)
    Allows you to release any resources that were allocated in exit points 0 through 8.
Parent topic: User Exits


Exit Interface Definition

Syntax:

typedef cblt_rtncode (*PFI_IDP_EXIT)(mf_uns32      exit_point,
                                     IDP_EXIT_INFO *exit_info);

On Entry:

exit point
Exit point in the request handler:
1 | External data value modification - input parameter
2 | Internal data value modification - input parameter
3 | Unmapped named external input parameter
4 | End of input request processing
5 | Start of response processing
6 | Internal data value modification - output parameter
7 | External data value modification - output parameter
8 | End of response processing
9 | End of request processing
exit_info
Usage depends on the exit point

On Exit:

exit_info
Usage depends on the exit point

Return codes:

Depends on the exit point.

Parent topic: Exit Points


External Data Value Modification - Input Parameter (Exit Point 1)

Syntax:

typedef cblt_rtncode (*PFI_IDP_EXIT)(mf_uns32      exit_point,
                                     IDP_EXIT_INFO *exit_info);

On Entry:

exit point
1 = External data value modification - input parameter
exit_info
version | Version of structure format
flags | 0
ext_value_size | Size of data addressed by ext_value
funcs | User exit support functions
field_name | Name of data item in COBOL program's Linkage Section
ext_param_name | Name of external parameter
ext_value | External data value associated with field_name
request_cxt | Request context
exit_data | User exit-specific data

On Exit:

exit_info
ext_value_size | Size of data addressed by ext_value. Needs to be updated only if the user exit allocates memory for a new ext_value string
ext_value | External data value to be associated with field_name. Needs to be updated only if the user exit allocates memory for a new ext_value string
exit_data | User exit-specific data

Return codes:

IDP_EXIT_CONTINUE
0 = Continue with default parameter mapping
IDP_EXIT_STOP
1 = Terminate mapping processing. No service will be invoked. An error response will be required
IDP_EXIT_HANDLED
2 = The exit has overridden the supplied external value. Use this value to perform default mapping for the given COBOL program Linkage Section field name.

Comments:

This exit gives you the opportunity to override the external value provided by the client request for the given COBOL program Linkage Section field name. If the exit chooses to override the external value, it must return IDP_EXIT_HANDLED and either update ext_value in place (if the replacement value is less or equal to ext_value_size), or allocate a replacement string using the support function fn_alloc_mem and set ext_value and ext_value_size accordingly. The request handler then performs default mapping for the original (IDP_EXIT_CONTINUE) or overridden (IDP_EXIT_HANDLED) external data value.

The user exit program owns the exit_data field of the IDP_EXIT_INFO structure. You would typically use it to preserve context information between exit point invocations. You can use it when returning any of the IDP_EXIT_ return values.

Parent topic: Exit Points


Internal Data Value Modification - Input Parameter (Exit Point 2)

Syntax:

typedef cblt_rtncode (*PFI_IDP_EXIT)(mf_uns32      exit_point,
                                     IDP_EXIT_INFO *exit_info);

On Entry:

exit point
2 = Internal data value modification - input parameter
exit_info
version | Version of structure format
flags | 0
data_size | Size of data ddressed by data_ptr
ext_value_size | Size of data addressed by ext_value
funcs | User exit support functions
field_name | Name of data item in COBOL program's Linkage Section
data_ptr | Internal data value associated with field_name
ext_param_name | Name of external parameter
ext_value | External data value associated with field_name
request_cxt | Request context
exit_data | User exit-specific data

On Exit:

exit_info
exit_data User exit-specific data

Return codes:

IDP_EXIT_CONTINUE
0 = Continue with default parameter mapping
IDP_EXIT_STOP
1 = Terminate mapping processing. No service will be invoked. An error response will be required
IDP_EXIT_HANDLED
2 = The exit has overridden the supplied internal value

Comments:

This exit gives you the opportunity to override the internal data value created by the request handler’s default mapping from the external data value provided by the client request for the given COBOL program Linkage Section data item name. data_ptr addresses the memory created by the request handler to be passed to the user program as part of its Linkage Section. If the exit chooses to override this parameter, it must only modify up to data_size bytes starting at data_ptr, and must return IDP_EXIT_HANDLED.

The user exit program owns the exit_data field of the IDP_EXIT_INFO structure. You would typically use it to preserve context information between exit point invocations. You can use it when returning any of the IDP_EXIT_ return values.

Parent topic: Exit Points


Unmapped Named External Input Parameter (Exit Point 3)

Syntax:

typedef cblt_rtncode (*PFI_IDP_EXIT)(mf_uns32      exit_point,
                                     IDP_EXIT_INFO *exit_info);

On Entry:

exit point
3 = Unmapped named external input parameter
exit_info
version
Version of structure format
flags
0
ext_value_size
Size of data addressed by ext_value
funcs
User exit support functions
ext_param_name
Name of external parameter
ext_value
External data value associated with field_name
request_cxt
version | Version of structure format
argc | Parameter count of loaded service
service_type | Type of client request
flags | Request context control flags
argv | Parameter list of loaded service
service_name | Name of loaded service
pgm_name | Name of the main program associated with the service
epoint_name | Name of the entry point to invoke
exit_data
User exit-specific data

On Exit:

exit_info
flags
0
request_cxt
accept_buf_len | Length of data in accept_buf
cmd_line _len | Length of data in cmd_line
flags | Request context control flags
accept_buf | Data to be used for ANSI ACCEPT statements
cmd_line | String to be used to resolve ACCEPT FROM COMMAND-LINE statements
exit_data
User exit-specific data

Return codes:

IDP_EXIT_CONTINUE
0 = Continue with processing
IDP_EXIT_STOP
1 = Terminate mapping processing. No service will be invoked. An error response will be required
IDP_EXIT_HANDLED
2 = The exit has overridden one or more of the returned request context fields

Comments:

This exit gives you the opportunity to handle an unmapped named external input parameter that has been specified in the client request. The exit program would typically handle the parameter by setting an appropriate value in one or more of the data areas addressed by argv, setting up data to be used for ANSI ACCEPT statements (accept_buf), or setting up the application’s command line (cmd_line). The exit should use the fn_alloc_mem support function of the exit_info funcs structure to allocate any memory used for the setting up of accept_buf or cmd_line. If the exit chooses to override any of the request context fields, it must return IDP_EXIT_HANDLED.

The user exit program owns the exit_data field of the IDP_EXIT_INFO structure. You would typically use it to preserve context information between exit point invocations. You can use it when returning any of the IDP_EXIT_ return values.

Parent topic: Exit Points


End of Input Request Processing (Exit Point 4)

Syntax:

typedef cblt_rtncode (*PFI_IDP_EXIT)(mf_uns32   exit_point,
                                  IDP_EXIT_INFO *exit_info);

On Entry:

exit point
4 = End of input request processing
exit_info
version
Version of structure format
flags
0
funcs
User exit support functions
request_cxt
version | Version of structure format
argc | Parameter count of loaded service
service_type | Type of client request
accept_buf_len | Length of data in accept_buf
cmd_line_len | Length of data in cmd_line
flags | Request context control flags
argv | Parameter list of loaded service
service_name | Name of loaded service
pgm_name | Name of the main program associated with the service
epoint_name | Name of the entry point to invoke
accept_buf | Data to be used for ANSI ACCEPT statements
cmd_line | String to be used to resolve ACCEPT FROM COMMAND-LINE statements
exit_data
User exit-specific data

On Exit:

exit info
flags
0
request_cxt
argc | Parameter count of loaded service
service_type | Type of client request
accept_buf_len | Length of data in accept_buf
cmd_line_len | Length of data in cmd_line
flags | Request context control flags
argv | Parameter list of loaded service
service_name | Name of loaded service
pgm_name | Name of the main program associated with the service
epoint_name | Name of the entry point to invoke
accept_buf | Data to be used for ANSI ACCEPT statements
cmd_line | String to be used to resolve ACCEPT FROM COMMAND-LINE statements
exit_data
User exit-specific data

Return codes:

IDP_EXIT_CONTINUE
0 = Continue with processing
IDP_EXIT_STOP
1 = Terminate mapping processing. No service will be invoked. An error response will be required
IDP_EXIT_HANDLED
2 = The exit has overridden one or more of the returned request context fields

Comments:

This exit gives you the opportunity to initialize parameter values in the internal data areas addressed by argv other than those initialized during external parameter mapping. The exit can optionally modify any of the returned request fields listed above. The exit should use the fn_alloc_mem support function of the exit_info funcs structure to allocate any memory used to replace request context strings (for example, service_name or epoint_name) or argv fields. If the exit chooses to override any of the request context fields, it must return IDP_EXIT_HANDLED.

The user exit program owns the exit_data field of the IDP_EXIT_INFO structure. You would typically use it to preserve context information between exit point invocations. You can use it when returning any of the IDP_EXIT_ return values.

Parent topic: Exit Points


Start of Response Processing (Exit Point 5)

Syntax:

typedef cblt_rtncode (*PFI_IDP_EXIT)(mf_uns32      exit_point,
                                     IDP_EXIT_INFO *exit_info);

On Entry:

exit point
5 = Start of response processing
exit_info
version
Version of structure format
flags
0
funcs
User exit support functions
request_cxt
version | Version of structure format
argc | Parameter count of loaded service
return_code | Service's return code, or run-time error generated by service
service_type | Type of client request
display_buf_len | Length of data in display_buf
flags | Request context control flags
protocol_attrs | An array of pointers to protocol-specifc attributes
argv | Parameter list of loaded service
service_name | Name of loaded service
pgm_name | Name of the main program associated with the service
display_buf | Concatenation of strings output by ANSI DISPLAY statements
response
flagss | Control flags
response_type | Server's response type
exit_data
User exit-specific data

On Exit:

exit_info
flags
0
response
response_len | Length of response_buf
flags | Control flags
response_buf | Server's response buffer
content_type | NULL-terminated content type string (HTTP) only
exit_data
User exit-specific data

Return codes:

IDP_EXIT_CONTINUE
0 = Continue with default response processing
IDP_EXIT_STOP
1 = Terminate mapping processing. An error response will be required
IDP_EXIT_HANDLED
2 = The entire response has been built by the exit. No further processing is required. The response is ready to be sent back to the client.

Comments:

This exit gives you the opportunity to bypass completely the default response processing. If the exit wants the default response processing to be bypassed, it must set up the response fields indicated above as being returned fields, using the fn_alloc_mem support function of the exit_info funcs structure to allocate the memory for the response buffer, and return IDP_EXIT_HANDLED.

The user exit program owns the exit_data field of the IDP_EXIT_INFO structure. You would typically use it to preserve context information between exit point invocations. You can use it when returning any of the IDP_EXIT_ return values.

Parent topic: Exit Points


Internal Data Value Modification - Output Parameter (Exit Point 6)

Syntax:

typedef cblt_rtncode (*PFI_IDP_EXIT)(mf_uns32      exit_point,
                                     IDP_EXIT_INFO *exit_info);

On Entry:

exit point
6 = Internal data value modification - output parameter
exit_info
version | Version of structure format
flags | 0
data_size | Size of data addressed by the data_ptr field
funcs | User exit support functions
field name | Name of data item in COBOL program's Linkage Section
data_ptr | Internal data value associated with field_name
ext_param_name | External parameter name
request_cxt | Request context
exit_data | User exit-specific data

On Exit:

exit_info
exit_data
User exit-specific data

Return codes:

IDP_EXIT_CONTINUE
0 = Continue with default parameter mapping
IDP_EXIT_STOP
1 = Terminate mapping processing. An error response will be required
IDP_EXIT_HANDLED
The exit has overridden the supplied internal data value

Comments:

This exit gives you the opportunity to override the internal data value created during the execution of the application. data_ptr addresses the memory assigned to the internal data value. If the exit chooses to override this parameter, it must only modify up to data_size bytes starting at data_ptr, and must return IDP_EXIT_HANDLED. The request handler will subsequently perform default mapping for the original (IDP_EXIT_CONTINUE) or overridden (IDP_EXIT_HANDLED) internal data value.

The user exit program owns the exit_data field of the IDP_EXIT_INFO structure. You would typically use it to preserve context information between exit point invocations. You can use it when returning any of the IDP_EXIT_ return values.

Parent topic: Exit Points


External Data Value Modification - Output Parameter (Exit Point 7)

Syntax:

typedef cblt_rtncode (*PFI_IDP_EXIT)(mf_uns32      exit_point,
                                     IDP_EXIT_INFO *exit_info);

On Entry:

exit point
7 = External data value modification - output parameter
exit_info
version | Version of structure format
flags | 0
ext_value_size | Size of data addressed by the ext_value field
funcs | User exit support functions
field name | Name of data item in COBOL program's Linkage Section
ext_param_name | Name of external parameter
ext_value | External data value associated with the field_name field
request_cxt | Request context
exit_data | User exit-specific data

On Exit:

exit_info
ext_value_size | Size of data addressed by the ext_value field. Needs to be updated only if the user exit allocates memory for a new ext_value string
ext_value | External data value to be associated with field_name. Needs to be updated only if the user exit allocates memory for a new ext_value string
exit_data | User exit-specific data

Return codes:

IDP_EXIT_CONTINUE
0 = Continue with default parameter mapping
IDP_EXIT_STOP
1 = Terminate mapping processing. An error response will be required
IDP_EXIT_HANDLED
2 = The exit has overridden the supplied external data value. Use this value to perform default mapping for the given COBOL Linkage Section field name
IDP_EXIT_OMIT
3 = The exit has determined that the given parameter should not be included in the response

Comments:

This exit gives you the opportunity to override the external value created by the request handler in its default mapping processing for the given COBOL Linkage Section field name. If the exit chooses to override the external value, it must return IDP_EXIT_HANDLED and either update ext_value in place (if the replacement value is less or equal to ext_value_size), or allocate a replacement string using the support function fn_alloc_mem and set ext_value and ext_value_size accordingly. The request handler will use the returned ext_value (IDP_EXIT_CONTINUE or IDP_EXIT_HANDLED) in its default response processing.

The user exit program owns the exit_data field of the IDP_EXIT_INFO structure. You would typically use it to preserve context information between exit point invocations. You can use it when returning any of the IDP_EXIT_ return values.

Parent topic: Exit Points


End of Response Processing (Exit Point 8)

Syntax:

typedef cblt_rtncode (*PFI_IDP_EXIT)(mf_uns32      exit_point,
                                     IDP_EXIT_INFO *exit_info);

On Entry:

exit point
8 = End of response processing
exit_info
version
Version of structure format
flags
0
funcs
User exit support functions
request_cxt
version | Version of structure format
service_type | Type of client request
display_buf_len | Length of data in display_buf
flags | Request context control flags
service_name | Name of loaded service
pgm_name | Name of the main program associated with the service
epoint_name | Name of the entry point to invoke
display_buf | Concatenation of strings output by ANSI DISPLAY statements
response
response_len | Length of response_buf
flags | Control flags
response_buf | Response buffer created by default mapping or overridden by the exit
content_type | NULL-terminated content type string (HTTP only)
exit_data
User exit-specific data

On Exit:

exit_info
response
response_len | Length of response_buf
response_buf | Response buffer
content_type | NULL-terminated content type string (HTTP only)
exit_data
User exit-specific data

Return codes:

IDP_EXIT_CONTINUE
0 = Continue with processing
IDP_EXIT_STOP
1 = Terminate response processing. The default response is not to be sent. An error response will be required
IDP_EXIT_HANDLED
2 = The exit has overridden the default response

Comments:

This exit gives you the opportunity to override the full response generated by default mapping. The exit can optionally modify any of the returned request fields listed above. The exit should use the fn_alloc_mem support function of the exit_info funcs structure to allocate any memory used to replace the response_buf field. If the exit chooses to override any of the response structure fields, it must return IDP_EXIT_HANDLED.

The user exit program owns the exit_data field of the IDP_EXIT_INFO structure. You would typically use it to preserve context information between exit point invocations. You can use it when returning any of the IDP_EXIT_ return values.

Parent topic: Exit Points


End of Request Processing (Exit Point 9)

Syntax:

typedef cblt_rtncode (*PFI_IDP_EXIT)(mf_uns32      exit_point,
                                     IDP_EXIT_INFO *exit_info);

On Entry:

exit point
9 = End of request processing
exit_info
version | Version of structure format
flags | 0
funcs | User exit support functions
request_cxt | Request context
exit_data | User exit-specific data

On Exit:

None

Return codes:

IDP_EXIT_CONTINUE
0 = Continue with processing
IDP_EXIT_STOP
1 = An error has occurred during end of request processing

Comments:

This exit gives you the opportunity to release any resources that were allocated in exit points 0 through 8.

Parent topic: Exit Points


Support Functions

The following support functions are available:

  • PFI
    A generic type definition for a function that returns an integer value.
  • PFI_IDPES_FN_DISPLAY_TO_UTF16
    Converts COBOL DISPLAY encoded strings to UTF-16 encoded strings.
  • PFI_IDPES_FN_UTF16_TO_DISPLAY
    Converts UTF-16 encoded strings to COBOL DISPLAY encoded strings.
  • PFV_IDPES_FN_ALLOC_MEM
    Allocates memory for user exits to use.
  • PFV_IDPES_FN_FREE_MEM
    Frees memory previously allocated for user exits to use.
Parent topic: User Exits


PFI

Syntax:

typedef cobrtncode_t (*PFI)();

On Entry:

None

On Exit:

None

Function returns:

An integer

Parent topic: Support Functions


PFI_IDPES_FN_DISPLAY_TO_UTF16

Syntax:

typedef cblt_rtncode (*PFI_IDPES_FN_DISPLAY_TO_UTF16)(
                                                cobuns8_t  in_string,
                                                cobuns32_t in_len,
                                                cobuns8_t  out_string,
                                                cobuns32_t *out_len);

On Entry:

in_string | COBOL DISPLAY encoded string
in_len | Size of in_string
out_len | Maximum size of out_string, or 0 for function to return the required size of out_string

On Exit:

out_string | UTF-16 encoded string
out_len | Size of out_string, or required size if 0 specified on input, or if function returns IDPES_BUFFER_TOO_SMALL

Return codes:

0 | IDPES_SUCCESS
1 | IDPES_BUFFER_TOO_SMALL

Comments:

Used by user exits to convert COBOL DISPLAY encoded strings into UTF-16 encoded ones

Parent topic: Support Functions


PFI_IDPES_FN_UTF16_TO_DISPLAY

Syntax:

typedef cblt_rtncode (*PFI_IDPES_FN_UTF16_TO_DISPLAY)(
                                                cobuns8_t  in_string,
                                                cobuns32_t in_len,
                                                cobuns8_t  out_string,
                                                cobuns32_t *out_len);

On Entry:

in_string | UTF16 encoded string
in_len | Size of in_string
out_len | Maximum size of out_string, or 0 for function to return the required size of out_string

On Exit:

out_string | COBOL DISPLAY encoded string
out_len | Size of out_string, or required size if 0 specified on input, or if function returns IDPES_BUFFER_TOO_SMALL

Return codes:

0 | IDPES_SUCCESS
1 | IDPES_BUFFER_TOO_SMALL

Comments:

Used by user exits to convert UTF-16 encoded strings into COBOL DISPLAY encoded ones

Parent topic: Support Functions


PFV_IDPES_FN_ALLOC_MEM

Syntax:

typedef void *(*PFV_IDPES_FN_ALLOC_MEM)(cobuns32_t mem_size);

On Entry:

mem_size Number of bytes to allocate

On Exit:

None

Function returns:

A pointer to the allocated space, or NULL if there is insufficient memory available or an error occurs during the allocation process.

Comments:

Used by user exits to allocate memory, for example, for the creation of a replacement external data value during exit point 7, External Data Value Modification - Output Parameter. If you allocate memory using this function you should subsequently free it using the fn_free_mem support function of IDP_EXIT_SERVICE_FUNCS.

Parent topic: Support Functions


PFV_IDPES_FN_FREE_MEM

Syntax:

typedef void *(*PFV_IDPES_FN_FREE_MEM)(void *mem);

On Entry:

mem Memory to be freed

On Exit:

None

Function returns:

Nothing

Comments:

Used by user exits to free memory previously allocated via the fn_alloc_mem support function of IDP_EXIT_SERVICE_FUNCS.

Parent topic: Support Functions


Structures

The following structures are available:

  • IDP_EXIT_INFO
    Contains the information passed between the request handler and the user exit program.
  • IDP_EXIT_SERVICE_FUNCS
    Contains the information passed between the request handler and the user exit program.
  • REQHAND_RESPONSE
    Contains the response to the client request.
  • REQUEST_CONTEXT
    Contains information about the client request.
Parent topic: User Exits


IDP_EXIT_INFO

Syntax:

typedef struct idp_exit_info
{
    cobuns32_t             version;         Version of structure format
    cobuns32_t             flags;           Reserved for future use
    cobuns32_t             data_size;       Size of data addressed by data_ptr
    cobuns32_t             ext_value_size;  Size of data addressed by ext_value
    cobuns32_t             reserved1[10];   Reserved for future use
    IDP_EXIT_SERVICE_FUNCS *funcs;          User exit support functions
    cobuns8_t              *field_name;     COBOL Linkage Section item’s name (COBOL DISPLAY encoded)
    void                   *data_ptr;       Internal data value associated with field_name
    cobuns8_t              *ext_param_name; External parameter name (COBOL DISPLAY encoded)
    cobuns8_t              *ext_value;      External data value associated with field_name (UTF-16 encoded)
    REQUEST_CONTEXT        *request_cxt;    Request context
    REQHAND_RESPONSE       *response;       Response details
    void                   *exit_data;      User exit-specific data
    void                   *reserved2[10];  Reserved for future use
}IDP_EXIT_INFO;
Parent topic: Structures


IDP_EXIT_SERVICE_FUNCS

Syntax:

typedef struct idp_exit_service_funcs
{
    cobuns32_t                    version;         Version of structure format
    cobuns32_t                    reserved;        Reserved for future use
    PFV_IDPES_FN_ALLOC_MEM        fn_alloc_mem;    Function to allocate memory
    PFV_IDPES_FN_FREE_MEM         fn_free_mem;     Function to free memory allocated by fn_alloc_mem
    PFI_IDPES_FN_DISPLAY_TO_UTF16 fn_disp_to_utf16 Function to convert from a COBOL DISPLAY encoded format to a UTF-16 encoded format
    PFI_IDPES_FN_UTF16_TO_DISPLAY fn_disp_to_utf16 Function to convert from a UTF-16 encoded format to a COBOL DISPLAY encoded format
    PFI                           fn_reserved[10]; Reserved for future use
} IDP_EXIT_SERVICE_FUNCS;
Parent topic: Structures


REQHAND_RESPONSE

Syntax:

typedef struct reqhand_response
{
    cobuns32_t version;       Version of structure format
    cobuns32_t response_len;  Length of response buffer
    cobuns32_t flags;         Control flags
    cobuns32_t response_type; Server response type
    void       *response_buf; Server response buffer
    void       *content_type; NULL terminated string (HTTP)
}REQHAND_RESPONSE;
Parent topic: Structures


REQUEST_CONTEXT

Syntax:

typedef struct request_context
{
    cobuns32_t            version;            Version of structure format
    cobuns32_t            handler_id;         ID of request handler being used to process the request
    cobuns32_t            request_len;        Length of request buffer
    cobuns32_t            argc;               Parameter count of loaded service
    cobrtncode_t          return_code;        Service’s return code, or run-time error error generated by service
    cobuns32_t            service_type;       Type of service request
    cobuns32_t            accept_buf_len;     Length of data in accept_buf
    cobuns32_t            display_buf_len;    Length of data in display_buf
    cobuns32_t            cmd_line_len;       Length of data in cmd_line
    cobuns32_t            flags;              Request context control flags
    cobuns32_t            reserved1[11];      Reserved for future use
    REQHAND_SERVICE_FUNCS *funcs;             Request handler support functions
    void                  *request_buf;       Request buffer
    void                  **protocol_attrs;   An array of pointers to protocol-specific attributes
    cobuns8_t             **argv;             Parameter list of loaded service
    void                  *handler_data;      Request handler-specific data
    cobuns8_t             *reserved1a;        Reserved for future use
    cobuns8_t             *service_name;      Name of loaded service
    cobuns8_t             *pgm_name;          Name of the main program associated with the service
    cobuns8_t             *epoint_name;       Name of entry point of the program to invoke
    void                  *idt;               Interface definition for service; the interpretation of the memory addressed by this field is request handler-specific
    cobuns8_t             *accept_buf;        Data to be used for ANSI ACCEPT statements
    cobuns8_t             *display_buf;       Concatenation of strings output by ANSI DISPLAY statements
    cobuns8_t             *cmd_line;          String to be used to resolve ACCEPT FROM COMMAND-LINE
    cobuns8_t             *rts_err_str;       Run-time error message text
    void                  *reserved2[9];      Reserved for future use
} REQUEST_CONTEXT;
Parent topic: Structures


Reference for MSS Deployment

  • CICS Commands
  • Data Conversion
  • CICS Resource Definitions
  • CICS Supplied Transactions
  • JCL Commands
  • JCL Environment Variables
  • TSO Support in Server Enterprise Edition
    Describes use of TSO commands in Server Enterprise Edition using the ISAEDT01 utility.
  • MSS Error Messages
Parent topic: Configuration and Administration
Parent topic: Mainframe Support for Deployed Applications


CICS Commands

  • caspcrd
    Creates resource definition and conversion table files, and populates them with default entries.
  • cascnvim
    Imports a file containing mainframe data conversion macros into the file dfhdrcnv.dat.
  • casfile
    Changes the information held about a file.
  • cassi (CICS version)
    Starts a service execution process. Use this version of the command if you have MSS CICS Support installed. You should use this command only when you want to debug a service, using one of the /a options.
  • casrdtex
    Exports CICS resources to a Resource Definition Table (.rdt file).
  • casrdtup
    Imports CICS resources from a resource definition table (.rdt file).
  • caspcupg
    Updates a resource definition file.
  • castran
    Retrieves or updates information on CICS transactions. Its primary use is to enable and disable transactions, but it can be used to alter other values such as the TWA size or timeout values, and to display the status of transactions. It can also perform a PHASEIN or NeWCOPY on CICS programs that are defined in the PPT.
Parent topic: Reference for MSS Deployment


caspcrd

Creates resource definition and conversion table files, and populates them with default entries.

Syntax:

caspcrd [/res-name][/c][/cc][/cb][/dp=resource-definition-path][/o]

Parameters:

/res-name | Name of the enterprise server. Defaults to ESDEMO
/c | Create a resource definition file
/cc | Create a conversion table file
/cb | Create a resource definition file and a table conversion file
/dp=resource-definition-path | The resource-definition-path specifies the path within which the files are created. Defaults to the current directory
/o | Overwrite existing files

Dependencies:

You must have started the enterprise server before you can issue a caspcrd command.

Comments:

On UNIX you can use a dash (-) instead of a forward slash (/).

If a path or filename contains spaces, it should be enclosed in quotation marks. For example, "e:\dev mto\files".

Parent topic: CICS Commands


cascnvim

Imports a file containing mainframe data conversion macros into the file dfhdrcnv.dat.

Syntax:

cascnvim /f{file-name}] [/op{path}] [/q] [/o]

Parameters:

/f{file-name} | Path and filename of the data conversion macros file
/op{path} | Path to the directory in which dfhdrcnv.dat is created
/q | Run in quiet mode; that is, the contents of the data conversion macros file are not displayed
/o | Overwrite existing entries

Dependencies:

The /op parameter sets the environment variable TXRDTP, which determines where dfhdrcnv.dat is created.

Comments:

If /op{path} or TXRDTP are not set, dfhdrcnv.dat is created in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\files\sys .

On UNIX you can use a dash (-) before a parameter as an alternative to a forward slash (/).

If a path or filename contains spaces, it should be enclosed in quotation marks. For example, "e:\dev mto\files" .

Parent topic: CICS Commands


casfile

Changes the information held about a file.

Syntax:

casfile [/res-name] [/mprototype:host:WebServiceport] [/fserver-name] [/dfile_DD-name]
[-e{e|u|d}][/iinputscript][/loutput-log]
[/o{o|c}][/pnew-dataset-path]][s{y|n|a}][/t{y|n}]{/w{w|r}]

Parameters:

/res-name
Name of the enterprise server to connect to. Defaults to ESDEMO
Note: When calling this utility from JCL or from a WEB service (that is, when you are running the utility within a SEP) you cannot use the /r option to connect to the server. Where this is the case, you must use the /m or /f options to connect to the server.
or:
/mprototype:host:WebServiceport
Location of the Web Services and J2EE listener for the enterprise server you want to connect to. For example, /mtcp:localhost:9003
or:
/fserver-name
Name of the enterprise server to connect to. This differs from the /r option, in that it performs a lookup to locate the Web Service for the enterprise server
/dfile_DD-name
Name of the file whose information you want to change. This is the eight-byte DD name, identical to the one held in the FCT for the file.
/e{e|u|d}
New file status:
e | Enable; default
u | Unenable
d | Disable
/iinputscript
Name of a file containing the parameters for the file named in file_DD-name or to multiple files.
/loutput-log
Name of file to contain the results of executing the command. The default is that the results are displayed on the enterprise server console.
/o{o|c}
New open status:
o Open; default
Note: This sets the status to open, but the file is not physically opened until it is first accessed.
c Closed
/pnew-dataset-path]
Name of a new path for the file
/s{y|n|a}
Output full file status.
y | On; default
n | Off
a | All files
/t{y|n}
Switch the File Handler trace on or off:
y | On; default
n | Off
/w{w|r}
New write status:
w | Read/write; default
r | Read-only
Note: Options /r, /m, /f are alternative ways of identifying the enterprise server that you want to connect to.

Dependencies:

You must have started the enterprise server before you can issue a casfile command.

Comments:

The /s and /f options are alternatives and are mutually exclusive.

On UNIX you can use a dash (-) instead of a forward slash (/).

If a path or filename contains spaces, it should be enclosed in quotation marks. For example,"e:\dev mto\files"

Parent topic: CICS Commands
Related information
Using Fileshare - More Features


cassi (CICS version)

Starts a service execution process. Use this version of the command if you have MSS CICS Support installed. You should use this command only when you want to debug a service, using one of the /a options.

Syntax:

cassi [/res-name]
      [/a]
      [/atterminal-id]
      [/axtransaction-id]

Parameters:

/res-name | Name of the enterprise server for which to start a service execution process. Defaults to ESDEMO
/a | Debug any application that runs in this service execution process
/atterminal-id | Debug any application that runs in response to a request from the terminal identified by terminal-id
/axtransaction-id | Debug any application that runs in response to a non-facility transaction identified by transaction-id

Dependencies:

To use this command:

  • You must have started the enterprise server named with the /r flag first.
  • You must be running under the same user ID as the enterprise server named with the /r flag. If the Directory Server was started as a system service, and the enterprise server was started using the Administration interface, then the enterprise server is probably running under the LOCAL_SYSTEM user ID, and this command will not work. For more information see the section Starting and Stopping the Directory Server in the chapter Introduction to Enterprise Server Administration in your Enterprise Server Configuration and Administration Guide.

Comments:

On UNIX you can use a dash (-) before a parameter as an alternative to a forward slash (/).

Parent topic: CICS Commands
Related information
Starting and Stopping the Directory Server


casrdtex

Exports CICS resources to a Resource Definition Table (.rdt file).

Syntax:

casrdtex /ofile-name [/a] [/e] [/ipresource-file-path] [/uuserid] [/ppassword] [/q] [/v]
 [/s[sit1[,sit2]...]] [/l[list1[list2]...]]
 [/n[snt1[,snt2]...]] [/g[grp1[,grp2]...]]
 [/m] [/x] [/f] [/t] [/y] [/d] [/j] [/i] [/z] [/c] [/b]

Parameters:

/ofile-name | The RDT file to export to. This parameter is mandatory.
/a | Append to an existing file
/e | Include non-IBM-compatible entries (Micro Focus extensions to the format, which all begin with an underscore)
/ipresource-file-path | The directory containing the CICS resource definition file, dfhdrdat, from which to export. This defaults to %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\files\sys .
/uuserid | User ID
/ppassword | Password
/q | Run in quiet mode
/v | Run in verbose mode
/s[sit1[,sit2]...] | Include the specified SITs in the export. If you specify just the switch, all are exported.
/l[list1[list2]...] | Include the specified startup lists (GRPLIST) in the export. If you specify just the switch, all are exported.
/n[snt1[,snt2]...] | Include the specified sign-on entries in the export. If you specify just the switch, all are exported.
/g[grp1[,grp2]...] | Include the specified groups in the export. If you specify just the switch, all are exported.

The remaining parameters select which table entries for the selected group(s) are to be included:

/m | Processing program table (PPT)
/x | Program control table (PCT)
/f | File control table (FCT)
/t | Terminal (TRM)
/y | Terminal type (TTY)
/d | TD queue (TDQ)
/i | Program list (PLT)
/j | Journal (JCT)
/z | Temporary storage (TST)
/c | Connection
/b | X/Open DB compatibility

Dependencies:

Run casrdtex from aNet Express command prompt to ensure that all of the necessary paths are available.

Comments:

If a path or filename contains spaces, it should be enclosed in quotation marks. For example, "e:\dev mto\files".

Example:

casrdtex /oresfile.rdt /ggroup1,group3 /m /x /ip"e:\dev mto\files"

The above command exports the PPT and PCT entries for the groups group1 and group3, from the dfhdrdat file in "e:\dev mto\files", to the file resfile.rdt.

casrdtex /oresfile.rdt /s /g /f /ip"e:\devmto\files"

The above command exports all SITs, and the FCT entries for all groups, to the file resfile.rdt.

Parent topic: CICS Commands


casrdtup

Imports CICS resources from a resource definition table (.rdt file).

Syntax:

casrdtup /ffile-name [/opresource-definition-path] [/rregion-name] [/uuserid]
[/ppassword] [/xext] [/q] [/o] [/d]

Parameters:

/ffile-name | The RDT file to import from. This parameter is mandatory.
/opresource-definition-path | The directory containing the resource definition file, dfhdrdat, into which resources are imported. This defaults to %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\files\sys .
/rregion-name | The name of the region into which the resources will be imported
/uuserid | User ID
/ppassword | Password
/xext | Default FCT file extension
/q | Quiet mode (no prompts)
/o | Overwrite existing entries. If this is not specified, any duplicate entry results in an error message.
/d | Discard MVS data set names

Dependencies:

To ensure that casrdtup is on your PATH, execute it from aNet Express command prompt.

Comments:

If a path or filename contains spaces, it should be enclosed in quotation marks. For example, "e:\dev mto\files".

This utility is designed to process mainframe generated resource definition records, which are not abbreviated. However, it will accept abbreviations for keywords and values, provided that the abbreviations are unique. For example, DSNA can be used in place of DSNAME, and BR can be used in place of BROWSE.

This utility expects values to be uppercase like those generated by the mainframe utility, DFHCSDUP. For example, "NONE" and "YES" rather than "None" and "Yes".

For more on the resource definitions that you can use with Enterprise Server MSS, see Resource Definitions.

Example:

casrdtup /fresfile.rdt /d /op"e:\devmto\files"

The above command imports the file resfile.rdt, discarding MVS data set names.

Parent topic: CICS Commands
Related information
Resource Definitions


caspcupg

Updates a resource definition file.

Syntax:

caspcupg [/res-name]
         [/dp=resource-defn-path]
         [/s(sit,fs-server-id)]
         [/f(group,fs-server-id)]
         [/o]
         [/uuserid]
         [/ppassword]
         [/sparameter]
         [/ssparameter]
         [/bpath]
         [/t=]
         [/td]
         [/z]
         [/x]

Parameters:

/res-name | Name of the enterprise server. Defaults to ESDEMO
/dp=resource-defn-path | Resource Definition Path.
/s(sit,fs-server-id) | Set FCT FSID in SIT and groups in startup list
or: |
/f(group, fs-server-id) | Set FCT FSID in group.
/o | Force upgrade of non-DFH-supplied resources.
/uuserid | User ID for updates
/ppassword | Password for updates
/sparameter | Set FCT start-open to parameter., which must be "Y" or "N"
/ssparameter | Set security on or off. parameter is + for on, or - for off
/bpath | Optional. Path to location to create backup file.
/t= | Set Termtype Device properties = Mapping properties
/td | Allow Termtype Device properties to differ from Mapping properties
/z | Reset blank PCT security keys to default value
/x | Quiet mode

Dependencies:

You must have started the enterprise server before you can issue a cascugp command.

Comments:

The /s and /f options are alternatives and are mutually exclusive.

On UNIX you can use a dash (-) before a parameter as an alternative to a forward slash (/).

If a path or filename contains spaces, it should be enclosed in quotation marks. For example, "e:\dev mto\files".

Parent topic: CICS Commands


castran

Retrieves or updates information on CICS transactions. Its primary use is to enable and disable transactions, but it can be used to alter other values such as the TWA size or timeout values, and to display the status of transactions. It can also perform a PHASEIN or NeWCOPY on CICS programs that are defined in the PPT.

The NEWCOPY option loads a new copy of the specified program only if it is not currently in use; otherwise, it will fail. The PHASEIN option loads a new copy even if the program is currently running. Where this is the case, the previously loaded copy remains until it is no longer in use. All requests that occur after the reload use the new copy.

Note: castran can also be invoked from within a JCL by writing a simple COBOL program to call it.

Syntax:

castran [/res-name] [/mprototype:host:WebServiceport] [/fserver-name]
    [/ttrans-id]
    [/e{e|d}]
    [/s{y|n|a}]
    [/g{y|n}]
    [/j{d|a}]
    [/d{y|n}]
    [/loutput-log]
    [/wTWA-size]
    [/qinput-timeout]
    [/xrunaway-timeout]
    [/ydeadlock-timeout]
    [/pprogram-name]
    [/nprogram-name]
    [/uuserid]
    [/apassword]
    [/cgroup]

Syntax to issue multiple commands from a command file:

castran [/res-name] [/mprototype:host:WebServiceport] [/fserver-name] /iinput-script-file

Parameters:

/res-name
Name of the enterprise server to connect to. Defaults to ESDEMO.
Note: When calling this utility from JCL or from a WEB service (that is, when you are running the utility within a SEP) you cannot use the /r option to connect to the server. Where this is the case, you must use the /m or /f options to connect to the server.
or:
/mprototype:host:WebServiceport
Location of the Web Services and J2EE listener for the enterprise server you want to connect to. For example, /mtcp:localhost:9003
or:
/fserver-name
Name of the enterprise server to connect to. This differs from the /r option, in that it performs a lookup to locate the Web Service for the enterprise server.
[-iinput-script-file]
The input script file which will contain a list of commands to run. Any comment line in the scriptfile must have # in column 1.
[-ttrans-id]
Four byte transaction ID.
[-e{e|d}]
Set the Enable status for the specified transaction:
Setting | Description
e or no value | Enable
d | Disable
[-s{y|n|a}]
Output the full transaction status for the specified transaction.
Setting | Description
y or no value | Display
n | Suppress
a | Display details for all transactions in PCT irrespective of the transaction id specified using the /t option
[-g{y|n}]
Set the Upper Case Translation status for the specified transaction.
Setting | Description
y or no value | UC Translation
n | No UC Translation
[-j{d|a}]
Set the Screen status for the specified transaction.
Setting | Description
d or no value | Default
a | Alternate
[-d{y|n}]
Set the Transaction Dump status of the specified transaction.
Setting | Description
y | Transaction Dump
n or no value | No Transaction Dump
[-loutput-log]
The file to which the output from the command is written. The default is to standard output.
[-wTWA-size]
Set the TWA Size {0..32767} for the specified transaction.
[-qinput-timeout]
Set the Input Timeout for the specified transaction.
Setting | Description
s or no value | System default
0..4080 | Timeout value in seconds
[-xrunaway-timeout]
Set the Runaway Timeout for the specified transaction.
Setting | Description
s or no value | System default
0..2700 | Timeout value in seconds
[-ydeadlock-timeout]
Set the Deadlock Timeout for the specified transaction.
Setting | Description
s or no value | System default
0..4080 | Timeout value in seconds
[-pprogram-name]
Issue a PHASEIN for the specified program. Please note: this is unrelated to any transaction id specified with the /t option.
[-nprogram-name]
Issue a NEWCOPY for the specified program. Please note: this is unrelated to any transaction id specified with the /t option.
[-uuserid]
Authorization User ID
[-apassword]
Authorization Password
[-cgroup]
Authorization Group (Optional)
Note: Options /r, /m, /f are alternative ways of identifying the enterprise server that you want to connect to.

Return Codes:

0 | Success
4 | Invalid flag/Duplicate flag(s)
12 | Transaction ID not found in PCT/Program not found in PPT/Incorrect user ID or password
15 | Region not running/invalid command

Dependencies:

You must have started the enterprise server before you can issue a castran command.

Comments:

Multiple usage of the same parameter type, results in only the first occurrence being use. All others will be ignored.

Exceeding the maximum value for TWA size or any of the timeout options, will result in the maximum value being set.

You can use a dash (-) instead of a forward slash (/) to indicate command options.

Script files must contain a transaction ID or program name on each line (except for comments), but cannot contain region names; that is, all commands in a file relate to one region, which is specified in the initial castran call. If a path or filename contains spaces, it should be enclosed in quotation marks. For example:

castran /rESDEMO /i"c:\input scripts\my script.txt"

In order to use castran with an Enterprise Server that has security enabled, you must ensure that all resource definitions are up to date. You can do this by issuing the following command:

caspcupg /r<server name> /dp=<dfhdrdat path>

Examples:

To disable a CICS transaction called ACCT and display its status on a region called ESDEMO:

castran /rESDEMO /tACCT /ed /sy

To alter the TWA size and turn off UC Translation for ACCT in a secure region:

castran /rESDEMO /uSYSAD /aSYSAD /w255 /gn /tACCT

To perform multiple operations by using an input script:

castran /rESDEMO /imultiple_cmds.txt

Where multiple_cmds.txt contains the following lines:

# multiple castran commands
/tACCT /ed
/tAC01 /ee /ja
/nACCT00
Parent topic: CICS Commands


Data Conversion

The following features of IBM's DFHCNV macros are supported:

Keyword | Support
DFHCNV TYPE=INITIAL |
CLINTCP=nnnn | Recognized
SRVERCP=nnnn | Recognized
CDEPAGE=nnnn | Recognized
DFHCNV TYPE=ENTRY |
RTYPE={FC|TS|TD|IC|PC} | Full
CLINTCP=nnnn | Recognized
SRVERCP=nnnn | Recognized
RNAME=resourcename | Full
XRNAME=xxxxxxxxxxxxxxxx | Full
USREXIT={YES|NO} | Recognized
CDEPAGE=nnnn | Recognized
DFHCNV TYPE=KEY |
TYPE=SELECT | Full
OPTION={COMPARE|DEFAULT} | Full
OFFSET=nnnn | Full
DATA='dd...dd' | Full
XDATA='xx...xx' | Full
DFHCNV TYPE=FIELD |
OFFSET=nnnn | Full
DATATYP={CHARACTER|PD|BINARY |NUMERIC} | Full
DATATYP={USERDATA|GRAPHIC} | Recognized
USRTYPE=xx | Recognized
DATALEN=n | Full
LAST=YES | Full
SOSI=YES|NO | Recognized
DFHCNV TYPE=FINAL | Full
DFHCNV TYPE={DSECT|IVP} | Recognized

The following terms are used to describe the level of support provided for keywords:

  • Full - Fully supports the function or operand
  • Recognized - Recognizes the function or operand but takes no action on it at run time
Parent topic: Reference for MSS Deployment


CICS Resource Definitions

In Mainframe Subsytem Support you can define a subset of the resource types that you can define in mainframe CICS. You can use the same definition mechanism as mainframe CICS: DEFINE statements followed by keywords that specify various attributes of the resource. The keywords differ depending on the resource being defined. DEFINE statements are held in resource definition table (.rdt) files, which constitute a staging post in the process of exchanging resource definitions with the mainframe CICS System Definition (CSD) file.

In mainframe CICS you can define many more types of resource than you can in Mainframe Subsytem Support, for example LSRPOOL and SESSIONS. Mainframe Subsytem Support does not support these resource types because they are meaningless on the target environment.

Mainframe Subsytem Support provides Micro Focus extensions for some resource types. These are extra keywords that define attributes specific to Mainframe Subsytem Support on the target environment.

In the following specifications of the resource type definitions, each keyword and its parameters is shown in a mixture of upper case and lower case. You need to specify at least the letters in upper case. For example, in the Connection definition, DE and DESCRIPTION are synonyms. However, we recommend that you specify keywords and parameters in full, as shown in the examples. Defaults are shown in bold.

Mainframe Subsytem Support also accepts DEFINE MAPSET and all its keywords, but it does not store these definitions as mapset definitions in the resource definition file. Instead it stores them as data tables (DEFINE PROGRAM with _MOduletype set to Data).

  • DEFINE CONNECTION
    Defines a remote system with which ES communicates via inter-region communication (IRC).
  • DEFINE FILE
    Defines the attributes and characteristics of a file used by Enterprise Server.
  • DEFINE PROGRAM
    Defines a program used to process transactions in Enterprise Server.
  • DEFINE TERMINAL
    Defines the characteristics of display devices and printers used by Enterprise Server.
  • DEFINE TRANSACTION
    Defines the attributes of a transaction.
  • DEFINE TDQUEUE
    Defines the attributes of a transient data queue.
  • DEFINE TYPETERM
    Defines the attributes for a set of terminals that have similar characteristics.
  • DEFINE _SIGNON
    Defines user IDs and their level of access security to Enterprise Server resources.
  • DEFINE _JOURNAL
    Defines the attributes of a journal used for recording system activity within Enterprise Server.
  • DEFINE _PGMLIST
    Defines a list of programs and the phase in which they are to run. The lists are used at post initialization and shut down.
  • DEFINE _SIT
    Defines a system initialization table that controls the execution of an Enterprise Server region.
  • DEFINE _STARTUPLIST
    Defines a list of resource groups to be installed at system initialization.
  • DEFINE _TEMPSTORAGE
    Defines the attributes of a temporary storage (TS) record set.
  • DEFINE _XOPENCOMPAT
    Defines the attributes of XA compatible resources (external resource managers).
Parent topic: Reference for MSS Deployment
Parent topic: Resource Definitions


DEFINE CONNECTION

Defines a remote system with which ES communicates via inter-region communication (IRC).
Keyword | Description
Connection(name) | Specifies the logical name of this connection. Mandatory. Must be unique across all connected systems. Can be up to four alphanumeric characters.
Group(groupname) | Names the group the connection definition belongs to. Mandatory. groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as Mainframe Subsystem Support (MSS) uses that prefix for system groups.
Description(text) | Describes the connection. Optional. text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.
Connection Properties |
Netname(name) | Specifies the network name that identifies the APPLID of the remote system or region. name can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Required in most circumstances.
PRotocol(Appc|Cci) | Identifies the connection method to be used for the connection: Appc: a remote connection over an LU6.2 link Cci: a remote connection through a CCI gateway Mandatory
Operational Properties |
INSERVICE(Yes|No) | Indicates whether or not this connection is in service; that is, whether transactions can be initiated and messages sent.
Security |
SEcurityname(name) | The security name of the remote system. Required only if the connection method is APPC. Can be up to eight alphanumeric characters from the set A through Z, 0 through 9, $, @ and #.
ATtachsec(Local|identify|Verify|Persistent|Mixedpe | The level of security required when a user attaches to this connection: Local: the authority of the user is taken to be that of the link Identify: Incoming attach requests must specify a user ID Verify: Incoming attach requests must specify both a user ID and a password Persistent: The first attach request must specify both a user ID and a password, but subsequent attach requests require only a user ID Mixedpe: Incoming attach requests may specify either Identify or Persistent
Micro Focus Extensions |
_OPERId(code) | Specifies an operator ID used for routing messages. Up to three alphanumeric characters. Optional.
_OPERPriority(number) | Specifies the operator priority for transactions initiated over this connection. Defaults to 0(zero). Operator priority is one factor in determining a transaction's execution priority, which is the sum of: Terminal priority Transaction priority Operator priority (this field) The sum cannot be greater than 255.
_Userid(name) | Specifies a user ID to be associated with the connection. Mandatory if no sign-on takes place on the connection.
_Natlang(E|K) | Specifies the national language in which messages are sent over the connection: E: English K: Kanji
_Sessionmax(number) | Specifies the maximum number of concurrent sessions for the connection. Defaults to 0(zero).
_Lualias(name) | Specifies the LU name by which the connection is known in the APPC configuration. Mandatory only where the connection method is APPC.
_Partneralias(name) | Specifies the name used by local transactions to refer to this partner LU. Mandatory only where the connection method is APPC.
_Aliasapplid(code) | Specifies the APPLID used by the APPC link. Mandatory only where the connection method is APPC.
_Modetable(name) | Specifies the name of the APPC transmission service profile that describes the APPC link between the local and partner LUs. Mandatory only where the connection method is APPC. It can be up to eight characters in length. The first character must be from the set A through Z and $. Subsequent characters can be from the set A through Z, 0 through 9 and $.
_CCIProtocol(CCIDDE|CCIIPX|CCINETB| CCINAMEP|CCITCPIP) | For connections where the connection method is CCI, specifies which CCI protocol is to be used: CCIDDE: Direct Data Exchange CCIIPX: Novell IPX CCINETB: NetBIOS CCITCPIP: TCP/IP Mandatory.
_CCIMachine(name) | Names the machine on which on which the CCITCP2 daemon is running. Required only where CCIProtocol is CCITCPIP.
_MFNode(name) | Names the machine on which the target region runs. This is its IP name or IP address. _MFNode and _MFPort together equate to the socket used by the TCP/IP server for the remote target region that this connection definition describes. These fields are mandatory only where CCIProtocol is CCITCPIP and when using a direct connection to the remote region with no CCITCP2 daemon present on the network.
_MFport(number) | Identifies the port number for _MFNode. _MFNode and _MFPort together equate to the socket used by the TCP/IP server for the remote target region that this connection definition describes. These fields are mandatory only where CCIProtocol is CCITCPIP and when using a direct connection to the remote region with no CCITCP2 daemon present on the network..
  • Examples
Parent topic: CICS Resource Definitions


Examples

DEFINE CONNECTION(L001) GROUP(SAMPGRP)
DESCRIPTION(Sample APPC connection)
       NETNAME(NET081) INSERVICE(YES) SECURITYNAME(SESS1)
       ATTACHSEC(LOCAL) PROTOCOL(APPC)

DEFINE CONNECTION(C002) GROUP(SAMPGRP)
DESCRIPTION(Sample CCI connection)
       INSERVICE(YES) ATTACHSEC(LOCAL) PROTOCOL(CCI) _OPERPRTY(0)
       _NATLANG(E) _SESSIONMAX(0) _CCIPROTOCOL(CCITCP)
       _CCIMACHINE(cvimtb09)

DEFINE CONNECTION(L001) GROUP(SAMPGRP)
DESCRIPTION(Sample APPC connection with MF extensions)
       NETNAME(NET081) INSERVICE(YES) SECURITYNAME(SESS1)
       ATTACHSEC(LOCAL) PROTOCOL(APPC) _OPERPRTY(0) _USERID(U555)
       _NATLANG(E) _SESSIONMAX(4) _LUALIAS(MTB9AFG)
       _PARTNRALIAS(ASL8KKK) _ALIASAPPLID(MPAPP)
Parent topic: DEFINE CONNECTION
Related information
Resource Definitions


DEFINE FILE

Defines the attributes and characteristics of a file used by Enterprise Server.
Keyword | Description
File(name) | Names the file. Mandatory. name can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #.
Group(groupname) | Names the group the file belongs to. Mandatory. groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as Mainframe Subsystem Support (MSS) uses that prefix for system groups.
Description(text) | Describes the file. Optional. text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.
VSAM
DSName(name) | Specifies the name of the physical file. This is a mainframe-style data set name of up to 44 characters.
Remote
REMOTESystem(name) Applicable only for remote files. Specifies the ID of the remote system that holds the file. This must correspond to either:
  • The Local SYSID field in the SIT used to run the related remote CICS region
  • The APPLID of another CICS system
REMOTEName(name) | Applicable only for remote files. Names the remote file. Necessary only if it differs from the local file name.
RECORDSize(number) | Applicable only for remote files. Specifies the maximum length in bytes of records in a remote file, in the range 1 through 32767.
Keylength(number) | Applicable only for remote files. Specifies the length in bytes of the key for a remote file, in the range 1 through 32767.
Initial Status
STAtus(Enabled|Disabled|Unenabled) Effective only for files owned by the local region. Specifies whether this file is accessible to transactions when the region is started.

Enabled: accessible at region startup

Disabled: not accessible at region startup

Unenabled: can be opened only by a SET FILE OPEN command. You cannot specify Unenabled for files of type Altindex

Opentime(Firstref|Startup) Indicates when the file is opened.

Firstref: the first time the file is referenced in the program being executed

Startup: when the region starts up

Note that this keyword controls only when the file is opened, not whether or not it is accessible; accessibility is controlled by the STAtus keyword.

Operations
Add(No|Yes) | Indicates whether users can add records to the file.
Browse(No|Yes) | Indicates whether users can browse the file.
DELete(No|Yes) | Indicates whether users can delete records from the file.
REAd(Yes|No | Indicates whether users can read records in the file.
Update(No|Yes) | Indicates whether users can update records in the file.
Recovery Parameters
RECOVery(None|Backoutonly|All) Specifies the recovery options for this file:

None: the file is not recoverable

Backoutonly; the file is a protected resource and changes can be backed out. You must also define the file as being held on a Fileshare server, as Fileshare is required for backward recovery.

All: the file is a protected resource and has both forward and backward recovery capability. For forward recovery journals are used to record changes to the file. You must also define the file as being held on a Fileshare server, as Fileshare is required for forward and backward recovery.

Security
RESsecnum(keys) | Specifies one or more indicators, each corresponding to one of the 24 resource keys for this file. A user has access to a particular resource only through a matching key as defined in his sign-on table entry. To toggle a key on you specify its number here. By default all keys are toggled off. You code the keys as a comma-separated list of individual numbers and ranges separated by hyphens. For example, to toggle the keys 1 to 5 and 10 on, code RESSECNUM(1-5,10).
Micro Focus Extensions
_MAxreclen(number) | Specifies the maximum logical record length of the file in bytes, in the range 1 through 32767. The value must be greater than or equal to the value of _Minreclen. Specify a value if _FILEType is one of the following: KSDS, RRDS, ESDS or the file is remote (you specified a value in Remotesystem(name)).
_MInreclen(number) | Specifies the minimum logical record length of the file in bytes , in the range 1 through 32767. The value must be less than or equal to the value of _Maxreclen. Specify a value if _FILEType is one of the following: KSDS, RRDS or ESDS.
_KEYPosition(number)

The key position is the offset, relative to zero, of the key from the beginning of the data record, in the range 0 through 32767. When set to 0, the key begins in the first position of the record. Specify a value if _FILEType is one of the following: KSDS or Altindex.

_KEYLength(number) Specifies the length of the record key in bytes, in the range 1 through 32767. The value of the following expression must not exceed the minimum record length:

key position + key length - 1

_FILEType(type) Specifies what type of file this is:

KSDS: key sequenced data set

ESDS; entry sequence data set

RRDS: relative record data set

Altindex: Alternate index for a KSDS file.

May be omitted if the file is defined as remote (you specified a value in Remotesystem(name)).

_Basefile(fileid) | For a file of type Altindex, specifies the base data file for which this is an alternate index. fileid must correspond to the file name of another file definition of type KSDS.
_Startempty(No|Yes) Indicates whether the current contents of the file are deleted when the region starts up:

No: the file contents are not deleted

Yes: the file contents are deleted

_Dupkey(No|Yes) | For an alternate index, indicates whether duplicate keys are allowed
_Path(string) | Specifies the path of the physical file if you want to override the default path. Do not include the filename or the file extension. Mandatory if the file is held on a Fileshare server, in which case _FILEShareid must be present too.
_FILEShareid(name) | Specifies the Fileshare server on which the file resides. name can be up to 16 characters in length.
_FILEFormat(Microfocus|IDXFMT4|IDXFMT8|IDXFMT9) | Specifies the format for files that are to be created by Mainframe Transaction Option. We recommend that you use the default, IDXFMT8.
_FILEName(name) | Specifies the name of the physical PC file if you want to override the default filename, which is the name given by File(name). Do not include the file extension.
_FILEExt(value) | Specifies the file extension of the physical file if you want to override the default, which is .dat
_Collseq(Ebcdic|Ascii) | Specifies the collating sequence used in the file.
  • Example
Parent topic: CICS Resource Definitions


Example

DEFINE FILE(SAMPLEA) GROUP(SAMPGRP)
DESCRIPTION(Sample KSDS FCT entry)
       STATUS(ENABLED) OPENTIME(STARTUP) RECORDFORMAT(F) ADD(YES)
       BROWSE(YES) DELETE(YES) READ(YES) UPDATE(YES)
       RECOVERY(BACKOUTONLY) _FILETYPE(KSDS) _MAXRECLEN(200)
       _MINRECLEN(200) _KEYPOSITION(1) _KEYLENGTH(6) _STARTEMPTY(YES)
       _DUPKEY(NO) _FILEEXT(DAT) _FILEFORMAT(MICROFOCUS)
DEFINE FILE(SAMPLEA1) GROUP(SAMPGRP)
DESCRIPTION(Index for SAMPLEA)
       STATUS(ENABLED) OPENTIME(FIRSTREF) RECORDFORMAT(F) ADD(YES)
       BROWSE(YES) DELETE(YES) READ(YES) UPDATE(YES)
       RECOVERY(BACKOUTONLY) _FILETYPE(ALTINDEX) _BASEFILE(SAMPLEA)
       _KEYPOSITION(8) _KEYLENGTH(4) _STARTEMPTY(NO) _DUPKEY(NO)
       _FILEEXT(DAT) _FILEFORMAT(MICROFOCUS)
DEFINE FILE(SAMPLEB) GROUP(SAMPGRP)
DESCRIPTION(Sample RRDS entry)
       STATUS(ENABLED) OPENTIME(FIRSTREF) RECORDFORMAT(F) ADD(YES)
       BROWSE(YES) DELETE(YES) READ(YES) UPDATE(YES)
       RECOVERY(BACKOUTONLY) _FILETYPE(RRDS) _MAXRECLEN(500)
       _MINRECLEN(500) _STARTEMPTY(NO) _DUPKEY(NO) _PATH(x:\cics\fshr)
       _FILESHAREID(FSHRCIC2) _FILEEXT(DAT) _FILEFORMAT(MICROFOCUS)
       RESSECNUM(01-08,17-22,24)
DEFINE FILE(SAMPLEC) GROUP(SAMPGRP)
DESCRIPTION(Example of an ESDS)
       STATUS(ENABLED) OPENTIME(FIRSTREF) RECORDFORMAT(F) ADD(YES)
       BROWSE(YES) DELETE(NO) READ(YES) UPDATE(NO)
       RECOVERY(BACKOUTONLY) _FILETYPE(ESDS) _MAXRECLEN(1000)
       _MINRECLEN(120) _STARTEMPTY(NO) _DUPKEY(NO) _FILEEXT(DAT)
       _FILEFORMAT(MICROFOCUS) _FILENAME(TESTC) _USECATALOG(NO)
Parent topic: DEFINE FILE


DEFINE PROGRAM

Defines a program used to process transactions in Enterprise Server.
Keyword | Description
PROGram(name) | Names the program. Mandatory. name can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a program name starting with DFH, as Mainframe Subsystem Support (MSS) uses that prefix for system programs.
Group(groupname) | Names the group the program belongs to. Mandatory. groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as MSS uses that prefix for system groups.
DEscription(text) | Describes the program. Optional. text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.
Language(Cobol|Assembler|Pli) | Specifies the programming language that the program is written in.
RESident(No|Yes) Specifies whether the program is permanently resident in memory:

No: The program is removed from memory when the tasks using it have completed

Yes: The program remains in memory throughout the session

Status(Enabled|Disabled) Specifies whether the program is accessible when the region starts up:

Enabled: the program is accessible when the region starts up.

Disabled: The program cannot be used until it is specifically enabled using the transaction CPMT.

RSl(keys) | (RSl stands for Resource Security Level.) Specifies one or more indicators, each corresponding to one of the 24 resource keys for this program. A user has access to a particular resource only through a matching key as defined in his sign-on table entry. To toggle a key on you specify its number here. By default all keys are toggled off. You code the keys as a comma-separated list of individual numbers and ranges separated by hyphens. For example, to toggle the keys 1 to 5 and 10 on, code RSl(1-5,10).
Remote Attributes
REMOTESystem(name) Applicable only for remote programs. Specifies the ID of the remote system that holds the file. This must correspond to either:
  • The Local SYSID field in the SIT used to run the related remote CICS region
  • The APPLID of another CICS system
REMOTEName(name) | Applicable only for remote programs. Names the remote file. Necessary only if it differs from the local program name.
Transid(name) | Applicable only for remote programs. Specifies the name of the transaction that the remote system is to attach and under which it is to run the remote program. If not specified, the remote system executes the program under one of the supplied mirror transactions CSMI and CVMI. If supplied, name must be up to four characters in length
Micro Focus Extensions
_MOduletype(Program|Data) Specifies whether the resource being defined is an executable program or a data table:

Program: Resource is an executable program

Data: Resource is a data table. It can be loaded via an EXEC CICS LOAD PROGRAM command. Any attempt to use EXEC PROGRAM LINK or EXEC PROGRAM XCTL will fail with a PGMIDERR condition

_Wssavestate(No|Yes) | Specifies whether or not a program's working storage should be saved in its initial state so that it can be restored if the same program is called again at a lower level
_MAxcommarea(size) | Specifies the amount of storage to be allocated to the communications area (COMMAREA) to allow CICS Option to behave like mainframe CICS. The size is in the range 0 through 32767. The effect of this is that when a program is passed a COMMAREA smaller than the COMMAREA defined in the program, the passed COMMAREA is automatically extended in length to fill the defined space. This overrides the COMMAREA override value held in the SIT.
  • Example
Parent topic: CICS Resource Definitions


Example

DEFINE PROGRAM(TEST001) GROUP(TESTGRP)
LANGUAGE(COBOL) RESIDENT(NO) STATUS(ENABLED)
RSL(01,03,06,08-14,16,19-21)
DEFINE PROGRAM(TEST002) GROUP(TESTGRP)
DESCRIPTION(Sample PPT program)
LANGUAGE(ASSEMBLER) RESIDENT(NO) STATUS(DISABLED)
DEFINE PROGRAM(SAMP001) GROUP(SAMPGRP)
DESCRIPTION(Sample PPT with MF extensions)
LANGUAGE(COBOL) RESIDENT(NO) STATUS(ENABLED)
_MODULETYPE(PROGRAM) _WSSAVESTATE(NO) _MAXCOMMAREA(0)
DEFINE PROGRAM(DATA001) GROUP(SAMPGRP)
DESCRIPTION(Sample PPT for data table)
LANGUAGE(ASSEMBLER) RESIDENT(NO) STATUS(ENABLED)
_MODULETYPE(DATA) _WSSAVESTATE(NO) _MAXCOMMAREA(0)
Parent topic: DEFINE PROGRAM
Related information
Resource Definitions


DEFINE TERMINAL

Defines the characteristics of display devices and printers used by Enterprise Server.
Keyword | Description
TErminal(name) | Specifies the logical name of this terminal. Mandatory. Must be unique across all connected systems. Up to four alphanumeric characters.
Group(groupname) | Names the group the terminal definition belongs to. Mandatory. groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as Mainframe Subsystem Support (MSS) uses that prefix for system groups.
Description(text) | Describes the terminal. Optional. text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.
AUTINSTModel(No|Yes|Only) Specifies whether or not this terminal definition can be used as a model terminal definition for autoinstall:

Yes: can be used as a model for autoinstall, as well as for a specific device that is not autoinstalled

No: can be used only for a specific device that is not autoinstalled

Only: can be used only as a model for autoinstall

AUTINSTName(name) | Applicable only if AUTINSTModel is Yes or Only. Specifies the name by which the definition is known to the Autoinstall Control Program. name can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Defaults to the value given by Terminal(name).
Terminal Identifiers
Typeterm(name) | Names the associated Typerterm definition, which must exist. Mandatory.
Netname(name) | Identifies the terminal to the network. Mandatory if AUTOINSTModel is Yes or No. name can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. The first character must be a letter.
REMOTESYSTem(name) Applicable only for remote terminals. Specifies the ID of the remote system that holds the terminal definition. This must correspond to either:
  • The Local SYSID field in the SIT used to run the related remote CICS region
  • The APPLID of another CICS system
REMOTEName(name) | Applicable only for remote terminals. Names the remote terminal. Necessary only if it differs from the local terminal name.
Associated Printers
PRINTER(name) | Identifies the printer used for handling print requests. This printer must be owned by the system that owns the terminal. name can be up to four characters in length.
PRINTERCopy(No|Yes) | Indicates whether or not the hardware copy feature (using the printer defined for this terminal) is used for print requests issued from this terminal.
ALTPRINTEr(name) | Identifies the printer used for handling print requests if the printer specified in PRINTER(name) is unavailable. This printer must be owned by the system that owns the terminal. name can be up to four characters in length.
ALTPRINTCopy(No|Yes) | Indicates whether or not the hardware copy feature (using the alternate printer defined for this terminal) is used for print requests issued from this terminal.
Operator Defaults
OPERId(code) | Specifies an operator ID used for routing messages. Specify this for a terminal that cannot be signed on, such as a printer. If you specify an operator ID for a terminal that can be signed on, it is overridden by the operator ID specified in the user's sign-on table entry. Up to three alphanumeric characters.
OPERPriority(number) Specifies the operator priority for transactions run from this terminal. Specify this for a terminal that cannot be signed on, such as a printer. If you specify it for a terminal that can be signed on, it is overridden by the operator priority specified in the user's sign-on table entry. Defaults to 0(zero). Operator priority is one factor in determining a transaction's execution priority, which is the sum of:

Terminal priority

Transaction priority

Operator priority (this field)

The sum cannot be greater than 255.

Preset Security
Userid(name) | Specifies a user ID to be associated with the terminal. Mandatory if no sign-on takes place on the connection.
Natlang(E|K) Specifies the national language in which messages are sent over the connection:

E: English

K: Kanji

Terminal Usages
Transaction(name) | Names the only transaction that users can run from this terminal, apart form print and paging requests. Optional. If not specified, users can run any transaction from this terminal.
Termpriority(number) Specifies the priority for transactions run from this terminal. Defaults to 0(zero). Terminal priority is one factor in determining a transaction's execution priority, which is the sum of:

Terminal priority (this field)

Transaction priority

Operator priority

The sum cannot be greater than 255.

Inservice(Yes|No) | Indicates whether or not this terminal is in service; that is, whether transactions can be initiated and messages sent.
Session Security
Securityname(name) | The security name of the terminal. Required only if the terminal is owned by a remote system and the connection method is APPC. Can be up to eight alphanumeric characters from the set A through Z, 0 through 9, $, @ and #.
ATtachsec(Local|Identify|Verify|Persistent|Mixedpe) The level of security required when a user issues an attach request from this terminal:

Local: the authority of the user is taken to be that of the link

Identify: Incoming attach requests must specify a user ID

Verify: Incoming attach requests must specify both a user ID and a password

Persistent: The first attach request must specify both a user ID and a password, but subsequent attach requests require only a user ID

Mixedpe: Incoming attach requests may specify either Identify or Persistent

  • Example
Parent topic: CICS Resource Definitions


Example

DEFINE TERMINAL(T001) GROUP(SAMPGRP)
DESCRIPTION(Sample terminal definition)
       AUTINSTMODEL(NO) TYPETERM(3270) NETNAME(NET0001) PRINTER(PRN2)
       PRINTERCOPY(YES) ALTPRINTER(PRN3) ALTPRINTCOPY(YES)
       OPERPRIORITY(0) USERID(P901) NATLANG(E) TERMPRIORITY(68)
       INSERVICE(YES) ATTACHSEC(LOCAL)
Parent topic: DEFINE TERMINAL
Related information
Resource Definitions


DEFINE TRANSACTION

Defines the attributes of a transaction.

General

Keyword (default values in bold) | Description
TRANSaction(name) | Names the transaction. Mandatory. name can be up to four alphanumeric characters in length. Do not specify a transaction name starting with C, as Mainframe Subsystem Support uses that prefix for system transactions.
Group(groupname) | Names the group the transaction definition belongs to. Mandatory. groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as Mainframe Subsystem Support uses that prefix for system groups
DEscription(text) | Describes the file. Optional. text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.
PROGram(name) | Program driven by this transaction.
TWasize(number) | Size of transaction work area, between 0 and 32767.
STAtus(Enabled|Disabled) Indicates whether or not the transaction is accessible when the region is started:
Enabled
The transaction is accessible when the region starts up
Disabled
The transaction cannot be used until it is specifically enabled using the transaction CPMT.

Remote Attributes

Keyword (default values in bold) | Description
DYnamic(No|Yes) Indicates whether or not the transaction can be dynamically routed to a remote region:
Yes
The transaction can be dynamically routed to a remote region
No
Creates a remote definition if REMOTESystem(name) is present; creates a local definition if it is not
REMOTESystem(name) Applicable only for remote transactions. Specifies the ID of the remote system that runs the transaction. This must correspond to either:
  • The Local SYSID field in the SIT used to run the related remote Mainframe Subsystem Support region
  • The APPLID of another CICS system
REMOTEName(name) | Applicable only for remote transactions. Names the remote transaction. Necessary only if it differs from the local transaction name.

Scheduling

Keyword | Description
PRIOrity(number) | Specifies the priority for this transaction. Defaults to 0(zero). Transaction priority is one factor in determining a transaction's execution priority, which is the sum of: Terminal priority Transaction priority (this field) Operator priority The sum cannot be greater than 255.

Recovery

Keyword (default values in bold) | Description
DTimout(No|0|mmss) Specifies the deadlock timeout, that is, the period after which the transaction is terminated if it has been suspended.
NO
No deadlock timeout
0
Use system (SIT) deadlock timeout value
mmss
mm is the number of minutes and ss is the number of seconds. The maximum value is 68 minutes.
DUmp(No|Yes) | Indicates whether or not Mainframe Subsystem Support produces a program dump if this transaction abends.
Runaway(SYSTEM|0|milliseconds) The time to allow a task to control the processor before it is assumed to be looping and therefore purged.
SYSTEM
Use system (SIT) value
0
No deadlock timeout
milliseconds
On this system, must be a value between 1000 and 2700000. Note that the mainframe allows 500 milliseconds.
TRACe(Yes|No|Special) Indicates tracing options for this transaction:
Yes
The transaction is traced
No
The transaction is not traced
Special
Not currently supported

Indoubt Attribute

Keyword (default value in bold) Description
INdoubt(Backout|Commit|Wait) Indicates the action to be taken if this transaction abends during syncpoint or abend processing:
Backout
The effects of the transaction are backed out using SYNCPOINT ROLLBACK (For this to work, you must also set backwards recovery on for any file used by the transaction.)
Commit
Any changes are committed
Wait
Critical resources are locked until the session has recovered and are then backed out or committed in step with the remote system

Security

Keyword (default values in bold) | Description
CMDSEC(No|Yes) | Indicates whether or not security checking is enabled for CICS command operations.
RESSec(No|Yes) | Indicates whether or not the transaction program performs resource security checking by comparing a user's resource keys (defined in the user's entry in the sign-on-table) with the keys enabled for a particular resource.
TRANSec(keys) Specifies one or more indicators, each corresponding to one of the 64 security keys for this transaction.

A user has access to a particular transaction only through a matching key as defined in his sign-on table entry. To toggle a key on you specify its number here. By default all keys are toggled off.

You code the keys as a comma-separated list of individual numbers and ranges separated by hyphens. For example, to toggle the keys 1 to 5 and 10 on, code TRANsec(1-5,10).

RSL(keys) (RSL stands for Resource Security Level.) Specifies one or more indicators, each corresponding to one of the 24 resource keys for this transaction.

A user has access to a particular resource only through a matching key as defined in his sign-on table entry. To toggle a key on you specify its number here. By default all keys are toggled off.

You code the keys as a comma-separated list of individual numbers and ranges separated by hyphens. For example, to toggle the keys 1 to 5 and 10 on, code RSl(1-5,10).

Micro Focus Extensions

Keyword (default values in bold) | Description
_CATEGORY(No|0|3) | A value of “3” specifies an IBM Category 3 Transaction. These transactions have no security checking. Therefore, transactions in this category are allowed for all users, and no authorization calls are made. An example of this type of transaction is CESN.
_Inboundtp(No|Yes) | Indicates whether or not registry entries to allow inbound transactions are created.
_Screen(Default|Alternate) | Indicates the screen size is used by the transaction. Both sizes are defined in the Typeterm definition for the terminal in use at the time.
_Uctran(Yes|No) | Indicates whether or not any data received by the transaction is automatically folded to upper case
_Timethold(SYSTEM|0|seconds) The time to wait for a transaction to complete before triggering a monitoring event.
SYSTEM
Use system (SIT) value.
0
No monitoring event.
seconds
Maximum time is 65333 seconds.
_Rtimeout(SYSTEM|0|seconds) The time to wait for input, after which the terminal will automatically sign off the user.
SYSTEM
Use system (SIT) value.
0
No timeout.
seconds
Maximum time is 4080 seconds.
  • Example
Parent topic: CICS Resource Definitions


Example

DEFINE TRANSACTION(TRNX) GROUP(SAMPGRP)
DESCRIPTION(Sample PCT entry)
       PROGRAM(ABP0001A) TWASIZE(1024) STATUS(ENABLED) DYNAMIC(YES)
       PRIORITY(100) DTIMOUT(NO) INDOUBT(COMMIT) DUMP(YES) TRACE(YES)
       RESSEC(NO) TRANSEC(01,09-10,15-20,25,30,53-59)
       RSL(02,07-10,15,24)

DEFINE TRANSACTION(TRNX) GROUP(SAMPGRP)
DESCRIPTION(Sample PCT entry)
       PROGRAM(ABP0001A) TWASIZE(1024) STATUS(ENABLED) DYNAMIC(YES)
       PRIORITY(100) DTIMOUT(NO) INDOUBT(COMMIT) DUMP(YES) TRACE(YES)
       RESSEC(NO) TRANSEC(01,09-10,15-20,25,30,53-59)
       RSL(02,07-10,15,24) _SCREEN(DEFAULT) _UCTRAN(YES) _INBOUNDTP(NO)
Parent topic: DEFINE TRANSACTION
Related information
Resource Definitions


DEFINE TDQUEUE

Defines the attributes of a transient data queue.
Keyword | Description
TDqueue(name) | Names this queue. Mandatory. name can be up to four alphanumeric characters, the first of which must be aletter other than C.
Group(groupname) | Names the group the queue belongs to. Mandatory. groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as Mainframe Subsystem Support (MSS) uses that prefix for system groups.
DESCription(text) | Describes the transient data queue. Optional. text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.
TYPE(INTra | Extra | INDirect | INTRDR) Specifies the type of this queue:

Intra: The contents of the queue are accessible only to transactions and are temporary

Extra: The contents of the queue are made available to non-CICS programs, or data is made available from non-CICS programs

INDirect: An alias that points to another queue, which may be of any type

INTRDR: Specifies the internal reader to which CICS applications can direct a JCL job stream for execution by the JCL engine.

Intrapartition Queue Parameters
Atifacility(Terminal|blank)) (Intrapartition queues). Indicates the type of destination the queue represents:

Terminal: the transient data queue is associated with a terminal, which is specified in Facilityid(name).

RECOVstatus(No|Physical|Logical) | (Intrapartition queues). Indicates whether or not the queue is recoverable. If you specify that the queue is recoverable (physical and logical are synonymous), you must also specify _FILESHAREID. This is because MSS recovery is handled by Fileshare.
Facilityid(name) | (Intrapartition queues). Specifies the terminal ID if Atifacility is set to Terminal. If unspecified defaults to the queue name. A terminal definition must exist.
TRAnsid(name) | (Intrapartition queues). Specifies the name of the transaction to be run when the queue reaches the level specified in Triggerlevel(number)
TRIggerlevel(number) | (Intrapartition queues). Specifies the number of data records to be accumulated in the queue before the transaction specified in Transid(name) is run. A value of 0 means that the transaction is never run.
Extrapartition Queue Parameters
DSName(name) | (Extrapartition queues). Not used..
Opentime(Initial|Deferred) (Extrapartition queues). Indicates the initial status of the queue:

Initial: the queue is opened when the region starts up

Deferred: the queue is closed until it is required

TypeFile(Output|Input|Rdback) | (Extrapartition queues). Specifies whether the queue is for input, output, or may be read backwards.
RECORDSize(number) | (Extrapartition queues). Specifies the maximum length of records in this queue, in the range 0 through 32767
RECORDFormat(Fixed|Variable) (Extrapartition queues). Specifies the record format:

Fixed: the minimum record size is set to the same value as the maximum record size

Variable: the minimum record size is set to 1

Printcontrol(Asa|Machine) | (Extrapartition queues). Specifies the type of print control characters to be used. Optional.
Indirect Parameters
Indirectname(name) | Specifies the name of another transient data queue, which must be defined
Remote Parameters
REMOTEName(name) | Applicable only for remote transient data queues. Names the remote queue. Necessary only if it differs from the local file name. The queue must be defined on the remote system.
REMOTESystem(name) | Applicable only for remote transient data queues. Specifies the ID of the remote system that holds the file. This must correspond to the Local SYSID field in the SIT used to run the related remote region.
Micro Focus Extensions
_Status(Enabled|Disabled) Effective only for queues owned by the local region. Specifies whether this queue is accessible when the region is started.

Enabled: accessible when the region starts up

Disabled: not accessible when the region starts up

_Minrecsize(number) | (Extrapartition queues). Specifies the minimum length of records in this queue. Must be less than or equal to RECORDSize. If this is not specified, MSS deduces it from RECORDFormat.
_FILEShareid(name) | Specifies the Fileshare server on which this queue resides
_PCfiletype(Normal|Lineseq) | Indicates the type of PC file to be created to hold the queue. Choose Lineseq if you want to edit the file.
_FILEName(name) | (Extrapartition queues). Specifies the name of the file that holds this queue. Do not include the file extension. Defaults to dfhxdddd.tdq where dddd is the four-character name of the queue as specified in Tdqueue(name).
_PAth(path) | (Extrapartition queues). Specifies the path of the file that holds the queue if you want to override the default.
_FILEExt(extension) | Specifies the extension of the file that that holds the queue if you want to override the default, which is .tdq
_Rsl(keys) | Specifies one or more indicators, each corresponding to one of the 24 resource keys for this queue. A user has access to a particular resource only through a matching key as defined in his sign-on table entry. To toggle a key on you specify its number here. By default all keys are toggled off. You code the keys as a comma-separated list of individual numbers and ranges separated by hyphens. For example, to toggle the keys 1 to 5 and 10 on, code Rsl(1-5,10).
  • Examples
Parent topic: CICS Resource Definitions


Examples

DEFINE TDQUEUE(A042) GROUP(SAMPGRP)
DESCRIPTION(Sample extrapartition DCT)
       TYPE(EXTRA) DDNAME(A042) OPENTIME(INITIAL) TYPEFILE(OUTPUT)
       RECORDFORMAT(VARIABLE) RECORDSIZE(500) BLOCKFORMAT(UNBLOCKED)
       REMOTENAME(P908) REMOTESYSTEM(SYSB)
DEFINE TDQUEUE(D010) GROUP(SAMPGRP)
DESCRIPTION(Sample intrapartition DCT)
       TYPE(INTRA) RECOVSTATUS(NO) TRANSID(TTAB) TRIGGERLEVEL(25)
DEFINE TDQUEUE(K022) GROUP(SAMPGRP)
DESCRIPTION(Sample extrapartition DCT)
       TYPE(EXTRA) DDNAME(K022) OPENTIME(INITIAL) TYPEFILE(OUTPUT)
       RECORDFORMAT(FIXED) RECORDSIZE(100) BLOCKFORMAT(UNBLOCKED)
DEFINE TDQUEUE(S030) GROUP(SAMPGRP)
DESCRIPTION(Sample indirect Q)
       TYPE(INDIRECT) INDIRECTNAME(D025)

DEFINE TDQUEUE(A042) GROUP(SAMPGRP)
DESCRIPTION(Sample extrapartition DCT with MF extensions)
       TYPE(EXTRA) DDNAME(A042) OPENTIME(INITIAL) TYPEFILE(OUTPUT)
       RECORDFORMAT(VARIABLE) RECORDSIZE(500) BLOCKFORMAT(UNBLOCKED)
       REMOTENAME(P908) REMOTESYSTEM(SYSB) _STATUS(ENABLED)
       _MINRECSIZE(26) _FILESHAREID(CICFSHRA) _PCFILETYPE(NORMAL)
       _FILENAME(ac116bx) _PATH(x:\frp\cicsa\) _FILEEXT(dct)
       _RSL(01,03,05,09-15)
DEFINE TDQUEUE(D010) GROUP(SAMPGRP)
DESCRIPTION(Sample intrapartition DCT with MF extensions)
       TYPE(INTRA) RECOVSTATUS(NO) TRANSID(TTAB) TRIGGERLEVEL(25)
       _STATUS(ENABLED)
DEFINE TDQUEUE(S030) GROUP(SAMPGRP)
DESCRIPTION(Sample indirect Q with MF extensions)
       TYPE(INDIRECT) INDIRECTNAME(D025) _STATUS(ENABLED)
Parent topic: DEFINE TDQUEUE
Related information
Resource Definitions


DEFINE TYPETERM

Defines the attributes for a set of terminals that have similar characteristics.
Keyword | Description
TYpeterm(name) | Names this terminal type. Mandatory. name can be up to four alphanumeric characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #.
Group(groupname) | Names the group the terminal type definition belongs to. Mandatory. groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as Mainframe Subsystem Support (MSS) uses that prefix for system groups.
DEScription(text) | Describes the terminal type. Optional. text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.
Resource Type
DEVice(3270|3270P) Specifies the device type:

3270: display

3270P: printer

SHippable(No|Yes) Indicates whether or not this definition can be shipped to a remote system if a device of this type attempts to initiate a remote transaction.

Yes: the terminal definition can be shipped. It is not necessary for the terminal definition to be installed on the remote system.

No: the terminal definition cannot be shipped. You must ensure that the terminal definition is installed on the remote system.

Mapping Properties
PAGesize(rows,columns) | Specifies the page size for the terminal type being defined. Page size is defined as rows, in the range 0 through 999, and columns, in the range 0 through 999. The default is 24 by 80.
ALTPage(rows,columns) | Specifies the page size for the terminal type being defined, if you have specified an alternate screen size (none-default values for ALTSCreen). Alternate page size is defined as rows, in the range 0 through 999, and columns, in the range 0 through 999. The default is 24 by 80. Unexpected results may occur if the number of columns is not the same as the number of columns you specify for alternate screen size. Defaults to the values specified in PAGesize
OBOperid(No|Yes) | Indicates whether or not MSS uses the outbound operator identifiers to support the BMS routing facilities required by this terminal type definition.
Device Properties
DEFscreen(rows,columns) | Specifies the default screen size for the 3270 terminal type being defined. This is the screen size that is used when a transaction definition specifies a default screen. Screen size is defined as rows, in the range 0 through 999, and columns, in the range 0 through 999. The default is 24 by 80. There is no validity checking; incorrect sizes may lead to unpredictable behavior.
ALTSCReen(rows,columns) | Specifies the alternate screen size for the 3270 terminal type being defined. This is the screen size that is used when a transaction definition specifies an alternate screen. Screen size is defined as rows, in the range 0 through 999, and columns, in the range 0 through 999. The default is 24 by 80. There is no validity checking; incorrect sizes may lead to unpredictable behavior.
APLKybd(No|Yes) | Indicates whether or not the terminal type has the APL keyboard feature
AUDiblealarm(No|Yes) | Indicates whether or not the terminal type has the audible alarm feature
COLor(Yes|No) | Indicates whether or not the terminal type has the color feature, allowing colors to be selected for individual fields
COPy(No|Yes) | Indicates whether or not the terminal type has the copy feature
DUalcasekybd(No|Yes) Indicates which type of keyboard the terminal type has:

Yes: the terminal has a typewriter keyboard

No: the terminal has an operator console keyboard

Both types of keyboard transmit both upper-case and lower-case data.

EXtendedds(Yes|No) Indicates whether or not the terminal type supports extensions to the 3270 data stream:

Yes: extensions are supported. You must specify Yes if you also specify yes for Color or Hilight.

No: extensions are not supported.

HIlight(Yes|No) | Indicates whether or not the terminal type has the extended highlight feature, allowing individual fields or characters to be displayed in bold, reverse video, or blinking
Katakana(No|Yes) | Indicates whether or not the this terminal type is a Katakana terminal type. Katakana terminals do not support mixed case output. Upper-case characters appear as upper-case English, but lower-case characters appear as Katakana characters.
Lightpen(No|Yes) | Indicates whether or not the terminal type has the light pen selector feature. MSS emulates this feature using mouse clicks.
PRIntadapter(Yes|No) | Indicates whether or not output BMS screens with the PRINT option set on are to be copied automatically to an attached printer.
PROgsymbols(No|Yes) | Indicates whether or not the terminal type supports the programmed symbol facility. This facility allows you to use a maximum of six sets of 191 characters.
OUtline(No|Yes) | Indicates whether or not the terminal type supports field outlining
SOsi(No|Yes) | Indicates whether or not the terminal type supports mixed EBCDIC and DBCS fields
CGcsgid(num1,num2) | Specifies the coded graphic character set global identifier (CGCSGID) that enables transaction programs to determine what character set is supported by this terminal. Defaults to 0,0, which means that the terminal type does not support this feature. num1 is the graphic character set global identifier (GCSGID) and num2 is the code page global identifier (CPGID).
Session Properties
AScii(No|7|8) Specifies whether or not this terminal type has an ASCII feature:

No: the terminal type does not have an ASCII feature

7: Terminals of this type are ASCII-7 terminals. All outbound data is translated to 7-bit ASCII, and all inbound data is translated to EBCDIC

8: Terminals of this type are ASCII-8 terminals. All outbound data is translated to 8-bit ASCII, and all inbound data is translated to EBCDIC

SENdsize(number) | Specifies the size, in bytes, of the receive buffer of a terminal of this type. This represents the maximum amount of data that the terminal can receive, and depends on the capability of the device. Considerations of line quality may lead you to specify a buffer size that is less than the terminal type's maximum buffer size. A message longer than the receive buffer is broken into as many request units as are necessary. Defaults to 0 (zero). If you specify a zero buffer size, the message is not broken up; the whole message is presented.
RECEivesize(number) | Specifies the maximum size, in bytes, of a request unit that can satisfy a receive request. The value you specify may be rounded down.
Diagnostic Display
ERRLastline(No|Yes) Indicates whether or not error messages are displayed at the bottom of the screen:

Yes: an error message is displayed at the bottom of the screen, starting at a position that allows the entire message to be shown at once. If messages are received in quick succession, an earlier message may be overwritten before the user has time to read it. Messages displayed in this way may have the additional attributes specified in ERRIntensity, ERRColor and ERRHilight.

No: an error message is displayed at the current cursor position, and without any additional attributes.

ERRIntensify(No|Yes) | Indicates whether or not an error message is displayed in an intensified field (bold). A setting of Yes takes effect only if ERRLastline is set to Yes.
ERRColor(NO|Blue|Red|Pink|Green|

Turquoise|Yellow|Neutral)

Specifies the color in which error messages are to be displayed on a terminal of this type. A setting other than NO takes effect only if ERRLastline is set to Yes.
ERRHilight(No|Blink|Reverse|

Underline)

Specifies the type of highlighting to be used for error messages displayed on a terminal of this type. A setting other than No takes effect only if ERRLastline is set to Yes.
Operational Properties
AUTOConnect(No|Yes) Indicates whether or not a session with the terminal is established when the region starts up:

Yes: a session is established when the region starts up

No: a session is established when the user signs on at the terminal

ATi(No|Yes) | Indicates whether or not a transaction can be automatically initiated on this terminal. If you specify ATi(No), you should specify TTi(Yes) to allow users to initiate transactions.
TTi(Yes|No) | Indicates whether or not users can initiate transactions at this terminal. If you specify TTi(No), you should specify ATi (Yes) to allow transactions to be automatically initiated.
CReatesess(No|Yes) Indicates whether or not a session can be initiated from a terminal of this type:

Yes: EXEC START requests and Automatic Transaction Initiation (ATI) requests are allowed to create sessions automatically

No: EXEC START requests and Automatic Transaction Initiation (ATI) requests are not allowed to create sessions automatically. Such requests are queued or rejected if a session has not been established.

Nepclass(number) | Specifies the transaction class of the node error program. Defaults to 0 (zero), which indicates that the default node error program is to be used.
Signoff(No|Yes) Indicates whether or not a terminal of this type is to be automatically signed off in the absence of user input:

Yes: the terminal is to be automatically signed off after a period of no user input; the length of this period is specified in the Timeout field of the user's entry in the sign-on table.

No: the terminal is not automatically signed of in the absence of user input.

Message Receiving Properties
ROutedmsgs(No|Yes) Indicates whether or not messages are routed to a terminal of this type by the EXEC CICS ROUTE command:

Yes: BMS routes to this terminal messages that are destined for all terminals, as well as messages destined for this terminal

No: no messages are routed to this terminal, even if they are specifically destined for this terminal

LOGOnmsg(No|Yes) Indicates whether or not the transaction that displays the logon message will be initiated when this terminal is connected:

Yes: the logon transaction is initiated when a session is established and displays the logon message on the terminal. Automatic Transaction Initiation (ATI) is used to start the transaction, so you must specify ATi(Yes). The transaction competes with any other ATI transactions for use of the terminal. If you specified ErrLastline(Yes), the logon message does not overwrite any error message currently displayed.

No: the logon transaction is not initiated when a session is established.

Application Features
BUildchain(No|Yes) Indicates whether or not MSS is to reassemble request units into complete messages before passing data from a terminal of this type to a transaction program:

Yes: MSS reassembles request units into a complete message before passing it to a transaction program.

No: messages are received by the transaction program in individual request units.

USerarealen(number) | Specifies the size, in bytes, of the user area of a terminal of this type. Defaults to 0 (zero).
Ioarealen(min,max) Specifies the minimum and maximum sizes, in bytes, of the terminal I/O area to be passed to a transaction program when it issues a RECEIVE. If you specify min, a terminal I/O area of at least that size is passed to the transaction program. If you specify both values and a message longer than min but shorter than max is received, then a terminal I/O area of the maximum size is passed to the transaction program. A message longer than max causes the node abnormal condition program to send an exception response to the terminal. Defaults to 0,0.

If you specify ATi(Yes), you must specify a terminal I/O area of at least one byte.

UCtran(No|Yes|Tranid) Indicates whether or not data entered in lower case is to be translated to upper case:

Yes: data input in lower case is translated to upper case

No: data input in lower case is not translated to upper case

Tranid: transaction identifiers input in lower case are translated to upper case; not other input data is translated

Recovery
RECOVOption(Sysdefault|Clearconv|

Releasesess|Uncondrel|None)

Specifies how MSS recovers the session and returns the terminal to normal service:

Sysdefault: MSS selects the best recovery strategy based on session activity and the characteristics of the terminal

Clearconv: MSS sends a CLEAR request to reset the conversation state, or an UNBIND request if the session does not support the CLEAR request. MSS sends the CLEAR or UNBIND request only if the session was busy.

Releasesess: MSS sends an UNBIND request to clear the active session, if the session was busy.

Uncondrel: MSS sends an UNBIND request to clear the active session, whether or not the session was busy

None: the terminal session is not automatically recovered. If you specified AUTOConnect(Yes), the terminal is automatically reconnected

RECOVNotify(None|Message|

Transaction)

Specifies how the user is notified of system recovery:

None: the user is not notified

Message: a message is displayed on the terminal. The terminal must be capable of displaying BMS maps, and you must have specified ATi(Yes)

Micro Focus Extensions
_Featurebuff(No|Yes) Indicates whether or not BMS buffers formatted data streams that are sent to a terminal of this type:

Yes: When an application issues a series of SEND TEXT PRINT commands, MSS sends a page to the terminal only when it is full

No: When an application issues a series of SEND TEXT PRINT commands, MSS sends a page to the terminal for every command issued, filling up the page by appending blank lines if necessary

  • Example
Parent topic: CICS Resource Definitions


Example

DEFINE TYPETERM(TT01AA01) GROUP(SAMPGRP)
DESCRIPTION(Sample terminal type definition)
       DEVICE(3270) SHIPPABLE(NO) PAGESIZE(24,80) ALTPAGE(24,80)
       OBOPERID(NO) DEFSCREEN(24,80) ALTSCREEN(24,80) APLKYBD(NO)
       APLTEXT(NO) AUDIBLEALARM(NO) COLOR(YES) COPY(NO)
       DUALCASEKYBD(NO) EXTENDEDDS(YES) HILIGHT(YES) KATAKANA(NO)
       LIGHTPEN(NO) PROGSYMBOLS(NO) FORMFEED(NO) OUTLINE(NO) SOSI(NO)
       CGCSGID(0,0) ASCII(NO) SENDSIZE(0) RECEIVESIZE(0)
       ERRLASTLINE(NO) ERRINTENSIFY(NO) ERRCOLOR(NO) ERRHILIGHT(NO)
       AUTOCONNECT(NO) ATI(NO) TTI(YES) CREATESESS(YES) NEPCLASS(0)
       SIGNOFF(NO) ROUTEDMSGS(NONE) LOGONMSG(NO) BUILDCHAIN(NO)
       USERAREALEN(0) IOAREALEN(0,0) UCTRAN(NO) RECOVOPTION(SYSDEFAULT)
       RECOVNOTIFY(NONE)
Parent topic: DEFINE TYPETERM
Related information
Resource Definitions


DEFINE _SIGNON

Defines user IDs and their level of access security to Enterprise Server resources.
Keyword | Description
Description(text) | Describes the sign-on record. Optional. text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.
_Password(password) The password that the user must supply to sign on to an enterprise server session.

Format: up to eight characters.

_OPIdent(name) An ID associated with the terminal.

Format: up to three alphanumeric characters.

_RSlkey(key,key1-key2) Specifies the resource keys owned by the user. A comma-separated list, each item in which may be any of the following:
nn
Toggle the specified resource key (nn is in the range 1 to 24).
mm-nn
Toggle resource keys in the range mm to nn inclusive (mm and nn are in the range 1 to 24).
_SCtykey(key,key1-key2) Specifies the security keys owned by the user. A comma-separated list, each item in which may be any of the following:
nn
Toggle the specified security key (nn is in the range 1 to 64).
mm-nn
Toggle security keys in the range mm to nn inclusive (mm and nn are in the range 1 to 64).
_USerkey(key,key1-key2) Specifies the surrogate keys owned by the user. A comma-separated list, each item in which may be any of the following:
nn
Toggle the specified surrogate key (nn is in the range 1 to 24).
mm-nn
Toggle surrogate keys in the range mm to nn inclusive (mm and nn are in the range 1 to 24).
_Timeout(minutes) Specifies the time, in minutes, for which the user will remain logged on to theTransaction System without initiating a transaction. A value of 0 means that the user will remain logged on indefinitely.

Format: 0 to 60.

_OPPrty(value) Specifies the priority of transaction programs started by this user. 0 is the highest priority, and 255 is the lowest. The priority of a transaction is the sum of:
  • The terminal priority
  • The transaction priority
  • The operator priority (this field)

This sum must not be greater than 255.

Format: 0 to 255.

_GRPPrefix(value) Controls this user's access to private group definitions. The user can only access groups whose names begin with the characters specified here.

You cannot specify a prefix that begins with "DFH".

If you do not specify a group prefix, the user cannot access any private group definitions.

Format: up to eight characters.

_GRPAccess(Update|Read|None) Specifies the type of access this user will be granted to group definitions.

The permissions specified here do not apply to groups whose name begins with "DFH".

In the case of private groups, the access granted here applies only to those groups whose name begins with the user's group prefix.

_PCtaccess(Update|Read|None) | Specifies the type of access this user will be granted to PCT definitions.
_FCtaccess(Update|Read|None) | Specifies the type of access this user will be granted to FCT definitions.
_PPtaccess(Update|Read|None) | Specifies the type of access this user will be granted to PPT definitions.
_DCtaccess(Update|Read|None) | Specifies the type of access this user will be granted to transient data queue/destination control table (DCT) definitions.
_SItaccess(Update|Read|None) | Specifies the type of access this user will be granted to SIT definitions.
_SNtaccess(Update|Read|None) | Specifies the type of access this user will be granted to sign-on table (SNT) definitions.
_TStaccess(Update|Read|None) | Specifies the type of access this user will be granted to temporary storage (TST) definitions.
_JCtaccess(Update|Read|None) | Specifies the type of access this user will be granted to journal control table (JCT) definitions.
_TTyaccess(Update|ReRead|None) | Specifies the type of access this user will be granted to terminal type (TTY) definitions.
_TRmaccess(Update|Read|None) | Specifies the type of access this user will be granted to terminal definitions.
_PLtaccess(Update|Read|None) | Specifies the type of access this user will be granted to program list table (PLT) definitions.
_SUpaccess(Update|Read|None) | Specifies the type of access this user will be granted to start-up list definitions.
_XLtaccess(Update|Read|None) | Specifies the type of access this user will be granted to XLT definitions.
_BAtaccess(Update|Read|None) | Specifies the type of access this user will be granted to batch processing.
_XAtaccess(Update|Read|None) | Specifies the type of access this user will be granted to XAT definitions.
_Imsaccess(Update|Read|None) | Specifies the type of access this user will be granted to IMS processing.
_JCLsubauth(Yes|No) | Specifies whether or not this user will be granted authority to submit JCL.

Example

DEFINE _SIGNON(FRED)
           DESCRIPTION(Fred’s system access)
       _PASSWORD(GUEST) _OPIDENT(SYS) _OPPRTY(255) _TIMEOUT(0)
       _RSLKEY(01-24) _SCTYKEY(01-64)
       _JCLSUBAUTH(NO) _GRPACCESS(UPDATE) _PCTACCESS(UPDATE)
       _FCTACCESS(UPDATE) _PPTACCESS(UPDATE) _DCTACCESS(UPDATE)
       _SITACCESS(UPDATE) _SNTACCESS(UPDATE) _TSTACCESS(UPDATE)
       _JCTACCESS(UPDATE) _TTYACCESS(UPDATE) _TRMACCESS(UPDATE)
       _PLTACCESS(UPDATE) _SUPACCESS(UPDATE) _XLTACCESS(UPDATE)
       _XATACCESS(UPDATE) _BATACCESS(UPDATE) _IMSACCESS(NONE)
Parent topic: CICS Resource Definitions


CICS Supplied Transactions

  • CAMX - Set Maximum Number of Servers
    Sets the maximum number of transaction servers for the region.
  • CDBG - Modify Debug Server
    Modifies a debug server.
  • CEBR - Browse Temporary Storage
    Examines the contents of records in temporary storage or transient data queues.
  • CENV - Show Active Configuration
    Displays the environment used by .
  • CESF - Sign Off
    Signs off from a terminal
  • CESN - Sign On
    Signs on to a terminal.
  • CFCR - Create a File
    Creates an empty file, if the file has previously been defined in the FCT.
  • CFLE, CFLI, CFLS - File Editor
  • CFMT - File Master Transaction
    Opens, closes, enables, disables or inquires on a file.
  • CGWY - Display the Status of and Start CCI Gateways
    Displays the status of CCI gateways and allows CCI gateways to be started.
  • CINQ - Inquire On ASSIGN Values
    Displays a list of all the ASSIGN command values and their settings.
  • CINS - Install a Resource Group
    Installs a resource group.
  • CKQC - Start a CKTI monitor
    Starts the CKTI transaction, which monitors the named MQSeries initiation queue.
  • CLOG - View the Console Log
    Allows you to view and search the console log in the same way as you can view and search the console log display of the Monitor Region tool. This is available for both multi-tasking and single-tasking systems.
  • CMAP - Display BMS Maps and Information
    CMAP displays the contents of a BMS map and displays information about the map and mapset.
  • CNCL - Release Copies of a Program
    Releases any existing copies of the specified called program from memory.
  • CPMT - Inquire and Set Program Attributes
    Displays the current attributes of the specified program for an inquire, and sets the specified program attribute.
  • CQIT - Shut Down a Region
    Shuts down a region.
  • CRTE - Start Transaction Routing
    Starts a transaction routing session to a remote system.
  • CRUN - Generic Run Program
    Invokes the specified program.
  • CSPG - Page Manipulation
    Manipulates pages of information produced by transactions where there is too much information to be displayed or printed at one time. You must have created the pages of information using BMS.
  • CSSF - End Transaction Routing
    Ends transaction routing session.
  • CTRA - Trace Activity
    Controls trace activity in Mainframe Transaction Option.
  • CWTO - Write to Operator
    Write to operator console.
  • EXIT - Sign Off Terminal Emulator
    Signs off and closes the terminal window.
Parent topic: Reference for MSS Deployment


CAMX - Set Maximum Number of Servers

Sets the maximum number of transaction servers for the region.

Syntax:

CAMX number

Notes:

The number must be in the range 1 through 999.

Parent topic: CICS Supplied Transactions


CDBG - Modify Debug Server

Modifies a debug server.

Syntax:

CDBG

Notes:

You do not enter any options on the command line. When you press Enter after CDBG, a screen is displayed showing details of the current debug server. You can:

  • Change the type of server from Term (for Terminal) to Tran (for Transaction) and vice versa. (You can't change the type of server if it is set to Generic.)
  • Change the resource that is being monitored.
Parent topic: CICS Supplied Transactions


CEBR - Browse Temporary Storage

Examines the contents of records in temporary storage or transient data queues.

Syntax:

CEBR

Notes:

You do not enter any options on the command line. When you press Enter after CEBR, a screen is displayed showing the contents of the queue CEBRname, where name is your terminal identifier.

If you want to display a different queue, either:

Enter the subcommand QUEUE with the queue identifier.

or:

Enter the queue identifier in the CEBR command line.

CEBR Subcommands:

The CEBR transaction has the following subcommands (the acceptable abbreviation is shown in upper case):

Option | Topic
BOTtom | Displays the last records in the TS queue (as many as fill the screen)
COLumn nnnn | Displays TS queue records starting at column nnnn
Find /string | Searches TS queue records for the character string string
GET xxxx | Takes the contents of the transient data queue named xxxx and puts it at the end of the displayed TS queue, so that you can browse its contents
LINE nnnn | Alters the display so that record nnnn -1 is at the top of the screen and record nnnn is the current record.
PURGE | Deletes the TS queue that you are browsing
PUT xxxx | Copies the TS queue being browsed to the TD queue named xxxx
Queue xxxxxxxxxxxxxxxx | Displays the contents of the TS queue named xxxxxxxxxxxxxxxx
TERMinal xxxx | Displays the contents of the TS queue named term-idxxxx, where term-id is your terminal identifier
Top | Starts the display at the first record in the TS queue

Restrictions:

The CEBR transaction works as it does on a mainframe, with minor exceptions. In the QUEUE subcommand, you cannot supply a queue name in hexadecimal. There are no PF key equivalents for subcommands.

Parent topic: CICS Supplied Transactions


CENV - Show Active Configuration

Displays the environment used by .

Syntax:

CENV

Notes:

A list of environment variables and their values is displayed on the screen.

Parent topic: CICS Supplied Transactions


CESF - Sign Off

Signs off from a terminal

Syntax:

CESF

Notes:

When the terminal emulator session is closed down, the sign-on screen appears.

Parent topic: CICS Supplied Transactions


CESN - Sign On

Signs on to a terminal.

Syntax:

CESN

Notes:

You do not enter any options on the command line. A screen appears when you enter the command, prompting you for:

Userid (1 to 8 characters)

Password (1 to 8 characters). Your password is not displayed on the screen when you type it in.

New password (1 to 8 characters). This field appears only if you have the authority to change your password.

Parent topic: CICS Supplied Transactions


CFCR - Create a File

Creates an empty file, if the file has previously been defined in the FCT.

Syntax:

CFCR fct-file-entry

Notes:

fct-file-entry is the name specified in the file option in the FCT. The file can be either a base file or an alternate index. It is created with all the related indexes.

A confirmation message shows you the base file characteristics and all the alternate keys that you specified. An error message is displayed if the file has not been created.

Parent topic: CICS Supplied Transactions


CFLE, CFLI, CFLS - File Editor

Syntax:

CFLE
CFLI [/Fcccccccc] [/Dfilename] [/Ccharset] [/Kkey]
CFLS

Entering the transaction name CFLE, CFLI, or CFLS on its own displays the main selection menu listing all the files that have FCT entries in the region.

You can select the file you want to edit from this list.

Parameters

[/Fcccccccc]
Displays only those file names that match the cccccccc specification. cccccccc can be 1 to 8 characters and is case sensitive. You can specify a '?' as a positional wildcard character. For example:
CFLE /FT

displays all file names beginning with 'T' and

CFLE /F??S

displays all file names whose third character is 'S'.

[/Dfilename]
Displays the edit screen for the filename specified and positions you on the first record. filename can be 1 to 8 characters and is case sensitive. For example:
CFLE /DTSTAKSDS

displays the edit screen for file TSTAKSDS positioned on the first record.

[/Ccharset]
Defines the character set of the file, A for ASCII (the default) or E for EBCDIC. For example:
CFLE /DTSTEKSDS /CE

displays the edit screen for file TSTEKSDS as an EBCDIC file.

[/Kkey]
Defines the key of the record at which the edit screen is positioned. key can be 1 to 64 characters and can be specified as character or hexadecimal.

For example:

CFLE /DTSTAKSDS /CE /K2222

or

CFLE /DTSTAKSDS /CE /KX'F2F2F2F2'

displays the edit screen for file TSTEKSDS as an EBCDIC file positioned at the record with key 2222.

If you specify both the /F and /D parameters, on leaving the edit screen the list of files defined by the /F parameter is displayed on the main selection screen.

Notes:

The CFLI transaction has no security restrictions and can be used by any user. It allows read access to local KSDS, ESDS, and RRDS files.

The CFLE transaction can be used only by a signed-on user (if security is turned on). It allows read and update access to local and remote KSDS, ESDS, and RRDS files. It also allows changes to the status of files in a similar way to the CFMT transaction.

The CFLS transaction has all the facilities of CFLE plus the ability to edit sequential files. It is installed in the group DFHOPER and cannot be used by any user when security is turned on. (You must copy the PCT entry to your own group and set the appropriate security keys for your installation.)

Parent topic: CICS Supplied Transactions


CFMT - File Master Transaction

Opens, closes, enables, disables or inquires on a file.

Syntax:

CFMT [OPen|CLose|ENable|DIsable|INquire|NAme] filename

Notes:

You must enter at least the first two letters of the option you choose.

The filename may contain wild card characters. A question mark denotes any single character, while a single asterisk denotes any number of characters. An asterisk can appear only at the end of the filename. Question marks and an asterisk can be combined, for example:

CFMT CL A??PP*

closes all files that start with "A" and have "PP" in character positions 4 and 5.

You can use the CEBR transaction to view the results of a CFMT transaction that uses wild cards in the filename.

Parent topic: CICS Supplied Transactions


CGWY - Display the Status of and Start CCI Gateways

Displays the status of CCI gateways and allows CCI gateways to be started.

Syntax:

CGWY

Notes:

You can use this transaction only in multi-tasking regions. It displays a screen listing the CCI gateways available and their status.

You can start any of the gateways by specifying '/' or 'S' next to the gateway and pressing Enter. Pressing F3 exits from the transaction.

Parent topic: CICS Supplied Transactions


CINQ - Inquire On ASSIGN Values

Displays a list of all the ASSIGN command values and their settings.

Syntax:

CINQ

Notes:

The ASSIGN command values and settings are listed in alphabetic order.

Parent topic: CICS Supplied Transactions


CINS - Install a Resource Group

Installs a resource group.

Syntax:

CINS group-name

CINS resource-type(resource-id) Group(group-name)

Parameters:

resource-type | One of File, Program, TDqueue, Terminal, TRansaction, TYpeterm. You must supply at least the portion of the type shown in upper case
resource-id | The name of the resource
group-name | The name of the group the resource belongs to

Notes:

If the group is already installed, the existing definitions are replaced by those currently in the resource definition file (RDF). The group-name can be a maximum of eight characters. Group can be abbreviated to G.

Example:

CINS F(ACCTFIL) G(TEST)

This will install the file control table entry for ACCTFIL from the resource group TEST.

Parent topic: CICS Supplied Transactions


CKQC - Start a CKTI monitor

Starts the CKTI transaction, which monitors the named MQSeries initiation queue.

Syntax:

CKQC [STARTCKTI initiation-queue-name]

Notes:

You can use this transaction only in a multi-tasking region. You must have enabled MQSeries for MSS either by importing a SIT that has MQSeries enabled or by enabling it on the detailed information page for the SIT in ESMAC.

You can invoke this transaction in a terminal window or in a program.

If you invoke CKQC in a terminal window, you need to enter only CKQC. A message then appears prompting you for the initiation queue name.

If you invoke CKQC in a program, you pass the command in an INPUTMSG or COMMAREA to the CICS Option utility dfhzckqc. If you invoke CKQC from the PLTPI, it cannot take the INPUTMSG parameter, only the COMMAREA. For example:

ID DIVISION.
PROGRAM-ID. TESTCKQC.
ENVIRONMENT DIVISION.
CONFIGURATION SECTION.
INPUT-OUTPUT SECTION.
DATA DIVISION.
FILE SECTION.
WORKING-STORAGE SECTION.
01  DATA-BUFF                    PIC X(80) VALUE
   'CKQC STARTCKTI TEST.INITQ'.
LINKAGE SECTION .
PROCEDURE DIVISION.
MODULE-ENTRY-POINT.
    EXEC CICS LINK
              PROGRAM ('DFHZCKQC')
              COMMAREA (DATA-BUFF)
              LENGTH (LENGTH OF DATA-BUFF)
    END-EXEC

    EXEC CICS RETURN
    END-EXEC
    GOBACK.
Parent topic: CICS Supplied Transactions


CLOG - View the Console Log

Allows you to view and search the console log in the same way as you can view and search the console log display of the Monitor Region tool. This is available for both multi-tasking and single-tasking systems.

Syntax:

CLOG

Notes:

Help that describes the function keys is available on each screen.

Parent topic: CICS Supplied Transactions


CMAP - Display BMS Maps and Information

CMAP displays the contents of a BMS map and displays information about the map and mapset.

Syntax:

CMAP [mapset-name [map-name]]

Parameters:

[mapset-name [map-name]]

If a mapset-name is specified, then a list of maps within the mapset is displayed. If, in addition, a map-name is specified, then that map is displayed.

If map-name is not specified, you can use wildcard characters ("?" and "*") within mapset-name to reduce the number of mapsets displayed.

Notes:

If no parameters are specified, or the parameters specified are not found, a list of mapsets found in the mapset directories is displayed. If a mapset contains .MOD files, the mapset name is displayed in white. If it contains .MST files, it is displayed in blue.

You can select an item in a list either by positioning the cursor, or by typing a slash "/" against the item, and pressing Enter. Selecting a mapset displays a list of the maps it contains. Selecting a map displays the map itself.

If a mapset appears more than once in the list, then CMAP always displays the first mapset.

Typing "i" against an item (mapset or map) and pressing Enter, displays information about the item.

Typing "d" against a mapset and pressing Enter deletes the mapset. A confirmation message is displayed. Press Enter to confirm the delete, press any other attention key to cancel it.

You can use F7-PgUp and F8-PgDn to page through lists that are more than one screen long.

Pressing Clear (or any attention key) returns to the previous higher level screen.

You can exit the transaction at any time by pressing F3.

Parent topic: CICS Supplied Transactions


CNCL - Release Copies of a Program

Releases any existing copies of the specified called program from memory.

Syntax:

CNCL program-name

Notes:

This transaction releases any existing copies of the specified called program from memory. (A called program is one that is not invoked through LINK or XCTL.) If a PPT entry exists for the program-name specified, an error message is displayed and the program is not released. (In this case you should use transaction CPMT NEWCOPY.) This transaction is valid only in an environment where logical cancel support is enabled in the COBOL run-time system.

Parent topic: CICS Supplied Transactions


CPMT - Inquire and Set Program Attributes

Displays the current attributes of the specified program for an inquire, and sets the specified program attribute.

Syntax:

CPMT function program-name

Notes:

The function is specified as one of:

CEdf

NOcedf

NEwcopy

PHasein

DPlsubset

FUllapi

PRivate

SHared

ENabled

DIsabled

INquire

NAme-inquire

For each function except INquire and NAme-inquire, CPMT issues an EXEC CICS SET PROGRAM command for the corresponding system programming API keyword.

For the INquire function, CPMT issues an EXEC CICS INQUIRE PROGRAM command, and displays the results.

For the NAme-inquire function, CPMT displays the fully qualified program name of the object loaded from disk for the associated program or table.

Parent topic: CICS Supplied Transactions


CQIT - Shut Down a Region

Shuts down a region.

Syntax:

CQIT [IMMED]

Notes:

If you specify IMMED, no programs specified in the PLTSD list in the SIT are executed. All existing tasks are canceled.

Parent topic: CICS Supplied Transactions


CRTE - Start Transaction Routing

Starts a transaction routing session to a remote system.

Syntax:

CRTE SYSID=sysid

Notes:

sysid is the system identifier of the remote system to which you want to connect. A message is displayed to confirm that the routing session has been started. You might need to sign on to the remote system before running any transaction. After this, you can enter the transaction identifier of the transaction you want to run.

Parent topic: CICS Supplied Transactions


CRUN - Generic Run Program

Invokes the specified program.

Syntax:

CRUN program

Notes:

The program is invoked through XCTL. You can use CRUN to execute a program without having to define an explicit PCT entry for it. CRUN is useful for testing a program, or for invoking a PLT-type program on an as-required basis.

Parent topic: CICS Supplied Transactions


CSPG - Page Manipulation

Manipulates pages of information produced by transactions where there is too much information to be displayed or printed at one time. You must have created the pages of information using BMS.
Note: BMS must be running in the system to act on the CSPG commands you enter.
  • CSPG getpage
    Retrieves a page.
  • CSPG getpageQ
    Displays the message identifiers and titles of logical messages queued for this terminal.
  • CSPG messchnyyyy
    Keeps the old pages from a transaction.
  • CSPG hmsgterm
    Erases a logical message, leaving the previous message displayed.
  • CSPG msgcopy
    Sends a copy of the page being displayed, as it appeared when initially transmitted, to another terminal.
Parent topic: CICS Supplied Transactions


CSPG getpage

Retrieves a page.

Syntax:

CSPG getpage[(x)] y [*ldc|*ALL][,hhhhhh]

Parameters:

getpage
The identification code you define for the retrieval transaction (1 to 7 characters)
(x)
For chaining messages. It indicates the level of the message you want to retrieve. You must include the parentheses. The value of x can be:
n | Message is at level n
+n | Message is at level n higher
-n | Message is at level n lower
C | Message is at current level (default)
L | Message is at last level
N | Message is at next level
P | Message is at previous level
y
The next thing you want to do with the message. It can be:
n | Display page n
+n | Display page n pages forward
-n | Display page n backward
C | Clear the screen and display current page again
L | Display the last page
N | Display the next page
P | Display the previous page
A | Only for auto-paging hard-copy terminals. Return the terminal to autopaging mode and output remaining pages.
*ldc
Reset the specified logical device code where you want to send the message to autopage.
*ALL
Reset all logical devices to autopage (if they are defined as such in the terminal definition).
hhhhhh
The identifier of an undelivered logical message you want to retrieve.
Parent topic: CSPG - Page Manipulation


CSPG getpageQ

Displays the message identifiers and titles of logical messages queued for this terminal.

Syntax:

CSPG getpageQ

Parameters:

getpage | The identification code you define for the retrieval transaction. (One to seven characters long.)
Q | Indicates that you want the identifiers of all of the logical messages directed to this terminal to be displayed.
Parent topic: CSPG - Page Manipulation


CSPG messchnyyyy

Keeps the old pages from a transaction.

Syntax:

CSPG messchnyyyy [parameters]

Parameters:

messchn | The defined message-chaining transaction identification code for your installation.
yyyy | The identifier of a transaction that produces data to be added to the message chain.
parameters | Any parameters transaction yyyy needs.
Parent topic: CSPG - Page Manipulation


CSPG hmsgterm

Erases a logical message, leaving the previous message displayed.

Syntax:

CPSG hmsgterm{A|B|C|H|R}[,hhhhhh]

Parameters:

msgterm | The transaction identifier of your message terminating transaction.
A | Terminates all logical messages directed to or currently being displayed on the terminal
B | Terminates the logical message currently being displayed on the terminal, and any logical messages chained to it.
C | Terminates the current logical message and any messages chained to it.
H | Terminates all logical messages chained to the message being displayed on the terminal. The page of the base message that was most recently displayed is redisplayed at the terminal.
R | Terminates all logical messages routed to the terminal. The page that was being displayed at the terminal is redisplayed.
hhhhhh | The 6-digit hexadecimal identifier of a specific, undelivered logical message to be erased. You can find out the message identifier using a page query command.

When termination is complete, you receive the message:

DFHTP4122 REQUESTED PURGE COMPLETE

Parent topic: CSPG - Page Manipulation


CSPG msgcopy

Sends a copy of the page being displayed, as it appeared when initially transmitted, to another terminal.

Syntax:

CSPG msgcopy tttt

Parameters:

msgcopy | The copy transaction identifier (one to seven characters long).
tttt | The identifier of the terminal to which the page is to be copied.

Comments:

A hard-copy terminal that is not defined as a paging terminal (one that displays pages when you request them) is an autopaging terminal (one that displays all pages without your intervention). You can temporarily designate an autopaging terminal as a paging terminal by using the NOAUTOPAGE option of the SEND PAGE command. If you do this the time the first page is to be displayed on the terminal, the terminal is temporarily treated as a paging terminal for the duration of the message. To stop this:

  1. Type P/A (reset terminal to autopaging status), indicating that all subsequent pages are to be displayed without further intervention.
  2. Type T/C (terminate current message). All pages from that logical message are purged, and the terminal is again put into autopaging status.

P/ is the paging transaction identifier, and T/ is the terminate transaction identifier.

You can use the message-switching transaction to direct output to other terminals.

When a terminal to which you have directed a message is in TRANSCEIVE status, and is not involved with a transaction, and is not displaying pages, CICS displays the first page of that message.

However, if the terminal is in TRANSACTION status, you can display the first page only of a waiting message by typing CSPG, CSPG P/1, or by typing simply P/1. Here, you are using P/ as a paging command. If no page is waiting, you get the following message:

DFHTP4104-NO PAGES WAITING TO BE DISPLAYED

Parent topic: CSPG - Page Manipulation


CSSF - End Transaction Routing

Ends transaction routing session.

Syntax:

CSSF

Parent topic: CICS Supplied Transactions


CTRA - Trace Activity

Controls trace activity in Mainframe Transaction Option.

Syntax:

CTRA

Notes:

You do not enter any options on the command line. A screen appears when the command is entered, which prompts for the following:

Activate trace facility, which can be set to Y(es) or N(O). Y activates trace for the system components marked with a Y. N stops all trace.

Overwrite existing file, which can be Y(es) or N(o). Y overwrites the existing trace file; N creates a new trace file.

Functions to trace lists the following functions. Y turns trace on for that function, N turns it off.

Storage control

Task Control

File Control

Dump Control

TS/TD Control

Interval Control

Journal Control

Table Management

Terminal Control

Communications

User Trace

Message

API

CCI

Pressing F3 saves the changes you have made; F12 discards them. Both function keys end the transaction.

Parent topic: CICS Supplied Transactions


CWTO - Write to Operator

Write to operator console.

Syntax:

CWTO message

Notes:

You can use this transaction only in a multi-tasking region.

If you do not type a message when you enter the transaction identifier, you are prompted for the message.

Parent topic: CICS Supplied Transactions


EXIT - Sign Off Terminal Emulator

Signs off and closes the terminal window.

Syntax:

EXIT

Notes:

When the terminal emulator closes down, the terminal is disconnected from Enterprise Server.

Parent topic: CICS Supplied Transactions


JCL Commands

  • cassi (JCL version)
    Starts a batch initiator or batch printer service execution process. Use this version of the command if you have MSS JCL Support installed. You should use this command to debug a JCL job.
  • cassub
    Runs a JCL batch job.
  • casout
    Starts a batch service execution process or administers a batch job.
Parent topic: Reference for MSS Deployment


cassi (JCL version)

Starts a batch initiator or batch printer service execution process. Use this version of the command if you have MSS JCL Support installed. You should use this command to debug a JCL job.

Syntax:

cassi [/res-name]
      [/a]
      [/bjob-class-list]
      [/poutput-class-list]
      [/qprinter-name]
      [/zprinter-exit]

Parameters:

/res-name | Name of the enterprise server for which to start a service execution process. Defaults to ESDEMO
/a | Debug any application that runs in this service execution process
/bjob-class-list | Start a batch inititiator SEP to handle the job classes named in job-class-list
[/poutput-class-list] | Start a batch printer SEP to handle the output classes named in output-class-list
[/qprinter-name] | Send output to printer-name, which must be the name of a printer defined on your machine.
[/zprinter-exit] | Direct output through the program printer-exit

Dependencies:

To use this command:

  • You must have started the enterprise server named with the /r flag first.
  • You must be running under the same user ID as the enterprise server named with the /r flag. If the Directory Server was started as a system service, and the enterprise server was started using the Administration interface, then the enterprise server is probably running under the LOCAL_SYSTEM user ID, and this command will not work. For more information see the section Starting and Stopping the Directory Server in the chapter Introduction to Enterprise Server Administration in your Enterprise Server Configuration and Administration Guide.

Comments:

On UNIX you can use a dash (-) before a parameter as an alternative to a forward slash (/).

Many of the command line utilities, including casstart, casstop, casfile, casout, and cassub, can be invoked by program using the call interface and passing the command line parameters to the call. For an example, please see casstart.

Parent topic: JCL Commands
Related information
casstart
Starting and Stopping the Directory Server


cassub

Runs a JCL batch job.

Syntax:

cassub [/res-name] or [/saddress] or [/les-name]
       [/jjobfile-name-by-content]
       [/xjobfile-name-by-reference]
       [/u]
       [/p]
       [/vversion]

Parameters:

Options /r, /s, /l are alternative ways of identifying the enterprise server that you want to connect to.

/res-name
Name of the enterprise server to run the job. Defaults to ESDEMO
Note: When calling this utility from JCL or from a WEB service (that is, when you are running the utility within a SEP) you cannot use the /r option to connect to the server. Where this is the case, you must use the /s or /l options to connect to the server.
/saddress
Submit the job to a remote server. address is the address of the listener associated with the server's MF JES service. The format is protocol:ip-address:port, where:
  • protocol is tcp
  • ip-address is either the text host name or IP address of the server listener
  • port is the port value
/les-name
Alternative to using the /r and /s options. Name of the enterprise server to run the job. You must specify a name - there is no default. This option searches all the repositories specified in mf-client.dat (or whichever configuration file you have identified with the MFC_CONFIG environment variable) for a server with the given name. Repositories are specified in the [directories] section, in the format:
mrpi://host[:port]

or:

file:///path-to-repository
/jjobfile-name-by-content
Path and filename of the file containing the JCL to run. See Comments below.
/xjobfile-name-by-reference
Path and filename of the file containing the JCL to run. See Comments below.
/u and /p
Reserved for future use.
/vversion
The version of the job control system software to use:
  1. VSE/Power
  2. JES2 (default)
  3. JES3

Dependencies

To use this command:

  • If you specify the /r parameter, you must have started the enterprise server named with the /r parameter first (or the ESDEMO on the local machine if you do not specify either /r or /s) using the casstart command. If you specify the /s parameter, you must have started the enterprise server identified by the /s parameter, using ES Admin.
  • You must be running under the same user ID as the enterprise server named with the /r parameter. If the Directory Server was started as a system service, and the enterprise server was started using the Administration interface, then the enterprise server is probably running under the LOCAL_SYSTEM user ID, and this command will not work. For more information see the section Starting and Stopping the Directory Server in the chapter Introduction to Enterprise Server Administration in your Enterprise Server Configuration and Administration Guide.
  • In order to successfully run the cassub command, you must have execute permissions on the cassub resource within the OPERCMDS resource class

Comments

You can use a dash (-) before a parameter as an alternative to a forward slash (/).

You must specify either the /j parameter or the /x parameter.

/r and /s are mutually exclusive. If you do not supply either, it is assumed that you are submitting to the server ESDEMO on the local machine.

For /x (by reference) the submitted file must be on the same platform as the enterprise server. This technique is more efficient, since only the name of the file is passed by the communications link. This is used internally (internal reader). You would use this technique where you run a job scheduling system on the same platform as the target enterprise server.

For /j (by content) the submitted file must be on the client's platform (which could be the same platform as the target enterprise server). The submitted JCL is physically passed over the communications link. This would be appropriate for an interactive user that has created the job stream on their machine and wants to submit it to an enterprise server running on another platform.

You can specify the /j or /x parameter more than once, in order to submit several JCL files in the same command.

The job is run by the most recently started available initiator that can handle the class specified on the JOB card.

Many of the command line utilities, including casstart, casstop, casfile, casout, and cassub, can be invoked by program using the call interface and passing the command line parameters to the call. For an example, please see casstart.

Parent topic: JCL Commands


casout

Starts a batch service execution process or administers a batch job.

Syntax:

casout [/res-name]
       [/sprototype:host:port]
       [/lservername]
       [/gnumber]
       [/gnumber:reldd]
       [/doutput-dsn]
       [/iclasses]
       [/jjobnumber:step:procstep]
       [/knumber]
       [/mnumber]
       [/fnumber]
       [/uuserid]
       [/ppassword]

       [/wmpr-name]

Connection parameters

Important: You must include only one of the following connection options.
/res-name
Connect to the named enterprise server. Defaults to ESDEMO.
Restriction: When calling this utility from JCL or from a WEB service (that is, when you are running the utility within a SEP) you cannot use the /r option to connect to the server. Where this is the case, you must use the /s or /l options to connect to the server.
/sprototype:host:port
Use the specified URL to find the enterprise server to connect to, for example stcp:localhost:9003.
/lservername
Look up the specified server name to find the enterprise server to connect to.

Other parameters

/gnumber
/gnumber:reldd
Display all sysout for job number number, or retrieve the relative DD for job number number.
/doutput-dsn
Output DSN for sysout retrieval. The /d option must precede the /g option.
/iclasses
Start an initiator to run jobs of the named classes.
/jjobnumber:step:procstep
Restart the job at the specified step/procstep. The procstep is optional.
/knumber
Kill job number number.
/mnumber:class
Modify job number number to use the specified class.
/fnumber
Flush the output of job number number.
/uuserid
Authorization user ID.
/ppassword
Authorization password.
/cgroup
The sign-on group to be used when running commands.
/qmessage-classes
Start an IMS Message Processing Region for the specified classes.
/tprocess-ID
Terminate the batch initiator, batch printer or IMS MPR that has the specified process ID.
/eIMScommand
Execute the specified IMS command.
/v
List all batch initiators, batch printers and IMS MPRs.
/nprinter-name
Specifies the name of the physical device to be used by a new batch printer. This option is used with the /b and /x options.
/boutput-classes
Specifies the output classes to be handled by a new batch printer. This option is used with the /n and /x options.
/xprinter-exit
Specifies the name of the name of a printer exit to be associated with a new batch printer. Used with the /n and /b options.
/wmpr-name
Name of the IMS MPR to be used.

Dependencies

  • You must have started the enterprise server before you can issue a casout command.
  • In order to successfully run the casout command, you must have execute permissions on the casout resource within the OPERCMDS resource class.

Comments

The /r, /s and /l options are alternatives and are mutually exclusive.

On UNIX you can use a dash (-) before a parameter as an alternative to a forward slash (/).

Examples

Starting an initiator for classes EFG on Enterprise Server JCLT:

casout /rJCLT /iEFG

Start a batch printer using the physical device "TestPrinter" for classes EFG on Enterprise Server JCLT:

casout /rJCLT /bEFG /n"TestPrinter"

Start a batch printer as in the previous example, but this time associate it with a printer exit (sampprnx):

casout /rJCLT /bEFG /n"TestPrinter" /xsampprnx

Start an IMS Message Processing Region for specified message classes:

casout /rJCLTT /q001

Return codes

When running casout from a command line, get the return code by running the following command:

echo %ERRORLEVEL%
All functions
Code | Description
0 | Successful completion
Codes relating to job modification
Code | Description
5 | The job is actively processing, requeued
8 | The job is not in the Output Hold queue, or does not exist
8 | The job is in the Output Hold queue, requeued
8 | The job is not in the Input Hold queue or does not exist for Release command
16 | The job does not exist for Class command
99 | You have attempted to invoke a sub-command that is not yet implemented
Codes relating to flushing jobs
Code | Description
4 | Job flushed
16 | Job not flushed - see secondary error code returned in message
Codes relating to job output
Code | Description
< 9 | The job's log was retrieved
1 | Job is in the Input Hold Queue
2 | Job is being parsed for syntax
3 | Job is in the Input Queue
4 | Job is moving from Input Queue to "Actively processing"
5 | Job is being processed
7 | Job is complete and is on the Held Output Queue
8 | Job is in the Output Queue
16 | Invalid job number - you have attempted to retrieve sysout data for a non-existent job
16 | Invalid job number or DD for job, retrieval request ignored
Codes relating to restarting jobs
Code | Description
16 | The job does not exist for restart
32 | Restart processing is not turned on. You must set the ES_JES_RESTART environment variable in order to enable restart processing.
Codes relating to killing jobs
Code | Description
16 | The job is not active. Kill request ignored.
Codes relating to IMS command execution
Code | Description
15 | Commands must be preceded by a / (forward slash)
16 | IMS command failed, no response from TMC
Codes relating to process termination
Code | Description
8 | SEP is not an initiator, printer, or IMS MPR
Codes relating to JES and IMS functions
Code | Description
99 | JES/IMS support is not enabled for the region, request rejected
Codes relating to security
Code | Description
199 | User specified is either not authorized to work with JCL or their password is not correct. Provide valid credentials.
Codes relating to connectivity
Code | Description
15 | Cannot connect to region. This might be because the region is not started, or the IP address or port are wrong.
Parent topic: JCL Commands


JCL Environment Variables

  • MF_ALIAS
    Specifies program aliases. Each set (pair) is 16 characters long - 8 characters for the program-name, and 8 characters for the alias. You can specify up to 10 pairs. This list is searched first and thus can potentially override the built-in list. If not found, the built-in alias table is searched.
  • MF_CHARSET
    Specifies which character set an enterprise server is to use.
  • MF_DUPJOBS
    Specifies whether jobs with duplicate names are allowed to run in parallel.
  • MF_FALLTHRUCHECK
    Specifies that MSS is to check that the main COBOL program ends by executing a GOBACK or STOP RUN.
  • MF_JESPWR_EXIT
    MF_JESPWR_EXIT is used to pass JES2 and VSE PWR statements to a user exit, MFJESPWR. If this environment variable is set the JCL execution engine will call the exit program, MFJESPWR, whenever a JES2 or VSE PWR statement is encountered. It passes the contents of the JCL record plus Job and Job Step information . A sample MFJESPWR.cbl is included with the product.
  • MF_NODD
    Specifies what action MSS is to take at run time if a job step uses a file that has not been allocated.
  • MF_SMS
    Turns on support for SMS data classes.
  • MF_UCC11
  • MF_USESCA7
    Specifies that MSS accepts CA7 Scheduler control statements as comments rather than diagnosing them as errors.
  • MFJSENGINE
    Specifies which sort engine the utility MFJSORT is to emulate.
  • MFREXX_LSEQ_RECSIZE_MAX
    Specifies the record length for the REXX EXECIO command when reading or writing a line sequential file that has been cataloged with a record length of zero.
  • MFREXX_NOT
    Specifies one or more characters to be used for the NOT operator in addition to REXX's default, which is "¬".
  • MFREXX_OR
    Specifies one or more characters to be used for the OR operator in addition to REXX's default, which is "|".
  • MFREXX_CONCAT
    Specifies one or more characters to be used for the CONCAT operator in addition to REXX's default, which is "||".
  • MFUSERCAT_NODE
    Sets node to enable DATACLAS support.
Parent topic: Reference for MSS Deployment


MF_ALIAS

Specifies program aliases. Each set (pair) is 16 characters long - 8 characters for the program-name, and 8 characters for the alias. You can specify up to 10 pairs. This list is searched first and thus can potentially override the built-in list. If not found, the built-in alias table is searched.
Note:

You can alias any program other than IEFBR14, which is always processed as IEFBR14.

Syntax:

MF_ALIAS=program-name1 alias1 [program-name2 alias2] ...[program-name10 alias10]

Comments:

An entry shorter than 8 characters must have trailing spaces extending its length to 8 characters.

Example:

MF_ALIAS=IKJEFT1BIDAEFT01MYPROG  THEIRPRG

adds:

Program-name | Alias
IKJEFT1B | IDAEFT01
MYPROG | THEIRPRG
Parent topic: JCL Environment Variables


MF_CHARSET

Specifies which character set an enterprise server is to use.

Syntax:

MF_CHARSET=A|E|ASCII|EBCDIC

Properties:

Default: ASCII

Comments:

A is an abbreviation for ASCII. E is an abbreviation for EBCDIC.

Parent topic: JCL Environment Variables


MF_DUPJOBS

Specifies whether jobs with duplicate names are allowed to run in parallel.

Syntax:

MF_DUPJOBS=Y|N

Properties:

Default: N
Parent topic: JCL Environment Variables


MF_FALLTHRUCHECK

Specifies that MSS is to check that the main COBOL program ends by executing a GOBACK or STOP RUN.

Syntax:

MF_FALLTHRUCHECK=y|n

Properties:

Default: y (Yes)

Comments:

If MF_FALLTHRUCHECK is set to Yes and the check fails, MSS issues this message:

JCLCM0213S Main pgm xxxxxxxx did not issue GOBACK or STOP RUN.
Parent topic: JCL Environment Variables


MF_JESPWR_EXIT

MF_JESPWR_EXIT is used to pass JES2 and VSE PWR statements to a user exit, MFJESPWR. If this environment variable is set the JCL execution engine will call the exit program, MFJESPWR, whenever a JES2 or VSE PWR statement is encountered. It passes the contents of the JCL record plus Job and Job Step information . A sample MFJESPWR.cbl is included with the product.

Syntax:

MF_JESPWR_EXIT= Y

Properties:

The default value is OFF ( i.e. not set )

This is the start of your topic.

Parent topic: JCL Environment Variables


MF_NODD

Specifies what action MSS is to take at run time if a job step uses a file that has not been allocated.

Syntax:

MF_NODD=a|r

Parameters:

a | Abend the program
r | Return the file status 3/5

Properties:

Default: abend
Parent topic: JCL Environment Variables


MF_SMS

Turns on support for SMS data classes.

Syntax:

MF_SMS=ON|OFF

Properties:

Default: OFF

Comments:

SMS is IBM's Storage Management Subsystem. MSS provides emulation for SMS data classes only.

To enable DATACLAS support this variable needs to be set ON in addition to setting MFUSERCAT_NODE=SYSMFE1

Parent topic: JCL Environment Variables


MF_UCC11

Syntax:

MF_UCC11=y|n|M

Description

Enables emulation of UCC11, the JCL job re-start functionality. This environment variable affects data set disposition processing in the following ways:

  • If UCC11 is enabled, a data set disposition of NEW is accepted even if the data set already exists. The features that this environment variable enables are:

Properties:

Y
JCL job re-start functionality is enabled. When restarting a job with DISP=(NEW,CATLG), datasets will not result in job failure due to the dataset already being cataloged.
M

On a restart a catalogued a dataset is presumed to have an initial disposition of MOD rather than NEW. As a result, any new data is appended to the existing dataset.

N
JCL job re-start functionality is disabled.
Default: n (No)
Parent topic: JCL Environment Variables


MF_USESCA7

Specifies that MSS accepts CA7 Scheduler control statements as comments rather than diagnosing them as errors.

Syntax:

MF_USESCA7=ON|OFF

Properties:

Default: ON

Comments:

CA7 Scheduler control statements begin with # in column 1.

Parent topic: JCL Environment Variables


MFJSENGINE

Specifies which sort engine the utility MFJSORT is to emulate.

Syntax:

MFJSENGINE=DFSORT|SYNCSORT

Properties:

Default: DFSORT
Parent topic: JCL Environment Variables


MFREXX_LSEQ_RECSIZE_MAX

Specifies the record length for the REXX EXECIO command when reading or writing a line sequential file that has been cataloged with a record length of zero.

Syntax:

MFREXX_LSEQ_RECSIZE_MAX=rec-length

Parameters:

rec-length Record length to use. The minimum value you can specify is 255. Specifying an invalid value, or a value less than 255, results in the default value being used.

Properties:

Default: 255
Parent topic: JCL Environment Variables


MFREXX_NOT

Specifies one or more characters to be used for the NOT operator in addition to REXX's default, which is "¬".

Syntax:

MFREXX_NOT=character-specification

Parameters:

character-specification One or more characters for each operator; each character you specify is used in addition to the default operator. Each additional character must be defined within single or double quotes, or in hexadecimal. Separate multiple characters with a space or a comma.

Properties:

Default: "¬"

Comments:

Any error in the specification of the additional characters, including the specification of alphabetic or numeric characters, results in the environment variable being ignored.

Parent topic: JCL Environment Variables


MFREXX_OR

Specifies one or more characters to be used for the OR operator in addition to REXX's default, which is "|".

Syntax:

MFREXX_OR=character-specification

Parameters:

character-specification One or more characters for each operator; each character you specify is used in addition to the default operator. Each additional character must be defined within single or double quotes, or in hexadecimal. Separate multiple characters with a space or a comma.

Properties:

Default: "|"

Comments:

Any error in the specification of the additional characters, including the specification of alphabetic or numeric characters, results in the environment variable being ignored.

Parent topic: JCL Environment Variables


MFREXX_CONCAT

Specifies one or more characters to be used for the CONCAT operator in addition to REXX's default, which is "||".

Syntax:

MFREXX_CONCAT=character-specification

Parameters:

character-specification One or more characters for each operator; each character you specify is used in addition to the default operator. Each additional character must be defined within single or double quotes, or in hexadecimal. Separate multiple characters with a space or a comma.

Properties:

Default: "||"

Comments:

Any error in the specification of the additional characters, including the specification of alphabetic or numeric characters, results in the environment variable being ignored.

Parent topic: JCL Environment Variables


MFUSERCAT_NODE

Sets node to enable DATACLAS support.

Syntax:

MFUSERCAT_NODE=SYSMFE1

Properties:

Default: No value assigned

Comments:

To enable DATACLAS support this variable needs to be set in addition to setting MF_SMS=ON.

Parent topic: JCL Environment Variables


MSS Error Messages

See your locally installed Help for the messages that Enterprise Server can display when it is running with MSS enabled. It gives an explanation or advice or both for those errors that are not self-explanatory.

  • JCL Error Messages
Parent topic: Reference for MSS Deployment


JCL Error Messages

  • JCLAM Error Messages
  • JCLCM Error Messages
  • JCLGN Error Messages
  • JCLIM Error Messages
  • JCLUT Error Messages
  • JCLZZ9999S job-number job-name MESSAGE UNDEFINED MESSAGECODE
  • SORT - MFJSORT Error Messages
  • MFJSORT Summary Messages
  • JES Messages
Parent topic: MSS Error Messages


JCLAM Error Messages

Select the number of the message you require details about.

  • JCLAM0000 - JCLAM0119
  • JCLAM0120 - JCLAM0139
  • JCLAM0140 - JCLAM 0159
  • JCLAM0160 - JCLAM0179
  • JCLAM0180 - JCLAM0230
  • JCLAM0231 -
Parent topic: JCL Error Messages


JCLCM Error Messages

Select the number of the message you require details about:

  • JCLCM0000 - JCLCM0199
  • JCLCM0200 - JCLCM0299
  • JCLCM0400 - JCLCM0499
  • JCLCM0500 - JCLCM0599
  • JCLCM0800 - JCLCM0899
  • JCLCM0900 - JCLCM0999
Parent topic: JCL Error Messages


JCLGN Error Messages

Select the number of the message you require details about:

  • JCLGN0001U job-number job-name MISSING SYSUT1
    The DD statement for SYSUT1 is missing from your JCL.
  • JCLGN0002U job-number job-name INVALID SYSUT1
    The dataset organization for SYSUT1 is invalid.
  • JCLGN0003U job-number job-name MISSING SYSUT2
    The DD statement for SYSUT2 is missing from your JCL.
  • JCLGN0004U job-number job-name INVALID SYSUT2
    The dataset organization for SYSUT2 is invalid. Only sequential datasets and members of a PDS dataset can be specified on the SYSUT2DD statement.
  • JCLGN0005U job-number job-name I/O ERROR ON SYSUT1
    An error has occurred when accessing the dataset specified by the SYSUT1DD statement.
  • JCLGN0006U job-number job-name I/O ERROR ON SYSUT2
    An error has occurred when accessing the dataset specified by the SYSUT2DD statement.
  • JCLGN0007U MISSING SYSPRINT
  • JCLGN0008U INVALID SYSPRINT
  • JCLGN0009U MISSING SYSIN
  • JCLGN0010U INVALID SYSIN
  • JCLGN0011U I/O ERROR ON SYSPRINT
  • JCLGN0012U I/O ERROR ON SYSIN
  • JCLGN0100U MISSING DD STATEMENT FOR filename
    You have referenced a data set from a program but your JCL does not include a DD entry for it.
  • JCLGN0101U INVALID DSORG FOR filename
    The data set's DSORG is inappropriate for the operation you are trying to perform.
  • JCLGN0102U I/O ERROR ON filename
  • JCLGN0103U I/O STATUS = file status
  • JCLGN0104U MFJGENER ABENDED system code
    See preceding messages for details of the error.
  • JCLGN0110I number RECORDS COPIED FROM SYSUT1 TO SYSUT2
  • JCLGN0111I number RECORDS COPIED
  • JCLGN0112I TO MEMBER NAME %
  • JCLGN0200E PARAMETER TOO LONG [value]
  • JCLGN0201E CONTINUATION ERROR [value]
  • JCLGN0202E MISMATCHED QUOTES OR PARENTHESIS [value]
  • JCLGN0210E UNRECOGNIZED OPERATOR KEYWORD [value]
  • JCLGN0211E DUPLICATE CONTROL STATEMENT [value]
  • JCLGN0220E UNRECOGNIZED OPERAND KEYWORD [value]
  • JCLGN0221E DUPLICATE OPERAND KEYWORD [value]
  • JCLGN0222E TOO MANY OPERANDS [value]
  • JCLGN0223E INVALID OPERAND VALUE [restriction]
    The restriction shows the values permitted.
  • JCLGN0224E UNEXPECTED OPERAND [%]
    Too many operands are present.
  • JCLGN0225E EXPECTED OPERAND MISSING [parameter]
    A required operand is missing from parameter.
Parent topic: JCL Error Messages


JCLIM Error Messages

Select the number of the message you require details about:

  • JCLIM0001U job-number job-name INVALID EXEC STATEMENT PARM
    MFJIMS expects parameter data on the EXEC statement, but the data has not been supplied.
  • JCLIM0002U job-number job-name INVALID PROGRAM TYPE PARM
    The program type specified in the PARM operand must be BMP (or IFP) or DLI (or DBB).
  • JCLIM0003U job-number job-name MISSING PROGRAM NAME PARM
    The program name has not been specified in the PARM operand.
  • JCLIM0004U job-number job-name MFIMS OPTION NOT INSTALLED
    MFJRRC00 is unable to locate the MFIMS software option.
  • JCLIM0005U - Program Parm Contains Invalid Character n
  • JCLIM0201U MISSING DDITV02 DD STATEMENT
  • JCLIM0202U INVALID DDITV02 PARM STATEMENT
  • JCLIM0203U INVALID DDITV02 PROGRAM PARM
  • JCLIM0204U I/O ERROR ON DDITV02 DATASET
  • JCLIM0205U - Missing DD Statement nnnnnn
  • JCLIM0206U - Invalid Dsorg For n
  • JCLIM0207U - Invalid/Missing Control Statement On n
  • JCLIM0208U - I/O Error On n
Parent topic: JCL Error Messages


JCLUT Error Messages

Select the number of the message you require details about:

  • JCLUT0001E job-number job-name Control statement error explanation
  • JCLUT0005E job-number job-name Continuation error
  • JCLUT0006E
  • JCLUT0007E
  • JCLUT0008E
  • JCLUT0009E
  • JCLUT0010E
  • JCLUT0100S MISSING "filename"
    The file cannot be found
  • JCLUT0101S INVALID "filename"
  • JCLUT0102S I/O ERROR ON "PDS member name"
    The PDS member does not exist or is invalid.
  • JCLUT0103S UTILITY "utility-name" ABENDED
    An error has caused the utility to abend.
  • JCLUT0104S DUPLICATE MEMBER "PDS-member-name"
    You have tried to create a PDS member but a member with that name already exists.
  • JCLUT0105S CATALOG ERROR ON "dataset-name"
  • JCLUT0106S RETURN CODE IS "value"
  • JCLUT0107S
  • JCLUT0108S
  • JCLUT0201I MEMBER "PDS-member-name" NOT FOUND
    You have tried to access a PDS member but there is no catalog entry for it.
  • JCLUT0202I RECORDS COPIED "number"
  • JCLUT0203I MEMBERS NAME "PDS-member-name"
  • JCLUT0204I MEMBERS WRITTEN TO OUTPUT DD "number"
  • JCLUT0205I INDD=OUTDD="filename", COMPRESS IN PLACE IGNORED
  • JCLUT0206S Character set mismatch. Copied without conversion
Parent topic: JCL Error Messages


JCLZZ9999S job-number job-name MESSAGE UNDEFINED MESSAGECODE

No message text has been defined for the specified message code.

Resolution:

Report the problem to Micro Focus Support.

Parent topic: JCL Error Messages


SORT - MFJSORT Error Messages

Select the number of the message you require details about.

Some message IDs are followed by a line of asterisks. The right-most asterisk indicates the position of the error in the preceding line. The message text is shown on the following line.

  • SORT000 - SORT099
  • SORT100 - SORT199
  • SORT200 - SORT399
Parent topic: JCL Error Messages


MFJSORT Summary Messages

After successfully completing a SORT operation, MFJSORT displays a summary of the operation, including information such as the number of records read and written. The following is an example of this summary information:

SORT204I: ********************* Sort Statistics *********************

SORT 205I: INPUT file 'SORTIN'

1267 record(s) input.

1252 record(s) used.

SORT206I: OUTPUT file 'SORTOUT'

1210 record(s) used.

1240 record(s) output.

SORT207I: OUTFIL file 'SORTFIL;

2 record(s) used

6 record(s) output

SORT399I: End of Micro Focus MFJSORT Utility

This provides the following information:

  • A total of 1267 records were read.
  • Of the 1267 records read, MFJSORT used 1252. MFJSORT might read a record but not use it because, for example, the record could fail to meet the conditions specified in an OMIT or INCLUDE statement, or records could be combined through the action of the SUM statement.
  • MFJSORT output 1210 records. This could be less than the number of records used because some of the released records failed to satisfy conditions specified in the OUTFIL OMIT or OUTFIL INCLUDE statements.
  • 1240 sorted records were written to SORTOUT. The 30 extra records above the number of returned records might be report headers or trailers.
  • For records for OUTFIL DD statements, MFJSORT used 2 records and output 6. The reasons for the difference between these numbers are the same as described above.

If the number of records read is the same as the number of records released, the messages for those two pieces of information are combined. Similarly, the messages showing the number of records returned and written are combined if their numbers are the same.

Parent topic: JCL Error Messages
Related information
SORT - MFJSORT Error Messages


JES Messages

These messages can be printed by the Job Entry Subsystem when a job is submitted or when output is printed.

Message | Description
JES000002E JCL parser not avaliable.
JES000003Ennnnn duplicates an existing job number. | The job # specified during submission duplicates an already existing job #. You need to reset your job # mechanism.
JES000011E Batch Spool File Error; Status nnnnnn. | While trying to access the spool, an unexpected file status was encountered. (nnnnn)
JES000012I Batch Input Spool has been cold-started. | There was no casspool.dat file located in the same directory as the System catalog that this server is configured to use. A new one has been created.
JES000013I JOB nnnnn requeued for restart at xxxxxx. | The job nnnnn has been queued for restart at the step (and where applicable the procstep) specified by xxxxxx.
JES000014E Job nnnnn not restarted. STEP xxxxxx does not exist. | The job nnnnn cannot be restarted because it does not contain the specified step (and where applicable the procstep) specified by xxxxxx.
JES000015I JOB nnnnn does not exist for restart. | The job specified does not exist. This may be because the job has been deleted by another user or by the spool housekeeping process.
JES000016E JOB nnnnn not executed. Undefined JES error. Inform Technical Support. | An attempt was made to restart a job that wasn't run with restart in effect, or files associated with the job have been deleted.
JES000017E JOB nnnnn job not restarted. | This error is displayed when the job or the step specified is non-restartable.
JES000024I Batch Printer: xxxxxx | The printer named ‘xxxxxx’ has been initialized.
JES000025E Printer not found: xxxxxx | The printer named ‘xxxxxx’ was not located while enumerating through the printers defined on this machine.
JES000026O Exit Module: xxxxxxxx | The batch printer specified in the previous JES000024I message is using a printer exit named ‘xxxxxxxx’
JES000027E Printer assignment failed. RC = nnnnn | A failure occurred while trying to set the default printer for the batch printer sep. A printer matching the specified name was found, but the setting as default printer for this SEP failed.
JES000028E Load fialed for exit Module: xxxxxxxx | A printer was found which matches the specified printer name, but the exit routine specified for this batch printer (xxxxxxxx) was not found.
JES000029I Locating batch printer: xxxxxx | An information message issued when a batch printer initializes, indicating which printer device is being searched for by this batch printing SEP
JES000029I xxxxxx on yyyyyy | Document xxxxxxxx is being printed by the batch printer on printer yyyyyyyy
JES000030E xxxxxx | While trying to print the document listed in the previous JES000029I message the spool tried to access the cataloged entry for this sysout dataset. There was a failure upon accessing the catalog specified by the message message
JES000031E Printer open failed. RC = nnnnn | A failure occurred in either the API call PC_PRINTER_OPEN or the API call PC_PRINTER_SET_FONT that occurs when a batch SEP tries to drive sysout output through to the defined printer. The failure return code is nnnnn
JES000032E Printer write failed. RC = nnnnn | A failured occurred while trying to write to the printer device attached to the batch printing SEP. The return code is documented in the API documentation for PC_PRINTER_WRITE
JES000033E Printer error accessing spool data: xxxxxx | A failure occurred while trying to access the physical dataset associated with sysout entry. The file status code of the failure is indicated by the message message.
JES000034E JOBnnnnn - TIME parameter exceeds 65533 seconds after applying class multiplier (xxxxxx).
JES000035E JOBnnnnn - TIME parameter exceeds 65533 seconds after applying class multiplier (xxxxxx)
JES000036E nnnnn xxxxxx
JES000040I SSTM environment established successfully. nnnnn
JES000041E SSTM initialization failure nnnnn
JES000042I SSTM not enabled: nnnnn
JES000050E JCL parsing error: RC = nnnnn. | While attempting to compile a piece of JCL for future execution, a failure occurred. The return code for the failure is documented by nnnnn
JES000051I Job Entry Subsystem (JES) services initialized. | The JES services for the process have been initialized
JES000052E Job Entry Subsystem (JES) initialization failed. Environment improperly configured. xxxxxxxx When a server is started, JES performs some validation checks to ensure that databases can be properly allocated. These fail messages indicate that this Initial Validation Process detected an error. The error indicates that the IVP was unable to allocate and test DSN on the system catalog. The likely causes are:
  • an error on the JES set tab
  • the System Catalog name is invalid or unusable
  • the Default Allocation Location is invalid or unusable
  • the environment variable MFALLOC_PROP is set
JES000222E JOB nnnnn cancelled by operator | Job # job-number was cancelled via the casout command -k option or via the ESMAC Spool view function
JES000913E JOBnnnnn User xxxxxx has an invalid password or no longer has auth to exec JCL.
JES000914E JOBnnnnn User xxxxxx is not a surrogate of User zzzzzz.
JES000915E JOBnnnnn User xxxxxx does not have authority to submit job zzzzzz.
Parent topic: JCL Error Messages


Enterprise Server Security

This help volume contains information and procedures for all aspects of securing an Enterprise Server installation.

  • Securing an Enterprise Server Installation
  • Using the Security Audit Manager
    The topics in this section describe how to configure and use the Enterprise Server Security Audit Manager.
  • Securing Communications
    The topics in this section describe the process of using SSL and PKI certificates to secure Enterprise Server communications.
Parent topic: Configuration and Administration


Securing an Enterprise Server Installation

The topics in this section describe the security features available in an Enterprise Server installation, and how you can use these features to implement a security policy.

This help also includes the context-sensitive information available from the user interface. To access the help, select Help > This Page from the left pane.

Note: The context information in this help volume is the most up-to-date version.
  • Architecture and Overview
  • Configuring Enterprise Server Security
  • Configuring External Security Facility (ESF) from the Command Line
  • Using the MFDS Internal Security Module
  • Configuring Operating System Security: osesm
  • Configuring Security using Active Directory
  • Configuring Security Using OpenLDAP
  • Examples
  • Managing an LDAP from the Enterprise Server UI
  • Migrating from Enterprise Server Early Versions
  • Security Reference Information
  • Glossary
Parent topic: Enterprise Server Security


Architecture and Overview

The topics in this section describe the Enterprise Server security architecture, and provide an overview of the configuration process.

  • About Securing an Enterprise Server Installation
  • Security Architecture
Parent topic: Securing an Enterprise Server Installation


Security Architecture

The Enterprise Server security architecture accommodates mainframe-style security for:

  • Migrated applications
  • The security mechanisms found in distributed systems
  • Custom solutions

This architecture allows you to configure multiple security mechanisms and repositories, so that you can separate the management of different types of resources.

Communication between clients and the server can be secured through the use of SSL.

  • System Components and Process Flows
  • About the External Security Facility (ESF)
  • About Security Managers
  • About Security Queries
  • Designing the Security Policy
Parent topic: Architecture and Overview


System Components and Process Flows

When a user attempts to access an Enterprise Server feature or application, or when an application attempts to access a controlled resource, Enterprise Server's External Security Facility (ESF) submits a security query to the appropriate ESMs to authenticate or authorize the action.

The illustration below shows the components involved in securing an installation, and the communications between each.

  • When they log on to a system, Enterprise Server administrators are authenticated against any security managers that are configured for the Directory Server. Access to Enterprise Server configuration is denied unless the authentication is successful.
  • When an Enterprise Servers accesses a resource, for example programs or databases, the request is authenticated against the security managers configured for the Enterprise Server. Access to the resource is denied unless the authentication is successful.
  • Security managers can use LDAP repositories to verify authentication requests.

Parent topic: Security Architecture


About the External Security Facility (ESF)

The ESF operates for both Enterprise Server and Directory Server access.

The ESF relays application and resource access authorization request queries to the security manager or Managers. It is responsible for:

  • Loading and invoking security managers
  • Sending security queries to the security managers
  • Managing a cache of the modules and security access query results
  • maintaining configuration information for itself and the security managers

The ESF performs security checks by making API calls to the ESMs, and processing the result that is returned. You can use this API to develop your own security managers. You can then use these security managers to process authentication requests, and allow or deny access as appropriate. A security manager can be anything that can process ESF API calls.

The External Security Facility API documentation is available, in doxygen format, on the Micro Focus Supportline website's Examples and Utilities page.

  • Follow this link to the Examples and Utilities page:

    Micro Focus Supportline Examples and Utilities page

  • Follow this link to the External Security Facility API documentation:

    External Security Facility Manager API

If no security manager recognizes a user, that is each security manager returns unknown, you can configure a default response.

Parent topic: Security Architecture


About Security Managers

Security managers process the security queries generated by the ESF, and return either an allow, deny or unknown status. You can configure multiple security managers in an installation;'s security manager pool. From the pool, you can create a default list of the security managers to use, and lists for individual Enterprise Servers.

Note: Security managers are sometimes refered to as External Security Managers, or ESMs.

The ESF sends security queries to the security managers in the order in which they are configured in the list.

You configure Enterprise Server to:

  • Authorize access when the first security manager authenticates it.
  • Authorize access only when all security managers authenticates it.
  • Authorize or block access requests that return an unknown status.

Enterprise Server includes the following security managers that you can configure and use:

  • osesm

    This security manager provides access to the Windows operating system's user configuration. You can use it to authenticate Windows users, determine a user's access level and apply permissions accordingly.

  • mldap_esm

    This security manager allows you to integrate your Enterprise Server security with an LDAP. You can use mldap_esm with both Microsoft Active Directory, and other LDAPs, for example OpenLDAP. With mldap_esm, you can implement access control for users, and for the resources and files that an application uses.

  • MFDS Internal Security

    Directory Server security can be implemented hrough the MFDS internal security manager. This security manager is used for Directory Server when no other security manager is present in its security manager list. It allows you to define users and groups, and restrict access to Enterprise Server administration functions.

  • CASESM

    The CAS ESM Module (casesm) uses the Enterprise Server legacy security definitions (stored in the CICS resource tables). This is the model used in earlier releases (5.0 and lower),

    This allows you to use any security configurations from software releases prior to release 5, that uses the current architecture.

In addition to the above, a security managers can be anything that can process the API security queries that the ESF generates, and can return results to the ESF. You can develop a security manager to suit your requirements. A security manager could be a database, a directory, or an operating system mechanism

Parent topic: Security Architecture


About Security Queries

During applications processing and the running of the Directory Server, Enterprise Server submits security queries to the External Security Facility (ESF), to verify that a user or system action is authorized. The ESF generates the appropriate API call and forwards this request to each configured security manager in turn.

The most common security queries are:

  • Authenticating user credentials, for example when the user signs on.
  • Checking that a user has the appropriate authorization to perform a particular task on a particular resource

A successful verify query establishes a security context (such as a session logon) within which further operations are performed. If the user or application performs subsequent operations outside this context, further authorization calls are made to check that he or she has appropriate authorization.

There are two types of authorization queries used by the External Security Facility:

  • The first, used by Enterprise Server when processing MSS application requests, implements mainframe-style permissions. In this approach, a user is granted a permission level that includes all the "lower" permissions (write access implies read access and so on).
  • The second type of query is currently used only by MF Directory Server. It implements more modern discretionary access controls (DACs). In this approach, permissions are separate from one another. For example, a user can have write access but not read access to a resource.
Note:

This issuing of security queries during MSS processing is intended to emulate, as far as is feasible, the behaviour found on IBM mainframe platforms. For more information on these security queries, refer to your mainframe documentation.

Parent topic: Security Architecture


Designing the Security Policy

The design and introduction of security policy requires careful planning to ensure that the measures adopted are appropriate to the systems being used. Such considerations are beyond the scope of this documentation. This topic gives a brief overview of the steps involved in using the Security Facility to control user authentication and authorization, and resource access control.

  1. Before you can use the Security Facility, you must decide which external security managers you are going to use and, if you plan to use multiple security managers, how you want to divide the responsibilities between them. Most installations use a single external security manager.
  2. Having done this you must define, within the repositories used by those managers, the users, resources and rules that you require. This may involve migration of user and resource details from legacy Directory Server and Enterprise Server security definitions, and in the case of LDAP repositories used with the MLDAP ESM Module, modifications to the schema to support the security information.
  3. The next step is to specify within Directory Server the security managers, the ESM Modules that will be used to connect to them, and the associated configuration information. In doing this you create a pool of security manager definitions from which you can choose the ones that you require for particular enterprise servers.
  4. At this point, you can begin to define security configuration options. You can have different configuration options for individual enterprise servers, and for Directory Server. You can also have a default configuration that applies to any enterprise server that does not have its own configuration.
  5. The configuration options include an ordered list of references to the security managers that you will use. Hence, as with the other options, you can use different lists for Directory Server and individual enterprise servers, and you can have a default list used by multiple servers.

    The order of the managers on the list determines the order in which they are queried when handling a security request, and this may, depending on other configuration options, affect the result of a query.

    You can now add the appropriate security managers from the security manager pool to the list that you are using.

Parent topic: Security Architecture


Configuring Enterprise Server Security

You convigure security using the Enterprise Server Administration user interface. You can use this interface to configure installation-wide security configurations, and to configure security for each enterprise server in the installation. This section details the tasks required to do this.

  • Security Configuration Stages
  • Adding a Security Manager to the Pool
  • Enabling a Security Manager
  • Defining a Security Manager List
  • Setting MF Directory Server Security Configuration
  • Customizing the Security Settings for an Enterprise Server Instance
  • Implementing Security Manager Changes
Parent topic: Securing an Enterprise Server Installation


Security Configuration Stages

Configuring the security managers to use involves the following stages:

  1. Add the security managers that you plan to use to the pool, so that they are available for use in your configurations.
  2. Define the list of the security managers to use with Enterprise Server instances, and the order in which they are used.

    You can then use this configuration with multiple Enterprise Server instances

  3. Repeat the previous step to define the security configuration for the Micro Focus directory server.
    Note: To avoid issues with resource access, it is recommended that you use the same configuration for Micro Focus directory server and the enterprise server instances that it manages.
  4. Customize the security configuration for each enterprise server that requires it.
  5. Update security managers as required, and implement the changes.
Parent topic: Configuring Enterprise Server Security


Adding a Security Manager to the Pool

Before you can use an External Security Manager (ESM) in your configuration, either in the default security configuration or to configure individual enterprise servers, you need to make it available by adding it to the MFDS security manager pool.

Once it is in the pool, you can configure it and set it to verify access.

  • To Add or Remove a Security Manager in the Pool
  • To Edit a Security Manager's Properties
Parent topic: Configuring Enterprise Server Security


To Add or Remove a Security Manager in the Pool

  1. On the menu at the left side of the Enterprise Server Administration Web page, under Configure, click Security .
  2. Click the Security Managers tab, and click Add.
  3. Specify the details of the ESM to add. The minimum information required is a unique name with which to identify the definition, and the name of the external security manager module that will be used to pass security queries to the relevant external security manager. At the left of the screen, select the Help > This Page option for detailed information on the options.
  4. Click Add.

    The ESM is added to the pool and is available for use in your configurations.

To remove an ESM from the pool, select it and click Remove.
Parent topic: Adding a Security Manager to the Pool
Related tasks
To Configure a Security Manager's Environment
Related information
To Edit a Security Manager's Properties


To Edit a Security Manager's Properties

Once you have added a security manager to the pool, you can edit its properties.

  1. On the menu at the left side of the Enterprise Server Administration Web page, under Configure , click Security .
  2. Click the Security Managers tab, and in the list, select the security manager to edit.
  3. Click Edit.
  4. Specify the details of the security manager.
    Name

    Specify the name used to identify the security manager.

    Module

    Specify the module used to access an external security manager or to implement the security rules. If you specify it with a relative path (which includes no path) it is relative to %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin.

    Connection Path

    If the module requires a connection string that tells it how to connect to the external security manager, specify it here.

    The information supplied in the string and its format depend on the module that you are using. For details, please see the documentation supplied with the module.

    Authorized ID and Password

    If the module requires credentials to connect to the external security manager, specify them here.

    As with the connection path, the content and format of these fields depend on the module that you are using. For details, please see the documentation supplied with the module.

    Enabled

    Check this to enable this security manager. If it is disabled, it will be ignored by Directory Server and those enterprise servers that reference it.

    Cache limit

    If the module has a configurable cache for holding responses from the security manager, enter its maximum size in kilobytes here.

    Cache TTL

    If the module has a configurable cache for holding responses from the security manager, enter the maximum time in seconds that an entry in the cache can be used to satisfy requests before the details must be requeried from the security manager.

    Note: Enterprise Server and Directory Server also have their own configurable caches for security information. These are checked before submitting queries to the security manager module.
    Description

    Specify a description of the security manager.

    Configuration information

    Specify any additional configuration settings that the module requires.

    Properties

    Click this to access pages for the management of users, groups and resources controlled by this security manager.

    Important: You will only be able to manage users, groups and resources where the security manager is on the priority list used by Directory Server. That is:
    • if Directory Server uses the Default ES Security configuration, the security manager must be on the Default ES Security manager list
    • if Directory Server uses its own configuration options, the security manager must be on the Directory Server's own security manager list

    In addition, the ESM module and the external security manager to which it connects must also support user, group and resource administration via the Security Facility.

  5. Click OK to save the changes and return to the Security Managers screen. Alternatively, click Apply to save the changes and remain on the current screen.
Parent topic: Adding a Security Manager to the Pool
Related tasks
To Configure a Security Manager's Environment
To Add or Remove a Security Manager in the Pool


Enabling a Security Manager

A security manager must be enabled before it can be used to manage securit. If a security manage is disabled, it is ignored by Micro Focus Directory Server and by all enterprise servers instances.

To disable the security manager for Micro Focus Directory Server only, or for a particular enterprise server in your installation, you must remove it from the relevant security manager list.

  • To Enable or Disable a Security Manager
Parent topic: Configuring Enterprise Server Security


To Enable or Disable a Security Manager

  1. On the menu at the left side of the Enterprise Server Administration Web page, under Configure, click Security.
  2. Click Security Managers.
  3. Select the security manager to enable or disable, and click Edit.
  4. Check or un-check Enabled, and click OK.
    Note:

    This globally disables the security manager, so that it is ignored by Directory Server and by all enterprise servers. If you only wish to disable the security manager for Micro FocusDirectory Server or for a particular enterprise server, you must remove it from the relevant security manager list.

Parent topic: Enabling a Security Manager


Defining a Security Manager List

Once you have added security managers to the pool, you can create a default list of the security managers to use, and select to enable or disable each. If you disable a security manager, it is not used in the authorization process, even when it appears in the list of security managers to apply.

This list is used by default for each new Enterprise Server instance that you create.

  • To Add a Security Manager to the Default ES Security Manager List
  • To Set Default Enterprise Server Security Configuration
Parent topic: Configuring Enterprise Server Security


To Add a Security Manager to the Default ES Security Manager List

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Default ES Security.
  3. In the Security Manager List, click Add.
  4. Select the definition that you want to add to the list by clicking the relevant radio button in the Select column.
  5. Click Add .
Note:
  • You cannot add the same definition to the list more than once. You can however have more than one security manager definition that uses the same external security module in the security managers pool.
  • Where you are running MF Directory Server with Restrict administration access set, and you make a change to the security manager list that it uses, you are challenged to supply:
    1. a set of credentials that are valid with the configuration prior to the changes being applied

      and

    2. a set of credentials that will be valid with the configuration after the changes are applied. This is to ensure that you can still access the MF Directory Server screens.

    If appropriate credentials are not supplied or are not valid, the changes will not be applied.

Parent topic: Defining a Security Manager List


To Set Default Enterprise Server Security Configuration

You can create a list of security managers to use as a default. Enterprise servers can use this as the default configuration. You must have added security managers to the pool before they can be configured in the default list.

  1. On the menu at the left side of the Enterprise Server Administration Web page, under Configure, click Security .
  2. Click the Default ES Security tab.

    The default security manager list is displayed.

  3. Select the security manager, and use the Up and Down arrows at the right of the list to position the security manager where you want it.

    When performing security checks, Enterprise Server validates against the security managers in the order in which they appear in the list.

  4. Complete the rest of the configurations on the screen.

    At the left of the screen, select the Help > This Page option for detailed information on the options.

Parent topic: Defining a Security Manager List


Setting MF Directory Server Security Configuration

You can configure the security configuration for the directory server. You can select to use the default MFDS Internal Security or you can configure security managers to validate against.

Note:
  • It is best to configure MFDS to use the default security configuration. If you do not do this, the enterprise server instance may not start because the Windows user account configured for starting ES is not known to the default MFDS security configuration.
  • The default MFDS Internal Security can only be used by itself. If you use this, you cannot configure any other security managers.
  1. On the menu at the left side of the Enterprise Server Administration Web page, under Configure, click Security.
  2. Check the Restrict administration access check box.
    This sets that security checks are applied to the directory server.
    Note: When you check this option, a login screen is displayed when you log on or change configurations. The user details you enter are verified against the security configurations.
  3. In the lower half of the screen under Security Manager List, click Change to display a list of the security managers configured.
  4. Select the security manager to add, and click Add.

    The security manager is added to the MFDS list.

  5. Use the Up and Down arrows at the right of the list to position the security manager where you want it.

    When performing security checks, Enterprise Server validates against the security managers in the order in which they appear in the list.

  6. Complete the rest of the configurations on the screen.

    At the left of the screen, select the Help > This Page option for detailed information on the options.

  7. Click OK or Apply to apply your configurations.
  • To Set the MF Directory Server Security Configuration
Parent topic: Configuring Enterprise Server Security


To Set the MF Directory Server Security Configuration

Configure MF Directory Server to use the same security configuration. If you do not do this, the enterprise server may not start because the Windows user account configured for starting ES is not known to the default MF Directory Server security configuration. If you don't want to change the MFDS security configuration now, you can add that user to MF Directory Server directly by editing the MFDS Internal Security security manager and clicking on Properties.

To use the same security configuration for Enterprise Server instances and MF Directory Server:

  1. Return to the MF Directory Server Security Options page if necessary, and select the MF Directory Server tab.
  2. Check the Use default ES Security Manager List checkbox.
  3. Click Apply. The MF Directory Server tab should now show the same security manager(s) as Default ES Security.
Parent topic: Setting MF Directory Server Security Configuration


Customizing the Security Settings for an Enterprise Server Instance

For each enterprise server, you can use the default security manager configuration, or you can configure the security managers to use for the particular server.

  • To Set Security Configuration Options for an Enterprise Server
Parent topic: Configuring Enterprise Server Security


To Set Security Configuration Options for an Enterprise Server

For each enterprise server, you can use the default ESM configuration, or you can configure the ESMs to use for the particular server.

  1. From the Enterprise Server Administration home page, click Edit for the relevant enterprise server.
  2. Click the Security tab.
  3. To use the default set of configuration settings, check Use default security configuration.
  4. To use a non-default configuration, add the ESMs to use in the Security Manager List area at the bottom of the screen.
  5. Use the Up and Down arrows at the right of the list to position the ESM where you want it.

    When performing security checks, Enterprise Server validates against the ESMs in the order in which they appear in the list.

  6. Complete the rest of the configurations on the screen.

    At the left of the screen, select the Help > This Page option for detailed information on the options.

Parent topic: Customizing the Security Settings for an Enterprise Server Instance


Implementing Security Manager Changes

If you are using an external security manager and you make changes to the security information (such as adding a user or changing group membership), there are two ways in which you can notify Enterprise Server so that it uses the updated information:

  • The Enterprise Server Administration interface
  • The esfupdate utility
  • To Update using the Enterprise Server Administration Interface
  • To Update Security Manager Changes Using esfupdate
Parent topic: Configuring Enterprise Server Security


To Update using the Enterprise Server Administration Interface

To use the Enterprise Server Administration Interface to update a server instance with changes to a security manager:

  1. On the menu at the left side of the Enterprise Server Administration Web page, under Configure , click Security .
  2. Click the Security Managers tab.
  3. Below the list of configured security managers, click Update Allon the Security Manager Pool page.

    This retrieves the latest security information from the external security manager.

Use the following steps to update the security managers used by the Directory Server:

  1. On the menu at the left side of the Enterprise Server Administration Web page, under Configure , click Security .
  2. Click the MF Directory Server tab.
  3. Check the Update when external Security Manager properties change check box.
Parent topic: Implementing Security Manager Changes


To Update Security Manager Changes Using esfupdate

If you are using an external Security Manager and changes are made to the security information (such as adding a user or changing group membership), there are two ways in which you can notify Enterprise Server so that it uses the updated information:

  • The Enterprise Server Administration interface .
  • The esfupdate utility

This topic describes the steps required to use the esfupdate utility.

The syntax of the esfupdate utility is as follows:

esfupdate [options]update-type[entity-name]
Options
A series of actions to perform. Possible values are:
Switch | Action | Meaning
-a | action | The update action to perform. One of "add", "delete", "modify" or "other". The default is "modify".
-u | user | The username for binding to Directory Server.
-p | password | The password for binding to Directory Server.
-m | host[:port] | The location of Directory Server. The default is localhost:86.
-r | server | The name of the server(s) to update. This can include wildcards.
-M | Updates the Directory Server.
-v | Displays version information and exit.
-h | Displays syntax information and exit.
update-type
One of "user", "group", "resource", "users", "groups", "resources", or "all".
entity-name
Must be supplied if update-type is "user", "group" or "resource". Otherwise omitted.

Comments

If user and password are not supplied, esfupdate attempts to bind to Directory Server anonymously.

If user is supplied but not password, you will be prompted for it.

If neither -M nor -r are specified, update notifications are sent to Directory Server and all running servers.

The example below notifies the Directory Server and any running enterprise servers that the user SAFU has been modified. This could mean that its Mainframe Subsystem Support user attributes (such as user priority) have been changed, or that it has been added to (or removed from) a group. It will bind to Directory Server as the "SYSAD" user.

esfupdate -u CN=SYSAD -p SYSAD user SAFU
Parent topic: Implementing Security Manager Changes


Configuring External Security Facility (ESF) from the Command Line

esfadmin is a command-line utility that calls the ESF Admin API to request administrative actions against ESMs. It is a part of Studio Enterprise Edition and Server Enterprise Edition, and can be found in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory.

One advantage of esfadmin is that it can be used to perform batch updates to an ESM, typically as part of a script. Another is that you supply all its configuration information on the command line, so you do not have to configure your MLDAP security manager in MFDS with an LDAP administrative user ID.

  • About the esfadmin Command
  • esfadmin Sub-commands
Parent topic: Securing an Enterprise Server Installation


About the esfadmin Command

The esfadmin command line includes options, a subcommand, and one or more parameters.This section discusses subcommands and parameters.

Each subcommand is a single word, telling esfadmin what task you want to perform. Parameters are name and value pairs in the form name=value. If the value contains spaces or other characters that are significant to the command processor or shell you’re using, you’ll need to quote or escape them. Subcommands and parameter names are case-insensitive, but parameter values may be case-sensitive, depending on the parameter and the ESMs that process the request.

For each subcommand, one or more parameters identifies the object (user, group, resource class, or resource access control definition) you’re operating on. These parameters are required. Other parameters set attributes of that object; they are optional in most cases. Note that some ESMs may require certain parameters be set even if ESF doesn’t. For example, the standard LDAP schema supplied by Micro Focus requires that resource objects have a value for the microfocus-MFDS-Resource-class attribute (even though it’s not used—this is for historical reasons), which is set by the “class” parameter when using esfadmin, so if you try to add a resource object without specifying class=somevalue you will get an error. These requirements are noted below.

The UID attribute is a special case. It is required by the LDAP schema, but if you do not supply one for an ADD operation, the MLDAP ESM Module will generate one for you.

Most of the subcommands have the same form: ADD, ALT (alter), DEL (delete), or LIST, followed by an object type: USER, GROUP, CLASS, or RESOURCE. There are also SETPASSWORD and SETOPTIONS commands. ADD and ALT commands are described in the same topic, since they use the same parameters.

The LISTx commands list all matching objects (see the LISTUSER topic for an example of using a pattern with wildcards for a list command) and their attributes. The SETPASSWORD command is used to reset a user’s password. The SETOPTIONS command is not currently used.

  • esfadmin Command Syntax
  • esfadmin Usage Notes
  • Setting User Passwords with esfadmin
Parent topic: Configuring External Security Facility (ESF) from the Command Line
Related reference
esfadmin Command Syntax


esfadmin Command Syntax

Syntax:

esfadmin [options] subcmd [keyword=value | keyword]...

Used to update the security definitions in active External Security Managers. It calls the Enterprise Server External Security Facility (ESF) to submit requests.

Parameters:

The options are:

-a | Do not audit. By default, esfadmin sends audit information for each request to the ESF Audit Facility.
-cconfig file Specifies the name of a configuration file for the MLDAP ESM Module. This is a text file, in the same format as the "Configuration Information" area in the Security Manager definition.

Usage: esfadmin -cldap-config.txt where ldap-config.txt contains:

[LDAP]
base=CN=Micro Focus,
CN=Program Data,
DC=mycorp,DC=com
-uESF user A valid ES account that will be used to sign on to the ESF. The default is: SYSAD

Usage:

esfadmin -uSYSAD

-pESF password. | The associated password. The default is: SYSAD
-UESM user A valid username for the External Security Manager; for example, with MLDAP, a user account with appropriate access to the LDAP repository.

If this is not supplied, then for commands other than the LIST commands, esfadmin will prompt for the ESM username. (For LIST commands, esfadmin will let the ESM module use its default credentials.

-PESM password The associated password.

If this is not supplied, then for commands other than the LIST commands, esfadmin will prompt for a password.

-Sserver URL Specifies the connection path for the LDAP server.

Usage:

esfadmin -S ldap://adhost

The sub commands are:

ADDUSER, ALTUSER, DELUSER, LISTUSER
ADDGROUP, ALTGROUP, DELGROUP, LISTGROUP
ADDCLASS, ALTCLASS, DELCLASS, LISTCLASS
ADDRESOURCE, ALTRESOURCE, DELRESOURCE, LISTRESOURCE
SETPASSWORD, SETOPTIONS

Comments:

The subcommand specifies the function to be performed. Each function requires one or more parameters. Parameters consist of stand-alone keywords and keyword-value pairs. Keyword-value pairs should be entered with no spaces between the keyword, the equal sign, and the value. Values that contain spaces or other special characters should be quoted, as required by the shell.

Parent topic: About the esfadmin Command
Related concepts
esfadmin Usage Notes
About the esfadmin Command
esfadmin Sub-commands
Related information
Setting User Passwords with esfadmin


esfadmin Usage Notes

Note the following points when using esfadmin:

  • You cannot move or rename an object in the security manager because you cannot specify the parameter once to identify it, and then again to give it a new name. You must use ADDx to create the new one, and then DELx to delete the old one. The ALTx commands will let you change the other parameters of an object, for the most part.
  • You can't change a resource's class by changing its CLASS attribute. That attribute exists (and must have a value), but that's a historical vestige. To change a resource's class, you have to create a new resource of the same name under the new class using ADDRESOURCE, and then delete the old one.
  • LISTUSER shows a user's group memberships, for convenience, but that's not actually an attribute of a user. So you can't use ALTUSER to change what groups a user belongs to (except for the user’s default group). You have to use ALTGROUP to change a group to add or delete a user from it.
  • LISTRESOURCE can only list resources from a single class. To list all resource definitions matching a certain pattern, you must use one LISTRESOURCE command per resource class.
  • When you change a group member list with ALTGROUP, you completely rewrite it. Be careful to ensure that only one administrator is changing a group’s membership at a time, or changes could be lost.
  • To change a resource's access control list (ACL), you list the ACEs as the value of the ACL parameter, separated by semicolons or newlines. For example:

    esfadmin ... ALTRESOURCE ...

    ACL="allow:SYSADM group:read;allow:CICSUSER:read"

    This has the same issue as updating group membership—it replaces the entire ACL, so make sure you have all the ACEs you want in the string, and watch out for races if multiple people might be making updates at the same time.

Parent topic: About the esfadmin Command
Related reference
esfadmin Command Syntax
ADDGROUP and ALTGROUP
ADDCLASS and ALTCLASS
ADDRESOURCE and ALTRESOURCE
ADDUSER and ALTUSER
DELCLASS
DELGROUP
DELRESOURCE
DELUSER
LISTCLASS
LISTGROUP
LISTRESOURCE
LISTUSER


Setting User Passwords with esfadmin

If you edit a user's password (the microfocus-MFDS-User-Pwd attribute) directly in the LDAP repository, using a tool such as ADSIEdit, you can only set a literal password value. This is often not satisfactory because the password can be seen by anyone who can read the repository.

If you have enabled MFDS administration of the LDAP repository, you can use MFDS to change a user's password. To do this, go to the MFDS security options, view the list of Security Managers, select the MLDAP manager, click the Properties button, edit the user, and set a new password. See the MFDS documentation for more information.

Another alternative is to use the esfadmin utility.

To set a password using the esfadmin command, you will need a valid ES username and password (not necessarily the user whose password you're setting), and an LDAP username and password for an account with write access to the user's record in the repository. esfadmin has to sign on to ESF before it can perform an admin request, which is why you need an ES username / password.

You set a password using the setpassword option:

esfadmin [options] setpassword user=username password=new-password

esfadmin will prompt for the LDAP user ID and password. (The user ID is usually specified as an LDAP DN, eg CN=admin,CN=ADAM Users,CN=Micro Focus,CN=Program Data,DC=local; or as a Windows username with domain, eg domain\admin.) You can also specify these on the command line using the -U and -P options (note these must be uppercase-U and uppercase-P).

By default esfadmin uses "SYSAD", one of the default accounts created during setup, for the ES username and password it uses to sign on to ESF. You can supply a different username and password with the -u and -p (both lowercase) options.

Parent topic: About the esfadmin Command
Related reference
esfadmin Command Syntax


esfadmin Sub-commands

The esfadmin command can use the following sub-commands:

  • ADDCLASS and ALTCLASS
  • ADDGROUP and ALTGROUP
  • ADDRESOURCE and ALTRESOURCE
  • ADDUSER and ALTUSER
  • DELCLASS
  • DELGROUP
  • DELUSER
  • DELRESOURCE
  • LISTCLASS
  • LISTGROUP
  • LISTRESOURCE
  • LISTUSER
  • SETOPTIONS
  • SETPASSWORD
Parent topic: Configuring External Security Facility (ESF) from the Command Line
Related reference
esfadmin Command Syntax


ADDCLASS and ALTCLASS

Description

Add a new class/modify an existing class.

Required parameters

CLASS=name
Name of the resource class

Optional parameters

DESC=description
Description text.
Note: Classes are just standard LDAP container objects, so all they have is a name and an optional description.
Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


ADDGROUP and ALTGROUP

Description

Add a new group/modify an existing group.

Required parameters

GROUP=name
Name of the group.

Optional parameters

MEMBERS=user list
List of users, separated by semicolons. See the note regarding setting group membership in the esfadmin Usage Notes topic.
DESC=description
Description text.
CUSTOM=string
Custom text (not used by Micro Focus).
UID=string
Unique ID (is automatically generated if not supplied with the request).
Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


ADDRESOURCE and ALTRESOURCE

Description

Add a new resource/modify an existing resource.

Required parameters

RESOURCE=name
Name of the resource.
CLASS=name
Name of its class. Required, but not used by Micro Focus.

Optional parameters

ACL=list of ACEs
ACEs separated by semicolons.
DESC=description
Description text.
CUSTOM=string
Custom text (not used by Micro Focus).
UID=string
Unique ID. If not supplied, one is generated automatically.
Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


ADDUSER and ALTUSER

Description

Add a new user/modify an existing user.

Required parameters

USER=username
Name of the user to add or change.

Required by standard MF LDAP schema for ADDUSER:

PRIORITY=integer
MSS user priority (0-255).
TIMEOUT=integer
MSS user timeout in minutes.
OPCLASS=integer
MSS operator class (usually 0).
ALLOW=TRUE|FALSE
Whether user can sign on.
Note: The TRUE|FALSE values must be in block capitals as shown.

Optional:

NAME=display name
User’s display name.
DESC=description
Description text.
GROUP=group name
Default group.
EXPIRES=yyyymmdd
Account expiration date.

The date format depends on the ESM in use. With the MLDAP ESM, you need to use the date format required by the LDAP server. You need to check to determine what this format is.

For example:
EXPIRES=YYYYMMDDHHMMSS.0Z
where 0Z represents the GMT zone.
PASSWORD=string
Password (will be stored as MF-MD5 salted hash).
PASSEXP=<date>

Password expiration date.

The date format depends on the ESM in use. With the MLDAP ESM, you need to use the date format required by the LDAP server. You need to check to determine what this format is.

For example:
PASSEXP=YYYYMMDDHHMMSS.0Z
where 0Z represents the GMT zone.
PASSCHG=TRUE|FALSE
Whether user must change password.
Note: The TRUE|FALSE values must be in block capitals as shown.
GRPPFX=string
MSS group prefix (currently unused).
OPID=xxx
MSS operator ID (three characters).
GETTOKEN=none|self|any
Permission to create passtokens.
USETOKEN=none|self|any
Permission to use passtokens.
CUSTOM=string
Custom text (not used by Micro Focus).
UID=string
Unique ID. If not supplied, one is generated automatically.
Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


DELCLASS

Description

Delete a class.

Required parameters

CLASS=name
Name of the resource class to delete.
Warning: All resource access control definitions in this class will also be deleted!
Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


DELGROUP

Description

Delete a group.

Required parameters

GROUP=name
Name of the group to delete.
Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


DELUSER

Required parameters

USER=name
Name of the user to delete.
Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


DELRESOURCE

Description

Delete a resource.

Required parameters

RESOURCE=name
Name of the resource to delete.
CLASS=name
Name of its class.
Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


LISTCLASS

Description

List the classes.

Required parameters

CLASS=pattern
Pattern name, optionally with “*” wildcards.
Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


LISTGROUP

Description

List the groups.

Required parameters

GROUP=pattern
Group name, optionally with “*” wildcards.
Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


LISTRESOURCE

Description

List the resources.

Required parameters

RESOURCE=pattern
Resource name, optionally with “*” wildcards.
CLASS=name
Name of class to search.
Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


LISTUSER

Description

List the users.

Required parameters

USER=pattern
User name, optionally with “*” wildcards.

Example

esfadmin listuser user="A*"

Lists all users with names beginning with “A”.

Parent topic: esfadmin Sub-commands
Related concepts
esfadmin Usage Notes


SETOPTIONS

Not currently in use.

Parent topic: esfadmin Sub-commands


SETPASSWORD

Description

Sets or resets a user password.

Required parameters

USER=name
Name of user whose password is being reset.
PASSWORD=string
New password (will be stored as MF-MD5 salted hash).
Parent topic: esfadmin Sub-commands


Using the MFDS Internal Security Module

You can use the MFDS Internal Security Module to secure the directory server or enterprise servers.

Note: This module cannot be used with any other security managers. It must be the only module configured.

With the the MFDS Internal Security Module, the ability to view, and to alter, objects and schema settings within Directory Server is controlled through a system of user accounts, user groups and permissions.

With this module in place, Enterprise Server administrators must log on. The features available to login IDs are controlled by permissions. You grant permissions to a user group. The users within that group can then perform the actions governed by those permissions.

  • Working with Users, Groups and Resources
  • Application Access and Administration Access
  • Understanding Users and Groups
  • Understanding Permissions
  • Managing Users and Groups
Parent topic: Securing an Enterprise Server Installation


Working with Users, Groups and Resources

Note: Typically, you can maintain user, group and resource information for the MFDS Internal Security manager only. If you use an external security manager, you would normally use the updating functionality associated with the particular LDAP that you are using to maintain this information. Check the documentation provided with your ESM module for details.

The property screens for the MFDS Internal Security manager can be used for adding, editing and deleting user, group and resource definitions held in this manager, and for specifying resource permissions.

In addition to the conditions listed above, the MFDS Internal Security manager definition must be used by MF Directory Server.

In order to use these property screens, your user account must have User Administration permissions. See Resource Classes for MF Directory Server for details.

Parent topic: Using the MFDS Internal Security Module


Application Access and Administration Access

When Directory Server is using the MFDS Internal Security Manager, any enterprise server that connects to the Directory Server to obtain or modify configuration information must supply valid user credentials. If, in addition, you have set the Restrict administration access configuration option, any user wanting to use the administrative features must provide credentials to log on. The features available to the user or application are controlled by permissions. You grant permissions to a user group. The users within that group can then perform the actions governed by those permissions.

Parent topic: Using the MFDS Internal Security Module


Understanding Users and Groups

When you connect to Enterprise Server Administration for a Directory Server that is running in restricted mode, you are presented with a summary screen. This screen shows basic details of the enterprise servers managed by the Directory Server.

Before you can perform any other actions, you must log on. To do this you require a user account. Directory Server comes with a number of preconfigured user accounts but you can create others.

When you have logged on, the features that you can use depend on the permissions granted to the user groups of which your user is a member.

Each user can be in many user groups. Again, Directory Server has several preconfigured groups and you can create others. Each of the preconfigured groups has appropriate permissions for a particular administrative task. One or more of the supplied users are assigned to each of the groups, with the exception of the System group, which is used by Micro Focus applications.

Group | Description | Preconfigured users assigned
All Users | This is the most limited group. Its default Enterprise Server permissions are set as Read only. This permission enables a user in the group to view configuration information for enterprise servers. All users are included in this group. | schemaadmin, adddelete, modify, administrator
Add/Delete This group has default Enterprise Server permissions that enable:
  • the addition and deletion of servers
  • the addition and deletion of services, listeners and packages to servers
adddelete, administrator
General Administrators | This group has default enterprise server permissions that enable all administration activities for enterprise servers. It also has permissions allowing all Directory Server administration activities with the exception of user managements. | administrator
Directory Server Administrators | This group has full permissions for the administration of the Directory Server and all enterprise servers. | schemaadmin
Modify | This group has default enterprise server permissions that enable the modification of enterprise server configuration information. | modify
System | This group is for the use of Micro Focus applications.
Parent topic: Using the MFDS Internal Security Module


Understanding Permissions

A permission controls use of a feature of Directory Server. For example, there is a permission that governs the administration of users and groups. You grant permissions to user groups.

There are two categories of permissions:

Directory Server Administration | These govern the administration of the Directory Server repository (for example, the management of user accounts).
Server | These govern the administration of the enterprise servers that are controlled by the Directory Server.

Some permissions include others. For example, the permission to modify an enterprise server includes the permission to start and stop the server. When a permission is granted, all those that it includes are automatically granted.

  • Directory Server Permissions
  • Server Permissions
Parent topic: Using the MFDS Internal Security Module


Directory Server Permissions

The following table describes the available Directory Server permissions.

Name | Description
Save Repository | Permits saving a copy of the repository to a file system directory.
Import Repository | Permits importing data from a file system directory. Includes the following permissions: Save Repository.
Restore Repository | Permits restoring a repository from a file system directory. The process of restoring overwrites all of the information in the current repository. Includes the following permissions: Save Repository, Import Repository.
Delete Repository | Permits deletion of the entire Directory Server repository including all enterprise servers, and all users and groups. Includes the following permissions: Save Repository, Import Repository.
Change MF Directory Server options | Permits changing of Directory Server options. Includes the following permissions: Save Repository, Import Repository.
Set Server Permissions | Permits the allocation of permissions on individual enterprise servers. Includes the following permissions: Save Repository, Import Repository, Restore Repository, Delete Repository, Change MF Directory Server.
Display Directories | Permits the viewing of a list of the Directory Servers that your Directory Server can detect on the network. Includes the following permissions: Save Repository, Import Repository, Restore Repository, Delete Repository, Change MF Directory Server, Set Server Permissions.
Shutdown MF Directory Server | Permits the shutting down of the Directory Server. Includes the following permissions: Save Repository, Import Repository, Restore Repository, Delete Repository, Change MF Directory Server, Set Server Permissions.
Administer Users | Permits the management of user accounts and user groups, and the setting of permissions. Includes the following permissions: Save Repository, Import Repository, Restore Repository, Delete Repository, Change MF Directory Server, Set Server Permissions, Display Directories, Shutdown MF Directory Server.
Parent topic: Understanding Permissions


Server Permissions

The following table describes the available server permissions.

Name | Description
Read | Permits viewing of an enterprise server configuration information.
Start/Stop | Permits the starting and stopping of an enterprise server. Includes the following permissions: Read
Modify | Permits the modification of configuration information for an enterprise server. Includes the following permissions: Read, Start/Stop
Add | Permits the adding of listeners, services and packages to an enterprise server. When set as a default permission for the group, it also permits the adding of enterprise servers. Includes the following permissions: Read, Start/Stop, Modify
Delete | Permits the deletion of enterprise servers, and of listeners, services and packages from an enterprise server. Includes the following permissions: Read, Start/Stop, Modify

You can set default server permissions for a group, but you can also override these defaults for individual enterprise servers. For example, you might have an operator group with default permissions to start and stop servers. You could override these for your test server, specifying that the operator group also has modify permission.

Note:

To permit a group to create new servers, you must set its default Add permission.

Parent topic: Understanding Permissions


Managing Users and Groups

You use screens within Enterprise Server Administration to manage users and user groups. To do this, you must be logged on to a user account that is a member of a group with appropriate permissions. The preconfigured user, schemaadmin is suitable for this task.

  • Setting Permissions
  • Best Practice
Parent topic: Using the MFDS Internal Security Module


Setting Permissions

You set the permissions for each group using screens within Enterprise Server Administration. To do this, you must be logged on to a user account that is a member of a group with appropriate permissions. The preconfigured user, schemaadmin is suitable for this task.

Parent topic: Managing Users and Groups


Best Practice

Change the passwords of the preconfigured accounts at the earliest possible opportunity.

Ensure that only those users who need access have user accounts.

Ensure that users have only the permissions that they require in order to do their jobs.

Limit the number of administrative users.

Parent topic: Managing Users and Groups


Configuring Operating System Security: osesm

The operating system security manager (osesm) lets users sign in to ESF-protected systems (ES regions and MFDS) using their operating system username and password.

Note: osesm is supported only on Windows.
  • How osesm Works
  • osesm Module Configuration
Parent topic: Securing an Enterprise Server Installation
Parent topic: Active Directory


How osesm Works

With the osesm security manager, users sign on to MFDS, Enterprise Server Administration, and/or MSS using their Windows username and password.

Note: osesm only supports the Verify operation (user sign-on). It does not do any resource access control (the Auth and XAuth operations). To control access to resources for signed-on users, you will need to configure another ESM module lower in the list for that purpose.

By default osesm first tries to sign a user on locally. If that fails, it does a search in the default domain (in the domain forest, on Windows 2003 and later) and tries again in the first domain where it finds the user. You can specify a different domain to try initially in the security manager configuration.

Note: osesm is limited to the signon IDs that Windows normally allows, and therefore it cannot verify a user in a domain that is not trusted by the local system. osesm can authenticate users from any domain that is listed in the Windows sign-on dialog. It cannot authenticate signons of the form username@domain.tld: the signon screens do not support this.

osesm supports ESF Passtokens, which can be used to automatically pass credentials between MFDS and the Enterprise Server administration UI, if both the directory server and Enterprise Server are configured to use osesm.

Parent topic: Configuring Operating System Security: osesm


osesm Module Configuration

Because osesm uses the operating system to authenticate user credentials, it doesn't have many configuration parameters. For information on the configuration fields, in the Edit Security Manager screen's left hand pane, select the Help > This Page option.

The osesm module also supports some additional configuration that can be set by editing the text in the Configuration Information area. Text in this area is organized into sections which begin with a tag in square brackets, followed by lines of the form: name=value.

Below are the various configuration sections you can configure, and the options that can be set in each section.

[Operation] section
domain=domain

Sets the default domain for checking the user's credentials. By default this is ".", which means to try to log the user on to the local system.

type=network | interactive

Sets the type of logon to use. Windows supports a number of logon types. Servers typically use the network logon to verify user credentials, as it is supposed to be faster and use less resources. However, it requires that the user has the "Use this computer over a network" right, which some user accounts may not have. Also, it does not work in some situations where the user should be able to log on, for example when a Windows XP system is trying to verify a domain user who does not have a local account. If you find users cannot log on using their correct domain usernames and passwords, try setting this to interactive, which will perform a full Windows interactive logon.

The default is network.

[Passtoken] section
enable=none | self | any

Sets the passtoken creation and use privileges:

  • none disables passtokens.
  • self allows the creation and use of self-only passtokens (users can use passtokens to transfer their credentials between the directory server and the administration user interface, for example).
  • any allows the creation of self and surrogate passtokens. This is a security risk: an attacker who learns how to forge surrogate passtokens could use them to sign on to any facility that accepts surrogate passtokens. (Currently ES does not use surrogate passtokens, but they might be used in the future for inter-region transaction routing, for example.)

The default is none. Set it to self if you want to be able to move between MFDS and ESMAC without signing on twice.

secret=string
Sets the secret data which will serve as the key for the Message Authentication Code (MAC) in ESF Passtokens generated by the ESM Module. This data prevents attackers who do not know it from forging passtokens. Note that any setting here will obviously not be secret from anyone who can read the MFDS repository. If this value is set, it must be set the same for all security domains (MFDS and ES regions) that will exchange passtokens.
secret file=path
Sets the path to a file that contains the secret data for the passtoken MAC. This is more secure than setting the secret data directly in the configuration. If SecretFile is set, any Secret directive is ignored. (If neither is set, a built-in default is used.)
duration=seconds
Sets the duration for passtokens. A token will be valid for this length of time after it's generated; after that it will be rejected. The default is 60 (one minute).
Parent topic: Configuring Operating System Security: osesm


Configuring Security using Active Directory

This section describe the methods available for configuring Microsoft Active Directory (AD) to provide Enterprise Server security.

The topics in this section illustrate the process by describing how you perform it using Microsoft's Active Directory Lightweight Directory Service (AD LDS) software.

UNIX appears in bold at the start of a paragraph that applies to performing the procedure using Server Enterprise Edition for UNIX rather than Studio Enterprise Edition for Windows.

  • Setting Up Security with AD LDS
    AD LDS is a lightweight stand-alone LDAP server that is similar in functionality to Active Directory. You can use the procedures in this section to become familiar with LDAP security.
  • Preparing Active Directory for Enterprise Server Security
    This section describe the procedures you need to perform for both of the following sections: using the MLDAP and the OSESM security managers in conjunction, and using the MLDAP security manager only.
  • Configuring Windows Users as Enterprise Server Administrators
    This section describes the procedures for verifying Enterprise Server administration using Windows authentication for user accounts stored in Active Directory.
  • Configuring Active Directory Users as Enterprise Server Administrators
    This section describes the procedures for configuring users defined in Microsoft Active Directory (AD) as Enterprise Server administrators. It describes how to grant the necessary permissions to the Windows users defined in AD, and how to configure Enterprise Server to use AD as its security manager.
Parent topic: Securing an Enterprise Server Installation


Setting Up Security with AD LDS

The topics in this section describe how to install and configure AD LDS for use with Enterprise Server's MLDAP_ESM security manager.

AD LDS is a stand-alone LDAP server that is very similar to Active Directory. The key difference is that, unlike Active Directory, AD LDS can be deployed on a server that is not a domain controller. (AD LDS was known as ADAM (Active Directory Application Mode) in previous releases.)

Even if you do not intend to use AD LDS as your LDAP, it is useful to follow the procedures in this section to familiarise yourself with what is involved. This will be a useful exercise if you want to use a more fully-featured LDAP such as Active Directory, or OpenLDAP.

  • ldifde Notes
  • Installing Active Directory Lightweight Directory Service (AD LDS)
  • Creating the AD LDS Server Instance
  • Running the Setup Script
  • Configuring Microsoft Users
  • Configuring Enterprise Server to use the MLDAP ESM
  • Configuring the AD LDS Repository
Parent topic: Configuring Security using Active Directory


ldifde Notes

Several of the steps in this process use the Microsoft ldifde utility, a relatively complex command-line utility with many options. You may want to read the documentation for ldifde that comes with AD LDS.

Here are some tips for using ldifde:

  • We use ldifde to read an LDIF file (with an .ldf extension) and update AD with the objects listed in the file. LDIF files are text files and can be edited in Notepad.
  • Many of the ldifde command lines shown below use the "-c" option, which takes two strings as parameters, and changes the first string to the second wherever it appears in the input. So "-c DC=X DC=mydom,DC=com" will change "DC=X" in the .ldf file to "DC=mydom,DC=com". That lets you customize the information in the .ldf file for your installation.
  • You can copy the .ldf files to your AD server and run ldifde there, or you can run it on a system with Studio Enterprise Edition installed and update AD remotely.
  • ldifde has to bind (log on to) AD in order to make changes to the directory. If you are not logged on as an authorized AD user, you can add "-b username domain password" to the ldifde command line.
  • When we show ldifde command lines below, we use the "-s servername" option to tell ldifde the hostname of the AD server. If you're running on the AD server, or if your AD server is the domain controller for the domain that you are running in, you can leave off the "-s servername" option.
  • Each time you run ldifde (with the "-j ." option), it will create an ldif.log file in the current directory. If there are errors or warnings, it will create an ldif.err file as well. If the files already exist, they will be overwritten. We recommend you rename the log file after each ldifde run (for example eg to ldif-1.log, ldif-2.log, etc) so you can send them to Micro Focus Support if you have problems. If an ldifde command fails, you can check the log and error files for more information.

A typical ldifde command will have these parts:

Ldifde | Command name
-i | Command type: import data into AD
-f filename.ldf | Specify LDIF file to import from
-s servername | Hostname of AD server
-k | Keep going even if some entries can't be processed
-j | Create log files in current directory
-c from-string to-string | Change from-string in data to to-string. This lets you customize a generic LDIF file for your installation. For example, from-string might be the placeholder DC=X, and to-string might be your domain DN.
Parent topic: Setting Up Security with AD LDS


Installing Active Directory Lightweight Directory Service (AD LDS)

You can download a copy of Active Directory Lightweight Directory Service (AD LDS) from the Microsoft website. Run the downloaded software and follow the prompts to install it.

Parent topic: Setting Up Security with AD LDS


Creating the AD LDS Server Instance

An AD LDS instance acts an LDAP server. This process describes how to create a server instance specifically for Enterprise Server use.

  1. Click Start > Administrative Tools > Active Directory Lightweight Directory Services Setup Wizard
  2. In the wizard screens select the following options and use the following values:
    Setup Options page
    Select the option A unique instance.
    Instance Name page
    In the Instance name field, enter: MFES.
    Ports page
    Accept the default LDAP and SSL ports: 389 and 636.
    Application Directory Partition page
    Select the option Yes, create an application directory partition and enter the name CN=Micro Focus,CN=Program Data,DC=local.
    File Locations page
    Accept the default file store location (or specify a custom one - this should make no difference).
    Service Account Selection page
    Select to run the service using the Default network service account and override any warning messages that appear.
    AD LDS Administrators page
    Use your current logged-on account (note that you can create an additional AD LDS administrative account in a later step, in case you do not normally use an Administrative account)
    Importing LDIF Files page
    Select the option Import the selected LDIF files, and from the list, select MS-User.LDF to be imported.
  3. On the final wizard screen, click Next to create the instance with your configurations.

As the instance is created, messages appear to show the progress. You may be prompted by your firewall. If so, configure it appropriately to allow your AD LDS instance to accept connections at least from localhost on port 389.

Parent topic: Setting Up Security with AD LDS


Running the Setup Script

The es-ldap-setup script defines the LDAP object classes and containers (the schema) that will hold ES data. That is, it configures AD LDS or AD so that you can use it with Enterprise Server.

By default, the script is installed by default into the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory.

You can run es-ldap-setup with no parameters to configure the default settings. When you run the script, check that it generates no errors.

Without parameters, the script displays the default it will set, and prompts you for information if you do not want to accept the default. Press Enter to accept the default values unless you need to specify something else.

These are the actions es-ldap-setup performs:

  1. Prompts for values such as username if they are not specified on the command line. Press Enter to accept the default, or supply a different value.
  2. If AD LDS or AD is not configured to allow password operations over unsecured connections, the script will configure it to allow them. This is required by some of the following actions. If the script changes this option on the server, it will reset it to its old value before exiting.
  3. Adds the ES user, group, and resource LDAP class definitions to the schema. These specify what attributes each of these types of object has.
  4. Adds the container objects for ES to the repository.
  5. Creates MFReader, the default LDAP user account for ES.
  6. Creates the administrative LDAP user for adding MSS users. (This step is skipped if the /AD option is specified.)
  7. Imports MSS users that are defined in the default MSS resource definition file into the LDAP repository.
  8. Imports MFDS users and groups into the LDAP repository.
  9. Imports the default MSS resource access control definitions into the LDAP repository.
  • The es-ldap-setup AD Setup Script
Parent topic: Setting Up Security with AD LDS


The es-ldap-setup AD Setup Script

The es-ldap-setup script defines the LDAP object classes and containers (the schema) that will hold ES data. That is, it configures AD LDS or AD so that you can use it with Enterprise Server.

By default, the script is installed by default into the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory.

The full syntax for es-ldap-setup is:

es-ldap-setup [/?] [/AD] username password partition server
  • The /? option will display a syntax message and information about what actions the script will perform.
  • The /AD option tells the script that you are using AD rather than AD LDS, so it will not try to create an LDAP administrative user account.
  • The username should be the name of an existing or new administrative user for the LDAP server. (For AD, this user must already exist and have suitable permissions.) It defaults to the current user's name.
  • Password is the LDAP administrator's initial password; it defaults to "password". You can change this password (or even disable or remove the administrative user account created by the script) after the script runs.
  • The partition parameter specifies the LDAP distinguished name (DN) of the application partition where the ES LDAP objects should be created. The default is "CN=Micro Focus,CN=Program Data,DC=local", which is generally suitable for use with AD LDS, but AD users will probably need to specify the DN of a container within their corporate LDAP hierarchy. See your LDAP administrator for more information.
  • The server parameter is the hostname and port of the LDAP server. It defaults to "localhost:389", which is the standard address for an LDAP server running on the local machine.

Most users will run es-ldap-setup with no parameters, but in some cases you may want to specify a username and password:

  • If you're running es-ldap-setup under your normal login ID, and using your local AD LDS installation as your LDAP server, just run it with no parameters.
  • If you're using ES with AD, specify the /AD option and all four parameters. Provide the username of a user with administrative access to AD, and that user's password; the DN of the part of the LDAP repository that will hold ES data; and the hostname and port of the AD server.
  • If you're running es-ldap-setup under an administrative account that isn't your normal login ID, it's usually best to specify your normal login ID as the username. That way, if you want to run the cas-to-ad utility in the future, you can run it under your normal login ID rather than having to specify a different user.
  • If you want a password other than the default "password", specify both the username and password parameters.
  • If you need to specify one parameter, you also have to provide values for the parameters before it. For example; if you need to specify a different LDAP server, you'll have to provide username, password, and partition as well.

These are the actions es-ldap-setup performs:

  1. Prompts for values for username, etc, if they are not specified on the command line. Press Enter to accept the default, or supply a different value.
  2. If AD LDS (or AD) is not configured to allow password operations over unsecured connections, the script will configure it to allow them. This is required by some of the following actions. If the script changes this option on the server, it will reset it to its old value before exiting.
  3. Adds the ES user, group, and resource LDAP class definitions to the schema. These specify what attributes each of these types of object has.
  4. Adds the container objects for ES to the repository.
  5. Creates MFReader, the default LDAP user account for ES.
  6. Creates the administrative LDAP user for adding MSS users. (This step is skipped if the /AD option is specified.)
  7. Imports MSS users that are defined in the default MSS resource definition file into the LDAP repository. See Adding MSS Users to the LDAP Repository for more information.
  8. Imports MFDS users and groups into the LDAP repository.
  9. Imports the default MSS resource access control definitions into the LDAP repository.

Before each action, es-ldap-setup will pause and tell you what it's about to do. When it finishes, it will report how many actions succeeded and how many failed, and give a list of the failing actions, which you can provide to Micro Focus Support if you have questions.

Note:

Some users may encounter a known issue with the AD LDS dsmgmt utility when running the script. If you get an error message similar to the following:

DsBindWithSpnExW error 0x6ba (The RPC server is unavailable.)

then there is an issue with your network configuration which is preventing the utility from connecting to your AD LDS server. This is a Windows issue, not a Micro Focus one. Possible fixes include:

  • Remove IPv6 support from your network configuration.
  • Specify the LDAP server address for the script using your local hostname rather than localhost. (Remember to include the port number, as in myhost:389.)
  • Disable your local system's firewall while running the script. With some application firewalls, such as Symantec Client Security, disabling the firewall may not be sufficient, and you may have to manually disable or delete rules that affect the ICMP protocol.
  • Check that your hosts file (%systemroot%\system32\drivers\etc\hosts) does not contain any invalid entries for localhost or your local hostname.
Parent topic: Running the Setup Script


Configuring Microsoft Users

With LDAP-based security for Enterprise Server using a security configuration that includes the MLDAP ESM Module, you can configure your installation so that authentication uses the standard Microsoft user objects in Active Directory, that is, the same user objects that are used for Windows authentication. With this configuration, users sign on to Enterprise Server using their Windows usernames and passwords, and Windows logon restrictions apply.

Note: When you set this configuration, you can no longer use the Enterprise Server user administration functionality to manage users. You must do this through your normal Microsoft user management interface.

To configure the system to use Microsoft standard users, you need to set the security manager's configuration as per the example below:

    [LDAP]
    base=
    user class=user
    user container=cn=users,dc=company,dc=com
    group container=cn=enterprise server user groups,cn=micro focus,
      cn=program data,dc=company,dc=com
    resource container=cn=enterprise server resources,cn=micro focus,
     cn=program data,dc=company,dc=com
    [Verify]
    mode=bind

user class environment variable to a value of: user

If this setting is not present, user class=microfocus-MFDS-User which is the default setting is used.

  • To Configure a Security Manager's Environment
Parent topic: Setting Up Security with AD LDS
Related tasks
To Configure a Security Manager's Environment
Related information
To configure the security facility to use the MLDAP ESM


To Configure a Security Manager's Environment

Use this task to configure the environment for a security manager.
Note: When you set this configuration, you can no longer use the Enterprise Server user administration functionality to manage users. You must do this through your normal Microsoft user management interface.
  1. On the Enterprise Server Administration screen, in the left pane, select Security.
  2. Select the Security Managers tab, and in the list of configured security managers, select the one to configure, and click Edit.

    The Configure Security Options screen is displayed.

  3. In the configuration area at the bottom of the screen, add or edit the [LDAP] configuration to add settings you want follows: For example:
    Note: In the example below, the line: user class="user" sets that Enterprise Server uses Microsoft user configurations, and you cannot change these through the Enterprise Server security user interface. Omit this line to configure the default behaviour, which is that you can configure user information stored in an LDAP.
    [LDAP]
base="DC=somecorp,DC=com"
user class="user"
user container="CN=users"
group container="CN=Enterprise Server Groups,CN=MF"
resource container="CN=Enterprise Server Resources,CN=MF"
Parent topic: Configuring Microsoft Users
Related concepts
Configuring Microsoft Users
Related tasks
To Add or Remove a Security Manager in the Pool
Related information
To Edit a Security Manager's Properties
To configure the security facility to use the MLDAP ESM


Configuring Enterprise Server to use the MLDAP ESM

After you have successfully configured your LDAP server, you can configure Enterprise Server to use LDAP for security.

  1. Create a Security Manager object in MFDS. The security manager that you create must use the following options:
    • Module: mldap_esm.
    • Connection Path: the hostname and port of your LDAP server, just as you supplied it on the es-ldap-setup command line. You can leave it blank if you're using a local AD LDS (or AD) server.
  2. Once the security manager has been created, enable it for a specific ES server, for example ESDEMO.
    CAUTION:
    Do not configure this ESM for MFDS until you have tested it with an ES server.
  3. Start the Enterprise Server, using the SYSAD user ID (password SYSAD). This ID is created in the AD LDS LDAP by the setup script.

    The enterprise server starts, using the AD LDS LDAP to authenticate the SYSAD user.

Parent topic: Setting Up Security with AD LDS


Configuring the AD LDS Repository

This section describes the tasks you can use to create, view, and edit your ES LDAP security configuration.

  • Browsing the AD LDS Repository
  • Adding Repository Objects using ADSIEdit
  • Adding MSS Users to the LDAP Repository
  • Enabling MFDS Administration for LDAP and User Password Changes
Parent topic: Setting Up Security with AD LDS


Browsing the AD LDS Repository

You can use the Microsoft ADSIEdit utility to view the ES areas of your LDAP repository. This tool is included with AD LDS. You can run it from the Start Menu.

  1. Click menu, select Start > Administrative Tools > ADSI Edit to open the editor.
  2. In the editor's menu, select Action > Connect to... to open the Connection Settings dialog box.
  3. In the the Connection Settings dialog box, enter the following details to create a connection to the ES application partition:
    • Connection name: MF or a name of your choosing.
    • Server name: localhost
    • Port: 389
    • Connect to the following node: select the Distinguished name (DN) or naming context radio button.
    • DN value to enter: CN=Micro Focus,CN=Program Data,DC=local
    • Connect using these credentials: select the The account of the currently logged-on user radio button.
  4. Click OK.

The left pane displays a tree view item with the name that you configured as the connection name. When you expand this item, and then the container within it, the ES containers are displayed, for example
        CN=Enterprise Server Users,
        CN=ADAM Users, and automatically-generated containers such as
        CN=Roles.

You can open these containers and double-click on the objects within them to view (or edit) their attributes.

Parent topic: Configuring the AD LDS Repository


Adding Repository Objects using ADSIEdit

You can also use ADSIEdit to create new objects in the repository, such as new MSS users, using Action > New. Select the appropriate object type, then complete the wizard, which will prompt for required values and give you an opportunity to enter optional ones. (You can change any of these later by editing the object.)

Creating an MSS user

  • To create an MSS user, select the CN=Enterprise Server Users container, right-click and select to create a new microfocus-MFDS-User object:
    • Set the cn attribute to the username
    • The dialog will prompt for some mandatory MSS attributes such as microfocus-MFDS-User-MTO-Timeout. You can set the Timeout, Priority, and OperatorClass attributes to 0 (or any other value which is valid under MSS).
    • Set the microfocus-MFDS-User-AllowLogon attibute to TRUE.
    • The microfocus-MFDS-UID attribute must be set, but currently the format of this value does not matter. You can set it to the username, for example.
    • If you want to set an initial password, when you reach the final page of the dialog (with the "Finish" button), click More Attributes, find the microfocus-MFDS-User-Pwd attribute, and double-click it. Set its value to "literal:password". Note that this password will be stored in plaintext (and so will be visible by anyone who has read access to the repository) until you change it.
    • Other optional attributes you may want to set:
      • displayName to the user's "display" name (often a person's legal name, etc)
      • description to any descriptive text you want to associate with the user
      • microfocus-MFDS-User-DefaultGroup to the user's default MSS group (eg ALLUSR)
      • microfocus-MFDS-User-MTO-GroupPrefix and microfocus-MFDS-User-MTO-OperatorID if you use MSS group prefixes and/or operator IDs with your normal MSS user definitions
      • microfocus-MFDS-User-CreateToken and microfocus-MFDS-User-UseToken if you use passtokens (typically, set both of these to self for users who will be using MFDS and ESMAC)

Creating an MSS user group

  • To create an MSS user group, right-click the CN=Enterprise Server User Groups" container and select to create a new microfocus-MFDS-Group object:
    • Set the cn attribute to the group name. Note that this name must be no longer than 8 characters.
    • The microfocus-MFDS-UID attribute must be set, but currently the format of this value does not matter. You can set it to the group name, for example.
    • To set the members of the group (you can change this later by editing the group object), click More Attributes on the final page of the dialog. Double-click the microfocus-MFDS-Group-Member attribute to get a dialog that lets you add or remove members.

Creating a resource class and resource acces control object

  • To create an MSS resource class, right-click the CN=Enterprise Server Resources container and create a new container object. Set its cn attribute to the name of the resource class.
  • To create an MSS resource access control object, expand the CN=Enterprise Server Resources container in the tree view, then right -click the container for the class of the resource you want to create. Create a new microfocus-MFDS-Resource object:
    • Set the cn attribute to the resource name, or to a string that contains wildcards to create a generic rule. Wildcards are explained in the documentation for the MLDAP ESM Module in your product documentation.
    • The microfocus-MFDS-UID attribute must be set, but currently the format of this value does not matter. Since resource names can be long, it may be easiest just to put a dummy value here, such as 1.
    • You must set the microfocus-MFDS-Resource-Class attribute, but this attribute is no longer used and is only in the schema for compatibility with pre-release versions. You can set this to the resource's class name or to any other value.
    • If you want to set an initial ACL, click More Attributes on the final page of the dialog. Double-click the microfocus-MFDS-Resource-ACE attribute to get a dialog that lets you add or remove access-control entries. See the MLDAP ESM Module documentation for more information.

You may want to create a new AD LDS user for ES to use. If you want to give ES permission to change objects in the repository -to let users change their passwords when they sign on, or to enable LDAP administration through MFDS - then you will want to configure the MLDAP Security Manager in MFDS with a different Authorized ID and Password. (It's not safe to give the default MFReader account write permission to the repository, because that username and its password are available to anyone who reads the ES LDAP setup materials.)

Creating an AD LDS user

  • To create an AD LDS user, expand the CN=AD LDS container, then create a new user object:
    • The cn is the only required attribute.
    • After creating the user, you can give it the appropriate permissions by editing the appropriate object in the CN=Roles container and double-clicking on the member attribute, which will give you a dialog box where you can add users to that role. Adding your new user to the Administrators role will give it administrative access to the repository, for example.
    • You can also give your new user more specific permissions by editing the ACLs for specific parts of the repository. See the AD LDS documentation for more information.
Parent topic: Configuring the AD LDS Repository


Adding MSS Users to the LDAP Repository

Many existing ES/MSS customers have created multiple MSS resource definition (RDO) files, to configure various ES servers (or "regions"). These RDO files may contain users defined for MSS. The es-ldap-setup script reads the default RDO file (located by default in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.xfiles\sys\dfhdrdat directory) and adds any user definitions in it to the LDAP repository. If you have other RDO files, though, you may want to extract user definitions from them and import them into LDAP for use with ES external security.

You can use the cas-to-ad.exe utility to migrate MSS user definitions into LDAP. Run "cas-to-ad -h" to get a syntax message. Current options are:

Option | use To | Default
-u user | Set username for AD connection (name or DN) | Current logon name
-p password | Set password for AD connection | None; if not set, you will be prompted
-d DN | DN for AD application partition | CN=Micro Focus,CN=Program Data,DC=local
-c container | container for added ES users | CN=Enterprise Server Users
-l host:port | Location of the AD server | localhost:389
-r path | Path to CAS RDO file | See below
-e encoding | Password encoding | md5 (the other option is "literal")
-v | Show version and exit | N/A
-h | Show syntax help and exit | N/A

Option values can be appended to the option character or specified as the next argument on the command line.

The CAS RDO file (always named dfhdrdat) that cas-to-ad will process is located as follows:

  1. If the -r option is used, cas-to-ad uses the specified path
  2. If not, cas-to-ad looks to see if the environment variable TXRDTP is defined, and if so uses that path
  3. If not, it looks for a dfhdrdat file in the current directory, and if one is present uses it
  4. If not, it looks for the Studio Enterprise Edition or Server Enterprise Edition base directory Registry key, and uses the files\sys\dfhdrdat under that directory.

The -e option controls how user passwords are stored in LDAP. The default is -e md5, which stores a salted MD5 hash of the password. The value of the microfocus-MFDS-User-Pwd attribute will have the form "MF-MD5:base64-salt:base64-hash", where base64-salt and base64-hash are character strings that contain base64-encoded data. This is an irreversible transformation (the hash can be used to verify the password but not to reconstruct it). The other encoding currently supported is -e literal, which stores the password in plain text, in the form "literal:password". This form is useful for debugging and when creating ES users using ADSIEdit.

Parent topic: Configuring the AD LDS Repository


Enabling MFDS Administration for LDAP and User Password Changes

By default, ES uses the MFReader account to connect to the LDAP server. As its name suggests, MFReader does not have authority to make changes to the repository, only to read from it.

You may want to configure your MLDAP Security Manager in MFDS with different LDAP user credentials (Authorized ID and Password), to give it update access to part or all of the repository. You can configure it with credentials for an administrative user, or create a new LDAP user (see Adding Repository Objects using ADSIEdit) and then set ACLs in the LDAP repository (using ADSIEdit or other Microsoft tools) to give that user write access to specific parts of the repository.

For example, if you have created an AD LDS user named "MFUpdate", you could give it write access to user objects by setting an ACL with the dsacls.exe AD LDS utility:

dsacls "\\localhost\CN=Enterprise Server Users,CN=Micro Focus,CN=Program Data,DC=local" /I:S   /G "CN=MFUpdate,CN=ADAM Users,CN=Micro Focus,CN=Program Data,DC=local":WP

(Enter this command all on one line.)

You should not give the MFReader LDAP user write access to the repository, because its name and password are well-known. Configure your security manager to use a different account instead, and be careful to keep that account's password a secret. (If non-privileged users have access to the system where MFDS is running, it's a good idea to set ACLs on the MFDS configuration files so that they can only be read by the account MFDS runs under, which is usually SERVICE.)

If an ES/MSS region is configured to use a MLDAP Security Manager that has update access to user objects, then interactive MSS users will be able to set their passwords when they sign on to the system (using the CESN transaction, or another program that calls the EXEC CICS SIGNON interface). This is particularly useful if you make use of the password expiration date attribute (microfocus-MFDS-User-Pwd-ExpirationDate) to force users to change passwords periodically, since it gives them a way to do so. (Note that the MLDAP ESM Module does not currently provide any way to automatically set the expiration date; that has to be done using some other tool.)

If MFDS is configured to use an MLDAP Security Manager that has update access to the various ES objects in the LDAP repository, then you can use MFDS to administer those objects. From the Security page of the MFDS administration GUI, go to the Security Managers tab, edit the Security Manager you have defined for LDAP, and click its Properties button. From there, you can view and edit users, groups, and resource access controls.

Parent topic: Configuring the AD LDS Repository


Preparing Active Directory for Enterprise Server Security

  • Prerequisites
  • Establishing a Work Directory and Copying Files
  • Extend the AD Schema
  • Create LDAP Objects
  • Final User Tasks
  • Configure ES Security
Parent topic: Configuring Security using Active Directory


Prerequisites

Software

To perform the procedures in this section, you will need the following software:

  • ldifde.exe, the Microsoft LDAP utility that is shipped with AD LDS.
  • Enterprise Server MFDS and the cas-to-ad utility, which are supplied with the product install.

    UNIX: The cas-to-ad step is optional; if you don't need to import existing MSS users, you can use a UNIX SX5.0 WS03 or greater environment instead, and run the ldifde commands on the domain controller.

  • The following LDIF (LDAP data) files are in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory.
    • mf-partition.ldf
    • mf-ad-containers.ldf
    • ms-user-plus-mto.ldf
    • es_default_ldap.ldf or es_default_ldap_msuser.ldf (only one of these is used)

Information

You will need the following:

  • A user account authorized to make AD schema changes (shown as username and password below).
  • The location of the AD server (shown as servername below).
  • The user class you will use.

    This can either be microfocus-MFDS-User (supplied by Micro Focus), if ES users will be separate from Windows users, or user (supplied by Microsoft and modified by Micro Focus) to use your Windows user accounts for ES. (Shown as userclass below.)

  • The DN of the AD domain (shown as domain-DN below).

    Normally, this will be the fully-qualified domain name of the AD host, minus the hostname, with each segment of the name listed as a separate DC element, so for example server.dept.mydom.com would use DC=dept,DC=mydom,DC=com. If you are using AD LDS, you may want to use the default domain DN for ES LDAP data, which is "CN=Micro Focus,CN=Program Data,DC=local".

  • The DNs of the containers for users, ES user groups, and ES resources, if you are going to use something other than the default values.

    ES groups and resources are used only by ES, so we recommend you use the defaults (located in CN=Micro Focus,CN=Program Data) for their containers.

    If you are using the Micro Focus user class (microfocus-MFDS-User), you can use the default ES user container (CN=Enterprise Server Users,CN=Micro Focus,CN=Program Data, below the domain-DN) as well.

    On the other hand, if you want to let existing Windows users sign on to ES without creating separate ES user accounts for them, you will need to configure ES to use your existing user container in AD (usually CN=Users). Use that for your user container (shown as user-container below) in the following commands as well.

Backups

Before you make any AD modifications we recommend you back up your AD schema and Directory Information Tree (DIT). You may already have standard procedures for this. If not, you should make a backup of the contents of the %WINDIR%\ntds directory to another location. This way you can drop the server (assuming Server 2003) into "Directory Server Recovery" mode and restore your previous AD data if you ever have to.

Note that the contents of that directory are in use when the server is running, so ordinary copy commands generally will not work. Some ways you can back up your AD information:

  • Make the backup in Directory Server Recovery Mode (press F8 while booting the AD host to enter Recovery Mode)
  • Use a backup utility such as the Backup applet that comes with Windows, or the ntbackup command-line equivalent (this does not require a reboot)
  • Use a utility to schedule a copy when the system is rebooted, such as SysInternals movefile (and then reboot to effect the copy)

Consult your Windows documentation for more information.

You may also want to export your current LDAP hierarchy to an LDIF file for later reference, using a command such as:

ldifde -f export-file -s servername -r "(objectclass=*)" -d "CN=Schema,CN=Configuration,domain-DN"
Parent topic: Preparing Active Directory for Enterprise Server Security


Establishing a Work Directory and Copying Files

We recommend creating and using a new work directory for this procedure, as that makes it easier to keep track of the files you use and create:

mkdir mf-ad-setup
cd mf-ad-setup

After creating your work directory, you will need to copy the LDIF files into it. These files are in the Base\Bin directory of your product installation.

If these files are not included with the product, contact Micro Focus Support.

Parent topic: Preparing Active Directory for Enterprise Server Security


Extend the AD Schema

Create the Micro Focus AD format schema extension LDIF file (enter this and all other commands on a single line):

mfds -L "CN=Schema,CN=Configuration,domain-DN" 1 mfds-schema.ldf

This will create the file mfds-schema.ldf. Use the latest WS03 build MFDS (1.06.11 or later) for this operation to ensure you have the latest schema definitions.

Import MF schema extensions into AD:

ldifde -i -f mfds-schema.ldf -s servername -k -j .

If you are updating a remote AD server, this command may take a minute or two. When it's done, remember to rename the log files, as described above.

Note: If you want to use the Microsoft user object class for your ES users, you must extend it with additional Micro Focus attributes:
ldifde -i -f ms-user-plus-mto.ldf -s servername -k -j . -c "DC=X" "CN=Schema,CN=Configuration,domain-DN"
Parent topic: Preparing Active Directory for Enterprise Server Security


Create LDAP Objects

  • Containers
  • ES/MSS Objects
Parent topic: Preparing Active Directory for Enterprise Server Security


Containers

Create the Micro Focus partition. You will need to edit the mf-partition.ldf file first if you do not want to use CN=Micro Focus,CN=Program Data as the container for the ES definitions.

ldifde -i -f mf-partition.ldf -s servername -k -j . -c "DC=X" "CN=Program Data,domain-DN"

You can copy the .ldf files to your AD server and run the command there, or run it from a system with Studio Enterprise Edition.

Next create the standard MF containers. If you want to use a different container for users, user groups, or resources, you may need to edit the mf-ad-containers.ldf file first. You may also have to edit some of the other .ldf files or make changes to some of the commands that follow.

We recommend using the standard containers, with one exception: if you are using Windows users for ES users, you will want to use the existing AD user container. You don't need to do anything different in this step for that.

The command to create the standard MF containers is:

ldifde -i -f mf-ad-containers.ldf -s servername -k -j . -c "DC=X" "CN=Micro Focus,CN=Program Data,domain-DN"
Parent topic: Create LDAP Objects


ES/MSS Objects

Import the predefined ES/MSS users, user groups, and resource access control definitions from the default LDAP configuration into your AD repository. The LDIF file you use depends on the user class you have chosen.

Run only one of the following two commands.

  • If you are using the default, ES-only microfocus-MFDS-User class:
    ldifde -i -f es_default_ldap.ldf -s servername -k -j . -c "DC=X" "domain-DN"

    es_default_ldap.ldf uses the default Micro Focus containers for ES users, groups, and resources.

  • If you are using the Microsoft user class, so that Windows users can also be ES users:
    ldifde -i -f es_default_ldap_msuser.ldf -s servername -k -j . -c "DC=X" "domain-DN"

    es_default_ldap_msuser.ldf uses the default Micro Focus containers for ES groups and resources, and the default AD user container (CN=Users) for users.

When you run this command, you will probably get warnings about objects that do not exist. You can ignore these warnings. They are generated because these .ldf files try to delete any existing instances of the objects they create.

Parent topic: Create LDAP Objects


Final User Tasks

Some user attributes may need to be set manually (using AD administration tools or hand-written LDIF files) after importing the ES definitions.

  • Set MSS Attributes for Windows Users
  • Enabling ES Predefined Users
  • Disable Password Expiration for ES Users
  • Remove Predefined Users
Parent topic: Preparing Active Directory for Enterprise Server Security


Set MSS Attributes for Windows Users

If you are using your existing Windows users as ES users, you will probably want to set some of the new MSS-specific user attributes for at least some of them. For example, the microfocus-MFDS-User-MTO-Timeout attribute sets the MSS timeout for that user. See the ES/MSS documentation for more information.

You will also probably want to add existing users to MFDS and MSS user groups to reflect their roles (developers, administrators, etc). Note these are ES user groups, not Windows user groups, so you change them by modifying your AD repository with an LDIF file or a tool such as ADSIEdit. The ES/MSS documentation includes information on ES user groups. For example, you can add Windows users to the #DSAdmin group in Enterprise Server User Groups to make them MFDS administrators; to give a user permission to start and stop ES regions, set their default group attribute microfocus-MFDS-User-DefaultGroup to SYSADM.

You can make these changes manually using a tool for administering AD data, such as ADSIEdit. For bulk changes, though, you will probably want to create LDIF files to update multiple users, groups, or resources at once.

Parent topic: Final User Tasks


Enabling ES Predefined Users

If you use the Microsoft user object class, AD will probably disable the new predefined ES users. If you want to use ES predefined users such as SYSAD (for starting and stopping ES regions) and schemaadmin (for MFDS administration), you will need to enable them. On your AD server, open the AD user manager (Active Directory Users and Computers) console. Select one or more users in the right pane, then choose Action > Enable Account from the main menu.

Parent topic: Final User Tasks


Disable Password Expiration for ES Users

The Microsoft user object class uses Windows passwords, which means normal Windows password rules in the domain security policy apply, including password expiration. Some administrators would prefer that the passwords for the predefined ES users (such as mfuser and SYSAD) not expire, since these are not normal login accounts. You can edit these users using standard Windows user administration tools and set the Password does not expire option for them.

Parent topic: Final User Tasks


Remove Predefined Users

Some administrators may choose to delete the predefined ES users after installation, and use only existing Windows user accounts for administering ES and signing on to MSS. We recommend doing this only after verifying basic ES operation with security enabled, since that will make it easier for Support to diagnose any problems.

You should not remove the default user accounts CICSUSER, JESUSER, IMSUSER, and mfuser, unless you specify different default accounts in the ES configuration (see the ES/MSS documentation for details). You can disable these accounts in Windows to prevent anyone from using them to log on to Windows.

If you remove the mf_cs and mf_mdsa users, you will not be able to run nonsecured ES servers using the default options.

Be sure you have another account for MFDS administration before removing the schemaadmin user.

Also, if you used CN=Users as your user container above, you can remove the empty CN=Enterprise Server Users container.

Parent topic: Final User Tasks


Configure ES Security

To use the ES security information in LDAP, you will need to configure ES security:

  • Create one or more Security Managers to connect to your LDAP server. You need to set various attributes for these managers:
    • The module name to mldap_esm
    • The connection path to ldap://servername (or ldaps://servername to use an SSL-secured connection, if your LDAP client and server support SSL)
    • The authorized ID and password to the name (usually a DN) and password of an account that has at least read permission for the ES objects in the directory
    • In the Configuration Information area, you will probably need to add a number of directives to alter the default behavior, for container DNs, user class, and so forth. For example, when using Windows users for ES, a typical configuration would be:
      [LDAP]
base=domain-DN
user container=CN=users
group container=CN=Enterprise Server User Groups,CN=Micro Focus,CN=Program Data
resource container=CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data
user class=user

[Verify]
mode=bind
password type=AD
  • Alter the security configuration for MF Directory Server, ES Default Security, and/or specific ES servers to use your new Security Manager

See the product documentation for more information. (In particular, see the documentation for the MLDAP ESM Module for information on configuring the module to match your AD setup.)

Parent topic: Preparing Active Directory for Enterprise Server Security


Configuring Windows Users as Enterprise Server Administrators

With this configuration:

  • Windows users are stored in Active Directory.
  • Enterprise Server uses Windows user authentication to authenticate administrators. You can restrict access to ES/MSS to a subset of Windows users by setting the appropriate ES/MSS resource permissions.

    Windows manages passwords (so Windows password policies will apply).

  • Enterprise Server administrators sign on with their Windows usernames and passwords
  • Other user attributes (for example operator class) are stored as additional attributes of the Windows user objects in AD.

For many installations, this provides the best of both worlds: mainframe-compatible security for Enterprise Server, but there is only one set of user accounts, and they're managed with standard Windows tools.

This configuration uses two ESM modules. Both use Active Directory, but through different interfaces, and they perform different tasks.

  • The OS ESM module processes user sign-on (Verify) requests by calling standard Windows APIs for user login and (if requested) password change. Windows handles these calls by communicating with the domain controller, which reads and updates Active Directory.
  • The MLDAP ESM module makes LDAP requests to AD to get user attributes and resource access control rules.

As with most ESF security configurations, this type can be used for some or all enterprise server instances and/or for MFDS.

  • Overview
  • Configuring ES and AD
Parent topic: Configuring Security using Active Directory


Overview

  • The OS ESM Module
  • The MLDAP ESM Module
  • The Security Manager Stack
  • Objects and Attributes in Active Directory
Parent topic: Configuring Windows Users as Enterprise Server Administrators


The OS ESM Module

The OS ESM module uses the Windows OS as an external security manager. It is quite simple, with only a handful of configuration options (for passtoken support), and it only supports ESF Verify (user signon) requests. It uses the Windows LogonUser function to check whether the user has supplied the correct password and is allowed to log into the system. Windows security policy rules such as restricted logon hours will be applied automatically, and if a user's password has expired and they have not supplied a new password, the request will be rejected with a must-change-password status. In other words, an MSS signon using this ESM will behave much like a conventional Windows login.

If the user requested a password change, the ESM module will call the Windows NetUserChangePassword function to attempt to change the password. Again, this is essentially the same as a conventional Windows login where the user specifies a new password.

Note that currently MSS restricts the length of usernames and passwords (see the ES documentation for details). Also, usernames or passwords that use non-ASCII characters may not work correctly.

Parent topic: Overview


The MLDAP ESM Module

The MLDAP ESM module lets you use an LDAP server as an external security manager. It is relatively full-featured and has a number of configuration options. By default, it implements ES security using LDAP object classes defined by Micro Focus; these objects are used only by ES, and not integrated with security for the OS or other applications.

However, the MLDAP ESM module can be configured to use other LDAP object classes (and containers, so it does not require the default directory hierarchy). By itself, this is not sufficient to completely integrate with Windows security, because the MLDAP ESM module cannot use Microsoft user password attributes; so if you used just the MLDAP ESM with Microsoft user classes, users would have separate passwords for Windows and MSS. In conjunction with the OS ESM, however, the MLDAP ESM will ignore the user password attribute (and other attributes used only for user signon) defined by Micro Focus, if the OS ESM has already verified the user using Windows.

Parent topic: Overview


The Security Manager Stack

An ESF configuration is defined (in MFDS) as one or more security managers, arranged in a list or stack. A security manager is an ESM module plus its configuration information, and a stack specifies which security managers will be used, and in what order they'll be called.

The configuration presented here will include a security manager using OS ESM and another manager using MLDAP ESM, configured to use the Microsoft user LDAP object class for users (rather than the default Micro Focus user class). These managers will be stacked so that the OS ESM is called first.

For Verify requests, ESF will call the OS ESM, which will use Windows to authenticate the user, as described above. Then (if the user is successfully verified) ESF will call the MLDAP ESM, which will load the user's MSS attributes from AD.

For Auth requests, ESF will only call the MLDAP ESM, since the OS ESM does not implement Auth. The MLDAP ESM will apply the access control rules defined in AD.

Parent topic: Overview


Objects and Attributes in Active Directory

With this configuration, ES will use a combination of Microsoft and Micro Focus object classes in Active Directory.

The Windows APIs invoked by OS ESM during Verify requests operate (indirectly) on the Windows security principals defined in AD. (More information on Windows security principals is available from the Microsoft Developer Network and similar resources.) These principals typically use LDAP object classes defined by Microsoft, such as user. Those classes have attributes such as cn (common name), which is the (base) username, and password, which contains the Microsoft hashed password.

In this configuration, the object class used for users will be extended to include attributes defined by Micro Focus. These attributes (which begin with "microfocus-MFDS-") are ignored by Windows, but ES will use them to set session characteristics when a user logs in, such as timeout and operator class. When a user signs on to MSS or MFDS, the MLDAP ESM will retrieve the values of those attributes from the user object.

Also during signon, the MLDAP ESM module will consult the ES user group lists. These are specified with microfocus-MFDS-User-Group objects, and they allow a user to belong to multiple MSS groups. Note that at this time ES does not use Windows user groups to control access to MFDS and MSS resources, even with this configuration.

Since OS ESM is handling the actual user credential verification, some of the attributes that Micro Focus defines for ES users are not used:

Unused Micro Focus User Attributes

Attribute Name | Description
microfocus-MFDS-User-Pwd | Micro Focus user password hash
microfocus-MFDS-User-Pwd-ExpirationDate | password expiration
microfocus-MFDS-User-Pwd-MustChange | password must-change flag
microfocus-MFDS-User-AllowLogon | allow-logon flag
microfocus-MFDS-User-ExpirationDate | user expiration
microfocus-MFDS-User-CreateToken | passtoken creation authority (if tokens are enabled in OS ESM)
microfocus-MFDS-User-UseToken | passtoken signon authority (if tokens are enabled in OS ESM)

Instead, the Windows password, expiration date, etc will be used. Note that the two passtoken attributes are used unless passtoken support is explicitly configured in OS ESM.

For resource access (Auth) requests, the MLDAP ESM will retrieve MF resource object access control data from microfocus-MFDS-Resource objects in AD.

Parent topic: Overview


Configuring ES and AD

This section describes one set of configuration options for ES and AD to enable integrated user accounts, with the same user information used for Windows and ES/MSS logins. Many other variations are possible, so you may want to adapt this to the needs of your installation.

  • Prerequisites
  • Active Directory
  • Restrictions
  • For More Information
Parent topic: Configuring Windows Users as Enterprise Server Administrators


Prerequisites

You will need a suitable user object class defined in your Active Directory schema. This can be any class that can be used to define Windows security principals. For this example, we will use the user class defined by Microsoft (in the LDIF file MS-user.ldf, included with Active Directory).

You will also need to have populated your Active Directory repository with some users. You may have already defined your Windows domain users in Active Directory, or you may want to define just a few users for a trial implementation.

You will need to have updated the Active Directory schema with the Micro Focus object class definitions for user groups and resource access rules, and created the containers for those objects. Generally, you will also want to have installed the user group and resource access definitions included with the default ES/MSS security configuration, which you can edit later to suit your requirements. Usually all of this is done by installing the default security configuration included with ES/MSS, which is contained in es_default_ldap.ldf and installed using the es-ldap-setup.cmd script. This script is provided as a sample, and may need to be modified for your installation, particularly if you are using the full Active Directory (rather than AD LDS) as your LDAP server for Enterprise Server.

The default configuration includes a number of built-in user accounts ( CICSUSER, SYSAD, etc). If you want to use the default configuration, you will need to add these users to Active Directory in a separate operation, as described below in the "Active Directory" section.

Parent topic: Configuring ES and AD


Active Directory

For this configuration, you will need to make the following changes to your Active Directory installation:

  1. Extend the Active Directory schema with definitions for the Micro Focus LDAP classes for user groups and resource access control rules.
  2. Add the object containers, user groups, and resource rules from the default Micro Focus LDAP security configuration to your Active Directory repository. (You can edit these later to meet your requirements.)
  3. Extend the Active Directory schema to add the ES/MSS user attributes to the user class (or whatever LDAP object class you use to define your Windows users).
  4. (Optional) Import the predefined MFDS and ES/MSS users from the default LDAP configuration into your AD repository.
  5. Set the MSS attributes for your Windows users as necessary.
  6. Add Windows users to the appropriate MSS groups.
  • Micro Focus User Groups and Resource Rules
  • Adding MSS User Attributes to the user Class
  • Importing MSS Users
  • Setting MSS User Attributes for Windows Users
  • Adding Windows Users to MSS Groups
  • Configuring Operating System Security: osesm
  • Configuring mldap_esm Security Manager for an LDAP
  • An ES Server Security Configuration
  • Testing
  • Default Server and MFDS Configuration
Parent topic: Configuring ES and AD


Micro Focus User Groups and Resource Rules

The first two steps are normally accomplished by running the es-ldap-setup.cmd command script, just as if you were using the default Micro Focus LDAP security configuration (with MSS users defined using the microfocus-MFDS-User class). See "Setting-Up-LDAP-Security-with-Enterprise-Server.html" for more information.

Parent topic: Active Directory


Adding MSS User Attributes to the user Class

To update the definition of the user class in the Active Directory schema with the MSS user attributes, you can import the LDIF file ms-user-plus-mto.ldf, which should have been included with this document. Typically, you'll use a command line like the following:

ldifde -i -f ms-user-plus-mto.ldf -k -v -j . -c "DC=X" #schemaNamingContext

(Specify this command all on one line.)

For those unfamiliar with the ldifde command, the parameter #schemaNamingContext is a symbolic constant that will be replaced with the DN of the schema in your LDAP directory. The parameter DC=X is a placeholder in the LDIF file that will be replaced with the value of #schemaNamingContext by ldifde as it processes the file. So where the LDIF commands in the file specify "DC=X", they will actually update the LDAP schema.

If you are using a class other than user for your Windows users, you'll have to modify this LDIF file before importing it. See your Active Directory documentation or other LDIF reference material for more information on LDIF files.

Parent topic: Active Directory


Importing MSS Users

If you want to use the predefined users from the default LDAP configuration supplied by Micro Focus, you can import the LDIF file mto-users.ldf, which should have been included with this document. Typically, you'll use a command line like the following:

ldifde -i -f mto-users.ldf -k -v -j . -c "DC=X" user-container

(Specify this command all on one line.) user-container should be the distinguished name (DN) of the LDAP container that holds your Windows users.

If you are using a class other than user for your Windows users, you'll have to modify this LDIF file before importing it. See your Active Directory documentation or other LDIF reference material for more information on LDIF files.

Parent topic: Active Directory


Setting MSS User Attributes for Windows Users

You may want to set MSS user attributes, such as operator class or MSS user timeout, for some of your Windows users. Currently, this must be done manually using an AD administrative tool such as ADSIEdit, or by writing and importing a custom LDIF file. The MSS user attributes are listed briefly below; see the product documentation for more information.

MSS User Attributes

Attribute Name | Description
microfocus-MFDS-UID | Micro Focus user unique identifier; currently unused
microfocus-MFDS-User-MTO-Priority | MSS user priority
microfocus-MFDS-User-MTO-Timeout | MSS user timeout
microfocus-MFDS-User-MTO-OperatorClass | MSS operator class
microfocus-MFDS-User-MTO-OperatorID | MSS operator ID
microfocus-MFDS-User-MTO-GroupPrefix | MSS group prefix
microfocus-MFDS-User-CustomText | MF custom text field; currently unused
microfocus-MFDS-User-DefaultGroup | MSS default group
microfocus-MFDS-User-UseToken | passtoken signon authority (if tokens are not enabled in OS ESM)
microfocus-MFDS-User-CreateToken | passtoken creation authority (if tokens are not enabled in OS ESM)

Micro Focus plans to provide additional tools to maintain MSS user attributes in future releases.

Parent topic: Active Directory


Adding Windows Users to MSS Groups

MSS resource access is typically controlled by rules that apply to user groups rather than to individual users, so you will probably want to add your Windows users to MSS user groups (SYSADM, etc) as appropriate. See the product documentation for more information about MSS user groups and how groups are used.

MSS user groups will be defined in the user group container that was created as part of the initial ES LDAP setup process. Usually this container is called "Enterprise Server User Groups".

Adding a user to a group is simply a matter of adding that user's common name (CN), which is the user's Windows login name (without any domain prefix or suffix), to the microfocus-MFDS-Group-Member attribute of the appropriate group. This is a multi-valued attribute, so it can have any number of user names specified for it. You will need to use an AD administration tool such as ADSIEdit or a custom LDIF file to make this change.

Once you have completed ES configuration, you may be able to use the MFDS user group administration screens to add or remove users from groups. (This depends on appropriate configuration in MFDS, appropriate permissions granted to the user account used by the ESM module, and other factors, so it may not work for all installations.)

Micro Focus plans to provide additional tools to maintain MSS user groups in future releases.

Parent topic: Active Directory


Configuring mldap_esm Security Manager for an LDAP

The default mldap_esm security manager settings are designed for the simple LDAP configuration using AD LDS and the Micro Focus user class. Before the mldap_esm security manager can update the information in an LDAP server, you need to set a number of configuration options.

  • Set Connection Path to the IP address and port of the LDAP server (for example ad-host:389)
  • Set Authorized ID to the DN of a user with appropriate permissions for the LDAP repository (for example CN=Administrator,CN=users,DC=somecorp,DC=com ). This user must have at least read access to the containers for user definitions, MSS user groups, and MSS resource access rules, and their contents. If you want to use the MFDS administration console to change user groups and resource access rules, this ID will also need update access to those portions of the repository.
  • Set Password to the password for the user specified in Authorized ID.
  • In Configuration Information, you will need to set a number of LDAP parameters:
    [LDAP]
base=DN-suffix
user class=user class
user container=user-container
group container=group-container
resource container=resource-container
    DN-suffix | The common part of the DN for your user container, MSS group container, and MSS resource rules container. For example, if your users are in CN=users,DC=somecorp,DC=com, and your MSS containers are in CN=MF,DC=somecorp,DC=com, you could set base to DC=somecorp,DC=com.
    user class The LDAP object class used for your users. The following options are available:
    • microfocus-MFDS-User

      This is the default setting.

    • user

      Microsoft standard users are used and you cannot add or modify users from the MFDS user interface.

    user-container | The DN of the container for user objects, without the "base" suffix, for example: CN=users
    group-container | The DN of the container for MSS user group objects, without the "base" suffix, for example: CN=Enterprise Server Groups,CN=MF
    resource-container | The DN of the container for resource access class containers (which in turn hold resource access definition objects), without the "base" suffix, for example CN=Enterprise Server Resources,CN=MF
Parent topic: Active Directory
Parent topic: Configuring Security Using OpenLDAP


An ES Server Security Configuration

Now you need to create a security configuration for an Enterprise Server region to test the security managers and LDAP installation. You can use the "Default ES Security" configuration for this, but you may wish to set this security configuration just for a single test server initially.

To create the default ES security configuration, which will be used for all ES servers defined by that MFDS that do not have an individual security configuration, go to the "Default ES Security" tab under Configure Security Options. To create a security configuration for just one server, edit that server and select the "Security" tab, then uncheck the "Use default ES Security Manager configuration" option.

Your security configuration will specify the Security Managers you created in the previous two steps, with the OS ESM manager first:

To create this configuration, uncheck Use default ES Security Manager configuration (if it is checked) and click Apply. Then click the Add... button under Security Manager List to get the list of security managers. Choose the security manager you just defined for OS ESM (we called it "Windows" above) and click Add. Repeat the process to add the security manager you just defined for MLDAP ESM (called "Active Directory" in the previous step).

Make sure that the OS ESM manager is first in the list. If the security managers end up in the wrong order, use the down-arrow button to the right of the list to switch them.

Set any additional options that are appropriate for your requirements. See the Enterprise Server Security documentation for details.

Click OK to save the security configuration.

Parent topic: Active Directory


Testing

To test the security configuration, try to start the ES server you just configured. If it fails to start, look for errors in your MLDAP ESM Security Manager configuration, which is the most likely source of trouble.

When the server starts, try to sign on to CICS or ESMAC with your Windows username and password. You should also be able to change your password from those signon screens. (Remember that you will be changing your Windows domain password!)

You may also want to test resource access control. For example, the CICS transaction CENV should be available to all users (assuming the default ES/MSS security configuration rules are being used), but the CINQ transaction is only available to members of the OPERATOR and SYSADM groups. So with two test users (or one user that signs on using different signon groups, if you are not using the "Use all groups" option), you can confirm whether group permissions are being applied correctly.

Parent topic: Active Directory


Default Server and MFDS Configuration

Once you are satisfied with your security configuration, you may want to make it the default configuration for all ES servers (if it isn't already), or make it the security configuration for MFDS as well.

To make it the default ES security configuration, go to the Security options in MFDS, then to the Default ES Security tab, and follow the instructions listed above for creating the security configuration.

To make it the MFDS security configuration, you can either do the same on the MF Directory Server security tab, or, if you have made it the default ES security configuration, go to that tab and select the Use default ES Security Manager List option. Note that MFDS security is somewhat more complex than ES security, and consequently you're more likely to run into configuration issues with MFDS.

Parent topic: Active Directory


Restrictions

In this initial release, there are a number of restrictions and usability issues with this security configuration. Most of these should be remedied in later releases. Also, check the Readme file and other materials, as additional utilities may have been included after this document was written.

  • MSS User Migration
  • User Administration with MFDS
  • User Search Order
  • Windows Groups Not Used by ESF
Parent topic: Configuring ES and AD


MSS User Migration

This release of ES does not include a tool for migrating existing MSS users, defined in the Resource Definition (RDO) file dfhdrdat, to LDAP user classes other than microfocus-MFDS-User. The cas-to-ad tool that is used by es-ldap-setup can only create Micro Focus user objects.

If you have a significant number of MSS users (who are not already Windows users) to migrate, you may want to use the casrdtex utility to export the RDO definitions to a text file, which could be processed into an LDIF file using a scripting language such as Perl.

Parent topic: Restrictions


User Administration with MFDS

MFDS includes some administration capabilities for LDAP external security managers, if it is configured appropriately. (MLDAP must be using the ESM in question for its security, and the ESM must be configured with a user ID that has update authority for the LDAP objects. See the MFDS documentation for more information.)

With the configuration described in this document, MFDS can usually be used to administer MSS user groups and resource access definitions. Also, some user administration operations will succeed. However, other operations, such as changing the user's password, will either fail or have no effect, because they will update one of the user attributes which are not used in this configuration.

Parent topic: Restrictions


User Search Order

The OS ESM module uses the Windows LogonUser function to verify a user's credentials (username and password), in the following manner:

  1. Try LogonUser with the username and password, and the domain parameter set to ".", which means to search the local system.
  2. If that fails, call LookupAccountName to try to find the domain in which the user is defined. According to Microsoft's documentation, this will first search well-known names, then local accounts, then the primary domain, then other trusted domains, and then (for Windows 2000 and later) the domain forest.
  3. If LookupAccountName succeeds, try LogonUser again with the domain returned by LookupAccountName.

If a user is defined in multiple places on that search list, the OS ESM module only tries to authenticate the user in the first one it finds. Normally this will have the expected behavior (much like logging on to Windows conventionally), but in a complex domain configuration situation it could produce confusing results.

Currently there is no provision for forcing a particular domain or changing the search order. Those options may be added in later releases.

Parent topic: Restrictions


Windows Groups Not Used by ESF

ESF does not make any use of Windows user groups. All group-related resource access control is performed using MSS user groups.

Note, though, that Windows security policies which contain group rules that affect user login, such as restricting logins to particular hours of the day, will still have effect for users in those groups, just as they do for Windows login.

Parent topic: Restrictions


For More Information

For additional information about Active Directory or LDAP, consult your Microsoft documentation.

If you have questions, please contact Micro Focus Support.

Parent topic: Configuring ES and AD


Configuring Active Directory Users as Enterprise Server Administrators

With this configuration:

  • Windows users are stored in Active Directory, but Enterprise Server does not use Windows user authentication to authenticate administrators. You maintain user information and Enterprise Server administrator passwords using your LDAP management software.
  • Other user attributes (for example operator class) are stored as additional attributes of the Windows user objects in AD
Note: The content in this topic assumes that you have read the previous content, and are familiar with Active Directory and LDAPs.
  • Prerequisites
  • Giving a User ES Administration Authority
  • Create ES Security Managers
  • Setting the Default ES and MFDS Security Configuration
  • Verify the Security Configuration
Parent topic: Configuring Security using Active Directory


Prerequisites

Software

The following software is required to perform these procedures:

  • ADSIEdit.msc, the Microsoft AD management console that is shipped with AD LDS. You can run this from the Start menu or from the command line.

Information

You will need the following information:

  • A user account authorized to make AD schema changes (shown as AD-admin and AD-password below).
  • The user account in the domain controlled by your AD server that you will be granting ES administrative authority.

    To simplify the process we recommend that this account have a name that is no longer than eight characters, ASCII, and has no spaces; and that the account's "Common name" (the name that appears in the list of users on the domain controller, in the Active Directory Users and Computers console) be the same as its "Logon name" (shown in the Account tab of the user's Properties in Users and Computers). Also, you may run into problems if this account exists both on the domain and the local computer, with the same name but with different passwords.

    This account is shown as ES-admin and ES-password below.

  • The location of the AD server (shown as servername below).
  • The DN of the AD domain (shown as domain-DN below). Normally, this will be the fully-qualified domain name of the AD host, minus the hostname, with each segment of the name listed as a separate DC element, so for example server.dept.mydom.com would use:

    DC=dept,DC=mydom,DC=com

Preparation

This procedure assumes that you have already:

  • Configured your Active Directory schema and repository for ES LDAP-based security.
  • Installed an Enterprise Server product on at least one system.
Parent topic: Configuring Active Directory Users as Enterprise Server Administrators


Giving a User ES Administration Authority

  • Start ADSI Edit
  • Connect to Active Directory
  • Make the User an MSS System Administrator
Parent topic: Configuring Active Directory Users as Enterprise Server Administrators


Start ADSI Edit

The ADSI Edit management console lets you modify objects in the AD repository. You can use other LDAP tools to make these changes - for example, you can create LDIF files and use the ldifde utility to import them, which is useful for making changes in bulk - but this example uses ADSIEdit.

Run Start > Administrative Tools > ADSI Edit.

Parent topic: Giving a User ES Administration Authority


Connect to Active Directory

  1. In the left pane, select ADSI Edit.
  2. From the menu, select Action > Connect to...
  3. Enter the servername (the hostname of your AD server) for the connection name and server name. Select Distinguished name (DN) or naming context and enter the domain-DN. This is similar to: DC=dept,DC=mydom,DC=com Set the authorized user name and password to AD-admin and AD-password if you're not already logged on as that user.
Parent topic: Giving a User ES Administration Authority


Make the User an MSS System Administrator

  1. In the left pane, open your new connection and the folder inside it, then select the CN=Users folder, which contains your domain's users.
  2. In the right pane, select the user you want to modify (CN=ES-Admin).
  3. Choose Action > Properties.
  4. Widen the Attribute column so you can read the full name of each attribute. Scroll down to find the microfocus-MFDS-User-DefaultGroup attribute and double-click it.
  5. Set the attribute's value to SYSADM. This sets the MSS default group for the user; the SYSADM group has permission to start ES and so forth in the default ES LDAP security configuration. Click OK and close the Properties window.
Parent topic: Giving a User ES Administration Authority


Create ES Security Managers

  • MFDS Security Configuration Screen
  • LDAP Security Manager
Parent topic: Configuring Active Directory Users as Enterprise Server Administrators


MFDS Security Configuration Screen

Open a browser window and connect to http://es-host:86, where es-host is the hostname of the system running your COBOL development system.

On the left-side menu, click on Security.

Parent topic: Create ES Security Managers


LDAP Security Manager

You will need to create a security manager to get security rules from AD over LDAP, using the MLDAP ESM Module:

  1. Select the Security tab and click Add.
  2. Enter the following information:
    Fieldname | Contents
    Name | LDAP
    Module Name | mldap_esm
    Connection Path | The servername
    Authorized ID cn=AD-admin,cn=users,domain-DN, for example:

    cn=administrator,cn=users,DC=dept,DC=mydom,DC=com

    Password | AD-password
  3. In the Configuration Information text box, enter the following:
    [LDAP]
base=[domain DN]
user class=user
user container=CN=Users
group container=CN=Enterprise Server User Groups,
  CN=Micro Focus,CN=Program Data
resource container=CN=Enterprise Server Resources,
  CN=Micro Focus,CN=Program Data

[Verify]
mode=bind
password type=AD
  4. Click Add

Note that in a production environment you would not want to use your AD administrative ID for the security manager, since that would create a security risk. It is shown only for convenience here.

In production, you would use an ID that had only the necessary permission for the repository, based on your intended use. (Basic ES security functions only need read access to the user information and the folders under cn=Micro Focus,cn=Program Data. If you want to use MFDS to administer ES groups and resources under LDAP, you have to use an account that also has write permission to the MF program data objects.)

Parent topic: Create ES Security Managers


Setting the Default ES and MFDS Security Configuration

You use the Enterprise Server Administration user interface to perform these procedures.

  • Set the Default ES Security Configuration
  • Setting the MFDS Security Configuration
Parent topic: Configuring Active Directory Users as Enterprise Server Administrators


Set the Default ES Security Configuration

Set the Default ES Security Configuration to use your new security manager(s), so you can use your ES administrative ID to perform CAS functions such as starting and stopping an ES region.
  1. In the left panel, select Security.
  2. Select the Default ES Security tab.
  3. Click Add to add a security manager.
  4. Add your new security manager(s):
    1. Select LDAP and click Add.

      The Default ES Security tab should now show LDAP.

  5. Click Apply.
Parent topic: Setting the Default ES and MFDS Security Configuration


Setting the MFDS Security Configuration

Next, configure MFDS to use the same security configuration. If you do not do this, the enterprise server may not start because the Windows user account configured for starting ES is not known to the default MFDS security configuration. If you don't want to change the MFDS security configuration now, you can add that user to MFDS directly by editing the MFDS Internal Security security manager and clicking on Properties.

To use the same security configuration for ES regions and MFDS:

  • Return to the MFDS Security Options page if necessary, and select the MF Directory Server tab.
  • Check the Use default ES Security Manager List checkbox.
  • Click Apply. The MF Directory Server tab should now show the same security manager(s) as Default ES Security.
Parent topic: Setting the Default ES and MFDS Security Configuration


Verify the Security Configuration

The topics in this section describe how you can check that your Active Directory is configured correctly.

  • Verify that the ESDEMO Server Starts
  • Verify MFDS Restricted Access
Parent topic: Configuring Active Directory Users as Enterprise Server Administrators


Verify that the ESDEMO Server Starts

Go to aNet Express command prompt and try to start ESDEMO:

casstart /uES-admin /pES-password

where ES-admin and ES-password are the username and password of the user you edited in step 4 to grant ES administration permissions. (You can also start ESDEMO from MFDS and supply a username and password in the Use Enterprise Server credentials form, but this is easier to run again if you need to correct a typo or other problem.)

ESDEMO should start successfully. If it does not, here are some things to check:
  • ES-admin and ES-password are spelled correctly.
  • The ESDEMO console log (console.log) shows the MLDAP ESM module being loaded and initialized successfully. The location of the console log depends on your installation, but the default location is %USERPROFILE%\Documents\Micro Focus\Net Express x.x\WORKAREA \ESDEMO.
    • If the MLDAP ESM module fails to initialize because it can't connect to the server, check the Connection Path setting in the LDAP security manager in MFDS. Also check firewall configurations on both systems.
    • If the MLDAP ESM module cannot bind to the server, check the Authorized ID and Password settings in the LDAP security manager in MFDS.
    • If the MLDAP ESM module is logging other errors, check the text in the Configuration Information area in the LDAP security manager in MFDS, such as the DNs of the various containers. Errors here will prevent the ESM module from finding its data in AD.
  • The user's "common name" does not match the user's "logon name". A user in Active Directory has multiple names, which can be confusing. Users log on to Windows using the "logon name", which is normally a fairly short nickname (such as the user's initials). If you look at a user's properties in Active Directory, this name is shown on the Account tab.

    LDAP clients, such as the MLDAP ESM module, use a user's Distinguished Name (DN), which is formed using the user's Common Name (CN), and the Common Name is set by Windows when the user is created. By default, Windows sets the common name to the user's first name, middle initial, and last name.

    Since the MLDAP ESM only uses the common name, it doesn't matter if the logon name is different, but users might be confused if they can log on using their common name but not their logon name. Also, if the common name is longer than 8 characters or contains spaces, that may cause difficulties with the current version of ES. (Future ES versions will support long names better.)

    You can change a user's common name by renaming the user in Active Directory Users and Computers. After you rename the user, you can go back and reset the user's first and last name and display name (under the General tab of the Properties dialog), if you wish.

Parent topic: Verify the Security Configuration


Verify MFDS Restricted Access

Once ESDEMO starts successfully, you can try enabling restricted access in MFDS to validate your security configuration there. Return to your MFDS browser session and:

  1. On the left-side menu, click on Security.
  2. Select the MF Directory Server tab.
  3. Check the Restrict administration access checkbox.
  4. Click Apply.
  5. MFDS will prompt you to supply a username and password that are authorized under the existing security configuration (to authorize the change to a new security configuration). If you still have the predefined security configuration that's installed with the product, you can use schemaadmin here for the username and password.
  6. MFDS will prompt you to supply a username and password that are authorized under the new security configuration (to prevent you from locking yourself out). Enter your ES-admin user ID and its password.
  7. If this works, you'll be sent to the MFDS restricted-functionality home page. Click on Log On and try your ES-admin ID.
Parent topic: Verify the Security Configuration


Configuring Security Using OpenLDAP

The MLDAP ESM module mldap_esm enables the Security Facility to use an LDAP server as an external security manager. The MLDAP ESM module can communicate with a variety of LDAP servers including OpenLDAP servers. The server can operate either on the same machine as your Enterprise Server installation, or it can be remote.

The content in this section assumes that you have already installed on your server machine, OpenLDAP and the OpenLDAP server, and the Enterprise Server software that is used by your Micro Focus product.

Important: You can use the information in this section to configure LDAP types other than OpenLDAP.
  • About OpenLDAP for the Micro Focus Environment
  • Installing the Required Schema Extensions
  • Configuring the OpenLDAP server
  • Configuring mldap_esm Security Manager for an LDAP
Parent topic: Securing an Enterprise Server Installation


About OpenLDAP for the Micro Focus Environment

Within the LDAP directory, you define users, user groups, resource classes, and resources, and these objects contain the attributes used to make security checks (for the Verify, Auth, and XAuth procedures). Micro Focus defines an LDAP schema for these objects and their attributes, but in many cases you can adapt an existing directory for at least part of this information, for example in order to reuse an existing repository of user information.

When it processes a security request, the module searches the configured LDAP repository for relevant rules and applies whatever it finds.

The External Security Facility API documentation is available, in doxygen format, on the Micro Focus Supportline website's Examples and Utilities page.

  • Follow this link to the Examples and Utilities page:

    Micro Focus Supportline Examples and Utilities page

  • Follow this link to the External Security Facility API documentation:

    External Security Facility Manager API

Parent topic: Configuring Security Using OpenLDAP


Installing the Required Schema Extensions

Note: Before you commence this procedure, ensure that you have sufficient access, for example root access, to create files in the $COBDIR/lib directory.
  1. Make sure that the Micro Focus bin directory is in your path.
  2. Start a command prompt and go to the OpenLDAP install directory.
  3. cd to the schema directory.
  4. Generate the MFDS OpenLDAP schema by issuing the following command:
    mfds -l dc=x 2
    This creates a schema file, for example mfds_1.08.43.schema in the $COBDIR/lib directory.
  5. Now create a new file called container.schema, which must look like this
    objectclass (
       1.2.840.113556.1.3.23
       NAME 'container'
       SUP top
       STRUCTURAL
       MUST ( cn ) )
    The container objectclass is used to group collections of like objects within the LDAP server Directory Information Tree in the Micro Focus extensions.
    Note:

    It is very important that when this schema file is created, there is no trailing whitespace on any of the lines that the schema file contains.

  • Adding default MFDS users, user groups and resources
Parent topic: Configuring Security Using OpenLDAP


Adding default MFDS users, user groups and resources

  1. Create an LDIF file file containing the user, group and resource definitions by using the mfds -e command. For example:
    mfds -e "cn=Micro Focus,dc=my-domain,dc=com" "cn=Enterprise Server Users" "cn=Enterprise Server User Groups" "cn=Enterprise Server Resources" 2 "c:\program files\openldap\mfds_users.ldf"
  2. Import the generate file using ldapadd. For example:
    ldapadd -v -D "cn=Manager,dc=my-domain,dc=com" -w secret -f mfds_users.ldf
  3. Confirm the creation of the containers using ldapsearch. To dump the contents of the Micro Focus container use:
    ldapsearch -x -b "dc=my-domain,dc=com" -s sub +
Parent topic: Installing the Required Schema Extensions


Configuring the OpenLDAP server

  1. At the command prompt, cd to the OpenLDAP install base directory.
  2. Edit the OpenLDAP server configuration file, slapd.conf, to add the following include statements:
    include      ./schema/cosine.schema
include      ./schema/inetorgperson.schema
include      ./schema/container.schema
include      ./schema/mfds.schema

You can now start the OpenLDAP server.

  • Confirming Extension Installation
  • Creating Standard Micro Focus application containers
Parent topic: Configuring Security Using OpenLDAP


Confirming Extension Installation

  1. Issue the following command:
    ldapsearch -x -b "cn=subschema" -s base + > schema.txt
  2. Check the contents of the resulting file, schema.txt, to verify that there are attribute and objectClass entries that begin with "microfocus-".
Parent topic: Configuring the OpenLDAP server


Creating Standard Micro Focus application containers

Before adding the standard Micro Focus containers, the initial domain context object needs to be added.

  1. Create a file called top.ldf with contents similar to those shown below.
    dn: dc=my-domain,dc=com
objectClass: dcObject
objectClass: organization
dc: my-domain
description: My domain description
o: My domain
  2. To add the domain context object use:
    ldapadd -v -D "cn=Manager,dc=my-domain,dc=com" -w secret -f top.ldf

    The successful output should look something like the following:

    add objectClass:
        dcObject
        organization
add dc:
        my-domain
add description:
        My domain description
add o:
        My domain
adding new entry "dc=my-domain,dc=com"
modify complete

You can now add the standard Micro Focus containers.

  1. Create a file called mf-containers-open.ldf, with contents as follows:
    dn: cn=Micro Focus,dc=my-domain,dc=com
cn: Micro Focus
objectClass: container

dn: cn=Enterprise Server Resources,cn=Micro Focus,dc=my-domain,dc=com
cn: Enterprise Server Resources
objectClass: container

dn: cn=Enterprise Server Users,cn=Micro Focus,dc=my-domain,dc=com
cn: Enterprise Server Users
objectClass: container

dn: cn=Enterprise Server User Groups,cn=Micro Focus,dc=my-domain,dc=com
cn: Enterprise Server User Groups
objectClass: container
  2. Create the containers by issuing the following command:
    ldapadd -v -D "cn=Manager,dc=my-domain,dc=com" -w secret -f mf-containers-open.ldf
  3. Confirm the creation of the containers by using ldapsearch to dump the contents of the Micro Focus container:
    ldapsearch -x -b "dc=my-domain,dc=com" -s sub +
Parent topic: Configuring the OpenLDAP server


Examples

This section contains examples of using LDIF to define Enterprise Server security information in Active Directory.

  • Examples of RACF Commands Compared with Active Directory Definitions
  • Defining a User with LDIF
  • Defining a Group with LDIF
  • Defining CAS Resources with LDIF
  • Defining Files with LDIF
  • Defining the SURROGAT Class and Users with LDIF
  • Defining a CICS Transaction with LDIF
Parent topic: Securing an Enterprise Server Installation


Examples of RACF Commands Compared with Active Directory Definitions

  • FCT Control: RACF Command and AD Definition
  • DCT Control: RACF Command and AD Definition
  • JCT Control: RACF Command and AD Definition
  • DOCTEMPLATE Control: RACF Command and AD Definition
  • EXEC CICS START control: RACF Command and AD Definition
  • EXEC CICS LINK/XCTL/LOAD control: RACF Command and AD Definition
  • EXEC CICS SET/INQUIRE/ENABLE/DISABLE control: RACF Command and AD Definition
  • CAS Commands control: RACF Command and AD Definition
Parent topic: Examples


FCT Control: RACF Command and AD Definition

FCT control: RACF command

RDEFINE FCICSFCT (file1, file2, .., filen)
  UACC(NONE)

  NOTIFY(sys_admin_userid)
  PERMIT file1 CLASS(FCICSFCT) ID(group1, group2) ACCESS(UPDATE)
  PERMIT file2 CLASS(FCICSFCT) ID(group1, group2) ACCESS(READ)
Default CICS CLASS used: FCICSFCT

Parameters passed to ESM:

  Entity: File ID
  Facility: Terminal
  Transaction active

FCT control: Active Directory ldif

dn: CN=FCICSFCT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local

changetype: add
  objectClass: top
  objectClass: container
  description: CICS Class for FCT
dn: CN=FILESAF,CN=FCICSFCT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local

changetype: delete
dn: CN=FILESAF,CN=FCICSFCT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local

changetype: add
  objectClass: microfocus-MFDS-Resource
  microfocus-MFDS-Resource-Class: FCICSFCT
  microfocus-MFDS-Resource-ACE: allow:SAFU:update
  microfocus-MFDS-Resource-ACE: allow:PLTPISUR:update
  microfocus-MFDS-Resource-ACE: allow:SYSADM
  group:update
  microfocus-MFDS-Resource-ACE: allow:OPERATOR
  group:update
  microfocus-MFDS-Resource-ACE: deny:*:execute
  microfocus-MFDS-UID: mfuid
  description: FILE used by test
Parent topic: Examples of RACF Commands Compared with Active Directory Definitions


DCT Control: RACF Command and AD Definition

DCT control: RACF command

RDEFINE  DCICSDCT  (qid1, qid2, ..., qidn) UACC(NONE)
                   NOTIFY(sys_admin_userid)
PERMIT qid1 CLASS(DCICSDCT) ID(group1, group2) ACCESS(UPDATE)
PERMIT qid2 CLASS(DCICSDCT) ID(group1, group2) ACCESS(UPDATE)

Default CICS CLASS used: DCICSDCT

Parameters passed to ESM:

          Entity: DCT queue ID
          Facility: Terminal
          Transaction active

DCT control: Active Directory ldif

dn: CN=DCICSDCT,CN=Enterprise
  Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: top
  objectClass: container
  description: CICS Class for DCT

  dn: CN=STDQ,CN=DCICSDCT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: delete

  dn: CN=STDQ,CN=DCICSDCT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: microfocus-MFDS-Resource
  microfocus-MFDS-Resource-Class: DCICSDCT
  microfocus-MFDS-Resource-ACE: allow:SAFU:update
  microfocus-MFDS-Resource-ACE: deny:*:execute
  microfocus-MFDS-UID: mfuid
  description: TDQ used by test
Parent topic: Examples of RACF Commands Compared with Active Directory Definitions


JCT Control: RACF Command and AD Definition

JCT control: RACF command

RDEFINE  KCICSJCT  userjnls UACC(NONE)
                   ADDMEM(JRNL001, JRNL002, ....)
                   NOTIFY(sys_admin_userid)
PERMIT   userjnls  CLASS(KCICSJCT) ID(group_userid)
             ACCESS(UPDATE)

Default CICS CLASS used: JCICSJCT

Parameters passed to ESM:

  Entity: JCT ID
  Facility: Terminal
  Transaction active

JCT control: Active Directory ldif

dn: CN=JCICSJCT,CN=Enterprise
  Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: top
  objectClass: container
  description: CICS Class for JCT

  dn: CN=01,CN=JCICSJCT,CN=Enterprise Server Resources,
    CN=Micro Focus,CN=Program Data,DC=local
  changetype: delete

  dn: CN=01,CN=JCICSJCT,CN=Enterprise Server Resources,
    CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: microfocus-MFDS-Resource
  microfocus-MFDS-Resource-Class: JCICSJCT
  microfocus-MFDS-Resource-ACE: allow:SAFU:control
  microfocus-MFDS-Resource-ACE: deny:*:execute
  microfocus-MFDS-UID: mfuid
  description: JOURNAL used by test
Parent topic: Examples of RACF Commands Compared with Active Directory Definitions


DOCTEMPLATE Control: RACF Command and AD Definition

DOCTEMPLATE control: RACF command

RDEFINE RCICSRES (DOCTEMPLATE.doc1, DOCTEMPLATE.doc2, .., DOCTEMPLATE.docn)
                  UACC(NONE)
                  NOTIFY(sys_admin_userid)
PERMIT  DOCTEMPLATE.doc1
        CLASS(RCICSRES)
        ID(group1, group2)
        ACCESS(READ)

DOCTEMPLATE control: Active Directory ldif

dn: CN=*,CN=RCICSRES,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=mftesting,DC=com
changetype: delete

dn: CN=*,CN=RCICSRES,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=mftesting,DC=com
changetype: add
objectClass: microfocus-MFDS-Resource
microfocus-MFDS-Resource-Class: MFESMAC
microfocus-MFDS-Resource-ACE: allow:SYSAD:alter
microfocus-MFDS-Resource-ACE: allow:ESMAC:alter
microfocus-MFDS-Resource-ACE: allow:CICSUSER:read
microfocus-MFDS-Resource-ACE: deny:*:execute
microfocus-MFDS-UID: mfuid
description: Allow full access any URIMAP to SYSAD or ESMAC Users
Parent topic: Examples of RACF Commands Compared with Active Directory Definitions


EXEC CICS START control: RACF Command and AD Definition

EXEC CICS START control: RACF command

RDEFINE  ACICSPCT (tran1, tran2, ..., trann) UACC(NONE)
                  NOTIFY(sys_admin_userid)
PERMIT  tran1 CLASS(ACICSPCT)  ID(userid) ACCESS(READ)
PERMIT  tran2 CLASS(ACICSPCT)  ID(userid) ACCESS(READ)
  • TCICSTRN if a terminal is used on the EXEC CICS START
  • ACICSPCT if no terminal is used on the EXEC CICS START
  • SURROGAT if a user is specified on the EXEC CICS START
  • For TCICSTRN and ACICSPCT

    Entity: Transaction ID

    Facility: Terminal

  • For SURROGAT

    Entity: Surrogate Userid

    Entity-1-ptr: Surrogate ACEE

    Facility: Terminal

EXEC CICS START control: Active Directory ldif

dn: CN=ACICSPCT,CN=Enterprise Server
Resources,CN=Micro Focus,CN=Program Data,DC=local
changetype: add
objectClass: top
objectClass: container
description: CICS Class for started transactions
dn: CN=TCICSTRN,CN=Enterprise Server
Resources,CN=Micro Focus,CN=Program Data,DC=local
changetype: add
objectClass: top
objectClass: container
description: CICS Class for TRANSACTIONS
dn: CN=SSST,CN=ACICSPCT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local
changetype: delete
dn: CN=SSST,CN=ACICSPCT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local
changetype: add objectClass:
microfocus-MFDS-Resource microfocus-MFDS-Resource-Class: ACICSPCT
microfocus-MFDS-Resource-ACE: allow:SAFU:read
microfocus-MFDS-Resource-ACE:
allow:SAFUSUR:read
microfocus-MFDS-Resource-ACE: deny:*:execute
microfocus-MFDS-UID: mfuid
description: CICS START with SURROGAT
dn: CN=SAFT,CN=TCICSTRN,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local
changetype: delete
dn: CN=SAFT,CN=TCICSTRN,CN=Enterprise Server
Resources,CN=Micro Focus,CN=Program Data,DC=local
changetype: add
objectClass:
microfocus-MFDS-Resource microfocus-MFDS-Resource-Class: TCICSTRN
microfocus-MFDS-Resource-ACE: allow:SAFU:read
microfocus-MFDS-Resource-ACE:
deny:*:
execute
microfocus-MFDS-UID: mfuid description:
Transaction used by test
Parent topic: Examples of RACF Commands Compared with Active Directory Definitions


EXEC CICS LINK/XCTL/LOAD control: RACF Command and AD Definition

EXEC CICS LINK/XCTL/LOAD control: RACF command

RDEFINE  MCICSPPT  (prog1, prog2, ..., progn)  UACC(NONE)
                  NOTIFY(sys_admin_userid)
PERMIT  prog1 CLASS(MCICSPPT)  ID(userid) ACCESS(READ)
PERMIT  prog2 CLASS(MCICSPPT)  ID(userid) ACCESS(READ)

Default CICS CLASS used: MCICSPPT

Parameters passed to ESM:

  • Entity: Program Name
  • Facility: Terminal
  • Transaction active

EXEC CICS LINK/XCTL/LOAD control: Active Directory ldif

dn: CN=MCICSPPT,CN=Enterprise
  Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: top
  objectClass: container
  description: CICS Class for PPT

  dn: CN=SAFLINK,CN=MCICSPPT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: delete

  dn: CN=SAFLINK,CN=MCICSPPT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: microfocus-MFDS-Resource
  microfocus-MFDS-Resource-Class: MCICSPPT
  microfocus-MFDS-Resource-ACE: allow:SAFU:control
  microfocus-MFDS-Resource-ACE: deny:*:execute
  microfocus-MFDS-UID: mfuid
  description: Program to test LINK
Parent topic: Examples of RACF Commands Compared with Active Directory Definitions


EXEC CICS SET/INQUIRE/ENABLE/DISABLE control: RACF Command and AD Definition

EXEC CICS SET/INQUIRE/ENABLE/DISABLE control: RACF command

RDEFINE  CCICSCMD CMDSAMP UACC(NONE)
                   NOTIFY(sys_admin_userid)
                  ADDMEM(AUTINSTMODEL, AUTOINSTALL, CONNECTION,
                  DSNAME, TRANSACTION, TRANDUMPCODE, VTAM)
PERMIT CMDSAMP CLASS(VCICSCMD) ID(operator_group) ACCESS(READ)
Default CICS CLASS used: CCICSCMD
  Parameters passed to ESM:

  Entity: Resource name

  Facility: Terminal

  Transaction active
  Resource Name can be:
  'PROCESSTYPE'.
  'LINE'.
  'MVSTCB'.
  'LSRPOOL'.
  'MAPSET'.
  'PARTITIONSET'.
  'SESSIONS'.
  'TYPETERM'.
  'EXITPROGRAM'.
  'JOURNALMODEL'.
  'REQID'.
  'TRACEDEST'.
  'TRACEFLAG'.
  'TRACETYPE'.
  'TSQUEUE'.
  'AUTINSTMODEL'.
  'AUTOINSTALL'.
  'BRFACILITY'.
  'CLASSCACHE'.
  'CONNECTION'.
  'CORBASERVER'.
  'DB2CONN'.
  'DB2ENTRY'.
  'DB2TRAN'.
  'DELETSHIPPED'.
  'DISPATCHER'.
  'DJAR'.
  'DOCTEMPLATE'.
  'DSNAME'.
  'DUMPDS'.
  'ENQMODEL'.
  'EXCI'.
  'FILE'.
  'IRC'.
  'JOURNALNAME'.
  'JVM'.
  'JVMPOOL'.
  'JVMPROFILE'.
  'MODENAME'.
  'MONITOR'.
  'PARTNER'.
  'PROFILE'.
  'PROGRAM'.
  'REQUESTMODEL'.
  'STATISTICS'.
  'STORAGE'.
  'STREAMNAME'.
  'SYSDUMPCODE'.
  'SYSTEM'.
  'TASK'.
  'TCLASS'.
  'TCPIP'.
  'TCPIPSERVICE'.
  'TDQUEUE'.
  'TERMINAL'.
  'TRANDUMPCODE'.
  'TRANSACTION'.
  'TSMODEL'.
  'TSPOOL'.
  'TSQNAME'.
  'UOW'.
  'UOWDSNFAIL'.
  'UOWENQ'.
  'UOWLINK'.
  'VTAM'.
  'WEB'.
  'WORKREQUEST'.
  'DUMP'.
  'RESETTIME'.
  'FEPIRESOURCE'.
  'BEAN'.
  'CFDTPOOL'.
  'RRMS'.
  'SUBPOOL'.
  'SECURITY'.
  'SHUTDOWN'.
  'UNKNOWN'.

EXEC CICS SET/INQUIRE/ENABLE/DISABLE control: Active Directory ldif

dn: CN=CCICSCMD,CN=Enterprise
  Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: top
  objectClass: container
  description: CICS Class for CMDS

  dn: CN=PROGRAM,CN=CCICSCMD,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: delete

  dn: CN=PROGRAM,CN=CCICSCMD,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: microfocus-MFDS-Resource
  microfocus-MFDS-Resource-Class: CCICSCMD
  microfocus-MFDS-Resource-ACE: allow:PLTPISUR:control
  microfocus-MFDS-Resource-ACE: allow:SAFU:control
  microfocus-MFDS-Resource-ACE: allow:SYSADM
  group:control
  microfocus-MFDS-Resource-ACE: deny:*:execute
  microfocus-MFDS-UID: mfuid
  description: PROGRAM entity for EXEC CICS SET/ENABLE/DISABLE commands

  dn: CN=EXITPROGRAM,CN=CCICSCMD,CN=Enterprise Server
  Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: delete

  dn: CN=EXITPROGRAM,CN=CCICSCMD,CN=Enterprise Server
  Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: microfocus-MFDS-Resource
  microfocus-MFDS-Resource-Class: CCICSCMD
  microfocus-MFDS-Resource-ACE: allow:PLTPISUR:control
  microfocus-MFDS-Resource-ACE: allow:SAFU:control
  microfocus-MFDS-Resource-ACE: allow:SYSADM
  group:control
  microfocus-MFDS-Resource-ACE: deny:*:execute
  microfocus-MFDS-UID: mfuid
  description: EXITPROGRAM entity for EXEC CICS SET/ENABLE/DISABLE commands

  dn: CN=TRANSACTION,CN=CCICSCMD,CN=Enterprise Server
  Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: delete

  dn: CN=TRANSACTION,CN=CCICSCMD,CN=Enterprise Server
  Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: microfocus-MFDS-Resource
  microfocus-MFDS-Resource-Class: CCICSCMD
  microfocus-MFDS-Resource-ACE: allow:PLTPISUR:control
  microfocus-MFDS-Resource-ACE: allow:SAFU:control
  microfocus-MFDS-Resource-ACE: allow:SYSADM
  group:control
  microfocus-MFDS-Resource-ACE: deny:*:execute
  microfocus-MFDS-UID: mfuid
  description: TRANSACTION entity
Parent topic: Examples of RACF Commands Compared with Active Directory Definitions


CAS Commands control: RACF Command and AD Definition

CASSTART/CASSTOP/CASFILE/CASSUB/CASOUT Commands control: RACF command

  • CLASS used:

    OPERCMDS Parameters passed to ESM:

  • Entity:

    Command (casstart/casstop/casfile/cassub/casout)

CASSTART/CASSTOP/CASFILE/CASSUB/CASOUT Commands control: Active Directory ldif

dn: CN=OPERCMDS,CN=Enterprise
  Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: top
  objectClass: container
  description: CICS Class for casstart/casstop/casfile....

  dn: CN=casstart,CN=OPERCMDS,CN=Enterprise
  Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: delete

  dn: CN=casstart,CN=OPERCMDS,CN=Enterprise
  Server Resources,CN=Micro Focus,CN=Program Data,DC=local
  changetype: add
  objectClass: microfocus-MFDS-Resource
  microfocus-MFDS-Resource-Class: OPERCMDS
  microfocus-MFDS-Resource-ACE: allow:SAFU:alter
  microfocus-MFDS-Resource-ACE: allow:SYSAD:alter
  microfocus-MFDS-Resource-ACE: allow:SYSADM
  group:alter
  microfocus-MFDS-Resource-ACE: deny:*:execute
  microfocus-MFDS-UID: mfuid
  description: casstart users
Parent topic: Examples of RACF Commands Compared with Active Directory Definitions


Defining a User with LDIF

Command | Description
dn: CN=SEC01,CN=Enterprise Server Users,CN=Micro Focus,CN=Program Data,DC=local | Identifies user SEC01
changetype: delete | Action is set to delete, the current definition for user SEC01 will be deleted
 | You must leave a blank line between actions
dn: CN=SEC01,CN=Enterprise Server Users,CN=Micro Focus,CN=Program Data,DC=local | Identifies user SEC01
changetype: add | Action is set to add
objectClass: microfocus-MFDS-User | Object class, we are defining a User
microfocus-MFDS-UID: no | UID (Unique Identifier). use mfuid as the value
microfocus-MFDS-User-CreateToken: self | User can create a passtoken for himself. (Used for single signon, the user can sign into MFDS and credentials will be passed to ESMAC)
microfocus-MFDS-User-MTO-Priority: 0 | User priority
microfocus-MFDS-User-MTO-Timeout: 0 | User login timeout in minutes, 0 means no timeout. (Inactivity when signed on)
microfocus-MFDS-User-MTO-OperatorClass: 0 | Operator Class
microfocus-MFDS-User-DefaultGroup: PAYROLL | Default group. A user as a default group, but can be part of several groups. The default group is used if the user does not specify a group when login in
microfocus-MFDS-User-AllowLogon: TRUE | TRUE if the user can login to a terminal or ESMAC
microfocus-MFDS-User-Pwd: literal:UserPassword | User password, this can be changed by the user using ESMAC or CESN
microfocus-MFDS-User-UseToken: self | The User can be signed using a passtoken created for himself (Used for single signon)
description: User Description | User description, used for documentation purposes
Parent topic: Examples


Defining a Group with LDIF

Command | Description
dn: cn=PAYROLL,CN=Enterprise Server User Groups,CN=Micro Focus,CN=Program Data,DC=local | Identifies group PAYROLL
changetype: delete | Action is set to delete, the current definition for group PAYROLL will be deleted
 | You must leave a blank line between actions
dn: cn=PAYROLL,CN=Enterprise Server User Groups,CN=Micro Focus,CN=Program Data,DC=local | Identifies group PAYROLL
changetype: add | Action is set to add
adminDisplayName: Payroll group | Display Name
objectClass: microfocus-MFDS-Group | Object class, we are defining a Group
microfocus-MFDS-UID: no | UID (Unique Identifier). use mfuid as the value
description: People who can process Payroll | Description for the group
microfocus-MFDS-Group-Member: SEC01 | User SEC01 is part of the group
microfocus-MFDS-Group-Member: SEC02 | More than one user can be added to the group
microfocus-MFDS-Group-Member: SEC03 |
Parent topic: Examples


Defining CAS Resources with LDIF

Command | Description
dn: CN=OPERCMDS,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies resource OPERCMDS
changetype: add | action set to add, will create the resource
objectClass: top | This is a main class
objectClass: container | will contain entities
description: Class for operator commands used by casstart/casstop/casout/casfile/cassub commands | description
 | You must leave a blank line between actions
dn: CN=casstart,CN=OPERCMDS,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the entity we want to delete
changetype: delete | action set to delete, we remove any existing definition
 | You must leave a blank line between actions
dn: CN=casstart,CN=OPERCMDS,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the entity we want to create
changetype: add | action set to add in order to create the entity
objectClass: microfocus-MFDS-Resource | We are creating a resource
microfocus-MFDS-Resource-Class: OPERCMDS | name of the class that the entity belongs to
microfocus-MFDS-Resource-ACE: allow:SYSADM group:alter | Terminology definition, we allow any one from SYSADM group to start the ES region
microfocus-MFDS-Resource-ACE: deny:*:execute | We deny all the others
microfocus-MFDS-UID: no | UID (Unique Identifier). use mfuid as the value
description: casstart command to start an ES region | description
 | You must leave a blank line between actions
dn: CN=casstop,CN=OPERCMDS,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the entity we want to delete
changetype: delete | action set to delete, we remove any existing definition
 | You must leave a blank line between actions
dn: CN=casstop,CN=OPERCMDS,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the entity we want to create
changetype: add | action set to add in order to create the entity
objectClass: microfocus-MFDS-Resource | We are creating a resource
microfocus-MFDS-Resource-Class: OPERCMDS | name of the class that the entity belongs to
microfocus-MFDS-Resource-ACE: allow:SYSADM group:alter | Terminology definition, we allow any one from SYSADM group to stop the ES region
microfocus-MFDS-Resource-ACE: deny:*:execute | We deny all the others
microfocus-MFDS-UID: no | UID (Unique Identifier). use mfuid as the value
description: casstop command to stop an ES region | description
Parent topic: Examples


Defining Files with LDIF

Command | Description
dn: CN=DATASET,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies resource DATASET
changetype: add | action set to add, will create the resource
objectClass: top | This is a main class
objectClass: container | will contain entities
description: Class for controlling access to datasets | Description
 | You must leave a blank line between actions
dn: CN=**EZACONFG,CN=DATASET,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the entity. CICS will use the physical filename when calling AUTH, if you do not want to specify the path, you can use '**' in front of the file, meaning any characters.
changetype: delete | action set to delete, we remove any existing definition
 | You must leave a blank line between actions
dn: CN=**EZACONFG,CN=DATASET,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the entity we want to create
changetype: add | action set to add in order to create the entity
objectClass: microfocus-MFDS-Resource | We are creating a resource
microfocus-MFDS-Resource-Class: DATASET | name of the class that the entity belongs to
microfocus-MFDS-Resource-ACE: allow:SYSADM group:update | Terminology definition, users or groups that can access the resource and their authorisation. In this case we allow any one from SYSADM group to update the file.
microfocus-MFDS-Resource-ACE: allow:SEC01:update | more than one Terminology definition can be added
microfocus-MFDS-UID: no | UID (Unique Identifier). use mfuid as the value
description: EZASOKET Configuration file | description of the resource
Parent topic: Examples


Defining the SURROGAT Class and Users with LDIF

Command | Description
dn : CN=SURROGAT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the SURROGAT resource
changetype : add | action set to add, will create the resource
objectClass : top | this is a main class
objectClass : container | will contain entities
description: Class for CICS SURROGATE users. JES Class for controlling access to job submission by surrogates. | description
 | You must leave a blank line between actions
dn : CN=PLTPISUR,CN=SURROGAT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the entity we want to delete
changetype : delete | action set to delete, we remove any existing definition
 | You must leave a blank line between actions
dn : CN=PLTPISUR,CN=SURROGAT,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the entity we want to create
changetype : add | action set to add in order to create the entity
objectClass : microfocus-MFDS-Resource | We are creating a resource
microfocus -MFDS-Resource-Class: SURROGAT | name of the class that the entity belongs to
microfocus -MFDS-Resource-ACE: allow:SYSAD:read | Terminology definition, we allow SYSAD to be a surrogat user of PLTPISUR
microfocus -MFDS-Resource-ACE: deny:*:execute | Terminology definition, we deny everyone else
microfocus -MFDS-UID: no | UID (Unique Identifier). use mfuid as the value
description: SAF SURROGAT user for PLTPI. Add all users that can start ES to it | description
Parent topic: Examples


Defining a CICS Transaction with LDIF

Command | Description
dn: CN=TCICSTRN,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the TCICSTRN resource
changetype: add | action set to add, will create the resource
objectClass: top | this is a main class
objectClass: container | will contain entities
description: CICS transactions, normal attach security | description
 | You must leave a blank line between actions
dn: CN=TRN1,CN=TCICSTRN,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the TRN1 entity
changetype: delete | action set to delete, will delete the entity
 | You must leave a blank line between actions
dn: CN=TRN1,CN=TCICSTRN,CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data,DC=local | Identifies the TRN1 entity
changetype: add | action set to add, will create the entity
objectClass: microfocus-MFDS-Resource | We are creating a resource
microfocus-MFDS-Resource-Class: TCICSTRN | name of the class that the entity belongs to
microfocus-MFDS-Resource-ACE: allow:ALLUSER group:read | Terminology definition, we grant anyone from group ALLUSER read access
microfocus-MFDS-Resource-ACE: deny:*:execute | Terminology definition, we deny everyone else
microfocus-MFDS-UID: no | UID (Unique Identifier). use mfuid as the value
description: My first Transaction | description
Parent topic: Examples


Managing an LDAP from the Enterprise Server UI

You use the mldap_esm security manager to configure an LDAP for use with your Enterprise Server installation. You can configure a security manager so that you can use it to administer the LDAP information from the MFDS user interface. This applies to Active Directory and other LDAP implementations, for example OpenLDAP.

Note:

Typically:

  • You use your LDAP's administration and management functionality to configure and manage your LDAP.
  • You use the Enterprise Server user interface to make minor changes to LDAP configurations.
  • About Managing an LDAP
  • Changing User Passwords Stored in an LDAP
  • About Users, Groups and Resources
  • Managing User Access
  • Managing Groups
  • Assigning Resource Permissions
  • Security Configuration Screen Help
Parent topic: Securing an Enterprise Server Installation


About Managing an LDAP

You can use the property screens for a security manager definition that uses mldap_esm to add, edit and delete user, group and resource definitions held in the associated LDAP repository, and for specifying resource permissions.

The mldap_esm security manager binds at configuration time only to the LDAP server, using credentials supplied as part of its configuration. All the privileges that it has for that repository are determined by those credentials. Therefore, in order to manage users, groups and resources through these property screens, you will need to ensure that these credentials have sufficient permissions on the LDAP server.

Note:

The MF Directory Server user ID with which you access the property screens is not related in any way to the credentials with which the mldap_esm security manager connects to the LDAP server. For added protection, when you attempt to access the security manager property screens, MF Directory Server will switch to "Restrict administration access" mode, requiring you to enter valid MF Directory Server user credentials.

Note also that when no authorized ID and password is specified in the security manager definition, the mldap_esm security manager uses the user ID, CN=MFReader,CN=ADAM Users,CN=Micro Focus,CN=Program Data,DC=local (though the last two components can be changed by setting the base DN), which is the user object created for this purpose in the sample configuration, and the password "mf_rdr" to connect to the LDAP repository. Of course, as these values are well known, you should not give MFReader write permission to your LDAP repository.

Instead of storing user passwords in the LDAP repository, the Security Facility stores password verifiers, in the form of salted MD5 hashes.

Parent topic: Managing an LDAP from the Enterprise Server UI


Changing User Passwords Stored in an LDAP

There are various ways for Enterprise Server users to change passwords stored in an LDAP. The Security Facility relays these requests to the security managers that are used to verify the user. Whether or not a password change request is honoured by a security manager depends on that manager and the security manager module that is used to connect to it.

When using the mldap_esm security manager, changing a user's password involves changing an attribute of the associated user object in the LDAP repository. This in turn requires that the mldap_esm security manager has write access to the repository. However, the mldap_esm security manager does not connect to the repository with the credentials of the user requesting the password change; it uses the authorized id and password that are specified in the Edit Security Manager screen.

In order to enable the mldap_esm security manager to support the changing of user passwords, you need to modify the security manager definition to specify an authorized user ID and password that has write access to the Enterprise Server user objects within the LDAP repository. The ID and password combination that you supply should, of course, be secret. To do this:

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the definition that you want to edit by clicking the relevant radio button in the Select column.
  4. Click Edit.
  5. In the Authorized ID field, supply the username used to bind to the LDAP server. The format for this is server-dependent, but is usually a Distinguished Name.

    This user should have read access to the Enterprise Server user, group, and resource objects in the LDAP repository, and modify access to user definitions to support letting users change their passwords from ES (for example from the CICS signon screen).

  6. In the Password field specify the password used to bind to the LDAP server.
  7. Click OK.
Note:

When no authorized ID and password is specified in the security manager definition, the MLDAP ESM uses the user ID, CN=MFReader,CN=ADAM Users,CN=Micro Focus,CN=Program Data,DC=local (though the last two components can be changed by setting the base DN), which is the user object created for this purpose in the sample configuration, and the password mf_rdr to connect to the LDAP repository. Of course, as these values are well known, you should not give MFReader write permission to your LDAP repository.

Parent topic: Managing an LDAP from the Enterprise Server UI


About Users, Groups and Resources

Each item (for example, program, file, transaction) to which access is controlled is a called a resource. A resource has a name and a class, which indicates the type of the resource. For example, each enterprise server is a resource, and all enterprise servers belong to the same resource class.

A resource name must be unique within its class. That is, you can define two or more resources with the same name, provided that they belong to different classes.

MSS resources use various class names defined by IBM. Non-MSS resources, such as ES configuration definitions in MF Directory Server, use resource class names defined by Micro Focus (using syntax that's not permitted for MSS resource class names, to avoid collisions). Users can also define their own resource classes for performing explicit access checks in applications.

When a user requests access to a resource the security facility relays the request to the external security manager, specifying the user, the resource and the resource class. The security manager will then look for resource rules that match the resource name. The processing of a request is dependent on the external security manager.

Where your ESM module provides suitable support, as is the case with the mldap_esm module, you can use the Enterprise Server Administration screens to define users, groups, resource classes and resources (referred to as resource entities). In defining a resource entity, you are specifying a rule against which an authorization request can be matched. Depending on your ESM, the resource entity might have a full resource name, or might contain wildcards. This allows you to write a single rule to apply to multiple resources.

With the mldap_esm module, for example, each resource entity has an Access Control List (ACL) that specifies access rights for that resource. Each entry in an ACL is referred to as an Access Control Entry, or ACE. These entries identify a user or group, and what permissions are to be granted or denied to them.

Users can be assigned to many user groups, and depending on your security manager and your security configuration a user may be allowed the permissions of all the groups to which he or she belongs, a particular group specified when the user signed on, or a default group specified as part of the user definition. For more details see Using all groups to which a user belongs.

Note:

For Micro Focus Directory Server access, users always have the permissions of all the groups to which they belong.

Parent topic: Managing an LDAP from the Enterprise Server UI
Related information
To add a user
To edit a user
To delete a user
To add a group
To edit a group
To delete a group
To add a resource class
To edit a resource class
To delete a resource class
To add a resource entity
To edit a resource entity
To delete a resource entity
To assign resource permissions
To view permissions for a user
To view permissions for a group
To assign resource permissions when using MFDS Internal Security


Managing User Access

The property screens for a security manager definition can be used for adding, editing and deleting user, group and resource definitions held in the associated external security manager (ESM), and for specifying resource permissions. This functionality is dependent on the ESM module, with which you connect to the ESM, providing support, and on the ESM honouring the requests submitted through these screens. Where such support is not available, users, groups and resources must be managed through the tools provided with your external security manager. Please check the documentation provided with your ESM module for details.

In addition to the conditions listed above, the security manager definition must be included in the security manager list that is used by MF Directory Server.

  • To Add a User
  • To Edit a User
  • To Delete a User
  • To View Permissions for a User
Parent topic: Managing an LDAP from the Enterprise Server UI


To Add a User

In order to use these property screens, your user account must have User Administration permissions.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers, and for the security manager to which the user is to be added, click the radio button in the Select column.
  3. Click Edit .
  4. Click Properties.
  5. Click Users.
  6. Click Add.
  7. Specify the user's details.

    For information about the entry fields, refer to the page help for this screen.

  8. Click Next.
  9. Type a description of the user in Description.
  10. For each user group of which the user is to be a member, select the group from User groups, and click <--Add.
  11. If you change your mind and want to remove the user from any group, select the group from Member of and click Remove-->.
  12. Click Add.
Enter the tasks the user should do after finishing this task (optional).
Parent topic: Managing User Access


To Edit a User

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the user definition that you want to edit by clicking the relevant radio button in the Select column.
  4. Click Edit .
  5. Click Properties .
  6. Click Users.

    The users screen is divided into tabs. The label of the tab indicates the start character(s) of the user ids that are listed on the tab.

  7. Select the tab containing the user you wish to edit.
  8. Click Edit for the user.
  9. Specify the user's details.

    For information about the entry fields, please refer to the page help for this screen.

  10. Click OK.
Parent topic: Managing User Access


To Delete a User

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the user to be deleted by clicking the relevant radio button in the Select column.
  4. Click Edit .
  5. Click Properties .
  6. Click Users.

    The users screen is divided into tabs. The label of the tab indicates the start character(s) of the user ids that are listed on the tab.

  7. Select the tab containing the user you wish to delete.
  8. Click Edit for the user that you wish to delete.
  9. Click Delete.
  10. Click OK on the User Delete Confirmation page.
Parent topic: Managing User Access


To View Permissions for a User

In order to use these property screens, your user account must have User Administration permissions.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the user definition that you want to view by clicking the relevant radio button in the Select column.
  4. Click Edit .
  5. Click Properties .
  6. Click Users.

    The users screen is divided into tabs. The label of the tab indicates the start character(s) of the user ids that are listed on the tab.

  7. Select the tab containing the user you wish to edit.
  8. Click Edit for the user.
  9. Click Permissions.

    The screen displays a tree structure. Expanding the top level node displays the various resource classes. Expanding a class displays the resource entities that it contains and the permissions that the user has for those entities. Please note, the permissions displayed are for those Access Control List entries that apply to the user, either by fully specifying the user's ID or by a wildcard match.

Parent topic: Managing User Access


Managing Groups

The property screens for a security manager definition can be used for adding, editing and deleting user, group and resource definitions held in the associated external security manager (ESM), and for specifying resource permissions. This functionality is dependent on the ESM module, with which you connect to the ESM, providing support, and on the ESM honouring the requests submitted through these screens. Where such support is not available, users, groups and resources must be managed through the tools provided with your external security manager. Check the documentation provided with your ESM module for details.

In addition to the conditions listed above, the security manager definition must be included in the security manager list that is used by MF Directory Server

  • To Add a Group
  • To Edit a Group
  • To Delete a Group
  • To View Permissions for a Group
Parent topic: Managing an LDAP from the Enterprise Server UI


To Add a Group

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager to which the group will be added by clicking the relevant radio button in the Select column.
  4. Click Edit .
  5. Click Properties .
  6. Click Groups.
  7. Click Add.
  8. Specify the details for the group.

    The group name cannot exceed eight characters and longer names will be truncated to the first eight characters. For more information about the entry fields, please refer to the page help for the screen.

  9. Click Next.
  10. Under Permissions, check each permission that you want to grant to the group. If you want to grant all permissions under the Directory Server Administration or Servers sections, click the appropriate Allow All button.

    The permissions are displayed in an inverted tree structure. Those on lower branches include the permissions on the branches from which they descend. For example, the permission to restore a repository includes the permission to import a repository. Therefore, restore is shown as a descendant of import.

    When you grant a particular permission, any permissions that it includes are automatically granted. Hence, when you check the Restore Repository permission, the Import Repository permission is automatically checked as well.

    Where a check box for a permission is greyed out, it indicates that the permission is included by other permissions that have been granted to the group. To revoke a permission that is included by others, you must first revoke those other permissions.

  11. Type a description of the user in Description.
  12. For each user group of which the user is to be a member, select the group from User groups, and click <--Add.
  13. If you change your mind and want to remove the user from any group, select the group from Member of and click Remove-->.
  14. Click Add.
Parent topic: Managing Groups


To Edit a Group

In order to perform this, your user account must have User Administration permissions.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the group that you want to edit by clicking the relevant radio button in the Select column.
  4. Click Edit .
  5. Click Properties .
  6. Click Groups.
  7. Click the Edit button adjacent to the group you want to edit.
  8. Specify the details for the group.

    For information about the entry fields, please refer to the page help for the screen.

  9. Click OK.
Parent topic: Managing Groups


To Delete a Group

In order to perform this, your user account must have User Administration permissions.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the group that you want to delete by clicking the relevant radio button in the Select column.
  4. Click Edit .
  5. Click Properties .
  6. Click Groups.
  7. Click the Edit button adjacent to the group you want to delete.
  8. Click Delete.
  9. Click OK on the Delete User Group confirmation page.
Parent topic: Managing Groups


To View Permissions for a Group

In order to use these property screens, your user account must have User Administration permissions.

Note:

Please note that the display and setting of permissions for MFDS Internal Security differs from that for other Security Managers, and is covered separately by To assign resource permissions when using MFDS Internal Security.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the group definition that you want to view by clicking the relevant radio button in the Select column.
  4. Click Edit .
  5. Click Properties .
  6. Click Groups.
  7. Click Edit for the group.
  8. Click Permissions.

    The screen displays a tree structure. Expanding the top level node displays the various resource classes. Expanding a class displays the resource entities that it contains and the permissions that the group has for those entities. Please note, the permissions displayed are for those Access Control List entries that apply to the group, either by fully specifying the group ID or by a wildcard match.

Parent topic: Managing Groups


Assigning Resource Permissions

The property screens for a security manager definition can be used for adding, editing and deleting user, group and resource definitions held in the associated external security manager (ESM), and for specifying resource permissions. This functionality is dependent on the ESM module, with which you connect to the ESM, providing support, and on the ESM honouring the requests submitted through these screens. Where such support is not available, users, groups and resources must be managed through the tools provided with your external security manager. Please check the documentation provided with your ESM module for details.

In addition to the conditions listed above, the security manager definition must be included in the security manager list that is used by MF Directory Server.

In order to use these property screens, your user account must have User Administration permissions. .

  • About Resource Security
  • To Add a Resource Class
  • To Add a Resource Entity
  • To Assign Resource Permissions
  • To Edit a Resource Class
  • To Edit a Resource Entity
  • To Assign Resource Permissions When Using MFDS Internal Security
  • To Delete a Resource Class
  • To Delete a Resource Entity
Parent topic: Managing an LDAP from the Enterprise Server UI


About Resource Security

You can control access by a transaction to the following types of resource:

  • Files
  • Transient data queues
  • Temporary storage queues
  • Journals
  • Other transactions
  • To Enable Resource Security
Parent topic: Assigning Resource Permissions


To Enable Resource Security

To enable resource security, do the following:

  1. Specify that a transaction is to perform resource security checking, by checking Security: Resource Level Checking on the PCT page in ESMAC for the transaction. (By default, transactions do not perform resource security checking.)
  2. Specify a set of resource keys in the resource table entry (for example, the FCT entry for a file). Each resource key is a number in the range 1 through 24.
  3. Specify a set of resource keys in a user's SNT entry. A user can access a resource if one or more of the resource keys for the resource matches a resource key specified in that user's SNT entry.

The figure below illustrates the process of resource key checking.

Figure 1. Resource key checking
Resource key checking
Parent topic: About Resource Security


To Add a Resource Class

In order to use these property screens, your user account must have User Administration permissions.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the resource class definition that you want to edit by clicking the relevant radio button in the Select column.
  4. Click Edit .
  5. Click Properties .
  6. Click Resources.
  7. Click Add.
  8. Specify the details for the resource class.

    For information about the entry fields, please refer to the page help for the screen.

  9. Click Add.
Parent topic: Assigning Resource Permissions


To Add a Resource Entity

In order to use these property screens, your user account must have User Administration permissions.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager to which the resource will be added by clicking the relevant radio button in the Select column.
  4. Click Edit.
  5. Click Properties .
  6. Click Resources.

    This displays a list of available resource classes.

  7. Click the Edit button adjacent to the resource class to which the new resource will belong.
  8. Click Add.
  9. Specify the details for the resource.

    For information about the entry fields, please refer to the page help for the screen.

  10. Click Add.
Parent topic: Assigning Resource Permissions


To Assign Resource Permissions

In order to use these property screens, your user account must have User Administration permissions.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the resource by clicking the relevant radio button in the Select column.
  4. Click Edit.
  5. Click Properties.
  6. Click Resources.

    This displays a list of available resource classes.

  7. Click the Edit button adjacent to the resource class to which the resource belongs.

    This displays a list of available resources.

  8. Click the Edit button adjacent to the resource.
  9. Specify the Access Control List(ACL) string for the resource.

    The ACL specifies the access rights for the resource entity. Each entry in an ACL is referred to as an Access Control Entry, or ACE. These entries are separated by semi-colons.

    Each ACE specifies an actor, which is a user, a wildcard pattern for users, or a group, and one or more permissions that are granted (allow) or denied (deny) to that actor. The format for the ACE is as follows:

    setting:actor:action-1,...,action-n

    Where:

    • setting is allow or deny
    • actor is the name of a user, a pattern with one or more wildcards (see Wildcards) string that will be matched against the user's name, or a group name or wildcard pattern followed by a space and the word group (eg "ADMIN group")
    • action-1 through action-n are permission tokens:
      • none
      • execute
      • read
      • update
      • add
      • delete
      • control
      • alter
      • all

    For example, the following ACL string:

    allow:Test group:Execute,Read,Update,Add,Delete;allow:Operator group:Read

    assigns the Test group execute, read, update, add and delete permissions for the resource, and assigns the Operator group read permission.

  10. Click OK.
Parent topic: Assigning Resource Permissions


To Edit a Resource Class

In order to use these property screens, your user account must have User Administration permissions.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the resource class definition that you want to edit by clicking the relevant radio button in the Select column.
  4. Click Edit .
  5. Click Properties .
  6. Click Resources.

    This displays a list of available resource classes.

  7. Click the Edit button adjacent to the resource class you want to update.
  8. Specify the details for the class.

    For information about the entry fields, please refer to the page help for the screen.

  9. Click Apply.
Parent topic: Assigning Resource Permissions


To Edit a Resource Entity

In order to use these property screens, your user account must have User Administration permissions.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the resource by clicking the relevant radio button in the Select column.
  4. Click Edit.
  5. Click Properties .
  6. Click Resources.

    This displays a list of available resource classes.

  7. Click the Edit button adjacent to the resource class to which the resource belongs.

    This displays a list of available resources.

  8. Click the Edit button adjacent to the resource.
  9. Specify the details for the resource.

    For information about the entry fields, please refer to the page help for the screen.

  10. Click OK.
Parent topic: Assigning Resource Permissions


To Assign Resource Permissions When Using MFDS Internal Security

The display and setting of permissions when using MFDS Internal Security differs from that of other security managers. In its model, you cannot create resource entities, or define Access Control Lists for them. Instead there is a predefined set of permissions, which you view and set through the permissions tab when editing user groups. Users inherit their permissions from the groups to which they belong.

The instructions below are for setting permissions for a group. For instructions on adding users to groups, see To assign one or more users to a user group and To assign a user to one or more user groups.

Note:

The permissions that you grant to a group for starting, stopping, adding, deleting and modifying enterprise servers can also be overridden for individual enterprise servers. For details, see To assign permissions on a specific enterprise server when using MFDS Internal Security.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the MFDS Internal Security Manager by clicking the relevant radio button in the Select column.
  4. Click Edit .
  5. Click Properties .
  6. Click Groups.
  7. Click the Edit button adjacent to the group you want to assign permissions to.
  8. Under Permissions, check each permission that you want to grant to the group. If you want to grant all permissions under the Directory Server Administration or Servers sections, click the appropriate Allow All button.

    The permissions are displayed in an inverted tree structure. Those on lower branches include the permissions on the branches from which they descend. For example, the permission to restore a repository includes the permission to import a repository. Therefore, restore is shown as a descendant of import.

    When you grant a particular permission, any permissions that it includes are automatically granted. Hence, when you check the Restore Repository permission, the Import Repository permission is automatically checked as well.

    Where a check box for a permission is greyed out, it indicates that the permission is included by other permissions that have been granted to the group. To revoke a permission that is included by others, you must first revoke those other permissions.

Parent topic: Assigning Resource Permissions


To Delete a Resource Class

In order to use these property screens, your user account must have User Administration permissions.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the resource class definition that you want to delete by clicking the relevant radio button in the Select column.
  4. Click Edit .
  5. Click Properties .
  6. Click Resources.

    This displays a list of available resource classes.

  7. Click the Edit button adjacent to the resource class you want to delete.
  8. Click Delete.
  9. Click OK on the Delete Confirmation page.
Restriction: You cannot delete a class which contains resources.
Parent topic: Assigning Resource Permissions


To Delete a Resource Entity

In order to use these property screens, your user account must have User Administration permissions.

  1. Click Security under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  2. Click Security Managers.
  3. Select the security manager containing the resource by clicking the relevant radio button in the Select column.
  4. Click Edit.
  5. Click Properties .
  6. Click Resources.

    This displays a list of available resource classes.

  7. Click the Edit button adjacent to the resource class to which the resource belongs.

    This displays a list of available resources.

  8. Click the Edit button adjacent to the resource.
  9. Click the Delete.
  10. Click OK on the Delete Confirmation page.
Parent topic: Assigning Resource Permissions


Migrating from Enterprise Server Early Versions

For Enterprise Server releases after release 5.0 Websync 2, the Enterprise Server security architecture changed significantly. The topics in this section cover issues relating to migrating your security configurations from earlier releases.

  • Integrating Security from Early Releases: casesm
  • Exporting MFDS Internal Security Definitions
  • AD LDS Migration Tasks
  • Importing Existing ES/MSS Users into Active Directory
Parent topic: Securing an Enterprise Server Installation


Integrating Security from Early Releases: casesm

The CAS ESM Module (casesm) uses the Enterprise Server legacy security definitions (stored in the CICS resource tables).

Parent topic: Migrating from Enterprise Server Early Versions


Exporting MFDS Internal Security Definitions

The topics in this section describe the process you use to export the configurations defined in the MFDS Internal Security module so that you can use them to configure an Active Directory.

  • To Export Micro Focus LDAP Schema Extensions
  • To Export Users and Groups to an LDIF File
  • To store the directory server repository in an LDAP server
Parent topic: Migrating from Enterprise Server Early Versions


To Export Micro Focus LDAP Schema Extensions

Before you can use an LDAP repository to hold information for Micro Focus applications, its schema must be extended to support the Micro Focus objects. To do this, you create an LDIF (Lightweight Directory Interchange Format) file containing the extensions.

Use themfds -L command line options to do this.

Syntax:

mfds -L [schema partition Distinguished Name] option ldif-filename [schema-version-1] [schema-version-2]

Parameters:

schema partition Distinguished Name | Specifies the DN of the partition in the Directory Information Tree where the schema definition is held. The schema partition holds, amongst other things, attributeSchema and classSchema objectclass instances.
option | Specifies the target directory server type: 0 = Microsoft Active Directory Lightweight Directory Server (AD LDS), 1 = Active Directory (Default), 2 = OpenLDAP, 3 = Sun Directory. Note: If you specify the ldif-filename, you must also specify a value for this parameter.
ldif-filename | Specifies the name of the destination file. Default: mfds_schema_[ mfds version ].ldf (e.g. mfds_schema_1.05.09.ldf)
schema-version-1 | Specifies the version of the schema extensions to be generated: 0 = current schema version (Default). Numbers greater than 0 specify older schema versions.
schema-version-2 | This option is used for upgrading from a previous schema. If schema-version-2 is specified and is less the schema-version-1, the output file is a delta between the schema-version-1 and schema-version-2. If schema-version-2 is greater than or equal to schema-version-1, this option is ignored.

Example:

To create a LDIF file called mfds-schema.ldf specifically for an Active Directory using the this_machine.mycom.com AD server, issue:

mfds -L DC=mycom,DC=com 1 c:\mfds-schema.ldf

However, in practice, rather than using a specific schema partition DN value, administrators may want to have a portable LDIF file where the root DN can be specified externally. If the Windows LDFIDE tool is used to extend the repository schema, the generated LDF file could use DC=X as the schema partition name. This can then be replaced at import time. For example,

mfds -L DC=X 1

should be sufficient for most installations.

Parent topic: Exporting MFDS Internal Security Definitions


To Export Users and Groups to an LDIF File

  1. To export existing Directory Server users and groups from the MF Directory Server repository to an LDIF file, use the mfds -e command. The syntax is as follows:

    mfds -e root DNuser partition DNgroup partition DNresource partition DNschema formatldif-filenamesec-path

    root DN | The application partition to which all of the exported entries will be assigned.
    user partition DN | The name of the container within the application partition to which the exprted users will be assigned.
    group partition DN | The container within the application partition to which the exported groups will be assigned.
    resource partition DN | The container within the application partition to which the exported resource definitions will be assigned.
    schema format | Values: 1 = Active Directory (Default), 2 = OpenLDAP.
    sec-path | The location of the MF Directory Server repository.

    For example, the following command exports MF Directory Server users, groups and resources to an Active Directory compatible LDIF file.

    mfds -e "CN=Micro Focus,CN=Program Data,DC=local" "CN=Enterprise Server Users"
"CN=Enterprise Server Groups" "CN=Enterprise Server Resources" 1 mfdsusers.ldf
    CN=Micro Focus,CN=Program Data,DC=local | specifies the application partition to which all exported entries will be assigned
    CN=Enterprise Server Users | specifies the container within the application partition to which the exported users will be assigned
    CN=Enterprise Server Groups | specifies the container within the application partition to which the exported groups will be assigned
    CN=Enterprise Server Resources | specifies the container within the application partition to which the exported resource definitions will be assigned
Parent topic: Exporting MFDS Internal Security Definitions


To store the directory server repository in an LDAP server

  1. Update the schema of the target LDAP server to support the Enterprise Server configuration objects. How you do this will vary slightly depending on the particular LDAP server that you are using. In all cases, you will use the MFDS -L command to create an LDIF file containing the necessary extensions and then use the relevant import command for your LDAP server.
  2. Click Options under Configure on the menu on the left-hand side of an Enterprise Server Administration Web page.
  3. From the drop-down list under Repository location select ldap://.
  4. Specify the LDAP server, connection information and the LDAP credentials required to write to the server.
Parent topic: Exporting MFDS Internal Security Definitions


AD LDS Migration Tasks

This section details the tasks required to migrate your security configuration used by Enterprise Server configured using the previous Enterprise Server security infrastructure, that is up to and including release 5.1 Websync 2..

  • To extend an AD LDS repository to support Enterprise Server configuration objects
  • To update an extended AD LDS repository to support changes to Enterprise Server configuration objects
  • To migrate Directory Server users to an AD LDS repository
  • To Migrate Enterprise Server Users to an AD LDS Repository
  • To configure the security facility to use the MLDAP ESM
  • Implementing Enterprise Server Security with Active Directory
Parent topic: Migrating from Enterprise Server Early Versions


To extend an AD LDS repository to support Enterprise Server configuration objects

  1. Create an LDIF file containing the required schema extensions by using the mfds -L command. For example, at the command line, enter:
    mfds -L DC=X 1 mfds_schema.ldf

    This creates an LDIF file mfds_schema.ldf. The DC=X specifies distinguished name for the schema partition string assigned to each entry in the LDIF file. You could specify the actual destination here, but typically you will want to create a portable file. In this example, we use DC=X and replace it with the appropriate value when we import.

  2. Use the LDIFDE command to import the generated LDF file into AD LDS. For example,
    ldifde -I -v -k -c "DC=X" CN=Schema,CN=Configuration,
DC=customer_dom,DC=com -f mfds_schema.ldf

    The -c option replaces the schema partition string specified when creating the LDIF file with the schema partition into which the objects are to be imported. In this example, the container is CN=Schema,CN=Configuration, DC=customer_dom,DC=com but it will vary depending on your particular circumstances. If using AD LDS, the schema partition root can be extracted using the schemaNamingContext RootDSE attribute value e.g.

    ldifde -i -f mfds-schema.ldf -s -k -v -j . -c "DC=X" #schemaNamingContext
Important: You must have sufficient rights to modify the LDAP schema and the schema must be writable.
Parent topic: AD LDS Migration Tasks


To update an extended AD LDS repository to support changes to Enterprise Server configuration objects

If you have previously extended an AD LDS repository to support Enterprise Server configuration objects, you will need to update the schema to include later changes. The steps involved are described below. If you have not previously extended the repository, simply follow the instructions in

  1. Create a delta LDIF file file containing the latest schema extensions by using the mfds -L command. For example, at the command line, enter:
    mfds -l DC=X 1 AD_MF_schema_delta.ldf 0 1

    This creates an LDIF file mfds_schema.ldf. The DC=X specifies distinguished name for the schema partition string assigned to each entry in the LDIF file. You could specify the actual destination here, but typically you will want to create a portable file. In this example, we use DC=X and replace it with the appropriate value when we import.

    The 1 following DC=X indicates that the generated file is to be in Active Directory/AD LDS format. The 0 following the file name indicates that a delta containing the most recent definitions should be generated. The 1 at the end of the command indicates that the delta is to include definitions since version 1 of the schema (version 1 was released with Net Express WS02).

  2. Use the LDIFDE command to import the generated LDF file into AD LDS. For example,
    ldifde -i -v -k -c "DC=X" CN=Schema,CN=Configuration,
DC=customer_dom,DC=com -f mfds_deleta.ldf

    The -c option replaces the schema partition string specified when creating the LDIF file with the schema partition into which the objects are to be imported. In this example, the container is CN=Schema,CN=Configuration, DC=customer_dom,DC=com but it will vary depending on your particular circumstances. If using AD LDS, the schema partition root can be extracted using the schemaNamingContext RootDSE attribute value e.g.

    ldifde -i -f mfds-delta.ldf -s -k -v -j . -c "DC=X" #schemaNamingContext
Important: You must have sufficient rights to modify the LDAP schema and the schema must be writable.
Parent topic: AD LDS Migration Tasks


To migrate Directory Server users to an AD LDS repository

Before you can do this, the target repository must be extended to support the Enterprise Server configuration objects. How you do this will vary slightly depending on the particular LDAP server that you are using. In all cases, you will create use the MFDS -L command to create an LDIF file containing the necessary extensions and then use the relevant import command for your LDAP server.

  1. Create an LDIF file file containing the user and group definitions by using the mfds -e command. For example, at the command line, enter:
    mfds -e "CN=Micro Focus,CN=Program Data,DC=local" "CN=Enterprise Server Users"
"CN=Enterprise Server Groups" "CN=Enterprise Server Resources" 1 mfds_users.ldf
    In this example:
    "CN=Micro Focus,CN=Program Data,DC=local" | specifies the application partition to which all exported entries will be assigned
    "CN=Enterprise Server Users" | specifies the container within the application partition to which the exported users will be assigned
    "CN=Enterprise Server Groups" | specifies the container within the application partition to which the exported groups will be assigned
    "CN=Enterprise Server Resources" | specifies the container within the application partition to which the exported resource definitions will be assigned

    This creates an LDIF file mfds_users.ldf.

  2. Use the LDIFDE command to import the generated LDF file into AD LDS. For example,
    ldifde -i -f fds_users.ldf -s localhost:389 -k -v -j
Important: You must have sufficient rights to modify the AD LDS container and the container must be writable.
Parent topic: AD LDS Migration Tasks


To Migrate Enterprise Server Users to an AD LDS Repository

Before you can migrate your users, the target repository must be extended to support the Enterprise Server configuration objects. How you do this will vary slightly depending on the particular LDAP server that you are using. In all cases, you will create use the MFDS -L command to create an LDIF file containing the necessary extensions and then use the relevant import command for your LDAP server.

The Monitor and Control users are defined in Sign On Table (SNT) entries. These are stored in a file called dfhdrdat. By default this is stored in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\files\sys . This has an associated index file, dfhdrdat.idx. Both files must be in the same location. If dfhdrdat.idx doesn't exist, it is created the first time dfhdrdat is accessed.

  1. Use the cas-to-ad.exe utility to do migrate the users. The utility has a number of options for specifying your LDAP directory credentials, target container, server details, path to the dfhdrdat file, password encoding and the information to be displayed.

    Examples:

    cas-to-ad
    cas-to-ad -u myuser -p password -r . -l localhost:389

    This extracts user definitions from dfhdrdat and attempt to import them into your LDAP Directory.

Parent topic: AD LDS Migration Tasks


To configure the security facility to use the MLDAP ESM

The Enterprise Server External Security Facility connects to external LDAP servers through the MLDAP ESM module. To configure this:

  1. Add a security manager to the security manager pool as described by To add a security manager to the pool and specify the following details:
    • Name - This is the name (for example, you might call it MLDAP) that you will use to refer to the security manager when adding it to particular security manager lists.
    • Module - Enter mldap_esm.
    • Connection Path - Enter the address for your LDAP server (e.g. localhost:389).
    • Authorized ID and Password - These refer to the credentials that the MLDAP ESM module will use to connect to and, if you are using the MF Directory Server screens for managing users and resources, write any necessary information to the LDAP server.

    Make sure that the Enabled option is checked. If it is not, the security manager will not be used by any security manager list to which it is added.

  2. Add the security manager to the security manager list for the relevant servers. See To add a security manager to an enterprise server's security manager list, To add a security manager to the Directory server's security manager list and To add a Security Manager to the Default ES Security Manager List.
Parent topic: AD LDS Migration Tasks
Related concepts
Configuring Microsoft Users
Related tasks
To Configure a Security Manager's Environment


Implementing Enterprise Server Security with Active Directory

If you enable external security in Enterprise Server, then you need to understand the implications and how security is checked upon an action. This document describes the relationship between a user and the different classes used to implement security.

In order to use External Security with Enterprise Server, you need first to create users and groups in Active Directory. These users and groups will have different properties, these properties will be used to verify that the user can access a resource.

Parent topic: AD LDS Migration Tasks


Importing Existing ES/MSS Users into Active Directory

You can import existing ES/MSS users from a CAS RDO (Resource Definition Online) file into Active Directory.

To import those users, use the Micro Focus cas-to-ad utility. This program reads a CAS RDO file, adding each user it finds to AD. (It will also try to add the CAS system users such as CICSUSER, but they were already added in the previous step.) The basic command is:

cas-to-ad -u - -d "domain-DN" -c "user-container" -l servername -U userclass

Be sure to enter the options just as shown above - they are case-sensitive. Ignore any warning messages about users that already exist.

The user-container parameter will typically be either "CN=Enterprise Server Users,CN=Micro Focus,CN=Program Data" if you are using microfocus-MFDS-User, or "CN=Users" if you are using Windows users (the Microsoft user class).

The servername parameter can also be specified as a URL, as in "-l ldap://servername". If your LDAP server uses a non-default port, you can specify that as well.

You can also use LDAP-over-SSL by using an "ldaps" URL: "ldaps://servername". (Requires cas-to-ad 1.4.0 or later.) This will only work if your server supports LDAP-over-SSL (this is usually true with Active Directory running on newer Windows domain controllers). Also, the LDAP client library will have to verify the Active Directory server's certificate, which may fail if your server uses a certificate signed by an unusual Certification Authority. If you want to use LDAP-over-SSL but cas-to-ad fails to connect to AD, contact your AD administrator for a copy of the signing certificate and instructions for installing it in your client system's trusted root certificate store.

cas-to-ad will look for the RDO file (dfhdrdat) in the directory specified by the environment variable TXRDTP. If that environment variable is not set, cas-to-ad looks in the current directory, then in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\files\sys directory (default location). To specify a different location, add "-r path" to the command line.

If cas-to-ad complains that it can't open your RDO file, it may be in use. Copy dfhdrdat.* to a temporary directory and use the -r path option to tell cas-to-ad to use the copy.

The "-u -" option binds (logs on) to AD as the current Windows user. If you are not logged in as a user with the necessary authority, or if you are running cas-to-ad remotely from a system in a different domain, you will need to specify a different user ID. You will also be prompted for a password, unless you specify it on the command line with the -p option. For example:

cas-to-ad -u domain\Administrator

or

cas-to-ad -u "CN=Administrator,CN=Users,domain-DN"

or to avoid having to enter the password when prompted:

cas-to-ad -u domain\Administrator -p password

Run "cas-to-ad -h" for a usage message to see other options.

Note that in some cases AD may not let you set passwords on unencrypted connections, so this command may fail if you use the -u option. This should be fixed in a future release; for now, if you encounter this problem, run cas-to-ad on a system in the same domain as the AD server. You can also get an encrypted connection by using LDAP-over-SSL, as described above.

  • Create MFDS objects LDIF file
  • Set MFDS user passwords
  • Import the MFDS Objects
Parent topic: Migrating from Enterprise Server Early Versions


Create MFDS objects LDIF file

Extract MFDS users, groups, and resources from your existing MFDS configuration:

mfds -e "domain-DN" "user-container" "CN=Enterprise Server User Groups,CN=Micro Focus,CN=Program Data" "CN=Enterprise Server Resources,CN=Micro Focus,CN=Program Data" 1 mfds_users.ldf userclass

Set domain-DN, user-container, and userclass as in previous commands. Be careful not to confuse user-container (CN=...) and userclass (microfocus-MFDS-User or user), which is easy to do.

(If you are using AD LDS rather than AD, you can specify "0" instead of "1" before mfds_users.ldf. This will produce a slightly different .ldf file that will tell AD LDS that the passwords for the MFDS users do not expire.)

This command will create mfds_users.ldf.

Parent topic: Importing Existing ES/MSS Users into Active Directory


Set MFDS user passwords

If you are using the microfocus-MFDS-User object class for your users, MFDS will set their password attribute (microfocus-MFDS-User-Pwd) in mfds_users.ldf using the password hashes it has for those users. This means MFDS users will continue to have the same passwords.

If you are using the user object class for your users, currently MFDS does not set user password attributes, which means the newly-imported MFDS users have no passwords. Until this is fixed, you will either need to edit the mfds_users.ldf file before importing it and add the appropriate password attributes, or you will have to set the passwords manually after the users are imported:

  • To set a password in the LDIF file, add this attribute to the user: userPassword: password (AD will automatically encrypt this password.)
  • To set a password manually, you can use the Microsoft ADSI Edit utility ADSIedit.msc: right-click on a user and choose "Reset Password".
  • You can also use normal Windows system administration mechanisms to set user passwords, since the user class uses standard Windows passwords.

At a minimum, you will need at least one MFDS administrative user with a password (such as schemaadmin), so you can log on to MFDS. Typically, you will also want at least one user with "modify" authority for use by ES and MFCS; this will usually be an MSS user as well, since it will need MSS authority to start and stop the region (if security is configured for the ES server). The SYSAD user is usually used for this purpose, at least during initial installation and verification. (You can delete these users later.)

If you want to continue using unsecured ES regions, you will need to set the passwords for the mf_cs and mf_mdsa predefined users.

By default, the passwords for MFDS predefined users are the same as their usernames.

Once you have successfully configured ES LDAP-based security for MFDS, you may also be able to use MFDS to set passwords, depending on details of your configuration.

Parent topic: Importing Existing ES/MSS Users into Active Directory


Import the MFDS Objects

ldifde -i -f mfds_users.ldf -s servername -k -j .

Note that since you specified your domain-DN when creating mfds_users.ldf, you do not need a -c option for this command.

Parent topic: Importing Existing ES/MSS Users into Active Directory


Security Reference Information

This section contains security-related reference information.

  • Environment Variables used in Enterprise Server Security
  • Resource Classes used by Enterprise Server
  • Solutions, Restrictions, and Changes in Behavior
Parent topic: Securing an Enterprise Server Installation


Environment Variables used in Enterprise Server Security

The following topics are concerned with the environment variables that you are likely to use in the context of Enterprise Server security.

  • Enterprise Server Default Users and Associated Enviroment Variables
  • Variables for Configuring MSS Security Behaviour
  • Environment Variables for CICS Resource Classes
Parent topic: Security Reference Information


Enterprise Server Default Users and Associated Enviroment Variables

Enterprise Server has a set of default users that are used when no user is logged on for CICS, JES, IMS or ESMAC authentication. These users and the associated environment variables are:

Environment | User | Associated Environment Variable
ESMAC | mfuser | ES_USR_DFLT_ESMAC
CICS | CICSUSER | ES_USR_DFLT_CICS
JES | JESUSER | ES_USR_DFLT_JES
IMS | IMSUSER | ES_USR_DFLT_IMS

Using the environment variables, the default users can be overwritten by the users of your choice. For instance we could overwrite the ESMAC default user using in the region configuration.

configuration:
[ES-Environment]
ES_USR_DFLT_ESMAC=ESMACUSR
Parent topic: Environment Variables used in Enterprise Server Security


Variables for Configuring MSS Security Behaviour

The variables below are used to control CICS and IMS security processing. They correspond to CICS and IMS intialization parameters for the mainframe, with a prefix of ES_ESM.

  • ES_ESM_CMDSEC
  • ES_ESM_PLTPISEC
  • ES_CESN_NO_OS390
  • ES_ESM_PLTPIUSR
  • ES_ESM_RCF
  • ES_ESM_RESSEC
  • ES_ESM_SECPRFX
  • ES_ESM_XUSER
  • ES_OLD_SEC_TSTD
  • ES_SURROGATE_JOB_USER
Parent topic: Environment Variables used in Enterprise Server Security


ES_ESM_CMDSEC

Use this variable to determine whether CICS processing should honor the CMDSEC option specified on a transaction's PLT definition.
Setting | Result
ASIS | The CMDSEC option of a transaction's resource definition will be honored. That is, command security checking is performed only when CMDSEC is set to YES on the transaction resource definition.
ALWAYS | CICS processing always performs command security checking irrespective of the CMDSEC setting on the transaction definition.
Parent topic: Variables for Configuring MSS Security Behaviour


ES_ESM_PLTPISEC

Use this variable to choose the desired level of security checking for PLTPI processing.
Setting | Result
NONE | No security will be performed for PLTPI processing
ALL | Resource security check and Command security check will be performed
RESSEC | Only Resource security check will be performed
CMDSEC | Only Command security check will be performed
Parent topic: Variables for Configuring MSS Security Behaviour


ES_CESN_NO_OS390

Use this variable to override the default behaviour CESN transaction response for invalid user credentials. Default behaviour reports "Your userid is invalid" or "Your password is invalid". Setting this variable to any value will cause CESN to produce an invalid credential message instead.

Example:

ES_CESN_NO_OS390=secured
Parent topic: Variables for Configuring MSS Security Behaviour


ES_ESM_PLTPIUSR

Use this to specify the userid under the authority of which PLT programs will run during CICS initialization. The userid must have appropriate authorization (as determined by the PLTPISEC parameter) to access all the resources used by the programs. Enterprise Server will check that the CICS region has authority to act as a surrogate for the userid specified.

If you do not specify PLTPIUSR, the user specified when starting the enterprise server/CICS region is used. Where this is the case, this user must have appropriate authorization on the resources used by the PLT programs.

Parent topic: Variables for Configuring MSS Security Behaviour


ES_ESM_RCF

Use this variable if RACF is to be used for command authorization.
Setting | Result
A | Includes options T, C, and S.
C | Specifies that RACF is to be used for ETO terminal command authorization.
N | Specifies that no sign-on, transaction, or command authorization is to be performed by RACF.
S | Specifies that RACF is to be used for static and ETO terminal command authorization. Includes option C.
T | Specifies that RACF is to be used for sign-on and transaction authorization.
Y | Includes options T and C.
Parent topic: Variables for Configuring MSS Security Behaviour


ES_ESM_RESSEC

Use this parameter to determine whether CICS processing should honor the RESSEC option specified on a transaction's PLT definition.
Setting | Result
ASIS | The RESSEC option of a transaction's resource definition will be honored. That is, resource security checking is performed only when RESSEC is set to yes on the PLT definition.
ALWAYS | CICS processing always performs resource security checking irrespective of the RLS security setting on the transaction definition.
Parent topic: Variables for Configuring MSS Security Behaviour


ES_ESM_SECPRFX

Use this to determine whether or not CICS processing should prefix the resource names when making security queries.
Setting | Result
NO | No prefixes are used
YES | Resource names are prefixed with the CICS region user ID.
prefix | This string will be used as the prefix for resource names. It can be 1 to 8 upper case alphanumeric characters and it must start with an alphabetic character.
Parent topic: Variables for Configuring MSS Security Behaviour


ES_ESM_XUSER

Use this to determine whether or not CICS processing will perform surrogate user checks.
Setting | Result
NO | No surrogate user checking is performed.
YES | Perform surrogate user checking wherever such checks are permitted.
Parent topic: Variables for Configuring MSS Security Behaviour


ES_OLD_SEC_TSTD

Use this to prevent security being enforced for TS or TD queues that are not defined in your security repository.
Setting | Result
Any value | Security will not be enforced for TS and TD queues that are not defined as entities within the security repository.
Important: If you do not set this variable, and you enable security for your enterprise server, you must declare each TS or TD that your transactions will access in your security repository.
Parent topic: Variables for Configuring MSS Security Behaviour


ES_SURROGATE_JOB_USER

Use this to associate a user ID with a job when submitting for processing through the internal reader from CICS.
Setting | Result
Any value | The user ID that started the ES region is used in the job submission.
No value | The CICS default user CICSUSER, or as specified by ES_USR_DFLT_CICS, is used in the job submission.
Parent topic: Variables for Configuring MSS Security Behaviour


Environment Variables for CICS Resource Classes

The variables listed below can be used to override the default CICS resource classes.

Environment variable | Default class | Possible values | Prefix letter if a name is specified + 7 letters of the name
ES_CLASS_XPCT | ACICSPCT | YES/NO/NAME | A
ES_CLASS_XCMD | CCICSCMD | YES/NO/NAME | C
ES_CLASS_XDCT | DCICSDCT | YES/NO/NAME | D
ES_CLASS_XFCT | FCICSFCT | YES/NO/NAME | F
ES_CLASS_XJCT | JCICSJCT | YES/NO/NAME | J
ES_CLASS_XPPT | MCICSPPT | YES/NO/NAME | M
ES_CLASS_XPSB | PCICSPSB | YES/NO/NAME | P
ES_CLASS_XRES | RCICSRES | YES/NO/NAME | R
ES_CLASS_XTST | SCICSTST | YES/NO/NAME | S
ES_CLASS_XTRAN | TCICSTRN | YES/NO/NAME | T

For instance if you set ES_CLASS_XTRAN to the value MYTRANS then CICS will look for TMYTRANS as the class.

Parent topic: Environment Variables used in Enterprise Server Security


Resource Classes used by Enterprise Server

Each item (e.g. program, file, transaction) to which access is controlled is a called a resource. A resource has a name and a class, which indicates the type of the resource. For example, each enterprise server is a resource, and all enterprise servers belong to the same resource class.

A resource name must be unique within its class. That is, you can define two or more resources with the same name, provided that they belong to different classes.

MSS resources use various class names defined by IBM. Non-MSS resources, such as ES configuration definitions in MFDirectory Server, use resource class names defined by Micro Focus (using syntax that's not permitted for MSS resource class names, to avoid collisions). Users can also define their own resource classes for performing explicit access checks in applications.

When a user requests access to a resource the security facility relays the request to the external security manager, specifying the user, the resource and the resource class. The security manager will then look for resource rules that match the resource name. The processing of a request is dependent on the external security manager.

When Enterprise Server executes application programs in the various MSS processing regimes, it makes the appropriate security queries. This behaviour is intended to emulate, as far as is feasible, that found on IBM mainframe platforms. The entities and classes used are specified in the tables listed below.

  • Resource Classes for CICS Security
  • Resource Classes for JES Security
  • Resource Classes for IMS Security
  • Resource Classes for ESMAC and Operator Command Security
  • Resource Classes for MF Directory Server
  • Resource Classes for MQSeries
  • CICS Resource and Command Checks
Parent topic: Security Reference Information


Resource Classes for CICS Security

The table below defines the name of each default resource class used in Enterprise Server for CICS security, its meaning, the type of resource entities it contains, and the minimum permission that a user requires on the entities.

Note:

The CICS class names can be configured using environment variables (see Environment Variables for CICS Resource Classes). CICS will only use the first 7 characters of the value specified in the environment variable, it will then prefix the value with 1 character depending on the request.

CICS Class name | CICS corresponding | Entities | ACCESS LEVEL
ACICSPCT | CICS Program control table | Started Transactions | READ
CCICSCMD | Used by CICS/ESA 3.1, or later, to verify that a user is permitted to use CICS system programmer commands such as INQUIRE, SET, PERFORM, and COLLECT | CICS Command Functions | See resource and cross reference table
DATASET | Dataset Names or Physical Filename used by CICS at startup | Files | READ or UPDATE
DCICSDCT | CICS Transient data queues | Transient Data Destination | UPDATE
FCICSFCT | CICS File control table | Files | READ or UPDATE
JCICSJCT | CICS Journal control table | Journal Number | READ or UPDATE
MCICSPPT | CICS Processing program table (LINK/XCTL) | Programs | READ
PCICSPSB | CICS Program specification blocks (PSBs) | Program Status Block | N/A
SCICSTST | CICS temporary storage queues | Temporary Storage Queues | READ or UPDATE
TCICSTRN | CICS Transactions | Transactions | READ
SURROGAT | Class for CICS SURROGATE users (EXEC CICS START USERID). | Users | READ
Note:

In previous releases, security was not enforced for TS or TD queues that were not declared in the security repository. Now, by default, you must declare each TS or TD that your transactions will access. To revert to the previous behaviour, use the ES_OLD_SEC_TSTD environment variable.

Parent topic: Resource Classes used by Enterprise Server


Resource Classes for JES Security

The table below defines the name of each default resource class used in Enterprise Server for JES security, its meaning, the type of resource entities it contains, and the minimum permission that a user requires on the entities.

DATASET
JES relation | Entities | ACCESS LEVEL
Dataset Names | Files | None, Read, Update, Alter
JESINPUT
JES relation Entities ACCESS LEVEL
Conditional access support for commands or jobs entered into the system through a JES input device. INTRDR = Jobs submitted via Internal Reader as a result of executing JCL.

STCINRDR=Jobs submitted via Internal Reader as a result of the execution of a CICS or IMS transaction.

TSUINRDR = Jobs submitted via the ESMAC JES "Control" page and/or the cassub command line interface.

None, Read
JESJOBS
JES relation Entities ACCESS LEVEL
Controlling the submission and cancellation of jobs by job name.
CANCEL
nodename.userid.jobname (for job cancellation authority)
SUBMIT
nodename.jobname.userid (for job submissions)
where nodename is the name of the enterprise server.

These rules are not typically used, but they do provide granularity of control for those environments with special requirements.

NONE
Allows no access.
READ
Allows user to submit jobs
UPDATE
Equivalent to READ.
CONTROL
Equivalent to UPDATE.
ALTER
Allows jobs to be cancelled .
JESSPOOL
JES relation Entities ACCESS LEVEL
Controlling access to job data sets on the JES spool (Joblog, SYSOUT and Messages. localnodeid.userid.jobname.jobid.dsnumber.name

where

localnodeid
the name of the enterprise server
dsnumber
the relative dataset number for the job e.g. 001
name
the dd name

These rules are not typically used, but they do provide granularity of control for those environments with special requirements.

NONE
Allows no access.
READ
Allows user to view the spool data set, but not change its attributes. For example, this does not allow the following keywords on the OUTPUT command: NOKEEP, NOHOLD, DELETE, NEWCLASS, and DEST.
UPDATE
Allows to update a spool data set.
CONTROL
Equivalent to UPDATE.
ALTER
Allows any operand specified on the TSO OUTPUT command, including deleting and printing. Also, when specified for a discrete profile, allows the user to change the profile itself.
PHYSFILE
JES relation Entities ACCESS LEVEL
Controls access to the physical file when changes to the dataset are made.

See the usage notes at the end of this table.

Physical files None, Alter
SURROGAT
JES relation Entities ACCESS LEVEL
JES Class for controlling access to job submission by surrogates. If UserA wants to submit a job to run as UserB then he must have "Read" access to the SURROGAT class for entity UserB.SUBMIT execution-userid .SUBMIT

For example, if USERA is USERB's surrogate, Enterprise Server will check that USERA has read access for the entity, USERB.SUBMIT in the SURROGAT class.

None, Read

DATASET usage notes

Access rights to files within the dataset are enforced if you have a mainframe dialect Compiler directive set. To ensure that security is also applied if you are not using a mainframe dialect, set the FCDCAT and ASSIGN"EXTERNAL" compiler directives, then ensure files are not assigned dynamically or statically in a SELECT statement.

PHYSFILE usage notes

When a user with alter access to a DATASET class makes changes, before the changes are applied to the physical file, the PHYSFILE class is checked for access rights. Changes are made only if the user has access rights to PHYSFILE.

For example, in ESMAC, user access to PHYSFILE is verified when a user creates a new file, and when the physical file name is changed. Changes are allowed only when the user has access rights to PHYSFILE.

If the PHYSFILE class does not exist, access rights are not verified before the changes to the physical file are made.

Below is an example LDIF definition for PHYSFILE.

#########################
# RACF Class = PHYSFILE #
#########################
dn:CN=PHYSFILE,CN=Enterprise Server Resources,CN=MicroFocus,CN=RPIS,DC=mftesting,DC=com
changetype: add
objectClass: top
objectClass: container
description: JES Class for controlling access to physical files

#########################
# physical file MYFILE #
#########################
dn:CN=D\3A\\RPIS\\DATA\\MYFILE.DAT,CN=PHYSFILE,CN=Enterprise ServerResources,CN=Micro Focus,CN=RPIS,DC=mftesting,DC=com changetype: add
objectClass: microfocus-MFDS-Resource
microfocus-MFDS-Resource-Class:PHYSFILE
microfocus-MFDS-Resource-ACE: allow:ALLUSER group:update
microfocus-MFDS-Resource-ACE: deny:*:execute
microfocus-MFDS-UID: mfuid
Parent topic: Resource Classes used by Enterprise Server


Resource Classes for IMS Security

The table below defines the name of each default resource class used in Enterprise Server for IMS security, its meaning, the type of resource entities it contains, and the minimum permission that a user requires on the entities.

IMS Class name | IMS relation | Entities | ACCESS LEVEL
TIMS | IMS transactions security class | Transactions | Read
CIMS | IMS Commands security class | IMS Commands | Read
FIMS | IMS Field-level sensitivity class | IMS Segments Fields | Update
IIMS | IMS PSB security class | IMS PSB access | Update
LIMS | IMS LTERM security class | IMS Logical terminals | Read
PIMS | IMS Database security class | IMS DBD access | Update
SIMS | IMS Segment-level security class | IMS Segments access | Update
OIMS | IMS Other items security class | IMS User defined security | Update
Parent topic: Resource Classes used by Enterprise Server


Resource Classes for ESMAC and Operator Command Security

The list below defines the name of each default resource class used in Enterprise Server for ESMAC and operator command security, its meaning, the type of resource entities it contains, and the minimum permission that a user requires on the entities.
OPERCMDS
Relation
Class for operator commands used by casstart/casstop/casfile/cassub/casout... commands
Entities
ES Commands
Access Level
Alter
MFESMAC
Relation
MAC Class for controlling access to ESMAC Resources

An attempt has been made to match the Entities listed below with the individual flags that are available for each user as defined in the old CICS Resource definition. For each "flag" there are three states: None, Read, Update.

Entities
Entity | Description
TABLE | This is the equivalent of the "Master" flag within the CICS RDT file. If your user has "Update" access to this resource then they will have the ability to interact with the majority of ESMAC function. Primary items controlled by this setting are the appearance of the buttons for controlling the SEPS (Tracing, Stopping), Stopping the Server, Accessing the console.log, trace data, dump data, and the list of currently active ACEEs. If a user has "None" then they will not be shown any buttons other than the Server Status Button and the Monitoring button in addition to the Chg User button which allows them to sign-on. The basic effect of no access to this resource is that they are treated in the same way as an unauthenticated user. If they have "Read" access they will be shown the options but will be unable to perform any updates. If they have "Update" access or greater than they have full control of these functions.
GRP | This resource controls access to the buttons under the Resources drop down when the By Group selection is utilized. If the user has "Update" access to this resource then they will be able to access all the buttons that appear under the Resources pulldown when the By Group selection is made.
IMS | This controls access to the buttons under the Resources drop down when the IMS selection is utilized. See notes on GRP for details on the access rights.
JCL | This controls access to the buttons under the Resources drop down when the JES selection is utilized. See notes on GRP for details on the access rights.
DCT, DOC, FCT, ICE, JCT, MPR, PCT, PLT, PPT, SYS6, SYSC, TCP, TCT, TERM, TST, TTYPE, URI, XAT, XLT This controls the access a user has to the various resources (e.g. DCT, PCT, FCT) when selected via the By Type or Active menus under the Resources pulldown. "None" indicates that they can do nothing with this resource type, "Read" indicates that they can see the current settings, and "Update" indicates that they can modify the entries of this type.

For example, if a user has READ access to PCT*, he or she will have the ability to view any PCTs defined to the system, but will not be able to update the entries. If the user has "Update" access then he or she can change and even install new ones. (assuming appropriate CINS authority)

The resources listed above also control access to specific pages. If for instance a page is primarily the DCT details for a DCT entry then attempting to access this page with no authority will result in your being driven to a "Sign-on" screen.

Access Level
None, Read, Update
Parent topic: Resource Classes used by Enterprise Server


Resource Classes for MF Directory Server

This topic describes the resource classes and entities that are used to control access to the functionality of Enterprise Server Administration.

Note: The management of permissions for MFDS Internal Security differs from that for other Security Managers, and is covered separately by Legacy Directory Server Security Model.
  • Class - Enterprise Server Administration
  • Class - Servers
Parent topic: Resource Classes used by Enterprise Server


Class - Enterprise Server Administration

This class contains a set of predefined entities that correspond to the screens and functions used to manage the configuration of MF Directory Server and to access the user, group and resource property screens for security managers. The entities, the functions that they control, and the permissions that a user requires are as follows:
Entity | Controls | Permission required
Repository Access | Saving a copy of the repository to a file system directory. | Read
 | Importing data from a file system directory. | Add
 | Restoring a repository from a file system directory. The process of restoring overwrites all of the information in the current repository. | Add, Delete
 | Deletion of the entire Directory Server repository including all enterprise servers. | Add, Delete
Options | Changing of Directory Server options. | Update
Object Permissions | Allocation of permissions on individual enterprise servers. | Update
Directory Discovery | Viewing of a list of the Directory Servers that your Directory Server can detect on the network. | Execute
Execution Control | Shutting down of the Directory Server. | Execute
User Administration | Management of user accounts and user groups, and the setting of permissions. | Update, Add, Delete
Parent topic: Resource Classes for MF Directory Server


Class - Servers

The entities contained in this class correspond to, and control the configuration of, Enterprise Servers.

Entity | Controls | Permission required
Server Name | Viewing of enterprise server configuration information. | Read
 | Starting and stopping of enterprise servers. | Execute
 | Modification of configuration information for an enterprise server. | Update
 | Adding of listeners, services and packages to an enterprise server. When set as a default permission for the group, it also permits the adding of enterprise servers. | Add
 | Deletion of enterprise servers, and of listeners, services and packages from an enterprise server. | Delete
Parent topic: Resource Classes for MF Directory Server


Resource Classes for MQSeries

The table below defines the name and meaning of each default resource class used in Enterprise Server MQSeries security.

MQSeries Class Name | MQSeries relation
MQADMIN Used mainly for holding profiles for administration-type functions. For example:
  • Profiles for MQSeries security switches
  • Profiles for alternate user security
  • The context security profile
MQCONN | Profiles used for connection security.
MQQUEUE | Profiles used for queue security.
MQPROC | Profiles used in process resource security
  • MQSeries Switch Profiles
  • Switches and Classes
  • How Switches Work
  • Profiles to Control Subsystem Security
  • Profiles to Control Queue Manager Level Security
  • Valid Combinations of Switches
  • Resource Level Checks
  • Profiles for Connection Security
  • Connection Security Profiles for the Batch/TSO adapter
  • Connection Security Profiles for the CICS Adapter
  • Connection Security Profiles for the IMS Adapter
  • Profiles for Queue Security
  • Process Profiles
  • Profiles for Alternate User Security
  • Profiles for Context Security
Parent topic: Resource Classes used by Enterprise Server


MQSeries Switch Profiles

To control the security checking performed by MQSeries, you must define switch profiles. A switch profile is a normal security profile that has a special meaning to MQSeries. The access list in switch profiles is not used by MQSeries.

When you set a security switch on, the security checks associated with the switch are performed. When you set a security switch off, the security checks associated with the switch are bypassed. The default is that all security switches are set on.

Parent topic: Resource Classes for MQSeries


Switches and Classes

When an Enterprise Server region is started, the first access to MQSeries checks the status of Security and the MQADMIN class. The subsystem security switch is set to off if one of these conditions are discovered:

  • Security is inactive
  • The MQADMIN class is not defined
  • The MQADMIN class has not been activated

If both Security and the MQADMIN class are active, MQSeries checks the MQADMIN class to see whether any of the switch profiles have been defined. It first checks the profiles described in Profiles to control subsystem security. If subsystem security is not required, MQSeries sets the internal subsystem security switch off, and performs no further checks.

The profiles determine whether the corresponding MQSeries switch is set off and that the type of security is deactivated. If any MQSeries switch is set on, MQSeries checks the status of the Security class associated with the type of security corresponding to the MQSeries switch. If the class is not installed or not active, the MQSeries switch is set off. For example, process security checks are not carried out if the MQPROC class has not been activated. A non active class is equivalent to defining NO.PROCESS.CHECKS profile for every queue manager that uses the Security database.

Parent topic: Resource Classes for MQSeries


How Switches Work

To set a security switch off, you need to define a NO.* switch profile. The existence of a NO.* profile means that security checks are not performed for that type of resource.

Each NO.* switch profile that MQSeries detects turns off the checking for that type of resource. Switch profiles are activated during startup of the queue manager. If you change the switch profiles while any affected Enterprise Server Regions are running, you will need to restart the region for the new values to take effect.

The switch profiles must always be defined in the MQADMIN class.

Parent topic: Resource Classes for MQSeries


Profiles to Control Subsystem Security

The first security check made by MQSeries is used to determine whether security checks are required for the whole MQSeries subsystem. If you specify that you do not want subsystem security, no further checks are made.

The following table shows the switch profiles that are checked to determine whether subsystem security is required.

Switch profile name | Type of resource or checking that is controlled
qmgr-name.NO.SUBSYS.SECURITY | Subsystem security for this queue manager. If not found, then security is on.
qmgr-name.YES.SUBSYS.SECURITY | Subsystem security for this queue manager (Default).
Parent topic: Resource Classes for MQSeries


Profiles to Control Queue Manager Level Security

When MQSeries has established that security checking is required, it then determines whether checking is required at queue manager level.

The following table shows the switch profiles are checked to determine the level required.

Switch profile name | Type of resource or checking that is controlled
qmgr-name.NO.QMGR.CHECKS | No queue manager level checks for this queue manager.
qmgr-name.YES.QMGR.CHECKS | Queue manager level checks override for this queue manager.
Parent topic: Resource Classes for MQSeries


Valid Combinations of Switches

The following table shows the combinations of switch settings that are valid.

Security level | Switch settings
Queue manager level security | qmgr-name.NO.QMGR.CHECKS
 | qmgr-name.YES.QMGR.CHECKS
Parent topic: Resource Classes for MQSeries


Resource Level Checks

The following table shows the switch profiles used to control access to MQSeries resources.

Type of resource checking that is controlled | Switch profile name
Alternate user security | qmgr-name.YES.ALTERNATE.USER.CHECKS
Connection security | qmgr-name.YES.CONNECT.CHECKS
Context security | qmgr-name.YES.CONTEXT.CHECKS
Process security | qmgr-name.YES.PROCESS.CHECKS
Queue security | qmgr-name.YES.QUEUE.CHECKS

For example, if you wanted to perform process security checks on queue manager QM_nwb_magd820, you would define the following switch profile:

QM_nwb_magd820.YES.PROCESS.CHECKS

If you wanted to perform queue security checks on QM_nwb_magd820, you would define the following switch profile:

QM_nwb_magd820.YES.QUEUE.CHECKS
Note:

Generic switch profiles such as qmgr-name.YES.** are ignored by Enterprise Server

Note:

If the switch is not found, security checks will be performed by default, and messages will appear on the console.log as:

CASKC0033I MQSeries !QM_nwb_magd820 SUBSYSTEM security switch set ON, profile 'QM_NWB_MAGD820.NO.SUBSYS.SECURITY' not found
CASKC0034I MQSeries !QM_nwb_magd820 CONNECTION security switch set ON, profile 'QM_NWB_MAGD820.NO.CONNECT.CHECKS' not found
CASKC0034I MQSeries !QM_nwb_magd820 PROCESS security switch set ON, profile 'QM_NWB_MAGD820.NO.PROCESS.CHECKS' not found
CASKC0034I MQSeries !QM_nwb_magd820 CONTEXT security switch set ON, profile 'QM_NWB_MAGD820.NO.CONTEXT.CHECKS' not found
CASKC0034I MQSeries !QM_nwb_magd820 QUEUE security switch set ON, profile 'QM_NWB_MAGD820.NO.QUEUE.CHECKS' not found
CASKC0034I MQSeries !QM_nwb_magd820 ALTERNATE security switch set ON, profile 'QM_NWB_MAGD820NO.ALTERNATE.USER.CHECKS' not found
Parent topic: Resource Classes for MQSeries


Profiles for Connection Security

If connection security is active, you must define profiles in the MQCONN class and permit the necessary groups or user IDs access to those profiles, so that they can connect to MQSeries subsystems.

To enable a connection to be made, you must grant users READ access to the appropriate profile.

A connection profile qualified with a queue manager name controls access to a specific queue manager and users given access to this profile can connect to that queue manager.

For example, a user with access to QM_nwb_magd820.BATCH can Batch connect to queue manager QM_nwb_magd820.

Parent topic: Resource Classes for MQSeries


Connection Security Profiles for the Batch/TSO adapter

Profiles for checking connections from Batch or TSO take the form:

qmgr-name.BATCH

where qmgr-name is the queue manager name. If it fails to find the profile, the connection request fails.

For connection requests through Batch or TSO, you must permit the job or TSO user ID to access the connection profile. For example, the following security definition allows Batch and TSO users in the ALLUSER group to connect to the queue manager QM_nwb_magd820:

#####################################
# MQCONN QM_nwb_magd820.BATCH auths #
#####################################
dn: CN=QM_nwb_magd820.BATCH,CN=MQCONN,CN=Enterprise Server Resources,CN=Micro Focus,DC=local
changetype: delete

dn: CN=QM_nwb_magd820.BATCH,CN=MQCONN,CN=Enterprise Server Resources,CN=Micro Focus,DC=local
changetype: add
objectClass: microfocus-MFDS-Resource
microfocus-MFDS-Resource-Class: MQCONN
microfocus-MFDS-Resource-ACE: allow:ALLUSER group:read
microfocus-MFDS-Resource-ACE: deny:*:execute
microfocus-MFDS-UID: mfuid
description: Enable security on MQCONN subsystem BATCH for QMGR QM_nwb_magd820
Parent topic: Resource Classes for MQSeries


Connection Security Profiles for the CICS Adapter

Profiles for checking connections from CICS take the form:

qmgr-name.CICS

where qmgr-name is the queue manager name. If it fails to find the profile, the connection request fails.

For connection requests by CICS, you need only permit the CICS address space user ID access to the connection profile.

For example, the following Security definitions allow the CICS address space user ID SYSAD to connect to the queue manager QM_nwb_magd820

#####################################
# MQCONN QM_nwb_magd820.CICS auths  #
#####################################
dn: CN=QM_nwb_magd820.CICS,CN=MQCONN,CN=Enterprise Server Resources,CN=Micro Focus,DC=local
changetype: delete

dn: CN=QM_nwb_magd820.CICS,CN=MQCONN,CN=Enterprise Server Resources,CN=Micro Focus,DC=local
changetype: add
objectClass: microfocus-MFDS-Resource
microfocus-MFDS-Resource-Class: MQCONN
microfocus-MFDS-Resource-ACE: allow:SYSAD:read
microfocus-MFDS-Resource-ACE: deny:*:execute
microfocus-MFDS-UID: mfuid
description: Enable security on MQCONN subsystem CICS for QMGR QM_nwb_magd820
Parent topic: Resource Classes for MQSeries


Connection Security Profiles for the IMS Adapter

Profiles for checking connections from IMS take the form:

qmgr-name.IMS

where qmgr-name is the queue manager name. If it fails to find the profile, the connection request fails.

Parent topic: Resource Classes for MQSeries


Profiles for Queue Security

If queue security is active, you must define profiles in the MQQUEUE class and permit the necessary groups or user IDs access to these profiles, so they can issue MQSeries API requests that use queues.

Profiles for queue security take the form:

qmgr-name.queuename

where qmgr-name (queue manager name) and queuename is the name of the queue being opened, as specified in the object descriptor on the MQOPEN or MQPUT1 call.

A profile prefixed by the queue manager name controls access to a single queue on that queue manager.

The RACF access required to open a queue depends on the MQOPEN or MQPUT1 options specified. If more than one of the MQOO_* and MQPMO_* options are coded, the queue security check is performed for the highest RACF authority required.

TMQOPEN or MQPUT1 option | RACF access level required to access qmgr-name.queuename
MQOO_BIND_* | UPDATE
MQOO_BROWSE | READ
MQOO_INPUT_* | UPDATE
MQOO_INQUIRE | READ
MQOO_OUTPUT or MQPUT1 | UPDATE
MQOO_PASS_ALL_CONTEXT | UPDATE
MQOO_PASS_IDENTITY_CONTEXT | UPDATE
MQOO_SAVE_ALL_CONTEXT | UPDATE
MQOO_SET | ALTER
MQOO_SET_ALL_CONTEXT | UPDATE
MQOO_SET_IDENTITY_CONTEXT | UPDATE
MQPMO_PASS_ALL_CONTEXT | UPDATE
MQPMO_PASS_IDENTITY_CONTEXT | UPDATE
MQPMO_SET_ALL_CONTEXT | UPDATE
MQPMO_SET_IDENTITY_CONTEXT | UPDATE
Parent topic: Resource Classes for MQSeries


Process Profiles

If process security is active, you must define profiles in the MQPROC class, and permit access to the necessary groups or user IDs so they can use MQI requests that use processes. Profiles for processes take the form:

qmgr-name.processname

where qmgr-name (queue manager name) and processname is the name of the process being opened.

A profile prefixed by the queue manager name controls access to a single process definition on that queue manager.

The following table shows the access required for opening a process.

MQOPEN option | RACF access level required to qmgr-name.processname
MQOO_INQUIRE | READ
Parent topic: Resource Classes for MQSeries


Profiles for Alternate User Security

If alternate user security is active, you must define profiles in the MQADMIN class and permit the necessary groups or user IDs access to these profiles, so that they can use the ALTERNATE_USER_AUTHORITY options when the object is opened.

Profiles for alternate user security can be specified at subsystem level and take the following form:

qmgr-name.ALTERNATE.USER.alternateuserid

where qmgr-name (queue manager name) and alternateuserid is the value of the AlternateUserId field in the object descriptor.

A profile prefixed by the queue manager name controls use of an alternate user ID on that queue manager.

The following table shows the access when specifying an alternate user option.

MQOPEN or MQPUT1 option | RACF access level required
MQOO_ALTERNATE_USER_AUTHORITY MQPMO_ALTERNATE_USER_AUTHORITY | UPDATE

In addition to alternate user security checks, other security checks for queue, process, and context security can also be made. The alternate user ID, if provided, is only used for security checks on queue and process definition. For alternate user and context security checks, the user ID requesting the check is used.

Parent topic: Resource Classes for MQSeries


Profiles for Context Security

If context security is active, you must define a profile in the MQADMIN class called:

qmgr-name.CONTEXT

where qmgr-name (queue manager name).

A profile prefixed by the queue manager name allows control for context security on that queue manager.

You must give the necessary groups or user IDs access to this profile. The following table shows the access level required, depending on the specification of the context options, when the queue is opened.

MQOPEN or MQPUT1 option | RACF access level required to qmgr-name.CONTEXT
MQOO_OUTPUT or MQPUT1 (USAGE(XMITQ)) | CONTROL
MQOO_PASS_ALL_CONTEXT | READ
MQOO_PASS_IDENTITY_CONTEXT | READ
MQOO_SAVE_ALL_CONTEXT | No context security check
MQOO_SET_ALL_CONTEXT | CONTROL
MQOO_SET_IDENTITY_CONTEXT | UPDATE
MQPMO_DEFAULT_CONTEXT | No context security check
MQPMO_NO_CONTEXT | No context security check
MQPMO_PASS_ALL_CONTEXT | READ
MQPMO_PASS_IDENTITY_CONTEXT | READ
MQPMO_SET_ALL_CONTEXT | CONTROL
MQPMO_SET_IDENTITY_CONTEXT | UPDATE
Parent topic: Resource Classes for MQSeries


CICS Resource and Command Checks

Note: Not all of the commands listed here are currently supported by Enterprise Server.
EXEC CICS COMMAND | Details of resource checking |  |  |  | Command security checking (default class CCICSCMD - governed by environment variable ES_CLASS_XCMD)
 | Default resource class name | Environment variable governing resource class | Resource | Type of access required | Resource | Type of access required
ACQUIRE |  |  |  |  | TERMINAL | UPDATE
ACQUIRE for BTS | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
CANCEL | ACICSPCT | ES_CLASS_XPCT | transid | READ |  |
CANCEL for BTS | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
COLLECT STATISTICS |  |  |  |  | STATISTICS | READ
COLLECT STATISTICS FILE | FCICSFCT | ES_CLASS_XFCT | file | READ | STATISTICS | READ
COLLECT STATISTICS JOURNALNAME | JCICSJCT | ES_CLASS_XJCT | journal | READ | STATISTICS | READ
COLLECT STATISTICS JOURNALNUM | JCICSJCT | ES_CLASS_XJCT | journal | READ | STATISTICS | READ
COLLECT STATISTICS PROGRAM | MCICSPPT | ES_CLASS_XPPT | program | READ | STATISTICS | READ
COLLECT STATISTICS TDQUEUE | ACICSPCT | ES_CLASS_XPCT | tdqueue | READ | STATISTICS | READ
COLLECT TRANSACTION | DCICSDCT | ES_CLASS_XDCT | transid | READ | STATISTICS | READ
CREATE CONNECTION |  |  |  |  | CONNECTION | ALTER
CREATE CORBASERVER |  |  |  |  | CORBASERVER | ALTER
CREATE DJAR |  |  |  |  | DJAR | ALTER
CREATE DOCTEMPLATE | RCICSRES | ES_CLASS_XRES |  | ALTER | DOCTEMPLATE | ALTER
CREATE ENQMODEL |  |  |  |  | ENQMODEL | ALTER
CREATE FILE | FCICSFCT | ES_CLASS_XFCT | file | ALTER | FILE | ALTER
CREATE JOURNALMODEL |  |  |  |  | JOURNALMODEL | ALTER
CREATE LSRPOOL |  |  |  |  | LSRPOOL | ALTER
CREATE MAPSET | MCICSPPT | ES_CLASS_XPPT | mapset | ALTER | MAPSET | ALTER
CREATE PARTITIONSET | MCICSPPT | ES_CLASS_XPPT | partitionset | ALTER | PARTITIONSET | ALTER
CREATE PIPELINE |  |  |  |  | PIPELINE | ALTER
CREATE PARTNER |  |  |  |  | PARTNER | ALTER
CREATE PROCESSTYPE |  |  |  |  | PROCESSTYPE | ALTER
CREATE PROFILE |  |  |  |  | PROFILE | ALTER
CREATE PROGRAM | MCICSPPT | ES_CLASS_XPPT | program | ALTER | PROGRAM | ALTER
CREATE REQUESTMODEL |  |  |  |  | REQUESTMODEL | ALTER
CREATE SESSIONS |  |  |  |  | SESSIONS | ALTER
CREATE TCPIPSERVICE |  |  |  |  | TCPIPSERVICE | ALTER
CREATE TDQUEUE | DCICSDCT | ES_CLASS_XDCT | tdqueue | ALTER | TDQUEUE | ALTER
CREATE TERMINAL |  |  |  |  | TERMINAL | ALTER
CREATE TRANCLASS |  |  |  |  | TCLASS | ALTER
CREATE TRANSACTION | ACICSPCT | ES_CLASS_XPCT | transid | ALTER | TRANSACTION | ALTER
CREATE TSMODEL |  |  |  |  | TSMODEL | ALTER
CREATE TYPETERM |  |  |  |  | TYPETERM | ALTER
CREATE URIMAP |  |  |  |  | URIMAP | ALTER
CREATE WEBSERVICE |  |  |  |  | WEBSERVICE | ALTER
DEFINE ACTIVITY | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
DEFINE PROCESS | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
DELETE | FCICSFCT | ES_CLASS_XFCT | file | UPDATE |  |
DELETE ACTIVITY | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
DELETEQ TD | DCICSDCT | ES_CLASS_XDCT | tdqueue | UPDATE |  |
DELETEQ TS | SCICSTST | ES_CLASS_XTST | tsqueue | UPDATE |  |
DISABLE PROGRAM | MCICSPPT | ES_CLASS_XPPT | program | UPDATE | EXITPROGRAM | UPDATE
DISCARD AUTINSTMODEL |  |  |  |  | AUTINSTMODEL | ALTER
DISCARD CORBASERVER |  |  |  |  | CORBASERVER | ALTER
DISCARD DJAR |  |  |  |  | DJAR | ALTER
DISCARD DOCTEMPLATE | RCICSRES | ES_CLASS_XRES |  | ALTER | DOCTEMPLATE | ALTER
DISCARD ENQMODEL |  |  |  |  | ENQMODEL | ALTER
DISCARD FILE | FCICSFCT | ES_CLASS_XFCT | file | ALTER | FILE | ALTER
DISCARD JOURNALMODEL |  |  |  |  | JOURNALMODEL | ALTER
DISCARD JOURNALNAME | JCICSJCT | ES_CLASS_XJCT | journal | ALTER | JOURNALNAME | ALTER
DISCARD PARTNER |  |  |  |  | PARTNER | ALTER
DISCARD PIPELINE |  |  |  |  | PIPELINE | ALTER
DISCARD PROCESSTYPE |  |  |  |  | PROCESSTYPE | ALTER
DISCARD PROFILE |  |  |  |  | PROFILE | ALTER
DISCARD PROGRAM | MCICSPPT | ES_CLASS_XPPT | program | ALTER | PROGRAM | ALTER
DISCARD REQUESTMODEL |  |  |  |  | REQUESTMODEL | ALTER
DISCARD TCPIPSERVICE |  |  |  |  | TCPIPSERVICE | ALTER
DISCARD TDQUEUE | DCICSDCT | ES_CLASS_XDCT | tdqueue | ALTER | TDQUEUE | ALTER
DISCARD TERMINAL |  |  |  |  | TERMINAL | ALTER
DISCARD TRANCLASS |  |  |  |  | TCLASS | ALTER
DISCARD TRANSACTION | ACICSPCT | ES_CLASS_XPCT | transid | ALTER | TRANSACTION | ALTER
DISCARD TSMODEL |  |  |  |  | TSMODEL | ALTER
DISCARD URIMAP |  |  |  |  | URIMAP | ALTER
DISCARD WEBSERVICE |  |  |  |  | WEBSERVICE | ALTER
DOCUMENT |  |  |  |  | DOCUMENT |
ENABLE PROGRAM | MCICSPPT | ES_CLASS_XPPT | program | UPDATE | EXITPROGRAM | UPDATE
EXTRACT EXIT | MCICSPPT | ES_CLASS_XPPT | program | READ | EXITPROGRAM | UPDATE
EXTRACT STATISTICS |  |  |  |  | STATISTICS | READ
FEPI |  |  |  |  | FEPI |
HANDLE ABEND PROGRAM | MCICSPPT | ES_CLASS_XPPT | program | READ |  |
INQUIRE ACTIVITYID | FCICSFCT | ES_CLASS_XFCT | BTS repository file | READ |  |
INQUIRE AUTINSTMODEL |  |  |  |  | AUTINSTMODEL | READ
INQUIRE AUTOINSTALL |  |  |  |  | AUTOINSTALL | READ
INQUIRE BEAN |  |  |  |  | BEAN | READ
INQUIRE BRFACILITY |  |  |  |  | BRFACILITY | READ
INQUIRE CFDTPOOL |  |  |  |  | CFDTPOOL | READ
INQUIRE CLASSCACHE |  |  |  |  | CLASSCACHE | READ
INQUIRE CONNECTION |  |  |  |  | CONNECTION | READ
INQUIRE CORBASERVER |  |  |  |  | CORBASERVER | READ
INQUIRE CONTAINER | FCICSFCT | ES_CLASS_XFCT | BTS repository file | READ |  |
INQUIRE DELETSHIPPED |  |  |  |  | DELETSHIPPED | READ
INQUIRE DJAR |  |  |  |  | DJAR | READ
INQUIRE DOCTEMPLATE | RCICSRES | ES_CLASS_XRES |  | READ | DOCTEMPLATE | READ
INQUIRE DSNAME |  |  |  |  | DSNAME | READ
INQUIRE DUMPDS |  |  |  |  | DUMPDS | READ
INQUIRE ENQMODEL |  |  |  |  | ENQMODEL | READ
INQUIRE EXCI |  |  |  |  | EXCI | READ
INQUIRE EVENT | FCICSFCT | ES_CLASS_XFCT | BTS repository file | READ |  |
INQUIRE EXITPROGRAM | MCICSPPT | ES_CLASS_XPPT | program | READ | EXITPROGRAM | READ
INQUIRE FILE | FCICSFCT | ES_CLASS_XFCT | file | READ | FILE | READ
INQUIRE HOST |  |  |  |  | HOST | READ
INQUIRE IRC |  |  |  |  | IRC | READ
INQUIRE JOURNALMODEL |  |  |  |  | JOURNALMODEL | READ
INQUIRE JOURNALNAME | JCICSJCT | ES_CLASS_XJCT | journal | READ | JOURNAL | READ
INQUIRE JVM |  |  |  |  | JVM | READ
INQUIRE JVMPOOL |  |  |  |  | JVMPOOL | READ
INQUIRE JVMPROFILE |  |  |  |  | JVMPROFILE | READ
INQUIRE MODENAME |  |  |  |  | MODENAME | READ
INQUIRE MONITOR |  |  |  |  | MONITOR | READ
INQUIRE MVSTCB |  |  |  |  | MVSTCB | READ
INQUIRE NETNAME |  |  |  |  | TERMINAL | READ
INQUIRE PARTNER |  |  |  |  | PARTNER | READ
INQUIRE PIPELINE |  |  |  |  | PIPELINE | READ
INQUIRE PROCESS | FCICSFCT | ES_CLASS_XFCT | BTS repository file | READ |  |
INQUIRE PROCESSTYPE |  |  |  |  | PROCESSTYPE | READ
INQUIRE PROFILE |  |  |  |  | PROFILE | READ
INQUIRE PROGRAM | MCICSPPT | ES_CLASS_XPPT | program | READ | PROGRAM | READ
INQUIRE REQID | ACICSPCT | ES_CLASS_XPCT | transid | READ | REQID | READ
INQUIRE REQUESTMODEL |  |  |  |  | REQUESTMODEL | READ
INQUIRE RRMS |  |  |  |  | RRMS | READ
INQUIRE STATISTICS |  |  |  |  | STATISTICS | READ
INQUIRE STORAGE |  |  |  |  | STORAGE | READ
INQUIRE STREAMNAME |  |  |  |  | STREAMNAME | READ
INQUIRE SUBPOOL |  |  |  |  | SUBPOOL | READ
INQUIRE SYSDUMPCODE |  |  |  |  | SYSDUMPCODE | READ
INQUIRE SYSTEM |  |  |  |  | SYSTEM | READ
INQUIRE TASK |  |  |  |  | TASK | READ
INQUIRE TCLASS |  |  |  |  | TCLASS | READ
INQUIRE TCPIP |  |  |  |  | TCPIP | READ
INQUIRE TCPIPSERVICE |  |  |  |  | TCPIPSERVICE | READ
INQUIRE TDQUEUE | DCICSDCT | ES_CLASS_XDCT | tdqueue | READ | TDQUEUE | READ
INQUIRE TERMINAL |  |  |  |  | TERMINAL | READ
INQUIRE TIMER | FCICSFCT | ES_CLASS_XFCT | BTS repository file | READ |  |
INQUIRE TRACEDEST |  |  |  |  | TRACEDEST | READ
INQUIRE TRACEFLAG |  |  |  |  | TRACEFLAG | READ
INQUIRE TRACETYPE |  |  |  |  | TRACETYPE | READ
INQUIRE TRANCLASS |  |  |  |  | TCLASS | READ
INQUIRE TRANDUMPCODE |  |  |  |  | TRANDUMPCODE | READ
INQUIRE TRANSACTION | ACICSPCT | ES_CLASS_XPCT | program | READ | TRANSACTION | READ
INQUIRE TSMODEL |  |  |  |  | TSMODEL | READ
INQUIRE TSPOOL |  |  |  |  | TSPOOL | READ
INQUIRE TSQUEUE | SCICSTST | ES_CLASS_XTST | tsqueue | READ | TSQUEUE | READ
INQUIRE TSQNAME | SCICSTST | ES_CLASS_XTST | tsqname | READ | TSQUEUE | READ
INQUIRE UOW |  |  |  |  | UOW | READ
INQUIRE UOWDSNFAIL |  |  |  |  | UOWDSNFAIL | READ
INQUIRE UOWENQ |  |  |  |  | UOWENQ | READ
INQUIRE UOWLINK |  |  |  |  | UOWLINK | READ
INQUIRE URIMAP |  |  |  |  | URIMAP | READ
INQUIRE VTAM |  |  |  |  | VTAM | READ
INQUIRE WEB |  |  |  |  | WEB | READ
INQUIRE WEBSERVICE |  |  |  |  | WEBSERVICE | READ
INQUIRE WORKREQUEST |  |  |  |  | WORKREQUEST | READ
LINK | MCICSPPT | ES_CLASS_XPPT | program | READ |  |
LINK ACQPROCESS | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
LINK ACTIVITY / ACQACTIVITY | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
LOAD | MCICSPPT | ES_CLASS_XPPT | program | READ |  |
PERFORM CLASSCACHE |  |  |  |  | CLASSCACHE | UPDATE
PERFORM CORBASERVER |  |  |  |  | CORBASERVER | UPDATE
PERFORM DELETSHIPPED |  |  |  |  | DELETSHIPPED | UPDATE
PERFORM DJAR |  |  |  |  | DJAR | UPDATE
PERFORM DUMP |  |  |  |  | DUMP | UPDATE
PERFORM PIPELINE |  |  |  |  | PIPELINE | UPDATE
PERFORM RESETTIME |  |  |  |  | RESETTIME | UPDATE
PERFORM SECURITY |  |  |  |  | SECURITY | UPDATE
PERFORM SHUTDOWN |  |  |  |  | SHUTDOWN | UPDATE
PERFORM STATISTICS |  |  |  |  | STATISTICS | UPDATE
READ | FCICSFCT | ES_CLASS_XFCT | file | READ |  |
READQ TD | DCICSDCT | ES_CLASS_XDCT | tdqueue | UPDATE |  |
READQ TS | SCICSTST | ES_CLASS_XTST | tsqueue | READ |  |
RELEASE | MCICSPPT | ES_CLASS_XPPT | program | READ |  |
RESET ACTIVITY | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
RESET ACQPROCESS | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
RESYNC ENTRYNAME |  |  |  |  | EXITPROGRAM | UPDATE
RETURN / RETURN ENDACTIVITY | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
REWRITE | FCICSFCT | ES_CLASS_XFCT | file | UPDATE |  |
RUN | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
RUN / ASYNCH SYNC | FCICSFCT | ES_CLASS_XFCT | DFHLRQ file | UPDATE |  |
SET AUTOINSTALL |  |  |  |  | AUTOINSTALL | UPDATE
SET BRFACILITY |  |  |  |  | BRFACILITY | UPDATE
SET CLASSCACHE |  |  |  |  | CLASSCACHE | UPDATE
SET CONNECTION |  |  |  |  | CONNECTION | UPDATE
SET CORBASERVER |  |  |  |  | CORBASERVER | UPDATE
SET DELETSHIPPED |  |  |  |  | DELETSHIPPED | UPDATE
SET DOCTEMPLATE | RCICSRES | ES_CLASS_XRES |  | UPDATE | DOCTEMPLATE | UPDATE
SET DSNAME |  |  |  |  | DSNAME | UPDATE
SET DUMPDS |  |  |  |  | DUMPDS | UPDATE
SET ENQMODEL |  |  |  |  | ENQMODEL | UPDATE
SET FILE | FCICSFCT | ES_CLASS_XFCT | file | UPDATE | FILE | UPDATE
SET HOST |  |  |  |  | HOST | UPDATE
SET IRC |  |  |  |  | IRC | UPDATE
SET JOURNALNAME | JCICSJCT | ES_CLASS_XJCT | journal | UPDATE | JOURNAL | UPDATE
SET JVMPOOL |  |  |  |  | JVMPOOL | UPDATE
SET MODENAME |  |  |  |  | MODENAME | UPDATE
SET MONITOR |  |  |  |  | MONITOR | UPDATE
SET NETNAME |  |  |  |  | TERMINAL | UPDATE
SET PIPELINE |  |  |  |  | PIPELINE | UPDATE
SET PROGRAM | MCICSPPT | ES_CLASS_XPPT | program | UPDATE | PROGRAM | UPDATE
SET REQUESTMODEL |  |  |  |  | REQUESTMODEL | UPDATE
SET STATISTICS |  |  |  |  | STATISTICS | UPDATE
SET SYSDUMPCODE |  |  |  |  | SYSDUMPCODE | UPDATE
SET SYSTEM |  |  |  |  | SYSTEM | UPDATE
SET TASK |  |  |  |  | TASK | UPDATE
SET TCLASS |  |  |  |  | TCLASS | UPDATE
SET TCPIP |  |  |  |  | TCPIP | UPDATE
SET TCPIPSERVICE |  |  |  |  | TCPIPSERVICE | UPDATE
SET TDQUEUE | DCICSDCT | ES_CLASS_XDCT | tdqueue | UPDATE | TDQUEUE | UPDATE
SET TERMINAL |  |  |  |  | TERMINAL | UPDATE
SET TRACEDEST |  |  |  |  | TRACEDEST | UPDATE
SET TRACEFLAG |  |  |  |  | TRACEFLAG | UPDATE
SET TRACETYPE |  |  |  |  | TRACETYPE | UPDATE
SET TRANCLASS |  |  |  |  | TCLASS | UPDATE
SET TRANDUMPCODE |  |  |  |  | TRANDUMPCODE | UPDATE
SET TRANSACTION | ACICSPCT | ES_CLASS_XPCT | transid | UPDATE | TRANSACTION | UPDATE
SET TSMODEL |  |  |  |  | TSMODEL | UPDATE
SET TSQNAME | SCICSTST | ES_CLASS_XTST | tsqueue | UPDATE | TSQUEUE | UPDATE
SET TSQUEUE | SCICSTST | ES_CLASS_XTST | tsqname | UPDATE | TSQUEUE | UPDATE
SET UOW |  |  |  |  | UOW | UPDATE
SET UOWLINK |  |  |  |  | UOWLINK | UPDATE
SET URIMAP |  |  |  |  | URIMAP | UPDATE
SET VTAM |  |  |  |  | VTAM | UPDATE
SET WEB |  |  |  |  | WEB | UPDATE
SET WEBSERVICE |  |  |  |  | WEBSERVICE | UPDATE
SET WORKREQUEST |  |  |  |  | WORKREQUEST | UPDATE
START | ACICSPCT | ES_CLASS_XPCT | transid | READ |  |
STARTBR | FCICSFCT | ES_CLASS_XFCT | file | READ |  |
STARTBROWSE ACTIVITY | FCICSFCT | ES_CLASS_XFCT | BTS repository file | READ |  |
STARTBROWSE CONTAINER (BTS) | FCICSFCT | ES_CLASS_XFCT | BTS repository file | READ |  |
STARTBROWSE EVENT | FCICSFCT | ES_CLASS_XFCT | BTS repository file | READ |  |
STARTBROWSE PROCESS | FCICSFCT | ES_CLASS_XFCT | BTS repository file | READ |  |
SUSPEND | FCICSFCT | ES_CLASS_XFCT | BTS repository file | UPDATE |  |
WAIT JOURNALNAME | JCICSJCT | ES_CLASS_XJCT | journal | READ |  |
WAIT JOURNALNUM | JCICSJCT | ES_CLASS_XJCT | journal | READ |  |
WRITE | FCICSFCT | ES_CLASS_XFCT | file | UPDATE |  |
WRITE JOURNALNAME | JCICSJCT | ES_CLASS_XJCT | journal | UPDATE |  |
WRITE JOURNALNUM | JCICSJCT | ES_CLASS_XJCT | DFHJnn | UPDATE |  |
WRITEQ TD | DCICSDCT | ES_CLASS_XDCT | tdqueue | UPDATE |  |
WRITEQ TS | SCICSTST | ES_CLASS_XTST | tsqueue or tsqname | UPDATE |  |
XCTL | MCICSPPT | ES_CLASS_XPPT | program | READ |  |
Parent topic: Resource Classes used by Enterprise Server


Solutions, Restrictions, and Changes in Behavior

  • Service Deployment and Security
  • Restrictions on usernames and passwords
  • Restricting JCL submission
  • Configuring Credentials for Starting and Stopping Enterprise Servers
  • Timeouts for Terminal Users
  • Sign-on Disabled for Default Users
  • Configuring Sun Java System Directory as a Security Manager
Parent topic: Security Reference Information


Service Deployment and Security

Enterprise Server provides a deployment feature to let developers package COBOL programs as Web Services or EJBs and deploy them to an Enterprise Server instance. The deployment process uploads the packaged service (in the form of a COBOL Archive or "CAR" file) to ES, then invokes an installer (mfdepinst) that extracts the contents from the archive, creates package and service objects in the Micro Focus Directory Server repository, and notifies ES of the new service.

Service deployment is initiated by a deployment client, running under the control of a developer or administrator. Deployment clients include the those generated by the Interface Mapping Toolkit (IMTK), or the imtkmake command-line tool. All of these are documented elsewhere

Deployment and Security

Creating service and package objects in the MFDS repository requires update access, which may not be granted to all users. mfdepinst has to present credentials (a username and a password) to MFDS when it tries to create those objects. In a secured installation, deployment requests from users may fail to create service and package objects because of insufficient permissions.

The default configuration installed with Enterprise Server lets mfdepinst create objects in the MFDS repository, but when security options are changed it's easy to cause deployment requests to fail. (This is actually the appropriate behavior; when an installation is secured, it should prevent unauthorized access.) This is particularly true when external security is enabled.

How Deployment Credentials are Verified and Authorized

In early releases of Enterprise Server, the credentials sent to MFDS by mfdepinst were verified against entries in the file cciusers.dat. In more recent releases, MFDS keeps its own database of user information as part of the repository.

External security, which is enabled by specifying an external security manager (ESM) for MFDS security, lets MFDS use an outside facility, such as an LDAP server, to verify user credentials.

How MFDS is configured determines how the username and password sent by mfdepinst will be verified, and what determines their level of access. If you are using internal security, you'll have to ensure that the username and password sent by mfdepinst are configured in MFDS, and that the user account used by mfdepinst has "add" access for the MFDS repository. Similarly, if you're using external security, your ESM will have to accept the username and password sent by mfdepinst and grant it access to add objects to MFDS.

The ES Administration Guide discusses these topics in more detail.

How Deployment Credentials are Set

WithNet Express version 5.0, Websync 2 or later you can specify a username and password when deploying a service interface to a secure server either through the Net Express IDE or when using imtkmake from the command line.

Parent topic: Solutions, Restrictions, and Changes in Behavior


Restrictions on usernames and passwords

Usernames longer than eight characters cannot be used for MSS. This includes using them to start an enterprise server. As a consequence, if an MF Directory Server administrator signs on with a username that is longer than eight characters, he or she will have to supply a different username when starting an enterprise server from the Enterprise Server Administration screens.

This restriction also applies to JES and JCL support. Any name referenced in JCL must be uppercase (e.g. USER=XXX), as you cannot use a lower-case or mixed-case username in JCL. You can however have a user with a lower- or mixed-case name to submit jobs.

Important: For reasons of mainframe compatibility and technical limitations, many components of Enterprise Server are limited to a maximum of eight ASCII characters for user IDs and passwords. To avoid issues with user sign-on and similar functions, avoid attempting to create user IDs or passwords that do not meet this requirement.
Parent topic: Solutions, Restrictions, and Changes in Behavior


Restricting JCL submission

In order to disable the JCL Submit button in ESMAC for a group of users, but still allow them to submit JCL using the cassub command line utility, the LDAP security repository requires a read access rule for the "CN=cassub,CN=OPERCMDS,CN=Enterprise Server Resources" resource class authorization.

dn: CN=cassub,CN=OPERCMDS,CN=Enterprise Server Resources
microfocus-MFDS-Resource-ACE: allow:<group-name> group:read

<group-name> must be followed by a space and the word “group” for group access authority.

Parent topic: Solutions, Restrictions, and Changes in Behavior


Configuring Credentials for Starting and Stopping Enterprise Servers

When you start or stop an enterprise server from MF Directory Server, you are given the option of supplying two sets of credentials. The first is the operating system credentials under which the processes are to run (this is labelled Start/Stop processes as). The second, labelled Use Enterprise Server credentials of: is checked by the security features of MF Directory Server and Enterprise Server. The requirements of this second set of credentials are described below.

When an enterprise server starts, it connects to MF Directory Server to obtain its configuration details and to update its status information. To do this, it requires suitable Directory Server user credentials (that is, credentials that Directory Server will verify and authorize through the External Security Facility). You can specify that it should connect using a built-in default user or using the credentials with which you are currently logged on to Enterprise Server Administration. Alternatively, you can specify a different Directory Server username and password.

If you choose to use the built-in default user, the process is as follows:

  1. The enterprise server is started by the casstart command.
  2. It connects to MF Directory Server to obtain its configuration settings via the default user, mf_mdsa.
  3. The enterprise server subsequently spawns its communications server(s), referred to as MFCS.
  4. MFCS connects to MF Directory Server using the default user, mf_cs. This user requires permissions to do things like reading and writing data to the MF Directory Server repository. For example, it can read what configuration the server has, and write changes to the status field.
  5. The enterprise server will then use another default user, mfuser, as the identity for operations.
  • mf_cs and mf_mdsa must exist in the security context of MF Directory Server. That is, depending on the security configuration, they must exist in one of the security repositories used by MF Directory Server. The users must also have suitable permissions. At this point in time, the users must be members of a group called "#System" and this group must have modify permission on the resource entity in the Servers class that corresponds to the enterprise server. For more on the resource classes and entities controlling access to MF Directory Server resources, see Resource Classes for MF Directory Server.
  • mfuser must exist within the security context of the enterprise server and must have appropriate permissions on the casstart entity in the OPERCMDS class. For more about OPERCMDS, see Resource Classes for ESMAC and Operator Command Security.

If you choose to use the credentials with which you are currently logged on to Enterprise Server Administration, or if you specify alternative credentials, the enterprise server and MFCS will use those credentials when connecting to MF Directory Server. The enterprise server will also use the credentials internally.

Therefore, the user that you specify must exist within the security domain of both the MF Directory Server and the enterprise server. In addition:

  • To read and update information in MF Directory Server

    In the MF Directory Server domain, it must be a member of the #System group, and this group must have modify permission on the resource entity in the Servers class that corresponds to the enterprise server

  • To run the start command in Enterprise Server

    In the context of the enterprise server, it must have alter permission on the casstart entity within the OPERCMDS resource class

To stop an enterprise server, the requirements are the same, except that the user requires alter permission on the casstop entity with the OPERCMDS resource class.

Note:

Where an external security manager is configured for the enterprise server, a userid and password must be supplied when stopping it through any external method, such as casstop.

Parent topic: Solutions, Restrictions, and Changes in Behavior


Timeouts for Terminal Users

If a user is connected to a tn3270 terminal, and an ID timeout is specified either at the user level or at the system level (that is, the value specified in the SIT or overridden on the ESMAC Control page), then when the timeout is reached the user will be automatically signed-off and the default transaction specified in the SIT will be started.

Values are specified in minutes. If the value specified for the user is 0, the system timeout value is used. If the value specified for the user is -62, the user is never timed-out, irrespective of the system value. If any other value is specified for the user, that value is used in preference to the system value.

Note:

Note that Terminal timeouts (SIT parameter or user ID parameter) must be less than 16 hours.

Parent topic: Solutions, Restrictions, and Changes in Behavior


Sign-on Disabled for Default Users

When security is enabled, the default users can no longer sign-on to the system from a terminal.

Parent topic: Solutions, Restrictions, and Changes in Behavior


Configuring Sun Java System Directory as a Security Manager

This section describes the steps you need to perform in order to configure Sun Java System Directory to use it as an Enterprise Server security manager and configuration repository. Micro Focus has developed and tested under Sun Java System Directory Server Enterprise Edition 6.1. Later revisions of Sun Java System Directory should be compatible with Micro Focus Enterprise Server Security Manager and Configuration Repository but this is not guaranteed. Micro Focus will review any issues found in later releases of Sun Java System Directory but cannot guarantee compatibility.

Note:

The commands in this section make the following assumptions:

  • You have downloaded and installed Sun Java System Directory Server Enterprise Edition 6.1 as described on the Sun web site.
  • You have installed into /usr/local/dsee.
  • You are using port 3880. This is an arbitrarily-chosen port. Check with your system administrator to find out what ports are available on your system.
  • You are using the dsadm command-line tool instead of the Sun Java Web Console GUI Directory Service Control Centre.
  • You are using the scratch directory /usr/local/dsee/var/example.

You will need to change the commands if your installation uses settings other than these.

When configuring an external Security Manager connection on Solaris, it is possible to specify the use of the Sun-provided LDAP client module for LDAP communications with the external Security Manager. The following configuration text is required in the Security Manager Configuration Information area:

[LDAP]
provider=/usr/lib/libldap.so
Note: A Security Manager connection configured on Solaris is not limited to using Sun Java Directory Server. It can communicate with other LDAP-based external Security Managers such as Microsoft Active Directory or Open LDAP.
  1. To set up the Sun Directory Server configuration and database directories:
    1. Enter the following command:
      dsadm create -p 3880 /usr/local/dsee/var/example

      The following information is displayed: Choose the Directory Manager password:

    2. Specify the Directory Manager password.

      The following information is displayed: Confirm the Directory Manager Password

    3. Confirm the password.

      The following information is displayed: Use 'dsadm start '/usr/local/dsee/var/example'' to start the instance.

  2. To start the instance and confirm that it is running:
    1. Enter the following command:
      dsadm start /usr/local/dsee/var/example

      The following information is displayed: Server started: pid=24879

    2. Enter the following command:
      dsadm info /usr/local/dsee/var/example
      The following information is displayed:
      Instance Path | /usr/local/dsee/var/example
      Owner | hub(staff)
      Non-secure port | 3880
      Secure port | 1636
      Bit format | 64-bit
      State | Running
      Server PID | 24879
      DSCC url -
      SMF application name -
      Instance version | D-A00
    3. Use an LDAP browser to connect to the instance at machine-address:3880 using id DN: "cn=Directory Manager" and password "password" to confirm it is running. Currently only the RootDSE data is displayed.
  3. To extend the schema, create a text file called 99container.ldif in /usr/local/dsee/var/example/config/schema. The file should contain the following:
    dn:cn=schema
objectClasses:(1.2.840.113556.1.3.23 NAME 'container' SUP top STRUCTURAL MUST (cn))
  4. To generate the Micro Focus Schema Extension file, enter the following command:
    mfds -l DC=X 3	/usr/local/dsee/var/example/config/schema/99microfocus.ldif
  5. To ensure the Directory Server instance picks up the new schema files, enter the following command:
    dsadm restart /usr/local/dsee/var/example
  6. To confirm the Micro Focus schema has been installed, enter the following command:
    /usr/local/dsee/dsrk6/bin/ldapsearch -b cn=schema -v -h 127.0.0.1 -p 3880 -D "cn=Directory Manager" -w password "objectclass=*" > schema.txt

    This command dumps the active schema to a file called schema.txt . You can search this file to confirm that it includes the expected "container" and "microfocus" attributeTypes and objectClasses.

  7. To create a default suffix for an example DIT:
    1. Enter the following command:
      dsconf create-suffix -p 3880 dc=example,dc=com

      The following information is displayed: Enter "cn=Directory Manager" password:

    2. Specify the password.
  8. To confirm that the new suffix exists:
    1. Enter the following command:
      dsconf list-suffixes -p 3880

      The following information is displayed: Enter "cn=Directory Manager" password:

    2. Specify the password.

      The following information is displayed: dc=example,dc=com

  9. To import the standard shipped example LDIF file.
    1. Enter the following command:
      dsconf import -p 3880 /usr/local/dsee/ds6/ldif/Example.ldif dc=example,dc=com

      The following information is displayed: Enter "cn=Directory Manager" password:

    2. Specify the password.

      The following information is displayed:

      New data will override existing data of the suffix "dc=example,dc=com".

      Initialization will have to be performed on replicated suffixes.

      Do you want to continue [y/n] ?

    3. Press 'Y'

      The following information is displayed:

      ## Index buffering enabled with bucket size 40
      ## Beginning import job...
      ## Processing file "/usr/local/dsee/ds6/ldif/Example.ldif"
      ## Finished scanning file "/usr/local/dsee/ds6/ldif/Example.ldif" (160 entries)
      ## Workers finished; cleaning up...
      ## Workers cleaned up.
      ## Cleaning up producer thread...
      ## Indexing complete.
      ## Starting numsubordinates attribute generation. This may take a while, please wait for further activity reports.
      ## Numsubordinates attribute generation complete. Flushing caches...
      ## Closing files...
      ## Import complete. Processed 160 entries in 4 seconds. (40.00 entries/sec)
      Task completed (slapd exit code: 0).
  10. Refresh the LDAP browser to ensure that you can see the new DIT contents. There should be a new "example" DC, containing organizational units for groups and people.
  11. Add the standard Micro Focus containers:create a file /home/hub/staff/example/mf-containers-sun.ldif containing the following:
    dn: cn=Micro Focus,dc=example,dc=com
cn: Micro Focus
objectClass: container

dn: cn=Micro Focus,dc=example,dc=com
cn: Micro Focus
objectClass: container

dn: cn=Enterprise Server Users,cn=Micro Focus,dc=example,dc=com
cn: Enterprise Server Users
objectClass: container

dn: cn=Enterprise Server User Groups,cn=Micro Focus,dc=example,dc=com
cn: Enterprise Server User Groups
objectClass: container

dn: cn=MFDS Repository,cn=Micro Focus,dc=example,dc=com
cn: MFDS Repository
objectClass: container
  12. Add containers to the DIT:
    1. Enter the following command:
      /usr/local/dsee/dsrk6/bin/ldapmodify -a -v -h 127.0.0.1 -p 3880 -D "cn=Directory Manager" -w password -f /home/hub/staff/example/mf-containers-sun.ldif

      The following information is displayed:

      bin_ldapmodify: started Wed Sep 19 16:31:26 2007
      ldap_init( 127.0.0.1, 3880 )
      add cn:
      Micro Focus
      add objectClass:
      container
      adding new entry cn=Micro Focus,dc=example,dc=com
      modify complete
      add cn:
      Enterprise Server Resources
      add objectClass:
      container
      adding new entry cn=Enterprise Server Resources,cn=Micro Focus,dc=example,dc=com
      modify complete
      add cn:
      Enterprise Server Users
      add objectClass:
      container
      adding new entry cn=Enterprise Server Users,cn=Micro Focus,dc=example,dc=com
      modify complete
      add cn:
      Enterprise Server User Groups
      add objectClass:
      container
      adding new entry cn=Enterprise Server User Groups,cn=Micro Focus,dc=example,dc=com
      modify complete
      add cn:
      MFDS Repository
      add objectClass:
      container
      adding new entry cn=MFDS Repository,cn=Micro Focus,dc=example,dc=com
      modify complete
  13. Refresh the LDAP browser to ensure that you can see the new DIT contents. There should be a new "Micro Focus " container with the user "Enterprise Server" subcontainers.
  14. Add the Directory Server resources and users.
    1. Enter the following command:
      mfds -e "cn=Micro Focus,dc=example,dc=com" "cn=Enterprise Server Users" "cn=Enterprise Server User Groups" "cn=Enterprise Server Resources" 2 "/home/hub/staff/example/mfds-users-sun.ldif"
      Note:

      There is no difference between the OpenLDAP and Sun syntax for the generated LDIF file, so no Directory Server changes have been required.

  15. Import the generated mfds_users_sun.ldif file.
    1. Enter the following command:
      /usr/local/dsee/dsrk6/bin/ldapmodify -a -v -h 127.0.0.1 -p 3880 -D "cn=Directory Manager" -w password -f /home/hub/staff/example/mf-users-sun.ldif
  16. Refresh the LDAP browser to ensure that you can see the new DIT contents. The "Enterprise Server" subcontainers now contain the "Enterprise Server Administration", "schemaadmin" and "#"-prefixed Directory Server default user groups.
  17. In Directory Server, configure a new external security manager as follows:
    Name | Sun Directory 6.1 machine-address:3880
    Module | mldap_esm
    Connection Path | machine-address:3880
    Authorized ID | cn=Directory Manager
    Description | Test Sun Directory ESM
    Configuration Information | [LDAP]
    Base=cn=Micro Focus,DC=example,dc=com
    user container=CN=Enterprise Server Users
    group container=CN=Enterprise Server User Groups
    resource container=CN=Enterprise Server Resources
  18. Change the MF Server Directory Security Manager List to use this external security manager and turn on administrative security.
Parent topic: Solutions, Restrictions, and Changes in Behavior


Glossary

  • ACE
  • ACEE
  • ACL
  • ADAM
  • ADSI Edit
  • Auditing
  • CA-ACF2
  • CA-TopSecret
  • CLASS
  • CSD
  • ESF
  • ESM
  • LDAP
  • LDIF
  • RACF
  • Resource
  • SAF
  • schema
  • security manager
  • SNMP
Parent topic: Securing an Enterprise Server Installation


ACE

Access Control Entry: an entry in an Access Control List (ACL). It specifies an actor (e.g. a user or group) and the kinds of access that the actor has to a particular resource.
Parent topic: Glossary


ACEE

Access Control Environment Element: on the mainframe, a data structure that contains access control information for a task; in MF Server, a data structure that holds security information for a user (or potentially other actor).
Parent topic: Glossary


ACL

Access Control List: a rule specifying what actors (typically users and groups) are allowed what kinds of access (e.g. read, update) to a resource (file, transaction, configuration object, etc). (Some ESMs may not implement ACLs as such, but they provide an equivalent scheme.)
Parent topic: Glossary


ADAM

Active Directory Application Mode (ADAM) is a part of Microsoft’s fully integrated directory services available with Windows Server 2003, and is built specifically to address directory-enabled application scenarios.
Parent topic: Glossary


ADSI Edit

Lightweight Directory Access Protocol (LDAP) editor that you can use to manage objects and attributes in Active Directory.
Parent topic: Glossary


Auditing

Auditing refers to collecting information on security-related events and preserving it in for later review.
Parent topic: Glossary


CA-ACF2

An alternative to RACF.
Parent topic: Glossary


CA-TopSecret

An alternative to RACF.
Parent topic: Glossary


CLASS

In Micro Focus security terms, a CLASS is used to identify a collection of ENTITIES.
Parent topic: Glossary


CSD

CICS System Definiton (definition stored in Enterprise Server in DFHDRDAT / DFHDRDAT.IDX)
Parent topic: Glossary


ESF

The Micro Focus External Security Facility, which relays security queries to external security managers. This facility can run within both Enterprise Server and MF Directory Server.
Parent topic: Glossary


ESM

External Security Manager, another name for Security manager: any system outside MF Server that can respond to security queries. It might be the OS itself, or an LDAP server, or some other facility.
Parent topic: Glossary


LDAP

Lightweight Directory Access Protocol: a standard for configuration-data directories, particularly user directories. Microsoft Active Directory is an LDAP implementation.
Parent topic: Glossary


LDIF

LDAP Directory Interchange Format: a standard for transporting LDAP data and schema definitions between LDAP servers.
Parent topic: Glossary


RACF

Resource Access Facility, IBM's proprietorial security mechanism. Also known as z/OS Security Server
Parent topic: Glossary


Resource

Any item to which access is controlled. A resource has a name and a class. A resource name is unique within its class.
Parent topic: Glossary


SAF

System Authoriization Facility API, a call interface to z/OS software security functions. The API is a generic interface to the security functions that are typically provided by IBM’s Resource Access Facility (RACF) product. With Enterprise Server, this is typically user verification and resource access authorization.
Parent topic: Glossary


schema

In LDAP, the organization of information in the directory. The schema defines the types of configuration objects, their attributes, and their relationships.
Parent topic: Glossary


security manager

The module and associated configuration information that the External Security Facility connects to.
Parent topic: Glossary


SNMP

Simple Network Monitoring Protocol: a standard protocol for communicating system status and administration information. SNMP clients (usually called "agents") send information about changes in system status ("alerts") to an SNMP server ("monitor" or "manager"). They also respond to the monitor's queries for current status, and may be written to accept some administrative commands from the manager as well. The current version of SNMP is SNMPv3, which includes security provisions.
Parent topic: Glossary


Using the Security Audit Manager

The Audit Manager logs the records of auditable events that take place during Enterprise Server operation. You can use these records for things such as checking for security breaches or unauthorized access, or for monitoring usage.

  • About the Audit Manager
  • Audit Manager Architecture
  • Getting Started with Auditing
  • Starting and Stopping the Audit Process
  • Configuring the AUDITFILE Emitter
  • Configuring the SNMP Emitter
  • Accessing Audit Data
  • Dumping Audit Files
  • Using the Audit Manager as a Windows Service
  • Audit Manager Errors
  • Configuring a User Exit
  • Audit Manager APIs
Parent topic: Enterprise Server Security


About the Audit Manager

The Audit Manager can collect audit events generated by MFDS and by the SEPs running in an Enterprise Server installation. It can either write the information to a set of secure files, or output the information as SNMP events.

  • In a Windows environment, the default installation configures and starts the Micro Focus Audit Manager service.
    • If it's not already running, you can start this service from the Windows Services dialog box, or with the command:
      net start mfauditmgr
    • For flexibility, you can also run the Audit Manager directly, by running the mfauditmgr program located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin and \base\bin\win64.
  • In a UNIX environment, you can run the Audit Manager service as a daemon.

You can configure Audit Manager behaviour using a configuration file. You specify this configuration file with the -c <filename> option.

You can log auditable events to file, or as SNMP events. With SMMP, you can use SNMP management software to analyze the events.

The Audit Manager provides a utility, and APIs, that you can use to generate reports from the audit files that the system generates. The Audit Manager also provides APIs with which you can perform operations such as customizing logging destinations, and configuring your applications to generate audit events.

Parent topic: Using the Security Audit Manager
Related concepts
Audit Setup Configuration File
Related reference
To Start the Audit Manager
To stop the Audit Manager


Audit Manager Architecture

Audit event information is generated by SEPs, and by Micro Focus Directory Server (MFDS).

  • On a SEP, an Audit Manager process collects the audit events.
  • A Micro Focus Directory Server (MFDS) generates audit events and forwards these to the the system's Inter-Process Communications (IPC).

The IPC sends the audit events to the Audit Manager.

The Audit Manager's event consolidator process combines these events, and the Audit event emitter or emitters output them, either to a secure file, or as SNMP events.

This process is illustrated by the figure below:

  • About Audit Emitters
  • Audit Setup Configuration File
  • Default Audit Configuration
Parent topic: Using the Security Audit Manager


About Audit Emitters

The Audit Manager uses audit emitters to output the audit data.

There are two emitters that you can configure:

  • The AUDITFILE emitter writes audit data to a file. You use the Audit Facility Administration utility to access this data.

    The AUDITFILE emitter writes records to a collection of secure audit files. You configure the number and the size of the audit files in the collection when you set up the emitter definition.

    To access the audit details, you use a command to produce reports from the audit files. Once you have accessed the data, you can dump the file, and it becomes available for re-use by the audit process.

  • The SNMP emitter generates audit data as SNMP events.

    You can use an SNMP management tool to access this data.

Note: If there are no emitters configured, audit events are discarded.
Parent topic: Audit Manager Architecture


Audit Setup Configuration File

You can use a configuration file to configure audit setup. You specifiy the configuration file with the the auditmgr command's -c option when you start auditing. In the Windows environment, you can use the Micro Focus Audit Manager service Start Parameter to specify the configuration file.

An example configuration file is below:
mfaudit.dest=AUDITFILE
# Sets the output type to secure file.
mfaudit.emitter.auditfile#collectionsize=3
# Sets that the audit process uses three files only.
mfaudit.emitter.auditfile#location=C:\MFAudit\logs
# Sets the location where the files are to be created.
mfaudit.emitter.auditfile#file= audit.aud_$(GEN)
# Sets the auditing file names. The $(GEN) parameter
# sets that the filenames are numbered sequentially.
mfaudit.emitter.auditfile#maxfilesize=200
# Sets that audit files are closed when they reach
# a size of 200 KB
Parent topic: Audit Manager Architecture
Related concepts
About the Audit Manager
Related reference
To Start the Audit Manager
To stop the Audit Manager


Default Audit Configuration

If you start auditing without using a configuration file, the following defaults are used:

  • Shared memory is used as the IPC mechanism.
  • The Secure file emitter only is enabled, with the following characteristics:
    • Audit file collection size of 5.
    • 20 Mb maximum size of each audit file in the collection.
  • Location in which the audit files are created: The value set in the environment variable: MFAUDIT_LOGS
  • In the Windows environment, if the MFAUDIT_LOGS environment variable is not set, the audit logs are created in the location set by the following registry key:

    \HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Micro Focus\NetExpress\<version>\MFAUDIT\<version>\Install

Parent topic: Audit Manager Architecture


Getting Started with Auditing

The sections in this topic provide an example of how to configure secure file auditing in a Windows environment. You can use a similar process to configure auditing in a UNIX environment.

Note: In the Windows environment, auditing runs as a Windows service. You can also run auditing from a command line, as a separate process. To do this, you use the mfauditmgr command.

1. Create a configuration file

In this section, you create the configuration file that the audit process is to use. The configuration file controls the audit process: sets up the location, number, and maximum size of the files that the Audit Manager creates.

The lines beginning with the # character are comments only.

  1. Create a folder to hold your configuration file and auditing logs, for example: C:\MFAudit
  2. In the directory you created, use a text editor to create the audit.cfg file, and add the following content. The lines starting with # are comments only:
    mfaudit.dest=AUDITFILE
# Sets the output type to secure file.
mfaudit.emitter.auditfile#collectionsize=3
# Sets that the audit process uses three files only.
mfaudit.emitter.auditfile#location=C:\MFAudit\logs
# Sets the location where the files are to be created.
mfaudit.emitter.auditfile#file= audit.aud_$(GEN)
# Sets the auditing file names. The $(GEN) parameter
# sets that the filenames are numbered sequentially.
mfaudit.emitter.auditfile#maxfilesize=200
# Sets that audit files are closed when they reach
# a size of 200 KB

2. Start the auditing service

In this section, you re-start the auditing service so that it uses the configuration file.

  1. In Windows Services, locate the Micro Focus Audit Manager service, and if it is started, stop it.
  2. Right-click the service, and select Properties.
  3. Select the General tab, and in the Start parameters field at the bottom of the dialog box, enter the following:
    -c C:\MFAudit\audit.cfg
  4. On the dialog box, click Start and check that the service starts without errors.
  5. In Windows Explorer, check that the log files have been created ready for use.

3. Configure an External Security Manager (ESM)

In this section, you configure the Operating System ESM so that it is available for use.

  1. Start an Enterprise Server Administration session, and in the left hand pane under Configure, select Security.

    The Security Options screen appears.

  2. Select the Security Managers tab, and click Add to display the Add Security Manager screen.
  3. In the Name field, enter a name, for example Windows ESM, and in the Module field, enter osesm to specify the security manager. Ensure that the Enabled checkbox is checked, and click Add to add the security manager.

4. Generate MFDS auditing events

In this section, you configure the Operating System External Security Manager (ESM) to generate auditing events for Micro Focus Directory Server.

  1. In the left hand pane, select Security.
  2. Select the MF Directory Server tab and at the bottom of the screen, and click the Change button.
  3. Select the radio button next to the Windows ESM item you created, and click Add. You are prompted for a login with MF directory server administration permissions.
  4. Enter a valid Enterprise Server Administration user ID, for example the default SYSAD, password SYSAD, and click OK. You are prompted for a user ID and password with Administer Users permissions. Enter your system login and click OK.
  5. Under the MF Directory Server tab, in the Security Facility Configuration area, select the Create audit events checkbox, and at the bottom of the screen, click Apply.

MFDS operations that are performed are now logged to the audit files.

5. Generate Enterprise Server audit events

In this stage, you configure the Audit Manager to collect records of events generated by Enterprise Servers that are running.

  1. In the left hand pane, select Security.
  2. Select the Default ES Security tab and under Default ES Security Manager List, click Add.
  3. Select the radio button next to the Windows ESM entry, and click Add.

6. Perform secure operations

In this section, you generate audit events to be logged.

  1. Log off the directory server and log back on again.
  2. Perform some enterprise server processes, for example starting and stopping regions.
  3. Repeat the process to generate some audit events that you can check.

7. View the audit logs

In this section, you make the audit records accessible for viewing, and generate a report.

  1. In Windows Explorer, check the audit files and verify by the file size and datestamp that the first audit file has logged the audit data.

  2. Open a command prompt, and navigate to the C:\MFAudit\logs folder.
  3. Use the following command to make the first audit file available for dumping:
    mfauditadm -p -f audit.aud_1
  4. Use the following command to generate an audit report from the dumped file:
    mfauditadm -r -o audreport.txt -f audit.aud_1
    The above command creates a file named audreport.txt, that contains the audit information.
Parent topic: Using the Security Audit Manager


Starting and Stopping the Audit Process

You control auditing by starting or stopping the Audit Manager.

To capture audit events generated by audit-enabled products, you must configure and start the Audit Manager. You can start the process from the command line.

  • In the Windows environment, by default the Audit Manager runs as a service. You can control auditing by starting or stopping the Micro Focus Audit Manager service.
  • Under Unix and Linux you can configure the Audit Manager consolidator to run as a background process.

The Audit Manager consolidator obtains its configuration information from a file specified with a command line option.

  • To Start the Audit Manager
  • To stop the Audit Manager
Parent topic: Using the Security Audit Manager


To Start the Audit Manager

Syntax:

Use this command to start the Audit Manager.

mfauditmgr [-c cfg-file] [-n name]

Parameters:

cfg-file Specifies the name of the configuration file that is to be used for defining which emitters are to be enabled etc.

If no configuration file is specified, the audit event consolidator instance is configured as follows:

  • Shared memory is used as the IPC mechanism.
  • The Secure file emitter only is enabled, with the following characteristics:
    • Audit file collection size of 5.
    • 20 Mb maximum size of each audit file in the collection.
  • Location in which the audit files are created: The value set in the environment variable: MFAUDIT_LOGS
  • If the MFAUDIT_LOGS environment variable is not set, the audit logs are created in the location set by the following registry key:

    \HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Micro Focus\NetExpress\6.0\MFAUDIT\6.0\Install

name Specifies the name of the audit event consolidator instance. This is the name that applications will use to communicate with this audit event consolidator instance.

If this option is not specified, the machine name is used.

Parent topic: Starting and Stopping the Audit Process
Related concepts
About the Audit Manager
Audit Setup Configuration File
Related reference
To stop the Audit Manager


To stop the Audit Manager

Syntax:

This command stops the Audit Manager.

mfauditmgr -x [-n name]

Parameters:

-x | Stop the audit event consolidator instance
name | Specifies the name of the audit event consolidator instance. This is the name that applications will use to communicate with this audit event consolidator instance. If this option is not specified, the machine name will be used.

Comments:

You will only be allowed to stop an audit event consolidator instance if you are the owner (that is, the user that started it), or are a Windows Administrator. In Windows environments, you can use this command to stop the instance even if the instance has been started as a service.

Parent topic: Starting and Stopping the Audit Process
Related concepts
About the Audit Manager
Audit Setup Configuration File
Related reference
To Start the Audit Manager


Configuring the AUDITFILE Emitter

The AUDITFILE emitter writes audit records to a collection of files. These files hold the records in a binary format, and can be processed using the audit file APIs or the Audit Manager Administration Utility.

When the current file in the collection has reached its maximum size, the emitter writes to the next file in the collection. When all files in the collection have reached their maximum file, the emitter attempts to re-use the first file in the collection. This fails if the contents of the audit file have not yet been dumped.

When the last available file in the collection becomes half full, the emitter writes a warning event to the Windows event log, or to the Unix syslog. When the last available file in the collection becomes full, the emitter writes an error event to the Windows event log, or to the Unix syslog.

When no files are available, the emitter attempts to cache audit events in memory until a file becomes available. When there is no memory available, the emitter removes events from the cache to allow it to cache the most recent events. When an audit file becomes available, the emitter generates an audit event that details how many audit events were lost, and writes this as the first event in the file.

An audit file cannot be dumped until it has reached its maximum size, or has been set by an administrator as available for dumping. Marking an active files as available for dumping causes the file to be closed immediately, and the next file in the collection becomes the active file.

  • Setting AUDITFILE Emitter Properties
  • Setting the Audit Output Type
  • Specifying a User-defined Emitter
Parent topic: Using the Security Audit Manager
Related reference
Setting AUDITFILE Emitter Properties
AUDITFILE User Exit
To Make the Active Audit File Available for Dumping
To Dump an Audit File
To Generate a Report for an Audit File
To Generate a Report for All Audit Files in a Collection


Setting AUDITFILE Emitter Properties

Syntax:

In the Audit Manager Configuration file, you use the following line to specify the AUDITFILE emitter output properties.

mfaudit.emitter.emitter-name#property=property-value

Parameters:

emitter-name | The name of the audit emitter for which the property is to be set.
property-name | The name of the emitter property to set.
property-value | The value of the emitter property to be set. Emitter names and property names are case-insensitive. See the table below for details.
property-value | Description
AuditfileExit | The name of a DLL(Windows) or shared object (Unix/Linux) that is to be invoked by the AUDITFILE emitter to report on emitter status changes (see AUDITFILE User Exit). The name of the exit specified should reside in a directory on PATH (Windows) or LIBPATH / LD_LIBRARY_PATH / SHLIB_PATH on Unix/Linux.
CollectionSize The number of audit files that will be created in a collection.

Used in conjunction with MaxFileSize.

Default: 5. Maximum 10.
File The name of the audit file to be written.

The following pseudo-variables may be used for the construction of the audit file name:

  • $(AUDITID) - the name of the audit event consolidator that invoked this emitter.
  • $(GEN) - the generation of the file starting from 1.
Default: mfaudit.$(AUDITID).aud_$(GEN)

For example, the second file in the audit file collection created by this emitter when invoked by the audit event consolidator named nwb-cpjdell would be: mfaudit.nwb-cpjdell.aud_2

Note: If the $(GEN) pseudo-variable is not included in the file specification, this emitter appends it.
Location The directory where the audit files are to be written.

Default: the location specified by the MFAUDIT_LOGS environment variable or the current directory if MFAUDIT_LOGS is not set. The emitter will write an error event to the to the Unix syslog, if it is unable to create audit files in the specified directory.

Note: The Audit Manager attempts to create the output audit file location if it does not already exist. If the creation of the directory specified by the Location property fails, it will use the default location. If the creation of the directory specified by the MFAUDIT_LOGS environment variable fails, the current directory will be used.
The Net Express command prompt, 32-bit, sets MFAUDIT_LOGS to %PUBLIC%\Micro Focus\MFAUDIT\Logs..

If the MFAUDIT_LOGS environment variable is not set when running as a Windows Service, the Audit Manager will output the audit files to the directory specified by the \HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Micro Focus\NetExpress\<version>\MFAUDIT\<version>\Install registry key ).

MaxFileSize The directory where the audit files are to be written.

The maximum size of an audit file in KB that will be written before the file is closed, and the next audit file in the collection is opened.

A file in the collection is identified by the $(GEN) pseudo-variable (see File property above). The first audit file in a collection will result in the $(GEN) pseudo-variable being set to 1, the second in the sequence will result in it being set to 2, and so on until CollectionSize is exceeded. Once the CollectionSize number of files has been reached, the sequence number will revert back to 1.

Default: 0x00005000, indicating 20 MB max file size

Comments:

mfaudit.emitter.emitter-name#property is used to set a property with the a name and value for the given emitter. Any property name and value can be set, irrespective as to whether the emitter will actually make use of it. The CBL_AUDIT_EMITTER_PROPERTY_GET API can be used by an emitter to retrieve property values as strings or numeric values.

Multiple mfaudit.emitter.emitter-name#property entries can occur in the configuration file, but for duplicates, the last-most entry is used.

Property names are case insensitive.

When any of the following common case-insensitive property values are used, they are held in two forms: the string as given, and a corresponding numeric value. An emitter can then use the CBL_AUDIT_EMITTER_PROPERTY_GET API to retrieve the numeric value of the property directly without needing to perform its own string conversion.

String Value | Numeric Value
ON | 1
OFF | 0
YES | 1
Y | 1
NO | 0
N | 0
TRUE | 1
FALSE | 0
ENABLED | 1
DISABLED | 0
numeric-string | n

Examples:

Set the audit file name, the number of files in the audit file collection, and the maximum size of each audit file in the backup set for the AUDITFILE emitter.

...
mfaudit.emitter.auditfile#collectionsize=3
mfaudit.emitter.auditfile#location=e:\audit
mfaudit.emitter.auditfile#file= myaudit.aud_$(GEN)
mfaudit.emitter.auditfile#maxfilesize=200
...

Audit files myaudit.aud_1, myaudit.aud_2, and myaudit.aud_3 are created in the directory e:\audit. Each of these files has a maximum size of 200kb.

Parent topic: Configuring the AUDITFILE Emitter
Related reference
AUDITFILE User Exit
Related information
Configuring the AUDITFILE Emitter


Setting the Audit Output Type

Syntax:

In the the Audit Manager Configuration file, you use the mfaudit.dest parameter to specify audit event output types or emitter destinations to use: to file or as SNMP events, or both.

mfaudit.dest=audit-emitter-list

Parameters:

audit-emitter-list
A list of comma or space separated audit emitter names. Emitter names are case-insensitive. The supplied emitter names are:
  • AUDITFILE

    Trace events are written to an audit file in a binary format. The resulting file can be processed using the audit file APIs or the Audit Manager Administration Utility.

  • SNMP

    Trace events are generated as SNMP events.

The default is: mfaudit.dest=AUDITFILE

Comments:

mfaudit.dest is used to specify the audit event output types that are to be used by the audit event consolidator instance . You can configure multiple types.

Examples:

The following entry specifies that tracing events are to be output to an audit file.

...
mfaudit.dest=AUDITFILE
...

The following entry specifies that tracing events are to be output using both the audit file and SNMP emitters.

...
mfaudit.dest=AUDITFILE,SNMP
...
OR
...
mfaudit.dest=AUDITFILE
mfaudit.dest=SNMP
...
Parent topic: Configuring the AUDITFILE Emitter


Specifying a User-defined Emitter

Syntax:

In the the Audit Manager Configuration file, you use the following line to define an audit emitter that you have created. That is, it assigns an emitter name to your emitter program. Once you use this command, you can then use this emitter with the mfaudit.dest configuration.

mfaudit.emitter.emitter-name=program-name

Parameters:

emitter-name | The name of the emitter being defined. This name can be specified in mfaudit.dest entries elsewhere in the configuration file. Emitter names are case-insensitive.
program-name | The name of the program that implements the emitter interface and that will be invoked by the audit facility when outputting events to the destination named by emitter-name.

Default:

Not applicable.

Comments:

mfaudit.emitter is used to define a user-specific emitter. Where there are multiple mfaudit.emitter for the same emiter, the last-most is used.

Note: We recommend that custom emitters that you use should be written in C. They should not be written in COBOL due to potential recursion issues during CTF tracing.

Examples:

1) Define a user-specific emitter named MYAUDIT and make it a default audit emitter.

...
mfaudit.emitter.MYAUDIT=myauditemitter.dll
mfaudit.dest=MYAUDIT
...

2) Replace the well-known AUDITFILE emitter.

...
mfaudit.emitter.AUDITFILE=myauditfileemitter.so
...
Parent topic: Configuring the AUDITFILE Emitter


Configuring the SNMP Emitter

SNMP installations are split into two parts: an SNMP Agent runs on the systems being managed, whilst a central Management Console or other Management Tool runs elsewhere to monitor and maintain the systems that are running the Agents. There may be more than one Agent on a given system, provided that they are all configured to avoid using the same UDP and/or TCP ports, and that the Management Tool is told which ports to use to contact the Agents.

Various specifications of SNMP exist. v1 is not widely used today. v2, and specifically v2c, is most common. Whilst v3 can be thought of as being v2c using encrypted data flows.

There are many Agent systems. These may be software used on various operating systems, or firmware operating within hardware devices such as network routers. Micro Focus does not supply any Agent software.

The SNMP Emitter for the Micro Focus Audit Manager supports multiple logical interfaces which in turn interface with specific Agent services. The following SNMP Agent interfaces are provided for use with Net Express.

Agent interface module | Supplied with | Supported SNMP version | Description
mf_audit_win_snmp.dll | All installations of Net Express and Server | v2 and v2c | This module supports installations of Microsoft's WinSNMP embedded SNMP service, which works with SNMP v2 and v2c.
mf_audit_net_snmp.dll | All installations of Net Express and Server | v2, v2c and v3 (with no authentication or encryption of data) | This module supports installations of Net-SNMP v5.4 and upwards.
mf_audit_net_snmp.dll | The optional Security Pack for Net Express and Server | v2, v2c and v3 (with authentication and encryption of data) | This module supports installations of Net-SNMP v5.4 and upwards.

To use any of these modules, make the appropriate entries in the configuration file used by the Micro Focus Audit Consolidator Process. For details of the configuration file, see The Audit Consolidator Process Configuration File. For details on starting the consolidator process and specifying the location of the configuration file, see To start an audit event consolidator.

For each of these modules, a sample configuration file is shipped. The files are mf_audit_net_snmp.cfg and mf_audit_win_snmp.cfg. These contain elements specific to each of the variants of Windows SNMP support, but they are not complete mfauditmgr configuration files. The contents of the relevant sample file, or files, must first be merged with the existing Audit Manager configuration file, and then the Audit Manager system service must be re-started before the changes will take effect.

Many configuration options are common to both agent installations, but there are some entries that are specifically for use with Net-SNMP: the WinSNMP agent only supports SNMP v1 and SNMP v2 Trap generation, whilst the Net-SNMP agent also supports SNMP v3. However, the only configuration element that changes between WinSNMP and Net-SNMP when using SNMP v2 Traps is the agent name item.

It is perfectly acceptable to switch between Agents by using a single configuration file and alternating the agent used between mf_audit_win_snmp and mf_audit_net_snmp then re-starting the mfauditmgr service. Any extra SNMP v3 parameters that may have been supplied for Net-SNMP will simply be ignored by the WinSNMP emitter. A v2 Trap will always be issued when WinSNMP is in use, regardless of the SNMP version configured.

However, to use v3 authentication you must have the mf_audit_net_snmp module supplied with the Security Pack. If you configure the use of authentication when using the mf_audit_net_snmp module with the base Net Express or Server product, the emitter will log an error message.

Here's an example of a configuration file which will trace Audit events to both SNMP and the standard AUDITFILE emitter. This configuration uses WinSNMP to send the SNMP Trap messages.

mfaudit.emitter.snmp                = snmpaudit
mfaudit.dest                             = auditfile,snmp

mfaudit.emitter.auditfile#collectionsize = 5
mfaudit.emitter.auditfile#location       = c:\logs
mfaudit.emitter.auditfile#maxfilesize    = 1

mfaudit.emitter.snmp#agent      = mf_audit_win_snmp
# location of the Trap receiver, the Management Console that will view the audit events
mfaudit.emitter.snmp#agent.host  = <target host name or IP address>
# use port 162, the IANA default port for UDP and TCP traps
mfaudit.emitter.snmp#agent.port  = 162
# default is to exclude the events 0,2,3,4,5,6, the example below excludes
# events with a category >9
mfaudit.emitter.snmp#agent.exclude.events=>9

# Mode of transport, either UDP or TCP
# The default is UDP. Although an option for v2 installations
# TCP is normally only used for SNMP v3
# and is still only optional for v3
mfaudit.emitter.snmp#agent.transport = UDP

# the SNMP community of installations in which this system exists
# community default is "public"
mfaudit.emitter.snmp#agent.community = public

# snmp_version can be either "2" or "3". If v3, extra parameters
# are also required, see below.
# The default is "2"
mfaudit.emitter.snmp#agent.snmp_version = 2

The only change required to re-configure this audit manager installation to emit Audit events to SNMP using Net-SNMP instead of WinSNMP is shown below.

mfaudit.emitter.snmp#agent       = mf_audit_net_snmp

There are several extra parameters that are required in order to configure an SNMP v3 environment for the sending of encrypted audit messages. These are covered in Working with SNMP v3.

  • Using the SNMP Audit Emitter
  • Using the SNMP Emitter with a Net-SNMP Agent
  • Working with SNMP v3
Parent topic: Using the Security Audit Manager


Using the SNMP Audit Emitter

To use the SNMP Emitter, you must:

  1. Configure the SNMP Agent to emit Trap messages to a monitoring Management Tool location. To do this:
    1. Configure the SNMP Emitter to tell the Agent the location of the Management Tools that should receive the emitter Audit Events.
    2. If you are using the Net SNMP Agent, install the Micro Focus MIB file (see below) into the Net SNMP MIB database.
  2. Configure the Management Tool that is to monitor the trap output.
    1. Import the Micro Focus MIB file (see below) into the Management Tool's MIB database so that it can recognise the message content that it is going to receive from the Agent.
    2. Tell the Management Tool to accept SNMP Trap events from the location (and the port number if the Agent is not using default ports) of the originating Agent.

The Micro Focus MIB file, mf_audit_snmp.mib, is located in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory by default.

Note: Some MIB import tools require specific file extensions such as .mib or .mb, or just .txt. Ensure that you rename this file to match the requirements of your software before attempting to install the Micro Focus MIB extension.
Note: With the Microsoft WinSNMP Agent, the WinSNMP emitter will work without any further configuration beyond that contained in the audit configuration file.
Parent topic: Configuring the SNMP Emitter


Using the SNMP Emitter with a Net-SNMP Agent

Windows systems always have WinSNMP installed unless it has been specifically removed or disabled - although, without a little configuration it is quiescent. This is not the case with Net-SNMP, which you must install by hand.

The installation and configuration of Net-SNMP is beyond the scope of this document. Please refer to the Net-SNMP documentation for details. The main project, along with binary distributions, can be found at www.net-snmp.org (binaries are at www.net-snmp.org/download.html).

Once you have installed Net-SNMP, you must add the Micro Focus MIB definitions to the Net-SNMP MIB database before it will accept any actions from the audit emitter. You do this by running mf_audit_net_snmp_deploy.bat, which is supplied in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory by default.

The default installation drive for Net-SNMP is c:\usr. However, this location is used is at the discretion of the installer. Therefore, the mf_audit_net_snmp_deploy.bat file has an optional location parameter for specifying the location in which it will attempt to install the MIB. This parameter takes long and spacey names, provided that they are delimited with quote characters. If no parameter is found, the file will attempt to install the MIB into a Net-SNMP installation located in c:\usr.

When you have installed and configured the Agent software, you can configure the audit emitter (see below).

  • Configuring the emitter
  • Specifying the location of management tools
  • Configuring logging for problem diagnosis
Parent topic: Configuring the SNMP Emitter


Configuring the emitter

The configuration of each emitter can be viewed as two separate sections: where do you want the Trap messages to be received, and how do you want to send them. This breaks down into a series of location and format options.

The location information is always the same collection of:
  • Local agent (WinSNMP or Net-SNMP)
  • Destination location
  • Destination port
  • Transmission method
  • Events to be audited
  • SNMP version to be used
  • SNMP community identity

The format options vary widely depending upon the version of SNMP to be used.

Parent topic: Using the SNMP Emitter with a Net-SNMP Agent


Specifying the location of management tools

Specifying the location of management tools that will receive events

In the configuration file for the SNMP emitter, the agent.host and agent.port entries configure the snmp emitter to tell the Agent which of its configured management tools should receive the emitted Audit Events. For example:

mfaudit.emitter.snmp#agent.host = 127.0.0.1

WinSNMP cannot handle DNS (text) names and will only accept dotted decimal notation IP addresses like the one shown in the example above.

Net-SNMP can handle DNS or Dotted Decimal notation for the host location.

The Internet Assigned Names Authority (IANA) defines the standard ports to be used for SNMP traffic. Although it is entirely possible that specific installations may choose to use other ports, the following are the defined standard group of ports:

  • snmp 161/tcp SNMP
  • snmp 161/udp SNMP
  • snmptrap 162/tcp SNMPTRAP
  • snmptrap 162/udp SNMPTRAP

The SNMP Audit Emitter only uses the SNMPTRAP ports. If any installations require an override of the port definitions, follow the guidance below for configuring the SNMP agents on your installation, and modify the mfaudit.emitter.snmp#agent.port line in the configuration file. Failure to do both sets of configuration will lead to indeterminate results.

mfaudit.emitter.snmp#agent.port = 162

The transmission method is either UDP or TCP. UDP is widely used as it is fast and has few system overheads. UDP was also the only transmission method available in the early days of SNMP. TCP is slower but it can be used to transmit more than a single IP packet of information, and if audited events are being truncated the user should switch to using TCP. When changing a working system, remember that both the receiver and sender must share a similar configuration, so the changes must be made at both ends of the link.

To select UDP, set transport = UDP. For TCP, set transport = TCP. The default is to use UDP.

mfaudit.emitter.snmp#agent.transport = UDP

The SNMP Trap versions are set using the "snmp_version" configuration option. Acceptable values are either "2" or "3". The default snmpv value is "2".

If SNMP v3 is selected and you wish to use the authentication and privacy features, several extra parameters are also required and you must have the Net SNMP emitter module that is supplied with the Security Pack. See Working with SNMP v3 for more details.

mfaudit.emitter.snmp#agent.snmp_version= 2

The actual range of events that will be audited through this emitter can be masked using the agent.exclude.events option. For more details of this option, see the general Audit Manager documentation. The default behaviour is to exclude events below those at category 9.

mfaudit.emitter.snmp#agent.exclude.events=>9

All SNMP v2 and v3 installations operate within logical communities of installations. If no community name is specified all SNMP installations will use the default community name "public".

To specify the community of your local installations and, in particular, that of the receiver of the SNMP audit events, you will need to add a community option to your configuration file. This name must not be spacey in form.

mfaudit.emitter.snmp#agent.community = community_name

Parent topic: Using the SNMP Emitter with a Net-SNMP Agent


Configuring logging for problem diagnosis

Because audit emitters cannot use the Micro Focus Consolidated Tracing Facility (CTF) to produce diagnostic information, the SNMP emitter supports an alternative logging mechanism. This enables you to send log information to a file and optionally to the screen.

To use the logging mechanism, you use the agent.log_emitter, agent.log_to_screen and agent.logfilename entries in the configuration file. The sample below, illustrates the use of these entries. The comment lines (those preceded with #) document the allowable values.

# Emitters cannot use Micro Focus CTF trace facilities, so
# a basic alternative logging method has been provided.
#
# Logging can go to file and screen, or just to file.
#
# mfaudit.emitter.snmp#agent.log_emitter options
#
# on                  - enable all logging options
# off                 - do not log anything
# errors              - log only errors
# flow                - log module process flow
# content             - log audit message (partial) content
# errors_flow         - log errors and logic flow
# errors_flow_content - log errors and logic flow and content
mfaudit.emitter.snmp#agent.log_emitter = errors

# mfaudit.emitter.snmp#agent.log_to_screen options
# on                   - log to console screen
# off                  - do not log to screen, log to file
mfaudit.emitter.snmp#agent.log_to_screen = on

# mfaudit.emitter.snmp#agent.logfilename options
# if screen logging is disabled log to file name given here
mfaudit.emitter.snmp#agent.logfilename = c:\snmpemitter.log
Parent topic: Using the SNMP Emitter with a Net-SNMP Agent


Working with SNMP v3

SNMP v3 adds two optional levels of security to SNMP v2c Traps: Authentication and Privacy (Content Encryption).

To enable generated Audit events be sent using SNMP v3 flows, we rely upon software produced by the OpenSource Net-SNMP project. The main project along with binary distributions can be found at www.net-snmp.org. (Binaries are at www.net-snmp.org/download.html). This release of Micro Focus SNMP Audit Emitter was created to use Net-SNMP v5.4. It does not require a 3rd party OpenSSL installation, nor does it require an OpenSSL compliant Net-SNMP installation.

Note:
  • In order to use SNMP v3 with privacy and authentication, you must have the mf_audit_net_snmp.dll that is provided with the optional Micro Focus Security Pack, not the version that is supplied with the base product.
  • Microsoft Windows SNMP services do not include native SNMP v3 support, so the WinSNMP option will not provide SNMP v3.
  • The SNMP V3 Specific Configuration Options
  • Configuring the Micro Focus Audit Emitter for SNMP V3
Parent topic: Configuring the SNMP Emitter


The SNMP V3 Specific Configuration Options

The use of SNMP v3 with authentication and privacy introduces the need to configure several basic options before the SNMP v3 Traps can be generated and sent. If you are not using authentication and privacy, you can ignore these options. They are as follows:

  • Security Engine ID
  • Username
  • Hash method (MD5 or SHA1)
  • Authentication password
  • Cipher (DES or AES128)
  • Cipher password

There are two further options which will only be used in a limited number of installations:

  • Context EngineID
  • ContextName

Depending upon the transmission privilege settings all of the options may be used. In most installations, all of the options are going to be required to enable correct authentication and cryptographically protected transmissions that can be received correctly at the management console where the trap messages are monitored.

The SNMP Audit Emitter can only send SNMP v3 traps under a single user identity. In order for the traps to be deciphered correctly, this identity must also be configured with exactly the same content at the receiver of the trap messages.

Parent topic: Working with SNMP v3


Configuring the Micro Focus Audit Emitter for SNMP V3

The first change to a standard V2 installation is to enable V3 operations.

mfaudit.emitter.snmp#agent.snmp_version = 3

Now we must select the level of security privilege that we require on our transmissions.

Whilst Authentication can be enabled or disabled at will, Privacy can only be enabled when Authentication is already enabled. So the three transmission privilege permutations are:

NoAuth No authentication or encryption of data

AuthPriv Authenticate and use private (encrypted) data

AuthNoPriv Authenticate user with no encryption of data

When configuring the SNMP Audit Emitter, this choice is held in the "privilege" setting. The following example enables both Authorisation and Privacy.

mfaudit.emitter.snmp#agent.privilege = AuthPriv

When either Privacy or Authentication and Privacy are disabled, the relevant sections of the configuration are ignored.

To provided Authorisation, a user identity is configured at the monitoring trap receiver and the issuing Emitter. Five options define a user, and a further option defines the Security EngineID that groups the user within a logical group of users.

We shall now take a look at the User options in detail.

The Username

The username is a single text string with a simple name. This name cannot contain spaces.

mfaudit.emitter.snmp#agent.security_username = fred_jones

The Hash Method

The Hash Method and Authentication Pass Phrase (the Shared Secret in cryptographic terms) are combined to form a cryptic value. This value which will be compared with the receiver's similarly configured pairing which has a matching Username and Security EngineID. A mismatch will cause the authentication attempt to be rejected.

Most installations support the MD5 hash method, and later installations may also support SHA1. If configuring a new V3 user, you should choose to use the latest hash method installed at the monitoring location that will receive the traps. The original MD5 method is the default hash method as it will currently be pre-configured in more installations than SHA1.

mfaudit.emitter.snmp#agent.hmac = MD5

The chosen hash method is applied to a configured pass phrase. The pass phrase must be at least 8 characters in length and may be spacey if the phrase is contained within a single pair of quote characters. Non-spacey passwords may omit the quote characters.

mfaudit.emitter.snmp#agent.auth_passphrase = "auth password"

The Encryption Cipher

The Privacy cipher can be either DES or AES128. Like the SHA1 hash above, AES is a recent addition to SNMP V3 and may not be in place in all installations. As a result, the default setup is to use the DES cipher. As with choosing a hash method, if you are configuring a new v3 user you should choose to use the latest cipher method that is installed at the monitoring location that will receive the traps. This should ideally be AES, however the default setting is DES as this will match the majority of installations in the field today.

The three options are DES, AES and AES128. The latter two are equivalent. It is anticipated that additions to the SNMP V3 standard will add AES192 and AES256 support in the future. When this happens AES will refer to AES128.

mfaudit.emitter.snmp#agent.cipher = DES

Exactly the same rules apply to Privacy (Cipher) pass phrases and Authentication pass phrases.

mfaudit.emitter.snmp#agent.cipher_passphrase = "crypt password"

The Security Engine ID

Several copies of a given username can exist within an SNMP installation, however only one copy can exist within the scope of any one Security Engine. So the group of five options shown above are always paired with a Security Engine ID. This is a numerical string represented in hex format. There are many long and varied methods for determining what value to use for a security engine ID and there is as yet no formal consensus. This document is not the place to examine the arguments, however in the setup you will need to choose a value to use as the Security Engine ID. This must match the receiver's Engine ID and Username's config grouping of options.

The following example would work as an initial test value, however it lacks meaning in a wider SNMP context and your network management team should assign a security Engine ID for the Audit Emitter monitoring, or advise the user of an existing Engine ID that should be used.

mfaudit.emitter.snmp#agent.security_engineID = 0x0102030405

Putting this group together we have a collection that describes the user, the user's Security Engine in which it will work, and the methods of both proving the user's identity and encrypting the audit event's data content. Taken together this is the complete configuration describing a single user.

mfaudit.emitter.snmp#agent.privilege = AuthPriv
mfaudit.emitter.snmp#agent.security_engineID = 0x0102030405
mfaudit.emitter.snmp#agent.security_username = fred_jones
mfaudit.emitter.snmp#agent.hmac = MD5
mfaudit.emitter.snmp#agent.auth_passphrase = "auth password"
mfaudit.emitter.snmp#agent.cipher = DES
mfaudit.emitter.snmp#agent.cipher_passphrase = "crypt password"

The ContextID and ContextName

The final configuration items not mentioned so far are the Security Context ID and ContextName. These are paired together in much the same fashion as the SecurityEngineID and UserName to form a restricted connection entity.

Contexts can be useful in installations where several applications will be receiving SNMP data and the users do not wish all the applications to receive all the incoming data.

By giving different applications the same SecurityEngineID and UserName configuration, but different ContextEngine and ContextName configurations, data destined for specific locations can be sent to those locations without the need to configure extra Users in the SecurityEngine domain in order to distinguish the destinations and sources.

Again, in a similar fashion to the SecurityEngineID and UserName configuration items, the ContextEngineID is expected to be a hex string, and the ContextName a character string which usually has human readable content.

mfaudit.emitter.snmp#agent.context_engineID = 0x0102030405
mfaudit.emitter.snmp#agent.context_name = primary_audit_monitor
Parent topic: Working with SNMP v3


Accessing Audit Data

Audit data is either written to files, or output as SNMP events. You use the mfauditadm command to access the audit output data.

Before you can access data from the active file, you must make it available for dumping.

  • To Generate a Report for an Audit File
  • To Generate a Report for All Audit Files in a Collection
  • To Dump and Generate a Report for an Audit File
  • To Dump and Generate Reports for All Audit Files in a Collection
  • To Make the Active Audit File Available for Dumping
Parent topic: Using the Security Audit Manager


To Generate a Report for an Audit File

Syntax:

You use the Audit Manager Administration command line utility to do this. To dump or generate a report for the active audit file, you must first make it available for dumping.

mfauditadm -r -o report-file-name] -f audit-file-name

Parameters:

-r | Generate a report
-f audit-file-name | The audit file from which the report is to be generated.
-o report-file-name | Name of the report file to be created. If this option is not specified, the report file will be derived from the audit-file-name, where the extension will be replaced by .txt. For example, if the audit-file-name was specified as mfaudit.DOCTEST.aud_3, the report file created would be named mfaudit.DOCTEST.txt

Example:

mfauditadm -r -o auditdata.txt -f mfaudit.DOCTEST.aud_5
Note:

Once an audit file has been dumped, you cannot generate a report for it, nor can you dump it again, until it has been reused by the audit consolidator process.

Parent topic: Accessing Audit Data
Related information
Dumping Audit Files
Configuring the AUDITFILE Emitter


To Generate a Report for All Audit Files in a Collection

Syntax:

You use the Audit Facility Administration command line utility to do this.

mfauditadm -r -c [-o report-file-name] -f audit-file-name

Parameters:

-f audit-file-name | An audit file in the collection for which reports are to be generated.
-c | Generate a report for each available file in the collection.
-r | Generate a report.
-o report-file-name | Name of the report file to be created. If this option is not specified, the report file will be derived from the audit-file-name, where the extension will be replaced by .txt. For example, if the audit-file-name was specified as mfaudit.DOCTEST.aud_3, the report file created would be named mfaudit.DOCTEST.txt

Example:

mfauditadm -r -c -o auditdata.txt -f mfaudit.DOCTEST.aud_5
Note:

To dump or generate a report for the active audit file, you must first make it available for dumping. Once an audit file has been dumped, you cannot generate a report for it, nor can you dump it again, until it has been reused by the audit consolidator process.

Parent topic: Accessing Audit Data
Related information
Dumping Audit Files
Configuring the AUDITFILE Emitter


To Dump and Generate a Report for an Audit File

Syntax:

You use the Audit Manager Administration command line utility to do this.

mfauditadm -r [-date date] [-time time] -d [-o report-file-name] -f audit-file-name

Parameters:

-f audit-file-name | The audit file to be dumped and for which a report is to be generated.
-d | Mark the file as dumped.
-r | Generate a report.
-o report-file-name | Name of the report file to be created. If this option is not specified, the report file will be derived from the audit-file-name, where the extension will be replaced by .txt. For example, if the audit-file-name was specified as mfaudit.DOCTEST.aud_3, the report file created would be named mfaudit.DOCTEST.txt

Example:

mfauditadm -r -d -o auditdata.txt -f mfaudit.DOCTEST.aud_5
Note:

To dump or generate a report for the active audit file, you must first make it available for dumping. Once an audit file has been dumped, you cannot generate a report for it, nor can you dump it again, until it has been reused by the audit consolidator process.

Parent topic: Accessing Audit Data


To Dump and Generate Reports for All Audit Files in a Collection

Syntax:

You use the Audit Manager Administration command line utility to do this.

mfauditadm -r -c -d [-o report-file-name] -f audit-file-name

Parameters:

-f audit-file-name | An audit file in the collection to be dumped and for which a report is to be generated.
-c | Include each available file in the collection.
-r | Generate a report for each file available for dumping.
-d | Mark the files as dumped
-o report-file-name | Name of the report file to be created. If this option is not specified, the report file will be derived from the audit-file-name, where the extension will be replaced by .txt. For example, if the audit-file-name was specified as mfaudit.DOCTEST.aud_3, the report file created would be named mfaudit.DOCTEST.txt

Example:

mfauditadm -r -c -d -o auditdata.txt -f mfaudit.DOCTEST.aud_5
Note:

To dump or generate a report for the active audit file, you must first make it available for dumping. Once an audit file has been dumped, you cannot generate a report for it, nor can you dump it again, until it has been reused by the audit consolidator process.

Parent topic: Accessing Audit Data


To Make the Active Audit File Available for Dumping

Syntax:

In order to access the active file's audit data, you need to make it available for dumping. You use the Audit Manager Administration command line utility to do this. After you perform this, it is no longer the active file, and you can access the data it contains.
Note: You can specify the audit file by either giving its name or the name of the audit event consolidator that uses it. If neither are specified, the command uses the current active file.
mfauditadm -p [-n instance-name]
mfauditadm -p [-f audit-file-name]

Parameters:

-p | Make the active audit file available for dumping
-n instance-name | Specifies the name of the audit event consolidator instance. This is the name that applications will use to communicate with this audit event consolidator instance. This option cannot be used with the -f option. If neither this option nor the -f option is not specified, the machine name will be used.
-f audit-file-name | Specifiies the name of the audit file to be made available for dumping. This option cannot be used with the -n option. An error will be reported if the named file is not an active audit file.

Example:

mfauditadm -p -f mfaudit.DOCTEST.aud_5
Parent topic: Accessing Audit Data
Related information
Dumping Audit Files
Configuring the AUDITFILE Emitter


Dumping Audit Files

Audit files created by the AUDITFILE Emitter cannot be reused until they have been dumped. Dumping involves the creation of backup files or reports using the audit file APIs. Once an audit file has been dumped it is marked as being available for reuse.

An audit file cannot be dumped until:

  • It has reached its maximum size.

    or

  • It is marked as available for dumping using the Audit Manager Administration Utility.
  • To Dump an Audit File
  • To Dump All Audit Files in a Collection
Parent topic: Using the Security Audit Manager
Related reference
To Make the Active Audit File Available for Dumping
To Dump an Audit File
To Generate a Report for an Audit File
To Generate a Report for All Audit Files in a Collection


To Dump an Audit File

Syntax:

You use the Audit Manager Administration command line utility to do this.

mfauditadm -d -f audit-file-name

Parameters:

-f | The audit file to be dumped.
-d | Mark the file as dumped.

Example:

mfauditadm -d -f mfaudit.DOCTEST.aud_5
Note:

To dump or generate a report for the active audit file, you must first make it available for dumping. Once an audit file has been dumped, you cannot generate a report for it, nor can you dump it again, until it has been reused by the audit consolidator process.

Parent topic: Dumping Audit Files
Related information
Dumping Audit Files
Configuring the AUDITFILE Emitter


To Dump All Audit Files in a Collection

Syntax:

You use the Audit Manager Administration command line utility to do this.

mfauditadm -d -c -f audit-file-name

Parameters:

-f audit-file-name | An audit file in the collection to be dumped.
-c | Dump each available file in the collection containing audit-file-name.
-d | Mark the files as dumped.

Example:

mfauditadm -d -c -f mfaudit.DOCTEST.aud_5
Note:

To dump or generate a report for the active audit file, you must first make it available for dumping. Once an audit file has been dumped, you cannot generate a report for it, nor can you dump it again, until it has been reused by the audit consolidator process.

Parent topic: Dumping Audit Files


Using the Audit Manager as a Windows Service

If you have configured the consolidator to use the AUDITFILE Emitter to log audit information, you will need to manage the files that it creates.

To create your own audit emitters to log information, see Audit Emitter Interface.

Note:

The default installation installs the Audit Manager as a service.

  • To Install the Audit Event Consolidator as a Service (Windows only)
  • To Uninstall the Audit Event Consolidator as a Service (Windows only)
Parent topic: Using the Security Audit Manager


To Install the Audit Event Consolidator as a Service (Windows only)

You use the mfauditmgr command line utility to perform this.

Note:

The default installation installs the Audit Manager as a service.

Syntax:

mfauditmgr -i [-n name] [-c cfg-file]

Parameters:

-n name | The name of the audit event consolidator instance. This is the name that applications will use to communicate with the audit event consolidator instance. If this option is not specified, the machine name will be used.
-i | Install the audit event consolidator as a service.
-c cfg-file Specifies the name of the configuration file that is to be used for defining which emitters are to be enabled etc.

If no configuration file is specified, the audit event consolidator instance will be configured as follows:

  • The AUDITFILE emitter will be the only emitter enabled, and its properties will be set to their default values. For details, see AUDITFILE Emitter Properties.
.

Comments:

When starting the service, the -n and -c options may also be specified in the service's Start Parameters entry field (right-click on the Micro Focus Audit Manager service in the Services Window, and select Properties to bring up the properties dialog. Enter the command-line options in the Start Parameters field and click on the Start button.

Parent topic: Using the Audit Manager as a Windows Service


To Uninstall the Audit Event Consolidator as a Service (Windows only)

Syntax:

You use the mfauditmgr command line utility to perform this.

mfauditmgr -u [-n name]

Parameters:

-n name | The name of the audit event consolidator instance. This is the name that applications will use to communicate with the audit event consolidator instance. If this option is not specified, the machine name will be used.
-u | Uninstall the audit event consolidator as a service.
Parent topic: Using the Audit Manager as a Windows Service


Audit Manager Errors

The Audit Manager can generate the following error messages:

  • AUD0002E: Failed to start server
  • AUD0003E: Failed to connect to server
  • AUD0004E :Failed to initialise audit facility
  • AUD0005E: Failed to allocate memory
  • AUD0006E: File does not exist
  • AUD0007E: File is not available for dumping
  • AUD0008E: No file is available for dumping
  • AUD0009E: Invalid file format
  • AUD0010E: Invalid file name
  • AUD0011E: File not dumped
  • AUD0012E: Operation failed
  • AUD0013E: Failed to create output file
  • AUD0029E: Failed to initialise CTF
  • AUD0030E: You are not authorised to stop the server
  • AUD0031E: Failed to install service
  • AUD0032E: Failed to uninstall service
  • AUD0033E: File is not active
  • AUD0034E: You are not authorised to perform this operation
  • AUD0036E: Semaphore fault
Parent topic: Using the Security Audit Manager


AUD0002E: Failed to start server

Indicates that the audit manager server has failed to start.

Resolution

Note the events leading up to the error condition, and contact Micro Focus Technical Support.

Parent topic: Audit Manager Errors


AUD0003E: Failed to connect to server

Indicates that the audit process has failed to connect to the audit manager server.

Resolution

Note the events leading up to the error condition, and contact Micro Focus Technical Support.

Parent topic: Audit Manager Errors


AUD0004E :Failed to initialise audit facility

Indicates that the audit facility has failed to initialise.

Resolution

Note the events leading up to the error condition, and contact Micro Focus Technical Support.

Parent topic: Audit Manager Errors


AUD0005E: Failed to allocate memory

Indicates that a memory allocation process has failed.

Resolution

Note the events leading up to the error condition, and contact Micro Focus Technical Support.

Parent topic: Audit Manager Errors


AUD0006E: File does not exist

Indicates that

Indicates that you attempted a dump operation on a non-existent file.

Resolution

Check your syntax and try again.

Parent topic: Audit Manager Errors


AUD0007E: File is not available for dumping

Indicates that the file you attempted to dump has not been made available for dumping.

Resolution

Use the mfauditadm -p command to make the file available for dumping.

Parent topic: Audit Manager Errors


AUD0008E: No file is available for dumping

Indicates that you attempted a dump operation and no files have been made available for dumping.

Resolution

Use the mfauditadm -p command to make the file you want available for dumping.

Parent topic: Audit Manager Errors


AUD0009E: Invalid file format

Indicates that the audit file that you are attempting to dump is not a valid audit file.

Resolution

Check that the audit file you specified is valid and has been made available for dumping.

Parent topic: Audit Manager Errors


AUD0010E: Invalid file name

Indicates that the audit output file configuration attempts to allocate an incorrect filename for the output files.

Resolution

Check that the audit output filename (configured in the Audit Manager Configuration file) is valid. Don't forget that the process attempts to append a number to each sequential output filename.

Parent topic: Audit Manager Errors


AUD0011E: File not dumped

Indicates that an audit file dump operation failed.

Resolution

Check that the audit file has been made available for dumping, and that the location set to hold the dump output is valid, and has sufficient access permissions and space available to hold the dumped output.

Parent topic: Audit Manager Errors


AUD0012E: Operation failed

An audit operation failed.

Resolution

Note the sequence of events that lead up to the message, and contact Micro Focus Technical Support.

Parent topic: Audit Manager Errors


AUD0013E: Failed to create output file

The audit process failed in its attempts to create the file to hold the audit output.

Resolution

Check that the location set to hold audit output (configured in the Audit Manager Configuration file) is valid, and has sufficient access permissions and space available to hold the audit output.

Parent topic: Audit Manager Errors


AUD0029E: Failed to initialise CTF

The Audit Facility uses parts of the Consolidated Tracing Facility (CTF) infrastructure to provide functionality. The Audit Facility failed to initialise Consolidated Tracing Facility in order to access the functionaity it needs.

Resolution

If the problem persists, note the sequence of events leading up to the error and contact Micro Focus Technical Support.

Parent topic: Audit Manager Errors


AUD0030E: You are not authorised to stop the server

Your login ID does not have sufficient security access permissions to perform the operation.

Resolution

Use a login with the required permissions set, or contact your system administrator.

Parent topic: Audit Manager Errors


AUD0031E: Failed to install service

The mfauditmgr -i command failed to install the consolidator service.

Resolution

Try starting the service manually. If the problem persists, contact Micro Focus Technical Support.

Parent topic: Audit Manager Errors


AUD0032E: Failed to uninstall service

The mfauditmgr -u command failed to uninstall the consolidator service.

Resolution

Try uninstalling the service manually. If the problem persists, contact Micro Focus Technical Support.

Parent topic: Audit Manager Errors


AUD0033E: File is not active

The file from which you are attempting the dumping operation is not the active audit file.

Resolution

Use the following command to set the file as the active file:
mfauditadm -p -f <filename>
Parent topic: Audit Manager Errors


AUD0034E: You are not authorised to perform this operation

Your login ID does not have sufficient security access permissions to perform the operation.

Resolution

Use a login with the required permissions set, or contact your system administrator.

Parent topic: Audit Manager Errors


AUD0036E: Semaphore fault

An internal communications process has failed.

Resolution

Note the events leading up to the error condtition, and contact Micro Focus Technical Support.

Parent topic: Audit Manager Errors


Configuring a User Exit

You can invoke the AUDITFILE emitter user exit to report on emitter status changes. It is enabled by specifying its name to the AUDITFILE emitter using the configuration file's mfaudit.emitter.emitter-name#property entry.

  • AUDITFILE User Exit
Parent topic: Using the Security Audit Manager


AUDITFILE User Exit

The interface to the AUDITFILE_EMITTER_EXIT entry point is as follows:

  • AUDITFILE emitter initialising: The exit may change the emitter's properties during its invocation.
  • AUDITFILE emitter deinitialising: The exit would typically release any resources it has acquired during its previous invocations.
  • The name of the audit file being made active.
  • The name of the audit file that is now full.
  • No audit files are available for outputting events to.

The AUDITFILE emitter loads the DLL or shared object named by the AuditfileExit property and invokes the AUDITFILE_EMITTER_EXIT entry point within it whenever an emitter status change occurs.

Syntax:

typedef cobrtncode_t (*PFI_AUDITFILE_EMITTER_EXIT)(cobuns32_t function,
                                                   cobuns8_t *emitter_name,
                                                   ...);

On Entry:

function
AUDITFILE emitter status change:
0 | AUDITFILE emitter initialising. The exit may change the emitter's properties during its invocation
1 | AUDITFILE emitter deinitialising. The exit would typically release any resources it has acquired during its previous invocations
2 | A new audit file is being made active
3 | The active audit file is now full
4 | There are no audit files available for outputting events into
emitter name
The name of the emitter invoking the exit
...
A variable number of parameters depending on the value of function. When:
function=0 | no additional parameters
function=1 | no additional parameters
function=2 | 1 additional parameter: a null-terminated filename
function=3 | 1 additional parameter: a null-terminated filename
function=4 | no additional parameters

On Exit:

Nothing

Return Codes:

Dependent upon the exit function. At present this should always be 0.

Comments:

Please note that the user exit should not be written in COBOL.

See auditfile_exit.c for an example.

Parent topic: Configuring a User Exit
Related reference
Setting AUDITFILE Emitter Properties
Related information
Configuring the AUDITFILE Emitter


Audit Manager APIs

The Audit Manager provides APIs that you can use to audit-enable your applications, create your own audit emitters and process audit files.

  • API Return Codes
  • Audit Events
  • Audit Configuration APIs
  • Audit Event Generation APIs
  • Audit Event Consolidator APIs
  • Audit File Processing APIs
  • Audit Emitter Interface
  • Structure and Typedefs
Parent topic: Using the Security Audit Manager


API Return Codes

These return codes are provided in the mfaudit.cpy copybook for COBOL programs, and the mfaudit.h include file for C programs.

Value | Name | Description
0 | 78-AUD-RET-SUCCESS | Success
-1 | 78-AUD-RET-FAILURE | Unspecified Failure
1 | 78-AUD-RET-INVALID-HANDLE | Invalid audit or audit file handle specified
2 | 78-AUD-RET-INVALID-AUDIT-CATEGORY | Invalid audit category specified
5 | 78-AUD-RET-NOT-ENOUGH-MEMORY | Memory allocation error
6 | 78-AUD-RET-OUTPUT-ERROR | Error outputting to one or more output destinations
7 | 78-AUD-RET-PROPERTY-NOT-FOUND | Property not found
8 | 78-AUD-RET-BUFFER-TOO-SMALL | Buffer length too small
9 | 78-AUD-RET-VALUE-NOT-INTEGER | Value is not an integer
10 | 78-AUD-RET-EMITTER-NOT-FOUND | Emitter not found
12 | 78-AUD-RET-ZERO-LENGTH-DATA | Zero length data specified
13 | 78-AUD-RET-INVALID-PROP-NAME | Invalid property name specified
14 | 78-AUD-RET-INVALID-COMP-NAME | Invalid component name specified
15 | 78-AUD-RET-INVALID-EMITTER-NAME | Invalid emitter name specified
19 | 78-AUD-RET-NO-SERVER-PROCESS | mfauditmgr process is not running
20 | 78-AUD-RET-ACCESS-DENIED | Unable to access resource(s)
1000 | 78-AUD-RET-FILE-NOT-EXIST | File does not exist
1001 | 78-AUD-RET-FILE-NOT AVAILABLE | File(s) not available for dumping
1002 | 78-AUD-RET-FILE-INVALID-FORMAT | Unrecognised audit file format
1003 | 78-AUD-RET-FILE-EOF | End of file
1004 | 78-AUD-RET-FILE-NO-MORE-RECORDS | No more records left to process
1005 | 78-AUD-RET-FILE-INVALID-NAME | Invalid audit file name
1006 | 78-AUD-RET-FILE-NOT-DUMPED | Audit file has not been dumped
Parent topic: Audit Manager APIs


Audit Events

Event Category | Component Identifier | Event Identifier | Event Data | Description
Audit Facility (1) MF.AUDITMGR 0
  1. mfauditmgr instance name (text)
  2. mfauditmgr instance type (4-byte comp-5)

    0 = command line

    1 = Windows service

 mfauditmgr starting
1
  1. mfauditmgr instance name (text)
 mfauditmgr stopping
2 | None | Request received from mfauditadm -p to deactivate the active file
Parent topic: Audit Manager APIs


Audit Configuration APIs

The following Audit Configuration APIs are available:

  • CBL_AUDIT_CONFIG_PROPERTY_GET
    Get an audit configuration property value.
  • CBL_AUDIT_CONFIG_PROPERTY_SET
    Sets an audit configuration property value.
Parent topic: Audit Manager APIs


CBL_AUDIT_CONFIG_PROPERTY_GET

Syntax:

call "CBL_AUDIT_CONFIG_PROPERTY_GET" using by value     flags
                                           by reference property-name
                                           by reference property-vallen
                                           by reference property-value
                                              returning status-code

Parameters:

 | Typedef | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
property-name | pic x(n) | pic x(n)
property-vallen | cblt-x4-comp5 | pic x(4) comp-5
property-value | pic x(n) | pic x(n)

On Entry:

Control flags

Bit | Value | Meaning
0 | 0 | Return string value. Use bit 1 to determine string terminator
 | 1 | Return integer value. Ignore bit 1.
1 | 0 | Return the value as a space-terminated string
 | 1 | Return the value as a null-terminated string
2-28 |  | Reserved for future use (must be 0)
29 | 0 | property-name is space-terminated
 | 1 | property-name is null-terminated
30-31 |  | Reserved for future use (must be 0)

property-name: Space- or null- terminated (depending upon setting of bit 29) case-insensitive property name.

NAME | mfauditmgr instance name to connect, or are connected, to
NOSERVER_ACTION | indicates the desired behaviour of the CBL_AUDIT_EVENT API when the mfauditmgr process is not running. A value of "wait" indicates the API will block (the default). A value of "nowait" indicates the API will return an error.
SYSTEM | name of the system to be associated with audit events output by this process

property vallen: Length of property-value buffer in which property value is to be returned. The routine fails if this is too small for the value to be returned. This parameter is ignored if value is being returned as an integer.

On Exit:

property-vallen | Length of returned string value in property-value buffer. Length does not include termination character. If property-value is null, or if the specified buffer length is too small for the value to be returned, property-vallen will be set to the required buffer length. This parameter is not set if the value is being returned as an integer.
property-value | Buffer in which the property value is to be returned. This is either a pic x(n) field for a value being returned as a string, or a pic x(4) comp-5 field for a value being returned as an integer. A null property-value may be specified to request that the API returns the required buffer length to hold the specified property value.

Return Codes:

78-AUD-RET-SUCCESS
78-AUD-RET-NOT-ENOUGH-MEMORY
78-AUD-RET-PROPERTY-NOT-FOUND
78-AUD-RET-BUFFER-TOO-SMALL
78-AUD-RET-VALUE-NOT-INTEGER
78-AUD-RET-INVALID-PROP-NAME

Comments:

CBL_AUDIT_CONFIG_PROPERTY_GET is used to retrieve a named property value associated with the audit facility's configuration for the current process.

Supported properties are yet to be defined.

Examples:

Get the value associated with the audit facility's "system" property.

copy "mfaudit.cpy" .

01 flags           pic x(4) comp-5.
01 prop-len        pic x(4) comp-5.
01 prop-string     pic x(100).
...
compute flags = 78-AUD-FLAG-PROP-STRING-VALUE
move length of prop-string to prop-len

call "CBL_AUDIT_CONFIG_PROPERTY_GET" using
                                     by value flags
                                     by reference "system "
                                     by reference prop-len
                                     by reference prop-string
...
Parent topic: Audit Configuration APIs


CBL_AUDIT_CONFIG_PROPERTY_SET

Syntax:

call "CBL_AUDIT_CONFIG_PROPERTY_SET" using by value     flags
                                           by reference property-name
                                           by reference property-value
                                              returning status-code

Parameters:

 | Typedef | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
property-name | pic x(n) | pic x(n)
property-value | pic x(n) | pic x(n)

On Entry:

flags
Bit | Value | Meaning
0 | 0 | String value. Use bit 1 to determine string terminator
1 | Integer value. Ignore bit 1.
1 | 0 | String value is space-terminated
1 | String value is null-terminated
2-28 | Reserved for future use (must be 0)
29 | 0 | property-name is space-terminated
1 | property-name is null-terminated
30-31 | Reserved for future use (must be 0)
property-name
Space- or null- terminated (depending upon setting of bit 29) case-insensitive property name. Recognised property names are:
NAME | mfauditmgr instance name to connect, or are connected, to
NOSERVER_ACTION | indicates the desired behaviour of the CBL_AUDIT_EVENT API when the mfauditmgr process is not running. A value of "wait" indicates the API will block (the default). A value of "nowait" indicates the API will return an error.
SYSTEM | name of the system to be associated with audit events output by this process
Note: Other property names may be set, but they will be ignored by the facility.

On Exit:

Nothing.

Return Codes:

78-AUD-RET-SUCCESS
78-AUD-RET-NOT-ENOUGH-MEMORY
78-AUD-RET-INVALID-PROPERTY-NAME

Comments:

CBL_AUDIT_CONFIG_PROPERTY_SET is used to set a named property value for the audit facility's configuration for the current process. If a property with the same name already exists, its value will be replaced with the new value.

Supported properties are yet to be defined.

Examples:

Set the audit facility's "system" property value.

copy "mfaudit.cpy ".

01 flags           pic x(4) comp-5.
01 prop-string     pic x(100).
...
compute flags = 78-AUD-FLAG-PROP-STRING-VALUE
move "ESDEMO" & x"00" to prop-string

call "CBL_AUDIT_EMITTER_PROPERTY_SET" using
                                    by value flags
                                    by reference "system "
                                    by reference prop-string
...
Parent topic: Audit Configuration APIs


Audit Event Generation APIs

The following Audit Event Generation APIs are available:

  • CBL_AUDIT_EVENT
    Outputs an audit event.
  • CBL_AUDIT_HANDLE_GET
    Get an audit handle.
  • cobaudit_event
    Outputs an audit event.
Parent topic: Audit Manager APIs


CBL_AUDIT_EVENT

Syntax:

call "CBL_AUDIT_EVENT" using by value     flags
                             by reference component-id
                             by reference audit-event
                                returning status-code

Table 1. Parameters
 | Typedef | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
component-id | pic x(n) | pic x(n)
audit-event | cblt-aud-event | Group containing
cblte-audevt-version | cblt-x4-comp5 | pic x(4) comp-5
cblte-audevt-flags | cblt-x4-comp5 | pic x(4) comp-5
cblte-audevt-id | cblt-x4-comp5 | pic x(4) comp-5
cblte-audevt-category | cblt-x4-comp5 | pic x(4) comp-5
cblte-audevt-data-count | cblt-x4-comp5 | pic x(4) comp-5
cblte-audevt-reserved1 | cblt-x4-comp5 | pic x(4) comp-5 occurs 7
cblte-audevt-event-len | cblt-pointer | pointer
cblte-audevt-event-type | cblt-pointer | pointer
cblte-audevt-event-data | cblt-pointer | pointer
cblte-audevt-reserved2 | cblt-pointer | pointer occurs 7

On entry

Control flags

Bit | Value | Meaning
0-12 | Reserved | for future use (must be 0)
13 | 0 | cblte-audevt-event-data is an array of pointers to trace data of varying size and type. The corresponding elements of the cblte-audevt-event-len and cblte-audevt-event-type arrays need to be set up.
 | 1 | cblte-audevt-event-data is an array of pointers to trace data of the same size and type. Only the first element of cblte-audevt-event-len and cblte-audevt-event-type need to be set up.
14-29 |  | Reserved for future use (must be 0)
30 | 0 | component-id is space-terminated
 | 1 | component-id is null-terminated
 |  | (ignored if bit 31 unset)
31 | 0 | component-id is an audit handle created by CBL_AUDIT_HANDLE_GET (pic x(4) comp-5).
 | 1 | component-id is a text string (pic x(n)) . The termination character for the string is defined by bit 30.
component-id
Component identifier. This will either be a pic x(4) comp-5 tracer handle (See CBL_AUDIT_HANDLE_GET() - Get an Audit Handle for details about how a component acquires an audit handle) if bit 31 of flags is not set, or a pic x(n) text identifier if bit 31 of flags is set.
cblte-audevt-version
Structure version. Must be 0.
cblte-audevt-flags
Control flags. Must be 0.
cblte-audevt-id
Component specific audit event identifier used to identify the type of event being output
cblte-audevt-category
Category of the audit event being output.
Value Category
0 Unknown
1 Audit Facility
2 System
3 Security API request check
4 Security API request define
5 Security API request other
6 Security API result allow
7 Security API result deny
8 Security API result error
9 Security API result success
cblte-audevt-data-count
Number of audit data items. Indicates the number of elements in the cblte-audevt-event-len, cblte-audevt-event-type, and cblte-audevt-event-data arrays. May be 0.
cblte-audevt-event-len
Pointer to array of 4-byte comp-5 items. Each array element indicates the length of the corresponding audit data item in the cblte-audevt-event-data array. May be NULL if cblte-audevt-data-count is 0.
cblte-audevt-event-type
Pointer to array of 4-byte comp-5 items. Each array element indicates the type of the corresponding audit data item in the cblte-sudevt-event-data array. May be NULL if cblte-audevt-data-count is 0.
Value Type
0 Binary
1 Text (local encoding)
2 Address
3 COMP-5
4 COMP-X
5 UTF8
6 Signed COMP-5
7 Signed COMP-X
cblte-audevt-event-data
Pointer to array of pointer items. Each array element addresses an audit data item of the type and length indicated by the corresponding element in the cblte-audevt-event-type and cblte-audevt-event-len arrays respectively. May be NULL if cblte-audevt-data-count is 0.

N.B. for address type items, the array element is the address value, and not a pointer to the address value.

On Exit:

Nothing

Return Codes:

78-AUD-RET-SUCCESS
78-AUD-RET-INVALID-HANDLE
78-AUD-RET-INVALID-AUDIT-CATEGORY
78-AUD-RET-NOT-ENOUGH-MEMORY
78-AUD-RET-OUTPUT-ERROR
78-AUD-RET-INVALID-COMPONENT-NAME
78-AUD-RET-NO-SERVER-PROCESS
78-AUD-RET-ACCESS-DENIED

Comments:

None

Examples:

copy "mfaudit.cpy".

78 78-EVENT-TYPE-A      value 1.
78 78-EVENT-TYPE-B      value 2.

01 audit-event          cblt-aud-event.
01 audit-event-lengths  pic x(4) comp-5 occurs 1.
01 audit-event-pointers pointer occurs 1.
01 audit-event-types    pic x(4) comp-5 occurs 1.
01 audit-handle         pic x(4) comp-5.
01 audit-info           pic x(10).
01 component-id         pic x(7) value "mycomp ".
01 flags                pic x(4) comp-5.

...
move low-values to audit-event

set cblte-audevt-event-len of audit-event to
    address of audit-event-lengths(1)
set cblte-audevt-event-type of audit-event to
    address of audit-event-types(1)
set cblte-audevt-event-data of audit-event
    to address of audit-event-pointers(1)

1) Acquire an audit handle to trace "mycomp" component audit events, and then output two audit events: one with event data, one without.

call "CBL_AUDIT_HANDLE_GET" using by value 0
                                  by reference component-id
                                  by reference audit-handle
...
move 0 to flags
move 78-AUD-FLAG-CATEGORY-UNKNOWN to
     cblte-audevt-category of audit-event
move 78-EVENT-TYPE-A to cblte-audevt-id of audit-event
move 1 to cblte-audevt-data-count of audit-event
move length of audit-info to audit-event-lengths(1)
move 78-AUDIT-EVENT-TYPE-TEXT to audit-event-types(1)
set audit-event-pointers(1) to address of audit-info

call "CBL_AUDIT_EVENT" using by value flags
                             by reference audit-handle
                             by reference audit-event
...
move 78-EVENT-TYPE-B to cblte-audevt-id of audit-event
move 0 to cblte-audevt-data-count of audit-event

call "CBL_AUDIT_EVENT" using by value flags
                             by reference audit-handle
                             by reference audit-event
...

2) Output two informational events for the "mycomp" component without acquiring an audit handle

...
move 78-AUD-FLAG-COMPID-STRING to flags
move 78-AUD-FLAG-CATEGORY-UNKNOWN to
     cblte-audevt-category of audit-event
move 78-EVENT-TYPE-A to cblte-audevt-id of audit-event
move 1 to cblte-audevt-data-count of audit-event
move length of audit-info to audit-event-lengths(1)
move 78-AUDIT-EVENT-TYPE-TEXT to audit-event-types(1)
set audit-event-pointers(1) to address of audit-info

call "CBL_AUDIT_EVENT" using by value flags
                             by reference component-id
                             by reference audit-event
...
move 78-EVENT-TYPE-B to cblte-audevt-id of audit-event
move 0 to cblte-audevt-data-count of audit-event

call "CBL_AUDIT_EVENT" using by value flags
                             by reference component-id
                             by reference audit-event
...
Parent topic: Audit Event Generation APIs


CBL_AUDIT_HANDLE_GET

Syntax:

call "CBL_AUDIT_HANDLE_GET" using by value     flags
                                  by reference component-name
                                  by reference audit-handle
                                     returning status-code

Parameters:

 | Typedef | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
component-name | pic x(n) | pic x(n)
audit-handle | cblt-x4-comp5 | pic x(4) comp-5

On Entry:

flags
Bit | Value | Meaning
0-29 | Reserved for future use (must be 0)
30 | 0 | component-name is space-terminated
1 | component-name is null-terminated
(ignored if bit 31 unset)
31 | Reserved for future use (must be 0)
component-name
Space- or null-terminated (depending upon bit 30 setting) case-insensitive component identifier string.

On Exit:

audit-handle
Audit handle to be specified to the CBL_AUDIT_EVENT API.

Return Codes:

78-AUD-RET-SUCCESS
78-AUD-RET-NOT-ENOUGH-MEMORY
78-AUD-RET-INVALID-COMPONENT-NAME

Comments:

Components should invoke this API to acquire an audit handle before performing any auditing operations. This API returns an audit handle that should be passed to the CBL_AUDIT_EVENT API.

Please note that the CBL_AUDIT_EVENT API allows a component to be specified as a handle or as a string depending upon its flags parameter specification. This allows events to be output without first acquiring an audit handle by specifying a component identifier string instead. However, this will have an impact on performance as the component identifier will be validated each time.

Examples:

Acquire an audit handle to output "mycomp" audit events.

copy "mfaudit.cpy".

01 audit-handle    pic x(4) comp-5.
01 component-name  pic x(7) value "mycomp".
...
call "CBL_AUDIT_HANDLE_GET" using by value 0
                                  by reference component-name
                                  by reference audit-handle
...
Parent topic: Audit Event Generation APIs


cobaudit_event

Syntax:

cobrtncode_t cobaudit_event(cobuns32_t      flags_p,
                   const cobuns8_t *component_id,
                   AUDIT_EVENT     *audit_event)

On Entry:

Control flags
Bit | Value | Meaning
0-29 |  | Reserved for future use (must be 0)
30 | 0 | component-name is space-terminated
 | 1 | component-name is null-terminated
 |  | (ignored if bit 31 unset)
31 |  | Reserved for future use (must be 0)
component_id
Component identifier. This will either be a 32-bit unsigned integer tracer handle (See CBL_AUDIT_HANDLE_GET() - Get an Audit Handle for details about how a component acquires an audit handle) if bit 31 of flags is not set, or a text identifier if bit 31 of flags is set.
audit_event
Audit event structure
version | Structure version. Must be 0.
flags | Control flags. Must be 0.
event_id | Component specific event identifier used to identify the type of event being output.
event_category | Audit event category.
data_count | Number of audit data items. Indicates the number of elements in the event_len, event_type, and event_data arrays. May be 0.
event_len | Pointer to array of 32-bit unsigned integers. Each array element indicates the length of the corresponding audit data item in the event_data array. May be NULL if data_count is 0.
event_type Pointer to array of 32-bit unsigned integers. Each array element indicates the type of the corresponding audit data item in the event_data array. May be NULL if data_count is 0.
Any value other than the ones specified above will be treated as type 0 (binary).
0 Binary
1 Text (local encoding)
2 Address
3 COMP-5
4 COMP-X
5 UTF8
6 Signed COMP-5
7 Signed COMP-X
event_data Pointer to array of pointer items. Each array element addresses an audit data item of the type and length indicated by the corresponding element in the event_type and event_len arrays respectively. May be NULL if data_count is 0.

N.B. for address type items, the array element is the address value, and not a pointer to the address value.

On Exit:

Nothing

Return Codes:

AUDIT_RET_SUCCESS
AUDIT_RET_INVALID_HANDLE
AUDIT_RET_INVALID_AUDIT_CATEGORY
AUDIT_RET_NOT_ENOUGH_MEMORY
AUDIT_RET_OUTPUT_ERROR
AUDIT_RET_INVALID_COMPONENT_NAME
AUDIT_RET_NO_SERVER_PROCESS
AUDIT_RET_ACCESS_DENIED

Comments:

cobaudit_event() is intended for use by C programs. It outputs the specified event identified by event_id to one or more output destinations.

Parent topic: Audit Event Generation APIs


Audit Event Consolidator APIs

The following Audit Event Consolidator APIs are available:

  • CBL_AUDIT_EMITTER_PROPERTY_GET
    Get an audit emitter property value.
  • CBL_AUDIT_EMITTER_PROPERTY_SET
    Set an audit emitter property value.
Parent topic: Audit Manager APIs


CBL_AUDIT_EMITTER_PROPERTY_GET

Syntax:

call "CBL_AUDIT_EMITTER_PROPERTY_GET" using by value     flags
                                            by reference emitter-name
                                            by reference property-name
                                            by reference property-vallen
                                            by reference property-value
                                               returning status-code

Parameters:

 | Typedef | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
emitter-name | pic x(n) | pic x(n)
property-name | pic x(n) | pic x(n)
property-vallen | cblt-x4-comp5 | pic x(4) comp-5
property-value | pic x(n) | pic x(n)

On Entry:

flags
Bit | Value | Meaning
0 | 0 | Return string value. Use bit 1 to determine string terminator
1 | Return integer value. Ignore bit 1.
1 | 0 | Return the value as a space-terminated string
1 | Return the value as a null-terminated string
2-27 | Reserved for future use (must be 0)
28 | 0 | emitter-name is space-terminated
1 | emitter-name is null-terminated
29 | 0 | property-name is space-terminated
1 | property-name is null-terminated
30-31 | Reserved for future use (must be 0)
emitter-name
Space- or null-terminated (depending upon setting of bit 28) case-insensitive emitter name.
property-name
Space- or null- terminated (depending upon setting of bit 29) case-insensitive property name.
property-vallen
Length of property-value buffer in which property value is to be returned. The routine fails if this is too small for the value to be returned.

Ignored if value is being returned as an integer.

On Exit:

property-vallen | Length of returned string value in property-value buffer. Length does not include termination character. If property-value is null, or if the specified buffer length is too small for the value to be returned, property-vallen will be set to the required buffer length. Not set if the value is being returned as an integer.
property-value | Buffer in which the property value is to be returned. This is either a pic x(n) field for a value being returned as a string, or a pic x(4) comp-5 field for a value being returned as an integer. A null property-value may be specified to request that the API returns the required buffer length to hold the specified property value.

Return Codes:

78-AUD-RET-SUCCESS
78-AUD-RET-NOT-ENOUGH-MEMORY
78-AUD-RET-PROPERTY-NOT-FOUND
78-AUD-RET-BUFFER-TOO-SMALL
78-AUD-RET-VALUE-NOT-INTEGER
78-AUD-RET-EMITTER-NOT-FOUND

Comments:

CBL_AUDIT_EMITTER_PROPERTY_GET is used to retrieve a named property value for the emitter with name emitter-name. The function would typically by used by an emitter during its initialisation to determine how it had been configured.

Examples:

Get two property values associated with the "AUDITFILE" emitter: one a space-terminated string value, one an integer value.

copy "mfaudit.cpy ".

01 emitter-name    pic x(10) value " AUDITFILE".
01 flags           pic x(4) comp-5.
01 prop-integer    pic x(4) comp-5.
01 prop-len        pic x(4) comp-5.
01 prop-string     pic x(100).
...
compute flags = 78-AUD-FLAG-PROP-STRING-VALUE
move length of prop-string to prop-len

call "CBL_AUDIT_EMITTER_PROPERTY_GET" using
                                    by value flags
                                    by reference emitter-name
                                    by reference "location "
                                    by reference prop-len
                                    by reference prop-string
...
compute flags = 78-AUD-FLAG-PROP-INT-VALUE

call "CBL_AUDIT_EMITTER_PROPERTY_GET" using
                                    by value flags
                                    by reference emitter-name
                                    by reference "collectionsize "
                                    by value 0
                                    by reference prop-integer
...
Parent topic: Audit Event Consolidator APIs


CBL_AUDIT_EMITTER_PROPERTY_SET

Syntax:

call "CBL_AUDIT_EMITTER_PROPERTY_SET" using by value     flags
                                            by reference emitter-name
                                            by reference property-name
                                            by reference property-value
                                               returning status-code

Parameters:

 | Typedef | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
emitter-name | pic x(n) | pic x(n)
property-name | pic x(n) | pic x(n)
property-value | pic x(n) | pic x(n)

On Entry:

flags
Bit | Value | Meaning
0 | 0 | String value. Use bit 1 to determine string terminator
1 | Integer value. Ignore bit 1.
1 | 0 | String value is space-terminated
1 | String value is null-terminated
2-27 | Reserved for future use (must be 0)
28 | 0 | emitter-name is space-terminated
1 | emitter-name is null-terminated
29 | 0 | property-name is space-terminated
1 | property-name is null-terminated
30-31 | Reserved for future use (must be 0)
emitter-name
Typedef: pic x(n)

Picture: pic x(n)

property-name
Typedef: pic x(n)

Picture: pic x(n)

property-value
Typedef: pic x(n)

Picture: pic x(n)

On Exit:

Nothing

Return Codes:

78-AUD-RET-SUCCESS
78-AUD-RET-NOT-ENOUGH-MEMORY
78-AUD-RET-EMITTER-NOT-FOUND
78-AUD-RET-INVALID-EMITTER-NAME
78-AUD-RET-INVALID-PROPERTY-NAME

Comments:

CBL_AUDIT_EMITTER_PROPERTY_SET is used to set a named property value for the emitter with name emitter-name. If a property with the same name already exists for the emitter, its value will be replaced with the new value.

Examples:

Set two property values associated with the "AUDITFILE" emitter: one a null-terminated string value, one an integer value.

copy "mfaudit.cpy ".

01 emitter-name    pic x(10) value "AUDITFILE".
01 flags           pic x(4) comp-5.
01 prop-integer    pic x(4) comp-5.
01 prop-string     pic x(100).
...
compute flags = 78-AUD-FLAG-PROP-STRING-VALUE b-or
                78-AUD-FLAG-PROP-NULL-TERM
move "xxx" & x"00" to prop-string

call "CBL_AUDIT_EMITTER_PROPERTY_SET" using
                                    by value flags
                                    by reference emitter-name
                                    by reference "location "
                                    by reference prop-string
...
compute prop-flags = 78-AUD-FLAG-PROP-INT-VALUE
move 10 to prop-integer

call "CBL_AUDIT_EMITTER_PROPERTY_GET" using
                                    by value flags
                                    by reference emitter-name
                                    by reference "collectionsize "
                                    by reference prop-integer
...
Parent topic: Audit Event Consolidator APIs


Audit File Processing APIs

The following Audit File Processing APIs are available:

  • CBL_AUDIT_FILE_CLOSE
    Close an audit file.
  • CBL_AUDIT_FILE_OPEN
    Open an audit file.
  • CBL_AUDIT_FILE_READ
    Read a record from an audit file.
  • cobaudit_file_read
    Read a record from an audit file.
Parent topic: Audit Manager APIs


CBL_AUDIT_FILE_CLOSE

Syntax:

call "CBL_AUDIT_FILE_CLOSE" using by value     flags
                                  by value     auditfile-handle
                                     returning status-code

Parameters:

 | Typedef | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
auditfile-handle | cblt-pointer | pointer

On Entry:

Control flags

Bit | Value | Meaning
0 | 0 | Close all files associated with the handle
 | 1 | Close the current file associated with the handle (use when processing a file collection).
1 | 0 | Do not set 'dumped' flag
 | 1 | Set 'dumped' flag
2-31 |  | Reserved for future use (must be 0)
auditfile-handle
Audit handle returned by the CBL_AUDIT_FILE_OPEN API.

On Exit:

Nothing

Return Codes:

78-AUD-RET-SUCCESS
78-AUD-RET-INVALID-HANDLE
78-AUD-RET-FILE-NOT-DUMPED

Comments:

CBL_AUDIT_FILE_CLOSE() is used to close the audit file, or audit file collection, identified by the auditfile-handle parameter. The flags parameter can be used to control whether or not the file, or files if an audit file collection is associated with the handle, is marked as being 'dumped'. Once a file is marked as 'dumped', it can be reused by the audit event consolidator process.

Examples:

copy "mfaudit.cpy ".

01 auditfile-handle  pic x(4) comp-5.
01 flags             pic x(4) comp-5.
...
compute flags = 78-AUDITFILE-FLAG-CLOSE-CURRENT b-or
                78-AUDITFILE-FLAG-CLOSE-DUMPED

call "CBL_AUDIT_FILE_CLOSE" using by value flags
                                  by value auditfile-handle
...
Parent topic: Audit File Processing APIs


CBL_AUDIT_FILE_OPEN

Syntax:

call "CBL_AUDIT_FILE_OPEN" using by value     flags
                                 by reference auditfile-handle
                                 by reference auditfile-name
                                    returning status-code

Parameters:

 | Typedef | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
auditfile-handle | cblt-pointer | pointer
auditfile-name | pic x(n) | pic x(n)

On Entry:

flags
Bit | Value | Meaning
0 | 0 | Open the specified audit file
1 | Open the audit file collection for which the specified file is a member
1 | 0 | auditfile-name is space-terminated
1 | auditfile-name is null-terminated
2-31 | Reserved for future use (must be 0)

On Exit:

auditfile-handle Audit handle to be specified to the CBL_AUDIT_FILE_READ and CBL_AUDIT_FILE_CLOSE APIs.

Return Codes:

78-AUD-RET-SUCCESS
78-AUD-RET-NOT-ENOUGH-MEMORY
78-AUD-RET-FILE-NOT-EXIST
78-AUD-RET-FILE-NOT-AVAILABLE
78-AUD-RET-FILE-INVALID-FORMAT
78-AUD-RET-FILE-INVALID-NAME

Comments:

CBL_AUDIT_FILE_OPEN() is used to open an audit file, or audit file collection. Only files that are available for dumping will be opened by this API (i.e. files in a collection which are marked as 'dumped' or 'active' will not be opened).

Examples:

copy "mfaudit.cpy ".

01 auditfile-handle  pic x(4) comp-5.
01 auditfile-name    pic x(32)
                     value "mfaudit.nwb-cpjdell.aud_1" & x"00".
01 flags             pic x(4) comp-5.
...
compute flags = 78-AUDITFILE-FLAG-OPEN-COLLECTION b-or
                78-AUDITFILE-FLAG-OPEN-NAME-NULL-TERM

call "CBL_AUDIT_FILE_OPEN" using by value flags
                                 by reference auditfile-handle
                                 by reference auditfile-name
      ...
Parent topic: Audit File Processing APIs


CBL_AUDIT_FILE_READ

Syntax:

call "CBL_AUDIT_FILE_READ" using by value     flags
                                 by value     auditfile-handle
                                 by reference auditfile-record
                                    returning status-code

Parameters:

 | Typedef | Picture
flags | cblt-x4-comp5 | pic x(4) comp-5
auditfile-handle | cblt-pointer | pointer
auditfile-record | cblt-aud-record | Group containing
cblte-audrec-version | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-flags | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-pid-len | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-tid-len | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-pid-32 | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-pid-64 | cblt-x8-comp5 | pic x(8) comp-5 redefines cblte-audrec-pid-32
cblte-audrec-tid-32 | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-tid-64 | cblt-x8-comp5 | pic x(8) comp-5 redefines cblte-audrec-tid-32
cblte-audrec-event-id | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-event-category | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-data-count | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-appname-len | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-cmdline-len | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-os-name-len | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-mc-name-len | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-sys-name-len | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-comp-name-len | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-encoded-time | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-hour | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-minute | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-second | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-millisecond | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-encoded-date | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-year | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-month | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-day | cblt-x4-comp5 | pic x(4) comp-5
cblte-audrec-reserved1 | cblt-x4-comp5 | pic x(4) comp-5 occurs 7
cblte-audrec-appname | cblt-pointer | pointer
cblte-audrec-cmdline | cblt-pointer | pointer
cblte-audrec-os-name | cblt-pointer | pointer
cblte-audrec-mc-name | cblt-pointer | pointer
cblte-audrec-sys-name | cblt-pointer | pointer
cblte-audrec-comp-name | cblt-pointer | pointer
cblte-audrec-event-len | cblt-pointer | pointer
cblte-audrec-event-type | cblt-pointer | pointer
cblte-audrec-event-data | cblt-pointer | pointer
cblte-audrec-reserved2 | cblt-pointer | pointer occurs 7

On Entry:

flags
Bit | Value | Meaning
0-31 | Reserved for future use (must be 0)
Auditfile-handle
Audit handle returned by the CBL_AUDIT_FILE_OPEN API.

On Exit:

cblte-audevt-version
Structure version
cblte-audevt-flags
Control flags
cblte-audrec-pid-len
Length of process identifier (4 or 8)
cblte-audrec-tid-len
Length of thread identifier (4 or 8)
cblte-audrec-pid-32
4-byte process identifier
cblte-audrec-pid-64
8-byte process identifier
cblte-audrec-tid-32
4-byte thread identifier
cblte-audrec-tid-64
8-byte thread identfier
cblte-audrec-event-id
Component specific audit event identifier
cblte-audrec-category
Audit event category
Value | Category
0 | Unknown
1 | Audit Facility
2 | System
3 | Security API request check
4 | Security API request define
5 | Security API request other
6 | Security API result allow
7 | Security API result deny
8 | Security API result error
9 | Security API result success
cblte-audrec-data-count
Number of audit data items. Indicates the number of items in the cblte-audrec-event-len, cblte-audrec-event-type and cblte-audrec-event-data arrays
cblte-audrec-appname-len
Length of application name
cblte-audrec-cmdline-len
Length of command line
cblte-audrec-os-name-len
Length of operating system name
cblte-audrec-mc-name-len
Length of computer/machine name
cblte-audrec-sys-name-len
Length of system name
cblte-audrec-comp-name-len
Length of component name
cblte-audrec-encoded-time
Encoded time of event
cblte-audrec-hour
Decoded hour
cblte-audrec-minute
Decoded minute
cblte-audrec-second
Decoded second
cblte-audrec-millisecond
Decoded millisecond
cblte-audrec-encoded-date
Encoded date of event
cblte-audrec-year
Decoded year
cblte-audrec-month
Decoded month
cblte-audrec-day
Decoded day
cblte-audrec-appname
Pointer to null-terminated name of application that generated audit event
cblte-audrec-cmdline
Pointer to null-terminated command-line of application that generated audit event
cblte-audrec-os-name
Pointer to null-terminated name of operating system that generated audit event
cblte-audrec-mc-name
Pointer to null-terminated name of computer that generated audit event
cblte-audrec-sys-name
Pointer to null-terminated name of system that generated audit event
cblte-audrec-comp-name
Pointer to null-terminated name of component that generated audit event
cblte-audrec-event-len
Pointer to array of 4-byte comp-5 items. Each array element indicates the length of the corresponding audit data item. Will be NULL if cblte-audrec-data-count is 0
cblte-audrec-event-type
Pointer to array of 4-byte comp-5 items. Each array element indicates the type of the corresponding audit data item in the cblte-audrec-event-data array. Will be NULL if cblte-audrec-data-count is 0.
Value | Type
0 | Binary
1 | Text (local encoding)
2 | Address
3 | COMP-5
4 | COMP-X
5 | UTF8
6 | Signed COMP-5
7 | Signed COMP-X

Any value other than the ones specified above will be treated as type 0 (binary).

cblte-audrec-event-data
Pointer to array of pointer items. Each array element addresses an audit data item of the type and length indicated by the corresponding element in the cblte-audrec-event-type and cblte-audrec-event-len arrays respectively. Will be NULL if cblte-audrec-data-count is 0.

Return Codes:

78-AUD-RET-SUCCESS
78-AUD-RET-FAILURE
78-AUD-RET-NOT-ENOUGH-MEMORY
78-AUD-RET-INVALID-HANDLE
78-AUD-RET-FILE-INVALID-FORMAT
78-AUD-RET-FILE-EOF
78-AUD-RET-FILE-NO-MORE-RECORDS

Comments:

CBL_AUDIT_FILE_READ() is used to return the next audit record from the file(s) associated with the current handle.

The function will return 78-AUD-RET-FILE-EOF when attempting to read past the last record in a file for the first time. The next attempt to read past the last record will either return the first record of the next file in the collection if a collection has been opened and another file is available, or 78-AUD-RET-FILE-NO-MORE-RECORDS.

Examples:

copy "mfaudit.cpy ".

01 auditfile-handle  pic x(4) comp-5.
01 auditfile-record  cblt-aud-record.
01 flags             pic x(4) comp-5.
...
compute flags = 0

call "CBL_AUDIT_FILE_READ" using by value flags
                                 by value auditfile-handle
                                 by reference auditfile-record
...
Parent topic: Audit File Processing APIs


cobaudit_file_read

Syntax:

cobrtncode_t cobaudit_file_read(cobuns32_t       flags,
                                cbl_os_pointer_t auditfile_handle,
                                AUDIT_RECORD     *auditfile_record)

On Entry:

Control flags
Bit | Value | Meaning
0-31 | Reserved for future use (must be 0)
auditfile-handle
Audit handle returned by the CBL_AUDIT_FILE_OPEN API.
auditfile_record
Audit event structure
version | Structure version (must be 0)
flags | Control flags (must be 0)

On Exit:

Auditfile_record

Audit event structure

version
Structure version
flags
Control flags
process_id_len
Length of process identifier (4 or 8)
thread_id_len
Length of thread identifier (4 or 8)
p.process_id_32
4-byte process identifier
p.process_id_64
8-byte process identifier
t.thread_id_32
4-byte thread identifier
t.thread_id_64
8-byte thread identfier
event_id
Component specific audit event identifier
event_category
Audit event category
Value | Category
0 | Unknown
1 | Audit Facility
2 | System
3 | Security API request check
4 | Security API request define
5 | Security API request other
6 | Security API result allow
7 | Security API result deny
8 | Security API result error
9 | Security API result success
data_count
Number of audit data items. Indicates the number of items in the event_len, event_type and event_data arrays
appname_len
Length of application name
cmdline_len
Length of command line
os_name_len
Length of operating system name
mc_name_len
Length of computer/machine name
sys_name_len
Length of system name
comp_name_len
Length of component name
time
Encoded time of event
hour
Decoded hour
minute
Decoded minute
second
Decoded second
millisecond
Decoded millisecond
date
Encoded date of event
year
Decoded year
month
Decoded month
day
Decoded day
appname
Pointer to null-terminated name of application that generated audit event
cmdline
Pointer to null-terminated command-line of application that generated audit event
os_name
Pointer to null-terminated name of operating system that generated audit event
mc_name
Pointer to null-terminated name of computer that generated audit event
sys_name
Pointer to null-terminated name of system that generated audit event
comp_name
Pointer to null-terminated name of component that generated audit event
event_len
Pointer to array of 4-byte comp-5 items. Each array element indicates the length of the corresponding audit data item. Will be NULL if data-count is 0
event_type
Pointer to array of 4-byte comp-5 items. Each array element indicates the type of the corresponding audit data item in the event_data array. Will be NULL if data_count is 0.

Any value other than the ones specified above will be treated as type 0 (binary).

Value | Type
0 | Binary
1 | Text (local encoding)
2 | Address
3 | COMP-5
4 | COMP-X
5 | UTF8
6 | Signed COMP-5
7 | Signed COMP-X
event_data
Pointer to array of pointer items. Each array element addresses an audit data item of the type and length indicated by the corresponding element in the event_type and event_len arrays respectively. Will be NULL if data_count is 0.

Return Codes:

AUDIT_RET_SUCCESS
AUDIT_RET_FAILURE
AUDIT_RET_INVALID_HANDLE
AUDIT_RET_NOT_ENOUGH_MEMORY
AUDIT_RET_FILE_INVALID_FORMAT
AUDIT_RET_FILE_EOF
AUDIT_RET_FILE_NO_MORE_RECORDS

Comments:

cobaudit_event() is intended for use by C programs. It is used to return the next audit record from the file(s) associated with the current handle.

The function will return AUDIT_RET_FILE_EOF when attempting to read past the last record in a file for the first time. The next attempt to read past the last record will either return the first record of the next file in the collection if a collection has been opened and another file is available, or AUDIT_RET_FILE_NO_MORE_RECORDS.

Parent topic: Audit File Processing APIs


Audit Emitter Interface

The following Audit Emitter Interface information and APIs are available:

  • Audit Emitter Interface Overview
  • PFI_AUD_EMITTER_DEINIT
  • PFI_AUD_EMITTER_INIT
  • PFV_AUD_EMITTER_NOTIFY
  • PFI_AUD_EMITTER_OUTPUT
Parent topic: Audit Manager APIs


Audit Emitter Interface Overview

Each emitter configured for use by the Audit Manager, whether well-known or dynamically loaded, will conform to the interface outlined in this section.

A dynamically loaded emitter is loaded by the Audit Manager using the program name specified by an mfaudit.emitter configuration file entry (see mfaudit.emitter.emitter-name).

Once loaded, the GET_AUDIT_EMITTER_FUNCS entry point of the loaded program is invoked to retrieve the address of a function pointer table (see Structures and Typedefs for AUDIT_EMITTER_FUNCS). This table contains pointers for a set of functions responsible for initialising the emitter, deinitialising the emitter, outputting an audit event, and handling notifications of emitter property changes. The example below shows how the main entry point for an emitter would typically be coded to return an AUDIT_EMITTER_FUNCS structure:

....
#include "mfaudit.h"
....
static int audit_emitter_deinit(cobuns32_t flags,
                                void       *emitter_data);

static int audit_emitter_init(cobuns32_t          flags,
                              const cobuns8_t     *emitter_name,
                              AUDIT_EMITTER_EVENT *audit_event,
                              void                **emitter_data);

static void audit_emitter_notify(cobuns32_t notif_type,
                                 void       *notif_buf,
                                 void       *emitter_data);

static int audit_emitter_output(cobuns32_t          flags,
                                AUDIT_EMITTER_EVENT *audit_event,
                                Void                *emitter_data);

static AUDIT_EMITTER_FUNCS audit_emitter_funcs =
{
    0,                         /* Version of structure format      */
    0,                         /* Reserved for future use          */
    audit_emitter_init,        /* Function to initialise the       */
                               /* emitter                          */
    audit_emitter_deinit,      /* Function to deinitialise the     */
                               /* emitter                          */
    audit_emitter_output,      /* Function to output a trace event */
    audit_emitter_notify,      /* Function to handle notifications */
                               /* of emitter config changes        */
};
....

AUDIT_EMITTER_FUNCS *
GET_AUDIT_EMITTER_FUNCS()
{
    return &audit_emitter_funcs;
}
....

Emitter initialisation (the invocation of the fn_init AUDIT_EMITTER_FUNCS function) is deferred by the Audit Manager until just prior to the first audit event needing to be output. During emitter initialisation the emitter would typically invoke the CBL_AUDIT_EMITTER_PROPERTY_GET API to pick up the value associated with each of its known properties.

Emitter de-initialisation (the invocation of the fn_deinit AUDIT_EMITTER_FUNCS function) occurs during Audit Manager de-initialisation. During emitter de-initialisation the emitter would release any resources it had acquired during any previous invocations.

The outputting of an audit event (the invocation of the fn_output AUDIT_EMITTER_FUNCS function) occurs when a component invokes the CBL_AUDIT_EVENT API (see CBL_AUDIT_EVENT() - Output an Audit Event).

The emitter is notified (the invocation of the fn_notify AUDIT_EMITTER_FUNCS function) of each configuration change (e.g. property value change) that occurs for it after it has been initialised.

Parent topic: Audit Emitter Interface


PFI_AUD_EMITTER_DEINIT

Syntax:

typedef int (*PFI_AUD_EMITTER_DEINIT)(cobuns32_t flags,
                                      void       *emitter_data);

On Entry:

flags
Reserved for future use (must be 0)
emitter_data
Emitter-specific data

On Exit:

Nothing

Return Codes:

EMITTER_DEINIT_SUCCESS | 0
EMITTER_DEINIT_FAIL | -1

Comments:

This function is invoked by the audit facility during its deinitialisation to allow the emitter to release any resources it had acquired during any previous invocations.

Parent topic: Audit Emitter Interface


PFI_AUD_EMITTER_INIT

Syntax:

typedef int (*PFI_AUD_EMITTER_INIT)(cobuns32_t          flags,
                                    const cobuns8_t     *emitter_name,
                                    AUDIT_EMITTER_EVENT *audit_event,
                                    void                **emitter_data);

On Entry:

flags
Reserved for future use (must be 0)
emitter_name
Name of emitter being initialised
audit_event
Details of the first audit event to be output. (N.B. the event is not expected to be emitted during initialisation, but the information provided may be useful for file header creation (e.g. date/time))

On Exit:

emitter_data
Emitter-specific data

Return Codes:

EMITTER_INIT_SUCCESS | 0
EMITTER_INIT_FAIL | -1

Comments:

This function is invoked by the audit facility to perform the emitter's initialisation. Initialisation would typically involve the interrogation of the audit facility for the emitter's configuration properties via calls to the CBL_AUDIT_EMITTER_PROPERTY_GET() API (see CBL_AUDIT_EMITTER_PROPERTY_GET() - Get an Audit Emitter Property Value).

Emitter initialisation is deferred by the audit facility until just prior to the first audit event needing to be output.

Parent topic: Audit Emitter Interface


PFV_AUD_EMITTER_NOTIFY

Syntax:

typedef void (*PFV_AUD_EMITTER_NOTIFY)(cobuns32_t notif_type,
                                       void       *notif_buf,
                                       void       *emitter_data);

On Entry:

notif_type
Notification type:
0: Property value change has occurred. notif_buf is a pointer to an EMITTER_NOTIF_PROP_CHANGE structure.
notif_buf
Notification buffer. The contents of this buffer are dependent upon notif_type.
emitter_data
Emitter-specific data

On Exit:

Nothing

Return Codes:

Nothing

Comments:

This function is invoked by the audit facility for each configuration change that occurs for the emitter after it has been initialised.

Parent topic: Audit Emitter Interface


PFI_AUD_EMITTER_OUTPUT

Syntax:

typedef int (*PFI_AUD_EMITTER_OUTPUT)(cobuns32_t   flags,
                                      AUDIT_EMITTER_EVENT *audit_event,
                                      void		    *emitter_data);

On Entry:

flags | Reserved for future use (must be 0)
audit_event | Audit event to output
emitter_data | Emitter-specific data

On Exit:

Nothing

Return Codes:

EMITTER_OUTPUT_SUCCESS | 0
EMITTER_OUTPUT_FAIL | -1

Comments:

This function is invoked by the audit facility to output an audit event to an output destination.

Parent topic: Audit Emitter Interface


Structure and Typedefs

The following Structure and Typedefs APIs are available:

  • Structures and Typedefs for AUDIT_EMITTER_FUNCS
  • Structures and Typedefs - AUDIT_EVENT
  • Structures and Typedefs - AUDIT_EMITTER_EVENT
  • Structures and Typedefs - AUDIT_RECORD
  • Structures and Typedefs - EMITTER_NOTIF_PROP_CHANGE
Parent topic: Audit Manager APIs


Structures and Typedefs for AUDIT_EMITTER_FUNCS

typedef struct audit_event
{
    cobuns32_t                version;               Version of structure format
    cobuns32_t                reserved;	             Reserved for future use
    PFI_AUD_EMITTER_INIT      fn_init;               Function to initialise the emitter
    PFI_AUD_EMITTER_DEINIT    fn_deinit;             Function to deinitialise the emitter
    PFI_AUD_EMITTER_OUTPUT    fn_output;             Function to output a trace event
    PFV_AUD_EMITTER_NOTIFY    fn_notify;             Function to handle notifications of emitter config changes
    PFI                       fn_reserved[4];        Reserved for future use
} AUDIT_EMITTER_FUNCS;

Version types (version):

    #define AUDIT_EMITTER_FUNCS_VERSION	0
Parent topic: Structure and Typedefs


Structures and Typedefs - AUDIT_EVENT

typedef struct audit_event
{
    cobuns32_t	version;	Version of structure format
    cobuns32_t	flags;	Control flags
    cobuns32_t	event_id;	Audit event identifier
    cobuns32_t	event_category;	Audit event category
    cobuns32_t	data_count;	Number of audit data items
    cobuns32_t	reserved1[7];	Reserved for future use
    cobuns32_t	*event_len;	Audit data item lengths
    cobuns32_t	*event_type;	Audit data item types
    void	*event_data;	Audit data items
    void	*reserved2[7];	Reserved for future use
}AUDIT_EVENT;

Version types (version):

    #define AUDIT_EVENT_VERSION	0

Control flags (flags):

    #define AUDIT_EVENT_FLAGS_NONE	0x00000000

Audit event categories (event_category):

    #define AUDIT_EVENT_CATEGORY_UNKNOWN	0

Audit data item types (event_type):

    #define AUDIT_EVENT_TYPE_BINARY     0
    #define AUDIT_EVENT_TYPE_TEXT       1
    #define AUDIT_EVENT_TYPE_ADDRESS    2
    #define AUDIT_EVENT_TYPE_COMP5      3
    #define AUDIT_EVENT_TYPE_COMPX      4
    #define AUDIT_EVENT_TYPE_UTF8       5
    #define AUDIT_EVENT_TYPE_COMP5S     6
    #define AUDIT_EVENT_TYPE_COMPXS     7
Parent topic: Structure and Typedefs


Structures and Typedefs - AUDIT_EMITTER_EVENT

typedef struct audit_emitter_event
{
    cobuns32_t          version;          Version of structure format
    cobuns32_t          flags;            Control flags
    cobuns32_t          date;             Encoded date
    cobuns32_t          time;             Encoded time
    cobuns32_t          process_id_len;   Length of process identifier
    cobuns32_t          thread_id_len;    Length of thread identifier
    cobuns32_t          comp_id;          Component identifier
    cobuns32_t          event_id;         Audit event identifier
    cobuns32_t          event_category;   Audit event category
    cobuns32_t          data_count;       Number of audit data items
    cobuns32_t          reserved1[6];     Reserved for future use
    const cobuns8_t     *process_id;      Process identifier
    const cobuns8_t     *thread_id;       Thread identifier
    const cobuns8_t     *appname;         Null-terminated application name
    const cobuns8_t     *cmdline;         Null-terminated process cmd line
    const cobuns8_t     *os_name;         Null-terminated operating system name
    const cobuns8_t     *mc_name;         Null-terminated machine name
    const cobuns8_t     *sys_name;        Null-terminated system name
    const cobuns8_t     *comp_name;       Null-terminated component name
    const cobuns8_t     *auditmgr_name;   Null-terminated auditmgr instance name
    const cobuns32_t    *event_len;       Audit data item lengths
    const cobuns32_t    *event_type;      Audit data item types
    const void          **event_data;     Audit data items
    void                *reserved2[7];    Reserved for future use
}AUDIT_EMITTER_EVENT;

Version types (version):

    #define AUDIT_EMITTER_VERSION	0

Control flags (flags):

    #define AUDIT_EMITTER_FLAGS_NONE         0x00000000
    #define AUDIT_EMITTER_FLAGS_ARRAY_DATA   0x00000002

Event categories (event_category):

    #define AUDIT_EVENT_CATEGORY_UNKNOWN             0
    #define AUDIT_EVENT_CATEGORY_AUDIT_FACILITY      1
    #define AUDIT_EVENT_CATEGORY_SYSTEM              2
    #define AUDIT_EVENT_CATEGORY_SEC_API_REQ_CHECK   3
    #define AUDIT_EVENT_CATEGORY_SEC_API_REQ_DEFINE  4
    #define AUDIT_EVENT_CATEGORY_SEC_API_REQ_OTHER   5
    #define AUDIT_EVENT_CATEGORY_SEC_API_RES_ALLOW   6
    #define AUDIT_EVENT_CATEGORY_SEC_API_RES_DENY    7
    #define AUDIT_EVENT_CATEGORY_SEC_API_RES_ERROR   8
    #define AUDIT_EVENT_CATEGORY_SEC_API_RES_SUCCESS 9

Audit data item types (event_type):

    #define AUDIT_EMITTER_TYPE_BINARY     0
    #define AUDIT_EMITTER_TYPE_TEXT       1
    #define AUDIT_EMITTER_TYPE_ADDRESS    2
    #define AUDIT_EMITTER_TYPE_COMP5      3
    #define AUDIT_EMITTER_TYPE_COMPX      4
    #define AUDIT_EMITTER_TYPE_UTF8       5
    #define AUDIT_EMITTER_TYPE_COMP5S     6
    #define AUDIT_EMITTER_TYPE_COMPXS     7
Parent topic: Structure and Typedefs


Structures and Typedefs - AUDIT_RECORD

typedef struct audit_record
{
    cobuns32_t         version;                 Version of structure format
    cobuns32_t         flags;                   Control flags
    cobuns32_t         process_id_len;          Process identifier length (4 or 8 bytes)
    cobuns32_t         thread_id_len;           Thread identifier length (4 or 8 bytes)

    union
    {
    cobuns32_t            process_id_32;           Process identifier (32-bit)
    cobuns64_t            process_id_64;           Process identifier (64-bit)
    }p;

    union
    {
    cobuns32_t            thread_id_32;            Thread identifier (32-bit)
    cobuns64_t            thread_id_64;            Thread identifier (64-bit)
    }t;

    cobuns32_t         event_id;                Audit event identifier
    cobuns32_t         event_category;          Audit event category
    cobuns32_t         data_count;              Number of audit data items
    cobuns32_t         appname_len;             Application name length
    cobuns32_t         cmdline_len;             Process command line length
    cobuns32_t         os_name_len;             Operating system name length
    cobuns32_t         mc_name_len;             Machine name length
    cobuns32_t         sys_name_len;            System name length
    cobuns32_t         comp_name_len;           Component name length

    cobuns32_t         time;                    Encoded time
    cobuns32_t         hour;                    Decoded hour
    cobuns32_t         minute;                  Decoded minute
    cobuns32_t         second;                  Decoded second
    cobuns32_t         millisecond;             Decoded millisecond
    cobuns32_t         date;                    Encoded date
    cobuns32_t         year;                    Decoded year
    cobuns32_t         month;                   Decoded month
    cobuns32_t         day;                     Decoded day
    cobuns32_t         reserved1[7];            Reserved for future use

    const cobuns8_t    *appname;                Null-terminated application name
    const cobuns8_t    *cmdline;                Null-terminated process command line
    const cobuns8_t    *os_name;                Operating system name
    const cobuns8_t    *mc_name;                Machine name
    const cobuns8_t    *sys_name;               Null-terminated system name
    const cobuns8_t    *comp_name;              Null-terminated component name
    cobuns32_t         *event_len;              Audit data item lengths
    cobuns32_t         *event_type;             Audit data item types
    void               *event_data;             Audit data items
    void               *reserved2[7];           Reserved for future use
}AUDIT_RECORD;

Version types (version):

    #define AUDIT_RECORD_VERSION	0

Event categories (event_category):

    #define AUDIT_EVENT_CATEGORY_UNKNOWN             0
    #define AUDIT_EVENT_CATEGORY_AUDIT_FACILITY      1
    #define AUDIT_EVENT_CATEGORY_SYSTEM              2
    #define AUDIT_EVENT_CATEGORY_SEC_API_REQ_CHECK   3
    #define AUDIT_EVENT_CATEGORY_SEC_API_REQ_DEFINE  4
    #define AUDIT_EVENT_CATEGORY_SEC_API_REQ_OTHER   5
    #define AUDIT_EVENT_CATEGORY_SEC_API_RES_ALLOW   6
    #define AUDIT_EVENT_CATEGORY_SEC_API_RES_DENY    7
    #define AUDIT_EVENT_CATEGORY_SEC_API_RES_ERROR   8
    #define AUDIT_EVENT_CATEGORY_SEC_API_RES_SUCCESS 9

Audit data item types (event_type):

    #define AUDIT_EVENT_TYPE_BINARY    0
    #define AUDIT_EVENT_TYPE_TEXT      1
    #define AUDIT_EVENT_TYPE_ADDRESS   2
    #define AUDIT_EVENT_TYPE_COMP5     3
    #define AUDIT_EVENT_TYPE_COMPX     4
    #define AUDIT_EVENT_TYPE_UTF8      5
    #define AUDIT_EVENT_TYPE_COMP5S    6
    #define AUDIT_EVENT_TYPE_COMPXS    7
Parent topic: Structure and Typedefs


Structures and Typedefs - EMITTER_NOTIF_PROP_CHANGE

typedef struct emitter_notif_prop_change
{
    cobuns32_t           version;  Version of structure format
    cobuns32_t           flags;    Control flags
    cobuns32_t           namelen;  Length of property name
    cobuns32_t           vallen;   Length of value
    cobuns32_t           valint;   Integer representation of value
    cobuns8_t            *name;    Property name
    cobuns8_t            *value;   Property value
}EMITTER_NOTIF_PROP_CHANGE;

Version types (version):

    #define EMITTER_PROP_CHANGE_VERSION	0

Control flags (flags):

    #define EMITTER_PROP_CHANGE_FLAGS_NONE         0x00000000
    #define EMITTER_PROP_CHANGE_FLAGS_VAL_INTEGER  0x00000001
Parent topic: Structure and Typedefs


Securing Communications

Note: Before you attempt to secure communications, it is important that you understand PKI and SSL concepts. The SSL and PKI Technology Primer contains information on these concepts.
  • Introduction to Securing Communications
  • Configuring Secure Communications for Client Applications
  • Setting Up Secure Communications
  • Troubleshooting a Secure Connection
  • Using the Demonstration Certificate Authority
  • Tutorial: Requesting and Issuing Server Certificates
  • Tutorial: Configuring SSL Security in the Server
  • Information on OpenSSL
  • SSL and PKI Technology Primer
    The topics in this section describe the basics of SSL and PKI technology, and how they work together to secure communications.
  • Secure Communications (SSL) Legal Information
Parent topic: Enterprise Server Security


Introduction to Securing Communications

You can enable secure communication between Micro Focus systems and clients who access those systems. This is done using Secure Sockets Layer (SSL) encryption. With secure communications, all communications between a client and a server are encrypted.

You typically use PKI certificates issued from a trusted Certifying Authority (CA) to secure your installation.

Web browser access is secured with the HTTPS web browser protocol. This mechanism secures web access, for example the Enterprise Server configuration user interface.

You can use the demonstration CA software to generate certificates and test your secure communications setup before using certificates issued by a trusted CA. The demonstration CA software is based on the OpenSSL software.

You can use these to familiarize yourself with the setup without the need to obtain cerrtificates from a trusted CA. The online help includes a tutorial that describes the process of using the DemoCA to secure your system.

Parent topic: Securing Communications


Configuring Secure Communications for Client Applications

A client application is an application that communicates with Enterprise Server Enterprise. You can require a certificate from any clients that communicate with your server. This sets up SSL links for peer-to-peer communication (as opposed to client/server communication).

In order to communicate securely, a client application needs access to the root certificates of any trusted CAs that the server uses. The trusted CAs are those who signed the certificates of the servers you are communicating with securely.

  • Securing Peer to Peer Communications
  • Installing a Client Certificate for Enterprise Server
  • Adding a CA Root Certificate to your Client Application
  • Installing a CA Root Certificate in a Client Browser
  • Installing server certificates for secure communication
Parent topic: Securing Communications


Securing Peer to Peer Communications

You can configure that any clients that communicate with your server must supply a certificate. This sets up SSL links for peer-to-peer communication (as opposed to client/server communication)

To request or require a certificate from clients who communicate with your server:

  1. Connect to ES Admin, for example by entering http://localhost:86 in your Web browser.
  2. Select the enterprise server you want, such as ESDEMO. Stop it if it is started, and then click Edit.
  3. Go to the Listeners page.
  4. Select the HTTPS listener you want (if you can't see the one you want, set the Process filter to All), and click Edit .
  5. Check Secure Sockets Layer.
  6. Click SSL Options and then:
    • Check the appropriate option to request or require client certificates.
    • Enter the CA root certificate of the CA who signed the client cerificate.

If the CA who signed the client's certificate is not trusted, communication is prevented. If you want to trust the signing CA, you can add it to your trusted CAs by updating the relevant certificates options in your browser.

Parent topic: Configuring Secure Communications for Client Applications
Parent topic: Secure Communications (SSL)
Previous topic: Adding a CA Root Certificate to your Client Application
Next topic: Locating Certificate Problems


Installing a Client Certificate for Enterprise Server

On client systems such as COBOL Web Services clients, and clients that use client/server binding, ES/MSS Remote Job Entry, and COBOL XML I/O, you need to set client information in a file, as follows:

To set up client certificate, key file and pass phrase information in a file:

  1. On the Enterprise Server machine, create the file mf-client.dat in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory if the file doesn't already exist.
  2. Add an [SSL] section to this file and set parameters for the root certificate, the client certificate, the client key file, and the client key file passphrase, as follows:
         [SSL]
    root=/path/to/root/cert.type
    certificate=/path/to/client/cert.type
    key=/path/to/client/keyfile.type
    passphrase=keyfile passphrase

    where:

    • root defaults to ssldir/private/CArootcert.pem, where ssldir is the directory where Security Pack is installed, and is by default %ProgramFiles(x86)%\Micro Focus\DemoCA. To find out the directory, look up the registry key HKEY_LOCAL_MACHINE\Software\Micro Focus\DemoCA\1.0\Setup\DemoCAFolder .
    • If certificate isn't specified, no client-side certificate is used
Note:
  • If you use a client certificate, the pass phrase for the key file appears in plain text in the mf-client.dat file. For security purposes, you should make this file readable only by the user or users who run applications that use this certificate.
  • Instead of mf-client.dat, you can create a file of any name or location, but you must identify it using the MFC_CONFIG environment variable.
Parent topic: Configuring Secure Communications for Client Applications
Parent topic: Secure Communications (SSL)
Previous topic: Installing server certificates for secure communication
Next topic: Installing a CA Root Certificate in a Client Browser


Adding a CA Root Certificate to your Client Application

If you have written a client application that communicates with server applications such as Enterprise Server, the client application needs access to the root certificates of any trusted CAs. The trusted CAs are those who signed the certificates of the servers you are communicating with securely.

This pack includes a collection of well-known CA root certificates plus the self-signed certificate of the demonstration CA. These root certificates are contained in a single file called CARootCerts.pem, found in %ProgramFiles(x86)%\Micro Focus\DemoCA by default. This file is not protected by a pass phrase, so you can modify it. You need to add other CA root certificates to the CA root certificate file, if your client application communicates with servers whose certificates are signed by CAs whose certificates are not already in the file.

To add a CA root certificate to the root certificate file:

  1. Convert the new certificate to the same format as the certificates in the file, which in this case is PEM format with DER content encoding. Use openssl to do this. For example, to convert a PKCS7 format file, such as IECert.p7b, to PEM format:
    openssl pkcs7 -inform DER -in IECert.p7b -text -print_certs -out IECert.pem
  2. Append the new certificates to the existing file CARootCerts.pem. For example:
    copy CARootCerts.pem+ IECert.pem NewCARootCerts.pem
Note: The CARootCerts.pem file is subject to being updated when a new version of the Micro Focus Security Pack is installed. If you add certificates to this file, you will need to repeat those additions when you update the Micro Focus Security Pack.
Parent topic: Configuring Secure Communications for Client Applications
Parent topic: Secure Communications (SSL)
Previous topic: Installing a CA Root Certificate in a Client Browser
Next topic: Securing Peer to Peer Communications


Installing a CA Root Certificate in a Client Browser

The root certificates of well-known trusted CAs are often installed with the client browser, so you might not need to install any. However, the security policy in your organization might restrict your access to the Web and might have removed the trusted CA root certificates. In this case you will need to install root certificates for the CAs that signed the server certificates of the servers you need to communicate with securely.

Note that the root certificate for the demonstration CA is not pre-installed, and so you need to install this certificate to enable you to use the demonstration CA.

CA root certificates can be specified as any of the following:

  • A single file containing a single certificate.
  • A single file containing multiple certificates. This file defines your trusted CAs (plus their chains if appropriate)
  • A directory containing PEM files that each contain a single certificate. These files are named with the hash value of the certificate content, using the hash.0 format. For example, you can display this hash value, using the command:
    openssl X509 -hash -in CARootcert.pem

    This produces the following output:

    1a584193
----BEGIN CERTIFICATE
....

    Where:

    • The number that is displayed before the certificate is the hash value of the certificate
    • The filename of the certificate would be 1a584193.0

To install a CA root certificate:

  1. In your browser, go to the options where you manage certificates. For example:
    • In Internet Explorer, click Tools > Internet Options > Content > Certificates. Go to the Trusted Root Certification Authorities tab.
    • In Mozilla Firefox, click Tools > Options > Advanced. Scroll down, click Manage Certificates and then click Authorities.
  2. Click Import and select the CA's root certificate.

    For the demonstration, select the self-signed certificate CARootCert.cer, which is in the private subdirectory of %ProgramFiles(x86)%\Micro Focus\DemoCA by default.

    Internet Explorer requires X509 certificates, in DER format, so only those are listed in the File Open field, and not the PEM format files. Mozilla Firefox can handle several types, so several are listed and you can install the PEM-format certificate.

  3. In Internet Explorer, use the Browse button to enter Trusted Root Certification Authorities in the Certificate Store field.

    In Mozilla Firefox, check Trust this CA to identify Web sites.

  4. Look down the list under Trusted Root Certification Authorities (for Internet Explorer) and Authorities (for Firefox). You'll see your Demo CA is now listed; look for its Common Name. If when you installed Micro Focus Security Pack you chose to use your computer DNS name as the DemoCA's Common Name, it will probably look an odd-one-out, because real CAs tend to give themselves user-friendly Common Names.
Parent topic: Configuring Secure Communications for Client Applications
Parent topic: Secure Communications (SSL)
Previous topic: Installing a Client Certificate for Enterprise Server
Next topic: Adding a CA Root Certificate to your Client Application


Installing server certificates for secure communication

In the role of administrator of Enterprise Server, you need to install the SSL server certificate so that remote client software and Web users can request it. Installing a certificate entails storing the certificate and key file in a folder accessible to the server software.

To install a server certificate:

  1. Connect to ES Admin, for example by entering http://localhost:86 in your Web browser.
  2. Select the enterprise server you want, such as ESDEMO. Stop it if it is started, and then click Edit.
  3. Go to the Listeners page.
  4. Select the HTTPS listener you want (if you can't see the one you want, set the Process filter to All), and click Edit .
  5. If Secure Sockets Layer is not checked, check it and configure this listener as a secure listener.
  6. Enter the filenames of your server certificate and private key in the Certificate and Keyfile fields. If these are not in the default directories, you also need to supply the paths to these files. For example:
    • ssldir/certs/srvcert.pem
    • ssldir/keys/srvkey.pem

    Where ssldir is the directory where Security Pack is installed, and is by default %ProgramFiles(x86)%\Micro Focus\DemoCA. To find out the directory, look up the registry key HKEY_LOCAL_MACHINE\Software\Micro Focus\DemoCA\1.0\Setup\DemoCAFolder.

  7. Click OK.
Parent topic: Configuring Secure Communications for Client Applications
Parent topic: Secure Communications (SSL)
Previous topic: To Enable Logging for Listener Startup
Next topic: Installing a Client Certificate for Enterprise Server


Setting Up Secure Communications

To set up secure communications, you need the following:

  • For machine on which the server operates, a certificate and a private key file for the server.

    Typically these are issued by a trusted Certifying Authority (CA). To set up secure communications, you need to know the path location where these files are stored.

  • The pass phrase for the server certificate and keyfile.
  • For machines that access the listener, the CA's root certificate.

    Root certificates for many trusted authorities are installed by default with many web browsers.

The process you use to set up secure communications for an Enterprise Server instance is outlined below:

  1. Install the certificate and a private key file on the machine running Enterprise Server, and note the path.
  2. For the Enterprise Server instance to configure, create a secure listener and configure it to use the key file that you installed.
  3. Start the server and the listener, and configure the private key file's pass phrases.

    You can set the certificate and keyfile pass phrases either in a configuration file, or you can enter them manually whenever you start the server.

  4. On machines that use the listener, if required, configure the CA root certificate.

Steps 2, 3, and 4 are described in detail in this help.

  • To enable secure communications with SSL
  • To configure an HTTPS listener
  • To Create a Secure Listener
  • To Start a Secure Listener and Set the Pass Phrase
  • To Configure the Pass Phrase in a File
Parent topic: Securing Communications


To enable secure communications with SSL

  1. Make sure the enterprise server you're going to use, for example ESDEMO, is stopped.
  2. Create and configure an HTTPS listener.
  3. If you want to keep your pass phrases in a file, add them to the file.
  4. Return to the Home page of ES Admin and start ESDEMO.
  5. Check that all the listeners have started, by looking on the Listeners page. If you entered the pass phrases using a file, you should find that the HTTPS listener has started like all the other listeners. If you didn't, then the status of the HTTPS listener is Start pending.
  6. If you didn't set the pass phrase using a file, set it now:
  7. Optionally, enable additional logging of listener startup for debugging purposes.
Parent topic: Setting Up Secure Communications
Parent topic: Secure Communications (SSL)
Next topic: To configure an HTTPS listener
Related information
To configure an HTTPS listener
To enable logging for listener startup


To configure an HTTPS listener

As a Web site owner or administrator of Enterprise Server, to ensure secure communcation using SSL, you create and configure an HTTPS listener, as follows:

  1. Connect to ES Admin, for example by entering http://localhost:86 in your Web browser. Make sure the enterprise server you're going to use, for example ESDEMO, is stopped.
  2. Go to the Listeners page and find your HTTPS listener. The status column should indicate "Start pending" and the Status Log column shouold show "Waiting for keyfile passphrase".
  3. Go to the listeners page, (click Edit > Listeners). Make sure the Process filter is set to All so you can see all the listeners.
  4. Click Add.
  5. Enter a name for the listerner.
  6. Change the Endpoint Address to *.443, which is the default for HTTPS.
  7. Check Secure Sockets Layer.
  8. Enter the filenames of your server certificate and private key in the Certificate and Keyfile fields. If these are not in the default directories, you also need to supply the paths to these files. For example:
    • ssldir\certs\srvcert.pem
    • ssldir\keys\srvkey.pem

    Where ssldir is the directory where Security Pack is installed, and is by default %ProgramFiles(x86)%\Micro Focus\DemoCA. To find out the directory, look up the registry key HKEY_LOCAL_MACHINE\Software\Micro Focus\DemoCA\1.0\Setup\DemoCAFolder.

  9. Specify that this will be an "HTTP echo" listener, which provides a simple response to HTTP requests. To do this, select Custom under Supported Conversation Type and enter http-echo in the field alongside.
  10. Click Add. On the listeners page, the new listener now has a padlock symbol to show that it uses SSL.
Parent topic: Setting Up Secure Communications
Parent topic: Secure Communications (SSL)
Previous topic: To enable secure communications with SSL
Next topic: To set a pass phrase


To Create a Secure Listener

For an Enterprise Server instance, you can create a secure listener, to encrypt the communications that the listener handles.

  1. On the Enterprise Server Administration screen, edit the server to which you want to add the secure listener.
  2. Select the Listeners tab, and next to the listener you want to secure, click Edit.
  3. In the Endpoint Options area, select the Secure Sockets Layer checkbox.

    The Certificate and the Keyfile fields become active.

  4. Enter the path locations of the certficate and the private key file.
  5. Click OK to save your configurations.
Parent topic: Setting Up Secure Communications


To Start a Secure Listener and Set the Pass Phrase

You use this task for Enterprise Server instances with secure listeners where you want to set the pass phrases each time you start the server.
  1. On the Enterprise Server Administration screen, click the Start button for the server that you want to start, and on the confirmation screen, click OK to continue.
  2. When the server starts, click the server's Details button.
  3. On the server's Details screen, select the Listeners tab.
  4. In the listener list, locate your secure listener, and in the Status column, click Authorize.

    The Communications Process screen is displayed.

  5. Enter the Certificate Passprhase and the Keyfile Passphrase and click Set Passphrases The passphrases are set and the listener starts and becomes available for use.
Note: If the listener fails to start, it can be useful to look in the CS console. To access the CS console, on the server's Details page, select: Server > Diagnostics > CS Console
Parent topic: Setting Up Secure Communications


To Configure the Pass Phrase in a File

You can configure the pass phrases that a listener requires in the mf-server.dat file. When you start the listener, it retrieves the passphrases from the file, and you do not need to configure them manually.

The mf-server.dat file is in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin directory by default.

  1. Open the mf-server.dat file in a text editor.
  2. In the file, add the following lines:
    [Listener-name/SSL/passphrases]
certificate=certificate passphrase
keyfile=keyfile passphrase
    where:
    • Listener-name is the name of the listener.
    • certificate passphrase is the certificate's passphrase.
    • keyfile passphrase is the keyfile's passphrase.
  3. Save the file and start the listener. The listener retrieves the passphrases from the file and starts.
Note:

The pass phrases appear in plain text in the mf-server.dat file. For security purposes, you should make this file readable only by the user account (or accounts) under which the enterprise server is started. That would normally be the account under which Micro Focus Directory Server (MFDS) runs (typically LOCAL_SYSTEM) and the accounts of any users who run casstart from the command line.

Parent topic: Setting Up Secure Communications


Troubleshooting a Secure Connection

If a secure listener fails to start, there are some options you can use to locate the cause.

  • Accessing the Communications Server Console
  • To Enable Logging for Listener Startup
  • Locating Certificate Problems
Parent topic: Securing Communications


Accessing the Communications Server Console

To determine the cause of a secure listnener failure, it can be useful to look in the Communications Server (CS) console and review the messages that the listener generated. To access the CS console:

  1. On the Entereprise Server Administration Home page, click Edit at the left of the server you want to check.
  2. Click the Diagnostics tab, then click the CS Console tab.
  3. To view the entire log since the server was started, click Show Entire Log. The log opens in a text editor window.
Parent topic: Troubleshooting a Secure Connection


To Enable Logging for Listener Startup

To help locate the causes of listener problems, you can enable additional logging of the listener startup process.

  1. On the Entereprise Server Administration Home page, click Edit at the left of the server you want to configure
  2. Go to the Listeners page.
  3. At the top of the list of listeners, click the Communications Process Edit button (not Edit for any of the inidividual listeners).
  4. Add the following to the Configuration Information area:
    [listeners]
logging=3
  5. Click OK.

LIstener startup information is now logged, and is available in the log files.

Parent topic: Troubleshooting a Secure Connection
Parent topic: Secure Communications (SSL)
Previous topic: To set a pass phrase
Next topic: Installing server certificates for secure communication


Locating Certificate Problems

If your application refuses to trust a certificate from a specific location, it might be because the one of the signers in the chain of CAs, or even the originating CA root, is not trusted. To locate the problem, you need to get the server's certificate chain, from its own identity certificate right through to the originating CA root in the server's chain of trust.

To get the chain of certificates for a specific server, you use the s_client function of OpenSSL. This function implements a generic SSL/TLS client that can establish a transparent connection to a remote server speaking SSL/TLS. It's intended for testing purposes only and provides only rudimentary interface functionality but internally uses mostly all functionality of the OpenSSL ssl library.

You connect to a SSL service on the server, as follows:

openssl s_client -showcerts -connect <myserver>:<ssl_port>

This returns all the certificates in the chain, starting with the server certificate and ending with the root CA certificate. They are all in PEM format. This command opens a session with the server. After responding to your request for the certificates, the session sits waiting for you to send further requests. You can send Ctrl+Z to exit the session or wait for the server to time out the connection.

For example:

openssl s_client -showcerts -connect ibank.myBank.co.uk:443

The above command returns:

Loading 'screen' into random state - done
CONNECTED(00000790)
depth=2 /C=US
        /O=VeriSign, Inc.
        /OU=Class 3 Public Primary Certification Authority

verify error:num=19:self signed certificate in certificate chain
verify return:0

Error 19 status is expected, because the CA root certificate in all certificate chains is self-signed. See Error 19 Details later for more details.

---
Certificate chain
 0 s:/C=GB/ST=Bucks/L=Chesham/O=myBank PLC
     /OU=Enable
     /OU=Terms of use at www.verisign.co.uk/rpa (c) 03
     /OU=Authenticated by VeriSign
     /OU=Member, VeriSign Trust Network
     /CN=ibank.myBank.co.uk
   i:/O=VeriSign Trust Network
     /OU=VeriSign, Inc.
     /OU=VeriSign International Server CA - Class 3
     /OU=www.verisign.com/CPS Incorp.by Ref. LIABILITY LTD.(c)97 VeriSign
-----BEGIN CERTIFICATE-----
MIIE3TCCBEagAwIBAgIQXM1dOQs/cV03UDAru58mEjANBgkqhkiG9w0BAQQFADCB
ujEfMB0GA1QBChMWVmVyaVNpZ24gVHJ1c3QgTmV0d29yazDJEEUGA1UECxMOVmVy
ONfYgdrkI7Bwhc58KJR4zqwppdl0QgsspXgmz7gJFgsgfZdptm/QvXfs+N4mxDm8
b0I6p9RtmLq82Itr6q1wUWssjHm5PlZRoQ8YaYJkaUN2rLsRT1SyQxygRo9xu81d
0Q==
-----END CERTIFICATE-----

This marks the end of certificate “0”, which identifies the server system. The next section labeled "s:" refers to the certificate owner ("subject") and the following section "i:" refers to the issuer.

 1 s:/O=VeriSign Trust Network
     /OU=VeriSign, Inc.
     /OU=VeriSign International Server CA - Class 3
     /OU=www.verisign.com/CPS Incorp.by Ref. LIABILITY LTD.(c)97 VeriSign
   i:/C=US
     /O=VeriSign, Inc.
     /OU=Class 3 Public Primary Certification Authority
-----BEGIN CERTIFICATE-----
MIIDgzCCAuygAwIBAgIQJUuKhThCzONY+MXdriJupDANBgkqhkiG9w0BAQUFADBf
MQswCQYDVQQGEwJVUzEXMBUGA1UEChMOVmVyaVNpZ24sIEluYy4xNzA1BgNVBAsT
1RPuKSvD5HKNRO3RrCAJLeH24RkFOLA9D59/+D3R3IYChmFOJl9en5IeDCSk9dBw
E88mw0M9SR2egi5SX7w+xmYpAY5Okiy8RnUDgqxz6dl+C2fvVFIa
-----END CERTIFICATE-----

We have reached the end of certificate “1” which identifies the signer of the server system’s certificate. Looking at the “s” section we can see that there is less detail in this certificate than in certificate “0”, but still enough to give a legal identity to the signer. This is important to understand. When creating certificate to use in real world situations, the creator must provide enough information within the certificate content to legally identify the item or entity being represented by the certificate.

 2 s:/C=US
     /O=VeriSign, Inc.
     /OU=Class 3 Public Primary Certification Authority
   i:/C=US
     /O=VeriSign, Inc.
     /OU=Class 3 Public Primary Certification Authority
-----BEGIN CERTIFICATE-----
MIICPDCCAaUCEHC65B0Q2Sk0tjjKewPMur8wDQYJKoZIhvcNAQECBQAwXzELMAkG
A1USXhMCVVMxFzAVBgNVBAoTDlZlcmlTaWduLCBJbmMuMTcwNQYDVQQLEy5DbGFzlbwdj2wsqFHMc9ikwFPwTtYmwHYBV4GSXiHx0bH/59AhWM1pF+NEHJwZRDmJXNyc
AA9WjQKZ7aKQRUzkuxCkPfAyAw7xzvjoyVGM5mKf5p/AfbdynMk2OmufTqj/ZA1k
-----END CERTIFICATE-----
---
Server certificate
subject=/C=GB/ST=Bucks/L=Chesham/O=myBank PLC
        /OU=Enable
        /OU=Terms of use at www.verisign.co.uk/rpa (c) 03
        /OU=Authenticated by VeriSign/OU=Member, VeriSign Trust Network
        /CN=ibank.myBank.co.uk
issuer=/O=VeriSign Trust Network
       /OU=VeriSign, Inc.
       /OU=VeriSign International Server CA - Class 3
       /OU=www.verisign.com/CPS Incorp.by Ref. LIABILITY LTD.(c)97 VeriSign
---
No client certificate CA names sent
---
SSL handshake has read 2894 bytes and written 352 bytes
---
New, TLSv1/SSLv3, Cipher is RC4-MD5
Server public key is 1024 bit
SSL-Session:
    Protocol  : SSLv3
    Cipher    : RC4-MD5
    Session-ID: 56931DEEE4EDB5808FAC374D3AD7EC1C90A4FB4E2FF6DA16749203A87C7FA169

    Session-ID-ctx:
    Master-Key: C87463A6C17BFC2A8817F9B6B302C8EAE53B2BC25AB63A3DEA461EA495B20C78
B4AAF17DEED14661D8A09488215DCA7B
    Key-Arg   : None
    Start Time: 1112711406
    Timeout   : 300 (sec)
    Verify return code: 19 (self signed certificate in certificate chain)
---
closed

You can close the session using Ctrl+Z and then Enter, to which the server should respond:

DONE

Error 19 Details

In the above example, you can see that the ultimate CA root certificate is self-signed. The ultimate CA root certificate in all certificate chains is self-signed.

The error 19 occurs because the s_client function doesn't check the default OpenSSL CA certificate store against the CA root certificates being passed in the replies by the server. So, even if this certificate is already present in the CARootCerts file, and this file is correctly configured in the openssl.cnf file, this function will still fail to trust the self-signed certificate.

You can avoid this error by setting up a collection of trusted CA root certificates to be used in this s_client function call. This makes the s_client function check the default OpenSSL CA certificate store against the CA root certificates being passed in the replies by the server.

To avoid generating the error 19 from s_client, the caller must pass one of the following arguments:

  • -CApath <ssl-base-dir>certs/ to use a directory of CA root certificates
  • -CApath <ssl-base-dir>file to use a single file certificate collection of your choice which would contain all the trusted certificates for the PKI within which your installation is operating
Parent topic: Troubleshooting a Secure Connection
Parent topic: Secure Communications (SSL)
Previous topic: Securing Peer to Peer Communications


Using the Demonstration Certificate Authority

This section describes the demonstration Certificate Authority (CA), delivered as part of Micro Focus Security Pack.

You can use the demonstration CA software to generate certificates and test your secure communications setup before using certificates issued by a trusted CA. The demonstration CA software is based on the OpenSSL software.

You can familiarize yourself with the setup without the need to obtain cerrtificates from a trusted CA. The online help includes a tutorial that describes the process of using the DemoCA to secure your system.

  • About the Demo CA
  • OpenSSL and Micro Focus Demo CA
  • Installing Micro Focus Demo CA
  • Contents of the Demonstration CA
  • Your CA Certificate, Key and Password
  • Your Distinguished Name and Policy
  • Is the Demonstration CA a Real CA?
Parent topic: Securing Communications
Parent topic: Secure Communications (SSL)


About the Demo CA

Micro Focus Demo CA enables you to configure secure communication for an Enterprise Server listener.

Encryption uses Secure Sockets Layer (SSL) and is fully interoperable with standard (non-Micro Focus) SSL clients and servers. Micro Focus Demo CA also provides support for integration with Public Key Infrastructures (PKIs) and PKI functions, such as processing certificates.

The demonstration CA software enables you to operate as a Certifying Authority. An operating CA needs to create certificates, and it needs an LDAP to store the certificates it creates along with its own certificate (self-signed in the case of a root CA). For training and testing you will be acting as both a CA and a server requesting certificates, so you need certificates and keys for both.

The demonstration CA comprises a directory structure and the files needed for the demonstration. The demonstration CA is set up with the following:

  • A public/private key pair.
  • A certificate containing your Distinguished Name, your public key and signed with your private key. The Distinguished Name comprises the details you gave during installation, such as your computer name (known as Common Name in PKI terminology), address, and so on.
  • A pass phrase, which you use to access the private key. This pass phrase is srvrootpwd, which you can change later. OpenSSL uses pass phrases, which can include spaces, whereas passwords cannot.
  • A configuration file openssl.cnf, which contains the SSL defaults and other information.

You use the demonstration CA to create certificates. Since the CA is local, these certificates are not recognized outside your organization. For production use you should obtain certificates from a well-known Certifying Authority and use those. The Demo CA is suitable for training and testing.

Note:

If you consider using the demonstration for anything other than training or testing, it is essential that you read the warnings in the section Is the Demonstration CA a Real CA?.

Parent topic: Using the Demonstration Certificate Authority
Related information
OpenSSL and Micro Focus Demo CA
Installing Micro Focus Demo CA
Contents of the Demonstration CA
Your CA Certificate, Key and Password
Your Distinguished Name and Policy
Is the Demonstration CA a Real CA?


OpenSSL and Micro Focus Demo CA

Micro Focus Demo CA includes the utility openssl.exe. You can use the demonstration CA to generate and process certificates and keys during training, development and testing.

OpenSSL is an organization that has developed a toolkit for implementing SSL. A subset of this toolkit is provided with this pack, as a command-line utility called openssl.exe. It provides functions you need for using SSL and PKIs - notably, functions for creating and checking certificates. For details on the OpenSSL organization, see their Web site www.openssl.org.

The SSL support in the Micro Focus Demo CA is based on the OpenSSL source distribution, and provides a subset of the features in full OpenSSL source. Therefore, documentation on the Web regarding OpenSSL applies to the SSL support provided by this pack, although some features might not be relevant. The SSL documentation on the Web can be a useful guide.

Parent topic: Using the Demonstration Certificate Authority
Related information
About the Demo CA
Installing Micro Focus Demo CA
Contents of the Demonstration CA
Your CA Certificate, Key and Password
Your Distinguished Name and Policy
Is the Demonstration CA a Real CA?


Installing Micro Focus Demo CA

By default, the Micro Focus Demo CA installation file, DemoCA_Setup.exe is located in %ProgramFiles(x86)%\Micro Focus\DemoCA.

To install Micro Focus Demo CA:

  1. Make sure that Studio Enterprise Edition is installed on the installation machine.
  2. Run DemoCA_Setup.exe.
Note: The values that you set in the installation screen define the default distinguished name (DN) for the sample certificates created in the DemoCA.

Parent topic: Using the Demonstration Certificate Authority
Related information
About the Demo CA
OpenSSL and Micro Focus Demo CA
Contents of the Demonstration CA
Your CA Certificate, Key and Password
Your Distinguished Name and Policy
Is the Demonstration CA a Real CA?


Contents of the Demonstration CA

The Demo CA installation creates the following directories and contents:

Name | Description
certs | You use this directory to store copies of all certificates and key files that you as a CA issue
crl | When you revoke a certificate, it is added to file crl.pem in here
newcerts | Holds the database of certificates you have issued. When you create a certificate, it is created in here with a numeric name, for example 01.pem.
private | Contains your self-signed CA root certificate in several formats and your private key

The following files are installed by default in %ProgramFiles(x86)%\Micro Focus\DemoCA:

Name | Description
create_srv_req.cmd | Script that creates a request for a server certificate
create_cli.cmd | Script that creates a client certificate
index.txt | Index to the certificates stored in newcerts
install_demoCA.cmd | Script that creates a CA that can be used to sign and verify certificates. This is for demonstration and development purposes only and should not be used in production.
sign_srv.cmd | Script that processes a server certificate request and signs the certificate
openssl.exe | OpenSSL command-line utility
openssl.cnf | Configuration file that specifies directories and defaults for SSL support
.rand | Random number used in generating keys. This number is generated anew each time you create a key.
serial | Number to be allocated to the next certificate you issue.
srv.pem | Certificate request (together with the private key in the one file) from which the server certificate was created
srvcert.pem | Your server certificate
srvkey.pem | Your server's private key
Parent topic: Using the Demonstration Certificate Authority
Related information
About the Demo CA
OpenSSL and Micro Focus Demo CA
Installing Micro Focus Demo CA
Your CA Certificate, Key and Password
Your Distinguished Name and Policy
Is the Demonstration CA a Real CA?


Your CA Certificate, Key and Password

The private subdirectory contains the root CA certificate and matching private key.

The certificate is provided in several formats, because different entities that you communicate with, such as different browsers, may require different formats. The .pem files contain a format called PEM. This is a way of modifying a binary string so that the bit pattern in each byte coincides with an ASCII character, so that the string is printable and displayable as text. The .cer file contains a format called DER, which is not plain text.

The files provided in the private subdirectory are:

  • CAkey.pem - the CA's private key file. You can open this file in a text editor and see that the key is just one long number. In PEM format, it is preceded and followed by headers - these identify it as an RSA private key. It has been encrypted, by combining it with the pass phrase mentioned above. It appears as a string of characters.
  • CARootcert.pem - the CA's certificate in PEM format, the default for OpenSSL. In a text editor, the PEM-format certificate looks similar in layout to the key, but in fact a certificate has a complex structure. You can open the certificate file using the x509 command of the openssl utility. For example from the private subdirectory, enter:
    ..\openssl x509 -in carootcert.pem -text

    This shows the certificate first in human-readable form, and then in machine-readable form between the BEGIN CERTIFICATE and END CERTIFICATE lines. It shows that the public key was generated using the RSA algorithm and is 1024 bits long. The signature was created using the MD5 hashing algorithm and the RSA encryption algorithm. Notice that the Issuer and Subject are the same, because this is a self-signed certificate, as you would expect of a root CA's certificate.

  • CARootcert.cer - The CA's certificate in another format, P7B format, the default for Internet Explorer, which might be required because different browsers require different formats. You can view the certificate using the x509 command and the -inform parameter to specify that this certificate is in DER format. For example from the private subdirectory, enter:
    ..\openssl x509 -in carootcert.cer -text -inform DER

    Compare the x509 displays of the PEM and DER versions of this certificate, and notice that their contents are identical. However, you cannot display the DER one with a text editor.

The CAKey.pem and srvkey.pem files are installed with the same password "srvrootpwd". See Is the Demonstration CA a Real CA? for recommendations.

You should regard the contents of this private folder as sacrosanct. These are the public/private key pair that you must have in order to operate your CA. Do not alter or lose anything in here. Note that anyone who gets hold of your private key can masquerade as you. In production, you would take precautions such as making these files read-only, and keeping secure backups.

Parent topic: Using the Demonstration Certificate Authority
Related information
About the Demo CA
OpenSSL and Micro Focus Demo CA
Installing Micro Focus Demo CA
Contents of the Demonstration CA
Your Distinguished Name and Policy
Is the Demonstration CA a Real CA?


Your Distinguished Name and Policy

When you installed the Micro Focus Security Pack, you provided details of your site, such as Common Name, locality, and so on. All these details together are known as your Distinguished Name, and are intended to identify your site uniquely in the world. These details were put into your certificates.

Especially important is the Common Name. If this is not exactly the same as the fully qualified domain name of the machine running your SSL software, people you communicate with will get warnings that your certificate may not be valid. This field defaults to the name as known to your operating system, so you will probably not need to change it. You can however use wildcards in the Common Name, so you can use the same certificate for several machines. You will need to do this if, for example, you are running a Web site with a cluster of Web servers.

The elements of the Distinguished Name - Common Name, Locality, and so on - are standard, but it's up to you as the CA to have a policy on which of them you require. You can define the policy and specify the required elements, using the policy directive of the openssl ca function. You can specify several default groups of content within openssl.cnf and refer to each group by its name as a policy. See OpenSSL Configuration File.

Parent topic: Using the Demonstration Certificate Authority
Related information
About the Demo CA
OpenSSL and Micro Focus Demo CA
Installing Micro Focus Demo CA
Contents of the Demonstration CA
Your CA Certificate, Key and Password
Is the Demonstration CA a Real CA?


Is the Demonstration CA a Real CA?

CAUTION:

We strongly recommend that you do not use the demonstration CA to set up a commercial CA or other generally available CA service.

If you intend to set up a PKI within your organization, the demonstration CA is suitable software to use to run your real-life CAs. However, Micro Focus does not provide support for this use. As with any production software system, you must take great care to back up vital information and keep it secure.

The demonstration CA is suitable for creating certificate signing requests to be sent to a commercial or official CA.

Note:

The demonstration CA is installed with the same password "srvrootpwd" for the CA root private key CAkey.pem and the server private key Srvkey.pem files. We recommend that to ensure any form of real security you regenerate the demonstration CA content and recreate a server certificate.

Parent topic: Using the Demonstration Certificate Authority
Related information
About the Demo CA
OpenSSL and Micro Focus Demo CA
Installing Micro Focus Demo CA
Contents of the Demonstration CA
Your CA Certificate, Key and Password
Your Distinguished Name and Policy


Tutorial: Requesting and Issuing Server Certificates

This tutorial shows how to request and issue server certificates, using the scripts supplied with the demonstration CA.

  • Introduction
  • Requesting a Server Certificate
  • Issuing a Server Certificate
Parent topic: Securing Communications
Parent topic: Secure Communications (SSL)


Introduction

In this tutorial, you first request a server certificate from the CA. Then you take the role of the CA and issue the requested certificate. To do this, you use the following scripts:

  • create_srv_req.cmd creates a request for a server certificate, using the OpenSSL command openssl req. It creates a public/private key pair for your server, putting the public key in a certificate request, which you subsequently send to the CA.
  • sign_srv.cmd, which processes a server certificate request created with the above script, and signs it using the openssl ca command. It creates a signed certificate, which containing the public key from the certificate request.

These scripts are supplied with Micro Focus Demo CA and are by default in %ProgramFiles(x86)%\Micro Focus\DemoCA.

To find out the Windows directory, look up the registry key: HKEY_LOCAL_MACHINE\Software\Micro Focus\DemoCA\1.0\Setup\DemoCAFolder.

Parent topic: Tutorial: Requesting and Issuing Server Certificates
Related information
Requesting a Server Certificate
Issuing a Server Certificate


Requesting a Server Certificate

In this section, you ask the certifying authority (CA) for a server certificate. As the server owner you create a private key and a public key. The public key is created in a certificate request (usually called a Certificate Signing Request, CSR) that you would send to the CA.

With a commercial CA, you would typically contact them first, learn about what types of certificates they supply, and find out their prices, terms and conditions.

  1. Run the batch utility create_srv_req.cmd, located in %ProgramFiles(x86)%\Micro Focus\DemoCA by default.

    The batch file creates a public/private key pair for your server, and creates a certificate request with the public key, to send to the CA.

    The private key is generated first and is stored in srvkey.pem.

  2. At the prompt, enter a pass phrase. Use a pass phrase that is easy for you to remember and yet hard for others to guess, for example: open sesame You must supply this pass phrase to access your server's private key. You are prompted to confirm the pass phrase.
  3. The utility prompts you for the following details. These default to the values that you entered when you installed Micro Focus Demo CA:
    • Country Name
    • State or Province
    • Locality
    • Organization Name
    • Organizational Unit
    • Common Name

    For example, you can enter something like:

    Country Name: US
State or Province Name: California
Locality: Palo Alto
Organization Name: Bloggs Widgets Inc
Organizational Unit Name: Marketing
Common Name: [Press Enter to accept
the server name value configured on installation.]
Email Address: bloggs@widgets.com

    The details you enter are included in your server certificate to identify you.

  4. At the Enter an additional challenge password prompt, press Enter to ignore it. You can specify a pass phrase to protect your public certificate, but since it is a public certificate, it is seldom appropriate to protect it in this way.
  5. At the Unstructured Name prompt, press Enter to ignore.
  6. When the batch file finishes, confirm that the following were created in the installation directory:
    • Your server's private key in srvkey.pem. You can view this in a text editor.
    • Your public key in a certificate request file called srvcertreq.csr. The CSR file is formatted according to the PKCS #10 standard, and is informally known as a PKCS #10 file, P10 file, or CSR file. You can view this using the req as follows:
      openssl req -in srvcertreq.csr -text
  7. In a real case you would now send srvcertreq.csr to the CA.
Parent topic: Tutorial: Requesting and Issuing Server Certificates
Related information
Introduction
Issuing a Server Certificate


Issuing a Server Certificate

In this section, you issue the server certificate.

  1. Run the batch file sign_srv.cmd, which is in %ProgramFiles(x86)%\Micro Focus\DemoCA by default. When the batch file asks if you ready, press any key.

    The batch file calls the ca command of the openssl utility to create a signed certificate, srvcert.pem, containing the public key from the certificate request.

  2. When you are prompted for the passphrase, enter the CA passphrase srvrootpwd. This confirms your right to access the CA private key file cakey.pem, and then displays the certificate request (from the CSR file srvcertreq.csr).
  3. When asked whether to sign the certificate, reply y twice.

    The certificate is then created and signed with your private key from cakey.pem. It is in PEM format. It is saved in srvcert.pem, with a copy in newcerts\01.pem. If this tutorial has been run before, and 01.pem already exists, the copy will be called 02.pem and so on.

  4. As before, view the certificate using the openssl x509 command:
    openssl x509 -in 01.pem -text

    Notice that the Issuer is shown as the Distinguished Name of your Demo CA, while the Subject - the entity to whom the certificate has been issued - is the Distinguished Name of your server.

  5. Copy 01.pem from the newcerts directory to the certs, which is your Demo CA's database of certificates it has issued.
  6. In a real case the CA would now send srvcert.pem to the server owner to install it in their SSL software so that Web users can download it.
Parent topic: Tutorial: Requesting and Issuing Server Certificates
Related information
Introduction
Requesting a Server Certificate


Tutorial: Configuring SSL Security in the Server

This tutorial shows how to configure SSL security in Enterprise Server.

  • Introduction
  • Creating a Secure HTTPS Listener
  • Installing the Server Certificate
  • Setting a Pass Phrase
  • Interpreting a Security Alert
  • Importing the CA's Root Certificate
  • Verifying the Certificate
  • Tidying Up
Parent topic: Securing Communications
Parent topic: Secure Communications (SSL)


Introduction

In this tutorial:

  • As the server administrator, you configure SSL security for Enterprise Server.

    You create an HTTPS listener and you install the server certificate and private key file that you created in the previous tutorial.

  • As an Enterprise Server user, you connect to the server from a Web browser. You install the CA's root certificate in order to access Enterprise Server.

    Typically, you rarely need to install CA root certificates. These are already configured for most trusted Certifying Authorities.

Note:

You must have completed the previous tutorial, Requesting and Issuing Server Certificates before you can run this tutorial.

In this tutorial, you configure the ESDEMO server to use secure communications. ESDEMO is created by the Enterprise Server installation. Within an enterprise server, you can create listeners for different kinds of communication.

One of ESDEMO's default listeners is HTTP Echo. This listener provices a simple test of Web communication. When a Web browser connects to HTTP Echo, the listener responds by sending a simple Web page with some identifying details.

Parent topic: Tutorial: Configuring SSL Security in the Server
Related information
Creating a Secure HTTPS Listener
Installing the Server Certificate
Setting a Pass Phrase
Interpreting a Security Alert
Importing the CA's Root Certificate
Verifying the Certificate
Tidying Up


Creating a Secure HTTPS Listener

This section describes the process that the server owner uses to configure an enterprise server to use SSL. In this tutorial, you create an HTTPS version of the HTTP Echo listener. You will use this listener in the stage: Interpreting a Security Alert

  1. Start Enterprise Server Administration, access the Home screen and make sure the ESDEMO enterprise server is stopped.
  2. For ESDEMO, click Edit > Listeners to access the Listeners page. Make sure the Process filter is set to All so you can see all the listeners.
  3. Click Add to create a listener for HTTPS.
  4. In the Name field, enter HTTPS Echo as the name.
  5. Change the Endpoint Address to *.9443.

    Although you can use port 443, it might already be in use. For example, IIS listens by default on port 443. If you want to use port 443, you can check whether it is in use, by running the following command:

    netstat -an | findstr 443
  6. Specify that this will be an "HTTP echo" listener, which provides a simple response to HTTP requests. To do this, select Custom under Supported Conversation Type and enter http-echo in the field alongside.
  7. In the Description field, type:
    Simple secure HTTP test
  8. Click Add.

On the Listeners page, the new entry for HTTP Echo appears.

Parent topic: Tutorial: Configuring SSL Security in the Server
Related information
Introduction
Installing the Server Certificate
Setting a Pass Phrase
Interpreting a Security Alert
Importing the CA's Root Certificate
Verifying the Certificate
Tidying Up


Installing the Server Certificate

In this section, as server administrator, you install the server certificate on the server so that remote Web users can to request it. To install a certificate, you store the certificate and the key file in a folder accessible to your server software.

  1. Edit the new HTTPS Echo listener. To do this, select the new listener on the Listeners page and click Edit.
  2. Check Secure Sockets Layer.
  3. Enter the full path and filenames of your server certificate and private key in the Certificate and Keyfile fields. These are by default srvcert.pem and srvkey.pem, installed by default in %ProgramFiles(x86)%\Micro Focus\DemoCA.
  4. Click OK.

    On the Listeners page, the entry for HTTP Echo now has a padlock symbol, which shows that it uses SSL.

Parent topic: Tutorial: Configuring SSL Security in the Server
Related information
Introduction
Creating a Secure HTTPS Listener
Setting a Pass Phrase
Interpreting a Security Alert
Importing the CA's Root Certificate
Verifying the Certificate
Tidying Up


Setting a Pass Phrase

To enable the HTTPS listener to run, you need to enter the pass phrase that you defined for the private key file. In other situations, you might also have a pass phrase for the server certificate, which you would also need to enter. This tutorial does not require one.

There are two ways of setting the pass phrases. One way is to store the pass phrases in a file, and the other is to enter them once the enterprise server is started.

To set the pass phrase in a file:

  1. Edit the file mf-server.dat, located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin. If the file does not exist, create it.
  2. Add the following lines to mf-server.dat:
    [HTTPS Echo/SSL/passphrases]
certificate=
keyfile=open sesame

    It does not matter where in the file you add this section. If you like, you can add a comment (preceded by a ";") to describe the entry. Make sure the name HTTPS Echo is spelled exactly as it is in ES Admin.

  3. Start ESDEMO from the home page of ES Admin.
  4. When ESDEMO has started, look at the Listeners page to make sure that the new listener HTTPS Echo has started, as with the other listeners.

To set the pass phrase manually without using a file:

  1. Start ESDEMO from the home page of ES Admin.
  2. When ESDEMO has started, go to the Listeners page. If you didn't enter the pass phrase in the above file, the status of the listener HTTPS Echo is Start pending.
  3. Click Authorize in the Status column of HTTPS Echo. This displays the SSL Listeners page in a separate browser window.
  4. Enter open sesame in the Keyfile Passphrase field, then click Set passphrases. You can leave the Certificate Passphrase field blank, since you did not define a certificate passphrase.
  5. Confirm that the HTTPS Echo is now started by viewing the main Listeners page (and clicking Refresh if necessary).

If you ever have problems starting or running an SSL-enabled listener, it can be useful to look at the MFCS log. Click Server > Diagnostics > CS Console.

Parent topic: Tutorial: Configuring SSL Security in the Server
Related information
Introduction
Creating a Secure HTTPS Listener
Installing the Server Certificate
Interpreting a Security Alert
Importing the CA's Root Certificate
Verifying the Certificate
Tidying Up


Interpreting a Security Alert

In this section as a user connecting to the server, you verify that you have connected to the correct Web site, and that it is trustworthy.

Since the Web site was certified by your Demo CA, you need your Demo CA's self-signed certificate installed in your browser in order for the Web site's certificate to be accepted. The necessary demo CA's self-signed certificate is not installed, so that you can see the messages that this causes.

  1. In your browser, enter https://localhost:9443.

    This uses the secure version of HTTPEcho that you created in the stage Creating a Secure HTTPS Listener.

    You could enter your machine's actual DNS host name or even its dotted decimal IP address rather than localhost. Normally, it should make no difference, but for the purposes of this tutorial, use localhost.

  2. A Security Alert is displayed. It warns you that the Web site's security certificate may not be trustworthy, and it lists what is right and what is wrong with it.

    If this tutorial has already been run and the CA certificate is still installed, you do not get this alert. You can remove the certificate and then restart this section to display the alert.

  3. Close the security alert.

This security alert indicates that you have not installed the self-signed certificate of the CA that issued this server certificate.

Parent topic: Tutorial: Configuring SSL Security in the Server
Related information
Introduction
Creating a Secure HTTPS Listener
Installing the Server Certificate
Setting a Pass Phrase
Importing the CA's Root Certificate
Verifying the Certificate
Tidying Up


Importing the CA's Root Certificate

Browsers typically come with certificates for well-known CAs already installed, and you rarely need to install them. If you need a CA's root certificate, you can usually download it from the CA's Web site.

The demonstration CA's certificate is not pre-installed in your browser, so you need to install it. It is supplied in the private directory of the demoCA. You install this certificate as follows:

  1. In your browser, go to the options where you manage certificates.
    • In Internet Explorer, click Tools > Internet Options > Content > Certificates. Go to the Trusted Root Certification Authorities tab and click Import.
    • In Mozilla Firefox, click Tools > Options > Advanced. Then scroll down and click Manage Certificates. Click Authorities and then click Import.
  2. Install the CA's self-signed certificate, which is in the private folder of your DemoCA directory. Specify the file CARootCert.cer. Internet Explorer requires X509 certificates, in DER format, so only those are listed, and not the PEM format files. Mozilla Firefox can handle several types, so several are listed and you need to install the PEM-format certificate.
  3. In Internet Explorer, use the Browse button to enter Trusted Root Certification Authorities in the Certificate Store field.

    In Mozilla Firefox, check Trust this CA to identify Web sites.

  4. Look down the list under Trusted Root Certification Authorities (for IE) and Authorities (for Firefox). You will see that your Demo CA is now listed; look for its Common Name. If when you installed Micro Focus Demo CA you chose to use your computer DNS name as the DemoCA's Common Name, it will appear different to the rest, because real CAs tend to give themselves user-friendly Common Names.
Parent topic: Tutorial: Configuring SSL Security in the Server
Related information
Introduction
Creating a Secure HTTPS Listener
Installing the Server Certificate
Setting a Pass Phrase
Interpreting a Security Alert
Verifying the Certificate
Tidying Up


Verifying the Certificate

Now that the CA's certificate is installed, you should be able to connect from the client Web browser.

  1. Try to connect again. In the Web browser, enter https://localhost.
  2. Read the Security Alert again. This time it shows only one problem, which is that the name in the certificate doesn't match the URL you tried to connect to. This is a warning that the certificate might not have come from the desired Web site, but from another Web site masquerading as it.
  3. Click View Certificate. The Issued To name in the certificate is the DNS host name of your computer, and you were trying to connect to localhost, and this is the cause of the discrepancy.
  4. Since this is in fact the desired Web site, click Close > OK.

    The connection is made, and HTTPS Echo sends a page with identification details to your browser, confirming that the connection has been made successfully. It is normal for most of the strings to be empty, as shown.

Parent topic: Tutorial: Configuring SSL Security in the Server
Related information
Introduction
Creating a Secure HTTPS Listener
Installing the Server Certificate
Setting a Pass Phrase
Interpreting a Security Alert
Importing the CA's Root Certificate
Tidying Up


Tidying Up

You should remove your Demo CA's self-signed certificate from your Web browser, both to avoid confusion in real use of your browser, and to enable this tutorial to be run again if required.

  1. In your browser, go to the options where you manage certificates.
    • Internet Explorer, click Tools > Internet Options > Content > Certificates. Then go to the Trusted Root Certification Authorities tab.
    • In Mozilla Firefox, click Tools > Options > Advanced. Then scroll down and click Manage Certificates and click Authorities.
  2. Select your Demo CA's certificate (the Common Name, not the organization name), then remove it.
  3. Close the browser and re-open it.
Parent topic: Tutorial: Configuring SSL Security in the Server
Related information
Introduction
Creating a Secure HTTPS Listener
Installing the Server Certificate
Setting a Pass Phrase
Interpreting a Security Alert
Importing the CA's Root Certificate
Verifying the Certificate


Information on OpenSSL

The openssl.exe utility is installed by default in the directory: %ProgramFiles(x86)%\Micro Focus\DemoCA. This directory is pointed to by the SSLDIR environment variable, which is created when you install this pack. The directory is not automatically added to your path, but you might find it useful to add it.

The openssl utility supplied with this pack is a full implementation of the utility, except that certain algorithms that are subject to patents or other legal restrictions have been excluded. See Supported Algorithms in the Readme for a list of the supported algorithms.

You can run openssl from the command line.

For details of the OpenSSL utility, see www.openssl.org and www.mkssoftware.com.

  • OpenSSL Utility
  • OpenSSL Configuration File
  • Algorithms
  • Interpreting OpenSSL Error Messages
  • Supported SSL Versions and Supported Algorithms
Parent topic: Securing Communications
Parent topic: Secure Communications (SSL)


OpenSSL Utility

The OpenSSL utility is installed by default in %ProgramFiles(x86)%\Micro Focus\DemoCA.The directory is pointed to by the SSLDIR environment variable, which is created when you install this pack. The directory is not automatically added to your path, but you might find it useful to add it.

The OpenSSL utility supplied with this pack is a full implementation of the utility, except that certain algorithms that we believe to be subject to patents or other legal restrictions have been excluded.

To start the OpenSSL utility, run openssl from the command line.

Parent topic: Information on OpenSSL
Related information
Supported SSL Versions and Supported Algorithms
www.openssl.org
www.mkssoftware.com
OpenSSL Configuration File
Some Common Algorithms
Definitions for OpenSSL


OpenSSL Configuration File

The OpenSSL configuration file provides SSL defaults for items such as:

  • The location of your certificate files.
  • Your Distinguished Name. This comprises the details of your site (your Common Name, your locality and so on). Initially your Distinguished Name comprises the details you entered during installation.
  • Defaults for the openssl ca policy command, which specifies which elements of the Distinguished Name are required.

The configuration file is called openssl.cnf by default and belongs in the same directory as openssl.exe by default. You can specify a different configuration file by using the OPENSSL_CONF environment variable or you can specify alternative configurations within one configuration file.

The configuration file is a text file and comprises several sections, such as:

  • The ca section, which configures the CA. You can have several ca sections, each specifying a different configuration for a different CA, and switch between them by changing the default_ca option. You can also override this choice from the command line, using the -name parameter. This is useful in development and testing, enabling you to try out different configurations.
  • The policy section, which specifies how closely the Distinguished Name in a certificate presented to SSL software must agree with the Distinguished Name in an installed certificate, for the two certificates to be considered to match.
  • The req section, which configures the openssl req command.
  • The distinguished_name section, which specifies the Distinguished Name fields required when the openssl req command is creating a certificate request or a self-signed certificate. The actual name of this section is specified in the distinguished_name entry in the req section. This enables you to switch between different distinguished_name configurations, by changing the entry in the req section.
  • The attributes, which has attributes such as challengePassword or unstructuredName. Like the distinguished_name section, the actual name of the attributes section is specified in the req section, so that you can have several attributes sections, and switch between them.

In the options in the configuration file, all filenames must be given complete with absolute path.

For full details see OpenSSL CA function on the MKS Software site and page down to the section on the Configuration File .

Parent topic: Information on OpenSSL
Related information
OpenSSL CA function


Algorithms

You can list the available algorithms using the openssl ciphers and openssl speed functions as follows. Note that not all the algorithms listed are supported. See below.

openssl ciphers

The openssl ciphers function lists the full cipher and hash suite available in the supplied openssl utility. Most of the ciphers available in OpenSSL are supported by Micro Focus Security Pack, but not all of them.

The openssl ciphers function produces output like this:

DHE-RSA-AES256-SHA:DHE-DSS-AES256-SHA:AES256-SHA:...

Where:

  1. The first element is the method
  2. The next one or more elements (except the last) are the ciphers and might indicate the symmetric and asymmetric ciphers
  3. The last element is the hashing algorithm used for signing

openssl speed

The openssl speed function lists the algorithms supported by the Micro Focus Security Pack and available in the supplied openssl utility. The speed function also lists how long each algorithm takes on your computer. This function takes some minutes to run.

Parent topic: Information on OpenSSL
Related information
Supported SSL Versions and Supported Algorithms
OpenSSL Utility
Some Common Algorithms


Interpreting OpenSSL Error Messages

OpenSSL produces many error messages which are cryptic at times. This topic does not explain all the OpenSSL error messages, but it gives some guidance on how to interpret the messages.

Here is a typical OpenSSL error message that is caused by faling to set the SSLDIR environment variable to a directory containing openssl.cnf:

C:\Program Files\Micro Focus\DemoCA>openssl ca -revoke srvsert3.p12
Using configuration from /usr/local/ssl/openssl.cnf
error loading the config file '/usr/local/ssl/openssl.cnf'
3792:error:02001003:system library:fopen:No such process:.\crypto\bio\bss_file.c
:104:fopen('/usr/local/ssl/openssl.cnf','rb')
3792:error:2006D080:BIO routines:BIO_new_file:no such file:.\crypto\bio\bss_file
.c:107:
3792:error:0E064072:configuration file routines:CONF_load:no such file:.\crypto\
conf\conf_def.c:197:

The structure breaks down as follows:

  • Command line and parameters
  • Confirmation of configuration file to be used
  • Initial indication of error status
  • Low level code layer error information
  • Medium level code layer error information
  • Top level code layer error information

Within each code layer specific location information is given about what status was generated, within which source module and guidance as to the parameter that caused the error.

The important information is usually found in the final line. In this case the text “no such file” indicates the symptom of the failure. The file might no exist, but we might be looking in the wrong place and need to adjust the SSLDIR accordingly.

The OpenSSL Web site www.openssl.org has several relevant sections, in particular the HOW TO sections.

openssl dsa -in srvkey.pem -out keyout.pem
read DSA key
Enter PEM pass phrase:
unable to load Key
2588:error:06078081:digital envelope routines:EVP_PKEY_get1_DSA:expecting a dsa
key:.\crypto\evp\p_lib.c:241:
Parent topic: Information on OpenSSL
Related information
www.openssl.org
OpenSSL Configuration File


Supported SSL Versions and Supported Algorithms

Micro Focus Demo CA supports the following versions of SSL, in both client and server mode:

  • SSL V2.0
  • SSL V3.0
  • TLS V1.1

The following algorithms are supported:

  • AES-128 / 192 / 256
  • Blowfish CBC
  • CAST CBC
  • DES CBC / DES EDE3
  • DSA
  • HMAC(MD5)
  • MD2 / MDC2 / MD4 / MD5
  • SHA1
  • RMD160
  • RC2-CBC / RC4
  • RSA
Parent topic: Information on OpenSSL
Parent topic: SSL Reference


SSL and PKI Technology Primer

If you are new to securing communications, it is important that you understand the concepts of how communications are secured.

  • SSL
    This section gives an overview of the whole subject of SSL encryption.
  • CAs and PKIs
    This section describes CAs and PKIs.
  • Checking, Exporting and Importing Certificates Overview
    This tutorial talks through the certificates already installed on your machine, regardless of the Micro Focus Security Pack.
  • Certificates
    This chapter provides some background to certificates.
  • Standards and Organizations
    A great many standards have been created covering SSL and PKI, and as is often the way with new areas some of these standards are rivals or at least alternatives. This chapter briefly introduces the standards referred to in the coming chapters, and the organizations behind these standards.
  • Some Common Algorithms: Overview
  • Definitions for OpenSSL
    This topic briefly explains some terms that, while they are not part of SSL, often appear in discussions and documentation of SSL, especially of OpenSSL.
  • Attacks
    This topic explains some of the best known strategies for breaking a code, and what features SSL has that you can use to protect yourself from these attacks.
  • Designing a PKI
    This chapter advises on points to remember, ideas to consider, and pitfalls to avoid if you are designing a PKI for your organization. This is by no means an exhaustive list, but is intended to be helpful in suggesting points to consider.
Parent topic: Securing Communications
Parent topic: Secure Communications (SSL)


SSL

For most of this section we'll assume, for simplicity, that you are the sender of messages and someone else is the recipient. In practice, of course, you're likely to be sending messages to each other, and so everything we describe is actually happening in both directions.

Throughout this explanation, we have taken care to say "your SSL software does so-and-so" not "you do so-and-so". This is partly to emphasize that all the detailed work is done by the software - as a user, or even as a programmer, of SSL-enabled software you generally just set options. It is also to emphasize that you must keep your computer secure, with such things as login passwords. If someone else can use your SSL software in your place, obviously all security is lost.

  • What is SSL?
  • SSL and TLS Terminology
  • Encryption and Decryption
  • Hashing
  • Signing
  • Certificates
Parent topic: SSL and PKI Technology Primer
Parent topic: SSL and PKI Technology Primer
Next topic: What is SSL?


What is SSL?

SSL is a standard mechanism for sending and receiving electronic communications in encrypted form. SSL can be used wherever confidential information is to be sent between machines, such as a network, a company intranet, or the Internet. For brevity, this book generally talks about the Internet.

SSL is heavily reliant on the use of Public Key Infrastructures (PKIs). A PKI is a system of issuing online certificates to people and organizations involved in electronic communications - such as Web sites - to confirm their authenticity and trustworthiness.

SSL is widely used by organizations large and small. For example, if you use online banking, you may notice that the Web addresses - also known as universal resource locators (URL) - of many pages on your bank's Web site have addresses beginning https rather than http. This indicates that messages between that Web page and the Web site are sent via a version of HTTP that uses SSL.

Any two software programs that communicate with one another and have SSL support can send their messages to one another in encrypted form, provided that they also have a trust relationship with a PKI.

SSL can provide the following benefits:

  • Confidentiality – keeping information private
  • Integrity – ensuring information has not been tampered with
  • Authentication – confirming the identity of the individual who sent the information
  • Non-repudiation – proving that the individual who sent the information did so

Some of the above benefits are provided by PKIs that are used by SSL.

Parent topic: SSL
Parent topic: SSL and PKI Technology Primer
Previous topic: SSL
Next topic: SSL and TLS Terminology


SSL and TLS Terminology

SSL was originally defined by Netscape. The first publicly released version, SSL v2, came out in 1994. Several vendor-specific variants appeared, notably Private Communications Technology (PCT) from Microsoft. PCT was effectively a rival to SSL v3 when that came out in 1995. The Internet Engineering Task Force (IETF) took on the task of creating an industry-wide standard, and developed what was effectively SSL v3.1. However, they adopted for this the vendor-neutral name of Transport Layer Security (TLS). The terms TLS and SSL are sometimes used interchangeably. In this book we generally keep to the term SSL.

Parent topic: SSL
Parent topic: SSL and PKI Technology Primer
Previous topic: What is SSL?
Next topic: Encryption and Decryption


Encryption and Decryption

When software with SSL enabled sends a message, it sends it encrypted - that is, in a secret code. The software that receives the message, provided it too has SSL enabled and knows the secret code used, decrypts it - turns it back into the original uncoded message.

This gives you the first of the benefits of SSL mentioned above: confidentiality. If some unintended recipient - known as an eavesdropper, or attacker - picks up the message, they can't decipher it, because they don't know the code.

To encrypt a message, you need a key and an algorithm. A key is a number, and an algorithm is a method of combining this number with your message to create the encrypted message. To take a simple example, imagine you encrypt a message by replacing each letter by the letter two places farther along the alphabet, so that, for example, IBM becomes KDO. Here, "replace each letter by the letter n places farther along the alphabet" is your algorithm, and 2 is your key.

If you were to use a different key, you'd get a completely different code, although you're still using the same algorithm. So if for example n = 1, IBM becomes JCN.

  • Keys and Algorithms
  • Public Keys, Private Keys, and Secret Keys
  • Using Asymmetric and Symmetric Algorithms Together
Parent topic: SSL
Parent topic: SSL and PKI Technology Primer
Previous topic: SSL and TLS Terminology
Next topic: Keys and Algorithms


Keys and Algorithms

Now it seems obvious that the intended recipient of your coded message needs to know the algorithm and the key, so as to decode the message; and equally it seems obvious that the algorithm and key must be kept secret from everyone else. And so you get the problem of how to let your intended recipient know them - after all, anyone who might be eavesdropping on your messages might be also eavesdropping when you send the algorithm and key.

Luckily, it's not as simple as that.

The algorithms typically used by SSL are so complex (typically taking several pages of mathematics to describe), and the keys used are typically so long (sometimes hundreds of digits long, when written in hex or decimal), that even if someone does know the algorithm, the chances of them guessing the key, or finding it by trial and error, are virtually nil. So, far from keeping algorithms secret, SSL uses well-known algorithms, which have been developed and published over the years by experts in cryptography.

When you are configuring software that uses SSL, it will generally ask you which of these well-known algorithms you want to use. Since the software does all the encryption/decryption for you, you don't need to understand these algorithms (you'd need considerable mathematical knowledge to do so), but you do need to know the names of the best-known ones and a little about their relative advantages and disadvantages. We'll cover this later. We'll mention some well-known ones as we go along.

You don't need to decide a key yourself, either. Instead, your SSL software uses a random number generator to create one.

Parent topic: Encryption and Decryption
Parent topic: SSL and PKI Technology Primer
Previous topic: Encryption and Decryption
Next topic: Public Keys, Private Keys, and Secret Keys


Public Keys, Private Keys, and Secret Keys

As for keeping the key secret from all but your intended recipient, well, some of the well-known algorithms need two keys - and a message encrypted with one of the keys can only be decrypted with the other. So once you and your intended recipient have agreed which algorithm to use, your recipient's software generates a pair of keys, and sends you one (called his/her public key) while keeping the other one secret, even from you (this one is called his/her private key). Your software then encrypts and sends your message using the public key, and the recipient's software decrypts it using the private key.

So there's no danger of the private key being discovered by an eavesdropper - it never gets sent anywhere. It is known only to its owner.

As for the public key, there's no need to keep it secret. On the contrary, it can safely be made available to anyone who requests it. We'll come back later to how this is done.

An algorithm like this, using a private key and a public key, is called asymmetric. An algorithm that uses just one key, which has to be a secret between the sender and recipient, is called symmetric, and the key is called a secret key.

An algorithm that uses a private key and a public key is also called a public key algorithm. One of the best known ones is RSA, developed by Ron Rivest, Adi Shamir, and Leonard Adleman in 1977. An algorithm that uses just one key, a secret key, is called a secret key algorithm. One of the best known ones is Data Encryption Standard (DES), published as a US standard in 1977.

Parent topic: Encryption and Decryption
Parent topic: SSL and PKI Technology Primer
Previous topic: Keys and Algorithms
Next topic: Using Asymmetric and Symmetric Algorithms Together


Using Asymmetric and Symmetric Algorithms Together

An asymmetric system has one major disadvantage - the algorithms are very complex and therefore very time-consuming. No matter how fast your computer is, you wouldn't want to use them to encrypt/decrypt large amounts of data.

So encryption software normally uses a symmetric algorithm on the data itself, meaning the secret key has to be sent to the recipient - but in case an eavesdropper intercepts the secret key, the software sends the secret key encrypted, using an asymmetric algorithm.

In this kind of system, the secret key is called a session key, since it is generated when the would-be sender and recipient first connect, sent using the asymmetric algorithm, and then used for all the data transmissions until the session is complete and the connection broken. A new secret key is generated for every new session.

Parent topic: Encryption and Decryption
Parent topic: SSL and PKI Technology Primer
Previous topic: Public Keys, Private Keys, and Secret Keys
Next topic: Hashing


Hashing

As explained in the chapter SSL, a hash is created by applying an algorithm that combines the characters of a message in some way to produce a string that is meaningless but nevertheless can be regarded as characteristic of the message - the chances of any other message, subjected to the same algorithm, giving the same hash are tiny.

It is neither necessary nor desirable that the hash should be unique; the algorithm should be such that the hash does not contain enough information to reconstruct the original message. So there actually will be other messages (though a tiny subset of the set of all possible messages) that would give the same hash. This important property of a good hashing algorithm is called irreversibility. Nevertheless, it should be difficult to deliberately create two messages that produce the same hash. This property is called collision-resistance.

Just as with encryption, there are various well-known algorithms used for hashing, and your SSL software may let you choose which it uses.

  • MD5
  • SHA
Parent topic: SSL
Parent topic: SSL and PKI Technology Primer
Previous topic: Using Asymmetric and Symmetric Algorithms Together
Next topic: Signing
Parent topic: Some Common Algorithms: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: RSA
Next topic: MD5
Related information
RFC2828


Signing

But imagine the following:

  1. You send a message, encrypted and accompanied by a hash.
  2. An hacker intercepts it and prevents it reaching your intended recipient.
  3. The hacker, pretending to be you, sends a new message, encrypted and accompanied by a hash.
  4. The recipient decrypts this, and finds the hash matches the hash he or she calculates, so believes he or she has received an uncorrupted message from you.

This is called a man-in-the-middle attack.

The solution to this is for your software to send the hash encrypted as well - but encrypted using your own private key. Since you have published your public key, the recipient's software will be able to decrypt the hash and use it. And the recipient can be sure it came from you, since only your software knows the private key that matches your public key.

A hash encrypted with your private key is called a digital signature.

So if you send a message signed in this way, the recipient knows it came from you. This is the third of the benefits of SSL mentioned above: authentication.

In fact, with a digital signature, your recipient can prove it came from you. If you should ever want to deny it, you can't. This is the fourth benefit mentioned above: non-repudiation. In some parts of the world, a digital signature has legal force, like a traditional hand-written signature.

Notice though that, unlike a hand-written signature, a digital signature is different every time - it is an encryption of the hash of the message it is attached to.

A similar idea to this is a message authentication code (MAC), which is a hash encrypted with the secret key of a symmetric algorithm. MACs are used instead of digital signatures to provide integrity, authentication, and non-repudiation in some systems.

Parent topic: SSL
Parent topic: SSL and PKI Technology Primer
Previous topic: Hashing
Next topic: Certificates


Certificates

When asymmetric algorithms were first invented, it was suggested that people should publish their public keys in books like phone books. That idea didn't catch on. Instead, a new standard file type was invented, called a certificate.

A certificate contains its owner's public key and everyday elements of their identity such as their name, company, location, and the DNS host name of their computer. Your SSL software normally includes a function to create your certificate, but it's more usual to get an independent body, called a Certificate Authority, to create it. We'll go into this in the next chapter.

Anyone can have a certificate, and anyone needing to prove their identity online needs one. Notably, they are needed by organizations such as online banks and other Web sites that need clients or other organizations to communicate with them securely.

When you connect to such a Web site, the initial contact (called the handshake) between your SSL software and theirs includes their SSL software sending yours their certificate. This is how you get their public key, so that encrypted communication between you can begin, as described above.

Parent topic: SSL
Parent topic: SSL and PKI Technology Primer
Previous topic: Signing


CAs and PKIs

Two of the many well-known CAs on the Internet are VeriSign (http://www.verisign.com) and Thawte (http://www.thawte.com). You may find it useful to look at their Web sites from time to time while reading this chapter.

At this point we need to introduce the term "entity". A user of a network or intranet or the Internet might not be an individual person - it could be an organization, or even a machine. So we'll use the more general term "entity" from now on.

  • Trust
  • What is a CA?
  • What is a PKI?
  • Root and Subordinate CAs
  • How Do you Check a Certificate?
  • Certificate Validity Period and Revocation
  • Types of Certificates - Purpose
  • Authentication Modes
  • Typical Process
Parent topic: SSL and PKI Technology Primer
Parent topic: SSL and PKI Technology Primer
Next topic: Trust
Related information
Verisign
Thawte


Trust

So far, we've assumed that you and the people you communicate with know and trust each other. In real life, this is unlikely to be the case. On the Internet, or a big organization's intranet, you are one of a great many people, all potentially communicating with each other, and unlikely ever to know each other personally.

In the previous chapter, we introduced certificates as a way of making an entity's public key available to anyone who wants it.

To prove that the entity is trustworthy, an entity's certificate is created and digitally signed by someone who knows the entity personally, or at least is able to check up on them personally, and who is in turn trusted by others. In this way the certificate also serves - like a traditional paper certificate - as a proof of the entity's trustworthiness. SSL software includes a function to display a certificate on the screen so a user can check the details of the owner and the signatory.

And the person who signed the certificate can in turn have a certificate signed by a third person, and that person can in turn have a certificate signed by a fourth, and so on. Each certificate includes a record of this chain of certificates.

This is called a "web-of-trust model", and in a small organization it may be sufficient, since it's fairly easy to ensure that anyone checking a certificate will find someone he or she knows and trusts in the chain of signatories on the certificate. But it's not scalable; that is, it won't work for a big organization consisting of thousands of people mostly unknown to each other - and certainly not for the Internet.

The solution to this is a PKI, which we describe later in this chapter.

Parent topic: CAs and PKIs
Parent topic: SSL and PKI Technology Primer
Previous topic: CAs and PKIs
Next topic: What is a CA?


What is a CA?

Since you yourself can't possibly check up on all your contacts, you need someone who can - someone who can investigate entities, perhaps meet them in person, and then provide a statement to other entities that they are trustworthy. A Certification Authority (CA) is a body that does this. For an intranet, the CA might be a department within your organization. For the Internet, there are well-known CAs that provide this service.

  • How does the CA show it trusts an entity?
  • How does the CA check on entities?
  • Why should you trust the CA?
  • How do you know the certificate really came from the CA?
Parent topic: CAs and PKIs
Parent topic: SSL and PKI Technology Primer
Previous topic: Trust
Next topic: How does the CA show it trusts an entity?


How does the CA show it trusts an entity?

They issue certificates. Once they have satisfied themselves that an entity is genuine and trustworthy, they create a certificate as described above, containing the entity's public key, and the entity's identity details such as name, location, DNS host name, etc. They send this certificate to the entity to store, and keep a copy themselves.

The CA generally has a server dedicated to this function, and this machine is also known as the CA.

You can configure your SSL software to compare a received certificate to a list of known trusted CAs. As described above, you can also have your SSL software display a certificate on your screen for you to check the details.

Parent topic: What is a CA?
Parent topic: SSL and PKI Technology Primer
Previous topic: What is a CA?
Next topic: How does the CA check on entities?


How does the CA check on entities?

This is an important point, and a CA will have a Certificate Policy (or Practice) Statement (CPS) explaining how they do it. Typically this is available on the CA's Web site for anyone to read.

This check is what anchors electronic communications to the real world. Typically it involves the entity, or its representatives if it is an organization, actually presenting themselves in person to the CA, with proof of identity. If this is not practicable because entities wanting certification are geographically wide-spread, the CA will have Registration Authorities, local branches that carry out the in-person checks and then forward approval to the central CA.

Again, the RA uses a server which is itself known as the RA. The connection between the RA and CA is likely to be an electronic one - the RA notifies its approval to the CA, which then issues the certificate. At both levels, though, there are likely to be actual human beings making the decisions to recognize the proofs of identity, and to grant the certificates.

If the entities wanting certification are too widespread even for RAs to be within reach of them all, then the CA may use notaries - individuals authorized to check identification in person and forward the details to the CA or one of its RAs.

All these policies should be detailed in the CA's CPS - this document and the policies it describes are as important a part of a PKI as the SSL technology itself.

Parent topic: What is a CA?
Parent topic: SSL and PKI Technology Primer
Previous topic: How does the CA show it trusts an entity?
Next topic: Why should you trust the CA?


Why should you trust the CA?

The above all depends on the CA themselves being trustworthy. Who gave them the right to check identities and issue certificates pronouncing people trustworthy?

For the intranet of a company or other organization, the CA is likely to be a department set up at the management's direction. For the Internet, a number of privately run CAs have been established, which have become widely trusted simply because they have earned a world-wide reputation.

To maintain its reputation, a CA would be expected to keep its CA server extremely secure, not only from hackers, but also from physical on-site interference, to ensure that certificates cannot be created other than by the official route. If you read a CA's CPS, you should expect to find strict, detailed rules about physical access to the server by the CA's staff.

Parent topic: What is a CA?
Parent topic: SSL and PKI Technology Primer
Previous topic: How does the CA check on entities?
Next topic: How do you know the certificate really came from the CA?


How do you know the certificate really came from the CA?

They sign it.

In addition to the data described earlier (the public key, name , etc of the certified entity), a certificate contains the CA's digital signature. As described earlier, this provides proof - in some countries, legal proof - that it came from the CA.

Parent topic: What is a CA?
Parent topic: SSL and PKI Technology Primer
Previous topic: Why should you trust the CA?
Next topic: What is a PKI?


What is a PKI?

A PKI is the whole system described in the preceding sections - one or more CAs, their procedures (defined in their CPS's) for vetting applicants for certificates, and for handling and issuing certificates, and the SSL software used by entities to send, receive, and check certificates.

The Internet has, in effect, its own world-wide PKI, based around internationally known CAs such as Thawte, VeriSign and others. An organization, such as a company, can set up its own PKI for use within its intranet or network.

The same SSL software and world-wide standards (such as certificate formats) would normally be used in either case. The principal distinction between the world-wide PKI and a private one is that in a private one the organization would set up its own CAs, recognized within the organization.

Parent topic: CAs and PKIs
Parent topic: SSL and PKI Technology Primer
Previous topic: How do you know the certificate really came from the CA?
Next topic: Root and Subordinate CAs


Root and Subordinate CAs

If there were only a few CAs in the world, they would soon become overloaded. In fact, there are many. But how does a new CA show its trustworthiness? Usually, by applying for and being granted a certificate from one of the established CAs. A CA certified by another is called a subordinate CA.

A CA that is not certified by any other, but relies solely on its own reputation, is called a root CA. Even a root CA needs a certificate (we'll see below why), and the format of a certificate requires that it be signed, so they create and sign their own certificate. This is called a self-signed certificate or a root certificate.

Similarly, in a large organization, there might be subordinate CAs - for example, each department might run its own CA, each certified by the organization's root CA.

Also, a big CA such as those on the Internet might find that to cope with demand they need several CA machines. Each of these is a subordinate CA, with a certificate granted by one root CA machine.

A subordinate CA can itself certify subordinate CAs, so the standard format for a certificate includes a record of a chain of CAs, each certified by the next, back to a root CA. This chain of certificates is called the certification path. Thus a PKI is hierarchical. You trust the certificate if you know and trust any of the CAs on the certification path.

So in contrast to the web of trust described earlier, a PKI is a tree of trust, with one or more root CAs at the top, subordinate CAs below them and the actual users (client or server) at the bottom.

In a minor departure from this hierarchical nature, CAs can also cross-certify each other. For example, two government departments might each have its own PKI, with its own CA. Within each department, every member has been vetted and then certified by the relevant CA. They might then find that members of the two departments frequently need to communicate with each other. To establish trust between all the members of the two departments, effectively linking the two PKI's into one, all that is needed is for the two CAs to grant each other certificates.

Parent topic: CAs and PKIs
Parent topic: SSL and PKI Technology Primer
Previous topic: What is a PKI?
Next topic: How Do you Check a Certificate?


How Do you Check a Certificate?

We said above that the SSL software compares a certificate to a list of known CAs. We'll describe more precisely what happens.

A CA itself has a certificate - a self-signed one in the case of a root CA. Your SSL software can store certificates (known as installing a certificate), and typically comes with the certificates of a number of well-known CAs already installed. You can install more, if you come across more CAs you wish to trust. Also, there may be periodic updates - for example, the automatic updates that Microsoft send out for Windows XP sometimes install additional CA certificates in Internet Explorer.

When your SSL software receives an entity's certificate as part of a handshake, it compares the hierarchy of CAs named in the certificate to the installed CA certificates. If any in the hierarchy matches any in the installed list, then the entity is considered to have been certified by a known and trusted CA.

Your SSL software also needs to check that the CA's digital signature in the entity's certificate is genuine. Remember that to check a digital signature your SSL software decrypts it using its owner's public key, and then compares the resulting decrypted hash with the hash that the SSL software has itself worked out from the message (in this case the entity's certificate). The SSL software obtains the CA's public key from the CA's certificate.

Parent topic: CAs and PKIs
Parent topic: SSL and PKI Technology Primer
Previous topic: Root and Subordinate CAs
Next topic: Certificate Validity Period and Revocation


Certificate Validity Period and Revocation

Optionally, a certificate can contain start and end dates, when it starts and ceases to be valid. End dates are especially common, since most CAs consider it good policy to require a certificate to be renewed from time to time. Not only does it enable them to check that the holder is still genuine, but it enables them to charge for renewing the certificate.

It is sometimes necessary for a CA to revoke a certificate, for example if the holder's matching private key is lost or revealed, or if the CA ceases to consider the holder trustworthy. There are two ways a CA can do this. Both have shortcomings.

The first is to maintain a certificate revocation list (CRL), which it makes remotely accessible. A CRL can be installed in SSL software, for example in a browser, and when the SSL software is examining a certificate to see if it is trustworthy, part of the procedure is to see if the certificate is on any of the installed CRLs.

This approach has the problem that CA updates are issued periodically, so there is a delay between a CA deciding to revoke a certificate and the fact appearing in the latest issue of the CRL.

A more recent solution is for the CA to provide online certificate status - meaning that SSL software checking a certificate can contact the CA's server online and get a signed response saying whether the certificate has been revoked. The Online Certificate Status Protocol (OCSP) has been introduced for this.

This approach has the problem that it puts a high load on the CA's server.

Parent topic: CAs and PKIs
Parent topic: SSL and PKI Technology Primer
Previous topic: How Do you Check a Certificate?
Next topic: Types of Certificates - Purpose


Types of Certificates - Purpose

CAs issue different kinds of certificates, differing in what kind of checks the CA has made on the owner and consequently what purpose the certificate serves - in what roles it guarantees the owner as trustworthy. For example:

  • Typically, a CA issues its own root CA machine with a self-signed root certificate
  • If you are the owner of a Web site accessed by the general public, you can request a server identification certificate (server certificate for short), confirming to your clients the identity of your server
  • If you are engaged in business-to-business communications (B2B), you will probably want a client certificate, confirming the identity of your site

Exactly what the certificate certifies - in other words, its purpose - is stated in the certificate.

Parent topic: CAs and PKIs
Parent topic: SSL and PKI Technology Primer
Previous topic: Certificate Validity Period and Revocation
Next topic: Authentication Modes


Authentication Modes

In a client/server scenario, it may be that only the server has a certificate, so that the clients can confirm the identity of the server; or it may be that clients too are required to have certificates, so that the server can identify their identities.

If only the server has a certificate, the online service is said to be operating in server-only authentication mode. If the clients too have certificates, the service is operating in full authentication mode.

If as a Web site owner you want the benefits of non-repudiation, that is, you want to be able to prove that data really was sent to you from a particular client, then you should use full authentication.

Parent topic: CAs and PKIs
Parent topic: SSL and PKI Technology Primer
Previous topic: Types of Certificates - Purpose
Next topic: Typical Process


Typical Process

Here's a brief, simplified overview of what typically happens when you contact a secure Web site, that is, one using SSL. Let's say you are a Web user contacting your online bank.

In the following, remember that a symmetric algorithm is normally used to encrypt the data itself, while an asymmetric algorithm is used only to send the secret key for the symmetric algorithm.

In the following, we refer to "your browser" and "the bank's server". Of course we mean the SSL software in each.

  1. You enter the URL of the bank's login page.
  2. Your browser sends a list of symmetric algorithms it can support to the bank's server, and requests the bank's certificate.
  3. Their server replies saying which symmetric algorithm to use, and sends the requested certificate. It also sends a random number to be used in generating the secret key.
  4. Your browser checks the hierarchy of CAs shown in the bank's certificate against the CA certificates you've got installed. If there is no match, the browser flags a warning.
  5. If there is any match, the browser checks the bank's certificate against the CA that issued it, typically making the following checks and flagging a warning if any fail:
    • Checks the CA's digital signature in the bank's certificate.

      Remember this signature is the encrypted hash of the bank's certificate - encrypted using the CA's private key. Your browser gets the CA's public key from the CA's certificate, and uses it to decrypt the signature, thus getting back the hash. Your browser then itself hashes the bank's certificate, and checks the two hashes match.

    • Checks the start and expiry dates in the certificate to confirm the certificate is current.
    • Checks the URL in the certificate is exactly the same as the URL DNS name of the machine that sent the Web page.
    • Checks in the CA's certificate revocation list (CRL), or contacts the CA's server using OCSP, to see if the certificate has been revoked.
  6. Your browser generates a random number, encrypts it with the asymmetric algorithm using the bank's public key, and sends it to the bank's server.
  7. The bank's server uses the bank's private key to decrypt the random number the browser sent.
  8. Your browser and the bank's server now independently calculate the secret key from the two random numbers.
  9. As a final check, your browser and the bank's server send each other MACs of all the above messages, and check them to ensure no attacker has altered any of the messages.
  10. Your browser and the bank's server can now send each other your data confidentially, using the chosen symmetric algorithm.
Parent topic: CAs and PKIs
Parent topic: SSL and PKI Technology Primer
Previous topic: Authentication Modes


Checking, Exporting and Importing Certificates Overview

  • Viewing Certificates
  • Checking a Certificate
  • Exporting a Certificate from Internet Explorer
  • Importing a Certificate into Mozilla Firefox
Parent topic: SSL and PKI Technology Primer
Parent topic: SSL and PKI Technology Primer
Next topic: Viewing Certificates


Viewing Certificates

There are probably some certificates already installed on your machine. Applications that use SSL, such as a Web browser, usually come with certificates for well-known Web sites and CAs. New certificates for Web sites with newly established reputations are often included in the regular updates that are published for the applications.

  • With Internet Explorer
  • With Mozilla Firefox
Parent topic: Checking, Exporting and Importing Certificates Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: Checking, Exporting and Importing Certificates Overview
Next topic: With Internet Explorer


With Internet Explorer

If your browser is Internet Explorer:

  1. Click Tools > Internet Options > Content.
  2. Click Certificates and then the Trusted Root Certification Authorities tab on the far right.

    This lists the root CAs known and trusted by your Web browser - that is, the CAs whose certificates have been installed in the SSL software in your Web browser. A default set of these, consisting of many of the world's best known ones, is installed when Internet Explorer is installed.

    The terminology used in Internet Explorer is slightly different from that used in this book, as follows:

    Internet Explorer | This book
    Personal certificate | Your client certificate
    Other people's | Client or server certificate of some other entity
    Intermediate CA | Subordinate CA
    Trusted root CA | Root CA
  3. Double-click any one of the certificates shown. This displays the certificate on the screen. In many cases the "Issued To" and "Issued by" names are the same, indicating a self-signed certificate - one issued by a root CA to itself.
  4. Double-click one of the certificates. This displays the certificate. Notice that the "Issued To" and "Issued by" names are the same. This is what you would expect from a self-signed certificate - one issued by a root CA to itself.
  5. Click the Certification Path tab. This lists the chain of CAs from the certificate back to the root CA. Because this certificate is for a root CA, there is just one entry.
  6. Click OK to close the certificate.
  7. Click the Intermediate Certification Authorities tab. This shows a list of subordinate CAs whose certificates have been installed in your Internet Explorer.
  8. Double-click one of the certificates.
  9. Click Certification Path. You now see the chain of CAs, from the subordinate CA that issued this certificate, back up through the hierarchy to the root CA.
  10. Close the dialog boxes.
Parent topic: Viewing Certificates
Parent topic: SSL and PKI Technology Primer
Previous topic: Viewing Certificates
Next topic: With Mozilla Firefox


With Mozilla Firefox

If your browser is Mozilla Firefox:

  1. Click Tools > Options > Advanced. Then, depending on your version, either scroll down and click Manage Certificates, or click the Security tab and then View Certificates.
  2. Click the Authorities tab. This lists the CAs known and trusted by your Web browser - that is, whose certificates have been installed in the SSL software in your Web browser. A default set of these, consisting of many of the world's best known ones, is installed when Firefox is installed.
  3. Double-click any one of the certificates shown. This displays the certificate on the screen. In many cases the "Issued To" and "Issued by" names are the same, indicating a self-signed certificate - one issued by a root CA to itself.
  4. Click the Certification Path tab. This lists the chain of CAs from the certificate back to the root CA. If this certificate is for a root CA, there is just one entry.
  5. Click OK to close the certificate.
  6. Look at some other certificates in the same way. You may find that all the certificates are for root CAs. If you find one for a subordinate CA, you can see the chain of CAs, from the subordinate CA that issued this certificate, back up through the hierarchy to the root CA.
  7. Close the dialog boxes.
Parent topic: Viewing Certificates
Parent topic: SSL and PKI Technology Primer
Previous topic: With Internet Explorer
Next topic: Checking a Certificate


Checking a Certificate

Frauds have sometimes been perpetrated in which fake Web sites masquerade as genuine sites - when you think you are connecting to the genuine site, for example your online bank, you are in fact diverted to a fraudulent one designed to look like it, and trick you into revealing your confidential details. This kind of fraud is called "phishing".

As a safeguard against this, you can view the certificate of the site you are connecting to.

  • With Internet Explorer
  • With Mozilla Firefox
Parent topic: Checking, Exporting and Importing Certificates Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: With Mozilla Firefox
Next topic: With Internet Explorer


With Internet Explorer

If your browser is Internet Explorer:

  1. Go to the Web site for any online entity that needs secure communications, such as an online bank.
  2. Follow the links to the first logon page. You do not need to logon.
  3. Look at the URL. You should find that it begins with https instead of http. HTTPS is Secure HTTP, the version of HTTP that uses SSL.
  4. Look at your Web browser's status line. You should see a symbol like a padlock. This shows that communications on this page use SSL.

    Some pages contain both secure (that is, encrypted) and insecure (unencrypted) information. If you view such a page, your browser might display a warning to this effect, and ask you if you want to continue. If you choose to continue, the padlock symbol disappears, because Internet Explorer does not treat such pages as secure. You will need to try some other HTTPS page to continue with this tutorial.

  5. Double-click the padlock symbol. This displays the entity's certificate.

    Click the Certification Path to show the hierarchy of CAs from the one that issued the certificate up to the root CA.

    A Web site that was masquerading as the one you believe you've contacted could not fake a certificate, because no reputable CA, having checked up on them, would sign a certificate for them. And since the list of CAs in your browser includes only genuine, reputable CAs, there will be no match and your browser will reject their certificate.

    However, even for the most respectable organizations, you will sometimes find warning messages on the General tab saying that in some respects the certificate is faulty. This is because some detail on the certificate is incorrect - for example, the expiry date may have passed. It is up to you to look at the details on the certificate, and decide whether you trust the Web site despite this flaw.

Parent topic: Checking a Certificate
Parent topic: SSL and PKI Technology Primer
Previous topic: Checking a Certificate
Next topic: With Mozilla Firefox


With Mozilla Firefox

If your browser is Mozilla Firefox:

  1. Go to the Web site for any online entity that needs secure communications, such as an online bank.
  2. Follow the links to the first logon page. You do not need to logon.
  3. Look at the URL. You should find that it begins with https instead of http. HTTPS is Secure HTTP, the version of HTTP that uses SSL.
  4. Look at your Web browser's status line. You should see a symbol like a padlock. This shows that communications on this page use SSL.

    Some pages contain both secure (that is, encrypted) and insecure (unencrypted) information. If you view such a page, your browser should display a warning to this effect, and ask you if you want to continue. If you choose to continue, the padlock symbol appears with a line through it, because Firefox does not treat such pages as secure. You can still view the certificate though.

  5. Double-click the padlock symbol.
  6. On the Page Info dialog box that appears, click View. This displays the entity's certificate. If you click the Details tab, you will see the hierarchy of CAs from the one that issued the certificate up to the root CA.

    A Web site that was masquerading as the one you believe you've contacted could not fake a certificate, because no reputable CA, having checked up on them, would sign a certificate for them. And since the list of CAs in your browser includes only genuine, reputable CAs, there will be no match and your browser will reject their certificate.

    However, even for the most respectable organizations, you will sometimes find warning messages on the General tab saying that in some respects the certificate is faulty. This is because some detail on the certificate is incorrect - for example, the expiry date may have passed. It is up to you to look at the details on the certificate, and decide whether you trust the Web site despite this flaw.

Parent topic: Checking a Certificate
Parent topic: SSL and PKI Technology Primer
Previous topic: With Internet Explorer
Next topic: Exporting a Certificate from Internet Explorer


Exporting a Certificate from Internet Explorer

To export a certificate from Internet Explorer in the appropriate format, ready for importing into Firefox:

  1. In Internet Explorer click Tools > Internet Options.
  2. Go to the Content tab and double-click Certificates.
  3. Go to the Trusted Root Certificate tab and find the certificates marked Verisign Trust Network. There are several notable features of these certificates:
    1. There are multiple certificates and each one is unique.
    2. These different types of certificates are used to confirm the trust of different types of identification certificates.
    3. Some of these certificates have passed their expiry date. However they are still valid and should be present to prove the trust path for certificates that were signed during their working life span.
    4. Some of these certificates are direct replacements for expired or about-to-expire certificates.
    5. The life of the replacement certificates is typically far longer than that of the original certificates. Replacing certificates is problematic as it involves a significant amount of manual work and therefore distribution that is not often undertaken. To avoid the distribution complication it is in the interest of all identification certificate users to use certificates with a long life.
  4. Select a certificate and click Export.
  5. In Certificate Export Wizard, click Next.
  6. You choose the format required by your target browser. If you don't know the format required, you can generate a few of the most common formats and save them to different files, so that the correct format is available.

    Select DER encoded binary X.509 and click Next.

  7. Specify the %ProgramFiles%\Micro Focus\DemoCA\Verisign as the name of the file to export to and click Next.
  8. On the final screen notice:
    • Export Keys is always "No” when handling CA root certificates.
    • Include all certificates in the certification path is always “No” when using file formats that cannot support multiple certificates. When using a server certificate signed by an intermediate CA you would usually export the complete chain of trust back to the fully trusted CARoot. In this case we would have chosen a different format at step 6.
    • File Format should match the filename extension in most cases,. Although there are times when various subformats such as .p7b and .p7c are interchanged to aid portability of the generated output file.
  9. Click Finish > OK and the file appears in the chosen directory.
  10. Close all the open IE dialog boxes.
Parent topic: Checking, Exporting and Importing Certificates Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: With Mozilla Firefox
Next topic: Importing a Certificate into Mozilla Firefox


Importing a Certificate into Mozilla Firefox

  1. In Firefox, go to Tools > Options.
  2. Go to the Advanced tab and the Security sub-tab and click View Certificates.
  3. Go to the Authorities tab and click Import. Note that different tabs show different files without an extension indicating that they are native format
    • Files with a .p12 extension are shown without the extension when you import from the Your Certificates tab
    • Files with a .cer are shown without the extension when you import from the other certificate type tabs

    This emphasises the value of understanding how the different types of certificate usage affect the type of file being used to transport a certificate. Other certificate stores may have different rules about formats. It is worth investigating they destination locations requirements before attempting to create certificate files for their use.

  4. Specify the file that you exported from Internet Explorer.

    A message should popup telling you that this certificate already exists. This confirms that file was correctly formatted and read by the import tool.

Parent topic: Checking, Exporting and Importing Certificates Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: Exporting a Certificate from Internet Explorer


Certificates

  • Certificate and Key Formats
  • Don't Edit Certificates and Key Files
  • To Convert Certificate Formats
  • Multiple PEM Format Certificates
Parent topic: SSL and PKI Technology Primer
Parent topic: SSL and PKI Technology Primer
Next topic: Certificate and Key Formats


Certificate and Key Formats

Certificates are often known as X.509 certificates, since X.509 is the standard that defines their context and layout. The commonest algorithms for creating public and private keys are RSA and DSA, and keys are often referred to as RSA keys or DSA keys. None of these, however, define the format of the file in which a certificate or key is held. There are many rival formats for these files. Some of the commonest standard formats are:

  • DER. This format can contain private keys (RSA or DSA), public keys (RSA or DSA) and X.509 certificates. It is headerless. It is the default format for most browsers. A file can contain only one certificate. Optionally the certificate can be encrypted. The standard extension is .cer, but might be .der in some installations.
  • PEM. This format can contain private keys (RSA or DSA), public keys (RSA or DSA) and X.509 certificates. It is the default format for OpenSSL. It stores the data in either ASN.1 or DER format, surrounded by ASCII headers, so is suitable for sending files as text between systems. A file can contain multiple certificates. The standard extension is .pem.
  • PKCS#12. This is also known as PFX. This format can contain private keys (RSA or DSA), public keys (RSA or DSA) and X.509 certificates. It stores them in a binary format. The standard extension is .pfx or .p12.
  • PKCS #7. This is the Cryptographic Message Syntax Standard. A file can contain multiple certificates. Optionally they can be hashed. Optionally a certificate can be accompanied by a private key. As well as the original PKCS #7, there are three revisions: a, b, and c. The standard extensions for these four versions are .spc, .p7a, .p7b and .p7c respectively.
Parent topic: Certificates
Parent topic: SSL and PKI Technology Primer
Previous topic: Certificates
Next topic: Don't Edit Certificates and Key Files


Don't Edit Certificates and Key Files

You must never edit the contents of a certificate or keyfile. If you change anything within a certificate, any SSL software examining the certificate to authenticate your identity will detect it has been tampered with and declare it invalid.

A keyfile, and in certain circumstances a certificate file, will always be protected by its own security pass phrase. This pass phrase prevents certificate and key file management tools from making unauthorized access to the file content.

Parent topic: Certificates
Parent topic: SSL and PKI Technology Primer
Previous topic: Certificate and Key Formats
Next topic: To Convert Certificate Formats
Related information
Certificates


To Convert Certificate Formats

To convert certificate formats, use openssl.exe, as follows:

  • To convert binary-only PKCS7 (.p7 .p7a .p7b .p7c) files as output from Windows Internet Explorer Certificate Manager, with single or multiple certificate content, and generate human readable text content in the output file:
        openssl pkcs7 -inform DER -in filename.p7b -text -print_certs -out outfilename.pem

    For example:

    openssl pkcs7 -inform DER -in IECert.p7b -text -print_certs -out IECert.pem
  • To convert binary-only PKCS7 files as output from Windows Internet Explorer Certificate Manager, with single or multiple certificate content, and generate only binary content in the output file leave out the “-text” element:

openssl pkcs7 -inform DER -in filename.p7b -text -print_certs -out outfilename.pem

    Example:

    openssl pkcs7 -inform DER -in IECert.p7b -text -print_certs -out IECert.pem

    When handling many certificates in one file you might encounter issues of space being taken for the descriptive text content. In these circumstances you may wish to remove the text content, however this is not recommended for normal use as it make handling of the certificates harder because their content is not immediately viewable.

    Some applications do not accept X509v3 certificates when accompanied by a text description within the certificate file. You can overcome this for most applications, by editing the certificate to trim the text sections, but take care to leave intact the lines beginning and terminating the binary certificate data.

  • To convert PEM to PKCS#12 (to install in a Web browser or for storage):
    • If your PEM-format certificate and key are both in one file, use:
      openssl pkcs12 -export -in pem-cert-and-key-file -out pkcs12-cert-and-key-file
    • If they are in separate files, use:
      openssl pkcs12 -export -in pem-cert-file -inkey pem-key-file -out pkcs12-cert-and-key-file

    Both these commands put the certificate and keyfile into one file. If you intend to store your private key and certificate together in this fashion you should apply a pass phrase to the resultant file.

  • To convert PKCS#12 to PEM:

    • openssl pkcs12 -in pkcs-12-cert-and-key-file -out pem-cert-and-key-file
  • To convert ASN.1 PEM files to DER PEM :
    • If the PEM file contains DSA keys, use:
      openssl dsa -inform PEM -outform DER -in pem-file -out der-file
    • If it contains RSA Keys, use:
      openssl rsa -inform PEM -outform DER -in pem-file -out der-file
  • To convert DER (.cer in most implementations) to PEM:
    • If the DER file contains DSA keys, use :
      openssl dsa -inform DER -outform PEM -in der-file -out pem-file
    • If it contains RSA Keys, use:
      openssl rsa -inform DER -outform PEM -in der-file -out pem-file
Parent topic: Certificates
Parent topic: SSL and PKI Technology Primer
Previous topic: Don't Edit Certificates and Key Files
Next topic: Multiple PEM Format Certificates


Multiple PEM Format Certificates

Normally there is only one certificate in a file. OpenSSL generally assumes this is the case, so it ignores any after the first when handling server and client certificates.

However, a file can contain multiple PEM and PKCS7 format certificates. This is useful for storing a bundle of the root certificates of the CAs you trust, or a certificate verification chain. To use the certificates, you will need to split the file into one file per certificate.

You can split the file using a text editor, but you must take care to not change the data for each individual certificate. Each certificate takes the following format and is terminated by the END CERTIFICATE line:

optional-header-info
------BEGIN optional-text CERTIFICATE-----
...
------END optional-text CERTIFICATE-----

As long as you do not change or break up the data within the BEGIN and END lines, the certificate itself is complete. A certificate is rendered useless unless it retains its binary composition that was created when it was originally signed.

Parent topic: Certificates
Parent topic: SSL and PKI Technology Primer
Previous topic: To Convert Certificate Formats


Standards and Organizations

  • X.509
  • PKCS Standards
Parent topic: SSL and PKI Technology Primer
Parent topic: SSL and PKI Technology Primer
Next topic: X.509


X.509

The most important standard for PKI's is X.509, which defines the format and content of digital certificates and how to validate them. It is an International Telecommunications Union (ITU) Recommendation, published as ITU-T X.509 and ISO/IEC/ITU 9594-8.

Standards are still evolving, and different companies have implemented it in different ways. For example, Netscape and Microsoft both use X.509 certificates in their Web servers and browsers, but an X.509 certificate created by Netscape may not be readable by Microsoft products, and vice versa.

Parent topic: Standards and Organizations
Parent topic: SSL and PKI Technology Primer
Previous topic: Standards and Organizations
Next topic: PKCS Standards


PKCS Standards

There is a set of de facto cryptographic message standards called Public Key Cryptography Standards (PKCS) which were originally developed and are still maintained by RSA Laboratories. (For more detailed information, see the Web page at RSA Laboratories.

The standards that are most relevant to PKI are:

  • PKCS #7, Cryptographic Message Syntax Standard. A general syntax for data to which cryptography can be applied, such as digital signatures and encryption. It also provides a syntax for disseminating certificates or certificate revocation lists (CRLs).
  • PKCS #10, Certification Request Syntax Standard. Provides a format for a request for a certificate.
  • PKCS #12, Personal Information Exchange Syntax Standard. Primarily provides a format for storing keys or a certificate in a file.
Parent topic: Standards and Organizations
Parent topic: SSL and PKI Technology Primer
Previous topic: X.509
Related information
RSA Laboratories


Some Common Algorithms: Overview

This topic names some of the best known encryption algorithms, and describes how to choose what algorithm to use.

  • Algorithms and Key Lengths
  • Choosing an Algorithm
  • Symmetric Algorithms
  • Asymmetric Algorithms
  • Hashing
  • Digital Signatures
Parent topic: SSL and PKI Technology Primer
Parent topic: SSL and PKI Technology Primer
Next topic: Algorithms and Key Lengths


Algorithms and Key Lengths

Two things that your SSL software may let you choose are the algorithm and the key length to be used for encryption. One thing to consider in choosing is how easy the code will be to crack.

In general, for the same algorithm, the longer the key the harder the code is to break. This is simply because a would-be attacker can easily use a computer to try key after key until hitting on the right one. The longer the key, the longer it takes to generate all possible numbers of that length, looking for the right one. You need a key that is so long that even with the most powerful computers this would take an impracticably long time.

Of course, computers are constantly becoming more powerful. Therefore, the length of key considered necessary is constantly increasing as the years pass. At the time of writing (early 2005), a key length of 128 bits is generally considered adequate for reasonable security using a symmetric algorithm, while with an asymmetric algorithm 2048 bits is considered adequate.

Parent topic: Some Common Algorithms: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: Some Common Algorithms: Overview
Next topic: Choosing an Algorithm


Choosing an Algorithm

In choosing which algorithm to use, there are several factors to consider.

Cryptography, the invention of new algorithms and of ways to break the codes they create, is a branch of mathematics that is constantly advancing. Attempts to crack a particular algorithm are often undertaken by serious researchers anxious to confirm whether the algorithm is really secure.

It may be possible for an expert cryptographer to find a mathematical way of breaking an algorithm, or it may be vulnerable to a "brute force" attack - just trying different keys until the correct one is found.

Just because an algorithm has been cracked in the past does not necessarily mean you must not use it - you should consider whether your data is valuable enough to tempt a hacker to devote the resources that have been shown to be needed to crack it.

Two problems with all symmetric algorithms are that the key has to be known to both sender and receiver, and so it could be intercepted when being sent from one to the other; and that if the same key is used for all your messages, any eavesdropper who finds out the key can decrypt all your messages.

Parent topic: Some Common Algorithms: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: Algorithms and Key Lengths
Next topic: Symmetric Algorithms


Symmetric Algorithms

In this section we briefly describe some of the best-known symmetric (secret key) algorithms.

A symmetric algorithm that treats the message to be encrypted as a continuous stream of bits is called a stream cipher. A symmetric algorithm that splits the message up into chunks and encrypts each chunk is called a block cipher. The only stream cipher to have been widely used is RC4.

  • RC4
  • DES
  • Triple DES
  • AES
  • Blowfish
  • Twofish
Parent topic: Some Common Algorithms: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: Choosing an Algorithm
Next topic: RC4


RC4

RC4 was designed by Ron Rivest of RSA Security in 1987. It stands for "Rivest Cipher 4", or alternatively for "Ron's Code". RC4 is a widely-used cipher. (There are related algorithms RC2, RC5 and RC6.)

Parent topic: Symmetric Algorithms
Parent topic: SSL and PKI Technology Primer
Previous topic: Symmetric Algorithms
Next topic: DES


DES

One of the most well-known secret key algorithms is the US Data Encryption Standard (DES). It was published in 1977. In the past the US government encouraged users to adopt this as the main or only secret key algorithm in use. In 1998, it was shown that a dedicated hacker with moderate computer power can crack it (see EFF DES cracker project), but it is often considered secure enough for some trivial uses. It is to be replaced as a US standard by the Advanced Encryption Standard (AES).

DES uses a fixed key length of 64 bits. Of these, 8 are used for parity, so in effect the key is 56 bits long.

Parent topic: Symmetric Algorithms
Parent topic: SSL and PKI Technology Primer
Previous topic: RC4
Next topic: Triple DES
Related information
EFF DES cracker project


Triple DES

A variation on DES is simply to encrypt the message three times in succession, using DES. One long key is split into three shorter keys, one for each encryption, so the overall key length is three times that of regular DES. Triple DES is usually written as 3DES. It is considered secure enough for most uses

Parent topic: Symmetric Algorithms
Parent topic: SSL and PKI Technology Primer
Previous topic: DES
Next topic: AES


AES

This is US standard FIPS-197, and is designed as a replacement for DES. It uses an algorithm designed by Joan Daemen and Vincent Rijmen (see csrc.nist.gov/CryptoToolkit/aes/rijndael/Rijndael-ammended.pdf, and known as the Rijndael algorithm.

AES is currently considered secure for commercial use.

Parent topic: Symmetric Algorithms
Parent topic: SSL and PKI Technology Primer
Previous topic: Triple DES
Next topic: Blowfish
Related information
csrc.nist.gov/CryptoToolkit/aes/rijndael/Rijndael-ammended.pdf


Blowfish

This was developed by Bruce Schneier of Counterpane Labs. It is used in a great many products, and is standard in the OpenBSD operating system. For details see www.counterpane.com/blowfish.html.

Blowfish is currently considered secure for commercial use.

Parent topic: Symmetric Algorithms
Parent topic: SSL and PKI Technology Primer
Previous topic: AES
Next topic: Twofish
Related information
www.counterpane.com/blowfish.html


Twofish

This too was developed by Bruce Schneier, and is efficient when implemented in hardware and smart cards. For details see www.counterpane.com/twofish.html.

Twofish is currently considered secure for commercial use.

Parent topic: Symmetric Algorithms
Parent topic: SSL and PKI Technology Primer
Previous topic: Blowfish
Next topic: Asymmetric Algorithms
Related information
www.counterpane.com/twofish.html


Asymmetric Algorithms

The two best known asymmetric (public key) algorithms are D-H and RSA.

  • Diffie-Hellman (D-H)
  • RSA
Parent topic: Some Common Algorithms: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: Twofish
Next topic: Diffie-Hellman (D-H)


Diffie-Hellman (D-H)

Whitfield Diffie and Martin Hellman were the first to show, in a paper published in 1976, that a code could be devised that was encoded using one key and decoded using another.

James Ellis wrote a paper in 1970 on similar work done by himself and Clifford Cocks, but it was covered by the UK's Official Secrets Act, and was not published until many years later.

Using the Diffie-Hellman (D-H) algorithm, one key is specifically for encryption and the other for decryption - you can't use them the other way around. This makes it unsuitable for a PKI system as normally used.

Parent topic: Asymmetric Algorithms
Parent topic: SSL and PKI Technology Primer
Previous topic: Asymmetric Algorithms
Next topic: RSA


RSA

It was Ron Rivest, Adi Shamir, and Leonard Adleman who later developed an algorithm where you could use either key to encrypt. This is known as the RSA algorithm. This made possible the full use of asymmetric encryption for the purposes we have discussed - certificates, non-repudiation, etc, as well as confidentiality - and thus made PKI systems possible.

Parent topic: Asymmetric Algorithms
Parent topic: SSL and PKI Technology Primer
Previous topic: Diffie-Hellman (D-H)
Next topic: Hashing


MD5

This is probably the most commonly used hash function. It produces a 128-bit hash. It has largely superseded earlier MD functions (for example, MD2, MD4). It is defined in RFC1321.

MD5 has been shown to be vulnerable to collisions in some applications. It can still be used for most purposes in SSL, but SHA is now preferred for new applications.

Parent topic: Hashing
Parent topic: SSL and PKI Technology Primer
Previous topic: Hashing
Next topic: SHA
Related information
RFC1321


SHA

The Secure Hash Algorithm (SHA) is a US standard, developed by the National Institute of Standards and Technology (NIST). SHA-1 is a revised version, published in 1994. It produces a 160-bit hash, which is more secure than MD5's 128-bit hash. It is defined in RFC3174 .

There are several further revisions of SHA, described on the NIST Web site at www.csrc.nist.gov/cryptval/shs.htm.

It is expected that a revision of SHA will replace MD5 as the most popular hashing algorithm.

Parent topic: Hashing
Parent topic: SSL and PKI Technology Primer
Previous topic: MD5
Next topic: Digital Signatures
Related information
RFC3174
www.csrc.nist.gov/cryptval/shs.htm


Digital Signatures

As explained earlier, a digital signature on a message consists of an encrypted hash of the message - first the message is hashed, and then the hash is encrypted using the private key of the signatory (usually a CA).

The recipient can check the signature by decrypting it using the signatory's public key, then hashing the message him/herself and comparing the two results.

Many methods of hashing are possible, combining different encryption algorithms with different hashing algorithms. One is particularly worth mentioning.

  • Digital Signature Standard (DSS)
Parent topic: Some Common Algorithms: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: SHA
Next topic: Digital Signature Standard (DSS)


Digital Signature Standard (DSS)

This is a US standard. It specifies that SHA-1 is to be used for the hashing, and a specially designed asymmetric algorithm called Digital Signature Algorithm (DSA) is to be used for the encryption. DSA can only be used for signing, not for other encryption.

Parent topic: Digital Signatures
Parent topic: SSL and PKI Technology Primer
Previous topic: Digital Signatures
Related information
FIPS PUB 186


Definitions for OpenSSL

  • Overview
  • Base64 Encoding
  • SSLeay
Parent topic: SSL and PKI Technology Primer
Parent topic: SSL and PKI Technology Primer
Next topic: Overview


Overview

Abstract Syntax Notation number One (ASN.1) is a notation used extensively by standards committees and other bodies for defining protocols for use in data communications. It resembles a programming language, but consists mostly of features for defining data structures. There are various data types, and syntax for building up complex data structures out of these elementary types. You might think of a protocol specification written in ASN.1 as resembling the Data Division of a COBOL program, although the actual syntax of the language is more like C.

You may well never see an example of ASN.1, since it is for use in defining protocols, and even protocols themselves tend to be things that the user does not see directly. Nevertheless, ASN.1 is very widely used, and a great many electronic devices in every day use - from air traffic control systems to washing machines - use data transmission protocols that were designed using ASN.1.

Many of the standards used in SSL that we have been discussing were designed in ASN.1, and consequently you will sometimes come across ASN.1 terminology when reading about SSL. This is especially true of the documentation for OpenSSL. Although as an end-user, or as a COBOL developer, you are unlikely to come directly in contact with these concepts, you will find the OpenSSL documentation easier to follow if we explain some of them.

  • ASN.1 Compiler
  • Encoding Rules
  • Distinguished or Canonical Encoding Rules
  • Object Identifiers
  • Octets
  • UTF8String
  • Further Information
Parent topic: Definitions for OpenSSL
Parent topic: SSL and PKI Technology Primer
Previous topic: Definitions for OpenSSL
Next topic: ASN.1 Compiler


ASN.1 Compiler

People who are implementing protocols designed in ASN.1 often use an ASN.1 compiler, which translates a protocol specification from ASN.1 into source code in a programming language. For the C programming language, for example, the compiler would probably output a C header file (similar to a COBOL copyfile), for inclusion in a C program.

Parent topic: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: Overview
Next topic: Encoding Rules


Encoding Rules

A protocol specification in ASN.1 specifies the data structures in a source-like, human-readable way. It says nothing about how those data structures are to be represented when actually transmitted. The bodies responsible for defining ASN.1 have defined encoding rules, which specify how each data structure that you can specify in ASN.1 is to be represented as a bit pattern.

There are in fact several alternative sets of encoding rules that the committees have designed over the years. The earliest set is called the Basic Encoding Rules (BER), and a later one, which produces much more compact messages, is called the Packed Encoding Rules (PER).

Parent topic: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: ASN.1 Compiler
Next topic: Distinguished or Canonical Encoding Rules


Distinguished or Canonical Encoding Rules

Clearly a set of encoding rules must be such that any particular bit pattern corresponds to just one ASN.1 data structure - otherwise software receiving a message would not know which data structure to interpret the bit pattern as. However, the reverse is not necessarily the case - no ambiguity is caused if several different bit patterns can represent the same ASN.1 data structure.

Nevertheless, in some applications, if different bit patterns can represent the same ASN.1 data structure, it does cause problems. For these applications, it's desirable to have a set of encoding rules where each ASN.1 data structure converts to just one bit pattern, and vice versa. This is especially true in secure communications, because if you are digitally signing messages you need semantically equivalent messages to always have the same encoding.

Such a set of encoding rules is called canonical, or distinguished. Two such sets of rules have been developed - one was named the Distinguished Encoding Rules (DER) and the other was named the Canonical Encoding Rules (CER). CER has not caught on, and is very seldom used. However, the standard file extension for a file containing DER is .cer.

In reading documentation of OpenSSL, you will often see mentions of data stored in DER format.

Parent topic: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: Encoding Rules
Next topic: Object Identifiers


Object Identifiers

An important data type in ASN.1 is the object identifier. An object identifier (OID) is a reference number, unique in the world, that can be allocated to, in principle, any object; in practice, to any object that can be represented as a set of information. The object identifiers form a tree structure, which you can access at Object identifier tree. The branches of the tree are referred to as arcs, and various organizations have been allocated responsibility for assigning nodes in particular parts of the tree to anyone who requests one, to represent particular objects.

Each node has a number, and optionally, a name. An object's OID is the list of numbers representing the nodes in the tree from the root to that object's own node. They are normally shown enclosed in braces and separated by spaces. If a node's name is shown as well, the node's number is normally shown in parentheses. Only the numbers are intended to be machine-readable - the names are there to be human-readable.

Parent topic: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: Distinguished or Canonical Encoding Rules
Next topic: Octets
Related information
Object identifier tree


Octets

COBOL programmers are used to working with memory physically organized into groups of eight bits, and calling these groups bytes. However, in communications, where we are talking about a continuous stream of bits on the wire, each group of eight bits is called an octet.

The ASN.1 encoding rules define four types of octet: identifier octet, length octet, contents octet, and end-of-content octet. There's no need to go into detail here about exactly how these are used (it's different for different encoding rules anyway); it suffices to say that the contents octets contain the actual data, while the others are needed for the syntax of the encoded bit-stream.

Parent topic: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: Object Identifiers
Next topic: UTF8String


UTF8String

ASN.1 has a number of different string data types. They differ in the range of characters they can support, and in how many octets are used to represent each character.

The string data type you will see mentioned most often is the UTF8String. This is the best data type for internationalization. UTF8 stands for UCS Transformation Format, 8-bit (where UCS stands for Universal Character Set). It in fact uses a variable-length encoding. The original ASCII characters have exactly the same encoding as in ASCII itself, using 7-bits, and with the top bit set to zero. All other characters have the top bit set to 1. Because the encoding is variable length, all known characters can be represented.

Parent topic: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: Octets
Next topic: Further Information


Further Information

For detailed information on ASN.1, see ASN.1 Information Site

The formal standards documents on ASN.1 and its encoding rules are published by the International Telecommunications Union Telecommunications Sector (ITU-T) and International Standards Organization (ISO) / International Electrotechnical Commission (IEC).

Parent topic: Overview
Parent topic: SSL and PKI Technology Primer
Previous topic: UTF8String
Next topic: Base64 Encoding
Related information
ASN.1 Information Site


Base64 Encoding

The bit patterns produced by the encoding rules described above are unlikely, in general, to correspond to printable characters. But sometimes it's convenient to represent the encoded data in printable form. This can be done by converting it to base64 encoding.

Base64 is a scheme for converting binary data to printable ASCII characters, namely the upper- and lower-case Roman alphabet characters (A–Z, a–z), the numerals (0–9), and the "+" and "/" symbols, with the "=" symbol as a special suffix code.

The data's original length must be a multiple of eight bits. To convert data to base64, the first byte is placed in the most significant eight bits of a 24-bit buffer, the next in the middle eight, and the third in the least significant eight bits. If there are fewer than three bytes to encode, the corresponding buffer bits will be zero. The buffer is then used, six bits at a time, most significant first, as indices into the string "ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789+/" and each character thus selected is output.

This is repeated until the input data is exhausted. If at the end only one or two input bytes remain, then only the first two or three characters of the output are used, and the output is then padded with two or one "=" characters respectively. This prevents anyone adding extra bits to the reconstructed data.

The resulting base64-encoded data is approximately 33% longer than the original data, and typically appears as seemingly random characters.

Base64 encoding is specified in full in RFC 1421 and RFC 2045.

Many of the commands provided by the openssl.exe utility can convert between normal binary encoding and base64 encoding.

Parent topic: Definitions for OpenSSL
Parent topic: SSL and PKI Technology Primer
Previous topic: Further Information
Next topic: SSLeay


SSLeay

The Open SSL documentation occasionally mentions SSLeay, mainly where it needs to discuss compatibility of OpenSSL with SSLeay.

After SSL was first introduced by Netscape, an independent implementation of it was developed, the SSLeay library by Eric A. Young and Tim Hudson. This was released in 1995. OpenSSL is based on this SSLeay library.

Parent topic: Definitions for OpenSSL
Parent topic: SSL and PKI Technology Primer
Previous topic: Base64 Encoding


Attacks

  • Terminology
  • Brute Force Attack
  • Dictionary Attack
  • Replay Attack
  • Man-in-the-Middle Attack
  • Truncation Attack
Parent topic: SSL and PKI Technology Primer
Parent topic: SSL and PKI Technology Primer
Next topic: Terminology


Terminology

A message sent unencrypted is said to be in cleartext or plaintext. A message sent encrypted is said to be in ciphertext.

The US government used to restrict the strength of encryption it allowed to be included in software for export - beyond a certain strength, encryption is regarded as of military value. In January 2000 these restrictions were mostly removed. Nevertheless a lot of encryption software still exists that was designed in that period to be exportable. The term "export cipher" means an algorithm and key length designed to be exportable under these regulations.

The information given here is believed to be correct at the time of writing, but remember that typical computer power and legal requirements are constantly changing.

The word "cipher" is often used to mean an encryption algorithm. A particular algorithm with a particular key length is often referred to by the algorithm's abbreviated name followed by a hyphen and the key length. For example, RC4-40 means "Rivest Cipher 4 with 40-bit keys".

Short keys are usually called small or weak keys.

Parent topic: Attacks
Parent topic: SSL and PKI Technology Primer
Previous topic: Attacks
Next topic: Brute Force Attack


Brute Force Attack

This consists of simply going through every possible key, deciphering the ciphertext with each key, and trying to find some recognizable cleartext in the result. If you use a 128-bit key there are 2128 possible keys.

A would-be code-breaker would regard this type of attack as the last resort, to be used only if there is no feature - that is, weakness - of the cipher that makes possible some more intelligent attack. A cipher that forces the code-breaker to resort to this method is a strong cipher.

However, ciphers that use weak (small) keys are susceptible to brute force attack, in particular RC4-40, RC2-40 and DES-56. There have been many successful brute force attacks against RC4-40 since its release in February 1995.

A brute force attack against ciphers with 128 bits or more is probably impractical in the foreseeable future.

Parent topic: Attacks
Parent topic: SSL and PKI Technology Primer
Previous topic: Terminology
Next topic: Dictionary Attack


Dictionary Attack

This type of attack can be used when the attacker knows or guesses some part of your original message. In the case of a protocol, this may be easy - for example, in HTTP messages the "get" command often appears.

The attacker takes the known cleartext and encrypts it using every possible key. The resulting set of ciphertexts is saved. This set of saved ciphertexts is called a dictionary.

When the attacker gets hold of an encrypted message, he or she searches it for occurrences of any of these ciphertexts. When a match is found, then the key that gave that ciphertext must be the key that was used to encrypt the whole message.

SSL protects you from this kind of attack by using various technical measures that ensure the same plain text produces different ciphertext each time.

Parent topic: Attacks
Parent topic: SSL and PKI Technology Primer
Previous topic: Brute Force Attack
Next topic: Replay Attack


Replay Attack

In a replay attack, an attacker records an exchange of messages between a client and server and tries to recreate the exchange later by resending the client messages to the server.

To prevent this, SSL has a nonce number. This is a connection-id, which the server generates as a random number and sends to the client together with the server certificate. Since the nonce is different for each session, someone resending the old set of client messages cannot fool the server into thinking they are a new set. SSL nonces are 128 bits long.

Parent topic: Attacks
Parent topic: SSL and PKI Technology Primer
Previous topic: Dictionary Attack
Next topic: Man-in-the-Middle Attack


Man-in-the-Middle Attack

In a man-in-the-middle attack, an attacker intercepts messages and modifies them, and then passes them on to the intended recipient.

SSL's system of certificates and private keys prevents this. An attacker would have to fake a certificate and somehow get it signed with a CA's key.

Parent topic: Attacks
Parent topic: SSL and PKI Technology Primer
Previous topic: Replay Attack
Next topic: Truncation Attack


Truncation Attack

In a truncation attack, an attacker inserts into a message a TCP code indicating the message has finished, thus preventing the recipient picking up the rest of the message.

To prevent this, SSL from version v3 onward has a closing handshake, so the recipient knows the message has not ended until this has been performed.

Parent topic: Attacks
Parent topic: SSL and PKI Technology Primer
Previous topic: Man-in-the-Middle Attack


Designing a PKI

  • General Points
  • Client Certificates
  • Security
Parent topic: SSL and PKI Technology Primer
Parent topic: SSL and PKI Technology Primer
Next topic: General Points


General Points

  • Don't design a PKI with a particular application in mind - rather, think of it as a fundamental part of your organization's general data processing setup. If you design it for use with a particular application, you are likely to find it inflexible when you try to use it with other applications.
  • Authentication doesn't imply authorization. Just because someone has the necessary keys to access your data, that doesn't mean they necessarily should be allowed access to all your data. You should still have other mechanisms, for example an access control list (ACL), to ensure people can only access data appropriate to their position.
  • You should make people change their keys from time to time, by applying for new certificate/key pairs. That way if a private key is stolen without anyone noticing, at least it will become useless to the thief next time the certificate/key pair is changed.

    This applies to all private keys - client keys, server keys, subordinate CA keys, and root CA keys.

    The easiest way to enforce this is to include expiry dates in certificates.

  • There are many ways of structuring your tree of trust. Should there be just one root CA, or several? Should subordinate CAs be able to grant CA certificates to other subordinate CAs, or should only root CAs be able to do this?
  • Will your CAs sometimes need to revoke certificates? The commonest way to do this is for a CA to maintain a certificate revocation list (CRL), a list of certificates it has granted and later revoked (they can be deleted from the list once they expire). Users can obtain the CRL and install it in their SSL software.
  • Will users generate their own private keys? In some setups, the CA generates both the certificate and the private key for the user. This saves the ordinary user needing to know how to create a certificate signing request (many of the major CAs on the Web are willing to work in this way) but it means the private key must somehow be conveyed securely to the user. To obtain the maximum security benefit of asymmetric encryption - that the private key is never sent anywhere, so can't be listened in on - the user should him/herself use openssl.exe to create a private key and the matching certificate signing request, and send the latter to the CA, so the CA can create the certificate.
  • It may be an advantage to have all certificate requests handled by your subordinate CA machines. Then your root CA machine only needs to be online when you are using it to certify subordinate CAs. After that it can be taken offline, or at least its private key can be stored offline, until you need it to certify more subordinate CAs. This can greatly improve the security of the root CA, by reducing to a minimum the times when it could be accessed illicitly. It also means the users are not dependent on a single machine, the root CA machine, to keep functioning.

    It will still be possible - and simpler - to have your users install the root CA's certificate in their browsers (or whatever SSL-enabled software they use) rather than the certificates of all the subordinate CAs.

  • If you want really tight control, you might want to delete from your Web browser all the CA certificates that have been installed by default, and install just certificates of your own choosing - from your own CA, if you are setting up a private PKI. However you'd have to think carefully about the effect on accessing other Web sites outside your PKI.
  • If as a Web site owner you want the benefits of non-repudiation, that is, you want to be able to prove that data really was sent to you from a particular client, then you should use full authentication - you can if you wish generate client certificates for your clients (acting as a CA to this extent) and send the clients their certificates for them to store and use. Remember your clients will need to understand how to install these personal certificates in their software, e.g. their browsers.
  • It's worth pointing out a few features of the "world-wide" PKI used on the World Wide Web, which you may or may not choose to emulate in your own PKI:
    • It uses server-only authentication - although there's nothing to stop a particular online service arranging with its known clients that they should have to have certificates.
    • All CAs are equally trusted - there's no concept of some being trusted more than others.
  • When a certificate/keyfile pair is created, you can create pass phrases to protect them. It's essential to protect the keyfile in this way, because a private key is extremely sensitive information and every form of security available should be used to protect it. However, a certificate is intended to be available to anyone who wants to see it, so it's seldom appropriate to protect it in this way.

Parent topic: Designing a PKI
Parent topic: SSL and PKI Technology Primer
Previous topic: Designing a PKI
Next topic: Client Certificates


Client Certificates

In looking at certificates installed in Web browsers, you may have noticed that (using Internet Explorer terminology, but the situation is the same with any Web browser) the Personal and Other People's lists are empty or nearly empty, while the Intermediate CA and Trusted Root CA lists contain many entries.

This is a fairly typical situation. As an ordinary Web user, you probably don't actually need a certificate of your own - Web businesses such as online banks and shops generally use server-only authentication. As for Other People's, you could install server certificates sent to you by such online businesses, but it's generally unnecessary as these businesses send their certificates in the initial hand-shake of any communication session. It's much more necessary to have CA certificates installed, since these are needed to validate the certificates these businesses send you.

You might sometimes find it useful to install an entity's client certificate, if you communicate with them peer-to-peer rather than client/server.

Parent topic: Designing a PKI
Parent topic: SSL and PKI Technology Primer
Previous topic: General Points
Next topic: Security


Security

The security of your CA and RA machines is vital.

Remember you need to ensure reliability and availability, as well as confidentiality and trustworthiness.

Remember that SSL protects data only while it is in transit - once it has been received and stored, it is no longer encrypted, and so you need to look to other methods to ensure it remains confidential.

  • Controlling Network Access
  • Controlling Physical Access
  • Backups
Parent topic: Designing a PKI
Parent topic: SSL and PKI Technology Primer
Previous topic: Client Certificates
Next topic: Controlling Network Access


Controlling Network Access

You will of course need to protect your machines with a firewall and with virus scanning, and require any user accessing the machines remotely (if you allow this at all) to login, giving their user ID and password.

It's advisable to have the latest version of your operating system - the security features are usually improved at each upgrade.

Parent topic: Security
Parent topic: SSL and PKI Technology Primer
Previous topic: Security
Next topic: Controlling Physical Access


Controlling Physical Access

You should certainly require anyone using your CA and machines locally on to login, giving their user ID and password, and you should probably control access to the computer room too, so that no-one authorized can even get to the machine.

Also ask yourself about other ways an interloper could get in. Could someone insert an USB device between the printer and the system? Could someone run code from an I/O device? Could someone trick their way into your site by talking to the people who work there, finding out how they work, and emulating them?

Parent topic: Security
Parent topic: SSL and PKI Technology Primer
Previous topic: Controlling Network Access
Next topic: Backups


Backups

The private keys of your CA machines are vital. Keep them backed up to guard against accidental loss - but keep the backups every bit as secure as the system itself, to guard against them being stolen.

Parent topic: Security
Parent topic: SSL and PKI Technology Primer
Previous topic: Controlling Physical Access


Mainframe Support for Deployed Applications

  • MSS Configuration and Administration
    Mainframe Subsystem Support (MSS) enables CICS, IMS and JCL applications that have been migrated from the mainframe to be maintained, developed and deployed on Windows or UNIX.
  • Reference for MSS Deployment
    Contains information on general and CICS commands, data conversion, resource definitions, and supplied transactions.
Parent topic: Deployment


MSS Configuration and Administration

  • Introduction to Mainframe Subsystem Support
  • Assembler Support
  • CICS Support
  • IMS Support
  • JCL Support
  • Using Fileshare
  • Running EZASOKET Applications on Enterprise Server
Parent topic: Mainframe Support for Deployed Applications


Introduction to Mainframe Subsystem Support

  • What is Mainframe Subsystem Support?
  • Licensing
  • Developing and Testing the Application
  • Running the Application
  • Event Manager
  • About SSTM
    Describes the Subsystem Started Task Manager
  • To enable JCL support from a CICS or IMS subsystem
    Describes how to enable JCL support from within a CICS or IMS subsystem.
  • Security implications with the SSTM subsystem
    Describes the access rights that the user ID needs in order to use SSTM
  • SSTM subsystem status messages
    Describes status messages associated with the SSTM subsystem
Parent topic: MSS Configuration and Administration


What is Mainframe Subsystem Support?

Mainframe Subsystem Support (MSS) is a facility that enables CICS, IMS and JCL applications that have been migrated from the mainframe to be maintained, developed and deployed on Windows or UNIX platforms.

You use the COBOL development system Studio Enterprise Edition for maintaining your CICS, IMS and JCL applications. If you are working with CICS, you can edit and compile BMS maps, and also compile the CICS programs, using the Micro Focus CICS preprocessor, which translates the CICS commands into native code. If you are working with IMS, you can edit and generate your DBDs, MFSs and PSBs, and compile your IMS programs. If you are working with JCL, you can edit and create JCL, and build projects containing the programs that the JCL references. When the application is ready to run, you then deploy it to the COBOL run-time server Server Enterprise Edition.

You use Server Enterprise Edition for running your CICS, IMS and JCL applications, for testing and for production use. Server Enterprise Edition also provides facilities for monitoring and controlling your applications and for other tasks such as maintaining CICS resource definitions and viewing the system catalog and spool queues.

Parent topic: Introduction to Mainframe Subsystem Support


Licensing

For information about development licensing, see your Licensing topics. For information about deployment licensing, see Deployment Licensing.

Parent topic: Introduction to Mainframe Subsystem Support


Developing and Testing the Application

The process used by developers using Studio Enterprise Edition as the development environment with Enterprise Server as the deployment environment is as follows:

  1. Use Studio Enterprise Edition to maintain and compile BMS mapsets for CICS or generate DBDs, MFSs and PSBs for IMS.
  2. Use Studio Enterprise Edition to maintain resource definitions.
  3. Maintain and compile CICS, IMS and batch programs in Studio Enterprise Edition.
  4. If the target deployment platform is UNIX, they use the Studio Enterprise Edition Publish option to publish the application to UNIX.
  5. They deploy the application to Enterprise Server.
  6. They debug the application in the Studio Enterprise Edition IDE.

Steps 3 through 6 need to be repeated as required to get the application working correctly.

Developers need to have some familiarity with running programs in Server Enterprise Edition and the facilities provided therein specifically for monitoring CICS, IMS and JCL applications.

Note:

As Enterprise Server only supports upper case API names, care has to be taken when making calls with lower or mixed case names. This is particularly relevant with applications that have been developed on case sensitive operating systems such as UNIX. This problem can be avoided by using the NOCASE directive when compiling the application. This instructs the COBOL compiler to convert external symbols to upper case.

In the case where, for example, an IMS application uses lower or mixed case API names and has moved to a UNIX platform but must also issue calls to platform specific lower or mixed case APIs', the CASE directive can be used, provided the IMS specific symbols are converted from lower or mixed case to upper case.

Parent topic: Introduction to Mainframe Subsystem Support


Running the Application

Once the application is working correctly, administrators look after the running and monitoring of the application in Enterprise Server. They need to:

  • Maintain resource definitions for CICS; they can do this in the development environment. The format is portable between environments. There are also import and export tools which enable the downloading of the definitions into a text file for more convenient editing.
  • Control and monitor the running of the application, within the context of Enterprise Server.

The administration tool ESMAC, Enterprise Server Monitoring and Control, provides facilities for maintaining resource definitions and monitoring and controlling CICS, IMS and JCL applications. Many of its facilities are also available for non-MSS applications running in Enterprise Server. For detailed information about running CICS, IMS and JCL applications in Enterprise Server, see the chapters Administering CICS-enabled Enterprise Servers , Administering IMS-enabled Enterprise Servers and Administering JCL-enabled Enterprise Servers.

You also need to use facilities in the main Enterprise Server interface. For more information see the main Enterprise Server Configuration and Administration Guide .

Parent topic: Introduction to Mainframe Subsystem Support


Event Manager

The JCL support in Mainframe Subsystem Support includes an event manager, which provides support for third-party products such as schedulers.

When an enterprise server is started, it can call a user exit program, which on this first call can register an interest in particular types of events (for example, abends). Then whenever an event of any of the registered types occurs, the event manager will call the user exit program to process it. This user exit program can be a third party tool, such as a scheduler.

For further information, please contact your sales representative.

Parent topic: Introduction to Mainframe Subsystem Support


About SSTM

The Subsystem Started Task Manager (SSTM) provides full JCL functionality within the CICS and IMS subsystems. This JCL functionality is equivalent to that of a task started under z/OS. Each subsystem type runs as follows:

  • A CICS (MSS) Region typically uses more than one SEP to process online transactions. In the CICS region, each SEP runs the same JCL using the same job name and number. Within the region, all CICS SEPs JCL job activities and their outputs can be found under this one job number.

    All of the CICS SEPs:
    • Share permanent datasets whether these are allocated via the JCL or via SVC99. The system does not provide any access serialization capabilities. Any non-read access to shared datasets must be serialized, if necessary, by the user.
    • Do not share in-stream (DD * and DD DATA) datasets
    • Do not share other datasets (temporary and SYSOUT datasets).
    • The joblog dataset will contain JCL logged activity incurred by all CICS SEPs with identification of the originating SEPs process id.
  • An IMS subsystem uses one SEP for each Message Processing Region (MPR) and will typically have more than one MPR. Each MPR has a unique job number, but will very lilely have the same job name. Each MPR’s activity and outputs are independent as with batch jobs, and can be found under the MPR’s job number.
Parent topic: Introduction to Mainframe Subsystem Support


To enable JCL support from a CICS or IMS subsystem

In the Enterprise Server (ES) configuration, you enable JCL support by setting the ES_SSTM_ssss environment variable to a fully qualified path to the JCL used to initialize the SSTM Environment. In the environment variable,ssss is CICS or IMS depending on the environment that you want to initialise.
Note: The specified JCL job stream must contain only one step. A multiple step job is treated as an error and will fail SSTM initialization.
Note: Setting the SSTM is required for the CICS spooling facility. That is, if you want to use the CICS SPOOLOPEN OUTPUT, SPOOLWRITE, SPOOLCLOSE commands, etc.
From the Enterprise Server Administration Console, set the ES_SSTM_ssss to the fully qualified path of the JCL used to initialize the SSTM Environment.

Example settings

  • CICS environment:
    ES_SSTM_CICS=c:\es\sstm\jcl\sstmcics.jcl
  • IMS environment:
    ES_SSTM_IMS=c:\es\sstm\jcl\sstmims.jcl
The following is an example JCL code for CICS. In the code:
  • The program name in the PGM= entry must be syntactically correct, but it does not need to exist.
  • The DD OUTJCL is shared across CICS SEPs. The other DDs in the example are not shared, and are local to each SEP.
//SSTMJCL JOB 'CICS JOB',MSGCLASS=A
//CICS     EXEC PGM=NOTUSED
//SYSOUT   DD SYSOUT=*
//SYSPRINT DD SYSOUT=*
//TEMPJCL  DD DSN=&&TEMPJCL,DISP=NEW
//OUTJCL   DD DSN=CICS.SSTM.OUTJCL,DISP=(MOD,CATLG)
//INTRDR   DD SYSOUT=(*,INTRDR)
Parent topic: Introduction to Mainframe Subsystem Support


Security implications with the SSTM subsystem

The user ID under which the Enterprise Server session runs requires sufficient authority to submit and execute JCL. Any writes that the JCL makes to the internal reader via a CICS trancode are submitted as the currently logged on user. If no-one is logged on, these are submitted as Default CICS User ID.

Note: If you have overridden your Default CICS User with another user ID, or you have created a new Default CICS User ID, then you need to ensure that this user ID has sufficient authority to submit and execute JCL.
Parent topic: Introduction to Mainframe Subsystem Support


SSTM subsystem status messages

JES000040I SSTM environment established successfully.!
Indicates that the SSTM environment initialized successfully.
JES000041E SSTM initialization failure %1$s!
Indicates likely JCL errors. Check the appropriate job log and console log for additional information. Appropriate CTF traces will contain information that may help in diagnosing the problems.
JES000042I SSTM not enabled: %1$s!
Either you chose not to initialize SSTM environment, or you have misspelled the environment variable name.
Parent topic: Introduction to Mainframe Subsystem Support


Assembler Support

  • To turn on Assembler support for CICS-enabled enterprise servers
  • Configuring Runtime Memory Requirements
Parent topic: MSS Configuration and Administration


To turn on Assembler support for CICS-enabled enterprise servers

To turn on Assembler support for a CICS-enabled enterprise server:

  1. On the Enterprise Servers Administration page, click Edit in the row for the server for which you want to enable Assembler support.
  2. Select the General tab and type the following in the Configuration Information section:
    [ES-Environment]

ES_MFASM_SUPPORT=Y
  3. Click Apply and then OK.
Parent topic: Assembler Support
Parent topic: Configuring CICS-enabled Enterprise Servers


CICS Support

  • Installation Verification
  • Configuring CICS-enabled Enterprise Servers
  • Resource Definitions
  • Configuring CICS for Security
  • Configuring CICS for Databases
  • Intersystem Communication
  • Setting Up Communications with Mainframe CICS Regions
  • Configuring CICS Terminals and Printers
    Describes how to set up and configure terminals and printers for the CICS support in Server Enterprise Edition.
  • CICS Web Interface Support
  • Modernizing CICS Applications
  • Administering CICS-enabled Enterprise Servers
  • MSS Aspects of Troubleshooting
  • CICS Support Tasks
Parent topic: MSS Configuration and Administration


Installation Verification

This chapter describes the installation verification procedure (IVP) you can use to check that the Mainframe Subsystem Support software is installed and working properly. The installation verification procedure involves starting an enterprise server and terminal emulation, signing on and running a transaction.

The steps involved in running the installation verification procedure are:

  1. Start Enterprise Server Administration
  2. Import an enterprise server: the installation software comes with an enterprise server configuration file that you can import and use for installation verification.
  3. Start the enterprise server
  4. Connect to the enterprise server
  5. Run the installation verification procedure

Unless stated otherwise, the information in the related topics applies whether you are running the installation verification procedure under Enterprise Server for UNIX or Enterprise Server for Windows.

  • Starting Enterprise Server Administration
  • Configuring an Enterprise Server
  • Importing the Installation Verification Enterprise Server
  • Starting the Enterprise Server
  • Connecting to the Enterprise Server
  • Running the Installation Verification Procedure
Parent topic: CICS Support


Starting Enterprise Server Administration

To start Enterprise Server Administration from within Visual Studio, click Micro Focus Servers in the Server Explorer pane and select Administration from the drop-down menu.

To start Enterprise Server Administration from the Start menu. Click Start > All Programs > Micro Focus Server Enterprise Edition x.x > Enterprise Server Administration.

Parent topic: Installation Verification


Configuring an Enterprise Server

Once you have started Enterprise Server Administration, you need to configure an enterprise server to enable it to run CICS applications and to specify the location of the files it will need.

To configure an enterprise server for use with the installation verification procedure:

  1. In the table of servers on the Home page of Enterprise Server Administration, click Edit to the left of the row for the server that you want to edit.
  2. On the Server > Properties > General tab in the Configuration Information, type an environment specification for locating the CICS files into. For example, if your project files are all in subdirectories under c:\tutorials\CICS, type:
    [ES-Environment]
CICSPROJ=c:\tutorials\cics

    This sets a value for $CICSPROJ.

  3. Click Properties > MSS.
  4. Specify DFH\$IVP in System Initialization Table.

    Note the use of the slash (\) character to escape the dollar sign.

  5. Specify the location of the transaction programs in Transaction Path, for example:

    $CICSPROJ\mto-bms\debug

  6. Specify the location of the data files in VSAM File Path, for example:

    $CICSPROJ\mto-bms

  7. Specify the location of the BMS maps in Map Path, for example:

    $CICSPROJ\mto-bms

  8. Click OK.

    At this point you have enabled CICS support for this enterprise server and specified the location of the relevant files. The directory names used in the examples above are for illustration only - you should change them to use the directories in which the installation verification procedure files are installed on your system.

  9. Click the Listeners tab.
  10. Click Add in the Listeners column for Communications process 1.
  11. Specify the following information to enable you to use a TN3270 emulator:
    Field | Value
    Name | tn3270
    Endpoint address | *.nnnn, where nnnn is between 5000 and 65535. Check with the system administrator to ensure you choose a number that is not used by other applications.
    Supported Conversation Type | Check TN3270
  12. Click Add.
Parent topic: Installation Verification


Importing the Installation Verification Enterprise Server

The installation software comes with an Enterprise Server configuration file. You can import this file and use the server that it configures for installation verification.

To import the Enterprise Server installation verification configuration file:

  1. On the Enterprise Server Administration screen, under Actions at the left, click Import to display the Import server information screen. The Recent Directories field displays two entries. For example, with Windows XP, the verification enterprise server entry is:

    C:\Documents and Settings\All Users\Application Data\Micro Focus\NetExpress\6.0\MFDS\MSSIVP\

  2. Select the verification enterprise server entry and click Select and then click Next.
  3. Click Next three more times to accept the default settings, then on the Import server information (Page 4 of 4) screen, click OK.
  4. Select the Listeners tab, and verify the following information to enable you to use a TN3270 emulator:
    Field | Value
    Name | tn3270
    Endpoint address | The default endpoint address is 9010. Check with the system administrator that this is not used by other applications. If it is, configure another endpoint address to use.
    Supported Conversation Type | Check TN3270
Parent topic: Installation Verification


Starting the Enterprise Server

Having enabled the enterprise server for CICS applications and specified the location of the files required for the installation verification procedure, the next step is to start the enterprise server.

To start the enterprise server for use with the installation verification procedure:

  1. In the table of servers on the Home page of Enterprise Server Administration, find the row for the server that you want to start, and click Start in the Current Status column.

    The value in Current Status changes to "Starting". If you have Show local console checked on the Edit Server page, the enterprise server console daemon window appears indicating the progress of the process of starting the server.

  2. After a few seconds, click Refresh on the Home page.

    The value in Current Status changes to "Started".

Parent topic: Installation Verification


Connecting to the Enterprise Server

Once you have configured and started the enterprise server, you need to start a 3270 emulator from which you can run the installation verification procedure.

To connect to the enterprise server:

  1. Start a TN3270 emulator.
  2. Specify the following connection information (if appropriate):
    Field | Value
    Host name | The name of the computer the enterprise server is running on. This is localhost if it is the current machine.
    Port | The number you specified for the field Endpoint address in the section Configuring an Enterprise Server.
  3. Connect.
Note:

We recommend that you use a Telnet 3270 (TN3270) client such as Micro Focus RUMBA .

Parent topic: Installation Verification


Running the Installation Verification Procedure

This section describes how to run the installation verification procedure once you have configured and started the enterprise server and connected to it with a 3270 emulator. When you first connect, a 3270 terminal is displayed with a screen prompting you for a USERID and PASSWORD.

To run the installation verification procedure:

  1. Press Clear (3270 key).

    The display clears.

  2. Enter the following command:
    CFCR ACCTFIL

    The following messages are displayed:

    Base - ACCTFIL KSDS Key 1 for 5 VARIABLE 63 to 383
ACCTIX     ALTR   Key    6 for   12

CFCR - File successfully created
  3. Press Clear (3270 key).

    The display clears.

  4. Enter the following command:
    acct

    The following screen is displayed.

    Figure 1. Running the Installation Verification Procedure
    Running the Installation Verification Procedure

    You can now add a record to the demonstration account file.

  5. Press Tab until the cursor is positioned in the field immediately following the label REQUEST TYPE.
  6. Type A. The cursor automatically moves ahead to the ACCOUNT field.
  7. Type 22222; then press Enter.
  8. Fill in the fields as follows:
    Field | Value
    SURNAME | SMITH
    FIRST | JOHN
    MI | S
    TITLE | MR
    TELEPHONE | 501234
    ADDRESS (1) | 59 THE COURT
    ADDRESS (2) | WOODED AVENUE
    NO. CARDS ISSUED | 1
    DATE ISSUED | 03 04 98
    REASON | N
    CARD CODE | X
    APPROVED BY | GGC

    Other fields are optional, so you can leave them blank.

  9. Press Enter.
  10. Display the record you have just entered by typing SMITH into the SURNAME field and pressing Enter.
  11. Press Clear (3270 key).

    The display clears.

  12. Enter exit to disconnect the 3270 emulator.
  13. In the table of servers on the Home page of Enterprise Server Administration, find the row for the server that you are using, and click Stop in the Current Status column.

    The value in Current Status changes to "Stopping". If you have Show local console checked on the Edit Server page, the enterprise server console daemon window appears indicating the progress of the process of stopping the server. After a few seconds the value in Current Status changes to "Stopped".

Parent topic: Installation Verification


Configuring CICS-enabled Enterprise Servers

Descriptions of some of the ways in which CICS-enabled enterprise servers can be used, the information needed to control enterprise server processing and how to create and configure CICS-enabled enterprise servers.

  • Overview
  • Shared Memory Area
  • The System Initialization Table (SIT)
  • The Startup List
  • Loading DLL files
  • Deferring Loading of PCT Entries
  • To turn on Assembler support for CICS-enabled enterprise servers
Parent topic: CICS Support
Related information
Configuring an Enterprise Server for a CICS service


Overview

A CICS-enabled enterprise server equates to a CICS region. On a mainframe, CICS regions are used for a variety of purposes, such as separating departmental applications or projects, and isolating the impact of failures by separating resources into terminal-owning regions, application-owning regions and file-owning regions. MSS-enabled enterprise servers can be used in similar ways.

You do not need to define services, request handlers or implementation packages in order to run migrated CICS applications in an MSS-enabled enterprise server. However, you should not delete the system services and request handlers that are automatically associated with an enterprise server when you create it.

You can, if you wish, run non-CICS applications such as Web services alongside CICS applications in an MSS-enabled enterprise server.

Configuring a CICS-enabled enterprise server is very like configuring any enterprise server, as described in section Enterprise Servers in the chapter Configuration in your Enterprise Server Configuration and Administration Guide. The differences are listed and explained in the following topics.

Parent topic: Configuring CICS-enabled Enterprise Servers


Shared Memory Area

Because an MSS-enabled enterprise server contains more types of object than a non-CICS enabled enterprise server, there are more objects to take into account when you are deciding how much space to allocate to the shared memory area.
Item | Calculation
Remote systems
  • Number of sysids x 96
  • Number of sessions x 32
PCT | Number of entries x 48
FCT | Number of entries x 88 + (4 x number of split key components used)
DCT | Number of entries x 48
PPT | Number of entries x 48
Programs (load hold)1 | Number active x (average length + 8)
TST | Number of entries x 32
PLT | Number of entries x (56 + (8 x average number of items in list))
JCT | Number of entries x 48
ICE2 | Number active x 64
AID3 | Number active x 64
Getmain SHARED4 | Number active x (average length + 8)
ENQ5
  • Number active x (24 + average argument length)
  • Number of processes waiting on ENQ x 16
CICS client requests6 | (3270 data stream length + COMMAREA + TEUA + 64) x number of servers
Parent topic: Configuring CICS-enabled Enterprise Servers
1 Programs loaded as data with EXEC CICS LOAD
2 Interval Control Elements. Tasks scheduled for a particular time.
3 Automatic Initiate Descriptor. Tasks awaiting a free service execution process for execution.
4 Areas of memory allocated with EXEC CICS GETMAIN SHARED.
5 User controllable synchronization locks allocated with EXEC CICS ENQ.
6 The buffers calculation is a rule of thumb. Use the average data stream, COMMAREA, and TEUA sizes for the computation. This only works if your system is set up to incur a minimum amount of SEP queueing. The buffers calculation must exceed the maximum size of a single buffer; that is, one that contains maximum data, COMMAREA, and TEUA sizes.

Buffers are short lived and stay in shared storage only if no SEP is available to service the request. Once a SEP is dispatched, the buffer is immediately moved to local process storage and the shared storage is released. Outbound buffers also stay in shared storage for a very short period of time. Outbound, the only delay is for processor dispatch to the supporting terminal process. Once the terminal process is dispatched, the buffer contents are moved to local process storage and the shared storage buffer is released.


The System Initialization Table (SIT)

The System Initialization Table (SIT) specifies how a CICS-enabled enterprise server is to be initialized when it starts up. It determines such things as, but is not limited to:

  • A list of resource groups that are automatically installed at startup (the startup list).
  • Whether the loading of any PCT entries is to be deferred.
  • The System ID that a CICS-enabled enterprise server is to be known by.
  • The number of service execution processes (SEPs) that start for the enterprise server. A SEP equates to a CICS transaction server in a multi-tasking region.
  • Whether any network communications are to be enabled.
  • Whether trace is to be active, and for which features.

Some of the properties of a SIT are shared with the enterprise server definition, for example, the size of shared memory and settings for traces and dumps.

A SIT is defined and stored in a resource definition file (RDF). An RDF can hold any number of SITs. CICS supplies several pre-configured SITs. These can be used as defaults or used as a basis for customizing your own.

Parent topic: Configuring CICS-enabled Enterprise Servers


The Startup List

The startup list names the resource groups that are to be installed at system initialization. In this way, you can specify which resources are associated with a SIT and therefore which resources are installed when a CICS-enabled enterprise server is started. You can share resources across multiple enterprise servers or you can restrict some resources to a specific enterprise server. No matter what resources are defined in an RDF, a resource is not installed for an enterprise server unless the group that the resource belongs to is specified in the startup list associated with the SIT used to start the enterprise server. (You can, however, use the supplied transaction CINS to install further resource groups once the server is running.)

Assume, for example, that the RDF defines the resources shown below:

Figure 1. Example of resources defined in the RDF
Example of resources defined in the RDF

Starting an enterprise server with the SIT SAMPSIT1 specified will initialize that enterprise server with the two groups SAMPGRP1 and SAMPGRP2. This is because SAMPSIT1 specifies a startup list SAMPLST1 which has only those two groups listed.

Additional groups can be installed to that enterprise server when it is running, without having to stop the server, by using the supplied transaction CINS.

Assuming you have the authority (sign-on security privilege) to run the transaction, enter:

CINS SAMPGRP3

Then the SAMPLIST3 group is installed and made available to enterprise server users.

Parent topic: Configuring CICS-enabled Enterprise Servers


Loading DLL files

The application's compiler generates DLL files from your source code. In the Windows environment, DLL code is controlled by the operating system. Once a DLL has been loaded, it is locked to the loading process, in this case CICS, and no other process can overwrite the DLL file.

When you modify existing code you need to use the procedure described below to replace an existing DLL file with the new file that you compile. To configure and load a replacement DLL file:

  1. Create a staging folder to hold your updated DLL files, and compile your DLLs to this folder.
  2. On the enterprise server running the CICS application, from the Enterprise Server Administration screen, select the Server > Properties > General tab.
  3. In the Configuration Information field, define an environment variable, ES_STAGING_FOLDER that sets the staging directory. For example, to define the staging directory as D:\CICS\Staging, you would use the following entry:
    [ES-Environment]
ES_STAGING_FOLDER=D:\CICS\Staging

    See the figure below for an example.

  4. Click Apply to set the envfironment variable.
  5. Use the CICS CPMT transaction to set that a new version is available.

    The transaction replaces any existing DLLs that your application uses with the DLLs in the staging directory. For example, to load a new version of MYPROG.DLL, you would use the following CPMT CICS transaction:

    CPMT NE MYPROG

Note:

Use this process only for updating programs that are currently in use by CICS. For new programs, you must copy or compile your new program directly into the appropriate production folder.

Figure 1. Configuring DLL updates
Configuring DLL updates

  • Errors
Parent topic: Configuring CICS-enabled Enterprise Servers


Errors

All errors generated by the CPMT command are returned in EIBRESP, EIBRESP2 and EIBRCODE.

Table 1. >NOTFND (RESP 13) RESP2 values
Value | Description
1 | The environment variable cannot be resolved.
3 | The length of the file name when added to the staging folder is too big.
4 | The file name plus staging folder is incorrect.
8 | No staging folder has been defined.
12 | Program not found in staging folder.
Table 2. >IOERR (RESP 17) RESP2 values
Value Description
16 A Windows API function has failed. EIBRCODE contains:
  • Pos 1: 'C' to indicate that CopyFileA has failed
  • Pos 2-5: Windows error code in binary
,
Table 3. >PGMIDERR (RESP 27) RESP2 values
Value | Description
7 | Program not found (no PPT entry and program not loaded).,
Parent topic: Loading DLL files


Deferring Loading of PCT Entries

You can control whether to load all PCT entries at startup or to defer the loading of some or all PCT entries until the corresponding transaction ID is entered.

The advantages of loading all PCT entries at startup are:

  • Online execution time of PCT lookup is fast as all definitions are stored in memory.
  • The transactions available in the enterprise server are fixed at startup. Any offline RDF changes or additions are not visible to the enterprise server unless the CINS transaction is run.

These advantages are particularly important in a production environment, where you need fast response times and stable region definition. The disadvantage is that if there are many PCT entries to load, the startup time is increased and the shared memory usage will be high.

You can control the loading of PCT entries with the Defer Install field on the CICS SIT page of ESMAC.

If you defer loading PCT entries, when you enter a transaction ID that is not currently loaded into memory, CICS searches the groups specified in the original startup list in reverse order. If a PCT entry for the transaction ID is found, it is dynamically loaded into memory for subsequent use. If the transaction ID is not found, a TRANSIDERR occurs as normal.

Note: If a group specified as deferred is empty at startup, it will not be searched subsequently for PCT entries.

The following examples assume that resources are defined as shown.

Assume the RDF defines the resources shown below.

Figure 1. Resource Definition File for Example 1
Resource Definition File for Example 1

Using DEFSIT1, the following entries are loaded into memory at startup (in addition to the DFH group entries):

  • (TRN2,PROG2) from DEFGRP1
  • (TRN3,PROG3) from DEFGRP1
  • (TRN4,PROG4) from DEFGRP2
  • (TRN1,PROG5) from DEFGRP2

The entry for (TRN1,PROG5) from DEFGRP2 is used instead of the entry for TRN1 in DEFGRP1. This is because DEFGRP2 occurs later than DEFGRP1 in the startup list.

Assume the RDF defines the resources shown below.

Figure 2. Resource Definition File for Example 2
Resource Definition File for Example 2

Starting the region with DEFSIT2, deferred PCT loading is enabled for all groups in the startup list. No PCT entries are loaded into memory at startup. When the enterprise server is running, if the transaction ID TRN3, for example, is entered from a client, the system will:

  • Search DEFGRP2 for a PCT entry=TRN3. Result: Not found
  • Search DEFGRP1 for a PCT entry=TRN3. Result: Found. Load the definition into memory

Subsequent uses of the transaction ID TRN3 will find the PCT entry in memory, so no searching of the resource definition file takes place. Similarly, if the transaction ID TRN1 is entered from a client, the system searches for and finds the definition in DEFGRP2.

This will find the same definition for TRN1 as shown in Resource Definition File for Example 1 above.

Assume the RDF defines the resources shownbelow.

Figure 3. Resource Definition File for Example 3
Resource Definition File for Example 3

The third type of deferred PCT load allows you to specify the number of groups that will have the loading of their PCT definitions deferred. In this case, the deferred group count is set to 1, so the loading of PCT definitions from DEFGRP2 is deferred.

The number of groups to defer is counted back from the end of the startup list.

In this case, at system startup, the following PCT definitions are loaded into memory:

  • (TRN1,PROG1) from DEFGRP1
  • (TRN2,PROG2) from DEFGRP1
  • (TRN3,PROG3) from DEFGRP1

The definition for transaction ID TRN1 is now taken from DEFGRP1 and not from DEFGRP2.

Parent topic: Configuring CICS-enabled Enterprise Servers


Resource Definitions

  • Introduction
  • Exchanging Resource Definitions Between Resource Definition Files
  • Maintaining Resource Definitions
  • CICS Resource Definitions
Parent topic: CICS Support


Introduction

The resource definitions stored by MSS are different in both content and form to those stored on the mainframe. Many resource types and attributes that you can define on the mainframe are meaningless in the Windows environment, for example LSRPOOL. MSS recognizes these resource types and attributes but takes no action on them. Conversely, MSS understands some additional attributes that only make sense in the Windows environment, and some of these are mandatory.

The following table lists all the types of resource definition used or recognized by MSS. For each type of resource definition, the name by which it is known in the .rdt file used for exchanging resource definitions with other Enterprise Server with MSS systems is given, followed by an indication of the support provided, then any abbreviation used within the interface and its meanings. Mainframe resource types are listed first, followed by Micro Focus extensions.

Keyword in .rdt file | Used or recognized | Abbreviation | Meaning
CONNECTION | Used |  |
FILE | Used | FCT | file control table
LSRPOOL | Recognized |  |
MAPSET | Recognized |  |
PARTITIONSET | Recognized |  |
PARTNER | Recognized |  |
PROFILE | Recognized |  |
PROGRAM | Used | PPT | program processing table
SESSIONS | Recognized |  |
TERMINAL | Used | Term | terminal
TRANCLASS | Recognized |  |
TRANSACTION | Used | PCT | program control table
TYPETERM | Used | T-type | terminal type
TDQUEUE | Used | DCT | destination control table
_JOURNAL | Extension | JCT | journal control table
_PGMLIST | Extension | PLT | program load table
_SIGNON | Extension | SNT | signon table
_SIT | Extension | SIT | system initialization table
_STARTUPLIST | Extension |  |
_TEMPSTORAGE | Extension | TST | temporary storage table
_XOPENCOMPAT | Extension | XAT | XA-compliant database table

The CICS resources are defined in the resource definition file dfhdrdat (with index dfhdrdat.idx). This is an ISAM file.

When Enterprise Server runs the application, it needs to know where the application's dfhdrdat file is. You specify its location using the /ip switch of the casrdtex command and /op switch of the casrdtup command.

Parent topic: Resource Definitions


Exchanging Resource Definitions Between Resource Definition Files

You can import and export resource definitions from and to other resource definition files held on the same or different installations of Server Enterprise Edition.

casrdtup | Imports the resource definition tables in a specified file into the resource definition file dfhdrdat. Use the /ip switch to identify the location of the directory containing dfhdrdat.
casrdtex | Exports the resource definition tables from the resource definition file dfhdrdat to a specified file. Use the /op switch to identify the location of the directory containing dfhdrdat.

Enter casrdtex and casrdtup at the command line to display a full list of the switches available.

Parent topic: Resource Definitions
Related information
casrdtup
casrdtex


Maintaining Resource Definitions

When you have downloaded your resource definitions from the mainframe, they can be maintained in the Windows or UNIX environment. MSS uses several different types of resource, such as programs and files. The standard resources that can be used by most systems are predefined. You need to add definitions only for those resources that are used specifically by your system.

  • Types of Resource
  • Facilities for Maintaining Resources
Parent topic: Resource Definitions


Types of Resource

Each type of resource is defined in a separate table. For example, programs are defined in a processing program table (PPT) and files in a file control table (FCT). For each resource type, more than one table can be defined for the same system. And more than one table for the same resource type can be used by the system, except for the system initialization table (SIT), which defines parameters to control the initialization of the system, and the sign-on table (SNT), which defines user sign-on authorizations.

Note:

Not all programs need entries in the PPT. However PPT entries are required for the following types of program:

  • Programs started by Program Load Tables
  • Programs for autoinstall

They are also required for data tables.

Tables for the same or different resource types can be combined into a group. For example, you will probably find it convenient to combine all the tables for the resources used by an application (or set of related applications) into a single group.

All the groups that you want to be included in the enterprise server startup are defined in a startup list. During startup, MSS uses this list to check that the resources are available and performs appropriate initialization procedures on them.

For full information about CICS resource definition, see the IBM documentation.

Parent topic: Maintaining Resource Definitions


Facilities for Maintaining Resources

You can edit the resource definitions using ESMAC, which provides a graphical user interface. For more information see the section Controlling CICS Resources in the chapter Administering MSS-enabled Enterprise Servers.

Alternatively, you can edit them using a text editor, but to do this, you first need to export the resource definition tables from the dfhdrdat file, and when you have finished editing, you need to import the tables back again. For more information about importing and exporting resources see the section Exchanging Resource Definitions Between Resource Definition Files .

Parent topic: Maintaining Resource Definitions
Related information
Exchanging Resource Definitions Between Resource Definition Files


DEFINE _JOURNAL

Defines the attributes of a journal used for recording system activity within Enterprise Server.
Keyword | Description
_Journal(number) | Specifies the key of a journal record. The key must be a two digit number.
Group(groupname) Names the group the journal definition belongs to. Mandatory.

Groupname can be up to eight characters in length. Acceptable characters are A through Z, a through z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as Mainframe Subsystem Support (MSS) uses that prefix for system groups.

Description(text) Describes the sign-on record. Optional.

Text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.

_OPenstate(NEWFILE | APPEND) The status of the journal control table when it is opened. It may contain one of the following values:
  • NEWFILE: a new file will be created
  • APPEND: information will be added at the end of an existing file
_MInreclen(number) | Specifies the minimum logical record length of the file in bytes, in the range 1 through 32767. The value must be less than or equal to the value of _MAxreclen.
_MAxreclen (number) | Specifies the maximum logical record length of the file in bytes, in the range 1 through 32767. The value must be greater than or equal to the value of _MInreclen.
_FILEName | Specifies the name of the physical PC file. Do not include the file extension.
_FILEExt(value) | Specifies the file extension of the physical file.
_FILEShareid(name) | Specifies the Fileshare server on which the file resides. name can be up to 16 characters in length.
_Path(path) | Specifies the path of the physical file. Do not include the filename or the file extension. Mandatory if the file is held on a Fileshare server, in which case _FILEShareid must be present too.
_Rsl(keys) Specifies one or more indicators, each corresponding to one of the 24 resource keys for this journal.

A user has access to a particular resource only through a matching key as defined in his sign-on table entry. To toggle a key on you specify its number here. By default all keys are toggled off. You code the keys as a comma-separated list of individual numbers and ranges separated by hyphens. For example, to toggle the keys 1 to 5 and 10 on, code RSL(1-5,10).

Example

DEFINE _JOURNAL(01) GROUP(TEST)
DESCRIPTION(Journal 1)
       _MINRECLEN(5) _MAXRECLEN(330) _FILENAME(jourfile)
       _FILESHAREID(FSID) _PATH(c:\logging) _FILEEXT(dat)
       _RSL(01,06-09)
Parent topic: CICS Resource Definitions


DEFINE _PGMLIST

Defines a list of programs and the phase in which they are to run. The lists are used at post initialization and shut down.
Keyword | Description
_Pgmlist(name) | Specifies the key of a program list table (PLT) record. Mandatory. Name can be up to two characters in length. Acceptable characters are A through Z, a through z, 0 through 9, $, @ and #.
Group(groupname) | Names the group the program list definition belongs to. Mandatory. Groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as Mainframe Subsystem Support (MSS) uses that prefix for system groups.
Description(text) | Describes the program list record. Optional. Text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.
_PGMPH(name,phase) | Specifies the name of a program and the phase in which it is to run, separated by a comma. Both parameters are mandatory. Name can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a program name starting with DFH, as MSS uses that prefix for system programs. Phase specifies the start up phase in which the program is to be run. It must have a value of 1 or 2. This parameter may be repeated to a maximum of 64 occurrences.

Example

DEFINE _PGMLIST(SD) GROUP(TEST)
DESCRIPTION(Shutdown List)
       _PGMPH(PLTWTO,1) _PGMPH(PLTWTO2,2)
Parent topic: CICS Resource Definitions


DEFINE _SIT

Defines a system initialization table that controls the execution of an Enterprise Server region.
Keyword | Description
_SIT(name) Specifies the key of a system initialization table record. Mandatory. Name can be up to eight characters in length.

Acceptable characters are A through Z, 0 through 9, $, @ and #.

Group(groupname) Names the group the system initialization table definition belongs to. Mandatory.

Groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as Mainframe Subsystem Support (MSS) uses that prefix for system groups.

Description(text) Describes the system initialization table record. Optional.

Text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.

_ CWasize (value) | Specifies the size of the region's common work area (CWA) in bytes in the range 0 through 32767. This area is shared among applications running in the region.
_COMmareaovr(value) Specifies the minimum amount of storage to be allocated to the communications area (COMMAREA) to allow MSS to behave like mainframe CICS.

The size is in the range 0 through 32767. The effect of this is that when a program is passed a COMMAREA smaller than the COMMAREA defined in the program, the passed COMMAREA is automatically extended in length to fill the defined space.

_SHAredpages(value) | Specifies the number of shared pages in memory to be reserved for all the processes that run in the region. Each page is 4 KB long.
_SERvers(value) | Specifies the number of service execution processes that are to be started at server initialization.
_TRTsize(2 | 14-9999) Specifies the number of entries the trace buffer can hold before it wraps back to the start. The trace buffer is also written to disk at this point if Auxiliary Trace is active.

A value of 2 means that there is space for only one entry, and if Auxiliary Trace is active each entry is written straight out to disk.

_SYSid(sysid) | Specifies the system ID of the region. This is the name by which it is known to other regions.
_INITIaltran(tranid) | Specifies the ID of an initial transaction that runs on every terminal when it logs on to the region.
_PLTPilist(name) | Specifies a program list table (PLT) entry that nominates the initialization programs to be run when the region is started.
_PLTSdlist (name) | Specifies a program list table (PLT) entry that nominates the shutdown programs to be run when the region is stopped.
_STArtuplist(name) Specifies the startup list which determines the resources to be loaded when the server is initialized.

Default value is DFHLIST.

_RETrievecmd(string) Specifies the character string that BMS control is to interpret as the BMS paging command RETRIEVE.

Default value is P/.

_CHAincmd(string) Specifies the character string that BMS control is to interpret as the BMS paging command CHAIN.

Default value is C/.

_PURgecmd (string) Specifies the character string that BMS control is to interpret as the BMS paging command PURGE.

Default value is D/.

_COPycmd (string) Specifies the character string that BMS control is to interpret as the BMS paging command COPY.

Default value is T/.

_PF1Cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF1 key.
_PF2Cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF2 key.
_PF3Cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF3 key.
_PF4Cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF4 key.
_PF5Cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF5 key.
_PF6Cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF6 key.
_PF7Cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF7 key.
_PF8Cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF8 key.
_PF9Cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF9 key.
_PF10cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF10 key.
_PF11cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF11 key.
_PF12cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF12 key.
_PF13cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF13 key.
_PF14cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF14 key.
_PF15cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF15 key.
_PF16cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF16 key.
_PF17cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF17 key.
_PF18cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF18 key.
_PF19cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF19 key.
_PF20cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF20 key.
_PF21cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF21 key.
_PF22cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF22 key.
_PF23cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF23 key.
_PF24cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PF24 key.
_PA1cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PA1 key.
_PA2cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PA2 key.
_PA3cmd(string) | Specifies a character string that is to equate to a BMS paging command for the PA3 key.
_ABEnddump(NO | YES) Indicates that MSS should produce a dump if an abend occurs in any of your transaction programs.

Default is NO.

_DATEFormat(MMDDYY | DDMMYY | YYMMDD) Specifies the display format used to display the date. This is used in conjunction with the FULLDATE (for four-digit years) or DATE (for two-digit years) operands of the EXEC CICS FORMATTIME command. This setting determines only the order of day, month, and year; it does not prevent four digits from being displayed.

Default is MMDDYY

_DATESep(value) Specifies the character to be used to separate the day, month and year components of the date. You can specify any displayable character.

Default is solidus (/).

_TIMEsep(value) Specifies the character to be used to separate the hours, minutes and seconds components of the time. You can specify any displayable character.

Default is colon (:).

_NRECTSPath(path) | Specifies the path for non-recoverable temporary storage queues.
_RECTSPath (path) | Specifies the path for recoverable temporary storage queues.
_NRECTDPath (path) | Specifies the path for non-recoverable transient data queues.
_RECTDPath (path) | Specifies the path for recoverable transient data queues.
_NRECTSFshr(name) | Specifies a Fileshare server ID for non-recoverable temporary storage queues.
_RECTSFshr (name) | Specifies a Fileshare server ID for recoverable temporary storage queues.
_NRECTDFshr (name) | Specifies a Fileshare server ID for non-recoverable transient data queues.
_RECTDFshr (name) | Specifies a Fileshare server ID for recoverable transient data queues.
_PRINTSupp(NO | YES) Indicates whether or not the region supports a printer:
  • YES: the region supports a printer
  • NO: the region does not support a printer (default)
_PRINTDest(name) | Specifies the printer destination, up to 14 characters in length. You must also specify 3270 printer support when specifying a printer destination.
_FILeshare(NO | YES) Indicates whether MSS should create a dedicated Fileshare server process as part of region startup.

Default is NO.

_FSHRUserid(user) Specifies the user ID to be used by the region to log on to all Fileshare servers that MSS is configured to use. You should specify a user ID only if Fileshare security is enabled. If you specify a user ID, you must also specify a password in _FSHRPASSWD. The user ID and password combination must correspond to an entry in the password file of each Fileshare server the region is to access.

The ID may be up to 20 characters.

_FSHRPasswd(password) | Specifies the 20-character password used in conjunction with _FSHRUSERID to log on to all Fileshare servers that MSS is configured to use.
_TSColdstart(NO | YES) Indicates whether or not MSS should reset temporary storage queues at region start up.

Default is NO.

_TDColdstart(NO | YES) Indicates whether or not MSS should reset transient data queues at region start up.

Default is NO.

_AUXtrace(NO | YES) Indicates whether MSS is to enable or disable auxiliary tracing.

Default is NO.

_TRACEStore(NO | YES) Indicates whether MSS is to enable or disable storage control tracing.

Default is NO.

_TRACETASk(NO | YES) Indicates whether MSS is to enable or disable task control tracing.

Default is NO.

_TRACEFile(NO | YES) Indicates whether MSS is to enable or disable file control tracing.

Default is NO.

_TRACEDump(NO | YES) Indicates whether MSS is to enable or disable dump control tracing.

Default is NO.

_TRACETStd(NO | YES) Indicates whether MSS is to enable or disable temporary storage/transient data tracing.

Default is NO.

_TRACEIntrvl(NO | YES) Indicates whether MSS is to enable or disable interval control tracing.

Default is NO.

_TRACEJournl(NO | YES) Indicates whether MSS is to enable or disable journal control tracing.

Default is NO.

_TRACETABle(NO | YES) Indicates whether MSS is to enable or disable table management tracing.

Default is NO.

_TRACEUSer(NO | YES) Indicates whether MSS is to enable or disable user tracing .

Default is NO.

_TRACETErm(NO | YES) Indicates whether MSS is to enable or disable terminal control tracing.

Default is NO.

_TRACECOmms(NO | YES) Indicates whether MSS is to enable or disable communications tracing.

Default is NO.

_TRACEMessg(NO | YES) Indicates whether MSS is to enable or disable message tracing.

Default is NO.

_TRACECCi(NO | YES) Indicates whether MSS is to enable or disable CCI tracing.

Default is NO.

_TRACEAPi(NO | YES) Indicates whether MSS is to enable or disable CICS API tracing.

Default is NO.

_TRACEUExit(NO | YES) Indicates whether MSS is to enable or disable user exit tracing.

Default is NO.

_ENAbtn3270(NO | YES) Indicates whether TN3270 is enabled or not.

Default is NO.

_TN3270port(23 | value) Specifies the port number on which MSS listens for TN3270 requests.

Default value is 23.

_EXTernshut(ALLOWED | LOGON | NONE) Specifies the type of external shutdown.You can choose from:
  • ALLOWED: no special privileges are required (default).
  • LOGON: a successful logon must be made first.
  • NONE: external shutdown is disallowed.
Note: An external shutdown is a shutdown of the server initiated by clicking Shutdown on the Control page, Stop Server on the Enterprise Server Administration Server Details page, or issuing a casstop command.
_SECuritykey(0- 64) Specifies a security key number. MSS checks this against the shutdown security key specified when you shut down the region. You need to specify a security key number only if you choose LOGON in External Shutdown.

Default value is 64.

_STGcushion(0-262144) Specifies the number of 4KB pages that should be reserved from the shared memory pages to allow the server to continue processing when the shared memory allocation is too small for the operational requirements of the server.

Default value is 4096

_DUMponsysab(NO | YES) Indicates whether MSS should produce a dump if an abend occurs in its own code.

Default is NO.

_WAItonsend(NO | YES) Indicates whether MSS should wait on each terminal control or BMS SEND operation until it receives a response.
  • YES: MSS does not wait on each SEND, thus enabling terminal control and send operations to be buffered, which improves performance (default)
  • NO: MSS does wait
_TDDEFREQD(NO | YES) Indicates whether a transaction program executing in this region can create a transient data queue only if it has been defined in the destination control table (DCT). Applies only to intra-partition transient data queues.
  • YES: a DCT entry must be defined
  • NO: a DCT entry is optional (default)
_DEVelopment | Obsolete.
_DEFerpct(NO | YES | 1-64) Specifies the number of PCT groups whose loading you want to defer.
  • YES: none of the PCT entries is loaded into memory when the region starts up.
  • NO: all PCT entries are loaded into memory when the region starts up (default).
  • any other value: the PCT entries in that number of groups are not loaded into memory when the region starts up. For example, if you specify 3, the last three groups in the start up list's precedence order are not loaded into memory when the region starts up.
I
_MAXauxdump(value) | Specifies the maximum size of the auxiliary trace and dump file in kilobytes. A value of 0 (zero) means that there is no maximum size.
_FORceprog(NO | YES) Indicates whether MSS should reload programs each time they are invoked.
  • YES: programs are loaded on each invocation.
  • NO: programs are reused (default)
This applies only to programs that are not marked resident and have not been loaded with the hold attribute.
_TERmorigsys(NO | YES) Indicates how a remote CICS region handles a START request shipped to it by this CICS region, and the terminal that should be started is not defined on the remote system:
  • YES: the remote region should assume that the terminal is defined on the originating system and should start a terminal anyway
  • NO: the remote system returns a TERMIDERR to the originating region (default)
_COLdstartrc(NO | YES) Indicates whether the auxiliary trace and dump files are to be deleted at region startup:
  • YES: the trace and dump files are deleted
  • NO: the trace and dump files are reused (default)
_CICsrel | Obsolete.
_LOcaltrtsz(value) Specifies the number of entries the local trace table can hold before it wraps back to the start. A value of 0 (zero) means that no local trace table is allocated.

Each service execution process has its own local trace table. Each entry is 24 bytes long.

_UNICLIGway(NO | YES) Indicates whether an IBM Universal Clients gateway is to be established when the region starts up:
  • YES: a gateway is established at startup
  • NO: a gateway is not established at startup (default)
_UNICLIPort(value) Specifies the TCP/IP port number to use for the Universal Clients gateway.

This must match the TCP/IP port number you specify in the Universal Clients configuration file except that if you use the defaults, the value in the configuration file is 0 whereas the default value for _UNICLIPort is 1435.

_UNICLISess(0-255) | Specifies the number of sessions you want allocated to servicing inbound requests per connection, where connection corresponds to a client machine.
_MQENABCOnn(NO | YES) Indicates whether support for IBM MQSeries® is enabled:
  • YES: MQSeries support is enabled
  • NO: MQSeries support is disabled (default)
_MQENABCKti(NO | YES) Indicates whether support is enabled for the transaction CKTI, which monitors the IBM MQSeries® initiation queue:
  • YES: CKTI support is enabled
  • NO: CKTI support is disabled (default)
_MQQmgrname(name) | Specifies the name of the IBM MQSeries® queue manager. Can be up to 48 characters.
_MQInitqname(name) | Specifies the name of the IBM MQSeries® initiation queue. Can be up to 48 characters.
_AUToinsexit(name) Specifies the name of the program to be used to autoinstall terminals. Specify:
  • DFHZATDX - the autoinstall program supplied with MSS.
  • User-specified: the name of your autoinstall exit program. Up to 8 characters from 0 through 9, A through Z, @, # and $. The first character must not be numeric.
_TRAnsthold(-1 | 0-65535) | Specifies the amount of time in seconds that a transaction is allowed to execute before it is abended.
_DTImeout(0-4080) Specifies the maximum time in seconds that the region will permit an application to wait for a resource that has been locked by another process. A value of 0 indicates that there is no timeout.
Note: In CAS you can override this value at runtime by changing the Deadlock Timeout on the ESMAC Control screen. You can also override this value for an individual transaction through the relevant Program Control Table entry.
_RTImeout(0-4080) Specifies the maximum time in seconds allowed for operator response to an explicit CICS RECEIVE command before the transaction is abended.
A value of 0 indicates that there is no timeout.
Note: In CAS you can override this value at runtime by changing the Input Timeout on the ESMAC Control screen. You can also override this value for an individual transaction through the relevant Program Control Table entry.
_RUNaway(0-2700) Specifies the maximum continuous period of time in seconds that the region will allow a transaction to run without making a CICS, EZASOKET or MQSeries API call. When this time is exceeded, the transaction is abended.
A value of 0 indicates that there is no timeout.
Note: In CAS you can override this value at runtime by changing the Runaway Timeout on the ESMAC Control screen. You can also override this value for an individual transaction through the relevant Program Control Table entry.
_IDTimeout(0-4080) Specify the time in minutes that the system will allow an ESMAC or TN3270 client session to remain idle before logging off the user. A value of 0 indicates that there is no timeout.
Note: In CAS you can override this value at runtime by changing the ID Timeout on the ESMAC Control screen.

Example

DEFINE _SIT(TESTSIT)
DESCRIPTION(Sample SIT)
       _CWASIZE(512) _COMMAREAOVR(0) _SHAREDPAGES(128) _SERVERS(2)
       _TRTSIZE(341) _SYSID($MCO) _INITIALTRAN(CESN)
       _STARTUPLIST(MCOSUPL) _RETRIEVECMD(P/) _CHAINCMD(C/)
       _PURGECMD(D/) _COPYCMD(T/) _ABENDDUMP(NO) _DATEFORMAT(MMDDYY)
       _DATESEP(/) _TIMESEP(:) _PRINTSUPP(NO) _CCIGATEWAY(NO)
       _TSCOLDSTART(NO) _TDCOLDSTART(NO) _TRACESTORE(NO) _TRACETASK(NO)
       _TRACEFILE(NO) _TRACEDUMP(NO) _TRACETSTD(NO) _TRACEINTRVL(NO)
       _TRACEJOURNL(NO) _TRACETABLE(NO) _TRACEUSER(NO) _TRACETERM(NO)
       _TRACECOMMS(NO) _AUXTRACE(NO) _TRACEMESSG(NO) _TRACECCI(NO)
       _TRACEAPI(NO) _TRACEUEXIT(NO) _CCIDDE(NO) _CCIIPX(NO)
       _CCINAMEP(NO) _CCINETBIOS(NO) _CCITCPIP(NO) _ENABTN3270(NO)
       _EXTERNSHUT(ALLOWED) _SECURITYKEY(64) _STGCUSHION(1)
       _DUMPONSYSAB(YES) _WAITONSEND(YES) _TDDEFREQD(NO)
       _DEVELOPMENT(YES) _DEFERPCT(NO) _MAXAUXDUMP(0) _FORCEPROG(YES)
       _TERMORIGSYS(NO) _TN3270PORT(0) _CICSREL(33) _FILESHARE(NO)
       _LOCALTRTSZ(341) _UNICLIGWAY(NO) _MQENABCONN(NO) _MQENABCKTI(NO)
       _TCPIPGWPORT(0) _TRANSTHOLD(0) _DTIMEOUT(0) _RUNAWAY(0)
       _RTIMEOUT(0) _IDTIMEOUT(0)
Parent topic: CICS Resource Definitions


DEFINE _STARTUPLIST

Defines a list of resource groups to be installed at system initialization.
Keyword | Description
_STARTUPLIST (name) | Specifies the key of a startup list record. Mandatory. Name can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #.
_GRP(groupname) | Names the group to be in the startup list. Groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. This parameter may be repeated for as many groups as there are in the list.

Example

DEFINE _STARTUPLIST(TESTLIST)
DESCRIPTION(Example Startup List)
       _GRP(DFHBMS) _GRP(DFHCONS) _GRP(DFHEDF) _GRP(DFHHARDC)
       _GRP(DFHISC) _GRP(DFHOPER) _GRP(DFHSIGN) _GRP(DFHSPI)
       _GRP(DFHTYPE) _GRP(DFHVTAM) _GRP(DFH$ACCT) _GRP(DFH$IVP)
       _GRP(DFHTERM) _GRP(PEH) _GRP(TEST)
Parent topic: CICS Resource Definitions


DEFINE _TEMPSTORAGE

Defines the attributes of a temporary storage (TS) record set.
Keyword | Description
_Tempstorage(name) Specifies the key of a temporary storage (TS) record. Mandatory.

Name can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #.

Group(groupname) Names the group the temporary storage definition belongs to. Mandatory.

Groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as Mainframe Subsystem Support (MSS) uses that prefix for system groups.

Description(text) Describes the temporary storage record. Optional.

Text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.

_REMOTESysid (sysid) Applicable only for remote queues. Specifies the ID of the remote system that holds the queue. This must correspond to either:
  • The Local SYSID field in the SIT used to run the related remote CICS Option region.
  • The APPLID of another CICS system.
_REMOTEName(name) | Applicable only for remote queues. Names the remote queue. Necessary only if it differs from the local queue name.
_RECovery (NO | YES) Indicates whether or not the queue is recoverable.

Default is NO.

_RSl (RSL stands for Resource Security Level.) Specifies one or more indicators, each corresponding to one of the 24 resource keys for this program.

A user has access to a particular resource only through a matching key as defined in his sign-on table entry. To toggle a key on you specify its number here. By default all keys are toggled off. You code the keys as a comma-separated list of individual numbers and ranges separated by hyphens. For example, to toggle the keys 1 to 5 and 10 on, code RSL(1-5,10).

Example

DEFINE _TEMPSTORAGE(TESTQ9) GROUP(TEST)
DESCRIPTION(Sample TSQ)
       _REMOTESYSID(SYSB) _REMOTENAME(RMT) _RECOVERY(YES)
       _RSL(01-03,06,14)
Parent topic: CICS Resource Definitions


DEFINE _XOPENCOMPAT

Defines the attributes of XA compatible resources (external resource managers).
Keyword | Description
_Xopencompat(name) Specifies the key of an X/Open or XA resource manager record. Mandatory.

Name can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #.

Group(groupname) Names the group the XA definition belongs to. Mandatory.

Groupname can be up to eight characters in length. Acceptable characters are A through Z, 0 through 9, $, @ and #. Do not specify a group name starting with DFH, as Mainframe Subsystem Support (MSS) uses that prefix for system groups.

Description(text) Describes the XA record. Optional.

Text can be up to 60 characters in length, with no restrictions except that if you use a left parenthesis you must ensure that there is a matching right parenthesis.

_Openstring (string) Specifies the string that is passed to the resource manager on the xa_open() call.

An entry in this field usually contains at least the database name, and the user ID and password for connecting to the database.

Where the resource manager supports dynamic registration, and the database vendor requires the name of the module that provides the ax_reg function, you should specify casaxlib. Use of open and close strings is mutually exclusive with DATABASE, USERID and PASSWORD.

Note: The contents of this string are database-specific. For DB2, the contents are documented in IBM's DB2 Administration Guide and Application Programmer's Guide. For Oracle, see the Oracle Application Developer's Guide - Fundamentals.
_Closestring(string) | Specifies the string that is passed to the resource manager on the xa_close() call. To find out whether or not you need to supply Close string, see your database vendor's documentation.
_Database(name) | Specifies the name by which the resource manager is known.
_Userid(user) | Specifies a resource manager ID, which is used internally to identify a particular XA configuration. This must be unique within the system.
_Password(password) | Specifies the password required for the User ID.
_SWitchmod(path) | Specifies the location of the executable file (DLL) that contains the entry point that returns the xa_switch_t structure to the system.
_Runtime(None | Db2 | Oracle | Sybase | User) Specifies an external resource manager that the server needs to communicate with on behalf of container-managed applications.

Default is None.

_SUpportmod(name) | If you specified USER in RUNTIME, specify the name of the module that supplies the run-time support for the database calls made by the application.

Example

Example
DEFINE _XOPENCOMPAT(ORACLE) GROUP(TEST)
DESCRIPTION(Oracle XA Sample)
       _OPENSTRING(Oracle_XA+Acc=P/scott/tiger+SesTm=0+DbgFl=15)
       _SWITCHMOD(c:\oracle\bin) _RUNTIME(ORACLE) _SUPPORTMOD(xaosw)
Parent topic: CICS Resource Definitions


Configuring CICS for Security

This chapter describes the basic security features that you can implement with MSS. It explains:
  • The security features provided by MSS
  • How to enable transaction and resource security
  • Password encryption and decryption

You can implement more extensive security through the use of the Enterprise Server External Security Facility. For details see Introduction to Enterprise Server Security.

  • Overview
  • Transaction Security
  • Resource Security
  • Sign-on Table (SNT) Entries
  • Password Encryption and Decryption
Parent topic: CICS Support
Related information
Introduction to Enterprise Server Security


Overview

MSS provides optional security for individual transactions and resources. It is off by default.

MSS controls access to transactions and resources through three mechanisms:

  • Transaction security
  • Resource security
  • Sign-on Table (SNT) entries

MSS also provides a mechanism for implementing your own password encryption and decryption strategy.

Parent topic: Configuring CICS for Security


Transaction Security

Transaction security allows you to control access to individual transactions.

To enable security for a transaction, you must do two things:

  • Define a set of security keys for the transaction in its PCT entry. Each security key is a number in the range 1 through 64.
  • Specify a set of security keys in a user's SNT entry. A user can access a transaction if at least one of the transaction's security keys matches a security key specified in that user's SNT entry.

If you assign security key number 1 to a transaction, any user can run the transaction; all users own security key 1 by default. Figure 9-1 illustrates security key checking applied to a transaction.

Figure 1. Transaction key checking
Transaction key checking
Parent topic: Configuring CICS for Security


Resource Security

You can control access by a transaction to the following types of resource:

  • Files
  • Transient data queues
  • Temporary storage queues
  • Journals
  • Other transactions

To enable resource security, do the following:

  1. Specify that a transaction is to perform resource security checking, by checking Security: Resource Level Checking on the PCT page in ESMAC for the transaction. (By default, transactions do not perform resource security checking.)
  2. Specify a set of resource keys in the resource table entry (for example, the FCT entry for a file). Each resource key is a number in the range 1 through 24.
  3. Specify a set of resource keys in a user's SNT entry. A user can access a resource if one or more of the resource keys for the resource matches a resource key specified in that user's SNT entry.

The figure below illustrates the process of resource key checking.

Figure 1. Resource key checking
Resource key checking
Parent topic: Configuring CICS for Security


Sign-on Table (SNT) Entries

You must create an entry for the user in the Sign-on Table (SNT) if the user requires:

  • A user ID and password. These are required if:
    • The user has to sign on to MSS using the supplied transaction CESN.
    • The user wants to modify resource definitions using the Resource Definition Facility if security is enabled.
  • Security keys and/or resource keys.

Each entry in the SNT specifies the following:

  • The ID with which a user signs on through the CESN transaction.
  • The user's MSS password.
  • The user's security and resource keys.
  • The User SYSAD
Parent topic: Configuring CICS for Security


The User SYSAD

When you create a MSS Resource Definition File, its SNT already contains an entry for the system administrator, with username SYSAD and password SYSAD. (You must enter this password in upper case.)

User SYSAD has system administrator privileges and owns all security and resource keys.

You should change SYSAD's password to something more secure as soon as possible.

Parent topic: Sign-on Table (SNT) Entries


Password Encryption and Decryption

MSS calls a user-replaceable module, dfhucryp.gnt located in both %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin and \base\bin\win64, to perform encryption and decryption of user passwords. The installed module does not actually perform any encryption; that is, the encrypted password is the same as the unencrypted password. You can replace this module with one that implements a password encryption and decryption strategy appropriate for your site.

The example module, dfhucry1.gnt, that implements a simple encryption and decryption scheme, is supplied. The source (.cbl) form is provided in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source and \base\source\win64. It uses the number of 1 bits in the user ID as a shift count and a pair of encipher and decipher tables.

  • The Interface to the Password Module
  • Choosing an Encryption and Decryption Scheme
  • Replacing the Password Encryption and Decryption Scheme
Parent topic: Configuring CICS for Security


The Interface to the Password Module

The interface to dfhucryp.gnt is a standard call interface, requiring a single parameter:

CALL "DFHUCRYP" USING CRYPT-PARAMETER-AREA.
 01  CRYPT-PARAMETER-AREA.
     05  CRYPT-FUNCTION                PIC XX COMP-X.
         88  CRYPT-ENCRYPT-88             VALUE 1.
         88  CRYPT-DECRYPT-88             VALUE 2.
     05  CRYPT-RESULT                  PIC XX COMP-X.
         88 CRYPT-SUCCESSFUL-88           VALUE 0.
         88 CRYPT-FAILED-88               VALUE 1.
     05  CRYPT-USER-ID                 PIC XX(8).
     05  CRYPT-ENCRYPTED-PASSWORD      PIC XX(8).
     05  CRYPT-DECRYPTED-PASSWORD      PIC XX(8).

where:

CRYPT-FUNCTION Specifies the function as encrypt (=1) or decrypt (=2).

The encrypt function takes the decrypted password as input and outputs the encrypted password, possibly referring to the user ID field.

The decrypt function takes the encrypted password as input and outputs the decrypted password, possibly referring to the user ID field.

CRYPT-RESULT | This field is used to signal the success (=0) or failure (=1) of the function. Since a failure is treated as a password mismatch in all validation functions, the error return can be used to screen out unacceptable passwords during the SNT update process.
CRYPT-USER-ID | The user ID associated with the password being encrypted or decrypted.
CRYPT-ENCRYPTED-PASSWORD | The encrypted password. This field is used as an input field by the decrypt function and as an output field by the encrypt function.
CRYPT-DECRYPTED-PASSWORD | The decrypted password. This field is used as an output field by the decrypt function and as an input field by the encrypt function.
Parent topic: Password Encryption and Decryption


Choosing an Encryption and Decryption Scheme

The only restrictions on the encryption and decryption scheme you choose are as follows:

  • It must be a reversible encryption scheme.
  • The implementation must conform to the interface described in the previous section.

You should bear in mind that the routine is called on entry to the resource definition maintenance functions and at every attempt to sign on to MSS. A slow scheme can, therefore, result in poor performance.

Parent topic: Password Encryption and Decryption


Replacing the Password Encryption and Decryption Scheme

If you alter your password encryption and decryption scheme, any encrypted passwords stored in the Sign-on Table (SNT) must be decrypted using the old scheme and then re-encrypted with the new scheme. A utility program called dfhpcryp.gnt is supplied to assist in this conversion.

The procedure for moving to a new encryption scheme is described below. In this procedure, you introduce your new encryption module to the system as dfhucryu.gnt. You then run the dfhpcryp.gnt utility, which uses the existing module (dfhucryp.gnt) and your new one to perform the conversion. When the conversion is complete, you replace the existing module with your new one.

Before you make any changes, take a backup copy of the following:

  • The Resource Definition File (dfhdrdat and dfhdrdat.idx). This holds the SNT entries.
  • The current encryption module (dfhucryp.gnt).

To run dfhpcryp.gnt:

  1. Compile the new encryption module to .gnt.
    Note:

    Do not replace the existing dfhucryp.gnt at this stage. Your new module must only replace the existing dfhucryp.gnt after you have run the dfhpcryp.gnt utility to perform the conversion.

  2. Rename your new encryption module to dfhucryu.gnt and copy it into the same directory as the existing dfhucryp.gnt.
  3. Ensure that no part of MSS is active.
  4. Run the dfhpcryp.gnt utility.
  5. When dfhpcryp.gnt completes, remove dfhucryp.gnt and rename dfhucryu.gnt to dfhucryp.gnt.
  6. Back up the modified Resource Definition File.

MSS is now ready to run with the new encryption and decryption scheme.

The backups taken during this process are important in case you want to return to the old encryption and decryption scheme for any reason.

Parent topic: Password Encryption and Decryption


Configuring CICS for Databases

MSS CICS provides support for both relational and hierarchical databases. This chapter discusses the support provided.

  • Database Managers Supported
  • Using Other Database Managers
Parent topic: CICS Support


Database Managers Supported

MSS provides built-in support for the same XA-compliant database managers as Server Enterprise Edition without MSS.

You can add support for other XA-compliant database managers. To do this, you write and compile a switch module for the database. See the database vendor's documentation for advice on how to do this.

You can configure the database managers using either the Edit Server page in Enterprise Server Administration, or the CICS XAT page in ESMAC.

The support for relational database managers enables CICS applications to issue database DDL and DML statements in the form of embedded Structured Query Language. SQL requests are structured in a similar way to CICS commands. Using them, you can create, modify and query data tables.

  • To Add an XA Resource
  • To create a resource table
Parent topic: Configuring CICS for Databases
Related information
To add an XA resource to an enterprise server
To create a resource table
Configuring Resource Managers


Using Other Database Managers

You can access other, non-XA-compliant databases through . The recommended method is to use the exit program DFHUSYNC. A sample exit program is supplied as dfhusync.cbl, located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source and \base\source\win64. Follow these steps to customize the sample exit program:

  1. Add code to be invoked at any or all of the following points:

    • SEP initialization

    • The start of a CICS task

    • When rollback is required

    • When a prepare is required for a syncpoint

    • When a commit is required

    • SEP shutdown

      This code should invoke the appropriate actions from the database manager being used. If you want to enable commit and rollback processing (two-phase commit), include the SQL Communications Area (SQLCA) in the Working-Storage Section of the dfhusync.cbl module.

  2. Run dfhusync.cbl through the appropriate SQL preprocessor.

  3. In Studio Enterprise Edition, compile dfhusync.cbl to any callable format. Do not use the CICS preprocessor.

  4. Put the compiled module in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\bin, or, if Enterprise Server is installed standalone, %ProgramFiles(x86)%\Micro Focus\Server Enterprise Edition x.x\bin. This replaces the default file supplied with MSS.

Note: A CICS application that updates more than one single-phase resource compromises resource integrity
Parent topic: Configuring CICS for Databases


Intersystem Communication

This chapter describes the facilities provided by MSS for Intersystem Communication and how to set up MSS to use these facilities.

  • Overview
  • Common Configuration Tasks
  • Function Shipping
  • Asynchronous Processing
  • Transaction Routing
  • Distributed Program Linking
  • Distributed Transaction Processing
  • Network Links
Parent topic: CICS Support


Overview

Intersystem Communication (ISC) provides communications between two MSS systems, or between a CICS systemand MSS, or between a CICS system or MSS and an IBM-compatible CICS system using Mainframe Access. It enables distributed processing, where the processing of CICS transactions is split between various systems.

You need to do some configuration to get these facilities working. Some of this is common to all distributed processing facilities, while some is specific to one facility.

Parent topic: Intersystem Communication


Common Configuration Tasks

To enable any of the distributed processing facilities, you need to do the following:

  • For both outbound and inbound flows, define network links between the MSS system and the system or systems that you want to communicate with. For each remote system you define a connection.
  • For both outbound and inbound flows add a listener for Intersystem Communication to the enterprise server. This must be of type "MTO ISC", have the name "MF MTO Inter-System Communication" and have Legacy Micro Focus Application Format checked.
  • For inbound flows, add the resource group DFHISC to the startup list for the SIT. (You do not need to do this for distributed transaction processing (DTP)).
  • To Add a Service Listener to an Enterprise Server Instance
Parent topic: Intersystem Communication
Related information
To add a service listener to an enterprise server
Network Links


Function Shipping

Function shipping enables a transaction executing on a local MSS system to access remote resources (files, temporary storage queues and transient data queues).

The operation of function shipping is illustrated below.

Figure 1. Function Shipping
Function Shipping

Outbound function shipping is what happens when your local transaction programs ship functions to remote MSS systems or to IBM-compatible CICS systems.

Inbound function shipping is what happens when remote MSS systems ship functions to your MSS system.

  • Restrictions on Function Shipping
  • Configuration for Function Shipping
Parent topic: Intersystem Communication


Restrictions on Function Shipping

The following restrictions apply to function shipping as implemented in MSS:

  • You cannot ship a function directly to a DL/I (IMS) database.
  • You should not ship a function that updates a resource across multiple links, because recovery cannot be coordinated.
  • You should take syncpoints from your system and not the invoked end of the link, otherwise you might get unpredictable results.

    This is advisable because function shipping only incorporates sync level 1 logic. Whether you have single or multiple connected systems, a sync request can be propagated through all the connected systems.

Parent topic: Function Shipping


Configuration for Function Shipping

This section describes any configuration required that is specific to function shipping. See the section Common Configuration Tasks for configuration that is required for all types of intersystem communication.

You might need to do some specific configuration for outbound function shipping. There are two ways of ensuring that functions get shipped to a remote system:

  • Specify the system ID of the remote system in the relevant EXEC CICS command. For example:
    EXEC CICS READ FILE(CUSTFILE) SYSID(HS01)

    reads the file CUSTFILE which belongs to the remote system HS01.

    EXEC CICS WRITEQ TD QUEUE(QUEUE01) SYSID(HS01)

    writes to the transient-data queue QUEUE01 which belongs to the remote system HS01.

  • Specify the system ID and name of the resource in the resource's local definition. The following table shows the fields that need updating:

    Table Required Entry
    FCT The file to be accessed, specifying:
    Remote SYSID on the FCT Details page of ESMAC
    The ID of the SysC table entry for the remote system
    Remote File on the FCT Details page of ESMAC
    The name by which the file is known on the remote system. If you do not specify this field, the file is assumed to have the same name on both systems
    DCT The TD queue that can be accessed by local transactions, specifying:
    SYSID on the DCT Details page of ESMAC
    The ID of the SysC table entry for the remote system
    Name on the DCT Details page of ESMAC
    The name by which the TD queue is known on the remote system. If you do not specify this field, the TD queue is assumed to have the same name on both systems.
    TST The remote TS queue that can be accessed by local transactions, specifying:
    SYSID on the TST Details page of ESMAC
    The ID of the SysC table entry for the remote system
    Name on the TST Details page of ESMAC
    The name by which the TS queue is known on the remote system. If you do not specify this field, the TS queue is assumed to have the same name on both systems
Note: If local transactions using ANSI ship functions to an IBM-compatible EBCDIC CICS system, you must set up data conversion facilities on the remote system.
Parent topic: Function Shipping
Related information
Common Configuration Tasks


Asynchronous Processing

Asynchronous processing enables a local transaction program to initiate a transaction program on a remote system by means of the EXEC CICS START command. The remote transaction does not attempt to send a response back to the initiating local transaction program; this is what makes it asynchronous.

There are two ways of doing outbound asynchronous processing with MSS:

  • Specify in a transaction definition (PCT) that it is remote.
  • Name the system ID of the remote system in the EXEC CICS START command, which provides automatic transaction initiation (ATI).

If you use the first way, you need to do some specific configuration by defining the fields in the PCT as follows:

Required Entry

Each remote transaction that can be initiated (using ATI) by a local transaction, specifying:

Remote SYSID on the PCT Details page of ESMAC
The ID of the SysC table entry for the remote system
Remote PCT on the PCT Details page of ESMAC
The name by which the transaction is known on the remote system. If you do not specify this field, the transaction is assumed to have the same name on both systems

No specific configuration is required for inbound asynchronous processing.

Parent topic: Intersystem Communication
Related information
Common Configuration Tasks


Transaction Routing

Transaction routing enables an MSS system to invoke transactions on a remote system. The terminal attached to the local system is treated as if it were attached to the remote system.

The operation of transaction routing is illustrated below.

Figure 1. Transaction Routing
Transaction Routing
  • Implementing Transaction Routing
  • Restrictions on Transaction Routing
  • Configuration for Transaction Routing
Parent topic: Intersystem Communication


Implementing Transaction Routing

You can implement transaction routing in MSS in either of two ways:

  • Specify that particular transactions are to be routed to a remote system. See the section Configuration for Transaction Routing later in this chapter for more information on how to set up this implementation of transaction routing.
  • Use the supplied transaction CRTE to create a routing session on a remote system.
  • Using the Routing Transaction CRTE
  • Defining Remote Terminals
Parent topic: Transaction Routing
Related information
Configuration for Transaction Routing


Using the Routing Transaction CRTE

You can use the supplied transaction CRTE to start a routing session on a remote system. When the routing session has been established, your local system appears as a remote terminal to the remote system. All transactions invoked during this session are executed on the remote system.

The use of CRTE to implement transaction routing is illustrated below.

Figure 1. Transaction Routing via CRTE
Transaction Routing via CRTE

No configuration of the local or remote system (other than the link itself) is required when using CRTE. You should use CRTE, instead of making PCT definitions, in the following cases:

  • For infrequently-invoked transactions.
  • For transactions that reside on all of your systems.

Note that, because the routing session has to be explicitly established and canceled, you might have to perform additional signon operations.

CRTE supports both conversational and pseudo-conversational transactions. Transactions invoked by PA or PF keys cannot be invoked through CRTE.

Parent topic: Implementing Transaction Routing


Defining Remote Terminals

The remote system needs a definition of the terminal from which the transaction is issued. You can either:

  • Define the terminal in the remote system as well as the local system. This method is known as duplicating a terminal definition.
  • Ship the local definition to the remote system when a transaction is routed to the remote system. This method is known as shipping a terminal definition.

3270 terminals and printers default to the shipping method, but you can duplicate the definitions if you choose.

With either method, each terminal name must be unique across the entire network.

Shipping definitions has some advantages over duplicating definitions:

  • You can save on the use and maintenance of disk storage on the remote system because the remote terminal definitions are not stored there.
  • You also save the initial labor of entering the remote definitions on the remote system.
Parent topic: Implementing Transaction Routing


Restrictions on Transaction Routing

There are several restrictions that apply to the transaction routing as implemented in MSS:

  • BMS paging is not supported.
  • The fully-qualified network name might not be available in the IBM mainframe monitoring record of an APPC link.
  • You should not invoke a transaction on a remote mainframe CICS system that uses the MSGINTEG(YES) or PROTECT(YES) options, as they cannot be honored on sync level 1 links.
Parent topic: Transaction Routing


Configuration for Transaction Routing

This section describes any configuration required that is specific to transaction routing. See the section Common Configuration Tasks for configuration that is required for all types of intersystem communication.

You might need to do some specific configuration for outbound transaction routing. There are two ways of ensuring that transactions get routed to a remote system:

  • Specify the transaction that you want to route and the system ID of the remote system in an EXEC CICS START command. For example:
    EXEC CICS START TRANSID(CWEN)SYSID(HS01)

    starts the transaction CWEN on the remote system HS01.

  • Specify the system ID and transaction ID in the resource's local definition. The following table shows the fields that need updating
    Table Required Entry
    PCT Each remote transaction that can be initiated (using ATI) by a local transaction, specifying:
    Remote SYSID on the PCT Details page of ESMAC
    The ID of the SysC table entry for the remote system
    Remote PCT on the PCT Details page of ESMAC
    The name by which the transaction is known on the remote system. If you do not specify this field, the transaction is assumed to have the same name on both systems

No specific configuration is required for inbound transaction routing.

Parent topic: Transaction Routing
Related information
Common Configuration Tasks


Distributed Program Linking

Distributed program linking (DPL) enables a program running on MSS to link to a program running on a remote system. This provides an easy way to access DL/I (IMS) and SQL databases and BDAM files on a remote CICS system.

  • Restrictions on Distributed Program Linking
  • Abends When Using Distributed Program Linking
  • Configuration for Distributed Program Linking
Parent topic: Intersystem Communication


Restrictions on Distributed Program Linking

There are certain restrictions on the types of program to which you can link using the distributed program linking feature of MSS.

You cannot link to programs that:

  • Issue terminal control commands from a connected system back to MSS.
  • Inquire on terminal attributes.
  • Issue BMS commands.
  • Issue data interchange commands.
  • Address the TWA or the TCTUA. You must use the COMMAREA to pass data between systems, or you might get unpredictable results.
  • Issue syncpoints. DPL incorporates only sync level 1 logic. Whether you have single or multiple connected systems, a sync request can be propagated through all the connected systems. You should therefore take syncpoints from your system and not the invoked end of the link, otherwise you might get unpredictable results.

In addition to these restrictions, you should also be aware that when you are accessing DB2 from a transaction running on MSS, security access to the DB2 application plan is based on the transaction ID under which the program runs. The default transaction ID is one of the mirror transactions CPMI, CSMI and CVMI. To enable greater selectivity for DB2 application plans, you can specify an alternative transaction ID in either the PCT entry or in the EXEC CICS LINK command. This transaction muct be defined in the target system and must point to the mirror program DFHZCSMI. In all other respects (such as security attributes and task priority), the mirror transaction operates normally.

Parent topic: Distributed Program Linking


Abends When Using Distributed Program Linking

If the remote program terminates abnormally, the remote system's mirror program returns the last abend code to MSS, using the ASSIGN ABCODE command. The remote program might have handled other abends before terminating.

Parent topic: Distributed Program Linking


Configuration for Distributed Program Linking

This section describes any configuration required that is specific to distributed program linking. See the section Common Configuration Tasks for configuration that is required for all types of intersystem communication.

You might need to do some specific configuration for outbound distributed program linking. There are two ways of linking to a program on a remote system:

  • Specify the system ID of the remote system in the relevant EXEC CICS command. For example:
    EXEC CICS LINK TRANSID(PPQQ) SYSID(HS01)

    links to the transaction program PPQQ which belongs to the remote system HS01.

  • Specify the system ID and name of the resource in the resource's local definition. The following table shows the fields that need updating
    Table Required Entry
    PPT Each remote program to which a local program can link, specifying:
    Remote SYSID on the PPT Details page of ESMAC
    The ID of the SysC table entry for the remote system
    Remote Prog on the PPT Details page of ESMAC
    The name by which the program is known on the remote system. If you do not specify this field, the program is assumed to have the same name on both systems.
    Rmt Trans ID on the PPT Details page of ESMAC
    The name of the transaction (overriding the default mirror transaction ID) under which to run the remote program. This mechanism allows greater flexibility when the remote program accesses DB2 as the DB2 application plan is based upon the active transaction.
Note:

If local programs that use a different character set (ANSI or EBCDIC) are linked, you may need to set up data conversion facilities on the remote system.

Parent topic: Distributed Program Linking
Related information
Common Configuration Tasks


Distributed Transaction Processing

Distributed Transaction Processing (DTP) allows a CICS transaction running in one system to communicate with a transaction running in another system. The transactions are written and designed to communicate with each other over the intersystem communication link. DTP provides facilities so that two programs can communicate with each other, signal each other with regard to their status, and jointly commit modifications to protected resources.

DTP takes place between programs that are designed to be a matched pair. Their activities, command utilization, error protocols, and message formats must all be coordinated. MSS enables running transactions to initiate and communicate synchronously with transactions in remote systems that support the APPC protocols.

  • Restrictions on DTP
  • Configuring for DTP
Parent topic: Intersystem Communication


Restrictions on DTP

The following restrictions apply to Distributed Transaction Processing:

  • Process Initialization Parameter (PIP) data represented by the PIPLIST and PIPLENGTH operands for the CONNECT PROCESS and EXTRACT PROCESS commands is not transmitted by MSS, even though the operands are recognized by the MSS preprocessor.
  • Inbound transaction processing names can be no greater than four characters in length.
Parent topic: Distributed Transaction Processing


Configuring for DTP

The links to any interconnected system must be defined according to the examples provided in the section Network Links. You can either define any programs and transactions that are to participate in a DTP conversation through resource definition table entries on both the local and remote system or specify them in the CONNECT PROCESS and EXTRACT PROCESS commands.

Parent topic: Distributed Transaction Processing
Related information
Network Links


Network Links

The distributed processing facilities described above require that a network link is set up between the client and server systems. This section describes how to set up these links.

  • Types of Network
  • Supported Link Types
  • Communications Definitions
Parent topic: Intersystem Communication


Types of Network

This section describes the setting up of network links for the following types of communications network:

  • MSS to mainframe CICS and mainframe CICS to MSS
  • MSS to MSS

These are the network links that you can use for function shipping, asynchronous processing, transaction routing, distributed program linking and distributed transaction processing.

Parent topic: Network Links


Supported Link Types

You use TCP/IP network links for all types of Intersystem Communication .When you use TCP/IP to connect to the mainframe, you also need Micro Focus Mainframe Access Version 3.0 or above. Configuring MSS to use TCP/IP network links is described below.

Parent topic: Network Links


Communications Definitions

This section describes the definitions you need to make to enable communications. To create the necessary definitions you use the SysC page in ESMAC: from the Server page, click the Services dropdown in the Resources group in the left-hand menu, click By type, then click SysC. You see the list of existing SysC definitions. Click SysC in the New panel of buttons at the bottom of the page.

You must set the following fields:

Name | The name of the target system: this is also the value you enter in SYSID when you define a remote transaction
MF Node | The text host name or dotted decimal address of the target server
MF Port | The decimal value of the port that the target server listens on
Net Name | The name of the target enterprise server or CICS region
Session Max | The maximum number of send sessions

You need a connection definition for the enterprise server that is initiating the conversation. If you create a connection definition in both enterprise servers and both servers try to initiate the connection, MSS resolves the contention.

If you specify the home enterprise server as the target enterprise server (that is, Net name is the same as the name of the current enterprise server), MSS ignores the entry. This is useful because it enables a number of servers to share a single group that specifies the connections for all the regions.

You also need to add a listener for Intersystem Communication to each enterprise server that uses ISC. For more information see the section Common Configuration Tasks.

  • MSS-to-mainframe Example
  • Bidirectional MSS-to-mainframe Example
  • MSS-to-MSS Example
Parent topic: Network Links
Related information
Common Configuration Tasks


MSS-to-mainframe Example

In this example an MSS-enabled enterprise server is to be connected to a CICS region on a mainframe using TCP/IP and Mainframe Manager. The connection definition is shown below.

Figure 1. Example of MSS to Mainframe Connection Definition
Example of MTO to Mainframe Connection Definition

The name of the definition, RSYS in this example, must match the server name as defined in the Mainframe Access server definition, which in turn points to the target CICS region on the mainframe. This example would have a Mainframe Access server definition similar to the folllowing:

<MCOID=RSYS>
LUNAME=CICSTSR3
TPNAME=*
MODENAME=#INTER
SYNCLEVEL=0
SECURITY=NONE
<END>
Parent topic: Communications Definitions


Bidirectional MSS-to-mainframe Example

You must configure the Mainframe Access Server to enable ES/MSS outbound communications and provide it with definitions for the target CICS and target ES/MSS systems.

You must also create an appropriate connection definition for your enterprise server. The connection definition is shown below.

Figure 1. Example of MSSto Mainframe Connection Definition
Example of MTO to Mainframe Connection Definition

As with the previous example, the name of the definition, RSYS in this example, must match the server name as defined in the Mainframe Access server definition, which in turn points to the target CICS region on the mainframe. This example would have a Mainframe Access server definition similar to the folllowing:

<MCOID=RSYS>
LUNAME=CICSTSR3
TPNAME=*
MODENAME=#INTER
SYNCLEVEL=0
SECURITY=NONE
<END>
Note: If your enterprise server is not going to initiate the communications, you can omit the connection definition.
Parent topic: Communications Definitions


MSS-to-MSS Example

Two MSS-enabled enterprise servers, PEERSRV1 and PEERSRV2, are to be connected using CCITCP. Two connection definitions are shown, although only one is required.

The connection definition for the first region is shown below.

Figure 1. Example Connection Definition for PEERSRV1
Example Connection Definition for PEERSRV1

The connection definition for the second region is shown below.

Figure 2. Example Connection Definition for PEERSRV2
Example Connection Definition for PEERSRV2
Parent topic: Communications Definitions


Setting Up Communications with Mainframe CICS Regions

This section describes how to configure communication links between CICS regions operating on an Enterprise Server environment, and mainframe CICS regions.

Note:

This functionality is available for both Windows and UNIX environments.

You can also configure links between an Enterprise Server environment, and files residing on a mainframe. This functionality is covered in a different area of the help.

  • Connecting to a Mainframe: Overview
  • System Architecture
  • Communications Software Requirements
  • Process Overview
  • Configuration Definitions
  • Mainframe Connection Information Requirements for 802.2 DLC
  • Installing the Communications Server Software
  • Configuring Communications Server to Mainframe Communication
  • Connecting a Client to the Host CICS Region
  • Defining a CICS Connection from the Host to the Local COBOL System
  • Setting Up Communications from Host to Local CICS System
Parent topic: CICS Support
Related concepts
Working with Mainframe Files


Connecting to a Mainframe: Overview

The configuration described in this section uses an SNA link between CICS applications running on a mainframe and CICS operating on a local COBOL system, that is one that operates on one or more local Windows or UNIX machines.

Note:

This functionality allows Enterprise Server to connect to a remote peer system using a SYS62 connection and support the standard 2-Phase Commit protocoL.

One of the benefits that this functionality provides is that it improves transactional data integrity between CICS applications running on a UNIX platform, and CICS applications running on a mainframe under z/OS.

To configure a link between Enterprise Server and Mainframe CICS regions, you should be familiar with:
  • The concepts of a CICS system, and how it can operate over multiple machines in a single system environment
  • CICS intersystem communication requirements.
  • Configuring the communications software on the local server.
  • Configuring the communications software on the client.

For information on communication between IBM CICS products, see the IBM publication CICS Family: Interproduct Communication, SC33-0824.

Parent topic: Setting Up Communications with Mainframe CICS Regions


System Architecture

A system that connects a mainframe CICS region and an Enterprise Server CICS region uses communications server software, for example to manage SNA communications.

  • In the Windows environment, Microsoft Host Integration Server.
  • In a Sun Solaris UNIX environment, SNAP-IX

An installation typically consists of:

  • A mainframe running CICS applications.
  • A PC or a UNIX communications server with a dedicated SNA link to the mainframe. This runs communications server software, and acts as an SNA manager.
  • One or more client PCs or UNIX machines running communications server SNA client software, and Enterprise Server COBOL systems.

For details of the communication server's hardware and software requirements, refer to the documentation for the communications software that you are using.

Parent topic: Setting Up Communications with Mainframe CICS Regions


Communications Software Requirements

The communications software that you use depends on your platform. Available platforms and the corresponding communications server software to use with each is as follows:

  • AIX

    IBM Communications Server for AIX

  • HP-UX

    HP-UX SNAplus2 Link

  • Microsoft Windows

    Microsoft BizTalk Host Integration Server

    Note: If you install this on a x64 machine the installation process installs only the 64bit libraries. In order to use a SYS62 connection your region MUST BE 64-bit. This is an issue only with Microsoft BizTalk Host Integration Server.
  • Red Hat/SUSE Linux

    IBM Communications Server for Linux

  • Red Hat/SUSE Linux on zSeries

    IBM Communications Server for Linux on zSeries

  • Solaris

    SNAP-IX

Parent topic: Setting Up Communications with Mainframe CICS Regions


Process Overview

To set up an SNA link between a mainframe CICS environment and CICS regions on local enterprise servers, follow the procedures outlined in the following four stages. The procedures describe how to configure an 802.2 DLC connection:

  • Configure the communication link between the local SNA Communications server and the mainframe host:

    This stage involves installing the SNA Server software on the local SNA Communications server and any clients running Enterprise Server, and configuring the SNA link from the local SNA Communications server to the mainframe.

  • Connect the local CICS system to the Host CICS region:

    This stage involves configuring the connections between the local CICS systems (running on any clients), and the CICS region running on the host.

  • Define the client connections and sessions to the host:

    This stage involves defining the local connections and sessions to the host CICS region, so that the host can recognize sessions running on the client COBOL system.

  • Set up communications from the host to the local CICS system:

    This stage involves configuring the link so that the host can initiate tasks on a local CICS system.

This chapter provides an overview of the procedures in each stage. For detailed information on each procedure, refer to the documentation delivered with the SNA Communications software that you are using.

Each procedure includes a list of the information you need to configure an 802.2 DLC connection. You can collect this information from your mainframe system administrator. An example value is included for each setting required. These example values are used consistently across the procedures described in this chapter, to help clarify situations where different procedures use the same values.

Parent topic: Setting Up Communications with Mainframe CICS Regions


Configuration Definitions

The terminology used often varies between environments and communications service managers used. The following table details the terminology that is used in this chapter. Alternative names are shown in parentheses.

Generic Term | Description
Client | A machine, running a COBOL system, where you install communications client software. This machine accesses a host CICS environment via a local server.
Data Link Control (DLC) link The interface to the network. The attributes of a link can be divided into two parts:
  • Characteristics of the port (logical and physical)
  • Control characteristics of the link
Control Point (CP, CP Name) | Identifies the local node manager that provides services to the local logical units.
Link station | The part of data link control (DLC) that is responsible for the transfer of data between two communications services managers connected by a link.
Local server | The machine with the SNA link to the host, where you install communications server software, to provide access to a COBOL System running on client PCs.
Network name (NETID) | The name of the network to which the system is connected.
Logical Unit (LU) | A network accessible unit (NAU). In SNA there are a number of logical unit types that identify the protocols supported by that logical unit. For APPC the LU type is 6.2 referred to as LU 6.2.
Partner LU | The logical unit with which to communicate.
Transaction Program (TP) | The program to be executed at one end of a conversation.
Session | The logical connection between two network accessible units.
Inter Systems Communications (ISC) | Two or more regions running on different processor complexes that are able to communicate with each other.
Mode | The connection characteristics of a session.
Parent topic: Setting Up Communications with Mainframe CICS Regions


Mainframe Connection Information Requirements for 802.2 DLC

For an 802.2 DLC connection, you require, from your mainframe system administrator, the information detailed in the table below. For each item, the table lists the configuration task that requires the information, and an example value. For details of the local information required, refer to each task.

Parameter from the VTAM System Administrator | Task and Example Value | Description
Remote Network Name (NETID) | Configuring the Local Server: HSTNET1 | The network name of the VTAM domain. All resources that comprise this VTAM domain are in this VTAM domain.
Local Control Point (CP) name assigned to the local server | Configuring the Local Server: MCOPU020 | The unique PU identifier created by the mainframe administrator for the local server. This is specified in the VTAM PU definition for this machine. That is, the CP name matches the PU identifier.
Remote Network Address | Configuring the Connection Address: 400000004044 | 12-digit hexadecimal network address of the remote host system's network controller.
Remote Control Point (CP) Name (also known as SSCPNAME) | Configuring the System Identification: HSTMVS | The name of the remote system
The XID format used by the host system | Configuring the System Identification: 3 (default) | The XID format can be either 0 or 3. A format of 3 is generally used for APPC (and must be used for independent APPC LUs). The older format, 0, tends to be used for 3270 devices.
Remote Node ID | Configuring the System Identification: None | An 8-digit hexadecimal number used to identify the host system on the SNA network. Your mainframe system administrator will advise whether or not you need to use this.
Local Node ID | Configuring the System Identification: 05D,22222 | An 8-digit hexadecimal number used to identify the local system on the SNA network. The first three digits are the IDBLK and the last five are the IDNUM. These must correspond with the IDBLK and IDNUM fields of the VTAM PU definition for this machine, as defined on the host system.
Maximum Basic Transmission Unit (BTU) Length (also known as I-Frame) | Configuring 802.2 DLC Properties: 1493 | The number of bytes that can be transmitted in a single data link control frame. This is calculated by subtracting 9 from the MAXDATA parameter of the PU definition for this machine (that is, maximum BTU length = MAXDATA - 9). This is a maximum value. The actual value used is negotiated to the highest value below this figure that is acceptable to both partners.
List of independent LUs for your PU definition. | Configuring Local APPC LUs: MCOLU021 | These LUs are required for APPC and are defined in the list of LUs defined for your PU on VTAM. You can have multiple independent LUs per PU. All independent LUs for your PU have LOCADDR set to zero under the PU definition on VTAM.
Target LU Name | Configuring Remote LUs: HSTCICS1 | This should match the LU definition as it exists on the remote system, in this case, a VTAM APPLID definition on the host system. To communicate with a host CICS system, this is the APPLID of the host CICS environment .
List of the dependent LUs defined as terminals with their associated LU number for your VTAM definition. Configuring a 3270 LU for the 3270 Applet:
  • MCOTRM22,2
  • MCOTRM23,3
  • MCOTRM24,4
These LUs are used for terminals to the host. They are not required for APPC, but are very useful for the host CICS configuration. They are found under your PU definition on VTAM. The LU number must match the associated LOCADDR number for this named LU.
The Mode Table defining the session limits for the connection | Configuring Remote LUs: #INTER | This is used to negotiate the session limits with the host. Normally the host would use the default mode of #INTER. If #INTER is not appropriate, you can define and use another mode. If you need to define another mode, your VTAM system administrator should be able to supply the parameters required, and the Host Integration Server 2006 Helpthe Host.
Parent topic: Setting Up Communications with Mainframe CICS Regions


Installing the Communications Server Software

You need to install the communications server software on both the communications server, and on Enterprise Server clients that connect to it. The process varies depending on your environment and the communications server software that you use.

  • Installing the Communications Server Software on the Local Server
  • Installing the Communications Software on the Local Clients
Parent topic: Setting Up Communications with Mainframe CICS Regions


Installing the Communications Server Software on the Local Server

In this procedure, you install the communications server software onto the local communications server, and add the configuration details required to define the local server.

Parameter | Example value | Origin and description
Remote network name (NETID) | HSTNET1 | Mainframe administrator: the VTAM domain's network name.
Local control point (CP) name assigned to the local machine | MCOPU020 | Mainframe administrator: the VTAM PU assigned to the local Microsoft HIS server.
Parent topic: Installing the Communications Server Software


Installing the Communications Software on the Local Clients

In this procedure, you install the communications software onto each of the local Enterprise Server clients.

Parameter | Example value | Origin and description
Sponsor server | NY-HOST-5 | The network name of the host system.
SNA Service Account | NYDOMAIN\MCOU | A valid user ID for the system
Parent topic: Installing the Communications Server Software


Configuring Communications Server to Mainframe Communication

For specific details on performing each stage outlined in this section, refer to your communications server software documentation.

To enable a mainframe CICS environment to communicate with an Enterprise Server COBOL system attached to the communications server, an LU 6.2 link is required between the local server and the mainframe. The LU 6.2 link is separated into SNA Server (PC) and VTAM (mainframe) components.

  • Configuring the Link Service for the local server
  • Configuring the connection
  • Configuring the remote system's network address
  • Configuring the System Identification
  • Configuring 802.2 DLC Properties
  • Configuring Local APPC LUs
  • Configuring Remote LUs
  • Adding a User
  • Configuring a 3270 LU for Terminal Access
  • Associating a 3270 LU with a User
  • Activating the Configuration in the Windows Environment
Parent topic: Setting Up Communications with Mainframe CICS Regions


Configuring the Link Service for the local server

In this procedure, you create a new DLC 802.2 Link Service and specify the network adaptor that the link service uses.

Parameter | Example value | Origin and description
Link service name | SNADLC1 | User-assigned
Adapter | 4 | User-assigned

If the local server has more than one PU to the mainframe, you will need more than one link service. Each PU to a host requires a unique Local Service Access Point (SAP) address. If you are defining your first link service, use the default of 4. For a host with multiple PUs, the link service adapter number must be a hexadecimal number that is a multiple of 4, and is in the range of 04 to EC.

Parent topic: Configuring Communications Server to Mainframe Communication


Configuring the connection

In this procedure, you define the 802.2 connection for the local server.

Parameter | Example value | Origin and description
Connection name | MVSHOST1 | User-assigned
Link service | SNADLC1 | Defined when you configure the local server
Remote End | Host System | Defines the mainframe as the remote system
Allowed Directions | Both Directions | Allows communications in both directions
Activation | By Administrator | Can change this after testing to either On Demand, or At Server Startup
Parent topic: Configuring Communications Server to Mainframe Communication


Configuring the remote system's network address

In this procedure, you configure the remote system's network address.

Parameter | Example value | Origin and description
Remote Network Address | 400000004044 | Mainframe system administrator: Network address of the remote host system's network controller
Parent topic: Configuring Communications Server to Mainframe Communication


Configuring the System Identification

In this procedure, you configure the remote network system identification details.

Parameter | Example value | Origin and description
Remote Network Name | HSTNET1 | Mainframe system administrator: The network name of the VTAM domain.
Local Control Point Name | MCOPU020 | Mainframe system administrator: the VTAM PU identifier assigned to the local machine.
Local Node ID | 05D,22222 | Mainframe system administrator: identifies the local system on the SNA network.
XID Type | Format 3 | Mainframe system administrator: can be either 0 or 3, generally 3.
Remote Network Name | HSTNET1 | Mainframe system administrator: The network name of the VTAM domain.
Remote Control Point Name | HSTMVS | Mainframe system administrator: The name of the remote system
Remote Node ID |  | Mainframe system administrator will advise whether you need to use this. Identifies the host system on the SNA network.
Parent topic: Configuring Communications Server to Mainframe Communication


Configuring 802.2 DLC Properties

In this procedure, you configure the maximum Basic Transmission Unit (BTU) length for the connection.

Parameter | Example value | Origin and description
Max BTU Length | 1493 | The maximum number of bytes that can be transmitted in a single data link control frame. The actual value is the maximum value acceptable to both partners, up to the maximum value.

Before attempting to communicate to the host you must define the local and remote LUs that will be used to communicate over the SNA connection you have configured.

Parent topic: Configuring Communications Server to Mainframe Communication


Configuring Local APPC LUs

In this procedure, you configure the Local APPC Logical Units (LUs). Independent LUs are used to communicate over the host connection. You need to configure:

  • Local Advanced Program to program Communication (APPC) LUs
  • Remote LUs
Parameter | Example value | Origin and description
LU Alias | MCOLU021 | Mainframe system administrator: defined in the list of LUs configured for your PU on VTAM.
LU 6.2 type | Independent |
Network Name | HSTNET1 | Mainframe system administrator: The network name of the VTAM domain.

If you are using multiple APPC LUs, you can configure each of them as follows:

Parent topic: Configuring Communications Server to Mainframe Communication


Configuring Remote LUs

In this procedure, you configure a remote Logical Unit ( LU) that is assigned to a connection.

Independent LUs are used to communicate over the host connection. You need to configure:

  • Local Advanced Program to program Communication (APPC) LUs
  • Remote LUs: When communicating with host systems running VTAM (or NCP), the Remote LU is known as the APPLID.
Parameter | Example value | Origin and description
Connection | MVSHOST1 | Defined in the Configuring the Connection task.
LU Alias | HSTCICS1 | Mainframe system administrator: This LU name should match the definition of the LU as it exists on the remote system, in this case in the form of a VTAM APPLID definition on the host system. To communicate with a host CICS system, this is the host CICS APPLID.
Implicit Incoming Mode | #INTER | Mainframe system administrator: Used to negotiate the session limits with the host.
Network Name | HSTCICS1 | Defaults to the value specified for the connection
Note:

When a connection is established between a Local LU and a Remote LU, the Mode characteristics are negotiated. The partner system (for example, the mainframe) may reduce the session limits, and fewer client sessions than expected may be supported. Hence it is important that the Mode characteristics as defined for both the Local and Remote LUs are compatible.

Parent topic: Configuring Communications Server to Mainframe Communication


Adding a User

Before you can use a connection you need to be defined to the communications server as a user.

Parameter | Example value | Origin and description
User | MCOU | User-defined. A user name.
Parent topic: Configuring Communications Server to Mainframe Communication


Configuring a 3270 LU for Terminal Access

In order to enable terminal access to the host system, a 3270 LU must be configured for use by each terminal session.

This operation can be repeated for other 3270 dependent LUs for your PU. With a 3270 LU configured with the values below, the operation could be repeated for LU MCOTRM23 with an LU number of 3, and MCOTRM24 with an LU number of 4.

Parameter | Example value | Origin and description
LU number | 2 | Mainframe system administrator: LUs used for terminals to the host.
LU name | MCOTRM22 | Mainframe system administrator: LUs used for terminals to the host.
Parent topic: Configuring Communications Server to Mainframe Communication


Associating a 3270 LU with a User

When a user runs a terminal emulator session, a 3270 LU is required in order to establish a 3270 session with the host system. This LU may come from a pool of 3270 LUs or it may be associated with the user. The example values define a pool and associate a user to this pool.

Parameter | Example value | Origin and description
Pool | DevPool | User-defined
Display Model Attributes | 2 (25x80) |
Assign to user | MCOU | A user that you have configured
Parent topic: Configuring Communications Server to Mainframe Communication


Activating the Configuration in the Windows Environment

To activate the configuration in the Windows environment, you must stop and restart the Server service.

Provided the 'Activation Type' was defined as 'On Server Startup' or 'On Demand', when the server is active, the underlying connections activate.

When configured for Incoming and Outgoing calls, the status for Connections becomes 'On Demand/Incoming' when successfully activated. The connection status becomes 'Active' when the first session is established, or if the connection is activated manually by the administrator.

Parent topic: Configuring Communications Server to Mainframe Communication


Connecting a Client to the Host CICS Region

Once you have configured communications server software on the server, you can configure each client to communicate with the host CICS region.

  • Client - Host Configuration Parameters
  • To Define a Client Connection to a Host CICS System
  • To Include the Resource Group in the Startup List
Parent topic: Setting Up Communications with Mainframe CICS Regions


Client - Host Configuration Parameters

The parameters that you require for configuring the client to the host are:

Client Name | From your VTAM Administrator | Host CICS Name as in CEDA | Example Value | Matching SNA Server Parameter
LU alias | Independent LU for the connection's PU that you are going to use |  | MCOLU021 | SNA Server value for 'LU Alias' in the 'Local APPC LU' definition for the APPC LU that you are going to use
Partner alias | Target LU name for your connection |  | HSTCICS1 | SNA Server value for 'LU Alias' in the 'Remote APPC LU'; the host CICS system's APPLID
Alias applid | The APPLID of the local client as defined to the host. This is not in the list above because it takes a default value. |  | MCOLU021 | SNA Server value for 'LU Name' in the 'Local APPC LU' definition for the APPC LU that you are going to use. Normally the same as 'LU Alias'.
Mode table | The mode table defining the session limits for the connection | 'MOdename' under 'Session Identifiers' | #INTER | SNA Server value for 'Implicit Incoming Mode' in the 'Remote APPC LU'
Net name | Your local CICS system's network name. This is the same as Alias APPLID. | 'Netname' under 'Connection Identifiers' | MCOLU021 | SNA Server value for 'LU Name' in the 'Local APPC LU' definition for the APPC LU that you are going to use. Normally the same as 'LU Alias'.
Parent topic: Connecting a Client to the Host CICS Region


To Define a Client Connection to a Host CICS System

To define a client connection to a host CICS system use the Enterprise Server Administration interface.

  1. Open the Enterprise Server Administration screen, and on the administration page click Start next to the name of the CICS server you want to use.
  2. ClickDetails next to the name of the server and navigate to Server...> Control> ES Monitor and Control. The Server information page is displayed.
  3. In the Resources panel on the sidebar, choose by Group from the list and then click Groups.
  4. Add a new group or choose a group to add your connection definition to. Click Details next to the group's name.
  5. On the details page click Sys62. This opens the page for creating a LU6.2 system connection.
  6. Enter the following values:
    • Name of the Sys62.

      This name does not relate to any other setting on the mainframe. The name value you choose for this is the one you use in your programs or in a terminal.

      For example CRTE SYSID=XXXX where XXXX is the name of the Sys62 connection that you have defined here.

    • (Optional) Description of the Sys62.
    • In the LU Alias field, enter the independent LU name for your PU as defined on VTAM.
    • In the Partner Alias field, enter the APPLID of the remote CICS system.
    • In the Net Name, enter the APPLID of the remote system or region.
    • In the APPLID field, enter the APPLID of the local system as defined to the host.
    • In the Mode table field, enter the mode table that the SNA Server and the host are to use.
    • In the Session maximum field, enter the maximum number of sessions between LU-LU pairs. The maximum number supported is: 5.
  7. Click Group list to return to the group’s details page.
  8. Click PPT. The Processing Program Table page opens.
  9. Enter the following values:
    • PPT name.
    • (Optional) Description.
    • Remote SysID. The value should be equal to the name you have entered for the Sys62.
  10. Return to the Server home page.
Parent topic: Connecting a Client to the Host CICS Region


To Include the Resource Group in the Startup List

To include a resource group in the startup list use the Enterprise Server Administration interface.

  1. Open the Enterprise Server Administration page and click Start next to the name of the CICS server you want to use.
  2. Click Details next to the name of the server and navigate to Server... > Control > ES Monitor and Control. The Server information page is displayed.
  3. In the Resources panel on the sidebar, choose by Group from the list and then click Groups. A list of all resource groups that are currently included in the host CICS system's definitions is displayed.
  4. Click New. The new group page is displayed.
  5. Enter:
    • Name of the group.
    • (Optional) Description of the group.
Parent topic: Connecting a Client to the Host CICS Region


Defining a CICS Connection from the Host to the Local COBOL System

In order for the host CICS region to recognize a COBOL system running on a local client, you need to define a connection definition and an associated session on the host. On most host systems, a CICS region change such as this is usually applied by the system administrator. Liaise with your system administrator to perform this process.

You need to have a resource group for the connection and session definitions. The example group value is HSTTOSNA. The example connection name is LU21 and the session name is LU21SESS.

You can use an SNA Server 3270 applet to configure the host CICS system by entering the VTAM ID of your host CICS region when the terminal has a connection to the host VTAM system.

  • Using the CEDA Transaction to Configure the Host CICS Regions
  • Defining a Terminal for Transaction Routing
  • Installing the Definitions
  • Configuring a Default Terminal
  • Testing the Connection to the Host CICS System
  • Starting the Local CICS Connection
Parent topic: Setting Up Communications with Mainframe CICS Regions


Using the CEDA Transaction to Configure the Host CICS Regions

This procedure describes how to use the IBM-supplied transaction CEDA to configure the host CICS regions. For more information on the CEDA transaction, see the IBM publication CICS/ESA 3.3 Resource Definition.

In the following procedures, accept the default values for the fields that are not described. When you have defined your connection and sessions, and have tested them, you can configure the connections and settings to be installed automatically on the host CICS region at startup. You can do this by adding the group to your CICS startup list.

  1. In CICS, on the host system, enter the following transaction:

    transaction 'CEDA DEFINE GROUP(group_name) CONNECTION(connection_name)

    where group_name is the name of the group containing the connection connection_name. A transaction using the example values in this chapter is:

    CEDA DEFINE GROUP(HSTTOSNA) CONNECTION(LU21)

  2. In the Netname field, under Connection Identifiers, type the netname of you local COBOL system and press Enter. You should receive the message Define Successful near the bottom of the screen.
  3. Press PF3 to end CEDA, followed by Clear.
  4. Enter the transaction:

    CEDA DEFINE GROUP(group_name) SESSION(session_name)

    where group_name is the name of the group containing the session session_name. A transaction using the example values in this chapter is:

    CEDA DEFINE GROUP(HSTTOSNA) SESSION(LU21SESS)

  5. In the Connection field, under Session Identifiers, type the name of the connection you have defined. The example value is LU21.
  6. In the MOdename field, under Session Identifiers, type the name of the mode table that you are using. The example value is #INTER.
  7. In Session Properties you need to enter the maximum number of sessions in the group and the maximum number of contention winners. Example values are 8 and 4 respectively.
  8. If required, change send size and receive size default values. This will depend on your mode table.
  9. Press Enter and you should receive the message Define Successful near the bottom of the screen.
  10. Press PF3 to end CEDA, followed by Clear.
Parent topic: Defining a CICS Connection from the Host to the Local COBOL System


Defining a Terminal for Transaction Routing

On some versions of VTAM you might need to define a terminal so that you can perform transaction routing to the host CICS region from the local COBOL system.

This requirement is indicated by the error message TXCS1012E Comms error x'0006' during route of TRAN to system HST1 when you enter the first transaction ID to be run on the host CICS region.

If you define a transaction routing terminal, you also need to change the default terminal configuration. The example transaction routing terminal is: L21A.

  1. Enter the transaction:

    CEDA DEFINE GROUP(group_name) TERMINAL(terminal_id)

    where group_name is the name of the group containing the terminal_id terminal definition. With the example values, the command is

    CEDA DEFINE GROUP(HSTTOSNA) TERMINAL(L21A)

  2. Enter the following details under Terminal Identifiers:
    • Typeterm = DFHLU2
    • Netname=L21A
    • REMOTESYSTem = LU21
    • REMOTEName = L21A
  3. Press Enter and you should receive the message 'Define Successful' near the bottom of the screen.
  4. Press PF3 to end CEDA, followed by Clear.
Parent topic: Defining a CICS Connection from the Host to the Local COBOL System
Related information
Configuring a Default Terminal


Installing the Definitions

After you have defined the connection, the session, and, if required, the terminal, you need to install the terminal definitions. As a connection and a session are paired, you need to install the group that they are contained in rather than the individual entries.

  • Using the example values, on your host CICS region, enter:

    CEDA INSTALL GROUP(HSTTOSNA)

    The message: Install Successful is displayed.

Parent topic: Defining a CICS Connection from the Host to the Local COBOL System


Configuring a Default Terminal

You only need to do this if you receive the following message when you enter the first transaction ID to be run on the host CICS region:

TXCS1012E Comms error x'0006' during route of TRAN to system HST1

To configure a default terminal use the Enterprise Server Administration interface.

Parent topic: Defining a CICS Connection from the Host to the Local COBOL System
Related information
Defining a Terminal for Transaction Routing


Testing the Connection to the Host CICS System

To test your connection to the host CICS system you need to ensure that:

  1. The local communications server has an active link to the host.
  2. The host CICS region is running. In most installations this is the case, but sometimes you may need to ask your host system administrator to start the host CICS region that you are going to connect with. It can usually be tested by using an SNA Server 3270 applet and entering the VTAM ID of your host CICS region when the terminal has a connection to the host VTAM.
Parent topic: Defining a CICS Connection from the Host to the Local COBOL System


Starting the Local CICS Connection

To start the local CICS connection use the Enterprise Server Administration interface.

  1. Open the Enterprise Server Administration page, and click Start next to the name of the CICS server you want to use.
  2. With a 3270 terminal emulator connect to the CICS region.
  3. Complete any sign-on procedure required by your system.
  4. Enter the transaction:

    CRTE SYSID=HST1

    where HST1 is your connection definition name. You should receive the following message:

    DFH4409 The routing session to system HST1 has been started

    This initiates transaction routing for this terminal without acquiring any resources. It does not test the connection.
  5. To test the connection, enter a transaction that you know exists on the host CICS system. A suitable transaction is:

    CEMT INQUIRE CONNECTION

    This should return the following information:
    IN CONN
STATUS:  RESULTS - OVERTYPE TO MODIFY
Con(COA1) Net(COA1REMT)  Ins Rel  Vta Appc
Con(LU21) Net(MCOLU021)  Ins Acq  Vta Appc

    In the list of connections, you should see the connection that you have defined, and the netname associated with it. It should also have the acquired status (Acq).

Parent topic: Defining a CICS Connection from the Host to the Local COBOL System


Setting Up Communications from Host to Local CICS System

At this stage, you are not able to use transaction routing, function shipping, or DPL from the host CICS region. Also, distributed transaction processing (DTP) does not work because the host CICS region is currently unable to initiate tasks on the local CICS system.

If you have reached this point successfully, you should now have the communications server software on the local server configured and connected to the VTAM host system. The local CICS system should be able to use transaction routing, function shipping, and distributed program linking (DPL) to the host system.

  • Defining Transaction Programs
  • Testing Inbound Transaction Routing from the Host
Parent topic: Setting Up Communications with Mainframe CICS Regions


Defining Transaction Programs

In this procedure, you define transaction programs (TPs) to the local communications server (or client connected to the communications server) so that it knows how to invoke a CICS program invoked from the mainframe.

The following TPs must be defined for inbound function shipping, transaction routing, and distributed program linking:

TP Name | CICS Transaction | Purpose
CPMI | CPMI | Function shipping mirror transaction for ANSI
CSMI | CSMI | Function shipping mirror transaction, general
CVMI | CVMI | Function shipping mirror transaction for EBCDIC
CRTE | CRTE | Transaction routing transaction
CRSR | CRSR | Internal CICS housekeeping transaction

For inbound function shipping, transaction routing, or distributed program linking, you must add the resource group DFHISC to the startup list in the SIT that contains the PCT definitions for the above transactions.

To define a transaction program:

  1. Add a New TP and specify the transaction name. This is used to identify the transaction program to the SNA Server. This TP name should correspond to the transaction that the host system attempts to run on the local CICS region (for example, CRTE).
  2. Setup/configure the transaction that will run on the local CICS region, specifying the region (REGIONNAME), transaction (TTPNAME) and parameters, where:
    • REGIONNAME is the name of your region, for example: MSSDEMO
    • TPNAME is the name of your transaction program, for example CRTE
    • the name of the Local LU Alias as defined to the SNA server for the inbound request. This is the independent LU that you are going to use for your PU as defined to VTAM. The example value is: MCOLU021

Include the 'TP Name' table in the generic section.

  • Defining Transaction Programs using a HIS connection
Parent topic: Setting Up Communications from Host to Local CICS System


Defining Transaction Programs using a HIS connection

Note: The information in this section relates specifically to Windows systems using Microsoft BizTalk Host Integration Server (HIS). For other Advanced Program-to-Program Communications (APPC) software, the command names used will vary, but the overall details added will be the same.

For inbound communications, the HIS SNA Server requires registry entries to be created for each CICS transaction on the local server or a client. These entries are used by the HIS SNA Server to start the CICS program dfhgatch.exe, which routes the request to the correct CICS region and transaction.

The Micro Focus CICS registry entries for the transaction programs can be found in the following location:

/HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/SnaBase
   /Parameters/TP's/tpname/Parameters

To add a new or overwrite an existing registry entry for an inbound transaction program for HIS:

  1. Start an Enterprise Server command prompt.
  2. From the prompt, run tpsetup.exe. The TP Setup dialog box is displayed.

    tpsetup.exe is supplied with the HIS software.

  3. Click Add to display the Add New TP dialog box.
  4. In the TP Name field, enter the transaction name. This is used to identify the transaction program to the HIS SNA Server. This TP name should correspond to the transaction that the host system attempts to run on the local CICS region (for example, CRTE).
  5. In the Command line field, specify an entry to run casatch.exe. This starts the transaction on the local CICS region. The entry will depend on the bit-version of your Enterprise Server region.
    CAUTION:

    Be sure that you specify the path to the correct casatch.exe bit-version corresponding to the region (not the installed Enterprise Server software) that you are using.

    For example, the default locations for Studio Enterprise Edition are:

    • For 32-bit systems: %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\casatch.exe
    • For 64-bit systems: %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\casatch.exet
  6. In the Parameters field, specify the region, transaction and parameter details.
    This will generally be in the format: /RREGIONNAME /TTPNAME where:
    • REGIONNAME is the name of your region, for example MSSDEMO
    • TPNAME is the name of your transaction program, for example CRTE
  7. Specify the name of the Local LU Alias as defined to the HIS SNA server for the inbound request. This is the independent LU that you are going to use for your PU as defined to VTAM. The example value is: MCOLU021
  8. Click OK

For information on adding and editing transaction programs, see the Host Integration Server 2006 Help.

Note:
  • tpstart.exe reads the registry only when it is started. So, if you have updated the registry by adding or changing a TP, you need to stop and restart tpstart.exe to pick up any updates.
  • casatch.exe fails unless it is run under the same userid, or a userid with identical privileges, as the local Enterprise Server region. Therefore, either the Enterprise Server region must be started from a normal Net Express command prompt (using the casstart command), or MFDS must be started from a normal Net Express command prompt, using the mfds command. That is, as opposed to running MFDS as a service.

    If MFDS is running as a user process, started from the command prompt, then you can use either casstart or the user interface.

Parent topic: Defining Transaction Programs


Testing Inbound Transaction Routing from the Host

When you have added the required TP definitions to the registry, you are able to perform inbound transaction routing from the host.

This test completes the configuration. To test your connection to the host ensure that:

  1. The communications server has an active link to the host.
  2. The host CICS region is running. In most installations this is normally the case, but sometimes you may need to ask your host system administrator to start the host CICS region that you are going to connect with. It can usually be tested by using a communications server 3270 applet and entering the VTAM ID of your host CICS region when the terminal has a connection to the host VTAM.
  3. You have restarted the region as described in the section Starting the Local CICS Connection.

When the previous steps have been done:

  1. Start a communications server applet to the host VTAM, as described earlier, and connect to the host CICS region.
  2. When you have a session on the host CICS region, run the supplied transaction:

    CRTE SYSID=localwhere local is the name of the connection that you defined earlier. With the supplied example values, it is:

    CRTE SYSID=LU21

    .
  3. You should now be able to use the SNA Server 3270 applet as if it was a terminal on your local CICS system. To test the connection, run the transaction CENV supplied with the Enterprise Server CICS software. This should give you information about your local CICS system. When you have completed transaction routing, enter the CANCEL command.
Note:

When transaction routing is active in one direction, you cannot then route back to your terminal. This is because when you attempt to route back, the original terminal-id is passed back and is rejected because it is not unique. All terminal-ids must be unique within a CICS region, both on the host and the local client.

Parent topic: Setting Up Communications from Host to Local CICS System
Related information
Starting the Local CICS Client


Configuring CICS Terminals and Printers

  • Overview
  • Using Telnet 3270 terminal emulators
  • Defining Terminal Models
  • Enabling CICS Printer Support
Parent topic: CICS Support


Overview

The user interface to CICS applications running in Enterprise Server is through 3270 terminal emulators. These enable Enterprise Server to display CICS application input and output screens using 3270 data streams, and to receive input.

Note:

We recommend that you use a Telnet 3270 (TN3270) client such as Micro Focus RUMBA.

Parent topic: Configuring CICS Terminals and Printers


Using Telnet 3270 terminal emulators

You can use third-party TN3270 terminal emulators as CICS clients. The TN3270 emulator session can run on the same machine as Server Enterprise Edition or on a network machine.

To use a TN3270 terminal emulator, you need to create a TN3270 listener in Server Enterprise Edition Administration.

When you specify the Endpoint for the listener, we recommend that you use any port number above 5000 that isn't in use, since the usual port number for Telnet, 23, might already be in use for non-3270 Telnet access.

The TN3270 emulator session can run on the same machine as Server Enterprise Edition or on a remote machine.

By default MSS installs TN3270 terminals dynamically as basic 3270 terminals. This means that some of the more advanced features of your TN3270 terminal emulator won't be available. To make these features available, you need to enable MSS to associate the TN3270 device type and a CICS typeterm definition, known as a T-Type in ESMAC.

The TN3270 device type is specified by the emulator software and might or might not be configurable. Device types indicate the ability of the emulator to support various elements of the 3270 data stream, for example, color, extended attributes, the use of a TCTUA etc.

During the connection negotiation the TN3270 client sends a data packet indicating which device it wishes to emulate. MSS uses this data to identify a T-Type entry which defines this terminal type.

To make this work you need to:

  1. Define a T-Type entry that matches the capabilities of the TN3270 terminal emulator.
  2. Define a terminal model entry on the ESMAC Term page which points to this typeterm definition. Required fields for the terminal model entry are:
    Name | Unique name of this terminal model
    Model | O(nly), Y(es) , or N(o)
    Model name | The TN3270 device type
    Terminal type | The name of the T-type entry to use with this terminal

For example, suppose the TN3270 client software is configured to emulate an IBM 3279 MOD2 with support for extended attributes. At connection time MSS searches for a terminal model entry with the name TN32792E. The terminal type specified in this terminal entry is then used to look up the terminal's details in the T-type entry .

Configuring screen size

If you want to use a screen size other than the default, which is MOD2 (24 x 80), you need to set the environment variable ES_TN3270_FORCE_ALT=Yes before starting the enterprise server. You can then change the size to MOD1 (12 x 80), MOD2 (24 x 80), MOD3 (32 x 80), MOD4 (43 x 80), and MOD5 (27 x 132) during the terminal session.

To use custom dimensions, you need to set ES_TN3270_FORCE_ALT=Yes and also specify the screen size in the Alt. Screen Width and Alt. Screen Height fields of the ESMAC T-Type page.

  • To specify a listener for TN3270 terminals
Parent topic: Configuring CICS Terminals and Printers


Defining Terminal Models

The steps to define a terminal model are outlined below.

  1. Create a new entry in the terminal control table. (In ESMAC select Resources > by Type, click one of the table buttons, scroll down to the end of the table, and click Term.)
    • For a terminal definition specified as Model: Only, you must specify:
      • Model Name.
      • Terminal Type: the name of a typeterm entry
    • For a terminal definition specified as Model: Yes, you must specify:
      • Model Name.
      • Terminal Type: the name of a typeterm entry
      • Net Name.
    • A terminal definition specified as Model: No is a physical terminal definition and you must specify:
      • Terminal Type: the name of a typeterm entry
      • Net Name.
  2. Create a matching T-Type entry (if none exists). (In ESMAC from the Term page click Group List, scroll down to the end of the table, and click TType.) At a minimum, this must specify:
    • Def. Screen Height
    • Def. Screen Width

    Many different models can refer to the same T-Type entry.

Parent topic: Configuring CICS Terminals and Printers


Enabling CICS Printer Support

You can use a printer device for 3270 printer support. Printer support is handled by 3270 printer emulators, which interpret the 3270 printer data stream and send it to a system printer.

Use the printer exit program DFHUPRINT to redirect printed output to different print type 3270 devices with multiple physical printers or print spooler queues.

DFHUPRINT must reside on the transaction path for your enterprise server. The exit program is called during the processing of 3270 printed output after a SEND with PRINT event. These events are buffered and result in an OPEN call, a number of PRINT calls, and a CLOSE call.

When the OPEN call is made, the control block contains the terminal ID of the target 3270 print device. You can use this ID to identify the target system printer through a table, for example.

An extract from the exit program is shown below.

       open-printer section.
           evaluate true
               when upi-printer-termid = 'L860'
                    string '\\nwb-savprint' delimited by size
                           '\training-hp4v' delimited by size
                      into ws-filename
                    end-string
               when upi-printer-termid = 'L861'
                    string '\\nwb-savprint' delimited by size
                           '\training-hp5v' delimited by size
                      into ws-filename
                    end-string
               when upi-printer-termid = space
                    move 'Win2PDF' to ws-filename
           end-evaluate
        open extend print-file

If you only have one destination printer, instead of using DFHUPRINT you can start a printer emulator by configuring the following fields on the SIT page in ESMAC:

Field | Contents
3270 Print | Y
Print Destination | Device name for printed output

The enterprise server then starts a printer emulator for each entry in the terminal table which is:

  • Set as MODEL=NO (the netname must be defined)

    The netname defined in the terminal table must be unique to the region. The terminal ID for the printer is taken from the terminal definition. To avoid conflicts with automatically assigned netnames, you should assign netnames to printers counting downwards from PRNZZZZ.

  • Has a Terminal Type entry which specifies a 3270 printer (3270P)
Parent topic: Configuring CICS Terminals and Printers


CICS Web Interface Support

Server Enterprise Edition with Mainframe Subsystem Support can run CICS Web-aware programs (those that use EXEC CICS WEB commands).

In order to run these programs, you need to make sure the server has a Web Services and J2EE listener configured that matches a port identified for a TCP/IP service in the CICS resources definitions.

Enterprise Server supports version 3.1 and above of CICS Transaction Server.

  • To enable CICS Web interface support
    This task enables you to run Web-aware CICS programs.
  • CICS Web Error Processing
    Sources and copybooks that enable you to perform error processing for Web-aware applications.
  • Analyzer Programs
Parent topic: CICS Support
Related information
Introduction to Developing Exit Points
Global and Task-related Exit Programs


To enable CICS Web interface support

  1. In the Enterprise Server Administration console, choose the Listeners tab.
  2. Add a listener and set Endpoint Address to the port on which to listen for calls from CICS web-aware programs. You must also set Supported Conversation Type to Web Services and J2EE.
  3. In the Enterprise Server Administration console Server tab, choose the Control tab and click ES Monitor and Control.
  4. Create a new TCPIPSv resource and set Port to the same number as the Endpoint Address field in the associated listener. Make sure that the Open option is selected.
Parent topic: CICS Web Interface Support


CICS Web Error Processing

  • Web Error Application program
  • Web Error Program
Parent topic: CICS Web Interface Support


Web Error Application program

DFHWBERX uses the EXEC CICS WEB and DOCUMENT API commands to get information about the Web client's request and create and send the error response.

DFHWBERX is used in the following circumstances:

  • When it is configured in the Program setting in a URIMAP definition, if an error response is always wanted for the request.
  • When the default analyzer program DFHWBAAX is set as the analyzer program on the TCPIPSERVICE definition, and no matching URIMAP definition is found for a request. DFHWBAAX sets DFHWBERX as the application program using the wbra_server_program output parameter.

Refer to IBM's CICS Transaction Server documentation for more details of how DFHWBERX processes errors and recommendations on how to use it.

Parent topic: CICS Web Error Processing


Web Error Program

The Web error program DFHWBEP receives a list of parameters containing error information, and a block of storage containing the default HTTP response to send to the Web client. The program can use or modify the default response, or create and send its own response using the EXEC CICS WEB and DOCUMENT API commands.

The error information passed to DFHWBEP includes an HTTP status code, an error code, abend code, message number, response and reason codes, and the name of the program where the error has occurred. You can modify all the items in the error response.

Refer to IBM's CICS Transaction Server documentation for guidelines and recommendations on how to use DFHWBEP, and descriptions of the input and output parameters it uses.

Parent topic: CICS Web Error Processing


Analyzer Programs

Analyzer programs are associated with TCPIPSERVICE definitions. They interpret selected HTTP requests and take over some of the processing, monitoring and audit actions normally performed by a URIMAP.

Each CICS Web support TCPIPSERVICE definition must use an analyzer program, and each TCPIPSERVICE definition can specify a different analyzer program.

The use of an Analyzer program is specified in the Analyzer field of URIMAP definition and can override the URIMAP's Convertor, Transaction, User Id, and Program options when used.

Important:
  • You can only use analyzer programs if they have been compiled with ASCII specified as the character set.
  • Analyzer programs can only be called when CICS is an HTTP server. You cannot use them if CICS is an HTTP client, or processing Web services.

The Default Analyzer

If no URIMAP is defined, or no value is entered in the Analyzer field of a URIMAP definition, Enterprise Server uses DFHWBAAX as the default analyzer program for TCPIPSERVICE definitions that have Protocol set to "HTTP".

DFHWBAAX tests for the presence of a URIMAP definition, and depending on the result performs the following:

  • If it finds a URIMAP definition, DFHWBAAX automatically accepts the URIMAP definition's Transaction (alias transaction), Converter (converter program), and Program (application program) settings for use in any further processing.
  • If it does not find a matching URIMAP definition, DFHWBAAX passes control to the Web error application program DFHWBERX to produce an error response. For this to happen you must configure DFHWBERX as the application program to handle the request using the wbra_server_program output parameter.

For more information on DFHWBAAX and how to use TCPIPSERVICE analyzer programs, see IBM's CICS Transaction Server documentation.

Parent topic: CICS Web Interface Support


Modernizing CICS Applications

This chapter provides information about how you can extend your existing CICS applications.

  • Overview
  • Access to CICS Programs from Web Services and Services called from EJBs
  • CICS Transaction Gateway
  • Data Conversion
Parent topic: CICS Support


Overview

Extending existing applications involves the process of exposing your CICS applications to a range of non-CICS client types. Enterprise Server provides the following extension facilities:

  • Access to CICS programs from Web services and Enterprise JavaBeans running under Enterprise Server. For this you need no extra software.
  • CICS Transaction Gateway. For this you need IBM CICS Transaction Gateway (CTG) or IBM Universal Client. A typical scenario is where a graphical front-end runs on a PC, possibly in a Web browser, and uses a CICS application to access data resources managed by Enterprise Server.
Parent topic: Modernizing CICS Applications


Access to CICS Programs from Web Services and Services called from EJBs

A COBOL program running as a service in an enterprise server can call a CICS program running in the same enterprise server. The service can be either a Web service or a service called from an EJB. The service must be configured to be container-managed.

To use this facility you need to:

  1. Code an EXEC CICS LINK statement in the COBOL source program.
  2. Compile it using an extra Compiler directive option.
  3. Deploy the program in the usual way, having carried out any interface mapping required to make the program accessible as a service to client programs.
  4. Run the program as a service in an enterprise server. This involves invoking it from a suitable client.
  • Coding the EXEC CICS LINK Statement
  • Compiling the COBOL Program
  • Deploying the COBOL Program
  • Running the Service in an Enterprise Server
  • Restrictions
Parent topic: Modernizing CICS Applications


Coding the EXEC CICS LINK Statement

The COBOL program calls the CICS program using the External CICS Interface (EXCI). To use this interface, you need to code an EXEC CICS LINK call every time the COBOL program wants to invoke a CICS program.

CAUTION:
An EXCI call can only be executed in a service that is Container Managed. An EXCI call executed in an Application Managed generates an abend: EXIA.

This is similar to the EXEC CICS LINK call used in a CICS program to perform distributed program linking. However, there are some significant differences.

The format of the call is as follows:

EXEC CICS LINK
    PROGRAM(program-name)
    RETCODE(data-area-1)
    COMMAREA(data-area-2)
    .
    .
    .
    END-EXEC

where the options are as follows:

PROGRAM(program-name) | The name of the CICS program to be invoked
RETCODE(data-area-1) | An area in which the CICS program places a return code indicating sucess or failure
COMMAREA(data-area-2) | An area that the service program and the CICS program use for communications

The call must be immediately followed by an EXEC-END statement.

For example:

exec cics link
               program     (ws-program)
               commarea    (ws-commarea)
               retcode     (exci-exec-return-code)
end-exec

We supply a copy book, dfhxcplo.cpy, which provides data descriptions for RETCODE and COMMAREA. You can find this copybook in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source and \base\source\win64. The copybook has data descriptions for the parameter passed in the RETCODE field, exci-exec-return-code:

01 exci-exec-return-code.
   03 exec-resp                pic 9(8) comp.
   03 exec-resp2               pic s9(8) comp.
   03 exec-abcode              pic x(4).
   03 exec-msg-len             pic 9(8) comp.
   03 exec-msg-ptr             pointer.
Parent topic: Access to CICS Programs from Web Services and Services called from EJBs
Related information
CICS External CICS Interface Guide


Compiling the COBOL Program

You need to compile the program in Studio Enterprise Edition with the CICSECM(EXCI=YES) directive.

Note: If you are building from the Visual Studio IDE, do not check EXEC CICS COBOL tab of your project properties to set this directive, but instead type CICSECM(EXCI=YES) into the Additional Directives field.
Parent topic: Access to CICS Programs from Web Services and Services called from EJBs


Deploying the COBOL Program

After you have performed any interface mapping necessary to make the program available a a service, you need to deploy it. For more information on interface mapping and deploying see the Service Interfaces part of the help. The program must be deployed as a container-managed service.

Parent topic: Access to CICS Programs from Web Services and Services called from EJBs


Running the Service in an Enterprise Server

Once the COBOL program has been deployed to the MSS-enabled enterprise server where the target CICS program runs, you need to invoke it using a suitable client.

When the EXEC CICS LINK statement in the service program is executed, control is passed to the CICS program, which executes and passes the results back to the calling service program. The service program sets the return code to indicate to the container wheher or not the transaction should be rolled back.

When a service executes within an enterprise server, the COBOL program search path is restricted to the setting of Package Path within the service’s package object, set on the Edit Package page of Enterprise Server Adminstration. When an EXCI call is issued the search path is temporarily modified to include the system-wide CICS Transaction Path set on the Edit Server > Properties > MSS page.

Parent topic: Access to CICS Programs from Web Services and Services called from EJBs


Restrictions

The following restrictions apply to the use of the External CICS Interface:

  • The COBOL service and the CICS program it calls must be running in the same enterprise server. The EXEC CICS LINK command takes the APPLID() operand, which is used to specify a remote server on which the CICS program resides, but it is ignored.
  • The EXEC CICS LINK command takes the SYNCONRETURN() operand, which is used to specify that the MSS enterprise server is to take a syncpoint on successful completion of the server program. This operand is ignored. You can only use the EXCI interface from a container-managed service. The resources updated by the CICS program should not be committed or rolled back until the container-managed service is complete so that the CICS resources remain coordinated with those of the calling service.
  • The CICS program should not issue explicit EXEC CICS SYNCPOINT commands. Results will be unpredictable and might leave resources in an inconsistent state.
Parent topic: Access to CICS Programs from Web Services and Services called from EJBs


CICS Transaction Gateway

The following components are required to run a CICS application using CTG and Enterprise Server:

  • Your client program. You can build and run the client program under Net Express.
  • Middleware. Messages and data are passed between the server and client components using middleware. MSS supports the middleware products, IBM CICS Transaction Gateway® ECI Version 1 calls and IBM Universal Client® Version 3.0. This middleware software must be installed on the same machine as your client program.
  • Enterprise Server.
  • Your CICS programs. You deploy these to the machine where Enterprise Server with MSS is installed.

Net Express and Enterprise Server can be on the same or different machines.

This chapter uses CTG to mean IBM CICS Transaction Gateway or IBM Universal Client.

You use CTG as the middleware between your client program and the CICS application running on Enterprise Server.

To enable support for CTG, you need to set up both the client and server software. You need to:

  1. Configure the IBM CTG client and tell it which machine the server program is running on.
  2. Prepare your client program, by inserting ECI calls to the CTG in your program.
  3. Compile your CICS server program.
  4. Configure the enterprise server that will run the CICS server program. Among other things, this involves enabling an enterprise server for MSS .
  5. Add an enterprise server listener for CICS requests.
  • Demonstration Programs for CTG
  • Configuring the CTG Client
  • Preparing the Client Program
  • Compiling your CICS Server Program
  • Configuring the Enterprise Server
  • Adding a Listener to Enterprise Server
  • Running the Demonstration
Parent topic: Modernizing CICS Applications


Demonstration Programs for CTG

This chapter uses the application eci.app to demonstrate how to set up the client and server software.

To follow the examples in this chapter, you need the following software installed:

  • Studio Enterprise Edition
  • Server Enterprise Edition (installed automatically with Studio Enterprise Edition).
  • UNIX Option (if you want to deploy to UNIX)

If you want to deploy to UNIX, you need, in addition, Server Express version 4.0, Service Pack 1 or later with MSS with the following parts installed:

  • Studio Enterprise Edition
  • MSS
  • Server Enterprise Edition

The CTG demonstration programs are supplied with Net Express in the Examples\Net Express IDE\mto-ctg directory of your Net Express installation.in the directory \mfe\mfcics\source They are:

eci.app
A Net Express project file for the COBOL programs.
eci2oper.cbl
A server program that you run under Server Enterprise Edition. It consists of a CICS program that writes a data area to the system console. This transaction program performs a WRITE OPERATOR command on the field ECI-DEMO-MESSAGE using the text passed in the DFHCOMMAREA. If the WRITE OPERATOR command fails, the EIBRESP and EIBRESP2 values are passed back to the calling program in the fields ECI-ERROR-EIBRESP and ECI-ERROR-EIBRESP2.
eci-call.cbl
A client program that you run under Server Enterprise Edition. This batch program has three main parts:
  • initialise-eci-interface set-up-eci-call - Sets up an entry point to the module CCLAPI32 dfhtexst that handles the calling of the ECI.
  • call-eci-program - Calls CCLAPI32 dfhtexst and passes it the data area and program name to run. The following fields from the ECI-PARMS structure are worth noting:
    • eci-program - The name of the program to be run by Server Enterprise Edition .
    • eci-commarea-pptr - A pointer to the data area to be passed to and from Server Enterprise Edition .
    • eci-error-id - If the program completes successfully this contains a value of 0. If unsuccessful it contains the value of an error condition described in the IBM publication CICS Transaction Gateway Programming Reference SC34-6140-00.
  • display-eci-error - Checks for any error conditions returned by the program running under Server Enterprise Edition or by CCLAPI32 dfhtexst . If errors occur in the eci2oper program, they are returned in EIBRESP and EIBRESP2. Note, this is not a general requirement, but is part of the implementation of the demonstration program.
eci2oper.mlc
The data conversion macros needed by the demonstration application.
Parent topic: CICS Transaction Gateway


Configuring the CTG Client

The CTG needs to know which machine the server program is running on.

You specify this using the CTG configuration tool. Alternatively, you can edit the CTG configuration file ctg.ini (or cicscli.ini for Universal Client) on the client machine.

To configure the CTG client for the demonstration:

  1. Start the CTG configuration tool, which is available, by default, on the Windows Start menu as IBM CICS Transaction Gateway > Configuration Tool.
  2. Add a new server for the client and set the following options:
    Server name | name for the enterprise server, such as myCICSserver
    Network protocol | TCP/IP
    Hostname or IP address | name of the machine running enterprise server
    Port | port number to listen on, which must be the same as the port number you specify for the Enterprise Server listener, later. The port number defaults to 1435, which is the IANA recognized port number for IBM CICS.

    Only the server name and hostname or IP address is mandatory.

  3. Save the configuration and close the tool
Parent topic: CICS Transaction Gateway


Preparing the Client Program

You need to insert your ECI calls to the CTG in your program. In COBOL, an ECI call looks like this:

CALL "CICS_ExternalCall" USING ECI-PARMS

ECI-PARMS is the ECI parameter block, through which the program communicates with the server. The parameter control block is available as a copybook in the copybook folder within your CTG installation. It is called cicseci.cbl. You need to make this copybook available to your client program. You do this by adding the CTG copybook directory to the COBCPY environment variable.

When you compile your program to an executable, you must link it to the CTG library, cclwin32.lib.

For further information about using CICS Transaction Gateway, see the IBM manual CICS Family: Client/Server Programming (SC33-1435).

Before you run the demonstration, prepare the Net Express client as follows:

  1. Locate the following code in the program eci-call.cbl
    01 ECI-Client-Type.
        03 pic x comp-x
           *> --
           *> --Change the following value to select client type
           *> --
           value 0.
       88 ECI-MicroFocus-88 value 0.
       88 ECI-UniCli-88     value 1.

    Change the above value clause to set ECI-Client-Type to 1.

  2. Save the program.
  3. Set the COBCPY environment variable to include the copybook directory of your CTG installation. This enables the project to locate the ECI copyfiles supplied by the CTG. To set the COBCPY environment variable edit the Project Properties
    1. Click Project > Properties
    2. Click IDE.
    3. Click Import.
    4. Select COBCPY and click OK.
    5. Double-click COBCPY.
    6. In the Value field, add a semicolon at the end, followed by the copybook directory of your CTG installation.
    7. Click Set and then OK.
  4. Notice in the project properties that EXEC CICS is not enabled for the project, since the client program is not a CICS program.
  5. Rebuild the program.
Parent topic: CICS Transaction Gateway
Related information
CICS Family: Client/Server Programming


Compiling your CICS Server Program

When you compile CICS programs, you use the CICS External Compiler Module (ECM), which preprocesses the EXEC CICS statements. The ECM is invoked by the CICSECM() directive, which you set when you choose EXEC CICS in the project build settings. The client program passes the Program-ID of the server program to Enterprise Server, which locates the program and starts it.

To compile the demonstration CICS program:

  1. In Net Express, open the project eci.app if it is not already open.
  2. Check that CICS is enabled for the server program eci2oper.cbl. To do this, right click eci2oper.cbl, click Build settings and then go to the Compile tab. Ensure that EXEC CICS is checked, which sets the CICSECM directive.
  3. Rebuild the project.
Parent topic: CICS Transaction Gateway


Configuring the Enterprise Server

To configure the enterprise server for the demonstration:

  1. Enable MSS in the enterprise server ESDEMO.
  2. On the MSS tab that you used in the previous step, in Transaction Path enter the location of the demonstration server program, eci2oper:
    Examples\Net Express IDE\mto-ctg\debug
  3. Start the enterprise server ESDEMO.
  4. If your CICS programs use the EBCDIC character set, you need to start ESMAC and do the following:
    • Specify the SIT to use.
    • Add a PPT entry for the server program in the resource definitions.
    • Make sure that the group to which you added the PPT entry is in the startup list.
    • Import the data conversion macros that the server program uses; see the section Data Conversion.
  • To enable MSS for an enterprise server
  • To start an enterprise server instance
  • To create a resource group
Parent topic: CICS Transaction Gateway
Related information
To enable MTO for an enterprise server
To start an enterprise server
To create a resource group
Data Conversion


Adding a Listener to Enterprise Server

To enable support for CTG, you need to add an MSS listener to Server Enterprise Edition so that it can receive and handle client requests from CTG. When you add the listener, you configure it and you specify a port for the listener to listen on.

To add a listener for the demo application:

  1. Start Enterprise Server Administration.
  2. In Server Enterprise Edition Administration, in the row for ESDEMO, click Edit.
  3. Click Listeners.
  4. Click Add and fill in the following details for the new listener:
    • A name for the new listener, such as MyECI.
    • A port number to use, in the form *.nnnn, such as 1435. You must use the same number as you specified when you configured the CTG client.
    • The Supported Conversation Type. Set this to MSS Inter-System Communication.

    Then click Add to return to the listeners page.

  5. Stop and restart the enterprise server.
Parent topic: CICS Transaction Gateway
Related information
To access Enterprise Server Administration
To start an enterprise server
To stop an enterprise server


Running the Demonstration

To run the demonstration:

  1. Start the CTG client from the Windows Start menu, which is by default in IBM CICS Transaction Gateway > Start Client. If you don't do this, the CTG client is started automatically when you run the program.
  2. In Net Express, open the project eci.app and rebuild it.
  3. Click Debug > Run.
  4. Ensure that the executable file is debug\eci-call.
  5. If Enterprise Server is not running, go to the MSS Debug tab and click Start Enterprise Server.
  6. Return to the Application tab and click OK.
  7. When the Application Output window appears and prompts you to enter a message to send to the console, enter your message.
  8. The message is displayed in the Enterprise Server Console Daemon. To see the message within the Enterprise Server administration console:
    1. In the Current Status column for your enterprise server, click Details.
    2. At the bottom of the page, click ES Console.
Parent topic: CICS Transaction Gateway


Data Conversion

Within a single system using MSS, file data is always presented in the same codeset in which it was recorded. Between two systems running MSS, or between MSS and other CICS systems, data may need to be translated between EBCDIC and ANSI. The requirement and the method you use to meet it depend on which middleware you are using.

  • If You Use CICS Transaction Gateway
Parent topic: Modernizing CICS Applications


If You Use CICS Transaction Gateway

If you use IBM CICS Transaction Gateway, you can supply information that enables data to be converted in data conversion templates, which are held in an indexed file called dfhdrcnv, in the same folder as the resource definition file (by default ). Each data conversion template contains entries for resources that need translation and identifies which data fields require it. Each resource must have an entry in the resource definition file.

You cannot edit the file dfhdrcnv directly; instead you maintain it by importing mainframe-style DFHCNV macros, and by deleting templates that you no longer need.

Mainframe-style DFHCNV macros are organized into entries and templates. An entry is a set of conversion macros that apply to the same resource; the start of an entry is marked by a DFHCNV macro that begins TYPE=ENTRY and the entry continues until the next macro that begins TYPE=ENTRY, or until the END marker. An entry can contain one or several templates, depending on the type of resource it belongs to.

  • Importing Data Conversion Templates
  • Example Macros
Parent topic: Data Conversion
Related information
CICS Family: Communicating from CICS on System/390
CICS Web Interface Guide CICS for MVS/ESA 4.1


Importing Data Conversion Templates

You use the command cascnvim to convert the data. For more information see the help topics cascnvim and Data Conversion.

Note:

If data conversion is required for a program's COMMAREA, you must define a PPT entry for that program; see the section Controlling CICS Resources in the chapter Administering MSS-enabled Enterprise Servers.

Parent topic: If You Use CICS Transaction Gateway
Related information
cascnvim
Data Conversion


Example Macros

The following data conversion macros apply to a file (TESTFC), which has two data constructs, and to a program (TESTPC):

TITLE 'DFHCNV MACRO IMPORT'
* --------- START OF DFHCNV MACROS ---------- *
DFHCNV TYPE=INITIAL,CLINTCP=(932, 437,XXXX)
SPACE 2
DFHCNV TYPE=ENTRY,RTYPE=FC,RNAME=TESTFC,USREXIT=NO
DFHCNV TYPE=KEY
DFHCNV TYPE=FIELD,OFFSET=0,DATATYP=CHARACTER,DATALEN=8
DFHCNV TYPE=FIELD,OFFSET=8,DATATYP=PD,DATALEN=3,LAST=YES
DFHCNV TYPE=SELECT,OPTION=COMPARE,OFFSET=11,DATA='A'
DFHCNV TYPE=FIELD,OFFSET=0,DATATYP=CHARACTER,DATALEN=8
DFHCNV TYPE=FIELD,OFFSET=8,DATATYP=PD,DATALEN=3
DFHCNV TYPE=FIELD,OFFSET=11,DATATYP=CHARACTER,DATALEN=1
DFHCNV TYPE=FIELD,OFFSET=12,DATATYP=PD,DATALEN=4
DFHCNV TYPE=FIELD,OFFSET=16,DATATYP=PD,DATALEN=4
DFHCNV TYPE=FIELD,OFFSET=20,DATATYP=BINARY,DATALEN=8
DFHCNV TYPE=FIELD,OFFSET=28,DATATYP=USERDATA,DATALEN=10, X23456789
USRTYPE=B'01010000'
DFHCNV TYPE=FIELD,OFFSET=38,DATATYP=CHARACTER,DATALEN=50, X
LAST=YES
DFHCNV TYPE=SELECT,OPTION=COMPARE,OFFSET=11,DATA='B'
DFHCNV TYPE=FIELD,OFFSET=0,DATATYP=CHARACTER,DATALEN=8
DFHCNV TYPE=FIELD,OFFSET=8,DATATYP=PD,DATALEN=3
DFHCNV TYPE=FIELD,OFFSET=11,DATATYP=CHARACTER,DATALEN=1
DFHCNV TYPE=FIELD,OFFSET=12,DATATYP=USERDATA,DATALEN=2
DFHCNV TYPE=FIELD,OFFSET=14,DATATYP=CHARACTER,DATALEN=20, X
LAST=YES
DFHCNV TYPE=ENTRY,RTYPE=PC,RNAME=TESTPC
DFHCNV TYPE=SELECT,OPTION=DEFAULT
DFHCNV TYPE=FIELD,OFFSET=0,DATATYP=BINARY,DATALEN=12
DFHCNV TYPE=FIELD,OFFSET=12,DATATYP=CHARACTER,DATALEN=96
DFHCNV TYPE=FINAL
END
Parent topic: If You Use CICS Transaction Gateway


Administering CICS-enabled Enterprise Servers

This chapter describes how you can use Enterprise Server Monitor and Control to run CICS applications.

  • Overview
  • Visual Appearance
  • Enabling MSS for an Enterprise Server
  • Changing the SIT for an MSS-Enabled Server
  • Configuring CICS Search Paths
  • Specifying a Listener for TN3270 Terminals
  • Sending Messages to All Terminals
  • Viewing Locks
  • Controlling CICS Resources
Parent topic: CICS Support


Overview

Enterprise Server Monitor and Control (ESMAC) enables you to monitor and control CICS-enabled enterprise servers. When Enterprise Server is being used to run CICS applications, an enterprise server corresponds to a CICS region. You can use ESMAC to ensure all the resources required by your CICS application are available, and change and create resources for your application and other applications as necessary. You can also use all the facilities described in the chapter Administering Servers Using ESMAC in your Enterprise Server Configuration and Administration Guide, and in the help topics grouped under Administer a Server Using ESMAC. You should familiarise yourself with the contents of that chapter and the associated help topics before reading this chapter.

Parent topic: Administering CICS-enabled Enterprise Servers
Related information
To create an ESMAC user
To start ESMAC for a server
To monitor services
To configure dumps
To view a dump
To initiate a system dump
To specify what information is traced
To change the trace dataset
To transfer the in-memory trace data to the auxiliary dataset at rollover
To view a system trace
To record service input and output
To view a local trace for a SEP
To view a local trace for a client process
To kill a SEP
To reply to an ACCEPT FROM CONSOLE statement
To shut down a server


Visual Appearance

When you first view ESMAC for an CICS-enabled enterprise server, the Server Information page is displayed, as shown in Figure 0-1 :

Figure 1. ESMAC Server information page for CICS
ESMAC Server information page for CICS

When you run ESMAC on an CICS-enabled enterprise server, you can use it to view and change SITs, groups, startup lists, and other CICS resources required by CICS applications running on the enterprise server, in addition to all the facilities ESMAC provides for servers that are not enabled for CICS.

Parent topic: Administering CICS-enabled Enterprise Servers


Enabling MSS for an Enterprise Server

You enable MSS on an enterprise server in the same way on both Windows and UNIX.

To enable MSS, you use Enterprise Server Administration (for an introduction to this tool, see the chapter Introduction to Enterprise Server Administration in your Enterprise Server Configuration and Administration Guide).

Note: You need the appropriate license before you can use an MSS-enabled enterprise server.
  • To enable MSS for an enterprise server
Parent topic: Administering CICS-enabled Enterprise Servers
Related information
To enable MTO for an enterprise server
Introduction to Enterprise Server Administration


Changing the SIT for an MSS-Enabled Server

If you want to change the SIT that is associated with an MSS-enabled enterprise server, you have to return to the Home page of Enterprise Server Administration, stop the server, edit the server's Properties > MSS page, start the server and return to ESMAC.

  • To change the SIT associated with a server
Parent topic: Administering CICS-enabled Enterprise Servers
Related information
To change the SIT associated with a server


Configuring CICS Search Paths

You can also use the Properties > MSS page to configure CICS search paths. You can define the paths to the directories that contain CICS application programs, CICS BMS load modules, the CICS resource definition file, and the default location for CICS VSAM data sets.

  • To configure CICS search paths
Parent topic: Administering CICS-enabled Enterprise Servers
Related information
To configure CICS search paths


Specifying a Listener for TN3270 Terminals

Enterprise Server MSS provides support for TN3270 clients. To enable the TN3270 client support you need to define a new listener in Enterprise Server Administration.

  • To specify a listener for TN3270 terminals
Parent topic: Administering CICS-enabled Enterprise Servers
Related information
To specify a listener for TN3270 terminals


Sending Messages to All Terminals

ESMAC provides a facility for sending a message to all the 3270 clients currently connected to the server.

  • To send a message to all 3270 terminals
Parent topic: Administering CICS-enabled Enterprise Servers
Related information
To send a message to all 3270 terminals


Viewing Locks

You can view the current locks that have been issued against resources such as files.

  • To view resource locks
Parent topic: Administering CICS-enabled Enterprise Servers


Controlling CICS Resources

ESMAC enables you to view, create and modify the resources required by a CICS application running on an enterprise server. An enterprise server equates to a CICS region. When a CICS region starts, it is typically initialized with a system initialization table (SIT). The SIT defines various startup parameters, as well as defining which startup lists are invoked. The startup lists define which groups are used by the CICS applications in this region. The groups in turn define the resources (for example, file control tables and program processing tables) to be loaded for use by applications.

You can maintain the following resources

  • SITs
  • Startup lists
  • Groups
  • Tables

This includes not just the resources used by this enterprise server, but all the resources defined in the resource definition file for this enterprise server.

ESMAC provides flexibility in the way you view resources. You can view:

  • Active resources - the resources that are currently active on the enterprise server. An enterprise server is associated with a SIT, and when the SIT is initialized, it invokes its startup list, which contains the groups in which resources are stored. These then become active.

    The Active resources category includes two items that are not strictly speaking resources:

    • ICE, which stands for interval control elements, CICS-related events that are scheduled to happen in the future
    • Resource locks
  • Resources by group - the resources in groups currently defined in the enterprise server's resource definition file.
  • All the SITs in the resource definition file.
  • All the startup lists in the resource definition file.
  • Resources used by the current startup list - resources defined in groups that are defined in the startup list initiated by the SIT for the enterprise server.
  • Resources by type - all resources, listed according to type (FCT, DCT, and so on).
  • Detailed information for any resource.

If you have suitable permissions you can also:

  • Modify resources.
  • Delete resources.
  • Create new resources, such as tables and groups. You can do this in two ways:
    • Create a new resource using the values of an existing resource.
    • Create a completely new resource. How you do this depends on whether you are creating a new table (FCT, DCT, and so on) or another resource (such as a group or SIT).
  • Format and view a dump of a resource.
  • Delete interval control elements and data queues
  • To view active resources
  • To view and delete data queue items
  • To view detailed information for a resource
  • To view and delete interval control elements
  • To create a resource from an existing resource
  • To view resources by group
  • To view resources by startup list
  • To view resources by type
Parent topic: Administering CICS-enabled Enterprise Servers
Related information
To view active resources
To view resources by group
To view resources by startup list
To view resources by type
To view detailed information for a resource
To view and delete data queue items
To view and delete interval control elements
To view resource locks
To create a resource from an existing resource
To create a resource table
To create a resource group
To delete a resource
To view a dump of a resource
To create a SIT
To create a startup list
To change the SIT associated with a server


MSS Aspects of Troubleshooting

This chapter covers some aspects of troubleshooting problems with running applications in an Mainframe Subsystem Support(MSS)-enabled enterprise server.

  • Introduction
  • Configuring Dumps for Data Capture
  • Viewing a System Trace
Parent topic: CICS Support


Introduction

Problem diagnosis on an MSS-enabled enterprise server is very similar to problem diagnosis on an enterprise server running Web services or EJB-type services, as described in the chapter Troubleshooting in the Enterprise Server Configuration and Administration Guide.

Parent topic: MSS Aspects of Troubleshooting


Configuring Dumps for Data Capture

When you are configuring dumps and traces for an MSS-enabled enterprise server, you might want to select dump on transaction abend; on the ESMAC Control page click Tran next to Dump on ABEND. Dumps created when transactions abend are internally triggered dumps. When you do your data capture, you should include the transaction abend dump, if one exists.

There is a fourth way of obtaining an externally triggered dump: issue an EXEC CICS DUMP command in a CICS program.

Parent topic: MSS Aspects of Troubleshooting


Viewing a System Trace

On the Trace page of ESMAC, which you see when you request a trace from the Diagnostics group in the menu, the process IDs that appear in the PIDs column can have the following additional prefixes:

3 | 3270 client
L | CCI listener
Q | MQSeries listener

The prefix J for journal control also covers extra-partition transient data

Parent topic: MSS Aspects of Troubleshooting


IMS Support

  • IMS Installation Verification
  • Configuring IMS-enabled Enterprise Servers
    This chapter describes how to create and configure IMS-enabled enterprise servers.
  • Administering IMS-enabled Enterprise Servers
  • Migrating IMS Applications
  • IMS Database Forward Recovery
    Describes IMS database recovery using database image copies and forward recovery log files to restore the most recent database updates.
  • Setting Checkpoints and Using Batch Backout
  • Support for IMS DB System Commands
  • WebSphere MQSeries Trigger Monitoring
  • IMS Support Tasks
Parent topic: MSS Configuration and Administration


IMS Installation Verification

This chapter takes you step by step through the process of configuring an enterprise server to run IMS applications, and then building and running an IMS application. This is intended both as an introduction to using IMS in Mainframe Subsystem Support (MSS), and as an Installation Verification Procedure (IVP) to confirm that the IMS support is correctly installed.

  • IVP Overview
  • Before Running the IVP
  • Running the IVP
Parent topic: IMS Support


Enabling JCL for an Enterprise Server

JCL support is required for any IMS-enabled enterprise server that needs a message processing region to start whenever the enterprise server starts. You will define such a message processing region later, so you need to enable JCL support for IMSIVP.

To enable JCL support for the IMSIVP enterprise server:

  1. Click the Server, Properties, MSS, JES and General tabs.
  2. Check Job Entry Subsystem enabled.
  3. Click Apply.
Parent topic: Configuring an Enterprise Server for the IVP


Configuring IMS-enabled Enterprise Servers

  • Overview
  • MSS and CICS Support
  • Adding IMS-specific Resource Definitions
  • Enabling MSS for an Enterprise Server
  • Enabling IMS for an Enterprise Server
  • Specifying the Location of Genned Files
  • Specifying IMS Resources to a Resource Group
  • Adding a Resource Group to a Startup List
  • Enabling JCL for an Enterprise Server
  • Defining Transactions
  • Configuring IMS Printers
    Describes printers supported and the process required to define and configure a printer to use with an IMS-enabled enterprise server.
  • Calculating Shared Memory Area Requirements
Parent topic: IMS Support
Related information
Configuring an Enterprise Server for an IMS service


Overview

If you want to run IMS applications in an enterprise server, you can either create a new enterprise server specifically for this purpose, or use an existing enterprise server. If you create a new enterprise server, you should choose Micro Focus Enterprise Server with Mainframe Subsystem Support on the first page of the Add Server dialog.

Once you have created a new enterprise server or modified an existing one, you can configure it for IMS. Depending on your IMS applications, the various configuration operations you need to perform are as follows:

  • enabling IMS
  • enabling JCL
  • specifying the location of genned files
  • creating a resource group
  • adding a resource group to a startup list
  • defining transactions
  • calculating shared memory area requirements

These operations are covered in the following sections.

Resources, SITs and startup lists are all CICS concepts. This is because support for IMS in Enterprise Server is closely integrated with support for CICS. As a result, much of the configuration necessary to run CICS applications in an enterprise server is also necessary to run IMS applications.

Parent topic: Configuring IMS-enabled Enterprise Servers


MSS and CICS Support

This section provides a brief overview of the CICS concepts with which you need to be familiar in order to configure enterprise server for use with IMS. This is necessary because support for IMS in Enterprise Server is integrated with support for CICS. If you are familiar with basic CICS concepts you can skip this section.

In CICS, items of software or hardware for use by applications are called resources. Mainframe Subsystem Support adds to Enterprise Server facilities for defining, controlling and monitoring resources. These facilities have been extended to include resources needed by IMS applications. You don't need CICS experience to use these, but you do need a basic understanding of the structure, so for readers unfamiliar with the CICS model, here is a quick overview.

In CICS, you define sets of resources. These sets of resources are called resource groups.

A CICS region is an environment for running CICS applications. When you create a region, you specify a system initialization table (SIT), which gives details of how the region is to be configured. One item specified by the SIT is called a startup list; this is a list of resource groups that are to become available automatically when the region is started.

An enterprise server is equivalent to a CICS region, in Enterprise Server for Windows or UNIX. To run IMS applications, you need to define special service execution processes (SEPs) called message processing regions (MPRs). You define these MPRs as CICS-style resources. Resources always belong to resource groups, so you also need to define a resource group, which needs to be referenced by a startup list, which needs to be referenced by a system initialization table (SIT). You then need to specify that the enterprise server is to use this SIT.

The figure below shows the hierarchical structure of SITs, startup lists, resource groups, and individual resources. The bottom line of the figure shows some more types of CICS resources - a program control table (PCT), file control table (FCT) and program processing table (PPT).

Figure 1. Structure of CICS Resources
Structure of CICS Resources

For more information about CICS Support within MSS, see Part 2 of this book. For more information about Enterprise Server, see your Enterprise Server Configuration and Administration Guide.

Parent topic: Configuring IMS-enabled Enterprise Servers


Adding IMS-specific Resource Definitions

IMS support includes two new transactions, /CIC and /IMS, that you use to switch enterprise servers to CICS and IMS modes respectively. In order for these new transactions to be available you need to update your resource definition file using the caspcupg command.

To update your resource definition file, enter the following command:

caspcupg /dp=resourcedefinitionpath /o

where resourcedefinitionpath is the path to the system resource defintion file to be updated. If you are using the default system resource defintion file, dfhdrdat located by default in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\files\sys , you can omit /dp=resourcedefinitionpath. See caspcupg for more information on the caspcupg utility.

Updating a resource definition file with the /CIC and /IMS transactions in this way is a one-off process. Once you have used caspcupg to upgrade a resource definition file, any enterprise server that uses the updated resource definition file can use the new transactions.

Parent topic: Configuring IMS-enabled Enterprise Servers


Enabling MSS for an Enterprise Server

IMS support is part of Mainframe Subsystem Support (MSS), so before you enable an enterprise server for IMS you must enable it for MSS.

Note: When enabling an enterprise server for MSS you do not need to specify any settings for the CICS search paths unless your IMS application also includes CICS.
  • To enable MSS for an enterprise server
Parent topic: Configuring IMS-enabled Enterprise Servers


Enabling IMS for an Enterprise Server

Once you have enabled MSS for an enterprise server you can enable IMS for it.

Note:
  • Enabling an enterprise server for IMS sets up the basic support for IMS, but additional configuration is required, as described in the section Specifying the Location of Genned Files.
  • You also need to perform the basic configuration that any enterprise server needs. For more information see the section Enterprise Servers in the chapter Configuration in your Enterprise Server Configuration and Administration Guide. You do not need to define services, request handlers or implementation packages in order to run migrated IMS applications in an IMS-enabled enterprise server. However, you should not delete the system services and request handlers that are automatically associated with an enterprise server when you create it.
  • To enable IMS for an MSS-enabled enterprise server
  • Using IMS Connect with Enterprise Server
  • Using OTMA with Enterprise Server
Parent topic: Configuring IMS-enabled Enterprise Servers
Related information
To enable IMS for an MSS-enabled enterprise server
Specifying the Location of Genned Files


Using IMS Connect with Enterprise Server

To enable Enterprise Server to use IMS Connect, you must create a custom listener.

  1. Click the Listeners tab in Enterprise Server Administration.
  2. Click Add.
  3. Enter a unique name for the new listener.
  4. From the Endpoint Protocol drop-down list, choose TCP .
  5. Enter an appropriate port for IMS Connect in the Endpoint Address text box.
  6. Select a Supported Conversation Type of Custom and enter mfcs-ims-connect in the text box.
  7. Optionally, add trace details in the Configuration Information text box, for example:
    [Trace]
trace=y
data-trace=all
allmax=255
  8. Click Add.
Note:

The following IMS features are supported by Enterprise Server:

  • Conversational (SPA) and non-conversational transactions that do not use the IMS SETO functionality
  • Support for IMS commands
  • Security for all IMS Connect listeners
  • The following IBM-supplied I/O exits:
    • HWSIMSO0 '*IRMREQ*' Yes
    • HWSIMSO1 '*IRMRE1*' Yes
    • HWSSMPL0 '*SAMPLE*' Yes (unmodified - same as HWSIMSO0)
    • HWSSMPL1 '*SAMPL1*' Yes (unmodified - same as HWSIMSO1)
    • HWSJAVA0 '*HWSJAV*' No
    • HWSCSLO0 '*HWSCSL*' No
    No exit screening configuration is provided.
  • The return MOD name control
  • Persistent, non-persistent and transactional socket control
  • End-to-end ASCII flows

There is limited support for flow control and Syncpoint/Commit controls

The following are not supported:
  • Modified Sample I/O exits or target resolution exits
  • The return OTMA headers control
  • UTF and UCS codesets
  • The Translate control
  • The IRM timer
  • The One Message and One Message No Wait" controls
  • The Auto Flow and no Auto Flow controls
  • Asynchronous and unsolicited output to an IMS Connect client
Parent topic: Enabling IMS for an Enterprise Server


Using OTMA with Enterprise Server

If you are using Open Transaction Manager Access (OTMA) to communicate with IMS, no special configuration is needed. However you can specify the amount of time that an OTMA client should wait for an MPR to process a message. The default is 120 seconds, but you can change this period using the environment variable ES_OTMA_TIMEOUT.

Enterprise Server's OTMA C/I (Call Interface) supports the following calls:
  • CALL FUNCTION otma_create - creates storage structures to support communications but does not establish a connection with IMS.
  • otma_open - establishes a connection with IMS. Issue an otma_create prior to establishing an otma_open call.
  • otma_alloc - creates an independent transaction session.
  • otma_send_receive - ends to IMS and passes parameters for receive functions.
  • otma_free- releases the independent transaction session.
  • otma_close - ends the connection with IMS.
Parent topic: Enabling IMS for an Enterprise Server


Specifying the Location of Genned Files

After you have enabled IMS for an enterprise server you need to specify the directory the enterprise server is to search for the IMS-related files it needs for your IMS applications.

  • To specify the location of genned files
Parent topic: Configuring IMS-enabled Enterprise Servers
Related information
To specify the location of genned files


Specifying IMS Resources to a Resource Group

Before you can run an IMS application in an enterprise server you ensure that the following resources are included in a resource group:

  • the list of transactions (and their associated programs) that the IMS application can perform
  • the message processing regions that the enterprise server will use

You can add these resources to an existing resource group or create a new one for them.

To update an enterprise server's resource groups you must first start the enterprise server then use Enterprise Server Monitor and Control (ESMAC). See the chapter Administering Servers Using ESMAC in your Enterprise Server Configuration and Administration Guide for more information on Enterprise Server Monitor and Control.

  • To create a resource group
  • To modify a resource
  • Adding a Transaction to a Resource Group
  • Adding a Message Processing Region to a Resource Group
Parent topic: Configuring IMS-enabled Enterprise Servers
Related information
To create a resource group
To modify a resource


Adding a Transaction to a Resource Group

You add a transaction to a resource group by adding a PCT.

Parent topic: Specifying IMS Resources to a Resource Group


Adding a Message Processing Region to a Resource Group

Every enterprise server that will be used to run IMS applications must have at least one message processing region. By adding a message processing region to a resource group you ensure that the message processing region starts each time the enterprise server starts.

  • To add a message processing region to a resource group
Parent topic: Specifying IMS Resources to a Resource Group
Related information
To add a message processing region to a resource group


Adding a Resource Group to a Startup List

Having created a resource group for the resources needed by your IMS application, you need to add the resource group to a startup list.

  • To add a resource group to a startup list
Parent topic: Configuring IMS-enabled Enterprise Servers
Related information
To add a resource group to a startup list


Enabling JCL for an Enterprise Server

If your IMS application includes any JCL you need to configure the enterprise server as described in the chapter Configuring MSS-enabled Enterprise Servers for JCL.

Parent topic: Configuring IMS-enabled Enterprise Servers


Defining Transactions

Usually, a transaction definition must exist for any program you want to run. There are two ways of creating transaction definitions:

  • Define them manually.
  • Import them from a mainframe stage 1 file.

These two methods are covered in the following sections.

  • Defining Transactions Manually
  • Importing Transactions
Parent topic: Configuring IMS-enabled Enterprise Servers


Defining Transactions Manually

Before you can run any transaction you must define it.

  • To define a transaction manually
Parent topic: Defining Transactions
Related information
To define a transaction manually


Importing Transactions

The transaction import facility enables you to extract IMS transactions from an IMS stage 1 file downloaded from the mainframe, and automatically add the transactions to your IMS project. Importing transactions is a process with two steps:

  1. The stage 1 file is read and all the transaction definitions are extracted into another file, known as a transaction file. Note that the stage 1 file never contains any transaction definitions for DLI programs as these are batch programs that run outside the IMS region.

    To create a transaction file from a stage 1 file enter the following command:

    mfims stage1ext stage1file transactionfile

    where:

    stage1file | is the stage 1 file downloaded from the mainframe.
    transactionfile | is the transaction file to be created to contain the transaction and printer definitions needed to subsequently import into Enterprise Server. This is a flat text file, so you can edit it to remove any definitions that are not needed for the application to run under Enterprise Server.
  2. The transaction file from the first step is read and transaction definitions are added to the IMSGEN2.DAT file in the current directory.

    To import transaction defintions from a transaction file enter the following command from an application command prompt:

    mfims stage1imp transactionfile [ADDREPL] [DELEXIST]

    where:

    transactionfile | is the transaction file created by step 1.
    ADDREPL | specifies that you want to add new transactions and replace existing transactions. If you do not specify ADDREPL, new transactions are added but existing transactions are left unchanged.
    DELEXIST | specifies that you want to delete all the existing transaction definitions in the IMSGEN2.DAT file before any are imported.
Parent topic: Defining Transactions


Configuring IMS Printers

Describes printers supported and the process required to define and configure a printer to use with an IMS-enabled enterprise server.

Server Enterprise Edition supports LU1 and LU3 printers for use with enterprise servers configured to run IMS applications, and is specifically limited to printer clients that support the TCP TN3270 protocol. Non-TN3270 printer clients and the IMS Spool interface are not supported.

Prerequisites

Before configuring a printer, you must have an MSS-enabled enterprise server defined in Server Enterprise Edition Administration. Once this is in place, do the following:
  • Specify a system initialization table
    We recommend that you either specify the provided SIT, IMSSIT, or that you copy the IMSSIT to another name and specify the newly copied SIT. IMSSIT is preconfigured with many of the requirements necessary to run a successful IMS application, including:
    • Initial Tran ID - This is set to /IMS, and specifies that interactive TN3270 clients initially connect to IMS TM.
    • IMSSTRT Startup List - Includes several resource groups that provide a number of resource definitions required for the basic operation of Server Enterprise Edition. Group IMSGRP contains resource definitions that are specific to Server Enterprise Edition and IMS operation.
    • IMSGRP Resource Group - Contains a TERM model definition for LU1 printers.
  • Ensure that your SIT is updated with current printer definitions

    When you upgrade from an earlier version of Studio Enterprise Edition, user-specific resource groups such as IMSGRP are not updated automatically. We recommend that you add the current printer definitions manually. Do this by running the following command at aNet Express command prompt:

    caspcupg /o

Enabling Printer Support

The procedure for enabling printer support varies depending on your needs. Consider the following use case scenarios:

Use Case 1: Most or All Printers are LU1
No further configuration is required unless some printers are LU3 (see Use Case 3 below).
Use Case 2: Most or All Printers are LU3
In this case, rename the MLU1 printer Term Model definition in the IMSGRP resource group to MLU3, and redefine it as Term Model specifically for LU3 printers.
Important: You must rename and reconfigure the MLU1 definition, or remove it and create a new definition for LU3 printers. We do not support multiple Term Model printer definitions for TN32871.
Use Case 3: Define Specific Printers to Server Enterprise Edition
In this case, you want to install explicit definitions for exceptions to Use Case 1 or 2, or for all printers. This requires that you add the printer definition or definitions to the IMSGRP resource group by adding a Term definition for each printer.

Additional Configuration

In addition to defining your printers, you must also configure the following:
  • Define the printer to Server Enterprise Edition security
  • Configure your TN3270 emulator to attach to the printer

See Assigning Client Names for more information.

  • Assigning Client Names
    Describes the client name and other names you must provide as you configure an IMS-enabled printer.
  • To define specific printers for an IMS-enabled enterprise server
  • To enable printer security for an IMS-enabled enterprise server
  • To attach to an IMS printer
Parent topic: Configuring IMS-enabled Enterprise Servers
Related concepts
Assigning Client Names
Related tasks
To define specific printers for an IMS-enabled enterprise server
To enable MSS for an enterprise server
To enable IMS for an MSS-enabled enterprise server
To start an enterprise server instance
To Start ESMAC for an enterprise server instance


Assigning Client Names

Describes the client name and other names you must provide as you configure an IMS-enabled printer.
In the process of configuring printers for an IMS-enabled enterprise server, you must provide a client name and other names in several areas of configuration. This can be tricky. Consider the following as you complete the configuration process:
  • The TN3270 client name is ultimately the IMS LTERM name that identifies the printer.
  • This client name must also appear in the Server Enterprise Edition security system as a user ID. The printer operates under Server Enterprise Edition with the security authorization assigned to this user ID.
  • When attached to Server Enterprise Edition, this client name appears as the printer's Net Name on the Server Enterprise Edition ESMAC Clients page.
  • If this client name/Net Name is not defined to Server Enterprise Edition with a specific TERM definition, it is assigned the characteristics of the Server Enterprise Edition TERM model definition with the model name of TN32871.
  • The TN3270 printer emulator Terminal Type definition must default to or be specified as IBM-3287-1. The TN3270 client name and terminal type are the controlling definitions.
  • Associated Server Enterprise Edition definitions are used if they match the names specified in the TN3270 client.
Parent topic: Configuring IMS Printers
Related concepts
Configuring IMS Printers
Related tasks
To attach to an IMS printer
To define specific printers for an IMS-enabled enterprise server


To define specific printers for an IMS-enabled enterprise server

Note: This topic applies to Use Case 3: Define Specific Printers to Enterprise Server from the topic Configuring IMS Printers. See Configuring IMS Printers for information on LU1 and LU3 Term Model definitions.
  1. Start ES Monitor & Control for your IMS-enabled enterprise server.
  2. Edit the IMSGRP resource definition, found in the IMSSTRT startup list.
    Note: The IMSGRP resource definition is found in the IMSSIT system initialization table. If you have not specified IMSSIT for this enterprise server, create a new resource group.
  3. On the CICS GROUP page, click Term.
  4. In the Name field, type a four-character name for the new Term; generally, this is the last four characters of the Net Name, and must be unique within the Term name namespace for an enterprise server. A name conflict encountered for either specifically or dynamically defined clients can prevent definitions from installing properly at run time.
  5. Type a meaningful description into the Description field.
  6. From the Model drop-down list, select No.
  7. In the Net Name field, type a name. See Assigning Client Names for more information.
  8. In the Terminal Type field, type the terminal type that represents the printer. For example, for an LU3 printer, type LU3PRINT. LU3PRNT is a supplied T-TYPE definition in the DFHTERM definition group.
  9. Ensure that the Fixed Transaction field is set to /IMS. This specification ensures that Server Enterprise Edition publishes this device to theServer Enterprise Edition IMS TM.
  10. Click Add.
Parent topic: Configuring IMS Printers
Related concepts
Configuring IMS Printers
Assigning Client Names
Related tasks
To enable MSS for an enterprise server
To enable IMS for an MSS-enabled enterprise server
To start an enterprise server instance
To Start ESMAC for an enterprise server instance


To enable printer security for an IMS-enabled enterprise server

Note: This topic applies specifically to the use of legacy SNT security for Server Enterprise Edition. If using external security managers, the security manager that controls authentication (i.e., manages user IDs) must contain a user definition that matches the Net Name specified for the printer.
  1. Start ES Monitor & Control for your IMS-enabled enterprise server.
  2. From the list on the left side of the page, click Users.
  3. Click the Details button that corresponds to CICSUSER.
  4. Check Local ES Security Enabled.
  5. Click Apply.
  6. Add a user definition for each printer, providing a user ID for each that is the same as the printer's Net Name.
Parent topic: Configuring IMS Printers
Related tasks
To start an enterprise server instance
To Start ESMAC for an enterprise server instance


To attach to an IMS printer

In your TN3270 emulator, specify the client name (NETNAME), which is the IMS LTERM name under which it operates. For example, in Rumba type this name into the Device Name field on the TN3270 tab of the Connection Configuration dialog box. See Assigning Client Names for more information.

Parent topic: Configuring IMS Printers
Related concepts
Assigning Client Names


Calculating Shared Memory Area Requirements

The shared memory area calculation for an IMS-enabled enterprise server is essentially the same as for a Web services enterprise server. Your calculation should also include 512 bytes for each 3270 client that will be concurrently connected to the enterprise server. Note that you must include your message processing regions in the total number of service execution processes.

If you are using CICS or JCL applications in the same enterprise server you will also need to perform the calculations described in Shared Memory Area in the chapter Configuring MSS-enabled Enterprise Servers for CICS and Shared Memory Area in the chapter Configuring MSSenabled Enterprise Servers for JCL and add the relevant results to the figure you calculcated for IMS.

Parent topic: Configuring IMS-enabled Enterprise Servers
Shared Memory Area


Administering IMS-enabled Enterprise Servers

This chapter describes how you can use Enterprise Server Monitor and Control to run IMS applications on an MSS-enabled enterprise server.

  • ESMAC
  • Temporary MPRs
Parent topic: IMS Support


ESMAC

You can use Enterprise Server Monitor and Control (ESMAC) to run and monitor IMS applications. You can also use all the facilities described in the chapter Administering Servers Using ESMAC in your Enterprise Server Configuration and Administration Guide , and in the help topics grouped under Administer a Server Using ESMAC. You should familiarize yourself with the contents of that chapter and the associated help topics before reading this chapter. If you want to find out about maintaining resources for running CICS applications, see the chapter Administering CICS-enabled Enterprise Servers using ESMAC .

  • Visual Appearance
Parent topic: Administering IMS-enabled Enterprise Servers
Related information
To create an ESMAC user
To start ESMAC for a server
To monitor services
To configure dumps
To view a dump
To initiate a system dump
To specify what information is traced
To change the trace dataset
To transfer the in-memory trace data to the auxiliary dataset at rollover
To view a system trace
To record service input and output
To view a local trace for a SEP
To view a local trace for a client process
To kill a SEP
To reply to an ACCEPT FROM CONSOLE statement
To shut down a server


Visual Appearance

When you first view ESMAC for an IMS-enabled enterprise server, the Server Information page is displayed, as shown in the figure below:

Figure 1. ESMAC Server information page for IMS
ESMAC Server information page for IMS

When you run ESMAC on an IMS-enabled enterprise server, you can use it to perform a wide range of administrative functions. Because of the integration between support for IMS and CICS within Enterprise Server, most of these administrative functions are described in the chapter Administering CICS-enabled Enterprise Servers. In addition, you can use ESMAC to create temporary MPRs, as described in the section Temporary MPRs.

Parent topic: ESMAC
Related information
Administering CICS-enabled Enterprise Servers
Temporary MPRs


Temporary MPRs

As well as defining permanent message processing regions, as described in the section Adding a Message Processing Region to a Resource Group in the chapter Configuring IMS-enabled Enterprise Servers , you can define temporary ones that exist only until an enterprise server is stopped.

To start a temporary MPR:

  1. In the dropdown list under Resources on the ESMAC menu, select IMS.
  2. Click Control in the Resources part of the ESMAC menu.

    The IMS Control page that appears is for starting MPRs and creating an internal diagnostic view of IMS TM message queues.

  3. In MPR Classes field, type the list of message classes you want this MPR to be able to run.
  4. If you are defining an MPR for transactions that you want to debug, check Debug.
  5. Click Start.

    The MPR starts immediately and lasts until the enterprise server is stopped.

Like all SEPs, any MPRs you define are shown, together with their statuses, on the SEPs page in ESMAC. Click SEPs near the top left of the ESMAC menu to display this. MPRs are displayed in the IMS MPR section.

Parent topic: Administering IMS-enabled Enterprise Servers
Related information
Adding a Message Processing Region to a Resource Group


Migrating IMS Applications

This chapter describes the process you should use to migrate your IMS applications from the mainframe to Enterprise Server and lists issues you might encounter while doing so.

  • Migration Procedure
  • Migration Issues
Parent topic: IMS Support


Migration Procedure

  1. Download the following application files from the mainframe to your PC:
    1. Source (program + PSB/DBD + MFS)
    2. Stage 1 definition
    3. Unloaded database data
  2. Create a project containing these downloaded files:
    1. Add the source files to the project.
    2. Build the project.
    3. Load the database data in EBCDIC or ASCII.
    4. Import the Stage 1 files.
    5. Create segment layout (.slf) files for all segments.

    See your documentation for information on performing these operations.

  3. Test the project.
  4. Remove any unsupported features and languages, including Assembler exits.
  5. Configure Enterprise Server for IMS support.
  6. Configure Enterprise Server for CICS and JCL support as required.
  7. Import the Stage 1 files.
  8. Generate the DBDs, PSBs and MFSs.
Parent topic: Migrating IMS Applications
Related information
Configuring CICS-enabled Enterprise Servers
Configuring IMS-enabled Enterprise Servers
Configuring JCL Timeouts
Developing and Testing the Application


Migration Issues

Server Enterprise Edition supports the running of applications compiled using both the ASCII and the EBCDIC character sets.

When migrating from EBCDIC to ASCII, you might encounter problems where character literals have been used in assignments and comparisons. The binary value represented by a particular character depends on the character set used: an 'A' is equivalent to the hexadecimal value C1 when using EBCDIC, but 41 when using ASCII.

  • Special Characters in MFS Attributes
  • Null MFS Fields
Parent topic: Migrating IMS Applications


Special Characters in MFS Attributes

Issue

If you have used character literals to specify the values of MFS attributes, the resulting values will be different when you compile using ASCII from those that you obtain when compiling using EBCDIC. For example, the two code fragments below give the same results when compiling with the EBCDIC character set. When using ASCII, however, the first example will give different behavior: '{A' now translates as hexadecimal 7B41 rather than C0C1.

Attributes specified using character literals

05 ATTRIBUTE-VARIABLES.
   10 CURSOR-ATTR          PIC X(2) VALUE '{A'.
   10 ERROR-ATTR           PIC X(2) VALUE '{I'.
   10 OK-ATTR              PIC X(2) VALUE ' A'.
   10 PROT-ATTR            PIC X(2) VALUE ' 1'.

Attributes specified using hexadecimal/binary notation

05 ATTRIBUTE-VARIABLES.
   10 CURSOR-ATTR          PIC X(2) VALUE X'C0C1'.
   10 ERROR-ATTR           PIC X(2) VALUE X'C0C9'.
   10 OK-ATTR              PIC X(2) VALUE X'00C1'.
   10 PROT-ATTR            PIC X(2) VALUE X'00F1'.

Resolution

To facilitate the migration of programs, you can specify at the level of the transaction or the system whether MFS attribute values have been coded using character or binary notation. (The value specified for the transaction definition overrides that for the system.)

Where you specify that the attribute values have been coded as character literals, Enterprise Server will automatically translate the values of MFS attributes to those that would be used if the program were compiled as EBCDIC. For example: the hexadecimal 7B41 value produced by assigning '{A' to an attribute and compiling with ASCII, will be converted to the correct C0C1 value. Where you specify that attribute values have been coded as binary data, Enterprise Server will take no action.

As an alternative solution, edit your programs to use x'nn' notation (as used in the second example above) instead of characters.

  • To define how MFS attributes are coded
Parent topic: Migration Issues
Related information
To define how MFS attributes are coded


Null MFS Fields

Issue

On the mainframe, the MFS null character, which is used to truncate fields, is defined as being x'3F'. However, in the ASCII character set, this represents the question mark (?) character. Therefore, where an ASCII application uses the question mark character in display data (whether held as literals within the program or obtained from an external source) an alternative null character must be chosen.

Resolution

Enterprise Server allows you to specify at the level of the transaction or the system which character is the null character. The default for this is x'1A'.

You must also edit any programs that use x'3F' to use the new null character instead.

  • To define the MFS null character
Parent topic: Migration Issues
Related information
To define the MFS null character


IMS Database Forward Recovery

Describes IMS database recovery using database image copies and forward recovery log files to restore the most recent database updates.

The process includes:

Preparing for Forward Recovery
  1. Run the Image Copy utility to make backups of all databases.
  2. Establish backup procedures to back up all databases at specified intervals moving forward.
  3. Enable forward recovery log files and set a location for generated log files.
  4. Establish backup procedures to back up all forward recovery log files at specified intervals moving forward.
Recovering IMS Databases
  1. Do one of the following:
    • Run the Image Restore utility to restore selected databases; then run the Recovery utility without specifying any image copy databases. This applies the updates from forward recovery log files to the databases found in the current location.
    • Run the Recovery utility specifying image copy databases. This restores the image copies and then applies the updates from forward recovery log files to the specified databases.
  2. Following each recovery done using the Recovery utility, always run the Image Copy utility to back up the recovered databases.
  • Preparing for Database Recovery
    Describes procedures, prerequisites, and settings necessary for successful database recovery following a hardware or a system failure.
  • Forward Recovery Log Files
    Describes the location, creation, naming convention, and use of forward recovery log files.
  • Image Copy Utility
    Describes the functions of the Image Copy utility and the JCL required to run it.
  • Image Restore Utility
    Describes the functions of the Image Restore utility and the JCL required to run it.
  • Recovery Utility
    Describes the functions of the Recovery utility, and the input and JCL required to run it.
Parent topic: IMS Support


Preparing for Database Recovery

Describes procedures, prerequisites, and settings necessary for successful database recovery following a hardware or a system failure.

Back Up All Databases

Before you can recover a database, you must have a copy of it to restore. This requires that you perform database backups of all databases, and keep backup copies to use for recovery. Always back up your databases at predetermined recurring intervals. In the event that your database requires recovery, this can minimize the time required to restore the database, and minimizes risk when performing the recovery procedure.

Note: The Recovery utility always uses forward recovery log files to update an existing copy of the database even when, in certain situations, the restored backup copy is an empty, initialized database. Therefore, a backup copy of the database is always required for database recovery.

You can use any backup utility you choose. As an option, Micro Focus provides the Image Copy utility, which is part of our IMS Database Forward Recovery feature.

Important: Do not use any Micro Focus utilities on the backup image of a database before attempting to use the database copy for recovery. If you alter the database image in any way, the recovery fails.

Enable Forward Recovery Logging and Set Logfile Location

To use Forward Recovery, you must have the appropriate forward recovery log files in place. By default, forward recovery logging is turned off in Server Enterprise Edition. Once enabled, Server Enterprise Edition creates logs for all online database updates and for all database updates that occur as a result of executing a BMP transaction. To enable forward recovery logging and specify a location for generated forward recovery log files, include the following environment variables and settings in the [ES-Environment] specification entered into the Configuration Information field of Server Enterprise Edition Administration for each enterprise server that updates an IMS database:

ES_IMS_ROLLFORWARD=YES
ES_IMS_TLOG_PATH=logFilePath
Important: Server Enterprise Edition does not create forward recovery log files when databases are updated offline by batch programs running DLI or DBB mode. In these cases, we recommend that you create a backup of each affected database immediately following the completion of each batch job.

Set Up Log File Backup

Because the forward recovery log files are critical to database recovery, you must put something into place to back them up on a regular basis to preserve them. To successfully recover a database, all log files created by database activity that took place after the most recent database backup must be present for use by the recovery utility. All log files that contain records of database activity of any kind are required for a successful recovery, including log files that record only database query activity rather than database updates.

Never delete any log file until after the database has been backed up and you have verified that the log file is no longer needed.

Parent topic: IMS Database Forward Recovery


Forward Recovery Log Files

Describes the location, creation, naming convention, and use of forward recovery log files.
Note: You must enable the creation of forward recovery log files and specify a location for generated log files. See Preparing for Database Recovery for details.

Log File Location

Once forward recovery logging is enabled, Server Enterprise Edition stores log files in the location specified by the ES_IMS_TLOG_PATH environment variable. Once created, you can move log files, but do not rename them. Before attempting to recover a database, all log files must reside in the directory specified by ES_IMS_TLOG_PATH.

When forward recovering logging is enabled, Enterprise Server IMS controls the size of the log files and any extensions.

Log File Naming Conventions

Each log file generated for forward recovery contains the name of the server that created it, and a timestamp representing the time it was created. The Recovery utility uses log file time stamps to determine which log files are required for the restoration, and excludes out-of-date log files from the recovery. This minimizes the time required to complete the recovery.

serverName-yymmddhhiisscc.TLOG

Where serverName is the name of the server on which the database is stored, and yymmddhhiisscc represents two digits for each: year, month, day, hour, minute, second, and microsecond.

Depending on the size of the database and the volume of transactions, recovery log files can become quite large. To better manage large-volume logs, Server Enterprise Edition occasionally creates extension logs. The name of an extension log file is the same as the originating log file, plus an appended extension number such as 001, 002, etc.

Parent topic: IMS Database Forward Recovery


Image Copy Utility

Describes the functions of the Image Copy utility and the JCL required to run it.
The Image Copy utility copies all specified databases from their current location as defined by the ES_IMSDAT environment variable to a specified backup location. This is done using JCL that includes the following:
  • One STOP statement to stop each database you want to back up. All databases must be stopped before the Image Copy utility can back them up. For example:
    //STOP01    EXEC PGM=MFDBUJCL,PARM='/STO DB BNKTXN'
//SYSOUT    DD SYSOUT=*
//STOP02    EXEC PGM=MFDBUJCL,PARM='/STO DB BNKCUST'
//SYSOUT    DD SYSOUT=*
//STOP03    EXEC PGM=MFDBUJCL,PARM='/STO DB BNKACC'
//SYSOUT    DD SYSOUT=*
  • A JCL step to execute the Image Copy utility, IMAGECOPY. Optionally, you can also specify the VERIFY parameter to verify the contents of all copied databases. If a database is found to be corrupt, no copy is made. In this case, correct the problem by rebuilding the database before attempting to make another backup. The following example shows the VERIFY parameter in use:
    //IC       EXEC PGM=MFDBUJCL,PARM='IMAGECOPY,VERIFY'
  • Specify the name and location of each backed up database. The following example specifies that the copied databases be stored as GDGs, enabling you to keep multiple versions of the data:
    //BNKIC1   DD DSN=BNKTXN.IC.GDG(+1),DISP=(NEW,CATLG)
//BNKIC2   DD DSN=BNKTXNX1.IC.GDG(+1),DISP=(NEW,CATLG)
//BNKIC3   DD DSN=BNKCUST.IC.GDG(+1),DISP=(NEW,CATLG)
//BNKIC4   DD DSN=BNKACC.IC.GDG(+1),DISP=(NEW,CATLG)
//BNKIC5   DD DSN=BNKTXNX2.IC.GDG(+1),DISP=(NEW,CATLG)
  • In the SYSIN statement, list each database you want to copy followed by the name of the DD that represents the location of the backed up database. Place the database name in the first eight columns. For example:
    //SYSIN    DD *
BNKTXN       BNKIC1
BNKTXNX1     BNKIC2
BNKCUST      BNKIC3
BNKACC       BNKIC4
BNKTXNX2     BNKIC5

The following is a complete example of the JCL required to execute the Image Copy utility. It specifies that five databases, defined in the first eight bytes of SYSIN data, are to be copied to locations specified by the DD statements. Also, since the VERIFY parameter has been specified, an attempt is made to verify the integrity of the databases:

//RUNGDG JOB  'IC',CLASS=A,MSGCLASS=A
//*
//STOP01    EXEC PGM=MFDBUJCL,PARM='/STO DB BNKTXN'
//SYSOUT    DD SYSOUT=*
//STOP02    EXEC PGM=MFDBUJCL,PARM='/STO DB BNKCUST'
//SYSOUT    DD SYSOUT=*
//STOP03    EXEC PGM=MFDBUJCL,PARM='/STO DB BNKACC'
//SYSOUT    DD SYSOUT=*
//*
//IC       EXEC PGM=MFDBUJCL,PARM='IMAGECOPY,VERIFY'
//*
//SYSOUT   DD SYSOUT=*
//BNKIC1   DD DSN=BNKTXN.IC.GDG(+1),DISP=(NEW,CATLG)
//BNKIC2   DD DSN=BNKTXNX1.IC.GDG(+1),DISP=(NEW,CATLG)
//BNKIC3   DD DSN=BNKCUST.IC.GDG(+1),DISP=(NEW,CATLG)
//BNKIC4   DD DSN=BNKACC.IC.GDG(+1),DISP=(NEW,CATLG)
//BNKIC5   DD DSN=BNKTXNX2.IC.GDG(+1),DISP=(NEW,CATLG)
//SYSIN    DD *
BNKTXN       BNKIC1
BNKTXNX1     BNKIC2
BNKCUST      BNKIC3
BNKACC       BNKIC4
BNKTXNX2     BNKIC5
/*
//*
//START01  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKTXN'
//SYSOUT    DD SYSOUT=*
//START02  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKCUST'
//SYSOUT    DD SYSOUT=*
//START03  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKACC'
//SYSOUT    DD SYSOUT=*
//

If, for any reason, a database copy fails, the Image Copy utility creates an empty output dataset. In this case, you might want to delete the empty file before attempting to rerun the utility.

Important: Do not use any Micro Focus utilities on the backup image of a database before attempting to use the database image copy for recovery. If you alter the database image copy in any way, this causes the Recovery utility to fail.
Parent topic: IMS Database Forward Recovery


Image Restore Utility

Describes the functions of the Image Restore utility and the JCL required to run it.
The Image Restore utility copies a specified database image copy, overwriting the database with the same name, from the backup location to current location as defined by the ES_IMSDAT environment variable. If the ES_IMSDAT variable contains a concatenation of directories, each directory is searched for the matching database, and the database image copy is copied to the first directory found that contains a matching database. If the database is not found in any of the directories, the database image copy is copied to the first directory on the path.
Note: You can run the Image Restore utility to restore just the database, or you can restore the database and restore recent updates simultaneously using the Recovery utility.

An Image Restore job is run using JCL that includes the following:

  • One STOP statement to stop each database you want to restore. All databases must be stopped before the Image Restore utility can overwrite them. For example:
    //STOP01  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKTXN'
//SYSOUT    DD SYSOUT=*
//STOP02  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKCUST'
//SYSOUT    DD SYSOUT=*
//STOP03  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKACC'
  • A JCL step to execute the Image Restore utility, IMAGERESTORE. For example:
    //IC    EXEC PGM=MFDBUJCL,PARM='IMAGERESTORE'
  • Specify the name and location of each database you want to restore. The following example specifies that the copied databases are stored as GDGs, enabling you to keep multiple versions of the data:
    //BNKIC1   DD DSN=BNKTXN.IC.GDG(0),DISP=OLD
//BNKIC2  DD DSN=BNKTXNX1.IC.GDG(0),DISP=OLD
//BNKIC3  DD DSN=BNKCUST.IC.GDG(0),DISP=OLD
//BNKIC4   DD DSN=BNKACC.IC.GDG(0),DISP=OLD
//BNKIC5  DD  DSN=BNKTXNX2.IC.GDG(0),DISP=OLD
  • In the SYSIN statement, list each database you want to restore followed by the name of the DD that represents the location of the backed up database. Place the database name in the first eight columns. For example:
    //SYSIN    DD *
BNKTXN       BNKIC1
BNKTXNX1     BNKIC2
BNKCUST      BNKIC3
BNKACC       BNKIC4
BNKTXNX2     BNKIC5

The following is a complete example of the JCL required to execute the Image Restore utility. It specifies that five databases defined in the first eight bytes of SYSIN data are to be restored from the location specified by the DD statements to the location defined by the ES_IMSDAT environment variable:

//RUNGDG JOB  'IR',CLASS=A,MSGCLASS=A
//*
//STOP01  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKTXN'
//SYSOUT    DD SYSOUT=*
//STOP02  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKCUST'
//SYSOUT    DD SYSOUT=*
//STOP03  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKACC'
//SYSOUT    DD SYSOUT=*
//*
//IC    EXEC PGM=MFDBUJCL,PARM='IMAGERESTORE'
//*
//SYSOUT   DD SYSOUT=*
//BNKIC1   DD DSN=BNKTXN.IC.GDG(0),DISP=OLD
//BNKIC2  DD DSN=BNKTXNX1.IC.GDG(0),DISP=OLD
//BNKIC3  DD DSN=BNKCUST.IC.GDG(0),DISP=OLD
//BNKIC4   DD DSN=BNKACC.IC.GDG(0),DISP=OLD
//BNKIC5  DD  DSN=BNKTXNX2.IC.GDG(0),DISP=OLD
//SYSIN    DD *
BNKTXN       BNKIC1
BNKTXNX1     BNKIC2
BNKCUST      BNKIC3
BNKACC       BNKIC4
BNKTXNX2     BNKIC5
/*
//*
//START01  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKTXN'
//SYSOUT    DD SYSOUT=*
//START04  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKCUST'
//SYSOUT    DD SYSOUT=*
//START05  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKACC'
//SYSOUT    DD SYSOUT=*
//
Parent topic: IMS Database Forward Recovery


Recovery Utility

Describes the functions of the Recovery utility, and the input and JCL required to run it.
Important: To successfully recover a database, all forward recovery log files containing records of all database activity that took place after the last database backup up must be present for use by the Recovery utility. Log files must be unlocked to be used in recovery. To unlock log files, stop the server that created them.

The Recovery utility can restore image copy databases and/or the most recent database updates performed just before a hardware or a system failure.

To restore database image copies, the Recovery utility accepts as input the name and location of each database backup file. Optionally, before running this utility, run the Image Restore utility to copy any database image copy to the current location. To update a database with the most recent changes, the relevant log files must be available on the path specified by the ES_IMS_TLOG_PATH environment variable. The Recovery utility determines the relevant log files required to recover each database.

The utility can recover up to 200 databases in each JCL job. Be aware, however, if the date and timestamp on any given database is significantly older than the other specified databases, we recommend that you recover that database separately to save time. To do otherwise could cause the utility to process a large number of log files unnecessarily, ultimately degrading performance.

By default, when one execution of a database forward recovery job specifies multiple databases, and the Recovery utility cannot recover one or more of the databases specified, it attempts to recover the remaining databases. This can happen, for example, when a required forward recovery log file is missing. In this case, the Recovery utility recovers the databases for which all log files are found. Upon completion of the job, the job SYSOUT dataset contains information indicating the databases recovered and those not recovered.

Note: If you want to preserve the state of your current databases before recovery, be sure to copy them elsewhere before running the Recovery utility.

The Recovery utility copies database images as specified in the DD statements to the current location before applying the updates from the forward recovery log files. The JCL includes:

  • One STOP statement to stop each database you want to recover. All databases must be stopped before the Recovery utility can recover them. For example:
    //STOP01  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKTXN'
//SYSOUT    DD SYSOUT=*
//STOP03  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKCUST'
//SYSOUT    DD SYSOUT=*
//STOP04  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKACC'
  • A RECOVER statement to execute the Recovery utility. This statement must include the RECOVER and the SERVER parameters. The RECOVER parameter simply executes the utility; SERVER is required, and names the server that created the log files. The utility uses only those logs that are necessary to restore the specified databases. For example:
    //RECOVER EXEC PGM=MFDBUJCL,PARM='RECOVER,SERVER=IMSBANK'
  • If you want to restore one or more database image copies and simultaneously restore the information in the forward recovery log files, specify the name and location of each database you want to restore and also use the SYSIN statement to list each database, followed by the name of the DD that represents the location of the backed up database. Place the database name in the first eight columns. For example:
    //BNKIC1   DD DSN=BNKTXN.IC.GDG(0),DISP=OLD
//BNKIC2   DD DSN=BNKTXNX1.IC.GDG(0),DISP=OLD
//BNKIC3   DD DSN=BNKCUST.IC.GDG(0),DISP=OLD
//BNKIC4   DD DSN=BNKACC.IC.GDG(0),DISP=OLD
//BNKIC5   DD DSN=BNKTXNX2.IC.GDG(0),DISP=OLD
.
.
.
//SYSIN    DD *
BNKTXN       BNKIC1
BNKTXNX1     BNKIC2
BNKCUST      BNKIC3
BNKACC       BNKIC4
BNKTXNX2     BNKIC5
  • If you have previously restored the necessary databases using the Image Restore utility or any other database recovery utility, use the SYSIN statement to list each database you want to restore using forward recovery log files only:
    //SYSIN    DD *
BNKTXN
BNKTXNX1
BNKTXNX2
BNKCUST
BNKACC

The following examples show the complete JCL required to execute the Recovery utility:

Example 1 - Restore database image copies, and database updates from forward recovery log files

//RUNGDG JOB  'RECOVERY',CLASS=A,MSGCLASS=A
//*
//STOP01  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKTXN'
//SYSOUT    DD SYSOUT=*
//STOP03  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKCUST'
//SYSOUT    DD SYSOUT=*
//STOP04  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKACC'
//SYSOUT    DD SYSOUT=*
//*
//*
//RECOVER EXEC PGM=MFDBUJCL,PARM='RECOVER,SERVER=IMSBANK'
//*
//SYSOUT   DD SYSOUT=*
//BNKIC1   DD DSN=BNKTXN.IC.GDG(0),DISP=OLD
//BNKIC2   DD DSN=BNKTXNX1.IC.GDG(0),DISP=OLD
//BNKIC3   DD DSN=BNKCUST.IC.GDG(0),DISP=OLD
//BNKIC4   DD DSN=BNKACC.IC.GDG(0),DISP=OLD
//BNKIC5   DD DSN=BNKTXNX2.IC.GDG(0),DISP=OLD
//SYSIN    DD *
BNKTXN         BNKIC1
BNKTXNX1     BNKIC2
BNKCUST       BNKIC3
BNKACC         BNKIC4
BNKTXNX2    BNKIC5
/*
//*
//START01  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKTXN'
//SYSOUT    DD SYSOUT=*
//START04  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKCUST'
//SYSOUT    DD SYSOUT=*
//START05  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKACC'
//SYSOUT    DD SYSOUT=*
//*

Example 2 - Restore only database updates from forward recovery log files

//RUNGDG JOB  'RECOVERY',CLASS=A,MSGCLASS=A
//*
//STOP01  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKTXN'
//SYSOUT    DD SYSOUT=*
//STOP03  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKCUST'
//SYSOUT    DD SYSOUT=*
//STOP04  EXEC PGM=MFDBUJCL,PARM='/STO DB BNKACC'
//SYSOUT    DD SYSOUT=*
//*
//*
//RECOVER EXEC PGM=MFDBUJCL,PARM='RECOVER,SERVER=IMSBANK'
//*
//SYSOUT   DD SYSOUT=*
//SYSIN    DD *
BNKTXN
BNKTXNX1
BNKTXNX2
BNKCUST
BNKACC
/*
//*
//START01  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKTXN'
//SYSOUT    DD SYSOUT=*
//START04  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKCUST'
//SYSOUT    DD SYSOUT=*
//START05  EXEC PGM=MFDBUJCL,PARM='/STA DB BNKACC'
//SYSOUT    DD SYSOUT=*
//*
Parent topic: IMS Database Forward Recovery


Setting Checkpoints and Using Batch Backout

The topics in this section describe the checkpoint functionality, and how you can use this functionality with Batch Backout.

  • About Using Checkpoints
  • About the Checkpoint Files
  • Avoiding Dataset Contention
  • IMS Batch Backout
Parent topic: IMS Support


About Using Checkpoints

The MSS IMS functionality provides for symbolic checkpoint and restart calls and the basic checkpoint call. The symbolic checkpoint call can provide a checkpoint ID and save areas. These checkpoint ID and save areas are stored in a file named IMSLOGR.DAT and IMSLOGR.IDX. IMS Option also writes the system generated checkpoint ID to the IMS System Log file so you can specify the system checkpoint ID as the restart ID instead of the optional user specified checkpoint ID.

If a restart call indicates that a restart should take place, the save areas are restored into the program's Working-Storage. The restart's checkpoint ID can be specified in the XRST call itself or as part of the Batch Program Command used to start the batch program. All restart calls, successful or not, are logged in the IMS System Log.

An XRST call does not reposition any databases and will not restore any PCB information. Whether or not database updates were rolled back depends on whether you are using databases which support dynamic backout. IMS Option supports dynamic database backout with its Fileshare databases and with Remote IMS databases. See the Sync Point Coordination chapter in the Technical Reference for more information.

IMS Option GSAM files are not affected by checkpoint or restart calls. A checkpoint call will not affect GSAM database position. GSAM updates are committed to the data file when the update call completes.

Parent topic: Setting Checkpoints and Using Batch Backout


About the Checkpoint Files

The IMSLOGR files contain the save areas and checkpoint IDs for Symbolic Checkpoint (CHKP) calls. The IMSLOGR files are created the first time a CHKP call is made and added to for each subsequent CHKP call. It is read when a Symbolic Restart call (XRST) is issued to restore the program save areas. You will need to delete this file periodically as it could grow quite large. Once deleted, you cannot use XRST calls to restart from the deleted checkpoints.

These files are in the Listing directory.

Parent topic: Setting Checkpoints and Using Batch Backout


Avoiding Dataset Contention

IMS programs that make use of checkpoint/restart, for example the Batch Backout functionality can use the IMSLOGR DD statement to define the input log file to use.

You can use this in the JCL to avoid dataset contention with other concurrent checkpoint/restart programs. This log file is used to store checkpoint IDs, GSAM reposition information and application save areas during extended checkpoint processing.

Parent topic: Setting Checkpoints and Using Batch Backout


IMS Batch Backout

The Batch Backout utility allows database changes made by IMS batch applications (DLI and DBB) to be recovered either to a point prior to the start of the application or to a checkpoint.

Note:
  • Batch Backout is available only for offline batch IMS programs that access non-shared IMS databases. Batch IMS programs, both DLI and DBB, can only update IMS databases that are taken offline and made unavailable to online systems such as BMP programs, IMS transactions, CICS transactions and ODBA applications.
  • The Batch Backout utility can only be used for recovery of updates performed to offline IMS databases.
  • Batch Backout Implementation
  • Enabling Batch Backout Logging
  • Recovering Database Changes with the Batch Backout Utility
  • Rebuilding Corrupted Databases
  • Restrictions and Limitations
  • Error Conditions
Parent topic: Setting Checkpoints and Using Batch Backout


Batch Backout Implementation

To use the Batch Backout utility, you configure your IMS database update process to create batch backout log files. The Batch Backout process uses these log file to reverse changes. You can use the checkpoints that your applications set in these log files to back out selected changes only.

The Enterprise Server Batch Backout utility is similar in functionality to the IBM IMS batch backout implementation. The Enterprise Server implementation differs in the following ways:

  • The names of utilities, such as the backout program must not correspond to any names of similar utilities on the mainframe.
  • The format of the log files used as part of the database recovery process in the Enterprise Server implementation differs and is not compatible with the log files that are produced on the mainframe.
Note: Online IMS databases implemented in an Enterprise Server environment include dynamic (automatic) backout functionality. That is, when an application that has updated an online Enterprise Server environment IMS database abends, the uncommitted unit-of-work is backed out automatically, and does not require use of the Batch Backout utility. As a result, the features of Batch Backout that relate to the recovery of online databases are not needed and therefore unsupported in Enterprise Server.
Parent topic: IMS Batch Backout


Enabling Batch Backout Logging

Batch Backout logging for a batch IMS program is enabled in JCL by the presence of the BBOLOG DD statement. For example:

//BBOLOG  DD DSN=HLQ.PRJ01.BBOLOG.DEMO001T,DISP=(NEW,CATLG,DELETE)

IEFRDER and IEFRDER2 DD statements are ignored to avoid confusion with mainframe IMS logging and log record formats.

When enabled, updates to all IMS databases, along with checkpoint calls issued by the application program, are written to the BBOLOG dataset. Backup log files are extended as required in the event that they exceed size restrictions.

Standard JCL DSN management can be used for tracking these log datasets in the Micro Focus Server catalog.

CAUTION:
When logging is enabled, the primary log file and any extensions must not exist. If the job detects that the primary or extended log file already exists, then the job terminates with an appropriate error message.

Below is sample batch JCL that specifies a BBOLOG dataset:

//IMSBATCH JOB 'MICRO FOCUS',CLASS=A,MSGCLASS=A
//* DLI PROGRAM EXECUTION
//*
//S01       EXEC PGM=DFSRRC00,REGION=4M,
//          PARM='BMP,DEMO001B,DEMO001T,,,,,,,,,CDLI,,N,N'
//REPORT1   DD  SYSOUT=*
//BTSLST    DD  SYSOUT=*
//IMSERR    DD  SYSOUT=*
//IEFRDER   DD  DUMMY
//BBOLOG    DD  DSN=HLQ.PRJ01.BBOLOG.DEMO001T,DISP=(NEW,CATLG,DELETE)
//PRINTDD   DD  SYSOUT=*
//SYSOUT    DD  SYSOUT=*
//SYSPRINT  DD  SYSOUT=*
//
Parent topic: IMS Batch Backout


Recovering Database Changes with the Batch Backout Utility

The Batch Backout utility processes a backout log file and removes the updates to the IMS databases that were issued from the program that created the log file. The log file is processed in reverse. Database updates can be rolled back either for the entire batch job or back to a specific checkpoint ID.

The input log file to the Batch Backout utility is specified on the BBOLOGI DD statement. The log file must be catalogued in Micro Focus Server as follows:

//BBOLOGI DD DSN=HLQ.PRJ01.BBOLOG.DEMO001T,DISP=SHR

You can specify an optional recovery log file using the BBOLOGO DD statement. It too must be catalogued in Micro Focus Server, for example:

//BBOLOGO DD DSN=HLQ.PRJ01.BBOLOG.RECOVERY,DISP=(NEW,CATLG,DELETE)

You can use this log output file in the event that the database file needs to be restored to its state before the backout utility was run. In this event, use this recovery log as the input log (BBOLOGI) to a subsequent run of the backout utility.

CAUTION:
it is important to be aware of the existence of the extension logs when backing up the logs or moving them to alternate locations. The recovery log to be created (that is the file associated with ddname BBOLOGO) data file and any extensions associated with it must not exist. In this event, the recovery job terminates with the appropriate error message.
  • Using Checkpoints with Batch Backout
  • Using Extended Log Files
  • Batch Backout Example JCL
Parent topic: IMS Batch Backout


Using Checkpoints with Batch Backout

Database updates can be rolled back either for the entire batch job or back to a specific checkpoint ID. The backout functionality is implemented in the MFDBUJCL IMS Database Utility JCL interface. You specify PARM='BBO' to activate batch backout. For example:

//BACKOUT EXEC PGM=MFDBUJCL,PARM='BBO'

If restarting from a checkpoint, the checkpoint ID is specified in the SYSIN DD, for example:

  //SYSIN   DD *
  CHKPT CHECK001
  /*

Checkpoint options are listed in the table below.

CHKPT Keyword | Behavior
LAST | Default. Restores to the point of the last successful checkpoint call.
ALL | Backs out all checkpoints.
checkpoint id | Restores to the checkpoint specified. This id is limited to eight characters.
Parent topic: Recovering Database Changes with the Batch Backout Utility


Using Extended Log Files

When database logging is enabled, it is possible that the log file can become so large that it is necessary to create one or more extended log files. In this event, the extended log file or files are created in the same directory as the primary log file. These files are not catalogued with Enterprise Server.

The naming convention for extended logs is that an underscore and a sequential numeric value is added to the end of the name of the primary log file. For example, if the primary log file is named BankDemoLog.dat, then the extended log files are named BankDemoLog.dat_1, BankDemoLog.dat_2, . . . BankDemoLog.dat_nn, . . .

CAUTION:
When a database batch job is submitted and logging is enabled, the primary log file and its extensions must not exist. If the job detects that the primary or extended log file already exists, then the job terminates with an appropriate error message. Similarly for the batch backout utility, if you want the optional recovery log to be created (that is the file associated with ddname BBOLOGO) , then that recovery data file and any extensions associated with it must not exist.

Consequently, it is important to be aware of the existence of the extension logs when backing up the logs or moving them to alternate locations.

Parent topic: Recovering Database Changes with the Batch Backout Utility


Batch Backout Example JCL

Below is sample JCL that invokes the backout process . In the example code:

  • The process uses the HLQ.PRJ01.BBOLOG.DEMO001T log file.
  • The backout process starts from the end of the log file, and backs out to the checkpoint CHECKOO1
  • The process creates the output log file: BBOLOG.BBOLOG2
//BBO    JOB 'IMSDBU BATCH BACKOUT',CLASS=A,MSGCLASS=A
//*
//* THIS JOB DEMONSTRATES THE BATCH BACKOUT UTILITY
//*
//BACKOUT EXEC PGM=MFDBUJCL,PARM='BBO'
//SYSOUT  DD SYSOUT=*
//SYSIN   DD *
CHKPT CHECK001
/*
//BBOLOGI DD DSN=HLQ.PRJ01.BBOLOG.DEMO001T,DISP=SHR
//BBOLOGO DD DSN=HLQ.PRJ01.BBOLOG.BBOLOG2,DISP=(NEW,CATLG,DELETE)
Parent topic: Recovering Database Changes with the Batch Backout Utility


Rebuilding Corrupted Databases

When a database file has become corrupt, you must re-build it. This situation is rare, but can occur if, for example, the file was open during a system crash.

To rebuild a corrupted database, use JCL submission executing the database utility program: MFDBUJCL

With MFDBUJCL:

  • The SYSIN data can specify a fully qualified database file or just the database file name.
  • Specify REBUILD as the parameter.
  • Use SYSIN data to name the file to be rebuilt and, optionally, an output file.

    With these files, the file extension, .DAT may be specified or not. If not specified, it is automatically appended.

  • The OUTPUT file is optional. If it is not included, then the database file is rebuilt in place.

    If you specify an OUTPUT file, then it becomes the rebuilt file and the INPUT file remains unchanged. In this situation, you must make sure that this output file is renamed to the original file name before it can be used.

Note:
  • If a database file requires a rebuild, then you should consider whether any associated index files should be rebuilt as well.
  • Make sure that there is enough free space on disk before submitting the rebuild job.

    You will need as much space as the file to be rebuilt requires, and if you have specified an OUTPUT file to be created in the same directory, then you need to account for the extra space requirement.

An example of JCL for restoring a corrupted database is below:

  //DBUJCL01 JOB 'IMS DATABASE UTILITY',CLASS=A,MSGCLASS=A
//*--------------------------------------------------------------------
//* Copyright (C) 1991-2010 Micro Focus (IP) Limited.
//* All rights reserved.
//*-------------------------------------------------------------------
//*
//* THIS JOB REBUILDS THE IMS DEMONSTRATION DATABASE
//* 'DBDNP' USING THE IMSDBU JCL INTERFACE MFDBUJCL.
//*
//*
//STEP01  EXEC PGM=MFDBUJCL,PARM='REBUILD'
//SYSOUT  DD SYSOUT=*
//SYSIN   DD *
INPUT=DBDNP.DAT
OUTPUT=DBDNP.OUT.DAT
/*
//
Parent topic: IMS Batch Backout


Restrictions and Limitations

Batch Backout is not supported for the following cases:

  • BMP programs: BMP programs participate with online shared IMS databases and are not eligible for backout processing.
  • GSAM databases are not supported for batch backout.
  • Databases which have been made available to online BMP programs, IMS transactions, CICS transactions or ODBA applications are no longer eligible for batch backout processing.
  • Batch Backout processing is currently limited to a single input log file. DD concatenation or multiple input DD statements are not supported. If there are multiple input log files, then you need to run the backout utility multiple times. Take care to process the files in the correct order.
  • Recovery after a crash in the Micro Focus Server database engine may not be possible without external intervention.
Parent topic: IMS Batch Backout


Error Conditions

If the backout fails due to an error, the job returns an error condition of 20, and the database file is unchanged.

A return code of zero indicates success.

If an error occurs, then the following messages can be displayed in the job log. Use these messages to assist in problem determination and correction.

Message | Description
MFDBUJCL: PROBLEM WITH THE INPUT BACKOUT LOG | The input backout log may be corrupt or unreadable.
MFDBUJCL: PROBLEM WITH THE OUTPUT RECOVERY LOG. | In this event, the physical name of the recovery log file is displayed.
MFDBUJCL: PROBLEM WITH THE FILE TO BE RECOVERED | The physical name of the database file is displayed. If the file has been determined to be corrupt, then the error message indicates this as well as instructions for rebuilding the data file.
MFDBUJCL: ILLEGAL CONFIGURATION ITEM | This is an internal message.
MFDBUJCL: CHECKPOINT SET BUT NOT FOUND | A checkpoint was supplied in the SYSIN data but was not found in the log file.
MFDBUJCL: BACKOUT SUCCESSFUL. HOWEVER THE RECOVERY DATASET SHOULD NOT BE TRUSTED TO RUN A RECOVERY | This is a warning message. The backout of the dataset was complete, but the recovery log may be invalid and should not be used in a recovery of the dataset.

Additionally, the job log may display reason codes, files status codes or other messages which may help in problem determination.

Parent topic: IMS Batch Backout


Support for IMS DB System Commands

Enterprise Server currently provides support for issuing a subset of DB system commands. These commands enable you to control and query the statuses of IMS databases.

  • Supported IMS DB commands
  • Database command interfaces
  • ES server warm/cold start
Parent topic: IMS Support


Supported IMS DB commands

/DIS[PLAY] DB ALL | database1 [database2] ...
  • This returns the current status of each of the named databases.
  • 1 to 16 databases can be specified or the “ALL” parameter.
  • ES-IMS only returns database status for those databases it knows about. ES-IMS accesses databases as they are accessed by application programs and system commands, so the list of "known" databases grows dynamically.
  • Database statuses are described below:
    • UNKNOWN - The database name is not valid. There is no ACB defined for this DB.
    • NOTOPEN - The database is defined but has not been accessed.
    • OPEN - The database is currently being accessed by an application program.
    • CLOSED - The database has been opened but is not currently open.
    • STOPPED - The database is stopped and not available to MPP, BMP or CICS-DLI programs.
/STO[P] DB database1 [database2] ...
  • The STOP command stops a database or a list of databases.
  • When a database is stopped, it is not accessible from MPP, BMP or CICS-DLI programs. The database is only accessible from IMSDBU or batch DLI programs.
  • This command is run synchronously. It will suspend until the database is closed and stopped.
/STA[RT] DB database1 [database2] ...
  • The START command starts a database or a list of databases.
  • Use the START command to make the database available to online, BMP and CICS-DLI programs.
Parent topic: Support for IMS DB System Commands


Database command interfaces

TN3270
  • Database commands can be entered via a TN3270 session connected to /IMS.
  • The response output from the command will be sent back to the terminal session.
ESMAC
  • DB commands can be entered via the ESMAC IMS Control panel.
  • The response output is sent back to the ESMAC panel.
JCL
  • DB commands can be entered via the IMSDBU JCL interface using the PARM parameter
  • The response output is sent back to the job in the SYSOUT DD for the job step.
  • Step condition code is set if command fails.
  • Sample JCL step
    //STEP01  EXEC PGM=MFDBUJCL,PARM='/DIS DB DEMO03DD'
//SYSOUT  DD SYSOUT=*
  • Only one command can be entered per JOB step.
Parent topic: Support for IMS DB System Commands
Related concepts
IMSDBU Utility


ES server warm/cold start

  • All database statuses are set to NOTOPEN when a server is first started.
  • In future, initial database status will be configurable by DB name.
  • There is no current support for warm restart of the database status.
  • In future, database statuses will be stored on disk and will be used during warm restart.
Parent topic: Support for IMS DB System Commands


WebSphere MQSeries Trigger Monitoring

Server Enterprise Edition provides functionality for WebSphere MQSeries Trigger Monitoring for IMS, allowing IMS MPP programs to be scheduled when WebSphere MQ messages arrive on a designated WebSphere MQ queue.

To enable trigger monitoring, IBM WebSphere MQSeries Server or IBM WebSphere MQSeries Client must be installed on the machine where Enterprise Server is running.

WebSphere MQ objects required for triggering must be defined. These are:
  • An application queue with the trigger control set on, a recommended trigger type of 'First'. The application queue will reference the process and initiation queue.
  • A process definition with the application type set to an integer value of 3 and an application id set to the IMS MPP transaction to be started. (The integer value of 3 for the application type is the numeric designation for IMS and ensures compatibility with WebSphere MQ UNIX installations.)
  • An initiation queue
The objects need to be defined from the WebSphere MQ command line or IDE. See IBM WebSphere MQ Queue Parameters for details on how to do this.
  • Configuring Enterprise Server for WebSphere MQSeries Trigger Monitors
  • Security
  • Error Handling
  • Enabling IMS Trigger Monitor Tracing
  • What You Can Do
Parent topic: IMS Support


Configuring Enterprise Server for WebSphere MQSeries Trigger Monitors

The Enterprise Server region must be configured for both IMS and JES. For JES, you must define a batch initiator to process “class A” jobs. You need to ensure that enough initiators are defined for the job class to run all instances of the trigger monitor plus any other submitted jobs that will run under that class.

You also need to generate a PSB for the trigger monitor and create an XA resource to allow MPP applications to interface with IBM WebSphere MQ. A sample PSB definition file, csq4trmn.psb is included in the %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source folder.

The path to the CSQ4TRMN executable must be added to the JES Program Path. The path to any IMS MPP transactions that are started by the Trigger Monitor must be present on the IMS TM Application Path.

Parent topic: WebSphere MQSeries Trigger Monitoring


Security

If security is enabled, the trigger monitor will run under the userid that submitted the JCL to start the trigger monitor.

Parent topic: WebSphere MQSeries Trigger Monitoring


Error Handling

The trigger monitor will put messages in the WebSphere MQ dead-letter queue (if specified) under the following conditions:

  • There is an error starting the desired IMS transaction
  • The length of the message on the Initiation Queue is incorrect
  • The version (MQTMC-VERSION) of the trigger message is not 1
  • The application type specified in the trigger message is not IMS
Parent topic: WebSphere MQSeries Trigger Monitoring


Enabling IMS Trigger Monitor Tracing

You can dynamically control the IMS Trigger Monitor tracing. You do this by putting specific messages on the MQSeries Initiation Queue that the trigger monitor monitors. You can write a program to place these messages on the queue, or you can use an IBM supplied utility such as amqsput, or amqsputc.

You use the CSQ4TRMN:TRACE message to toggle tracing on and off:

  • If trace is currently OFF, putting a message with the CSQ4TRMN:TRACE massage string toggles the trace setting in the IMS Trigger Monitor ON.
  • If trace is currently ON, putting a message with the CSQ4TRMN:TRACE massage string toggles the trace setting in the IMS Trigger Monitor OFF.

You can also terminate the Trigger Monitor job by putting a specific message on the MQSeries Initiation Queue that the trigger monitor monitors. As with dynamic control, you can write a program to place these messages on the queue, or you can use an IBM supplied utility such as amqsput, or amqsputc.

To terminate the Trigger Monitor job, place the following message on the MQSeries Initiation Queue that is being monitored:

CSQ4TRMN:STOP

Parent topic: WebSphere MQSeries Trigger Monitoring


What You Can Do

Depending on your user granted permissions, you can do all or some of the following:

  • Start and stop the trigger monitor
  • Generate the PSB for the trigger monitor
  • Create the required XA resource
  • To start a WebSphere MQSeries trigger monitor
  • To stop a WebSphere MQSeries trigger monitor
  • To generate a PSB for a Trigger Monitor
  • To create an XA resource for a trigger monitor
Parent topic: WebSphere MQSeries Trigger Monitoring


JCL Support

  • Configuring Enterprise Servers for JCL
  • Administering JCL-enabled Enterprise Servers
  • z/OS Enterprise Server Extensions
    Describes the Server Enterprise Edition extensions designed to enhance usability, performance, and to allow more granular control.
  • Configuring JCL Timeouts
  • JCL Aspects of Troubleshooting
  • JCL Support Tasks
Parent topic: MSS Configuration and Administration


Configuring Enterprise Servers for JCL

This chapter describes how to create and configure JCL-enabled enterprise servers.

  • Enabling JCL for an Enterprise Server
  • SEPs for JCL
  • Shared Memory Area
  • Environment Validation
  • Spooler Housekeeping
  • Running the Spool Housekeeping Program from JCL
  • Controlling where Datasets are Created
  • Restarting Jobs
Parent topic: JCL Support


Enabling JCL for an Enterprise Server

You enable JCL on an enterprise server in the same way for both Windows and UNIX by using Enterprise Server Administration (for an introduction to this tool, see the chapter Introduction to Enterprise Server Administration in your Enterprise Server Configuration and Administration Guide ).

Note: You need the appropriate license before you can use an JCL-enabled enterprise server.
  • To enable JCL support
  • To enable MSS for an enterprise server
Parent topic: Configuring Enterprise Servers for JCL
Related information
To enable MTO for an enterprise server
To enable JCL support


SEPs for JCL

Two special types of service execution process are required to run JCL jobs. These are:

  • Batch initiator SEPs. A batch initiator SEP runs jobs.
  • Batch printer SEPs. A batch printer SEP handles the sending of output to a printer.

Both types of SEP have a class property. The JOB CLASS of a JCL jobstream must match the class of a batch initiator SEP in order for the SEP to run the job. The MSGCLASS or SYSOUT class must match the class of a batch printer SEP in order for the SEP to print the output.

You can either define permanent batch initiator and printer SEPs or create SEPs during a session that exist only until the end of the session.

When you define a batch printer SEP, you can specify a printer exit module, which enables you to perform additional formatting of output data before it is printed. For more information see the section Printer Exit Modules in the chapter JCL Support in your MTO Developer's Guide, if you have the development documentation available.

If you want to create a batch printer SEP that uses a printer accessed across a network, you need to have started the enterprise server from the command line or from the IDE; if you start it from ES Admin, it runs as a system service and the network printers defined on your machine are not available.

  • To define a batch initiator or printer SEP
Parent topic: Configuring Enterprise Servers for JCL


Shared Memory Area

The shared memory area calculation for a JCL-enabled enterprise server is the same as for a Web services enterprise server. You must include your batch initiator and batch printer SEPs in the total number of service execution processes.

If you also run CICS applications in the same enterprise server, you will also need to perform the calculations described in the section Shared Memory Area in the chapter Configuring MSS-enabled Enterprise Servers for CICS and add the results to the total.

Parent topic: Configuring Enterprise Servers for JCL


Environment Validation

When you start an enterprise server, a utility called DFHZJCL2 runs automatically to check for some common set-up errors that might otherwise be hard to spot. For example, it checks that the system catalog and default allocation location are both usable. If a problem is found, it displays a message on the console log.

For example, should the catalog be unusable there will be a message in the log saying: "Catalog Open IVP test failed".

Once it has completed the validation DFHZJCL2 schedules the spool housekeeping by issuing a CICS START for transaction JCL1.

Parent topic: Configuring Enterprise Servers for JCL


Spooler Housekeeping

When you start an enterprise server, a CICS transaction called JCL1 runs to delete old spool files. You can configure how often this happens and how long spool files are kept for.
Note: This process does not run automatically. You need to configure it using the PTLPI process. You also need to configure the CICS region to use spooler housekeeping. SSTM is mandatory to enable support for the spooler.

The housekeeping process involves the following programs: DFHZJCL1, DFHZJCL3, MVSP0027. The validation program described in the previous section starts the transaction JCL1, which runs the program DFHZJCL1. This program does the following:

  • LINKS to DFHZJCL3 to get the Housekeeping Frequency (i.e. how often spool housekeeping should be run) and the Housekeeping Retain Period (i.e. how long spool files should be kept prior to automatic deletion).
  • CALLS MVSP0027 passing the Housekeeping Retain Period. MVSP0027 deletes any spool files older than the retain period.
  • STARTS JCL1 after the interval specified in Housekeeping Frequency
  • Displays messages on the console saying that the spool housekeeping has:
    • started: SPOOL CLEAN-UP started

      and

    • finished (successfully or not ): SPOOL CLEAN-UP ended normally, maximum retain period is 6 days.
Note:

The preferred way of running Spool Housekeeping is using JCL, as described in this help. The job can then be scheduled to reflect the realities of the customer's environment.

You can also run spool housekeeping using a CICS trancode. To do this:
  • Define the CICS trancode for JCL1 that points to program DFHZJCL1.
To set that this trancode runs automatically upon server startup, add the group that contains that trancode to the startup list.
  • Setting the Retain Periods
  • Setting the Default Retain Period and Run Frequency
  • Setting the Retain Period and Archive Flag for Specific Held Classes
Parent topic: Configuring Enterprise Servers for JCL


Setting the Retain Periods

You configure the retain periods by editing and recompiling DFHZJCL3, one of the programs run during the housekeeping process.

Note: When you configure a retain period less than the default clean up date, only HELD output is deleted before the default cleanup date. The JESYSMSG spool file is not deleted until the default clean up date is reached regardless of what class it is. Other processes depend on this file while any spool output is retained.

For example, a job produces JESYSMSG and SYSPRINT output to class B. If the retain period for class B is 2 days and the default retain period is 7 days, and class B is HELD, only the SYSPRINT will be deleted after 2 days.

If class B is not HELD, neither spool file is deleted after 2 days. All spool output, including the JESYSMSG regardless of whether HELD or not, will be deleted after 7 days.

DFHJCL3 uses a user modifiable copybook which contains the run frequency and retain period values. The copy book is SPOOLHK.CPY a portion of which is reproduced below. Set the values as required (see below) and recompile DFHZJCL3.

      **********************************************************************************
      *  This copy book controls the spool housekeeping.
      **********************************************************************************
      *      ws-run-frequency
      *          this field controls how often the spool clean-up is run
      *          it is stated in days
      *      ws-keep-for
      *          this field contains the default retention period in days for
      *          spooled output
      **********************************************************************************
           03  default-settings.
             05  ws-version                      pic x(8)
                          value 'SPHK 1.0'.
             05  ws-run-frequency                pic 99999 value 1.
             05  ws-keep-for                     pic 99999 value 6.
      **********************************************************************************
      *    The following fields contain the retention periods for spooled output by class
      *    and a flag indicating whether spool files in this class should be archived on
      *    deletion.  There are 36 entries, A through Z and 0 through 9.
      *    If the value is set to 99999 then the default value from ws-keep-for
      *    will be used. A Y indicates that spool files should be archived upon deletion.
      *    These ws-keep-for values are DAYS.
      *    To change the retention period edit the appropriate values and recompile
      *    DFHZJCL1.cbl
      *    e.g.  to change the class A retention period to 1 week and specify that no
      *    archiving is required:
      *    edit the first  filler for class A so that the value is 7
      *    edit the second filler for class A so that the value is N
      *    giving:
      *      class A
      *      05  filler                           pic 99999 value 00007.
      *      05  filler                           pic x     value 'N'  .
      **********************************************************************************
           03 ws-class-settings.
      *      class A
             05  filler                           pic 99999 value 00001.
             05  filler                           pic x     value 'N'  .
      *      class B
             05  filler                           pic 99999 value 00002.
             05  filler                           pic x     value 'N'  .
Parent topic: Spooler Housekeeping


Setting the Default Retain Period and Run Frequency

The comments in the copybook, SPOOLHK.CPY explain the field values

 05  ws-run-frequency                pic 99999 value 1
Change the value of ws-run-frequency to the number of days that you want to elapse between runs of spool housekeeping.
Note: The ws-run-frequency value is used only if the spool housekeeping is run using CICS. It has no meaning with the recommended method, that is when you schedule a batch job to run spool housekeeping.
05  ws-keep-for                         pic 99999 value 6

This is the default retain period and applies to ALL spool output. Change the value of ws-keep-for to the maximum number of days that you wish to keep spool output for. (This includes: i) Any held output for SYSOUT classes with no specific retention period ii) Any output that was scheduled for printing which is still on the spool print queue)

Note:

The retain interval is in days. Using one day is not recommended as a run shortly after midnight would delete spool files written the late previous night; that is, files that are only a few minutes or hours old.

Parent topic: Spooler Housekeeping
Related information
Setting the Retain Periods


Setting the Retain Period and Archive Flag for Specific Held Classes

             05  filler                                 pic 99999 value 99999.
             05  filler                                 pic x     value 'N'  .

For those HELD output classes where the output should be deleted after a SHORTER interval than the above default retain period, edit the first value for the appropriate class.

If you want to archive the contents of the MVS SPOOL spool file prior to deletion, change the second value to ‘Y’. The file will be copied to the location specified in the environment variable MF_SPOOL_ARCHIVE_LOC.

Parent topic: Spooler Housekeeping


Running the Spool Housekeeping Program from JCL

The spool house keeping program, MVSP0027, can be called in batch from a user-written program run by JCL.

To do this, you must write your program to assign the fields as indicated by the instructions in copybook spoolhk.cpy, found in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source, and call MVSP0027. For example:

Example JCL to call your program

//EXAMP1 JOB 'CPTEST',CLASS=A,MSGCLASS=A
//STEP01 EXEC PGM=MFSPHK01
//SYSOUT DD SYSOUT=*
//OFILE  DD SYSOUT=*

Example program to invoke housekeeping

000100 IDENTIFICATION DIVISION.
000300 PROGRAM-ID. MFSPHK01.
003100***************************************************************
004600 ENVIRONMENT DIVISION.
004700 input-output section.
       file-control.
           select infile assign to ifile organization is sequential
                  file status is status-codei.
           select outfile assign to ofile organization is sequential
                  file status is status-codeo.
       DATA DIVISION.
       file section.
       fd  infile.
       01  inrec                         pic x(80).
       fd  outfile.
       01  outrec                        pic x(120).
       WORKING-STORAGE SECTION.
       01 status-codei                   pic xx.
       01 status-codeo                   pic xx.
       01 ws-message                     pic x(120).
       01  spool-hk-settings.
           copy spoolhk.cpy.
       01  ws-mvsp0027-rc                pic xx comp-5.
       01  ws-mvsp0027-reason            pic xx.
       01  disp-num                      pic 99.
       PROCEDURE DIVISION.

      *****************************************************************
      *                                                               *
      *****************************************************************
       0000-MAINLINE-MODULE.
           move 0 to ws-mvsp0027-rc
           call 'mvsp0027' using spool-hk-settings
                                ws-mvsp0027-rc
                                ws-mvsp0027-reason
           move spaces to ws-message
           evaluate ws-mvsp0027-rc
             when 0
               string
                    'SPOOL CLEAN-UP ENDED NORMALLY' delimited by size
                    ' maximum retain period is '    delimited by size
                     ws-keep-for                    delimited by size
                     ' days. '                      delimited by size
               into ws-message
             when 4
               string
                    'SPOOL CLEAN-UP ENDED, '        delimited by size
                    ' empty CASSPOOL/MVSSPOOL  '    delimited by size
                    ' maximum retain period is '    delimited by size
                     ws-keep-for                    delimited by size
                     ' days. '                      delimited by size
               into ws-message
           when other
               move  ws-mvsp0027-rc  to disp-num
               string
                    'SPOOL clean-up failed RC = '  delimited by size
                     disp-num                      delimited by size
                    ' reason code = '              delimited by size
                     ws-mvsp0027-reason            delimited by size
               into ws-message
           end-evaluate
           display ws-message upon console
           goback.

       FILE-INPUT SECTION.
           perform open-infile
           perform read-infile
           PERFORM UNTIL status-codei NOT = '00'
              *> populate mvsp0027 parms
              perform read-infile
           end-perform
           .

       open-infile section.
           open input infile
           if status-codei = '00'
               continue
           else
               move 12 to return-code
               goback
           end-if
           .
       read-infile section.
           read infile
           evaluate status-codei
               when '00'
               when '10'
                   continue
               when other
                   move 16 to return-code
                   goback
           end-evaluate
           .
Parent topic: Configuring Enterprise Servers for JCL


Controlling where Datasets are Created

To override the default location used during the creation of datasets, you can configure Enterprise Server to consult a file containing rules that determine where new datasets are created.

You do this by setting the ES_ALLOC_OVERRIDE environment variable to the location of the "rules" file. Each rule in the file specifies: an offset from the beginning of the catalog record, a value that will be found at the offset in records for datasets that match the rule, and a directory in which the files for those datasets will be created.

For example, the following rule:

OFFSET(n) VALUE (MYSTRING) SUBDIR (C:\MYDIR\MYSUBDIR)

will allocate to C:\MYDIR\MYSUBDIR all files that contain the string "MYSTRING" at position n of the catalog record. The catalog structure is defined in the copyfile: mvscatlg.cpy. This is located in %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x\base\source.

Each rule must occupy only 1 line and all keywords must be in uppercase. Rules are processed in the order that they appear in the file, and the first one that matches is the one that is used; that is, no further rules are consulted for that dataset.

Example rules file

#  Key off of the spool indicator
OFFSET(313) VALUE(S) SUBDIR(C:\MVSP0030\SPOOL)
#  Key off of the VOLUME value.
OFFSET(314) VALUE(CSIWRK) SUBDIR(C:\MVSP0030\VOLUME)
#  Key off of the DSORG
OFFSET(324) VALUE(VSAM) SUBDIR(C:\MVSP0030\VSAM)
#  Key off of the LRECL
OFFSET(469) HEXVALUE(0063) SUBDIR(C:\MVSP0030\LRECL99)
#  Key off of the first 6 bytes of the dataset name
OFFSET(1) VALUE(MFIDMF) SUBDIR(C:\MVSP0030\MFIDMF)
#  Key off of the DATACLAS value.
OFFSET(449) VALUE(MFIDMFY) SUBDIR(C:\MVSP0030\DATACLAS)
Note:
  • If you want your catalogs to be portable it is a good practice to have the "Subdir" directories at the same level in the directory structure or in directories that are children of the directory containing the catalog.dat file. In the example below we recommend that the catalog.dat be located in C:\MVSP0030\ This is not an absolute requirement, but will help your maintenance.
  • When you are specifying the name of the subdirectory to which files should be allocated, you can specify the string <CatalogFolder> to indicate the directory in which the catalog is stored. For example:
    OFFSET(313) VALUE(S) SUBDIR(<CatalogFolder>\SPOOL)
  • You can also use environment variables when specifying the subdirectory to which files should be allocated. For example:
    OFFSET(313) VALUE(S) SUBDIR($APPROOT\SPOOL)
    where APPROOT is the environment variable. The environment variable will be expanded before it is used in the pc dataset name field in the system catalog.
Parent topic: Configuring Enterprise Servers for JCL


Restarting Jobs

Enterprise Server provides support for restarting JCL jobs at a specified step and optionally a procstep. A typical sequence of events is as follows:

  • The job completes and remains on the Output Hold queue.
  • The user requeues the job for restart using either ESMAC, the casout command, or the callable API, specifying the step and (optionally) the procstep.
  • The job is put back into the Input queue.
  • The job is rescheduled and restarts at the specified step/procstep.
  • Enabling job restart functionality
  • Restarting a job
  • Non-restartable steps
  • Processing during restart
  • GDG Processing during Restart
Parent topic: Configuring Enterprise Servers for JCL


Enabling job restart functionality

The restart functionality is governed by two environment variables:

ES_JES_RESTART Setting this variable to Y has the following effects:
  • ESMAC will display new fields for a job's details on the Output Hold queue, along with a Restart button. The new fields allow you to specify the step and procstep at which the job is to restart.
  • When the job is run, the lexical files (MFELX*.DAT) associated with the job will no longer be cleaned up when the job is completed; instead, these files will be cleaned up when the job is deleted.
MF_UCC11 Setting this environment variable to Y enables:
  • Automatic reset of the GDG bias to the level of the prior run of the job; that is, the restart will automatically pick up the "correct" GDG Bias.
  • Restarting a job with DISP=(NEW,CATLG) datasets will not result in job failure due to the dataset already being cataloged.
  • COND Code Processing and IF/THEN logic that is dependent upon COND codes from prior steps that are skipped by the RESTART will work as expected with no changes to the JCL.

When this environment variable is set to M, on a restart a catalogued a dataset is presumed to have an initial disposition of MOD rather than NEW. As a result, any new data is appended to the existing dataset.

Parent topic: Restarting Jobs


Restarting a job

You can restart a job through:

  • the ESMAC Job Details Page for a job on the "Output Hold" queue
  • the casout command line. For example:
    casout /r<Servername> /j<jobnumber:step:procstep>
  • driving the casout callable API
Parent topic: Restarting Jobs


Non-restartable steps

You cannot restart a job at a step if that step contains:

  • a //UCC11NR DD DUMMY statement
  • any temporary datasets that have DISP of SHR or OLD
Parent topic: Restarting Jobs


Processing during restart

On a restart:

  1. The joblog and all other SYSOUTs will be extended with new data unless they have already been printed/deleted.
  2. Any DISP=NEW datasets will cause an already existing dataset to be deleted before allocation.
  3. Any DISP=MOD datasets that already exist will be extended.
  4. Any DISP=OLD datasets will be over-written.

At the conclusion of the restarted job, its new execution state (step condition codes) will be saved for a future restart.

Note:
  • A non-unique restart step/procstep is resolved to its first occurrence and a message is issued upon restart. This is the same behavior as RESTART= on the JOB statement.
  • When a job is deleted from the Output Hold queue in ESMAC, from the casout command, or via the automated spool cleanup mechanism, all traces of the job are removed and it can no longer be restarted.
Parent topic: Restarting Jobs


GDG Processing during Restart

When a job that uses GDG bias is restarted, all references to a GDG relative bias (e.g. +1, -3) will cause the DD statement to reference the same physical file as the original job. The only time that this will not be true is where the processing of the original job (or of other jobs that were run after the original job) has caused the GDG Bias to be rolled off, scratched, or deleted.

In the case of most mainframe jobs there will be no issues but you should be aware of the following scenarios:

  1. Where a job runs to successful (non-abend) completion and this results in a GDG Bias being rolled off, that Bias will not be available on the restart and any step which references that bias will fail with a "dataset not found" message.
  2. Where a different job, which references the relevant GDGs and creates new relative biases, runs between the end of the job in question and before the job restart takes place, it is possible that the bias referenced by the restarted job will no longer be present.
  3. Where a job abends prior to completion, the abnormal termination disposition is applied as specified by the DISP= statements in the JCL. In this scenario you will encounter problems if the step at which you restart references a bias that doesn't exist as a result of the prior abnormal termination.
Parent topic: Restarting Jobs


Administering JCL-enabled Enterprise Servers

This chapter describes how you can use Enterprise Server Monitor and Control to run JCL jobs on an MSS-enabled enterprise server. It also covers the use of commands to use some JCL facilities.

  • ESMAC
  • On-the-fly SEPs for JCL
  • Running and Controlling JCL Jobs
  • Running JCL jobs held on the enterprise server machine
  • Managing and Viewing Spool Queues
  • Viewing the Catalog and Data Sets
  • Importing and Exporting a Catalog: import export utility
    Describes how to use the catalog import-export utility
  • Using JCL Facilities from the Command Line
  • Interacting with JCL Jobs
  • Character Sets
Parent topic: JCL Support


ESMAC

You can use Enterprise Server Monitor and Control (ESMAC) to run and monitor JCL jobs. You can also use all the facilities described in the chapter Administering Servers Using ESMAC in your Enterprise Server Configuration and Administration Guide , and in the help topics grouped under Administer a Server Using ESMAC. You should familiarize yourself with the contents of that chapter and the associated help topics before reading this chapter.

As an alternative to using the ESMAC interface, you can use some JCL facilities from the command line. For more information see the section Using JCL Facilities from the Command Line.

  • Visual Appearance
Parent topic: Administering JCL-enabled Enterprise Servers
Related information
To create an ESMAC user
To start ESMAC for a server
To monitor services
To configure dumps
To view a dump
To initiate a system dump
To specify what information is traced
To change the trace dataset
To transfer the in-memory trace data to the auxiliary dataset at rollover
To view a system trace
To record service input and output
To view a local trace for a SEP
To view a local trace for a client process
To kill a SEP
To reply to an ACCEPT FROM CONSOLE statement
To shut down a server
Administering Servers Using ESMAC
Using JCL Facilities from the Command Line


Visual Appearance

When you first view ESMAC for a JCL-enabled enterprise server, the Server Information page is displayed, as shown below:

Figure 1. ESMAC Server information page for JCL
ESMAC Server information page for JCL

When you run ESMAC on a JCL-enabled enterprise server, you can use it to:

  • Run on-the-fly SEPs for running JCL jobs and handling printer output
  • Submit and monitor JCL jobs
  • View the catalog
  • View spool queues
Parent topic: ESMAC


On-the-fly SEPs for JCL

As well as defining permanent batch initiators and printer SEPS, as described in the chapter Configuring JCL-enabled Enterprise Servers, you can run temporary ones that exist only until the end of the session.

Like all SEPs, the initiators and printers defined are shown, together with their statuses, on the SEPs page in ESMAC. Click SEPs near the top left of the ESMAC menu to display this.

  • To start a batch initiator or printer immediately
Parent topic: Administering JCL-enabled Enterprise Servers
Related information
To define a batch initiator or printer SEP
To start a batch initiator or printer immediately


Running and Controlling JCL Jobs

ESMAC provides facilities for running and controlling JCL jobs, using the JCL Control page.

When a job is submitted, it is immediately syntax checked, and then put onto an input queue to await execution. It goes into execution once an initiator of a corresponding class becomes available. If two or more jobs of the same class are on the input queue, the one with the highest priority is scheduled for execution first.

The default behavior when using ESMAC to submit JCL jobstreams to an Enterprise Server is for the file to be uploaded by the web browser and submitted across the wire (if the Enterprise Server is remote) along with other form data. In previous releases, you could use the ESMAC JES "Control" page (CASRDO44) to enter a file name that is only visible to the Enterprise Server instance.

Security changes implemented with Mozilla Firefox V3 and IE 8 prevent us from supporting this behavior. If you are using an older browser that still allows this behavior you can override it and cause only the filename to be submitted to the Enterprise Server.

Once the job has completed, you can view details of its execution from the JCL Control page.

You see the JOBnnnnn page appears, where nnnnn is the number of the job. This page gives you access to several more facilities, described under the next section, Viewing Spool Queues .

You can view resource locks; you might want to do this if you suspect that a resource locking issue is holding up one of your JCL jobs.

  • To run a JCL job
  • To run a JCL job on a remote enterprise server
  • To view details of a job's execution
  • To view resource locks
Parent topic: Administering JCL-enabled Enterprise Servers
Related information
To run a JCL job
To run a JCL job on a remote enterprise server
To view details of a job's execution
To view resource locks
Viewing Spool Queues


Running JCL jobs held on the enterprise server machine

When you are accessing an enterprise server session remotely, by default, ESMAC submits JCL jobs held on the machine running the web browser. If you are using a ESMAC and web browser to connect to a remote machine and you want to submit JCL that is only visible to the remote machine, then you will need to override the default behavior. (For example, if you are accessing an Enterprise Server session running on a Unix machine and configuring the session from a web browser running on a Windows machine, by default ESMAC runs JCL jobs held on the Windows machine.)

To access files from the machine running the Enterprise Server, configure the following environment variable:

CASRDO44_NEWSUB=OFF

See Environment Variables for details.

With this environment variable configured, from a remote machine, you can browse for and run JCL jobs located on the machine running the Enterprise Server session.

It is important to note that this behavior will only function if you are using a browser that allows an HTML element of TYPE=FILE to be used as an entry field for a filename, as opposed to the actual file being submitted as part of a MIME multi-part form.

(Firefox V3.0 and later and IE8 and later no longer allow this behavior.

Parent topic: Administering JCL-enabled Enterprise Servers


Managing and Viewing Spool Queues

You can manage and view the spool queues from ESMAC.

The queues are listed below:

Button | Shows: | Details
Input | Input queue | Jobs waiting to start (usually waiting for an initiator for the correct class to be available)
In Hold | Held input queue | Jobs that are held (HOLD on the job card, or Hold button on a job’s entry in the Input Queue)
Active | Active jobs queue | Jobs currently running
Output | Output queue | Output files waiting to be printed (usually waiting for a printer for the correct class to be available)
Out Hold | Held output queue | Output files that are held (Hold button on a job’s entry in the Output Queue)
Printing | Print queue | Output files currently being printed

A spool queue that is not empty consists of entries for each job in the queue, with a button bearing the job number at the left-hand side of the page. You can click a job number button to view more details of the job. You see the JOBnnnnn page, where nnnnn is the number of the job. This page gives you access to several more facilities. You can:

  • Hold the job, that is, prevent the job from being executed if it is in the input queue or its output files from being printed if it is in the output queue
  • Update the control information for the job; this includes Class and Priority; you can use one or both of these to change the order in which jobs are run
  • Purge the job
  • View the details of any of the outputs from the job

The output file details page gives you access to some facilities for controlling and viewing individual output files. You can:

  • Hold the job, that is, prevent the job from being executed if it is in the input queue or its output files from being printed if it is in the output queue
  • Update the control information for the job; this includes Class and Priority; you can use one or both of these to change the order in which jobs are run
  • Purge the output file
  • View the contents of the output file
  • To view the spool queues
  • To delete a job
  • To delete a job output file
  • To delete all jobs in a queue
  • To hold or release a job
  • To update control information for a job
  • To view details of a job output file
  • To view details of a job's execution
  • To view the contents of a job output file
  • Active output jobs and server re-starts
    Describes the effect of running jobs when a region is re-started.
  • Spool Housekeeping Return and Reason Codes
    Describes the return output from spool housekeeping operations
Parent topic: Administering JCL-enabled Enterprise Servers
Related information
To view the spool queues
To view details of a job's execution
To hold or release a job
To update control information for a job
To delete a job
To view details of a job output file
To delete a job output file
To view the contents of a job output file
To delete all jobs in a queue


Active output jobs and server re-starts

If you boot an Enterprise Server region that shares a catalog with another Enterprise Server region that is currently running, the boot process flushes the currently running server's active jobs to the Held Output queue. As a result, the jobs disappear from the region's Active queue.

When a job is moved from Active to Output Hold as a result of a server restart, the Completion Code as viewed in the JES Output Hold queue is set to RFLS. This indicates that the job was flushed as a result of a restart.

To modify this behaviour, there is an environment variable that you can set to disable it.

If the environment variable ES_JES_DISABLE_RESTART_FLUSH is set to any value, then a region's jobs are not moved from the Active queue to the Output Hold queue when the region is re-started.

The recommended way to use this environment variable is to:

  • Set the ES_JES_DISABLE_RESTART_FLUSH environment variable for all online servers that share the Batch server's catalog.
  • Do not set the ES_JES_DISABLE_RESTART_FLUSH environment variable for all the Batch server.

This prevents the Online servers from purging the JES Active queue when they are cycled.

Parent topic: Managing and Viewing Spool Queues


Spool Housekeeping Return and Reason Codes

When you run a spool housekeeping operation, the return code is displayed on the console log. Possible values are as follows:

Return code | Reason
0 | The operation completed successfully without errors.
4 | No spool records were found. You would expect this when a server is first started, if spool housekeeping is scheduled via CICS.
8 | This is a warning, and the processing continues. It indicates that a spool record that was a candidate for deletion could not be deleted (possibly in use), or a catalog entry for a spool record that was a candidate for deletion is not present.
16 | This indicates a fatal error. Processing is terminated. Generally, it is the result of an unexpected file status code from IO on casspool.dat, mvsspl01.dat or catalog.dat.

These return codes indicate that the file i/o on the associated file has returned an unexpected status code. This can happen for a number of reasons. For example, because another process has the file locked, because an expected record no longer exists or an invalid catalog or archive location has been specified. If the resulting return code indicates a serious error (16) or the errors are persistent, CTF tracing for the housekeeping process is available (which will log the file status codes encountered for a precise diagnosis). The appropriate settings for CTF are:

mftrace.level.mf.mvs.mvsp0027  = debug
mftrace.comp.mf.mvs.mvsp0027#entry      = true
mftrace.comp.mf.mvs.mvsp0027#delete     = true
mftrace.comp.mf.mvs.mvsp0027#warning    = true

This configures that when the spool housekeeping operation fails, the return is accompanied by a reason code. These reason codes can help locate the source of the spool houskeeping problem, and they can also help to diagnose errors.

Return code | Reason
01, 02 | Read next record on casspool. operation failed.
03 | Purge record on casspool operation failed.
04 | Delete record on casspool operation failed.
05 | Start on casspool operation failed.
10 | Open on mvsspool operation failed.
11 | Delete record on mvsspool operation failed.
12 | Read next record on mvsspool operation failed.
13 | Keyed read on mvsspool operation failed.
20 | Open on profile (the .pro file describes the spool archive file for data file editor - only when archiving requested ) operation failed.
21 | Write on profile ( only when archiving requested ) operation failed.
30 | The Copy spool to archive operation failed. The spool archive directory may not exist.
40 | The Read record on catalog.dat file operation failed.
41 | The delete record from catalog.dat file operation failed.
Parent topic: Managing and Viewing Spool Queues


Viewing the Catalog and Data Sets

You can view the catalog from ESMAC.

From the catalog page you can:

  • Create a catalog entry for a new data set
  • View the details of an existing catalog entry
  • Update an existing catalog entry
  • Delete a catalog entry
  • Copy a catalog entry to create a new entry
  • Import a system catalog from an XML file
  • Export the contents of an existing catalog to an XML file
  • View the contents of a cataloged data set
  • To view the catalog
  • To copy a catalog entry for a data set
  • To create a catalog entry for a data set
  • To delete a catalog entry for a data set
  • To update a catalog entry for a data set
  • Importing and Exporting a Catalog: import export utility
    Describes how to use the catalog import-export utility
  • To view the contents of a data set
  • To view the details of a catalog entry
Parent topic: Administering JCL-enabled Enterprise Servers


Using JCL Facilities from the Command Line

You can use some JCL facilities from the command line. Commands are provided for:

  • Submitting JCL jobs
  • Starting batch initiator SEPs

These commands are described in detail in this chapter.

For any particular enterprise server, if you are going to invoke any functions via commands, you must use commands to start and stop that enterprise server. These commands are introduced in the section Command-line Interface in the chapter Servers in your Configuration and Administration Guide. All the commands are specified in detail in the help topics Commands.

  • Starting a Batch Initiator SEP
  • Submitting JCL Jobs
Parent topic: Administering JCL-enabled Enterprise Servers


Starting a Batch Initiator SEP

You use the command cassi to start a batch initiator or batch printer SEP from the command line. Before you use cassi to start a batch initiator or batch printer SEP, you must already have started the enterprise server using the command casstart.

For a full definition of cassi see the topic cassi (JCL version).

Here are some examples:

casstart -rJCLDEMO
start cassi -bABC -rJCLDEMO

This starts a batch initiator SEP for the classes A, B and C on the enterprise server JCLDEMO.

casstart -rJCLDEMO
start cassi -pA -q"HP LaserJet 4L" -rJCLDEMO

This starts a batch printer SEP for the class A on the enterprise server JCLDEMO using the printer defined on your machine as "HP LaserJet 4L".

casstart -rJCLDEMO
start cassi -pA -q"HP LaserJet 4L" -rJCLDEMO -zSAMPPRNX -a

This is as above, with the differences that the SEP is started for debug and the printer exit SAMPPRNX is installed.

Note that it’s advisable to run the command cassi in a separate session, using the Windows start command as shown.

Parent topic: Using JCL Facilities from the Command Line
Related information
cassi (JCL version)


Submitting JCL Jobs

You use the command cassub to submit a JCL job from the command line to an enterprise server running either on your own machine or a remote machine.

For a full definition of cassub see the topic cassub.

  • Submitting to a Local Machine
  • Submitting to a Remote Machine
Parent topic: Using JCL Facilities from the Command Line


Submitting to a Local Machine

Before you use cassub to submit a JCL job on your machine, you must already have started the enterprise server using casstart.

If the enterprise server does not have a batch initiator SEP defined that handles jobs of the same class as the job you want to submit, you must also start a suitable batch initiator SEP using the command cassi.

For example:

casstart -rjcldemo
cassub -jC:\users\user-ID\documents\Micro Focus\Enterprise Developer\WORKAREA\jcldemo\esjcl\esjcl.jcl -rjcldemo

This submits the JCL in the file C:\users\user-ID\documents\Micro Focus\Enterprise Developer\WORKAREA\jcldemo\esjcl\esjcl.jcl to the enterprise server jcldemo.

Parent topic: Submitting JCL Jobs


Submitting to a Remote Machine

Before you use cassub to submit a JCL job to a remote machine, you must find out the address of the Web Services listener associated with the service MF JES. To do this:

  1. Open ES Admin for the remote machine.
  2. On the Home page of ES Admin click Details next to Services in the Objects column for the server that you want to submit a job to.
  3. Note the address of the listener for the service with a service class of MF JES.

You then specify this address using the -s parameter of cassub. For example:

cassub -jc:\program files\micro focus\Studio Enterprise Edition X.X\base\workarea\jcldemo\esjcl\esjcl.jcl -stcp:192.168.1.102:2811

This submits the JCL in the file %USERPROFILE%\Documents\Micro Focus\Net Express x.x\WORKAREA \jcldemo\esjcl\esjcl.jcl on your machine to an enterprise server running on a remote machine. The enterprise server must already have been started.

You can verify that you have successfully submitted the job by using the ESMAC Log feature: click Log in the Diagnostics group of the menu, and then click Display. You will be able to see messages relating to the job submission.

You can view the remote machine's spool queues and catalog entries in the usual way.

  • To View and Use Remote Directory Server Instances
Parent topic: Submitting JCL Jobs
Related information
To view and use remote Directory Server instances


Interacting with JCL Jobs

You can run jobs on an enterprise server that include ACCEPT FROM CONSOLE and DISPLAY UPON CONSOLE statements. When execution reaches a DISPLAY UPON CONSOLE statement, the display text is displayed in the console log and the job log, and the job continues. When execution reaches an ACCEPT FROM CONSOLE statement, the job pauses and asks for input using pages in ESMAC.

There is also a facility for replying to ACCEPT FROM CONSOLE statements in basic ESMAC for running Web services, and this is available to JCL jobs. For more information see the sectiion Interacting with Services in the chapter Administering Servers Using ESMAC in your Configuration and Administration Guide.

  • To reply to an ACCEPT FROM CONSOLE statement
Parent topic: Administering JCL-enabled Enterprise Servers
Related information
To reply to an ACCEPT FROM CONSOLE statement


Character Sets

Migrated JCL applications used to run on the mainframe using the EBCDIC character set. However, the native character set on Windows and UNIX machines is ASCII. On Enterprise Server you can continue to run JCL applications in EBCDIC if you wish, or you can run them in ASCII. There are both program and data considerations.

  • Programs
  • Data
Parent topic: Administering JCL-enabled Enterprise Servers


Programs

The default mode for an enterprise server is ASCII, since Windows, like UNIX, is an ASCII environment. Programs can be run in EBCDIC as long as they have been compiled using directive CHARSET"EBCDIC". At the beginning of a program execution, that is, the execution of a program invoked by the CALL command, the RUN sub-command (of DSN), or by a job step (PGM=), the JCL engine detects the character set of the program. The character set of the program remains constant throughout its execution.

Steps in a JCL job stream can use different character sets. But if a program initiated by a job step then calls another program, it's up to the programmer to make sure that the character sets used by the programs are compatible (for example for call parameters) or that they handle any incompatibilities themselves.

Parent topic: Character Sets


Data

The programmer needs to ensure that any data files they read are in the character set that matches the program. The File Handler will issue an abend if it is asked to open a file whose catalog entry has a different character set from the character set of the program.

In-stream data and line sequential files are automatically converted to match the mode of the application program. Data in all other files is not converted.

All data presented to or exchanged with the program is either ASCII or EBCDIC depending on the character set of the program. Conversions are done as appropriate. This includes data in MVS control blocks.

Pointer data is native unless AMODE is in effect, in which case, it is big-endian (network order). This includes data in MVS control blocks.

Binary data is always big-endian. This includes data in MVS control blocks.

Parent topic: Character Sets


z/OS Enterprise Server Extensions

Server Enterprise Edition provides extensions to several MVS features. These extensions can be added to existing source and can remain there since they are treated as comments by the host operating system.

You write the extensions as comments, so that if you move your JCL or IDCAMS back to the mainframe they are ignored. The start of the Micro Focus extensions within a comment is indicated by the four-character string “MFE:”. Extensions are identified by keywords. These keywords begin with the % sign, to avoid any possible conflict with z/OS keywords.

There is no change to standard JCL or IDCAMS comments.

  • JCL Extensions
    Describes JCL extensions as used with Server Enterprise Edition.
  • IDCAMS Extensions
    Describes the extensions Server Enterprise Edition provides to the IDCAMS command language.
Parent topic: JCL Support


JCL Extensions

Describes JCL extensions as used with Server Enterprise Edition.

Syntax:

//*MFE: {keyword=value}[...]

Syntax Rules:

  1. //*MFE: must be coded in columns 1 through 7
  2. Keywords must start in column 8 or after
  3. All extension keywords begin with the % sign

General Rules:

  1. Code each extension on a line following the last line of the entire JCL statement to which it applies.
  2. All other JCL syntax rules apply.

Parameters:

keyword=value Specify an extension keyword and value. All extension keywords must begin with the % (percent) character.

Example:

//STEP1    EXEC PGM=MYPROG,REGION=1024K,
//              ACCT=(‘ACCOUNT INFO’),
//              PARM=’parameter string’
//*MFE:         %TYPEXEC=HOST,%SOMEOTHER=SOMEVAL
//*MFE:         %ANOTHER=VAL

In this example, three extension keywords apply to the EXEC statement and follow the complete statement. %TYPEXEC, %SOMEOTHR, and %ANOTHER are extension keywords.

  • JOB Statement Extensions
    Lists each JOB statement extension and provides a description of each.
  • DD Statement Extensions
    Lists each DD statement extension and provides a description of each.
Parent topic: z/OS Enterprise Server Extensions


JOB Statement Extensions

JOB Statement Extensions
%CATMAINT({Y | N | D} [,partial-dsname]) | Specify whether a catalog maintenance step is automatically generated at job end. It can be used with or without RJSE, and is RJSE independent.
 | Y | Generate a maintenance step at job end. If specified without partial-dsname, the entire catalog is read.
 | N | Do not generate a maintenance step at job end (default)
 | D | Generate a maintenance step at job end, and delete the audit log SYSOUT dataset (becomes DD DUMMY). If specified without partial-dsname, the entire catalog is read.
 | partial-dsname | Specify a partial dataset name. Valid only in combination with Y or D. The catalog maintenance utility looks only at catalog records for datasets that begin with the specified partial-dsname value, thus limiting the search. Each selected record is presented to the user exit (mfcatmntue) as before. In addition to current functions, the exit might, at initialization time, change the partial dataset name and/or the expiry date.
%HLQ =value | RJSE only. Specifies a dataset name High Level Qualifier (HLQ) used for generated dataset names instead of the user ID.
 | value | A high level qualifier up to 8 characters in length. It is not validated for syntax, but should be valid as a z/OS dataset name HLQ.
%MFA ={RJSE | ALL} | Change the setting of the environment variable MF_MFA for the life of this job only.
 | RJSE | Search for datasets in the local catalog only. No mainframe is performed.
 | ALL | Search for datasets first in the local catalog, and if not found, on the mainframe.
 | Note: This keyword is ignored if the environment variable MFASERV is not ON.

Examples:

%CATMAINT Example

%CATMAINT=(Y,MFIDSA.D)
%CATMAINT=D
%CATMAINT=(Y,MFI01.DSA)
//MFIDSAR9 JOB (MFIDSART),CLASS=A,
//             MSGCLASS=X,MSGLEVEL=(1,1),USER=MFIDSA,
//             REGION=0M
//*MFE:%CATMAINT=(Y,MFI01.DSA)

%HLQ Example

%HLQ=MFI01.DA
%HLQ=MFIDSA
%HLQ=PQ.R.S.T
//MFIDSAR9 JOB (MFIDSART),CLASS=A,
//             MSGCLASS=X,MSGLEVEL=(1,1),USER=MFIDSA,
//             REGION=0M
//*MFE:%HLQ=MFI01.DA

%MFA Example

%MFA=RJSE
Parent topic: JCL Extensions
Related reference
JCL-Specific Environment Variables


DD Statement Extensions

Lists each DD statement extension and provides a description of each.
DD Statement Extensions
%PCDSN=pcdatasetname When creating a new dataset, specify a data file on the local PC for a new dataset that you want to associate with the z/OS dataset name.
  • If you omit this parameter, Server Enterprise Edition generates a PC filename automatically.
  • This parameter is valid only with new data sets (i.e., DISP=NEW and DISP=MOD that is new), and is ignored for old data sets (i.e., DISP=OLD, DISP=SHR, DSIP=MOD that is old).
  • If necessary, enclose pcdatasetname in single quotes.
  • If the filename specified for pcdatasetnamecontains spaces, enclose the name in double quotes (").
  • The specified filename cannot exceed 256 characters, including all characters between single quotes and including double quotes that enclose the PC filename.
%UPLOAD={YES | NO | AUTO} | RJSE only.
YES | Upload the dataset referenced by the DD
NO | Do not upload the dataset referenced by the DD
AUTO | Have the system make the determination whether or not to upload the dataset (default)
%DOWNLOAD={YES | NO | AUTO} | RJSE only.
YES | Download the dataset referenced by the DD
NO | Do not download the dataset referenced by the DD
AUTO | Have the system make the determination whether or not to download the dataset (default)
%PDSMEM={ALL | ONLY} | RJSE only.
ALL | Upload or download the entire PDS referenced by the DD
ONLY | Upload or download only the PDS member referenced by the DD
Note: This option is ignored if the dataset is not a PDS.
%CHARSET={EBCDIC | ASCII} RJSE only. Specify the character set for a new dataset. By default, the character set is the same as the character set of the system.
Note: This parameter is for Micro Focus internal use only unless justified otherwise.
%LSEQRECF={V | VB | F | FB} | Specify the appropriate host record format for the uploaded RECFM=LSEQ dataset.
V | Upload as RECFM=V dataset
VB | Upload as RECFM=VB dataset
F | Upload as RECFM=F dataset
FB | Upload as RECFM=FB dataset (default)
Note: We strongly advise that you set LRECL for local LSEQ datasets to a valid value other than 0. When the LRECL value is 0, the system assumes a host dataset LRECL of 80 for F and FB, or 255 for V and VB, and issues a warning message. This could lead to other failures.
%RELATED={[YES | NO | AUTO)} | RJSE only. Specifies whether to move the dataset from one location to another. This must be specified on the DD statement if the same dataset exists on the host as well as the PC. The two datasets with the same name are presumed to be not related to each other and may contain different contents. The host dataset is used only by jobs running on the host and the PC dataset is used only by jobs running locally.
YES | Move the dataset from one location to another
NO | Never move the dataset from one location to another (default)
AUTO | Have the system make the determination whether or not to move the dataset
Important: Causes all other RJSE-related DD parameters to be ignored.

Examples:

%PCDSN Example 1

//NONVSAM  DD DSN=MFIDSA.RJSE.NONVSAM.WITH.SPECIFIC.PCNAME,
//            DISP=(NEW,CATLG),SPACE=(TRK,1),LRECL=80,
//            RECFM=F,DSORG=PS
//*MFE:       %PCDSN='"F:\MX30 JCL SYSTEM\PCFILE.NONVSAM.DAT"'

The specified filename contains spaces and therefore requires double quotes.

%PCDSN Example 2

Assign a PC physical filename to a data set you are creating using JCL:

//SYSUT2   DD DSN=MFIDSA.NONVSAM.WITH.SPECIFIC.PCNAME,
//            DISP=(NEW,CATLG),SPACE=(TRK,1)
//*MFE:       %PCDSN='<CATALOGFOLDER>\MYFILE.NONVSAM.DAT'
  • The string <CATALOGFOLDER>, written exactly as shown, means the folder containing the catalog.
  • The single quotes surrounding the value are required here because the value contains lower-case characters and greater-than and less-than signs (<>) and therefore does not conform to JCL syntax rules.

%PCDSN Example 3

Create a dynamic PDS:

//DD1      DD DSN='TEST.DYN1',DISP=(NEW,CATLG),
//            DCB=(RECFM=FB,LRECL=123,DSORG=PO)
//*MFE:       %PCDSN=C:\DPDS\*.DAT

This creates TEST.DYN1 as a dynamic PDS whose members are files in the directory C:\DPDS with the extension .DAT. The data set organization must be PO.

%UPLOAD, %PDSMEM Example

//STEP1    EXEC PGM=MYPROG,REGION=1024K,
//              ACCT=(‘ACCOUNT INFO’),
//              PARM=’parameter string’
//*MFE:         %UPLOAD=YES,%PDSMEM=ALL

%CHARSET Example

//SYSUT2   DD DSN=MFIDSA.NONVSAM.EBCDIC.DATASET,
//            DISP=(NEW,CATLG),SPACE=(TRK,1)
//*MFE:       %CHARSET=EBCDIC

%TYPEXEC Example

//HOST1    EXEC OGN=HOSTPGM, REGION=1024K,
//              PARM='parameter string'
//*MFE:         %TYPEXEC=HOST

This indicates that this step is to be executed on the host system.

%RELATED Example

//DEF  DD DSN=MFIDSA.RC.SEQ,DISP=SHR
//*MFE: %RELATED=NO
Parent topic: JCL Extensions


IDCAMS Extensions

Describes the extensions Server Enterprise Edition provides to the IDCAMS command language.

Syntax:

;MFE: {keyword(value)[,...]

General Rules:

  1. Code each extension on a line by itself following the last semicolon (;) that terminates the command to which it applies. If the command does not end with a semicolon, then add a semicolon.
  2. The value of the extension keyword follows normal IDCAMS rules for use of quotes, special characters, continuations, etc.

Parameters:

keyword(value) Specify an extension keyword and value. All extension keywords must begin with the % (percent) character.

Example:

DEFINE CLUSTER(NAME(MFIDSA.RJSE.VSAMKSDS.WITH.SPECIFIC.PCNAME ) -
        TRK(1 1) -
        ;MFE:%PCDSN -
         ('"F:\MX30 JCL SYSTEM\PCFILE.VSAMKSDS.DAT"')
  • DEFINE Statement Extensions
    Lists each DEFINE statement extension and provides a description of each.
Parent topic: z/OS Enterprise Server Extensions


DEFINE Statement Extensions

Lists each DEFINE statement extension and provides a description of each.
DEFINE Command Extensions
%PCDSN(pcdatasetname) Specify a data file on the local PC for a new dataset that you want to associate with the z/OS dataset referenced in the DEFINE command.
Note:
  • If you omit this parameter, Server Enterprise Edition generates a PC filename automatically.
  • This parameter is valid only with new datasets and is ignored for old datasets.
  • If z/OS rules dictate, enclose pcdatasetname in single quotes.
  • If the filename specified for pcdatasetnamecontains spaces, enclose the name in double quotes (").
  • The specified filename cannot exceed 256 characters, including all characters between single quotes and including double quotes that enclose the PC filename.
%CHARSET({EBCDIC | ASCII}) Specify the character set for a new dataset. By default, the character set is the same as the character set of the system.
Note: This parameter is for Micro Focus internal use only unless justified otherwise.

Example:

%PCDSN Example

DEFINE CLUSTER(NAME(MFIDSA.RJSE.VSAMKSDS.WITH.SPECIFIC.PCNAME ) -
        TRK(1 1) -
        RECSZ(80 80) KEYS(15 3)) -
        ;MFE:%PCDSN -
         ('"F:\MX30 JCL SYSTEM\ \PCFILE.VSAMKSDS.DAT"')

%PCDSN Example

DEFINE CLUSTER(NAME(MFIDSA.RJSE.VSAMKSDS.WITH.SPECIFIC.PCNAME ) -
        TRK(1 1) -
        ;MFE:%PCDSN -
         ('"F:\MX30 JCL SYSTEM\PCFILE.VSAMKSDS.DAT"')
Parent topic: IDCAMS Extensions


Configuring JCL Timeouts

This chapter describes how you can configure timeouts for JCL jobs.

  • Overview: JCL Timeouts
  • Difference with the TIME= parameter
  • How the timeout is calculated
  • Establishing "Default" and "By Class" timeout values
  • New Messages
  • CTF Tracing/CAS AUX Tracing
Parent topic: JCL Support


Overview: JCL Timeouts

On a Z/OS system, both runaway and looping batch jobs can be controlled by the use of the TIME= parameter. This can operate on the JOB card. The TIME= parameter takes the form of: TIME=(x,y) where x is a time value in CPU minutes, and y is a time value in CPU seconds.

The Enterprise Server environment does not recognize the concept of CPU seconds. To allow for this, Enterprise Server includes a mechanism that enables you to configure a value in real seconds to equate to the CPU seconds that are coded in your JCL. Using this mechanism, you can configure a JCL job to abend long running jobs if they take longer than the boundaries you set.

A timeout can only be applied to a job when you have defined a class-specific timeout multiplier and/or a Default multiplier. If no class-specific or Default multiplier has been defined, a multiplier of 1 (one) is used. If multiple initiators are active, and a job is started, and then held awaiting the completion of another job of the same name, the time spent waiting is included in the job's elapsed time, when determining if the job has exceeded it's allotted time span.

Parent topic: Configuring JCL Timeouts


Difference with the TIME= parameter

The following topics illustrate the differences between JCL timeouts and using the TIME= parameter.

  • Abends - S322:
  • Maximum number of actual Seconds
  • Rerun/Recovery method
Parent topic: Configuring JCL Timeouts


Abends - S322:

On a mainframe, a job abends with an S322 abend code when the TIME value has been exceeded on a per job or per step basis.

The method used to end a job is as follows, depending on the platform on which Studio Enterprise Edition is operating:

  • on a Unix environment, all terminations due to timeout are of the "hard kill" variety.
  • on the Win32 platform, the process first attempts a "soft kill." If this is unsuccessful it is immediately followed by a "hard kill".

    on Enterprise Server running on a PC, it is possible that your code is executing in a loop that is so tight that the timing mechanism is unable to break execution to terminate the job gracefully. In this event, it performs a "hard kill" on the process.

For all timeouts, the ESMAC Condition Code associated with the job is an S322. The job termination codes, as shown in the joblog, are either S222 in the event of a successful "soft kill" or nothing in the event of a successful "hard kill" In both cases a message similar to the one below is written to the console.log file:

CASKC6002I JOB10347 terminated due to exceeding TIME parameter 05:01:20

Parent topic: Difference with the TIME= parameter


Maximum number of actual Seconds

The maximum number of "real" seconds that can be used for a timeout value (calculated) for a JOB/STEP is 65533, or approximately 18.2 hours. If the time as calculated exceeds 65533 seconds, then a JES000034E message, as shown below, is issued to the console and the maximum value of 65533 seconds is applied to the job.

JES000034E JOB10348 - TIME parameter exceeds 65533 after applying class multiplier (0100)

Parent topic: Difference with the TIME= parameter


Rerun/Recovery method

On a mainframe, the third dataset disposition (abnormal termination) is always triggered and processed upon receipt of an S322 abend.

In the Enterprise Server environment however , the abnormal dataset disposition processing for an S322 abend is ONLY processed on the Windows Platform and only when a "soft kill" can be issued. If a "hard kill" is required to stop the job, for example on a UNIX platform, then you must treat the dataset dispositions for failing jobstep as "unknown," and reset the datasets accordingly. The DBMS commit/rollback can be used, and will process as expected

You can check the method: soft kill, or hard kill by examining the joblog for the failing job:

  • A joblog entry of S222 (operator cancel) indicates a soft kill, using abnormal dataset disposition processing.
  • If there is no job termination message entries, then the job was terminated with a hard kill.
Parent topic: Difference with the TIME= parameter


How the timeout is calculated

The timeout calculation is made by first attempting to apply a job CLASS-specific multiplier. If this multiplier is not present, the process applies the default setting. If neither is present, then a timeout multiplier of 1 (one) is applied to the job. In the example jobstream below, the job has specified a maximum TIME of 20 seconds of CPU time.

If CLASS=C jobs run with a multiplier of 2, then the job will run for between 40 and 50 seconds before being cancelled automatically by the system. This run time refers to actual execution time only, and does not include the time that the job spends in the INPUT or INPUT HOLD queues.

The Overhead value is a machine-dependant figure that is typically between 6 and 10 real seconds. It can vary in either direction depending upon the machine's workload and CPU speed. Any minutes specified on the JOB card are converted to CPU seconds before calculating.

The timeout is is calculated as follows:

Real Seconds = (TIME * Multiplier) + Overhead

For example, in the code below, the timeout is set for around 40 seconds.

//DMFBR14 JOB 'DMFBR14',CLASS=C,MSGCLASS=A,TIME=(,20)
//**************************************************************
//* Timeout after running for about 40 seconds. (Class C Multipler of 2)
//**************************************************************
//* Copyright (C) 1985-2008 Micro Focus International Ltd.
//* All rights reserved.
//**************************************************************
//*
//* Run one step for about 1 minute
//*
//STEP1 EXEC PGM=INFINITE,PARM='00012'
//SYSOUT DD SYSOUT=*
//SYSPRINT DD SYSOUT=*
//JBSTATUS DD SYSOUT=*,DCB=(LRECL=80,RECFM=FB,DSORG=PS)
//*
Parent topic: Configuring JCL Timeouts
Related information
To define a batch initiator or printer SEP
To start a batch initiator or printer immediately


Establishing "Default" and "By Class" timeout values

The sample jobstream below can be used to display and/or modify the settings used to calculate the number of actual seconds that can elapse before a job is cancelled automatically. In the code below:

  • The first step, LIST01, lists the current settings. These are written to the SYSPRINT DD and viewable via ESMAC in the Output Hold queue entry for the job.
  • .The second step, STEP10, establishes multipliers for classes A, B, C, and D, and sets a default setting of 10. The multiplier values must be 4 digits and can have a range of 0001 to 9999.
//SETMULT JOB 'SETMULT',CLASS=A,MSGCLASS=X,NOTIFY=MFIDMF
//*
//* List out all the values contained in jesinfo.dat
//*
//LIST01 EXEC PGM=MVSP0036,PARM='LIST'
//SYSOUT DD SYSOUT=*
//SYSPRINT DD SYSOUT=*,HOLD=Y
//SYSIN DD *
/*
//*
//* Set the values in jesinfo.dat for TIME= multipliers
//* as a default and on a class by class basis.
//* The multipliers are used in an attempt to equate CPU Seconds
//* to "real" seconds.
//*
//STEP10 EXEC PGM=MVSP0036,PARM='JESMULTIPLIER'
//SYSOUT DD SYSOUT=*
//SYSPRINT DD SYSOUT=*,HOLD=Y
//SYSIN DD *
DEFAULT(0010)
A(0009)
B(0004)
C(0002)
D(0100)
/*

Note the following:

  • The JESINFO.DAT file should not be manually edited. Its contents should only be updated via the MVSP0036 utility.
  • The JESINFO.DAT is in the same location as your catalog file, typically catalog.dat.
  • The settings in JESINFO.DAT are specific to an Enterprise Server region. These settings should not be shared among multiple servers.
Parent topic: Configuring JCL Timeouts
Related information
To view resource locks


New Messages

This functionality generates the following messages:

  • CASKC6002I JOBnnnnn terminated due to exceeding TIME parameter
  • JES000034E JOBnnnnn - TIME parameter exceeds 65533 after applying class multiplier (nnnn)

Parent topic: Configuring JCL Timeouts


CTF Tracing/CAS AUX Tracing

The following tracing functionality has been added:

  • The DISP property of mf.mvs.casspool ctf tracing has been enhanced to show the calculation for adjusted timeouts.
  • A trace has been added to the CAS Aux tracing for jobs that terminate due to a timeout. This trace is from the casmgr process, and shows the name of the job that timed out.
Parent topic: Configuring JCL Timeouts


JCL Aspects of Troubleshooting

This chapter covers some aspects of troubleshooting problems with running JCL applications in an MSS-enabled enterprise server.

  • Introduction
  • Consolidated Tracing Facility
  • MVSJOBNO
Parent topic: JCL Support


Introduction

Problem diagnosis on a JCL-enabled enterprise server is very similar to problem diagnosis on an enterprise server running Web services or EJB-type services, as described in the chapter Troubleshooting in the Enterprise Server Configuration and Administration Guide.

Parent topic: JCL Aspects of Troubleshooting


Consolidated Tracing Facility

The Consolidated Tracing Facility (CTF) allows you to produce diagnostic information detailing the operation of Micro Focus software components and your own programs.

Parent topic: JCL Aspects of Troubleshooting
Related information
Introduction to the Consolidated Tracing Facility


MVSJOBNO

If you get MVSJOBNO I/O error 42, delete the file mvsjobds.dat, which you will find in the same directory as your catalog, and then try the failed operation again.

Parent topic: JCL Aspects of Troubleshooting


Using Fileshare

  • Using Enterprise Server with Fileshare
  • Using Fileshare - More Features
  • Fileshare - Further Details
Parent topic: MSS Configuration and Administration


Using Enterprise Server with Fileshare

This Part describes how to configure an enterprise server so that I/O for CICS- or JCL-related files is handled by a Fileshare server. The major reason for doing this is that it provides transactional VSAM file access for CICS-related files. This Part covers only stand-alone Fileshare servers. A stand-alone Fileshare server is one that you run separately from Enterprise Server, by running fs.exe. Enterprise Server's built-in Fileshare server is not recommended for this use.This chapter is intended to help you get up and running quickly. After a brief overview and an outline of the main points of configuration, it walks you through a typical configuration. The chapter Using Fileshare - More Features gives brief introductions to other useful and important aspects. The chapter Fileshare - Further Details goes into more detail.

  • Overview
  • Details of Configuration
  • Walkthrough
Parent topic: Using Fileshare


Overview

Fileshare is a client/server file handler, supplied as part of Enterprise Server. When you configure an enterprise server to use Fileshare, you are making the enterprise server a Fileshare client, so that some or all file I/O requests coming from applications running in that enterprise server will be handled by a Fileshare server.

You can configure some or all files that are accessed from CICS applications to be accessed via Fileshare. You can also configure files accessed by JCL, and even the catalog itself, to be accessed via Fileshare, if you wish. However, the major benefit of Fileshare is when used with CICS.

Although its name implies file sharing, the primary reason for using Fileshare is to support transactional access to data files using the COMMIT and ROLLBACK verbs or EXEC CICS SYNCPOINT when using CICS. Without it, there is no transactional behavior in CICS. Fileshare also provides rollforward recovery to ensure the integrity of your files in the event of a system failure.

  • Transactional VSAM Access
  • Configuration
Parent topic: Using Enterprise Server with Fileshare


Transactional VSAM Access

On an IBM mainframe, when a CICS application accesses a VSAM dataset, the access is transactional. This means that CICS, acting as a Transaction Manager (TM), ensures that the updates to the VSAM dataset are committed or rolled back as appropriate. The application can control the transaction boundaries with explicit EXEC CICS SYNCPOINT commands, and CICS implicitly controls the transaction at end of task.

In Mainframe Subsystem Support, CICS provides VSAM emulation but does not provide transactional access to these resources. Fileshare does provide such access. Mainframe Subsystem Support acts as the TM and uses Fileshare's Resource Manager (RM) to provide behavior compatible with mainframe CICS.

No changes to your program source are needed to take advantage of Fileshare. If a resource definition indicates that a resource uses Fileshare, the default configuration provides backward recovery for that resource. This means that if an application explicitly backs out updates to a VSAM dataset, or CICS rolls back an update because of an application failure, Fileshare ensures that the dataset is returned to a consistent state.

If a file is accessed only from JCL, not CICS, then there is no advantage in using Fileshare for it. However, if it is accessed by both, and you configure it to use Fileshare for the sake of transactional VSAM access, then Fileshare is used for all accesses to it, whether from CICS or JCL. The later chapter Using Fileshare - More Features describes how to handle potential conflicts between accesses from CICS and JCL.

Parent topic: Overview


Configuration

You need to configure both the enterprise server and the Fileshare server:

  • You configure the Fileshare server by parameters on the command line when you start it.
  • You specify via ES Admin and ESMAC which files are to be accessed via Fileshare. You can:
    • Configure an individual file to be accessed via Fileshare.
    • Configure all files to be accessed via Fileshare.
    • Configure the catalog itself to be accessed via Fileshare.

Sections in this chapter cover these topics in detail. The final section is a walkthrough of a typical configuration.

Parent topic: Overview


Details of Configuration

This section briefly summarizes what you need to do. A later section walks you through a typical example.

  • Start a Fileshare Server
  • Configure Which Files to Access via Fileshare
Parent topic: Using Enterprise Server with Fileshare


Start a Fileshare Server

You start the Fileshare server from an application command prompt, in the directory where you want the files it manages to reside. We'll call this the Fileshare directory. When you later configure your enterprise server, you can specify subdirectories of this directory for particular files.

You start it using the command:

start fs /s fs-server-name

or, if you want tracing:

start fs /s fs-server-name /tr f

A Fileshare console window opens. If you specified /tr f, the trace is written to this window and also to a file called fsscreen.lst in your Fileshare directory. You should normally delete fsscreen.lst before starting a Fileshare server, or your new trace output will be concatenated to whatever is currently in the file, which can be confusing when trying to track down problems.

You can turn tracing on or off while Fileshare is running, by pressing F2.

You should not normally use tr f in production, as it has a detrimental effect on performance.

Be sure to start your Fileshare server before your enterprise server, so that the Fileshare server is available right from the start to service any I/O requests the enterprise server may send.

To close the Fileshare server, press Esc in the Fileshare console window. You would normally do this only after stopping your enterprise server.

Parent topic: Details of Configuration


Configure Which Files to Access via Fileshare

You need to tell your enterprise server which files are to be accessed via the Fileshare server.

  • Format of the Fileshare Server Name
  • Accessing All Datasets via Fileshare
  • Accessing an Individual Dataset via FiIeshare
  • Dataset Created by a Batch Job
  • Accessing the Catalog via Fileshare
Parent topic: Details of Configuration


Format of the Fileshare Server Name

Remember that a dataset is represented by a physical file on disk, and although the enterprise server can create a default name for the physical file there are various places where you can override this default and specify a name of your own choosing. To specify that a file is to be accessed via Fileshare, you specify the path and filename of the physical file and include in the path the name of the Fileshare server to use.

Wherever you specify the Fileshare server, you precede its name with "$$". For example:

$$server1
Parent topic: Configure Which Files to Access via Fileshare


Accessing All Datasets via Fileshare

You can configure an enterprise server so that all datasets are accessed via Fileshare.

In ES Admin, on the Edit page for the server, on the JES tab, include the name of the Fileshare server in the path for the Default Allocated Dataset Location. You then don't need to specify anything for individual datasets, unless you want to override this.

Changes made on this page are picked up when you next start the enterprise server.

Parent topic: Configure Which Files to Access via Fileshare


Accessing an Individual Dataset via FiIeshare

You can configure an individual dataset to be accessed via Fileshare, or by a specific Fileshare server overriding the one specified in the Default Allocated Dataset Location.

Go to the FCT page for the file (in ESMAC, select Start L on the Resources dropdown list, then click FCT, then click Details by the file), and then:

  • If the FCT entry is not linked to a catalog entry (there is no check mark by Use Catalog), look at the group of fields provided for specifying a physical filename to override the default location. Enter the name of the Fileshare server in the Fileshare Server field.
  • If the FCT entry is linked to a catalog entry, go to the Catalog page for the file (select JES on the Resources dropdown list, click Catalog, then click Details by the file) - you see a Physical File field provided for specifying a physical filename to override the default location. Include the name of the Fileshare server in the path/filename you specify here.

    (Because JCL does not need transactional VSAM access, the catalog page does not have an explicit Fileshare Server field as the FCT entry does. However, simply including the Fileshare server name in the path in the Physical File field does as well.)

Note that the FCT page has check boxes called Backward Recovery and Forward Recovery. These are for use with integrated Fileshare, and are not relevant to stand-alone Fileshare.

In a similar way, you can specify that an extrapartition transient data file is to be accessed via Fileshare, by naming a Fileshare server on the file's DCT page in ESMAC. Also, the SIT page in ESMAC has four fields where you can specify that temporary storage queues (recoverable and non-recoverable) and intrapartition transient data files (recoverable and non-recoverable) are to be accessed via Fileshare.

Parent topic: Configure Which Files to Access via Fileshare


Dataset Created by a Batch Job

You can specify that an individual file created by JCL or IDCAMS is to be accessed via Fileshare, or by a specific Fileshare server overriding the one specified in the Default Allocated Dataset Location.

In the DD or DEFINE command that creates it, use the extension %PCDSN (see the chapter Extensions to JCL and IDCAMS ) to specify a physical filename to override the default location - include the name of the Fileshare server in the path/filename you specify here.

Parent topic: Configure Which Files to Access via Fileshare


Accessing the Catalog via Fileshare

You can configure an enterprise server so that the catalog itself is accessed via Fileshare.

In ES Admin, on the Edit page for the server, on the JES tab, include the name of the Fileshare server in the path for the System Catalog.

This also causes the spool files to be accessed via Fileshare.

Changes made on this page are picked up when you next start the enterprise server.

In the real world you would probably not put system files such as the catalog under the control of Fileshare, since accesses to these are managed by enterprise server and it would not bring any advantage, just the additional overhead of Fileshare communications.

Parent topic: Configure Which Files to Access via Fileshare


Walkthrough

The configuration you create in this walkthrough makes all I/O for applications running in your enterprise server go via a Fileshare server.

  • Configure the Fileshare Server
  • Add an Enterprise Server
  • Configure All Datasets to go via Fileshare
  • Run a JCL Job
Parent topic: Using Enterprise Server with Fileshare


Configure the Fileshare Server

In this walkthrough, we'll assume your Fileshare server runs on the same machine as your enterprise server. We'll create a directory to use as the Fileshare directory. Within this, we'll create a subdirectory to contain the the user files created and accessed by applications.

  1. Start an application command prompt.
  2. Create directory c:\fsdir and then within it create subdirectory datasets.
  3. Change into the directory c:\fsdir, and enter:
    start fs /s server1

    This starts a Fileshare server named server1.

    The Fileshare console window appears, as shown below.

    Fileshare console window

    If you have the ES Admin home page visible at this point, you may notice that an entry appears for SERVER1. This is because Fileshare is implemented using Micro Focus's Common Communications Interface (CCI), and a Fileshare server is an example of a CCI server. ES Admin shows CCI servers as well as enterprise servers. The current status is shown as Registered.

Parent topic: Walkthrough


Add an Enterprise Server

We will create a new enterprise server to use for this walkthrough. You could alternatively apply your changes to an existing enterprise server.

  1. On the ES Admin home page, click Add.
  2. Enter FSDEMO as the name for the new server, and click Next.
  3. Select Micro Focus Enterprise Server with Mainframe Subsystem Support to make it MSS-enabled. Click Next.
  4. Click Add.
Parent topic: Walkthrough


Configure All Datasets to go via Fileshare

We next configure this enterprise server to send all I/O requests for all datasets accessed by applications running in it to the Fileshare server.

  1. On the ES Admin home page, click Edit next to FSDEMO.
  2. Click the MSS tab and make sure the check box "Mainframe Subsystem Support enabled is checked. Click OK.
  3. Click the JES tab.

    Select the checkbox Job Entry Subsystem enabled.

  4. In the four fields on this page, you enter filenames and paths as described in the chapter JCL Walkthrough:
    1. In the JES Program Path, System Catalog and System Procedure Library fields, enter the usual values for your installation. (If you want to use the values used in the chapter JCL Walkthrough, they are in the section Configuring Program Paths in that chapter.)
    2. In the Default Allocated Dataset Location field, you use the $$ format to specify the name of the Fileshare server to use, followed by the name of the subdirectory you created above. Type:
      \$\$server1\datasets
  5. Click OK.
  6. Click OK.
  7. You now need to start FSDEMO. You will find steps in the next section more convenient if you start it from the command line rather than from ES Admin. So, in your application command prompt, enter:
    casstart /rFSDEMO
Parent topic: Walkthrough


Run a JCL Job

Important: If you are using Microsoft Internet Explorer's Enhanced Security Configuration feature you must disable it before following this procedure. For example:
  1. Close all instances of Internet Explorer.
  2. Select Start > Administrative Tools > Server Manager. If a User Account Control dialog box appears, click Continue.
  3. Under Security Summary, choose Configure IE ESC.
  4. Make sure both Administrators and Users are not selected.
  5. Click OK.

Now that your Fileshare server server1 and your enterprise server FSDEMO are both running, we will run a simple JCL jobstream to verify that new datasets are created correctly and that everything is working.

  1. We will run iefbr14.jcl, supplied in the directory Examples\Studio Enterprise Edition IDE\ESFS\ESFS. For convenience, copy it to c:\fsdir.

  2. Because you used the casstart command to start FSDEMO, you can submit the JCL from the Studio Enterprise Edition command line. In your c:\fsdir directory, enter:

    cassub -rFSDEMO -jc:\fsdir\iefbr14.jcl

    If you had started FSDEMO via ES Admin, you would have had to submit the JCL using the JES Control page in ESMAC.

    The job is parsed and then waits for a batch initiator to run it.

  3. In ES Admin, click Details in the Current Status column of FSDEMO, and then click ES Monitor and Control.
  4. With JES selected in the Resources dropdown list, click Control to display the JES Control page.
  5. Type A in the Classes field and click Start to start a class A initiator.

    The JCL job runs.

  6. Click Spool to display the JES Spool page and click the Output radio button. You should see something similar to the following:

  7. Put a check mark by the "DMFBR14" line and click Display to display the details for the DMFBR14 jobstream, as follows:

  8. Click Details next to the SYSLOG.

    You should see something similiar to the following. Note how the Physical File field is qualified using the Fileshare server name.

  9. Click Display.

    You should see the joblog displayed below. The PC filenames have now been resolved to be qualified by the Fileshare server name. ($$SERVER1).

  10. Now click Back and then click Catalog to display the JES Catalog page. The click Details by the entry for the newly created dataset DMF.TEST.DSN.

    Catalog Entry for Created Dataset

You have now verified that everything is configured and working.

Parent topic: Walkthrough


Using Fileshare - More Features

This chapter describes various features and aspects of behavior that will often be useful when configuring an enterprise server to use Fileshare.

  • Files Accessed by Both CICS and JCL
  • Bulk Update of Catalog
  • FSView
  • Performance
  • Configuration File
  • Installing Fileshare as a Service
  • Walkthrough
Parent topic: Using Fileshare


Files Accessed by Both CICS and JCL

If a batch job needs exclusive access to a dataset that is also accessed by CICS, then the dataset must be closed and disabled before the batch job can run. The batch job waits until this has been done before executing.

If the batch job does not require exclusive access, there is no problem - it can access the dataset at the same time as CICS.

You can use the casfile command to close and disable a dataset, and to open and enable it again after the batch job has finished with it. You call casfile from the application command prompt. You could call it indirectly from within a JCL jobstream, by writing a simple COBOL program to call it and then calling the COBOL program from the jobstream.

Here are some examples of casfile, showing its most important parameters. See casfile for full details.

To close and disable a file called payroll in an enterprise server called FSDEMO, enter:

casfile -rFSDEMO -oc -ed –dPAYROLL

Where:

  • -oc means set the Open status to "closed"
  • -ed means set the Enable status to "disabled"
  • the -d parameter gives the dataset name as shown in the FCT.

To open and enable the same file, enter:

casfile -rFSDEMO -oo -ee –dPAYROLL

Where:

  • -oo means set the Open status to "open"
    Note: Note:

    This sets the status to open, but the file is not physically opened until it is first accessed.

  • -ee means set the Enable status to "enabled"

You can call casfile from a COBOL program via x"91" function 35 (not on UNIX), CBL_EXEC_RUN_UNIT or simply by CALL "CASFILE" using ..., where the input consists of a string containing the options that you use on the command line prefixed with its length, as indicated below.

01  lk-cmd-line.
        05  lk-cmd-len                pic x(02) comp-x.
        05  lk-cmd-data               pic x(1024).

A return code of 0 indicates success. Any other value indicates an error.

Parent topic: Using Fileshare - More Features


Bulk Update of Catalog

If you move a number of datasets from one place on your PC or PC network to another - from one directory to another, from one network server to another, or from the control of one Fileshare server to another - you need to make sure each one's catalog entry shows the new path in the physical filename.

If the catalog and the datasets reside together on the same path, there is no problem. By default, paths in the catalog are stored as relative paths (although they are expanded before being displayed), so the relocation of the files is reflected automatically.

However, if the catalog resides in a different location to the data files, you must update the catalog entries. You can update them all in one command, using the utility mvspcrn.exe in a COBOL command environment.

Before running the utility, you must set the environment variables:

  • MFSYSCAT - full path and filename of the catalog to be updated.

  • MFALLOC_LOC - full path of the Default Allocated Dataset Location.

In fact the value in MFALLOC_LOC is ignored, but it must be set. It's good practice to set it to the Default Allocated Dataset Location.

The format of the command line is:

mvspcrn old-string new-string [options]

The options are:

-y Specifies quiet mode - no prompts are given

In each catalog entry where the physical filename (including path) starts with old-string, old-string is replaced by new-string.

If the quiet mode option is not set the utility displays two prompts, asking you to confirm the setting of MFSYSCAT and the parameters, and then updates the catalog.

The parameters are not case sensitive.

The utility does not actually move or rename any files. It only updates their catalog entries.

The utility affects entries for spool files as well as entries for cataloged datasets.

We strongly recommend that you back up your catalog before running this utility. Check that your MFSYSCAT points to the correct catalog.

old-string is compared to the string actually stored in the catalog, so, in the case of a file accessed via a Fileshare server, old-string should start with the Fileshare server name preceded by $$.

  • Examples
Parent topic: Using Fileshare - More Features


Examples

In all these examples, we'll assume your catalog is c:\catalog\catalog.dat.

  • Example 1
  • Example 2
  • Example 3
  • Example 4
  • Example 5
  • Example 5
Parent topic: Bulk Update of Catalog


Example 1

You have a set of datasets in directory c:\datasets and you move them all to e:\datasets. To update the catalog:

set mfsyscat=c:\catalog\catalog.dat
set mfalloc_loc=e:\datasets
mvspcrn c e
Parent topic: Examples


Example 2

You have a set of datasets in directory c:\datasets and you move them all to e:\data. To update the catalog:

set mfsyscat=c:\catalog\catalog.dat
set mfalloc_loc=e:\datasets
mvspcrn c:\datasets e:\data
Parent topic: Examples


Example 3

You have a set of datasets accessed via Fileshare server server1. They are in c:\fsdir\datasets, where c:\fsdir is the Fileshare directory for server1. You do not move the datasets, but you stop the server and restart it with a different name, server2. To update the catalog:

set mfsyscat=c:\catalog\catalog.dat
set mfalloc_loc=$$server1\datasets
mvspcrn $$server1 $$server2
Parent topic: Examples


Example 4

You have a set of datasets accessed via Fileshare server server1. They are in c:\fsdir\datasets, where c:\fsdir is the Fileshare directory for server1. You move the datasets to c:\fs2dir\data, where c:\fs2dir is the Fileshare directory for server2. In future you want to access them via server2. To update the catalog:

set mfsyscat=c:\catalog\catalog.dat
set mfalloc_loc=$$server1\datasets
mvspcrn $$server1\datasets $$server2\data
Parent topic: Examples


Example 5

You have a set of datasets accessed via Fileshare server server1. They are in c:\fsdir\datasets, where c:\fsdir is the Fileshare directory for server1. Those associated with your payroll application all have names beginning payroll, and you move these to c:\fs2dir\data, where c:\fs2dir is the Fileshare directory for server2. In future you want to access these files via server2. To update the catalog:

set mfsyscat=c:\catalog\catalog.dat
set mfalloc_loc=$$server1\datasets
mvspcrn $$server1\datasets\payroll $$server2\data\payroll
Parent topic: Examples


FSView

FSView is a command-line utility for administering Fileshare servers. Entering the command fsview puts you into FSView mode, where you can enter a range of commands..

When you use some of the features described later in this chapter, you cannot control Fileshare interactively from the Fileshare console window. So you need to use FSView instead, most importantly for closing a Fileshare server. This section gives brief instructions on FSView, to enable you to do this.

Fileshare security is off by default. However, to use FSView you must create a password for the special user ID FSVIEW and enter this user ID and password when you connect to your Fileshare server from the FSView utility.

You specify passwords in a password file, containing a password for each user who will be connecting to the Fileshare server. You do this by running a command for each user. The first such command creates the file.

If this file contains more than one entry, specifying this file when starting a Fileshare server turns on security for that server. All clients then have to specify their user IDs and passwords when they connect. However, since for our present purpose we need only create one entry, this does not happen.

  • Walkthrough
Parent topic: Using Fileshare - More Features
Related information
Fileshare Guide


Walkthrough

Here is a brief walkthrough to demonstrate FSView. In the following, you create the password file, start a Fileshare server, and then use the FSView utility to close it.

  1. At an application command prompt, in your Fileshare directory c:\fsdir, enter:
    fs /pf pass.dat /u FSVIEW /pw Meryton

    This creates a password file called pass.dat, containing an entry for the user ID FSVIEW with password Meryton. The contents of this file are encrypted for secrecy.

    User IDs and passwords are case-sensitive.

    Note this call of fs.exe does not start a server, as you have not specified the /s parameter.

  2. Start a Fileshare server, by entering:
    start fs /s server1 /pf pass.dat /sc
  3. At an application command prompt, still in c:\fsdir, enter:
    fsview

    You now see the FSView command prompt.

  4. Give your logon credentials by entering the FSView command:
    admin logon FSVIEW Meryton
  5. To connect FSView to your Fileshare server and send the server your logon credentials, enter:
    server set server1
  6. To close the server, enter the command:
    server shutdown

    The server does not close yet. This command does not take effect until you exit from FSView.

  7. To close FSView, enter:
    exit

    FSView and the Fileshare server both close.

Parent topic: FSView


Performance

There are a number of changes you can make to your Fileshare server to make it run faster.

  • Synchronous Communications
  • Processor Affinity
Parent topic: Using Fileshare - More Features


Synchronous Communications

The Synchronous Communications option can improve performance up to the order of 10 times. You enable this simply by specifying the /sc parameter on the fs.exe command line.

This improves performance greatly but has no impact on the ability of the client (in this case an enterprise server) to interact with the Fileshare server.

However, it means Fileshare polls the keyboard very seldom, so it is impractical to administer Fileshare from the keyboard - for example, you cannot close a Fileshare server by entering Esc. Instead you must use the FSView utility, which is briefly described in the section FSView.

Parent topic: Performance
Related information
FSView


Processor Affinity

If your server machine is a multi-processor machine, you can use a mechanism called processor affinity for fs.exe. You can experiment with this setting via a popup menu accessible from the Process List on the Task Manager. Right-click fs.exe in the process list, and you can then select a context for the process. If you have the Windows Server resource kit installed, it includes a utility called imagecfg which you can use to permanently set processor affinity for a given .exe file.

Parent topic: Performance


Configuration File

You can specify your parameters to fs.exe in a configuration file, as an alternative to the command line.

If you give no parameters on the command line, then fs.exe looks for a configuration file. By default it looks for a file called fs.cfg in the Fileshare directory, that is, the directory where you started fs.exe. You can use the /cf parameter to specify a different path and/or filename.

For example, you could have a configuration file c:\fsdir\fsconf.cfg containing:

/s server1
/tr f

and start your server server1, from your application command prompt, by entering the command:

fs /cf fsconf.cfg

Another example: you could have a configuraiton file c:\fsdir\fs.cfg containing:

/s server1

and start your server by entering:

fs
Parent topic: Using Fileshare - More Features


Installing Fileshare as a Service

You can install Fileshare as a Windows service. You install it by entering:

fsservice -i FS32SEV1 /wd C:\support\FS32\DATA /cf C:\support\FS32\FSAD32.CFG
at an application command prompt, where
FS32SEV1
A unique file name.
wd
The fileshare working directory.
cf
The fully-qualified fileshare server configuration file.
You can then start and stop it from the Windows Control Panel.

You uninstall Fileshare by entering:

fsservice -u

When you run Fileshare as a service, you must use a configuration file to pass your settings, and this file must be called fs.cfg. It must be in your c:\windows\system32 directory if the cf setting is not used.

In your configuration file, you can use the wd setting to specify your Fileshare directory. The wd setting can also be used when installing the service

When Fileshare is running as a service, you do not get a Fileshare console window, so cannot control it interactively via this window. Consequently:

  • You have to use FSView to control Fileshare and therefore must create a password file
  • We strongly recommend that you use sc, since it gives great performance gains, and the only reason for not using it was loss of interactive control.
  • You should specify /tr f in the configuration file if you want tracing, as you cannot use F2.
Parent topic: Using Fileshare - More Features
Related information
FSView


Walkthrough

This example demonstrates several of the features described in this chapter. We'll start a Fileshare server, just as we did in the chapter Using Enterprise Server with Fileshare, but this time we'll use a configuration file, install Fileshare as a Windows service, and enable synchronous communications and tracing.

First make sure you do not have a Fileshare server currently running.

  1. Create file fs.cfg, containing:
    /s server1
/wd c:\fsdir
/pf pass.dat
/sc
/tr f
  2. Save this file to c:\windows\system32.
  3. If you have not already done so (you may have already done this in the Walkthrough in the section FSView), create file pass.dat in your c:\fsdir directory by entering:
    fs /pf pass.dat /u FSVIEW /pw Meryton

    The existence of this password file enables you to use FSView.

  4. To install the Fileshare service. at a command prompt, enter:
    fsservice -i

  5. Click Start > Control Panel > Administrative Tools > Services
  6. Select Micro Focus Fileshare Service and click Start.

    You can also if you wish double-click Micro Focus Fileshare Service and change its Startup Type to Automatic, so that it will start whenever you start Windows.

Parent topic: Using Fileshare - More Features


Fileshare - Further Details

This chapter explains how to set up Fileshare. It covers the following topics:

  • Running a Fileshare Server

  • Setting up an enterprise server as a Fileshare client

You should read the first two chapters in this Using with Fileshare Part before reading this chapter.

For more information about Fileshare and its more advanced features see the Fileshare Guide.

  • Overview
  • Running a Fileshare Server
  • Setting Up an MSS-enabled Enterprise Server as a Fileshare Client
  • Specifying Fileshare Servers in the RDF
Parent topic: Using Fileshare


Overview

Fileshare provides MSS with VSAM data integrity, enabling you to use SYNCPOINT and SYNCPOINT ROLLBACK commands. Fileshare also enables you to access data files on other systems running on the same network as the machine running MSS.

MSS can connect to up to sixteen Fileshare Servers, giving you the option of splitting your data across several machines. You can also run a Fileshare Server as a separate process on the same machine running MSS. This means you can effectively test a network application without a network.

Fileshare Servers can be used for the following MSS resources:

  • Application data files
  • Extrapartition transient data files
  • Intrapartition transient data and temporary storage queues

Fileshare works in a client/server setup, with the Fileshare Server being the server and an MSS-enabled enterprise server being the Fileshare client. The two can communicate with each other over a variety of protocols. The support for these protocols is provided by Micro Focus Common Communications Interface (CCI) modules. You establish the protocols to be used by each server by specifying the appropriate CCI modules when you start the Fileshare Server. Fileshare files can still be accessed by non-MSS applications at the same time.

The remainder of this chapter explains how to set up both the Fileshare Server and the client region to communicate over these protocols.

Parent topic: Fileshare - Further Details


Running a Fileshare Server

Before you try to run a Fileshare Server, you must ensure that Fileshare is available on the server machine.

You must run Fileshare commands from the command prompt.

To start a Fileshare Server, enter the following:

fs /s server-name

where server-name names the server, and corresponds to the ID by which the client region knows the server. The /s parameter is mandatory on each Fileshare command. For a list of valid parameters, see the section Using a Fileshare Server Configuration File.

This command starts a server with the default protocol enabled, and with no password-checking performed when a client tries to access the server. The default protocol is TCP/IP. You can use the /cm switch to explicitly name the protocols to be used. For example:

fs /s fstest /cm ccitc32 /cm ccinb32

In this example, ccitc32 and ccinb32 are the CCI modules required for TCP/IP and NetBIOS, respectively.

The following example starts a server with password-checking applied through the file fs.pwd:

fs /s fstest /cm ccitc32 /pf fs.pwd

The section Using a Fileshare Password File explains how password-checking works.

You can avoid specifying a list of parameters whenever you start the server by creating a Fileshare Server configuration file, as the next section explains.

  • Using a Fileshare Server Configuration File
  • Fileshare Options
  • Using a Fileshare Password File
  • Monitoring Fileshare
  • Stopping a Fileshare Server
Parent topic: Fileshare - Further Details
Related information
Using a Fileshare Server Configuration File
Using a Fileshare Password File


Using a Fileshare Server Configuration File

If you enter the fs command with no parameters, Fileshare looks for a server configuration file named fs.cfg in your current directory.

You can also specify a configuration file of a different name with the /cf option, for example:

fs /cf c:\filesh.cfg

A Fileshare Server configuration file is an ASCII text file that contains one option per line.

Parent topic: Running a Fileshare Server


Fileshare Options

The Fileshare Server configuration file, fs.cfg, contains the Fileshare configuration options described below. Only the /s option is required. The /pf option is strongly recommended, however, as without it you cannot enforce any Fileshare security, although MSS does provide Resource Security Level (RSL) checking.

/s server-name

Specifies that server-name is the name that the Fileshare Server registers on the network. The name specified has to be unique to that Fileshare Server and must correspond to the Fileshare Server ID specified in the enterprise server's Resource Definition Tables. If a Fileshare Server with that name is already registered on the network, an error is returned.

[/d database-reference-file]

Specifies database-reference-file as the name of the database reference file that the Fileshare Server is to use.

/t nnnnnnnn

Sets the transaction processing timeout, in seconds. If the server does not hear from its client in this period, and another client has requested access to records locked as part of the transaction, all files involved in the transaction are rolled back to their original state and all locks are removed.

The default timeout is 60 seconds. You can disable timeout by setting this to 0. The valid values are 0 through 99999999.

[/m record-size]

Specifies the maximum record size that the Fileshare Server processes in kilobytes. The valid values for record-size are 16 through 64. If you specify a value less than 16, the Fileshare Server uses a maximum record size of 16K. If you specify a value greater than 64, the Fileshare Server uses a maximum record size of 64K. if you do not include this option, the Fileshare Server uses a maximum record size of 64K. Setting a lower value than the default value reduces the amount of memory that the Fileshare Server needs to run.

/cm cci-protocol

Specifies cci-protocol as one of the CCI communications protocols that the Fileshare Server can use to receive communications from a Fileshare Client. Repeat this option for every communications protocol that you want to use to contact this Fileshare Server. Valid values for cci-protocol are:

  • CCITC32 for TCP/IP
  • CCINB32 for NetBIOS
  • CCIIX32 for IPX

If you do not specify any entries, the default is CCITC32.

[/cf configuration-file]

Specifies the name of the Fileshare Server configuration file. Use this option only on the command line. When using this option, you must specify the required Fileshare Server options in the configuration file. If you do not specify a name for the configuration file, it defaults to fs.cfg in the Fileshare Server's current directory.

/pf password-file

Names the password file used by this server. This option activates the Fileshare Password system. If you do not use this option, the Fileshare Server runs without security enabled.

[/tr f]

Specifies that the Fileshare Server trace option is activated as soon as the Fileshare Server starts. The trace echoes to the screen and a file called fsscreen.lst in the Fileshare Server's current directory. This option seriously impacts the Fileshare Server's performance. Use it only for problem investigation.

Examples

Assume the file fs.cfg contains the following lines:

/s fsserv1
/cm ccitc32
/cm ccinb32
/pf serv1.pwd

If you enter the command:

fs

Fileshare reads fs.cfg and starts a server named FSSERV1, with the TCP/IP and NetBIOS protocols enabled. It uses the file serv1.pwd for password security.

Parent topic: Running a Fileshare Server


Using a Fileshare Password File

A Fileshare Server uses its password file to verify that a client enterprise server is entitled to access its files. Although Fileshare can run without a password file, you must use one if you want to apply any security through the Fileshare Server itself. This is strongly recommended, since Fileshare has access to all the files on your system.

The Fileshare Server uses its password file only when the enterprise server makes its first attempt at access (that is, when it starts up). File-level security is controlled by MSS itself, through the resource definitions you make.

The only way to maintain a password file is through this command line:

fs /pf pwd-filename options

Depending on the options you specify, Fileshare creates, modifies, or deletes pwd-filename. You can name the password file whatever you want, but it must correspond to the name you specify with the /pf option when configuring the Fileshare Server.

The options are as follows:

/u username | The user name used by the enterprise server to log onto the server. (This must correspond to the value specified in the FS user name field in the enterprise server's SIT.) Can be up to 20 characters.
/pw password | The enterprise server's password. (This must correspond to what is specified in the FS password field in the enterprise server's SIT.) Can be up to 20 characters.
/e | Erases the specified user from the password file. You must specify both the /u and /pw options on the same command line when you are using /e. If you delete all the entries in the password file, the Fileshare server deletes it.
Note: Note:

Both passwords and user names are case-sensitive.

Examples

Assume no password file exists, and you want to create one with two entries. The following commands:

fs /pf fssecu.pwd /u mtoServ1 /pw fspass1
fs /pf fssecu.pwd /u mtoserv2 /pw fspass2

result in the password file fssecu.pwd being created, with entries for both mtoserv1 and mtoserv2. The mtoserv1/fspass1 and mtoserv2/fspass2 combinations must correspond to FS username and FS password fields in the enterprise servers' SIT.

To put password checking into effect on a Fileshare Server called FSSERV (for example), you must use the /pf option when starting it:

fs /s fsserv /cm ccitcp /pf fssecu.pwd

To disable mtoserv2's access to this Fileshare Server, use the following command:

fs /pf fssecu.pwd /e /u mtoserv2 /pw fspass2

If you now enter this command:

fs /pf fssecu.pwd /e /u mtoserv1 /pw fspass1

Fileshare removes the entry for mtoserv1, and deletes the file fssecu.pwd.

Parent topic: Running a Fileshare Server


Monitoring Fileshare

You can monitor the activity on a Fileshare Server by pressing F2 from the same session in which you started the server. This turns on Fileshare's trace facility, which displays file requests as they occur. For each request, you see the user identifier, opcode, requested filename, and file status bytes of the reply to the user.

You should use this facility only as a diagnostic aid, since it can degrade performance. Press F2 again to turn it off.

Parent topic: Running a Fileshare Server


Stopping a Fileshare Server

Before stopping a Fileshare Server, you must either stop all enterprise servers connected to it or make sure that all the files held on Fileshare servers are closed..

To stop a Fileshare Server locally, go to the session from which you started it, and press the Esc key. You see the prompt:

FS097-I Are you sure you wish to close the Fileshare Server? (Y/N)

Enter Y to continue the shutdown; enter any other key to let the server continue running.

If any database files are open when you reply Y, a second prompt appears:

FS111-I Warning - database files are still open
    Continue with the close (Y/N)?

If you enter Y, Fileshare closes all open files and shuts down. Enter any other key to cancel the shutdown.

Parent topic: Running a Fileshare Server


Setting Up an MSS-enabled Enterprise Server as a Fileshare Client

If you have enabled Fileshare security, you must first give the enterprise server a Fileshare user name and password. These must be specified in the FS user name and FS password fields of the enterprise server's SIT. The enterprise server uses this user name and password combination to log on to all its Fileshare Servers. The combination must appear in the password file for each Fileshare server the enterprise server wants to access.

Next you should name the servers the enterprise server is to connect to. For data files you can have a choice of mechanisms for doing this:

  • Entries in the File Control Table (FCT) of the Resource Definition File (RDF)
  • Entries in the Fileshare client configuration file, fhredir.cfg

For extrapartition transient data queues and intrapartition transient data and temporary storage queues you must name the servers in the RDF. If you do not explicitly name the servers in the RDF, and you have an entry in the fhredir.cfg file that simply names a server (/s servername), then all file requests that do not have an explicit Fileshare server defined will be redirected to the named Fileshare server. If you are running multiple enterprise servers this will cause file contention problems.

Finally, you must specify the protocols over which the region communicates with its servers. You do this in the client configuration file fhredir.cfg.

MSS consults the fhredir.cfg file whenever a region requires a resource from a server. You should not, therefore, change this file while any regions using servers defined by it are running.

For full details of fhredir.cfg entries and examples see the chapters Standard Operation and Configuration in your Fileshare Guide

The next section explains how to specify Fileshare servers in the RDF to enable Fileshare access.

Parent topic: Fileshare - Further Details


Specifying Fileshare Servers in the RDF

Through the Resource Definition File, you can specify that any of the following resources reside on a Fileshare Server:

  • Application data files (through the FCT)
  • Extrapartition transient data queues (through the DCT)
  • Intrapartition transient data and temporary storage queues (through the SIT)

The FCT, DCT, and SIT contain fields for specifying the name of a Fileshare Server. If you fill one of these fields in, MSS looks for the resource on a Fileshare Server.

The FCT fields are on the FCT Details page of ESMAC.

The fields are:

Field | Description
Fileshare Server | The Fileshare Server through which MSS accesses the file. This name must correspond to the name you give the server when you start it. This field is mandatory.
Override Filename | The filename Fileshare uses to find the file. This field is optional. it defaults to the name of the FCT entry.
File Path | The path Fileshare uses to find the file. This field is optional. It must be specified if the path defined by the project does not exist on the Fileshare server machine.
File Extension

Specifies the file extension Fileshare uses to find the file. This field is optional. For indexed files, this results in a filename and its index component as follows:

  • filename.dat

  • filename.idx

The DCT fields are on the DCT Details page of ESMAC.

The fields are:

Field | Description
Fileshare | The Fileshare Server through which MSS accesses the file. This name must correspond to the name you give the server when you start it. This field is mandatory.
File Name

The filename Fileshare uses to find the file. This field is optional. The name defaults to the name of the DCT entry

The path Fileshare uses to find the file. This field is optional. It must be specified if the path defined by the project does not exist on the Fileshare server machine.

Extension

The file extension Fileshare uses to find the file. This field is optional. For indexed files, this results in a filename and its index component as follows:

  • filename.dat

  • filename.idx

In the SIT, there are two sets of fields through which you specify Fileshare Servers for temporary storage and intrapartition transient data queues. You do not have to specify the Fileshare Server and path for each individual queue.

The SIT fields are on the SIT Details page of ESMAC.

There are four sets of the following fields, one each for:

  • Recoverable temporary storage queues
  • Unrecoverable temporary storage queues
  • Recoverable transient data queues
  • Unrecoverable transient data queues

The fields are:

Field | Description
Fileshare Srvr | The Fileshare Server through which MSS accesses the file. This name must correspond to the name you give the server when you start it. This field is mandatory.
Path | The path Fileshare uses to find the file. This field is optional. It must be specified if the path defined by the project does not exist on the Fileshare server machine

Parent topic: Fileshare - Further Details


Running EZASOKET Applications on Enterprise Server

Enterprise Server with Mainframe Subsystem Support can run CICS and JCL applications that use the EZASOKET APIs. Applications use the features provided by these APIs to establish and manage connections, and to exchange data, over TCP/IP networks.

This section describes the support of EZASOKET in Enterprise Server. It does not provide a guide to EZASOKET programming.

For instructions on developing CICS and JCL applications to run on Enterprise Server, please see your Mainframe Subsystem Support Developer's Guide.

  • Introduction
  • Prerequisites
  • Supplied Transactions and Programs
  • Items Omitted from this Release
  • Notes on Individual Functions
  • Configuring and Managing EZASOKET Support for CICS Applications
Parent topic: MSS Configuration and Administration


Introduction

Micro Focus EZASOKET is designed to emulate, as closely as possible, the IBM implementation documented in SC31-8518-01, "OS/390 SecureWay Communications Server: IP CICS Sockets Guide Version 2 Release 8" (1999). It also supports some, though not all, of the features introduced in the z/OS implementation documented in SC31-8807-02, "z/OS Communications Server: IP CICS Sockets Guide Version 1 Release 5" (2004).

However, there are some differences. Micro Focus EZASOKET makes use of the local platform's native TCP/IP support. Due to differences between TCP/IP implementations, there are some circumstances in which Micro Focus EZASOKET does not behave identically to the IBM implementation. These differences are documented in the section Notes on individual functions.

Parent topic: Running EZASOKET Applications on Enterprise Server
Related information
Notes on individual functions


Prerequisites

You must have Studio Enterprise Edition with Mainframe Subsystem Support.

You must ensure that your enterprise server has Mainframe Subsystem Support enabled.

You must specify a suitable SIT for your enterprise server.

To run CICS applications on your enterprise server:

  • You must ensure that you have a TN3270 listener defined
  • You may also need to define the CICS search paths

To use JCL with an enterprise server, you must:

  • Enable JES for the server
  • Define batch initiators and printers for the server

You may also need to define the JES program paths in Enterprise Server Administration.

To ensure 64-bit applications that use EZASOKET work correctly, you must compile these applications with the compiler directive AMODE set.

Note: Beyond the requirements stated above, the support of EZASOKET for JCL does not need any special configuration. EZASOKET CICS support needs additional configuration as described in the section Configuring and managing EZASOKET support for CICS applications.
Parent topic: Running EZASOKET Applications on Enterprise Server
Related information
To enable MTO for an enterprise server
To change the SIT associated with a server
To specify a listener for TN3270 terminals
To configure CICS search paths
To enable JCL support
To define a batch initiator or printer SEP
Configuring and managing EZASOKET support for CICS applications


Supplied Transactions and Programs

This section lists the programs and transactions supplied with Server Enterprise Edition.

  • Standard Transactions and Programs
  • Test Transactions
  • Demonstration Programs
Parent topic: Running EZASOKET Applications on Enterprise Server


Standard Transactions and Programs

For more information on these items, please refer to the IBM document SC31-8807-02, "z/OS Communications Server: IP CICS Sockets Guide Version 1 Release 5".

  • DFHEZA: group containing the EZASOKET definitions for CICS
  • EZAC: transaction to define/alter/display/delete the CICS/Sockets listeners
  • EZAO: transaction to start/stop CICS/Sockets listeners
  • EZACIC20: program used in PLTPI/PLTSD or as a linked program to start/stop CICS/Sockets listeners
  • EZACICSE: (default security exit, ASCII) can be replaced with your own exit
  • EZACIC02: (default listener IPv4) can be replaced by your own listener
  • EZACIC04: EBCDIC to ASCII translation program
  • EZACIC05: ASCII to EBCDIC translation program
  • EZACIC14: EBCDIC to ASCII translation program using a fixed table
  • EZACIC15: ASCII to EBCDIC translation program using a fixed table
  • EZACIC06: Translates bit-masks into character arrays and character arrays into bit-masks
  • EZACIC08: Interprets the variable length address list in the HOSTENT structure returned by GETHOSTBYNAME or GETHOSTBYADDR.
  • EZACIC25: Domain Name Server (DNS) cache module emulation
Parent topic: Supplied Transactions and Programs


Test Transactions

  • EZPI: transaction to test CICS/Sockets listener CSKL is defined properly
  • EZPO: transaction used by EZPI to test CICS/Sockets is defined properly
Parent topic: Supplied Transactions and Programs


Demonstration Programs

  • EZAPING: Client demo program
  • EZAPONG: Server demo program started by EZAPING
Parent topic: Supplied Transactions and Programs


Items Omitted from this Release

The features not available this release are:

  • IPv6 support
  • raw sockets
  • multicasting
  • full support for Out-Of-Band (OOB) data

The following APIs are not available:

  • FREEADDRINFO
  • GETADDRINFO
  • GETNAMEINFO
  • INITAPIX
  • READV
  • RECVMSG
  • SENDMSG
  • WRITEV

The EZACIC09 utility program (which is used with GETADDRINFO) is not included in this release.

The CICS Domain Name System Cache is not included in this implementation. However, the API for it (utility program EZACIC25) is included, so you do not need to change application programs that use the DNS Cache.

WLM (Work Load Manager) registration for listeners is not supported.

Parent topic: Running EZASOKET Applications on Enterprise Server


Notes on Individual Functions

The functions below are available:

  • GETHOSTBYADDR
  • GETHOSTBYNAME
  • GETSOCKNAME
  • GETSOCKOPT
  • GIVESOCKET
  • INITAPI
  • IOCTL
  • SELECT
  • SETSOCKOPT
  • SOCKET
  • TAKESOCKET
  • Security Exit
Parent topic: Running EZASOKET Applications on Enterprise Server


GETHOSTBYADDR

Where a hostname cannot be resolved, the function returns a RETCODE of -1 and null pointer for HOSTENT. This is in line with the behaviour of versions of IBM EZASOKET that were tested. However, the IBM documentation states that, if the hostname cannot be resolved, the function will return a HOSTENT structure containing the error code. The behaviour of this function may change in future releases. We recommend that application programs rely on the RETCODE value to determine whether the call succeeded, and only inspect the HOSTENT structure if RETCODE is 0.

The GETHOSTBYADDR function is not thread-safe.

Because the native name resolution functions used by Micro Focus are not thread-safe, there is a very small possibility of a race condition occurring and of the function returning incorrect data. However, this is significantly less likely than errors elsewhere in the name resolution system, such as a failing DNS server.

Parent topic: Notes on Individual Functions


GETHOSTBYNAME

See GETHOSTBYADDR above.

Parent topic: Notes on Individual Functions


GETSOCKNAME

The IBM documentation states that if GETSOCKNAME is passed a socket that does not have a local address, GETSOCKNAME will return successfully (RETCODE = 0), with the FAMILY field of the NAME parameter set to 2 and the other fields set to 0. The Micro Focus implementation may return an error in this case.

Parent topic: Notes on Individual Functions


GETSOCKOPT

Only the following operations are supported:

  • SO_ACCEPTCONN
  • SO_BROADCAST
  • SO_DEBUG
  • SO_ERROR
  • SO_KEEPALIVE
  • SO_LINGER
  • SO_RCVBUF
  • SO_REUSEADDR
  • SO_SNDBUF
  • SO_TYPE
  • TCP_NODELAY
Parent topic: Notes on Individual Functions


GIVESOCKET

The CLIENT parameter is ignored. That is, this version does not support restricting which tasks can take a socket.

Cross-region GIVESOCKET is not supported.

Parent topic: Notes on Individual Functions


INITAPI

The IDENT and SUBTASK parameters are ignored.

No task may have more than 4096 sockets.

Parent topic: Notes on Individual Functions


IOCTL

Only the FIONBIO and FIONREAD operations are supported.

Parent topic: Notes on Individual Functions


SELECT

The reporting of exception conditions, tested for by use of the ESNDMSK parameter, differs between platforms. This is due to differences between TCP/IP implementations on those platforms.

Where a socket specified with the ESNDMSK parameter has been the subject of a GIVESOCKET, but has not yet been the subject of a TAKESOCKET, SELECT will continue to poll the socket until the TAKESOCKET occurs. In addition, SELECT cannot test sockets which are in this "given" state for normal I/O events.

Parent topic: Notes on Individual Functions


SETSOCKOPT

Only the following operations are supported:

  • SO_BROADCAST
  • SO_DEBUG
  • SO_KEEPALIVE
  • SO_LINGER
  • SO_RCVBUF
  • SO_REUSEADDR
  • SO_SNDBUF
  • TCP_NODELAY
Parent topic: Notes on Individual Functions


SOCKET

The value of the PROTO parameter passed by the caller is ignored.

Only STREAM and DGRAM sockets are supported.

Parent topic: Notes on Individual Functions


TAKESOCKET

Only the TASK field of the CLIENT parameter is used. Other fields are ignored.

See GIVESOCKET above for more information on the limitations of GIVESOCKET and TAKESOCKET in this release.

Note: Note:

If you create your own EZASOKET listener, you must compile it with the directive CALL-RECOVERY.

Parent topic: Notes on Individual Functions


Security Exit

The CICS EZASOKET Security Exit should be compiled with directive charset(ASCII) as all the parameters are expected to be passed in ASCII and returned in ASCII.

Parent topic: Notes on Individual Functions


Configuring and Managing EZASOKET Support for CICS Applications

This assumes that you have already configured your Enterprise Server to run CICS applications as detailed in the chapter CICS Walkthrough in your Mainframe Subsystem Support Developer's Guide. You also need to ensure that you have updated your Resource Definition Files. See the section Updating Existing Resource Definitions in the chapter Configuring Enterprise Edition/MSS of your Server Enterprise Edition Extending CICS and IMS Applications Guide.

  • Enabling EZASOKET Support in Enterprise Server
  • Adding DFHEZA Group to your CICS Startup List
  • Restarting the Enterprise Server
  • Understanding EZASOKET Configuration
  • Using the Configuration Transaction (EZAC)
  • Starting and Stopping the EZASOKET Interface Automatically
  • Starting and Stopping the EZASOKET Interface with a Program Link
  • Starting/Stopping the EZASOKET Interface and Listeners Manually
  • Testing that EZASOKET Support is Correctly Installed and Configured
  • Sockets return codes (ERRNOs)
    The system-wide message numbers and codes set by the system calls.
Parent topic: Running EZASOKET Applications on Enterprise Server


Enabling EZASOKET Support in Enterprise Server

To enable EZASOKET support you must either set the environment variable ES_EZASOKET_SUPPORT=YES or take the following steps:

  1. Connect to Enterprise Server Administration.
  2. In the table of servers on the Home page of Enterprise Server Administration, find the row for the server that you using as your CICS region, and click Edit in the left hand column.
  3. Click Properties > MSS.
  4. Check EZASOKET support.
  5. Click OK.
  6. If the enterprise server is started, please stop it.
  7. Restart the server.
Parent topic: Configuring and Managing EZASOKET Support for CICS Applications
Related information
To access Enterprise Server Administration
To stop an enterprise server
To start an enterprise server


Adding DFHEZA Group to your CICS Startup List

  1. On the Home page of Enterprise Server Administration, click Details in the Current Status column for your enterprise server.
  2. Click ES Monitor & Control.
  3. In the Resources panel, which is about half way down on the left, expand the drop-down list and select by Group.

    The buttons in the Resources panel change to indicate the options for viewing and managing resources by group.

  4. Click StartUp in the Resources panel.
  5. Click Details for your startup list.

    This displays the contents of your startup list.

  6. Type DFHEZA in the first empty field.
  7. Click Apply.
Parent topic: Configuring and Managing EZASOKET Support for CICS Applications


Restarting the Enterprise Server

To make the enterprise server pick up the configuration changes you just made, you have to stop it and restart it.

  1. Stop the enterprise server.
  2. Restart the enterprise server.
Parent topic: Configuring and Managing EZASOKET Support for CICS Applications
Related information
To stop an enterprise server
To start an enterprise server


Understanding EZASOKET Configuration

The EZASOKET configuration file (EZACONFG) contains details of CICS regions (that is, enterprise servers capable of running CICS applications) and the CICS listeners within those regions. The file can be shared by multiple enterprise servers. The location of the file used by your enterprise server is governed by the File Path configuration setting for the server.

For each CICS region that supports EZASOKET and is controlled by the configuration file, there is an associated object (referred to as a CICS object) in the configuration file. The object is identified by the APPLID of the CICS region. There is also a listener object for each listener defined for a CICS region.

The first task you will perform is to use the EZAC transaction to define a CICS object in the configuration file for your CICS region/enterprise server. If the configuration file does not exist, EZAC will create it.

Parent topic: Configuring and Managing EZASOKET Support for CICS Applications


Using the Configuration Transaction (EZAC)

The EZAC transaction enables you to add, delete, or modify items in the configuration file while your CICS region is running. The following table lists and describes the functions supported by the EZAC transaction.

Command | Object | Function
ALTER | CICS/Listener | Modifies the attributes of an existing resource definition
DEFINE | CICS/Listener | Creates a new resource definition
DISPLAY | CICS/Listener | Shows the parameters specified for the CICS/Listener object
DELETE CICS/Listener
  • CICS - Deletes the CICS object and all of its associated listeners
  • Listener - Deletes the listener object

Start a TN3270 session, connect to the port for the TN3270 listener on your enterprise server and start the EZAC transaction. When you enter EZAC, the following screen is displayed:

Figure 1. Initial EZAC screen
Initial EZAC screen

Enter the command you want to execute followed by the type of object. For creating a CICS object for your CICS region, you type:

EZAC DEF CICS or EZAC,DEF,CICS or EZAC,DEFINE,CICS or EZAC DEF and then select CICS on the screen. You are now presented with a screen in which you specify the CICS region for which you are configuring EZASOKET.

Figure 2. EZAC, Define, CICS screen
EZAC, Define, CICS screen

Enter the name of the CICS APPLID for which you are defining configuration information. In this case, the APPLID is the name of your enterprise server. The field defaults to this value.

When you press Enter, the following screen is displayed.

Figure 3. Application parameters screen
Application parameters screen

Specify the parameters you require for EZASOKET support in your CICS region. For more information, please refer to the IBM document SC31-8807-02, "z/OS Communications Server: IP CICS Sockets Guide Version 1 Release 5".

A CICS region will typically have one or more listeners. Each listener may be an instance of the supplied listener or a user-written listener. Define a CICS listener for your region using: EZAC DEF LIST or EZAC DEFINE LISTENER or EZAC,DEF,LIST or EZAC,DEFINE,LISTENER as shown in the following screenshots:

Figure 4. Listener screen
Listener screen

The following screen allows you to define the characteristics of your listener

Figure 5. Listener characteristics screen
Listener characteristics screen

For more information on this topic, please refer to the IBM document SC31-8807-02, "z/OS Communications Server: IP CICS Sockets Guide Version 1 Release 5".

Note:

The supplied transaction used in this example, CSKL, uses the default listener program, EZACIC02. This listener is written in ASCII. The rules described in the table below determine whether or not it converts the transaction id and the user data in the Transaction Initial Message from EBCDIC to ASCII.

TRANTRN | TRANUSR | Tranid format | Translate tranid? | Translate user data?
YES | YES | ASCII | NO | NO
YES | NO | ASCII | NO | NO
NO | YES | ASCII | NO | YES
NO | NO | ASCII | NO | NO
YES | YES | EBCDIC | YES | YES
YES | NO | EBCDIC | YES | NO
NO | YES | EBCDIC | YES | YES
NO | NO | EBCDIC | YES | NO
Parent topic: Configuring and Managing EZASOKET Support for CICS Applications


Starting and Stopping the EZASOKET Interface Automatically

You can enable automatic startup/shutdown of the EZASOKET interface by placing the EZACIC20 module in the appropriate Program List Table (PLT). Listeners that have been defined as IMMEDIATE=YES will then start automatically when the CICS region is started.

  1. On the Home page of Enterprise Server Administration, click Details in the Current Status column for your enterprise server.
  2. Click ES Monitor & Control.
  3. In the Resources panel, which is about half way down on the left, expand the drop-down list and select by Group.

    The buttons in the Resources panel change to indicate the options viewing and managing resources by group.

  4. Click SIT in the Resources panel.
  5. Click Details for your SIT table.
  6. Locate the Program Lists section.
  7. Enter the names you want to use for the Post Initialization and the Shut Down lists. For example:
    Post initialization
  8. Click Apply.

    You now create the program lists as described in the steps below.

  9. In the Resources panel, expand the drop-down list and select by Type.

    The buttons in the Resources panel change to indicate the options for viewing and managing resources by type.

  10. Click PLT in the Resources panel.

    The screen shows a list of CICS defined PLTs. At the bottom of the list is a set of buttons for creating new entries.

  11. Click PLT in the New section of the list.
  12. In Name, enter the name of your Post Initialization list.
  13. Click Grp to expand the drop-down list and select the group you want to use. This group must be defined in your Startup list.
  14. Enter a description in Description.
  15. In the row labelled 01:
    • In the first field, enter EZACIC20.
    • From the drop-down list, choose Run once.

    For example:
    Select group

  16. Click Add to save the new list.
  17. Click PLT in the Resources panel.
  18. Click PLT in the New section of the list.
  19. In Name, enter the name of your Shut Down list.
  20. Click Grp to expand the drop-down list and select the group you want to use. This group must be defined in your Startup list.
  21. Enter a description in Description.
  22. In the row labelled 01:
    • In the first field, enter EZACIC20.
    • From the drop-down list, choose Run once.
  23. Click Add to save the new list.
Parent topic: Configuring and Managing EZASOKET Support for CICS Applications


Starting and Stopping the EZASOKET Interface with a Program Link

You can start or stop the EZASOKET interface by issuing an EXEC CICS LINK to program EZACIC20. Make sure you include the following steps in the LINKing program:

  • Define the COMMAREA for EZACIC20. This can be done by including the EZACICA.CPY copybook in your program.
  • Initialize the COMMAREA values as follows:
    P20TYPE

    I Initialization

    T Immediate Termination

    D Deferred Termination
    P20OBJ

    C CICS EZASOKET interface

    L Listener
    P20LIST

    Name of listener if this is listener initialization/termination.
  • Issue the EXEC CICS LINK to program EZACIC20.
    Note:

    EZACIC20 will not return until the function is complete.

  • Check the P20RET field for the response from EZACIC20.
    Note:

    Note: If the EZASOKET interface is not in startup or termination and no COMMAREA was provided, the E20L user abend code is issued by EZACIC20.

Parent topic: Configuring and Managing EZASOKET Support for CICS Applications


Starting/Stopping the EZASOKET Interface and Listeners Manually

You can start the EZASOKET interface manually by using the EZAO transaction. This transaction has four functions:

  • Interface Startup

    Starts the interface in a CICS region and starts all listeners that are identified for immediate start.

    Note: The EZAO transaction must be running on the CICS region where you want to start the EZASOKET interface. You cannot start an EZASOKET interface from a different CICS.

  • Interface Shutdown

    Stops the interface in a CICS region.

  • Listener Startup

    Starts a listener in a CICS region.

  • Listener Shutdown

    Stops a listener in a CICS region.

You can type EZAO and select the action you require as shown below:

Figure 1. EZAO screen
EZAO screen

and then select the object that you want to act upon:

Figure 2. EZAO, Start
EZAO, Start

Alternatively, you can enter EZAO START|STOP CICS|LISTENER and then respond to the screen prompts as shown in the following examples:

Figure 3. EZAO, START, LISTENER
EZAO, START, LISTENER
Figure 4. EZAO, STOP, LISTENER(CSKL)
EZAO, STOP, LISTENER(CSKL)
Figure 5. EZAO, START, CICS
EZAO, START, CICS
Figure 6. EZAO, STOP, CICS
EZAO, STOP, CICS
Parent topic: Configuring and Managing EZASOKET Support for CICS Applications


Testing that EZASOKET Support is Correctly Installed and Configured

Using the transaction EZAC, alter an existing listener or define a new listener to test the supplied transaction EZPI as show below:

Figure 1. EZAC, ALTER, LISTENER
EZAC, ALTER, LISTENER

You can use any available port, but you must ensure that the fields TRANTRN and TRANUSR are set to NO.

Note:

You cannot use the same TRANID for more than one listener within a CICS region. Therefore, if you want to create a second instance of a listener, you must define a new transaction in a group specified in your startup list. For example, to create a new instance of the default listener, you create a new transaction and associate it with the default listener program, EZACIC02. You then use EZAC to create a new listener definition with the new transaction name as the TRANID.

Start the listener using EZAO. Once the listener has been started and the message EZY1291I appears on the console.log, run the demo transaction EZPI as shown in the examples below:

Figure 2. EZPI
EZPI
Figure 3. EZPI parameters
EZPI parameters

If everything is correctly installed and configured, you will get your message in reverse order in the Received field.

Figure 4. EZPI received
EZPI received
Parent topic: Configuring and Managing EZASOKET Support for CICS Applications


Sockets return codes (ERRNOs)

These message numbers and codes are in the TCPERRNO.H include file supplied with TCP/IP Services.

Error number | Message name | Socket type | Error description | Programmer's response
1 | EAI_NONAME | GETADDRINFO GETNAMEINFO | NODE or HOST cannot be found. | Ensure the NODE or HOST name can be resolved.
1 | EDOM | All | Argument too large. | Check parameter values of the function call.
1 | EPERM | All | Permission is denied. No owner exists. | Check that TPC/IP is still active; check protocol value of socket () call.
1 | EPERM | IOCTL (SIOCTTLSCTL requesting both TTLS_INIT_ CONNECTION and TTLS_RESET_ SESSION or both TTLS_INIT_ CONNECTION and TTLS_RESET_ CIPHER) | The combination of requests specified is not permitted. | Request TTLS_RESET_SESSION and TTLS_RESET_CIPHER only when TTLS_INIT_ CONNECTION has been previously requested for the connection.
1 EPERM IOCTL (SIOCTTLSCTL) Denotes one of the following error conditions:
  • The TTLS_INIT_ CONNECTION option was requested with either TTLS_RESET_ SESSION, TTLS_RESET_ CIPHER or TTLS_STOP_ CONNECTION
  • The TTLS_STOP_ CONNECTION option was requested along with TTLS_RESET_ SESSION or TTLS_RESET_ CIPHER
  • The TTLS_ALLOW_ HSTIMEOUT option was requested without TTLS_INIT_ CONNECTION
Request TTLS_RESET_SESSION and TTLS_RESET_CIPHER only when TTLS_INIT_ CONNECTION and TTLS_STOP_ CONNECTION are not requested. Always request TTLS_INIT_ CONNECTION when TTLS_ALLOW_ HSTIMEOUT is requested. Use seperate SIOCTTLSCTL ioctls to request TTLS_INIT_ CONNECTION and TTLS_STOP_ CONNECTION.
2 | EAI_AGAIN | FREEADDRINFO GETADDRINFO GETNAMEINFO | For GETADDRINFO, NODE could not be resolved within the configured time interval. For GETNAMEINFO, HOST could not be resolved within the configured time interval. The Resolver address space has not been started. The request can be retried later. | Ensure the Resolver is active, then retry the request.
2 | ENOENT | All | The data set or directory was not found. | Check files used by the function call.
2 | ERANGE | All | The result is too large. | Check parameter values of the function call.
3 | EAI_FAIL | FREEADDRINFO GETADDRINFO GETNAMEINFO | This is an unrecoverable error. NODELEN, HOSTLEN, or SERVLEN is incorrect. For FREEADDRINFO, the resolver storage does not exist. | Correct the NODELEN, HOSTLEN, or SERVLEN. Otherwise, call your system administrator.
3 | ESRCH | All | The process was not found. A table entry was not located. | Check parameter values and structures pointed to by the function parameters.
4 | EAI_OVERFLOW | GETNAMEINFO | The output buffer for the host name or service name was too small. | Increase the size of the buffer to 255 characters, which is the maximum size permitted.
4 | EINTR | All | A system call was interrupted. | Check that the socket connection and TCP/IP are still active.
5 | EAI_FAMILY | GETADDRINFO GETNAMEINFO | The AF or the FAMILY is incorrect. | Correct the AF or the FAMILY.
5 | EIO | All | An I/O error occurred. | Check status and contents of source database if this occurred during a file access.
6 | EAI_MEMORY | GETADDRINFO GETNAMEINFO | The resolver cannot obtain storage to process the host name. | Contact your system administrator.
6 | ENXIO | All | The device or driver was not found. | Check status of the device attempting to access.
7 | E2BIG | All | The argument list is too long. | Check the number of function parameters.
7 | EAI_BADFLAGS | GETADDRINFO GETNAMEINFO | FLAGS has an incorrect value. | Correct the FLAGS.
8 | EAI_SERVICE | GETADDRINFO | The SERVICE was not recognized for the specified socket type. | Correct the SERVICE.
8 | ENOEXEC | All | An EXEC format error occurred. | Check that the target module on an exec call is a valid executable module.
9 | EAI_SOCKTYPE | GETADDRINFO | The SOCTYPE was not recognized. | Correct the SOCTYPE.
9 | EBADF | All | An incorrect socket descriptor was specified. | Check socket descriptor value. It might be currently not in use or incorrect.
9 | EBADF | Givesocket | The socket has already been given. The socket domain is not AF_INET or AF_INET6. | Check the validity of function parameters.
9 | EBADF | Select | One of the specified descriptor sets is an incorrect socket descriptor. | Check the validity of function parameters.
9 | EBADF | Takesocket | The socket has already been taken. | Check the validity of function parameters.
9 | EAI_SOCKTYPE | GETADDRINFO | The SOCTYPE was not recognized. | Correct the SOCTYPE.
10 | ECHILD | All | There are no children. | Check if created subtasks still exist.
11 | EAGAIN | All | There are no more processes. | Retry the operation. Data or condition might not be available at this time.
12 | ENOMEM | All | There is not enough storage. | Check the validity of function parameters.
13 | EACCES | All | Permission denied, caller not authorized. | Check access authority of file.
13 | EACCES | Takesocket | The other application (listener) did not give the socket to your application. Permission denied, caller not authorized. | Check access authority of file.
13 | EACCES | IOCTL (SIOCTTLSCTL) | The IOCTL is requesting a function that requires that the socket be mapped to policy that specifies ApplicationControlled On. | Check policy and add ApplicationControlled On if the application should be permitted to issue the controlled SIOCTTLSCTL functions.
14 | EFAULT | All | An incorrect storage address or length was specified. | Check the validity of function parameters.
14 | EFAULT | IOCTL (SIOCSAPPLDATA) | An abend occurred while attempting to copy the SetADcontainer structure from the address provided in the SetAD_ptr field. | Check the validity of function parameters.
15 | ENOTBLK | All | A block device is required. | Check device status and characteristics.
16 | EBUSY | All | Listen has already been called for this socket. Device or file to be accessed is busy. | Check if the device or file is in use.
17 | EEXIST | All | The data set exists. | Remove or rename existing file.
18 | EXDEV | All | This is a cross-device link. A link to a file on another file system was attempted. | Check file permissions.
19 | ENODEV | All | The specified device does not exist. | Check file name and if it exists.
20 | ENOTDIR | All | The specified directory is not a directory. | Use a valid file that is a directory.
21 | EISDIR | All | The specified directory is a directory. | Use a valid file that is not a directory.
22 | EINVAL | All types | An incorrect argument was specified. | Check the validity of function parameters.
22 | EINVAL | Multicast Source filter APIs | Mix of any-source, source-specific or full-state APIs | Specify the correct type of APIs.
22 | EINVAL | MCAST_JOIN_GROUP, MCAST_JOIN_SOURCE_ GROUP, MCAST_BLOCK_SOURCE, MCAST_LEAVE_GROUP, MCAST_LEAVE_SOURCE_ GROUP, MCAST_UNBLOCK_ SOURCE, SIOCGMSFILTER, SIOCSMSFILTER | The socket address family or the socket length of the input multicast group or the source IP address is not correct. | Specify the correct value.
22 | EINVAL | SIOCSMSFILTER, SIOCSIPMSFILTER | The specified filter mode is not correct. | Specify the correct value.
23 | ENFILE | All | Data set table overflow occurred. | Reduce the number of open files.
24 | EMFILE | All | The socket descriptor table is full. | Check the maximum sockets specified in MAXDESC().
25 | ENOTTY | All | An incorrect device call was specified. | Check specified IOCTL() values.
26 | ETXTBSY | All | A text data set is busy. | Check the current use of the file.
27 | EFBIG | All | The specified data set is too large. | Check size of accessed dataset.
28 | ENOSPC | All | There is no space left on the device. | Increase the size of accessed file.
29 | ESPIPE | All | An incorrect seek was attempted. | Check the offset parameter for seek operation.
30 | EROFS | All | The data set system is Read only. | Access data set for read only operation.
31 | EMLINK | All | There are too many links. | Reduce the number of links to the accessed file.
32 | EPIPE | All | The connection is broken. For socket write/send, peer has shut down one or both directions. | Reconnect with the peer.
32 | EPIPE | IOCTL (SIOCTTLSCTL requesting TTLS_INIT_ CONNECTION, TTLS_RESET_CIPHER, or TTLS_STOP_ CONNECTION) | The TCP connection is not in the established state. | Issue the SIOCTTLSCTL IOCTL when the socket is connected.
33 | EDOM | All | The specified argument is too large. | Check and correct function parameters.
34 | ERANGE | All | The result is too large. | Check function parameter values.
35 | EWOULDBLOCK | Accept | The socket is in nonblocking mode and connections are not queued. This is not an error condition. | Reissue Accept().
35 | EWOULDBLOCK | Read Recvfrom | The socket is in nonblocking mode and read data is not available. This is not an error condition. | Issue a select on the socket to determine when data is available to be read or reissue the Read()/Recvfrom().
35 | EWOULDBLOCK | Send Sendto Write | The socket is in nonblocking mode and buffers are not available. | Issue a select on the socket to determine when data is available to be written or reissue the Send(), Sendto(), or Write().
35 | EWOULDBLOCK | IOCTL (SIOCTTLSCTL) | The handshake is in progress and the socket is a non-blocking socket. | For a non-blocking socket, you can wait for the handshake to complete by issuing Select or Poll for Socket Writable.
36 | EINPROGRESS | Connect | The socket is marked nonblocking and the connection cannot be completed immediately. This is not an error condition. | See the Connect() description for possible responses.
36 | EINPROGRESS | IOCTL (SIOCTTLSCTL requesting TTLS_INIT_ CONNECTION or TTLS_STOP_ CONNECTION) | The handshake is already in progress and the socket is a non-blocking socket. | For a non-blocking socket, you can wait for the handshake to complete by issuing Select or Poll for Socket Writable.
37 | EALREADY | Connect | The socket is marked nonblocking and the previous connection has not been completed. | Reissue Connect().
37 | EALREADY | IOCTL (SIOCTTLSCTL requesting TTLS_INIT_ CONNECTION or TTLS_STOP_ CONNECTION) | For TTLS_INIT_ CONNECTION, the socket is already secure. For TTLS_STOP_ CONNECTION, the socket is not secure. | Modify the application so that it issues the SIOCTTLSCTL IOCTL that requests TTLS_INIT_ CONNECTION only when the socket is not already secure and that requests TTLS_STOP_ CONNECTION only when the socket is secure.
37 | EALREADY | Maxdesc | A socket has already been created calling Maxdesc() or multiple calls to Maxdesc(). | Issue Getablesize() to query it.
37 | EALREADY | Setibmopt | A connection already exists to a TCP/IP image. A call to SETIBMOPT (IBMTCP_IMAGE), has already been made. | Only call Setibmopt() once.
38 | ENOTSOCK | All | A socket operation was requested on a nonsocket connection. The value for socket descriptor was not valid. | Correct the socket descriptor value and reissue the function call.
39 | EDESTADDRREQ | All | A destination address is required. | Fill in the destination field in the correct parameter and reissue the function call.
40 | EMSGSIZE | Sendto Sendmsg Send Write | The message is too long. It exceeds the IP limit of 64K or the limit set by the setsockopt() call. | Either correct the length parameter, or send the message in smaller pieces.
41 | EPROTOTYPE | All | The specified protocol type is incorrect for this socket. | Correct the protocol type parameter.
41 | EPROTOTYPE | IOCTL (SIOCTTLSCTL) | Socket is not a TCP socket. | Issue the SIOCTTLSCTL IOCTL on TCP sockets only.
41 | EPROTOTYPE | IOCTL (SIOCSAPPLDATA) | The request was not successful. The socket is not a stream (TCP) socket. | Issue the SIOCSAPPLDATA IOCTL on TCP sockets only.
42 | ENOPROTOOPT | Getsockopt Setsockopt | The socket option specified is incorrect or the level is not SOL_SOCKET. Either the level or the specified optname is not supported. | Correct the level or optname.
42 | ENOPROTOOPT | Getibmsockopt Setibmsockopt | Either the level or the specified optname is not supported. | Correct the level or optname.
43 | EPROTONOSUPPORT | Socket | The specified protocol is not supported. | Correct the protocol parameter.
44 | ESOCKTNOSUPPORT | All | The specified socket type is not supported. | Correct the socket type parameter.
45 | EOPNOTSUPP | IOCTL | The specified IOCTL command is not supported by this socket API. | Correct the IOCTL COMMAND.
45 | EOPNOTSUPP | GETSOCKOPT | The specified GETSOCKOPT OPTNAME option is not supported by this socket API. | Correct the GETSOCKOPT OPTNAME option.
45 | EOPNOTSUPP | IOCTL (SIOCTTLSCTL requesting TTLS_INIT_ CONNECTION, TTLS_RESET_ SESSION, TTLS_RESET_ CIPHER or TTLS_STOP_ CONNECTION) | Mapped policy indicates that AT-TLS is not enabled for the connection. | Modify the policy to enable AT-TLS for the connection.
45 | EOPNOTSUPP | RECV, RECVFROM, RECVMSG, SEND, SENDTO, SENDMSG | The specified flags are not supported on this socket type or protocol. | Correct the FLAG.
45 | EOPNOTSUPP | Accept Givesocket | The selected socket is not a stream socket. | Use a valid socket.
45 | EOPNOTSUPP | Listen | The socket does not support the Listen call. | Change the type on the Socket() call when the socket was created. Listen() only supports a socket type of SOCK_STREAM.
45 | EOPNOTSUPP | Getibmopt Setibmopt | The socket does not support this function call. This command is not supported for this function. | Correct the command parameter. See Getibmopt() for valid commands. Correct by ensuring a Listen() was not issued before the Connect().
46 | EPFNOSUPPORT | All | The specified protocol family is not supported or the specified domain for the client identifier is not AF_INET=2. | Correct the protocol family.
47 | EAFNOSUPPORT | Bind Connect Socket | The specified address family is not supported by this protocol family. | For Socket(), set the domain parameter to AF_INET. For Bind() and Connect(), set Sin_Family in the socket address structure to AF_INET.
47 | EAFNOSUPPORT | Getclient Givesocket | The socket specified by the socket descriptor parameter was not created in the AF_INET domain. | The Socket() call used to create the socket should be changed to use AF_INET for the domain parameter.
47 | EAFNOSUPPORT | IOCTL | You attempted to use an IPv4-only ioctl on an AF_INET6 socket. | Use the correct socket type for the ioctl or use an ioctl that supports AF_INET6 sockets.
48 | EADDRINUSE | Bind | The address is in a timed wait because a LINGER delay from a previous close or another process is using the address. This error can also occur if the port specified in the bind call has been configured as RESERVED on a port reservation statement in the TCP/IP profile. | If you want to reuse the same address, use Setsockopt() with SO_REUSEADDR. Refer to the section about Setsockopt() in z/OS Communications Server: IP Sockets Application Programming Interface Guide and Reference for more information. Otherwise, use a different address or port in the socket address structure.
48 | EADDRINUSE | IP_ADD_MEMBERSHIP, IP_ADD_SOURCE_ MEMBERSHIP, IPV6_JOIN_GROUP, MCAST_JOIN_GROUP, MCAST_JOIN_SOURCE_ GROUP | The specified multicast address and interface address (or interface index) pair is already in use. | Correct the specified multicast address, interface address, or interface index.
49 | EADDRNOTAVAIL | Bind | The specified address is incorrect for this host. | Correct the function address parameter.
49 | EADDRNOTAVAIL | Connect | The calling host cannot reach the specified destination. | Correct the function address parameter.
49 | EADDRNOTAVAIL | Multicast APIs | The specified multicast address, interface address, or interface index is not correct. | Correct the specified address.
49 | EADDRNOTAVAIL | IP_BLOCK_SOURCE, IP_ADD_SOURCE_ MEMBERSHIP, MCAST_BLOCK_SOURCE, MCAST_JOIN_SOURCE_ GROUP | A duplicate source IP address is specified on the multicast group and interface pair. | Correct the specified source IP address.
49 | EADDRNOTAVAIL | IP_UNBLOCK_SOURCE, IP_DROP_SOURCE_ MEMBERSHIP, MCAST_UNBLOCK_ SOURCE, MCAST_LEAVE_SOURCE_ GROUP | A previously blocked source multicast group cannot be found. | Correct the specified address.
50 | ENETDOWN | All | The network is down. | Retry when the connection path is up.
51 | ENETUNREACH | Connect | The network cannot be reached. | Ensure that the target application is active.
52 | ENETRESET | All | The network dropped a connection on a reset. | Reestablish the connection between the applications.
53 | ECONNABORTED | All | The software caused a connection abend. | Reestablish the connection between the applications.
54 | ECONNRESET | All | The connection to the destination host is not available. | N/A
54 | ECONNRESET | Send Write | The connection to the destination host is not available. | The socket is closing. Issue Send() or Write() before closing the socket.
55 | ENOBUFS | All | No buffer space is available. | Check the application for massive storage allocation call.
55 | ENOBUFS | Accept | Not enough buffer space is available to create the new socket. | Call your system administrator.
55 | ENOBUFS | Send Sendto Write | Not enough buffer space is available to send the new message. | Call your system administrator.
55 | ENOBUFS | IOCTL (SIOCTTLSCTL TTLS_Version1 requesting TTLS_RETURN_ CERTIFICATE or TTLS_Version2 query) | The buffer size provided is too small. | For TTLS_Version1 use the returned certificate length to allocate a larger buffer and reissue IOCTL with the larger buffer.
55 | ENOBUFS | Takesocket | Not enough buffer space is available to create the new socket. | Call your system administrator.
55 | ENOBUFS | IOCTL (SIOCSAPPLDATA) | There is no storage available to store the associated data. | Call your system administrator.
55 | ENOBUFS | IP_BLOCK_SOURCE, IP_ADD_SOURCE_ MEMBERSHIP, MCAST_BLOCK_SOURCE, MCAST_JOIN_SOURCE_ GROUP, SIOCSIPMSFILTER, SIOCSMSFILTER, setipv4sourcefilter, setsourcefilter | A maximum of 64 source filters can be specified per multicast address, interface address pair. | Remove unneeded source IP addresses and reenter the command.
56 | EISCONN | Connect | The socket is already connected. | Correct the socket descriptor on Connect() or do not issue a Connect() twice for the socket.
57 | ENOTCONN | All | The socket is not connected. | Connect the socket before communicating.
57 | ENOTCONN | IOCTL (SIOCTTLSCTL) | The socket is not connected. | Issue the SIOCTTLSCTL IOCTL only after the socket is connected.
58 | ESHUTDOWN | All | A Send cannot be processed after socket shutdown. | Issue read/receive before shutting down the read side of the socket.
59 | ETOOMANYREFS | All | There are too many references. A splice cannot be completed. | Call your system administrator.
59 | ETOOMANYREFS | IP_ADD_MEMBERSHIP, IP_ADD_SOURCE_ MEMBERSHIP, MCAST_JOIN_GROUP, MCAST_JOIN_SOURCE_ GROUP, IPV6_JOIN_GROUP | A maximum of 20 multicast groups per single UDP socket or a maximum of 256 multicast groups per single RAW socket can be specified. | Remove unneeded multicast groups and reenter the command.
60 | ETIMEDOUT | Connect | The connection timed out before it was completed. | Ensure the server application is available.
61 | ECONNREFUSED | Connect | The requested connection was refused. | Ensure server application is available and at specified port.
62 | ELOOP | All | There are too many symbolic loop levels. | Reduce symbolic links to specified file.
63 | ENAMETOOLONG | All | The file name is too long. | Reduce size of specified file name.
64 | EHOSTDOWN | All | The host is down. | Restart specified host.
65 | EHOSTUNREACH | All | There is no route to the host. | Set up network path to specified host and verify that host name is valid.
66 | ENOTEMPTY | All | The directory is not empty. | Clear out specified directory and reissue call.
67 | EPROCLIM | All | There are too many processes in the system. | Decrease the number of processes or increase the process limit.
68 | EUSERS | All | There are too many users on the system. | Decrease the number of users or increase the user limit.
69 | EDQUOT | All | The disk quota has been exceeded. | Call your system administrator.
70 | ESTALE | All | An old NFS** data set handle was found. | Call your system administrator.
71 | EREMOTE | All | There are too many levels of remote in the path. | Call your system administrator.
72 | ENOSTR | All | The device is not a stream device. | Call your system administrator.
73 | ETIME | All | The timer has expired. | Increase timer values or reissue function.
74 | ENOSR | All | There are no more stream resources. | Call your system administrator.
75 | ENOMSG | All | There is no message of the desired type. | Call your system administrator.
76 | EBADMSG | All | The system cannot read the message. | Verify that z/OS Communications Server installation was successful and that message files were properly loaded.
77 | EIDRM | All | The identifier has been removed. | Call your system administrator.
78 | EDEADLK | All | A deadlock condition has occurred. | Call your system administrator.
78 | EDEADLK | Select Selectex | None of the sockets in the socket descriptor sets are either AF_INET or AF_IUCV sockets and there is no timeout value or no ECB specified. The select/selectex would never complete. | Correct the socket descriptor sets so that an AF_INET or AF_IUCV socket is specified. A timeout or ECB value can also be added to avoid the select/selectex from waiting indefinitely.
79 | ENOLCK | All | No record locks are available. | Call your system administrator.
80 | ENONET | All | The requested machine is not on the network. | Call your system administrator.
81 | ERREMOTE | All | The object is remote. | Call your system administrator.
82 | ENOLINK | All | The link has been severed. | Release the sockets and reinitialize the client-server connection.
83 | EADV | All | An ADVERTISE error has occurred. | Call your system administrator.
84 | ESRMNT | All | An SRMOUNT error has occurred. | Call your system administrator.
85 | ECOMM | All | A communication error has occurred on a Send call. | Call your system administrator.
86 | EPROTO | All | A protocol error has occurred. | Call your system administrator.
86 EPROTO IOCTL (SIOCTTLSCTL requesting TTLS_RESET_ SESSION, TTLS_RESET_ CIPHER, TTLS_STOP_ CONNECTION, or TTLS_ALLOW_ HSTIMEOUT) One of the following errors occurred:
  • A TTLS_INIT_ CONNECTION request has not been received for the connection
  • TTLS_RESET_ CIPHER or TTLS_STOP_ CIPHER was requested on a connection that is secured using SSL version 2.
  • TTLS_ALLOW_ HSTIMEOUT was requested but the policy has the HandshakeRole value client or the HandshakeTimeout is 0.
Request TTLS_INIT_ CONNECTION prior to requesting TTLS_RESET_SESSION or TTLS_RESET_CIPHER. Request TTLS_RESET_CIPHER or TTLS_STOP_ CONNECTION only on connections secured using SSL version 3 or TLS version 1. Request TTLS_ALLOW_ HSTIMEOUT only when the security type is TTLS_SEC_SERVER or higher and the HandshakeTimeout is not 0.
87 | EMULTIHOP | All | A multihop address link was attempted. | Call your system administrator.
88 | EDOTDOT | All | A cross-mount point was detected. This is not an error. | Call your system administrator.
89 | EREMCHG | All | The remote address has changed. | Call your system administrator.
90 | ECONNCLOSED | All | The connection was closed by a peer. | Check that the peer is running.
113 | EBADF | All | Socket descriptor is not in correct range. The maximum number of socket descriptors is set by MAXDESC(). The default range is 0-49. | Reissue function with corrected socket descriptor.
113 | EBADF | Bind socket | The socket descriptor is already being used. | Correct the socket descriptor.
113 | EBADF | Givesocket | The socket has already been given. The socket domain is not AF_INET. | Correct the socket descriptor.
113 | EBADF | Select | One of the specified descriptor sets is an incorrect socket descriptor. | Correct the socket descriptor. Set on Select() or Selectex().
113 | EBADF | Takesocket | The socket has already been taken. | Correct the socket descriptor.
113 | EBADF | Accept | A Listen() has not been issued before the Accept(). | Issue Listen() before Accept().
121 | EINVAL | All | An incorrect argument was specified. | Check and correct all function parameters.
121 EINVAL IOCTL (SIOCSAPPLDATA) The input parameter is not a correctly formatted SetApplData structure.
  • The SetAD_eye1 value is not valid.
  • The SetAD_ver value is not valid.
  • The storage pointed to by SetAD_ptr does not contain a correctly formatted SetADcontainer structure.
  • The SetAD_eye2 value is not valid.
  • The SetAD_len value contains an incorrect length for the SetAD_ver version of the SetADcontainer structure.
Check and correct all function parameters.
122 | ECLOSED
126 | ENMELONG
136 | ENOTEMPT
145 | E2BIG | All | The argument list is too long. | Eliminate excessive number of arguments.
156 EMVSINITIAL All Process initialization error.

This indicates an z/OS® UNIX® process initialization failure. This is usually an indication that a proper OMVS RACF® segment is not defined for the user ID associated with application. The RACF OMVS segment may not be defined or may contain errors such as an improper HOME() directory specification.

Attempt to initialize again. After ensuring that an OMVS Segment is defined, if the errno is still returned, call your MVS™ system programmer to have IBM® service contacted.
157 | EMISSED
1002 | EIBMSOCKOUTOFRANGE | Socket | A socket number assigned by the client interface code is out of range. | Check the socket descriptor parameter.
1003 | EIBMSOCKINUSE | Socket | A socket number assigned by the client interface code is already in use. | Use a different socket descriptor.
1004 | EIBMIUCVERR | All | The request failed because of an IUCV error. This error is generated by the client stub code. | Ensure IUCV/VMCF is functional.
1008 | EIBMCONFLICT | All | This request conflicts with a request already queued on the same socket. | Cancel the existing call or wait for its completion before reissuing this call.
1009 | EIBMCANCELLED | All | The request was canceled by the CANCEL call. | Informational, no action needed.
1011 | EIBMBADTCPNAME | All | A TCP/IP name that is not valid was detected. | Correct the name specified in the IBM_TCPIMAGE structure.
1011 | EIBMBADTCPNAME | Setibmopt | A TCP/IP name that is not valid was detected. | Correct the name specified in the IBM_TCPIMAGE structure.
1011 | EIBMBADTCPNAME | INITAPI | A TCP/IP name that is not valid was detected. | Correct the name specified on the IDENT option TCPNAME field.
1012 | EIBMBADREQUESTCODE | All | A request code that is not valid was detected. | Contact your system administrator.
1013 | EIBMBADCONNECTIONSTATE | All | A connection token that is not valid was detected; bad state. | Verify TCP/IP is active.
1014 | EIBMUNAUTHORIZEDCALLER | All | An unauthorized caller specified an authorized keyword. | Ensure user ID has authority for the specified operation.
1015 | EIBMBADCONNECTIONMATCH | All | A connection token that is not valid was detected. There is no such connection. | Verify TCP/IP is active.
1016 | EIBMTCPABEND | All | An abend occurred when TCP/IP was processing this request. | Verify that TCP/IP has restarted.
1023 | EIBMTERMERROR | All | Encountered a terminating error while processing. | Call your system administrator.
1026 | EIBMINVDELETE | All | Delete requestor did not create the connection. | Delete the request from the process that created it.
1027 | EIBMINVSOCKET | All | A connection token that is not valid was detected. No such socket exists. | Call your system programmer.
1028 | EIBMINVTCPCONNECTION | All | Connection terminated by TCP/IP. The token was invalidated by TCP/IP. | Reestablish the connection to TCP/IP.
1032 | EIBMCALLINPROGRESS | All | Another call was already in progress. | Reissue after previous call has completed.
1036 | EIBMNOACTIVETCP | All | TCP/IP is not installed or not active. | Correct TCP/IP name used.
1036 | EIBMNOACTIVETCP | Select | EIBMNOACTIVETCP | Ensure TCP/IP is active.
1036 | EIBMNOACTIVETCP | Getibmopt | No TCP/IP image was found. | Ensure TCP/IP is active.
1037 | EIBMINVTSRBUSERDATA | All | The request control block contained data that is not valid. | Call your system programmer.
1038 | EIBMINVUSERDATA | All | The request control block contained user data that is not valid. | Check your function parameters and call your system programmer.
1040 | EIBMSELECTEXPOST | SELECTEX | SELECTEX passed an ECB that was already posted. | Check whether the user's ECB was already posted.
1112 | ECANCEL
2001 | EINVALIDRXSOCKETCALL | REXX™ | A syntax error occurred in the RXSOCKET parameter list. | Correct the parameter list passed to the REXX socket call.
2002 | ECONSOLEINTERRUPT | REXX | A console interrupt occurred. | Retry the task.
2003 | ESUBTASKINVALID | REXX | The subtask ID is incorrect. | Correct the subtask ID on the INITIALIZE call.
2004 | ESUBTASKALREADYACTIVE | REXX | The subtask is already active. | Only issue the INITIALIZE call once in your program.
2005 | ESUBTASKALNOTACTIVE | REXX | The subtask is not active. | Issue the INITIALIZE call before any other socket call.
2006 | ESOCKNETNOTALLOCATED | REXX | The specified socket could not be allocated. | Increase the user storage allocation for this job.
2007 | EMAXSOCKETSREACHED | REXX | The maximum number of sockets has been reached. | Increase the number of allocate sockets, or decrease the number of sockets used by your program.
2009 | ESOCKETNOTDEFINED | REXX | The socket is not defined. | Issue the SOCKET call before the call that fails.
2011 | EDOMAINSERVERFAILURE | REXX | A Domain Name Server failure occurred. | Call your MVS system programmer.
2012 | EINVALIDNAME | REXX | An incorrect name was received from the TCP/IP server. | Call your MVS system programmer.
2013 | EINVALIDCLIENTID | REXX | An incorrect clientid was received from the TCP/IP server. | Call your MVS system programmer.
2014 | ENIVALIDFILENAME | REXX | An error occurred during NUCEXT processing. | Specify the correct translation table file name, or verify that the translation table is valid.
2016 | EHOSTNOTFOUND | REXX | The host is not found. | Call your MVS system programmer.
2017 | EIPADDRNOTFOUND | REXX | Address not found. | Call your MVS system programmer.
3412 | ENODATA | Message does not exist.
3416 | ELINKED | Stream is linked.
3419 | ERECURSE | Recursive attempt rejected.
3420 | EASYNC | Asynchronous I/O scheduled. This is a normal, internal event that is NOT returned to the user.
3448 | EUNATCH | The protocol required to support the specified address family is not available.
3464 | ETERM | Operation terminated.
3474 | EUNKNOWN | Unknown system state.
3495 | EBADOBJ | You attempted to reference a object that does not exist.
3513 | EOUTOFSTATE | Protocol engine has received a command that is not acceptable in its current state.
Parent topic: Configuring and Managing EZASOKET Support for CICS Applications


Secure Communications (SSL)

Micro Focus Demo CA enables secure communication between your computer and Micro Focus products in which the Demo CA is enabled. Encryption is done using Secure Sockets Layer (SSL) encryption. Support is also provided for Public Key Infrastructures (PKIs).

  • Using the Demonstration Certificate Authority
  • Tutorial: Requesting and Issuing Server Certificates
  • Tutorial: Configuring SSL Security in the Server
  • Information on OpenSSL
  • SSL and PKI Technology Primer
    The topics in this section describe the basics of SSL and PKI technology, and how they work together to secure communications.
  • SSL Reference
Parent topic: Deployment


To set a pass phrase

You can configure a pass phrase in a file, or you can set it when you start the Enterprise Server instance. To set a pass phrase when you start the instance:

  1. Start your enterprise server from the home page of ES Admin and wait for it to start.
  2. Go to the Listeners page and find your HTTPS listener. The status column should indicate "Start pending" and the Status Log column should show "Waiting for keyfile passphrase".
  3. Click Authorize in the Status column of the HTTPS listener.
  4. Enter your pass phrases and click Set passphrases.
  5. Confirm that the status of the HTTPS listener is now "Started", by looking at the main Listeners page (and clicking Refresh if necessary).
Note: If you have problems starting or running an SSL-enabled listener, it can be useful to look at the MFCS log. Click Server > Diagnostics > CS Console.
Parent topic: Secure Communications (SSL)
Previous topic: To configure an HTTPS listener
Next topic: To Enable Logging for Listener Startup


SSL Reference

  • Supported SSL Versions and Supported Algorithms
Parent topic: Secure Communications (SSL)


IMS System Log

The IMS System Log is a general-purpose log file. It is used to provide descriptive information for serious problems encountered when debugging, running or using the IMS Option utilities. It consists of the Mainframe Express IDE's IMS Log tab and the imsmto.log file in the Listing folder.

  • The Mainframe Express IDE's IMS Log tab:

    This contains messages produced during the current execution of the IDE. When you start the IDE, the IMS Log tab is disabled until a message is produced. You can clear the IMS Log tab at any time during an IDE session.

  • The imsmto.log file in the Listing directory:

    This is a historical log file. The most recent log entries are added to the end of an existing imsmto.log file. It is an ASCII text file and is created the first time a message needs logging. You may need to delete this file periodically as it could grow quite large. The 'mto' in imsmto stands for 'Master Terminal Operator'.


run Command

Restriction: This command is supported for native COBOL only.

To run dynamically loadable programs (that is, .gnt files or .int files) use the run command, as follows:

run [switch-param] program-name [program-param]

where:

switch-param
One or more programmable and run-time switches that control events in a program at run time. Your application supplier will tell you which switches to specify.
program-name
The name of a dynamically loadable program.
program-parameters
One or more parameters that are required by the program. Each parameter is a string, separated from adjoining parameters by one or more spaces.


Overview of Mapping and Deploying a Java Interface

You can expose procedural COBOL as EJBs or Java beans, by using the to map an interface onto your COBOL program. The Interface Mapping Toolkit generates a COBOL service and an EJB or Java bean, and optionally a client for the EJB.

In brief, the Service Interfaces feature enables you to select the COBOL entry points or program IDs and the parameters to use in the new interface. It records all the mapping information, so that the EJB or Java bean can call the COBOL service. You use the Service Interfaces feature to generate the EJB or Java bean and the COBOL service.

The COBOL service then needs to be deployed to a COBOL enterprise server. The COBOL service comprises the mapping information and the original COBOL. You can deploy the service automatically, or you can do it manually.

You deploy or run the Java in one of the following ways:

  • You deploy the EJB to a Java 2 Enterprise Edition (J2EE) application server and also deploy a resource adapter to handle the connection between the J2EE application server and the enterprise server.
  • You run the Java bean in a Java 2 Standard Edition (J2SE) environment. The bean accesses the enterprise server directly, without a resource adapter. This avoids using a J2EE application server, but you lose the management and transaction support that it provides.
  • You ignore the EJB or Java bean generated and write your own Java, which uses an unmanaged connection to call the resource adapter and send the request to an enterprise server.

At run time, your client application makes Java requests and invokes the generated EJB or Java bean. The EJB uses the resource adapter to pass the requests to an enterprise server, which in turn runs the exposed COBOL. Tha Java bean pass the requests to the enterprise server directly.

The mapping information is used at run time to pass data to and from the exposed COBOL. The enterprise server returns the response to the EJB through the resource adapter or directly to the Java bean. The EJB or bean passes the response on to the client.


Better Method Overload in Managed COBOL

Suppose we have an argument list A with a set of argument types (A1, A2,…An) and two applicable method overloads Mp and Mq with parameter types (P1…Pn) and (Q1,…Qn), where if necessary the parameters have been converted to expanded form (see above).

Then, Mp is said to be a better method overload than Mq if both the following are true:

  • For each argument, the implicit conversion from Ax to Px is not worse than the conversion from Ax to Qx (see below for definition of better conversion)
  • There is at least one argument for which the conversion from Ax to Px is better than the conversion from Ax to Qx

Suppose we have two conversions, from type S to types T1 and T2, then T1 is the better conversion when T1 and T2 are as follows:

T1 is: And T2 is one of:
same as S anything
binary-char
  • binary-char unsigned
  • binary-short unsigned
  • binary-long unsigned
  • binary-double unsigned
binary-short
  • binary-short unsigned
  • binary-long unsigned
  • binary-double unsigned
binary-long
  • binary-long unsigned
  • binary-double unsigned
binary-double
  • binary-double unsigned

Otherwise neither conversion is better.


Implicit Conversion in Method Overloading in Managed COBOL

An implicit conversion exists from type S to type T if it is possible to assign an object of type S to an object of type T, with the equivalent of the following statement:

SET obj-T TO obj-S

The following types of implicit conversion are available:

Identity conversions

This simply means that S is the same type as T

Implicit numeric conversions

COBOL generally allows any numeric item to be assigned to any other, with any loss of data being the responsibility of the user. However, when determining if a conversion exists for the purposes of method overloading, we distinguish between proper conversions and truncation conversions. Proper conversions are those for which no loss of data magnitude should result, though even in this case precision can be lost when converting between fixed point and floating point.

For managed COBOL types, proper implicit conversions include:

binary-char
  • binary-short
  • binary-long
  • binary-double
  • float-short
  • float-long
  • decimal
binary-char unsigned

The same as binary-char, plus:

  • binary-short unsigned
  • binary-long unsigned
  • binary-double unsigned
binary-short
  • binary-long
  • binary-double
  • float-short
  • float-long
  • decimal
binary-short unsigned

The same as binary-short, plus:

  • binary-long unsigned
  • binary-double unsigned
binary-long
  • binary-double
  • float-short
  • float-long
  • decimal
binary-long unsigned

The same as binary-long, plus:

  • binary-double unsigned
binary-double
  • float-short
  • float-long
  • decimal
binary-double unsigned

The same as binary-double

character
  • binary-short unsigned
  • binary-long
  • binary-long unsigned
  • binary-double
  • binary-double unsigned
  • float-short
  • float-long
  • decimal
float-short
  • float-long
Implicit enumeration conversions

The value 0 may be converted to any enum type

Implicit reference conversions

If S and T are reference types, S may be assigned to T when:

  • Type S is derived (directly or indirectly) from type T. This includes the case where T is System.Object, since all types derive from that
  • Type S implements interface type T
  • If S is an array type with element type E1 and T is an array type with element type E2, then S can be assigned to T provided:
    • S and T have the same number of dimensions
    • Both E1 and E2 are reference types
    • An implicit conversion exists from E1 to E2
  • Any array type may be assigned to type System.Array in .NET COBOL
  • Any delegate type may be assigned to type System.Delegate
  • Null may be assigned to any reference type
Boxing conversions

Any value type can be converted to a System.Object, type by a process known as boxing. As part of this process the value is copied onto the object heap and a reference is created

Implicit constant expression conversions

Any numeric constant can be converted to any type capable of containing the full value of that constant. For instance the value 1 can be converted both to BINARY-CHAR UNSIGNED and to BINARY-CHAR.

User defined implicit conversions

A user defined implicit conversion consists of an optional implicit numeric conversion from S to S1 followed by the execution of a user defined implicit conversion operator resulting in T1, followed by another optional implicit numeric conversion to T. User defined implicit conversion operators are defined in COBOL with OPERATOR-ID IMPLICIT and result in methods with the name op_Implicit.

Related information
Type Compatibility of Managed COBOL with Other Managed Languages


Method Overloading in Managed COBOL

In managed COBOL, it is permissible (and very common practice) for a given class or interface to have multiple methods with the same name, which are distinguished from each other by having different signatures. The signature of a method is determined by the:

  • Number of parameters
  • Type of each parameter
  • Passing mode (BY VALUE, BY REFERENCE, or BY OUTPUT) of each parameter
  • Return type , which in .NET COBOL, this type may be System.Void, which represents a method with no RETURNING item

When code written in COBOL, or any other language, attempts to invoke a method in some class or interface, and more than one method with the given name exists, then a choice of the available methods is made. The choice is based on the number of parameters and the ‘best’ type match for the parameters (the precise definition of ‘best’ is complex and is treated later). If no method with a suitable signature can be found, a ‘method not found’ error results. If there is no method that provides a better match than all the other possible methods with this name, an ‘ambiguous match’ error is given.

Although the type of the RETURNING item is a part of the method's signature, the choice of method to be invoked is never based on the RETURNING type. This is different from .NET and JVM, which allow a class to have multiple methods that differ only by returning type. This is not generally good practice, and COBOL produces an error if it finds such multiple methods within a single class. The only time when such multiple methods can arise from a COBOL program is in the case of the explicit and implicit operators.

Related reference
The Operator-ID Paragraph


Method Signatures Defined by Managed COBOL Programs

The type of a COBOL parameter may be specified by:

  • Referencing the type explicitly in the PROCEDURE DIVISION phrase using the AS syntax
  • Declaring a linkage section item with a given type and referencing that linkage section item in the PROCEDURE DIVISION USING phrase

For REFERENCE and OUTPUT parameters, managed types are exposed directly as managed pointers to the corresponding managed type. COBOL data types that do not correspond to managed types (such as PIC X fields, groups, numeric fields other than BINARY-LONG and so on) are exposed as COBOL pointers (objects of type MicroFocus.COBOL.Program.Reference, in .NET COBOL).

For VALUE parameters, and RETURNING items, types are exposed as follows:

COBOL types: are exposed as:
Managed types | objects of the corresponding type
Numeric items with more than 19 decimal digit positions | MicroFocus.COBOL.Program.BigDecimal
Numeric items with implied decimal point, such as PIC 9(9)v99, all sizes | - System.Decimal in .NET COBOL
Unsigned numeric items with no implied decimal point: In .NET COBOL:
  • < 3 numeric digits - unsigned int8
  • < 5 numeric digits - unsigned int16
  • < 10 numeric digits - unsigned int32
  • < 19 numeric digits - unsigned int64

In JVM COBOL, they are exposed the same as signed numeric items.

Signed numeric items with no implied decimal point:
  • < 3 numeric digits - int8
  • < 5 numeric digits - int16
  • < 10 numeric digits - int32
  • < 19 numeric digits - int64
All other types PIC X, group and so on | string
Related information
Type Compatibility of Managed COBOL with Other Managed Languages


Data File Convert


Library Names in Paths

You can include a library name in the name of a file you want to open. The file specification is of the form

 device\library-name.lbr\filename.ext

Example

c:\appdir\applib.lbr\app.dat

This type of filename is only valid when used as the name of a data file being opened in read-only mode, using either OPEN INPUT syntax or the CBL_OPEN_FILE byte stream routine. If the library is not already open, this call will open that library on the given device and leave it open after the call. If the library does not exist, or if the given filename.ext does not exist in that library, a "file not found" error is returned.

Related concepts
Filename Mapping
Related information
Defining Input and Output Files


CASCD1057S

A JES Initiator for Server server-name has abended due to an unexpected signal signal-value.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


CASRD0050E

The URIMAP resource-name cannot be installed as it maps to the same HOST and PATH plus optional TCPIPSERVICE as URIMAP2.
System action:
Continue, the resource will not be installed.
Resolution:
Specify different HOST, PATH or TCPIPSERVICE values.
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0046 - CASRD0052


CASST0015E

While attempting to shutdown a region an error occurred trying to submit the shutdown request
System action:
As the shut down program cannot attach to the region the region cannot be shutdown.
Resolution:
A forced region shutdown may be required.
Destination:
Console
Module:
casstop
Parent topic: CASST0000 - CASST0020


CASKC0003I

The server process process-id has shutdown normally.
System action:
The process terminates normally.
Resolution:
None.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0000 - CASKC0015


CASRD0019E

The resource definition for resource-type entry resource-name is not installable. The existing installed definition is in use.
System action:
Continue, the group will not be installed.
Resolution:
Close and disable the file and retry the operation.
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASXO0010S

The Resource manager for the XAT resource returned a non-zero value to the xa_commit call.

The return codes are:

  • -2 Asynchronous operation already outstanding
  • -3 A resource manager error occurred
  • -4 The XID is not valid
  • -5 Invalid arguments were given
  • -6 Routine invoked in an improper context
  • -7 Resource Manager unavailable
  • -8 the XID already exists
  • -9 Resource Manager doing work outside global transaction
  • The following indicate the transaction is marked as roll-back only
  • 100 The resource manager marked the transaction roll-back
  • only for an unspecified reason.
  • 101 A communication failure occurred
  • 102 The resource manager detected a deadlock
  • 103 The resource manager detected a violation of the integrity
  • of its resources
  • 104 The resource manager marked the transaction roll-back
  • only for a reason not in this list.
  • 105 A protocol error occurred in the resource manager
  • 106 The work represented by this transaction took too long
  • 107 The resource manager detected a transient error
System Action:
The Transaction is abnormally terminated
Resolution:
Check that the Resource Manager is still available
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


CASST5005S

A transaction program abend occurred in the program program of the plt-name list during Phase 2 PLTSD processing.
System Action:
PLT processing is terminated; Shutdown is aborted
Resolution:
Do a SHUTDOWN IMMMEDIATE to bypass PLTSD processing. Determine the cause of the transaction program abend and correct it. If the problem cannot be determined, the Resource Definitions can be updated to omit the program from the PLT or to use a different (or no) PLT.
Destination:
console (and terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASSP0003E

The daemon process responsible for initiating recovery for process-id failed trying to lock shared memory.
System action:
The region manager cannot be informed of the process's termination. The region may continue successfully.
Resolution:
None
Destination:
Console
Module:
dfhgdied
Parent topic: CASSP0001 - CASSP0014


CASKC0018E

The system attempted load the Interface Definition Table (IDT) for Service service-name. The file system open for the disk image failed with a reason code of reason-code. The reason-code will be displayed in decimal. The hexidecimal representation of the error might indicate a COBOL RTS error, for example 0x390D is a 9/13 which means file not found.
System action:
The service request is failed
Resolution:
Correct the location or deployment error and retry the request.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


Interfaces - in COBOL and C#

Interfaces in Managed COBOL

*> Accessibility keywords
public
private
internal
protected
protected internal
static

*> Inheritance
class-id FootballGame inherits type Competition.
  ...
end class.

*> Interface definition
interface-id IAlarmClock.
  ...
end interface.

*> Inheriting an interface
interface-id IAlarmClock inherits type IClock.
  ...
end interface.

*> Interface implementation
class-id WristWatch implements type IAlarmClock, type ITimer.
   ...
end class.

Interfaces in C#

// Accessibility keywords
public
private
internal
protected
protected internal
static
new

// Inheritance
class FootballGame : Competition
{
  ...
}

// Interface definition
interface IAlarmClock
{
  ...
}

// Extending an interface
interface IAlarmClock : IClock
{
  ...
}

// Interface implementation
class WristWatch : IAlarmClock, ITimer
{
   ...
}
Related reference
Interfaces


CASCS2002E

A systems data stream was received by the CAS mirror transaction trans-ID that is not supported. It is not an FMH 5, 6, or 43.
System Action:
The transaction is abended and the conversation is terminated
Resolution:
If the problem persists, determine the reason that the partner system is generating the unsupported FMH data and correct the problem
Destination:
TDQ CSMT
Module:
dfhzcsmi
Parent topic: CASCS1500 - CASCS2004


Using the Java/COBOL Application Launcher from the Command Line

Restriction: This applies to native code only.

The command to invoke the Java/COBOL application launcher can take one of two formats:

cobjrun [options] class [arguments]
cobjrun -jar [options] jarfile [arguments]

where the parameters are:

options
The options you would normally specify to your Java application launcher.
class
The name of the class to be invoked. If the Java/COBOL application launcher cannot find a Java class of this name, it tries to find a COBOL program of the same name. If a COBOL program is found, it is executed.
arguments
The arguments to pass to the main function.
-jar
Specifies that a program from a JAR file is to be executed.
jarfile
The name of the Java archive (.jar) file to be invoked.
Important:
  • The Java/COBOL application launcher loads a specified class, and invokes the class's main method, where the method declaration must be in one of the following formats.
    If the class is a Java class:
    public static void main(String args[])
    If the class is a COBOL class:
    method-id main static.

procedure division using by value args as string occurs any.
  • If the Java application is contained in a .jar file, you need to add it to the classpath by using the -classpath (or -cp) option and specifying the fully qualified class-name
  • If you specify a .jar file that contains a manifest including a Main-Class attribute, you can use the -jar option to execute the application
  • In Eclipse, you set up a launch configuration and you specify cobjrun as the executable to run and specify that the multi-threaded run-time system is used
  • If you are calling a COBOL program, you cannot use the command_line_linkage tunable method to use the command line arguments in the COBOL program, but you can use the X/Open argument-name and argument-value syntax.
  • When using cobjrun in a 64-bit AIX environment, you must specify the locations of shared libraries using the LIBPATH environment variable, for example
    export LIBPATH=/usr/java6_64/jre/lib/ppc64/j9vm:/usr/java6_64/jre/lib/ppc64:/usr/java6_64/jre/../lib/ppc64:
  • If you receive an Could not load JVM... error, check your environment settings, and also ensure your effective working mode (COBMODE) matches the version of Java shared libraries being called.
  • If the effective working mode is not set, you can directly invoke the correct environment by using either cobjrun32 or cobjrun64.
Related concepts
Setting Up the Environment for Java and COBOL


SORT000 - SORT099

  • SORT009U job-number job-name SORT TERMINATED - ERROR ACCESSING MFJSORTM.DAT
    The message file cannot be found or it cannot be opened.
  • SORT012U job-number job-name SYSIN DATASET 'DATASET' EMPTY
    MFJSORT has found the specified SYSIN data set to be empty. Processing is terminated.
  • SORT013U job-number job-name I/O ERROR ON DATASET 'DATASET'
    An I/O error has occurred on the specified data set.
  • SORT014U job-number job-name STATUS = FILE STATUS
    The specified file status values indicate the cause of the I/O error reported in message SORT013U.
  • SORT015U job-number job-name COMMAND STATEMENT ERROR(S) DETECTED
    Errors have been detected during SYSIN command statement processing.
  • SORT016I job-number job-name SORTTEMP DATASET ALLOCATED TO 'FILE'
    The temporary sort work file has been allocated to the specified file. The temporary file name is obtained from the operating system and appended with a $WK file name extension.
  • SORT019I job-number job-name KEY LENGTH TRUNCATED TO 4096 BYTES
    The concatenated key length exceeds 4096 bytes. Processing continues, however the sort/merge operation uses only the first 4096 bytes of the key field(s) specified.
  • SORT020U job-number job-name SORT(EXTSM) FAILED – SORT ENGINE STATUS = EXTSM STATUS
    The size of the files which can be sorted or merged by MFJSORT(EXTSM) is determined by the record length, number of sort fields, sort field lengths, the amount of memory available, and the amount of disk space available for virtual paging.
  • SORT033I job-number job-namenumber RECORDS MERGED
    This message indicates the number of records actually written to the SORTOUT output data set by the MERGE function.
  • SORT034I job-number job-namenumber RECORDS COPIED
    This message indicates the number of records actually written to the SORTOUT output data set by the COPY function.
  • SORT035U job-number job-name SORTIN DSORG OR RECFM MISSING
    The record format for the SORTIN data set is missing.
  • SORT036U job-number job-name SORTIN RECORD LENGTH MISSING OR INVALID
    The record length for the SORTIN data set is missing.
  • SORT037U job-number job-name SYSIN RECFM 'FORMAT'' INVALID
    The record format for the SYSIN data set is invalid.
  • SORT038U job-number job-name SORTIN RECFM 'FORMAT' INVALID
    The record format for the SORTIN data set is invalid.
  • SORT039U job-number job-name SORTOUT RECFM 'FORMAT' INVALID
    The record format for the SORTOUT data set is invalid.
  • SORT040U job-number job-name SORT TERMINATED BY E15 'PROGRAM'
    The user E15 exit has requested termination of the sort/merge operation.
  • SORT041U job-number job-name SORT TERMINATED BY E35 'PROGRAM'
    The user E35 exit has requested termination of the sort/merge operation.
  • SORT042U job-number job-name MEMORY ALLOCATION FAILURE
    The system has run out of memory during the sort process.
  • SORT043U job-number job-name TOO MANY OUTFIL FILES SPECIFIED
    The limit of 16 OUTFIL files has been exceeded.
  • SORT044U job-number job-name TOO MANY 'USE' FILES SPECIFIED
    The limit of 16 USE files has been exceeded (non-emulation mode).
  • SORT045U job-number job-name TOO MANY 'GIVE' FILES SPECIFIED
    The limit of 16 GIVE files has been exceeded (non-emulation mode).
  • SORT090U job-number job-name SORT TERMINATED - MISSING SYSOUT
    The DD statement for the SYSOUT data set cannot be located.
  • SORT091U job-number job-name SORT TERMINATED - MISSING SYSIN
    The DD statement for the SYSIN data set cannot be located.
  • SORT092U job-number job-name SORT TERMINATED - MISSING SORTOUT
    The DD statement for the SORTOUT data set cannot be located.
  • SORT093U job-number job-name SORT TERMINATED - MISSING SORTIN OR SORTIN01
    The DD statement for a SORTIN or SORTIN01 data set cannot be located.
  • SORT094U job-number job-name SORT TERMINATED - MISSING SORTOFnn
    The DD statement for a SORTOF data set referenced by the OUTFIL control statement cannot be located.
  • SORT095U job-number job-name SORT TERMINATED – BAD DATA IN 'CHANGE' FIELD
    Input data did not match any of the CHANGE find-constants and the NOMATCH option was not specified.
  • SORT096U job-number job-name SORT TERMINATED – MISSING FNAMES DATASET 'DATASET'
    The DD statement for the FNAMES data set cannot be located.
Parent topic: SORT - MFJSORT Error Messages


CASRD0002E

The resource-type name resource-name is locked with an ENQ. Some other operation is currently being executed that involves it.
System action:
Validation continues but the group group-name will not be installed
Resolution:
Verify that the proper group is being installed and retry
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


JCLCM0400 - JCLCM0499

  • JCLCM0401U job-number job-name MISSING JOB STATEMENT
    JCL error. A JOB statement is required in the jobstream.
  • JCLCM0402E job-number job-name MISSING EXECUTE STATEMENT
    JCL error. At least one EXEC statement is required in the jobstream.
  • JCLCM0403E job-number job-name TOO MANY PROCEDURES REFERENCED
    JCL error. The job submitted has exceeded the maximum number of cataloged procedures that this system can load.
  • JCLCM0404E job-number job-name MISSING PEND STATEMENT
    JCL error. A PEND statement is required to end the instream procedure begun by a previous PROC statement.
  • JCLCM0405E job-number job-name RECURSIVE, ILLEGAL NESTING, OR LIMIT EXCEEDED
    JCL error. A procedure has attempted to execute another procedure. Nested procedures are not permitted.
  • JCLCM0406E job-number job-name PROCEDURE NOT FOUND
    JCL error. The procedure name specified cannot be located.
  • JCLCM0407E job-number job-name INVALID LABEL
    JCL error. The label on a JCL statement is invalid - for example, it exceeds eight characters.
  • JCLCM0408I UNKNOWN OUTPUT STMT OPERAND IGNORED
    You have used an unknown keyword.
  • JCLCM0409E job-number job-name INVALID OPERATOR
    JCL error. The JCL operator (EXEC, DD, etc.) contained on the statement is unknown.
  • JCLCM0410E job-number job-name INVALID CONTINUATION
    JCL error. The JCL statement contains an invalid continuation or the expected continuation was not received.
  • JCLCM0411E job-number job-name OPERAND TOO LONG
    JCL error. The JCL operand exceeds the length allowed for the JCL parameter.
  • JCLCM0412E job-number job-name NON-NUMERIC DATA DETECTED
    JCL error. Non-numeric data has been found in an operand that is required to be numeric.
  • JCLCM0413E job-number job-name DUPLICATE JOB
    JCL error. More than one JOB statement has been detected.
  • JCLCM0414E job-number job-name INVALID OR UNKNOWN OR UNEXPECTED OPERAND
    JCL error. The operand received is not recognized.
  • JCLCM0415E job-number job-name INVALID ADDRSPC OPERAND
    JCL error. The ADDRSPC operand is improperly coded.
  • JCLCM0416I job-number job-name INVALID JOBCLASS OPERAND IGNORED
    JCL error. The JOBCLASS operand is improperly coded and has been ignored.
  • JCLCM0417I job-number job-name INVALID MSGCLASS OPERAND IGNORED
    JCL error. The MSGCLASS operand on the JOB statement is improperly coded and has been ignored.
  • JCLCM0418E job-number job-name INVALID MSGLEVEL OPERAND
    JCL error. The MSGLEVEL operand is improperly coded.
  • JCLCM0419E job-number job-name INVALID PERFORM OPERAND
    JCL error. The PERFORM operand is improperly coded.
  • JCLCM0420E job-number job-name INVALID PRTY OPERAND
    JCL error. The PRTY operand is improperly coded.
  • JCLCM0421E job-number job-name INVALID RD OPERAND
    JCL error. The RD operand is improperly coded.
  • JCLCM0422I job-number job-name INVALID REGION OPERAND IGNORED
    JCL error. The REGION operand on the JOB or EXEC statement is improperly coded and has been ignored.
  • JCLCM0423E job-number job-name INVALID STEP NAME
    JCL error. The job step name is invalid.
  • JCLCM0424E job-number job-name INVALID PROCSTEP NAME
    JCL error. The procedure step name is invalid.
  • JCLCM0425E job-number job-name INVALID TIME OPERAND
    JCL error. The TIME operand is improperly coded.
  • JCLCM0426E job-number job-name INVALID TYPRUN OPERAND
    JCL error. The TYPRUN operand is improperly coded.
  • JCLCM0427E job-number job-name CONDITION STATEMENT IMPROPERLY FORMED
    JCL error. The COND operand is improperly coded.
  • JCLCM0428E job-number job-name INVALID CONDITION CODE
    JCL error. The condition code is improperly coded.
  • JCLCM0429E job-number job-name INVALID CONDITION OPERATOR
    JCL error. The condition operator is improperly coded.
  • JCLCM0430E job-number job-name INVALID PROGRAM NAME
    The program name is improperly coded.
  • JCLCM0431E job-number job-name INVALID DYNAMNBR OPERAND
    JCL error. The DYNAMNBR operand is improperly coded.
  • JCLCM0432E job-number job-name INVALID BURST OPERAND
    JCL error. The BURST operand is improperly coded.
  • JCLCM0433E job-number job-name INVALID CHKPT OPERAND
    JCL error. The CHKPT operand is improperly coded.
  • JCLCM0434E job-number job-name INVALID RECFM OPERAND
    JCL error. The RECFM operand is improperly coded.
  • JCLCM0435E job-number job-name INVALID LRECL OPERAND
    JCL error. The LRECL operand is improperly coded.
  • JCLCM0436E job-number job-name INVALID DISP OPERAND
    JCL error. The DISP operand is improperly coded.
  • JCLCM0437E job-number job-name UNEXPECTED STATEMENT
    JCL error. The JCL statement received was not expected.
  • JCLCM0438E job-number job-name PROCSTEP NOT FOUND
    JCL error. The procedure step name referenced cannot be located.
  • JCLCM0439E job-number job-name INVALID LABEL REFERENCE
    JCL error. The label reference on a JCL statement is invalid.
  • JCLCM0440E job-number job-name SYMBOL NOT FOUND
    JCL error. The symbolic parameter cannot be found on the PROC or EXEC statement.
  • JCLCM0441E job-number job-name UNKNOWN PROCSTEP NAME
    JCL error. The procedure step name referenced has not been defined by a previous EXEC statement.
  • JCLCM0442E job-number job-name INVALID OVERRIDE
    JCL error. The override is invalid.
  • JCLCM0443E job-number job-name INVALID POSITIONAL OPERAND
    JCL error. The positional operand was not expected.
  • JCLCM0444E job-number job-name INVALID DATASET NAME
    JCL error. The data set name is invalid.
  • JCLCM0445E job-number job-name INVALID REFER BACK
    JCL error. The refer back is invalid.
  • JCLCM0446E job-number job-name DCBMODEL NAME NOT FOUND
    JCL error. The model name specified in the DCB parameter cannot be found in the catalog.
  • JCLCM0447E job-number job-name INVALID DDNAME
    JCL error. The DD name is invalid.
  • JCLCM0448E job-number job-name INVALID DDNAME REFERENCE
    JCL error. The DD name deferral is invalid.
  • JCLCM0449E job-number job-name MISMATCHED PARENTHESES
    JCL error. An expected parenthesis was not received.
  • JCLCM0450E job-number job-name REFERENCED DD DOES NOT REFER TO A PDS MEMBER
    A reference such as PGM=*.step.pste.ddname refers to a DD name that does not reference a PDS member.
  • JCLCM0453E job-number job-name UNKNOWN RESTART STEP NAME
    JCL error. The step name specified in the RESTART operand of the JOB statement cannot be resolved.
  • JCLCM0454E job-number job-name INVALID ABEND CODE
    JCL error. The abend code in an IF statement or in the COND operand of the JOB or EXEC statement is specified incorrectly.
  • JCLCM0455E job-number job-name INVALID BLKSIZE OPERAND
    JCL error. The BLKSIZE operand is improperly coded.
  • JCLCM0456I job-number job-name BLKSIZE NOT A MULTIPLE OF LRECL
    JCL error. BLKSIZE must be a multiple of LRECL when both are coded and when RECFM=fixed is specified or implied.
  • JCLCM0457E job-number job-name INVALID EXPDT VALUE
    JCL error. The value specified for EXPDT is improperly coded or is not within the acceptable range.
  • JCLCM0458W job-number job-name INVALID FREE VALUE – DEFAULT OF (END) SUBSTITUTED
    JCL error. The value specified for FREE is improperly coded or is not within the acceptable range.
  • JCLCM0459E job-number job-name INVALID UCS VALUE
    JCL error. The value specified for UCS is improperly coded or is not within the acceptable range.
  • JCLCM0460E job-number job-name INVALID RECORG VALUE
    JCL error. The value specified for RECORG must be KS, ES, or RR.
  • JCLCM0461E job-number job-name INVALID DLM VALUE
    JCL error. The value specified for DLM is improperly coded.
  • JCLCM0462E job-number job-name INVALID AVGREC VALUE
    JCL error. The value specified for AVGREC is improperly coded or is not within the acceptable range.
  • JCLCM0463E job-number job-name TOO MANY LIBRARIES SPECIFIED
    JCL error. More than 15 libraries were specified on the JCLLIB statement.
  • JCLCM0464E job-number job-name INCLUDE NOT FOUND
    JCL error. The data set specified in the INCLUDE statement was not found.
  • JCLCM0465E job-number job-name DUPLICATE INSTREAM PROCEDURE
    JCL error. The instream procedure name is a duplicate of one already used.
  • JCLCM0466U job-number job-name INVALID JOBNAME
    JCL error. The job name specified is invalid.
  • JCLCM0467E job-number job-name CONFLICTING OR INCOMPATIBLE OPERANDS
    JCL error. Conflicting operands have been included on the JCL statement.
  • JCLCM0468E job-number job-name INVALID DSORG VALUE
    JCL error. The value specified for DSORG is improperly coded.
  • JCLCM0469I job-number job-name NONUNIQUE REFERENCE RESOLVED TO FIRST OCCURRENCE
    JCL error. This message indicates that there are multiple job steps with the same name as the referenced stepname.
  • JCLCM0470I job-number job-name NONUNIQUE REFERENCE RESOLVED TO CURRENT OCCURRENCE
    JCL error. This message indicates that there are multiple job steps with the same name as the referenced stepname.
  • JCLCM0471E job-number job-name OPERAND TABLE LIMIT EXCEEDED
    JCL error. The limit on the number of operands supported has been exceeded.
  • JCLCM0472E job-number job-name SYMBOL TABLE LIMIT EXCEEDED
    JCL error. The limit on the number of symbols supported has been exceeded.
  • JCLCM0473E job-number job-name INVALID NULL OPERAND VALUE
    JCL error. A keyword operand with no value was specified, but a value is required.
  • JCLCM0474E job-number job-name INVALID SYSOUT CLASS OPERAND
    JCL error. The SYSOUT class operand on the DD statement is improperly coded.
  • JCLCM0475I DD CHANGED TO DUMMY (DDNAME= MISSING)
    You have referenced a file for which there is no DDNAME statement.
  • JCLCM0476E job-number job-name Symbol "name" was not used
    The specified symbol is not used anywhere in the procedure. One explanation is that the symbol is misspelled.
  • JCLCM0477S More than 255 EXEC statements
  • JCLCM0486E Duplicate comma in action section of limitation type global SYSOUT limit
  • JCLCM0487E Global output limit number for limitation type too long
  • JCLCM0488E Closing bracket before action in limitation type global SYSOUT limit
  • JCLCM0489E No value decoded for limitation type global output limit
  • JCLCM0490E Error parsing numeric value for limitation type global SYSOUT limit
  • JCLCM0491E Invalid action parameter for limitation type global SYSOUT limit
  • JCLCM0499S job-number job-name FILE I/O ERROR OR FILE IS EMPTY
    There was an I/O error trying to read the referenced cataloged procedure or JCL included file, or the file is empty.
Parent topic: JCLCM Error Messages


CASST5024S

The specified PLTSD program list table was not present in the installed PPT.
System action:
PLT Processing is bypassed, shutdown continues.
Resolution:
None
Destination:
Console (and Terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


JCLAM0180 - JCLAM0230

  • JCLAM0180S Unexpected return code return-code from jseb-func-enq-ds
    Indicates an internal error detected by jseb-func-enq-ds.
  • JCLAM0181S Unexpected return code % from jseb-func-deq-ds
    Indicates an internal error detected by jseb-func-deq-ds.
  • JCLAM0182U Unexpected return code % from jseb-func-info-job
    Indicates an internal error detected by jseb-func-info-job.
  • JCLAM0183S Character set mismatch. Copied without conversion
    You are trying to copy an ASCII dataset to an EBCDIC one, or vice versa.
  • JCLAM0184I OS Copy used to perform this REPRO
    Informational only.
  • JCLAM0185S OS Copy operation for this REPRO failed with RC=return-code
  • JCLAM0186I Incompatible data set attributes. OSCOPY ignored.
    A full copy operation was done, instead of using the copy facility provided by the operating system as you requested.
  • JCLAM0221S Insufficient authority to define new dataset %
    Lack of permissions to perform this action.
  • JCLAM0222S Insufficient authority to read dataset %
    Lack of permissions to perform this action.
  • JCLAM0223S Insufficient authority to update dataset %
    Lack of permissions to perform this action.
  • JCLAM0224E Insufficient authority to delete dataset %
    Lack of permissions to perform this action.
  • JCLAM0225E Insufficient authority to alter/change dataset %
    Lack of permissions to perform this action.
  • JCLAM0226U Insufficient authority for SYSPRINT dataset %
    Lack of permissions to perform this action.
  • JCLAM0227U Insufficient authority for SYSIN dataset %
    Lack of permissions to perform this action.
  • JCLAM0228I Record n out of key sequence.
    The record has a key that is less than or equal to the key of the previous record.
  • JCLAM0229E Record n out of key sequence.
    The record has a key that is less than or equal to the key of the previous record.
  • JCLAM0230S Insufficient authority to use PCDSN dataset %
    Lack of permissions to perform this action.
Parent topic: JCLAM Error Messages


CASCD1040S

The ES Communication Server of ES region-name has exited, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


JCLAM0140 - JCLAM 0159

  • JCLAM0140I job-number job-name LASTCC set to number
    The condition code LASTCC has been set to the specified value.
  • JCLAM0141I job-number job-name MAXCC set to number
    The condition code MAXCC has been set to the specified value.
  • JCLAM0142S job-number job-name AVERAGE RECORD LENGTH INVALID
    The average record length must be greater than 0 bytes but not greater than 32760 bytes.
  • JCLAM0143S job-number job-name MAXIMUM RECORD LENGTH INVALID
    The maximum record length must be greater than 0 bytes but not greater than 32760 bytes.
  • JCLAM0144S job-number job-name KEY LENGTH INVALID
    The primary key length must be greater than 0 but not greater than 64.
  • JCLAM0145S job-number job-name KEY OFFSET INVALID
    The key offset plus the key length exceeds the defined record length.
  • JCLAM0146E job-number job-nameNUMBER DUPLICATE KEYS
    The specified number of duplicate keyed records have NOT been replaced by the REPRO command.
  • JCLAM0147W job-number job-name 00000000 DATASETS LISTED
    No datasets have been listed by the LISTCAT command.
  • JCLAM0148E job-number job-name NO MATCHING ENTRIES [ENTRYNAME]
    There are no entries in the catalog which match the pattern entry name specified for the delete request.
  • JCLAM0149S INVALID QUOTED LITERAL
    The literal contains an uneven number of quotation marks.
  • JCLAM0150S ERROR. FILE IS EMPTY
    You are trying to copy from an empty file.
  • JCLAM0151S job-number job-name Invalid dataclass name "name"
    The specified data class name is not legal or is longer than 8 characters.
  • JCLAM0152S job-number job-name Dataclass "name" does not exist
    This specified data class has not been defined to this system.
  • JCLAM0153S job-number job-name UNEXPECTED MVSSMS FUNC_GU RETCODE [number]
    Unexpected return code received from the MVSSMS (the data class manager).
  • JCLAM0154S job-number job-name THEN MUST FOLLOW AN IF COMMAND
    The IF command must be followed by the THEN keyword.
  • JCLAM0155I job-number job-name Remainder of command stream ignored
    The remainder of the command stream has been ignored.
  • JCLAM0156I job-number job-name CANCEL COMMAND EXECUTED
    The CANCEL command has been executed.
  • JCLAM0157S job-number job-name Space (CYL or TRK or REC) missing
    Space, using one of the specified keywords, must be specified for a new data set.
  • JCLAM0158S job-number job-name RECORG for input and output data set incompatible
    Either the output file is RRDS and is not empty, or the input file is not RRDS.
  • JCLAM0159S job-number job-name Primary quantity invalid
    The primary quantity is not a number.
Parent topic: JCLAM Error Messages


CASKC0006E

A CICS API server abended during a transaction. The transaction cannot be continued. The abend could not be handled directly by transaction system.
System action:
Start a new CICS API server.
Resolution:
Try running the transaction again. If the problem persists then the transaction is probably faulty. Contact the system administrator to get the problem resolved.
Destination:
Terminal
Module:
dfhgglbl
Parent topic: CASKC0000 - CASKC0015


CASXO0009S

The Resource manager for the XAT resource reported that due to a heuristic decision the work done on behalf of the transaction has been partially committed and partially rolled back.
System Action:
The state of the transaction is undefined
Resolution:
Contact your administrator for the resource
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


JCLAM0227U Insufficient authority for SYSIN dataset %

Lack of permissions to perform this action.

Resolution:

Contact your system administrator.

Parent topic: JCLAM0180 - JCLAM0230


CASCF0034S

An error occurred when writing the global configuration save file (gcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


JCLAM0231 -

  • JCLAM0231E Unable to acquire exclusive lock on dataset "dataset-name"
    The action requires an exclusive lock on the named dataset but was unable to obtain it.
Parent topic: JCLAM Error Messages


CASRD0034W

An attempt was made to install the resource-type entry resource-name from group group-name. The table defined is ZERO length.
System action:
Continue, the CVT definition is not installed. If a definition was previously installed, it remains active.
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASCF0037S

The directory specified by the CASLOCAL environment variable is invalid.
System Action:
Terminate the requesting process
Resolution:
Check that the directory that is specified in CASLOCAL is valid and retry
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASCD0152S

Region region-name has abended during normal execution due to receipt of signal signal-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASCD0003S

CAS was unable to run the COBOL RTS in the CAS daemon process A UNIX 'exec' call returned with errno set to errno
System Action:
The CAS daemon is not started
Resolution:
Correct the cause of the error and retry
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0001 - CASCD0015


CASCD0100 - CASCD0117

  • CASCD0100I
    The CAS Daemon has initialized and is waiting for work
  • CASCD0101I
    The CAS Daemon has completed termination
  • CASCD0102F
    The CAS Daemon has failed to initialize
  • CASCD0103E
    The CAS Daemon has received a message with an unknown request type of Request-Type
  • CASCD0104I
    The ES Daemon has initialized and is waiting for work
  • CASCD0110I
    The CAS Daemon is beginning a normal shutdown
  • CASCD0111I
    The CAS Daemon is beginning an orderly shutdown and will wait for the number-of-regions regions to terminate before shutting down
  • CASCD0112I
    The CAS Daemon is beginning an immediate shutdown and will abend number-of-regions regions before shutting down
  • CASCD0113I
    The CAS Daemon has terminated
  • CASCD0114W
    The CAS Daemon cannot begin a normal shutdown while there are regions running
  • CASCD0115E
    The CAS Daemon was already shutting down when this request was received
  • CASCD0116I
    The CAS Daemon was in a normal or orderly shutdown already, but will now shutdown immediately
  • CASCD0117S
    A UNIX call returned with errno set to errno during quiesce of the CAS Daemon.
Parent topic: CASCD Error Messages


C$NARG

Returns the number of parameters passed in the USING phrase of a CALL statement to the subprogram that contains the call to C$NARG.

Arguments specified explicitly as OMITTED in the USING list of the CALL statement are included in the count. The GIVING argument is not included in the count.

Note: When calling this routine, ensure you are using the 1024 calling convention.

Syntax:

CALL "C$NARG" USING parameter-count

Parameters:

parameter-count
PIC 9(3) BINARY, COMP-4 or COMP-1

On Exit:

parameter-count
The number of parameters passed.
Related reference
The CALL Statement
Related information
Call Conventions for Interfacing with Mixed Languages


CASCS1121I

The CAS CCI gateway successfully connected to the IBM Universal Client identified by netname remote-region. It is accessible via sysid sys-id. This system is the contention winner or the client side of the connection.
System action:
The connection is available for work.
Resolution:
None
Destination:
Console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASCS1014E

Outbound transaction routing of transaction trans-id failed because system system-id is marked out of service.
System Action:
The request is rejected
Resolution:
>Place the connection system-id in service and acquired
Destination:
user terminal and TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASCS1137S

An error occurred when reading the configuration save file.
System Action:
The CCI gateway will not initialize successfully
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


JCLCM0128S Host dataset %1$s unexpectedly deleted by alien job.

Explains purpose of topic. Written as sentence fragment. Contains no more than two sentences.
Parent topic: JCLCM0000 - JCLCM0199


CASST4102E

The shutdown request was rejected because the system was already in shutdown or was never successfully started.
System action:
None
Resolution:
None
Destination:
Console (and Terminal)
Module:
dfhzcqit
Parent topic: CASST4000 - CASST4111


JCLCM0130W LRECL of host RECFM V dataset %1$s assumed to be 255.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0129W LRECL of host RECFM F dataset %1$s assumed to be 80.

Parent topic: JCLCM0000 - JCLCM0199


CASFD0011I

The output from the offline dump/trace format request was written to the output file output-file-name.
System action:
None
Resolution:
None
Destination:
Standard error.
Module:
dfhgdup
Parent topic: CASFD0001 - CASFD0014


CASCF0013S

The global configuration file ($CASDIR/dfhtx.cfg) could not located.
System Action:
Terminate the requesting process
Resolution:
Make sure that $CASDIR is set correctly and that the configuration file exists
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0001 - CASCF0015


CASCS1004S

Inbound allocate for transaction trans-id failed because it could not acquire sufficient process storage to store the transmitted data.
System Action:
The transaction is abnormally terminated
Resolution:
This server will likely continue to fail. It should be terminated and restarted.
Destination:
TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


Objects - in COBOL and C#

Objects in Managed COBOL

01 hero  type SuperHero value new SuperHero.
01 hero2 type SuperHero.
01 obj object.
01 reader type StreamReader.
01 myLine string.

set hero::Name to SpamMan
set hero::PowerLevel to 3

invoke hero::Defend("Laura Jones")
invoke type SuperHero::Rest   *> Calling static method

set hero2 to hero     *> Both reference the same object
set hero2::Name to "WormWoman"
display hero::Name    *> Prints WormWoman

set hero to null      *> Free the object

if hero = null
    set hero to new SuperHero
end-if

set obj to new SuperHero
if obj is instance of type SuperHero
    display "Is a SuperHero object."
end-if

*> No 'using' construct in COBOL
try
    set reader to type File::OpenText("test.txt")
    perform until exit
        set myLine to reader::ReadLine
        if myLine = null
            exit perform
        end-if
    end-perform
finally
    if reader not = null
        invoke reader::Dispose
    end-if
end-try

Objects in C#

SuperHero hero = new SuperHero();

hero.Name = "SpamMan";
hero.PowerLevel = 3;

hero.Defend("Laura Jones");
SuperHero.Rest();   // Calling static method

SuperHero hero2 = hero;   // Both reference the same object
hero2.Name = "WormWoman";
Console.WriteLine(hero.Name);   // Prints WormWoman

hero = null ;   // Free the object

if (hero == null)
  hero = new SuperHero();

Object obj = new SuperHero();
if (obj is SuperHero)
{
  Console.WriteLine("Is a SuperHero object.");
}

// Mark object for quick disposal
using (StreamReader reader = File.OpenText("test.txt"))
{
  string line;
  while ((line = reader.ReadLine()) != null)
  {
    Console.WriteLine(line);
  }
}
Related reference
Classes
INVOKE Statement
SET Statement
Related information
Invoking a Method


CASST0016E

While attempting to shutdown a region an error occurred trying to submit the shutdown request
System action:
As the shut down program cannot attach to the region the region cannot be shutdown.
Resolution:
A forced region shutdown may be required.
Destination:
Console
Module:
casstop
Parent topic: CASST0000 - CASST0020


C$GetEnv

Returns the value of an environment variable.
Note: When calling this routine, ensure you are using the 1024 calling convention.

Syntax:

CALL "C$GetEnv" USING name, value [, return]

Parameters:

name
PIC X(n)
value
PIC X (n)
return
PIC 9(n) BINARY, where n can be a digit from 1 to 9

On Entry:

name
The name of the environment variable.

On Exit:

value
The value of the environment variable, returned from the call.
return
The result code returned from the call: zero for success and non-zero for failure.

Comments:

On UNIX, environment variable names are case-sensitive. On Windows, environment variable names are not case-sensitive.

Related information
Call Conventions for Interfacing with Mixed Languages


JCLUT0010E

Message

INPUT DD(%1$s) on DSD CARD not found

Where %1$s is Dataset name.

Message Information

The INPUT dataset specified on the DSD card could not be found.

Resolution

Check for a missing DD card defining the dataset or a mismatch of dataset names.

Parent topic: JCLUT Error Messages


CASKC0002E

The system supplied module "dfhzplt.gnt" was not accessible.
System action:
The region is terminated immediately.
Resolution:
Correct the setup of the region such that the module can be loaded and re-start the region.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0000 - CASKC0015


CASCD0050I

The region initiation has been started. Client connection will not be immediately available. Check the console log to determine if the region completed initiation successfully.
System Action:
None
Resolution:
None
Destination:
standard error
Module:
dfhrem
Parent topic: CASCD0050 - CASCD0099


JCLCM0122S Incorrect password caused SAF failure on the host.

Parent topic: JCLCM0000 - JCLCM0199


CASCF0041S

The system files directory ($CASDIR/files/sys) is invalid.
System Action:
Terminate the requesting process
Resolution:
Check that CASDIR is correct and the directory exists
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASCS1107W

The CAS CCI gateway failed to connect to remote-region. The reason-codeis the CCI protocol return code.
System Action:
The connection is marked as inactive
Resolution:
Check that the remote-region is active and that the system has a network path to remote-region for the protocol specified
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASST0001I

The region manager has completed its termination phase
System Action:
All shared memory and semaphores were removed successfully
Resolution:
None
Destination:
console
Module:
dfhgterm
Parent topic: CASST0000 - CASST0020


CASKC0027E

A message has been generated processing a service.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


CASCS1116I

The signature check string for CCI protocol support module module-nameis CCI-signature-string. This is a documentation message.
System Action:
The CCI gateway will continue initialization
Resolution:
None
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASRD0004I

Group group-name install is initiated from terminal or facility facility-id.
System action:
Continue operation
Resolution:
None
Destination:
console, TD queue CRDI
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


CASCD0137W

The CAS Daemon process created a child process which could failed in initialization due to a failed 'execlp' call.
System Action:
Terminate the child process
Resolution:
Determine and fix cause of failure then retry
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASST4000I

A request to shutdown the Micro Focus Transaction System has been entered using either the CQIT transaction or the PERFORM SHUTDOWN command.
System action:
Shutdown processing is started.
Resolution:
None
Destination:
Console (and Terminal)
Module:
dfhzcqit
Parent topic: CASST4000 - CASST4111


Comparison of COBOL with Other Managed Languages

The following topics show examples of various programming techniques and constructs in COBOL compared with C#.

Related reference
Access Modifiers


CASCD0169S

The CAS gateway for region region-name has abended due to the unexpected signal signal-value.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0160 - CASCD0175


CASCD0174I

The ES Console thread that handles process terminations has exited normally.
System Action:
None
Resolution:
None
Destination:
system console
Module:
cascd
Parent topic: CASCD0160 - CASCD0175


CASKC0005W

The region manager attempted to close a CICS server process and received an error. This may be due to a lack of shared memory.
System action:
Increment AMAX.
Resolution:
Try decreasing the value of AMAX so ascertain whether the problem is permanent.
Destination:
System Console and standard error.
Module:
dfhgglbl
Parent topic: CASKC0000 - CASKC0015


CASCD0004S

CAS failed to create named pipe 'pipe-name' which was to be used for communication with the CAS daemon. A UNIX 'mknod' call returned with errno set to errno
System Action:
The CAS daemon is not started
Resolution:
Correct the cause of the error and retry
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0001 - CASCD0015


CASCS1501I

The CAS gateway has started shutdown processing.
System Action:
None
Resolution:
None
Destination:
console
Module:
hydra
Parent topic: CASCS1500 - CASCS2004


CASCD0024S

Too many arguments were specified, the maximum permitted is 1.
System Action:
The request is rejected
Resolution:
Retry the request with the correct number of arguments
Destination:
standard error
Module:
dfhtxp
Parent topic: CASCD0016 - CASCD0031


CASST5002S

The Resource Definition file could not be opened to read the PLTSD program list table.
System Action:
PLT Processing is bypassed, shutdown continues
Resolution:
None
Destination:
console (and terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASKC6005I

An IMS transaction exceeded its time threshold and is still running.
System action:
Warning message logged.
Resolution:
Investigate why threshold was exceeded
Destination:
System Console
Module:
casmgr
Parent topic: CASKC5006 - CASKC6006


CASRD1039E

A request to add, update or delete a service failed due to an unrecognised service definition.
System action:
Reject the administration request.
Resolution:
Check the CAS components are compatible.
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


CASKC0001E

Transaction trans-id abnormally terminated with abend code abend-code. A abend-description will be supplied for standard CICS API exception ABENDs.
System action:
The transaction is terminated and protected resources are returned to the state they were in at the start of the failing transaction.
Resolution:
Correct the cause of the abnormal termination and re-submit the request.
Destination:
User terminal, TDQ CSMT and console.log.
Module:
dfheserv
Parent topic: CASKC0000 - CASKC0015


CASKC5006 - CASKC6006

  • CASKC5006I
    The SEP, Batch Initiator or IMS MPR process issued a message. The text is message.
  • CASKC6001S
    A process was looping or hung and exceeded the specified task timeout. The attempt to kill the process aparently has failed to remove the process.
  • CASKC6002I
    A process was looping or hung and exceeded the specified TIME parameter on the JOB or STEP card.
  • CASKC6003I
    A transaction exceeded its time threshold and is still running.
  • CASKC6004I
    A transaction completed but exceeded its time threshold.
  • CASKC6005I
    An IMS transaction exceeded its time threshold and is still running.
  • CASKC6006I
    Time taken by the web service application was greater than ES_WS_RUNAWAY_TIMEOUT
Parent topic: CASKC Error Messages


CASXO0008S

The Resource manager for the XAT resource reported that due to a heuristic decision the work done on behalf of the transaction has been rolled back.
System Action:
The state of the transaction is undefined
Resolution:
Contact your administrator for the resource
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


CASST5000 - CASST6002

  • CASST5000I
    Shutdown PLT processing has started using the plt-name list.
  • CASST5001I
    Shutdown PLT processing was entered, but no list was specified.
  • CASST5002S
    The Resource Definition file could not be opened to read the PLTSD program list table.
  • CASST5003S
    The specified PLTSD program list table could not be found in the Resource Definition file.
  • CASST5004S
    The specified PLTSD program list table was not present in the installed PPT.
  • CASST5005S
    A transaction program abend occurred in the program program of the plt-name list during Phase 2 PLTSD processing.
  • CASST5006S
    The named program specified could not be found and resulted in a PGMIDERR.
  • CASST5010I
    Shutdown PLT processing has completed successfully using the plt-name list.
  • CASST5020I
    Shutdown Phase 2 PLT processing has started using the plt-name list.
  • CASST5021I
    Shutdown Phase 2 PLT processing was entered, but no list was specified.
  • CASST5022S
    The Resource Definition file could not be opened to read the PLTSD program list table.
  • CASST5023S
    The specified PLTSD program list table could not be found in the Resource Definition file.
  • CASST5024S
    The specified PLTSD program list table was not present in the installed PPT.
  • CASST5025S
    A transaction program abend occurred in the program program of the plt-name list during Phase 2 PLTSD processing.
  • CASST5026S
    The named program specified could not be found and resulted in a PGMIDERR.
  • CASST5030I
    Shutdown Phase 2 PLT processing has completed successfully using the plt-name list.
  • CASST5201I
    The spool service has terminated normally
  • CASST5230I
    The Event Process is terminating.
  • CASST5231I
    The Event Manager Process has terminated.
  • CASST6002I
    The MQSeries trigger monitor program (CKTI) has disconnected from the queue manager and is terminating
Parent topic: CASST Error Messages


Strings - in COBOL and C#

Strings in Managed COBOL

*> Escape sequences
x"0a"  *> line-feed
x"09"  *> tab
"\"    *> backslash
""     *> quote

*> String concatenation
01 school string value "Harding" & x"09".
   *> school is "Harding (tab) University"
   set school to school & "University"

*> Chars
01 letter character.
01 word character occurs any.
    set letter to school::Chars(0)         *> letter is H
    set letter to type Convert::ToChar(65) *> letter is A
    set letter to 65 as character          *> same thing
    set word to school::ToCharArray        *>word holds Harding

*> String literal
01 msg string value "File is c:\temp\x.dat".

*> String comparison
01 mascot string value "Beatles".
    if mascot = "Beatles"                    *> true
    if mascot::Equals("Beatles")             *> true
    if mascot::ToUpper::"Equals"("BEATLES")  *> true
    if mascot::CompareTo("Beatles") = 0      *> true

*> Substring
    set s to mascot::Substring(1, 3) *> s is "eat"

*> Replacement
    set s to mascot::Replace("Beatl" "Monke")  *> s is "Monkees"

*> Split
01 names string value "John,Paul,George,Ringo".
01 parts string occurs any.
    set parts to names::Split(",")

*> Date to string
01 dt type DateTime value new DateTime(1973, 10, 12).
01 s string.
    set s to dt::ToString("MMM dd, yyyy")  *> Oct 12, 1973

*> int to string
01 x string.
01 y binary-long value 2.
    set x to type x::ToString   *> x is "2"

*> string to int
01 x binary-long.
    set x to type Convert::ToInt32("-5")   *> x is -5

*> Mutable string
01 buffer type System.Text.StringBuilder
        value new System.Text.StringBuilder("two ").
    invoke buffer::Append("three ")
    invoke buffer::Insert(0, "one ")
    invoke buffer::Replace("two" "TWO"
    display buffer             *> Prints "one TWO three"

Strings in C#

// Escape sequences
\r    // carriage-return
\n    // line-feed
\t    // tab
\\    // backslash
\"    // quote

// String concatenation
string school = "Harding\t";
school = school + "University"; // school is "Harding (tab) University"

// Chars
char letter = school[0];              // letter is H
letter = Convert.ToChar(65);          // letter is A
letter = (char)65;                    // same thing
char[] word = school.ToCharArray();   // word holds Harding

// String literal
string msg = @"File is c:\temp\x.dat";
// same as
string msg = "File is c:\\temp\\x.dat";

// String comparison
string mascot = "Beatles";
if (mascot == "Beatles")                 // true
if (mascot.Equals("Beatles"))            // true
if (mascot.ToUpper().Equals("BEATLES"))  // true
if (mascot.CompareTo("Beatles") == 0)    // true

// Substring
s = mascot.Substring(1, 3))     // s is "eat"

// Replacement
s = mascot.Replace("Beatl", "Monke")) // s is "Monkees"

// Split
string names = "John,Paul,George,Ringo";
// One name in each slot
string[] parts = names.Split(",".ToCharArray());

// Date to string
DateTime dt = new DateTime(1973, 10, 12);
string s = dt.ToString("MMM dd, yyyy");     // Oct 12, 1973

// int to string
int x = 2;
string y = x.ToString();     // y is "2"

// string to int
int x = Convert.ToInt32("-5");     // x is -5

// Mutable string
System.Text.StringBuilder buffer =
    new System.Text.StringBuilder("two ");
buffer.Append("three ");
buffer.Insert(0, "one ");
buffer.Replace("two", "TWO");
Console.WriteLine(buffer);     // Prints "one TWO three"
Related information
String Handling in Managed COBOL


CASCS1502W

The CAS gateway failed to initialize successfully.
System Action:
None
Resolution:
None
Destination:
console
Module:
hydra
Parent topic: CASCS1500 - CASCS2004


CASRD1002I

The service was deleted successfully.
System action:
None.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1000 - CASRD1015


CASCD0116I

The CAS Daemon was in a normal or orderly shutdown already, but will now shutdown immediately
System Action:
Immediate shutdown
Resolution:
None
Destination:
standard error
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


JCLCM0125E %1$s is not supported.

Parent topic: JCLCM0000 - JCLCM0199


CASKC0014E

The system attempted to read an MQ queue record from the queue queue-name. The read opperation failed to return a record.
System action:
Transaction aborted.
Resolution:
Resolve the configuration mismatch and restart the associated ASEE iniation queue listener.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0000 - CASKC0015


CASCD1068I

An Animserv process for Server server-name has successfully terminated
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


SORT100 - SORT199

  • SORT100E job-number job-name MISSING OPERATOR
    The SYSIN command statement does not contain a valid operator.
  • SORT101E job-number job-name MALFORMED OPERATOR
    The SYSIN command statement operator (at the specified column) is invalid. A space must separate the operator from any operands.
  • SORT102E job-number job-name EXPECTED OPERAND MISSING
    A required operand is not present on the command statement.
  • SORT103E job-number job-name INVALID OPERATOR 'OPERATOR'
    The command statement operator (at the specified column) is invalid.
  • SORT104E job-number job-name INVALID OPERAND KEYWORD 'OPERAND'
    The command statement operand (at the specified column) is invalid.
  • SORT105E job-number job-name EXPECTED CONTINUATION NOT PRESENT
    The command statement contains a continuation character in column 72, but the continuation text has not been found.
  • SORT106E job-number job-name FIELD FORMATS IMPROPERLY SPECIFIED
    The field format is incorrectly coded as a field-specific operand (for example, FIELDS=1,5,CH,A) and also as a global operand (for example, FORMAT=CH).
  • SORT107E job-number job-name FIELD FORMAT 'FORMAT' INVALID
    The specified field format (at the specified column) is invalid. Valid field formats are AQ, BI, CH, FI, ZD, and PD.
  • SORT108E job-number job-name SEQUENCE 'SEQUENCE' INVALID
    The sequence operand (at the specified column) must be A or D for ascending or descending sequences respectively.
  • SORT109E job-number job-name TOO MANY FIELDS SPECIFIED
    Control fields are limited to 16.
  • SORT110E job-number job-name NON-NUMERIC DATA DETECTED
    Numeric data is expected at the specified column.
  • SORT111E job-number job-name 'OPERATOR' OPERATOR ALREADY PROCESSED
    The specified operator (at the specified column) has already been processed.
  • SORT112E job-number job-name 'EXIT'' EXIT NOT SUPPORTED
    The specified exit (at the specified column) is not supported. Only the E15 and E35 exits are supported by MFJSORT.
  • SORT114E job-number job-name EXPECTED '(' NOT FOUND
    A left parenthesis is expected at the specified column but has not been found.
  • SORT115E job-number job-name BOOLEAN OPERATOR 'OPERATOR' INVALID
    The specified Boolean operator (at the specified column) is invalid. Valid Boolean operators are EQ, NE, LT, LE, GT, and GE.
  • SORT118E job-number job-name SORT / MERGE CONFLICT
    Both SORT and MERGE commands have been found; only one can be specified. The second command is at the specified column.
  • SORT119E job-number job-name INCLUDE / OMIT CONFLICT
    Both INCLUDE and OMIT commands have been found; only one can be specified. The second command is at the specified column.
  • SORT120E job-number job-name SORT STATEMENT MISSING FIELDS OPERAND
    The SORT command statement does not contain a FIELDS operand.
  • SORT121E job-number job-name MERGE STATEMENT MISSING FIELDS OPERAND
    The MERGE command statement does not contain a FIELDS operand.
  • SORT122E job-number job-name INCLUDE STATEMENT MISSING COND OPERAND
    The INCLUDE command statement does not contain a COND operand.
  • SORT123E job-number job-name OMIT STATEMENT MISSING COND OPERAND
    The OMIT command statement does not contain a COND operand.
  • SORT124E job-number job-name FIELD POSITION 'NUMBER' INVALID
    The specified field position is invalid. Field positions can start at 1 but must not exceed the length of the SORTIN record, allowing for the length of the control field.
  • SORT125E job-number job-name FIELD LENGTH 'NUMBER' INVALID
    The field length specified is too long. Control fields are limited to 1024 bytes in length. Byte(.bit) notation is not supported.
  • SORT126E job-number job-name RECORD LENGTH 'NUMBER'' INVALID
    The specified record length is invalid. Record lengths may not exceed 32768 bytes.
  • SORT127E job-number job-name MISSING SORT/MERGE/COPY COMMAND STATEMENT
    A SORT, MERGE, or COPY command statement is required.
  • SORT128E job-number job-title EXPECTED ')' NOT FOUND
    A closing parenthesis ')' was expected and not found.
  • SORT129E job-number job-name EXPECTED '=' NOT FOUND
    '=' was expected and not found.
  • SORT130E job-number job-name EXPECTED 'F' OR 'V' NOT FOUND
    Either F or V must be specified to indicate recording mode (non-emulation mode).
  • SORT131E job-number job-name EXPECTED 'IX', 'RL', 'SQ', OR 'LS' NOT FOUND
    Organization must be specified as either IX, RL, SQ or LS (non-emulation mode).
  • SORT132E job-number job-name PRIME KEY MUST BE SPECIFIED FIRST
    When specifying keys for a USE OR GIVE indexed file (non-emulation mode), the prime key must be specified first.
  • SORT133E job-number job-name EXPECTED 'P', 'AD', 'A', OR 'C' NOT FOUND
    Key type for a USE OR GIVE indexed file must be specified as one of P (primary), AD (alternate permitting duplicates) A (alternate not permitting duplicates) or C (component).
  • SORT134E job-number job-name KEYWORD/VALUE 'VALUE' INVALID FOR DFSORT EMULATION
    The specified keyword is not valid for DFSORT emulation.
  • SORT135E job-number job-name KEYWORD/VALUE 'VALUE' INVALID FOR SYNCSORT EMULATION
    The specified keyword is not valid for SYNCSORT emulation.
  • SORT136E job-number job-name NO GIVE FILE SPECIFIED FOR OUTFIL GROUP
    No GIVE file has been specified for the current OUTFIL group (non-emulation mode).
  • SORT137E job-number job-name NO USE FILE SPECIFIED
    No USE file has been specified for the SORT (non-emulation mode).
  • SORT138E job-number job-name TARGET LITERAL 'LITERAL' TOO LONG IN CHANGE
    The set-constant in a CHANGE statement must not be longer than the specified length of the output field to be inserted (v).
  • SORT139E job-number job-name SUBSTRING COMPARISON MUST BE WITH CHARACTER LITERAL
    The right-hand side of a substring comparison must be a character literal.
  • SORT140E job-number job-name INVALID BINARY DIGIT DETECTED
    An invalid digit has been found in a binary literal. Valid digits are 0 and 1.
  • SORT141E job-number job-name CANNOT SPECIFY SAVE WITH EITHER INCLUDE OR OMIT
    Only one of INCLUDE, OMIT or SAVE may be specified for any OUTFIL group.
  • SORT142E job-number job-name REPEATED FILES= OR FNAMES=
    Only one of FILES= or FNAMES= may be specified for any OUTFIL group.
  • SORT191I job-number job-name OPERATOR 'OPERATOR' IGNORED
    The specified operator (at the specified column) is not supported and has been ignored. Processing continues without error.
  • SORT192I job-number job-name OPERAND 'OPERAND' IGNORED
    The specified operand (at the specified column) is not supported and has been ignored. Processing continues without error.
  • SORT193E job-number job-name INVALID HEX DIGIT DETECTED
    An hexadecimal digit (0 - 9 or A - F) is expected at the specified column but has not been found.
  • SORT194I job-number job-name NO ALTSEQ COMMAND SPECIFIED FOR 'AQ' SORT FIELD FORMATS; 'CH' ASSUMED
    A SORT control field requests an alternate collating sequence but no ALTSEQ command statement is specified. The standard collating sequence has been used instead. Processing continues without error.
  • SORT195I job-number job-name SORTWORK DIRECTORY 'DIRECTORY' IS INVALID; USING CURRENT DIRECTORY
    The MFJWORK or TEMP environment variable does not contain a valid device or directory path. The current directory has been used for temporary files instead. Processing continues without error.
  • SORT196E job-number job-name SUM / COPY CONFLICT
    The SUM command (at the specified column) cannot be used when the FIELDS=COPY statement is in effect.
  • SORT197E job-number job-name INREC / MERGE CONFLICT
    The INREC command (at the specified column) cannot be used with MERGE operations.
  • SORT198E job-number job-name NON-NUMERIC DATA DETECTED IN 'ZD' SUM FIELD
    Non-numeric data has been found in a field specified as zoned decimal.
  • SORT199E job-number job-name TOO MANY OUTFIL STMTS OR TOO MANY FIELDS ON OUTFIL STMT(S)
    More than 16 SORTOFnn files are specified by the OUTFIL command(s).
Parent topic: SORT - MFJSORT Error Messages


CASCD0062S

An attempt has been made to start a server before there is an active CAS Daemon
System Action:
The server is not started
Resolution:
Start an CAS Daemon before attempting to start other components
Destination:
standard error
Module:
dfhserv
Parent topic: CASCD0050 - CASCD0099


CASST0017E

While attempting to shutdown a region with option force the request has been rejected because the region security is on
System action:
The region cannot be shutdown.
Resolution:
Use other system OS tools for terminating the region
Destination:
Console
Module:
casstop
Parent topic: CASST0000 - CASST0020


CASCS1103E

An error occurred allocating local process storage. The process has exceeded the available address space. There are too many clients or traffic buffering is backed up in the gateway process.
System Action:
The requested registration is rejected
Resolution:
Reduce the gateway loading
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASXO0023S

A severe error occured interfacing with the XA Resouce Manager.
System Action:
The XA Resource Manager will not be called for future transactions
Resolution:
Determine the cause of the failure and re-enable it
Destination:
console
Module:
dfheserv
Parent topic: CASXO0016 - CASXO0026


CASCD1043I

The IMS DB Control Process has been started for Server server-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


CASSP0014S

The process terminated due to a COBOL RTS error.
System action:
Depending on the process type the system will restart the process.
Resolution:
None
Destination:
Console and standard error.
Module:
cascperr
Parent topic: CASSP0001 - CASSP0014


CASRD1010I

The request handler was added successfully.
System action:
None.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1000 - CASRD1015


CASRD1036E

An unsuccessful request was made to update the named package. return-code values
System action:
No updates made.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


CASRD0010E

The resource definition for resource-type entry resource-name from group group-name failed to install. The reason is reason-code. Reason codes are return codes.
System action:
Continue, the current resource is not installed.
Resolution:
Review the group definition and the table manager return code and take appropriate corrective action.
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


CASCD1037S

The Spool service of region region-name has exited, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


CASRD1000I

The service was added successfully.
System action:
None.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1000 - CASRD1015


CASFD0004S

The offline dump requester failed in its attempt to change to the root Transaction System directory.
System action:
The dump request is ignored
Resolution:
Correct the CASDIR specification and retry the operation.
Destination:
Console and standard error.
Module:
dfhgtrtd
Parent topic: CASFD0001 - CASFD0014


CASCF0042S

The region's base directory ($REGIONBASE/$CASREGN) in invalid.
System Action:
Terminate the requesting process
Resolution:
Check that region name is correct and the directory exists
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASRD0021E

The resource definition for terminal resource-name is not installable. The existing installed definition is not replaceable.
System action:
Continue, the group will not be installed.
Resolution:
None
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASCD1061S

An undefined process request was received for Server server-name
System Action:
Continue
Resolution:
Evaluate the impact of the error and take approprate action
Destination:
Console and standard error
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


CASCD0101I

The CAS Daemon has completed termination
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


CASFD0002S

The offline dump requester failed in its attempt to contact the region.
System action:
The dump request is ignored
Resolution:
Check that the region is active.
Destination:
Console and standard error.
Module:
dfhgtrtd
Parent topic: CASFD0001 - CASFD0014


CASST0005I

The shutdown program is starting to shutdown the region.
System Action:
Start shutting down the region
Resolution:
None
Destination:
console
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


JCLCM0126E %1$s is not yet supported.

Parent topic: JCLCM0000 - JCLCM0199


CASCD0141S

Region region-name has failed to initialize and exited, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASXO0021I

The XA resource manager's switch module contained appropriate support for local transactions.
System Action:
None
Resolution:
None
Destination:
console
Module:
dfhexa
Parent topic: CASXO0016 - CASXO0026


CASRD0008I

The resource definition for resource-type entry resource-name from group group-name has replaced the previous definition in the current system.
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


CASKC0043E

Transaction trans-id abnormally terminated with abend code ASRA.
System action:
The transaction is terminated and protected resources are returned to the state they were in at the start of the failing transaction.
Resolution:
Correct the cause of the abnormal termination and re-submit the request.
Destination:
User terminal ,TDQ CSMT and console.log.
Module:
dfhebms
Parent topic: CASKC0031 - CASKC0045


CASCD0138F

CAS attempted to exec dfhgrtrm, but the call failed with errno errno
System Action:
Terminate the new process and abort the attempt to terminate a region. The region will continue to run.
Resolution:
Determine and fix cause of failure then retry
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASST4010I

Shutdown processing has begun using the indicated PLT.
System action:
PLTSD Processing is started, shutdown proceeding normally.
Resolution:
None
Destination:
Console (and Terminal)
Module:
dfhzcqit
Parent topic: CASST4000 - CASST4111


CASCF0029S

An error occurred when reading the region configuration save file (rcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASCF0012S

An unrecognized line was found in the development configuration file (dfhtxdev.cfg) at the line shown.
System Action:
Terminate the requesting process
Resolution:
Correct the fault with the configuration file ensuring that the line contains a valid configuration item
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0001 - CASCF0015


CASCS1123I

The client has made a connction request either from a machine with which a connection already exists or presenting a netname which is already in use.
System action:
Resolution:
Destination:
Console
Module:
casgate
Parent topic: CASCS1116 - CASCS1138


CASRD1000 - CASRD1015

  • CASRD1000I
    The service was added successfully.
  • CASRD1001I
    The service was updated successfully.
  • CASRD1002I
    The service was deleted successfully.
  • CASRD1005E
    An unsuccessful request was made to add the named service. return-code values
  • CASRD1006E
    An unsuccessful request was made to update the named service. return-code values
  • CASRD1007E
    An unsuccessful request was made to delete the named service. return-code values
  • CASRD1008I
    An unrecognized administration request was made for the named service.
  • CASRD1010I
    The request handler was added successfully.
  • CASRD1011I
    The request handler was updated successfully.
  • CASRD1012I
    The request handler was deleted successfully.
  • CASRD1015E
    An unsuccessful request was made to add the named request handler. return-code values
Parent topic: CASRD Error Messages


CASCS1136S

An error occurred when creating the configuration save file.
System Action:
The CCI gateway will not initialize successfully
Resolution:
Check directory permissions and disk space
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASRD0005E

Validation errors were found when preparing to install group group-name. The error messages are written to TS queue TS-queue-name. These messages may be reviewed with the utility transaction CEBR.
System action:
The install request is rejected
Resolution:
Verify that the proper group is being installed, correct any errors noted in the detail messages in TS queue TS-queue-name.
Destination:
terminal, console, TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


C$Delay

Relinquishes the CPU for a length of time specified in seconds.
Note: When calling this routine, ensure you are using the 1024 calling convention.

This library routine allows other programs to run while the current program waits.

Syntax:

CALL "C$Delay" USING seconds

Parameters:

seconds
PIC 9(n)v999, where n is a digit from 1 to 7

On Entry:

seconds
The number of seconds.

Comments:

The amount of delay is not exact. It depends upon the particular machine configuration and the load on the machine.
Related information
Call Conventions for Interfacing with Mixed Languages


C$SetEnv

Sets or clears the value of an environment variable.
Note: When calling this routine, ensure you are using the 1024 calling convention.

Setting the value of an environment variable with C$SetEnv updates the corresponding environment variable immediately in the process space of the current run unit. Thus, when the RM/COBOL runtime system uses environment variables for such actions as file access name resolution, the call to C$SetEnv will have an immediate effect on that run unit.

Syntax:

CALL "C$SetEnv" USING name, value [, return]

Parameters:

name
PIC X(n)
value
PIC X(n)
return
PIC 9(n) BINARY, where n can be a digit from 1 to 9

On Entry:

name
The name of the environment variable to set or clear.
value
The value to which the environment variable is set. A value of SPACES indicates that the environment variable should be deleted.

On Exit:

return
The result code returned from the call: zero for success and non-zero for failure.

Comments:

On UNIX, environment variable names are case-sensitive. On Windows, environment variable names are not case-sensitive.

Related information
Call Conventions for Interfacing with Mixed Languages


ILSMARTNEST

Use in conjunction with ILSMARTLINKAGE, to expose the Linkage Section items and entry points to managed code as nested classes of the program class in which they are defined.
Restriction: This directive is supported for managed COBOL only.

Syntax:

>>-.---.-.----.-ILSMARTNEST------><
   +-\-+ +-NO-+

Properties:

Default: | NOILSMARTNEST
Phase: | Syntax check
$SET: | Any

Comments:

By creating nested classes, programs within the same compilation unit can have linkage records with the same name.

Example:

The following COBOL program is compiled with ILSMARTLINKAGE, ILSMARTNEST, ILCUTPREFIX(lnk-b-) and ILCUTPREFIX(lnk-):

       program-id. BookLegacy.
                         ...
       linkage section.
       01 lnk-function            pic x.
       01 lnk-b-details.
          03 lnk-b-text-details.
             05 lnk-b-title       pic x(50).
             05 lnk-b-type        pic x(20).
             05 lnk-b-author      pic x(50).
          03 lnk-b-stockno        pic x(4).
          03 lnk-b-retail         pic 99v99.
          03 lnk-b-onhand         pic 9(5).
       procedure division using by value lnk-function
                                by reference lnk-b-details.

In C#, you can access the data in BookLegacy program in .NET COBOL as follows:

    BookLegacy myBook = new BookLegacy();
         //creates an object corresponding to the BookLegacy program
    BookLegacy.Details myDetails = new Details();
         //creates an instance corresponding to the group lnk-b-details
    . . .
       myDetails.Stockno = "6666";
       myDetails.Title = "Managed COBOL";
       myDetails.Author = "Mike Focus";
       myDetails.Type = "Reference";
       myDetails.Retail = 15.50M;
       myDetails.Onhand = 20;
       myDetails.Sold = 5;
       myBook.BookLegacy("2", myDetails);
         // calls the BookLegacy method with myDetails,
         // which corresponds to the group item lnk-b-details
See the C# WinBook demonstration in the Studio Enterprise Edition samples for more.
Note: The C# program and form needs amending, to refer to BookLegacy.Details, when compiling with the ILSMARTNEST Compiler directive set.
Related reference
ILSMARTLINKAGE
ILSMARTRESTRICT


CASCD0125I

CAS attempted to exec executable-name, but the call failed with errno errno
System Action:
Terminate the new process and abort the attempt to start a REM or server
Resolution:
Determine and fix cause of failure then retry
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASSP0011S

A syncpoint was requested and attempted against the configured resource managers. A bad response was returned and the resource managers were rolledback to the previous syncpoint.
System action:
The transaction will abend.
Resolution:
Investigate why the syncpoint failed.
Destination:
Console and standard error.
Module:
dfhesync
Parent topic: CASSP0001 - CASSP0014


Synchronization - in COBOL and C#

Synchronization in Managed COBOL

*> Synchronize on an object's monitor, in this case
*> the current object
sync on self
   *> The code here is synchronized
end-sync

Synchronization in C#

// Synchronize on an object's monitor, in this case
// the current object
lock (this)
{
    // The code here is synchronised
}
Related reference
SYNC Statement


CASKC0041E

Transaction trans-id abnormally terminated with abend code abend-code. A abend-description will be supplied for standard CICS API exception ABENDs.
System action:
The transaction is terminated.
Resolution:
Correct the cause of the abnormal termination and re-submit the request.
Destination:
console.log
Module:
dfhgglbl
Parent topic: CASKC0031 - CASKC0045


CASXO0017S

An unrecoverable error occured interfacing with the XA Resouce Manager.
System Action:
The XA Resource Manager will not be called for future transactions
Resolution:
Determine the cause of the failure and restart the system
Destination:
console
Module:
dfhexa
Parent topic: CASXO0016 - CASXO0026


CASXO0001S

The Resource manager for the XAT resource returned a non-zero value to the xa_open call. Where the return code means :

The return codes are:

  • -1 An error occured in the transaction manager
  • -2 Asynchronous operation already outstanding
  • -3 A resource manager error occurred
  • -4 The XID is not valid
  • -5 Invalid arguments were given
  • -6 Routine invoked in an improper context
  • -7 Resource Manager unavailable
  • -8 the XID already exists
  • -9 Resource Manager doing work outside global transaction
System Action:
The region will not start
Resolution:
Check that the Database Manager has been started, if necessary
Destination:
console and standard error
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


CASCF0026S

An error occurred when opening the region configuration file ($REGIONBASE/$CASREGN/dfhtx.cfg).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASST4020I

The PLTSD Phase 1 processing has been completed.
System action:
Shutdown proceeding normally.
Resolution:
None
Destination:
Console (and Terminal)
Module:
dfhzcqit
Parent topic: CASST4000 - CASST4111


CASCD0117S

A UNIX call returned with errno set to errno during quiesce of the CAS Daemon.

The call that failed is specified by function, where:

  • 1 = msgget
  • 2 = msgsnd
  • 3 = fgets
  • 4 = fopen
  • 5 = mknod
System Action:
The CAS Daemon continues shutdown
Resolution:
Dependent on value of errno
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


JCLCM0487E Global output limit number for limitation type too long

The value of the limitation is too large. Valid values are
PAGES | 0-99999999
LINES | 0-99999999
BYTES | 0-999999
CARDS | 0-99999999
OUTLIM | 1-16777215

Resolution:

Correct the value to be within the range.

Parent topic: JCLCM0400 - JCLCM0499


CASCD0165W

CAS attempted to create a new process from the CAS Daemon process but the call failed with RC=return-code from a DosExecPgm request.
System Action:
Abort the attempt to start a REM or server
Resolution:
Determine and fix cause of failure then retry
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0160 - CASCD0175


CASCD4002W

An error occured whilst binding to the MF Directory Server.
System Action:
Continue initialization using defaults
Resolution:
None
Destination:
Console and standard error
Module:
dfhmd
Parent topic: CASCD4002 - CASCD4007


CASSP0001W

The console daemon detected a process's termination and attempted to inform the region manger of the event. It failed due to the reason given.
System action:
The region manager cannot be informed of the process's termination. The region may continue successfully. If the reason is 3 then this may be normal if the region is in the process of shutting down.
Resolution:
None
Destination:
Console
Module:
caspdied
Parent topic: CASSP0001 - CASSP0014


CASRD0027E

ARRAY(0x2a9d458)
System action:
The request is rejected.
Resolution:
Verify the system installation. Check that the CVT definition file has not been moved, deleted, or the network connection lost.
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASCD0104I

The ES Daemon has initialized and is waiting for work
System Action:
None
Resolution:
None
Destination:
standard error and system console
Module:
cascd
Parent topic: CASCD0100 - CASCD0117


CASCF0053S

An error occurred reading the region's stored configuration data. This may occur if the region failed in initialization or the registry data has become corrupted.
System Action:
Terminate the requesting process
Resolution:
Make sure that the region is active and retry
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASCF0055S

An error occurred writing the region's stored configuration data. This may occur if the registry data has become corrupted.
System Action:
Terminate the requesting process
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASCS5101W

A warning message generated from a Communications Server.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
casgate
Parent topic: CASCS5010 - CASCS5103


CASCS2003E

A systems data stream was received by the CAS mirror transaction trans-ID that contained an invalid structured field.
System Action:
The transaction is abended and the conversation is terminated
Resolution:
If the problem persists, determine the reason that the partner system is generating the invalid structured field and correct the problem
Destination:
TDQ CSMT
Module:
dfhzcsmi
Parent topic: CASCS1500 - CASCS2004


CASXO0020I

The XA resource manager's switch module was loaded successfully.
System Action:
None
Resolution:
None
Destination:
console
Module:
dfhexa
Parent topic: CASXO0016 - CASXO0026


CASST0000 - CASST0020

  • CASST0000I
    The region manager has started its termination phase
  • CASST0001I
    The region manager has completed its termination phase
  • CASST0002W
    While attempting to shutdown a region an error occurred trying to attach to the region.
  • CASST0003W
    An attempt was made to shutdown a region externally which is marked as having external shutdown disabled
  • CASST0004W
    An attempt was made to shutdown a region externally which is marked as requiring a valid userid and password to complete the shutdown request due to the reason given.
  • CASST0005I
    The shutdown program is starting to shutdown the region.
  • CASST0006I
    The shutdown program is starting to shutdown the region by scheduling the transaction specified.
  • CASST0007I
    The shutdown program is starting to shutdown the region by abending all region processes.
  • CASST0008W
    An attempt to shutdown a region externally via a transid was rejected as the user failed the security check on the transaction.
  • CASST0009W
    An attempt to shutdown a region externally via a transid was rejected as the transaction is defined as remote.
  • CASST0010W
    An attempt to shutdown a region externally via a transid was rejected as the transaction was not found.
  • CASST0011W
    An attempt to shutdown a region externally via a transid was rejected as the transaction could not be scheduled due to an error allocating shared memory.
  • CASST0012W
    A forceable region abend was requested via the dfhgrtrm utility. Data may be lost or the system may be left in an unstable state. This option should only be used as a last resort, it is recommended that the region is shutdown cleanly via the /t option.
  • CASST0013W
    A forceable region abend was requested via the dfhgrtrm utility without the protection of locking shared memory. This should only be used if the region is 'hung', that is, it is impossible to connect a 3270 terminal to the region or shut the region down with the /t option.
  • CASST0014E
    While attempting to shutdown a region an error occurred trying to submit the shutdown request
  • CASST0015E
    While attempting to shutdown a region an error occurred trying to submit the shutdown request
  • CASST0016E
    While attempting to shutdown a region an error occurred trying to submit the shutdown request
  • CASST0017E
    While attempting to shutdown a region with option force the request has been rejected because the region security is on
  • CASST0018S
    The Casstop process failed to initialize safmgr. The reason code is reason-code.
  • CASST0019S
    The Safmgr failed to initialize and, therefore, Enterprise Server will be shutdown.
  • CASST0020I
    The shutdown is in progress, use force if the region did not stop in a timely fashion.
Parent topic: CASST Error Messages


CASST4001I

A request to shutdown the Micro Focus Transaction System IMMEDIATELY has been entered using the PERFORM SHUTDOWN command.
System action:
Shutdown processing is started; no PLT processing will be done.
Resolution:
None
Destination:
Console (and Terminal)
Module:
dfhzcqit
Parent topic: CASST4000 - CASST4111


CASRD0032E

An attempt was made to install the resource-type entry resource-name from group group-name. The install failed with reason reason-code. Reason codes are return codes from the table manager. Common reasons are:
System action:
Continue, the CVT definition is not installed.
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASXO0002S

The Switch Load Module for the XAT resource failed to load
System Action:
The region will not start
Resolution:
Check that the Switch Load Module is on the libpath or in $CASDIR\lib
Destination:
console and standard error
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


CASCS1001S

Inbound allocate for transaction trans-id failed because it could not acquire sufficient process storage to issue the receive allocate.
System Action:
The receive allocate is not issued and will time out based external communications parameters
Resolution:
This server will likely continue to fail. It should be terminated and restarted.
Destination:
TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASKC0013E

The system attempted to read an MQ queue record from the queue queue-name. The MQ open opperation failed with reason code reason-code.
System action:
Transaction aborted. The MQ Message is retained on the input queue queue-name.
Resolution:
Resolve the configuration mismatch and restart the associated ASEE iniation queue listener.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0000 - CASKC0015


JCLCM0900 - JCLCM0999

  • JCLCM0900E job-number job-name User Exit shut down due to a failure
    A failure in the user exit has forced the JCL engine to shut down the user exit.
  • JCLCM0901I job-number job-name Event-job-ready action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0902I job-number job-name Event-job-flushed action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0903I job-number job-name Event-job-started action is: explanation
    The user exit has requested this action to be taken for this event.
  • JCLCM0904I job-number job-name Event-job-JCL-error action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0905I job-number job-name Event-job-ended action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0906I job-number job-name Event-TSO-started action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0907I job-number job-name Event-TSO-ended action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0908I job-number job-name Event-step-ready action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0909I job-number job-name Event-step-started action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0910I job-number job-name Event-step-ended action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0911I job-number job-name Event-step-bypassed action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0912I job-number job-name Event-CALL-ready action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0913I job-number job-name Event-CALL-started action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0914I job-number job-name Event-CALL-ended action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0915I job-number job-name Event-RUN-ready action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0916I job-number job-name Event-RUN-started action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0917I job-number job-name Event-RUN-ended action is: explanation
    The user exist has requested this action to be taken for this event.
  • JCLCM0918I job-number job-name Event-before-PGM-call action is: explanation
    The user exit has requested this action to be taken for this event.
  • JCLCM0919I job-number job-name Event-after-PGM-call action is: explanation
    The user exist has requested this action to be taken for this event.
Parent topic: JCLCM Error Messages


CASCD0154S

server server-number of region region-name has abended due to receipt of signal signal-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASRD0046E

The hexadecimal value entered for the transaction had a double quote missing or mismatched.
System action:
The request is not executed
Resolution:
Correct the request and resubmit
Destination:
terminal, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0046 - CASRD0052


JCLCM0123S Expired password caused SAF failure on the host.

Parent topic: JCLCM0000 - JCLCM0199


Deployment Licensing

Related concepts
Overview of Deploying Native COBOL Applications
Deploying Native Applications


CASXO0001 - CASXO0015

  • CASXO0001S
    The Resource manager for the XAT resource returned a non-zero value to the xa_open call. Where the return code means :
  • CASXO0002S
    The Switch Load Module for the XAT resource failed to load
  • CASXO0003S
    The Resource manager for the XAT resource returned a non-zero value to the xa_start call.
  • CASXO0004S
    The Resource manager for the XAT resource returned a non-zero value to the xa_end call.
  • CASXO0005S
    The Resource manager for the XAT resource returned a non-zero value to the xa_prepare call.
  • CASXO0006S
    The Resource manager for the XAT resource reported that due to a failure the work done on behalf of the transaction may have been heuristically completed.
  • CASXO0007S
    The Resource manager for the XAT resource reported that due to a heuristic decision the work done on behalf of the transaction has been committed.
  • CASXO0008S
    The Resource manager for the XAT resource reported that due to a heuristic decision the work done on behalf of the transaction has been rolled back.
  • CASXO0009S
    The Resource manager for the XAT resource reported that due to a heuristic decision the work done on behalf of the transaction has been partially committed and partially rolled back.
  • CASXO0010S
    The Resource manager for the XAT resource returned a non-zero value to the xa_commit call.
  • CASXO0011S
    The Resource manager for the XAT resource returned a non-zero value to the xa_rollback call.
  • CASXO0012S
    The Resource manager for the XAT resource returned a non-zero value to the xa_close call.
  • CASXO0013S
    The Resource manager for the XAT resource indicated it had rolled back the transaction.
  • CASXO0014S
    The Resource manager for the XAT resource returned a non-zero value to the xa_commit call.
  • CASXO0015I
    The XA resource manager's switch module was loaded successfully and the xa-open processing called.
Parent topic: CASXO Error Messages


CASCD0124E

An attempt was made to start a server for a region which is not active
System Action:
The request is rejected
Resolution:
Start the REM for region-name before attempting to start servers again
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


JCLAM0225E Insufficient authority to alter/change dataset %

Lack of permissions to perform this action.

Resolution:

Contact your system administrator.

Parent topic: JCLAM0180 - JCLAM0230


CASCD0141 - CASCD0159

  • CASCD0141S
    Region region-name has failed to initialize and exited, the value specified on the exit call was exit-value
  • CASCD0142S
    Region region-name has ended abnormally with an exit call, the value specified on the exit call was exit-value
  • CASCD0143S
    Region region-name has ended abnormally during termination with an exit call, the value specified on the exit call was exit-value
  • CASCD0144S
    server server-number of region region-name has failed to initialize and exited, the value specified on the exit call was exit-value
  • CASCD0145S
    The 3270 printer service of region region-name has exited, the value specified on the exit call was exit-value
  • CASCD0146S
    The 3270 CCI gateway of region region-name has exited, the value specified on the exit call was exit-value
  • CASCD0151S
    Region region-name has abended during initialization due to receipt of signal signal-value
  • CASCD0152S
    Region region-name has abended during normal execution due to receipt of signal signal-value
  • CASCD0153S
    Region region-name has abended during termination due to receipt of signal signal-value
  • CASCD0154S
    server server-number of region region-name has abended due to receipt of signal signal-value
  • CASCD0155S
    The 3270 printer service of region region-name has abended due to receipt of signal signal-value
  • CASCD0156S
    The 3270 CCI gateway of region region-name has abended due to receipt of signal signal-value
  • CASCD0157E
    An error occurred in the CCI communications of the CAS console daemon. CCI-error-text is returned from CCI. This message will be generated prior to message CASCD0158E for CCI error return code 9.
  • CASCD0158E
    An error occurred in the CCI communications of the CAS console daemon.
  • CASCD0159F
    Only one CAS Daemon is required, attempts to start more are rejected
Parent topic: CASCD Error Messages


CASFD0001I

The offline dump requester issued a dump request for region region-name. The dump went to the normal region dump dataset.
System action:
The dump request is issued
Resolution:
None.
Destination:
Console and standard error.
Module:
dfhgtrtd
Parent topic: CASFD0001 - CASFD0014


CASCD0143S

Region region-name has ended abnormally during termination with an exit call, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASRD0039E

Extra parameter or invalid parameter in install request for group group-name. The error or extra parameter is error-parameter.
System action:
The request is not executed
Resolution:
Correct the request and resubmit
Destination:
terminal, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASST4110I

Shutdown processing has begun using the indicated PLT.
System action:
PLTSD Processing is started, shutdown proceeding normally.
Resolution:
None
Destination:
Console
Module:
casrdo11
Parent topic: CASST4000 - CASST4111


CASCS1138S

An error occurred when writing the configuration save file.
System Action:
The CCI gateway will not initialize successfully
Resolution:
Check directory permissions and disk space
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASRD1041E

A request to add, update or delete a package failed due to an unrecognised package definition.
System action:
Reject the administration request.
Resolution:
Check the CAS components are compatible.
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


CASCF0061F

The system groups have not been defined in $COBDIR/etc/cas/dfhtx.cfg
System Action:
Terminate the requesting process
Resolution:
Ensure that dfhtx.cfg contains entries for system groups
Destination:
standard error
Module:
config-module(dfhcpcfi)
Parent topic: CASCF0046 - CASCF0063


CASCD1001S

An error occurred locating the region directory for region region-name. Either the region is not defined or environment variable CASDIR is pointing to the wrong place.
System Action:
The region start request is not processed
Resolution:
Correct the setting of CASDIR, correct region-name, or define the region
Destination:
standard out
Module:
dfhrem
Parent topic: CASCD1001 - CASCD1043


CASCD4002 - CASCD4007

  • CASCD4002W
    An error occured whilst binding to the MF Directory Server.
  • CASCD4003W
    An error occured whilst retrieving the ES configuration from the MF Directory Server.
  • CASCD4004W
    An error occured whilst binding to the MF Directory Server.
  • CASCD4005I
    Messages to CAS Deamon will be logged to the windows event log.
  • CASCD4006I
    Messages to CAS Deamon will not be logged to the windows event log.
  • CASCD4007E
    Error error-message when trying to log to the windows event log.
Parent topic: CASCD Error Messages


CASCS1104I

The CAS CCI gateway initialized successfully on specified port, remoterequesters can now connect to the region. The CCI network protocol supported is CCI-protocol.
System Action:
None
Resolution:
None
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASCF0056S

An error occurred reading the project's configuration data. This may occur if this process was not invoked by the IDE or no project is open. Check that the appropriate configuration value is set within the current project or workgroup settings.
System Action:
Terminate the requesting process
Resolution:
Make sure the IDE is active and a valid project file is open
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASCD1036I

The Spool service process for region region-name has successfully completed termination
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


CASCD0054S

A UNIX call returned with errno set to errno.

The call that failed is specified by errno, where:

  • 1 = msgget
  • 2 = msgsnd
  • 3 = fgets
  • 4 = fopen
  • 5 = mknod
System Action:
The region is not started
Resolution:
Determine the cause of the error and retry if appropriate
Destination:
standard error
Module:
dfhtxp
Parent topic: CASCD0050 - CASCD0099


CASCS1018E

Inbound transaction trans-id from system system-id failed security check for user user-id. The user ID was not found in this system's SNT.
System Action:
The transaction is abnormally terminated
Resolution:
Correct the user ID on the remote system or add it locally
Destination:
TDQ CSMT
Module:
dfhebms (issued in dfhecics)
Parent topic: CASCS1001 - CASCS1018


CASST4011I

Shutdown processing has begun; no PLTSD was specified for PLT processing.
System action:
Shutdown proceeding normally without PLT processing.
Resolution:
None
Destination:
Console (and Terminal)
Module:
dfhzcqit
Parent topic: CASST4000 - CASST4111


CASRD0023E

The resource definition for terminal resource-name is not installable. The existing installed definition is not replaceable.
System action:
Continue, the group will not be installed.
Resolution:
None
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASFD0009S

The offline dump requester could not issue an IMS dump request for region region-name. The IMS option was not enabled for the region
System action:
The dump request is aborted
Resolution:
Correct the installation setup and retry the operation.
Destination:
Standard error.
Module:
dfhgdup
Parent topic: CASFD0001 - CASFD0014


CASCD0112I

The CAS Daemon is beginning an immediate shutdown and will abend number-of-regions regions before shutting down
System Action:
Abend the regions then shutdown
Resolution:
None
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


CASST5026S

The named program specified could not be found and resulted in a PGMIDERR.
System action:
PLT processing continues, the named program is ignored.
Resolution:
Make sure that the program exists and has been compiled correctly. The compiled program must been in a directory specified on TRANPATH.
Destination:
Console
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASRD0052E

The Current Userid Current Userid is not a surrogate of user URIMAP Userid or has not enough power the resource cannot be installed.
System action:
Continue, the resource will not be installed.
Resolution:
Specify a different Userid or allow resource-type to be a surrogate.
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0046 - CASRD0052


CASRD0006E

Validation of group was successful but portions of the install failed for group group-name. The error messages are written to TS queue TS-queue-name. These messages may be reviewed with the utility transaction CEBR.
System action:
The install request was processed with errors
Resolution:
Review the detail error messages and take corrective action
Destination:
terminal, console, TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


CASCF0058S

An error occurred reading the project's configuration data. This may occur if this process was not invoked by the IDE or no project is open. Check that the appropriate configuration value is set within the current project or workgroup settings.
System Action:
Terminate the requesting process
Resolution:
Make sure the IDE is active and a valid project file is open
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASCD0016W

The region name specified on the command line to dfhtxs to auto-start was found to be invalid. If the region can not be located under $CASDIR or appropriate REGIONBASE directory then it is removed from the auto-start region list.
System Action:
The region will be removed from the auto-start list and the console will continue its initialization.
Resolution:
Check the spelling of the region name and appropriate REGIONBASE settings, including character case if on UNIX. If the name is incorrect then the region can be started immediately via dfhrem.
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0016 - CASCD0031


CASKC6003I

A transaction exceeded its time threshold and is still running.
System action:
Warning message logged.
Resolution:
Investigate why threshold was exceeded
Destination:
System Console
Module:
casmgr
Parent topic: CASKC5006 - CASKC6006


CASST5004S

The specified PLTSD program list table was not present in the installed PPT.
System Action:
PLT Processing is bypassed, shutdown continues
Resolution:
None
Destination:
console (and terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASCS1110I

The CAS CCI gateway successfully connected to remote-region. It is accessible via sysid sys-id. This system is the contention loser or the server side of the connection.
System Action:
The connection is available for work
Resolution:
None
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASCF0063F

The group associated with the module has not been recognized
System Action:
Terminate the requesting process
Resolution:
Contact system administrator. Group owner not declared in groups
Destination:
Standard error
Module:
config-module(dfhcpcfi)
Parent topic: CASCF0046 - CASCF0063


C$GetNativeCharset

Retrieves information about the native character set in effect for the current run unit.
Note: When calling this routine, ensure you are using the 1024 calling convention.

The native character set specifies how non-numeric data is encoded in memory and on data files.

Syntax:

CALL "C$GetNativeCharset" USING charset-name [, codepage-number]

Parameters:

charset-name
PIC X(n)
codepage-number
PIC 9(n)

On Exit:

charset-name
The name of the character set in use for the current run unit after the call.
Note: For Windows, the name will have a value of “ANSI” or “OEM”. On UNIX, the value will be “NONE”.
codepage-number
The codepage number of the character set in use for the current run unit after the call.
Note: For Windows, the codepage number will be the system ANSI codepage number if charset-name contains “ANSI” and will be the system OEM codepage number if charset-name contains “OEM”. On UNIX, the value will be 0.

Comments:

The native character set for a run unit on Windows can be either ANSI or OEM.

The native character set for a run unit on UNIX is determined by the locale settings for the system.

Related information
Call Conventions for Interfacing with Mixed Languages


CASCS1135S

An error occurred when creating the configuration save file.
System Action:
The CCI gateway will not initialize successfully
Resolution:
Check directory permissions and disk space
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASCD0128I

The 3270 printer service has been started for region region-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASRD0031 - CASRD0045

  • CASRD0031I
    The CVT definition for resource-type entry resource-name from group group-name is installed in the current system.
  • CASRD0032E
    An attempt was made to install the resource-type entry resource-name from group group-name. The install failed with reason reason-code. Reason codes are return codes from the table manager. Common reasons are:
  • CASRD0033E
    An attempt was made to install the resource-type entry resource-name from group group-name. The install failed with error reason-code. Error codes are return codes from local storage allocation.
  • CASRD0034W
    An attempt was made to install the resource-type entry resource-name from group group-name. The table defined is ZERO length.
  • CASRD0035W
    An attempt was made to install the resource-type entry resource-name from group group-name. The base resource definition table was not found.
  • CASRD0036W
    During install of the resource-type entry resource-name, group group-name, a free main for the old table definition failed. The reason reason-code is the return from the free shared memory routine.
  • CASRD0037E
    A conversion table entry of type resource-type (entry resource-name, group group-name) is invalid.
  • CASRD0038E
    A conversion table entry of type resource-type (entry resource-name, group group-name) is not currently supported.
  • CASRD0039E
    Extra parameter or invalid parameter in install request for group group-name. The error or extra parameter is error-parameter.
  • CASRD0040E
    The resource type resource-type (resource resource-name, group group-name) is not found.
  • CASRD0041E
    The READ for resource type resource-type (resource resource-name, group group-name) failed for reason reason-code.
  • CASRD0042E
    The resource-type name resource-name is locked with an ENQ. Some other operation is currently being executed that involves it.
  • CASRD0043E
    The resource type that you are trying to install is not recognized.
  • CASRD0044E
    The GROUP keyword for the resource that you are trying to install is not recognized.
  • CASRD0045E
    The hexadecimal value entered for the transaction had a single quote missing or mismatched.
Parent topic: CASRD Error Messages


CASFD0007S

The offline dump requester failed to find the requester support module.
System action:
The dump request is aborted
Resolution:
Correct the installation setup and retry the operation.
Destination:
Console and standard error.
Module:
dfhgtrtd
Parent topic: CASFD0001 - CASFD0014


CASRD0043E

The resource type that you are trying to install is not recognized.
System action:
The request is not executed
Resolution:
Correct the request and resubmit
Destination:
terminal, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASCD1059I

An IMS MPR Process has been started for Server server-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


Structures, Value Types - in COBOL and C#

Structures in Managed COBOL

COBOL uses the valuetype-id to define a value type.

valuetype-id StudentRecord.
01 aName string public.
01 gpa float-short public.
method-id new.
procedure division using by value nam as string,
                                  gpa as float-short.
    set aName to nam
    set self::"gpa" to gpa
end method.
end valuetype.

class-id a.
method-id main static.
local-storage section.
01 stu type StudentRecord value new StudentRecord("Bob", 3.5).
01 stu2 type StudentRecord.
procedure division.
    set stu2 to stu
    set stu2::name to "Sue"
    display stu::name   *> Prints Bob
    display stu2::name  *> Prints Sue
end method.
end class.

Structures in C#

C# uses struct to define a value type.

struct StudentRecord
{
  public string name;
  public float gpa;

  public StudentRecord(string name, float gpa)
  {
    this.name = name;
    this.gpa = gpa;
  }
}
StudentRecord stu = new StudentRecord("Bob", 3.5f);
StudentRecord stu2 = stu;

stu2.name = "Sue";
Console.WriteLine(stu.name);    // Prints Bob
Console.WriteLine(stu2.name);   // Prints Sue
Related reference
ValueTypes


CASRD0029W

The CVT resource type resource-type (resource resource-name, group group-name) is not supported.
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASRD0031I

The CVT definition for resource-type entry resource-name from group group-name is installed in the current system.
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASRD0018E

The resource definition for resource-type entry resource-name is not installable. The existing installed definition is in use.
System action:
Continue, the group will not be installed.
Resolution:
Close and disable the file and retry the operation.
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASCF0004F

The configuration support module could not be loaded as part of system initialization. This module is required for normal system operation.
System Action:
Terminate the requesting process
Resolution:
Check that $CASDIR is set correctly and the module dfh0cfg exists in $CASDIR/lib
Destination:
standard error
Module:
config-module(dfhcpcfi)
Parent topic: CASCF0001 - CASCF0015


CASCD0151S

Region region-name has abended during initialization due to receipt of signal signal-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


JCLCM0013S Job cancelled by global OUTLIM setting of setting

The job has been cancelled because the global OUTLIM value has been exceeded.

Resolution:

None.

Parent topic: JCLCM0000 - JCLCM0199


CASKC1000 - CASKC1003

  • CASKC1000I
    During startup the maximum number of concurrent requests is logged.
  • CASKC1001W
    The number of active client requests exceeded the licensed maximum client-count times.
  • CASKC1002I
    During shutdown the maximum number of concurrent requests is logged against the actual
  • CASKC1003I
    A request for a license of the referenced type was made to the license server. No license was available. Pleas contact your Micro Focus sales representative
Parent topic: CASKC Error Messages


CASCD0173S

The ES Console tried to start a receive-all thread. The create-thread operation failed with a return code of return-code
Resolution:
Report the failure to Micro Focus Support
Destination:
system console
Module:
cascd
Parent topic: CASCD0160 - CASCD0175


CASKC0017E

The system attempted to register the request-handler-name request handler. The MF RTS return code is reason-code. Services requiring this handler will not be available until the problem is corrected. The MF RTS may not be able to locate the executable or.
System action:
None.
Resolution:
Correct the error and re-register the handler.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


CASCD1060I

An JES Initiator Process has been started for Server server-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


CASCF0028S

An error occurred when reading the global configuration save file (gcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASST5030I

Shutdown Phase 2 PLT processing has completed successfully using the plt-name list.
System action:
Shutdown proceeds normally.
Resolution:
None
Destination:
Console (and Terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASRD0047E

The resource definition for resource-type entry resource-name is not installable. The existing installed definition is in use.
System action:
Continue, the resource will not be installed.
Resolution:
Disable the resource and retry the operation.
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0046 - CASRD0052


CASCD1033I

The MQSeries Gateway service process for region region-name has successfully completed termination
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


CASKC6006I

Time taken by the web service application was greater than ES_WS_RUNAWAY_TIMEOUT
System action:
System will continue as normal.
Resolution:
Resolve the issue that caused the timeout.
Destination:
Console and standard error
Module:
cashtsrv
Parent topic: CASKC5006 - CASKC6006


CASCS1009S

The install for terminal definition failed to acquire local storage during execution of transaction trans-id.
System Action:
The transaction is abnormally terminated
Resolution:
This server will likely continue to fail. It should be terminated and restarted.
Destination:
TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASCF0040S

The resource definition file path points to a directory is invalid.
System Action:
Terminate the requesting process
Resolution:
Check that RDTDIR item is correct and the directory exists
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASKC0022E

The system could not connect to the queue-manager-name queue manager. The reason code is reason-code.
System action:
This request will be aborted.
Resolution:
Check the MQ and CAS configuration.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


CASRD1012I

The request handler was deleted successfully.
System action:
None.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1000 - CASRD1015


CASCD0100I

The CAS Daemon has initialized and is waiting for work
System Action:
None
Resolution:
None
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


CASCD0129I

The 3270 CCI gateway service has been started for region region-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASRD0049E

The resource definition for resource-type entry resource-name is not installable. The port port number is already in use.
System action:
Continue, the resource will not be installed.
Resolution:
Close the service using the port and retry the operation.
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0046 - CASRD0052


CASCF0046F

The file handling support module could not be loaded as part of system initialization. This module is required for normal system operation.
System Action:
Terminate the requesting process
Resolution:
Check that $CASDIR is set correctly and the module mffh exists in $COBDIR
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASKC6001S

A process was looping or hung and exceeded the specified task timeout. The attempt to kill the process aparently has failed to remove the process.
System action:
The process DCA is released and internal recovery is initiated.
Resolution:
Resolve the issue that caused the timeout
Destination:
System Console
Module:
casmgr
Parent topic: CASKC5006 - CASKC6006


JCLCM0000 - JCLCM0199

  • JCLCM0000I job-number job-name JCL PROCESSOR TERMINATED
    The JCL processor has terminated. This does not imply an error. It could occur, for example, if a debugging session is cancelled while a jobstream is being processed.
  • JCLCM0001U job-number job-name I/O ERROR ON SYSTEM CATALOG FILE
    Configuration error.
  • JCLCM0010W SYSOUT Limit limit exceeded by DD name
  • JCLCM0011I OUTLIM limit for DD name incremented by amount by user exit MFJUSOXT
  • JCLCM0012S Job cancelled by user exit MFJUSOXT
  • JCLCM0013S Job cancelled by global OUTLIM setting of setting
  • JCLCM0094I Non-JCL record in the input stream has caused this SYSIN DD statement to be generated.
    This message, while it never appears in any JCL listings, is referred to in the generated SYSIN DD statement. It means that in your JCL source stream, you have one or more non-JCL records before the final // if any.
  • JCLCM0121S Unexpected return type from RJSECA-FC-Execute %1$s.
  • JCLCM0122S Incorrect password caused SAF failure on the host.
  • JCLCM0123S Expired password caused SAF failure on the host.
  • JCLCM0124S Invalid user id caused SAF failure on the host.
  • JCLCM0125E %1$s is not supported.
  • JCLCM0126E %1$s is not yet supported.
  • JCLCM0127S Host dataset %1$s unexpectedly created by alien job.
  • JCLCM0128S Host dataset %1$s unexpectedly deleted by alien job.
    Explains purpose of topic. Written as sentence fragment. Contains no more than two sentences.
  • JCLCM0129W LRECL of host RECFM F dataset %1$s assumed to be 80.
  • JCLCM0130W LRECL of host RECFM V dataset %1$s assumed to be 255.
  • JCLCM0147U job-number job-name NO DATASET NAME SPECIFIED
    The function requested requires a data set name to be specified.
  • JCLCM0158U job-number job-name MVS data set "name" not found
    The specified MVS data set is not in the catalog.
  • JCLCM0159U job-number job-name FILE OPEN ERROR FILENAME
    There was an open error on the main source file submitted to the JCL scanner for processing.
  • JCLCM0160U job-number job-name FILE I/O ERROR FILENAME
    There was an I/O error on the main source file submitted to the JCL scanner for processing.
  • JCLCM0161U job-number job-name DATASET TYPE INVALID DATASETNAME
    The specified data set is of a type that cannot be used for the requested function.
  • JCLCM0162U job-number job-name FILE IS EMPTY FILENAME
    The specified file is empty. The function you have attempted cannot be performed on an empty data set or file.
  • JCLCM0163U job-number job-name MVSJOBNO ERROR ASSIGNING JOBNUM
    An internal error has been detected while attempting to assign a job number. The return-code from MVSJOBNO.DLL is non-zero.
  • JCLCM0164A job-number job-name All job numbers in the range lower-job-number:upper-job-number are in use.
    The system has used up all available job numbers and cannot process this job.
  • JCLCM0165S Open for joblog "filename" failed. Also see JCLCM0166
  • JCLCM0166S File status code for last file I/O failure was value
  • JCLCM0169I JCL copied
  • JCLCM0170I job-number job-name JCL SCANNED - NO ERRORS
    The job submitted contains no syntax errors.
  • JCLCM0171E job-number job-name JCL SCANNED - JCL ERROR
    The job submitted contains syntax errors which are detailed in other messages.
  • JCLCM0172E job-number job-name JOB FAILED - JCL ERROR
    The job submitted contains a JCL syntax error.
  • JCLCM0173I job-number job-name MFJUSCAN SCANNER EXIT - NO ERRORS
    The JCL scanner user exit module MFJUSCAN was called and ended with a zero return code.
  • JCLCM0174E job-number job-name MFJUSCAN SCANNER EXIT - JCL ERROR
    The JCL scanner user exit module MFJUSCAN was called and ended with a non-zero return code.
  • JCLCM0175S job-number job-name MFJUSCAN SCANNER EXIT - I/O ERROR ON FILENAME
    An I/O error has occurred while attempting to process the user error file returned to the JCL scanner.
  • JCLCM0180I job-number job-name Job ready for execution.
    The job named is ready for execution.
  • JCLCM0181S job-number job-name JOB ABENDED - ERRORCODE
    The job has ended abnormally with the specified return code.
  • JCLCM0182I job-number job-name JOB ENDED - RC(RETURNCODE)
    The job has ended normally with the specified return code.
  • JCLCM0185U job-number job-name Job flushed upon User Exit request.
    The user exit has requested that the job be flushed.
  • JCLCM0187I job-number job-name JOB SUBMITTED JOBNAME
    The specified job contains a valid job name, a job number has been assigned, and syntax checking of the JCL has started.
  • JCLCM0188I job-number job-name JOB STARTED.
    Execution of the submitted job has started.
  • JCLCM0189I job-number job-name STEP BYPASSED STEPNAME.PROCSTEPNAME
    Execution of the specified job step has been bypassed due to a prior abend or because of return codes.
  • JCLCM0190I job-number job-name STEP STARTED STEPNAME.PROCSTEPNAME
    Execution of the specified job step has started.
  • JCLCM0191I job-number job-name STEP ENDED STEP1 - COND CODE CONDITION-CODE
    Execution of the job step has completed normally with the specified return code.
  • JCLCM0192S job-number job-name STEP ABENDED STEP01 - COND CODE ABEND-CODE
    Execution of the job step has completed abnormally with the specified user abend, system abend, or run time error.
  • JCLCM0193U job-number job-name PROGRAM NOT FOUND - PROGRAMNAME
    The specified program cannot be located.
  • JCLCM0194S job-number job-name DCB MODEL NOT FOUND - DDNAME
    The specified DD statement references a DCB model data set which cannot be located.
  • JCLCM0195S job-number job-name DATASET IS NOT A GDG - DDNAME
    The specified DD statement refers to a GDG data set with a bias (+1) or (-1), but no GDG model by the same name exists in the catalog.
  • JCLCM0196S Resource allocation failed for dd-name<[concat dd seq no]>. Reason=nnn
    This is usually preceded by another JCLCM message providing additional information.
  • JCLCM0197S job-number job-name DISP=MOD, DSN INCOMPATIBLE - DDNAME
    The specified DD statement specifies DISP=MOD, which is incompatible with the organization of the data set name specified.
  • JCLCM0198I VSE CONFIG FILE - outcome : config-file
    Tells you the outcome of your attempt to load an optional VSE JCL configuration file (specified by the VSE_STARTUP_CFG environment variable).
  • JCLCM0199I job-number job-name Program program-name is cobol-dialectchar-setbyte-orderamode-type
    The program program-name, which is being executed, has the stated characteristics.
Parent topic: JCLCM Error Messages


CASCS1108I

The CAS CCI gateway serving the CCI-protocol is shutting down.
System Action:
None
Resolution:
None
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASST0006I

The shutdown program is starting to shutdown the region by scheduling the transaction specified.
System Action:
Schedule transaction
Resolution:
None
Destination:
console
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


CASST5006S

The named program specified could not be found and resulted in a PGMIDERR.
System Action:
PLT processing continues, the named program is ignored
Resolution:
Make sure that the program exists and has been compiled correctly. The compiled program must been in a directory specified on TRANPATH.
Destination:
console
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASRD1016E

An unsuccessful request was made to update the named request handler. return-code values
System action:
No updates made.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


CASRD0001E

The resource-type entry resource-name is locked with an ENQ. Some other operation is currently being executed that involves it.
System action:
The group group-name will be partially installed
Resolution:
Reinstall the group or resource.
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


CASSP0004E

The daemon process responsible for initiating recovery for process ID process-id failed trying to lock shared memory.
System action:
The region manager cannot be informed of the process's termination. The region may continue successfully.
Resolution:
None
Destination:
Console
Module:
dfhgdied
Parent topic: CASSP0001 - CASSP0014


C$ConvertOemToAnsi

Converts a buffer containing OEM characters to a buffer containing the corresponding ANSI characters.
Note: When calling this routine, ensure you are using the 1024 calling convention.

Syntax:

CALL "C$ConvertOemToAnsi" USING oem-buffer, ansi-buffer
[, char-count]

Parameters:

oem-buffer
PIC X(n)
ansi-buffer
PIC X(n)
char-count
PIC 9(n)

On Entry:

oem-buffer
The OEM characters to be converted to ANSI characters.
char-count
The number of characters to be converted.
Note: If omitted or if the value is invalid, the actual size of the shorter of ansi-buffer and oem-buffer is used.

On Exit:

ansi-buffer
The converted ANSI characters.
Related information
Call Conventions for Interfacing with Mixed Languages


CASCS1112E

The CAS CCI gateway failed to connect to region remote-region.

The reason is reason-code. Reason codes are:

  • 1 Name conflict (the netname references a non-system node)
  • 2 Locate error
  • 3 Auto-install error (The automatic connection install failed)
  • 4 Contention reject (The bind is in progress from the remote system)
System Action:
The bind was rejected by the partner system
Resolution:
None
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASCF0002F

An error has occurred during Region configuration file processing.

The error-type describes the type of error, and error-qualifier gives further information depending on error-type as follows:

  • 1 - The region name (error-qualifier) was not valid
  • 2 - Line number error-qualifier of the configuration file is not valid
  • 3 - The configuration file did not exist when OPEN was called, error-qualifier contains the COBOL return code from CBL_OPEN_FILE
  • 4 - Failure when creating configuration save file, error-qualifier contains COBOL return code from CBL_CREATE_FILE
  • 5 - Failure reading from file, error-qualifier contains the COBOL return code from CBL_READ_FILE
  • 6 - Failure writing to file, error-qualifier contains the COBOL return code from CBL_WRITE_FILE
System Action:
Terminate the requesting process
Resolution:
Determine and fix the cause of the problem
Destination:
standard error and/or system console
Module:
dfh0cfg
Parent topic: CASCF0001 - CASCF0015


JCLAM0231E Unable to acquire exclusive lock on dataset "dataset-name"

The action requires an exclusive lock on the named dataset but was unable to obtain it.

Resolution:

Ensure the dataset is not locked by another step, job or process.

Parent topic: JCLAM0231 -


CASRD0007I

The group group-name has been successfully installed. Details of the install are written to TD queue CRDI.
System action:
The install request is completed
Resolution:
None
Destination:
terminal, console, TD queue CRDI
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


CASKC0035I

A security profile Security profile found for Queue Manager Queue Manager Namehas been found and security for MQSeries has been turned off for type Type security.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
dfheserv
Parent topic: CASKC0031 - CASKC0045


C$LogicalOr

Performs a bitwise logical OR operation on two or more non-numeric or numeric operands.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:

CALL "C$LogicalOr"
    [GIVING result]
     USING operand1 {operand2} ...

Parameters:

result
PIC 9(n)
operand1
A non-numeric or numeric operand
operand2, 3, etc
A non-numeric or numeric operand that must be of the same data type as operand1
Note: If any non-numeric operand2 is shorter than operand1, it is assumed to be padded on the right with binary zeroes.

On Entry:

operand1, 2, 3, etc
Non-numeric or numeric operands, which must be of the same data type as operand1.

On Exit:

result
The result of the operation or operand1.

Comments:

For non-numeric USING operands, the bitwise logical inclusive OR of all the operands replaces the value of operand1. The value of result is set to a non-zero value if any character of operand1 is non-zero after the operation completes and zero otherwise.

For numeric USING operands, each operand is converted, if necessary, to a 32-bit binary integer. These 32-bit binary values are logically inclusive OR'd together. If the GIVING phrase is specified, the result of this operation is stored in result and the value of operand1 is not modified. If the GIVING phrase is not specified, the result of this operation is stored in operand1.

Related information
Call Conventions for Interfacing with Mixed Languages


CASRD0022E

The resource definition for terminal resource-name is not installable. The existing installed definition is not replaceable.
System action:
Continue, the group will not be installed.
Resolution:
None
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASXO0019S

The Switch Load Module for the XAT resource failed to load the necessary DLLs or .so programs. The returned pointer was null.
System Action:
The region will not start
Resolution:
Check that the programs loaded by the Switch Load Module are on the path or libpath or in $CASDIR\lib
Destination:
console and standard error
Module:
dfhexa
Parent topic: CASXO0016 - CASXO0026


CASCF0032S

An error occurred when opening the region configuration file ($REGIONBASE/$CASREGN/dfhtx.cfg).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASCS1100 - CASCS1115

  • CASCS1100W
    An error occurred in the CCI communications of the CAS CCI gateway.
  • CASCS1101W
    An error occurred in the CCI communications of the CAS CCI gateway. CCI-error-text is returned from CCI. This message will be generated prior to message CASCS1100W for CCI error return code 9.
  • CASCS1102E
    An error occurred in registering system net-name. This is an internal error indicating a logic error or a module mismatch problem.
  • CASCS1103E
    An error occurred allocating local process storage. The process has exceeded the available address space. There are too many clients or traffic buffering is backed up in the gateway process.
  • CASCS1104I
    The CAS CCI gateway initialized successfully on specified port, remoterequesters can now connect to the region. The CCI network protocol supported is CCI-protocol.
  • CASCS1105S
    The CAS CCI gateway failed to initialize successfully . The reason-code is generally from the CCI protocol module. reason-code of 998 says the CCI protocol module could not be loaded. reason-code of 999 says the CCI protocol module signature was bad.
  • CASCS1106S
    The CAS CCI gateway failed to initialize successfully . The reason-code is from dfhgreqc.
  • CASCS1107W
    The CAS CCI gateway failed to connect to remote-region. The reason-codeis the CCI protocol return code.
  • CASCS1108I
    The CAS CCI gateway serving the CCI-protocol is shutting down.
  • CASCS1109I
    The CAS CCI gateway successfully connected to remote-region. It is accessible via sysid sys-id. This system is the contention winner or the client side of the connection.
  • CASCS1110I
    The CAS CCI gateway successfully connected to remote-region. It is accessible via sysid sys-id. This system is the contention loser or the server side of the connection.
  • CASCS1111E
    The CAS CCI gateway failed to connect to region remote-region.
  • CASCS1112E
    The CAS CCI gateway failed to connect to region remote-region.
  • CASCS1113S
    The CAS CCI gateway detected a CCI protocol error.
  • CASCS1114E
    An error occurred loading the protocol support module module-name.
  • CASCS1115E
    The signature check for CCI protocol support module module-namefailed. The signature found is CCI-signature-string.
Parent topic: CASCS Error Messages


To associate a CICS.NET region with a connection

  1. Optionally, define a CICS.NET region with the MicroFocus.SEE.SqlExit user exit using the Microsoft Management Console in Server Enterprise Edition for .NET .
    Note: You can associate a CICS.NET region before defining it, but you must define it before attempting to connect to the region.
  2. Start HCO for SQL Server tools as an administrator from Start > All Programs > Micro Focus Studio Enterprise Edition x.x > HCO for SQL Server Tools.
  3. Click Manage Connections.
  4. From the Connection List tab, click New SQL Server Connection.
  5. Select Connection mode. This enables you to specify the details for your application SQL Server database connection.
  6. On this tab, specify a data source name, authentication method, user ID and password if applicable, a SQL Server instance, and the SQL Server database to which you want to connect.
  7. Click Test to verify that the connection is successful.
  8. On the SQL Server Connection tab, select CICS Region mode. This enables you to specify the details of the CICS.NET region you want to associate with this connection.
  9. Specify an authentication method, user ID and password if applicable, the SQL Server instance associated with the CICS.NET region you want to use, and the CICS region you want to associate with this connection.
  10. If you defined the CICS.NET region as specified in step 1, click Test CICS Connection to verify that the connection is successful.
  11. Click Save to create the complete connection definition. This takes you back to the Connection List tab where you now see your new connection and the CICS region with which it is associated.
Related reference
SQL Server Connection tab
Connection List tab


CASKC0011I

The destination specified triggering of the transaction on a terminal other than the current terminal in single tasking mode.
System action:
None.
Resolution:
None.
Destination:
System Console and CSMT td queue.
Module:
dfhetstd
Parent topic: CASKC0000 - CASKC0015


CASXO0004S

The Resource manager for the XAT resource returned a non-zero value to the xa_end call.

The return codes are:

  • -2 Asynchronous operation already outstanding
  • -3 A resource manager error occurred
  • -4 The XID is not valid
  • -5 Invalid arguments were given
  • -6 Routine invoked in an improper context
  • -7 Resource Manager unavailable
  • -8 the XID already exists
  • -9 Resource Manager doing work outside global transaction
  • The following indicate the transaction is marked as roll-back only
  • 100 The resource manager marked the transaction roll-back
  • only for an unspecified reason.
  • 101 A communication failure occurred
  • 102 The resource manager detected a deadlock
  • 103 The resource manager detected a violation of the integrity
  • of its resources
  • 104 The resource manager marked the transaction roll-back
  • only for a reason not in this list.
  • 105 A protocol error occurred in the resource manager
  • 106 The work represented by this transaction took too long
  • 107 The resource manager detected a transient error
System Action:
The Transaction is abnormally terminated
Resolution:
Check that the Resource Manager is still available
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


JCLAM0120 - JCLAM0139

  • JCLAM0120S job-number job-name UNKNOWN COMMAND [COMMAND]
    The specified command is not known to MFJAMS.
  • JCLAM0121E job-number job-name GDG IS NOT EMPTY [GDGNAME]
    A DELETE command has been attempted for a generation data group which still contains cataloged entries.
  • JCLAM0122I job-number job-name HOST ENTRY RETAINED [ENTRYNAME]
    The specified entryname, which resides on the host, has been retained (not deleted).
  • JCLAM0123S job-number job-name GDG LIMIT MISSING OR ZERO
    An attempt to define a new GDG must specify the number of entries to maintain before automatic deletion.
  • JCLAM0124I job-number job-name GDG LIMIT CHANGED TO 31
    You have requested more than the maximum number of GDG entries allowed.
  • JCLAM0125S job-number job-name RELATENAME NOT CATALOGED [ENTRYNAME]
    The dataset specified by RELATENAME must exist before an alternate index can be defined.
  • JCLAM0126S job-number job-name FILE MISSING OR INVALID TYPE [FILENAME]
    The specified workstation file cannot be located.
  • JCLAM0127I job-number job-name ALTERNATE INDEX DEFINED [ENTRYNAME]
    The alternate index has been defined. The appropriate workstation file has been updated to reflect the new index keys.
  • JCLAM0128I job-number job-nameNUMBER RECORDS INDEXED
    The keys for the specified number of records have been added for the newly-defined alternate index.
  • JCLAM0129S job-number job-name INVALID PRIMARY KEY OR RECORDSIZE
    The key position plus the key length exceeds the defined record length.
  • JCLAM0130S job-number job-name DD MISSING [DDNAME]
    A DD statement for the specified DD name is not defined in your JCL.
  • JCLAM0131S job-number job-name INSUFFICIENT DCB [DATASETNAME]
    The specified dataset does not have complete data control block characteristics.
  • JCLAM0132S job-number job-name I/O ERROR [DATASETNAME]
  • JCLAM0133S job-number job-name I/O STATUS [FILE STATUS]
  • JCLAM0134I job-number job-namenumber Records processed
    The specified number of records have been processed.
  • JCLAM0135I job-number job-namenumber Datasets listed
    The specified number of data sets have been listed by the LISTCAT command.
  • JCLAM0136W job-number job-name PARM IGNORED FOR SEQ DATASETS [PARAMETER]
    The specified parameter is invalid for sequential datasets.
  • JCLAM0137I job-number job-name DATASET VERIFIED [DATASETNAME]
    The specified dataset has been verified. The dataset was opened and closed successfully.
  • JCLAM0138I job-number job-name DATASET VERIFIED(LOCKED) [DATASETNAME]
    The specified dataset has been verified even though the dataset is currently locked by another process.
  • JCLAM0139S job-number job-name DATASET MUST BE VSAM [DATASETNAME]
    The dataset name specified in the VERIFY command is not a VSAM dataset. Only VSAM datasets can be verified.
Parent topic: JCLAM Error Messages


CASRD1006E

An unsuccessful request was made to update the named service. return-code values
System action:
No updates made.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1000 - CASRD1015


CASCS1011E

Outbound transaction routing of transaction trans-id to system system-id is not supported because there is no communications buffer allocated.
System Action:
The request is rejected
Resolution:
Check for errors during server startup
Destination:
user terminal and TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASCD0162S

The journal control service for region region-name has abended due to the unexpected signal signal-value.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0160 - CASCD0175


CASCS1008E

The install for terminal definition for terminal-id was rejected. The table manager return code is return-code.
System Action:
The transaction is abnormally terminated
Resolution:
Correct the cause of the table conflict as indicated by the table manager return code return-code
Destination:
TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASXO0012S

The Resource manager for the XAT resource returned a non-zero value to the xa_close call.

The return codes are:

  • -2 Asynchronous operation already outstanding
  • -3 A resource manager error occurred
  • -5 Invalid arguments were given
  • -6 Routine invoked in an improper context
System Action:
None
Resolution:
Contact your system administrator for the resource
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


C$LogicalAnd

Performs a bitwise logical AND operation on two or more non-numeric or numeric operands.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:

CALL "C$LogicalAnd"
[GIVING result]
 USING operand1 {operand2} ...

Parameters:

result
PIC 9(n)
operand1
A non-numeric or numeric operand
operand2, 3, etc
A non-numeric or numeric operand that must be of the same data type as operand1
Note: If any non-numeric operand2 is shorter than operand1, it is assumed to be padded on the right with binary zeroes.

On Entry:

operand1, 2, 3, etc
Non-numeric or numeric operands, which must be of the same data type as operand1.

On Exit:

result
The result of the operation or operand1.

Comments:

For non-numeric USING operands, the bitwise logical AND of all the operands replaces the value of operand1. The value of result is set to a non-zero value if any character of operand1 is non-zero after the operation completes and zero otherwise.

For numeric USING operands, each operand is converted, if necessary, to a 32-bit binary integer. These 32-bit binary values are logically ANDed together. If the GIVING phrase is specified, the result of this operation is stored in result and the value of operand1 is not modified. If the GIVING phrase is not specified, the result of this operation is stored in operand1.

Related information
Call Conventions for Interfacing with Mixed Languages


C$LogicalShiftRight

Performs a logical shift right operation on a non-numeric or numeric operand.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:

CALL "C$LogicalShiftRight"
[GIVING result]
 USING operand [shiftcount]

Parameters:

result
PIC 9(n)
operand
A non-numeric or numeric operand
shiftcount
PIC 9(n)

On Entry:

operand
A non-numeric or numeric operand.
shiftcount
The number of positions to shift during the operation.

On Exit:

result
The result of the operation.

Comments:

If operandrefers to a non-numeric data item, the value of the data item is shifted right by the number of bit positions specified by shiftcount. Any bits shifted off the right end are lost and zero-valued bits are shifted into the left end. The value of Result is set to a non-zero value if any character of operand is non-zero after the operation completes and zero otherwise.

If operand refers to a numeric data item, the operand is converted, if necessary, to a 32-bit binary integer. The 32-bit binary value is logically shifted right by the number of bit positions specified by shiftcount. If the GIVING phrase is specified, the result of this operation is stored in result and the value of operand is not modified. If the GIVING phrase is not specified, the result of this operation is stored in operand.

Related information
Call Conventions for Interfacing with Mixed Languages


CASCF0016 - CASCF0030

  • CASCF0016S
    The global configuration save file ($CASDIR/gcf.bin) could not located.
  • CASCF0017S
    The region configuration save file ($REGIONBASE/$CASREGN/rcf.bin) could not be located.
  • CASCF0018S
    The development configuration file (dcf.bin) could not be located.
  • CASCF0019S
    An error occurred when creating the global configuration save file (gcf.bin).
  • CASCF0020S
    An error occurred when creating the region configuration save file (rcf.bin).
  • CASCF0021S
    An error occurred when creating the development configuration save file (dcf.bin).
  • CASCF0022S
    An error occurred when opening the global configuration save file (gcf.bin).
  • CASCF0023S
    An error occurred when opening the region configuration save file (rcf.bin).
  • CASCF0024S
    An error occurred when opening the development configuration save file (dcf.bin).
  • CASCF0025S
    An error occurred when opening the global configuration file ($CASDIR/dfhtx.cfg)
  • CASCF0026S
    An error occurred when opening the region configuration file ($REGIONBASE/$CASREGN/dfhtx.cfg).
  • CASCF0027S
    An error occurred when opening the development configuration file (dfhtxdev.cfg).
  • CASCF0028S
    An error occurred when reading the global configuration save file (gcf.bin).
  • CASCF0029S
    An error occurred when reading the region configuration save file (rcf.bin).
  • CASCF0030S
    An error occurred when reading the development configuration save file (dcf.bin).
Parent topic: CASCF Error Messages


CASCS1015E

Outbound transaction routing of transaction trans-id failed because system system-id is not acquired.
System Action:
The request is rejected
Resolution:
Place the connection system-id in service and acquired
Destination:
user terminal and TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASCD0060I

The server has been started.
System Action:
None
Resolution:
None
Destination:
standard error
Module:
dfhserv
Parent topic: CASCD0050 - CASCD0099


CASCF0031 - CASCF0045

  • CASCF0031S
    An error occurred when reading the global configuration file ($CASDIR/dfhtx.cfg)
  • CASCF0032S
    An error occurred when opening the region configuration file ($REGIONBASE/$CASREGN/dfhtx.cfg).
  • CASCF0033S
    An error occurred when opening the development configuration file (dfhtxdev.cfg).
  • CASCF0034S
    An error occurred when writing the global configuration save file (gcf.bin).
  • CASCF0035S
    An error occurred when writing the region configuration save file (rcf.bin).
  • CASCF0036S
    An error occurred when writing the development configuration save file (dcf.bin).
  • CASCF0037S
    The directory specified by the CASLOCAL environment variable is invalid.
  • CASCF0038S
    The directory specified by the CASDIR environment variable is invalid.
  • CASCF0039S
    The region file directory ($REGIONBASE/$CASREGN/files/reg) is invalid.
  • CASCF0040S
    The resource definition file path points to a directory is invalid.
  • CASCF0041S
    The system files directory ($CASDIR/files/sys) is invalid.
  • CASCF0042S
    The region's base directory ($REGIONBASE/$CASREGN) in invalid.
  • CASCF0043F
    The messaging support module could not be loaded as part of system initialization. This module is required for normal system operation.
  • CASCF0044F
    The utility support module could not be loaded as part of system initialization. This module is required for normal system operation.
  • CASCF0045F
    The file handling support module could not be loaded as part of system initialization. This module is required for normal system operation.
Parent topic: CASCF Error Messages


JCLCM0489E No value decoded for limitation type global output limit

Syntax error in the environment setting for a limitation.

Resolution:

Correct the syntax error.

Parent topic: JCLCM0400 - JCLCM0499


CASRD0037E

A conversion table entry of type resource-type (entry resource-name, group group-name) is invalid.
System action:
The entry is bypassed
Resolution:
Correct the definition
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASCD0026S

The CAS Daemon did not respond to the shutdown request, it is not possible to determine the current state of the daemon
System Action:
The request is rejected
Resolution:
Determine the cause of the error and retry if appropriate
Destination:
standard error
Module:
dfhtxp
Parent topic: CASCD0016 - CASCD0031


CASRD0012W

The resource type resource-type (resource resource-name, group group-name) is not supported.
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


The cobmode Utility

Run the cobmode utility from the command line to set the global effective working mode or view the current mode in effect for your session.

The effective working mode determines your ability to compile and run 32- and 64-bit applications. Using the effective working mode in conjunction with the generic cob and cobrun commands has the same effect as using one of the bit-specific commands (for example, cob32 or cobrun64).

The cobmode utility enables you to set the global effective working mode, which affects all users that currently point the $COBDIR variable at the same location. Local effective working mode, which is set using the COBMODE environment variable, only affects your current session. If both modes are set, the local effective working mode is used.

The cobmode utility, and the need to set the effective working mode, is only available if your system is capable of developing or running 64-bit applications. If it is capable and the effective working mode is not set, effective working mode defaults to 32-bit.


CASCD1039I

The ES Communications Server process for ES region-name has successfully completed termination
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


JCLAM0223S Insufficient authority to update dataset %

Lack of permissions to perform this action.

Resolution:

Contact your system administrator.

Parent topic: JCLAM0180 - JCLAM0230


CASST5201I

The spool service has terminated normally
System Action:
None
Resolution:
None
Destination:
console
Module:
dfhgspol
Parent topic: CASST5000 - CASST6002


CASCD0016 - CASCD0031

  • CASCD0016W
    The region name specified on the command line to dfhtxs to auto-start was found to be invalid. If the region can not be located under $CASDIR or appropriate REGIONBASE directory then it is removed from the auto-start region list.
  • CASCD0022E
    There is no CAS Daemon to shutdown.
  • CASCD0023S
    The specified option is not valid
  • CASCD0024S
    Too many arguments were specified, the maximum permitted is 1.
  • CASCD0025S
    A UNIX call returned with errno set to errnoThe call that failed is specified by errno, where: 1 = msgget 2 = msgsnd 3 = fgets 4 = fopen 5 = mknod
  • CASCD0026S
    The CAS Daemon did not respond to the shutdown request, it is not possible to determine the current state of the daemon
  • CASCD0027W
    The immediate shutdown option of the console daemon shutdown utility abends all running regions. Data may be lost or the system may be left in an unstable state. This option should only be used as a last resort. It is recommended that each region is shutdown cleanly before using the dfhtxp command.
  • CASCD0028I
    If the CAS Console Daemon is not running with the effective user ID of root (UID=0) this message details the current effective user id. The effective user ID that the CAS console Daemon runs as, and all region created, is set at installation time.
  • CASCD0029I
    This exit provides external control for starting CAS server instances. It will be given control each time the console daemon wants to start a new server instance.
  • CASCD0030I
    Console daemon forwarded a server instance start request to the casexitv exit program and casexitv returned with a non-zero return code of return-code.
  • CASCD0031I
    A server has been started for region region-name. server-number server start requests have been issued.
Parent topic: CASCD Error Messages


CASCD0115E

The CAS Daemon was already shutting down when this request was received
System Action:
Ignore the redundant shutdown request
Resolution:
None
Destination:
standard error
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


CASCD0153S

Region region-name has abended during termination due to receipt of signal signal-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


JCLAM0230S Insufficient authority to use PCDSN dataset %

Lack of permissions to perform this action.

Resolution:

Contact your system administrator.

Parent topic: JCLAM0180 - JCLAM0230


CASCF0059F

The CAS configuration module could not be located during system initialization. This module is required for normal system operation.
System Action:
Terminate the requesting process
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


JCLAM0226U Insufficient authority for SYSPRINT dataset %

Lack of permissions to perform this action.

Resolution:

Contact your system administrator.

Parent topic: JCLAM0180 - JCLAM0230


CASCD0111I

The CAS Daemon is beginning an orderly shutdown and will wait for the number-of-regions regions to terminate before shutting down
System Action:
Wait for regions then shutdown
Resolution:
None
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


CASCF0001 - CASCF0015

  • CASCF0001F
    An error has occurred during Region configuration file processing Refer to CASCF0002F for the possible values of RC-1 and RC-2
  • CASCF0002F
    An error has occurred during Region configuration file processing.
  • CASCF0003F
    The messaging support module could not be loaded as part of system initialization. This module is required for normal system operation.
  • CASCF0004F
    The configuration support module could not be loaded as part of system initialization. This module is required for normal system operation.
  • CASCF0005F
    The utility support module could not be loaded as part of system initialization. This module is required for normal system operation.
  • CASCF0006F
    The file handling support module could not be loaded as part of system initialization. This module is required for normal system operation.
  • CASCF0007F
    The file handling support module could not be loaded as part of system initialization. This module is required for normal system operation.
  • CASCF0008F
    An unexpected error occurred in system initialization while processing the configuration file.
  • CASCF0010S
    An unrecognized line was found in the global configuration file ($CASDIR/dfhtx.cfg) at the line shown.
  • CASCF0011S
    An unrecognized line was found in the region configuration file ($REGIONBASE/$CASREGN/dfhtx.cfg) at the line shown.
  • CASCF0012S
    An unrecognized line was found in the development configuration file (dfhtxdev.cfg) at the line shown.
  • CASCF0013S
    The global configuration file ($CASDIR/dfhtx.cfg) could not located.
  • CASCF0014S
    The region configuration file ($REGIONBASE/$CASREGN/dfhtx.cfg) could not be located.
  • CASCF0015S
    The development configuration file (dfhtxdev.cfg) could not be located.
Parent topic: CASCF Error Messages


CASRD0020E

The resource definition for terminal resource-name is not installable. The existing installed definition is not replaceable.
System action:
Continue, the group will not be installed.
Resolution:
None
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


Attributes - in COBOL and C#

Attributes in Managed COBOL

*> Define attributes on a class
class-id MyClass
          attribute WebService(name Description = "My service")
          attribute Obsolete.

*> Define attributes on a field
01 a binary-long attribute XmlAttribute("UpperB")
          attribute Obsolete static.

*> Define attributes on a property
*> Note that in this case, the attributes must follow
*> the reserved word PROPERTY
01 b binary-long property
          attribute XmlAttribute("UpperB")
          attribute Obsolete static.

*> Define attributes on an event
*> Note that the attributes must follow
*> the reserved word EVENT.
01 d type fred event
          attribute Obsolete static.

*> Define attributes on a method
method-id main
          attribute Obsolete static.
procedure division
    move 999 to a
    display a

end method.

*> Define attributes on a method parameter and return type
method-id stat static.
procedure division
          using by value l1 as binary-long
                   attribute CLSCompliant(true)
                   attribute MarshalAs(3)
          returning l2 as binary-long
                   attribute CLSCompliant(true)
                   attribute MarshalAs(2).
    move 999 to a
    display a
    set d to null
end method.

*> Define attributes on a property
method-id set property prop
          attribute Obsolete static.
procedure division using by value l1 as binary-long.
    move l1 to a
end method.

end class.

*> Define attribute on a delegate
delegate-id fred attribute Obsolete.
procedure division using by value l1 as binary-long.
end delegate.

Atttributes in C#

// C# terminology : attribute
// Define attributes on a class
[WebService(Description = "MyService")]
[Obsolete]
class MyClass
{
    // Define attributes on a field
    [XmlAttribute("UpperB")]
    [Obsolete]
    long a;

    // Define attribute on a property
    private string prop;

    [Obsolete]
    public string b
    {
        [return:XmlAttribute("UpperB")]
        get { return prop; }

        [value:XmlAttribute("UpperB")]
        set { prop = value; }
    }

    // Define attribute on an event
    [Obsolete]
    public event fred d;

    // Define attribute on a method
    [Obsolete]
    public void main()
    {
    }

    // Define attributes on parameters and returns
    [return:CLSCompliant(true)]
    [return:MarshalAs(2)]
    public long Stat([CLSCompliant(true)][MarshalAs(3)]long l1)
    {
        return 12;
    }

    // Define attributes on a property
    [Obsolete]
    public string b
    {
        set { prop = value; }
    }

    // Define attributes on a delegate
    [Obsolete]
    public delegate void fred(long l1);
}
Related reference
Attributes


CASKC0000E

Transaction trans-id is not defined in the region Program Control Table (PCT).
System action:
The transaction request is reject.
Resolution:
Supply a correct transaction identifier or request that the system administrator add the transaction identifier definition to the region PCT.
Destination:
User terminal
Module:
dfheserv
Parent topic: CASKC0000 - CASKC0015


CASCD0159F

Only one CAS Daemon is required, attempts to start more are rejected
System Action:
The request is rejected
Resolution:
Terminate existing Daemon if restart is required
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0141 - CASCD0159


RM/COBOL Library Routines

The following RM/COBOL routines are available in this COBOL system.


CASCS1119I

The CAS CCI gateway received an bind from region remote-region. The bind is rejected because the local region has initiated a bind to this remote region and contention rules dictate that the local region should be the contention winner.
System Action:
The bind from the remote region is rejected. The bind initiated by the local region is allowed to continue
Resolution:
None
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASCF0043F

The messaging support module could not be loaded as part of system initialization. This module is required for normal system operation.
System Action:
Terminate the requesting process
Resolution:
Check that $CASDIR is set correctly and the module dfh0msg exists in $CASDIR/lib.
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASCD0031I

A server has been started for region region-name. server-number server start requests have been issued.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0016 - CASCD0031


CASCD0130I

Region region-name has successfully completed termination
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASCD0113I

The CAS Daemon has terminated
System Action:
None
Resolution:
None
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


CASCS5100I

An informational message generated from a Communications Server.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
casgate
Parent topic: CASCS5010 - CASCS5103


CASCD1032I

A MQSeries Gateway has been started for region region-name This gateway emulates the CKTI trigger monitor transaction.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


CASST0009W

An attempt to shutdown a region externally via a transid was rejected as the transaction is defined as remote.
System action:
The region will not be shutdown.
Resolution:
Make sure that the transaction is local.
Destination:
Console
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


CASKC0007W

The system shared memory resource limit has been reached. The shared storage cushion will be released and made available to the system. Any GETMAIN SHARED or LOAD HOLD requests will be rejected until the critical memory condition is alleviated. Any tasks which require more storage than is available will will be suspended until the storage requirements can be met.
System action:
Make the shared storage cushion available and suspend any tasks which require more memory than is available until their requirements can be met.
Resolution:
If this is a common occurrence increase the number of shared pages in the SIT.
Destination:
System Console.
Module:
dfhgglbl
Parent topic: CASKC0000 - CASKC0015


CASRD1001I

The service was updated successfully.
System action:
None.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1000 - CASRD1015


CASCF0048F

The value for the environment variable is larger than the internal work areas. This may result in an invalid value so the initialization will be aborted.

Some values for ID are:

  • 01 - $COBCPY / CASCPYSRC
System Action:
Terminate the requesting process
Resolution:
Check the directories specified in the appropriate environment variable / configuration items are required
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASCD0167I

The CAS daemon was not active when the start region request was issued. The CAS daemon was automatically started.
System Action:
Start CAS daemon
Resolution:
None
Destination:
standard error
Module:
dfhrem
Parent topic: CASCD0160 - CASCD0175


Enumeration - in COBOL and C#

Enumeration in Managed COBOL

enum-id Action public.
working-storage section.
01 binary-long.         *> Underlying type for the enum.
                        *> binary-long is the default
    78 Starter value 0. *> Declare enum values as level-78 items
    78 Stop    value 1.
    78 Rewind  value 2.
    78 Forward value 3.
end enum.
*> Short hand version of above.
*> PUBLIC and BINARY-LONG are the defaults
*> The default values are 0 1 2...
enum-id Action.
   78 Starter.
   78 Stop.
   78 Rewind.
   78 Forward.
end enum.
enum-id Status.
   78 Flunk value 50.
   78 Pass value 70.
   78 Excel value 90.
end enum.
program-id main.
   display type Status::Pass as binary-long *> prints 70
   display type Status::Pass                *> prints Pass
end program.

Enumeration in C#

enum Action {Start, Stop, Rewind, Forward};
enum Status {Flunk = 50, Pass = 70, Excel = 90};

Action a = Action.Stop;
if (a != Action.Start)
  Console.WriteLine(a + " is " + (int) a);   // Prints "Stop is 1"

Console.WriteLine((int) Status.Pass);        // Prints 70
Console.WriteLine(Status.Pass);              // Prints Pass
Related reference
Enums


Constants - in COBOL and C#

Constants in Managed COBOL

78 MAX_STUDENTS value 25.  *> default public, binary-long

*> INITIALIZE ONLY - instance or static, may be initialized in constructor
01 MIN_DIAMETER float-short value 4.93 initialize only.

Constants in C#

const int MAX_STUDENTS = 25;

// Can set to a const or var; may be initialised in a constructor
readonly float MIN_DIAMETER = 4.93f;
Related reference
Fields


CASCS1500 - CASCS2004

  • CASCS1500I
    The CAS gateway initialized successfully. Remote requesters can now connect to the region.
  • CASCS1501I
    The CAS gateway has started shutdown processing.
  • CASCS1502W
    The CAS gateway failed to initialize successfully.
  • CASCS2001E
    A systems data stream was received by the CAS mirror transaction trans-ID that is logically too short to decode.
  • CASCS2002E
    A systems data stream was received by the CAS mirror transaction trans-ID that is not supported. It is not an FMH 5, 6, or 43.
  • CASCS2003E
    A systems data stream was received by the CAS mirror transaction trans-ID that contained an invalid structured field.
  • CASCS2004E
    The systems transaction trans-ID was executed from an invalid terminal type. term-ID is the originating terminal. The most most likely cause of this error is that a user entered this transaction in error.
Parent topic: CASCS Error Messages


Java Calling JVM COBOL

In order to call JVM COBOL from Java, you need to add the JVM COBOL project to the build path of the Java project and to import any COBOL classes you want to use into your Java sources.

This is an outline of the steps to enable calling JVM COBOL from Java:

  1. In your Eclipse workspace, create a JVM COBOL project for your COBOL program.
  2. In your Eclipse workspace, create a Java project for the calling Java program.
  3. In the Java project, add the JVM COBOL project to the project's Java build path.
  4. Add mfcobol.jar and the JVM COBOL Runtime, mfcobolrts.jar to the project's classpath.

    This ensures proper interoperation of Java code with COBOL types which are not directly mapped to JVM types such as COBOL group items or COBOL numeric types which are longer than four bytes.

  5. In the Java source code, add an import statement to import the COBOL class you want to use or the entire package into your Java source file as follows:
    import com.microfocus.cobol.MyClass

    or

    import com.microfocus.cobol.*
    Note: We recommend that you use the RunUnit class for multi-user environments. See com.microfocus.cobol.runtimeservices for more information.
Related reference
com.microfocus.cobol.runtimeservices


CASCS1001 - CASCS1018

  • CASCS1001S
    Inbound allocate for transaction trans-id failed because it could not acquire sufficient process storage to issue the receive allocate.
  • CASCS1002E
    Inbound allocate for transaction trans-id failed because of a communications error. trans-id is the primary return code of the communications layer.
  • CASCS1003S
    Inbound transaction routing of transaction trans-id failed because the terminal term-id is not owned by the remote system system-id. The request originated from a terminal that has the same term-id as another remote system or the term-id is defined as local to this CICS region.
  • CASCS1004S
    Inbound allocate for transaction trans-id failed because it could not acquire sufficient process storage to store the transmitted data.
  • CASCS1006E
    Inbound transaction trans-id from system system-id failed with a primary communications return code of comms-primary-RC.
  • CASCS1007E
    The terminal definition for terminal-id was requested from the remote system while trying to process transaction trans-id. The primary communications return code is comms-primary-RC.
  • CASCS1008E
    The install for terminal definition for terminal-id was rejected. The table manager return code is return-code.
  • CASCS1009S
    The install for terminal definition failed to acquire local storage during execution of transaction trans-id.
  • CASCS1010E
    A terminal definition was requested from system system-id. The response received was not a valid builder list.
  • CASCS1011E
    Outbound transaction routing of transaction trans-id to system system-id is not supported because there is no communications buffer allocated.
  • CASCS1012E
    Outbound transaction routing of transaction trans-id to system system-id failed with a communications return-code of comms-primary-RC. Refer to the communications protocol stack documentation for other return codes and for more information. Also note that some protocol stacks use different values for the above conditions.
  • CASCS1013E
    Outbound transaction routing of transaction trans-id failed because system system-id is not defined.
  • CASCS1014E
    Outbound transaction routing of transaction trans-id failed because system system-id is marked out of service.
  • CASCS1015E
    Outbound transaction routing of transaction trans-id failed because system system-id is not acquired.
  • CASCS1016E
    Outbound transaction routing of transaction trans-id failed because system system-id is not defined as a connection.
  • CASCS1017E
    Inbound transaction trans-id from system system-id failed security check for user user-id. The password supplied by the remote system was not valid.
  • CASCS1018E
    Inbound transaction trans-id from system system-id failed security check for user user-id. The user ID was not found in this system's SNT.
Parent topic: CASCS Error Messages


ILSMARTLINKAGE

Exposes the linkage section and entry points to managed code by creating types.

Syntax:

Restriction: This directive is supported for managed COBOL only.
>>-.---.-.-------ILSMARTLINKAGE---.-------------.--.--------><
   +-/-+ |                        +-"namespace"-+  |
         +-----NOILSMARTLINKAGE--------------------+

Parameters:

namespace
The namespace in which each generated class is grouped

Properties:

Default: | ILSMARTLINKAGE
Phase: | Syntax check
$SET: | Initial

Comments:

This directive exposes group linkage items to managed code. In addition to the class generated as usual for the COBOL program, this directive effectively generates one class for every 01 level group item in the linkage section. Each data item in the group is exposed as a property of this class, where the property is of a standard managed type. Subordinate groups are exposed as strings.

Hyphens are removed from data item names and the letter following a removed hyphen is folded to upper case. For example a data item author-name is renamed to AuthorName.

If a namespace is specified, all classes generated as a result of this directive are grouped under that namespace.

Example:

The following COBOL program is compiled with ILSMARTLINKAGE, ILCUTPREFIX(lnk-b-) and ILCUTPREFIX(lnk-):

       program-id. BookLegacy.
                         ...
       linkage section.
       01 lnk-function            pic x.
       01 lnk-b-details.
          03 lnk-b-text-details.
             05 lnk-b-title       pic x(50).
             05 lnk-b-type        pic x(20).
             05 lnk-b-author      pic x(50).
          03 lnk-b-stockno        pic x(4).
          03 lnk-b-retail         pic 99v99.
          03 lnk-b-onhand         pic 9(5).
       procedure division using by value lnk-function
                                by reference lnk-b-details.

In C#, you can access the data in BookLegacy program in .NET managed COBOL as follows:

    BookLegacy myBook = new BookLegacy();
         //creates an object corresponding to the BookLegacy program
    Details myDetails = new Details();
         //creates an instance corresponding to the group lnk-b-details
    . . .
       myDetails.Stockno = "6666";
       myDetails.Title = "Managed COBOL";
       myDetails.Author = "Mike Focus";
       myDetails.Type = "Reference";
       myDetails.Retail = 15.50M;
       myDetails.Onhand = 20;
       myDetails.Sold = 5;
       myBook.BookLegacy("2", myDetails);
         // calls the BookLegacy method with myDetails,
         // which corresponds to the group item lnk-b-details

See the C# WinBook demonstration in the Studio Enterprise Edition samples for more.

Related reference
ILSMARTNEST
ILSMARTRESTRICT


JCLCM0491E Invalid action parameter for limitation type global SYSOUT limit

The action parameter is not one of the recognised options WARNING, CANCEL, or DUMP.

Resolution:

Correct the action parameter.

Parent topic: JCLCM0400 - JCLCM0499


CASKC0010I

The animation server has shutdown normally. The shutdown was implicitly requested by closing the associated terminal.
System action:
The process terminates normally.
Resolution:
None.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0000 - CASKC0015


CASCD0155S

The 3270 printer service of region region-name has abended due to receipt of signal signal-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASRD0041E

The READ for resource type resource-type (resource resource-name, group group-name) failed for reason reason-code.
System action:
The request is not executed
Resolution:
Check resource file (DFHDRDAT), correct the request and resubmit
Destination:
terminal, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASCD0008F

CAS failed to create a UNIX message queue A UNIX message queue call returned with errno set to functionThe call that failed is specified by function, where: 1 = msgget 2 = msgctl 3 = msgrcv 4 = msgsnd
System Action:
The CAS Daemon is not started
Resolution:
Determine the cause of the error and retry if appropriate
Destination:
standard error
Module:
dfhmd
Parent topic: CASCD0001 - CASCD0015


esqlconfig command

Runs the command-line implementation of the OpenESQL Configuration utility, enabling you to set a default behavior for the SQL(BEHAVIOR) compiler directive option.

Syntax:

esqlconfig {-P[erformance] | -A[NSI] | -C[ompatibility] | -W[arning]
| -E[rror] | -D[isplay] | -H[elp]}

Parameters:

P[erformance] | Sets the default to Optimize for performance and mainframe compatibility, and displays the old and new settings
A[NSI] | Sets the default to ANSI compliance, and displays the old and new settings
C[ompatibility] | Sets the default to No change in default behavior and no optimization, and displays the old and new settings
W[arning] | Sets the default to Issue a warning at compile time, and displays the old and new settings
E[rror] | Sets the default to Issue an error at compile time, and displays the old and new settings
D[isplay] | Displays the current default setting
H[elp] | Displays the current default setting, and displays the syntax for the esqlconfig command

Comments:

If you enter no parameters or an invalid parameter, esqlconfig displays the current default setting and appropriate syntax as if you had specified the -H parameter.

For more information about parameter settings, see the topic OpenESQL Configuration Utility.

Related concepts
OpenESQL Configuration Utility
Related information
To start the OpenESQL Configuration Utility
OpenESQL Configuration Utility


General Debugging Options

You can specify options that control the behavior when debugging Micro Focus COBOL in Tools > Options > Debugging .
COBOL Debugging Settings > Step into inline PERFORM statements when using Step Over
By default, Step Over (F10) skips inline PERFORM statements.
Check this option to enable stepping into inline PERFORM statements when you use Step Over. Works with native code only.
Just-in-time > Micro Focus COBOL
Check this to enable just-in-time debugging for when the application fails.
Symbols
Add a new folder by clicking New Folder, and in the Symbol file locations list, enter the absolute path to the .idy files. This makes the symbol files (.idy) available for debugging.


CASRD0030E

The resource-type entry resource-name is locked with an ENQ. Some other operation is currently being executed that involves it.
System action:
Install continues but the CVT for resource-name is bypassed.
Resolution:
Verify that the proper group is being installed and retry
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASCD0063S

The server has sent no progress messages, its state is not known
System Action:
None
Resolution:
Determine the cause of the error and retry if appropriate
Destination:
standard error
Module:
dfhserv
Parent topic: CASCD0050 - CASCD0099


JCLCM0200 - JCLCM0299

  • JCLCM0200S job-number job-name DISP=NEW, DATASET EXISTS - DDNAME
    The specified DD statement specifies DISP=NEW but the data set name specified already exists in the catalog.
  • JCLCM0201S job-number job-name DATASET IS NOT A PDS - DDNAME
    The specified DD statement refers to a PDS member but no PDS model by the same name exists in the catalog.
  • JCLCM0202S job-number job-name DISP=OLD/SHR, DATASET NOT FOUND - DDNAME
    The specified DD statement specifies DISP=OLD or DISP=SHR but the data set name specified does not exist in the catalog.
  • JCLCM0203S ACI option has overridden step abend S422
    You have requested the Automatic Catalog Input option, and therefore an S422 abend has been ignored.
  • JCLCM0205I job-number job-namePROGRAM FUNC=func/functext RC=rcode/rcodetext
    The specified program has detected an unexpected return code from the MVS Job Step Resource Manager (MJRM). Details of the function and return code are provided in the message.
  • JCLCM0206I job-number job-name ALLOCATION DEFERRED UNTIL OPEN - DDNAME
    In the specified DD statement, the first (or only) data set specified does not exist and the step being executed is an IMS batch step.
  • JCLCM0207I job-number job-name DUPLICATE DD STATEMENT IGNORED - DDNAME
    The specified DD statement is a duplicate of a DD statement defined earlier in the job step.
  • JCLCM0208I job-number job-name Host OS may require SPACE for DD "DD-name"
    The host operating system (MVS, OS/390, z/OS) might require that you specify the SPACE parameter unless the data set is allocated to a device such a tape device.
  • JCLCM0209S job-number job-name DISP=NEW, UNCATALOGED DUPLICATE EXISTS - DDNAME
    The specified DD statement specifies DISP=NEW but the data set name specified already exists in the catalog (in an uncataloged state).
  • JCLCM0210U job-number job-name I/O ERROR ON SPOOL FILE
    An I/O error has occurred while accessing the spool file containing JOB output.
  • JCLCM0211S job-number job-name Dataclass "name" does not exist
    This specified data class has not been defined to this system.
  • JCLCM0212S job-number job-name REFDD dataclass "name" does not exist
    This specified data class has not been defined to this system.
  • JCLCM0213S job-number job-name Main pgm name did not issue GOBACK or STOP RUN
    The specified main COBOL program fell through to the end of the program without executing a GOBACK or a STOP RUN statement.
  • JCLCM0214S Required resources could not be obtained
    All the required datasets for this job are unavailable. Probably some other job or user is using them.
  • JCLCM0216S Insufficient storage available to process the job
    Either you have defined more data sets than the system can handle, or there is an internal error.
  • JCLCM0217S Internal system error "internal code"
    Internal error.
  • JCLCM0218S System error "internal code"
    System error.
Parent topic: JCLCM Error Messages


CASST4101I

A request to shutdown the Micro Focus Transaction System IMMEDIATELY has been entered using the PERFORM SHUTDOWN command.
System action:
Shutdown processing is started; no PLT processing will be done.
Resolution:
None
Destination:
Console
Module:
casrdo11
Parent topic: CASST4000 - CASST4111


CASCS1500I

The CAS gateway initialized successfully. Remote requesters can now connect to the region.
System Action:
None
Resolution:
None
Destination:
console
Module:
hydra
Parent topic: CASCS1500 - CASCS2004


CASXO0014S

The Resource manager for the XAT resource returned a non-zero value to the xa_commit call.

The return codes are:

  • -2 Asynchronous operation already outstanding
  • -3 A resource manager error occurred
  • -4 The XID is not valid
  • -5 Invalid arguments were given
  • -6 Routine invoked in an improper context
  • -7 Resource Manager unavailable
  • -8 the XID already exists
  • -9 Resource Manager doing work outside global transaction
System Action:
The Transaction is abnormally terminated
Resolution:
Check that the Resource Manager is still available
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


com.microfocus.cobol.runtimeservices

Restriction: com.microfocus.cobol.runtimeservices is supported for JVM COBOL only.

The com.microfocus.cobol.runtimeservices class library provides the following classes:

  • CallableProgram
  • Interop
  • RunUnit

To use these classes in your Java programs, add mfcobolrts.jar to the build path of your Java project.

For information on these classes, import the Javadocs into Eclipse. They are available in the file mfcobolrts.docs.zip, which is located in the Help folder of your installation folder. The default location for this is %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.x.

To view the Javadocs as standalone Help, unzip the file, and then double-click index.html in Windows Explorer.

Related concepts
Java Calling JVM COBOL


CASRD0015W

The resource type resource-type (resource resource-name, group group-name) is not recognized.
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


CASST4021E

The PLTSD processing encountered an error in processing program list or one of the programs in the list ABENDed.
System action:
Shutdown processing aborted.
Resolution:
Do a SHUTDOWN IMMMEDIATE to bypass PLTSD processing.
Destination:
Console (and Terminal)
Module:
dfhzcqit
Parent topic: CASST4000 - CASST4111


CASCD0134I

CAS attempted to exec dfhgdied, but the call failed with errno errno
System Action:
Terminate the new process and abort the attempt to inform the region manager of the process which has terminated
Resolution:
Determine and fix cause of failure then retry
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


C$GetLastFileName

Retrieves the last filename used in a COBOL I/O statement (including OPEN and CLOSE).

Syntax:

Note: When calling this routine, ensure you are using the 1024 calling convention.
CALL "C$GetLastFileName" USING filename

Parameters:

filename
PIC X(30)

On Exit:

filename
The name of the filename used in the last I/O operation.

Comments:

For REWRITE and WRITE statements, the COBOL filename associated with the specified file record-name is provided.

If the filename is longer than 30 characters, it is truncated to the right.

Related information
Call Conventions for Interfacing with Mixed Languages


CASRD0035W

An attempt was made to install the resource-type entry resource-name from group group-name. The base resource definition table was not found.
System action:
Continue, the CVT definition is not installed.
Resolution:
Install the base resource and than re-install this group.
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASCD0161I

The CAS Daemon has initialized and is waiting for work
System Action:
None
Resolution:
None
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0160 - CASCD0175


CASCD4007E

Error error-message when trying to log to the windows event log.
System Action:
SYSACTION
Resolution:
Report the error to technical support
Destination:
console and standard error
Module:
dfhmd
Parent topic: CASCD4002 - CASCD4007


CASRD0026E

The resource definition for resource-type entry resource-name is not installable. The existing installed definition is in use.
System action:
Continue, the group will not be installed.
Resolution:
Close and disable the file and retry the operation.
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASCD4004W

An error occured whilst binding to the MF Directory Server.
System Action:
Continue initialization using defaults
Resolution:
None
Destination:
Console and standard error
Module:
dfhmd
Parent topic: CASCD4002 - CASCD4007


CASCD1064I

An Event Manager for Server server-name has successfully completed termination
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


CASCD1001 - CASCD1043

  • CASCD1001S
    An error occurred locating the region directory for region region-name. Either the region is not defined or environment variable CASDIR is pointing to the wrong place.
  • CASCD1002S
    An error occurred locating the target directory for the region work files.
  • CASCD1003S
    An error occurred locating the target directory for the system work files.
  • CASCD1004S
    An error occurred setting up the environment variables for the region. The return code from the function is reason-code.
  • CASCD1010S
    An error occurred whilst processing the global configuration file.
  • CASCD1011S
    An error occurred while processing the region configuration file.
  • CASCD1020I
    The JCP service has been started for region region-name
  • CASCD1031S
    The ODBC service process of region region-name has exited, the value specified on the exit call was exit-value
  • CASCD1032I
    A MQSeries Gateway has been started for region region-name This gateway emulates the CKTI trigger monitor transaction.
  • CASCD1033I
    The MQSeries Gateway service process for region region-name has successfully completed termination
  • CASCD1034S
    The MQSeries Gateway process of region region-name has exited, the value specified on the exit call was exit-value
  • CASCD1035I
    A Spool service has been started for region region-name
  • CASCD1036I
    The Spool service process for region region-name has successfully completed termination
  • CASCD1037S
    The Spool service of region region-name has exited, the value specified on the exit call was exit-value
  • CASCD1038I
    An ES Communications Server has been started for ES region-name
  • CASCD1039I
    The ES Communications Server process for ES region-name has successfully completed termination
  • CASCD1040S
    The ES Communication Server of ES region-name has exited, the value specified on the exit call was exit-value
  • CASCD1041S
    The ES Console was notified of a process death that it did not know about. This should not occur.
  • CASCD1042I
    The IMS TM Control Process has been started for Server server-name
  • CASCD1043I
    The IMS DB Control Process has been started for Server server-name
Parent topic: CASCD Error Messages


CASCD0145S

The 3270 printer service of region region-name has exited, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASCD0120 - CASCD0139

  • CASCD0120I
    The REM for region region-name has been started. It will run with a process-id of pid
  • CASCD0122E
    An attempt was made to start a region or server when the system was shutting down
  • CASCD0123E
    An attempt was made to start a region (region-name) for which a REM was already running
  • CASCD0124E
    An attempt was made to start a server for a region which is not active
  • CASCD0125I
    CAS attempted to exec executable-name, but the call failed with errno errno
  • CASCD0126I
    CAS attempted to fork a new process from the CAS Daemon process but the call failed with errno errno
  • CASCD0127I
    A server has been started for region region-name, it is the server-number server to be started for that region and will run with a process-id of pid
  • CASCD0128I
    The 3270 printer service has been started for region region-name
  • CASCD0129I
    The 3270 CCI gateway service has been started for region region-name
  • CASCD0130I
    Region region-name has successfully completed termination
  • CASCD0131I
    Server server-number of region region-name has successfully completed termination
  • CASCD0132I
    The 3270 printer service for region region-namehas successfully completed termination
  • CASCD0133I
    The 3270 CCI gateway service for region region-namehas successfully completed termination
  • CASCD0134I
    CAS attempted to exec dfhgdied, but the call failed with errno errno
  • CASCD0135I
    CAS attempted to fork a new process from the CAS Daemon process but the call failed with errno errno
  • CASCD0136W
    CAS attempted to exec dfhgrtrm, but the call failed with errno errno
  • CASCD0137W
    The CAS Daemon process created a child process which could failed in initialization due to a failed 'execlp' call.
  • CASCD0138F
    CAS attempted to exec dfhgrtrm, but the call failed with errno errno
  • CASCD0139I
    The CAS Daemon was started automatically as part of region startup. No regions are active so the CAS Daemon is automatically terminating.
Parent topic: CASCD Error Messages


CASCD0061F

The request to start a server was not successful
System Action:
The server is not started
Resolution:
Check previous messages for cause of error, correct the problem and retry if appropriate
Destination:
standard error
Module:
dfhserv
Parent topic: CASCD0050 - CASCD0099


CASKC0016E

The system attempted to read an MQ queue record from the queue queue-name. The close opperation for the queue failed with reason code reason-code. This error should not occur.
System action:
None.
Resolution:
Report error to Micro Focus.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


CASCD0022E

There is no CAS Daemon to shutdown.
System Action:
The request is rejected
Resolution:
Ensure an CAS Daemon is running before attempting shutdown
Destination:
standard error
Module:
dfhtxp
Parent topic: CASCD0016 - CASCD0031


C$LogicalShiftLeft

Performs a logical shift left operation on a non-numeric or numeric operand.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:

CALL "C$LogicalShiftLeft"
[GIVING result]
 USING operand [shiftcount]

Parameters:

result
PIC 9(n)
operand
A non-numeric or numeric operand
shiftcount
PIC 9(n)

On Entry:

operand
A non-numeric or numeric operand.
shiftcount
The number of positions to shift during the operation.

On Exit:

result
The result of the operation.

Comments:

If operand refers to a non-numeric data item, the value of the data item is shifted left by the number of bit positions specified by shiftcount. Any bits shifted off the left end are lost and zero-valued bits are shifted into the right end. The value of result is set to a non-zero value if any character of operand is non-zero after the operation completes and zero otherwise.

If operand refers to a numeric data item, the operand is converted, if necessary, to a 32-bit binary integer. The 32-bit binary value is logically shifted left by the number of bit positions specified by shiftcount. If the GIVING phrase is specified, the result of this operation is stored in result and the value of operand is not modified. If the GIVING phrase is not specified, the result of this operation is stored in operand.

Related information
Call Conventions for Interfacing with Mixed Languages


CASCF0016S

The global configuration save file ($CASDIR/gcf.bin) could not located.
System Action:
Terminate the requesting process
Resolution:
Make sure that $CASDIR is set correctly and that the configuration file exists. If you are using $CASLOCAL make sure that it is set correctly.
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASRD1008I

An unrecognized administration request was made for the named service.
System action:
Reject the request.
Resolution:
Check the product installation.
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1000 - CASRD1015


CASST0018S

The Casstop process failed to initialize safmgr. The reason code is reason-code.
System action:
The Casstop command is terminated.
Resolution:
Report failure to Micro Focus
Destination:
Console and stdout
Module:
casstop
Parent topic: CASST0000 - CASST0020


CASCD0158E

An error occurred in the CCI communications of the CAS console daemon.

Some common values for CCI-error are:

  • 2 - Comms buffer too small for received message
  • 3 - Invalid session identifier given
  • 4 - Server of same name already defined (warning)
  • 5 - Server of same name already defined (error)
  • 6 - Invalid public or machine name
  • 7 - Invalid request on closed session
  • 8 - Previous connection not responding
  • 9 - Miscellaneous error
  • 10 - Request could not be executed
  • 11 - Run out of memory
  • 12 - Unknown error
System Action:
None
Resolution:
None
Destination:
console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASCD0133I

The 3270 CCI gateway service for region region-namehas successfully completed termination
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASRD0040E

The resource type resource-type (resource resource-name, group group-name) is not found.
System action:
The request is not executed
Resolution:
Correct the request and resubmit
Destination:
terminal, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASCD0009F

CAS detected an error whilst reading from a UNIX message queue A UNIX message queue call returned with errno set to functionThe call that failed is specified by function, where: 1 = msgget 2 = msgctl 3 = msgrcv 4 = msgsnd
System Action:
The CAS System shuts down
Resolution:
Determine the cause of the error and retry if appropriate
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0001 - CASCD0015


CASRD0016 - CASRD0030

  • CASRD0016W
    The resource type resource-type (resource resource-name, group group-name) is not supported.
  • CASRD0017W
    The resource type resource-type (resource resource-name, group group-name) is not recognized.
  • CASRD0018E
    The resource definition for resource-type entry resource-name is not installable. The existing installed definition is in use.
  • CASRD0019E
    The resource definition for resource-type entry resource-name is not installable. The existing installed definition is in use.
  • CASRD0020E
    The resource definition for terminal resource-name is not installable. The existing installed definition is not replaceable.
  • CASRD0021E
    The resource definition for terminal resource-name is not installable. The existing installed definition is not replaceable.
  • CASRD0022E
    The resource definition for terminal resource-name is not installable. The existing installed definition is not replaceable.
  • CASRD0023E
    The resource definition for terminal resource-name is not installable. The existing installed definition is not replaceable.
  • CASRD0024E
    The resource definition for terminal resource-name is not installable. The existing installed definition is not recognized.
  • CASRD0025E
    The resource definition for resource-type entry resource-name is not installable. The existing installed definition is in use.
  • CASRD0026E
    The resource definition for resource-type entry resource-name is not installable. The existing installed definition is in use.
  • CASRD0027E
    ARRAY(0x2a9d458)
  • CASRD0028W
    The resource type resource-type (resource resource-name, group group-name) is not supported.
  • CASRD0029W
    The CVT resource type resource-type (resource resource-name, group group-name) is not supported.
  • CASRD0030E
    The resource-type entry resource-name is locked with an ENQ. Some other operation is currently being executed that involves it.
Parent topic: CASRD Error Messages


JCLCM0012S Job cancelled by user exit MFJUSOXT

The user exit has requested that the job be cancelled as the OUTLIM value has been exceeded.

Resolution:

None.

Parent topic: JCLCM0000 - JCLCM0199


CASCD1004S

An error occurred setting up the environment variables for the region. The return code from the function is reason-code.
System Action:
The region start request is not processed
Resolution:
Correct the installation of Transaction System
Destination:
standard out
Module:
dfhrem
Parent topic: CASCD1001 - CASCD1043


CASCS1116 - CASCS1138

  • CASCS1116I
    The signature check string for CCI protocol support module module-nameis CCI-signature-string. This is a documentation message.
  • CASCS1117I
    The CAS CCI gateway connection to remote-region is lost. Active work on sysid sys-id will terminate abnormally. The CCI network protocol in use is CCI-transport.
  • CASCS1118W
    The CAS CCI gateway connection to remote-region is lost due to an abnormal termination on sysid sys-id. The CCI network protocol in use was CCI-transport.
  • CASCS1119I
    The CAS CCI gateway received an bind from region remote-region. The bind is rejected because the local region has initiated a bind to this remote region and contention rules dictate that the local region should be the contention winner.
  • CASCS1120W
    The communications server failed to establish an ISC connection to peer system remote-region. The CCI protocol return code is reason-code.
  • CASCS1121I
    The CAS CCI gateway successfully connected to the IBM Universal Client identified by netname remote-region. It is accessible via sysid sys-id. This system is the contention winner or the client side of the connection.
  • CASCS1122I
    The system is attempting to activate the connection (TCT) identified as sys-id to the region named remote-region.
  • CASCS1123I
    The client has made a connction request either from a machine with which a connection already exists or presenting a netname which is already in use.
  • CASCS1124I
    The CAS CCI gateway connection to remote-region is releasing. The action is at the request of the remote system. Active work on sysid sys-id will terminate abnormally. The CCI network protocol in use is CCI-transport.
  • CASCS1125I
    The CAS CCI gateway connection to remote-region is releasing. The action is at the request of the local system. Active work on sysid sys-id will terminate abnormally. The CCI network protocol in use is CCI-transport.
  • CASCS1131S
    An error occurred whilst processing the region configuration file.
  • CASCS1132S
    An error occurred while processing the configuration file.
  • CASCS1133S
    An unrecognized line was found in the configuration file at the line shown.
  • CASCS1134S
    The configuration file could not be found.
  • CASCS1135S
    An error occurred when creating the configuration save file.
  • CASCS1136S
    An error occurred when creating the configuration save file.
  • CASCS1137S
    An error occurred when reading the configuration save file.
  • CASCS1138S
    An error occurred when writing the configuration save file.
Parent topic: CASCS Error Messages


JCLCM0490E Error parsing numeric value for limitation type global SYSOUT limit

The value for the limitation could not be converted to a numeric value.

Resolution:

Correct the setting to be a numeric value within the limitation range

Parent topic: JCLCM0400 - JCLCM0499


CASCD1041S

The ES Console was notified of a process death that it did not know about. This should not occur.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


CASCF0031S

An error occurred when reading the global configuration file ($CASDIR/dfhtx.cfg)
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASCF0015S

The development configuration file (dfhtxdev.cfg) could not be located.
System Action:
Terminate the requesting process
Resolution:
Make sure that $CASDIR is set correctly and that the configuration file exists
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0001 - CASCF0015


CASRD0048E

The resource definition for resource-type entry resource-name is not installable. The existing installed definition is open.
System action:
Continue, the resource will not be installed.
Resolution:
Close the service and retry the operation.
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0046 - CASRD0052


CASRD0024E

The resource definition for terminal resource-name is not installable. The existing installed definition is not recognized.
System action:
Continue, the group will not be installed.
Resolution:
None
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASCS1002E

Inbound allocate for transaction trans-id failed because of a communications error. trans-id is the primary return code of the communications layer.
System Action:
The receive allocate is not issued and will time out based external communications parameters
Resolution:
The most likely cause of this error is a definition error for the invocable transaction program
Destination:
TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASCF0045F

The file handling support module could not be loaded as part of system initialization. This module is required for normal system operation.
System Action:
Terminate the requesting process
Resolution:
Check that $CASDIR is set correctly and the module dfhextfh exists in $CASDIR/lib
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASCD1042I

The IMS TM Control Process has been started for Server server-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


CASCD0131I

Server server-number of region region-name has successfully completed termination
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASST5022S

The Resource Definition file could not be opened to read the PLTSD program list table.
System action:
PLT Processing is bypassed, shutdown continues.
Resolution:
None
Destination:
Console (and Terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


JCLCM0486E Duplicate comma in action section of limitation type global SYSOUT limit

There is a syntax error in the environment settings for a limitation.

Resolution:

Fix the syntax error.

Parent topic: JCLCM0400 - JCLCM0499


CASCS5010 - CASCS5103

  • CASCS5010I
    The maximum number of sessions supported for Universal Client connections is 127. The value of the region configuration item CAS_UNICLI_SESSIONS exceeds this limit.
  • CASCS5011W
    MFCS failed to open the port for the TCPIPSERVICE TCPIPSERVICE name
  • CASCS5100I
    An informational message generated from a Communications Server.
  • CASCS5101W
    A warning message generated from a Communications Server.
  • CASCS5102E
    An error message generated from a Communications Server.
  • CASCS5103S
    A severe error message generated from a Communications Server.
Parent topic: CASCS Error Messages


CASST0011W

An attempt to shutdown a region externally via a transid was rejected as the transaction could not be scheduled due to an error allocating shared memory.
System action:
The region will not be shutdown.
Resolution:
If there is no shared memory available try to shutdown the region without a transid.
Destination:
Console
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


CASST0013W

A forceable region abend was requested via the dfhgrtrm utility without the protection of locking shared memory. This should only be used if the region is 'hung', that is, it is impossible to connect a 3270 terminal to the region or shut the region down with the /t option.
System action:
The region will be forceably abended without first obtaining a lock on shared memory.
Resolution:
This may be the only option in severe system failures, report the failure mode to Technical Support.
Destination:
Console and stdout
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


JCLAM0000 - JCLAM0119

  • JCLAM0000I job-number job-name Interactive AMS Terminated
    The MFJAMS utility has terminated.
  • JCLAM0001I job-number job-name Number of hex digits should be even
    There must be an even number of digits in a hexadecimal string. A leading x"0" has been assumed.
  • JCLAM0002S job-number job-name Invalid hex. Digits must be 0 thru 9 or A thru F.
    An invalid hexadecimal character has been encountered. The character is not a digit (0 through 9) or a letter A through F.
  • JCLAM0003U job-number job-name MISSING SYSIN DD
    The jobstream does not contain the required SYSIN DD statement.
  • JCLAM0004U job-number job-name MISSING SYSPRINT DD
    The jobstream does not contain the required SYSPRINT DD statement.
  • JCLAM0101S job-number job-name OPERAND TOO LONG [OPERAND]
    The specified operand is too long.
  • JCLAM0102S job-number job-name NUMERIC OPERAND REQUIRED [DATA]
    Numeric data was expected but the specified non-numeric data was received.
  • JCLAM0103S job-number job-name UNKNOWN PARAMETER [PARAMETER]
    The parameter is ignored, the return code is set to 12, and processing continues.
  • JCLAM0104S job-number job-name EXPECTED CONTINUATION NOT RECEIVED
    Continuation from the previous command statement was expected but not received.
  • JCLAM0105S job-number job-name INVALID ENTRYNAME FORMAT [ENTRYNAME]
    The specified entry name does not conform to the rules for MVS dataset naming.
  • JCLAM0106S job-number job-name REQUIRED OPERAND MISSING [OPERAND]
    The specified operand was expected but not received.
  • JCLAM0107S job-number job-name INVALID COMMAND (PARENS) [COMMAND]
    Command statement syntax error.
  • JCLAM0108S job-number job-name INCOMPLETE COMMAND [COMMAND]
    Command statement syntax error.
  • JCLAM0109S job-number job-name NO ENTRYNAME SPECIFIED
    The command requires an entry name.
  • JCLAM0110E job-number job-name ENTRYNAME ALREADY EXISTS [ENTRYNAME]
    A DEFINE command has been specified for a dataset which already exists.
  • JCLAM0111I job-number job-name ENTRYNAME RENAMED TO [ENTRYNAME]
    The entryname has been renamed to the specified name.
  • JCLAM0112S job-number job-name UNABLE TO CATALOG [ENTRYNAME]
    MFJAMS is unable to catalog the specified entry name.
  • JCLAM0113I job-number job-name ENTRYNAME DEFINED [ENTRYNAME]
    The specified entry name has been defined and cataloged. The appropriate workstation files have been created.
  • JCLAM0114I job-number job-name ENTRYNAME DELETED [ENTRYNAME]
    The specified entry name has been deleted and removed from the catalog. The appropriate workstation files have been deleted.
  • JCLAM0115E 00000000000000job-numberjob-name ENTRYNAME NOT CATALOGED [ENTRYNAME]
    The specified entry name does not exist.
  • JCLAM0116S UNEXPECTED RETURN CODE FROM MVSCATIO [return-code]
    An internal error has been detected by MVSCATIO.
  • JCLAM0117S job-number job-name TOO MANY ENTRYNAMES SPECIFIED
    The DELETE command is limited to 99 entry names.
  • JCLAM0118S job-number job-name PARAMETER NOT SUPPORTED [PARAMETER]
    The parameter is not supported by MFJAMS or is invalid for the type of dataset being defined.
  • JCLAM0119S job-number job-name MODELNAME NOT CATALOGED [ENTRYNAME]
    The specified entry name used as a model name does not exist.
Parent topic: JCLAM Error Messages


CASST0003W

An attempt was made to shutdown a region externally which is marked as having external shutdown disabled
System Action:
The region will continue running
Resolution:
To shut the region down log on the region and enter the transid required to shutdown the region
Destination:
console
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


CASCD0172S

The ES Console Process failed because it does not have the required threading support.
System Action:
The Enterprise Server is not started
Resolution:
Report the failure to Micro Focus Support
Destination:
system console
Module:
cascd
Parent topic: CASCD0160 - CASCD0175


CASCS5102E

An error message generated from a Communications Server.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
casgate
Parent topic: CASCS5010 - CASCS5103


CASCD0050 - CASCD0099

  • CASCD0050I
    The region initiation has been started. Client connection will not be immediately available. Check the console log to determine if the region completed initiation successfully.
  • CASCD0051F
    The request to start a region was not successful
  • CASCD0052S
    An attempt has been made to start a region before there is an active CAS Daemon
  • CASCD0053S
    The REM has sent no progress messages, its state is not known
  • CASCD0054S
    A UNIX call returned with errno set to errno.
  • CASCD0060I
    The server has been started.
  • CASCD0061F
    The request to start a server was not successful
  • CASCD0062S
    An attempt has been made to start a server before there is an active CAS Daemon
  • CASCD0063S
    The server has sent no progress messages, its state is not known
  • CASCD0064S
    A UNIX call returned with errno set to errno.
  • CASCD0099I
    The CAS Daemon tag for current version
Parent topic: CASCD Error Messages


CASCD4006I

Messages to CAS Deamon will not be logged to the windows event log.
System Action:
None
Resolution:
None
Destination:
Console and standard error
Module:
dfhmd
Parent topic: CASCD4002 - CASCD4007


CASCD1010S

An error occurred whilst processing the global configuration file.
System Action:
The region manager will not initialize successfully
Resolution:
Correct the fault with the configuration file
Destination:
console
Module:
dfhrem
Parent topic: CASCD1001 - CASCD1043


CASCD0164S

The FS service for region region-name has abended due to the unexpected signal signal-value.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0160 - CASCD0175


CASKC0034I

A security profile Security profile found for Queue Manager Queue Manager Namehas not been found and security for MQSeries has been turned on for type Type security.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
dfheserv
Parent topic: CASKC0031 - CASKC0045


CASCS2001E

A systems data stream was received by the CAS mirror transaction trans-ID that is logically too short to decode.
System Action:
The transaction is abended and the conversation is terminated
Resolution:
If the problem persists, determine the reason that the partner system is generating the short request data streams and correct the problem
Destination:
TDQ CSMT
Module:
dfhzcsmi
Parent topic: CASCS1500 - CASCS2004


CASCF0039S

The region file directory ($REGIONBASE/$CASREGN/files/reg) is invalid.
System Action:
Terminate the requesting process
Resolution:
Check that region name is correct and the directory exists
Destination:
Standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASST5023S

The specified PLTSD program list table could not be found in the Resource Definition file.
System action:
PLT Processing is bypassed, shutdown continues.
Resolution:
None
Destination:
Console (and Terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASSP0002I

The console daemon detected a process's termination and successfully informed the region manger of the event. pinfo describes the process information details
System action:
The region manager will take appropriate action to recover after the process's termination
Resolution:
None
Destination:
Console
Module:
caspdied
Parent topic: CASSP0001 - CASSP0014


CASST0019S

The Safmgr failed to initialize and, therefore, Enterprise Server will be shutdown.
System action:
The reporting Enterprise Server is terminated.
Resolution:
Correct the Safmgr initialization problem and restart ES.
Destination:
Console and stdout
Module:
any ES process (cascpsfi)
Parent topic: CASST0000 - CASST0020


CASKC0000 - CASKC0015

  • CASKC0000E
    Transaction trans-id is not defined in the region Program Control Table (PCT).
  • CASKC0001E
    Transaction trans-id abnormally terminated with abend code abend-code. A abend-description will be supplied for standard CICS API exception ABENDs.
  • CASKC0002E
    The system supplied module "dfhzplt.gnt" was not accessible.
  • CASKC0003I
    The server process process-id has shutdown normally.
  • CASKC0004W
    The region manager requested that a CICS server process be started and received an error response.
  • CASKC0005W
    The region manager attempted to close a CICS server process and received an error. This may be due to a lack of shared memory.
  • CASKC0006E
    A CICS API server abended during a transaction. The transaction cannot be continued. The abend could not be handled directly by transaction system.
  • CASKC0007W
    The system shared memory resource limit has been reached. The shared storage cushion will be released and made available to the system. Any GETMAIN SHARED or LOAD HOLD requests will be rejected until the critical memory condition is alleviated. Any tasks which require more storage than is available will will be suspended until the storage requirements can be met.
  • CASKC0008I
    The system has now enough free shared storage to re-acquire the shared storage cushion. GETMAIN SHARED and LOAD HOLD requests will now be accepted.
  • CASKC0009E
    The PCT entry transid is currently marked as disabled.
  • CASKC0010I
    The animation server has shutdown normally. The shutdown was implicitly requested by closing the associated terminal.
  • CASKC0011I
    The destination specified triggering of the transaction on a terminal other than the current terminal in single tasking mode.
  • CASKC0012W
    The system attempted to read an MQ queue record from the queue queue-name. The MQ open opperation failed with reason code reason-code.
  • CASKC0013E
    The system attempted to read an MQ queue record from the queue queue-name. The MQ open opperation failed with reason code reason-code.
  • CASKC0014E
    The system attempted to read an MQ queue record from the queue queue-name. The read opperation failed to return a record.
  • CASKC0015E
    The system attempted to read an MQ queue record from the queue queue-name. The read opperation failed with reason code reason-code.
Parent topic: CASKC Error Messages


CASCF0025S

An error occurred when opening the global configuration file ($CASDIR/dfhtx.cfg)
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASKC0042I

Transaction trans-id abnormally terminated with abend code abend-code. A abend-description will be supplied for standard CICS API exception ABENDs.
System action:
The transaction is terminated and protected resources are returned to the state they were in at the start of the failing transaction.
Resolution:
Correct the cause of the abnormal termination and re-submit the request.
Destination:
User terminal ,TDQ CSMT and console.log.
Module:
dfheserv
Parent topic: CASKC0031 - CASKC0045


CASRD0028W

The resource type resource-type (resource resource-name, group group-name) is not supported.
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASRD1007E

An unsuccessful request was made to delete the named service. return-code values
System action:
No updates made.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1000 - CASRD1015


CASCD0029I

This exit provides external control for starting CAS server instances. It will be given control each time the console daemon wants to start a new server instance.
System Action:
None
Resolution:
None
Destination:
Console
Module:
dfhmd
Parent topic: CASCD0016 - CASCD0031


CASCS1118W

The CAS CCI gateway connection to remote-region is lost due to an abnormal termination on sysid sys-id. The CCI network protocol in use was CCI-transport.
System Action:
The connection sys-id is no longer available for work
Resolution:
None
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASKC6004I

A transaction completed but exceeded its time threshold.
System action:
Warning message logged.
Resolution:
Investigate why threshold was exceeded
Destination:
System Console
Module:
dfheserv
Parent topic: CASKC5006 - CASKC6006


JCLUT0006E

Message

SYSUT1 = SYSUT2 nothing to do

Message Information

SYSUT1 and SYSUT2 reference the same file

Parent topic: JCLUT Error Messages


CASCS1105S

The CAS CCI gateway failed to initialize successfully . The reason-code is generally from the CCI protocol module. reason-code of 998 says the CCI protocol module could not be loaded. reason-code of 999 says the CCI protocol module signature was bad.
System Action:
Process terminates
Resolution:
Check that the CCITCP2 process is running on the machine specified in the SIT. Check that the specified CCI protocol stack is available. Check that the RTS is built properly. For TN3270, check that the specified or default port is available and that the CAS process has the permissions required to access it
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


SORT200 - SORT399

  • SORT205I: job-number job-name INPUT file 'ddname'
    Informational message showing the name of the input file for the SORT operation just performed.
  • SORT206I: job-number job-name OUTPUT file 'ddname'
    Informational message showing the name of the output file for the SORT operation just performed.
  • SORT207I: job-number job-name OUTFIL file 'ddname '
    Informational message showing the name of the output file for the SORT operation just performed.
  • SORT301E: job-number job-name Position/Length bit specification ' byte.bit' must be >= 0 and <= 7.
    The bit portion of the byte.bit position or length specification must be between 0 and 7.
  • SORT399I: job-number job-name End of Micro Focus MFJSORT Utility.
    Informational message indicating the end of the SORT process.
Parent topic: SORT - MFJSORT Error Messages


ILSMARTRESTRICT

Syntax:

Restriction: This directive is supported for managed COBOL only.
>>-.---.---.----.-ILSMARTRESTRICT-------><
   +-/-+   +-NO-+

Properties:

Default: | ILSMARTRESTRICT
Phase: | Syntax check
$SET: | Initial

Example:

The following COBOL program is compiled with ILSMARTLINKAGE, ILSMARTRESTRICT, ILCUTPREFIX(lnk-b-) and ILCUTPREFIX(lnk-):

       program-id. BookLegacy.
                         ...
       linkage section.
       01 lnk-function            pic x.
       01 lnk-b-details.
          03 lnk-b-text-details.
             05 lnk-b-title       pic x(50).
             05 lnk-b-type        pic x(20).
             05 lnk-b-author      pic x(50).
       01 lnk-b-reprint-details redefines lnk-b-details.
          03 lnk-b-invisible      pic x(20).

       procedure division using by value lnk-function
                                by reference lnk-b-details.

In C#, you can access the data in BookLegacy program in .NET managed COBOL as follows:

    BookLegacy myBook = new BookLegacy();
         //creates an object corresponding to the BookLegacy program
    Details myDetails = new Details();
         //creates an instance corresponding to the group lnk-b-details
    . . .
       myDetails.Title = "Great Expectations";

       myBook.BookLegacy("2", myDetails);
         // calls the BookLegacy method with myDetails,
         // which corresponds to the group item lnk-b-details

Without ILSMARTRESTRICT set, you can also access other properties, such as group items and redefining elementary items:

...
myDetails.setDetails = "Great Expectations     Novel       Dickens";
myDetails.setInvisible = "can't see this";

See the C# WinBook demonstration in the Studio Enterprise Edition samples for more.

Related reference
ILSMARTNEST
ILSMARTLINKAGE


CASST4000 - CASST4111

  • CASST4000I
    A request to shutdown the Micro Focus Transaction System has been entered using either the CQIT transaction or the PERFORM SHUTDOWN command.
  • CASST4001I
    A request to shutdown the Micro Focus Transaction System IMMEDIATELY has been entered using the PERFORM SHUTDOWN command.
  • CASST4002E
    The shutdown request was rejected because the system was already in shutdown or was never successfully started.
  • CASST4010I
    Shutdown processing has begun using the indicated PLT.
  • CASST4011I
    Shutdown processing has begun; no PLTSD was specified for PLT processing.
  • CASST4020I
    The PLTSD Phase 1 processing has been completed.
  • CASST4021E
    The PLTSD processing encountered an error in processing program list or one of the programs in the list ABENDed.
  • CASST4022S
    The PLT processing transaction program, dfhzplt, could not be found.
  • CASST4090I
    The attached terminal is automatically disconnected when a shutdown request is processed.
  • CASST4100I
    A request to shutdown the Micro Focus Transaction System has been entered using either the CQIT transaction or the PERFORM SHUTDOWN command.
  • CASST4101I
    A request to shutdown the Micro Focus Transaction System IMMEDIATELY has been entered using the PERFORM SHUTDOWN command.
  • CASST4102E
    The shutdown request was rejected because the system was already in shutdown or was never successfully started.
  • CASST4110I
    Shutdown processing has begun using the indicated PLT.
  • CASST4111I
    Shutdown processing has begun; no PLTSD was specified for PLT processing.
Parent topic: CASST Error Messages


JCLCM0500 - JCLCM0599

  • JCLCM0500E SPACE parameter "value" is invalid or misplaced
  • JCLCM0501E UNIT parameter "value" is invalid or misplaced
  • JCLCM0502E VOLUME parameter "value" is invalid or misplaced
  • JCLCM0503E Invalid USER parameter
  • JCLCM0504E TYPEXEC parameter "value" is invalid
  • JCLCM0505E DSNTYPE parameter "value" is invalid
  • JCLCM0506E account parameter or its length in error
  • JCLCM0507E programmer parameter or its length in error
  • JCLCM0508E Invalid ACCODE parameter
  • JCLCM0509E Invalid CCSID parameter
  • JCLCM0510E Invalid BYTES parameter
  • JCLCM0511E Invalid CARDS parameter
  • JCLCM0512E Invalid GROUP parameter
  • JCLCM0513E Invalid LINES parameter
  • JCLCM0514E Invalid NOTIFY parameter
  • JCLCM0515E Invalid PAGES parameter
  • JCLCM0516E Invalid PASSWORD parameter
  • JCLCM0517E PARM parameter or its length in error
  • JCLCM0518E Invalid RESTART parameter
  • JCLCM0519E Invalid SECLABEL parameter
  • JCLCM0520E Invalid UPLOAD parameter
  • JCLCM0521E Invalid DOWNLOAD parameter
  • JCLCM0522E Invalid MEMBER parameter
  • JCLCM0523E Invalid PCDSN parameter
  • JCLCM0524E COPIES parameter "value" has invalid value or syntax
  • JCLCM0525E Excess COPIES specification "value" rejected
  • JCLCM0526E FCB parameter "value" has invalid value
  • JCLCM0527E FLASH parameter "value" has invalid value
  • JCLCM0528E HOLD parameter "value" has invalid value
  • JCLCM0529E PRTSP parameter "value" has invalid value
  • JCLCM0530E SPIN parameter "value" has invalid value
  • JCLCM0531E TRTCH parameter "value" is invalid
  • JCLCM0532E "value" parameter is invalid
  • JCLCM0533E "value" parameter has invalid value
  • JCLCM0599I Excess VOLUME specification "value" ignored
Parent topic: JCLCM Error Messages


CASFD0010I

The offline dump/trace format request is complete.
System action:
None
Resolution:
None
Destination:
Standard error.
Module:
dfhgdup
Parent topic: CASFD0001 - CASFD0014


CASRD0042E

The resource-type name resource-name is locked with an ENQ. Some other operation is currently being executed that involves it.
System action:
The resource will not be installed
Resolution:
Verify that the proper resource is being installed and retry
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASFD0013I

The offline dump requester issued an IMS dump request for region region-name. The dump went to the normal region dump dataset.
System action:
The dump request is issued
Resolution:
None
Destination:
Standard error.
Module:
dfhgdup
Parent topic: CASFD0001 - CASFD0014


CASCS1134S

The configuration file could not be found.
System Action:
The CCI gateway will not initialize successfully
Resolution:
Make sure that CASDIR is set correctly and that the configuration file exists
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASCF0021S

An error occurred when creating the development configuration save file (dcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASCF0049F

The activation key for the product is invalid or has expired.
System Action:
Terminate the requesting process
Resolution:
Contact your Micro Focus representative
Destination:
standard error
Module:
config-module(dfhcpcfi)
Parent topic: CASCF0046 - CASCF0063


CASST5230I

The Event Process is terminating.
System Action:
None
Resolution:
None
Destination:
console
Module:
casevmgr
Parent topic: CASST5000 - CASST6002


CASKC0019E

The system attempted to load the Interface Definition Table (IDT) for Service service-name. The file system read for the disk image details failed with a reason code of reason-code.
System action:
The service request is failed
Resolution:
Correct the location or deployment error and retry the request.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


CASCD0001 - CASCD0015

  • CASCD0001F
    The request to start a CAS daemon was not successful
  • CASCD0002S
    CAS failed to create a new process in which to run the CAS daemon A UNIX 'fork' call returned with errno set to errno
  • CASCD0003S
    CAS was unable to run the COBOL RTS in the CAS daemon process A UNIX 'exec' call returned with errno set to errno
  • CASCD0004S
    CAS failed to create named pipe 'pipe-name' which was to be used for communication with the CAS daemon. A UNIX 'mknod' call returned with errno set to errno
  • CASCD0005S
    CAS failed to open named pipe 'pipe-name' which was to be used to receive messages from the CAS daemon A UNIX 'fopen' call returned with errno set to errno
  • CASCD0006S
    An error occurred attempting to read from the named pipe pipe-namewhich was being used to receive messages from the CAS daemon A UNIX 'fgets' call returned with errno set to errno
  • CASCD0007S
    The CAS daemon process has terminated without first sending a severe or fatal error message process status is the status as returned by the UNIX 'wait' call
  • CASCD0008F
    CAS failed to create a UNIX message queue A UNIX message queue call returned with errno set to functionThe call that failed is specified by function, where: 1 = msgget 2 = msgctl 3 = msgrcv 4 = msgsnd
  • CASCD0009F
    CAS detected an error whilst reading from a UNIX message queue A UNIX message queue call returned with errno set to functionThe call that failed is specified by function, where: 1 = msgget 2 = msgctl 3 = msgrcv 4 = msgsnd
  • CASCD0010F
    CAS failed to delete a UNIX message queue during shutdown A UNIX message queue call returned with errno set to functionThe call that failed is specified by function, where: 1 = msgget 2 = msgctl 3 = msgrcv 4 = msgsnd
  • CASCD0011F
    CAS failed to open the system console log file The COBOL file status after failure is RC1,RC2
  • CASCD0012F
    CAS failed to write to the system console log file because the system disk is full.
  • CASCD0013F
    Only one CAS Daemon is required, attempts to start more are rejected
  • CASCD0014F
    A UNIX setuid call has failed, returning errno set to errno. This is probably caused by an attempt to start an CAS Daemon without super-user authority
  • CASCD0015W
    After the CAS Daemon has been created an attempt is made to communicate with it. This attempt was unsuccessful. It is possible that the console daemon may start successfully and this error occurred due to a slow machine.
Parent topic: CASCD Error Messages


CASCD1062I

A JES Printer Process has been started for Server server-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


CASST4100I

A request to shutdown the Micro Focus Transaction System has been entered using either the CQIT transaction or the PERFORM SHUTDOWN command.
System action:
Shutdown processing is started.
Resolution:
None
Destination:
Console
Module:
casrdo11
Parent topic: CASST4000 - CASST4111


CASXO0006S

The Resource manager for the XAT resource reported that due to a failure the work done on behalf of the transaction may have been heuristically completed.
System Action:
The state of the transaction is undefined
Resolution:
Contact your administrator for the resource
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


CASKC0012W

The system attempted to read an MQ queue record from the queue queue-name. The MQ open opperation failed with reason code reason-code.
System action:
Transaction aborted. The MQ Message is retained on the input queue queue-name.
Resolution:
Resolve the configuration mismatch and restart the associated ASEE iniation queue listener.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0000 - CASKC0015


CASKC0028E

A message has been generated processing a service.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


JCLUT0108S

Message

MFDG internal error (%1$s)

Where %1$s is subcode

Message Information

An error occurred in the MFDG program. The error code indicates the position. These errors are related to temporary file access or memory assignment.

Subcodes:

  • 002 - Open output DATAFL
  • 003 - Write DATAFL
  • 004 - Create temp file
  • 005 - Temp file count > max allowed
  • 006 - Allocate FD-REC
  • 007 - Allocate CREATE-REC
  • 008 - Allocate REPEAT-REC
  • 009 - Open input DATAFL
  • 010 - Allocate CREATE-NAME
  • 011 - Allocate DSD

Resolution

Check that disk space and swap space is available for temporary files and memory allocation. If the problem persists contact Micro Focus SupportLine.

Parent topic: JCLUT Error Messages


CASCF0014S

The region configuration file ($REGIONBASE/$CASREGN/dfhtx.cfg) could not be located.
System Action:
Terminate the requesting process
Resolution:
Make sure that $CASDIR is set correctly and that the configuration file exists
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0001 - CASCF0015


CASCS1133S

An unrecognized line was found in the configuration file at the line shown.
System Action:
The CCI gateway will not initialize successfully
Resolution:
Correct the fault with the configuration file ensuring that the line contains a valid configuration item
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASCS1131S

An error occurred whilst processing the region configuration file.
System action:
The CCI gateway will not initialize successfully.
Resolution:
Correct the fault with the configuration file.
Destination:
Console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASRD0014W

An attempt was made to install the resource-type entry resource-name from group group-name after deleting the previous definition. The install failed with reason reason-code. Reason codes are return codes from the table manager. Common reasons are:
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


CASCF0038S

The directory specified by the CASDIR environment variable is invalid.
System Action:
Terminate the requesting process
Resolution:
Check that the directory that is specified in CASDIR is valid and retry
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASCF0044F

The utility support module could not be loaded as part of system initialization. This module is required for normal system operation.
System Action:
Terminate the requesting process
Resolution:
Check that $CASDIR is set correctly and the module(s) dfh0utl exists in $CASDIR/lib
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASCS1117I

The CAS CCI gateway connection to remote-region is lost. Active work on sysid sys-id will terminate abnormally. The CCI network protocol in use is CCI-transport.
System Action:
The connection sys-id is no longer available for work
Resolution:
Restart peer region
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASCD0170S

A process for region region-name has abended due to the unexpected signal signal-value.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0160 - CASCD0175


CASCS1101W

An error occurred in the CCI communications of the CAS CCI gateway. CCI-error-text is returned from CCI. This message will be generated prior to message CASCS1100W for CCI error return code 9.
System Action:
None
Resolution:
None
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASCD0027W

The immediate shutdown option of the console daemon shutdown utility abends all running regions. Data may be lost or the system may be left in an unstable state. This option should only be used as a last resort. It is recommended that each region is shutdown cleanly before using the dfhtxp command.
System Action:
Console daemon shutdown will continue
Destination:
Console and stdout
Module:
dfhtxp
Parent topic: CASCD0016 - CASCD0031


CASCF0006F

The file handling support module could not be loaded as part of system initialization. This module is required for normal system operation.
System Action:
Terminate the requesting process
Resolution:
Check that $CASDIR is set correctly and the module dfhextfh exists in $CASDIR/lib.
Destination:
standard error
Module:
config-module(dfhcpcfi)
Parent topic: CASCF0001 - CASCF0015


CASCF0050S

An error occurred accessing the console daemon configuration data. Typically this occurs when the console daemon is not currently active.
System Action:
Terminate the requesting process
Resolution:
Make sure the console daemon is active and retry
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASST0004W

An attempt was made to shutdown a region externally which is marked as requiring a valid userid and password to complete the shutdown request due to the reason given.
  • 1 - error opening region resource definition file
  • 2 - user did not have valid security key
  • 3 - userid and/or password invalid
System Action:
The region will continue running
Resolution:
Specify a valid userid+password on the command line. If the userid+password is valid make sure that the security keys of the user matches the external security key specified in the SIT.
Destination:
console
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


CASCD0012F

CAS failed to write to the system console log file because the system disk is full.
System Action:
All output on standard error and system log on UNIX
Resolution:
Free up space on the system disk
Destination:
standard error
Module:
dfhmd
Parent topic: CASCD0001 - CASCD0015


CASCS1132S

An error occurred while processing the configuration file.
System action:
The CCI gateway will not initialize successfully.
Resolution:
Correct the fault with the configuration file.
Destination:
Console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASXO0007S

The Resource manager for the XAT resource reported that due to a heuristic decision the work done on behalf of the transaction has been committed.
System Action:
The state of the transaction is undefined
Resolution:
Contact your administrator for the resource
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


CASCF0052S

An error occurred reading the console daemon's stored configuration data. This may occur if the console daemon failed in initialization or the registry data has become corrupted.
System Action:
Terminate the requesting process
Resolution:
Make sure that the console daemon is active and retry
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASRD1005E

An unsuccessful request was made to add the named service. return-code values
System action:
No updates made.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1000 - CASRD1015


CASRD0001 - CASRD0015

  • CASRD0001E
    The resource-type entry resource-name is locked with an ENQ. Some other operation is currently being executed that involves it.
  • CASRD0002E
    The resource-type name resource-name is locked with an ENQ. Some other operation is currently being executed that involves it.
  • CASRD0003S
    ARRAY(0x2a9d620)
  • CASRD0004I
    Group group-name install is initiated from terminal or facility facility-id.
  • CASRD0005E
    Validation errors were found when preparing to install group group-name. The error messages are written to TS queue TS-queue-name. These messages may be reviewed with the utility transaction CEBR.
  • CASRD0006E
    Validation of group was successful but portions of the install failed for group group-name. The error messages are written to TS queue TS-queue-name. These messages may be reviewed with the utility transaction CEBR.
  • CASRD0007I
    The group group-name has been successfully installed. Details of the install are written to TD queue CRDI.
  • CASRD0008I
    The resource definition for resource-type entry resource-name from group group-name has replaced the previous definition in the current system.
  • CASRD0009I
    The resource definition for resource-type entry resource-name from group group-name is installed in the current system.
  • CASRD0010E
    The resource definition for resource-type entry resource-name from group group-name failed to install. The reason is reason-code. Reason codes are return codes.
  • CASRD0011S
    ARRAY(0x2886360)
  • CASRD0012W
    The resource type resource-type (resource resource-name, group group-name) is not supported.
  • CASRD0013W
    An attempt was made to delete the resource-type entry resource-namein preparation for re-installing it from group group-name. The delete failed with reason reason-code. Reason codes are return codes from the table manager. Common reasons are:
  • CASRD0014W
    An attempt was made to install the resource-type entry resource-name from group group-name after deleting the previous definition. The install failed with reason reason-code. Reason codes are return codes from the table manager. Common reasons are:
  • CASRD0015W
    The resource type resource-type (resource resource-name, group group-name) is not recognized.
Parent topic: CASRD Error Messages


CASCS1114E

An error occurred loading the protocol support module module-name.
System Action:
The CCI gateway will not initialize successfully
Resolution:
Correct the CCI installation or activate the underlying OS support such that the CCI module can be loaded
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASCF0011S

An unrecognized line was found in the region configuration file ($REGIONBASE/$CASREGN/dfhtx.cfg) at the line shown.
System Action:
Terminate the requesting process
Resolution:
Terminate the requesting process
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0001 - CASCF0015


CASCF0022S

An error occurred when opening the global configuration save file (gcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASRD1015E

An unsuccessful request was made to add the named request handler. return-code values
System action:
No updates made.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1000 - CASRD1015


CASRD0033E

An attempt was made to install the resource-type entry resource-name from group group-name. The install failed with error reason-code. Error codes are return codes from local storage allocation.
System action:
Continue, the CVT definition is not installed
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASCF0054S

An error occurred writing the console daemons stored configuration data. This may occur if the registry data has become corrupted.
System Action:
Terminate the requesting process
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASCF0057S

An error occurred reading the project's configuration data. This may occur if this process was not invoked by the IDE or no project is open. Check that the appropriate configuration value is set within the current project or workgroup settings.
System Action:
Terminate the requesting process
Resolution:
Make sure the IDE is active and a valid project file is open
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASCD0160 - CASCD0175

  • CASCD0160F
    The DosStartSession failed with the return code error-id. This code may be an error listed with DosStartSession, DosOpen, DosLoadModule, or DosExecPgm. The module being started is dfhmd.exe in directory $CASDIR\lib.
  • CASCD0161I
    The CAS Daemon has initialized and is waiting for work
  • CASCD0162S
    The journal control service for region region-name has abended due to the unexpected signal signal-value.
  • CASCD0163S
    The extra partition transient data service for region region-name has abended due to the unexpected signal signal-value.
  • CASCD0164S
    The FS service for region region-name has abended due to the unexpected signal signal-value.
  • CASCD0165W
    CAS attempted to create a new process from the CAS Daemon process but the call failed with RC=return-code from a DosExecPgm request.
  • CASCD0166W
    CAS attempted to create a new process from the CAS Daemon process but the call failed with RC=return-code from a CreateProcess request.
  • CASCD0167I
    The CAS daemon was not active when the start region request was issued. The CAS daemon was automatically started.
  • CASCD0168S
    The Spool service for region region-name has abended due to the unexpected signal signal-value.
  • CASCD0169S
    The CAS gateway for region region-name has abended due to the unexpected signal signal-value.
  • CASCD0170S
    A process for region region-name has abended due to the unexpected signal signal-value.
  • CASCD0171S
    The MQSeries gateway for region region-name has abended due to an unexpected signal signal-value.
  • CASCD0172S
    The ES Console Process failed because it does not have the required threading support.
  • CASCD0173S
    The ES Console tried to start a receive-all thread. The create-thread operation failed with a return code of return-code
  • CASCD0174I
    The ES Console thread that handles process terminations has exited normally.
  • CASCD0175I
    Processing of ddbg port range detected an error Verify region configuration.
Parent topic: CASCD Error Messages


CASCD0015W

After the CAS Daemon has been created an attempt is made to communicate with it. This attempt was unsuccessful. It is possible that the console daemon may start successfully and this error occurred due to a slow machine.
System Action:
If the console daemon starts the system can continue as normal. If the console daemon does not start then no regions can be started.
Resolution:
Wait to see if the console daemon initializes, if it does not then check if any error messages were displayed or written to the console.log file.
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0001 - CASCD0015


JCLCM0127S Host dataset %1$s unexpectedly created by alien job.

Parent topic: JCLCM0000 - JCLCM0199


CASXO0022W

The XA resource manager's switch module did not contain support for local transaction commit/rollback functions.
System Action:
Transactional support for JCL via IKJEFT01 will not be supported
Resolution:
None
Destination:
console
Module:
dfhexa
Parent topic: CASXO0016 - CASXO0026


CASST0014E

While attempting to shutdown a region an error occurred trying to submit the shutdown request
System action:
As the shut down program cannot attach to the region the region cannot be shutdown.
Resolution:
A forced region shutdown may be required.
Destination:
Console
Module:
casstop
Parent topic: CASST0000 - CASST0020


CASKC0030S

One of the essential system modules failed to load.
System action:
The internal service request will not be processed.
Resolution:
Ensure product is installed correctly. A forced shutdown could be required to terminate the server.
Destination:
System Console
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


CASKC0044S

ES failed to authorize the CICS Default user during initialization.
System action:
ES shutdown is initialized
Resolution:
Correct authorization problem for default CICS user
Destination:
System Console
Module:
dfheserv
Parent topic: CASKC0031 - CASKC0045


CASKC0016 - CASKC0030

  • CASKC0016E
    The system attempted to read an MQ queue record from the queue queue-name. The close opperation for the queue failed with reason code reason-code. This error should not occur.
  • CASKC0017E
    The system attempted to register the request-handler-name request handler. The MF RTS return code is reason-code. Services requiring this handler will not be available until the problem is corrected. The MF RTS may not be able to locate the executable or.
  • CASKC0018E
    The system attempted load the Interface Definition Table (IDT) for Service service-name. The file system open for the disk image failed with a reason code of reason-code. The reason-code will be displayed in decimal. The hexidecimal representation of the error might indicate a COBOL RTS error, for example 0x390D is a 9/13 which means file not found.
  • CASKC0019E
    The system attempted to load the Interface Definition Table (IDT) for Service service-name. The file system read for the disk image details failed with a reason code of reason-code.
  • CASKC0020E
    The system attempted to load the Interface Definition Table (IDT) for Service service-name. The allocate request for storage to hold the disk image failed with a reason code of reason-code.
  • CASKC0021E
    The system attempted to load the Interface Definition Table (IDT) for Service service-name. The file system read for the disk image failed with a reason code of reason-code.
  • CASKC0022E
    The system could not connect to the queue-manager-name queue manager. The reason code is reason-code.
  • CASKC0023E
    The system could not locate a definition for the request-handler-name request handler.
  • CASKC0024E
    The request handler did not generate a response to an input request.
  • CASKC0025I
    A message has been generated processing a service.
  • CASKC0026E
    A message has been generated processing a service.
  • CASKC0027E
    A message has been generated processing a service.
  • CASKC0028E
    A message has been generated processing a service.
  • CASKC0029E
    A message has been generated processing a service.
  • CASKC0030S
    One of the essential system modules failed to load.
Parent topic: CASKC Error Messages


CASCD0025S

A UNIX call returned with errno set to errnoThe call that failed is specified by errno, where: 1 = msgget 2 = msgsnd 3 = fgets 4 = fopen 5 = mknod
System Action:
The CAS Daemon is not shut down
Resolution:
Determine the cause of the error and retry if appropriate
Destination:
standard error
Module:
dfhtxp
Parent topic: CASCD0016 - CASCD0031


CASCF0036S

An error occurred when writing the development configuration save file (dcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASRD0045E

The hexadecimal value entered for the transaction had a single quote missing or mismatched.
System action:
The request is not executed
Resolution:
Correct the request and resubmit
Destination:
terminal, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASKC0026E

A message has been generated processing a service.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
dfheserv, casbat, casmpr
Parent topic: CASKC0016 - CASKC0030


CASRD1037E

An unsuccessful request was made to delete the named package. return-code values
System action:
No updates made.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


CASCS1007E

The terminal definition for terminal-id was requested from the remote system while trying to process transaction trans-id. The primary communications return code is comms-primary-RC.
System Action:
The transaction is abnormally terminated
Resolution:
Correct the cause of the communications error
Destination:
TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASCS1106S

The CAS CCI gateway failed to initialize successfully . The reason-code is from dfhgreqc.
System Action:
Process terminates
Resolution:
Check that the associated region is active
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASCS1115E

The signature check for CCI protocol support module module-namefailed. The signature found is CCI-signature-string.
System Action:
The CCI gateway will not initialize successfully
Resolution:
Correct the CCI installation
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASCD0171S

The MQSeries gateway for region region-name has abended due to an unexpected signal signal-value.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0160 - CASCD0175


CASKC0024E

The request handler did not generate a response to an input request.
System action:
Active work unit will be terminated.
Resolution:
Check that the request handler is working properly.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


CASST5001I

Shutdown PLT processing was entered, but no list was specified.
System Action:
Shutdown proceeds normally
Resolution:
None
Destination:
console (and terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


JCLCM0124S Invalid user id caused SAF failure on the host.

Parent topic: JCLCM0000 - JCLCM0199


JCLUT0107S

Message

Incompatible DCB properties

Message Information

The concatenated data in SYSUT1 have different LRECL values.

Resolution

The data with the largest LRECL value must appear first on the list of concatenated data in SYSUT1.

Parent topic: JCLUT Error Messages


C$Century

Updates your COBOL programs to handle the year 2000 issue.
Note: When calling this routine, ensure you are using the 1024 calling convention.

This library routine retrieves the first two digits of the current year.

Syntax:

CALL "C$Century" USING value-buffer

Parameters:

value-buffer
A two-byte data item with a format of either unsigned numeric display (NSU) or alphanumeric display (ANS).

On Exit:

value-buffer
The first two digits of the current year.

Comments:

You can achieve the same result using the standard COBOL command ACCEPT data-name FROM DATE YYYYMMDD and then referencing the data name.

Related information
Call Conventions for Interfacing with Mixed Languages


CASCF0046 - CASCF0063

  • CASCF0046F
    The file handling support module could not be loaded as part of system initialization. This module is required for normal system operation.
  • CASCF0047F
    An unexpected error occurred in system initialization while processing the configuration file.
  • CASCF0048F
    The value for the environment variable is larger than the internal work areas. This may result in an invalid value so the initialization will be aborted.
  • CASCF0049F
    The activation key for the product is invalid or has expired.
  • CASCF0050S
    An error occurred accessing the console daemon configuration data. Typically this occurs when the console daemon is not currently active.
  • CASCF0051S
    An error occurred accessing the region configuration data. Typically this occurs when the region is not currently active.
  • CASCF0052S
    An error occurred reading the console daemon's stored configuration data. This may occur if the console daemon failed in initialization or the registry data has become corrupted.
  • CASCF0053S
    An error occurred reading the region's stored configuration data. This may occur if the region failed in initialization or the registry data has become corrupted.
  • CASCF0054S
    An error occurred writing the console daemons stored configuration data. This may occur if the registry data has become corrupted.
  • CASCF0055S
    An error occurred writing the region's stored configuration data. This may occur if the registry data has become corrupted.
  • CASCF0056S
    An error occurred reading the project's configuration data. This may occur if this process was not invoked by the IDE or no project is open. Check that the appropriate configuration value is set within the current project or workgroup settings.
  • CASCF0057S
    An error occurred reading the project's configuration data. This may occur if this process was not invoked by the IDE or no project is open. Check that the appropriate configuration value is set within the current project or workgroup settings.
  • CASCF0058S
    An error occurred reading the project's configuration data. This may occur if this process was not invoked by the IDE or no project is open. Check that the appropriate configuration value is set within the current project or workgroup settings.
  • CASCF0059F
    The CAS configuration module could not be located during system initialization. This module is required for normal system operation.
  • CASCF0061F
    The system groups have not been defined in $COBDIR/etc/cas/dfhtx.cfg
  • CASCF0062F
    The module has not been recognized by the authorisation process
  • CASCF0063F
    The group associated with the module has not been recognized
Parent topic: CASCF Error Messages


CASCS1010E

A terminal definition was requested from system system-id. The response received was not a valid builder list.
System Action:
The transaction is abnormally terminated
Resolution:
Verify the definition for the connection to the system-id system
Destination:
TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


Delegates and Events - in COBOL and C#

Delegates and Events in Managed COBOL

delegate-id MsgArrivedEventHandler.
procedure division using by value msg as string.
end delegate.

class-id a.
01 MsgArrivedEvent type MsgArrivedEventHandler event static.
    *> Delegates must be used with events in COBOL

method-id main static.
*> Combining delegates
    set MsgArrivedEvent to MsgArrivedEvent + method self::My_MsgArrivedEventCallback
       *> Throws exception if obj is null
    invoke run MsgArrivedEvent("Test message")
    set MsgArrivedEvent to MsgArrivedEvent - method self::My_MsgArrivedEventCallback

*> Attaching to an event
    attach method self::My_MsgArrivedEventCallback to self::MsgArrivedEvent
    invoke run MsgArrivedEvent("Test message 2")
end method.

method-id My_MsgArrivedEventCallback static.
procedure division using by value str as string.
    display str
end method.
end class.

Delegates and Events in C#

delegate void MsgArrivedEventHandler(string message);

event MsgArrivedEventHandler MsgArrivedEvent;

// Delegates must be used with events in C#

MsgArrivedEvent +=
    new MsgArrivedEventHandler(My_MsgArrivedEventCallback);
// Throws exception if obj is null
MsgArrivedEvent("Test message");
MsgArrivedEvent -=
    new MsgArrivedEventHandler(My_MsgArrivedEventCallback);

using System.Windows.Forms;

Button MyButton = new Button();
MyButton.Click += new System.EventHandler(MyButton_Click);

private void MyButton_Click(object sender, System.EventArgs e)
{
  MessageBox.Show(this, "Button was clicked", "Info",
    MessageBoxButtons.OK, MessageBoxIcon.Information);
}
Related reference
Delegates and Events


CASCS1122I

The system is attempting to activate the connection (TCT) identified as sys-id to the region named remote-region.
System action:
Resolution:
Destination:
Console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASRD1035E

An unsuccessful request was made to add the named package. return-code values
System action:
No updates made.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


CASXO0018S

The Resource manager for the XAT resource returned a non-zero value to the xa_end call.

The return codes are:

  • -2 Asynchronous operation already outstanding
  • -3 A resource manager error occurred
  • -4 The XID is not valid
  • -5 Invalid arguments were given
  • -6 Routine invoked in an improper context
  • -7 Resource Manager unavailable
  • -8 the XID already exists
  • -9 Resource Manager doing work outside global transaction
  • The following indicate the transaction is marked as roll-back only
  • 100 The resource manager marked the transaction roll-back only for an unspecified reason.
  • 101 A communication failure occurred
  • 102 The resource manager detected a deadlock
  • 103 The resource manager detected a violation of the integrity of its resources
  • 104 The resource manager marked the transaction roll-back
  • only for a reason not in this list.
  • 105 A protocol error occurred in the resource manager
  • 106 The work represented by this transaction took too long
  • 107 The resource manager detected a transient error
System Action:
The Transaction is abnormally terminated
Resolution:
Check that the Resource Manager is still available
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0016 - CASXO0026


CASCD0030I

Console daemon forwarded a server instance start request to the casexitv exit program and casexitv returned with a non-zero return code of return-code.
System Action:
None - the exit is responsible for starting the requested server instance
Resolution:
Take action approprate to the exit program's return code
Destination:
Console
Module:
dfhmd
Parent topic: CASCD0016 - CASCD0031


Constructors and Deconstructors - in COBOL and C#

Constructors and Deconstructors in Managed COBOL

class-id SuperHero.
working-storage section.
01 powerLevel binary-long.
method-id new.
procedure division.
    set powerLevel to 0
end method.

method-id new.
procedure division using by value powerLevel as binary-long.
    set powerLevel to powerLevel
end method.
method-id Finalize override protected.
    *> Destructor code to free unmanaged resources.
end method.

end class SuperHero.

Constructors and Deconstructors in C#

class SuperHero
{
  private int _powerLevel;

  public SuperHero()
  {
     _powerLevel = 0;
  }

  public SuperHero(int powerLevel)
  {
    this._powerLevel= powerLevel;
  }

  ~SuperHero()
  {
    // Destructor code to free unmanaged resources.
    // Implicitly creates a Finalize method
  }
}
Related reference
Constructors


CASST0000I

The region manager has started its termination phase
System Action:
Shared memory and semaphores will be removed
Resolution:
None
Destination:
console
Module:
dfhgterm
Parent topic: CASST0000 - CASST0020


JCLUT0008E

Message

Missing or empty INPUT DD(%1$s).

Where %1$s is Dataset Name.

Message Information

The INPUT file could not be found in the catalog or is empty.

Resolution

The INPUT file must exist, be cataloged and contain at least one record.

Parent topic: JCLUT Error Messages


CASCD0122E

An attempt was made to start a region or server when the system was shutting down
System Action:
The request is rejected
Resolution:
Do not attempt to start regions or servers during shutdown
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASCD4005I

Messages to CAS Deamon will be logged to the windows event log.
System Action:
None
Resolution:
None
Destination:
Console and standard error
Module:
dfhmd
Parent topic: CASCD4002 - CASCD4007


CASSP0012S

IMS has abended during the current transaction running.
System action:
The transaction and IMS will abend.
Resolution:
Investigate why IMS abended.
Destination:
Console and standard error.
Module:
dfhesync
Parent topic: CASSP0001 - CASSP0014


CASXO0003S

The Resource manager for the XAT resource returned a non-zero value to the xa_start call.

The return codes are:

  • -2 Asynchronous operation already outstanding
  • -3 A resource manager error occurred
  • -4 The XID is not valid
  • -5 Invalid arguments were given
  • -6 Routine invoked in an improper context
  • -7 Resource Manager unavailable
  • -8 the XID already exists
  • -9 Resource Manager doing work outside global transaction
  • The following indicate the transaction is marked as roll-back only
  • 100 The resource manager marked the transaction roll-back
  • only for an unspecified reason.
  • 101 A communication failure occurred
  • 102 The resource manager detected a deadlock
  • 103 The resource manager detected a violation of the integrity
  • of its resources
  • 104 The resource manager marked the transaction roll-back
  • only for a reason not in this list.
  • 105 A protocol error occurred in the resource manager
  • 106 The work represented by this transaction took too long
  • 107 The resource manager detected a transient error
System Action:
The Transaction is abnormally terminated
Resolution:
Check that the Resource Manager is still available
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


CASCS1012E

Outbound transaction routing of transaction trans-id to system system-id failed with a communications return-code of comms-primary-RC. Refer to the communications protocol stack documentation for other return codes and for more information. Also note that some protocol stacks use different values for the above conditions.

Common values for comms-primary-RC are:

  • x'0003' Allocation error (SYSIDERR)
  • x'000f' Conversation failure - retry
  • x'0010' Conversation failure - no retry
System Action:
The transaction is abnormally terminated
Resolution:
Correct the communications error and retry the operation
Destination:
user terminal and TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


DELETE

Deletes a file.
Note: When calling this routine, ensure you are using the 1024 calling convention.

Syntax:

CALL "DELETE" USING file-name [exit-code]

Parameters:

file-name
PIC X(n)
exit-code
PIC S9(4) BINARY

On Entry:

file-name
The full or relative pathname of the file to be deleted.

On Exit:

exit-code
The exit code of the command upon return from the operating system: zero for success and non-zero for failure.

Comments:

The values for the old-name parameter may be quoted with double quotes (") or single quotes ('). When the name is quoted, the quotes are removed, but the name is not otherwise modified. If the name is not quoted, the first control character terminates the name on Windows and the first white space character terminates the name on UNIX. On Windows, trailing spaces are removed from unquoted names.

The old-name data item must be less than 1024 characters in length.

Related information
Call Conventions for Interfacing with Mixed Languages


CASCD0163S

The extra partition transient data service for region region-name has abended due to the unexpected signal signal-value.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0160 - CASCD0175


CASCD0126I

CAS attempted to fork a new process from the CAS Daemon process but the call failed with errno errno
System Action:
Abort the attempt to start a REM or server
Resolution:
Determine and fix cause of failure then retry
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASCD1031S

The ODBC service process of region region-name has exited, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


CASCF0018S

The development configuration file (dcf.bin) could not be located.
System Action:
Terminate the requesting process
Resolution:
Make sure that $CASDIR is set correctly and that the configuration file exists
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


Compiler

Calling methods
The COBOL Compiler no longer supports calling a method with "self" as a parameter, when the method parameter definition is "by reference" (explicit or implicit). Instead, the method parameter definition should be "by value". This brings the COBOL compiler in line with C#.

Note that you might need to update your code so that it defines the method parameters “by value”.

For example, the following construct is no longer correct and generates error COBCH0829:

       method-id myMethod using x as myClassName.
       …
       invoke myMethod(self).

The correct way to define the method parameters is “by value”:

       method-id myMethod using by value x as myClassName.
Related information
COBCH0829 Could not find method new with this signature


CASCD0142S

Region region-name has ended abnormally with an exit call, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASCF0005F

The utility support module could not be loaded as part of system initialization. This module is required for normal system operation.
System Action:
Terminate the requesting process
Resolution:
Check that $CASDIR is set correctly and the module dfh0utl exists in $CASDIR/lib
Destination:
standard error
Module:
config-module(dfhcpcfi)
Parent topic: CASCF0001 - CASCF0015


CASCD0160F

The DosStartSession failed with the return code error-id. This code may be an error listed with DosStartSession, DosOpen, DosLoadModule, or DosExecPgm. The module being started is dfhmd.exe in directory $CASDIR\lib.
System Action:
The request is rejected
Resolution:
Correct the cause of the return code error-id
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0160 - CASCD0175


CASKC0040I

A remote client entered a message to the active system.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
casasys
Parent topic: CASKC0031 - CASKC0045


CASCF0023S

An error occurred when opening the region configuration save file (rcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


Data Types - in COBOL and C#

Data Types in Managed COBOL

*> Value types
condition-value
binary-char (unsigned)
character
binary-short (unsigned)
binary-long (unsigned)
binary-double (unsigned)
float-short
float-long
decimal
DateTime (not a built-in COBOL type)

*> Reference types
object
string
*> Initializing. Two methods shown.
*> Method 1, in working storage
01 isTrue  condition-value       value true.
01 hex     binary-char unsigned  value h"2a".  *> Hex
01 octal   binary-char unsigned  value o"52".  *> Octal
01 person  object                value null.
01 aName   string                value "Dwight".
01 grade   character             value "B".
01 today   type DateTime         value
               type DateTime::Parse("12/3/2007 12:15:00)
01 amount  decimal               value 35.99.
01 gpa     float-short           value 2.9.
01 pi      float-long            value 3.14159265.
01 lTotal  binary-double         value 123456.
01 sTotal  binary-short          value 123.
01 usTotal binary-short unsigned value 123.
01 uiTotal binary-long           value 123.
01 ulTotal binary-long unsigned  value 123.
*> Method 2, local declaration
declare isTrue  condition-value       value true.
declare hex     binary-char unsigned  value h"2a".  *> Hex
declare octal   binary-char unsigned  value o"52".  *> Octal
declare person  object                value null.
declare aName   string                value "Dwight".
declare grade   character             value "B".
declare today   type DateTime         value
                    type DateTime::Parse("12/3/2007 12:15:00)
declare amount  decimal               value 35.99.
declare gpa     float-short           value 2.9.
declare pi      float-long            value 3.14159265.
declare lTotal  binary-double         value 123456.
declare sTotal  binary-short          value 123.
declare usTotal binary-short unsigned value 123.
declare uiTotal binary-long           value 123.
declare ulTotal binary-long unsigned  value 123.
*> Type information
01 x binary-long.
display x::GetType            *> Prints System.Int32
display type of binary-long   *> Prints System.Int32
display x::GetType::Name      *> Prints Int32
*> Type conversion
01 d float-short value 3.5.   *> automatic conversion
set i to d as binary-long     *> set to 3 (truncates decimal)
*> COBOL types not supported in C# or Java
*> Only a few examples here
01 displayNumber pic 9(9).99.
01 computeNumber pic 9(9)V99.
01 alphaNumberic pic a(23).
01 binaryStorage pic x(12).
*> Also groups and redefines - a few examples
01 arecord.
   03 aSubRecord pic x(10).
   03 aUnion     pic 9(10) redefines aSubrecord.

Data Types in C#

// Value Types
bool
byte, sbyte
char
short, ushort
int, uint
long, ulong
float, double
decimal
DateTime   // (not a built-in C# type)

// Reference Types
object
string

// Initializing
bool     isTrue  = true;
byte     hex     = 0x2A;   // hex

object   person  = null;
string   aName   = "Dwight";
char     grade   = 'B';
DateTime today   = DateTime.Parse("12/31/2007 12:15:00");

decimal  amount  = 35.99m;
float    gpa     = 2.9f;
double   pi      = 3.14159265;
long     lTotal  = 123456L;
short    sTotal  = 123;
ushort   usTotal = 123;
uint     uiTotal = 123;
ulong    ulTotal = 123;

// Type Information
int x;
Console.WriteLine(x.GetType());        // Prints System.Int32
Console.WriteLine(typeof(int));        // Prints System.Int32
Console.WriteLine(x.GetType().Name);   // prints Int32

// Type Conversion
float d = 3.5f;
int i = (int)d;   // set to 3  (truncates decimal)
Related reference
Local Data Item Declaration
Fields
Related information
Types and Type Conversion
Type Compatibility of Managed COBOL with Other Managed Languages
Type Mappings from Native COBOL to Managed Code


JCLCM0121S Unexpected return type from RJSECA-FC-Execute %1$s.

Parent topic: JCLCM0000 - JCLCM0199


CASKC0032I

A security profile Security profile found for Queue Manager Queue Manager Name has been found and security for MQSeries has been turned off.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
dfheserv
Parent topic: CASKC0031 - CASKC0045


CASCF0035S

An error occurred when writing the region configuration save file (rcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASCS1017E

Inbound transaction trans-id from system system-id failed security check for user user-id. The password supplied by the remote system was not valid.
System Action:
The transaction is abnormally terminated
Resolution:
Correct the user password on either the local or remote system
Destination:
TDQ CSMT
Module:
dfhebms (issued in dfhecics)
Parent topic: CASCS1001 - CASCS1018


CASST0002W

While attempting to shutdown a region an error occurred trying to attach to the region.
System Action:
As the shut down program cannot attach to the region the region cannot be shutdown
Resolution:
Make sure that the region being shutdown is running and retry
Destination:
console
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


CASRD1011I

The request handler was updated successfully.
System action:
None.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1000 - CASRD1015


CASST5000I

Shutdown PLT processing has started using the plt-name list.
System Action:
PLT processing proceeds normally
Resolution:
None
Destination:
console (and terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASRD1031I

The package was updated successfully.
System action:
None.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


Exception Handling - in COBOL and C#

Exception Handling in Managed COBOL

*> Throw an exception
declare myException as type Exception =
         new Exception(“Something is really wrong.").
raise myException

*> Catch an exception.
try
  set y to 0;
  compute x = 10 / y
catch myException  *> Argument is optional, no "When" keyword
  display myException::Message
finally
  invoke type Microsoft.VisualBasic.Interaction::Beep
end-try

Exception Handling in C#

// Throw an exception
Exception up = new Exception("Something is really wrong.");
throw up;

// Catch an exception
try
{
  y = 0;
  x = 10 / y;
}
catch (Exception ex) // Argument is optional, no "When" keyword
{
  Console.WriteLine(ex.Message);
}
finally
{
  Microsoft.VisualBasic.Interaction.Beep();
}
Related reference
RAISE Statement
TRY Statement


CASCD1003S

An error occurred locating the target directory for the system work files.
System Action:
The region start request is not processed
Resolution:
Correct the region setup or define the region
Destination:
standard out
Module:
dfhrem
Parent topic: CASCD1001 - CASCD1043


CASCD0023S

The specified option is not valid
System Action:
The request is rejected
Resolution:
Retry the request with a valid option
Destination:
standard error
Module:
dfhtxp
Parent topic: CASCD0016 - CASCD0031


Functions, Methods - in COBOL and C#

Functions in Managed COBOL

method-id TestFunc.
procedure division using by value x as binary-long,
                            by reference y as binary-long,
                            output z as binary-long.
   add 1 to x, y
   move 5 to z
end method.

01 a binary-long value 1.
01 b binary-long value 1.
01 c binary-long.  *> c doesn't need initializing

    invoke self::TestFunc(value a reference b output c)
*> Or
    invoke self::TestFunc(a b c)
    display a space b space c

*> sum is an intrinsic function in COBOL
01 total binary-long.
    set total to function sum(4 3 2 1) *> returns 10

*> To create a non intrinsic variable argument list function:
method-id MySum.
local-storage section.
01 i binary-long.
procedure division using params nums as binary-long occurs any
                   returning mysum as binary-long.
    perform varying i through nums
        add i to mysum
    end-perform
end method.

*> then to call it:
method-id main.
local-storage section.
01 i binary-long.
procedure division
    set i to self::MySum(1 2 3 4)
    display i
end method.

*> COBOL doesn't support optional arguments/parameters.
*> Just create two different versions of the same function.
method-id SayHello.
   procedure division using by value nam as string, prefix as string.
   display "Greetings, " prefix space nam
end method SayHello.

method-id SayHello.
   procedure division using by value nam as string.
   invoke self::SayHello(nam "")
end method.

Functions in C#

// Pass by value (in, default), reference (in/out),
// and reference (out)
void TestFunc(int x, ref int y, out int z)
{
   x++;
   y++;
   z = 5;
}

int a = 1, b = 1, c;  // c doesn't need initializing
TestFunc(a, ref b, out c);
Console.WriteLine("{0} {1} {2}", a, b, c);  // 1 2 5

// Accept variable number of arguments
int Sum(params int[] nums)
{
  int sum = 0;
  foreach (int i in nums)
  {
      sum += i;
  }
  return sum;
}

int total = Sum(4, 3, 2, 1);   // returns 10

/* C# doesn't support optional arguments/parameters.
   Just create two different versions of the same function. */
void SayHello(string name, string prefix)
{
   Console.WriteLine("Greetings, " + prefix + " " + name);
}

void SayHello(string name)
{
   SayHello(name, "");
}
Related reference
Constructors
INVOKE Statement
Related information
Extension Methods and Operators
Invoking a Method


CASKC1000I

During startup the maximum number of concurrent requests is logged.
System action:
None
Resolution:
None
Destination:
System Console and standard error.
Module:
dfhgglbl
Parent topic: CASKC1000 - CASKC1003


CASCD0139I

The CAS Daemon was started automatically as part of region startup. No regions are active so the CAS Daemon is automatically terminating.
System Action:
Shutdown
Resolution:
None
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASCF0001F

An error has occurred during Region configuration file processing Refer to CASCF0002F for the possible values of RC-1 and RC-2
System Action:
Terminate the requesting process
Resolution:
Determine and fix the cause of the problem
Destination:
standard error and/or system console
Module:
dfh0cfg
Parent topic: CASCF0001 - CASCF0015


CASCD4003W

An error occured whilst retrieving the ES configuration from the MF Directory Server.
System Action:
Continue initialization using defaults
Resolution:
None
Destination:
console and standard error
Module:
dfhmd
Parent topic: CASCD4002 - CASCD4007


CASCS5103S

A severe error message generated from a Communications Server.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
casgate
Parent topic: CASCS5010 - CASCS5103


CASCD1057 - CASCD1069

  • CASCD1057S
    A JES Initiator for Server server-name has abended due to an unexpected signal signal-value.
  • CASCD1058S
    A JES Printer for Server server-name has abended due to an unexpected signal signal-value.
  • CASCD1059I
    An IMS MPR Process has been started for Server server-name
  • CASCD1060I
    An JES Initiator Process has been started for Server server-name
  • CASCD1061S
    An undefined process request was received for Server server-name
  • CASCD1062I
    A JES Printer Process has been started for Server server-name
  • CASCD1063I
    An Event Manager Process has been started for Server server-name
  • CASCD1064I
    An Event Manager for Server server-name has successfully completed termination
  • CASCD1065S
    An Event Manager for Server server-name has exited, the value specified on the exit call was exit-value
  • CASCD1066S
    An Event Manager for Server server-name has abended due to an unexpected signal signal-value.
  • CASCD1067I
    An Animserv process has been started for Server server-name
  • CASCD1068I
    An Animserv process for Server server-name has successfully terminated
  • CASCD1069S
    An Animserv process for Server server-name has exited, the value specified on the exit call was exit-value
Parent topic: CASCD Error Messages


JCLUT0009E

Message

INPUT DD(%1$s) on CREATE or FD CARD is not on DSD CARD.

Where %1$s is Dataset name

Message Information

The INPUT dataset specified is not mentioned in the DSD INPUT parameter.

Resolution

Include the dataset name in the INPUT parameters of the DSD statement.

Parent topic: JCLUT Error Messages


CASKC0020E

The system attempted to load the Interface Definition Table (IDT) for Service service-name. The allocate request for storage to hold the disk image failed with a reason code of reason-code.
System action:
The service request is failed
Resolution:
Increase the shared memory allocation for the Cobol Application Server.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


C$LogicalXor

Performs a bitwise logical exclusive OR operation on two or more non-numeric or numeric operands.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:

CALL "C$LogicalXor"
    [GIVING result]
     USING operand1 {operand2} ...

Parameters:

result
PIC 9(n)
operand1
A non-numeric or numeric operand
operand2, 3, etc
A non-numeric or numeric operand that must be of the same data type as operand1
Note: If any non-numeric operand2 is shorter than operand1, it is assumed to be padded on the right with binary zeroes.

On Entry:

operand1, 2, 3, etc
Non-numeric or numeric operands, which must be of the same data type as operand1.

On Exit:

result
The result of the operation or operand1.

Comments:

For non-numeric USING operands, the bitwise logical exclusive OR of all the operands replaces the value of operand1. The value of result is set to a non-zero value if any character of operand1 is non-zero after the operation completes and zero otherwise.

For numeric USING operands, each operand is converted, if necessary, to a 32-bit binary integer. These 32-bit binary values are logically exclusive OR'd together. If the GIVING phrase is specified, the result of this operation is stored in result and the value of operand1 is not modified. If the GIVING phrase is not specified, the result of this operation is stored in operand1.

Related information
Call Conventions for Interfacing with Mixed Languages


CASCD0002S

CAS failed to create a new process in which to run the CAS daemon A UNIX 'fork' call returned with errno set to errno
System Action:
The CAS daemon is not started
Resolution:
Correct the cause of the error and retry
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0001 - CASCD0015


CASST0008W

An attempt to shutdown a region externally via a transid was rejected as the user failed the security check on the transaction.
System Action:
The region will not be shutdown
Resolution:
Make sure that the userid and password being specified has the correct security keys set in the SNT to run the shutdown transaction
Destination:
console
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


CASRD1017E

An unsuccessful request was made to delete the named request handler. return-code values
System action:
No updates made.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


CASCD1066S

An Event Manager for Server server-name has abended due to an unexpected signal signal-value.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


CASRD0038E

A conversion table entry of type resource-type (entry resource-name, group group-name) is not currently supported.
System action:
The entry is bypassed
Resolution:
Correct the definition
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASST5025S

A transaction program abend occurred in the program program of the plt-name list during Phase 2 PLTSD processing.
System action:
PLT processing is terminated; Shutdown is aborted.
Resolution:
Do a SHUTDOWN IMMMEDIATE to bypass PLTSD processing. Determine the cause of the transaction program abend and correct it. If the problem cannot be determined, the Resource Definitions can be updated to omit the program from the PLT or to use a different (or no) PLT.
Destination:
Console (and Terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASCS1100W

An error occurred in the CCI communications of the CAS CCI gateway.

Some common values for CCI-error are:

  • 2 - Comms buffer too small for received message
  • 3 - Invalid session identifier given
  • 4 - Server of same name already defined (warning)
  • 5 - Server of same name already defined (error)
  • 6 - Invalid public or machine name
  • 7 - Invalid request on closed session
  • 8 - Previous connection not responding
  • 9 - Miscellaneous error
  • 10 - Request could not be executed
  • 11 - Run out of memory
  • 12 - Unknown error

All error codes are from CCI. Numbers greater than 99 are specific to a net layer and do not map directly to one of the codes above. For NetBios, 100 is added to the net layer code to differentiate from the codes above. For further information check CCI return code documentation.

System Action:
None
Resolution:
None
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASCD0110I

The CAS Daemon is beginning a normal shutdown
System Action:
Shutdown
Resolution:
none
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


CASCF0027S

An error occurred when opening the development configuration file (dfhtxdev.cfg).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASRD0051E

The DOCTEMPLATE resource-name cannot be installed as it contains the same TEMPLATENAME as DOCTEMPLATE2.
System action:
Continue, the resource will not be installed.
Resolution:
Specify different TEMPLATENAME values.
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0046 - CASRD0052


CASCD0175I

Processing of ddbg port range detected an error Verify region configuration.
Resolution:
Port range processing is disabled, unless no more port available. Verify configuration and correct error
Destination:
system console
Module:
cascd
Parent topic: CASCD0160 - CASCD0175


CASCS1003S

Inbound transaction routing of transaction trans-id failed because the terminal term-id is not owned by the remote system system-id. The request originated from a terminal that has the same term-id as another remote system or the term-id is defined as local to this CICS region.
System Action:
The transaction is abended
Resolution:
Correct the terminal definitions
Destination:
TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASKC0031 - CASKC0045

  • CASKC0031E
    The system attempted load the Interface Definition Table (IDT) but failed to locate the file. IDT locations need to be fully qualified.
  • CASKC0032I
    A security profile Security profile found for Queue Manager Queue Manager Name has been found and security for MQSeries has been turned off.
  • CASKC0033I
    A security profile Security profile found for Queue Manager Queue Manager Namehas not been found and security for MQSeries has been turned on.
  • CASKC0034I
    A security profile Security profile found for Queue Manager Queue Manager Namehas not been found and security for MQSeries has been turned on for type Type security.
  • CASKC0035I
    A security profile Security profile found for Queue Manager Queue Manager Namehas been found and security for MQSeries has been turned off for type Type security.
  • CASKC0040I
    A remote client entered a message to the active system.
  • CASKC0041E
    Transaction trans-id abnormally terminated with abend code abend-code. A abend-description will be supplied for standard CICS API exception ABENDs.
  • CASKC0042I
    Transaction trans-id abnormally terminated with abend code abend-code. A abend-description will be supplied for standard CICS API exception ABENDs.
  • CASKC0043E
    Transaction trans-id abnormally terminated with abend code ASRA.
  • CASKC0044S
    ES failed to authorize the CICS Default user during initialization.
  • CASKC0045I
    Logging all enable and disable requests for CICS transactions
Parent topic: CASKC Error Messages


CASRD0025E

The resource definition for resource-type entry resource-name is not installable. The existing installed definition is in use.
System action:
Continue, the group will not be installed.
Resolution:
Close and disable the file and retry the operation.
Destination:
TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASCD1035I

A Spool service has been started for region region-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


C$DARG

Returns information about a parameter passed in the USING or GIVING phrases of the CALL statement that called a subprogram.
Restriction: This routine is supported in native COBOL only.

When calling this routine, ensure you are using the 1024 calling convention.

This information identifies the type and length of the argument and, when the argument is numeric or numeric edited, the number of digits and scale factor for the argument.

Syntax:

CALL "C$DARG" USING argument-number, argument-description

Parameters:

argument-number
pic 9(n)
argument-description
01 ARGUMENT-DESCRIPTION.
    02 ARGUMENT-TYPE PIC 9(2) BINARY(2).
    02 ARGUMENT-TYPE PIC 9(2) BINARY(2).
    02 ARGUMENT-LENGTH PIC 9(8) BINARY(4).
    02 ARGUMENT-DIGIT-COUNT PIC 9(2) BINARY(2).
    02 ARGUMENT-SCALE PIC S9(2) BINARY(2).
    02 ARGUMENT-POINTER POINTER.
    02 ARGUMENT-PICTURE POINTER.

On Entry:

argument-number
The ordinal position of the argument in the USING phrase of the CALL statement. The value zero returns the description of the GIVING phrase of the CALL statement.

On Exit:

argument-description
Details of the passed parameter. Those details include:
argument-type
The type of data item; see the table in the Comments section.
argument-length
The number of character positions of the data item.
argument-digit-count
The number of digits defined in the PICTURE character-string for an argument that is a numeric or numeric edited data item as indicated by the ARGUMENT-TYPE field value; otherwise, the value zero is returned for nonnumeric data items. The digit count for a numeric or numeric edited data item does not include any positions defined by the PICTURE symbol P, which represents a scaling position.
argument-scale
The power of 10 scale factor (that is, the position of the implied or actual decimal point) for an argument that is a numeric or numeric edited data item as indicated by the ARGUMENT-TYPE field value; otherwise, the value zero is returned for nonnumeric data items. If the PICTURE symbol P was used in the description of the data item, the absolute value of the ARGUMENTSCALE value will exceed the ARGUMENT-DIGIT-COUNT value; in this case, a positive scale value indicates an integer with P scaling positions on the right of the PICTURE character-string and a negative scale value indicates a fraction with P scaling positions on the left of the PICTURE character-string
argument-pointer
This parameter is not returned in this COBOL system.
argument-picture
This parameter is not returned in this COBOL system.

Comments:

Use the C$NARG library routine to obtain the number of arguments passed in the CALL statement.

The actual number of arguments may exceed the number of formal arguments declared in the Procedure Division header of the program that calls C$DARG. All of the actual arguments can be accessed using C$DARG even though there is no formal argument name available for accessing the actual arguments beyond the number of formal arguments.

The following table is used to indicate the data type specified in the ARGUMENT TYPE field:

Type Number | RM/COBOL Data Type | Type Number | RM/COBOL Data Type
0 | NSE | 16 | ANS
1 | NSU | 17 | ANS (justified right)
2 | NTS | 18 | ABS
3 | NTC | 19 | ABS (justified right)
4 | NLS | 20 | ANSE
5 | NLC | 21 | ABSE
6 | NCS | 22 | GRP (fixed length)
7 | NCU | 23 | GRPV (variable length)
8 | NPP | 25 | PTR
9 | NPS | 26 | NBSN
10 | NPU | 27 | NBUN
11 | NBS | 32 | OMITTED
12 | NBU |  |
Restriction: Data type OMITTED (type number 32) is not supported in this COBOL system.
Related reference
The CALL Statement
Related information
Call Conventions for Interfacing with Mixed Languages


CASCD0146S

The 3270 CCI gateway of region region-name has exited, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASKC0031E

The system attempted load the Interface Definition Table (IDT) but failed to locate the file. IDT locations need to be fully qualified.
System action:
The service request is failed
Resolution:
Correct the location or deployment error and retry the request.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0031 - CASKC0045


CASCF0047F

An unexpected error occurred in system initialization while processing the configuration file.

Some values for RC are:

  • 01 - No region name specified
  • 02 - Bad line in file
  • 03 - File not found
  • 04 - Error creating file
  • 05 - Error opening file
  • 06 - Error reading file
  • 07 - Error writing to file
  • 08 - CASLOCAL invalid
  • 09 - CASDIR invalid
  • 10 - Region files directory invalid
  • 11 - Messaging support module not found
  • 12 - Utilities module not found
  • 13 - File handling module not found
  • 14 - System files directory invalid
  • 15 - Resource definition file directory invalid
  • 16 - Region directory invalid
  • 17 - Environment variable too large
System Action:
Terminate the requesting process
Resolution:
Determine the cause of the error from the return-code table and re-try
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASST6002I

The MQSeries trigger monitor program (CKTI) has disconnected from the queue manager and is terminating
System Action:
None
Resolution:
None
Destination:
console
Module:
dfhtmqgw
Parent topic: CASST5000 - CASST6002


CASCS1109I

The CAS CCI gateway successfully connected to remote-region. It is accessible via sysid sys-id. This system is the contention winner or the client side of the connection.
System Action:
The connection is available for work
Resolution:
None
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASCD0166W

CAS attempted to create a new process from the CAS Daemon process but the call failed with RC=return-code from a CreateProcess request.
System Action:
Abort the attempt to start a REM or server
Resolution:
Determine and fix cause of failure then retry
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0160 - CASCD0175


JCLAM0221S Insufficient authority to define new dataset %

Lack of permissions to perform this action.

Resolution:

Contact your system administrator.

Parent topic: JCLAM0180 - JCLAM0230


CASRD0044E

The GROUP keyword for the resource that you are trying to install is not recognized.
System action:
The request is not executed
Resolution:
Correct the request and resubmit
Destination:
terminal, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASCF0062F

The module has not been recognized by the authorisation process
System Action:
>Terminate the requesting process
Resolution:
Contact Micro Focus
Destination:
standard error
Module:
config-module(dfhcpcfi)
Parent topic: CASCF0046 - CASCF0063


CASFD0001 - CASFD0014

  • CASFD0001I
    The offline dump requester issued a dump request for region region-name. The dump went to the normal region dump dataset.
  • CASFD0002S
    The offline dump requester failed in its attempt to contact the region.
  • CASFD0003S
    The offline dump requester failed in its attempt to change to the region's directories.
  • CASFD0004S
    The offline dump requester failed in its attempt to change to the root Transaction System directory.
  • CASFD0005S
    The offline dump requester failed in its attempt to change to the region's directories.
  • CASFD0006S
    The offline dump requester failed in its attempt to set environment variables.
  • CASFD0007S
    The offline dump requester failed to find the requester support module.
  • CASFD0008S
    The offline dump requester failed to issue the IMS dump request because the parameter to not locked the shared memory was used.
  • CASFD0009S
    The offline dump requester could not issue an IMS dump request for region region-name. The IMS option was not enabled for the region
  • CASFD0010I
    The offline dump/trace format request is complete.
  • CASFD0011I
    The output from the offline dump/trace format request was written to the output file output-file-name.
  • CASFD0012E
    No input dump/trace dataset could be located.
  • CASFD0013I
    The offline dump requester issued an IMS dump request for region region-name. The dump went to the normal region dump dataset.
  • CASFD0014E
    The input Dump/Trace dataset was not generated on the same bitism environment.
Parent topic: CASFD Error Messages


CASSP0010S

A syncpoint, either implied or requested via API has failed and the DB/file resource state is unpredictable.
System action:
The transaction will abend.
Resolution:
Investigate why the syncpoint failed and restore the database resource managers to a known position.
Destination:
Console and standard error.
Module:
dfhesync
Parent topic: CASSP0001 - CASSP0014


CASCF0019S

An error occurred when creating the global configuration save file (gcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASCD0005S

CAS failed to open named pipe 'pipe-name' which was to be used to receive messages from the CAS daemon A UNIX 'fopen' call returned with errno set to errno
System Action:
The CAS daemon is not started
Resolution:
Correct the cause of the error and retry
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0001 - CASCD0015


C$LogicalComplement

Performs a bitwise logical One's Complement operation on a non-numeric or numeric operand.

When calling this routine, ensure you are using the 1024 calling convention.

Syntax:

CALL "C$LogicalComplement"
[GIVING result]
 USING operand

Parameters:

result
PIC 9(n)
operand
A non-numeric or numeric operand

On Entry:

operand
A non-numeric or numeric operand.

On Exit:

result
The result of the operation or operand.

Comments:

If operand refers to a non-numeric data item, the bitwise logical One’s Complement of the value of operand replaces the value of operand. The value of result is set to a non-zero value if any character of operand is non-zero after the operation completes and zero otherwise.

If operand refers to a numeric data item, the operand is converted, if necessary, to a 32-bit binary integer. The 32-bit binary value is logically One’s Complemented. If the GIVING phrase is specified, the result of this operation is stored in result and the value of operand is not modified. If the GIVING phrase is not specified, the result of this operation is stored in operand.

Related information
Call Conventions for Interfacing with Mixed Languages


CASKC0008I

The system has now enough free shared storage to re-acquire the shared storage cushion. GETMAIN SHARED and LOAD HOLD requests will now be accepted.
System action:
The shared storage cushion will be re-acquired and the critical memory condition will be reset.
Resolution:
None
Destination:
System Console.
Module:
dfhgglbl
Parent topic: CASKC0000 - CASKC0015


CASCD0007S

The CAS daemon process has terminated without first sending a severe or fatal error message process status is the status as returned by the UNIX 'wait' call
System Action:
The CAS daemon is not started
Resolution:
Determine the cause of the error and retry if appropriate
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0001 - CASCD0015


CASXO0024I

A user disabled the XA Resouce Manager.
System Action:
The XA Resource Manager will not be called for future transactions
Resolution:
None
Destination:
console
Module:
casrdo81
Parent topic: CASXO0016 - CASXO0026


CASKC1001W

The number of active client requests exceeded the licensed maximum client-count times.
System action:
System will continue as normal
Resolution:
Check system configuration and allocate additional client licenses as appropriate
Destination:
System Console and standard error.
Module:
dfhgglbl
Parent topic: CASKC1000 - CASKC1003


CASFD0006S

The offline dump requester failed in its attempt to set environment variables.
System action:
The dump request is ignored
Resolution:
Correct the configuration specification and retry the operation.
Destination:
Console and standard error.
Module:
dfhgtrtd
Parent topic: CASFD0001 - CASFD0014


CASFD0012E

No input dump/trace dataset could be located.
System action:
None
Resolution:
Check the location of the dump/trace datasets and retry. Dump/Trace dataset names:
Destination:
Standard error.
Module:
dfhgdup
Parent topic: CASFD0001 - CASFD0014


CASCF0010S

An unrecognized line was found in the global configuration file ($CASDIR/dfhtx.cfg) at the line shown.
System Action:
Terminate the requesting process
Resolution:
Correct the fault with the configuration file ensuring that the line contains a valid configuration item
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0001 - CASCF0015


JCLCM0800 - JCLCM0899

  • JCLCM0801I Event-job-concluded. Job ended normally
  • JCLCM0802I Event-job-concluded. Job ended abnormally
  • JCLCM0803I Event-job-concluded. Job failed - JCL error
  • JCLCM0804I Event-job-concluded. Job scanned - No Errors
  • JCLCM0805I Event-job-concluded. Job scanned - JCL error
  • JCLCM0806I Event-job-concluded. Job flushed - No JOB stmt
  • JCLCM0807I Event-job-concluded. Job flushed - Bad JOB stmt
  • JCLCM0808I Event-job-concluded. Job flushed by User Exit req
  • JCLCM0809I Event-job-concluded. Job copied
  • JCLCM0810I Event-job-concluded. Job cancelled
  • JCLCM0811I Event-job-concluded. Job authentication failed
Parent topic: JCLCM Error Messages


CASKC0023E

The system could not locate a definition for the request-handler-name request handler.
System action:
All requests associated with this handler will be rejected.
Resolution:
Check the CAS configuration.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


CASRD1030I

The package was added successfully.
System action:
None.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


CASCD0051F

The request to start a region was not successful
System Action:
The region is not started
Resolution:
Check previous messages for cause of error, correct the problem and retry if appropriate
Destination:
standard error
Module:
dfhrem
Parent topic: CASCD0050 - CASCD0099


CASST4022S

The PLT processing transaction program, dfhzplt, could not be found.
System action:
Shutdown processing aborted.
Resolution:
Do a SHUTDOWN IMMMEDIATE to bypass PLTSD processing.
Destination:
Console (and Terminal)
Module:
dfhzcqit
Parent topic: CASST4000 - CASST4111


CASCD1020I

The JCP service has been started for region region-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


CASCF0030S

An error occurred when reading the development configuration save file (dcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASCD1065S

An Event Manager for Server server-name has exited, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


CASCS5011W

MFCS failed to open the port for the TCPIPSERVICE TCPIPSERVICE name
System action:
TCPIPSERVICE TCPIPSERVICE name status set to Closed.
Resolution:
Check if port is already in use.
Destination:
Console
Module:
casgate
Parent topic: CASCS5010 - CASCS5103


To define an SQL user exit for a CICS.NET region

  1. Click Start > All Programs > Micro Focus Studio Enterprise Edition x.x > Configuration, then right-click Enterprise Server for .NET Administration and select Run as Administrator to start the Microsoft Management Console.
  2. Expand the list in the Tree pane to show the defined regions.
  3. Click the CICS.NET region you want to use; then click Start/Stop Region on the Actions pane.
  4. If the region is started, click Stop.
  5. From the Tree pane, select your CICS.NET region.
  6. From the Actions pane, click Edit Region Startup File.
  7. From the tree view in the Results pane, click Region to display the properties for the region.
  8. Expand the General section in the properties listing.
  9. In the SQL User Exit field, type MicroFocus.SEE.SqlExit.
    Note: If you have installed Server Enterprise Edition for .NET using the default installation parameters, you do not need to prepend the path to the user exit program. However, if you altered the installation location when installing Server Enterprise Edition for .NET , prepend the full path to the user exit program name.
  10. Save your region configuration changes.
  11. In the Results pane, click Start to start the region.
  12. Close the Microsoft Management Console.
Related reference
SQL Server Connection tab
Connection List tab


CASST0007I

The shutdown program is starting to shutdown the region by abending all region processes.
System Action:
All region process with be abnormally ended
Resolution:
None
Destination:
console
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


CASXO0026I

A user requested support for one phase commit only.
System Action:
The XA Resource Manager will be called for future transactions
Resolution:
None
Destination:
console
Module:
dfhexa
Parent topic: CASXO0016 - CASXO0026


CASKC0021E

The system attempted to load the Interface Definition Table (IDT) for Service service-name. The file system read for the disk image failed with a reason code of reason-code.
System action:
The service request is failed
Resolution:
Correct the location or deployment error and retry the request.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


CASRD0003S

ARRAY(0x2a9d620)
System action:
The request is rejected.
Resolution:
Verify that the proper group is being installed.
Destination:
terminal, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


CASCD0013F

Only one CAS Daemon is required, attempts to start more are rejected
System Action:
The request is rejected
Resolution:
Terminate existing Daemon if restart is required
Destination:
standard error
Module:
dfhmd
Parent topic: CASCD0001 - CASCD0015


JCLAM0224E Insufficient authority to delete dataset %

Lack of permissions to perform this action.

Resolution:

Contact your system administrator.

Parent topic: JCLAM0180 - JCLAM0230


JCLCM0011I OUTLIM limit for DD name incremented by amount by user exit MFJUSOXT

The user exit has incremented the OUTLIM value by <amount>.

Resolution:

None.

Parent topic: JCLCM0000 - JCLCM0199


Properties - in COBOL and C#

Properties in Managed COBOL

class-id MyClass.
working-storage section.
01 volume binary-long private.
property-id Volume binary-long.
  getter.
    set property-value to volume
  setter.
    if property-value < 0
      set volume to 0
    else
      set volume to property-value
    end-if
end property.
end class.
*> COBOL also allows you to expose fields as properties
class-id MyClass.
working-storage section.
01 llength  binary-long property as "Length".
01 width    binary-long property as "Width"   no get.
01 breadth  binary-long property as "Breadth" no set.
end class.
class-id a.
method-id main.
local-storage section.
01 foo type MyClass value new MyClass.
procedure division.
    add 1 to foo::Volume
    display foo::Volume
end method.
end class.

Properties in C#

private int _size;
private int _length;
private int _width;
private int _breadth;

public int Size
{
  get
  {
    return _size;
  }
  set
  {
    if (value < 0)
    {
      _size = 0;
    }
    else
    {
      _size = value;
    }
  }
}

public int Length
{
  get
  {
    return _length;
  }
  set
  {
    _length = value;
  }
}

public int Width
{
  set
  {
    _width = value;
  }
}

public int Breadth
{
  get
  {
    return _breadth;
  }
}
foo.Size++;

Properties in Java

private int _size = 0;
private int _length = 0;
private int _width = 0;
private int _breadth = 0;

public int getSize()
{
    return _size;
}
public void setSize(int value)
{
    if (value < 0)
    {
      _size = 0;
    }
    else
    {
      _size = value;
    }
}

public int getLength()
{
    return _length;
}
public void setLength(int value)
{
    _size = value;
}

public void setWidth(int value)
{
    _width = value;
}

public int getBreadth()
{
    return _breadth;
}

foo.Size++;

Portions of these examples were produced by Dr. Frank McCown, Harding University Computer Science Dept, and are licensed under a Creative Commons License.

Related reference
Properties


CASXO0016 - CASXO0026

  • CASXO0016S
    The XA resource manager's switch module had been previously loaded successfully by another server but failed to intiialize on this process.
  • CASXO0017S
    An unrecoverable error occured interfacing with the XA Resouce Manager.
  • CASXO0018S
    The Resource manager for the XAT resource returned a non-zero value to the xa_end call.
  • CASXO0019S
    The Switch Load Module for the XAT resource failed to load the necessary DLLs or .so programs. The returned pointer was null.
  • CASXO0020I
    The XA resource manager's switch module was loaded successfully.
  • CASXO0021I
    The XA resource manager's switch module contained appropriate support for local transactions.
  • CASXO0022W
    The XA resource manager's switch module did not contain support for local transaction commit/rollback functions.
  • CASXO0023S
    A severe error occured interfacing with the XA Resouce Manager.
  • CASXO0024I
    A user disabled the XA Resouce Manager.
  • CASXO0025I
    A user enabled the XA Resouce Manager.
  • CASXO0026I
    A user requested support for one phase commit only.
Parent topic: CASXO Error Messages


CASCD0014F

A UNIX setuid call has failed, returning errno set to errno. This is probably caused by an attempt to start an CAS Daemon without super-user authority
System Action:
The CAS Daemon is not started
Resolution:
Retry the request from a super-user
Destination:
standard error
Module:
dfhmd
Parent topic: CASCD0001 - CASCD0015


C$GetLastFileOp

Retrieves the last COBOL I/O operation performed.

Syntax:

Note: When calling this routine, ensure you are using the 1024 calling convention.

Use this library routine within a declarative procedure after an I/O error has occurred.

CALL "C$GetLastFileOp" USING operation

Parameters:

operation
PIC X(20)

On Exit:

operation
The name of the last I/O operation performed. The valid operations returned are:
  • Close
  • CloseUnit
  • Delete
  • DeleteFile
  • DeleteRandom
  • Open
  • ReadNext
  • ReadPrevious
  • ReadRandom
  • Rewrite
  • RewriteRandom
  • Start
  • Unlock
  • Write
  • WriteRandom

Comments:

If the operation is longer than 20 characters, it is truncated to the right.

If the value SPACES is returned that indicates that no operation is available.

Related information
Call Conventions for Interfacing with Mixed Languages


CASKC0009E

The PCT entry transid is currently marked as disabled.
System action:
The requested transaction is not executed.
Resolution:
Notify the system administrator.
Destination:
User terminal and TDQ CSMT.
Module:
dfheserv
Parent topic: CASKC0000 - CASKC0015


CASCF0003F

The messaging support module could not be loaded as part of system initialization. This module is required for normal system operation.
System Action:
Terminate the requesting process
Resolution:
Check that $CASDIR is set correctly and the module dfh0msg exists in $CASDIR/lib
standard error
DEST
Module:
config-module(dfhcpcfi)
Parent topic: CASCF0001 - CASCF0015


printer_raw_redirection

Redirects WRITE statements through the Windows print spooler as RAW data types.
Restriction: This tunable is supported for .NET COBOL only.

Syntax:

>>-----printer_raw_redirection=----.-TRUE-.-------><
                                   +-FALSE+

Parameters:

TRUE | Redirect WRITE statements to files defined with the ASSIGN TO PRINTER syntax through the Windows print spooler and process them as RAW data types.
FALSE | Output is sent through the printer driver or directly to the printer port; see printer_redirection.

Properties:

Default: | FALSE
IDE equivalent: | None

Comments:

This tunable is dependent on printer redirection being on, which you can do by setting the printer_redirection tunable or by calling the PC_PRINTER_REDIRECTION_PROC routine.


CASCD1034S

The MQSeries Gateway process of region region-name has exited, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


CASRD0011S

ARRAY(0x2886360)
System action:
The request is rejected.
Resolution:
Verify the system installation. Check that the resource definition file has not been moved, deleted, or the network connection lost.
Destination:
terminal, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


CASCS1120W

The communications server failed to establish an ISC connection to peer system remote-region. The CCI protocol return code is reason-code.
System Action:
The bind for the peer server is silently retried until the ISC connection status changes
Resolution:
Check that the remote-region is active and that the system has a network path to remote-region for the protocol specified
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1116 - CASCS1138


CASCD0144S

server server-number of region region-name has failed to initialize and exited, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASCD0052S

An attempt has been made to start a region before there is an active CAS Daemon
System Action:
The region is not started
Resolution:
Start an CAS Daemon before attempting to start other components
Destination:
standard error
Module:
dfhrem
Parent topic: CASCD0050 - CASCD0099


C$ConvertAnsiToOem

Converts a buffer containing ANSI characters to a buffer containing the corresponding OEM characters.

When calling this routine, ensure you are using the 1024 calling convention.

This is supported on Windows only.

Syntax:

CALL "C$ConvertAnsiToOem" USING ansi-buffer, oem-buffer
[, char-count]

Parameters:

ansi-buffer
PIC X(n)
oem-buffer
PIC X(n)
char-count
PIC 9(n)

On Entry:

ansi-buffer
The ANSI characters to be converted to OEM characters.
char-count
The number of characters to be converted.
Note: If omitted or if the value is invalid, the actual size of the shorter of ansi-buffer and oem-buffer is used.

On Exit:

oem-buffer
The converted OEM characters.
Related information
Call Conventions for Interfacing with Mixed Languages


CASCF0007F

The file handling support module could not be loaded as part of system initialization. This module is required for normal system operation.
System Action:
Terminate the requesting process
Resolution:
Check that $CASDIR is set correctly and the module mffh exists in $COBDIR
Destination:
standard error
Module:
config-module(dfhcpcfi)
Parent topic: CASCF0001 - CASCF0015


CASKC1002I

During shutdown the maximum number of concurrent requests is logged against the actual
System action:
None
Resolution:
None
Destination:
System Console and standard error.
Module:
dfhgglbl
Parent topic: CASKC1000 - CASKC1003


CASCD0099I

The CAS Daemon tag for current version
System Action:
None
Resolution:
None
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0050 - CASCD0099


CASCS1016E

Outbound transaction routing of transaction trans-id failed because system system-id is not defined as a connection.
System Action:
The request is rejected
Resolution:
Correct the resource definition for SYSID system-id or point transaction to the correct SYSID
Destination:
user terminal and TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASXO0011S

The Resource manager for the XAT resource returned a non-zero value to the xa_rollback call.

The return codes are:

  • -2 Asynchronous operation already outstanding
  • -3 A resource manager error occurred
  • -4 The XID is not valid
  • -5 Invalid arguments were given
  • -6 Routine invoked in an improper context
  • -7 Resource Manager unavailable
  • -8 the XID already exists
  • -9 Resource Manager doing work outside global transaction
  • The following indicate the transaction is marked as roll-back only
  • 100 The resource manager marked the transaction roll-back only for an unspecified reason.
  • 101 A communication failure occurred
  • 102 The resource manager detected a deadlock
  • 103 The resource manager detected a violation of the integrity of its resources
  • 104 The resource manager marked the transaction roll-only for a reason not in this list.
  • 105 A protocol error occurred in the resource manager
  • 106 The work represented by this transaction took too long
  • 107 The resource manager detected a transient error
System Action:
The Transaction is abnormally terminated
Resolution:
Check that the Resource Manager is still available
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


CASRD0017W

The resource type resource-type (resource resource-name, group group-name) is not recognized.
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASCD1067I

An Animserv process has been started for Server server-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


CASCD0157E

An error occurred in the CCI communications of the CAS console daemon. CCI-error-text is returned from CCI. This message will be generated prior to message CASCD0158E for CCI error return code 9.
System Action:
None
Resolution:
None
Destination:
console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASST5010I

Shutdown PLT processing has completed successfully using the plt-name list.
System Action:
Shutdown proceeds normally
Resolution:
None
Destination:
console (and terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


Operators - in COBOL and C#

Operators in Managed COBOL

*> Comparison
= < > <= >= <>

*> Arithmetic
+ - * /
function mod
*>no direct COBOL equivalent to integer division
**

*> Assignment
move, set, compute

*> Bitwise
b-and, b-or, b-xor, b-not, b-left, b-right

*> Logical
and, or, not

Operators in C#

// Comparison
==  <  >  <=  >=  !=

// Arithmetic
+  -  *  /
%  (mod)
/  (integer division if both operands are ints)
Math.Pow(x, y)

// Assignment
=  +=  -=  *=  /=   %=  &=  |=  ^=  <<=  >>=  ++  --

// Bitwise
&   |   ^   ~   <<   >>

// Logical
&&   ||   &   |   ^   !

//Note: && and || perform short-circuit logical evaluations

// String Concatenation
+
Related reference
Operators
Related information
Operator Overloading in Managed COBOL


CASRD1018I

An unrecognized administration request was made for the named request handler.
System action:
Reject the request.
Resolution:
Check the product installation.
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


JCLAM0222S Insufficient authority to read dataset %

Lack of permissions to perform this action.

Resolution:

Contact your system administrator.

Parent topic: JCLAM0180 - JCLAM0230


CASCS1125I

The CAS CCI gateway connection to remote-region is releasing. The action is at the request of the local system. Active work on sysid sys-id will terminate abnormally. The CCI network protocol in use is CCI-transport.
System action:
The connection sys-id will no longer be available for work.
Resolution:
No user action is required.
Destination:
Console
Module:
casgate
Parent topic: CASCS1116 - CASCS1138


CASST4090I

The attached terminal is automatically disconnected when a shutdown request is processed.
System action:
Disconnect the terminal requesting shutdown.
Resolution:
None
Destination:
Terminal
Module:
dfhzcqit
Parent topic: CASST4000 - CASST4111


CASCD0006S

An error occurred attempting to read from the named pipe pipe-namewhich was being used to receive messages from the CAS daemon A UNIX 'fgets' call returned with errno set to errno
System Action:
The CAS daemon is not started
Resolution:
Correct the cause of the error and retry
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0001 - CASCD0015


CASCD0114W

The CAS Daemon cannot begin a normal shutdown while there are regions running
System Action:
The shutdown request is rejected
Resolution:
Shutdown the active regions and retry
Destination:
standard error
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


JCLCM0488E Closing bracket before action in limitation type global SYSOUT limit

The syntax of the environment setting is incorrect.

Resolution:

Correct the syntax error.

Parent topic: JCLCM0400 - JCLCM0499


CASXO0025I

A user enabled the XA Resouce Manager.
System Action:
The XA Resource Manager will be called for future transactions
Resolution:
None
Destination:
console
Module:
casrdo81
Parent topic: CASXO0016 - CASXO0026


CASST4002E

The shutdown request was rejected because the system was already in shutdown or was never successfully started.
System action:
None
Resolution:
None
Destination:
Console (and Terminal)
Module:
dfhzcqit
Parent topic: CASST4000 - CASST4111


CASCD0001F

The request to start a CAS daemon was not successful
System Action:
The CAS daemon is not started
Resolution:
Check previous messages for cause of error, correct the problem and retry if appropriate
Destination:
standard error
Module:
dfhtxs
Parent topic: CASCD0001 - CASCD0015


CASRD0036W

During install of the resource-type entry resource-name, group group-name, a free main for the old table definition failed. The reason reason-code is the return from the free shared memory routine.
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0031 - CASRD0045


CASCD1011S

An error occurred while processing the region configuration file.
System Action:
The console daemon or region manager will not initialize successfully
Resolution:
Correct the fault with the configuration file
Destination:
console
Module:
dfhrem
Parent topic: CASCD1001 - CASCD1043


CASCF0024S

An error occurred when opening the development configuration save file (dcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASCD1063I

An Event Manager Process has been started for Server server-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


CASSP0001 - CASSP0014

  • CASSP0001W
    The console daemon detected a process's termination and attempted to inform the region manger of the event. It failed due to the reason given.
  • CASSP0002I
    The console daemon detected a process's termination and successfully informed the region manger of the event. pinfo describes the process information details
  • CASSP0003E
    The daemon process responsible for initiating recovery for process-id failed trying to lock shared memory.
  • CASSP0004E
    The daemon process responsible for initiating recovery for process ID process-id failed trying to lock shared memory.
  • CASSP0010S
    A syncpoint, either implied or requested via API has failed and the DB/file resource state is unpredictable.
  • CASSP0011S
    A syncpoint was requested and attempted against the configured resource managers. A bad response was returned and the resource managers were rolledback to the previous syncpoint.
  • CASSP0012S
    IMS has abended during the current transaction running.
  • CASSP0013S
    A rollback, either implied or requested via API has failed and the DB/file resource state is unpredictable.
  • CASSP0014S
    The process terminated due to a COBOL RTS error.
Parent topic: CASSP Error Messages


CASRD1040E

A request to add, update or delete a request handler failed due to an unrecognised request handler definition.
System action:
Reject the administration request.
Resolution:
Check the CAS components are compatible.
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


Nested Classes in Managed COBOL

In managed COBOL, you can define a nested class within another class, following all the methods belonging to the containing class.

Nested classes can access static fields, properties and methods within the containing classes using the syntax:

self::memberName

The optional SHARING PARENT phrase in the nested class definition enables the nested class to access the instance fields, properties and methods in the containing class.

    class-id ContainingClass.
    ...
    class-id Nested1.
        ...
    end class.
    class-id Nested2 sharing parent.
       ...
    end class.
    end class.

Nested Classes with SHARING PARENT

Nested classes with the SHARING PARENT phrase may only be instantiated from within an instance method in the enclosing class. They can access the instance members from that containing class using the self:: syntax, even when those instance members are private.

Such a nested class contains an implicit reference to an instance of its containing class. The nested class uses this reference to access the enclosing class's instance members. This means that the containing class instance will not be garbage collected until all references to the inner class held externally have themselves been garbage collected.

For example:

    class-id ContainingClass.
    01 companyName string value "Micro Focus".

    method-id instance1.
    01 o type Nested2.
        set o to new Nested2
        ...
    end method

    class-id Nested2 SHARING PARENT.
    method-id method2
        display self::companyName
    end method.
    end class.

    end class.

Nested Classes without SHARING PARENT

Nested classes defined without the SHARING PARENT phrase may be declared as public, private or internal. Depending on the visibility specified, they can be instantiated from any context, not just from the containing class, and not just from instance methods. They cannot access instance members of the containing class with the self:: syntax, but only do it using an explicit object reference.

Related reference
Classes


CASCD0010F

CAS failed to delete a UNIX message queue during shutdown A UNIX message queue call returned with errno set to functionThe call that failed is specified by function, where: 1 = msgget 2 = msgctl 3 = msgrcv 4 = msgsnd
System Action:
The CAS Daemon continues shutdown
Resolution:
Determine the cause of the error and retry if appropriate
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0001 - CASCD0015


CASST0010W

An attempt to shutdown a region externally via a transid was rejected as the transaction was not found.
System action:
The region will not be shutdown.
Resolution:
Make sure that the transaction is in the correct case and has been installed to the region.
Destination:
Console
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


CASKC0025I

A message has been generated processing a service.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


CASCD0102F

The CAS Daemon has failed to initialize
System Action:
The CAS daemon is not started
Resolution:
Check previous messages for cause of error, correct the problem and retry if appropriate
Destination:
standard error
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


CASFD0005S

The offline dump requester failed in its attempt to change to the region's directories.
System action:
The dump request is ignored
Resolution:
Correct the region specification and retry the operation.
Destination:
Console and standard error.
Module:
dfhgtrtd
Parent topic: CASFD0001 - CASFD0014


CASCD0064S

A UNIX call returned with errno set to errno.

The call that failed is specified by errno, where:

System Action:
The CAS Daemon is not shut down
Resolution:
Determine the cause of the error and retry if appropriate
Destination:
standard error
Module:
dfhtxp
Parent topic: CASCD0050 - CASCD0099


CASCS2004E

The systems transaction trans-ID was executed from an invalid terminal type. term-ID is the originating terminal. The most most likely cause of this error is that a user entered this transaction in error.
System Action:
The transaction and conversation is terminated
Resolution:
None
Destination:
User terminal and TDQ CSMT
Module:
dfhzcrsr
Parent topic: CASCS1500 - CASCS2004


CASKC1003I

A request for a license of the referenced type was made to the license server. No license was available. Pleas contact your Micro Focus sales representative
System action:
None
Resolution:
None
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC1000 - CASKC1003


CASRD0016W

The resource type resource-type (resource resource-name, group group-name) is not supported.
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0016 - CASRD0030


CASSP0013S

A rollback, either implied or requested via API has failed and the DB/file resource state is unpredictable.
System action:
The transaction will abend.
Resolution:
Investigate why the rollback failed and restore the database resource managers to a known position.
Destination:
Console and standard error.
Module:
dfhesync
Parent topic: CASSP0001 - CASSP0014


CASST5021I

Shutdown Phase 2 PLT processing was entered, but no list was specified.
System Action:
Shutdown proceeds normally
Resolution:
None
Destination:
console (and terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASKC0029E

A message has been generated processing a service.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
dfheserv
Parent topic: CASKC0016 - CASKC0030


CASCF0020S

An error occurred when creating the region configuration save file (rcf.bin).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


Loops - in COBOL and C#

Loops in Managed COBOL

*> Pre-test loops:
declare c1 as binary-long.
perform until c >= 10
   add 1 to c
end-perform

perform varying c as binary-long from 2 by 2 until c > 10
   display c2
end-perform

*>Post-test loops:
declare c3 as binary-long.
perform with test after until c3 >= 10
   add 1 to c3
end-perform

*> Array or collection looping
01 names string occurs any.
set content of names to ("Rod" "Jane" "Fred")
perform varying s as string through names
   display s
end-perform

*> Breaking out of loops:
01 i1 binary-long value 0.
perform until exit
   if i1 = 5
      exit perform
   end-if
   add 1 to i1
end-perform

*> Continue to next iteration:
declare i2 binary-long value 0
perform varying i2 from 0 by 1 until i2 >= 5
   if i2 < 4
      exit perform cycle
   end-if
   display i2 *>Only prints 4
end-perform

Loops in C#

// Pre-test Loops
// no "until" keyword
int c1;
while (c1 < 10)
{
   c1++;
}

for (int c2 = 2; c2 <= 10; c2 += 2)
{
   Console.WriteLine(c2);
}

// Post-test Loop
int c3;
do
{
  c3++;
} while (c3 < 10);

// Array or collection looping
string[] names = {"Rod", "Jane", "Freddy"};
foreach (string s in names)
{
   Console.WriteLine(s);
}

// Breaking out of loops
int i1 = 0;
while (true)
{
  if (i1 == 5)
  {
      break;
  }
  i1++;
}

// Continue to next iteration
for (int i2 = 0; i2 < 5; i2++)
{
  if (i2 < 4)
  {
    continue;
  }
  Console.WriteLine(i2);   // Only prints 4
}
Related reference
PERFORM Statement


CASCD0168S

The Spool service for region region-name has abended due to the unexpected signal signal-value.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0160 - CASCD0175


JCLUT0007E

Message

NAME, LENGTH or QUANTITY omitted.

Message information

Syntax Error. An IEBDG control statement is missing the NAME, LENGTH or QUANTITY value.

Solution

Correct the syntax and resubmit the job.

Parent topic: JCLUT Error Messages


CASKC0045I

Logging all enable and disable requests for CICS transactions
System action:
none
Resolution:
none
Destination:
CSKL
Module:
dfhesysp
Parent topic: CASKC0031 - CASKC0045


CASCF0033S

An error occurred when opening the development configuration file (dfhtxdev.cfg).
System Action:
Terminate the requesting process
Resolution:
Check the access permissions on the drive/directory/file
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0031 - CASCF0045


CASRD1016 - CASRD1041

  • CASRD1016E
    An unsuccessful request was made to update the named request handler. return-code values
  • CASRD1017E
    An unsuccessful request was made to delete the named request handler. return-code values
  • CASRD1018I
    An unrecognized administration request was made for the named request handler.
  • CASRD1030I
    The package was added successfully.
  • CASRD1031I
    The package was updated successfully.
  • CASRD1032I
    The package was deleted successfully.
  • CASRD1035E
    An unsuccessful request was made to add the named package. return-code values
  • CASRD1036E
    An unsuccessful request was made to update the named package. return-code values
  • CASRD1037E
    An unsuccessful request was made to delete the named package. return-code values
  • CASRD1038I
    An unrecognized administration request was made for the named package.
  • CASRD1039E
    A request to add, update or delete a service failed due to an unrecognised service definition.
  • CASRD1040E
    A request to add, update or delete a request handler failed due to an unrecognised request handler definition.
  • CASRD1041E
    A request to add, update or delete a package failed due to an unrecognised package definition.
Parent topic: CASRD Error Messages


CASCD0156S

The 3270 CCI gateway of region region-name has abended due to receipt of signal signal-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0141 - CASCD0159


CASRD0009I

The resource definition for resource-type entry resource-name from group group-name is installed in the current system.
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzins
Parent topic: CASRD0001 - CASRD0015


CASRD0013W

An attempt was made to delete the resource-type entry resource-namein preparation for re-installing it from group group-name. The delete failed with reason reason-code. Reason codes are return codes from the table manager. Common reasons are:
System action:
Continue
Resolution:
None
Destination:
TD queue CRDI, TS queue CEBR{facility-name}
Module:
dfhzcins
Parent topic: CASRD0001 - CASRD0015


CASCD0028I

If the CAS Console Daemon is not running with the effective user ID of root (UID=0) this message details the current effective user id. The effective user ID that the CAS console Daemon runs as, and all region created, is set at installation time.
System Action:
None
Resolution:
None
Destination:
Console
Module:
dfhmd
Parent topic: CASCD0016 - CASCD0031


CASXO0016S

The XA resource manager's switch module had been previously loaded successfully by another server but failed to intiialize on this process.
System Action:
None
Resolution:
Determine the cause of the failure and restart the system
Destination:
console
Module:
dfhexa
Parent topic: CASXO0016 - CASXO0026


CASCS1113S

The CAS CCI gateway detected a CCI protocol error.
System Action:
The CAS CCI gateway is terminated
Resolution:
Start the net requester service on the workstation
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASRD1032I

The package was deleted successfully.
System action:
None.
Resolution:
None
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


CASFD0008S

The offline dump requester failed to issue the IMS dump request because the parameter to not locked the shared memory was used.
System action:
The dump request is aborted
Resolution:
Correct the parameters and retry the operation.
Destination:
standard error.
Module:
dfhgtrtd
Parent topic: CASFD0001 - CASFD0014


CASCS1111E

The CAS CCI gateway failed to connect to region remote-region.

The reason is reason-code. Reason codes are:

  • 1 Name conflict (the netname references a non-system node)
  • 2 Locate error
  • 3 Auto-install error (The automatic connection install failed)
System Action:
The bind is rejected
Resolution:
None
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASCD0135I

CAS attempted to fork a new process from the CAS Daemon process but the call failed with errno errno
System Action:
Abort the attempt to inform the region manager of a terminated process
Resolution:
Determine and fix cause of failure then retry
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASCF0008F

An unexpected error occurred in system initialization while processing the configuration file.

Some values for RC are:

  • 01 - No region name specified
  • 02 - Bad line in file
  • 03 - File not found
  • 04 - Error creating file
  • 05 - Error opening file
  • 06 - Error reading file
  • 07 - Error writing to file
  • 08 - CASLOCAL invalid
  • 09 - CASDIR invalid
  • 10 - Region files directory invalid
  • 11 - Messaging support module not found
  • 12 - Utilities module not found
  • 13 - File handling module not found
  • 14 - System files directory invalid
  • 15 - Resource definition file directory invalid
  • 16 - Region directory invalid
System Action:
Terminate the requesting process
Resolution:
Determine the cause of the error from the return-code table and re-try
Destination:
standard error
Module:
config-module(dfhcpcfi)
Parent topic: CASCF0001 - CASCF0015


CASST5020I

Shutdown Phase 2 PLT processing has started using the plt-name list.
System Action:
PLT processing proceeds normally
Resolution:
None
Destination:
console (and terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASRD1038I

An unrecognized administration request was made for the named package.
System action:
Reject the request.
Resolution:
Check the product installation.
Destination:
Console
Module:
casasrvc
Parent topic: CASRD1016 - CASRD1041


CASCS1124I

The CAS CCI gateway connection to remote-region is releasing. The action is at the request of the remote system. Active work on sysid sys-id will terminate abnormally. The CCI network protocol in use is CCI-transport.
System action:
The connection sys-id will no longer be available for work.
Resolution:
No user action is required.
Destination:
Console
Module:
casgate
Parent topic: CASCS1116 - CASCS1138


remote_64bit_access

Specifies whether 64-bit file access is permitted for unknown remote file systems.

Syntax:

>>-----set remote_64bit_access=---.-TRUE-.-------------><
                                  +-FALSE+

Parameters:

TRUE | The runtime assumes that any unknown remote file system supports 64-bit file access.
FALSE | The runtime assumes that any unknown remote file system does not support 64-bit file access.

Properties:

Default: | FALSE
IDE equivalent: | None

Comments:

When this tunable is set to FALSE, and 64-bit access is requested, a 181 return code or file status is produced. You request 64-bit access using the access-mode parameter in CBL_CREATE_FILE and CBL_OPEN_FILE, or by setting FILEMAXSIZE=8 in your File Handler configuration file.

Related reference
CBL OPEN FILE
CBL CREATE FILE
FILEMAXSIZE


CASXO0013S

The Resource manager for the XAT resource indicated it had rolled back the transaction.

The return codes are:

  • 100 The resource manager marked the transaction roll-back only for an unspecified reason.
  • 101 A communication failure occurred
  • 102 The resource manager detected a deadlock
  • 103 The resource manager detected a violation of the integrity of its resources
  • 104 The resource manager marked the transaction roll-back only for a reason not in this list.
  • 105 A protocol error occurred in the resource manager
  • 106 The work represented by this transaction took too long
  • 107 The resource manager detected a transient error
System Action:
None
Resolution:
Contact your system administrator for the resource
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


CASCD0053S

The REM has sent no progress messages, its state is not known
System Action:
None
Resolution:
Determine the cause of the error and retry if appropriate
Destination:
standard error
Module:
dfhrem
Parent topic: CASCD0050 - CASCD0099


CASCD1069S

An Animserv process for Server server-name has exited, the value specified on the exit call was exit-value
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


CASKC6002I

A process was looping or hung and exceeded the specified TIME parameter on the JOB or STEP card.
System action:
The process DCA is released and internal recovery is initiated.
Resolution:
Resolve the issue that caused the timeout
Destination:
System Console
Module:
casmgr
Parent topic: CASKC5006 - CASKC6006


CASCS1013E

Outbound transaction routing of transaction trans-id failed because system system-id is not defined.
System Action:
The request is rejected
Resolution:
Add the resource definition for SYSID system-id
Destination:
user terminal and TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASCD1002S

An error occurred locating the target directory for the region work files.
System Action:
The region start request is not processed
Resolution:
Correct the region setup or define the region
Destination:
standard out
Module:
dfhrem
Parent topic: CASCD1001 - CASCD1043


CASCS1006E

Inbound transaction trans-id from system system-id failed with a primary communications return code of comms-primary-RC.
System Action:
The transaction is abnormally terminated
Resolution:
Correct the communications problem indicated by comms-primary-RC
Destination:
TDQ CSMT
Module:
dfhebms (issued in dfheserv)
Parent topic: CASCS1001 - CASCS1018


CASCF0017S

The region configuration save file ($REGIONBASE/$CASREGN/rcf.bin) could not be located.
System Action:
Terminate the requesting process
Resolution:
Make sure that $CASDIR is set correctly and a multi-tasking region is running
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0016 - CASCF0030


CASCD0127I

A server has been started for region region-name, it is the server-number server to be started for that region and will run with a process-id of pid
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASCD0011F

CAS failed to open the system console log file The COBOL file status after failure is RC1,RC2
System Action:
The CAS Daemon is not started
Resolution:
Determine the cause of the error and retry if appropriate
Destination:
standard error
Module:
dfhmd
Parent topic: CASCD0001 - CASCD0015


CASST4111I

Shutdown processing has begun; no PLTSD was specified for PLT processing.
System action:
Shutdown proceeding normally without PLT processing.
Resolution:
None
Destination:
Console
Module:
casrdo11
Parent topic: CASST4000 - CASST4111


JCLAM0160 - JCLAM0179

  • JCLAM0160S job-number job-name Secondary quantity invalid
    The secondary quantity is not a number.
  • JCLAM0161S job-number job-name "name" Dataset not found
    The named data set does not exist.
  • JCLAM0162S job-number job-name Mutually exclusive keywords specified
    Only one of these keywords is permitted.
  • JCLAM0163S job-number job-name The "*" specification must be surrounded by dots
    The * specification must be preceded and followed by a period.
  • JCLAM0164S Left parenthesis missing after "keyword"
  • JCLAM0165S Unrecognizable keyword "keyword"
    You have used a non-existent keyword, or one that is not supported.
  • JCLAM0166S A required keyword must follow "keyword"
    You have failed to use a keyword where it is required.
  • JCLAM0167S Command "%" is not supported
    The command is not implemented.
  • JCLAM0168S Invalid keyword value "value"
    The value is not of the required type or range.
  • JCLAM0169I The "command-name" command is not required. Command ignored
    This command is not needed in the Micro Focus environment.
  • JCLAM0170I Use host compatible form: "extension-name"
    You have used a Micro Focus JCL extension without a preceding %.
  • JCLAM0171S Password is not permitted here "level"
    LEVEL does not allow a password.
  • JCLAM0172S System Error. Insufficient space in vcat for token
    System error. token is a word or other token from the command, showing how far through processing the command the system had got when it ran out of space.
  • JCLAM0173I Excess VOLUME specification "%" ignored
  • JCLAM0174E keyword % in the DATA component is invalid
    You have used a keyword that does not exist, or is not allowed in this context, or is not supported.
  • JCLAM0175E keyword % in the INDEX component is invalid
    You have used a keyword that does not exist, or is not allowed in this context, or is not supported.
  • JCLAM0176I Data set dataset-name indexed
    Informational only.
  • JCLAM0177S Unexpected return-code return-code from CALLRB
    Indicates an internal error detected by CALLRB
  • JCLAM0178S Unexpected status-code status-code from CALLRB
    Indicates an internal error detected by CALLRB
  • JCLAM0179S Unable to obtain access to "dataset-name"
    System cannot obtain access to the specified dataset.
Parent topic: JCLAM Error Messages


CASKC0004W

The region manager requested that a CICS server process be started and received an error response.
System action:
Decrement AMAX.
Resolution:
Try increasing the value of AMAX to ascertain whether the problem is permanent.
Destination:
System Console and standard error.
Module:
dfhgglbl
Parent topic: CASKC0000 - CASKC0015


CASST5231I

The Event Manager Process has terminated.
System Action:
None
Resolution:
None
Destination:
console
Module:
casevmgr
Parent topic: CASST5000 - CASST6002


Generics, Defining - in COBOL and C#

Defining Generics in Managed COBOL

*> Generic class
class-id Point3D using T.

*> With constraints
class-id Point3D using T.
constraints.
   constrain T implements type IComputable.

*> Generic interface
interface-id IComputable using T.
*> Generic method
method-id MakePoint3D static public using T.
procedure division using by value
       x as T y as T z as T
       returning ret as type Point3D[T].

*> With constraints
method-id MakePoint3D static public using T.
constraints.
   constrain T implements type IComputable.
*> Generic value type
valuetype-id container using T Y.
   01 a T public.
   01 b Y public.
end valuetype.

*> With constraints
valuetype-id container using T Y.
constraints.
   constrain T implements type IComputable.

*> Generic iterator, use a parametrised class
class-id a using T.

iterator-id itg static.
01 val binary-long value 1.
procedure division using by value x as T yielding y as T.
    perform until val = 50
        add 1 to val
        set y to x *> Just for example!
        goback
    end-perform
end iterator.

end class.

*> To use, parametrise the class
perform varying thg through type a[string]::itg("Dog")
    display thg
end-perform

Defining Generics in C#

// Generic class
class Point3D<T>

// Generic class with constraints
class Point3D_c<T> where T : IComputable

// Generic interface
interface IComputable<T>

// Generic method
public static Point3D<T> MakePoint3D<T>(T x, T y, T z)
{
    return new Point3D<T>(x, y, z);
}

// Generic method with constraints
public static void MakePoint3D<T>(T x, T y, T z) where T : IComputable
{
    return new Point3D<T>(x, y, z);
}

// Generic value type
struct container<T, Y>
{
    public T a;
    public Y b;
}

// Generic value type with constraints
struct container<T, Y> where T : IComputable

// Generic iterator, use a parameterised class
class a<T>
{
    public static IEnumerable<T> itg(T x)
    {
        int val = 1;
        while (val < 50)
        {
            val++;
            yield return x;
        }
    }
}

// Using generic iterator
foreach (string dog in a<string>.itg("Dog"))
    System.Console.WriteLine(dog);
Related reference
Constraints Paragraph
Generic Using Phrase


CASCD0123E

An attempt was made to start a region (region-name) for which a REM was already running
System Action:
The request is rejected
Resolution:
Retry with a valid region name (if required)
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASCD0132I

The 3270 printer service for region region-namehas successfully completed termination
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASXO0015I

The XA resource manager's switch module was loaded successfully and the xa-open processing called.
System Action:
None
Resolution:
None
Destination:
console
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


CASXO0005S

The Resource manager for the XAT resource returned a non-zero value to the xa_prepare call.

The return codes are:

  • -2 Asynchronous operation already outstanding
  • -3 A resource manager error occurred
  • -4 The XID is not valid
  • -5 Invalid arguments were given
  • -6 Routine invoked in an improper context
  • -7 Resource Manager unavailable
  • -8 the XID already exists
  • -9 Resource Manager doing work outside global transaction
  • The following indicate the transaction is marked as roll-back only
  • 100 The resource manager marked the transaction roll-back
  • only for an unspecified reason.
  • 101 A communication failure occurred
  • 102 The resource manager detected a deadlock
  • 103 The resource manager detected a violation of the integrity
  • of its resources
  • 104 The resource manager marked the transaction roll-back
  • only for a reason not in this list.
  • 105 A protocol error occurred in the resource manager
  • 106 The work represented by this transaction took too long
  • 107 The resource manager detected a transient error
System Action:
The Transaction is abnormally terminated
Resolution:
Check that the Resource Manager is still available
Destination:
terminal
Module:
dfhexa
Parent topic: CASXO0001 - CASXO0015


CASFD0014E

The input Dump/Trace dataset was not generated on the same bitism environment.
System action:
None
Resolution:
Check your current environment.
Destination:
Standard error.
Module:
dfhgdup
Parent topic: CASFD0001 - CASFD0014


CASFD0003S

The offline dump requester failed in its attempt to change to the region's directories.
System action:
The dump request is ignored
Resolution:
Correct the region specification and retry the operation.
Destination:
Console and standard error.
Module:
dfhgtrtd
Parent topic: CASFD0001 - CASFD0014


Choices - in COBOL and C#

Choices in Managed COBOL

*>COBOL has no exact equivalent syntax to x ? y : z

if age < 20
   move "What's up?" to greeting
else
   move "Hello" to greeting
end-if

if x not = 100 and y < 5
   multiply 5 by x
   multiply 2 by y
end-if

*> evaluate is preferred in COBOL rather than if/else if/else
evaluate x
  when > 5
    multiply y by x
  when 5
    add y to x
  when < 10
    subtract y from x
  when other
    divide y into x
end-evaluate

evaluate color   *> can be any type
   when "torquoise"
   when "red"
      add 1 to r
   when "blue"
      add 1 to b
   when "green"
      add 1 to g
   when other
      add 1 to other-color
end-evaluate

Choices in C#

greeting = age < 20 ? "What's up?" : "Hello";

// Good practice is that all consequents are enclosed in {}
// or are on the same line as if.
if (age < 20) greeting = "What's up?";
else
{
   greeting = "Hello";
}

// Multiple statements must be enclosed in {}
if (x != 100 && y < 5)
{
  x *= 5;
  y *= 2;
}

if (x > 5)
{
   x *= y;
}
else if (x == 5)
{
   x += y;
}
else if (x < 10)
{
   x -= y;
}
else
{
   x /= y;
}

// Every case must end with break or goto case
switch (color)                       // Must be integer or string
{
  case "turquoise":
  case "red":
          r++;
          break;
  case "blue":
          b++;
          break;
  case "green":
          g++;
          break;
  default:
          other++;
          break;      // break necessary on default
}

Portions of these examples were produced by Dr. Frank McCown, Harding University Computer Science Dept, and are licensed under a Creative Commons License.

Related reference
IF Statement


CASCD1058S

A JES Printer for Server server-name has abended due to an unexpected signal signal-value.
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1057 - CASCD1069


CASCD0136W

CAS attempted to exec dfhgrtrm, but the call failed with errno errno
System Action:
Terminate the new process and abort the attempt to terminate a region. The region will continue to run.
Resolution:
Determine and fix cause of failure then retry
Destination:
standard error and system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASKC0015E

The system attempted to read an MQ queue record from the queue queue-name. The read opperation failed with reason code reason-code.
System action:
Transaction aborted.
Resolution:
Resolve the configuration mismatch and restart the associated ASEE iniation queue listener.
Destination:
System Console and standard error.
Module:
dfheserv
Parent topic: CASKC0000 - CASKC0015


Arrays - in COBOL and C#

Arrays in Managed COBOL

01 nums binary-long occurs 3 values 1, 2, 3.
*> Can also do:
set content of nums to (1, 2, 3)

*> 5 is the size of the array
01 names string occurs 5.
*> Can also do:
01 names string occurs any.
set size of names to 5
set names(1) to "Rod"  *> first element indexed as 1
set names(6) to "Jane"  *> throws System.IndexOutOfRangeException

*> COBOL cannot resize an array - use copy
01 names2 string occurs 7.
  invoke type Array::Copy(names, names2, names::Length)
*> or:
  invoke names::CopyTo(names2, 0)
*> or:
  invoke type Array::Resize(names, 7)

01 twoD float-short occurs any, any.
  set size of twoD to rows, cols

01 jagged binary-long occurs any, occurs any.
  set size of jagged to 3
  set size of jagged(1) to 5
  set jagged(1 5) to 5

Arrays in C#

int[] nums = {1, 2, 3};
for (int i = 0; i < nums.Length; i++)
{
   Console.WriteLine(nums[i]);
}

// 5 is the size of the array
string[] names = new string[5];
names[0] = "Rod";
names[5] = "Jane";   // Throws System.IndexOutOfRangeException

// C# can't dynamically resize an array.  Just copy into new array.
string[] names2 = new string[7];
// or names.CopyTo(names2, 0);
Array.Copy(names, names2, names.Length);

float[,] twoD = new float[rows, cols];
twoD[2,0] = 4.5f;

int[][] jagged = new int[3][] {
  new int[5], new int[2], new int[3] };
jagged[0][4] = 5;

Portions of these examples were produced by Dr. Frank McCown, Harding University Computer Science Dept, and are licensed under a Creative Commons License.

Related reference
Indexers
SET Statement


Program Structure - in COBOL and C#

Program Structure in Managed COBOL

class-id HelloWorld as "Hello.Helloworld".

method-id main static.
local-storage section.
01 helloString string value "COBOL".
procedure division using by value args as string occurs any.

    if length of args > 0
        set helloString to args(1)
    end-if
    display "Hello, " & helloString & "!"

end method.

end class.

Program Structure in C#

namespace Hello
{
    public class HelloWorld
    {
        public static void Main(string[] args)
        {
            string helloString = "C#";

            if (args.Length > 1)
            {
                helloString = args[0];
            }
            System.Console.WriteLine("Hello, " + helloString + "!");
        }
    }
}
Related reference
Classes


JCLCM0010W SYSOUT Limit limit exceeded by DD name

One of the output limits has been exceeded.

Resolution:

None.

Parent topic: JCLCM0000 - JCLCM0199


CASCD0103E

The CAS Daemon has received a message with an unknown request type of Request-Type
System Action:
The request is ignored
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0100 - CASCD0117


CASCD1038I

An ES Communications Server has been started for ES region-name
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD1001 - CASCD1043


CASCF0051S

An error occurred accessing the region configuration data. Typically this occurs when the region is not currently active.
System Action:
Terminate the requesting process
Resolution:
Make sure the region is active and retry
Destination:
standard error
Module:
config-module(dfhcpcfe)
Parent topic: CASCF0046 - CASCF0063


CASKC5006I

The SEP, Batch Initiator or IMS MPR process issued a message. The text is message.
System action:
Dependant on the message.
Resolution:
Action the message
Destination:
Console
Module:
cascpsrv
Parent topic: CASKC5006 - CASKC6006


CASCS1102E

An error occurred in registering system net-name. This is an internal error indicating a logic error or a module mismatch problem.
System Action:
The system is not registered
Resolution:
Report the problem to Micro Focus
Destination:
console
Module:
dfhtcci
Parent topic: CASCS1100 - CASCS1115


CASCS5010I

The maximum number of sessions supported for Universal Client connections is 127. The value of the region configuration item CAS_UNICLI_SESSIONS exceeds this limit.
System action:
None
Resolution:
None
Destination:
Console
Module:
casgate
Parent topic: CASCS5010 - CASCS5103


CASKC0033I

A security profile Security profile found for Queue Manager Queue Manager Namehas not been found and security for MQSeries has been turned on.
System action:
None.
Resolution:
None
Destination:
System Console
Module:
dfheserv
Parent topic: CASKC0031 - CASKC0045


CASCD0120I

The REM for region region-name has been started. It will run with a process-id of pid
System Action:
None
Resolution:
None
Destination:
system console
Module:
dfhmd
Parent topic: CASCD0120 - CASCD0139


CASST0020I

The shutdown is in progress, use force if the region did not stop in a timely fashion.
System action:
None.
Resolution:
None.
Destination:
Console and stdout
Module:
casstop
Parent topic: CASST0000 - CASST0020


CASRD0046 - CASRD0052

  • CASRD0046E
    The hexadecimal value entered for the transaction had a double quote missing or mismatched.
  • CASRD0047E
    The resource definition for resource-type entry resource-name is not installable. The existing installed definition is in use.
  • CASRD0048E
    The resource definition for resource-type entry resource-name is not installable. The existing installed definition is open.
  • CASRD0049E
    The resource definition for resource-type entry resource-name is not installable. The port port number is already in use.
  • CASRD0050E
    The URIMAP resource-name cannot be installed as it maps to the same HOST and PATH plus optional TCPIPSERVICE as URIMAP2.
  • CASRD0051E
    The DOCTEMPLATE resource-name cannot be installed as it contains the same TEMPLATENAME as DOCTEMPLATE2.
  • CASRD0052E
    The Current Userid Current Userid is not a surrogate of user URIMAP Userid or has not enough power the resource cannot be installed.
Parent topic: CASRD Error Messages


RENAME

Renames a file.
Note: When calling this routine, ensure you are using the 1024 calling convention.

Syntax:

CALL "RENAME" USING old-name new-name [exit-code]

Parameters:

old-name
PIC X(n)
new-name
PIC X(n)
exit-code
PIC S9(4) BINARY

On Entry:

old-name
The source filename.
new-name
The target filename.

On Exit:

exit-code
The exit code of the command upon return from the operating system: zero for success and non-zero for failure.

Comments:

The values for the old-name and new-name parameters may be quoted with double quotes (") or single quotes ('). When the name is quoted, the quotes are removed, but the name is not otherwise modified. If the name is not quoted, the first control character terminates the name on Windows and the first white space character terminates the name on UNIX. On Windows, trailing spaces are removed from unquoted names.

The old- and new-name data item must be less than 1024 characters in length.

Related information
Call Conventions for Interfacing with Mixed Languages


CASST5003S

The specified PLTSD program list table could not be found in the Resource Definition file.
System Action:
PLT Processing is bypassed, shutdown continues
Resolution:
None
Destination:
console (and terminal)
Module:
dfhzplt
Parent topic: CASST5000 - CASST6002


CASST0012W

A forceable region abend was requested via the dfhgrtrm utility. Data may be lost or the system may be left in an unstable state. This option should only be used as a last resort, it is recommended that the region is shutdown cleanly via the /t option.
System action:
The region will be forceably abended.
Resolution:
If a clean shutdown is required use the /t command line option on future invocations.
Destination:
Console and stdout
Module:
dfhgrtrm
Parent topic: CASST0000 - CASST0020


Iterators - in COBOL and C#

Iterators in Managed COBOL

class-id sillyCount.
working-storage section.
01 c binary-long value 1 static.

method-id main static.
01 i binary-long.
procedure division using by value cmds as string occurs any.
    *> Use perform to loop over an iterator
    perform varying i through self::doCount()
        display i
    end-perform
end method.

*> Create an iterator by defining a member as an iterator
*> Using iterator-id instead of method-id
iterator-id doCount static.
    *> The return value if the iterator is defined using the
    *> yielding keyword
procedure division yielding j as binary-long.
    perform until false
        add 1 to c
        move c to j
        *> Until the iterator is stopped, it will yield on
        *> a goback verb
        goback

        *> then start again directly after the goback
        *> on the next invocation of the iterator
        multiply c by 10 giving j
        if c less then 50
            goback
        else
            *> Stop iterator - as it says
            *> Control goes back to the calling routine.
            stop iterator
            goback
       end-if
    end-perform
    *> COBOL will implicitly stop iterator at the
    *> end of the iterator definition.
    *> In this example – the code never gets here.
end iterator.
end class.

Iterators in C#

class SillyCount
{
    static int c = 1;

    static void Main(string[] args)
    {
        // Use foreach to loop through an iterator
        foreach(int i in doCount())
        {
            System.Console.WriteLine(i);
        }
     }

    // C# lacks specific syntax to mark a method as an iterator
    // you have to create a method with the correct concrete form
    // of the IEnumerable interface and then use the yield return
    // syntax inside the method.
    static IEnumerable<int> doCount()
    {
        while (true)
        {
            c++;
            // C# uses an implicit return 'variable' rather than
            // the named one in COBOL. Yield return returns
            // the value as the current value of the iterator
            yield return  c;

            // then starts immediately after the
            // yield return on the next invocation of
          // the iterator
            if (c < 50)
            {
                yield return c * 50;
            }
            else
            {
                // yield break marks the end of the iterator
                yield break;
            }
        }
    }
}
Related reference
Indexers
Iterators


To create a TSQL stored procedure query

  1. In your OpenESQL Assistant Options, set Query > Type Stored Procedure to TSQL.
  2. Start the OpenESQL Assistant.
  3. Connect to a Microsoft SQL Server data source.
  4. Check the box next to a table name.
  5. Click a query type from the list.
  6. Check Generate Query as a TSQL Stored Procedure.
  7. In the SP name field, type a name for the stored procedure. Alternatively, accept the default value.
  8. Click OK.
  9. Continue to build your query.
Note: For detailed information on building a query, see the topic Building Queries.
Related concepts
OpenESQL Assistant
Building Queries
Setting OpenESQL Assistant Options
Stored Procedures
Generating an SQL Stored Procedure Query
OpenESQL Assistant
Building Queries
Stored Procedures
Related tasks
To start the OpenESQL Assistant
To connect to a data source
Related reference
OpenESQL Assistant - Options
Select Type of Query to Create dialog box


Order in which Copybooks Are Searched For

By default, the Compiler looks for copybooks in the same directory as the program using them. If your copybooks are elsewhere, you need to define their location.

You can define the location of your copybooks outside the project directory by specifying the copybook paths in project properties on the Copybook Paths tab, adding them to the project as linked files or folders, or by setting the environment variable COBCPY.

Tip: Linked resources are an Eclipse concept and are supported for COBOL projects, but Micro Focus recommends you use project dependencies where possible, and create projects to contain the resources and define an appropriate dependency between them.

Each COPY statement in your program identifies a copybook to be copied. If the filename in the COPY statement is incomplete, because it lacks either an extension or a path, the Compiler searches for it as follows:

  1. In the directory given by the COPY library-name. Note that if the name of the copybook is a qualified filename, that is, it includes the path or directory, the Compiler searches that directory only.
  2. In the directory containing the main source program being compiled.
  3. In any directories listed in the COBCPY environment variable, in the order specified.

If the COPY statement does not give the extension of the copybook's filename, the Compiler searches for files with extensions given by the directive COPYEXT.


To create and load a binary trace file into the CTF Viewer

  1. Enable CTF tracing.
  2. Configure CTF to generate a binary trace file when the application is run, by adding the following lines to the configuration file ctf.cfg:
    mftrace.dest                     = binfile
mftrace.emitter.binfile#location = <directory in which to write the trace file>
  3. Run the application.
  4. Click File > Open File, and then double-click the trace file you want.

    Alternatively you can create a project containing the trace files.

    1. Create a new project of the General type.
    2. Follow the wizard, and when it asks for the location of your files, specify the directory containing your trace files. We recommend that you specify the trace file location defined in the mftrace.emitter.binfile#location entry in your CTF configuration file.
    3. In the COBOL Explorer view, double-click a trace file to load it into the viewer.
Related concepts
CTF Trace File Formats
Example CTF Configuration Files


To enable your annotation files in the CTF Viewer

  1. Click Window > Preferences > Micro Focus COBOL > Consolidated Trace Facility > Annotation File Locations.

    Initially, the Location field is populated with the location of the trace files. This location is defined in the MFTRACE_ANNOTATIONS environment variable, which is set automatically in the Studio Enterprise Edition command environment from which you start Eclipse.

  2. Set the location to point to where your trace files are. You can add multiple locations and retain or remove the default location.
  3. Set the order of the trace file locations, so that the first location is used if trace files are found there.

The locations are preserved between Eclipse IDE sessions.

Related concepts
CTF Trace File Formats
Example CTF Configuration Files


Bookmarks in the CTF viewer

You can set bookmarks on events in a trace file, when you are using the CTF Viewer. Bookmarks enable you to navigate quickly. Bookmarks behave as follows:

  • You can add a bookmark to an event, by right-clicking the event and clicking Add Bookmark.
  • Bookmarked events are shown in the main CTF View by a blue bookmark icon in column one of the event. They are also displayed in the Bookmarks view.
  • Double-click a bookmark in the Bookmarks view to jump to the bookmarked event in the Viewer. If the bookmarked event is in a file that isn't open, the file is automatically opened.
  • You can select multiple events in the main CTF view and set bookmarks on them all. You can also select multiple bookmarked events and remove their bookmarks.
  • Bookmarks persist between IDE sessions.
Related concepts
CTF Trace File Formats
Example CTF Configuration Files


To search in the CTF Viewer

  1. Right-click in the CTF Viewer.
  2. Click Find.
  3. Enter your search string in the Find field, using the normal search features.
  4. Click Find.
Note:
  • You can use only Find capabilities and not Replace ones, since the trace file is loaded as a read-only file.
  • When you search for a text string, each row in the viewer is treated as a single text string, with each column in a row separated by a single space character. For example, a row with the following information is treated as a single text string for searching purposes:
    12:17:35.630 COBOL Runtime System 504 Library Load 0 0 C:\nx50\Base\BIN\UTILS.lbr
  • You can also use Find from the Edit menu.
  • You can use keys for Find next (Ctrl+K) and Find previous (Shift+Ctrl+K).
Related concepts
CTF Trace File Formats
Example CTF Configuration Files


Creating Debug Files

If you encounter an error when compiling a program that requires you to contact Micro Focus technical support, your support representative might request that you provide additional debug files (as well as source and data files) to help us determine the cause of the problem. If so, they will advise you how to create them.

Parent topic: Contacting Micro Focus


Environment Variables

These are the most common environment variables that can be used with the Micro Focus products.

The following environment variables are set in the system registry. You can change the values using the SET command, but values you set are only added to the values already set in the registry.

CCITCP2 | Specifies the machine that the CCITCP2 daemon is running on.
COBCPY | The location of COBOL copybooks.
COBDATA | Specifies the locations in which to search for data files.
COBDIR | The location of the COBOL system directory.
COBHNF | The location of .hnf files.
COBPATH | Specifies the locations in which to search for .int, .gnt and .lbr files. To specify more than one location, use the ; (semicolon) separator .
LIB | Tells the Linker where to find .lib files.
INCLUDE | Specifies which directories should be searched for such things as resource include files.
PATH | Indicates which directories Windows should search for executable files.

The following environment variables can be set from within your environment using the SET command:

COBCONFIG_ | The location of COBOL configuration files.
COBCONFIG.BLOCK | The location of the application configuration file.
COBFSTATCONV | Specifies name of a user-supplied module that the Callable File Handler should use to convert the file status codes if an I/O error is encountered on a file.
COBIDY | The location of debugger .idy files.
COBLANG | Tells the COBOL system in which language environment you want to run your COBOL program. COBLANG can be used in conjunction with third party products using values of the LANG environment variable which are in a different format than that used by the COBOL system.
COBPRFDIR | Specifies a directory to be used for storing .ipf files created by programs compiled with the PROFILE compiler directive.
COBSW | Used to pass COBOL run-time system and user switch settings to user application programs.
DD_ | Used to identify environment variables that define file-name mappings.
ENTRYNAMEMAP | Specifies entry name map files and folders containing them.
EXTFH | Specifies the File Handler configuration file to use.
FHREDIR | Used to override the default configuration filename a Fileshare V2 client program user.
FSIDXINTEGRITY | When this is set to OFF, this writing to disk any changed nodes held in the index cache, until space in the cache is needed for other nodes.
HELPFILES | The list of files to be loaded at initialization by HyHelp.
LANG | Tells the system in which language environment you want to run your program.
MAINFRAME_FLOATING_POINT | Specifies the floating point format used.
MFCSCFG | Specifies a configuration file to be used by the Client/Server Binding client program. It is also used by the Client/Server Binding server program when the srvtier facility is used.
MFJSERET | Determines the response to an unsuccessful sort, copy or merge operation. Set to ABEND for an unsuccessful operation to abend and its program to continue instead of terminating with an unrecoverable error (return code 16).
MFJSTATS | When this is set to ON, creates a report containing statistics for the SORT that is displayed to SYSOUT. If a report file already exists for a previous SORT, the new statistics are appended to the end of the previous one.
MFEXTMAP | Used by the External File Mapper to locate the file mfextmap.dat.
MFLOGDIR | Specifies a directory to be used by the Client/Server Binding for log files.
OOSW | Used to set run-time switches that effect OO programs.
SORTCOMPRESS | Tells the system whether or not to execute a compression routine on each record to be sorted. SORTCOMPRESS=5 allows for run-length encoding of sort records, resulting in much better performance when records contain multiple repeated characters. Note that 5 is the only valid value for this.
SORTSCHEME | Use in conjunction with SORTSPACE for improved performance. This is activated by setting SORTSCHEME=1. This is the only valid value for the environment variable. See SORTSPACE below for more information.
SORTSPACE The amount of memory to be allocated to internal workspace for SORT operations. This can be specified in different formats: for example, you could specify 64M, 2G, and 1000000 to give sort memory areas of 64 Megabytes, 2 Gigabytes and 1000000 bytes respectively.
Typically, increasing SORTSPACE will improve the overall performance of your SORT. This can be further improved by the use of SORTSCHEME when the files to be sorted are over 1GB. Consider:
  • Setting SORTSCHEME when your files are in excess of 1GB.
  • The size of the record minus the key-size when setting SORTSCHEME on.
  • The SORTSPACE levels for SORTSCHEME. The following are the minimum settings for SORTSCHEME to take effect with the key size:
    • 1Mb or greater - records up to 5k non key
    • 4Mb or greater - records of 12K non key
    • 8Mb or greater - records of 28K non key
    • 16Mb or greater - records of 62k non key
    • For very large SORTs, a greater SORTSPACE maybe required.
  • Setting SORTSPACE to a higher value may result in more temporary file space being used.
SORTTEMPSPACE The amount of temporary memory to be allocated to internal workspace for SORT operations. This can be specified in different formats much like the SORTSPACE environment variable. By using SORTTEMPSPACE, you can maximize available memory.

To maximize the use of available memory to improve performance, particularly in systems suffering from memory fragmentation, the memory allocation strategy used by SORT can be adjusted through use of the SORTTEMPSPACE environment variable. Increasing the amount of SORTTEMPSPACE can help prevent "SORT020U SORT(EXTSM) failed - sort engine status = 9/105" error messages.

SORTTYPE | Setting SORTTYPE=2 forces SORT to use the file handler, so that format modifications are picked up from the extfh.cfg file. Not setting this means SORT will try to use CBL_ routines to read and write files to improve performance. Note that 2 is the only valid value for this environment variable.
TESTCOVER | Enables you to use the test coverage tool, which creates a statistical execution profile of a program. This should be set to the path of the test coverage configuration file.
TMP | Tells the run-time system where to put paging files Normally it puts these files in the current directory. By using TMP you can specify a different drive or path for them.
Related concepts
File Not Found Errors
Related information
To use test coverage from the command line for native COBOL


JCLAM0001I job-number job-name Number of hex digits should be even

There must be an even number of digits in a hexadecimal string. A leading x"0" has been assumed.

Resolution:

Add the missing hexadecimal digit in the appropriate position.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0002S job-number job-name Invalid hex. Digits must be 0 thru 9 or A thru F.

An invalid hexadecimal character has been encountered. The character is not a digit (0 through 9) or a letter A through F.

Resolution:

Correct the offending character(s).

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0003U job-number job-name MISSING SYSIN DD

The jobstream does not contain the required SYSIN DD statement.

Resolution:

Add a SYSIN DD statement to the jobstream to specify the location of your input utility control statements and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0004U job-number job-name MISSING SYSPRINT DD

The jobstream does not contain the required SYSPRINT DD statement.

Resolution:

Add a SYSPRINT DD statement to the jobstream to specify the location where you want messages and other printed output to be written and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0101S job-number job-name OPERAND TOO LONG [OPERAND]

The specified operand is too long.

Resolution:

Correct the operand and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0102S job-number job-name NUMERIC OPERAND REQUIRED [DATA]

Numeric data was expected but the specified non-numeric data was received.

Resolution:

Correct the data and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0103S job-number job-name UNKNOWN PARAMETER [PARAMETER]

The parameter is ignored, the return code is set to 12, and processing continues.

Resolution:

If appropriate, correct the parameter and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0104S job-number job-name EXPECTED CONTINUATION NOT RECEIVED

Continuation from the previous command statement was expected but not received.

Resolution:

Check to make sure the previous record does not have an extraneous continuation character.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0105S job-number job-name INVALID ENTRYNAME FORMAT [ENTRYNAME]

The specified entry name does not conform to the rules for MVS dataset naming.

Resolution:

Correct the entry name and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0106S job-number job-name REQUIRED OPERAND MISSING [OPERAND]

The specified operand was expected but not received.

Resolution:

Include the missing operand and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0107S job-number job-name INVALID COMMAND (PARENS) [COMMAND]

Command statement syntax error.

An opening parenthesis "(" was expected but not received.

Resolution:

Correct the command and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0108S job-number job-name INCOMPLETE COMMAND [COMMAND]

Command statement syntax error.

A closing parenthesis ")" was expected but not received.

Resolution:

Correct the command and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0109S job-number job-name NO ENTRYNAME SPECIFIED

The command requires an entry name.

Resolution:

Correct the command to include an entry name and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0110E job-number job-name ENTRYNAME ALREADY EXISTS [ENTRYNAME]

A DEFINE command has been specified for a dataset which already exists.

Resolution:

If appropriate, delete the dataset and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0111I job-number job-name ENTRYNAME RENAMED TO [ENTRYNAME]

The entryname has been renamed to the specified name.

Resolution:

No action is required.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0112S job-number job-name UNABLE TO CATALOG [ENTRYNAME]

MFJAMS is unable to catalog the specified entry name.

Another user or process might be using the entry name or workstation file.

Resolution:

Try the operation again when the entry name or workstation file is available for exclusive use.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0113I job-number job-name ENTRYNAME DEFINED [ENTRYNAME]

The specified entry name has been defined and cataloged. The appropriate workstation files have been created.
Parent topic: JCLAM0000 - JCLAM0119


JCLAM0114I job-number job-name ENTRYNAME DELETED [ENTRYNAME]

The specified entry name has been deleted and removed from the catalog. The appropriate workstation files have been deleted.
Parent topic: JCLAM0000 - JCLAM0119


JCLAM0115E 00000000000000job-numberjob-name ENTRYNAME NOT CATALOGED [ENTRYNAME]

The specified entry name does not exist.

Resolution:

Correct the entry name or determine why it does not exist.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0117S job-number job-name TOO MANY ENTRYNAMES SPECIFIED

The DELETE command is limited to 99 entry names.

Resolution:

If you have provided a list of entry names, break the DELETE command into more than one command. If you have specified a generic entry name, specify a more restrictive generic entry name that does not result in more than 99 datasets.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0118S job-number job-name PARAMETER NOT SUPPORTED [PARAMETER]

The parameter is not supported by MFJAMS or is invalid for the type of dataset being defined.

This error occurs if you try to use unsupported features such as LSDS datasets, or if you try to define keys for an RRDS dataset.

Resolution:

Correct the parameter and try again.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0119S job-number job-name MODELNAME NOT CATALOGED [ENTRYNAME]

The specified entry name used as a model name does not exist.

The model name must exist in order to borrow characteristics from the model.

Resolution:

Correct the entry name or determine why it does not exist.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0120S job-number job-name UNKNOWN COMMAND [COMMAND]

The specified command is not known to MFJAMS.

Processing continues, however future commands might be affected by this error.

Resolution:

If appropriate, correct the command and try again.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0121E job-number job-name GDG IS NOT EMPTY [GDGNAME]

A DELETE command has been attempted for a generation data group which still contains cataloged entries.

Resolution:

Delete the cataloged GDG entries and try again, or specify the FORCE parameter to instruct MFJAMS to delete all GDG entries in addition to the GDG model.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0122I job-number job-name HOST ENTRY RETAINED [ENTRYNAME]

The specified entryname, which resides on the host, has been retained (not deleted).

Resolution:

No action is required.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0123S job-number job-name GDG LIMIT MISSING OR ZERO

An attempt to define a new GDG must specify the number of entries to maintain before automatic deletion.

Resolution

Specify the number of entries and try again.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0134I job-number job-namenumber Records processed

The specified number of records have been processed.

Resolution

No action is required.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0135I job-number job-namenumber Datasets listed

The specified number of data sets have been listed by the LISTCAT command.

Resolution:

No action is required.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0136W job-number job-name PARM IGNORED FOR SEQ DATASETS [PARAMETER]

The specified parameter is invalid for sequential datasets.

For example, you must not specify a FROMKEY for a sequential dataset.

Resolution

If appropriate, correct the parameter and try again.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0137I job-number job-name DATASET VERIFIED [DATASETNAME]

The specified dataset has been verified. The dataset was opened and closed successfully.

If the open failed, the index portion of the VSAM dataset has been recreated. The dataset is available for use.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0138I job-number job-name DATASET VERIFIED(LOCKED) [DATASETNAME]

The specified dataset has been verified even though the dataset is currently locked by another process.

The verify operation assumes that if another process has the dataset locked it is in satisfactory condition and can be successfully opened.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0139S job-number job-name DATASET MUST BE VSAM [DATASETNAME]

The dataset name specified in the VERIFY command is not a VSAM dataset. Only VSAM datasets can be verified.

Resolution

If appropriate, correct the dataset name and try again.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0140I job-number job-name LASTCC set to number

The condition code LASTCC has been set to the specified value.

Resolution:

No action is required.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0141I job-number job-name MAXCC set to number

The condition code MAXCC has been set to the specified value.

Resolution:

No action is required.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0142S job-number job-name AVERAGE RECORD LENGTH INVALID

The average record length must be greater than 0 bytes but not greater than 32760 bytes.

Resolution:

Correct the average record length and try again.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0143S job-number job-name MAXIMUM RECORD LENGTH INVALID

The maximum record length must be greater than 0 bytes but not greater than 32760 bytes.

Resolution:

Correct the maximum record length and try again.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0144S job-number job-name KEY LENGTH INVALID

The primary key length must be greater than 0 but not greater than 64.

Resolution:

Correct the primary key length and try again.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0145S job-number job-name KEY OFFSET INVALID

The key offset plus the key length exceeds the defined record length.

Resolution:

Correct the key offset and/or key length and try again.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0146E job-number job-nameNUMBER DUPLICATE KEYS

The specified number of duplicate keyed records have NOT been replaced by the REPRO command.

Resolution:

No action is required.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0147W job-number job-name 00000000 DATASETS LISTED

No datasets have been listed by the LISTCAT command.

Resolution:

No action is required.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0148E job-number job-name NO MATCHING ENTRIES [ENTRYNAME]

There are no entries in the catalog which match the pattern entry name specified for the delete request.

Resolution:

No action is required.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0151S job-number job-name Invalid dataclass name "name"

The specified data class name is not legal or is longer than 8 characters.

Resolution:

Correct the name and retry.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0152S job-number job-name Dataclass "name" does not exist

This specified data class has not been defined to this system.

Resolution:

Correct the name and retry, or define the data class with the specified name.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0153S job-number job-name UNEXPECTED MVSSMS FUNC_GU RETCODE [number]

Unexpected return code received from the MVSSMS (the data class manager).

Resolution:

Contact Micro Focus Support.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0154S job-number job-name THEN MUST FOLLOW AN IF COMMAND

The IF command must be followed by the THEN keyword.

Resolution:

Correct the command and retry.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0155I job-number job-name Remainder of command stream ignored

The remainder of the command stream has been ignored.

This is for one of the following reasons:

  • The CANCEL command has been executed
  • MAXCC has been set to 16

Resolution:

No action is required.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0156I job-number job-name CANCEL COMMAND EXECUTED

The CANCEL command has been executed.

Resolution:

No action is required.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0157S job-number job-name Space (CYL or TRK or REC) missing

Space, using one of the specified keywords, must be specified for a new data set.

Resolution:

Specify space parameters as appropriate and re-run.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0158S job-number job-name RECORG for input and output data set incompatible

Either the output file is RRDS and is not empty, or the input file is not RRDS.

Resolution:

Correct and re-run.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0159S job-number job-name Primary quantity invalid

The primary quantity is not a number.

Resolution:

Correct and re-run.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0160S job-number job-name Secondary quantity invalid

The secondary quantity is not a number.

Resolution:

Correct and re-run.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0161S job-number job-name "name" Dataset not found

The named data set does not exist.

Resolution:

Correct and re-run.

Parent topic: JCLAM0160 - JCLAM0179


JCLCM0163U job-number job-name MVSJOBNO ERROR ASSIGNING JOBNUM

An internal error has been detected while attempting to assign a job number. The return-code from MVSJOBNO.DLL is non-zero.

Resolution:

Contact SupportLine.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0170I job-number job-name JCL SCANNED - NO ERRORS

The job submitted contains no syntax errors.
Parent topic: JCLCM0000 - JCLCM0199


JCLCM0171E job-number job-name JCL SCANNED - JCL ERROR

The job submitted contains syntax errors which are detailed in other messages.

Resolution:

Use the job log in the spool view to resolve the JCL syntax errors.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0172E job-number job-name JOB FAILED - JCL ERROR

The job submitted contains a JCL syntax error.

Resolution:

Consult the JCL listing for the more details of the error.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0173I job-number job-name MFJUSCAN SCANNER EXIT - NO ERRORS

The JCL scanner user exit module MFJUSCAN was called and ended with a zero return code.
Parent topic: JCLCM0000 - JCLCM0199


JCLCM0174E job-number job-name MFJUSCAN SCANNER EXIT - JCL ERROR

The JCL scanner user exit module MFJUSCAN was called and ended with a non-zero return code.

Resolution:

Consult the JCL listing for additional information on the JCL errors detected by the user written MFJUSCAN user exit module.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0175S job-number job-name MFJUSCAN SCANNER EXIT - I/O ERROR ON FILENAME

An I/O error has occurred while attempting to process the user error file returned to the JCL scanner.

Resolution:

Ensure that the filename being returned by the user written MFJUSCAN user exit module is correct. Verify that the file has been properly formatted and that the file has been closed.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0181S job-number job-name JOB ABENDED - ERRORCODE

The job has ended abnormally with the specified return code.

Resolution:

Consult the JCL spool file listing for the exact reason for the failure.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0182I job-number job-name JOB ENDED - RC(RETURNCODE)

The job has ended normally with the specified return code.
Parent topic: JCLCM0000 - JCLCM0199


JCLCM0185U job-number job-name Job flushed upon User Exit request.

The user exit has requested that the job be flushed.
Parent topic: JCLCM0000 - JCLCM0199


JCLCM0187I job-number job-name JOB SUBMITTED JOBNAME

The specified job contains a valid job name, a job number has been assigned, and syntax checking of the JCL has started.
Parent topic: JCLCM0000 - JCLCM0199


JCLCM0188I job-number job-name JOB STARTED.

Execution of the submitted job has started.
Parent topic: JCLCM0000 - JCLCM0199


JCLCM0189I job-number job-name STEP BYPASSED STEPNAME.PROCSTEPNAME

Execution of the specified job step has been bypassed due to a prior abend or because of return codes.
Parent topic: JCLCM0000 - JCLCM0199


JCLCM0190I job-number job-name STEP STARTED STEPNAME.PROCSTEPNAME

Execution of the specified job step has started.
Parent topic: JCLCM0000 - JCLCM0199


JCLCM0191I job-number job-name STEP ENDED STEP1 - COND CODE CONDITION-CODE

Execution of the job step has completed normally with the specified return code.
Parent topic: JCLCM0000 - JCLCM0199


JCLCM0192S job-number job-name STEP ABENDED STEP01 - COND CODE ABEND-CODE

Execution of the job step has completed abnormally with the specified user abend, system abend, or run time error.

Resolution:

Correct the cause of the abnormal termination.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0193U job-number job-name PROGRAM NOT FOUND - PROGRAMNAME

The specified program cannot be located.

Resolution:

Correct the program name and/or correct your STEPLIB specifications to reflect the correct location of the program.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0194S job-number job-name DCB MODEL NOT FOUND - DDNAME

The specified DD statement references a DCB model data set which cannot be located.

Resolution:

Remove the reference to the DCB model on the DD statement or ensure that it exists as a valid entry in the catalog.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0195S job-number job-name DATASET IS NOT A GDG - DDNAME

The specified DD statement refers to a GDG data set with a bias (+1) or (-1), but no GDG model by the same name exists in the catalog.

Resolution:

Define the GDG model or correct the data set name on the DD statement to ensure that it refers to a valid data set name.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0197S job-number job-name DISP=MOD, DSN INCOMPATIBLE - DDNAME

The specified DD statement specifies DISP=MOD, which is incompatible with the organization of the data set name specified.

Resolution:

Correct the JCL error and resubmit the jobstream.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0200S job-number job-name DISP=NEW, DATASET EXISTS - DDNAME

The specified DD statement specifies DISP=NEW but the data set name specified already exists in the catalog.

Resolution:

Correct the JCL error and resubmit the jobstream.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0201S job-number job-name DATASET IS NOT A PDS - DDNAME

The specified DD statement refers to a PDS member but no PDS model by the same name exists in the catalog.

Resolution:

Define the PDS model or correct the data set name on the DD statement to ensure that it refers to a valid dataset name.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0202S job-number job-name DISP=OLD/SHR, DATASET NOT FOUND - DDNAME

The specified DD statement specifies DISP=OLD or DISP=SHR but the data set name specified does not exist in the catalog.

Resolution:

Correct the JCL error and resubmit the jobstream.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0402E job-number job-name MISSING EXECUTE STATEMENT

JCL error. At least one EXEC statement is required in the jobstream.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0403E job-number job-name TOO MANY PROCEDURES REFERENCED

JCL error. The job submitted has exceeded the maximum number of cataloged procedures that this system can load.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0404E job-number job-name MISSING PEND STATEMENT

JCL error. A PEND statement is required to end the instream procedure begun by a previous PROC statement.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0405E job-number job-name RECURSIVE, ILLEGAL NESTING, OR LIMIT EXCEEDED

JCL error. A procedure has attempted to execute another procedure. Nested procedures are not permitted.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0406E job-number job-name PROCEDURE NOT FOUND

JCL error. The procedure name specified cannot be located.

Resolution:

Check the procedure name and correct. Check the procedure libraries to be sure the specified procedure actually exists in the libraries accessible to the JCL scanner.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0407E job-number job-name INVALID LABEL

JCL error. The label on a JCL statement is invalid - for example, it exceeds eight characters.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0409E job-number job-name INVALID OPERATOR

JCL error. The JCL operator (EXEC, DD, etc.) contained on the statement is unknown.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0410E job-number job-name INVALID CONTINUATION

JCL error. The JCL statement contains an invalid continuation or the expected continuation was not received.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0411E job-number job-name OPERAND TOO LONG

JCL error. The JCL operand exceeds the length allowed for the JCL parameter.

For example, program names cannot exceed eight characters.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0412E job-number job-name NON-NUMERIC DATA DETECTED

JCL error. Non-numeric data has been found in an operand that is required to be numeric.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0413E job-number job-name DUPLICATE JOB

JCL error. More than one JOB statement has been detected.

Resolution:

Resubmit the JCL with only one job per jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0414E job-number job-name INVALID OR UNKNOWN OR UNEXPECTED OPERAND

JCL error. The operand received is not recognized.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0415E job-number job-name INVALID ADDRSPC OPERAND

JCL error. The ADDRSPC operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0416I job-number job-name INVALID JOBCLASS OPERAND IGNORED

JCL error. The JOBCLASS operand is improperly coded and has been ignored.

Resolution:

If necessary, correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0417I job-number job-name INVALID MSGCLASS OPERAND IGNORED

JCL error. The MSGCLASS operand on the JOB statement is improperly coded and has been ignored.

An appropriate default value will be used for jobstream execution.

Resolution:

If necessary, correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0418E job-number job-name INVALID MSGLEVEL OPERAND

JCL error. The MSGLEVEL operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0419E job-number job-name INVALID PERFORM OPERAND

JCL error. The PERFORM operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0420E job-number job-name INVALID PRTY OPERAND

JCL error. The PRTY operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0421E job-number job-name INVALID RD OPERAND

JCL error. The RD operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0422I job-number job-name INVALID REGION OPERAND IGNORED

JCL error. The REGION operand on the JOB or EXEC statement is improperly coded and has been ignored.

Resolution:

If necessary, correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0423E job-number job-name INVALID STEP NAME

JCL error. The job step name is invalid.

Resolution:

Make sure the name does not exceed eight characters. Make sure the name refers to a valid job step.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0424E job-number job-name INVALID PROCSTEP NAME

JCL error. The procedure step name is invalid.

Resolution

Make sure the name qualifiers do not each exceed eight characters. Make sure that specification of a procedure step name is valid where used.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0425E job-number job-name INVALID TIME OPERAND

JCL error. The TIME operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0426E job-number job-name INVALID TYPRUN OPERAND

JCL error. The TYPRUN operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0427E job-number job-name CONDITION STATEMENT IMPROPERLY FORMED

JCL error. The COND operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0428E job-number job-name INVALID CONDITION CODE

JCL error. The condition code is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0439E job-number job-name INVALID LABEL REFERENCE

JCL error. The label reference on a JCL statement is invalid.

Resolution:

Make sure the label reference is specified correctly, including stepname or procstepname as applicable.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0440E job-number job-name SYMBOL NOT FOUND

JCL error. The symbolic parameter cannot be found on the PROC or EXEC statement.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0441E job-number job-name UNKNOWN PROCSTEP NAME

JCL error. The procedure step name referenced has not been defined by a previous EXEC statement.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0442E job-number job-name INVALID OVERRIDE

JCL error. The override is invalid.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0443E job-number job-name INVALID POSITIONAL OPERAND

JCL error. The positional operand was not expected.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0444E job-number job-name INVALID DATASET NAME

JCL error. The data set name is invalid.

Resolution:

Check the data set name to make sure it follows the MVS data set naming rules.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0445E job-number job-name INVALID REFER BACK

JCL error. The refer back is invalid.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0446E job-number job-name DCBMODEL NAME NOT FOUND

JCL error. The model name specified in the DCB parameter cannot be found in the catalog.

Resolution:

You must catalog model names in the catalog with model DCB characteristics.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0447E job-number job-name INVALID DDNAME

JCL error. The DD name is invalid.

Resolution:

Make sure the DD name is no longer than eight characters.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0448E job-number job-name INVALID DDNAME REFERENCE

JCL error. The DD name deferral is invalid.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0449E job-number job-name MISMATCHED PARENTHESES

JCL error. An expected parenthesis was not received.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0450E job-number job-name REFERENCED DD DOES NOT REFER TO A PDS MEMBER

A reference such as PGM=*.step.pste.ddname refers to a DD name that does not reference a PDS member.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0453E job-number job-name UNKNOWN RESTART STEP NAME

JCL error. The step name specified in the RESTART operand of the JOB statement cannot be resolved.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0454E job-number job-name INVALID ABEND CODE

JCL error. The abend code in an IF statement or in the COND operand of the JOB or EXEC statement is specified incorrectly.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0455E job-number job-name INVALID BLKSIZE OPERAND

JCL error. The BLKSIZE operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0456I job-number job-name BLKSIZE NOT A MULTIPLE OF LRECL

JCL error. BLKSIZE must be a multiple of LRECL when both are coded and when RECFM=fixed is specified or implied.

The error has been ignored, but the associated data set may be unusable.

Resolution:

If necessary, correct the error and resubmit the job.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0457E job-number job-name INVALID EXPDT VALUE

JCL error. The value specified for EXPDT is improperly coded or is not within the acceptable range.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0458W job-number job-name INVALID FREE VALUE – DEFAULT OF (END) SUBSTITUTED

JCL error. The value specified for FREE is improperly coded or is not within the acceptable range.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0459E job-number job-name INVALID UCS VALUE

JCL error. The value specified for UCS is improperly coded or is not within the acceptable range.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0460E job-number job-name INVALID RECORG VALUE

JCL error. The value specified for RECORG must be KS, ES, or RR.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0461E job-number job-name INVALID DLM VALUE

JCL error. The value specified for DLM is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0462E job-number job-name INVALID AVGREC VALUE

JCL error. The value specified for AVGREC is improperly coded or is not within the acceptable range.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0463E job-number job-name TOO MANY LIBRARIES SPECIFIED

JCL error. More than 15 libraries were specified on the JCLLIB statement.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0464E job-number job-name INCLUDE NOT FOUND

JCL error. The data set specified in the INCLUDE statement was not found.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0465E job-number job-name DUPLICATE INSTREAM PROCEDURE

JCL error. The instream procedure name is a duplicate of one already used.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0499S job-number job-name FILE I/O ERROR OR FILE IS EMPTY

There was an I/O error trying to read the referenced cataloged procedure or JCL included file, or the file is empty.

Resolution:

Verify that the correlated PC file exists, that it is not empty, and that the attributes specified in the system catalog match the physical characteristics of the file.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0900E job-number job-name User Exit shut down due to a failure

A failure in the user exit has forced the JCL engine to shut down the user exit.

The user exit will not be notified of any future events for this job.

Resolution:

Correct the problems in the user exit and re-run.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0901I job-number job-name Event-job-ready action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0902I job-number job-name Event-job-flushed action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0903I job-number job-name Event-job-started action is: explanation

The user exit has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0904I job-number job-name Event-job-JCL-error action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0905I job-number job-name Event-job-ended action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0906I job-number job-name Event-TSO-started action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0907I job-number job-name Event-TSO-ended action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0908I job-number job-name Event-step-ready action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0909I job-number job-name Event-step-started action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0910I job-number job-name Event-step-ended action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0911I job-number job-name Event-step-bypassed action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0912I job-number job-name Event-CALL-ready action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0913I job-number job-name Event-CALL-started action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0914I job-number job-name Event-CALL-ended action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0915I job-number job-name Event-RUN-ready action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0916I job-number job-name Event-RUN-started action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0917I job-number job-name Event-RUN-ended action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0918I job-number job-name Event-before-PGM-call action is: explanation

The user exit has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLCM0919I job-number job-name Event-after-PGM-call action is: explanation

The user exist has requested this action to be taken for this event.

Resolution:

No action is required.

Parent topic: JCLCM0900 - JCLCM0999


JCLGN0001U job-number job-name MISSING SYSUT1

The DD statement for SYSUT1 is missing from your JCL.

Resolution:

Include a DD statement for SYSUT1 and try again.

Parent topic: JCLGN Error Messages


JCLGN0002U job-number job-name INVALID SYSUT1

The dataset organization for SYSUT1 is invalid.

Only sequential datasets and members of a PDS dataset can be specified on the SYSUT1DD statement.

Resolution:

Correct the DD statement for SYSUT1 and try again.

Parent topic: JCLGN Error Messages


JCLGN0003U job-number job-name MISSING SYSUT2

The DD statement for SYSUT2 is missing from your JCL.

Resolution:

Include a DD statement for SYSUT2 and try again.

Parent topic: JCLGN Error Messages


JCLGN0004U job-number job-name INVALID SYSUT2

The dataset organization for SYSUT2 is invalid. Only sequential datasets and members of a PDS dataset can be specified on the SYSUT2DD statement.

Resolution:

Correct the DD statement for SYSUT2 and try again.

Parent topic: JCLGN Error Messages


JCLGN0005U job-number job-name I/O ERROR ON SYSUT1

An error has occurred when accessing the dataset specified by the SYSUT1DD statement.

Resolution:

Verify that DCB characteristics specified on the SYSUT1DD statement, if any, and the DCB characteristics in the system catalog for the data set name specified on the SYSUT1DD statement are correct.

Parent topic: JCLGN Error Messages


SORT014U job-number job-name STATUS = FILE STATUS

The specified file status values indicate the cause of the I/O error reported in message SORT013U.

Resolution:

File I/O errors are often caused by defining improper values for record formats. For example, you might have defined a line sequential data set (LSEQ) as a record sequential data set.

Parent topic: SORT000 - SORT099
Related information
SORT013U job-number job-name I/O ERROR ON DATASET 'DATASET'


SORT015U job-number job-name COMMAND STATEMENT ERROR(S) DETECTED

Errors have been detected during SYSIN command statement processing.

Resolution:

Correct the errors and try again.

Parent topic: SORT000 - SORT099


SORT016I job-number job-name SORTTEMP DATASET ALLOCATED TO 'FILE'

The temporary sort work file has been allocated to the specified file. The temporary file name is obtained from the operating system and appended with a $WK file name extension.

Temporary work files are allocated to the path name specified in the MFJSORTW environment variable. If MFJSORTW is not specified, the temporary files are allocated to the directory specified in the TEMP environment variable, and to the current drive and directory when neither is specified.

The temporary file name format is hhmmssss.$WK, where hhmmssss is the system time of file allocation.

Parent topic: SORT000 - SORT099


SORT019I job-number job-name KEY LENGTH TRUNCATED TO 4096 BYTES

The concatenated key length exceeds 4096 bytes. Processing continues, however the sort/merge operation uses only the first 4096 bytes of the key field(s) specified.

Resolution:

Check the key field(s) specified for the sort/merge operation.

Parent topic: SORT000 - SORT099


SORT020U job-number job-name SORT(EXTSM) FAILED – SORT ENGINE STATUS = EXTSM STATUS

The size of the files which can be sorted or merged by MFJSORT(EXTSM) is determined by the record length, number of sort fields, sort field lengths, the amount of memory available, and the amount of disk space available for virtual paging.

Resolution:

Make additional real or virtual memory available, or reduce the file size or the number and length of sort/merge fields, and retry the sort/merge operation. Contact SupportLine if the problem persists.

Parent topic: SORT000 - SORT099


SORT033I job-number job-namenumber RECORDS MERGED

This message indicates the number of records actually written to the SORTOUT output data set by the MERGE function.
Parent topic: SORT000 - SORT099


SORT034I job-number job-namenumber RECORDS COPIED

This message indicates the number of records actually written to the SORTOUT output data set by the COPY function.
Parent topic: SORT000 - SORT099


SORT035U job-number job-name SORTIN DSORG OR RECFM MISSING

The record format for the SORTIN data set is missing.

Resolution:

Correct the catalog entry for the SORTIN data set to include the record format (RECFM).

Parent topic: SORT000 - SORT099


SORT036U job-number job-name SORTIN RECORD LENGTH MISSING OR INVALID

The record length for the SORTIN data set is missing.

Resolution:

Correct the catalog entry for the SORTIN data set to include the logical record length (LRECL).

Parent topic: SORT000 - SORT099


SORT037U job-number job-name SYSIN RECFM 'FORMAT'' INVALID

The record format for the SYSIN data set is invalid.

Resolution:

Correct the catalog entry for the SYSIN data set to include a valid record format (RECFM).

Parent topic: SORT000 - SORT099


SORT038U job-number job-name SORTIN RECFM 'FORMAT' INVALID

The record format for the SORTIN data set is invalid.

Resolution:

Correct the catalog entry for the SORTIN data set to include a valid record format (RECFM).

Parent topic: SORT000 - SORT099


SORT039U job-number job-name SORTOUT RECFM 'FORMAT' INVALID

The record format for the SORTOUT data set is invalid.

Resolution:

Correct the catalog entry for the SORTOUT data set to include a valid record format (RECFM).

Parent topic: SORT000 - SORT099


SORT040U job-number job-name SORT TERMINATED BY E15 'PROGRAM'

The user E15 exit has requested termination of the sort/merge operation.
Parent topic: SORT000 - SORT099


SORT041U job-number job-name SORT TERMINATED BY E35 'PROGRAM'

The user E35 exit has requested termination of the sort/merge operation.
Parent topic: SORT000 - SORT099


SORT042U job-number job-name MEMORY ALLOCATION FAILURE

The system has run out of memory during the sort process.

Resolution:

Close down some other active programs and try again.

Parent topic: SORT000 - SORT099


SORT043U job-number job-name TOO MANY OUTFIL FILES SPECIFIED

The limit of 16 OUTFIL files has been exceeded.

Resolution:

Reduce the number of OUTFIL files.

Parent topic: SORT000 - SORT099


SORT044U job-number job-name TOO MANY 'USE' FILES SPECIFIED

The limit of 16 USE files has been exceeded (non-emulation mode).

Resolution:

Reduce the number of USE files.

Parent topic: SORT000 - SORT099


SORT045U job-number job-name TOO MANY 'GIVE' FILES SPECIFIED

The limit of 16 GIVE files has been exceeded (non-emulation mode).

Resolution:

Reduce the number of GIVE files.

Parent topic: SORT000 - SORT099


SORT090U job-number job-name SORT TERMINATED - MISSING SYSOUT

The DD statement for the SYSOUT data set cannot be located.

Resolution:

Specify a SYSOUT DD statement and try again.

Parent topic: SORT000 - SORT099


SORT091U job-number job-name SORT TERMINATED - MISSING SYSIN

The DD statement for the SYSIN data set cannot be located.

Resolution:

Specify a SYSIN DD statement and try again.

Parent topic: SORT000 - SORT099


SORT092U job-number job-name SORT TERMINATED - MISSING SORTOUT

The DD statement for the SORTOUT data set cannot be located.

Resolution:

Specify a SORTOUT DD statement and try again.

Parent topic: SORT000 - SORT099


SORT093U job-number job-name SORT TERMINATED - MISSING SORTIN OR SORTIN01

The DD statement for a SORTIN or SORTIN01 data set cannot be located.

Resolution:

Specify a SORTIN or SORTIN01 DD statement and try again.

Parent topic: SORT000 - SORT099


SORT094U job-number job-name SORT TERMINATED - MISSING SORTOFnn

The DD statement for a SORTOF data set referenced by the OUTFIL control statement cannot be located.

Resolution:

Specify a SORTOFnn DD statement and try again.

Parent topic: SORT000 - SORT099


SORT095U job-number job-name SORT TERMINATED – BAD DATA IN 'CHANGE' FIELD

Input data did not match any of the CHANGE find-constants and the NOMATCH option was not specified.

Resolution:

Change the sort request, using the NOMATCH option to specify the action to be taken when input data does not match any of the CHANGE find-constants.

Parent topic: SORT000 - SORT099


SORT096U job-number job-name SORT TERMINATED – MISSING FNAMES DATASET 'DATASET'

The DD statement for the FNAMES data set cannot be located.

Resolution:

Specify a DD statement and try again.

Parent topic: SORT000 - SORT099


SORT110E job-number job-name NON-NUMERIC DATA DETECTED

Numeric data is expected at the specified column.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT111E job-number job-name 'OPERATOR' OPERATOR ALREADY PROCESSED

The specified operator (at the specified column) has already been processed.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT112E job-number job-name 'EXIT'' EXIT NOT SUPPORTED

The specified exit (at the specified column) is not supported. Only the E15 and E35 exits are supported by MFJSORT.

Resolution:

Check the exit name. You might have misspelled it.

Parent topic: SORT100 - SORT199


SORT114E job-number job-name EXPECTED '(' NOT FOUND

A left parenthesis is expected at the specified column but has not been found.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT115E job-number job-name BOOLEAN OPERATOR 'OPERATOR' INVALID

The specified Boolean operator (at the specified column) is invalid. Valid Boolean operators are EQ, NE, LT, LE, GT, and GE.

Resolution:

Correct the Boolean operator and try again.

Parent topic: SORT100 - SORT199


SORT118E job-number job-name SORT / MERGE CONFLICT

Both SORT and MERGE commands have been found; only one can be specified. The second command is at the specified column.

Resolution:

Correct the command statements and try again.

Parent topic: SORT100 - SORT199


SORT119E job-number job-name INCLUDE / OMIT CONFLICT

Both INCLUDE and OMIT commands have been found; only one can be specified. The second command is at the specified column.

Resolution:

Correct the command statements and try again.

Parent topic: SORT100 - SORT199


SORT120E job-number job-name SORT STATEMENT MISSING FIELDS OPERAND

The SORT command statement does not contain a FIELDS operand.

Resolution:

Correct the SORT statement and try again.

Parent topic: SORT100 - SORT199


SORT121E job-number job-name MERGE STATEMENT MISSING FIELDS OPERAND

The MERGE command statement does not contain a FIELDS operand.

Resolution:

Correct the MERGE statement and try again.

Parent topic: SORT100 - SORT199


SORT122E job-number job-name INCLUDE STATEMENT MISSING COND OPERAND

The INCLUDE command statement does not contain a COND operand.

Resolution:

Correct the INCLUDE statement and try again.

Parent topic: SORT100 - SORT199


SORT123E job-number job-name OMIT STATEMENT MISSING COND OPERAND

The OMIT command statement does not contain a COND operand.

Resolution:

Correct the OMIT statement and try again.

Parent topic: SORT100 - SORT199


SORT124E job-number job-name FIELD POSITION 'NUMBER' INVALID

The specified field position is invalid. Field positions can start at 1 but must not exceed the length of the SORTIN record, allowing for the length of the control field.

Resolution:

Correct the field position and try again.

Parent topic: SORT100 - SORT199


SORT125E job-number job-name FIELD LENGTH 'NUMBER' INVALID

The field length specified is too long. Control fields are limited to 1024 bytes in length. Byte(.bit) notation is not supported.

Resolution:

Correct the field length and try again.

Parent topic: SORT100 - SORT199


SORT126E job-number job-name RECORD LENGTH 'NUMBER'' INVALID

The specified record length is invalid. Record lengths may not exceed 32768 bytes.

Resolution:

Correct the record length and try again.

Parent topic: SORT100 - SORT199


SORT127E job-number job-name MISSING SORT/MERGE/COPY COMMAND STATEMENT

A SORT, MERGE, or COPY command statement is required.

Resolution:

Include a SORT, MERGE, or COPY command statement and try again.

Parent topic: SORT100 - SORT199


SORT128E job-number job-title EXPECTED ')' NOT FOUND

A closing parenthesis ')' was expected and not found.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT129E job-number job-name EXPECTED '=' NOT FOUND

'=' was expected and not found.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT130E job-number job-name EXPECTED 'F' OR 'V' NOT FOUND

Either F or V must be specified to indicate recording mode (non-emulation mode).

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT131E job-number job-name EXPECTED 'IX', 'RL', 'SQ', OR 'LS' NOT FOUND

Organization must be specified as either IX, RL, SQ or LS (non-emulation mode).

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT132E job-number job-name PRIME KEY MUST BE SPECIFIED FIRST

When specifying keys for a USE OR GIVE indexed file (non-emulation mode), the prime key must be specified first.

Resolution:

Reorder the key definitions so that the prime key is first and try again.

Parent topic: SORT100 - SORT199


SORT133E job-number job-name EXPECTED 'P', 'AD', 'A', OR 'C' NOT FOUND

Key type for a USE OR GIVE indexed file must be specified as one of P (primary), AD (alternate permitting duplicates) A (alternate not permitting duplicates) or C (component).

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT134E job-number job-name KEYWORD/VALUE 'VALUE' INVALID FOR DFSORT EMULATION

The specified keyword is not valid for DFSORT emulation.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT135E job-number job-name KEYWORD/VALUE 'VALUE' INVALID FOR SYNCSORT EMULATION

The specified keyword is not valid for SYNCSORT emulation.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT136E job-number job-name NO GIVE FILE SPECIFIED FOR OUTFIL GROUP

No GIVE file has been specified for the current OUTFIL group (non-emulation mode).

Resolution:

Specify a GIVE file for the group and try again.

Parent topic: SORT100 - SORT199


SORT137E job-number job-name NO USE FILE SPECIFIED

No USE file has been specified for the SORT (non-emulation mode).

Resolution:

Specify a USE file and try again.

Parent topic: SORT100 - SORT199


SORT138E job-number job-name TARGET LITERAL 'LITERAL' TOO LONG IN CHANGE

The set-constant in a CHANGE statement must not be longer than the specified length of the output field to be inserted (v).

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT197E job-number job-name INREC / MERGE CONFLICT

The INREC command (at the specified column) cannot be used with MERGE operations.

Resolution:

Substitute a SORT command instead of MERGE and try again.

Parent topic: SORT100 - SORT199


SORT198E job-number job-name NON-NUMERIC DATA DETECTED IN 'ZD' SUM FIELD

Non-numeric data has been found in a field specified as zoned decimal.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT199E job-number job-name TOO MANY OUTFIL STMTS OR TOO MANY FIELDS ON OUTFIL STMT(S)

More than 16 SORTOFnn files are specified by the OUTFIL command(s).

Resolution:

Reduce the number of SORTOFnn files and try again.

Parent topic: SORT100 - SORT199


SORT205I: job-number job-name INPUT file 'ddname'

Informational message showing the name of the input file for the SORT operation just performed.
Parent topic: SORT200 - SORT399
Related information
MFJSORT Summary Messages


SORT206I: job-number job-name OUTPUT file 'ddname'

Informational message showing the name of the output file for the SORT operation just performed.
Parent topic: SORT200 - SORT399
Related information
MFJSORT Summary Messages


SORT207I: job-number job-name OUTFIL file 'ddname '

Informational message showing the name of the output file for the SORT operation just performed.
Parent topic: SORT200 - SORT399
Related information
MFJSORT Summary Messages


SORT301E: job-number job-name Position/Length bit specification ' byte.bit' must be >= 0 and <= 7.

The bit portion of the byte.bit position or length specification must be between 0 and 7.

Resolution:

Correct the error and re-run.

Parent topic: SORT200 - SORT399


SORT399I: job-number job-name End of Micro Focus MFJSORT Utility.

Informational message indicating the end of the SORT process.
Parent topic: SORT200 - SORT399
Related information
MFJSORT Summary Messages


JCLCM0199I job-number job-name Program program-name is cobol-dialectchar-setbyte-orderamode-type

The program program-name, which is being executed, has the stated characteristics.
cobol-dialect
One of:
  • COBOL ANS85
  • COBOL VSC2
  • COBOL OSVS
  • Z/OS HLASM
  • non-COBOL
char-set
One of:
  • ASCII
  • EBCDIC
byte-order
One of:
  • Big-Endian
  • Little-Endian
amode-type
One of:
  • AMODE31
  • AMODE24
  • NOAMODE
Parent topic: JCLCM0000 - JCLCM0199


JCLCM0164A job-number job-name All job numbers in the range lower-job-number:upper-job-number are in use.

The system has used up all available job numbers and cannot process this job.

The job has been rejected. The range in effect is indicated by lower-job-number and upper-job-number.

Resolution:

The administrator should purge jobs and spool files that are no longer needed. Until more job numbers become available, all future job submissions will be rejected with this message.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0180I job-number job-name Job ready for execution.

The job named is ready for execution.
Parent topic: JCLCM0000 - JCLCM0199


JCLAM0116S UNEXPECTED RETURN CODE FROM MVSCATIO [return-code]

An internal error has been detected by MVSCATIO.

Resolution:

Note the return code and contact Micro Focus Support.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0149S INVALID QUOTED LITERAL

The literal contains an uneven number of quotation marks.

Resolution:

Make sure any quotation marks within the literal are doubled. For example, This is Jane''s book (two consecutive single quotation marks). If the literal is continued onto a second line make sure the first line has a terminating literal.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0150S ERROR. FILE IS EMPTY

You are trying to copy from an empty file.

Resolution:

Make sure the sending file is not empty.

Parent topic: JCLAM0140 - JCLAM 0159


JCLAM0164S Left parenthesis missing after "keyword"

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0165S Unrecognizable keyword "keyword"

You have used a non-existent keyword, or one that is not supported.

Resolution:

Check your syntax and spelling.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0166S A required keyword must follow "keyword"

You have failed to use a keyword where it is required.

Resolution:

Check your syntax and spelling.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0167S Command "%" is not supported

The command is not implemented.
Parent topic: JCLAM0160 - JCLAM0179


JCLAM0168S Invalid keyword value "value"

The value is not of the required type or range.
Parent topic: JCLAM0160 - JCLAM0179


JCLAM0169I The "command-name" command is not required. Command ignored

This command is not needed in the Micro Focus environment.

The job should function the same without the command.

Resolution:

Remove the command if you wish, or leave it there for mainframe compatibility.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0170I Use host compatible form: "extension-name"

You have used a Micro Focus JCL extension without a preceding %.

This works in the Micro Focus environment but is not mainframe compatible.

Resolution:

We recommend replacing PCDSN with %PCDSN for mainframe compatibility.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0171S Password is not permitted here "level"

LEVEL does not allow a password.
Parent topic: JCLAM0160 - JCLAM0179


JCLAM0000I job-number job-name Interactive AMS Terminated

The MFJAMS utility has terminated.

This does not imply an error. It could occur, for example, if a debugging session is canceled while the utility is in use.

Resolution

No action is required.

Parent topic: JCLAM0000 - JCLAM0119


JCLAM0179S Unable to obtain access to "dataset-name"

System cannot obtain access to the specified dataset.

It is probably being used by another job or user with exclusive access.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0180S Unexpected return code return-code from jseb-func-enq-ds

Indicates an internal error detected by jseb-func-enq-ds.

Resolution:

Note the return code and contact SupportLine.

Parent topic: JCLAM0180 - JCLAM0230


JCLAM0181S Unexpected return code % from jseb-func-deq-ds

Indicates an internal error detected by jseb-func-deq-ds.

Resolution:

Note the return code and contact SupportLine.

Parent topic: JCLAM0180 - JCLAM0230


JCLAM0182U Unexpected return code % from jseb-func-info-job

Indicates an internal error detected by jseb-func-info-job.

Resolution:

Note the return code and contact SupportLine.

Parent topic: JCLAM0180 - JCLAM0230


JCLAM0183S Character set mismatch. Copied without conversion

You are trying to copy an ASCII dataset to an EBCDIC one, or vice versa.
Parent topic: JCLAM0180 - JCLAM0230


JCLAM0184I OS Copy used to perform this REPRO

Informational only.

Resolution:

No action is required.

Parent topic: JCLAM0180 - JCLAM0230


JCLAM0185S OS Copy operation for this REPRO failed with RC=return-code

Parent topic: JCLAM0180 - JCLAM0230


JCLAM0186I Incompatible data set attributes. OSCOPY ignored.

A full copy operation was done, instead of using the copy facility provided by the operating system as you requested.

Resolution:

No action is required.

Parent topic: JCLAM0180 - JCLAM0230


JCLAM0228I Record n out of key sequence.

The record has a key that is less than or equal to the key of the previous record.

Resolution:

No action is required.

Parent topic: JCLAM0180 - JCLAM0230


JCLAM0229E Record n out of key sequence.

The record has a key that is less than or equal to the key of the previous record.

Resolution:

Correct the order of the records so that the keys are sequential, and re-run.

Parent topic: JCLAM0180 - JCLAM0230


JCLCM0169I JCL copied

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0196S Resource allocation failed for dd-name<[concat dd seq no]>. Reason=nnn

This is usually preceded by another JCLCM message providing additional information.

The meanings of the reason codes are as follows:

  • 001 - invalid mvs dataset name
  • 002 - invalid recfm and dsorg combination
  • 003 - invalid recfm, lrecl and dsorg combination
  • 004 - invalid lrecl
  • 005 - no gdg model present
  • 006 - gdg max < 1 or > 99
  • 007 - gdg roll disp is incorrect
  • 008 - charset is not ascii, ebcdic or unknown
Parent topic: JCLCM0000 - JCLCM0199


JCLCM0198I VSE CONFIG FILE - outcome : config-file

Tells you the outcome of your attempt to load an optional VSE JCL configuration file (specified by the VSE_STARTUP_CFG environment variable).

outcome can be LOADED (indicating that the configuration file was read sucessfully), NOT SPECIFIED (no configuration file was specified), or UNAVAILABLE (the specified configuration file could not be read).

Resolution:

No action is required if the outcome is as you expected. Otherwise, make sure the file is specified and available.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0203S ACI option has overridden step abend S422

You have requested the Automatic Catalog Input option, and therefore an S422 abend has been ignored.

Resolution:

Investigate the abend. One possible cause is that a data set used by the step does not exist on the host.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0214S Required resources could not be obtained

All the required datasets for this job are unavailable. Probably some other job or user is using them.

Resolution:

Try again later.

Parent topic: JCLCM0200 - JCLCM0299


JCLAM0124I job-number job-name GDG LIMIT CHANGED TO 31

You have requested more than the maximum number of GDG entries allowed.

Resolution

Reduce the number of entries requested to 31 or fewer and try again. The minimum number is 1.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0125S job-number job-name RELATENAME NOT CATALOGED [ENTRYNAME]

The dataset specified by RELATENAME must exist before an alternate index can be defined.

The dataset is not cataloged.

Resolution:

Correct the dataset name or define the dataset and try the operation again.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0126S job-number job-name FILE MISSING OR INVALID TYPE [FILENAME]

The specified workstation file cannot be located.

Resolution:

Make sure the VSAM file is complete and try the operation again.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0127I job-number job-name ALTERNATE INDEX DEFINED [ENTRYNAME]

The alternate index has been defined. The appropriate workstation file has been updated to reflect the new index keys.
Parent topic: JCLAM0120 - JCLAM0139


JCLAM0128I job-number job-nameNUMBER RECORDS INDEXED

The keys for the specified number of records have been added for the newly-defined alternate index.
Parent topic: JCLAM0120 - JCLAM0139


JCLAM0129S job-number job-name INVALID PRIMARY KEY OR RECORDSIZE

The key position plus the key length exceeds the defined record length.

Resolution:

Correct the record length or key position and try again.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0130S job-number job-name DD MISSING [DDNAME]

A DD statement for the specified DD name is not defined in your JCL.

Resolution:

Add the necessary statement for the DD name or correct the DD name specified in the INFILE or OUTFILE parameter and try again.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0131S job-number job-name INSUFFICIENT DCB [DATASETNAME]

The specified dataset does not have complete data control block characteristics.

Resolution:

Provide the required DCB parameters in your JCL or update the catalog to include all of the DCB parameters. A valid RECFM and LRECL is required.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0132S job-number job-name I/O ERROR [DATASETNAME]

Resolution

See message JCLAM0133S for information on the I/O operation that caused the error.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0133S job-number job-name I/O STATUS [FILE STATUS]

Resolution:

File I/O errors are generally caused by defining incorrect values for record formats. For example, defining a line sequential dataset (LSEQ) as a record sequential dataset. Correct the values and retry the operation.

Parent topic: JCLAM0120 - JCLAM0139


JCLAM0162S job-number job-name Mutually exclusive keywords specified

Only one of these keywords is permitted.

Resolution:

Specify only the desired keyword and re-run.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0163S job-number job-name The "*" specification must be surrounded by dots

The * specification must be preceded and followed by a period.

For example, MFIDSA.PAYROLL.* is invalid since it is not followed by a period.

Resolution:

Correct and re-run.

Parent topic: JCLAM0160 - JCLAM0179


JCLCM0000I job-number job-name JCL PROCESSOR TERMINATED

The JCL processor has terminated. This does not imply an error. It could occur, for example, if a debugging session is cancelled while a jobstream is being processed.

Resolution:

No action is required.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0001U job-number job-name I/O ERROR ON SYSTEM CATALOG FILE

Configuration error.

Resolution:

If running under the IDE, contact SupportLine. If running from a Micro Focus command prompt, correct the setting for the MFSYSCAT environment variable.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0147U job-number job-name NO DATASET NAME SPECIFIED

The function requested requires a data set name to be specified.

Resolution:

Ensure that a data set name has been specified and try again. Contact SupportLine if the problem persists.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0158U job-number job-name MVS data set "name" not found

The specified MVS data set is not in the catalog.

Resolution:

Add the data set to the catalog and re-run.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0159U job-number job-name FILE OPEN ERROR FILENAME

There was an open error on the main source file submitted to the JCL scanner for processing.

Resolution

Verify that the file exists, that it is not empty, and that it has been correlated properly in the system catalog if it is not a line sequential file.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0160U job-number job-name FILE I/O ERROR FILENAME

There was an I/O error on the main source file submitted to the JCL scanner for processing.

Resolution:

Verify that the file exists, that it is not empty, and that it has been correlated properly in the system catalog if it is not a line sequential file.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0161U job-number job-name DATASET TYPE INVALID DATASETNAME

The specified data set is of a type that cannot be used for the requested function.

For example, you cannot submit a GDG or PDS model name as a JCL jobstream because the contents of the data set are not recognized as JCL.

Resolution:

Verify that the data set name is correct and that the correct DCB attributes have been specified in the system catalog.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0162U job-number job-name FILE IS EMPTY FILENAME

The specified file is empty. The function you have attempted cannot be performed on an empty data set or file.

Resolution:

Verify whether the data set is empty and that the correct DCB attributes have been specified in the system catalog.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0205I job-number job-namePROGRAM FUNC=func/functext RC=rcode/rcodetext

The specified program has detected an unexpected return code from the MVS Job Step Resource Manager (MJRM). Details of the function and return code are provided in the message.

Resolution:

Contact SupportLine.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0206I job-number job-name ALLOCATION DEFERRED UNTIL OPEN - DDNAME

In the specified DD statement, the first (or only) data set specified does not exist and the step being executed is an IMS batch step.

Allocation of any data sets for the DD statement is deferred until data set open time to prevent generation of JCL errors for DD statements which may be associated with IMS databases, as they are not required by the IMS component.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0207I job-number job-name DUPLICATE DD STATEMENT IGNORED - DDNAME

The specified DD statement is a duplicate of a DD statement defined earlier in the job step.

Resolution:

Delete the duplicate DD statement to avoid this message in future.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0208I job-number job-name Host OS may require SPACE for DD "DD-name"

The host operating system (MVS, OS/390, z/OS) might require that you specify the SPACE parameter unless the data set is allocated to a device such a tape device.

Resolution:

Change the JCL to run on the host if appropriate.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0209S job-number job-name DISP=NEW, UNCATALOGED DUPLICATE EXISTS - DDNAME

The specified DD statement specifies DISP=NEW but the data set name specified already exists in the catalog (in an uncataloged state).

Resolution:

This condition can arise when DISP=(NEW,KEEP) or DISP=(,UNCATLG) is specified or implied. Select the Catalog View, check the Show uncataloged datasets check box, and review the entries listed. Delete the duplicate data set entry in the catalog, or correct the disposition or data set name in the JCL as appropriate.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0210U job-number job-name I/O ERROR ON SPOOL FILE

An I/O error has occurred while accessing the spool file containing JOB output.

Resolution:

Contact SupportLine.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0211S job-number job-name Dataclass "name" does not exist

This specified data class has not been defined to this system.

Resolution:

Correct the name and retry, or define the data class with this name.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0212S job-number job-name REFDD dataclass "name" does not exist

This specified data class has not been defined to this system.

Resolution:

Correct the name and retry, or define the data class with this name.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0213S job-number job-name Main pgm name did not issue GOBACK or STOP RUN

The specified main COBOL program fell through to the end of the program without executing a GOBACK or a STOP RUN statement.

Resolution:

Correct as appropriate and re-run.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0401U job-number job-name MISSING JOB STATEMENT

JCL error. A JOB statement is required in the jobstream.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0429E job-number job-name INVALID CONDITION OPERATOR

JCL error. The condition operator is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0430E job-number job-name INVALID PROGRAM NAME

The program name is improperly coded.

Specify a program name of 1 to 8 alphanumeric or national characters in the PROGRAM field. The first character must be alphabetic or national.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0431E job-number job-name INVALID DYNAMNBR OPERAND

JCL error. The DYNAMNBR operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0432E job-number job-name INVALID BURST OPERAND

JCL error. The BURST operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0433E job-number job-name INVALID CHKPT OPERAND

JCL error. The CHKPT operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0434E job-number job-name INVALID RECFM OPERAND

JCL error. The RECFM operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0435E job-number job-name INVALID LRECL OPERAND

JCL error. The LRECL operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0436E job-number job-name INVALID DISP OPERAND

JCL error. The DISP operand is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0437E job-number job-name UNEXPECTED STATEMENT

JCL error. The JCL statement received was not expected.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0438E job-number job-name PROCSTEP NOT FOUND

JCL error. The procedure step name referenced cannot be located.

Resolution:

Make sure the name refers to a valid procedure step.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0466U job-number job-name INVALID JOBNAME

JCL error. The job name specified is invalid.

Resolution:

Check the job name to make sure it follows the MVS naming rules.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0467E job-number job-name CONFLICTING OR INCOMPATIBLE OPERANDS

JCL error. Conflicting operands have been included on the JCL statement.

For example, you cannot specify DCB= and LIKE= and REFDD= all on the same DD statement.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0468E job-number job-name INVALID DSORG VALUE

JCL error. The value specified for DSORG is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0469I job-number job-name NONUNIQUE REFERENCE RESOLVED TO FIRST OCCURRENCE

JCL error. This message indicates that there are multiple job steps with the same name as the referenced stepname.

The JCL processor has assumed that the use of that stepname refers to the first job step which has that stepname.

Resolution:

Check that the default action is appropriate.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0470I job-number job-name NONUNIQUE REFERENCE RESOLVED TO CURRENT OCCURRENCE

JCL error. This message indicates that there are multiple job steps with the same name as the referenced stepname.

The JCL processor has assumed that the use of that stepname refers to the current job step which has that stepname.

Resolution:

Check that the default action is appropriate.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0471E job-number job-name OPERAND TABLE LIMIT EXCEEDED

JCL error. The limit on the number of operands supported has been exceeded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0472E job-number job-name SYMBOL TABLE LIMIT EXCEEDED

JCL error. The limit on the number of symbols supported has been exceeded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0473E job-number job-name INVALID NULL OPERAND VALUE

JCL error. A keyword operand with no value was specified, but a value is required.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0474E job-number job-name INVALID SYSOUT CLASS OPERAND

JCL error. The SYSOUT class operand on the DD statement is improperly coded.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0476E job-number job-name Symbol "name" was not used

The specified symbol is not used anywhere in the procedure. One explanation is that the symbol is misspelled.

Resolution:

Correct the error and resubmit the jobstream.

Parent topic: JCLCM0400 - JCLCM0499


JCLGN0006U job-number job-name I/O ERROR ON SYSUT2

An error has occurred when accessing the dataset specified by the SYSUT2DD statement.

Resolution:

Verify that DCB characteristics specified on the SYSUT2DD statement, if any, and the DCB characteristics in the system catalog for the data set name specified on the SYSUT2DD statement are correct.

Parent topic: JCLGN Error Messages


JCLIM0001U job-number job-name INVALID EXEC STATEMENT PARM

MFJIMS expects parameter data on the EXEC statement, but the data has not been supplied.

Resolution:

Specify the parameter data and try again. The format of the PARM operand is:
PARM = ' type , programname , psbname '
Parent topic: JCLIM Error Messages


JCLIM0002U job-number job-name INVALID PROGRAM TYPE PARM

The program type specified in the PARM operand must be BMP (or IFP) or DLI (or DBB).

Resolution:

Correct the program type in the PARM operand of the EXEC statement and try again.

Parent topic: JCLIM Error Messages


JCLIM0003U job-number job-name MISSING PROGRAM NAME PARM

The program name has not been specified in the PARM operand.

Resolution:

Specify a program name in the PARM operand of the EXEC statement and try again.

Parent topic: JCLIM Error Messages


JCLIM0004U job-number job-name MFIMS OPTION NOT INSTALLED

MFJRRC00 is unable to locate the MFIMS software option.

Resolution:

If necessary, install the MFIMS component. If it is already installed, contact SupportLine.

Parent topic: JCLIM Error Messages


SORT009U job-number job-name SORT TERMINATED - ERROR ACCESSING MFJSORTM.DAT

The message file cannot be found or it cannot be opened.

Another process might have the file open for exclusive use.

Resolution:

Retry the sort/merge operation.

Parent topic: SORT000 - SORT099


SORT012U job-number job-name SYSIN DATASET 'DATASET' EMPTY

MFJSORT has found the specified SYSIN data set to be empty. Processing is terminated.

Resolution:

Make certain that the SYSIN data set or instream SYSIN contains data.

Parent topic: SORT000 - SORT099


SORT013U job-number job-name I/O ERROR ON DATASET 'DATASET'

An I/O error has occurred on the specified data set.

Resolution:

See message SORT014U, which identifies the specific status code encountered.

Parent topic: SORT000 - SORT099
Related information
SORT014Ujob-number job-name STATUS=FILE STATUS


SORT100E job-number job-name MISSING OPERATOR

The SYSIN command statement does not contain a valid operator.

Resolution:

Correct the SYSIN command statement to include a valid operator.

Parent topic: SORT100 - SORT199


SORT101E job-number job-name MALFORMED OPERATOR

The SYSIN command statement operator (at the specified column) is invalid. A space must separate the operator from any operands.

Resolution:

Correct the SYSIN command statement to include a space after the operator.

Parent topic: SORT100 - SORT199


SORT102E job-number job-name EXPECTED OPERAND MISSING

A required operand is not present on the command statement.

Resolution:

Correct the command statement.

Parent topic: SORT100 - SORT199


SORT103E job-number job-name INVALID OPERATOR 'OPERATOR'

The command statement operator (at the specified column) is invalid.

Resolution:

Correct the command statement operator.

Parent topic: SORT100 - SORT199


SORT104E job-number job-name INVALID OPERAND KEYWORD 'OPERAND'

The command statement operand (at the specified column) is invalid.

Resolution:

Correct the command statement operand.

Parent topic: SORT100 - SORT199


SORT105E job-number job-name EXPECTED CONTINUATION NOT PRESENT

The command statement contains a continuation character in column 72, but the continuation text has not been found.

Resolution:

Check the command statement(s).

Parent topic: SORT100 - SORT199


SORT106E job-number job-name FIELD FORMATS IMPROPERLY SPECIFIED

The field format is incorrectly coded as a field-specific operand (for example, FIELDS=1,5,CH,A) and also as a global operand (for example, FORMAT=CH).

Resolution:

Specify the field format in one location only and try again.

Parent topic: SORT100 - SORT199


SORT107E job-number job-name FIELD FORMAT 'FORMAT' INVALID

The specified field format (at the specified column) is invalid. Valid field formats are AQ, BI, CH, FI, ZD, and PD.

Resolution:

Correct the field format and try again.

Parent topic: SORT100 - SORT199


SORT108E job-number job-name SEQUENCE 'SEQUENCE' INVALID

The sequence operand (at the specified column) must be A or D for ascending or descending sequences respectively.

Resolution:

Correct the sequence operand and try again.

Parent topic: SORT100 - SORT199


SORT109E job-number job-name TOO MANY FIELDS SPECIFIED

Control fields are limited to 16.

Resolution:

Reduce the number of control fields and try again.

Parent topic: SORT100 - SORT199


SORT139E job-number job-name SUBSTRING COMPARISON MUST BE WITH CHARACTER LITERAL

The right-hand side of a substring comparison must be a character literal.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT140E job-number job-name INVALID BINARY DIGIT DETECTED

An invalid digit has been found in a binary literal. Valid digits are 0 and 1.

Resolution:

Correct the binary literal and try again.

Parent topic: SORT100 - SORT199


SORT141E job-number job-name CANNOT SPECIFY SAVE WITH EITHER INCLUDE OR OMIT

Only one of INCLUDE, OMIT or SAVE may be specified for any OUTFIL group.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT142E job-number job-name REPEATED FILES= OR FNAMES=

Only one of FILES= or FNAMES= may be specified for any OUTFIL group.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT191I job-number job-name OPERATOR 'OPERATOR' IGNORED

The specified operator (at the specified column) is not supported and has been ignored. Processing continues without error.
Parent topic: SORT100 - SORT199


SORT192I job-number job-name OPERAND 'OPERAND' IGNORED

The specified operand (at the specified column) is not supported and has been ignored. Processing continues without error.
Parent topic: SORT100 - SORT199


SORT193E job-number job-name INVALID HEX DIGIT DETECTED

An hexadecimal digit (0 - 9 or A - F) is expected at the specified column but has not been found.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


SORT194I job-number job-name NO ALTSEQ COMMAND SPECIFIED FOR 'AQ' SORT FIELD FORMATS; 'CH' ASSUMED

A SORT control field requests an alternate collating sequence but no ALTSEQ command statement is specified. The standard collating sequence has been used instead. Processing continues without error.
Parent topic: SORT100 - SORT199


SORT195I job-number job-name SORTWORK DIRECTORY 'DIRECTORY' IS INVALID; USING CURRENT DIRECTORY

The MFJWORK or TEMP environment variable does not contain a valid device or directory path. The current directory has been used for temporary files instead. Processing continues without error.
Parent topic: SORT100 - SORT199


SORT196E job-number job-name SUM / COPY CONFLICT

The SUM command (at the specified column) cannot be used when the FIELDS=COPY statement is in effect.

Resolution:

Correct the command statement and try again.

Parent topic: SORT100 - SORT199


JCLUT0001E job-number job-name Control statement error explanation

Message

Control statement error "%1$s"

Where the parameter "%1$s" is a syntax hint.

Message information

Syntax Error. There is an error in the syntax of the control statement. The message will also contain a hint of the problem.

Resolution

Correct the syntax and resubmit the job.

Parent topic: JCLUT Error Messages


JCLUT0005E job-number job-name Continuation error

Message

Continuation error.

Message information

Syntax error.

Resolution

Correct the syntax and resubmit the job.

Parent topic: JCLUT Error Messages


JCLAM0172S System Error. Insufficient space in vcat for token

System error. token is a word or other token from the command, showing how far through processing the command the system had got when it ran out of space.

Resolution:

Contact SupportLine.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0173I Excess VOLUME specification "%" ignored

Resolution:

No action is required.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0174E keyword % in the DATA component is invalid

You have used a keyword that does not exist, or is not allowed in this context, or is not supported.

Resolution:

Check your syntax and spelling.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0175E keyword % in the INDEX component is invalid

You have used a keyword that does not exist, or is not allowed in this context, or is not supported.

Resolution:

Check your syntax and spelling.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0176I Data set dataset-name indexed

Informational only.

Resolution:

No action is required.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0177S Unexpected return-code return-code from CALLRB

Indicates an internal error detected by CALLRB

Resolution:

Note the return code and contact SupportLine.

Parent topic: JCLAM0160 - JCLAM0179


JCLAM0178S Unexpected status-code status-code from CALLRB

Indicates an internal error detected by CALLRB

Resolution:

Note the status code and contact SupportLine.

Parent topic: JCLAM0160 - JCLAM0179


JCLCM0216S Insufficient storage available to process the job

Either you have defined more data sets than the system can handle, or there is an internal error.

Resolution:

Contact SupportLine.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0217S Internal system error "internal code"

Internal error.

Resolution:

Contact SupportLine. Please mention the internal code.

Parent topic: JCLCM0200 - JCLCM0299


JCLCM0408I UNKNOWN OUTPUT STMT OPERAND IGNORED

You have used an unknown keyword.
Parent topic: JCLCM0400 - JCLCM0499


JCLCM0475I DD CHANGED TO DUMMY (DDNAME= MISSING)

You have referenced a file for which there is no DDNAME statement.

Resolution:

Add the required DDNAME statement to the JCL.

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0477S More than 255 EXEC statements

Parent topic: JCLCM0400 - JCLCM0499


JCLCM0500E SPACE parameter "value" is invalid or misplaced

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0501E UNIT parameter "value" is invalid or misplaced

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0502E VOLUME parameter "value" is invalid or misplaced

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0503E Invalid USER parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0504E TYPEXEC parameter "value" is invalid

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0505E DSNTYPE parameter "value" is invalid

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0506E account parameter or its length in error

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0507E programmer parameter or its length in error

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0508E Invalid ACCODE parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0509E Invalid CCSID parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0510E Invalid BYTES parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0511E Invalid CARDS parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0512E Invalid GROUP parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0513E Invalid LINES parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0514E Invalid NOTIFY parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0515E Invalid PAGES parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0516E Invalid PASSWORD parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0517E PARM parameter or its length in error

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0518E Invalid RESTART parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0519E Invalid SECLABEL parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0520E Invalid UPLOAD parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0521E Invalid DOWNLOAD parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0522E Invalid MEMBER parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0523E Invalid PCDSN parameter

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0524E COPIES parameter "value" has invalid value or syntax

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0525E Excess COPIES specification "value" rejected

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0526E FCB parameter "value" has invalid value

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0527E FLASH parameter "value" has invalid value

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0528E HOLD parameter "value" has invalid value

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0529E PRTSP parameter "value" has invalid value

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0530E SPIN parameter "value" has invalid value

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0531E TRTCH parameter "value" is invalid

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0532E "value" parameter is invalid

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0533E "value" parameter has invalid value

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0599I Excess VOLUME specification "value" ignored

Parent topic: JCLCM0500 - JCLCM0599


JCLCM0801I Event-job-concluded. Job ended normally

Parent topic: JCLCM0800 - JCLCM0899


JCLCM0802I Event-job-concluded. Job ended abnormally

Parent topic: JCLCM0800 - JCLCM0899


JCLCM0803I Event-job-concluded. Job failed - JCL error

Parent topic: JCLCM0800 - JCLCM0899


JCLCM0804I Event-job-concluded. Job scanned - No Errors

Parent topic: JCLCM0800 - JCLCM0899


JCLCM0805I Event-job-concluded. Job scanned - JCL error

Parent topic: JCLCM0800 - JCLCM0899


JCLCM0806I Event-job-concluded. Job flushed - No JOB stmt

Parent topic: JCLCM0800 - JCLCM0899


JCLCM0807I Event-job-concluded. Job flushed - Bad JOB stmt

Parent topic: JCLCM0800 - JCLCM0899


JCLCM0808I Event-job-concluded. Job flushed by User Exit req

Parent topic: JCLCM0800 - JCLCM0899


JCLCM0809I Event-job-concluded. Job copied

Parent topic: JCLCM0800 - JCLCM0899


JCLCM0810I Event-job-concluded. Job cancelled

Parent topic: JCLCM0800 - JCLCM0899


JCLCM0811I Event-job-concluded. Job authentication failed

Parent topic: JCLCM0800 - JCLCM0899


JCLGN0007U MISSING SYSPRINT

Parent topic: JCLGN Error Messages


JCLGN0008U INVALID SYSPRINT

Parent topic: JCLGN Error Messages


JCLGN0009U MISSING SYSIN

Parent topic: JCLGN Error Messages


JCLGN0010U INVALID SYSIN

Parent topic: JCLGN Error Messages


JCLGN0011U I/O ERROR ON SYSPRINT

Parent topic: JCLGN Error Messages


JCLGN0012U I/O ERROR ON SYSIN

Parent topic: JCLGN Error Messages


JCLGN0100U MISSING DD STATEMENT FOR filename

You have referenced a data set from a program but your JCL does not include a DD entry for it.
Parent topic: JCLGN Error Messages


JCLGN0101U INVALID DSORG FOR filename

The data set's DSORG is inappropriate for the operation you are trying to perform.
Parent topic: JCLGN Error Messages


JCLGN0102U I/O ERROR ON filename

Parent topic: JCLGN Error Messages


JCLGN0103U I/O STATUS = file status

Parent topic: JCLGN Error Messages


JCLGN0104U MFJGENER ABENDED system code

See preceding messages for details of the error.
Parent topic: JCLGN Error Messages


JCLGN0110I number RECORDS COPIED FROM SYSUT1 TO SYSUT2

Parent topic: JCLGN Error Messages


JCLGN0111I number RECORDS COPIED

Parent topic: JCLGN Error Messages


JCLGN0112I TO MEMBER NAME %

Parent topic: JCLGN Error Messages


JCLGN0200E PARAMETER TOO LONG [value]

Parent topic: JCLGN Error Messages


JCLGN0201E CONTINUATION ERROR [value]

Parent topic: JCLGN Error Messages


JCLGN0202E MISMATCHED QUOTES OR PARENTHESIS [value]

Parent topic: JCLGN Error Messages


JCLGN0210E UNRECOGNIZED OPERATOR KEYWORD [value]

Parent topic: JCLGN Error Messages


JCLGN0211E DUPLICATE CONTROL STATEMENT [value]

Parent topic: JCLGN Error Messages


JCLGN0220E UNRECOGNIZED OPERAND KEYWORD [value]

Parent topic: JCLGN Error Messages


JCLGN0221E DUPLICATE OPERAND KEYWORD [value]

Parent topic: JCLGN Error Messages


JCLGN0222E TOO MANY OPERANDS [value]

Parent topic: JCLGN Error Messages


JCLGN0223E INVALID OPERAND VALUE [restriction]

The restriction shows the values permitted.
Parent topic: JCLGN Error Messages


JCLGN0224E UNEXPECTED OPERAND [%]

Too many operands are present.
Parent topic: JCLGN Error Messages


JCLGN0225E EXPECTED OPERAND MISSING [parameter]

A required operand is missing from parameter.
Parent topic: JCLGN Error Messages


JCLIM0201U MISSING DDITV02 DD STATEMENT

Parent topic: JCLIM Error Messages


JCLIM0202U INVALID DDITV02 PARM STATEMENT

Parent topic: JCLIM Error Messages


JCLIM0203U INVALID DDITV02 PROGRAM PARM

Parent topic: JCLIM Error Messages


JCLIM0204U I/O ERROR ON DDITV02 DATASET

Parent topic: JCLIM Error Messages


JCLUT0100S MISSING "filename"

The file cannot be found
Parent topic: JCLUT Error Messages


JCLUT0101S INVALID "filename"

Message

Invalid "%1$s"

Where %1$s is filename.

Message Information

The file attributes are invalid.

Resolution

Correct the file properties so that the operation is valid.

Parent topic: JCLUT Error Messages


JCLUT0102S I/O ERROR ON "PDS member name"

The PDS member does not exist or is invalid.
Parent topic: JCLUT Error Messages


JCLUT0103S UTILITY "utility-name" ABENDED

An error has caused the utility to abend.

Resolution:

Check preceding messages for the reason.

Parent topic: JCLUT Error Messages


JCLUT0104S DUPLICATE MEMBER "PDS-member-name"

You have tried to create a PDS member but a member with that name already exists.

Resolution:

Use a different name.

Parent topic: JCLUT Error Messages


JCLUT0105S CATALOG ERROR ON "dataset-name"

Message

Catalog error on %1$s

Where %1$s is Dataset name.

Message Information

Either you have referenced a data set that has no entry in the catalog, or you have tried to catalog a data set with a name that already exists in the catalog.

Resolution

Check the catalog entry for this dataset.

Parent topic: JCLUT Error Messages


JCLUT0106S RETURN CODE IS "value"

Message

Return code is "%1$s"

Where %1$s is return code.

Message Information

The value of the return code is not as expected.

Parent topic: JCLUT Error Messages


JCLUT0201I MEMBER "PDS-member-name" NOT FOUND

You have tried to access a PDS member but there is no catalog entry for it.
Parent topic: JCLUT Error Messages


JCLUT0202I RECORDS COPIED "number"

Message

Records copied "%1$s"

Where %1$s is Number of records.

Message Information

The number of records copied.

Resolution

No action is required.

Parent topic: JCLUT Error Messages


JCLUT0203I MEMBERS NAME "PDS-member-name"

Message

Members name "%1$s".

Where %1$s is PDS member name.

Message Information

The name of the PDS member.

Resolution

No action is required.

Parent topic: JCLUT Error Messages


JCLUT0204I MEMBERS WRITTEN TO OUTPUT DD "number"

Message

Members written to output DD "%1$s".

Where %1$s is the number of members.

Message Information

The number of members written to output DD.

Resolution

No action is required.

Parent topic: JCLUT Error Messages


JCLUT0205I INDD=OUTDD="filename", COMPRESS IN PLACE IGNORED

Message

INDD=OUTDD="%1$s", compress in place ignored.

Where %1$s is Dataset name.

Message Information

Informational only. "Compress in place" is not meaningful on the PC, so control statements requesting it are ignored.

Resolution:

No action is required.

Parent topic: JCLUT Error Messages


JCLUT0206S Character set mismatch. Copied without conversion

Message

Character set mismatch. Copied without conversion

Message Information

You are trying to copy an ASCII dataset to an EBCDIC one, or vice versa.

Resolution

Convert one of the datasets so that both match.

Parent topic: JCLUT Error Messages


JCLCM0165S Open for joblog "filename" failed. Also see JCLCM0166

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0166S File status code for last file I/O failure was value

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0094I Non-JCL record in the input stream has caused this SYSIN DD statement to be generated.

This message, while it never appears in any JCL listings, is referred to in the generated SYSIN DD statement. It means that in your JCL source stream, you have one or more non-JCL records before the final // if any.

Example of non-JCL records

//MYJOB JOB
//STEP1 EXEC PGM=IEFBR14
//SYSOUT DD SYSOUT=*
   some data
   some more data
//SYSPRINT DD SYSOUT=*
blank line
//

The above JCL will cause two statements of the form:

//SYSIN DD * ***MFE JCL GENERATED STMT*** For more info, see JCLCM0094I

to appear, one after /SYSOUT DD and the other after //SYSPRINT DD.

Parent topic: JCLCM0000 - JCLCM0199


JCLCM0218S System error "internal code"

System error.

Resolution:

Contact SupportLine. Please mention the internal code.

Parent topic: JCLCM0200 - JCLCM0299


JCLIM0005U - Program Parm Contains Invalid Character n

Parent topic: JCLIM Error Messages


JCLIM0205U - Missing DD Statement nnnnnn

Parent topic: JCLIM Error Messages


JCLIM0206U - Invalid Dsorg For n

Parent topic: JCLIM Error Messages


JCLIM0207U - Invalid/Missing Control Statement On n

Parent topic: JCLIM Error Messages


JCLIM0208U - I/O Error On n

Parent topic: JCLIM Error Messages


WADM010: userid is not a registered user.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM011: Unknown table format in table name.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM012: No password specified.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM013: User userid is already registered.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM014: No UserID specified.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM016: No User Comment specified.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM017: Memory allocated insufficient for the number of groups found.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM018: Group name already exists.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM019: No Group Authorization ID specified.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM020: Group name does not exist.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM022: name is not a valid group name.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM023: The priority name does not exist.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM027: The User ID entered is invalid.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM028: Valid range for value value is > 0 and < number.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM029: name is not a valid priority name.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM030: No Priority Name specified.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM031: Priority name already exists.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM032: An error occurred while updating an internal list (name).

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM033: The SecondaryID name is invalid.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM034: Cannot delete yourself ('name') as a User.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM002: Passwords don't match.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM003: You must enter a UserID before entering a password.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM004: Expected number record(s), got number.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM005: Password must have at least number characters.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM006: Password must contain at least one digit.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM007: Password must contain the characters character and character.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM008: Incomplete information retrieved from table name.

Parent topic: WADM - SQLWizard Administrator Error Messages


WADM009: User userid belongs to unregistered group name.

DELETE FROM SYSTEM.SYSXDB.SYSACFMEMBERS WHERE GROUPAUTHID = userid;

Parent topic: WADM - SQLWizard Administrator Error Messages


XU010: Error deleting file name. error-descr.

Parent topic: XU - Library Error Messages


XU011: Error seeking file name. error-descr.

Parent topic: XU - Library Error Messages


XU014: Incorrect file version in file name.

Parent topic: XU - Library Error Messages


XU015: Corrupted file format in file name.

Parent topic: XU - Library Error Messages


XU016: Invalid file or path specification.

Check that you have typed the path name correctly. Also check that the directory exists and that you have permission to access it.

Parent topic: XU - Library Error Messages


XU017: The file FileName does not have correct read/write permissions.

If FileName is on your local computer, change the file's permissions using a utility such as the DOS ATTRIB or Windows' Attribute command (in most cases you will need to disable the file's read-only attribute).

If FileName is on a network, check with your network administrator to obtain the needed access rights.

Parent topic: XU - Library Error Messages


XU018: Invalid drive in search path.

Check to make sure that you have specified the correct drive. If you are using a network, also make sure that the drive letter is mapped to a physical device.

Parent topic: XU - Library Error Messages


XU020: Maximum of 3 unsuccessful attempts to login.

Restart the client application and try logging on again, ensuring that you:

  • Log on to the correct server
  • Enter the correct user ID
  • Enter the correct password using the correct combination of upper and lowercase letters
Note:

XDB Server passwords are CASE-SENSITIVE! Make sure that CAPS LOCK is off if all or part of your password is lowercase.

If you enter this information correctly and still cannot log on, contact your XDB Server Administrator to check your User ID and/or reset your password.

Parent topic: XU - Library Error Messages


XU021: More than 15 errors...

Correct the displayed errors and re-execute the operation.

Parent topic: XU - Library Error Messages


XU022: Invalid server name.

Correct the server name and re-execute the operation. See your SQL Reference for valid server names.

Parent topic: XU - Library Error Messages


XU023: Invalid location name.

Correct the location name and re-execute the operation. See your SQL Reference for valid location names.

Parent topic: XU - Library Error Messages


XU025: Unknown system error. Errno = ErrNumber. Doserrno = DErrNumber.

Do the following:

  • Record the error numbers reported by this error message.
  • Note which operation was in process when the error occurred.
  • Contact Micro Focus Technical Support.
Parent topic: XU - Library Error Messages


XU030: Object name not found in SYSIBM.SYSTABLES while checking if it's an alias.

Check that the SYSIBM setting in Options is correct. Also check that the values in SYSIBM.SYSTABLES are correct. Often the problem is caused by an out-of-sync catalog cache location. If this is the case, rebuild the catalog cache. If this is not the case, or if rebuilding the catalog cache does not correct the problem, contact Micro Focus Technical Support.

Parent topic: XU - Library Error Messages


XU031: Object name is not an alias.

Check that the SYSIBM setting in Options is correct. Also check that all aliases are defined in SYSIBM.SYSTABLES, and that they are denoted with an "A" in the TYPE column.

Often this problem is caused by an out-of-sync catalog cache location. If this is the case, rebuild the catalog cache. If this is not the case, or if rebuilding the catalog cache does not correct the problem, contact Micro Focus Technical Support.

Parent topic: XU - Library Error Messages


XU032: Error Querying SYSTABLES

Check that the SYSIBM setting in Options is correct. Also check that the values in SYSIBM.SYSTABLES are correct and that you have SELECT privileges on this table.

Often this problem is caused by an out-of-sync catalog cache location. If this is the case, rebuild the catalog cache. If this is not the case, or if rebuilding the catalog cache does not correct the problem, contact Micro Focus Technical Support.

Parent topic: XU - Library Error Messages


XU001: No more RAM memory available to application.

Parent topic: XU - Library Error Messages


XU002: No more EXTENDED memory available to application.

Note: Add the following line to your AUTOEXEC.BAT file:
SET XM = /Z 12288
Parent topic: XU - Library Error Messages


XU004: Filename name is too long.

Parent topic: XU - Library Error Messages


XU005: File name not found.

Parent topic: XU - Library Error Messages


XU006: Error opening file name. error-descr.

Parent topic: XU - Library Error Messages


XU007: Error reading file name. error-descr.

Parent topic: XU - Library Error Messages


XU008: Error writing file name. error-descr.

Parent topic: XU - Library Error Messages


XU009: Error closing file name. error-descr.

Parent topic: XU - Library Error Messages


COBSQ0015 Host variables data types in UNION do not match.

One of the data types for host variables used in a UNION does not match

You cannot select different column types where the result column is the same ordinal position returned. For example, if the first column returned on SQL statement 1 is a numeric column and the first column returned in SQL statement 2 is a character column, that is invalid.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0016 This statement will Delete an entire table

The SQL statement will delete the entire contents of a table if executed.

No action is required, as this is a warning. Qualify the SQL statement with a WHERE clause if you do not want to delete the entire table.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0017 HostVariable is not preceded by a colon.

The SQL Option preprocessor has detected a host variable in an EXEC SQL SET statement that is not preceded by a colon. Although DB2 and XDB Server currently accept host variables without colons, this practice is unconventional and it may not be supported in future releases.

No action is required, as this is a warning. However, you might want to include the colon now to avoid problems in future releases of this software.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0018 SQL statement not currently supported - converted to comment.

The SQL Option preprocessor has detected an EXEC SQL statement that is not currently supported by the SQL Option run-time system. This statement may be valid on the database engine that the code was ported from, so the processor converts the statement to comments in order that the program can compile cleanly.

No action is required at this time. However, if SQL Option ever does support this statement, you will need to recompile this program.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0019 Operation is assumed to apply to Allocate Cursor.

The cursor name in a FETCH statement was not found.

No action is required at this time, provided that the cursor name is subsequently defined with an ALLOCATE CURSOR statement.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0021 SQL Option must be selected and available

You have installed both Host Compatibility Option (HCO) and SQL Option for DB2, and HCO is the current selection.

Make SQL Option for DB2 the currently active database.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0101: Expected token1 found token2.

The preprocessor was expecting a reserved word and did not find it.

Check the syntax of the SQL statement.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0102: Host variable mismatch.

The preprocessor was expecting host variables for the SQL statement and did not find any, or found an invalid amount of host variables.

Correct the SQL statement in error and recompile your program.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0104: Illegal symbol variable.

The SQL Option preprocessor found an invalid token in the SQL statement. The token can be a variable that should have had a colon to indicate it was a host variable. In DB2 V6 mode this is an error; it is a warning in DB2 V5 mode. This error can also result when an invalid token (such as a semi-colon) is found in the SQL statement, or a qualified host variable has more than two levels of qualification and points at a variable defined as a level 49 variable.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0106: variable Invalid/Not Declared

The preprocessor could not find the host variable variable.

Check to make sure that the host variable is declared in the program and that the picture or usage is correct. See the appropriate XDB COBOL Precompiler manual for the correct picture and usage.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0107: INTO not allowed for DECLARE.

An INTO is not allowed on a DECLARE CURSOR statement.

See the SQL Reference for the correct usage of the DECLARE CURSOR statement.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0110: No INTO clause specified.

An INTO is required for SQL FETCH or SELECT ... INTO statements.

See the SQL Reference for the correct usage of the FETCH and SELECT statements.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0111: No FROM clause specified.

A FROM clause is required for SELECT statements.

Add a FROM clause to this statement. See the SQL Reference for the correct syntax.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0112: Invalid positioning of FROM.

The FROM clause specified into the SELECT statement is before the INTO specification.

The FROM clause must follow the INTO clause. See the SQL Reference for the correct syntax.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0114: Invalid file name.

The copybook filename was not found. Check for spelling errors.

Check to ensure that the copybook exists, with the correct extensions, either in COBCPY directory or locally.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0115: Token array overflow.

The statement identified has gone over the limit set by XDB. The limit was set for memory considerations.

Call Micro Focus Technical Support.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0117: Invalid in data division.

A SQL statement in question was not defined in the PROCEDURE DIVISION.

Some SQL statements such as UPDATE, DELETE, INSERT, and SELECT..INTO can only be coded in the PROCEDURE DIVISION. Move the statement in question to the PROCEDURE DIVISION and then recompile the program.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0118: Invalid WHENEVER.

The invalid function was used as a WHENEVER argument.

If using SQL Option extensions, check to ensure that the XDBFUNCS directive is set.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0120: Not valid in current compatibility mode.

SQL Option extensions are not allowed if the XDBFUNCS directive is not set.

Recompile the program with the XDBFUNCS directive set.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0124: Group variable token is not allowed in the WHERE clause.

The group variable in token was used in a WHERE clause. This is not valid.

Do one of the following:

  • break up the group variable into its elementary items and compare each item to its corresponding field in the table
  • redefine the group variable into a single elementary item
Parent topic: COBSQ0100 - COBSQ0149


COBSQ0125: Cursor not found.

An OPEN, FETCH or CLOSE statement references a cursor name that was not DECLAREd.

The DECLARE CURSOR statement must be coded before an OPEN, FETCH or CLOSE SQL statement. If defined, move the DECLARE CURSOR statement before the statement in error. Otherwise, check to make sure the cursor name used in the DECLARE CURSOR statement matches the cursor name used in the SQL statement in error.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0126: A _ is illegal in a host variable.

An underscore (_) was found in a host variable name in the SQL statement in error.

Underscores are only valid in column names for SQL tables. A hyphen (-) is valid for host variable names. Change the underscore to a hyphen and recompile your program.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0127: A ( is illegal in the INTO clause.

A left parenthesis "(" was found in the SQL statement in error.

Correct the syntax and recompile your program. See the SQL Reference for the correct syntax.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0131: SQLCA not found OR comp/comp-5 mixup in SQLCA.

An SQLCA was not found and the directive STRICT-DB2 was set.

Check to see if an SQLCA is included and declared correctly.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0135: Host variable type mismatch.

The host variable data definition does not match the column type associate with it in the SQL statement. For example, you are trying to use a host variable defined as PIC X(n) with a column defined as SMALLINT.

Verify that the host variable that corresponds to the column definition and make any changes to correct error or use the SQL Option DCLGEN tool to generate a copybook of host variable for the SQL table in question.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0137: Indicator variable token is not SMALLINT type.

The indicator variable data definition does not match the data type associate with it in the SQL statement. For example, you are trying to use an indicator variable defined as PIC X(n) rather than PIC S9(04) COMP. SMALLINT.

Correct the picture clause for the indicator variable identified in the error message and recompile the program.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0184 Illegal token ':' found. Check to see if previous token was an indicator variable.

The SQL Option preprocessor found a colon in an SQL statement and the previous token was an indicator variable. This could be caused by a missing comma in the list of host and indicator variables in the SQL statement.

Correct the statement and recompile the program.

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0185 Syntax error, last symbol read is token.

The SQL Option generic syntax parser found an error in the SQL statement.

Verify that the SQL statement is valid. Make any corrections that are required and then recompile. If the error persists and the statement is valid, contact Micro Focus Technical Support.

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0189 'ORDER BY' clause not permitted.

The SQL Option preprocessor found an ORDER BY clause in an embedded SELECT...INTO statement. This is not valid on the mainframe.

Remove the ORDER BY clause or convert the statement into a DECLARE CURSOR statement, then recompile the program.

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0190 GROUP BY clause on a SELECT INTO will not bind.

The SQL Option preprocessor found a GROUP BY clause in an embedded SELECT ... INTO statement. This is not valid on the mainframe.

Remove the HAVINGclause or convert the statement into a DECLARE CURSOR statement, then recompile the program.

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0191 HAVING clause on a SELECT INTO will not bind.

The SQL Option preprocessor found a HAVING clause in an embedded SELECT ... INTO statement. This is not valid on the mainframe.

Remove the GROUP BY clause or convert the statement into a DECLARE CURSOR statement, then recompile the program.

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0198: DB2 emulation mismatch - SERVER is in DB2 V6 mode

The SQL Option preprocessor is in DB2 V5 mode and the server is in DB2 V6 mode. Run time errors could result if you try to execute this program compiled this way.

Either change build settings to compile the program specifying the directive XDB(DB2VER=V6).

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0199: DB2 emulation mismatch - SERVER is in DB2 V5 mode

The SQL Option preprocessor is in DB2 V6 mode and the server is in DB2 V5 mode. Run time errors could result if you try to execute this program compiled this way.

Either change build settings to compile the program specifying the directive XDB(DB2VER=V5).

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0201 Illegal token variable found on SET line.

The SQL Option preprocessor found an invalid variable in a SET statement.

Locate and correct the SET statement. For a description of this statement, see the SET command in the SQL Reference.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0202 Number of host variables specified in UNION do not match.

The number of host variables specified in each SQL statement in a UNION statement is different.

Make sure that the number of host variables match for each SQL statement that are specified within UNION.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0299 Internal EXEC SQL statement table overflow - use directive MAXSQL to override default.

The SQL Option preprocessor predefines space for 750 SQL statements. This error is produced if more than 750 SQL statements have been coded in the program.

Specify the directive XDB(MAXSQL=nnnn), where nnnn is a number greater than 750 to allow more than 750 SQL statements, then recompile the program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0312 Undefined or unusable host variable token

The SQL Option found an unusable host variable in the SQL statement. This error can result when a qualified host variable has more than two levels of qualification or points at a variable defined as a level 49 variable defined with two levels of qualification.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0324 SQLDA fields defined with incompatible fields for XDB OPTIMIZE directive setting.

When emulating DB2 for OS/390, you must use COMP fields in your SQLDA definition. If you specify OPTIMIZE=PC, you must use COMP-5 fields.

Change the XDB OPTIMIZE directive or modify your SQLDA definition, then recompile the program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0325 Multiple types of SQLDA's detected - all SQLDA's must use same structure.

The SQL Option preprocessor supports multiple types of SQLDA definitions. When coding them in a program, they all must be defined using the same structure or data corruption or a protection violation could occur. The preprocessor found multiple types of SQLDAs in the program. If you use a DB2 for OS/390-style SQLDA, you also need to specify the XDB directive XDB(SQLDA-VER=1)

Change your SQLDA definitions to be consistent and recompile your program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0326 SQL statements not supported in nested subroutine.

The XDB directive IGNORE-NESTED was specified but a SQL statement was found in a nested subroutine. This directive stops the SQL Option preprocessor from generating any code for SQL statements.

Remove the SQL statements from the nested subroutine and recompile the program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0327 Invalid BLOCKING option specified – valid options are: FSR, SR, or LB.

The SQL Option preprocessor found an invalid option for the preprocessor directive BLOCKING.

Correct the directive and recompile the program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0328 Invalid DEFAULT-CHAR option specified – valid options are: BITS, SBCS, DBCS, or SYSDEFAULT.

The SQL Option preprocessor found an invalid option for the preprocessor directive DEFAULT-CHAR.

Correct the directive and recompile the program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0329 Invalid EXIST-CHECK option specified – valid options are: REQUIRED or OPTIONAL.

The SQL Option preprocessor found an invalid option for the preprocessor directive EXIST-CHECK.

Correct the directive and recompile the program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0330 Required directive AUTOBIND not specified with directive directive.

The SQL Option preprocessor did not find the AUTOBIND directive specified with the preprocessor directive specified in the error message.

Add the AUTOBIND directive and recompile the program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0331 Invalid DATE format specified - valid options are: ISO, EUR, JIS, USA or LOCAL.

The SQL Option preprocessor did not find option for the DATE directive. It must be one of ISO, EUR, JIS, USA, or LOCAL.

Correct the DATE directive and recompile the program

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0332 Invalid TIME format specified - valid options are: ISO, EUR, JIS, USA or LOCAL.

The SQL Option preprocessor did not find option for the TIME directive. It must be one of ISO, EUR, JIS, USA, or LOCAL.

Correct the TIME directive and recompile the program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0333 Invalid number of values specified, maximum is 10 per option: token .

The SQL Option preprocessor found more than 10 options specified for the directive identified by the token in the error message.

Remove the excess options and recompile the program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0334 Only one DBRM specified when multiple other directives specified for AUTOBIND.

The SQL Option preprocessor found more than one option specified in either the AUTHID, COLLECTION-ID, or LOCATION directives but only one DBRM specified.

If you want to create multiple bind files with multiple options, you need to specify more than one DBRM filename. If you want only one DBRM file, remove the option(s) that have multiple entries. Once you have made the relevant changes, recompile the program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0335 No collection-id specified, option required for AUTOBIND.

The AUTOBIND directive was specified but no collection-id was specified.

Add the required directive or remove the AUTOBIND directive and then recompile the program.

Parent topic: COBSQ0200 - COBSQ0399


COBSQ0401 Statement is too long.

The SQL statement passed to the SQL Option preprocessor is more than 65536 characters long. The SQL Option preprocessor gets passed a compressed version of the SQL statement rather than the original source, which may have comments included in the source as well as leading and trailing blanks.

Break the SQL statement into multiple SQL statements, then recompile the program.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0402 Statement contains too many host variables.

The SQL statement contains more than 8000 host and indicator variables.

Break the SQL statement into multiple SQL statements, then recompile the program.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0403 variable does not have a suitable definition to be used as a host variable.

The host variable displayed in the error message is not recognized with a data definition suitable for SQL data types.

See your SQL Reference to review valid data definitions for host variables.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0002: token is badly defined

One of three things has happened:

  • The SQLCA is defined to be less than 136 characters long
  • The SQLCODE variable is not defined as an elementary field with definition of PIC S9(8) COMP.
  • The SQLSTATE variable is not defined as an elementary field with definition of PIC X(5).

Correct the definition or use the supplied SQLCA copybook. If the problem persists, report this error to your support representative. Trace files may be needed to resolve this problem. See Creating Debug Files in the Studio Enterprise Edition documentation on Programming for details on how to create additional trace files that might be requested by your support representative.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0415 Statement not allowed in the PROCEDURE DIVISION.

A SQL statement such as EXEC SQL DECLARE TABLE was coded in the Procedure Division. This statement cannot be coded in the Procedure Division.

Move the statement into the Working-Storage Section then recompile the program.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0416 An error occurred whilst processing the trace file.

A file error occurred while trying to write information to the SQL Option preprocessor trace file.

Make sure you have write permissions for the drive/directory where the file is being written to and that there is enough space left on the drive.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0418 Mismatched DECLARE.

More than one DECLARE statement was found within an EXEC SQL statement.

Correct the statement then recompile the program.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0419 Host variable name is too long.

The host variable name is too long. The maximum length of the host variable is 30 characters.

Make sure the host variable is a valid COBOL name. It should be no more than 30 characters long.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0420 Internal error - dictionary handle is too big.

The SQL Option preprocessor creates an internal dictionary of all host variables used in a program. A system error has occurred while working with this dictionary.

Report this error to your support representative, who might need you to supply trace files in order to resolve this problem. See Creating Debug Files in the Studio Enterprise Edition documentation on Programming for details on how to create additional trace files.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0422 Nested INCLUDE's not supported.

An EXEC SQL INCLUDE was found inside another EXEC SQL INCLUDE. This is not allowed on DB2 for OS/390.

Remove the EXEC SQL INCLUDE from the copybook and then recompile the program.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0900 An internal error occurred. Create a trace file using the compiler directive CHKECM(TRACE) and contact your support representative.

An unexpected error occurred in the SQL Option preprocessor.

Report this error to your support representative, who might need you to supply trace files in order to resolve this problem. See Creating Debug Files for details on how to create these files.

Parent topic: COBSQ0900 - COBSQ0999


COBSQ0901 This error prevents SQL processing from continuing - further EXEC SQL statements will be ignored.

If a severe SQL error occurs, any additional EXEC SQL statements will not be processed by the SQL Option preprocessor.

Correct the severe error then recompile the program.

Parent topic: COBSQ0900 - COBSQ0999


COBSQ0024 EXEC SQL statement found within COPY statement, COPY directive not set. May cause compile error on mainframe.

An EXEC SQL statement was found in a COPY statement. On the mainframe this could cause compilation errors unless you are using a preprocessor that expands copybooks before the source is passed to the DB2 precompiler.

If you are using a preprocessor, set the XDB(COPY) directive to remove the warning message. Otherwise, remove the EXEC SQL statement from the copy statement if you will be porting the code back to the mainframe.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0003 Program contains more than one definition of token

More than one definition exists of one or more of the following fields: SQLCA, SQLCODE or SQLSTATE.

Remove the duplicate definitions and recompile the program.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0004 Nested or multi-source programs not allowed.

You are trying to compile a program that is nested or multi-source.

Use Micro Focus Net Express if you want to develop applications using nested or multi-source programs, or specify the XDB directive: XDB(IGNORE-NESTED).

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0005: An error occurred whilst processing the internal dictionary.

A system error has occurred trying to read the internal dictionary that the preprocessor creates of all host variables used in the program.

Report this error to your support representative. Trace files may be needed to resolve this problem. See Creating Debug Files in the Studio Enterprise Edition documentation on Programming for details on how to create additional trace files that might be requested by your support representative.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0006 No DB engine could be found.

The required SQL Option system software was not installed.

Install one of the required SQL Option software products.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0007 Source file name is invalid.

A system error has occurred. The source file name passed to SQL Option preprocessor is not valid.

Report this error to your support representative, who might need you to supply trace files in order to resolve this problem. See Creating Debug Files in the Studio Enterprise Edition documentation on Programming for details on how to create additional trace files.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0012: Host variable used without a colon.

The host variable is defined without a colon in the SQL statement.

No action is required, as this is a warning. For compatibility across multiple SQL syntaxes, a colon should always precede host variables. Currently, SQL Option and DB2 support the use of host variables without a colon, but this feature may be revoked at some time in the future.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0013: Login failed. : program-name.

The XDB Server was not started when the specified DB2 program was compiled. The XDB Server must be started in order for the SQL statements in the program to be validated.

Before trying to compile the program again, either start the XDB Server or turn off the VALIDATE directive.

Parent topic: COBSQ0000 - COBSQ0099


COBSQ0138: The length of a host variable on CONNECT is greater than 16.

The host variable data definition used in CONNECT statement has a data length greater than 16 characters long.

The host variable length must be 16 characters or less on a CONNECT statement. Change the length of the variable and then recompile the program.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0141: PREPARE before DECLARE is illegal.

The PREPARE statement must follow the DECLARE CURSOR that references it.

Move the DECLARE CURSOR statement before the PREPARE statement, then recompile the program.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0144: Statement not identified.

The SQL statement did not contain a SQL verb recognized by the SQL Option preprocessor.

Check the spelling of the SQL verb. If SQL Option extensions are being used, check to ensure that the XDBFUNCS directive is active.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0147: Multiple INTO's only allowed with a UNION.

Multiple INTO clauses were found in a SELECT INTO statement – this is only allowed if UNION is specified.

Correct the syntax and recompile your program. See the SQL Reference for the correct syntax.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0149: Illegal token found on CONNECT line.

The CONNECT statement contains syntax that is not recognized.

Correct the syntax and recompile your program. See the SQL Reference for the correct syntax.

Parent topic: COBSQ0100 - COBSQ0149


COBSQ0151: Cursor already DECLARED.

The cursor name in the DECLARE CURSOR statement has already been declared in the program.

Make sure the cursor name specified in the DECLARE CURSOR statement has not already been used in a previous DECLARE CURSOR statement, then recompile the program.

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0154: Login failed.

If the VALIDATE directive is specified, the SQL Option preprocessor tries to login to the XDB server. This error is produced if the login fails. This could be caused by a wrong location or AUTHID specification in the Options settings.

Go into Option settings and check that the correct location and AUTHID are specified.

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0163: Invalid Cursor name

An invalid character, often a hyphen, was found in the cursor name.

If you are using the DB2 directive, check that your cursor name does not contain a hyphen. If it does, do one of the following:

  • Remove it from the cursor name (or change it to an allowed character), or...
  • Use the HYPHEN-IN-CURSOR SQL Option preprocessor directive.

Note: Although MVS DB2 currently allows hyphens in a cursor name, this practice may not be supported in future releases.

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0164: Syntax error in INTO Clause

The SQL Option preprocessor found an invalid INTO clause in an embedded SELECT statement.

Correct the syntax and recompile your program. See the SQL Reference for the correct syntax.

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0170: Login failed. Unable to VALIDATE SQL

If the VALIDATE directive is specified, the SQL Option preprocessor tries to login to the XDB server. This error is produced if the login fails.

Ensure that the SQL Option server is started and that a valid AUTHID is specified.

Parent topic: COBSQ0150 - COBSQ0199


COBSQ0404 Bad SQL data declaration.

An unexpected SQL declaration has been passed to the SQL Option preprocessor. This error typically occurs only for a host variable defined as follows:

host-variable-name SQL TYPE IS ....

and the SQL Option preprocessor has not been setu p to handle that definition.

Report this error to your support representative, who might need you to supply trace files in order to resolve this problem. See Creating Debug Files in the Studio Enterprise Edition documentation on Programming for details on how to create additional trace files.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0405 Syntax error.

The SQL statement includes invalid syntax or does not include required information. For example, this error would be generated if you only coded:

EXEC SQL INCLUDE END-EXEC

and did not specify the name of the copybook file to include.

Correct the SQL statement and recompile the program.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0406 Filename too long.

A filename used in the program to specify a copybook or INCLUDE file is more than 260 characters long.

Correct the filename and recompile the program.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0407 File token not found.

The copybook specified in token was not found.

The SQL Option preprocessor looks first in the current directory, and then down the paths specified by environment variables XDBCPY and COBCPY. Either correct the filename or update the Copybook folder to include the drive/directory to look in to find the copybook.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0408 token is non-unique and should be qualified.

The host variable displayed in token is not unique.

You must fully qualify a host variable in a SQL query if the variable-name is not unique. For example, if ORD-NO exists in both the ORDERS and ITEMS copybooks, you would need to specify something like the following if you wanted the host variable from the ORDERS copybook to be used in the query:

:ORDERS.ORD-NO

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0409: token is not a data item

The precompiler found a host variable that is referenced in an SQL statement but has no valid COBOL definition.

Verify that the host variable exists. If it does not, make the necessary changes to correct the error or use the SQL Option DCLGEN tool to generate a copybook of host variable for the SQL table in question.

If the variable in error message is defined in a COBOL copybook, you may need to specify the XDB(COPY) directive.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0410 Statement contains more than one SQLDA.

More than one SQLDA has been defined in the Working-Storage Section.

The SQL Option preprocessor currently has a limit of one SQLDA definition per program. If you cannot work around this limit, contact your support representative.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0411 token is not a table of null indicator variables.

The SQL Option preprocessor was expecting the token displayed to be a null indicator or a null indicator table.

Correct the SQL statement and recompile the program. If you are using a null indicator table, make sure you do not use the group-name. For example, if the following is a definition of a null indicator table:

01 staff-null-tbl.

03 staff-null-ind occurs 7 times pic s9(04) comp.

You should specify staff-null-ind instead of staff-null-tbl in your query.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0412 token should not be a defined with an OCCURS clause.

A host variable is defined as part of an OCCURS clause. The SQL Option preprocessor does not allow host variables to be defined this way.

Change the definition of the host variable and recompile the program.

Parent topic: COBSQ0400 - COBSQ0499


COBSQ0413 token should not be a subordinate to an item defined with an OCCURS clause.

A host variable is defined as part of an OCCURS clause or as part of a structure that includes an OCCURS clause. The SQL Option preprocessor does not allow host variables to be defined this way.

Change the definition of the host variable and recompile the program.

Parent topic: COBSQ0400 - COBSQ0499


WE009: No more Export windows can be created.

Parent topic: WE000 - WE049


WE010: Table table is empty.

Parent topic: WE000 - WE049


WE011: Invalid value value for TIMESTAMP command in group number, groupname.

Parent topic: WE000 - WE049


WE012: Invalid field type specified for field fieldname.

Parent topic: WE000 - WE049


WE013: Unable to retrieve field information.

Parent topic: WE000 - WE049


WE014: Batch Export file file-name not found.

Parent topic: WE000 - WE049


WE015: Keyboard navigation error.

Parent topic: WE000 - WE049


WE016: No fields in table specification.

Parent topic: WE000 - WE049


WE017: Internal error getting text from screen. Contact Micro Focus Technical Support.

Parent topic: WE000 - WE049


WE018: Internal error opening table window. Contact Micro Focus Technical Support.

Parent topic: WE000 - WE049


WE019: Internal error opening query window. Contact Micro Focus Technical Support.

Parent topic: WE000 - WE049


WE020: Batch Export file file-name does not contain a group heading

Parent topic: WE000 - WE049


WE024: Query result does not contain any records.

Parent topic: WE000 - WE049


WE025: Data file filename is empty.

Parent topic: WE000 - WE049


WE026: Float value in field fieldname is larger than the IBM370 limit.

Parent topic: WE000 - WE049


WE027: Data exceeds 4K page size.

Parent topic: WE000 - WE049


WE028: No output filename specified.

Parent topic: WE000 - WE049


WE030: Invalid output file specification filename.

Parent topic: WE000 - WE049


WE031: Invalid table name.

Parent topic: WE000 - WE049


WE032: No table name specified.

Parent topic: WE000 - WE049


WE033: Error writing to file filename.

Parent topic: WE000 - WE049


WE034: Can't display a join of multiple tables on Export's Design screen.

Parent topic: WE000 - WE049


WE035: Field fieldname specified in query does not exist in table tablename.

Parent topic: WE000 - WE049


WE036: Invalid query.

Parent topic: WE000 - WE049


WE037: Invalid record delimiter delimiter.

Parent topic: WE000 - WE049


WE038: Invalid field delimiter delimiter.

Parent topic: WE000 - WE049


WE050: PRIQTY value must be an integer in the range 12 to 4,194,304.

Parent topic: WE050 - WE099


WE051: SECQTY value must be an integer in the range 0 to 131,068.

Parent topic: WE050 - WE099


WE052: FREEPAGE value must be an integer in the range 0 to 255.

Parent topic: WE050 - WE099


WE053: PCTFREE value must be an integer in the range 0 to 99.

Parent topic: WE050 - WE099


WE054: No tables found with authid auth-id in location location-name.

Parent topic: WE050 - WE099


WE055: Invalid DATABASE name.

Parent topic: WE050 - WE099


WE056: Invalid TABLESPACE name.

Parent topic: WE050 - WE099


WE057: Invalid EDITPROC name.

Parent topic: WE050 - WE099


WE058: Invalid VALIDPROC name.

Parent topic: WE050 - WE099


WE059: Internal error reading batch file.

Parent topic: WE050 - WE099


WE060: Unable to access code page information.

Parent topic: WE050 - WE099


WE061: Invalid error log file name file-name specified in batch file.

Parent topic: WE050 - WE099


WE062: Float value in field fieldname is smaller than the IBM370 limit.

Parent topic: WE050 - WE099


WE063: Unable to open View Batch window, probably out of memory.

Parent topic: WE050 - WE099


WE064: Unable to open View Data window, probably out of memory.

Parent topic: WE050 - WE099


WE065: Unrecognized value value for SQL_OPTS command in group number, groupname.

SQL_OPTS = statement-type [, statement-type, ...];

where statement-type is one of the following types:

CREATE | (CREATE TABLE and CREATE VIEW commands)
INSERT | (INSERT INTO commands)
INDEX | (CREATE INDEX commands)
SYNONYM | (CREATE SYNONYM commands)
CHECK | (ALTER TABLE...CHECK commands)
COMMENT | (COMMENT ON commands)

For example:

SQL_OPTS = CREATE, INDEX;

selects CREATE TABLE, CREATE VIEW, and CREATE INDEX SQL commands for use in the target file.

Parent topic: WE050 - WE099


WE066: Invalid value value for ASCII_CODEPAGE in group number, groupname.

ASCII_CODEPAGE = n;

where n is the codepage number. Use the default ASCII character set for your country.

Parent topic: WE050 - WE099


WE067: Invalid value value for EBCDIC_CODEPAGE in group number, groupname.

EBCDIC_CODEPAGE = n;

where n is the codepage number. Use the default EBCDIC character set for your country.

Parent topic: WE050 - WE099


WE068: Invalid value value for FORMAT command in group number, groupname.

FORMAT = target-file-type;

where target-file-type is one of the following options:

FIXASC | used for fixed format ASCII files
FREASC | used for free format ASCII files
DSNTIAUL | used for IBM DSNTIAUL files
SQL | used for SQL statements
Parent topic: WE050 - WE099


WE069: Batch file filename is empty.

Parent topic: WE050 - WE099


WE070: Unknown batch command command in group number, groupname.

Parent topic: WE050 - WE099


WE071: Invalid value value for FLD_DELIMITER command in group number, groupname.

FLD_DELIMITER = { xx | <ascii> };

where xx is a character string delimiter and ascii is and ASCII decimal code. The angled brackets around the ASCII code are required. Be sure not to use a character found in your data as a delimiter. For example, do not use a comma as the delimiter if your data contains numeric or money fields grouped with a comma.

Parent topic: WE050 - WE099


WE072: Invalid value value for REC_DELIMITER command in group number, groupname.

REC_DELIMITER = { xx | <ascii> };

where xx is a character string delimiter and ascii is an ASCII decimal code. The angled brackets around the ASCII code are required. Be sure not to use a character found in your data as your delimiter. For example, do not use a comma as the delimiter if your data contains numeric fields grouped with a comma.

Parent topic: WE050 - WE099


WE073: Invalid value value for HEADING command in group number, groupname.

HEADING = {Y | N};

If HEADING is set to N, no heading is included in the target file. If HEADING is set to Y, the column headings are included as the first record of the file.

Parent topic: WE050 - WE099


WE074: Invalid value value for FILENAME command in group number, groupname.

FILENAME = filename;

where filename is the full path specification and filename for the target file.

Parent topic: WE050 - WE099


WE075: Invalid value value for TABLE command in group number, groupname.

TABLE = table-name;

where table-name is the name of the table or view.

Parent topic: WE050 - WE099


WE001: Unable to create document window, XVT error error.

Parent topic: WE000 - WE049


WE086: Invalid value value for AUDIT command in group number, groupname.

Parent topic: WE050 - WE099


WE087: Invalid value value for VCAT command in group number, groupname.

Parent topic: WE050 - WE099


WE088: Invalid value value for STOGROUP command in group number, groupname.

Parent topic: WE050 - WE099


WE089: Invalid value value for PRIQTY command in group number, groupname.

Parent topic: WE050 - WE099


WE090: Invalid value value for SECQTY command in group number, groupname.

Parent topic: WE050 - WE099


WE091: Invalid value value for ERASE command in group number, groupname.

Parent topic: WE050 - WE099


WE092: Invalid value value for FREEPAGE command in group number, groupname.

Parent topic: WE050 - WE099


WE093: Invalid value value for PCTFREE command in group number, groupname.

Parent topic: WE050 - WE099


WE094: Invalid value value for DUPQTY command in group number, groupname.

Parent topic: WE050 - WE099


WE095: Invalid value value for CLUSTER command in group number, groupname.

Parent topic: WE050 - WE099


WE096: Invalid value value for SUBPAGES command in group number, groupname.

Parent topic: WE050 - WE099


WE097: Invalid value value for BUFFERPOOL command in group number, groupname.

  • BP0 - BP49 for indexes with 4K page sizes;
  • BP32K or BP32K1 - BP32K9 for indexes with 32K page sizes.
Parent topic: WE050 - WE099


WE098: Invalid value value for DSETPASS command in group number, groupname.

Parent topic: WE050 - WE099


WE099: Invalid value value for CLOSE command in group number, groupname.

Parent topic: WE050 - WE099


WE100: Invalid value value for DEFER command in group number, groupname.

Parent topic: WE100 - WE149


WE101: Error opening batch file for writing.

Make sure the file exists, that you have privileges to access it, that it is not in use by another application, that there is enough disk space available, and that the target directory is a valid path.

Parent topic: WE100 - WE149


WE102: Error writing to batch file.

Parent topic: WE100 - WE149


WE103: Invalid value value for SRC_ASCII_CODEPAGE command in group number, groupname.

Parent topic: WE100 - WE149


WE104: Invalid value value for DST_ASCII_CODEPAGE command in group number, groupname.

Parent topic: WE100 - WE149


WE105: Warning: No translation table matches the default ASCII source and destination codepages pagenopageno in XDB.INI.

Parent topic: WE100 - WE149


WE106: Invalid Where clause.

Parent topic: WE100 - WE149


WE107: Export to SQL can't export a query that contains more than one table.

Parent topic: WE100 - WE149


WE108: Query doesn't start with SELECT.

Parent topic: WE100 - WE149


WE109: Export doesn't understand the query. Last symbol read was symbol.

Parent topic: WE100 - WE149


WE110: Query contains a string that is too long for Export to process.

Parent topic: WE100 - WE149


WE002: No query exists on the query screen.

Parent topic: WE000 - WE049


WE003: Index is damaged.

Parent topic: WE000 - WE049


WE004: Unable to query auth-id.SYSTABLES to get information about item.

Parent topic: WE000 - WE049


WE005: Invalid value value for APPEND_ERR_FILE command in group number, groupname.

Parent topic: WE000 - WE049


WE006: No translation table exists with specified INCCSID and OUTCCSID.

Parent topic: WE000 - WE049


WE007: Unable to add field name name to Included list.

Parent topic: WE000 - WE049


WE008: Cannot open file filename.

The file may not exist, may be in use, disk may be full or you may be out of memory.

Parent topic: WE000 - WE049


WE039: Invalid value for number of spaces between fields.

Parent topic: WE000 - WE049


WE040: Batch file filename is invalid.

Parent topic: WE000 - WE049


WE041: Batch file contains more than one transaction.

Parent topic: WE000 - WE049


WE042: Error opening log file filename.

Parent topic: WE000 - WE049


WE043: Invalid error log file name filename.

Parent topic: WE000 - WE049


WE044: Invalid ON_ERROR value value.

Parent topic: WE000 - WE049


WE045: Invalid batch file name filename.

Parent topic: WE000 - WE049


WE046: Invalid data file name filename.

Parent topic: WE000 - WE049


WE048: Invalid value for DSETPASS.

Parent topic: WE000 - WE049


WE049: Invalid STOGROUP name.

Parent topic: WE000 - WE049


WE076: Invalid value value for PAGE_SIZE command in group number, groupname.

PAGE_SIZE = {4K | 32K};

If PAGE_SIZE is set to 4K, the storage size for each record in the table is 4K bytes; if it is set to 32K, the storage size is 32K bytes.

Parent topic: WE050 - WE099


WE077: Invalid value value for FIELDS command in group number, groupname.

FIELDS = field-name1 [, field-name2]. . .;

where the field names are listed in order, and separated by commas.

Parent topic: WE050 - WE099


WE078: Invalid value value for QUOTES command in group number, groupname.

QUOTES = {Y | N};

If QUOTES is set to N, quotes will not be placed around character strings. If QUOTES is set to Y, character strings will be surrounded by quotes.

Parent topic: WE050 - WE099


WE079: Invalid value value for SPACES command in group number, groupname.

SPACES = n;

where n is an integer between 0 and 99, corresponding to the number of spaces to be inserted between the columns of data.

Parent topic: WE050 - WE099


WE080: Unable to get information about fields in table tablename.

Parent topic: WE050 - WE099


WE081: Invalid value value for REPLACE command in group number, groupname.

REPLACE = {Y | N};

If REPLACE is set to N and the destination file exists, the data is appended to the end of the file. If REPLACE is set to Y, the data in the target file will be replaced. This statement is supported for the following formats: Free ASCII, Fixed ASCII, and SQL. With all other formats, the file is replaced instead of being appended to regardless of how REPLACE is set.

Parent topic: WE050 - WE099


WE082: Invalid value value for DATABASE command in group number, groupname.

Parent topic: WE050 - WE099


WE083: Invalid value value for TABLESPACE command in group number, groupname.

Parent topic: WE050 - WE099


WE084: Invalid value value for EDITPROC command in group number, groupname.

Parent topic: WE050 - WE099


WE085: Invalid value value for VALIDPROC command in group number, groupname.

Parent topic: WE050 - WE099


WE112: Internal error getting For Bit Data info. Contact Micro Focus Technical Support.

Parent topic: WE100 - WE149


WE113: Internal error getting Nullable info. Contact Micro Focus Technical Support.

Parent topic: WE100 - WE149


WE114: Invalid record delimiter – escape character character is not allowed.

Parent topic: WE100 - WE149


WE115: Invalid field delimiter – escape character character is not allowed.

Parent topic: WE100 - WE149


WDG019: No table on command line.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG020: Invalid option on command line.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG021: No filename on command line.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG022: Can't create batch file.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG023: No table name.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG024: No filename.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG025: No structure name.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG026: Error updating the status bar.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG001: name is not a legal table name.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG005: Unknown field type in table tablename.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG008: name is not a legal language name.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG010: Illegal computational value.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG015: Error number spawning editor name.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG016: Accessing file name.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG017: Invalid location name nameerrortype.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WDG018: No filename on command line.

Parent topic: WDG - SQL Wizard Declaration Generator Error Messages


WI009: Keyboard navigation error.

Parent topic: WI000 - WI049


WI010: Invalid value value for DSN_CRLF command in group number, groupname.

Parent topic: WI000 - WI049


WI011: No source file name specified.

Parent topic: WI000 - WI049


WI012: Unable to open Grid window.

Parent topic: WI000 - WI049


WI013: Data in field fieldname of record record-name is number characters long but field definition inumber characters.

Parent topic: WI000 - WI049


WI014: End-of-line delimiter delimiter not found while counting fields in record.

Parent topic: WI000 - WI049


WI015: Invalid value value for APPEND_ERR_FILE command in group number, groupname.

Parent topic: WI000 - WI049


WI016: Invalid value value for APPEND_REC_FILE command in group number, groupname.

Parent topic: WI000 - WI049


WI017: DSNTIAUL file file-name does not contain a complete record.

Parent topic: WI000 - WI049


WI018: Invalid value value for TIMESTAMP command in group number, groupname.

Parent topic: WI000 - WI049


WI019: Batch import file file-name not found.

Parent topic: WI000 - WI049


WI020: Batch Import file filename does not contain a group heading.

Parent topic: WI000 - WI049


WI021: Record number contains more than the maximum of number fields, or end of record not found.

Parent topic: WI000 - WI049


WI022: Table name is not specified in group number, groupname.

Parent topic: WI000 - WI049


WI023: Error writing to logfile filename, errno = error-number.

Parent topic: WI000 - WI049


WI024: Error opening logfile filename.

Parent topic: WI000 - WI049


WI025: End quote missing in field fieldname, record record of data file filename.

Parent topic: WI000 - WI049


WI026: Data exceeds 4K page size.

Parent topic: WI000 - WI049


WI027: Length specification missing from Char, Varchar, Graphic, or, VarGraphic data type, line line-number.

Character: | CH(length)
VarChar: | VC(length)
Graphic: | GR(length)
VarGraphic: | VG(length)

Example: TYPE = CH(100), VC(250), GR(45), VG(20);

Parent topic: WI000 - WI049


WI029: Number fields were specified, but number fields were found in file.

Parent topic: WI000 - WI049


WI030: Unable to open file filename.

Parent topic: WI000 - WI049


WI031: More field names were found than the number of fields specified.

Parent topic: WI000 - WI049


WI034: Field name for field number, fieldname, is longer than number characters.

Parent topic: WI000 - WI049


WI035: Incorrect field type type in ConvertDataStrToInternal().

Parent topic: WI000 - WI049


WI036: Invalid field delimiter delimiter.

Parent topic: WI000 - WI049


WI049: Invalid length in Graphic type specification type, field number.

Parent topic: WI000 - WI049


WI050: Invalid length in Vargraphic type specification type, field number.

Parent topic: WI050 - WI099


WI051: Batch file contains more than one transaction.

Parent topic: WI050 - WI099


WI052: Batch file filename is invalid.

Parent topic: WI050 - WI099


WI054: Can't get info from fixed ASCII file that doesn't contain a header line.

Parent topic: WI050 - WI099


WI055: Error opening table file filename.

Parent topic: WI050 - WI099


WI057: Error writing to table file filename.

Parent topic: WI050 - WI099


WI058: Can't access table file filename, probably locked by the XDB Server.

Parent topic: WI050 - WI099


WI059: Invalid error log file name filename.

Parent topic: WI050 - WI099


WI060: Invalid record log file name filename.

Parent topic: WI050 - WI099


WI063: Invalid error log file name filename specified in batch file filename.

Parent topic: WI050 - WI099


WI064: Invalid record log file name filename specified in batch file filename.

Parent topic: WI050 - WI099


WI065: Unable to access code page information.

Parent topic: WI050 - WI099


WI066: Number of records to recalculate must be an integer from 0 to 4,294,967,296.

Parent topic: WI050 - WI099


WI067: Commit interval must be an integer from 0 to 4,294,967,296.

Parent topic: WI050 - WI099


WI069: Quotes missing around character value string.

Parent topic: WI050 - WI099


WI071: Float value in field number, fieldname of record number is larger than IBM370's limit.

Parent topic: WI050 - WI099


WI072: Float value in field number, fieldname of record number is smaller than IBM370's limit.

Parent topic: WI050 - WI099


WI073: Unable to open View Batch window, probably out of memory.

Parent topic: WI050 - WI099


WI074: Unable to open View Data window, probably out of memory.

Parent topic: WI050 - WI099


WI077: Internal error reading batch file.

Parent topic: WI050 - WI099


WI078: Invalid value value for PAGE_SIZE command in group number, groupname.

PAGE_SIZE = {4K | 32K};

If PAGE_SIZE is set to 4K, the storage size for each record in the table is 4K bytes; if it is set to 32K, the storage size is 32K bytes.

Parent topic: WI050 - WI099


WI079: Invalid value string for FORMAT command in group number, groupname.

Parent topic: WI050 - WI099


WI080: Can't import into a non-XDB Server location using Engine Direct Write

Parent topic: WI050 - WI099


WI082: Data file filename does not contain any data.

Parent topic: WI050 - WI099


WI083: Invalid value value for ASCII_CODEPAGE command in group number, groupname.

Parent topic: WI050 - WI099


WI001: Premature end of line found, record record.

Parent topic: WI000 - WI049


WI094: Invalid value value for INSERT_MODE command in group number, groupname.

INSERT_MODE = { NORMAL | EDR };

where NORMAL indicates regular import mode and EDR indicates Engine Direct Write import

Parent topic: WI050 - WI099


WI095: Invalid value value in position number for NULL_PERM command in group number, groupname.

NULL_PERM = {Y | N | D} [, {Y | N | D}] ...;

where the specification is listed in the same order as the corresponding field names, and delimited by commas.

If NULL_PERM is set to Y, NULL values are permitted in the column. If NULL_PERM is set to N, the column is prevented from containing NULL values. If NULL_PERM is set to D, NULL values are converted to a specified default value for the column.

Parent topic: WI050 - WI099


WI096: Invalid value value in position number for USE_PIC command in group number, groupname.

USE_PIC = {Y | N | NA} [, {Y | N | NA}] ...;

where the specification (Y, N, or NA) is listed in the same order as the corresponding field names, and delimited by commas. If USE_PIC is set to Y for one of the fields, Import will apply the appropriate profile mask to the data in that field. If USE_PIC is set to N for a field, the mask will not be applied to that field. If USE_PIC is set to NA, the field is not of a type that format pictures apply to.

The USE_PIC command only applies to date, time, decimal and money fields. Masks defined in Options must be changed to match the format of the file you are importing.

Parent topic: WI050 - WI099


WI097: Invalid value value in position number for TYPES command in group number, groupname.

TYPES = field-type1 [, field-type2]. . .;

where field types are listed in the same order as corresponding field names, and delimited by commas. Valid field types are as follows:

CH[(n)] | Char (Character)
CB[(n)] | Character For Bit Data
DT[(p[s])] | Date
DC | Decimal
SF | Float (4-byte)
FL | Float
GR | Graphic
LI | Integer
LV | Long Varchar
LB | Long Varchar For Bit Data
LG | Long Vargraphic
MN | Money
SI | Smallint (Small Integer)
TM | Time
TS | Timestamp
VC[(n)] | Varchar (Variable Character)
VB[(n)] | Varchar For Bit Data
VG[(n)] | Vargraphic
Parent topic: WI050 - WI099


WI098: Invalid value value in position n for FIELDS command in group number, groupname.

FIELDS = field-name1 [, field-name2]. . .;

where the field names are listed in order, and separated by commas.

Parent topic: WI050 - WI099


WI099: Invalid value value for TABLE command in group number, groupname.

TABLE = table-name;

where table-name is the name of the table.

Parent topic: WI050 - WI099


WI100: Invalid value value for FILENAME command in group number, groupname.

FILENAME = filename;

where filename is the full path specification and file of the source file. For example:

FILENAME = C:\XDB\APPS\employee.asc;

specifies the location of the source file as C:\XDB\APPS\ and the file name EMPLOYEE.ASC.

Parent topic: WI100 - WI149


WI101: Invalid value value for ON_ERROR command in group number, groupname.

ON_ERROR = { SKIP | INS_NULL | QUIT | END_ALL | PROMPT };

If ON_ERROR is set to SKIP, a record that contains invalid data is skipped and Import goes on to the next record. If ON_ERROR is set to INS_NULL, a NULL is placed in the field if the field is nullable. If ON_ERROR is set to QUIT, the batch import will be terminated if invalid data is found. If ON_ERROR is set to END_ALL, all batch import processing is terminated. If ON_ERROR is set to PROMPT, the user is prompted for further action.

Parent topic: WI100 - WI149


WI102: Invalid value value for COMMIT_INTERVAL command in group number, groupname.

COMMIT_INTERVAL = {n};

where n is a number between 0 and 2,147,483,647.

Parent topic: WI100 - WI149


WI103: The number of values for the FIELDS command in group number, groupname does not match the number of fields found in a previous command.

Parent topic: WI100 - WI149


WI104: The number of values for the TYPES command in group number, groupname does not match the number of fields found in a previous command.

Parent topic: WI100 - WI149


WI105: The number of values for the USE_PIC command in group number, groupname does not match the number of fields found in a previous command.

Parent topic: WI100 - WI149


WI106: The number of values for the NULL_PERM command in group number, groupname does not match the number of fields found in a previous command.

Parent topic: WI100 - WI149


WI107: The number of values for the OFFSETS command in group number, groupname does not match the number of fields found in a previous command.

Parent topic: WI100 - WI149


WI108: The number of values for the SRC_LENS command in group number, groupname does not match the number of fields found in a previous command.

Parent topic: WI100 - WI149


WI109: The number of values for the EBCDIC_TO_ASCII command in group number, groupname does not match the number of fields found in a previous command.

Parent topic: WI100 - WI149


WI110: Batch file filename is empty.

Parent topic: WI100 - WI149


WI111: Unknown batch command command in group number, groupname.

Parent topic: WI100 - WI149


WI112: Short float value in field number, fieldname of record number is larger than IBM370's limit.

Parent topic: WI100 - WI149


WI113: Short float value in field number, fieldname of record number is smaller than IBM370's limit.

Parent topic: WI100 - WI149


WI115: Error opening batch file for writing.

Parent topic: WI100 - WI149


WI116: Error writing to batch file.

Parent topic: WI100 - WI149


WI117: Invalid value value for SRC_ASCII_CODEPAGE command in group Tnumber, Tname.

Parent topic: WI100 - WI149


WI118: Invalid value value for DST_ASCII_CODEPAGE command in group Tnumber, Tname.

Parent topic: WI100 - WI149


WI119: Invalid batch file name filename.

Parent topic: WI100 - WI149


WI121: Can't import data file filename into table tablename because data file has number columns but table has number columns.

Parent topic: WI100 - WI149


WI002: Number field(s) were found in record number; record should contain number field(s).

Parent topic: WI000 - WI049


WI003: The character character in position position in heading line of Fixed ASCII file filename is not allowed in a column name.

Parent topic: WI000 - WI049


WI004: The maximum number of open Import windows has been reached.

Parent topic: WI000 - WI049


WI005: Table name is not specified.

Parent topic: WI000 - WI049


WI007: Invalid value number for varchar length; length must be no greater than number.

Parent topic: WI000 - WI049


WI008: No translation table exists with specified INCCSID and OUTCCSID.

Parent topic: WI000 - WI049


WI037: Invalid record delimiter delimiter.

Parent topic: WI000 - WI049


WI038: Invalid source file name filename.

Parent topic: WI000 - WI049


WI039: Invalid table name.

Parent topic: WI000 - WI049


WI040: Invalid value for number of spaces between fields.

Parent topic: WI000 - WI049


WI041: Data file filename is empty.

Parent topic: WI000 - WI049


WI044: Invalid character (character) found in field name in field number in header line of data file.

Parent topic: WI000 - WI049


WI047: Invalid length in type specification type, field number.

Parent topic: WI000 - WI049


WI048: Invalid length in Character or Varchar type specification type, field number.

Parent topic: WI000 - WI049


WI084: Invalid value value for EBCDIC_CODEPAGE command in group number, groupname.

Parent topic: WI050 - WI099


WI085: Invalid value value for FLD_DELIMITER command in group number, groupname.

FLD_DELIMITER = {'xx'|'<ascii1>'} {'xx'|'<ascii2>'} [...];

where 'xx' is one or more keyboard characters and 'ascii' is an ASCII decimal code. The angle brackets around the ASCII code are required. Quote marks around delimiters are optional.

For example, to instruct the SQLWizard Import utility to use a comma as the delimiter in your file, use the command:

FLD_DELIMITER = , ;
Parent topic: WI050 - WI099


WI086: Invalid value value for REC_DELIMITER command in group number, groupname.

REC_DELIMITER = {'xx' | '<ascii>' ...} ;

where 'xx' is a character string delimiter and 'ascii' is an ASCII decimal code. The angled brackets around the ASCII code are required. The default delimiter is a space character (ASCII code <032>).

Parent topic: WI050 - WI099


WI087: Invalid value value for HEADING command in group number, groupname.

HEADING={Y | N};

Set HEADING equal to N if there is no heading in the source file. Set HEADING equal to Y if the first row is to be considered a heading in the source file.

Parent topic: WI050 - WI099


WI088: Invalid value value in position number for EBCDIC_TO_ASCII command in group number, groupname.

EBCDIC_TO_ASCII = {Y | N | NA} [, {Y | N | NA}]...;

where the number of Ys, Ns and NAs is equal to the number of fields in the table. If EBCDIC_TO_ASCII is set to N, data are not converted to ASCII. If EBCDIC_TO_ASCII is set to Y (default), the data are assumed to be EBCDIC and are converted to the ASCII equivalent. If EBCDIC_TO_ASCII is set to NA, conversion is not applicable for the field type.

Parent topic: WI050 - WI099


WI089: Invalid value value in position number for SRC_LENS command in group number, groupname.

SRC_LENS = length1 [, length2] ...;

where the lengths are listed in the same order as the corresponding field names, and delimited by commas. For example:

SRC_LENS = 8,10,20,15,2,5,4,20,30;

specifies the column widths of the Fixed ASCII source file being read.

Parent topic: WI050 - WI099


WI090: Invalid value value in position number for OFFSETS command in group number, groupname.

OFFSETS = start-pos1 [, start-pos2]. . .;

where the starting positions are listed in the same order as the corresponding field names, and delimited by commas. For example:

OFFSETS = 1,11,23,35,57,74,85,91,113;

specifies the starting positions of the columns in a Fixed ASCII source file.

To determine the starting positions, it may be necessary to examine the file using the SOURCE FILE command from the View menu or a text editor.

Parent topic: WI050 - WI099


WI091: Invalid value value for SPACES command in group number, groupname.

SPACES = {n};

where n is some number between 0-99. The default is 2.

Parent topic: WI050 - WI099


WI092: Invalid value value for QUOTES command in group number, groupname.

QUOTES = {Y | N};

Set QUOTES to N if there are no quotes around character strings in the source file. Set QUOTES to Y if the character strings in the source file are surrounded by quotes.

Parent topic: WI050 - WI099


WI093: Invalid value value for REPLACE command in group number, groupname.

REPLACE = {Y | N};

If REPLACE is set to N, the imported data will append to the existing data. If REPLACE is set to Y, the imported data will replace the data in the table.

Parent topic: WI050 - WI099


WI122: Batch specification in group Tnumber, Tname in file filename is not sufficient to create new table tablename.

Parent topic: WI100 - WI149


WI123: Table tablename contains number columns but batch file specifies number columns.

Parent topic: WI100 - WI149


WI124: Invalid value Value for varchar length. Length must be no greater than page size Size.

If the current page size is set to 4K, increase it to 32K in the Import dialog box and try importing the file again. If this does not correct the problem, verify that the DSNTIAUL file contains valid, non-corrupted data.

Parent topic: WI100 - WI149


WI125: Invalid record delimiter - escape character character is not allowed.

Parent topic: WI100 - WI149


WI126: Invalid field delimiter – escape character character is not allowed.

Parent topic: WI100 - WI149


L104: Illegal symbol token. Valid symbols are token-list.

Parent topic: L100 - L149


L105: Invalid string.

Parent topic: L100 - L149


L107: The name name is too long. Maximum allowable size is size.

Parent topic: L100 - L149


L108: THE NAME name IS QUALIFIED INCORRECTLY

Parent topic: L100 - L149


L109: clause clause is not permitted.

Parent topic: L100 - L149


L110: Invalid hex literal beginning string.

Parent topic: L100 - L149


L111: A column function does not include a column name.

Parent topic: L100 - L149


L112: The operand of a column function is another column function.

Parent topic: L100 - L149


L113: Invalid character found in name: name. Reason code - reason-code.

Parent topic: L100 - L149


L114: THE LOCATION NAME location DOES NOT MATCH THE CURRENT SERVER

Parent topic: L100 - L149


L115: A predicate is invalid because operation operation is followed by a list, any or all.

Parent topic: L100 - L149


L117: The number of insert values is not the same as the number of object columns.

Parent topic: L100 - L149


L118: The object table or view of the insert/delete/update is in a FROM clause.

Parent topic: L100 - L149


L119: A column in a HAVING clause is not included in the GROUP BY clause.

Parent topic: L100 - L149


L120: A WHERE clause or a SET clause includes a column function.

Parent topic: L100 - L149


L121: Column name is used more than once in insert or update.

Parent topic: L100 - L149


L122: Select with no GROUP BY has column name/function or a column name not in GROUP BY.

Parent topic: L100 - L149


L123: THE PARAMETER IN POSITION n IN THE FUNCTION name MUST BE A CONSTANT OR KEYWORD

Parent topic: L100 - L149


L125: An integer in the ORDER BY clause does not identify a column of the result.

Parent topic: L100 - L149


L126: The SELECT statement contains both an UPDATE clause and an ORDER BY clause.

Parent topic: L100 - L149


L127: Distinct is specified more than once in a subselect.

Parent topic: L100 - L149


L128: Invalid use of NULL in a predicate.

Parent topic: L100 - L149


L129: The statement contains too many table names.

Parent topic: L100 - L149


L130: Escape clause with more than one char or string contains invalid esc char.

Parent topic: L100 - L149


L131: Statement with LIKE predicate has incompatible data types.

Parent topic: L100 - L149


L132: AN OPERAND OF value IS NOT VALID

Parent topic: L100 - L149


L151: Update is invalid because the descr of column name cannot be updated.

Parent topic: L150 - L199


L152: THE DROP clause CLAUSE IN THE ALTER STATEMENT IS INVALID BECAUSE constraint-name IS A constraint-type

Parent topic: L150 - L199


L153: The CREATE VIEW statement does not include a required column list.

Parent topic: L150 - L199


L154: CREATE VIEW failed because definition with union, union all, or remote object.

Parent topic: L150 - L199


L156: The statement does not identify a table.

Parent topic: L150 - L199


L157: name is not the name of a table needed for a foreign key clause.

Parent topic: L150 - L199


L158: Number of columns specified for view is not equal to number of columns in select.

Parent topic: L150 - L199


L159: DROP or COMMENT ON token identifies a(n) token.

Parent topic: L150 - L199


L160: The WITH CHECK OPTION cannot be used for the specified view.

Parent topic: L150 - L199


L161: INSERT or UPDATE not allowed because result row does not satisfy view definition.

Parent topic: L150 - L199


L164: authid does not have privilege to create a view with qualification authorization.

Parent topic: L150 - L199


L170: The number of arguments specified for function is invalid.

Parent topic: L150 - L199


L171: The data type, length, or value of argument argument of function is invalid.

Parent topic: L150 - L199


L173: UR IS SPECIFIED ON THE WITH CLAUSE BUT THE CURSOR IS NOT READ-ONLY

Parent topic: L150 - L199


L180: The string representation of a datetime value has invalid syntax.

Parent topic: L150 - L199


L181: The string representation of a datetime value is not a valid datetime value.

Parent topic: L150 - L199


L182: An arithmetic expression with a datetime value is invalid.

Parent topic: L150 - L199


L183: Arithmetic operation on date or timestamp has result not in valid range.

Parent topic: L150 - L199


L184: Arithmetic expression with a datetime value contains a parameter marker.

Parent topic: L150 - L199


L185: Local format option was used with date or time with no local exit.

Parent topic: L150 - L199


L186: Local date or time length was increased and the execute program uses old length.

Parent topic: L150 - L199


L187: Reference to a current date/time special register is invalid.

Parent topic: L150 - L199


L188: The string representation of a name is invalid.

Parent topic: L150 - L199


L189: CCSID ccsid is unknown or invalid for the data type or subtype.

Parent topic: L150 - L199


L190: ATTRIBUTES OF column-name IN table-name ARE NOT COMPATIBLE WITH EXISTING COLUMN

Parent topic: L150 - L199


L191: A string cannot be used because it is invalid mixed data.

Parent topic: L150 - L199


L007: Statement contains the illegal character character.

Parent topic: L000 - L099


L219: The required explanation table name does not exist.

Parent topic: L200 - L299


L220: Column name in explanation table name is not defined properly.

Parent topic: L200 - L299


L221: "opt cols" in explanation table name is incomplete. Opt col name is missing.

Parent topic: L200 - L299


L240: THE PART CLAUSE OF A LOCK TABLE STATEMENT IS INVALID

Parent topic: L200 - L299


L250: Local location name is not defined when procession a 3-part object name.

Parent topic: L200 - L299


L251: Token name is not valid.

Parent topic: L200 - L299


L301: Value of input host variable number number not used because wrong data type.

Parent topic: L300 - L399


L302: Value of input variable number number is invalid for the target column.

Parent topic: L300 - L399


L303: Cannot assign value to output host variable number number. Types not comparable.

Parent topic: L300 - L399


L304: Value with data type type cannot go in host variable at position number.

Parent topic: L300 - L399


L305: Output host variable number number cannot be NULL when there is no indicator.

Parent topic: L300 - L399


L309: Predicate is invalid because a referenced host variable has the NULL value.

Parent topic: L300 - L399


L310: DECIMAL HOST VARIABLE OR PARAMETER number CONTAINS NON-DECIMAL DATA

Parent topic: L300 - L399


L311: Length of input host variable number number is negative or greater than the max.

Parent topic: L300 - L399


L312: Undefined or unusable host variable name.

Parent topic: L300 - L399


L313: Number of host variables specified "< >" to number of parameter markers.

Parent topic: L300 - L399


L314: The statement contains an ambiguous host variable reference.

Parent topic: L300 - L399


L327: CANNOT INSERT ROW BECAUSE IT IS OUTSIDE THE BOUND OF THE PARTITION RANGE

Parent topic: L300 - L399


L330: String cannot be translated. Reason reason, char code-point, host var number.

Parent topic: L300 - L399


L331: String cannot be assigned to a host variable. Reason reason, char code-point, pos number.

Parent topic: L300 - L399


L332: SYSSTRINGS does not define a translation CCSID ccsid to ccsid.

Parent topic: L300 - L399


L333: String variable subtype not same as bind time and diff cannot be resolved.

Parent topic: L300 - L399


L338: AN ON CLAUSE IS INVALID

Parent topic: L300 - L399


L350: INVALID SPECIFICATION OF A LARGE OBJECT COLUMN

Parent topic: L300 - L399


L351: UNSUPPORTED SQLTYPE IN POSITION position-number OF SELECT-LIST

Parent topic: L300 - L399


L352: UNSUPPORTED SQLTYPE IN POSITION position-number OF INPUT-LIST

Parent topic: L300 - L399


L010: The string constant beginning character is not terminated.

Parent topic: L000 - L099


L402: Arithmetic function/operator "< >" applied to character/datetime data.

Parent topic: L400 - L449


L404: THE SQL STATEMENT SPECIFIES A STRING THAT IS TOO LONG

Parent topic: L400 - L449


L405: Numeric literal literal is out of range.

Parent topic: L400 - L449


L406: A calculated or derived numeric value not within range of its object column.

Parent topic: L400 - L449


L407: COLUMN column-name CANNOT CONTAIN NULL VALUES IN INSERT, UPDATE OR SET

Parent topic: L400 - L449


L408: THE VALUE IS NOT COMPATIBLE WITH THE DATA TYPE OF ITS TARGET

Parent topic: L400 - L449


L409: Invalid operand of a count function.

Parent topic: L400 - L449


L410: Floating point literal literal contains more than 30 characters.

Parent topic: L400 - L449


L411: Current datetime, SQLID or user keyword cannot be used as specified.

Parent topic: L400 - L449


L412: The SELECT clause of a subquery specifies multiple columns.

Parent topic: L400 - L449


L413: OVERFLOW OCCURRED DURING NUMERIC DATA TYPE CONVERSION

Parent topic: L400 - L449


L414: Numeric or datetime column name is specified in a LIKE predicate.

Parent topic: L400 - L449


L415: Cols, number, of the operands of a union do not have comparable col. descr.

Parent topic: L400 - L449


L416: An operand of a union contains a long string column.

Parent topic: L400 - L449


L417: PREPARE string includes parameter markers as operand of same operator.

Parent topic: L400 - L449


L418: A string to be prepared contains an invalid use of parameter markers.

Parent topic: L400 - L449


L419: Decimal divide operation is invalid because the result has a negative scale.

Parent topic: L400 - L449


L420: STRING ARGUMENT VALUE NOT ACCEPTABLE TO FUNCTION function-name

Parent topic: L400 - L449


L421: Operand of a union or union all does not have the same number of columns.

Parent topic: L400 - L449


L423: INVALID VALUE FOR LOCATOR IN POSITION position-number

Parent topic: L400 - L449


L426: Dynamic commit not valid at application server where updates not allowed.

Parent topic: L400 - L449


L427: Dynamic rollback not valid at application server where updates not allowed.

Parent topic: L400 - L449


L430: routine-typeroutine-name (specific-name) HAS ABNORMALLY TERMINATED

Parent topic: L400 - L449


L433: VALUE value IS TOO LONG

Parent topic: L400 - L449


L435: INVALID SQLSTATE sqlstate SPECIFIED IN RAISE_ERROR OR IN A SIGNAL SQLSTATE

Parent topic: L400 - L449


L438: APPLICATION RAISED ERROR WITH DIAGNOSTIC TEXT: text

Parent topic: L400 - L449


L029: INTO clause required.

Parent topic: L000 - L099


L456: FUNCTION function-name, SPECIFIC specific-name EXISTS IN THE SCHEMA

Parent topic: L450 - L499


L457: ILLEGAL USE OF name; IT IS RESERVED FOR SYSTEM USE

Parent topic: L450 - L499


L458: FUNCTION function-name COULD NOT BE FOUND BY SIGNATURE

Parent topic: L450 - L499


L461: VALUE OF TYPE source-data-type CANNOT BE CAST TO target-data-type

Parent topic: L450 - L499


L463: routine-name (specific-name) RETURNED sqlstate, DIAGNOSTIC TEXT text

Parent topic: L450 - L499


L469: CALL STATEMENT NEEDS AN OUTPUT HOST VARIABLE FOR PARAMETER number

Parent topic: L450 - L499


L470: CALL STATEMENT SPECIFIED A NULL VALUE FOR INPUT PARAMETER number

Parent topic: L450 - L499


L471: INVOCATION OF FUNCTION/PROCEDURE name FAILED DUE TO REASON rc

Parent topic: L450 - L499


L472: CURSOR cursor-name LEFT OPEN BY FUNCTION function-name (specific-name)

Parent topic: L450 - L499


L473: USER DEFINED TYPE CANNOT BE THE SAME NAME AS A BUILT-IN TYPE

Parent topic: L450 - L499


L475: type-1 RESULT CANNOT BE CAST TO type-2 RETURN TYPE OF THE function-name

Parent topic: L450 - L499


L476: FUNCTION function-name NAMED WITHOUT SIGNATURE, FUNCTION NOT UNIQUE

Parent topic: L450 - L499


L478: ACTION ON type1 CANNOT BE PROCESSED; name OF TYPE type2 DEPENDENT ON IT

Parent topic: L450 - L499


L480: PROCEDURE procedure-name HAS NOT YET BEEN CALLED

Parent topic: L450 - L499


L482: PROCEDURE procedure-name RETURNED NO LOCATORS

Parent topic: L450 - L499


L483: PARMS FOR function-name DOES NOT MATCH NUMBER OF PARMS OF SOURCE FUNCTION

Parent topic: L450 - L499


L487: object-typeobject-name USED SQL BUT WAS CREATED WITH NOSQL OPTION

Parent topic: L450 - L499


L491: FUNCTION function-name MUST HAVE RETURNS, AND EITHER EXTERNAL OR SOURCE

Parent topic: L450 - L499


L492: function-name PARAMETER number HAS MISMATCH WITH A SOURCE FUNCTION

Parent topic: L450 - L499


L495: EST COST OF estimate-amount1 PROCESSOR SECONDS EXCEEDS RESOURCE LIMIT

Parent topic: L450 - L499


L496: SQL STATEMENT REFERENCES A RESULT SET NOT CREATED BY THE CURRENT SERVER

Parent topic: L450 - L499


L497: INTERNAL IDENTIFIERS LIMIT HAS BEEN EXCEEDED FOR DATABASE database-name

Parent topic: L450 - L499


L499: CURSOR cursor-name ALREADY ASSIGNED TO procedure-name RESULT SET

Parent topic: L450 - L499


L500: IDENTIFIED CURSOR WAS CLOSED WHEN THE CONNECTION WAS DESTROYED

Parent topic: L500 - L549


L501: Cursor identified in a FETCH or CLOSE statement is not open.

Parent topic: L500 - L549


L502: The cursor identified in an OPEN statement is already open.

Parent topic: L500 - L549


L060: Invalid type specification: spec.

Parent topic: L000 - L099


L516: The described statement does not identify a prepared statement.

Parent topic: L500 - L549


L517: Cursor name does not identify a prepared SELECT statement.

Parent topic: L500 - L549


L518: The EXECUTE statement does not identify a valid prepared statement.

Parent topic: L500 - L549


L519: PREPARE identifies SELECT statement of the open cursor name.

Parent topic: L500 - L549


L525: SQL cannot execute, error at bind for section sectno, package pkgname, consistency token Xcontoken.

Parent topic: L500 - L549


L526: REQUESTED FUNCTION DOES NOT APPLY TO GLOBAL TEMPORARY TABLES

Parent topic: L500 - L549


L530: The INSERT or UPDATE value of foreign key name is invalid.

Parent topic: L500 - L549


L531: Primary key in parent has dependent rows in relation name.

Parent topic: L500 - L549


L532: The relation name restricts the deletion of row with RID X number.

Parent topic: L500 - L549


L533: Invalid multiple-row insert.

Parent topic: L500 - L549


L534: The primary key cannot be updated because of multiple-row update.

Parent topic: L500 - L549


L535: Invalid update or delete with WHERE CURRENT OF.

Parent topic: L500 - L549


L536: Delete is invalid because table name can be affected by the operation.

Parent topic: L500 - L549


L537: Primary key/foreign key identifies column name more than once.

Parent topic: L500 - L549


L538: Foreign key name does not match description of primary key of table name.

Parent topic: L500 - L549


L539: Table name does not have a primary key.

Parent topic: L500 - L549


L540: Definition of table name does not have primary index.

Parent topic: L500 - L549


L541: FOREIGN KEY key-name HAS DUPLICATE REFERENTIAL CONSTRAINT

Parent topic: L500 - L549


L542: name cannot be a column of primary key because it can contain NULL values.

Parent topic: L500 - L549


L543: CANNOT DELETE ROW IN PARENT TABLE; RESTRICTED BY CONSTRAINT check-constraint

Parent topic: L500 - L549


L544: CANNOT ADD CHECK CONSTRAINT; EXISTING ROW VIOLATES THE CHECK CONSTRAINT

Parent topic: L500 - L549


L545: The requested operation is not allowed because of the check constraint CheckConstraint.

Parent topic: L500 - L549


L546: CHECK CONSTRAINT constraint-name IS INVALID

Parent topic: L500 - L549


L548: A CHECK CONSTRAINT THAT IS DEFINED WITH column-name IS INVALID

Parent topic: L500 - L549


L549: The Statement statement is not allowed for ObjectType1ObjectName because the bind option dynamicrules in the ObjectType2 is in effect.

Parent topic: L500 - L549


L551: Authid does not have privileges to perform operation Name on this object.

Parent topic: L550 - L599


L084: UNACCEPTABLE SQL STATEMENT.

Parent topic: L000 - L099


L573: table-name DOES NOT HAVE UNIQUE KEY WITH SPECIFIED COLUMN NAMES

Parent topic: L550 - L599


L574: THE DEFAULT VALUE CONFLICTS WITH DEFINITION OF COLUMN column-name

Parent topic: L550 - L599


L577: DEFINITION OF object-typeobject-name DID NOT SPECIFY MODIFY DATA

Parent topic: L550 - L599


L579: DEFINITION OF object-typeobject-name DID NOT SPECIFY READ OR MODIFY DATA

Parent topic: L550 - L599


L580: THE RESULT-EXPRESSIONS OF A CASE EXPRESSION CANNOT ALL BE NULL

Parent topic: L550 - L599


L581: RESULT-EXPRESSION DATA TYPES OF CASE EXPRESSION ARE NOT COMPATIBLE

Parent topic: L550 - L599


L582: WHEN-CLAUSE CONDITION CANNOT BE QUANTIFIED, IN, OR EXISTS PREDICATE

Parent topic: L550 - L599


L583: INVALID USE OF FUNCTION; function-name NOT DETERMINISTIC/EXTERNAL ACTION

Parent topic: L550 - L599


L585: SCHEMA NAME schema-name CANNOT APPEAR MORE THAN ONCE IN THE CURRENT PATH

Parent topic: L550 - L599


L586: TOTAL LENGTH OF CURRENT PATH SPECIAL REGISTER CANNOT EXCEED 254 CHARACTERS

Parent topic: L550 - L599


L587: A LIST OF ITEM-REFERENCES ARE NOT IN THE SAME FAMILY

Parent topic: L550 - L599


L590: PARAMETER parameter-name NOT UNIQUE FOR ROUTINE routine-name

Parent topic: L550 - L599


L592: NOT AUTHORIZED TO CREATE FUNCTIONS/PROCEDURES IN WLM ENV env-name

Parent topic: L550 - L599


L601: Name of the object to be created identical to existing name name.

Parent topic: L600 - L649


L602: Too many columns specified in a CREATE INDEX.

Parent topic: L600 - L649


L603: Unique index cannot be created. The table has rows with duplicate columns.

Parent topic: L600 - L649


L604: Column definition specifies an invalid length, precision, or scale attribute.

Parent topic: L600 - L649


L607: Operation operation is not defined for system tables.

Parent topic: L600 - L649


L611: ONLY LOCKMAX 0 CAN BE SPECIFIED WHEN LOCK SIZE IS TABLESPACE OR TABLE

Parent topic: L600 - L649


L612: name is a duplicate column name.

Parent topic: L600 - L649


L613: The primary key is too long or has too many columns.

Parent topic: L600 - L649


L614: Cannot create index. Sum of internal lengths of columns > allowable.

Parent topic: L600 - L649


L615: op is not allowed on a package in use.

Parent topic: L600 - L649


L616: obj-typeobj-name CANNOT BE DROPPED; REFERENCED BY obj-typeobj-name

Parent topic: L600 - L649


L617: TYPE 1 INDEX IS NOT VALID FOR TABLE table-name

Parent topic: L600 - L649


L618: Operation operation is not allowed on system databases.

Parent topic: L600 - L649


L101: The statement is too long or too complex.

Parent topic: L100 - L149


L629: No set NULL because foreign key name cannot contain NULL values.

Parent topic: L600 - L649


L630: WHERE NOT NULL SPECIFICATION IS INVALID FOR TYPE 1 INDEXES

Parent topic: L600 - L649


L631: Foreign key name is too long or has too many columns.

Parent topic: L600 - L649


L632: Cannot define table as dependent of name due to delete rule restriction.

Parent topic: L600 - L649


L633: The delete rule must be delete.

Parent topic: L600 - L649


L634: The delete rule must not be cascade.

Parent topic: L600 - L649


L635: The delete rules cannot be different or cannot be set NULL.

Parent topic: L600 - L649


L636: Partitioning keys not specified in ascending/descending order.

Parent topic: L600 - L649


L637: Duplicate keyword keyword.

Parent topic: L600 - L649


L638: Table name cannot be created. Column definition is missing.

Parent topic: L600 - L649


L639: Column of foreign key with delete rule of set NULL cannot be in partition index.

Parent topic: L600 - L649


L640: LOCKSIZE ROW CANNOT BE SPECIFIED; TABLE HAS TYPE 1 INDEX

Parent topic: L600 - L649


L642: TOO MANY COLUMNS IN UNIQUE CONSTRAINTS

Parent topic: L600 - L649


L643: CHECK CONSTRAINT EXCEEDS MAXIMUM ALLOWABLE LENGTH

Parent topic: L600 - L649


L644: INVALID VALUE SPECIFIED FOR KEYWORD keyword IN statement-type STATEMENT

Parent topic: L600 - L649


L646: Cannot create table name in partitioned default tablespace name.

Parent topic: L600 - L649


L647: Bufferpool name cannot be specified. It has not been activated.

Parent topic: L600 - L649


L652: Violation of installation-defined edit or validation procedure proc.

Parent topic: L650 - L699


L650: THE ALTER INDEX CANNOT BE EXECUTED, REASON reason-code

Parent topic: L650 - L699


L651: TABLE DESCRIPTION EXCEEDS MAXIMUM SIZE OF OBJECT DESCRIPTOR

Parent topic: L650 - L699


L653: Table name in partitioned tablespace name not available.

Parent topic: L650 - L699


L655: CREATE OR ALTER STOGROUP IS INVALID

Parent topic: L650 - L699


L658: object-type CANNOT BE DROPPED USING THE statement STATEMENT

Parent topic: L650 - L699


L660: Cannot create index name on partitioned tablespace name.

Parent topic: L650 - L699


L661: Cannot create index name on partitioned tablespace name.

Parent topic: L650 - L699


L662: Cannot create a partitioned index on a non-partitioned tablespace name.

Parent topic: L650 - L699


L102: Size of string constant starting string is too great.

Parent topic: L100 - L149


L676: A 32K page bufferpool may not be used for an index.

Parent topic: L650 - L699


L677: Insufficient virtual storage for bufferpool expansion.

Parent topic: L650 - L699


L678: literal specified for index limit key must conform to data type type.

Parent topic: L650 - L699


L679: Object name cannot be created. A drop is pending on the object.

Parent topic: L650 - L699


L680: Too many columns specified for a table.

Parent topic: L650 - L699


L681: Column name in violation of installation-defined field procedure name.

Parent topic: L650 - L699


L682: Field procedure proc could not be loaded.

Parent topic: L650 - L699


L683: Invalid column type for fieldproc or bit data option, column.

Parent topic: L650 - L699


L684: The length of literal list beginning string is too long.

Parent topic: L650 - L699


L685: Invalid field type column.

Parent topic: L650 - L699


L686: Cannot compare column defined by one field procedure to one defined by another.

Parent topic: L650 - L699


L687: Field types incomparable.

Parent topic: L650 - L699


L688: Incorrect data returned from field procedure, column, msgno.

Parent topic: L650 - L699


L689: Too many columns defined for a dependent table.

Parent topic: L650 - L699


L690: Statement is rejected by data def ctrl support, reason reason.

Parent topic: L650 - L699


L691: The required registrations table table does not exist.

Parent topic: L650 - L699


L692: Unique index index-name in table table-name does not exist.

Parent topic: L650 - L699


L693: Column column is not defined properly.

Parent topic: L650 - L699


L694: DDL STMT CANNOT EXECUTE; DROP PENDING ON DDL REGISTRATION TABLE table-name

Parent topic: L650 - L699


L696: TRIGGER trigger-name CONTAINS INVALID USE OF NAME name, REASON reason-code

Parent topic: L650 - L699


L697: CORR. NAMES NOT ALLOWED IN TRIGGER WITH "FOR EACH STATEMENT" OR "BEFORE"

Parent topic: L650 - L699


L713: REPLACEMENT VALUE value FOR special-register IS INVALID

Parent topic: L700 - L799


L715: Prog program dep on function of the release from which fallback has occurred.

Parent topic: L700 - L799


L716: Program program precompiled with wrong level for this release.

Parent topic: L700 - L799


L717: object dependent on function of release from which fallback has occurred.

Parent topic: L700 - L799


L718: REBIND failed because IBMREQD of ibmreqd is invalid.

Parent topic: L700 - L799


L103: literal is an invalid numeric literal.

Parent topic: L100 - L149


L730: The parent of a table in a read-only database must also be in the database.

Parent topic: L700 - L799


L731: User-defined dataset dsname must be defined with SHAREOPTIONS(1,3).

Parent topic: L700 - L799


L732: Table space or index space has not been defined on the owning subsystem.

Parent topic: L700 - L799


L733: The description of a table space, index space or ROSHARE READ db must be consistent.

Parent topic: L700 - L799


L734: The ROSHARE attr of a database cannot be altered from ROSHARE READ.

Parent topic: L700 - L799


L735: Database dbid is not longer a shared database.

Parent topic: L700 - L799


L736: Invalid OBID obid specified.

Parent topic: L700 - L799


L737: Implicit table space not allowed.

Parent topic: L700 - L799


L739: ALTER function-name FAILED; PARALLEL PROCESSED FUNCTIONS CANNOT MODIFY DATA

Parent topic: L700 - L799


L740: FUNCTION name THAT MODIFIES SQL DATA IS NOT VALID IN CURRENT CONTEXT

Parent topic: L700 - L799


L741: WORK FILE DATABASE IS ALREADY DEFINED FOR MEMBER member-name

Parent topic: L700 - L799


L742: DSNDB07 IS THE IMPLICIT WORK FILE DATABASE

Parent topic: L700 - L799


L746: SQL STATEMENT IN name VIOLATES THE NESTING SQL RESTRICTION

Parent topic: L700 - L799


L747: table-name NOT AVAILABLE UNTIL AUX TABLES AND INDEXES HAVE BEEN CREATED

Parent topic: L700 - L799


L748: AN INDEX ALREADY EXISTS ON AUXILIARY TABLE table-name

Parent topic: L700 - L799


L750: TABLE source-name CANNOT BE RENAMED; REFERENCED BY EXISTING DEFINITIONS

Parent topic: L700 - L799


L751: object-typeobject-name (specific-name) ATTEMPTED TO EXECUTE statement

Parent topic: L700 - L799


L752: CONNECT statement invalid because the process is not in the connectable state.

Parent topic: L700 - L799


L763: INVALID TABLE SPACE NAME table-space-name

Parent topic: L700 - L799


L764: LOB TABLE SPACE AND ITS BASE TABLE SPACE MUST BE IN SAME DATABASE

Parent topic: L700 - L799


L765: TABLE IS NOT COMPATIBLE WITH DATABASE

Parent topic: L700 - L799


L766: REQUESTED OPERATION NOT PERMITTED ON AUXILIARY TABLE OF STATEMENT OBJECT

Parent topic: L700 - L799


L767: MISSING OR INVALID COLUMN SPECIFICATION FOR INDEX index-name

Parent topic: L700 - L799


L768: AUXILIARY TABLE ALREADY EXISTS FOR THE SPECIFIED COLUMN OR PARTITION

Parent topic: L700 - L799


L769: SPECIFICATION OF AUX TABLE DOES NOT MATCH CHARACTERISTICS OF BASE TABLE

Parent topic: L700 - L799


L770: TABLE table-name CANNOT HAVE LOB COLUMN UNLESS IT ALSO HAS ROWID COLUMN

Parent topic: L700 - L799


L133: Column function in subquery of HAVING invalid because expression applies op to corr ref.

Parent topic: L100 - L149


L134: IMPROPER USE OF LONG STRING COLUMN column-name OR AN EXPRESSION OF MAXIMUM LENGTH GREATER THAN 255.

Parent topic: L100 - L149


L136: Sort cannot be executed because sort key length > 4000 bytes.

Parent topic: L100 - L149


L137: THE LENGTH RESULTING FROM operation IS GREATER THAN maximum-length

Parent topic: L100 - L149


L138: The second or third argument of the SUBSTR function is out of range.

Parent topic: L100 - L149


L142: THE SQL STATEMENT IS NOT SUPPORTED

Parent topic: L100 - L149


L144: Invalid section number number.

Parent topic: L100 - L149


L147: ALTER FUNCTION function-name FAILED BECAUSE SOURCE FUNCTIONS CANNOT BE ALTERED

Parent topic: L100 - L149


L148: THE SOURCE TABLE source-name CANNOT BE RENAMED OR ALTERED

Parent topic: L100 - L149


L150: The INSERT, DELETE or UPDATE object is a view and is not permitted.

Parent topic: L150 - L199


L197: QUALIFIED NAMES IN ORDER BY NOT PERMITTED WITH UNION OR UNION ALL

Parent topic: L150 - L199


L198: Operand of the PREPARE or EXECUTE IMMEDIATE statement is blank or empty.

Parent topic: L150 - L199


L199: Illegal use of keyword keyword. Token token was expected.

Parent topic: L150 - L199


L203: A reference to column name is ambiguous.

Parent topic: L200 - L299


L204: name is an undefined name.

Parent topic: L200 - L299


L205: col is not a column of table tablename.

Parent topic: L200 - L299


L206: name is not a column of a table in an INSERT, UPDATE or FROM clause.

Parent topic: L200 - L299


L207: ORDER BY invalid because the column name applies to result of UNION or UNION ALL.

Parent topic: L200 - L299


L208: ORDER BY invalid because column name is not part of the result table.

Parent topic: L200 - L299


L212: name IS MULTIPLY SPECIFIED IN TRIGGER REFERENCING CLAUSE

Parent topic: L200 - L299


L355: A LOB COLUMN IS TOO LARGE TO BE LOGGED

Parent topic: L300 - L399


L372: ONLY ONE COLUMN DEFINED AS ROWID IS ALLOWED IN A TABLE

Parent topic: L300 - L399


L390: FUNCTION function-name (specific-name), NOT VALID IN THAT CONTEXT

Parent topic: L300 - L399


L392: SQLDA PROVIDED FOR cursor HAS BEEN CHANGED FROM PREVIOUS FETCH

Parent topic: L300 - L399


L396: object-typeobject-name EXECUTED SQL STATEMENT DURING FINAL CALL PROCESSING

Parent topic: L300 - L399


L397: GENERATED OPTION SPECIFIED ON COLUMN THAT IS NOT TYPE ROW ID

Parent topic: L300 - L399


L398: LOCATOR REQUESTED FOR HOST VARIABLE position-number BUT VARIABLE NOT A LOB

Parent topic: L300 - L399


L399: ATTEMPTED TO INSERT AN INVALID VALUE INTO A ROWID COLUMN

Parent topic: L300 - L399


L400: THE CATALOG HAS THE MAXIMUM NUMBER OF USER DEFINED INDEXES

Parent topic: L400 - L449


L401: Operands of an arithmetic or comparison operation are not comparable.

Parent topic: L400 - L449


L440: NO routine-type NAMED routine-name WITH COMPATIBLE ARGUMENTS WAS FOUND

Parent topic: L400 - L449


L441: INVALID USE OF 'DISTINCT' OR 'ALL' WITH SCALAR FUNCTION function-name

Parent topic: L400 - L449


L443: function-name (specific-name) RETURNED WITH DIAGNOSTIC TEXT msg-text

Parent topic: L400 - L449


L444: USER PROGRAM name COULD NOT BE FOUND

Parent topic: L400 - L449


L449: INVALID EXTERNAL NAME CLAUSE FOR FUNCTION OR PROCEDURE routine-name

Parent topic: L400 - L449


L450: FUNCTION/STORED PROCEDURE name, PARAMETER NUMBER parmnum, OVERLAYED MEMORY

Parent topic: L450 - L499


L451: INVALID data-item DEFINITION IN function-name, INVALID DATA TYPE type

Parent topic: L450 - L499


L453: PROBLEM WITH THE RETURNS CLAUSE FOR FUNCTION function-name

Parent topic: L450 - L499


L454: SIGNATURE FOR FUNCTION function-name NOT UNIQUE WITHIN SCHEMA

Parent topic: L450 - L499


L455: function-name, SCHEMA schema-name1 IN SPECIFIC NAME DOES NOT MATCH schema-name2

Parent topic: L450 - L499


L503: Column cannot be updated because it is not in the UPDATE clause of the select.

Parent topic: L500 - L549


L504: The cursor name name is not defined.

Parent topic: L500 - L549


L507: The cursor identified in the UPDATE or DELETE statement is not open.

Parent topic: L500 - L549


L508: Cursor identified in an update or delete is not positioned on a row.

Parent topic: L500 - L549


L509: The table in an UPDATE or DELETE is not a table designated by cursor.

Parent topic: L500 - L549


L510: Table designated by cursor of UPDATE/DELETE statement cannot be modified.

Parent topic: L500 - L549


L511: FOR UPDATE clause invalid because cursor cannot be modified.

Parent topic: L500 - L549


L512: Statement reference to remote object is invalid.

Parent topic: L500 - L549


L513: The alias name must not be defined by another local or remote alias.

Parent topic: L500 - L549


L514: The cursor name is not in a prepared state.

Parent topic: L500 - L549


L552: authid does not have the privileges to perform operation operation.

Parent topic: L550 - L599


L553: authid specified is not one of the valid AuthIDs.

Parent topic: L550 - L599


L554: An AuthID cannot grant a privilege to itself.

Parent topic: L550 - L599


L555: An AuthID cannot revoke a privilege from itself.

Parent topic: L550 - L599


L556: A privilege cannot be revoked because it is not possessed by authid.

Parent topic: L550 - L599


L557: Inconsistent grant/revoke keyword keyword. Permitted keywords are keyword-list.

Parent topic: L550 - L599


L558: Invalid clause or combination of clauses on a grant or revoke.

Parent topic: L550 - L599


L559: All authorization functions have been disabled.

Parent topic: L550 - L599


L567: bind-type AUTHORIZATION ERROR FOR auth-idpackage-nameprivilege

Parent topic: L550 - L599


L571: The statement would result in a multiple site update.

Parent topic: L550 - L599


L619: Operation disallowed because the workfile database is not stopped.

Parent topic: L600 - L649


L620: Keyword keyword not allowed for tablespace in workfile database.

Parent topic: L600 - L649


L621: Duplicate dbid dbid was detected and previously assigned to dbname.

Parent topic: L600 - L649


L622: FOR MIXED DATA is invalid because MIXED DATA inst opt is NO.

Parent topic: L600 - L649


L623: A clustering index already exists on table name.

Parent topic: L600 - L649


L624: Table name already has a primary key.

Parent topic: L600 - L649


L625: TABLE table-name DOES NOT HAVE INDEX TO ENFORCE UNIQUENESS OF PARENT KEY

Parent topic: L600 - L649


L626: ALTER statement is not executable because the pageset is not stopped.

Parent topic: L600 - L649


L627: ALTER statement is invalid because the pageset has user-managed data set.

Parent topic: L600 - L649


L628: THE CLAUSES ARE MUTUALLY EXCLUSIVE

Parent topic: L600 - L649


L663: Number of key limit values is 0, or > number of columns in key of index.

Parent topic: L650 - L699


L664: Internal length of limit-key fields for partitioned index name is too long.

Parent topic: L650 - L699


L665: The PART clause of an ALTER statement is omitted or invalid.

Parent topic: L650 - L699


L666: stmt-verbobject cannot be executed because of something in progress.

Parent topic: L650 - L699


L667: Clustering index for partitioned tablespace cannot be explicitly dropped.

Parent topic: L650 - L699


L668: Cannot add column to the table because the table has an edit procedure.

Parent topic: L650 - L699


L669: A table in a partitioned tablespace cannot be explicitly dropped.

Parent topic: L650 - L699


L670: The record length of the table exceeds the page size limit.

Parent topic: L650 - L699


L671: Cannot alter buffpool attr of tablespace because pg size of tablespace would change.

Parent topic: L650 - L699


L672: OPERATION DROP NOT ALLOWED ON TABLE table-name

Parent topic: L650 - L699


L719: BIND ADD error, package package already exists.

Parent topic: L700 - L799


L720: Attempt to replace package package with existing version version.

Parent topic: L700 - L799


L721: BIND err CONTOK = contoken X cannot be created because it is not unique.

Parent topic: L700 - L799


L722: Package package does not exist.

Parent topic: L700 - L799


L723: ERROR IN TRIGGER trigger-name, SECTION NUMBER section-number

Parent topic: L700 - L799


L724: ACTIVATION OF object-typeobject-name WOULD EXCEED MAXIMUM OF SQL CASCADING

Parent topic: L700 - L799


L725: SPECIAL REGISTER register AT location WAS SUPPLIED INVALID VALUE

Parent topic: L700 - L799


L726: Cannot replace package package. Enable or disable entries also with package.

Parent topic: L700 - L799


L728: DATA TYPE data-type IS NOT ALLOWED IN DB2 PRIVATE PROTOCOL PROCESSING

Parent topic: L700 - L799


L729: COMMIT ON RETURN STORED PROCEDURE CANNOT BE IN NESTED CALL STATEMENT

Parent topic: L700 - L799


L771: INVALID SPECIFICATION OF A ROWID COLUMN

Parent topic: L700 - L799


L797: ATTEMPT TO CREATE TRIGGER trigger-name WITH AN UNSUPPORTED SQL STATEMENT

Parent topic: L700 - L799


L798: ATTEMPT TO INSERT VALUE INTO ROWID GENERATED ALWAYS COLUMN column-name

Parent topic: L700 - L799


L802: EXCEPTION ERROR exception-type OCCURRED DURING operation-type OPERATION ON data-type DATA

Parent topic: L800 - L899


L803: INSERT/UPDATE INVALID;INDEX SPACE index-space-name RESTRICTS DUP COLUMNS, RID row-id

Parent topic: L800 - L899


L804: Error found in application program input parameters for the SQL statement.

Parent topic: L800 - L899


L805: Program name name not found in plan name.

Parent topic: L800 - L899


L807: Access denied to package pkg.

Parent topic: L800 - L899


L808: CONNECT STATEMENT IS NOT CONSISTENT WITH THE FIRST CONNECT STATEMENT

Parent topic: L800 - L899


L811: Result of embedded select statement is a table with more than one row.

Parent topic: L800 - L899


L812: BLANK COLLECTION-ID IN CURRENT PACKAGE SET; PGM program-name.consistency-token USING PLAN plan-name

Parent topic: L800 - L899


L815: GROUP BY/HAVING clause specified in embedded select statement/subquery.

Parent topic: L800 - L899


L817: Cannot execute INSERT/UPDATE/DELETE/DLL/AUTHORIZATION statement.

Parent topic: L800 - L899


L818: Timestamp in load module is not the same as bind timestamp built from the DBRM.

Parent topic: L800 - L899


L819: Cannot process view. Length of its parse tree in the catalog is zero.

Parent topic: L800 - L899


L820: Cannot process SQL statement. catalog contains a value not valid in version.

Parent topic: L800 - L899


L822: SQLDA contains invalid data address or indicator variable address.

Parent topic: L800 - L899


L840: Too many items returned in a select or insert list.

Parent topic: L800 - L899


L842: A CONNECTION TO location-name ALREADY EXISTS

Parent topic: L800 - L899


L843: SET CONNECTION OR RELEASE STATEMENT MUST SPECIFY AN EXISTING CONNECTION

Parent topic: L800 - L899


L870: NUMBER OF HOST VARIABLES IN STATEMENT NOT EQUAL TO NUMBER OF DESCRIPTORS

Parent topic: L800 - L899


L872: A VALID CCSID HAS NOT YET BEEN SPECIFIED FOR THIS SUBSYSTEM

Parent topic: L800 - L899


L873: DATA ENCODED WITH DIFFERENT CCSIDS CANNOT BE REFERENCED IN SAME STATEMENT

Parent topic: L800 - L899


L874: object-type ENCODING SCHEME MUST BE SAME AS THE CONTAINING TABLE SPACE

Parent topic: L800 - L899


L875: operand CANNOT BE USED WITH THE ASCII DATA REFERENCED

Parent topic: L800 - L899


L876: 'object' CANNOT BE CREATED, REASON 'reason'

Parent topic: L800 - L899


L877: CCSID ASCII IS NOT ALLOWED FOR THIS DATABASE OR TABLE SPACE

Parent topic: L800 - L899


L878: THE PLAN_TABLE USED FOR EXPLAIN CANNOT BE ASCII

Parent topic: L800 - L899


L879: object-name CANNOT DEFINE OBJECT MIXED/GRAPHIC WITH ENCODING SCHEME encoding-scheme

Parent topic: L800 - L899


L900: Cannot EXEC SQL because application is not connected to application server.

Parent topic: L900 - L999


L901: System error caused failed execution so subsequent SQL may be successful.

Parent topic: L900 - L999


L902: Pointer to the essential ctrl block (CT/RDA) has value 0, rebind required.

Parent topic: L900 - L999


L904: Unavailable resource caused failed exec. type type of resource name.

Parent topic: L900 - L999


L905: Fail exec due to resource limit, resource name name limit amount.

Parent topic: L900 - L999


L906: Cannot execute SQL statement. Function disabled due to a prior error.

Parent topic: L900 - L999


L907: Unable to determine if commit of updates made at a remote site failed.

Parent topic: L900 - L999


L908: bind error using authid authority no bind or rebind are allowed.

Parent topic: L900 - L999


L909: The object has been deleted.

Parent topic: L900 - L999


L910: SQL statement cannot access object on which a drop/alter is pending.

Parent topic: L900 - L999


L911: Rollback due to a deadlock/timeout. Reason code.

Parent topic: L900 - L999


L913: Failed execution cause by deadlock/timeout. Reason code code.

Parent topic: L900 - L999


L917: Bind package failed.

Parent topic: L900 - L999


L918: SQL cannot be executed because connection has been lost.

Parent topic: L900 - L999


L919: A ROLLBACK OPERATION IS REQUIRED

Parent topic: L900 - L999


L922: AUTHORIZATION FAILURE: error-type ERROR. REASON reason-code

Parent topic: L900 - L999


L923: CONNECTION NOT ESTABLISHED: DB2 condition REASON reason-code, TYPE resource-type, NAME resource-name

Parent topic: L900 - L999


L924: DB2 CONNECTION INTERNAL ERROR, function-code, return-code, reason-code

Parent topic: L900 - L999


L925: Commit not valid in IMS/VS or CICS environment.

Parent topic: L900 - L999


L926: Rollback not valid in IMS/VS or CICS environment.

Parent topic: L900 - L999


L927: Language interface called when the connecting environment was not established.

Parent topic: L900 - L999


L929: FAILURE IN A DATA CAPTURE EXIT: token

Parent topic: L900 - L999


L939: ROLLBACK REQUIRED DUE TO UNREQUESTED ROLLBACK OF A REMOTE SERVER

Parent topic: L900 - L999


L947: STATEMENT FAILED;WILL CHANGE TABLE DEFINED BUT DATA CANNOT BE PROPAGATED

Parent topic: L900 - L999


L948: DISTRIBUTED OPERATION IS INVALID

Parent topic: L900 - L999


L950: Location name is invalid or not in comm db.

Parent topic: L900 - L999


L981: STATEMENT FAILED;CONNECTION DOES NOT ALLOW SQL OPERATIONS, REASON reason-code.

Parent topic: L900 - L999


L991: CrossAccess Data Access error ErrorNum (ConditionCode) for IMS/VSAM. Consult CrossAccess System Messages documentation.

Parent topic: L900 - L999


L992: CrossAccess System error ErrorNum while accessing IMS/VSAM. Contact mainframe systems programming.

Parent topic: L900 - L999


L1000: Exec failed. Protocol error: Reason reason (type)

Reason | Type | Description
220a DSCINVRM | 0113 MDDTYPE | A data descriptor was detected with an invalid DRDA type.
220a DSCINVRM | 0105 NOSUPPORT | A data descriptor was detected with an unsupported late descriptor field.
220a DSCINVRM | 0107 BADVALUE | A data descriptor was detected that contains more fields than the describe indicated.
220e DTAMCHRM | 0000 | The data returned is inconsistent with the descriptor supplied.
124c SYNTAXRM | 010b LENGTH | The length of a long data stream structure is too great or is not supported.
124c SYNTAXRM | 0101 HEADER | A general data stream header is incomplete.
124c SYNTAXRM | 010C LONGDSS | A long dss data stream structure is too large to fit in memory.
124c SYNTAXRM | 0104 FORMAT | An invalid data stream type has been detected.
124c SYNTAXRM | 010e CPNTNFD | An unsupported DDM code point has been detected.
Parent topic: L1000 - L1099


L1020: Exec failed with dealloc. Protocol error: reason 1218 (02)

Parent topic: L1000 - L1099


L1021: :Execution failed. Manager manager at level level not supported.

Parent topic: L1000 - L1099


L1040: Unavail resource caused perm failure. Reason Alloc type type.

Parent topic: L1000 - L1099


L1041: Unavail resource caused perm failure. Reason Alloc type type.

Parent topic: L1000 - L1099


L1050: command command or SQL invalid while bind in progress.

Parent topic: L1000 - L1099


L1051: Bind with specified package name and consistency token not active.

Parent topic: L1000 - L1099


L1052: Program preparation assumptions are incorrect.

Parent topic: L1000 - L1099


L1053: Owner authorization failure.

Parent topic: L1000 - L1099


L1060: RDB authorization failure.

Parent topic: L1000 - L1099


L1061: RDB not found.

Parent topic: L1000 - L1099


L1070: command command not supported.

Parent topic: L1000 - L1099


L1071: object object not supported error.

Parent topic: L1000 - L1099


L1072: parameter parameter not supported error.

Parent topic: L1000 - L1099


L1073: value parameter value not supported error.

Parent topic: L1000 - L1099


L1074: Reply message with codepoint (severity) not supported.

Parent topic: L1000 - L1099


L1080: Communication error primary (secondary).

Parent topic: L1000 - L1099


L1090: Remote operation invalid for application execution environment.

Parent topic: L1000 - L1099


L30000: Distribution protocol error: reason reason-code.

Parent topic: L30000 - L30099


L30020: Distribution protocol error cause deallocation reason: reason-code.

Parent topic: L30000 - L30099


L30021: Distribution protocol error: manager manager at level level not supported.

Parent topic: L30000 - L30099


L30030: Not committed, SQLCODE = orig-sqlcode and SQLSTATE = orig-sqlstate.

Parent topic: L30000 - L30099


L30040: Unavailable resource. Reason reason-code type rsrc-type, name rsrc-name, id pppvvrrm, RDBNAME rdbname.

Parent topic: L30000 - L30099


L30041: Unavailable resource. Reason reason-code type resource-type name resource-name id pppvvrrm RDBNAME rdbname.

Parent topic: L30000 - L30099


L30050: command or SQL statement invalid while bind.

Parent topic: L30000 - L30099


L30051: Bind process with specified package name and consistency token not active.

Parent topic: L30000 - L30099


L30052: Program preparation assumptions are incorrect.

Parent topic: L30000 - L30099


L30053: Owner authorization failure.

Parent topic: L30000 - L30099


L30060: RDB authorization failure.

Parent topic: L30000 - L30099


L30061: RDB not found.

Parent topic: L30000 - L30099


L30070: command command not supported.

Parent topic: L30000 - L30099


L30071: object object not supported.

Parent topic: L30000 - L30099


L30072: parameter: subcode parameter not supported.

Parent topic: L30000 - L30099


L30073: parameter: subcode parameter value not supported.

Parent topic: L30000 - L30099


L30074: Reply message with codepoint (SRVCOD) not supported.

Parent topic: L30000 - L30099


L30080: Communication error code.

Parent topic: L30000 - L30099


L30090: Remote operation invalid for application execution.

Parent topic: L30000 - L30099


XMIG008: Table tablename does not exist.

Check that the correct table name and source location has been specified. Check also that the table exists at the specified source location and that the source location's system catalog is accurate.

Parent topic: XMIG - Migrate Error Messages


XMIG009: Check source location data consistency.

This can occur because:

  • The foreign key on the source table was created after illegal data was inserted into the table.
  • The data in the primary key table was inserted with one of the following:
    • a subsetting query
    • Every Nth Row migration
    • First N Rows migration

    and, therefore, does not contains the rows to make the data in this table valid.

Select a different data subset for this table or drop the foreign key.

Parent topic: XMIG - Migrate Error Messages


XMIG010: Error saving file name.

Verify that you have privileges to access the specified drive, that there is enough disk space available on the specified drive, and that the target directory is valid.

Parent topic: XMIG - Migrate Error Messages


XMIG011: Query window contains more than one query.

If there is only one query in this window, remove the end-of-statement delimiter (e.g., a quote character). If there are multiple queries in this window, split them into separate Query windows (place only one query in each window).

Parent topic: XMIG - Migrate Error Messages


XMIG012: Query must be a SELECT statement.

Remove the invalid statement from the Query window. To include additional SQL in a migration, use the Prologue and Epilogue functions. See your Migrate User's Guide for information about using Prologue and Epilogue scripts.

Parent topic: XMIG - Migrate Error Messages


XMIG013: Table already exists. Illegal with current settings.

Parent topic: XMIG - Migrate Error Messages


XMIG014: Field names in query may not match the field names of the destination table.

Generate and test your SQL using SQLWizard and paste it into the Migrate window.

Parent topic: XMIG - Migrate Error Messages


XMIG015: No key fields specified in replication query.

Parent topic: XMIG - Migrate Error Messages


XMIG049: SELECT error. May not have privileges.

Verify that you are running with the correct SQLID for the task, and that you have the permissions necessary to access the object. See the owner of the object or your database administrator to request access to an object for which you do not have privileges.

Parent topic: XMIG - Migrate Error Messages


XMIG017: Cannot find information in system_table for 'table_name'.

Parent topic: XMIG - Migrate Error Messages


XMIG053: Filters yield no results. Filters are reset.

Parent topic: XMIG - Migrate Error Messages


XMIG000: Error system error: Unknown error errorID.

Reinstall Migrate or contact Micro Focus Technical Support for a copy of the correct XMIG.XRR file.

Parent topic: XMIG - Migrate Error Messages


XMIG001: No more RAM memory available.

Close all other applications and re-execute the operation. If the error persists, check that your system has adequate swap-file space. Or, reduce the complexity of the migration to work within the available memory.

Parent topic: XMIG - Migrate Error Messages


XMIG002: No Column in table.

Do the following:

  • Save the migration specifications to a MIG file.
  • Back up your source location.
  • Record the version of XDB Server and Migrate software you are using.
  • Contact Micro Focus Technical Support.
Parent topic: XMIG - Migrate Error Messages


XMIG003: Cannot open file filename.

Check that nothing is preventing Migrate from accessing this file. For example, check that this file is present, that it is not "read-only" and that the drive on which it is stored is available and operational.

Parent topic: XMIG - Migrate Error Messages


XMIG004: Syntax Error.

Check the syntax of the SQL statements specified by any of the following components used in the migration:

  • The Prologue script file
  • The Epilogue script file
  • The Query window(s)

Often, this error is caused by comments that are included in these components. If any of this SQL contains comments, remove them and rerun the migration.

If you are executing the migration from a MIG file, check that each QUERY statement in the file defines a valid SELECT statement.

Parent topic: XMIG - Migrate Error Messages


XMIG005: Destination location has not been defined.

Specify a destination location and rerun the migration. If you are executing the migration from a MIG file, check that the file contains a DESTINATION statement, and that this statement specifies a valid location name.

Parent topic: XMIG - Migrate Error Messages


XMIG006: Destination table has not been defined.

Specify a destination table and rerun the migration. If you are executing the migration from a MIG file, check that the file contains a NAME statement in the TABLE section, and that this statement contains a valid table name.

Parent topic: XMIG - Migrate Error Messages


XMIG007: Error in internal query querystring.

Update SYSXDB.SYSQUERY to include the required fields. Micro Focus provides a script to do this. See "SQLWizard Upgrade Procedures" in your Setup guide for details.

Parent topic: XMIG - Migrate Error Messages


N010: Session # number closed.

Parent topic: N000 - N099


N011: Command canceled.

Parent topic: N000 - N099


N012: Undocumented NetBIOS error.

Parent topic: N000 - N099


N013: Duplicate name name in local name table.

Parent topic: N000 - N099


N014: Network name table is full.

Parent topic: N000 - N099


N015: Command completed, name has active session and is now de-registered.

Parent topic: N000 - N099


N017: Local session table is full.

Parent topic: N000 - N099


N018: Cannot open network session.

Parent topic: N000 - N099


N019: Illegal session name identification number.

Parent topic: N000 - N099


N020: Cannot find name called or no answer.

Also make sure you are using the same type of NetBIOS (for example IBM to IBM). This also may be related to not having a bridge for NetBIOS. If you are in a WAN environment, you need to have a bridge established to have connectivity to a server on another LAN.

Parent topic: N000 - N099


N021: Name name not found.

Also make sure you are using the same type of NetBIOS (for example IBM to IBM). This also may be related to not having a bridge for NetBIOS. If you are in a WAN environment, you need to have a bridge established to have connectivity to a server on another LAN.

Parent topic: N000 - N099


N022: Name name in use on remote adapter.

Parent topic: N000 - N099


N023: Name name was deleted.

Parent topic: N000 - N099


N024: Session ended abnormally.

Parent topic: N000 - N099


N025: Name conflict detected.

Parent topic: N000 - N099


N026: Incompatible remote device.

Parent topic: N000 - N099


N027 - N032: Undocumented NetBIOS errors.

Parent topic: N000 - N099


N033: Interface busy.

Parent topic: N000 - N099


N034: Too many commands outstanding.

Parent topic: N000 - N099


N035: Invalid number in NCB_LANA_NUM field.

Parent topic: N000 - N099


N036: Command completed while cancel occurring.

Parent topic: N000 - N099


N037: Attempt to use reserved name as a group name.

Parent topic: N000 - N099


N038: Attempt to issue a command out of sequence.

Parent topic: N000 - N099


N040 - N049: Unusual network conditions.

Parent topic: N000 - N099


N050: NetBIOS is not loaded.

WINDOWS NOTE: In Windows, you must load NetBIOS prior to entering Windows. You might also be running non-IBM or Novell NetBIOS. XDB Server must see the file NETAPI.DLL which is only associated with IBM and Novell NetBIOS. Refer to file NETAPI.TXT.

Parent topic: N000 - N099


N051 - N254: Unusual network conditions.

Parent topic: N000 - N099


N364: No more structures available for Named Pipe name (ERROR_OF_STRUCTURES).

Parent topic: N300 - N399


N365: Invalid parameter specified for Named Pipe call (ERROR_INVALID_PARAMETER).

Parent topic: N300 - N399


N366: Named Pipes system call interrupted (ERROR_INTERRUPT).

Parent topic: N300 - N399


N367: Named Pipe name is broken (ERROR_BROKEN_PIPE).

Parent topic: N300 - N399


N368: Buffer too small for Named Pipe (ERROR_BUFFER_OVERFLOW).

Parent topic: N300 - N399


N369: Semaphore not found (ERROR_SEM_TIMEOUT).

Parent topic: N300 - N399


N370: Invalid name name specified for Named Pipe (ERROR_INVALID_NAME).

Parent topic: N300 - N399


N371: Invalid level parameter (ERROR_INVALID_LEVEL).

Parent topic: N300 - N399


N372: Invalid name name specified for Named Pipe (ERROR_SEM_NOT_FOUND).

Parent topic: N300 - N399


N373: Handle does not refer to Named Pipe (ERROR_BAD_PIPE).

Parent topic: N300 - N399


N374: All available instances of Named Pipe name are in use (ERROR_PIPE_BUSY).

Parent topic: N300 - N399


N375: Data unavailable on non-blocking read (ERROR_NO_DATA).

Parent topic: N300 - N399


N376: Named Pipe name currently not connected (ERROR_PIPE_NOT_CONNECTED).

Parent topic: N300 - N399


N377: Buffer too small for Named Pipe name (ERROR_MORE_DATA).

Parent topic: N300 - N399


N396: Undocumented Named Pipes error number.

Parent topic: N300 - N399


N406: Bad transaction program identifier: identifier.

Parent topic: N400 - N449


N407: Bad conversation identifier: identifier.

Parent topic: N400 - N449


N408: Bad logical unit alias: alias.

Parent topic: N400 - N449


N409: Allocation failure no retry. Sense code: code.

Parent topic: N400 - N449


N410: Allocation failure retry. Sense code: code.

Parent topic: N400 - N449


N411: Invalid data segment.

Parent topic: N400 - N449


N412: Bad conversation type parameter.

Parent topic: N400 - N449


N413: Bad synchronization level parameter.

Parent topic: N400 - N449


N414: Bad security parameter.

Parent topic: N400 - N449


N415: Bad return control parameter.

Parent topic: N400 - N449


N416: Program initialization parameter length incorrect.

Parent topic: N400 - N449


N001: Illegal buffer length value.

Parent topic: N000 - N099


N427: Bad return status with data parameter.

Parent topic: N400 - N449


N428: Bad logical length.

Parent topic: N400 - N449


N429: Send data not in send state.

Parent topic: N400 - N449


N430: Send data invalid type parameter.

Parent topic: N400 - N449


N431: Send data confirm with synchronization none.

Parent topic: N400 - N449


N432: Send data not logical length body.

Parent topic: N400 - N449


N433: Bad type.

Parent topic: N400 - N449


N434: Undefined transaction program name: name.

Parent topic: N400 - N449


N435: Attach manager already inactive.

Parent topic: N400 - N449


N436: Allocate not pending.

Parent topic: N400 - N449


N437: Invalid process.

Parent topic: N400 - N449


N438: Security not valid.

Parent topic: N400 - N449


N439: Transaction program not available retry.

Parent topic: N400 - N449


N440: Transaction program not available no retry.

Parent topic: N400 - N449


N441: Transaction program name not recognized.

Parent topic: N400 - N449


N442: Program initialization parameter not allowed.

Parent topic: N400 - N449


N443: Program initialization parameter not specified correctly.

Parent topic: N400 - N449


N444: Conversation type mismatch.

Parent topic: N400 - N449


N445: Synchronization level not supported.

Parent topic: N400 - N449


N446: Parameter check.

Parent topic: N400 - N449


N447: State check.

Parent topic: N400 - N449


N448: Allocation error.

Parent topic: N400 - N449


N449: Dealloc abend.

Parent topic: N400 - N449


N450: Dealloc abend program.

Parent topic: N450 - N499


N451: Dealloc abend switched virtual circuit.

Parent topic: N450 - N499


N452: Dealloc abend timer.

Parent topic: N450 - N499


N002: Undocumented NetBIOS error.

Parent topic: N000 - N099


N463: Conversation type mixed.

Parent topic: N450 - N499


N464: Transaction program is busy.

Parent topic: N450 - N499


N465: Communication subsystem abended.

Parent topic: N450 - N499


N466: Communication subsystem is not loaded.

Parent topic: N450 - N499


N467: Invalid verb segment.

Parent topic: N450 - N499


N468: Unexpected DOS error.

Parent topic: N450 - N499


N469: Stack too small.

Parent topic: N450 - N499


N476: Security Location Not Configured.

Parent topic: N450 - N499


N477: Invalid Host Authorization.

Parent topic: N450 - N499


N478: Invalid Host Password.

Parent topic: N450 - N499


N479: Host Authorization Has Expired.

Parent topic: N450 - N499


N480: Host Authorization Has Been Revoked.

Parent topic: N450 - N499


N486: Nucleus loopback error.

Parent topic: N450 - N499


N487: AS target not supported.

Parent topic: N450 - N499


N488: An AS target module failed to load.

Parent topic: N450 - N499


N489: An AS target module function address was not found.

Parent topic: N450 - N499


N496: Protocol memory allocation failure.

Parent topic: N450 - N499


N497: Transaction identifier is invalid.

Parent topic: N450 - N499


N498: Connection identifier is invalid.

Parent topic: N450 - N499


N499: Unsupported protocol.

Parent topic: N450 - N499


N500: A protocol module failed to load.

Parent topic: N500 - N599


N501: A protocol module function address was not found.

Parent topic: N500 - N599


N506: No available connections.

Parent topic: N500 - N599


N507: Open semaphore failure.

Parent topic: N500 - N599


N508: Create semaphore failure.

Parent topic: N500 - N599


N509: Shared memory failure.

Parent topic: N500 - N599


N003: Invalid network command.

Parent topic: N000 - N099


N004: Undocumented NetBIOS error.

Parent topic: N000 - N099


N005: NetBIOS command timed out.

Parent topic: N000 - N099


N006: Incomplete network message.

Parent topic: N000 - N099


N008: Illegal local session number number.

Parent topic: N000 - N099


N009: Resource is not available.

Parent topic: N000 - N099


N300: TCP Error errmsgfunction( ) = errorcode

Eight-digit error codes, including the following, indicate problems with DB2 or VTAM.

ErrorCode Description
00000008 Cannot connect to application.

On the machine where XDB Link is installed, start the Gateway Profile Utility and verify that the Remote APPLID setting matches the APPLID of the remote application. (If you are using an earlier version of the Gateway Profile Utility, this setting might appear as Remote Host instead of Remote APPLID.)
00040005 Bad user id and/or password.

Verify that the user ID is correct and valid (i.e., not revoked). Verify that the password is correct and current (i.e., not expired).

Note:

If the Password Expiration Maintenance Utility (PEM) is installed on the host, you can run the PEM utility on your workstation to quickly determine why the user ID and/or password was rejected (e.g., password expired, user ID revoked, user ID invalid). If the problem stems from an expired password, you can use PEM to update that password. See the "PEM Utility" chapter in the XDB Link User's Guide for information about using PEM to diagnose and correct user ID and password problems.

Five-digit error codes starting with 110 indicate problems with XDB Link.

ErrorCode Description
11004 Cannot connect to host.

Check the following:

  1. Verify that the TCP/IP connection on the host system is up and running.
  2. On the machine where the XDB Link is installed:
    • Make sure the HOSTS file contains an entry that defines the host system's IP address, and verify that this IP address is correct. Also make sure the line containing this entry has a hard return at the end.

      OR

      If using DHCP, make sure the host system's IP address is registered with a DNS server.

    • Make sure the SERVICES file contains an entry that defines the port used by the Host Option on the host, and verify that the port number is correct. Also make sure the line containing this entry has a hard return at the end.
  3. Start the Gateway Profile Utility and verify that:
    • The Remote HOST setting matches the name assigned to the host's IP address in the HOSTS file or the DNS server.
    • The Port setting matches the name assigned to the Host Option in the SERVICES file.
11002 Cannot connect to host.

Check the following:

  1. Verify that the TCP/IP connection on the host system is up and running.
  2. On the machine where the XDB Link is installed:
    • Make sure the HOSTS file contains an entry that defines the host system's IP address, and verify that this IP address is correct. Also make sure the line containing this entry has a hard return at the end.

      OR

      If using DHCP, make sure the host system's IP address is registered with a DNS server.

    • Make sure the SERVICES file contains an entry that defines the port used by the Host Option on the host, and verify that the port number is correct. Also make sure the line containing this entry has a hard return at the end.
  3. Start the Gateway Profile Utility and verify that:
    • The Remote HOST setting matches the name assigned to the host's IP address in the HOSTS file or the DNS server.
    • The Port setting matches the name assigned to the Host Option in the SERVICES file.

The following error codes indicate problems with the client machine.

Note:

Two-digit error codes (e.g., 35) are displayed if you are running under a 16-bit operating system such as Windows 3.1. Five digit error codes (e.g., 10035) are displayed if you are running under a 32-bit operating system such as Windows 95, Windows NT, or OS/2.

Errors marked with an asterisk (*) are ones that can occur if your XDBNET.INI file does not specify a valid TCP/IP address for the server you are attempting to access. When these errors occur, open the XDBNET.INI file and verify that the following values are correct for your server:

  • Server name
  • IPAddress
  • TCPPort
16-bith ErrorCode | 32-bit ErrorCode | Description
35 | 10035 | Operation would block.
36 | 10036 | Operation now in progress.
37 | 10037 | Operation already in progress.
38 | 10038 | Socket operation on non-socket.
39 | 10039 | Destination address required.
40 | 10040 | Message too long.
41 | 10041 | Protocol wrong type for socket.
42 | 10042 | Protocol not available.
43 | 10043 | Protocol not supported.
44 | 10044 | Socket type not supported.
45 | 10045 | Operation not supported on socket.
46 | 10046 | Protocol family not supported.
47 | 10047 | Address family not supported by protocol family.
48 | 10048 | Address already in use.
49 | 10049 | Can't assign requested address.
50 | 10050 | Network is down.
51 | 10051 | Network is unreachable.
52 | 10052 | Network dropped connection on reset.
53 | 10053 | Software caused connection abort.
54 | 10054 | Connection reset by peer. *
55 | 10055 | No buffer space available.
56 | 10056 | Socket is already connected.
57 | 10057 | Socket is not connected.
58 | 10058 | Can't send after socket shutdown.
59 | 10059 | Too many references can't splice.
60 | 10060 | Connection timed out. *
61 | 10061 | Connection refused. *
62 | 10062 | Too many levels of symbolic links.
63 | 10063 | File name too long.
64 | 10064 | Host is down. *
65 | 10065 | No route to host. *
66 | 10066 | Directory not empty.
93 | 10093 | Unknown Error. *
Parent topic: N300 - N399


N301: SPX Error: errmsgfunction() = errcode

errcode | errmsg
1 | Illegal protocol address.
2 | Illegal protocol option.
3 | Access permission denied.
4 | Bad transport endpoint.
5 | Unable to allocate address.
6 | Out of state.
7 | Invalid sequence number.
8 | System error (system error code).
9 | Even requires attention (event name).
10 | Invalid data size.
11 | Buffer overflow.
12 | Unable to accept data.
13 | Data not available.
14 | No disconnect indication exists.
15 | No unit data error indication.
16 | Invalid flag specified.
17 | No orderly release indication.
18 | Not supported.
19 | State change.
20 | Invalid structure type.
21 | Invalid transport provider name.
22 | Bad value.
23 | Address in use.

For example, if an SPX connection attempted to use an incorrect address, the following error message would be displayed:

N301: SPX Error: Illegal protocol address. bind() = 1
Parent topic: N300 - N399


N302: NETBIOS Error errmsgfunction = errorcode

N302: NETBIOS Error: Cannot find name called or no answer.

The following describes common NETBIOS errors that can occur.

Code | Description
1 | Invalid buffer length.
2 | Buffer full.
3 | Invalid command.
5 | Command timed out.
6 | Incomplete received message.
7 | Illegal buffer address.
8 | Invalid local session number.
9 | No resource available.
10 | Session has been closed.
11 | Command was cancelled.
13 | Duplicate name in local name table.
14 | Name table full.
15 | No deletions allowed, name has active sessions.
17 | Local session table full.
18 | Remote session table full.
19 | Illegal name number.
20 | Cannot find name called or no answer. Check that you have specified the correct server in Options and that the server is up and running. See also N020: Cannot find name called or no answer. for other possible causes.
21 | Cannot put wild card(*) in NCB name.
22 | Name in use on remote adapter.
23 | Name deleted.
24 | Session ended abnormally.
25 | Name conflict detected.
33 | Interface busy, IRET before retrying.
34 | Too many commands outstanding, retry later.
35 | Invalid name number (for NT check NCB_LANA_NUM field).
36 | Command completed while cancel occurring.
37 | Reserved name specified.
38 | Command not valid to cancel.
48 | Name defined by anther local process.
52 | Environment undefined. RESET required.
53 | Required OS resources exhausted.
54 | Max number of applications exceeded.
55 | No saps available for netbios.
56 | Requested resources are not available.
57 | Invalid ncb address or length > segment.
59 | Invalid NCB DDID.
61 | Lock of user area failed.
63 | NETBIOS not loaded.
64 | System error.
255 | Asynchronous command is not yet finished.
Parent topic: N300 - N399


N357: Invalid Named Pipe function call (ERROR_INVALID_FUNCTION).

Parent topic: N300 - N399


N358: Invalid path path specified for Named Pipe (ERROR_FILE_NOT_FOUND).

Parent topic: N300 - N399


N359: Cannot find Named Pipe name (ERROR_PATH_NOT_FOUND).

If you are trying to run locally, add the line SET XDBSERVE=LOCAL to your CONFIG.SYS file and reboot.

1. If running local and not starting the engine explicitly, then retry the programs. Under conditions of low memory it may take the XDB Server longer to initialize than the predefined wait period before a client may access the server.

2. If the Named Pipe displayed memory starts with \\, you are trying to recess a remote XDB Server via Named Pipes. Also, you may need to put your server name after NPDAEMON.EXE in your CONFIG.SYS file. The server cannot be found.

If you are operating under Banyan VINES, bring up the engine first by typing xdbserve, and then type xdb. Also see error N020.

Parent topic: N300 - N399


N360: Access denied to Named Pipe name (ERROR_ACCESS_DENIED).

Parent topic: N300 - N399


N361: Invalid handle to Named Pipe specified (ERROR_INVALID_HANDLE).

Parent topic: N300 - N399


N362: Not enough memory for Named Pipe operation (ERROR_NOT_ENOUGH_MEMORY).

Parent topic: N300 - N399


N363: Invalid format specified for Named Pipe (ERROR_BAD_FORMAT).

Parent topic: N300 - N399


N417: Use of SNASVCMG or CPSVCMG for mode not allowed.

Parent topic: N400 - N449


N418: Unknown partner mode/alias:"<".

Parent topic: N400 - N449


N419: Dealloc bad type parameter.

Parent topic: N400 - N449


N420: Dealloc flush bad state.

Parent topic: N400 - N449


N421: Dealloc confirm bad state.

Parent topic: N400 - N449


N422: Dealloc not logical length body.

Parent topic: N400 - N449


N423: Dealloc log logical length wrong.

Parent topic: N400 - N449


N424: Receive and wait bad state.

Parent topic: N400 - N449


N425: Receive and wait not logical length body.

Parent topic: N400 - N449


N426: Receive and wait bad fill parameter.

Parent topic: N400 - N449


N453: Dealloc normal.

Parent topic: N450 - N499


N454: Program error no truncation.

Parent topic: N450 - N499


N455: Program error truncation.

Parent topic: N450 - N499


N456: Program error purging.

Parent topic: N450 - N499


N457: Conversation failure retry.

Parent topic: N450 - N499


N458: Conversation failure no retry.

Parent topic: N450 - N499


N459: Switch virtual circuit error no truncation.

Parent topic: N450 - N499


N460: Switch virtual circuit error truncation.

Parent topic: N450 - N499


N461: Switch virtual circuit error purging.

Parent topic: N450 - N499


N462: Unsuccessful.

Parent topic: N450 - N499


N510: Open process failure.

Parent topic: N500 - N599


N511: Cannot communicate with server.

Check to see that the server is running.

If you receive this error when trying to start SQLWizard, it is most likely because your single-workstation server is not loaded. Start the XDB Server, then restart SQLWizard.

Note:

For non-DB2 databases, put the XDB Server icon in your StartUp Program Group or Folder to ensure that your single-workstation server is already running when you start SQLWizard.

Parent topic: N500 - N599


N512: Connection is closed.

Parent topic: N500 - N599


PIC008 Sign character found on both sides of the decimal.

Correct the Numeric Format. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC009 Error in substitution portion of picture definition.

Correct the substitution clause in the Numeric Format. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC010 Illegal decimal found in picture.

Correct the Numeric Format. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC011 Illegal rounding character found in picture.

Correct the Numeric Format. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC012 Illegal dollar sign found in picture.

Correct the Numeric Format. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC013 Closing single quote not found in substitution string.

Correct the Numeric Format. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC014 Value too wide for picture field.

In Options, increase the Numeric Format to accommodate the value being displayed or entered. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC015 Error in time/date picture definition.

Correct the invalid format or use one of the standard time and date formats provided in Options. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC016: Error trying to identify the picture format type.

Parent topic: PIC - Picture Error Messages


PIC017 Invalid year value.

Check the Date Format defined in Options. Change the value to match the picture, or change the Date Format to accommodate the value. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC018 Invalid separator in value.

Check the Numeric Format defined in Options. Either change the value to match the picture, or change the Numeric Format to accommodate the value. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC019 Invalid character in value.

Check the picture formats defined in Options. Either change the values to match the pictures, or change the picture formats in Options to accommodate the values. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC020 Money value error.

Check the Money Format defined in Options. Either change the value to match the picture, or change the Money Format to accommodate the value. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC021 Numeric value error.

Check the Numeric Format defined in Options. Either change the value to match this format, or change the Numeric Format to accommodate your values. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC022 Illegal Integer value.

Check the Numeric Format defined in Options. Either change the value to match this format, or change the Numeric Format to accommodate the size of your values. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC023 Illegal Time value.

Check the Time Format defined in Options. Either change the value to match the picture, or change the Time Format to accommodate the value. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC024 Illegal Date value.

Check the Date Format defined in Options. Either change the value to match the picture, or change the Date Format to accommodate the value. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC025 Scale is bigger than precision.

Reduce the value in Float Decimal Places to a value accepted by your system.

Parent topic: PIC - Picture Error Messages


PIC026 Invalid separator in time value.

Check the Time Format defined in Options. Either change the value to match the picture, or change the Time Format to accommodate the value. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC027 Invalid separator in date value.

Check the Date Format defined in Options. Either change the value to match the picture, or change the Date Format to accommodate the value. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC028 Invalid separator in timestamp value.

Check the Time Format defined in Options. Either change the timestamp to match the picture, or change the Time Format to accommodate the value. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC000: Error system error: Unknown error errorID.

Check to make sure that the error file, XPIC.XRR, is the proper error file for this version of Options.

Parent topic: PIC - Picture Error Messages


PIC001 Syntax error in mask definition.

Correct the Numeric Format. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC002 Grouping character found twice or in illegal position.

Correct the Numeric Format. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC003 No grouping length.

Parent topic: PIC - Picture Error Messages


PIC004 Decimal character found twice or in illegal position.

Correct the Numeric Format. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC005 Rounding character in illegal position.

Correct the Numeric Format. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


PIC006 Illegal character in picture specification.

Correct the invalid format in Options. See the Options User's Guide for characters allowed by each picture type.

Parent topic: PIC - Picture Error Messages


PIC007 $ character found on both sides of decimal.

Correct the Numeric Format. See the Options User's Guide for the proper syntax.

Parent topic: PIC - Picture Error Messages


SQL0103S error creating output file: file

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0104S error writing DBRM file

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0105S error reading input file

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0106S error writing output file

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0107S scope mismatch

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0108S end of file before end of quoted string

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0109S end of file before end of comment

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0110S token buffer overflow

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0111S statement buffer overflow

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0112S parser stack overflow

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0113S include file file not found

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0114S host variable error in sqlda

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0115S illegal host variable marker '?'

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0116S invalid directives: directive

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0117S same name specified for the input file and the output file

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0118S host variable hostvar not found

Check to make sure that the host variable is declared in the program and that the picture or usage is correct.

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0119S declaration stack overflow

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0120S SQL syntax error, last token read: token

Verify that the SQL statement is valid. Make any corrections that are required and then recompile. If the error persists and the statement is valid, contact Micro Focus Technical Support.

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0121S cursor cursor not declared

The DECLARE CURSOR statement must be coded before an OPEN, FETCH or CLOSE SQL statement. If defined, move the DECLARE CURSOR statement before the statement in error. Otherwise, check to make sure the cursor name used in the DECLARE CURSOR statement matches the cursor name used in the SQL statement in error.

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0122S cursor cursor already declared

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0123S invalid host variable: hostvar

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0124S invalid null indicator variable: hostvar

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0125S statement statement not declared

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0126S statement statement already declared

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0127S host variable hostvar ambiguous

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0001S DECLARE syntax error, last token read: token

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0002S identifier too long

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0003S engine check error: message

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0004S identifier token not defined

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0005S host variable used without colon

No action is required, as this is a warning. For compatibility across multiple SQL syntaxes, a colon should always precede host variables. Currently, SQL Option and DB2 support the use of host variables without a colon, but this feature may be revoked at some time in the future.

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0006S UNION of SELECT INTO is deprecated feature with undefined results

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0101S error creating DBRM file: file

Parent topic: SQL - SQL PL/I Precompiler Error Messages


SQL0102S error opening input file: file

Parent topic: SQL - SQL PL/I Precompiler Error Messages


WCRT010: The location name does not exist.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT011: The synonym/alias name does not exist in the database.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT012: Incomplete location specification. No object specified.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT013: No name specified for field # fieldnum.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT014: No data type specified for field # fieldnum.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT015: No length specified for field # fieldnum.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT016: No column with a matching type found.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT017: No foreign key name specified.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT018: No index name specified.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT019: No alias name specified.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT020: No synonym name specified.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT021: Cannot undo the Drop designation for this primary key index due to the existence of another primary key specification.

In order to allow this operation to succeed, you must first either delete (i.e. drop) the other (and newly specified) primary key index, or alter the type of the other primary key index from being a primary key to either a regular index or unique index.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT022: No referenced table specified for the relationship.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT023: object name name is already defined for this table.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT024: Location specified in Alias Name.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT025: No target location(s) specified for the Alias.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT026: Index creator. index-name already exists in location location.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT027: Table/View/Synonym/Alias creator. name already exists in location location.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT028: Location name already exists.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT029: Cannot alter/drop table with over number columns using this method.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT030: The directory directory-name does not exist.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT031: Log cannot be forwarded to a directory-name. It appears to be used by a different location.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT032: Invalid format for directory directory-name.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT033: Illegal null permission for field Field specified.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT034: You cannot alter a Global Temporary Table.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT035: You can not alter a table that contains a distinct type

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT000: Error system error: Unknown error error id.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT001: Illegal identifier identifier specified for object Name. Last symbol read was symbol.

Legal identifiers must begin with a letter (A-z), and may include letters (including standard IBM code page extended characters), digits, and the special characters #%&{}$.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT004: The data type and/or length of column col1 does not match that of primary key column col2.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT005: No columns specified for the object.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT006: Identifier identifier exceeds its maximum length of length for object-type name.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT007: Incomplete table specification. No object specified.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT008: Referenced table table does not contain a primary key.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT009: The index index does not exist for the table table.

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WCRT036: Altering a table that contains a BLOB column is not supported

Parent topic: WCRT - SQL Wizard Create/Alter Table Error Messages


WSQL009: Query result cannot be edited.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL010: Error executing menu.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL011: Printing failed.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL012: Cannot list windows.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL013: Too many windows.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL014: Window does not have METRICS data.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL015: Incomplete line in string.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL016: No default value in string.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL017: Prompted number number is out of range, should be 1-100.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL018: Error adding item to prompted list.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL019: Cannot find the prompted number number.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL020: Invalid characters in string.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL021: Cannot find query.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL022: Argument is NULL.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL023: Cannot open temporary file.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL024: Cannot create temporary file.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL025: You must have a valid connection to use all of SQLWizard's options.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL026: Invalid entry in field fieldname.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL027: Window does not have METRICS data.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL028: Cannot open query.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL029: Error running batch SQL.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL030: No such Query.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL031: No column needs order by.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL032: Cannot create toolbar.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL033: Error saving file filename.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL034: Error seeking file.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL045: Name name is invalid.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL046: Cannot save query. Please check if disk is full.

Check that nothing is preventing SQLWizard from accessing the query tables (the sysquery.tab and syspromp.tab files). For example, check that the drive on which they are stored is available and operational. Check also that the files are not "read-only."

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL047: The query has been corrupted.

Recreate and save the query.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL049: SELECT error. May not have privileges.

Verify that you are running with the correct SQLID for the task and that you have the permissions necessary to access the object. If you need access to an object for which you do not have privileges, see the owner of the object or your database administrator.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL050: Cannot edit tables with renamed columns.

SELECT xemp = e_no FROM tutorial.employee;

When you edit the result, SQLWizard attempts to update xemp, which doesn't exist in the table.

To edit the result, reissue the query without renaming the column.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL051: Batch error in command number number.

Examine the script file and correct the error in the specified command.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL052: End of statement delimiter not found.

Check that all your SQL statements end with the proper end-of-statement character (a semi-colon). Check also that all strings in your SQL stream are delimited with matching quote characters. This error can occur if an end-of-string quote is missing or if the end-of-string delimiter doesn't match the string's start-of-string delimiter. (For example, if you typed a double quote at the beginning of the string and a single quote at the end, like this: "string value' ).

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL053: Filters yield no results. Filters are reset.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL054: Cannot display result set containing a LOB field.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL055: Invalid value, terminator_character, specified for TERMINATOR.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL001: XDB Engine is not loaded.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL002: Error allocating memory.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL003: Error opening file filename.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL004: Error creating name window.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL005: Error creating name dialog.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL006: Error creating name text editor.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL007: Error adding line to text editor.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL008: Prohibit Cartesian products.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL035: Error seeking query.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL036: Cannot find table name.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL037: Cannot paste table name.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL038: Cannot open init file.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL039: Cannot paste query.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL040: The editor is read-only.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL041: Cannot open a synonym under a different location or AuthID.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL042: Error in querying SYSACFUSERS.

Resolution:

We provide SQL scripts you can run to grant privileges against system catalog tables. All are located in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.xmfsql\cfg directory and must be run from there.

Note: Scripts with filenames beginning with XP enable you to grant privileges to the PUBLIC user ID. Scripts with filenames beginning with XU enable you to grant privileges to any user ID other than PUBLIC.
  • XPALLVU.SQL and XUALLVU.SQL - Create a view of the system catalog tables of a location and grant select privileges on that view.
  • XPGRTALL.SQL and XUGRTALL.SQL - Grant select privileges on the system catalog tables of a location.
  • XPGRTSYS.SQL and XUGRTSYS.SQL - Grant select privileges on the system catalog tables of the SYSTEM location.
  • XPSYSVU.SQL and XUSYSVU.SQL - Create a view of the system catalog tables of the SYSTEM location and grant select privileges on that view.
Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL043: Cannot access SYSIBM tables using AuthID authid.

Resolution:

We provide SQL scripts you can run to grant privileges against system catalog tables. All are located in your %ProgramFiles(x86)%\Micro Focus\Studio Enterprise Edition x.xmfsql\cfg directory and must be run from there.

Note:

Scripts with filenames beginning with XP enable you to grant privileges to the PUBLIC user ID. Scripts with filenames beginning with XU enable you to grant privileges to any user ID other than PUBLIC.

  • XPALLVU.SQL and XUALLVU.SQL - Create a view of the system catalog tables of a location and grant select privileges on that view.
  • XPGRTALL.SQL and XUGRTALL.SQL - Grant select privileges on the system catalog tables of a location.
  • XPGRTSYS.SQL and XUGRTSYS.SQL - Grant select privileges on the system catalog tables of the SYSTEM location.
  • XPSYSVU.SQL and XUSYSVU.SQL - Create a view of the system catalog tables of the SYSTEM location and grant select privileges on that view.
Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


WSQL044: Cannot access SYSXDB tables using AuthID authid.

Parent topic: WSQL - SQL Wizard Interactive SQL Error Messages


X009: Illegal field name name.

Parent topic: X000 - X049


X010: No more RAM memory available.

Parent topic: X000 - X049


X011: Type mismatch within expression.

Parent topic: X000 - X049


X012: Type mismatch while doing comparison.

This error can also be returned if a FETCH statement is returning data into a data structure, and the data structure associated with the FETCH statement is not exactly the same as the data structure associated with the DECLARE CURSOR statement. Look for transposed columns, or missing columns in one of the data structures. For example, if the engine is returning numeric data in the cursor into a character field in the fetch, this error is returned.

Parent topic: X000 - X049


X013: Order by clause invalid on singleton select statement.

Parent topic: X000 - X049


X014: Set location can only be used for local locations.

Parent topic: X000 - X049


X015: Attempt to close an unopened location directory.

Parent topic: X000 - X049


X016: Undefined query identifier or location not open.

If you are using Direct Flight software, an internal error has occurred. Record the version of XDB Server software you are using and contact Micro Focus Technical Support.

Parent topic: X000 - X049


X017: Illegal record position.

Parent topic: X000 - X049


X018: Duplicate value in unique index name.

Parent topic: X000 - X049


X019: Query too long.

Parent topic: X000 - X049


X020: Syntax error. Last symbol read was string.

This error can be caused by incorrect (or inconsistent) settings of environment variables used by the Micro Focus COBOL compiler. For example, a syntax error can occur when Micro Focus is running in EBCDIC mode and XDB Server is running in ASCII mode.

If the Micro Focus COBOL.DIR directive file (or any other Micro Focus directive file) contains a CHARSET(EBCDIC) directive, then the XDBCOB.DIR directive file should contain a matching EBCDIC directive. An EBCDIC/ASCII mismatch can be deduced while checking the value of SQLERRMC (SQLCA variable) from within your Micro Focus Animator session.

If the value which appears for SQLERRMC consists of a series of unreadable characters, then a character set mismatch has probably occurred.

If using the DAYS function, you cannot use a group level for date. You must redefine the group level to one field definition. (The group level is the level that has elementary items within a COBOL program.)

Parent topic: X000 - X049


X021: Pathname too long.

Parent topic: X000 - X049


X022: Too many queries open at same time.

Parent topic: X000 - X049


X023: Length of value exceeds length of destination.

Parent topic: X000 - X049


X024: Index Name has been damaged.

Parent topic: X000 - X049


X025: Incomplete comment.

Parent topic: X000 - X049


X026: Exceeds max number of tables/views permitted in query.

Parent topic: X000 - X049


X027: Maximum of number connected client nodes has been exceeded.

Try connecting to the server at a later time or during off-peak hours. If this problem occurs frequently, you may want to consider upgrading your XDB Server license. Contact Micro Focus Sales to do this.

Parent topic: X000 - X049


X028: Cannot find table/view/synonym name.

Parent topic: X000 - X049


X029: Invalid hex constant.

Correct the hex constant and resubmit the statement or program.

Parent topic: X000 - X049


X030: Invalid field number.

Parent topic: X000 - X049


X031: Cannot truncate log file.

Parent topic: X000 - X049


X032: Lock Conflict.

Parent topic: X000 - X049


X033: Column name is ambiguous.

Parent topic: X000 - X049


X034: Illegal correlation name name.

Parent topic: X000 - X049


X046: Illegal number of fields specified for compound index.

Parent topic: X000 - X049


X047: Index name too long.

Parent topic: X000 - X049


X048: Index name already exists.

SELECT creator,name FROM sysibm.sysindexes
Parent topic: X000 - X049


X049: Duplicate name name in create index list.

Parent topic: X000 - X049


X050: No more RAM available to REDIRECTOR.

If you are using JDBC, this error indicates a shortage of memory or swap space on the XDB Server computer.

Try resubmitting your request. If other programs/transactions have finished processing, the XDB Server may have enough memory to process your request.

If this error becomes a persistent problem...

  • Check that there is adequate disk space available on the swap device used by the server machine.
  • Reduce the number of other programs running on the server and/or limit the number of active transactions allowed by the XDB Server and other transaction-processing programs.
  • Increase the hardware capacity of your server machine (specifically, RAM and hard disk).

If this error persists, contact Micro Focus Technical Support.

Parent topic: X000 - X049


X051: Duplicate key value when creating unique index indexname.

To fix this problem, drop this index and then test for duplicates using the following query:

SELECT index-field-list FROM table-name GROUP BY index-field-list HAVING count(*) > 1

where index-field-list is the list of the columns in the index you are trying to create, and table-name is the name of the table you are indexing. The rows retrieved correspond to duplicate entries that prevent you from creating a unique index on the specified fields.

If duplicates are found, perform a SELECT * from the table where values equal those of the results that come from the previous query and delete the additional entry rebuild index after dropping duplicates. If no records are retrieved, there are no duplicates.

Parent topic: X050 - X099


X052: Cannot update field to incompatible type.

Parent topic: X050 - X099


X053: String length is larger than field length.

Parent topic: X050 - X099


X054: Unequal number of fields and values.

Parent topic: X050 - X099


X055: Duplicate names name in insert/alter/create list.

Parent topic: X050 - X099


X056: Table/View name already exists.

SELECT name, ''table'' FROM sysibm.systables UNION SELECT name, ''view '' FROM sysibm.sysviews
Parent topic: X050 - X099


X057: Specified more fields or values than the table has.

Parent topic: X050 - X099


X058: Field name type incompatible with type type.

Parent topic: X050 - X099


X059: Inserting character constant larger than field length specified.

Parent topic: X050 - X099


X060: value is outside allowable field length boundary.

Parent topic: X050 - X099


X061: number is greater than maximum allowable number of fields.

Parent topic: X050 - X099


X062: Value value is too large to insert into field name.

Parent topic: X050 - X099


X063: Index name not found.

SELECT name FROM sysindex
Parent topic: X050 - X099


X064: Not a proper command or command not implemented.

Parent topic: X050 - X099


X065: Illegal field name name in order specification.

Parent topic: X050 - X099


X066: Illegal number number in order/group specification.

Parent topic: X050 - X099


X067: Aggregates not allowed in WHERE clause of query.

Parent topic: X050 - X099


X068: Selecting an expression with a GROUP BY clause.

Parent topic: X050 - X099


X069: Too many set clauses in update command.

Parent topic: X050 - X099


X070: Ordering by field name that is not selected.

Parent topic: X050 - X099


X071: Selecting more than one item in a nested query.

Parent topic: X050 - X099


X001: Cannot perform operation (errornum) on file filename.

1005 | No such file or directory (ENOENT)
1011 | Bad file descriptor (EBADF)
1013 | Permission denied (EACCES)
1020 | File exists (EEXIST)
1023 | Too many open files (EMFILE)
1027 | No space left on device (ENOSPC)

If errornumber is less than 1000, then this is an error specific to your platform. If the errornumber you get is not in the table, contact Micro Focus Technical Support.

The following are more detailed descriptions of values for errornumber:

  • 1005 No such file or directory (ENOENT).

    The specified file or directory does not exist or cannot be found. This message can also occur when a component of the path name does not specify an existing directory.

  • 1011 Bad file descriptor (EBADF).

    The specified file handle is not a valid file handle value, it does not refer to an open file, or an attempt was made to write to a file or device opened for read-only access (or vice versa).

  • 1013 Permission denied (EACCES).

    The file's permission does not allow the specified access. This error occurs when someone attempts to access a file or directory in a way that is incompatible with the file or directory attributes. For example, this error will occur when an attempt to read is made on an unopened file, or when an attempt to write is made on a read-only file.

  • 1020 File exists (EEXIST)

    The O_CREATE and the OEXCL flags are specified when opening a file, but the named file already exists.

  • 1023 Too many open files.

    The number of files exceeds the maximum allowed.

  • 1027 No space left on device (ENOSPC).

    No more space for writing is available on the device. For example, the disk is full.

Parent topic: X000 - X049


X082: Each query in a UNION must have the same number of projected fields.

Parent topic: X050 - X099


X083: Data types in column name do not match.

Parent topic: X050 - X099


X084: ORDER BY items must be constants for union of queries.

Parent topic: X050 - X099


X085: ORDER BY must follow all queries when performing a union.

Parent topic: X050 - X099


X086: NULL not allowed in field name.

Parent topic: X050 - X099


X087: Table/View name exceeds maximum length of number.

Parent topic: X050 - X099


X088: Field name length exceeds maximum length of number characters.

Parent topic: X050 - X099


X089: Cannot open location on path. Check location path setting.

Parent topic: X050 - X099


X090: Too many users registered.

Parent topic: X050 - X099


X091: User has no privilege privilege on objectname.

Parent topic: X050 - X099


X092: User account has been disabled.

Re-enabling is done when a superuser re-grants access authority by clicking Users on the Admin menu in SQL Wizard.

Parent topic: X050 - X099


X093: Unknown user name.

Parent topic: X050 - X099


X094: User userid cannot GRANT/REVOKE on table/view/database name.

Parent topic: X050 - X099


X095: Invalid receipt. (Should register first.)

This condition may occur when a program developed with an application interface attempts to short circuit XDB Server security. Programmers should refer to the C Application Programming Interface Xdbxlogin() or Xdbxqutrcpt() functions. Others should contact their database administrator and/or software developer.

Parent topic: X050 - X099


X096: Illegal password.

Parent topic: X050 - X099


X097: Illegal attempt to open more than one location.

Parent topic: X050 - X099


X098: Cannot grant a privilege to yourself.

Parent topic: X050 - X099


X099: User already exists.

Parent topic: X050 - X099


X100: Memory Resident Engine not loaded!

Parent topic: X100 - X149


X101: Illegal function code passed to engine.

Parent topic: X100 - X149


X102: Cannot find view name.

Parent topic: X100 - X149


X103: Must select aggregates if using HAVING clause with no GROUP BY.

Parent topic: X100 - X149


X104: A password is required for connection with LU servername.

Parent topic: X100 - X149


X105: Operation not allowed on view name.

Parent topic: X100 - X149


X106: No translation row in tablename SYSUSERNAMES for LU servername.

Parent topic: X100 - X149


X107: Current AuthID can't be used to reference remote object.

Check that you are using a valid AuthID for the requested location (make sure you have supplied the appropriate AuthID and that you have spelled it correctly). Also check with your database administrator to determine whether this ID is valid for the requested location.

Parent topic: X100 - X149


X002: Empty query string.

Parent topic: X000 - X049


X119: Location name exceeds maximum length of number.

Parent topic: X100 - X149


X120: Cannot find location name in SYSXDB.SYSLOCALS table.

Parent topic: X100 - X149


X121: Operation requires system level privilege.

Parent topic: X100 - X149


X122: Incorrect location files on path path.

Parent topic: X100 - X149


X123: Cannot open system location on path path.

Parent topic: X100 - X149


X124: Illegal operation on system object.

SQLWizard Notes:

If you are running against XDB Server or a local copy of the SQL Engine, the SYSIBM and SYSXDB items (found in the SQL page of Options) should be set to SYSIBM and SYSXDB, respectively. This causes catalog queries to be issued directly against the catalog tables.

If you are running against DB2 via XDB Link you will usually use views of the catalog tables instead of accessing the tables directly. Your database administrator should be able to tell you the AuthID to use for catalog queries.

Contact Micro Focus Support for availability of an update that allows queries to views of the system catalog tables.

Parent topic: X100 - X149


X125: Must execute statement before fetch.

Parent topic: X100 - X149


X126: Cannot GROUP BY an aggregate function.

Parent topic: X100 - X149


X127: Pattern matching allowed on character fields only.

Parent topic: X100 - X149


X128: Target table cannot also be source table.

Parent topic: X100 - X149


X129: Attempt to insert invalid data into field name.

Parent topic: X100 - X149


X130: Attempt to drop system location.

Parent topic: X100 - X149


X131: Attempt to drop location in use.

SQLWizard Notes:

If you open a location, or query the tables in a location (by looking at the location through the Catalog Browser, for example), the SQL Engine considers the location to be in use. If you receive the error when you try to drop a location:

  1. Exit from SQLWizard (or the application that is returning the error).
  2. If your default location is the location you want to drop, you must open Options and change the default location to a different location.
  3. Restart SQLWizard.
  4. Drop the location using the Location menu's Drop option.
Parent topic: X100 - X149


X132: Cannot find location name name in SYSXDB.SYSLOCALS table.

Parent topic: X100 - X149


X133: Cannot use reserve word word in table/index definition.

Parent topic: X100 - X149


X134: error: DOMAIN ERROR.

Parent topic: X100 - X149


X135: error: RANGE ERROR.

Parent topic: X100 - X149


X136: Functionality not available with LITE engine.

Eliminate the invalid commands from the statement, or contact Micro Focus Sales to have the XDB Server upgraded to the full-featured version.

Parent topic: X100 - X149


X137: Cannot perform operation (errno) on location file name.

Parent topic: X100 - X149


X138: Illegal operation on view.

Parent topic: X100 - X149


X139: Record size exceeds the maximum.

Parent topic: X100 - X149


X140: WITH CHECK OPTION clause not allowed on read only view.

Parent topic: X100 - X149


X141: Record does not satisfy view definition.

Parent topic: X100 - X149


X142: Operation not allowed on read only view.

Parent topic: X100 - X149


X143: Table already has check condition.

Parent topic: X100 - X149


X144: Record does not satisfy table name check condition.

Parent topic: X100 - X149


X003: INI Error errmsg

file - the .INI file name (XDBNET.INI in this case) where the error occurred.

section - the server section name in XDBNET.INI where an error occurred.

item - the server section parameter name (for example, IpAddress or IpxNodeAddr) where an error occurred.

string - the server section string value where an error occurred.

Possible Error Messages:

  • Item item had no associated string in file section [section].

    Sample XDBNET.INI file error where a string value is missing:

    [server XDB] IpAddress=
  • file file not found.

    The XDBNET.INI file identified by file does not exist.

  • Section [section] was not found in file.

    The server section identified by section could not be found in the XDBNET.INI file.

  • Item item was not sound in section [section] of file file.

    A required item identified by item (such as a TcpPort value) was not found in the server section identified by section of the XDBNET.INI file.

  • File file : Section [section] : Item item has data too long.

    The data in an XDBNET.INI file item has exceeded the allowable number of digits.

  • File file : Section [section] : Item item has invalid data.

    Parameter appearing in an XDBNET.INI file item contains an invalid value.

Note:

If using a version earlier than 5.0, XDB will return the following X003 error message:

X003: Money value overflow.

An attempt was made to place a value that is too large or too small into a numeric field (float, int, smallint, etc.). See XDB Server Specifications in the SQL Reference for maximum and minimum values permitted in numeric data types. Check picture specifications.

Parent topic: X000 - X049


X155: Table/record currently locked by user at node.

Parent topic: X150 - X199


X156: Table/record currently locked by user at node.

Parent topic: X150 - X199


X157: Cannot obtain exclusive lock or drop lock in isolation level 5 or 6.

SET ISOLATION isolation-level
Parent topic: X150 - X199


X158: Cannot obtain or delete table locks in isolation level 5 or 6.

Parent topic: X150 - X199


X159: Current location is locked by user at node.

Parent topic: X150 - X199


X160: Cannot obtain isolation level EU due to existing locks.

Parent topic: X150 - X199


X161: Not enough memory free on XDB Server to process request.

Parent topic: X150 - X199


X162: Logging in to XDB Server name requires security on at user node.

SQLWizard Notes:

Open Options to the Connect page, and click on the Client Security option to check it. Close Options and try starting SQLWizard again.

Parent topic: X150 - X199


X163: No network node name specified. Must be set through XDBCONFIG.

Parent topic: X150 - X199


X164: Operation cannot be performed in isolation level DR or SR.

Parent topic: X150 - X199


X165: Redirector version does not match XDB Server version.

Please add one of the following to the [CLIENT] section of XDB.INI:

XDBPacketVer=251

or

XDBPacketVer=255
Parent topic: X150 - X199


X166: Operation requires isolation level EU (Exclusive Use) with this server.

Parent topic: X150 - X199


X167: Redirector does not support the selected protocol protocol.

Parent topic: X150 - X199


X168: User has been deleted by DBA at XDB Server.

Parent topic: X150 - X199


X169: Attempted to examine the status of an un-executed command.

If in Windows, exit from Windows and then restart it. Retry the command.

SQLWizard NOTE: To recover from this problem so that you can continue running Micro Focus applications, exit from the calling application (like SQLWizard) and close the SQL Engine (if it is loaded). Then open the Process Viewer and click on the Kill All button to close down all remaining processes.

Parent topic: X150 - X199


X170: Referenced key field type(s) must match foreign key field type(s)

Parent topic: X150 - X199


X171: Foreign key already exists on field(s) specified.

Parent topic: X150 - X199


X172: Cannot create directory on path path.

Parent topic: X150 - X199


X173: Cannot flush location file contents to disk.

Parent topic: X150 - X199


X174: Synonym/Table name already exists.

Parent topic: X150 - X199


X175: Synonyms cannot be created on other synonyms.

Parent topic: X150 - X199


X176: Synonym name does not exist.

Parent topic: X150 - X199


X177: Maximum identifier size exceeded.

Parent topic: X150 - X199


X178: Precision must be a value between 1 and 31.

Parent topic: X150 - X199


X179: Scale must be a value between 0 and the precision.

Parent topic: X150 - X199


X180: Cannot truncate table file.

Parent topic: X150 - X199


X004: Number value overflow.

Parent topic: X000 - X049


X191: View definition too large for memory buffer.

Parent topic: X150 - X199


X192: Error in source view definition.

Parent topic: X150 - X199


X193: Outer join condition not allowed on expression predicates.

Parent topic: X150 - X199


X194: Attempt to divide by zero.

Parent topic: X150 - X199


X195: User does not have privileges necessary for renaming a table.

Parent topic: X150 - X199


X196: Expression in GROUP BY/ORDER BY clause not allowed.

Parent topic: X150 - X199


X197: Expression not allowed on left side of set clause.

Parent topic: X150 - X199


X198: Expression not allowed for field of insert clause.

Parent topic: X150 - X199


X199: Illegal foreign key constraint.

Parent topic: X150 - X199


X200: Illegal attempt to log out of parent process when dependents exist.

Parent topic: X200 - X249


X201: User does not have privilege necessary for operation.

Parent topic: X200 - X249


X202: Check condition does not exist.

Parent topic: X200 - X249


X204: Referenced key must be a primary/candidate key.

This message could also be returned if a program manipulates data from the system tables, and the site is converting from Version 2.41 to 3.x or 4.0. Look for table names that are no longer in the Version 3.x or 4.0 system tables. Make sure all references to these tables are changed prior to the pre-compilation.

Parent topic: X200 - X249


X205: Invalid character representation of numeric data.

Parent topic: X200 - X249


X206: Compatibility index must be set to group by number.

Parent topic: X200 - X249


X207: Check condition/view name incompatible with current version.

Parent topic: X200 - X249


X208: Table/View exists in target location. Use WITH REPLACE to overwrite.

Parent topic: X200 - X249


X209: Cannot perform GROUP BY on a view containing a GROUP BY.

Parent topic: X200 - X249


X210: Cannot perform join with a view containing a GROUP BY.

Parent topic: X200 - X249


X211: Cannot perform aggregate function on a view containing a GROUP BY.

Parent topic: X200 - X249


X212: Function not available under current compatibility setting.

Parent topic: X200 - X249


X213: Internal error encountered in function function. Contact Micro Focus.

Parent topic: X200 - X249


X214: The cursor identified in an open statement is already open.

Parent topic: X200 - X249


X215: The cursor identified in a fetch/close statement is not open.

Parent topic: X200 - X249


X216: Exceeded maximum outer join conditions.

Parent topic: X200 - X249


X217: Specified more than one primary key clause.

Parent topic: X200 - X249


X005: Date value error.

Parent topic: X000 - X049


X228: The relationship name restricts the deletion of row with ID number.

A row of the table cannot be deleted because it has a dependent in a relationship with a delete rule of RESTRICT or the deletion cascades to a row which is dependent in a relationship with a delete rule of RESTRICT.

Examine the delete rule for all dependent tables to determine the cause of the problem. The specified tables involved can be determined from the relationship name name. The specific dependent row is known by record number,number. This is the number of the row from the beginning of the table.

Parent topic: X200 - X249


X229: The insert/update value of foreign key name is invalid.

When a row is inserted into a dependent table, the insert value of a foreign key must be equal to the value of the primary key of some row of the parent table in the associated relationship.

When the value of the foreign key is updated, the update value of the foreign key must be equal to the value of the primary key of some row of the parent table of the associated relationship.

Examine the INSERT or UPDATE value of the foreign key first, and then compare it with each of the primary key values of the parent table to determine the problem.

Parent topic: X200 - X249


X230: Index name is not compatible with current version.

Parent topic: X200 - X249


X231: Cursor must be declared as FOR UPDATE OF.

Parent topic: X200 - X249


X232: Index name sort sequence different from current setting.

Parent topic: X200 - X249


X233: Non-quantified predicate followed by a list of values.

Parent topic: X200 - X249


X234: Function not available with engine as database engine.

Parent topic: X200 - X249


X235: XDBXDIRECT function not supported on GROUP BY cursor.

Parent topic: X200 - X249


X236: Must use ALTER TABLE DROP PRIMARY KEY to drop index pending.

Parent topic: X200 - X249


X237: operation not allowed on table name while in use.

Parent topic: X200 - X249


X238: Attempt to update a deleted record.

Parent topic: X200 - X249


X239: Invalid DEGREE specified.

Check that your SET CURRENT DEGREE value is one of the following:

  • "ANY"
  • "1" (a one)
  • "1 " (a one followed by 2 spaces)

These are the only values allowed by this command.

Parent topic: X200 - X249


X240: Cannot delete field name which has existing referential key.

Parent topic: X200 - X249


X241: Cannot modify field name which has existing referential key.

Parent topic: X200 - X249


X242: Maximum number of sort fields exceeded.

Parent topic: X200 - X249


X243: Host variable not allowed in current command.

Parent topic: X200 - X249


X244: Object table is referenced in nested query FROM clause.

Parent topic: X200 - X249


X245: Requested packet is larger than max buffer size.

To increase the receive buffer size, add the following line to the XDB.INI's file's {

Parent topic: X200 - X249


X246: Primary key cannot be target of multiple-row update.

Parent topic: X200 - X249


X247: String representation of a date/time value is invalid.

Parent topic: X200 - X249


X248: AuthID not allowed on synonym table reference.

Parent topic: X200 - X249


X249: Invalid picture specification.

Parent topic: X200 - X249


X250: Invalid PCTFREE value.

Parent topic: X250 - X299


X251: Only one clustered index allowed per table.

Parent topic: X250 - X299


X252: Truncate not allowed on primary key table.

Parent topic: X250 - X299


X006: String constant too long.

Parent topic: X000 - X049


X263: XdbWinInit() has not been called. XdbWinInit() must be called first.

Parent topic: X250 - X299


X264: A necessary window could not be created.

Parent topic: X250 - X299


X265: User program ProgramName could not be found.

Verify that the LOADMOD column in the SYSIBM.SYSPROCEDURES table specifies the correct DLL for your stored procedure. Also confirm that:

  • The DLL exists.
  • The DLL is in a directory that can be accessed by the XDB Server (check permissions).
  • The specified procedure (function) is contained in the DLL.
  • The procedure name as specified in the PROCEDURE column of the SYSIBM.SYSPROCEDURES table matches the function name in the DLL exactly with respect to case. For example, if your function is called "MyProc" in the DLL, it must also be specified as "MyProc" in the PROCEDURE column -- not "myproc" or "MYPROC".
Parent topic: X250 - X299


X266: Server is shutting down. Accepting no more logins.

Parent topic: X250 - X299


X267: Invalid parameter in function function.

Do the following:

  • Record the version of the XDB Server software you are using.
  • Record the version of the client software you are using.
  • Make a note of the operation that failed.
  • Contact Micro Focus Technical Support.
Parent topic: X250 - X299


X268: Server shutdown already in progress.

Parent topic: X250 - X299


X269: Illegal shutdown parameter.

Parent topic: X250 - X299


X270: Update/Delete on invalid cursor position.

Parent topic: X250 - X299


X271: The Server failed when trying to begin a thread.

Number of Named Pipe threads

Number of NetBIOS threads

Number of Engine threads

Parent topic: X250 - X299


X272: Cannot open file name. Increase the max number of open files in the XDB Server Configuration utility.

Parent topic: X250 - X299


X273: AuthID exceeds the maximum length.

Parent topic: X250 - X299


X274: Location name exceeds the maximum length.

Parent topic: X250 - X299


X275: Column name in explanation table name is not defined properly.

Parent topic: X250 - X299


X276: Invalid number of fields (number) in explanation table name.

Parent topic: X250 - X299


X277: userid does not have privilege to create with qualification authid.

Parent topic: X250 - X299


X278: auth specified is not one of the valid AuthIDs.

Parent topic: X250 - X299


X279: Name name is too long. Maximum allowable size is number.

Parent topic: X250 - X299


X280: name is an undefined name.

Parent topic: X250 - X299


X281: Object name name of object type type already exists.

Parent topic: X250 - X299


X282: Too many volume serial numbers specified.

Parent topic: X250 - X299


X283: The PART clause of an ALTER statement is omitted or invalid.

Parent topic: X250 - X299


X284: Duplicate keyword keyword.

Parent topic: X250 - X299


X285: Attempt to drop stogroup used by a tablespace.

Parent topic: X250 - X299


X286: Operation not allowed on system database.

Parent topic: X250 - X299


X287: Alias name must not be defined on another alias.

Parent topic: X250 - X299


X288: Statement reference to remote object is invalid.

  • An alias has been used incorrectly.
  • Multiple locations are referred to in the statement.
  • A three-part name is used in a statement that is not supported by Distributed Unit of Work. Only INSERT, UPDATE, DELETE, and SELECT statements can reference a remote location.
  • An attempt is made to logon to a mainframe location from SQL Wizard but the link or the location name is not configured correctly.
Parent topic: X250 - X299


X007: Incomplete string. Check for missing quotes.

select * from employee where lname = 'O'Brien' and st = ''VA''

should be changed to:

select * from employee where lname = ''O'Brien'' and st = ''VA''
Parent topic: X000 - X049


X299: A segmented tablespace may not be partitioned.

Parent topic: X250 - X299


X300: Cannot open configuration file CONFIG.XDB. Check XDBCFG setting.

Execute the following command:

SET XDBCFG=xdbpath

where xdbpathis the appropriate Micro Focus configuration directory. Make sure you specify the same directory using Options (described in the Options User's Guide).

Parent topic: X300 - X349


X301: Cannot open configuration file CONFIG.XDB. Check XDBCFG setting.

Execute the following command:

SET XDBCFG=xdbpath

where xdbpathis the appropriate Micro Focus configuration directory. Make sure you specify the same directory using Options (described in the Options User's Guide).

Parent topic: X300 - X349


X302: Cannot read configuration file CONFIG.XDB.

Parent topic: X300 - X349


X305: Cannot open help file name.

Parent topic: X300 - X349


X306: Syntax error in mask definition.

Parent topic: X300 - X349


X307: Grouping character found twice or in illegal position.

Parent topic: X300 - X349


X308: No grouping length.

Parent topic: X300 - X349


X309: Decimal character found twice or in illegal position.

Parent topic: X300 - X349


X310: Rounding character in illegal position.

Parent topic: X300 - X349


X311: Illegal character in picture specification.

Parent topic: X300 - X349


X312: "$" character found on both sides of decimal.

Parent topic: X300 - X349


X313: Sign character found on both sides of the decimal.

Parent topic: X300 - X349


X314: Error in substitution portion of picture definition.

x PIC $999,999.99 $='DM' .=',' ,='.' MASK salary $999,999.99 $='DM' .=',' ,='.'
Parent topic: X300 - X349


X315: Illegal decimal found in picture.

Parent topic: X300 - X349


X316: Illegal rounding character found in picture.

Parent topic: X300 - X349


X317: Illegal dollar sign found in picture.

Parent topic: X300 - X349


X318: Closing single quote not found in substitution string.

Parent topic: X300 - X349


X319: Value too wide for picture field.

Parent topic: X300 - X349


X320: Error in time/date picture definition.

Parent topic: X300 - X349


X321: Invalid CONFIG.XDB. Run XDBPROFI to reconfigure system.

Parent topic: X300 - X349


X322: Invalid year value.

Parent topic: X300 - X349


X323: Invalid separator in value.

Parent topic: X300 - X349


X324: Invalid character in value.

Parent topic: X300 - X349


X325: Money value error.

Parent topic: X300 - X349


X326: Numeric value error.

Parent topic: X300 - X349


X008: Version number incompatibility in user exit file.

Parent topic: X000 - X049


X338: Table/View name does not exist.

Parent topic: X300 - X349


X339: Error opening file FileName for Page1 to Page2 translation.

Make sure that this file exists on the XDB Server, that it is in the correct directory (as reported by the file's path in this message), and that there is nothing preventing the server from accessing this file. For example, check that the drive on which the file is stored is available and operational, that the file is readable, and the file is in a directory that can be accessed by the XDB Server (check permissions).

If you cannot locate this file on your system, contact Micro Focus Technical Support to obtain a copy of it.

Parent topic: X300 - X349


X340: Not enough memory to perform action.

Parent topic: X300 - X349


X341: Illegal decimal precision.

Parent topic: X300 - X349


X342: Called function is not compatible with current version.

Parent topic: X300 - X349


X343: An explicit COMMIT is illegal in an IMS/CICS program.

Parent topic: X300 - X349


X344: An explicit ROLLBACK is illegal in an IMS/CICS program.

Parent topic: X300 - X349


X345: A negative or zero ABSOLUTE FETCH is illegal.

Parent topic: X300 - X349


X346: Cannot locate files in the directory specified.

Parent topic: X300 - X349


X347: Illegal function code passed to the COBOL interface.

Parent topic: X300 - X349


X348: No application path specified.

Parent topic: X300 - X349


X352: Server violation.

Parent topic: X350 - X399


X354: Error loading server communications DLL(name).

Parent topic: X350 - X399


X355: Error connecting to remote server(name).

Parent topic: X350 - X399


X356: Error sending to remote server(name).

Parent topic: X350 - X399


X357: Error receiving from remote server(name).

Parent topic: X350 - X399


X358: Governor limit exceeded.

Parent topic: X350 - X399


X359: Error initializing remote server gateway.

Check the following:

  • Verify that the system catalog on the local server contains a server-to-server definition for the remote server and that that definition is correct.
  • Ensure that xdb\GTWY40n.DLL exists on the local server.

Also, if your local server is running as an application (rather than as a service) under Windows NT, use the Server Configuration Utility to verify that the Remote Threads parameter is set to a value greater than 0.

See the XDB Server Administration Guide for additional information about specifying remote threads and establishing server-to-server connectivity.

Parent topic: X350 - X399


X360: Incorrect version of the server configuration file.

Parent topic: X350 - X399


X361: No remote thread available to process request.

Parent topic: X350 - X399


X362: Index error during recovery.

Parent topic: X350 - X399


X363: No protocol threads available to process request.

Parent topic: X350 - X399


X364: The describe statement does not identify a prepared statement.

Parent topic: X350 - X399


X365: Log path cannot be set to path.

Parent topic: X350 - X399


X366: Error replacing alias name with actual table name.

Parent topic: X350 - X399


X367: GROUP BY/HAVING not allowed in subquery/embedded select.

Parent topic: X350 - X399


X035: Length of input host variable number number is invalid.

If you are using VARCHAR fields, make sure that the length of the VARCHAR field is correct.

Parent topic: X000 - X049


X037: Invalid timeout specification.

Parent topic: X000 - X049


X038: Cannot acquire read/write access on specified path.

Parent topic: X000 - X049


X039: Abort code.

Parent topic: X000 - X049


X040: Log system couldn't operation.

If operation is a file-related operation, check that there is nothing preventing the log file from being used. For example, check that there is disk space available to write the log file. Also check that the log file is not write-protected or opened for exclusive use. If the problem with the log file is not apparent, contact Micro Focus Technical Support.

If operation is an internal operation, contact Micro Focus Technical Support.

Parent topic: X000 - X049


X041: Left side of expression incompatible with right side.

Parent topic: X000 - X049


X042: Field type not compatible with nested query results.

Parent topic: X000 - X049


X043: Aggregate function on invalid type.

Parent topic: X000 - X049


X044: Invalid data type indicator.

Parent topic: X000 - X049


X045: Invalid element in structure structure in function function.

Parent topic: X000 - X049


X072: Cannot nest aggregate functions.

AVG(SUM(a))
Parent topic: X050 - X099


X073: Fields selected must appear in GROUP BY clause or inside an aggregate function.

Parent topic: X050 - X099


X074: GROUP BY clause invalid on current query.

Parent topic: X050 - X099


X075: Cannot mix fields with aggregates without GROUP BY.

Parent topic: X050 - X099


X076: Luname servername does not exist in tablename SYSLUNAMES table.

Parent topic: X050 - X099


X077: Cannot include join in table expansion.

Parent topic: X050 - X099


X078: Illegal level value for table expansion.

Parent topic: X050 - X099


X079: Insert/Delete/Update function not allowed on sorted query.

Parent topic: X050 - X099


X080: Only one DISTINCT clause allowed per query.

SELECT count(distinct sno),count(distinct pno) FROM partsupp

Parent topic: X050 - X099


X081: Exceeds maximum number of UNIONed queries.

Parent topic: X050 - X099


X108: Field list must be provided when expressions are selected.

CREATE VIEW myview(employee, currentpay, afterraise) AS SELECT lname, payrate, payrate*1.10 FROM employee

Because payrate*1.10 is an expression, column names must be provided in the CREATE VIEW clause of the command.

Parent topic: X100 - X149


X110: Cannot operation logfile filename. Check logpath setting.

Parent topic: X100 - X149


X111: Maximum number records per table in trial version.

Parent topic: X100 - X149


X112: Cannot perform operation (errno) on index index-name.

Parent topic: X100 - X149


X113: Cannot perform operation (errno) on table table-name.

Parent topic: X100 - X149


X114: Cannot close current database. Please exit.

Parent topic: X100 - X149


X115: Location already exists in the path specified.

Parent topic: X100 - X149


X116: Time value error.

Parent topic: X100 - X149


X117: Maximum number of open locations exceeded.

SQLWizard Notes: Each time you query a location, the system holds the location open, and it is counted as a "location in use." The XDB Server Configuration program lets you specify the maximum number of concurrent "locations in use" allowed by the XDB Server.

To increase the maximum number of open locations, start your XDB Server Configuration program and set the "Maximum Locations" value to a relatively large number, such as 50. Then, restart your server to put this value into effect.

Parent topic: X100 - X149


X118: Location name table already exists.

Parent topic: X100 - X149


X145: Key key not found when analyzing referential constraint.

Parent topic: X100 - X149


X146: Violation of constraint between key key1 and key key2.

Parent topic: X100 - X149


X147: Cannot find key key.

Parent topic: X100 - X149


X148: Primary key key already exists on this table.

Parent topic: X100 - X149


X149: Primary/Unique key fields must be specified as NOT NULL.

Parent topic: X100 - X149


X150: Referenced fields must be specified as NOT NULL.

Parent topic: X150 - X199


X151: Location path exceeds maximum length of 48.

Parent topic: X150 - X199


X152: Invalid transaction number.

Parent topic: X150 - X199


X153: No space for locks.

Parent topic: X150 - X199


X154: Cannot find table/record lock.

Parent topic: X150 - X199


X181: Cannot truncate index file.

Parent topic: X150 - X199


X182: Cannot perform table on forward log file name.

Parent topic: X150 - X199


X183: Cannot perform operation on backward log file name.

Parent topic: X150 - X199


X184: Illegal outer join conditions.

Parent topic: X150 - X199


X185: FOR UPDATE OF not allowed with GROUP BY or ORDER BY clause.

Parent topic: X150 - X199


X186: Maximum number of open files exceeded.

Parent topic: X150 - X199


X187: Referenced key and foreign key must have same number of fields.

Parent topic: X150 - X199


X188: Attempt to place NULL value in host variable with no indicator variable.

Parent topic: X150 - X199


X189: Source and Target locations have the same name.

Parent topic: X150 - X199


X190: Cannot copy table/view to itself.

Parent topic: X150 - X199


X218: Referenced table does not contain a primary key.

Parent topic: X200 - X249


X219: Relationship name name already exists on this table.

Parent topic: X200 - X249


X220: Operation not allowed on table with incomplete definition.

Parent topic: X200 - X249


X221: ALTER TABLE PRIMARY KEY requires existing unique index.

Parent topic: X200 - X249


X222: Relationship name must be less than 8 characters.

Parent topic: X200 - X249


X223: Self-Referencing tables must use the CASCADE delete rule.

Parent topic: X200 - X249


X224: One or more foreign key fields must be nullable for SET NULL rule.

Parent topic: X200 - X249


X225: Primary key clause does not exist.

Parent topic: X200 - X249


X226: Relationship name name cannot be found in system table SYSREF.

Parent topic: X200 - X249


X227: Attempt to update parent having dependents in relationship name.

Parent topic: X200 - X249


X253: Compact cluster by clause must specify existing clustered index.

Parent topic: X250 - X299


X254: DUPQTY value must be 8, 16, 32, 64 or 128.

Parent topic: X250 - X299


X255: Communication Manager out of memory.

Parent topic: X250 - X299


X256: Stored Procedure ProcName failed due to reason ReasonCode.

If ReasonCodeis... | The problem is that...
00E79000 | A value in either SYSIBM.SYSROUTINES or SYSIBM.SYSPARMS is invalid. This is an internal error. Please contact Product Support.
00X10000 | Too many parameters. The maximum number of parameters is 750.
00X10001 | The SQL Option Server supports COBOL and C stored procedures.
00X10002 | The attempted operation was not supported. A common cause of this is that access to a remote location was attempted without the proper XDB.INI configuration.
00X10003 | The stored procedure exceeded the number of result sets. The maximum number is 50.
00X10004 | The operating system rejected a request to create a pipe used to invoke the stored procedure. Please contact Product Support.
00X10005 | The operating system rejected a request to create a pipe used to invoke the stored procedure. Please contact Product Support.
00X10006 | The operating system rejected a request to create the stored procedure process. Please contact Product Support.
00X10007 | A write to the stored procedure communications pipe by the server has failed. This typically indicates the stored procedure has abnormally exited.
00X10008 | A read from the stored procedure communications pipe by the server has failed. This typically indicates the stored procedure has abnormally exited.
00X10009 | An internal error has prevented the stored procedures communications layer from initializing. Please contact Product Support.
00X10010 | An unknown element was passed in the SQL statement that is calling the stored procedure. Please contact Product Support.
Parent topic: X250 - X299


X257: Engine configuration maximums too large. Reconfigure them smaller.

Parent topic: X250 - X299


X258: Out of memory for expressions.

Parent topic: X250 - X299


X259: Error on Operation (size) Server (server).

Parent topic: X250 - X299


X260: Operation cannot be performed on current location version.

Parent topic: X250 - X299


X261: Redirector not loaded!

Parent topic: X250 - X299


X262: Invalid parameter. A valid window handle was expected.

Parent topic: X250 - X299


X289: Invalid value specified for keyword keyword.

Parent topic: X250 - X299


X290: Keyword keyword not allowed for tablespace in workfile database.

Parent topic: X250 - X299


X291: Illegal use of keyword keyword.

Parent topic: X250 - X299


X292: Unable to perform operation operation on database name.

Parent topic: X250 - X299


X293: Table/Index ObjectName in use.

To restrict access to a database using the STOP DATABASE command, you must issue the command while the table or index is not is use.

Parent topic: X250 - X299


X294: Unable to operation stopped database name.

Parent topic: X250 - X299


X295: Database ROSHARE can only be altered from OWNER to NONE.

Parent topic: X250 - X299


X296: Location name is not converted. Run location conversion program.

Parent topic: X250 - X299


X297: FOR FETCH ONLY and FOR UPDATE OF are mutually exclusive clauses.

Parent topic: X250 - X299


X298: Synonym target must include an explicit authorization ID.

Parent topic: X250 - X299


X327: Integer value error.

Parent topic: X300 - X349


X328: No more RAM memory available.

Parent topic: X300 - X349


X329: COMMAND.COM not found.

Parent topic: X300 - X349


X330: Cannot execute program.

Parent topic: X300 - X349


X332: Index name does not exist.

Parent topic: X300 - X349


X333: Unknown field type in table name.

Parent topic: X300 - X349


X334: Index name has been damaged.

Parent topic: X300 - X349


X335: Key name does not exist.

Parent topic: X300 - X349


X336: Key name has been damaged.

Parent topic: X300 - X349


X337: Synonym name does not exist.

Parent topic: X300 - X349


X368: Illegal string string found.

Parent topic: X350 - X399


X369: Invalid index type.

Parent topic: X350 - X399


X370: The target location needs to be compatible with DB2 version version.

Parent topic: X350 - X399


X371: The selected locksize and lockmax options do not match.

Parent topic: X350 - X399


X372: Illegal attempt to convert location to a lower version.

Parent topic: X350 - X399


X373: Invalid number of parameters (number expected) for stored procedure ProcName.

Verify that the PARMLIST column in the SYSIBM.SYSPROCEDURES table specifies the correct number of parameters for your stored procedure.

  • If the PARMLIST value is incorrect, correct it.
  • If the PARMLIST value is correct, edit the SQL CALL statement to pass the correct number of parameters to the stored procedure.
Parent topic: X350 - X399


X374: Stored procedure ProcName received a null value for parameter number.

Verify that the LINKAGE column in the SYSIBM.SYSPROCEDURES table correctly specifies whether ProcName can accept null values.

  • If ProcName can accept null values, set the LINKAGE value to N.
  • If ProcName cannot accept null values, make sure the LINKAGE value is blank. Then correct your CALL statement so that it passes a non-null value for parameter number.
Parent topic: X350 - X399


X375: Stored procedure ProcName has been placed in a must rollback state.

  • CALL
  • COMMIT
  • CONNECT
  • RELEASE
  • ROLLBACK
  • SET CURRENT SQLID

These operations are not allowed in a stored procedure.

To eliminate this error, remove the invalid operation from the stored procedure.

Parent topic: X350 - X399


X376: Missing OBID clause when creating a table in a ROSHARE READ database.

Parent topic: X350 - X399


X377: A privilege cannot be revoked because it is not possessed by AuthID authid.

Check the appropriate authorization catalog tables to verify that the AuthID possesses the privilege to be revoked. Correct and reissue the REVOKE statement.

Parent topic: X350 - X399


X378: Attempt to disable login with security off.

Enable security using the XDB Server Configuration utility, then disable the login.

Parent topic: X350 - X399


X379: The login was rejected due to logins being disabled.

Contact your database administrator for assistance.

Parent topic: X350 - X399


X380: The XDB Server has rejected this connection due to load balance requirements.

Contact your database administrator for assistance.

Parent topic: X350 - X399


X381: Cannot connect with requested location. Location is offline.

Try connecting to the location at a later time. If this error persists, contact your database administrator for assistance.

Parent topic: X350 - X399


X382: Cannot take requested location offline. Location is in use.

Wait until the active users finish processing then take the location offline (You may want to use the DISABLE LOGIN command to prevent new users from logging on to the server). If you need to take the location offline immediately, you can force the active users off the location using the Monitor utility.

Parent topic: X350 - X399


X383: Sequence error for reason code (ReasonCode) Message.

If ReasonCode/Message is... The problem is that...
(1) Performed connection operation while not logged in. The XDB Server received a database request from a client program that has not yet connected or has already disconnected from the database. Often this problem is caused by faulty logic in a user program.

Check the code in your program to ensure that all connect/disconnect sequences occur in the correct order. For example...

  • Make sure that your program checks for SQLConnect failures, and that it doesn't continue to issue requests to the server when a connection failure occurs.
  • If it is a JDBC program, check that it does not call any other method in the connection class after calling the close( ) method. close( ) must be the last method called by a database transaction.
  • If it is an ODBC program, check that it does not use a connection handle before it calls SQLConnect( ) or after it calls SQLDisconnect( ).
Parent topic: X350 - X399


X384: Invalid handle.

Do the following:

  • Record the version of the XDB Server software.
  • Note whether you are using JDBC or ODBC software and record which version you are using.
  • Make a note of the operation that failed.
  • Contact Micro Focus Technical Support.
Parent topic: X350 - X399


X385: Login error with Reason Code ReasonCode Message (returned Number).

If ReasonCode/Message is... | The problem is that...
1 Get Receipt Failed | The internal call to Xdbxgetrcpt( ) failed because of a Number error. See error Number for additional information and corrective action.
2 Profile Query Failed The query of SYSPROFILES failed during execution of Xdbxcommand.

Do the following:

  • Check for problems with the SYSXDB.SYSPROFILES table in the system location (confirm, for example, that it was created and hasn't been dropped).
  • Check that you have correctly specified the values for the SYSTEM location and for the SYSPROFILES authid in the URL and/or the Properties Object passed to DriverManager.getConnection.
  • Verify that you have privileges to access SYSXDB.SYSPROFILES.

See also error Number for additional information and corrective action.

If you cannot resolve the problem, contact Micro Focus Technical Support and provide them with the following information:

  • The versions of client and server software you are using.
  • The JDBC URL you have specified
  • Properties you have set in the Properties Object
3 Set Status Failed | The internal call to Xdbxstatus( ) failed because of a Number error. See error Number for additional information and corrective action.
5 System Open Failed | The internal call to Xdbxopen( ) failed because of a Number error. See error Number for additional information and corrective action.
6 Profile Fetch Failed The fetch from SYSXDB.SYSPROFILES failed during execution of Xdbxfetch.

Do the following:

  • Check for problems with the SYSXDB.SYSPROFILES table in the system location (corrupt records, for example).
  • Verify that you have privileges to access SYSXDB.SYSPROFILES.

See also error Number for additional information and corrective action.

If you cannot resolve the problem, contact Micro Focus Technical Support and provide them with the following information:

  • The versions of client and server software you are using.
  • The JDBC URL you have specified
  • The properties you have set in the Properties Object
7 Initialize Autocommit Failed | The internal call to turn on autocommit failed because of a Number error. See error Number for additional information and corrective action.
9 Close Failed | The internal call to Xdbxclose( ) failed because of a Number error. See error Number for additional information and corrective action.
10 Open Initial Location Failed The internal call to open the primary location (as specified by the location property) failed.
  • Check that a record exists in SYSXDB.SYSPROFILES for the profile name and location you are attempting to use.
  • Check that you have specified the location correctly in the URL or in the Properties Object (jet.dfjdbc.profile.location).

See error Number for additional information and corrective action.
14 Set Package Set Failed The internal call to set the Package Set Id (as specified by the packageset property) failed.
  • Check that a record exists in SYSXDB.SYSPROFILES for the profile name and package set you are attempting to use.
  • Check that you have specified the package set correctly in the URL or in the Properties Object (jet.dfjdbc.profile.packageset). See Getting Started with JetExpress for more information about the Properties Object

See error Number for additional information and corrective action.
Parent topic: X350 - X399


X386: Conflicting definitions for the same variable or parameter. Description

If this error occurs in a stored procedure, check that the parameters passed to the XDB Server match the procedure's parameter definitions in SYSIBM.SYSPROCEDURES. If this error occurs in an SQL statement, check that the variables it passes to the XDB Server match the data type the XDB Server expects.

Parent topic: X350 - X399


X392: Your SQL Option (for DB2 emulation) has expired.

Contact Micro Focus Technical Support.

Parent topic: X350 - X399


X393: Output host variable PositionNumber is incompatible with the query result.

Check your source code to ensure that it is writing its results to the correct output variable and that the data type of that variable is compatible with the expected result.

Parent topic: X350 - X399


X394: Input host variable PositionNumber is incompatible with the current query.

Check your source code to ensure that your SELECT statement specifies the correct host variable and that this variable's data type is compatible with database field with it is being used.

Parent topic: X350 - X399


X395: Value for data type Type is out of range for host variable PositionNumber.

Check your source code to ensure that it specifies the correct host variable for this result and that the data type of this variable is large enough to hold the value produced by the database.

Parent topic: X350 - X399


X396 ColumnName is not a column of specified table or view in the query.

Parent topic: X350 - X399


X397 Decimal host variable or parameter Identifier contains non-decimal data.

Parent topic: X350 - X399


X398 ColumnName is not an updateable column; it is not identified in the update clause.

Parent topic: X350 - X399


X399 Improper use of long string data, StringValue.

Parent topic: X350 - X399


X400 Named cursor already assigned to a result set locator.

Parent topic: X400 - X449


X401 Statement can't be issued until the stored procedure has been called.

Parent topic: X400 - X449


X402 Invalid result set locator.

Parent topic: X400 - X449


X403 Cursor name CursorName was not defined.

Parent topic: X400 - X449


X404 A Rollback is required.

Parent topic: X400 - X449


X405 An ON clause in a JOIN operator is invalid.

Parent topic: X400 - X449


X406 Stored procedure StoredProcName parameter ParameterName is larger than declared.

Parent topic: X400 - X449


X407 Stored procedure StoredProcName requires a host variable for parameter ParameterName.

Parent topic: X400 - X449


X408 Stored procedure StoredProcName did not return result sets.

Parent topic: X400 - X449


X387: Option conflict with location rules

Parent topic: X350 - X399


X388: Invalid token 'token' found in PARMLIST for procedure proc-name

Parent topic: X350 - X399


X389: Illegal operation on temporary table

Parent topic: X350 - X399


X390: Check option not allowed on temporary table

Parent topic: X350 - X399


X391: WITH DEFAULT clause not allowed on CREATE GLOBAL TEMPORARY TABLE

Parent topic: X350 - X399


X409: Error in trigger trigger-name, section number trigger-section

Parent topic: X400 - X449


X410: Function function-name named without signature, function not unique

Parent topic: X400 - X449


X411: Signature for function function-name not unique within schema

Parent topic: X400 - X449


X412: Set transition variable is used for before trigger per row only

Parent topic: X400 - X449


X413: Invalid insert into column %s defined as generated always

Parent topic: X400 - X449


X414: Internal error, identity column definition not found

Parent topic: X400 - X449


X036: Default specification for field name is invalid.

Contact Micro Focus Technical Support.

Parent topic: X000 - X049


X415: Only one rowid or identity column is allowed in a table

Parent topic: X400 - X449